接口 javax.swing.event.ListDataListener 的使用 (Java Platform SE 6)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个 下一个 框架 无框架

接口 javax.swing.event.ListDataListener
的使用

使用 ListDataListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 ListDataListener 的使用

实现 ListDataListener 的 javax.swing 中的类
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。

返回 ListDataListener 的 javax.swing 中的方法
 ListDataListener[] AbstractListModel.getListDataListeners()
返回已在此 AbstractListModel 上注册的所有列表数据侦听器组成的数组。

参数类型为 ListDataListener 的 javax.swing 中的方法
void | AbstractListModel.addListDataListener(ListDataListener l) 将某个侦听器添加到每次更改数据模型都要通知的列表。
void | ListModel.addListDataListener(ListDataListener l) 将一个侦听器添加到每次在数据模型发生更改时都得到通知的列表。
void | AbstractListModel.removeListDataListener(ListDataListener l) 将某个侦听器从每次更改数据模型都要通知的列表中移除。
void | ListModel.removeListDataListener(ListDataListener l) 从每次在数据模型发生更改时都得到通知的列表中移除侦听器。

javax.swing.plaf.basic 中 ListDataListener 的使用

实现 ListDataListener 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxUI.ListDataHandler 此侦听器观察 ComboBoxModel 中的更改。
class | BasicComboPopup.ListDataHandler 从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
class | BasicListUI.ListDataHandler 在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。

声明为 ListDataListener 的 javax.swing.plaf.basic 中的字段
protected ListDataListener | BasicListUI.listDataListener
protected ListDataListener | BasicComboPopup.listDataListener 此受保护字段是特定于实现的。
protected ListDataListener | BasicComboBoxUI.listDataListener 此受保护字段是特定于实现的。

返回 ListDataListener 的 javax.swing.plaf.basic 中的方法
protected ListDataListener | BasicListUI.createListDataListener() 创建在需要时由模型添加到 JList 的 ListDataListener 的实例。
protected ListDataListener | BasicComboPopup.createListDataListener() 创建将添加到 ComboBoxModel 的列表数据侦听器。
protected ListDataListener | BasicComboBoxUI.createListDataListener() 创建将添加到 ComboBoxModel 的列表数据侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.swing.event.PopupMenuListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.PopupMenuListener
的使用

使用 PopupMenuListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 PopupMenuListener 的使用

返回 PopupMenuListener 的 javax.swing 中的方法
 PopupMenuListener[] JComboBox.getPopupMenuListeners()
返回利用 addPopupMenuListener() 添加到此 JComboBox 的所有 PopupMenuListener 组成的数组。
 PopupMenuListener[] JPopupMenu.getPopupMenuListeners()
返回利用 addPopupMenuListener() 添加到此 JMenuItem 的所有 PopupMenuListener 组成的数组。

参数类型为 PopupMenuListener 的 javax.swing 中的方法
void | JComboBox.addPopupMenuListener(PopupMenuListener l) 添加 PopupMenu 侦听器，该侦听器将侦听取自组合框弹出部分的通知消息。
void | JPopupMenu.addPopupMenuListener(PopupMenuListener l) 添加 PopupMenu 侦听器。
void | JComboBox.removePopupMenuListener(PopupMenuListener l) 移除 PopupMenuListener。
void | JPopupMenu.removePopupMenuListener(PopupMenuListener l) 移除 PopupMenu 侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.event.ChangeEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.ChangeEvent
的使用

使用 ChangeEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 ChangeEvent 的使用

声明为 ChangeEvent 的 javax.swing 中的字段
protected ChangeEvent | JSlider.changeEvent 一个滑块实例仅需要一个 ChangeEvent，因为该事件唯一（只读）的状态是源属性。
protected ChangeEvent | AbstractCellEditor.changeEvent
protected ChangeEvent | JProgressBar.changeEvent 每个实例只需要一个 ChangeEvent，因为事件的唯一感兴趣属性是不可变源，即进度条。
protected ChangeEvent | JTabbedPane.changeEvent 由于事件仅有的（只读）状态是源属性，因此每个 TabPane 实例只需要一个 ChangeEvent。
protected ChangeEvent | DefaultBoundedRangeModel.changeEvent 由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。
protected ChangeEvent | MenuSelectionManager.changeEvent 每个按钮模型实例只需要一个 ChangeEvent，因为事件的惟一状态是 source 属性。
protected ChangeEvent | DefaultSingleSelectionModel.changeEvent
protected ChangeEvent | DefaultButtonModel.changeEvent 每个按钮模型实例只需要一个 ChangeEvent，因为事件的唯一状态是源属性。
protected ChangeEvent | AbstractButton.changeEvent 每个按钮实例都只需要一个 ChangeEvent，因为事件的唯一状态是源属性。

参数类型为 ChangeEvent 的 javax.swing 中的方法
void | JTable.columnMarginChanged(ChangeEvent e) 当列由于间距的更改而被移动时调用。
void | JTable.AccessibleJTable.columnMarginChanged(ChangeEvent e) 跟踪由于空白变更而引起的列移动的变更。
void | JTable.editingCanceled(ChangeEvent e) 编辑取消时调用。
void | JTable.AccessibleJTable.editingCanceled(ChangeEvent e) 编辑取消时调用。
void | JTable.editingStopped(ChangeEvent e) 编辑结束时调用。
void | JTable.AccessibleJTable.editingStopped(ChangeEvent e) 跟踪单元格内容的变更。
void | JSpinner.DefaultEditor.stateChanged(ChangeEvent e) 当 spinner 的模型状态更改时调用此方法。
void | JSpinner.AccessibleJSpinner.stateChanged(ChangeEvent e) 侦听器的目标已更改其状态时调用。
void | ProgressMonitor.AccessibleProgressMonitor.stateChanged(ChangeEvent e) 在侦听器的目标已更改其状态时调用。
void | JTabbedPane.ModelListener.stateChanged(ChangeEvent e)
void | JTabbedPane.AccessibleJTabbedPane.stateChanged(ChangeEvent e)
void | JScrollPane.AccessibleJScrollPane.stateChanged(ChangeEvent e) 当侦听器目标的状态改变时，此方法被调用。
void | JMenuItem.AccessibleJMenuItem.stateChanged(ChangeEvent e) 支持更改侦听器接口并激发属性更改。
void | AbstractButton.ButtonChangeListener.stateChanged(ChangeEvent e)

javax.swing.colorchooser 中 ChangeEvent 的使用

声明为 ChangeEvent 的 javax.swing.colorchooser 中的字段
protected  ChangeEvent DefaultColorSelectionModel.changeEvent
由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。

javax.swing.event 中 ChangeEvent 的使用

参数类型为 ChangeEvent 的 javax.swing.event 中的方法
void | TableColumnModelListener.columnMarginChanged(ChangeEvent e) 告知侦听器因为页边空白更改，有一列被移除。
void | CellEditorListener.editingCanceled(ChangeEvent e) 此方法告知侦听器编辑器已经取消编辑
void | CellEditorListener.editingStopped(ChangeEvent e) 此方法告知侦听器编辑器已经结束编辑
void | ChangeListener.stateChanged(ChangeEvent e) 当侦听器的目标已更改其状态时调用。

javax.swing.plaf.basic 中 ChangeEvent 的使用

参数类型为 ChangeEvent 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.CellEditorHandler.editingCanceled(ChangeEvent e) 在树中取消编辑时传递消息。
void | BasicTreeUI.CellEditorHandler.editingStopped(ChangeEvent e) 在树中停止编辑时传递消息。
void | BasicSliderUI.ChangeHandler.stateChanged(ChangeEvent e)
void | BasicProgressBarUI.ChangeHandler.stateChanged(ChangeEvent e)
void | BasicTabbedPaneUI.TabSelectionHandler.stateChanged(ChangeEvent e)
void | BasicScrollPaneUI.ViewportChangeHandler.stateChanged(ChangeEvent e)
void | BasicScrollPaneUI.HSBChangeListener.stateChanged(ChangeEvent e)
void | BasicScrollPaneUI.VSBChangeListener.stateChanged(ChangeEvent e)
void | BasicScrollBarUI.ModelListener.stateChanged(ChangeEvent e)
void | BasicMenuUI.ChangeHandler.stateChanged(ChangeEvent e)
void | BasicButtonListener.stateChanged(ChangeEvent e)

javax.swing.table 中 ChangeEvent 的使用

声明为 ChangeEvent 的 javax.swing.table 中的字段
protected  ChangeEvent DefaultTableColumnModel.changeEvent
更改事件（只需要一个）

参数类型为 ChangeEvent 的 javax.swing.table 中的方法
 void JTableHeader.columnMarginChanged(ChangeEvent e)
当列由于间距改变而被移动时调用。

javax.swing.text 中 ChangeEvent 的使用

声明为 ChangeEvent 的 javax.swing.text 中的字段
protected ChangeEvent | DefaultCaret.changeEvent 此模型的更改事件。
protected ChangeEvent | StyleContext.NamedStyle.changeEvent 由于事件的惟一状态（只读）为源属性，因此每个模型实例只需要一个 ChangeEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.MouseInputListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.MouseInputListener
的使用

使用 MouseInputListener 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.event 中 MouseInputListener 的使用

实现 MouseInputListener 的 javax.swing.event 中的类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseInputListener 的使用

实现 MouseInputListener 的 javax.swing.plaf.basic 中的类
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
protected class | BasicMenuItemUI.MouseInputHandler
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
class | BasicTableHeaderUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。

声明为 MouseInputListener 的 javax.swing.plaf.basic 中的字段
protected MouseInputListener | BasicToolBarUI.dockingListener
protected MouseInputListener | BasicInternalFrameUI.glassPaneDispatcher
protected MouseInputListener | BasicTableUI.mouseInputListener
protected MouseInputListener | BasicTableHeaderUI.mouseInputListener
protected MouseInputListener | BasicListUI.mouseInputListener
protected MouseInputListener | BasicMenuItemUI.mouseInputListener

返回 MouseInputListener 的 javax.swing.plaf.basic 中的方法
protected MouseInputListener | BasicToolBarUI.createDockingListener()
protected MouseInputListener | BasicInternalFrameUI.createGlassPaneDispatcher()
protected MouseInputListener | BasicDesktopIconUI.createMouseInputListener()
protected MouseInputListener | BasicTableUI.createMouseInputListener() 创建 JTable 的鼠标侦听器。
protected MouseInputListener | BasicTableHeaderUI.createMouseInputListener() 创建 JTableHeader 的鼠标侦听器。
protected MouseInputListener | BasicListUI.createMouseInputListener() 创建实现 MouseInputListener 的委托。
protected MouseInputListener | BasicMenuUI.createMouseInputListener(JComponent c)
protected MouseInputListener | BasicMenuItemUI.createMouseInputListener(JComponent c)

javax.swing.plaf.metal 中 MouseInputListener 的使用

实现 MouseInputListener 的 javax.swing.plaf.metal 中的类
protected  class MetalToolBarUI.MetalDockingListener

返回 MouseInputListener 的 javax.swing.plaf.metal 中的方法
protected  MouseInputListener MetalToolBarUI.createDockingListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.MenuDragMouseListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.MenuDragMouseListener
的使用

使用 MenuDragMouseListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 MenuDragMouseListener 的使用

返回 MenuDragMouseListener 的 javax.swing 中的方法
 MenuDragMouseListener[] JMenuItem.getMenuDragMouseListeners()
返回利用 addMenuDragMouseListener() 添加到此 JMenuItem 的所有 MenuDragMouseListener 组成的数组。

参数类型为 MenuDragMouseListener 的 javax.swing 中的方法
void | JMenuItem.addMenuDragMouseListener(MenuDragMouseListener l) 将 MenuDragMouseListener 添加到菜单项。
void | JMenuItem.removeMenuDragMouseListener(MenuDragMouseListener l) 从菜单项中移除 MenuDragMouseListener。

javax.swing.plaf.basic 中 MenuDragMouseListener 的使用

声明为 MenuDragMouseListener 的 javax.swing.plaf.basic 中的字段
protected  MenuDragMouseListener BasicMenuItemUI.menuDragMouseListener

返回 MenuDragMouseListener 的 javax.swing.plaf.basic 中的方法
protected MenuDragMouseListener | BasicMenuUI.createMenuDragMouseListener(JComponent c)
protected MenuDragMouseListener | BasicMenuItemUI.createMenuDragMouseListener(JComponent c)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.MenuKeyListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.MenuKeyListener
的使用

使用 MenuKeyListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 MenuKeyListener 的使用

返回 MenuKeyListener 的 javax.swing 中的方法
 MenuKeyListener[] JPopupMenu.getMenuKeyListeners()
返回利用 addMenuKeyListener() 添加到此 JPopupMenu 的所有 MenuKeyListener 组成的数组。
 MenuKeyListener[] JMenuItem.getMenuKeyListeners()
返回利用 addMenuKeyListener() 添加到此 JMenuItem 的所有 MenuKeyListener 的数组。

参数类型为 MenuKeyListener 的 javax.swing 中的方法
void | JPopupMenu.addMenuKeyListener(MenuKeyListener l) 将 MenuKeyListener 添加到弹出菜单。
void | JMenuItem.addMenuKeyListener(MenuKeyListener l) 将 MenuKeyListener 添加到菜单项。
void | JPopupMenu.removeMenuKeyListener(MenuKeyListener l) 从弹出菜单移除 MenuKeyListener。
void | JMenuItem.removeMenuKeyListener(MenuKeyListener l) 从菜单项中移除 MenuKeyListener。

javax.swing.plaf.basic 中 MenuKeyListener 的使用

声明为 MenuKeyListener 的 javax.swing.plaf.basic 中的字段
protected  MenuKeyListener BasicMenuItemUI.menuKeyListener

返回 MenuKeyListener 的 javax.swing.plaf.basic 中的方法
protected MenuKeyListener | BasicMenuUI.createMenuKeyListener(JComponent c)
protected MenuKeyListener | BasicMenuItemUI.createMenuKeyListener(JComponent c)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.event.MenuEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.MenuEvent
的使用

使用 MenuEvent 的软件包
javax.swing.event 供 Swing 组件触发的事件使用。

javax.swing.event 中 MenuEvent 的使用

参数类型为 MenuEvent 的 javax.swing.event 中的方法
void | MenuListener.menuCanceled(MenuEvent e) 取消菜单时调用。
void | MenuListener.menuDeselected(MenuEvent e) 取消选择某个菜单时调用。
void | MenuListener.menuSelected(MenuEvent e) 选择某个菜单时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.AncestorListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.AncestorListener
的使用

使用 AncestorListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AncestorListener 的使用

返回 AncestorListener 的 javax.swing 中的方法
 AncestorListener[] JComponent.getAncestorListeners()
返回在此组件上注册的所有祖先侦听器所组成的数组。

参数类型为 AncestorListener 的 javax.swing 中的方法
void | JComponent.addAncestorListener(AncestorListener listener) 注册 listener，从而当组件或其任意祖先移动，或者变得可见或不可见时该侦听器将收到 AncestorEvent。
void | JComponent.removeAncestorListener(AncestorListener listener) 注销 listener，使其不再接收 AncestorEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.ChangeListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.ChangeListener
的使用

使用 ChangeListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 ChangeListener 的使用

实现 ChangeListener 的 javax.swing 中的类
protected class | AbstractButton.ButtonChangeListener 将 ChangeListener 扩展为可序列化的。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTabbedPane.ModelListener 将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

声明为 ChangeListener 的 javax.swing 中的字段
protected ChangeListener | JSlider.changeListener changeListener（无前缀）是添加到滑块模型的侦听器。
protected ChangeListener | JProgressBar.changeListener 侦听由进度条的模型发送的更改事件，并将其再次指派到在此进度条上注册的更改事件侦听器。
protected ChangeListener | JTabbedPane.changeListener changeListener 是添加到模型中的侦听器。
protected ChangeListener | AbstractButton.changeListener 按钮模型的 changeListener。

返回 ChangeListener 的 javax.swing 中的方法
protected  ChangeListener JSlider.createChangeListener()
想要以不同方式处理模型的 ChangeEvent 的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
protected  ChangeListener JProgressBar.createChangeListener()
要以不同方式处理来自模型的更改事件的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
protected  ChangeListener JTabbedPane.createChangeListener()
要对 ChangeEvents 进行不同处理的子类可以重写它，从而返回 ModelListener 的一个子类，或者返回另一个 ChangeListener 实现。
protected  ChangeListener AbstractButton.createChangeListener()
想以不同的方式处理 ChangeEvent 的子类可以重写此方法，以返回另一个 ChangeListener 实现。
 ChangeListener[] AbstractSpinnerModel.getChangeListeners()
返回使用 addChangeListener() 添加到此 AbstractSpinnerModel 中的所有 ChangeListener 组成的数组。
 ChangeListener[] JSpinner.getChangeListeners()
返回一个通过 addChangeListener() 方法添加到此 JSpinner 的所有 ChangeListener 的数组。
 ChangeListener[] JSlider.getChangeListeners()
返回一个通过 addChangeListener() 方法添加此 JSlider 的所有 ChangeListener 的数组。
 ChangeListener[] JProgressBar.getChangeListeners()
返回通过 addChangeListener 添加到此进度条的所有 ChangeListener 组成的数组。
 ChangeListener[] JTabbedPane.getChangeListeners()
返回通过 addChangeListener 方法添加到此 JTabbedPane 中的所有 ChangeListener 的数组。
 ChangeListener[] JViewport.getChangeListeners()
返回使用 addChangeListener() 添加到此 JViewport 的所有 ChangeListener 的数组。
 ChangeListener[] DefaultBoundedRangeModel.getChangeListeners()
返回此 DefaultBoundedRangeModel 上所有已注册的更改侦听器组成的数组。
 ChangeListener[] MenuSelectionManager.getChangeListeners()
返回使用 addChangeListener() 添加到此 MenuSelectionManager 的所有 ChangeListener 的数组。
 ChangeListener[] DefaultSingleSelectionModel.getChangeListeners()
返回此 DefaultSingleSelectionModel 上所有已注册的更改侦听器组成的数组。
 ChangeListener[] DefaultButtonModel.getChangeListeners()
返回此 DefaultButtonModel 上所有已注册的更改侦听器组成的数组。
 ChangeListener[] AbstractButton.getChangeListeners()
返回使用 addChangeListener() 添加到此 AbstractButton 中的所有 ChangeListener 组成的数组。

参数类型为 ChangeListener 的 javax.swing 中的方法
void | AbstractSpinnerModel.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到模型的侦听器列表中。
void | JSpinner.addChangeListener(ChangeListener listener) 为每次发生模型更改时要通知的列表添加侦听器。
void | SpinnerModel.addChangeListener(ChangeListener l) 向该模型的侦听器列表添加一个 ChangeListener。
void | JSlider.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到滑块。
void | JProgressBar.addChangeListener(ChangeListener l) 将指定的 ChangeListener 添加到进度条。
void | JTabbedPane.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到此选项卡窗格中。
void | JViewport.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表。
void | DefaultBoundedRangeModel.addChangeListener(ChangeListener l) 添加一个 ChangeListener。
void | BoundedRangeModel.addChangeListener(ChangeListener x) 将一个 ChangeListener 添加到模型的侦听器列表中。
void | MenuSelectionManager.addChangeListener(ChangeListener l) 向按钮添加 ChangeListener。
void | DefaultSingleSelectionModel.addChangeListener(ChangeListener l) 向按钮添加一个 ChangeListener。
void | SingleSelectionModel.addChangeListener(ChangeListener listener) 在模型中添加作为更改侦听侦听器的 listener。
void | DefaultButtonModel.addChangeListener(ChangeListener l) 向模型添加一个 ChangeListener。
void | ButtonModel.addChangeListener(ChangeListener l) 向模型添加一个 ChangeListener。
void | AbstractButton.addChangeListener(ChangeListener l) 向按钮添加一个 ChangeListener。
void | AbstractSpinnerModel.removeChangeListener(ChangeListener l) 从模型的侦听器列表中移除一个 ChangeListener。
void | JSpinner.removeChangeListener(ChangeListener listener) 从此 spinne 中移除 ChangeListener。
void | SpinnerModel.removeChangeListener(ChangeListener l) 从该模型的侦听器列表移除一个 ChangeListener。
void | JSlider.removeChangeListener(ChangeListener l) 从滑块中移除一个 ChangeListener。
void | JProgressBar.removeChangeListener(ChangeListener l) 从进度条移除 ChangeListener。
void | JTabbedPane.removeChangeListener(ChangeListener l) 从此选项卡窗格中移除一个 ChangeListener。
void | JViewport.removeChangeListener(ChangeListener l) 从每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表中移除 ChangeListener。
void | DefaultBoundedRangeModel.removeChangeListener(ChangeListener l) 移除一个 ChangeListener。
void | BoundedRangeModel.removeChangeListener(ChangeListener x) 从模型的侦听器列表中移除一个 ChangeListener。
void | MenuSelectionManager.removeChangeListener(ChangeListener l) 从按钮中移除 ChangeListener。
void | DefaultSingleSelectionModel.removeChangeListener(ChangeListener l) 从按钮中移除一个 ChangeListener。
void | SingleSelectionModel.removeChangeListener(ChangeListener listener) 从模型中移除作为更改侦听器的 listener。
void | DefaultButtonModel.removeChangeListener(ChangeListener l) 从模型中移除一个 ChangeListener。
void | ButtonModel.removeChangeListener(ChangeListener l) 从模型中移除一个 ChangeListener。
void | AbstractButton.removeChangeListener(ChangeListener l) 从按钮中移除一个 ChangeListener。

javax.swing.colorchooser 中 ChangeListener 的使用

返回 ChangeListener 的 javax.swing.colorchooser 中的方法
 ChangeListener[] DefaultColorSelectionModel.getChangeListeners()
返回一个使用 addChangeListener 添加到此 DefaultColorSelectionModel 中的所有 ChangeListener 的数组。

参数类型为 ChangeListener 的 javax.swing.colorchooser 中的方法
void | ColorSelectionModel.addChangeListener(ChangeListener listener) 在模型中添加作为更改侦听器的 listener。
void | DefaultColorSelectionModel.addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到模型中。
void | ColorSelectionModel.removeChangeListener(ChangeListener listener) 从模型中移除作为更改侦听器的 listener。
void | DefaultColorSelectionModel.removeChangeListener(ChangeListener l) 从模型中移除一个 ChangeListener。

javax.swing.plaf.basic 中 ChangeListener 的使用

实现 ChangeListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
class | BasicMenuUI.ChangeHandler 从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。
class | BasicProgressBarUI.ChangeHandler 此内部类因编译器故障而被标记为“公开”。
protected class | BasicScrollBarUI.ModelListener 侦听模型更改的侦听器。
class | BasicScrollPaneUI.HSBChangeListener 水平滚动条侦听器。
class | BasicScrollPaneUI.ViewportChangeHandler 视口事件的侦听器。
class | BasicScrollPaneUI.VSBChangeListener 垂直滚动条侦听器。
class | BasicSliderUI.ChangeHandler 数据模型侦听器。
class | BasicTabbedPaneUI.TabSelectionHandler 此类应视为“受保护”内部类。

声明为 ChangeListener 的 javax.swing.plaf.basic 中的字段
protected ChangeListener | BasicSliderUI.changeListener
protected ChangeListener | BasicProgressBarUI.changeListener
protected ChangeListener | BasicMenuUI.changeListener
protected ChangeListener | BasicMenuBarUI.changeListener
protected ChangeListener | BasicScrollPaneUI.hsbChangeListener
protected ChangeListener | BasicColorChooserUI.previewListener
protected ChangeListener | BasicTabbedPaneUI.tabChangeListener
protected ChangeListener | BasicScrollPaneUI.viewportChangeListener
protected ChangeListener | BasicScrollPaneUI.vsbChangeListener

返回 ChangeListener 的 javax.swing.plaf.basic 中的方法
protected ChangeListener | BasicTabbedPaneUI.createChangeListener()
protected ChangeListener | BasicMenuBarUI.createChangeListener()
protected ChangeListener | BasicMenuUI.createChangeListener(JComponent c)
protected ChangeListener | BasicSliderUI.createChangeListener(JSlider slider)
protected ChangeListener | BasicScrollPaneUI.createHSBChangeListener()
protected ChangeListener | BasicScrollPaneUI.createViewportChangeListener()
protected ChangeListener | BasicScrollPaneUI.createVSBChangeListener()

javax.swing.text 中 ChangeListener 的使用

返回 ChangeListener 的 javax.swing.text 中的方法
 ChangeListener[] DefaultCaret.getChangeListeners()
返回此插入符上所有已注册的更改侦听器组成的数组。
 ChangeListener[] StyleContext.getChangeListeners()
返回使用 addChangeListener() 添加到此 StyleContext 中的所有 ChangeListener 组成的数组。
 ChangeListener[] StyleContext.NamedStyle.getChangeListeners()
返回使用 addChangeListener() 添加到此 NamedStyle 中的所有 ChangeListener 组成的数组。

参数类型为 ChangeListener 的 javax.swing.text 中的方法
void | DefaultCaret.addChangeListener(ChangeListener l) 添加一个侦听器，以便对插入符位置改变进行跟踪。
void | Caret.addChangeListener(ChangeListener l) 添加作为跟踪任何插入符位置更改的侦听器。
void | Style.addChangeListener(ChangeListener l) 添加一个侦听器，以便随时跟踪属性的更改。
void | StyleContext.addChangeListener(ChangeListener l) 添加一个侦听器，以跟踪何时添加或删除样式。
void | StyleContext.NamedStyle.addChangeListener(ChangeListener l) 添加更改侦听器。
void | DefaultCaret.removeChangeListener(ChangeListener l) 移除跟踪位置更改的侦听器。
void | Caret.removeChangeListener(ChangeListener l) 移除跟踪插入符位置更改的侦听器。
void | Style.removeChangeListener(ChangeListener l) 移除跟踪属性更改的侦听器。
void | StyleContext.removeChangeListener(ChangeListener l) 移除一个跟踪正被添加或移除样式的侦听器。
void | StyleContext.NamedStyle.removeChangeListener(ChangeListener l) 移除更改侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.CaretListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.CaretListener
的使用

使用 CaretListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 CaretListener 的使用

实现 CaretListener 的 javax.swing 中的类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

javax.swing.text 中 CaretListener 的使用

实现 CaretListener 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 CaretListener 的 javax.swing.text 中的方法
 CaretListener[] JTextComponent.getCaretListeners()
返回在此文本组件上已注册的所有插入符侦听器的数组。

参数类型为 CaretListener 的 javax.swing.text 中的方法
void | JTextComponent.addCaretListener(CaretListener listener) 添加插入符侦听器，以便侦听任何插入符的更改通知。
void | JTextComponent.removeCaretListener(CaretListener listener) 移除插入符侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.MenuListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.MenuListener
的使用

使用 MenuListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 MenuListener 的使用

返回 MenuListener 的 javax.swing 中的方法
 MenuListener[] JMenu.getMenuListeners()
返回利用 addMenuListener() 添加到此 JMenu 的所有 MenuListener 组成的数组。

参数类型为 MenuListener 的 javax.swing 中的方法
void | JMenu.addMenuListener(MenuListener l) 添加菜单事件的侦听器。
void | JMenu.removeMenuListener(MenuListener l) 移除菜单事件的侦听器。

javax.swing.plaf.basic 中 MenuListener 的使用

声明为 MenuListener 的 javax.swing.plaf.basic 中的字段
protected  MenuListener BasicMenuUI.menuListener

返回 MenuListener 的 javax.swing.plaf.basic 中的方法
protected  MenuListener BasicMenuUI.createMenuListener(JComponent c)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.event.UndoableEditEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.UndoableEditEvent
的使用

使用 UndoableEditEvent 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.event 中 UndoableEditEvent 的使用

参数类型为 UndoableEditEvent 的 javax.swing.event 中的方法
 void UndoableEditListener.undoableEditHappened(UndoableEditEvent e)
发生了可撤消的编辑操作

javax.swing.text 中 UndoableEditEvent 的使用

参数类型为 UndoableEditEvent 的 javax.swing.text 中的方法
protected  void AbstractDocument.fireUndoableEditUpdate(UndoableEditEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。

javax.swing.text.html 中 UndoableEditEvent 的使用

参数类型为 UndoableEditEvent 的 javax.swing.text.html 中的方法
protected  void HTMLDocument.fireUndoableEditUpdate(UndoableEditEvent e)
通知所有需要此事件类型的通知的已注册侦听器。

javax.swing.undo 中 UndoableEditEvent 的使用

参数类型为 UndoableEditEvent 的 javax.swing.undo 中的方法
 void UndoManager.undoableEditHappened(UndoableEditEvent e)
一个 UndoableEditListener 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.DocumentEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.DocumentEvent
的使用

使用 DocumentEvent 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 DocumentEvent 的使用

参数类型为 DocumentEvent 的 javax.swing.event 中的方法
void | DocumentListener.changedUpdate(DocumentEvent e) 给出属性或属性集发生了更改的通知。
void | DocumentListener.insertUpdate(DocumentEvent e) 给出对文档执行了插入操作的通知。
void | DocumentListener.removeUpdate(DocumentEvent e) 给出移除了一部分文档的通知。

javax.swing.text 中 DocumentEvent 的使用

实现 DocumentEvent 的 javax.swing.text 中的类
 class AbstractDocument.DefaultDocumentEvent
存储修改文档时发生的文档更改。

参数类型为 DocumentEvent 的 javax.swing.text 中的方法
void | JTextComponent.AccessibleJTextComponent.changedUpdate(DocumentEvent e) 处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | FlowView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | GlyphView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | LabelView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | ParagraphView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | WrappedPlainView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出文档中此视图负责的位置上的属性已发生更改的通知。
void | PlainView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | View.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | FlowView.FlowStrategy.changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected void | AbstractDocument.fireChangedUpdate(DocumentEvent e) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected void | AbstractDocument.fireInsertUpdate(DocumentEvent e) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected void | AbstractDocument.fireRemoveUpdate(DocumentEvent e) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected void | BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
protected void | View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected void | View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
void | JTextComponent.AccessibleJTextComponent.insertUpdate(DocumentEvent e) 处理文档插入（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | FlowView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | GlyphView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | WrappedPlainView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出在文档中此视图负责的位置插入了某些内容的通知。
void | ZoneView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出在文档中此视图负责的位置插入了某些内容的通知。
void | FieldView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | View.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | FlowView.FlowStrategy.insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | JTextComponent.AccessibleJTextComponent.removeUpdate(DocumentEvent e) 处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | FlowView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知从文档中此视图负责的某个位置已移除内容。
void | GlyphView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
void | WrappedPlainView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出从文档中此视图负责的位置移除了某些内容的通知。
void | ZoneView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | FieldView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | View.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | FlowView.FlowStrategy.removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。
protected boolean | ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
protected boolean | View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
protected void | PlainView.updateDamage(DocumentEvent changes, Shape a, ViewFactory f) 重新绘制给定文档事件覆盖的更改区域。
protected void | AsyncBoxView.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接收的更改通知。
protected void | View.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接受的更改通知。

javax.swing.text.html 中 DocumentEvent 的使用

参数类型为 DocumentEvent 的 javax.swing.text.html 中的方法
void | BlockView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
void | ImageView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 当 Elements 属性已更改时调用。
void | InlineView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
protected void | HTMLDocument.fireChangedUpdate(DocumentEvent e) 通知所有需要此事件类型的通知的已注册侦听器。
void | InlineView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | InlineView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.event.DocumentEvent.EventType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.DocumentEvent.EventType
的使用

使用 DocumentEvent.EventType 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 DocumentEvent.EventType 的使用

声明为 DocumentEvent.EventType 的 javax.swing.event 中的字段
static DocumentEvent.EventType | DocumentEvent.EventType.CHANGE 更改类型。
static DocumentEvent.EventType | DocumentEvent.EventType.INSERT 插入类型。
static DocumentEvent.EventType | DocumentEvent.EventType.REMOVE 移除类型。

返回 DocumentEvent.EventType 的 javax.swing.event 中的方法
 DocumentEvent.EventType DocumentEvent.getType()
获得事件类型。

javax.swing.text 中 DocumentEvent.EventType 的使用

返回 DocumentEvent.EventType 的 javax.swing.text 中的方法
 DocumentEvent.EventType AbstractDocument.DefaultDocumentEvent.getType()
返回事件的类型。

参数类型为 DocumentEvent.EventType 的 javax.swing.text 中的构造方法
AbstractDocument.DefaultDocumentEvent(int offs, int len, DocumentEvent.EventType type)
构造更改记录。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.event.DocumentEvent.ElementChange 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.DocumentEvent.ElementChange
的使用

使用 DocumentEvent.ElementChange 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 DocumentEvent.ElementChange 的使用

返回 DocumentEvent.ElementChange 的 javax.swing.event 中的方法
 DocumentEvent.ElementChange DocumentEvent.getChange(Element elem)
获得给定元素的更改信息。

javax.swing.text 中 DocumentEvent.ElementChange 的使用

实现 DocumentEvent.ElementChange 的 javax.swing.text 中的类
static class AbstractDocument.ElementEdit
一个 ElementChange 实现，可将其添加到文档事件中。

返回 DocumentEvent.ElementChange 的 javax.swing.text 中的方法
 DocumentEvent.ElementChange AbstractDocument.DefaultDocumentEvent.getChange(Element elem)
获得元素的更改。

参数类型为 DocumentEvent.ElementChange 的 javax.swing.text 中的方法
protected void | BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
protected void | View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected boolean | ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
protected boolean | View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
protected void | AsyncBoxView.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接收的更改通知。
protected void | View.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接受的更改通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.event.EventListenerList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.EventListenerList
的使用

使用 EventListenerList 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing 中的字段
protected EventListenerList | AbstractSpinnerModel.listenerList 此模型的 ChangeListener 列表。
protected EventListenerList | AbstractCellEditor.listenerList
protected EventListenerList | DefaultListSelectionModel.listenerList
protected EventListenerList | AbstractListModel.listenerList
protected EventListenerList | DefaultBoundedRangeModel.listenerList 等待模型更改的侦听器。
protected EventListenerList | MenuSelectionManager.listenerList
protected EventListenerList | DefaultSingleSelectionModel.listenerList 已注册侦听器的集合
protected EventListenerList | DefaultButtonModel.listenerList 在此模型中存储侦听器。
protected EventListenerList | Timer.listenerList
protected EventListenerList | JComponent.listenerList 此组件的事件侦听器列表。

javax.swing.colorchooser 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing.colorchooser 中的字段
protected  EventListenerList DefaultColorSelectionModel.listenerList

javax.swing.table 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing.table 中的字段
protected EventListenerList | DefaultTableColumnModel.listenerList TableColumnModelListener 的列表
protected EventListenerList | AbstractTableModel.listenerList 侦听器的列表

javax.swing.text 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing.text 中的字段
protected EventListenerList | DefaultCaret.listenerList 事件侦听器列表。
protected EventListenerList | StyleContext.NamedStyle.listenerList 模型的更改侦听器。
protected EventListenerList | AbstractDocument.listenerList 文档的事件侦听器列表。

javax.swing.tree 中 EventListenerList 的使用

声明为 EventListenerList 的 javax.swing.tree 中的字段
protected EventListenerList | DefaultTreeModel.listenerList 侦听器。
protected EventListenerList | DefaultTreeSelectionModel.listenerList 事件侦听器列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AbstractTableModel (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 AbstractTableModel

java.lang.Object
    继承者  javax.swing.table.AbstractTableModel
所有已实现的接口：
Serializable, TableModel
直接已知子类：
DefaultTableModel
public abstract class AbstractTableModel
extends Object
implements TableModel, Serializable

此抽象类为 TableModel 接口中的大多数方法提供默认实现。它负责管理侦听器，并为生成 TableModelEvents 以及将其调度到侦听器提供方便。要创建一个具体的 TableModel 作为 AbstractTableModel 的子类，只需提供对以下三个方法的实现：

  public int getRowCount();
  public int getColumnCount();
  public Object getValueAt(int row, int column);

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected  EventListenerList listenerList
侦听器的列表
构造方法摘要
AbstractTableModel()
方法摘要
 void addTableModelListener(TableModelListener l)
每次数据模型发生更改时，就向被通知的列表添加一个侦听器。
 int findColumn(String columnName)
返回具有给定名称的列。
 void fireTableCellUpdated(int row, int column)
通知所有侦听器，已更新 [row, column] 处的单元格值。
 void fireTableChanged(TableModelEvent e)
将给定的通知事件转发到所有将自身注册为此表模型的侦听器的 TableModelListeners。
 void fireTableDataChanged()
通知所有侦听器，表的所有行单元格值可能已更改。
 void fireTableRowsDeleted(int firstRow, int lastRow)
通知所有侦听器，已删除范围在 [firstRow, lastRow]（包括）的行。
 void fireTableRowsInserted(int firstRow, int lastRow)
通知所有侦听器，已插入范围在 [firstRow, lastRow]（包括）的行。
 void fireTableRowsUpdated(int firstRow, int lastRow)
通知所有侦听器，已更新范围在 [firstRow, lastRow]（包括）的行。
 void fireTableStructureChanged()
通知所有侦听器，表的结构已更改。
 Class<?> getColumnClass(int columnIndex)
返回 Object.class 而不管 columnIndex 是多少。
 String getColumnName(int column)
返回列默认名称，其中列使用以下工作表约定：A、B、C……Z、AA、AB 等等。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。
 TableModelListener[] getTableModelListeners()
返回一个包含在此模型上注册的所有表模型侦听器的数组。
 boolean isCellEditable(int rowIndex, int columnIndex)
返回 false。
 void removeTableModelListener(TableModelListener l)
每次数据模型发生更改时，就从被通知的列表移除一个侦听器。
 void setValueAt(Object aValue, int rowIndex, int columnIndex)
由于提供了此空实现，因此，如果用户的数据模型是不可编辑的，则他们不必实现此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.table.TableModel 继承的方法
getColumnCount, getRowCount, getValueAt

字段详细信息

listenerList

protected EventListenerList listenerList
侦听器的列表

构造方法详细信息

AbstractTableModel

public AbstractTableModel()
方法详细信息

getColumnName

public String getColumnName(int column)
返回列默认名称，其中列使用以下工作表约定：A、B、C……Z、AA、AB 等等。如果无法找到 column，则返回一个空字符串。

指定者：
接口 TableModel 中的 getColumnName
参数：
column - 被查询的列
返回：
包含 column 默认名称的字符串

findColumn

public int findColumn(String columnName)
返回具有给定名称的列。由于实现是未用过的，因此，如果经常调用此方法，则应该重写此方法。此方法不在 TableModel 接口中，也不被 JTable 使用。

参数：
columnName - 包含要查找的列名称的字符串
返回：
名称为 columnName 的列，如果未找到该列，则返回 -1

getColumnClass

public Class<?> getColumnClass(int columnIndex)
返回 Object.class 而不管 columnIndex 是多少。

指定者：
接口 TableModel 中的 getColumnClass
参数：
columnIndex - 被查询的列
返回：
Object.class

isCellEditable

public boolean isCellEditable(int rowIndex,
                              int columnIndex)
返回 false。这是所有单元格的默认实现。

指定者：
接口 TableModel 中的 isCellEditable
参数：
rowIndex - 被查询的行
columnIndex - 被查询的列
返回：
false
另请参见：
TableModel.setValueAt(java.lang.Object, int, int)

setValueAt

public void setValueAt(Object aValue,
                       int rowIndex,
                       int columnIndex)
由于提供了此空实现，因此，如果用户的数据模型是不可编辑的，则他们不必实现此方法。

指定者：
接口 TableModel 中的 setValueAt
参数：
aValue - 要分配给单元格的值
rowIndex - 单元格所在行
columnIndex - 单元格所在列
另请参见：
TableModel.getValueAt(int, int), TableModel.isCellEditable(int, int)

addTableModelListener

public void addTableModelListener(TableModelListener l)
每次数据模型发生更改时，就向被通知的列表添加一个侦听器。

指定者：
接口 TableModel 中的 addTableModelListener
参数：
l - TableModelListener

removeTableModelListener

public void removeTableModelListener(TableModelListener l)
每次数据模型发生更改时，就从被通知的列表移除一个侦听器。

指定者：
接口 TableModel 中的 removeTableModelListener
参数：
l - TableModelListener

getTableModelListeners

public TableModelListener[] getTableModelListeners()
返回一个包含在此模型上注册的所有表模型侦听器的数组。

返回：
此模型的所有 TableModelListener，如果当前没有已注册的表模型侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addTableModelListener(javax.swing.event.TableModelListener), removeTableModelListener(javax.swing.event.TableModelListener)

fireTableDataChanged

public void fireTableDataChanged()
通知所有侦听器，表的所有行单元格值可能已更改。行数也可能已更改，并且 JTable 应该从头开始重新绘制该表。假定表的结构（如同列的顺序）是相同的。

另请参见：
TableModelEvent, EventListenerList, JTable.tableChanged(TableModelEvent)

fireTableStructureChanged

public void fireTableStructureChanged()
通知所有侦听器，表的结构已更改。表中的列数，新列的名称和类型可能与以前的状态不同。如果 JTable 接收此事件，并且设置了其 autoCreateColumnsFromModel 标志，则它丢弃之前具有的所有表列，并按列在模型中出现的顺序重新分配默认列。这与对 JTable 调用 setModel(TableModel) 具有相同的效果。

另请参见：
TableModelEvent, EventListenerList

fireTableRowsInserted

public void fireTableRowsInserted(int firstRow,
                                  int lastRow)
通知所有侦听器，已插入范围在 [firstRow, lastRow]（包括）的行。

参数：
firstRow - 第一行
lastRow - 最后一行
另请参见：
TableModelEvent, EventListenerList

fireTableRowsUpdated

public void fireTableRowsUpdated(int firstRow,
                                 int lastRow)
通知所有侦听器，已更新范围在 [firstRow, lastRow]（包括）的行。

参数：
firstRow - 第一行
lastRow - 最后一行
另请参见：
TableModelEvent, EventListenerList

fireTableRowsDeleted

public void fireTableRowsDeleted(int firstRow,
                                 int lastRow)
通知所有侦听器，已删除范围在 [firstRow, lastRow]（包括）的行。

参数：
firstRow - 第一行
lastRow - 最后一行
另请参见：
TableModelEvent, EventListenerList

fireTableCellUpdated

public void fireTableCellUpdated(int row,
                                 int column)
通知所有侦听器，已更新 [row, column] 处的单元格值。

参数：
row - 已更新的单元格所在行
column - 已更新的单元格所在列
另请参见：
TableModelEvent, EventListenerList

fireTableChanged

public void fireTableChanged(TableModelEvent e)
将给定的通知事件转发到所有将自身注册为此表模型的侦听器的 TableModelListeners。

参数：
e - 要转发的事件
另请参见：
addTableModelListener(javax.swing.event.TableModelListener), TableModelEvent, EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值（如 FooListener.class）来指定 listenerType 参数。例如，可以通过以下代码查询模型 m，以获得其表模型侦听器：

TableModelListener[] tmls = (TableModelListener[])(m.getListeners(TableModelListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 所请求侦听器的类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此组件上注册为 FooListener 的所有对象组成的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getTableModelListeners()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DefaultTableCellRenderer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 DefaultTableCellRenderer

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.table.DefaultTableCellRenderer
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants, TableCellRenderer
直接已知子类：
DefaultTableCellRenderer.UIResource
public class DefaultTableCellRenderer
extends JLabel
implements TableCellRenderer, Serializable

呈现（显示） JTable 中每个单元格的标准类。

实现注意事项：此类继承自一个标准的组件类 JLabel。但是 JTable 为其单元格的呈现使用了特殊的机制，因此要求稍微对其单元格渲染器的行为进行修改。该 table 类定义一个单元格渲染器，并将其用作呈现表中所有单元格的橡皮图章；它呈现第一个单元格、更改该单元格渲染器的内容、将原点移到新的位置、重新进行绘制，等等。标准的 JLabel 组件不是通过此方式使用的，每次绘制单元格时，我们都希望避免触发 revalidate 事件。这会大大降低程序的性能，因为 revalidate 消息会沿容器的层次结构向上传递，以确定任意其他组件是否将受到影响。由于该渲染器是绘制操作生命周期中唯一的父类，类似地，我们也希望避免与为进行绘制操作而遍历容器层次结构相关联的开销。所以此类将 validate、invalidate、revalidate、repaint 和 firePropertyChange 方法重写为无操作，并单独重写 isOpaque 方法以提高性能。如果您编写自己的渲染器，请记住此性能方面的考虑。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JTable

嵌套类摘要
static class DefaultTableCellRenderer.UIResource
DefaultTableCellRenderer 的一个子类，它实现 UIResource。
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected static Border noFocusBorder
一个空 Border。
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
DefaultTableCellRenderer()
创建一个默认的表单元格渲染器。
方法摘要
void | firePropertyChange(String propertyName, boolean oldValue, boolean newValue) 因为性能原因而被重写。
protected void | firePropertyChange(String propertyName, Object oldValue, Object newValue) 因为性能原因而被重写。
Component | getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回默认的表单元格渲染器。
void | invalidate() 因为性能原因而被重写。
boolean | isOpaque() 因为性能原因而被重写。
void | repaint() 因为性能原因而被重写。
void | repaint(long tm, int x, int y, int width, int height) 因为性能原因而被重写。
void | repaint(Rectangle r) 因为性能原因而被重写。
void | revalidate() 因为性能原因而被重写。
void | setBackground(Color c) 重写 JComponent.setBackground 将未选定单元格的背景色分配为指定颜色。
void | setForeground(Color c) 重写 JComponent.setForeground 将未选定单元格的前景色分配为指定颜色。
protected void | setValue(Object value) 将要呈现的单元格的 String 对象设置为 value。
void | updateUI() 取自 UIManager 的关于外观 [L&F] 已更改的通知。
void | validate() 因为性能原因而被重写。
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

noFocusBorder

protected static Border noFocusBorder
一个空 Border。可以不使用此字段。要更改此渲染器所使用的 Border，请重写 getTableCellRendererComponent 方法并直接设置所返回组件的边界。

构造方法详细信息

DefaultTableCellRenderer

public DefaultTableCellRenderer()
创建一个默认的表单元格渲染器。

方法详细信息

setForeground

public void setForeground(Color c)
重写 JComponent.setForeground 将未选定单元格的前景色分配为指定颜色。

覆盖：
类 JComponent 中的 setForeground
参数：
c - 将前景色设置为此值
另请参见：
Component.getForeground()

setBackground

public void setBackground(Color c)
重写 JComponent.setBackground 将未选定单元格的背景色分配为指定颜色。

覆盖：
类 JComponent 中的 setBackground
参数：
c - 将背景色设置为此值
另请参见：
Component.getBackground(), JComponent.setOpaque(boolean)

updateUI

public void updateUI()
取自 UIManager 的关于外观 [L&F] 已更改的通知。用取自 UIManager 的最新版本 UI 对象替换当前的 UI 对象。

覆盖：
类 JLabel 中的 updateUI
另请参见：
JComponent.updateUI()

getTableCellRendererComponent

public Component getTableCellRendererComponent(JTable table,
                                               Object value,
                                               boolean isSelected,
                                               boolean hasFocus,
                                               int row,
                                               int column)
返回默认的表单元格渲染器。

在打印操作期间，将调用此方法（isSelected 和 hasFocus 为 false）阻止选择和焦点在打印输出中出现。要根据是否打印表进行其他定制，检查 JComponent.isPaintingForPrint() 的返回值。

指定者：
接口 TableCellRenderer 中的 getTableCellRendererComponent
参数：
table - JTable
value - 分配给 [row, column] 处单元格的值
isSelected - 如果已选定单元格，则为 true
hasFocus - 如果单元格具有焦点，则为 true
row - 要呈现的单元格所在行
column - 要呈现的单元格所在列
返回：
默认的表单元格渲染器
另请参见：
JComponent.isPaintingForPrint()

isOpaque

public boolean isOpaque()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 isOpaque
返回：
如果此组件是完全不透明的，则返回 true
另请参见：
JComponent.setOpaque(boolean)

invalidate

public void invalidate()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Container 中的 invalidate
从以下版本开始：
1.5
另请参见：
Container.validate(), Container.layout(), LayoutManager, LayoutManager2.invalidateLayout(Container)

validate

public void validate()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Container 中的 validate
另请参见：
Container.add(java.awt.Component),
Component.invalidate(),
JComponent.revalidate(),
Container.validateTree()

revalidate

public void revalidate()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 revalidate
另请参见：
Component.invalidate(),
Container.validate(),
JComponent.isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

repaint

public void repaint(long tm,
                    int x,
                    int y,
                    int width,
                    int height)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 repaint
参数：
tm - 不使用此参数
x - 脏区的 x 值
y - 脏区的 y 值
width - 脏区的宽度
height - 脏区的高度
另请参见：
Component.isShowing(), RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

repaint

public void repaint(Rectangle r)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 repaint
参数：
r - 包含脏区的 Rectangle
另请参见：
Component.isShowing(), RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

repaint

public void repaint()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 repaint
从以下版本开始：
1.5
另请参见：
Component.update(Graphics)

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 其值已改变的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

firePropertyChange

public void firePropertyChange(String propertyName,
                               boolean oldValue,
                               boolean newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 firePropertyChange
参数：
propertyName - 其值已更改的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

setValue

protected void setValue(Object value)
将要呈现的单元格的 String 对象设置为 value。

参数：
value - 此单元格的字符串值；如果 value 为 null，则将文本值设置为空字符串
另请参见：
JLabel.setText(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTableCellRenderer.UIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 DefaultTableCellRenderer.UIResource

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.table.DefaultTableCellRenderer
                        继承者  javax.swing.table.DefaultTableCellRenderer.UIResource
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, UIResource, SwingConstants, TableCellRenderer
正在封闭类：
DefaultTableCellRenderer
public static class DefaultTableCellRenderer.UIResource
extends DefaultTableCellRenderer
implements UIResource

DefaultTableCellRenderer 的一个子类，它实现 UIResource。DefaultTableCellRenderer 不直接实现 UIResource，因此应用程序可以安全地使用 DefaultTableCellRenderer 子类重写 cellRenderer 属性。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.table.DefaultTableCellRenderer 继承的嵌套类/接口
DefaultTableCellRenderer.UIResource
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.table.DefaultTableCellRenderer 继承的字段
noFocusBorder
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
DefaultTableCellRenderer.UIResource()
方法摘要
从类 javax.swing.table.DefaultTableCellRenderer 继承的方法
firePropertyChange, firePropertyChange, getTableCellRendererComponent, invalidate, isOpaque, repaint, repaint, repaint, revalidate, setBackground, setForeground, setValue, updateUI, validate
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DefaultTableCellRenderer.UIResource

public DefaultTableCellRenderer.UIResource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTableColumnModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 DefaultTableColumnModel

java.lang.Object
    继承者  javax.swing.table.DefaultTableColumnModel
所有已实现的接口：
PropertyChangeListener, Serializable, EventListener, ListSelectionListener, TableColumnModel
public class DefaultTableColumnModel
extends Object
implements TableColumnModel, PropertyChangeListener, ListSelectionListener, Serializable

JTable 的标准列处理程序。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JTable

字段摘要
protected ChangeEvent | changeEvent 更改事件（只需要一个）
protected int | columnMargin 每列之间的空白宽度
protected boolean | columnSelectionAllowed 此列模型中允许的列选择
protected EventListenerList | listenerList TableColumnModelListener 的列表
protected ListSelectionModel | selectionModel 跟踪列选择的模型
protected Vector<TableColumn> | tableColumns 此模型中 TableColumn 对象组成的数组
protected int | totalColumnWidth 所有列总宽度的本地缓存
构造方法摘要
DefaultTableColumnModel()
创建默认的表列模型。
方法摘要
 void addColumn(TableColumn aColumn)
将 aColumn 追加到 tableColumns 数组的结尾。
 void addColumnModelListener(TableColumnModelListener x)
添加表列模型事件的侦听器。
protected  ListSelectionModel createSelectionModel()
创建新的默认列表选择模型。
protected  void fireColumnAdded(TableColumnModelEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireColumnMarginChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireColumnMoved(TableColumnModelEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireColumnRemoved(TableColumnModelEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireColumnSelectionChanged(ListSelectionEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。
 TableColumn getColumn(int columnIndex)
返回 columnIndex 处列的 TableColumn 对象。
 int getColumnCount()
返回 tableColumns 数组中的列数。
 int getColumnIndex(Object identifier)
返回 tableColumns 数组中第一列的索引，当使用 equals 进行比较时，该列的标识符等于 identifier。
 int getColumnIndexAtX(int x)
返回位于 x 处列的索引，如果该点处没有列，则返回 -1。
 int getColumnMargin()
返回 TableColumn 的空白宽度。
 TableColumnModelListener[] getColumnModelListeners()
返回一个包含在此模型上注册的所有列模型侦听器的数组。
 Enumeration<TableColumn> getColumns()
返回该模型中所有列的一个 Enumeration。
 boolean getColumnSelectionAllowed()
如果允许列选择，则返回 true，否则返回 false。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
 int getSelectedColumnCount()
返回选定的列数。
 int[] getSelectedColumns()
返回包含选定列的数组。
 ListSelectionModel getSelectionModel()
返回用来维护列选择状态的 ListSelectionModel。
 int getTotalColumnWidth()
返回所有列的总宽度。
 void moveColumn(int columnIndex, int newIndex)
将 columnIndex 位置的列和标题移到 newIndex。
 void propertyChange(PropertyChangeEvent evt)
Property Change Listener 更改方法。
protected  void recalcWidthCache()
重新计算所有列的总宽度。
 void removeColumn(TableColumn column)
从 tableColumns 数组删除 column。
 void removeColumnModelListener(TableColumnModelListener x)
移除表列模型事件的侦听器。
 void setColumnMargin(int newMargin)
将列空白设置为 newMargin。
 void setColumnSelectionAllowed(boolean flag)
设置是否允许列选择。
 void setSelectionModel(ListSelectionModel newModel)
将此 TableColumnModel 的选择模型设置为 newModel，并为来自新选择模型的侦听器通知注册它。
 void valueChanged(ListSelectionEvent e)
列选择更改时转发 ListSelectionEvents 的 ListSelectionListener。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

tableColumns

protected Vector<TableColumn> tableColumns
此模型中 TableColumn 对象组成的数组

selectionModel

protected ListSelectionModel selectionModel
跟踪列选择的模型

columnMargin

protected int columnMargin
每列之间的空白宽度

listenerList

protected EventListenerList listenerList
TableColumnModelListener 的列表

changeEvent

protected transient ChangeEvent changeEvent
更改事件（只需要一个）

columnSelectionAllowed

protected boolean columnSelectionAllowed
此列模型中允许的列选择

totalColumnWidth

protected int totalColumnWidth
所有列总宽度的本地缓存

构造方法详细信息

DefaultTableColumnModel

public DefaultTableColumnModel()
创建默认的表列模型。

方法详细信息

addColumn

public void addColumn(TableColumn aColumn)
将 aColumn 追加到 tableColumns 数组的结尾。此方法还将 columnAdded 事件发送到它的侦听器。

指定者：
接口 TableColumnModel 中的 addColumn
参数：
aColumn - 要添加的 TableColumn
抛出：
IllegalArgumentException - 如果 aColumn 为 null
另请参见：
removeColumn(javax.swing.table.TableColumn)

removeColumn

public void removeColumn(TableColumn column)
从 tableColumns 数组删除 column。如果 column 不在该表各列的列表中，则此方法不执行任何操作。此方法调用 tile 重新调整标题和表视图的大小。此方法还将 columnRemoved 事件发送到它的侦听器。

指定者：
接口 TableColumnModel 中的 removeColumn
参数：
column - 要移除的 TableColumn
另请参见：
addColumn(javax.swing.table.TableColumn)

moveColumn

public void moveColumn(int columnIndex,
                       int newIndex)
将 columnIndex 位置的列和标题移到 newIndex。原来在 columnIndex 位置的列现在可以在 newIndex 处找到。newIndex 位置上的原有列向左或右移动以留出空间。如果 columnIndex 等于 newIndex，则此操作不移动任何列。此方法还将 columnMoved 事件发送到它的侦听器。

指定者：
接口 TableColumnModel 中的 moveColumn
参数：
columnIndex - 要移动列的索引
newIndex - 将列移动到该新索引位置
抛出：
IllegalArgumentException - 如果 column 或 newIndex 不在有效范围内

setColumnMargin

public void setColumnMargin(int newMargin)
将列空白设置为 newMargin。此方法还将 columnMarginChanged 事件发送到它的侦听器。

指定者：
接口 TableColumnModel 中的 setColumnMargin
参数：
newMargin - 新的空白宽度，以像素为单位
另请参见：
getColumnMargin(), getTotalColumnWidth()

getColumnCount

public int getColumnCount()
返回 tableColumns 数组中的列数。

指定者：
接口 TableColumnModel 中的 getColumnCount
返回：
tableColumns 数组中的列数
另请参见：
getColumns()

getColumns

public Enumeration<TableColumn> getColumns()
返回该模型中所有列的一个 Enumeration。

指定者：
接口 TableColumnModel 中的 getColumns
返回：
该模型中所有列的一个 Enumeration

getColumnIndex

public int getColumnIndex(Object identifier)
返回 tableColumns 数组中第一列的索引，当使用 equals 进行比较时，该列的标识符等于 identifier。

指定者：
接口 TableColumnModel 中的 getColumnIndex
参数：
identifier - 标识符对象
返回：
tableColumns 数组中第一列的索引，该列的标识符等于 identifier
抛出：
IllegalArgumentException - 如果 identifier 为 null，或者没有 TableColumn 具有此 identifier
另请参见：
getColumn(int)

getColumn

public TableColumn getColumn(int columnIndex)
返回 columnIndex 处列的 TableColumn 对象。

指定者：
接口 TableColumnModel 中的 getColumn
参数：
columnIndex - 所需列的索引
返回：
columnIndex 处列的 TableColumn 对象

getColumnMargin

public int getColumnMargin()
返回 TableColumn 的空白宽度。默认的 columnMargin 为 1。

指定者：
接口 TableColumnModel 中的 getColumnMargin
返回：
TableColumn 的最大宽度
另请参见：
setColumnMargin(int)

getColumnIndexAtX

public int getColumnIndexAtX(int x)
返回位于 x 处列的索引，如果该点处没有列，则返回 -1。 为了与 Swing 的可分离模型架构保持一致，TableColumnModel 不知道表的各列是如何实际显示在屏幕上的。各列的可视化表示由使用此模型的视图/控制器（通常是 JTable）来负责。该视图/控制器无需从左到右按顺序显示各列。例如，为了适应语言环境的优先选择，可以从右到左显示各列，或者可能根据用户的请求隐藏某些列。因为模型不知道各列是如何在屏幕上布局的，所以不应将给定的 xPosition 认为是 2D 图形空间中的坐标。相反，应该将其认为是从模型中首列开始的一个宽度。如果需要 2D 空间中给定 X 坐标的列索引，则可以使用 JTable.columnAtPoint。

指定者：
接口 TableColumnModel 中的 getColumnIndexAtX
参数：
x - 需要的水平位置
返回：
列的索引，如果未找到列，则返回 -1
另请参见：
JTable.columnAtPoint(java.awt.Point)

getTotalColumnWidth

public int getTotalColumnWidth()
返回所有列的总宽度。

指定者：
接口 TableColumnModel 中的 getTotalColumnWidth
返回：
totalColumnWidth 属性

setSelectionModel

public void setSelectionModel(ListSelectionModel newModel)
将此 TableColumnModel 的选择模型设置为 newModel，并为来自新选择模型的侦听器通知注册它。如果 newModel 为 null，则抛出一个异常。

指定者：
接口 TableColumnModel 中的 setSelectionModel
参数：
newModel - 新的选择模型
抛出：
IllegalArgumentException - 如果 newModel 为 null
另请参见：
getSelectionModel()

getSelectionModel

public ListSelectionModel getSelectionModel()
返回用来维护列选择状态的 ListSelectionModel。

指定者：
接口 TableColumnModel 中的 getSelectionModel
返回：
提供列选择状态的对象。如果不允许列选择，则返回 null。
另请参见：
setSelectionModel(javax.swing.ListSelectionModel)

setColumnSelectionAllowed

public void setColumnSelectionAllowed(boolean flag)
设置是否允许列选择。默认值为 false。

指定者：
接口 TableColumnModel 中的 setColumnSelectionAllowed
参数：
flag - 如果允许列选择，则为 true，否则为 false
另请参见：
TableColumnModel.getColumnSelectionAllowed()

getColumnSelectionAllowed

public boolean getColumnSelectionAllowed()
如果允许列选择，则返回 true，否则返回 false。默认值为 false。

指定者：
接口 TableColumnModel 中的 getColumnSelectionAllowed
返回：
columnSelectionAllowed 属性
另请参见：
TableColumnModel.setColumnSelectionAllowed(boolean)

getSelectedColumns

public int[] getSelectedColumns()
返回包含选定列的数组。如果 selectionModel 为 null，则返回一个空数组。

指定者：
接口 TableColumnModel 中的 getSelectedColumns
返回：
包含选定列的数组，如果没有选定的列，或 selectionModel 为 null，则返回一个空数组

getSelectedColumnCount

public int getSelectedColumnCount()
返回选定的列数。

指定者：
接口 TableColumnModel 中的 getSelectedColumnCount
返回：
选定的列数

addColumnModelListener

public void addColumnModelListener(TableColumnModelListener x)
添加表列模型事件的侦听器。

指定者：
接口 TableColumnModel 中的 addColumnModelListener
参数：
x - 一个 TableColumnModelListener 对象

removeColumnModelListener

public void removeColumnModelListener(TableColumnModelListener x)
移除表列模型事件的侦听器。

指定者：
接口 TableColumnModel 中的 removeColumnModelListener
参数：
x - 一个 TableColumnModelListener 对象

getColumnModelListeners

public TableColumnModelListener[] getColumnModelListeners()
返回一个包含在此模型上注册的所有列模型侦听器的数组。

返回：
此默认表列模型的所有 ColumnModelListener，如果当前没有已注册的列模型侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addColumnModelListener(javax.swing.event.TableColumnModelListener), removeColumnModelListener(javax.swing.event.TableColumnModelListener)

fireColumnAdded

protected void fireColumnAdded(TableColumnModelEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。使用传入此触发方法的参数延后（lazily）创建事件实例。

参数：
e - 接收的事件
另请参见：
EventListenerList

fireColumnRemoved

protected void fireColumnRemoved(TableColumnModelEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
e - 接收的事件
另请参见：
EventListenerList

fireColumnMoved

protected void fireColumnMoved(TableColumnModelEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
e - 接收的事件
另请参见：
EventListenerList

fireColumnSelectionChanged

protected void fireColumnSelectionChanged(ListSelectionEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
e - 接收的事件
另请参见：
EventListenerList

fireColumnMarginChanged

protected void fireColumnMarginChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值（如 FooListener.class）来指定 listenerType 参数。例如，可以使用以下代码查询 DefaultTableColumnModel m 的列模型侦听器：

ColumnModelListener[] cmls = (ColumnModelListener[])(m.getListeners(ColumnModelListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此模型上注册为 FooListener 的所有对象组成的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定实现 java.util.EventListener 的类或接口。
从以下版本开始：
1.3
另请参见：
getColumnModelListeners()

propertyChange

public void propertyChange(PropertyChangeEvent evt)
Property Change Listener 更改方法。用于跟踪列宽或首选列宽的更改。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
evt - PropertyChangeEvent

valueChanged

public void valueChanged(ListSelectionEvent e)
列选择更改时转发 ListSelectionEvents 的 ListSelectionListener。

指定者：
接口 ListSelectionListener 中的 valueChanged
参数：
e - 更改事件

createSelectionModel

protected ListSelectionModel createSelectionModel()
创建新的默认列表选择模型。

recalcWidthCache

protected void recalcWidthCache()
重新计算所有列的总宽度。更新 totalColumnWidth 属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTableModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 DefaultTableModel

java.lang.Object
    继承者  javax.swing.table.AbstractTableModel
        继承者  javax.swing.table.DefaultTableModel
所有已实现的接口：
Serializable, TableModel
public class DefaultTableModel
extends AbstractTableModel
implements Serializable

这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。

警告： DefaultTableModel 返回 Object 的一个列类。DefaultTableModel 与 TableRowSorter 一起使用时将导致大量使用 toString，这对于非 String 数据类型代价昂贵。如果与 TableRowSorter 一起使用 DefaultTableModel，建议最好重写 getColumnClass 以返回适当的类型。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行远程方法调用（Remote Method Invocation，RMI）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
TableModel, getDataVector()

字段摘要
protected Vector | columnIdentifiers Vector，由多个列标识符组成。
protected Vector | dataVector Vector，由包含多个 Object 值的 Vector 组成。
从类 javax.swing.table.AbstractTableModel 继承的字段
listenerList
构造方法摘要
DefaultTableModel()
构造默认的 DefaultTableModel，它是一个零列零行的表。
DefaultTableModel(int rowCount, int columnCount)
构造一个具有 rowCount 行和 columnCount 列的 null 对象值的 DefaultTableModel。
DefaultTableModel(Object[][] data, Object[] columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。
DefaultTableModel(Object[] columnNames, int rowCount)
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。
DefaultTableModel(Vector columnNames, int rowCount)
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。
DefaultTableModel(Vector data, Vector columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。
方法摘要
void | addColumn(Object columnName) 将一列添加到模型中。
void | addColumn(Object columnName, Object[] columnData) 将一列添加到模型中。
void | addColumn(Object columnName, Vector columnData) 将一列添加到模型中。
void | addRow(Object[] rowData) 添加一行到模型的结尾。
void | addRow(Vector rowData) 添加一行到模型的结尾。
protected static Vector | convertToVector(Object[] anArray) 返回一个包含与该数组相同的对象的向量。
protected static Vector | convertToVector(Object[][] anArray) 返回一个 vector，该 vector 由包含与该数组相同的对象的多个 vector 组成。
int | getColumnCount() 返回此数据表中的列数。
String | getColumnName(int column) 返回列名称。
Vector | getDataVector() 返回由多个包含表数据值的 Vector 组成的 Vector。
int | getRowCount() 返回此数据表中的行数。
Object | getValueAt(int row, int column) 返回 row 和 column 处单元格的属性值。
void | insertRow(int row, Object[] rowData) 在模型中的 row 位置插入一行。
void | insertRow(int row, Vector rowData) 在模型中的 row 位置插入一行。
boolean | isCellEditable(int row, int column) 无论参数值是多少都返回 true。
void | moveRow(int start, int end, int to) 将 start（包含）到 end（包含）范围中的一行或多行移到模型中的 to 位置。
void | newDataAvailable(TableModelEvent event) 等效于 fireTableChanged。
void | newRowsAdded(TableModelEvent e) 确保新行的列数正确。
void | removeRow(int row) 移除模型中 row 位置的行。
void | rowsRemoved(TableModelEvent event) 等效于 fireTableChanged。
void | setColumnCount(int columnCount) 设置模型中的列数。
void | setColumnIdentifiers(Object[] newIdentifiers) 替换模型中的列标识符。
void | setColumnIdentifiers(Vector columnIdentifiers) 替换模型中的列标识符。
void | setDataVector(Object[][] dataVector, Object[] columnIdentifiers) 用数组 dataVector 中的值替换 dataVector 实例变量中的值。
void | setDataVector(Vector dataVector, Vector columnIdentifiers) 用新的行 Vector（dataVector）替换当前的 dataVector 实例变量。
void | setNumRows(int rowCount) 从 Java 2 platform v1.3 开始已过时。
void | setRowCount(int rowCount) 设置模型中的行数。
void | setValueAt(Object aValue, int row, int column) 设置 column 和 row 处单元格的对象值。
从类 javax.swing.table.AbstractTableModel 继承的方法
addTableModelListener, findColumn, fireTableCellUpdated, fireTableChanged, fireTableDataChanged, fireTableRowsDeleted, fireTableRowsInserted, fireTableRowsUpdated, fireTableStructureChanged, getColumnClass, getListeners, getTableModelListeners, removeTableModelListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

dataVector

protected Vector dataVector
Vector，由包含多个 Object 值的 Vector 组成。

columnIdentifiers

protected Vector columnIdentifiers
Vector，由多个列标识符组成。

构造方法详细信息

DefaultTableModel

public DefaultTableModel()
构造默认的 DefaultTableModel，它是一个零列零行的表。

DefaultTableModel

public DefaultTableModel(int rowCount,
                         int columnCount)
构造一个具有 rowCount 行和 columnCount 列的 null 对象值的 DefaultTableModel。

参数：
rowCount - 表的行数
columnCount - 表的列数
另请参见：
setValueAt(java.lang.Object, int, int)

DefaultTableModel

public DefaultTableModel(Vector columnNames,
                         int rowCount)
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。每列的名称都取自 columnNames 向量。

参数：
columnNames - 包含新的列名称的 vector；如果该参数为 null，则该模型没有列
rowCount - 表的行数
另请参见：
setDataVector(java.util.Vector, java.util.Vector), setValueAt(java.lang.Object, int, int)

DefaultTableModel

public DefaultTableModel(Object[] columnNames,
                         int rowCount)
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。每列的名称都取自 columnNames 数组。

参数：
columnNames - 包含新的列名称的 array；如果该参数为 null，则该模型没有列
rowCount - 表的行数
另请参见：
setDataVector(java.util.Vector, java.util.Vector), setValueAt(java.lang.Object, int, int)

DefaultTableModel

public DefaultTableModel(Vector data,
                         Vector columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。

参数：
data - 表的数据，它是一个 Vector，由包含多个 Object 值的 Vector 组成
columnNames - 包含新的列名称的 vector
另请参见：
getDataVector(), setDataVector(java.util.Vector, java.util.Vector)

DefaultTableModel

public DefaultTableModel(Object[][] data,
                         Object[] columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。Object[][] 数组中的第一个索引是行索引，第二个索引是列索引。

参数：
data - 表的数据
columnNames - 列的名称
另请参见：
getDataVector(), setDataVector(java.util.Vector, java.util.Vector)
方法详细信息

getDataVector

public Vector getDataVector()
返回由多个包含表数据值的 Vector 组成的 Vector。外层 vector 中包含的每个 vector 都是一行的值。换句话说，要获得第 1 行、第 5 列的单元格，可以使用以下代码：

((Vector)getDataVector().elementAt(1)).elementAt(5);

返回：
vector，由包含表数据值的多个 vector 组成
另请参见：
newDataAvailable(javax.swing.event.TableModelEvent),
newRowsAdded(javax.swing.event.TableModelEvent),
setDataVector(java.util.Vector, java.util.Vector)

setDataVector

public void setDataVector(Vector dataVector,
                          Vector columnIdentifiers)
用新的行 Vector（dataVector）替换当前的 dataVector 实例变量。每一行都用 dataVector 表示，dataVector 是由多个 Object 值组成的 Vector。columnIdentifiers 是新列的名称。columnIdentifiers 中的第一个名称映射为 dataVector 中第 0 列。将 dataVector 中每一行调整为与 columnIdentifiers 中的列数匹配，这通过在 Vector 太长时截短它、在 Vector 太短时添加 null 值来实现。

注意，为 dataVector 传入 null 值会导致未指定的行为，可能抛出异常。

参数：
dataVector - 新的数据向量
columnIdentifiers - 列的名称
另请参见：
getDataVector()

setDataVector

public void setDataVector(Object[][] dataVector,
                          Object[] columnIdentifiers)
用数组 dataVector 中的值替换 dataVector 实例变量中的值。Object[][] 数组中第一个索引是行索引，第二个索引是列索引。columnIdentifiers 是新列名称。

参数：
dataVector - 新的数据向量
columnIdentifiers - 列的名称
另请参见：
setDataVector(Vector, Vector)

newDataAvailable

public void newDataAvailable(TableModelEvent event)
等效于 fireTableChanged。

参数：
event - 更改事件

newRowsAdded

public void newRowsAdded(TableModelEvent e)
确保新行的列数正确。这是通过使用 Vector 中的 setSize 方法来完成的，该方法在 Vector 太长时将其截短，在 Vector 太短时追加 null。此方法还向所有侦听器发送 tableChanged 通知消息。

参数：
e - 此 TableModelEvent 描述添加行的位置。如果为 null，则此方法假定所有行都是新添加的
另请参见：
getDataVector()

rowsRemoved

public void rowsRemoved(TableModelEvent event)
等效于 fireTableChanged。

参数：
event - 更改事件

setNumRows

public void setNumRows(int rowCount)
从 Java 2 platform v1.3 开始已过时。请使用 setRowCount 替代。

setRowCount

public void setRowCount(int rowCount)
设置模型中的行数。如果新的大小大于当前大小，则将新行添加到该模型的结尾，如果新的大小小于当前大小，则丢弃索引 rowCount 处及其之后的所有行。

从以下版本开始：
1.3
另请参见：
setColumnCount(int)

addRow

public void addRow(Vector rowData)
添加一行到模型的结尾。如果未指定 rowData，则新行将包含 null 值。将生成添加行的通知。

参数：
rowData - 要添加的行数据（可选）

addRow

public void addRow(Object[] rowData)
添加一行到模型的结尾。如果未指定 rowData，则新行将包含 null 值。将生成添加行的通知。

参数：
rowData - 要添加的行数据（可选）

insertRow

public void insertRow(int row,
                      Vector rowData)
在模型中的 row 位置插入一行。如果未指定 rowData，则新行将包含 null 值。将生成添加行的通知。

参数：
row - 要插入的行的行索引
rowData - 要添加的行数据（可选）
抛出：
ArrayIndexOutOfBoundsException - 如果 row 无效

insertRow

public void insertRow(int row,
                      Object[] rowData)
在模型中的 row 位置插入一行。如果未指定 rowData，则新行将包含 null 值。将生成添加行的通知。

参数：
row - 要插入的行的行索引
rowData - 要添加的行数据（可选）
抛出：
ArrayIndexOutOfBoundsException - 如果 row 无效

moveRow

public void moveRow(int start,
                    int end,
                    int to)
将 start（包含）到 end（包含）范围中的一行或多行移到模型中的 to 位置。进行移动操作后，原先索引为 start 的行的索引将变为 to。此方法将向所有侦听器发送 tableChanged 通知消息。

以下是移动操作的示例：

  1. moveRow(1,3,5);
          a|B|C|D|e|f|g|h|i|j|k   - 移动前
          a|e|f|g|h|B|C|D|i|j|k   - 移动后

  2. moveRow(6,7,1);
          a|b|c|d|e|f|G|H|i|j|k   - 移动前
          a|G|H|b|c|d|e|f|i|j|k   - 移动后

参数：
start - 要移动的起始行索引
end - 要移动的结束行索引
to - 行要移动到的目标位置
抛出：
ArrayIndexOutOfBoundsException - 如果任意元素将被移出该表的范围

removeRow

public void removeRow(int row)
移除模型中 row 位置的行。向所有侦听器发送移除行的通知。

参数：
row - 要移除的行的行索引
抛出：
ArrayIndexOutOfBoundsException - 如果 row 无效

setColumnIdentifiers

public void setColumnIdentifiers(Vector columnIdentifiers)
替换模型中的列标识符。如果 newIdentifier 数大于当前的列数，则将新列添加到模型中每一行的结尾。如果 newIdentifier 数小于当前的列数，则丢弃每行结尾处所有多余的列。

参数：
columnIdentifiers - 列标识符的向量。如果为 null，则将该模型设置为具有零列
另请参见：
setNumRows(int)

setColumnIdentifiers

public void setColumnIdentifiers(Object[] newIdentifiers)
替换模型中的列标识符。如果 newIdentifier 数大于当前的列数，则将新列添加到模型中每一行的结尾。如果 newIdentifier 数小于当前的列数，则丢弃每行结尾处所有多余的列。

参数：
newIdentifiers - 列标识符的数组。如果为 null，则将该模型设置为具有零列
另请参见：
setNumRows(int)

setColumnCount

public void setColumnCount(int columnCount)
设置模型中的列数。如果新大小大于当前大小，则将新列添加到模型结尾并使其具有 null 单元格值。如果新大小小于当前大小，则将丢弃索引 columnCount 处及其之后的所有列。

参数：
columnCount - 模型中新的列数
从以下版本开始：
1.3
另请参见：
setColumnCount(int)

addColumn

public void addColumn(Object columnName)
将一列添加到模型中。新列的标识符将为 columnName，它可以为 null。此方法将向所有侦听器发送 tableChanged 通知消息。此方法覆盖了 addColumn(Object, Vector)，它使用 null 作为数据向量。

参数：
columnName - 要添加的列的标识符

addColumn

public void addColumn(Object columnName,
                      Vector columnData)
将一列添加到模型中。新列的标识符将为 columnName，它可以为 null。columnData 是列的可选数据向量。如果它为 null，则使用 null 值填充该列。否则，将新数据添加到模型中，第一个元素将添加到第 0 行，依此类推。此方法将向所有侦听器发送 tableChanged 通知消息。

参数：
columnName - 要添加的列的标识符
columnData - 要添加的列的数据（可选）

addColumn

public void addColumn(Object columnName,
                      Object[] columnData)
将一列添加到模型中。新列的标识符将为 columnName。columnData 是该列的可选数据数组。如果它为 null，则使用 null 值填充该列。否则，将新数据添加到模型中，第一个元素添加到第 0 行，依此类推。此方法将向所有侦听器发送 tableChanged 通知消息。

另请参见：
addColumn(Object, Vector)

getRowCount

public int getRowCount()
返回此数据表中的行数。

指定者：
接口 TableModel 中的 getRowCount
返回：
该模型中的行数
另请参见：
TableModel.getColumnCount()

getColumnCount

public int getColumnCount()
返回此数据表中的列数。

指定者：
接口 TableModel 中的 getColumnCount
返回：
该模型中的列数
另请参见：
TableModel.getRowCount()

getColumnName

public String getColumnName(int column)
返回列名称。

指定者：
接口 TableModel 中的 getColumnName
覆盖：
类 AbstractTableModel 中的 getColumnName
参数：
column - 被查询的列
返回：
此列的名称，它使用 columnIdentifiers 中适当成员的字符串值。如果 columnIdentifiers 不具有此索引的条目，则返回由超类提供的默认名称

isCellEditable

public boolean isCellEditable(int row,
                              int column)
无论参数值是多少都返回 true。

指定者：
接口 TableModel 中的 isCellEditable
覆盖：
类 AbstractTableModel 中的 isCellEditable
参数：
row - 要查询其值的行
column - 要查询其值的列
返回：
true
另请参见：
setValueAt(java.lang.Object, int, int)

getValueAt

public Object getValueAt(int row,
                         int column)
返回 row 和 column 处单元格的属性值。

指定者：
接口 TableModel 中的 getValueAt
参数：
row - 要查询其值的行
column - 要查询其值的列
返回：
指定单元格处的值 Object
抛出：
ArrayIndexOutOfBoundsException - 如果给定了无效的 row 或 column

setValueAt

public void setValueAt(Object aValue,
                       int row,
                       int column)
设置 column 和 row 处单元格的对象值。aValue 是新值。此方法将生成一个 tableChanged 通知。

指定者：
接口 TableModel 中的 setValueAt
覆盖：
类 AbstractTableModel 中的 setValueAt
参数：
aValue - 新值，可以为 null
row - 要更改其值的行
column - 要更改其值的列
抛出：
ArrayIndexOutOfBoundsException - 如果给定了无效的 row 或 column
另请参见：
TableModel.getValueAt(int, int), TableModel.isCellEditable(int, int)

convertToVector

protected static Vector convertToVector(Object[] anArray)
返回一个包含与该数组相同的对象的向量。

参数：
anArray - 要转换的数组
返回：
新的向量；如果 anArray 为 null，则返回 null

convertToVector

protected static Vector convertToVector(Object[][] anArray)
返回一个 vector，该 vector 由包含与该数组相同的对象的多个 vector 组成。

参数：
anArray - 要转换的二维数组
返回：
由多个 vector 组成的新 vector；如果 anArray 为 null，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTableHeader (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 JTableHeader

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.table.JTableHeader
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, EventListener, Accessible, TableColumnModelListener
public class JTableHeader
extends JComponent
implements TableColumnModelListener, Accessible

这是管理 JTable 的头的对象。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JTable

嵌套类摘要
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected TableColumnModel | columnModel 表头的 TableColumnModel。
protected TableColumn | draggedColumn 被拖动列的索引。
protected int | draggedDistance 列被拖离其初始位置的距离。
protected boolean | reorderingAllowed 如果为 true，则允许用户重新排序各列；默认值为 true。
protected boolean | resizingAllowed 如果为 true，则允许用户调整各列的大小；默认值为 true。
protected TableColumn | resizingColumn 进行大小调整的列的索引。
protected JTable | table 将此对象作为其头的表，默认值为 null。
protected boolean | updateTableInRealTime 从 Java 2 platform v1.3 开始已过时。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JTableHeader()
构造具有默认 TableColumnModel 的 JTableHeader。
JTableHeader(TableColumnModel cm)
构造 JTableHeader，使用 cm 作为列模型对其进行初始化。
方法摘要
void | columnAdded(TableColumnModelEvent e) 将列添加到表列模型时调用。
int | columnAtPoint(Point point) 返回该 point 所处列的索引，如果列位于边界外，则返回 -1。
void | columnMarginChanged(ChangeEvent e) 当列由于间距改变而被移动时调用。
void | columnMoved(TableColumnModelEvent e) 重新定位列时调用。
void | columnRemoved(TableColumnModelEvent e) 从表列模型中移除列时调用。
void | columnSelectionChanged(ListSelectionEvent e) 当 TableColumnModel 的选择模型更改时调用。
protected TableColumnModel | createDefaultColumnModel() 返回默认的列模型对象，它是 DefaultTableColumnModel。
protected TableCellRenderer | createDefaultRenderer() 返回 TableColumn 未定义头渲染器时所使用的默认渲染器。
AccessibleContext | getAccessibleContext() 获取与此 JTableHeader 关联的 AccessibleContext。
TableColumnModel | getColumnModel() 返回包含此表头所有列信息的 TableColumnModel。
TableCellRenderer | getDefaultRenderer() 返回 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
TableColumn | getDraggedColumn() 当且仅当正在进行拖动时，返回被拖动的列，否则返回 null。
int | getDraggedDistance() 当且仅当正在进行拖动时，返回该列到其初始位置的水平距离。
Rectangle | getHeaderRect(int column) 返回包含 column 处头 tile 的矩形。
boolean | getReorderingAllowed() 如果允许用户通过拖动各列的头对其进行重新安排，则返回 true；否则返回 false。
boolean | getResizingAllowed() 如果允许用户通过在头间拖动来调整各列的大小，则返回 true；否则返回 false。
TableColumn | getResizingColumn() 返回正在调整其大小的列。
JTable | getTable() 返回与此头关联的表。
String | getToolTipText(MouseEvent event) 如果设置了提示文本，则允许使用渲染器的提示。
TableHeaderUI | getUI() 返回渲染此组件的外观 (L&F) 对象。
String | getUIClassID() 返回用于构造外观 (L&F) 类名称的后缀，该类用于渲染此组件。
boolean | getUpdateTableInRealTime() 从 Java 2 platform v1.3 开始已过时。
protected void | initializeLocalVars() 使用默认值初始化局部变量和属性。
protected String | paramString() 返回此 JTableHeader 的字符串表示形式。
void | resizeAndRepaint() 确定头的大小并将其标记为需要显示。
void | setColumnModel(TableColumnModel columnModel) 将此表的列模型设置为 newModel，并向侦听器注册来自新列模型的通知。
void | setDefaultRenderer(TableCellRenderer defaultRenderer) 设置 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
void | setDraggedColumn(TableColumn aColumn) 将头的 draggedColumn 设置为 aColumn。
void | setDraggedDistance(int distance) 将头的 draggedDistance 设置为 distance。
void | setReorderingAllowed(boolean reorderingAllowed) 设置用户是否可以拖动列头，以重新排序各列。
void | setResizingAllowed(boolean resizingAllowed) 设置用户是否可以通过在头间拖动来调整各列的大小。
void | setResizingColumn(TableColumn aColumn) 将头的 resizingColumn 设置为 aColumn。
void | setTable(JTable table) 设置与此头关联的表。
void | setUI(TableHeaderUI ui) 设置渲染此组件的 (L&F) 对象。
void | setUpdateTableInRealTime(boolean flag) 从 Java 2 platform v1.3 开始已过时。
void | updateUI() UIManager 发出的关于 L&F 已更改的通知。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

table

protected JTable table
将此对象作为其头的表，默认值为 null。

columnModel

protected TableColumnModel columnModel
表头的 TableColumnModel。

reorderingAllowed

protected boolean reorderingAllowed
如果为 true，则允许用户重新排序各列；默认值为 true。

resizingAllowed

protected boolean resizingAllowed
如果为 true，则允许用户调整各列的大小；默认值为 true。

updateTableInRealTime

protected boolean updateTableInRealTime
从 Java 2 platform v1.3 开始已过时。为响应列拖动或调整大小而进行的实时重新绘制现在是无条件的。

resizingColumn

protected transient TableColumn resizingColumn
进行大小调整的列的索引。如果未调整大小，则为 null。

draggedColumn

protected transient TableColumn draggedColumn
被拖动列的索引。如果未拖动，则为 null。

draggedDistance

protected transient int draggedDistance
列被拖离其初始位置的距离。

构造方法详细信息

JTableHeader

public JTableHeader()
构造具有默认 TableColumnModel 的 JTableHeader。

另请参见：
createDefaultColumnModel()

JTableHeader

public JTableHeader(TableColumnModel cm)
构造 JTableHeader，使用 cm 作为列模型对其进行初始化。如果 cm 为 null，则此方法将使用默认的 TableColumnModel 来初始化其表头。

参数：
cm - 该表的列模型
另请参见：
createDefaultColumnModel()
方法详细信息

setTable

public void setTable(JTable table)
设置与此头关联的表。

参数：
table - 新表

getTable

public JTable getTable()
返回与此头关联的表。

返回：
table 属性

setReorderingAllowed

public void setReorderingAllowed(boolean reorderingAllowed)
设置用户是否可以拖动列头，以重新排序各列。

参数：
reorderingAllowed - 如果表视图应该允许重新排序，则为 true；否则为 false
另请参见：
getReorderingAllowed()

getReorderingAllowed

public boolean getReorderingAllowed()
如果允许用户通过拖动各列的头对其进行重新安排，则返回 true；否则返回 false。默认值为 true。无论此设置为多少都可以通过编程方式重新安排各列。

返回：
reorderingAllowed 属性
另请参见：
setReorderingAllowed(boolean)

setResizingAllowed

public void setResizingAllowed(boolean resizingAllowed)
设置用户是否可以通过在头间拖动来调整各列的大小。

参数：
resizingAllowed - 如果表视图应该允许调整大小，则为 true
另请参见：
getResizingAllowed()

getResizingAllowed

public boolean getResizingAllowed()
如果允许用户通过在头间拖动来调整各列的大小，则返回 true；否则返回 false。默认值为 true。无论此设置为多少都可以通过编程方式重新安排各列。

返回：
resizingAllowed 属性
另请参见：
setResizingAllowed(boolean)

getDraggedColumn

public TableColumn getDraggedColumn()
当且仅当正在进行拖动时，返回被拖动的列，否则返回 null。

返回：
如果正在进行拖动，则返回被拖动的列；否则返回 null
另请参见：
getDraggedDistance()

getDraggedDistance

public int getDraggedDistance()
当且仅当正在进行拖动时，返回该列到其初始位置的水平距离。否则返回值无意义。

返回：
当且仅当正在进行拖动时，返回该列到其初始位置的水平距离；否则返回值无意义
另请参见：
getDraggedColumn()

getResizingColumn

public TableColumn getResizingColumn()
返回正在调整其大小的列。如果未调整列的大小，则此方法返回 null。

返回：
如果正在进行大小调整，则返回调整其大小的列；否则返回 null

setUpdateTableInRealTime

public void setUpdateTableInRealTime(boolean flag)
从 Java 2 platform v1.3 开始已过时。为响应列拖动或调整大小而进行的实时重新绘制现在是无条件的。

getUpdateTableInRealTime

public boolean getUpdateTableInRealTime()
从 Java 2 platform v1.3 开始已过时。为响应列拖动或调整大小而进行的实时重新绘制现在是无条件的。

setDefaultRenderer

public void setDefaultRenderer(TableCellRenderer defaultRenderer)
设置 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。

参数：
defaultRenderer - 默认渲染器
从以下版本开始：
1.3

getDefaultRenderer

public TableCellRenderer getDefaultRenderer()
返回 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。

返回：
默认渲染器
从以下版本开始：
1.3

columnAtPoint

public int columnAtPoint(Point point)
返回该 point 所处列的索引，如果列位于边界外，则返回 -1。

返回：
该 point 所处列的索引，如果列位于边界外，则返回 -1

getHeaderRect

public Rectangle getHeaderRect(int column)
返回包含 column 处头 tile 的矩形。column 参数超出范围时，此方法使用与 JTable 的 getCellRect 方法相同的约定。

返回：
包含 column 处头 tile 的矩形
另请参见：
JTable.getCellRect(int, int, boolean)

getToolTipText

public String getToolTipText(MouseEvent event)
如果设置了提示文本，则允许使用渲染器的提示。

覆盖：
类 JComponent 中的 getToolTipText
参数：
event - 标识正确渲染器和正确提示的事件位置
返回：
此组件的工具提示

getUI

public TableHeaderUI getUI()
返回渲染此组件的外观 (L&F) 对象。

返回：
渲染此组件的 TableHeaderUI 对象

setUI

public void setUI(TableHeaderUI ui)
设置渲染此组件的 (L&F) 对象。

参数：
ui - TableHeaderUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
UIManager 发出的关于 L&F 已更改的通知。用来自 UIManager 的最新版本 UI 对象替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回用于构造外观 (L&F) 类名称的后缀，该类用于渲染此组件。

覆盖：
类 JComponent 中的 getUIClassID
返回：
"TableHeaderUI" 字符串
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setColumnModel

public void setColumnModel(TableColumnModel columnModel)
将此表的列模型设置为 newModel，并向侦听器注册来自新列模型的通知。

参数：
columnModel - 此表的新数据源
抛出：
IllegalArgumentException - 如果 newModel 为 null
另请参见：
getColumnModel()

getColumnModel

public TableColumnModel getColumnModel()
返回包含此表头所有列信息的 TableColumnModel。

返回：
columnModel 属性
另请参见：
setColumnModel(javax.swing.table.TableColumnModel)

columnAdded

public void columnAdded(TableColumnModelEvent e)
将列添加到表列模型时调用。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnAdded
参数：
e - 接收到的事件
另请参见：
TableColumnModelListener

columnRemoved

public void columnRemoved(TableColumnModelEvent e)
从表列模型中移除列时调用。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnRemoved
参数：
e - 接收到的事件
另请参见：
TableColumnModelListener

columnMoved

public void columnMoved(TableColumnModelEvent e)
重新定位列时调用。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnMoved
参数：
e - 接收到的事件
另请参见：
TableColumnModelListener

columnMarginChanged

public void columnMarginChanged(ChangeEvent e)
当列由于间距改变而被移动时调用。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnMarginChanged
参数：
e - 接收到的事件
另请参见：
TableColumnModelListener

columnSelectionChanged

public void columnSelectionChanged(ListSelectionEvent e)
当 TableColumnModel 的选择模型更改时调用。此方法当前无效（不重绘头）。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnSelectionChanged
参数：
e - 接收到的事件
另请参见：
TableColumnModelListener

createDefaultColumnModel

protected TableColumnModel createDefaultColumnModel()
返回默认的列模型对象，它是 DefaultTableColumnModel。子类可以重写此方法，以返回不同的列模型对象。

返回：
默认的列模型对象

createDefaultRenderer

protected TableCellRenderer createDefaultRenderer()
返回 TableColumn 未定义头渲染器时所使用的默认渲染器。

返回：
默认的表列渲染器
从以下版本开始：
1.3

initializeLocalVars

protected void initializeLocalVars()
使用默认值初始化局部变量和属性。由构造方法使用。

resizeAndRepaint

public void resizeAndRepaint()
确定头的大小并将其标记为需要显示。等效于 revalidate 后跟 repaint。

setDraggedColumn

public void setDraggedColumn(TableColumn aColumn)
将头的 draggedColumn 设置为 aColumn。

应用程序代码不显式地使用此方法，它们由列拖动机制在内部使用。

参数：
aColumn - 被拖动的列，如果没有列被拖动，则为 null

setDraggedDistance

public void setDraggedDistance(int distance)
将头的 draggedDistance 设置为 distance。

参数：
distance - 拖动的距离

setResizingColumn

public void setResizingColumn(TableColumn aColumn)
将头的 resizingColumn 设置为 aColumn。

应用程序代码不显式地使用此方法，它们由列大小调整机制在内部使用。

参数：
aColumn - 调整其大小的列，如果现在没有调整列的大小，则为 null

paramString

protected String paramString()
返回此 JTableHeader 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

重写 paramString 以提供有关特定的新的 JFC 组件方面的信息。

覆盖：
类 JComponent 中的 paramString
返回：
此 JTableHeader 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JTableHeader 关联的 AccessibleContext。对于 JTableHeaders，AccessibleContext 采用 AccessibleJTableHeader 的形式。如有必要，则会创建一个新的 AccessibleJTableHeader 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJTableHeader，用作此 JTableHeader 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTableHeader.AccessibleJTableHeader (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 JTableHeader.AccessibleJTableHeader

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.table.JTableHeader.AccessibleJTableHeader
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JTableHeader
protected class JTableHeader.AccessibleJTableHeader
extends JComponent.AccessibleJComponent

此类实现对 JTableHeader 类的可访问性支持。它提供适合于表头用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JTableHeader.AccessibleJTableHeader()
方法摘要
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回该对象的第 n 个可访问子对象。
int | getAccessibleChildrenCount() 返回该对象中可访问的子对象数。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JTableHeader.AccessibleJTableHeader

protected JTableHeader.AccessibleJTableHeader()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回本地坐标 Point 包含的可访问子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Container.AccessibleAWTContainer 中的 getAccessibleAt
参数：
p - 定义 Accessible 左上角的点，该点在此对象的父级坐标空间中给出。
返回：
指定位置的 Accessible（如果存在）；否则返回 null

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回该对象中可访问的子对象数。如果此对象的所有子级都实现 Accessible，则此方法应该返回该对象的子级数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子对象数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回该对象的第 n 个可访问子对象。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
该对象的第 n 个可访问子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
所有已实现的接口：
Accessible, AccessibleComponent
正在封闭类：
JTableHeader.AccessibleJTableHeader
protected class JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
extends AccessibleContext
implements Accessible, AccessibleComponent

此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
构造一个 AccessiblJTableHeaaderEntry
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener l) 将 PropertyChangeListener 添加到侦听器列表。
boolean | contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
AccessibleAction | getAccessibleAction() 获取与此对象关联的可支持一个或多个动作的 AccessibleAction。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回该对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回该对象的可访问子级数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。
AccessibleContext | getAccessibleContext() 获取与此对象关联的 AccessibleContext。
String | getAccessibleDescription() 获取此对象的 accessibleDescription 属性。
int | getAccessibleIndexInParent() 获取此对象在其可访问父级中的基于零的索引。
String | getAccessibleName() 获取此对象的 accessibleName 属性。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集合。
AccessibleText | getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleValue | getAccessibleValue() 获取与此对象关联的支持 Numerical 值的 AccessibleValue。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 获取该组件的语言环境。
Point | getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否已启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定此对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表移除 PropertyChangeListener。
void | requestFocus() 请求此对象的焦点。
void | setAccessibleDescription(String s) 设置此对象的可访问描述。
void | setAccessibleName(String s) 设置此对象的可访问的本地化名称。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor c) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleParent, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

public JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c,
                                                                       JTableHeader p,
                                                                       JTable t)
构造一个 AccessiblJTableHeaaderEntry

从以下版本开始：
1.4
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此对象关联的 AccessibleContext。在此类的 Java Accessibility API 的实现中，返回的是此对象，它充当其本身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getAccessibleName

public String getAccessibleName()
从类 AccessibleContext 复制的描述
获取此对象的 accessibleName 属性。对象的 accessibleName 属性是指定该对象功能的本地化 String。例如，标签和按钮的 accessibleName 属性可以是标签或按钮本身的文本。对于不显示其名称的对象，仍应设置 accessibleName。例如，对于用于输入城市名称的文本字段，在 en_US 语言环境下，accessibleName 可以为 "city"。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
从类 AccessibleContext 复制的描述
设置此对象的可访问的本地化名称。更改名称将导致激发 ACCESSIBLE_NAME_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 AccessibleContext 中的 setAccessibleName
参数：
s - 对象的新本地化名称。
另请参见：
AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
从类 AccessibleContext 复制的描述
获取此对象的 accessibleDescription 属性。此对象的 accessibleDescription 属性是描述该对象功能的本地化短语。例如，对于 "Cancel" 按钮，accessibleDescription 可以是 "Ignore changes and close dialog box"（忽略更改并关闭对话框）。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
该对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
从类 AccessibleContext 复制的描述
设置此对象的可访问描述。更改名称将导致激发 ACCESSIBLE_DESCRIPTION_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 AccessibleContext 中的 setAccessibleDescription
参数：
s - 此对象的新的本地化描述
另请参见：
AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
从类 AccessibleContext 复制的描述
获取此对象的职责。对象的职责是此对象的类的一般功能或用途。例如，push 按钮的职责是 AccessibleRole.PUSH_BUTTON。AccessibleRole 中提供了一些职责，组件开发人员可以从一组预定义职责中进行选择。这就使辅助技术能为各种交互的组件子类（例如，对所有充当按钮的组件使用 AccessibleRole.PUSH_BUTTON）以及区分行为各异的子类（例如，复选框 AccessibleRole.CHECK_BOX 和单选框 AccessibleRole.RADIO_BUTTON）提供一致的接口。

注意，AccessibleRole 类也是可扩展的，因此如果预定义的职责集合不充分，则自定义组件的开发人员可以定义他们自己的 AccessibleRole。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
从类 AccessibleContext 复制的描述
获取此对象的状态集合。对象的 AccessibleStateSet 由一组唯一的 AccessibleState 组成。对象的 AccessibleStateSet 中的更改将导致激发 ACCESSIBLE_STATE_PROPERTY 属性的 PropertyChangeEvent。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象的当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
从类 AccessibleContext 复制的描述
获取此对象在其可访问父级中的基于零的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
返回此对象在父级中从零开始的索引；如果此对象没有可访问父级，则返回 -1。
另请参见：
AccessibleContext.getAccessibleParent(),
AccessibleContext.getAccessibleChildrenCount(),
AccessibleContext.getAccessibleChild(int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
从类 AccessibleContext 复制的描述
返回该对象的可访问子级数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
该对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
从类 AccessibleContext 复制的描述
返回该对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是从零开始的，因此 Accessible 对象的第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 子级从零开始的索引
返回：
对象的 Accessible 子级
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
从类 AccessibleContext 复制的描述
获取该组件的语言环境。如果该组件没有语言环境，则返回其父级的语言环境。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此组件的语言环境。如果此组件没有语言环境，则返回其父级的语言环境。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
从类 AccessibleContext 复制的描述
将 PropertyChangeListener 添加到侦听器列表。此侦听器为所有 Accessible 属性注册，并且将在这些属性发生更改时调用。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
l - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
从类 AccessibleContext 复制的描述
从侦听器列表移除 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
l - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
从类 AccessibleContext 复制的描述
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
如果受对象支持，则返回 AccessibleAction；否则返回 null
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其自身实现 AccessibleComponent 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
此对象
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
从类 AccessibleContext 复制的描述
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
如果受对象支持，则返回 AccessibleSelection；否则返回 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
从类 AccessibleContext 复制的描述
获取与在显示器上显示文本的此对象关联的 AccessibleText。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
从类 AccessibleContext 复制的描述
获取与此对象关联的支持 Numerical 值的 AccessibleValue。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
如果受对象支持，则返回 AccessibleValue；否则返回 null
另请参见：
AccessibleValue

getBackground

public Color getBackground()
从接口 AccessibleComponent 复制的描述
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
如果支持的话，返回对象的背景色；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的背景色。

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 新的背景 Color
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

getForeground

public Color getForeground()
从接口 AccessibleComponent 复制的描述
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
如果支持的话，返回对象的前景色；否则返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 新的前景 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
从接口 AccessibleComponent 复制的描述
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
如果支持的话，返回对象的 Cursor；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor c)
从接口 AccessibleComponent 复制的描述
设置此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 对象的新 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
从接口 AccessibleComponent 复制的描述
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
如果支持的话，返回对象的 Font；否则返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
从接口 AccessibleComponent 复制的描述
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
从接口 AccessibleComponent 复制的描述
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
如果支持的话，返回对象的 FontMetrics；否则返回 null
另请参见：
AccessibleComponent.getFont()

isEnabled

public boolean isEnabled()
从接口 AccessibleComponent 复制的描述
确定是否已启用该对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
从接口 AccessibleComponent 复制的描述
确定此对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
从接口 AccessibleComponent 复制的描述
确定是否正显示对象。通过检查该对象和祖先的可见性可确定这一点。注：即使该对象被另一对象屏蔽（例如，它是下拉菜单的下级），仍然返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果正在显示对象，则返回 true；否则，返回 false

contains

public boolean contains(Point p)
从接口 AccessibleComponent 复制的描述
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 相对于对象的坐标系统的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
从接口 AccessibleComponent 复制的描述
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocation

public Point getLocation()
从接口 AccessibleComponent 复制的描述
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
Point 的实例，该点表示屏幕坐标空间中对象边界的左上角 ；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
从接口 AccessibleComponent 复制的描述
设置对象相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
从接口 AccessibleComponent 复制的描述
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
从接口 AccessibleComponent 复制的描述
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
从接口 AccessibleComponent 复制的描述
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
从接口 AccessibleComponent 复制的描述
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的维数。
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
从接口 AccessibleComponent 复制的描述
返回本地坐标 Point 包含的可访问子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 相对于此对象坐标系统的 point。
返回：
如果存在，则返回指定位置处的 Accessible；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
从接口 AccessibleComponent 复制的描述
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
从接口 AccessibleComponent 复制的描述
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableCellEditor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
接口 TableCellEditor

所有超级接口：
CellEditor
所有已知实现类：
DefaultCellEditor
public interface TableCellEditor
extends CellEditor

此接口定义了要成为组件（如 JListBox、JComboBox、JTree 或 JTable）的值编辑器的任意对象需要实现的方法。

方法摘要
 Component getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
为编辑器设置初始 value。
从接口 javax.swing.CellEditor 继承的方法
addCellEditorListener, cancelCellEditing, getCellEditorValue, isCellEditable, removeCellEditorListener, shouldSelectCell, stopCellEditing

方法详细信息

getTableCellEditorComponent

Component getTableCellEditorComponent(JTable table,
                                      Object value,
                                      boolean isSelected,
                                      int row,
                                      int column)
为编辑器设置初始 value。如果编辑器正在编辑时调用此方法，则会使该编辑器 stopEditing 并且丢失掉部分已编辑的值。

返回应该添加到客户端 Component 层次结构中的组件。一旦在客户端的层次结构中安装了此组件，就能够进行绘制和接收用户输入。

参数：
table - 要求编辑器进行编辑的 JTable；可以为 null
value - 要编辑的单元格的值；由具体的编辑器解释和绘制该值。例如，如果 value 是字符串 "true"，则它可呈现为字符串，或者也可作为已选中的复选框来呈现。null 是有效值
isSelected - 如果使用高亮显示来呈现该单元格，则为 true
row - 要编辑的单元格所在行
column - 要编辑的单元格所在列
返回：
要编辑的组件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableCellRenderer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
接口 TableCellRenderer

所有已知实现类：
DefaultTableCellRenderer, DefaultTableCellRenderer.UIResource
public interface TableCellRenderer

此接口定义了要成为 JTable 中单元格渲染器的任意对象所需的方法。

方法摘要
 Component getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
返回用于绘制单元格的组件。

方法详细信息

getTableCellRendererComponent

Component getTableCellRendererComponent(JTable table,
                                        Object value,
                                        boolean isSelected,
                                        boolean hasFocus,
                                        int row,
                                        int column)
返回用于绘制单元格的组件。此方法用于在绘制前适当地配置渲染器。

TableCellRenderer 还负责呈现表示该表当前 DnD 放置位置的单元格（如果有）。如果此呈现器负责呈现 DnD 放置位置，则它应该直接查询表以确定给定的行和列是否表示放置位置：

     JTable.DropLocation dropLocation = table.getDropLocation();
     if (dropLocation != null
             && !dropLocation.isInsertRow()
             && !dropLocation.isInsertColumn()
             && dropLocation.getRow() == row
             && dropLocation.getColumn() == column) {

         // this cell represents the current drop location
         // so render it specially, perhaps with a different color
     }

在打印操作期间，将调用此方法（isSelected 和 hasFocus 为 false）阻止选择和焦点在打印输出中出现。要根据是否打印表进行其他定制，检查 JComponent.isPaintingForPrint() 的返回值。

参数：
table - 要求渲染器绘制的 JTable；可以为 null
value - 要呈现的单元格的值。由具体的渲染器解释和绘制该值。例如，如果 value 是字符串 "true"，则它可呈现为字符串，或者也可呈现为已选中的复选框。null 是有效值
isSelected - 如果使用选中样式的高亮显示来呈现该单元格，则为 true；否则为 false
hasFocus - 如果为 true，则适当地呈现单元格。例如，在单元格上放入特殊的边框，如果可以编辑该单元格，则以彩色呈现它，用于指示正在进行编辑
row - 要绘制的单元格的行索引。绘制头时，row 值是 -1
column - 要绘制的单元格的列索引
另请参见：
JComponent.isPaintingForPrint()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableColumn (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 TableColumn

java.lang.Object
    继承者  javax.swing.table.TableColumn
所有已实现的接口：
Serializable
public class TableColumn
extends Object
implements Serializable

TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。此外，TableColumn 还为显示和编辑此列中值的渲染器和编辑器提供了槽。

还可以基于每种类型，而不是每列来指定渲染器和编辑器，请参阅 JTable 类中的 setDefaultRenderer 方法。此默认机制仅用于 TableColumn 中的渲染器（或编辑器）为 null 的情况。

TableColumn 存储 JTable 中各列与 TableModel 中各列之间的链接。modelIndex 是 TableModel 中的列，要获得此列中单元格的数据值，可对 modelIndex 进行查询。在视图中移动列时，此 modelIndex 不更改。

注：某些实现可能假定所有 TableColumnModel 都是唯一的，因此我们建议不要多次将同一 TableColumn 实例添加到 TableColumnModel 中。要从模型中显示具有相同数据列的 TableColumn，可创建具有相同 modelIndex 的新实例。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
TableColumnModel,
DefaultTableColumnModel,
JTableHeader.getDefaultRenderer(),
JTable.getDefaultRenderer(Class),
JTable.getDefaultEditor(Class),
JTable.getCellRenderer(int, int),
JTable.getCellEditor(int, int)

字段摘要
static String | CELL_RENDERER_PROPERTY 从 Java 2 platform v1.3 开始已过时。
protected TableCellEditor | cellEditor 用于编辑列的数据单元格的编辑器。
protected TableCellRenderer | cellRenderer 用于绘制列的数据单元格的渲染器。
static String | COLUMN_WIDTH_PROPERTY 从 Java 2 platform v1.3 开始已过时。
static String | HEADER_RENDERER_PROPERTY 从 Java 2 platform v1.3 开始已过时。
static String | HEADER_VALUE_PROPERTY 从 Java 2 platform v1.3 开始已过时。
protected TableCellRenderer | headerRenderer 用于绘制列标题的渲染器。
protected Object | headerValue 列的标题值。
protected Object | identifier 根据 JTable 的绘制机制，此对象不会在内部使用；可在 TableColumn 中设置标识符，并将其作为标记和定位表列的可选方式。
protected boolean | isResizable 如果为 true，则允许用户调整列的大小；默认值为 true。
protected int | maxWidth 列的最大宽度。
protected int | minWidth 列的最小宽度。
protected int | modelIndex 模型中的列索引，通过此 TableColumn 显示该模型。
protected int | resizedPostingDisableCount 已过时。 从 Java 2 platform v1.3 开始
protected int | width 列的宽度。
构造方法摘要
TableColumn()
覆盖方法，它使用的默认模型索引为 0、默认宽度为 75、渲染器为 null、编辑器为 null。
TableColumn(int modelIndex)
覆盖方法，它使用的默认宽度为 75、渲染器为 null、编辑器为 null。
TableColumn(int modelIndex, int width)
覆盖方法，它使用的渲染器为 null、编辑器为 null 。
TableColumn(int modelIndex, int width, TableCellRenderer cellRenderer, TableCellEditor cellEditor)
使用指定的模型索引、宽度、单元格渲染器、单元格编辑器创建并初始化 TableColumn 实例；所有 TableColumn 构造方法都委托给此方法。
方法摘要
 void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表中添加一个 PropertyChangeListener。
protected  TableCellRenderer createDefaultHeaderRenderer()
从 Java 2 platform v1.3 开始，TableColumn 构造方法不再调用此方法。
 void disableResizedPosting()
已过时。 从 Java 2 platform v1.3 开始
 void enableResizedPosting()
已过时。 从 Java 2 platform v1.3 开始
 TableCellEditor getCellEditor()
返回 JTable 用于编辑此列各值的 TableCellEditor。
 TableCellRenderer getCellRenderer()
返回 JTable 用于绘制此列各值的 TableCellRenderer。
 TableCellRenderer getHeaderRenderer()
返回用于绘制 TableColumn 标题的 TableCellRenderer。
 Object getHeaderValue()
返回用作标题渲染器值的 Object。
 Object getIdentifier()
返回此列的 identifier 对象。
 int getMaxWidth()
返回 TableColumn 的最大宽度。
 int getMinWidth()
返回 TableColumn 的最小宽度。
 int getModelIndex()
返回此列的模型索引。
 int getPreferredWidth()
返回 TableColumn 的首选宽度。
 PropertyChangeListener[] getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 TableColumn 的所有 PropertyChangeListener 组成的数组。
 boolean getResizable()
如果允许用户调整 TableColumn 的宽度，则返回 true；否则返回 false。
 int getWidth()
返回该 TableColumn 的宽度。
 void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表中移除一个 PropertyChangeListener。
 void setCellEditor(TableCellEditor cellEditor)
设置编辑此列中单元格时所用的编辑器。
 void setCellRenderer(TableCellRenderer cellRenderer)
设置 JTable 用于绘制此列各值的 TableCellRenderer。
 void setHeaderRenderer(TableCellRenderer headerRenderer)
将用于绘制 TableColumn 的标题的 TableCellRenderer 设置为 headerRenderer。
 void setHeaderValue(Object headerValue)
设置 Object，将使用其字符串表示形式作为 headerRenderer 的值。
 void setIdentifier(Object identifier)
将 TableColumn 的标识符设置为 anIdentifier。
 void setMaxWidth(int maxWidth)
将 TableColumn 的最大宽度设置为 maxWidth；如果 maxWidth 小于最小宽度，则设置为最小宽度。
 void setMinWidth(int minWidth)
将 TableColumn 的最小宽度设置为 minWidth，如有必要，调整新的最小宽度以确保 0 <= minWidth <= maxWidth。
 void setModelIndex(int modelIndex)
设置此列的模型索引。
 void setPreferredWidth(int preferredWidth)
将此列的首选宽度设置为 preferredWidth。
 void setResizable(boolean isResizable)
设置是否可以调整此列的大小。
 void setWidth(int width)
不应使用此方法来设置 JTable 中列的宽度，而应使用 setPreferredWidth。
 void sizeWidthToFit()
调整 TableColumn 的大小，以适合其标题单元格的宽度。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

COLUMN_WIDTH_PROPERTY

public static final String COLUMN_WIDTH_PROPERTY
从 Java 2 platform v1.3 开始已过时。请使用 string 字面值来标识属性。

另请参见：
常量字段值

HEADER_VALUE_PROPERTY

public static final String HEADER_VALUE_PROPERTY
从 Java 2 platform v1.3 开始已过时。请使用 string 字面值来标识属性。

另请参见：
常量字段值

HEADER_RENDERER_PROPERTY

public static final String HEADER_RENDERER_PROPERTY
从 Java 2 platform v1.3 开始已过时。请使用 string 字面值来标识属性。

另请参见：
常量字段值

CELL_RENDERER_PROPERTY

public static final String CELL_RENDERER_PROPERTY
从 Java 2 platform v1.3 开始已过时。请使用 string 字面值来标识属性。

另请参见：
常量字段值

modelIndex

protected int modelIndex
模型中的列索引，通过此 TableColumn 显示该模型。在视图中移动列时，modelIndex 保持不变。

identifier

protected Object identifier
根据 JTable 的绘制机制，此对象不会在内部使用；可在 TableColumn 中设置标识符，并将其作为标记和定位表列的可选方式。table 包只修改或调用这些标识符对象中的 equals 方法，该方法用于 DefaultTableColumnModel 中的 getColumnIndex() 方法中。

width

protected int width
列的宽度。

minWidth

protected int minWidth
列的最小宽度。

maxWidth

protected int maxWidth
列的最大宽度。

headerRenderer

protected TableCellRenderer headerRenderer
用于绘制列标题的渲染器。

headerValue

protected Object headerValue
列的标题值。

cellRenderer

protected TableCellRenderer cellRenderer
用于绘制列的数据单元格的渲染器。

cellEditor

protected TableCellEditor cellEditor
用于编辑列的数据单元格的编辑器。

isResizable

protected boolean isResizable
如果为 true，则允许用户调整列的大小；默认值为 true。

resizedPostingDisableCount

@Deprecated
protected transient int resizedPostingDisableCount
已过时。 从 Java 2 platform v1.3 开始
在以前的版本中不使用此字段，并且当前也没有计划以后支持它。

构造方法详细信息

TableColumn

public TableColumn()
覆盖方法，它使用的默认模型索引为 0、默认宽度为 75、渲染器为 null、编辑器为 null。此方法用于进行序列化。

另请参见：
TableColumn(int, int, TableCellRenderer, TableCellEditor)

TableColumn

public TableColumn(int modelIndex)
覆盖方法，它使用的默认宽度为 75、渲染器为 null、编辑器为 null。

另请参见：
TableColumn(int, int, TableCellRenderer, TableCellEditor)

TableColumn

public TableColumn(int modelIndex,
                   int width)
覆盖方法，它使用的渲染器为 null、编辑器为 null 。

另请参见：
TableColumn(int, int, TableCellRenderer, TableCellEditor)

TableColumn

public TableColumn(int modelIndex,
                   int width,
                   TableCellRenderer cellRenderer,
                   TableCellEditor cellEditor)
使用指定的模型索引、宽度、单元格渲染器、单元格编辑器创建并初始化 TableColumn 实例；所有 TableColumn 构造方法都委托给此方法。width 的值用于初始宽度和首选宽度；如果 width 为负，则将它们设置为 0。将最小宽度设置为 15，如果初始宽度更小，则将最小宽度设置为初始宽度的值。

当 cellRenderer 或 cellEditor 参数为 null 时，由 JTable 的 getDefaultRenderer 或 getDefaultEditor 方法提供的默认值分别用于根据此列中数据的类型来提供默认的渲染器和编辑器。通过重写 JTable 中的 getCellRenderer 方法可回避这种以列为中心的呈现策略。

参数：
modelIndex - 模型中列的索引，该模型提供表中此列的数据；即使列在视图中重新排序，该模型索引依然不变
width - 此列的首选宽度和初始宽度
cellRenderer - 用于呈现此列中值的对象
cellEditor - 用于编辑此列中值的对象
另请参见：
getMinWidth(),
JTable.getDefaultRenderer(Class),
JTable.getDefaultEditor(Class),
JTable.getCellRenderer(int, int),
JTable.getCellEditor(int, int)
方法详细信息

setModelIndex

public void setModelIndex(int modelIndex)
设置此列的模型索引。模型索引是模型中此 TableColumn 将要显示的列的索引。TableColumn 在视图中移动时，该模型索引保持不变。

参数：
modelIndex - 新的 modelIndex

getModelIndex

public int getModelIndex()
返回此列的模型索引。

返回：
modelIndex 属性

setIdentifier

public void setIdentifier(Object identifier)
将 TableColumn 的标识符设置为 anIdentifier。

注：JTable 不使用标识符，它们只是为了便于外部标记和标识列的位置。

参数：
identifier - 此列的标识符
另请参见：
getIdentifier()

getIdentifier

public Object getIdentifier()
返回此列的 identifier 对象。注意，JTable 不使用标识符，它们只是为了便于外部使用。如果 identifier 为 null，则 getIdentifier() 返回 getHeaderValue 作为默认值。

返回：
identifier 属性
另请参见：
setIdentifier(java.lang.Object)

setHeaderValue

public void setHeaderValue(Object headerValue)
设置 Object，将使用其字符串表示形式作为 headerRenderer 的值。创建 TableColumn 时，默认的 headerValue 为 null。

参数：
headerValue - 新的 headerValue
另请参见：
getHeaderValue()

getHeaderValue

public Object getHeaderValue()
返回用作标题渲染器值的 Object。

返回：
headerValue 属性
另请参见：
setHeaderValue(java.lang.Object)

setHeaderRenderer

public void setHeaderRenderer(TableCellRenderer headerRenderer)
将用于绘制 TableColumn 的标题的 TableCellRenderer 设置为 headerRenderer。

标题渲染器负责呈现排序指示符。如果正在使用排序并指定了渲染器，则此渲染器必须呈现排序指示。

参数：
headerRenderer - 新的 headerRenderer
另请参见：
getHeaderRenderer()

getHeaderRenderer

public TableCellRenderer getHeaderRenderer()
返回用于绘制 TableColumn 标题的 TableCellRenderer。headerRenderer 为 null 时，JTableHeader 使用其 defaultRenderer。headerRenderer 的默认值为 null。

返回：
headerRenderer 属性
另请参见：
setHeaderRenderer(javax.swing.table.TableCellRenderer),
setHeaderValue(java.lang.Object),
JTableHeader.getDefaultRenderer()

setCellRenderer

public void setCellRenderer(TableCellRenderer cellRenderer)
设置 JTable 用于绘制此列各值的 TableCellRenderer。

参数：
cellRenderer - 新的 cellRenderer
另请参见：
getCellRenderer()

getCellRenderer

public TableCellRenderer getCellRenderer()
返回 JTable 用于绘制此列各值的 TableCellRenderer。列的 cellRenderer 不仅控制着该列的可视外观，而且还用于解释 TableModel 所提供的值对象。cellRenderer 为 null 时，JTable 根据该列中单元格的类来使用默认的编辑器。cellRenderer 的默认值为 null。

返回：
cellRenderer 属性
另请参见：
setCellRenderer(javax.swing.table.TableCellRenderer), JTable.setDefaultRenderer(java.lang.Class, javax.swing.table.TableCellRenderer)

setCellEditor

public void setCellEditor(TableCellEditor cellEditor)
设置编辑此列中单元格时所用的编辑器。

参数：
cellEditor - 新的 cellEditor
另请参见：
getCellEditor()

getCellEditor

public TableCellEditor getCellEditor()
返回 JTable 用于编辑此列各值的 TableCellEditor。cellEditor 为 null 时，JTable 根据该列中单元格的类来使用默认的渲染器。cellEditor 的默认值为 null。

返回：
cellEditor 属性
另请参见：
setCellEditor(javax.swing.table.TableCellEditor), JTable.setDefaultEditor(java.lang.Class, javax.swing.table.TableCellEditor)

setWidth

public void setWidth(int width)
不应使用此方法来设置 JTable 中列的宽度，而应使用 setPreferredWidth。与 AWT 中的布局管理器类似，在表本身更改大小时，或者更改列的首选宽度时，JTable 会自动调整列的宽度。因此，以编程方式设置宽度没有长期的效果。

此方法将此列的宽度设置为 width。如果 width 超出最小或最大宽度，则将其调整为合适的界限值。

参数：
width - 新宽度
另请参见：
getWidth(), setMinWidth(int), setMaxWidth(int), setPreferredWidth(int), JTable.doLayout()

getWidth

public int getWidth()
返回该 TableColumn 的宽度。默认宽度为 75。

返回：
width 属性
另请参见：
setWidth(int)

setPreferredWidth

public void setPreferredWidth(int preferredWidth)
将此列的首选宽度设置为 preferredWidth。如果 preferredWidth 超出最小或最大宽度，则将其调整为合适的界限值。

有关如何根据 preferredWidth 计算 JTable（和 JTableHeader）中列宽度的细节，请参见 JTable 中的 doLayout 方法。

参数：
preferredWidth - 新的首选宽度
另请参见：
getPreferredWidth(), JTable.doLayout()

getPreferredWidth

public int getPreferredWidth()
返回 TableColumn 的首选宽度。默认首选宽度为 75。

返回：
preferredWidth 属性
另请参见：
setPreferredWidth(int)

setMinWidth

public void setMinWidth(int minWidth)
将 TableColumn 的最小宽度设置为 minWidth，如有必要，调整新的最小宽度以确保 0 <= minWidth <= maxWidth。例如，如果 minWidth 参数为负，则此方法将 minWidth 属性设置为 0。

如果 width 或 preferredWidth 属性的值小于新的最小宽度，则此方法将该属性设置为新的最小宽度。

参数：
minWidth - 新的最小宽度
另请参见：
getMinWidth(), setPreferredWidth(int), setMaxWidth(int)

getMinWidth

public int getMinWidth()
返回 TableColumn 的最小宽度。不能通过用户或编程的方式将 TableColumn 的宽度设置为小于此值。

返回：
minWidth 属性
另请参见：
setMinWidth(int), TableColumn(int, int, TableCellRenderer, TableCellEditor)

setMaxWidth

public void setMaxWidth(int maxWidth)
将 TableColumn 的最大宽度设置为 maxWidth；如果 maxWidth 小于最小宽度，则设置为最小宽度。

如果 width 或 preferredWidth 属性的值大于新的最大宽度，则此方法将该属性设置为新的最大宽度。

参数：
maxWidth - 新的最大宽度
另请参见：
getMaxWidth(), setPreferredWidth(int), setMinWidth(int)

getMaxWidth

public int getMaxWidth()
返回 TableColumn 的最大宽度。不能通过用户或编程的方式将 TableColumn 的宽度设置为大于此值。默认的 maxWidth 为 Integer.MAX_VALUE。

返回：
maxWidth 属性
另请参见：
setMaxWidth(int)

setResizable

public void setResizable(boolean isResizable)
设置是否可以调整此列的大小。

参数：
isResizable - 如果为 true，则允许调整大小；否则为 false
另请参见：
getResizable()

getResizable

public boolean getResizable()
如果允许用户调整 TableColumn 的宽度，则返回 true；否则返回 false。无论此设置是什么，都可以通过编程方式更改宽度。默认值为 true。

返回：
isResizable 属性
另请参见：
setResizable(boolean)

sizeWidthToFit

public void sizeWidthToFit()
调整 TableColumn 的大小，以适合其标题单元格的宽度。如果标题渲染器为 null（默认情况如此），则此方法不执行任何操作。否则，此方法将此列的最小、最大和首选宽度设置为标题渲染器所传递的 Component 的最小、最大和首选大小。此 TableColumn 的瞬态 "width" 属性也设置为首选宽度。注意，table 包不会在内部使用此方法。

另请参见：
setPreferredWidth(int)

disableResizedPosting

@Deprecated
public void disableResizedPosting()
已过时。 从 Java 2 platform v1.3 开始

在以前的版本中不使用此字段，并且当前也没有计划以后支持它。

enableResizedPosting

@Deprecated
public void enableResizedPosting()
已过时。 从 Java 2 platform v1.3 开始

在以前的版本中不使用此字段，并且当前也没有计划以后支持它它。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表中添加一个 PropertyChangeListener。该侦听器是为所有属性注册的。

响应对当前组件上 setFont、setBackground 或 setForeground 的显式调用时，将触发一个 PropertyChangeEvent。注意，如果当前组件将继承其容器的前景、背景或字体，则在响应所继承属性中的更改时不会触发任何事件。

参数：
listener - 要添加的侦听器

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表中移除一个 PropertyChangeListener。所移除的 PropertyChangeListener 是为所有属性注册的。

参数：
listener - 要移除的侦听器

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 TableColumn 的所有 PropertyChangeListener 组成的数组。

返回：
添加的所有 PropertyChangeListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

createDefaultHeaderRenderer

protected TableCellRenderer createDefaultHeaderRenderer()
从 Java 2 platform v1.3 开始，TableColumn 构造方法不再调用此方法。以前 TableColumn 使用此方法来创建默认的标题渲染器。从 Java 2 platform v1.3 开始，默认的标题渲染器为 null。JTableHeader 现在提供其自己的共享默认渲染器，就像 JTable 为其单元格渲染器所提供的。

返回：
默认的标题渲染器
另请参见：
JTableHeader.createDefaultRenderer()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableColumnModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
接口 TableColumnModel

所有已知实现类：
DefaultTableColumnModel
public interface TableColumnModel

定义了适合用于 JTable 的表列模型对象的要求。

另请参见：
DefaultTableColumnModel

方法摘要
void | addColumn(TableColumn aColumn) 将 aColumn 追加到 tableColumns 数组的结尾。
void | addColumnModelListener(TableColumnModelListener x) 为表列模型事件添加侦听器。
TableColumn | getColumn(int columnIndex) 返回 columnIndex 位置列的 TableColumn 对象。
int | getColumnCount() 返回该模型中的列数。
int | getColumnIndex(Object columnIdentifier) 返回该表中首列的索引，使用 equals 进行比较时，该列的标识符等于 identifier。
int | getColumnIndexAtX(int xPosition) 返回位于该水平点 xPosition 位置列的索引；如果该点位于任何列边界外，则返回 -1。
int | getColumnMargin() 返回每列中单元格之间的宽度。
Enumeration<TableColumn> | getColumns() 返回该模型中所有列的 Enumeration。
boolean | getColumnSelectionAllowed() 如果可以选择列，则返回 true。
int | getSelectedColumnCount() 返回选定的列数。
int[] | getSelectedColumns() 返回所有选定列的索引数组。
ListSelectionModel | getSelectionModel() 返回当前的选择模型。
int | getTotalColumnWidth() 返回所有列的总宽度。
void | moveColumn(int columnIndex, int newIndex) 将 columnIndex 位置的列及其头移至 newIndex。
void | removeColumn(TableColumn column) 从 tableColumns 数组中删除 TableColumn column。
void | removeColumnModelListener(TableColumnModelListener x) 移除表列模型事件的侦听器。
void | setColumnMargin(int newMargin) 将 TableColumn 的列空白设置为 newMargin。
void | setColumnSelectionAllowed(boolean flag) 设置是否可以选择此模型中的列。
void | setSelectionModel(ListSelectionModel newModel) 设置选择模型。

方法详细信息

addColumn

void addColumn(TableColumn aColumn)
将 aColumn 追加到 tableColumns 数组的结尾。此方法向其侦听器发送一个 columnAdded 事件。

参数：
aColumn - 要添加的 TableColumn
另请参见：
removeColumn(javax.swing.table.TableColumn)

removeColumn

void removeColumn(TableColumn column)
从 tableColumns 数组中删除 TableColumn column。如果 column 不处于该表各列的列表中，则此方法不执行任何操作。此方法向其侦听器发送一个 columnRemoved 事件。

参数：
column - 要移除的 TableColumn
另请参见：
addColumn(javax.swing.table.TableColumn)

moveColumn

void moveColumn(int columnIndex,
                int newIndex)
将 columnIndex 位置的列及其头移至 newIndex。原位于 columnIndex 位置的列现在将在 newIndex 处找到。将原位于 newIndex 位置的列向左或向右移动以留出空间。如果 columnIndex 等于 newIndex，则不移动任何列。此方法向其侦听器发送一个 columnMoved 事件。

参数：
columnIndex - 要移动的列的索引
newIndex - 该列新位置的索引
抛出：
IllegalArgumentException - 如果 columnIndex 或 newIndex 不在有效范围内

setColumnMargin

void setColumnMargin(int newMargin)
将 TableColumn 的列空白设置为 newMargin。此方法向其侦听器发送一个 columnMarginChanged 事件。

参数：
newMargin - 新列空白的宽度，以像素为单位
另请参见：
getColumnMargin()

getColumnCount

int getColumnCount()
返回该模型中的列数。

返回：
该模型中的列数

getColumns

Enumeration<TableColumn> getColumns()
返回该模型中所有列的 Enumeration。

返回：
该模型中所有列的 Enumeration

getColumnIndex

int getColumnIndex(Object columnIdentifier)
返回该表中首列的索引，使用 equals 进行比较时，该列的标识符等于 identifier。

参数：
columnIdentifier - 标识符对象
返回：
首个表列的索引，其标识符等于 identifier
抛出：
IllegalArgumentException - 如果 identifier 为 null，或者没有 TableColumn 具有此 identifier
另请参见：
getColumn(int)

getColumn

TableColumn getColumn(int columnIndex)
返回 columnIndex 位置列的 TableColumn 对象。

参数：
columnIndex - 所需列的索引
返回：
columnIndex 位置列的 TableColumn 对象

getColumnMargin

int getColumnMargin()
返回每列中单元格之间的宽度。

返回：
单元格之间的空白，以像素为单位

getColumnIndexAtX

int getColumnIndexAtX(int xPosition)
返回位于该水平点 xPosition 位置列的索引；如果该点位于任何列边界外，则返回 -1。 在维护 Swing 的可分离模型架构的过程中，TableColumnModel 并不了解表的各列实际出现在屏幕上的方式。列的虚拟展示由使用此模型（通常是 JTable）的 view/controller 对象负责。view/controller 不必从左到右按顺序显示这些列。例如，为了适应语言环境的优先选择，可以从右到左显示各列，或者可能根据用户的请求隐藏某些列。因为该模型不了解各列在屏幕上的排列方式，所以不应将给定的 xPosition 考虑为 2D 图形空间中的坐标。相反，应将其考虑为从模型中第一列开始的宽度。如果要求 2D 空间中给定 X 坐标的列索引，则可以使用 JTable.columnAtPoint。

返回：
列的索引；如果无法找到列，则返回 -1
另请参见：
JTable.columnAtPoint(java.awt.Point)

getTotalColumnWidth

int getTotalColumnWidth()
返回所有列的总宽度。

返回：
计算出的所有列的总宽度

setColumnSelectionAllowed

void setColumnSelectionAllowed(boolean flag)
设置是否可以选择此模型中的列。

参数：
flag - 如果可以选择列，则为 true；否则为 false
另请参见：
getColumnSelectionAllowed()

getColumnSelectionAllowed

boolean getColumnSelectionAllowed()
如果可以选择列，则返回 true。

返回：
如果可以选择列，则返回 true
另请参见：
setColumnSelectionAllowed(boolean)

getSelectedColumns

int[] getSelectedColumns()
返回所有选定列的索引数组。

返回：
包含所有选定列索引的整数数组；如果没有选定的列，则返回一个空数组

getSelectedColumnCount

int getSelectedColumnCount()
返回选定的列数。

返回：
选定的列数；如果没有选定的列，则返回 0

setSelectionModel

void setSelectionModel(ListSelectionModel newModel)
设置选择模型。

参数：
newModel - ListSelectionModel 对象
另请参见：
getSelectionModel()

getSelectionModel

ListSelectionModel getSelectionModel()
返回当前的选择模型。

返回：
ListSelectionModel 对象
另请参见：
setSelectionModel(javax.swing.ListSelectionModel)

addColumnModelListener

void addColumnModelListener(TableColumnModelListener x)
为表列模型事件添加侦听器。

参数：
x - TableColumnModelListener 对象

removeColumnModelListener

void removeColumnModelListener(TableColumnModelListener x)
移除表列模型事件的侦听器。

参数：
x - TableColumnModelListener 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
接口 TableModel

所有已知实现类：
AbstractTableModel, DefaultTableModel
public interface TableModel

TableModel 接口指定了 JTable 用于询问表格式数据模型的方法。

只要数据模型实现了 TableModel 接口，就可以通过以下两行代码设置 JTable 显示该模型：

        TableModel myData = new MyTableModel();
        JTable table = new JTable(myData);

有关进一步的文档，请参见 The Java Tutorial 中的 Creating a Table Model 一节。

另请参见：
JTable

方法摘要
void | addTableModelListener(TableModelListener l) 每当数据模型发生更改时，就将一个侦听器添加到被通知的列表中。
Class<?> | getColumnClass(int columnIndex) 针对列中所有的单元格值，返回最具体的超类。
int | getColumnCount() 返回该模型中的列数。
String | getColumnName(int columnIndex) 返回 columnIndex 位置的列的名称。
int | getRowCount() 返回该模型中的行数。
Object | getValueAt(int rowIndex, int columnIndex) 返回 columnIndex 和 rowIndex 位置的单元格值。
boolean | isCellEditable(int rowIndex, int columnIndex) 如果 rowIndex 和 columnIndex 位置的单元格是可编辑的，则返回 true。
void | removeTableModelListener(TableModelListener l) 每当数据模型发生更改时，就从被通知的列表中移除一个侦听器。
void | setValueAt(Object aValue, int rowIndex, int columnIndex) 将 columnIndex 和 rowIndex 位置的单元格中的值设置为 aValue。

方法详细信息

getRowCount

int getRowCount()
返回该模型中的行数。JTable 使用此方法来确定它应该显示多少行。此方法应该是快速执行的，因为在呈现期间会经常调用它。

返回：
该模型中的行数
另请参见：
getColumnCount()

getColumnCount

int getColumnCount()
返回该模型中的列数。JTable 使用此方法来确定在默认情况下它应该创建并显示多少列。

返回：
该模型中的列数
另请参见：
getRowCount()

getColumnName

String getColumnName(int columnIndex)
返回 columnIndex 位置的列的名称。这用于初始化该表的列头名。注：此名称不必是惟一的；表中的两列可以具有相同的名称。

参数：
columnIndex - 列的索引
返回：
列的名称

getColumnClass

Class<?> getColumnClass(int columnIndex)
针对列中所有的单元格值，返回最具体的超类。JTable 使用此方法来设置列的默认渲染器和编辑器。

参数：
columnIndex - 列的索引
返回：
模型中对象值的公共祖先类。

isCellEditable

boolean isCellEditable(int rowIndex,
                       int columnIndex)
如果 rowIndex 和 columnIndex 位置的单元格是可编辑的，则返回 true。否则，在该单元格上调用 setValueAt 不会更改该单元格的值。

参数：
rowIndex - 要查询的值所在行
columnIndex - 要查询的值所在列
返回：
如果该单元格是可编辑的，则返回 true
另请参见：
setValueAt(java.lang.Object, int, int)

getValueAt

Object getValueAt(int rowIndex,
                  int columnIndex)
返回 columnIndex 和 rowIndex 位置的单元格值。

参数：
rowIndex - 要查询的值所在行
columnIndex - 要查询的值所在列
返回：
指定单元格位置的值 Object

setValueAt

void setValueAt(Object aValue,
                int rowIndex,
                int columnIndex)
将 columnIndex 和 rowIndex 位置的单元格中的值设置为 aValue。

参数：
aValue - 新值
rowIndex - 要更改的值所在行
columnIndex - 要更改的值所在列
另请参见：
getValueAt(int, int), isCellEditable(int, int)

addTableModelListener

void addTableModelListener(TableModelListener l)
每当数据模型发生更改时，就将一个侦听器添加到被通知的列表中。

参数：
l - TableModelListener

removeTableModelListener

void removeTableModelListener(TableModelListener l)
每当数据模型发生更改时，就从被通知的列表中移除一个侦听器。

参数：
l - TableModelListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableRowSorter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 TableRowSorter<M extends TableModel>

java.lang.Object
    继承者  javax.swing.RowSorter<M>
        继承者  javax.swing.DefaultRowSorter<M,Integer>
            继承者  javax.swing.table.TableRowSorter<M>
类型参数：
M - 模型的类型，必须为 TableModel 的一个实现
public class TableRowSorter<M extends TableModel>
extends DefaultRowSorter<M,Integer>

RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。下面的例子显示了向 JTable 添加排序操作：

TableModel myModel = createMyTableModel();
JTable table = new JTable(myModel);
table.setRowSorter(new TableRowSorter(myModel));
此类将完成所有连线操作（wiring），从而当用户做出适当的行为（比如单击列标题）时，表将进行直观的排序。

JTable 的基于行的方法和 JTable 的选择模型引用视图而不是底层模型。因此，有必要在两者之前进行转换。例如，要获取基于 myModel 的选择，需要转换索引：

int[] selection = table.getSelectedRows();
for (int i = 0; i < selection.length; i++) {
selection[i] = table.convertRowIndexToModel(selection[i]);
   }
类似地，要在基于底层模型坐标的 JTable 中选择一行，执行以下相反的操作：
table.setRowSelectionInterval(table.convertRowIndexToView(row),
table.convertRowIndexToView(row));

前一个例子假定不能进行过滤操作。如果能够进行过滤,则对于在视图中不可见的位置，convertRowIndexToView 将返回 -1。

TableRowSorter 使用 Comparator 进行比较。下文定义了如何为列选择 Comparator：

  1. 如果已经通过 setComparator 方法为列指定了 Comparator，则使用它。
  2. 如果 getColumnClass 返回的列类是 String，则使用 Collator.getInstance() 返回的 Comparator。
  3. 如果列类实现 Comparable，则使用调用 compareTo 方法的 Comparator。
  4. 如果已经指定了 TableStringConverter，则使用它将值转换为 String，然后使用 Collator.getInstance() 返回的 Comparator。
  5. 否则，先在对象上调用 toString，再对结果调用 Collator.getInstance()，使用所返回的 Comparator。

除了排序操作，TableRowSorter 还提供过滤操作。使用 setFilter 方法指定过滤器。下例将只显示包含字符串“foo”的行：

TableModel myModel = createMyTableModel();
TableRowSorter sorter = new TableRowSorter(myModel);
sorter.setRowFilter(RowFilter.regexFilter(".*foo.*"));
JTable table = new JTable(myModel);
table.setRowSorter(sorter);

如果底层模型结构发生了更改（调用了 modelStructureChanged 方法），则以下值将被重置为其默认值：列的 Comparator，当前排序顺序以及每一列是否可排序。默认的排序顺序是自然排序（与模型相同），并且默认情况下列是可排序的。

TableRowSorter 有一个形式类型参数：模型的类型。传入完全对应于模型的类型允许基于模型进行过滤，而无需强制转换。有关此情况的例子，请参阅 RowFilter 文档。

警告： DefaultTableModel 返回 Object 的列类。这种情况下将使用 toString 完成所有比较。这将产生不必要的昂贵开销。如果列只包含一种值类型，比如 Integer，则应该重写 getColumnClass 并返回适当的 Class。这将明显增强此类的性能。

从以下版本开始：
1.6
另请参见：
JTable, RowFilter, DefaultTableModel, Collator, Comparator

嵌套类摘要
从类 javax.swing.DefaultRowSorter 继承的嵌套类/接口
DefaultRowSorter.ModelWrapper<M,I>
从类 javax.swing.RowSorter 继承的嵌套类/接口
RowSorter.SortKey
构造方法摘要
TableRowSorter()
使用空模型创建一个 TableRowSorter。
TableRowSorter(M model)
使用 model 作为底层 TableModel 创建一个 TableRowSorter。
方法摘要
Comparator<?> | getComparator(int column) 返回指定列的 Comparator。
TableStringConverter | getStringConverter() 返回负责将值从模型转换为字符串的对象。
void | setModel(M model) 将 TableModel 设置为此 TableRowSorter 要使用的底层模型。
void | setStringConverter(TableStringConverter stringConverter) 设置负责将值从模型转换为字符串的对象。
protected boolean | useToString(int column) 返回排序过程中进行比较之前是否要将值转换为字符串。
从类 javax.swing.DefaultRowSorter 继承的方法
allRowsChanged, convertRowIndexToModel, convertRowIndexToView, getMaxSortKeys, getModel, getModelRowCount, getModelWrapper, getRowFilter, getSortKeys, getSortsOnUpdates, getViewRowCount, isSortable, modelStructureChanged, rowsDeleted, rowsInserted, rowsUpdated, rowsUpdated, setComparator, setMaxSortKeys, setModelWrapper, setRowFilter, setSortable, setSortKeys, setSortsOnUpdates, sort, toggleSortOrder
从类 javax.swing.RowSorter 继承的方法
addRowSorterListener, fireRowSorterChanged, fireSortOrderChanged, removeRowSorterListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableRowSorter

public TableRowSorter()
使用空模型创建一个 TableRowSorter。

TableRowSorter

public TableRowSorter(M model)
使用 model 作为底层 TableModel 创建一个 TableRowSorter。

参数：
model - 要使用的底层 TableModel，null 被视为空模型。
方法详细信息

setModel

public void setModel(M model)
将 TableModel 设置为此 TableRowSorter 要使用的底层模型。可以用 null 值设置空模型。

参数：
model - 要使用的底层模型，或者 null

setStringConverter

public void setStringConverter(TableStringConverter stringConverter)
设置负责将值从模型转换为字符串的对象。如果为非 null，则此方法用于将所有不具有已注册 Comparator 的对象值转换为字符串。

参数：
stringConverter - 负责将值从模型转换为字符串的对象

getStringConverter

public TableStringConverter getStringConverter()
返回负责将值从模型转换为字符串的对象。

返回：
负责将值转换为字符串的对象。

getComparator

public Comparator<?> getComparator(int column)
返回指定列的 Comparator。如果没有使用 setComparator 方法指定 Comparator，那么将基于指定列的列类（TableModel.getColumnClass）返回 Comparator。如果列类为 String，则返回 Collator.getInstance。如果列类实现 Comparable，则返回调用 compareTo 方法的私有 Comparator。否则，返回 Collator.getInstance。

覆盖：
类 DefaultRowSorter<M extends TableModel,Integer> 中的 getComparator
参数：
column - 要获取 Comparator 的列，就底层模型而言
返回：
指定列的 Comparator
抛出：
IndexOutOfBoundsException - 如果 column 超出底层模型的范围

useToString

protected boolean useToString(int column)
返回排序过程中进行比较之前是否要将值转换为字符串。如果为 true，则将使用 ModelWrapper.getStringValueAt；否则，将使用 ModelWrapper.getValueAt。由子类（比如 TableRowSorter）决定是否在其 ModelWrapper 实现中遵守此值。

覆盖：
类 DefaultRowSorter<M extends TableModel,Integer> 中的 useToString
参数：
column - 要测试的列的索引，就底层模型而言
抛出：
IndexOutOfBoundsException - 如果 column 无效
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableStringConverter (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.table
类 TableStringConverter

java.lang.Object
    继承者  javax.swing.table.TableStringConverter

public abstract class TableStringConverter
extends Object

TableStringConverter 用于将对象从模型转换为字符串。当模型返回不具有有意义的 toString 实现的对象时，此类用于过滤和搜索操作。

从以下版本开始：
1.6

构造方法摘要
TableStringConverter()
方法摘要
abstract  String toString(TableModel model, int row, int column)
返回指定位置处值的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableStringConverter

public TableStringConverter()
方法详细信息

toString

public abstract String toString(TableModel model,
                                int row,
                                int column)
返回指定位置处值的字符串表示形式。

参数：
model - 要从中获取值的 TableModel
row - 向其请求字符串的行
column - 向其请求字符串的列
返回：
字符串表示形式。此方法不返回 null。
抛出：
NullPointerException - 如果 model 为 null
IndexOutOfBoundsException - 如果参数超出模型的范围
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.table (Java Platform SE 6)

 javax.swing.table
接口
TableCellEditor
TableCellRenderer
TableColumnModel
TableModel
类
AbstractTableModel
DefaultTableCellRenderer
DefaultTableCellRenderer.UIResource
DefaultTableColumnModel
DefaultTableModel
JTableHeader
TableColumn
TableRowSorter
TableStringConverter


javax.swing.table (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.table

提供用于处理 javax.swing.JTable 的类和接口。

请参见：
描述

接口摘要
TableCellEditor | 此接口定义了要成为组件（如 JListBox、JComboBox、JTree 或 JTable）的值编辑器的任意对象需要实现的方法。
TableCellRenderer | 此接口定义了要成为 JTable 中单元格渲染器的任意对象所需的方法。
TableColumnModel | 定义了适合用于 JTable 的表列模型对象的要求。
TableModel | TableModel 接口指定了 JTable 用于询问表格式数据模型的方法。

类摘要
AbstractTableModel | 此抽象类为 TableModel 接口中的大多数方法提供默认实现。
DefaultTableCellRenderer | 呈现（显示） JTable 中每个单元格的标准类。
DefaultTableCellRenderer.UIResource | DefaultTableCellRenderer 的一个子类，它实现 UIResource。
DefaultTableColumnModel | JTable 的标准列处理程序。
DefaultTableModel | 这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。
JTableHeader | 这是管理 JTable 的头的对象。
TableColumn | TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。
TableRowSorter<M extends TableModel> | RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。
TableStringConverter | TableStringConverter 用于将对象从模型转换为字符串。

软件包 javax.swing.table 的描述

提供用于处理 javax.swing.JTable 的类和接口。JTable 是 Swing 的网格或表格视图，用于为应用程序内的表格数据结构构造用户界面。如果您想控制如何构造、更新和呈现这些表，以及如何显示和管理与该表关联的数据，请使用此包。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • The Java Tutorial 中的 How to Use Tables 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.table 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.table 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • javax.swing.table.DefaultTableModel (implements java.io.Serializable)
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.table.JTableHeader.AccessibleJTableHeader
      • javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.table.DefaultTableCellRenderer (implements java.io.Serializable, javax.swing.table.TableCellRenderer)
              • javax.swing.table.DefaultTableCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
          • javax.swing.table.JTableHeader (implements javax.accessibility.Accessible, javax.swing.event.TableColumnModelListener)
    • javax.swing.table.DefaultTableColumnModel (implements javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, java.io.Serializable, javax.swing.table.TableColumnModel)
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,I>
        • javax.swing.table.TableRowSorter<M>
    • javax.swing.table.TableColumn (implements java.io.Serializable)
    • javax.swing.table.TableStringConverter

接口分层结构

  • javax.swing.CellEditor
    • javax.swing.table.TableCellEditor
  • javax.swing.table.TableCellRenderer
  • javax.swing.table.TableColumnModel
  • javax.swing.table.TableModel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.table 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.table
的使用

使用 javax.swing.table 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 使用的 javax.swing.table 中的类
JTableHeader
这是管理 JTable 的头的对象。
TableCellEditor
此接口定义了要成为组件（如 JListBox、JComboBox、JTree 或 JTable）的值编辑器的任意对象需要实现的方法。
TableCellRenderer
此接口定义了要成为 JTable 中单元格渲染器的任意对象所需的方法。
TableColumn
TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。
TableColumnModel
定义了适合用于 JTable 的表列模型对象的要求。
TableModel
TableModel 接口指定了 JTable 用于询问表格式数据模型的方法。

javax.swing.event 使用的 javax.swing.table 中的类
TableColumnModel
定义了适合用于 JTable 的表列模型对象的要求。
TableModel
TableModel 接口指定了 JTable 用于询问表格式数据模型的方法。

javax.swing.plaf.basic 使用的 javax.swing.table 中的类
JTableHeader
这是管理 JTable 的头的对象。

javax.swing.table 使用的 javax.swing.table 中的类
AbstractTableModel
此抽象类为 TableModel 接口中的大多数方法提供默认实现。
DefaultTableCellRenderer
呈现（显示） JTable 中每个单元格的标准类。
JTableHeader
这是管理 JTable 的头的对象。
TableCellEditor
此接口定义了要成为组件（如 JListBox、JComboBox、JTree 或 JTable）的值编辑器的任意对象需要实现的方法。
TableCellRenderer
此接口定义了要成为 JTable 中单元格渲染器的任意对象所需的方法。
TableColumn
TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。
TableColumnModel
定义了适合用于 JTable 的表列模型对象的要求。
TableModel
TableModel 接口指定了 JTable 用于询问表格式数据模型的方法。
TableStringConverter
TableStringConverter 用于将对象从模型转换为字符串。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.TableRowSorter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.TableRowSorter
的使用

没有 javax.swing.table.TableRowSorter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.TableStringConverter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.TableStringConverter
的使用

使用 TableStringConverter 的软件包
javax.swing.table 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.table 中 TableStringConverter 的使用

返回 TableStringConverter 的 javax.swing.table 中的方法
 TableStringConverter TableRowSorter.getStringConverter()
返回负责将值从模型转换为字符串的对象。

参数类型为 TableStringConverter 的 javax.swing.table 中的方法
 void TableRowSorter.setStringConverter(TableStringConverter stringConverter)
设置负责将值从模型转换为字符串的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.DefaultTableModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.DefaultTableModel
的使用

没有 javax.swing.table.DefaultTableModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.DefaultTableColumnModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.DefaultTableColumnModel
的使用

没有 javax.swing.table.DefaultTableColumnModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.table.TableColumnModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.table.TableColumnModel
的使用

使用 TableColumnModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableColumnModel 的使用

声明为 TableColumnModel 的 javax.swing 中的字段
protected  TableColumnModel JTable.columnModel
表的 TableColumnModel。

返回 TableColumnModel 的 javax.swing 中的方法
protected TableColumnModel | JTable.createDefaultColumnModel() 返回默认的列模型对象，它是一个 DefaultTableColumnModel。
TableColumnModel | JTable.getColumnModel() 返回包含此表所有列信息的 TableColumnModel。

参数类型为 TableColumnModel 的 javax.swing 中的方法
 void JTable.setColumnModel(TableColumnModel columnModel)
将此表的列模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。

参数类型为 TableColumnModel 的 javax.swing 中的构造方法
JTable(TableModel dm, TableColumnModel cm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和默认的选择模型对其进行初始化。
JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。

javax.swing.event 中 TableColumnModel 的使用

参数类型为 TableColumnModel 的 javax.swing.event 中的构造方法
TableColumnModelEvent(TableColumnModel source, int from, int to)
构造一个 TableColumnModelEvent 对象。

javax.swing.table 中 TableColumnModel 的使用

实现 TableColumnModel 的 javax.swing.table 中的类
 class DefaultTableColumnModel
JTable 的标准列处理程序。

声明为 TableColumnModel 的 javax.swing.table 中的字段
protected  TableColumnModel JTableHeader.columnModel
表头的 TableColumnModel。

返回 TableColumnModel 的 javax.swing.table 中的方法
protected TableColumnModel | JTableHeader.createDefaultColumnModel() 返回默认的列模型对象，它是 DefaultTableColumnModel。
TableColumnModel | JTableHeader.getColumnModel() 返回包含此表头所有列信息的 TableColumnModel。

参数类型为 TableColumnModel 的 javax.swing.table 中的方法
 void JTableHeader.setColumnModel(TableColumnModel columnModel)
将此表的列模型设置为 newModel，并向侦听器注册来自新列模型的通知。

参数类型为 TableColumnModel 的 javax.swing.table 中的构造方法
JTableHeader(TableColumnModel cm)
构造 JTableHeader，使用 cm 作为列模型对其进行初始化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.TableColumn 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.TableColumn
的使用

使用 TableColumn 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableColumn 的使用

返回 TableColumn 的 javax.swing 中的方法
 TableColumn JTable.getColumn(Object identifier)
返回表中列的 TableColumn 对象，当使用 equals 进行比较时，表的标识符等于 identifier。

参数类型为 TableColumn 的 javax.swing 中的方法
void | JTable.addColumn(TableColumn aColumn) 将 aColumn 追加到此 JTable 的列模型所保持的列数组的尾部。
void | JTable.removeColumn(TableColumn aColumn) 从此 JTable 的列数组中移除 aColumn。

javax.swing.table 中 TableColumn 的使用

声明为 TableColumn 的 javax.swing.table 中的字段
protected TableColumn | JTableHeader.draggedColumn 被拖动列的索引。
protected TableColumn | JTableHeader.resizingColumn 进行大小调整的列的索引。

类型参数类型为 TableColumn 的 javax.swing.table 中的字段
protected  Vector<TableColumn> DefaultTableColumnModel.tableColumns
此模型中 TableColumn 对象组成的数组

返回 TableColumn 的 javax.swing.table 中的方法
TableColumn | DefaultTableColumnModel.getColumn(int columnIndex) 返回 columnIndex 处列的 TableColumn 对象。
TableColumn | TableColumnModel.getColumn(int columnIndex) 返回 columnIndex 位置列的 TableColumn 对象。
TableColumn | JTableHeader.getDraggedColumn() 当且仅当正在进行拖动时，返回被拖动的列，否则返回 null。
TableColumn | JTableHeader.getResizingColumn() 返回正在调整其大小的列。

返回变量类型为 TableColumn 的类型的 javax.swing.table 中的方法
Enumeration<TableColumn> | DefaultTableColumnModel.getColumns() 返回该模型中所有列的一个 Enumeration。
Enumeration<TableColumn> | TableColumnModel.getColumns() 返回该模型中所有列的 Enumeration。

参数类型为 TableColumn 的 javax.swing.table 中的方法
void | DefaultTableColumnModel.addColumn(TableColumn aColumn) 将 aColumn 追加到 tableColumns 数组的结尾。
void | TableColumnModel.addColumn(TableColumn aColumn) 将 aColumn 追加到 tableColumns 数组的结尾。
void | DefaultTableColumnModel.removeColumn(TableColumn column) 从 tableColumns 数组删除 column。
void | TableColumnModel.removeColumn(TableColumn column) 从 tableColumns 数组中删除 TableColumn column。
void | JTableHeader.setDraggedColumn(TableColumn aColumn) 将头的 draggedColumn 设置为 aColumn。
void | JTableHeader.setResizingColumn(TableColumn aColumn) 将头的 resizingColumn 设置为 aColumn。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.table.TableCellEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.table.TableCellEditor
的使用

使用 TableCellEditor 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableCellEditor 的使用

实现 TableCellEditor 的 javax.swing 中的类
 class DefaultCellEditor
表单元格和树单元格的默认编辑器。

声明为 TableCellEditor 的 javax.swing 中的字段
protected  TableCellEditor JTable.cellEditor
活动单元格编辑器对象，它重写当前单元格占用的屏幕空间，并允许用户更改其内容。

返回 TableCellEditor 的 javax.swing 中的方法
TableCellEditor | JTable.getCellEditor() 返回活动单元格编辑器；如果该表当前没有被编辑，则返回 null。
TableCellEditor | JTable.getCellEditor(int row, int column) 返回适用于由 row 和 column 所指定单元格的编辑器。
TableCellEditor | JTable.getDefaultEditor(Class<?> columnClass) 尚未在 TableColumn 中设置编辑器时，返回要使用的编辑器。

参数类型为 TableCellEditor 的 javax.swing 中的方法
Component | JTable.prepareEditor(TableCellEditor editor, int row, int column) 通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备编辑器。
void | JTable.setCellEditor(TableCellEditor anEditor) 设置活动单元格编辑器。
void | JTable.setDefaultEditor(Class<?> columnClass, TableCellEditor editor) 如果尚未在 TableColumn 中设置编辑器，则设置要使用的默认单元格编辑器。

javax.swing.table 中 TableCellEditor 的使用

声明为 TableCellEditor 的 javax.swing.table 中的字段
protected  TableCellEditor TableColumn.cellEditor
用于编辑列的数据单元格的编辑器。

返回 TableCellEditor 的 javax.swing.table 中的方法
 TableCellEditor TableColumn.getCellEditor()
返回 JTable 用于编辑此列各值的 TableCellEditor。

参数类型为 TableCellEditor 的 javax.swing.table 中的方法
 void TableColumn.setCellEditor(TableCellEditor cellEditor)
设置编辑此列中单元格时所用的编辑器。

参数类型为 TableCellEditor 的 javax.swing.table 中的构造方法
TableColumn(int modelIndex, int width, TableCellRenderer cellRenderer, TableCellEditor cellEditor)
使用指定的模型索引、宽度、单元格渲染器、单元格编辑器创建并初始化 TableColumn 实例；所有 TableColumn 构造方法都委托给此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.DefaultTableCellRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.DefaultTableCellRenderer
的使用

使用 DefaultTableCellRenderer 的软件包
javax.swing.table 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.table 中 DefaultTableCellRenderer 的使用

javax.swing.table 中 DefaultTableCellRenderer 的子类
static class DefaultTableCellRenderer.UIResource
DefaultTableCellRenderer 的一个子类，它实现 UIResource。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.DefaultTableCellRenderer.UIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.DefaultTableCellRenderer.UIResource
的使用

没有 javax.swing.table.DefaultTableCellRenderer.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.AbstractTableModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.AbstractTableModel
的使用

使用 AbstractTableModel 的软件包
javax.swing.table 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.table 中 AbstractTableModel 的使用

javax.swing.table 中 AbstractTableModel 的子类
 class DefaultTableModel
这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.table.TableModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.table.TableModel
的使用

使用 TableModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableModel 的使用

声明为 TableModel 的 javax.swing 中的字段
protected  TableModel JTable.dataModel
表的 TableModel。

返回 TableModel 的 javax.swing 中的方法
protected TableModel | JTable.createDefaultDataModel() 返回默认的表模型对象，它是一个 DefaultTableModel。
TableModel | JTable.getModel() 返回提供此 JTable 所显示数据的 TableModel。

返回变量类型为 TableModel 的类型的 javax.swing 中的方法
 RowSorter<? extends TableModel> JTable.getRowSorter()
返回负责排序的对象。

参数类型为 TableModel 的 javax.swing 中的方法
 void JTable.setModel(TableModel dataModel)
将此表的数据模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。

类型变量类型为 TableModel 的 javax.swing 中的方法参数
 void JTable.setRowSorter(RowSorter<? extends TableModel> sorter)
设置 RowSorter。

参数类型为 TableModel 的 javax.swing 中的构造方法
JTable(TableModel dm)
构造一个 JTable，使用数据模型 dm、默认的列模型和默认的选择模型对其进行初始化。
JTable(TableModel dm, TableColumnModel cm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和默认的选择模型对其进行初始化。
JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。

javax.swing.event 中 TableModel 的使用

参数类型为 TableModel 的 javax.swing.event 中的构造方法
TableModelEvent(TableModel source)
如果表中的所有行数据都发生更改，那么侦听器应该丢弃基于这些行的所有状态，并重新查询 TableModel 来获得新的行计数和所有恰当值。
TableModelEvent(TableModel source, int row)
此数据行已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow)
行 [firstRow, lastRow] 中的数据已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow, int column)
列 column 的 [firstRow, lastRow] 范围内的单元格已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow, int column, int type)
从 (firstRow, column) 到 (lastRow, column) 的单元格已被更改。

javax.swing.table 中 TableModel 的使用

类型参数类型为 TableModel 的 javax.swing.table 中的类
 class TableRowSorter<M extends TableModel>
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。

实现 TableModel 的 javax.swing.table 中的类
class | AbstractTableModel 此抽象类为 TableModel 接口中的大多数方法提供默认实现。
class | DefaultTableModel 这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。

参数类型为 TableModel 的 javax.swing.table 中的方法
abstract  String TableStringConverter.toString(TableModel model, int row, int column)
返回指定位置处值的字符串表示形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.JTableHeader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.JTableHeader
的使用

使用 JTableHeader 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 JTableHeader 的使用

声明为 JTableHeader 的 javax.swing 中的字段
protected  JTableHeader JTable.tableHeader
表所使用的 TableHeader。

返回 JTableHeader 的 javax.swing 中的方法
protected JTableHeader | JTable.createDefaultTableHeader() 返回默认的表标题对象，它是一个 JTableHeader。
JTableHeader | JTable.getTableHeader() 返回此 JTable 所使用的 tableHeader。

参数类型为 JTableHeader 的 javax.swing 中的方法
 void JTable.setTableHeader(JTableHeader tableHeader)
将此 JTable 所使用的 tableHeader 设置为 newHeader。

javax.swing.plaf.basic 中 JTableHeader 的使用

声明为 JTableHeader 的 javax.swing.plaf.basic 中的字段
protected  JTableHeader BasicTableHeaderUI.header
要将绘制委托给此 UI 的 JTableHeader。

javax.swing.table 中 JTableHeader 的使用

参数类型为 JTableHeader 的 javax.swing.table 中的构造方法
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
构造一个 AccessiblJTableHeaaderEntry

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.JTableHeader.AccessibleJTableHeader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.JTableHeader.AccessibleJTableHeader
的使用

没有 javax.swing.table.JTableHeader.AccessibleJTableHeader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.table.TableCellRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.table.TableCellRenderer
的使用

使用 TableCellRenderer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 TableCellRenderer 的使用

返回 TableCellRenderer 的 javax.swing 中的方法
TableCellRenderer | JTable.getCellRenderer(int row, int column) 返回适于由此行和列所指定单元格的渲染器。
TableCellRenderer | JTable.getDefaultRenderer(Class<?> columnClass) 尚未在 TableColumn 中设置渲染器时，返回要使用的单元格渲染器。

参数类型为 TableCellRenderer 的 javax.swing 中的方法
Component | JTable.prepareRenderer(TableCellRenderer renderer, int row, int column) 通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备渲染器。
void | JTable.setDefaultRenderer(Class<?> columnClass, TableCellRenderer renderer) 如果没有在 TableColumn 中设置渲染器，则设置要使用的默认单元格渲染器。

javax.swing.table 中 TableCellRenderer 的使用

实现 TableCellRenderer 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。

声明为 TableCellRenderer 的 javax.swing.table 中的字段
protected TableCellRenderer | TableColumn.cellRenderer 用于绘制列的数据单元格的渲染器。
protected TableCellRenderer | TableColumn.headerRenderer 用于绘制列标题的渲染器。

返回 TableCellRenderer 的 javax.swing.table 中的方法
protected TableCellRenderer | TableColumn.createDefaultHeaderRenderer() 从 Java 2 platform v1.3 开始，TableColumn 构造方法不再调用此方法。
protected TableCellRenderer | JTableHeader.createDefaultRenderer() 返回 TableColumn 未定义头渲染器时所使用的默认渲染器。
TableCellRenderer | TableColumn.getCellRenderer() 返回 JTable 用于绘制此列各值的 TableCellRenderer。
TableCellRenderer | JTableHeader.getDefaultRenderer() 返回 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
TableCellRenderer | TableColumn.getHeaderRenderer() 返回用于绘制 TableColumn 标题的 TableCellRenderer。

参数类型为 TableCellRenderer 的 javax.swing.table 中的方法
void | TableColumn.setCellRenderer(TableCellRenderer cellRenderer) 设置 JTable 用于绘制此列各值的 TableCellRenderer。
void | JTableHeader.setDefaultRenderer(TableCellRenderer defaultRenderer) 设置 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
void | TableColumn.setHeaderRenderer(TableCellRenderer headerRenderer) 将用于绘制 TableColumn 的标题的 TableCellRenderer 设置为 headerRenderer。

参数类型为 TableCellRenderer 的 javax.swing.table 中的构造方法
TableColumn(int modelIndex, int width, TableCellRenderer cellRenderer, TableCellEditor cellEditor)
使用指定的模型索引、宽度、单元格渲染器、单元格编辑器创建并初始化 TableColumn 实例；所有 TableColumn 构造方法都委托给此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
的使用

没有 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AbstractDocument (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AbstractDocument

java.lang.Object
    继承者  javax.swing.text.AbstractDocument
所有已实现的接口：
Serializable, Document
直接已知子类：
DefaultStyledDocument, PlainDocument
public abstract class AbstractDocument
extends Object
implements Document, Serializable

文档接口的实现，可作为实现各种文档的基础。在此级别上几乎没有策略，所以相应地增加了使用难度。

此类实现了文档的锁定机制。它允许多个 reader 或一个 writer，并且在 writer 开始对文档的另一次改变前，必须等到将以前的更改已通知该文档的所有观察者。使用 render 方法获取和释放读取锁定。通过改变文档的那些方法来获取写入锁定，并且在该方法调用期间保持锁定。在生成改变的线程上完成通知，并且在通知期间该线程对文件具有完全的读取访问权限，不过在通知结束前其他 reader 无法读取。该通知是一个 bean 事件通知，只有通知所有侦听器之后才允许进一步的改变。

所有根据此类创建子类且与文本组件（该组件具有派生自 BasicTextUI 的外观实现）一起使用的模型都可安全地进行异步更新，因为如果该文档的类型是 AbstractDocument，则对 View 层次结构的所有访问都是由 BasicTextUI 序列化的。锁定机制假定独立的线程仅从 DocumentListener 方法访问 View 层次结构，并且同一时间只有一个事件线程处于活动状态。

如果需要并发支持，则有下列额外的含义。所有 DocumentListener 实现和所有 UndoListener 实现的代码路径必须是线程安全的，并且如果要避免死锁，则不能访问组件锁定。在 JComponent 上执行 repaint 和 revalidate 方法是安全的。

AbstractDocument 在文档的结尾模拟了一个隐含的分隔。除了其他作用，这一功能允许您在最后一个字符的后面定位插入符。因此，getLength 返回一个比 Content 的长度小的值。如果创建自己的 Content，一定要有一个额外的字符并且初始化它。有关此内容的示例，请参见 StringContent 和 GapContent。另一个含义是模拟该隐含结束字符的 Element 具有 endOffset == (getLength() + 1)。例如，在 DefaultStyledDocument 中，getParagraphElement(getLength()).getEndOffset() == getLength() + 1。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
static interface | AbstractDocument.AttributeContext 一个接口，它用于允许 MutableAttributeSet 的实现使用可插入属性压缩技术。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
static interface | AbstractDocument.Content 描述可编辑的字符序列内容的接口。
class | AbstractDocument.DefaultDocumentEvent 存储修改文档时发生的文档更改。
static class | AbstractDocument.ElementEdit 一个 ElementChange 实现，可将其添加到文档事件中。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
字段摘要
protected static String | BAD_LOCATION 指示位置错误的错误消息。
static String | BidiElementName 用于保存单向操作的元素名。
static String | ContentElementName 用于表示内容的元素名
static String | ElementNameAttribute 用于指定元素名的属性名。
protected EventListenerList | listenerList 文档的事件侦听器列表。
static String | ParagraphElementName 用于表示段落的元素名
static String | SectionElementName 用于保存各节（行/段落）的元素名。
从接口 javax.swing.text.Document 继承的字段
StreamDescriptionProperty, TitleProperty
构造方法摘要
protected | AbstractDocument(AbstractDocument.Content data) 构造具有某种指定内容存储机制的新 AbstractDocument。
protected | AbstractDocument(AbstractDocument.Content data, AbstractDocument.AttributeContext context) 构造具有某种指定内容存储机制的新 AbstractDocument。
方法摘要
 void addDocumentListener(DocumentListener listener)
添加负责通知任何更改的文档侦听器。
 void addUndoableEditListener(UndoableEditListener listener)
添加负责通知任何更改的撤消侦听器。
protected  Element createBranchElement(Element parent, AttributeSet a)
创建文档分支元素，它可包含其他元素。
protected  Element createLeafElement(Element parent, AttributeSet a, int p0, int p1)
创建文档叶元素。
 Position createPosition(int offs)
返回更改文档时，将跟踪更改的位置。
 void dump(PrintStream out)
提供诊断转储 (dump)。
protected  void fireChangedUpdate(DocumentEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected  void fireInsertUpdate(DocumentEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected  void fireRemoveUpdate(DocumentEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected  void fireUndoableEditUpdate(UndoableEditEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
 int getAsynchronousLoadPriority()
获得异步加载优先级。
protected  AbstractDocument.AttributeContext getAttributeContext()
获取管理属性的上下文。
 Element getBidiRootElement()
返回此文档双向结构的根元素。
protected  AbstractDocument.Content getContent()
获得文档的内容。
protected  Thread getCurrentWriter()
获取当前的写入线程（如果有的话）。
abstract  Element getDefaultRootElement()
返回视图赖依存在的根元素，除非提供了向元素结构指派视图的其他机制。
 DocumentFilter getDocumentFilter()
返回负责进行插入/移除过滤的 DocumentFilter。
 DocumentListener[] getDocumentListeners()
返回在此文档上注册的所有文档侦听器的数组。
 Dictionary<Object,Object> getDocumentProperties()
支持管理属性集。
 Position getEndPosition()
返回表示文档结尾的位置。
 int getLength()
返回数据的长度。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。
abstract  Element getParagraphElement(int pos)
获得包含给定位置的段落元素。
 Object getProperty(Object key)
查找属性值的便捷方法。
 Element[] getRootElements()
获得已定义的所有根元素。
 Position getStartPosition()
返回表示文档开始的位置。
 String getText(int offset, int length)
从文档中获得文本序列。
 void getText(int offset, int length, Segment txt)
获取文档给定部分内包含的文本。
 UndoableEditListener[] getUndoableEditListeners()
返回在此文档上注册的所有可撤消编辑侦听器的数组。
 void insertString(int offs, String str, AttributeSet a)
将某些内容插入文档。
protected  void insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
在文本插入后更新文档结构。
protected  void postRemoveUpdate(AbstractDocument.DefaultDocumentEvent chng)
随文本的移除更新任何文档结构。
 void putProperty(Object key, Object value)
存储属性值的便捷方法。
 void readLock()
获取一个锁定，以开始读取文档的某个状态。
 void readUnlock()
执行读取解除锁定。
 void remove(int offs, int len)
从文档中移除某些内容。
 void removeDocumentListener(DocumentListener listener)
移除文档侦听器。
 void removeUndoableEditListener(UndoableEditListener listener)
移除撤消侦听器。
protected  void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
随文本的移除更新任何文档结构。
 void render(Runnable r)
如果模型支持被异步更新，则此方法允许在并发情况下安全地呈现该模型。
 void replace(int offset, int length, String text, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换它。
 void setAsynchronousLoadPriority(int p)
设置异步加载优先级。
 void setDocumentFilter(DocumentFilter filter)
设置 DocumentFilter。
 void setDocumentProperties(Dictionary<Object,Object> x)
替换此文档的文档属性字典。
protected  void writeLock()
获取一个锁定，以开始改变此锁定保护的文档。
protected  void writeUnlock()
释放以前通过 writeLock 所获得的写入锁定。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

listenerList

protected EventListenerList listenerList
文档的事件侦听器列表。

BAD_LOCATION

protected static final String BAD_LOCATION
指示位置错误的错误消息。

另请参见：
常量字段值

ParagraphElementName

public static final String ParagraphElementName
用于表示段落的元素名

另请参见：
常量字段值

ContentElementName

public static final String ContentElementName
用于表示内容的元素名

另请参见：
常量字段值

SectionElementName

public static final String SectionElementName
用于保存各节（行/段落）的元素名。

另请参见：
常量字段值

BidiElementName

public static final String BidiElementName
用于保存单向操作的元素名。

另请参见：
常量字段值

ElementNameAttribute

public static final String ElementNameAttribute
用于指定元素名的属性名。

另请参见：
常量字段值
构造方法详细信息

AbstractDocument

protected AbstractDocument(AbstractDocument.Content data)
构造具有某种指定内容存储机制的新 AbstractDocument。

参数：
data - 内容

AbstractDocument

protected AbstractDocument(AbstractDocument.Content data,
                           AbstractDocument.AttributeContext context)
构造具有某种指定内容存储机制的新 AbstractDocument。

参数：
data - 内容
context - 属性上下文
方法详细信息

getDocumentProperties

public Dictionary<Object,Object> getDocumentProperties()
支持管理属性集。调用者可以使用 documentProperties 字典通过文档范围内起作用的属性注释文档。

返回：
非 null 的 Dictionary
另请参见：
setDocumentProperties(java.util.Dictionary)

setDocumentProperties

public void setDocumentProperties(Dictionary<Object,Object> x)
替换此文档的文档属性字典。

参数：
x - 新字典
另请参见：
getDocumentProperties()

fireInsertUpdate

protected void fireInsertUpdate(DocumentEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。使用传入此触发方法的参数延后 (lazily) 创建事件实例。

参数：
e - 事件
另请参见：
EventListenerList

fireChangedUpdate

protected void fireChangedUpdate(DocumentEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
e - 事件
另请参见：
EventListenerList

fireRemoveUpdate

protected void fireRemoveUpdate(DocumentEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
e - 事件
另请参见：
EventListenerList

fireUndoableEditUpdate

protected void fireUndoableEditUpdate(UndoableEditEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
e - 事件
另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用以下代码查询文档 d，以获得该文档的侦听器：

DocumentListener[] mls = (DocumentListener[])(d.getListeners(DocumentListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 所请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
返回一个在此组件上作为 FooListener 注册的所有对象的数组，如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getDocumentListeners(), getUndoableEditListeners()

getAsynchronousLoadPriority

public int getAsynchronousLoadPriority()
获得异步加载优先级。如果小于零，则不应异步加载该文档。

返回：
异步加载优先级，如果不应异步加载该文档，则返回 -1

setAsynchronousLoadPriority

public void setAsynchronousLoadPriority(int p)
设置异步加载优先级。

参数：
p - 新异步加载优先级；小于零的值指示不应异步加载该文档

setDocumentFilter

public void setDocumentFilter(DocumentFilter filter)
设置 DocumentFilter。DocumentFilter 被传递到 insert 和 remove，以便有条件地允许文本的插入/删除。null 值指示不进行过滤。

参数：
filter - 用于限制文本的 DocumentFilter
从以下版本开始：
1.4
另请参见：
getDocumentFilter()

getDocumentFilter

public DocumentFilter getDocumentFilter()
返回负责进行插入/移除过滤的 DocumentFilter。null 返回值意味着不进行过滤。

返回：
the DocumentFilter
从以下版本开始：
1.4
另请参见：
setDocumentFilter(javax.swing.text.DocumentFilter)

render

public void render(Runnable r)
如果模型支持被异步更新，则此方法允许在并发情况下安全地呈现该模型。给定的 runnable 的执行方式是，在 runnable 执行时安全读取模型且不作任何更改。该 runnable 本身可能不 进行任何改变。

实现此方法以便为 runnable 执行期间获取一个读取锁定。在同一时间，可能有多个 runnable 在执行，并且当存在活动呈现的 runnable 时将会阻塞所有 writer。如果该 runnable 抛出异常，则将安全地释放其锁定。对于从不退出的 runnable 没有保护，在其生命周期中会有效地保持文档的锁定。

如果给定的 runnable 试图在此实现中对文档进行任何改变，则会发生死锁。没有为每个呈现线程进行跟踪以便允许检测此种情况的机制，但是子类可以通过额外的开销对呈现线程进行跟踪，并在死锁时抛出错误。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 Document 中的 render
参数：
r - 要执行的渲染器

getLength

public int getLength()
返回数据的长度。这是表示用户数据的内容字符数。

指定者：
接口 Document 中的 getLength
返回：
长度，该值 >= 0
另请参见：
Document.getLength()

addDocumentListener

public void addDocumentListener(DocumentListener listener)
添加负责通知任何更改的文档侦听器。

指定者：
接口 Document 中的 addDocumentListener
参数：
listener - 要添加的 DocumentListener
另请参见：
Document.addDocumentListener(javax.swing.event.DocumentListener)

removeDocumentListener

public void removeDocumentListener(DocumentListener listener)
移除文档侦听器。

指定者：
接口 Document 中的 removeDocumentListener
参数：
listener - 要移除的 DocumentListener
另请参见：
Document.removeDocumentListener(javax.swing.event.DocumentListener)

getDocumentListeners

public DocumentListener[] getDocumentListeners()
返回在此文档上注册的所有文档侦听器的数组。

返回：
此文档的所有 DocumentListener，如果当前没有注册的文档侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addDocumentListener(javax.swing.event.DocumentListener), removeDocumentListener(javax.swing.event.DocumentListener)

addUndoableEditListener

public void addUndoableEditListener(UndoableEditListener listener)
添加负责通知任何更改的撤消侦听器。在 UndoableEdit 上执行撤消/重复操作将激发适当的 DocumentEvent，以让视图与模型保持同步。

指定者：
接口 Document 中的 addUndoableEditListener
参数：
listener - 要添加的 UndoableEditListener
另请参见：
Document.addUndoableEditListener(javax.swing.event.UndoableEditListener)

removeUndoableEditListener

public void removeUndoableEditListener(UndoableEditListener listener)
移除撤消侦听器。

指定者：
接口 Document 中的 removeUndoableEditListener
参数：
listener - 要移除的 UndoableEditListener
另请参见：
Document.removeDocumentListener(javax.swing.event.DocumentListener)

getUndoableEditListeners

public UndoableEditListener[] getUndoableEditListeners()
返回在此文档上注册的所有可撤消编辑侦听器的数组。

返回：
此文档的所有 UndoableEditListener，如果当前没有注册的可撤消编辑侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addUndoableEditListener(javax.swing.event.UndoableEditListener), removeUndoableEditListener(javax.swing.event.UndoableEditListener)

getProperty

public final Object getProperty(Object key)
查找属性值的便捷方法。它等效于：
 getDocumentProperties().get(key);

指定者：
接口 Document 中的 getProperty
参数：
key - 非 null 的属性键
返回：
此属性的值，或者为 null
另请参见：
getDocumentProperties()

putProperty

public final void putProperty(Object key,
                              Object value)
存储属性值的便捷方法。它等效于：
 getDocumentProperties().put(key, value);
如果 value 为 null，则此方法将移除该属性。

指定者：
接口 Document 中的 putProperty
参数：
key - 非 null 的键
value - 属性值
另请参见：
getDocumentProperties()

remove

public void remove(int offs,
                   int len)
            throws BadLocationException
从文档中移除某些内容。移除内容会导致在进行实际更改时保持写入锁定。将会把更改通知调用此方法的线程上的观察者。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 Document 中的 remove
参数：
offs - 起始偏移量，该值 >= 0
len - 要移除的字符数，该值 >= 0
抛出：
BadLocationException - 给定的移除位置不是文档内的有效位置
另请参见：
Document.remove(int, int)

replace

public void replace(int offset,
                    int length,
                    String text,
                    AttributeSet attrs)
             throws BadLocationException
删除从 offset 到 offset + length 的文本区域，并用 text 替换它。由实现决定如何实现该替换，某些实现可能将该替换当作两个不同的操作：一次移除，后跟一次插入，其他实现可能将该替换当作一个原子操作。

参数：
offset - 子元素的索引
length - 要删除的文本长度，可能为 0，指示不删除任何内容
text - 要插入的文本，null 指示不插入文本
attrs - AttributeSet 指示所插入文本的属性，null 是合法值，通常作为空 attributeset 对待，但是具体的解释由子类负责
抛出：
BadLocationException - 给定的位置不是文档内的有效位置
从以下版本开始：
1.4

insertString

public void insertString(int offs,
                         String str,
                         AttributeSet a)
                  throws BadLocationException
将某些内容插入文档。插入内容会导致在实际发生改变时存储写锁定，接着会向线程上抓取该写入锁定的观察者发出通知。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 Document 中的 insertString
参数：
offs - 起始偏移量，该值 >= 0
str - 要插入的字符串；null/空字符串不执行任何操作
a - 插入内容的属性
抛出：
BadLocationException - 如果给定的插入位置不是文档中的有效位置
另请参见：
Document.insertString(int, java.lang.String, javax.swing.text.AttributeSet)

getText

public String getText(int offset,
                      int length)
               throws BadLocationException
从文档中获得文本序列。

指定者：
接口 Document 中的 getText
参数：
offset - 起始偏移量，该值 >= 0
length - 要检索的字符数，该值 >= 0
返回：
文本
抛出：
BadLocationException - 给定范围内包括的位置不是文档内的有效位置
另请参见：
Document.getText(int, int)

getText

public void getText(int offset,
                    int length,
                    Segment txt)
             throws BadLocationException
获取文档给定部分内包含的文本。

如果 txt 参数的 partialReturn 属性为 false，Segment 中返回的数据将是请求的整个长度，根据数据存储的方式可能是副本，也可能不是。如果 partialReturn 属性为 true，则只能返回不需要创建副本即能返回的文本量。使用部分返回在需要扫描大部分文档的情况下具有更好的效果。下面是使用部分返回访问整个文档的示例：

   int nleft = doc.getDocumentLength();
   Segment text = new Segment();
   int offs = 0;
   text.setPartialReturn(true);
   while (nleft > 0) {
       doc.getText(offs, nleft, text);
       // do something with text
       nleft -= text.count;
       offs += text.count;
   }

指定者：
接口 Document 中的 getText
参数：
offset - 起始偏移量，该值 >= 0
length - 要检索的字符数，该值 >= 0
txt - 所检索到的文本被放入的 Segment 对象
抛出：
BadLocationException - 给定范围内包括的位置不是文档内的有效位置

createPosition

public Position createPosition(int offs)
                        throws BadLocationException
返回更改文档时，将跟踪更改的位置。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 Document 中的 createPosition
参数：
offs - 模型中的位置，该值 >= 0
返回：
位置
抛出：
BadLocationException - 如果给定的位置不表示关联文档内的有效位置
另请参见：
Document.createPosition(int)

getStartPosition

public final Position getStartPosition()
返回表示文档开始的位置。可对返回的位置进行计数以便跟踪更改，也可以让其保留在文档起始位置。

指定者：
接口 Document 中的 getStartPosition
返回：
位置

getEndPosition

public final Position getEndPosition()
返回表示文档结尾的位置。可对返回的位置进行计数以便跟踪更改，也可以让其保留在文档结束位置。

指定者：
接口 Document 中的 getEndPosition
返回：
位置

getRootElements

public Element[] getRootElements()
获得已定义的所有根元素。通常只有一个根元素，所以默认实现将返回默认的根元素。

指定者：
接口 Document 中的 getRootElements
返回：
根元素

getDefaultRootElement

public abstract Element getDefaultRootElement()
返回视图赖依存在的根元素，除非提供了向元素结构指派视图的其他机制。

指定者：
接口 Document 中的 getDefaultRootElement
返回：
根元素
另请参见：
Document.getDefaultRootElement()

getBidiRootElement

public Element getBidiRootElement()
返回此文档双向结构的根元素。其子级表示以给定的 Unicode 双向层次进行字符操作。

getParagraphElement

public abstract Element getParagraphElement(int pos)
获得包含给定位置的段落元素。子类必须为其自身定义准确的段落组成。但是应该要记住，一个段落至少应该是在其上可运行 Unicode 双向算法的文本单元。

参数：
pos - 起始偏移量，该值 >= 0
返回：
元素

getAttributeContext

protected final AbstractDocument.AttributeContext getAttributeContext()
获取管理属性的上下文。此方法高效地建立了用于压缩 AttributeSet 信息的策略。

返回：
上下文

insertUpdate

protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng,
                            AttributeSet attr)
在文本插入后更新文档结构。这将在写锁定内发生。如果此类的子类重新实现此方法，则还应该委托给超类。

参数：
chng - 更改的描述
attr - 更改的属性

removeUpdate

protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
随文本的移除更新任何文档结构。从 Content 中实际移除文本前调用此方法。这将在写锁定内发生。如果此类的子类重新实现此方法，则还应该委托给超类。

参数：
chng - 更改的描述

postRemoveUpdate

protected void postRemoveUpdate(AbstractDocument.DefaultDocumentEvent chng)
随文本的移除更新任何文档结构。从 Content 中移除文本后调用此方法。这将在写锁定内发生。如果此类的子类重新实现此方法，则还应该委托给超类。

参数：
chng - 更改的描述

dump

public void dump(PrintStream out)
提供诊断转储 (dump)。

参数：
out - 输出流

getContent

protected final AbstractDocument.Content getContent()
获得文档的内容。

返回：
内容

createLeafElement

protected Element createLeafElement(Element parent,
                                    AttributeSet a,
                                    int p0,
                                    int p1)
创建文档叶元素。使用此操作来创建那些表示文档结构的元素。因为此实现分别保存结构和内容，所以扩展内容时元素会自动增加，然后会拆分现有的元素。文档本身决定如何生成元素，从而在使用的元素类型上提供了灵活性。

参数：
parent - 父元素
a - 元素的属性
p0 - 范围的开始，该值 >= 0
p1 - 范围的结尾，该值 >= p0
返回：
新元素

createBranchElement

protected Element createBranchElement(Element parent,
                                      AttributeSet a)
创建文档分支元素，它可包含其他元素。

参数：
parent - 父元素
a - 属性
返回：
元素

getCurrentWriter

protected final Thread getCurrentWriter()
获取当前的写入线程（如果有的话）。这可用于区分被调用的方法是否为现有修改的一部分，或者是否需要获得锁定并开始新事务。

返回：
正在修改文档的线程，如果没有正在进行修改，则返回 null

writeLock

protected final void writeLock()
获取一个锁定，以开始改变此锁定保护的文档。为了获得锁定，不能有正在进行的写入、更改通知或读取。另外，只要某个线程不尝试从文档通知内获得其他 writeLock，就允许它获得多个 writeLock。尝试从 DocumentListener 通知内获得 writeLock 将导致 IllegalStateException。每个线程可获得多个 writeLock 的功能允许子类获得一个 writeLock、执行多个操作，然后释放该锁定。

对 writeLock 的调用必须与对 writeUnlock 的调用对称，否则 Document 将被保持在锁定状态，从而无法进行读取或写入。

抛出：
IllegalStateException - 如果尝试非法锁定。如果正确实现了文档，则仅在文档侦听器尝试改变该文档时才出现此异常。此情况违反了 bean 事件模型，此模型中不保证传递顺序，在允许进一步改变前应通知所有侦听器。

writeUnlock

protected final void writeUnlock()
释放以前通过 writeLock 所获得的写入锁定。将锁定计数减一后，如果没有其他未解锁的锁定，则允许新的 writer 或多个 reader 执行操作。

另请参见：
writeLock()

readLock

public final void readLock()
获取一个锁定，以开始读取文档的某个状态。同时可以有多个 reader。完成对侦听器的更改通知前，写入锁定会阻塞各个 reader。使用此方法应该非常小心，以避免对文档的无意破坏。此方法应该始终与 readUnlock 保持对称。

另请参见：
readUnlock()

readUnlock

public final void readUnlock()
执行读取解除锁定。该操作通知某个 reader 已完成操作。如果没有其他 reader，则又可以开始写入。此方法应该与 readLock 保持对称，并且应该在最后的语句中出现，这样才能保证对称性。下面是一个示例：

     readLock();
     try {
        // do something
     } finally {
         readUnlock();
     }

另请参见：
readLock()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AbstractDocument.AbstractElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AbstractDocument.AbstractElement

java.lang.Object
    继承者  javax.swing.text.AbstractDocument.AbstractElement
所有已实现的接口：
Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
直接已知子类：
AbstractDocument.BranchElement, AbstractDocument.LeafElement
正在封闭类：
AbstractDocument
public abstract class AbstractDocument.AbstractElement
extends Object
implements Element, MutableAttributeSet, Serializable, TreeNode

实现元素的抽象部分。默认情况下，通过提供表示该元素当前属性集合的不可变部分的字段，元素支持这些属性。该元素本身可以实现 MutableAttributeSet，后者可以通过获取新的不可变集合来修改该集合。这些不可变集合是由与此文档相关的 AttributeContext 提供的。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
AbstractDocument.AbstractElement(Element parent, AttributeSet a)
创建新的 AbstractElement。
方法摘要
void | addAttribute(Object name, Object value) 向该元素添加一个属性。
void | addAttributes(AttributeSet attr) 向该元素添加一个属性集合。
abstract Enumeration | children() 以 Enumeration 形式返回接收方的子级。
boolean | containsAttribute(Object name, Object value) 检查是否定义了给定的属性名称/值。
boolean | containsAttributes(AttributeSet attrs) 检查该元素是否包含所有的属性。
AttributeSet | copyAttributes() 复制属性集合。
void | dump(PrintStream psOut, int indentAmount) 转储该元素层次结构的调试表示形式。
abstract boolean | getAllowsChildren() 如果接收方允许有子级，则返回 true。
Object | getAttribute(Object attrName) 获取属性值。
int | getAttributeCount() 获取所定义的属性数量。
Enumeration<?> | getAttributeNames() 获取所有属性的名称。
AttributeSet | getAttributes() 获取该元素的属性。
TreeNode | getChildAt(int childIndex) 在索引 childIndex 处返回子级 TreeNode。
int | getChildCount() 返回接受方所包含的子级 TreeNode 的数量。
Document | getDocument() 获得基础模型。
abstract Element | getElement(int index) 获取子元素。
abstract int | getElementCount() 获取该元素子级的数量。
abstract int | getElementIndex(int offset) 获取最接近给定模型偏移量的子元素索引。
abstract int | getEndOffset() 获取该元素在此模型中的终止偏移量。
int | getIndex(TreeNode node) 返回接收方子级中 node 的索引。
String | getName() 获取该元素的名称。
TreeNode | getParent() 返回接收方的父级 TreeNode。
Element | getParentElement() 获取该元素的父级。
AttributeSet | getResolveParent() 获取要解析的父级。
abstract int | getStartOffset() 获取该元素在此模型中的起始偏移量。
boolean | isDefined(Object attrName) 检查是否定义了给定的属性。
boolean | isEqual(AttributeSet attr) 检查两个属性集合是否相等。
abstract boolean | isLeaf() 检查该元素是否为叶元素。
void | removeAttribute(Object name) 从该集合中移除一个属性。
void | removeAttributes(AttributeSet attrs) 移除该元素的属性集合。
void | removeAttributes(Enumeration<?> names) 移除该元素的属性集合。
void | setResolveParent(AttributeSet parent) 设置要解析的父级。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractDocument.AbstractElement

public AbstractDocument.AbstractElement(Element parent,
                                        AttributeSet a)
创建新的 AbstractElement。

参数：
parent - 父元素
a - 该元素的属性
从以下版本开始：
1.4
方法详细信息

dump

public void dump(PrintStream psOut,
                 int indentAmount)
转储该元素层次结构的调试表示形式。

参数：
psOut - 输出流
indentAmount - 缩进级别 >= 0

getAttributeCount

public int getAttributeCount()
获取所定义的属性数量。

指定者：
接口 AttributeSet 中的 getAttributeCount
返回：
属性数量 >= 0
另请参见：
AttributeSet.getAttributeCount()

isDefined

public boolean isDefined(Object attrName)
检查是否定义了给定的属性。

指定者：
接口 AttributeSet 中的 isDefined
参数：
attrName - 非 null 属性的名称
返回：
如果定义了属性，则返回 true
另请参见：
AttributeSet.isDefined(java.lang.Object)

isEqual

public boolean isEqual(AttributeSet attr)
检查两个属性集合是否相等。

指定者：
接口 AttributeSet 中的 isEqual
参数：
attr - 要检查的属性集合
返回：
如果相同，则返回 true
另请参见：
AttributeSet.isEqual(javax.swing.text.AttributeSet)

copyAttributes

public AttributeSet copyAttributes()
复制属性集合。

指定者：
接口 AttributeSet 中的 copyAttributes
返回：
副本
另请参见：
AttributeSet.copyAttributes()

getAttribute

public Object getAttribute(Object attrName)
获取属性值。

指定者：
接口 AttributeSet 中的 getAttribute
参数：
attrName - 非 null 属性名称
返回：
属性值
另请参见：
AttributeSet.getAttribute(java.lang.Object)

getAttributeNames

public Enumeration<?> getAttributeNames()
获取所有属性的名称。

指定者：
接口 AttributeSet 中的 getAttributeNames
返回：
枚举形式的属性名称
另请参见：
AttributeSet.getAttributeNames()

containsAttribute

public boolean containsAttribute(Object name,
                                 Object value)
检查是否定义了给定的属性名称/值。

指定者：
接口 AttributeSet 中的 containsAttribute
参数：
name - 非 null 属性名称
value - 属性值
返回：
如果定义了名称/值，则返回 true
另请参见：
AttributeSet.containsAttribute(java.lang.Object, java.lang.Object)

containsAttributes

public boolean containsAttributes(AttributeSet attrs)
检查该元素是否包含所有的属性。

指定者：
接口 AttributeSet 中的 containsAttributes
参数：
attr - 要检查的属性
返回：
如果该元素包含所有的属性，则返回 true
另请参见：
AttributeSet.containsAttributes(javax.swing.text.AttributeSet)

getResolveParent

public AttributeSet getResolveParent()
获取要解析的父级。如果未重写，则要解析的父级默认为父元素。

指定者：
接口 AttributeSet 中的 getResolveParent
返回：
父级中的属性，如果不存在，则返回 null
另请参见：
AttributeSet.getResolveParent()

addAttribute

public void addAttribute(Object name,
                         Object value)
向该元素添加一个属性。

指定者：
接口 MutableAttributeSet 中的 addAttribute
参数：
name - 非 null 属性名称
value - 属性值
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

addAttributes

public void addAttributes(AttributeSet attr)
向该元素添加一个属性集合。

指定者：
接口 MutableAttributeSet 中的 addAttributes
参数：
attr - 要添加的属性
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

removeAttribute

public void removeAttribute(Object name)
从该集合中移除一个属性。

指定者：
接口 MutableAttributeSet 中的 removeAttribute
参数：
name - 非 null 属性名称
另请参见：
MutableAttributeSet.removeAttribute(java.lang.Object)

removeAttributes

public void removeAttributes(Enumeration<?> names)
移除该元素的属性集合。

指定者：
接口 MutableAttributeSet 中的 removeAttributes
参数：
names - 属性名称
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

removeAttributes

public void removeAttributes(AttributeSet attrs)
移除该元素的属性集合。

指定者：
接口 MutableAttributeSet 中的 removeAttributes
参数：
attr - 属性
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

setResolveParent

public void setResolveParent(AttributeSet parent)
设置要解析的父级。

指定者：
接口 MutableAttributeSet 中的 setResolveParent
参数：
parent - 父级，如果不存在，则返回 null
另请参见：
MutableAttributeSet.setResolveParent(javax.swing.text.AttributeSet)

getDocument

public Document getDocument()
获得基础模型。

指定者：
接口 Element 中的 getDocument
返回：
模型

getParentElement

public Element getParentElement()
获取该元素的父级。

指定者：
接口 Element 中的 getParentElement
返回：
父级

getAttributes

public AttributeSet getAttributes()
获取该元素的属性。

指定者：
接口 Element 中的 getAttributes
返回：
属性集合

getName

public String getName()
获取该元素的名称。

指定者：
接口 Element 中的 getName
返回：
名称，如果不存在，则返回 null

getStartOffset

public abstract int getStartOffset()
获取该元素在此模型中的起始偏移量。

指定者：
接口 Element 中的 getStartOffset
返回：
偏移量 >= 0
另请参见：
Document, AbstractDocument

getEndOffset

public abstract int getEndOffset()
获取该元素在此模型中的终止偏移量。

指定者：
接口 Element 中的 getEndOffset
返回：
偏移量 >= 0
另请参见：
Document, AbstractDocument

getElement

public abstract Element getElement(int index)
获取子元素。

指定者：
接口 Element 中的 getElement
参数：
index - 子索引，其值 >= 0 && < getElementCount()
返回：
子元素

getElementCount

public abstract int getElementCount()
获取该元素子级的数量。

指定者：
接口 Element 中的 getElementCount
返回：
子级的数量 >= 0

getElementIndex

public abstract int getElementIndex(int offset)
获取最接近给定模型偏移量的子元素索引。

指定者：
接口 Element 中的 getElementIndex
参数：
offset - 偏移量 >= 0
返回：
元素索引 >= 0

isLeaf

public abstract boolean isLeaf()
检查该元素是否为叶元素。

指定者：
接口 Element 中的 isLeaf
指定者：
接口 TreeNode 中的 isLeaf
返回：
如果是叶元素，则返回 true

getChildAt

public TreeNode getChildAt(int childIndex)
在索引 childIndex 处返回子级 TreeNode。

指定者：
接口 TreeNode 中的 getChildAt

getChildCount

public int getChildCount()
返回接受方所包含的子级 TreeNode 的数量。

指定者：
接口 TreeNode 中的 getChildCount
返回：
接受方所包含的子级 TreeNodews 的数量

getParent

public TreeNode getParent()
返回接收方的父级 TreeNode。

指定者：
接口 TreeNode 中的 getParent
返回：
接收方的父级 TreeNode

getIndex

public int getIndex(TreeNode node)
返回接收方子级中 node 的索引。如果接收方中不包含 node，将返回 -1。

指定者：
接口 TreeNode 中的 getIndex
参数：
node - 感兴趣的位置
返回：
接收方的子级中 node 的索引，如果不存在，则返回 -1

getAllowsChildren

public abstract boolean getAllowsChildren()
如果接收方允许有子级，则返回 true。

指定者：
接口 TreeNode 中的 getAllowsChildren
返回：
如果接收方允许有子级，则返回 true，否则返回 false

children

public abstract Enumeration children()
以 Enumeration 形式返回接收方的子级。

指定者：
接口 TreeNode 中的 children
返回：
接收方的 Enumeration 形式的子级
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractDocument.AttributeContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 AbstractDocument.AttributeContext

所有已知实现类：
StyleContext, StyleSheet
正在封闭类：
AbstractDocument
public static interface AbstractDocument.AttributeContext

一个接口，它用于允许 MutableAttributeSet 的实现使用可插入属性压缩技术。可以使用属性集的每个变化将以前的 AttributeSet 实例与另一个实例交换，保留 AttributeSet 保持不可变的可能性。StyleContext 类提供了一个实现。 此类提供的 Element 实现使用此接口来提供其 MutableAttributeSet 实现，所以可采用不同的 AttributeSet 压缩技术。要返回负责实现所需压缩技术的对象，则应该实现 getAttributeContext 方法。

另请参见：
StyleContext

方法摘要
AttributeSet | addAttribute(AttributeSet old, Object name, Object value) 向给定属性集中添加一个属性，并返回新的有代表性的属性集。
AttributeSet | addAttributes(AttributeSet old, AttributeSet attr) 向元素添加一组属性。
AttributeSet | getEmptySet() 获取一个空的 AttributeSet。
void | reclaim(AttributeSet a) 回收某个属性集。
AttributeSet | removeAttribute(AttributeSet old, Object name) 从属性集中移除某个属性。
AttributeSet | removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的一组属性。
AttributeSet | removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一组属性。

方法详细信息

addAttribute

AttributeSet addAttribute(AttributeSet old,
                          Object name,
                          Object value)
向给定属性集中添加一个属性，并返回新的有代表性的属性集。

参数：
old - 旧的属性集
name - 非 null 的属性名
value - 属性值
返回：
已更新的属性集
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

addAttributes

AttributeSet addAttributes(AttributeSet old,
                           AttributeSet attr)
向元素添加一组属性。

参数：
old - 旧的属性集
attr - 要添加的属性
返回：
已更新的属性集
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

removeAttribute

AttributeSet removeAttribute(AttributeSet old,
                             Object name)
从属性集中移除某个属性。

参数：
old - 旧的属性集
name - 非 null 的属性名
返回：
已更新的属性集
另请参见：
MutableAttributeSet.removeAttribute(java.lang.Object)

removeAttributes

AttributeSet removeAttributes(AttributeSet old,
                              Enumeration<?> names)
移除元素的一组属性。

参数：
old - 旧的属性集
names - 属性名
返回：
已更新的属性集
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

removeAttributes

AttributeSet removeAttributes(AttributeSet old,
                              AttributeSet attrs)
移除元素的一组属性。

参数：
old - 旧的属性集
attrs - 属性
返回：
已更新的属性集
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

getEmptySet

AttributeSet getEmptySet()
获取一个空的 AttributeSet。

返回：
属性集

reclaim

void reclaim(AttributeSet a)
回收某个属性集。这是 MutableAttributeSet 标记其不再需要特定的、不可变的属性集的一种方式。仅在 1.1 版本中才必需使用此方法，因为该版本中没有弱引用。1.1 版本的实现将在其 finalize 方法中调用此方法。

参数：
a - 要回收的属性集
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractDocument.BranchElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AbstractDocument.BranchElement

java.lang.Object
    继承者  javax.swing.text.AbstractDocument.AbstractElement
        继承者  javax.swing.text.AbstractDocument.BranchElement
所有已实现的接口：
Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
直接已知子类：
DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement
正在封闭类：
AbstractDocument
public class AbstractDocument.BranchElement
extends AbstractDocument.AbstractElement

实现一个包含其他元素的复合元素。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
AbstractDocument.BranchElement(Element parent, AttributeSet a)
构造最初不包含任何子元素的复合元素。
方法摘要
Enumeration | children() 以 Enumeration 的形式返回接收者的子级。
boolean | getAllowsChildren() 如果接收者允许接收子元素，则返回 true。
Element | getElement(int index) 获得一个子元素。
int | getElementCount() 获得该元素的子元素数。
int | getElementIndex(int offset) 获得与给定模型偏移量最接近的子元素索引。
int | getEndOffset() 获得模型中该元素的结束偏移量。
String | getName() 获得元素名。
int | getStartOffset() 获得模型中该元素的起始偏移量。
boolean | isLeaf() 检查该元素是否为叶元素。
Element | positionToElement(int pos) 获得包含给定模型位置的子元素。
void | replace(int offset, int length, Element[] elems) 使用新的元素集替换该内容。
String | toString() 将该元素转换为字符串。
从类 javax.swing.text.AbstractDocument.AbstractElement 继承的方法
addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, getResolveParent, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractDocument.BranchElement

public AbstractDocument.BranchElement(Element parent,
                                      AttributeSet a)
构造最初不包含任何子元素的复合元素。

参数：
parent - 父元素
a - 该元素的属性
从以下版本开始：
1.4
方法详细信息

positionToElement

public Element positionToElement(int pos)
获得包含给定模型位置的子元素。

参数：
pos - 位置，该位置 >= 0
返回：
元素，如果没有，则返回 null

replace

public void replace(int offset,
                    int length,
                    Element[] elems)
使用新的元素集替换该内容。

参数：
offset - 起始偏移量，该偏移量 >= 0
length - 要替换的长度，该长度 >= 0
elems - 新元素

toString

public String toString()
将该元素转换为字符串。

覆盖：
类 Object 中的 toString
返回：
字符串

getName

public String getName()
获得元素名。

指定者：
接口 Element 中的 getName
覆盖：
类 AbstractDocument.AbstractElement 中的 getName
返回：
元素名

getStartOffset

public int getStartOffset()
获得模型中该元素的起始偏移量。

指定者：
接口 Element 中的 getStartOffset
指定者：
类 AbstractDocument.AbstractElement 中的 getStartOffset
返回：
偏移量，该偏移量 >= 0
另请参见：
Document, AbstractDocument

getEndOffset

public int getEndOffset()
获得模型中该元素的结束偏移量。

指定者：
接口 Element 中的 getEndOffset
指定者：
类 AbstractDocument.AbstractElement 中的 getEndOffset
返回：
偏移量，该偏移量 >= 0
抛出：
NullPointerException - 如果此元素没有子元素
另请参见：
Document, AbstractDocument

getElement

public Element getElement(int index)
获得一个子元素。

指定者：
接口 Element 中的 getElement
指定者：
类 AbstractDocument.AbstractElement 中的 getElement
参数：
index - 子元素的索引，该索引 >= 0 && < getElementCount()
返回：
子元素，如果没有，则返回 null

getElementCount

public int getElementCount()
获得该元素的子元素数。

指定者：
接口 Element 中的 getElementCount
指定者：
类 AbstractDocument.AbstractElement 中的 getElementCount
返回：
子元素数，该数 >= 0

getElementIndex

public int getElementIndex(int offset)
获得与给定模型偏移量最接近的子元素索引。

指定者：
接口 Element 中的 getElementIndex
指定者：
类 AbstractDocument.AbstractElement 中的 getElementIndex
参数：
offset - 偏移量，该偏移量 >= 0
返回：
元素索引，该索引 >= 0

isLeaf

public boolean isLeaf()
检查该元素是否为叶元素。

指定者：
接口 Element 中的 isLeaf
指定者：
接口 TreeNode 中的 isLeaf
指定者：
类 AbstractDocument.AbstractElement 中的 isLeaf
返回：
如果为叶元素，则返回 true

getAllowsChildren

public boolean getAllowsChildren()
如果接收者允许接收子元素，则返回 true。

指定者：
接口 TreeNode 中的 getAllowsChildren
指定者：
类 AbstractDocument.AbstractElement 中的 getAllowsChildren
返回：
如果接收者允许接收子元素，则返回 true；否则返回 false

children

public Enumeration children()
以 Enumeration 的形式返回接收者的子级。

指定者：
接口 TreeNode 中的 children
指定者：
类 AbstractDocument.AbstractElement 中的 children
返回：
接收者的子级
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractDocument.Content (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 AbstractDocument.Content

所有已知实现类：
GapContent, StringContent
正在封闭类：
AbstractDocument
public static interface AbstractDocument.Content

描述可编辑的字符序列内容的接口。各个实现不一定支持历史机制，历史机制可通过变化是否返回 UndoableEdit 实现反映出来。

另请参见：
AbstractDocument

方法摘要
Position | createPosition(int offset) 在内容中创建一个位置，该位置将在内容改变时跟踪更改。
void | getChars(int where, int len, Segment txt) 获得字符序列并将其复制到 Segment 中。
String | getString(int where, int len) 获取序列中包含的字符串。
UndoableEdit | insertString(int where, String str) 向序列中插入一个字符串。
int | length() 当前字符序列内容的长度。
UndoableEdit | remove(int where, int nitems) 移除该序列的某一部分。

方法详细信息

createPosition

Position createPosition(int offset)
                        throws BadLocationException
在内容中创建一个位置，该位置将在内容改变时跟踪更改。

参数：
offset - 内容中的偏移量，该偏移量 >= 0
返回：
一个 Position
抛出：
BadLocationException - 如果 offset 无效

length

int length()
当前字符序列内容的长度。

返回：
长度，该长度 >= 0

insertString

UndoableEdit insertString(int where,
                          String str)
                          throws BadLocationException
向序列中插入一个字符串。

参数：
where - 序列中插入位置的偏移量，该偏移量 >= 0
str - 要插入的字符串
返回：
如果该实现支持历史机制，则返回对 Edit 实现的引用，否则返回 null
抛出：
BadLocationException - 如果参数所覆盖的区域不包含在字符序列中

remove

UndoableEdit remove(int where,
                    int nitems)
                    throws BadLocationException
移除该序列的某一部分。

参数：
where - 序列中插入位置的偏移量，该偏移量 >= 0。
nitems - 序列中要移除的条目数量，该数量 >= 0。
返回：
如果该实现支持历史机制，则返回对 Edit 实现的引用，否则返回 null。
抛出：
BadLocationException - 如果参数所覆盖的区域不包含在字符序列中。

getString

String getString(int where,
                 int len)
                 throws BadLocationException
获取序列中包含的字符串。

参数：
where - 要获取的序列中的 Offset，该 Offset >= 0。
len - 要复制的字符的数量，该数量 >= 0。
返回：
字符串
抛出：
BadLocationException - 如果参数所覆盖的区域不包含在字符序列中。

getChars

void getChars(int where,
              int len,
              Segment txt)
              throws BadLocationException
获得字符序列并将其复制到 Segment 中。

参数：
where - 起始偏移量，该偏移量 >= 0
len - 字符的数量，该数量 >= 0
txt - 将内容复制到的目标位置
抛出：
BadLocationException - 如果参数所覆盖的区域不包含在字符序列中。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractDocument.DefaultDocumentEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AbstractDocument.DefaultDocumentEvent

java.lang.Object
    继承者  javax.swing.undo.AbstractUndoableEdit
        继承者  javax.swing.undo.CompoundEdit
            继承者  javax.swing.text.AbstractDocument.DefaultDocumentEvent
所有已实现的接口：
Serializable, DocumentEvent, UndoableEdit
正在封闭类：
AbstractDocument
public class AbstractDocument.DefaultDocumentEvent
extends CompoundEdit
implements DocumentEvent

存储修改文档时发生的文档更改。文档修改完成后，可将此内容用于更改通知。AbstractDocument 类及其扩展使用此方法向文档侦听器广播更改信息。

嵌套类摘要
从接口 javax.swing.event.DocumentEvent 继承的嵌套类/接口
DocumentEvent.ElementChange, DocumentEvent.EventType
字段摘要
从类 javax.swing.undo.CompoundEdit 继承的字段
edits
从类 javax.swing.undo.AbstractUndoableEdit 继承的字段
RedoName, UndoName
构造方法摘要
AbstractDocument.DefaultDocumentEvent(int offs, int len, DocumentEvent.EventType type)
构造更改记录。
方法摘要
boolean | addEdit(UndoableEdit anEdit) 添加文档编辑。
DocumentEvent.ElementChange | getChange(Element elem) 获得元素的更改。
Document | getDocument() 获得发起更改事件的文档。
int | getLength() 返回更改的长度。
int | getOffset() 返回文档中更改开始位置的偏移量。
String | getPresentationName() 提供此次编辑的已本地化的、可读的描述，比如，适合于在更改日志中使用的。
String | getRedoPresentationName() 提供此次编辑可重复执行形式的、已本地化的、可读的描述，例如用作 Redo 菜单项。
DocumentEvent.EventType | getType() 返回事件的类型。
String | getUndoPresentationName() 提供此次编辑可撤消形式的、已本地化的、可读的描述，例如，用作 Undo 菜单项。
boolean | isSignificant() DefaultDocument 事件是有意义的。
void | redo() 重复执行更改。
String | toString() 返回更改事件的字符串表示形式。
void | undo() 撤消更改。
从类 javax.swing.undo.CompoundEdit 继承的方法
canRedo, canUndo, die, end, isInProgress, lastEdit
从类 javax.swing.undo.AbstractUndoableEdit 继承的方法
replaceEdit
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractDocument.DefaultDocumentEvent

public AbstractDocument.DefaultDocumentEvent(int offs,
                                             int len,
                                             DocumentEvent.EventType type)
构造更改记录。

参数：
offs - 更改文档中的偏移量，该偏移量 >= 0
len - 更改的长度，该长度 >= 0
type - 事件类型 (DocumentEvent.EventType)
从以下版本开始：
1.4
方法详细信息

toString

public String toString()
返回更改事件的字符串表示形式。

覆盖：
类 CompoundEdit 中的 toString
返回：
字符串。

addEdit

public boolean addEdit(UndoableEdit anEdit)
添加文档编辑。如果编辑事件的数量超过阈值，则会开启哈希表上针对 ElementChange 实现的查找功能，因为需要相对快速地执行这些访问。

指定者：
接口 UndoableEdit 中的 addEdit
覆盖：
类 CompoundEdit 中的 addEdit
参数：
anEdit - 文档编辑记录
返回：
如果添加了编辑，则返回 true
另请参见：
UndoableEdit.addEdit(javax.swing.undo.UndoableEdit)

redo

public void redo()
          throws CannotRedoException
重复执行更改。

指定者：
接口 UndoableEdit 中的 redo
覆盖：
类 CompoundEdit 中的 redo
抛出：
CannotRedoException - 如果无法重复执行该更改
另请参见：
AbstractUndoableEdit.canRedo()

undo

public void undo()
          throws CannotUndoException
撤消更改。

指定者：
接口 UndoableEdit 中的 undo
覆盖：
类 CompoundEdit 中的 undo
抛出：
CannotUndoException - 如果无法撤消该更改
另请参见：
AbstractUndoableEdit.canUndo()

isSignificant

public boolean isSignificant()
DefaultDocument 事件是有意义的。如果希望聚集多个 DefaultDocumentEvent，以将其作为单次编辑展示给用户，则可将这些事件放入 CompoundEdit 中。

指定者：
接口 UndoableEdit 中的 isSignificant
覆盖：
类 CompoundEdit 中的 isSignificant
返回：
该事件对于编辑撤消而言是否有意义
另请参见：
UndoableEdit.isSignificant()

getPresentationName

public String getPresentationName()
提供此次编辑的已本地化的、可读的描述，比如，适合于在更改日志中使用的。

指定者：
接口 UndoableEdit 中的 getPresentationName
覆盖：
类 CompoundEdit 中的 getPresentationName
返回：
描述
另请参见：
AbstractUndoableEdit.getUndoPresentationName(), AbstractUndoableEdit.getRedoPresentationName()

getUndoPresentationName

public String getUndoPresentationName()
提供此次编辑可撤消形式的、已本地化的、可读的描述，例如，用作 Undo 菜单项。通常派生自 getDescription()；

指定者：
接口 UndoableEdit 中的 getUndoPresentationName
覆盖：
类 CompoundEdit 中的 getUndoPresentationName
返回：
描述
另请参见：
AbstractUndoableEdit.getPresentationName()

getRedoPresentationName

public String getRedoPresentationName()
提供此次编辑可重复执行形式的、已本地化的、可读的描述，例如用作 Redo 菜单项。通常派生自 getPresentationName()；

指定者：
接口 UndoableEdit 中的 getRedoPresentationName
覆盖：
类 CompoundEdit 中的 getRedoPresentationName
返回：
描述
另请参见：
AbstractUndoableEdit.getPresentationName()

getType

public DocumentEvent.EventType getType()
返回事件的类型。

指定者：
接口 DocumentEvent 中的 getType
返回：
以 DocumentEvent.EventType 形式返回事件的类型
另请参见：
DocumentEvent.getType()

getOffset

public int getOffset()
返回文档中更改开始位置的偏移量。

指定者：
接口 DocumentEvent 中的 getOffset
返回：
偏移量，该偏移量 >= 0
另请参见：
DocumentEvent.getOffset()

getLength

public int getLength()
返回更改的长度。

指定者：
接口 DocumentEvent 中的 getLength
返回：
长度，该长度 >= 0
另请参见：
Document.getLength()

getDocument

public Document getDocument()
获得发起更改事件的文档。

指定者：
接口 DocumentEvent 中的 getDocument
返回：
文档
另请参见：
DocumentEvent.getDocument()

getChange

public DocumentEvent.ElementChange getChange(Element elem)
获得元素的更改。

指定者：
接口 DocumentEvent 中的 getChange
参数：
elem - 元素
返回：
更改
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractDocument.ElementEdit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AbstractDocument.ElementEdit

java.lang.Object
    继承者  javax.swing.undo.AbstractUndoableEdit
        继承者  javax.swing.text.AbstractDocument.ElementEdit
所有已实现的接口：
Serializable, DocumentEvent.ElementChange, UndoableEdit
正在封闭类：
AbstractDocument
public static class AbstractDocument.ElementEdit
extends AbstractUndoableEdit
implements DocumentEvent.ElementChange

一个 ElementChange 实现，可将其添加到文档事件中。

字段摘要
从类 javax.swing.undo.AbstractUndoableEdit 继承的字段
RedoName, UndoName
构造方法摘要
AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
构造一个编辑记录。
方法摘要
Element[] | getChildrenAdded() 获得已添加的子元素列表。
Element[] | getChildrenRemoved() 获得已移除的子元素列表。
Element | getElement() 返回基础元素。
int | getIndex() 返回元素列表中的索引。
void | redo() 重复执行更改。
void | undo() 撤消更改。
从类 javax.swing.undo.AbstractUndoableEdit 继承的方法
addEdit, canRedo, canUndo, die, getPresentationName, getRedoPresentationName, getUndoPresentationName, isSignificant, replaceEdit, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractDocument.ElementEdit

public AbstractDocument.ElementEdit(Element e,
                                    int index,
                                    Element[] removed,
                                    Element[] added)
构造一个编辑记录。这不会修改元素，所以对于刚刚关联到模型的视图可安全地使用它，以便让该视图符合 当前的模型状态。

参数：
e - 元素
index - 模型中的索引，该索引 >= 0
removed - 已移除的元素集
added - 已添加的元素集
方法详细信息

getElement

public Element getElement()
返回基础元素。

指定者：
接口 DocumentEvent.ElementChange 中的 getElement
返回：
元素

getIndex

public int getIndex()
返回元素列表中的索引。

指定者：
接口 DocumentEvent.ElementChange 中的 getIndex
返回：
索引，该索引 >= 0

getChildrenRemoved

public Element[] getChildrenRemoved()
获得已移除的子元素列表。

指定者：
接口 DocumentEvent.ElementChange 中的 getChildrenRemoved
返回：
列表

getChildrenAdded

public Element[] getChildrenAdded()
获得已添加的子元素列表。

指定者：
接口 DocumentEvent.ElementChange 中的 getChildrenAdded
返回：
列表

redo

public void redo()
          throws CannotRedoException
重复执行更改。

指定者：
接口 UndoableEdit 中的 redo
覆盖：
类 AbstractUndoableEdit 中的 redo
抛出：
CannotRedoException - 如果无法重复执行该更改
另请参见：
AbstractUndoableEdit.canRedo()

undo

public void undo()
          throws CannotUndoException
撤消更改。

指定者：
接口 UndoableEdit 中的 undo
覆盖：
类 AbstractUndoableEdit 中的 undo
抛出：
CannotUndoException - 如果无法撤消该更改
另请参见：
AbstractUndoableEdit.canUndo()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractDocument.LeafElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AbstractDocument.LeafElement

java.lang.Object
    继承者  javax.swing.text.AbstractDocument.AbstractElement
        继承者  javax.swing.text.AbstractDocument.LeafElement
所有已实现的接口：
Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
直接已知子类：
HTMLDocument.RunElement
正在封闭类：
AbstractDocument
public class AbstractDocument.LeafElement
extends AbstractDocument.AbstractElement

实现可直接表示某类内容的元素。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Element

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
AbstractDocument.LeafElement(Element parent, AttributeSet a, int offs0, int offs1)
构造一个表示文档中内容的元素（没有子元素）。
方法摘要
Enumeration | children() 以 Enumeration 的形式返回接收者的子级。
boolean | getAllowsChildren() 如果接收者允许接收子元素，则返回 true。
Element | getElement(int index) 获得一个子元素。
int | getElementCount() 返回子元素的数量。
int | getElementIndex(int pos) 获得与给定模型偏移量最接近的子元素索引。
int | getEndOffset() 获得模型中该元素的结束偏移量。
String | getName() 获得元素名。
int | getStartOffset() 获得模型中该元素的起始偏移量。
boolean | isLeaf() 检查该元素是否为叶元素。
String | toString() 将该元素转换为字符串。
从类 javax.swing.text.AbstractDocument.AbstractElement 继承的方法
addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, getResolveParent, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractDocument.LeafElement

public AbstractDocument.LeafElement(Element parent,
                                    AttributeSet a,
                                    int offs0,
                                    int offs1)
构造一个表示文档中内容的元素（没有子元素）。

参数：
parent - 父元素
a - 元素属性
offs0 - 起始偏移量，该偏移量 >= 0
offs1 - 结束偏移量，该偏移量 >= offs0
从以下版本开始：
1.4
方法详细信息

toString

public String toString()
将该元素转换为字符串。

覆盖：
类 Object 中的 toString
返回：
字符串

getStartOffset

public int getStartOffset()
获得模型中该元素的起始偏移量。

指定者：
接口 Element 中的 getStartOffset
指定者：
类 AbstractDocument.AbstractElement 中的 getStartOffset
返回：
偏移量，该偏移量 >= 0
另请参见：
Document, AbstractDocument

getEndOffset

public int getEndOffset()
获得模型中该元素的结束偏移量。

指定者：
接口 Element 中的 getEndOffset
指定者：
类 AbstractDocument.AbstractElement 中的 getEndOffset
返回：
偏移量，该偏移量 >= 0
另请参见：
Document, AbstractDocument

getName

public String getName()
获得元素名。

指定者：
接口 Element 中的 getName
覆盖：
类 AbstractDocument.AbstractElement 中的 getName
返回：
名称

getElementIndex

public int getElementIndex(int pos)
获得与给定模型偏移量最接近的子元素索引。

指定者：
接口 Element 中的 getElementIndex
指定者：
类 AbstractDocument.AbstractElement 中的 getElementIndex
参数：
pos - 偏移量，该偏移量 >= 0
返回：
元素索引，该索引 >= 0

getElement

public Element getElement(int index)
获得一个子元素。

指定者：
接口 Element 中的 getElement
指定者：
类 AbstractDocument.AbstractElement 中的 getElement
参数：
index - 子元素的索引，该索引 >= 0 && < getElementCount()
返回：
子元素

getElementCount

public int getElementCount()
返回子元素的数量。

指定者：
接口 Element 中的 getElementCount
指定者：
类 AbstractDocument.AbstractElement 中的 getElementCount
返回：
子元素的数量，该数量 >= 0

isLeaf

public boolean isLeaf()
检查该元素是否为叶元素。

指定者：
接口 Element 中的 isLeaf
指定者：
接口 TreeNode 中的 isLeaf
指定者：
类 AbstractDocument.AbstractElement 中的 isLeaf
返回：
如果为叶元素，则返回 true

getAllowsChildren

public boolean getAllowsChildren()
如果接收者允许接收子元素，则返回 true。

指定者：
接口 TreeNode 中的 getAllowsChildren
指定者：
类 AbstractDocument.AbstractElement 中的 getAllowsChildren
返回：
如果接收者允许接收子元素，则返回 true；否则返回 false

children

public Enumeration children()
以 Enumeration 的形式返回接收者的子级。

指定者：
接口 TreeNode 中的 children
指定者：
类 AbstractDocument.AbstractElement 中的 children
返回：
接收者的子级
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractWriter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AbstractWriter

java.lang.Object
    继承者  javax.swing.text.AbstractWriter
直接已知子类：
HTMLWriter, MinimalHTMLWriter
public abstract class AbstractWriter
extends Object

AbstractWriter 是一个抽象类，它实际执行元素树（包括属性）的写出工作。在每行写出的元素数方面，writer 默认值是 100。但是子类可设置此值。

字段摘要
protected static char NEWLINE
text 包模拟新行的方式。
构造方法摘要
protected | AbstractWriter(Writer w, Document doc) 创建新的 AbstractWriter。
protected | AbstractWriter(Writer w, Document doc, int pos, int len) 创建新的 AbstractWriter。
protected | AbstractWriter(Writer w, Element root) 创建新的 AbstractWriter。
protected | AbstractWriter(Writer w, Element root, int pos, int len) 创建新的 AbstractWriter。
方法摘要
protected void | decrIndent() 降低缩进级别。
protected boolean | getCanWrapLines() 返回是否可以换行。
protected int | getCurrentLineLength() 返回当前行的长度。
protected Document | getDocument() 获取文档。
protected ElementIterator | getElementIterator() 获取 ElementIterator。
int | getEndOffset() 选择要输出内容的最后一个偏移量。
protected int | getIndentLevel() 返回当前的缩进级别。
protected int | getIndentSpace() 返回要缩进的空格量。
protected int | getLineLength() 返回最大行长度。
String | getLineSeparator() 返回用于表示换行的 String。
int | getStartOffset() 返回要输出内容的第一个偏移量。
protected String | getText(Element elem) 返回与该元素关联的文本。
protected Writer | getWriter() 返回用于输出内容的 Writer。
protected void | incrIndent() 提高缩进级别。
protected void | indent() 执行缩进。
protected boolean | inRange(Element next) 此方法确定当前元素是否位于指定的范围内。
protected boolean | isLineEmpty() 如果应该将当前行视为空行，则返回 true。
protected void | output(char[] content, int start, int length) 写出内容过程的最后一步。
protected void | setCanWrapLines(boolean newValue) 设置是否可以换行。
protected void | setCurrentLineLength(int length) 设置当前行的长度。
protected void | setIndentSpace(int space) 允许子类指定缩进映射为多少空格。
protected void | setLineLength(int l) 允许子类设置每行上要写入的字符数。
void | setLineSeparator(String value) 设置用于表示换行的 String。
protected void | text(Element elem) 写出文本。
protected abstract void | write() 需要由子类实现此抽象方法。
protected void | write(char ch) 写出字符。
protected void | write(char[] chars, int startIndex, int length) 所有 write 方法都调用到此方法。
protected void | write(String content) 写出字符串。
protected void | writeAttributes(AttributeSet attr) 以 " =" 对的形式写出属性集。
protected void | writeLineSeparator() 写入行分隔符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NEWLINE

protected static final char NEWLINE
text 包模拟新行的方式。

另请参见：
getLineSeparator(), 常量字段值
构造方法详细信息

AbstractWriter

protected AbstractWriter(Writer w,
                         Document doc)
创建新的 AbstractWriter。使用默认的文档根初始化 ElementIterator。

参数：
w - Writer。
document - Document。

AbstractWriter

protected AbstractWriter(Writer w,
                         Document doc,
                         int pos,
                         int len)
创建新的 AbstractWriter。使用传入的元素初始化 ElementIterator。

参数：
w - Writer
doc - Element
pos - 在文档中获取内容的位置。
len - 写出量。

AbstractWriter

protected AbstractWriter(Writer w,
                         Element root)
创建新的 AbstractWriter。使用传入的元素初始化 ElementIterator。

参数：
w - Writer
root - Element

AbstractWriter

protected AbstractWriter(Writer w,
                         Element root,
                         int pos,
                         int len)
创建新的 AbstractWriter。使用传入的元素初始化 ElementIterator。

参数：
w - Writer
root - Element
pos - 在文档中获取内容的位置。
len - 写出量。
方法详细信息

getStartOffset

public int getStartOffset()
返回要输出内容的第一个偏移量。

从以下版本开始：
1.3

getEndOffset

public int getEndOffset()
选择要输出内容的最后一个偏移量。

从以下版本开始：
1.3

getElementIterator

protected ElementIterator getElementIterator()
获取 ElementIterator。

返回：
ElementIterator。

getWriter

protected Writer getWriter()
返回用于输出内容的 Writer。

从以下版本开始：
1.3

getDocument

protected Document getDocument()
获取文档。

返回：
Document。

inRange

protected boolean inRange(Element next)
此方法确定当前元素是否位于指定的范围内。未指定范围时，则将范围初始化为整个文档。如果指定的范围与该元素的范围相交，则 inRange() 返回 true。

参数：
next - Element。
返回：
指示元素是否位于该范围的 boolean 值。

write

protected abstract void write()
                       throws IOException,
                              BadLocationException
需要由子类实现此抽象方法。其职责是对元素进行迭代并使用 write() 方法生成所需格式的输出。

抛出：
IOException
BadLocationException

getText

protected String getText(Element elem)
                  throws BadLocationException
返回与该元素关联的文本。此处假定该元素是一个叶元素。遇到错误时抛出 BadLocationException。

参数：
elem - Element
返回：
String 形式的文本
抛出：
BadLocationException - 如果 pos 表示文档内的无效位置

text

protected void text(Element elem)
             throws BadLocationException,
                    IOException
写出文本。如果调用构造方法时指定了范围，则只写出相应范围内的文本。

参数：
elem - Element。
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的一个无效位置

setLineLength

protected void setLineLength(int l)
允许子类设置每行上要写入的字符数。默认值是 100。

参数：
l - 最大行长度。

getLineLength

protected int getLineLength()
返回最大行长度。

从以下版本开始：
1.3

setCurrentLineLength

protected void setCurrentLineLength(int length)
设置当前行的长度。

从以下版本开始：
1.3

getCurrentLineLength

protected int getCurrentLineLength()
返回当前行的长度。

从以下版本开始：
1.3

isLineEmpty

protected boolean isLineEmpty()
如果应该将当前行视为空行，则返回 true。已在空行上调用 getCurrentLineLength == 0 || indent 时返回值仍为 true。

从以下版本开始：
1.3

setCanWrapLines

protected void setCanWrapLines(boolean newValue)
设置是否可以换行。行写入期间可以切换此设置。例如，输出带引号的字符串时，HTML 输出可能将此内容设置为 false。

从以下版本开始：
1.3

getCanWrapLines

protected boolean getCanWrapLines()
返回是否可以换行。如果为 false，则不会输出 lineSeparator。

从以下版本开始：
1.3

setIndentSpace

protected void setIndentSpace(int space)
允许子类指定缩进映射为多少空格。进行缩进时，缩进级别乘以此映射关系。默认值是 2。

参数：
space - 表示将缩进映射为多少空格的 int 值。

getIndentSpace

protected int getIndentSpace()
返回要缩进的空格量。

从以下版本开始：
1.3

setLineSeparator

public void setLineSeparator(String value)
设置用于表示换行的 String。这是在构造方法中根据 Document 或系统属性 line.separator 来初始化的。

从以下版本开始：
1.3

getLineSeparator

public String getLineSeparator()
返回用于表示换行的 String。

从以下版本开始：
1.3

incrIndent

protected void incrIndent()
提高缩进级别。如果正在进行的缩进导致 getIndentSpace() *getIndentLevel() 大于 getLineLength()，则不会进行缩进。

decrIndent

protected void decrIndent()
降低缩进级别。

getIndentLevel

protected int getIndentLevel()
返回当前的缩进级别。也就是用调用 incrIndent 的次数减去调用 decrIndent 的次数。

从以下版本开始：
1.3

indent

protected void indent()
               throws IOException
执行缩进。写出的空格数是缩进级别乘以映射关系所映射的空格。如果当前行为空行，则不会进行缩进，所以当前行仍被认为是空行。

抛出：
IOException - 如果发生任何 I/O 错误

write

protected void write(char ch)
              throws IOException
写出字符。调用以 char[] 为参数的 write 方法来实现字符的写出。

参数：
ch - 一个 char。
抛出：
IOException - 如果发生任何 I/O 错误

write

protected void write(String content)
              throws IOException
写出字符串。调用采用 char[] 的 write 方法来实现字符的写出。

参数：
content - String。
抛出：
IOException - 如果发生任何 I/O 错误

writeLineSeparator

protected void writeLineSeparator()
                           throws IOException
写入行分隔符。这会直接调用 output 并将 lineLength 设置为 0。

抛出：
IOException
从以下版本开始：
1.3

write

protected void write(char[] chars,
                     int startIndex,
                     int length)
              throws IOException
所有 write 方法都调用到此方法。如果 getCanWrapLines() 返回 false，则将使用不包含 NEWLINE 的每个 chars 序列调用 output，然后调用 writeLineSeparator。另一方面，如果 getCanWrapLines() 返回 true，则根据需要拆分字符串，以便遵守 getLineLength。惟一的例外是，如果当前字符串不包含空白，并且在行长度超过 getLineLength 的情况中无法放入该字符串。

抛出：
IOException
从以下版本开始：
1.3

writeAttributes

protected void writeAttributes(AttributeSet attr)
                        throws IOException
以 " =" 对的形式写出属性集。遇到 I/O 错误时抛出 IOException。

参数：
attr - AttributeSet。
抛出：
IOException - 如果发生任何 I/O 错误

output

protected void output(char[] content,
                      int start,
                      int length)
               throws IOException
写出内容过程的最后一步。所有 write 方法最终会被此方法调用，此方法在 Writer 上调用 write。

此方法还根据 length 更新行长度。如果调用此方法来输出新行，则当前行长度因不再有效而需要被重置。如果由调用者决定是否执行此操作，则使用 writeLineSeparator 写出新行，这将正确地更新当前行的长度。

抛出：
IOException
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AsyncBoxView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AsyncBoxView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.AsyncBoxView
所有已实现的接口：
SwingConstants
public class AsyncBoxView
extends View

异步执行布局处理的框。此类很有用，因为它可通过不在 GUI 事件线程中执行任何布局处理来保持该线程的持续活动。布局是在子视图的操作粒度上完成的。访问某部分布局的每个子视图后（可能是耗时的操作），可放弃剩余的任务，或者可执行新的、具有更高优先级的任务（如响应一个同步请求或对一个可见区域进行操作）。

访问子视图的同时，要获得关联文档上的读取锁定，这样该模型在被访问时是稳定的。

从以下版本开始：
1.3

嵌套类摘要
class | AsyncBoxView.ChildLocator 该类在本地化区域发生更改时，管理该本地化区域中子视图的有效位置。
class | AsyncBoxView.ChildState 表示子视图布局状态的记录。
字段摘要
protected  AsyncBoxView.ChildLocator locator
这是管理子视图偏移量的对象。
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
AsyncBoxView(Element elem, int axis)
构造执行异步布局处理的 BoxView。
方法摘要
protected AsyncBoxView.ChildState | createChildState(View v) 通过此方法创建新的 ChildState 记录，以允许扩展 ChildState 记录的子类执行/保存更多状态。
protected void | flushRequirementChanges() 将首选项中的更改向上发布到父视图。
float | getBottomInset() 获得视图四周底部的空白部分。
Shape | getChildAllocation(int index, Shape a) 获取给定子视图的分配区域。
protected AsyncBoxView.ChildState | getChildState(int index) 获取对象，该对象表示在给定索引位置的子视图的布局状态。
protected boolean | getEstimatedMajorSpan() 主跨距当前是估计值吗？
protected float | getInsetSpan(int axis) 获取 insets 所占据的沿某个轴的跨距。
protected LayoutQueue | getLayoutQueue() 获取用于布局处理的队列。
float | getLeftInset() 获得视图四周左侧的空白部分。
int | getMajorAxis() 获取主轴（即子级平铺时沿用的轴）。
float | getMaximumSpan(int axis) 确定此视图沿某轴的最大跨距。
float | getMinimumSpan(int axis) 确定此视图沿某轴的最小跨距。
int | getMinorAxis() 获取辅轴（与平铺轴垂直的轴）。
int | getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
float | getPreferredSpan(int axis) 确定此视图沿某轴的首选跨距。
float | getRightInset() 获得视图四周右侧的空白部分。
float | getTopInset() 获得视图四周顶部的空白部分。
View | getView(int n) 获得第 n 个子视图。
int | getViewCount() 返回此视图中的视图数。
int | getViewIndex(int pos, Position.Bias b) 返回该模型中表示给定位置的子视图索引。
protected int | getViewIndexAtPosition(int pos, Position.Bias b) 获取此模型中表示给定位置的子视图索引。
protected void | loadChildren(ViewFactory f) 加载初始化该视图的所有子级。
protected void | majorRequirementChange(AsyncBoxView.ChildState cs, float delta) 沿主轴上的要求更改。
protected void | minorRequirementChange(AsyncBoxView.ChildState cs) 沿辅轴上的要求更改。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | paint(Graphics g, Shape alloc) 使用给定的分配和呈现表面呈现该视图。
void | preferenceChanged(View child, boolean width, boolean height) 子视图可以在父级上调用此方法，以指示首选项已更改并且应该重新考虑布局。
void | replace(int offset, int length, View[] views) 调用超类以更新子视图，并且更新子视图的状态记录。
void | setBottomInset(float i) 设置视图四周底部的空白部分。
protected void | setEstimatedMajorSpan(boolean isEstimated) 设置 estimatedMajorSpan 属性，它确定是否应该将主跨距视为估计值。
void | setLeftInset(float i) 设置视图四周左侧的空白部分。
void | setParent(View parent) 设置视图的父级。
void | setRightInset(float i) 设置视图四周右侧的空白部分。
void | setSize(float width, float height) 设置视图的大小。
void | setTopInset(float i) 设置视图四周顶部的空白部分。
protected void | updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接收的更改通知。
int | viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getResizeWeight, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, remove, removeAll, removeUpdate, updateChildren, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

locator

protected AsyncBoxView.ChildLocator locator
这是管理子视图偏移量的对象。用于管理子视图位置的所有锁定都位于此对象上。

构造方法详细信息

AsyncBoxView

public AsyncBoxView(Element elem,
                    int axis)
构造执行异步布局处理的 BoxView。

参数：
elem - 要表示的模型元素
axis - 平铺时沿用的轴。这可以是 X_AXIS 或 Y_AXIS 之一。
方法详细信息

getMajorAxis

public int getMajorAxis()
获取主轴（即子级平铺时沿用的轴）。这将是 X_AXIS 或 Y_AXIS 值之一。

getMinorAxis

public int getMinorAxis()
获取辅轴（与平铺轴垂直的轴）。这将是 X_AXIS 或 Y_AXIS 值之一。

getTopInset

public float getTopInset()
获得视图四周顶部的空白部分。

setTopInset

public void setTopInset(float i)
设置视图四周顶部的空白部分。

参数：
i - inset 值

getBottomInset

public float getBottomInset()
获得视图四周底部的空白部分。

setBottomInset

public void setBottomInset(float i)
设置视图四周底部的空白部分。

参数：
i - inset 值

getLeftInset

public float getLeftInset()
获得视图四周左侧的空白部分。

setLeftInset

public void setLeftInset(float i)
设置视图四周左侧的空白部分。

参数：
i - inset 值

getRightInset

public float getRightInset()
获得视图四周右侧的空白部分。

setRightInset

public void setRightInset(float i)
设置视图四周右侧的空白部分。

参数：
i - inset 值

getInsetSpan

protected float getInsetSpan(int axis)
获取 insets 所占据的沿某个轴的跨距。

参数：
axis - 确定总的 insets 所沿用的轴，为 X_AXIS 或 Y_AXIS 之一。
从以下版本开始：
1.4

setEstimatedMajorSpan

protected void setEstimatedMajorSpan(boolean isEstimated)
设置 estimatedMajorSpan 属性，它确定是否应该将主跨距视为估计值。如果此属性为 true，则沿主轴方向的 setSize 值将更改沿主轴方向的要求，并且在更新所有子级之前（更新子级会导致自动将该属性设置为 false）忽略递增量。如果该属性为 false，则认为 majorSpan 的值是准确的，并且在计算时将递增量添加到总值中。

从以下版本开始：
1.4

getEstimatedMajorSpan

protected boolean getEstimatedMajorSpan()
主跨距当前是估计值吗？

从以下版本开始：
1.4

getChildState

protected AsyncBoxView.ChildState getChildState(int index)
获取对象，该对象表示在给定索引位置的子视图的布局状态。

参数：
index - 子视图索引。这应该是一个 >= 0 且 < getViewCount() 的值。

getLayoutQueue

protected LayoutQueue getLayoutQueue()
获取用于布局处理的队列。

createChildState

protected AsyncBoxView.ChildState createChildState(View v)
通过此方法创建新的 ChildState 记录，以允许扩展 ChildState 记录的子类执行/保存更多状态。

majorRequirementChange

protected void majorRequirementChange(AsyncBoxView.ChildState cs,
                                      float delta)
沿主轴上的要求更改。当执行布局处理的线程完成获取子视图新首选项的任务后，由该线程为给定的 ChildState 对象调用此方法。通常这是布局线程，但是如果要尝试立即更新某些内容（例如执行模型/视图转换），则它也可能是事件线程。

实现此方法以便将主轴标记为已更改，所以如果需要将要求发布到父视图，后续的检查可查看是否将主轴考虑在内。如果沿主轴的跨距不是估计值，则通过给定的 delta 更新它，以反映递增量。如果主跨距是估计值，则忽略 delta。

minorRequirementChange

protected void minorRequirementChange(AsyncBoxView.ChildState cs)
沿辅轴上的要求更改。当执行布局处理的线程完成获取子视图新首选项的任务后，由该线程为给定的 ChildState 对象调用此方法。通常这是布局线程，但是如果要尝试立即更新某些内容（例如执行模型/视图转换），则它也可能是 GUI 线程。

flushRequirementChanges

protected void flushRequirementChanges()
将首选项中的更改向上发布到父视图。它通常由布局线程调用。

replace

public void replace(int offset,
                    int length,
                    View[] views)
调用超类以更新子视图，并且更新子视图的状态记录。应该在模型持有写入锁定的同时调用此方法，这样将不会发生与布局线程的交互（例如，布局线程获得读取锁定后才能执行任何操作）。

覆盖：
类 View 中的 replace
参数：
offset - 子视图中的起始偏移量，该值 >= 0
length - 要替换的现有视图数，该值 >= 0
views - 要插入的子视图

loadChildren

protected void loadChildren(ViewFactory f)
加载初始化该视图的所有子级。此方法由 setParent 方法调用。子类可重新实现此方法，从而以不同的方式初始化其子视图。默认的实现为每个子元素创建一个子视图。

通常在更改子元素时 Document 上会持有写入锁定，这可保持呈现和布局线程的安全。例外情况是初始化视图以表示现有的元素时（通过此方法），所以在进行初始化的时候它是同步的，以将 preferenceChanged 排除在外。

参数：
f - 视图工厂
另请参见：
setParent(javax.swing.text.View)

getViewIndexAtPosition

protected int getViewIndexAtPosition(int pos,
                                     Position.Bias b)
获取此模型中表示给定位置的子视图索引。在每个子元素都有一个子视图的情况下，实现此方法可获取该视图。

参数：
pos - 位置，该值 >= 0
返回：
表示给定位置的视图的索引，如果没有视图表示该位置，则返回 -1

updateLayout

protected void updateLayout(DocumentEvent.ElementChange ec,
                            DocumentEvent e,
                            Shape a)
更新布局，以响应从模型接收的更改通知。实现此方法可记录 ChildLocator 上的更改，这样可正确地计算子级的偏移量。

覆盖：
类 View 中的 updateLayout
参数：
ec - 对此视图所负责的元素的更改（如果没有更改则可能为 null）。
e - 来自相关文档的更改信息
a - 该视图的当前分配区域
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

setParent

public void setParent(View parent)
设置视图的父级。如果此视图没有子级，则可重新实现此方法以提供超类行为并调用 loadChildren 方法。子级不应在构造方法中加载，因为设置父级的操作可能会导致其尝试向上搜索层次结构（例如获得宿主 Container）。如果此视图具有子视图（将该视图从视图层次结构中的一个位置移到另一个位置），则不调用 loadChildren 方法。

覆盖：
类 View 中的 setParent
参数：
parent - 视图的父级，如果没有，则为 null

preferenceChanged

public void preferenceChanged(View child,
                              boolean width,
                              boolean height)
子视图可以在父级上调用此方法，以指示首选项已更改并且应该重新考虑布局。重新实现此方法可在布局线程上对新工作进行排队。此方法通过子视图获得来自多个线程的消息。

覆盖：
类 View 中的 preferenceChanged
参数：
child - 子视图
width - 如果已更改宽度首选项，则为 true
height - 如果已更改高度首选项，则为 true
另请参见：
JComponent.revalidate()

setSize

public void setSize(float width,
                    float height)
设置视图的大小。如果该视图缓存了任何布局信息，则此操作会导致视图进行布局处理。

由于主轴是异步更新的，并且应该是已平铺子级的和，所以对于主轴应忽略该调用。由于辅轴是很灵活的，所以如果辅跨距更改了，则将工作放入队列以调整子视图的大小。

覆盖：
类 View 中的 setSize
参数：
width - 宽度，该值 >= 0
height - 高度，该值 >= 0

paint

public void paint(Graphics g,
                  Shape alloc)
使用给定的分配和呈现表面呈现该视图。

实现此方法可确定要呈现的所需区域（如非剪贴区域）是否为最新的。如果是最新的，则呈现子视图。如果不是最新的，则将构建所需区域的任务作为最高优先级的任务放入布局队列中。在准备就绪时，此方法通过事件线程和渲染来持续运行，在尚未准备就绪时推迟一段时间（因为可以重新安排绘制请求）。

指定者：
类 View 中的 paint
参数：
g - 要使用的呈现表面
alloc - 要在其中进行呈现的已分配区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某轴的首选跨距。

指定者：
类 View 中的 getPreferredSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的跨距，该值 >= 0。通常会通知该视图呈现到返回的跨距中，但并不能保证。父级可选择重新调整视图大小或分解视图。
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

getMinimumSpan

public float getMinimumSpan(int axis)
确定此视图沿某轴的最小跨距。

覆盖：
类 View 中的 getMinimumSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的跨距，该值 >= 0。通常会通知该视图呈现到返回的跨距中，但并不能保证。父级可选择重新调整视图大小或拆分视图。
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

getMaximumSpan

public float getMaximumSpan(int axis)
确定此视图沿某轴的最大跨距。

覆盖：
类 View 中的 getMaximumSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的跨距，该值 >= 0。通常会通知该视图呈现到返回的跨距中，但并不能保证。父级可选择重新调整视图大小或拆分视图。
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

getViewCount

public int getViewCount()
返回此视图中的视图数。由于默认不应是复合视图，因此此方法返回 0。

覆盖：
类 View 中的 getViewCount
返回：
视图数，该值 >= 0
另请参见：
View.getViewCount()

getView

public View getView(int n)
获得第 n 个子视图。由于默认没有子视图，所以此方法返回 null。

覆盖：
类 View 中的 getView
参数：
n - 要获得的视图编号，该值 >= 0 && < getViewCount()
返回：
视图

getChildAllocation

public Shape getChildAllocation(int index,
                                Shape a)
获取给定子视图的分配区域。这就允许找出各种视图的位置，而无需假定视图存储其位置。由于默认没有任何子视图，所以此方法返回 null。

覆盖：
类 View 中的 getChildAllocation
参数：
index - 子视图的索引，该值 >= 0 && < getViewCount()
a - 此视图的分配区域。
返回：
子视图的分配区域

getViewIndex

public int getViewIndex(int pos,
                        Position.Bias b)
返回该模型中表示给定位置的子视图索引。默认情况下视图没有子视图，所以此方法的实现返回 -1，以指示任何位置都没有有效的子视图索引。

覆盖：
类 View 中的 getViewIndex
参数：
pos - 位置，该值 >= 0
返回：
表示给定位置的视图的索引，如果没有视图表示该位置，则返回 -1
从以下版本开始：
1.3

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

指定者：
类 View 中的 modelToView
参数：
pos - 要转换的位置，该值 >= 0
a - 要呈现于其中的已分配区域
b - 在该位置是两个视图的边界时，为偏向前一个字符或下一个字符的偏差，由偏移量表示。
返回：
返回给定位置的边界框
抛出：
BadLocationException - 如果给定的位置不表示关联文档内的有效位置
IllegalArgumentException - 如果 bias 参数无效
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

viewToModel

public int viewToModel(float x,
                       float y,
                       Shape a,
                       Position.Bias[] biasReturn)
提供从视图坐标空间到模型逻辑坐标空间的映射。填入 biasReturn 参数可指示给定的点是靠近模型中的下一个字符还是模型中的前一个字符。

预计由 GUI 线程调用此方法，在关联的模型上保持读取锁定。实现此方法可定位子视图，并通过对 ChildLocator 对象执行锁定来确定其分配，以及通过对 ChildLocator 对象执行锁定对子视图调用 viewToModel，以避免与布局线程相互干扰。

指定者：
类 View 中的 viewToModel
参数：
x - X 坐标，该值 >= 0
y - Y 坐标，该值 >= 0
a - 要在其中进行呈现的已分配区域
返回：
模型中的位置，它可最佳地表示视图中的给定点，该值 >= 0。填入 biasReturn 参数可指示给定的点是靠近模型中的下一个字符还是模型中的前一个字符。

getNextVisualPositionFrom

public int getNextVisualPositionFrom(int pos,
                                     Position.Bias b,
                                     Shape a,
                                     int direction,
                                     Position.Bias[] biasRet)
                              throws BadLocationException
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。有些视图可能是不可见的，它们的顺序可能与模型中的顺序不同，或者它们可能不允许访问模型中的某些位置。

覆盖：
类 View 中的 getNextVisualPositionFrom
参数：
pos - 要转换的位置，该值 >= 0
a - 要在其中进行呈现的已分配区域
direction - 从当前位置开始的方向，可以将它们设想为通常可在键盘上找到的箭头键；可为下列值：
    SwingConstants.WEST SwingConstants.EAST SwingConstants.NORTH SwingConstants.SOUTH
biasRet - 包含要检查的偏差的数组
返回：
模型中的位置，它可最佳地以可视化定位方式表示视图中的下一个位置
抛出：
BadLocationException
IllegalArgumentException - 如果 direction 无效
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AsyncBoxView.ChildLocator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AsyncBoxView.ChildLocator

java.lang.Object
    继承者  javax.swing.text.AsyncBoxView.ChildLocator
正在封闭类：
AsyncBoxView
public class AsyncBoxView.ChildLocator
extends Object

该类在本地化区域发生更改时，管理该本地化区域中子视图的有效位置。AsyncBoxView 可能在不断地更改，但是在布局线程决定向父级发布更新之前，可见的区域需要保持相对的稳定。

从以下版本开始：
1.3

字段摘要
protected Rectangle | childAlloc 用于子级分配区域以避免创建大量垃圾的形状。
protected Rectangle | lastAlloc 最后的可见分配区域（用于向上刷新更改时进行重新绘制）。
protected AsyncBoxView.ChildState | lastValidOffset 最后一次有效偏移量计算的位置。
构造方法摘要
AsyncBoxView.ChildLocator()
构造 ChildLocator。
方法摘要
void | childChanged(AsyncBoxView.ChildState cs) 子级已更改的通知。
protected Shape | getChildAllocation(int index) 获取用于子视图的分配区域。
Shape | getChildAllocation(int index, Shape a) 获取用于子视图的分配区域。
int | getViewIndexAtPoint(float x, float y, Shape a) 获取位于给定点的子视图索引。
protected int | getViewIndexAtVisualOffset(float targetOffset) 查找负责表示沿主轴方向框中偏移量位置的视图。
void | paintChildren(Graphics g) 绘制与剪贴区域相交的子级。
protected void | setAllocation(Shape a) 将当前已分配的形状复制到用于存储当前分配区域的 Rectangle 中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

lastValidOffset

protected AsyncBoxView.ChildState lastValidOffset
最后一次有效偏移量计算的位置。

lastAlloc

protected Rectangle lastAlloc
最后的可见分配区域（用于向上刷新更改时进行重新绘制）。

childAlloc

protected Rectangle childAlloc
用于子级分配区域以避免创建大量垃圾的形状。

构造方法详细信息

AsyncBoxView.ChildLocator

public AsyncBoxView.ChildLocator()
构造 ChildLocator。

方法详细信息

childChanged

public void childChanged(AsyncBoxView.ChildState cs)
子级已更改的通知。无论是否需要新的偏移量计算这都有效。由已更改其主跨距的 ChildState 对象调用此方法。所以此方法可以由多个线程调用。

paintChildren

public void paintChildren(Graphics g)
绘制与剪贴区域相交的子级。

getChildAllocation

public Shape getChildAllocation(int index,
                                Shape a)
获取用于子视图的分配区域。这将更新那些位于给定索引之前尚未更新的所有子级的偏移量。

getViewIndexAtPoint

public int getViewIndexAtPoint(float x,
                               float y,
                               Shape a)
获取位于给定点的子视图索引。此方法由各种 View 方法调用，这些方法需要计算将消息转发到哪个子视图。这应该由在此对象上同步的代码块调用，并且通常应该后跟一个或多个对 getChildAllocation 的调用，该调用也应该在同步的代码块中进行。

参数：
x - X 坐标，该坐标 >= 0
y - Y 坐标，该坐标 >= 0
a - View 的分配区域
返回：
最近的子视图索引

getChildAllocation

protected Shape getChildAllocation(int index)
获取用于子视图的分配区域。这不更新 ChildState 记录中的偏移量。

setAllocation

protected void setAllocation(Shape a)
将当前已分配的形状复制到用于存储当前分配区域的 Rectangle 中。在特定于 Java2D 的实现中，这是一个浮点矩形。

getViewIndexAtVisualOffset

protected int getViewIndexAtVisualOffset(float targetOffset)
查找负责表示沿主轴方向框中偏移量位置的视图。确保在 ChildState 对象上设置的偏移量最高到超出所需偏移量的给定目标跨距。

返回：
表示给定可见位置的视图索引 (targetOffset)，如果没有视图表示该位置，则返回 -1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AsyncBoxView.ChildState (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 AsyncBoxView.ChildState

java.lang.Object
    继承者  javax.swing.text.AsyncBoxView.ChildState
所有已实现的接口：
Runnable
正在封闭类：
AsyncBoxView
public class AsyncBoxView.ChildState
extends Object
implements Runnable

表示子视图布局状态的记录。它作为另一个线程上的任务是可运行的。所有基于模型上的读取锁定、对子视图的访问在此对象上都应该是同步的（例如，布局线程和 GUI 线程可同时在模型上具有读取锁定，并且相互之间不设置保护）。通过对 ChildState 实例的同步，对子视图层次结构的访问是序列化的。

从以下版本开始：
1.3

构造方法摘要
AsyncBoxView.ChildState(View v)
构造子视图状态。
方法摘要
View | getChildView() 获取此记录表示的子视图。
float | getMajorOffset() 沿主轴的偏移量是什么。
float | getMajorSpan() 沿主轴的跨距是什么。
float | getMinorOffset() 沿辅轴的偏移量是什么
float | getMinorSpan() 沿辅轴的跨距是什么。
boolean | isLayoutValid() 是否已对子视图进行布局。
void | preferenceChanged(boolean width, boolean height) 标记此子视图更改的首选项。
void | run() 更新 ChildState。
void | setMajorOffset(float offs) 此方法应该仅由 ChildLocator 调用，它只是一个保存缓存位置的便捷场所。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AsyncBoxView.ChildState

public AsyncBoxView.ChildState(View v)
构造子视图状态。这需要从相当大的范围开始，这样在开始就不会错误地认为所有子视图都是可见的。

从以下版本开始：
1.4
方法详细信息

getChildView

public View getChildView()
获取此记录表示的子视图。

run

public void run()
更新 ChildState。此方法应该由需要花费一定时间更新子视图状态的线程调用（应该是布局线程）。

在更新期间要求在关联的文档上获得一个读取锁定，从而确保进行操作时模型不被更改。首先应检查是否需要实际完成工作。然后在等待更新状态的同时可发生下列可能的事件：

  1. 可能已从视图层次结构中移除了子视图。
  2. 可能已由更高优先级的操作更新了子视图（如子视图可能变为可见的）。

指定者：
接口 Runnable 中的 run
另请参见：
Thread.run()

getMinorSpan

public float getMinorSpan()
沿辅轴的跨距是什么。

getMinorOffset

public float getMinorOffset()
沿辅轴的偏移量是什么

getMajorSpan

public float getMajorSpan()
沿主轴的跨距是什么。

getMajorOffset

public float getMajorOffset()
沿主轴的偏移量是什么。

setMajorOffset

public void setMajorOffset(float offs)
此方法应该仅由 ChildLocator 调用，它只是一个保存缓存位置的便捷场所。

preferenceChanged

public void preferenceChanged(boolean width,
                              boolean height)
标记此子视图更改的首选项。

参数：
width - 如果已更改宽度首选项，则为 true
height - 如果已更改高度首选项，则为 true
另请参见：
JComponent.revalidate()

isLayoutValid

public boolean isLayoutValid()
是否已对子视图进行布局。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeSet (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 AttributeSet

所有已知子接口：
MutableAttributeSet, Style
所有已知实现类：
AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement, SimpleAttributeSet, StyleContext.NamedStyle, StyleContext.SmallAttributeSet
public interface AttributeSet

唯一属性的集合。这是只读的、不可变的接口。属性基本上是键和与该键关联的值。该集合可能表示类似于 run 风格、逻辑风格等内容。这些内容通常用于描述某个图形表示形式（如字体）的功能。可能键的集合是无界的,并且可以是任何内容。通常，View 实现将响应属性定义并呈现某些内容来表示该属性。

可以以层次结构的方式解析各个属性。如果某个键无法在本地解析，且它存在解析父集合，则通过该父集合来解析该键。

另请参见：
MutableAttributeSet

嵌套类摘要
static interface | AttributeSet.CharacterAttribute 此接口是类型签名，可出现在任意属性键上以帮助实现字符级的表示。
static interface | AttributeSet.ColorAttribute 此接口是类型签名，可出现在任意属性键上以帮助实现颜色的表示。
static interface | AttributeSet.FontAttribute 此接口是类型签名，可出现在任意属性键上以帮助确定使用何种字体来呈现某类文本。
static interface | AttributeSet.ParagraphAttribute 此接口是类型签名，可出现在任意属性键上以帮助实现段落级的表示。
字段摘要
static Object | NameAttribute 用于命名属性集合的属性名。
static Object | ResolveAttribute 用于标识解析父集合属性集（如果已定义）的属性名。
方法摘要
boolean | containsAttribute(Object name, Object value) 如果此集合用相同的名称和相等值定义一个属性，则返回 true 。
boolean | containsAttributes(AttributeSet attributes) 如果此集合用相等值定义给定集合中的所有属性，则返回 true。
AttributeSet | copyAttributes() 返回保证固定不变的属性集。
Object | getAttribute(Object key) 获取给定属性的值。
int | getAttributeCount() 返回此集合中本地定义的属性个数。
Enumeration<?> | getAttributeNames() 返回集合中本地定义的属性名称的枚举。
AttributeSet | getResolveParent() 获取解析父集合。
boolean | isDefined(Object attrName) 检查指定属性是否具有该属性集中指定的值，而无需通过其他属性集进行解析。
boolean | isEqual(AttributeSet attr) 确定两个属性集是否相等。

字段详细信息

NameAttribute

static final Object NameAttribute
用于命名属性集合的属性名。

ResolveAttribute

static final Object ResolveAttribute
用于标识解析父集合属性集（如果已定义）的属性名。

方法详细信息

getAttributeCount

int getAttributeCount()
返回此集合中本地定义的属性个数。不包括父集合中定义的属性。

返回：
属性数，该数 >= 0

isDefined

boolean isDefined(Object attrName)
检查指定属性是否具有该属性集中指定的值，而无需通过其他属性集进行解析。

参数：
attrName - 属性名
返回：
如果该属性具有指定的值，则返回 true

isEqual

boolean isEqual(AttributeSet attr)
确定两个属性集是否相等。

参数：
attr - 属性集
返回：
如果两个属性集相等，则返回 true

copyAttributes

AttributeSet copyAttributes()
返回保证固定不变的属性集。

返回：
属性集的一个副本

getAttribute

Object getAttribute(Object key)
获取给定属性的值。如果在本地未找到该值，则继续向上搜索解析父集合（如果存在），直至找到该值或没有其他的父集合为止。如果未找到该值，则返回 null。

参数：
key - 该属性绑定的非 null 键
返回：
值

getAttributeNames

Enumeration<?> getAttributeNames()
返回集合中本地定义的属性名称的枚举。不包括在解析父集合中定义的属性名称（如果有）。Enumeration 的值可以是任何内容，而不仅限于特定的 Object 类型。

此方法不返回 null。对于没有属性的集合，此方法返回空 Enumeration。

返回：
名称

containsAttribute

boolean containsAttribute(Object name,
                          Object value)
如果此集合用相同的名称和相等值定义一个属性，则返回 true 。如果在本地没有找到这种属性，则在解析父集合层次中进行搜索。

参数：
name - 非 null 的属性名
value - 值
返回：
如果集合用相等值定义该属性，不管是在本地还是通过其解析父集合，都返回 true
抛出：
NullPointerException - 如果 name 或 value 为 null

containsAttributes

boolean containsAttributes(AttributeSet attributes)
如果此集合用相等值定义给定集合中的所有属性，则返回 true。如果在本地没有找到属性，则在解析父集合层次中进行搜索。

参数：
attributes - 要检查的属性集
返回：
如果此集合用相等值定义所有属性，不管在本地还是通过其解析父集合，都返回 true
抛出：
NullPointerException - 如果 attributes 为 null

getResolveParent

AttributeSet getResolveParent()
获取解析父集合。

返回：
父集合
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeSet.CharacterAttribute (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 AttributeSet.CharacterAttribute

所有已知实现类：
StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants
正在封闭接口：
AttributeSet
public static interface AttributeSet.CharacterAttribute

此接口是类型签名，可出现在任意属性键上以帮助实现字符级的表示。这将是应用到所谓 run 风格内容的所有属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeSet.ColorAttribute (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 AttributeSet.ColorAttribute

所有已知实现类：
StyleConstants.ColorConstants
正在封闭接口：
AttributeSet
public static interface AttributeSet.ColorAttribute

此接口是类型签名，可出现在任意属性键上以帮助实现颜色的表示。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeSet.FontAttribute (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 AttributeSet.FontAttribute

所有已知实现类：
StyleConstants.FontConstants
正在封闭接口：
AttributeSet
public static interface AttributeSet.FontAttribute

此接口是类型签名，可出现在任意属性键上以帮助确定使用何种字体来呈现某类文本。这不是一个封闭集合，其定义可在不同平台版本间发生改变，并且可通过其他用户添加的条目而得到修正，这些条目与特定于某些内容的逻辑设置相对应。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeSet.ParagraphAttribute (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 AttributeSet.ParagraphAttribute

所有已知实现类：
StyleConstants.ParagraphConstants
正在封闭接口：
AttributeSet
public static interface AttributeSet.ParagraphAttribute

此接口是类型签名，可出现在任意属性键上以帮助实现段落级的表示。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BadLocationException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 BadLocationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.swing.text.BadLocationException
所有已实现的接口：
Serializable
public class BadLocationException
extends Exception

此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
BadLocationException(String s, int offs)
创建新的 BadLocationException 对象。
方法摘要
 int offsetRequested()
返回文档中的非法偏移量。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BadLocationException

public BadLocationException(String s,
                            int offs)
创建新的 BadLocationException 对象。

参数：
s - 一个指示参数所发生的错误的字符串
offs - 文档中的偏移量，要求 >= 0
方法详细信息

offsetRequested

public int offsetRequested()
返回文档中的非法偏移量。

返回：
偏移量 >= 0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BoxView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 BoxView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
所有已实现的接口：
SwingConstants
直接已知子类：
BlockView, FlowView, TableView, TableView.TableCell, TableView.TableRow, WrappedPlainView, ZoneView
public class BoxView
extends CompositeView

一个视图，它通过沿某轴平铺将其子级排列到框形状中。此框与 TeX 中的框有些类似，它需要处理子级的对齐方式，还要考虑到子级的灵活性等等。这是一个构造块，可用于表示类似线、段落、列表、列、页面等的集合。子级平铺时沿用的轴被视为主轴。与它垂直的轴为辅轴。

每个轴的布局分别由 layoutMajorAxis 和 layoutMinorAxis 方法单独处理。子类可通过重新实现这些方法来更改该布局算法。需要时将根据是否有缓存布局信息以及此缓存是否有效来调用这些方法。通常情况下，当沿轴的给定大小发生更改，或者调用了 layoutChanged 对布局强制更新时，此方法被调用。layoutChanged 方法使缓存布局信息无效（如果有）。发布到父视图的要求是通过 calculateMajorAxisRequirements 和 calculateMinorAxisRequirements 进行计算的。如果布局算法已更改，这些方法按道理都需要重新实现。

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
BoxView(Element elem, int axis)
构造一个 BoxView。
方法摘要
protected void | baselineLayout(int targetSpan, int axis, int[] offsets, int[] spans) 在给定的 targetSpan 区域，即我们将使用的区域的宽度（或高度），计算每个子视图在此 BoxView 中的位置和扩展。
protected SizeRequirements | baselineRequirements(int axis, SizeRequirements r) 通过检查每个子视图的大小计算此 BoxView 的大小要求。
protected SizeRequirements | calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算主轴 axis 的大小要求。
protected SizeRequirements | calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴 axis 的大小要求。
protected void | childAllocation(int index, Rectangle alloc) 为子视图分配一个区域。
protected boolean | flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图的放置方向。
protected void | forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
float | getAlignment(int axis) 确定此视图沿某个轴所需的调整值。
int | getAxis() 获取平铺轴属性。
Shape | getChildAllocation(int index, Shape a) 获取给定子视图的分配。
int | getHeight() 返回框的当前高度。
float | getMaximumSpan(int axis) 确定此视图沿某个轴的最大区域。
float | getMinimumSpan(int axis) 确定此视图沿某个轴的最小区域。
protected int | getOffset(int axis, int childIndex) 获取特定子级当前布局的偏移量。
float | getPreferredSpan(int axis) 确定此视图沿某个轴的首选区域。
int | getResizeWeight(int axis) 获取调整的权重。
protected int | getSpan(int axis, int childIndex) 获取特定子级的当前布局的区域。
protected View | getViewAtPoint(int x, int y, Rectangle alloc) 获取给定坐标处的子视图。
int | getWidth() 返回框的当前宽度。
protected boolean | isAfter(int x, int y, Rectangle innerAlloc) 确定一个点是否位于分配区域的后面。
protected boolean | isAllocationValid() 子级分配是否仍有效。
protected boolean | isBefore(int x, int y, Rectangle innerAlloc) 确定一个点是否位于分配区域的前面。
protected boolean | isLayoutValid(int axis) 确定沿给定轴的布局是否有效。
protected void | layout(int width, int height) 执行对框的布局
void | layoutChanged(int axis) 使沿某轴的布局变得无效。
protected void | layoutMajorAxis(int targetSpan, int axis, int[] offsets, int[] spans) 执行对框的主轴的布局（即它所代表的轴）。
protected void | layoutMinorAxis(int targetSpan, int axis, int[] offsets, int[] spans) 执行对框的辅轴的布局（即与它所代表的轴垂直的轴）。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
void | paint(Graphics g, Shape allocation) 使用该面给定的呈现面和区域呈现 BoxView。
protected void | paintChild(Graphics g, Rectangle alloc, int index) 绘制一个子级。
void | preferenceChanged(View child, boolean width, boolean height) 这由子级来调用，以表明它的首选项区域已更改。
void | replace(int index, int length, View[] elems) 使布局变得无效并调整所需/分配的缓存大小。
void | setAxis(int axis) 设置平铺轴属性。
void | setSize(float width, float height) 设置视图的大小。
int | viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets, setParent
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BoxView

public BoxView(Element elem,
               int axis)
构造一个 BoxView。

参数：
elem - 此视图负责的元素
axis - View.X_AXIS 或 View.Y_AXIS 之一
方法详细信息

getAxis

public int getAxis()
获取平铺轴属性。这是子视图平铺沿用的轴。

返回：
框的主轴，可以是 View.X_AXIS 或 View.Y_AXIS
从以下版本开始：
1.3

setAxis

public void setAxis(int axis)
设置平铺轴属性。这是子视图平铺沿用的轴。

参数：
axis - View.X_AXIS 或 View.Y_AXIS 之一
从以下版本开始：
1.3

layoutChanged

public void layoutChanged(int axis)
使沿某轴的布局变得无效。如果任何一个子视图的首选项发生更改，将自动使所沿轴的布局变得无效。有些情况下，如果首选项未更改，则可能需要重新计算布局。调用此方法可将布局标记为无效。下次在此视图（通常在绘制中）上调用 setSize 方法时，布局将被更新。

参数：
axis - View.X_AXIS 或 View.Y_AXIS 之一
从以下版本开始：
1.3

isLayoutValid

protected boolean isLayoutValid(int axis)
确定沿给定轴的布局是否有效。

参数：
axis - View.X_AXIS 或 View.Y_AXIS 之一
从以下版本开始：
1.4

paintChild

protected void paintChild(Graphics g,
                          Rectangle alloc,
                          int index)
绘制一个子级。默认情况下，这就是它所执行的所有功能，但是子类可使用此方法绘制与该子级有关的组件。

参数：
g - 图像上下文
alloc - 分配的要向其绘制的区域
index - 子级的索引，该索引 >= 0 && < getViewCount()

replace

public void replace(int index,
                    int length,
                    View[] elems)
使布局变得无效并调整所需/分配的缓存大小。旧布局中的子级分配仍可被访问，但是新的子级将都有一个值为 0 的偏移量和区域。

覆盖：
类 CompositeView 中的 replace
参数：
index - 要插入新视图的子视图的开始索引；其值 >= 0 且 <= getViewCount
length - 要移除的现有子视图数；其值 >= 0 且 <= (getViewCount() - offset)
elems - 要添加的子视图；此值可以为 null，表示没有要添加的子级（对移除有用）

forwardUpdate

protected void forwardUpdate(DocumentEvent.ElementChange ec,
                             DocumentEvent e,
                             Shape a,
                             ViewFactory f)
将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。如果有一个子级更改了它的要求并且在转发前分配为有效，则框中从开始子级到框结束部分将被重新绘制。

覆盖：
类 View 中的 forwardUpdate
参数：
ec - 此视图负责的元素发生的更改（如果未发生更改，则为 null）
e - 来自相关文档的更改信息
a - 视图的当前分配
f - 重新构造时需要使用的工厂（如果视图有子级）
从以下版本开始：
1.3
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

preferenceChanged

public void preferenceChanged(View child,
                              boolean width,
                              boolean height)
这由子级来调用，以表明它的首选项区域已更改。实现此方法可丢弃缓存布局信息，以便在子级下次需要分配时执行新的计算。

覆盖：
类 View 中的 preferenceChanged
参数：
child - 子视图
width - 如果应更改宽度首选项，则为 true
height - 如果应更改高度首选项，则为 true
另请参见：
JComponent.revalidate()

getResizeWeight

public int getResizeWeight(int axis)
获取调整的权重。对于小于等于 0 的值，无法调整大小。

覆盖：
类 View 中的 getResizeWeight
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
权重
抛出：
IllegalArgumentException - 如果轴无效

setSize

public void setSize(float width,
                    float height)
设置视图的大小。如果视图缓存了任何布局信息，此方法将对视图布局。实现此方法以调用布局方法，调用参数为 insets 内部的大小。

覆盖：
类 View 中的 setSize
参数：
width - 宽度 >= 0
height - 高度 >= 0

paint

public void paint(Graphics g,
                  Shape allocation)
使用该面给定的呈现面和区域呈现 BoxView。只呈现与给定 Graphics 边界相交的子级。

指定者：
类 View 中的 paint
参数：
g - 要使用的呈现面
allocation - 要呈现的已分配区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getChildAllocation

public Shape getChildAllocation(int index,
                                Shape a)
获取给定子视图的分配。这有助于获得各个视图所处的位置。实现此方法，如果布局为无效，则返回 null，否则执行超类行为。

覆盖：
类 CompositeView 中的 getChildAllocation
参数：
index - 子级的索引，该索引 >= 0 && < getViewCount()
a - 对此视图的分配
返回：
对此子级的分配；或者，如果 a 为 null 则返回 null；如果布局无效，则返回 null

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。这确保在调用超类之前分配有效。

覆盖：
类 CompositeView 中的 modelToView
参数：
pos - 要转换的位置，其值 >= 0
a - 分配的要在其中呈现的区域
b - 一个偏移值，可以是 Position.Bias.Forward 或 Position.Bias.Backward
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置在所关联的文档中不是一个有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public int viewToModel(float x,
                       float y,
                       Shape a,
                       Position.Bias[] bias)
提供从视图坐标空间到模型逻辑坐标空间的映射。

覆盖：
类 CompositeView 中的 viewToModel
参数：
x - 要转换的视图位置的 x 坐标，其值 >= 0
y - 要转换的视图位置的 y 坐标，其值 >= 0
a - 分配的要在其中呈现的区域
bias - 可以是 Position.Bias.Forward 或 Position.Bias.Backward
返回：
模型中最能代表视图中给定点的位置，其值 >= 0
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

getAlignment

public float getAlignment(int axis)
确定此视图沿某个轴所需的调整值。实现此方法可提供要将所有子级沿垂直平铺轴的轴按对齐点排列所需的总调整值。要平铺的轴将请求居中（即 0.5f）。

覆盖：
类 View 中的 getAlignment
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
所需的调整值，该值 >= 0.0f && <= 1.0f；它应该是一个介于 0.0 和 1.0 之间的值，0 表示在原点对齐，1.0 表示在离开原点的整个区域对齐；调整值为 0.5 表示视图居中
抛出：
IllegalArgumentException - 如果轴无效

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某个轴的首选区域。

指定者：
类 View 中的 getPreferredSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，其值 >= 0；通常会告知该视图在返回的区域中呈现，但不保证一定如此；父级可选择重新调整视图大小或拆分视图
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

getMinimumSpan

public float getMinimumSpan(int axis)
确定此视图沿某个轴的最小区域。

覆盖：
类 View 中的 getMinimumSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，其值 >= 0；通常会告知该视图在返回的区域中呈现，但不保证一定如此；父级可选择重新调整视图大小或拆分视图
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

getMaximumSpan

public float getMaximumSpan(int axis)
确定此视图沿某个轴的最大区域。

覆盖：
类 View 中的 getMaximumSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，其值 >= 0；通常会告知该视图在返回的区域中呈现，但不保证一定如此；父级可选择重新调整视图大小或拆分视图
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

isAllocationValid

protected boolean isAllocationValid()
子级分配是否仍有效。

返回：
如果分配仍有效，则返回 true

isBefore

protected boolean isBefore(int x,
                           int y,
                           Rectangle innerAlloc)
确定一个点是否位于分配区域的前面。

指定者：
类 CompositeView 中的 isBefore
参数：
x - X 坐标，该坐标 >= 0
y - Y 坐标，该坐标 >= 0
innerAlloc - 已分配区域；这是 insets 内部的区域
返回：
如果该点位于区域的前面，则返回 true；否则返回 false

isAfter

protected boolean isAfter(int x,
                          int y,
                          Rectangle innerAlloc)
确定一个点是否位于分配区域的后面。

指定者：
类 CompositeView 中的 isAfter
参数：
x - X 坐标，该坐标 >= 0
y - Y 坐标，该坐标 >= 0
innerAlloc - 已分配区域；这是 insets 内部的区域
返回：
如果该点位于区域的后面，则返回 true；否则返回 false

getViewAtPoint

protected View getViewAtPoint(int x,
                              int y,
                              Rectangle alloc)
获取给定坐标处的子视图。

指定者：
类 CompositeView 中的 getViewAtPoint
参数：
x - X 坐标，该坐标 >= 0
y - Y 坐标，该坐标 >= 0
alloc - 父级在入口处的内部分配，在出口处应将更改为子级的分配
返回：
视图

childAllocation

protected void childAllocation(int index,
                               Rectangle alloc)
为子视图分配一个区域。

指定者：
类 CompositeView 中的 childAllocation
参数：
index - 要为子视图分配的索引，该索引 >= 0 && < getViewCount()
alloc - 分配的区域

layout

protected void layout(int width,
                      int height)
执行对框的布局

参数：
width - insets 的内部宽度，该宽度 >= 0
height - insets 的内部高度，该高度 >= 0

getWidth

public int getWidth()
返回框的当前宽度。这是上次为其分配的宽度。

返回：
框的当前宽度

getHeight

public int getHeight()
返回框的当前高度。这是上次为其分配的高度。

返回：
框的当前高度

layoutMajorAxis

protected void layoutMajorAxis(int targetSpan,
                               int axis,
                               int[] offsets,
                               int[] spans)
执行对框的主轴的布局（即它所代表的轴）。布局的结果（每个子级的偏移量和区域）存储在给定的数组中，它表示沿主轴对子级的分配。

参数：
targetSpan - 分配给视图的总区域，将用于布置子级
axis - 要布置的轴
offsets - 每个子视图相对于视图原点的偏移量；这是一个返回值，由此方法的实现填充
spans - 每个子视图的区域；这是一个返回值，由此方法的实现填充

layoutMinorAxis

protected void layoutMinorAxis(int targetSpan,
                               int axis,
                               int[] offsets,
                               int[] spans)
执行对框的辅轴的布局（即与它所代表的轴垂直的轴）。布局的结果（每个子级的偏移量和区域）存储在给定的数组中，它表示沿辅轴对子级的分配。

参数：
targetSpan - 分配给视图的总区域，将用于布置子级
axis - 要布置的轴
offsets - 每个子视图相对于视图原点的偏移量；这是一个返回值，由此方法的实现填充
spans - 每个子视图的区域；这是一个返回值，由此方法的实现填充

calculateMajorAxisRequirements

protected SizeRequirements calculateMajorAxisRequirements(int axis,
                                                          SizeRequirements r)
计算主轴 axis 的大小要求。

参数：
axis - 所考察的轴
r - SizeRequirements 对象；如果为 null，将创建一个对象
返回：
新初始化的 SizeRequirements 对象
另请参见：
SizeRequirements

calculateMinorAxisRequirements

protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                                          SizeRequirements r)
计算辅轴 axis 的大小要求。

参数：
axis - 所考察的轴
r - SizeRequirements 对象；如果为 null，将创建一个对象
返回：
新初始化的 SizeRequirements 对象
另请参见：
SizeRequirements

baselineLayout

protected void baselineLayout(int targetSpan,
                              int axis,
                              int[] offsets,
                              int[] spans)
在给定的 targetSpan 区域，即我们将使用的区域的宽度（或高度），计算每个子视图在此 BoxView 中的位置和扩展。

参数：
targetSpan - 分配给视图的总区域，将用于布置子级
axis - 所考察的轴，可以是 View.X_AXIS 或 View.Y_AXIS
offsets - 一个空数组，由此方法用指定每个子视图位置的值填充
spans - 一个空数组，由此方法用指定每个子视图扩展的值填充

baselineRequirements

protected SizeRequirements baselineRequirements(int axis,
                                                SizeRequirements r)
通过检查每个子视图的大小计算此 BoxView 的大小要求。

参数：
axis - 所考察的轴
r - SizeRequirements 对象；如果为 null，将创建一个对象
返回：
新初始化的 SizeRequirements 对象

getOffset

protected int getOffset(int axis,
                        int childIndex)
获取特定子级当前布局的偏移量。

参数：
axis - 所考察的轴
childIndex - 所请求子级的索引
返回：
指定子级的偏移量（位置）

getSpan

protected int getSpan(int axis,
                      int childIndex)
获取特定子级的当前布局的区域。

参数：
axis - 所考察的轴
childIndex - 所请求子级的索引
返回：
指定子级的区域（宽度或高度）

flipEastAndWestAtEnds

protected boolean flipEastAndWestAtEnds(int position,
                                        Position.Bias bias)
确定下一个视图的放置方向。假定 View 的索引为 n。通常情况下，这些 View 从按左到右布置，这样位于它东面的 View 的索引为 n + 1，位于它西面的 View 的索引为 n - 1。在某些情况下（例如双向文本中）有可能位于它东面的 View 索引不是 n + 1，而是 n - 1，位于它西面的 View 索引不是 n - 1，而是 n + 1。在这种情况下，此方法返回 true，表明这些 View 按降序布置。否则该方法返回 false，表明这些视图 View 按升序布置。

如果接收者沿 Y_AXIS 布置它的 View，这将返回在负责呈现 position 和 bias 的 View 上调用相同的方法所返回的值。否则将返回 false。

覆盖：
类 CompositeView 中的 flipEastAndWestAtEnds
参数：
position - 模型中的位置
bias - 可以是 Position.Bias.Forward 或 Position.Bias.Backward
返回：
如果围绕 View 的负责呈现 position 和 bias 的 View 按降序布置则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Caret (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Caret

所有已知实现类：
BasicTextUI.BasicCaret, DefaultCaret
public interface Caret

文档视图中的一个位置，它表示文档模型中能插入其他内容的位置。插入符在文档中有一个称作点的位置。点就是插入符当前在模型中的位置。插入符还保留一个位置，它表示选定项的另一端，称为标记。如果没有选定项，点和标记将相等。如果存在选定项，这两个值将不相同。

通过调用 setDot 或 moveDot 可以放置点。设置点能够移除任何以前存在的选定项。点和标记将相等。移动点将能够创建选定项，而标记将保留在它以前所在的任何位置。

方法摘要
void | addChangeListener(ChangeListener l) 添加作为跟踪任何插入符位置更改的侦听器。
void | deinstall(JTextComponent c) 在将 UI 从 JTextComponent 的接口中移除时调用。
int | getBlinkRate() 获取插入符的闪烁率。
int | getDot() 获取插入符的当前位置。
Point | getMagicCaretPosition() 获取当前插入符可见位置。
int | getMark() 获取标记的当前位置。
void | install(JTextComponent c) 在将 UI 安装到 JTextComponent 的接口中时调用。
boolean | isSelectionVisible() 确定选定项当前是否可见。
boolean | isVisible() 确定插入符当前是否可见。
void | moveDot(int dot) 将插入符位置（点）移动到其他某个位置，放在标记后面。
void | paint(Graphics g) 呈现插入符。
void | removeChangeListener(ChangeListener l) 移除跟踪插入符位置更改的侦听器。
void | setBlinkRate(int rate) 设置插入符的闪烁率。
void | setDot(int dot) 将插入符位置设置为其他某个位置。
void | setMagicCaretPosition(Point p) 设置当前插入符的可视位置。
void | setSelectionVisible(boolean v) 设置选定项的可见性
void | setVisible(boolean v) 设置插入符的可见性。

方法详细信息

install

void install(JTextComponent c)
在将 UI 安装到 JTextComponent 的接口中时调用。使用它可以获得对正由此接口的实现导航的模型的访问。

参数：
c - JTextComponent

deinstall

void deinstall(JTextComponent c)
在将 UI 从 JTextComponent 的接口中移除时调用。这可用于取消对任何所关联侦听器的注册。

参数：
c - JTextComponent

paint

void paint(Graphics g)
呈现插入符。UI 类调用此方法。

参数：
g - 图形上下文

addChangeListener

void addChangeListener(ChangeListener l)
添加作为跟踪任何插入符位置更改的侦听器。

参数：
l - 更改侦听器

removeChangeListener

void removeChangeListener(ChangeListener l)
移除跟踪插入符位置更改的侦听器。

参数：
l - 更改侦听器

isVisible

boolean isVisible()
确定插入符当前是否可见。

返回：
如果插入符可见，则返回 true；否则返回 false

setVisible

void setVisible(boolean v)
设置插入符的可见性。

参数：
v - 如果插入符应该显示，则返回 true；如果插入符应该隐藏，则返回 false

isSelectionVisible

boolean isSelectionVisible()
确定选定项当前是否可见。

返回：
如果插入符可见，则返回 true；否则返回 false

setSelectionVisible

void setSelectionVisible(boolean v)
设置选定项的可见性

参数：
v - 如果插入符应该显示，则返回 true；如果插入符应该隐藏，则返回 false

setMagicCaretPosition

void setMagicCaretPosition(Point p)
设置当前插入符的可视位置。这可供在具有不规则结束位置的行间（例如，插入符出现上下移动）移动时使用。如果文本按从左到右或从右到左流入，x 坐标将指示垂直移动所需要的导航位置。如果文本按从上到下或从下到上流入，y 坐标将指示水平移动所需要的导航位置。

参数：
p - 用于所保存位置的 Point。它可以为 null，表示无可见位置。

getMagicCaretPosition

Point getMagicCaretPosition()
获取当前插入符可见位置。

返回：
可见位置。
另请参见：
setMagicCaretPosition(java.awt.Point)

setBlinkRate

void setBlinkRate(int rate)
设置插入符的闪烁率。它确定了插入符是否闪烁以及闪烁的速度，通常作为增强插入符的吸引力的一种手段使用。

参数：
rate - 延迟的毫秒数，该值 >= 0。如果该值为零，则插入符不闪烁。

getBlinkRate

int getBlinkRate()
获取插入符的闪烁率。它确定了插入符是否闪烁以及闪烁的速度，通常作为增强插入符的吸引力的一种手段使用。

返回：
延迟的毫秒数，该值 >= 0。 如果该值为零，则插入符不闪烁。

getDot

int getDot()
获取插入符的当前位置。

返回：
位置，其值 >= 0

getMark

int getMark()
获取标记的当前位置。如果有一个选定项，则标记将与点不同。

返回：
位置，其值 >= 0

setDot

void setDot(int dot)
将插入符位置设置为其他某个位置。这使得标记变得与点相同，从而有效地将选定项范围设置为零。

如果参数为负或超出文档的长度，则分别将插入符置于开始位置或结束位置。

参数：
dot - 插入符将设置的新位置

moveDot

void moveDot(int dot)
将插入符位置（点）移动到其他某个位置，放在标记后面。这对进行选择很有用。

参数：
dot - 插入符将移动的新位置，其值 >= 0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChangedCharSetException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 ChangedCharSetException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.swing.text.ChangedCharSetException
所有已实现的接口：
Serializable
public class ChangedCharSetException
extends IOException

顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

构造方法摘要
ChangedCharSetException(String charSetSpec, boolean charSetKey)
方法摘要
String | getCharSetSpec()
boolean | keyEqualsCharSet()
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ChangedCharSetException

public ChangedCharSetException(String charSetSpec,
                               boolean charSetKey)
方法详细信息

getCharSetSpec

public String getCharSetSpec()

keyEqualsCharSet

public boolean keyEqualsCharSet()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 ComponentView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.ComponentView
所有已实现的接口：
SwingConstants
直接已知子类：
FormView, ObjectView
public class ComponentView
extends View

实现视图接口的组件装饰器。整个元素用于代表该组件。它充当了只供显示的 View 实现和交互式轻量级组件之间的网关（即允许组件嵌入 View 层次结构中）。

组件根据 Component.getAlignmentY 返回的值相对于文本基线放置。对于 Swing 组件，使用 JComponent.setAlignmentY 方法可以很便捷地设置此值。例如，值设置为 0.75 将使组件的 75％ 位于基线的上面，25％ 位于基线的下面。

通过确保在事件线程中完成对所有的组件访问，实现此类可完成在多线程情况下（例如，来自模型更改的同步通知）进行正常工作所需的工作。

所使用的组件由 createComponent 方法的返回值确定。此方法的默认实现为将存储的组件作为元素的一个属性返回（通过调用 StyleConstants.getComponent）。此行为有一个限制，组件不能由多于一个文本组件（即可共享的模型）使用。通过实现 createComponent 从而实际上基于属性中包含的某种规范创建一个组件，子类可消除此约束。html 包中的 ObjectView 类为 ComponentView 实现的一个示例，它支持一个共享模型的多组件视图。

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
ComponentView(Element elem)
创建新的 ComponentView 对象。
方法摘要
protected Component | createComponent() 创建与此视图关联的组件。
float | getAlignment(int axis) 确定此视图沿某轴所需的对齐方式。
Component | getComponent() 获取与此视图关联的组件。
float | getMaximumSpan(int axis) 确定此视图沿某轴的最大区域。
float | getMinimumSpan(int axis) 确定此视图沿某轴的最小区域。
float | getPreferredSpan(int axis) 确定此视图沿某轴的首选区域。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供模型坐标空间到视图坐标空间的映射。
void | paint(Graphics g, Shape a) 真正的绘制行为自然来源于组件与其父容器（容纳此视图的同一容器）之间的关联。
void | setParent(View p) 为子视图设置父级。
int | viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setSize, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComponentView

public ComponentView(Element elem)
创建新的 ComponentView 对象。

参数：
elem - 要装饰的元素
方法详细信息

createComponent

protected Component createComponent()
创建与此视图关联的组件。当确定需要一个新组件时将调用此方法。在调用 setParent 的过程中，或者在收到属性已更改的通知时，都有可能调用上面的方法。

getComponent

public final Component getComponent()
获取与此视图关联的组件。

paint

public void paint(Graphics g,
                  Shape a)
真正的绘制行为自然来源于组件与其父容器（容纳此视图的同一容器）之间的关联。实现它不进行任何操作。

指定者：
类 View 中的 paint
参数：
g - 图形上下文
a - 形状
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某轴的首选区域。实现它可返回由 Component.getPreferredSize 返回的沿所需轴的值。

指定者：
类 View 中的 getPreferredSpan
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，该区域 >= 0。通常会告知该视图要在返回的区域中呈现，但不能保证一定如此。父级可选择重新调整视图大小或拆分视图。
抛出：
IllegalArgumentException - 如果轴无效
另请参见：
View.getPreferredSpan(int)

getMinimumSpan

public float getMinimumSpan(int axis)
确定此视图沿某轴的最小区域。实现它可返回由 Component.getMinimumSize 返回的沿所需轴的值。

覆盖：
类 View 中的 getMinimumSpan
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，该区域 >= 0。通常会告知该视图在返回的区域中呈现，但不能保证一定如此。父级可选择重新调整视图大小或拆分视图。
抛出：
IllegalArgumentException - 如果轴无效
另请参见：
View.getPreferredSpan(int)

getMaximumSpan

public float getMaximumSpan(int axis)
确定此视图沿某轴的最大区域。实现它可返回由 Component.getMaximumSize 返回的沿所需轴的值。

覆盖：
类 View 中的 getMaximumSpan
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，该区域 >= 0。通常会告知该视图在返回的区域中呈现，但不能保证一定如此。父级可选择重新调整视图大小或拆分视图。
抛出：
IllegalArgumentException - 如果轴无效
另请参见：
View.getPreferredSpan(int)

getAlignment

public float getAlignment(int axis)
确定此视图沿某轴所需的对齐方式。实现它来为嵌入组件提供对齐方式。

覆盖：
类 View 中的 getAlignment
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
需要的对齐方式。这应该是介于 0.0 和 1.0 之间的一个值，0 指示在起始位置对齐，1.0 指示在离开起始位置的整个跨距处对齐。为 0.5 表示在视图的中心对齐。

setParent

public void setParent(View p)
为子视图设置父级。父级在子级上调用此方法以告知子级谁为其父，同时为类似宿主 Container 的组件提供视图访问。如果父视图参数为非空且尚未创建组件，将执行超类行为，然后调用 createComponent。嵌入组件的父被设置为由 getContainer 返回的值。如果父视图参数为 null，此视图将被清空，这样组件将从其父中移除。

更改组件所在的层次结构将会触动组件锁，这是 View 层次结构的一个不安全之处。因此，如果在事件线程中，则会立即执行此功能；如果是从另一个线程（来自异步更新的更改通知）调用，则此功能将在事件队列排队。

覆盖：
类 View 中的 setParent
参数：
p - 父级

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供模型坐标空间到视图坐标空间的映射。

指定者：
类 View 中的 modelToView
参数：
pos - 要转换的位置，该值 >= 0
a - 分配的要在其中呈现的区域
b - 当位置是两个视图的边界时，该参数是离由偏移量表示的前一个字符或者下一个字符的偏差；b 将是这些值之一：
  • Position.Bias.Forward
  • Position.Bias.Backward
返回：
返回给定位置的边界框
抛出：
BadLocationException - 如果给定位置在所关联的文档中不是一个有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public int viewToModel(float x,
                       float y,
                       Shape a,
                       Position.Bias[] bias)
提供从视图坐标空间到模型逻辑坐标空间的映射。

指定者：
类 View 中的 viewToModel
参数：
x - X 坐标，该值 >= 0
y - Y 坐标，该值 >= 0
a - 分配的要在其中呈现的区域
返回：
模型中最能代表视图中给定点的位置
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompositeView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 CompositeView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
所有已实现的接口：
SwingConstants
直接已知子类：
BoxView
public abstract class CompositeView
extends View

CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。（注意，CompositeView 主要管理相对较少的子视图。）CompositeView 主要充当 View 实现的起点，例如 BoxView，它将包含子 View。要管理子 View 集的子类应使用 replace(int, int, javax.swing.text.View[]) 方法。由于 View 在 DocumentListener 通知过程中调用 replace，所以通常不需要直接调用 replace。

虽然 CompositeView 不会对其子 View 施加布局策略，但它允许插入将包含的子 View。插入内容可通过 setInsets(short, short, short, short) 或 setParagraphInsets(javax.swing.text.AttributeSet) 进行设置。

除了 View 的抽象方法之外，CompositeView 的子类还需要重写：

  • isBefore(int, int, java.awt.Rectangle) - 用于测试给定的 View 位置是否位于 CompositeView 的可视空间之前。
  • isAfter(int, int, java.awt.Rectangle) - 用于测试给定的 View 位置是否位于 CompositeView 的可视空间之后。
  • getViewAtPoint(int, int, java.awt.Rectangle) - 返回位于给定可视位置的视图。
  • childAllocation(int, java.awt.Rectangle) - 返回特定子 View 的边界。getChildAllocation 在其边界减去 CompositeView 的 Inset 之后，将调用 childAllocation。

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
CompositeView(Element elem)
为给定元素构造一个 CompositeView。
方法摘要
protected abstract void | childAllocation(int index, Rectangle a) 返回给定子级的分配区域。
protected boolean | flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图放置的朝向。
protected short | getBottomInset() 获取底部 inset。
Shape | getChildAllocation(int index, Shape a) 获取要在其中呈现的给定子视图的分配区域。
protected Rectangle | getInsideAllocation(Shape a) 将分配给视图的不可变分配区域转换为表示内部分配区域的可变分配区域（即给定分配区域的边界，其顶部、左部、底部和右部的 insets 已移除）。
protected short | getLeftInset() 获取左部 inset。
protected int | getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在东或在西。
protected int | getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在北也可以在南。
int | getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
protected short | getRightInset() 获取右部 inset。
protected short | getTopInset() 获取顶部 inset。
View | getView(int n) 返回该容器中的第 n 个视图。
protected abstract View | getViewAtPoint(int x, int y, Rectangle alloc) 获取位于给定坐标的子视图。
protected View | getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
int | getViewCount() 返回此视图的子视图数。
int | getViewIndex(int pos, Position.Bias b) 返回表示模型中给定位置的子视图索引。
protected int | getViewIndexAtPosition(int pos) 获取表示模型中给定位置的子视图索引。
protected abstract boolean | isAfter(int x, int y, Rectangle alloc) 测试一个点是否位于矩形范围之后。
protected abstract boolean | isBefore(int x, int y, Rectangle alloc) 测试一个点是否位于矩形范围之前。
protected void | loadChildren(ViewFactory f) 加载所有的子级以初始化该视图。
Shape | modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | replace(int offset, int length, View[] views) 替换子视图。
protected void | setInsets(short top, short left, short bottom, short right) 设置视图的 insets。
protected void | setParagraphInsets(AttributeSet attr) 按照给定属性中指定的段落属性设置 insets。
void | setParent(View parent) 设置此视图的父级。
int | viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getParent, getPreferredSpan, getResizeWeight, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, paint, preferenceChanged, remove, removeAll, removeUpdate, setSize, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CompositeView

public CompositeView(Element elem)
为给定元素构造一个 CompositeView。

参数：
elem - 此视图负责的元素
方法详细信息

loadChildren

protected void loadChildren(ViewFactory f)
加载所有的子级以初始化该视图。它由 setParent(javax.swing.text.View) 方法调用。子类可重新实现它以便按不同的方式初始化其子视图。默认实现为每个子元素创建一个子视图。

参数：
f - 视图工厂
另请参见：
setParent(javax.swing.text.View)

setParent

public void setParent(View parent)
设置此视图的父级。重新实现此方法可提供超类行为，并可在此视图无子级的情况下调用 loadChildren 方法。不应在构造方法中加载子级，因为设置父级的动作可能引起它们试图沿层次结构向上搜索，例如，要获得承载 Container。如果此视图有子级（视图从视图层次结构中的一个位置移动到另一个位置），则不调用 loadChildren 方法。

覆盖：
类 View 中的 setParent
参数：
parent - 视图的父级，如果没有则为 null

getViewCount

public int getViewCount()
返回此视图的子视图数。

覆盖：
类 View 中的 getViewCount
返回：
视图数，该数量 >= 0
另请参见：
getView(int)

getView

public View getView(int n)
返回该容器中的第 n 个视图。

覆盖：
类 View 中的 getView
参数：
n - 需要的视图数量，该数量 >= 0 且 < getViewCount()
返回：
索引为 n 的视图

replace

public void replace(int offset,
                    int length,
                    View[] views)
替换子视图。如果没有要移除的视图，此方法视为插入操作。如果没有要添加的视图，此方法视为移除操作。被移除的视图的父级将被设置为 null，并且移除了对它们的内部引用，所以它们有可能被作为垃圾回收。

覆盖：
类 View 中的 replace
参数：
offset - 要插入新视图的子视图的起始索引；该索引 >= 0 且 <= getViewCount
length - 要移除的现有子视图数；此值应 >= 0 且 <= (getViewCount() - offset)
views - 要添加的子视图；此值可以为 null，表示不添加任何子级（对移除有用）

getChildAllocation

public Shape getChildAllocation(int index,
                                Shape a)
获取要在其中呈现的给定子视图的分配区域。这有助于获得各个视图所处的位置。

覆盖：
类 View 中的 getChildAllocation
参数：
index - 子级的索引，该索引 >= 0 且 < getViewCount()
a - 对此视图的分配区域
返回：
子级的分配区域

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

指定者：
类 View 中的 modelToView
参数：
pos - 要转换的位置，该位置 >= 0
a - 要在其中呈现的已分配区域
b - 一个偏移值，可以是 Position.Bias.Forward 或 Position.Bias.Backward
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置不是相关文档中的有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

modelToView

public Shape modelToView(int p0,
                         Position.Bias b0,
                         int p1,
                         Position.Bias b1,
                         Shape a)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

覆盖：
类 View 中的 modelToView
参数：
p0 - 要转换的位置，该位置 >= 0
b0 - 由 p0 表示的上一字符或下一个字符的偏移量，在这种情况下，该位置是两个视图的边界；既可以是 Position.Bias.Forward，也可以是 Position.Bias.Backward
p1 - 要转换的位置，该位置 >= 0
b1 - 由 p1 表示的上一字符或下一个字符的偏移量，在这种情况下，该位置是两个视图的边界；
a - 要呈现的已分配区域
返回：
返回给定位置的边界框
抛出：
BadLocationException - 如果给定位置不是相关文档中的有效位置
IllegalArgumentException - 如果为无效的偏移量参数
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

viewToModel

public int viewToModel(float x,
                       float y,
                       Shape a,
                       Position.Bias[] bias)
提供从视图坐标空间到模型的逻辑坐标空间的映射。

指定者：
类 View 中的 viewToModel
参数：
x - 要转换的视图位置的 x 坐标，该坐标 >= 0
y - 要转换的视图位置的 y 坐标，该坐标 >= 0
a - 要呈现的已分配区域
bias - 可以是 Position.Bias.Forward 或 Position.Bias.Backward
返回：
模型中最能代表视图中给定点的位置，该位置 >= 0
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

getNextVisualPositionFrom

public int getNextVisualPositionFrom(int pos,
                                     Position.Bias b,
                                     Shape a,
                                     int direction,
                                     Position.Bias[] biasRet)
                              throws BadLocationException
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。有些视图可能不可见，它们可能与该模型中发现的顺序不同，或它们可能只是不允许访问该模型中的某些位置。这是一个适用于 getNextNorthSouthVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[]) 和 getNextEastWestVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[]) 的便捷方法。

覆盖：
类 View 中的 getNextVisualPositionFrom
参数：
pos - 要转换的位置，该位置 >= 0
b - 偏移量值，可以是 Position.Bias.Forward 或 Position.Bias.Backward
a - 要呈现的已分配区域
direction - 相对当前位置的方向，通常可视为键盘上看到的方向键；它可能为下列值之一：
  • SwingConstants.WEST
  • SwingConstants.EAST
  • SwingConstants.NORTH
  • SwingConstants.SOUTH
biasRet - 一个包含已检查偏移量的数组
返回：
模型中最能代表下一个可视位置的位置
抛出：
BadLocationException
IllegalArgumentException - 如果 direction 无效

getViewIndex

public int getViewIndex(int pos,
                        Position.Bias b)
返回表示模型中给定位置的子视图索引。实现此方法可调用 getViewIndexByPosition 方法以便向后兼容。

覆盖：
类 View 中的 getViewIndex
参数：
pos - 位置，该位置 >= 0
返回：
表示给定位置的视图的索引，如果没有视图表示该位置，则返回 -1
从以下版本开始：
1.3

isBefore

protected abstract boolean isBefore(int x,
                                    int y,
                                    Rectangle alloc)
测试一个点是否位于矩形范围之前。

参数：
x - X 坐标，该坐标 >= 0
y - Y 坐标，该坐标 >= 0
alloc - 矩形
返回：
如果该点位于指定范围之前，则返回 true

isAfter

protected abstract boolean isAfter(int x,
                                   int y,
                                   Rectangle alloc)
测试一个点是否位于矩形范围之后。

参数：
x - X 坐标，该坐标 >= 0
y - Y 坐标，该坐标 >= 0
alloc - 矩形
返回：
如果该点位于指定范围之后，则返回 true

getViewAtPoint

protected abstract View getViewAtPoint(int x,
                                       int y,
                                       Rectangle alloc)
获取位于给定坐标的子视图。

参数：
x - X 坐标，该坐标 >= 0
y - Y 坐标，该坐标 >= 0
alloc - 入口处父级的分配区域，出口处应改为子级的分配区域
返回：
子视图

childAllocation

protected abstract void childAllocation(int index,
                                        Rectangle a)
返回给定子级的分配区域。

参数：
index - 子级的索引，该索引 >= 0 且 < getViewCount()
a - 入口处框内部的分配区域，和出口索引处的子视图分配区域。

getViewAtPosition

protected View getViewAtPosition(int pos,
                                 Rectangle a)
获取表示模型中给定位置的子视图。实现此方法，以便在每个子元素都有一个子视图的情况下获取视图。

参数：
pos - 位置，该位置 >= 0
a - 入口处框内部的分配区域，出口处包含此位置的视图分配区域
返回：
表示给定位置的视图，如果没有视图，则为 null

getViewIndexAtPosition

protected int getViewIndexAtPosition(int pos)
获取表示模型中给定位置的子视图索引。实现此方法，以便在每个子元素都有一个子视图的情况下获取视图。

参数：
pos - 位置，该位置 >= 0
返回：
表示给定位置的视图的索引，如果没有视图表示该位置，则返回 -1

getInsideAllocation

protected Rectangle getInsideAllocation(Shape a)
将分配给视图的不可变分配区域转换为表示内部分配区域的可变分配区域（即给定分配区域的边界，其顶部、左部、底部和右部的 insets 已移除）。返回值需要进一步改变以表示子视图的分配区域。实现此方法可重用一个实例变量，这样可避免创建太多的矩形。通常调用此方法的结果将传给 childAllocation 方法。

参数：
a - 分配给视图的分配区域
返回：
表示视图边界空白全部移除后的内部分配区域；如果给定分配区域为 null，则返回值为 null

setParagraphInsets

protected void setParagraphInsets(AttributeSet attr)
按照给定属性中指定的段落属性设置 insets。

参数：
attr - 属性

setInsets

protected void setInsets(short top,
                         short left,
                         short bottom,
                         short right)
设置视图的 insets。

参数：
top - 顶部 inset，该值 >= 0
left - 左部 inset，该值 >= 0
bottom - 底部 inset，该值 >= 0
right - 右部 inset，该值 >= 0

getLeftInset

protected short getLeftInset()
获取左部 inset。

返回：
inset，该值 >= 0

getRightInset

protected short getRightInset()
获取右部 inset。

返回：
inset，该值 >= 0

getTopInset

protected short getTopInset()
获取顶部 inset。

返回：
inset，该值 >= 0

getBottomInset

protected short getBottomInset()
获取底部 inset。

返回：
inset，该值 >= 0

getNextNorthSouthVisualPositionFrom

protected int getNextNorthSouthVisualPositionFrom(int pos,
                                                  Position.Bias b,
                                                  Shape a,
                                                  int direction,
                                                  Position.Bias[] biasRet)
                                           throws BadLocationException
返回光标的下一个可视位置，可以在北也可以在南。

参数：
pos - 要转换的位置，该位置 >= 0
b - 偏移量值，可以是 Position.Bias.Forward 或 Position.Bias.Backward
a - 要呈现的已分配区域
direction - 相对当前位置的方向，通常可视为键盘上看到的方向键；它可能为下列值之一：
  • SwingConstants.NORTH
  • SwingConstants.SOUTH
biasRet - 一个包含已检查偏移量的数组
返回：
模型中最能代表下一个向北或向南的位置
抛出：
BadLocationException
IllegalArgumentException - 如果 direction 无效
另请参见：
getNextVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[])

getNextEastWestVisualPositionFrom

protected int getNextEastWestVisualPositionFrom(int pos,
                                                Position.Bias b,
                                                Shape a,
                                                int direction,
                                                Position.Bias[] biasRet)
                                         throws BadLocationException
返回光标的下一个可视位置，可以在东或在西。

参数：
pos - 要转换的位置，该位置 >= 0
b - 偏移量值，可以是 Position.Bias.Forward 或 Position.Bias.Backward
a - 要呈现的已分配区域
direction - 相对当前位置的方向，通常可视为键盘上看到的方向键；它可能为下列值之一：
  • SwingConstants.WEST
  • SwingConstants.EAST
biasRet - 一个包含已检查偏移量的数组
返回：
模型中最能代表下一个向西或向东的位置
抛出：
BadLocationException
IllegalArgumentException - 如果 direction 无效
另请参见：
getNextVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[])

flipEastAndWestAtEnds

protected boolean flipEastAndWestAtEnds(int position,
                                        Position.Bias bias)
确定下一个视图放置的朝向。假定 View 位于索引 n 处，通常 View 是从左向右放置的，所以在东面的 View 将位于索引 n + 1 处，在西面的 View 将位于索引 n - 1 处。在某些情况下（例如双向文本中）有可能东面的 View 不是位于 n + 1 处，而是位于 n - 1 处，或者西面的 View 不是位于 n - 1 处，而是位于索引 n + 1 处。这种情况下，该方法将返回 true，指示 View 按降序放置。

它无条件返回 false，如果有可能需要按降序放置 View，则子类应重写此方法。

参数：
position - 模型中的位置
bias - 可以是 Position.Bias.Forward 或 Position.Bias.Backward
返回：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateFormatter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DateFormatter

java.lang.Object
    继承者  javax.swing.JFormattedTextField.AbstractFormatter
        继承者  javax.swing.text.DefaultFormatter
            继承者  javax.swing.text.InternationalFormatter
                继承者  javax.swing.text.DateFormatter
所有已实现的接口：
Serializable, Cloneable
public class DateFormatter
extends InternationalFormatter

DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4
另请参见：
DateFormat

构造方法摘要
DateFormatter()
这是 new DateFormatter(DateFormat.getDateInstance()) 的简写。
DateFormatter(DateFormat format)
返回用指定的 Format 实例配置的 DateFormatter。
方法摘要
 void setFormat(DateFormat format)
设置用于指示可编辑和显示的合法值的格式。
从类 javax.swing.text.InternationalFormatter 继承的方法
clone, getActions, getFields, getFormat, getMaximum, getMinimum, install, setFormat, setMaximum, setMinimum, stringToValue, valueToString
从类 javax.swing.text.DefaultFormatter 继承的方法
getAllowsInvalid, getCommitsOnValidEdit, getDocumentFilter, getNavigationFilter, getOverwriteMode, getValueClass, setAllowsInvalid, setCommitsOnValidEdit, setOverwriteMode, setValueClass
从类 javax.swing.JFormattedTextField.AbstractFormatter 继承的方法
getFormattedTextField, invalidEdit, setEditValid, uninstall
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DateFormatter

public DateFormatter()
这是 new DateFormatter(DateFormat.getDateInstance()) 的简写。

DateFormatter

public DateFormatter(DateFormat format)
返回用指定的 Format 实例配置的 DateFormatter。

参数：
format - 用于指示合法值的 Format
方法详细信息

setFormat

public void setFormat(DateFormat format)
设置用于指示可编辑和显示的合法值的格式。

如果已经使用了 nullary 构造方法，当前语言环境中此属性的值将通过 Dateformat.getDateInstance() 方法确定。

参数：
format - 用于字符串来回转换的 DateFormat 实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultCaret (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultCaret

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Rectangle2D
            继承者  java.awt.Rectangle
                继承者  javax.swing.text.DefaultCaret
所有已实现的接口：
FocusListener, MouseListener, MouseMotionListener, Shape, Serializable, Cloneable, EventListener, Caret
直接已知子类：
BasicTextUI.BasicCaret
public class DefaultCaret
extends Rectangle
implements Caret, FocusListener, MouseListener, MouseMotionListener

插入符的默认实现。插入符以垂直线形式呈现，颜色由相关的 JTextComponent 的 CaretColor 属性指定。它可以按 BlinkRate 属性中指定的速率闪烁。

此实现需要两个异步通知源。计时器线程为异步触发，这使得插入符只需重绘最新的边界框。当修改文档时，插入符还跟踪更改。通常这发生在某些鼠标或键盘事件引起的事件调度线程中。同步和异步文档更新中的插入符的行为是由 UpdatePolicy 属性控制的。重绘新插入符位置在任何情况下都发生在事件线程上，因为只有在事件线程上对 modelToView 的调用才是安全的。

插入符充当它所安装到的文本组件上的鼠标和焦点侦听器，并根据这些事件定义插入符的语义。侦听器方法可重新实现以更改其语义。默认情况下，第一个鼠标按钮将用于设置焦点和插入符位置。用第一个鼠标按钮拖动鼠标指针将在模型中划出一个连续选定。如果关联的文本组件为可编辑的，此插入符在获得焦点时将为可见，在失去焦点时为不可见。

关联的文本组件的 Highlighter 边界默认用于呈现选定。通过提供高亮显示所用的 painter，可定制选定的外观。默认情况下，painter 用于需要用关联文本组件的 SelectionColor 属性中指定的纯色呈现的情况。通过重新实现 getSelectionHighlighter 方法，可以很容易地更改此方法。

通过重新实现该 paint 方法，可获得定制的插入符外观。如果 paint 方法已更改，damage 方法也应重新实现，这样可重新绘制需要的区域以便呈现插入符。插入符扩展了 Rectangle 类，它用于保持记录上次呈现插入符的位置的边界框。这有助于插入符以线程安全的方式重绘，因为在模型更新和视图修复期间移动插入符而不调用 modelToView 是不稳定的（即无法保证传递到 DocumentListeners 的顺序）。

当插入符位置改变时，此变幻的插入符位置将设置为 null。使用计时器确定新的位置（在插入符改变后）。计时器触发后，如果变幻的插入符位置仍为 null，它将重置为当前的插入符位置。任何更改插入符位置和希望变幻的插入符位置保持不变的操作都必须记住变幻的插入符位置和更改光标，然后将变幻的插入符位置设置为原始值。这样做的好处是，只有希望变幻的插入符位置保持不变的操作（例如打开/向下）需要知道它的值。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Caret

嵌套类摘要
从类 java.awt.geom.Rectangle2D 继承的嵌套类/接口
Rectangle2D.Double, Rectangle2D.Float
字段摘要
static int | ALWAYS_UPDATE 指示无论文档更新是否是在事件调度线程中执行，始终根据文档更改更新插入符位置。
protected ChangeEvent | changeEvent 此模型的更改事件。
protected EventListenerList | listenerList 事件侦听器列表。
static int | NEVER_UPDATE 指示无论文档有任何更新，插入符都应在文档中保持同一绝对位置，由于删除使文档长度小于当前插入符位置除外。
static int | UPDATE_WHEN_ON_EDT 指示只有在事件调度线程中执行文档更改时，才更新插入符位置。
从类 java.awt.Rectangle 继承的字段
height, width, x, y
从类 java.awt.geom.Rectangle2D 继承的字段
OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP
构造方法摘要
DefaultCaret()
构造默认的插入符。
方法摘要
 void addChangeListener(ChangeListener l)
添加一个侦听器，以便对插入符位置改变进行跟踪。
protected  void adjustVisibility(Rectangle nloc)
滚动关联的视图（如果有）以使插入符可见。
protected  void damage(Rectangle r)
毁坏围绕插入符的区域以使该区域在新的位置重绘。
 void deinstall(JTextComponent c)
当 UI 从一个 JTextComponent 的接口移除时调用。
 boolean equals(Object obj)
将此对象与指定的对象进行比较。
protected  void fireStateChanged()
通知所有需要此事件类型的通知的已注册侦听器。
 void focusGained(FocusEvent e)
在包含插入符的组件获得焦点时调用。
 void focusLost(FocusEvent e)
在包含插入符的组件失去焦点时调用。
 int getBlinkRate()
获取插入符闪烁率。
 ChangeListener[] getChangeListeners()
返回此插入符上所有已注册的更改侦听器组成的数组。
protected  JTextComponent getComponent()
获取此插入符所绑定的文本编辑器组件。
 int getDot()
获取插入符的当前位置。
 Position.Bias getDotBias()
返回插入符位置的偏差。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
 Point getMagicCaretPosition()
获取保存的插入符位置。
 int getMark()
获取标记的当前位置。
 Position.Bias getMarkBias()
返回标记的偏差。
protected  Highlighter.HighlightPainter getSelectionPainter()
获取此 Highlighter 的 painter。
 int getUpdatePolicy()
获取文档更新时的插入符移动策略。
 void install(JTextComponent c)
当 UI 装入一个 JTextComponent 的接口时调用。
 boolean isActive()
确定插入符当前是否处于激活状态。
 boolean isSelectionVisible()
检查当前选定是否可见。
 boolean isVisible()
指示插入符当前是否可见。
 void mouseClicked(MouseEvent e)
单击鼠标时调用。
 void mouseDragged(MouseEvent e)
根据鼠标指针当前位置移动插入符位置。
 void mouseEntered(MouseEvent e)
鼠标进入某个区域时调用。
 void mouseExited(MouseEvent e)
鼠标退出某个区域时调用。
 void mouseMoved(MouseEvent e)
移动鼠标时调用。
 void mousePressed(MouseEvent e)
如果按下 button 1，实现它可请求将焦点置于关联的文本组件上，并设置插入符位置。
 void mouseReleased(MouseEvent e)
释放鼠标时调用。
protected  void moveCaret(MouseEvent e)
试图使用 viewToModel() 从鼠标事件的坐标移动插入符的位置。
 void moveDot(int dot)
将插入符位置移动到指定位置，存在向前偏差。
 void moveDot(int dot, Position.Bias dotBias)
将插入符位置移动到指定位置，存在指定偏差。
 void paint(Graphics g)
将插入符作为垂直线呈现。
protected  void positionCaret(MouseEvent e)
试图使用 viewToModel() 从鼠标事件的坐标设置插入符的位置。
 void removeChangeListener(ChangeListener l)
移除跟踪位置更改的侦听器。
protected  void repaint()
使得重绘插入符。
 void setBlinkRate(int rate)
设置插入符闪烁率。
 void setDot(int dot)
将插入符位置和标记设置为指定位置，存在向前偏差。
 void setDot(int dot, Position.Bias dotBias)
将插入符位置和标记设置为指定位置，存在指定偏差。
 void setMagicCaretPosition(Point p)
保存当前插入符位置。
 void setSelectionVisible(boolean vis)
更改选定的可见性。
 void setUpdatePolicy(int policy)
设置文档更新时的插入符移动策略。
 void setVisible(boolean e)
设置插入符可见性，并重绘插入符。
 String toString()
返回表示此 Rectangle 及其值的 String。
从类 java.awt.Rectangle 继承的方法
add, add, add, contains, contains, contains, contains, createIntersection, createUnion, getBounds, getBounds2D, getHeight, getLocation, getSize, getWidth, getX, getY, grow, inside, intersection, intersects, isEmpty, move, outcode, reshape, resize, setBounds, setBounds, setLocation, setLocation, setRect, setSize, setSize, translate, union
从类 java.awt.geom.Rectangle2D 继承的方法
add, add, add, contains, contains, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, setRect, union
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.awt.Shape 继承的方法
contains, contains, contains, contains, getPathIterator, getPathIterator, intersects, intersects

字段详细信息

UPDATE_WHEN_ON_EDT

public static final int UPDATE_WHEN_ON_EDT
指示只有在事件调度线程中执行文档更改时，才更新插入符位置。

从以下版本开始：
1.5
另请参见：
setUpdatePolicy(int), getUpdatePolicy(), 常量字段值

NEVER_UPDATE

public static final int NEVER_UPDATE
指示无论文档有任何更新，插入符都应在文档中保持同一绝对位置，由于删除使文档长度小于当前插入符位置除外。这种情况下，插入符位置将调整到文档的结尾。

从以下版本开始：
1.5
另请参见：
setUpdatePolicy(int), getUpdatePolicy(), 常量字段值

ALWAYS_UPDATE

public static final int ALWAYS_UPDATE
指示无论文档更新是否是在事件调度线程中执行，始终根据文档更改更新插入符位置。

从以下版本开始：
1.5
另请参见：
setUpdatePolicy(int), getUpdatePolicy(), 常量字段值

listenerList

protected EventListenerList listenerList
事件侦听器列表。

changeEvent

protected transient ChangeEvent changeEvent
此模型的更改事件。由于事件的唯一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。这里生成的事件源总是 "this"。

构造方法详细信息

DefaultCaret

public DefaultCaret()
构造默认的插入符。

方法详细信息

setUpdatePolicy

public void setUpdatePolicy(int policy)
设置文档更新时的插入符移动策略。通常，当在插入符位置之前或当前位置插入时，以及在插入符位置之前删除时，插入符会更新其在文档中的绝对位置。这里的“绝对位置”指的是相对于文档开头的位置。例如，在一个可编辑的文本组件中输入一个字符时，它将插入到插入符位置，而插入符由于此插入将移动到文档中下一个绝对位置，如果输入的是 BACKSPACE，插入符的绝对位置将减小，因为在它之前删除了一个字符。有时候，关闭插入符位置更新很有用，这样无论文档怎么更新，插入符都将保持在文档中同一绝对位置。

允许以下更新策略：

  • NEVER_UPDATE：无论文档怎样更新，插入符在文档中都位于同一绝对位置，除非由于删除使文档长度小于当前插入符位置。这种情况下，插入符位置将被调整到文档的结尾。使用此策略时，插入符不会试图在滚动关联的视图时保持可见。
  • ALWAYS_UPDATE：插入符始终跟踪文档更改。对于一般的更改，如果在插入符位置之前或当前位置插入，则增加它的位置，如果在当前位置之前删除，则减小它的位置。对于撤消/恢复更新，它总是移动到更新发生的位置。插入符总是试图通过调用 adjustVisibility 方法保持可见。
  • UPDATE_WHEN_ON_EDT：如果文档更新在事件调度线程上执行，则与 ALWAYS_UPDATE 动作类似；如果文档更新在其它线程上执行，则与 NEVER_UPDATE 类似。

默认属性值为 UPDATE_WHEN_ON_EDT。

参数：
policy - 它是以下值之一：UPDATE_WHEN_ON_EDT、NEVER_UPDATE、ALWAYS_UPDATE
抛出：
IllegalArgumentException - 如果传入无效的值
从以下版本开始：
1.5
另请参见：
getUpdatePolicy(), adjustVisibility(java.awt.Rectangle), UPDATE_WHEN_ON_EDT, NEVER_UPDATE, ALWAYS_UPDATE

getUpdatePolicy

public int getUpdatePolicy()
获取文档更新时的插入符移动策略。

返回：
以下值之一：UPDATE_WHEN_ON_EDT、NEVER_UPDATE、ALWAYS_UPDATE
从以下版本开始：
1.5
另请参见：
setUpdatePolicy(int), UPDATE_WHEN_ON_EDT, NEVER_UPDATE, ALWAYS_UPDATE

getComponent

protected final JTextComponent getComponent()
获取此插入符所绑定的文本编辑器组件。

返回：
组件

repaint

protected final void repaint()
使得重绘插入符。重绘区域为插入符的边界框（即插入符矩形或 this）。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

damage

protected void damage(Rectangle r)
毁坏围绕插入符的区域以使该区域在新的位置重绘。如果重新实现 paint()，此方法也应重新实现。此方法应更新插入符边界（x、y、width 和 height）。

参数：
r - 插入符的当前位置
另请参见：
paint(java.awt.Graphics)

adjustVisibility

protected void adjustVisibility(Rectangle nloc)
滚动关联的视图（如果有）以使插入符可见。究竟应该如何动作在某种程度上是一个策略的问题，此方法可重新实现以更改此行为。默认情况下，scrollRectToVisible 方法在关联的组件中调用。

参数：
nloc - 要滚动到的新位置

getSelectionPainter

protected Highlighter.HighlightPainter getSelectionPainter()
获取此 Highlighter 的 painter。

返回：
painter

positionCaret

protected void positionCaret(MouseEvent e)
试图使用 viewToModel() 从鼠标事件的坐标设置插入符的位置。

参数：
e - 鼠标事件

moveCaret

protected void moveCaret(MouseEvent e)
试图使用 viewToModel() 从鼠标事件的坐标移动插入符的位置。如果点与标记不同，这将产生一个选定。

参数：
e - 鼠标事件

focusGained

public void focusGained(FocusEvent e)
在包含插入符的组件获得焦点时调用。如果组件为可编辑，实现此方法可将插入符设置为可见。

指定者：
接口 FocusListener 中的 focusGained
参数：
e - 鼠标事件
另请参见：
FocusListener.focusGained(java.awt.event.FocusEvent)

focusLost

public void focusLost(FocusEvent e)
在包含插入符的组件失去焦点时调用。实现此方法可将插入符的可见性设置为 false。

指定者：
接口 FocusListener 中的 focusLost
参数：
e - 鼠标事件
另请参见：
FocusListener.focusLost(java.awt.event.FocusEvent)

mouseClicked

public void mouseClicked(MouseEvent e)
单击鼠标时调用。如果单击是由 button1 生成的，则双击选中一个字，三击选中当前行。

指定者：
接口 MouseListener 中的 mouseClicked
参数：
e - 鼠标事件
另请参见：
MouseListener.mouseClicked(java.awt.event.MouseEvent)

mousePressed

public void mousePressed(MouseEvent e)
如果按下 button 1，实现它可请求将焦点置于关联的文本组件上，并设置插入符位置。如果按住 shift 键，插入符将移动，潜在导致一个选定，否则插入符位置将被设置为新位置。如果该组件未启用，则不会有任何焦点请求。

指定者：
接口 MouseListener 中的 mousePressed
参数：
e - 鼠标事件
另请参见：
MouseListener.mousePressed(java.awt.event.MouseEvent)

mouseReleased

public void mouseReleased(MouseEvent e)
释放鼠标时调用。

指定者：
接口 MouseListener 中的 mouseReleased
参数：
e - 鼠标事件
另请参见：
MouseListener.mouseReleased(java.awt.event.MouseEvent)

mouseEntered

public void mouseEntered(MouseEvent e)
鼠标进入某个区域时调用。

指定者：
接口 MouseListener 中的 mouseEntered
参数：
e - 鼠标事件
另请参见：
MouseListener.mouseEntered(java.awt.event.MouseEvent)

mouseExited

public void mouseExited(MouseEvent e)
鼠标退出某个区域时调用。

指定者：
接口 MouseListener 中的 mouseExited
参数：
e - 鼠标事件
另请参见：
MouseListener.mouseExited(java.awt.event.MouseEvent)

mouseDragged

public void mouseDragged(MouseEvent e)
根据鼠标指针当前位置移动插入符位置。这有效地扩展了选定。默认情况下，只有鼠标按键 1 才能完成这一操作。

指定者：
接口 MouseMotionListener 中的 mouseDragged
参数：
e - 鼠标事件
另请参见：
MouseMotionListener.mouseDragged(java.awt.event.MouseEvent)

mouseMoved

public void mouseMoved(MouseEvent e)
移动鼠标时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
参数：
e - 鼠标事件
另请参见：
MouseMotionListener.mouseMoved(java.awt.event.MouseEvent)

paint

public void paint(Graphics g)
将插入符作为垂直线呈现。如果重新实现此方法，则 damage 方法也应重新实现，因为它假定插入符的形状为垂直线。将插入符颜色设置为 getCaretColor() 返回的值。

如果关联文档中有多个文本方向，将呈现一个指示插入符偏移的标志。只有当关联文档为 AbstractDocument 的子类并且在双向元素结构中有多个双向级别时（即文本关联了多个方向），才会发生这样的情况。

指定者：
接口 Caret 中的 paint
参数：
g - 图形上下文
另请参见：
damage(java.awt.Rectangle)

install

public void install(JTextComponent c)
当 UI 装入一个 JTextComponent 的接口时调用。使用此方法可获得对由此接口的实现导航的模型的访问。将点和标记设置为 0，并建立文档、属性更改、焦点、鼠标及鼠标动作侦听器。

指定者：
接口 Caret 中的 install
参数：
c - 组件
另请参见：
Caret.install(javax.swing.text.JTextComponent)

deinstall

public void deinstall(JTextComponent c)
当 UI 从一个 JTextComponent 的接口移除时调用。这可用于取消对任何所关联侦听器的注册。

指定者：
接口 Caret 中的 deinstall
参数：
c - 组件
另请参见：
Caret.deinstall(javax.swing.text.JTextComponent)

addChangeListener

public void addChangeListener(ChangeListener l)
添加一个侦听器，以便对插入符位置改变进行跟踪。

指定者：
接口 Caret 中的 addChangeListener
参数：
l - 侦听器
另请参见：
Caret.addChangeListener(javax.swing.event.ChangeListener)

removeChangeListener

public void removeChangeListener(ChangeListener l)
移除跟踪位置更改的侦听器。

指定者：
接口 Caret 中的 removeChangeListener
参数：
l - 侦听器
另请参见：
Caret.removeChangeListener(javax.swing.event.ChangeListener)

getChangeListeners

public ChangeListener[] getChangeListeners()
返回此插入符上所有已注册的更改侦听器组成的数组。

返回：
此插入符的所有 ChangeListener， 如果当前未注册任何改侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener)

fireStateChanged

protected void fireStateChanged()
通知所有需要此事件类型的通知的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。从后向前处理侦听器列表。

另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用以下代码查询 DefaultCaret c 以获得其更改侦听器：

ChangeListener[] cls = (ChangeListener[])(c.getListeners(ChangeListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 所请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
返回一个在此组件上作为 FooListener 注册的所有对象的数组，如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getChangeListeners()

setSelectionVisible

public void setSelectionVisible(boolean vis)
更改选定的可见性。

指定者：
接口 Caret 中的 setSelectionVisible
参数：
vis - 新可见性

isSelectionVisible

public boolean isSelectionVisible()
检查当前选定是否可见。

指定者：
接口 Caret 中的 isSelectionVisible
返回：
如果选定为可见，则返回 true

isActive

public boolean isActive()
确定插入符当前是否处于激活状态。

此方法返回 Caret 当前是否处于闪烁状态。它不提供有关当前闪烁为打开或关闭的信息。要确定插入符当前是否绘制，请使用 isVisible 方法。

返回：
如果处于激活状态，则返回 true；否则返回 false
从以下版本开始：
1.5
另请参见：
isVisible()

isVisible

public boolean isVisible()
指示插入符当前是否可见。由于插入符闪烁打开和关闭，它的返回值将在 true 和 false 之间改变。当绘制插入符时，返回 true；当不绘制插入符时，返回 false。isActive 指示插入符是否处于闪烁状态，它可能为可见，而 isVisible 指示插入符是否确实为可见。

希望呈现不同的闪烁插入符的子类应重写 paint，并只在此方法返回 true 时才绘制插入符。

指定者：
接口 Caret 中的 isVisible
返回：
如果可见，则返回 true；否则返回 false
另请参见：
Caret.isVisible(), isActive()

setVisible

public void setVisible(boolean e)
设置插入符可见性，并重绘插入符。理解此方法、isVisible 以及 isActive 三者之间的关系非常重要。使用 true 值调用此方法可激活插入符闪烁。将它设置为 false 可彻底关闭闪烁。要确定闪烁是否激活，应调用 isActive。从实际效果来看，isActive 相当于它的 "getter" 方法，isVisible 可用于获取插入符的当前可见状态，即当前是否绘制的状态。此状态将随插入符的闪烁打开和关闭而更改。

下面的列表显示了调用此方法后 isActive 和 isVisible 可能的返回值：

setVisible(true):

  • isActive():true
  • isVisible():true 或 false 取决于插入符闪烁为打开还是关闭

setVisible(false):

  • isActive():false
  • isVisible():false

指定者：
接口 Caret 中的 setVisible
参数：
e - 可见性指示符
另请参见：
isActive(), Caret.setVisible(boolean)

setBlinkRate

public void setBlinkRate(int rate)
设置插入符闪烁率。

指定者：
接口 Caret 中的 setBlinkRate
参数：
rate - 闪烁率，以毫秒为单位，0 为停止闪烁
另请参见：
Caret.setBlinkRate(int)

getBlinkRate

public int getBlinkRate()
获取插入符闪烁率。

指定者：
接口 Caret 中的 getBlinkRate
返回：
延迟，以毫秒为单位。如果为 0，则插入符不闪烁。
另请参见：
Caret.getBlinkRate()

getDot

public int getDot()
获取插入符的当前位置。

指定者：
接口 Caret 中的 getDot
返回：
位置，该位置 >= 0
另请参见：
Caret.getDot()

getMark

public int getMark()
获取标记的当前位置。如果有选定，点和标记将不同。

指定者：
接口 Caret 中的 getMark
返回：
位置，该位置 >= 0
另请参见：
Caret.getMark()

setDot

public void setDot(int dot)
将插入符位置和标记设置为指定位置，存在向前偏差。此方法将选择范围隐式地设置为 0。

指定者：
接口 Caret 中的 setDot
参数：
dot - 位置，该位置 >= 0
另请参见：
setDot(int, Position.Bias), Caret.setDot(int)

moveDot

public void moveDot(int dot)
将插入符位置移动到指定位置，存在向前偏差。

指定者：
接口 Caret 中的 moveDot
参数：
dot - 位置，该位置 >= 0
另请参见：
moveDot(int, javax.swing.text.Position.Bias), Caret.moveDot(int)

moveDot

public void moveDot(int dot,
                    Position.Bias dotBias)
将插入符位置移动到指定位置，存在指定偏差。

参数：
dot - >= 0 的位置
dotBias - 此位置的偏差，不为 null
抛出：
IllegalArgumentException - 如果偏差为 null
从以下版本开始：
1.6
另请参见：
Caret.moveDot(int)

setDot

public void setDot(int dot,
                   Position.Bias dotBias)
将插入符位置和标记设置为指定位置，存在指定偏差。此方法将选择范围隐式地设置为 0。

参数：
dot - >= 0 的位置
dotBias - 此位置的偏差，不为 null
抛出：
IllegalArgumentException - 如果偏差为 null
从以下版本开始：
1.6
另请参见：
Caret.setDot(int)

getDotBias

public Position.Bias getDotBias()
返回插入符位置的偏差。

返回：
插入符位置的偏差
从以下版本开始：
1.6

getMarkBias

public Position.Bias getMarkBias()
返回标记的偏差。

返回：
标记的偏差
从以下版本开始：
1.6

setMagicCaretPosition

public void setMagicCaretPosition(Point p)
保存当前插入符位置。这在插入符有向上/向下动作时使用，方便在不均匀结束位置的行间移动。

指定者：
接口 Caret 中的 setMagicCaretPosition
参数：
p - 位置
另请参见：
getMagicCaretPosition()

getMagicCaretPosition

public Point getMagicCaretPosition()
获取保存的插入符位置。

指定者：
接口 Caret 中的 getMagicCaretPosition
返回：
位置 see #setMagicCaretPosition
另请参见：
Caret.setMagicCaretPosition(java.awt.Point)

equals

public boolean equals(Object obj)
将此对象与指定的对象进行比较。比较矩形的超类行为是不需要的，所以这将更改为 Object 行为。

覆盖：
类 Rectangle 中的 equals
参数：
obj - 要与此字体比较的对象
返回：
如果对象相同，则返回 true；否则，返回 false
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
从类 Rectangle 复制的描述
返回表示此 Rectangle 及其值的 String。

覆盖：
类 Rectangle 中的 toString
返回：
表示此 Rectangle 对象的坐标和大小值的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit

java.lang.Object
    继承者  javax.swing.text.EditorKit
        继承者  javax.swing.text.DefaultEditorKit
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
StyledEditorKit
public class DefaultEditorKit
extends EditorKit

这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。此实现提供了一个默认实现，该默认实现把文本当作纯文本，并提供简单编辑器的最小操作集合。

换行
有两个属性负责处理换行。系统属性 line.separator，它的定义是和平台相关的，可以是 "\n"、"\r" 或 "\r\n"。还有一个属性，它是在 DefaultEditorKit 中定义的，名称为 EndOfLineStringProperty，它是在文档加载时自动定义的，定义为第一个出现的任意换行符。加载文档后，将会适当地设置 EndOfLineStringProperty，当文档被写回时，将用到 EndOfLineStringProperty。但是当文档在内存中时，无论文档在磁盘上如何定义换行，现在都将用 "\n" 字符定义换行。因此，为便于搜索，要经常使用 "\n"。当创建了新文档而 EndOfLineStringProperty 尚未定义时，写入文档将使用 System 属性。

注意，在 Document 上使用 get/setProperty 方法设置 EndOfLineStringProperty。子类可重写此行为。

嵌套类摘要
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
字段摘要
static String | backwardAction 用于将插入符在逻辑上向后移动一个位置的动作名称。
static String | beepAction 用于创建蜂鸣声的动作名称。
static String | beginAction 用于将插入符移动到文档开头的 Action 名称。
static String | beginLineAction 用于将插入符移动到行首的 Action 名称。
static String | beginParagraphAction 用于将插入符移动到段落开头的 Action 名称。
static String | beginWordAction 用于将插入符移动到字首的 Action 名称。
static String | copyAction 复制选定区域并将其内容置于剪贴板中的动作名称。
static String | cutAction 剪切选定区域并将其内容置于剪贴板中的动作名称。
static String | defaultKeyTypedAction 在接收到键输入事件 并且无 keymap 输入时默认执行的动作名称。
static String | deleteNextCharAction 删除当前插入符位置之后字符内容的动作名称。
static String | deleteNextWordAction 删除选择开始位置之后单词的动作名称。
static String | deletePrevCharAction 删除当前插入符位置之前字符内容的动作名称。
static String | deletePrevWordAction 删除选择开始位置之前单词的动作名称。
static String | downAction 用于将插入符在逻辑上向下移动一个位置的动作名称。
static String | endAction 用于将插入符移动到文档末尾的 Action 名称。
static String | endLineAction 用于将插入符移动到行尾的 Action 名称。
static String | EndOfLineStringProperty 在读取文档时，如果遇到 CRLF，将添加具有此名称的一个属性，属性值为 "\r\n"。
static String | endParagraphAction 用于将插入符移动到段落末尾的 Action 名称。
static String | endWordAction 用于将插入符移动到字尾的动作名称。
static String | forwardAction 用于将插入符逻辑向前移动一个位置的动作名称。
static String | insertBreakAction 向文档放置行/段中断的动作名称。
static String | insertContentAction 将内容置于关联文档中的动作名称。
static String | insertTabAction 将制表符置于文档中的动作名称。
static String | nextWordAction 用于将插入符移动到下一个字开头的 Action 名称。
static String | pageDownAction 垂直向下翻页的动作名称。
static String | pageUpAction 垂直向上翻页的动作名称。
static String | pasteAction 将系统剪贴板内容粘贴到选定区域、如果未选中任何内容，则粘贴到插入符之前的动作名称。
static String | previousWordAction 用于将插入符移动到前一个字开头的 Action 名称。
static String | readOnlyAction 将编辑器设置为只读模式的动作名称。
static String | selectAllAction 用于选中整个文档的动作名称
static String | selectionBackwardAction 通过将插入符在逻辑上向后移动一个位置来扩展选定内容的动作名称。
static String | selectionBeginAction 用于将插入符移动到文档开头的 Action 名称。
static String | selectionBeginLineAction 用于将插入符移动到行首并扩展选定内容的 Action 名称。
static String | selectionBeginParagraphAction 用于将插入符移动到段落开头并扩展选定内容的 Action 名称。
static String | selectionBeginWordAction 用于将插入符移动到字首并扩展选定内容的 Action 名称。
static String | selectionDownAction 用于将插入符在逻辑上向下移动一个位置并扩展选定内容的动作名称。
static String | selectionEndAction 用于将插入符移动到文档末尾的 Action 名称。
static String | selectionEndLineAction 用于将插入符移动到行尾并扩展选定内容的 Action 名称。
static String | selectionEndParagraphAction 用于将插入符移动到段落末尾并扩展选定内容的 Action 名称。
static String | selectionEndWordAction 用于将插入符移动到字尾并扩展选定内容的动作名称。
static String | selectionForwardAction 通过将插入符在逻辑上向前移动一个位置来扩展选定内容的动作名称。
static String | selectionNextWordAction 用于将选定内容移动到下一个字的开头并扩展选定内容的 Action 名称。
static String | selectionPreviousWordAction 用于将选定内容移动到前一个字的开头并扩展选定内容的 Action 名称。
static String | selectionUpAction 用于将插入符在逻辑上向上移动一个位置并扩展选定内容的动作名称。
static String | selectLineAction 用于选中围绕插入符的某一行的 Action 名称。
static String | selectParagraphAction 用于选中围绕插入符的一个段落的动作名称。
static String | selectWordAction 用于选中围绕插入符的某个字的 Action 名称。
static String | upAction 用于将插入符在逻辑上向上移动一个位置的动作名称。
static String | writableAction 将编辑器设置为可写入模式的动作名称。
构造方法摘要
DefaultEditorKit()
DefaultEditorKit 的默认构造方法
方法摘要
Caret | createCaret() 获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
Document | createDefaultDocument() 创建一个适合此编辑器类型的未初始化文本存储模型 (PlainDocument)。
Action[] | getActions() 获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
String | getContentType() 获取此工具包声明支持的数据的 MIME 类型。
ViewFactory | getViewFactory() 获取一个适合供由此包所产生的任何模型来产生视图的工厂。
void | read(InputStream in, Document doc, int pos) 插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
void | read(Reader in, Document doc, int pos) 插入取自给定流的内容，它将被视为纯文本。
void | write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
void | write(Writer out, Document doc, int pos, int len) 将取自文档的内容以纯文本格式写入给定流。
从类 javax.swing.text.EditorKit 继承的方法
clone, deinstall, install
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

EndOfLineStringProperty

public static final String EndOfLineStringProperty
在读取文档时，如果遇到 CRLF，将添加具有此名称的一个属性，属性值为 "\r\n"。

另请参见：
常量字段值

insertContentAction

public static final String insertContentAction
将内容置于关联文档中的动作名称。如果存在选定内容，则在添加新内容之前将移除这些选定内容。

另请参见：
getActions(), 常量字段值

insertBreakAction

public static final String insertBreakAction
向文档放置行/段中断的动作名称。如果存在选定内容，则在添加中断之前将移除这些选定内容。

另请参见：
getActions(), 常量字段值

insertTabAction

public static final String insertTabAction
将制表符置于文档中的动作名称。如果存在选定内容，则在添加制表符之前将移除这些选定内容。

另请参见：
getActions(), 常量字段值

deletePrevCharAction

public static final String deletePrevCharAction
删除当前插入符位置之前字符内容的动作名称。

另请参见：
getActions(), 常量字段值

deleteNextCharAction

public static final String deleteNextCharAction
删除当前插入符位置之后字符内容的动作名称。

另请参见：
getActions(), 常量字段值

deleteNextWordAction

public static final String deleteNextWordAction
删除选择开始位置之后单词的动作名称。

从以下版本开始：
1.6
另请参见：
getActions(), JTextComponent.getSelectionStart(), 常量字段值

deletePrevWordAction

public static final String deletePrevWordAction
删除选择开始位置之前单词的动作名称。

从以下版本开始：
1.6
另请参见：
getActions(), JTextComponent.getSelectionStart(), 常量字段值

readOnlyAction

public static final String readOnlyAction
将编辑器设置为只读模式的动作名称。

另请参见：
getActions(), 常量字段值

writableAction

public static final String writableAction
将编辑器设置为可写入模式的动作名称。

另请参见：
getActions(), 常量字段值

cutAction

public static final String cutAction
剪切选定区域并将其内容置于剪贴板中的动作名称。

另请参见：
JTextComponent.cut(), getActions(), 常量字段值

copyAction

public static final String copyAction
复制选定区域并将其内容置于剪贴板中的动作名称。

另请参见：
JTextComponent.copy(), getActions(), 常量字段值

pasteAction

public static final String pasteAction
将系统剪贴板内容粘贴到选定区域、如果未选中任何内容，则粘贴到插入符之前的动作名称。

另请参见：
JTextComponent.paste(), getActions(), 常量字段值

beepAction

public static final String beepAction
用于创建蜂鸣声的动作名称。

另请参见：
getActions(), 常量字段值

pageUpAction

public static final String pageUpAction
垂直向上翻页的动作名称。

另请参见：
getActions(), 常量字段值

pageDownAction

public static final String pageDownAction
垂直向下翻页的动作名称。

另请参见：
getActions(), 常量字段值

forwardAction

public static final String forwardAction
用于将插入符逻辑向前移动一个位置的动作名称。

另请参见：
getActions(), 常量字段值

backwardAction

public static final String backwardAction
用于将插入符在逻辑上向后移动一个位置的动作名称。

另请参见：
getActions(), 常量字段值

selectionForwardAction

public static final String selectionForwardAction
通过将插入符在逻辑上向前移动一个位置来扩展选定内容的动作名称。

另请参见：
getActions(), 常量字段值

selectionBackwardAction

public static final String selectionBackwardAction
通过将插入符在逻辑上向后移动一个位置来扩展选定内容的动作名称。

另请参见：
getActions(), 常量字段值

upAction

public static final String upAction
用于将插入符在逻辑上向上移动一个位置的动作名称。

另请参见：
getActions(), 常量字段值

downAction

public static final String downAction
用于将插入符在逻辑上向下移动一个位置的动作名称。

另请参见：
getActions(), 常量字段值

selectionUpAction

public static final String selectionUpAction
用于将插入符在逻辑上向上移动一个位置并扩展选定内容的动作名称。

另请参见：
getActions(), 常量字段值

selectionDownAction

public static final String selectionDownAction
用于将插入符在逻辑上向下移动一个位置并扩展选定内容的动作名称。

另请参见：
getActions(), 常量字段值

beginWordAction

public static final String beginWordAction
用于将插入符移动到字首的 Action 名称。

另请参见：
getActions(), 常量字段值

endWordAction

public static final String endWordAction
用于将插入符移动到字尾的动作名称。

另请参见：
getActions(), 常量字段值

selectionBeginWordAction

public static final String selectionBeginWordAction
用于将插入符移动到字首并扩展选定内容的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionEndWordAction

public static final String selectionEndWordAction
用于将插入符移动到字尾并扩展选定内容的动作名称。

另请参见：
getActions(), 常量字段值

previousWordAction

public static final String previousWordAction
用于将插入符移动到前一个字开头的 Action 名称。

另请参见：
getActions(), 常量字段值

nextWordAction

public static final String nextWordAction
用于将插入符移动到下一个字开头的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionPreviousWordAction

public static final String selectionPreviousWordAction
用于将选定内容移动到前一个字的开头并扩展选定内容的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionNextWordAction

public static final String selectionNextWordAction
用于将选定内容移动到下一个字的开头并扩展选定内容的 Action 名称。

另请参见：
getActions(), 常量字段值

beginLineAction

public static final String beginLineAction
用于将插入符移动到行首的 Action 名称。

另请参见：
getActions(), 常量字段值

endLineAction

public static final String endLineAction
用于将插入符移动到行尾的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionBeginLineAction

public static final String selectionBeginLineAction
用于将插入符移动到行首并扩展选定内容的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionEndLineAction

public static final String selectionEndLineAction
用于将插入符移动到行尾并扩展选定内容的 Action 名称。

另请参见：
getActions(), 常量字段值

beginParagraphAction

public static final String beginParagraphAction
用于将插入符移动到段落开头的 Action 名称。

另请参见：
getActions(), 常量字段值

endParagraphAction

public static final String endParagraphAction
用于将插入符移动到段落末尾的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionBeginParagraphAction

public static final String selectionBeginParagraphAction
用于将插入符移动到段落开头并扩展选定内容的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionEndParagraphAction

public static final String selectionEndParagraphAction
用于将插入符移动到段落末尾并扩展选定内容的 Action 名称。

另请参见：
getActions(), 常量字段值

beginAction

public static final String beginAction
用于将插入符移动到文档开头的 Action 名称。

另请参见：
getActions(), 常量字段值

endAction

public static final String endAction
用于将插入符移动到文档末尾的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionBeginAction

public static final String selectionBeginAction
用于将插入符移动到文档开头的 Action 名称。

另请参见：
getActions(), 常量字段值

selectionEndAction

public static final String selectionEndAction
用于将插入符移动到文档末尾的 Action 名称。

另请参见：
getActions(), 常量字段值

selectWordAction

public static final String selectWordAction
用于选中围绕插入符的某个字的 Action 名称。

另请参见：
getActions(), 常量字段值

selectLineAction

public static final String selectLineAction
用于选中围绕插入符的某一行的 Action 名称。

另请参见：
getActions(), 常量字段值

selectParagraphAction

public static final String selectParagraphAction
用于选中围绕插入符的一个段落的动作名称。

另请参见：
getActions(), 常量字段值

selectAllAction

public static final String selectAllAction
用于选中整个文档的动作名称

另请参见：
getActions(), 常量字段值

defaultKeyTypedAction

public static final String defaultKeyTypedAction
在接收到键输入事件 并且无 keymap 输入时默认执行的动作名称。

另请参见：
getActions(), 常量字段值
构造方法详细信息

DefaultEditorKit

public DefaultEditorKit()
DefaultEditorKit 的默认构造方法

方法详细信息

getContentType

public String getContentType()
获取此工具包声明支持的数据的 MIME 类型。默认类型为 text/plain。

指定者：
类 EditorKit 中的 getContentType
返回：
类型

getViewFactory

public ViewFactory getViewFactory()
获取一个适合供由此包所产生的任何模型来产生视图的工厂。默认情况下，让 UI 生成此工厂，所以此方法无实现。

指定者：
类 EditorKit 中的 getViewFactory
返回：
视图工厂

getActions

public Action[] getActions()
获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。

指定者：
类 EditorKit 中的 getActions
返回：
命令列表

createCaret

public Caret createCaret()
获取能在由关联的 ViewFactory 生成的视图中导航的插入符。

指定者：
类 EditorKit 中的 createCaret
返回：
插入符

createDefaultDocument

public Document createDefaultDocument()
创建一个适合此编辑器类型的未初始化文本存储模型 (PlainDocument)。

指定者：
类 EditorKit 中的 createDefaultDocument
返回：
模型

read

public void read(InputStream in,
                 Document doc,
                 int pos)
          throws IOException,
                 BadLocationException
插入取自给定流的内容，其格式需要适合此类型的内容处理程序。

指定者：
类 EditorKit 中的 read
参数：
in - 要读入的流
doc - 插入到的目标文档。
pos - 文档中放入内容的位置，该位置 >= 0。
抛出：
IOException - 如果有任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置。

write

public void write(OutputStream out,
                  Document doc,
                  int pos,
                  int len)
           throws IOException,
                  BadLocationException
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

指定者：
类 EditorKit 中的 write
参数：
out - 要写入的流
doc - 写入所用的源文档。
pos - 文档中获取内容的位置，该位置 >= 0。
len - 要写出的量，该写出量 >= 0。
抛出：
IOException - 如果有任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置。

read

public void read(Reader in,
                 Document doc,
                 int pos)
          throws IOException,
                 BadLocationException
插入取自给定流的内容，它将被视为纯文本。

指定者：
类 EditorKit 中的 read
参数：
in - 要读入的流
doc - 插入到的目标文档。
pos - 文档中放入内容的位置，该位置 >= 0。
抛出：
IOException - 如果有任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置。

write

public void write(Writer out,
                  Document doc,
                  int pos,
                  int len)
           throws IOException,
                  BadLocationException
将取自文档的内容以纯文本格式写入给定流。

指定者：
类 EditorKit 中的 write
参数：
out - 要写入的流
doc - 写入所用的源文档。
pos - 文档中获取内容的位置，该位置 >= 0。
len - 要写入的量，该写入量 >= 0。
抛出：
IOException - 如果有任何 I/O 错误
BadLocationException - 如果 pos 不是位于 0 和文档长度之间。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit.CutAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit.CutAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.DefaultEditorKit.CutAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
DefaultEditorKit
public static class DefaultEditorKit.CutAction
extends TextAction

剪切选定的区域并将其内容放入系统剪贴板中。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultEditorKit.cutAction, DefaultEditorKit.getActions()

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
DefaultEditorKit.CutAction()
使用适当的标识符创建此对象。
方法摘要
 void actionPerformed(ActionEvent e)
触发此动作时执行的操作。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultEditorKit.CutAction

public DefaultEditorKit.CutAction()
使用适当的标识符创建此对象。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
触发此动作时执行的操作。

参数：
e - 动作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit.BeepAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit.BeepAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.DefaultEditorKit.BeepAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
DefaultEditorKit
public static class DefaultEditorKit.BeepAction
extends TextAction

创建蜂鸣声。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultEditorKit.beepAction, DefaultEditorKit.getActions()

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
DefaultEditorKit.BeepAction()
使用适当的标识符创建此对象。
方法摘要
 void actionPerformed(ActionEvent e)
触发此动作时执行的操作。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultEditorKit.BeepAction

public DefaultEditorKit.BeepAction()
使用适当的标识符创建此对象。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
触发此动作时执行的操作。

参数：
e - 动作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit.CopyAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit.CopyAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.DefaultEditorKit.CopyAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
DefaultEditorKit
public static class DefaultEditorKit.CopyAction
extends TextAction

复制选定的区域并将其内容放入系统剪贴板中。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultEditorKit.copyAction, DefaultEditorKit.getActions()

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
DefaultEditorKit.CopyAction()
使用适当的标识符创建此对象。
方法摘要
 void actionPerformed(ActionEvent e)
触发此动作时执行的操作。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultEditorKit.CopyAction

public DefaultEditorKit.CopyAction()
使用适当的标识符创建此对象。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
触发此动作时执行的操作。

参数：
e - 动作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit.DefaultKeyTypedAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit.DefaultKeyTypedAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
DefaultEditorKit
public static class DefaultEditorKit.DefaultKeyTypedAction
extends TextAction

如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。不同的虚拟机对于将什么作为键输入 事件发送有所不同，并且此动作试图过滤掉不需要的事件。这将过滤控制字符和那些带有 ALT 修饰符的字符。它允许 Control-Alt 序列通过，因为它们在一些 PC 键盘上组成了合法的 unicode 字符。

如果事件未获得过滤，它会尝试将内容插入文本编辑器。内容取自 ActionEvent 的命令字符串。文本输入通过目标文本组件的 replaceSelection 方法完成。这是大多数文本输入任务都将触发的动作。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultEditorKit.defaultKeyTypedAction,
DefaultEditorKit.getActions(),
Keymap.setDefaultAction(javax.swing.Action),
Keymap.getDefaultAction()

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
DefaultEditorKit.DefaultKeyTypedAction()
用适当的标识符创建此对象。
方法摘要
 void actionPerformed(ActionEvent e)
动作触发时执行的操作。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultEditorKit.DefaultKeyTypedAction

public DefaultEditorKit.DefaultKeyTypedAction()
用适当的标识符创建此对象。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
动作触发时执行的操作。

参数：
e - 动作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit.InsertBreakAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit.InsertBreakAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.DefaultEditorKit.InsertBreakAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
DefaultEditorKit
public static class DefaultEditorKit.InsertBreakAction
extends TextAction

在文档中放置行/段落中断。如果存在选定内容，则在添加中断之前将移除这选定内容。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultEditorKit.insertBreakAction, DefaultEditorKit.getActions()

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
DefaultEditorKit.InsertBreakAction()
创建此对象，使其具有相应的标识符。
方法摘要
 void actionPerformed(ActionEvent e)
触发此动作时执行该操作。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultEditorKit.InsertBreakAction

public DefaultEditorKit.InsertBreakAction()
创建此对象，使其具有相应的标识符。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
触发此动作时执行该操作。

参数：
e - 动作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit.InsertContentAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit.InsertContentAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.DefaultEditorKit.InsertContentAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
DefaultEditorKit
public static class DefaultEditorKit.InsertContentAction
extends TextAction

将内容置于关联的文档中。如果存在选定内容，则在添加新内容之前将移除这选定内容。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultEditorKit.insertContentAction, DefaultEditorKit.getActions()

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
DefaultEditorKit.InsertContentAction()
创建此对象，使其具有相应的标识符。
方法摘要
 void actionPerformed(ActionEvent e)
此动作触发时执行的操作。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultEditorKit.InsertContentAction

public DefaultEditorKit.InsertContentAction()
创建此对象，使其具有相应的标识符。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
此动作触发时执行的操作。

参数：
e - 动作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit.InsertTabAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit.InsertTabAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.DefaultEditorKit.InsertTabAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
DefaultEditorKit
public static class DefaultEditorKit.InsertTabAction
extends TextAction

将一个制表符置于文档中。如果存在选定内容，则在添加制表符之前将移除这选定内容。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultEditorKit.insertTabAction, DefaultEditorKit.getActions()

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
DefaultEditorKit.InsertTabAction()
创建此对象，使其具有相应的标识符。
方法摘要
 void actionPerformed(ActionEvent e)
此动作触发时执行的操作。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultEditorKit.InsertTabAction

public DefaultEditorKit.InsertTabAction()
创建此对象，使其具有相应的标识符。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
此动作触发时执行的操作。

参数：
e - 动作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultEditorKit.PasteAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultEditorKit.PasteAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.DefaultEditorKit.PasteAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
DefaultEditorKit
public static class DefaultEditorKit.PasteAction
extends TextAction

将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultEditorKit.pasteAction, DefaultEditorKit.getActions()

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
DefaultEditorKit.PasteAction()
创建此对象，使其具有相应的标识符。
方法摘要
 void actionPerformed(ActionEvent e)
触发此动作时执行的操作。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultEditorKit.PasteAction

public DefaultEditorKit.PasteAction()
创建此对象，使其具有相应的标识符。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
触发此动作时执行的操作。

参数：
e - 动作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultFormatter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultFormatter

java.lang.Object
    继承者  javax.swing.JFormattedTextField.AbstractFormatter
        继承者  javax.swing.text.DefaultFormatter
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
InternationalFormatter, MaskFormatter
public class DefaultFormatter
extends JFormattedTextField.AbstractFormatter
implements Cloneable, Serializable

DefaultFormatter 格式化任意对象。格式化是通过调用 toString 方法完成的。为将值转换回 String，类必须提供一个采用 String 参数的构造方法。如果未发现采用 String 的单一参数构造方法，则返回值将为传入 stringToValue 的 String。

DefaultFormatter 的实例不能在 JFormattedTextField 的多个实例中使用。要获得已配置好的 DefaultFormatter 的副本，请使用 clone 方法。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4
另请参见：
JFormattedTextField.AbstractFormatter

构造方法摘要
DefaultFormatter()
创建 DefaultFormatter。
方法摘要
Object | clone() 创建此 DefaultFormatter 的副本。
boolean | getAllowsInvalid() 返回编辑的值是否在一段时间内允许为无效。
boolean | getCommitsOnValidEdit() 返回何时将编辑内容发布回 JFormattedTextField。
protected DocumentFilter | getDocumentFilter() 返回用于限制放置到 JFormattedTextField 中的字符的 DocumentFilter。
protected NavigationFilter | getNavigationFilter() 返回用于限制光标放置位置的 NavigationFilter。
boolean | getOverwriteMode() 返回插入字符时的行为。
Class<?> | getValueClass() 返回用于创建新 Objects 的类。
void | install(JFormattedTextField ftf) 将 DefaultFormatter 安装到特定的 JFormattedTextField。
void | setAllowsInvalid(boolean allowsInvalid) 设置编辑的值在一段时间内是否允许为无效（也就是说，stringToValue 是否抛出 ParseException）。
void | setCommitsOnValidEdit(boolean commit) 设置何时将编辑内容发布回 JFormattedTextField。
void | setOverwriteMode(boolean overwriteMode) 配置插入字符时的行为。
void | setValueClass(Class<?> valueClass) 设置用于创建新 Objects 的类。
Object | stringToValue(String string) 通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。
String | valueToString(Object value) 使用 toString 方法将传入的 Object 转换为 String。
从类 javax.swing.JFormattedTextField.AbstractFormatter 继承的方法
getActions, getFormattedTextField, invalidEdit, setEditValid, uninstall
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultFormatter

public DefaultFormatter()
创建 DefaultFormatter。

方法详细信息

install

public void install(JFormattedTextField ftf)
将 DefaultFormatter 安装到特定的 JFormattedTextField。这会调用 valueToString，以便将 JFormattedTextField 的当前值转换为 String。此方法稍后将会把 getActions 返回的 Action、getDocumentFilter 返回的 DocumentFilter 和 getNavigationFilter 返回的 NavigationFilter 安装到 JFormattedTextField 上。

如果子类希望在 JFormattedTextField 上安装其他侦听器，则通常只需要重写此方法。

如果在将当前值转换为 String 时存在 ParseException，则这会将文本设置为空 String，并将 JFormattedTextField 标记为正处在无效状态。

尽管这是一个公共方法，但通常仅供 JFormattedTextField 的子类使用。当值发生更改，或内部状态发生更改时，JFormattedTextField 将在适当的时候调用此方法。

覆盖：
类 JFormattedTextField.AbstractFormatter 中的 install
参数：
ftf - 要格式化为的 JFormattedTextField，可以为 null，指示未从当前的 JFormattedTextField 安装。

setCommitsOnValidEdit

public void setCommitsOnValidEdit(boolean commit)
设置何时将编辑内容发布回 JFormattedTextField。如果为 true，commitEdit 在每次有效编辑（编辑文本的任何时间）后调用。另一方面，如果为 false，则 DefaultFormatter 不会将编辑内容发布回 JFormattedTextField。因此，JFormattedTextField 值的惟一一次改变发生的时间是，在 JFormattedTextField 上调用 commitEdit 时，通常为按下回车或当焦点离开 JFormattedTextField 时。

参数：
commit - 用于指示何时将编辑内容提交回 JTextComponent

getCommitsOnValidEdit

public boolean getCommitsOnValidEdit()
返回何时将编辑内容发布回 JFormattedTextField。

返回：
如果在每次有效编辑后提交编辑，则返回 true

setOverwriteMode

public void setOverwriteMode(boolean overwriteMode)
配置插入字符时的行为。如果 overwriteMode 为 true （默认值），新字符将改写模型中现有的字符。

参数：
overwriteMode - 指示使用改写或替代模式

getOverwriteMode

public boolean getOverwriteMode()
返回插入字符时的行为。

返回：
如果新插入字符改写现有字符，则返回 true

setAllowsInvalid

public void setAllowsInvalid(boolean allowsInvalid)
设置编辑的值在一段时间内是否允许为无效（也就是说，stringToValue 是否抛出 ParseException）。允许用户临时输入一个无效值会很方便。

参数：
allowsInvalid - 用于指示编辑的值是否必须始终为有效

getAllowsInvalid

public boolean getAllowsInvalid()
返回编辑的值是否在一段时间内允许为无效。

返回：
如果编辑的值必须始终为有效，则返回 false

setValueClass

public void setValueClass(Class<?> valueClass)
设置用于创建新 Objects 的类。如果传入的类不具有采用 String 的只带一个参数的构造方法，将使用 String 值。

参数：
valueClass - 用于构造从 stringToValue 中返回的值的类

getValueClass

public Class<?> getValueClass()
返回用于创建新 Objects 的类。

返回：
用于构造从 stringToValue 中返回的值的类

stringToValue

public Object stringToValue(String string)
                     throws ParseException
通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。如果 getValueClass 返回 null，将使用 JFormattedTextField 中当前值的类。如果它为 null，将返回一个 String。如果构造方法抛出异常，则会抛出 ParseException。如果没有只带一个参数的 String 构造方法，则返回 string。

指定者：
类 JFormattedTextField.AbstractFormatter 中的 stringToValue
参数：
string - 要转换的字符串
返回：
文本的 Object 表示形式
抛出：
ParseException - 如果转换过程中出现错误

valueToString

public String valueToString(Object value)
                     throws ParseException
使用 toString 方法将传入的 Object 转换为 String。

指定者：
类 JFormattedTextField.AbstractFormatter 中的 valueToString
参数：
value - 要转换的值
返回：
值的 String 表示形式
抛出：
ParseException - 如果在转换时发生错误

getDocumentFilter

protected DocumentFilter getDocumentFilter()
返回用于限制放置到 JFormattedTextField 中的字符的 DocumentFilter。

覆盖：
类 JFormattedTextField.AbstractFormatter 中的 getDocumentFilter
返回：
限制编辑的 DocumentFilter

getNavigationFilter

protected NavigationFilter getNavigationFilter()
返回用于限制光标放置位置的 NavigationFilter。

覆盖：
类 JFormattedTextField.AbstractFormatter 中的 getNavigationFilter
返回：
限制导航的 NavigationFilter

clone

public Object clone()
             throws CloneNotSupportedException
创建此 DefaultFormatter 的副本。

覆盖：
类 JFormattedTextField.AbstractFormatter 中的 clone
返回：
DefaultFormatter 的副本
抛出：
CloneNotSupportedException - 如果对象的类不支持 Cloneable 接口，则重写 clone 方法的子类也会抛出此异常，以指示无法复制某个实例。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultFormatterFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultFormatterFactory

java.lang.Object
    继承者  javax.swing.JFormattedTextField.AbstractFormatterFactory
        继承者  javax.swing.text.DefaultFormatterFactory
所有已实现的接口：
Serializable
public class DefaultFormatterFactory
extends JFormattedTextField.AbstractFormatterFactory
implements Serializable

JFormattedTextField.AbstractFormatterFactory 的一个实现。DefaultFormatterFactory 允许指定许多不同的 JFormattedTextField.AbstractFormatter 以供使用。最重要的一个为默认 (setDefaultFormatter)。如果无法找到更专用的 formatter，则使用默认的 formatter。下面的步骤用于确定要使用的适当 formatter。

  1. 传入的值是否为 null？使用 null formatter。
  2. JFormattedTextField 有焦点吗？使用编辑 formatter。
  3. 否则，使用显示 formatter。
  4. 如果未发现非 null AbstractFormatter，则使用默认 formatter。

下列代码显示如何用两个 JFormattedTextField.AbstractFormatter 配置 JFormattedTextField，一个用于显示，一个用于编辑。

 JFormattedTextField.AbstractFormatter editFormatter = ...;
 JFormattedTextField.AbstractFormatter displayFormatter = ...;
 DefaultFormatterFactory factory = new DefaultFormatterFactory(
                 displayFormatter, displayFormatter, editFormatter);
 JFormattedTextField tf = new JFormattedTextField(factory);

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4
另请参见：
JFormattedTextField

构造方法摘要
DefaultFormatterFactory()
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat, JFormattedTextField.AbstractFormatter nullFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
方法摘要
JFormattedTextField.AbstractFormatter | getDefaultFormatter() 返回供最后选择使用的 JFormattedTextField.AbstractFormatter，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | getDisplayFormatter() 返回在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | getEditFormatter() 返回在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | getFormatter(JFormattedTextField source) 根据 JFormattedTextField 的状态返回默认的 formatter、显示 formatter、编辑器 formatter 或 null formatter。
JFormattedTextField.AbstractFormatter | getNullFormatter() 返回值为 null 时使用的 formatter。
void | setDefaultFormatter(JFormattedTextField.AbstractFormatter atf) 设置 JFormattedTextField.AbstractFormatter 供最后选择使用，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
void | setDisplayFormatter(JFormattedTextField.AbstractFormatter atf) 设置在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
void | setEditFormatter(JFormattedTextField.AbstractFormatter atf) 设置在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
void | setNullFormatter(JFormattedTextField.AbstractFormatter atf) 设置在 JFormattedTextField 值为 null 时使用的 formatter。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultFormatterFactory

public DefaultFormatterFactory()

DefaultFormatterFactory

public DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。

参数：
defaultFormat - 在未发现更专用的 JFormattedTextField.AbstractFormatter 时使用的 JFormattedTextField.AbstractFormatter。

DefaultFormatterFactory

public DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat,
                               JFormattedTextField.AbstractFormatter displayFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。

参数：
defaultFormat - 在未发现更专用的 JFormattedTextField.AbstractFormatter 时使用的 JFormattedTextField.AbstractFormatter。
displayFormat - 在 JFormattedTextField 没有焦点时使用的 JFormattedTextField.AbstractFormatter。

DefaultFormatterFactory

public DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat,
                               JFormattedTextField.AbstractFormatter displayFormat,
                               JFormattedTextField.AbstractFormatter editFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。

参数：
defaultFormat - 在未发现更专用的 JFormattedTextField.AbstractFormatter 时使用的 JFormattedTextField.AbstractFormatter。
displayFormat - 在 JFormattedTextField 没有焦点时使用的 JFormattedTextField.AbstractFormatter。
editFormat - 在 JFormattedTextField 拥有焦点时使用的 JFormattedTextField.AbstractFormatter。

DefaultFormatterFactory

public DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat,
                               JFormattedTextField.AbstractFormatter displayFormat,
                               JFormattedTextField.AbstractFormatter editFormat,
                               JFormattedTextField.AbstractFormatter nullFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。

参数：
defaultFormat - 在未发现更专用的 JFormattedTextField.AbstractFormatter 时使用的 JFormattedTextField.AbstractFormatter。
displayFormat - 在 JFormattedTextField 没有焦点时使用的 JFormattedTextField.AbstractFormatter。
editFormat - 在 JFormattedTextField 拥有焦点时使用的 JFormattedTextField.AbstractFormatter。
nullFormat - JFormattedTextField 为 null 值时使用的 JFormattedTextField.AbstractFormatter。
方法详细信息

setDefaultFormatter

public void setDefaultFormatter(JFormattedTextField.AbstractFormatter atf)
设置 JFormattedTextField.AbstractFormatter 供最后选择使用，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。

参数：
atf - 未指定更专用值的情况下使用的 JFormattedTextField.AbstractFormatter

getDefaultFormatter

public JFormattedTextField.AbstractFormatter getDefaultFormatter()
返回供最后选择使用的 JFormattedTextField.AbstractFormatter，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。

返回：
未指定更专用值的情况下使用的 JFormattedTextField.AbstractFormatter。

setDisplayFormatter

public void setDisplayFormatter(JFormattedTextField.AbstractFormatter atf)
设置在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。

参数：
atf - 在 JFormattedTextField 没有焦点时使用的 JFormattedTextField.AbstractFormatter

getDisplayFormatter

public JFormattedTextField.AbstractFormatter getDisplayFormatter()
返回在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。

返回：
在 JFormattedTextField does 没有焦点时使用的 JFormattedTextField.AbstractFormatter

setEditFormatter

public void setEditFormatter(JFormattedTextField.AbstractFormatter atf)
设置在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。

参数：
atf - 在组件拥有焦点时使用的 JFormattedTextField.AbstractFormatter

getEditFormatter

public JFormattedTextField.AbstractFormatter getEditFormatter()
返回在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。

返回：
在组件拥有焦点时使用的 JFormattedTextField.AbstractFormatter

setNullFormatter

public void setNullFormatter(JFormattedTextField.AbstractFormatter atf)
设置在 JFormattedTextField 值为 null 时使用的 formatter。

参数：
atf - 在 JFormattedTextField 值为 null 时使用的 JFormattedTextField.AbstractFormatter。

getNullFormatter

public JFormattedTextField.AbstractFormatter getNullFormatter()
返回值为 null 时使用的 formatter。

返回：
值为 null 时使用的 JFormattedTextField.AbstractFormatter

getFormatter

public JFormattedTextField.AbstractFormatter getFormatter(JFormattedTextField source)
根据 JFormattedTextField 的状态返回默认的 formatter、显示 formatter、编辑器 formatter 或 null formatter。

指定者：
类 JFormattedTextField.AbstractFormatterFactory 中的 getFormatter
参数：
source - 请求 JFormattedTextField.AbstractFormatter 的 JFormattedTextField
返回：
处理格式任务的 JFormattedTextField.AbstractFormatter。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultHighlighter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultHighlighter

java.lang.Object
    继承者  javax.swing.text.LayeredHighlighter
        继承者  javax.swing.text.DefaultHighlighter
所有已实现的接口：
Highlighter
直接已知子类：
BasicTextUI.BasicHighlighter
public class DefaultHighlighter
extends LayeredHighlighter

实现 Highlighter 接口。实现一个用纯色绘制的简单高亮显示 painter。

另请参见：
Highlighter

嵌套类摘要
static class DefaultHighlighter.DefaultHighlightPainter
只高亮显示用纯色填充高亮显示区域的 painter。
从类 javax.swing.text.LayeredHighlighter 继承的嵌套类/接口
LayeredHighlighter.LayerPainter
从接口 javax.swing.text.Highlighter 继承的嵌套类/接口
Highlighter.Highlight, Highlighter.HighlightPainter
字段摘要
static LayeredHighlighter.LayerPainter DefaultPainter
LayeredHighlighter.LayerPainter 的默认实现，可用于绘制高亮显示区域。
构造方法摘要
DefaultHighlighter()
创建新 DefaultHighlighther 对象。
方法摘要
Object | addHighlight(int p0, int p1, Highlighter.HighlightPainter p) 向视图添加高亮显示。
void | changeHighlight(Object tag, int p0, int p1) 更改高亮显示。
void | deinstall(JTextComponent c) 从 JTextComponent 的接口移除 UI 时调用。
boolean | getDrawsLayeredHighlights()
Highlighter.Highlight[] | getHighlights() 制作高亮显示的副本。
void | install(JTextComponent c) 当 UI 安装到 JTextComponent 的接口时调用。
void | paint(Graphics g) 呈现高亮显示区域。
void | paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
void | removeAllHighlights() 移除所有的高亮显示。
void | removeHighlight(Object tag) 从视图中移除高亮显示。
void | setDrawsLayeredHighlights(boolean newValue) 如果为 true，则高亮显示将在视图绘制文本时绘制。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DefaultPainter

public static final LayeredHighlighter.LayerPainter DefaultPainter
LayeredHighlighter.LayerPainter 的默认实现，可用于绘制高亮显示区域。

从 1.4 开始，此字段为 final。

构造方法详细信息

DefaultHighlighter

public DefaultHighlighter()
创建新 DefaultHighlighther 对象。

方法详细信息

paint

public void paint(Graphics g)
呈现高亮显示区域。

参数：
g - 图形上下文

install

public void install(JTextComponent c)
当 UI 安装到 JTextComponent 的接口时调用。安装编辑器并移除任何现有的高亮显示。

参数：
c - 编辑器组件
另请参见：
Highlighter.install(javax.swing.text.JTextComponent)

deinstall

public void deinstall(JTextComponent c)
从 JTextComponent 的接口移除 UI 时调用。

参数：
c - 组件
另请参见：
Highlighter.deinstall(javax.swing.text.JTextComponent)

addHighlight

public Object addHighlight(int p0,
                           int p1,
                           Highlighter.HighlightPainter p)
                    throws BadLocationException
向视图添加高亮显示。返回一个可用于引用高亮显示的标记。

参数：
p0 - 要高亮显示范围的起始偏移量，该值 >= 0
p1 - 要高亮显示范围的结束偏移量，该值 >= p0
p - 要用于实际呈现高亮显示的 painter
返回：
可充当引用高亮显示的标记的对象
抛出：
BadLocationException - 如果指定的位置无效

removeHighlight

public void removeHighlight(Object tag)
从视图中移除高亮显示。

参数：
tag - 对高亮显示的引用

removeAllHighlights

public void removeAllHighlights()
移除所有的高亮显示。

changeHighlight

public void changeHighlight(Object tag,
                            int p0,
                            int p1)
                     throws BadLocationException
更改高亮显示。

参数：
tag - 高亮显示标记
p0 - 范围的开始处，该值 >= 0
p1 - 范围的结束处，该值 >= p0
抛出：
BadLocationException - 如果指定的位置无效

getHighlights

public Highlighter.Highlight[] getHighlights()
制作高亮显示的副本。它并不实际复制每个高亮显示区域，只是对它们进行引用。

返回：
副本
另请参见：
Highlighter.getHighlights()

paintLayeredHighlights

public void paintLayeredHighlights(Graphics g,
                                   int p0,
                                   int p1,
                                   Shape viewBounds,
                                   JTextComponent editor,
                                   View view)
当要呈现叶 View （例如，LabelView）时，要调用此方法。如果高亮显示位于给定的区域，则会立即绘制该高亮显示。

指定者：
类 LayeredHighlighter 中的 paintLayeredHighlights
参数：
g - 用于绘制的图形
p0 - 视图的起始偏移量
p1 - 视图的结束偏移量
viewBounds - 视图的边界
editor - JTextComponent
view - 要呈现的视图实例

setDrawsLayeredHighlights

public void setDrawsLayeredHighlights(boolean newValue)
如果为 true，则高亮显示将在视图绘制文本时绘制。即视图将调用 paintLayeredHighlight，结果将导致在绘制文本前绘制矩形（如果偏移量位于高亮显示区域中）。要这样做，所提供的 painter 必须是 LayeredHighlightPainter 的一个实例。

getDrawsLayeredHighlights

public boolean getDrawsLayeredHighlights()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultHighlighter.DefaultHighlightPainter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultHighlighter.DefaultHighlightPainter

java.lang.Object
    继承者  javax.swing.text.LayeredHighlighter.LayerPainter
        继承者  javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
所有已实现的接口：
Highlighter.HighlightPainter
正在封闭类：
DefaultHighlighter
public static class DefaultHighlighter.DefaultHighlightPainter
extends LayeredHighlighter.LayerPainter

只高亮显示用纯色填充高亮显示区域的 painter。

构造方法摘要
DefaultHighlighter.DefaultHighlightPainter(Color c)
构造新的高亮显示 painter。
方法摘要
Color | getColor() 返回高亮显示的颜色。
void | paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c) 绘制高亮显示区域。
Shape | paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultHighlighter.DefaultHighlightPainter

public DefaultHighlighter.DefaultHighlightPainter(Color c)
构造新的高亮显示 painter。如果 c 为 null，则会对 JTextComponent 查询其选定颜色。

参数：
c - 高亮显示所用的颜色
方法详细信息

getColor

public Color getColor()
返回高亮显示的颜色。

返回：
颜色

paint

public void paint(Graphics g,
                  int offs0,
                  int offs1,
                  Shape bounds,
                  JTextComponent c)
绘制高亮显示区域。

参数：
g - 图形上下文
offs0 - 起始模型偏移量，该值 >= 0
offs1 - 结束模型偏移量，该值 >= offs1
bounds - 高亮显示所用的边界框
c - 编辑器

paintLayer

public Shape paintLayer(Graphics g,
                        int offs0,
                        int offs1,
                        Shape bounds,
                        JTextComponent c,
                        View view)
绘制高亮显示的某一部分。

指定者：
类 LayeredHighlighter.LayerPainter 中的 paintLayer
参数：
g - 图形上下文
offs0 - 起始模型偏移量，该值 >= 0
offs1 - 结束模型偏移量，该值 >= offs1
bounds - 视图的边界框，它不一定是要绘制的区域。
c - 编辑器
view - 要绘制的视图
返回：
要在其中绘制的区域
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Keymap (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Keymap

public interface Keymap

将 KeyStroke 绑定到操作的集合。绑定基本上是可能在层次结构中解析的名称值对。

方法摘要
void | addActionForKeyStroke(KeyStroke key, Action a) 向 keymap 添加绑定。
Action | getAction(KeyStroke key) 获取适合于给定符号事件序列的操作。
Action[] | getBoundActions() 获取在此 keymap 中定义的所有操作。
KeyStroke[] | getBoundKeyStrokes() 获取在此映射中绑定到其他操作的所有击键。
Action | getDefaultAction() 当击键（即接收 KEY_TYPED KeyEvent）且该键没有绑定操作的情况下获取激发的默认操作。
KeyStroke[] | getKeyStrokesForAction(Action a) 获取将导致给定操作的击键。
String | getName() 获取键绑定集合的名称。
Keymap | getResolveParent() 获取用于解析键绑定的父级 keymap。
boolean | isLocallyDefined(KeyStroke key) 确定是否本地定义给定的键序列。
void | removeBindings() 从 keymap 移除所有绑定。
void | removeKeyStrokeBinding(KeyStroke keys) 从 keymap 移除绑定。
void | setDefaultAction(Action a) 在进行击键的情况下设置要激发的默认操作。
void | setResolveParent(Keymap parent) 设置将用于解析键绑定的父级 keymap。

方法详细信息

getName

String getName()
获取键绑定集合的名称。

返回：
名称

getDefaultAction

Action getDefaultAction()
当击键（即接收 KEY_TYPED KeyEvent）且该键没有绑定操作的情况下获取激发的默认操作。通常，此操作可能是某个插入文本的操作，所以该 keymap 不需要对每个可能的键进行操作。

返回：
默认操作

setDefaultAction

void setDefaultAction(Action a)
在进行击键的情况下设置要激发的默认操作。

参数：
a - 操作

getAction

Action getAction(KeyStroke key)
获取适合于给定符号事件序列的操作。此操作由 JTextController 使用，以确定如何解释键序列。如果绑定未在本地解析，则会尝试通过父级 keymap 解析（如果设置了父级 keymap）。

参数：
key - 键序列
返回：
如果定义了一个键序列，则返回与该键序列相关的操作，否则返回 null

getBoundKeyStrokes

KeyStroke[] getBoundKeyStrokes()
获取在此映射中绑定到其他操作的所有击键。

返回：
击键列表

getBoundActions

Action[] getBoundActions()
获取在此 keymap 中定义的所有操作。

返回：
操作列表

getKeyStrokesForAction

KeyStroke[] getKeyStrokesForAction(Action a)
获取将导致给定操作的击键。

参数：
a - 操作
返回：
击键列表

isLocallyDefined

boolean isLocallyDefined(KeyStroke key)
确定是否本地定义给定的键序列。

参数：
key - 键序列
返回：
如果本地定义键序列，则返回 true；否则返回 false

addActionForKeyStroke

void addActionForKeyStroke(KeyStroke key,
                           Action a)
向 keymap 添加绑定。

参数：
key - 键序列
a - 操作

removeKeyStrokeBinding

void removeKeyStrokeBinding(KeyStroke keys)
从 keymap 移除绑定。

参数：
keys - 键序列

removeBindings

void removeBindings()
从 keymap 移除所有绑定。

getResolveParent

Keymap getResolveParent()
获取用于解析键绑定的父级 keymap。

返回：
keymap

setResolveParent

void setResolveParent(Keymap parent)
设置将用于解析键绑定的父级 keymap。

参数：
parent - 父级 keymap
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultStyledDocument (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultStyledDocument

java.lang.Object
    继承者  javax.swing.text.AbstractDocument
        继承者  javax.swing.text.DefaultStyledDocument
所有已实现的接口：
Serializable, Document, StyledDocument
直接已知子类：
HTMLDocument
public class DefaultStyledDocument
extends AbstractDocument
implements StyledDocument

能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。此文档的元素结构表示样式在运行时的相互引用。这些样式运行被映射到段落元素结构（也有可能以其他结构形式驻留）。样式运行在段落边界处中断，原因是段落边界被指派了逻辑样式。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Document, AbstractDocument

嵌套类摘要
static class | DefaultStyledDocument.AttributeUndoableEdit 用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。
class | DefaultStyledDocument.ElementBuffer 管理对元素层次结构更改的类。
static class | DefaultStyledDocument.ElementSpec 构建元素的规范。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。
从类 javax.swing.text.AbstractDocument 继承的嵌套类/接口
AbstractDocument.AbstractElement, AbstractDocument.AttributeContext, AbstractDocument.BranchElement, AbstractDocument.Content, AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractDocument.LeafElement
字段摘要
protected DefaultStyledDocument.ElementBuffer | buffer
static int | BUFFER_SIZE_DEFAULT 初始内容缓冲区的默认大小。
从类 javax.swing.text.AbstractDocument 继承的字段
BAD_LOCATION, BidiElementName, ContentElementName, ElementNameAttribute, listenerList, ParagraphElementName, SectionElementName
从接口 javax.swing.text.Document 继承的字段
StreamDescriptionProperty, TitleProperty
构造方法摘要
DefaultStyledDocument()
构造默认的样式化文档。
DefaultStyledDocument(AbstractDocument.Content c, StyleContext styles)
构造样式化文档。
DefaultStyledDocument(StyleContext styles)
构造具有默认的内容存储实现和一组共享样式的样式化文档。
方法摘要
void | addDocumentListener(DocumentListener listener) 添加负责通知任何更改的文档侦听器。
Style | addStyle(String nm, Style parent) 向逻辑样式层次结构中添加新样式。
protected void | create(DefaultStyledDocument.ElementSpec[] data) 初始化文档，以反映给定元素结构（即由 getDefaultRootElement 方法报告的结构）。
protected AbstractDocument.AbstractElement | createDefaultRoot() 创建用于代表默认文档结构的根元素。
Color | getBackground(AttributeSet attr) 从属性集获得背景颜色。
Element | getCharacterElement(int pos) 获得基于某个位置的字符元素。
Element | getDefaultRootElement() 获得默认的根元素。
Font | getFont(AttributeSet attr) 从属性集获得字体。
Color | getForeground(AttributeSet attr) 从属性集获得前景色。
Style | getLogicalStyle(int p) 获取表示给定位置处分配给段落的逻辑样式。
Element | getParagraphElement(int pos) 获得位于偏移量 pos 的段落元素。
Style | getStyle(String nm) 获取以前添加的已命名的样式。
Enumeration<?> | getStyleNames() 获取样式名称列表。
protected void | insert(int offset, DefaultStyledDocument.ElementSpec[] data) 批量插入新元素。
protected void | insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
void | removeDocumentListener(DocumentListener listener) 移除文档侦听器。
void | removeStyle(String nm) 移除以前添加到文档中的已命名样式。
protected void | removeUpdate(AbstractDocument.DefaultDocumentEvent chng) 在文本移除后更新文档结构。
void | setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace) 为文档某些部分设置属性。
void | setLogicalStyle(int pos, Style s) 设置给定位置处用于段落的逻辑样式。
void | setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
protected void | styleChanged(Style style) 此文档样式有任何改变时调用。
从类 javax.swing.text.AbstractDocument 继承的方法
addUndoableEditListener, createBranchElement, createLeafElement, createPosition, dump, fireChangedUpdate, fireInsertUpdate, fireRemoveUpdate, fireUndoableEditUpdate, getAsynchronousLoadPriority, getAttributeContext, getBidiRootElement, getContent, getCurrentWriter, getDocumentFilter, getDocumentListeners, getDocumentProperties, getEndPosition, getLength, getListeners, getProperty, getRootElements, getStartPosition, getText, getText, getUndoableEditListeners, insertString, postRemoveUpdate, putProperty, readLock, readUnlock, remove, removeUndoableEditListener, render, replace, setAsynchronousLoadPriority, setDocumentFilter, setDocumentProperties, writeLock, writeUnlock
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.text.Document 继承的方法
addUndoableEditListener, createPosition, getEndPosition, getLength, getProperty, getRootElements, getStartPosition, getText, getText, insertString, putProperty, remove, removeUndoableEditListener, render

字段详细信息

BUFFER_SIZE_DEFAULT

public static final int BUFFER_SIZE_DEFAULT
初始内容缓冲区的默认大小。

另请参见：
常量字段值

buffer

protected DefaultStyledDocument.ElementBuffer buffer
构造方法详细信息

DefaultStyledDocument

public DefaultStyledDocument(AbstractDocument.Content c,
                             StyleContext styles)
构造样式化文档。

参数：
c - 内容容器
styles - 可跨文档共享的资源和样式定义

DefaultStyledDocument

public DefaultStyledDocument(StyleContext styles)
构造具有默认的内容存储实现和一组共享样式的样式化文档。

参数：
styles - 样式

DefaultStyledDocument

public DefaultStyledDocument()
构造默认的样式化文档。此缓冲区输入内容大小为 BUFFER_SIZE_DEFAULT 并有一个由文档的生命周期确定其范围且不与其他文档共享的样式上下文。

方法详细信息

getDefaultRootElement

public Element getDefaultRootElement()
获得默认的根元素。

指定者：
接口 Document 中的 getDefaultRootElement
指定者：
类 AbstractDocument 中的 getDefaultRootElement
返回：
根
另请参见：
Document.getDefaultRootElement()

create

protected void create(DefaultStyledDocument.ElementSpec[] data)
初始化文档，以反映给定元素结构（即由 getDefaultRootElement 方法报告的结构）。如果该文档包含了任何数据，将首先移除这些数据。

insert

protected void insert(int offset,
                      DefaultStyledDocument.ElementSpec[] data)
               throws BadLocationException
批量插入新元素。这有助于在取消锁定状态下对文档进行解析并为元素结构修改做准备。此方法使用一个描述如何更新元素结构的标记数组，这样在异步更新的情况下写锁定的时间得到显著降低。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
offset - 起始偏移量，该偏移量 >= 0
data - 元素数据
抛出：
BadLocationException - 无效的起始偏移量

addStyle

public Style addStyle(String nm,
                      Style parent)
向逻辑样式层次结构中添加新样式。样式属性自下向上进行解析，所以在子级中指定的属性将重写父级中指定的属性。

指定者：
接口 StyledDocument 中的 addStyle
参数：
nm - 样式的名称（在命名样式集合中必须是惟一的）。如果样式未命名，则此名称可能为 null，但是调用者要负责管理返回的引用，因为未命名的样式不能通过其名称获取。未命名的样式可以用于诸如字符属性重写这样的情况（例如在样式运行中）。
parent - 父样式。如果未指定的属性不需要以其他样式解析，则此值可以为 null。
返回：
样式

removeStyle

public void removeStyle(String nm)
移除以前添加到文档中的已命名样式。

指定者：
接口 StyledDocument 中的 removeStyle
参数：
nm - 要移除的样式的名称

getStyle

public Style getStyle(String nm)
获取以前添加的已命名的样式。

指定者：
接口 StyledDocument 中的 getStyle
参数：
nm - 样式名称
返回：
样式

getStyleNames

public Enumeration<?> getStyleNames()
获取样式名称列表。

返回：
所有样式名称

setLogicalStyle

public void setLogicalStyle(int pos,
                            Style s)
设置给定位置处用于段落的逻辑样式。如果没有为字符和段落属性显式设置属性，则它们将通过分配到段落的逻辑样式进行解析，也就是通过某个层次结构来解析，这些层次结构完全独立于文档中元素的层次结构。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 StyledDocument 中的 setLogicalStyle
参数：
pos - 文档开始处的偏移量，该偏移量 >= 0
s - 要分配给段落的逻辑样式，如果没有，则为 null

getLogicalStyle

public Style getLogicalStyle(int p)
获取表示给定位置处分配给段落的逻辑样式。

指定者：
接口 StyledDocument 中的 getLogicalStyle
参数：
p - 要转换为段落的位置和确定逻辑样式要分配到的位置，该值 >= 0。这是文档开始处的偏移量。
返回：
样式，如果没有，则为 null

setCharacterAttributes

public void setCharacterAttributes(int offset,
                                   int length,
                                   AttributeSet s,
                                   boolean replace)
为文档某些部分设置属性。进行更改的过程中由此操作保持写锁定，并在更改成功完成后向侦听器发送一个 DocumentEvent。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 StyledDocument 中的 setCharacterAttributes
参数：
offset - 文档中的偏移量，该偏移量 >= 0
length - 长度，该长度 >= 0
s - 属性
replace - 如果应在设置新属性之前替换原来的属性，则为 true

setParagraphAttributes

public void setParagraphAttributes(int offset,
                                   int length,
                                   AttributeSet s,
                                   boolean replace)
设置段落属性。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 StyledDocument 中的 setParagraphAttributes
参数：
offset - 段落偏移量，该偏移量 >= 0
length - 所影响的字符数，该字符数 >= 0
s - 属性
replace - 确定是替换现有属性还是合并现有属性

getParagraphElement

public Element getParagraphElement(int pos)
获得位于偏移量 pos 的段落元素。一个段落至少要包含一个子 Element，它通常为叶元素。

指定者：
接口 StyledDocument 中的 getParagraphElement
指定者：
类 AbstractDocument 中的 getParagraphElement
参数：
pos - 起始偏移量，该偏移量 >= 0
返回：
元素

getCharacterElement

public Element getCharacterElement(int pos)
获得基于某个位置的字符元素。

指定者：
接口 StyledDocument 中的 getCharacterElement
参数：
pos - 文档中的位置，该位置 >= 0
返回：
元素

insertUpdate

protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng,
                            AttributeSet attr)
在文本插入后更新文档结构。这在一个写锁定内完成。此实现只解析插入的内容中的换行，然后为元素缓冲区建立一组指令。

覆盖：
类 AbstractDocument 中的 insertUpdate
参数：
chng - 对文档更改的描述
attr - 属性

removeUpdate

protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
在文本移除后更新文档结构。

覆盖：
类 AbstractDocument 中的 removeUpdate
参数：
chng - 对文档更改的描述

createDefaultRoot

protected AbstractDocument.AbstractElement createDefaultRoot()
创建用于代表默认文档结构的根元素。

返回：
基本元素

getForeground

public Color getForeground(AttributeSet attr)
从属性集获得前景色。

指定者：
接口 StyledDocument 中的 getForeground
参数：
attr - 属性集
返回：
颜色

getBackground

public Color getBackground(AttributeSet attr)
从属性集获得背景颜色。

指定者：
接口 StyledDocument 中的 getBackground
参数：
attr - 属性集
返回：
颜色

getFont

public Font getFont(AttributeSet attr)
从属性集获得字体。

指定者：
接口 StyledDocument 中的 getFont
参数：
attr - 属性集
返回：
字体

styleChanged

protected void styleChanged(Style style)
此文档样式有任何改变时调用。子类可能希望对损坏情况进行感知。

参数：
style - 已发生更改的样式。

addDocumentListener

public void addDocumentListener(DocumentListener listener)
添加负责通知任何更改的文档侦听器。

指定者：
接口 Document 中的 addDocumentListener
覆盖：
类 AbstractDocument 中的 addDocumentListener
参数：
listener - 侦听器
另请参见：
Document.addDocumentListener(javax.swing.event.DocumentListener)

removeDocumentListener

public void removeDocumentListener(DocumentListener listener)
移除文档侦听器。

指定者：
接口 Document 中的 removeDocumentListener
覆盖：
类 AbstractDocument 中的 removeDocumentListener
参数：
listener - 侦听器
另请参见：
Document.removeDocumentListener(javax.swing.event.DocumentListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultStyledDocument.AttributeUndoableEdit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultStyledDocument.AttributeUndoableEdit

java.lang.Object
    继承者  javax.swing.undo.AbstractUndoableEdit
        继承者  javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
所有已实现的接口：
Serializable, UndoableEdit
正在封闭类：
DefaultStyledDocument
public static class DefaultStyledDocument.AttributeUndoableEdit
extends AbstractUndoableEdit

用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。

字段摘要
protected AttributeSet | copy
protected Element | element
protected boolean | isReplacing
protected AttributeSet | newAttributes
从类 javax.swing.undo.AbstractUndoableEdit 继承的字段
RedoName, UndoName
构造方法摘要
DefaultStyledDocument.AttributeUndoableEdit(Element element, AttributeSet newAttributes, boolean isReplacing)
方法摘要
void | redo() 重复更改。
void | undo() 撤消更改。
从类 javax.swing.undo.AbstractUndoableEdit 继承的方法
addEdit, canRedo, canUndo, die, getPresentationName, getRedoPresentationName, getUndoPresentationName, isSignificant, replaceEdit, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

newAttributes

protected AttributeSet newAttributes

copy

protected AttributeSet copy

isReplacing

protected boolean isReplacing

element

protected Element element
构造方法详细信息

DefaultStyledDocument.AttributeUndoableEdit

public DefaultStyledDocument.AttributeUndoableEdit(Element element,
                                                   AttributeSet newAttributes,
                                                   boolean isReplacing)
方法详细信息

redo

public void redo()
          throws CannotRedoException
重复更改。

指定者：
接口 UndoableEdit 中的 redo
覆盖：
类 AbstractUndoableEdit 中的 redo
抛出：
CannotRedoException - 如果更改不可重复
另请参见：
AbstractUndoableEdit.canRedo()

undo

public void undo()
          throws CannotUndoException
撤消更改。

指定者：
接口 UndoableEdit 中的 undo
覆盖：
类 AbstractUndoableEdit 中的 undo
抛出：
CannotUndoException - 如果更改不可撤消
另请参见：
AbstractUndoableEdit.canUndo()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultStyledDocument.ElementBuffer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultStyledDocument.ElementBuffer

java.lang.Object
    继承者  javax.swing.text.DefaultStyledDocument.ElementBuffer
所有已实现的接口：
Serializable
正在封闭类：
DefaultStyledDocument
public class DefaultStyledDocument.ElementBuffer
extends Object
implements Serializable

管理对元素层次结构更改的类。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
DefaultStyledDocument.ElementBuffer(Element root)
创建新的 ElementBuffer。
方法摘要
void | change(int offset, int length, AbstractDocument.DefaultDocumentEvent de) 更改内容。
protected void | changeUpdate() 更新元素结构，以响应文档中的更改。
Element | clone(Element parent, Element clonee) 创建此元素的一个副本，使其具有不同的父级。
Element | getRootElement() 获得根元素。
void | insert(int offset, int length, DefaultStyledDocument.ElementSpec[] data, AbstractDocument.DefaultDocumentEvent de) 插入新内容。
protected void | insertUpdate(DefaultStyledDocument.ElementSpec[] data) 向文档添加更新。
void | remove(int offset, int length, AbstractDocument.DefaultDocumentEvent de) 移除内容。
protected void | removeUpdate() 更新元素结构，以响应对文档中关联序列的移除操作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultStyledDocument.ElementBuffer

public DefaultStyledDocument.ElementBuffer(Element root)
创建新的 ElementBuffer。

参数：
root - 根元素
从以下版本开始：
1.4
方法详细信息

getRootElement

public Element getRootElement()
获得根元素。

返回：
根元素

insert

public void insert(int offset,
                   int length,
                   DefaultStyledDocument.ElementSpec[] data,
                   AbstractDocument.DefaultDocumentEvent de)
插入新内容。

参数：
offset - 起始偏移量，该值 >= 0
length - 长度，该值 >= 0
data - 要插入的数据
de - 捕获此编辑的事件

remove

public void remove(int offset,
                   int length,
                   AbstractDocument.DefaultDocumentEvent de)
移除内容。

参数：
offset - 起始偏移量，该值 >= 0
length - 长度，该值 >= 0
de - 捕获此编辑的事件

change

public void change(int offset,
                   int length,
                   AbstractDocument.DefaultDocumentEvent de)
更改内容。

参数：
offset - 起始偏移量，该值 >= 0
length - 长度，该值 >= 0
de - 捕获此编辑的事件

insertUpdate

protected void insertUpdate(DefaultStyledDocument.ElementSpec[] data)
向文档添加更新。

参数：
data - 要插入的元素

removeUpdate

protected void removeUpdate()
更新元素结构，以响应对文档中关联序列的移除操作。移除区域中的任何元素都将被移除。

changeUpdate

protected void changeUpdate()
更新元素结构，以响应文档中的更改。

clone

public Element clone(Element parent,
                     Element clonee)
创建此元素的一个副本，使其具有不同的父级。

参数：
parent - 父元素
clonee - 要复制的元素
返回：
副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultStyledDocument.ElementSpec (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultStyledDocument.ElementSpec

java.lang.Object
    继承者  javax.swing.text.DefaultStyledDocument.ElementSpec
正在封闭类：
DefaultStyledDocument
public static class DefaultStyledDocument.ElementSpec
extends Object

构建元素的规范。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
static short | ContentType getType 的可能值。
static short | EndTagType getType 的可能值。
static short | JoinFractureDirection getDirection 的可能值。
static short | JoinNextDirection getDirection 的可能值。
static short | JoinPreviousDirection getDirection 的可能值。
static short | OriginateDirection getDirection 的可能值。
static short | StartTagType getType 的可能值。
构造方法摘要
DefaultStyledDocument.ElementSpec(AttributeSet a, short type)
当标记不在文档中存储时供标记使用的构造方法。
DefaultStyledDocument.ElementSpec(AttributeSet a, short type, char[] txt, int offs, int len)
用于外部创建规范的构造方法，供批量输入内容和标记到文档中。
DefaultStyledDocument.ElementSpec(AttributeSet a, short type, int len)
供文档内部解析使用的构造方法，在数据已添加但还需要 len 信息时使用。
方法摘要
char[] | getArray() 获得字符数组。
AttributeSet | getAttributes() 获得元素属性。
short | getDirection() 获得方向。
int | getLength() 获得长度。
int | getOffset() 获得起始偏移量。
short | getType() 获得元素类型。
void | setDirection(short direction) 设置方向。
void | setType(short type) 设置元素类型。
String | toString() 将元素转换为字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

StartTagType

public static final short StartTagType
getType 的可能值。它指定此记录类型为开始标记，同时表示指定元素开始的标记。

另请参见：
常量字段值

EndTagType

public static final short EndTagType
getType 的可能值。它指定此记录类型为结束标记，同时表示指定元素结束的标记。

另请参见：
常量字段值

ContentType

public static final short ContentType
getType 的可能值。它指定此记录类型表示内容。

另请参见：
常量字段值

JoinPreviousDirection

public static final short JoinPreviousDirection
getDirection 的可能值。它指定与此记录关联的数据应与位于它之前的元素连接。

另请参见：
常量字段值

JoinNextDirection

public static final short JoinNextDirection
getDirection 的可能值。它指定与此记录关联的数据应与跟随它的元素连接。

另请参见：
常量字段值

OriginateDirection

public static final short OriginateDirection
getDirection 的可能值。它指定与此记录关联的数据应用于生成新元素。这将是正常的值。

另请参见：
常量字段值

JoinFractureDirection

public static final short JoinFractureDirection
getDirection 的可能值。它指定与此记录关联的数据应与离散的元素连接。

另请参见：
常量字段值
构造方法详细信息

DefaultStyledDocument.ElementSpec

public DefaultStyledDocument.ElementSpec(AttributeSet a,
                                         short type)
当标记不在文档中存储时供标记使用的构造方法。

参数：
a - 元素的属性
type - 元素类型（StartTagType、EndTagType 和 ContentType）

DefaultStyledDocument.ElementSpec

public DefaultStyledDocument.ElementSpec(AttributeSet a,
                                         short type,
                                         int len)
供文档内部解析使用的构造方法，在数据已添加但还需要 len 信息时使用。

参数：
a - 元素的属性
type - 元素类型（StartTagType、EndTagType 和 ContentType）
len - 长度，该长度 >= 0

DefaultStyledDocument.ElementSpec

public DefaultStyledDocument.ElementSpec(AttributeSet a,
                                         short type,
                                         char[] txt,
                                         int offs,
                                         int len)
用于外部创建规范的构造方法，供批量输入内容和标记到文档中。

参数：
a - 元素的属性
type - 元素类型（StartTagType、EndTagType 和 ContentType）
txt - 元素的文本
offs - 文本偏移量，该偏移量 >= 0
len - 文本长度，该长度 >= 0
方法详细信息

setType

public void setType(short type)
设置元素类型。

参数：
type - 元素类型（StartTagType、EndTagType 和 ContentType）

getType

public short getType()
获得元素类型。

返回：
元素类型（StartTagType、EndTagType 和 ContentType）

setDirection

public void setDirection(short direction)
设置方向。

参数：
direction - 方向（JoinPreviousDirection、JoinNextDirection）

getDirection

public short getDirection()
获得方向。

返回：
方向（JoinPreviousDirection 和 JoinNextDirection）

getAttributes

public AttributeSet getAttributes()
获得元素属性。

返回：
属性集

getArray

public char[] getArray()
获得字符数组。

返回：
数组

getOffset

public int getOffset()
获得起始偏移量。

返回：
偏移量，该偏移量 >= 0

getLength

public int getLength()
获得长度。

返回：
长度，该长度 >= 0

toString

public String toString()
将元素转换为字符串。

覆盖：
类 Object 中的 toString
返回：
字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultStyledDocument.SectionElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultStyledDocument.SectionElement

java.lang.Object
    继承者  javax.swing.text.AbstractDocument.AbstractElement
        继承者  javax.swing.text.AbstractDocument.BranchElement
            继承者  javax.swing.text.DefaultStyledDocument.SectionElement
所有已实现的接口：
Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
正在封闭类：
DefaultStyledDocument
protected class DefaultStyledDocument.SectionElement
extends AbstractDocument.BranchElement

文档的默认根元素... 与所包含的段落/行对应。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
DefaultStyledDocument.SectionElement()
创建新 SectionElement。
方法摘要
 String getName()
获得元素的名称。
从类 javax.swing.text.AbstractDocument.BranchElement 继承的方法
children, getAllowsChildren, getElement, getElementCount, getElementIndex, getEndOffset, getStartOffset, isLeaf, positionToElement, replace, toString
从类 javax.swing.text.AbstractDocument.AbstractElement 继承的方法
addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, getResolveParent, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DefaultStyledDocument.SectionElement

public DefaultStyledDocument.SectionElement()
创建新 SectionElement。

方法详细信息

getName

public String getName()
获得元素的名称。

指定者：
接口 Element 中的 getName
覆盖：
类 AbstractDocument.BranchElement 中的 getName
返回：
名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTextUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DefaultTextUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
                继承者  javax.swing.text.DefaultTextUI
所有已实现的接口：
ViewFactory
已过时。

@Deprecated
public abstract class DefaultTextUI
extends BasicTextUI

该类已过时，不应再使用。可在 javax.swing.plaf.basic 包中找到各种基本的 TextUI 实现，而 BasicTextUI 类取代了此类。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的嵌套类/接口
BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter
构造方法摘要
DefaultTextUI()
已过时。
方法摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的方法
create, create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getPropertyPrefix, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, propertyChange, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultTextUI

public DefaultTextUI()
已过时。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Document (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Document

所有已知子接口：
StyledDocument
所有已知实现类：
AbstractDocument, DefaultStyledDocument, HTMLDocument, PlainDocument
public interface Document

Document 是一个作为 swing 文本组件模型的文本容器。此接口的目标是为了满足不同的文档处理需要，从非常简单的文档（纯文本 textfield）到非常复杂的文档（例如，HTML 或 XML 文档）。

内容

在最简单的级别，文本可用一个线性的字符序列模型表示。为支持国际化，Swing 文本模型使用 unicode 字符。显示在文本组件中的字符序列一般称为组件的内容。

要引用序列中的位置，使用的是两个字符之间的坐标。如下图所示，文本文档中位置可称为一个位置或一个偏移量。位置是从零开始的。

此例中，如前图所示，如果文档的内容为序列 "The quick brown fox" ，"The" 之前的位置为 0，位于 "The" 之后、它后面的空白之前的位置为 3。序列 "The" 中的整个字符序列称为一个范围。

下列方法提供对组成内容的字符数据的访问。

  • getLength()
  • getText(int, int)
  • getText(int, int, Segment)

结构

只将文本表示为一般的内容并不常见。更多的情况下，文本都通常具有与其关联的某种结构。具体构造成哪种结构取决于特定的 Document 实现。它可以简单到没有结构（即简单的文本字段），也可以是类似下面的图。

结构单位（即树的节点）由 Element 接口引用。每个 Element 都可用一组属性标记。这些属性（名称/值对）由 AttributeSet 接口定义。

下面的方法提供对文档结构的访问。

  • getDefaultRootElement
  • getRootElements

可变

所有的文档都需要能够添加和移除简单的文本。通常，通过键盘或鼠标动作添加和移除文本。插入和移除对文档结构有何影响完全取决于文档的实现。

下列方法与文档内容的变化相关：

  • insertString(int, String, AttributeSet)
  • remove(int, int)
  • createPosition(int)

通知

Document 的改变必须传送给相关的观察者。更改通知遵守为 JavaBeans 指定的事件模型大纲。在 JavaBeans 事件模型中，一旦指派了一个事件通知，必须在事件源发生进一步的更改之前通知所有的侦听器。此外，无法保证传送的顺序。

通知以两个独立的事件提供，DocumentEvent 和 UndoableEditEvent。如果通过 Document 的 api 对其进行改变，将对所有注册的 DocumentListeners 发送一个 DocumentEvent。如果 Document 实现支持撤消/重复功能，UndoableEditEvent 将发送到所有注册的 UndoableEditListener 上。如果对可撤消的编辑进行撤消，应从 Document 触发 DocumentEvent 以指示又进行了更改。但是这种情况下不应生成任何 UndoableEditEvent，因为编辑实际上是更改的源，而不是通过其 api 对 Document 进行的改变。

上图中假设左面显示的组件改变了蓝色矩形表示的文本对象。文档通过对两个组件视图指派 DocumentEvent 进行响应，并向侦听逻辑发送 UndoableEditEvent，以保留历史缓冲区。

现在假定右面显示的组件改变相同的文档。同样，文档对两个组件视图指派 DocumentEvent 并对保留历史缓冲区的侦听逻辑发送 UndoableEditEvent。

如果历史缓冲区因此回滚（即撤消上一个 UndoableEdit），将对两个视图发送 DocumentEvent，导致二者都反映出对文档的撤消改动（即移除右面的组件的改动）。如果历史缓冲区再次回滚另一个更改，将对两个视图发送另外的 DocumentEvent，导致它们反映出对文档的撤消改动，即移除左面的组件的改动。

与观察文档的改动相关的方法有：

  • addDocumentListener(DocumentListener)
  • removeDocumentListener(DocumentListener)
  • addUndoableEditListener(UndoableEditListener)
  • removeUndoableEditListener(UndoableEditListener)

属性

文档实现通常具有在运行时与之关联的某组属性。两个最常见的属性是 StreamDescriptionProperty 和 TitleProperty，前者可描述 Document 的来源，后者可用于命名 Document。与这些属性相关的方法有：

  • getProperty(Object)
  • putProperty(Object, Object)

有关 Document 类的更多信息，请参阅 The Swing Connection 以及更有针对性的文章 The Element Interface。

另请参见：
DocumentEvent, DocumentListener, UndoableEditEvent, UndoableEditListener, Element, Position, AttributeSet

字段摘要
static String | StreamDescriptionProperty 用于描述初始化文档的流的属性名。
static String | TitleProperty 文档标题的属性名（如果有）。
方法摘要
void | addDocumentListener(DocumentListener listener) 注册给定的观察者以便开始接收文档发生更改的通知。
void | addUndoableEditListener(UndoableEditListener listener) 注册给定的观察者以便开始接收文档发生不可撤消的编辑的通知。
Position | createPosition(int offs) 此方法允许应用程序在字符内容序列中标记位置。
Element | getDefaultRootElement() 返回视图赖以存在的根元素，除非提供了向元素结构指定视图的其他机制。
Position | getEndPosition() 返回代表文档结束处的位置。
int | getLength() 返回文档中当前内容的字符数。
Object | getProperty(Object key) 获得与文档关联的属性。
Element[] | getRootElements() 返回定义的所有根元素。
Position | getStartPosition() 返回代表文档起始处的位置。
String | getText(int offset, int length) 获取文档中给定部分包含的文本。
void | getText(int offset, int length, Segment txt) 获取文档中给定部分包含的文本。
void | insertString(int offset, String str, AttributeSet a) 插入内容字符串。
void | putProperty(Object key, Object value) 将属性与文档关联。
void | remove(int offs, int len) 移除文档的部分内容。
void | removeDocumentListener(DocumentListener listener) 将给定的观察者从通知列表中撤消注册，这样就不再接收改动更新。
void | removeUndoableEditListener(UndoableEditListener listener) 将给定的观察者从通知列表中撤消注册，这样就不再接收更新。
void | render(Runnable r) 如果模型支持异步更新，则允许在并发情况下安全呈现模型。

字段详细信息

StreamDescriptionProperty

static final String StreamDescriptionProperty
用于描述初始化文档的流的属性名。如果文档从流初始化并且有来自该流的信息，则应使用此属性。

另请参见：
常量字段值

TitleProperty

static final String TitleProperty
文档标题的属性名（如果有）。

另请参见：
常量字段值
方法详细信息

getLength

int getLength()
返回文档中当前内容的字符数。

返回：
字符的数量，该数量 >= 0

addDocumentListener

void addDocumentListener(DocumentListener listener)
注册给定的观察者以便开始接收文档发生更改的通知。

参数：
listener - 要注册的观察者
另请参见：
removeDocumentListener(javax.swing.event.DocumentListener)

removeDocumentListener

void removeDocumentListener(DocumentListener listener)
将给定的观察者从通知列表中撤消注册，这样就不再接收改动更新。

参数：
listener - 要注册的观察者
另请参见：
addDocumentListener(javax.swing.event.DocumentListener)

addUndoableEditListener

void addUndoableEditListener(UndoableEditListener listener)
注册给定的观察者以便开始接收文档发生不可撤消的编辑的通知。

参数：
listener - 要注册的观察者
另请参见：
UndoableEditEvent

removeUndoableEditListener

void removeUndoableEditListener(UndoableEditListener listener)
将给定的观察者从通知列表中撤消注册，这样就不再接收更新。

参数：
listener - 要注册的观察者
另请参见：
UndoableEditEvent

getProperty

Object getProperty(Object key)
获得与文档关联的属性。

参数：
key - 非 null 属性键
返回：
属性
另请参见：
putProperty(Object, Object)

putProperty

void putProperty(Object key,
                 Object value)
将属性与文档关联。提供两个标准属性键：StreamDescriptionProperty 和 TitleProperty。也可以定义其他属性，如 author。

参数：
key - 非 null 属性键
value - 属性值
另请参见：
getProperty(Object)

remove

void remove(int offs,
            int len)
            throws BadLocationException
移除文档的部分内容。这将导致对注册的 DocumentListener 发送类型为 DocumentEvent.EventType.REMOVE 的 DocumentEvent，除非抛出异常。通过在 DocumentListener 上调用 removeUpdate 方法，通知被发送到侦听器。

为确保并发情况下的合理行为，事件在改动发生之后指派。这意味着在指派移除通知之前，文档已经更新并且由 createPosition 创建的任何标记已更改。对于移除的情况，移除范围的结束折叠至范围的开始，移除范围内的任何标记都折叠至范围的开始。

图示从 'The quick brown fox' 中移除 'quick'。

如果移除导致 Document 结构更改，生成的 DocumentEvent 中还将包含更改所涉及的插入和移除 Element 的细节。移除对结构造成的更改则具体取决于 Document 的实现。

如果 Document 支持撤消/重复，还将生成 UndoableEditEvent。

参数：
offs - 起始位置的偏移量，该值 >= 0
len - 要移除的字符数，该值 >= 0
抛出：
BadLocationException - 移除范围的有些部分不是文档的有效部分。异常中的位置为遇到的第一个损坏位置。
另请参见：
DocumentEvent, DocumentListener, UndoableEditEvent, UndoableEditListener

insertString

void insertString(int offset,
                  String str,
                  AttributeSet a)
                  throws BadLocationException
插入内容字符串。这将导致对注册的 DocumentListener 发送类型为 DocumentEvent.EventType.INSERT 的 DocumentEvent，除非抛出异常。通过在 DocumentListener 上调用 insertUpdate 方法传送 DocumentEvent。生成的 DocumentEvent 的偏移量和长度将指示对 Document 实际进行的更改。

图示将 'quick' 插入 'The quick brown fox'

如果插入导致 Document 结构更改，有关更改涉及的插入和移除的 Element 的细节将包含在生成的 DocumentEvent 中。作为对插入的响应，由 Document 的实现决定结构应如何更改。

如果 Document 支持撤消/重复，还将生成 UndoableEditEvent。

参数：
offset - 要插入内容的偏移量，该值 >= 0。跟踪给定的位置或其后位置的更改的所有位置都将移动。
str - 要插入的字符串
a - 要与插入的内容关联的属性。如果没有属性，它可能为 null。
抛出：
BadLocationException - 给定插入位置不是文档中的有效位置
另请参见：
DocumentEvent, DocumentListener, UndoableEditEvent, UndoableEditListener

getText

String getText(int offset,
               int length)
               throws BadLocationException
获取文档中给定部分包含的文本。

参数：
offset - 文档中代表所需文本起始位置的偏移量，该值 >= 0
length - 需要的字符串的长度，该值 >= 0
返回：
以长度 >= 0 的字符串形式返回文本。
抛出：
BadLocationException - 给定范围的某些部分不是文档中的有效部分。异常中的位置为遇到的第一个损坏位置。

getText

void getText(int offset,
             int length,
             Segment txt)
             throws BadLocationException
获取文档中给定部分包含的文本。

如果 txt 参数的 partialReturn 属性为 false，Segment 中返回的数据将是请求的整个长度，根据数据存储的方式可能是副本，也可能不是。如果 partialReturn 属性为 true，则只返回不需要创建副本即能返回的文本量。使用部分返回在需要扫描大部分文档的情况下具有更好的效果。下面是使用部分返回访问整个文档的示例：

   int nleft = doc.getDocumentLength();
   Segment text = new Segment();
   int offs = 0;
   text.setPartialReturn(true);
   while (nleft > 0) {
       doc.getText(offs, nleft, text);
       // do someting with text
       nleft -= text.count;
       offs += text.count;
   }

参数：
offset - 文档中代表所需文本起始位置的偏移量，该值 >= 0
length - 需要的字符串的长度，该值 >= 0
txt - 要在其中返回文本的 Segment 对象
抛出：
BadLocationException - 给定范围的某些部分不是文档中的有效部分。异常中的位置为遇到的第一个损坏位置。

getStartPosition

Position getStartPosition()
返回代表文档起始处的位置。可对返回的位置进行计数以便跟踪更改，也可以让其保留在文档起始位置。

返回：
位置

getEndPosition

Position getEndPosition()
返回代表文档结束处的位置。可对返回的位置进行计数以便跟踪更改，也可以让其保留在文档结束位置。

返回：
位置

createPosition

Position createPosition(int offs)
                        throws BadLocationException
此方法允许应用程序在字符内容序列中标记位置。然后可使用此标记对在内容中的插入和移除的更改进行跟踪。总的策略是，总在当前位置之前插入（最常见的情况），除非插入位置为零，这种情况下强制插入到原点位置之后。

参数：
offs - 文档起始处的偏移量，该值 >= 0
返回：
位置
抛出：
BadLocationException - 如果给定的位置不代表关联文档中的有效位置

getRootElements

Element[] getRootElements()
返回定义的所有根元素。

通常只有一个文档结构，但是此接口支持在文本数据上构建任意数的结构投影。文档可以有多个根元素以支持多文档结构。一些示例如下：

  • 文本方向。
  • 词法解析标记流。
  • 解析树。
  • 转换为本机格式以外的格式。
  • 修改规范。
  • 注释。

返回：
根元素

getDefaultRootElement

Element getDefaultRootElement()
返回视图赖以存在的根元素，除非提供了向元素结构指定视图的其他机制。

返回：
根元素

render

void render(Runnable r)
如果模型支持异步更新，则允许在并发情况下安全呈现模型。给定的可运行程序的执行方式是，在可运行程序执行时安全读取模型且不作任何更改。可运行程序本身不 作任何改变。

参数：
r - 用于呈现模型的 Runnable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentFilter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DocumentFilter

java.lang.Object
    继承者  javax.swing.text.DocumentFilter

public class DocumentFilter
extends Object

DocumentFilter，顾名思义，它是 Document 改变方法的一个过滤器。修改包含 DocumentFilter 的 Document 时（通过 insert 或 remove），它将适当的方法调用转发给 DocumentFilter。该默认实现允许进行修改。通过有条件地调用超类方法，或在传入的 FilterBypass 上调用必要的方法，子类可以过滤修改。子类不应回调 Document 进行修改，而应调用超类或 FilterBypass。

在 DocumentFilter 上调用 remove 或 insertString 时，DocumentFilter 可能多次回调 FilterBypass，或针对不同的区域，但它不应在从 remove 或 insertString 方法返回后回调 FilterBypass。

从以下版本开始：
1.4
另请参见：
Document

嵌套类摘要
static class DocumentFilter.FilterBypass
充当避开回调 Document 进行更改的方法。
构造方法摘要
DocumentFilter()
方法摘要
void | insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr) 将文本插入指定的 Document 之前调用。
void | remove(DocumentFilter.FilterBypass fb, int offset, int length) 移除指定 Document 中的指定区域之前调用。
void | replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs) 在替换指定的 Document 中的文本区域之前调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentFilter

public DocumentFilter()
方法详细信息

remove

public void remove(DocumentFilter.FilterBypass fb,
                   int offset,
                   int length)
            throws BadLocationException
移除指定 Document 中的指定区域之前调用。希望有条件地允许移除的子类应重写此方法，并只在必要的时候调用超类实现，或者根据需要直接调用 FilterBypass。

参数：
fb - 可用于改动 Document 的 FilterBypass
offset - 起始位置处的偏移量，该值 >= 0
length - 要移除的字符数，该值 >= 0
抛出：
BadLocationException - 移除范围的有些部分不是文档的有效部分。异常中的位置为遇到的第一个损坏位置。

insertString

public void insertString(DocumentFilter.FilterBypass fb,
                         int offset,
                         String string,
                         AttributeSet attr)
                  throws BadLocationException
将文本插入指定的 Document 之前调用。希望有条件地允许插入的子类应重写此方法，并只在必要的时候调用超类实现，或者直接调用 FilterBypass。

参数：
fb - 可用于改动 Document 的 FilterBypass
offset - 要插入内容的偏移量，该值 >= 0。跟踪给定的位置或其后位置的更改的所有位置都将移动。
string - 要插入的字符串
attr - 要与插入的内容关联的属性。如果没有属性，它可能为 null。
抛出：
BadLocationException - 给定的插入位置不是文档中的有效位置

replace

public void replace(DocumentFilter.FilterBypass fb,
                    int offset,
                    int length,
                    String text,
                    AttributeSet attrs)
             throws BadLocationException
在替换指定的 Document 中的文本区域之前调用。希望有条件地允许替换的子类应重写此方法，并只在必要的时候调用超类实现，或者直接调用 FilterBypass。

参数：
fb - 可用于改动 Document 的 FilterBypass
offset - Document 中的 Location
length - 要删除的文本的长度
text - 要插入的文本，null 指示没有要插入的文本
attrs - 指示插入的文本的属性的 AttributeSet，null 也为合法。
抛出：
BadLocationException - 给定的插入位置不是文档中的有效位置
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentFilter.FilterBypass (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 DocumentFilter.FilterBypass

java.lang.Object
    继承者  javax.swing.text.DocumentFilter.FilterBypass
正在封闭类：
DocumentFilter
public abstract static class DocumentFilter.FilterBypass
extends Object

充当避开回调 Document 进行更改的方法。希望支持 DocumentFilter 的 Document 实现必须提供一种实现，以便在从 DocumentFilter 调用下列方法时不回调 DocumentFilter。

从以下版本开始：
1.4

构造方法摘要
DocumentFilter.FilterBypass()
方法摘要
abstract Document | getDocument() 返回发生变化的 Document。
abstract void | insertString(int offset, String string, AttributeSet attr) 插入指定的文本，绕过 DocumentFilter。
abstract void | remove(int offset, int length) 移除指定的文本区域，绕过 DocumentFilter。
abstract void | replace(int offset, int length, String string, AttributeSet attrs) 删除从 offset 到 offset + length 的文本区域，并用 text 替换。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentFilter.FilterBypass

public DocumentFilter.FilterBypass()
方法详细信息

getDocument

public abstract Document getDocument()
返回发生变化的 Document。

返回：
Document 移除/插入 String 操作将在其中执行的文档

remove

public abstract void remove(int offset,
                            int length)
                     throws BadLocationException
移除指定的文本区域，绕过 DocumentFilter。

参数：
offset - 起始位置的偏移量，该值 >= 0
length - 要移除的字符数，该值 >= 0
抛出：
BadLocationException - 移除范围的某些部分不是文档的有效部分。异常中的位置为遇到的第一个损坏位置。

insertString

public abstract void insertString(int offset,
                                  String string,
                                  AttributeSet attr)
                           throws BadLocationException
插入指定的文本，绕过 DocumentFilter。

参数：
offset - 文档中要插入内容处的偏移量，该值 >= 0。跟踪给定的位置或其后位置的更改的所有位置都将移动。
string - 要插入的字符串
attr - 与要插入的内容关联的属性。如果没有属性，则它可能为 null。
抛出：
BadLocationException - 给定的插入位置不是文档中的有效位置

replace

public abstract void replace(int offset,
                             int length,
                             String string,
                             AttributeSet attrs)
                      throws BadLocationException
删除从 offset 到 offset + length 的文本区域，并用 text 替换。

参数：
offset - Document 中的位置
length - 要删除的文本长度
string - 要插入的文本，null 指示没有要插入的文本
attrs - 指示插入文本属性的 AttributeSet，null 也合法。
抛出：
BadLocationException - 给定的插入位置不是文档中的有效位置
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EditorKit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 EditorKit

java.lang.Object
    继承者  javax.swing.text.EditorKit
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
DefaultEditorKit
public abstract class EditorKit
extends Object
implements Cloneable, Serializable

针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。EditorKit 充当某个策略类型的工厂。例如，可以提供 html 和 rtf 的实现，它可与其他实现互换。

工具包可安全存储编辑状态，因为工具包的实例专供文本组件使用。新的工具包通常通过复制原型工具包创建。工具包会调用其 setComponent 方法来建立与 JTextComponent 的联系。

构造方法摘要
EditorKit()
构造一个 EditorKit。
方法摘要
Object | clone() 创建此编辑器工具包的副本。
abstract Caret | createCaret() 获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
abstract Document | createDefaultDocument() 创建一个适合此编辑器类型的未初始化的文本存储模型。
void | deinstall(JEditorPane c) 从 JEditorPane 中移除工具包时调用。
abstract Action[] | getActions() 获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
abstract String | getContentType() 获得此工具包声明支持的数据的 MIME 类型。
abstract ViewFactory | getViewFactory() 获取适合生成此工具包生成的任何模型视图的工厂。
void | install(JEditorPane c) 将工具包安装到 JEditorPane 中时调用。
abstract void | read(InputStream in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract void | read(Reader in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract void | write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract void | write(Writer out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EditorKit

public EditorKit()
构造一个 EditorKit。

方法详细信息

clone

public Object clone()
创建此编辑器工具包的副本。实现它可使用 Object.clone。如果无法复制工具包，则返回 null。

覆盖：
类 Object 中的 clone
返回：
副本
另请参见：
Cloneable

install

public void install(JEditorPane c)
将工具包安装到 JEditorPane 中时调用。

参数：
c - JEditorPane

deinstall

public void deinstall(JEditorPane c)
从 JEditorPane 中移除工具包时调用。这可用于取消对任何所关联侦听器的注册。

参数：
c - JEditorPane

getContentType

public abstract String getContentType()
获得此工具包声明支持的数据的 MIME 类型。

返回：
类型

getViewFactory

public abstract ViewFactory getViewFactory()
获取适合生成此工具包生成的任何模型视图的工厂。

返回：
工厂

getActions

public abstract Action[] getActions()
获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。

返回：
动作组

createCaret

public abstract Caret createCaret()
获取能在由关联的 ViewFactory 生成的视图中导航的插入符。

返回：
插入符

createDefaultDocument

public abstract Document createDefaultDocument()
创建一个适合此编辑器类型的未初始化的文本存储模型。

返回：
模型

read

public abstract void read(InputStream in,
                          Document doc,
                          int pos)
                   throws IOException,
                          BadLocationException
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。

参数：
in - 要读入的流
doc - 插入到的目标文档。
pos - 文档中放入内容的位置，该值 >= 0。
抛出：
IOException - 如果有任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置。

write

public abstract void write(OutputStream out,
                           Document doc,
                           int pos,
                           int len)
                    throws IOException,
                           BadLocationException
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

参数：
out - 要写入的流
doc - 写入所用的源文档。
pos - 文档中获取内容的位置，该值 >= 0。
len - 要写入的量，该值 >= 0。
抛出：
IOException - 如果有任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置。

read

public abstract void read(Reader in,
                          Document doc,
                          int pos)
                   throws IOException,
                          BadLocationException
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。

由于实际的编辑是基于 unicode 的，这将是读入数据的首选方法。但是有些类型的内容以 8 位形式存储，因此又适合 InputStream。

参数：
in - 要读入的流
doc - 插入到的目标文档。
pos - 文档中放入内容的位置，该值 >= 0。
抛出：
IOException - 如果有任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置。

write

public abstract void write(Writer out,
                           Document doc,
                           int pos,
                           int len)
                    throws IOException,
                           BadLocationException
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

由于实际的编辑是基于 unicode 的，这将是写入数据的首选方法。但是有些类型的内容以 8 位形式存储，因此又适合 OutputStream。

参数：
out - 要写入的流
doc - 写入所用的源文档。
pos - 文档中获取内容的位置，该值 >= 0。
len - 要写出的量，该值 >= 0。
抛出：
IOException - 如果有任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Element (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Element

所有已知实现类：
AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement
public interface Element

描述文档的结构元素的接口。主要是为了体现 SGML 元素的精髓。

方法摘要
AttributeSet | getAttributes() 获取此元素包含的属性集合。
Document | getDocument() 获取与此元素关联的文档。
Element | getElement(int index) 获取给定索引处的子元素。
int | getElementCount() 获得此元素包含的子元素数。
int | getElementIndex(int offset) 获得离给定偏移量最近的子元素索引。
int | getEndOffset() 获取此元素结束处的文档起始偏移量。
String | getName() 获取元素的名称。
Element | getParentElement() 获得父元素。
int | getStartOffset() 获取此元素开始处的文档起始偏移量。
boolean | isLeaf() 确定此元素是否为叶元素。

方法详细信息

getDocument

Document getDocument()
获取与此元素关联的文档。

返回：
文档

getParentElement

Element getParentElement()
获得父元素。如果该元素为根元素，则返回 null。

返回：
父元素

getName

String getName()
获取元素的名称。如果该元素用于表示某些类型的结构，这将是类型名。

返回：
元素名称

getAttributes

AttributeSet getAttributes()
获取此元素包含的属性集合。

返回：
元素的属性

getStartOffset

int getStartOffset()
获取此元素开始处的文档起始偏移量。如果此元素有子级，这将是其第一个子级的偏移量。至于文档位置，则可能存在向前的偏差。

返回：
起始偏移量，该值 >= 0 且 < getEndOffset()；
另请参见：
Document, AbstractDocument

getEndOffset

int getEndOffset()
获取此元素结束处的文档起始偏移量。如果此元素有子级，这将是其最后一个子级的结束偏移量。至于文档位置，则可能存在向后的偏差。

所有默认的 Document 实现都继承自 AbstractDocument。AbstractDocument 在文档的结束处模仿了一个暗含的中断。因此，它有可能返回一个大于文档长度的值。

返回：
结束偏移量，该值 > getStartOffset() 且 <= getDocument().getLength() + 1
另请参见：
Document, AbstractDocument

getElementIndex

int getElementIndex(int offset)
获得离给定偏移量最近的子元素索引。偏移量的指定是相对于文档起始处的。如果 Element 是叶元素，则返回 -1；否则返回最能代表给定位置的 Element 索引。如果位置小于起始偏移量，则返回 0。如果位置大于或等于结束偏移量，则返回 getElementCount() - 1。

参数：
offset - 指定的偏移量，该值 >= 0
返回：
元素索引，该值 >= 0

getElementCount

int getElementCount()
获得此元素包含的子元素数。如果此元素是叶元素，则返回零。

返回：
子元素数，该值 >= 0

getElement

Element getElement(int index)
获取给定索引处的子元素。

参数：
index - 指定的索引，该值 >= 0
返回：
子元素

isLeaf

boolean isLeaf()
确定此元素是否为叶元素。可能 有子级的元素（即便现在还没有子级）将返回 false。

返回：
如果为叶元素，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ElementIterator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 ElementIterator

java.lang.Object
    继承者  javax.swing.text.ElementIterator
所有已实现的接口：
Cloneable
public class ElementIterator
extends Object
implements Cloneable

ElementIterator，顾名思义，沿 Element 树进行迭代。可使用 Document 或 Element 参数调用此构造方法。如果以 Document 为参数调用此构造方法，那么迭代的根为 document.getDefaultRootElement() 的返回值。

迭代以深度优先 (depth-first) 的方式进行。至于如何处理边界条件：a) 如果 next() 在 first() 或 current() 之前调用，将返回根。b) next() 返回 null 指示列表的末尾。c) 如果当前元素为根或 next() 已经返回 null 时，previous() 返回 null。

ElementIterator 并不锁定 Element 树。这意味着它不跟踪任何更改。由此类的用户负责确保元素迭代期间不出现更改。

简单用法示例：

    public void iterate() {
        ElementIterator it = new ElementIterator(root);
          Element elem;
          while (true) {
           if ((elem = next()) != null) {
                 // process element
                 System.out.println("elem: " + elem.getName());
             } else {
                 break;
             }
          }
    }

构造方法摘要
ElementIterator(Document document)
创建新的 ElementIterator。
ElementIterator(Element root)
创建新的 ElementIterator。
方法摘要
Object | clone() 复制 ElementIterator。
Element | current() 获取当前 Element。
int | depth() 获取元素树的当前深度。
Element | first() 获取第一个元素。
Element | next() 获取下一个 Element。
Element | previous() 获取前一个 Element。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ElementIterator

public ElementIterator(Document document)
创建新的 ElementIterator。根元素用于获得文档的默认根元素。

参数：
document - Document。

ElementIterator

public ElementIterator(Element root)
创建新的 ElementIterator。

参数：
root - 根 Element。
方法详细信息

clone

public Object clone()
复制 ElementIterator。

覆盖：
类 Object 中的 clone
返回：
复制的 ElementIterator 对象。
另请参见：
Cloneable

first

public Element first()
获取第一个元素。

返回：
Element。

depth

public int depth()
获取元素树的当前深度。

返回：
深度。

current

public Element current()
获取当前 Element。

返回：
位于堆栈顶部的元素，如果根元素为 null 则返回 null

next

public Element next()
获取下一个 Element。定位下一个元素的策略是深度优先搜索。

返回：
下一个元素，如果位于列表末尾，则返回 null。

previous

public Element previous()
获取前一个 Element。但是如果当前元素为最后一个元素，或者当前元素为 null，则返回 null。

返回：
前一个 Element（如果有）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 FieldView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.PlainView
            继承者  javax.swing.text.FieldView
所有已实现的接口：
SwingConstants, TabExpander
直接已知子类：
PasswordView
public class FieldView
extends PlainView

扩展多行纯文本视图，使其适合单行编辑器视图。如果为视图分配了额外的空间，则该字段必须调整视图，使之适合该空间。如果承载组件是 JTextField，此视图将管理相关 BoundedRangeModel 的范围并调整水平分配区域以便与 JTextField 的当前可见性设置相匹配。

另请参见：
View

字段摘要
从类 javax.swing.text.PlainView 继承的字段
metrics
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
FieldView(Element elem)
构造包装了元素的新 FieldView。
方法摘要
protected Shape | adjustAllocation(Shape a) 调整给定视图的分配区域，使其适合文本字段的分配区域。
protected FontMetrics | getFontMetrics() 获取与承载此视图组件相关的字体规格。
float | getPreferredSpan(int axis) 确定此视图沿某轴的首选区域。
int | getResizeWeight(int axis) 确定视图沿给定轴的大小可调整性。
void | insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
void | removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
int | viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
从类 javax.swing.text.PlainView 继承的方法
changedUpdate, damageLineRange, drawLine, drawSelectedText, drawUnselectedText, getLineBuffer, getTabSize, lineToRect, nextTabStop, setSize, updateDamage, updateMetrics
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FieldView

public FieldView(Element elem)
构造包装了元素的新 FieldView。

参数：
elem - 所需元素
方法详细信息

getFontMetrics

protected FontMetrics getFontMetrics()
获取与承载此视图组件相关的字体规格。

返回：
字体规格

adjustAllocation

protected Shape adjustAllocation(Shape a)
调整给定视图的分配区域，使其适合文本字段的分配区域。如果在垂直方向上分配该视图的区域超过了首选区域，则会更改该分配区域以便垂直居中。根据相关 JTextField 上的水平对齐属性设置，该视图将在水平方向上进行调整（如果其为承载组件的类型）。

参数：
a - 指定给视图的分配区域，该分配区域可能需要调整大小。
返回：
超类应该使用的分配区域。

paint

public void paint(Graphics g,
                  Shape a)
使用给定呈现面和该表面的区域呈现。该视图可能需要进行布置和创建子视图，以使它本身能够在给定的分配区域呈现。

覆盖：
类 PlainView 中的 paint
参数：
g - 要使用的呈现表面
a - 要在其中呈现的分配区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某轴的首选区域。

覆盖：
类 PlainView 中的 getPreferredSpan
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，该值 >= 0。通常会告知该视图在返回的区域中呈现，但不保证一定如此。父级可选择重新调整视图大小或拆分视图。
另请参见：
View.getPreferredSpan(int)

getResizeWeight

public int getResizeWeight(int axis)
确定视图沿给定轴的大小可调整性。0 或更小的值表示大小不可调整。

覆盖：
类 View 中的 getResizeWeight
参数：
axis - View.X_AXIS 或 View.Y_AXIS
返回：
权重，如果 > 1，表示为 View.X_AXIS，如果为 0，表示 View.Y_AXIS

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

覆盖：
类 PlainView 中的 modelToView
参数：
pos - 要转换的位置，其值 >= 0
a - 分配的要在其中呈现的区域
b - 当位置是两个视图的边界时，该参数是离由偏移量表示的前一个字符或者下一个字符的偏差；b 将是这些值之一：
  • Position.Bias.Forward
  • Position.Bias.Backward
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置在所关联的文档中不是一个有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public int viewToModel(float fx,
                       float fy,
                       Shape a,
                       Position.Bias[] bias)
提供从视图坐标空间到该模型的逻辑坐标空间的映射。

覆盖：
类 PlainView 中的 viewToModel
参数：
fx - X 坐标，该值 >= 0.0f
fy - Y 坐标，该值 >= 0.0f
a - 要在其中呈现的分配区域
返回：
模型中最能代表视图中给定点的位置
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

insertUpdate

public void insertUpdate(DocumentEvent changes,
                         Shape a,
                         ViewFactory f)
通知在文档中此视图负责的某个位置已插入内容。

覆盖：
类 PlainView 中的 insertUpdate
参数：
changes - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(DocumentEvent changes,
                         Shape a,
                         ViewFactory f)
通知在文档中此视图负责的某个位置已插入内容。

覆盖：
类 PlainView 中的 removeUpdate
参数：
changes - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 FlowView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.FlowView
所有已实现的接口：
SwingConstants
直接已知子类：
ParagraphView
public abstract class FlowView
extends BoxView

试图将其子级流入某个部分受约束的空间的视图。此视图可用于构建段落、页面等。该流由以下几项功能组成。

  • 子视图的逻辑集合，该集合用作组成物理视图的布局池。
  • 将逻辑视图转换为物理（流动）视图的策略。
  • 要依靠其工作的策略约束。
  • 表示流的物理结构。此视图的子级位于为创建流而放置逻辑视图的片段的位置。

从以下版本开始：
1.3
另请参见：
View

嵌套类摘要
static class FlowView.FlowStrategy
维护流的物理形式的策略。
字段摘要
protected View | layoutPool 这些都是表示此视图表示的元素（要转换为物理视图的逻辑视图）的子元素的视图。
protected int | layoutSpan 创建流所依靠的默认约束。
protected FlowView.FlowStrategy | strategy 保持流更新的行为。
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
FlowView(Element elem, int axis)
构造给定元素的 FlowView。
方法摘要
protected SizeRequirements | calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算沿辅轴的要求。
void | changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected abstract View | createRow() 创建应在保持流中子级行值时使用的视图。
int | getFlowAxis() 获取应沿其流入视图的轴。
int | getFlowSpan(int index) 获取给定子索引流入的约束区域。
int | getFlowStart(int index) 获取沿流轴的流区域开始位置。
protected int | getViewIndexAtPosition(int pos) 获取此模型中表示给定位置的子视图索引。
void | insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
protected void | layout(int width, int height) 布置子级。
protected void | loadChildren(ViewFactory f) 加载初始化该视图的所有子级。
void | removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知从文档中此视图负责的某个位置已移除内容。
void | setParent(View parent) 设置此视图的父级。
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paint, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, isVisible, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

layoutSpan

protected int layoutSpan
创建流所依靠的默认约束。

layoutPool

protected View layoutPool
这些都是表示此视图表示的元素（要转换为物理视图的逻辑视图）的子元素的视图。这些都不是此视图的直接子级。这些子级既可以直接放入行，也可以用于拆分较小存储块，以便形成物理视图。

strategy

protected FlowView.FlowStrategy strategy
保持流更新的行为。默认情况下，这是所有 FlowView 实例共享的一个单独行为（FlowStrategy 是无状态的）。子类可以创建一个备用策略，该策略可用来保持状态。

构造方法详细信息

FlowView

public FlowView(Element elem,
                int axis)
构造给定元素的 FlowView。

参数：
elem - 此视图负责的元素
axis - 可以是 View.X_AXIS 或 View.Y_AXIS 之一
方法详细信息

getFlowAxis

public int getFlowAxis()
获取应沿其流入视图的轴。默认情况下，这将是与该流行沿其平铺的轴垂直的轴（默认流行自身的轴）。此操作通常由 FlowStrategy 使用。

getFlowSpan

public int getFlowSpan(int index)
获取给定子索引流入的约束区域。FlowStrategy 在更新该流时调用此方法。可以通过为行约束提供不同的值而形成流。默认情况下，返回沿流轴的 insets 内的整个区域。

参数：
index - 正在更新的行的索引。这应该是一个 >= 0 且 < getViewCount() 的值。
另请参见：
getFlowStart(int)

getFlowStart

public int getFlowStart(int index)
获取沿流轴的流区域开始位置。FlowStrategy 在更新该流时调用此方法。可以通过为行约束提供不同的值而形成流。

参数：
index - 正在更新的行的索引。这应该是一个 >= 0 且 < getViewCount() 的值。
另请参见：
getFlowSpan(int)

createRow

protected abstract View createRow()
创建应在保持流中子级行值时使用的视图。在更新流的过程中添加或移除新子级（即添加或移除行）时，此方法由 FlowStrategy 调用。

loadChildren

protected void loadChildren(ViewFactory f)
加载初始化该视图的所有子级。此方法由 setParent 方法调用。重新实现此方法，以便不直接加载任何子级（因为它们是在格式化进程中创建的）。如果 layoutPool 变量为 null，则创建一个 LogicalView 实例，表示在格式化进程中使用的逻辑视图。

覆盖：
类 CompositeView 中的 loadChildren
参数：
f - 视图工厂
另请参见：
CompositeView.setParent(javax.swing.text.View)

getViewIndexAtPosition

protected int getViewIndexAtPosition(int pos)
获取此模型中表示给定位置的子视图索引。

覆盖：
类 CompositeView 中的 getViewIndexAtPosition
参数：
pos - 位置，该值 >= 0
返回：
表示给定位置的视图的索引，如果没有视图表示该位置，则返回 -1

layout

protected void layout(int width,
                      int height)
布置子级。如果沿流轴的区域已改变，则布局将标记为无效，这样会导致沿框轴重新计算布局的超类行为。FlowStrategy.layout 方法将被调用以便相应地重建这些流行。如果此视图的高度改变（由沿框轴的首选大小确定），则调用 preferenceChanged。这一切做完后，将执行超类的正常框布局。

覆盖：
类 BoxView 中的 layout
参数：
width - 要按其布置的宽度，该值 >= 0。这是 inset 区域内的宽度。
height - 按其布置的高度，该值 >= 0。这是 inset 区域内的高度。

calculateMinorAxisRequirements

protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                                          SizeRequirements r)
计算沿辅轴的要求。实现此方法，以便通过在其上调用 getMinimumSpan、getPreferredSpan 和 getMaximumSpan 将此请求转到逻辑视图。

覆盖：
类 BoxView 中的 calculateMinorAxisRequirements
参数：
axis - 所考察的轴
r - SizeRequirements 对象；如果为 null，将创建一个对象
返回：
新初始化的 SizeRequirements 对象
另请参见：
SizeRequirements

insertUpdate

public void insertUpdate(DocumentEvent changes,
                         Shape a,
                         ViewFactory f)
发出通知，通知在文档中此视图负责的某个位置已插入内容。

覆盖：
类 View 中的 insertUpdate
参数：
changes - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(DocumentEvent changes,
                         Shape a,
                         ViewFactory f)
发出通知，通知从文档中此视图负责的某个位置已移除内容。

覆盖：
类 View 中的 removeUpdate
参数：
changes - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

changedUpdate

public void changedUpdate(DocumentEvent changes,
                          Shape a,
                          ViewFactory f)
发出通知，通知文档中此视图负责的某个位置的属性已更改。

覆盖：
类 View 中的 changedUpdate
参数：
changes - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

setParent

public void setParent(View parent)
设置此视图的父级。重新实现此方法可提供超类行为，并可在此视图无子级的情况下调用 loadChildren 方法。不应在构造方法中加载子级，因为设置父级的动作可能引起它们试图沿层次结构向上搜索，例如，要获得承载 Container。如果此视图有子级（视图从视图层次结构中的一个位置移动到另一个位置），则不调用 loadChildren 方法。

覆盖：
类 CompositeView 中的 setParent
参数：
parent - 视图的父级，如果没有则为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowView.FlowStrategy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 FlowView.FlowStrategy

java.lang.Object
    继承者  javax.swing.text.FlowView.FlowStrategy
正在封闭类：
FlowView
public static class FlowView.FlowStrategy
extends Object

维护流的物理形式的策略。默认实现是完全无状态的，并且如果给定的 FlowView 布局无效，则要重新计算整个流。备用策略可以通过创建子类实现，并且可以对布局或备用分解行为执行增量修复。

从以下版本开始：
1.3

构造方法摘要
FlowView.FlowStrategy()
方法摘要
protected void | adjustRow(FlowView fv, int rowIndex, int desiredSpan, int x) 如有可能，调整给定行以使其适合布局区域。
void | changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected View | createView(FlowView fv, int startOffset, int spanLeft, int rowIndex) 创建一个可用于表示流的当前片段的视图。
protected View | getLogicalView(FlowView fv) 此方法提供访问 FlowView 的逻辑视图的流策略。
void | insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | layout(FlowView fv) 更新给定 FlowView 的流。
protected int | layoutRow(FlowView fv, int rowIndex, int pos) 创建一个符合该行布局区域的视图的行。
void | removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlowView.FlowStrategy

public FlowView.FlowStrategy()
方法详细信息

insertUpdate

public void insertUpdate(FlowView fv,
                         DocumentEvent e,
                         Rectangle alloc)
发出通知，通知在文档中此视图负责的某个位置已插入内容。该策略应能更新相应的已更改区域（这取决于修复所用的策略）。

参数：
e - 来自相关文档的更改信息
alloc - 该 insets 内此视图的当前分配区域。如果视图尚未显示，则此值为 null。
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(FlowView fv,
                         DocumentEvent e,
                         Rectangle alloc)
发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。

参数：
e - 来自相关文档的更改信息
alloc - 该 insets 内此视图的当前分配区域。
另请参见：
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

changedUpdate

public void changedUpdate(FlowView fv,
                          DocumentEvent e,
                          Rectangle alloc)
发出通知，通知文档中此视图负责的某个位置的属性已更改。

参数：
fv - 包含这些更改的 FlowView
e - 描述对文档做出的更改的 DocumentEvent
alloc - 视图的边界
另请参见：
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

getLogicalView

protected View getLogicalView(FlowView fv)
此方法提供访问 FlowView 的逻辑视图的流策略。

layout

public void layout(FlowView fv)
更新给定 FlowView 的流。默认情况下，这样会导致所有行（子视图）的重建，以匹配每行的给定约束。此方法由 FlowView.layout 调用来更新流中的子视图。

参数：
fv - 回流视图

layoutRow

protected int layoutRow(FlowView fv,
                        int rowIndex,
                        int pos)
创建一个符合该行布局区域的视图的行。它将由布局方法调用。通过重复调用 createView 方法来实现行的填充，直到用尽可用区域、遇到强制中断或 createView 方法返回 null 为止。如果已用尽剩余区域，则调用 adjustRow 方法来调整该行，试图使它符合给定区域。

参数：
rowIndex - 要使用视图填充的行的索引。假定行入口为空。
pos - 视图子级中元素从其开始的当前位置。
返回：
开始下一行的位置

adjustRow

protected void adjustRow(FlowView fv,
                         int rowIndex,
                         int desiredSpan,
                         int x)
如有可能，调整给定行以使其适合布局区域。默认情况下，此操作将试图能在最接近行结尾的位置找到最高中断权重。如果遇到强制中断，则该中断将定位于强制中断的位置。

参数：
rowIndex - 调整当前布局区域的行。
desiredSpan - 当前布局区域，该值 >= 0
x - 行开始处的位置。

createView

protected View createView(FlowView fv,
                          int startOffset,
                          int spanLeft,
                          int rowIndex)
创建一个可用于表示流的当前片段的视图。这可以是逻辑视图中的整个视图，也可以是该逻辑视图的一个片段。

参数：
fv - 保存流的视图
startOffset - 正创建的视图的开始位置
spanLeft - 行中填充的区域左半部分
rowIndex - 视图将放入其中的行
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GapContent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 GapContent

java.lang.Object
    继承者  javax.swing.text.GapContent
所有已实现的接口：
Serializable, AbstractDocument.Content
public class GapContent
extends Object
implements AbstractDocument.Content, Serializable

AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。基础存储是一个 unicode 字符数组，在数组的某个位置存在间隙。将该间隙移动到要进行更改的位置，以便利用一般行为，让多数更改都在原来的位置上进行。在间隙边界发生更改通常很容易，而且移动间隙通常比直接移动数组内容来适应更改要更容易。

跟踪更改的位置也通常容易维护。Position 实现（标记）存储数组索引，并可方便地根据当前间隙位置计算连续位置。更改只需要更新移动间隙时新旧间隙边界之间的标记，因此更新标记通常会相当容易。该标记是按顺序存储的，所以可以使用二分查找法快速找到。这提高了添加标记的成本，但降低了保持标记更新的成本。

构造方法摘要
GapContent()
创建新的 GapContent 对象。
GapContent(int initialLength)
创建具有指定初始大小的新 GapContent 对象。
方法摘要
protected Object | allocateArray(int len) 分配一个存储适当类型项的数组（由子类确定）。
Position | createPosition(int offset) 在内容中创建一个位置，使其在内容发生变化时能跟踪内容的更改。
protected Object | getArray() Access to the array.
protected int | getArrayLength() 获取分配的数组的长度。
void | getChars(int where, int len, Segment chars) 检索部分内容。
protected int | getGapEnd() Access to the end of the gap.
protected int | getGapStart() Access to the start of the gap.
protected Vector | getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
String | getString(int where, int len) 检索部分内容。
UndoableEdit | insertString(int where, String str) 在内容中插入字符串。
int | length() 返回内容的长度。
UndoableEdit | remove(int where, int nitems) 移除部分内容。
protected void | replace(int position, int rmSize, Object addItems, int addSize) Replace the given logical position in the storage with the given new items.
protected void | resetMarksAtZero() 重新设置具有 0 偏移量的所有标记，使其也有零索引。
protected void | shiftEnd(int newSize) 扩大间隙、移动任何必要的数据和更新适当的标记。
protected void | shiftGap(int newGapStart) 将间隙的起始点移动到新位置，而不更改间隙的大小。
protected void | shiftGapEndUp(int newGapEnd) 调整间隙，使其结尾向前扩展。
protected void | shiftGapStartDown(int newGapStart) 调整间隙，使其结尾向后扩展。
protected void | updateUndoPositions(Vector positions, int offset, int length) 重新设置处在 positions 的所有 UndoPosRef 实例的位置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GapContent

public GapContent()
创建新的 GapContent 对象。初始大小默认为 10。

GapContent

public GapContent(int initialLength)
创建具有指定初始大小的新 GapContent 对象。初始大小不允许小于 2，以便留出空间供再次包含间隙和拆分操作。

参数：
initialLength - 初始大小
方法详细信息

allocateArray

protected Object allocateArray(int len)
分配一个存储适当类型项的数组（由子类确定）。

getArrayLength

protected int getArrayLength()
获取分配的数组的长度。

length

public int length()
返回内容的长度。

指定者：
接口 AbstractDocument.Content 中的 length
返回：
长度，该值 >= 1
另请参见：
AbstractDocument.Content.length()

insertString

public UndoableEdit insertString(int where,
                                 String str)
                          throws BadLocationException
在内容中插入字符串。

指定者：
接口 AbstractDocument.Content 中的 insertString
参数：
where - 起始位置，该值 >= 0 且 < length()
str - 要插入的非 null 字符串
返回：
撤消的 UndoableEdit 对象
抛出：
BadLocationException - 如果指定位置无效
另请参见：
AbstractDocument.Content.insertString(int, java.lang.String)

remove

public UndoableEdit remove(int where,
                           int nitems)
                    throws BadLocationException
移除部分内容。

指定者：
接口 AbstractDocument.Content 中的 remove
参数：
where - 起始位置，该值 >= 0 且 where + nitems < length()
nitems - 要移除的字符数，该值 >= 0
返回：
撤消的 UndoableEdit 对象
抛出：
BadLocationException - 如果指定位置无效
另请参见：
AbstractDocument.Content.remove(int, int)

getString

public String getString(int where,
                        int len)
                 throws BadLocationException
检索部分内容。

指定者：
接口 AbstractDocument.Content 中的 getString
参数：
where - 起始位置，该值 >= 0
len - 要检索的长度，该值 >= 0
返回：
一个表示该内容的字符串
抛出：
BadLocationException - 如果指定位置无效
另请参见：
AbstractDocument.Content.getString(int, int)

getChars

public void getChars(int where,
                     int len,
                     Segment chars)
              throws BadLocationException
检索部分内容。如果所需内容跨越间隙，则要复制该内容。如果所需内容未跨越间隙，则由于它是连续的，所以返回实际的存储而不用复制。

指定者：
接口 AbstractDocument.Content 中的 getChars
参数：
where - 起始位置，该值 >= 0，where + len <= length()
len - 要检索的字符数，该值 >= 0
chars - 要在其中返回字符的 Segment 对象
抛出：
BadLocationException - 如果指定位置无效
另请参见：
AbstractDocument.Content.getChars(int, int, javax.swing.text.Segment)

createPosition

public Position createPosition(int offset)
                        throws BadLocationException
在内容中创建一个位置，使其在内容发生变化时能跟踪内容的更改。

指定者：
接口 AbstractDocument.Content 中的 createPosition
参数：
offset - 要跟踪的偏移量，该值 >= 0
返回：
位置
抛出：
BadLocationException - 如果指定位置无效

shiftEnd

protected void shiftEnd(int newSize)
扩大间隙、移动任何必要的数据和更新适当的标记。

shiftGap

protected void shiftGap(int newGapStart)
将间隙的起始点移动到新位置，而不更改间隙的大小。这会移动数组中的数据和更新相应的标记。

resetMarksAtZero

protected void resetMarksAtZero()
重新设置具有 0 偏移量的所有标记，使其也有零索引。

shiftGapStartDown

protected void shiftGapStartDown(int newGapStart)
调整间隙，使其结尾向后扩展。此操作不移动任何数据，但它一定会更新受边界更改影响的所有标记。从旧间隙起始点向后到新间隙起始点的所有标记都合并到了间隙的结尾（其位置已被移除）。

shiftGapEndUp

protected void shiftGapEndUp(int newGapEnd)
调整间隙，使其结尾向前扩展。此操作不移动任何数据，但它一定会更新受边界更改影响的所有标记。从旧间隙结尾点向前到新间隙结尾点的所有标记都合并到了间隙的结尾（其位置已被移除）。

getPositionsInRange

protected Vector getPositionsInRange(Vector v,
                                     int offset,
                                     int length)
返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。如果 v 不为 null，则在此处放置匹配的 Position。返回具有结果 Position 的向量。

参数：
v - 要使用的 Vector，其位置是向量为 null 时创建的新位置
offset - 起始偏移量，该值 >= 0
length - 长度，该值 >= 0
返回：
实例的集合

updateUndoPositions

protected void updateUndoPositions(Vector positions,
                                   int offset,
                                   int length)
重新设置处在 positions 的所有 UndoPosRef 实例的位置。

这里指的是内部用法，通常不适合子类。

参数：
positions - 重新设置 UndoPosRef 实例的位置

getArray

protected final Object getArray()
Access to the array. The actual type of the array is known only by the subclass.

getGapStart

protected final int getGapStart()
Access to the start of the gap.

getGapEnd

protected final int getGapEnd()
Access to the end of the gap.

replace

protected void replace(int position,
                       int rmSize,
                       Object addItems,
                       int addSize)
Replace the given logical position in the storage with the given new items. This will move the gap to the area being changed if the gap is not currently located at the change location.

参数：
position - the location to make the replacement. This is not the location in the underlying storage array, but the location in the contiguous space being modeled.
rmSize - the number of items to remove
addItems - the new items to place in storage.
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GlyphView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 GlyphView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.GlyphView
所有已实现的接口：
Cloneable, SwingConstants, TabableView
直接已知子类：
LabelView
public class GlyphView
extends View
implements TabableView, Cloneable

GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。此视图通常负责以某种方式使用字符级别属性显示文本字形。GlyphPainter 类的实现用于进行实际呈现和模型/视图转换。此操作分别呈现与该模型关联的布局和管理。

该视图支持为了格式化而进行的分解。通过分解产生的片段共享对元素负主要负责的视图（即它们是嵌套的类，只有其自身少量的状态），因此它们可以共享其资源。

因为此视图表示可以有嵌入其中的选项卡的文本，所以可实现 TabableView 接口。只有此视图嵌入进行选项卡扩展的容器时，才扩展选项卡。ParagraphView 是一个包含进行选项卡扩展的容器的示例。

从以下版本开始：
1.3

嵌套类摘要
static class GlyphView.GlyphPainter
执行字形呈现的类。
字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
GlyphView(Element elem)
构造在元素上包装的新视图。
方法摘要
View | breakView(int axis, int p0, float pos, float len) 在给定的轴上以给定的长度拆分此视图。
void | changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
protected void | checkPainter() 检查是否存在字形 painter。
protected Object | clone() 创建一个浅表复制。
View | createFragment(int p0, int p1) 创建表示元素某部分的视图。
float | getAlignment(int axis) 确定此视图沿某个轴所需的对齐方式。
Color | getBackground() 获取用于呈现字形的背景色。
int | getBreakWeight(int axis, float pos, float len) 确定此视图拆分几率有多大。
int | getEndOffset() 获取此视图负责的一部分模型。
Font | getFont() 获取字形应该以其为依据的字体。
Color | getForeground() 获取用于呈现字形的前景色。
GlyphView.GlyphPainter | getGlyphPainter() 获取当前安装的字形 painter。
int | getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
float | getPartialSpan(int p0, int p1) 确定沿与选项卡扩展同轴的区域是否为该视图的一部分。
float | getPreferredSpan(int axis) 确定此视图沿某个轴的首选区域。
int | getStartOffset() 获取此视图负责的一部分模型。
float | getTabbedSpan(float x, TabExpander e) 确定使用给定选项卡扩展实现时所需的区域。
TabExpander | getTabExpander() 如果此视图中存在选项卡，则获取要使用的 TabExpander。
Segment | getText(int p0, int p1) 获取对占用给定范围的文本的引用。
void | insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
boolean | isStrikeThrough() 确定字形是否应该有删除线。
boolean | isSubscript() 确定字形是否应该呈现为上标。
boolean | isSuperscript() 确定字形是否应该呈现为下标。
boolean | isUnderline() 确定字形是否应加下划线。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | paint(Graphics g, Shape a) 呈现一部分运行的文本样式。
void | removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
void | setGlyphPainter(GlyphView.GlyphPainter p) 设置用于呈现字形的 painter。
int | viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
从类 javax.swing.text.View 继承的方法
append, forwardUpdate, forwardUpdateToView, getAttributes, getChildAllocation, getContainer, getDocument, getElement, getGraphics, getMaximumSpan, getMinimumSpan, getParent, getResizeWeight, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, setSize, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GlyphView

public GlyphView(Element elem)
构造在元素上包装的新视图。

参数：
elem - 元素
方法详细信息

clone

protected final Object clone()
创建一个浅表复制。这由 createFragment 和 breakView 方法使用。

覆盖：
类 Object 中的 clone
返回：
复制
另请参见：
Cloneable

getGlyphPainter

public GlyphView.GlyphPainter getGlyphPainter()
获取当前安装的字形 painter。如果尚未安装 painter，且尚不需要默认，则返回 null。

setGlyphPainter

public void setGlyphPainter(GlyphView.GlyphPainter p)
设置用于呈现字形的 painter。

getText

public Segment getText(int p0,
                       int p1)
获取对占用给定范围的文本的引用。这通常由 GlyphPainter 使用，以确定它应该呈现哪些字符的字形。

参数：
p0 - 起始文档偏移量，该值 >= 0
p1 - 结束文档偏移量，该值 >= p0
返回：
包含文本的 Segment

getBackground

public Color getBackground()
获取用于呈现字形的背景色。如果不存在背景色，则应该返回 null。如果相关文档是样式化文档，则实现此方法以调用 StyledDocument.getBackground，否则返回 null。

getForeground

public Color getForeground()
获取用于呈现字形的前景色。如果没有前景色，则应返回 null。如果相关文档是一个 StyledDocument，则实现此方法可调用 StyledDocument.getBackground。如果相关文档不是一个 StyledDocument，则使用相关组件的前景色。如果没有相关组件，则返回 null。

getFont

public Font getFont()
获取字形应该以其为依据的字体。如果相关文档是一个 StyledDocument，则实现此方法可调用 StyledDocument.getFont。如果相关文档不是一个 StyledDocument，则使用相关组件的字体。如果没有相关组件，则返回 null。

isUnderline

public boolean isUnderline()
确定字形是否应加下划线。如果为 true，则应通过基线绘制下划线。

isStrikeThrough

public boolean isStrikeThrough()
确定字形是否应该有删除线。如果为 true，则应穿过字形中心划一条线。

isSubscript

public boolean isSubscript()
确定字形是否应该呈现为上标。

isSuperscript

public boolean isSuperscript()
确定字形是否应该呈现为下标。

getTabExpander

public TabExpander getTabExpander()
如果此视图中存在选项卡，则获取要使用的 TabExpander。

checkPainter

protected void checkPainter()
检查是否存在字形 painter。如果不存在 painter，则安装默认的字形 painter。

getTabbedSpan

public float getTabbedSpan(float x,
                           TabExpander e)
确定使用给定选项卡扩展实现时所需的区域。

指定者：
接口 TabableView 中的 getTabbedSpan
参数：
x - 为进行选项卡扩展该视图所在的位置，该位置 >= 0。
e - 遇到选项卡时对其进行扩展的方法。
返回：
所需的区域，该区域 >= 0
另请参见：
TabableView.getTabbedSpan(float, javax.swing.text.TabExpander)

getPartialSpan

public float getPartialSpan(int p0,
                            int p1)
确定沿与选项卡扩展同轴的区域是否为该视图的一部分。这专门由 TabExpander 使用，用于选项卡扩展涉及的相对于 tab stop 来说没有空白的文本部分对齐的情况。因此，可假定给定的范围不包含选项卡。

使用 getTabbedSpan 或 getPreferredSize 时可以调用此方法。它必须安排自己的文本缓冲区来进行测量。

指定者：
接口 TabableView 中的 getPartialSpan
参数：
p0 - 起始文档偏移量，该偏移量 >= 0
p1 - 结束文档偏移量，该偏移量 >= p0
返回：
区域，该区域 >= 0

getStartOffset

public int getStartOffset()
获取此视图负责的一部分模型。

覆盖：
类 View 中的 getStartOffset
返回：
模型中的起始偏移量
另请参见：
View.getStartOffset()

getEndOffset

public int getEndOffset()
获取此视图负责的一部分模型。

覆盖：
类 View 中的 getEndOffset
返回：
模型中的结束偏移量
另请参见：
View.getEndOffset()

paint

public void paint(Graphics g,
                  Shape a)
呈现一部分运行的文本样式。

指定者：
类 View 中的 paint
参数：
g - 要使用的呈现表面
a - 已分配的呈现区域

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某个轴的首选区域。

指定者：
类 View 中的 getPreferredSpan
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，该区域 >= 0。通常会告知该视图在返回的区域中呈现，但不保证一定如此。父级可选择重新调整视图大小或拆分视图。
另请参见：
View.getPreferredSpan(int)

getAlignment

public float getAlignment(int axis)
确定此视图沿某个轴所需的对齐方式。对于标签，该对齐方式是让字体基线沿 y 轴对齐，而超类是沿 x 轴对齐方式。

覆盖：
类 View 中的 getAlignment
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
需要的对齐方式。这应是 0.0 和 1.0 之间的值，其中 0.0 指示原点对齐，1.0 指示原点以外的整个区域对齐。0.5 对齐方式指视图的中心。

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

指定者：
类 View 中的 modelToView
参数：
pos - 要转换的位置，该位置 >= 0
a - 要呈现的分配区域
b - 可以是 Position.Bias.Forward，也可以是 Position.Bias.Backward
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置不表示相关文档中的有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public int viewToModel(float x,
                       float y,
                       Shape a,
                       Position.Bias[] biasReturn)
提供从视图坐标空间到模型逻辑坐标空间的映射。

指定者：
类 View 中的 viewToModel
参数：
x - X 坐标，该坐标 >= 0
y - Y 坐标，该坐标 >= 0
a - 要在其中呈现的分配区域
biasReturn - 将 Position.Bias.Forward 或 Position.Bias.Backward 作为此数组中的第零个元素返回
返回：
模型中最能表示视图给定点的位置，该位置 >= 0
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

getBreakWeight

public int getBreakWeight(int axis,
                          float pos,
                          float len)
确定此视图拆分几率有多大。这可用于确定在格式化进程中最有可能调用 breakView 的视图。权重越高，拆分的可能性越大。如果值等于或小于 View.BadBreakWeight，则不应考虑拆分。值大于或等于 View.ForcedBreakWeight 时应该拆分视图。

实现此方法以转发到 Y_AXIS 的超类。沿 X_AXIS 可以返回以下值。

View.ExcellentBreakWeight
如果有空白占据着所需的拆分位置。
View.BadBreakWeight
如果所需的拆分位置导致了拆分位置的起始偏移量。
View.GoodBreakWeight
如果不出现其他情况。
如果能够找到空白位置，则通常会导致在空白位置处的拆分行为，否则会在字符之间拆分。

覆盖：
类 View 中的 getBreakWeight
参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
pos - 已拆分视图的潜在起始位置，该位置 >= 0。这可能对计算选项卡的位置有用。
len - 指定到所需的潜在拆分处 pos 的相对长度，该长度 >= 0。
返回：
View.ForcedBreakWeight 和 View.BadBreakWeight 之间的一个权重值
另请参见：
LabelView, ParagraphView, View.BadBreakWeight, View.GoodBreakWeight, View.ExcellentBreakWeight, View.ForcedBreakWeight

breakView

public View breakView(int axis,
                      int p0,
                      float pos,
                      float len)
在给定的轴上以给定的长度拆分此视图。实现此方法，以便尝试在空白位置处拆分，并在结束处返回一个带有空白的片段。如果找不到空白位置，则使用最靠近的字符。

覆盖：
类 View 中的 breakView
参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
p0 - 模型中片段应该开始其表示形式的位置，该位置 >= 0。
pos - 沿已拆分视图可能占用的轴的位置，该位置 >= 0。这可能对诸如选项卡计算一类的情况很有用。
len - 指定的沿需要潜在拆分的轴的距离，该距离 >= 0。
返回：
如果视图可以拆分，则返回表示给定区域的视图片段。如果视图不支持拆分行为，则返回视图自身。
另请参见：
View.breakView(int, int, float, float)

createFragment

public View createFragment(int p0,
                           int p1)
创建表示元素某部分的视图。此方法可能在测量视图片段的格式化操作期间有用。如果视图不支持分段（默认），则返回其自身。

此视图确实支持分段。实现此方法以返回一个嵌套类，该类共享在此视图中只表示该视图的某一部分的状态。

覆盖：
类 View 中的 createFragment
参数：
p0 - 起始偏移量，该偏移量 >= 0。此值应该大于或等于元素起始偏移量且小于元素结束偏移量。
p1 - 结束偏移量，该偏移量 > p0。这应该是一个小于或等于元素结束偏移量且大于元素起始偏移量的值。
返回：
视图片段，如果视图不支持片段拆分，则返回其自身
另请参见：
LabelView

getNextVisualPositionFrom

public int getNextVisualPositionFrom(int pos,
                                     Position.Bias b,
                                     Shape a,
                                     int direction,
                                     Position.Bias[] biasRet)
                              throws BadLocationException
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。有些视图可能不可见，它们可能与该模型中发现的顺序不同，或它们可能只是不允许访问该模型中的某些位置。

覆盖：
类 View 中的 getNextVisualPositionFrom
参数：
pos - 要转换的位置，该位置 >= 0
a - 要呈现的分配区域
direction - 相对当前位置的方向，可视为通常在键盘上看到的箭头键方向。此方向可以是 SwingConstants.WEST、SwingConstants.EAST、SwingConstants.NORTH 或 SwingConstants.SOUTH。
返回：
模型中最能表示下一个可视位置的位置。
抛出：
BadLocationException
IllegalArgumentException - 如果方向无效

insertUpdate

public void insertUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
发出通知，通知文档中此视图负责的位置已插入内容。实现此方法，以便沿呈现字形的轴调用 preferenceChanged。

覆盖：
类 View 中的 insertUpdate
参数：
e - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
发出通知，通知文档中此视图负责的位置已移除内容。实现此方法，以便沿呈现字形的轴调用 preferenceChanged。

覆盖：
类 View 中的 removeUpdate
参数：
e - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

changedUpdate

public void changedUpdate(DocumentEvent e,
                          Shape a,
                          ViewFactory f)
发出通知，通知文档此视图负责的位置处的属性已更改。实现此方法，以便沿水平轴和垂直轴调用 preferenceChanged。

覆盖：
类 View 中的 changedUpdate
参数：
e - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GlyphView.GlyphPainter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 GlyphView.GlyphPainter

java.lang.Object
    继承者  javax.swing.text.GlyphView.GlyphPainter
正在封闭类：
GlyphView
public abstract static class GlyphView.GlyphPainter
extends Object

执行字形呈现的类。此类可实现为无状态的，或将某些信息存储为缓存，以便更快地呈现和模型/视图转换。至少，GlyphPainter 允许 View 实现独立于特定的 JVM 版本和功能选择（即向国际化并轨）来执行其职责。

从以下版本开始：
1.3

构造方法摘要
GlyphView.GlyphPainter()
方法摘要
abstract float | getAscent(GlyphView v)
abstract int | getBoundedPosition(GlyphView v, int p0, float x, float len) 确定表示符合给定区域的最大 advance 的模型位置。
abstract float | getDescent(GlyphView v)
abstract float | getHeight(GlyphView v)
int | getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
GlyphView.GlyphPainter | getPainter(GlyphView v, int p0, int p1) 创建用于给定 GlyphView 的 painter。
abstract float | getSpan(GlyphView v, int p0, int p1, TabExpander e, float x) 确定给定开始位置（相对于选项卡扩展而言）的字形区域。
abstract Shape | modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract void | paint(GlyphView v, Graphics g, Shape a, int p0, int p1) 绘制表示给定范围的字形。
abstract int | viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GlyphView.GlyphPainter

public GlyphView.GlyphPainter()
方法详细信息

getSpan

public abstract float getSpan(GlyphView v,
                              int p0,
                              int p1,
                              TabExpander e,
                              float x)
确定给定开始位置（相对于选项卡扩展而言）的字形区域。

getHeight

public abstract float getHeight(GlyphView v)

getAscent

public abstract float getAscent(GlyphView v)

getDescent

public abstract float getDescent(GlyphView v)

paint

public abstract void paint(GlyphView v,
                           Graphics g,
                           Shape a,
                           int p0,
                           int p1)
绘制表示给定范围的字形。

modelToView

public abstract Shape modelToView(GlyphView v,
                                  int pos,
                                  Position.Bias bias,
                                  Shape a)
                           throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。这由拆分后的视图共享。

参数：
v - 包含目标坐标空间的 GlyphView
pos - 要转换的位置
bias - 可以是 Position.Bias.Forward，也可以是 Position.Bias.Backward
a - 视图的边界
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置不表示相关文档中的有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public abstract int viewToModel(GlyphView v,
                                float x,
                                float y,
                                Shape a,
                                Position.Bias[] biasReturn)
提供从视图坐标空间到模型逻辑坐标空间的映射。

参数：
v - 要为其提供映射的 GlyphView
x - X 坐标
y - Y 坐标
a - 要呈现的分配区域
biasReturn - 将 Position.Bias.Forward 或 Position.Bias.Backward 返回，作为此数组中的第零个元素
返回：
模型中最能代表视图中给定点的位置
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

getBoundedPosition

public abstract int getBoundedPosition(GlyphView v,
                                       int p0,
                                       float x,
                                       float len)
确定表示符合给定区域的最大 advance 的模型位置。此方法可用于拆分给定的视图。结果应为一个不完全占用给定 advance 的位置。这与 viewToModel 不同，后者将返回充分利用最大 advance 的位置。

参数：
v - 查找在其处拆分的模型位置的视图。
p0 - 模型中片段应开始其表示形式的位置，该值 >= 0。
x - 沿已拆分视图可能占用的轴的图形位置，该值 >= 0。这可能对选项卡计算之类的情况有用。
len - 向需要潜在拆分的视图指定的距离，该值 >= 0.
返回：
能用于拆分的最大模型位置。
另请参见：
View.breakView(int, int, float, float)

getPainter

public GlyphView.GlyphPainter getPainter(GlyphView v,
                                         int p0,
                                         int p1)
创建用于给定 GlyphView 的 painter。如果该 painter 状态正常，则它可以创建另一个 painter 以表示正在创建的新 GlyphView。如果该 painter 未处于有效状态，则可能返回其自身。默认行为是返回其自身。

参数：
v - 要为其提供 painter 的 GlyphView
p0 - 初始文档偏移量，该值 >= 0
p1 - 结束文档偏移量，该值 >= p0

getNextVisualPositionFrom

public int getNextVisualPositionFrom(GlyphView v,
                                     int pos,
                                     Position.Bias b,
                                     Shape a,
                                     int direction,
                                     Position.Bias[] biasRet)
                              throws BadLocationException
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。有些视图可能不可见，它们可能与该模型中发现的顺序不同，或它们可能只是不允许访问该模型中的某些位置。

参数：
v - 要使用的视图
pos - 要转换的位置，该值 >= 0
b - 可以是 Position.Bias.Forward，也可以是 Position.Bias.Backward
a - 要呈现的分配区域
direction - 相对当前位置的方向，通常可视为键盘上找到的箭头键。此可以是 SwingConstants.WEST、SwingConstants.EAST、SwingConstants.NORTH 或 SwingConstants.SOUTH。
biasRet - 将 Position.Bias.Forward 或 Position.Bias.Backward 作为此数组中的第零个元素返回
返回：
模型中最能表示下一个可视位置的位置。
抛出：
BadLocationException
IllegalArgumentException - 如果方向无效
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Highlighter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Highlighter

所有已知实现类：
BasicTextUI.BasicHighlighter, DefaultHighlighter, LayeredHighlighter
public interface Highlighter

一个允许用户用带有颜色的区域标出背景的对象接口。

嵌套类摘要
static interface | Highlighter.Highlight
static interface | Highlighter.HighlightPainter 呈现高亮显示。
方法摘要
Object | addHighlight(int p0, int p1, Highlighter.HighlightPainter p) 向视图添加高亮显示。
void | changeHighlight(Object tag, int p0, int p1) 更改给定的高亮显示，以使其横跨文档的不同部分。
void | deinstall(JTextComponent c) 将 UI 从 JTextComponent 的接口移除时调用。
Highlighter.Highlight[] | getHighlights() 获取高亮显示的当前列表。
void | install(JTextComponent c) 将 UI 安装到 JTextComponent 的接口时调用。
void | paint(Graphics g) 呈现高亮显示。
void | removeAllHighlights() 移除此轮廓色负责的所有高亮显示。
void | removeHighlight(Object tag) 从视图中移除高亮显示。

方法详细信息

install

void install(JTextComponent c)
将 UI 安装到 JTextComponent 的接口时调用。使用它可以获得对正由此接口的实现导航的模型的访问。

参数：
c - JTextComponent 编辑器

deinstall

void deinstall(JTextComponent c)
将 UI 从 JTextComponent 的接口移除时调用。这可用于取消对任何所关联侦听器的注册。

参数：
c - JTextComponent 编辑器

paint

void paint(Graphics g)
呈现高亮显示。

参数：
g - 图形上下文。

addHighlight

Object addHighlight(int p0,
                    int p1,
                    Highlighter.HighlightPainter p)
                    throws BadLocationException
向视图添加高亮显示。返回一个可用于引用高亮显示的标记。

参数：
p0 - 范围的开头，该值 >= 0
p1 - 范围的结尾，该值 >= p0
p - 用于实际高亮显示的 painter
返回：
引用高亮显示的对象
抛出：
BadLocationException - 表明为无效的范围规范

removeHighlight

void removeHighlight(Object tag)
从视图中移除高亮显示。

参数：
tag - 要移除高亮显示

removeAllHighlights

void removeAllHighlights()
移除此轮廓色负责的所有高亮显示。

changeHighlight

void changeHighlight(Object tag,
                     int p0,
                     int p1)
                     throws BadLocationException
更改给定的高亮显示，以使其横跨文档的不同部分。这要比只改变要更改内容来扩大/缩小（如用鼠标扫过）选中项时的移除/添加更有效。

参数：
tag - 要更改的高亮显示
p0 - 范围的开头，该值 >= 0
p1 - 范围的结尾，该值 >= p0
抛出：
BadLocationException - 表明为无效的范围规范

getHighlights

Highlighter.Highlight[] getHighlights()
获取高亮显示的当前列表。

返回：
高亮显示列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Highlighter.Highlight (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Highlighter.Highlight

正在封闭接口：
Highlighter
public static interface Highlighter.Highlight

方法摘要
int | getEndOffset() 获取高亮显示结束模型偏移量。
Highlighter.HighlightPainter | getPainter() 获取 highlighter 的 painter。
int | getStartOffset() 获取高亮显示的初始模型偏移量。

方法详细信息

getStartOffset

int getStartOffset()
获取高亮显示的初始模型偏移量。

返回：
初始偏移量，该值 >= 0

getEndOffset

int getEndOffset()
获取高亮显示结束模型偏移量。

返回：
结束偏移量，该值 >= 0

getPainter

Highlighter.HighlightPainter getPainter()
获取 highlighter 的 painter。

返回：
painter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Highlighter.HighlightPainter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Highlighter.HighlightPainter

所有已知实现类：
DefaultHighlighter.DefaultHighlightPainter, LayeredHighlighter.LayerPainter
正在封闭接口：
Highlighter
public static interface Highlighter.HighlightPainter

呈现高亮显示。

方法摘要
 void paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c)
呈现高亮显示。

方法详细信息

paint

void paint(Graphics g,
           int p0,
           int p1,
           Shape bounds,
           JTextComponent c)
呈现高亮显示。

参数：
g - 图形上下文
p0 - 模型中的初始偏移量，该值 >= 0
p1 - 模型中的结束偏移量，该值 >= p0
bounds - 高亮显示的边界框
c - 编辑器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IconView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 IconView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.IconView
所有已实现的接口：
SwingConstants
public class IconView
extends View

实现视图接口的图标修饰符。使用整个元素表示该图标。此方法充当一个从只显示 View 实现到交互式轻量级图标的门户（也就是说，它允许将图标嵌入 View 层次结构中。图标的父级是由相关视图工厂提供的容器。

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
IconView(Element elem)
创建表示元素的新图标视图。
方法摘要
float | getAlignment(int axis) 确定此视图沿某个轴所需的调整值。
float | getPreferredSpan(int axis) 确定此视图沿某个轴的首选区域。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | paint(Graphics g, Shape a) 绘制图标。
int | viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setParent, setSize, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IconView

public IconView(Element elem)
创建表示元素的新图标视图。

参数：
elem - 要为其创建视图的元素
方法详细信息

paint

public void paint(Graphics g,
                  Shape a)
绘制图标。实际绘制行为自然会从该图标与其父容器（承载此视图的同一个容器）的关联中发生，因此，这只允许相对于该视图正确定位图标。因为该视图的坐标系就是父容器，所以定位子图标很容易。

指定者：
类 View 中的 paint
参数：
g - 要使用的呈现表面
a - 分配的要在其中呈现的区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某个轴的首选区域。

指定者：
类 View 中的 getPreferredSpan
参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
返回：
要呈现该视图的区域。通常会告知该视图在返回的区域中呈现，但不保证一定如此。父级可选择重新调整视图大小或拆分视图。
抛出：
IllegalArgumentException - 如果轴无效
另请参见：
View.getPreferredSpan(int)

getAlignment

public float getAlignment(int axis)
确定此视图沿某个轴所需的调整值。实现此方法以使图标底部沿 y 轴对齐，而默认是沿 x 轴对齐。

覆盖：
类 View 中的 getAlignment
参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
返回：
所需的调整值，该值 >= 0.0f 且 <= 1.0f。这应该是介于 0.0 和 1.0 之间的一个值，0 指示相对原点对齐，1.0 指示相对离开原点的整个区域对齐。调整值为 0.5 表示视图的中心。

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

指定者：
类 View 中的 modelToView
参数：
pos - 要转换的位置，其值 >= 0
a - 分配的要在其中呈现的区域
b - 当位置是两个视图的边界时，该参数是离由偏移量表示的前一个字符或者下一个字符的偏差；b 将是这些值之一：
  • Position.Bias.Forward
  • Position.Bias.Backward
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置在所关联的文档中不是一个有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public int viewToModel(float x,
                       float y,
                       Shape a,
                       Position.Bias[] bias)
提供从视图坐标空间到该模型的逻辑坐标空间的映射。

指定者：
类 View 中的 viewToModel
参数：
x - X 坐标，该值 >= 0
y - Y 坐标，该值 >= 0
a - 要在其中呈现的分配区域
返回：
模型中最能代表视图中给定点的位置，该值 >= 0
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InternationalFormatter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 InternationalFormatter

java.lang.Object
    继承者  javax.swing.JFormattedTextField.AbstractFormatter
        继承者  javax.swing.text.DefaultFormatter
            继承者  javax.swing.text.InternationalFormatter
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
DateFormatter, NumberFormatter
public class InternationalFormatter
extends DefaultFormatter

InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。

如果 getAllowsInvalid() 为 false，这将要求 Format 在每次编辑时格式化当前文本。

可以通过 setMinimum 和 setMaximum 方法指定最小值和最大值。为使此值生效，必须比较 stringToValue 返回的值和通过 Comparable 接口得到的最小值/最大值。

配置 Format 和 InternationalFormatter 时一定要仔细，因为有可能造成某些值无法输入的情形。假定日期格式 'M/d/yy'（一种由 setAllowsInvalid(false) 决定总是有效的 InternationalFormatter）处于改写模式 (setOverwriteMode(true)) 且日期为 7/1/99。在此情况下，用户将不能输入两位数月份或某月的两位数日期。要避免此现象，该格式应该为 'MM/dd/yy'。

如果 InternationalFormatter 配置为只允许有效值 (setAllowsInvalid(false))，则每次有效编辑都会导致 JFormattedTextField 的文本根据 Format 全部重新设置。光标位置也将随着对结果 String 的字面值字符的添加/删除而调整。

InternationalFormatter 的 stringToValue 行为与 DefaultTextFormatter 稍有不同，它可以执行以下操作：

  1. 在 setFormat 指定的 Format 上调用 parseObject
  2. 如果针对一些值设置了某个 Class (setValueClass)，则会调用超类实现，以便将 parseObject 返回的值转换为适当的类。
  3. 如果尚未抛出 ParseException，并且该值不在最小值/最大值之间，则抛出 ParseException。
  4. 返回该值。
InternationalFormatter 以此方式实现 stringToValue，所以可以指定一个 Format 可能返回的替代 Class。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4
另请参见：
Format, Comparable

构造方法摘要
InternationalFormatter()
创建一个不带指定 Format 的 InternationalFormatter。
InternationalFormatter(Format format)
创建一个具有指定 Format 实例的 InternationalFormatter。
方法摘要
Object | clone() 创建该 DefaultFormatter 的一个副本。
protected Action[] | getActions() 如果 getSupportsIncrement 返回 true，则这将返回两个适合增加/减少该值的 Action。
Format.Field[] | getFields(int offset) 返回与 offset 处的文本相关的 Format.Field 常量。
Format | getFormat() 返回指示可以编辑和显示的合法值的格式。
Comparable | getMaximum() 返回最大允许值。
Comparable | getMinimum() 返回最小允许值。
void | install(JFormattedTextField ftf) 将 DefaultFormatter 安装到特定的 JFormattedTextField 上。
void | setFormat(Format format) 设置指示可以编辑和显示的合法值的格式。
void | setMaximum(Comparable max) 设置最大允许值。
void | setMinimum(Comparable minimum) 设置最小允许值。
Object | stringToValue(String text) 返回 String text 的 Object 表示形式。
String | valueToString(Object value) 返回 Object value 的 String 表示形式。
从类 javax.swing.text.DefaultFormatter 继承的方法
getAllowsInvalid, getCommitsOnValidEdit, getDocumentFilter, getNavigationFilter, getOverwriteMode, getValueClass, setAllowsInvalid, setCommitsOnValidEdit, setOverwriteMode, setValueClass
从类 javax.swing.JFormattedTextField.AbstractFormatter 继承的方法
getFormattedTextField, invalidEdit, setEditValid, uninstall
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InternationalFormatter

public InternationalFormatter()
创建一个不带指定 Format 的 InternationalFormatter。

InternationalFormatter

public InternationalFormatter(Format format)
创建一个具有指定 Format 实例的 InternationalFormatter。

参数：
format - 用于往返于 String 转换的 Format 实例
方法详细信息

setFormat

public void setFormat(Format format)
设置指示可以编辑和显示的合法值的格式。

参数：
format - 用于往返 String 转换的 Format 实例

getFormat

public Format getFormat()
返回指示可以编辑和显示的合法值的格式。

返回：
用于往返 String 转换的 Format 实例

setMinimum

public void setMinimum(Comparable minimum)
设置最小允许值。如果尚未指定 valueClass，且 minimum 为非 null，则 valueClass 将被设置为 minimum 类的值类。

参数：
minimum - 可以输入的最小合法值
另请参见：
DefaultFormatter.setValueClass(java.lang.Class)

getMinimum

public Comparable getMinimum()
返回最小允许值。

返回：
可以输入的最小合法值

setMaximum

public void setMaximum(Comparable max)
设置最大允许值。如果尚未指定 valueClass，且 max 为非 null，则将 valueClass 设置为 max 类的值。

参数：
max - 可以输入的最大合法值
另请参见：
DefaultFormatter.setValueClass(java.lang.Class)

getMaximum

public Comparable getMaximum()
返回最大允许值。

返回：
可以输入的最大合法值

install

public void install(JFormattedTextField ftf)
将 DefaultFormatter 安装到特定的 JFormattedTextField 上。这将调用 valueToString，将 JFormattedTextField 中的当前值转换为 String。此方法稍后将会将 getActions 返回的 Action、getDocumentFilter 返回的 DocumentFilter 和 getNavigationFilter 返回的 NavigationFilter 安装到 JFormattedTextField 上。

如果子类希望在 JFormattedTextField 上安装其他侦听器，则通常只需要重写此方法。

如果在将当前值转换为 String 时存在 ParseException，则这会将文本设置为空 String，并将 JFormattedTextField 标记为正处在无效状态。

尽管这是一个公共方法，但通常仅供 JFormattedTextField 的子类使用。当值发生更改，或内部状态发生更改时，JFormattedTextField 将在适当的时候调用此方法。

覆盖：
类 DefaultFormatter 中的 install
参数：
ftf - 要格式化的 JFormattedTextField，可能为 null，指示未从当前的 JFormattedTextField 安装。

valueToString

public String valueToString(Object value)
                     throws ParseException
返回 Object value 的 String 表示形式。此方法会在当前 Format 上调用 format。

覆盖：
类 DefaultFormatter 中的 valueToString
参数：
value - 要转换的值
返回：
值的 String 表示形式
抛出：
ParseException - 如果在转换时发生错误

stringToValue

public Object stringToValue(String text)
                     throws ParseException
返回 String text 的 Object 表示形式。

覆盖：
类 DefaultFormatter 中的 stringToValue
参数：
text - 要转换的 String
返回：
文本的 Object 表示形式
抛出：
ParseException - 如果转换时发生错误

getFields

public Format.Field[] getFields(int offset)
返回与 offset 处的文本相关的 Format.Field 常量。如果 offset 不是当前文本中的有效位置，这将返回一个空数组。

参数：
offset - 要检查文本的偏移量
返回：
与给定位置的文本相关的 Format.Field 常量。

clone

public Object clone()
             throws CloneNotSupportedException
创建该 DefaultFormatter 的一个副本。

覆盖：
类 DefaultFormatter 中的 clone
返回：
DefaultFormatter 的副本
抛出：
CloneNotSupportedException - 如果对象的类不支持 Cloneable 接口，则重写 clone 方法的子类也会抛出此异常，以指示无法复制某个实例。
另请参见：
Cloneable

getActions

protected Action[] getActions()
如果 getSupportsIncrement 返回 true，则这将返回两个适合增加/减少该值的 Action。

覆盖：
类 JFormattedTextField.AbstractFormatter 中的 getActions
返回：
要在 JFormattedTextField 上安装的 Action 数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTextComponent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 JTextComponent

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.text.JTextComponent
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable
直接已知子类：
JEditorPane, JTextArea, JTextField
public abstract class JTextComponent
extends JComponent
implements Scrollable, Accessible

JTextComponent 是 swing 文本组件的基类。它会试着与 java.awt.TextComponent 类兼容，并且在此理应如此。还提供其他额外灵活性（不包括可插入 UI 和 bean 支持）服务。有关如何使用此类提供的功能的信息，请参阅 The Java Tutorial 中的 General Rules for Using Text Components 一节。

插入符更改
插入符是 swing 文本组件中的可插入对象。将插入符位置和选择的更改通知发送到已向文本组件注册的 CaretListener 接口的实现。如果尚未设置定制插入符，则该 UI 将安装默认插入符。
默认情况下，该插入符会跟踪在事件指派线程上执行的所有更改，并且如果插入发生在插入符位置或之前，或者移除发生在插入符位置之前，则相应地更新其位置。DefaultCaret 尝试使自己可见，这将导致 JScrollPane 内的文本组件发生滚动。DefaultCaret.setUpdatePolicy(int) 方法可以更改默认的插入符行为。
注：不可编辑的文本组件也有插入符，尽管可能不绘制它。

命令
文本组件提供许多可能用于操作组件的命令。这实质上是组件表示其功能的方式。这些都将根据 swing Action 接口使用 TextAction 实现来表示。文本组件支持的命令集合可以使用 getActions() 方法查找。这些操作可以绑定到由按键等触发的键事件上。

文本输入
文本组件支持灵活而且国际化的文本输入，在使用 keymap 和输入法框架的同时维护与 AWT 侦听器模型的兼容性。

Keymap 让应用程序将击键绑定到操作上。为了允许 keymap 在整个多文本组件上共享，它们可以使用扩展 TextAction 的操作。TextAction 可以确定哪个 JTextComponent 最近有或以前有过焦点，并因此成为该操作的执行者（在此情况下，发送到该操作的 ActionEvent 不包含作为其源的目标文本组件）。

input method framework 让文本组件与输入法交互，分隔预处理事件的软件组件，来让用户使用非常有限的几个键盘键输入成千上万个不同的字符。JTextComponent 是该框架的一个活动客户端，因此它可实现与输入法交互的首选用户界面。因此，有些键事件因为受输入法处理而无法到达文本组件，而有些文本输入不是作为键事件而是作为在 InputMethodEvent 内的提交文本到达文本组件的。完整的文本输入是 keyTyped 键事件中的字符和输入法事件中的提交文本的结合。

AWT 侦听器模型让应用程序将事件侦听器附加到组件，以便将事件绑定到操作。Swing 鼓励使用 keymap 替代侦听器，但要通过使用它为侦听器提供获得事件的机会来维护与侦听器的兼容性。

键盘事件和输入法事件通过以下几个阶段进行处理，每个阶段都能使用该事件：

Stage

KeyEvent

InputMethodEvent

1. | 输入法 | （在此处生成）
2. | 焦点管理器
3. | 注册的键侦听器 | 注册的输入法侦听器
4. | 在 JTextComponent 中的输入法处理
5. | 使用当前 keymap 进行 keymap 处理
6. | 在 JComponent 中进行键盘处理（如加速键、组件导航等）

要维护与侦听键事件但不知道输入法事件的应用程序的兼容性，在阶段 4 中的输入法处理会提供不处理输入法事件的组件的兼容性模式。对于这些组件，可将提交文本转换为 keyTyped 键事件，并在阶段 3 开始的键事件管线中进行处理，而不是在输入法事件管线中处理。

默认情况下，组件将创建一个作为默认 keymap 由所有 JTextComponent 实例共享的 keymap（名为 DEFAULT_KEYMAP）。通常，外观实现将安装一个不同的 keymap，以便把另一个 keymap 中找不到的绑定解析为默认 keymap。该绑定最少包括：

  • 将内容插入打印键编辑器。
  • 使用 backspace 和 del 键移除内容。
  • 前后移动的插入符

模型/视图拆分
文本组件具有模型/视图拆分功能。文本组件会将用于表示模型、视图和控制器的对象拉在一起。文本文档模型可以由充当该模型观察者的其他视图共享（如，多个组件可以共享一个文档）。

该图表显示控制器、文档、事件和 ViewFactory 之间的交互

该模型由 Document 接口定义。此模型应提供灵活的文本存储机制，以在编辑过程中跟踪更改，并且可以扩展为更复杂的模型。该模型接口旨在捕获 SGML（用于表示多种内容的系统）提供的表达式功能。每次修改文档都会以 DocumentEvent 形式将更改的详细信息通知给所有观察者，允许视图与模型保持最新。将此事件发送给实现了 DocumentListener 接口且注册为需要正在接受观察的模型的观察者。

位置信息
提供确定视图中文本位置的功能。确定此信息有两个方法，modelToView(int) 和 viewToModel(java.awt.Point)。

撤消/恢复支持
提供对编辑历史机制的支持，以允许进行撤消/恢复操作。默认情况下文本组件本身不提供历史缓冲区，但确实提供可以与历史缓冲区一起使用的 UndoableEdit 记录以提供撤消/恢复支持。该支持由 Document 模型提供，该模型允许用户附加 UndoableEditListener 实现。

线程安全
swing 文本组件对线程安全操作提供一定程度的支持。因为文本组件的可配置性级别高，所以可以回避所提供的保护。该保护主要来自模型，因此 AbstractDocument 的文档会描述提供的假定保护。异步调用的安全方法标记为注释。

换行
有关如果处理换行的讨论，请参阅 DefaultEditorKit。

打印支持
提供了几个 print 方法进行基本文档打印。如果需要更高级的打印，请使用 getPrintable(java.text.MessageFormat, java.text.MessageFormat) 方法。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Document, DocumentEvent, DocumentListener, Caret, CaretEvent, CaretListener, TextUI, View, ViewFactory

嵌套类摘要
class | JTextComponent.AccessibleJTextComponent 此类实现 JTextComponent 类的可访问性支持。
static class | JTextComponent.DropLocation 表示 JTextComponent 的放置位置 (drop location)。
static class | JTextComponent.KeyBinding 用于创建键绑定的绑定记录。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static String | DEFAULT_KEYMAP 将由所有 JTextComponent 实例共享的默认 keymap，除非这些实例已有另一个 keymap 集合。
static String | FOCUS_ACCELERATOR_KEY 焦点加速键的绑定 (bound) 属性名称。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JTextComponent()
创建一个新的 JTextComponent。
方法摘要
void | addCaretListener(CaretListener listener) 添加插入符侦听器，以便侦听任何插入符的更改通知。
void | addInputMethodListener(InputMethodListener l) 添加指定的输入方法侦听器，以接收发自此组件的输入方法事件。
static Keymap | addKeymap(String nm, Keymap parent) 将一个新 keymap 添加到 keymap 层次结构。
void | copy() 将关联文本模型中当前选定的范围传输到系统剪贴板，并在文本模型中保留内容。
void | cut() 将关联文本模型中当前选定的范围传输到系统剪贴板，并从模型中移除内容。
protected void | fireCaretUpdate(CaretEvent e) 通知所有已注册需要此事件类型的通知的侦听器。
AccessibleContext | getAccessibleContext() 获取与此 JTextComponent 关联的 AccessibleContext。
Action[] | getActions() 获取编辑器的命令列表。
Caret | getCaret() 获取允许在视图上进行面向文本导航的插入符。
Color | getCaretColor() 获取用于呈现插入符的当前颜色。
CaretListener[] | getCaretListeners() 返回在此文本组件上已注册的所有插入符侦听器的数组。
int | getCaretPosition() 返回文本组件的文本插入符的位置。
Color | getDisabledTextColor() 获取用于呈现禁用文本的当前颜色。
Document | getDocument() 获取与编辑器关联的模型。
boolean | getDragEnabled() 返回是否启用自动拖动处理。
JTextComponent.DropLocation | getDropLocation() 返回在组件上进行 DnD 操作过程中此组件在视觉上指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。
DropMode | getDropMode() 返回此组件的放置模式。
char | getFocusAccelerator() 返回将导致接收文本组件获取焦点的加速键。
Highlighter | getHighlighter() 获取负责进行高亮显示的对象。
InputMethodRequests | getInputMethodRequests() 获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。
Keymap | getKeymap() 获取当前在此文本组件中活动的 keymap。
static Keymap | getKeymap(String nm) 获取以前添加到文档中的已命名 keymap。
Insets | getMargin() 返回文本组件的边框和它的文本之间的空白。
NavigationFilter | getNavigationFilter() 返回 NavigationFilter。
Dimension | getPreferredScrollableViewportSize() 返回视图组件视口的首选大小。
Printable | getPrintable(MessageFormat headerFormat, MessageFormat footerFormat) 返回一个 Printable，用于打印此 JTextComponent 的内容。
int | getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
boolean | getScrollableTracksViewportHeight() 如果视口总是强制此 Scrollable 的高度与视口高度匹配，则返回 true。
boolean | getScrollableTracksViewportWidth() 如果视口总是强制此 Scrollable 的宽度与视口宽度匹配，则返回 true。
int | getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
String | getSelectedText() 返回此 TextComponent 中包含的选定文本。
Color | getSelectedTextColor() 获取用于呈现选定文本的当前颜色。
Color | getSelectionColor() 获取用于呈现选定的当前颜色。
int | getSelectionEnd() 返回选定文本的结束位置。
int | getSelectionStart() 返回选定文本的起始位置。
String | getText() 返回此 TextComponent 中包含的文本。
String | getText(int offs, int len) 获取由组件表示的文本部分。
String | getToolTipText(MouseEvent event) 返回用作 event 的工具提示的字符串。
TextUI | getUI() 获取此面向文本的编辑器的用户界面工厂。
boolean | isEditable() 返回指示此 TextComponent 是否可编辑的 boolean。
static void | loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions) 加载带有一组绑定的 keymap。
Rectangle | modelToView(int pos) 将模型中给定位置转换为视图坐标系统中的位置。
void | moveCaretPosition(int pos) 将插入符移动到新的位置，同时保留最后一次调用 setCaretPosition 之前定义的标记。
protected String | paramString() 返回此 JTextComponent 的字符串表示形式。
void | paste() 将系统剪贴板的内容传输到关联的文本模型中。
boolean | print() 一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，不打印标题和脚注文本。
boolean | print(MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，打印指定的标题和脚注文本。
boolean | print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive) 打印此 JTextComponent 的内容。
protected void | processInputMethodEvent(InputMethodEvent e) 处理组件上发生的输入方法事件，方法是将其指派到任意已注册的 InputMethodListener 对象。
void | read(Reader in, Object desc) 根据流进行初始化。
void | removeCaretListener(CaretListener listener) 移除插入符侦听器。
static Keymap | removeKeymap(String nm) 移除以前添加到文档中的已命名 keymap。
void | removeNotify() 通知此组件它不再有父组件。
void | replaceSelection(String content) 用给定字符串所表示的新内容替换当前选定的内容。
void | select(int selectionStart, int selectionEnd) 选定指定的开始和结束位置之间的文本。
void | selectAll() 选择 TextComponent 中的所有文本。
void | setCaret(Caret c) 设置要使用的插入符。
void | setCaretColor(Color c) 设置用于呈现插入符的当前颜色。
void | setCaretPosition(int position) 设置 TextComponent 的文本插入符的位置。
void | setComponentOrientation(ComponentOrientation o) 设置语言敏感的方向，用于排序此组件内的元素或文本。
void | setDisabledTextColor(Color c) 设置用于呈现禁用文本的当前颜色。
void | setDocument(Document doc) 将编辑器与文本文档关联。
void | setDragEnabled(boolean b) 开启或关闭自动拖动处理。
void | setDropMode(DropMode dropMode) 设置此组件的放置模式，为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。
void | setEditable(boolean b) 设置指定的 boolean 变量，以指示此 TextComponent 是否应该为可编辑的。
void | setFocusAccelerator(char aKey) 设置将导致接收的文本组件获取焦点的加速键。
void | setHighlighter(Highlighter h) 设置要使用的 highlighter。
void | setKeymap(Keymap map) 设置用于将事件绑定到操作的 keymap。
void | setMargin(Insets m) 设置组件的边框和它的文本之间的空白。
void | setNavigationFilter(NavigationFilter filter) 设置 NavigationFilter。
void | setSelectedTextColor(Color c) 设置用于呈现选定文本的当前颜色。
void | setSelectionColor(Color c) 设置用于呈现选定的当前颜色。
void | setSelectionEnd(int selectionEnd) 将选择结束点设置为指定的位置。
void | setSelectionStart(int selectionStart) 将选定起始点设置为指定的位置。
void | setText(String t) 将此 TextComponent 文本设置为指定文本。
void | setUI(TextUI ui) 设置此面向文本的编辑器的用户界面工厂。
void | updateUI() 重新加载可插入的 UI。
int | viewToModel(Point pt) 将视图坐标系统中的给定位置转换为模型中最具代表性的位置。
void | write(Writer out) 将模型的内容存储到给定的流中。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

FOCUS_ACCELERATOR_KEY

public static final String FOCUS_ACCELERATOR_KEY
焦点加速键的绑定 (bound) 属性名称。

另请参见：
常量字段值

DEFAULT_KEYMAP

public static final String DEFAULT_KEYMAP
将由所有 JTextComponent 实例共享的默认 keymap，除非这些实例已有另一个 keymap 集合。

另请参见：
常量字段值
构造方法详细信息

JTextComponent

public JTextComponent()
创建一个新的 JTextComponent。建立插入符事件的侦听器，并安装可插入的 UI。将组件标记为可编辑状态。不使用任何布局管理器，因为布局受文本的视图子系统管理。文档模型被设置为 null。

方法详细信息

getUI

public TextUI getUI()
获取此面向文本的编辑器的用户界面工厂。

返回：
工厂

setUI

public void setUI(TextUI ui)
设置此面向文本的编辑器的用户界面工厂。

参数：
ui - 工厂

updateUI

public void updateUI()
重新加载可插入的 UI。用于获取新界面的键是 getUIClassID()。该 UI 的类型是 TextUI。设置该 UI 之后调用 invalidate。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

addCaretListener

public void addCaretListener(CaretListener listener)
添加插入符侦听器，以便侦听任何插入符的更改通知。

参数：
listener - 要添加的侦听器
另请参见：
CaretEvent

removeCaretListener

public void removeCaretListener(CaretListener listener)
移除插入符侦听器。

参数：
listener - 要移除的侦听器
另请参见：
CaretEvent

getCaretListeners

public CaretListener[] getCaretListeners()
返回在此文本组件上已注册的所有插入符侦听器的数组。

返回：
组件的所有 CaretListener；如果当前没有注册任何插入符侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addCaretListener(javax.swing.event.CaretListener), removeCaretListener(javax.swing.event.CaretListener)

fireCaretUpdate

protected void fireCaretUpdate(CaretEvent e)
通知所有已注册需要此事件类型的通知的侦听器。使用传入此触发方法的参数延后创建事件实例。侦听器列表按从后往前的方式处理。

参数：
e - 事件
另请参见：
EventListenerList

setDocument

public void setDocument(Document doc)
将编辑器与文本文档关联。使用当前已注册的工厂构建一个文档视图，重新确认后由编辑器显示该文档。PropertyChange 事件 ("document") 被传播到每个侦听器。

参数：
doc - 要显示/编辑的文档
另请参见：
getDocument()

getDocument

public Document getDocument()
获取与编辑器关联的模型。此方法主要是让 UI 以最少的要求成为文本编辑器的声明次数获取。子类将返回通常将用于扩展 Document 的实际模型类型。

返回：
模型

setComponentOrientation

public void setComponentOrientation(ComponentOrientation o)
从类 Component 复制的描述
设置语言敏感的方向，用于排序此组件内的元素或文本。语言敏感的 LayoutManager 和 Component 子类使用此属性来确定如何布局并绘制组件。

在构造时，组件的方向设置为 ComponentOrientation.UNKNOWN，表示尚未显式地指定它。UNKNOWN 方向的行为与 ComponentOrientation.LEFT_TO_RIGHT 相同。

要设置单个组件的方向，请使用此方法。要设置整个组件层次结构的方向，请使用 applyComponentOrientation。

覆盖：
类 Component 中的 setComponentOrientation
另请参见：
ComponentOrientation

getActions

public Action[] getActions()
获取编辑器的命令列表。这是嵌入的 UI 所支持的命令列表，该 UI 通过编辑器本身支持的命令集进行扩充。这些命令对于绑定到事件是很有用的，例如在 keymap 中。

返回：
命令列表

setMargin

public void setMargin(Insets m)
设置组件的边框和它的文本之间的空白。文本组件的默认 Border 对象将使用此值创建适当的空白。不过，如果在文本组件上设置非默认边框，则由 Border 对象负责创建适当的空白（其他情况下实际上忽略此属性）。这会导致重绘该组件。PropertyChange 事件 ("margin") 被发送到所有侦听器。

参数：
m - 边框和文本之间的空间

getMargin

public Insets getMargin()
返回文本组件的边框和它的文本之间的空白。

返回：
空白

setNavigationFilter

public void setNavigationFilter(NavigationFilter filter)
设置 NavigationFilter。NavigationFilter 作为一种限制光标移动的方式由 DefaultCaret 和默认光标移动操作使用。

从以下版本开始：
1.4

getNavigationFilter

public NavigationFilter getNavigationFilter()
返回 NavigationFilter。NavigationFilter 作为一种限制光标移动的方式由 DefaultCaret 和默认光标移动操作使用。null 返回值意味着光标移动和选择不受限制。

返回：
NavigationFilter
从以下版本开始：
1.4

getCaret

public Caret getCaret()
获取允许在视图上进行面向文本导航的插入符。

返回：
插入符

setCaret

public void setCaret(Caret c)
设置要使用的插入符。默认情况下，这将由安装的 UI 设置。如果需要，还可以更改为定制插入符。设置插入符会导致触发一个 PropertyChange 事件 ("caret")。

参数：
c - 插入符
另请参见：
getCaret()

getHighlighter

public Highlighter getHighlighter()
获取负责进行高亮显示的对象。

返回：
highlighter

setHighlighter

public void setHighlighter(Highlighter h)
设置要使用的 highlighter。默认情况下，这将由安装的 UI 设置。如果需要，还可以更改为自定义 highlighter。可以将 highlighter 设置为 null，以禁用它。安装新 highlighter 时，将触发一个 PropertyChange 事件 ("highlighter")。

参数：
h - highlighter
另请参见：
getHighlighter()

setKeymap

public void setKeymap(Keymap map)
设置用于将事件绑定到操作的 keymap。设置为 null 可有效地禁用键盘输入。安装新 keymap 时将触发一个 PropertyChange 事件 ("keymap")。

参数：
map - keymap
另请参见：
getKeymap()

setDragEnabled

public void setDragEnabled(boolean b)
开启或关闭自动拖动处理。要启用自动拖动处理，应该将此属性设置为 true，并且组件的 TransferHandler 必须为非 null。dragEnabled 属性的默认值为 false。

遵守此属性并识别用户拖动动作的作业取决于外观实现，特别是组件的 TextUI。启用自动拖动处理时，只要用户在选择上按下鼠标按钮并将鼠标移动几个像素，多数外观（包括那些子类化 BasicLookAndFeel 的外观）就会开始拖放操作。因此将此属性设置为 true 可以对选择行为产生微妙的影响。

如果在忽略此属性的情况下使用外观，仍然可以通过在组件的 TransferHandler 上调用 exportAsDrag 开始拖放操作。

参数：
b - 是否启用自动拖动处理
抛出：
HeadlessException - 如果 b 为 true，并且 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDragEnabled

public boolean getDragEnabled()
返回是否启用自动拖动处理。

返回：
dragEnabled 属性的值
从以下版本开始：
1.4
另请参见：
setDragEnabled(boolean)

setDropMode

public final void setDropMode(DropMode dropMode)
设置此组件的放置模式，为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。但是，为了便于用户使用，建议使用 DropMode.INSERT。它还提供类似于在文本位置之间的放置操作行为，但这样做时不影响实际文本选择和插入符位置。

JTextComponents 支持以下放置模式：

  • DropMode.USE_SELECTION
  • DropMode.INSERT

放置模式只在此组件具有接受放置的 TransferHandler 时才有意义。

参数：
dropMode - 要使用的放置模式
抛出：
IllegalArgumentException - 如果不支持该放置模式或放置模式为 null
从以下版本开始：
1.6
另请参见：
getDropMode(),
getDropLocation(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDropMode

public final DropMode getDropMode()
返回此组件的放置模式。

返回：
此组件的放置模式
从以下版本开始：
1.6
另请参见：
setDropMode(javax.swing.DropMode)

getDropLocation

public final JTextComponent.DropLocation getDropLocation()
返回在组件上进行 DnD 操作过程中此组件在视觉上指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。

此方法不用于从 TransferHandler 查询放置位置，因为只有在返回 TransferHandler 的 canImport 并允许显示位置后才设置放置位置。

此属性更改时，组件将触发名为 "dropLocation" 的属性更改事件。

返回：
放置位置
从以下版本开始：
1.6
另请参见：
setDropMode(javax.swing.DropMode), TransferHandler.canImport(TransferHandler.TransferSupport)

getKeymap

public Keymap getKeymap()
获取当前在此文本组件中活动的 keymap。

返回：
keymap

addKeymap

public static Keymap addKeymap(String nm,
                               Keymap parent)
将一个新 keymap 添加到 keymap 层次结构。Keymap 绑定自下向上进行解析，所以在子级中指定的属性将重写父级中指定的属性。

参数：
nm - keymap 的名称（必须为文档中命名的 keymap 集合中唯一的一个）；如果 keymap 是未命名的，则该名称可以为 null，但调用者负责管理返回的引用，因为未命名的 keymap 无法按名称获取
parent - 父级 keymap；如果未指定的绑定不需要在其他某个 keymap 中解析，则此 keymap 可以为 null
返回：
keymap

removeKeymap

public static Keymap removeKeymap(String nm)
移除以前添加到文档中的已命名 keymap。具有 null 名称的 Keymap 可以不以此方式移除。

参数：
nm - 要移除的 keymap 的名称
返回：
已移除的 keymap

getKeymap

public static Keymap getKeymap(String nm)
获取以前添加到文档中的已命名 keymap。此 keymap 不与以 null 命名的 keymap 一起使用。

参数：
nm - keymap 的名称
返回：
keymap

loadKeymap

public static void loadKeymap(Keymap map,
                              JTextComponent.KeyBinding[] bindings,
                              Action[] actions)

加载带有一组绑定的 keymap。这可用于取得一个静态定义表，并将它们加载到某个 keymap 中。以下示例说明了将一些键绑定到与 JTextComponent 关联的剪切、复制和粘贴操作。完成此操作的代码片段可能与以下形式一样：

   static final JTextComponent.KeyBinding[] defaultBindings = {
     new JTextComponent.KeyBinding(
       KeyStroke.getKeyStroke(KeyEvent.VK_C, InputEvent.CTRL_MASK),
       DefaultEditorKit.copyAction),
     new JTextComponent.KeyBinding(
       KeyStroke.getKeyStroke(KeyEvent.VK_V, InputEvent.CTRL_MASK),
       DefaultEditorKit.pasteAction),
     new JTextComponent.KeyBinding(
       KeyStroke.getKeyStroke(KeyEvent.VK_X, InputEvent.CTRL_MASK),
       DefaultEditorKit.cutAction),
   };

   JTextComponent c = new JTextPane();
   Keymap k = c.getKeymap();
   JTextComponent.loadKeymap(k, defaultBindings, c.getActions());
绑定和操作的集合可以为空，但必须为非 null。

参数：
map - keymap
bindings - 绑定
actions - 操作集合

getCaretColor

public Color getCaretColor()
获取用于呈现插入符的当前颜色。

返回：
颜色

setCaretColor

public void setCaretColor(Color c)
设置用于呈现插入符的当前颜色。设置为 null 可有效地还原默认颜色。设置颜色会导致触发一个 PropertyChange 事件 ("caretColor")。

参数：
c - 颜色
另请参见：
getCaretColor()

getSelectionColor

public Color getSelectionColor()
获取用于呈现选定的当前颜色。

返回：
颜色

setSelectionColor

public void setSelectionColor(Color c)
设置用于呈现选定的当前颜色。将颜色设置为 null 的方法与设置 Color.white 的方法相同。设置颜色会导致一个 PropertyChange 事件 ("selectionColor")。

参数：
c - 颜色
另请参见：
getSelectionColor()

getSelectedTextColor

public Color getSelectedTextColor()
获取用于呈现选定文本的当前颜色。

返回：
颜色

setSelectedTextColor

public void setSelectedTextColor(Color c)
设置用于呈现选定文本的当前颜色。将颜色设置为 null 的方法与设置 Color.black 的方法相同。设置颜色会导致触发一个 PropertyChange 事件 ("selectedTextColor")。

参数：
c - 颜色
另请参见：
getSelectedTextColor()

getDisabledTextColor

public Color getDisabledTextColor()
获取用于呈现禁用文本的当前颜色。

返回：
颜色

setDisabledTextColor

public void setDisabledTextColor(Color c)
设置用于呈现禁用文本的当前颜色。设置颜色会触发一个 PropertyChange 事件 ("disabledTextColor")。

参数：
c - 颜色
另请参见：
getDisabledTextColor()

replaceSelection

public void replaceSelection(String content)
用给定字符串所表示的新内容替换当前选定的内容。如果没有选择的内容，则该操作插入给定的文本。如果没有替换文本，则该操作移除当前选择的内容。

这是插入内容操作的默认实现使用的一种方法，该操作绑定了 keymap 操作。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
content - 要替换选定内容的内容

getText

public String getText(int offs,
                      int len)
               throws BadLocationException
获取由组件表示的文本部分。如果长度为 0，则返回空字符串。

参数：
offs - 偏移量，该值 >= 0
len - 长度，该值 >= 0
返回：
文本
抛出：
BadLocationException - 如果偏移量或长度无效

modelToView

public Rectangle modelToView(int pos)
                      throws BadLocationException
将模型中给定位置转换为视图坐标系统中的位置。组件大小必须为一个正值才能用于计算此转换（即在确定组件大小之前不能计算布局）。该组件未必是可见或已绘制的。

参数：
pos - 位置，该值 >= 0
返回：
直角坐标，其在坐标系中的位置为 (r.x, r.y)；如果组件尚不具有正值大小，则返回 null。
抛出：
BadLocationException - 如果给定位置不表示关联文档中的有效位置
另请参见：
TextUI.modelToView(javax.swing.text.JTextComponent, int)

viewToModel

public int viewToModel(Point pt)
将视图坐标系统中的给定位置转换为模型中最具代表性的位置。组件大小必须为一个正值才能用于计算此转换（即在确定组件大小之前不能计算布局）。该组件不必是可见或已绘制的。

参数：
pt - 视图中要转换的位置
返回：
文档起始部分的偏移量，该值 >= 0；如果组件尚不具有正值大小，则返回 -1。
另请参见：
TextUI.viewToModel(javax.swing.text.JTextComponent, java.awt.Point)

cut

public void cut()
将关联文本模型中当前选定的范围传输到系统剪贴板，并从模型中移除内容。重新设置当前选定。对于 null 选定不执行任何操作。

另请参见：
Toolkit.getSystemClipboard(), Clipboard

copy

public void copy()
将关联文本模型中当前选定的范围传输到系统剪贴板，并在文本模型中保留内容。当前选定保持原样。对于 null 选定不执行任何操作。

另请参见：
Toolkit.getSystemClipboard(), Clipboard

paste

public void paste()
将系统剪贴板的内容传输到关联的文本模型中。如果在关联视图中有选定的内容，则使用剪贴板的内容替换它。如果没有选定的内容，则将剪贴板插入关联视图中当前插入位置的前面。如果剪贴板为空，则不执行任何操作。

另请参见：
replaceSelection(java.lang.String), Toolkit.getSystemClipboard(), Clipboard

moveCaretPosition

public void moveCaretPosition(int pos)
将插入符移动到新的位置，同时保留最后一次调用 setCaretPosition 之前定义的标记。这就构成了一个选定。如果文档为 null，则不执行任何操作。位置必须在 0 和组件的文本长度之间，否则将抛出异常。

参数：
pos - 位置
抛出：
IllegalArgumentException - 如果 position 提供的值小于 0 或大于组件的文本长度
另请参见：
setCaretPosition(int)

setFocusAccelerator

public void setFocusAccelerator(char aKey)
设置将导致接收的文本组件获取焦点的加速键。加速键将是 alt 键和给定字符（已转换为大写）的修改键。默认情况下，不存在焦点加速键。以前的任何加速键设置都将被取代。'\0' 键设置将被注册，并具有关闭焦点加速键的效果。设置新键时，将触发一个 PropertyChange 事件 (FOCUS_ACCELERATOR_KEY)。

参数：
aKey - 键
另请参见：
getFocusAccelerator()

getFocusAccelerator

public char getFocusAccelerator()
返回将导致接收文本组件获取焦点的加速键。如果没有设置焦点加速键，则返回 '\0'。

返回：
键

read

public void read(Reader in,
                 Object desc)
          throws IOException
根据流进行初始化。此方法创建一个适合于组件类型的模型，并根据流初始化该模型。默认情况下，此方法将以纯文本的方式加载该模型。该模型以前的内容将被丢弃。

参数：
in - 从中读取的流
desc - 描述流的对象；此对象可以是一个字符串、一个 File、一个 URL 等。有些种类的文档（如 html）或许能够使用此信息；如果为非 null，则将其作为文档的属性添加
抛出：
IOException - 如果使用该流初始化
另请参见：
EditorKit.createDefaultDocument(), setDocument(javax.swing.text.Document), PlainDocument

write

public void write(Writer out)
           throws IOException
将模型的内容存储到给定的流中。默认情况下，此方法将以纯文本的方式存储该模型。

参数：
out - 输出流
抛出：
IOException - 如果发生任何 I/O 错误

removeNotify

public void removeNotify()
从类 JComponent 复制的描述
通知此组件它不再有父组件。调用此方法时，移除父组件链中所有已设置的 KeyboardAction。

覆盖：
类 JComponent 中的 removeNotify
另请参见：
JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

setCaretPosition

public void setCaretPosition(int position)
设置 TextComponent 的文本插入符的位置。注意，插入符可跟踪更改，所以如果组件的底层文本被更改，则此位置可能会移动。如果文档为 null，则不执行任何操作。位置必须在 0 和组件的文本长度之间，否则将抛出异常。

参数：
position - 位置
抛出：
IllegalArgumentException - 如果 position 提供的值小于 0 或大于组件的文本长度

getCaretPosition

public int getCaretPosition()
返回文本组件的文本插入符的位置。

返回：
文本组件的文本插入符的位置，该值 >= 0

setText

public void setText(String t)
将此 TextComponent 文本设置为指定文本。如果该文本为 null 或空，则具有只删除旧文本的效果。插入文本时，得到的插入符的位置由该插入符类的实现确定。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。 注意，文本不是绑定属性，所以更改时不触发 PropertyChangeEvent。要侦听文本的更改，请使用 DocumentListener。

参数：
t - 要设置的新文本
另请参见：
getText(int, int), DefaultCaret

getText

public String getText()
返回此 TextComponent 中包含的文本。如果底层文档为 null，则将给出 NullPointerException。注意，文本不是绑定属性，所以更改时不触发 PropertyChangeEvent。要侦听文本的更改，请使用 DocumentListener。

返回：
文本
抛出：
NullPointerException - 如果文档为 null
另请参见：
setText(java.lang.String)

getSelectedText

public String getSelectedText()
返回此 TextComponent 中包含的选定文本。如果选定为 null 或文档为空，则返回 null。

返回：
文本
抛出：
IllegalArgumentException - 如果由于某种原因选定没有到文档的有效映射
另请参见：
setText(java.lang.String)

isEditable

public boolean isEditable()
返回指示此 TextComponent 是否可编辑的 boolean。

返回：
boolean 值
另请参见：
setEditable(boolean)

setEditable

public void setEditable(boolean b)
设置指定的 boolean 变量，以指示此 TextComponent 是否应该为可编辑的。当状态更改时，将触发 PropertyChange 事件（"editable"）。

参数：
b - 要设置的 boolean
另请参见：
isEditable()

getSelectionStart

public int getSelectionStart()
返回选定文本的起始位置。如果是空文档，则返回 0；如果没有选定，则返回点值。

返回：
起始位置，该值 >= 0

setSelectionStart

public void setSelectionStart(int selectionStart)
将选定起始点设置为指定的位置。新的起始点将限制在当前选定的结束点或之前。

这可用于在 java.awt.TextComponent 上调用此方法的代码向后兼容。实现此方法以转发给 Caret 实现，后者是维护实际选定的位置。

参数：
selectionStart - 文本的起始位置，该值 >= 0

getSelectionEnd

public int getSelectionEnd()
返回选定文本的结束位置。如果文本为空，则返回 0；如果没有选择，则返回点值。

返回：
结束位置，该值 >= 0

setSelectionEnd

public void setSelectionEnd(int selectionEnd)
将选择结束点设置为指定的位置。新的结束点限制在当前选定开始位置处或之后。

这可用于在 java.awt.TextComponent 上调用此方法的代码向后兼容。实现此方法以转发 Caret 实现，后者是维护实际选定的位置。

参数：
selectionEnd - 文本的结束位置，该值 >= 0

select

public void select(int selectionStart,
                   int selectionEnd)
选定指定的开始和结束位置之间的文本。

此方法设置选定文本的开始位置和结束位置，并强行限制开始位置必须大于等于零。结束位置必须大于等于开始位置，并大于等于文本组件的文本长度。

如果调用者提供不一致或超出限度的值，则该方法静默地实施这些限制，并且不会失败。要特别指出的是，如果开始位置或结束位置大于文本长度，则将它重置为等于文本长度。如果开始位置小于零，则将它重置为零，如果结束位置小于开始位置，则将它重置为开始位置。

此调用是为向后兼容性提供的。将其作为调用 setCaretPosition 的途径，接着再调用 moveCaretPosition。管理选定的首选方法是直接调用这些方法。

参数：
selectionStart - 文本的起始位置
selectionEnd - 文本的结束位置
另请参见：
setCaretPosition(int), moveCaretPosition(int)

selectAll

public void selectAll()
选择 TextComponent 中的所有文本。在 null 或空文档上不执行任何操作。

getToolTipText

public String getToolTipText(MouseEvent event)
返回用作 event 的工具提示的字符串。这将返回以下内容之一：
  1. 如果 setToolTipText 已使用非 null 值调用，则它将被返回；否则
  2. 在 UI 上调用 getToolTipText 的值将被返回。
默认情况下，JTextComponent 不使用 ToolTipManager 注册它本身。这意味着只有已在 ToolTipManager 上调用了 registerComponent 工具提示才在 TextUI 上显示。

覆盖：
类 JComponent 中的 getToolTipText
参数：
event - 关联事件
返回：
用作 event 的工具提示的字符串
另请参见：
JComponent.setToolTipText(java.lang.String),
TextUI.getToolTipText(javax.swing.text.JTextComponent, java.awt.Point),
ToolTipManager.registerComponent(javax.swing.JComponent)

getPreferredScrollableViewportSize

public Dimension getPreferredScrollableViewportSize()
返回视图组件视口的首选大小。实现此方法以执行返回组件的首选大小的默认行为。

指定者：
接口 Scrollable 中的 getPreferredScrollableViewportSize
返回：
其视图为此 Scrollable 的 JViewport 的 preferredSize
另请参见：
JComponent.getPreferredSize()

getScrollableUnitIncrement

public int getScrollableUnitIncrement(Rectangle visibleRect,
                                      int orientation,
                                      int direction)
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。理想情况下，组件应通过返回需要的距离来处理一个部分公开的行或列，以便完全公开此项。

此操作的默认实现是只返回可视区域的 10%。子类或许能够提供一个更加合理的值。

指定者：
接口 Scrollable 中的 getScrollableUnitIncrement
参数：
visibleRect - 视口中可见的视图区域
orientation - SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL
direction - 小于零向上/左滚动，大于零向下/右滚动
返回：
在指定方向滚动的“单位”增量
抛出：
IllegalArgumentException - 如果方向无效
另请参见：
JScrollBar.setUnitIncrement(int)

getScrollableBlockIncrement

public int getScrollableBlockIncrement(Rectangle visibleRect,
                                       int orientation,
                                       int direction)
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。

此操作的默认实现是只返回可视区域。子类将或许能够提供一个更加合理的值。

指定者：
接口 Scrollable 中的 getScrollableBlockIncrement
参数：
visibleRect - 视口中可见的视图区域
orientation - SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL
direction - 小于零向上/左滚动，大于零向下/右滚动
返回：
在指定方向滚动的“块”增量
另请参见：
JScrollBar.setBlockIncrement(int)

getScrollableTracksViewportWidth

public boolean getScrollableTracksViewportWidth()
如果视口总是强制此 Scrollable 的宽度与视口宽度匹配，则返回 true。例如，支持换行的正常文本视图在这里将返回 true，因为不希望让换行内容超出视口右边界而无法显示。注意，其祖先为 JScrollPane 的 Scrollable 返回 true 可有效地禁用水平滚动。

类似于 JViewport 的滚动容器在每次进行验证时都将使用此方法。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportWidth
返回：
如果视口应该强制 Scrollable 宽度与其自身宽度相匹配，则返回 true

getScrollableTracksViewportHeight

public boolean getScrollableTracksViewportHeight()
如果视口总是强制此 Scrollable 的高度与视口高度匹配，则返回 true。例如，纵行文本视图（按列从左向右流入文本）通过在此处返回 true 可有效地禁用垂直滚动。

类似于 JViewport 的滚动容器在每次进行验证时都将使用此方法。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportHeight
返回：
如果视口强制 Scrollable 高度与其自身高度匹配，则返回 true

print

public boolean print()
              throws PrinterException
一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，不打印标题和脚注文本。注：打印完成前此方法将阻塞。

注：在 headless 模式下，不显示对话框。

此方法调用功能完备的 print 方法执行打印。

返回：
除非用户取消了打印，否则返回 true
抛出：
PrinterException - 如果打印系统中发生导致打印中断的错误
SecurityException - 如果不允许此线程初始化打印作业请求
从以下版本开始：
1.6
另请参见：
print(MessageFormat, MessageFormat, boolean, PrintService, PrintRequestAttributeSet, boolean)

print

public boolean print(MessageFormat headerFormat,
                     MessageFormat footerFormat)
              throws PrinterException
一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，打印指定的标题和脚注文本。注:打印完成前此方法将阻塞。

注：在 headless 模式下，不显示对话框。

此方法调用功能完备的 print 方法执行打印。

参数：
headerFormat - 在 MessageFormat 中用作标题的文本，或者为 null，表示没有标题
footerFormat - 在 MessageFormat 中用作脚注的文本，或者为 null，表示没有脚注
返回：
除非用户取消了打印，否则返回 true
抛出：
PrinterException - 如果打印系统中发生导致作业中断的错误
SecurityException - 如果不允许此线程初始化打印作业请求
从以下版本开始：
1.6
另请参见：
print(MessageFormat, MessageFormat, boolean, PrintService, PrintRequestAttributeSet, boolean), MessageFormat

print

public boolean print(MessageFormat headerFormat,
                     MessageFormat footerFormat,
                     boolean showPrintDialog,
                     PrintService service,
                     PrintRequestAttributeSet attributes,
                     boolean interactive)
              throws PrinterException
打印此 JTextComponent 的内容。注：打印完成前此方法将阻塞。

通过提供 MessageFormat 参数可以将页面标题和脚注文本添加到输出。打印代码从格式中请求 String，提供可能包含于格式化字符串中的单个项：表示当前页数的 Integer。

showPrintDialog boolean 参数允许指定是否向用户显示打印对话框。当向用户显示对话框时，用户可以使用该对话框更改打印属性甚至取消打印。

service 允许为打印对话框提供初始 PrintService；不显示对话框时，允许指定要打印到的 PrintService。

attributes 可用于为打印对话框提供初始值；不显示对话框时，用于提供所有需要的属性。attributes 可用于控制如何打印作业，例如双面 或单面。

interactive boolean 参数允许指定是否在交互 模式下执行打印。如果为 true，则在打印期间显示进度对话框（带有中止选项）。在事件指派线程 上调用 print 时，此对话框为有模式的，否则为无模式的。警告：打印完成前在事件指派线程 上调用此方法（其中 interactive false）将阻塞所有 事件（包括重绘）的处理。建议只有在不具有可见 GUI 的应用程序进行打印时才这样做。

注：在 headless 模式下，忽略 showPrintDialog 和 interactive 参数且不显示对话框。

此方法确保在打印期间不改变 document。要直观地指示它，则在打印期间设置 setEnabled(false)。

此方法使用 getPrintable(java.text.MessageFormat, java.text.MessageFormat) 呈现文档内容。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

示例用法。此代码片断显示了一个跨平台的打印对话框，除非用户取消该对话框，否则在交互 模式下打印 JTextComponent：

 textComponent.print(new MessageFormat("My text component header"),
     new MessageFormat("Footer. Page - {0}"), true, null, null, true);

在事件指派线程 之外执行此代码将在后台 执行打印。以下模式可用于后台 打印：

     FutureTask<Boolean> future =
         new FutureTask<Boolean>(
             new Callable<Boolean>() {
                 public Boolean call() {
                     return textComponent.print(.....);
                 }
             });
     executor.execute(future);

参数：
headerFormat - 在 MessageFormat 中用作标题的文本，或者为 null，表示没有标题
footerFormat - 在 MessageFormat 中用作脚注的文本，或者为 null，表示没有脚注
showPrintDialog - 如果显示打印对话框，则为 true，否则为 false
service - 初始 PrintService，或者为 null，表示使用默认值
attributes - 应用于打印作业的作业属性，或者为 null，表示没有作业属性
interactive - 是否在交互模式下进行打印
返回：
除非用户取消了打印，否则返回 true
抛出：
PrinterException - 如果打印系统中发生了导致作业中断的错误
SecurityException - 如果不允许此线程初始化打印作业请求
从以下版本开始：
1.6
另请参见：
getPrintable(java.text.MessageFormat, java.text.MessageFormat), MessageFormat, GraphicsEnvironment.isHeadless(), FutureTask

getPrintable

public Printable getPrintable(MessageFormat headerFormat,
                              MessageFormat footerFormat)
返回一个 Printable，用于打印此 JTextComponent 的内容。返回的 Printable 以文档在屏幕上呈现的外形对该文档进行打印，为了符合纸张标准重新格式化时除外。返回的 Printable 可包装于另一个 Printable 内，以便创建复杂的报告和文档。

返回的 Printable 与此 JTextComponent 共享 document。开发人员确保使用此 Printable 时不改变 document。打印期间改变 document 将导致不确定的打印行为。

通过提供 MessageFormat 参数可以将页面标题和脚注文本添加到输出。打印代码从格式中请求 String，提供可能包含于格式化字符串中的单个项：表示当前页数的 Integer。

打印时，返回的 Printable 对文档内容进行适当地格式化以适合页面大小。为了能正确的自动换行，所有页面的 imageable width 必须相同。请参阅 PageFormat.getImageableWidth()。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

可以在任意线程上打印返回的 Printable。

返回 Printable 的此实现在事件指派线程 上执行所有打印，而不管是在什么线程上使用它。

参数：
headerFormat - 在 MessageFormat 中用作标题的文本，或者为 null，表示没有标题
footerFormat - 在 MessageFormat 中用作脚注的文本，或者为 null，表示没有脚注
返回：
打印此 JTextComponent 内容时使用的 Printable
从以下版本开始：
1.6
另请参见：
Printable, PageFormat, Document.render(java.lang.Runnable)

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JTextComponent 关联的 AccessibleContext。对于文本组件，AccessibleContext 采用 AccessibleJTextComponent 的形式。如有必要，可以创建一个新的 AccessibleJTextComponent 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
充当此 JTextComponent 的 AccessibleContext 的 AccessibleJTextComponent

paramString

protected String paramString()
返回此 JTextComponent 的字符串表示形式。此方法仅在进行调试的时候使用，返回的字符串的内容和格式在各种实现间可能有所不同。返回的字符串可以为空，但不可以为 null。

重写 paramString 来提供有关 JFC 组件的一些特定新方面的信息。

覆盖：
类 JComponent 中的 paramString
返回：
此 JTextComponent 的字符串表示形式

processInputMethodEvent

protected void processInputMethodEvent(InputMethodEvent e)
从类 Component 复制的描述
处理组件上发生的输入方法事件，方法是将其指派到任意已注册的 InputMethodListener 对象。

如果组件上没有启用输入方法事件，则不调用此方法。发生下列之一时启用输入方法事件：

  • 通过 addInputMethodListener 注册了一个 InputMethodListener 对象。
  • 通过 enableEvents 启用了输入方法事件。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

覆盖：
类 Component 中的 processInputMethodEvent
参数：
e - 输入方法事件
另请参见：
InputMethodEvent, InputMethodListener, Component.addInputMethodListener(java.awt.event.InputMethodListener), Component.enableEvents(long)

getInputMethodRequests

public InputMethodRequests getInputMethodRequests()
从类 Component 复制的描述
获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。支持当场文本输入的组件必须重写此方法，以便返回一个 InputMethodRequests 实例。同时，还必须处理输入方法事件。

覆盖：
类 Component 中的 getInputMethodRequests
返回：
组件的输入方法请求处理程序，默认为 null
另请参见：
Component.addInputMethodListener(java.awt.event.InputMethodListener)

addInputMethodListener

public void addInputMethodListener(InputMethodListener l)
从类 Component 复制的描述
添加指定的输入方法侦听器，以接收发自此组件的输入方法事件。如果组件还重写了 getInputMethodRequests 并返回一个 InputMethodRequests 实例，则该组件只接收发自输入方法的输入方法事件。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

覆盖：
类 Component 中的 addInputMethodListener
参数：
l - 输入方法侦听器
另请参见：
InputMethodEvent,
InputMethodListener,
Component.removeInputMethodListener(java.awt.event.InputMethodListener),
Component.getInputMethodListeners(),
Component.getInputMethodRequests()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTextComponent.AccessibleJTextComponent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 JTextComponent.AccessibleJTextComponent

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.text.JTextComponent.AccessibleJTextComponent
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
直接已知子类：
JEditorPane.AccessibleJEditorPane, JTextArea.AccessibleJTextArea, JTextField.AccessibleJTextField
正在封闭类：
JTextComponent
public class JTextComponent.AccessibleJTextComponent
extends JComponent.AccessibleJComponent
implements AccessibleText, CaretListener, DocumentListener, AccessibleAction, AccessibleEditableText, AccessibleExtendedText

此类实现 JTextComponent 类的可访问性支持。它提供适合菜单用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
从接口 javax.accessibility.AccessibleExtendedText 继承的字段
ATTRIBUTE_RUN, LINE
构造方法摘要
JTextComponent.AccessibleJTextComponent()
构造 AccessibleJTextComponent。
方法摘要
void | caretUpdate(CaretEvent e) 处理插入符更新（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_CARET_PROPERTY 和 AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY）。
void | changedUpdate(DocumentEvent e) 处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | cut(int startIndex, int endIndex) 将两个索引之间的文本剪切到系统剪贴板中。
void | delete(int startIndex, int endIndex) 删除两个索引之间的文本
boolean | doAccessibleAction(int i) 对该对象执行指定的 Action
AccessibleAction | getAccessibleAction() 获取与此对象关联的可支持一个或多个动作的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可用的可访问操作的数目，如果多于一个，则第一个视为该对象的“默认”操作。
String | getAccessibleActionDescription(int i) 返回对该对象的指定操作的描述。
AccessibleEditableText | getAccessibleEditableText() 返回此文本组件的 AccessibleEditableText 接口。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取 JTextComponent 的状态设置。
AccessibleText | getAccessibleText() 获取与此对象关联的 AccessibleText。
String | getAfterIndex(int part, int index) 返回给定索引之后的 String。
String | getAtIndex(int part, int index) 返回给定索引处的 String。
String | getBeforeIndex(int part, int index) 返回给定索引之前的 String。
int | getCaretPosition() 返回插入符的从零开始的偏移量。
AttributeSet | getCharacterAttribute(int i) 返回给定字符（位于给定索引处）的 AttributeSet。
Rectangle | getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
int | getCharCount() 返回字符（有效索引）的数量
int | getIndexAtPoint(Point p) 在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
String | getSelectedText() 返回选定文本的某一部分。
int | getSelectionEnd() 返回选定文本中的结束偏移量。
int | getSelectionStart() 返回选定文本中的起始偏移量。
Rectangle | getTextBounds(int startIndex, int endIndex) 返回包围两个索引之间文本的 Rectangle。
String | getTextRange(int startIndex, int endIndex) 返回两个索引之间的文本字符串。
AccessibleTextSequence | getTextSequenceAfter(int part, int index) 返回给定 index 之后的 AccessibleTextSequence。
AccessibleTextSequence | getTextSequenceAt(int part, int index) 返回给定 index 处的 AccessibleTextSequence。
AccessibleTextSequence | getTextSequenceBefore(int part, int index) 返回给定 index 之前的 AccessibleTextSequence。
void | insertTextAtIndex(int index, String s) 在给定索引处插入指定字符串
void | insertUpdate(DocumentEvent e) 处理文档插入（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | paste(int startIndex) 将系统剪贴板中的文本粘贴到指定索引的文本开始处。
void | removeUpdate(DocumentEvent e) 处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
void | replaceText(int startIndex, int endIndex, String s) 使用指定字符串替换两个索引之间的文本。
void | selectText(int startIndex, int endIndex) 选择两个索引之间的文本。
void | setAttributes(int startIndex, int endIndex, AttributeSet as) 设置两个索引之间的文本的属性。
void | setTextContents(String s) 将文本内容设置为指定字符串。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JTextComponent.AccessibleJTextComponent

public JTextComponent.AccessibleJTextComponent()
构造 AccessibleJTextComponent。添加跟踪插入符更改的侦听器。

方法详细信息

caretUpdate

public void caretUpdate(CaretEvent e)
处理插入符更新（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_CARET_PROPERTY 和 AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY）。此类跟踪内部点位置。当插入符移动时，内部位置就会在触发事件后更新。

指定者：
接口 CaretListener 中的 caretUpdate
参数：
e - CaretEvent

insertUpdate

public void insertUpdate(DocumentEvent e)
处理文档插入（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。此类通过事件跟踪更改的偏移量。

指定者：
接口 DocumentListener 中的 insertUpdate
参数：
e - DocumentEvent

removeUpdate

public void removeUpdate(DocumentEvent e)
处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。此类通过该事件跟踪更改的偏移量。

指定者：
接口 DocumentListener 中的 removeUpdate
参数：
e - DocumentEvent

changedUpdate

public void changedUpdate(DocumentEvent e)
处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。此类通过该事件跟踪更改的偏移量。

指定者：
接口 DocumentListener 中的 changedUpdate
参数：
e - DocumentEvent

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取 JTextComponent 的状态设置。对象的 AccessibleStateSet 是由唯一的 AccessibleState 的集合组成的。对象的 AccessibleStateSet 中的更改将导致为 AccessibleContext.ACCESSIBLE_STATE_PROPERTY 属性触发 PropertyChangeEvent。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象的当前状态设置的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, JComponent.AccessibleJComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象 (AccessibleRole.TEXT) 职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleText

public AccessibleText getAccessibleText()
获取与此对象关联的 AccessibleText。在此类的 Java Accessibility API 实现中，返回此对象，它负责以自己的方式实现 AccessibleText 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
此对象
另请参见：
AccessibleText

getIndexAtPoint

public int getIndexAtPoint(Point p)
在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。如果该点无效，则此方法返回 -1。

指定者：
接口 AccessibleText 中的 getIndexAtPoint
参数：
p - 本地坐标中的 Point
返回：
Point p 之下的、从零开始的字符索引。

getCharacterBounds

public Rectangle getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。以本地坐标形式返回边界。如果索引无效，则返回一个 null 矩形。 如果 JTextComponent 包含在 JScrollPane 中（在此情况下，得到的矩形应该由父坐标组成），则返回的屏幕坐标为“不滚动的坐标”。要使用的好算法是：Accessible a: AccessibleText at = a.getAccessibleText(); AccessibleComponent ac = a.getAccessibleComponent(); Rectangle r = at.getCharacterBounds(); Point p = ac.getLocation(); r.x += p.x; r.y += p.y; 注：JTextComponent 必须具有一个有效大小（例如，它已被添加到其祖先容器是有效顶级窗口的父容器中），以便此方法能够返回一个有意义的（非空）值。

指定者：
接口 AccessibleText 中的 getCharacterBounds
参数：
i - String 中的索引，该值 >= 0
返回：
字符边界框的屏幕坐标

getCharCount

public int getCharCount()
返回字符（有效索引）的数量

指定者：
接口 AccessibleText 中的 getCharCount
返回：
字符数，该值 >= 0

getCaretPosition

public int getCaretPosition()
返回插入符的从零开始的偏移量。 注：插入符右边的那个字符将拥有与偏移量相同的索引值（插入符在两个字符之间）。

指定者：
接口 AccessibleText 中的 getCaretPosition
返回：
插入符的从零开始的偏移量。

getCharacterAttribute

public AttributeSet getCharacterAttribute(int i)
返回给定字符（位于给定索引处）的 AttributeSet。

指定者：
接口 AccessibleText 中的 getCharacterAttribute
参数：
i - 文本中从零开始的索引
返回：
字符的 AttributeSet

getSelectionStart

public int getSelectionStart()
返回选定文本中的起始偏移量。如果没有选择文本，但有一个插入符，则起始偏移量和结束偏移量是相同的。如果文本为空，则返回 0，如果没有选择文本，则返回插入符位置。

指定者：
接口 AccessibleText 中的 getSelectionStart
返回：
选择文本中起始处的索引，该值 >= 0

getSelectionEnd

public int getSelectionEnd()
返回选定文本中的结束偏移量。如果没有选择文本，但有一个插入符，则起始偏移量和结束偏移量是相同的。如果文本为空，则返回 0，如果没有选择文本，则返回插入符位置。

指定者：
接口 AccessibleText 中的 getSelectionEnd
返回：
选择文本中结束处的索引，该值 >= 0

getSelectedText

public String getSelectedText()
返回选定文本的某一部分。

指定者：
接口 AccessibleText 中的 getSelectedText
返回：
文本，如果没有选择文本，则返回 null

getAtIndex

public String getAtIndex(int part,
                         int index)
返回给定索引处的 String。单词之间的空白视为一个单词。

指定者：
接口 AccessibleText 中的 getAtIndex
参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
字母、单词或句子

getAfterIndex

public String getAfterIndex(int part,
                            int index)
返回给定索引之后的 String。单词之间的空白视为一个单词。

指定者：
接口 AccessibleText 中的 getAfterIndex
参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
字母、单词或句子

getBeforeIndex

public String getBeforeIndex(int part,
                             int index)
返回给定索引之前的 String。单词之间的空白视为一个单词。

指定者：
接口 AccessibleText 中的 getBeforeIndex
参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
字母、单词或句子

getAccessibleEditableText

public AccessibleEditableText getAccessibleEditableText()
返回此文本组件的 AccessibleEditableText 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleEditableText
返回：
该 AccessibleEditableText 接口
从以下版本开始：
1.4
另请参见：
AccessibleEditableText

setTextContents

public void setTextContents(String s)
将文本内容设置为指定字符串。

指定者：
接口 AccessibleEditableText 中的 setTextContents
参数：
s - 要设置文本内容的字符串
从以下版本开始：
1.4

insertTextAtIndex

public void insertTextAtIndex(int index,
                              String s)
在给定索引处插入指定字符串

指定者：
接口 AccessibleEditableText 中的 insertTextAtIndex
参数：
index - 将要插入字符串处的文本索引
s - 要插入文本中的字符串
从以下版本开始：
1.4

getTextRange

public String getTextRange(int startIndex,
                           int endIndex)
返回两个索引之间的文本字符串。

指定者：
接口 AccessibleEditableText 中的 getTextRange
指定者：
接口 AccessibleExtendedText 中的 getTextRange
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引
返回：
两个索引之间的文本字符串
从以下版本开始：
1.4

delete

public void delete(int startIndex,
                   int endIndex)
删除两个索引之间的文本

指定者：
接口 AccessibleEditableText 中的 delete
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引
从以下版本开始：
1.4

cut

public void cut(int startIndex,
                int endIndex)
将两个索引之间的文本剪切到系统剪贴板中。

指定者：
接口 AccessibleEditableText 中的 cut
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引
从以下版本开始：
1.4

paste

public void paste(int startIndex)
将系统剪贴板中的文本粘贴到指定索引的文本开始处。

指定者：
接口 AccessibleEditableText 中的 paste
参数：
startIndex - 文本中的开始索引
从以下版本开始：
1.4

replaceText

public void replaceText(int startIndex,
                        int endIndex,
                        String s)
使用指定字符串替换两个索引之间的文本。

指定者：
接口 AccessibleEditableText 中的 replaceText
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引
从以下版本开始：
1.4

selectText

public void selectText(int startIndex,
                       int endIndex)
选择两个索引之间的文本。

指定者：
接口 AccessibleEditableText 中的 selectText
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引
从以下版本开始：
1.4

setAttributes

public void setAttributes(int startIndex,
                          int endIndex,
                          AttributeSet as)
设置两个索引之间的文本的属性。

指定者：
接口 AccessibleEditableText 中的 setAttributes
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引
as - 属性集
从以下版本开始：
1.4
另请参见：
AttributeSet

getTextSequenceAt

public AccessibleTextSequence getTextSequenceAt(int part,
                                                int index)
返回给定 index 处的 AccessibleTextSequence。

指定者：
接口 AccessibleExtendedText 中的 getTextSequenceAt
参数：
part - 要获取的 CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回指定文本的 AccessibleTextSequence。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

getTextSequenceAfter

public AccessibleTextSequence getTextSequenceAfter(int part,
                                                   int index)
返回给定 index 之后的 AccessibleTextSequence。

指定者：
接口 AccessibleExtendedText 中的 getTextSequenceAfter
参数：
part - 要获取的 CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回指定文本的 AccessibleTextSequence。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

getTextSequenceBefore

public AccessibleTextSequence getTextSequenceBefore(int part,
                                                    int index)
返回给定 index 之前的 AccessibleTextSequence。

指定者：
接口 AccessibleExtendedText 中的 getTextSequenceBefore
参数：
part - 要获取的 CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回指定文本的 AccessibleTextSequence。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

getTextBounds

public Rectangle getTextBounds(int startIndex,
                               int endIndex)
返回包围两个索引之间文本的 Rectangle。

指定者：
接口 AccessibleExtendedText 中的 getTextBounds
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结束索引
返回：
如果索引有效，则返回文本的有界矩形。否则，返回 null
从以下版本开始：
1.6

getAccessibleAction

public AccessibleAction getAccessibleAction()
从类 AccessibleContext 复制的描述
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
如果受对象支持，则返回 AccessibleAction；否则返回 null
另请参见：
AccessibleAction

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可用的可访问操作的数目，如果多于一个，则第一个视为该对象的“默认”操作。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
此对象中从 0 开始的 Action 数
从以下版本开始：
1.4

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回对该对象的指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 从 0 开始的操作索引
返回：
该操作的 String 描述
从以下版本开始：
1.4
另请参见：
getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
对该对象执行指定的 Action

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 操作的从零开始的索引
返回：
如果执行了该操作，则返回 true；否则，返回 false。
从以下版本开始：
1.4
另请参见：
getAccessibleActionCount()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTextComponent.DropLocation (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 JTextComponent.DropLocation

java.lang.Object
    继承者  javax.swing.TransferHandler.DropLocation
        继承者  javax.swing.text.JTextComponent.DropLocation
正在封闭类：
JTextComponent
public static final class JTextComponent.DropLocation
extends TransferHandler.DropLocation

表示 JTextComponent 的放置位置 (drop location)。

从以下版本开始：
1.6
另请参见：
JTextComponent.getDropLocation()

方法摘要
Position.Bias | getBias() 返回放置索引的偏差。
int | getIndex() 返回关联组件中应该用来插入放置数据的位置的索引。
String | toString() 返回此放置位置的字符串表示形式。
从类 javax.swing.TransferHandler.DropLocation 继承的方法
getDropPoint
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getIndex

public int getIndex()
返回关联组件中应该用来插入放置数据的位置的索引。此索引表示字符之间的位置，将由插入符来解释。

返回：
放置索引

getBias

public Position.Bias getBias()
返回放置索引的偏差。

返回：
放置偏差

toString

public String toString()
返回此放置位置的字符串表示形式。此方法仅用于调试，对于各个实现，所返回字符串的内容和格式可能有所不同。

覆盖：
类 TransferHandler.DropLocation 中的 toString
返回：
此放置位置的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTextComponent.KeyBinding (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 JTextComponent.KeyBinding

java.lang.Object
    继承者  javax.swing.text.JTextComponent.KeyBinding
正在封闭类：
JTextComponent
public static class JTextComponent.KeyBinding
extends Object

用于创建键绑定的绑定记录。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
String | actionName 键的操作名称。
KeyStroke | key 键。
构造方法摘要
JTextComponent.KeyBinding(KeyStroke key, String actionName)
创建新的键绑定。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

key

public KeyStroke key
键。

actionName

public String actionName
键的操作名称。

构造方法详细信息

JTextComponent.KeyBinding

public JTextComponent.KeyBinding(KeyStroke key,
                                 String actionName)
创建新的键绑定。

参数：
key - 键
actionName - 键的操作名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LabelView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 LabelView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.GlyphView
            继承者  javax.swing.text.LabelView
所有已实现的接口：
Cloneable, SwingConstants, TabableView
直接已知子类：
InlineView
public class LabelView
extends GlyphView
implements TabableView

LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。它缓存用于呈现的字符级属性。

嵌套类摘要
从类 javax.swing.text.GlyphView 继承的嵌套类/接口
GlyphView.GlyphPainter
字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
LabelView(Element elem)
构造在元素上包装的新视图。
方法摘要
void | changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
Color | getBackground() 获取用于呈现字形的背景色。
Font | getFont() 获取字形应该以其为依据的字体。
protected FontMetrics | getFontMetrics() 已过时。 FontMetrics 不用于在 JDK 中运行时的字形呈现。
Color | getForeground() 获取用于呈现字形的前景色。
boolean | isStrikeThrough() 确定字形是否应该有删除线。
boolean | isSubscript() 确定字形是否应该呈现为上标。
boolean | isSuperscript() 确定字形是否应该呈现为下标。
boolean | isUnderline() 确定字形是否应加下划线。
protected void | setBackground(Color bg) 设置视图的背景色。
protected void | setPropertiesFromAttributes() 从属性集设置缓存的属性。
protected void | setStrikeThrough(boolean s) 设置视图是否具有删除线。
protected void | setSubscript(boolean s) 设置视图是否有下标。
protected void | setSuperscript(boolean s) 设置视图是否有上标。
protected void | setUnderline(boolean u) 设置视图是否加下划线。
从类 javax.swing.text.GlyphView 继承的方法
breakView, checkPainter, clone, createFragment, getAlignment, getBreakWeight, getEndOffset, getGlyphPainter, getNextVisualPositionFrom, getPartialSpan, getPreferredSpan, getStartOffset, getTabbedSpan, getTabExpander, getText, insertUpdate, modelToView, paint, removeUpdate, setGlyphPainter, viewToModel
从类 javax.swing.text.View 继承的方法
append, forwardUpdate, forwardUpdateToView, getAttributes, getChildAllocation, getContainer, getDocument, getElement, getGraphics, getMaximumSpan, getMinimumSpan, getParent, getResizeWeight, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, setSize, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.text.TabableView 继承的方法
getPartialSpan, getTabbedSpan

构造方法详细信息

LabelView

public LabelView(Element elem)
构造在元素上包装的新视图。

参数：
elem - 元素
方法详细信息

setUnderline

protected void setUnderline(boolean u)
设置视图是否加下划线。注意，此 setter 受保护，其真正意图仅为确定是否需要在设置时更新某些附加状态。

参数：
u - 如果视图加下划线，则为 true；否则为 false
另请参见：
isUnderline()

setStrikeThrough

protected void setStrikeThrough(boolean s)
设置视图是否具有删除线。注意，此 setter 受保护，其真正意图仅为确定是否需要在设置时更新某些附加状态。

参数：
s - 如果视图有删除线，则为 true；否则为 false
另请参见：
isStrikeThrough()

setSuperscript

protected void setSuperscript(boolean s)
设置视图是否有上标。注意，此 setter 受保护，其真正意图仅为确定是否需要在设置时更新某些附加状态。

参数：
s - 如果视图有上标，则为 true；否则为 false
另请参见：
isSuperscript()

setSubscript

protected void setSubscript(boolean s)
设置视图是否有下标。注意，此 setter 受保护，其真正意图仅为确定是否需要在设置时更新某些附加状态。

参数：
s - 如果视图有下标，则为 true；否则为 false
另请参见：
isSubscript()

setBackground

protected void setBackground(Color bg)
设置视图的背景色。此方法通常作为配置此 View 的一部分调用。如果需要自定义背景色，则应重写 setPropertiesFromAttributes 并调用此方法。null 值指示不应呈现背景，这样将始终显示父级 View 的背景。

参数：
bg - 背景色，或 null
从以下版本开始：
1.5
另请参见：
setPropertiesFromAttributes()

setPropertiesFromAttributes

protected void setPropertiesFromAttributes()
从属性集设置缓存的属性。

getFontMetrics

@Deprecated
protected FontMetrics getFontMetrics()
已过时。 FontMetrics 不用于在 JDK 中运行时的字形呈现。

获取用于此视图的 FontMetrics。

getBackground

public Color getBackground()
获取用于呈现字形的背景色。实现此方法以返回缓存的背景色，该颜色默认为 null。

覆盖：
类 GlyphView 中的 getBackground
返回：
缓存的背景色
从以下版本开始：
1.3

getForeground

public Color getForeground()
获取用于呈现字形的前景色。实现此方法以返回缓存的前景色，该颜色默认为 null。

覆盖：
类 GlyphView 中的 getForeground
返回：
缓存的前景色
从以下版本开始：
1.3

getFont

public Font getFont()
获取字形应该以其为依据的字体。实现此方法以返回缓存的字体。

覆盖：
类 GlyphView 中的 getFont
返回：
缓存的字体

isUnderline

public boolean isUnderline()
确定字形是否应加下划线。如果为 true，则应通过基线绘制下划线。实现此方法以返回缓存的 underline 属性。

当请求此属性时，LabelView 会重新将其状态与 Element 的 AttributeSet 属性同步。如果 Element 的 AttributeSet 没有此属性设置，则它将转换为 false。

覆盖：
类 GlyphView 中的 isUnderline
返回：
缓存的 underline 属性的值
从以下版本开始：
1.3

isStrikeThrough

public boolean isStrikeThrough()
确定字形是否应该有删除线。如果为 true，则会通过字形的中心划线。实现此方法以返回缓存的 strikeThrough 属性。

当请求此属性时，LabelView 会重新将其状态与 Element 的 AttributeSet 属性同步。如果 Element 的 AttributeSet 没有此属性设置，则它将转换为 false。

覆盖：
类 GlyphView 中的 isStrikeThrough
返回：
缓存的 strikeThrough 属性的值
从以下版本开始：
1.3

isSubscript

public boolean isSubscript()
确定字形是否应该呈现为上标。

覆盖：
类 GlyphView 中的 isSubscript
返回：
缓存的 subscript 属性的值

当请求此属性时，LabelView 会重新将其状态与 Element 的 AttributeSet 属性同步。如果 Element 的 AttributeSet 没有此属性设置，则它将转换为 false。

从以下版本开始：
1.3

isSuperscript

public boolean isSuperscript()
确定字形是否应该呈现为下标。

当请求此属性时，LabelView 会重新将其状态与 Element 的 AttributeSet 属性同步。如果 Element 的 AttributeSet 没有此属性设置，则它将转换为 false。

覆盖：
类 GlyphView 中的 isSuperscript
返回：
缓存的 superscript 属性的值
从以下版本开始：
1.3

changedUpdate

public void changedUpdate(DocumentEvent e,
                          Shape a,
                          ViewFactory f)
发出通知，通知文档此视图负责的位置处的属性已更改。

覆盖：
类 GlyphView 中的 changedUpdate
参数：
e - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayeredHighlighter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 LayeredHighlighter

java.lang.Object
    继承者  javax.swing.text.LayeredHighlighter
所有已实现的接口：
Highlighter
直接已知子类：
DefaultHighlighter
public abstract class LayeredHighlighter
extends Object
implements Highlighter

另请参见：
Highlighter

嵌套类摘要
static class LayeredHighlighter.LayerPainter
分层的高亮显示渲染器。
从接口 javax.swing.text.Highlighter 继承的嵌套类/接口
Highlighter.Highlight, Highlighter.HighlightPainter
构造方法摘要
LayeredHighlighter()
方法摘要
abstract  void paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
当叶 View（如 LabelView）呈现时，它们应调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.text.Highlighter 继承的方法
addHighlight, changeHighlight, deinstall, getHighlights, install, paint, removeAllHighlights, removeHighlight

构造方法详细信息

LayeredHighlighter

public LayeredHighlighter()
方法详细信息

paintLayeredHighlights

public abstract void paintLayeredHighlights(Graphics g,
                                            int p0,
                                            int p1,
                                            Shape viewBounds,
                                            JTextComponent editor,
                                            View view)
当叶 View（如 LabelView）呈现时，它们应调用此方法。如果高亮显示处在给定的区域，则它将立即被绘制。

参数：
g - 用于绘制的图形
p0 - 视图的起始偏移量
p1 - 视图的结束偏移量
viewBounds - 视图的边界
editor - JTextComponent
view - 正在呈现的视图实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayeredHighlighter.LayerPainter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 LayeredHighlighter.LayerPainter

java.lang.Object
    继承者  javax.swing.text.LayeredHighlighter.LayerPainter
所有已实现的接口：
Highlighter.HighlightPainter
直接已知子类：
DefaultHighlighter.DefaultHighlightPainter
正在封闭类：
LayeredHighlighter
public abstract static class LayeredHighlighter.LayerPainter
extends Object
implements Highlighter.HighlightPainter

分层的高亮显示渲染器。

构造方法摘要
LayeredHighlighter.LayerPainter()
方法摘要
abstract  Shape paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.text.Highlighter.HighlightPainter 继承的方法
paint

构造方法详细信息

LayeredHighlighter.LayerPainter

public LayeredHighlighter.LayerPainter()
方法详细信息

paintLayer

public abstract Shape paintLayer(Graphics g,
                                 int p0,
                                 int p1,
                                 Shape viewBounds,
                                 JTextComponent editor,
                                 View view)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutQueue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 LayoutQueue

java.lang.Object
    继承者  javax.swing.text.LayoutQueue

public class LayoutQueue
extends Object

文本布局任务的队列。

从以下版本开始：
1.3
另请参见：
AsyncBoxView

构造方法摘要
LayoutQueue()
构造一个布局队列。
方法摘要
void | addTask(Runnable task) 添加一个任务，该任务不必立即执行，原因是其结果可能是不可见的。
static LayoutQueue | getDefaultQueue() 返回默认的布局队列。
static void | setDefaultQueue(LayoutQueue q) 设置默认的布局队列。
protected Runnable | waitForWork() 由 worker 线程使用以获取一个要执行的新任务
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LayoutQueue

public LayoutQueue()
构造一个布局队列。

方法详细信息

getDefaultQueue

public static LayoutQueue getDefaultQueue()
返回默认的布局队列。

setDefaultQueue

public static void setDefaultQueue(LayoutQueue q)
设置默认的布局队列。

参数：
q - 新队列。

addTask

public void addTask(Runnable task)
添加一个任务，该任务不必立即执行，原因是其结果可能是不可见的。

waitForWork

protected Runnable waitForWork()
由 worker 线程使用以获取一个要执行的新任务

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MaskFormatter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 MaskFormatter

java.lang.Object
    继承者  javax.swing.JFormattedTextField.AbstractFormatter
        继承者  javax.swing.text.DefaultFormatter
            继承者  javax.swing.text.MaskFormatter
所有已实现的接口：
Serializable, Cloneable
public class MaskFormatter
extends DefaultFormatter

MaskFormatter 用于格式化和编辑字符串。MaskFormatter 的行为通过 String 掩码控制，该掩码指定可以包含在 Document 模型中特定位置的有效字符。可以指定以下字符：

字符 | 描述
# | 任何有效数字，使用 Character.isDigit。
' | 转义字符，用于避开任何具有特殊格式的字符。
U | 任何字符 (Character.isLetter)。将所有小写字母映射为大写。
L | 任何字符 (Character.isLetter)。将所有大写字母映射为小写。
A | 任何字符或数字（Character.isLetter 或 Character.isDigit）
? | 任何字符 (Character.isLetter)。
* | 所有字符。
H | 任何十六进制字符（0-9、a-f 或 A-F）。

字符通常对应于一个 char，但在某些语言中不是这样。掩码是以单个字符为基础的，因此可以任意调整 char 数量来满足需要。

可以进一步限制可通过 setInvalidCharacters 和 setValidCharacters 方法输入的字符。setInvalidCharacters 允许指定哪些字符无效。setValidCharacters 允许指定哪些字符有效。例如，以下代码块与具有无效/有效字符的 '0xHHH' 掩码等效：

 MaskFormatter formatter = new MaskFormatter("0x***");
 formatter.setValidCharacters("0123456789abcdefABCDEF");

最初格式化值时，如果字符串的长度小于掩码的长度，则可能发生以下两种情况。要么使用占位符字符串，要么使用占位符字符。优先考虑使用占位符字符串。例如：

   MaskFormatter formatter = new MaskFormatter("###-####");
   formatter.setPlaceholderCharacter('_');
   formatter.getDisplayValue(tf, "123");

可能生成字符串 '123-____'。如果已调用 setPlaceholder("555-1212")，则生成 '123-1212'。占位符字符串只用于初始格式，后续格式只使用占位符字符。

如果 MaskFormatter 配置为只允许有效字符 (setAllowsInvalid(false))，则在编辑时将根据需要跳过字面值字符。假定 MaskFormatter 带有掩码 "###-####"，且当前值为 "555-1212"。使用右箭头键通过字段导航将生成（| 指示插入符的位置）：

   |555-1212
   5|55-1212
   55|5-1212
   555-|1212
   555-1|212
'-' 为字面值（不可编辑的）字符，将跳过这一字符。

编辑时会导致类似行为。假定在前一示例中将字符串 '123-45' 和 '12345' 插入 MaskFormatter。两项插入都将导致相同的字符串 '123-45__'。MaskFormatter 在字符位置 3（即 '-'）处理插入时，可能发生以下两种情况：

  1. 如果插入的字符是 '-'，则接受它。
  2. 如果插入的字符与下一个非字面值字符的掩码匹配，则在新位置接受它。
  3. 其他任何情况都将导致无效的编辑

默认情况下，MaskFormatter 将不允许无效编辑，您可以使用 setAllowsInvalid 方法更改此设置，并在有效编辑状态提交编辑（使用 setCommitsOnValidEdit 更改此设置）。

默认情况下，MaskFormatter 处于改写模式。也就是说，键入字符时不插入新字符，而是使用新键入的字符替换当前位置的字符。可以通过方法 setOverwriteMode 更改此行为。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4

构造方法摘要
MaskFormatter()
创建一个不带掩码的 MaskFormatter。
MaskFormatter(String mask)
创建具有指定掩码的 MaskFormatter。
方法摘要
String | getInvalidCharacters() 返回输入无效的字符。
String | getMask() 返回格式化掩码。
String | getPlaceholder() 如果值未完全填充掩码，则返回要使用的 String。
char | getPlaceholderCharacter() 返回用来替代值中没有的字符的字符（即用户必须填充它们）。
String | getValidCharacters() 返回可以输入的有效字符。
boolean | getValueContainsLiteralCharacters() 如果 stringToValue 应该返回掩码中的字面值，则返回 true。
void | install(JFormattedTextField ftf) 将 DefaultFormatter 安装在特定的 JFormattedTextField 上。
void | setInvalidCharacters(String invalidCharacters) 允许进一步限制可以输入的字符。
void | setMask(String mask) 设置指示合法字符的掩码。
void | setPlaceholder(String placeholder) 设置值未完全填充掩码时要使用的字符串。
void | setPlaceholderCharacter(char placeholder) 设置一个字符，用来替代值中不存在的字符（即用户必须填充它们）。
void | setValidCharacters(String validCharacters) 允许进一步限制可以输入的字符。
void | setValueContainsLiteralCharacters(boolean containsLiteralChars) 如果为 true，则返回的值和设置的值还将包含掩码中的字面值字符。
Object | stringToValue(String value) 解析文本，返回 String value 的适当 Object 表示形式。
String | valueToString(Object value) 返回基于掩码的 Object value 的 String 表示形式。
从类 javax.swing.text.DefaultFormatter 继承的方法
clone, getAllowsInvalid, getCommitsOnValidEdit, getDocumentFilter, getNavigationFilter, getOverwriteMode, getValueClass, setAllowsInvalid, setCommitsOnValidEdit, setOverwriteMode, setValueClass
从类 javax.swing.JFormattedTextField.AbstractFormatter 继承的方法
getActions, getFormattedTextField, invalidEdit, setEditValid, uninstall
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MaskFormatter

public MaskFormatter()
创建一个不带掩码的 MaskFormatter。

MaskFormatter

public MaskFormatter(String mask)
              throws ParseException
创建具有指定掩码的 MaskFormatter。如果 mask 不是有效掩码，则抛出 ParseException。

抛出：
ParseException - 如果掩码不包含有效掩码字符
方法详细信息

setMask

public void setMask(String mask)
             throws ParseException
设置指示合法字符的掩码。如果 mask 无效，这将抛出一个 ParseException。

抛出：
ParseException - 如果掩码不包含有效掩码字符

getMask

public String getMask()
返回格式化掩码。

返回：
指示合法字符值的掩码。

setValidCharacters

public void setValidCharacters(String validCharacters)
允许进一步限制可以输入的字符。只允许输入在掩码中指定的（不是 invalidCharacters，而是 validCharacters）字符。传入 null（默认）意味着有效字符只由掩码和无效字符限定范围。

参数：
validCharacters - 如果为非 null，则指定合法字符。

getValidCharacters

public String getValidCharacters()
返回可以输入的有效字符。

返回：
合法字符

setInvalidCharacters

public void setInvalidCharacters(String invalidCharacters)
允许进一步限制可以输入的字符。只允许输入在掩码中指定的（不是 invalidCharacters，而是 validCharacters）字符。传入 null （默认）意味着有效字符只由掩码和有效字符限定范围。

参数：
invalidCharacters - 如果为非 null，则指定非法字符。

getInvalidCharacters

public String getInvalidCharacters()
返回输入无效的字符。

返回：
非法字符。

setPlaceholder

public void setPlaceholder(String placeholder)
设置值未完全填充掩码时要使用的字符串。null 值意味着应该使用占位字符。

参数：
placeholder - 值未完全填充掩码的情况下格式化时使用的字符串

getPlaceholder

public String getPlaceholder()
如果值未完全填充掩码，则返回要使用的 String。

返回：
如果值未完全填充掩码，则返回格式化时使用的 String

setPlaceholderCharacter

public void setPlaceholderCharacter(char placeholder)
设置一个字符，用来替代值中不存在的字符（即用户必须填充它们）。默认值为一个空格。

此方法仅适用于占位符字符串尚未指定，或未完全填充掩码的情况。

参数：
placeholder - 如果值未完全填充掩码，则为格式化时使用的 Character

getPlaceholderCharacter

public char getPlaceholderCharacter()
返回用来替代值中没有的字符的字符（即用户必须填充它们）。

返回：
如果值未完全填充掩码，则返回格式化时使用的 Character

setValueContainsLiteralCharacters

public void setValueContainsLiteralCharacters(boolean containsLiteralChars)
如果为 true，则返回的值和设置的值还将包含掩码中的字面值字符。

例如，如果掩码为 '(###) ###-####'，当前值为 '(415) 555-1212'，且 valueContainsLiteralCharacters 为 true，则 stringToValue 将返回 '(415) 555-1212'。另一方面，如果 valueContainsLiteralCharacters 为 false，则 stringToValue 将返回 '4155551212'。

参数：
containsLiteralChars - 用于指示掩码中的字面值是否应该在 stringToValue 中返回。

getValueContainsLiteralCharacters

public boolean getValueContainsLiteralCharacters()
如果 stringToValue 应该返回掩码中的字面值，则返回 true。

返回：
如果掩码中的字面值应该在 stringToValue 中返回，则返回 True

stringToValue

public Object stringToValue(String value)
                     throws ParseException
解析文本，返回 String value 的适当 Object 表示形式。此方法将在必要时将字面值字符分开并调用超类 stringToValue，所以，如果已指定了值类 (setValueClass)，则将创建它的一个实例。如果该值与当前掩码不匹配，这将抛出一个 ParseException。有关如何处理字面值的详细信息，请参阅 setValueContainsLiteralCharacters(boolean)。

覆盖：
类 DefaultFormatter 中的 stringToValue
参数：
value - 要转换的字符串
返回：
文本的 Object 表示形式
抛出：
ParseException - 如果在转换时发生错误
另请参见：
setValueContainsLiteralCharacters(boolean)

valueToString

public String valueToString(Object value)
                     throws ParseException
返回基于掩码的 Object value 的 String 表示形式。有关如何处理字面值的详细信息，请参阅 setValueContainsLiteralCharacters(boolean)。

覆盖：
类 DefaultFormatter 中的 valueToString
参数：
value - 要转换的 Value
返回：
值的 String 表示形式
抛出：
ParseException - 如果在转换时发生错误
另请参见：
setValueContainsLiteralCharacters(boolean)

install

public void install(JFormattedTextField ftf)
将 DefaultFormatter 安装在特定的 JFormattedTextField 上。这将调用 valueToString，将 JFormattedTextField 中的当前值转换为 String。此方法稍后将会把 getActions 返回的 Action、getDocumentFilter 返回的 DocumentFilter 和 getNavigationFilter 返回的 NavigationFilter 安装到 JFormattedTextField 上。

如果子类希望在 JFormattedTextField 上安装其他侦听器，则通常只需要重写此方法。

如果在将当前值转换为 String 时存在 ParseException，则这会将文本设置为空 String，并将 JFormattedTextField 标记为正处在无效状态。

尽管这是一个公共方法，但通常仅供 JFormattedTextField 的子类使用。当值发生更改，或内部状态发生更改时，JFormattedTextField 将在适当的时候调用此方法。

覆盖：
类 DefaultFormatter 中的 install
参数：
ftf - 要格式化为的 JFormattedTextField，可以为 null，这指示从当前的 JFormattedTextField 卸载。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MutableAttributeSet (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 MutableAttributeSet

所有超级接口：
AttributeSet
所有已知子接口：
Style
所有已知实现类：
AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement, SimpleAttributeSet, StyleContext.NamedStyle
public interface MutableAttributeSet
extends AttributeSet

独特属性的可变集合的通用接口。 实现可能需要提供以下形式的构造方法：public XXXAttributeSet(ConstAttributeSet source);

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
方法摘要
void | addAttribute(Object name, Object value) 创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。
void | addAttributes(AttributeSet attributes) 创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。
void | removeAttribute(Object name) 移除具有给定 name 的属性。
void | removeAttributes(AttributeSet attributes) 移除具有给定 name 的属性集。
void | removeAttributes(Enumeration<?> names) 移除具有给定 name 的属性集。
void | setResolveParent(AttributeSet parent) 设置正解析的父级。
从接口 javax.swing.text.AttributeSet 继承的方法
containsAttribute, containsAttributes, copyAttributes, getAttribute, getAttributeCount, getAttributeNames, getResolveParent, isDefined, isEqual

方法详细信息

addAttribute

void addAttribute(Object name,
                  Object value)
创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。该对象必须是不可变的，或者说不能由任何客户端改变。

参数：
name - 名称
value - 值

addAttributes

void addAttributes(AttributeSet attributes)
创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。

参数：
attributes - 属性集

removeAttribute

void removeAttribute(Object name)
移除具有给定 name 的属性。

参数：
name - 属性名称

removeAttributes

void removeAttributes(Enumeration<?> names)
移除具有给定 name 的属性集。

参数：
names - 名称集

removeAttributes

void removeAttributes(AttributeSet attributes)
移除具有给定 name 的属性集。

参数：
attributes - 属性集

setResolveParent

void setResolveParent(AttributeSet parent)
设置正解析的父级。如果某个属性未在本地定义，则它就是要进行解析的属性集。

参数：
parent - 父级
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NavigationFilter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 NavigationFilter

java.lang.Object
    继承者  javax.swing.text.NavigationFilter

public class NavigationFilter
extends Object

NavigationFilter 可用于限制光标的定位。当默认光标定位操作尝试重新定位光标时，它们将调用 NavigationFilter，（假定 JTextComponent 有一个非 null NavigationFilter 集合）。通过这种方式，NavigationFilter 可以有效地限制光标定位。同样，当用户更改选定内容以进一步限定光标的位置时，DefaultCaret 将调用 NavigationFilter。

子类可以有条件地调用超类实现以限制可以放置光标的位置，或者直接调用 FilterBypass。

从以下版本开始：
1.4
另请参见：
Caret, DefaultCaret, View

嵌套类摘要
static class NavigationFilter.FilterBypass
用作防止回调插入符以定位光标的方式。
构造方法摘要
NavigationFilter()
方法摘要
int | getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet) 返回从现在位置起的下一个放置插入符的可视位置。
void | moveDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 移动点之前调用。
void | setDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 设置点之前调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NavigationFilter

public NavigationFilter()
方法详细信息

setDot

public void setDot(NavigationFilter.FilterBypass fb,
                   int dot,
                   Position.Bias bias)
在 Caret 设置点之前调用。默认实现直接调用具有传入参数的 FilterBypass。子类可能希望有条件地调用具有不同位置的超类，或在 FilterBypass 上调用必需的方法。

参数：
fb - 可用于改变插入符位置的 FilterBypass
dot - 位置，该值 >= 0
bias - 距所在点的偏差

moveDot

public void moveDot(NavigationFilter.FilterBypass fb,
                    int dot,
                    Position.Bias bias)
在 Caret 移动点之前调用。默认实现直接调用具有传入参数的 FilterBypass。子类可能希望有条件地调用具有不同位置的超类，或在 FilterBypass 上调用必需的方法。

参数：
fb - 可用于改变插入符位置的 FilterBypass
dot - 位置，该值 >= 0
bias - 新位置的偏差

getNextVisualPositionFrom

public int getNextVisualPositionFrom(JTextComponent text,
                                     int pos,
                                     Position.Bias bias,
                                     int direction,
                                     Position.Bias[] biasRet)
                              throws BadLocationException
返回从现在位置起的下一个放置插入符的可视位置。默认实现只将该方法转发给根视图。子类可能希望根据其他标准进一步限制放置插入符的位置。

参数：
text - 包含文本的 JTextComponent
pos - 用于确定下一个位置的位置
bias - 用于确定下一个位置的偏差
direction - 相对于当前位置的方向，可以视为通常在键盘上找到的方向键。它将是以下值之一：
  • SwingConstants.WEST
  • SwingConstants.EAST
  • SwingConstants.NORTH
  • SwingConstants.SOUTH
biasRet - 用于返回下一个位置的偏差结果
返回：
此模型中最能表示下一个可见位置的位置
抛出：
BadLocationException
IllegalArgumentException - 如果 direction 不是上面的合法值之一
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NavigationFilter.FilterBypass (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 NavigationFilter.FilterBypass

java.lang.Object
    继承者  javax.swing.text.NavigationFilter.FilterBypass
正在封闭类：
NavigationFilter
public abstract static class NavigationFilter.FilterBypass
extends Object

用作防止回调插入符以定位光标的方式。希望支持 NavigationFilter 的插入符实现必须提供一个不回调 NavigationFilter 的实现。

从以下版本开始：
1.4

构造方法摘要
NavigationFilter.FilterBypass()
方法摘要
abstract Caret | getCaret() 返回不断变化的 Caret。
abstract void | moveDot(int dot, Position.Bias bias) 移动插入符的位置，并跳过 NavigationFilter。
abstract void | setDot(int dot, Position.Bias bias) 设置插入符的位置，并跳过 NavigationFilter。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NavigationFilter.FilterBypass

public NavigationFilter.FilterBypass()
方法详细信息

getCaret

public abstract Caret getCaret()
返回不断变化的 Caret。

返回：
不断变化的 Caret

setDot

public abstract void setDot(int dot,
                            Position.Bias bias)
设置插入符的位置，并跳过 NavigationFilter。

参数：
dot - 位置，该值 >= 0
bias - 到点所在位置处的偏差

moveDot

public abstract void moveDot(int dot,
                             Position.Bias bias)
移动插入符的位置，并跳过 NavigationFilter。

参数：
dot - 位置，该值 >= 0
bias - 新位置的偏差
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumberFormatter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 NumberFormatter

java.lang.Object
    继承者  javax.swing.JFormattedTextField.AbstractFormatter
        继承者  javax.swing.text.DefaultFormatter
            继承者  javax.swing.text.InternationalFormatter
                继承者  javax.swing.text.NumberFormatter
所有已实现的接口：
Serializable, Cloneable
public class NumberFormatter
extends InternationalFormatter

添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。使用的规范（这些规范只在 NumberFormatter 不显示无效数字时使用，如 setAllowsInvalid(false)）有：

  • 在除指数字段外的任何字段中按下 +/-（- 由与 DecimalFormat 相关的 DecimalFormatSymbols 确定）将试图把数的符号更改为正/负。
  • 在指数字段中按下 +/-（- 由与 DecimalFormat 相关的 DecimalFormatSymbols 确定）将试图把指数符号更改为正/负。

如果要显示特定数字，则可能希望打开改写模式 setOverwriteMode(true)。例如：

 DecimalFormat decimalFormat = new DecimalFormat("0.000E0");
 NumberFormatter textFormatter = new NumberFormatter(decimalFormat);
 textFormatter.setOverwriteMode(true);
 textFormatter.setAllowsInvalid(false);

如果打算允许用户输入小数值，则应强制 DecimalFormat 至少包含一个小数 (#.0###)，或允许该值无效 setAllowsInvalid(true)。否则，用户可能无法输入小数值。

NumberFormatter 提供的 stringToValue 行为与其超类的这一行为稍有不同。如果已为 DefaultFormatter.setValueClass(java.lang.Class) 值（也就是 Integer、Long、Float、Double、Byte 或 Short 之一）指定了某个类，并且 Format 的 parseObject 返回一个 Number 的实例，则将使用适合于该值类表示的基本类型的构造方法创建一个该值类的对应实例。例如：setValueClass(Integer.class) 将导致结果值通过 new Integer(((Number)formatter.parseObject(string)).intValue()) 创建。通常，当希望设置最小/最大值时此方法很有用，因为各种 Number 实现一般不相互比较。如果由于某种原因需要某些值的特定 Number 实现，此方法也非常有用。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4

构造方法摘要
NumberFormatter()
创建具有默认 NumberFormat 实例的 NumberFormatter，该实例通过 NumberFormat.getNumberInstance() 获得。
NumberFormatter(NumberFormat format)
创建具有指定 Format 实例的 NumberFormatter。
方法摘要
 void setFormat(Format format)
设置指示可以编辑和显示的合法值的格式。
从类 javax.swing.text.InternationalFormatter 继承的方法
clone, getActions, getFields, getFormat, getMaximum, getMinimum, install, setMaximum, setMinimum, stringToValue, valueToString
从类 javax.swing.text.DefaultFormatter 继承的方法
getAllowsInvalid, getCommitsOnValidEdit, getDocumentFilter, getNavigationFilter, getOverwriteMode, getValueClass, setAllowsInvalid, setCommitsOnValidEdit, setOverwriteMode, setValueClass
从类 javax.swing.JFormattedTextField.AbstractFormatter 继承的方法
getFormattedTextField, invalidEdit, setEditValid, uninstall
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NumberFormatter

public NumberFormatter()
创建具有默认 NumberFormat 实例的 NumberFormatter，该实例通过 NumberFormat.getNumberInstance() 获得。

NumberFormatter

public NumberFormatter(NumberFormat format)
创建具有指定 Format 实例的 NumberFormatter。

参数：
format - 用于指示合法值的 Format
方法详细信息

setFormat

public void setFormat(Format format)
设置指示可以编辑和显示的合法值的格式。

如果已经使用了默认构造方法，则将通过 NumberFormat.getNumberInstance() 方法为当前语言环境确定此属性值。

覆盖：
类 InternationalFormatter 中的 setFormat
参数：
format - 用于指示合法值的 NumberFormat 实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParagraphView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 ParagraphView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.FlowView
                    继承者  javax.swing.text.ParagraphView
所有已实现的接口：
SwingConstants, TabExpander
直接已知子类：
ParagraphView
public class ParagraphView
extends FlowView
implements TabExpander

存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。它基本上是周围有空白的纵向框。该框的内容是一组行，这些行是特殊的横向框。此视图创建表示段落元素的子元素的视图集合。如果这些视图合适，则可将其中的每个视图直接放到行中；否则，将调用 breakView 方法尝试将视图切割成合适的片段。

另请参见：
View

嵌套类摘要
从类 javax.swing.text.FlowView 继承的嵌套类/接口
FlowView.FlowStrategy
字段摘要
protected  int firstLineIndent
相对于左边的 inset 进行的第一行的缩进。
从类 javax.swing.text.FlowView 继承的字段
layoutPool, layoutSpan, strategy
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
ParagraphView(Element elem)
创建给定元素的 ParagraphView。
方法摘要
protected void | adjustRow(javax.swing.text.ParagraphView.Row r, int desiredSpan, int x) 如有可能，调整给定行以使其处于布局区域内。
View | breakView(int axis, float len, Shape a) 以给定的长度在给定的轴上拆分此视图。
void | changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected View | createRow() 创建用于在流中存储子级行值的 View。
protected int | findOffsetToCharactersInString(char[] string, int start) 根据 string 中字符查找文档中的下一个字符，起点是偏移量 start。
protected boolean | flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图要布置的方向。
float | getAlignment(int axis) 确定此视图沿某轴所需的对齐方式。
int | getBreakWeight(int axis, float len) 获取给定位置的拆分权重。
protected int | getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x) 返回最接近 x 处的模型位置。
int | getFlowSpan(int index) 获取给定子索引流入的约束区域。
int | getFlowStart(int index) 获取沿流轴的流区域开始位置。
protected View | getLayoutView(int index) 返回给定 index 处的视图。
protected int | getLayoutViewCount() 返回此视图负责的视图数。
protected int | getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 在东或西方向返回光标的下一个可视位置。
protected float | getPartialSize(int startOffset, int endOffset) 返回 startOffset 和 endOffset 之间的视图使用的大小。
protected float | getTabBase() 返回从中计算制表符的位置。
protected TabSet | getTabSet() 获取计算制表符时使用的 Tabset。
float | nextTabStop(float x, int tabOffset) 返回给定了参照位置的下一个制表符位位置。
void | paint(Graphics g, Shape a) 使用给定的呈现面和该面上的区域进行呈现。
protected void | setFirstLineIndent(float fi) 设置第一行的行缩进量。
protected void | setJustification(int j) 设置对齐方式的类型。
protected void | setLineSpacing(float ls) 设置行间距。
protected void | setPropertiesFromAttributes() 从属性集设置缓存的属性。
从类 javax.swing.text.FlowView 继承的方法
calculateMinorAxisRequirements, getFlowAxis, getViewIndexAtPosition, insertUpdate, layout, loadChildren, removeUpdate, setParent
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, forwardUpdate, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, isVisible, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

firstLineIndent

protected int firstLineIndent
相对于左边的 inset 进行的第一行的缩进。

构造方法详细信息

ParagraphView

public ParagraphView(Element elem)
创建给定元素的 ParagraphView。

参数：
elem - 此视图负责的元素
方法详细信息

setJustification

protected void setJustification(int j)
设置对齐方式的类型。

参数：
j - 为下列值之一：
  • StyleConstants.ALIGN_LEFT
  • StyleConstants.ALIGN_CENTER
  • StyleConstants.ALIGN_RIGHT

setLineSpacing

protected void setLineSpacing(float ls)
设置行间距。

参数：
ls - 该值为行高的因子

setFirstLineIndent

protected void setFirstLineIndent(float fi)
设置第一行的行缩进量。

参数：
fi - 以磅 (point) 为单位的值

setPropertiesFromAttributes

protected void setPropertiesFromAttributes()
从属性集设置缓存的属性。

getLayoutViewCount

protected int getLayoutViewCount()
返回此视图负责的视图数。段落的子视图是已用于安排表示子元素的 View 片段的行。这是平铺在两个维数之间的视图数，此数应等于此视图负责的元素的子元素数。

返回：
此 ParagraphView 负责的视图数

getLayoutView

protected View getLayoutView(int index)
返回给定 index 处的视图。段落的子视图是已用于安排表示子元素的 View 片段的行。此方法返回负责子元素索引的视图（拆分前）。这些是从工厂生成（以表示子元素）且用于布局的 View。

参数：
index - 所需视图的 index
返回：
index 处的视图

adjustRow

protected void adjustRow(javax.swing.text.ParagraphView.Row r,
                         int desiredSpan,
                         int x)
如有可能，调整给定行以使其处于布局区域内。默认情况下，此操作将试图能在最接近行结尾的位置找到最高拆分权重。如果遇到强制拆分，则该拆分将定位于强制拆分的位置。

这是内部用法，不应直接使用。

参数：
r - 要调整到当前布局区域内的行
desiredSpan - 当前布局区域，该值 >= 0
x - r 开始处的位置

getNextNorthSouthVisualPositionFrom

protected int getNextNorthSouthVisualPositionFrom(int pos,
                                                  Position.Bias b,
                                                  Shape a,
                                                  int direction,
                                                  Position.Bias[] biasRet)
                                           throws BadLocationException
在东或西方向返回光标的下一个可视位置。通过 CompositeView 重写。

覆盖：
类 CompositeView 中的 getNextNorthSouthVisualPositionFrom
参数：
pos - 模型中的位置
b - Position.Bias.Forward 或 Position.Bias.Backward
a - 要呈现的分配区域
direction - SwingConstants.NORTH 或 SwingConstants.SOUTH
biasRet - 包含以此方法查到的偏差的数组
返回：
模型中表示下一个位置可视处的位置
抛出：
BadLocationException
另请参见：
CompositeView.getNextVisualPositionFrom(int, javax.swing.text.Position.Bias, java.awt.Shape, int, javax.swing.text.Position.Bias[])

getClosestPositionTo

protected int getClosestPositionTo(int pos,
                                   Position.Bias b,
                                   Shape a,
                                   int direction,
                                   Position.Bias[] biasRet,
                                   int rowIndex,
                                   int x)
                            throws BadLocationException
返回最接近 x 处的模型位置。rowIndex 是要在其中查找的视图对应的索引。

参数：
pos - 模型中的位置
a - 要呈现的分配区域
direction - 它是以下值之一：
  • SwingConstants.NORTH
  • SwingConstants.SOUTH
biasRet - 包含在此方法中查到的偏差的数组
rowIndex - 视图的索引
x - 需要的 x 坐标
返回：
最接近 x 的模型位置
抛出：
BadLocationException

flipEastAndWestAtEnds

protected boolean flipEastAndWestAtEnds(int position,
                                        Position.Bias bias)
确定下一个视图要布置的方向。假定 View 位于索引 n 处，通常 View 是从左向右放置的，所以在东面的 View 将位于索引 n + 1 处，在西面的 View 将位于索引 n - 1 处。在某些情况下（例如双向文本中）有可能东面的 View 不是位于 n + 1 处，而是位于 n - 1 处，或者西面的 View 不是位于 n - 1 处，而是位于索引 n + 1 处。这种情况下，该方法将返回 true，指示 View 按降序放置。

如果文本在某个位置从右向左布置，则返回 true；否则返回 false。

覆盖：
类 BoxView 中的 flipEastAndWestAtEnds
参数：
position - 模型中的位置
bias - Position.Bias.Forward 或 Position.Bias.Backward
返回：
如果文本在某个位置从右向左布置，则返回 true；否则返回 false。

getFlowSpan

public int getFlowSpan(int index)
获取给定子索引流入的约束区域。

覆盖：
类 FlowView 中的 getFlowSpan
参数：
index - 查询视图的索引
返回：
在 index 处给定视图的约束区域
从以下版本开始：
1.3
另请参见：
FlowView.getFlowStart(int)

getFlowStart

public int getFlowStart(int index)
获取沿流轴的流区域开始位置。

覆盖：
类 FlowView 中的 getFlowStart
参数：
index - 查询视图的索引
返回：
在 index 处给定视图的位置
从以下版本开始：
1.3
另请参见：
FlowView.getFlowSpan(int)

createRow

protected View createRow()
创建用于在流中存储子级行值的 View。

指定者：
类 FlowView 中的 createRow
返回：
新的 View
从以下版本开始：
1.3

nextTabStop

public float nextTabStop(float x,
                         int tabOffset)
返回给定了参照位置的下一个制表符位位置。此视图实现制表符坐标系，并在布局进程中在逻辑子级上调用 getTabbedSpan，以确定该子级所需的区域。逻辑子级可以将其制表符扩展委托给知道如何扩展制表符的段落。LabelView 是将其制表符扩展需要委托给段落的视图的示例。

实现此方法以尝试在段落元素的属性集合中查找 TabSet。如果能找到一个制表符集，将使用其设置；否则将提供默认扩展。制表符扩展的基本位置是段落左部最近分配的位置（即子级布局的依据）。

指定者：
接口 TabExpander 中的 nextTabStop
参数：
x - X 引用位置
tabOffset - 在文本流内放置制表符的位置，该值 >= 0
返回：
制表符扩展的尾端，该值 >= 0
另请参见：
TabSet, TabStop, LabelView

getTabSet

protected TabSet getTabSet()
获取计算制表符时使用的 Tabset。

返回：
TabSet

getPartialSize

protected float getPartialSize(int startOffset,
                               int endOffset)
返回 startOffset 和 endOffset 之间的视图使用的大小。如果子视图实现 TabableView 接口，则此方法将使用 getPartialView 计算该大小。如果需要某个大小，并且 View 未实现 TabableView 接口，则使用 preferredSpan。

参数：
startOffset - 起始文档偏移量，该值 >= 0
endOffset - 结束文档偏移量，该值 >= startOffset
返回：
大小，该值 >= 0

findOffsetToCharactersInString

protected int findOffsetToCharactersInString(char[] string,
                                             int start)
根据 string 中字符查找文档中的下一个字符，起点是偏移量 start。如果找不到字符，则返回 -1。

参数：
string - 由字符组成的字符串
start - 模型中的起始位置，该值 >= 0
返回：
文档偏移量；如果找不到字符，则返回 -1

getTabBase

protected float getTabBase()
返回从中计算制表符的位置。

返回：
从中计算制表符的位置

paint

public void paint(Graphics g,
                  Shape a)
使用给定的呈现面和该面上的区域进行呈现。实现此方法以便在拆分用作制表符计算的基坐标之后委托给超类。

覆盖：
类 BoxView 中的 paint
参数：
g - 要使用的呈现表面
a - 分配的要在其中呈现的区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getAlignment

public float getAlignment(int axis)
确定此视图沿某轴所需的对齐方式。实现此方法以使第一行中心沿 y 轴对齐，而默认是沿 x 轴对齐。

覆盖：
类 BoxView 中的 getAlignment
参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
返回：
所需的对齐方式。这应是 0.0 和 1.0 之间的值，其中 0.0 指示原点对齐，1.0 指示原点以外的整个区域对齐。0.5 对齐方式指视图中心对齐。

breakView

public View breakView(int axis,
                      float len,
                      Shape a)
以给定的长度在给定的轴上拆分此视图。

ParagraphView 实例只可沿 Y_AXIS 且只在 len 位于第一行之后时拆分。

参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
len - 指定沿给定轴可能需要拆分的位置，该值 >= 0
a - 视图的当前分配区域
返回：
如果视图可以拆分，则返回表示给定区域的视图片段；如果视图不支持拆分行为，则返回视图本身
另请参见：
View.breakView(int, int, float, float)

getBreakWeight

public int getBreakWeight(int axis,
                          float len)
获取给定位置的拆分权重。

ParagraphView 实例只沿 Y_AXIS 且只在 len 位于第一行之后拆分。如果长度小于一行，则返回 BadBreakWeight 的值。

参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
len - 指定可能需要拆分的位置，该值 >= 0
返回：
指示在此处拆分的可能性；GoodBreakWeight 或 BadBreakWeight
另请参见：
View.getBreakWeight(int, float, float)

changedUpdate

public void changedUpdate(DocumentEvent changes,
                          Shape a,
                          ViewFactory f)
发出通知，通知文档中此视图负责的某个位置的属性已更改。

覆盖：
类 FlowView 中的 changedUpdate
参数：
changes - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PasswordView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 PasswordView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.PlainView
            继承者  javax.swing.text.FieldView
                继承者  javax.swing.text.PasswordView
所有已实现的接口：
SwingConstants, TabExpander
public class PasswordView
extends FieldView

实现适用于 JPasswordField UI 实现的视图。这基本上是一个将其内容呈现为在相关组件中指定的回显字符的字段 ui（如果其能将组件收缩为 JPasswordField）。

另请参见：
View

字段摘要
从类 javax.swing.text.PlainView 继承的字段
metrics
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
PasswordView(Element elem)
构造在元素上包装的新视图。
方法摘要
protected int | drawEchoCharacter(Graphics g, int x, int y, char c) 呈现回显字符，或呈现用来显示密码字符的图形。
protected int | drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为选定文本。
protected int | drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为正常的未选定文本。
float | getPreferredSpan(int axis) 确定此视图沿某轴的首选区域。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
int | viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
从类 javax.swing.text.FieldView 继承的方法
adjustAllocation, getFontMetrics, getResizeWeight, insertUpdate, paint, removeUpdate
从类 javax.swing.text.PlainView 继承的方法
changedUpdate, damageLineRange, drawLine, getLineBuffer, getTabSize, lineToRect, nextTabStop, setSize, updateDamage, updateMetrics
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PasswordView

public PasswordView(Element elem)
构造在元素上包装的新视图。

参数：
elem - 元素
方法详细信息

drawUnselectedText

protected int drawUnselectedText(Graphics g,
                                 int x,
                                 int y,
                                 int p0,
                                 int p1)
                          throws BadLocationException
将模型中给定的范围呈现为正常的未选定文本。此方法可设置前景色，并能使用 getEchoChar() 返回的值回显字符。

覆盖：
类 PlainView 中的 drawUnselectedText
参数：
g - 图形上下文
x - 起始 X 坐标，该值 >= 0
y - 起始 Y 坐标，该值 >= 0
p0 - 模型中的起始偏移量，该值 >= 0
p1 - 模型中的结束偏移量，该值 >= p0
返回：
范围结束处的 X 位置，该值 >= 0
抛出：
BadLocationException - 如果 p0 或 p1 超出范围

drawSelectedText

protected int drawSelectedText(Graphics g,
                               int x,
                               int y,
                               int p0,
                               int p1)
                        throws BadLocationException
将模型中给定的范围呈现为选定文本。实现此方法以使用承载组件中指定的颜色呈现文本。假定 highlighter 将呈现选定的背景。使用 getEchoChar() 的结果显示字符。

覆盖：
类 PlainView 中的 drawSelectedText
参数：
g - 图形上下文
x - 起始 X 坐标，该值 >= 0
y - 起始 Y 坐标，该值 >= 0
p0 - 模型中的起始偏移量，该值 >= 0
p1 - 模型中的结束偏移量，该值 >= p0
返回：
范围结束处的 X 位置，该值 >= 0
抛出：
BadLocationException - 如果 p0 或 p1 超出范围

drawEchoCharacter

protected int drawEchoCharacter(Graphics g,
                                int x,
                                int y,
                                char c)
呈现回显字符，或呈现用来显示密码字符的图形。将 Graphics 对象中的颜色设置为选定文本或未选定文本的适当前景色。

参数：
g - 图形上下文
x - 起始 X 坐标，该值 >= 0
y - 起始 Y 坐标，该值 >= 0
c - 回显字符
返回：
更新的 X 位置，该值 >= 0

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

覆盖：
类 FieldView 中的 modelToView
参数：
pos - 要转换的位置，其值 >= 0
a - 分配的要在其中呈现的区域
b - 当位置是两个视图的边界时，该参数是离由偏移量表示的前一个字符或者下一个字符的偏差；b 将是这些值之一：
  • Position.Bias.Forward
  • Position.Bias.Backward
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置在所关联的文档中不是一个有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public int viewToModel(float fx,
                       float fy,
                       Shape a,
                       Position.Bias[] bias)
提供从视图坐标空间到该模型的逻辑坐标空间的映射。

覆盖：
类 FieldView 中的 viewToModel
参数：
fx - X 坐标，该值 >= 0.0f
fy - Y 坐标，该值 >= 0.0f
a - 要在其中呈现的分配区域
返回：
模型中最能代表视图中给定点的位置
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某轴的首选区域。

覆盖：
类 FieldView 中的 getPreferredSpan
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，该值 >= 0。通常会告知该视图在返回的区域中呈现，但不保证一定如此。父级可选择重新调整视图大小或拆分视图。
另请参见：
View.getPreferredSpan(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PlainDocument (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 PlainDocument

java.lang.Object
    继承者  javax.swing.text.AbstractDocument
        继承者  javax.swing.text.PlainDocument
所有已实现的接口：
Serializable, Document
public class PlainDocument
extends AbstractDocument

维护无任何字符属性的普通文档。此文档的默认元素结构是文本中的行的映射。由 getDefaultRootElement 返回的 Element 是行的映射，且每个子元素表示一行。此模型不维护任何字符级属性，但每行都可以用一个任意的属性集来标记。使用默认的根元素可以快速执行从行到偏移量和从偏移量到行的转换。由编辑激发的 DocumentEvent 的结构信息将指示行结构的更改。

默认的内容存储管理是通过间隙缓冲区实现 (GapContent) 执行的。如果编辑是连续的或集群化的（正如常见的那样），此操作支持对大型文档的高效合理编辑。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Document, AbstractDocument

嵌套类摘要
从类 javax.swing.text.AbstractDocument 继承的嵌套类/接口
AbstractDocument.AbstractElement, AbstractDocument.AttributeContext, AbstractDocument.BranchElement, AbstractDocument.Content, AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractDocument.LeafElement
字段摘要
static String | lineLimitAttribute 指定行的最大长度的属性名称（如果有最大长度）。
static String | tabSizeAttribute 指定内容中包含的制表符大小的属性名称。
从类 javax.swing.text.AbstractDocument 继承的字段
BAD_LOCATION, BidiElementName, ContentElementName, ElementNameAttribute, listenerList, ParagraphElementName, SectionElementName
从接口 javax.swing.text.Document 继承的字段
StreamDescriptionProperty, TitleProperty
构造方法摘要
PlainDocument()
构造一个纯文本文档。
PlainDocument(AbstractDocument.Content c)
构造一个纯文本文档。
方法摘要
protected AbstractDocument.AbstractElement | createDefaultRoot() 创建用于表示默认文档结构的根元素。
Element | getDefaultRootElement() 获取文档模型的默认根元素。
Element | getParagraphElement(int pos) 获取包含给定位置的段落元素。
void | insertString(int offs, String str, AttributeSet a) 向文档中插入某些内容。
protected void | insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 随文本插入更新文档结构。
protected void | removeUpdate(AbstractDocument.DefaultDocumentEvent chng) 随文本的移除更新任何文档结构。
从类 javax.swing.text.AbstractDocument 继承的方法
addDocumentListener, addUndoableEditListener, createBranchElement, createLeafElement, createPosition, dump, fireChangedUpdate, fireInsertUpdate, fireRemoveUpdate, fireUndoableEditUpdate, getAsynchronousLoadPriority, getAttributeContext, getBidiRootElement, getContent, getCurrentWriter, getDocumentFilter, getDocumentListeners, getDocumentProperties, getEndPosition, getLength, getListeners, getProperty, getRootElements, getStartPosition, getText, getText, getUndoableEditListeners, postRemoveUpdate, putProperty, readLock, readUnlock, remove, removeDocumentListener, removeUndoableEditListener, render, replace, setAsynchronousLoadPriority, setDocumentFilter, setDocumentProperties, writeLock, writeUnlock
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

tabSizeAttribute

public static final String tabSizeAttribute
指定内容中包含的制表符大小的属性名称。值的类型为 Integer。

另请参见：
常量字段值

lineLimitAttribute

public static final String lineLimitAttribute
指定行的最大长度的属性名称（如果有最大长度）。值的类型为 Integer。

另请参见：
常量字段值
构造方法详细信息

PlainDocument

public PlainDocument()
构造一个纯文本文档。构造和设置一个使用 GapContent 的默认模型。

PlainDocument

public PlainDocument(AbstractDocument.Content c)
构造一个纯文本文档。创建一个默认的根元素，并将制表符大小设置为 8。

参数：
c - 内容容器
方法详细信息

insertString

public void insertString(int offs,
                         String str,
                         AttributeSet a)
                  throws BadLocationException
向文档中插入某些内容。插入内容会导致在实际发生改变时存储写锁定，接着会向线程上抓取该写入锁定的观察者发出通知。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 Document 中的 insertString
覆盖：
类 AbstractDocument 中的 insertString
参数：
offs - 起始偏移量，该值 >= 0
str - 要插入的字符串；null/空字符串不执行任何操作
a - 插入内容的属性
抛出：
BadLocationException - 如果给定的插入位置不是文档中的有效位置
另请参见：
Document.insertString(int, java.lang.String, javax.swing.text.AttributeSet)

getDefaultRootElement

public Element getDefaultRootElement()
获取文档模型的默认根元素。

指定者：
接口 Document 中的 getDefaultRootElement
指定者：
类 AbstractDocument 中的 getDefaultRootElement
返回：
根
另请参见：
Document.getDefaultRootElement()

createDefaultRoot

protected AbstractDocument.AbstractElement createDefaultRoot()
创建用于表示默认文档结构的根元素。

返回：
基本元素

getParagraphElement

public Element getParagraphElement(int pos)
获取包含给定位置的段落元素。因为此文档只模型化行，所以返回的应为行。

指定者：
类 AbstractDocument 中的 getParagraphElement
参数：
pos - 起始偏移量，该值 >= 0
返回：
元素

insertUpdate

protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng,
                            AttributeSet attr)
随文本插入更新文档结构。这将在写锁定内发生。因为此文档只映射出行，所以只刷新行映射。

覆盖：
类 AbstractDocument 中的 insertUpdate
参数：
chng - 描述编辑的更改事件
attr - 插入文本的属性集

removeUpdate

protected void removeUpdate(AbstractDocument.DefaultDocumentEvent chng)
随文本的移除更新任何文档结构。这将在写锁定内发生。因为此结构只表示行映射，所以此方法只检查是否移除行间距。如果是，移除区域外的两行将合并在一起。

覆盖：
类 AbstractDocument 中的 removeUpdate
参数：
chng - 描述编辑的更改事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PlainView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 PlainView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.PlainView
所有已实现的接口：
SwingConstants, TabExpander
直接已知子类：
FieldView
public class PlainView
extends View
implements TabExpander

实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。该视图用每个子元素表示文本的某一行。

另请参见：
View

字段摘要
protected  FontMetrics metrics
当前字体的字体规格。
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
PlainView(Element elem)
构造在元素上包装的新 PlainView。
方法摘要
void | changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected void | damageLineRange(int line0, int line1, Shape a, Component host) 重新绘制给定的行范围。
protected void | drawLine(int lineIndex, Graphics g, int x, int y) 呈现文本的某一行，取消末尾的空白并扩展所有的制表符。
protected int | drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为选定文本。
protected int | drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为正常的未选定文本。
protected Segment | getLineBuffer() 提供对可用于从相关文档获取文本的缓冲区的访问。
float | getPreferredSpan(int axis) 确定此视图沿某轴的首选区域。
protected int | getTabSize() 返回文档中制表符大小的集合，默认值是 8。
void | insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
protected Rectangle | lineToRect(Shape a, int line) 确定表示给定行的矩形。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
float | nextTabStop(float x, int tabOffset) 在给定引用位置之后，返回下一个制表符停靠位的位置。
void | paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
void | removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | setSize(float width, float height) 设置视图的大小。
protected void | updateDamage(DocumentEvent changes, Shape a, ViewFactory f) 重新绘制给定文档事件覆盖的更改区域。
protected void | updateMetrics() 检查字体规格和最长行是否最新。
int | viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getAlignment, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

metrics

protected FontMetrics metrics
当前字体的字体规格。

构造方法详细信息

PlainView

public PlainView(Element elem)
构造在元素上包装的新 PlainView。

参数：
elem - 元素
方法详细信息

getTabSize

protected int getTabSize()
返回文档中制表符大小的集合，默认值是 8。

返回：
制表符大小

drawLine

protected void drawLine(int lineIndex,
                        Graphics g,
                        int x,
                        int y)
呈现文本的某一行，取消末尾的空白并扩展所有的制表符。实现此方法以调用方法 drawUnselectedText 和 drawSelectedText，这样可定制呈现选定和未选定文本的方法。

参数：
lineIndex - 要绘制的行，该值 >= 0
g - Graphics 上下文
x - 起始 X 位置，该值 >= 0
y - 起始 Y 位置 >= 0
另请参见：
drawUnselectedText(java.awt.Graphics, int, int, int, int), drawSelectedText(java.awt.Graphics, int, int, int, int)

drawUnselectedText

protected int drawUnselectedText(Graphics g,
                                 int x,
                                 int y,
                                 int p0,
                                 int p1)
                          throws BadLocationException
将模型中给定的范围呈现为正常的未选定文本。使用前景色或禁用的颜色呈现文本。

参数：
g - 图形上下文
x - 起始 X 坐标，该值 >= 0
y - 起始 Y 坐标，该值 >= 0
p0 - 模型中的起始位置，该值 >= 0
p1 - 模型中的结束位置，该值 >= 0
返回：
范围末尾的 X 位置，该值 >= 0
抛出：
BadLocationException - 如果范围无效

drawSelectedText

protected int drawSelectedText(Graphics g,
                               int x,
                               int y,
                               int p0,
                               int p1)
                        throws BadLocationException
将模型中给定的范围呈现为选定文本。实现此方法以使用承载组件中指定的颜色呈现文本。假定轮廓色将呈现选定的背景。

参数：
g - 图形上下文
x - 起始 X 坐标，该值 >= 0
y - 起始 Y 坐标，该值 >= 0
p0 - 模型中的起始位置，该值 >= 0
p1 - 模型中的结束位置，该值 >= 0
返回：
范围末尾的位置
抛出：
BadLocationException - 如果范围无效

getLineBuffer

protected final Segment getLineBuffer()
提供对可用于从相关文档获取文本的缓冲区的访问。

返回：
缓冲区

updateMetrics

protected void updateMetrics()
检查字体规格和最长行是否最新。

从以下版本开始：
1.4

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某轴的首选区域。

指定者：
类 View 中的 getPreferredSpan
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，该值 >= 0。通常会告知该视图在返回的区域中呈现，但不保证一定如此。父级可选择重新调整视图大小或拆分视图。
抛出：
IllegalArgumentException - 如果轴无效
另请参见：
View.getPreferredSpan(int)

paint

public void paint(Graphics g,
                  Shape a)
使用给定呈现面和该表面的区域呈现。该视图可能需要进行布置和创建子视图，以使它本身能够在给定的分配区域呈现。

指定者：
类 View 中的 paint
参数：
g - 要使用的呈现表面
a - 已分配的呈现区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

指定者：
类 View 中的 modelToView
参数：
pos - 要转换的位置，该值 >= 0
a - 分配的要在其中呈现的区域
b - 当位置是两个视图的边界时，该参数是离由偏移量表示的前一个字符或者下一个字符的偏差；b 将是这些值之一：
  • Position.Bias.Forward
  • Position.Bias.Backward
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置在所关联的文档中不是一个有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public int viewToModel(float fx,
                       float fy,
                       Shape a,
                       Position.Bias[] bias)
提供从视图坐标空间到该模型的逻辑坐标空间的映射。

指定者：
类 View 中的 viewToModel
参数：
fx - X 坐标，该值 >= 0
fy - Y 坐标，该值 >= 0
a - 要呈现的分配区域
返回：
在模型内最能表示该视图中给定点的位置，该值 >= 0
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

insertUpdate

public void insertUpdate(DocumentEvent changes,
                         Shape a,
                         ViewFactory f)
发出通知，通知在文档中此视图负责的某个位置已插入内容。

覆盖：
类 View 中的 insertUpdate
参数：
changes - 取自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(DocumentEvent changes,
                         Shape a,
                         ViewFactory f)
通知在文档中此视图负责的某个位置已插入内容。

覆盖：
类 View 中的 removeUpdate
参数：
changes - 取自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

changedUpdate

public void changedUpdate(DocumentEvent changes,
                          Shape a,
                          ViewFactory f)
发出通知，通知文档中此视图负责的某个位置的属性已更改。

覆盖：
类 View 中的 changedUpdate
参数：
changes - 取自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

setSize

public void setSize(float width,
                    float height)
设置视图的大小。如果此方法有任何布局任务，则会导致沿给定的轴布局视图。

覆盖：
类 View 中的 setSize
参数：
width - 宽度 >= 0
height - 宽度 >= 0

nextTabStop

public float nextTabStop(float x,
                         int tabOffset)
在给定引用位置之后，返回下一个制表符停靠位的位置。此实现不支持诸如居中对齐一类的事情，所以它将忽略 tabOffset 参数。

指定者：
接口 TabExpander 中的 nextTabStop
参数：
x - 当前位置，该值 >= 0
tabOffset - 下一个流内出现制表符的位置，该值 >= 0。
返回：
以点为测量单位的制表位，该值 >= 0

updateDamage

protected void updateDamage(DocumentEvent changes,
                            Shape a,
                            ViewFactory f)
重新绘制给定文档事件覆盖的更改区域。对于只在一行上进行插入/移除的情况，破坏范围开始处的行。如果添加或移除多行，则破坏整个视图。检查最长的行以查看它是否更改。

从以下版本开始：
1.4

damageLineRange

protected void damageLineRange(int line0,
                               int line1,
                               Shape a,
                               Component host)
重新绘制给定的行范围。

参数：
host - 承载视图的组件（用于调用 repaint）
a - 视图所呈现的分配区域
line0 - 要重绘的起始行号。它必须是模型中的有效行号。
line1 - 要重绘的结束行号。它必须是模型中的有效行号。
从以下版本开始：
1.4

lineToRect

protected Rectangle lineToRect(Shape a,
                               int line)
确定表示给定行的矩形。

参数：
a - 视图要呈现的分配区域
line - 要查找的区域的行号。它必须是模型中的有效行号。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Position (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Position

public interface Position

表示文档中的位置。该接口能提取出文档的实现详细信息，并启用文档内能够随编辑文档跟踪更改的位置规范。

Position 对象指向两个字符之间的位置。周围内容改变时，Position 对象自动调整其偏移量以反映更改。如果在 Position 对象的位置之前插入或移除内容，则 Position 分别增加或减少其偏移量以便指向相同位置。如果文档中包含 Position 偏移量的部分被移除，则该 Position 的偏移量就成为移除区域的开始位置。例如，如果 Position 的偏移量为 5 而 2-10 的区域被移除，那么该 Position 的偏移量就成为 2。

偏移量为 0 的 Position 是一种特殊情况。文档内容改变时它不改变其偏移量。

嵌套类摘要
static class Position.Bias
用来指示模型中位置偏差的类型安全的枚举。
方法摘要
 int getOffset()
获取文档内的当前偏移量。

方法详细信息

getOffset

int getOffset()
获取文档内的当前偏移量。

返回：
偏移量，该值 >= 0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Position.Bias (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 Position.Bias

java.lang.Object
    继承者  javax.swing.text.Position.Bias
正在封闭接口：
Position
public static final class Position.Bias
extends Object

用来指示模型中位置偏差的类型安全的枚举。指示两个字符之间的位置。偏差可用于指示在简单偏移量不确定的边界条件下对位置两边之一的趋向。

字段摘要
static Position.Bias | Backward 指示到模型中上一字符的偏差。
static Position.Bias | Forward 指示到模型中下一字符的偏差。
方法摘要
 String toString()
字符串表示形式
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

Forward

public static final Position.Bias Forward
指示到模型中下一字符的偏差。

Backward

public static final Position.Bias Backward
指示到模型中上一字符的偏差。

方法详细信息

toString

public String toString()
字符串表示形式

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Segment (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 Segment

java.lang.Object
    继承者  javax.swing.text.Segment
所有已实现的接口：
CharSequence, Cloneable, CharacterIterator
public class Segment
extends Object
implements Cloneable, CharacterIterator, CharSequence

表示文本片段的字符数组的 segment。尽管能够直接访问数组，也应将其视为不可变的。此实现提供了对文本片段的快速访问，而且不存在来回复制字符的开销。它实际上是一个未受保护的 String。

Segment 实现 java.text.CharacterIterator 接口以支持对国际化支持的使用，而不用将文本复制到某个字符串。

字段摘要
char[] | array 这是包含了所需文本的数组。
int | count 这是构成所需文本的数组元素的数目。
int | offset 这是所需文件开始处的数组偏移量。
从接口 java.text.CharacterIterator 继承的字段
DONE
构造方法摘要
Segment()
创建一个新 segment。
Segment(char[] array, int offset, int count)
创建一个引用现有数组的新 segment。
方法摘要
 char charAt(int index)
返回指定索引的 char 值。
 Object clone()
创建一个浅表副本。
 char current()
获取当前位置（由 getIndex() 返回）的字符。
 char first()
将位置设置为 getBeginIndex()，并返回该位置的字符。
 int getBeginIndex()
返回文本的起始索引。
 int getEndIndex()
返回文本的结束索引。
 int getIndex()
返回当前索引。
 boolean isPartialReturn()
指示部分返回有效的标记。
 char last()
将位置设置为 getEndIndex()-1（如果文本为空，则设置为 getEndIndex()），并返回该位置的字符。
 int length()
返回此字符序列的长度。
 char next()
将迭代器的索引加一，并返回新索引处的字符。
 char previous()
将迭代器的索引减一，并返回新索引处的字符。
 char setIndex(int position)
将位置设置为文本中的指定位置，并返回该字符。
 void setPartialReturn(boolean p)
指示部分返回有效的标记。
 CharSequence subSequence(int start, int end)
返回一个新的 CharSequence，它是此序列的子序列。
 String toString()
将 segment 转换为 String。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

array

public char[] array
这是包含了所需文本的数组。永远不应修改此数组；它只是用来提高效率的。

offset

public int offset
这是所需文件开始处的数组偏移量。

count

public int count
这是构成所需文本的数组元素的数目。

构造方法详细信息

Segment

public Segment()
创建一个新 segment。

Segment

public Segment(char[] array,
               int offset,
               int count)
创建一个引用现有数组的新 segment。

参数：
array - 要引用的数组
offset - 数组中的偏移量
count - 字符数
方法详细信息

setPartialReturn

public void setPartialReturn(boolean p)
指示部分返回有效的标记。如果标志为 true，则接口方法 Document.getText(position,length,Segment) 的实现应该在不进行复制的情况下尽可能多地返回文本。标志的默认状态为 false，这将导致 Document.getText(position,length,Segment) 提供其总是具有的返回行为（要么复制，要么不复制文本，具体取决于请求）。

参数：
p - 部分返回是否有效。
从以下版本开始：
1.4

isPartialReturn

public boolean isPartialReturn()
指示部分返回有效的标记。

返回：
部分返回是否有效。
从以下版本开始：
1.4

toString

public String toString()
将 segment 转换为 String。

指定者：
接口 CharSequence 中的 toString
覆盖：
类 Object 中的 toString
返回：
字符串

first

public char first()
将位置设置为 getBeginIndex()，并返回该位置的字符。

指定者：
接口 CharacterIterator 中的 first
返回：
文本中的第一个字符，如果文本为空，则返回 DONE
从以下版本开始：
1.3
另请参见：
getBeginIndex()

last

public char last()
将位置设置为 getEndIndex()-1（如果文本为空，则设置为 getEndIndex()），并返回该位置的字符。

指定者：
接口 CharacterIterator 中的 last
返回：
文本中的最后一个字符，如果文本为空，则返回 DONE
从以下版本开始：
1.3
另请参见：
getEndIndex()

current

public char current()
获取当前位置（由 getIndex() 返回）的字符。

指定者：
接口 CharacterIterator 中的 current
返回：
当前位置的字符；如果当前位置已超出文本末尾，则返回 DONE。
从以下版本开始：
1.3
另请参见：
getIndex()

next

public char next()
将迭代器的索引加一，并返回新索引处的字符。如果所得索引大于等于 getEndIndex()，则将当前索引重置为 getEndIndex()，并返回值 DONE。

指定者：
接口 CharacterIterator 中的 next
返回：
新位置的字符；如果该新位置已超出文本范围的末尾，则返回 DONE。
从以下版本开始：
1.3

previous

public char previous()
将迭代器的索引减一，并返回新索引处的字符。如果当前索引为 getBeginIndex()，则新索引仍为 getBeginIndex()，并返回值 DONE。

指定者：
接口 CharacterIterator 中的 previous
返回：
新位置的字符；如果当前位置等于 getBeginIndex()，则返回 DONE。
从以下版本开始：
1.3

setIndex

public char setIndex(int position)
将位置设置为文本中的指定位置，并返回该字符。

指定者：
接口 CharacterIterator 中的 setIndex
参数：
position - 文本中的位置。从 getBeginIndex() 到 getEndIndex() 的有效值范围。如果提供了无效值，则抛出 IllegalArgumentException。
返回：
指定位置的字符；如果指定位置等于 getEndIndex()，则返回 DONE
从以下版本开始：
1.3

getBeginIndex

public int getBeginIndex()
返回文本的起始索引。

指定者：
接口 CharacterIterator 中的 getBeginIndex
返回：
文本开始处的索引。
从以下版本开始：
1.3

getEndIndex

public int getEndIndex()
返回文本的结束索引。此索引是文本末尾后面第一个字符的索引。

指定者：
接口 CharacterIterator 中的 getEndIndex
返回：
文本中最后一个字符后面的索引
从以下版本开始：
1.3

getIndex

public int getIndex()
返回当前索引。

指定者：
接口 CharacterIterator 中的 getIndex
返回：
当前索引。
从以下版本开始：
1.3

charAt

public char charAt(int index)
返回指定索引的 char 值。索引范围是从零到 length() - 1。对于数组索引，序列的第一个 char 值是索引零，下一个是索引一，依此类推。

如果索引指定的 char 值是代理项，则返回代理项的值。

指定者：
接口 CharSequence 中的 charAt
参数：
index - 要返回的 char 值的索引
返回：
指定的 char 值
从以下版本开始：
1.6

length

public int length()
返回此字符序列的长度。该长度是序列中的 16 位 char 数。

指定者：
接口 CharSequence 中的 length
返回：
此序列中的 char 数
从以下版本开始：
1.6

subSequence

public CharSequence subSequence(int start,
                                int end)
返回一个新的 CharSequence，它是此序列的子序列。子序列从指定序列的 char 值开始，并在索引 end - 1 的 char 值结束。返回序列的长度（char 中）是 end - start，因此，如果 start == end，则返回一个空序列。

指定者：
接口 CharSequence 中的 subSequence
参数：
start - 开始索引（包括）
end - 结束索引（不包括）
返回：
指定的子序列
从以下版本开始：
1.6

clone

public Object clone()
创建一个浅表副本。

指定者：
接口 CharacterIterator 中的 clone
覆盖：
类 Object 中的 clone
返回：
副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleAttributeSet (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 SimpleAttributeSet

java.lang.Object
    继承者  javax.swing.text.SimpleAttributeSet
所有已实现的接口：
Serializable, Cloneable, AttributeSet, MutableAttributeSet
public class SimpleAttributeSet
extends Object
implements MutableAttributeSet, Serializable, Cloneable

使用哈希表的 MutableAttributeSet 的直接实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
static AttributeSet EMPTY
空的属性集。
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
SimpleAttributeSet()
创建新属性集。
SimpleAttributeSet(AttributeSet source)
根据提供的属性集创建新属性集。
方法摘要
void | addAttribute(Object name, Object value) 向列表添加属性。
void | addAttributes(AttributeSet attributes) 向列表添加属性集。
Object | clone() 复制属性集。
boolean | containsAttribute(Object name, Object value) 检查属性列表中是否包含了指定的属性名称/值对。
boolean | containsAttributes(AttributeSet attributes) 确定属性列表中是否包含所有指定的名称/值对。
AttributeSet | copyAttributes() 创建属性的副本。
boolean | equals(Object obj) 将该对象与指定对象比较。
Object | getAttribute(Object name) 获取属性的值。
int | getAttributeCount() 获取属性数目的总数。
Enumeration<?> | getAttributeNames() 获取集合中的属性名称。
AttributeSet | getResolveParent() 获取正解析的父级。
int | hashCode() 返回此属性集的哈希代码。
boolean | isDefined(Object attrName) 告知是否定义了给定的属性。
boolean | isEmpty() 检查属性集是否为空。
boolean | isEqual(AttributeSet attr) 比较两个属性集。
void | removeAttribute(Object name) 从列表中移除属性。
void | removeAttributes(AttributeSet attributes) 从列表中移除属性集。
void | removeAttributes(Enumeration<?> names) 从列表中移除属性集。
void | setResolveParent(AttributeSet parent) 设置解析的父级。
String | toString() 将属性集转换为 String。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

EMPTY

public static final AttributeSet EMPTY
空的属性集。

构造方法详细信息

SimpleAttributeSet

public SimpleAttributeSet()
创建新属性集。

SimpleAttributeSet

public SimpleAttributeSet(AttributeSet source)
根据提供的属性集创建新属性集。

参数：
source - 属性集
方法详细信息

isEmpty

public boolean isEmpty()
检查属性集是否为空。

返回：
如果集合为空，则返回 true；否则返回 false

getAttributeCount

public int getAttributeCount()
获取属性数目的总数。

指定者：
接口 AttributeSet 中的 getAttributeCount
返回：
总数。

isDefined

public boolean isDefined(Object attrName)
告知是否定义了给定的属性。

指定者：
接口 AttributeSet 中的 isDefined
参数：
attrName - 属性名
返回：
如果属性已定义，则返回 true。

isEqual

public boolean isEqual(AttributeSet attr)
比较两个属性集。

指定者：
接口 AttributeSet 中的 isEqual
参数：
attr - 第二个属性集
返回：
如果集合相等，则返回 true；否则返回 false

copyAttributes

public AttributeSet copyAttributes()
创建属性的副本。

指定者：
接口 AttributeSet 中的 copyAttributes
返回：
副本

getAttributeNames

public Enumeration<?> getAttributeNames()
获取集合中的属性名称。

指定者：
接口 AttributeSet 中的 getAttributeNames
返回：
Enumeration 形式的名称

getAttribute

public Object getAttribute(Object name)
获取属性的值。

指定者：
接口 AttributeSet 中的 getAttribute
参数：
name - 属性名称
返回：
值

containsAttribute

public boolean containsAttribute(Object name,
                                 Object value)
检查属性列表中是否包含了指定的属性名称/值对。

指定者：
接口 AttributeSet 中的 containsAttribute
参数：
name - 名称
value - 值
返回：
如果名称/值对包含在列表中，则返回 true

containsAttributes

public boolean containsAttributes(AttributeSet attributes)
确定属性列表中是否包含所有指定的名称/值对。

指定者：
接口 AttributeSet 中的 containsAttributes
参数：
attributes - 属性列表
返回：
如果列表包含所有的名称/值对，则返回 true

addAttribute

public void addAttribute(Object name,
                         Object value)
向列表添加属性。

指定者：
接口 MutableAttributeSet 中的 addAttribute
参数：
name - 属性名称
value - 属性值

addAttributes

public void addAttributes(AttributeSet attributes)
向列表添加属性集。

指定者：
接口 MutableAttributeSet 中的 addAttributes
参数：
attributes - 要添加的属性集

removeAttribute

public void removeAttribute(Object name)
从列表中移除属性。

指定者：
接口 MutableAttributeSet 中的 removeAttribute
参数：
name - 属性名

removeAttributes

public void removeAttributes(Enumeration<?> names)
从列表中移除属性集。

指定者：
接口 MutableAttributeSet 中的 removeAttributes
参数：
names - 要移除的属性集

removeAttributes

public void removeAttributes(AttributeSet attributes)
从列表中移除属性集。

指定者：
接口 MutableAttributeSet 中的 removeAttributes
参数：
attributes - 要移除的属性集

getResolveParent

public AttributeSet getResolveParent()
获取正解析的父级。如果某个属性未在本地定义，则它就是要进行解析的属性集。如果没有其他要解析的属性集，则此为 null。

指定者：
接口 AttributeSet 中的 getResolveParent
返回：
父级

setResolveParent

public void setResolveParent(AttributeSet parent)
设置解析的父级。

指定者：
接口 MutableAttributeSet 中的 setResolveParent
参数：
parent - 父级

clone

public Object clone()
复制属性集。

覆盖：
类 Object 中的 clone
返回：
新属性集
另请参见：
Cloneable

hashCode

public int hashCode()
返回此属性集的哈希代码。

覆盖：
类 Object 中的 hashCode
返回：
此属性集的哈希代码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将该对象与指定对象比较。如果此对象是一个等效的属性集，则结果为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此属性集比较的对象
返回：
如果对象是相同的，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
将属性集转换为 String。

覆盖：
类 Object 中的 toString
返回：
字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringContent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StringContent

java.lang.Object
    继承者  javax.swing.text.StringContent
所有已实现的接口：
Serializable, AbstractDocument.Content
public final class StringContent
extends Object
implements AbstractDocument.Content, Serializable

AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。它只能管理简单字符数组中的字符内容。而且其效率很低。

通常建议使用间隙缓冲区或拼凑表实现。此缓冲区无法扩展为大尺寸。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
StringContent()
创建新的 StringContent 对象。
StringContent(int initialLength)
创建具有指定初始大小的新 StringContent。
方法摘要
 Position createPosition(int offset)
在内容中创建一个位置，让其跟踪随内容的变化而进行的更改。
 void getChars(int where, int len, Segment chars)
检索内容的某一部分，where ＋ len 必须 <= length()
protected  Vector getPositionsInRange(Vector v, int offset, int length)
返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
 String getString(int where, int len)
检索内容的某一部分，where ＋ len 必须 <= length()。
 UndoableEdit insertString(int where, String str)
将字符串插入到内容中。
 int length()
返回内容的长度。
 UndoableEdit remove(int where, int nitems)
移除部分内容，其中 where ＋ nitems 必须 < length()。
protected  void updateUndoPositions(Vector positions)
在 positions 处重新设置所有 UndoPosRef 实例的位置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringContent

public StringContent()
创建新的 StringContent 对象。初始大小默认为 10。

StringContent

public StringContent(int initialLength)
创建具有指定初始大小的新 StringContent。如果长度小于 1，大小将为 1。

参数：
initialLength - 初始大小
方法详细信息

length

public int length()
返回内容的长度。

指定者：
接口 AbstractDocument.Content 中的 length
返回：
长度，该值 >= 1
另请参见：
AbstractDocument.Content.length()

insertString

public UndoableEdit insertString(int where,
                                 String str)
                          throws BadLocationException
将字符串插入到内容中。

指定者：
接口 AbstractDocument.Content 中的 insertString
参数：
where - 起始位置，该值 >= 0 且 < length()
str - 要插入的非 null 字符串
返回：
撤消的 UndoableEdit 对象
抛出：
BadLocationException - 如果指定位置无效
另请参见：
AbstractDocument.Content.insertString(int, java.lang.String)

remove

public UndoableEdit remove(int where,
                           int nitems)
                    throws BadLocationException
移除部分内容，其中 where ＋ nitems 必须 < length()。

指定者：
接口 AbstractDocument.Content 中的 remove
参数：
where - 起始位置，该值 >= 0
nitems - 要移除的字符数，该值 >= 0
返回：
撤消的 UndoableEdit 对象
抛出：
BadLocationException - 如果指定位置无效
另请参见：
AbstractDocument.Content.remove(int, int)

getString

public String getString(int where,
                        int len)
                 throws BadLocationException
检索内容的某一部分，where ＋ len 必须 <= length()。

指定者：
接口 AbstractDocument.Content 中的 getString
参数：
where - 起始位置，该值 >= 0
len - 要检索的长度，该值 >= 0
返回：
一个表示该内容的字符串；该字符串可能为空
抛出：
BadLocationException - 如果指定位置无效
另请参见：
AbstractDocument.Content.getString(int, int)

getChars

public void getChars(int where,
                     int len,
                     Segment chars)
              throws BadLocationException
检索内容的某一部分，where ＋ len 必须 <= length()

指定者：
接口 AbstractDocument.Content 中的 getChars
参数：
where - 起始位置，该值 >= 0
len - 要检索的字符数，该值 >= 0
chars - 要在其中返回字符的 Segment 对象
抛出：
BadLocationException - 如果指定位置无效
另请参见：
AbstractDocument.Content.getChars(int, int, javax.swing.text.Segment)

createPosition

public Position createPosition(int offset)
                        throws BadLocationException
在内容中创建一个位置，让其跟踪随内容的变化而进行的更改。

指定者：
接口 AbstractDocument.Content 中的 createPosition
参数：
offset - 所创建位置的偏移量，该值 >= 0
返回：
位置
抛出：
BadLocationException - 如果指定位置无效

getPositionsInRange

protected Vector getPositionsInRange(Vector v,
                                     int offset,
                                     int length)
返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。如果 v 不为 null，则在此处放置匹配的 Position。返回具有结果 Position 的向量。

这里指的是内部用法，通常不适合子类。

参数：
v - 要使用的 Vector，其位置是向量为 null 时创建的新位置
offset - 起始偏移量，该值 >= 0
length - 长度，该值 >= 0
返回：
实例的集合

updateUndoPositions

protected void updateUndoPositions(Vector positions)
在 positions 处重新设置所有 UndoPosRef 实例的位置。

这里指的是内部用法，通常不适合子类。

参数：
positions - 实例的位置
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Style (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 Style

所有超级接口：
AttributeSet, MutableAttributeSet
所有已知实现类：
StyleContext.NamedStyle
public interface Style
extends MutableAttributeSet

与文档中某个元素相关的属性集合。因为这些通常用于字符和段落样式与元素之间的关联，所以就提供了这方面的操作。取得与元素关联的其他自定义属性将有效地成为层次结构中的名称-值对，并且如果没有在本地找到名称（键），则会把请求转发给父级。常用的属性被分离了出来，以便采用更有效的替代实现。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
方法摘要
void | addChangeListener(ChangeListener l) 添加一个侦听器，以便随时跟踪属性的更改。
String | getName() 获取样式名称。
void | removeChangeListener(ChangeListener l) 移除跟踪属性更改的侦听器。
从接口 javax.swing.text.MutableAttributeSet 继承的方法
addAttribute, addAttributes, removeAttribute, removeAttributes, removeAttributes, setResolveParent
从接口 javax.swing.text.AttributeSet 继承的方法
containsAttribute, containsAttributes, copyAttributes, getAttribute, getAttributeCount, getAttributeNames, getResolveParent, isDefined, isEqual

方法详细信息

getName

String getName()
获取样式名称。不要求命名样式，因此如果没有与此样式相关的名称，则返回 null。

返回：
名称

addChangeListener

void addChangeListener(ChangeListener l)
添加一个侦听器，以便随时跟踪属性的更改。

参数：
l - 更改侦听器

removeChangeListener

void removeChangeListener(ChangeListener l)
移除跟踪属性更改的侦听器。

参数：
l - 更改侦听器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyleConstants

java.lang.Object
    继承者  javax.swing.text.StyleConstants
直接已知子类：
StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants
public class StyleConstants
extends Object

一个已知的 或常见的属性键和方法的集合，可通过应用 AttributeSet 或 MutableAttributeSet 方法以类型安全的方式获取/设置属性。

段落属性定义了所呈现的段落。所有的大小都是以点的形式指定的（如 postscript 中所示），其测量与设备无关。

图表显示 SpaceAbove、FirstLineIndent、LeftIndent、RightIndent 和 SpaceBelow 为一个段落。

嵌套类摘要
static class | StyleConstants.CharacterConstants 这是一个类型安全的已知 属性的枚举，它用于字符样式。
static class | StyleConstants.ColorConstants 这是一个类型安全的已知 属性的枚举，它用于颜色样式。
static class | StyleConstants.FontConstants 这是一个类型安全的已知 属性的枚举，它用于字体样式。
static class | StyleConstants.ParagraphConstants 这是一个类型安全的已知 属性的枚举，它用于段落样式。
字段摘要
static int | ALIGN_CENTER 段落对齐的可能值。
static int | ALIGN_JUSTIFIED 段落对齐的可能值。
static int | ALIGN_LEFT 段落对齐方式的可能值。
static int | ALIGN_RIGHT 段落对齐的可能值。
static Object | Alignment 段落的对齐方式。
static Object | Background 背景色属性的名称。
static Object | BidiLevel 由 Unicode bidi 算法指派的字符双向级别。
static Object | Bold 粗体属性的名称。
static Object | ComponentAttribute 组件属性的名称。
static String | ComponentElementName 用于表示组件的元素名称。
static Object | ComposedTextAttribute 撰写文本的输入法属性的名称。
static Object | Family 字体系列的名称。
static Object | FirstLineIndent 段落第一行要缩进的空间量。
static Object | FontFamily 字体系列的名称。
static Object | FontSize 字体大小的名称。
static Object | Foreground 前景色属性的名称。
static Object | IconAttribute 图标属性的名称。
static String | IconElementName 用于表示图标的元素名称。
static Object | Italic 斜体属性的名称。
static Object | LeftIndent 段落左边的缩进量。
static Object | LineSpacing 段落的行之间的空间量。
static Object | ModelAttribute 用来标识嵌入了对象的模型的属性，这些嵌入的对象具有分开的模型视图。
static Object | NameAttribute 用于命名属性集合的属性名称。
static Object | Orientation 段落的方向。
static Object | ResolveAttribute 用来标识属性的解析父集的属性名（如果定义了属性的解析父集）。
static Object | RightIndent 段落右边的缩进量。
static Object | Size 字体大小的名称。
static Object | SpaceAbove 段落上方的空间量。
static Object | SpaceBelow 段落下方的空间量。
static Object | StrikeThrough 删除线属性的名称。
static Object | Subscript 下标属性的名称。
static Object | Superscript 上标属性的名称。
static Object | TabSet 段落的 TabSet，类型为包含了 TabStop 的 TabSet。
static Object | Underline 下划线属性的名称。
方法摘要
static int | getAlignment(AttributeSet a) 获取对齐设置。
static Color | getBackground(AttributeSet a) 从属性列表中获取背景色设置。
static int | getBidiLevel(AttributeSet a) 获取 BidiLevel 设置。
static Component | getComponent(AttributeSet a) 从属性列表中获取组件设置。
static float | getFirstLineIndent(AttributeSet a) 获取首行缩进设置。
static String | getFontFamily(AttributeSet a) 从属性列表中获取字体系列设置。
static int | getFontSize(AttributeSet a) 从属性列表中获取字体大小设置。
static Color | getForeground(AttributeSet a) 从属性列表中获取前景色设置。
static Icon | getIcon(AttributeSet a) 从属性列表中获取图标设置。
static float | getLeftIndent(AttributeSet a) 获取左边缩进设置。
static float | getLineSpacing(AttributeSet a) 获取行间距设置。
static float | getRightIndent(AttributeSet a) 获取右边缩进设置。
static float | getSpaceAbove(AttributeSet a) 获取上部空间设置。
static float | getSpaceBelow(AttributeSet a) 获取下部空间设置。
static TabSet | getTabSet(AttributeSet a) 获取 TabSet。
static boolean | isBold(AttributeSet a) 确定是否设置了粗体属性。
static boolean | isItalic(AttributeSet a) 确定是否设置了斜体属性。
static boolean | isStrikeThrough(AttributeSet a) 确定是否设置了删除线属性。
static boolean | isSubscript(AttributeSet a) 确定是否设置了下标属性。
static boolean | isSuperscript(AttributeSet a) 确定是否设置了上标属性。
static boolean | isUnderline(AttributeSet a) 确定是否设置了下划线属性。
static void | setAlignment(MutableAttributeSet a, int align) 设置对齐方式。
static void | setBackground(MutableAttributeSet a, Color fg) 设置背景色。
static void | setBidiLevel(MutableAttributeSet a, int o) 设置 BidiLevel。
static void | setBold(MutableAttributeSet a, boolean b) 设置粗体属性。
static void | setComponent(MutableAttributeSet a, Component c) 设置组件属性。
static void | setFirstLineIndent(MutableAttributeSet a, float i) 设置首行缩进。
static void | setFontFamily(MutableAttributeSet a, String fam) 设置字体属性。
static void | setFontSize(MutableAttributeSet a, int s) 设置字体大小属性。
static void | setForeground(MutableAttributeSet a, Color fg) 设置前景色。
static void | setIcon(MutableAttributeSet a, Icon c) 设置图标属性。
static void | setItalic(MutableAttributeSet a, boolean b) 设置斜体属性。
static void | setLeftIndent(MutableAttributeSet a, float i) 设置左边缩进。
static void | setLineSpacing(MutableAttributeSet a, float i) 设置行间距。
static void | setRightIndent(MutableAttributeSet a, float i) 设置右边缩进。
static void | setSpaceAbove(MutableAttributeSet a, float i) 设置上部空间。
static void | setSpaceBelow(MutableAttributeSet a, float i) 设置下部空间。
static void | setStrikeThrough(MutableAttributeSet a, boolean b) 设置删除线属性。
static void | setSubscript(MutableAttributeSet a, boolean b) 设置下标属性。
static void | setSuperscript(MutableAttributeSet a, boolean b) 设置上标属性。
static void | setTabSet(MutableAttributeSet a, TabSet tabs) 设置 TabSet。
static void | setUnderline(MutableAttributeSet a, boolean b) 设置下标属性。
String | toString() 返回字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ComponentElementName

public static final String ComponentElementName
用于表示组件的元素名称。

另请参见：
常量字段值

IconElementName

public static final String IconElementName
用于表示图标的元素名称。

另请参见：
常量字段值

NameAttribute

public static final Object NameAttribute
用于命名属性集合的属性名称。

ResolveAttribute

public static final Object ResolveAttribute
用来标识属性的解析父集的属性名（如果定义了属性的解析父集）。

ModelAttribute

public static final Object ModelAttribute
用来标识嵌入了对象的模型的属性，这些嵌入的对象具有分开的模型视图。

BidiLevel

public static final Object BidiLevel
由 Unicode bidi 算法指派的字符双向级别。

FontFamily

public static final Object FontFamily
字体系列的名称。

Family

public static final Object Family
字体系列的名称。

从以下版本开始：
1.5

FontSize

public static final Object FontSize
字体大小的名称。

Size

public static final Object Size
字体大小的名称。

从以下版本开始：
1.5

Bold

public static final Object Bold
粗体属性的名称。

Italic

public static final Object Italic
斜体属性的名称。

Underline

public static final Object Underline
下划线属性的名称。

StrikeThrough

public static final Object StrikeThrough
删除线属性的名称。

Superscript

public static final Object Superscript
上标属性的名称。

Subscript

public static final Object Subscript
下标属性的名称。

Foreground

public static final Object Foreground
前景色属性的名称。

Background

public static final Object Background
背景色属性的名称。

ComponentAttribute

public static final Object ComponentAttribute
组件属性的名称。

IconAttribute

public static final Object IconAttribute
图标属性的名称。

ComposedTextAttribute

public static final Object ComposedTextAttribute
撰写文本的输入法属性的名称。此属性的值是表示所撰写文本的 AttributedString 的实例。

FirstLineIndent

public static final Object FirstLineIndent
段落第一行要缩进的空间量。此值在相反方向可能为负的偏移量。类型为 Float，并且以点的形式指定空间大小。

LeftIndent

public static final Object LeftIndent
段落左边的缩进量。类型为 float，并且以点的形式指定大小。

RightIndent

public static final Object RightIndent
段落右边的缩进量。类型为 float，并且以点的形式指定大小。

LineSpacing

public static final Object LineSpacing
段落的行之间的空间量。类型为 float，并且以行高的因子来指定大小。

SpaceAbove

public static final Object SpaceAbove
段落上方的空间量。类型为 float，并且以点的形式指定大小。

SpaceBelow

public static final Object SpaceBelow
段落下方的空间量。类型为 float，并且以点的形式指定大小。

Alignment

public static final Object Alignment
段落的对齐方式。类型为 Integer。有效值有：
  • ALIGN_LEFT
  • ALIGN_RIGHT
  • ALIGN_CENTER
  • ALIGN_JUSTIFED

TabSet

public static final Object TabSet
段落的 TabSet，类型为包含了 TabStop 的 TabSet。

Orientation

public static final Object Orientation
段落的方向。

ALIGN_LEFT

public static final int ALIGN_LEFT
段落对齐方式的可能值。它指定文本左对齐，并且要将额外的空白放在右边。

另请参见：
常量字段值

ALIGN_CENTER

public static final int ALIGN_CENTER
段落对齐的可能值。它指定文本中间对齐，并且要将额外的空白放在左边和右边。

另请参见：
常量字段值

ALIGN_RIGHT

public static final int ALIGN_RIGHT
段落对齐的可能值。它指定文本右对齐，并且要将额外的空白放在左边。

另请参见：
常量字段值

ALIGN_JUSTIFIED

public static final int ALIGN_JUSTIFIED
段落对齐的可能值。它指定额外空间必须分散在段落的行间，文本行除了最后一行应该左对齐之外都具有左边和右边的缩进。

另请参见：
常量字段值
方法详细信息

toString

public String toString()
返回字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
字符串

getBidiLevel

public static int getBidiLevel(AttributeSet a)
获取 BidiLevel 设置。

参数：
a - 属性集
返回：
值

setBidiLevel

public static void setBidiLevel(MutableAttributeSet a,
                                int o)
设置 BidiLevel。

参数：
a - 属性集
o - 双向级别值

getComponent

public static Component getComponent(AttributeSet a)
从属性列表中获取组件设置。

参数：
a - 属性集
返回：
组件，如果没有则为 null

setComponent

public static void setComponent(MutableAttributeSet a,
                                Component c)
设置组件属性。

参数：
a - 属性集
c - 组件

getIcon

public static Icon getIcon(AttributeSet a)
从属性列表中获取图标设置。

参数：
a - 属性集
返回：
图标，如果没有则为 null

setIcon

public static void setIcon(MutableAttributeSet a,
                           Icon c)
设置图标属性。

参数：
a - 属性集
c - 图标

getFontFamily

public static String getFontFamily(AttributeSet a)
从属性列表中获取字体系列设置。

参数：
a - 属性集
返回：
字体系列，默认为 "Monospaced"

setFontFamily

public static void setFontFamily(MutableAttributeSet a,
                                 String fam)
设置字体属性。

参数：
a - 属性集
fam - 字体

getFontSize

public static int getFontSize(AttributeSet a)
从属性列表中获取字体大小设置。

参数：
a - 属性集
返回：
字体大小，默认为 12

setFontSize

public static void setFontSize(MutableAttributeSet a,
                               int s)
设置字体大小属性。

参数：
a - 属性集
s - 字体大小

isBold

public static boolean isBold(AttributeSet a)
确定是否设置了粗体属性。

参数：
a - 属性集
返回：
如果已设置则为 true；否则为 false

setBold

public static void setBold(MutableAttributeSet a,
                           boolean b)
设置粗体属性。

参数：
a - 属性集
b - 指定 true/false 来表示是否设置了这一属性

isItalic

public static boolean isItalic(AttributeSet a)
确定是否设置了斜体属性。

参数：
a - 属性集
返回：
如果已设置则为 true；否则为 false

setItalic

public static void setItalic(MutableAttributeSet a,
                             boolean b)
设置斜体属性。

参数：
a - 属性集
b - 指定 true/false 来表示是否设置了这一属性

isUnderline

public static boolean isUnderline(AttributeSet a)
确定是否设置了下划线属性。

参数：
a - 属性集
返回：
如果已设置则为 true；否则为 false

isStrikeThrough

public static boolean isStrikeThrough(AttributeSet a)
确定是否设置了删除线属性。

参数：
a - 属性集
返回：
如果已设置则为 true；否则为 false

isSuperscript

public static boolean isSuperscript(AttributeSet a)
确定是否设置了上标属性。

参数：
a - 属性集
返回：
如果已设置则为 true；否则为 false

isSubscript

public static boolean isSubscript(AttributeSet a)
确定是否设置了下标属性。

参数：
a - 属性集
返回：
如果已设置则为 true；否则为 false

setUnderline

public static void setUnderline(MutableAttributeSet a,
                                boolean b)
设置下标属性。

参数：
a - 属性集
b - 指定 true/false 来表示是否设置了这一属性

setStrikeThrough

public static void setStrikeThrough(MutableAttributeSet a,
                                    boolean b)
设置删除线属性。

参数：
a - 属性集
b - 指定 true/false 来表示是否设置了这一属性

setSuperscript

public static void setSuperscript(MutableAttributeSet a,
                                  boolean b)
设置上标属性。

参数：
a - 属性集
b - 指定 true/false 来表示是否设置了这一属性

setSubscript

public static void setSubscript(MutableAttributeSet a,
                                boolean b)
设置下标属性。

参数：
a - 属性集
b - 指定 true/false 来表示是否设置了这一属性

getForeground

public static Color getForeground(AttributeSet a)
从属性列表中获取前景色设置。

参数：
a - 属性集
返回：
颜色，默认为 Color.black

setForeground

public static void setForeground(MutableAttributeSet a,
                                 Color fg)
设置前景色。

参数：
a - 属性集
fg - 颜色

getBackground

public static Color getBackground(AttributeSet a)
从属性列表中获取背景色设置。

参数：
a - 属性集
返回：
颜色，默认为 Color.black

setBackground

public static void setBackground(MutableAttributeSet a,
                                 Color fg)
设置背景色。

参数：
a - 属性集
fg - 颜色

getFirstLineIndent

public static float getFirstLineIndent(AttributeSet a)
获取首行缩进设置。

参数：
a - 属性集
返回：
值，如果未设置则为 0

setFirstLineIndent

public static void setFirstLineIndent(MutableAttributeSet a,
                                      float i)
设置首行缩进。

参数：
a - 属性集
i - 值

getRightIndent

public static float getRightIndent(AttributeSet a)
获取右边缩进设置。

参数：
a - 属性集
返回：
值，如果未设置则为 0

setRightIndent

public static void setRightIndent(MutableAttributeSet a,
                                  float i)
设置右边缩进。

参数：
a - 属性集
i - 值

getLeftIndent

public static float getLeftIndent(AttributeSet a)
获取左边缩进设置。

参数：
a - 属性集
返回：
值，如果未设置则为 0

setLeftIndent

public static void setLeftIndent(MutableAttributeSet a,
                                 float i)
设置左边缩进。

参数：
a - 属性集
i - 值

getLineSpacing

public static float getLineSpacing(AttributeSet a)
获取行间距设置。

参数：
a - 属性集
返回：
值，如果未设置则为 0

setLineSpacing

public static void setLineSpacing(MutableAttributeSet a,
                                  float i)
设置行间距。

参数：
a - 属性集
i - 值

getSpaceAbove

public static float getSpaceAbove(AttributeSet a)
获取上部空间设置。

参数：
a - 属性集
返回：
值，如果未设置则为 0

setSpaceAbove

public static void setSpaceAbove(MutableAttributeSet a,
                                 float i)
设置上部空间。

参数：
a - 属性集
i - 值

getSpaceBelow

public static float getSpaceBelow(AttributeSet a)
获取下部空间设置。

参数：
a - 属性集
返回：
值，如果未设置则为 0

setSpaceBelow

public static void setSpaceBelow(MutableAttributeSet a,
                                 float i)
设置下部空间。

参数：
a - 属性集
i - 值

getAlignment

public static int getAlignment(AttributeSet a)
获取对齐设置。

参数：
a - 属性集
返回：
值，如果未设置则为 StyleConstants.ALIGN_LEFT

setAlignment

public static void setAlignment(MutableAttributeSet a,
                                int align)
设置对齐方式。

参数：
a - 属性集
align - 对齐方式值

getTabSet

public static TabSet getTabSet(AttributeSet a)
获取 TabSet。

参数：
a - 属性集
返回：
TabSet

setTabSet

public static void setTabSet(MutableAttributeSet a,
                             TabSet tabs)
设置 TabSet。

参数：
a - 属性集。
tabs - TabSet
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleConstants.CharacterConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyleConstants.CharacterConstants

java.lang.Object
    继承者  javax.swing.text.StyleConstants
        继承者  javax.swing.text.StyleConstants.CharacterConstants
所有已实现的接口：
AttributeSet.CharacterAttribute
正在封闭类：
StyleConstants
public static class StyleConstants.CharacterConstants
extends StyleConstants
implements AttributeSet.CharacterAttribute

这是一个类型安全的已知 属性的枚举，它用于字符样式。外部类为其起了别名，以便常规表示它们。

嵌套类摘要
从类 javax.swing.text.StyleConstants 继承的嵌套类/接口
StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants
字段摘要
从类 javax.swing.text.StyleConstants 继承的字段
ALIGN_CENTER, ALIGN_JUSTIFIED, ALIGN_LEFT, ALIGN_RIGHT, Alignment, Background, BidiLevel, Bold, ComponentAttribute, ComponentElementName, ComposedTextAttribute, Family, FirstLineIndent, FontFamily, FontSize, Foreground, IconAttribute, IconElementName, Italic, LeftIndent, LineSpacing, ModelAttribute, NameAttribute, Orientation, ResolveAttribute, RightIndent, Size, SpaceAbove, SpaceBelow, StrikeThrough, Subscript, Superscript, TabSet, Underline
方法摘要
从类 javax.swing.text.StyleConstants 继承的方法
getAlignment, getBackground, getBidiLevel, getComponent, getFirstLineIndent, getFontFamily, getFontSize, getForeground, getIcon, getLeftIndent, getLineSpacing, getRightIndent, getSpaceAbove, getSpaceBelow, getTabSet, isBold, isItalic, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setAlignment, setBackground, setBidiLevel, setBold, setComponent, setFirstLineIndent, setFontFamily, setFontSize, setForeground, setIcon, setItalic, setLeftIndent, setLineSpacing, setRightIndent, setSpaceAbove, setSpaceBelow, setStrikeThrough, setSubscript, setSuperscript, setTabSet, setUnderline, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleConstants.ColorConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyleConstants.ColorConstants

java.lang.Object
    继承者  javax.swing.text.StyleConstants
        继承者  javax.swing.text.StyleConstants.ColorConstants
所有已实现的接口：
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute
正在封闭类：
StyleConstants
public static class StyleConstants.ColorConstants
extends StyleConstants
implements AttributeSet.ColorAttribute, AttributeSet.CharacterAttribute

这是一个类型安全的已知 属性的枚举，它用于颜色样式。外部类为其起了别名，以便常规表示它们。

嵌套类摘要
从类 javax.swing.text.StyleConstants 继承的嵌套类/接口
StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants
字段摘要
从类 javax.swing.text.StyleConstants 继承的字段
ALIGN_CENTER, ALIGN_JUSTIFIED, ALIGN_LEFT, ALIGN_RIGHT, Alignment, Background, BidiLevel, Bold, ComponentAttribute, ComponentElementName, ComposedTextAttribute, Family, FirstLineIndent, FontFamily, FontSize, Foreground, IconAttribute, IconElementName, Italic, LeftIndent, LineSpacing, ModelAttribute, NameAttribute, Orientation, ResolveAttribute, RightIndent, Size, SpaceAbove, SpaceBelow, StrikeThrough, Subscript, Superscript, TabSet, Underline
方法摘要
从类 javax.swing.text.StyleConstants 继承的方法
getAlignment, getBackground, getBidiLevel, getComponent, getFirstLineIndent, getFontFamily, getFontSize, getForeground, getIcon, getLeftIndent, getLineSpacing, getRightIndent, getSpaceAbove, getSpaceBelow, getTabSet, isBold, isItalic, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setAlignment, setBackground, setBidiLevel, setBold, setComponent, setFirstLineIndent, setFontFamily, setFontSize, setForeground, setIcon, setItalic, setLeftIndent, setLineSpacing, setRightIndent, setSpaceAbove, setSpaceBelow, setStrikeThrough, setSubscript, setSuperscript, setTabSet, setUnderline, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleConstants.FontConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyleConstants.FontConstants

java.lang.Object
    继承者  javax.swing.text.StyleConstants
        继承者  javax.swing.text.StyleConstants.FontConstants
所有已实现的接口：
AttributeSet.CharacterAttribute, AttributeSet.FontAttribute
正在封闭类：
StyleConstants
public static class StyleConstants.FontConstants
extends StyleConstants
implements AttributeSet.FontAttribute, AttributeSet.CharacterAttribute

这是一个类型安全的已知 属性的枚举，它用于字体样式。外部类为其起了别名，以便常规表示它们。

嵌套类摘要
从类 javax.swing.text.StyleConstants 继承的嵌套类/接口
StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants
字段摘要
从类 javax.swing.text.StyleConstants 继承的字段
ALIGN_CENTER, ALIGN_JUSTIFIED, ALIGN_LEFT, ALIGN_RIGHT, Alignment, Background, BidiLevel, Bold, ComponentAttribute, ComponentElementName, ComposedTextAttribute, Family, FirstLineIndent, FontFamily, FontSize, Foreground, IconAttribute, IconElementName, Italic, LeftIndent, LineSpacing, ModelAttribute, NameAttribute, Orientation, ResolveAttribute, RightIndent, Size, SpaceAbove, SpaceBelow, StrikeThrough, Subscript, Superscript, TabSet, Underline
方法摘要
从类 javax.swing.text.StyleConstants 继承的方法
getAlignment, getBackground, getBidiLevel, getComponent, getFirstLineIndent, getFontFamily, getFontSize, getForeground, getIcon, getLeftIndent, getLineSpacing, getRightIndent, getSpaceAbove, getSpaceBelow, getTabSet, isBold, isItalic, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setAlignment, setBackground, setBidiLevel, setBold, setComponent, setFirstLineIndent, setFontFamily, setFontSize, setForeground, setIcon, setItalic, setLeftIndent, setLineSpacing, setRightIndent, setSpaceAbove, setSpaceBelow, setStrikeThrough, setSubscript, setSuperscript, setTabSet, setUnderline, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleConstants.ParagraphConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyleConstants.ParagraphConstants

java.lang.Object
    继承者  javax.swing.text.StyleConstants
        继承者  javax.swing.text.StyleConstants.ParagraphConstants
所有已实现的接口：
AttributeSet.ParagraphAttribute
正在封闭类：
StyleConstants
public static class StyleConstants.ParagraphConstants
extends StyleConstants
implements AttributeSet.ParagraphAttribute

这是一个类型安全的已知 属性的枚举，它用于段落样式。外部类为其起了别名，以便常规表示它们。

嵌套类摘要
从类 javax.swing.text.StyleConstants 继承的嵌套类/接口
StyleConstants.CharacterConstants, StyleConstants.ColorConstants, StyleConstants.FontConstants, StyleConstants.ParagraphConstants
字段摘要
从类 javax.swing.text.StyleConstants 继承的字段
ALIGN_CENTER, ALIGN_JUSTIFIED, ALIGN_LEFT, ALIGN_RIGHT, Alignment, Background, BidiLevel, Bold, ComponentAttribute, ComponentElementName, ComposedTextAttribute, Family, FirstLineIndent, FontFamily, FontSize, Foreground, IconAttribute, IconElementName, Italic, LeftIndent, LineSpacing, ModelAttribute, NameAttribute, Orientation, ResolveAttribute, RightIndent, Size, SpaceAbove, SpaceBelow, StrikeThrough, Subscript, Superscript, TabSet, Underline
方法摘要
从类 javax.swing.text.StyleConstants 继承的方法
getAlignment, getBackground, getBidiLevel, getComponent, getFirstLineIndent, getFontFamily, getFontSize, getForeground, getIcon, getLeftIndent, getLineSpacing, getRightIndent, getSpaceAbove, getSpaceBelow, getTabSet, isBold, isItalic, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setAlignment, setBackground, setBidiLevel, setBold, setComponent, setFirstLineIndent, setFontFamily, setFontSize, setForeground, setIcon, setItalic, setLeftIndent, setLineSpacing, setRightIndent, setSpaceAbove, setSpaceBelow, setStrikeThrough, setSubscript, setSuperscript, setTabSet, setUnderline, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyleContext

java.lang.Object
    继承者  javax.swing.text.StyleContext
所有已实现的接口：
Serializable, AbstractDocument.AttributeContext
直接已知子类：
StyleSheet
public class StyleContext
extends Object
implements Serializable, AbstractDocument.AttributeContext

样式池及其关联的资源。此类用于确定资源组的生存期，假定该资源组是一个容器，它保持各种资源的缓存，这些资源（如字体和颜色等）通过各种样式定义得以重用。如果需要最大化相关资源的共享，则可由多个文档来共享此类。

此类还对小属性集提供有效支持，并通过共享和利用其不变的特性来压缩这些小属性集。因为许多样式都是重复的，所以共享的潜能非常大，而且复制成本也相当低廉。较大的集合降低了共享的可能性，并因此自动转换回一种空间利用率低的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
class | StyleContext.NamedStyle 通常用于表示字符和段落样式的属性集合。
class | StyleContext.SmallAttributeSet 此类可在数组中存储少量的属性。
字段摘要
static String DEFAULT_STYLE
赋予与段落相关的默认逻辑样式的名称。
构造方法摘要
StyleContext()
创建新的 StyleContext 对象。
方法摘要
 AttributeSet addAttribute(AttributeSet old, Object name, Object value)
向给定的集合中添加属性，并返回新的有代表性的集合。
 AttributeSet addAttributes(AttributeSet old, AttributeSet attr)
向元素添加属性集。
 void addChangeListener(ChangeListener l)
添加一个侦听器，以跟踪何时添加或删除样式。
 Style addStyle(String nm, Style parent)
将新的样式添加到样式层次中。
protected  MutableAttributeSet createLargeAttributeSet(AttributeSet a)
创建一个以空间来换取时间的大属性集合。
protected  StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
创建一个可能用于共享的压缩属性集。
 Color getBackground(AttributeSet attr)
使用一个属性集并将其转换成为一个背景色规范。
 ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 StyleContext 中的所有 ChangeListener 组成的数组。
protected  int getCompressionThreshold()
返回键/值对的最大数目，尝试将其压缩到一个惟一/不可变的集合中。
static StyleContext getDefaultStyleContext()
返回由所有文档共享的默认 AttributeContext，这些文档不影响定义/提供其自己的上下文。
 AttributeSet getEmptySet()
获取空 AttributeSet。
 Font getFont(AttributeSet attr)
从属性集中获取字体。
 Font getFont(String family, int style, int size)
获取新字体。
 FontMetrics getFontMetrics(Font f)
获取某种字体的字体规格。
 Color getForeground(AttributeSet attr)
使用一个属性集并将其转换成为一个前景色规范。
static Object getStaticAttribute(Object key)
返回以前用 registerStaticAttributeKey 注册的对象。
static Object getStaticAttributeKey(Object key)
返回其 key 将要注册的 String
 Style getStyle(String nm)
获取以前添加到文档中的已命名样式
 Enumeration<?> getStyleNames()
获取定义的样式名称。
 void readAttributes(ObjectInputStream in, MutableAttributeSet a)
读入属性的特定于上下文的处理。
static void readAttributeSet(ObjectInputStream in, MutableAttributeSet a)
从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。
 void reclaim(AttributeSet a)
返回 MutableAttributeSet 实现不再需要的集合。
static void registerStaticAttributeKey(Object key)
将一个对象注册为用作属性集中的一个键的静态对象。
 AttributeSet removeAttribute(AttributeSet old, Object name)
从集合中移除一个属性。
 AttributeSet removeAttributes(AttributeSet old, AttributeSet attrs)
移除元素的属性集。
 AttributeSet removeAttributes(AttributeSet old, Enumeration<?> names)
移除元素的一个属性集。
 void removeChangeListener(ChangeListener l)
移除一个跟踪正被添加或移除样式的侦听器。
 void removeStyle(String nm)
移除以前添加到文档中的已命名样式。
 String toString()
将 StyleContext 转换成为 String。
 void writeAttributes(ObjectOutputStream out, AttributeSet a)
写出属性的特定于上下文的处理。
static void writeAttributeSet(ObjectOutputStream out, AttributeSet a)
将属性集写入到给定的对象流以便序列化。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_STYLE

public static final String DEFAULT_STYLE
赋予与段落相关的默认逻辑样式的名称。

另请参见：
常量字段值
构造方法详细信息

StyleContext

public StyleContext()
创建新的 StyleContext 对象。

方法详细信息

getDefaultStyleContext

public static final StyleContext getDefaultStyleContext()
返回由所有文档共享的默认 AttributeContext，这些文档不影响定义/提供其自己的上下文。

返回：
上下文

addStyle

public Style addStyle(String nm,
                      Style parent)
将新的样式添加到样式层次中。样式属性自下向上进行解析，所以在子级中指定的属性将重写父级中指定的属性。

参数：
nm - 样式的名称（其在文档中命名样式的集合内必须是惟一的）。如果样式未命名，则此名称可能为 null，但是调用者要负责管理返回的引用，因为未命名的样式不能通过其名称获取。未命名的样式可以用于诸如字符属性重写这样的情况（例如在样式运行中）。
parent - 父样式。如果未指定的属性不需要以其他样式解析，则此值可以为 null。
返回：
创建的样式

removeStyle

public void removeStyle(String nm)
移除以前添加到文档中的已命名样式。

参数：
nm - 要移除的样式名称

getStyle

public Style getStyle(String nm)
获取以前添加到文档中的已命名样式

参数：
nm - 样式名称
返回：
样式

getStyleNames

public Enumeration<?> getStyleNames()
获取定义的样式名称。

返回：
以枚举形式返回名称列表

addChangeListener

public void addChangeListener(ChangeListener l)
添加一个侦听器，以跟踪何时添加或删除样式。

参数：
l - 更改侦听器

removeChangeListener

public void removeChangeListener(ChangeListener l)
移除一个跟踪正被添加或移除样式的侦听器。

参数：
l - 更改侦听器

getChangeListeners

public ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 StyleContext 中的所有 ChangeListener 组成的数组。

返回：
所有添加的 ChangeListener，或者在没有添加侦听器时返回一个空数组
从以下版本开始：
1.4

getFont

public Font getFont(AttributeSet attr)
从属性集中获取字体。实现此方法以便尝试为给定的 AttributeSet 获取缓存字体，如果尝试失败，将解析字体特征，然后从低级字体缓存中获取字体。

参数：
attr - 属性集
返回：
字体

getForeground

public Color getForeground(AttributeSet attr)
使用一个属性集并将其转换成为一个前景色规范。此方法可以用于指定诸如更亮、更鲜艳等之类的内容。在默认情况下，它只返回由 StyleConstants.Foreground 属性指定的值。

参数：
attr - 属性集
返回：
颜色

getBackground

public Color getBackground(AttributeSet attr)
使用一个属性集并将其转换成为一个背景色规范。此方法可以用于指定诸如更亮、更鲜艳等之类的内容。在默认情况下，它只返回由 StyleConstants.Background 属性指定的值。

参数：
attr - 属性集
返回：
颜色

getFont

public Font getFont(String family,
                    int style,
                    int size)
获取新字体。如果存在缓存字体，则从缓存中返回一种 Font。如果缓存中不存在，则向缓存中添加一种字体。这基本上是一个针对 1.1 字体特征的低级别缓存。

参数：
family - 字体系列（如 "Monospaced"）
style - 字体的样式（比如 Font.PLAIN）
size - 点大小，该值 >= 1
返回：
新字体

getFontMetrics

public FontMetrics getFontMetrics(Font f)
获取某种字体的字体规格。

参数：
f - 字体
返回：
规格

addAttribute

public AttributeSet addAttribute(AttributeSet old,
                                 Object name,
                                 Object value)
向给定的集合中添加属性，并返回新的有代表性的集合。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 AbstractDocument.AttributeContext 中的 addAttribute
参数：
old - 原有属性集
name - 非 null 属性名称
value - 属性值
返回：
更新后的属性集
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

addAttributes

public AttributeSet addAttributes(AttributeSet old,
                                  AttributeSet attr)
向元素添加属性集。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 AbstractDocument.AttributeContext 中的 addAttributes
参数：
old - 原有属性集
attr - 要添加的属性
返回：
更新后的属性集
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

removeAttribute

public AttributeSet removeAttribute(AttributeSet old,
                                    Object name)
从集合中移除一个属性。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 AbstractDocument.AttributeContext 中的 removeAttribute
参数：
old - 原有的属性集
name - 非 null 属性名称
返回：
更新后的属性集
另请参见：
MutableAttributeSet.removeAttribute(java.lang.Object)

removeAttributes

public AttributeSet removeAttributes(AttributeSet old,
                                     Enumeration<?> names)
移除元素的一个属性集。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 AbstractDocument.AttributeContext 中的 removeAttributes
参数：
old - 原有属性集
names - 属性名
返回：
更新后的属性集
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

removeAttributes

public AttributeSet removeAttributes(AttributeSet old,
                                     AttributeSet attrs)
移除元素的属性集。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 AbstractDocument.AttributeContext 中的 removeAttributes
参数：
old - 原有属性集
attrs - 属性
返回：
更新后的属性集
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

getEmptySet

public AttributeSet getEmptySet()
获取空 AttributeSet。

指定者：
接口 AbstractDocument.AttributeContext 中的 getEmptySet
返回：
集合

reclaim

public void reclaim(AttributeSet a)
返回 MutableAttributeSet 实现不再需要的集合。因为在 1.1 以下没有弱引用，所以这对于操作很有用。此方法通常由 MutableAttributeSet 实现的初始化方法所调用。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 AbstractDocument.AttributeContext 中的 reclaim
参数：
a - 要回收的集合

getCompressionThreshold

protected int getCompressionThreshold()
返回键/值对的最大数目，尝试将其压缩到一个惟一/不可变的集合中。此限制之上的任何集合都将使用哈希表并且将成为一个 MutableAttributeSet。

返回：
阈值

createSmallAttributeSet

protected StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
创建一个可能用于共享的压缩属性集。这是想要改变 SmallAttributeSet 行为的子类的一个钩子。重新实现此方法以返回提供某种属性转换的 AttributeSet。

参数：
a - 以压缩形式表示的属性集。

createLargeAttributeSet

protected MutableAttributeSet createLargeAttributeSet(AttributeSet a)
创建一个以空间来换取时间的大属性集合。此集合将不共享。这是想要改变更大属性存储样式（默认情况下是 SimpleAttributeSet）的子类的一个钩子。重新实现此方法以返回提供某种属性转换的 MutableAttributeSet。

参数：
a - 以更大形式表示的属性集。

toString

public String toString()
将 StyleContext 转换成为 String。

覆盖：
类 Object 中的 toString
返回：
字符串

writeAttributes

public void writeAttributes(ObjectOutputStream out,
                            AttributeSet a)
                     throws IOException
写出属性的特定于上下文的处理。

抛出：
IOException

readAttributes

public void readAttributes(ObjectInputStream in,
                           MutableAttributeSet a)
                    throws ClassNotFoundException,
                           IOException
读入属性的特定于上下文的处理。

抛出：
ClassNotFoundException
IOException

writeAttributeSet

public static void writeAttributeSet(ObjectOutputStream out,
                                     AttributeSet a)
                              throws IOException
将属性集写入到给定的对象流以便序列化。此方法特别适用于处理使用 registerStaticAttributeKey 方法注册的静态属性键。任何没有注册为静态键的属性键都将被直接序列化。期望将所有的值都序列化。

参数：
out - 输出流
a - 属性集
抛出：
IOException - 如果发生任何 I/O 错误

readAttributeSet

public static void readAttributeSet(ObjectInputStream in,
                                    MutableAttributeSet a)
                             throws ClassNotFoundException,
                                    IOException
从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。这将试图将过去的静态对象键恢复为当前虚拟机中的静态对象键（假定使用 registerStaticAttributeKey 方法只注册了这些键）。从流检索的属性将被放置到给定的可变集合中。

参数：
in - 用来读取属性数据的对象流。
a - 放置属性定义的属性集
抛出：
ClassNotFoundException - 如果在读取对象流时遇到向上传递。
IOException - 如果在读取对象流时遇到向上传递。

registerStaticAttributeKey

public static void registerStaticAttributeKey(Object key)
将一个对象注册为用作属性集中的一个键的静态对象。序列化时允许特殊对待这种键。

对于 1.1 版本以下的虚拟机上的操作，这将使用由 toString 连接到类名所返回的值。为了在稍后重新计算时保持一致，由 toString 所返回的值不应该包含类的引用（即应当从 Object 中的定义重新实现）。

参数：
key - 非 null 对象键

getStaticAttribute

public static Object getStaticAttribute(Object key)
返回以前用 registerStaticAttributeKey 注册的对象。

getStaticAttributeKey

public static Object getStaticAttributeKey(Object key)
返回其 key 将要注册的 String

另请参见：
getStaticAttribute(java.lang.Object), registerStaticAttributeKey(java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleContext.NamedStyle (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyleContext.NamedStyle

java.lang.Object
    继承者  javax.swing.text.StyleContext.NamedStyle
所有已实现的接口：
Serializable, AttributeSet, MutableAttributeSet, Style
正在封闭类：
StyleContext
public class StyleContext.NamedStyle
extends Object
implements Style, Serializable

通常用于表示字符和段落样式的属性集合。这是 MutableAttributeSet（在需要时可以观察它）的一个实现。当集合足够小时这些样式将利用不可变性的优势，并且可能比诸如 SimpleAttributeSet 之类更为高效。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
protected ChangeEvent | changeEvent 由于事件的惟一状态（只读）为源属性，因此每个模型实例只需要一个 ChangeEvent。
protected EventListenerList | listenerList 模型的更改侦听器。
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
StyleContext.NamedStyle()
利用 null 名称和父级创建新的命名样式。
StyleContext.NamedStyle(String name, Style parent)
创建新的命名样式。
StyleContext.NamedStyle(Style parent)
创建新的命名样式。
方法摘要
 void addAttribute(Object name, Object value)
添加属性。
 void addAttributes(AttributeSet attr)
将属性集添加到元素。
 void addChangeListener(ChangeListener l)
添加更改侦听器。
 boolean containsAttribute(Object name, Object value)
确定给定的属性名称/值是否已定义。
 boolean containsAttributes(AttributeSet attrs)
检查元素是否包含了所有属性。
 AttributeSet copyAttributes()
复制属性集。
protected  void fireStateChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
 Object getAttribute(Object attrName)
获取属性的值。
 int getAttributeCount()
返回定义的属性数。
 Enumeration<?> getAttributeNames()
获取所有属性的名称。
 ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 NamedStyle 中的所有 ChangeListener 组成的数组。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
 String getName()
获取样式的名称。
 AttributeSet getResolveParent()
从父级获取属性。
 boolean isDefined(Object attrName)
确定给定属性是否已定义。
 boolean isEqual(AttributeSet attr)
检查两个属性集是否相等。
 void removeAttribute(Object name)
从集合中移除属性。
 void removeAttributes(AttributeSet attrs)
移除元素的属性集。
 void removeAttributes(Enumeration<?> names)
移除元素的属性集。
 void removeChangeListener(ChangeListener l)
移除更改侦听器。
 void setName(String name)
更改样式的名称。
 void setResolveParent(AttributeSet parent)
设置解析的父级。
 String toString()
将样式转换成为字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

listenerList

protected EventListenerList listenerList
模型的更改侦听器。

changeEvent

protected transient ChangeEvent changeEvent
由于事件的惟一状态（只读）为源属性，因此每个模型实例只需要一个 ChangeEvent。此处生成的事件源总是 "this"。

构造方法详细信息

StyleContext.NamedStyle

public StyleContext.NamedStyle(String name,
                               Style parent)
创建新的命名样式。

参数：
name - 样式名称，未命名则为 null
parent - 父样式，如果没有则为 null
从以下版本开始：
1.4

StyleContext.NamedStyle

public StyleContext.NamedStyle(Style parent)
创建新的命名样式。

参数：
parent - 父样式，如果没有则为 null
从以下版本开始：
1.4

StyleContext.NamedStyle

public StyleContext.NamedStyle()
利用 null 名称和父级创建新的命名样式。

方法详细信息

toString

public String toString()
将样式转换成为字符串。

覆盖：
类 Object 中的 toString
返回：
字符串

getName

public String getName()
获取样式的名称。样式不是必须命名的，因此如果没有与该样式关联的名称，则返回 null。

指定者：
接口 Style 中的 getName
返回：
名称

setName

public void setName(String name)
更改样式的名称。利用 null 名称不能执行任何操作。

参数：
name - 新名称

addChangeListener

public void addChangeListener(ChangeListener l)
添加更改侦听器。

指定者：
接口 Style 中的 addChangeListener
参数：
l - 更改侦听器

removeChangeListener

public void removeChangeListener(ChangeListener l)
移除更改侦听器。

指定者：
接口 Style 中的 removeChangeListener
参数：
l - 更改侦听器

getChangeListeners

public ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 NamedStyle 中的所有 ChangeListener 组成的数组。

返回：
所有添加的 ChangeListener，或者在没有添加侦听器时返回空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。事件实例是使用传入到 fire 方法的参数延后创建的。

另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。

返回：
从模型中接收 listenerType 通知的所有对象。
从以下版本开始：
1.3

getAttributeCount

public int getAttributeCount()
返回定义的属性数。

指定者：
接口 AttributeSet 中的 getAttributeCount
返回：
属性数，大于等于 0
另请参见：
AttributeSet.getAttributeCount()

isDefined

public boolean isDefined(Object attrName)
确定给定属性是否已定义。

指定者：
接口 AttributeSet 中的 isDefined
参数：
attrName - 非空的属性名
返回：
如果属性已定义，则返回 true
另请参见：
AttributeSet.isDefined(java.lang.Object)

isEqual

public boolean isEqual(AttributeSet attr)
检查两个属性集是否相等。

指定者：
接口 AttributeSet 中的 isEqual
参数：
attr - 要检查的属性集
返回：
如果相同返回 true
另请参见：
AttributeSet.isEqual(javax.swing.text.AttributeSet)

copyAttributes

public AttributeSet copyAttributes()
复制属性集。

指定者：
接口 AttributeSet 中的 copyAttributes
返回：
副本
另请参见：
AttributeSet.copyAttributes()

getAttribute

public Object getAttribute(Object attrName)
获取属性的值。

指定者：
接口 AttributeSet 中的 getAttribute
参数：
attrName - 非空属性名
返回：
属性值
另请参见：
AttributeSet.getAttribute(java.lang.Object)

getAttributeNames

public Enumeration<?> getAttributeNames()
获取所有属性的名称。

指定者：
接口 AttributeSet 中的 getAttributeNames
返回：
以枚举形式返回属性名称
另请参见：
AttributeSet.getAttributeNames()

containsAttribute

public boolean containsAttribute(Object name,
                                 Object value)
确定给定的属性名称/值是否已定义。

指定者：
接口 AttributeSet 中的 containsAttribute
参数：
name - 非空属性名
value - 属性值
返回：
如果名称/值已定义则返回为 true
另请参见：
AttributeSet.containsAttribute(java.lang.Object, java.lang.Object)

containsAttributes

public boolean containsAttributes(AttributeSet attrs)
检查元素是否包含了所有属性。

指定者：
接口 AttributeSet 中的 containsAttributes
参数：
attrs - 要检查的属性
返回：
如果元素包含了所有属性，则返回 true
另请参见：
AttributeSet.containsAttributes(javax.swing.text.AttributeSet)

getResolveParent

public AttributeSet getResolveParent()
从父级获取属性。如果未重写，则解析父级默认为父元素。

指定者：
接口 AttributeSet 中的 getResolveParent
返回：
来自父级的属性
另请参见：
AttributeSet.getResolveParent()

addAttribute

public void addAttribute(Object name,
                         Object value)
添加属性。

指定者：
接口 MutableAttributeSet 中的 addAttribute
参数：
name - 非空属性名
value - 属性值
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

addAttributes

public void addAttributes(AttributeSet attr)
将属性集添加到元素。

指定者：
接口 MutableAttributeSet 中的 addAttributes
参数：
attr - 要添加的属性
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

removeAttribute

public void removeAttribute(Object name)
从集合中移除属性。

指定者：
接口 MutableAttributeSet 中的 removeAttribute
参数：
name - 非空属性名
另请参见：
MutableAttributeSet.removeAttribute(java.lang.Object)

removeAttributes

public void removeAttributes(Enumeration<?> names)
移除元素的属性集。

指定者：
接口 MutableAttributeSet 中的 removeAttributes
参数：
names - 属性名称
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

removeAttributes

public void removeAttributes(AttributeSet attrs)
移除元素的属性集。

指定者：
接口 MutableAttributeSet 中的 removeAttributes
参数：
attrs - 属性
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

setResolveParent

public void setResolveParent(AttributeSet parent)
设置解析的父级。

指定者：
接口 MutableAttributeSet 中的 setResolveParent
参数：
parent - 父级，如果没有则为 null
另请参见：
MutableAttributeSet.setResolveParent(javax.swing.text.AttributeSet)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleContext.SmallAttributeSet (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyleContext.SmallAttributeSet

java.lang.Object
    继承者  javax.swing.text.StyleContext.SmallAttributeSet
所有已实现的接口：
AttributeSet
正在封闭类：
StyleContext
public class StyleContext.SmallAttributeSet
extends Object
implements AttributeSet

此类可在数组中存储少量的属性。存储格式为键、值、键、值等等。集合的大小是数组的长度除以 2。默认情况下，这是以压缩可共享形式存储属性时所用的类。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
StyleContext.SmallAttributeSet(AttributeSet attrs)
StyleContext.SmallAttributeSet(Object[] attributes)
方法摘要
Object | clone() 复制属性集。
boolean | containsAttribute(Object name, Object value) 检查给定的属性名称/值是否已定义。
boolean | containsAttributes(AttributeSet attrs) 检查属性集是否包含了所有给定的属性。
AttributeSet | copyAttributes() 复制属性集。
boolean | equals(Object obj) 将此对象与指定对象比较。
Object | getAttribute(Object key) 获取属性的值。
int | getAttributeCount() 返回定义的属性数。
Enumeration<?> | getAttributeNames() 获取所有属性的名称。
AttributeSet | getResolveParent() 如果未重写，解析父级默认为是解析父元素。
int | hashCode() 返回此属性集的一个哈希代码。
boolean | isDefined(Object key) 检查给定属性是否已定义。
boolean | isEqual(AttributeSet attr) 检查两个属性集是否相等。
String | toString() 返回表示键/值对的字符串
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

StyleContext.SmallAttributeSet

public StyleContext.SmallAttributeSet(Object[] attributes)

StyleContext.SmallAttributeSet

public StyleContext.SmallAttributeSet(AttributeSet attrs)
方法详细信息

toString

public String toString()
返回表示键/值对的字符串

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

hashCode

public int hashCode()
返回此属性集的一个哈希代码。

覆盖：
类 Object 中的 hashCode
返回：
此属性集的一个哈希代码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。如果此对象是一个等同的属性集，则结果为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
Object.hashCode(), Hashtable

clone

public Object clone()
复制属性集。因为该集合是不可变的，复制副本实际上就是同一个集合。

覆盖：
类 Object 中的 clone
返回：
属性集
另请参见：
Cloneable

getAttributeCount

public int getAttributeCount()
返回定义的属性数。

指定者：
接口 AttributeSet 中的 getAttributeCount
返回：
属性数
另请参见：
AttributeSet.getAttributeCount()

isDefined

public boolean isDefined(Object key)
检查给定属性是否已定义。

指定者：
接口 AttributeSet 中的 isDefined
参数：
key - 属性键
返回：
如果属性已定义，则返回 true
另请参见：
AttributeSet.isDefined(java.lang.Object)

isEqual

public boolean isEqual(AttributeSet attr)
检查两个属性集是否相等。

指定者：
接口 AttributeSet 中的 isEqual
参数：
attr - 所要检查的属性集
返回：
如果相同，返回 true
另请参见：
AttributeSet.isEqual(javax.swing.text.AttributeSet)

copyAttributes

public AttributeSet copyAttributes()
复制属性集。

指定者：
接口 AttributeSet 中的 copyAttributes
返回：
副本
另请参见：
AttributeSet.copyAttributes()

getAttribute

public Object getAttribute(Object key)
获取属性的值。

指定者：
接口 AttributeSet 中的 getAttribute
参数：
key - 属性名称
返回：
属性值
另请参见：
AttributeSet.getAttribute(java.lang.Object)

getAttributeNames

public Enumeration<?> getAttributeNames()
获取所有属性的名称。

指定者：
接口 AttributeSet 中的 getAttributeNames
返回：
属性名称
另请参见：
AttributeSet.getAttributeNames()

containsAttribute

public boolean containsAttribute(Object name,
                                 Object value)
检查给定的属性名称/值是否已定义。

指定者：
接口 AttributeSet 中的 containsAttribute
参数：
name - 属性名称
value - 属性值
返回：
如果名称/值已定义，则返回为 true
另请参见：
AttributeSet.containsAttribute(java.lang.Object, java.lang.Object)

containsAttributes

public boolean containsAttributes(AttributeSet attrs)
检查属性集是否包含了所有给定的属性。

指定者：
接口 AttributeSet 中的 containsAttributes
参数：
attr - 要检查的属性
返回：
如果该元素包含所有的属性，则返回 true
另请参见：
AttributeSet.containsAttributes(javax.swing.text.AttributeSet)

getResolveParent

public AttributeSet getResolveParent()
如果未重写，解析父级默认为是解析父元素。

指定者：
接口 AttributeSet 中的 getResolveParent
返回：
来自父级的属性
另请参见：
AttributeSet.getResolveParent()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledDocument (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 StyledDocument

所有超级接口：
Document
所有已知实现类：
DefaultStyledDocument, HTMLDocument
public interface StyledDocument
extends Document

用作通用样式化文档的接口。

字段摘要
从接口 javax.swing.text.Document 继承的字段
StreamDescriptionProperty, TitleProperty
方法摘要
Style | addStyle(String nm, Style parent) 向逻辑样式层次中添加新样式。
Color | getBackground(AttributeSet attr) 使用一个属性集并将其转换为一个背景色规范。
Element | getCharacterElement(int pos) 获取表示文档中给定偏移量处字符的元素。
Font | getFont(AttributeSet attr) 使用一个属性集并将其转换为字体规范。
Color | getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
Style | getLogicalStyle(int p) 获取段落中给定位置的逻辑样式。
Element | getParagraphElement(int pos) 获取表示包含文档中给定偏移量的段落的元素。
Style | getStyle(String nm) 获取以前添加的指定样式。
void | removeStyle(String nm) 移除以前添加到文档中的指定样式。
void | setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace) 更改内容元素属性，该属性是用来给定文档中现有内容范围的。
void | setLogicalStyle(int pos, Style s) 设置给定位置的段落所用的逻辑样式。
void | setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
从接口 javax.swing.text.Document 继承的方法
addDocumentListener, addUndoableEditListener, createPosition, getDefaultRootElement, getEndPosition, getLength, getProperty, getRootElements, getStartPosition, getText, getText, insertString, putProperty, remove, removeDocumentListener, removeUndoableEditListener, render

方法详细信息

addStyle

Style addStyle(String nm,
               Style parent)
向逻辑样式层次中添加新样式。样式属性自下向上进行解析，所以在子级中指定的属性将重写父级中指定的属性。

参数：
nm - 样式的名称（在命名样式集合中必须是惟一的）。如果样式未命名，则此名称可能为 null，但是调用者要负责管理返回的引用，因为未命名的样式不能通过其名称获取。未命名的样式可以用于诸如字符属性重写这样的情况（例如在样式运行中）。
parent - 父样式。如果未指定的属性不需要以其他样式解析，则此值可以为 null。
返回：
样式

removeStyle

void removeStyle(String nm)
移除以前添加到文档中的指定样式。

参数：
nm - 要移除的样式的名称

getStyle

Style getStyle(String nm)
获取以前添加的指定样式。

参数：
nm - 样式名称
返回：
样式

setCharacterAttributes

void setCharacterAttributes(int offset,
                            int length,
                            AttributeSet s,
                            boolean replace)
更改内容元素属性，该属性是用来给定文档中现有内容范围的。给定 Attributes 参数中定义的所有属性都适用于此给定的范围。此方法可用来完全移除给定范围的所有内容层次的属性，这是通过提供尚未定义属性的 AttributeSet 参数和将 replace 参数设置为 true 实现的。

参数：
offset - 开始更改处，该值 >= 0
length - 更改的长度，该值 >= 0
s - 要更改为的非 null 属性。任何定义的属性都将适用于此给定范围的文本。
replace - 表示在设置新属性时是否清除以前的属性。如果为 true，此操作将完全替换以前的属性。如果为 false，新属性将与以前的属性合并。

setParagraphAttributes

void setParagraphAttributes(int offset,
                            int length,
                            AttributeSet s,
                            boolean replace)
设置段落属性。

参数：
offset - 开始更改处，该值 >= 0
length - 更改的长度，该值 >= 0
s - 要更改为的非 null 属性。任何定义的属性都将适用于此给定范围的文本。
replace - 表示在设置新属性时是否清除以前的属性。如果为 true，此操作将完全替换以前的属性。如果为 false，新属性将与以前的属性合并。

setLogicalStyle

void setLogicalStyle(int pos,
                     Style s)
设置给定位置的段落所用的逻辑样式。如果没有为字符和段落属性显式设置属性，则它们将通过分配到段落的逻辑样式进行解析，也就是通过某个层次结构来解析，这些层次结构完全独立于文档中元素的层次结构。

参数：
pos - 开始位置，该值 >= 0
s - 要设置的样式

getLogicalStyle

Style getLogicalStyle(int p)
获取段落中给定位置的逻辑样式。

参数：
p - 位置，该值 >= 0
返回：
样式

getParagraphElement

Element getParagraphElement(int pos)
获取表示包含文档中给定偏移量的段落的元素。

参数：
pos - 偏移量，该值 >= 0
返回：
元素

getCharacterElement

Element getCharacterElement(int pos)
获取表示文档中给定偏移量处字符的元素。

参数：
pos - 偏移量，该值 >= 0
返回：
元素

getForeground

Color getForeground(AttributeSet attr)
使用一个属性集并将其转换成为一个前景色规范。此方法可以用于指定诸如更亮、更鲜艳等之类的内容。

参数：
attr - 属性集
返回：
颜色

getBackground

Color getBackground(AttributeSet attr)
使用一个属性集并将其转换为一个背景色规范。此方法可以用于指定诸如更亮、更鲜艳等之类的内容。

参数：
attr - 属性集
返回：
颜色

getFont

Font getFont(AttributeSet attr)
使用一个属性集并将其转换为字体规范。此操作可用于将诸如系列、样式、大小等一类的东西转换为当前文档所用的系统中可用的字体。

参数：
attr - 属性集
返回：
字体
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit

java.lang.Object
    继承者  javax.swing.text.EditorKit
        继承者  javax.swing.text.DefaultEditorKit
            继承者  javax.swing.text.StyledEditorKit
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
HTMLEditorKit, RTFEditorKit
public class StyledEditorKit
extends DefaultEditorKit

这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。此实现提供了一个默认实现，该默认实现把文本当做样式化文本，并提供编辑样式化文本的最小操作集合。

嵌套类摘要
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
从类 javax.swing.text.DefaultEditorKit 继承的嵌套类/接口
DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction
字段摘要
从类 javax.swing.text.DefaultEditorKit 继承的字段
backwardAction, beepAction, beginAction, beginLineAction, beginParagraphAction, beginWordAction, copyAction, cutAction, defaultKeyTypedAction, deleteNextCharAction, deleteNextWordAction, deletePrevCharAction, deletePrevWordAction, downAction, endAction, endLineAction, EndOfLineStringProperty, endParagraphAction, endWordAction, forwardAction, insertBreakAction, insertContentAction, insertTabAction, nextWordAction, pageDownAction, pageUpAction, pasteAction, previousWordAction, readOnlyAction, selectAllAction, selectionBackwardAction, selectionBeginAction, selectionBeginLineAction, selectionBeginParagraphAction, selectionBeginWordAction, selectionDownAction, selectionEndAction, selectionEndLineAction, selectionEndParagraphAction, selectionEndWordAction, selectionForwardAction, selectionNextWordAction, selectionPreviousWordAction, selectionUpAction, selectLineAction, selectParagraphAction, selectWordAction, upAction, writableAction
构造方法摘要
StyledEditorKit()
创建供样式化文档使用新的 EditorKit。
方法摘要
Object | clone() 创建此编辑器工具包的一个副本。
Document | createDefaultDocument() 创建一个适合此编辑器类型的未初始化文本存储模型。
protected void | createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
void | deinstall(JEditorPane c) 工具包从 JEditorPane 移除时调用。
Action[] | getActions() 获取编辑器的命令列表。
Element | getCharacterAttributeRun() 获取表示该插入符处当前运行的字符属性的元素。
MutableAttributeSet | getInputAttributes() 获取该窗格的输入属性。
ViewFactory | getViewFactory() 获取一个适合供由此包所产生的任何模型来产生视图的工厂。
void | install(JEditorPane c) 工具包安装到 JEditorPane 时调用。
从类 javax.swing.text.DefaultEditorKit 继承的方法
createCaret, getContentType, read, read, write, write
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyledEditorKit

public StyledEditorKit()
创建供样式化文档使用新的 EditorKit。

方法详细信息

getInputAttributes

public MutableAttributeSet getInputAttributes()
获取该窗格的输入属性。当插入符移动并且没有选定项时，则输入属性将自动变化来反映当前插入符位置的字符属性。样式化编辑操作使用输入属性来执行其操作。

返回：
属性集

getCharacterAttributeRun

public Element getCharacterAttributeRun()
获取表示该插入符处当前运行的字符属性的元素。

返回：
元素

getActions

public Action[] getActions()
获取编辑器的命令列表。此命令列表受超类支持，该超类是通过样式操作的本地定义的命令集合扩展的。

覆盖：
类 DefaultEditorKit 中的 getActions
返回：
命令列表

createDefaultDocument

public Document createDefaultDocument()
创建一个适合此编辑器类型的未初始化文本存储模型。

覆盖：
类 DefaultEditorKit 中的 createDefaultDocument
返回：
模型

install

public void install(JEditorPane c)
工具包安装到 JEditorPane 时调用。

覆盖：
类 EditorKit 中的 install
参数：
c - 该 JEditorPane

deinstall

public void deinstall(JEditorPane c)
工具包从 JEditorPane 移除时调用。这可用于取消对任何所关联侦听器的注册。

覆盖：
类 EditorKit 中的 deinstall
参数：
c - 该 JEditorPane

getViewFactory

public ViewFactory getViewFactory()
获取一个适合供由此包所产生的任何模型来产生视图的工厂。实现此方法来返回下列种类的元素的 View 实现。
  • AbstractDocument.ContentElementName
  • AbstractDocument.ParagraphElementName
  • AbstractDocument.SectionElementName
  • StyleConstants.ComponentElementName
  • StyleConstants.IconElementName

覆盖：
类 DefaultEditorKit 中的 getViewFactory
返回：
工厂

clone

public Object clone()
创建此编辑器工具包的一个副本。

覆盖：
类 EditorKit 中的 clone
返回：
副本
另请参见：
Cloneable

createInputAttributes

protected void createInputAttributes(Element element,
                                     MutableAttributeSet set)
将 element 的 AttributeSet 键/值复制到 set 中。这操作不复制组件、图标或者元素名称属性。子类可能希望修改此处要复制什么，不复制什么。确保首先移除 set 中的所有属性。

这在插入符移到一个不同位置时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit.AlignmentAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit.AlignmentAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.StyledEditorKit.AlignmentAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
StyledEditorKit
public static class StyledEditorKit.AlignmentAction
extends StyledEditorKit.StyledTextAction

设置段落对齐的操作。此操作为当前选中的目标 JEditorPane 的范围设置 StyleConstants.Alignment 属性。该操作是通过在与此目标 JEditorPane 相关的样式文档上调用 StyledDocument.setParagraphAttributes 来完成的。

如果目标文本组件被指定为 ActionEvent 的源，则存在一个命令字符串，该命令字符串将被解释为一个整数，该整数应为 StyleConstants.Alignment 属性中的合法值之一。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
StyledEditorKit.AlignmentAction(String nm, int a)
创建新的 AlignmentAction。
方法摘要
 void actionPerformed(ActionEvent e)
设置对齐方式。
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyledEditorKit.AlignmentAction

public StyledEditorKit.AlignmentAction(String nm,
                                       int a)
创建新的 AlignmentAction。

参数：
nm - 操作名
a - 对齐方式，该值 >= 0
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
设置对齐方式。

参数：
e - 操作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit.BoldAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit.BoldAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.StyledEditorKit.BoldAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
StyledEditorKit
public static class StyledEditorKit.BoldAction
extends StyledEditorKit.StyledTextAction

切换粗体属性的操作。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
StyledEditorKit.BoldAction()
构造新的 BoldAction。
方法摘要
 void actionPerformed(ActionEvent e)
切换粗体属性。
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyledEditorKit.BoldAction

public StyledEditorKit.BoldAction()
构造新的 BoldAction。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
切换粗体属性。

参数：
e - 操作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TabableView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 TabableView

所有已知实现类：
GlyphView, InlineView, LabelView
public interface TabableView

大小依赖于制表符的 View 的接口。

另请参见：
TabExpander, LabelView, ParagraphView

方法摘要
float | getPartialSpan(int p0, int p1) 确定部分视图沿与制表符扩展相同的轴的跨距。
float | getTabbedSpan(float x, TabExpander e) 确定当使用给定的制表符扩展实现时所需的跨距。

方法详细信息

getTabbedSpan

float getTabbedSpan(float x,
                    TabExpander e)
确定当使用给定的制表符扩展实现时所需的跨距。如果某个容器要调用此方法，则其将在调用 getPreferredSpan 得到正常布局之前进行此操作。实现此方法的视图应该对沿制表符扩展轴的 getPreferredSpan 任何后续调用给出相同的结果。

参数：
x - 为制表符扩展目的而放置视图的位置，该值 >= 0。
e - 遇到制表符时扩展的方式。
返回：
所需的跨距，该值 >= 0

getPartialSpan

float getPartialSpan(int p0,
                     int p1)
确定部分视图沿与制表符扩展相同的轴的跨距。此方法供 TabExpander 使用，用于制表符扩展涉及到对齐相对于制表位 (tab stop) 没有空格的部分文本的情况。因此存在一个假设，即给定的范围中不包含制表符。

参数：
p0 - 文本文档中的起始位置，该值 >= 0
p1 - 文本文档中的结束位置，该值 >= p0
返回：
跨距，该值 >= 0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit.FontFamilyAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit.FontFamilyAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.StyledEditorKit.FontFamilyAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
StyledEditorKit
public static class StyledEditorKit.FontFamilyAction
extends StyledEditorKit.StyledTextAction

在相关的 JEditorPane 中设置字体系列的操作。此方法将使用 ActionEvent 上作为命令字符串指定的系列（如果有），否则将使用过去初始化的系列。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
StyledEditorKit.FontFamilyAction(String nm, String family)
创建新的 FontFamilyAction。
方法摘要
 void actionPerformed(ActionEvent e)
设置字体系列。
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyledEditorKit.FontFamilyAction

public StyledEditorKit.FontFamilyAction(String nm,
                                        String family)
创建新的 FontFamilyAction。

参数：
nm - 操作名
family - 字体系列
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
设置字体系列。

参数：
e - 事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit.FontSizeAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit.FontSizeAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.StyledEditorKit.FontSizeAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
StyledEditorKit
public static class StyledEditorKit.FontSizeAction
extends StyledEditorKit.StyledTextAction

设置关联的 JEditorPane 中字体大小的操作。此方法将使用 ActionEvent 上作为命令字符串指定的系列（如果有），否则将使用过去初始化的系列。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
StyledEditorKit.FontSizeAction(String nm, int size)
创建新 FontSizeAction。
方法摘要
 void actionPerformed(ActionEvent e)
设置字体大小。
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyledEditorKit.FontSizeAction

public StyledEditorKit.FontSizeAction(String nm,
                                      int size)
创建新 FontSizeAction。

参数：
nm - 操作名
family - 字体系列
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
设置字体大小。

参数：
e - 操作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit.ForegroundAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit.ForegroundAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.StyledEditorKit.ForegroundAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
StyledEditorKit
public static class StyledEditorKit.ForegroundAction
extends StyledEditorKit.StyledTextAction

设置前景色的操作。此操作为当前选中的目标 JEditorPane 的范围设置 StyleConstants.Foreground 属性。该操作通过在与目标 JEditorPane 相关联的样式文档上调用 StyledDocument.setCharacterAttributes 来完成。

如果目标文本组件被指定为 ActionEvent 的源，则存在一个命令字符串，该命令字符串将被解释成为前景色。调用 Color.decode 来解释该字符串，而且因此对该方法而言，它是合法的输入。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
StyledEditorKit.ForegroundAction(String nm, Color fg)
创建新的 ForegroundAction。
方法摘要
 void actionPerformed(ActionEvent e)
设置前景色。
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyledEditorKit.ForegroundAction

public StyledEditorKit.ForegroundAction(String nm,
                                        Color fg)
创建新的 ForegroundAction。

参数：
nm - 操作名
fg - 前景色
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
设置前景色。

参数：
e - 操作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit.ItalicAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit.ItalicAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.StyledEditorKit.ItalicAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
StyledEditorKit
public static class StyledEditorKit.ItalicAction
extends StyledEditorKit.StyledTextAction

切换斜体属性的一种操作。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
StyledEditorKit.ItalicAction()
构造新的 ItalicAction。
方法摘要
 void actionPerformed(ActionEvent e)
切换斜体属性。
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyledEditorKit.ItalicAction

public StyledEditorKit.ItalicAction()
构造新的 ItalicAction。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
切换斜体属性。

参数：
e - 操作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit.StyledTextAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit.StyledTextAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
直接已知子类：
HTMLEditorKit.HTMLTextAction, StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.UnderlineAction
正在封闭类：
StyledEditorKit
public abstract static class StyledEditorKit.StyledTextAction
extends TextAction

假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。此操作具有一些便捷的方法，能导致字符或段落级的属性更改。如果假定 StyledDocument、JEditorPane 或 StyledEditorKit 失败为 true，则此便捷方法将抛出一个 IllegalArgumentException。

如果 ActionEvent 的源可缩小为一个 JEditorPane 类型，则事件在其上执行的组件将成为 ActionEvent 的源。如果该源不能缩小，则更改最近获得焦点的文本组件。如果不是以上两种情况，则不能执行该操作。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
StyledEditorKit.StyledTextAction(String nm)
通过字符串操作名称创建新的 StyledTextAction。
方法摘要
protected JEditorPane | getEditor(ActionEvent e) 获得操作的目标编辑器。
protected StyledDocument | getStyledDocument(JEditorPane e) 获取与编辑器窗格相关的文档。
protected StyledEditorKit | getStyledEditorKit(JEditorPane e) 获取与编辑器窗格相关的编辑器工具包。
protected void | setCharacterAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对字符内容应用给定的属性。
protected void | setParagraphAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对段落应用给定的属性。
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.event.ActionListener 继承的方法
actionPerformed

构造方法详细信息

StyledEditorKit.StyledTextAction

public StyledEditorKit.StyledTextAction(String nm)
通过字符串操作名称创建新的 StyledTextAction。

参数：
nm - 操作名称
方法详细信息

getEditor

protected final JEditorPane getEditor(ActionEvent e)
获得操作的目标编辑器。

参数：
e - 操作事件
返回：
编辑器

getStyledDocument

protected final StyledDocument getStyledDocument(JEditorPane e)
获取与编辑器窗格相关的文档。

参数：
e - 编辑器
返回：
文档
抛出：
IllegalArgumentException - 如果文档类型错误

getStyledEditorKit

protected final StyledEditorKit getStyledEditorKit(JEditorPane e)
获取与编辑器窗格相关的编辑器工具包。

参数：
e - 编辑器窗格
返回：
工具包
抛出：
IllegalArgumentException - 如果文档类型错误

setCharacterAttributes

protected final void setCharacterAttributes(JEditorPane editor,
                                            AttributeSet attr,
                                            boolean replace)
对字符内容应用给定的属性。如果有选定项，则属性将应用于该选定范围。如果没有选定项，该属性将应用于输入属性集，该输入属性集为任何插入的新文本定义了属性。

参数：
editor - 编辑器
attr - 属性
replace - 如果为 true，则首先替换现有的属性

setParagraphAttributes

protected final void setParagraphAttributes(JEditorPane editor,
                                            AttributeSet attr,
                                            boolean replace)
对段落应用给定的属性。如果有选定项，该属性将应用于与选定项相交的段落。如果没有选定项，该属性将应用于当前插入符处的段落。

参数：
editor - 编辑器
attr - 属性
replace - 如果为 true，则首先替换现有的属性
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyledEditorKit.UnderlineAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 StyledEditorKit.UnderlineAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.StyledEditorKit.UnderlineAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
StyledEditorKit
public static class StyledEditorKit.UnderlineAction
extends StyledEditorKit.StyledTextAction

切换下划线属性的操作。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
StyledEditorKit.UnderlineAction()
创建新的 UnderlineAction。
方法摘要
 void actionPerformed(ActionEvent e)
切换下划线属性。
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StyledEditorKit.UnderlineAction

public StyledEditorKit.UnderlineAction()
创建新的 UnderlineAction。

方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
切换下划线属性。

参数：
e - 操作事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TabExpander (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 TabExpander

所有已知实现类：
FieldView, ParagraphView, ParagraphView, PasswordView, PlainView, WrappedPlainView
public interface TabExpander

允许不同类型的制表符扩展实现的简单接口。

方法摘要
 float nextTabStop(float x, int tabOffset)
给定一个引用位置，返回下一个制表位 (tab stop) 位置。

方法详细信息

nextTabStop

float nextTabStop(float x,
                  int tabOffset)
给定一个引用位置，返回下一个制表位 (tab stop) 位置。值以点为单位表示。

参数：
x - 以点为单位的位置，该值 >= 0
tabOffset - 文本流中的位置，制表符在该处出现，该值 >= 0。
返回：
下一个制表位，该值 >= 0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 TableView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.TableView
所有已实现的接口：
SwingConstants
public abstract class TableView
extends BoxView

为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。在单元格元素下可以有任意的元素结构，这将由通过 getViewFactory 方法返回的 ViewFactory 来构建。

    表
      行
        单元格
        单元格
      行
        单元格
        单元格

此类实现为一个框的层次，表本身是垂直框，行是水平框，单元格是垂直框。单元格允许跨越多个列和行。在默认情况下，表可认为是在网格之上形成的（即可以在网格包布局中找到类似物），其中表单元格能请求跨越多个网格单元格。默认情况下，表单元格的水平跨距以此网格为基础，但是可以通过重新实现所请求的单元格跨距来更改（即需要时表单元格可以具有独立的跨距）。

另请参见：
View

嵌套类摘要
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
TableView(Element elem)
针对给定的元素构造一个 TableView。
方法摘要
protected SizeRequirements | calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴的所需大小。
protected TableView.TableCell | createTableCell(Element elem) 已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。
protected TableView.TableRow | createTableRow(Element elem) 创建新的表格行。
protected void | forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected View | getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected void | layoutColumns(int targetSpan, int[] offsets, int[] spans, SizeRequirements[] reqs) 布局列，使其符合给定的目标跨距。
protected void | layoutMinorAxis(int targetSpan, int axis, int[] offsets, int[] spans) 针对框的辅轴（即垂直于其所表示的轴的轴）执行布局操作。
void | replace(int offset, int length, View[] views) 更改子视图。
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, flipEastAndWestAtEnds, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, modelToView, paint, paintChild, preferenceChanged, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets, setParent
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableView

public TableView(Element elem)
针对给定的元素构造一个 TableView。

参数：
elem - 此视图所负责的元素
方法详细信息

createTableRow

protected TableView.TableRow createTableRow(Element elem)
创建新的表格行。

参数：
elem - 元素
返回：
行

createTableCell

@Deprecated
protected TableView.TableCell createTableCell(Element elem)
已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。

参数：
elem - 元素
返回：
单元格

forwardUpdate

protected void forwardUpdate(DocumentEvent.ElementChange ec,
                             DocumentEvent e,
                             Shape a,
                             ViewFactory f)
从类 BoxView 复制的描述
将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。如果有一个子级更改了它的要求并且在转发前分配为有效，则框中从开始子级到框结束部分将被重新绘制。

覆盖：
类 BoxView 中的 forwardUpdate
参数：
ec - 此视图负责的元素发生的更改（如果未发生更改，则为 null）
e - 来自相关文档的更改信息
a - 视图的当前分配
f - 重新构造时需要使用的工厂（如果视图有子级）
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

replace

public void replace(int offset,
                    int length,
                    View[] views)
更改子视图。实现此方法来提供超类的行为并且使网格无效，以便对行和列进行重新计算。

覆盖：
类 BoxView 中的 replace
参数：
offset - 要插入新视图的子视图的开始索引；其值 >= 0 且 <= getViewCount
length - 要移除的现有子视图数；其值 >= 0 且 <= (getViewCount() - offset)
views - 要添加的子视图；此值可以为 null，表示没有要添加的子级（对移除有用）

layoutColumns

protected void layoutColumns(int targetSpan,
                             int[] offsets,
                             int[] spans,
                             SizeRequirements[] reqs)
布局列，使其符合给定的目标跨距。通过 offsets 和 spans 返回结果。

参数：
targetSpan - 所有表格列总的给定跨距
reqs - 每一列的所需大小。此参数是请求最小、首选、最大跨距的单元的列最大值
spans - 分配给每一列的量的返回值
offsets - 距每一列起始点的偏移量的返回值

layoutMinorAxis

protected void layoutMinorAxis(int targetSpan,
                               int axis,
                               int[] offsets,
                               int[] spans)
针对框的辅轴（即垂直于其所表示的轴的轴）执行布局操作。布局的结果应当置于给定数组中，该数组对子级沿辅轴的位置分配。只要布局需要沿辅轴进行更新，超类便调用此方法。

实现此方法来调用 layoutColumns 方法，然后转发给超类来实际执行表格行的布局。

覆盖：
类 BoxView 中的 layoutMinorAxis
参数：
targetSpan - 给视图的总跨距，将用于对子级的布局。
axis - 要布局的轴。
offsets - 距每个子视图的视图起始处的偏移量。这是一个返回值，由此方法的实现填写。
spans - 每个子视图的跨距。这是一个返回值，由此方法的实现填写。

calculateMinorAxisRequirements

protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                                          SizeRequirements r)
计算辅轴的所需大小。只要所需大小需要更新（即一个 preferenceChanged 传给了此视图），超类便调用此方法。

实现此方法来计算作为列的所需大小之和的所需大小。

覆盖：
类 BoxView 中的 calculateMinorAxisRequirements
参数：
axis - 所考察的轴
r - SizeRequirements 对象；如果为 null，将创建一个对象
返回：
新初始化的 SizeRequirements 对象
另请参见：
SizeRequirements

getViewAtPosition

protected View getViewAtPosition(int pos,
                                 Rectangle a)
获取表示模型中给定位置的子视图。实现此方法以通过遍历子级来查找包含给定位置的范围。在此视图中，子级与子元素无须具有一一对应的映射。

覆盖：
类 CompositeView 中的 getViewAtPosition
参数：
pos - 查找位置，该值 >= 0
a - 入口处表的分配和出口处包含该位置的视图的分配
返回：
表示给定位置的视图，如果不存在则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableView.TableCell (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 TableView.TableCell

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.TableView.TableCell
所有已实现的接口：
SwingConstants
正在封闭类：
TableView
已过时。 表单元格如今可以是任何 View 实现。

@Deprecated
public class TableView.TableCell
extends BoxView

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
TableView.TableCell(Element elem)
已过时。 构造给定元素的 TableCell。
方法摘要
int | getColumnCount() 已过时。 获取此单元格所跨的列数（即网格宽度）。
int | getGridColumn() 已过时。 获取网格位置的列
int | getGridRow() 已过时。 获取网格位置的行
int | getRowCount() 已过时。 获取此单元格所跨的行数（即网格高度）。
void | setGridLocation(int row, int col) 已过时。 设置网格的位置。
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, calculateMajorAxisRequirements, calculateMinorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paint, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets, setParent
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableView.TableCell

public TableView.TableCell(Element elem)
已过时。
构造给定元素的 TableCell。

参数：
elem - 此视图负责的元素
从以下版本开始：
1.4
方法详细信息

getColumnCount

public int getColumnCount()
已过时。
获取此单元格所跨的列数（即网格宽度）。

返回：
列数

getRowCount

public int getRowCount()
已过时。
获取此单元格所跨的行数（即网格高度）。

返回：
行数

setGridLocation

public void setGridLocation(int row,
                            int col)
已过时。
设置网格的位置。

参数：
row - 行，该值 >= 0
col - 列，该值 >= 0

getGridRow

public int getGridRow()
已过时。
获取网格位置的行

getGridColumn

public int getGridColumn()
已过时。
获取网格位置的列

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableView.TableRow (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 TableView.TableRow

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.TableView.TableRow
所有已实现的接口：
SwingConstants
正在封闭类：
TableView
public class TableView.TableRow
extends BoxView

以行为中心的表格中的行视图。

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
TableView.TableRow(Element elem)
构造给定元素的 TableView。
方法摘要
int | getResizeWeight(int axis) 确定视图沿给定轴的大小可调整性。
protected View | getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected void | layoutMajorAxis(int targetSpan, int axis, int[] offsets, int[] spans) 对框的主轴（即其表示的轴）执行布局操作。
protected void | layoutMinorAxis(int targetSpan, int axis, int[] offsets, int[] spans) 对盒子的辅轴（即垂直于其表示的轴的轴）执行布局操作。
void | replace(int offset, int length, View[] views) 更改子视图。
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, calculateMajorAxisRequirements, calculateMinorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, modelToView, paint, paintChild, preferenceChanged, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets, setParent
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableView.TableRow

public TableView.TableRow(Element elem)
构造给定元素的 TableView。

参数：
elem - 此视图负责的元素
从以下版本开始：
1.4
方法详细信息

replace

public void replace(int offset,
                    int length,
                    View[] views)
更改子视图。实现此方法来提供超类的行为并且使网格无效，以便重新计算行和列。

覆盖：
类 BoxView 中的 replace
参数：
offset - 要插入新视图的子视图的开始索引；其值 >= 0 且 <= getViewCount
length - 要移除的现有子视图数；其值 >= 0 且 <= (getViewCount() - offset)
views - 要添加的子视图；此值可以为 null，表示没有要添加的子级（对移除有用）

layoutMajorAxis

protected void layoutMajorAxis(int targetSpan,
                               int axis,
                               int[] offsets,
                               int[] spans)
对框的主轴（即其表示的轴）执行布局操作。布局的结果应当置于给定数组中，该数组表示对子级沿主轴的分配。

重新实现此方法来为每个子级分配列宽度的跨距，为跨多个列的单元格分配多列跨距。

覆盖：
类 BoxView 中的 layoutMajorAxis
参数：
targetSpan - 给视图的总体跨距，将用于对子级的布局。
axis - 要布局的轴。
offsets - 距每个子视图的视图起始处的偏移量。这是一个返回值，由此方法的实现填写。
spans - 每个孩子视图的跨距。这是一个返回值，由此方法的实现填写。

layoutMinorAxis

protected void layoutMinorAxis(int targetSpan,
                               int axis,
                               int[] offsets,
                               int[] spans)
对盒子的辅轴（即垂直于其表示的轴的轴）执行布局操作。布局的结果应当置于给定数组中，该数组表示对子级沿辅轴的分配。只要布局需要沿辅轴进行更新，超类便调用此方法。

实现此方法来委托给超类，然后调整任何跨多行的单元格的跨距。

覆盖：
类 BoxView 中的 layoutMinorAxis
参数：
targetSpan - 给视图的总体跨距，将用于对子级的布局。
axis - 要布局的轴。
offsets - 距每个子视图的视图起始处的偏移量。这是一个返回值，由此方法的实现填写。
spans - 每个子视图的跨距。这是一个返回值，由此方法的实现填写。

getResizeWeight

public int getResizeWeight(int axis)
确定视图沿给定轴的大小可调整性。0 或更小的值表示大小不可调整。

覆盖：
类 BoxView 中的 getResizeWeight
参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
返回：
大小调整权值
抛出：
IllegalArgumentException - 如果 axis 无效

getViewAtPosition

protected View getViewAtPosition(int pos,
                                 Rectangle a)
获取表示模型中给定位置的子视图。实现此方法以通过遍历子级来查找包含给定位置的范围。在此视图中，子级与子元素无须具有一一对应的映射。

覆盖：
类 CompositeView 中的 getViewAtPosition
参数：
pos - 查找位置，该值 >= 0
a - 入口处表格的分配和出口处包含该位置的视图的分配
返回：
表示给定位置的视图，如果不存在则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TabSet (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 TabSet

java.lang.Object
    继承者  javax.swing.text.TabSet
所有已实现的接口：
Serializable
public class TabSet
extends Object
implements Serializable

由许多 TabStop 组成的一个 TabSet。其提供了定位给定位置的最近 TabStop 和查找所有潜在的 TabStop 的方法。它也是不可变的。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
TabSet(TabStop[] tabs)
创建并且返回 TabSet 的一个实例。
方法摘要
boolean | equals(Object o) 指示此 TabSet 是否与另一个相等。
TabStop | getTab(int index) 返回索引 index 处的 TabStop。
TabStop | getTabAfter(float location) 返回 location 之后的 Tab 实例。
int | getTabCount() 返回接收者包含的 Tab 实例数。
int | getTabIndex(TabStop tab)
int | getTabIndexAfter(float location) 返回 location 之后使用的 Tab 的索引。
int | hashCode() 返回此 TabStop 集合的哈希代码。
String | toString() 返回此 tab 集合的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

TabSet

public TabSet(TabStop[] tabs)
创建并且返回 TabSet 的一个实例。传入的 Tab 数组必须按升序排列。

方法详细信息

getTabCount

public int getTabCount()
返回接收者包含的 Tab 实例数。

getTab

public TabStop getTab(int index)
返回索引 index 处的 TabStop。如果 index 超出了制表符的范围，则此方法将抛出 IllegalArgumentException。

getTabAfter

public TabStop getTabAfter(float location)
返回 location 之后的 Tab 实例。如果 location 之后没有任何制表符，则此方法将返回 null。

getTabIndex

public int getTabIndex(TabStop tab)
返回：
返回 TabStop tab 的索引，如果接收者中没有包含 tab，则返回 -1。

getTabIndexAfter

public int getTabIndexAfter(float location)
返回 location 之后使用的 Tab 的索引。如果 location 之后没有任何制表符，则此方法将返回 －1。

equals

public boolean equals(Object o)
指示此 TabSet 是否与另一个相等。

覆盖：
类 Object 中的 equals
参数：
o - 此实例将要与之相比的 TabSet 实例。
返回：
如果 o 是 TabSet 的实例且其具有相同数目的 TabStop，并且这些 TabStop 也全部相等，则返回 true，否则返回 false。
从以下版本开始：
1.5
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 TabStop 集合的哈希代码。

覆盖：
类 Object 中的 hashCode
返回：
返回此 TabStop 集合的哈希代码值。
从以下版本开始：
1.5
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 tab 集合的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TabStop (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 TabStop

java.lang.Object
    继承者  javax.swing.text.TabStop
所有已实现的接口：
Serializable
public class TabStop
extends Object
implements Serializable

此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。制表位位于距左页边空白的一个指定距离，以一种指定的方式来对齐文本，并且具有一个指定的前导字符。TabStop 是不可变的，并且通常包含于 TabSet 中。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
static int | ALIGN_BAR
static int | ALIGN_CENTER 制表符后的字符所放置的位置：直到下一个制表符/新行的所有字符都以制表符位置为中心放置。
static int | ALIGN_DECIMAL 制表符后的字符对齐的方式：下一个数字/制表符/新行位于制表符位置，与 RIGHT_TAB 非常类似，仅包括了数字作为要查找的附加字符。
static int | ALIGN_LEFT 制表符后的字符所放置的位置。
static int | ALIGN_RIGHT 制表符后的字符所放置的位置：直到下一个制表符/新行的所有字符都以此位置结束。
static int | LEAD_DOTS
static int | LEAD_EQUALS
static int | LEAD_HYPHENS
static int | LEAD_NONE
static int | LEAD_THICKLINE
static int | LEAD_UNDERLINE
构造方法摘要
TabStop(float pos)
在给定位置 pos 创建一个具有默认对齐方式和默认前导字符的制表符。
TabStop(float pos, int align, int leader)
创建一个具有指定位置 pos、对齐方式 align 和前导字符 leader 的制表符。
方法摘要
boolean | equals(Object other) 如果制表符相等，则返回 true。
int | getAlignment() 以 integer 的形式返回制表符的对齐方式。
int | getLeader() 返回制表符的前导字符。
float | getPosition() 以 float 的形式返回制表符的位置。
int | hashCode() 返回此对象的哈希代码。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ALIGN_LEFT

public static final int ALIGN_LEFT
制表符后的字符所放置的位置。

另请参见：
常量字段值

ALIGN_RIGHT

public static final int ALIGN_RIGHT
制表符后的字符所放置的位置：直到下一个制表符/新行的所有字符都以此位置结束。

另请参见：
常量字段值

ALIGN_CENTER

public static final int ALIGN_CENTER
制表符后的字符所放置的位置：直到下一个制表符/新行的所有字符都以制表符位置为中心放置。

另请参见：
常量字段值

ALIGN_DECIMAL

public static final int ALIGN_DECIMAL
制表符后的字符对齐的方式：下一个数字/制表符/新行位于制表符位置，与 RIGHT_TAB 非常类似，仅包括了数字作为要查找的附加字符。

另请参见：
常量字段值

ALIGN_BAR

public static final int ALIGN_BAR
另请参见：
常量字段值

LEAD_NONE

public static final int LEAD_NONE
另请参见：
常量字段值

LEAD_DOTS

public static final int LEAD_DOTS
另请参见：
常量字段值

LEAD_HYPHENS

public static final int LEAD_HYPHENS
另请参见：
常量字段值

LEAD_UNDERLINE

public static final int LEAD_UNDERLINE
另请参见：
常量字段值

LEAD_THICKLINE

public static final int LEAD_THICKLINE
另请参见：
常量字段值

LEAD_EQUALS

public static final int LEAD_EQUALS
另请参见：
常量字段值
构造方法详细信息

TabStop

public TabStop(float pos)
在给定位置 pos 创建一个具有默认对齐方式和默认前导字符的制表符。

TabStop

public TabStop(float pos,
               int align,
               int leader)
创建一个具有指定位置 pos、对齐方式 align 和前导字符 leader 的制表符。

方法详细信息

getPosition

public float getPosition()
以 float 的形式返回制表符的位置。

返回：
制表符的位置

getAlignment

public int getAlignment()
以 integer 的形式返回制表符的对齐方式。

返回：
制表符的对齐方式

getLeader

public int getLeader()
返回制表符的前导字符。

返回：
制表符的前导字符

equals

public boolean equals(Object other)
如果制表符相等，则返回 true。

覆盖：
类 Object 中的 equals
参数：
other - 要与之比较的引用对象。
返回：
如果制表符相等，则返回 true；否则，返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希代码。此方法必须在此定义以保证 100% 纯正。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希代码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 TextAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
直接已知子类：
DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction, StyledEditorKit.StyledTextAction
public abstract class TextAction
extends AbstractAction

用于跨多个不同文本组件共享的键绑定的 Action 实现。因为共享该动作，所以它一定有一个获得其动作目标的途径。此类提供试图查找要操作的文本组件的支持。获得要操作的组件的首选途径是通过接收到的 ActionEvent。如果由 getSource 返回的 Object 能收缩为一个文本组件，则使用它。如果动作事件为 null 或者不能被收缩，则试用最后一个获得焦点的文本组件。这通过配合使用一个安排与 TextAction 共享信息的 JTextController 来确定。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
TextAction(String name)
创建一个新的 JTextAction 对象。
方法摘要
static Action[] | augmentList(Action[] list1, Action[] list2) 取一个命令列表并用另一个命令列表去扩充。
protected JTextComponent | getFocusedComponent() 获取当前具有焦点的文本组件。
protected JTextComponent | getTextComponent(ActionEvent e) 确定动作所使用的组件。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.event.ActionListener 继承的方法
actionPerformed

构造方法详细信息

TextAction

public TextAction(String name)
创建一个新的 JTextAction 对象。

参数：
name - 动作的名称
方法详细信息

getTextComponent

protected final JTextComponent getTextComponent(ActionEvent e)
确定动作所使用的组件。如果 ActionEvent 不为 null 且能够被收缩，则从 ActionEvent 的源获取该组件。否则，就使用最后一个获得焦点的组件。

参数：
e - ActionEvent
返回：
组件

augmentList

public static final Action[] augmentList(Action[] list1,
                                         Action[] list2)
取一个命令列表并用另一个命令列表去扩充。第二个列表优先于第一个列表；即当两个列表包含相同名称的一个命令时，使用第二个列表中的那个命令。

参数：
list1 - 第一个列表，可能为空但不是 null
list2 - 第二个列表，可能为空但不是 null
返回：
扩充后的列表

getFocusedComponent

protected final JTextComponent getFocusedComponent()
获取当前具有焦点的文本组件。这允许动作能在文本组件之间共享，这对其中要定义大型动作集但通常在不同组件间使用同一方式的键绑定很有用。

返回：
组件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Utilities (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 Utilities

java.lang.Object
    继承者  javax.swing.text.Utilities

public class Utilities
extends Object

处理各种文本相关活动的方法集合。

构造方法摘要
Utilities()
方法摘要
static int | drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset) 使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
static int | getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定对给定文本进行拆分的位置，以符合给定的跨距。
static int | getNextWord(JTextComponent c, int offs) 确定针对给定位置的下一个单词开头。
static Element | getParagraphElement(JTextComponent c, int offs) 确定某个段落/行要使用的元素。
static int | getPositionAbove(JTextComponent c, int offs, int x) 确定模型中离行上方给定的视图位置最近的位置。
static int | getPositionBelow(JTextComponent c, int offs, int x) 确定模型中离行下方给定的视图位置最近的位置。
static int | getPreviousWord(JTextComponent c, int offs) 确定针对给定位置的上一个单词开头。
static int | getRowEnd(JTextComponent c, int offs) 确定包含指定模型位置的行的结束行模型位置。
static int | getRowStart(JTextComponent c, int offs) 确定包含指定模型位置的行的起始行模型位置。
static int | getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
static int | getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
static int | getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset) 确定给定的考虑制表符的文本段的宽度。
static int | getWordEnd(JTextComponent c, int offs) 确定针对给定位置的单词结尾。
static int | getWordStart(JTextComponent c, int offs) 确定针对给定模型位置的单词开头。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Utilities

public Utilities()
方法详细信息

drawTabbedText

public static final int drawTabbedText(Segment s,
                                       int x,
                                       int y,
                                       Graphics g,
                                       TabExpander e,
                                       int startOffset)
使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。此特别实现在一个使用 int 和假定为 72dpi 的 1.1 样式的坐标系统中进行呈现。

参数：
s - 文本源
x - X 起始处，该值 >= 0
y - Y 起始处，该值 >= 0
g - 图形上下文
e - 扩展制表符的方式如果此值为 null，则制表符将被扩展成为一个空白字符。
startOffset - 文档中文本的起始偏移量，该值 >= 0
返回：
处于呈现的文本结尾的 X 位置

getTabbedTextWidth

public static final int getTabbedTextWidth(Segment s,
                                           FontMetrics metrics,
                                           int x,
                                           TabExpander e,
                                           int startOffset)
确定给定的考虑制表符的文本段的宽度。在一个使用 int 和假定为 72dpi 的 1.1 样式的坐标系统中实现此方法。

参数：
s - 文本源
metrics - 用于计算的字体规格
x - X 起始处，该值 >= 0
e - 扩展制表符的方式。如果此值为 null，则制表符将被扩展成为一个空白字符。
startOffset - 文档中文本的起始偏移量，该值 >= 0
返回：
文本的宽度

getTabbedTextOffset

public static final int getTabbedTextOffset(Segment s,
                                            FontMetrics metrics,
                                            int x0,
                                            int x,
                                            TabExpander e,
                                            int startOffset)
确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。在一个使用 int 和假定为 72dpi 的 1.1 样式的坐标系统中实现此方法。

参数：
s - 文本源
metrics - 用于计算的字体规格
x0 - 代表给定文本开始处起始视图的位置，该值 >= 0。
x - 要转换为文本中偏移量的目标视图位置，该值 >= 0。
e - 扩展制表符的方式。如果此值为 null，则制表符将被扩展成为一个空白字符。
startOffset - 文档中文本的起始偏移量，该值 >= 0
返回：
文本中的偏移量，该值 >= 0

getTabbedTextOffset

public static final int getTabbedTextOffset(Segment s,
                                            FontMetrics metrics,
                                            int x0,
                                            int x,
                                            TabExpander e,
                                            int startOffset,
                                            boolean round)

getBreakLocation

public static final int getBreakLocation(Segment s,
                                         FontMetrics metrics,
                                         int x0,
                                         int x,
                                         TabExpander e,
                                         int startOffset)
确定对给定文本进行拆分的位置，以符合给定的跨距。此方法试图找到一个字边界。

参数：
s - 文本源
metrics - 用于计算的字体规格
x0 - 表示给定文本开始处的起始视图位置。
x - 要转换为文本中偏移量的目标视图位置。
e - 扩展制表符的方式。如果此值为 null，则制表符将被扩展成为一个空白字符。
startOffset - 文本文档中的起始偏移量
返回：
给定文本中的偏移量

getRowStart

public static final int getRowStart(JTextComponent c,
                                    int offs)
                             throws BadLocationException
确定包含指定模型位置的行的起始行模型位置。该给定组件必须具有一个用来计算结果的大小。如果组件不具有大小，则将返回值 -1。

参数：
c - 编辑器
offs - 文档中的偏移量，该值 >= 0
返回：
如果请求能被计算，则返回 >= 0 的位置；否则将返回值 -1。
抛出：
BadLocationException - 如果偏移量超出范围

getRowEnd

public static final int getRowEnd(JTextComponent c,
                                  int offs)
                           throws BadLocationException
确定包含指定模型位置的行的结束行模型位置。该给定组件必须具有一个用来计算结果的大小。如果组件不具有大小，则将返回值 -1。

参数：
c - 编辑器
offs - 文档中的偏移量，该值 >= 0
返回：
如果请求能被计算，则返回 >= 0 的位置；否则将返回值 -1。
抛出：
BadLocationException - 如果偏移量超出范围

getPositionAbove

public static final int getPositionAbove(JTextComponent c,
                                         int offs,
                                         int x)
                                  throws BadLocationException
确定模型中离行上方给定的视图位置最近的位置。该给定组件必须具有一个用来计算结果的大小。如果组件不具有大小，则将返回值 -1。

参数：
c - 编辑器
offs - 文档中的偏移量，该值 >= 0
x - X 坐标，该值 >= 0
返回：
如果请求能被计算，则返回 >= 0 的位置；否则将返回值 -1。
抛出：
BadLocationException - 如果偏移量超出范围

getPositionBelow

public static final int getPositionBelow(JTextComponent c,
                                         int offs,
                                         int x)
                                  throws BadLocationException
确定模型中离行下方给定的视图位置最近的位置。该给定组件必须具有一个用来计算结果的大小。如果组件不具有大小，则将返回值 -1。

参数：
c - 编辑器
offs - 文档中的偏移量，该值 >= 0
x - X 坐标，该值 >= 0
返回：
如果请求能被计算，则返回 >= 0 的位置；否则将返回值 -1。
抛出：
BadLocationException - 如果偏移量超出范围

getWordStart

public static final int getWordStart(JTextComponent c,
                                     int offs)
                              throws BadLocationException
确定针对给定模型位置的单词开头。使用 BreakIterator.getWordInstance() 来实际获得单词。

参数：
c - 编辑器
offs - 文档中的偏移量，该值 >= 0
返回：
单词开头的模型中的位置，该值 >= 0
抛出：
BadLocationException - 如果偏移量超出范围

getWordEnd

public static final int getWordEnd(JTextComponent c,
                                   int offs)
                            throws BadLocationException
确定针对给定位置的单词结尾。使用 BreakIterator.getWordInstance() 来实际获得单词。

参数：
c - 编辑器
offs - 文档中的偏移量，该值 >= 0
返回：
单词尾部的模型中的位置，该值 >= 0
抛出：
BadLocationException - 如果偏移量超出范围

getNextWord

public static final int getNextWord(JTextComponent c,
                                    int offs)
                             throws BadLocationException
确定针对给定位置的下一个单词开头。使用 BreakIterator.getWordInstance() 来实际获得单词。

参数：
c - 编辑器
offs - 文档中的偏移量，该值 >= 0
返回：
单词开头的模型中的位置，该值 >= 0
抛出：
BadLocationException - 如果偏移量超出范围

getPreviousWord

public static final int getPreviousWord(JTextComponent c,
                                        int offs)
                                 throws BadLocationException
确定针对给定位置的上一个单词开头。使用 BreakIterator.getWordInstance() 来实际获得单词。

参数：
c - 编辑器
offs - 文档中的偏移量，该值 >= 0
返回：
单词开头的模型中的位置，该值 >= 0
抛出：
BadLocationException - 如果偏移量超出范围

getParagraphElement

public static final Element getParagraphElement(JTextComponent c,
                                                int offs)
确定某个段落/行要使用的元素。

参数：
c - 编辑器
offs - 文档中的起始偏移量，该值 >= 0
返回：
元素
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


View (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 View

java.lang.Object
    继承者  javax.swing.text.View
所有已实现的接口：
SwingConstants
直接已知子类：
AsyncBoxView, ComponentView, CompositeView, GlyphView, IconView, ImageView, PlainView
public abstract class View
extends Object
implements SwingConstants

View 类是 text 包极为重要的一部分。顾名思义，其表示文本模型的一个视图或者文本模型的一部分。负责文本组件外观的正是此类。View 无意成为用户必须学习的全新内容，相反其更像是一个轻量级组件。

在默认情况下，视图是很轻量的。它包含一个对父视图的引用，由此能获取许多内容而无需保持状态，它还包含一个对模型 (Element) 某部分的引用。视图无需精确地表示模型中的元素，而只是使用一个典型而便利的映射。视图可以选择性地维护一对 Position 对象，从而维护其在模型中的位置（即表示一个元素段）。这通常是将视图拆分为片的格式化的结果。与元素坚固联系的便利之处在于使其更容易地构建工厂来生成视图，还能使其在模型更改时更容易地跟踪视图片，并且视图一定会更改视图来反映该模型。因此，简单的视图直接表示一个 Element，而复杂的视图并不如此。

视图具有以下责任：

参与布局。

视图有一个 setSize 方法，该方法如同 Component 中的 doLayout 和 setSize 组合而成。视图有一个 preferenceChanged 方法，该方法与 Component 中的 invalidate 类似，但该方法可以仅使一个轴无效并标识请求更改的子级。

View 根据三个值（即最小跨距、首选跨距、最大跨距）来表示其所需的大小。视图中的布局可以在独立于每一个轴来完成。对于一个运行正常的 View 实现，将满足：最小跨距 <= 首选跨距 <= 最大跨距。

布局最小值的设置方法有：

  • getMinimumSpan
  • getPreferredSpan
  • getMaximumSpan
  • getAlignment
  • preferenceChanged
  • setSize

方法 setSize 应当准备好被多次调用（即使在大小没有更改时也可能调用此方法）。通常调用 setSize 方法来确保试图在视图上执行需要更新布局的操作之前，已经完成了 View 布局。应该始终 将视图的大小设置为该视图所指定的最小跨距和最大跨距之间的某个值。此外，如果视图已经更改了其需要的布局值，并且希望其父级遵守该值，则必须一直在其父级上调用 preferenceChanged 方法。在发送了 preferenceChanged 之前，父 View 无需识别更改。如果需要的话，此类允许父 View 实现缓存子级的需求。调用序列如下所示：

父视图和子视图间的示例调用序列： setSize, getMinimum, getPreferred, getMaximum, getAlignment, setSize

确切的调用序列取决于父视图的布局功能（如果该视图具有任何子级）。在决定提供给每个子级的内容之前，视图可能收集子级的优先权，或者其可能一次一个地迭代更新子级。

呈现模型的一部分。

这在 paint 方法中完成，该方法与组件的 paint 方法非常类似。期望 View 潜在地组装一个相当大的树。对于呈现，View 具有如下语义：

  • 视图在绘制时从其父级获取分配，因此如果分配的区域与其准备处理的区域不同，其必须准备重新执行布局。
  • 坐标系统与承载 Component（即由 getContainer 方法返回的 Component）相同。这意味着子视图与父级处于同一个坐标系统中，除非父级显式地改变了坐标系统。要安排重绘本身，视图可以在承载 Component 上调用 repaint。
  • 在默认情况下不剪贴 子级。允许视图只在真正需要剪贴的时候进行剪贴才更有效率。
  • 给定的 Graphics 对象没有以任何方式初始化。视图应该设置任何所需的设置。
  • View 本身是透明的。虽然视图可以呈现在其整个分配中，但通常视图不这么做。通过向下遍历 View 实现树来执行呈现。每个 View 负责呈现其子级。线程安全取决于此行为。虽然视图实现不必要在实现时考虑线程安全，但是其他确实利用了并发的视图实现可以依赖树遍历来保证线程安全。
  • 相对于模型的视图顺序由实现来决定。尽管子视图通常将按其在模型中出现的相同顺序被排列，但它们也可能以完全不同的顺序来可视地排列。如果子级是重叠的，View 实现可能具有一个与其相关联的 Z-顺序。

用于呈现的方法有：

  • paint

在模型和视图坐标系统间转换。

因为视图对象产生自一个工厂，因而不能指望其必然处于某个特定模型，所以用户必须要能够执行转换以恰当地定位模型的空间表示形式。执行此操作的方法有：

  • modelToView
  • viewToModel
  • getDocument
  • getElement
  • getStartOffset
  • getEndOffset

在尝试进行转换之前布局必须有效。当通过 DocumentEvent 从模型广播更改时，转换无效并且禁止尝试。

响应模型的更改。

如果总体视图由多片（如果希望更改视图并写入最小数量的新代码，这是最佳的情形）表示，而具有大量的 DocumentListener 是不现实的。如果每个视图都侦听模型，在任意给定的时间上，仅有少数视图可能对所广播的更改实际感兴趣。因为模型不了解视图，所以没有方法来过滤更改信息的广播。视图层次结构本身就代为负责传播更改信息。在视图层次结构的任何一层上，视图都足够了解其子级，从而能最佳地进一步分发更改信息。因此，更改从视图层次结构的根开始广播。执行此操作的方法有：

  • insertUpdate
  • removeUpdate
  • changedUpdate

字段摘要
static int | BadBreakWeight 该权重指示对于格式化来说视图未处于拆分的好时机。
static int | ExcellentBreakWeight 该权重指示视图支持拆分，并且表示拆分的极好时机。
static int | ForcedBreakWeight 该权重指示视图支持拆分，并且在被置入一个通过拆分其子级来格式化子级的视图时，必须拆分该视图以恰当的表示它。
static int | GoodBreakWeight 该权重指示视图支持拆分，但是可能存在更好时机。
static int | X_AXIS 用于格式化/拆分操作的轴。
static int | Y_AXIS 用于格式化/拆分操作的轴。
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
View(Element elem)
创建一个新的 View 对象。
方法摘要
void | append(View v) 追加单个子视图。
View | breakView(int axis, int offset, float pos, float len) 试图在给定的轴上拆分视图。
void | changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
View | createFragment(int p0, int p1) 创建一个表示元素某部分的视图。
protected void | forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected void | forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
float | getAlignment(int axis) 确定此视图沿某个轴所需的对齐方式。
AttributeSet | getAttributes() 获取呈现时要使用的属性。
int | getBreakWeight(int axis, float pos, float len) 确定此视图中拆分时机的权重大小。
Shape | getChildAllocation(int index, Shape a) 获取给定子视图的分配。
Container | getContainer() 获取承载视图的容器。
Document | getDocument() 获取与视图关联的模型。
Element | getElement() 获取此视图所映射的主题的结构化部分。
int | getEndOffset() 获取此视图负责的模型的一部分。
Graphics | getGraphics() 获取用于呈现的 Graphics。
float | getMaximumSpan(int axis) 确定此视图沿某个轴的最大跨距。
float | getMinimumSpan(int axis) 确定此视图沿某个轴的最小跨距。
int | getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
View | getParent() 返回视图的父级。
abstract float | getPreferredSpan(int axis) 确定此视图沿某个轴的首选跨距。
int | getResizeWeight(int axis) 确定视图沿给定轴的大小可调整性。
int | getStartOffset() 获取此视图负责的模型的一部分。
String | getToolTipText(float x, float y, Shape allocation) 返回提定位置的工具提示文本。
View | getView(int n) 获取第 n 个子视图。
int | getViewCount() 返回此视图中的视图数。
ViewFactory | getViewFactory() 获取将提供给视图层次结构的 ViewFactory 实现。
int | getViewIndex(float x, float y, Shape allocation) 返回表示视图中给定位置的子视图索引。
int | getViewIndex(int pos, Position.Bias b) 返回表示模型中给定位置的子视图索引。
void | insert(int offs, View v) 插入单个子视图。
void | insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
boolean | isVisible() 返回一个指示视图是否可视的 boolean 值。
Shape | modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
Shape | modelToView(int pos, Shape a) 已过时。
abstract Shape | modelToView(int pos, Shape a, Position.Bias b) 为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
abstract void | paint(Graphics g, Shape allocation) 使用给定的呈现表面和该表面上的区域来呈现。
void | preferenceChanged(View child, boolean width, boolean height) 子视图能在父级上调用此方法来指示首选项已经更改，并且应该重新考虑布局。
void | remove(int i) 移除给定位置处的一个子级。
void | removeAll() 移除所有子级。
void | removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | replace(int offset, int length, View[] views) 替代子视图。
void | setParent(View parent) 为此视图建立父视图。
void | setSize(float width, float height) 设置视图的大小。
protected boolean | updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
protected void | updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接受的更改通知。
int | viewToModel(float x, float y, Shape a) 已过时。
abstract int | viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

BadBreakWeight

public static final int BadBreakWeight
该权重指示对于格式化来说视图未处于拆分的好时机。此值指示不应该尝试将视图拆分成段，因为该视图没有写入支持分段操作。

另请参见：
getBreakWeight(int, float, float), GoodBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, 常量字段值

GoodBreakWeight

public static final int GoodBreakWeight
该权重指示视图支持拆分，但是可能存在更好时机。

另请参见：
getBreakWeight(int, float, float), BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, 常量字段值

ExcellentBreakWeight

public static final int ExcellentBreakWeight
该权重指示视图支持拆分，并且表示拆分的极好时机。

另请参见：
getBreakWeight(int, float, float), BadBreakWeight, GoodBreakWeight, ForcedBreakWeight, 常量字段值

ForcedBreakWeight

public static final int ForcedBreakWeight
该权重指示视图支持拆分，并且在被置入一个通过拆分其子级来格式化子级的视图时，必须拆分该视图以恰当的表示它。

另请参见：
getBreakWeight(int, float, float), BadBreakWeight, GoodBreakWeight, ExcellentBreakWeight, 常量字段值

X_AXIS

public static final int X_AXIS
用于格式化/拆分操作的轴。

另请参见：
常量字段值

Y_AXIS

public static final int Y_AXIS
用于格式化/拆分操作的轴。

另请参见：
常量字段值
构造方法详细信息

View

public View(Element elem)
创建一个新的 View 对象。

参数：
elem - 要表示的 Element
方法详细信息

getParent

public View getParent()
返回视图的父级。

返回：
父级，如果不存在则返回 null

isVisible

public boolean isVisible()
返回一个指示视图是否可视的 boolean 值。在默认情况下所有视图都是可视的。

返回：
始终返回 true

getPreferredSpan

public abstract float getPreferredSpan(int axis)
确定此视图沿某个轴的首选跨距。

参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
返回：
视图想要在其中呈现的跨距。通常告知视图呈现在返回的跨距中，但并不保证如此。父级可能选择调整视图大小或者拆分视图。
另请参见：
getPreferredSpan(int)

getMinimumSpan

public float getMinimumSpan(int axis)
确定此视图沿某个轴的最小跨距。

参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
返回：
视图能在其中呈现的最小跨距。
另请参见：
getPreferredSpan(int)

getMaximumSpan

public float getMaximumSpan(int axis)
确定此视图沿某个轴的最大跨距。

参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
返回：
视图能在其中呈现的最大跨距。
另请参见：
getPreferredSpan(int)

preferenceChanged

public void preferenceChanged(View child,
                              boolean width,
                              boolean height)
子视图能在父级上调用此方法来指示首选项已经更改，并且应该重新考虑布局。在默认情况下，此方法仅仅上传播到下一个父级。根视图将在相关联的文本组件上调用 revalidate。

参数：
child - 子视图
width - 如果宽度首选项更改，则该参数为 true
height - 如果高度首选项更改，则该参数为 true
另请参见：
JComponent.revalidate()

getAlignment

public float getAlignment(int axis)
确定此视图沿某个轴所需的对齐方式。返回所需的对齐方式。这应该是一个 >= 0.0 并且 <= 1.0 的值，其中 0 指示在起始处对齐，1.0 指示在离起始处的整个跨距的地方对齐。0.5 则指示在视图中央对齐。

参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
返回：
值 0.5

paint

public abstract void paint(Graphics g,
                           Shape allocation)
使用给定的呈现表面和该表面上的区域来呈现。该视图可能需要进行布置和创建子视图，以使它本身能够在给定的分配区域呈现。

参数：
g - 要使用的呈现表面
allocation - 分配的要在其中呈现的区域

setParent

public void setParent(View parent)
为此视图建立父视图。如果父视图运行正常，则会保证在其他任何方法之前调用此方法。这也是最后调用的一个方法，因为也调用其来指示已从层次结构中移除视图。当调用此方法来将父级设置为 null 时，此方法对每一个子级执行同样操作，传播它们已经从视图树中断开连接的通知。如果重新实现此方法，应该调用 super.setParent()。

参数：
parent - 新的父级，如果要从父级中移除视图，则为 null

getViewCount

public int getViewCount()
返回此视图中的视图数。因为默认情况下不是一个复合视图，所以此方法返回 0。

返回：
视图数，该值 >= 0
另请参见：
getViewCount()

getView

public View getView(int n)
获取第 n 个子视图。因为在默认情况下没有任何子级，所以此方法返回 null。

参数：
n - 要获取的视图的编号，该值 >= 0 && < getViewCount()
返回：
视图

removeAll

public void removeAll()
移除所有子级。此方法是 replace 的便捷调用。

从以下版本开始：
1.3

remove

public void remove(int i)
移除给定位置处的一个子级。此方法是 replace 的便捷调用。

从以下版本开始：
1.3

insert

public void insert(int offs,
                   View v)
插入单个子视图。此方法是 replace 的便捷调用。

参数：
offs - 要其前插入视图的偏移量，该值 >= 0
v - 视图
从以下版本开始：
1.3
另请参见：
replace(int, int, javax.swing.text.View[])

append

public void append(View v)
追加单个子视图。此方法是 replace 的便捷调用。

参数：
v - 视图
从以下版本开始：
1.3
另请参见：
replace(int, int, javax.swing.text.View[])

replace

public void replace(int offset,
                    int length,
                    View[] views)
替代子视图。如果没有任何视图要移除，则此方法充当一个插入操作。如果没有任何视图要添加，则此方法充当一个移除操作。将要被移除的视图会将其父级设置为 null，并且移除对它们的内部引用以便能被垃圾回收。实现此方法以不执行任何操作，因为默认情况下视图没有任何子级。

参数：
offset - 子视图中插入新 views 的起始索引。这应当是一个 >= 0 并且 <= getViewCount 的值
length - 要移除的已存在的子视图数 这应当是一个 >= 0 并且 <= (getViewCount() - offset) 的值。
views - 要添加的子视图。此值可以为 null，指示当前不添加任何子级（移除时很有用）
从以下版本开始：
1.3

getViewIndex

public int getViewIndex(int pos,
                        Position.Bias b)
返回表示模型中给定位置的子视图索引。默认情况下，视图没有任何子级，因此实现此方法以返回 -1，指示在任何位置都没有有效的子级索引。

参数：
pos - 位置，该值 >= 0
返回：
表示给定位置的视图索引，如果没有任何视图表示该位置，则返回 -1

getChildAllocation

public Shape getChildAllocation(int index,
                                Shape a)
获取给定子视图的分配。这使得在没有假定视图如何存储其位置的情况下，能找出各种视图的定位。因为默认情况下没有任何子视图，所以此方法返回 null。

参数：
index - 子级的索引，该值 >= 0 && < getViewCount()
a - 此视图的分配
返回：
子级的分配

getNextVisualPositionFrom

public int getNextVisualPositionFrom(int pos,
                                     Position.Bias b,
                                     Shape a,
                                     int direction,
                                     Position.Bias[] biasRet)
                              throws BadLocationException
提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。一些视图可能是不可视的，它们的顺序可能与模型中的顺序不同，或者它们可能不允许访问模型中的某些位置。

参数：
pos - 要转换的位置，该值 >= 0
a - 为呈现分配的区域
direction - 以当前位置开始的方向，可以将它们设想为通常出现在键盘上的箭头键。它将是以下值之一：
  • SwingConstants.WEST
  • SwingConstants.EAST
  • SwingConstants.NORTH
  • SwingConstants.SOUTH
返回：
模型中的位置，它最能表示下一个可视位置的位置
抛出：
BadLocationException
IllegalArgumentException - 如果 direction 不具有上述合法值之一

modelToView

public abstract Shape modelToView(int pos,
                                  Shape a,
                                  Position.Bias b)
                           throws BadLocationException
为给定字符提供从文档模型坐标空间到视图坐标空间的映射。

参数：
pos - 所需字符的位置 (>=0)
a - 包围了请求字符的视图区域
b - 当位置是两个视图的边界时，该参数是离由偏移量表示的前一个字符或者下一个字符的偏差；b 将是这些值之一：
  • Position.Bias.Forward
  • Position.Bias.Backward
返回：
在视图坐标空间中，给定位置处的字符的边界框
抛出：
BadLocationException - 如果给定的位置不表示关联文档中的一个有效位置
IllegalArgumentException - 如果 b 上文列出的 Position.Bias 的合法值之一
另请参见：
viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

modelToView

public Shape modelToView(int p0,
                         Position.Bias b0,
                         int p1,
                         Position.Bias b1,
                         Shape a)
                  throws BadLocationException
为给定区域提供从文档模型坐标空间到视图坐标空间的映射。给定区域被创建为第一个和最后一个字符位置的并集。

参数：
p0 - 第一个字符的位置 (>=0)
b0 - 当位置是两个视图的一个边界时，第一个字符位置离由偏移量表示的前一个字符或下一个字符的偏差；b0 将是这些值之一：
  • Position.Bias.Forward
  • Position.Bias.Backward
p1 - 最后一个字符的位置 (>=0)
b1 - 第二个字符位置的偏差，由上文所示的合法值之一来定义
a - 包围了请求区域的视图区域
返回：
边界框，它是由第一个和最后一个字符位置指定的区域的并集
抛出：
BadLocationException - 如果给定的位置不表示关联文档中的一个有效位置
IllegalArgumentException - 如果 b0 或者 b1 不是上文列出的 Position.Bias 的合法值之一
另请参见：
viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

viewToModel

public abstract int viewToModel(float x,
                                float y,
                                Shape a,
                                Position.Bias[] biasReturn)
提供从视图坐标空间到模型的逻辑坐标空间的映射。将填写 biasReturn 参数来指示给定的点更接近于模型中的下一个字符还是前一个字符。

参数：
x - X 坐标，该值 >= 0
y - Y 坐标，该值 >= 0
a - 要在其中呈现的分配区域
返回：
模型中最能表示视图中给定点的位置，该值 >= 0。将填写 biasReturn 参数来指示给定的点更接近于模型中的下一个字符还是前一个字符。

insertUpdate

public void insertUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
发出通知，通知在文档中此视图负责的某个位置已插入内容。为了减少子类的负担，此功能已分散到以下子类能重新实现的调用中：
  1. 如果此视图负责的元素发生任何更改，调用 updateChildren。如果此视图有表示子元素的子视图，则此方法应当做任何必须的操作来保证子视图正确表示模型。
  2. 要转发 DocumentEvent 到合适的子视图，调用 forwardUpdate。
  3. 要给视图一个机会来修复其布局、重新计划布局或者不做任何操作，调用 updateLayout。

参数：
e - 来自关联文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
给出从文档中此视图负责的位置移除了某些内容的通知。为了减少子类的负担，此功能已分散到以下子类能重新实现的调用中：
  1. 如果此视图负责的元素发生任何更改，则调用 updateChildren。如果此视图有表示子元素的子视图，则此方法应当做任何必须的操作来保证子视图正确表示模型。
  2. 要转发 DocumentEvent 到合适的子视图，调用 forwardUpdate。
  3. 要给视图一个机会来修复其布局、重新计划布局或者不做任何操作，调用 updateLayout。

参数：
e - 来自关联文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

changedUpdate

public void changedUpdate(DocumentEvent e,
                          Shape a,
                          ViewFactory f)
发出通知，通知文档此视图负责的位置处的属性已更改。为了减少子类的负担，此功能已分散到以下子类能重新实现的调用中：
  1. 如果此视图负责的元素发生任何更改，则调用 updateChildren。如果此视图有表示子元素的子视图，则此方法应当做任何必须的操作来保证子视图正确表示模型。
  2. 要转发 DocumentEvent 到合适的子视图，调用 forwardUpdate。
  3. 要给视图一个机会来修复其布局、重新计划布局或者不做任何操作，调用 updateLayout。

参数：
e - 发自关联文档的更改信息
a - 视图的当前分配
f - 视图有子级时用于重建的工厂 View#changedUpdate

getDocument

public Document getDocument()
获取与视图关联的模型。

返回：
视图模型，如果没有则返回 null
另请参见：
getDocument()

getStartOffset

public int getStartOffset()
获取此视图负责的模型的一部分。

返回：
模型中的起始偏移量，该值 >= 0
另请参见：
getStartOffset()

getEndOffset

public int getEndOffset()
获取此视图负责的模型的一部分。

返回：
模型中的结尾偏移量，该值 >= 0
另请参见：
getEndOffset()

getElement

public Element getElement()
获取此视图所映射的主题的结构化部分。该视图可能没有负责元素的整个部分。

返回：
主题
另请参见：
getElement()

getGraphics

public Graphics getGraphics()
获取用于呈现的 Graphics。此方法可以用来确定字符特征，并且它对于打印视图和组件视图是不同的。

返回：
用于呈现的 Graphics 对象
从以下版本开始：
1.3

getAttributes

public AttributeSet getAttributes()
获取呈现时要使用的属性。默认情况下此方法只是返回关联元素的属性。应该使用此方法而不是直接使用元素来获得对属性的访问，从而允许特定于视图的属性被混合进来，或者允许视图具有通过子类的特定于视图的属性变换。每个视图应当记录为了呈现或布局的其能够识别的属性，并且应该总是通过此方法所返回的 AttributeSet 来访问它们。

breakView

public View breakView(int axis,
                      int offset,
                      float pos,
                      float len)
试图在给定的轴上拆分视图。此方法由试图对其子级进行格式化的视图调用。例如，一个段落的视图通常尝试将其子级置于行中，表示文本块的视图有时能被拆分成为更小的片。

实现此方法以返回视图本身，这表示在不可拆分时的默认行为。如果视图确实支持拆分，返回的视图的起始偏移量应当是给定的偏移量，并且结尾偏移量应当小于或者等于要被拆分的视图的结尾偏移量。

参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
offset - 文档模型中拆分段将占用的位置，该值 >= 0。这可能是该段返回的起始偏移量
pos - 拆分视图将沿轴占用的位置，该值 >= 0。这对制表符计算之类的操作很有用。
len - 指定所需的可能的拆分沿轴的距离，该值 >= 0
返回：
如果视图能被拆分，则返回表示给定跨距的视图段。如果视图不支持拆分行为，返回视图本身。
另请参见：
ParagraphView

createFragment

public View createFragment(int p0,
                           int p1)
创建一个表示元素某部分的视图。此方法在对视图段进行测量的格式化操作中可能很有用。如果视图不支持分段（默认），其应该返回视图本身。

参数：
p0 - 起始偏移量，该值 >= 0。此值应当是一个大于等于元素起始偏移量且小于元素结尾偏移量的值。
p1 - 结尾偏移量，该值 > p0。此值应当是一个小于等于元素结尾偏移量且大于元素起始偏移量的值。
返回：
视图段，如果视图不支持拆分成段，则返回视图本身
另请参见：
LabelView

getBreakWeight

public int getBreakWeight(int axis,
                          float pos,
                          float len)
确定此视图中拆分时机的权重大小。此方法能用于确定在格式化过程中最倾向调用 breakView 的视图。例如，表示其中具有空格的文本的视图可能比没有空格的视图更倾向拆分。权值越高，拆分的倾向性更大。等于或者小于 BadBreakWeight 的值不应被考虑进行拆分。大于或者等于 ForcedBreakWeight 值应该被拆分。

实现此方法以提供返回 BadBreakWeight 的默认行为，除非长度大于视图长度，在这种情况下整个视图表示一个段。除非一个视图被写入支持拆分行为，否则不倾向于试图并拆分视图。一定支持拆分的视图例子是 LabelView。使用拆分权值的视图示例是 ParagraphView。

参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
pos - 拆分视图开始的可能的位置，该值 >= 0。这可能对于计算制表符位置很有用。
len - 指定自 pos（可能需要拆分的位置）的相对长度，该值 >= 0
返回：
权值，其应当是 ForcedBreakWeight 和 BadBreakWeight 之间的某个值
另请参见：
LabelView, ParagraphView, BadBreakWeight, GoodBreakWeight, ExcellentBreakWeight, ForcedBreakWeight

getResizeWeight

public int getResizeWeight(int axis)
确定视图沿给定轴的大小可调整性。对于小于或等于 0 的值，无法调整大小。

参数：
axis - 可能是 View.X_AXIS 或 View.Y_AXIS
返回：
权重

setSize

public void setSize(float width,
                    float height)
设置视图的大小。如果此方法有任何布局的职责，则它将促使视图沿给定轴进行布局。

参数：
width - 宽度，该值 >= 0
height - 高度，该值 >= 0

getContainer

public Container getContainer()
获取承载视图的容器。此方法对计划一次重绘、找出承载组件字体等操作很有用。此方法的默认实现是将查询转发给父视图。

返回：
容器，如果没有，则返回 null

getViewFactory

public ViewFactory getViewFactory()
获取将提供给视图层次结构的 ViewFactory 实现。通常将视图提供给此方法作为参数，以便在它们最可能需要该工厂的时候根据模型更新，但是在其他时候，此方法便以足够。

返回：
工厂，如果没有，则返回 null

getToolTipText

public String getToolTipText(float x,
                             float y,
                             Shape allocation)
返回提定位置的工具提示文本。默认实现返回传入位置标识的子 View 的值。

从以下版本开始：
1.4
另请参见：
JTextComponent.getToolTipText(java.awt.event.MouseEvent)

getViewIndex

public int getViewIndex(float x,
                        float y,
                        Shape allocation)
返回表示视图中给定位置的子视图索引。此方法迭代所有子级，返回第一个具有包含 x、y 的边界的子级。

参数：
x - x 坐标
y - y 坐标
allocation - View 中的当前分配。
返回：
表示给定位置的视图索引，如果没有任何视图表示该位置，则返回 -1
从以下版本开始：
1.4

updateChildren

protected boolean updateChildren(DocumentEvent.ElementChange ec,
                                 DocumentEvent e,
                                 ViewFactory f)
更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。实现此方法以假定子视图直接负责此视图所表示的元素的子元素。ViewFactory 用来为每个元素创建子视图，这些子视图将从给定的 ElementChange 中指定的索引开始被添加到 ElementChange 中。移除表示已移除指定元素的子视图数目。

参数：
ec - 此视图所负责的元素的更改信息。如果调用此方法，该参赛不应当为 null
e - 来自关联文档的变化信息
f - 用于构建子视图的工厂
返回：
子视图是否表示此视图所负责的元素的子元素。某些视图创建表示其所负责的一部分元素的子级，其应当返回 false。此信息用于确定是否应该转发添加的元素范围中的视图
从以下版本开始：
1.3
另请参见：
insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

forwardUpdate

protected void forwardUpdate(DocumentEvent.ElementChange ec,
                             DocumentEvent e,
                             Shape a,
                             ViewFactory f)
将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。如果此视图负责的元素发生了更改，则在转发时应当考虑该更改（即新子视图不应该获得通知）。

参数：
ec - 此视图所负责的元素的更改（如果没有任何更改，则为 null）。
e - 来自关联文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
从以下版本开始：
1.3
另请参见：
insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

forwardUpdateToView

protected void forwardUpdateToView(View v,
                                   DocumentEvent e,
                                   Shape a,
                                   ViewFactory f)
将 DocumentEvent 转发到给定的子视图。此方法只是根据实际类型，通过对 insertUpdate、removeUpdate 或者 changedUpdate 的调用来将消息传递给视图。此方法由 forwardUpdate 调用来将事件转发给需要它的子级。

参数：
v - 作为事件转发目标的子视图
e - 来自关联文档的更改信息
a - 视图的当前分配
f - 用于重建的工厂（如果视图有子级）
从以下版本开始：
1.3
另请参见：
forwardUpdate(javax.swing.event.DocumentEvent.ElementChange, javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

updateLayout

protected void updateLayout(DocumentEvent.ElementChange ec,
                            DocumentEvent e,
                            Shape a)
更新布局，以响应从模型接受的更改通知。如果 ElementChange 记录不为 null，则实现此方法来调用 preferenceChanged 以重新计划一个新的布局。

参数：
ec - 此视图所负责的元素的更改（如果没有任何更改则为 null）
e - 来自关联文档的更改信息
a - 视图的当前分配
从以下版本开始：
1.3
另请参见：
insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

modelToView

@Deprecated
public Shape modelToView(int pos,
                                    Shape a)
                  throws BadLocationException
已过时。

提供从文档模型坐标空间到所映射的视图坐标空间的映射。实现此方法以将偏差默认为前文提到的 Position.Bias.Forward。

参数：
pos - 要转换的位置，该值 >= 0
a - 分配的要在其中呈现的区域
返回：
返回给定位置的边界框
抛出：
BadLocationException - 如果给定位置在所关联的文档中不是一个有效位置
另请参见：
modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

@Deprecated
public int viewToModel(float x,
                                  float y,
                                  Shape a)
已过时。

提供从视图坐标空间到该模型的逻辑坐标空间的映射。

参数：
x - X 坐标，该值 >= 0
y - Y 坐标，该值 >= 0
a - 分配的要在其中呈现的区域
返回：
模型中最能代表视图中给定点的位置，该值 >= 0
另请参见：
viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
接口 ViewFactory

所有已知实现类：
BasicEditorPaneUI, BasicFormattedTextFieldUI, BasicPasswordFieldUI, BasicTextAreaUI, BasicTextFieldUI, BasicTextPaneUI, BasicTextUI, DefaultTextUI, HTMLEditorKit.HTMLFactory, MetalTextFieldUI
public interface ViewFactory

创建文档专题某些部分的视图的工厂。此类用于启用自定义视图在文档模型上映射的方式。

方法摘要
 View create(Element elem)
根据给定的文档的结构化元素创建一个视图。

方法详细信息

create

View create(Element elem)
根据给定的文档的结构化元素创建一个视图。

参数：
elem - 用于创建视图的文档片
返回：
视图
另请参见：
View
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WrappedPlainView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 WrappedPlainView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.WrappedPlainView
所有已实现的接口：
SwingConstants, TabExpander
public class WrappedPlainView
extends BoxView
implements TabExpander

进行换行的纯文本（仅有一种字体和颜色的文本）视图。此视图期望其关联元素具有表示其应该换行的子元素。它实现为一个包含逻辑行视图的垂直框。逻辑行视图是嵌套类，如果逻辑行太宽以至于分配无法容纳时，这些类把逻辑行呈现为多个物理行。行视图针对其状态利用外部类来减少其内存需求。

行视图通过 drawLine 方法来执行其所有的呈现操作，此方法通过 drawSelectedText 和 drawUnselectedText 方法来依次执行其所有呈现操作。这使得子类能容易地专用于呈现而不考虑布局问题。

另请参见：
View

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
WrappedPlainView(Element elem)
创建一个新的 WrappedPlainView。
WrappedPlainView(Element elem, boolean wordWrap)
创建一个新的 WrappedPlainView。
方法摘要
protected int | calculateBreakPosition(int p0, int p1) 此方法由嵌套换行视图调用，以确定拆分位置。
void | changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出文档中此视图负责的位置上的属性已发生更改的通知。
protected void | drawLine(int p0, int p1, Graphics g, int x, int y) 取消结尾空格并扩展所有制表符，从而呈现一行文本。
protected int | drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为所选文本。
protected int | drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中的给定范围呈现为普通未选择的文本。
protected Segment | getLineBuffer() 提供对能用于从关联文档获取文本的缓冲区的访问。
float | getMaximumSpan(int axis) 确定此视图沿某个轴的最大跨距。
float | getMinimumSpan(int axis) 确定此视图沿某个轴的最小跨距。
float | getPreferredSpan(int axis) 确定此视图沿某个轴的首选跨距。
protected int | getTabSize() 返回文档的制表符大小设置，默认为 8。
void | insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出在文档中此视图负责的位置插入了某些内容的通知。
protected void | loadChildren(ViewFactory f) 加载所有子级来初始化视图。
float | nextTabStop(float x, int tabOffset) 返回给定引用位置之后的下一个制表位位置。
void | paint(Graphics g, Shape a) 使用给定的呈现表面和表现上的区域来呈现。
void | removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出从文档中此视图负责的位置移除了某些内容的通知。
void | setSize(float width, float height) 设置视图的大小。
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, calculateMajorAxisRequirements, calculateMinorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getOffset, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, modelToView, setInsets, setParagraphInsets, setParent
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, isVisible, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WrappedPlainView

public WrappedPlainView(Element elem)
创建一个新的 WrappedPlainView。将在字符边界换行。

参数：
elem - 作为视图基础的元素

WrappedPlainView

public WrappedPlainView(Element elem,
                        boolean wordWrap)
创建一个新的 WrappedPlainView。可以在字符或者单词边界换行，具体取决于 wordWrap 参数的设置。

参数：
elem - 作为视图基础的元素
wordWrap - 应该在单词边界换行吗？
方法详细信息

getTabSize

protected int getTabSize()
返回文档的制表符大小设置，默认为 8。

返回：
制表符大小

drawLine

protected void drawLine(int p0,
                        int p1,
                        Graphics g,
                        int x,
                        int y)
取消结尾空格并扩展所有制表符，从而呈现一行文本。实现此方法来调用方法 drawUnselectedText 和 drawSelectedText，以便自定义呈现选择和未选择文本的方式。

参数：
p0 - 要使用的文档起始位置，该值 >= 0
p1 - 要使用的文档结尾位置，该值 >= p0
g - 图形上下文
x - 起始 X 位置，该值 >= 0
y - 起始 Y 位置，该值 >= 0
另请参见：
drawUnselectedText(java.awt.Graphics, int, int, int, int), drawSelectedText(java.awt.Graphics, int, int, int, int)

drawUnselectedText

protected int drawUnselectedText(Graphics g,
                                 int x,
                                 int y,
                                 int p0,
                                 int p1)
                          throws BadLocationException
将模型中的给定范围呈现为普通未选择的文本。

参数：
g - 图形上下文
x - 起始 X 坐标，该值 >= 0
y - 起始 Y 坐标，该值 >= 0
p0 - 模型中的开始位置，该值 >= 0
p1 - 模型中的结束位置，该值 >= p0
返回：
结尾范围的 X 位置，该值 >= 0
抛出：
BadLocationException - 如果范围无效

drawSelectedText

protected int drawSelectedText(Graphics g,
                               int x,
                               int y,
                               int p0,
                               int p1)
                        throws BadLocationException
将模型中给定的范围呈现为所选文本。实现此方法以使用承载组件中指定的颜色来呈现文本。假定 highlighter 将呈现所选背景。

参数：
g - 图形上下文
x - 起始 X 坐标，该值 >= 0
y - 起始 Y 坐标，该值 >= 0
p0 - 模型中的开始位置，该值 >= 0
p1 - 模型中的结束位置，该值 >= p0
返回：
范围结尾处的位置
抛出：
BadLocationException - 如果范围无效

getLineBuffer

protected final Segment getLineBuffer()
提供对能用于从关联文档获取文本的缓冲区的访问。

返回：
缓冲区

calculateBreakPosition

protected int calculateBreakPosition(int p0,
                                     int p1)
此方法由嵌套换行视图调用，以确定拆分位置。可以重新实现此方法来改变拆分行为。它将在单词还是字符边界分解，取决于在构造方法中给定的拆分参数。

loadChildren

protected void loadChildren(ViewFactory f)
加载所有子级来初始化视图。此方法由 setParent 方法调用。子类可以重新实现此方法以使用一种不同的方式初始化其子视图。默认的实现为每个子元素创建一个子视图。

覆盖：
类 CompositeView 中的 loadChildren
参数：
f - 视图工厂
另请参见：
CompositeView.setParent(javax.swing.text.View)

nextTabStop

public float nextTabStop(float x,
                         int tabOffset)
返回给定引用位置之后的下一个制表位位置。此实现不支持诸如居中之类的操作，所以它会忽略 tabOffset 参数。

指定者：
接口 TabExpander 中的 nextTabStop
参数：
x - 当前位置，该值 >= 0
tabOffset - 文本流中制表符出现的位置，该值 >= 0。
返回：
以点为单位的制表位，该值 >= 0

paint

public void paint(Graphics g,
                  Shape a)
使用给定的呈现表面和表现上的区域来呈现。实现此方法来隐藏供嵌套行使用的选择位置、选择颜色和字体规格。

覆盖：
类 BoxView 中的 paint
参数：
g - 要使用的呈现表面
a - 要在其中呈现的分配区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

setSize

public void setSize(float width,
                    float height)
设置视图的大小。如果此方法有任何布局的职责，则它将促使视图沿给定轴进行布局。

覆盖：
类 BoxView 中的 setSize
参数：
width - 宽度，该值 >= 0
height - 高度，该值 >= 0

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某个轴的首选跨距。实现此方法以在第一次确保当前字体规格已被缓存（对于使用该规格来确定可能的换行高度的嵌套行而言）后提供超类的行为。

覆盖：
类 BoxView 中的 getPreferredSpan
参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
返回：
将要在其中呈现视图的跨距。通常告知视图呈现在返回的跨距中，但并不保证如此。父级可能选择调整视图大小或者拆分视图。
另请参见：
View.getPreferredSpan(int)

getMinimumSpan

public float getMinimumSpan(int axis)
确定此视图沿某个轴的最小跨距。实现此方法以在第一次确保当前字体规格已被缓存（对于使用该规格来确定可能的换行高度的嵌套行而言）后提供超类的行为。

覆盖：
类 BoxView 中的 getMinimumSpan
参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
返回：
视图可能想要在其中呈现的跨距。通常告知视图呈现在返回的跨距中，但并不保证如此。父级可能选择调整视图大小或者拆分视图。
另请参见：
View.getMinimumSpan(int)

getMaximumSpan

public float getMaximumSpan(int axis)
确定此视图沿某个轴的最大跨距。实现此方法以在第一次确保当前字体规格已被缓存（对于使用该规格来确定可能的换行高度的嵌套行而言）后提供超类的行为。

覆盖：
类 BoxView 中的 getMaximumSpan
参数：
axis - 可能是 View.X_AXIS 或者 View.Y_AXIS
返回：
视图可能想要在其中呈现的跨距。通常告知视图呈现在返回的跨距中，但并不保证如此。父级可能选择调整视图大小或者拆分视图。
另请参见：
View.getMaximumSpan(int)

insertUpdate

public void insertUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
发出在文档中此视图负责的位置插入了某些内容的通知。实现此方法以便只更新子级。

覆盖：
类 View 中的 insertUpdate
参数：
e - 发自关联文档的更改信息
a - 视图的当前分配
f - 视图有子级时用于重建的工厂
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
发出从文档中此视图负责的位置移除了某些内容的通知。实现此方法以便只更新子级。

覆盖：
类 View 中的 removeUpdate
参数：
e - 发自关联文档的更改信息
a - 视图的当前分配
f - 视图有子级时用于重建的工厂
另请参见：
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

changedUpdate

public void changedUpdate(DocumentEvent e,
                          Shape a,
                          ViewFactory f)
发出文档中此视图负责的位置上的属性已发生更改的通知。

覆盖：
类 View 中的 changedUpdate
参数：
e - 发自关联文档的更改信息
a - 视图的当前分配
f - 视图有子级时用于重建的工厂 View#changedUpdate
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZoneView (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.text
类 ZoneView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.ZoneView
所有已实现的接口：
SwingConstants
public class ZoneView
extends BoxView

ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。在将要表示的模型很大的情况下，此类仅为将要主动地查看/编辑的区域构建视图对象，从而使其在内容消耗上有一个实质性的减少。可以通过某种途径估计子级的大小，或者仅利用保存的结果来异步计算。

ZoneView 扩展 BoxView 来为其子级提供一个实现分区的框。分区是特殊的 View 实现（此类的一个实例的子级），其仅表示一个 ZoneView 实例所负责的一部分模型。在尝试显示子视图之前，分区不创建子视图。一个框形的视图很合适，这是因为：

  • 框是一种常用的视图，有了一个提供此行为的框便有了向视图工厂的视图层次中插入该行为的实质性机会。
  • 框朝一个方向平铺，因此很容易以一种可靠的方式将其分割成区。
  • 框通常跟模型有一种简单的联系（即它们创建直接表示子元素的子视图）。
  • 比起其他形状，更容易估计框的大小。

默认的行为由 maxZoneSize 和 maxZonesLoaded 两个属性来控制。将 maxZoneSize 设置为整数 Integer.MAX_VALUE 会导致仅创建一个分区。这将有效地将视图转换为装饰模式的一个实现。将 maxZonesLoaded 设置为 Integer.MAX_VALUE 整数值将导致分区永远不会被卸载。为简单起见，在由视图负责的元素的子元素所表示的边界上创建分区。分区可以是任何 View 实现，但是默认的实现以高效地支持极大分区的 AsyncBoxView 为基础。

从以下版本开始：
1.3
另请参见：
View

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
ZoneView(Element elem, int axis)
构造一个 ZoneView。
方法摘要
protected View | createZone(int p0, int p1) 针对模型中的给定范围（应该在此对象的职责范围内），创建一个视图来表示分区。
int | getMaximumZoneSize() 获取当前最大的分区大小。
int | getMaxZonesLoaded() 获取当前设置的允许同时加载的分区数。
protected int | getViewIndexAtPosition(int pos) 返回表示模型中给定位置的子视图索引。
void | insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出在文档中此视图负责的位置插入了某些内容的通知。
protected boolean | isZoneLoaded(View zone) 确定某个分区是否处于加载状态。
protected void | loadChildren(ViewFactory f) 加载所有子级来初始化视图。
void | removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | setMaximumZoneSize(int size) 设置所需的最大分区大小。
void | setMaxZonesLoaded(int mzl) 设置当前设置的允许同时加载的分区数。
protected void | unloadZone(View zone) 卸载一个分区（将分区转换到其内存节省状态）。
protected boolean | updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
protected void | zoneWasLoaded(View zone) 当加载某个分区后由该分区调用。
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, calculateMajorAxisRequirements, calculateMinorAxisRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAlignment, getAxis, getChildAllocation, getHeight, getMaximumSpan, getMinimumSpan, getOffset, getPreferredSpan, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paint, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets, setParent
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdateToView, getAttributes, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, isVisible, modelToView, remove, removeAll, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ZoneView

public ZoneView(Element elem,
                int axis)
构造一个 ZoneView。

参数：
elem - 此视图负责的元素
axis - View.X_AXIS 或者 View.Y_AXIS
方法详细信息

getMaximumZoneSize

public int getMaximumZoneSize()
获取当前最大的分区大小。

setMaximumZoneSize

public void setMaximumZoneSize(int size)
设置所需的最大分区大小。如果单个子视图大于此大小则分区也会大于此大小，因为分区是在子视图边界上形成的。

参数：
size - 在试图将分区拆分成更小的分区前，此分区能显示的字符数。

getMaxZonesLoaded

public int getMaxZonesLoaded()
获取当前设置的允许同时加载的分区数。

setMaxZonesLoaded

public void setMaxZonesLoaded(int mzl)
设置当前设置的允许同时加载的分区数。如果 mzl 小于 1，此方法将抛出 IllegalArgumentException。

参数：
mzl - 能主动加载的所需最大分区数，必须大于 0
抛出：
IllegalArgumentException - 如果 mzl < 1

zoneWasLoaded

protected void zoneWasLoaded(View zone)
当加载某个分区后由该分区调用。这发生在试图在某个处于卸载状态的分区上显示或执行模型/视图转换的时候。实现此方法来检查是否已达到最大的分区数，如果达到则卸载存在最久的分区。

参数：
zone - 刚刚加载的子视图

unloadZone

protected void unloadZone(View zone)
卸载一个分区（将分区转换到其内存节省状态）。希望分区来表示此视图负责元素的子元素的一个子集。因此，默认的实现会移除所有子级。

参数：
zone - 需要设置成卸载状态的子视图。

isZoneLoaded

protected boolean isZoneLoaded(View zone)
确定某个分区是否处于加载状态。希望分区来表示此视图负责元素的子元素的一个子集。因此，默认的实现在视图存在子级时返回 true。

createZone

protected View createZone(int p0,
                          int p1)
针对模型中的给定范围（应该在此对象的职责范围内），创建一个视图来表示分区。由分区管理逻辑调用此方法来创建新分区。子类通过更改此方法来为分区提供不同的实现。

参数：
p0 - 所需分区的开始处。此参数应 >= getStartOffset() 且 < getEndOffset()。此值也应 < p1。
p1 - 所需分区的结尾。此参数应 > getStartOffset() 且 <= getEndOffset()。此值也应 > p0。

loadChildren

protected void loadChildren(ViewFactory f)
加载所有子级来初始化视图。此方法由 setParent 方法调用。实现此方法以不直接加载任何子级（因为它们由分区创建）。此方法创建了初始的分区集。但是在试图显示分区或执行模型/视图坐标转换之前，并不实际组装这些分区。

覆盖：
类 CompositeView 中的 loadChildren
参数：
f - 视图工厂
另请参见：
CompositeView.setParent(javax.swing.text.View)

getViewIndexAtPosition

protected int getViewIndexAtPosition(int pos)
返回表示模型中给定位置的子视图索引。

覆盖：
类 CompositeView 中的 getViewIndexAtPosition
参数：
pos - 位置，该值 >= 0
返回：
表示给定位置的视图索引，如果没有任何视图表示该位置，则返回 -1

updateChildren

protected boolean updateChildren(DocumentEvent.ElementChange ec,
                                 DocumentEvent e,
                                 ViewFactory f)
超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。重新实现此方法以不执行任何操作，并且返回 false。

覆盖：
类 View 中的 updateChildren
参数：
ec - 此视图所负责的元素的更改信息。如果调用此方法，该参赛不应当为 null
e - 来自关联文档的变化信息
f - 用于构建子视图的工厂
返回：
子视图是否表示此视图所负责的元素的子元素。某些视图创建表示其所负责的一部分元素的子级，其应当返回 false。此信息用于确定是否应该转发添加的元素范围中的视图
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory),
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

insertUpdate

public void insertUpdate(DocumentEvent changes,
                         Shape a,
                         ViewFactory f)
给出在文档中此视图负责的位置插入了某些内容的通知。此方法一般委托给超类，但是可重新实现此方法来更新相关的分区（即确定某个分区是否需要拆分为 2 个或更多分区的集合）。

覆盖：
类 View 中的 insertUpdate
参数：
changes - 来自关联文档的更改信息
a - 视图的当前分配
f - 视图有子级时用于重建的工厂
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(DocumentEvent changes,
                         Shape a,
                         ViewFactory f)
给出从文档中此视图负责的位置移除了某些内容的通知。此方法一般委托给超类，但是可重新实现此方法来更新相关的分区（即确定分区是否需要被移除或跟其他分区合并）。

覆盖：
类 View 中的 removeUpdate
参数：
changes - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.text (Java Platform SE 6)

 javax.swing.text
接口
AbstractDocument.AttributeContext
AbstractDocument.Content
AttributeSet
AttributeSet.CharacterAttribute
AttributeSet.ColorAttribute
AttributeSet.FontAttribute
AttributeSet.ParagraphAttribute
Caret
Document
Element
Highlighter
Highlighter.Highlight
Highlighter.HighlightPainter
Keymap
MutableAttributeSet
Position
Style
StyledDocument
TabableView
TabExpander
ViewFactory
类
AbstractDocument
AbstractDocument.ElementEdit
AbstractWriter
AsyncBoxView
BoxView
ComponentView
CompositeView
DateFormatter
DefaultCaret
DefaultEditorKit
DefaultEditorKit.BeepAction
DefaultEditorKit.CopyAction
DefaultEditorKit.CutAction
DefaultEditorKit.DefaultKeyTypedAction
DefaultEditorKit.InsertBreakAction
DefaultEditorKit.InsertContentAction
DefaultEditorKit.InsertTabAction
DefaultEditorKit.PasteAction
DefaultFormatter
DefaultFormatterFactory
DefaultHighlighter
DefaultHighlighter.DefaultHighlightPainter
DefaultStyledDocument
DefaultStyledDocument.AttributeUndoableEdit
DefaultStyledDocument.ElementSpec
DefaultTextUI
DocumentFilter
DocumentFilter.FilterBypass
EditorKit
ElementIterator
FieldView
FlowView
FlowView.FlowStrategy
GapContent
GlyphView
GlyphView.GlyphPainter
IconView
InternationalFormatter
JTextComponent
JTextComponent.DropLocation
JTextComponent.KeyBinding
LabelView
LayeredHighlighter
LayeredHighlighter.LayerPainter
LayoutQueue
MaskFormatter
NavigationFilter
NavigationFilter.FilterBypass
NumberFormatter
ParagraphView
PasswordView
PlainDocument
PlainView
Position.Bias
Segment
SimpleAttributeSet
StringContent
StyleConstants
StyleConstants.CharacterConstants
StyleConstants.ColorConstants
StyleConstants.FontConstants
StyleConstants.ParagraphConstants
StyleContext
StyledEditorKit
StyledEditorKit.AlignmentAction
StyledEditorKit.BoldAction
StyledEditorKit.FontFamilyAction
StyledEditorKit.FontSizeAction
StyledEditorKit.ForegroundAction
StyledEditorKit.ItalicAction
StyledEditorKit.StyledTextAction
StyledEditorKit.UnderlineAction
TableView
TabSet
TabStop
TextAction
Utilities
View
WrappedPlainView
ZoneView
异常
BadLocationException
ChangedCharSetException


javax.swing.text (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.text

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

请参见：
描述

接口摘要
AbstractDocument.AttributeContext | 一个接口，它用于允许 MutableAttributeSet 的实现使用可插入属性压缩技术。
AbstractDocument.Content | 描述可编辑的字符序列内容的接口。
AttributeSet | 唯一属性的集合。
AttributeSet.CharacterAttribute | 此接口是类型签名，可出现在任意属性键上以帮助实现字符级的表示。
AttributeSet.ColorAttribute | 此接口是类型签名，可出现在任意属性键上以帮助实现颜色的表示。
AttributeSet.FontAttribute | 此接口是类型签名，可出现在任意属性键上以帮助确定使用何种字体来呈现某类文本。
AttributeSet.ParagraphAttribute | 此接口是类型签名，可出现在任意属性键上以帮助实现段落级的表示。
Caret | 文档视图中的一个位置，它表示文档模型中能插入其他内容的位置。
Document | Document 是一个作为 swing 文本组件模型的文本容器。
Element | 描述文档的结构元素的接口。
Highlighter | 一个允许用户用带有颜色的区域标出背景的对象接口。
Highlighter.Highlight |
Highlighter.HighlightPainter | 呈现高亮显示。
Keymap | 将 KeyStroke 绑定到操作的集合。
MutableAttributeSet | 独特属性的可变集合的通用接口。
Position | 表示文档中的位置。
Style | 与文档中某个元素相关的属性集合。
StyledDocument | 用作通用样式化文档的接口。
TabableView | 大小依赖于制表符的 View 的接口。
TabExpander | 允许不同类型的制表符扩展实现的简单接口。
ViewFactory | 创建文档专题某些部分的视图的工厂。

类摘要
AbstractDocument | 文档接口的实现，可作为实现各种文档的基础。
AbstractDocument.ElementEdit | 一个 ElementChange 实现，可将其添加到文档事件中。
AbstractWriter | AbstractWriter 是一个抽象类，它实际执行元素树（包括属性）的写出工作。
AsyncBoxView | 异步执行布局处理的框。
BoxView | 一个视图，它通过沿某轴平铺将其子级排列到框形状中。
ComponentView | 实现视图接口的组件装饰器。
CompositeView | CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
DateFormatter | DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
DefaultCaret | 插入符的默认实现。
DefaultEditorKit | 这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
DefaultEditorKit.BeepAction | 创建蜂鸣声。
DefaultEditorKit.CopyAction | 复制选定的区域并将其内容放入系统剪贴板中。
DefaultEditorKit.CutAction | 剪切选定的区域并将其内容放入系统剪贴板中。
DefaultEditorKit.DefaultKeyTypedAction | 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
DefaultEditorKit.InsertBreakAction | 在文档中放置行/段落中断。
DefaultEditorKit.InsertContentAction | 将内容置于关联的文档中。
DefaultEditorKit.InsertTabAction | 将一个制表符置于文档中。
DefaultEditorKit.PasteAction | 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
DefaultFormatter | DefaultFormatter 格式化任意对象。
DefaultFormatterFactory | JFormattedTextField.AbstractFormatterFactory 的一个实现。
DefaultHighlighter | 实现 Highlighter 接口。
DefaultHighlighter.DefaultHighlightPainter | 只高亮显示用纯色填充高亮显示区域的 painter。
DefaultStyledDocument | 能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
DefaultStyledDocument.AttributeUndoableEdit | 用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。
DefaultStyledDocument.ElementSpec | 构建元素的规范。
DefaultTextUI | 已过时。
DocumentFilter | DocumentFilter，顾名思义，它是 Document 改变方法的一个过滤器。
DocumentFilter.FilterBypass | 充当避开回调 Document 进行更改的方法。
EditorKit | 针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
ElementIterator | ElementIterator，顾名思义，沿 Element 树进行迭代。
FieldView | 扩展多行纯文本视图，使其适合单行编辑器视图。
FlowView | 试图将其子级流入某个部分受约束的空间的视图。
FlowView.FlowStrategy | 维护流的物理形式的策略。
GapContent | AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。
GlyphView | GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
GlyphView.GlyphPainter | 执行字形呈现的类。
IconView | 实现视图接口的图标修饰符。
InternationalFormatter | InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
JTextComponent | JTextComponent 是 swing 文本组件的基类。
JTextComponent.DropLocation | 表示 JTextComponent 的放置位置 (drop location)。
JTextComponent.KeyBinding | 用于创建键绑定的绑定记录。
LabelView | LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
LayeredHighlighter |
LayeredHighlighter.LayerPainter | 分层的高亮显示渲染器。
LayoutQueue | 文本布局任务的队列。
MaskFormatter | MaskFormatter 用于格式化和编辑字符串。
NavigationFilter | NavigationFilter 可用于限制光标的定位。
NavigationFilter.FilterBypass | 用作防止回调插入符以定位光标的方式。
NumberFormatter | 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。
ParagraphView | 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
PasswordView | 实现适用于 JPasswordField UI 实现的视图。
PlainDocument | 维护无任何字符属性的普通文档。
PlainView | 实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
Position.Bias | 用来指示模型中位置偏差的类型安全的枚举。
Segment | 表示文本片段的字符数组的 segment。
SimpleAttributeSet | 使用哈希表的 MutableAttributeSet 的直接实现。
StringContent | AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。
StyleConstants | 一个已知的 或常见的属性键和方法的集合，可通过应用 AttributeSet 或 MutableAttributeSet 方法以类型安全的方式获取/设置属性。
StyleConstants.CharacterConstants | 这是一个类型安全的已知 属性的枚举，它用于字符样式。
StyleConstants.ColorConstants | 这是一个类型安全的已知 属性的枚举，它用于颜色样式。
StyleConstants.FontConstants | 这是一个类型安全的已知 属性的枚举，它用于字体样式。
StyleConstants.ParagraphConstants | 这是一个类型安全的已知 属性的枚举，它用于段落样式。
StyleContext | 样式池及其关联的资源。
StyledEditorKit | 这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
StyledEditorKit.AlignmentAction | 设置段落对齐的操作。
StyledEditorKit.BoldAction | 切换粗体属性的操作。
StyledEditorKit.FontFamilyAction | 在相关的 JEditorPane 中设置字体系列的操作。
StyledEditorKit.FontSizeAction | 设置关联的 JEditorPane 中字体大小的操作。
StyledEditorKit.ForegroundAction | 设置前景色的操作。
StyledEditorKit.ItalicAction | 切换斜体属性的一种操作。
StyledEditorKit.StyledTextAction | 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
StyledEditorKit.UnderlineAction | 切换下划线属性的操作。
TableView | 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
TabSet | 由许多 TabStop 组成的一个 TabSet。
TabStop | 此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。
TextAction | 用于跨多个不同文本组件共享的键绑定的 Action 实现。
Utilities | 处理各种文本相关活动的方法集合。
View | View 类是 text 包极为重要的一部分。
WrappedPlainView | 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
ZoneView | ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

异常摘要
BadLocationException | 此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
ChangedCharSetException | 顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

软件包 javax.swing.text 的描述

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

包规范

  • HTML 3.2 Reference Specification - HTML 规范，它是 HTMLEditorKit 的基础。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.text 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.text 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.BeepAction
        • javax.swing.text.DefaultEditorKit.CopyAction
        • javax.swing.text.DefaultEditorKit.CutAction
        • javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
        • javax.swing.text.DefaultEditorKit.InsertBreakAction
        • javax.swing.text.DefaultEditorKit.InsertContentAction
        • javax.swing.text.DefaultEditorKit.InsertTabAction
        • javax.swing.text.DefaultEditorKit.PasteAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.StyledEditorKit.AlignmentAction
          • javax.swing.text.StyledEditorKit.BoldAction
          • javax.swing.text.StyledEditorKit.FontFamilyAction
          • javax.swing.text.StyledEditorKit.FontSizeAction
          • javax.swing.text.StyledEditorKit.ForegroundAction
          • javax.swing.text.StyledEditorKit.ItalicAction
          • javax.swing.text.StyledEditorKit.UnderlineAction
    • javax.swing.text.AbstractDocument (implements javax.swing.text.Document, java.io.Serializable)
      • javax.swing.text.DefaultStyledDocument (implements javax.swing.text.StyledDocument)
      • javax.swing.text.PlainDocument
    • javax.swing.text.AbstractDocument.AbstractElement (implements javax.swing.text.Element, javax.swing.text.MutableAttributeSet, java.io.Serializable, javax.swing.tree.TreeNode)
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.DefaultStyledDocument.SectionElement
      • javax.swing.text.AbstractDocument.LeafElement
    • javax.swing.undo.AbstractUndoableEdit (implements java.io.Serializable, javax.swing.undo.UndoableEdit)
      • javax.swing.text.AbstractDocument.ElementEdit (implements javax.swing.event.DocumentEvent.ElementChange)
      • javax.swing.undo.CompoundEdit
        • javax.swing.text.AbstractDocument.DefaultDocumentEvent (implements javax.swing.event.DocumentEvent)
      • javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
    • javax.swing.text.AbstractWriter
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.text.JTextComponent.AccessibleJTextComponent (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleExtendedText, javax.accessibility.AccessibleText, javax.swing.event.CaretListener, javax.swing.event.DocumentListener)
    • javax.swing.text.AsyncBoxView.ChildLocator
    • javax.swing.text.AsyncBoxView.ChildState (implements java.lang.Runnable)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.text.DefaultTextUI
    • javax.swing.text.DefaultStyledDocument.ElementBuffer (implements java.io.Serializable)
    • javax.swing.text.DefaultStyledDocument.ElementSpec
    • javax.swing.text.DocumentFilter
    • javax.swing.text.DocumentFilter.FilterBypass
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
    • javax.swing.text.ElementIterator (implements java.lang.Cloneable)
    • javax.swing.text.FlowView.FlowStrategy
    • javax.swing.text.GapContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • javax.swing.text.GlyphView.GlyphPainter
    • javax.swing.JFormattedTextField.AbstractFormatter (implements java.io.Serializable)
      • javax.swing.text.DefaultFormatter (implements java.lang.Cloneable, java.io.Serializable)
        • javax.swing.text.InternationalFormatter
          • javax.swing.text.DateFormatter
          • javax.swing.text.NumberFormatter
        • javax.swing.text.MaskFormatter
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
      • javax.swing.text.DefaultFormatterFactory (implements java.io.Serializable)
    • javax.swing.text.JTextComponent.KeyBinding
    • javax.swing.text.LayeredHighlighter (implements javax.swing.text.Highlighter)
      • javax.swing.text.DefaultHighlighter
    • javax.swing.text.LayeredHighlighter.LayerPainter (implements javax.swing.text.Highlighter.HighlightPainter)
      • javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
    • javax.swing.text.LayoutQueue
    • javax.swing.text.NavigationFilter
    • javax.swing.text.NavigationFilter.FilterBypass
    • javax.swing.text.Position.Bias
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
          • javax.swing.text.DefaultCaret (implements javax.swing.text.Caret, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • javax.swing.text.Segment (implements java.text.CharacterIterator, java.lang.CharSequence, java.lang.Cloneable)
    • javax.swing.text.SimpleAttributeSet (implements java.lang.Cloneable, javax.swing.text.MutableAttributeSet, java.io.Serializable)
    • javax.swing.text.StringContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.CharacterConstants (implements javax.swing.text.AttributeSet.CharacterAttribute)
      • javax.swing.text.StyleConstants.ColorConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.ColorAttribute)
      • javax.swing.text.StyleConstants.FontConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.FontAttribute)
      • javax.swing.text.StyleConstants.ParagraphConstants (implements javax.swing.text.AttributeSet.ParagraphAttribute)
    • javax.swing.text.StyleContext (implements javax.swing.text.AbstractDocument.AttributeContext, java.io.Serializable)
    • javax.swing.text.StyleContext.NamedStyle (implements java.io.Serializable, javax.swing.text.Style)
    • javax.swing.text.StyleContext.SmallAttributeSet (implements javax.swing.text.AttributeSet)
    • javax.swing.text.TabSet (implements java.io.Serializable)
    • javax.swing.text.TabStop (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.swing.text.BadLocationException
        • java.io.IOException
          • javax.swing.text.ChangedCharSetException
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.text.JTextComponent.DropLocation
    • javax.swing.text.Utilities
    • javax.swing.text.View (implements javax.swing.SwingConstants)
      • javax.swing.text.AsyncBoxView
      • javax.swing.text.ComponentView
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView (implements javax.swing.text.TabExpander)
          • javax.swing.text.TableView
          • javax.swing.text.TableView.TableCell
          • javax.swing.text.TableView.TableRow
          • javax.swing.text.WrappedPlainView (implements javax.swing.text.TabExpander)
          • javax.swing.text.ZoneView
      • javax.swing.text.GlyphView (implements java.lang.Cloneable, javax.swing.text.TabableView)
        • javax.swing.text.LabelView (implements javax.swing.text.TabableView)
      • javax.swing.text.IconView
      • javax.swing.text.PlainView (implements javax.swing.text.TabExpander)
        • javax.swing.text.FieldView
          • javax.swing.text.PasswordView

接口分层结构

  • javax.swing.text.AbstractDocument.AttributeContext
  • javax.swing.text.AbstractDocument.Content
  • javax.swing.text.AttributeSet
    • javax.swing.text.MutableAttributeSet
      • javax.swing.text.Style
  • javax.swing.text.AttributeSet.CharacterAttribute
  • javax.swing.text.AttributeSet.ColorAttribute
  • javax.swing.text.AttributeSet.FontAttribute
  • javax.swing.text.AttributeSet.ParagraphAttribute
  • javax.swing.text.Caret
  • javax.swing.text.Document
    • javax.swing.text.StyledDocument
  • javax.swing.text.Element
  • javax.swing.text.Highlighter
  • javax.swing.text.Highlighter.Highlight
  • javax.swing.text.Highlighter.HighlightPainter
  • javax.swing.text.Keymap
  • javax.swing.text.Position
  • javax.swing.text.TabableView
  • javax.swing.text.TabExpander
  • javax.swing.text.ViewFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.text 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.text
的使用

使用 javax.swing.text 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 使用的 javax.swing.text 中的类
AttributeSet
唯一属性的集合。

javax.accessibility 使用的 javax.swing.text 中的类
AttributeSet
唯一属性的集合。

javax.swing 使用的 javax.swing.text 中的类
AttributeSet
唯一属性的集合。
BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
Document
Document 是一个作为 swing 文本组件模型的文本容器。
DocumentFilter
DocumentFilter，顾名思义，它是 Document 改变方法的一个过滤器。
EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
Element
描述文档的结构元素的接口。
JTextComponent
JTextComponent 是 swing 文本组件的基类。
JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。
JTextComponent.KeyBinding
用于创建键绑定的绑定记录。
MutableAttributeSet
独特属性的可变集合的通用接口。
NavigationFilter
NavigationFilter 可用于限制光标的定位。
Position.Bias
用来指示模型中位置偏差的类型安全的枚举。
Style
与文档中某个元素相关的属性集合。
StyledDocument
用作通用样式化文档的接口。
StyledEditorKit
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。

javax.swing.event 使用的 javax.swing.text 中的类
Document
Document 是一个作为 swing 文本组件模型的文本容器。
Element
描述文档的结构元素的接口。

javax.swing.plaf 使用的 javax.swing.text 中的类
BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
JTextComponent
JTextComponent 是 swing 文本组件的基类。
Position.Bias
用来指示模型中位置偏差的类型安全的枚举。
View
View 类是 text 包极为重要的一部分。

javax.swing.plaf.basic 使用的 javax.swing.text 中的类
BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
Caret
文档视图中的一个位置，它表示文档模型中能插入其他内容的位置。
DefaultCaret
插入符的默认实现。
DefaultHighlighter
实现 Highlighter 接口。
EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
Element
描述文档的结构元素的接口。
Highlighter
一个允许用户用带有颜色的区域标出背景的对象接口。
JTextComponent
JTextComponent 是 swing 文本组件的基类。
Keymap
将 KeyStroke 绑定到操作的集合。
LayeredHighlighter
Position.Bias
用来指示模型中位置偏差的类型安全的枚举。
View
View 类是 text 包极为重要的一部分。
ViewFactory
创建文档专题某些部分的视图的工厂。

javax.swing.plaf.metal 使用的 javax.swing.text 中的类
ViewFactory
创建文档专题某些部分的视图的工厂。

javax.swing.plaf.multi 使用的 javax.swing.text 中的类
BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
JTextComponent
JTextComponent 是 swing 文本组件的基类。
Position.Bias
用来指示模型中位置偏差的类型安全的枚举。
View
View 类是 text 包极为重要的一部分。

javax.swing.text 使用的 javax.swing.text 中的类
AbstractDocument
文档接口的实现，可作为实现各种文档的基础。
AbstractDocument.AbstractElement
实现元素的抽象部分。
AbstractDocument.AttributeContext
一个接口，它用于允许 MutableAttributeSet 的实现使用可插入属性压缩技术。
AbstractDocument.BranchElement
实现一个包含其他元素的复合元素。
AbstractDocument.Content
描述可编辑的字符序列内容的接口。
AbstractDocument.DefaultDocumentEvent
存储修改文档时发生的文档更改。
AsyncBoxView.ChildLocator
该类在本地化区域发生更改时，管理该本地化区域中子视图的有效位置。
AsyncBoxView.ChildState
表示子视图布局状态的记录。
AttributeSet
唯一属性的集合。
AttributeSet.CharacterAttribute
此接口是类型签名，可出现在任意属性键上以帮助实现字符级的表示。
AttributeSet.ColorAttribute
此接口是类型签名，可出现在任意属性键上以帮助实现颜色的表示。
AttributeSet.FontAttribute
此接口是类型签名，可出现在任意属性键上以帮助确定使用何种字体来呈现某类文本。
AttributeSet.ParagraphAttribute
此接口是类型签名，可出现在任意属性键上以帮助实现段落级的表示。
BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
BoxView
一个视图，它通过沿某轴平铺将其子级排列到框形状中。
Caret
文档视图中的一个位置，它表示文档模型中能插入其他内容的位置。
CompositeView
CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
DefaultEditorKit
这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
DefaultFormatter
DefaultFormatter 格式化任意对象。
DefaultStyledDocument.ElementBuffer
管理对元素层次结构更改的类。
DefaultStyledDocument.ElementSpec
构建元素的规范。
Document
Document 是一个作为 swing 文本组件模型的文本容器。
DocumentFilter
DocumentFilter，顾名思义，它是 Document 改变方法的一个过滤器。
DocumentFilter.FilterBypass
充当避开回调 Document 进行更改的方法。
EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
Element
描述文档的结构元素的接口。
ElementIterator
ElementIterator，顾名思义，沿 Element 树进行迭代。
FieldView
扩展多行纯文本视图，使其适合单行编辑器视图。
FlowView
试图将其子级流入某个部分受约束的空间的视图。
FlowView.FlowStrategy
维护流的物理形式的策略。
GlyphView
GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
GlyphView.GlyphPainter
执行字形呈现的类。
Highlighter
一个允许用户用带有颜色的区域标出背景的对象接口。
Highlighter.Highlight
Highlighter.HighlightPainter
呈现高亮显示。
InternationalFormatter
InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
JTextComponent
JTextComponent 是 swing 文本组件的基类。
JTextComponent.DropLocation
表示 JTextComponent 的放置位置 (drop location)。
JTextComponent.KeyBinding
用于创建键绑定的绑定记录。
Keymap
将 KeyStroke 绑定到操作的集合。
LayeredHighlighter
LayeredHighlighter.LayerPainter
分层的高亮显示渲染器。
LayoutQueue
文本布局任务的队列。
MutableAttributeSet
独特属性的可变集合的通用接口。
NavigationFilter
NavigationFilter 可用于限制光标的定位。
NavigationFilter.FilterBypass
用作防止回调插入符以定位光标的方式。
PlainView
实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
Position
表示文档中的位置。
Position.Bias
用来指示模型中位置偏差的类型安全的枚举。
Segment
表示文本片段的字符数组的 segment。
Style
与文档中某个元素相关的属性集合。
StyleConstants
一个已知的 或常见的属性键和方法的集合，可通过应用 AttributeSet 或 MutableAttributeSet 方法以类型安全的方式获取/设置属性。
StyleContext
样式池及其关联的资源。
StyleContext.SmallAttributeSet
此类可在数组中存储少量的属性。
StyledDocument
用作通用样式化文档的接口。
StyledEditorKit
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
StyledEditorKit.StyledTextAction
假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
TabableView
大小依赖于制表符的 View 的接口。
TabExpander
允许不同类型的制表符扩展实现的简单接口。
TableView.TableCell
已过时。 表单元格如今可以是任何 View 实现。
TableView.TableRow
以行为中心的表格中的行视图。
TabSet
由许多 TabStop 组成的一个 TabSet。
TabStop
此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。
TextAction
用于跨多个不同文本组件共享的键绑定的 Action 实现。
View
View 类是 text 包极为重要的一部分。
ViewFactory
创建文档专题某些部分的视图的工厂。

javax.swing.text.html 使用的 javax.swing.text 中的类
AbstractDocument
文档接口的实现，可作为实现各种文档的基础。
AbstractDocument.AbstractElement
实现元素的抽象部分。
AbstractDocument.AttributeContext
一个接口，它用于允许 MutableAttributeSet 的实现使用可插入属性压缩技术。
AbstractDocument.BranchElement
实现一个包含其他元素的复合元素。
AbstractDocument.Content
描述可编辑的字符序列内容的接口。
AbstractDocument.DefaultDocumentEvent
存储修改文档时发生的文档更改。
AbstractDocument.LeafElement
实现可直接表示某类内容的元素。
AbstractWriter
AbstractWriter 是一个抽象类，它实际执行元素树（包括属性）的写出工作。
AttributeSet
唯一属性的集合。
BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
BoxView
一个视图，它通过沿某轴平铺将其子级排列到框形状中。
ComponentView
实现视图接口的组件装饰器。
CompositeView
CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
DefaultEditorKit
这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
DefaultStyledDocument
能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
DefaultStyledDocument.ElementSpec
构建元素的规范。
Document
Document 是一个作为 swing 文本组件模型的文本容器。
EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
Element
描述文档的结构元素的接口。
GlyphView
GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
LabelView
LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
MutableAttributeSet
独特属性的可变集合的通用接口。
ParagraphView
存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
Position.Bias
用来指示模型中位置偏差的类型安全的枚举。
Style
与文档中某个元素相关的属性集合。
StyleContext
样式池及其关联的资源。
StyleContext.SmallAttributeSet
此类可在数组中存储少量的属性。
StyledDocument
用作通用样式化文档的接口。
StyledEditorKit
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
StyledEditorKit.StyledTextAction
假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
TabableView
大小依赖于制表符的 View 的接口。
TextAction
用于跨多个不同文本组件共享的键绑定的 Action 实现。
View
View 类是 text 包极为重要的一部分。
ViewFactory
创建文档专题某些部分的视图的工厂。

javax.swing.text.html.parser 使用的 javax.swing.text 中的类
ChangedCharSetException
顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。
SimpleAttributeSet
使用哈希表的 MutableAttributeSet 的直接实现。

javax.swing.text.rtf 使用的 javax.swing.text 中的类
BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
DefaultEditorKit
这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
Document
Document 是一个作为 swing 文本组件模型的文本容器。
EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
StyledEditorKit
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。

javax.swing.tree 使用的 javax.swing.text 中的类
JTextComponent
JTextComponent 是 swing 文本组件的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


RTFEditorKit (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.rtf
类 RTFEditorKit

java.lang.Object
    继承者  javax.swing.text.EditorKit
        继承者  javax.swing.text.DefaultEditorKit
            继承者  javax.swing.text.StyledEditorKit
                继承者  javax.swing.text.rtf.RTFEditorKit
所有已实现的接口：
Serializable, Cloneable
public class RTFEditorKit
extends StyledEditorKit

这是对 RTF 编辑功能的默认实现。Swing 团队未编写 RTF 支持。将来我们希望改进提供的支持。

嵌套类摘要
从类 javax.swing.text.StyledEditorKit 继承的嵌套类/接口
StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction
从类 javax.swing.text.DefaultEditorKit 继承的嵌套类/接口
DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction
字段摘要
从类 javax.swing.text.DefaultEditorKit 继承的字段
backwardAction, beepAction, beginAction, beginLineAction, beginParagraphAction, beginWordAction, copyAction, cutAction, defaultKeyTypedAction, deleteNextCharAction, deleteNextWordAction, deletePrevCharAction, deletePrevWordAction, downAction, endAction, endLineAction, EndOfLineStringProperty, endParagraphAction, endWordAction, forwardAction, insertBreakAction, insertContentAction, insertTabAction, nextWordAction, pageDownAction, pageUpAction, pasteAction, previousWordAction, readOnlyAction, selectAllAction, selectionBackwardAction, selectionBeginAction, selectionBeginLineAction, selectionBeginParagraphAction, selectionBeginWordAction, selectionDownAction, selectionEndAction, selectionEndLineAction, selectionEndParagraphAction, selectionEndWordAction, selectionForwardAction, selectionNextWordAction, selectionPreviousWordAction, selectionUpAction, selectLineAction, selectParagraphAction, selectWordAction, upAction, writableAction
构造方法摘要
RTFEditorKit()
构造一个 RTFEditorKit。
方法摘要
String | getContentType() 获取此工具包支持的 MIME 类型的数据。
void | read(InputStream in, Document doc, int pos) 插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
void | read(Reader in, Document doc, int pos) 插入来自给定流的内容，该内容将被视为纯文本。
void | write(OutputStream out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
void | write(Writer out, Document doc, int pos, int len) 将文档中的内容作为纯文本写入给定的流。
从类 javax.swing.text.StyledEditorKit 继承的方法
clone, createDefaultDocument, createInputAttributes, deinstall, getActions, getCharacterAttributeRun, getInputAttributes, getViewFactory, install
从类 javax.swing.text.DefaultEditorKit 继承的方法
createCaret
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RTFEditorKit

public RTFEditorKit()
构造一个 RTFEditorKit。

方法详细信息

getContentType

public String getContentType()
获取此工具包支持的 MIME 类型的数据。此工具包支持 text/rtf 类型。

覆盖：
类 DefaultEditorKit 中的 getContentType
返回：
类型

read

public void read(InputStream in,
                 Document doc,
                 int pos)
          throws IOException,
                 BadLocationException
插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。

覆盖：
类 DefaultEditorKit 中的 read
参数：
in - 从中读取数据的流
doc - 插入的目标。
pos - 文档中存放内容的位置。
抛出：
IOException - 如果出现任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。

write

public void write(OutputStream out,
                  Document doc,
                  int pos,
                  int len)
           throws IOException,
                  BadLocationException
以适合此类内容处理程序的格式，将文档中的内容写入给定流。

覆盖：
类 DefaultEditorKit 中的 write
参数：
out - 要向其写入的流
doc - 写入的源。
pos - 文档中获取内容的位置。
len - 要写出的数量。
抛出：
IOException - 如果出现任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。

read

public void read(Reader in,
                 Document doc,
                 int pos)
          throws IOException,
                 BadLocationException
插入来自给定流的内容，该内容将被视为纯文本。

覆盖：
类 DefaultEditorKit 中的 read
参数：
in - 从中读取数据的流
doc - 插入的目标。
pos - 文档中存放内容的位置。
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。

write

public void write(Writer out,
                  Document doc,
                  int pos,
                  int len)
           throws IOException,
                  BadLocationException
将文档中的内容作为纯文本写入给定的流。

覆盖：
类 DefaultEditorKit 中的 write
参数：
out - 要向其写入的流
doc - 写入的源。
pos - 文档中获取内容的位置。
len - 要写出的数量。
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.text.rtf (Java Platform SE 6)

 javax.swing.text.rtf
类
RTFEditorKit


javax.swing.text.rtf (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.text.rtf

提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

请参见：
描述

类摘要
RTFEditorKit 这是对 RTF 编辑功能的默认实现。

软件包 javax.swing.text.rtf 的描述

提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

注：大多数 Swing API 都不是 线程安全的。有关详细信息，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.text.rtf 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.text.rtf 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.rtf.RTFEditorKit
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.text.rtf 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.text.rtf
的使用

没有 javax.swing.text.rtf 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.rtf.RTFEditorKit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.rtf.RTFEditorKit
的使用

没有 javax.swing.text.rtf.RTFEditorKit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


BlockView (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 BlockView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.html.BlockView
所有已实现的接口：
SwingConstants
直接已知子类：
ListView
public class BlockView
extends BoxView

用来显示具有 CSS 规范的块（作为一个框）的视图实现。

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
BlockView(Element elem, int axis)
创建表示 html 框的新视图。
方法摘要
protected SizeRequirements | calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算块沿主轴的要求（即沿其平铺的轴）。
protected SizeRequirements | calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算块沿辅轴的要求（即垂直沿其平铺的轴的轴）。
void | changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
float | getAlignment(int axis) 获取对齐方式。
AttributeSet | getAttributes() 获取呈现时要使用的属性。
float | getMaximumSpan(int axis) 确定此视图沿某轴的最大区域。
float | getMinimumSpan(int axis) 确定此视图沿某个轴的最小区域。
float | getPreferredSpan(int axis) 确定此视图沿某个轴的首选区域。
int | getResizeWeight(int axis) 获取调整的权重。
protected StyleSheet | getStyleSheet()
protected void | layoutMinorAxis(int targetSpan, int axis, int[] offsets, int[] spans) 执行对框的辅轴（即与它所代表的轴垂直的轴）的布局。
void | paint(Graphics g, Shape allocation) 使用给定呈现面和该表面的区域呈现。
void | setParent(View parent) 建立此视图的父视图。
protected void | setPropertiesFromAttributes() 更新来自属性的任何缓存的值。
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAxis, getChildAllocation, getHeight, getOffset, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdateToView, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BlockView

public BlockView(Element elem,
                 int axis)
创建表示 html 框的新视图。此操作可用于许多元素。

参数：
elem - 用来创建视图的元素
axis - 要么是 View.X_AXIS，要么是 View.Y_AXIS
方法详细信息

setParent

public void setParent(View parent)
建立此视图的父视图。如果父视图的功能正确，在调用任何其他方法之前要确保调用此方法。

实现此方法的目的是为了转发到超类，以及调用 setPropertiesFromAttributes() 方法来设置 css 属性中的段落属性。此时进行调用可确保能够通过父视图属性向上进行解析。

覆盖：
类 CompositeView 中的 setParent
参数：
parent - 新父级，如果该视图正从其以前添加到的父视图中移除，则返回 null

calculateMajorAxisRequirements

protected SizeRequirements calculateMajorAxisRequirements(int axis,
                                                          SizeRequirements r)
计算块沿主轴的要求（即沿其平铺的轴）。如果指定了 CSS 的宽度或高度属性并应用于该轴，则实现此方法是为了提供超类行为，然后对其调整。

覆盖：
类 BoxView 中的 calculateMajorAxisRequirements
参数：
axis - 所考察的轴
r - SizeRequirements 对象；如果为 null，将创建一个对象
返回：
新初始化的 SizeRequirements 对象
另请参见：
SizeRequirements

calculateMinorAxisRequirements

protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                                          SizeRequirements r)
计算块沿辅轴的要求（即垂直沿其平铺的轴的轴）。如果指定了 CSS 的宽度或高度属性并应用于该轴，则实现此方法是为了提供超类行为，然后对其调整。

覆盖：
类 BoxView 中的 calculateMinorAxisRequirements
参数：
axis - 所考察的轴
r - SizeRequirements 对象；如果为 null，将创建一个对象
返回：
新初始化的 SizeRequirements 对象
另请参见：
SizeRequirements

layoutMinorAxis

protected void layoutMinorAxis(int targetSpan,
                               int axis,
                               int[] offsets,
                               int[] spans)
执行对框的辅轴（即与它所代表的轴垂直的轴）的布局。布局的结果（每个子级的偏移量和区域）存储在给定的数组中，它表示沿辅轴对子级的分配。

覆盖：
类 BoxView 中的 layoutMinorAxis
参数：
targetSpan - 为视图分配的总区域，它应该用来布局子视图。
axis - 正在进行布局的轴
offsets - 每个子视图的视图原点的偏移量；这是一个返回值并且由此方法的实现来填充
spans - 每个子视图的区域，这是一个返回值并且由此方法的实现来填充

paint

public void paint(Graphics g,
                  Shape allocation)
使用给定呈现面和该表面的区域呈现。实现它的目的是为了把 painter 委托给 css 框，以便在进行内部绘制之前先绘制边框和背景。

覆盖：
类 BoxView 中的 paint
参数：
g - 要使用的呈现表面
allocation - 分配的要在其中呈现的区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getAttributes

public AttributeSet getAttributes()
获取呈现时要使用的属性。实现它的目的是为了使用 StyleSheet 多路传输模型中指定的属性。

覆盖：
类 View 中的 getAttributes

getResizeWeight

public int getResizeWeight(int axis)
获取调整的权重。

覆盖：
类 BoxView 中的 getResizeWeight
参数：
axis - 可以是 X_AXIS，也可以是 Y_AXIS
返回：
权重
抛出：
IllegalArgumentException - 如果是无效的轴

getAlignment

public float getAlignment(int axis)
获取对齐方式。

覆盖：
类 BoxView 中的 getAlignment
参数：
axis - 可以是 X_AXIS，也可以是 Y_AXIS
返回：
对方方式

changedUpdate

public void changedUpdate(DocumentEvent changes,
                          Shape a,
                          ViewFactory f)
从类 View 复制的描述
发出通知，通知文档此视图负责的位置处的属性已更改。为了减少子类的负担，此功能已分散到以下子类能重新实现的调用中：
  1. 如果此视图负责的元素发生任何更改，则调用 updateChildren。如果此视图有表示子元素的子视图，则此方法应当做任何必须的操作来保证子视图正确表示模型。
  2. 要转发 DocumentEvent 到合适的子视图，调用 forwardUpdate。
  3. 要给视图一个机会来修复其布局、重新计划布局或者不做任何操作，调用 updateLayout。

覆盖：
类 View 中的 changedUpdate
参数：
changes - 发自关联文档的更改信息
a - 视图的当前分配
f - 视图有子级时用于重建的工厂 View#changedUpdate

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某个轴的首选区域。

覆盖：
类 BoxView 中的 getPreferredSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，其值 >= 0；通常要求视图呈现在返回的区域中，尽管不一定如此；父级可选择重新调整视图大小或分解视图
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

getMinimumSpan

public float getMinimumSpan(int axis)
确定此视图沿某个轴的最小区域。

覆盖：
类 BoxView 中的 getMinimumSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，其值 >= 0；通常要求视图呈现在返回的区域中，尽管不一定如此；父级可选择重新调整视图大小或分解视图
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

getMaximumSpan

public float getMaximumSpan(int axis)
确定此视图沿某轴的最大区域。

覆盖：
类 BoxView 中的 getMaximumSpan
参数：
axis - 可以为 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，其值 >= 0；通常要求视图呈现在返回的区域中，尽管不一定如此；父级可选择重新调整视图大小或分解视图
抛出：
IllegalArgumentException - 如果轴类型无效
另请参见：
View.getPreferredSpan(int)

setPropertiesFromAttributes

protected void setPropertiesFromAttributes()
更新来自属性的任何缓存的值。

getStyleSheet

protected StyleSheet getStyleSheet()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CSS (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 CSS

java.lang.Object
    继承者  javax.swing.text.html.CSS
所有已实现的接口：
Serializable
public class CSS
extends Object
implements Serializable

将 CSS attributes 集定义为类型安全的枚举。HTML View 实现使用 CSS 属性来确定其呈现的方式。它还定义了 CSS/HTML/StyleConstant 之间的映射方法。任何 shorthand 属性（例如 font）都将被映射为 intrinsic 属性。

以下描述了呈现引擎所支持的 CSS 属性：

  • font-family
  • font-style
  • font-size （支持相对单位）
  • font-weight
  • font
  • color
  • background-color（透明色除外）
  • background-image
  • background-repeat
  • background-position
  • background
  • background-repeat
  • text-decoration（闪烁和上划线除外）
  • vertical-align（只有 sup 和 super）
  • text-align（居中对齐）
  • margin-top
  • margin-right
  • margin-bottom
  • margin-left
  • margin
  • padding-top
  • padding-right
  • padding-bottom
  • padding-left
  • border-style（只支持 inset、outset 和 none）
  • list-style-type
  • list-style-position
以下是已建模的属性，但当前未呈现。
  • font-variant
  • background-attachment（背景总是被视为可滚动）
  • word-spacing
  • letter-spacing
  • text-indent
  • text-transform
  • line-height
  • border-top-width（用来指示是否应使用某个边框）
  • border-right-width
  • border-bottom-width
  • border-left-width
  • border-width
  • border-top
  • border-right
  • border-bottom
  • border-left
  • border
  • width
  • height
  • float
  • clear
  • display
  • white-space
  • list-style

注：目前我们尚未完全支持相对单元（除非另行说明），因此 p { margin-top:10% } 将被视为没有指定 margin-top（顶部空白）。

另请参见：
StyleSheet

嵌套类摘要
static class CSS.Attribute
用作 AttributeSet 的键的定义，此属性集可存储 CSS 属性。
构造方法摘要
CSS()
方法摘要
static CSS.Attribute[] | getAllAttributeKeys() 返回所有可能的 CSS 属性键集合。
static CSS.Attribute | getAttribute(String name) 将字符串转换为 CSS.Attribute 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CSS

public CSS()
方法详细信息

getAllAttributeKeys

public static CSS.Attribute[] getAllAttributeKeys()
返回所有可能的 CSS 属性键集合。

getAttribute

public static final CSS.Attribute getAttribute(String name)
将字符串转换为 CSS.Attribute 对象。如果给定名称没有属性，这将返回 null。

参数：
name - 要获取类型安全枚举的 CSS 属性名称
返回：
返回 CSS.Attribute 对象，如果字符串不表示有效的属性键，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CSS.Attribute (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 CSS.Attribute

java.lang.Object
    继承者  javax.swing.text.html.CSS.Attribute
正在封闭类：
CSS
public static final class CSS.Attribute
extends Object

用作 AttributeSet 的键的定义，此属性集可存储 CSS 属性。因为这是一个封闭集合（即由规范精确定义），因此它是最终集合并且不能扩充。

字段摘要
static CSS.Attribute | BACKGROUND
static CSS.Attribute | BACKGROUND_ATTACHMENT
static CSS.Attribute | BACKGROUND_COLOR
static CSS.Attribute | BACKGROUND_IMAGE
static CSS.Attribute | BACKGROUND_POSITION
static CSS.Attribute | BACKGROUND_REPEAT
static CSS.Attribute | BORDER
static CSS.Attribute | BORDER_BOTTOM
static CSS.Attribute | BORDER_BOTTOM_WIDTH
static CSS.Attribute | BORDER_COLOR
static CSS.Attribute | BORDER_LEFT
static CSS.Attribute | BORDER_LEFT_WIDTH
static CSS.Attribute | BORDER_RIGHT
static CSS.Attribute | BORDER_RIGHT_WIDTH
static CSS.Attribute | BORDER_STYLE
static CSS.Attribute | BORDER_TOP
static CSS.Attribute | BORDER_TOP_WIDTH
static CSS.Attribute | BORDER_WIDTH
static CSS.Attribute | CLEAR
static CSS.Attribute | COLOR
static CSS.Attribute | DISPLAY
static CSS.Attribute | FLOAT
static CSS.Attribute | FONT
static CSS.Attribute | FONT_FAMILY
static CSS.Attribute | FONT_SIZE
static CSS.Attribute | FONT_STYLE
static CSS.Attribute | FONT_VARIANT
static CSS.Attribute | FONT_WEIGHT
static CSS.Attribute | HEIGHT
static CSS.Attribute | LETTER_SPACING
static CSS.Attribute | LINE_HEIGHT
static CSS.Attribute | LIST_STYLE
static CSS.Attribute | LIST_STYLE_IMAGE
static CSS.Attribute | LIST_STYLE_POSITION
static CSS.Attribute | LIST_STYLE_TYPE
static CSS.Attribute | MARGIN
static CSS.Attribute | MARGIN_BOTTOM
static CSS.Attribute | MARGIN_LEFT
static CSS.Attribute | MARGIN_RIGHT
static CSS.Attribute | MARGIN_TOP
static CSS.Attribute | PADDING
static CSS.Attribute | PADDING_BOTTOM
static CSS.Attribute | PADDING_LEFT
static CSS.Attribute | PADDING_RIGHT
static CSS.Attribute | PADDING_TOP
static CSS.Attribute | TEXT_ALIGN
static CSS.Attribute | TEXT_DECORATION
static CSS.Attribute | TEXT_INDENT
static CSS.Attribute | TEXT_TRANSFORM
static CSS.Attribute | VERTICAL_ALIGN
static CSS.Attribute | WHITE_SPACE
static CSS.Attribute | WIDTH
static CSS.Attribute | WORD_SPACING
方法摘要
String | getDefaultValue() 获取属性的默认值。
boolean | isInherited() 指示是否应该从父级继承属性。
String | toString() 属性的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

BACKGROUND

public static final CSS.Attribute BACKGROUND

BACKGROUND_ATTACHMENT

public static final CSS.Attribute BACKGROUND_ATTACHMENT

BACKGROUND_COLOR

public static final CSS.Attribute BACKGROUND_COLOR

BACKGROUND_IMAGE

public static final CSS.Attribute BACKGROUND_IMAGE

BACKGROUND_POSITION

public static final CSS.Attribute BACKGROUND_POSITION

BACKGROUND_REPEAT

public static final CSS.Attribute BACKGROUND_REPEAT

BORDER

public static final CSS.Attribute BORDER

BORDER_BOTTOM

public static final CSS.Attribute BORDER_BOTTOM

BORDER_BOTTOM_WIDTH

public static final CSS.Attribute BORDER_BOTTOM_WIDTH

BORDER_COLOR

public static final CSS.Attribute BORDER_COLOR

BORDER_LEFT

public static final CSS.Attribute BORDER_LEFT

BORDER_LEFT_WIDTH

public static final CSS.Attribute BORDER_LEFT_WIDTH

BORDER_RIGHT

public static final CSS.Attribute BORDER_RIGHT

BORDER_RIGHT_WIDTH

public static final CSS.Attribute BORDER_RIGHT_WIDTH

BORDER_STYLE

public static final CSS.Attribute BORDER_STYLE

BORDER_TOP

public static final CSS.Attribute BORDER_TOP

BORDER_TOP_WIDTH

public static final CSS.Attribute BORDER_TOP_WIDTH

BORDER_WIDTH

public static final CSS.Attribute BORDER_WIDTH

CLEAR

public static final CSS.Attribute CLEAR

COLOR

public static final CSS.Attribute COLOR

DISPLAY

public static final CSS.Attribute DISPLAY

FLOAT

public static final CSS.Attribute FLOAT

FONT

public static final CSS.Attribute FONT

FONT_FAMILY

public static final CSS.Attribute FONT_FAMILY

FONT_SIZE

public static final CSS.Attribute FONT_SIZE

FONT_STYLE

public static final CSS.Attribute FONT_STYLE

FONT_VARIANT

public static final CSS.Attribute FONT_VARIANT

FONT_WEIGHT

public static final CSS.Attribute FONT_WEIGHT

HEIGHT

public static final CSS.Attribute HEIGHT

LETTER_SPACING

public static final CSS.Attribute LETTER_SPACING

LINE_HEIGHT

public static final CSS.Attribute LINE_HEIGHT

LIST_STYLE

public static final CSS.Attribute LIST_STYLE

LIST_STYLE_IMAGE

public static final CSS.Attribute LIST_STYLE_IMAGE

LIST_STYLE_POSITION

public static final CSS.Attribute LIST_STYLE_POSITION

LIST_STYLE_TYPE

public static final CSS.Attribute LIST_STYLE_TYPE

MARGIN

public static final CSS.Attribute MARGIN

MARGIN_BOTTOM

public static final CSS.Attribute MARGIN_BOTTOM

MARGIN_LEFT

public static final CSS.Attribute MARGIN_LEFT

MARGIN_RIGHT

public static final CSS.Attribute MARGIN_RIGHT

MARGIN_TOP

public static final CSS.Attribute MARGIN_TOP

PADDING

public static final CSS.Attribute PADDING

PADDING_BOTTOM

public static final CSS.Attribute PADDING_BOTTOM

PADDING_LEFT

public static final CSS.Attribute PADDING_LEFT

PADDING_RIGHT

public static final CSS.Attribute PADDING_RIGHT

PADDING_TOP

public static final CSS.Attribute PADDING_TOP

TEXT_ALIGN

public static final CSS.Attribute TEXT_ALIGN

TEXT_DECORATION

public static final CSS.Attribute TEXT_DECORATION

TEXT_INDENT

public static final CSS.Attribute TEXT_INDENT

TEXT_TRANSFORM

public static final CSS.Attribute TEXT_TRANSFORM

VERTICAL_ALIGN

public static final CSS.Attribute VERTICAL_ALIGN

WORD_SPACING

public static final CSS.Attribute WORD_SPACING

WHITE_SPACE

public static final CSS.Attribute WHITE_SPACE

WIDTH

public static final CSS.Attribute WIDTH
方法详细信息

toString

public String toString()
属性的字符串表示形式。这应该精确匹配 CSS 规范中指定的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

getDefaultValue

public String getDefaultValue()
获取属性的默认值。如果没有默认值（如对于复合属性），则将返回 null。

isInherited

public boolean isInherited()
指示是否应该从父级继承属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FormSubmitEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 FormSubmitEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.HyperlinkEvent
            继承者  javax.swing.text.html.HTMLFrameHyperlinkEvent
                继承者  javax.swing.text.html.FormSubmitEvent
所有已实现的接口：
Serializable
public class FormSubmitEvent
extends HTMLFrameHyperlinkEvent

FormSubmitEvent 用于通知提交表单所需的参与者。

从以下版本开始：
1.5

嵌套类摘要
static class FormSubmitEvent.MethodType
表示 HTML 表单方法类型。
从类 javax.swing.event.HyperlinkEvent 继承的嵌套类/接口
HyperlinkEvent.EventType
字段摘要
从类 java.util.EventObject 继承的字段
source
方法摘要
String | getData() 获取表单提交数据。
FormSubmitEvent.MethodType | getMethod() 获取表单方法类型。
从类 javax.swing.text.html.HTMLFrameHyperlinkEvent 继承的方法
getTarget
从类 javax.swing.event.HyperlinkEvent 继承的方法
getDescription, getEventType, getSourceElement, getURL
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getMethod

public FormSubmitEvent.MethodType getMethod()
获取表单方法类型。

返回：
表单方法类型，要么是 Method.GET，要么是 Method.POST。

getData

public String getData()
获取表单提交数据。

返回：
表示表单提交数据的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FormSubmitEvent.MethodType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing.text.html
枚举 FormSubmitEvent.MethodType

java.lang.Object
    继承者  java.lang.Enum<FormSubmitEvent.MethodType>
        继承者  javax.swing.text.html.FormSubmitEvent.MethodType
所有已实现的接口：
Serializable, Comparable<FormSubmitEvent.MethodType>
正在封闭类：
FormSubmitEvent
public static enum FormSubmitEvent.MethodType
extends Enum<FormSubmitEvent.MethodType>

表示 HTML 表单方法类型。

  • GET 对应于 GET 表单方法
  • POST 对应于 POST 表单方法

从以下版本开始：
1.5

枚举常量摘要
GET
POST
方法摘要
static FormSubmitEvent.MethodType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static FormSubmitEvent.MethodType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

GET

public static final FormSubmitEvent.MethodType GET

POST

public static final FormSubmitEvent.MethodType POST
方法详细信息

values

public static final FormSubmitEvent.MethodType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(FormSubmitEvent.MethodType c : FormSubmitEvent.MethodType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static FormSubmitEvent.MethodType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


FormView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 FormView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.ComponentView
            继承者  javax.swing.text.html.FormView
所有已实现的接口：
ActionListener, EventListener, SwingConstants
public class FormView
extends ComponentView
implements ActionListener

实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。组件模型存储为元素的属性（使用 StyleConstants.ModelAttribute），并用来构建视图的组件。模型类型假定为由 HTMLDocument.HTMLReader.FormAction 设置的类型。如果多个视图映射到文档，则它们将共享嵌入的组件模型。

下表显示了此视图创建了哪些组件。

元素类型 | 构建的组件
输入，类型为 button | JButton
输入，类型为 checkbox | JCheckBox
输入，类型为 image | JButton
输入，类型为 password | JPasswordField
输入，类型为 radio | JRadioButton
输入，类型为 reset | JButton
输入，类型为 submit | JButton
输入，类型为 text | JTextField
选择，size > 1 或定义的多个属性 | JScrollPane 中的 JList
选择，大小未指定或为 1 | JComboBox
textarea | JScrollPane 中的 JTextArea
输入，类型为 file | JTextField

嵌套类摘要
protected  class FormView.MouseEventListener
当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
字段摘要
static String | RESET 已过时。 从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值
static String | SUBMIT 已过时。 从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
FormView(Element elem)
创建新的 FormView 对象。
方法摘要
void | actionPerformed(ActionEvent evt) 负责处理 ActionEvent。
protected Component | createComponent() 创建组件。
float | getMaximumSpan(int axis) 确定此视图沿某轴的最大区域。
protected void | imageSubmit(String imageData) 调用此方法来提交表单，以响应在图像上的单击，此图像是类型为 "image" 的 <INPUT> 表单元素。
protected void | submitData(String data) 此方法负责提交表单数据。
从类 javax.swing.text.ComponentView 继承的方法
getAlignment, getComponent, getMinimumSpan, getPreferredSpan, modelToView, paint, setParent, viewToModel
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setSize, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SUBMIT

@Deprecated
public static final String SUBMIT
已过时。 从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值
如果没有为类型为 "submit" 的 FORM 输入元素指定值属性，则使用此默认字符串。

RESET

@Deprecated
public static final String RESET
已过时。 从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值
如果没有为类型为 "reset" 的 FORM 输入元素指定值属性，则使用此默认字符串。

构造方法详细信息

FormView

public FormView(Element elem)
创建新的 FormView 对象。

参数：
elem - 要修饰的元素
方法详细信息

createComponent

protected Component createComponent()
创建组件。这基本上是基于标记类型和相关元素的 html 属性的一个大的 switch 语句。

覆盖：
类 ComponentView 中的 createComponent

getMaximumSpan

public float getMaximumSpan(int axis)
确定此视图沿某轴的最大区域。对于特定的组件，最大区域和首选区域是相同的。对于其他组件，这将返回 Component.getMaximumSize 沿所需轴所返回的值。

覆盖：
类 ComponentView 中的 getMaximumSpan
参数：
axis - 可以是 View.X_AXIS 或 View.Y_AXIS
返回：
视图可能要在其中呈现的区域，该值 >= 0。通常会告知该视图在返回的区域中呈现，但不保证一定如此。父级可选择重新调整视图大小或拆分视图。
抛出：
IllegalArgumentException - 如果轴无效
另请参见：
View.getPreferredSpan(int)

actionPerformed

public void actionPerformed(ActionEvent evt)
负责处理 ActionEvent。如果与 FormView 关联的元素具有类型 "submit"、"reset"、"text" 或 "password"，则处理此操作。在类型为 "submit" 的情况下，将提交表单。在类型为 "reset" 的情况下，表单将被重置为其初始状态。在类型为 "text" 或 "password" 的情况下，如果元素是类型 "text" 或 "password" 的最后一个元素，则提交表单。否则，焦点将被传输到表单中的下一个组件。

指定者：
接口 ActionListener 中的 actionPerformed
参数：
evt - the ActionEvent

submitData

protected void submitData(String data)
此方法负责提交表单数据。将分出一个线程来执行提交操作。

imageSubmit

protected void imageSubmit(String imageData)
调用此方法来提交表单，以响应在图像上的单击，此图像是类型为 "image" 的 <INPUT> 表单元素。

参数：
imageData - 鼠标单击坐标。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FormView.MouseEventListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 FormView.MouseEventListener

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.text.html.FormView.MouseEventListener
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
FormView
protected class FormView.MouseEventListener
extends MouseAdapter

当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。MouseListener 是必要的，因为与鼠标单击关联的坐标需要连同图像数据一起提交。

构造方法摘要
protected FormView.MouseEventListener()
方法摘要
 void mouseReleased(MouseEvent evt)
鼠标按钮在组件上释放时调用。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mousePressed, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FormView.MouseEventListener

protected FormView.MouseEventListener()
方法详细信息

mouseReleased

public void mouseReleased(MouseEvent evt)
从类 MouseAdapter 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTML (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTML

java.lang.Object
    继承者  javax.swing.text.html.HTML

public class HTML
extends Object

HTMLDocument 中使用的常量。这些常量基本上是标记和属性定义。

嵌套类摘要
static class | HTML.Attribute 表示 HTML 属性的类型安全的枚举。
static class | HTML.Tag HTML 标记的类型安全的枚举。
static class | HTML.UnknownTag
字段摘要
static String NULL_ATTRIBUTE_VALUE
构造方法摘要
HTML()
方法摘要
static HTML.Attribute[] | getAllAttributeKeys() 返回所识别的 HTML 属性集。
static HTML.Tag[] | getAllTags() 返回默认 HTML reader 所识别的实际 HTML 标记集。
static HTML.Attribute | getAttributeKey(String attName) 获取已知属性名称的属性常量（即集合 {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG} 中的某个属性）。
static int | getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def) 获取整数属性值。
static HTML.Tag | getTag(String tagName) 获取已知标记名称的标记常量（即集合 {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR} 中的某个标记）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NULL_ATTRIBUTE_VALUE

public static final String NULL_ATTRIBUTE_VALUE
另请参见：
常量字段值
构造方法详细信息

HTML

public HTML()
方法详细信息

getAllTags

public static HTML.Tag[] getAllTags()
返回默认 HTML reader 所识别的实际 HTML 标记集。此集合不包括 reader 所构造的标记。

getTag

public static HTML.Tag getTag(String tagName)
获取已知标记名称的标记常量（即集合 {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR} 中的某个标记）。如果给定名称不表示某个已知标记，则返回 null。

参数：
tagName - 所请求的 String 名称
返回：
对应于 tagName 的标记常量，如果未找到，则返回 null

getIntegerAttributeValue

public static int getIntegerAttributeValue(AttributeSet attr,
                                           HTML.Attribute key,
                                           int def)
获取整数属性值。属性值存储为字符串，且这是将其转换为实际整数的一种便捷方法。

参数：
attr - 用于试图获取值的属性集
key - 用于获取值的键
def - 如果未定义属性或转换为整数时发生错误，则要使用的默认值

getAllAttributeKeys

public static HTML.Attribute[] getAllAttributeKeys()
返回所识别的 HTML 属性集。

返回：
所识别的 HTML 属性集

getAttributeKey

public static HTML.Attribute getAttributeKey(String attName)
获取已知属性名称的属性常量（即集合 {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG} 中的某个属性）。如果给定名称不表示某个已知属性，则返回 null。

参数：
attName - 所请求的 String
返回：
对应于 attName 的 Attribute
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTML.Attribute (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTML.Attribute

java.lang.Object
    继承者  javax.swing.text.html.HTML.Attribute
正在封闭类：
HTML
public static final class HTML.Attribute
extends Object

表示 HTML 属性的类型安全的枚举。

字段摘要
static HTML.Attribute | ACTION
static HTML.Attribute | ALIGN
static HTML.Attribute | ALINK
static HTML.Attribute | ALT
static HTML.Attribute | ARCHIVE
static HTML.Attribute | BACKGROUND
static HTML.Attribute | BGCOLOR
static HTML.Attribute | BORDER
static HTML.Attribute | CELLPADDING
static HTML.Attribute | CELLSPACING
static HTML.Attribute | CHECKED
static HTML.Attribute | CLASS
static HTML.Attribute | CLASSID
static HTML.Attribute | CLEAR
static HTML.Attribute | CODE
static HTML.Attribute | CODEBASE
static HTML.Attribute | CODETYPE
static HTML.Attribute | COLOR
static HTML.Attribute | COLS
static HTML.Attribute | COLSPAN
static HTML.Attribute | COMMENT
static HTML.Attribute | COMPACT
static HTML.Attribute | CONTENT
static HTML.Attribute | COORDS
static HTML.Attribute | DATA
static HTML.Attribute | DECLARE
static HTML.Attribute | DIR
static HTML.Attribute | DUMMY
static HTML.Attribute | ENCTYPE
static HTML.Attribute | ENDTAG
static HTML.Attribute | FACE
static HTML.Attribute | FRAMEBORDER
static HTML.Attribute | HALIGN
static HTML.Attribute | HEIGHT
static HTML.Attribute | HREF
static HTML.Attribute | HSPACE
static HTML.Attribute | HTTPEQUIV
static HTML.Attribute | ID
static HTML.Attribute | ISMAP
static HTML.Attribute | LANG
static HTML.Attribute | LANGUAGE
static HTML.Attribute | LINK
static HTML.Attribute | LOWSRC
static HTML.Attribute | MARGINHEIGHT
static HTML.Attribute | MARGINWIDTH
static HTML.Attribute | MAXLENGTH
static HTML.Attribute | METHOD
static HTML.Attribute | MULTIPLE
static HTML.Attribute | N
static HTML.Attribute | NAME
static HTML.Attribute | NOHREF
static HTML.Attribute | NORESIZE
static HTML.Attribute | NOSHADE
static HTML.Attribute | NOWRAP
static HTML.Attribute | PROMPT
static HTML.Attribute | REL
static HTML.Attribute | REV
static HTML.Attribute | ROWS
static HTML.Attribute | ROWSPAN
static HTML.Attribute | SCROLLING
static HTML.Attribute | SELECTED
static HTML.Attribute | SHAPE
static HTML.Attribute | SHAPES
static HTML.Attribute | SIZE
static HTML.Attribute | SRC
static HTML.Attribute | STANDBY
static HTML.Attribute | START
static HTML.Attribute | STYLE
static HTML.Attribute | TARGET
static HTML.Attribute | TEXT
static HTML.Attribute | TITLE
static HTML.Attribute | TYPE
static HTML.Attribute | USEMAP
static HTML.Attribute | VALIGN
static HTML.Attribute | VALUE
static HTML.Attribute | VALUETYPE
static HTML.Attribute | VERSION
static HTML.Attribute | VLINK
static HTML.Attribute | VSPACE
static HTML.Attribute | WIDTH
方法摘要
 String toString()
返回此属性的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SIZE

public static final HTML.Attribute SIZE

COLOR

public static final HTML.Attribute COLOR

CLEAR

public static final HTML.Attribute CLEAR

BACKGROUND

public static final HTML.Attribute BACKGROUND

BGCOLOR

public static final HTML.Attribute BGCOLOR

TEXT

public static final HTML.Attribute TEXT

LINK

public static final HTML.Attribute LINK

VLINK

public static final HTML.Attribute VLINK

ALINK

public static final HTML.Attribute ALINK

WIDTH

public static final HTML.Attribute WIDTH

HEIGHT

public static final HTML.Attribute HEIGHT

ALIGN

public static final HTML.Attribute ALIGN

NAME

public static final HTML.Attribute NAME

HREF

public static final HTML.Attribute HREF

REL

public static final HTML.Attribute REL

REV

public static final HTML.Attribute REV

TITLE

public static final HTML.Attribute TITLE

TARGET

public static final HTML.Attribute TARGET

SHAPE

public static final HTML.Attribute SHAPE

COORDS

public static final HTML.Attribute COORDS

ISMAP

public static final HTML.Attribute ISMAP

NOHREF

public static final HTML.Attribute NOHREF

ALT

public static final HTML.Attribute ALT

ID

public static final HTML.Attribute ID

SRC

public static final HTML.Attribute SRC

HSPACE

public static final HTML.Attribute HSPACE

VSPACE

public static final HTML.Attribute VSPACE

USEMAP

public static final HTML.Attribute USEMAP

LOWSRC

public static final HTML.Attribute LOWSRC

CODEBASE

public static final HTML.Attribute CODEBASE

CODE

public static final HTML.Attribute CODE

ARCHIVE

public static final HTML.Attribute ARCHIVE

VALUE

public static final HTML.Attribute VALUE

VALUETYPE

public static final HTML.Attribute VALUETYPE

TYPE

public static final HTML.Attribute TYPE

CLASS

public static final HTML.Attribute CLASS

STYLE

public static final HTML.Attribute STYLE

LANG

public static final HTML.Attribute LANG

FACE

public static final HTML.Attribute FACE

DIR

public static final HTML.Attribute DIR

DECLARE

public static final HTML.Attribute DECLARE

CLASSID

public static final HTML.Attribute CLASSID

DATA

public static final HTML.Attribute DATA

CODETYPE

public static final HTML.Attribute CODETYPE

STANDBY

public static final HTML.Attribute STANDBY

BORDER

public static final HTML.Attribute BORDER

SHAPES

public static final HTML.Attribute SHAPES

NOSHADE

public static final HTML.Attribute NOSHADE

COMPACT

public static final HTML.Attribute COMPACT

START

public static final HTML.Attribute START

ACTION

public static final HTML.Attribute ACTION

METHOD

public static final HTML.Attribute METHOD

ENCTYPE

public static final HTML.Attribute ENCTYPE

CHECKED

public static final HTML.Attribute CHECKED

MAXLENGTH

public static final HTML.Attribute MAXLENGTH

MULTIPLE

public static final HTML.Attribute MULTIPLE

SELECTED

public static final HTML.Attribute SELECTED

ROWS

public static final HTML.Attribute ROWS

COLS

public static final HTML.Attribute COLS

DUMMY

public static final HTML.Attribute DUMMY

CELLSPACING

public static final HTML.Attribute CELLSPACING

CELLPADDING

public static final HTML.Attribute CELLPADDING

VALIGN

public static final HTML.Attribute VALIGN

HALIGN

public static final HTML.Attribute HALIGN

NOWRAP

public static final HTML.Attribute NOWRAP

ROWSPAN

public static final HTML.Attribute ROWSPAN

COLSPAN

public static final HTML.Attribute COLSPAN

PROMPT

public static final HTML.Attribute PROMPT

HTTPEQUIV

public static final HTML.Attribute HTTPEQUIV

CONTENT

public static final HTML.Attribute CONTENT

LANGUAGE

public static final HTML.Attribute LANGUAGE

VERSION

public static final HTML.Attribute VERSION

N

public static final HTML.Attribute N

FRAMEBORDER

public static final HTML.Attribute FRAMEBORDER

MARGINWIDTH

public static final HTML.Attribute MARGINWIDTH

MARGINHEIGHT

public static final HTML.Attribute MARGINHEIGHT

SCROLLING

public static final HTML.Attribute SCROLLING

NORESIZE

public static final HTML.Attribute NORESIZE

ENDTAG

public static final HTML.Attribute ENDTAG

COMMENT

public static final HTML.Attribute COMMENT
方法详细信息

toString

public String toString()
返回此属性的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此属性的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTML.Tag (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTML.Tag

java.lang.Object
    继承者  javax.swing.text.html.HTML.Tag
直接已知子类：
HTML.UnknownTag
正在封闭类：
HTML
public static class HTML.Tag
extends Object

HTML 标记的类型安全的枚举。虽然 HTML 标记集合是一个封闭集合，但我们将此集合置于开放状态，以便用户可将自己的标记类型添加到其自定义解析器中，并且仍保持与 reader 的通信。

字段摘要
static HTML.Tag | A
static HTML.Tag | ADDRESS
static HTML.Tag | APPLET
static HTML.Tag | AREA
static HTML.Tag | B
static HTML.Tag | BASE
static HTML.Tag | BASEFONT
static HTML.Tag | BIG
static HTML.Tag | BLOCKQUOTE
static HTML.Tag | BODY
static HTML.Tag | BR
static HTML.Tag | CAPTION
static HTML.Tag | CENTER
static HTML.Tag | CITE
static HTML.Tag | CODE
static HTML.Tag | COMMENT 所有注释以此标记作为标签。
static HTML.Tag | CONTENT 所有文本内容以此标记作为标签。
static HTML.Tag | DD
static HTML.Tag | DFN
static HTML.Tag | DIR
static HTML.Tag | DIV
static HTML.Tag | DL
static HTML.Tag | DT
static HTML.Tag | EM
static HTML.Tag | FONT
static HTML.Tag | FORM
static HTML.Tag | FRAME
static HTML.Tag | FRAMESET
static HTML.Tag | H1
static HTML.Tag | H2
static HTML.Tag | H3
static HTML.Tag | H4
static HTML.Tag | H5
static HTML.Tag | H6
static HTML.Tag | HEAD
static HTML.Tag | HR
static HTML.Tag | HTML
static HTML.Tag | I
static HTML.Tag | IMG
static HTML.Tag | IMPLIED 所有文本内容必须包含在段落元素中。
static HTML.Tag | INPUT
static HTML.Tag | ISINDEX
static HTML.Tag | KBD
static HTML.Tag | LI
static HTML.Tag | LINK
static HTML.Tag | MAP
static HTML.Tag | MENU
static HTML.Tag | META
static HTML.Tag | NOFRAMES
static HTML.Tag | OBJECT
static HTML.Tag | OL
static HTML.Tag | OPTION
static HTML.Tag | P
static HTML.Tag | PARAM
static HTML.Tag | PRE
static HTML.Tag | S
static HTML.Tag | SAMP
static HTML.Tag | SCRIPT
static HTML.Tag | SELECT
static HTML.Tag | SMALL
static HTML.Tag | SPAN
static HTML.Tag | STRIKE
static HTML.Tag | STRONG
static HTML.Tag | STYLE
static HTML.Tag | SUB
static HTML.Tag | SUP
static HTML.Tag | TABLE
static HTML.Tag | TD
static HTML.Tag | TEXTAREA
static HTML.Tag | TH
static HTML.Tag | TITLE
static HTML.Tag | TR
static HTML.Tag | TT
static HTML.Tag | U
static HTML.Tag | UL
static HTML.Tag | VAR
构造方法摘要
 | HTML.Tag()
protected | HTML.Tag(String id) 创建具有指定 id 的新 Tag，且 causesBreak 和 isBlock 设置为 false。
protected | HTML.Tag(String id, boolean causesBreak, boolean isBlock) 创建具有指定 id 的新 Tag；causesBreak 和 isBlock 由用户定义。
方法摘要
boolean | breaksFlow() 如果此标记导致数据流换行，则返回 true；否则返回 false。
boolean | isBlock() 如果此标记是块标记（块标记是用于向文档添加结构的标记），则返回 true。
boolean | isPreformatted() 如果此标记是预格式化的，则返回 true，即如果此标记是 PRE 或 TEXTAREA，则为 true。
String | toString() 返回该标记的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

A

public static final HTML.Tag A

ADDRESS

public static final HTML.Tag ADDRESS

APPLET

public static final HTML.Tag APPLET

AREA

public static final HTML.Tag AREA

B

public static final HTML.Tag B

BASE

public static final HTML.Tag BASE

BASEFONT

public static final HTML.Tag BASEFONT

BIG

public static final HTML.Tag BIG

BLOCKQUOTE

public static final HTML.Tag BLOCKQUOTE

BODY

public static final HTML.Tag BODY

BR

public static final HTML.Tag BR

CAPTION

public static final HTML.Tag CAPTION

CENTER

public static final HTML.Tag CENTER

CITE

public static final HTML.Tag CITE

CODE

public static final HTML.Tag CODE

DD

public static final HTML.Tag DD

DFN

public static final HTML.Tag DFN

DIR

public static final HTML.Tag DIR

DIV

public static final HTML.Tag DIV

DL

public static final HTML.Tag DL

DT

public static final HTML.Tag DT

EM

public static final HTML.Tag EM

FONT

public static final HTML.Tag FONT

FORM

public static final HTML.Tag FORM

FRAME

public static final HTML.Tag FRAME

FRAMESET

public static final HTML.Tag FRAMESET

H1

public static final HTML.Tag H1

H2

public static final HTML.Tag H2

H3

public static final HTML.Tag H3

H4

public static final HTML.Tag H4

H5

public static final HTML.Tag H5

H6

public static final HTML.Tag H6

HEAD

public static final HTML.Tag HEAD

HR

public static final HTML.Tag HR

HTML

public static final HTML.Tag HTML

I

public static final HTML.Tag I

IMG

public static final HTML.Tag IMG

INPUT

public static final HTML.Tag INPUT

ISINDEX

public static final HTML.Tag ISINDEX

KBD

public static final HTML.Tag KBD

LI

public static final HTML.Tag LI

LINK

public static final HTML.Tag LINK

MAP

public static final HTML.Tag MAP

MENU

public static final HTML.Tag MENU

META

public static final HTML.Tag META

NOFRAMES

public static final HTML.Tag NOFRAMES

OBJECT

public static final HTML.Tag OBJECT

OL

public static final HTML.Tag OL

OPTION

public static final HTML.Tag OPTION

P

public static final HTML.Tag P

PARAM

public static final HTML.Tag PARAM

PRE

public static final HTML.Tag PRE

SAMP

public static final HTML.Tag SAMP

SCRIPT

public static final HTML.Tag SCRIPT

SELECT

public static final HTML.Tag SELECT

SMALL

public static final HTML.Tag SMALL

SPAN

public static final HTML.Tag SPAN

STRIKE

public static final HTML.Tag STRIKE

S

public static final HTML.Tag S

STRONG

public static final HTML.Tag STRONG

STYLE

public static final HTML.Tag STYLE

SUB

public static final HTML.Tag SUB

SUP

public static final HTML.Tag SUP

TABLE

public static final HTML.Tag TABLE

TD

public static final HTML.Tag TD

TEXTAREA

public static final HTML.Tag TEXTAREA

TH

public static final HTML.Tag TH

TITLE

public static final HTML.Tag TITLE

TR

public static final HTML.Tag TR

TT

public static final HTML.Tag TT

U

public static final HTML.Tag U

UL

public static final HTML.Tag UL

VAR

public static final HTML.Tag VAR

IMPLIED

public static final HTML.Tag IMPLIED
所有文本内容必须包含在段落元素中。如果遇到内容时段落不存在，则构造一个段落。

这是由 HTML reader 合成的标记。由于通过元素的标记类型来标识各个元素，所以我们创建某个伪标记类型来标记所构造的元素。

CONTENT

public static final HTML.Tag CONTENT
所有文本内容以此标记作为标签。

这是由 HTML reader 合成的标记。由于通过元素的标记类型来标识各个元素，所以我们创建某个伪标记类型来标记所构造的元素。

COMMENT

public static final HTML.Tag COMMENT
所有注释以此标记作为标签。

这是由 HTML reader 合成的标记。由于通过元素的标记类型来标识各个元素，所以我们创建某个伪标记类型来标记所构造的元素。

构造方法详细信息

HTML.Tag

public HTML.Tag()
从以下版本开始：
1.3

HTML.Tag

protected HTML.Tag(String id)
创建具有指定 id 的新 Tag，且 causesBreak 和 isBlock 设置为 false。

参数：
id - 新标记的 id

HTML.Tag

protected HTML.Tag(String id,
                   boolean causesBreak,
                   boolean isBlock)
创建具有指定 id 的新 Tag；causesBreak 和 isBlock 由用户定义。

参数：
id - 新标记的 id
causesBreak - 如果此标记导致数据流拆分，则为 true
isBlock - 如果标记用于向文档添加结构，则为 true
方法详细信息

isBlock

public boolean isBlock()
如果此标记是块标记（块标记是用于向文档添加结构的标记），则返回 true。

返回：
如果此标记是块标记，则返回 true；否则返回 false

breaksFlow

public boolean breaksFlow()
如果此标记导致数据流换行，则返回 true；否则返回 false。

返回：
如果此标记导致数据流换行，则返回 true；否则返回 false

isPreformatted

public boolean isPreformatted()
如果此标记是预格式化的，则返回 true，即如果此标记是 PRE 或 TEXTAREA，则为 true。

返回：
如果此标记是预格式化的，则返回 true；否则返回 false

toString

public String toString()
返回该标记的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该标记的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTML.UnknownTag (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTML.UnknownTag

java.lang.Object
    继承者  javax.swing.text.html.HTML.Tag
        继承者  javax.swing.text.html.HTML.UnknownTag
所有已实现的接口：
Serializable
正在封闭类：
HTML
public static class HTML.UnknownTag
extends HTML.Tag
implements Serializable

字段摘要
从类 javax.swing.text.html.HTML.Tag 继承的字段
A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, COMMENT, CONTENT, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, IMPLIED, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, S, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR
构造方法摘要
HTML.UnknownTag(String id)
创建具有指定 id 的新 UnknownTag。
方法摘要
boolean | equals(Object obj) 将此对象与指定对象进行比较。
int | hashCode() 返回对应于此标记的字符串的哈希代码。
从类 javax.swing.text.html.HTML.Tag 继承的方法
breaksFlow, isBlock, isPreformatted, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

HTML.UnknownTag

public HTML.UnknownTag(String id)
创建具有指定 id 的新 UnknownTag。

参数：
id - 新标记的 id
方法详细信息

hashCode

public int hashCode()
返回对应于此标记的字符串的哈希代码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象进行比较。当且仅当参数不为 null，并且是一个具有相同名称的 UnknownTag 对象时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此标记进行比较的对象
返回：
如果对象是相同的，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument

java.lang.Object
    继承者  javax.swing.text.AbstractDocument
        继承者  javax.swing.text.DefaultStyledDocument
            继承者  javax.swing.text.html.HTMLDocument
所有已实现的接口：
Serializable, Document, StyledDocument
public class HTMLDocument
extends DefaultStyledDocument

对 HTML 进行建模的文档。此模型的目的是支持浏览和编辑。因此，默认情况下 HTML 文档所描述的结构不是精确一致的。默认情况下被建模的元素结构是通过 HTMLDocument.HTMLReader 类构建的，此类实现了解析器所期望的 HTMLEditorKit.ParserCallback 协议。要更改结构，可以创建 HTMLReader 的子类，并且重新实现 getReader(int) 方法以返回新的 reader 实现。有关创建默认结构的细节，请参考 HTMLReader 文档。其目的是使文档无丢失（non-lossy）（虽然重新生成 HTML 格式可能导致出现不同的格式）。

文档只对 HTML 建模，并且不尝试在其中存储视图属性。元素由 StyleContext.NameAttribute 属性标识，此属性应该始终有一个标识元素种类的 HTML.Tag 类型值。某些元素（例如注释）是合成的。HTMLFactory 使用此属性来确定要构建哪种视图。

此文档支持增量加载。TokenThreshold 属性控制在试图更新文档的元素结构之前要缓冲的解析数量。通过 EditorKit 来设置此属性，以便子类可以禁用它。

Base 属性根据解析哪些相对 URL 来确定 URL。默认情况下，如果属性值是 URL，则这将是 Document.StreamDescriptionProperty。如果遇到 <BASE> 标记，则基本 URL 将成为该标记所指定的 URL。因为基本 URL 是一个属性，因此毫无疑问可以直接设置它。

此文档的默认内容存储机制是一个间隙缓冲区 (GapContent)。通过使用带有 Content 实现的构造方法，可以提供某些替代方法。

警告： 此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已经在 java.beans 包添加了对所有 JavaBeansTM 长期存储的支持。请参阅 XMLEncoder。

嵌套类摘要
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.HTMLReader 一个 HTML reader，用来加载具有 HTML 元素结构的 HTML 文档。
static class | HTMLDocument.Iterator 对特定类型的标记进行迭代的迭代器。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。
从类 javax.swing.text.DefaultStyledDocument 继承的嵌套类/接口
DefaultStyledDocument.AttributeUndoableEdit, DefaultStyledDocument.ElementBuffer, DefaultStyledDocument.ElementSpec, DefaultStyledDocument.SectionElement
从类 javax.swing.text.AbstractDocument 继承的嵌套类/接口
AbstractDocument.AbstractElement, AbstractDocument.AttributeContext, AbstractDocument.BranchElement, AbstractDocument.Content, AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractDocument.LeafElement
字段摘要
static String AdditionalComments
文档属性键值。
从类 javax.swing.text.DefaultStyledDocument 继承的字段
buffer, BUFFER_SIZE_DEFAULT
从类 javax.swing.text.AbstractDocument 继承的字段
BAD_LOCATION, BidiElementName, ContentElementName, ElementNameAttribute, listenerList, ParagraphElementName, SectionElementName
从接口 javax.swing.text.Document 继承的字段
StreamDescriptionProperty, TitleProperty
构造方法摘要
HTMLDocument()
使用默认的缓冲区大小和默认的 StyleSheet 构造 HTML 文档。
HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
构造具有给定内容存储实现和给定样式/属性存储机制的 HTML 文档。
HTMLDocument(StyleSheet styles)
构造具有默认内容存储实现和指定样式/属性存储机制的 HTML 文档。
方法摘要
protected void | create(DefaultStyledDocument.ElementSpec[] data) 替换具有给定元素规范的文档内容。
protected Element | createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可以包含其他元素。
protected AbstractDocument.AbstractElement | createDefaultRoot() 创建用于表示默认文档结构的根元素。
protected Element | createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建直接表示文本的文档叶元素（没有任何子级）。
protected void | fireChangedUpdate(DocumentEvent e) 通知所有需要此事件类型的通知的已注册侦听器。
protected void | fireUndoableEditUpdate(UndoableEditEvent e) 通知所有需要此事件类型的通知的已注册侦听器。
URL | getBase() 返回解析相对 URL 所根据的位置。
Element | getElement(Element e, Object attribute, Object value) 返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。
Element | getElement(String id) 返回具有给定 id Attribute 的元素。
HTMLDocument.Iterator | getIterator(HTML.Tag t) 获取指定 HTML 标记的迭代器。
HTMLEditorKit.Parser | getParser() 返回将 HTML 插入现有文档时所使用的解析器。
boolean | getPreservesUnknownTags() 返回在遇到未知标记时所观察到的解析器行为。
HTMLEditorKit.ParserCallback | getReader(int pos) 获取加载带有 HTML 的文档时所用解析器的 reader。
HTMLEditorKit.ParserCallback | getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag) 返回加载带有 HTML 的文档时所用解析器的 reader。
StyleSheet | getStyleSheet() 获取具有特定于文档的显示规则（CSS）的 StyleSheet，其中这些规则是在 HTML 文档本身中指定的。
int | getTokenThreshold() 获取在试图更新文档元素结构之前要缓冲的标记数。
protected void | insert(int offset, DefaultStyledDocument.ElementSpec[] data) 批量插入新元素。
void | insertAfterEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之后。
void | insertAfterStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的起始处。
void | insertBeforeEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的结尾处。
void | insertBeforeStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之前。
protected void | insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 由于插入文本而导致更新文档的结构。
void | processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent e) 处理 HTML 框架中的文档所生成的 HyperlinkEvents。
void | setBase(URL u) 设置解析相对 URL 所根据的位置。
void | setInnerHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换给定元素的子元素。
void | setOuterHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换父元素中的给定元素。
void | setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
void | setParser(HTMLEditorKit.Parser parser) 设置将 html 插入现有文档的方法所使用的解析器，例如 setInnerHTML 和 setOuterHTML。
void | setPreservesUnknownTags(boolean preservesTags) 确定解析器如何处理未知标记。
void | setTokenThreshold(int n) 设置在试图更新文档元素结构之前要缓冲的标记数。
从类 javax.swing.text.DefaultStyledDocument 继承的方法
addDocumentListener, addStyle, getBackground, getCharacterElement, getDefaultRootElement, getFont, getForeground, getLogicalStyle, getParagraphElement, getStyle, getStyleNames, removeDocumentListener, removeStyle, removeUpdate, setCharacterAttributes, setLogicalStyle, styleChanged
从类 javax.swing.text.AbstractDocument 继承的方法
addUndoableEditListener, createPosition, dump, fireInsertUpdate, fireRemoveUpdate, getAsynchronousLoadPriority, getAttributeContext, getBidiRootElement, getContent, getCurrentWriter, getDocumentFilter, getDocumentListeners, getDocumentProperties, getEndPosition, getLength, getListeners, getProperty, getRootElements, getStartPosition, getText, getText, getUndoableEditListeners, insertString, postRemoveUpdate, putProperty, readLock, readUnlock, remove, removeUndoableEditListener, render, replace, setAsynchronousLoadPriority, setDocumentFilter, setDocumentProperties, writeLock, writeUnlock
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.text.Document 继承的方法
addUndoableEditListener, createPosition, getEndPosition, getLength, getProperty, getRootElements, getStartPosition, getText, getText, insertString, putProperty, remove, removeUndoableEditListener, render

字段详细信息

AdditionalComments

public static final String AdditionalComments
文档属性键值。键值将是 String 的 Vector，这是正文中没有的注释。

另请参见：
常量字段值
构造方法详细信息

HTMLDocument

public HTMLDocument()
使用默认的缓冲区大小和默认的 StyleSheet 构造 HTML 文档。这是 HTMLDocument(Content, StyleSheet) 构造方法的一个便捷方法。

HTMLDocument

public HTMLDocument(StyleSheet styles)
构造具有默认内容存储实现和指定样式/属性存储机制的 HTML 文档。这是 HTMLDocument(Content, StyleSheet) 构造方法的一个便捷方法。

参数：
styles - 样式

HTMLDocument

public HTMLDocument(AbstractDocument.Content c,
                    StyleSheet styles)
构造具有给定内容存储实现和给定样式/属性存储机制的 HTML 文档。

参数：
c - 内容的容器
styles - 样式
方法详细信息

getReader

public HTMLEditorKit.ParserCallback getReader(int pos)
获取加载带有 HTML 的文档时所用解析器的 reader。实现它的目的是为了返回 HTMLDocument.HTMLReader 的一个实例。如果需要，子类可以重新实现此方法来更改文档获取结构的方式。（例如，处理自定义标记，或者从结构上表示字符样式元素。）

参数：
pos - 起始位置
返回：
解析器用于加载文档的 reader

getReader

public HTMLEditorKit.ParserCallback getReader(int pos,
                                              int popDepth,
                                              int pushDepth,
                                              HTML.Tag insertTag)
返回加载带有 HTML 的文档时所用解析器的 reader。实现它的目的是为了返回 HTMLDocument.HTMLReader 的一个实例。如果需要，子类可以重新实现此方法来更改文档获取结构的方式。（例如，处理自定义标记，或者从结构上表示字符样式元素。）

这是 getReader(int, int, int, HTML.Tag, TRUE) 的一个便捷方法。

参数：
popDepth - 插入前要生成的 ElementSpec.EndTagTypes 的数量
pushDepth - 插入前但生成结束标记之后，应该生成的 ElementSpec.StartTagTypes 的数量（它具有 ElementSpec.JoinNextDirection 方向）
insertTag - 开始插入文档的首个标记
返回：
解析器用于加载文档的 reader

getBase

public URL getBase()
返回解析相对 URL 所根据的位置。默认情况下，如果文档是从 URL 加载的，则这将是文档的 URL。如果找到 BASE 标记并可以对其进行解析，则它将充当基本位置。

返回：
基本位置

setBase

public void setBase(URL u)
设置解析相对 URL 所根据的位置。默认情况下，如果文档是从 URL 加载的，则这将是文档的 URL。如果找到 BASE 标记并可以对其进行解析，则它将充当基本位置。

这还将 StyleSheet 的基本 URL 以及文档的基本 URL 设置为 u。

参数：
u - 所需的基本 URL

insert

protected void insert(int offset,
                      DefaultStyledDocument.ElementSpec[] data)
               throws BadLocationException
批量插入新元素。这是在文档中创建元素的方式。通过解析确定所需的结构，并创建作为标记（它描述了编辑）集合的规范，同时保留文档的写入锁定打开。然后 reader 以突发的形式调用此方法，以获得短时（也就是正在实际更改文档时）的写入锁定。

覆盖：
类 DefaultStyledDocument 中的 insert
参数：
offset - 起始偏移量
data - 元素数据
抛出：
BadLocationException - 如果给定的位置在关联文档中不是一个有效位置。

insertUpdate

protected void insertUpdate(AbstractDocument.DefaultDocumentEvent chng,
                            AttributeSet attr)
由于插入文本而导致更新文档的结构。这将在写入锁定中发生。此实现仅解析换行处插入的内容，并构建元素缓冲区的指令集。

覆盖：
类 DefaultStyledDocument 中的 insertUpdate
参数：
chng - 文档更改的描述
attr - 属性

create

protected void create(DefaultStyledDocument.ElementSpec[] data)
替换具有给定元素规范的文档内容。如果加载是突发进行的，则在插入前调用此方法。如果在一次突发加载中完全加载文档，则这是唯一调用的方法。

覆盖：
类 DefaultStyledDocument 中的 create
参数：
data - 文档的新内容

setParagraphAttributes

public void setParagraphAttributes(int offset,
                                   int length,
                                   AttributeSet s,
                                   boolean replace)
设置段落属性。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

指定者：
接口 StyledDocument 中的 setParagraphAttributes
覆盖：
类 DefaultStyledDocument 中的 setParagraphAttributes
参数：
offset - 段落中的偏移量（必须至少为 0）
length - 受影响的字符数（必须至少为 0）
s - 属性
replace - 是替换现有属性，还是合并它们

getStyleSheet

public StyleSheet getStyleSheet()
获取具有特定于文档的显示规则（CSS）的 StyleSheet，其中这些规则是在 HTML 文档本身中指定的。

返回：
StyleSheet

getIterator

public HTMLDocument.Iterator getIterator(HTML.Tag t)
获取指定 HTML 标记的迭代器。这可以用于在所包含的点集合上进行迭代，或者在输入元素上进行迭代。

参数：
t - 所请求的 HTML.Tag
返回：
给定 HTML 标记的 Iterator
另请参见：
HTML.Tag

createLeafElement

protected Element createLeafElement(Element parent,
                                    AttributeSet a,
                                    int p0,
                                    int p1)
创建直接表示文本的文档叶元素（没有任何子级）。实现它的目的是为了返回 HTMLDocument.RunElement 类型的元素。

覆盖：
类 AbstractDocument 中的 createLeafElement
参数：
parent - 父元素
a - 元素属性
p0 - 该范围的开始处（必须至少为 0）
p1 - 该范围的结尾处（必须至少为 p0）
返回：
新元素

createBranchElement

protected Element createBranchElement(Element parent,
                                      AttributeSet a)
创建文档分支元素，它可以包含其他元素。实现它的目的是为了返回 HTMLDocument.BlockElement 类型的元素。

覆盖：
类 AbstractDocument 中的 createBranchElement
参数：
parent - 父元素
a - 属性
返回：
元素

createDefaultRoot

protected AbstractDocument.AbstractElement createDefaultRoot()
创建用于表示默认文档结构的根元素。

覆盖：
类 DefaultStyledDocument 中的 createDefaultRoot
返回：
基本元素

setTokenThreshold

public void setTokenThreshold(int n)
设置在试图更新文档元素结构之前要缓冲的标记数。

参数：
n - 要缓冲的标记数

getTokenThreshold

public int getTokenThreshold()
获取在试图更新文档元素结构之前要缓冲的标记数。默认值为 Integer.MAX_VALUE。

返回：
要缓冲的标记数

setPreservesUnknownTags

public void setPreservesUnknownTags(boolean preservesTags)
确定解析器如何处理未知标记。如果设置为 true，则将未知标记放入模型中，否则删除它们。

参数：
preservesTags - 如果应该将未知标记保存到模型中，则为 true，否则删除这些标记
另请参见：
HTML.Tag

getPreservesUnknownTags

public boolean getPreservesUnknownTags()
返回在遇到未知标记时所观察到的解析器行为。

返回：
如果解析时要保留未知标记，则返回 true
另请参见：
HTML.Tag

processHTMLFrameHyperlinkEvent

public void processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent e)
处理 HTML 框架中的文档所生成的 HyperlinkEvents。HyperlinkEvent 类型为 HTMLFrameHyperlinkEvent（正如参数所说明的）。除 HyperlinkEvent 中所包含的典型信息之外，此事件还包含对应于发生单击事件的框架的元素（源元素）和目标名称。目标名称有 4 个可能值：
  • _self
  • _parent
  • _top
  • 已命名的框架
如果目标是 _self，则该操作将更改 HTML.Attribute.SRC 属性的值，并触发 ChangedUpdate 事件。

如果目标是 _parent，则它删除父元素（父元素是 <FRAMESET> 元素），插入一个新的 <FRAME> 元素，并将其 HTML.Attribute.SRC 属性设置为一个等于目标 URL 的值，并触发 RemovedUpdate 和 InsertUpdate。

如果目标是 _top，则此方法不执行任何操作。在框架视图（即 FrameView）的实现中，要对 _top 进行处理。给定该 _top 意味着替换整个文档，在它要替换的文档外部进行这项处理是有意义的。

如果目标是已命名的框架，则在元素层次结构中搜索名称等于目标的元素，更新其 HTML.Attribute.SRC 属性并触发 ChangedUpdate 事件。

参数：
e - 事件

setParser

public void setParser(HTMLEditorKit.Parser parser)
设置将 html 插入现有文档的方法所使用的解析器，例如 setInnerHTML 和 setOuterHTML。

HTMLEditorKit.createDefaultDocument 用于设置解析器。如果手动创建 HTMLDocument，则一定要确保相应地设置解析器。

参数：
parser - 用于文本插入的解析器
从以下版本开始：
1.3

getParser

public HTMLEditorKit.Parser getParser()
返回将 HTML 插入现有文档时所使用的解析器。

返回：
用于文本插入的解析器
从以下版本开始：
1.3

setInnerHTML

public void setInnerHTML(Element elem,
                         String htmlText)
                  throws BadLocationException,
                         IOException
用指定为 HTML 字符串的内容替换给定元素的子元素。

这将至少包括两个事件，n 个插入事件后跟一个移除事件。

为了让它正确工作，文档必须具有一个 HTMLEditorKit.Parser 集。如果文档是通过 createDefaultDocument 方法从 HTMLEditorKit 创建的，那么就是这种情况。

参数：
elem - 其子元素将被替换的分支元素
htmlText - 要被解析并分配给 elem 的字符串
抛出：
IllegalArgumentException - 如果 elem 是一个叶元素
IllegalStateException - 如果尚未定义 HTMLEditorKit.Parser
BadLocationException
IOException
从以下版本开始：
1.3

setOuterHTML

public void setOuterHTML(Element elem,
                         String htmlText)
                  throws BadLocationException,
                         IOException
用指定为 HTML 字符串的内容替换父元素中的给定元素。

这将至少包括两个事件，n 个插入事件后跟一个移除事件。

当替换叶元素时，这将试图确保存在一个新行（如果需要的话）。这可能导致插入额外的元素。考虑下面的情况，如果要用 <img> 替换一个包含新行的字符元素，那么这将创建两个元素，一个用于图像，另一个用于新行。

如果最后试图替换元素，则最有可能以两个元素结尾，例如，setOuterHTML(getCharacterElement (getLength()), "blah") 将导致结尾处有两个叶元素，一个表示 'blah'，而另一个则表示结尾元素。

为了让它正确工作，文档必须具有一个 HTMLEditorKit.Parser 集。如果文档是通过 createDefaultDocument 方法从 HTMLEditorKit 创建的，那么就是这种情况。

参数：
elem - 其子元素要被替换的分支元素
htmlText - 要被解析并分配给 elem 的字符串
抛出：
IllegalStateException - 如果尚未设置 HTMLEditorKit.Parser
BadLocationException
IOException
从以下版本开始：
1.3

insertAfterStart

public void insertAfterStart(Element elem,
                             String htmlText)
                      throws BadLocationException,
                             IOException
将指定为字符串的 HTML 插入元素的起始处。

为了让它正确工作，文档必须具有一个 HTMLEditorKit.Parser 集。如果文档是通过 createDefaultDocument 方法从 HTMLEditorKit 创建的，那么就是这种情况。

参数：
elem - 分支元素，它要作为新文本的根元素
htmlText - 要被解析并分配给 elem 的字符串
抛出：
IllegalStateException - 如果尚未在文档上设置 HTMLEditorKit.Parser
BadLocationException
IOException
从以下版本开始：
1.3

insertBeforeEnd

public void insertBeforeEnd(Element elem,
                            String htmlText)
                     throws BadLocationException,
                            IOException
将指定为字符串的 HTML 插入元素的结尾处。

如果 elem 的子元素是叶元素，并且 elem.getEndOffset() - 1 位置处的字符是一个新行符，则将内容插入到新行符的前面，以便新行符的后面没有文本。

为了让它正确工作，文档必须具有一个 HTMLEditorKit.Parser 集。如果文档是通过 createDefaultDocument 方法从 HTMLEditorKit 创建的，那么就是这种情况。

参数：
elem - 元素，它要作为新文本的根元素
htmlText - 要被解析并分配给 elem 的字符串
抛出：
IllegalStateException - 如果尚未在文档上设置 HTMLEditorKit.Parser
BadLocationException
IOException
从以下版本开始：
1.3

insertBeforeStart

public void insertBeforeStart(Element elem,
                              String htmlText)
                       throws BadLocationException,
                              IOException
将指定为字符串的 HTML 插入给定元素的起始处之前。

为了让它正确工作，文档必须具有一个 HTMLEditorKit.Parser 集。如果文档是通过 createDefaultDocument 方法从 HTMLEditorKit 创建的，那么就是这种情况。

参数：
elem - 元素，它要作为新文本的根元素
htmlText - 要被解析并分配给 elem 的字符串
抛出：
IllegalStateException - 如果尚未在文档上设置 HTMLEditorKit.Parser
BadLocationException
IOException
从以下版本开始：
1.3

insertAfterEnd

public void insertAfterEnd(Element elem,
                           String htmlText)
                    throws BadLocationException,
                           IOException
将指定为字符串的 HTML 插入给定元素的起始处之后。

为了让它正确工作，文档必须具有一个 HTMLEditorKit.Parser 集。如果文档是通过 createDefaultDocument 方法从 HTMLEditorKit 创建的，那么就是这种情况。

参数：
elem - 元素，它要作为新文本的根元素
htmlText - 要被解析并分配给 elem 的字符串
抛出：
IllegalStateException - 如果尚未在文档上设置 HTMLEditorKit.Parser
BadLocationException
IOException
从以下版本开始：
1.3

getElement

public Element getElement(String id)
返回具有给定 id Attribute 的元素。如果未找到元素，则返回 null。注意，此方法处理的是 Attribute，而不是 字符串标记。在下面的 HTML 片段中：<a id="HelloThere">，属性是 'id'，字符串标记是 'a'。这是 getElement(RootElement, HTML.Attribute.id, id) 的一个便捷方法。它不是线程安全的。

参数：
id - 表示所需 Attribute 的字符串
返回：
具有指定 Attribute 的元素，如果未找到，则返回 null，如果 id 为 null，则返回 null
从以下版本开始：
1.3
另请参见：
HTML.Attribute

getElement

public Element getElement(Element e,
                          Object attribute,
                          Object value)
返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。它不是线程安全的。

参数：
e - 根元素，从它开始进行搜索
attribute - 所需的 Attribute
value - 指定 Attribute 的值
返回：
具有指定 Attribute 和指定 value 的元素，如果未找到，则返回 null
从以下版本开始：
1.3
另请参见：
HTML.Attribute

fireChangedUpdate

protected void fireChangedUpdate(DocumentEvent e)
通知所有需要此事件类型的通知的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

覆盖：
类 AbstractDocument 中的 fireChangedUpdate
参数：
e - 事件
另请参见：
EventListenerList

fireUndoableEditUpdate

protected void fireUndoableEditUpdate(UndoableEditEvent e)
通知所有需要此事件类型的通知的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

覆盖：
类 AbstractDocument 中的 fireUndoableEditUpdate
参数：
e - 事件
另请参见：
EventListenerList
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.BlockElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.BlockElement

java.lang.Object
    继承者  javax.swing.text.AbstractDocument.AbstractElement
        继承者  javax.swing.text.AbstractDocument.BranchElement
            继承者  javax.swing.text.html.HTMLDocument.BlockElement
所有已实现的接口：
Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
正在封闭类：
HTMLDocument
public class HTMLDocument.BlockElement
extends AbstractDocument.BranchElement

表示结构性 HTML 块 的元素。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
HTMLDocument.BlockElement(Element parent, AttributeSet a)
构造初始不包含子元素的复合元素。
方法摘要
String | getName() 获取元素名称。
AttributeSet | getResolveParent() 获得解析父级。
从类 javax.swing.text.AbstractDocument.BranchElement 继承的方法
children, getAllowsChildren, getElement, getElementCount, getElementIndex, getEndOffset, getStartOffset, isLeaf, positionToElement, replace, toString
从类 javax.swing.text.AbstractDocument.AbstractElement 继承的方法
addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HTMLDocument.BlockElement

public HTMLDocument.BlockElement(Element parent,
                                 AttributeSet a)
构造初始不包含子元素的复合元素。

参数：
parent - 父元素
a - 元素的属性
从以下版本开始：
1.4
方法详细信息

getName

public String getName()
获取元素名称。

指定者：
接口 Element 中的 getName
覆盖：
类 AbstractDocument.BranchElement 中的 getName
返回：
名称，如果没有，则返回 null

getResolveParent

public AttributeSet getResolveParent()
获得解析父级。HTML 属性不是在模型级继承的，因此我们重写此方法以返回 null。

指定者：
接口 AttributeSet 中的 getResolveParent
覆盖：
类 AbstractDocument.AbstractElement 中的 getResolveParent
返回：
null，表示没有
另请参见：
AttributeSet.getResolveParent()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader

java.lang.Object
    继承者  javax.swing.text.html.HTMLEditorKit.ParserCallback
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader
正在封闭类：
HTMLDocument
public class HTMLDocument.HTMLReader
extends HTMLEditorKit.ParserCallback

一个 HTML reader，用来加载具有 HTML 元素结构的 HTML 文档。这是一个从解析器的回调集合，实现的目的是为了创建用属性标记的元素集合。该解析构建用于描述所需元素子树的标记（ElementSpec），并使用文档外部类的插入方法以突发的形式将其插入处于写入锁定保护的文档中。

reader 可以由注册的动作（类型为 HTMLDocument.HTMLReader.TagAction）来配置，该注册动作描述了如何处理动作。提供动作的意义在于，如果元素结构归结为其中具有某种样式的段落，则可以提供最自然的文本编辑操作。某些方面是更自然地从结构上指定的，因此应该允许段落具有任意结构，但需要用结构化动作来编辑它们。这里的含意在于，某些正在被解析的流中所指定的 HTML 元素将被折叠到属性中，并且在某些情况下将合成各个段落。当已经将 HTML 元素转换为属性时，属性键将为 HTML.Tag 类型，并且值将为 AttributeSet 类型，以便不丢失任何信息。这使许多现有动作得以工作，以便用户可以键入输入，单击回车键、退格键、删除键等等，并得到正确的结果。可以创建选项，应用或移除属性等等。考虑这点，reader 所做的工作可以分为以下几类任务：

块
构建类似于它在流中被指定的结构。这生成包含其他元素的元素。
段落
类似于块，区别在于我们期望元素可用于段落视图，这样就不必合成段落元素。
字符
作为属性的元素，它可以在任意文本位置开始和停止。这最终被混合到文本的运行中，带有所有当前变平的 HTML 字符元素。
特殊的
生成嵌入式图形元素。
表单
生成类似于嵌入式图形元素的元素，区别在于它还带有与其关联的组件模型。
隐藏的
创建元素，当以只读方式查看文档时，此元素在视图中是隐藏的，编辑文档时，此元素是可见的。这可用于保持模型不丢失信息，并用于存储诸如注释和未识别标记等此类信息。

目前不支持 <APPLET>、<PARAM>、<MAP>、<AREA>、<LINK>、<SCRIPT> 和 <STYLE>。

下表显示了为 HTML.Tag 中定义的标记所分配的动作。

标记 | 动作
HTML.Tag.A | CharacterAction
HTML.Tag.ADDRESS | CharacterAction
HTML.Tag.APPLET | HiddenAction
HTML.Tag.AREA | AreaAction
HTML.Tag.B | CharacterAction
HTML.Tag.BASE | BaseAction
HTML.Tag.BASEFONT | CharacterAction
HTML.Tag.BIG | CharacterAction
HTML.Tag.BLOCKQUOTE | BlockAction
HTML.Tag.BODY | BlockAction
HTML.Tag.BR | SpecialAction
HTML.Tag.CAPTION | BlockAction
HTML.Tag.CENTER | BlockAction
HTML.Tag.CITE | CharacterAction
HTML.Tag.CODE | CharacterAction
HTML.Tag.DD | BlockAction
HTML.Tag.DFN | CharacterAction
HTML.Tag.DIR | BlockAction
HTML.Tag.DIV | BlockAction
HTML.Tag.DL | BlockAction
HTML.Tag.DT | ParagraphAction
HTML.Tag.EM | CharacterAction
HTML.Tag.FONT | CharacterAction
HTML.Tag.FORM | 从 1.4 版本开始，为 BlockAction
HTML.Tag.FRAME | SpecialAction
HTML.Tag.FRAMESET | BlockAction
HTML.Tag.H1 | ParagraphAction
HTML.Tag.H2 | ParagraphAction
HTML.Tag.H3 | ParagraphAction
HTML.Tag.H4 | ParagraphAction
HTML.Tag.H5 | ParagraphAction
HTML.Tag.H6 | ParagraphAction
HTML.Tag.HEAD | HeadAction
HTML.Tag.HR | SpecialAction
HTML.Tag.HTML | BlockAction
HTML.Tag.I | CharacterAction
HTML.Tag.IMG | SpecialAction
HTML.Tag.INPUT | FormAction
HTML.Tag.ISINDEX | IsndexAction
HTML.Tag.KBD | CharacterAction
HTML.Tag.LI | BlockAction
HTML.Tag.LINK | LinkAction
HTML.Tag.MAP | MapAction
HTML.Tag.MENU | BlockAction
HTML.Tag.META | MetaAction
HTML.Tag.NOFRAMES | BlockAction
HTML.Tag.OBJECT | SpecialAction
HTML.Tag.OL | BlockAction
HTML.Tag.OPTION | FormAction
HTML.Tag.P | ParagraphAction
HTML.Tag.PARAM | HiddenAction
HTML.Tag.PRE | PreAction
HTML.Tag.SAMP | CharacterAction
HTML.Tag.SCRIPT | HiddenAction
HTML.Tag.SELECT | FormAction
HTML.Tag.SMALL | CharacterAction
HTML.Tag.STRIKE | CharacterAction
HTML.Tag.S | CharacterAction
HTML.Tag.STRONG | CharacterAction
HTML.Tag.STYLE | StyleAction
HTML.Tag.SUB | CharacterAction
HTML.Tag.SUP | CharacterAction
HTML.Tag.TABLE | BlockAction
HTML.Tag.TD | BlockAction
HTML.Tag.TEXTAREA | FormAction
HTML.Tag.TH | BlockAction
HTML.Tag.TITLE | TitleAction
HTML.Tag.TR | BlockAction
HTML.Tag.TT | CharacterAction
HTML.Tag.U | CharacterAction
HTML.Tag.UL | BlockAction
HTML.Tag.VAR | CharacterAction

一旦遇到 </html>，则不再通知 Action。

嵌套类摘要
class | HTMLDocument.HTMLReader.BlockAction
class | HTMLDocument.HTMLReader.CharacterAction
class | HTMLDocument.HTMLReader.FormAction 此动作通过构建所有用于表示表单控件的元素来支持表单。
class | HTMLDocument.HTMLReader.HiddenAction
class | HTMLDocument.HTMLReader.IsindexAction
class | HTMLDocument.HTMLReader.ParagraphAction
class | HTMLDocument.HTMLReader.PreAction
class | HTMLDocument.HTMLReader.SpecialAction
class | HTMLDocument.HTMLReader.TagAction 为响应对标记的解析而执行的动作。
字段摘要
protected MutableAttributeSet | charAttr
protected Vector<DefaultStyledDocument.ElementSpec> | parseBuffer
从类 javax.swing.text.html.HTMLEditorKit.ParserCallback 继承的字段
IMPLIED
构造方法摘要
HTMLDocument.HTMLReader(int offset)
HTMLDocument.HTMLReader(int offset, int popDepth, int pushDepth, HTML.Tag insertTag)
方法摘要
protected void | addContent(char[] data, int offs, int length) 添加某个具有当前字符属性的文本。
protected void | addContent(char[] data, int offs, int length, boolean generateImpliedPIfNecessary) 添加某个具有当前字符属性的文本。
protected void | addSpecialElement(HTML.Tag t, MutableAttributeSet a) 添加基本上完全是在属性集中指定的内容。
protected void | blockClose(HTML.Tag t) 向解析器缓冲区添加一条指令，以关闭给定类型的块元素。
protected void | blockOpen(HTML.Tag t, MutableAttributeSet attr) 向解析器缓冲区添加一条指令，以创建具有给定属性的块元素。
void | flush() 在 reader 上调用的最后一个方法。
void | handleComment(char[] data, int pos)
void | handleEndOfLineString(String eol) 它的调用是在完成流的解析之后且在调用 flush 之前。
void | handleEndTag(HTML.Tag t, int pos) 从解析器回调。
void | handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | handleText(char[] data, int pos) 解析器调用它来指示遇到一个文本块。
protected void | popCharacterStyle() 将以前压入堆栈的字符样式弹出，以返回以前的样式。
protected void | preContent(char[] data) 添加在 PRE 元素中遇到的给定内容。
protected void | pushCharacterStyle() 将当前字符样式压入堆栈，以准备形成新的嵌套字符样式。
protected void | registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a) 注册给定标记的处理程序。
protected void | textAreaContent(char[] data) 将给定的内容添加到 textarea 文档。
从类 javax.swing.text.html.HTMLEditorKit.ParserCallback 继承的方法
handleError
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

parseBuffer

protected Vector<DefaultStyledDocument.ElementSpec> parseBuffer

charAttr

protected MutableAttributeSet charAttr
构造方法详细信息

HTMLDocument.HTMLReader

public HTMLDocument.HTMLReader(int offset)

HTMLDocument.HTMLReader

public HTMLDocument.HTMLReader(int offset,
                               int popDepth,
                               int pushDepth,
                               HTML.Tag insertTag)
方法详细信息

flush

public void flush()
           throws BadLocationException
在 reader 上调用的最后一个方法。它允许将任何挂起的更改刷新到文档中。因为当前这是同步加载的，所以此时会压入整个更改的集合。

覆盖：
类 HTMLEditorKit.ParserCallback 中的 flush
抛出：
BadLocationException

handleText

public void handleText(char[] data,
                       int pos)
解析器调用它来指示遇到一个文本块。

覆盖：
类 HTMLEditorKit.ParserCallback 中的 handleText

handleStartTag

public void handleStartTag(HTML.Tag t,
                           MutableAttributeSet a,
                           int pos)
从解析器回调。路由到适当的标记处理程序。

覆盖：
类 HTMLEditorKit.ParserCallback 中的 handleStartTag

handleComment

public void handleComment(char[] data,
                          int pos)
覆盖：
类 HTMLEditorKit.ParserCallback 中的 handleComment

handleEndTag

public void handleEndTag(HTML.Tag t,
                         int pos)
从解析器回调。路由到适当的标记处理程序。

覆盖：
类 HTMLEditorKit.ParserCallback 中的 handleEndTag

handleSimpleTag

public void handleSimpleTag(HTML.Tag t,
                            MutableAttributeSet a,
                            int pos)
从解析器回调。路由到适当的标记处理程序。

覆盖：
类 HTMLEditorKit.ParserCallback 中的 handleSimpleTag

handleEndOfLineString

public void handleEndOfLineString(String eol)
它的调用是在完成流的解析之后且在调用 flush 之前。eol 将是 \n、\r 或 \r\n 中的一个，它是在解析流时最常遇到的。

覆盖：
类 HTMLEditorKit.ParserCallback 中的 handleEndOfLineString
从以下版本开始：
1.3

registerTag

protected void registerTag(HTML.Tag t,
                           HTMLDocument.HTMLReader.TagAction a)
注册给定标记的处理程序。默认情况下所有已知的标记是已注册的。这可以用于更改特殊标记的处理，或者添加对自定义标记的支持。

pushCharacterStyle

protected void pushCharacterStyle()
将当前字符样式压入堆栈，以准备形成新的嵌套字符样式。

popCharacterStyle

protected void popCharacterStyle()
将以前压入堆栈的字符样式弹出，以返回以前的样式。

textAreaContent

protected void textAreaContent(char[] data)
将给定的内容添加到 textarea 文档。处于 textarea 上下文中时调用此方法。因此，所有看到的文本均属于文本区，并因此添加到与该文本区关联的 TextAreaDocument 中。

preContent

protected void preContent(char[] data)
添加在 PRE 元素中遇到的给定内容。此方法合成行以保持文本的运行，并调用 addContent 来实际添加文本。

blockOpen

protected void blockOpen(HTML.Tag t,
                         MutableAttributeSet attr)
向解析器缓冲区添加一条指令，以创建具有给定属性的块元素。

blockClose

protected void blockClose(HTML.Tag t)
向解析器缓冲区添加一条指令，以关闭给定类型的块元素。

addContent

protected void addContent(char[] data,
                          int offs,
                          int length)
添加某个具有当前字符属性的文本。

参数：
data - 要添加的内容
offs - 初始偏移量
length - 长度

addContent

protected void addContent(char[] data,
                          int offs,
                          int length,
                          boolean generateImpliedPIfNecessary)
添加某个具有当前字符属性的文本。

参数：
data - 要添加的内容
offs - 初始偏移量
length - 长度
generateImpliedPIfNecessary - 是否生成隐含段

addSpecialElement

protected void addSpecialElement(HTML.Tag t,
                                 MutableAttributeSet a)
添加基本上完全是在属性集中指定的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.BlockAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.BlockAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
直接已知子类：
HTMLDocument.HTMLReader.ParagraphAction, HTMLDocument.HTMLReader.PreAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.BlockAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.BlockAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet attr) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.BlockAction

public HTMLDocument.HTMLReader.BlockAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet attr)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.CharacterAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.CharacterAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.CharacterAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.CharacterAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet attr) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.CharacterAction

public HTMLDocument.HTMLReader.CharacterAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet attr)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.FormAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.FormAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
            继承者  javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.FormAction
extends HTMLDocument.HTMLReader.SpecialAction

此动作通过构建所有用于表示表单控件的元素来支持表单。这将处理 <INPUT>、<TEXTAREA>、<SELECT> 和 <OPTION> 标记。此动作所创建的元素应该将属性 StyleConstants.ModelAttribute 设置为保存表单控件状态的模型。这就允许多个视图，并允许对文档进行迭代来获得表单数据。下面是各类表单元素的模型分配。

元素类型 | 模型类型
输入，类型为 button | DefaultButtonModel
输入，类型为 checkbox | JToggleButton.ToggleButtonModel
输入，类型为 image | DefaultButtonModel
输入，类型为 password | PlainDocument
输入，类型为 radio | JToggleButton.ToggleButtonModel
输入，类型为 reset | DefaultButtonModel
输入，类型为 submit | DefaultButtonModel
输入，类型为 text 或 null。 | PlainDocument
选择 | DefaultComboBoxModel 或 DefaultListModel，带有 Option 类型的项
textarea | PlainDocument

构造方法摘要
HTMLDocument.HTMLReader.FormAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet attr) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.FormAction

public HTMLDocument.HTMLReader.FormAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet attr)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.SpecialAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.HiddenAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.HiddenAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.HiddenAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.HiddenAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.HiddenAction

public HTMLDocument.HTMLReader.HiddenAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.IsindexAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.IsindexAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.IsindexAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.IsindexAction()
方法摘要
 void start(HTML.Tag t, MutableAttributeSet a)
当发现此动作所注册的标记类型的开始标记时调用。
从类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 继承的方法
end
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.IsindexAction

public HTMLDocument.HTMLReader.IsindexAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.ParagraphAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.ParagraphAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
            继承者  javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.ParagraphAction
extends HTMLDocument.HTMLReader.BlockAction

构造方法摘要
HTMLDocument.HTMLReader.ParagraphAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.ParagraphAction

public HTMLDocument.HTMLReader.ParagraphAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.BlockAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.BlockAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.PreAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.PreAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
            继承者  javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.PreAction
extends HTMLDocument.HTMLReader.BlockAction

构造方法摘要
HTMLDocument.HTMLReader.PreAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet attr) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.PreAction

public HTMLDocument.HTMLReader.PreAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet attr)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.BlockAction 中的 start

end

public void end(HTML.Tag t)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.BlockAction 中的 end
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.SpecialAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.SpecialAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
        继承者  javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
直接已知子类：
HTMLDocument.HTMLReader.FormAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.SpecialAction
extends HTMLDocument.HTMLReader.TagAction

构造方法摘要
HTMLDocument.HTMLReader.SpecialAction()
方法摘要
 void start(HTML.Tag t, MutableAttributeSet a)
当发现此动作所注册的标记类型的开始标记时调用。
从类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 继承的方法
end
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.SpecialAction

public HTMLDocument.HTMLReader.SpecialAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
从类 HTMLDocument.HTMLReader.TagAction 复制的描述
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

覆盖：
类 HTMLDocument.HTMLReader.TagAction 中的 start
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.HTMLReader.TagAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.HTMLReader.TagAction

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
直接已知子类：
HTMLDocument.HTMLReader.BlockAction, HTMLDocument.HTMLReader.CharacterAction, HTMLDocument.HTMLReader.HiddenAction, HTMLDocument.HTMLReader.IsindexAction, HTMLDocument.HTMLReader.SpecialAction
正在封闭类：
HTMLDocument.HTMLReader
public class HTMLDocument.HTMLReader.TagAction
extends Object

为响应对标记的解析而执行的动作。这允许自定义每个标记的处理方式，并避免了大的 switch 语句。

构造方法摘要
HTMLDocument.HTMLReader.TagAction()
方法摘要
void | end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.HTMLReader.TagAction

public HTMLDocument.HTMLReader.TagAction()
方法详细信息

start

public void start(HTML.Tag t,
                  MutableAttributeSet a)
当发现此动作所注册的标记类型的开始标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

end

public void end(HTML.Tag t)
当发现此动作所注册的标记类型的结束标记时调用。tag 参数指示用于这些由许多标记共享的动作的实际标记。默认情况下，这不执行任何操作并完全忽略标记。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.Iterator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.Iterator

java.lang.Object
    继承者  javax.swing.text.html.HTMLDocument.Iterator
正在封闭类：
HTMLDocument
public abstract static class HTMLDocument.Iterator
extends Object

对特定类型的标记进行迭代的迭代器。此迭代器不是线程安全的。如果使用迭代器的上下文尚未确保对文档的可靠访问，则它的使用应该在 Document.render 的保护下进行。

构造方法摘要
HTMLDocument.Iterator()
方法摘要
abstract AttributeSet | getAttributes() 返回此标记的属性。
abstract int | getEndOffset() 返回当前出现的标记所定义的并具有相同属性的范围结尾处。
abstract int | getStartOffset() 返回当前出现的标记所定义的并具有相同属性的范围起始处。
abstract HTML.Tag | getTag() 此迭代器所表示的标记类型。
abstract boolean | isValid() 指示当前迭代器是否正在表示出现的标记。
abstract void | next() 将迭代器向前移动到它所表示的下一个标记出现的位置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLDocument.Iterator

public HTMLDocument.Iterator()
方法详细信息

getAttributes

public abstract AttributeSet getAttributes()
返回此标记的属性。

返回：
此标记的 AttributeSet，如果未找到标记，则返回 null

getStartOffset

public abstract int getStartOffset()
返回当前出现的标记所定义的并具有相同属性的范围起始处。

返回：
该范围起始处，如果未找到，则返回 -1

getEndOffset

public abstract int getEndOffset()
返回当前出现的标记所定义的并具有相同属性的范围结尾处。

返回：
该范围结尾处

next

public abstract void next()
将迭代器向前移动到它所表示的下一个标记出现的位置。

isValid

public abstract boolean isValid()
指示当前迭代器是否正在表示出现的标记。如果为 false，则此迭代器已没有更多的标记。

返回：
如果当前迭代器正在表示出现的标记，则返回 true；否则返回 false

getTag

public abstract HTML.Tag getTag()
此迭代器所表示的标记类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLDocument.RunElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLDocument.RunElement

java.lang.Object
    继承者  javax.swing.text.AbstractDocument.AbstractElement
        继承者  javax.swing.text.AbstractDocument.LeafElement
            继承者  javax.swing.text.html.HTMLDocument.RunElement
所有已实现的接口：
Serializable, AttributeSet, Element, MutableAttributeSet, TreeNode
正在封闭类：
HTMLDocument
public class HTMLDocument.RunElement
extends AbstractDocument.LeafElement

表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

嵌套类摘要
从接口 javax.swing.text.AttributeSet 继承的嵌套类/接口
AttributeSet.CharacterAttribute, AttributeSet.ColorAttribute, AttributeSet.FontAttribute, AttributeSet.ParagraphAttribute
字段摘要
从接口 javax.swing.text.AttributeSet 继承的字段
NameAttribute, ResolveAttribute
构造方法摘要
HTMLDocument.RunElement(Element parent, AttributeSet a, int offs0, int offs1)
构造表示文档内部（没有子级）内容的元素。
方法摘要
String | getName() 获取元素名称。
AttributeSet | getResolveParent() 获得解析父级。
从类 javax.swing.text.AbstractDocument.LeafElement 继承的方法
children, getAllowsChildren, getElement, getElementCount, getElementIndex, getEndOffset, getStartOffset, isLeaf, toString
从类 javax.swing.text.AbstractDocument.AbstractElement 继承的方法
addAttribute, addAttributes, containsAttribute, containsAttributes, copyAttributes, dump, getAttribute, getAttributeCount, getAttributeNames, getAttributes, getChildAt, getChildCount, getDocument, getIndex, getParent, getParentElement, isDefined, isEqual, removeAttribute, removeAttributes, removeAttributes, setResolveParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HTMLDocument.RunElement

public HTMLDocument.RunElement(Element parent,
                               AttributeSet a,
                               int offs0,
                               int offs1)
构造表示文档内部（没有子级）内容的元素。

参数：
parent - 父元素
a - 元素属性
offs0 - 起始偏移量（必须至少为 0）
offs1 - 结束偏移量（必须至少为 offs0）
从以下版本开始：
1.4
方法详细信息

getName

public String getName()
获取元素名称。

指定者：
接口 Element 中的 getName
覆盖：
类 AbstractDocument.LeafElement 中的 getName
返回：
名称，如果没有，则返回 null

getResolveParent

public AttributeSet getResolveParent()
获得解析父级。HTML 属性不是在模型级继承的，因此我们重写此方法以返回 null。

指定者：
接口 AttributeSet 中的 getResolveParent
覆盖：
类 AbstractDocument.AbstractElement 中的 getResolveParent
返回：
null，表示没有
另请参见：
AttributeSet.getResolveParent()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLWriter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLWriter

java.lang.Object
    继承者  javax.swing.text.AbstractWriter
        继承者  javax.swing.text.html.HTMLWriter

public class HTMLWriter
extends AbstractWriter

这是用于 HTMLDocuments 的 writer。

字段摘要
从类 javax.swing.text.AbstractWriter 继承的字段
NEWLINE
构造方法摘要
HTMLWriter(Writer w, HTMLDocument doc)
创建新的 HTMLWriter。
HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
创建新的 HTMLWriter。
方法摘要
protected void | closeOutUnwantedEmbeddedTags(AttributeSet attr) 搜索属性集和存储在标记向量中的每个标记。
protected void | comment(Element elem) 写出注释。
protected void | emptyTag(Element elem) 写出所有空元素（没有对应结束标记的所有标记）。
protected void | endTag(Element elem) 写出元素的结束标记。
protected boolean | isBlockTag(AttributeSet attr) 确定与该元素关联的 HTML.Tag 是否为块标记。
protected boolean | matchNameAttribute(AttributeSet attr, HTML.Tag tag) 如果 StyleConstants.NameAttribute 与作为参数传入的标记相同，则返回 true。
protected void | output(char[] chars, int start, int length) 重写此方法来映射任何字符实体，例如 < 映射到 <。
protected void | selectContent(AttributeSet attr) 写出 SELECT 表单元素的内容。
protected void | startTag(Element elem) 写出元素的开始标记。
protected boolean | synthesizedElement(Element elem) 如果元素是合成元素，则返回 true。
protected void | text(Element elem) 写出文本。
protected void | textAreaContent(AttributeSet attr) 写出 TEXTAREA 表单元素中所包含的文本。
void | write() 对 Element 树进行迭代并控制所有标记及其属性的写出。
protected void | writeAttributes(AttributeSet attr) 写出属性集。
protected void | writeEmbeddedTags(AttributeSet attr) 搜索 AttributeSet 中的嵌入式标记并写出它们。
protected void | writeLineSeparator() 写出行分隔符。
protected void | writeOption(Option option) 写出 Option 表单元素的内容。
从类 javax.swing.text.AbstractWriter 继承的方法
decrIndent, getCanWrapLines, getCurrentLineLength, getDocument, getElementIterator, getEndOffset, getIndentLevel, getIndentSpace, getLineLength, getLineSeparator, getStartOffset, getText, getWriter, incrIndent, indent, inRange, isLineEmpty, setCanWrapLines, setCurrentLineLength, setIndentSpace, setLineLength, setLineSeparator, write, write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLWriter

public HTMLWriter(Writer w,
                  HTMLDocument doc)
创建新的 HTMLWriter。

参数：
w - Writer
doc - HTMLDocument

HTMLWriter

public HTMLWriter(Writer w,
                  HTMLDocument doc,
                  int pos,
                  int len)
创建新的 HTMLWriter。

参数：
w - Writer
doc - HTMLDocument
pos - 文档位置，从此位置获取内容
len - 写出量
方法详细信息

write

public void write()
           throws IOException,
                  BadLocationException
对 Element 树进行迭代并控制所有标记及其属性的写出。

指定者：
类 AbstractWriter 中的 write
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。

writeAttributes

protected void writeAttributes(AttributeSet attr)
                        throws IOException
写出属性集。忽略带有类型 HTML.Tag 键的所有属性，带有类型 StyleConstants 键的所有属性，以及带有类型 HTML.Attribute.ENDTAG 键的所有属性。

覆盖：
类 AbstractWriter 中的 writeAttributes
参数：
attr - AttributeSet
抛出：
IOException - 如果发生任何 I/O 错误

emptyTag

protected void emptyTag(Element elem)
                 throws BadLocationException,
                        IOException
写出所有空元素（没有对应结束标记的所有标记）。

参数：
elem - Element
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。

isBlockTag

protected boolean isBlockTag(AttributeSet attr)
确定与该元素关联的 HTML.Tag 是否为块标记。

参数：
attr - AttributeSet
返回：
如果标记是块标记，则返回 true；否则返回 false。

startTag

protected void startTag(Element elem)
                 throws IOException,
                        BadLocationException
写出元素的开始标记。忽略所有的合成元素。

参数：
elem - Element
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException

textAreaContent

protected void textAreaContent(AttributeSet attr)
                        throws BadLocationException,
                               IOException
写出 TEXTAREA 表单元素中所包含的文本。

参数：
attr - AttributeSet
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。

text

protected void text(Element elem)
             throws BadLocationException,
                    IOException
写出文本。如果调用构造方法时指定了范围，则只写出相应范围内的文本。

覆盖：
类 AbstractWriter 中的 text
参数：
elem - Element
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。

selectContent

protected void selectContent(AttributeSet attr)
                      throws IOException
写出 SELECT 表单元素的内容。

参数：
attr - 与表单元素关联的 AttributeSet
抛出：
IOException - 如果发生任何 I/O 错误

writeOption

protected void writeOption(Option option)
                    throws IOException
写出 Option 表单元素的内容。

参数：
option - Option
抛出：
IOException - 如果发生任何 I/O 错误

endTag

protected void endTag(Element elem)
               throws IOException
写出元素的结束标记。

参数：
elem - Element
抛出：
IOException - 如果发生任何 I/O 错误

comment

protected void comment(Element elem)
                throws BadLocationException,
                       IOException
写出注释。

参数：
elem - Element
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的无效位置。

synthesizedElement

protected boolean synthesizedElement(Element elem)
如果元素是合成元素，则返回 true。目前我们只测试了 p 暗指的标记。

matchNameAttribute

protected boolean matchNameAttribute(AttributeSet attr,
                                     HTML.Tag tag)
如果 StyleConstants.NameAttribute 与作为参数传入的标记相同，则返回 true。

writeEmbeddedTags

protected void writeEmbeddedTags(AttributeSet attr)
                          throws IOException
搜索 AttributeSet 中的嵌入式标记并写出它们。它还将这些标记存储在一个向量中，以便在适当的时候能够写出对应的结束标记。

抛出：
IOException - 如果发生任何 I/O 错误

closeOutUnwantedEmbeddedTags

protected void closeOutUnwantedEmbeddedTags(AttributeSet attr)
                                     throws IOException
搜索属性集和存储在标记向量中的每个标记。如果未找到标记，则从向量中移除标记并写出对应的结束标记。

抛出：
IOException - 如果发生任何 I/O 错误

writeLineSeparator

protected void writeLineSeparator()
                           throws IOException
写出行分隔符。当它不是标准的 ascii 时，我们重写它以确保不替换新行内容。

覆盖：
类 AbstractWriter 中的 writeLineSeparator
抛出：
IOException
从以下版本开始：
1.3

output

protected void output(char[] chars,
                      int start,
                      int length)
               throws IOException
重写此方法来映射任何字符实体，例如 < 映射到 <。调用 super.output 可写出内容。

覆盖：
类 AbstractWriter 中的 output
抛出：
IOException
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLEditorKit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLEditorKit

java.lang.Object
    继承者  javax.swing.text.EditorKit
        继承者  javax.swing.text.DefaultEditorKit
            继承者  javax.swing.text.StyledEditorKit
                继承者  javax.swing.text.html.HTMLEditorKit
所有已实现的接口：
Serializable, Cloneable, Accessible
public class HTMLEditorKit
extends StyledEditorKit
implements Accessible

Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。因为 HTML 是很流行的内容格式，因此默认提供了某种支持。此类提供了 HTML version 3.2（带有某些扩展）的默认支持，并正在向 version 4.0 迁移。不支持 <applet> 标记，但为 <object> 标记提供了某种支持。

提供 HTML EditorKit 有几个目的，这些目的影响了 HTML 的建模方式。并从基本方法上影响了其设计。

支持编辑
有一点看起来相当明显，即 JEditorPane 的插件应该提供编辑支持，但实际上需要考虑几点设计因素。有相当数量的 HTML 文档没有正确遵守 HTML 规范。如果要编辑这些文档，则必须在某种程度上进行标准化，使其具有正确的形式。此外，用户不希望面对过多的结构编辑，因此使用传统的文本编辑动作优先于使用 HTML 文档中精确定义的 HTML 结构。

HTMLDocument 类提供了 HTML 的建模。其文档描述了建模 HTML 的细节。编辑支持主要不利用 text 包。

可扩展的/可伸缩的
为了最大化此工具包的使用，我们付诸了大量努力使其具有可扩展性。这里是一些特性。
  1. 解析器是可替换的。默认解析器是基于 DTD 的 Hot Java 解析器。可以使用不同的 DTD，或者可以使用一个完全不同的解析器。要更改解析器，请重新实现 getParser 方法。首次请求默认解析器时动态加载它，因此如果使用了另一个解析器，则永远不会加载类文件。默认解析器在此包下面一个单独的包中，这个包称为 parser。
  2. 解析器驱动由 HTMLDocument 所提供的 ParserCallback。要更改回调，请创建 HTMLDocument 子类，并重新实现 createDefaultDocument 方法以返回生成不同 reader 的文档。reader 控制文档的结构。虽然在默认情况下 Document 提供了 HTML 支持，但并不妨碍它支持替代元素结构所产生的非 HTML 标记。
  3. 默认的模型视图是作为 View 实现的层次结构提供的，所以我们可以轻松地自定义如何显示某个特定元素，或者通过提供新的 View 实现来添加新元素类型的功能。默认的视图集合由 HTMLFactory 类提供。可以轻松地更改此方法，方法是创建 HTMLFactory 的子类或替换 HTMLFactory 类，并重新实现 getViewFactory 方法以返回替代的工厂。
  4. View 实现主要是清除保持在视图中的 CSS 属性。这就能够在看似极不相同的相同模型上映射多个视图。这对于打印是非常有用的。出于显示目的，对于大多数的 HTML 属性，要将 HTML 属性转换为 CSS 属性。这有助于使 View 实现更为通用。

异步加载
较大的文档涉及大量的解析工作，并需要一定时间来加载。默认情况下，此工具包生成异步加载的文档（如果使用 JEditorPane.setPage 来加载）。这由文档的一个属性来控制。这可以通过重写 createDefaultDocument 方法来更改。批处理工作由 HTMLDocument.HTMLReader 类完成。实际的工作由 text 包中的 DefaultStyledDocument 和 AbstractDocument 类完成。

根据当前 LAF 进行自定义
HTML 提供了已知的特性集，但没有准确指定显示特征。Swing 具有其外观实现的 theme 机制。外观应该在 HTML 视图中提供显示特征。例如，视力较差的用户需要高对比度和比典型字体更大的字体。

StyleSheet 类提供了这种支持。通过设置 EditorKit 上的 StyleSheet 属性，可以对 HTML 的表示产生很大影响。

无丢失
EditorKit 能够读取和保存文档。通常用户最希望的是在两个操作之间没有数据丢失。HTMLEditorKit 的策略是保存未识别或不必要可见的内容，以便随后可以写出它们。因此，HTML 文档的模型应该包含读取文档时所发现的所有信息。由于需要支持编辑，因此这在某些方面受到限制（例如有时必须将不正确的文档标准化）。指导原则是不应该丢失信息，但可以合成某些信息来生成更正确的模型，或者重新安排信息。

嵌套类摘要
static class | HTMLEditorKit.HTMLFactory 用于构建 HTML 视图的工厂。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。
static class | HTMLEditorKit.Parser 解析器要支持的接口。
static class | HTMLEditorKit.ParserCallback 解析结果驱动这些回调方法。
从类 javax.swing.text.StyledEditorKit 继承的嵌套类/接口
StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction
从类 javax.swing.text.DefaultEditorKit 继承的嵌套类/接口
DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction
字段摘要
static String | BOLD_ACTION 粗体动作标识符
static String | COLOR_ACTION Color 选择动作标识符（颜色作为参数传递）
static String | DEFAULT_CSS 用于设置标记视图的默认级联样式表 (Cascading Style Sheet) 文件。
static String | FONT_CHANGE_BIGGER 字体大小增大到下一个值的动作标识符
static String | FONT_CHANGE_SMALLER 字体大小减小到下一个值的动作标识符
static String | IMG_ALIGN_BOTTOM 将图像底部对齐。
static String | IMG_ALIGN_MIDDLE 将图像居中对齐。
static String | IMG_ALIGN_TOP 将图像顶部对齐。
static String | IMG_BORDER 将图像对齐到边框。
static String | ITALIC_ACTION 斜体动作标识符
static String | LOGICAL_STYLE_ACTION 逻辑样式选择动作标识符（逻辑样式作为参数传递）
static String | PARA_INDENT_LEFT 段落左缩进动作标识符
static String | PARA_INDENT_RIGHT 段落右缩进动作标识符
从类 javax.swing.text.DefaultEditorKit 继承的字段
backwardAction, beepAction, beginAction, beginLineAction, beginParagraphAction, beginWordAction, copyAction, cutAction, defaultKeyTypedAction, deleteNextCharAction, deleteNextWordAction, deletePrevCharAction, deletePrevWordAction, downAction, endAction, endLineAction, EndOfLineStringProperty, endParagraphAction, endWordAction, forwardAction, insertBreakAction, insertContentAction, insertTabAction, nextWordAction, pageDownAction, pageUpAction, pasteAction, previousWordAction, readOnlyAction, selectAllAction, selectionBackwardAction, selectionBeginAction, selectionBeginLineAction, selectionBeginParagraphAction, selectionBeginWordAction, selectionDownAction, selectionEndAction, selectionEndLineAction, selectionEndParagraphAction, selectionEndWordAction, selectionForwardAction, selectionNextWordAction, selectionPreviousWordAction, selectionUpAction, selectLineAction, selectParagraphAction, selectWordAction, upAction, writableAction
构造方法摘要
HTMLEditorKit()
构造 HTMLEditorKit，创建 StyleContext，并加载样式表。
方法摘要
Object | clone() 创建编辑器工具包的一个副本。
Document | createDefaultDocument() 创建一个适合此编辑器类型的未初始化文本存储模型。
protected void | createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
void | deinstall(JEditorPane c) 工具包从 JEditorPane 移除时调用。
AccessibleContext | getAccessibleContext() 返回与此编辑器工具包关联的 AccessibleContext。
Action[] | getActions() 获取编辑器的命令列表。
String | getContentType() 获取此工具包支持的 MIME 类型的数据。
Cursor | getDefaultCursor() 返回默认光标。
MutableAttributeSet | getInputAttributes() 获取该样式编辑动作的输入属性。
Cursor | getLinkCursor() 返回要在超链接上使用的光标。
protected HTMLEditorKit.Parser | getParser() 获取要用于读取 HTML 流的解析器。
StyleSheet | getStyleSheet() 获取当前正用于呈现 HTML 元素的样式集。
ViewFactory | getViewFactory() 获取一个适合供由此包所产生的任何模型来产生视图的工厂。
void | insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag) 将 HTML 插入现有文档。
void | install(JEditorPane c) 将工具包安装到 JEditorPane 中时调用。
boolean | isAutoFormSubmission() 指示是否自动处理 html 表单提交，或只是激发 FormSubmitEvent。
void | read(Reader in, Document doc, int pos) 插入来自给定流的内容。
void | setAutoFormSubmission(boolean isAuto) 指定是否自动处理 html 表单提交，或只是激发 FormSubmitEvent。
void | setDefaultCursor(Cursor cursor) 设置默认光标。
void | setLinkCursor(Cursor cursor) 设置要在链接上使用的光标。
void | setStyleSheet(StyleSheet s) 设置要用于呈现各种 HTML 元素的样式集。
void | write(Writer out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
从类 javax.swing.text.StyledEditorKit 继承的方法
getCharacterAttributeRun
从类 javax.swing.text.DefaultEditorKit 继承的方法
createCaret, read, write
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_CSS

public static final String DEFAULT_CSS
用于设置标记视图的默认级联样式表 (Cascading Style Sheet) 文件。

另请参见：
常量字段值

BOLD_ACTION

public static final String BOLD_ACTION
粗体动作标识符

另请参见：
常量字段值

ITALIC_ACTION

public static final String ITALIC_ACTION
斜体动作标识符

另请参见：
常量字段值

PARA_INDENT_LEFT

public static final String PARA_INDENT_LEFT
段落左缩进动作标识符

另请参见：
常量字段值

PARA_INDENT_RIGHT

public static final String PARA_INDENT_RIGHT
段落右缩进动作标识符

另请参见：
常量字段值

FONT_CHANGE_BIGGER

public static final String FONT_CHANGE_BIGGER
字体大小增大到下一个值的动作标识符

另请参见：
常量字段值

FONT_CHANGE_SMALLER

public static final String FONT_CHANGE_SMALLER
字体大小减小到下一个值的动作标识符

另请参见：
常量字段值

COLOR_ACTION

public static final String COLOR_ACTION
Color 选择动作标识符（颜色作为参数传递）

另请参见：
常量字段值

LOGICAL_STYLE_ACTION

public static final String LOGICAL_STYLE_ACTION
逻辑样式选择动作标识符（逻辑样式作为参数传递）

另请参见：
常量字段值

IMG_ALIGN_TOP

public static final String IMG_ALIGN_TOP
将图像顶部对齐。

另请参见：
常量字段值

IMG_ALIGN_MIDDLE

public static final String IMG_ALIGN_MIDDLE
将图像居中对齐。

另请参见：
常量字段值

IMG_ALIGN_BOTTOM

public static final String IMG_ALIGN_BOTTOM
将图像底部对齐。

另请参见：
常量字段值

IMG_BORDER

public static final String IMG_BORDER
将图像对齐到边框。

另请参见：
常量字段值
构造方法详细信息

HTMLEditorKit

public HTMLEditorKit()
构造 HTMLEditorKit，创建 StyleContext，并加载样式表。

方法详细信息

getContentType

public String getContentType()
获取此工具包支持的 MIME 类型的数据。此工具包支持 text/html 类型。

覆盖：
类 DefaultEditorKit 中的 getContentType
返回：
类型

getViewFactory

public ViewFactory getViewFactory()
获取一个适合供由此包所产生的任何模型来产生视图的工厂。

覆盖：
类 StyledEditorKit 中的 getViewFactory
返回：
工厂

createDefaultDocument

public Document createDefaultDocument()
创建一个适合此编辑器类型的未初始化文本存储模型。

覆盖：
类 StyledEditorKit 中的 createDefaultDocument
返回：
模型

read

public void read(Reader in,
                 Document doc,
                 int pos)
          throws IOException,
                 BadLocationException
插入来自给定流的内容。如果 doc 是 HTMLDocument 的一个实例，则这将读取 HTML 3.2 文本。将 HTML 插入非空文档时必须插入到正文 Element 的内部，如果未插入正文中，则抛出一个异常。当插入非空文档时，正文外部的所有标记（头、标题）将被删除。

覆盖：
类 DefaultEditorKit 中的 read
参数：
in - 要从其读取的流
doc - 插入的目标
pos - 在文档中放置内容的位置
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置
RuntimeException - （最终将为 BadLocationException）如果 pos 无效

insertHTML

public void insertHTML(HTMLDocument doc,
                       int offset,
                       String html,
                       int popDepth,
                       int pushDepth,
                       HTML.Tag insertTag)
                throws BadLocationException,
                       IOException
将 HTML 插入现有文档。

参数：
doc - 内容将要插入的文档
offset - HTML 插入位置的偏移量
popDepth - 插入前要生成的 ElementSpec.EndTagTypes 的数量
pushDepth - 插入前但生成结束标记之后，应该生成的 ElementSpec.StartTagTypes 的数量（它具有 ElementSpec.JoinNextDirection 方向）
insertTag - 开始插入文档的首个标记
抛出：
RuntimeException - （最终将为 BadLocationException）如果 pos 无效
BadLocationException
IOException

write

public void write(Writer out,
                  Document doc,
                  int pos,
                  int len)
           throws IOException,
                  BadLocationException
以适合此类内容处理程序的格式，将文档中的内容写入给定流。

覆盖：
类 DefaultEditorKit 中的 write
参数：
out - 要写入的流
doc - 写入的源
pos - 在文档中获取内容的位置
len - 写出量
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 代表文档中的无效位置

install

public void install(JEditorPane c)
将工具包安装到 JEditorPane 中时调用。

覆盖：
类 StyledEditorKit 中的 install
参数：
c - JEditorPane

deinstall

public void deinstall(JEditorPane c)
工具包从 JEditorPane 移除时调用。这可用于取消对任何所关联侦听器的注册。

覆盖：
类 StyledEditorKit 中的 deinstall
参数：
c - JEditorPane

setStyleSheet

public void setStyleSheet(StyleSheet s)
设置要用于呈现各种 HTML 元素的样式集。这些样式是根据 CSS 规范指定的。工具包所生成的每个文档将拥有表的一个副本，它可以向此副本添加特定的文档样式。默认情况下，所有 HTMLEditorKit 实例共享所指定的 StyleSheet。如果需要，应该重新实现它以便提供更细的粒度。

getStyleSheet

public StyleSheet getStyleSheet()
获取当前正用于呈现 HTML 元素的样式集。默认情况下加载 DEFAULT_CSS 所指定的资源，所有 HTMLEditorKit 实例均共享此资源。

getActions

public Action[] getActions()
获取编辑器的命令列表。此命令列表受超类支持，该超类是通过样式操作的本地定义的命令集合扩展的。

覆盖：
类 StyledEditorKit 中的 getActions
返回：
命令列表

createInputAttributes

protected void createInputAttributes(Element element,
                                     MutableAttributeSet set)
将 element 的 AttributeSet 键/值复制到 set 中。此操作不复制组件、图标或者元素名称属性。子类可能希望修改此处要复制什么，不复制什么。确保首先移除 set 中的所有属性。

这在插入符移到一个不同位置时调用。

覆盖：
类 StyledEditorKit 中的 createInputAttributes

getInputAttributes

public MutableAttributeSet getInputAttributes()
获取该样式编辑动作的输入属性。

覆盖：
类 StyledEditorKit 中的 getInputAttributes
返回：
属性集

setDefaultCursor

public void setDefaultCursor(Cursor cursor)
设置默认光标。

从以下版本开始：
1.3

getDefaultCursor

public Cursor getDefaultCursor()
返回默认光标。

从以下版本开始：
1.3

setLinkCursor

public void setLinkCursor(Cursor cursor)
设置要在链接上使用的光标。

从以下版本开始：
1.3

getLinkCursor

public Cursor getLinkCursor()
返回要在超链接上使用的光标。

从以下版本开始：
1.3

isAutoFormSubmission

public boolean isAutoFormSubmission()
指示是否自动处理 html 表单提交，或只是激发 FormSubmitEvent。

返回：
如果自动处理 html 表单提交，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
setAutoFormSubmission(boolean)

setAutoFormSubmission

public void setAutoFormSubmission(boolean isAuto)
指定是否自动处理 html 表单提交，或只是激发 FormSubmitEvent。默认情况下设置为 true。

从以下版本开始：
1.5
另请参见：
isAutoFormSubmission, FormSubmitEvent

clone

public Object clone()
创建编辑器工具包的一个副本。

覆盖：
类 StyledEditorKit 中的 clone
返回：
副本
另请参见：
Cloneable

getParser

protected HTMLEditorKit.Parser getParser()
获取要用于读取 HTML 流的解析器。可以重新实现此方法以提供不同的解析器。默认情况下此实现是动态加载的，以避免加载默认解析器（如果没有使用它）的开销。默认解析器是使用 HTML 3.2 DTD 的 HotJava 解析器。

getAccessibleContext

public AccessibleContext getAccessibleContext()
返回与此编辑器工具包关联的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
与此编辑器工具包关联的 AccessibleContext
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLEditorKit.HTMLFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLEditorKit.HTMLFactory

java.lang.Object
    继承者  javax.swing.text.html.HTMLEditorKit.HTMLFactory
所有已实现的接口：
ViewFactory
正在封闭类：
HTMLEditorKit
public static class HTMLEditorKit.HTMLFactory
extends Object
implements ViewFactory

用于构建 HTML 视图的工厂。下表描述了默认情况下此工厂所构建的视图。

标记 | 创建的视图
HTML.Tag.CONTENT | InlineView
HTML.Tag.IMPLIED | javax.swing.text.html.ParagraphView
HTML.Tag.P | javax.swing.text.html.ParagraphView
HTML.Tag.H1 | javax.swing.text.html.ParagraphView
HTML.Tag.H2 | javax.swing.text.html.ParagraphView
HTML.Tag.H3 | javax.swing.text.html.ParagraphView
HTML.Tag.H4 | javax.swing.text.html.ParagraphView
HTML.Tag.H5 | javax.swing.text.html.ParagraphView
HTML.Tag.H6 | javax.swing.text.html.ParagraphView
HTML.Tag.DT | javax.swing.text.html.ParagraphView
HTML.Tag.MENU | ListView
HTML.Tag.DIR | ListView
HTML.Tag.UL | ListView
HTML.Tag.OL | ListView
HTML.Tag.LI | BlockView
HTML.Tag.DL | BlockView
HTML.Tag.DD | BlockView
HTML.Tag.BODY | BlockView
HTML.Tag.HTML | BlockView
HTML.Tag.CENTER | BlockView
HTML.Tag.DIV | BlockView
HTML.Tag.BLOCKQUOTE | BlockView
HTML.Tag.PRE | BlockView
HTML.Tag.BLOCKQUOTE | BlockView
HTML.Tag.PRE | BlockView
HTML.Tag.IMG | ImageView
HTML.Tag.HR | HRuleView
HTML.Tag.BR | BRView
HTML.Tag.TABLE | javax.swing.text.html.TableView
HTML.Tag.INPUT | FormView
HTML.Tag.SELECT | FormView
HTML.Tag.TEXTAREA | FormView
HTML.Tag.OBJECT | ObjectView
HTML.Tag.FRAMESET | FrameSetView
HTML.Tag.FRAME | FrameView

构造方法摘要
HTMLEditorKit.HTMLFactory()
方法摘要
 View create(Element elem)
根据元素创建视图。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLEditorKit.HTMLFactory

public HTMLEditorKit.HTMLFactory()
方法详细信息

create

public View create(Element elem)
根据元素创建视图。

指定者：
接口 ViewFactory 中的 create
参数：
elem - 元素
返回：
视图
另请参见：
View
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLEditorKit.HTMLTextAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLEditorKit.HTMLTextAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.html.HTMLEditorKit.HTMLTextAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
直接已知子类：
HTMLEditorKit.InsertHTMLTextAction
正在封闭类：
HTMLEditorKit
public abstract static class HTMLEditorKit.HTMLTextAction
extends StyledEditorKit.StyledTextAction

提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。

注：这些便捷方法均不在文档上获得锁定。如果另一个线程正在修改文本，则这些方法可能产生不一致的行为，或者返回错误的结果。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
HTMLEditorKit.HTMLTextAction(String name)
方法摘要
protected int | elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回要获得表示 tag 的元素时，从最深的叶元素开始所需的元素数。
protected Element | findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回在 offset 处与 tag 匹配的最深的元素。
protected Element[] | getElementsAt(HTMLDocument doc, int offset) 返回包含 offset 的 Elements 数组。
protected HTMLDocument | getHTMLDocument(JEditorPane e)
protected HTMLEditorKit | getHTMLEditorKit(JEditorPane e)
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.event.ActionListener 继承的方法
actionPerformed

构造方法详细信息

HTMLEditorKit.HTMLTextAction

public HTMLEditorKit.HTMLTextAction(String name)
方法详细信息

getHTMLDocument

protected HTMLDocument getHTMLDocument(JEditorPane e)
返回：
e 的 HTMLDocument。

getHTMLEditorKit

protected HTMLEditorKit getHTMLEditorKit(JEditorPane e)
返回：
e 的 HTMLEditorKit。

getElementsAt

protected Element[] getElementsAt(HTMLDocument doc,
                                  int offset)
返回包含 offset 的 Elements 数组。首个元素对应于根。

elementCountToTag

protected int elementCountToTag(HTMLDocument doc,
                                int offset,
                                HTML.Tag tag)
返回要获得表示 tag 的元素时，从最深的叶元素开始所需的元素数。如果未找到表示 tag 的元素，则返回 -1，如果 offset 处的叶元素的父元素表示 tag，则返回 0。

findElementMatchingTag

protected Element findElementMatchingTag(HTMLDocument doc,
                                         int offset,
                                         HTML.Tag tag)
返回在 offset 处与 tag 匹配的最深的元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLEditorKit.InsertHTMLTextAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLEditorKit.InsertHTMLTextAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.text.TextAction
            继承者  javax.swing.text.StyledEditorKit.StyledTextAction
                继承者  javax.swing.text.html.HTMLEditorKit.HTMLTextAction
                    继承者  javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
HTMLEditorKit
public static class HTMLEditorKit.InsertHTMLTextAction
extends HTMLEditorKit.HTMLTextAction

InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。至少需要提供两个 HTML.Tag。第一个 Tag 是 parentTag，它标识要向其添加元素的文档中的父级。第二个 Tag 是 addTag，它标识在 HTML 字符串中所看到的、应该被添加到文档中的首个标记。要记住的一个重要问题是解析器将生成所有适当的标记，即使它们不在传入的 HTML 字符串中也是如此。

例如，要创建一个动作，将一个表插入正文中。parentTag 应为 HTML.Tag.BODY，addTag 应为 HTML.Tag.TABLE，并且字符串可以类似于 <table><tr><td></td></tr></table>。

还有一个选项用来提供替换的 parentTag 和 addTag。如果在 offset 处没有 parentTag，则将检查它们。

字段摘要
protected HTML.Tag | addTag HTML 中的 Tag（从此 Tag 开始添加标记）。
protected HTML.Tag | alternateAddTag HTML 中的替换 Tag，如果未找到 parentTag 但找到了 alternateParentTag，则从此替换 Tag 开始添加标记。
protected HTML.Tag | alternateParentTag 如果未找到 parentTag，则要在文档中检查的替换 Tag。
protected String | html 要插入的 HTML。
protected HTML.Tag | parentTag 要在文档中检查的 Tag。
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)
HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)
方法摘要
void | actionPerformed(ActionEvent ae) 将 HTML 插入文档。
protected void | insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
protected void | insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag) HTMLEditorKit.insertHTML 的一个覆盖。
从类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 继承的方法
elementCountToTag, findElementMatchingTag, getElementsAt, getHTMLDocument, getHTMLEditorKit
从类 javax.swing.text.StyledEditorKit.StyledTextAction 继承的方法
getEditor, getStyledDocument, getStyledEditorKit, setCharacterAttributes, setParagraphAttributes
从类 javax.swing.text.TextAction 继承的方法
augmentList, getFocusedComponent, getTextComponent
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

html

protected String html
要插入的 HTML。

parentTag

protected HTML.Tag parentTag
要在文档中检查的 Tag。

addTag

protected HTML.Tag addTag
HTML 中的 Tag（从此 Tag 开始添加标记）。

alternateParentTag

protected HTML.Tag alternateParentTag
如果未找到 parentTag，则要在文档中检查的替换 Tag。

alternateAddTag

protected HTML.Tag alternateAddTag
HTML 中的替换 Tag，如果未找到 parentTag 但找到了 alternateParentTag，则从此替换 Tag 开始添加标记。

构造方法详细信息

HTMLEditorKit.InsertHTMLTextAction

public HTMLEditorKit.InsertHTMLTextAction(String name,
                                          String html,
                                          HTML.Tag parentTag,
                                          HTML.Tag addTag)

HTMLEditorKit.InsertHTMLTextAction

public HTMLEditorKit.InsertHTMLTextAction(String name,
                                          String html,
                                          HTML.Tag parentTag,
                                          HTML.Tag addTag,
                                          HTML.Tag alternateParentTag,
                                          HTML.Tag alternateAddTag)
方法详细信息

insertHTML

protected void insertHTML(JEditorPane editor,
                          HTMLDocument doc,
                          int offset,
                          String html,
                          int popDepth,
                          int pushDepth,
                          HTML.Tag addTag)
HTMLEditorKit.insertHTML 的一个覆盖。如果它抛出了一个异常，则将它包装到 RuntimeException 中并抛出。

insertAtBoundary

protected void insertAtBoundary(JEditorPane editor,
                                HTMLDocument doc,
                                int offset,
                                Element insertElement,
                                String html,
                                HTML.Tag parentTag,
                                HTML.Tag addTag)
当在边界上插入时调用。它确定了弹出数，之后确定需要执行的压入数，然后调用 insertHTML。

从以下版本开始：
1.3

insertAtBoundry

@Deprecated
protected void insertAtBoundry(JEditorPane editor,
                                          HTMLDocument doc,
                                          int offset,
                                          Element insertElement,
                                          String html,
                                          HTML.Tag parentTag,
                                          HTML.Tag addTag)
已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary

当在边界上插入时调用。它确定了弹出数，之后确定需要执行的压入数，然后调用 insertHTML。

actionPerformed

public void actionPerformed(ActionEvent ae)
将 HTML 插入文档。

参数：
ae - 事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLEditorKit.LinkController (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLEditorKit.LinkController

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.text.html.HTMLEditorKit.LinkController
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, Serializable, EventListener
正在封闭类：
HTMLEditorKit
public static class HTMLEditorKit.LinkController
extends MouseAdapter
implements MouseMotionListener, Serializable

此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

构造方法摘要
HTMLEditorKit.LinkController()
方法摘要
protected void | activateLink(int pos, JEditorPane editor) 如果给定位置表示一个链接，则调用关联 JEditorPane 上的 linkActivated。
void | mouseClicked(MouseEvent e) 鼠标单击事件时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
从类 java.awt.event.MouseAdapter 继承的方法
mouseEntered, mouseExited, mousePressed, mouseReleased, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLEditorKit.LinkController

public HTMLEditorKit.LinkController()
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
鼠标单击事件时调用。如果组件是只读的（例如浏览器），则用单击事件驱动一个试图跟随由链接指定的引用。

指定者：
接口 MouseListener 中的 mouseClicked
覆盖：
类 MouseAdapter 中的 mouseClicked
参数：
e - 鼠标事件
另请参见：
MouseListener.mouseClicked(java.awt.event.MouseEvent)

mouseDragged

public void mouseDragged(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseAdapter 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseAdapter 中的 mouseMoved

activateLink

protected void activateLink(int pos,
                            JEditorPane editor)
如果给定位置表示一个链接，则调用关联 JEditorPane 上的 linkActivated。

实现它的目的是为了转发到具有相同名称但后续参数都 == -1 的方法。

参数：
pos - 位置
editor - 编辑器窗格
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLEditorKit.Parser (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLEditorKit.Parser

java.lang.Object
    继承者  javax.swing.text.html.HTMLEditorKit.Parser
直接已知子类：
ParserDelegator
正在封闭类：
HTMLEditorKit
public abstract static class HTMLEditorKit.Parser
extends Object

解析器要支持的接口。这能够在重用此编辑器工具包所提供的某个实现的同时，提供一个不同的解析器。

构造方法摘要
HTMLEditorKit.Parser()
方法摘要
abstract  void parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
解析给定的流并通过解析的结果驱动给定的回调。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HTMLEditorKit.Parser

public HTMLEditorKit.Parser()
方法详细信息

parse

public abstract void parse(Reader r,
                           HTMLEditorKit.ParserCallback cb,
                           boolean ignoreCharSet)
                    throws IOException
解析给定的流并通过解析的结果驱动给定的回调。应该将此方法实现为线程安全的。

抛出：
IOException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLEditorKit.ParserCallback (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLEditorKit.ParserCallback

java.lang.Object
    继承者  javax.swing.text.html.HTMLEditorKit.ParserCallback
直接已知子类：
HTMLDocument.HTMLReader
正在封闭类：
HTMLEditorKit
public static class HTMLEditorKit.ParserCallback
extends Object

解析结果驱动这些回调方法。打开和关闭动作应该是对称的。flush 方法将是最后一个调用的方法，以便接收者有机会将任何挂起的数据刷新到文档中。

有关 AttributeSets 的内容、位置和其他信息，请参考 DocumentParser，它是所使用的默认解析器。

另请参见：
DocumentParser

字段摘要
static Object IMPLIED
这是作为属性集中的一个属性来传递的，用来指示元素是隐含的，例如字符串 '<>foo<\t>' 包含隐含的 html 元素和隐含的正文元素。
构造方法摘要
HTMLEditorKit.ParserCallback()
方法摘要
void | flush()
void | handleComment(char[] data, int pos)
void | handleEndOfLineString(String eol) 它的调用是在完成流的解析之后且在调用 flush 之前。
void | handleEndTag(HTML.Tag t, int pos)
void | handleError(String errorMsg, int pos)
void | handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
void | handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
void | handleText(char[] data, int pos)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IMPLIED

public static final Object IMPLIED
这是作为属性集中的一个属性来传递的，用来指示元素是隐含的，例如字符串 '<>foo<\t>' 包含隐含的 html 元素和隐含的正文元素。

从以下版本开始：
1.3
构造方法详细信息

HTMLEditorKit.ParserCallback

public HTMLEditorKit.ParserCallback()
方法详细信息

flush

public void flush()
           throws BadLocationException
抛出：
BadLocationException

handleText

public void handleText(char[] data,
                       int pos)

handleComment

public void handleComment(char[] data,
                          int pos)

handleStartTag

public void handleStartTag(HTML.Tag t,
                           MutableAttributeSet a,
                           int pos)

handleEndTag

public void handleEndTag(HTML.Tag t,
                         int pos)

handleSimpleTag

public void handleSimpleTag(HTML.Tag t,
                            MutableAttributeSet a,
                            int pos)

handleError

public void handleError(String errorMsg,
                        int pos)

handleEndOfLineString

public void handleEndOfLineString(String eol)
它的调用是在完成流的解析之后且在调用 flush 之前。eol 将是 \n、\r 或 \r\n 中的一个，它是在解析流时最常遇到的。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HTMLFrameHyperlinkEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 HTMLFrameHyperlinkEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.HyperlinkEvent
            继承者  javax.swing.text.html.HTMLFrameHyperlinkEvent
所有已实现的接口：
Serializable
直接已知子类：
FormSubmitEvent
public class HTMLFrameHyperlinkEvent
extends HyperlinkEvent

HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。

嵌套类摘要
从类 javax.swing.event.HyperlinkEvent 继承的嵌套类/接口
HyperlinkEvent.EventType
字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。
方法摘要
 String getTarget()
返回链接的目标。
从类 javax.swing.event.HyperlinkEvent 继承的方法
getDescription, getEventType, getSourceElement, getURL
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HTMLFrameHyperlinkEvent

public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。

参数：
source - 负责事件的对象
type - 事件类型
targetURL - 受影响的 URL
targetFrame - 要在其中显示文档的 Frame

HTMLFrameHyperlinkEvent

public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               String desc,
                               String targetFrame)
创建一个表示超文本链接事件的新对象。

参数：
source - 负责事件的对象
type - 事件类型
targetURL - 受影响的 URL
desc - 描述
targetFrame - 要在其中显示文档的 Frame

HTMLFrameHyperlinkEvent

public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               Element sourceElement,
                               String targetFrame)
创建一个表示超文本链接事件的新对象。

参数：
source - 负责事件的对象
type - 事件类型
targetURL - 受影响的 URL
sourceElement - 对应于事件源的元素
targetFrame - 要在其中显示文档的 Frame

HTMLFrameHyperlinkEvent

public HTMLFrameHyperlinkEvent(Object source,
                               HyperlinkEvent.EventType type,
                               URL targetURL,
                               String desc,
                               Element sourceElement,
                               String targetFrame)
创建一个表示超文本链接事件的新对象。

参数：
source - 负责事件的对象
type - 事件类型
targetURL - 受影响的 URL
desc - 描述
sourceElement - 对应于事件源的元素
targetFrame - 要在其中显示文档的 Frame
方法详细信息

getTarget

public String getTarget()
返回链接的目标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 ImageView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.html.ImageView
所有已实现的接口：
SwingConstants
public class ImageView
extends View

图像视图，用于支持 HTML <IMG> 标记。支持通过标记的 HEIGHT 和 WIDTH 属性进行缩放。如果不能加载图像，则将呈现任何通过 ALT 属性指定的文本。

虽然此类现在已经是 swing 的一部分，但它是从 1.4 版本才开始公开。

从以下版本开始：
1.4
另请参见：
IconView

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
ImageView(Element elem)
创建表示 IMG 元素的新视图。
方法摘要
void | changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 当 Elements 属性已更改时调用。
float | getAlignment(int axis) 确定此视图沿某个轴所需的调整值。
String | getAltText() 如果不能加载图像，则返回要显示的文本。
AttributeSet | getAttributes() 获取呈现时要使用的属性。
Image | getImage() 返回要呈现的图像。
URL | getImageURL() 返回图像源的 URL，如果不能确定图像源，则返回 null。
Icon | getLoadingImageIcon() 返回加载图像过程中要使用的图标。
boolean | getLoadsSynchronously() 如果图像应该在首次被请求时加载，则返回 true。
Icon | getNoImageIcon() 如果不能找到图像，则返回要使用的图标。
float | getPreferredSpan(int axis) 确定此视图沿某轴的首选区域。
protected StyleSheet | getStyleSheet() 获取 StyleSheet 的便捷方法。
String | getToolTipText(float x, float y, Shape allocation) 对于图像，工具提示文本来自于 ALT 属性指定的文本。
Shape | modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | paint(Graphics g, Shape a) 绘制 View。
void | setLoadsSynchronously(boolean newValue) 设置如何加载图像。
void | setParent(View parent) 建立此视图的父视图。
protected void | setPropertiesFromAttributes() 更新来自属性的任何缓存的值。
void | setSize(float width, float height) 设置视图的大小。
int | viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdate, forwardUpdateToView, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getMaximumSpan, getMinimumSpan, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageView

public ImageView(Element elem)
创建表示 IMG 元素的新视图。

参数：
elem - 要为其创建视图的元素
方法详细信息

getAltText

public String getAltText()
如果不能加载图像，则返回要显示的文本。这是从具有属性名称 HTML.Attribute.ALT 的 Elements 属性集获取的。

getImageURL

public URL getImageURL()
返回图像源的 URL，如果不能确定图像源，则返回 null。

getNoImageIcon

public Icon getNoImageIcon()
如果不能找到图像，则返回要使用的图标。

getLoadingImageIcon

public Icon getLoadingImageIcon()
返回加载图像过程中要使用的图标。

getImage

public Image getImage()
返回要呈现的图像。

setLoadsSynchronously

public void setLoadsSynchronously(boolean newValue)
设置如何加载图像。如果 newValue 为 true，则图像将在首次被请求时加载，否则将异步加载。默认是不同步加载，也即异步加载。

getLoadsSynchronously

public boolean getLoadsSynchronously()
如果图像应该在首次被请求时加载，则返回 true。

getStyleSheet

protected StyleSheet getStyleSheet()
获取 StyleSheet 的便捷方法。

getAttributes

public AttributeSet getAttributes()
获取呈现时要使用的属性。实现它的目的是为了使用 StyleSheet 多路传输模型中指定的属性。

覆盖：
类 View 中的 getAttributes

getToolTipText

public String getToolTipText(float x,
                             float y,
                             Shape allocation)
对于图像，工具提示文本来自于 ALT 属性指定的文本。对其进行重写以返回 getAltText。

覆盖：
类 View 中的 getToolTipText
另请参见：
JTextComponent.getToolTipText(java.awt.event.MouseEvent)

setPropertiesFromAttributes

protected void setPropertiesFromAttributes()
更新来自属性的任何缓存的值。

setParent

public void setParent(View parent)
建立此视图的父视图。此时应该缓存您所在的 AWT Container。

覆盖：
类 View 中的 setParent
参数：
parent - 新的父级，如果要从父级中移除视图，则为 null

changedUpdate

public void changedUpdate(DocumentEvent e,
                          Shape a,
                          ViewFactory f)
当 Elements 属性已更改时调用。重新创建图像。

覆盖：
类 View 中的 changedUpdate
参数：
e - 发自关联文档的更改信息
a - 视图的当前分配
f - 视图有子级时用于重建的工厂 View#changedUpdate

paint

public void paint(Graphics g,
                  Shape a)
绘制 View。

指定者：
类 View 中的 paint
参数：
g - 要使用的呈现表面
a - 分配的要在其中呈现的区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图沿某轴的首选区域。

指定者：
类 View 中的 getPreferredSpan
参数：
axis - 可以是 X_AXIS，也可以是 Y_AXIS
返回：
要呈现该视图的区域。通常会告知该视图在返回的区域中呈现，但不保证一定如此；父视图可以选择调整或拆分视图
另请参见：
View.getPreferredSpan(int)

getAlignment

public float getAlignment(int axis)
确定此视图沿某个轴所需的调整值。实现此方法以使图标底部沿 y 轴对齐，而默认是沿 x 轴对齐。

覆盖：
类 View 中的 getAlignment
参数：
axis - 可以是 X_AXIS，也可以是 Y_AXIS
返回：
所需的对齐方式；这应该是 0.0 和 1.0 之间的一个值，其中 0 指示对齐到原点，1.0 指示对齐到区域的边界，0.5 指示对齐到视图的中心

modelToView

public Shape modelToView(int pos,
                         Shape a,
                         Position.Bias b)
                  throws BadLocationException
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

指定者：
类 View 中的 modelToView
参数：
pos - 要转换的位置
a - 分配的要在其中呈现的区域
b - 当位置是两个视图的边界时，该参数是离由偏移量表示的前一个字符或者下一个字符的偏差；b 将是这些值之一：
  • Position.Bias.Forward
  • Position.Bias.Backward
返回：
给定位置的边界框
抛出：
BadLocationException - 如果给定位置在所关联的文档中不是一个有效位置
另请参见：
View.modelToView(int, java.awt.Shape, javax.swing.text.Position.Bias)

viewToModel

public int viewToModel(float x,
                       float y,
                       Shape a,
                       Position.Bias[] bias)
提供从视图坐标空间到该模型的逻辑坐标空间的映射。

指定者：
类 View 中的 viewToModel
参数：
x - X 坐标
y - Y 坐标
a - 要在其中呈现的分配区域
返回：
模型中最能代表视图中给定点的位置
另请参见：
View.viewToModel(float, float, java.awt.Shape, javax.swing.text.Position.Bias[])

setSize

public void setSize(float width,
                    float height)
设置视图的大小。如果此方法有任何布局任务，则会导致布局视图。

覆盖：
类 View 中的 setSize
参数：
width - 宽度，其值 >= 0
height - 高度，其值 >= 0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InlineView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 InlineView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.GlyphView
            继承者  javax.swing.text.LabelView
                继承者  javax.swing.text.html.InlineView
所有已实现的接口：
Cloneable, SwingConstants, TabableView
public class InlineView
extends LabelView

显示基于 css 属性的 inline element 样式。

嵌套类摘要
从类 javax.swing.text.GlyphView 继承的嵌套类/接口
GlyphView.GlyphPainter
字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
InlineView(Element elem)
构造在元素上包装的新视图。
方法摘要
View | breakView(int axis, int offset, float pos, float len) 尝试在给定轴上拆分此视图。
void | changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
AttributeSet | getAttributes() 获取呈现时要使用的属性。
int | getBreakWeight(int axis, float pos, float len) 确定此视图拆分的可能性有多大。
protected StyleSheet | getStyleSheet()
void | insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
protected void | setPropertiesFromAttributes() 从 attribute 设置缓存的属性。
从类 javax.swing.text.LabelView 继承的方法
getBackground, getFont, getFontMetrics, getForeground, isStrikeThrough, isSubscript, isSuperscript, isUnderline, setBackground, setStrikeThrough, setSubscript, setSuperscript, setUnderline
从类 javax.swing.text.GlyphView 继承的方法
checkPainter, clone, createFragment, getAlignment, getEndOffset, getGlyphPainter, getNextVisualPositionFrom, getPartialSpan, getPreferredSpan, getStartOffset, getTabbedSpan, getTabExpander, getText, modelToView, paint, setGlyphPainter, viewToModel
从类 javax.swing.text.View 继承的方法
append, forwardUpdate, forwardUpdateToView, getChildAllocation, getContainer, getDocument, getElement, getGraphics, getMaximumSpan, getMinimumSpan, getParent, getResizeWeight, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, replace, setParent, setSize, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.text.TabableView 继承的方法
getPartialSpan, getTabbedSpan

构造方法详细信息

InlineView

public InlineView(Element elem)
构造在元素上包装的新视图。

参数：
elem - 所需元素
方法详细信息

insertUpdate

public void insertUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
发出通知，通知文档中此视图负责的位置已插入内容。如果任何一个参数为 null，则此方法的行为将取决于实现。

覆盖：
类 GlyphView 中的 insertUpdate
参数：
e - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
从以下版本开始：
1.5
另请参见：
View.insertUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

removeUpdate

public void removeUpdate(DocumentEvent e,
                         Shape a,
                         ViewFactory f)
发出通知，通知文档中此视图负责的位置已移除内容。如果任何一个参数为 null，则此方法的行为将取决于实现。

覆盖：
类 GlyphView 中的 removeUpdate
参数：
e - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
从以下版本开始：
1.5
另请参见：
View.removeUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

changedUpdate

public void changedUpdate(DocumentEvent e,
                          Shape a,
                          ViewFactory f)
发出通知，通知文档此视图负责的位置处的属性已更改。

覆盖：
类 LabelView 中的 changedUpdate
参数：
e - 来自相关文档的更改信息
a - 视图的当前分配区域
f - 用于重建的工厂（如果该视图有子级）
另请参见：
View.changedUpdate(javax.swing.event.DocumentEvent, java.awt.Shape, javax.swing.text.ViewFactory)

getAttributes

public AttributeSet getAttributes()
获取呈现时要使用的属性。实现它的目的是为了使用 StyleSheet 多路传输模型中指定的属性。

覆盖：
类 View 中的 getAttributes

getBreakWeight

public int getBreakWeight(int axis,
                          float pos,
                          float len)
确定此视图拆分的可能性有多大。这可用于确定在格式化过程中哪个视图最需要调用 breakView。例如，对于表示文本的视图，包含空格的视图比不包含空格的视图可能更需要调用此方法。权重越高，需要拆分的可能性越大。值等于或小于 BadBreakWeight 时不考虑拆分。值大于或等于 ForcedBreakWeight 时应该拆分视图。

实现它的目的是为了提供返回 BadBreakWeight 的默认行为，除非长度大于视图的长度，这种情况下整个视图将表示片段。除非在编写视图时支持拆分行为，否则不需要尝试和拆分视图。支持拆分的一个视图示例是 LabelView。使用拆分权重的一个视图示例是 ParagraphView。

覆盖：
类 GlyphView 中的 getBreakWeight
参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
pos - 已拆分视图的潜在起始位置，该值 >= 0。这可能对计算选项卡的位置有用。
len - 指定从 pos（此处可能需要拆分）开始的相对长度，其值 >= 0。
返回：
权重，它应该是 ForcedBreakWeight 和 BadBreakWeight 之间的一个值。
另请参见：
LabelView, ParagraphView, View.BadBreakWeight, View.GoodBreakWeight, View.ExcellentBreakWeight, View.ForcedBreakWeight

breakView

public View breakView(int axis,
                      int offset,
                      float pos,
                      float len)
尝试在给定轴上拆分此视图。有关此方法的完整描述，请参阅 View.breakView(int, int, float, float)。

如果 axis 既不是 View.X_AXIS，也不是 View.Y_AXIS，或者 offset、pos 或 len 为 null，则此方法的行为是不确定的。

覆盖：
类 GlyphView 中的 breakView
参数：
axis - 可以是 View.X_AXIS，也可以是 View.Y_AXIS
offset - 拆分后的片段将要在文档模型中占用的位置，其值 >= 0。这应该是返回的片段的初始偏移量
pos - 拆分后的视图将沿轴占用的位置，其值 >= 0。这可能对于诸如制表符计算这样的操作很有用
len - 指定了沿轴（可能需要在此轴上进行拆分）的距离，其值 >= 0
返回：
表示给定区域的视图片段。
从以下版本开始：
1.5
另请参见：
View.breakView(int, int, float, float)

setPropertiesFromAttributes

protected void setPropertiesFromAttributes()
从 attribute 设置缓存的属性。

覆盖：
类 LabelView 中的 setPropertiesFromAttributes

getStyleSheet

protected StyleSheet getStyleSheet()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 ListView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.html.BlockView
                    继承者  javax.swing.text.html.ListView
所有已实现的接口：
SwingConstants
public class ListView
extends BlockView

用于显示 html 列表的视图实现。

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
ListView(Element elem)
创建表示列表元素的新视图。
方法摘要
 float getAlignment(int axis)
计算所需的列表形状。
 void paint(Graphics g, Shape allocation)
使用给定呈现面和该表面的区域呈现。
protected  void paintChild(Graphics g, Rectangle alloc, int index)
通过调用 paint() 绘制其中的一个子级。
protected  void setPropertiesFromAttributes()
更新来自属性的任何缓存的值。
从类 javax.swing.text.html.BlockView 继承的方法
calculateMajorAxisRequirements, calculateMinorAxisRequirements, changedUpdate, getAttributes, getMaximumSpan, getMinimumSpan, getPreferredSpan, getResizeWeight, getStyleSheet, layoutMinorAxis, setParent
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, childAllocation, flipEastAndWestAtEnds, forwardUpdate, getAxis, getChildAllocation, getHeight, getOffset, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layout, layoutChanged, layoutMajorAxis, modelToView, preferenceChanged, replace, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextNorthSouthVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, getViewIndexAtPosition, loadChildren, modelToView, setInsets, setParagraphInsets
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdateToView, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, insertUpdate, isVisible, modelToView, remove, removeAll, removeUpdate, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ListView

public ListView(Element elem)
创建表示列表元素的新视图。

参数：
elem - 要为其创建视图的元素
方法详细信息

getAlignment

public float getAlignment(int axis)
计算所需的列表形状。

覆盖：
类 BlockView 中的 getAlignment
参数：
axis - 可以是 X_AXIS，也可以是 Y_AXIS
返回：
所需的区域
另请参见：
View.getPreferredSpan(int)

paint

public void paint(Graphics g,
                  Shape allocation)
使用给定呈现面和该表面的区域呈现。

覆盖：
类 BlockView 中的 paint
参数：
g - 要使用的呈现表面
allocation - 分配的要在其中呈现的区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

paintChild

protected void paintChild(Graphics g,
                          Rectangle alloc,
                          int index)
通过调用 paint() 绘制其中的一个子级。默认情况下，这是它的全部动作，但子类可以使用此方法来绘制与此子级相关的对象。

覆盖：
类 BoxView 中的 paintChild
参数：
g - 图形上下文
alloc - 分配的要在其中呈现的区域
index - 子级的索引

setPropertiesFromAttributes

protected void setPropertiesFromAttributes()
从类 BlockView 复制的描述
更新来自属性的任何缓存的值。

覆盖：
类 BlockView 中的 setPropertiesFromAttributes
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MinimalHTMLWriter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 MinimalHTMLWriter

java.lang.Object
    继承者  javax.swing.text.AbstractWriter
        继承者  javax.swing.text.html.MinimalHTMLWriter

public class MinimalHTMLWriter
extends AbstractWriter

MinimalHTMLWriter 是一个回退 writer，HTMLEditorKit 使用它为非 EditorKit 生成的文档写出 HTML。 文档的格式为：

 <html>
   <head>
     <style>
        <!-- list of named styles
         p.normal {
            font-family: SansSerif;
              margin-height: 0;
              font-size: 14
           }
        -->
      </style>
   </head>
   <body>
    <p style=normal>
        Bold, italic, and underline attributes
        of the run are emitted as HTML tags.
        The remaining attributes are emitted as
        part of the style attribute of a <span> tag.
        The syntax is similar to inline styles.
</p>
   </body>
 </html>

字段摘要
从类 javax.swing.text.AbstractWriter 继承的字段
NEWLINE
构造方法摘要
MinimalHTMLWriter(Writer w, StyledDocument doc)
创建一个新的 MinimalHTMLWriter。
MinimalHTMLWriter(Writer w, StyledDocument doc, int pos, int len)
创建一个新的 MinimalHTMLWriter。
方法摘要
protected  void endFontTag()
此方法已不再使用，而用写出 <span> 来替换。
protected  boolean inFontTag()
如果我们当前正处在 <font> 标记中，则返回 true。
protected  boolean isText(Element elem)
如果元素是文本元素，则返回 true。
protected  void startFontTag(String style)
此方法已不再使用，而用写出 <span> 来替换。
protected  void text(Element elem)
写出文本。
 void write()
从 StyledDocument 生成 HTML 输出。
protected  void writeAttributes(AttributeSet attr)
写出以下类型的所有属性：StyleConstants.ParagraphConstants、StyleConstants.CharacterConstants、StyleConstants.FontConstants、StyleConstants.ColorConstants。
protected  void writeBody()
对文档中的元素进行迭代，并基于元素是分支元素还是叶元素来处理它们。
protected  void writeComponent(Element elem)
负责处理 Component Elements；有意不实现它。
protected  void writeContent(Element elem, boolean needsIndenting)
以与 HTML 兼容的方式写出属性集。
protected  void writeEndParagraph()
发出 <p> 标记的结束标记。
protected  void writeEndTag(String endTag)
写出适当缩进的结束标记。
protected  void writeHeader()
写出 <head> 和 <style> 标记，然后调用 writeStyles()，以写出所有命名的样式，这些样式作为 <style> 标记的内容。
protected  void writeHTMLTags(AttributeSet attr)
基于文本的属性设置生成文本的 bold <b>、italic <i> 和 <u> 标记。
protected  void writeImage(Element elem)
负责处理 Icon Elements；有意不实现它。
protected  void writeLeaf(Element elem)
负责写出其他非文本叶元素。
protected  void writeNonHTMLAttributes(AttributeSet attr)
以与 HTML 兼容的方式写出其余的字符级属性（bold、italic 和 underline 之外的属性）。
protected  void writeStartParagraph(Element elem)
发出段落的开始标记。
protected  void writeStartTag(String tag)
写出适当缩进的开始标记。
protected  void writeStyles()
写出所有命名的样式，这些样式作为 <style> 标记的内容。
从类 javax.swing.text.AbstractWriter 继承的方法
decrIndent, getCanWrapLines, getCurrentLineLength, getDocument, getElementIterator, getEndOffset, getIndentLevel, getIndentSpace, getLineLength, getLineSeparator, getStartOffset, getText, getWriter, incrIndent, indent, inRange, isLineEmpty, output, setCanWrapLines, setCurrentLineLength, setIndentSpace, setLineLength, setLineSeparator, write, write, write, writeLineSeparator
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MinimalHTMLWriter

public MinimalHTMLWriter(Writer w,
                         StyledDocument doc)
创建一个新的 MinimalHTMLWriter。

参数：
w - Writer
doc - StyledDocument

MinimalHTMLWriter

public MinimalHTMLWriter(Writer w,
                         StyledDocument doc,
                         int pos,
                         int len)
创建一个新的 MinimalHTMLWriter。

参数：
w - Writer
doc - StyledDocument
pos - 文档中要获取内容的位置。
len - 写出量。
方法详细信息

write

public void write()
           throws IOException,
                  BadLocationException
从 StyledDocument 生成 HTML 输出。

指定者：
类 AbstractWriter 中的 write
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的一个无效位置

writeAttributes

protected void writeAttributes(AttributeSet attr)
                        throws IOException
写出以下类型的所有属性：StyleConstants.ParagraphConstants、StyleConstants.CharacterConstants、StyleConstants.FontConstants、StyleConstants.ColorConstants。属性名称和值用冒号隔开。每个名称值对都用分号隔开。

覆盖：
类 AbstractWriter 中的 writeAttributes
参数：
attr - AttributeSet。
抛出：
IOException - 如果发生任何 I/O 错误

text

protected void text(Element elem)
             throws IOException,
                    BadLocationException
写出文本。

覆盖：
类 AbstractWriter 中的 text
参数：
elem - Element。
抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的一个无效位置

writeStartTag

protected void writeStartTag(String tag)
                      throws IOException
写出适当缩进的开始标记。还可以增加缩进量。

抛出：
IOException - 如果发生任何 I/O 错误

writeEndTag

protected void writeEndTag(String endTag)
                    throws IOException
写出适当缩进的结束标记。还可以减少缩进量。

抛出：
IOException - 如果发生任何 I/O 错误

writeHeader

protected void writeHeader()
                    throws IOException
写出 <head> 和 <style> 标记，然后调用 writeStyles()，以写出所有命名的样式，这些样式作为 <style> 标记的内容。内容周围带有有效的 HTML 注释标记，以确保文档在不支持标记的应用程序/浏览器中能够被看到。

抛出：
IOException - 如果发生任何 I/O 错误

writeStyles

protected void writeStyles()
                    throws IOException
写出所有命名的样式，这些样式作为 <style> 标记的内容。

抛出：
IOException - 如果发生任何 I/O 错误

writeBody

protected void writeBody()
                  throws IOException,
                         BadLocationException
对文档中的元素进行迭代，并基于元素是分支元素还是叶元素来处理它们。此方法对作为文本的叶元素进行特殊处理。

抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException

writeEndParagraph

protected void writeEndParagraph()
                          throws IOException
发出 <p> 标记的结束标记。写出标记之前，此方法确保正确关闭所有已打开的其他标记。

抛出：
IOException - 如果发生任何 I/O 错误

writeStartParagraph

protected void writeStartParagraph(Element elem)
                            throws IOException
发出段落的开始标记。如果段落具有与此方法关联的指定样式，则此方法还生成 <p> 标记的类属性，并将其值设置为样式的名称。

抛出：
IOException - 如果发生任何 I/O 错误

writeLeaf

protected void writeLeaf(Element elem)
                  throws IOException
负责写出其他非文本叶元素。

抛出：
IOException - 如果发生任何 I/O 错误

writeImage

protected void writeImage(Element elem)
                   throws IOException
负责处理 Icon Elements；有意不实现它。如何实现此方法是一个策略问题。例如，如果您正在生成 <img> 标记，那么您应该如何表示 src 属性呢（图像的位置）？某些情况下它将是 URL，而其他情况下则可能是从流中读取。

参数：
elem - StyleConstants.IconElementName 类型元素
抛出：
IOException

writeComponent

protected void writeComponent(Element elem)
                       throws IOException
负责处理 Component Elements；有意不实现它。如何实现此方法是一个策略问题。

抛出：
IOException

isText

protected boolean isText(Element elem)
如果元素是文本元素，则返回 true。

writeContent

protected void writeContent(Element elem,
                            boolean needsIndenting)
                     throws IOException,
                            BadLocationException
以与 HTML 兼容的方式写出属性集。

抛出：
IOException - 如果发生任何 I/O 错误
BadLocationException - 如果 pos 表示文档中的一个无效位置

writeHTMLTags

protected void writeHTMLTags(AttributeSet attr)
                      throws IOException
基于文本的属性设置生成文本的 bold <b>、italic <i> 和 <u> 标记。

抛出：
IOException - 如果发生任何 I/O 错误

writeNonHTMLAttributes

protected void writeNonHTMLAttributes(AttributeSet attr)
                               throws IOException
以与 HTML 兼容的方式写出其余的字符级属性（bold、italic 和 underline 之外的属性）。因为字体系列和字体大小这样的属性没有到 HTML 标记的直接映射，因此生成一个 <span> 标记并将其样式属性设置为包含其余属性（如内嵌样式）的列表。

抛出：
IOException - 如果发生任何 I/O 错误

inFontTag

protected boolean inFontTag()
如果我们当前正处在 <font> 标记中，则返回 true。

endFontTag

protected void endFontTag()
                   throws IOException
此方法已不再使用，而用写出 <span> 来替换。

写出 <font> 标记的结束标记。

抛出：
IOException - 如果发生任何 I/O 错误

startFontTag

protected void startFontTag(String style)
                     throws IOException
此方法已不再使用，而用写出 <span> 来替换。

写出 <font> 标记的开始标记。因为字体标记不能嵌套，所以在此方法写出新的开始标记之前将关闭任何打开的字体标记。

抛出：
IOException - 如果发生任何 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 ObjectView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.ComponentView
            继承者  javax.swing.text.html.ObjectView
所有已实现的接口：
SwingConstants
public class ObjectView
extends ComponentView

实现 <object> 元素视图接口的组件装饰符。

此视图将尝试加载由 classid 属性指定的类。如有可能，将使用用来加载相关文档的 Classloader。这通常与用于加载 EditorKit 的 ClassLoader 相同。如果文档的 ClassLoader 为 null，将使用 Class.forName。

如果可以成功地加载该类，则会尝试通过调用 Class.newInstance 来创建该类的一个实例。通过输入 java.awt.Component 尝试缩小该实例以便显示对象。

此视图还可以管理具有某些限制的参数集。期望 <object> 元素的参数以简单的字符串形式出现在相关元素的属性集中。每个 bean 属性都将作为 AttributeSet 的关键字来查询，并期望在属性具有参数规范时显示（类型字符串的）非 null 值。Reflection 将用来设置参数。当前，这仅限于非常简单的类型 String 的单个参数。

下面是一个简单的 HTML 调用示例：

      <object classid="javax.swing.JLabel">
      <param name="text" value="sample text">
      </object>

字段摘要
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
ObjectView(Element elem)
创建新的 ObjectView 对象。
方法摘要
protected  Component createComponent()
创建组件。
从类 javax.swing.text.ComponentView 继承的方法
getAlignment, getComponent, getMaximumSpan, getMinimumSpan, getPreferredSpan, modelToView, paint, setParent, viewToModel
从类 javax.swing.text.View 继承的方法
append, breakView, changedUpdate, createFragment, forwardUpdate, forwardUpdateToView, getAttributes, getBreakWeight, getChildAllocation, getContainer, getDocument, getElement, getEndOffset, getGraphics, getNextVisualPositionFrom, getParent, getResizeWeight, getStartOffset, getToolTipText, getView, getViewCount, getViewFactory, getViewIndex, getViewIndex, insert, insertUpdate, isVisible, modelToView, modelToView, preferenceChanged, remove, removeAll, removeUpdate, replace, setSize, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectView

public ObjectView(Element elem)
创建新的 ObjectView 对象。

参数：
elem - 要修饰的元素
方法详细信息

createComponent

protected Component createComponent()
创建组件。classid 将用作尝试加载的类名称规范。

覆盖：
类 ComponentView 中的 createComponent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Option (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 Option

java.lang.Object
    继承者  javax.swing.text.html.Option
所有已实现的接口：
Serializable
public class Option
extends Object
implements Serializable

用来表示 <option> 元素的 ListModel 值。这是一个作为 DefaultComboBoxModel 的项安装的对象，用来表示 <select> 元素。

警告： 此类的序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已经在 java.beans 包添加了对所有 JavaBeansTM 长期存储的支持。请参阅 XMLEncoder。

构造方法摘要
Option(AttributeSet attr)
创建新的 Option 对象。
方法摘要
AttributeSet | getAttributes() 获取与此选项相关的属性。
String | getLabel() 获取与该选项相关的标签。
String | getValue() 返回与 value 属性相关的字符串的便捷方法。
boolean | isSelected() 获取与此选项相关的选定状态。
void | setLabel(String label) 设置该选项使用的标签。
protected void | setSelection(boolean state) 设置选定的状态。
String | toString() String 的表示形式为 label。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Option

public Option(AttributeSet attr)
创建新的 Option 对象。

参数：
attr - 与选项元素相关的属性。复制这些属性以确保它们不更改。
方法详细信息

setLabel

public void setLabel(String label)
设置该选项使用的标签。

getLabel

public String getLabel()
获取与该选项相关的标签。

getAttributes

public AttributeSet getAttributes()
获取与此选项相关的属性。

toString

public String toString()
String 的表示形式为 label。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

setSelection

protected void setSelection(boolean state)
设置选定的状态。

isSelected

public boolean isSelected()
获取与此选项相关的选定状态。

getValue

public String getValue()
返回与 value 属性相关的字符串的便捷方法。如果没有指定值，则返回 label。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParagraphView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 ParagraphView

java.lang.Object
    继承者  javax.swing.text.View
        继承者  javax.swing.text.CompositeView
            继承者  javax.swing.text.BoxView
                继承者  javax.swing.text.FlowView
                    继承者  javax.swing.text.ParagraphView
                        继承者  javax.swing.text.html.ParagraphView
所有已实现的接口：
SwingConstants, TabExpander
public class ParagraphView
extends ParagraphView

显示段落，并使用 css 属性作为其配置。

嵌套类摘要
从类 javax.swing.text.FlowView 继承的嵌套类/接口
FlowView.FlowStrategy
字段摘要
从类 javax.swing.text.ParagraphView 继承的字段
firstLineIndent
从类 javax.swing.text.FlowView 继承的字段
layoutPool, layoutSpan, strategy
从类 javax.swing.text.View 继承的字段
BadBreakWeight, ExcellentBreakWeight, ForcedBreakWeight, GoodBreakWeight, X_AXIS, Y_AXIS
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
ParagraphView(Element elem)
构造给定元素的 ParagraphView。
方法摘要
protected SizeRequirements | calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算段落沿辅轴的要求。
AttributeSet | getAttributes() 获取呈现时所使用的属性。
float | getMaximumSpan(int axis) 确定此视图沿某轴的最大区域。
float | getMinimumSpan(int axis) 确定此视图沿某轴的最小区域。
float | getPreferredSpan(int axis) 确定此视图的首选区域。
protected StyleSheet | getStyleSheet()
boolean | isVisible() 指示是否应显示此视图。
void | paint(Graphics g, Shape a) 使用给定的呈现面和该面上的区域进行呈现。
void | setParent(View parent) 建立此视图的父视图。
protected void | setPropertiesFromAttributes() 通过 css 属性设置段落，而不是根据 StyleConstants 中的值（即超类所使用的值）设置段落。
从类 javax.swing.text.ParagraphView 继承的方法
adjustRow, breakView, changedUpdate, createRow, findOffsetToCharactersInString, flipEastAndWestAtEnds, getAlignment, getBreakWeight, getClosestPositionTo, getFlowSpan, getFlowStart, getLayoutView, getLayoutViewCount, getNextNorthSouthVisualPositionFrom, getPartialSize, getTabBase, getTabSet, nextTabStop, setFirstLineIndent, setJustification, setLineSpacing
从类 javax.swing.text.FlowView 继承的方法
getFlowAxis, getViewIndexAtPosition, insertUpdate, layout, loadChildren, removeUpdate
从类 javax.swing.text.BoxView 继承的方法
baselineLayout, baselineRequirements, calculateMajorAxisRequirements, childAllocation, forwardUpdate, getAxis, getChildAllocation, getHeight, getOffset, getResizeWeight, getSpan, getViewAtPoint, getWidth, isAfter, isAllocationValid, isBefore, isLayoutValid, layoutChanged, layoutMajorAxis, layoutMinorAxis, modelToView, paintChild, preferenceChanged, replace, setAxis, setSize, viewToModel
从类 javax.swing.text.CompositeView 继承的方法
getBottomInset, getInsideAllocation, getLeftInset, getNextEastWestVisualPositionFrom, getNextVisualPositionFrom, getRightInset, getTopInset, getView, getViewAtPosition, getViewCount, getViewIndex, modelToView, setInsets, setParagraphInsets
从类 javax.swing.text.View 继承的方法
append, breakView, createFragment, forwardUpdateToView, getBreakWeight, getContainer, getDocument, getElement, getEndOffset, getGraphics, getParent, getStartOffset, getToolTipText, getViewFactory, getViewIndex, insert, modelToView, remove, removeAll, updateChildren, updateLayout, viewToModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ParagraphView

public ParagraphView(Element elem)
构造给定元素的 ParagraphView。

参数：
elem - 此视图负责的元素
方法详细信息

setParent

public void setParent(View parent)
建立此视图的父视图。在父视图功能正常的情况下，此操作可保证在调用其他任何方法之前先调用该方法。

实现此方法可转发超类和调用 setPropertiesFromAttributes 方法，以便通过 css 属性设置段落属性。此时进行调用可确保能够通过父视图属性向上进行解析。

覆盖：
类 FlowView 中的 setParent
参数：
parent - 新父级，如果该视图正从其以前添加到的父视图中移除，则返回 null

getAttributes

public AttributeSet getAttributes()
获取呈现时所使用的属性。实现此方法以便多路传输 StyleSheet 模型中指定的属性。

覆盖：
类 View 中的 getAttributes

setPropertiesFromAttributes

protected void setPropertiesFromAttributes()
通过 css 属性设置段落，而不是根据 StyleConstants 中的值（即超类所使用的值）设置段落。

覆盖：
类 ParagraphView 中的 setPropertiesFromAttributes

getStyleSheet

protected StyleSheet getStyleSheet()

calculateMinorAxisRequirements

protected SizeRequirements calculateMinorAxisRequirements(int axis,
                                                          SizeRequirements r)
计算段落沿辅轴的要求。实现此方法以便使用超类的要求，然后稍加修改来设置允许的最小区域。典型的 html 呈现不会让视图大小小于最长的字的长度。

覆盖：
类 FlowView 中的 calculateMinorAxisRequirements
参数：
axis - 所考察的轴
r - SizeRequirements 对象；如果为 null，将创建一个对象
返回：
新初始化的 SizeRequirements 对象
另请参见：
SizeRequirements

isVisible

public boolean isVisible()
指示是否应显示此视图。如果不希望显示任何子级，并且惟一的可视子级是结束段落的中断，则不认为这是一个可视段落。否则，则认为该段落为可视段落，并返回 true。

覆盖：
类 View 中的 isVisible
返回：
如果应显示该段落，则返回 true

paint

public void paint(Graphics g,
                  Shape a)
使用给定的呈现面和该面上的区域进行呈现。实现此方法以便在中断用作选项卡计算的基坐标之后委托给超类。

覆盖：
类 ParagraphView 中的 paint
参数：
g - 要使用的呈现表面
a - 分配的要在其中呈现的区域
另请参见：
View.paint(java.awt.Graphics, java.awt.Shape)

getPreferredSpan

public float getPreferredSpan(int axis)
确定此视图的首选区域。如果该视图不可见，则返回 0，否则，将调用超类方法来获取沿某轴的首选区域。

覆盖：
类 BoxView 中的 getPreferredSpan
参数：
axis - 要么是 View.X_AXIS，要么是 View.Y_AXIS
返回：
该视图可能要在其中呈现的区域；通常会告知视图要呈现在返回的区域中，但不能保证一定如此；父级可能会选择调整或拆分该视图
另请参见：
BoxView.getPreferredSpan(int)

getMinimumSpan

public float getMinimumSpan(int axis)
确定此视图沿某轴的最小区域。如果该视图不可见，则返回 0，否则，将调用 superclass 方法来获取最小区域。

覆盖：
类 BoxView 中的 getMinimumSpan
参数：
axis - 要么是 View.X_AXIS，要么是 View.Y_AXIS
返回：
该视图可在其中呈现的最小区域
另请参见：
BoxView.getMinimumSpan(int)

getMaximumSpan

public float getMaximumSpan(int axis)
确定此视图沿某轴的最大区域。如果该视图不可见，则返回 0，否则，将调用 superclass 方法来获取最大区域。

覆盖：
类 BoxView 中的 getMaximumSpan
参数：
axis - 要么是 View.X_AXIS，要么是 View.Y_AXIS
返回：
该视图可在其中呈现的最大区域
另请参见：
BoxView.getMaximumSpan(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleSheet (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 StyleSheet

java.lang.Object
    继承者  javax.swing.text.StyleContext
        继承者  javax.swing.text.html.StyleSheet
所有已实现的接口：
Serializable, AbstractDocument.AttributeContext
public class StyleSheet
extends StyleContext

支持定义要呈现的 HTML 视图的可视化特征。该 StyleSheet 用于将 HTML 模型转换为具有可视化特征的视图。此类可自定义视图的外观、通过一个模型分别呈现多个视图等等。该类可以看作 CSS 规则的存储库。CSS 属性的键是类型 CSS.Attribute 的对象。值类型由 StyleSheet 实现决定，但需要 toString 方法返回 CSS 值的字符串表示形式。

获取其属性的 HTML View 实现的主要入口点是 getViewAttributes 方法。通过创建所需的用来将属性与视图关联的策略来实现这一方法。每个 HTMLEditorKit（也即每个关联的 JEditorPane）都可以有其自己的 StyleSheet，但默认情况下，所有 HTMLEditorKit 实例都将共享一个表。HTMLDocument 实例还可以有一个 StyleSheet，它用来存储特定于文档的 CSS 规范。

为使 View 存储较少的状态并因此变得更轻量级，StyleSheet 可充当处理某些呈现任务的 painter 的工厂。此方法允许实现来确定要缓存的内容，以及在选择器通常为多视图的级别上可能共享的内容。由于 StyleSheet 可以由面向多个文档的视图使用，并且通常 HTML 属性不影响使用的选择器，所以共享选择器的可能性非常大。

这些规则是按指定样式存储的，并且还存储了其他信息以便将元素的上下文快速转换为一个规则。以下代码片段将显示指定的样式，以及由此所包含的 CSS 规则。

   import java.util.*;
   import javax.swing.text.*;
   import javax.swing.text.html.*;

   public class ShowStyles {

       public static void main(String[] args) {
           HTMLEditorKit kit = new HTMLEditorKit();
           HTMLDocument doc = (HTMLDocument) kit.createDefaultDocument();
           StyleSheet styles = doc.getStyleSheet();

           Enumeration rules = styles.getStyleNames();
           while (rules.hasMoreElements()) {
               String name = (String) rules.nextElement();
               Style rule = styles.getStyle(name);
               System.out.println(rule.toString());
           }
           System.exit(0);
       }
   }

此语义用于 CSS 样式未良好定义的情况，在这种情况下，CSS 样式应根据元素的定义重写可视属性。例如，html <body bgcolor=red> 将使主体呈现为红色背景。但如果该 html 文件还包含 CSS 规则 body { background:blue }，则该主体的背景就没有它该呈现的颜色清晰了。当前的实现为在元素中定义的可视属性提供了最高优先权，也就是说在应用任何样式之前都要先检查它们。因此，在前面的示例中，当主体元素将背景颜色定义为红色时，其背景也将成为红色。

正如前面提到的那样，此方法支持 CSS。我们不提供对所有 CSS 规范的支持。请参考 CSS 类的 javadoc 以查看我们支持的属性。我们当前不支持的两种主要的 CSS 解析相关的概念是伪选择器，如 A:link { color:red } 和 important 修饰符。

注：此实现目前尚不完整。可以使用完整的替代实现来取代它。此类的未来版本将提供更好的 CSS 支持。

嵌套类摘要
static class | StyleSheet.BoxPainter 可以执行某些 CSS 格式化任务的类。
static class | StyleSheet.ListPainter 要执行某些 CSS 列表格式化任务的类。
从类 javax.swing.text.StyleContext 继承的嵌套类/接口
StyleContext.NamedStyle, StyleContext.SmallAttributeSet
字段摘要
从类 javax.swing.text.StyleContext 继承的字段
DEFAULT_STYLE
构造方法摘要
StyleSheet()
构造 StyleSheet
方法摘要
AttributeSet | addAttribute(AttributeSet old, Object key, Object value) 向给定集合添加属性，并返回新的表示方式的集合。
AttributeSet | addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
void | addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。
boolean | addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。
void | addRule(String rule) 向 sheet 添加规则集合。
void | addStyleSheet(StyleSheet ss) 将 StyleSheet ss 中的规则添加到接收者的规则中。
protected MutableAttributeSet | createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
protected StyleContext.SmallAttributeSet | createSmallAttributeSet(AttributeSet a) 创建可以共享的属性压缩集。
Color | getBackground(AttributeSet a) 获取一个属性集并将其转换为背景色规范。
URL | getBase() 返回 base。
StyleSheet.BoxPainter | getBoxPainter(AttributeSet a) 获取给定 CSS 属性集合使用的框 formatter。
AttributeSet | getDeclaration(String decl) 将 CSS 声明转换为表示 CSS 声明的 AttributeSet。
Font | getFont(AttributeSet a) 获取给定属性集使用的字体。
Color | getForeground(AttributeSet a) 获取一个属性集并将其转换为前景色规范。
static int | getIndexOfSize(float pt)
StyleSheet.ListPainter | getListPainter(AttributeSet a) 获取给定 CSS 属性集合使用的列表 formatter。
float | getPointSize(int index) 在给定大小索引的情况下返回点大小。
float | getPointSize(String size) 如果给定字符串（如 "+2"、"-2" 或 "2"），则返回点大小值。
Style | getRule(HTML.Tag t, Element e) 获取用来呈现给定类型的 HTML 标记的样式。
Style | getRule(String selector) 获取最能匹配以字符串形式表示的选择器的规则。
StyleSheet[] | getStyleSheets() 返回一个链接 StyleSheet 的数组。
AttributeSet | getViewAttributes(View v) 获取用来显示视图的属性集。
void | importStyleSheet(URL url) 从 url 导入样式表。
void | loadRules(Reader in, URL ref) 加载 CSS1 语法中指定的规则集合。
AttributeSet | removeAttribute(AttributeSet old, Object key) 从集合中移除属性。
AttributeSet | removeAttributes(AttributeSet old, AttributeSet attrs) 移除属性集。
AttributeSet | removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的属性集。
void | removeStyle(String nm) 移除以前添加到该文档中的指定样式。
void | removeStyleSheet(StyleSheet ss) 从接收者的规则中移除 StyleSheet ss。
void | setBase(URL base) 设置 base。
void | setBaseFontSize(int sz) 设置基本字体大小，其有效值范围为 1 到 7。
void | setBaseFontSize(String size) 根据传入的 String 设置基本字体大小。
Color | stringToColor(String string) 将颜色字符串（如 "RED" 或 "#NNNNNN"）转换为 Color。
AttributeSet | translateHTMLToCSS(AttributeSet htmlAttrSet) 将 HTML 属性集合转换为对等的 CSS 属性集合。
从类 javax.swing.text.StyleContext 继承的方法
addChangeListener, addStyle, getChangeListeners, getCompressionThreshold, getDefaultStyleContext, getEmptySet, getFont, getFontMetrics, getStaticAttribute, getStaticAttributeKey, getStyle, getStyleNames, readAttributes, readAttributeSet, reclaim, registerStaticAttributeKey, removeChangeListener, toString, writeAttributes, writeAttributeSet
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StyleSheet

public StyleSheet()
构造 StyleSheet

方法详细信息

getRule

public Style getRule(HTML.Tag t,
                     Element e)
获取用来呈现给定类型的 HTML 标记的样式。给定的元素代表标记，可用来确定是什么样的嵌套情形：是嵌套在元素的内部还是外部，这两种情况的属性是不一样的。

参数：
t - 将转换为可视属性的类型
e - 表示标记的元素；该元素可用于确定嵌套的情况，如果嵌套在其他元素的内部，则属性将不同
返回：
用来呈现标记的 CSS 属性集合

getRule

public Style getRule(String selector)
获取最能匹配以字符串形式表示的选择器的规则。其中 selector 是由空格隔开的元素名称 String。例如，selector 可以是 'html body tr td'

返回的 Style 属性将随着添加和移除规则进行更改。也就是说，如果要请求一个具有选择器 "table p" 的规则，并添加了具有选择器 "p" 的新规则，则返回的 Style 将包括来自规则 "p" 的新属性。

addRule

public void addRule(String rule)
向 sheet 添加规则集合。该规则应是有效的 CSS 格式。通常情况下将根据对 <style> 标记的解析结果调用此方法。

getDeclaration

public AttributeSet getDeclaration(String decl)
将 CSS 声明转换为表示 CSS 声明的 AttributeSet。通常在遇到 HTML 样式属性时将调用此方法。

loadRules

public void loadRules(Reader in,
                      URL ref)
               throws IOException
加载 CSS1 语法中指定的规则集合。如果与现有的规则发生了冲突，则保留新指定的规则。

参数：
in - 要从其读取 CSS 语法的流
ref - 引用 URL。此值表示流的位置，可以为 null。所有在流中指定的相关 URL 都将以此参数为依据。
抛出：
IOException

getViewAttributes

public AttributeSet getViewAttributes(View v)
获取用来显示视图的属性集。这基本上是一个可用于 View.getAttributes 的属性集。

removeStyle

public void removeStyle(String nm)
移除以前添加到该文档中的指定样式。

覆盖：
类 StyleContext 中的 removeStyle
参数：
nm - 要移除的样式的名称

addStyleSheet

public void addStyleSheet(StyleSheet ss)
将 StyleSheet ss 中的规则添加到接收者的规则中。ss's 规则将重写以前添加的所有样式表的规则。添加的 StyleSheet 永远不会重写接收样式表的规则。

从以下版本开始：
1.3

removeStyleSheet

public void removeStyleSheet(StyleSheet ss)
从接收者的规则中移除 StyleSheet ss。

从以下版本开始：
1.3

getStyleSheets

public StyleSheet[] getStyleSheets()
返回一个链接 StyleSheet 的数组。如果不存在链接 StyleSheet，则返回 null。

从以下版本开始：
1.3

importStyleSheet

public void importStyleSheet(URL url)
从 url 导入样式表。得到的规则将直接添加到接收者中。如果不想让这些规则成为接收者的一部分，则要创建一个新的 StyleSheet，并使用 addStyleSheet 与其链接。

从以下版本开始：
1.3

setBase

public void setBase(URL base)
设置 base。所有相关的导入语句都将与 base 相关。

从以下版本开始：
1.3

getBase

public URL getBase()
返回 base。

从以下版本开始：
1.3

addCSSAttribute

public void addCSSAttribute(MutableAttributeSet attr,
                            CSS.Attribute key,
                            String value)
将 CSS 属性添加到给定的集合。

从以下版本开始：
1.3

addCSSAttributeFromHTML

public boolean addCSSAttributeFromHTML(MutableAttributeSet attr,
                                       CSS.Attribute key,
                                       String value)
将 CSS 属性添加到给定的集合。

从以下版本开始：
1.3

translateHTMLToCSS

public AttributeSet translateHTMLToCSS(AttributeSet htmlAttrSet)
将 HTML 属性集合转换为对等的 CSS 属性集合。

参数：
htmlAttrSet - 包含 HTML 属性的 AttributeSet。

addAttribute

public AttributeSet addAttribute(AttributeSet old,
                                 Object key,
                                 Object value)
向给定集合添加属性，并返回新的表示方式的集合。实现此方法以将 StyleConstant 属性转换为 CSS，然后转发给超类行为。StyleConstants 属性没有相应的 CSS 项，将会存储 StyleConstants 属性（但不一定有用）。

指定者：
接口 AbstractDocument.AttributeContext 中的 addAttribute
覆盖：
类 StyleContext 中的 addAttribute
参数：
old - 原有属性集
key - 非 null 属性键
value - 属性值
返回：
更新的属性集
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

addAttributes

public AttributeSet addAttributes(AttributeSet old,
                                  AttributeSet attr)
向元素添加属性集。如果这些属性都是 StyleConstants 属性，则会将它们转换为 CSS，然后再转发给超类行为。

指定者：
接口 AbstractDocument.AttributeContext 中的 addAttributes
覆盖：
类 StyleContext 中的 addAttributes
参数：
old - 原有属性集
attr - 要添加的属性
返回：
更新后的属性集
另请参见：
MutableAttributeSet.addAttribute(java.lang.Object, java.lang.Object)

removeAttribute

public AttributeSet removeAttribute(AttributeSet old,
                                    Object key)
从集合中移除属性。如果该属性是 StyleConstants 属性，则会将请求转换为 CSS 属性，然后再转发给超类行为。

指定者：
接口 AbstractDocument.AttributeContext 中的 removeAttribute
覆盖：
类 StyleContext 中的 removeAttribute
参数：
old - 原有的属性集
key - 非 null 属性名称
返回：
更新的属性集
另请参见：
MutableAttributeSet.removeAttribute(java.lang.Object)

removeAttributes

public AttributeSet removeAttributes(AttributeSet old,
                                     Enumeration<?> names)
移除元素的属性集。如果所有属性都是 StyleConstants 属性，则该请求将会转换为 CSS 属性，然后再转发给超类行为。

指定者：
接口 AbstractDocument.AttributeContext 中的 removeAttributes
覆盖：
类 StyleContext 中的 removeAttributes
参数：
old - 原有属性集
names - 属性名
返回：
更新后的属性集
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

removeAttributes

public AttributeSet removeAttributes(AttributeSet old,
                                     AttributeSet attrs)
移除属性集。如果所有属性都是 StyleConstants 属性，则该请求将会转换为 CSS 属性，然后再转发给超类行为。

指定者：
接口 AbstractDocument.AttributeContext 中的 removeAttributes
覆盖：
类 StyleContext 中的 removeAttributes
参数：
old - 原有属性集
attrs - 属性
返回：
更新后的属性集
另请参见：
MutableAttributeSet.removeAttributes(java.util.Enumeration)

createSmallAttributeSet

protected StyleContext.SmallAttributeSet createSmallAttributeSet(AttributeSet a)
创建可以共享的属性压缩集。这是想要改变 SmallAttributeSet 行为的子类的一个钩子。重新实现此方法以返回提供某种属性转换的 AttributeSet。

覆盖：
类 StyleContext 中的 createSmallAttributeSet
参数：
a - 以压缩形式表示的属性集。

createLargeAttributeSet

protected MutableAttributeSet createLargeAttributeSet(AttributeSet a)
创建一个以空间来换取时间的大属性集合。此集合将不可共享。这是想要改变更大属性存储样式（默认情况下是 SimpleAttributeSet）的子类的一个钩子。重新实现此方法以返回提供某种属性转换的 MutableAttributeSet。

覆盖：
类 StyleContext 中的 createLargeAttributeSet
参数：
a - 以更大形式表示的属性集。

getFont

public Font getFont(AttributeSet a)
获取给定属性集使用的字体。

覆盖：
类 StyleContext 中的 getFont
参数：
a - 属性集
返回：
字体

getForeground

public Color getForeground(AttributeSet a)
获取一个属性集并将其转换为前景色规范。此方法可以用于指定诸如更亮、更鲜艳等之类的内容。

覆盖：
类 StyleContext 中的 getForeground
参数：
a - 属性集
返回：
颜色

getBackground

public Color getBackground(AttributeSet a)
获取一个属性集并将其转换为背景色规范。此方法可以用于指定诸如更亮、更鲜艳等之类的内容。

覆盖：
类 StyleContext 中的 getBackground
参数：
a - 属性集
返回：
颜色

getBoxPainter

public StyleSheet.BoxPainter getBoxPainter(AttributeSet a)
获取给定 CSS 属性集合使用的框 formatter。

getListPainter

public StyleSheet.ListPainter getListPainter(AttributeSet a)
获取给定 CSS 属性集合使用的列表 formatter。

setBaseFontSize

public void setBaseFontSize(int sz)
设置基本字体大小，其有效值范围为 1 到 7。

setBaseFontSize

public void setBaseFontSize(String size)
根据传入的 String 设置基本字体大小。字符串可以标识特定字体大小（有效值在 1 和 7 之间），也可以标识相对字体大小（如 +1 或 -2）。

getIndexOfSize

public static int getIndexOfSize(float pt)

getPointSize

public float getPointSize(int index)
在给定大小索引的情况下返回点大小。

getPointSize

public float getPointSize(String size)
如果给定字符串（如 "+2"、"-2" 或 "2"），则返回点大小值。

stringToColor

public Color stringToColor(String string)
将颜色字符串（如 "RED" 或 "#NNNNNN"）转换为 Color。注：此方法仅转换 HTML3.2 颜色字符串或长度为 7 的字符串；否则，将返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleSheet.BoxPainter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 StyleSheet.BoxPainter

java.lang.Object
    继承者  javax.swing.text.html.StyleSheet.BoxPainter
所有已实现的接口：
Serializable
正在封闭类：
StyleSheet
public static class StyleSheet.BoxPainter
extends Object
implements Serializable

可以执行某些 CSS 格式化任务的类。此类的实现使视图能够在不知道如何缓存 CSS 值的情况下显示 CSS 格式化。

作为视图的代表，此对象负责 View 的 insets 并确保根据 CSS 属性维护背景。

方法摘要
float | getInset(int side, View v) 获取给定边上所需的 inset，以便计算空白、边框和填充数量。
void | paint(Graphics g, float x, float y, float w, float h, View v) 根据给定的属性绘制 CSS 框。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getInset

public float getInset(int side,
                      View v)
获取给定边上所需的 inset，以便计算空白、边框和填充数量。

参数：
side - 要获取的框的 inset 大小。可以是 View.TOP、View.LEFT、View.BOTTOM，也可以是 View.RIGHT。
v - 做出请求的视图。这可以用来获取 AttributeSet，并且还可以用来解析 percentage 参数。
抛出：
IllegalArgumentException - 如果方向无效

paint

public void paint(Graphics g,
                  float x,
                  float y,
                  float w,
                  float h,
                  View v)
根据给定的属性绘制 CSS 框。此操作将绘制边框、填充和背景。

参数：
g - 呈现面。
x - 要呈现的分配区域的 x 坐标。
y - 要呈现的分配区域的 y 坐标。
w - 要呈现的分配区域的宽度。
h - 要呈现的分配区域的高度。
v - 做出请求的视图。此操作可以用来获取 AttributeSet，并且还可用来解析 percentage 参数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StyleSheet.ListPainter (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html
类 StyleSheet.ListPainter

java.lang.Object
    继承者  javax.swing.text.html.StyleSheet.ListPainter
所有已实现的接口：
Serializable
正在封闭类：
StyleSheet
public static class StyleSheet.ListPainter
extends Object
implements Serializable

要执行某些 CSS 列表格式化任务的类。此类的实现使视图能够在不知道如何缓存 CSS 值的情况下以 CSS 格式显示。

方法摘要
 void paint(Graphics g, float x, float y, float w, float h, View v, int item)
根据给定的属性绘制 CSS 列表装饰。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

paint

public void paint(Graphics g,
                  float x,
                  float y,
                  float w,
                  float h,
                  View v,
                  int item)
根据给定的属性绘制 CSS 列表装饰。

参数：
g - 呈现面。
x - 列表项分配区域的 x 坐标
y - 列表项分配区域的 y 坐标
w - 列表项分配区域的宽度
h - 列表项分配区域的高度
v - 要在其中绘画的分配区域。
item - 将绘制哪个列表项。这是一个大于或等于 0 的数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.text.html (Java Platform SE 6)

 javax.swing.text.html
类
BlockView
CSS
CSS.Attribute
FormSubmitEvent
FormView
HTML
HTML.Attribute
HTML.Tag
HTML.UnknownTag
HTMLDocument
HTMLDocument.Iterator
HTMLEditorKit
HTMLEditorKit.HTMLFactory
HTMLEditorKit.HTMLTextAction
HTMLEditorKit.InsertHTMLTextAction
HTMLEditorKit.LinkController
HTMLEditorKit.Parser
HTMLEditorKit.ParserCallback
HTMLFrameHyperlinkEvent
HTMLWriter
ImageView
InlineView
ListView
MinimalHTMLWriter
ObjectView
Option
ParagraphView
StyleSheet
StyleSheet.BoxPainter
StyleSheet.ListPainter
枚举
FormSubmitEvent.MethodType


javax.swing.text.html (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.text.html

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

请参见：
描述

类摘要
BlockView | 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
CSS | 将 CSS attributes 集定义为类型安全的枚举。
CSS.Attribute | 用作 AttributeSet 的键的定义，此属性集可存储 CSS 属性。
FormSubmitEvent | FormSubmitEvent 用于通知提交表单所需的参与者。
FormView | 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
HTML | HTMLDocument 中使用的常量。
HTML.Attribute | 表示 HTML 属性的类型安全的枚举。
HTML.Tag | HTML 标记的类型安全的枚举。
HTML.UnknownTag |
HTMLDocument | 对 HTML 进行建模的文档。
HTMLDocument.Iterator | 对特定类型的标记进行迭代的迭代器。
HTMLEditorKit | Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。
HTMLEditorKit.HTMLFactory | 用于构建 HTML 视图的工厂。
HTMLEditorKit.HTMLTextAction | 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
HTMLEditorKit.InsertHTMLTextAction | InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
HTMLEditorKit.LinkController | 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。
HTMLEditorKit.Parser | 解析器要支持的接口。
HTMLEditorKit.ParserCallback | 解析结果驱动这些回调方法。
HTMLFrameHyperlinkEvent | HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。
HTMLWriter | 这是用于 HTMLDocuments 的 writer。
ImageView | 图像视图，用于支持 HTML <IMG> 标记。
InlineView | 显示基于 css 属性的 inline element 样式。
ListView | 用于显示 html 列表的视图实现。
MinimalHTMLWriter | MinimalHTMLWriter 是一个回退 writer，HTMLEditorKit 使用它为非 EditorKit 生成的文档写出 HTML。
ObjectView | 实现 <object> 元素视图接口的组件装饰符。
Option | 用来表示 <option> 元素的 ListModel 值。
ParagraphView | 显示段落，并使用 css 属性作为其配置。
StyleSheet | 支持定义要呈现的 HTML 视图的可视化特征。
StyleSheet.BoxPainter | 可以执行某些 CSS 格式化任务的类。
StyleSheet.ListPainter | 要执行某些 CSS 列表格式化任务的类。

枚举摘要
FormSubmitEvent.MethodType 表示 HTML 表单方法类型。

软件包 javax.swing.text.html 的描述

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

包规范

  • HTML 3.2 Reference Specification - HTML 规范，它是 HTMLEditorKit 的基础。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.text.html 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.text.html 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.TextAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.html.HTMLEditorKit.HTMLTextAction
            • javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
    • javax.swing.text.AbstractDocument (implements javax.swing.text.Document, java.io.Serializable)
      • javax.swing.text.DefaultStyledDocument (implements javax.swing.text.StyledDocument)
        • javax.swing.text.html.HTMLDocument
    • javax.swing.text.AbstractDocument.AbstractElement (implements javax.swing.text.Element, javax.swing.text.MutableAttributeSet, java.io.Serializable, javax.swing.tree.TreeNode)
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.html.HTMLDocument.BlockElement
      • javax.swing.text.AbstractDocument.LeafElement
        • javax.swing.text.html.HTMLDocument.RunElement
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.HTMLWriter
      • javax.swing.text.html.MinimalHTMLWriter
    • javax.swing.text.html.CSS (implements java.io.Serializable)
    • javax.swing.text.html.CSS.Attribute
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.html.HTMLEditorKit (implements javax.accessibility.Accessible)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
          • javax.swing.text.html.FormSubmitEvent
    • javax.swing.text.html.HTML
    • javax.swing.text.html.HTML.Attribute
    • javax.swing.text.html.HTML.Tag
      • javax.swing.text.html.HTML.UnknownTag (implements java.io.Serializable)
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
    • javax.swing.text.html.HTMLDocument.Iterator
    • javax.swing.text.html.HTMLEditorKit.HTMLFactory (implements javax.swing.text.ViewFactory)
    • javax.swing.text.html.HTMLEditorKit.Parser
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
      • javax.swing.text.html.HTMLDocument.HTMLReader
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.text.html.FormView.MouseEventListener
      • javax.swing.text.html.HTMLEditorKit.LinkController (implements java.awt.event.MouseMotionListener, java.io.Serializable)
    • javax.swing.text.html.Option (implements java.io.Serializable)
    • javax.swing.text.StyleContext (implements javax.swing.text.AbstractDocument.AttributeContext, java.io.Serializable)
      • javax.swing.text.html.StyleSheet
    • javax.swing.text.html.StyleSheet.BoxPainter (implements java.io.Serializable)
    • javax.swing.text.html.StyleSheet.ListPainter (implements java.io.Serializable)
    • javax.swing.text.View (implements javax.swing.SwingConstants)
      • javax.swing.text.ComponentView
        • javax.swing.text.html.FormView (implements java.awt.event.ActionListener)
        • javax.swing.text.html.ObjectView
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
            • javax.swing.text.html.ListView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView (implements javax.swing.text.TabExpander)
              • javax.swing.text.html.ParagraphView
      • javax.swing.text.GlyphView (implements java.lang.Cloneable, javax.swing.text.TabableView)
        • javax.swing.text.LabelView (implements javax.swing.text.TabableView)
          • javax.swing.text.html.InlineView
      • javax.swing.text.html.ImageView

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.swing.text.html.FormSubmitEvent.MethodType
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.text.html 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.text.html
的使用

使用 javax.swing.text.html 的软件包
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html 使用的 javax.swing.text.html 中的类
BlockView
用来显示具有 CSS 规范的块（作为一个框）的视图实现。
CSS.Attribute
用作 AttributeSet 的键的定义，此属性集可存储 CSS 属性。
FormSubmitEvent.MethodType
表示 HTML 表单方法类型。
HTML.Attribute
表示 HTML 属性的类型安全的枚举。
HTML.Tag
HTML 标记的类型安全的枚举。
HTMLDocument
对 HTML 进行建模的文档。
HTMLDocument.HTMLReader.BlockAction
HTMLDocument.HTMLReader.SpecialAction
HTMLDocument.HTMLReader.TagAction
为响应对标记的解析而执行的动作。
HTMLDocument.Iterator
对特定类型的标记进行迭代的迭代器。
HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。
HTMLEditorKit.HTMLTextAction
提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
HTMLEditorKit.Parser
解析器要支持的接口。
HTMLEditorKit.ParserCallback
解析结果驱动这些回调方法。
HTMLFrameHyperlinkEvent
HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。
Option
用来表示 <option> 元素的 ListModel 值。
StyleSheet
支持定义要呈现的 HTML 视图的可视化特征。
StyleSheet.BoxPainter
可以执行某些 CSS 格式化任务的类。
StyleSheet.ListPainter
要执行某些 CSS 列表格式化任务的类。

javax.swing.text.html.parser 使用的 javax.swing.text.html 中的类
HTML.Tag
HTML 标记的类型安全的枚举。
HTMLEditorKit.Parser
解析器要支持的接口。
HTMLEditorKit.ParserCallback
解析结果驱动这些回调方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AttributeList (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 AttributeList

java.lang.Object
    继承者  javax.swing.text.html.parser.AttributeList
所有已实现的接口：
Serializable, DTDConstants
public final class AttributeList
extends Object
implements DTDConstants, Serializable

此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。可以使用 getAttributes() 方法从 Element 类中获取 AttributeList。

它实际上是链接列表中的一个元素。重复使用 getNext() 方法来枚举一个元素的所有属性。

另请参见：
Element

字段摘要
int | modifier
String | name
AttributeList | next
int | type
String | value
Vector<?> | values
从接口 javax.swing.text.html.parser.DTDConstants 继承的字段
ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM
构造方法摘要
AttributeList(String name)
创建一个属性列表元素。
AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
创建一个属性列表元素。
方法摘要
int | getModifier()
String | getName()
AttributeList | getNext()
int | getType()
String | getValue()
Enumeration<?> | getValues()
static int | name2type(String nm)
String | toString() 返回该对象的字符串表示。
static String | type2name(int tp)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

name

public String name

type

public int type

values

public Vector<?> values

modifier

public int modifier

value

public String value

next

public AttributeList next
构造方法详细信息

AttributeList

public AttributeList(String name)
创建一个属性列表元素。

AttributeList

public AttributeList(String name,
                     int type,
                     int modifier,
                     String value,
                     Vector<?> values,
                     AttributeList next)
创建一个属性列表元素。

方法详细信息

getName

public String getName()
返回：
属性名

getType

public int getType()
返回：
属性类型
另请参见：
DTDConstants

getModifier

public int getModifier()
返回：
属性修饰语
另请参见：
DTDConstants

getValues

public Enumeration<?> getValues()
返回：
可能的属性值

getValue

public String getValue()
返回：
默认的属性值

getNext

public AttributeList getNext()
返回：
列表中的下一个属性

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
字符串表示形式

name2type

public static int name2type(String nm)

type2name

public static String type2name(int tp)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ContentModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 ContentModel

java.lang.Object
    继承者  javax.swing.text.html.parser.ContentModel
所有已实现的接口：
Serializable
public final class ContentModel
extends Object
implements Serializable

内容模式的表示形式。内容模式基本上是一个受限制的 BNF 表达式。受限制从某种意义上来说就是，它必须是确定的。这意味着您不必将它表示为一个有限状态自动机。

有关更多信息，请参阅 SGML 手册第 556 页中的 Annex H 内容。

字段摘要
Object | content 内容。
ContentModel | next 下一个内容模式（使用 ','、'|' 或 '&' 表达式）。
int | type 类型。
构造方法摘要
ContentModel()
ContentModel(Element content)
为元素创建一个内容模式。
ContentModel(int type, ContentModel content)
创建一个特定类型的内容模式。
ContentModel(int type, Object content, ContentModel next)
创建一个特定类型的内容模式。
方法摘要
boolean | empty() 如果内容模式可以匹配一个空输入流，则返回 true。
Element | first() 返回必须具有下一个的元素。
boolean | first(Object token) 如果标记可能为输入流中第一个标记，则返回 true。
void | getElements(Vector<Element> elemVec) 使用作为此 contentModel 一部分的元素列表更新 elemVec。
String | toString() 转换为字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

type

public int type
类型。可以是 '*'、'?'、'+'、','、'|'、'&'。

content

public Object content
内容。可以是一个 Element 或者一个 ContentModel。

next

public ContentModel next
下一个内容模式（使用 ','、'|' 或 '&' 表达式）。

构造方法详细信息

ContentModel

public ContentModel()

ContentModel

public ContentModel(Element content)
为元素创建一个内容模式。

ContentModel

public ContentModel(int type,
                    ContentModel content)
创建一个特定类型的内容模式。

ContentModel

public ContentModel(int type,
                    Object content,
                    ContentModel next)
创建一个特定类型的内容模式。

方法详细信息

empty

public boolean empty()
如果内容模式可以匹配一个空输入流，则返回 true。

getElements

public void getElements(Vector<Element> elemVec)
使用作为此 contentModel 一部分的元素列表更新 elemVec。

first

public boolean first(Object token)
如果标记可能为输入流中第一个标记，则返回 true。

first

public Element first()
返回必须具有下一个的元素。

toString

public String toString()
转换为字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentParser (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 DocumentParser

java.lang.Object
    继承者  javax.swing.text.html.parser.Parser
        继承者  javax.swing.text.html.parser.DocumentParser
所有已实现的接口：
DTDConstants
public class DocumentParser
extends Parser

HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。读取 HTML 的 InputStream，并调用 ParserCallback 类中的适当方法。这是 HTMLEditorKit 用于解析 HTML url 的默认解析器。

此类将通知回调所有有效的标记，以及被隐含但没有明确指定的标记。例如，html 字符串 (<p>blah) 只定义了一个 p 标记。该回调将看到下面的方法：

  1. handleStartTag(html, ...)
  2. handleStartTag(head, ...)
  3. handleEndTag(head)
  4. handleStartTag(body, ...)
  5. handleStartTag(p, ...)
  6. handleText(...)
  7. handleEndTag(p)
  8. handleEndTag(body)
  9. handleEndTag(html)
斜体 表示的项是隐含的，也就是说，它们未被明确指定为本来应该提供的正确的 html（尽管头不是必须的，但仍生成了头）。对于隐含的标记，AttributeSet 参数中键 HTMLEditorKit.ParserCallback.IMPLIED 的值为 Boolean.TRUE。

HTML.Attributes 定义 html 属性的一个类型安全的枚举。如果在 HTML.Attribute 中定义了一个标记的属性键，HTML.Attribute 将作为键，否则将使用一个 String 作为键。例如，<p foo=bar class=neat> 有两个属性，foo 在 HTML.Attribute 中未定义，而 class 在其中定义，因此 AttributeSet 将包含两个值，HTML.Attribute.CLASS 作为键的 String 值 "neat"，String "foo" 作为键的 String 值 "bar"。

位置参数将指示标记、注释或文本的开始。与数组类似，流中的第一个字符位置为 0。对于被隐含的标记来说，位置参数将指示下一个出现的标记的位置。在第一个示例中，隐含的开始正文和 html 标记将具有与 p 标记相同的位置，隐含的结束 p、html 和正文标记都将具有相同的位置。

由于 html 跳过空白，因此文本的位置将是第一个有效字符的位置，例如，在字符串 "\n\n\nblah" 中，文本 "blah" 位置为 3，换行将被跳过。

对于没有值的属性，例如，在 html 字符串 <foo blah> 中，属性 blah 没有值，存在两个可以放入 AttributeSet 值中的可能值：

  • 如果 DTD 不包含该元素的定义，或者该定义没有一个显式值，则 AttributeSet 中的值将为 HTML.NULL_ATTRIBUTE_VALUE。
  • 如果 DTD 包含一个显式值，如：<!ATTLIST OPTION selected (selected) #IMPLIED> 将使用 dtd（在此情形中已选中）中的这一值。

在解析流之后，将通知回调最可能的行字符串结束符。行字符串的结束符将是 \n、\r 或 \r\n 之一，它在解析流中出现得最多。

字段摘要
从类 javax.swing.text.html.parser.Parser 继承的字段
dtd, strict
从接口 javax.swing.text.html.parser.DTDConstants 继承的字段
ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM
构造方法摘要
DocumentParser(DTD dtd)
方法摘要
protected void | handleComment(char[] text) 在遇到 HTML 注释时调用。
protected void | handleEmptyTag(TagElement tag) 处理空标记。
protected void | handleEndTag(TagElement tag) 处理结束标记。
protected void | handleError(int ln, String errorMsg) 发生了一个错误。
protected void | handleStartTag(TagElement tag) 处理开始标记。
protected void | handleText(char[] data) 处理文本。
void | parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
从类 javax.swing.text.html.parser.Parser 继承的方法
endTag, error, error, error, error, flushAttributes, getAttributes, getCurrentLine, getCurrentPos, handleEOFInComment, handleTitle, makeTag, makeTag, markFirstTime, parse, parseDTDMarkup, parseMarkupDeclarations, startTag
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentParser

public DocumentParser(DTD dtd)
方法详细信息

parse

public void parse(Reader in,
                  HTMLEditorKit.ParserCallback callback,
                  boolean ignoreCharSet)
           throws IOException
抛出：
IOException

handleStartTag

protected void handleStartTag(TagElement tag)
处理开始标记。

覆盖：
类 Parser 中的 handleStartTag

handleComment

protected void handleComment(char[] text)
从类 Parser 复制的描述
在遇到 HTML 注释时调用。

覆盖：
类 Parser 中的 handleComment

handleEmptyTag

protected void handleEmptyTag(TagElement tag)
                       throws ChangedCharSetException
处理空标记。

覆盖：
类 Parser 中的 handleEmptyTag
抛出：
ChangedCharSetException

handleEndTag

protected void handleEndTag(TagElement tag)
处理结束标记。

覆盖：
类 Parser 中的 handleEndTag

handleText

protected void handleText(char[] data)
处理文本。

覆盖：
类 Parser 中的 handleText

handleError

protected void handleError(int ln,
                           String errorMsg)
从类 Parser 复制的描述
发生了一个错误。

覆盖：
类 Parser 中的 handleError
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DTD (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 DTD

java.lang.Object
    继承者  javax.swing.text.html.parser.DTD
所有已实现的接口：
DTDConstants
public class DTD
extends Object
implements DTDConstants

SGML DTD 的表示形式。DTD 描述文档语法并用于解析 HTML 文档。它包含一个元素及其属性的列表，还包括一个在 DTD 中定义的条目的列表。

另请参见：
Element, AttributeList, ContentModel, Parser

字段摘要
Element | applet
Element | base
Element | body
Hashtable<String,Element> | elementHash
Vector<Element> | elements
Hashtable<Object,Entity> | entityHash
static int | FILE_VERSION
Element | head
Element | html
Element | isindex
Element | meta
String | name
Element | p
Element | param
Element | pcdata
Element | title
从接口 javax.swing.text.html.parser.DTDConstants 继承的字段
ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM
构造方法摘要
protected DTD(String name)
创建具有指定名称的新 DTD。
方法摘要
protected AttributeList | defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts) 创建并返回一个 AttributeList。
protected ContentModel | defContentModel(int type, Object obj, ContentModel next) 创建并返回一个新的内容模式。
protected Element | defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts) 创建并返回一个 Element。
Entity | defEntity(String name, int type, int ch) 创建并返回一个字符 Entity。
protected Entity | defEntity(String name, int type, String str) 创建并返回一个 Entity。
void | defineAttributes(String name, AttributeList atts) 定义 Element 的属性。
Element | defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts) 返回与指定参数匹配的 Element。
Entity | defineEntity(String name, int type, char[] data) 定义一个实体。
static DTD | getDTD(String name) 返回具有指定 name 的 DTD。
Element | getElement(int index) 按索引获取一个元素。
Element | getElement(String name) 按名称获取一个元素。
Entity | getEntity(int ch) 获取一个字符实体。
Entity | getEntity(String name) 按名称获取一个实体。
String | getName() 获取 DTD 的名称。
static void | putDTDHash(String name, DTD dtd)
void | read(DataInputStream in) 根据存档格式重新创建一个 DTD。
String | toString() 返回此 DTD 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

name

public String name

elements

public Vector<Element> elements

elementHash

public Hashtable<String,Element> elementHash

entityHash

public Hashtable<Object,Entity> entityHash

pcdata

public final Element pcdata

html

public final Element html

meta

public final Element meta

base

public final Element base

isindex

public final Element isindex

head

public final Element head

body

public final Element body

applet

public final Element applet

param

public final Element param

p

public final Element p

title

public final Element title

FILE_VERSION

public static final int FILE_VERSION
另请参见：
常量字段值
构造方法详细信息

DTD

protected DTD(String name)
创建具有指定名称的新 DTD。

参数：
name - 以 String 表示的新 DTD 的名称
方法详细信息

getName

public String getName()
获取 DTD 的名称。

返回：
DTD 的名称

getEntity

public Entity getEntity(String name)
按名称获取一个实体。

返回：
与 name String 对应的 Entity

getEntity

public Entity getEntity(int ch)
获取一个字符实体。

返回：
与 ch 字符对应的 Entity

getElement

public Element getElement(String name)
按名称获取一个元素。如果该元素不存在，将创建一个新元素。

参数：
name - 请求的 String
返回：
对应于 name 的 Element，它可以是新创建的

getElement

public Element getElement(int index)
按索引获取一个元素。

参数：
index - 请求的索引
返回：
与 index 相应的 Element

defineEntity

public Entity defineEntity(String name,
                           int type,
                           char[] data)
定义一个实体。如果由 name、type 和 data 指定的 Entity 存在，就返回该 Entity；否则将创建并返回一个新 Entity。

参数：
name - 以 String 表示的 Entity 的名称
type - Entity 的类型
data - Entity 的数据
返回：
请求的 Entity，如果未找到请求的，则返回一个新 Entity

defineElement

public Element defineElement(String name,
                             int type,
                             boolean omitStart,
                             boolean omitEnd,
                             ContentModel content,
                             BitSet exclusions,
                             BitSet inclusions,
                             AttributeList atts)
返回与指定参数匹配的 Element。如果不存在所需元素，则创建并返回一个新元素。

参数：
name - Element 的名称
type - Element 的类型
omitStart - 如果忽略开始，则为 true
omitEnd - 如果忽略结尾，则为 true
content - ContentModel
atts - 指定 Element 的 AttributeList
返回：
指定的 Element

defineAttributes

public void defineAttributes(String name,
                             AttributeList atts)
定义 Element 的属性。

参数：
name - Element 的名称
atts - 指定 Element 的 AttributeList

defEntity

public Entity defEntity(String name,
                        int type,
                        int ch)
创建并返回一个字符 Entity。

参数：
name - 实体的名称
返回：
新的字符 Entity

defEntity

protected Entity defEntity(String name,
                           int type,
                           String str)
创建并返回一个 Entity。

参数：
name - 实体的名称
返回：
新的 Entity

defElement

protected Element defElement(String name,
                             int type,
                             boolean omitStart,
                             boolean omitEnd,
                             ContentModel content,
                             String[] exclusions,
                             String[] inclusions,
                             AttributeList atts)
创建并返回一个 Element。

参数：
name - 元素的名称
返回：
新的 Element

defAttributeList

protected AttributeList defAttributeList(String name,
                                         int type,
                                         int modifier,
                                         String value,
                                         String values,
                                         AttributeList atts)
创建并返回一个 AttributeList。

参数：
name - 属性列表的名称
返回：
新的 AttributeList

defContentModel

protected ContentModel defContentModel(int type,
                                       Object obj,
                                       ContentModel next)
创建并返回一个新的内容模式。

参数：
type - 新内容模式的类型
返回：
新的 ContentModel

toString

public String toString()
返回此 DTD 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此 DTD 的字符串表示形式

putDTDHash

public static void putDTDHash(String name,
                              DTD dtd)

getDTD

public static DTD getDTD(String name)
                  throws IOException
返回具有指定 name 的 DTD。如果不存在具有该名称的 DTD，将创建并返回一个 DTD。名称中的所有大写字符都将转换为小写字符。

参数：
name - DTD 的名称
返回：
与 name 对应的 DTD
抛出：
IOException

read

public void read(DataInputStream in)
          throws IOException
根据存档格式重新创建一个 DTD。

参数：
in - 要从中读取数据的 DataInputStream
抛出：
IOException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DTDConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
接口 DTDConstants

所有已知实现类：
AttributeList, DocumentParser, DTD, Element, Entity, Parser
public interface DTDConstants

DTD 中使用的 SGML 常量。这些常量的名称对应于 The SGML Handbook 中所述的等效 SGML 构造，该书的作者是 Charles F. Goldfarb。

另请参见：
DTD, Element

字段摘要
static int | ANY
static int | CDATA
static int | CONREF
static int | CURRENT
static int | DEFAULT
static int | EMPTY
static int | ENDTAG
static int | ENTITIES
static int | ENTITY
static int | FIXED
static int | GENERAL
static int | ID
static int | IDREF
static int | IDREFS
static int | IMPLIED
static int | MD
static int | MODEL
static int | MS
static int | NAME
static int | NAMES
static int | NMTOKEN
static int | NMTOKENS
static int | NOTATION
static int | NUMBER
static int | NUMBERS
static int | NUTOKEN
static int | NUTOKENS
static int | PARAMETER
static int | PI
static int | PUBLIC
static int | RCDATA
static int | REQUIRED
static int | SDATA
static int | STARTTAG
static int | SYSTEM

字段详细信息

CDATA

static final int CDATA
另请参见：
常量字段值

ENTITY

static final int ENTITY
另请参见：
常量字段值

ENTITIES

static final int ENTITIES
另请参见：
常量字段值

ID

static final int ID
另请参见：
常量字段值

IDREF

static final int IDREF
另请参见：
常量字段值

IDREFS

static final int IDREFS
另请参见：
常量字段值

NAME

static final int NAME
另请参见：
常量字段值

NAMES

static final int NAMES
另请参见：
常量字段值

NMTOKEN

static final int NMTOKEN
另请参见：
常量字段值

NMTOKENS

static final int NMTOKENS
另请参见：
常量字段值

NOTATION

static final int NOTATION
另请参见：
常量字段值

NUMBER

static final int NUMBER
另请参见：
常量字段值

NUMBERS

static final int NUMBERS
另请参见：
常量字段值

NUTOKEN

static final int NUTOKEN
另请参见：
常量字段值

NUTOKENS

static final int NUTOKENS
另请参见：
常量字段值

RCDATA

static final int RCDATA
另请参见：
常量字段值

EMPTY

static final int EMPTY
另请参见：
常量字段值

MODEL

static final int MODEL
另请参见：
常量字段值

ANY

static final int ANY
另请参见：
常量字段值

FIXED

static final int FIXED
另请参见：
常量字段值

REQUIRED

static final int REQUIRED
另请参见：
常量字段值

CURRENT

static final int CURRENT
另请参见：
常量字段值

CONREF

static final int CONREF
另请参见：
常量字段值

IMPLIED

static final int IMPLIED
另请参见：
常量字段值

PUBLIC

static final int PUBLIC
另请参见：
常量字段值

SDATA

static final int SDATA
另请参见：
常量字段值

PI

static final int PI
另请参见：
常量字段值

STARTTAG

static final int STARTTAG
另请参见：
常量字段值

ENDTAG

static final int ENDTAG
另请参见：
常量字段值

MS

static final int MS
另请参见：
常量字段值

MD

static final int MD
另请参见：
常量字段值

SYSTEM

static final int SYSTEM
另请参见：
常量字段值

GENERAL

static final int GENERAL
另请参见：
常量字段值

DEFAULT

static final int DEFAULT
另请参见：
常量字段值

PARAMETER

static final int PARAMETER
另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Element (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 Element

java.lang.Object
    继承者  javax.swing.text.html.parser.Element
所有已实现的接口：
Serializable, DTDConstants
public final class Element
extends Object
implements DTDConstants, Serializable

使用 ELEMENT 构造在 DTD 中描述的一个元素。这实质上是对标记的描述。它描述了类型、内容模式、属性和属性类型等。它用于由 Parser 正确解析一个文档。

另请参见：
DTD, AttributeList

字段摘要
AttributeList | atts
ContentModel | content
Object | data 存储用户数据的字段。
BitSet | exclusions
BitSet | inclusions
int | index
String | name
boolean | oEnd
boolean | oStart
int | type
从接口 javax.swing.text.html.parser.DTDConstants 继承的字段
ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM
方法摘要
AttributeList | getAttribute(String name) 按名称获取一个元素。
AttributeList | getAttributeByValue(String name) 按值获取一个属性。
AttributeList | getAttributes() 获取属性。
ContentModel | getContent() 获取内容模式
int | getIndex() 获取索引。
String | getName() 获取元素的名称。
int | getType() 获取类型。
boolean | isEmpty() 检查是否为空
static int | name2type(String nm)
boolean | omitEnd() 如果可以忽略结束标记，则返回 true。
boolean | omitStart() 如果可以忽略开始标记，则返回 true。
String | toString() 转换为字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

index

public int index

name

public String name

oStart

public boolean oStart

oEnd

public boolean oEnd

inclusions

public BitSet inclusions

exclusions

public BitSet exclusions

type

public int type

content

public ContentModel content

atts

public AttributeList atts

data

public Object data
存储用户数据的字段。通常用于存储样式表。

方法详细信息

getName

public String getName()
获取元素的名称。

omitStart

public boolean omitStart()
如果可以忽略开始标记，则返回 true。

omitEnd

public boolean omitEnd()
如果可以忽略结束标记，则返回 true。

getType

public int getType()
获取类型。

getContent

public ContentModel getContent()
获取内容模式

getAttributes

public AttributeList getAttributes()
获取属性。

getIndex

public int getIndex()
获取索引。

isEmpty

public boolean isEmpty()
检查是否为空

toString

public String toString()
转换为字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

getAttribute

public AttributeList getAttribute(String name)
按名称获取一个元素。

getAttributeByValue

public AttributeList getAttributeByValue(String name)
按值获取一个属性。

name2type

public static int name2type(String nm)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Entity (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 Entity

java.lang.Object
    继承者  javax.swing.text.html.parser.Entity
所有已实现的接口：
DTDConstants
public final class Entity
extends Object
implements DTDConstants

使用 ENTITY 构造在 DTD 中描述了一个实体。它定义该实体的类型和值。

另请参见：
DTD

字段摘要
char[] | data
String | name
int | type
从接口 javax.swing.text.html.parser.DTDConstants 继承的字段
ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM
构造方法摘要
Entity(String name, int type, char[] data)
创建一个实体。
方法摘要
char[] | getData() 返回 data。
String | getName() 获取实体的名称。
String | getString() 返回以 String 表示的数据。
int | getType() 获取实体的类型。
boolean | isGeneral() 如果是常规实体，则返回 true。
boolean | isParameter() 如果为参数实体，则返回 true。
static int | name2type(String nm) 将 nm 字符串转换为相应的实体类型。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

name

public String name

type

public int type

data

public char[] data
构造方法详细信息

Entity

public Entity(String name,
              int type,
              char[] data)
创建一个实体。

参数：
name - 实体的名称
type - 实体的类型
data - 数据的 char 数组
方法详细信息

getName

public String getName()
获取实体的名称。

返回：
以 String 表示的实体名称

getType

public int getType()
获取实体的类型。

返回：
实体的类型

isParameter

public boolean isParameter()
如果为参数实体，则返回 true。

返回：
如果为参数实体，则返回 true

isGeneral

public boolean isGeneral()
如果是常规实体，则返回 true。

返回：
如果是常规实体，则返回 true

getData

public char[] getData()
返回 data。

返回：
data

getString

public String getString()
返回以 String 表示的数据。

返回：
以 String 表示的数据

name2type

public static int name2type(String nm)
将 nm 字符串转换为相应的实体类型。如果该字符串没有相应的实体类型，则返回与“CDATA”对应的类型。有效的实体类型有："PUBLIC"、"CDATA"、"SDATA"、"PI"、"STARTTAG"、"ENDTAG"、"MS"、"MD" 和 "SYSTEM"。

参数：
nm - 要转换的字符串
返回：
相应的实体类型，如果不存在，则返回与 "CDATA" 对应的类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Parser (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 Parser

java.lang.Object
    继承者  javax.swing.text.html.parser.Parser
所有已实现的接口：
DTDConstants
直接已知子类：
DocumentParser
public class Parser
extends Object
implements DTDConstants

一个简单的 DTD 驱动的 HTML 解析器。该解析器从 InputStream 读取 HTML 文件，并在遇到标记和数据时调用各种方法（在子类中应重写这些方法）。

遗憾的是，存在许多不良实现的 HTML 解析器，结果导致许多不良格式的 HTML 文件。此解析器尝试解析大多数 HTML 文件。这意味着该实现有时偏离有利于 HTML 的 SGML 规范。

该解析器将 \r 和 \r\n 视为 \n。开始标记之后和结束标记之前的换行被忽略，正如 SGML/HTML 规范中指定的那样。

html 规范不指定如何很好地组合空格。明确地说，不讨论下面的情形（注意，此处应使用空格，但我使用了 来强制显示空格）：

'<b>blah <i> <strike> foo' 可以被视为：'<b>blah <i><strike>foo'

以及：'<p><a href="xx"> <em>Using</em></a></p>' 好像被视为：'<p><a href="xx"><em>Using</em></a></p>'

如果 strict 为 false，在遇到中断流的标记 (TagElement.breaksFlows) 或尾部空白时，如果未遇到非空白字符，所有空白都将被忽略。看上去该行为与流行的浏览器的行为更接近。

另请参见：
DTD, TagElement, SimpleAttributeSet

字段摘要
protected DTD | dtd
protected boolean | strict 此标记确定 Parser 在强制执行 SGML 兼容性方面是否严格。
从接口 javax.swing.text.html.parser.DTDConstants 继承的字段
ANY, CDATA, CONREF, CURRENT, DEFAULT, EMPTY, ENDTAG, ENTITIES, ENTITY, FIXED, GENERAL, ID, IDREF, IDREFS, IMPLIED, MD, MODEL, MS, NAME, NAMES, NMTOKEN, NMTOKENS, NOTATION, NUMBER, NUMBERS, NUTOKEN, NUTOKENS, PARAMETER, PI, PUBLIC, RCDATA, REQUIRED, SDATA, STARTTAG, SYSTEM
构造方法摘要
Parser(DTD dtd)
方法摘要
protected void | endTag(boolean omitted) 处理结束标记。
protected void | error(String err)
protected void | error(String err, String arg1)
protected void | error(String err, String arg1, String arg2)
protected void | error(String err, String arg1, String arg2, String arg3) 调用错误处理程序。
protected void | flushAttributes()
protected SimpleAttributeSet | getAttributes()
protected int | getCurrentLine()
protected int | getCurrentPos()
protected void | handleComment(char[] text) 在遇到 HTML 注释时调用。
protected void | handleEmptyTag(TagElement tag) 在遇到空标记时调用。
protected void | handleEndTag(TagElement tag) 在遇到结束标记时调用。
protected void | handleEOFInComment()
protected void | handleError(int ln, String msg) 发生了一个错误。
protected void | handleStartTag(TagElement tag) 在遇到开始标记时调用。
protected void | handleText(char[] text) 在遇到 PCDATA 时调用。
protected void | handleTitle(char[] text) 在遇到 HTML 标题标记时调用。
protected TagElement | makeTag(Element elem)
protected TagElement | makeTag(Element elem, boolean fictional) 制作 TagElement。
protected void | markFirstTime(Element elem) 标记在文档中首次看到标记
void | parse(Reader in) 在给定 DTD 的情况下，解析 HTML 流。
String | parseDTDMarkup() 解析 Document Type Declaration 标记声明。
protected boolean | parseMarkupDeclarations(StringBuffer strBuff) 解析标记声明。
protected void | startTag(TagElement tag) 处理开始标记。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

dtd

protected DTD dtd

strict

protected boolean strict
此标记确定 Parser 在强制执行 SGML 兼容性方面是否严格。如果为 false，则对某些 HTML 构造有误的通用类比较宽松。无论是否严格，都会记录一个错误。

构造方法详细信息

Parser

public Parser(DTD dtd)
方法详细信息

getCurrentLine

protected int getCurrentLine()
返回：
当前解析行的行号

makeTag

protected TagElement makeTag(Element elem,
                             boolean fictional)
制作 TagElement。

makeTag

protected TagElement makeTag(Element elem)

getAttributes

protected SimpleAttributeSet getAttributes()

flushAttributes

protected void flushAttributes()

handleText

protected void handleText(char[] text)
在遇到 PCDATA 时调用。

handleTitle

protected void handleTitle(char[] text)
在遇到 HTML 标题标记时调用。

handleComment

protected void handleComment(char[] text)
在遇到 HTML 注释时调用。

handleEOFInComment

protected void handleEOFInComment()

handleEmptyTag

protected void handleEmptyTag(TagElement tag)
                       throws ChangedCharSetException
在遇到空标记时调用。

抛出：
ChangedCharSetException

handleStartTag

protected void handleStartTag(TagElement tag)
在遇到开始标记时调用。

handleEndTag

protected void handleEndTag(TagElement tag)
在遇到结束标记时调用。

handleError

protected void handleError(int ln,
                           String msg)
发生了一个错误。

error

protected void error(String err,
                     String arg1,
                     String arg2,
                     String arg3)
调用错误处理程序。

error

protected void error(String err,
                     String arg1,
                     String arg2)

error

protected void error(String err,
                     String arg1)

error

protected void error(String err)

startTag

protected void startTag(TagElement tag)
                 throws ChangedCharSetException
处理开始标记。将新标记推送到标记堆栈。在属性列表中检查所需的属性。

抛出：
ChangedCharSetException

endTag

protected void endTag(boolean omitted)
处理结束标记。结束标记从标记堆栈中弹出。

markFirstTime

protected void markFirstTime(Element elem)
标记在文档中首次看到标记

parseDTDMarkup

public String parseDTDMarkup()
                      throws IOException
解析 Document Type Declaration 标记声明。当前忽略它。

抛出：
IOException

parseMarkupDeclarations

protected boolean parseMarkupDeclarations(StringBuffer strBuff)
                                   throws IOException
解析标记声明。当前仅处理 Document Type Declaration 标记。如果为标记声明，则返回 true，否则返回 false。

抛出：
IOException

parse

public void parse(Reader in)
           throws IOException
在给定 DTD 的情况下，解析 HTML 流。

抛出：
IOException

getCurrentPos

protected int getCurrentPos()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParserDelegator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 ParserDelegator

java.lang.Object
    继承者  javax.swing.text.html.HTMLEditorKit.Parser
        继承者  javax.swing.text.html.parser.ParserDelegator
所有已实现的接口：
Serializable
public class ParserDelegator
extends HTMLEditorKit.Parser
implements Serializable

负责每次在调用其 parse 方法时启动一个新的 DocumentParser。存储对该 dtd 的一个引用。

构造方法摘要
ParserDelegator()
方法摘要
protected static DTD | createDTD(DTD dtd, String name)
void | parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet) 解析给定的流并通过解析的结果驱动给定的回调。
protected static void | setDefaultDTD()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ParserDelegator

public ParserDelegator()
方法详细信息

setDefaultDTD

protected static void setDefaultDTD()

createDTD

protected static DTD createDTD(DTD dtd,
                               String name)

parse

public void parse(Reader r,
                  HTMLEditorKit.ParserCallback cb,
                  boolean ignoreCharSet)
           throws IOException
从类 HTMLEditorKit.Parser 复制的描述
解析给定的流并通过解析的结果驱动给定的回调。应该将此方法实现为线程安全的。

指定者：
类 HTMLEditorKit.Parser 中的 parse
抛出：
IOException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TagElement (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.text.html.parser
类 TagElement

java.lang.Object
    继承者  javax.swing.text.html.parser.TagElement

public class TagElement
extends Object

一般的 HTML TagElement 类。该方法定义如何解释标记周围的空白。

构造方法摘要
TagElement(Element elem)
TagElement(Element elem, boolean fictional)
方法摘要
boolean | breaksFlow()
boolean | fictional()
Element | getElement()
HTML.Tag | getHTMLTag()
boolean | isPreformatted()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TagElement

public TagElement(Element elem)

TagElement

public TagElement(Element elem,
                  boolean fictional)
方法详细信息

breaksFlow

public boolean breaksFlow()

isPreformatted

public boolean isPreformatted()

getElement

public Element getElement()

getHTMLTag

public HTML.Tag getHTMLTag()

fictional

public boolean fictional()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.text.html.parser (Java Platform SE 6)

 javax.swing.text.html.parser
接口
DTDConstants
类
AttributeList
ContentModel
DocumentParser
DTD
Element
Entity
Parser
ParserDelegator
TagElement


javax.swing.text.html.parser (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.text.html.parser

提供默认的 HTML 解析器以及支持类。

请参见：
描述

接口摘要
DTDConstants DTD 中使用的 SGML 常量。

类摘要
AttributeList | 此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。
ContentModel | 内容模式的表示形式。
DocumentParser | HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。
DTD | SGML DTD 的表示形式。
Element | 使用 ELEMENT 构造在 DTD 中描述的一个元素。
Entity | 使用 ENTITY 构造在 DTD 中描述了一个实体。
Parser | 一个简单的 DTD 驱动的 HTML 解析器。
ParserDelegator | 负责每次在调用其 parse 方法时启动一个新的 DocumentParser。
TagElement | 一般的 HTML TagElement 类。

软件包 javax.swing.text.html.parser 的描述

提供默认的 HTML 解析器以及支持类。在解析该流之后，该解析器将通知一个代理必须实现 HTMLEditorKit.ParserCallback 接口。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅《The Java Tutorial》中的 Threads and Swing 一节。

从以下版本开始：
1.2
另请参见：
HTMLEditorKit.ParserCallback
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.text.html.parser 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.text.html.parser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.text.html.parser.AttributeList (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.swing.text.html.parser.ContentModel (implements java.io.Serializable)
    • javax.swing.text.html.parser.DTD (implements javax.swing.text.html.parser.DTDConstants)
    • javax.swing.text.html.parser.Element (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.swing.text.html.parser.Entity (implements javax.swing.text.html.parser.DTDConstants)
    • javax.swing.text.html.HTMLEditorKit.Parser
      • javax.swing.text.html.parser.ParserDelegator (implements java.io.Serializable)
    • javax.swing.text.html.parser.Parser (implements javax.swing.text.html.parser.DTDConstants)
      • javax.swing.text.html.parser.DocumentParser
    • javax.swing.text.html.parser.TagElement

接口分层结构

  • javax.swing.text.html.parser.DTDConstants
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.text.html.parser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.text.html.parser
的使用

使用 javax.swing.text.html.parser 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 使用的 javax.swing.text.html.parser 中的类
AttributeList
此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。
ContentModel
内容模式的表示形式。
DTD
SGML DTD 的表示形式。
DTDConstants
DTD 中使用的 SGML 常量。
Element
使用 ELEMENT 构造在 DTD 中描述的一个元素。
Entity
使用 ENTITY 构造在 DTD 中描述了一个实体。
Parser
一个简单的 DTD 驱动的 HTML 解析器。
TagElement
一般的 HTML TagElement 类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.AttributeList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.AttributeList
的使用

使用 AttributeList 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 AttributeList 的使用

声明为 AttributeList 的 javax.swing.text.html.parser 中的字段
AttributeList | Element.atts
AttributeList | AttributeList.next

返回 AttributeList 的 javax.swing.text.html.parser 中的方法
protected AttributeList | DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts) 创建并返回一个 AttributeList。
AttributeList | Element.getAttribute(String name) 按名称获取一个元素。
AttributeList | Element.getAttributeByValue(String name) 按值获取一个属性。
AttributeList | Element.getAttributes() 获取属性。
AttributeList | AttributeList.getNext()

参数类型为 AttributeList 的 javax.swing.text.html.parser 中的方法
protected AttributeList | DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts) 创建并返回一个 AttributeList。
protected Element | DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts) 创建并返回一个 Element。
void | DTD.defineAttributes(String name, AttributeList atts) 定义 Element 的属性。
Element | DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts) 返回与指定参数匹配的 Element。

参数类型为 AttributeList 的 javax.swing.text.html.parser 中的构造方法
AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
创建一个属性列表元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.ContentModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.ContentModel
的使用

使用 ContentModel 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 ContentModel 的使用

声明为 ContentModel 的 javax.swing.text.html.parser 中的字段
ContentModel | Element.content
ContentModel | ContentModel.next 下一个内容模式（使用 ','、'|' 或 '&' 表达式）。

返回 ContentModel 的 javax.swing.text.html.parser 中的方法
protected ContentModel | DTD.defContentModel(int type, Object obj, ContentModel next) 创建并返回一个新的内容模式。
ContentModel | Element.getContent() 获取内容模式

参数类型为 ContentModel 的 javax.swing.text.html.parser 中的方法
protected ContentModel | DTD.defContentModel(int type, Object obj, ContentModel next) 创建并返回一个新的内容模式。
protected Element | DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts) 创建并返回一个 Element。
Element | DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts) 返回与指定参数匹配的 Element。

参数类型为 ContentModel 的 javax.swing.text.html.parser 中的构造方法
ContentModel(int type, ContentModel content)
创建一个特定类型的内容模式。
ContentModel(int type, Object content, ContentModel next)
创建一个特定类型的内容模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.DTD 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.DTD
的使用

使用 DTD 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 DTD 的使用

声明为 DTD 的 javax.swing.text.html.parser 中的字段
protected  DTD Parser.dtd

返回 DTD 的 javax.swing.text.html.parser 中的方法
protected static DTD | ParserDelegator.createDTD(DTD dtd, String name)
static DTD | DTD.getDTD(String name) 返回具有指定 name 的 DTD。

参数类型为 DTD 的 javax.swing.text.html.parser 中的方法
protected static DTD | ParserDelegator.createDTD(DTD dtd, String name)
static void | DTD.putDTDHash(String name, DTD dtd)

参数类型为 DTD 的 javax.swing.text.html.parser 中的构造方法
DocumentParser(DTD dtd)
Parser(DTD dtd)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.html.parser.DTDConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.html.parser.DTDConstants
的使用

使用 DTDConstants 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 DTDConstants 的使用

实现 DTDConstants 的 javax.swing.text.html.parser 中的类
class | AttributeList 此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。
class | DocumentParser HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。
class | DTD SGML DTD 的表示形式。
class | Element 使用 ELEMENT 构造在 DTD 中描述的一个元素。
class | Entity 使用 ENTITY 构造在 DTD 中描述了一个实体。
class | Parser 一个简单的 DTD 驱动的 HTML 解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.DocumentParser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.DocumentParser
的使用

没有 javax.swing.text.html.parser.DocumentParser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.Element 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.Element
的使用

使用 Element 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 Element 的使用

声明为 Element 的 javax.swing.text.html.parser 中的字段
Element | DTD.applet
Element | DTD.base
Element | DTD.body
Element | DTD.head
Element | DTD.html
Element | DTD.isindex
Element | DTD.meta
Element | DTD.p
Element | DTD.param
Element | DTD.pcdata
Element | DTD.title

类型参数类型为 Element 的 javax.swing.text.html.parser 中的字段
Hashtable<String,Element> | DTD.elementHash
Vector<Element> | DTD.elements

返回 Element 的 javax.swing.text.html.parser 中的方法
protected Element | DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts) 创建并返回一个 Element。
Element | DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts) 返回与指定参数匹配的 Element。
Element | ContentModel.first() 返回必须具有下一个的元素。
Element | TagElement.getElement()
Element | DTD.getElement(int index) 按索引获取一个元素。
Element | DTD.getElement(String name) 按名称获取一个元素。

参数类型为 Element 的 javax.swing.text.html.parser 中的方法
protected TagElement | Parser.makeTag(Element elem)
protected TagElement | Parser.makeTag(Element elem, boolean fictional) 制作 TagElement。
protected void | Parser.markFirstTime(Element elem) 标记在文档中首次看到标记

类型变量类型为 Element 的 javax.swing.text.html.parser 中的方法参数
 void ContentModel.getElements(Vector<Element> elemVec)
使用作为此 contentModel 一部分的元素列表更新 elemVec。

参数类型为 Element 的 javax.swing.text.html.parser 中的构造方法
ContentModel(Element content)
为元素创建一个内容模式。
TagElement(Element elem)
TagElement(Element elem, boolean fictional)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.Entity 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.Entity
的使用

使用 Entity 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 Entity 的使用

类型参数类型为 Entity 的 javax.swing.text.html.parser 中的字段
 Hashtable<Object,Entity> DTD.entityHash

返回 Entity 的 javax.swing.text.html.parser 中的方法
Entity | DTD.defEntity(String name, int type, int ch) 创建并返回一个字符 Entity。
protected Entity | DTD.defEntity(String name, int type, String str) 创建并返回一个 Entity。
Entity | DTD.defineEntity(String name, int type, char[] data) 定义一个实体。
Entity | DTD.getEntity(int ch) 获取一个字符实体。
Entity | DTD.getEntity(String name) 按名称获取一个实体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.Parser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.Parser
的使用

使用 Parser 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 Parser 的使用

javax.swing.text.html.parser 中 Parser 的子类
 class DocumentParser
HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.ParserDelegator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.ParserDelegator
的使用

没有 javax.swing.text.html.parser.ParserDelegator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.parser.TagElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.parser.TagElement
的使用

使用 TagElement 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 TagElement 的使用

返回 TagElement 的 javax.swing.text.html.parser 中的方法
protected TagElement | Parser.makeTag(Element elem)
protected TagElement | Parser.makeTag(Element elem, boolean fictional) 制作 TagElement。

参数类型为 TagElement 的 javax.swing.text.html.parser 中的方法
protected void | DocumentParser.handleEmptyTag(TagElement tag) 处理空标记。
protected void | Parser.handleEmptyTag(TagElement tag) 在遇到空标记时调用。
protected void | DocumentParser.handleEndTag(TagElement tag) 处理结束标记。
protected void | Parser.handleEndTag(TagElement tag) 在遇到结束标记时调用。
protected void | DocumentParser.handleStartTag(TagElement tag) 处理开始标记。
protected void | Parser.handleStartTag(TagElement tag) 在遇到开始标记时调用。
protected void | Parser.startTag(TagElement tag) 处理开始标记。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.BlockView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.BlockView
的使用

使用 BlockView 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 BlockView 的使用

javax.swing.text.html 中 BlockView 的子类
 class ListView
用于显示 html 列表的视图实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.CSS 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.CSS
的使用

没有 javax.swing.text.html.CSS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.CSS.Attribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.CSS.Attribute
的使用

使用 CSS.Attribute 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 CSS.Attribute 的使用

声明为 CSS.Attribute 的 javax.swing.text.html 中的字段
static CSS.Attribute | CSS.Attribute.BACKGROUND
static CSS.Attribute | CSS.Attribute.BACKGROUND_ATTACHMENT
static CSS.Attribute | CSS.Attribute.BACKGROUND_COLOR
static CSS.Attribute | CSS.Attribute.BACKGROUND_IMAGE
static CSS.Attribute | CSS.Attribute.BACKGROUND_POSITION
static CSS.Attribute | CSS.Attribute.BACKGROUND_REPEAT
static CSS.Attribute | CSS.Attribute.BORDER
static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM
static CSS.Attribute | CSS.Attribute.BORDER_BOTTOM_WIDTH
static CSS.Attribute | CSS.Attribute.BORDER_COLOR
static CSS.Attribute | CSS.Attribute.BORDER_LEFT
static CSS.Attribute | CSS.Attribute.BORDER_LEFT_WIDTH
static CSS.Attribute | CSS.Attribute.BORDER_RIGHT
static CSS.Attribute | CSS.Attribute.BORDER_RIGHT_WIDTH
static CSS.Attribute | CSS.Attribute.BORDER_STYLE
static CSS.Attribute | CSS.Attribute.BORDER_TOP
static CSS.Attribute | CSS.Attribute.BORDER_TOP_WIDTH
static CSS.Attribute | CSS.Attribute.BORDER_WIDTH
static CSS.Attribute | CSS.Attribute.CLEAR
static CSS.Attribute | CSS.Attribute.COLOR
static CSS.Attribute | CSS.Attribute.DISPLAY
static CSS.Attribute | CSS.Attribute.FLOAT
static CSS.Attribute | CSS.Attribute.FONT
static CSS.Attribute | CSS.Attribute.FONT_FAMILY
static CSS.Attribute | CSS.Attribute.FONT_SIZE
static CSS.Attribute | CSS.Attribute.FONT_STYLE
static CSS.Attribute | CSS.Attribute.FONT_VARIANT
static CSS.Attribute | CSS.Attribute.FONT_WEIGHT
static CSS.Attribute | CSS.Attribute.HEIGHT
static CSS.Attribute | CSS.Attribute.LETTER_SPACING
static CSS.Attribute | CSS.Attribute.LINE_HEIGHT
static CSS.Attribute | CSS.Attribute.LIST_STYLE
static CSS.Attribute | CSS.Attribute.LIST_STYLE_IMAGE
static CSS.Attribute | CSS.Attribute.LIST_STYLE_POSITION
static CSS.Attribute | CSS.Attribute.LIST_STYLE_TYPE
static CSS.Attribute | CSS.Attribute.MARGIN
static CSS.Attribute | CSS.Attribute.MARGIN_BOTTOM
static CSS.Attribute | CSS.Attribute.MARGIN_LEFT
static CSS.Attribute | CSS.Attribute.MARGIN_RIGHT
static CSS.Attribute | CSS.Attribute.MARGIN_TOP
static CSS.Attribute | CSS.Attribute.PADDING
static CSS.Attribute | CSS.Attribute.PADDING_BOTTOM
static CSS.Attribute | CSS.Attribute.PADDING_LEFT
static CSS.Attribute | CSS.Attribute.PADDING_RIGHT
static CSS.Attribute | CSS.Attribute.PADDING_TOP
static CSS.Attribute | CSS.Attribute.TEXT_ALIGN
static CSS.Attribute | CSS.Attribute.TEXT_DECORATION
static CSS.Attribute | CSS.Attribute.TEXT_INDENT
static CSS.Attribute | CSS.Attribute.TEXT_TRANSFORM
static CSS.Attribute | CSS.Attribute.VERTICAL_ALIGN
static CSS.Attribute | CSS.Attribute.WHITE_SPACE
static CSS.Attribute | CSS.Attribute.WIDTH
static CSS.Attribute | CSS.Attribute.WORD_SPACING

返回 CSS.Attribute 的 javax.swing.text.html 中的方法
static CSS.Attribute[] | CSS.getAllAttributeKeys() 返回所有可能的 CSS 属性键集合。
static CSS.Attribute | CSS.getAttribute(String name) 将字符串转换为 CSS.Attribute 对象。

参数类型为 CSS.Attribute 的 javax.swing.text.html 中的方法
void | StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。
boolean | StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.FormSubmitEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.FormSubmitEvent
的使用

没有 javax.swing.text.html.FormSubmitEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.FormSubmitEvent.MethodType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.FormSubmitEvent.MethodType
的使用

使用 FormSubmitEvent.MethodType 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 FormSubmitEvent.MethodType 的使用

返回 FormSubmitEvent.MethodType 的 javax.swing.text.html 中的方法
FormSubmitEvent.MethodType | FormSubmitEvent.getMethod() 获取表单方法类型。
static FormSubmitEvent.MethodType | FormSubmitEvent.MethodType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static FormSubmitEvent.MethodType[] | FormSubmitEvent.MethodType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.FormView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.FormView
的使用

没有 javax.swing.text.html.FormView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.FormView.MouseEventListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.FormView.MouseEventListener
的使用

没有 javax.swing.text.html.FormView.MouseEventListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTML 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTML
的使用

没有 javax.swing.text.html.HTML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTML.Tag 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTML.Tag
的使用

使用 HTML.Tag 的软件包
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html 中 HTML.Tag 的使用

javax.swing.text.html 中 HTML.Tag 的子类
static class HTML.UnknownTag

声明为 HTML.Tag 的 javax.swing.text.html 中的字段
static HTML.Tag | HTML.Tag.A
static HTML.Tag | HTML.Tag.ADDRESS
protected HTML.Tag | HTMLEditorKit.InsertHTMLTextAction.addTag HTML 中的 Tag（从此 Tag 开始添加标记）。
protected HTML.Tag | HTMLEditorKit.InsertHTMLTextAction.alternateAddTag HTML 中的替换 Tag，如果未找到 parentTag 但找到了 alternateParentTag，则从此替换 Tag 开始添加标记。
protected HTML.Tag | HTMLEditorKit.InsertHTMLTextAction.alternateParentTag 如果未找到 parentTag，则要在文档中检查的替换 Tag。
static HTML.Tag | HTML.Tag.APPLET
static HTML.Tag | HTML.Tag.AREA
static HTML.Tag | HTML.Tag.B
static HTML.Tag | HTML.Tag.BASE
static HTML.Tag | HTML.Tag.BASEFONT
static HTML.Tag | HTML.Tag.BIG
static HTML.Tag | HTML.Tag.BLOCKQUOTE
static HTML.Tag | HTML.Tag.BODY
static HTML.Tag | HTML.Tag.BR
static HTML.Tag | HTML.Tag.CAPTION
static HTML.Tag | HTML.Tag.CENTER
static HTML.Tag | HTML.Tag.CITE
static HTML.Tag | HTML.Tag.CODE
static HTML.Tag | HTML.Tag.COMMENT 所有注释以此标记作为标签。
static HTML.Tag | HTML.Tag.CONTENT 所有文本内容以此标记作为标签。
static HTML.Tag | HTML.Tag.DD
static HTML.Tag | HTML.Tag.DFN
static HTML.Tag | HTML.Tag.DIR
static HTML.Tag | HTML.Tag.DIV
static HTML.Tag | HTML.Tag.DL
static HTML.Tag | HTML.Tag.DT
static HTML.Tag | HTML.Tag.EM
static HTML.Tag | HTML.Tag.FONT
static HTML.Tag | HTML.Tag.FORM
static HTML.Tag | HTML.Tag.FRAME
static HTML.Tag | HTML.Tag.FRAMESET
static HTML.Tag | HTML.Tag.H1
static HTML.Tag | HTML.Tag.H2
static HTML.Tag | HTML.Tag.H3
static HTML.Tag | HTML.Tag.H4
static HTML.Tag | HTML.Tag.H5
static HTML.Tag | HTML.Tag.H6
static HTML.Tag | HTML.Tag.HEAD
static HTML.Tag | HTML.Tag.HR
static HTML.Tag | HTML.Tag.HTML
static HTML.Tag | HTML.Tag.I
static HTML.Tag | HTML.Tag.IMG
static HTML.Tag | HTML.Tag.IMPLIED 所有文本内容必须包含在段落元素中。
static HTML.Tag | HTML.Tag.INPUT
static HTML.Tag | HTML.Tag.ISINDEX
static HTML.Tag | HTML.Tag.KBD
static HTML.Tag | HTML.Tag.LI
static HTML.Tag | HTML.Tag.LINK
static HTML.Tag | HTML.Tag.MAP
static HTML.Tag | HTML.Tag.MENU
static HTML.Tag | HTML.Tag.META
static HTML.Tag | HTML.Tag.NOFRAMES
static HTML.Tag | HTML.Tag.OBJECT
static HTML.Tag | HTML.Tag.OL
static HTML.Tag | HTML.Tag.OPTION
static HTML.Tag | HTML.Tag.P
static HTML.Tag | HTML.Tag.PARAM
protected HTML.Tag | HTMLEditorKit.InsertHTMLTextAction.parentTag 要在文档中检查的 Tag。
static HTML.Tag | HTML.Tag.PRE
static HTML.Tag | HTML.Tag.S
static HTML.Tag | HTML.Tag.SAMP
static HTML.Tag | HTML.Tag.SCRIPT
static HTML.Tag | HTML.Tag.SELECT
static HTML.Tag | HTML.Tag.SMALL
static HTML.Tag | HTML.Tag.SPAN
static HTML.Tag | HTML.Tag.STRIKE
static HTML.Tag | HTML.Tag.STRONG
static HTML.Tag | HTML.Tag.STYLE
static HTML.Tag | HTML.Tag.SUB
static HTML.Tag | HTML.Tag.SUP
static HTML.Tag | HTML.Tag.TABLE
static HTML.Tag | HTML.Tag.TD
static HTML.Tag | HTML.Tag.TEXTAREA
static HTML.Tag | HTML.Tag.TH
static HTML.Tag | HTML.Tag.TITLE
static HTML.Tag | HTML.Tag.TR
static HTML.Tag | HTML.Tag.TT
static HTML.Tag | HTML.Tag.U
static HTML.Tag | HTML.Tag.UL
static HTML.Tag | HTML.Tag.VAR

返回 HTML.Tag 的 javax.swing.text.html 中的方法
static HTML.Tag[] | HTML.getAllTags() 返回默认 HTML reader 所识别的实际 HTML 标记集。
abstract HTML.Tag | HTMLDocument.Iterator.getTag() 此迭代器所表示的标记类型。
static HTML.Tag | HTML.getTag(String tagName) 获取已知标记名称的标记常量（即集合 {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR} 中的某个标记）。

参数类型为 HTML.Tag 的 javax.swing.text.html 中的方法
protected void | HTMLDocument.HTMLReader.addSpecialElement(HTML.Tag t, MutableAttributeSet a) 添加基本上完全是在属性集中指定的内容。
protected void | HTMLDocument.HTMLReader.blockClose(HTML.Tag t) 向解析器缓冲区添加一条指令，以关闭给定类型的块元素。
protected void | HTMLDocument.HTMLReader.blockOpen(HTML.Tag t, MutableAttributeSet attr) 向解析器缓冲区添加一条指令，以创建具有给定属性的块元素。
protected int | HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回要获得表示 tag 的元素时，从最深的叶元素开始所需的元素数。
void | HTMLDocument.HTMLReader.TagAction.end(HTML.Tag t) 当发现此动作所注册的标记类型的结束标记时调用。
void | HTMLDocument.HTMLReader.BlockAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.ParagraphAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.HiddenAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.PreAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.CharacterAction.end(HTML.Tag t)
void | HTMLDocument.HTMLReader.FormAction.end(HTML.Tag t)
protected Element | HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回在 offset 处与 tag 匹配的最深的元素。
HTMLDocument.Iterator | HTMLDocument.getIterator(HTML.Tag t) 获取指定 HTML 标记的迭代器。
HTMLEditorKit.ParserCallback | HTMLDocument.getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag) 返回加载带有 HTML 的文档时所用解析器的 reader。
Style | StyleSheet.getRule(HTML.Tag t, Element e) 获取用来呈现给定类型的 HTML 标记的样式。
void | HTMLDocument.HTMLReader.handleEndTag(HTML.Tag t, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleEndTag(HTML.Tag t, int pos)
void | HTMLDocument.HTMLReader.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
void | HTMLDocument.HTMLReader.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
void | HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag) 将 HTML 插入现有文档。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag) HTMLEditorKit.insertHTML 的一个覆盖。
protected boolean | HTMLWriter.matchNameAttribute(AttributeSet attr, HTML.Tag tag) 如果 StyleConstants.NameAttribute 与作为参数传入的标记相同，则返回 true。
protected void | HTMLDocument.HTMLReader.registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a) 注册给定标记的处理程序。
void | HTMLDocument.HTMLReader.TagAction.start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
void | HTMLDocument.HTMLReader.BlockAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.ParagraphAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.SpecialAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.IsindexAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.HiddenAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.PreAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.CharacterAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.FormAction.start(HTML.Tag t, MutableAttributeSet attr)

参数类型为 HTML.Tag 的 javax.swing.text.html 中的构造方法
HTMLDocument.HTMLReader(int offset, int popDepth, int pushDepth, HTML.Tag insertTag)
HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)
HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)

javax.swing.text.html.parser 中 HTML.Tag 的使用

返回 HTML.Tag 的 javax.swing.text.html.parser 中的方法
 HTML.Tag TagElement.getHTMLTag()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTML.UnknownTag 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTML.UnknownTag
的使用

没有 javax.swing.text.html.HTML.UnknownTag 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTML.Attribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTML.Attribute
的使用

使用 HTML.Attribute 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTML.Attribute 的使用

声明为 HTML.Attribute 的 javax.swing.text.html 中的字段
static HTML.Attribute | HTML.Attribute.ACTION
static HTML.Attribute | HTML.Attribute.ALIGN
static HTML.Attribute | HTML.Attribute.ALINK
static HTML.Attribute | HTML.Attribute.ALT
static HTML.Attribute | HTML.Attribute.ARCHIVE
static HTML.Attribute | HTML.Attribute.BACKGROUND
static HTML.Attribute | HTML.Attribute.BGCOLOR
static HTML.Attribute | HTML.Attribute.BORDER
static HTML.Attribute | HTML.Attribute.CELLPADDING
static HTML.Attribute | HTML.Attribute.CELLSPACING
static HTML.Attribute | HTML.Attribute.CHECKED
static HTML.Attribute | HTML.Attribute.CLASS
static HTML.Attribute | HTML.Attribute.CLASSID
static HTML.Attribute | HTML.Attribute.CLEAR
static HTML.Attribute | HTML.Attribute.CODE
static HTML.Attribute | HTML.Attribute.CODEBASE
static HTML.Attribute | HTML.Attribute.CODETYPE
static HTML.Attribute | HTML.Attribute.COLOR
static HTML.Attribute | HTML.Attribute.COLS
static HTML.Attribute | HTML.Attribute.COLSPAN
static HTML.Attribute | HTML.Attribute.COMMENT
static HTML.Attribute | HTML.Attribute.COMPACT
static HTML.Attribute | HTML.Attribute.CONTENT
static HTML.Attribute | HTML.Attribute.COORDS
static HTML.Attribute | HTML.Attribute.DATA
static HTML.Attribute | HTML.Attribute.DECLARE
static HTML.Attribute | HTML.Attribute.DIR
static HTML.Attribute | HTML.Attribute.DUMMY
static HTML.Attribute | HTML.Attribute.ENCTYPE
static HTML.Attribute | HTML.Attribute.ENDTAG
static HTML.Attribute | HTML.Attribute.FACE
static HTML.Attribute | HTML.Attribute.FRAMEBORDER
static HTML.Attribute | HTML.Attribute.HALIGN
static HTML.Attribute | HTML.Attribute.HEIGHT
static HTML.Attribute | HTML.Attribute.HREF
static HTML.Attribute | HTML.Attribute.HSPACE
static HTML.Attribute | HTML.Attribute.HTTPEQUIV
static HTML.Attribute | HTML.Attribute.ID
static HTML.Attribute | HTML.Attribute.ISMAP
static HTML.Attribute | HTML.Attribute.LANG
static HTML.Attribute | HTML.Attribute.LANGUAGE
static HTML.Attribute | HTML.Attribute.LINK
static HTML.Attribute | HTML.Attribute.LOWSRC
static HTML.Attribute | HTML.Attribute.MARGINHEIGHT
static HTML.Attribute | HTML.Attribute.MARGINWIDTH
static HTML.Attribute | HTML.Attribute.MAXLENGTH
static HTML.Attribute | HTML.Attribute.METHOD
static HTML.Attribute | HTML.Attribute.MULTIPLE
static HTML.Attribute | HTML.Attribute.N
static HTML.Attribute | HTML.Attribute.NAME
static HTML.Attribute | HTML.Attribute.NOHREF
static HTML.Attribute | HTML.Attribute.NORESIZE
static HTML.Attribute | HTML.Attribute.NOSHADE
static HTML.Attribute | HTML.Attribute.NOWRAP
static HTML.Attribute | HTML.Attribute.PROMPT
static HTML.Attribute | HTML.Attribute.REL
static HTML.Attribute | HTML.Attribute.REV
static HTML.Attribute | HTML.Attribute.ROWS
static HTML.Attribute | HTML.Attribute.ROWSPAN
static HTML.Attribute | HTML.Attribute.SCROLLING
static HTML.Attribute | HTML.Attribute.SELECTED
static HTML.Attribute | HTML.Attribute.SHAPE
static HTML.Attribute | HTML.Attribute.SHAPES
static HTML.Attribute | HTML.Attribute.SIZE
static HTML.Attribute | HTML.Attribute.SRC
static HTML.Attribute | HTML.Attribute.STANDBY
static HTML.Attribute | HTML.Attribute.START
static HTML.Attribute | HTML.Attribute.STYLE
static HTML.Attribute | HTML.Attribute.TARGET
static HTML.Attribute | HTML.Attribute.TEXT
static HTML.Attribute | HTML.Attribute.TITLE
static HTML.Attribute | HTML.Attribute.TYPE
static HTML.Attribute | HTML.Attribute.USEMAP
static HTML.Attribute | HTML.Attribute.VALIGN
static HTML.Attribute | HTML.Attribute.VALUE
static HTML.Attribute | HTML.Attribute.VALUETYPE
static HTML.Attribute | HTML.Attribute.VERSION
static HTML.Attribute | HTML.Attribute.VLINK
static HTML.Attribute | HTML.Attribute.VSPACE
static HTML.Attribute | HTML.Attribute.WIDTH

返回 HTML.Attribute 的 javax.swing.text.html 中的方法
static HTML.Attribute[] | HTML.getAllAttributeKeys() 返回所识别的 HTML 属性集。
static HTML.Attribute | HTML.getAttributeKey(String attName) 获取已知属性名称的属性常量（即集合 {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG} 中的某个属性）。

参数类型为 HTML.Attribute 的 javax.swing.text.html 中的方法
static int HTML.getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def)
获取整数属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument
的使用

使用 HTMLDocument 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument 的使用

返回 HTMLDocument 的 javax.swing.text.html 中的方法
protected  HTMLDocument HTMLEditorKit.HTMLTextAction.getHTMLDocument(JEditorPane e)

参数类型为 HTMLDocument 的 javax.swing.text.html 中的方法
protected int | HTMLEditorKit.HTMLTextAction.elementCountToTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回要获得表示 tag 的元素时，从最深的叶元素开始所需的元素数。
protected Element | HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回在 offset 处与 tag 匹配的最深的元素。
protected Element[] | HTMLEditorKit.HTMLTextAction.getElementsAt(HTMLDocument doc, int offset) 返回包含 offset 的 Elements 数组。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
void | HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag) 将 HTML 插入现有文档。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag) HTMLEditorKit.insertHTML 的一个覆盖。

参数类型为 HTMLDocument 的 javax.swing.text.html 中的构造方法
HTMLWriter(Writer w, HTMLDocument doc)
创建新的 HTMLWriter。
HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
创建新的 HTMLWriter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.Iterator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.Iterator
的使用

使用 HTMLDocument.Iterator 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument.Iterator 的使用

返回 HTMLDocument.Iterator 的 javax.swing.text.html 中的方法
 HTMLDocument.Iterator HTMLDocument.getIterator(HTML.Tag t)
获取指定 HTML 标记的迭代器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
的使用

使用 HTMLDocument.HTMLReader.TagAction 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument.HTMLReader.TagAction 的使用

javax.swing.text.html 中 HTMLDocument.HTMLReader.TagAction 的子类
class | HTMLDocument.HTMLReader.BlockAction
class | HTMLDocument.HTMLReader.CharacterAction
class | HTMLDocument.HTMLReader.FormAction 此动作通过构建所有用于表示表单控件的元素来支持表单。
class | HTMLDocument.HTMLReader.HiddenAction
class | HTMLDocument.HTMLReader.IsindexAction
class | HTMLDocument.HTMLReader.ParagraphAction
class | HTMLDocument.HTMLReader.PreAction
class | HTMLDocument.HTMLReader.SpecialAction

参数类型为 HTMLDocument.HTMLReader.TagAction 的 javax.swing.text.html 中的方法
protected  void HTMLDocument.HTMLReader.registerTag(HTML.Tag t, HTMLDocument.HTMLReader.TagAction a)
注册给定标记的处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.Option 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.Option
的使用

使用 Option 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 Option 的使用

参数类型为 Option 的 javax.swing.text.html 中的方法
protected  void HTMLWriter.writeOption(Option option)
写出 Option 表单元素的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
的使用

使用 HTMLDocument.HTMLReader.BlockAction 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument.HTMLReader.BlockAction 的使用

javax.swing.text.html 中 HTMLDocument.HTMLReader.BlockAction 的子类
class | HTMLDocument.HTMLReader.ParagraphAction
class | HTMLDocument.HTMLReader.PreAction

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
的使用

使用 HTMLDocument.HTMLReader.SpecialAction 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLDocument.HTMLReader.SpecialAction 的使用

javax.swing.text.html 中 HTMLDocument.HTMLReader.SpecialAction 的子类
 class HTMLDocument.HTMLReader.FormAction
此动作通过构建所有用于表示表单控件的元素来支持表单。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
的使用

没有 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.RunElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.RunElement
的使用

没有 javax.swing.text.html.HTMLDocument.RunElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLDocument.BlockElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLDocument.BlockElement
的使用

没有 javax.swing.text.html.HTMLDocument.BlockElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit
的使用

使用 HTMLEditorKit 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLEditorKit 的使用

返回 HTMLEditorKit 的 javax.swing.text.html 中的方法
protected  HTMLEditorKit HTMLEditorKit.HTMLTextAction.getHTMLEditorKit(JEditorPane e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.LinkController 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.LinkController
的使用

没有 javax.swing.text.html.HTMLEditorKit.LinkController 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.Parser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.Parser
的使用

使用 HTMLEditorKit.Parser 的软件包
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html 中 HTMLEditorKit.Parser 的使用

返回 HTMLEditorKit.Parser 的 javax.swing.text.html 中的方法
HTMLEditorKit.Parser | HTMLDocument.getParser() 返回将 HTML 插入现有文档时所使用的解析器。
protected HTMLEditorKit.Parser | HTMLEditorKit.getParser() 获取要用于读取 HTML 流的解析器。

参数类型为 HTMLEditorKit.Parser 的 javax.swing.text.html 中的方法
 void HTMLDocument.setParser(HTMLEditorKit.Parser parser)
设置将 html 插入现有文档的方法所使用的解析器，例如 setInnerHTML 和 setOuterHTML。

javax.swing.text.html.parser 中 HTMLEditorKit.Parser 的使用

javax.swing.text.html.parser 中 HTMLEditorKit.Parser 的子类
 class ParserDelegator
负责每次在调用其 parse 方法时启动一个新的 DocumentParser。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.ParserCallback 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.ParserCallback
的使用

使用 HTMLEditorKit.ParserCallback 的软件包
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html 中 HTMLEditorKit.ParserCallback 的使用

javax.swing.text.html 中 HTMLEditorKit.ParserCallback 的子类
 class HTMLDocument.HTMLReader
一个 HTML reader，用来加载具有 HTML 元素结构的 HTML 文档。

返回 HTMLEditorKit.ParserCallback 的 javax.swing.text.html 中的方法
HTMLEditorKit.ParserCallback | HTMLDocument.getReader(int pos) 获取加载带有 HTML 的文档时所用解析器的 reader。
HTMLEditorKit.ParserCallback | HTMLDocument.getReader(int pos, int popDepth, int pushDepth, HTML.Tag insertTag) 返回加载带有 HTML 的文档时所用解析器的 reader。

参数类型为 HTMLEditorKit.ParserCallback 的 javax.swing.text.html 中的方法
abstract  void HTMLEditorKit.Parser.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
解析给定的流并通过解析的结果驱动给定的回调。

javax.swing.text.html.parser 中 HTMLEditorKit.ParserCallback 的使用

参数类型为 HTMLEditorKit.ParserCallback 的 javax.swing.text.html.parser 中的方法
void | DocumentParser.parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
void | ParserDelegator.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.HTMLFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.HTMLFactory
的使用

没有 javax.swing.text.html.HTMLEditorKit.HTMLFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction
的使用

使用 HTMLEditorKit.HTMLTextAction 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLEditorKit.HTMLTextAction 的使用

javax.swing.text.html 中 HTMLEditorKit.HTMLTextAction 的子类
static class HTMLEditorKit.InsertHTMLTextAction
InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
的使用

没有 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLFrameHyperlinkEvent
的使用

使用 HTMLFrameHyperlinkEvent 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 HTMLFrameHyperlinkEvent 的使用

javax.swing.text.html 中 HTMLFrameHyperlinkEvent 的子类
 class FormSubmitEvent
FormSubmitEvent 用于通知提交表单所需的参与者。

参数类型为 HTMLFrameHyperlinkEvent 的 javax.swing.text.html 中的方法
 void HTMLDocument.processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent e)
处理 HTML 框架中的文档所生成的 HyperlinkEvents。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.HTMLWriter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.HTMLWriter
的使用

没有 javax.swing.text.html.HTMLWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.ImageView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.ImageView
的使用

没有 javax.swing.text.html.ImageView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.InlineView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.InlineView
的使用

没有 javax.swing.text.html.InlineView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.ListView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.ListView
的使用

没有 javax.swing.text.html.ListView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.MinimalHTMLWriter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.MinimalHTMLWriter
的使用

没有 javax.swing.text.html.MinimalHTMLWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.ObjectView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.ObjectView
的使用

没有 javax.swing.text.html.ObjectView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.ParagraphView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.ParagraphView
的使用

没有 javax.swing.text.html.ParagraphView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.StyleSheet 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.StyleSheet
的使用

使用 StyleSheet 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 StyleSheet 的使用

返回 StyleSheet 的 javax.swing.text.html 中的方法
protected StyleSheet | BlockView.getStyleSheet()
StyleSheet | HTMLDocument.getStyleSheet() 获取具有特定于文档的显示规则（CSS）的 StyleSheet，其中这些规则是在 HTML 文档本身中指定的。
StyleSheet | HTMLEditorKit.getStyleSheet() 获取当前正用于呈现 HTML 元素的样式集。
protected StyleSheet | ImageView.getStyleSheet() 获取 StyleSheet 的便捷方法。
protected StyleSheet | InlineView.getStyleSheet()
protected StyleSheet | ParagraphView.getStyleSheet()
StyleSheet[] | StyleSheet.getStyleSheets() 返回一个链接 StyleSheet 的数组。

参数类型为 StyleSheet 的 javax.swing.text.html 中的方法
void | StyleSheet.addStyleSheet(StyleSheet ss) 将 StyleSheet ss 中的规则添加到接收者的规则中。
void | StyleSheet.removeStyleSheet(StyleSheet ss) 从接收者的规则中移除 StyleSheet ss。
void | HTMLEditorKit.setStyleSheet(StyleSheet s) 设置要用于呈现各种 HTML 元素的样式集。

参数类型为 StyleSheet 的 javax.swing.text.html 中的构造方法
HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
构造具有给定内容存储实现和给定样式/属性存储机制的 HTML 文档。
HTMLDocument(StyleSheet styles)
构造具有默认内容存储实现和指定样式/属性存储机制的 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.StyleSheet.BoxPainter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.StyleSheet.BoxPainter
的使用

使用 StyleSheet.BoxPainter 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 StyleSheet.BoxPainter 的使用

返回 StyleSheet.BoxPainter 的 javax.swing.text.html 中的方法
 StyleSheet.BoxPainter StyleSheet.getBoxPainter(AttributeSet a)
获取给定 CSS 属性集合使用的框 formatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.html.StyleSheet.ListPainter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.html.StyleSheet.ListPainter
的使用

使用 StyleSheet.ListPainter 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 StyleSheet.ListPainter 的使用

返回 StyleSheet.ListPainter 的 javax.swing.text.html 中的方法
 StyleSheet.ListPainter StyleSheet.getListPainter(AttributeSet a)
获取给定 CSS 属性集合使用的列表 formatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AbstractWriter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractWriter
的使用

使用 AbstractWriter 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 AbstractWriter 的使用

javax.swing.text.html 中 AbstractWriter 的子类
class | HTMLWriter 这是用于 HTMLDocuments 的 writer。
class | MinimalHTMLWriter MinimalHTMLWriter 是一个回退 writer，HTMLEditorKit 使用它为非 EditorKit 生成的文档写出 HTML。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AsyncBoxView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AsyncBoxView
的使用

没有 javax.swing.text.AsyncBoxView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AsyncBoxView.ChildLocator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AsyncBoxView.ChildLocator
的使用

使用 AsyncBoxView.ChildLocator 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AsyncBoxView.ChildLocator 的使用

声明为 AsyncBoxView.ChildLocator 的 javax.swing.text 中的字段
protected  AsyncBoxView.ChildLocator AsyncBoxView.locator
这是管理子视图偏移量的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AsyncBoxView.ChildState 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AsyncBoxView.ChildState
的使用

使用 AsyncBoxView.ChildState 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AsyncBoxView.ChildState 的使用

声明为 AsyncBoxView.ChildState 的 javax.swing.text 中的字段
protected  AsyncBoxView.ChildState AsyncBoxView.ChildLocator.lastValidOffset
最后一次有效偏移量计算的位置。

返回 AsyncBoxView.ChildState 的 javax.swing.text 中的方法
protected AsyncBoxView.ChildState | AsyncBoxView.createChildState(View v) 通过此方法创建新的 ChildState 记录，以允许扩展 ChildState 记录的子类执行/保存更多状态。
protected AsyncBoxView.ChildState | AsyncBoxView.getChildState(int index) 获取对象，该对象表示在给定索引位置的子视图的布局状态。

参数类型为 AsyncBoxView.ChildState 的 javax.swing.text 中的方法
void | AsyncBoxView.ChildLocator.childChanged(AsyncBoxView.ChildState cs) 子级已更改的通知。
protected void | AsyncBoxView.majorRequirementChange(AsyncBoxView.ChildState cs, float delta) 沿主轴上的要求更改。
protected void | AsyncBoxView.minorRequirementChange(AsyncBoxView.ChildState cs) 沿辅轴上的要求更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.BadLocationException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.BadLocationException
的使用

使用 BadLocationException 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing 中的方法
int | JTextArea.getLineEndOffset(int line) 确定给定行结尾处的偏移量。
int | JTextArea.getLineOfOffset(int offset) 将组件文本中的偏移量转换为行号。
int | JTextArea.getLineStartOffset(int line) 确定给定行起始处的偏移量。
String | JPasswordField.getText(int offs, int len) 已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。

javax.swing.plaf 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.plaf 中的方法
abstract int | TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。

javax.swing.plaf.basic 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.plaf.basic 中的方法
int | BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。

javax.swing.plaf.multi 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.plaf.multi 中的方法
int | MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b) 在由此对象处理的每个 UI 上调用 modelToView 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。

javax.swing.text 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.text 中的方法
 Object DefaultHighlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
向视图添加高亮显示。
 Object Highlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
向视图添加高亮显示。
 void DefaultHighlighter.changeHighlight(Object tag, int p0, int p1)
更改高亮显示。
 void Highlighter.changeHighlight(Object tag, int p0, int p1)
更改给定的高亮显示，以使其横跨文档的不同部分。
 Position StringContent.createPosition(int offset)
在内容中创建一个位置，让其跟踪随内容的变化而进行的更改。
 Position GapContent.createPosition(int offset)
在内容中创建一个位置，使其在内容发生变化时能跟踪内容的更改。
 Position AbstractDocument.createPosition(int offs)
返回更改文档时，将跟踪更改的位置。
 Position AbstractDocument.Content.createPosition(int offset)
在内容中创建一个位置，该位置将在内容改变时跟踪更改。
 Position Document.createPosition(int offs)
此方法允许应用程序在字符内容序列中标记位置。
protected  int PasswordView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为选定文本。
protected  int WrappedPlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为所选文本。
protected  int PlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为选定文本。
protected  int PasswordView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为正常的未选定文本。
protected  int WrappedPlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
将模型中的给定范围呈现为普通未选择的文本。
protected  int PlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1)
将模型中给定的范围呈现为正常的未选定文本。
 void StringContent.getChars(int where, int len, Segment chars)
检索内容的某一部分，where ＋ len 必须 <= length()
 void GapContent.getChars(int where, int len, Segment chars)
检索部分内容。
 void AbstractDocument.Content.getChars(int where, int len, Segment txt)
获得字符序列并将其复制到 Segment 中。
protected  int ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x)
返回最接近 x 处的模型位置。
protected  int CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
返回光标的下一个可视位置，可以在东或在西。
protected  int CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
返回光标的下一个可视位置，可以在北也可以在南。
protected  int ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
在东或西方向返回光标的下一个可视位置。
 int GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
 int AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
 int CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
 int GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
 int View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet)
提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
 int NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet)
返回从现在位置起的下一个放置插入符的可视位置。
static int Utilities.getNextWord(JTextComponent c, int offs)
确定针对给定位置的下一个单词开头。
static int Utilities.getPositionAbove(JTextComponent c, int offs, int x)
确定模型中离行上方给定的视图位置最近的位置。
static int Utilities.getPositionBelow(JTextComponent c, int offs, int x)
确定模型中离行下方给定的视图位置最近的位置。
static int Utilities.getPreviousWord(JTextComponent c, int offs)
确定针对给定位置的上一个单词开头。
static int Utilities.getRowEnd(JTextComponent c, int offs)
确定包含指定模型位置的行的结束行模型位置。
static int Utilities.getRowStart(JTextComponent c, int offs)
确定包含指定模型位置的行的起始行模型位置。
 String StringContent.getString(int where, int len)
检索内容的某一部分，where ＋ len 必须 <= length()。
 String GapContent.getString(int where, int len)
检索部分内容。
 String AbstractDocument.Content.getString(int where, int len)
获取序列中包含的字符串。
protected  String AbstractWriter.getText(Element elem)
返回与该元素关联的文本。
 String JTextComponent.getText(int offs, int len)
获取由组件表示的文本部分。
 String AbstractDocument.getText(int offset, int length)
从文档中获得文本序列。
 String Document.getText(int offset, int length)
获取文档中给定部分包含的文本。
 void AbstractDocument.getText(int offset, int length, Segment txt)
获取文档给定部分内包含的文本。
 void Document.getText(int offset, int length, Segment txt)
获取文档中给定部分包含的文本。
static int Utilities.getWordEnd(JTextComponent c, int offs)
确定针对给定位置的单词结尾。
static int Utilities.getWordStart(JTextComponent c, int offs)
确定针对给定模型位置的单词开头。
protected  void DefaultStyledDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data)
批量插入新元素。
 void DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)
将文本插入指定的 Document 之前调用。
 UndoableEdit StringContent.insertString(int where, String str)
将字符串插入到内容中。
 UndoableEdit GapContent.insertString(int where, String str)
在内容中插入字符串。
 UndoableEdit AbstractDocument.Content.insertString(int where, String str)
向序列中插入一个字符串。
abstract  void DocumentFilter.FilterBypass.insertString(int offset, String string, AttributeSet attr)
插入指定的文本，绕过 DocumentFilter。
 void PlainDocument.insertString(int offs, String str, AttributeSet a)
向文档中插入某些内容。
 void AbstractDocument.insertString(int offs, String str, AttributeSet a)
将某些内容插入文档。
 void Document.insertString(int offset, String str, AttributeSet a)
插入内容字符串。
abstract  Shape GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Rectangle JTextComponent.modelToView(int pos)
将模型中给定位置转换为视图坐标系统中的位置。
 Shape CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a)
为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
 Shape View.modelToView(int pos, Shape a)
已过时。
 Shape AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape BoxView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
 Shape ComponentView.modelToView(int pos, Shape a, Position.Bias b)
提供模型坐标空间到视图坐标空间的映射。
 Shape CompositeView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape GlyphView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape IconView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape PasswordView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape FieldView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
 Shape PlainView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract  Shape View.modelToView(int pos, Shape a, Position.Bias b)
为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
 void DefaultEditorKit.read(InputStream in, Document doc, int pos)
插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract  void EditorKit.read(InputStream in, Document doc, int pos)
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
 void DefaultEditorKit.read(Reader in, Document doc, int pos)
插入取自给定流的内容，它将被视为纯文本。
abstract  void EditorKit.read(Reader in, Document doc, int pos)
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
 void DocumentFilter.remove(DocumentFilter.FilterBypass fb, int offset, int length)
移除指定 Document 中的指定区域之前调用。
abstract  void DocumentFilter.FilterBypass.remove(int offset, int length)
移除指定的文本区域，绕过 DocumentFilter。
 UndoableEdit StringContent.remove(int where, int nitems)
移除部分内容，其中 where ＋ nitems 必须 < length()。
 UndoableEdit GapContent.remove(int where, int nitems)
移除部分内容。
 void AbstractDocument.remove(int offs, int len)
从文档中移除某些内容。
 UndoableEdit AbstractDocument.Content.remove(int where, int nitems)
移除该序列的某一部分。
 void Document.remove(int offs, int len)
移除文档的部分内容。
 void DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)
在替换指定的 Document 中的文本区域之前调用。
abstract  void DocumentFilter.FilterBypass.replace(int offset, int length, String string, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换。
 void AbstractDocument.replace(int offset, int length, String text, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换它。
protected  void AbstractWriter.text(Element elem)
写出文本。
protected abstract  void AbstractWriter.write()
需要由子类实现此抽象方法。
 void DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len)
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract  void EditorKit.write(OutputStream out, Document doc, int pos, int len)
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
 void DefaultEditorKit.write(Writer out, Document doc, int pos, int len)
将取自文档的内容以纯文本格式写入给定流。
abstract  void EditorKit.write(Writer out, Document doc, int pos, int len)
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

javax.swing.text.html 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.text.html 中的方法
protected void | HTMLWriter.comment(Element elem) 写出注释。
protected void | HTMLWriter.emptyTag(Element elem) 写出所有空元素（没有对应结束标记的所有标记）。
void | HTMLDocument.HTMLReader.flush() 在 reader 上调用的最后一个方法。
void | HTMLEditorKit.ParserCallback.flush()
protected void | HTMLDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data) 批量插入新元素。
void | HTMLDocument.insertAfterEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之后。
void | HTMLDocument.insertAfterStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的起始处。
void | HTMLDocument.insertBeforeEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的结尾处。
void | HTMLDocument.insertBeforeStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之前。
void | HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag) 将 HTML 插入现有文档。
Shape | ImageView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | HTMLEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容。
void | HTMLDocument.setInnerHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换给定元素的子元素。
void | HTMLDocument.setOuterHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换父元素中的给定元素。
protected void | HTMLWriter.startTag(Element elem) 写出元素的开始标记。
protected void | HTMLWriter.text(Element elem) 写出文本。
protected void | MinimalHTMLWriter.text(Element elem) 写出文本。
protected void | HTMLWriter.textAreaContent(AttributeSet attr) 写出 TEXTAREA 表单元素中所包含的文本。
void | HTMLWriter.write() 对 Element 树进行迭代并控制所有标记及其属性的写出。
void | MinimalHTMLWriter.write() 从 StyledDocument 生成 HTML 输出。
void | HTMLEditorKit.write(Writer out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
protected void | MinimalHTMLWriter.writeBody() 对文档中的元素进行迭代，并基于元素是分支元素还是叶元素来处理它们。
protected void | MinimalHTMLWriter.writeContent(Element elem, boolean needsIndenting) 以与 HTML 兼容的方式写出属性集。

javax.swing.text.rtf 中 BadLocationException 的使用

抛出 BadLocationException 的 javax.swing.text.rtf 中的方法
void | RTFEditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
void | RTFEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，该内容将被视为纯文本。
void | RTFEditorKit.write(OutputStream out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
void | RTFEditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容作为纯文本写入给定的流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.BoxView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.BoxView
的使用

使用 BoxView 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 BoxView 的使用

javax.swing.text 中 BoxView 的子类
class | FlowView 试图将其子级流入某个部分受约束的空间的视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | TableView 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
class | ZoneView ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

javax.swing.text.html 中 BoxView 的使用

javax.swing.text.html 中 BoxView 的子类
class | BlockView 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
class | ListView 用于显示 html 列表的视图实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.ChangedCharSetException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ChangedCharSetException
的使用

使用 ChangedCharSetException 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 ChangedCharSetException 的使用

抛出 ChangedCharSetException 的 javax.swing.text.html.parser 中的方法
protected void | DocumentParser.handleEmptyTag(TagElement tag) 处理空标记。
protected void | Parser.handleEmptyTag(TagElement tag) 在遇到空标记时调用。
protected void | Parser.startTag(TagElement tag) 处理开始标记。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.ComponentView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ComponentView
的使用

使用 ComponentView 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 ComponentView 的使用

javax.swing.text.html 中 ComponentView 的子类
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
class | ObjectView 实现 <object> 元素视图接口的组件装饰符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.CompositeView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.CompositeView
的使用

使用 CompositeView 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 CompositeView 的使用

javax.swing.text 中 CompositeView 的子类
class | BoxView 一个视图，它通过沿某轴平铺将其子级排列到框形状中。
class | FlowView 试图将其子级流入某个部分受约束的空间的视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | TableView 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
class | ZoneView ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

javax.swing.text.html 中 CompositeView 的使用

javax.swing.text.html 中 CompositeView 的子类
class | BlockView 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
class | ListView 用于显示 html 列表的视图实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DateFormatter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DateFormatter
的使用

没有 javax.swing.text.DateFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultFormatter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultFormatter
的使用

使用 DefaultFormatter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 DefaultFormatter 的使用

javax.swing.text 中 DefaultFormatter 的子类
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | InternationalFormatter InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
class | MaskFormatter MaskFormatter 用于格式化和编辑字符串。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultFormatterFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultFormatterFactory
的使用

没有 javax.swing.text.DefaultFormatterFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument
的使用

使用 DefaultStyledDocument 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 DefaultStyledDocument 的使用

javax.swing.text.html 中 DefaultStyledDocument 的子类
 class HTMLDocument
对 HTML 进行建模的文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument.SectionElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument.SectionElement
的使用

没有 javax.swing.text.DefaultStyledDocument.SectionElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument.ElementSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument.ElementSpec
的使用

使用 DefaultStyledDocument.ElementSpec 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 DefaultStyledDocument.ElementSpec 的使用

参数类型为 DefaultStyledDocument.ElementSpec 的 javax.swing.text 中的方法
protected void | DefaultStyledDocument.create(DefaultStyledDocument.ElementSpec[] data) 初始化文档，以反映给定元素结构（即由 getDefaultRootElement 方法报告的结构）。
protected void | DefaultStyledDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data) 批量插入新元素。
void | DefaultStyledDocument.ElementBuffer.insert(int offset, int length, DefaultStyledDocument.ElementSpec[] data, AbstractDocument.DefaultDocumentEvent de) 插入新内容。
protected void | DefaultStyledDocument.ElementBuffer.insertUpdate(DefaultStyledDocument.ElementSpec[] data) 向文档添加更新。

javax.swing.text.html 中 DefaultStyledDocument.ElementSpec 的使用

类型参数类型为 DefaultStyledDocument.ElementSpec 的 javax.swing.text.html 中的字段
protected  Vector<DefaultStyledDocument.ElementSpec> HTMLDocument.HTMLReader.parseBuffer

参数类型为 DefaultStyledDocument.ElementSpec 的 javax.swing.text.html 中的方法
protected void | HTMLDocument.create(DefaultStyledDocument.ElementSpec[] data) 替换具有给定元素规范的文档内容。
protected void | HTMLDocument.insert(int offset, DefaultStyledDocument.ElementSpec[] data) 批量插入新元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument.ElementBuffer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument.ElementBuffer
的使用

使用 DefaultStyledDocument.ElementBuffer 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 DefaultStyledDocument.ElementBuffer 的使用

声明为 DefaultStyledDocument.ElementBuffer 的 javax.swing.text 中的字段
protected  DefaultStyledDocument.ElementBuffer DefaultStyledDocument.buffer

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
的使用

没有 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultTextUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultTextUI
的使用

没有 javax.swing.text.DefaultTextUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DocumentFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DocumentFilter
的使用

使用 DocumentFilter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 DocumentFilter 的使用

返回 DocumentFilter 的 javax.swing 中的方法
protected  DocumentFilter JFormattedTextField.AbstractFormatter.getDocumentFilter()
如果想要提供某个 DocumentFilter 以限制输入内容，则应进行子类化和重写。

javax.swing.text 中 DocumentFilter 的使用

返回 DocumentFilter 的 javax.swing.text 中的方法
protected DocumentFilter | DefaultFormatter.getDocumentFilter() 返回用于限制放置到 JFormattedTextField 中的字符的 DocumentFilter。
DocumentFilter | AbstractDocument.getDocumentFilter() 返回负责进行插入/移除过滤的 DocumentFilter。

参数类型为 DocumentFilter 的 javax.swing.text 中的方法
 void AbstractDocument.setDocumentFilter(DocumentFilter filter)
设置 DocumentFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DocumentFilter.FilterBypass 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DocumentFilter.FilterBypass
的使用

使用 DocumentFilter.FilterBypass 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 DocumentFilter.FilterBypass 的使用

参数类型为 DocumentFilter.FilterBypass 的 javax.swing.text 中的方法
void | DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr) 将文本插入指定的 Document 之前调用。
void | DocumentFilter.remove(DocumentFilter.FilterBypass fb, int offset, int length) 移除指定 Document 中的指定区域之前调用。
void | DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs) 在替换指定的 Document 中的文本区域之前调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.ElementIterator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ElementIterator
的使用

使用 ElementIterator 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 ElementIterator 的使用

返回 ElementIterator 的 javax.swing.text 中的方法
protected  ElementIterator AbstractWriter.getElementIterator()
获取 ElementIterator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.FlowView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.FlowView
的使用

使用 FlowView 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 FlowView 的使用

javax.swing.text 中 FlowView 的子类
 class ParagraphView
存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。

参数类型为 FlowView 的 javax.swing.text 中的方法
protected void | FlowView.FlowStrategy.adjustRow(FlowView fv, int rowIndex, int desiredSpan, int x) 如有可能，调整给定行以使其适合布局区域。
void | FlowView.FlowStrategy.changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected View | FlowView.FlowStrategy.createView(FlowView fv, int startOffset, int spanLeft, int rowIndex) 创建一个可用于表示流的当前片段的视图。
protected View | FlowView.FlowStrategy.getLogicalView(FlowView fv) 此方法提供访问 FlowView 的逻辑视图的流策略。
void | FlowView.FlowStrategy.insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | FlowView.FlowStrategy.layout(FlowView fv) 更新给定 FlowView 的流。
protected int | FlowView.FlowStrategy.layoutRow(FlowView fv, int rowIndex, int pos) 创建一个符合该行布局区域的视图的行。
void | FlowView.FlowStrategy.removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.FlowView.FlowStrategy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.FlowView.FlowStrategy
的使用

使用 FlowView.FlowStrategy 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 FlowView.FlowStrategy 的使用

声明为 FlowView.FlowStrategy 的 javax.swing.text 中的字段
protected  FlowView.FlowStrategy FlowView.strategy
保持流更新的行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.GlyphView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.GlyphView
的使用

使用 GlyphView 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 GlyphView 的使用

javax.swing.text 中 GlyphView 的子类
 class LabelView
LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。

参数类型为 GlyphView 的 javax.swing.text 中的方法
abstract float | GlyphView.GlyphPainter.getAscent(GlyphView v)
abstract int | GlyphView.GlyphPainter.getBoundedPosition(GlyphView v, int p0, float x, float len) 确定表示符合给定区域的最大 advance 的模型位置。
abstract float | GlyphView.GlyphPainter.getDescent(GlyphView v)
abstract float | GlyphView.GlyphPainter.getHeight(GlyphView v)
int | GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
GlyphView.GlyphPainter | GlyphView.GlyphPainter.getPainter(GlyphView v, int p0, int p1) 创建用于给定 GlyphView 的 painter。
abstract float | GlyphView.GlyphPainter.getSpan(GlyphView v, int p0, int p1, TabExpander e, float x) 确定给定开始位置（相对于选项卡扩展而言）的字形区域。
abstract Shape | GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract void | GlyphView.GlyphPainter.paint(GlyphView v, Graphics g, Shape a, int p0, int p1) 绘制表示给定范围的字形。
abstract int | GlyphView.GlyphPainter.viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。

javax.swing.text.html 中 GlyphView 的使用

javax.swing.text.html 中 GlyphView 的子类
 class InlineView
显示基于 css 属性的 inline element 样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.GlyphView.GlyphPainter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.GlyphView.GlyphPainter
的使用

使用 GlyphView.GlyphPainter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 GlyphView.GlyphPainter 的使用

返回 GlyphView.GlyphPainter 的 javax.swing.text 中的方法
GlyphView.GlyphPainter | GlyphView.getGlyphPainter() 获取当前安装的字形 painter。
GlyphView.GlyphPainter | GlyphView.GlyphPainter.getPainter(GlyphView v, int p0, int p1) 创建用于给定 GlyphView 的 painter。

参数类型为 GlyphView.GlyphPainter 的 javax.swing.text 中的方法
 void GlyphView.setGlyphPainter(GlyphView.GlyphPainter p)
设置用于呈现字形的 painter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.IconView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.IconView
的使用

没有 javax.swing.text.IconView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.InternationalFormatter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.InternationalFormatter
的使用

使用 InternationalFormatter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 InternationalFormatter 的使用

javax.swing.text 中 InternationalFormatter 的子类
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.LabelView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.LabelView
的使用

使用 LabelView 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 LabelView 的使用

javax.swing.text.html 中 LabelView 的子类
 class InlineView
显示基于 css 属性的 inline element 样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.LayoutQueue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.LayoutQueue
的使用

使用 LayoutQueue 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 LayoutQueue 的使用

返回 LayoutQueue 的 javax.swing.text 中的方法
static LayoutQueue | LayoutQueue.getDefaultQueue() 返回默认的布局队列。
protected LayoutQueue | AsyncBoxView.getLayoutQueue() 获取用于布局处理的队列。

参数类型为 LayoutQueue 的 javax.swing.text 中的方法
static void LayoutQueue.setDefaultQueue(LayoutQueue q)
设置默认的布局队列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.MaskFormatter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.MaskFormatter
的使用

没有 javax.swing.text.MaskFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.NavigationFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.NavigationFilter
的使用

使用 NavigationFilter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 NavigationFilter 的使用

返回 NavigationFilter 的 javax.swing 中的方法
protected  NavigationFilter JFormattedTextField.AbstractFormatter.getNavigationFilter()
如果想要提供过滤器以限制用户可导航的位置，则应进行子类化和重写。

javax.swing.text 中 NavigationFilter 的使用

返回 NavigationFilter 的 javax.swing.text 中的方法
protected NavigationFilter | DefaultFormatter.getNavigationFilter() 返回用于限制光标放置位置的 NavigationFilter。
NavigationFilter | JTextComponent.getNavigationFilter() 返回 NavigationFilter。

参数类型为 NavigationFilter 的 javax.swing.text 中的方法
 void JTextComponent.setNavigationFilter(NavigationFilter filter)
设置 NavigationFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.NavigationFilter.FilterBypass 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.NavigationFilter.FilterBypass
的使用

使用 NavigationFilter.FilterBypass 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 NavigationFilter.FilterBypass 的使用

参数类型为 NavigationFilter.FilterBypass 的 javax.swing.text 中的方法
void | NavigationFilter.moveDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 移动点之前调用。
void | NavigationFilter.setDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 设置点之前调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.NumberFormatter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.NumberFormatter
的使用

没有 javax.swing.text.NumberFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.ParagraphView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ParagraphView
的使用

使用 ParagraphView 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 ParagraphView 的使用

javax.swing.text.html 中 ParagraphView 的子类
 class ParagraphView
显示段落，并使用 css 属性作为其配置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.PasswordView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.PasswordView
的使用

没有 javax.swing.text.PasswordView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StringContent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StringContent
的使用

没有 javax.swing.text.StringContent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.StyledDocument 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.StyledDocument
的使用

使用 StyledDocument 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 StyledDocument 的使用

返回 StyledDocument 的 javax.swing 中的方法
 StyledDocument JTextPane.getStyledDocument()
获取与编辑器关联的模型。

参数类型为 StyledDocument 的 javax.swing 中的方法
 void JTextPane.setStyledDocument(StyledDocument doc)
将编辑器与一个文本文档关联。

参数类型为 StyledDocument 的 javax.swing 中的构造方法
JTextPane(StyledDocument doc)
创建具有指定文档模型的新 JTextPane。

javax.swing.text 中 StyledDocument 的使用

实现 StyledDocument 的 javax.swing.text 中的类
 class DefaultStyledDocument
能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。

返回 StyledDocument 的 javax.swing.text 中的方法
protected  StyledDocument StyledEditorKit.StyledTextAction.getStyledDocument(JEditorPane e)
获取与编辑器窗格相关的文档。

javax.swing.text.html 中 StyledDocument 的使用

实现 StyledDocument 的 javax.swing.text.html 中的类
 class HTMLDocument
对 HTML 进行建模的文档。

参数类型为 StyledDocument 的 javax.swing.text.html 中的构造方法
MinimalHTMLWriter(Writer w, StyledDocument doc)
创建一个新的 MinimalHTMLWriter。
MinimalHTMLWriter(Writer w, StyledDocument doc, int pos, int len)
创建一个新的 MinimalHTMLWriter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit
的使用

使用 StyledEditorKit 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing 中 StyledEditorKit 的使用

返回 StyledEditorKit 的 javax.swing 中的方法
protected  StyledEditorKit JTextPane.getStyledEditorKit()
获取编辑器工具包。

javax.swing.text 中 StyledEditorKit 的使用

返回 StyledEditorKit 的 javax.swing.text 中的方法
protected  StyledEditorKit StyledEditorKit.StyledTextAction.getStyledEditorKit(JEditorPane e)
获取与编辑器窗格相关的编辑器工具包。

javax.swing.text.html 中 StyledEditorKit 的使用

javax.swing.text.html 中 StyledEditorKit 的子类
 class HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

javax.swing.text.rtf 中 StyledEditorKit 的使用

javax.swing.text.rtf 中 StyledEditorKit 的子类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.StyledTextAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.StyledTextAction
的使用

使用 StyledEditorKit.StyledTextAction 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 StyledEditorKit.StyledTextAction 的使用

javax.swing.text 中 StyledEditorKit.StyledTextAction 的子类
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。

javax.swing.text.html 中 StyledEditorKit.StyledTextAction 的使用

javax.swing.text.html 中 StyledEditorKit.StyledTextAction 的子类
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.FontFamilyAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.FontFamilyAction
的使用

没有 javax.swing.text.StyledEditorKit.FontFamilyAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.FontSizeAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.FontSizeAction
的使用

没有 javax.swing.text.StyledEditorKit.FontSizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.ForegroundAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.ForegroundAction
的使用

没有 javax.swing.text.StyledEditorKit.ForegroundAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.AlignmentAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.AlignmentAction
的使用

没有 javax.swing.text.StyledEditorKit.AlignmentAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.BoldAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.BoldAction
的使用

没有 javax.swing.text.StyledEditorKit.BoldAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.ItalicAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.ItalicAction
的使用

没有 javax.swing.text.StyledEditorKit.ItalicAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyledEditorKit.UnderlineAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyledEditorKit.UnderlineAction
的使用

没有 javax.swing.text.StyledEditorKit.UnderlineAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.TabSet 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TabSet
的使用

使用 TabSet 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TabSet 的使用

返回 TabSet 的 javax.swing.text 中的方法
protected TabSet | ParagraphView.getTabSet() 获取计算制表符时使用的 Tabset。
static TabSet | StyleConstants.getTabSet(AttributeSet a) 获取 TabSet。

参数类型为 TabSet 的 javax.swing.text 中的方法
static void StyleConstants.setTabSet(MutableAttributeSet a, TabSet tabs)
设置 TabSet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.TabStop 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TabStop
的使用

使用 TabStop 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TabStop 的使用

返回 TabStop 的 javax.swing.text 中的方法
TabStop | TabSet.getTab(int index) 返回索引 index 处的 TabStop。
TabStop | TabSet.getTabAfter(float location) 返回 location 之后的 Tab 实例。

参数类型为 TabStop 的 javax.swing.text 中的方法
 int TabSet.getTabIndex(TabStop tab)

参数类型为 TabStop 的 javax.swing.text 中的构造方法
TabSet(TabStop[] tabs)
创建并且返回 TabSet 的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.TabableView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.TabableView
的使用

使用 TabableView 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TabableView 的使用

实现 TabableView 的 javax.swing.text 中的类
class | GlyphView GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
class | LabelView LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。

javax.swing.text.html 中 TabableView 的使用

实现 TabableView 的 javax.swing.text.html 中的类
 class InlineView
显示基于 css 属性的 inline element 样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.TableView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TableView
的使用

没有 javax.swing.text.TableView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.TableView.TableRow 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TableView.TableRow
的使用

使用 TableView.TableRow 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TableView.TableRow 的使用

返回 TableView.TableRow 的 javax.swing.text 中的方法
protected  TableView.TableRow TableView.createTableRow(Element elem)
创建新的表格行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.TableView.TableCell 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TableView.TableCell
的使用

使用 TableView.TableCell 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TableView.TableCell 的使用

返回 TableView.TableCell 的 javax.swing.text 中的方法
protected  TableView.TableCell TableView.createTableCell(Element elem)
已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.WrappedPlainView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.WrappedPlainView
的使用

没有 javax.swing.text.WrappedPlainView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.ZoneView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.ZoneView
的使用

没有 javax.swing.text.ZoneView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Keymap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Keymap
的使用

使用 Keymap 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 Keymap 的使用

返回 Keymap 的 javax.swing.plaf.basic 中的方法
protected  Keymap BasicTextUI.createKeymap()
创建用于文本组件的 keymap，并在其中安装必需的绑定。

javax.swing.text 中 Keymap 的使用

返回 Keymap 的 javax.swing.text 中的方法
static Keymap | JTextComponent.addKeymap(String nm, Keymap parent) 将一个新 keymap 添加到 keymap 层次结构。
Keymap | JTextComponent.getKeymap() 获取当前在此文本组件中活动的 keymap。
static Keymap | JTextComponent.getKeymap(String nm) 获取以前添加到文档中的已命名 keymap。
Keymap | Keymap.getResolveParent() 获取用于解析键绑定的父级 keymap。
static Keymap | JTextComponent.removeKeymap(String nm) 移除以前添加到文档中的已命名 keymap。

参数类型为 Keymap 的 javax.swing.text 中的方法
static Keymap | JTextComponent.addKeymap(String nm, Keymap parent) 将一个新 keymap 添加到 keymap 层次结构。
static void | JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions) 加载带有一组绑定的 keymap。
void | JTextComponent.setKeymap(Keymap map) 设置用于将事件绑定到操作的 keymap。
void | Keymap.setResolveParent(Keymap parent) 设置将用于解析键绑定的父级 keymap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.FieldView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.FieldView
的使用

使用 FieldView 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 FieldView 的使用

javax.swing.text 中 FieldView 的子类
 class PasswordView
实现适用于 JPasswordField UI 实现的视图。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.PlainView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.PlainView
的使用

使用 PlainView 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 PlainView 的使用

javax.swing.text 中 PlainView 的子类
class | FieldView 扩展多行纯文本视图，使其适合单行编辑器视图。
class | PasswordView 实现适用于 JPasswordField UI 实现的视图。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultHighlighter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultHighlighter
的使用

使用 DefaultHighlighter 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 DefaultHighlighter 的使用

javax.swing.plaf.basic 中 DefaultHighlighter 的子类
static class BasicTextUI.BasicHighlighter

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
的使用

没有 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.LayeredHighlighter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.LayeredHighlighter
的使用

使用 LayeredHighlighter 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 LayeredHighlighter 的使用

javax.swing.plaf.basic 中 LayeredHighlighter 的子类
static class BasicTextUI.BasicHighlighter

javax.swing.text 中 LayeredHighlighter 的使用

javax.swing.text 中 LayeredHighlighter 的子类
 class DefaultHighlighter
实现 Highlighter 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.LayeredHighlighter.LayerPainter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.LayeredHighlighter.LayerPainter
的使用

使用 LayeredHighlighter.LayerPainter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 LayeredHighlighter.LayerPainter 的使用

javax.swing.text 中 LayeredHighlighter.LayerPainter 的子类
static class DefaultHighlighter.DefaultHighlightPainter
只高亮显示用纯色填充高亮显示区域的 painter。

声明为 LayeredHighlighter.LayerPainter 的 javax.swing.text 中的字段
static LayeredHighlighter.LayerPainter DefaultHighlighter.DefaultPainter
LayeredHighlighter.LayerPainter 的默认实现，可用于绘制高亮显示区域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Highlighter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Highlighter
的使用

使用 Highlighter 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 Highlighter 的使用

实现 Highlighter 的 javax.swing.plaf.basic 中的类
static class BasicTextUI.BasicHighlighter

返回 Highlighter 的 javax.swing.plaf.basic 中的方法
protected  Highlighter BasicTextUI.createHighlighter()
创建用于添加高亮显示的对象。

javax.swing.text 中 Highlighter 的使用

实现 Highlighter 的 javax.swing.text 中的类
class | DefaultHighlighter 实现 Highlighter 接口。
class | LayeredHighlighter

返回 Highlighter 的 javax.swing.text 中的方法
 Highlighter JTextComponent.getHighlighter()
获取负责进行高亮显示的对象。

参数类型为 Highlighter 的 javax.swing.text 中的方法
 void JTextComponent.setHighlighter(Highlighter h)
设置要使用的 highlighter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Highlighter.HighlightPainter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Highlighter.HighlightPainter
的使用

使用 Highlighter.HighlightPainter 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 Highlighter.HighlightPainter 的使用

实现 Highlighter.HighlightPainter 的 javax.swing.text 中的类
static class | DefaultHighlighter.DefaultHighlightPainter 只高亮显示用纯色填充高亮显示区域的 painter。
static class | LayeredHighlighter.LayerPainter 分层的高亮显示渲染器。

返回 Highlighter.HighlightPainter 的 javax.swing.text 中的方法
Highlighter.HighlightPainter | Highlighter.Highlight.getPainter() 获取 highlighter 的 painter。
protected Highlighter.HighlightPainter | DefaultCaret.getSelectionPainter() 获取此 Highlighter 的 painter。

参数类型为 Highlighter.HighlightPainter 的 javax.swing.text 中的方法
Object | DefaultHighlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p) 向视图添加高亮显示。
Object | Highlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p) 向视图添加高亮显示。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Highlighter.Highlight 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Highlighter.Highlight
的使用

使用 Highlighter.Highlight 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 Highlighter.Highlight 的使用

返回 Highlighter.Highlight 的 javax.swing.text 中的方法
Highlighter.Highlight[] | DefaultHighlighter.getHighlights() 制作高亮显示的副本。
Highlighter.Highlight[] | Highlighter.getHighlights() 获取高亮显示的当前列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultCaret 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultCaret
的使用

使用 DefaultCaret 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 DefaultCaret 的使用

javax.swing.plaf.basic 中 DefaultCaret 的子类
static class BasicTextUI.BasicCaret

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Caret 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Caret
的使用

使用 Caret 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 Caret 的使用

实现 Caret 的 javax.swing.plaf.basic 中的类
static class BasicTextUI.BasicCaret

返回 Caret 的 javax.swing.plaf.basic 中的方法
protected  Caret BasicTextUI.createCaret()
创建用于插入符的对象。

javax.swing.text 中 Caret 的使用

实现 Caret 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

返回 Caret 的 javax.swing.text 中的方法
Caret | DefaultEditorKit.createCaret() 获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
abstract Caret | EditorKit.createCaret() 获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
abstract Caret | NavigationFilter.FilterBypass.getCaret() 返回不断变化的 Caret。
Caret | JTextComponent.getCaret() 获取允许在视图上进行面向文本导航的插入符。

参数类型为 Caret 的 javax.swing.text 中的方法
 void JTextComponent.setCaret(Caret c)
设置要使用的插入符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.View 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.View
的使用

使用 View 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf 中 View 的使用

返回 View 的 javax.swing.plaf 中的方法
abstract  View TextUI.getRootView(JTextComponent t)
获取分配了相关文本组件（即层次结构的根）的 View，可遍历这些组件来确定在空间中表示模型的形式。

javax.swing.plaf.basic 中 View 的使用

返回 View 的 javax.swing.plaf.basic 中的方法
View | BasicPasswordFieldUI.create(Element elem) 创建元素的视图 (PasswordView)。
View | BasicTextAreaUI.create(Element elem) 创建元素的视图。
View | BasicTextFieldUI.create(Element elem) 基于元素创建视图 (FieldView)。
View | BasicTextUI.create(Element elem) 创建元素的视图。
View | BasicTextUI.create(Element elem, int p0, int p1) 创建元素的视图。
static View | BasicHTML.createHTMLView(JComponent c, String html) 创建给定组件和 html 字符串的 html 渲染器。
View | BasicTextUI.getRootView(JTextComponent tc) 获取分配了相关文本组件（即层次结构的根）的 View，可通过遍历该视图确定模型在空间中的表示形式。
protected View | BasicTabbedPaneUI.getTextViewForTab(int tabIndex) 返回为指定选项卡呈现样式化文本 (HTML) 所需的文本 View 对象；如果此选项卡不需要任何特殊化的文本呈现，则返回 null。

参数类型为 View 的 javax.swing.plaf.basic 中的方法
static int BasicHTML.getHTMLBaseline(View view, int w, int h)
返回 html 渲染器的基线。
protected  void BasicTextUI.setView(View v)
设置视图层次结构的当前根并调用 invalidate()。

javax.swing.plaf.multi 中 View 的使用

返回 View 的 javax.swing.plaf.multi 中的方法
 View MultiTextUI.getRootView(JTextComponent a)
在由此对象处理的每个 UI 上调用 getRootView 方法。

javax.swing.text 中 View 的使用

javax.swing.text 中 View 的子类
class | AsyncBoxView 异步执行布局处理的框。
class | BoxView 一个视图，它通过沿某轴平铺将其子级排列到框形状中。
class | ComponentView 实现视图接口的组件装饰器。
class | CompositeView CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
class | FieldView 扩展多行纯文本视图，使其适合单行编辑器视图。
class | FlowView 试图将其子级流入某个部分受约束的空间的视图。
class | GlyphView GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
class | IconView 实现视图接口的图标修饰符。
class | LabelView LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | PasswordView 实现适用于 JPasswordField UI 实现的视图。
class | PlainView 实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
class | TableView 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
class | ZoneView ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

声明为 View 的 javax.swing.text 中的字段
protected  View FlowView.layoutPool
这些都是表示此视图表示的元素（要转换为物理视图的逻辑视图）的子元素的视图。

返回 View 的 javax.swing.text 中的方法
View | ParagraphView.breakView(int axis, float len, Shape a) 以给定的长度在给定的轴上拆分此视图。
View | GlyphView.breakView(int axis, int p0, float pos, float len) 在给定的轴上以给定的长度拆分此视图。
View | View.breakView(int axis, int offset, float pos, float len) 试图在给定的轴上拆分视图。
View | ViewFactory.create(Element elem) 根据给定的文档的结构化元素创建一个视图。
View | GlyphView.createFragment(int p0, int p1) 创建表示元素某部分的视图。
View | View.createFragment(int p0, int p1) 创建一个表示元素某部分的视图。
protected abstract View | FlowView.createRow() 创建应在保持流中子级行值时使用的视图。
protected View | ParagraphView.createRow() 创建用于在流中存储子级行值的 View。
protected View | FlowView.FlowStrategy.createView(FlowView fv, int startOffset, int spanLeft, int rowIndex) 创建一个可用于表示流的当前片段的视图。
protected View | ZoneView.createZone(int p0, int p1) 针对模型中的给定范围（应该在此对象的职责范围内），创建一个视图来表示分区。
View | AsyncBoxView.ChildState.getChildView() 获取此记录表示的子视图。
protected View | ParagraphView.getLayoutView(int index) 返回给定 index 处的视图。
protected View | FlowView.FlowStrategy.getLogicalView(FlowView fv) 此方法提供访问 FlowView 的逻辑视图的流策略。
View | View.getParent() 返回视图的父级。
View | AsyncBoxView.getView(int n) 获得第 n 个子视图。
View | CompositeView.getView(int n) 返回该容器中的第 n 个视图。
View | View.getView(int n) 获取第 n 个子视图。
protected View | BoxView.getViewAtPoint(int x, int y, Rectangle alloc) 获取给定坐标处的子视图。
protected abstract View | CompositeView.getViewAtPoint(int x, int y, Rectangle alloc) 获取位于给定坐标的子视图。
protected View | CompositeView.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected View | TableView.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected View | TableView.TableRow.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。

参数类型为 View 的 javax.swing.text 中的方法
void | View.append(View v) 追加单个子视图。
protected AsyncBoxView.ChildState | AsyncBoxView.createChildState(View v) 通过此方法创建新的 ChildState 记录，以允许扩展 ChildState 记录的子类执行/保存更多状态。
protected void | View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
void | View.insert(int offs, View v) 插入单个子视图。
protected boolean | ZoneView.isZoneLoaded(View zone) 确定某个分区是否处于加载状态。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
void | DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
abstract void | LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当叶 View（如 LabelView）呈现时，它们应调用此方法。
void | AsyncBoxView.preferenceChanged(View child, boolean width, boolean height) 子视图可以在父级上调用此方法，以指示首选项已更改并且应该重新考虑布局。
void | BoxView.preferenceChanged(View child, boolean width, boolean height) 这由子级来调用，以表明它的首选项区域已更改。
void | View.preferenceChanged(View child, boolean width, boolean height) 子视图能在父级上调用此方法来指示首选项已经更改，并且应该重新考虑布局。
void | AsyncBoxView.replace(int offset, int length, View[] views) 调用超类以更新子视图，并且更新子视图的状态记录。
void | BoxView.replace(int index, int length, View[] elems) 使布局变得无效并调整所需/分配的缓存大小。
void | CompositeView.replace(int offset, int length, View[] views) 替换子视图。
void | TableView.replace(int offset, int length, View[] views) 更改子视图。
void | TableView.TableRow.replace(int offset, int length, View[] views) 更改子视图。
void | View.replace(int offset, int length, View[] views) 替代子视图。
void | AsyncBoxView.setParent(View parent) 设置视图的父级。
void | ComponentView.setParent(View p) 为子视图设置父级。
void | CompositeView.setParent(View parent) 设置此视图的父级。
void | FlowView.setParent(View parent) 设置此视图的父级。
void | View.setParent(View parent) 为此视图建立父视图。
protected void | ZoneView.unloadZone(View zone) 卸载一个分区（将分区转换到其内存节省状态）。
protected void | ZoneView.zoneWasLoaded(View zone) 当加载某个分区后由该分区调用。

参数类型为 View 的 javax.swing.text 中的构造方法
AsyncBoxView.ChildState(View v)
构造子视图状态。

javax.swing.text.html 中 View 的使用

javax.swing.text.html 中 View 的子类
class | BlockView 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
class | ImageView 图像视图，用于支持 HTML <IMG> 标记。
class | InlineView 显示基于 css 属性的 inline element 样式。
class | ListView 用于显示 html 列表的视图实现。
class | ObjectView 实现 <object> 元素视图接口的组件装饰符。

返回 View 的 javax.swing.text.html 中的方法
View | InlineView.breakView(int axis, int offset, float pos, float len) 尝试在给定轴上拆分此视图。
View | HTMLEditorKit.HTMLFactory.create(Element elem) 根据元素创建视图。

参数类型为 View 的 javax.swing.text.html 中的方法
float | StyleSheet.BoxPainter.getInset(int side, View v) 获取给定边上所需的 inset，以便计算空白、边框和填充数量。
AttributeSet | StyleSheet.getViewAttributes(View v) 获取用来显示视图的属性集。
void | StyleSheet.BoxPainter.paint(Graphics g, float x, float y, float w, float h, View v) 根据给定的属性绘制 CSS 框。
void | StyleSheet.ListPainter.paint(Graphics g, float x, float y, float w, float h, View v, int item) 根据给定的属性绘制 CSS 列表装饰。
void | BlockView.setParent(View parent) 建立此视图的父视图。
void | ImageView.setParent(View parent) 建立此视图的父视图。
void | ParagraphView.setParent(View parent) 建立此视图的父视图。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit
的使用

使用 DefaultEditorKit 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing.text 中 DefaultEditorKit 的使用

javax.swing.text 中 DefaultEditorKit 的子类
 class StyledEditorKit
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。

javax.swing.text.html 中 DefaultEditorKit 的使用

javax.swing.text.html 中 DefaultEditorKit 的子类
 class HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

javax.swing.text.rtf 中 DefaultEditorKit 的使用

javax.swing.text.rtf 中 DefaultEditorKit 的子类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
的使用

没有 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.InsertContentAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.InsertContentAction
的使用

没有 javax.swing.text.DefaultEditorKit.InsertContentAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.InsertBreakAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.InsertBreakAction
的使用

没有 javax.swing.text.DefaultEditorKit.InsertBreakAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.InsertTabAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.InsertTabAction
的使用

没有 javax.swing.text.DefaultEditorKit.InsertTabAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.CutAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.CutAction
的使用

没有 javax.swing.text.DefaultEditorKit.CutAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.CopyAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.CopyAction
的使用

没有 javax.swing.text.DefaultEditorKit.CopyAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.PasteAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.PasteAction
的使用

没有 javax.swing.text.DefaultEditorKit.PasteAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.DefaultEditorKit.BeepAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.DefaultEditorKit.BeepAction
的使用

没有 javax.swing.text.DefaultEditorKit.BeepAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.EditorKit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.EditorKit
的使用

使用 EditorKit 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing 中 EditorKit 的使用

返回 EditorKit 的 javax.swing 中的方法
protected EditorKit | JEditorPane.createDefaultEditorKit() 首次创建组件时，创建默认的编辑器工具包 (PlainEditorKit)。
protected EditorKit | JTextPane.createDefaultEditorKit() 创建默认使用的 EditorKit。
static EditorKit | JEditorPane.createEditorKitForContentType(String type) 根据默认的编辑器工具包注册表为给定的类型创建处理程序。
EditorKit | JEditorPane.getEditorKit() 获取用于处理内容的、当前已安装的工具包。
EditorKit | JEditorPane.getEditorKitForContentType(String type) 获取用于给定内容类型的编辑器工具包。

参数类型为 EditorKit 的 javax.swing 中的方法
void | JEditorPane.setEditorKit(EditorKit kit) 设置当前为处理内容而安装的工具包。
void | JTextPane.setEditorKit(EditorKit kit) 设置当前安装的用于内容处理的工具包。
void | JEditorPane.setEditorKitForContentType(String type, EditorKit k) 直接设置用于给定类型的编辑器工具包。

javax.swing.plaf 中 EditorKit 的使用

返回 EditorKit 的 javax.swing.plaf 中的方法
abstract  EditorKit TextUI.getEditorKit(JTextComponent t)
获取为要编辑的文档类型设置策略的服务绑定。

javax.swing.plaf.basic 中 EditorKit 的使用

返回 EditorKit 的 javax.swing.plaf.basic 中的方法
EditorKit | BasicEditorPaneUI.getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。
EditorKit | BasicTextUI.getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。

javax.swing.plaf.multi 中 EditorKit 的使用

返回 EditorKit 的 javax.swing.plaf.multi 中的方法
 EditorKit MultiTextUI.getEditorKit(JTextComponent a)
在由此对象处理的每个 UI 上调用 getEditorKit 方法。

javax.swing.text 中 EditorKit 的使用

javax.swing.text 中 EditorKit 的子类
class | DefaultEditorKit 这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
class | StyledEditorKit 这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。

javax.swing.text.html 中 EditorKit 的使用

javax.swing.text.html 中 EditorKit 的子类
 class HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

javax.swing.text.rtf 中 EditorKit 的使用

javax.swing.text.rtf 中 EditorKit 的子类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.ViewFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.ViewFactory
的使用

使用 ViewFactory 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 ViewFactory 的使用

实现 ViewFactory 的 javax.swing.plaf.basic 中的类
class | BasicEditorPaneUI 为 JEditorPane 提供外观。
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。
class | BasicTextAreaUI 为纯文本编辑器提供外观。
class | BasicTextFieldUI JTextField 的外观的基础。
class | BasicTextPaneUI 为样式化文本编辑器提供外观。
class | BasicTextUI 此类是文本组件外观的基础。

javax.swing.plaf.metal 中 ViewFactory 的使用

实现 ViewFactory 的 javax.swing.plaf.metal 中的类
 class MetalTextFieldUI
JTextField 外观的基础。

javax.swing.text 中 ViewFactory 的使用

实现 ViewFactory 的 javax.swing.text 中的类
 class DefaultTextUI
已过时。

返回 ViewFactory 的 javax.swing.text 中的方法
ViewFactory | StyledEditorKit.getViewFactory() 获取一个适合供由此包所产生的任何模型来产生视图的工厂。
ViewFactory | View.getViewFactory() 获取将提供给视图层次结构的 ViewFactory 实现。
ViewFactory | DefaultEditorKit.getViewFactory() 获取一个适合供由此包所产生的任何模型来产生视图的工厂。
abstract ViewFactory | EditorKit.getViewFactory() 获取适合生成此工具包生成的任何模型视图的工厂。

参数类型为 ViewFactory 的 javax.swing.text 中的方法
void | FlowView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | GlyphView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | LabelView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | ParagraphView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | WrappedPlainView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出文档中此视图负责的位置上的属性已发生更改的通知。
void | PlainView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | View.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
protected void | BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
protected void | View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected void | View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
void | FlowView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | GlyphView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | WrappedPlainView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出在文档中此视图负责的位置插入了某些内容的通知。
void | ZoneView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出在文档中此视图负责的位置插入了某些内容的通知。
void | FieldView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | View.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
protected void | AsyncBoxView.loadChildren(ViewFactory f) 加载初始化该视图的所有子级。
protected void | CompositeView.loadChildren(ViewFactory f) 加载所有的子级以初始化该视图。
protected void | FlowView.loadChildren(ViewFactory f) 加载初始化该视图的所有子级。
protected void | WrappedPlainView.loadChildren(ViewFactory f) 加载所有子级来初始化视图。
protected void | ZoneView.loadChildren(ViewFactory f) 加载所有子级来初始化视图。
void | FlowView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知从文档中此视图负责的某个位置已移除内容。
void | GlyphView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
void | WrappedPlainView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出从文档中此视图负责的位置移除了某些内容的通知。
void | ZoneView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | FieldView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | View.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
protected boolean | ZoneView.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
protected boolean | View.updateChildren(DocumentEvent.ElementChange ec, DocumentEvent e, ViewFactory f) 更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
protected void | PlainView.updateDamage(DocumentEvent changes, Shape a, ViewFactory f) 重新绘制给定文档事件覆盖的更改区域。

javax.swing.text.html 中 ViewFactory 的使用

实现 ViewFactory 的 javax.swing.text.html 中的类
static class HTMLEditorKit.HTMLFactory
用于构建 HTML 视图的工厂。

返回 ViewFactory 的 javax.swing.text.html 中的方法
 ViewFactory HTMLEditorKit.getViewFactory()
获取一个适合供由此包所产生的任何模型来产生视图的工厂。

参数类型为 ViewFactory 的 javax.swing.text.html 中的方法
void | BlockView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
void | ImageView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 当 Elements 属性已更改时调用。
void | InlineView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | InlineView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | InlineView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.TextAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.TextAction
的使用

使用 TextAction 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TextAction 的使用

javax.swing.text 中 TextAction 的子类
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。

javax.swing.text.html 中 TextAction 的使用

javax.swing.text.html 中 TextAction 的子类
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.JTextComponent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.JTextComponent
的使用

使用 JTextComponent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JTextComponent 的使用

javax.swing 中 JTextComponent 的子类
class | JEditorPane 可编辑各种内容的文本组件。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。

javax.swing.plaf 中 JTextComponent 的使用

参数类型为 JTextComponent 的 javax.swing.plaf 中的方法
abstract void | TextUI.damageRange(JTextComponent t, int p0, int p1) 促使重新绘制负责模型给定部分的那部分视图。
abstract void | TextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias firstBias, Position.Bias secondBias) 促使重新绘制负责模型给定部分的那部分视图。
abstract EditorKit | TextUI.getEditorKit(JTextComponent t) 获取为要编辑的文档类型设置策略的服务绑定。
abstract int | TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract View | TextUI.getRootView(JTextComponent t) 获取分配了相关文本组件（即层次结构的根）的 View，可遍历这些组件来确定在空间中表示模型的形式。
String | TextUI.getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射关系。

javax.swing.plaf.basic 中 JTextComponent 的使用

返回 JTextComponent 的 javax.swing.plaf.basic 中的方法
protected  JTextComponent BasicTextUI.getComponent()
获取与此 UI 实现关联的文本组件。

参数类型为 JTextComponent 的 javax.swing.plaf.basic 中的方法
void | BasicTextUI.damageRange(JTextComponent tc, int p0, int p1) 促使重新绘制负责模型给定部分的那部分视图。
void | BasicTextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias p0Bias, Position.Bias p1Bias) 促使重新绘制负责模型给定部分的那部分视图。
EditorKit | BasicEditorPaneUI.getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。
EditorKit | BasicTextUI.getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。
int | BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
View | BasicTextUI.getRootView(JTextComponent tc) 获取分配了相关文本组件（即层次结构的根）的 View，可通过遍历该视图确定模型在空间中的表示形式。
String | BasicTextUI.getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。

javax.swing.plaf.multi 中 JTextComponent 的使用

参数类型为 JTextComponent 的 javax.swing.plaf.multi 中的方法
void | MultiTextUI.damageRange(JTextComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 damageRange 方法。
void | MultiTextUI.damageRange(JTextComponent a, int b, int c, Position.Bias d, Position.Bias e) 在由此对象处理的每个 UI 上调用 damageRange 方法。
EditorKit | MultiTextUI.getEditorKit(JTextComponent a) 在由此对象处理的每个 UI 上调用 getEditorKit 方法。
int | MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
View | MultiTextUI.getRootView(JTextComponent a) 在由此对象处理的每个 UI 上调用 getRootView 方法。
String | MultiTextUI.getToolTipText(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 getToolTipText 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b) 在由此对象处理的每个 UI 上调用 modelToView 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 viewToModel 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b, Position.Bias[] c) 在由此对象处理的每个 UI 上调用 viewToModel 方法。

javax.swing.text 中 JTextComponent 的使用

返回 JTextComponent 的 javax.swing.text 中的方法
protected JTextComponent | DefaultCaret.getComponent() 获取此插入符所绑定的文本编辑器组件。
protected JTextComponent | TextAction.getFocusedComponent() 获取当前具有焦点的文本组件。
protected JTextComponent | TextAction.getTextComponent(ActionEvent e) 确定动作所使用的组件。

参数类型为 JTextComponent 的 javax.swing.text 中的方法
void | DefaultHighlighter.deinstall(JTextComponent c) 从 JTextComponent 的接口移除 UI 时调用。
void | Highlighter.deinstall(JTextComponent c) 将 UI 从 JTextComponent 的接口移除时调用。
void | DefaultCaret.deinstall(JTextComponent c) 当 UI 从一个 JTextComponent 的接口移除时调用。
void | Caret.deinstall(JTextComponent c) 在将 UI 从 JTextComponent 的接口中移除时调用。
int | NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet) 返回从现在位置起的下一个放置插入符的可视位置。
static int | Utilities.getNextWord(JTextComponent c, int offs) 确定针对给定位置的下一个单词开头。
static Element | Utilities.getParagraphElement(JTextComponent c, int offs) 确定某个段落/行要使用的元素。
static int | Utilities.getPositionAbove(JTextComponent c, int offs, int x) 确定模型中离行上方给定的视图位置最近的位置。
static int | Utilities.getPositionBelow(JTextComponent c, int offs, int x) 确定模型中离行下方给定的视图位置最近的位置。
static int | Utilities.getPreviousWord(JTextComponent c, int offs) 确定针对给定位置的上一个单词开头。
static int | Utilities.getRowEnd(JTextComponent c, int offs) 确定包含指定模型位置的行的结束行模型位置。
static int | Utilities.getRowStart(JTextComponent c, int offs) 确定包含指定模型位置的行的起始行模型位置。
static int | Utilities.getWordEnd(JTextComponent c, int offs) 确定针对给定位置的单词结尾。
static int | Utilities.getWordStart(JTextComponent c, int offs) 确定针对给定模型位置的单词开头。
void | DefaultHighlighter.install(JTextComponent c) 当 UI 安装到 JTextComponent 的接口时调用。
void | Highlighter.install(JTextComponent c) 将 UI 安装到 JTextComponent 的接口时调用。
void | DefaultCaret.install(JTextComponent c) 当 UI 装入一个 JTextComponent 的接口时调用。
void | Caret.install(JTextComponent c) 在将 UI 安装到 JTextComponent 的接口中时调用。
void | DefaultHighlighter.DefaultHighlightPainter.paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c) 绘制高亮显示区域。
void | Highlighter.HighlightPainter.paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c) 呈现高亮显示。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
void | DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
abstract void | LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当叶 View（如 LabelView）呈现时，它们应调用此方法。

javax.swing.tree 中 JTextComponent 的使用

javax.swing.tree 中 JTextComponent 的子类
 class DefaultTreeCellEditor.DefaultTextField
不提供任何编辑器时所使用的 TextField。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.JTextComponent.KeyBinding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.JTextComponent.KeyBinding
的使用

使用 JTextComponent.KeyBinding 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JTextComponent.KeyBinding 的使用

返回 JTextComponent.KeyBinding 的 javax.swing 中的方法
static JTextComponent.KeyBinding[] LookAndFeel.makeKeyBindings(Object[] keyBindingList)
构建一个 KeyBinding 数组的便捷方法。

javax.swing.text 中 JTextComponent.KeyBinding 的使用

参数类型为 JTextComponent.KeyBinding 的 javax.swing.text 中的方法
static void JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions)
加载带有一组绑定的 keymap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.JTextComponent.AccessibleJTextComponent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.JTextComponent.AccessibleJTextComponent
的使用

使用 JTextComponent.AccessibleJTextComponent 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTextComponent.AccessibleJTextComponent 的使用

javax.swing 中 JTextComponent.AccessibleJTextComponent 的子类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.JTextComponent.DropLocation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.JTextComponent.DropLocation
的使用

使用 JTextComponent.DropLocation 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 JTextComponent.DropLocation 的使用

返回 JTextComponent.DropLocation 的 javax.swing.text 中的方法
 JTextComponent.DropLocation JTextComponent.getDropLocation()
返回在组件上进行 DnD 操作过程中此组件在视觉上指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.TabExpander 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.TabExpander
的使用

使用 TabExpander 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 TabExpander 的使用

实现 TabExpander 的 javax.swing.text 中的类
class | FieldView 扩展多行纯文本视图，使其适合单行编辑器视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | PasswordView 实现适用于 JPasswordField UI 实现的视图。
class | PlainView 实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。

返回 TabExpander 的 javax.swing.text 中的方法
 TabExpander GlyphView.getTabExpander()
如果此视图中存在选项卡，则获取要使用的 TabExpander。

参数类型为 TabExpander 的 javax.swing.text 中的方法
static int | Utilities.drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset) 使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
static int | Utilities.getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定对给定文本进行拆分的位置，以符合给定的跨距。
abstract float | GlyphView.GlyphPainter.getSpan(GlyphView v, int p0, int p1, TabExpander e, float x) 确定给定开始位置（相对于选项卡扩展而言）的字形区域。
float | GlyphView.getTabbedSpan(float x, TabExpander e) 确定使用给定选项卡扩展实现时所需的区域。
float | TabableView.getTabbedSpan(float x, TabExpander e) 确定当使用给定的制表符扩展实现时所需的跨距。
static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
static int | Utilities.getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset) 确定给定的考虑制表符的文本段的宽度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Style 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Style
的使用

使用 Style 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 Style 的使用

返回 Style 的 javax.swing 中的方法
Style | JTextPane.addStyle(String nm, Style parent) 将一个新样式添加到逻辑样式层次结构中。
Style | JTextPane.getLogicalStyle() 获取分配给由当前插入符号位置表示的段落的逻辑样式，或者 null。
Style | JTextPane.getStyle(String nm) 获取以前添加的已命名的非 null 样式。

参数类型为 Style 的 javax.swing 中的方法
Style | JTextPane.addStyle(String nm, Style parent) 将一个新样式添加到逻辑样式层次结构中。
void | JTextPane.setLogicalStyle(Style s) 设置在当前插入符号位置用于段落的逻辑样式。

javax.swing.text 中 Style 的使用

实现 Style 的 javax.swing.text 中的类
 class StyleContext.NamedStyle
通常用于表示字符和段落样式的属性集合。

返回 Style 的 javax.swing.text 中的方法
Style | DefaultStyledDocument.addStyle(String nm, Style parent) 向逻辑样式层次结构中添加新样式。
Style | StyledDocument.addStyle(String nm, Style parent) 向逻辑样式层次中添加新样式。
Style | StyleContext.addStyle(String nm, Style parent) 将新的样式添加到样式层次中。
Style | DefaultStyledDocument.getLogicalStyle(int p) 获取表示给定位置处分配给段落的逻辑样式。
Style | StyledDocument.getLogicalStyle(int p) 获取段落中给定位置的逻辑样式。
Style | DefaultStyledDocument.getStyle(String nm) 获取以前添加的已命名的样式。
Style | StyledDocument.getStyle(String nm) 获取以前添加的指定样式。
Style | StyleContext.getStyle(String nm) 获取以前添加到文档中的已命名样式

参数类型为 Style 的 javax.swing.text 中的方法
Style | DefaultStyledDocument.addStyle(String nm, Style parent) 向逻辑样式层次结构中添加新样式。
Style | StyledDocument.addStyle(String nm, Style parent) 向逻辑样式层次中添加新样式。
Style | StyleContext.addStyle(String nm, Style parent) 将新的样式添加到样式层次中。
void | DefaultStyledDocument.setLogicalStyle(int pos, Style s) 设置给定位置处用于段落的逻辑样式。
void | StyledDocument.setLogicalStyle(int pos, Style s) 设置给定位置的段落所用的逻辑样式。
protected void | DefaultStyledDocument.styleChanged(Style style) 此文档样式有任何改变时调用。

参数类型为 Style 的 javax.swing.text 中的构造方法
StyleContext.NamedStyle(String name, Style parent)
创建新的命名样式。
StyleContext.NamedStyle(Style parent)
创建新的命名样式。

javax.swing.text.html 中 Style 的使用

返回 Style 的 javax.swing.text.html 中的方法
Style | StyleSheet.getRule(HTML.Tag t, Element e) 获取用来呈现给定类型的 HTML 标记的样式。
Style | StyleSheet.getRule(String selector) 获取最能匹配以字符串形式表示的选择器的规则。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.Utilities 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.Utilities
的使用

没有 javax.swing.text.Utilities 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.Segment 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.Segment
的使用

使用 Segment 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 Segment 的使用

返回 Segment 的 javax.swing.text 中的方法
protected Segment | WrappedPlainView.getLineBuffer() 提供对能用于从关联文档获取文本的缓冲区的访问。
protected Segment | PlainView.getLineBuffer() 提供对可用于从相关文档获取文本的缓冲区的访问。
Segment | GlyphView.getText(int p0, int p1) 获取对占用给定范围的文本的引用。

参数类型为 Segment 的 javax.swing.text 中的方法
static int Utilities.drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset)
使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
static int Utilities.getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
确定对给定文本进行拆分的位置，以符合给定的跨距。
 void StringContent.getChars(int where, int len, Segment chars)
检索内容的某一部分，where ＋ len 必须 <= length()
 void GapContent.getChars(int where, int len, Segment chars)
检索部分内容。
 void AbstractDocument.Content.getChars(int where, int len, Segment txt)
获得字符序列并将其复制到 Segment 中。
static int Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset)
确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
static int Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
static int Utilities.getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset)
确定给定的考虑制表符的文本段的宽度。
 void AbstractDocument.getText(int offset, int length, Segment txt)
获取文档给定部分内包含的文本。
 void Document.getText(int offset, int length, Segment txt)
获取文档中给定部分包含的文本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Position 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Position
的使用

使用 Position 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 Position 的使用

返回 Position 的 javax.swing.text 中的方法
Position | StringContent.createPosition(int offset) 在内容中创建一个位置，让其跟踪随内容的变化而进行的更改。
Position | GapContent.createPosition(int offset) 在内容中创建一个位置，使其在内容发生变化时能跟踪内容的更改。
Position | AbstractDocument.createPosition(int offs) 返回更改文档时，将跟踪更改的位置。
Position | AbstractDocument.Content.createPosition(int offset) 在内容中创建一个位置，该位置将在内容改变时跟踪更改。
Position | Document.createPosition(int offs) 此方法允许应用程序在字符内容序列中标记位置。
Position | AbstractDocument.getEndPosition() 返回表示文档结尾的位置。
Position | Document.getEndPosition() 返回代表文档结束处的位置。
Position | AbstractDocument.getStartPosition() 返回表示文档开始的位置。
Position | Document.getStartPosition() 返回代表文档起始处的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.Position.Bias 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.Position.Bias
的使用

使用 Position.Bias 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing 中的方法
TreePath | JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias) 将 TreePath 返回到以一个前缀开头的下一个树元素。
int | JList.getNextMatch(String prefix, int startIndex, Position.Bias bias) 返回其 toString 值以给定前缀开头的下一个列表元素。

javax.swing.plaf 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing.plaf 中的方法
abstract void | TextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias firstBias, Position.Bias secondBias) 促使重新绘制负责模型给定部分的那部分视图。
abstract int | TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract int | TextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射关系。

javax.swing.plaf.basic 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing.plaf.basic 中的方法
void | BasicTextUI.damageRange(JTextComponent t, int p0, int p1, Position.Bias p0Bias, Position.Bias p1Bias) 促使重新绘制负责模型给定部分的那部分视图。
int | BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
int | BasicTextUI.getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。

javax.swing.plaf.multi 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing.plaf.multi 中的方法
void | MultiTextUI.damageRange(JTextComponent a, int b, int c, Position.Bias d, Position.Bias e) 在由此对象处理的每个 UI 上调用 damageRange 方法。
int | MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
int | MultiTextUI.getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b, Position.Bias[] c) 在由此对象处理的每个 UI 上调用 viewToModel 方法。

javax.swing.text 中 Position.Bias 的使用

声明为 Position.Bias 的 javax.swing.text 中的字段
static Position.Bias | Position.Bias.Backward 指示到模型中上一字符的偏差。
static Position.Bias | Position.Bias.Forward 指示到模型中下一字符的偏差。

返回 Position.Bias 的 javax.swing.text 中的方法
Position.Bias | JTextComponent.DropLocation.getBias() 返回放置索引的偏差。
Position.Bias | DefaultCaret.getDotBias() 返回插入符位置的偏差。
Position.Bias | DefaultCaret.getMarkBias() 返回标记的偏差。

参数类型为 Position.Bias 的 javax.swing.text 中的方法
protected boolean | BoxView.flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图的放置方向。
protected boolean | CompositeView.flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图放置的朝向。
protected boolean | ParagraphView.flipEastAndWestAtEnds(int position, Position.Bias bias) 确定下一个视图要布置的方向。
protected int | ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x) 返回最接近 x 处的模型位置。
protected int | ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x) 返回最接近 x 处的模型位置。
protected int | CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在东或在西。
protected int | CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在东或在西。
protected int | CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在北也可以在南。
protected int | CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在北也可以在南。
protected int | ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 在东或西方向返回光标的下一个可视位置。
protected int | ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 在东或西方向返回光标的下一个可视位置。
int | GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
int | View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
int | NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet) 返回从现在位置起的下一个放置插入符的可视位置。
int | NavigationFilter.getNextVisualPositionFrom(JTextComponent text, int pos, Position.Bias bias, int direction, Position.Bias[] biasRet) 返回从现在位置起的下一个放置插入符的可视位置。
int | AsyncBoxView.getViewIndex(int pos, Position.Bias b) 返回该模型中表示给定位置的子视图索引。
int | CompositeView.getViewIndex(int pos, Position.Bias b) 返回表示模型中给定位置的子视图索引。
int | View.getViewIndex(int pos, Position.Bias b) 返回表示模型中给定位置的子视图索引。
protected int | AsyncBoxView.getViewIndexAtPosition(int pos, Position.Bias b) 获取此模型中表示给定位置的子视图索引。
abstract Shape | GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
Shape | AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | BoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
Shape | ComponentView.modelToView(int pos, Shape a, Position.Bias b) 提供模型坐标空间到视图坐标空间的映射。
Shape | CompositeView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | GlyphView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | IconView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PasswordView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | FieldView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PlainView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract Shape | View.modelToView(int pos, Shape a, Position.Bias b) 为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
abstract void | NavigationFilter.FilterBypass.moveDot(int dot, Position.Bias bias) 移动插入符的位置，并跳过 NavigationFilter。
void | DefaultCaret.moveDot(int dot, Position.Bias dotBias) 将插入符位置移动到指定位置，存在指定偏差。
void | NavigationFilter.moveDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 移动点之前调用。
abstract void | NavigationFilter.FilterBypass.setDot(int dot, Position.Bias bias) 设置插入符的位置，并跳过 NavigationFilter。
void | DefaultCaret.setDot(int dot, Position.Bias dotBias) 将插入符位置和标记设置为指定位置，存在指定偏差。
void | NavigationFilter.setDot(NavigationFilter.FilterBypass fb, int dot, Position.Bias bias) 在 Caret 设置点之前调用。
int | AsyncBoxView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | BoxView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | ComponentView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | CompositeView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
int | GlyphView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | IconView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | PasswordView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | FieldView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | PlainView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
abstract int | View.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
abstract int | GlyphView.GlyphPainter.viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。

javax.swing.text.html 中 Position.Bias 的使用

参数类型为 Position.Bias 的 javax.swing.text.html 中的方法
Shape | ImageView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
int | ImageView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.SimpleAttributeSet 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.SimpleAttributeSet
的使用

使用 SimpleAttributeSet 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 SimpleAttributeSet 的使用

返回 SimpleAttributeSet 的 javax.swing.text.html.parser 中的方法
protected  SimpleAttributeSet Parser.getAttributes()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.MutableAttributeSet 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.MutableAttributeSet
的使用

使用 MutableAttributeSet 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 MutableAttributeSet 的使用

返回 MutableAttributeSet 的 javax.swing 中的方法
 MutableAttributeSet JTextPane.getInputAttributes()
获取窗格的输入属性。

javax.swing.text 中 MutableAttributeSet 的使用

javax.swing.text 中 MutableAttributeSet 的子接口
 interface Style
与文档中某个元素相关的属性集合。

实现 MutableAttributeSet 的 javax.swing.text 中的类
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。
class | SimpleAttributeSet 使用哈希表的 MutableAttributeSet 的直接实现。
class | StyleContext.NamedStyle 通常用于表示字符和段落样式的属性集合。

返回 MutableAttributeSet 的 javax.swing.text 中的方法
protected MutableAttributeSet | StyleContext.createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
MutableAttributeSet | StyledEditorKit.getInputAttributes() 获取该窗格的输入属性。

参数类型为 MutableAttributeSet 的 javax.swing.text 中的方法
protected void | StyledEditorKit.createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
void | StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a) 读入属性的特定于上下文的处理。
static void | StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a) 从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。
static void | StyleConstants.setAlignment(MutableAttributeSet a, int align) 设置对齐方式。
static void | StyleConstants.setBackground(MutableAttributeSet a, Color fg) 设置背景色。
static void | StyleConstants.setBidiLevel(MutableAttributeSet a, int o) 设置 BidiLevel。
static void | StyleConstants.setBold(MutableAttributeSet a, boolean b) 设置粗体属性。
static void | StyleConstants.setComponent(MutableAttributeSet a, Component c) 设置组件属性。
static void | StyleConstants.setFirstLineIndent(MutableAttributeSet a, float i) 设置首行缩进。
static void | StyleConstants.setFontFamily(MutableAttributeSet a, String fam) 设置字体属性。
static void | StyleConstants.setFontSize(MutableAttributeSet a, int s) 设置字体大小属性。
static void | StyleConstants.setForeground(MutableAttributeSet a, Color fg) 设置前景色。
static void | StyleConstants.setIcon(MutableAttributeSet a, Icon c) 设置图标属性。
static void | StyleConstants.setItalic(MutableAttributeSet a, boolean b) 设置斜体属性。
static void | StyleConstants.setLeftIndent(MutableAttributeSet a, float i) 设置左边缩进。
static void | StyleConstants.setLineSpacing(MutableAttributeSet a, float i) 设置行间距。
static void | StyleConstants.setRightIndent(MutableAttributeSet a, float i) 设置右边缩进。
static void | StyleConstants.setSpaceAbove(MutableAttributeSet a, float i) 设置上部空间。
static void | StyleConstants.setSpaceBelow(MutableAttributeSet a, float i) 设置下部空间。
static void | StyleConstants.setStrikeThrough(MutableAttributeSet a, boolean b) 设置删除线属性。
static void | StyleConstants.setSubscript(MutableAttributeSet a, boolean b) 设置下标属性。
static void | StyleConstants.setSuperscript(MutableAttributeSet a, boolean b) 设置上标属性。
static void | StyleConstants.setTabSet(MutableAttributeSet a, TabSet tabs) 设置 TabSet。
static void | StyleConstants.setUnderline(MutableAttributeSet a, boolean b) 设置下标属性。

javax.swing.text.html 中 MutableAttributeSet 的使用

实现 MutableAttributeSet 的 javax.swing.text.html 中的类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

声明为 MutableAttributeSet 的 javax.swing.text.html 中的字段
protected  MutableAttributeSet HTMLDocument.HTMLReader.charAttr

返回 MutableAttributeSet 的 javax.swing.text.html 中的方法
protected MutableAttributeSet | StyleSheet.createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
MutableAttributeSet | HTMLEditorKit.getInputAttributes() 获取该样式编辑动作的输入属性。

参数类型为 MutableAttributeSet 的 javax.swing.text.html 中的方法
void | StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。
boolean | StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value) 将 CSS 属性添加到给定的集合。
protected void | HTMLDocument.HTMLReader.addSpecialElement(HTML.Tag t, MutableAttributeSet a) 添加基本上完全是在属性集中指定的内容。
protected void | HTMLDocument.HTMLReader.blockOpen(HTML.Tag t, MutableAttributeSet attr) 向解析器缓冲区添加一条指令，以创建具有给定属性的块元素。
protected void | HTMLEditorKit.createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
void | HTMLDocument.HTMLReader.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleSimpleTag(HTML.Tag t, MutableAttributeSet a, int pos)
void | HTMLDocument.HTMLReader.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos) 从解析器回调。
void | HTMLEditorKit.ParserCallback.handleStartTag(HTML.Tag t, MutableAttributeSet a, int pos)
void | HTMLDocument.HTMLReader.TagAction.start(HTML.Tag t, MutableAttributeSet a) 当发现此动作所注册的标记类型的开始标记时调用。
void | HTMLDocument.HTMLReader.BlockAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.ParagraphAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.SpecialAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.IsindexAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.HiddenAction.start(HTML.Tag t, MutableAttributeSet a)
void | HTMLDocument.HTMLReader.PreAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.CharacterAction.start(HTML.Tag t, MutableAttributeSet attr)
void | HTMLDocument.HTMLReader.FormAction.start(HTML.Tag t, MutableAttributeSet attr)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet
的使用

使用 AttributeSet 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 AttributeSet 的使用

返回 AttributeSet 的 java.awt 中的方法
 AttributeSet TextComponent.AccessibleAWTTextComponent.getCharacterAttribute(int i)
返回给定字符（位于给定索引处）的 AttributeSet。

javax.accessibility 中 AttributeSet 的使用

声明为 AttributeSet 的 javax.accessibility 中的字段
 AttributeSet AccessibleAttributeSequence.attributes
文本属性

返回 AttributeSet 的 javax.accessibility 中的方法
 AttributeSet AccessibleText.getCharacterAttribute(int i)
返回给定索引处给定字符的 AttributeSet

参数类型为 AttributeSet 的 javax.accessibility 中的方法
 void AccessibleEditableText.setAttributes(int startIndex, int endIndex, AttributeSet as)
设置两个索引之间文本的属性。

参数类型为 AttributeSet 的 javax.accessibility 中的构造方法
AccessibleAttributeSequence(int start, int end, AttributeSet attr)
构造带有给定参数的 AccessibleAttributeSequence。

javax.swing 中 AttributeSet 的使用

返回 AttributeSet 的 javax.swing 中的方法
AttributeSet | JSpinner.AccessibleJSpinner.getCharacterAttribute(int i) 返回给定索引处给定字符的 AttributeSet
AttributeSet | ProgressMonitor.AccessibleProgressMonitor.getCharacterAttribute(int i) 返回位于给定索引处的给定字符的 AttributeSet
AttributeSet | AbstractButton.AccessibleAbstractButton.getCharacterAttribute(int i) 返回位于给定索引处的给定字符的 AttributeSet。
AttributeSet | JLabel.AccessibleJLabel.getCharacterAttribute(int i) 返回给定索引处给定字符的 AttributeSet
AttributeSet | JTextPane.getCharacterAttributes() 获取在当前插入符号位置的有效字符属性，或者 null。
AttributeSet | JTextPane.getParagraphAttributes() 获取插入符号位置的当前有效段落属性，如果没有，则返回 null。

参数类型为 AttributeSet 的 javax.swing 中的方法
void | JSpinner.AccessibleJSpinner.setAttributes(int startIndex, int endIndex, AttributeSet as) 设置两个索引之间文本的属性。
void | JTextPane.setCharacterAttributes(AttributeSet attr, boolean replace) 将给定属性应用于字符内容。
void | JTextPane.setParagraphAttributes(AttributeSet attr, boolean replace) 将给定属性应用于段落。

javax.swing.text 中 AttributeSet 的使用

javax.swing.text 中 AttributeSet 的子接口
interface | MutableAttributeSet 独特属性的可变集合的通用接口。
interface | Style 与文档中某个元素相关的属性集合。

实现 AttributeSet 的 javax.swing.text 中的类
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。
class | SimpleAttributeSet 使用哈希表的 MutableAttributeSet 的直接实现。
class | StyleContext.NamedStyle 通常用于表示字符和段落样式的属性集合。
class | StyleContext.SmallAttributeSet 此类可在数组中存储少量的属性。

声明为 AttributeSet 的 javax.swing.text 中的字段
protected AttributeSet | DefaultStyledDocument.AttributeUndoableEdit.copy
static AttributeSet | SimpleAttributeSet.EMPTY 空的属性集。
protected AttributeSet | DefaultStyledDocument.AttributeUndoableEdit.newAttributes

返回 AttributeSet 的 javax.swing.text 中的方法
AttributeSet | StyleContext.addAttribute(AttributeSet old, Object name, Object value) 向给定的集合中添加属性，并返回新的有代表性的集合。
AttributeSet | AbstractDocument.AttributeContext.addAttribute(AttributeSet old, Object name, Object value) 向给定属性集中添加一个属性，并返回新的有代表性的属性集。
AttributeSet | StyleContext.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
AttributeSet | AbstractDocument.AttributeContext.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加一组属性。
AttributeSet | SimpleAttributeSet.copyAttributes() 创建属性的副本。
AttributeSet | AttributeSet.copyAttributes() 返回保证固定不变的属性集。
AttributeSet | StyleContext.SmallAttributeSet.copyAttributes() 复制属性集。
AttributeSet | StyleContext.NamedStyle.copyAttributes() 复制属性集。
AttributeSet | AbstractDocument.AbstractElement.copyAttributes() 复制属性集合。
AttributeSet | DefaultStyledDocument.ElementSpec.getAttributes() 获得元素属性。
AttributeSet | View.getAttributes() 获取呈现时要使用的属性。
AttributeSet | AbstractDocument.AbstractElement.getAttributes() 获取该元素的属性。
AttributeSet | Element.getAttributes() 获取此元素包含的属性集合。
AttributeSet | JTextComponent.AccessibleJTextComponent.getCharacterAttribute(int i) 返回给定字符（位于给定索引处）的 AttributeSet。
AttributeSet | StyleContext.getEmptySet() 获取空 AttributeSet。
AttributeSet | AbstractDocument.AttributeContext.getEmptySet() 获取一个空的 AttributeSet。
AttributeSet | SimpleAttributeSet.getResolveParent() 获取正解析的父级。
AttributeSet | AttributeSet.getResolveParent() 获取解析父集合。
AttributeSet | StyleContext.SmallAttributeSet.getResolveParent() 如果未重写，解析父级默认为是解析父元素。
AttributeSet | StyleContext.NamedStyle.getResolveParent() 从父级获取属性。
AttributeSet | AbstractDocument.AbstractElement.getResolveParent() 获取要解析的父级。
AttributeSet | StyleContext.removeAttribute(AttributeSet old, Object name) 从集合中移除一个属性。
AttributeSet | AbstractDocument.AttributeContext.removeAttribute(AttributeSet old, Object name) 从属性集中移除某个属性。
AttributeSet | StyleContext.removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的一组属性。
AttributeSet | StyleContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一个属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一组属性。

参数类型为 AttributeSet 的 javax.swing.text 中的方法
AttributeSet | StyleContext.addAttribute(AttributeSet old, Object name, Object value) 向给定的集合中添加属性，并返回新的有代表性的集合。
AttributeSet | AbstractDocument.AttributeContext.addAttribute(AttributeSet old, Object name, Object value) 向给定属性集中添加一个属性，并返回新的有代表性的属性集。
void | SimpleAttributeSet.addAttributes(AttributeSet attributes) 向列表添加属性集。
void | MutableAttributeSet.addAttributes(AttributeSet attributes) 创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。
void | StyleContext.NamedStyle.addAttributes(AttributeSet attr) 将属性集添加到元素。
void | AbstractDocument.AbstractElement.addAttributes(AttributeSet attr) 向该元素添加一个属性集合。
AttributeSet | StyleContext.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
AttributeSet | AbstractDocument.AttributeContext.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加一组属性。
boolean | SimpleAttributeSet.containsAttributes(AttributeSet attributes) 确定属性列表中是否包含所有指定的名称/值对。
boolean | AttributeSet.containsAttributes(AttributeSet attributes) 如果此集合用相等值定义给定集合中的所有属性，则返回 true。
boolean | StyleContext.SmallAttributeSet.containsAttributes(AttributeSet attrs) 检查属性集是否包含了所有给定的属性。
boolean | StyleContext.NamedStyle.containsAttributes(AttributeSet attrs) 检查元素是否包含了所有属性。
boolean | AbstractDocument.AbstractElement.containsAttributes(AttributeSet attrs) 检查该元素是否包含所有的属性。
protected Element | AbstractDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可包含其他元素。
protected MutableAttributeSet | StyleContext.createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
protected Element | AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建文档叶元素。
protected StyleContext.SmallAttributeSet | StyleContext.createSmallAttributeSet(AttributeSet a) 创建一个可能用于共享的压缩属性集。
static int | StyleConstants.getAlignment(AttributeSet a) 获取对齐设置。
Color | DefaultStyledDocument.getBackground(AttributeSet attr) 从属性集获得背景颜色。
Color | StyledDocument.getBackground(AttributeSet attr) 使用一个属性集并将其转换为一个背景色规范。
static Color | StyleConstants.getBackground(AttributeSet a) 从属性列表中获取背景色设置。
Color | StyleContext.getBackground(AttributeSet attr) 使用一个属性集并将其转换成为一个背景色规范。
static int | StyleConstants.getBidiLevel(AttributeSet a) 获取 BidiLevel 设置。
static Component | StyleConstants.getComponent(AttributeSet a) 从属性列表中获取组件设置。
static float | StyleConstants.getFirstLineIndent(AttributeSet a) 获取首行缩进设置。
Font | DefaultStyledDocument.getFont(AttributeSet attr) 从属性集获得字体。
Font | StyledDocument.getFont(AttributeSet attr) 使用一个属性集并将其转换为字体规范。
Font | StyleContext.getFont(AttributeSet attr) 从属性集中获取字体。
static String | StyleConstants.getFontFamily(AttributeSet a) 从属性列表中获取字体系列设置。
static int | StyleConstants.getFontSize(AttributeSet a) 从属性列表中获取字体大小设置。
Color | DefaultStyledDocument.getForeground(AttributeSet attr) 从属性集获得前景色。
Color | StyledDocument.getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
static Color | StyleConstants.getForeground(AttributeSet a) 从属性列表中获取前景色设置。
Color | StyleContext.getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
static Icon | StyleConstants.getIcon(AttributeSet a) 从属性列表中获取图标设置。
static float | StyleConstants.getLeftIndent(AttributeSet a) 获取左边缩进设置。
static float | StyleConstants.getLineSpacing(AttributeSet a) 获取行间距设置。
static float | StyleConstants.getRightIndent(AttributeSet a) 获取右边缩进设置。
static float | StyleConstants.getSpaceAbove(AttributeSet a) 获取上部空间设置。
static float | StyleConstants.getSpaceBelow(AttributeSet a) 获取下部空间设置。
static TabSet | StyleConstants.getTabSet(AttributeSet a) 获取 TabSet。
void | DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr) 将文本插入指定的 Document 之前调用。
abstract void | DocumentFilter.FilterBypass.insertString(int offset, String string, AttributeSet attr) 插入指定的文本，绕过 DocumentFilter。
void | PlainDocument.insertString(int offs, String str, AttributeSet a) 向文档中插入某些内容。
void | AbstractDocument.insertString(int offs, String str, AttributeSet a) 将某些内容插入文档。
void | Document.insertString(int offset, String str, AttributeSet a) 插入内容字符串。
protected void | DefaultStyledDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
protected void | PlainDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 随文本插入更新文档结构。
protected void | AbstractDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
static boolean | StyleConstants.isBold(AttributeSet a) 确定是否设置了粗体属性。
boolean | SimpleAttributeSet.isEqual(AttributeSet attr) 比较两个属性集。
boolean | AttributeSet.isEqual(AttributeSet attr) 确定两个属性集是否相等。
boolean | StyleContext.SmallAttributeSet.isEqual(AttributeSet attr) 检查两个属性集是否相等。
boolean | StyleContext.NamedStyle.isEqual(AttributeSet attr) 检查两个属性集是否相等。
boolean | AbstractDocument.AbstractElement.isEqual(AttributeSet attr) 检查两个属性集合是否相等。
static boolean | StyleConstants.isItalic(AttributeSet a) 确定是否设置了斜体属性。
static boolean | StyleConstants.isStrikeThrough(AttributeSet a) 确定是否设置了删除线属性。
static boolean | StyleConstants.isSubscript(AttributeSet a) 确定是否设置了下标属性。
static boolean | StyleConstants.isSuperscript(AttributeSet a) 确定是否设置了上标属性。
static boolean | StyleConstants.isUnderline(AttributeSet a) 确定是否设置了下划线属性。
void | StyleContext.reclaim(AttributeSet a) 返回 MutableAttributeSet 实现不再需要的集合。
void | AbstractDocument.AttributeContext.reclaim(AttributeSet a) 回收某个属性集。
AttributeSet | StyleContext.removeAttribute(AttributeSet old, Object name) 从集合中移除一个属性。
AttributeSet | AbstractDocument.AttributeContext.removeAttribute(AttributeSet old, Object name) 从属性集中移除某个属性。
void | SimpleAttributeSet.removeAttributes(AttributeSet attributes) 从列表中移除属性集。
void | MutableAttributeSet.removeAttributes(AttributeSet attributes) 移除具有给定 name 的属性集。
void | StyleContext.NamedStyle.removeAttributes(AttributeSet attrs) 移除元素的属性集。
void | AbstractDocument.AbstractElement.removeAttributes(AttributeSet attrs) 移除该元素的属性集合。
AttributeSet | StyleContext.removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, AttributeSet attrs) 移除元素的一组属性。
AttributeSet | StyleContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一个属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一组属性。
void | DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs) 在替换指定的 Document 中的文本区域之前调用。
abstract void | DocumentFilter.FilterBypass.replace(int offset, int length, String string, AttributeSet attrs) 删除从 offset 到 offset + length 的文本区域，并用 text 替换。
void | AbstractDocument.replace(int offset, int length, String text, AttributeSet attrs) 删除从 offset 到 offset + length 的文本区域，并用 text 替换它。
void | JTextComponent.AccessibleJTextComponent.setAttributes(int startIndex, int endIndex, AttributeSet as) 设置两个索引之间的文本的属性。
void | DefaultStyledDocument.setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace) 为文档某些部分设置属性。
void | StyledDocument.setCharacterAttributes(int offset, int length, AttributeSet s, boolean replace) 更改内容元素属性，该属性是用来给定文档中现有内容范围的。
protected void | StyledEditorKit.StyledTextAction.setCharacterAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对字符内容应用给定的属性。
void | DefaultStyledDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
void | StyledDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
protected void | StyledEditorKit.StyledTextAction.setParagraphAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对段落应用给定的属性。
protected void | CompositeView.setParagraphInsets(AttributeSet attr) 按照给定属性中指定的段落属性设置 insets。
void | SimpleAttributeSet.setResolveParent(AttributeSet parent) 设置解析的父级。
void | MutableAttributeSet.setResolveParent(AttributeSet parent) 设置正解析的父级。
void | StyleContext.NamedStyle.setResolveParent(AttributeSet parent) 设置解析的父级。
void | AbstractDocument.AbstractElement.setResolveParent(AttributeSet parent) 设置要解析的父级。
protected void | AbstractWriter.writeAttributes(AttributeSet attr) 以 " =" 对的形式写出属性集。
void | StyleContext.writeAttributes(ObjectOutputStream out, AttributeSet a) 写出属性的特定于上下文的处理。
static void | StyleContext.writeAttributeSet(ObjectOutputStream out, AttributeSet a) 将属性集写入到给定的对象流以便序列化。

参数类型为 AttributeSet 的 javax.swing.text 中的构造方法
AbstractDocument.AbstractElement(Element parent, AttributeSet a)
创建新的 AbstractElement。
AbstractDocument.BranchElement(Element parent, AttributeSet a)
构造最初不包含任何子元素的复合元素。
AbstractDocument.LeafElement(Element parent, AttributeSet a, int offs0, int offs1)
构造一个表示文档中内容的元素（没有子元素）。
DefaultStyledDocument.AttributeUndoableEdit(Element element, AttributeSet newAttributes, boolean isReplacing)
DefaultStyledDocument.ElementSpec(AttributeSet a, short type)
当标记不在文档中存储时供标记使用的构造方法。
DefaultStyledDocument.ElementSpec(AttributeSet a, short type, char[] txt, int offs, int len)
用于外部创建规范的构造方法，供批量输入内容和标记到文档中。
DefaultStyledDocument.ElementSpec(AttributeSet a, short type, int len)
供文档内部解析使用的构造方法，在数据已添加但还需要 len 信息时使用。
SimpleAttributeSet(AttributeSet source)
根据提供的属性集创建新属性集。
StyleContext.SmallAttributeSet(AttributeSet attrs)

javax.swing.text.html 中 AttributeSet 的使用

实现 AttributeSet 的 javax.swing.text.html 中的类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

返回 AttributeSet 的 javax.swing.text.html 中的方法
AttributeSet | StyleSheet.addAttribute(AttributeSet old, Object key, Object value) 向给定集合添加属性，并返回新的表示方式的集合。
AttributeSet | StyleSheet.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
AttributeSet | BlockView.getAttributes() 获取呈现时要使用的属性。
abstract AttributeSet | HTMLDocument.Iterator.getAttributes() 返回此标记的属性。
AttributeSet | ImageView.getAttributes() 获取呈现时要使用的属性。
AttributeSet | InlineView.getAttributes() 获取呈现时要使用的属性。
AttributeSet | Option.getAttributes() 获取与此选项相关的属性。
AttributeSet | ParagraphView.getAttributes() 获取呈现时所使用的属性。
AttributeSet | StyleSheet.getDeclaration(String decl) 将 CSS 声明转换为表示 CSS 声明的 AttributeSet。
AttributeSet | HTMLDocument.RunElement.getResolveParent() 获得解析父级。
AttributeSet | HTMLDocument.BlockElement.getResolveParent() 获得解析父级。
AttributeSet | StyleSheet.getViewAttributes(View v) 获取用来显示视图的属性集。
AttributeSet | StyleSheet.removeAttribute(AttributeSet old, Object key) 从集合中移除属性。
AttributeSet | StyleSheet.removeAttributes(AttributeSet old, AttributeSet attrs) 移除属性集。
AttributeSet | StyleSheet.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的属性集。
AttributeSet | StyleSheet.translateHTMLToCSS(AttributeSet htmlAttrSet) 将 HTML 属性集合转换为对等的 CSS 属性集合。

参数类型为 AttributeSet 的 javax.swing.text.html 中的方法
AttributeSet | StyleSheet.addAttribute(AttributeSet old, Object key, Object value) 向给定集合添加属性，并返回新的表示方式的集合。
AttributeSet | StyleSheet.addAttributes(AttributeSet old, AttributeSet attr) 向元素添加属性集。
protected void | HTMLWriter.closeOutUnwantedEmbeddedTags(AttributeSet attr) 搜索属性集和存储在标记向量中的每个标记。
protected Element | HTMLDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可以包含其他元素。
protected MutableAttributeSet | StyleSheet.createLargeAttributeSet(AttributeSet a) 创建一个以空间来换取时间的大属性集合。
protected Element | HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建直接表示文本的文档叶元素（没有任何子级）。
protected StyleContext.SmallAttributeSet | StyleSheet.createSmallAttributeSet(AttributeSet a) 创建可以共享的属性压缩集。
Color | StyleSheet.getBackground(AttributeSet a) 获取一个属性集并将其转换为背景色规范。
StyleSheet.BoxPainter | StyleSheet.getBoxPainter(AttributeSet a) 获取给定 CSS 属性集合使用的框 formatter。
Font | StyleSheet.getFont(AttributeSet a) 获取给定属性集使用的字体。
Color | StyleSheet.getForeground(AttributeSet a) 获取一个属性集并将其转换为前景色规范。
static int | HTML.getIntegerAttributeValue(AttributeSet attr, HTML.Attribute key, int def) 获取整数属性值。
StyleSheet.ListPainter | StyleSheet.getListPainter(AttributeSet a) 获取给定 CSS 属性集合使用的列表 formatter。
protected void | HTMLDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 由于插入文本而导致更新文档的结构。
protected boolean | HTMLWriter.isBlockTag(AttributeSet attr) 确定与该元素关联的 HTML.Tag 是否为块标记。
protected boolean | HTMLWriter.matchNameAttribute(AttributeSet attr, HTML.Tag tag) 如果 StyleConstants.NameAttribute 与作为参数传入的标记相同，则返回 true。
AttributeSet | StyleSheet.removeAttribute(AttributeSet old, Object key) 从集合中移除属性。
AttributeSet | StyleSheet.removeAttributes(AttributeSet old, AttributeSet attrs) 移除属性集。
AttributeSet | StyleSheet.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的属性集。
protected void | HTMLWriter.selectContent(AttributeSet attr) 写出 SELECT 表单元素的内容。
void | HTMLDocument.setParagraphAttributes(int offset, int length, AttributeSet s, boolean replace) 设置段落属性。
protected void | HTMLWriter.textAreaContent(AttributeSet attr) 写出 TEXTAREA 表单元素中所包含的文本。
AttributeSet | StyleSheet.translateHTMLToCSS(AttributeSet htmlAttrSet) 将 HTML 属性集合转换为对等的 CSS 属性集合。
protected void | HTMLWriter.writeAttributes(AttributeSet attr) 写出属性集。
protected void | MinimalHTMLWriter.writeAttributes(AttributeSet attr) 写出以下类型的所有属性：StyleConstants.ParagraphConstants、StyleConstants.CharacterConstants、StyleConstants.FontConstants、StyleConstants.ColorConstants。
protected void | HTMLWriter.writeEmbeddedTags(AttributeSet attr) 搜索 AttributeSet 中的嵌入式标记并写出它们。
protected void | MinimalHTMLWriter.writeHTMLTags(AttributeSet attr) 基于文本的属性设置生成文本的 bold <b>、italic <i> 和 <u> 标记。
protected void | MinimalHTMLWriter.writeNonHTMLAttributes(AttributeSet attr) 以与 HTML 兼容的方式写出其余的字符级属性（bold、italic 和 underline 之外的属性）。

参数类型为 AttributeSet 的 javax.swing.text.html 中的构造方法
HTMLDocument.BlockElement(Element parent, AttributeSet a)
构造初始不包含子元素的复合元素。
HTMLDocument.RunElement(Element parent, AttributeSet a, int offs0, int offs1)
构造表示文档内部（没有子级）内容的元素。
Option(AttributeSet attr)
创建新的 Option 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet.FontAttribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet.FontAttribute
的使用

使用 AttributeSet.FontAttribute 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AttributeSet.FontAttribute 的使用

实现 AttributeSet.FontAttribute 的 javax.swing.text 中的类
static class StyleConstants.FontConstants
这是一个类型安全的已知 属性的枚举，它用于字体样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet.ColorAttribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet.ColorAttribute
的使用

使用 AttributeSet.ColorAttribute 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AttributeSet.ColorAttribute 的使用

实现 AttributeSet.ColorAttribute 的 javax.swing.text 中的类
static class StyleConstants.ColorConstants
这是一个类型安全的已知 属性的枚举，它用于颜色样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet.CharacterAttribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet.CharacterAttribute
的使用

使用 AttributeSet.CharacterAttribute 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AttributeSet.CharacterAttribute 的使用

实现 AttributeSet.CharacterAttribute 的 javax.swing.text 中的类
static class | StyleConstants.CharacterConstants 这是一个类型安全的已知 属性的枚举，它用于字符样式。
static class | StyleConstants.ColorConstants 这是一个类型安全的已知 属性的枚举，它用于颜色样式。
static class | StyleConstants.FontConstants 这是一个类型安全的已知 属性的枚举，它用于字体样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.AttributeSet.ParagraphAttribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AttributeSet.ParagraphAttribute
的使用

使用 AttributeSet.ParagraphAttribute 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AttributeSet.ParagraphAttribute 的使用

实现 AttributeSet.ParagraphAttribute 的 javax.swing.text 中的类
static class StyleConstants.ParagraphConstants
这是一个类型安全的已知 属性的枚举，它用于段落样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants
的使用

使用 StyleConstants 的软件包
javax.swing.text 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 StyleConstants 的使用

javax.swing.text 中 StyleConstants 的子类
static class | StyleConstants.CharacterConstants 这是一个类型安全的已知 属性的枚举，它用于字符样式。
static class | StyleConstants.ColorConstants 这是一个类型安全的已知 属性的枚举，它用于颜色样式。
static class | StyleConstants.FontConstants 这是一个类型安全的已知 属性的枚举，它用于字体样式。
static class | StyleConstants.ParagraphConstants 这是一个类型安全的已知 属性的枚举，它用于段落样式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants.ParagraphConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants.ParagraphConstants
的使用

没有 javax.swing.text.StyleConstants.ParagraphConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants.CharacterConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants.CharacterConstants
的使用

没有 javax.swing.text.StyleConstants.CharacterConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants.ColorConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants.ColorConstants
的使用

没有 javax.swing.text.StyleConstants.ColorConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyleConstants.FontConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleConstants.FontConstants
的使用

没有 javax.swing.text.StyleConstants.FontConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyleContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleContext
的使用

使用 StyleContext 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 StyleContext 的使用

返回 StyleContext 的 javax.swing.text 中的方法
static StyleContext StyleContext.getDefaultStyleContext()
返回由所有文档共享的默认 AttributeContext，这些文档不影响定义/提供其自己的上下文。

参数类型为 StyleContext 的 javax.swing.text 中的构造方法
DefaultStyledDocument(AbstractDocument.Content c, StyleContext styles)
构造样式化文档。
DefaultStyledDocument(StyleContext styles)
构造具有默认的内容存储实现和一组共享样式的样式化文档。

javax.swing.text.html 中 StyleContext 的使用

javax.swing.text.html 中 StyleContext 的子类
 class StyleSheet
支持定义要呈现的 HTML 视图的可视化特征。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyleContext.SmallAttributeSet 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleContext.SmallAttributeSet
的使用

使用 StyleContext.SmallAttributeSet 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 StyleContext.SmallAttributeSet 的使用

返回 StyleContext.SmallAttributeSet 的 javax.swing.text 中的方法
protected  StyleContext.SmallAttributeSet StyleContext.createSmallAttributeSet(AttributeSet a)
创建一个可能用于共享的压缩属性集。

javax.swing.text.html 中 StyleContext.SmallAttributeSet 的使用

返回 StyleContext.SmallAttributeSet 的 javax.swing.text.html 中的方法
protected  StyleContext.SmallAttributeSet StyleSheet.createSmallAttributeSet(AttributeSet a)
创建可以共享的属性压缩集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.StyleContext.NamedStyle 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.StyleContext.NamedStyle
的使用

没有 javax.swing.text.StyleContext.NamedStyle 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.GapContent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.GapContent
的使用

没有 javax.swing.text.GapContent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.PlainDocument 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.PlainDocument
的使用

没有 javax.swing.text.PlainDocument 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument
的使用

使用 AbstractDocument 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument 的使用

javax.swing.text 中 AbstractDocument 的子类
class | DefaultStyledDocument 能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
class | PlainDocument 维护无任何字符属性的普通文档。

javax.swing.text.html 中 AbstractDocument 的使用

javax.swing.text.html 中 AbstractDocument 的子类
 class HTMLDocument
对 HTML 进行建模的文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.AbstractDocument.Content 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AbstractDocument.Content
的使用

使用 AbstractDocument.Content 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.Content 的使用

实现 AbstractDocument.Content 的 javax.swing.text 中的类
class | GapContent AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。
class | StringContent AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。

返回 AbstractDocument.Content 的 javax.swing.text 中的方法
protected  AbstractDocument.Content AbstractDocument.getContent()
获得文档的内容。

参数类型为 AbstractDocument.Content 的 javax.swing.text 中的构造方法
AbstractDocument(AbstractDocument.Content data)
构造具有某种指定内容存储机制的新 AbstractDocument。
AbstractDocument(AbstractDocument.Content data, AbstractDocument.AttributeContext context)
构造具有某种指定内容存储机制的新 AbstractDocument。
DefaultStyledDocument(AbstractDocument.Content c, StyleContext styles)
构造样式化文档。
PlainDocument(AbstractDocument.Content c)
构造一个纯文本文档。

javax.swing.text.html 中 AbstractDocument.Content 的使用

参数类型为 AbstractDocument.Content 的 javax.swing.text.html 中的构造方法
HTMLDocument(AbstractDocument.Content c, StyleSheet styles)
构造具有给定内容存储实现和给定样式/属性存储机制的 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.AbstractDocument.AttributeContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.AbstractDocument.AttributeContext
的使用

使用 AbstractDocument.AttributeContext 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.AttributeContext 的使用

实现 AbstractDocument.AttributeContext 的 javax.swing.text 中的类
 class StyleContext
样式池及其关联的资源。

返回 AbstractDocument.AttributeContext 的 javax.swing.text 中的方法
protected  AbstractDocument.AttributeContext AbstractDocument.getAttributeContext()
获取管理属性的上下文。

参数类型为 AbstractDocument.AttributeContext 的 javax.swing.text 中的构造方法
AbstractDocument(AbstractDocument.Content data, AbstractDocument.AttributeContext context)
构造具有某种指定内容存储机制的新 AbstractDocument。

javax.swing.text.html 中 AbstractDocument.AttributeContext 的使用

实现 AbstractDocument.AttributeContext 的 javax.swing.text.html 中的类
 class StyleSheet
支持定义要呈现的 HTML 视图的可视化特征。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.AbstractElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.AbstractElement
的使用

使用 AbstractDocument.AbstractElement 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.AbstractElement 的使用

javax.swing.text 中 AbstractDocument.AbstractElement 的子类
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。

返回 AbstractDocument.AbstractElement 的 javax.swing.text 中的方法
protected AbstractDocument.AbstractElement | DefaultStyledDocument.createDefaultRoot() 创建用于代表默认文档结构的根元素。
protected AbstractDocument.AbstractElement | PlainDocument.createDefaultRoot() 创建用于表示默认文档结构的根元素。

javax.swing.text.html 中 AbstractDocument.AbstractElement 的使用

javax.swing.text.html 中 AbstractDocument.AbstractElement 的子类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

返回 AbstractDocument.AbstractElement 的 javax.swing.text.html 中的方法
protected  AbstractDocument.AbstractElement HTMLDocument.createDefaultRoot()
创建用于表示默认文档结构的根元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.BranchElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.BranchElement
的使用

使用 AbstractDocument.BranchElement 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.BranchElement 的使用

javax.swing.text 中 AbstractDocument.BranchElement 的子类
protected  class DefaultStyledDocument.SectionElement
文档的默认根元素... 与所包含的段落/行对应。

javax.swing.text.html 中 AbstractDocument.BranchElement 的使用

javax.swing.text.html 中 AbstractDocument.BranchElement 的子类
 class HTMLDocument.BlockElement
表示结构性 HTML 块 的元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.LeafElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.LeafElement
的使用

使用 AbstractDocument.LeafElement 的软件包
javax.swing.text.html 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html 中 AbstractDocument.LeafElement 的使用

javax.swing.text.html 中 AbstractDocument.LeafElement 的子类
 class HTMLDocument.RunElement
表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.DefaultDocumentEvent
的使用

使用 AbstractDocument.DefaultDocumentEvent 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text 中 AbstractDocument.DefaultDocumentEvent 的使用

参数类型为 AbstractDocument.DefaultDocumentEvent 的 javax.swing.text 中的方法
void | DefaultStyledDocument.ElementBuffer.change(int offset, int length, AbstractDocument.DefaultDocumentEvent de) 更改内容。
void | DefaultStyledDocument.ElementBuffer.insert(int offset, int length, DefaultStyledDocument.ElementSpec[] data, AbstractDocument.DefaultDocumentEvent de) 插入新内容。
protected void | DefaultStyledDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
protected void | PlainDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 随文本插入更新文档结构。
protected void | AbstractDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr) 在文本插入后更新文档结构。
protected void | AbstractDocument.postRemoveUpdate(AbstractDocument.DefaultDocumentEvent chng) 随文本的移除更新任何文档结构。
void | DefaultStyledDocument.ElementBuffer.remove(int offset, int length, AbstractDocument.DefaultDocumentEvent de) 移除内容。
protected void | DefaultStyledDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng) 在文本移除后更新文档结构。
protected void | PlainDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng) 随文本的移除更新任何文档结构。
protected void | AbstractDocument.removeUpdate(AbstractDocument.DefaultDocumentEvent chng) 随文本的移除更新任何文档结构。

javax.swing.text.html 中 AbstractDocument.DefaultDocumentEvent 的使用

参数类型为 AbstractDocument.DefaultDocumentEvent 的 javax.swing.text.html 中的方法
protected  void HTMLDocument.insertUpdate(AbstractDocument.DefaultDocumentEvent chng, AttributeSet attr)
由于插入文本而导致更新文档的结构。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.text.AbstractDocument.ElementEdit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.text.AbstractDocument.ElementEdit
的使用

没有 javax.swing.text.AbstractDocument.ElementEdit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Document 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Document
的使用

使用 Document 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing 中 Document 的使用

返回 Document 的 javax.swing 中的方法
protected Document | JTextArea.createDefaultModel() 如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。
protected Document | JTextField.createDefaultModel() 如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。

参数类型为 Document 的 javax.swing 中的方法
void | JFormattedTextField.setDocument(Document doc) 将该编辑器与某个文本文档关联。
void | JTextPane.setDocument(Document doc) 将编辑器与一个文本文档关联。
void | JTextField.setDocument(Document doc) 将编辑器与一个文本文档关联。

参数类型为 Document 的 javax.swing 中的构造方法
JPasswordField(Document doc, String txt, int columns)
构造一个使用给定文本存储模型和给定列数的新 JPasswordField。
JTextArea(Document doc)
构造新的 JTextArea，使其具有给定的文档模型，所有其他参数均默认为 (null, 0, 0)。
JTextArea(Document doc, String text, int rows, int columns)
构造具有指定行数和列数以及给定模型的新的 JTextArea。
JTextField(Document doc, String text, int columns)
构造一个新的 JTextField，它使用给定文本存储模型和给定的列数。

javax.swing.event 中 Document 的使用

返回 Document 的 javax.swing.event 中的方法
 Document DocumentEvent.getDocument()
获得发起更改事件的文档。

javax.swing.text 中 Document 的使用

javax.swing.text 中 Document 的子接口
 interface StyledDocument
用作通用样式化文档的接口。

实现 Document 的 javax.swing.text 中的类
class | AbstractDocument 文档接口的实现，可作为实现各种文档的基础。
class | DefaultStyledDocument 能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
class | PlainDocument 维护无任何字符属性的普通文档。

返回 Document 的 javax.swing.text 中的方法
Document | StyledEditorKit.createDefaultDocument() 创建一个适合此编辑器类型的未初始化文本存储模型。
Document | DefaultEditorKit.createDefaultDocument() 创建一个适合此编辑器类型的未初始化文本存储模型 (PlainDocument)。
abstract Document | EditorKit.createDefaultDocument() 创建一个适合此编辑器类型的未初始化的文本存储模型。
protected Document | AbstractWriter.getDocument() 获取文档。
abstract Document | DocumentFilter.FilterBypass.getDocument() 返回发生变化的 Document。
Document | View.getDocument() 获取与视图关联的模型。
Document | JTextComponent.getDocument() 获取与编辑器关联的模型。
Document | AbstractDocument.AbstractElement.getDocument() 获得基础模型。
Document | AbstractDocument.DefaultDocumentEvent.getDocument() 获得发起更改事件的文档。
Document | Element.getDocument() 获取与此元素关联的文档。

参数类型为 Document 的 javax.swing.text 中的方法
void | DefaultEditorKit.read(InputStream in, Document doc, int pos) 插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract void | EditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | DefaultEditorKit.read(Reader in, Document doc, int pos) 插入取自给定流的内容，它将被视为纯文本。
abstract void | EditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | JTextComponent.setDocument(Document doc) 将编辑器与文本文档关联。
void | DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract void | EditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
void | DefaultEditorKit.write(Writer out, Document doc, int pos, int len) 将取自文档的内容以纯文本格式写入给定流。
abstract void | EditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

参数类型为 Document 的 javax.swing.text 中的构造方法
AbstractWriter(Writer w, Document doc)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Document doc, int pos, int len)
创建新的 AbstractWriter。
ElementIterator(Document document)
创建新的 ElementIterator。

javax.swing.text.html 中 Document 的使用

实现 Document 的 javax.swing.text.html 中的类
 class HTMLDocument
对 HTML 进行建模的文档。

返回 Document 的 javax.swing.text.html 中的方法
 Document HTMLEditorKit.createDefaultDocument()
创建一个适合此编辑器类型的未初始化文本存储模型。

参数类型为 Document 的 javax.swing.text.html 中的方法
void | HTMLEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容。
void | HTMLEditorKit.write(Writer out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。

javax.swing.text.rtf 中 Document 的使用

参数类型为 Document 的 javax.swing.text.rtf 中的方法
void | RTFEditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
void | RTFEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，该内容将被视为纯文本。
void | RTFEditorKit.write(OutputStream out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
void | RTFEditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容作为纯文本写入给定的流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.text.Element 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.text.Element
的使用

使用 Element 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 Element 的使用

参数类型为 Element 的 javax.swing 中的构造方法
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)

javax.swing.event 中 Element 的使用

返回 Element 的 javax.swing.event 中的方法
Element[] | DocumentEvent.ElementChange.getChildrenAdded() 获得添加到给定父元素中的子元素。
Element[] | DocumentEvent.ElementChange.getChildrenRemoved() 获得从给定父元素中移除的子元素。
Element | DocumentEvent.ElementChange.getElement() 返回所表示的元素。
Element | HyperlinkEvent.getSourceElement() 返回对应于事件源的 Element。

参数类型为 Element 的 javax.swing.event 中的方法
 DocumentEvent.ElementChange DocumentEvent.getChange(Element elem)
获得给定元素的更改信息。

参数类型为 Element 的 javax.swing.event 中的构造方法
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

javax.swing.plaf.basic 中 Element 的使用

参数类型为 Element 的 javax.swing.plaf.basic 中的方法
View | BasicPasswordFieldUI.create(Element elem) 创建元素的视图 (PasswordView)。
View | BasicTextAreaUI.create(Element elem) 创建元素的视图。
View | BasicTextFieldUI.create(Element elem) 基于元素创建视图 (FieldView)。
View | BasicTextUI.create(Element elem) 创建元素的视图。
View | BasicTextUI.create(Element elem, int p0, int p1) 创建元素的视图。

javax.swing.text 中 Element 的使用

实现 Element 的 javax.swing.text 中的类
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。

声明为 Element 的 javax.swing.text 中的字段
protected  Element DefaultStyledDocument.AttributeUndoableEdit.element

返回 Element 的 javax.swing.text 中的方法
Element | DefaultStyledDocument.ElementBuffer.clone(Element parent, Element clonee) 创建此元素的一个副本，使其具有不同的父级。
protected Element | AbstractDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可包含其他元素。
protected Element | AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建文档叶元素。
Element | ElementIterator.current() 获取当前 Element。
Element | ElementIterator.first() 获取第一个元素。
Element | AbstractDocument.getBidiRootElement() 返回此文档双向结构的根元素。
Element | StyledEditorKit.getCharacterAttributeRun() 获取表示该插入符处当前运行的字符属性的元素。
Element | DefaultStyledDocument.getCharacterElement(int pos) 获得基于某个位置的字符元素。
Element | StyledDocument.getCharacterElement(int pos) 获取表示文档中给定偏移量处字符的元素。
Element[] | AbstractDocument.ElementEdit.getChildrenAdded() 获得已添加的子元素列表。
Element[] | AbstractDocument.ElementEdit.getChildrenRemoved() 获得已移除的子元素列表。
Element | DefaultStyledDocument.getDefaultRootElement() 获得默认的根元素。
Element | PlainDocument.getDefaultRootElement() 获取文档模型的默认根元素。
abstract Element | AbstractDocument.getDefaultRootElement() 返回视图赖依存在的根元素，除非提供了向元素结构指派视图的其他机制。
Element | Document.getDefaultRootElement() 返回视图赖以存在的根元素，除非提供了向元素结构指定视图的其他机制。
Element | View.getElement() 获取此视图所映射的主题的结构化部分。
Element | AbstractDocument.ElementEdit.getElement() 返回基础元素。
abstract Element | AbstractDocument.AbstractElement.getElement(int index) 获取子元素。
Element | AbstractDocument.BranchElement.getElement(int index) 获得一个子元素。
Element | AbstractDocument.LeafElement.getElement(int index) 获得一个子元素。
Element | Element.getElement(int index) 获取给定索引处的子元素。
Element | DefaultStyledDocument.getParagraphElement(int pos) 获得位于偏移量 pos 的段落元素。
Element | StyledDocument.getParagraphElement(int pos) 获取表示包含文档中给定偏移量的段落的元素。
Element | PlainDocument.getParagraphElement(int pos) 获取包含给定位置的段落元素。
abstract Element | AbstractDocument.getParagraphElement(int pos) 获得包含给定位置的段落元素。
static Element | Utilities.getParagraphElement(JTextComponent c, int offs) 确定某个段落/行要使用的元素。
Element | AbstractDocument.AbstractElement.getParentElement() 获取该元素的父级。
Element | Element.getParentElement() 获得父元素。
Element | DefaultStyledDocument.ElementBuffer.getRootElement() 获得根元素。
Element[] | AbstractDocument.getRootElements() 获得已定义的所有根元素。
Element[] | Document.getRootElements() 返回定义的所有根元素。
Element | ElementIterator.next() 获取下一个 Element。
Element | AbstractDocument.BranchElement.positionToElement(int pos) 获得包含给定模型位置的子元素。
Element | ElementIterator.previous() 获取前一个 Element。

参数类型为 Element 的 javax.swing.text 中的方法
Element | DefaultStyledDocument.ElementBuffer.clone(Element parent, Element clonee) 创建此元素的一个副本，使其具有不同的父级。
View | ViewFactory.create(Element elem) 根据给定的文档的结构化元素创建一个视图。
protected Element | AbstractDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可包含其他元素。
protected void | StyledEditorKit.createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
protected Element | AbstractDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建文档叶元素。
protected TableView.TableCell | TableView.createTableCell(Element elem) 已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。
protected TableView.TableRow | TableView.createTableRow(Element elem) 创建新的表格行。
DocumentEvent.ElementChange | AbstractDocument.DefaultDocumentEvent.getChange(Element elem) 获得元素的更改。
protected String | AbstractWriter.getText(Element elem) 返回与该元素关联的文本。
protected boolean | AbstractWriter.inRange(Element next) 此方法确定当前元素是否位于指定的范围内。
void | AbstractDocument.BranchElement.replace(int offset, int length, Element[] elems) 使用新的元素集替换该内容。
protected void | AbstractWriter.text(Element elem) 写出文本。

参数类型为 Element 的 javax.swing.text 中的构造方法
AbstractDocument.AbstractElement(Element parent, AttributeSet a)
创建新的 AbstractElement。
AbstractDocument.BranchElement(Element parent, AttributeSet a)
构造最初不包含任何子元素的复合元素。
AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
构造一个编辑记录。
AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
构造一个编辑记录。
AbstractDocument.ElementEdit(Element e, int index, Element[] removed, Element[] added)
构造一个编辑记录。
AbstractDocument.LeafElement(Element parent, AttributeSet a, int offs0, int offs1)
构造一个表示文档中内容的元素（没有子元素）。
AbstractWriter(Writer w, Element root)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Element root, int pos, int len)
创建新的 AbstractWriter。
AsyncBoxView(Element elem, int axis)
构造执行异步布局处理的 BoxView。
BoxView(Element elem, int axis)
构造一个 BoxView。
ComponentView(Element elem)
创建新的 ComponentView 对象。
CompositeView(Element elem)
为给定元素构造一个 CompositeView。
DefaultStyledDocument.AttributeUndoableEdit(Element element, AttributeSet newAttributes, boolean isReplacing)
DefaultStyledDocument.ElementBuffer(Element root)
创建新的 ElementBuffer。
ElementIterator(Element root)
创建新的 ElementIterator。
FieldView(Element elem)
构造包装了元素的新 FieldView。
FlowView(Element elem, int axis)
构造给定元素的 FlowView。
GlyphView(Element elem)
构造在元素上包装的新视图。
IconView(Element elem)
创建表示元素的新图标视图。
LabelView(Element elem)
构造在元素上包装的新视图。
ParagraphView(Element elem)
创建给定元素的 ParagraphView。
PasswordView(Element elem)
构造在元素上包装的新视图。
PlainView(Element elem)
构造在元素上包装的新 PlainView。
TableView.TableCell(Element elem)
已过时。 构造给定元素的 TableCell。
TableView.TableRow(Element elem)
构造给定元素的 TableView。
TableView(Element elem)
针对给定的元素构造一个 TableView。
View(Element elem)
创建一个新的 View 对象。
WrappedPlainView(Element elem)
创建一个新的 WrappedPlainView。
WrappedPlainView(Element elem, boolean wordWrap)
创建一个新的 WrappedPlainView。
ZoneView(Element elem, int axis)
构造一个 ZoneView。

javax.swing.text.html 中 Element 的使用

实现 Element 的 javax.swing.text.html 中的类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

返回 Element 的 javax.swing.text.html 中的方法
protected Element | HTMLDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可以包含其他元素。
protected Element | HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建直接表示文本的文档叶元素（没有任何子级）。
protected Element | HTMLEditorKit.HTMLTextAction.findElementMatchingTag(HTMLDocument doc, int offset, HTML.Tag tag) 返回在 offset 处与 tag 匹配的最深的元素。
Element | HTMLDocument.getElement(Element e, Object attribute, Object value) 返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。
Element | HTMLDocument.getElement(String id) 返回具有给定 id Attribute 的元素。
protected Element[] | HTMLEditorKit.HTMLTextAction.getElementsAt(HTMLDocument doc, int offset) 返回包含 offset 的 Elements 数组。

参数类型为 Element 的 javax.swing.text.html 中的方法
protected void | HTMLWriter.comment(Element elem) 写出注释。
View | HTMLEditorKit.HTMLFactory.create(Element elem) 根据元素创建视图。
protected Element | HTMLDocument.createBranchElement(Element parent, AttributeSet a) 创建文档分支元素，它可以包含其他元素。
protected void | HTMLEditorKit.createInputAttributes(Element element, MutableAttributeSet set) 将 element 的 AttributeSet 键/值复制到 set 中。
protected Element | HTMLDocument.createLeafElement(Element parent, AttributeSet a, int p0, int p1) 创建直接表示文本的文档叶元素（没有任何子级）。
protected void | HTMLWriter.emptyTag(Element elem) 写出所有空元素（没有对应结束标记的所有标记）。
protected void | HTMLWriter.endTag(Element elem) 写出元素的结束标记。
Element | HTMLDocument.getElement(Element e, Object attribute, Object value) 返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。
Style | StyleSheet.getRule(HTML.Tag t, Element e) 获取用来呈现给定类型的 HTML 标记的样式。
void | HTMLDocument.insertAfterEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之后。
void | HTMLDocument.insertAfterStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的起始处。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
void | HTMLDocument.insertBeforeEnd(Element elem, String htmlText) 将指定为字符串的 HTML 插入元素的结尾处。
void | HTMLDocument.insertBeforeStart(Element elem, String htmlText) 将指定为字符串的 HTML 插入给定元素的起始处之前。
protected boolean | MinimalHTMLWriter.isText(Element elem) 如果元素是文本元素，则返回 true。
void | HTMLDocument.setInnerHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换给定元素的子元素。
void | HTMLDocument.setOuterHTML(Element elem, String htmlText) 用指定为 HTML 字符串的内容替换父元素中的给定元素。
protected void | HTMLWriter.startTag(Element elem) 写出元素的开始标记。
protected boolean | HTMLWriter.synthesizedElement(Element elem) 如果元素是合成元素，则返回 true。
protected void | HTMLWriter.text(Element elem) 写出文本。
protected void | MinimalHTMLWriter.text(Element elem) 写出文本。
protected void | MinimalHTMLWriter.writeComponent(Element elem) 负责处理 Component Elements；有意不实现它。
protected void | MinimalHTMLWriter.writeContent(Element elem, boolean needsIndenting) 以与 HTML 兼容的方式写出属性集。
protected void | MinimalHTMLWriter.writeImage(Element elem) 负责处理 Icon Elements；有意不实现它。
protected void | MinimalHTMLWriter.writeLeaf(Element elem) 负责写出其他非文本叶元素。
protected void | MinimalHTMLWriter.writeStartParagraph(Element elem) 发出段落的开始标记。

参数类型为 Element 的 javax.swing.text.html 中的构造方法
BlockView(Element elem, int axis)
创建表示 html 框的新视图。
FormView(Element elem)
创建新的 FormView 对象。
HTMLDocument.BlockElement(Element parent, AttributeSet a)
构造初始不包含子元素的复合元素。
HTMLDocument.RunElement(Element parent, AttributeSet a, int offs0, int offs1)
构造表示文档内部（没有子级）内容的元素。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
ImageView(Element elem)
创建表示 IMG 元素的新视图。
InlineView(Element elem)
构造在元素上包装的新视图。
ListView(Element elem)
创建表示列表元素的新视图。
ObjectView(Element elem)
创建新的 ObjectView 对象。
ParagraphView(Element elem)
构造给定元素的 ParagraphView。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AbstractLayoutCache (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 AbstractLayoutCache

java.lang.Object
    继承者  javax.swing.tree.AbstractLayoutCache
所有已实现的接口：
RowMapper
直接已知子类：
FixedHeightLayoutCache, VariableHeightLayoutCache
public abstract class AbstractLayoutCache
extends Object
implements RowMapper

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
static class AbstractLayoutCache.NodeDimensions
由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。
字段摘要
protected AbstractLayoutCache.NodeDimensions | nodeDimensions 负责获取节点大小的对象。
protected boolean | rootVisible 如果显示根节点，则为 True，如果其子节点是最高可视节点，则为 false。
protected int | rowHeight 每行的高度。
protected TreeModel | treeModel 提供信息的模型。
protected TreeSelectionModel | treeSelectionModel 选择模型。
构造方法摘要
AbstractLayoutCache()
方法摘要
abstract Rectangle | getBounds(TreePath path, Rectangle placeIn) 返回一个矩形，该矩形给出了绘制路径所需的 bounds。
abstract boolean | getExpandedState(TreePath path) 如果路径已扩展并且可视，则返回 true。
TreeModel | getModel() 返回要提供数据的 TreeModel。
AbstractLayoutCache.NodeDimensions | getNodeDimensions() 返回呈现树中节点的对象，它负责计算各个节点的尺寸。
protected Rectangle | getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn) 返回通过 placeIn 中的引用，表示 value 所需的大小。
abstract TreePath | getPathClosestTo(int x, int y) 返回最接近 x,y 节点的路径。
abstract TreePath | getPathForRow(int row) 返回传入行的路径。
int | getPreferredHeight() 返回首选高度。
int | getPreferredWidth(Rectangle bounds) 返回传入区域的首选宽度。
abstract int | getRowCount() 显示的行数。
abstract int | getRowForPath(TreePath path) 返回其路径中标识的最后一项可视的行。
int | getRowHeight() 返回每行高度。
int[] | getRowsForPaths(TreePath[] paths) 返回在其中显示 path 中 TreePath 实例的行。
TreeSelectionModel | getSelectionModel() 返回用于维护该选择的模型。
abstract int | getVisibleChildCount(TreePath path) 返回行的可视子节点数。
abstract Enumeration<TreePath> | getVisiblePathsFrom(TreePath path) 返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。
abstract void | invalidatePathBounds(TreePath path) 指示 LayoutCache，path 的边界无效，需要进行更新。
abstract void | invalidateSizes() 通知 TreeState 需要重新计算它引用的所有大小。
abstract boolean | isExpanded(TreePath path) 如果当前扩展了由行标识的值，则返回 true。
protected boolean | isFixedRowHeight() 如果每行的高度为固定大小，则返回 true。
boolean | isRootVisible() 如果显示树的根节点，则返回 true。
abstract void | setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的已扩展状态标记为 isExpanded。
void | setModel(TreeModel newModel) 设置将提供数据的 TreeModel。
void | setNodeDimensions(AbstractLayoutCache.NodeDimensions nd) 设置负责绘制树中节点的 renderer，因此，它还负责计算各个节点的尺寸。
void | setRootVisible(boolean rootVisible) 确定 TreeModel 的根节点是否可视。
void | setRowHeight(int rowHeight) 设置每个单元的高度。
void | setSelectionModel(TreeSelectionModel newLSM) 将用于管理选择的 TreeSelectionModel 设置为新的 LSM。
abstract void | treeNodesChanged(TreeModelEvent e) 在某个节点（或一组兄弟节点）以某种方式更改后进行调用。
abstract void | treeNodesInserted(TreeModelEvent e) 将节点插入树之后进行调用。
abstract void | treeNodesRemoved(TreeModelEvent e) 将节点从树移除之后进行调用。
abstract void | treeStructureChanged(TreeModelEvent e) 树彻底更改给定节点以下的结构之后进行调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

nodeDimensions

protected AbstractLayoutCache.NodeDimensions nodeDimensions
负责获取节点大小的对象。

treeModel

protected TreeModel treeModel
提供信息的模型。

treeSelectionModel

protected TreeSelectionModel treeSelectionModel
选择模型。

rootVisible

protected boolean rootVisible
如果显示根节点，则为 True，如果其子节点是最高可视节点，则为 false。

rowHeight

protected int rowHeight
每行的高度。如果高度 <= 0，则使用 renderer 来确定每行高度。

构造方法详细信息

AbstractLayoutCache

public AbstractLayoutCache()
方法详细信息

setNodeDimensions

public void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
设置负责绘制树中节点的 renderer，因此，它还负责计算各个节点的尺寸。

参数：
nd - NodeDimensions 对象

getNodeDimensions

public AbstractLayoutCache.NodeDimensions getNodeDimensions()
返回呈现树中节点的对象，它负责计算各个节点的尺寸。

返回：
NodeDimensions 对象

setModel

public void setModel(TreeModel newModel)
设置将提供数据的 TreeModel。

参数：
newModel - 将提供数据的 TreeModel

getModel

public TreeModel getModel()
返回要提供数据的 TreeModel。

返回：
要提供数据的 TreeModel

setRootVisible

public void setRootVisible(boolean rootVisible)
确定 TreeModel 的根节点是否可视。

参数：
rootVisible - 如果要显示树的根节点，则为 true
另请参见：
rootVisible

isRootVisible

public boolean isRootVisible()
如果显示树的根节点，则返回 true。

返回：
如果显示树的根节点，则返回 true
另请参见：
rootVisible

setRowHeight

public void setRowHeight(int rowHeight)
设置每个单元的高度。如果指定值小于或等于零，则查询当前单元 renderer，以获取每行高度。

参数：
rowHeight - 每个单元的高度（以像素为单位）

getRowHeight

public int getRowHeight()
返回每行高度。如果返回值小于或等于 0，则每行的高度由 renderer 确定。

setSelectionModel

public void setSelectionModel(TreeSelectionModel newLSM)
将用于管理选择的 TreeSelectionModel 设置为新的 LSM。

参数：
newLSM - 新的 TreeSelectionModel

getSelectionModel

public TreeSelectionModel getSelectionModel()
返回用于维护该选择的模型。

返回：
treeSelectionModel

getPreferredHeight

public int getPreferredHeight()
返回首选高度。

返回：
首选高度

getPreferredWidth

public int getPreferredWidth(Rectangle bounds)
返回传入区域的首选宽度。该区域由最接近 (bounds.x, bounds.y) 的路径定义，并在 bounds.height + bounds.y 结束。如果 bounds 为 null，则返回所有节点的首选宽度（这可能是开销很大的计算）。

参数：
bounds - 被查询的区域
返回：
传入区域的首选宽度

isExpanded

public abstract boolean isExpanded(TreePath path)
如果当前扩展了由行标识的值，则返回 true。

getBounds

public abstract Rectangle getBounds(TreePath path,
                                    Rectangle placeIn)
返回一个矩形，该矩形给出了绘制路径所需的 bounds。

参数：
path - 指定节点的 TreePath
placeIn - 提供可用空间的 Rectangle 对象
返回：
指定要使用的空间的 Rectangle 对象

getPathForRow

public abstract TreePath getPathForRow(int row)
返回传入行的路径。如果该行不可视，则返回 null。

参数：
row - 查询的行
返回：
给定的行的 TreePath

getRowForPath

public abstract int getRowForPath(TreePath path)
返回其路径中标识的最后一项可视的行。如果路径中任何元素当前不可视，则返回 -1。

参数：
path - 查询的 TreePath
返回：
路径中最后一项可视的行，如果路径中任何元素当前不可视，则返回 -1

getPathClosestTo

public abstract TreePath getPathClosestTo(int x,
                                          int y)
返回最接近 x,y 节点的路径。如果当前不存在任何可视内容，则返回 null，否则，始终返回一个有效路径。如果需要测试返回的对象是否正好位于 x, y，您应获取返回路径的 bounds，并根据它测试 x, y。

参数：
x - 所需位置的水平组件
y - 所需位置的垂直组件
返回：
最接近指定点的 TreePath

getVisiblePathsFrom

public abstract Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。该枚举的排序取决于路径显示的方式。如果所返回枚举的第一个元素是可视的，则它是路径，如果第一个元素是不可视的，将返回 null。

参数：
path - 枚举的起始位置
返回：
在所需位置开始的 Enumerator

getVisibleChildCount

public abstract int getVisibleChildCount(TreePath path)
返回行的可视子节点数。

参数：
path - 正被查询的路径
返回：
指定路径的可视子节点数

setExpandedState

public abstract void setExpandedState(TreePath path,
                                      boolean isExpanded)
将路径 path 的已扩展状态标记为 isExpanded。

参数：
path - 正在被扩展或折叠的路径
isExpanded - 如果应该扩展路径，则为 true，否则为 false

getExpandedState

public abstract boolean getExpandedState(TreePath path)
如果路径已扩展并且可视，则返回 true。

参数：
path - 正在被查询的路径
返回：
如果路径已扩展并且可视，则返回 true，否则返回 false

getRowCount

public abstract int getRowCount()
显示的行数。

返回：
显示的行数

invalidateSizes

public abstract void invalidateSizes()
通知 TreeState 需要重新计算它引用的所有大小。

invalidatePathBounds

public abstract void invalidatePathBounds(TreePath path)
指示 LayoutCache，path 的边界无效，需要进行更新。

参数：
path - 正在被更新的路径

treeNodesChanged

public abstract void treeNodesChanged(TreeModelEvent e)

在某个节点（或一组兄弟节点）以某种方式更改后进行调用。节点没有更改在树中的位置，也没有改变他们的子节点的数组，但是其他属性已更改，并且可能影响表示形式。示例：文件的名称已更改，但是它仍然位于文件系统中的同一位置。

e.path() 返回已更改节点的父节点的路径。

e.childIndices() 返回更改节点的索引。

参数：
e - TreeModelEvent

treeNodesInserted

public abstract void treeNodesInserted(TreeModelEvent e)

将节点插入树之后进行调用。

e.path() 返回新节点的父节点

e.childIndices() 按升序返回新节点的索引。

参数：
e - TreeModelEvent

treeNodesRemoved

public abstract void treeNodesRemoved(TreeModelEvent e)

将节点从树移除之后进行调用。注意，如果从该树移除子树，则对于移除的子树的根而言，此方法仅调用一次，而对于移除的每个兄弟子树集而言，则不是一次。

e.path() 返回节点在删除之前的父节点。

e.childIndices() 返回节点按升序删除之前的索引。

参数：
e - TreeModelEvent

treeStructureChanged

public abstract void treeStructureChanged(TreeModelEvent e)

树彻底更改给定节点以下的结构之后进行调用。如果 e.getPath() 返回的路径长度为一，并且第一个元素不标识当前的根节点，则第一个元素应成为树的新根。

e.path() 保持节点的路径。

e.childIndices() 返回 null。

参数：
e - TreeModelEvent

getRowsForPaths

public int[] getRowsForPaths(TreePath[] paths)
返回在其中显示 path 中 TreePath 实例的行。此方法应返回与传入数组长度相同的数组，如果 path 中的某个 TreePaths 无效，则应将它在该数组中的条目设置为 -1。

指定者：
接口 RowMapper 中的 getRowsForPaths
参数：
paths - 正被查询的 TreePath 的数组
返回：
传入的同一长度的数组，包含在其中显示每个 TreePath 的每个相应行；如果 paths 为 null，则返回 null

getNodeDimensions

protected Rectangle getNodeDimensions(Object value,
                                      int row,
                                      int depth,
                                      boolean expanded,
                                      Rectangle placeIn)
返回通过 placeIn 中的引用，表示 value 所需的大小。如果 inPlace 为 null，则应返回新创建的 Rectangle，否则将该值放置在 inPlace 中，并返回它。如果不存在 renderer，这将返回 null。

参数：
value - 要表示的 value
row - 查询的行
depth - 行的深度
expanded - 如果行已扩展，则为 true，否则为 false
placeIn - 包含表示 value 所需大小的 Rectangle
返回：
包含节点尺寸的 Rectangle，如果节点没有尺寸，则返回 null

isFixedRowHeight

protected boolean isFixedRowHeight()
如果每行的高度为固定大小，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AbstractLayoutCache.NodeDimensions (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 AbstractLayoutCache.NodeDimensions

java.lang.Object
    继承者  javax.swing.tree.AbstractLayoutCache.NodeDimensions
直接已知子类：
BasicTreeUI.NodeDimensionsHandler
正在封闭类：
AbstractLayoutCache
public abstract static class AbstractLayoutCache.NodeDimensions
extends Object

由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。

构造方法摘要
AbstractLayoutCache.NodeDimensions()
方法摘要
abstract  Rectangle getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds)
通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractLayoutCache.NodeDimensions

public AbstractLayoutCache.NodeDimensions()
方法详细信息

getNodeDimensions

public abstract Rectangle getNodeDimensions(Object value,
                                            int row,
                                            int depth,
                                            boolean expanded,
                                            Rectangle bounds)
通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。调用方法负责确定 Y 坐标。如果 bounds 为 null，则返回新创建的 Rectangle，否则，将该值保存在 bounds 中，并返回该值。

参数：
value - 要表示的 value
row - 查询的行
depth - 行的深度
expanded - 如果行已扩展，则为 true，否则为 false
bounds - 包含表示 value 所需大小的 Rectangle
返回：
包含节点尺寸的 Rectangle，如果节点没有尺寸，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultMutableTreeNode (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 DefaultMutableTreeNode

java.lang.Object
    继承者  javax.swing.tree.DefaultMutableTreeNode
所有已实现的接口：
Serializable, Cloneable, MutableTreeNode, TreeNode
直接已知子类：
JTree.DynamicUtilTreeNode
public class DefaultMutableTreeNode
extends Object
implements Cloneable, MutableTreeNode, Serializable

DefaultMutableTreeNode 是树数据结构中的通用节点。有关使用默认可变树节点的示例，请参阅 The Java Tutorial 中的 How to Use Trees 一节。

一个树节点最多可以有一个父节点、0 或多个子节点。DefaultMutableTreeNode 为检查和修改节点的父节点和子节点提供操作，也为检查节点所属的树提供操作。节点的树是所有节点的集合，通过从某一节点开始并沿着父节点和子节点的所有可能的链接，可以访问这些节点。不带父节点的节点是树的根；不带子节点的节点是叶节点。树可以由许多子树组成，每个节点充当自已的子树的根。

此类提供按各种顺序有效地遍历树或子树，或者沿着两节点间的路径进行遍历的枚举。DefaultMutableTreeNode 还可以保存对用户对象的引用，用户对象由用户使用。通过 toString() 请求 DefaultMutableTreeNode 的字符串表示形式将返回其用户对象的字符串表示形式。

这不是一个线程安全的类。如果打算在多个线程中使用 DefaultMutableTreeNode（或 TreeNodes 的树），则需要执行自己的同步。要采用的较好惯例是在树的根节点上进行同步。

尽管 DefaultMutableTreeNode 实现 MutableTreeNode 接口，并允许您将其添加到 MutableTreeNode 的任何实现中，但是并不是 DefaultMutableTreeNode 中的所有方法都将适用于所有的 MutableTreeNodes 实现。特别是通过提供的一些枚举，使用其中一些方法，我们假定 DefaultMutableTreeNode 只包含 DefaultMutableNode 实例。无论添加什么实现，所有的 TreeNode/MutableTreeNode 方法都将表现出定义的行为。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
MutableTreeNode

字段摘要
protected boolean | allowsChildren 如果该节点可以有子节点，则为 true
protected Vector | children 子节点的数组，如果此节点没有子节点，则可以为 null
static Enumeration<TreeNode> | EMPTY_ENUMERATION 始终为空的枚举。
protected MutableTreeNode | parent 此节点的父节点，如果此节点没有父节点，则为 null
protected Object | userObject 可选用户对象
构造方法摘要
DefaultMutableTreeNode()
创建没有父节点和子节点的树节点，该树节点允许有子节点。
DefaultMutableTreeNode(Object userObject)
创建没有父节点和子节点、但允许有子节点的树节点，并使用指定的用户对象对它进行初始化。
DefaultMutableTreeNode(Object userObject, boolean allowsChildren)
创建没有父节点和子节点的树节点，使用指定的用户对象对它进行初始化，仅在指定时才允许有子节点。
方法摘要
 void add(MutableTreeNode newChild)
从其父节点移除 newChild，并通过将其添加到此节点的子数组的结尾，使其成为此节点的子节点。
 Enumeration breadthFirstEnumeration()
创建并返回一个枚举，该枚举按广度优先的顺序遍历以此节点为根的子树。
 Enumeration children()
创建并返回此节点的子节点的正向枚举。
 Object clone()
重写以复制 public。
 Enumeration depthFirstEnumeration()
创建并返回一个枚举，该枚举按深度优先的顺序遍历以此节点为根的子树。
 boolean getAllowsChildren()
如果允许此节点拥有子节点，则返回 true。
 TreeNode getChildAfter(TreeNode aChild)
返回此节点的子节点数组中刚好跟在 aChild 之后的子节点，它必须是此节点的子节点。
 TreeNode getChildAt(int index)
返回此节点的子节点数组中指定索引处的子节点。
 TreeNode getChildBefore(TreeNode aChild)
返回此节点的子节点数组中刚好在 aChild 之前的子节点，它必须是此节点的子节点。
 int getChildCount()
返回此节点的子节点数。
 int getDepth()
返回以此节点为根的树的深度 -- 从此节点到叶节点的最长距离。
 TreeNode getFirstChild()
返回此节点的第一个子节点。
 DefaultMutableTreeNode getFirstLeaf()
查找并返回为此节点后代的第一个叶节点，即此节点或其第一个子节点的第一个叶节点。
 int getIndex(TreeNode aChild)
返回此节点的子节点数组中指定子节点的索引。
 TreeNode getLastChild()
返回此节点的最后一个子节点。
 DefaultMutableTreeNode getLastLeaf()
查找并返回为此节点后代的最后一个叶节点，即此节点或其最后一个子节点的最后一个叶节点。
 int getLeafCount()
返回为此节点后代的叶节点总数。
 int getLevel()
返回此节点上的级数 -- 从根到此节点的距离。
 DefaultMutableTreeNode getNextLeaf()
返回此节点后面的叶节点，如果此节点是树中的最后一个叶节点，则返回 null。
 DefaultMutableTreeNode getNextNode()
返回在此节点的树的前序遍历中此节点之后的节点。
 DefaultMutableTreeNode getNextSibling()
返回父节点的子节点数组中此节点的下一个兄弟节点。
 TreeNode getParent()
返回此节点的父节点，如果此节点没有父节点，则返回 null。
 TreeNode[] getPath()
返回从根到达此节点的路径。
protected  TreeNode[] getPathToRoot(TreeNode aNode, int depth)
构建节点的父节点一直到根节点（包括根节点），其中源节点是返回数组中的最后一个元素。
 DefaultMutableTreeNode getPreviousLeaf()
返回此节点之前的叶节点，如果此节点是树中的第一个叶节点，则返回 null。
 DefaultMutableTreeNode getPreviousNode()
返回在此节点树的前序遍历中此节点之前的节点。
 DefaultMutableTreeNode getPreviousSibling()
返回父节点的子节点数组中此节点的前一个兄弟节点。
 TreeNode getRoot()
返回包含此节点的树的根。
 TreeNode getSharedAncestor(DefaultMutableTreeNode aNode)
返回此节点和 aNode 最近的共同祖先。
 int getSiblingCount()
返回此节点的兄弟节点数。
 Object getUserObject()
返回此节点的用户对象。
 Object[] getUserObjectPath()
返回从根到达此节点的路径。
 void insert(MutableTreeNode newChild, int childIndex)
从其现有父节点移除 newChild（如果它有父节点），将子节点的父节点设置为此节点，然后，将该子节点添加到此节点位于索引 childIndex 处的子节点数组。
 boolean isLeaf()
如果此节点没有子节点，则返回 true。
 boolean isNodeAncestor(TreeNode anotherNode)
如果 anotherNode 是此节点的祖先 -- 如果它是此节点、此节点的父节点或此节点的父节点的祖先，则返回 true。
 boolean isNodeChild(TreeNode aNode)
如果 aNode 是此节点的子节点，则返回 true。
 boolean isNodeDescendant(DefaultMutableTreeNode anotherNode)
如果 anotherNode 是此节点的后代 -- 如果它是此节点、此节点的一个子节点或此节点的一个子节点的后代，则返回 true。
 boolean isNodeRelated(DefaultMutableTreeNode aNode)
当且仅当 aNode 位于与此节点相同的树中时，返回 true。
 boolean isNodeSibling(TreeNode anotherNode)
如果 anotherNode 是此节点的兄弟节点（与此节点共享同一父节点），则返回 true。
 boolean isRoot()
如果此节点是树的根，则返回 true。
 Enumeration pathFromAncestorEnumeration(TreeNode ancestor)
创建并返回沿着从 ancestor 到此节点的路径的一个枚举。
 Enumeration postorderEnumeration()
创建并返回按后序遍历以此节点为根的树的一个枚举。
 Enumeration preorderEnumeration()
创建并返回按前序遍历以此节点为根的子树的一个枚举。
 void remove(int childIndex)
从此节点的子节点中移除指定索引处的子节点，并将该节点的父节点设置为 null。
 void remove(MutableTreeNode aChild)
通过向其提供一个 null 父节点，从此节点的子节点数组移除 aChild。
 void removeAllChildren()
通过将其父节点设置为 null，移除此节点的所有子节点。
 void removeFromParent()
通过向此节点提供一个 null 父节点，从树中移除以此节点为根的子树。
 void setAllowsChildren(boolean allows)
确定是否允许此节点拥有子节点。
 void setParent(MutableTreeNode newParent)
将此节点的父节点设置为 newParent，但不更改父节点的子节点数组。
 void setUserObject(Object userObject)
将此节点的用户对象设置为 userObject。
 String toString()
返回将 toString() 发送到此节点的用户对象的结果，如果此节点没有用户对象，则返回 null。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

EMPTY_ENUMERATION

public static final Enumeration<TreeNode> EMPTY_ENUMERATION
始终为空的枚举。当请求叶节点的子节点的枚举时使用它。

parent

protected MutableTreeNode parent
此节点的父节点，如果此节点没有父节点，则为 null

children

protected Vector children
子节点的数组，如果此节点没有子节点，则可以为 null

userObject

protected transient Object userObject
可选用户对象

allowsChildren

protected boolean allowsChildren
如果该节点可以有子节点，则为 true

构造方法详细信息

DefaultMutableTreeNode

public DefaultMutableTreeNode()
创建没有父节点和子节点的树节点，该树节点允许有子节点。

DefaultMutableTreeNode

public DefaultMutableTreeNode(Object userObject)
创建没有父节点和子节点、但允许有子节点的树节点，并使用指定的用户对象对它进行初始化。

参数：
userObject - 用户提供的 Object，它构成节点的数据

DefaultMutableTreeNode

public DefaultMutableTreeNode(Object userObject,
                              boolean allowsChildren)
创建没有父节点和子节点的树节点，使用指定的用户对象对它进行初始化，仅在指定时才允许有子节点。

参数：
userObject - 用户提供的 Object，它构成该节点的数据
allowsChildren - 如果为 true，则允许该节点有子节点，否则它始终为一个叶节点
方法详细信息

insert

public void insert(MutableTreeNode newChild,
                   int childIndex)
从其现有父节点移除 newChild（如果它有父节点），将子节点的父节点设置为此节点，然后，将该子节点添加到此节点位于索引 childIndex 处的子节点数组。newChild 不能为 null，也不能为此节点的祖先。

指定者：
接口 MutableTreeNode 中的 insert
参数：
newChild - 在此节点下插入的 MutableTreeNode
childIndex - 此节点的子节点数组中的索引，它是此节点插入的位置
抛出：
ArrayIndexOutOfBoundsException - 如果 childIndex 超出边界
IllegalArgumentException - 如果 newChild 为 null，或者是此节点的祖先
IllegalStateException - 如果此节点不允许有子节点
另请参见：
isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

remove

public void remove(int childIndex)
从此节点的子节点中移除指定索引处的子节点，并将该节点的父节点设置为 null。要移除的子节点必须是 MutableTreeNode。

指定者：
接口 MutableTreeNode 中的 remove
参数：
childIndex - 要移除的此节点的子节点数组中子节点的索引
抛出：
ArrayIndexOutOfBoundsException - 如果 childIndex 超出边界

setParent

public void setParent(MutableTreeNode newParent)
将此节点的父节点设置为 newParent，但不更改父节点的子节点数组。从 insert() 和 remove() 调用此方法，以重新分配子节点的父节点，而不应从其他任何地方向它传递消息。

指定者：
接口 MutableTreeNode 中的 setParent
参数：
newParent - 此节点的新父节点

getParent

public TreeNode getParent()
返回此节点的父节点，如果此节点没有父节点，则返回 null。

指定者：
接口 TreeNode 中的 getParent
返回：
此节点的父 TreeNode，如果此节点没有父节点，则返回 null

getChildAt

public TreeNode getChildAt(int index)
返回此节点的子节点数组中指定索引处的子节点。

指定者：
接口 TreeNode 中的 getChildAt
参数：
index - 此节点的子节点数组中的一个索引
返回：
此节点的子节点数组中指定索引处的 TreeNode
抛出：
ArrayIndexOutOfBoundsException - 如果 index 超出边界

getChildCount

public int getChildCount()
返回此节点的子节点数。

指定者：
接口 TreeNode 中的 getChildCount
返回：
提供此节点的子节点数的 int

getIndex

public int getIndex(TreeNode aChild)
返回此节点的子节点数组中指定子节点的索引。如果指定节点不是此节点的子节点，则返回 -1。此方法执行线性搜索，该方法花费时间为 O(n)，其中 n 表示子节点数。

指定者：
接口 TreeNode 中的 getIndex
参数：
aChild - 要在此节点的子节点中搜索的 TreeNode
返回：
提供此节点的子节点数组中节点索引的 int，如果指定的节点不是此节点的子节点，则返回 -1
抛出：
IllegalArgumentException - 如果 aChild 为 null

children

public Enumeration children()
创建并返回此节点的子节点的正向枚举。修改此节点的子节点数组会使修改前创建的任何子节点枚举无效。

指定者：
接口 TreeNode 中的 children
返回：
此节点的子节点 Enumeration

setAllowsChildren

public void setAllowsChildren(boolean allows)
确定是否允许此节点拥有子节点。如果 allows 为 false，则移除此节点的所有子节点。

注：默认情况下，节点允许有子节点。

参数：
allows - 如果允许此节点拥有子节点，则为 true

getAllowsChildren

public boolean getAllowsChildren()
如果允许此节点拥有子节点，则返回 true。

指定者：
接口 TreeNode 中的 getAllowsChildren
返回：
如果此节点允许拥有子节点，则返回 true，否则返回 false

setUserObject

public void setUserObject(Object userObject)
将此节点的用户对象设置为 userObject。

指定者：
接口 MutableTreeNode 中的 setUserObject
参数：
userObject - 构成此节点的用户指定数据的 Object
另请参见：
getUserObject(), toString()

getUserObject

public Object getUserObject()
返回此节点的用户对象。

返回：
用户存储在此节点的 Object
另请参见：
setUserObject(java.lang.Object), toString()

removeFromParent

public void removeFromParent()
通过向此节点提供一个 null 父节点，从树中移除以此节点为根的子树。如果此节点是其树的根，则不执行任何操作。

指定者：
接口 MutableTreeNode 中的 removeFromParent

remove

public void remove(MutableTreeNode aChild)
通过向其提供一个 null 父节点，从此节点的子节点数组移除 aChild。

指定者：
接口 MutableTreeNode 中的 remove
参数：
aChild - 要移除的此节点的子节点
抛出：
IllegalArgumentException - 如果 aChild 为 null，或者不是此节点的子节点

removeAllChildren

public void removeAllChildren()
通过将其父节点设置为 null，移除此节点的所有子节点。如果此节点没有子节点，则此方法不执行任何操作。

add

public void add(MutableTreeNode newChild)
从其父节点移除 newChild，并通过将其添加到此节点的子数组的结尾，使其成为此节点的子节点。

参数：
newChild - 作为此节点的子节点添加的节点
抛出：
IllegalArgumentException - 如果 newChild 为 null
IllegalStateException - 如果此节点不允许拥有子节点
另请参见：
insert(javax.swing.tree.MutableTreeNode, int)

isNodeAncestor

public boolean isNodeAncestor(TreeNode anotherNode)
如果 anotherNode 是此节点的祖先 -- 如果它是此节点、此节点的父节点或此节点的父节点的祖先，则返回 true。（注意，节点被认为是它本身的祖先。）如果 anotherNode 为 null，则此方法返回 false。此操作至少花费时间 O(h)，其中 h 表示根到此节点的距离。

参数：
anotherNode - 测试是否为此节点的祖先的节点
返回：
如果此节点是 anotherNode 的后代，则返回 true
另请参见：
isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode), getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode)

isNodeDescendant

public boolean isNodeDescendant(DefaultMutableTreeNode anotherNode)
如果 anotherNode 是此节点的后代 -- 如果它是此节点、此节点的一个子节点或此节点的一个子节点的后代，则返回 true。注意，节点被认为是它本身的后代。如果 anotherNode 为 null，则返回 false。此操作至少花费时间 O(h)，其中 h 表示根到 anotherNode 的距离。

参数：
anotherNode - 测试是否为此节点的后代的节点
返回：
如果此节点是 anotherNode 的祖先，则返回 true
另请参见：
isNodeAncestor(javax.swing.tree.TreeNode), getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode)

getSharedAncestor

public TreeNode getSharedAncestor(DefaultMutableTreeNode aNode)
返回此节点和 aNode 最近的共同祖先。如果不存在这样的祖先 -- 如果此节点和 aNode 位于不同的树中，或者 aNode 为 null，则返回 null。节点被认为是它本身的祖先。

参数：
aNode - 查找其共同祖先的节点
返回：
此节点和 aNode 最近的共同祖先，如果没有，则返回 null
另请参见：
isNodeAncestor(javax.swing.tree.TreeNode), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

isNodeRelated

public boolean isNodeRelated(DefaultMutableTreeNode aNode)
当且仅当 aNode 位于与此节点相同的树中时，返回 true。如果 aNode 为 null，则返回 false。

返回：
如果 aNode 位于与此节点相同的树中，则返回 true；如果 aNode 为 null，则返回 false
另请参见：
getSharedAncestor(javax.swing.tree.DefaultMutableTreeNode), getRoot()

getDepth

public int getDepth()
返回以此节点为根的树的深度 -- 从此节点到叶节点的最长距离。如果此节点没有子节点，则返回 0。此操作的开销远大于 getLevel()，因为它必须有效地遍历以此节点为根的整棵树。

返回：
以此节点为根的树的深度
另请参见：
getLevel()

getLevel

public int getLevel()
返回此节点上的级数 -- 从根到此节点的距离。如果此节点为根，则返回 0。

返回：
此节点上的级数
另请参见：
getDepth()

getPath

public TreeNode[] getPath()
返回从根到达此节点的路径。该路径中最后一个元素是此节点。

返回：
提供了路径的 TreeNode 对象组成的数组，其中此路径中的第一个元素是根，最后一个元素是此节点。

getPathToRoot

protected TreeNode[] getPathToRoot(TreeNode aNode,
                                   int depth)
构建节点的父节点一直到根节点（包括根节点），其中源节点是返回数组中的最后一个元素。返回的数组长度给出了树中节点的深度。

参数：
aNode - 获取其路径的 TreeNode
depth - 提供朝根的方向（通过递归调用）执行的步骤数的 int，用于衡量返回的数组的大小
返回：
提供从根到指定节点的路径的 TreeNodes 组成的数组。

getUserObjectPath

public Object[] getUserObjectPath()
返回从根到达此节点的路径。如果路径中某些 TreeNodes 的用户对象为 null ，则返回的路径将包含 null。

getRoot

public TreeNode getRoot()
返回包含此节点的树的根。根是所有节点的祖先，其父节点为 null。

返回：
包含此节点的树的根
另请参见：
isNodeAncestor(javax.swing.tree.TreeNode)

isRoot

public boolean isRoot()
如果此节点是树的根，则返回 true。根是树中父节点为 null 的惟一节点；每棵树只有一个根。

返回：
如果此节点是树的根，则返回 true

getNextNode

public DefaultMutableTreeNode getNextNode()
返回在此节点的树的前序遍历中此节点之后的节点。如果此节点是该遍历中的最后一个节点，则返回 null。这是遍历整棵树的一种低效方式；请改用枚举。

返回：
前序遍历中此节点之后的节点，如果此节点是最后一个节点，则返回 null
另请参见：
preorderEnumeration()

getPreviousNode

public DefaultMutableTreeNode getPreviousNode()
返回在此节点树的前序遍历中此节点之前的节点。如果此节点是遍历的第一个节点 -- 树的根，则返回 null。这是遍历整棵树的一种低效方式；请改用枚举。

返回：
前序遍历中此节点之前的节点，如果此节点是第一个节点，则返回 null
另请参见：
preorderEnumeration()

preorderEnumeration

public Enumeration preorderEnumeration()
创建并返回按前序遍历以此节点为根的子树的一个枚举。由枚举的 nextElement() 方法返回的第一个节点是此节点。

通过插入、移除或移动节点修改树可以使修改前创建的任何枚举无效。

返回：
按前序遍历遍历树的一个枚举
另请参见：
postorderEnumeration()

postorderEnumeration

public Enumeration postorderEnumeration()
创建并返回按后序遍历以此节点为根的树的一个枚举。由枚举的 nextElement() 方法返回的第一个节点是最左边的叶节点。这与深度优先遍历相同。

通过插入、移除或移动节点修改树可以使修改前创建的任何枚举无效。

返回：
按后序遍历遍历树的一个枚举
另请参见：
depthFirstEnumeration(), preorderEnumeration()

breadthFirstEnumeration

public Enumeration breadthFirstEnumeration()
创建并返回一个枚举，该枚举按广度优先的顺序遍历以此节点为根的子树。由枚举的 nextElement() 方法返回的第一个节点是此节点。

通过插入、移除或移动节点修改树可以使修改前创建的任何枚举无效。

返回：
按广度优先的顺序遍历树的一个枚举
另请参见：
depthFirstEnumeration()

depthFirstEnumeration

public Enumeration depthFirstEnumeration()
创建并返回一个枚举，该枚举按深度优先的顺序遍历以此节点为根的子树。由枚举的 nextElement() 方法返回的第一个节点是最左边的叶节点。这与后序遍历相同。

通过插入、移除或移动节点修改树可以使修改前创建的任何枚举无效。

返回：
按深度优先的顺序遍历树的一个枚举
另请参见：
breadthFirstEnumeration(), postorderEnumeration()

pathFromAncestorEnumeration

public Enumeration pathFromAncestorEnumeration(TreeNode ancestor)
创建并返回沿着从 ancestor 到此节点的路径的一个枚举。枚举的 nextElement() 方法首先返回 ancestor，然后返回作为此节点祖先的 ancestor 的子节点，依此类推，最后返回此节点。创建枚举所花费的时间是 O(m)，其中 m 是此节点和 ancestor（包含）之间的节点数。每个 nextElement() 消息的花费都是 O(1)。

通过插入、移除或移动节点修改树可以使修改前创建的任何枚举无效。

返回：
一个枚举，它在从此节点的祖先到此节点的路径上
抛出：
IllegalArgumentException - 如果 ancestor 不是此节点的祖先
另请参见：
isNodeAncestor(javax.swing.tree.TreeNode), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

isNodeChild

public boolean isNodeChild(TreeNode aNode)
如果 aNode 是此节点的子节点，则返回 true。如果 aNode 为 null，则此方法返回 false。

返回：
如果 aNode 为此节点的子节点，则返回 true；如果 aNode 为 null，则返回 false

getFirstChild

public TreeNode getFirstChild()
返回此节点的第一个子节点。如果此节点没有子节点，则抛出 NoSuchElementException。

返回：
此节点的第一个子节点
抛出：
NoSuchElementException - 如果此节点没有子节点

getLastChild

public TreeNode getLastChild()
返回此节点的最后一个子节点。如果此节点没有子节点，则抛出 NoSuchElementException。

返回：
此节点的最后一个子节点
抛出：
NoSuchElementException - 如果此节点没有子节点

getChildAfter

public TreeNode getChildAfter(TreeNode aChild)
返回此节点的子节点数组中刚好跟在 aChild 之后的子节点，它必须是此节点的子节点。如果 aChild 是最后一个子节点，则返回 null。此方法对此节点的子节点执行线性搜索，以查找 aChild ，并且花费时间为 O(n)，其中 n 表示子节点数；要遍历整个子节点数组，请改用枚举。

返回：
此节点的子节点，它刚好跟在 aChild 之后
抛出：
IllegalArgumentException - 如果 aChild 为 null，或者不是此节点的子节点
另请参见：
children

getChildBefore

public TreeNode getChildBefore(TreeNode aChild)
返回此节点的子节点数组中刚好在 aChild 之前的子节点，它必须是此节点的子节点。如果 aChild 是第一个子节点，则返回 null。此方法对此节点的子节点执行线性搜索，以查找 aChild ，并且花费时间为 O(n) ，其中 n 表示子节点数。

返回：
此节点的子节点，它刚好在 aChild 之前
抛出：
IllegalArgumentException - 如果 aChild 为 null，或者不是此节点的子节点

isNodeSibling

public boolean isNodeSibling(TreeNode anotherNode)
如果 anotherNode 是此节点的兄弟节点（与此节点共享同一父节点），则返回 true。节点是其本身的兄弟节点。如果 anotherNode 为 null，则返回 false。

参数：
anotherNode - 测试其是否为此节点的兄弟节点
返回：
如果 anotherNode 是此节点的兄弟节点，则返回 true

getSiblingCount

public int getSiblingCount()
返回此节点的兄弟节点数。节点是其本身的兄弟节点（如果它没有父节点，或者没有兄弟节点，则此方法返回 1）。

返回：
此节点的兄弟节点数

getNextSibling

public DefaultMutableTreeNode getNextSibling()
返回父节点的子节点数组中此节点的下一个兄弟节点。如果此节点没有父节点，或者是父节点的最后一个子节点，则返回 null。此方法执行线性搜索，花费时间为 O(n)，其中 n 表示子节点数；要遍历整个数组，请改用父节点的子节点枚举。

返回：
此节点的兄弟节点，它刚好跟在此节点之后
另请参见：
children

getPreviousSibling

public DefaultMutableTreeNode getPreviousSibling()
返回父节点的子节点数组中此节点的前一个兄弟节点。如果此节点没有父节点，或者是父节点的第一个子节点，则返回 null。此方法执行线性搜索，花费时间为 O(n)，其中 n 表示子节点数。

返回：
此节点的兄弟节点，它刚好在此节点之前

isLeaf

public boolean isLeaf()
如果此节点没有子节点，则返回 true。要区分没有子节点的节点和不能 拥有子节点的节点（例如，区分空目录中的文件），请将此方法与 getAllowsChildren 联合使用

指定者：
接口 TreeNode 中的 isLeaf
返回：
如果此节点没有子节点，则返回 true
另请参见：
getAllowsChildren()

getFirstLeaf

public DefaultMutableTreeNode getFirstLeaf()
查找并返回为此节点后代的第一个叶节点，即此节点或其第一个子节点的第一个叶节点。如果它是叶节点，则返回此节点。

返回：
以此节点为根的子树中的第一个叶节点
另请参见：
isLeaf(), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

getLastLeaf

public DefaultMutableTreeNode getLastLeaf()
查找并返回为此节点后代的最后一个叶节点，即此节点或其最后一个子节点的最后一个叶节点。如果它是叶节点，则返回此节点。

返回：
以此节点为根的子树中的最后一个叶节点
另请参见：
isLeaf(), isNodeDescendant(javax.swing.tree.DefaultMutableTreeNode)

getNextLeaf

public DefaultMutableTreeNode getNextLeaf()
返回此节点后面的叶节点，如果此节点是树中的最后一个叶节点，则返回 null。

在 MutableNode 接口的此实现中，此操作效率非常低。为了确定下一个节点，此方法首先在父节点的子节点列表中执行线性搜索，以便找到当前节点。

该实现使该操作适合于从已知位置开始的简短遍历。但是，要遍历树中的所有叶节点，您应使用 depthFirstEnumeration 来枚举树中的节点，并对每个节点执行 isLeaf 确定哪些是叶节点。

返回：
返回此节点之后的下一个叶节点
另请参见：
depthFirstEnumeration(), isLeaf()

getPreviousLeaf

public DefaultMutableTreeNode getPreviousLeaf()
返回此节点之前的叶节点，如果此节点是树中的第一个叶节点，则返回 null。

在 MutableNode 接口的此实现中，此操作效率非常低。为了确定前一个节点，此方法首先在父节点的子节点列表中执行线性搜索，以便找到当前节点。

该实现使得操作适合于从已知位置开始的简短遍历。但是，要遍历树中的所有叶节点，您应使用 depthFirstEnumeration 来枚举树中的节点，并对每个节点执行 isLeaf 确定哪些是叶节点。

返回：
返回此节点之前的叶节点
另请参见：
depthFirstEnumeration(), isLeaf()

getLeafCount

public int getLeafCount()
返回为此节点后代的叶节点总数。如果此节点是叶节点，则返回 1。此方法花费时间为 O(n)，其中 n 表示此节点的后代数。

返回：
此节点下面的叶节点数
另请参见：
isNodeAncestor(javax.swing.tree.TreeNode)

toString

public String toString()
返回将 toString() 发送到此节点的用户对象的结果，如果此节点没有用户对象，则返回 null。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
另请参见：
getUserObject()

clone

public Object clone()
重写以复制 public。返回对此节点的浅表复制；新的节点没有父节点或子节点，但具有对同一用户对象（如果有）的引用。

覆盖：
类 Object 中的 clone
返回：
此节点的副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTreeCellEditor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 DefaultTreeCellEditor

java.lang.Object
    继承者  javax.swing.tree.DefaultTreeCellEditor
所有已实现的接口：
ActionListener, EventListener, CellEditor, TreeSelectionListener, TreeCellEditor
public class DefaultTreeCellEditor
extends Object
implements ActionListener, TreeCellEditor, TreeSelectionListener

TreeCellEditor。需要提供一个 DefaultTreeCellRenderer 实例，以便可以获取图标。您也可以提供一个根据 DefaultTreeCellRenderer 中的图标布局的 TreeCellEditor。如果不提供 TreeCellEditor，将使用 TextField。三次鼠标单击可启动编辑，或者一次单击之后，暂停一会，再单击并延迟 1200 毫秒也可启动编辑。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JTree

嵌套类摘要
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
字段摘要
protected Color | borderSelectionColor 如果应绘制边框选择色，则为 true。
protected boolean | canEdit 从 Java 2 平台 v1.4 开始，不应再使用此字段。
protected Component | editingComponent 用于编辑的组件，从 editingContainer 获取。
protected Container | editingContainer 将包含 editorComponent 的编辑容器。
protected Icon | editingIcon 编辑时要使用的图标。
protected Font | font 用以绘制的字体，null 指示将使用呈现器的字体。
protected TreePath | lastPath 选择的最后路径。
protected int | lastRow 最后传入到 getTreeCellEditorComponent 的行。
protected int | offset 在编辑中使用。
protected TreeCellEditor | realEditor 处理该编辑的编辑器。
protected DefaultTreeCellRenderer | renderer 用于从中获取边框和偏移量的呈现器。
protected Timer | timer 在启动编辑会话之前使用。
protected JTree | tree JTree 实例侦听。
构造方法摘要
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
使用指定呈现器和默认编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
方法摘要
 void actionPerformed(ActionEvent e)
计时器被激发时传递消息，这将启动编辑会话。
 void addCellEditorListener(CellEditorListener l)
添加 CellEditorListener。
 void cancelCellEditing()
将 cancelCellEditing 发送到 realEditor，并从此实例移除它。
protected  boolean canEditImmediately(EventObject event)
如果 event 为 null，或者它是一个单击计数 > 2 的 MouseEvent，并且 inHitRegion 返回 true，则此方法返回 true。
protected  Container createContainer()
创建管理 editingComponent 放置的容器。
protected  TreeCellEditor createTreeCellEditor()
如果构造方法中没有提供 TreeCellEditor，则调用此方法。
protected  void determineOffset(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
 Color getBorderSelectionColor()
返回绘制边框的颜色。
 CellEditorListener[] getCellEditorListeners()
返回使用 addCellEditorListener() 添加到此 DefaultTreeCellEditor 中的所有 CellEditorListener 组成的数组。
 Object getCellEditorValue()
返回当前正在编辑的值。
 Font getFont()
获取用于编辑的字体。
 Component getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
配置编辑器。
protected  boolean inHitRegion(int x, int y)
如果传入位置是要启动编辑的有效鼠标位置，则返回 true。
 boolean isCellEditable(EventObject event)
如果 realEditor 将 true 返回到此消息，则会通知 prepareForEditing，并返回 true。
protected  void prepareForEditing()
仅在编辑启动之前调用。
 void removeCellEditorListener(CellEditorListener l)
移除以前添加的 CellEditorListener。
 void setBorderSelectionColor(Color newColor)
设置用于边框的颜色。
 void setFont(Font font)
设置编辑使用的字体。
protected  void setTree(JTree newTree)
设置当前正在为其编辑的树。
 boolean shouldSelectCell(EventObject event)
针对返回值，向 realEditor 发送消息。
protected  boolean shouldStartEditingTimer(EventObject event)
如果 event 为 MouseEvent，并且单击计数为 1，则返回 true。
protected  void startEditingTimer()
启动编辑计时器。
 boolean stopCellEditing()
如果 realEditor 允许编辑停止，则移除 realEditor，并返回 true，否则返回 false。
 void valueChanged(TreeSelectionEvent e)
重置 lastPath。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

realEditor

protected TreeCellEditor realEditor
处理该编辑的编辑器。

renderer

protected DefaultTreeCellRenderer renderer
用于从中获取边框和偏移量的呈现器。

editingContainer

protected Container editingContainer
将包含 editorComponent 的编辑容器。

editingComponent

protected transient Component editingComponent
用于编辑的组件，从 editingContainer 获取。

canEdit

protected boolean canEdit
从 Java 2 平台 v1.4 开始，不应再使用此字段。如果要提供类似行为，您应直接重写 isCellEditable。

offset

protected transient int offset
在编辑中使用。指定存放 editingComponent 的 x 位置。

tree

protected transient JTree tree
JTree 实例侦听。

lastPath

protected transient TreePath lastPath
选择的最后路径。

timer

protected transient Timer timer
在启动编辑会话之前使用。

lastRow

protected transient int lastRow
最后传入到 getTreeCellEditorComponent 的行。

borderSelectionColor

protected Color borderSelectionColor
如果应绘制边框选择色，则为 true。

editingIcon

protected transient Icon editingIcon
编辑时要使用的图标。

font

protected Font font
用以绘制的字体，null 指示将使用呈现器的字体。

构造方法详细信息

DefaultTreeCellEditor

public DefaultTreeCellEditor(JTree tree,
                             DefaultTreeCellRenderer renderer)
使用指定呈现器和默认编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。（使用此构造方法进行常规编辑。）

参数：
tree - JTree 对象
renderer - DefaultTreeCellRenderer 对象

DefaultTreeCellEditor

public DefaultTreeCellEditor(JTree tree,
                             DefaultTreeCellRenderer renderer,
                             TreeCellEditor editor)
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。（使用此构造方法进行特殊编辑。）

参数：
tree - JTree 对象
renderer - DefaultTreeCellRenderer 对象
editor - TreeCellEditor 对象
方法详细信息

setBorderSelectionColor

public void setBorderSelectionColor(Color newColor)
设置用于边框的颜色。

参数：
newColor - 新的边框颜色

getBorderSelectionColor

public Color getBorderSelectionColor()
返回绘制边框的颜色。

返回：
边框选择色

setFont

public void setFont(Font font)
设置编辑使用的字体。null 指示应使用的呈现器字体。这将不会重写您在编辑器中设置的任何字体，接收者使用该编辑器进行实例化。如果传入编辑器的 null，则将创建采用此字体的默认编辑器。

参数：
font - 编辑 Font
另请参见：
getFont()

getFont

public Font getFont()
获取用于编辑的字体。

返回：
编辑 Font
另请参见：
setFont(java.awt.Font)

getTreeCellEditorComponent

public Component getTreeCellEditorComponent(JTree tree,
                                            Object value,
                                            boolean isSelected,
                                            boolean expanded,
                                            boolean leaf,
                                            int row)
配置编辑器。传递到 realEditor。

指定者：
接口 TreeCellEditor 中的 getTreeCellEditorComponent
参数：
tree - 要请求编辑器进行编辑的 JTree；此参数可以为 null
value - 要编辑的单元格的值
isSelected - 如果将呈现单元格并在选择时高亮显示，则为 true
expanded - 如果该节点被扩展，则为 true
leaf - 如果该节点是叶节点，则为 true
row - 正在编辑的节点的行索引
返回：
用于编辑的组件

getCellEditorValue

public Object getCellEditorValue()
返回当前正在编辑的值。

指定者：
接口 CellEditor 中的 getCellEditorValue
返回：
当前正在编辑的值

isCellEditable

public boolean isCellEditable(EventObject event)
如果 realEditor 将 true 返回到此消息，则会通知 prepareForEditing，并返回 true。

指定者：
接口 CellEditor 中的 isCellEditable
参数：
event - 编辑器考虑是否开始进行编辑时应该使用的事件
返回：
如果可开始进行编辑，则返回 true
另请参见：
CellEditor.shouldSelectCell(java.util.EventObject)

shouldSelectCell

public boolean shouldSelectCell(EventObject event)
针对返回值，向 realEditor 发送消息。

指定者：
接口 CellEditor 中的 shouldSelectCell
参数：
event - 编辑器开始进行编辑时应该使用的事件
返回：
如果编辑器愿意选择正编辑的单元格，则返回 true；否则返回 false
另请参见：
CellEditor.isCellEditable(java.util.EventObject)

stopCellEditing

public boolean stopCellEditing()
如果 realEditor 允许编辑停止，则移除 realEditor，并返回 true，否则返回 false。

指定者：
接口 CellEditor 中的 stopCellEditing
返回：
如果编辑已停止，则返回 true；否则返回 false

cancelCellEditing

public void cancelCellEditing()
将 cancelCellEditing 发送到 realEditor，并从此实例移除它。

指定者：
接口 CellEditor 中的 cancelCellEditing

addCellEditorListener

public void addCellEditorListener(CellEditorListener l)
添加 CellEditorListener。

指定者：
接口 CellEditor 中的 addCellEditorListener
参数：
l - 要添加的侦听器

removeCellEditorListener

public void removeCellEditorListener(CellEditorListener l)
移除以前添加的 CellEditorListener。

指定者：
接口 CellEditor 中的 removeCellEditorListener
参数：
l - 要移除的侦听器。

getCellEditorListeners

public CellEditorListener[] getCellEditorListeners()
返回使用 addCellEditorListener() 添加到此 DefaultTreeCellEditor 中的所有 CellEditorListener 组成的数组。

返回：
添加的所有 CellEditorListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

valueChanged

public void valueChanged(TreeSelectionEvent e)
重置 lastPath。

指定者：
接口 TreeSelectionListener 中的 valueChanged
参数：
e - 表现更改的特征的事件。

actionPerformed

public void actionPerformed(ActionEvent e)
计时器被激发时传递消息，这将启动编辑会话。

指定者：
接口 ActionListener 中的 actionPerformed

setTree

protected void setTree(JTree newTree)
设置当前正在为其编辑的树。这是添加选择侦听器所需要的。

参数：
newTree - 要编辑的新树

shouldStartEditingTimer

protected boolean shouldStartEditingTimer(EventObject event)
如果 event 为 MouseEvent，并且单击计数为 1，则返回 true。

参数：
event - 正在研究的事件

startEditingTimer

protected void startEditingTimer()
启动编辑计时器。

canEditImmediately

protected boolean canEditImmediately(EventObject event)
如果 event 为 null，或者它是一个单击计数 > 2 的 MouseEvent，并且 inHitRegion 返回 true，则此方法返回 true。

参数：
event - 正在研究的事件

inHitRegion

protected boolean inHitRegion(int x,
                              int y)
如果传入位置是要启动编辑的有效鼠标位置，则返回 true。如果 x <= 呈现器显示的图标和图标间距的宽度，则此实现返回 false。换句话说，如果用户单击呈现器显示的文本部分，则返回 true，否则返回 false。

参数：
x - 点的 x 坐标
y - 点的 y 坐标
返回：
如果传入的位置是有效鼠标位置，则返回 true

determineOffset

protected void determineOffset(JTree tree,
                               Object value,
                               boolean isSelected,
                               boolean expanded,
                               boolean leaf,
                               int row)

prepareForEditing

protected void prepareForEditing()
仅在编辑启动之前调用。将把 editingComponent 添加到 editingContainer。

createContainer

protected Container createContainer()
创建管理 editingComponent 放置的容器。

createTreeCellEditor

protected TreeCellEditor createTreeCellEditor()
如果构造方法中没有提供 TreeCellEditor，则调用此方法。它返回一个 TextField 编辑器。

返回：
新的 TextField 编辑器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTreeCellEditor.DefaultTextField (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 DefaultTreeCellEditor.DefaultTextField

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.text.JTextComponent
                    继承者  javax.swing.JTextField
                        继承者  javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants
正在封闭类：
DefaultTreeCellEditor
public class DefaultTreeCellEditor.DefaultTextField
extends JTextField

不提供任何编辑器时所使用的 TextField。此文本字段被锁定在构造它的边框内。也可以首选其字体上的父级字体。而且，如果 renderer 不为 null，并且没有指定任何字体，那么首选高度就是该 renderer 的高度。

嵌套类摘要
从类 javax.swing.JTextField 继承的嵌套类/接口
JTextField.AccessibleJTextField
从类 javax.swing.text.JTextComponent 继承的嵌套类/接口
JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected  Border border
要使用的边框。
从类 javax.swing.JTextField 继承的字段
notifyAction
从类 javax.swing.text.JTextComponent 继承的字段
DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
DefaultTreeCellEditor.DefaultTextField(Border border)
构造一个 DefaultTreeCellEditor.DefaultTextField 对象。
方法摘要
Border | getBorder() 重写 JComponent.getBorder，以返回当前边框。
Font | getFont() 获取组件的字体。
Dimension | getPreferredSize() 重写 JTextField.getPreferredSize，以根据当前字体（如果设置）返回首选大小，否则使用 renderer 的字体。
void | setBorder(Border border) 设置此组件的边框。
从类 javax.swing.JTextField 继承的方法
actionPropertyChanged, addActionListener, configurePropertiesFromAction, createActionPropertyChangeListener, createDefaultModel, fireActionPerformed, getAccessibleContext, getAction, getActionListeners, getActions, getColumns, getColumnWidth, getHorizontalAlignment, getHorizontalVisibility, getScrollOffset, getUIClassID, isValidateRoot, paramString, postActionEvent, removeActionListener, scrollRectToVisible, setAction, setActionCommand, setColumns, setDocument, setFont, setHorizontalAlignment, setScrollOffset
从类 javax.swing.text.JTextComponent 继承的方法
addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

border

protected Border border
要使用的边框。

构造方法详细信息

DefaultTreeCellEditor.DefaultTextField

public DefaultTreeCellEditor.DefaultTextField(Border border)
构造一个 DefaultTreeCellEditor.DefaultTextField 对象。

参数：
border - Border 对象
从以下版本开始：
1.4
方法详细信息

setBorder

public void setBorder(Border border)
设置此组件的边框。

这是一个绑定 (bound) 属性。

覆盖：
类 JComponent 中的 setBorder
参数：
border - 为此组件呈现的边框
另请参见：
Border, CompoundBorder

getBorder

public Border getBorder()
重写 JComponent.getBorder，以返回当前边框。

覆盖：
类 JComponent 中的 getBorder
返回：
此组件的边框对象
另请参见：
JComponent.setBorder(javax.swing.border.Border)

getFont

public Font getFont()
从类 Component 复制的描述
获取组件的字体。

指定者：
接口 MenuContainer 中的 getFont
覆盖：
类 Component 中的 getFont
返回：
组件的字体；如果此组件未设置字体，则返回其父级的字体
另请参见：
Component.setFont(java.awt.Font)

getPreferredSize

public Dimension getPreferredSize()
重写 JTextField.getPreferredSize，以根据当前字体（如果设置）返回首选大小，否则使用 renderer 的字体。

覆盖：
类 JTextField 中的 getPreferredSize
返回：
包含首选大小的 Dimension 对象
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTreeCellEditor.EditorContainer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 DefaultTreeCellEditor.EditorContainer

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.tree.DefaultTreeCellEditor.EditorContainer
所有已实现的接口：
ImageObserver, MenuContainer, Serializable
正在封闭类：
DefaultTreeCellEditor
public class DefaultTreeCellEditor.EditorContainer
extends Container

负责存放 editingComponent 的容器。

嵌套类摘要
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
DefaultTreeCellEditor.EditorContainer()
构造一个 EditorContainer 对象。
方法摘要
void | doLayout() 对此 Container 进行布局。
void | EditorContainer()
Dimension | getPreferredSize() 返回 Container 的首选大小。
void | paint(Graphics g) 重写 Container.paint 以绘制节点的图标，并使用选定的背景色。
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addNotify, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DefaultTreeCellEditor.EditorContainer

public DefaultTreeCellEditor.EditorContainer()
构造一个 EditorContainer 对象。

方法详细信息

EditorContainer

public void EditorContainer()

paint

public void paint(Graphics g)
重写 Container.paint 以绘制节点的图标，并使用选定的背景色。

覆盖：
类 Container 中的 paint
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

doLayout

public void doLayout()
对此 Container 进行布局。如果进行编辑，将编辑器放置在 x 方向上（y 为 0）offset 处。

覆盖：
类 Container 中的 doLayout
另请参见：
LayoutManager.layoutContainer(java.awt.Container),
Container.setLayout(java.awt.LayoutManager),
Container.validate()

getPreferredSize

public Dimension getPreferredSize()
返回 Container 的首选大小。这将至少是编辑器的首选大小加上 offset。

覆盖：
类 Container 中的 getPreferredSize
返回：
包含 Container 的首选大小的 Dimension；如果 editingComponent 为 null，则返回的 Dimension 为 0, 0
另请参见：
Container.getMinimumSize(),
Container.getMaximumSize(),
Container.getLayout(),
LayoutManager.preferredLayoutSize(Container),
Component.getPreferredSize()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTreeCellRenderer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 DefaultTreeCellRenderer

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.tree.DefaultTreeCellRenderer
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants, TreeCellRenderer
public class DefaultTreeCellRenderer
extends JLabel
implements TreeCellRenderer

显示树中的条目。DefaultTreeCellRenderer 是透明的，除非为 paint 创建子类，否则不要更改它。有关使用此类自定义节点显示的示例，请参阅 The Java Tutorial 中的 How to Use Trees 一节。

实现注意事项：此类重写 invalidate、validate、revalidate、repaint 和 firePropertyChange 只是为了提高性能。如果不重写这些方法，这些经常调用的方法将执行那些对于默认树单元格渲染器来说不必要的代码路径。如果编写自己的渲染器，则要小心权衡重写这些方法的利弊。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected Color | backgroundNonSelectionColor 不选定节点时用于背景的颜色。
protected Color | backgroundSelectionColor 选定节点时用于背景的颜色。
protected Color | borderSelectionColor 节点具有焦点时，用于焦点指示符的颜色。
protected Icon | closedIcon 用于显示无扩展的非叶节点的图标。
protected boolean | hasFocus 如果有焦点，则为 true。
protected Icon | leafIcon 用于显示叶节点的图标。
protected Icon | openIcon 用于显示扩展的非叶节点的图标。
protected boolean | selected 当前是否选择该值。
protected Color | textNonSelectionColor 用于非选定节点的前景颜色。
protected Color | textSelectionColor 用于选定节点的前景颜色。
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
DefaultTreeCellRenderer()
返回 DefaultTreeCellRenderer 的新实例。
方法摘要
void | firePropertyChange(String propertyName, boolean oldValue, boolean newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, byte oldValue, byte newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, char oldValue, char newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, double oldValue, double newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, float oldValue, float newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, int oldValue, int newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, long oldValue, long newValue) 因为性能原因而被重写。
protected void | firePropertyChange(String propertyName, Object oldValue, Object newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, short oldValue, short newValue) 因为性能原因而被重写。
Color | getBackgroundNonSelectionColor() 返回用于非选定节点的背景色。
Color | getBackgroundSelectionColor() 返回在选定节点的情况下背景所使用的颜色。
Color | getBorderSelectionColor() 返回绘制边框时所使用的颜色。
Icon | getClosedIcon() 返回用于表示没有扩展的非叶节点的图标。
Icon | getDefaultClosedIcon() 返回默认图标，对于当前的 laf，它用于表示没有扩展的非叶节点。
Icon | getDefaultLeafIcon() 返回默认图标，对于当前的 laf，它用于表示叶节点。
Icon | getDefaultOpenIcon() 返回默认图标，对于当前的 laf，它用于表示扩展的非叶节点。
Font | getFont() 获取此组件的字体。
Icon | getLeafIcon() 返回用于表示叶节点的图标。
Icon | getOpenIcon() 返回用于表示扩展的非叶节点的图标。
Dimension | getPreferredSize() 重写 JComponent.getPreferredSize，以返回稍宽的首选大小值。
Color | getTextNonSelectionColor() 返回未选定节点时绘制文本所使用的颜色。
Color | getTextSelectionColor() 返回选定节点时绘制文本所使用的颜色。
Component | getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus) 配置基于传入组件的渲染器。
void | invalidate() 因为性能原因而被重写。
void | paint(Graphics g) 绘制值。
void | repaint() 因为性能原因而被重写。
void | repaint(long tm, int x, int y, int width, int height) 因为性能原因而被重写。
void | repaint(Rectangle r) 因为性能原因而被重写。
void | revalidate() 因为性能原因而被重写。
void | setBackground(Color color) 创建子类，以便将 ColorUIResource 映射为 null。
void | setBackgroundNonSelectionColor(Color newColor) 设置用于非选定节点的背景色。
void | setBackgroundSelectionColor(Color newColor) 设置在选定节点的情况下背景所使用的颜色。
void | setBorderSelectionColor(Color newColor) 设置用于边框的颜色。
void | setClosedIcon(Icon newIcon) 设置用于表示没有扩展的非叶节点的图标。
void | setFont(Font font) 创建子类，以便将 FontUIResource 映射为 null。
void | setLeafIcon(Icon newIcon) 设置用于表示叶节点的图标。
void | setOpenIcon(Icon newIcon) 设置用于表示扩展的非叶节点的图标。
void | setTextNonSelectionColor(Color newColor) 设置选定节点时绘制文本所使用的颜色。
void | setTextSelectionColor(Color newColor) 设置选定节点时绘制文本所使用的颜色。
void | validate() 因为性能原因而被重写。
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

selected

protected boolean selected
当前是否选择该值。

hasFocus

protected boolean hasFocus
如果有焦点，则为 true。

closedIcon

protected transient Icon closedIcon
用于显示无扩展的非叶节点的图标。

leafIcon

protected transient Icon leafIcon
用于显示叶节点的图标。

openIcon

protected transient Icon openIcon
用于显示扩展的非叶节点的图标。

textSelectionColor

protected Color textSelectionColor
用于选定节点的前景颜色。

textNonSelectionColor

protected Color textNonSelectionColor
用于非选定节点的前景颜色。

backgroundSelectionColor

protected Color backgroundSelectionColor
选定节点时用于背景的颜色。

backgroundNonSelectionColor

protected Color backgroundNonSelectionColor
不选定节点时用于背景的颜色。

borderSelectionColor

protected Color borderSelectionColor
节点具有焦点时，用于焦点指示符的颜色。

构造方法详细信息

DefaultTreeCellRenderer

public DefaultTreeCellRenderer()
返回 DefaultTreeCellRenderer 的新实例。将对齐方式设置为左对齐。图标和文本色由 UIManager 确定。

方法详细信息

getDefaultOpenIcon

public Icon getDefaultOpenIcon()
返回默认图标，对于当前的 laf，它用于表示扩展的非叶节点。

getDefaultClosedIcon

public Icon getDefaultClosedIcon()
返回默认图标，对于当前的 laf，它用于表示没有扩展的非叶节点。

getDefaultLeafIcon

public Icon getDefaultLeafIcon()
返回默认图标，对于当前的 laf，它用于表示叶节点。

setOpenIcon

public void setOpenIcon(Icon newIcon)
设置用于表示扩展的非叶节点的图标。

getOpenIcon

public Icon getOpenIcon()
返回用于表示扩展的非叶节点的图标。

setClosedIcon

public void setClosedIcon(Icon newIcon)
设置用于表示没有扩展的非叶节点的图标。

getClosedIcon

public Icon getClosedIcon()
返回用于表示没有扩展的非叶节点的图标。

setLeafIcon

public void setLeafIcon(Icon newIcon)
设置用于表示叶节点的图标。

getLeafIcon

public Icon getLeafIcon()
返回用于表示叶节点的图标。

setTextSelectionColor

public void setTextSelectionColor(Color newColor)
设置选定节点时绘制文本所使用的颜色。

getTextSelectionColor

public Color getTextSelectionColor()
返回选定节点时绘制文本所使用的颜色。

setTextNonSelectionColor

public void setTextNonSelectionColor(Color newColor)
设置选定节点时绘制文本所使用的颜色。

getTextNonSelectionColor

public Color getTextNonSelectionColor()
返回未选定节点时绘制文本所使用的颜色。

setBackgroundSelectionColor

public void setBackgroundSelectionColor(Color newColor)
设置在选定节点的情况下背景所使用的颜色。

getBackgroundSelectionColor

public Color getBackgroundSelectionColor()
返回在选定节点的情况下背景所使用的颜色。

setBackgroundNonSelectionColor

public void setBackgroundNonSelectionColor(Color newColor)
设置用于非选定节点的背景色。

getBackgroundNonSelectionColor

public Color getBackgroundNonSelectionColor()
返回用于非选定节点的背景色。

setBorderSelectionColor

public void setBorderSelectionColor(Color newColor)
设置用于边框的颜色。

getBorderSelectionColor

public Color getBorderSelectionColor()
返回绘制边框时所使用的颜色。

setFont

public void setFont(Font font)
创建子类，以便将 FontUIResource 映射为 null。如果 font 为 null 或 FontUIResource，则此操作可以使 JTree 的字体完全显示。另一方面，如果 font 为非 null，并且不是 FontUIResource，则该字体变成 font。

覆盖：
类 JComponent 中的 setFont
参数：
font - 此组件所需的 Font
另请参见：
Component.getFont()

getFont

public Font getFont()
获取此组件的字体。

指定者：
接口 MenuContainer 中的 getFont
覆盖：
类 Component 中的 getFont
返回：
此组件的字体；如果还没有为此组件设置字体，则返回其父级的字体
另请参见：
Component.setFont(java.awt.Font)

setBackground

public void setBackground(Color color)
创建子类，以便将 ColorUIResource 映射为 null。如果 color 为 null 或 ColorUIResource，则此操作可以使 JTree 的背景色完全显示。另一方面，如果 color 为非 null，并且不是 ColorUIResource，则该背景色变成 color。

覆盖：
类 JComponent 中的 setBackground
参数：
color - 所需的背景 Color
另请参见：
Component.getBackground(), JComponent.setOpaque(boolean)

getTreeCellRendererComponent

public Component getTreeCellRendererComponent(JTree tree,
                                              Object value,
                                              boolean sel,
                                              boolean expanded,
                                              boolean leaf,
                                              int row,
                                              boolean hasFocus)
配置基于传入组件的渲染器。使用 convertValueToText 向树传递消息，从而设置该值，最终对 value 调用 toString。基于选择设置前景色，基于 leaf 和 expanded 参数设置图标。

指定者：
接口 TreeCellRenderer 中的 getTreeCellRendererComponent
返回：
渲染器用来绘制值的 Component

paint

public void paint(Graphics g)
绘制值。基于选择填充背景。

覆盖：
类 JComponent 中的 paint
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

getPreferredSize

public Dimension getPreferredSize()
重写 JComponent.getPreferredSize，以返回稍宽的首选大小值。

覆盖：
类 JComponent 中的 getPreferredSize
返回：
preferredSize 属性的值
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

validate

public void validate()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Container 中的 validate
另请参见：
Container.add(java.awt.Component),
Component.invalidate(),
JComponent.revalidate(),
Container.validateTree()

invalidate

public void invalidate()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Container 中的 invalidate
从以下版本开始：
1.5
另请参见：
Container.validate(), Container.layout(), LayoutManager, LayoutManager2.invalidateLayout(Container)

revalidate

public void revalidate()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 revalidate
另请参见：
Component.invalidate(),
Container.validate(),
JComponent.isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

repaint

public void repaint(long tm,
                    int x,
                    int y,
                    int width,
                    int height)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 repaint
参数：
tm - 不使用此参数
x - 脏区的 x 值
y - 脏区的 y 值
width - 脏区的宽度
height - 脏区的高度
另请参见：
Component.isShowing(), RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

repaint

public void repaint(Rectangle r)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 repaint
参数：
r - 包含脏区的 Rectangle
另请参见：
Component.isShowing(), RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

repaint

public void repaint()
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 repaint
从以下版本开始：
1.5
另请参见：
Component.update(Graphics)

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 其值已改变的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

firePropertyChange

public void firePropertyChange(String propertyName,
                               byte oldValue,
                               byte newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（byte 类型）
newValue - 该属性的新值（byte 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               char oldValue,
                               char newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（char 类型）
newValue - 该属性的新值（char 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               short oldValue,
                               short newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（short 类型）
newValue - 该属性的新值（short 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               int oldValue,
                               int newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 firePropertyChange
参数：
propertyName - 其值已更改的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

firePropertyChange

public void firePropertyChange(String propertyName,
                               long oldValue,
                               long newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（long 类型）
newValue - 该属性的新值（long 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               float oldValue,
                               float newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（float 类型）
newValue - 该属性的新值（float 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               double oldValue,
                               double newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（double 类型）
newValue - 该属性的新值（double 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               boolean oldValue,
                               boolean newValue)
因为性能原因而被重写。有关更多信息，请参见实现注意事项。

覆盖：
类 JComponent 中的 firePropertyChange
参数：
propertyName - 其值已更改的属性
oldValue - 该属性以前的值
newValue - 该属性的新值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTreeModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 DefaultTreeModel

java.lang.Object
    继承者  javax.swing.tree.DefaultTreeModel
所有已实现的接口：
Serializable, TreeModel
public class DefaultTreeModel
extends Object
implements Serializable, TreeModel

使用 TreeNodes 的简单树数据模型。有关使用 DefaultTreeModel 的更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Trees。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected boolean | asksAllowsChildren 确定 isLeaf 方法如何判断一个节点是否为叶节点。
protected EventListenerList | listenerList 侦听器。
protected TreeNode | root 树的根。
构造方法摘要
DefaultTreeModel(TreeNode root)
创建其中任何节点都可以有子节点的树。
DefaultTreeModel(TreeNode root, boolean asksAllowsChildren)
创建一棵树，指定某个节点是否可以有子节点，或者是否仅某些节点可以有子节点。
方法摘要
 void addTreeModelListener(TreeModelListener l)
为树更改后发布的 TreeModelEvent 添加侦听器。
 boolean asksAllowsChildren()
告知如何确定叶节点。
protected  void fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。
protected  void fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。
protected  void fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。
protected  void fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。
 Object getChild(Object parent, int index)
返回父节点的子节点数组中索引 index 处的 parent 的子节点。
 int getChildCount(Object parent)
返回 parent 的子节点数。
 int getIndexOfChild(Object parent, Object child)
返回父节点中子节点的索引。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
 TreeNode[] getPathToRoot(TreeNode aNode)
向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected  TreeNode[] getPathToRoot(TreeNode aNode, int depth)
向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
 Object getRoot()
返回树的根。
 TreeModelListener[] getTreeModelListeners()
返回在此模型上注册的所有树模型侦听器组成的数组。
 void insertNodeInto(MutableTreeNode newChild, MutableTreeNode parent, int index)
对它进行调用，以便在父节点的子节点中的 index 位置插入 newChild。
 boolean isLeaf(Object node)
返回指定的节点是否为叶节点。
 void nodeChanged(TreeNode node)
更改节点在树中的表示方式之后，调用此方法。
 void nodesChanged(TreeNode node, int[] childIndices)
更改由 childIndicies 标识的子对象在树中的表示方式之后，调用此方法。
 void nodeStructureChanged(TreeNode node)
如果完全更改了节点的子节点、子节点的子节点、依此类推，则调用此方法。
 void nodesWereInserted(TreeNode node, int[] childIndices)
将某些 TreeNodes 插入节点之后，调用此方法。
 void nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren)
从节点移除一些 TreeNodes 之后，调用此方法。
 void reload()
如果已修改此模型依赖的 TreeNode，则调用此方法。
 void reload(TreeNode node)
如果已修改此模型依赖的 TreeNode，则调用此方法。
 void removeNodeFromParent(MutableTreeNode node)
通知它从其父节点中移除节点。
 void removeTreeModelListener(TreeModelListener l)
移除以前使用 addTreeModelListener() 添加的侦听器。
 void setAsksAllowsChildren(boolean newValue)
通过向 TreeNodes 询问 getAllowsChildren() 或 isLeaf()，设置是否测试无叶性。
 void setRoot(TreeNode root)
将根设置为 root。
 void valueForPathChanged(TreePath path, Object newValue)
此方法设置由路径标识的 TreeNode 的用户对象，并发送更改的节点。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

root

protected TreeNode root
树的根。

listenerList

protected EventListenerList listenerList
侦听器。

asksAllowsChildren

protected boolean asksAllowsChildren
确定 isLeaf 方法如何判断一个节点是否为叶节点。如果为 true，并且节点不允许有子节点，则该节点是叶节点。（如果它允许有子节点，则它不是叶节点，即使不存在任何子节点也是这样。）例如，让您区分文件系统中的文件夹 节点和文件 节点。

如果此值为 false，则没有子节点的任何节点都是叶节点，并且任何节点都可以获取子节点。

另请参见：
TreeNode.getAllowsChildren(),
TreeModel.isLeaf(java.lang.Object),
setAsksAllowsChildren(boolean)
构造方法详细信息

DefaultTreeModel

public DefaultTreeModel(TreeNode root)
创建其中任何节点都可以有子节点的树。

参数：
root - 作为树的根的 TreeNode 对象
另请参见：
DefaultTreeModel(TreeNode, boolean)

DefaultTreeModel

public DefaultTreeModel(TreeNode root,
                        boolean asksAllowsChildren)
创建一棵树，指定某个节点是否可以有子节点，或者是否仅某些节点可以有子节点。

参数：
root - 作为树的根的 TreeNode 对象
asksAllowsChildren - 一个布尔值，如果任何节点都可以有子节点，则为 false，如果询问每个节点看是否有子节点，则为 true
另请参见：
asksAllowsChildren
方法详细信息

setAsksAllowsChildren

public void setAsksAllowsChildren(boolean newValue)
通过向 TreeNodes 询问 getAllowsChildren() 或 isLeaf()，设置是否测试无叶性。如果 newValue 为 true，则传递 getAllowsChildren()，否则传递 isLeaf()。

asksAllowsChildren

public boolean asksAllowsChildren()
告知如何确定叶节点。

返回：
如果只有不允许有子节点的节点是叶节点，则返回 true，如果没有子节点的节点（即使允许）是叶节点，则返回 false
另请参见：
asksAllowsChildren

setRoot

public void setRoot(TreeNode root)
将根设置为 root。root 为 null 暗示树不显示任何内容，并且是合法的。

getRoot

public Object getRoot()
返回树的根。仅当树没有节点时，返回 null。

指定者：
接口 TreeModel 中的 getRoot
返回：
树的根

getIndexOfChild

public int getIndexOfChild(Object parent,
                           Object child)
返回父节点中子节点的索引。如果父节点或子节点为 null，则返回 -1。

指定者：
接口 TreeModel 中的 getIndexOfChild
参数：
parent - 从此数据源获取的树中的节点
child - 用户需要的节点
返回：
父节点中子节点的索引，如果父节点或子节点为 null，则返回 -1

getChild

public Object getChild(Object parent,
                       int index)
返回父节点的子节点数组中索引 index 处的 parent 的子节点。parent 必须是以前从此数据源获取的节点。如果 index 是 parent 的一个有效索引（即：index >= 0 && index < getChildCount(parent)），则不应返回 null。

指定者：
接口 TreeModel 中的 getChild
参数：
parent - 从此数据源获取的树中的节点
返回：
索引 index 位置的 parent 的子节点

getChildCount

public int getChildCount(Object parent)
返回 parent 的子节点数。如果该节点是叶节点，或者它没有子节点，则返回 0。parent 必须是以前从此数据源获取的节点。

指定者：
接口 TreeModel 中的 getChildCount
参数：
parent - 从此数据源获取的树中的节点
返回：
节点 parent 的子节点数

isLeaf

public boolean isLeaf(Object node)
返回指定的节点是否为叶节点。执行测试的方法取决于 askAllowsChildren 设置。

指定者：
接口 TreeModel 中的 isLeaf
参数：
node - 要检查的节点
返回：
如果该节点是一个叶节点，则返回 true
另请参见：
asksAllowsChildren, TreeModel.isLeaf(java.lang.Object)

reload

public void reload()
如果已修改此模型依赖的 TreeNode，则调用此方法。该模型将通知其所有侦听器该模型已更改。

valueForPathChanged

public void valueForPathChanged(TreePath path,
                                Object newValue)
此方法设置由路径标识的 TreeNode 的用户对象，并发送更改的节点。如果使用 TreeModel 中的自定义用户对象，您将需要为该对象创建子类，并将更改的节点的用户对象设置为有意义的内容。

指定者：
接口 TreeModel 中的 valueForPathChanged
参数：
path - 用户已更改的节点的路径
newValue - TreeCellEditor 的新值

insertNodeInto

public void insertNodeInto(MutableTreeNode newChild,
                           MutableTreeNode parent,
                           int index)
对它进行调用，以便在父节点的子节点中的 index 位置插入 newChild。然后，通知 nodesWereInserted 创建适当的事件。这是添加子节点的首选方法，因为它将创建适当的事件。

removeNodeFromParent

public void removeNodeFromParent(MutableTreeNode node)
通知它从其父节点中移除节点。这将通知 nodesWereRemoved 创建适当事件。这是移除节点的首选方法，因为它可以为您处理事件的创建。

nodeChanged

public void nodeChanged(TreeNode node)
更改节点在树中的表示方式之后，调用此方法。

reload

public void reload(TreeNode node)
如果已修改此模型依赖的 TreeNode，则调用此方法。该模型将通知其所有侦听器给定节点下面的模型已更改。

参数：
node - 其下面的模型已更改的节点

nodesWereInserted

public void nodesWereInserted(TreeNode node,
                              int[] childIndices)
将某些 TreeNodes 插入节点之后，调用此方法。子索引应是新元素的索引，并且必须按升序排序。

nodesWereRemoved

public void nodesWereRemoved(TreeNode node,
                             int[] childIndices,
                             Object[] removedChildren)
从节点移除一些 TreeNodes 之后，调用此方法。childIndices 应是移除元素的索引，并且必须按升序排序。removedChildren 应是移除的子对象的数组。

nodesChanged

public void nodesChanged(TreeNode node,
                         int[] childIndices)
更改由 childIndicies 标识的子对象在树中的表示方式之后，调用此方法。

nodeStructureChanged

public void nodeStructureChanged(TreeNode node)
如果完全更改了节点的子节点、子节点的子节点、依此类推，则调用此方法。调用此方法将发布 treeStructureChanged 事件。

getPathToRoot

public TreeNode[] getPathToRoot(TreeNode aNode)
向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。返回的数组长度给出了树中节点的深度。

参数：
aNode - 获取其路径的 TreeNode

getPathToRoot

protected TreeNode[] getPathToRoot(TreeNode aNode,
                                   int depth)
向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。返回的数组长度给出了树中节点的深度。

参数：
aNode - 要获取其路径的 TreeNode
depth - 提供对根（通过递归调用）执行的步骤数的 int，用于确定返回的数组的大小
返回：
提供从根到指定节点的路径的 TreeNodes 数组。

addTreeModelListener

public void addTreeModelListener(TreeModelListener l)
为树更改后发布的 TreeModelEvent 添加侦听器。

指定者：
接口 TreeModel 中的 addTreeModelListener
参数：
l - 要添加的侦听器
另请参见：
removeTreeModelListener(javax.swing.event.TreeModelListener)

removeTreeModelListener

public void removeTreeModelListener(TreeModelListener l)
移除以前使用 addTreeModelListener() 添加的侦听器。

指定者：
接口 TreeModel 中的 removeTreeModelListener
参数：
l - 要移除的侦听器
另请参见：
addTreeModelListener(javax.swing.event.TreeModelListener)

getTreeModelListeners

public TreeModelListener[] getTreeModelListeners()
返回在此模型上注册的所有树模型侦听器组成的数组。

返回：
此模型的所有 TreeModelListener，如果当前没有注册任何树模型侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addTreeModelListener(javax.swing.event.TreeModelListener), removeTreeModelListener(javax.swing.event.TreeModelListener)

fireTreeNodesChanged

protected void fireTreeNodesChanged(Object source,
                                    Object[] path,
                                    int[] childIndices,
                                    Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
source - 更改的节点
path - 到根节点的路径
childIndices - 更改的元素的索引
children - 更改的元素
另请参见：
EventListenerList

fireTreeNodesInserted

protected void fireTreeNodesInserted(Object source,
                                     Object[] path,
                                     int[] childIndices,
                                     Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
source - 插入新元素的节点
path - 到根节点的路径
childIndices - 新元素的索引
children - 新元素
另请参见：
EventListenerList

fireTreeNodesRemoved

protected void fireTreeNodesRemoved(Object source,
                                    Object[] path,
                                    int[] childIndices,
                                    Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
source - 移除元素的节点
path - 到根节点的路径
childIndices - 移除元素的索引
children - 移除的元素
另请参见：
EventListenerList

fireTreeStructureChanged

protected void fireTreeStructureChanged(Object source,
                                        Object[] path,
                                        int[] childIndices,
                                        Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。使用传入此触发方法的参数延后创建事件实例。

参数：
source - 从该节点开始树模型已更改的节点
path - 到根节点的路径
childIndices - 受影响的元素的索引
children - 受影响的元素
另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用下面的代码查询 DefaultTreeModel m 的树模型侦听器：

TreeModelListener[] tmls = (TreeModelListener[])(m.getListeners(TreeModelListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 所请求侦听器的类型；该参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此容器上注册为 FooListener 的所有对象的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getTreeModelListeners()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultTreeSelectionModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 DefaultTreeSelectionModel

java.lang.Object
    继承者  javax.swing.tree.DefaultTreeSelectionModel
所有已实现的接口：
Serializable, Cloneable, TreeSelectionModel
直接已知子类：
JTree.EmptySelectionModel
public class DefaultTreeSelectionModel
extends Object
implements Cloneable, Serializable, TreeSelectionModel

TreeSelectionModel 的默认实现。每当 selection 中的路径（不是行）发生更改时，侦听器就会获得通知。为了能够跟踪行的更改，您可能希望获得一个侦听器，用于树上的扩展事件，并从该位置测试更改。

从所有更新选择路径的方法中调用 resetRowSelection。如果对这些方法中的任何方法创建子类来过滤允许选择的内容，并且没有通知超类，请确定并通知 resetRowSelection。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JTree

字段摘要
protected SwingPropertyChangeSupport | changeSupport 用于接收通知的注册侦听器。
protected int | leadIndex selection 中前导路径的索引。
protected TreePath | leadPath 添加的最后一条路径。
protected int | leadRow 前导行。
protected EventListenerList | listenerList 事件侦听器列表。
protected DefaultListSelectionModel | listSelectionModel 维护列表选择模型的句柄。
protected RowMapper | rowMapper 提供给定路径的行。
protected TreePath[] | selection 当前选择的路径。
static String | SELECTION_MODE_PROPERTY selectionMode 的属性名称。
protected int | selectionMode 用于 selection 的模式，将是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION。
从接口 javax.swing.tree.TreeSelectionModel 继承的字段
CONTIGUOUS_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION, SINGLE_TREE_SELECTION
构造方法摘要
DefaultTreeSelectionModel()
使用 DISCONTIGUOUS_TREE_SELECTION 的选择模式创建空的 DefaultTreeSelectionModel 新实例。
方法摘要
 void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表。
 void addSelectionPath(TreePath path)
将路径添加到当前的 selection 中。
 void addSelectionPaths(TreePath[] paths)
向当前的 selection 中添加路径。
 void addTreeSelectionListener(TreeSelectionListener x)
向每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表添加 x。
protected  boolean arePathsContiguous(TreePath[] paths)
如果路径是连续的，或者此对象没有 RowMapper，则返回 true。
protected  boolean canPathsBeAdded(TreePath[] paths)
用于测试是否可以添加特定的 TreePath 集合。
protected  boolean canPathsBeRemoved(TreePath[] paths)
如果可以移除该路径而不中断该模型的连续性，则返回 true。
 void clearSelection()
清空当前的 selection。
 Object clone()
返回具有相同 selection 的此对象的副本。
protected  void fireValueChanged(TreeSelectionEvent e)
通知已注册此对象上的树选择事件的所有侦听器。
 TreePath getLeadSelectionPath()
返回添加的最后一条路径。
 int getLeadSelectionRow()
返回 lead selection 索引。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
 int getMaxSelectionRow()
返回从 RowMapper 获取的已选择的 TreePath 的当前集合中的最大值。
 int getMinSelectionRow()
返回从 RowMapper 获取的已选择的 TreePath 的当前集合中的最小值。
 PropertyChangeListener[] getPropertyChangeListeners()
返回此 DefaultTreeSelectionModel 上注册的所有属性更改侦听器组成的数组。
 RowMapper getRowMapper()
返回能够将 TreePath 映射到行的 RowMapper 实例。
 int getSelectionCount()
返回选择的路径数。
 int getSelectionMode()
返回选择模式，它是 SINGLE_TREE_SELECTION、DISCONTIGUOUS_TREE_SELECTION 或 CONTIGUOUS_TREE_SELECTION 之一。
 TreePath getSelectionPath()
返回 selection 中的第一个路径。
 TreePath[] getSelectionPaths()
返回 selection 中的路径。
 int[] getSelectionRows()
返回当前已选的所有行。
 TreeSelectionListener[] getTreeSelectionListeners()
返回已在此模型上注册的所有树选择侦听器组成的数组。
protected  void insureRowContinuity()
确保当前选择的 TreePath 对于当前选择模式是有效的。
protected  void insureUniqueness()
此方法已过时，并且其实现现在是一个 noop。
 boolean isPathSelected(TreePath path)
如果当前选择了路径 path，则返回 true。
 boolean isRowSelected(int row)
如果选择了由 row 标识的行，则返回 true。
 boolean isSelectionEmpty()
如果 selection 当前为空，则返回 true。
protected  void notifyPathChange(Vector<javax.swing.tree.PathPlaceHolder> changedPaths, TreePath oldLeadSelection)
通知侦听器路径中的更改。
 void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除 PropertyChangeListener。
 void removeSelectionPath(TreePath path)
从 selection 中移除路径。
 void removeSelectionPaths(TreePath[] paths)
从 selection 中移除路径。
 void removeTreeSelectionListener(TreeSelectionListener x)
从每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表中移除 x。
 void resetRowSelection()
更新此对象从 TreePath 到行的映射关系。
 void setRowMapper(RowMapper newMapper)
设置 RowMapper 实例。
 void setSelectionMode(int mode)
设置选择模式，它必须是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一。
 void setSelectionPath(TreePath path)
为该选择设置路径。
 void setSelectionPaths(TreePath[] pPaths)
为该选择设置路径中的路径。
 String toString()
返回显示并标识此对象属性的字符串。
protected  void updateLeadIndex()
更新 leadIndex 实例变量。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SELECTION_MODE_PROPERTY

public static final String SELECTION_MODE_PROPERTY
selectionMode 的属性名称。

另请参见：
常量字段值

changeSupport

protected SwingPropertyChangeSupport changeSupport
用于接收通知的注册侦听器。

selection

protected TreePath[] selection
当前选择的路径。如果当前没有选择任何内容，则路径为 null。

listenerList

protected EventListenerList listenerList
事件侦听器列表。

rowMapper

protected transient RowMapper rowMapper
提供给定路径的行。

listSelectionModel

protected DefaultListSelectionModel listSelectionModel
维护列表选择模型的句柄。RowMapper 用于从 TreePath 映射到行，并将该值放置在此处。

selectionMode

protected int selectionMode
用于 selection 的模式，将是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION。

leadPath

protected TreePath leadPath
添加的最后一条路径。

leadIndex

protected int leadIndex
selection 中前导路径的索引。

leadRow

protected int leadRow
前导行。

构造方法详细信息

DefaultTreeSelectionModel

public DefaultTreeSelectionModel()
使用 DISCONTIGUOUS_TREE_SELECTION 的选择模式创建空的 DefaultTreeSelectionModel 新实例。

方法详细信息

setRowMapper

public void setRowMapper(RowMapper newMapper)
设置 RowMapper 实例。此实例用于确定特定 TreePath 的行。

指定者：
接口 TreeSelectionModel 中的 setRowMapper

getRowMapper

public RowMapper getRowMapper()
返回能够将 TreePath 映射到行的 RowMapper 实例。

指定者：
接口 TreeSelectionModel 中的 getRowMapper

setSelectionMode

public void setSelectionMode(int mode)
设置选择模式，它必须是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一。如果模式不是定义的值之一，则假定模式为 DISCONTIGUOUS_TREE_SELECTION。

如果当前的 selection 对新模式无效，这可以更改该 selection。例如，如果将模式更改为 SINGLE_TREE_SELECTION 时选中三个 TreePath，则只有一个 TreePath 仍然被选中。由特定的实现来决定保留选定哪一个 TreePath。

将该模式设置为定义的类型以外的其他类型，将导致该模式变成 DISCONTIGUOUS_TREE_SELECTION。

指定者：
接口 TreeSelectionModel 中的 setSelectionMode

getSelectionMode

public int getSelectionMode()
返回选择模式，它是 SINGLE_TREE_SELECTION、DISCONTIGUOUS_TREE_SELECTION 或 CONTIGUOUS_TREE_SELECTION 之一。

指定者：
接口 TreeSelectionModel 中的 getSelectionMode

setSelectionPath

public void setSelectionPath(TreePath path)
为该选择设置路径。如果这表示一个更改，则通知 TreeSelectionListener。如果 path 为 null，则这与调用 clearSelection 具有相同的效果。

指定者：
接口 TreeSelectionModel 中的 setSelectionPath
参数：
path - 要选择的新路径

setSelectionPaths

public void setSelectionPaths(TreePath[] pPaths)
为该选择设置路径中的路径。如果这表示一个更改，则通知 TreeSelectionListener。此对象将可能保持路径；换句话说，不更改传入数组中的任何对象。

如果 paths 为 null，则这与调用 clearSelection 具有相同的效果。

将前导路径设置为 pPaths 中的最后一个路径。

如果选择模式为 CONTIGUOUS_TREE_SELECTION，并且添加新路径会使该选择不连续，则将该选择重新设置为 paths 中的第一个 TreePath。

指定者：
接口 TreeSelectionModel 中的 setSelectionPaths
参数：
pPaths - 新的选择

addSelectionPath

public void addSelectionPath(TreePath path)
将路径添加到当前的 selection 中。如果路径当前不在 selection 中，则通知 TreeSelectionListener。如果 path 为 null，则通知无效。

指定者：
接口 TreeSelectionModel 中的 addSelectionPath
参数：
path - 添加到当前 selection 中的新路径

addSelectionPaths

public void addSelectionPaths(TreePath[] paths)
向当前的 selection 中添加路径。如果路径中的任何路径当前不在 selection 中，则通知 TreeSelectionListener。如果 paths 为 null，则此方法无效。

将前导路径设置为 paths 中的最后元素。

如果选择模式为 CONTIGUOUS_TREE_SELECTION，则添加新的路径会使选择不连续。那么可导致两种结果：如果 paths 中的 TreePaths 是连续的，则该选择会变为这些 TreePaths，相反，如果 TreePaths 不是连续的，则该选择会变为 paths 中的第一个 TreePath。

指定者：
接口 TreeSelectionModel 中的 addSelectionPaths
参数：
paths - 添加到当前 selection 的新路径

removeSelectionPath

public void removeSelectionPath(TreePath path)
从 selection 中移除路径。如果路径在 selection 中，则通知 TreeSelectionListener。如果 path 为 null，则此方法无效。

指定者：
接口 TreeSelectionModel 中的 removeSelectionPath
参数：
path - 要从选择中移除的路径

removeSelectionPaths

public void removeSelectionPaths(TreePath[] paths)
从 selection 中移除路径。如果路径中的任何路径在 selection 中，则通知 TreeSelectionListeners。如果 paths 为 null，则此方法无效。

指定者：
接口 TreeSelectionModel 中的 removeSelectionPaths
参数：
paths - 从 selection 中移除的路径

getSelectionPath

public TreePath getSelectionPath()
返回 selection 中的第一个路径。如果当前只选择一项，则此方法非常有用。

指定者：
接口 TreeSelectionModel 中的 getSelectionPath

getSelectionPaths

public TreePath[] getSelectionPaths()
返回 selection 中的路径。如果当前没有选择任何内容，则返回 null（或一个空数组）。

指定者：
接口 TreeSelectionModel 中的 getSelectionPaths

getSelectionCount

public int getSelectionCount()
返回选择的路径数。

指定者：
接口 TreeSelectionModel 中的 getSelectionCount

isPathSelected

public boolean isPathSelected(TreePath path)
如果当前选择了路径 path，则返回 true。

指定者：
接口 TreeSelectionModel 中的 isPathSelected

isSelectionEmpty

public boolean isSelectionEmpty()
如果 selection 当前为空，则返回 true。

指定者：
接口 TreeSelectionModel 中的 isSelectionEmpty

clearSelection

public void clearSelection()
清空当前的 selection。如果这表示当前 selection 中的更改，则通知选择侦听器。

指定者：
接口 TreeSelectionModel 中的 clearSelection

addTreeSelectionListener

public void addTreeSelectionListener(TreeSelectionListener x)
向每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表添加 x。

指定者：
接口 TreeSelectionModel 中的 addTreeSelectionListener
参数：
x - 要添加的新侦听器

removeTreeSelectionListener

public void removeTreeSelectionListener(TreeSelectionListener x)
从每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表中移除 x。

指定者：
接口 TreeSelectionModel 中的 removeTreeSelectionListener
参数：
x - 要移除的侦听器

getTreeSelectionListeners

public TreeSelectionListener[] getTreeSelectionListeners()
返回已在此模型上注册的所有树选择侦听器组成的数组。

返回：
此模型的所有 TreeSelectionListener，如果当前没有已注册的树选择侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addTreeSelectionListener(javax.swing.event.TreeSelectionListener), removeTreeSelectionListener(javax.swing.event.TreeSelectionListener)

fireValueChanged

protected void fireValueChanged(TreeSelectionEvent e)
通知已注册此对象上的树选择事件的所有侦听器。

另请参见：
addTreeSelectionListener(javax.swing.event.TreeSelectionListener), EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以通过下面的代码查询 DefaultTreeSelectionModel m 的树选择侦听器：

TreeSelectionListener[] tsls = (TreeSelectionListener[])(m.getListeners(TreeSelectionListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 所请求侦听器的类型；该参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此容器上注册为 FooListener 的所有对象的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getTreeSelectionListeners(), getPropertyChangeListeners()

getSelectionRows

public int[] getSelectionRows()
返回当前已选的所有行。如果没有已选的 TreePath 或没有设置 RowMapper，此方法将返回 null（或一个空数组）。如果某些行不可见（即：对于与 TreePath 对应的行，RowMapper 返回 -1），则可能返回长度小于选择的 TreePath 长度的数组。

指定者：
接口 TreeSelectionModel 中的 getSelectionRows

getMinSelectionRow

public int getMinSelectionRow()
返回从 RowMapper 获取的已选择的 TreePath 的当前集合中的最小值。如果没有选定任何内容，或不存在 RowMapper，则返回 -1。

指定者：
接口 TreeSelectionModel 中的 getMinSelectionRow

getMaxSelectionRow

public int getMaxSelectionRow()
返回从 RowMapper 获取的已选择的 TreePath 的当前集合中的最大值。如果没有选定任何内容，或不存在 RowMapper，则返回 -1。

指定者：
接口 TreeSelectionModel 中的 getMaxSelectionRow

isRowSelected

public boolean isRowSelected(int row)
如果选择了由 row 标识的行，则返回 true。

指定者：
接口 TreeSelectionModel 中的 isRowSelected

resetRowSelection

public void resetRowSelection()
更新此对象从 TreePath 到行的映射关系。当从 TreePaths 到整数的映射关系更改时（例如，扩展了节点），应调用此方法。

通常不必调用此方法，JTree 及其相关的侦听器将为您调用它。如果您正在实现自已的 View 类，则必须调用该方法。

这将调用 insureRowContinuity，以确保当前选择的 TreePath 基于选择模式仍然有效。

指定者：
接口 TreeSelectionModel 中的 resetRowSelection

getLeadSelectionRow

public int getLeadSelectionRow()
返回 lead selection 索引。它是添加的最后一个索引。

指定者：
接口 TreeSelectionModel 中的 getLeadSelectionRow

getLeadSelectionPath

public TreePath getLeadSelectionPath()
返回添加的最后一条路径。这可能与 JTree 维护的 leadSelectionPath 属性不同。

指定者：
接口 TreeSelectionModel 中的 getLeadSelectionPath

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表。该侦听器是为所有属性注册的。

当选择模式更改时，将激发 PropertyChangeEvent。

指定者：
接口 TreeSelectionModel 中的 addPropertyChangeListener
参数：
listener - 要添加的 PropertyChangeListener

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。

指定者：
接口 TreeSelectionModel 中的 removePropertyChangeListener
参数：
listener - 要移除的 PropertyChangeListener

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回此 DefaultTreeSelectionModel 上注册的所有属性更改侦听器组成的数组。

返回：
此模型的所有 PropertyChangeListener，如果当前没有注册的属性更改侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), removePropertyChangeListener(java.beans.PropertyChangeListener)

insureRowContinuity

protected void insureRowContinuity()
确保当前选择的 TreePath 对于当前选择模式是有效的。如果选择模式为 CONTIGUOUS_TREE_SELECTION，并且 RowMapper 存在，则此方法将确保所有的行是连续的，即：排序时，所有的行都是有顺序的，并且没有间隙。如果选择不是连续的，则重设该选择，以包含在排序时连续行的第一个设置。

如果选择模式为 SINGLE_TREE_SELECTION，并且选择了多个 TreePath，则重设该选择，以包含当前选择的第一个路径。

arePathsContiguous

protected boolean arePathsContiguous(TreePath[] paths)
如果路径是连续的，或者此对象没有 RowMapper，则返回 true。

canPathsBeAdded

protected boolean canPathsBeAdded(TreePath[] paths)
用于测试是否可以添加特定的 TreePath 集合。如果 paths 为 null（或空），或此对象没有 RowMapper，或当前没有选择任何内容，或选择模式为 DISCONTIGUOUS_TREE_SELECTION，或将该路径添加到当前的 selection 仍得到 TreePath 的连续集，则此方法返回 true。

canPathsBeRemoved

protected boolean canPathsBeRemoved(TreePath[] paths)
如果可以移除该路径而不中断该模型的连续性，则返回 true。这样开销相当大。

notifyPathChange

protected void notifyPathChange(Vector<javax.swing.tree.PathPlaceHolder> changedPaths,
                                TreePath oldLeadSelection)
通知侦听器路径中的更改。changePaths 应包含 PathPlaceHolder 的实例。

updateLeadIndex

protected void updateLeadIndex()
更新 leadIndex 实例变量。

insureUniqueness

protected void insureUniqueness()
此方法已过时，并且其实现现在是一个 noop。它仍由 setSelectionPaths 和 addSelectionPaths 调用，但只是用于向后兼容。

toString

public String toString()
返回显示并标识此对象属性的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式

clone

public Object clone()
             throws CloneNotSupportedException
返回具有相同 selection 的此对象的副本。此方法不复制选择侦听器和属性侦听器。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
CloneNotSupportedException - 此类的实例从不抛出
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExpandVetoException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 ExpandVetoException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.swing.tree.ExpandVetoException
所有已实现的接口：
Serializable
public class ExpandVetoException
extends Exception

用于阻止扩展/折叠发生的异常。有关更多信息和示例，请参阅 The Java Tutorial 中的 How to Write a Tree-Will-Expand Listener 一节。

字段摘要
protected  TreeExpansionEvent event
为其创建异常的事件。
构造方法摘要
ExpandVetoException(TreeExpansionEvent event)
构造不带任何消息的 ExpandVetoException 对象。
ExpandVetoException(TreeExpansionEvent event, String message)
构造带指定消息的 ExpandVetoException 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

event

protected TreeExpansionEvent event
为其创建异常的事件。

构造方法详细信息

ExpandVetoException

public ExpandVetoException(TreeExpansionEvent event)
构造不带任何消息的 ExpandVetoException 对象。

参数：
event - TreeExpansionEvent 对象

ExpandVetoException

public ExpandVetoException(TreeExpansionEvent event,
                           String message)
构造带指定消息的 ExpandVetoException 对象。

参数：
event - TreeExpansionEvent 对象
message - 包含该消息的 String
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FixedHeightLayoutCache (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 FixedHeightLayoutCache

java.lang.Object
    继承者  javax.swing.tree.AbstractLayoutCache
        继承者  javax.swing.tree.FixedHeightLayoutCache
所有已实现的接口：
RowMapper
public class FixedHeightLayoutCache
extends AbstractLayoutCache

注：在以后的版本中，这将变得更加开放。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.tree.AbstractLayoutCache 继承的嵌套类/接口
AbstractLayoutCache.NodeDimensions
字段摘要
从类 javax.swing.tree.AbstractLayoutCache 继承的字段
nodeDimensions, rootVisible, rowHeight, treeModel, treeSelectionModel
构造方法摘要
FixedHeightLayoutCache()
方法摘要
Rectangle | getBounds(TreePath path, Rectangle placeIn) 返回给出绘制路径所需边界的矩形。
boolean | getExpandedState(TreePath path) 如果该路径已扩展，并且可见，则返回 true。
TreePath | getPathClosestTo(int x, int y) 返回最接近 x,y 的节点的路径。
TreePath | getPathForRow(int row) 返回传入行的路径。
int | getRowCount() 返回可视的行数。
int | getRowForPath(TreePath path) 返回路径中标识的最后一项可见的行。
int | getVisibleChildCount(TreePath path) 返回行的可见子对象数。
Enumeration<TreePath> | getVisiblePathsFrom(TreePath path) 返回表示从传入位置开始的可见路径的增量的 Enumerator。
void | invalidatePathBounds(TreePath path) 不执行任何操作，FixedHeightLayoutCache 不缓存宽度（即所有可以更改的宽度）。
void | invalidateSizes() 通知 TreeState 需要重新计算它引用的所有大小。
boolean | isExpanded(TreePath path) 如果当前扩展了由行标识的值，则返回 true。
void | setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的扩展状态标记为 isExpanded。
void | setModel(TreeModel newModel) 设置将提供数据的 TreeModel。
void | setRootVisible(boolean rootVisible) 确定 TreeModel 的根节点是否可见。
void | setRowHeight(int rowHeight) 设置每个单元格的高度。
void | treeNodesChanged(TreeModelEvent e) 在已经以某种方式更改节点（或同级节点集）后调用。
void | treeNodesInserted(TreeModelEvent e) 将节点插入树之后进行调用。
void | treeNodesRemoved(TreeModelEvent e) 将节点从树移除之后进行调用。
void | treeStructureChanged(TreeModelEvent e) 树彻底更改给定节点以下的结构之后进行调用。
从类 javax.swing.tree.AbstractLayoutCache 继承的方法
getModel, getNodeDimensions, getNodeDimensions, getPreferredHeight, getPreferredWidth, getRowHeight, getRowsForPaths, getSelectionModel, isFixedRowHeight, isRootVisible, setNodeDimensions, setSelectionModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FixedHeightLayoutCache

public FixedHeightLayoutCache()
方法详细信息

setModel

public void setModel(TreeModel newModel)
设置将提供数据的 TreeModel。

覆盖：
类 AbstractLayoutCache 中的 setModel
参数：
newModel - 将提供数据的 TreeModel

setRootVisible

public void setRootVisible(boolean rootVisible)
确定 TreeModel 的根节点是否可见。

覆盖：
类 AbstractLayoutCache 中的 setRootVisible
参数：
rootVisible - 如果将显示树的根节点，则为 true
另请参见：
AbstractLayoutCache.rootVisible

setRowHeight

public void setRowHeight(int rowHeight)
设置每个单元格的高度。如果 rowHeight 小于或等于 0，则将抛出 IllegalArgumentException。

覆盖：
类 AbstractLayoutCache 中的 setRowHeight
参数：
rowHeight - 每个单元格的高度（以像素为单位）

getRowCount

public int getRowCount()
返回可视的行数。

指定者：
类 AbstractLayoutCache 中的 getRowCount
返回：
显示的行数

invalidatePathBounds

public void invalidatePathBounds(TreePath path)
不执行任何操作，FixedHeightLayoutCache 不缓存宽度（即所有可以更改的宽度）。

指定者：
类 AbstractLayoutCache 中的 invalidatePathBounds
参数：
path - 正在被更新的路径

invalidateSizes

public void invalidateSizes()
通知 TreeState 需要重新计算它引用的所有大小。

指定者：
类 AbstractLayoutCache 中的 invalidateSizes

isExpanded

public boolean isExpanded(TreePath path)
如果当前扩展了由行标识的值，则返回 true。

指定者：
类 AbstractLayoutCache 中的 isExpanded

getBounds

public Rectangle getBounds(TreePath path,
                           Rectangle placeIn)
返回给出绘制路径所需边界的矩形。

指定者：
类 AbstractLayoutCache 中的 getBounds
参数：
path - 指定节点的 TreePath
placeIn - 提供可用空间的 Rectangle 对象
返回：
指定要使用的空间的 Rectangle 对象

getPathForRow

public TreePath getPathForRow(int row)
返回传入行的路径。如果行不可见，则返回 null。

指定者：
类 AbstractLayoutCache 中的 getPathForRow
参数：
row - 查询的行
返回：
给定的行的 TreePath

getRowForPath

public int getRowForPath(TreePath path)
返回路径中标识的最后一项可见的行。如果路径中任何元素当前不可见，则返回 -1。

指定者：
类 AbstractLayoutCache 中的 getRowForPath
参数：
path - 查询的 TreePath
返回：
路径中最后一项可视的行，如果路径中任何元素当前不可视，则返回 -1

getPathClosestTo

public TreePath getPathClosestTo(int x,
                                 int y)
返回最接近 x,y 的节点的路径。如果当前没有任何可见的内容，则返回 null，否则，始终返回一个有效路径。如果需要测试返回的对象是否正好位于 x, y，您应获取返回路径的边界，并根据它测试 x, y。

指定者：
类 AbstractLayoutCache 中的 getPathClosestTo
参数：
x - 所需位置的水平组件
y - 所需位置的垂直组件
返回：
最接近指定点的 TreePath

getVisibleChildCount

public int getVisibleChildCount(TreePath path)
返回行的可见子对象数。

指定者：
类 AbstractLayoutCache 中的 getVisibleChildCount
参数：
path - 正被查询的路径
返回：
指定路径的可视子节点数

getVisiblePathsFrom

public Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
返回表示从传入位置开始的可见路径的增量的 Enumerator。该枚举的排序基于路径的显示方式。

指定者：
类 AbstractLayoutCache 中的 getVisiblePathsFrom
参数：
path - 枚举的起始位置
返回：
在所需位置开始的 Enumerator

setExpandedState

public void setExpandedState(TreePath path,
                             boolean isExpanded)
将路径 path 的扩展状态标记为 isExpanded。

指定者：
类 AbstractLayoutCache 中的 setExpandedState
参数：
path - 正在被扩展或折叠的路径
isExpanded - 如果应该扩展路径，则为 true，否则为 false

getExpandedState

public boolean getExpandedState(TreePath path)
如果该路径已扩展，并且可见，则返回 true。

指定者：
类 AbstractLayoutCache 中的 getExpandedState
参数：
path - 正在被查询的路径
返回：
如果路径已扩展并且可视，则返回 true，否则返回 false

treeNodesChanged

public void treeNodesChanged(TreeModelEvent e)

在已经以某种方式更改节点（或同级节点集）后调用。没有更改节点在树中的位置，也没有改变他们的子数组，但是其他的属性已更改，并且可能影响表示形式。示例：文件的名称已更改，但是它在文件系统中的位置不变。

e.path() 返回已更改节点的父节点的路径。

e.childIndices() 返回更改节点的索引。

指定者：
类 AbstractLayoutCache 中的 treeNodesChanged
参数：
e - TreeModelEvent

treeNodesInserted

public void treeNodesInserted(TreeModelEvent e)

将节点插入树之后进行调用。

e.path() 返回新节点的父节点

e.childIndices() 按升序返回新节点的索引。

指定者：
类 AbstractLayoutCache 中的 treeNodesInserted
参数：
e - TreeModelEvent

treeNodesRemoved

public void treeNodesRemoved(TreeModelEvent e)

将节点从树移除之后进行调用。注意，如果从树移除子树，则对于移除的子树的根而言，此方法仅调用一次，对于移除的每个兄弟子树集而言，则不是一次。

e.path() 返回删除节点的前一个父节点。

e.childIndices() 返回节点按升序删除之前具有的索引。

指定者：
类 AbstractLayoutCache 中的 treeNodesRemoved
参数：
e - TreeModelEvent

treeStructureChanged

public void treeStructureChanged(TreeModelEvent e)

树彻底更改给定节点以下的结构之后进行调用。如果 e.getPath() 返回的路径长度为一，并且第一个元素不标识当前根节点，则第一个元素应成为树的新根节点。

e.path() 保持节点的路径。

e.childIndices() 返回 null。

指定者：
类 AbstractLayoutCache 中的 treeStructureChanged
参数：
e - TreeModelEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MutableTreeNode (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
接口 MutableTreeNode

所有超级接口：
TreeNode
所有已知实现类：
DefaultMutableTreeNode, JTree.DynamicUtilTreeNode
public interface MutableTreeNode
extends TreeNode

定义针对树节点对象的要求，这些树节点可以通过以下操作更改：添加或移除子节点，或更改该节点中存储的用户对象的内容。

另请参见：
DefaultMutableTreeNode, JTree

方法摘要
void | insert(MutableTreeNode child, int index) 将 child 添加到 index 位置的接收者。
void | remove(int index) 从接收者移除 index 位置的子节点。
void | remove(MutableTreeNode node) 从接收者移除 node。
void | removeFromParent() 从其父对象移除接收者。
void | setParent(MutableTreeNode newParent) 将接收者的父对象设置为 newParent。
void | setUserObject(Object object) 将接收者的用户对象重新设置为 object。
从接口 javax.swing.tree.TreeNode 继承的方法
children, getAllowsChildren, getChildAt, getChildCount, getIndex, getParent, isLeaf

方法详细信息

insert

void insert(MutableTreeNode child,
            int index)
将 child 添加到 index 位置的接收者。child 通过 setParent 接收消息。

remove

void remove(int index)
从接收者移除 index 位置的子节点。

remove

void remove(MutableTreeNode node)
从接收者移除 node。对 node 发送 setParent 消息。

setUserObject

void setUserObject(Object object)
将接收者的用户对象重新设置为 object。

removeFromParent

void removeFromParent()
从其父对象移除接收者。

setParent

void setParent(MutableTreeNode newParent)
将接收者的父对象设置为 newParent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowMapper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
接口 RowMapper

所有已知实现类：
AbstractLayoutCache, FixedHeightLayoutCache, VariableHeightLayoutCache
public interface RowMapper

定义针对将树中的路径转换为显示行的对象的要求。

方法摘要
 int[] getRowsForPaths(TreePath[] path)
返回显示 path 中的 TreePath 实例的行。

方法详细信息

getRowsForPaths

int[] getRowsForPaths(TreePath[] path)
返回显示 path 中的 TreePath 实例的行。该接收者应返回与传入数组长度相同的数组，如果 path 中的 TreePath 之一无效，则应将该数组中的条目设置为 -1。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeCellEditor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
接口 TreeCellEditor

所有超级接口：
CellEditor
所有已知实现类：
DefaultCellEditor, DefaultTreeCellEditor
public interface TreeCellEditor
extends CellEditor

向 CellEditor 添加配置树中编辑器必需的扩展。

另请参见：
JTree

方法摘要
 Component getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
设置编辑器的初始值。
从接口 javax.swing.CellEditor 继承的方法
addCellEditorListener, cancelCellEditing, getCellEditorValue, isCellEditable, removeCellEditorListener, shouldSelectCell, stopCellEditing

方法详细信息

getTreeCellEditorComponent

Component getTreeCellEditorComponent(JTree tree,
                                     Object value,
                                     boolean isSelected,
                                     boolean expanded,
                                     boolean leaf,
                                     int row)
设置编辑器的初始值。如果在该编辑器正在编辑时调用此方法，则将导致编辑器停止编辑，并丢失所有未编辑完的值。

返回应添加到客户机的 Component 层次结构的组件。一旦在客户机的层次结构中进行了安装，此组件就能够绘制和接收用户输入。

参数：
tree - 要请求编辑器进行编辑的 JTree；此参数可以为 null
value - 要编辑的单元格的值
isSelected - 如果将呈现单元格并在选择时高亮显示，则为 true
expanded - 如果该节点被扩展，则为 true
leaf - 如果该节点是叶节点，则为 true
row - 正在编辑的节点的行索引
返回：
用于编辑的组件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeCellRenderer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
接口 TreeCellRenderer

所有已知实现类：
DefaultTreeCellRenderer
public interface TreeCellRenderer

定义针对显示树节点的对象的要求。有关实现显示自定义图标的树单元格渲染器的示例，请参阅 The Java Tutorial 中的 How to Use Trees 一节。

方法摘要
 Component getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
将当前树单元格的值设置为 value。

方法详细信息

getTreeCellRendererComponent

Component getTreeCellRendererComponent(JTree tree,
                                       Object value,
                                       boolean selected,
                                       boolean expanded,
                                       boolean leaf,
                                       int row,
                                       boolean hasFocus)
将当前树单元格的值设置为 value。如果 selected 为 true，则将单元格作为已选择的单元格进行绘制。如果 expanded 为 true，则当前扩展该节点，如果 leaf 为 true，则该节点表示叶节点，如果 hasFocus 为 true，则该节点当前拥有焦点。tree 是为其配置接收者的 JTree。返回渲染器用来绘制值的 Component。

TreeCellRenderer 也负责呈现表示树当前 DnD 放置位置的单元格（如果有）。如果此渲染器关心呈现 DnD 放置位置，则它应该直接查询该树以查看给定行是否表示放置位置：

     JTree.DropLocation dropLocation = tree.getDropLocation();
     if (dropLocation != null
             && dropLocation.getChildIndex() == -1
             && tree.getRowForPath(dropLocation.getPath()) == row) {

         // this row represents the current drop location
         // so render it specially, perhaps with a different color
     }

返回：
渲染器用来绘制值的 Component
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
接口 TreeModel

所有已知实现类：
DefaultTreeModel
public interface TreeModel

JTree 所使用的模型。

JTree 及其相关类大量使用了 TreePath，以标识 TreeModel 中的节点。如果 TreeModel 返回相同的对象（使用 equals 比较同一父节点下的两个不同索引的节点），那么产生的 TreePath 对象也被认为是相等的。某些实现可以假定，如果两个 TreePath 相等，则它们标识的节点也相等。如果不能满足此条件，则可能导致绘制问题和其他奇怪的问题。换句话说，如果对给定父节点调用 getChild 返回相同的 Object（由 equals 确定），则可能出现问题，建议您不要执行此操作。

类似地，JTree 及其相关类将 TreePath 置于 Map 中。因此，如果两次请求一个节点，则其返回值必须相等（使用 equals 方法）并且具有相同的 hashCode。

有关树模型的更多信息（包括自定义实现的示例），请参阅 The Java Tutorial 中的 How to Use Trees。

另请参见：
TreePath

方法摘要
void | addTreeModelListener(TreeModelListener l) 为树更改后发布的 TreeModelEvent 添加侦听器。
Object | getChild(Object parent, int index) 返回父节点的子数组中索引 index 位置的 parent 的子节点。
int | getChildCount(Object parent) 返回 parent 的子节点数。
int | getIndexOfChild(Object parent, Object child) 返回父节点中子节点的索引。
Object | getRoot() 返回树的根。
boolean | isLeaf(Object node) 如果 node 为叶节点，则返回 true。
void | removeTreeModelListener(TreeModelListener l) 移除以前通过 addTreeModelListener 添加的侦听器。
void | valueForPathChanged(TreePath path, Object newValue) 用户已将 path 标识的项的值更改为 newValue 时，进行通知。

方法详细信息

getRoot

Object getRoot()
返回树的根。仅当树没有节点时，才返回 null。

返回：
树的根

getChild

Object getChild(Object parent,
                int index)
返回父节点的子数组中索引 index 位置的 parent 的子节点。parent 必须是以前从此数据源获取的节点。如果 index 是 parent 的一个有效索引（即：index >= 0 && index < getChildCount(parent)），则此方法不应返回 null。

参数：
parent - 从此数据源获取的树中的节点
返回：
索引 index 位置的 parent 的子节点

getChildCount

int getChildCount(Object parent)
返回 parent 的子节点数。如果该节点为叶节点，或者它没有子节点，则返回 0。parent 必须是以前从此数据源获取的节点。

参数：
parent - 从此数据源获取的树中的节点
返回：
节点 parent 的子节点数

isLeaf

boolean isLeaf(Object node)
如果 node 为叶节点，则返回 true。即使 node 没有子节点，此方法也可能返回 false。例如，文件系统中的目录可以不包含任何文件；表示该目录的节点不是叶节点，但是它也没有任何子节点。

参数：
node - 从此数据源获取的树中的节点
返回：
如果 node 为叶节点，则返回 true

valueForPathChanged

void valueForPathChanged(TreePath path,
                         Object newValue)
用户已将 path 标识的项的值更改为 newValue 时，进行通知。如果 newValue 表示一个真实的新值，则该模型应发布一个 treeNodesChanged 事件。

参数：
path - 用户已更改的节点的路径
newValue - TreeCellEditor 的新值

getIndexOfChild

int getIndexOfChild(Object parent,
                    Object child)
返回父节点中子节点的索引。如果 parent 或 child 为 null，则返回 -1。如果 parent 或 child 不属于此树模型，则返回 -1。

参数：
parent - 从此数据源获取的树中的节点
child - 相关的节点
返回：
父节点中子节点的索引，如果 child 或 parent 为 null，或不属于此树模型，则返回 -1

addTreeModelListener

void addTreeModelListener(TreeModelListener l)
为树更改后发布的 TreeModelEvent 添加侦听器。

参数：
l - 要添加的侦听器
另请参见：
removeTreeModelListener(javax.swing.event.TreeModelListener)

removeTreeModelListener

void removeTreeModelListener(TreeModelListener l)
移除以前通过 addTreeModelListener 添加的侦听器。

参数：
l - 要移除的侦听器
另请参见：
addTreeModelListener(javax.swing.event.TreeModelListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeNode (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
接口 TreeNode

所有已知子接口：
MutableTreeNode
所有已知实现类：
AbstractDocument.AbstractElement, AbstractDocument.BranchElement, AbstractDocument.LeafElement, DefaultMutableTreeNode, DefaultStyledDocument.SectionElement, HTMLDocument.BlockElement, HTMLDocument.RunElement, JTree.DynamicUtilTreeNode
public interface TreeNode

定义可以用作 JTree 中树节点的对象所需的要求。

重写 equals 的 TreeNode 的实现通常也需要重写 hashCode。有关更多信息，请参阅 TreeModel。 有关使用树节点的更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Tree Nodes。

方法摘要
Enumeration | children() 以 Enumeration 的形式返回接收者的子节点。
boolean | getAllowsChildren() 如果接收者允许有子节点，则返回 true。
TreeNode | getChildAt(int childIndex) 返回索引 childIndex 位置的子 TreeNode。
int | getChildCount() 返回接收者包含的子 TreeNode 数。
int | getIndex(TreeNode node) 返回接收者子节点中的 node 的索引。
TreeNode | getParent() 返回接收者的父 TreeNode。
boolean | isLeaf() 如果接收者是一个叶节点，则返回 true。

方法详细信息

getChildAt

TreeNode getChildAt(int childIndex)
返回索引 childIndex 位置的子 TreeNode。

getChildCount

int getChildCount()
返回接收者包含的子 TreeNode 数。

getParent

TreeNode getParent()
返回接收者的父 TreeNode。

getIndex

int getIndex(TreeNode node)
返回接收者子节点中的 node 的索引。如果接收者不包含 node，则返回 -1。

getAllowsChildren

boolean getAllowsChildren()
如果接收者允许有子节点，则返回 true。

isLeaf

boolean isLeaf()
如果接收者是一个叶节点，则返回 true。

children

Enumeration children()
以 Enumeration 的形式返回接收者的子节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreePath (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 TreePath

java.lang.Object
    继承者  javax.swing.tree.TreePath
所有已实现的接口：
Serializable
public class TreePath
extends Object
implements Serializable

表示节点的路径。TreePath 是 TreeModel 提供的 Objects 的数组。对数组的元素进行排序，使根始终是数组的第一个元素 (index 为 0)。TreePath 是可序列化的，但是如果该路径的任何组件不可序列化，则它将不能写出。

有关使用树路径的更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Trees 一节。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
protected | TreePath() 主要为以不同方式表示路径的子类提供。
 | TreePath(Object singlePath) 构造仅包含单个元素的 TreePath。
 | TreePath(Object[] path) 根据 Objects 的数组构造路径，并根据树的数据模型的返回情况，唯一地标识树的根到指定节点的路径。
protected | TreePath(Object[] path, int length) 构造一个具有长度为 length 的标识路径组件的新 TreePath。
protected | TreePath(TreePath parent, Object lastElement) 构造一个新的 TreePath，它是以 lastElement 结束的 parent 标识的路径。
方法摘要
boolean | equals(Object o) 通过检查路径中每个元素的相等性，测试两个 TreePaths 的相等性。
Object | getLastPathComponent() 返回此路径的最后一个组件。
TreePath | getParentPath() 返回包含除最后一个路径组件之外的此对象所有元素的路径。
Object[] | getPath() 返回有序的 Objects 数组，它包含此 TreePath 的组件。
Object | getPathComponent(int element) 返回指定索引位置的路径组件。
int | getPathCount() 返回路径中的元素数。
int | hashCode() 返回该对象的 hashCode。
boolean | isDescendant(TreePath aTreePath) 如果 aTreePath 为此 TreePath 的后代，则返回 true。
TreePath | pathByAddingChild(Object child) 返回包含此对象的所有元素加上 child 的新路径。
String | toString() 返回一个显示并标识此对象属性的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

TreePath

public TreePath(Object[] path)
根据 Objects 的数组构造路径，并根据树的数据模型的返回情况，唯一地标识树的根到指定节点的路径。

该模型可自由地返回需要表示该路径的任何 Objects 的数组。DefaultTreeModel 返回 TreeNode 对象的数组。该路径中的第一个 TreeNode 是树的根，最后一个 TreeNode 是该路径标识的节点。

参数：
path - 表示节点路径的 Objects 数组

TreePath

public TreePath(Object singlePath)
构造仅包含单个元素的 TreePath。这通常用于构造 TreeModel 的根的 TreePath。

参数：
singlePath - 表示节点路径的 Object
另请参见：
TreePath(Object[])

TreePath

protected TreePath(TreePath parent,
                   Object lastElement)
构造一个新的 TreePath，它是以 lastElement 结束的 parent 标识的路径。

TreePath

protected TreePath(Object[] path,
                   int length)
构造一个具有长度为 length 的标识路径组件的新 TreePath。

TreePath

protected TreePath()
主要为以不同方式表示路径的子类提供。如果子类使用此构造方法，则它还应重写 getPath、getPathCount 和 getPathComponent 方法，并可能重写 equals 方法。

方法详细信息

getPath

public Object[] getPath()
返回有序的 Objects 数组，它包含此 TreePath 的组件。第一个元素 (index 为 0) 是根。

返回：
表示 TreePath 的 Objects 的数组
另请参见：
TreePath(Object[])

getLastPathComponent

public Object getLastPathComponent()
返回此路径的最后一个组件。对于 DefaultTreeModel 返回的路径，它将返回一个 TreeNode 实例。

返回：
该路径结尾处的 Object
另请参见：
TreePath(Object[])

getPathCount

public int getPathCount()
返回路径中的元素数。

返回：
给出路径项计数的 int

getPathComponent

public Object getPathComponent(int element)
返回指定索引位置的路径组件。

参数：
element - 指定路径中元素的 int，其中 0 表示路径中的第一个元素
返回：
该索引位置的 Object
抛出：
IllegalArgumentException - 如果索引超过路径的长度
另请参见：
TreePath(Object[])

equals

public boolean equals(Object o)
通过检查路径中每个元素的相等性，测试两个 TreePaths 的相等性。如果两个路径等长，并且包含相同的元素 (.equals)，则认为它们相等。

覆盖：
类 Object 中的 equals
参数：
o - 要比较的 Object
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回该对象的 hashCode。TreePath 的哈希代码被定义为路径中最后一个组件的哈希代码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的 hashCode
另请参见：
Object.equals(java.lang.Object), Hashtable

isDescendant

public boolean isDescendant(TreePath aTreePath)
如果 aTreePath 为此 TreePath 的后代，则返回 true。如果 P1 包含组成 P2 路径的所有组件，则 TreePath P1 是 TreePath P2 的后代。例如，如果此对象具有路径 [a, b]，并且 aTreePath 具有路径 [a, b, c]，那么 aTreePath 为此对象的后代。但是，如果 aTreePath 具有路径 [a]，那么它不是此对象的后代。按照此定义，TreePath 始终被视为其自身的后代。也就是说，aTreePath.isDescendant(aTreePath) 返回 true。

返回：
如果 aTreePath 为此路径的后代，则返回 true

pathByAddingChild

public TreePath pathByAddingChild(Object child)
返回包含此对象的所有元素加上 child 的新路径。child 将是新创建的 TreePath 的最后一个元素。如果子对象为 null，将抛出 NullPointerException。

getParentPath

public TreePath getParentPath()
返回包含除最后一个路径组件之外的此对象所有元素的路径。

toString

public String toString()
返回一个显示并标识此对象属性的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeSelectionModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
接口 TreeSelectionModel

所有已知实现类：
DefaultTreeSelectionModel, JTree.EmptySelectionModel
public interface TreeSelectionModel

此接口表示树选择组件的当前状态。有关使用树选择模型的信息和示例，请参阅 The Java Tutorial 中的 How to Use Trees 一节。

树选择的状态由 TreePath 集合描述，也可以是整数集合。从 TreePath 到整数的映射通过 RowMapper 实例的方式完成。TreeSelectionModel 不一定具有 RowMapper 才可以正确地操作，但是，没有 RowMapper 的情况下，getSelectionRows 将返回 null。

可以将 TreeSelectionModel 配置为只允许一条路径 (SINGLE_TREE_SELECTION)、多条连续路径 (CONTIGUOUS_TREE_SELECTION) 或多条不连续的路径 (DISCONTIGUOUS_TREE_SELECTION)。RowMapper 用于确定 TreePath 是否为连续。没有 RowMapper 时，CONTIGUOUS_TREE_SELECTION 和 DISCONTIGUOUS_TREE_SELECTION 的功能相同，即都允许在 TreeSelectionModel 中包含任何数量的路径。

对于 CONTIGUOUS_TREE_SELECTION 选择模型，路径在任何时候更改时（通过 setSelectionPath、addSelectionPath ...），都将重新检查 TreePath，以使它们保持连续。通过调用 resetRowSelection，也可以强制检查 TreePath。如何将一组不连续的 TreePath 映射到连续集合要通过此实例的实现者强制执行特定的策略来完成。

实现应对添加到该选择中的重复 TreePath 进行组合。例如，以下代码

   TreePath[] paths = new TreePath[] { treePath, treePath };
   treeSelectionModel.setSelectionPaths(paths);
会导致仅选择一个路径：treePath，而不是 treePath 的两个副本。

前导 TreePath 是添加（或设置）的最后一个路径。前导行则是对应于 TreePath 的行，由 RowMapper 确定。

字段摘要
static int | CONTIGUOUS_TREE_SELECTION 选择只能是连续的。
static int | DISCONTIGUOUS_TREE_SELECTION 选择可以包含任何数量的项，这些项不必是连续的。
static int | SINGLE_TREE_SELECTION 一次只能选择一个路径。
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | addSelectionPath(TreePath path) 将路径添加到当前的选择中。
void | addSelectionPaths(TreePath[] paths) 向当前的选择中添加路径。
void | addTreeSelectionListener(TreeSelectionListener x) 向侦听器列表添加 x，每次选定的 TreePath 集合发生更改时，这些侦听器都会得到通知。
void | clearSelection() 清空当前的选择。
TreePath | getLeadSelectionPath() 返回添加的最后一个路径。
int | getLeadSelectionRow() 返回前导选择索引。
int | getMaxSelectionRow() 返回从 RowMapper 获取的已选的 TreePath 当前集合中的最大值。
int | getMinSelectionRow() 返回从 RowMapper 获取的已选的 TreePath 当前集合中的最小值。
RowMapper | getRowMapper() 返回能够将 TreePath 映射到行的 RowMapper 实例。
int | getSelectionCount() 返回选择的路径数。
int | getSelectionMode() 返回当前选择的模式（SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一）。
TreePath | getSelectionPath() 返回选择中的第一个路径。
TreePath[] | getSelectionPaths() 返回选择中的路径。
int[] | getSelectionRows() 返回所有当前已选的行。
boolean | isPathSelected(TreePath path) 如果路径 path 在当前的选择中，则返回 true。
boolean | isRowSelected(int row) 如果选择了由 row 标识的行，则返回 true。
boolean | isSelectionEmpty() 如果选择当前为空，则返回 true。
void | removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
void | removeSelectionPath(TreePath path) 从选择中移除路径。
void | removeSelectionPaths(TreePath[] paths) 从选择中移除路径。
void | removeTreeSelectionListener(TreeSelectionListener x) 从每次已选的 TreePath 集合发生更改时都会得到通知的侦听器列表中移除 x。
void | resetRowSelection() 更新此对象从 TreePath 到行的映射关系。
void | setRowMapper(RowMapper newMapper) 设置 RowMapper 实例。
void | setSelectionMode(int mode) 设置选择模型，它必须是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一。
void | setSelectionPath(TreePath path) 为该选择设置路径。
void | setSelectionPaths(TreePath[] paths) 为该选择设置路径。

字段详细信息

SINGLE_TREE_SELECTION

static final int SINGLE_TREE_SELECTION
一次只能选择一个路径。

另请参见：
常量字段值

CONTIGUOUS_TREE_SELECTION

static final int CONTIGUOUS_TREE_SELECTION
选择只能是连续的。仅当提供 RowMapper 实例时，这才被强制执行。即：如果不设置任何 RowMapper，它的功能与 DISCONTIGUOUS_TREE_SELECTION 相同。

另请参见：
常量字段值

DISCONTIGUOUS_TREE_SELECTION

static final int DISCONTIGUOUS_TREE_SELECTION
选择可以包含任何数量的项，这些项不必是连续的。

另请参见：
常量字段值
方法详细信息

setSelectionMode

void setSelectionMode(int mode)
设置选择模型，它必须是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一。

如果对于新的模式当前选择无效，则此方法可以更改这一选择。例如，如果将模式更改为 SINGLE_TREE_SELECTION 时选中三个 TreePath，则只有一个 TreePath 仍然被选中。由特定的实现来决定保留选定哪一个 TreePath。

getSelectionMode

int getSelectionMode()
返回当前选择的模式（SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一）。

setSelectionPath

void setSelectionPath(TreePath path)
为该选择设置路径。如果这表示一个更改，则通知 TreeSelectionListener。如果 path 为 null，则这与调用 clearSelection 具有相同的效果。

参数：
path - 要选择的新路径

setSelectionPaths

void setSelectionPaths(TreePath[] paths)
为该选择设置路径。如果这表示一个更改，则通知 TreeSelectionListener。如果 paths 为 null，则这与调用 clearSelection 具有相同的效果。

参数：
paths - 新的选择

addSelectionPath

void addSelectionPath(TreePath path)
将路径添加到当前的选择中。如果路径当前不在选择中，则通知 TreeSelectionListener。如果 path 为 null，则此方法无效。

参数：
path - 添加到当前选择中的新路径

addSelectionPaths

void addSelectionPaths(TreePath[] paths)
向当前的选择中添加路径。如果 paths 中的任何路径当前不在选择中，则通知 TreeSelectionListener。如果 paths 为 null，则通此方法无效。

参数：
paths - 添加到当前选择的新路径

removeSelectionPath

void removeSelectionPath(TreePath path)
从选择中移除路径。如果路径在选择中，则通知 TreeSelectionListener。如果 path 为 null，则此方法无效。

参数：
path - 要从选择中移除的路径

removeSelectionPaths

void removeSelectionPaths(TreePath[] paths)
从选择中移除路径。如果 paths 中的任何路径在选择中，则通知 TreeSelectionListener。如果 paths 为 null，则此方法无效。

参数：
paths - 要从选择中移除的路径

getSelectionPath

TreePath getSelectionPath()
返回选择中的第一个路径。第一个路径由实现者定义，不一定是由 RowMapper 确定的具有最小整数值的 TreePath。

getSelectionPaths

TreePath[] getSelectionPaths()
返回选择中的路径。如果当前没有选择任何内容，则返回 null（或一个空数组）。

getSelectionCount

int getSelectionCount()
返回选择的路径数。

isPathSelected

boolean isPathSelected(TreePath path)
如果路径 path 在当前的选择中，则返回 true。

isSelectionEmpty

boolean isSelectionEmpty()
如果选择当前为空，则返回 true。

clearSelection

void clearSelection()
清空当前的选择。如果这表示当前选择中的更改，则通知选择侦听器。

setRowMapper

void setRowMapper(RowMapper newMapper)
设置 RowMapper 实例。此实例用于确定特定 TreePath 的行。

getRowMapper

RowMapper getRowMapper()
返回能够将 TreePath 映射到行的 RowMapper 实例。

getSelectionRows

int[] getSelectionRows()
返回所有当前已选的行。如果没有已选的 TreePath 或没有设置 RowMapper，此方法将返回 null（或一个空数组）。

getMinSelectionRow

int getMinSelectionRow()
返回从 RowMapper 获取的已选的 TreePath 当前集合中的最小值。如果没有选定任何内容，或不存在 RowMapper，则返回 -1。

getMaxSelectionRow

int getMaxSelectionRow()
返回从 RowMapper 获取的已选的 TreePath 当前集合中的最大值。如果没有选定任何内容，或不存在 RowMapper，则返回 -1。

isRowSelected

boolean isRowSelected(int row)
如果选择了由 row 标识的行，则返回 true。

resetRowSelection

void resetRowSelection()
更新此对象从 TreePath 到行的映射关系。当从 TreePath 到整数的映射发生更改时（例如，扩展了某个节点），应调用此方法。

通常不必调用此方法；JTree 及其相关的侦听器将为您调用它。如果您正在实现自已的 view 类，则必须调用它。

getLeadSelectionRow

int getLeadSelectionRow()
返回前导选择索引。它是添加的最后一个索引。

getLeadSelectionPath

TreePath getLeadSelectionPath()
返回添加的最后一个路径。这可能与 JTree 维护的 leadSelectionPath 属性不同。

addPropertyChangeListener

void addPropertyChangeListener(PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到侦听器列表中。该侦听器是为所有属性注册的。

当选择模式更改时，将触发 PropertyChangeEvent。

参数：
listener - 要添加的 PropertyChangeListener

removePropertyChangeListener

void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。

参数：
listener - 要移除的 PropertyChangeListener

addTreeSelectionListener

void addTreeSelectionListener(TreeSelectionListener x)
向侦听器列表添加 x，每次选定的 TreePath 集合发生更改时，这些侦听器都会得到通知。

参数：
x - 要添加的新侦听器

removeTreeSelectionListener

void removeTreeSelectionListener(TreeSelectionListener x)
从每次已选的 TreePath 集合发生更改时都会得到通知的侦听器列表中移除 x。

参数：
x - 要移除的侦听器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VariableHeightLayoutCache (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.tree
类 VariableHeightLayoutCache

java.lang.Object
    继承者  javax.swing.tree.AbstractLayoutCache
        继承者  javax.swing.tree.VariableHeightLayoutCache
所有已实现的接口：
RowMapper
public class VariableHeightLayoutCache
extends AbstractLayoutCache

注：在以后的版本中，此类将变得更加开放。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.tree.AbstractLayoutCache 继承的嵌套类/接口
AbstractLayoutCache.NodeDimensions
字段摘要
从类 javax.swing.tree.AbstractLayoutCache 继承的字段
nodeDimensions, rootVisible, rowHeight, treeModel, treeSelectionModel
构造方法摘要
VariableHeightLayoutCache()
方法摘要
Rectangle | getBounds(TreePath path, Rectangle placeIn) 返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
boolean | getExpandedState(TreePath path) 如果路径已扩展，并且可见，则返回 true。
TreePath | getPathClosestTo(int x, int y) 返回最接近 x,y 的节点的路径。
TreePath | getPathForRow(int row) 返回 row 的路径。
int | getPreferredHeight() 返回首选高度。
int | getPreferredWidth(Rectangle bounds) 返回 visibleRegion 中区域的首选宽度和高度。
int | getRowCount() 返回可见的行数。
int | getRowForPath(TreePath path) 返回路径中标识的最后一项在其中可见的行。
int | getVisibleChildCount(TreePath path) 返回 path 的可见子路径数。
Enumeration<TreePath> | getVisiblePathsFrom(TreePath path) 返回从传入位置开始的可见路径的增量的 Enumerator。
void | invalidatePathBounds(TreePath path) 指示 LayoutCache path 的边界无效，需要更新。
void | invalidateSizes() 通知 TreeState 需要重新计算它引用的所有大小。
boolean | isExpanded(TreePath path) 如果当前扩展了 path 标识的值，则返回 true。
void | setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的扩展状态标记为 isExpanded。
void | setModel(TreeModel newModel) 设置将提供数据的 TreeModel。
void | setNodeDimensions(AbstractLayoutCache.NodeDimensions nd) 设置负责绘制树中节点的渲染器。
void | setRootVisible(boolean rootVisible) 确定 TreeModel 的根节点是否可见。
void | setRowHeight(int rowHeight) 设置每个单元格的高度。
void | treeNodesChanged(TreeModelEvent e) 按某种方式更改节点（或兄弟节点集）后进行调用。
void | treeNodesInserted(TreeModelEvent e) 将节点插入树后进行调用。
void | treeNodesRemoved(TreeModelEvent e) 将节点从树删除后进行调用。
void | treeStructureChanged(TreeModelEvent e) 树彻底更改给定节点以下的结构之后进行调用。
从类 javax.swing.tree.AbstractLayoutCache 继承的方法
getModel, getNodeDimensions, getNodeDimensions, getRowHeight, getRowsForPaths, getSelectionModel, isFixedRowHeight, isRootVisible, setSelectionModel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VariableHeightLayoutCache

public VariableHeightLayoutCache()
方法详细信息

setModel

public void setModel(TreeModel newModel)
设置将提供数据的 TreeModel。

覆盖：
类 AbstractLayoutCache 中的 setModel
参数：
newModel - 将提供数据的 TreeModel

setRootVisible

public void setRootVisible(boolean rootVisible)
确定 TreeModel 的根节点是否可见。

覆盖：
类 AbstractLayoutCache 中的 setRootVisible
参数：
rootVisible - 如果将显示树的根节点，则为 true
另请参见：
AbstractLayoutCache.rootVisible

setRowHeight

public void setRowHeight(int rowHeight)
设置每个单元格的高度。如果指定的值小于或等于零，则会查询当前单元格渲染器以获取每行高度。

覆盖：
类 AbstractLayoutCache 中的 setRowHeight
参数：
rowHeight - 每个单元格的高度（以像素为单位）

setNodeDimensions

public void setNodeDimensions(AbstractLayoutCache.NodeDimensions nd)
设置负责绘制树中节点的渲染器。

覆盖：
类 AbstractLayoutCache 中的 setNodeDimensions
参数：
nd - 渲染器

setExpandedState

public void setExpandedState(TreePath path,
                             boolean isExpanded)
将路径 path 的扩展状态标记为 isExpanded。

指定者：
类 AbstractLayoutCache 中的 setExpandedState
参数：
path - 相关的 TreePath
isExpanded - 如果应扩展路径，则为 true，否则为 false

getExpandedState

public boolean getExpandedState(TreePath path)
如果路径已扩展，并且可见，则返回 true。

指定者：
类 AbstractLayoutCache 中的 getExpandedState
参数：
path - 正在被查询的路径
返回：
如果路径已扩展，并且可见，则返回 true，否则返回 false

getBounds

public Rectangle getBounds(TreePath path,
                           Rectangle placeIn)
返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。

指定者：
类 AbstractLayoutCache 中的 getBounds
参数：
path - 要绘制的路径
placeIn - 矩形的边界
返回：
矩形的边界，如果无法确认该节点，则返回 null

getPathForRow

public TreePath getPathForRow(int row)
返回 row 的路径。如果 row 不可见，则返回 null。

指定者：
类 AbstractLayoutCache 中的 getPathForRow
参数：
row - 相关的位置
返回：
row 的路径，如果 row 不可见，则返回 null

getRowForPath

public int getRowForPath(TreePath path)
返回路径中标识的最后一项在其中可见的行。如果路径中任何元素当前不可见，则返回 -1。

指定者：
类 AbstractLayoutCache 中的 getRowForPath
参数：
path - 相关的 TreePath
返回：
路径中的最后一项在其中可见的行

getRowCount

public int getRowCount()
返回可见的行数。

指定者：
类 AbstractLayoutCache 中的 getRowCount
返回：
可见的行数

invalidatePathBounds

public void invalidatePathBounds(TreePath path)
指示 LayoutCache path 的边界无效，需要更新。

指定者：
类 AbstractLayoutCache 中的 invalidatePathBounds
参数：
path - 现在无效的 TreePath

getPreferredHeight

public int getPreferredHeight()
返回首选高度。

覆盖：
类 AbstractLayoutCache 中的 getPreferredHeight
返回：
首选高度

getPreferredWidth

public int getPreferredWidth(Rectangle bounds)
返回 visibleRegion 中区域的首选宽度和高度。

覆盖：
类 AbstractLayoutCache 中的 getPreferredWidth
参数：
bounds - 被查询的区域
返回：
传入区域的首选宽度

getPathClosestTo

public TreePath getPathClosestTo(int x,
                                 int y)
返回最接近 x,y 的节点的路径。如果当前没有任何可见的内容，则返回 null，否则，始终返回一个有效路径。如果需要测试返回的对象是否正好位于 x, y，您应获取返回路径的边界，并根据它测试 x, y。

指定者：
类 AbstractLayoutCache 中的 getPathClosestTo
参数：
x - x 坐标
y - y 坐标
返回：
最接近 x,y 的节点的路径

getVisiblePathsFrom

public Enumeration<TreePath> getVisiblePathsFrom(TreePath path)
返回从传入位置开始的可见路径的增量的 Enumerator。该枚举的排序基于路径的显示方式。

指定者：
类 AbstractLayoutCache 中的 getVisiblePathsFrom
参数：
path - TreePath 的起始位置
返回：
表示可见路径的增量的 Enumerator

getVisibleChildCount

public int getVisibleChildCount(TreePath path)
返回 path 的可见子路径数。

指定者：
类 AbstractLayoutCache 中的 getVisibleChildCount
参数：
path - 正被查询的路径
返回：
path 的可见子路径数

invalidateSizes

public void invalidateSizes()
通知 TreeState 需要重新计算它引用的所有大小。

指定者：
类 AbstractLayoutCache 中的 invalidateSizes

isExpanded

public boolean isExpanded(TreePath path)
如果当前扩展了 path 标识的值，则返回 true。

指定者：
类 AbstractLayoutCache 中的 isExpanded
返回：
如果当前扩展了 path 标识的值，则返回 true

treeNodesChanged

public void treeNodesChanged(TreeModelEvent e)
按某种方式更改节点（或兄弟节点集）后进行调用。没有更改节点在树中的位置，也没有改变他们的子数组，但是其他的属性已更改，并且可能影响表示形式。示例：文件的名称已更改，但是它在文件系统中的位置不变。

e.path 返回已更改节点的父节点的路径。

e.childIndices 返回已更改节点的索引。

指定者：
类 AbstractLayoutCache 中的 treeNodesChanged
参数：
e - 相关的 TreeModelEvent

treeNodesInserted

public void treeNodesInserted(TreeModelEvent e)
将节点插入树后进行调用。

e.path 返回新节点的父节点。

e.childIndices 按升序返回新节点的索引。

指定者：
类 AbstractLayoutCache 中的 treeNodesInserted
参数：
e - 相关的 TreeModelEvent

treeNodesRemoved

public void treeNodesRemoved(TreeModelEvent e)
将节点从树删除后进行调用。注意，如果从树移除子树，则对于移除的子树的根而言，此方法仅调用一次，对于移除的每个兄弟子树集而言，则不是一次。

e.path 返回删除节点的前一个父节点。

e.childIndices 返回节点按升序删除之前具有的索引。

指定者：
类 AbstractLayoutCache 中的 treeNodesRemoved
参数：
e - 相关的 TreeModelEvent

treeStructureChanged

public void treeStructureChanged(TreeModelEvent e)
树彻底更改给定节点以下的结构之后进行调用。如果 e.getPath 返回的路径长度为一，并且第一个元素不标识当前根节点，则第一个元素应成为树的新根。

e.path 保持节点的路径。

e.childIndices 返回 null。

指定者：
类 AbstractLayoutCache 中的 treeStructureChanged
参数：
e - 相关的 TreeModelEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.tree (Java Platform SE 6)

 javax.swing.tree
接口
MutableTreeNode
RowMapper
TreeCellEditor
TreeCellRenderer
TreeModel
TreeNode
TreeSelectionModel
类
AbstractLayoutCache
AbstractLayoutCache.NodeDimensions
DefaultMutableTreeNode
DefaultTreeCellEditor
DefaultTreeCellRenderer
DefaultTreeModel
DefaultTreeSelectionModel
FixedHeightLayoutCache
TreePath
VariableHeightLayoutCache
异常
ExpandVetoException


javax.swing.tree (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.tree

提供处理 javax.swing.JTree 的类和接口。

请参见：
描述

接口摘要
MutableTreeNode | 定义针对树节点对象的要求，这些树节点可以通过以下操作更改：添加或移除子节点，或更改该节点中存储的用户对象的内容。
RowMapper | 定义针对将树中的路径转换为显示行的对象的要求。
TreeCellEditor | 向 CellEditor 添加配置树中编辑器必需的扩展。
TreeCellRenderer | 定义针对显示树节点的对象的要求。
TreeModel | JTree 所使用的模型。
TreeNode | 定义可以用作 JTree 中树节点的对象所需的要求。
TreeSelectionModel | 此接口表示树选择组件的当前状态。

类摘要
AbstractLayoutCache | 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
AbstractLayoutCache.NodeDimensions | 由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。
DefaultMutableTreeNode | DefaultMutableTreeNode 是树数据结构中的通用节点。
DefaultTreeCellEditor | TreeCellEditor。
DefaultTreeCellRenderer | 显示树中的条目。
DefaultTreeModel | 使用 TreeNodes 的简单树数据模型。
DefaultTreeSelectionModel | TreeSelectionModel 的默认实现。
FixedHeightLayoutCache | 注：在以后的版本中，这将变得更加开放。
TreePath | 表示节点的路径。
VariableHeightLayoutCache | 注：在以后的版本中，此类将变得更加开放。

异常摘要
ExpandVetoException 用于阻止扩展/折叠发生的异常。

软件包 javax.swing.tree 的描述

提供处理 javax.swing.JTree 的类和接口。如果您要控制如何构造、更新和呈现树，以及如何查看、管理与树节点相关的数据，则使用这些类和接口。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • The Java Tutorial 中的 How to Use Trees 一节

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.tree 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.tree 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.tree.AbstractLayoutCache (implements javax.swing.tree.RowMapper)
      • javax.swing.tree.FixedHeightLayoutCache
      • javax.swing.tree.VariableHeightLayoutCache
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.tree.DefaultTreeCellEditor.EditorContainer
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.tree.DefaultTreeCellRenderer (implements javax.swing.tree.TreeCellRenderer)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
            • javax.swing.JTextField (implements javax.swing.SwingConstants)
              • javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
    • javax.swing.tree.DefaultMutableTreeNode (implements java.lang.Cloneable, javax.swing.tree.MutableTreeNode, java.io.Serializable)
    • javax.swing.tree.DefaultTreeCellEditor (implements java.awt.event.ActionListener, javax.swing.tree.TreeCellEditor, javax.swing.event.TreeSelectionListener)
    • javax.swing.tree.DefaultTreeModel (implements java.io.Serializable, javax.swing.tree.TreeModel)
    • javax.swing.tree.DefaultTreeSelectionModel (implements java.lang.Cloneable, java.io.Serializable, javax.swing.tree.TreeSelectionModel)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.swing.tree.ExpandVetoException
    • javax.swing.tree.TreePath (implements java.io.Serializable)

接口分层结构

  • javax.swing.CellEditor
    • javax.swing.tree.TreeCellEditor
  • javax.swing.tree.RowMapper
  • javax.swing.tree.TreeCellRenderer
  • javax.swing.tree.TreeModel
  • javax.swing.tree.TreeNode
    • javax.swing.tree.MutableTreeNode
  • javax.swing.tree.TreeSelectionModel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.tree 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.tree
的使用

使用 javax.swing.tree 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 使用的 javax.swing.tree 中的类
DefaultMutableTreeNode
DefaultMutableTreeNode 是树数据结构中的通用节点。
DefaultTreeSelectionModel
TreeSelectionModel 的默认实现。
ExpandVetoException
用于阻止扩展/折叠发生的异常。
MutableTreeNode
定义针对树节点对象的要求，这些树节点可以通过以下操作更改：添加或移除子节点，或更改该节点中存储的用户对象的内容。
TreeCellEditor
向 CellEditor 添加配置树中编辑器必需的扩展。
TreeCellRenderer
定义针对显示树节点的对象的要求。
TreeModel
JTree 所使用的模型。
TreeNode
定义可以用作 JTree 中树节点的对象所需的要求。
TreePath
表示节点的路径。
TreeSelectionModel
此接口表示树选择组件的当前状态。

javax.swing.event 使用的 javax.swing.tree 中的类
ExpandVetoException
用于阻止扩展/折叠发生的异常。
TreePath
表示节点的路径。

javax.swing.plaf 使用的 javax.swing.tree 中的类
TreePath
表示节点的路径。

javax.swing.plaf.basic 使用的 javax.swing.tree 中的类
AbstractLayoutCache
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
AbstractLayoutCache.NodeDimensions
由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。
TreeCellEditor
向 CellEditor 添加配置树中编辑器必需的扩展。
TreeCellRenderer
定义针对显示树节点的对象的要求。
TreeModel
JTree 所使用的模型。
TreePath
表示节点的路径。
TreeSelectionModel
此接口表示树选择组件的当前状态。

javax.swing.plaf.metal 使用的 javax.swing.tree 中的类
TreePath
表示节点的路径。

javax.swing.plaf.multi 使用的 javax.swing.tree 中的类
TreePath
表示节点的路径。

javax.swing.text 使用的 javax.swing.tree 中的类
TreeNode
定义可以用作 JTree 中树节点的对象所需的要求。

javax.swing.text.html 使用的 javax.swing.tree 中的类
TreeNode
定义可以用作 JTree 中树节点的对象所需的要求。

javax.swing.tree 使用的 javax.swing.tree 中的类
AbstractLayoutCache
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
AbstractLayoutCache.NodeDimensions
由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。
DefaultMutableTreeNode
DefaultMutableTreeNode 是树数据结构中的通用节点。
DefaultTreeCellRenderer
显示树中的条目。
MutableTreeNode
定义针对树节点对象的要求，这些树节点可以通过以下操作更改：添加或移除子节点，或更改该节点中存储的用户对象的内容。
RowMapper
定义针对将树中的路径转换为显示行的对象的要求。
TreeCellEditor
向 CellEditor 添加配置树中编辑器必需的扩展。
TreeCellRenderer
定义针对显示树节点的对象的要求。
TreeModel
JTree 所使用的模型。
TreeNode
定义可以用作 JTree 中树节点的对象所需的要求。
TreePath
表示节点的路径。
TreeSelectionModel
此接口表示树选择组件的当前状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.ExpandVetoException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.ExpandVetoException
的使用

使用 ExpandVetoException 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

javax.swing 中 ExpandVetoException 的使用

抛出 ExpandVetoException 的 javax.swing 中的方法
void | JTree.fireTreeWillCollapse(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.fireTreeWillExpand(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。

javax.swing.event 中 ExpandVetoException 的使用

抛出 ExpandVetoException 的 javax.swing.event 中的方法
void | TreeWillExpandListener.treeWillCollapse(TreeExpansionEvent event) 每当树中的一个节点将被折叠时调用。
void | TreeWillExpandListener.treeWillExpand(TreeExpansionEvent event) 每当树中的一个节点将被扩展时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.FixedHeightLayoutCache 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.FixedHeightLayoutCache
的使用

没有 javax.swing.tree.FixedHeightLayoutCache 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeCellEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeCellEditor
的使用

没有 javax.swing.tree.DefaultTreeCellEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
的使用

没有 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer
的使用

没有 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeModel
的使用

没有 javax.swing.tree.DefaultTreeModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.DefaultMutableTreeNode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultMutableTreeNode
的使用

使用 DefaultMutableTreeNode 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 DefaultMutableTreeNode 的使用

javax.swing 中 DefaultMutableTreeNode 的子类
static class JTree.DynamicUtilTreeNode
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。

参数类型为 DefaultMutableTreeNode 的 javax.swing 中的方法
static void JTree.DynamicUtilTreeNode.createChildren(DefaultMutableTreeNode parent, Object children)
将 children 中的所有子节点添加到父节点。

javax.swing.tree 中 DefaultMutableTreeNode 的使用

返回 DefaultMutableTreeNode 的 javax.swing.tree 中的方法
DefaultMutableTreeNode | DefaultMutableTreeNode.getFirstLeaf() 查找并返回为此节点后代的第一个叶节点，即此节点或其第一个子节点的第一个叶节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getLastLeaf() 查找并返回为此节点后代的最后一个叶节点，即此节点或其最后一个子节点的最后一个叶节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getNextLeaf() 返回此节点后面的叶节点，如果此节点是树中的最后一个叶节点，则返回 null。
DefaultMutableTreeNode | DefaultMutableTreeNode.getNextNode() 返回在此节点的树的前序遍历中此节点之后的节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getNextSibling() 返回父节点的子节点数组中此节点的下一个兄弟节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getPreviousLeaf() 返回此节点之前的叶节点，如果此节点是树中的第一个叶节点，则返回 null。
DefaultMutableTreeNode | DefaultMutableTreeNode.getPreviousNode() 返回在此节点树的前序遍历中此节点之前的节点。
DefaultMutableTreeNode | DefaultMutableTreeNode.getPreviousSibling() 返回父节点的子节点数组中此节点的前一个兄弟节点。

参数类型为 DefaultMutableTreeNode 的 javax.swing.tree 中的方法
TreeNode | DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode aNode) 返回此节点和 aNode 最近的共同祖先。
boolean | DefaultMutableTreeNode.isNodeDescendant(DefaultMutableTreeNode anotherNode) 如果 anotherNode 是此节点的后代 -- 如果它是此节点、此节点的一个子节点或此节点的一个子节点的后代，则返回 true。
boolean | DefaultMutableTreeNode.isNodeRelated(DefaultMutableTreeNode aNode) 当且仅当 aNode 位于与此节点相同的树中时，返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.tree.MutableTreeNode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.MutableTreeNode
的使用

使用 MutableTreeNode 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 MutableTreeNode 的使用

实现 MutableTreeNode 的 javax.swing 中的类
static class JTree.DynamicUtilTreeNode
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。

javax.swing.tree 中 MutableTreeNode 的使用

实现 MutableTreeNode 的 javax.swing.tree 中的类
 class DefaultMutableTreeNode
DefaultMutableTreeNode 是树数据结构中的通用节点。

声明为 MutableTreeNode 的 javax.swing.tree 中的字段
protected  MutableTreeNode DefaultMutableTreeNode.parent
此节点的父节点，如果此节点没有父节点，则为 null

参数类型为 MutableTreeNode 的 javax.swing.tree 中的方法
void | DefaultMutableTreeNode.add(MutableTreeNode newChild) 从其父节点移除 newChild，并通过将其添加到此节点的子数组的结尾，使其成为此节点的子节点。
void | DefaultMutableTreeNode.insert(MutableTreeNode newChild, int childIndex) 从其现有父节点移除 newChild（如果它有父节点），将子节点的父节点设置为此节点，然后，将该子节点添加到此节点位于索引 childIndex 处的子节点数组。
void | MutableTreeNode.insert(MutableTreeNode child, int index) 将 child 添加到 index 位置的接收者。
void | DefaultTreeModel.insertNodeInto(MutableTreeNode newChild, MutableTreeNode parent, int index) 对它进行调用，以便在父节点的子节点中的 index 位置插入 newChild。
void | DefaultMutableTreeNode.remove(MutableTreeNode aChild) 通过向其提供一个 null 父节点，从此节点的子节点数组移除 aChild。
void | MutableTreeNode.remove(MutableTreeNode node) 从接收者移除 node。
void | DefaultTreeModel.removeNodeFromParent(MutableTreeNode node) 通知它从其父节点中移除节点。
void | DefaultMutableTreeNode.setParent(MutableTreeNode newParent) 将此节点的父节点设置为 newParent，但不更改父节点的子节点数组。
void | MutableTreeNode.setParent(MutableTreeNode newParent) 将接收者的父对象设置为 newParent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.VariableHeightLayoutCache 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.VariableHeightLayoutCache
的使用

没有 javax.swing.tree.VariableHeightLayoutCache 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.AbstractLayoutCache 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.AbstractLayoutCache
的使用

使用 AbstractLayoutCache 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing.plaf.basic 中 AbstractLayoutCache 的使用

声明为 AbstractLayoutCache 的 javax.swing.plaf.basic 中的字段
protected  AbstractLayoutCache BasicTreeUI.treeState
负责处理大小和展开问题的对象。

返回 AbstractLayoutCache 的 javax.swing.plaf.basic 中的方法
protected  AbstractLayoutCache BasicTreeUI.createLayoutCache()
创建负责管理展开内容及节点大小的对象。

javax.swing.tree 中 AbstractLayoutCache 的使用

javax.swing.tree 中 AbstractLayoutCache 的子类
class | FixedHeightLayoutCache 注：在以后的版本中，这将变得更加开放。
class | VariableHeightLayoutCache 注：在以后的版本中，此类将变得更加开放。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.AbstractLayoutCache.NodeDimensions 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.AbstractLayoutCache.NodeDimensions
的使用

使用 AbstractLayoutCache.NodeDimensions 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing.plaf.basic 中 AbstractLayoutCache.NodeDimensions 的使用

javax.swing.plaf.basic 中 AbstractLayoutCache.NodeDimensions 的子类
 class BasicTreeUI.NodeDimensionsHandler
负责获取节点大小的类，其方法被转发到 BasicTreeUI 方法。

声明为 AbstractLayoutCache.NodeDimensions 的 javax.swing.plaf.basic 中的字段
protected  AbstractLayoutCache.NodeDimensions BasicTreeUI.nodeDimensions
负责告知 TreeState 节点所需的大小。

返回 AbstractLayoutCache.NodeDimensions 的 javax.swing.plaf.basic 中的方法
protected  AbstractLayoutCache.NodeDimensions BasicTreeUI.createNodeDimensions()
创建能够确定树中给定节点大小的 NodeDimensions 的实例。

javax.swing.tree 中 AbstractLayoutCache.NodeDimensions 的使用

声明为 AbstractLayoutCache.NodeDimensions 的 javax.swing.tree 中的字段
protected  AbstractLayoutCache.NodeDimensions AbstractLayoutCache.nodeDimensions
负责获取节点大小的对象。

返回 AbstractLayoutCache.NodeDimensions 的 javax.swing.tree 中的方法
 AbstractLayoutCache.NodeDimensions AbstractLayoutCache.getNodeDimensions()
返回呈现树中节点的对象，它负责计算各个节点的尺寸。

参数类型为 AbstractLayoutCache.NodeDimensions 的 javax.swing.tree 中的方法
void | VariableHeightLayoutCache.setNodeDimensions(AbstractLayoutCache.NodeDimensions nd) 设置负责绘制树中节点的渲染器。
void | AbstractLayoutCache.setNodeDimensions(AbstractLayoutCache.NodeDimensions nd) 设置负责绘制树中节点的 renderer，因此，它还负责计算各个节点的尺寸。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.tree.RowMapper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.RowMapper
的使用

使用 RowMapper 的软件包
javax.swing.tree 提供处理 javax.swing.JTree 的类和接口。

javax.swing.tree 中 RowMapper 的使用

实现 RowMapper 的 javax.swing.tree 中的类
class | AbstractLayoutCache 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | FixedHeightLayoutCache 注：在以后的版本中，这将变得更加开放。
class | VariableHeightLayoutCache 注：在以后的版本中，此类将变得更加开放。

声明为 RowMapper 的 javax.swing.tree 中的字段
protected  RowMapper DefaultTreeSelectionModel.rowMapper
提供给定路径的行。

返回 RowMapper 的 javax.swing.tree 中的方法
RowMapper | DefaultTreeSelectionModel.getRowMapper() 返回能够将 TreePath 映射到行的 RowMapper 实例。
RowMapper | TreeSelectionModel.getRowMapper() 返回能够将 TreePath 映射到行的 RowMapper 实例。

参数类型为 RowMapper 的 javax.swing.tree 中的方法
void | DefaultTreeSelectionModel.setRowMapper(RowMapper newMapper) 设置 RowMapper 实例。
void | TreeSelectionModel.setRowMapper(RowMapper newMapper) 设置 RowMapper 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.TreePath 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.TreePath
的使用

使用 TreePath 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreePath 的使用

返回 TreePath 的 javax.swing 中的方法
TreePath | JTree.getAnchorSelectionPath() 返回标识为定位的路径。
TreePath | JTree.getClosestPathForLocation(int x, int y) 返回离 x,y 最近的节点的路径。
TreePath | JTree.getEditingPath() 返回当前正在编辑的元素的路径。
TreePath | JTree.getLeadSelectionPath() 返回标识为前导的路径。
TreePath | JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias) 将 TreePath 返回到以一个前缀开头的下一个树元素。
TreePath | JTree.DropLocation.getPath() 返回树中应该用来放入放置数据的路径。
protected TreePath[] | JTree.getPathBetweenRows(int index0, int index1) 返回 JTreePath 实例，它表示 index0 和 index1（包括 index1）之间的路径。
TreePath | JTree.getPathForLocation(int x, int y) 返回指定位置处的节点路径。
TreePath | JTree.getPathForRow(int row) 返回指定行的路径。
TreePath | JTree.getSelectionPath() 返回首选节点的路径。
TreePath[] | JTree.getSelectionPaths() 返回所有选择值的路径。

返回变量类型为 TreePath 的类型的 javax.swing 中的方法
protected Enumeration<TreePath> | JTree.getDescendantToggledPaths(TreePath parent) 返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
Enumeration<TreePath> | JTree.getExpandedDescendants(TreePath parent) 返回当前展开的 parent 路径的子路径的 Enumeration。

参数类型为 TreePath 的 javax.swing 中的方法
void | JTree.addSelectionPath(TreePath path) 将由指定的 TreePath 标识的节点添加到当前选择。
void | JTree.addSelectionPaths(TreePath[] paths) 将路径数组中的每个路径添加到当前选择。
void | JTree.EmptySelectionModel.addSelectionPaths(TreePath[] paths) 一个未添加任何内容的 null 实现。
void | JTree.collapsePath(TreePath path) 确保指定路径标识的节点是折叠的，并且可查看。
void | JTree.expandPath(TreePath path) 确保指定路径标识的节点展开，并且可查看。
void | JTree.fireTreeCollapsed(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.fireTreeExpanded(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.fireTreeWillCollapse(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.fireTreeWillExpand(TreePath path) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected Enumeration<TreePath> | JTree.getDescendantToggledPaths(TreePath parent) 返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
Enumeration<TreePath> | JTree.getExpandedDescendants(TreePath parent) 返回当前展开的 parent 路径的子路径的 Enumeration。
Rectangle | JTree.getPathBounds(TreePath path) 返回将指定节点绘入的 Rectangle。
int | JTree.getRowForPath(TreePath path) 返回显示由指定路径标识的节点的行。
boolean | JTree.hasBeenExpanded(TreePath path) 如果已经展开路径标识的节点，则返回 true。
boolean | JTree.isCollapsed(TreePath path) 如果当前折叠了路径标识的值，则返回 true，如果当前未显示路径中的任何值，则返回 false。
boolean | JTree.isExpanded(TreePath path) 如果当前展开了路径标识的节点，则返回 true。
boolean | JTree.isPathEditable(TreePath path) 返回 isEditable。
boolean | JTree.isPathSelected(TreePath path) 如果当前选择了路径标识的条目，则返回 true。
boolean | JTree.isVisible(TreePath path) 如果当前可查看路径标识的值，则返回 true，这意味着该路径或者是根路径，或者它的所有父路径均被展开。
void | JTree.makeVisible(TreePath path) 确保路径标识的节点当前可查看。
protected boolean | JTree.removeDescendantSelectedPaths(TreePath path, boolean includePath) 移除选择中的任何路径（path 的子路径）。
void | JTree.removeSelectionPath(TreePath path) 从当前选择中移除指定路径标识的节点。
void | JTree.removeSelectionPaths(TreePath[] paths) 从当前选择移除指定路径标识的节点。
void | JTree.EmptySelectionModel.removeSelectionPaths(TreePath[] paths) 一个未移除任何内容的 null 实现。
void | JTree.scrollPathToVisible(TreePath path) 确保路径中所有的路径组件均展开（最后一个路径组件除外）并滚动，以便显示该路径标识的节点。
void | JTree.setAnchorSelectionPath(TreePath newPath) 将标识的路径设置为定位路径。
protected void | JTree.setExpandedState(TreePath path, boolean state) 设置此 JTree 的展开状态。
void | JTree.setLeadSelectionPath(TreePath newPath) 将标识的路径设置为前导路径。
void | JTree.setSelectionPath(TreePath path) 选择指定路径标识的节点。
void | JTree.setSelectionPaths(TreePath[] paths) 选择由指定的路径数组标识的节点。
void | JTree.EmptySelectionModel.setSelectionPaths(TreePath[] pPaths) 一个未选择任何内容的 null 实现。
void | JTree.startEditingAtPath(TreePath path) 选择指定路径标识的节点，并开始编辑。

类型变量类型为 TreePath 的 javax.swing 中的方法参数
protected  void JTree.removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
移除已展开的 toRemove 中 TreePath 的所有子路径。

参数类型为 TreePath 的 javax.swing 中的构造方法
JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
构造一个 AccessibleJTreeNode

javax.swing.event 中 TreePath 的使用

声明为 TreePath 的 javax.swing.event 中的字段
protected TreePath | TreeSelectionEvent.newLeadSelectionPath 在路径被更改之后的 leadSelectionPath，可能为 null。
protected TreePath | TreeSelectionEvent.oldLeadSelectionPath 在路径被更改之前的 leadSelectionPath，可能为 null。
protected TreePath | TreeExpansionEvent.path 到达此事件表示的值的路径。
protected TreePath | TreeModelEvent.path 到达已更改节点的父节点的路径。
protected TreePath[] | TreeSelectionEvent.paths 此事件表示的路径。

返回 TreePath 的 javax.swing.event 中的方法
TreePath | TreeSelectionEvent.getNewLeadSelectionPath() 返回当前前导路径。
TreePath | TreeSelectionEvent.getOldLeadSelectionPath() 返回以前是前导路径的路径。
TreePath | TreeExpansionEvent.getPath() 返回到达已被扩展/折叠的值的路径。
TreePath | TreeSelectionEvent.getPath() 返回第一个路径元素。
TreePath[] | TreeSelectionEvent.getPaths() 返回已经添加到该选择中或已从中移除的路径。
TreePath | TreeModelEvent.getTreePath() 对于除 treeStructureChanged 以外的所有事件，返回已更改节点的父节点。

参数类型为 TreePath 的 javax.swing.event 中的方法
 boolean TreeSelectionEvent.isAddedPath(TreePath path)
如果 path 标识的路径被添加到选择中，则返回 true。

参数类型为 TreePath 的 javax.swing.event 中的构造方法
TreeExpansionEvent(Object source, TreePath path)
构造一个 TreeExpansionEvent 对象。
TreeModelEvent(Object source, TreePath path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 TreePath 对象。
TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。
TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。
TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。
TreeSelectionEvent(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。

javax.swing.plaf 中 TreePath 的使用

返回 TreePath 的 javax.swing.plaf 中的方法
abstract TreePath | TreeUI.getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
abstract TreePath | TreeUI.getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
abstract TreePath | TreeUI.getPathForRow(JTree tree, int row) 返回传入的 row 的路径。

参数类型为 TreePath 的 javax.swing.plaf 中的方法
abstract Rectangle | TreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
abstract int | TreeUI.getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
abstract void | TreeUI.startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并试着编辑它。

javax.swing.plaf.basic 中 TreePath 的使用

声明为 TreePath 的 javax.swing.plaf.basic 中的字段
protected  TreePath BasicTreeUI.editingPath
要编辑的路径。

类型参数类型为 TreePath 的 javax.swing.plaf.basic 中的字段
protected  Hashtable<TreePath,Boolean> BasicTreeUI.drawingCache
用于最小化垂直线的绘制。

返回 TreePath 的 javax.swing.plaf.basic 中的方法
TreePath | BasicTreeUI.getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
TreePath | BasicTreeUI.getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
protected TreePath | BasicTreeUI.getLastChildPath(TreePath parent) 返回到 parent 的最后一个子节点的路径。
TreePath | BasicTreeUI.getPathForRow(JTree tree, int row) 返回传入的 row 的路径。

参数类型为 TreePath 的 javax.swing.plaf.basic 中的方法
protected void | BasicTreeUI.checkForClickInExpandControl(TreePath path, int mouseX, int mouseY) 如果 mouseX 和 mouseY 位于 row 的展开/折叠区域内，则此方法将切换行。
protected TreePath | BasicTreeUI.getLastChildPath(TreePath parent) 返回到 parent 的最后一个子节点的路径。
Rectangle | BasicTreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
int | BasicTreeUI.getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
protected void | BasicTreeUI.handleExpandControlClick(TreePath path, int mouseX, int mouseY) 当用户单击特定行时传递消息，此方法调用 toggleExpandState。
protected boolean | BasicTreeUI.isLocationInExpandControl(TreePath path, int mouseX, int mouseY) 如果 mouseX 和 mouseY 落在用于展开/折叠节点的行的区域内，并且 row 的节点不表示叶节点，则返回 true。
protected void | BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制 row 的展开（切换）部分。
protected void | BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制支路 (leg) 的水平部分。
protected void | BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制 row 的渲染器部分。
protected void | BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path) 绘制支路的垂直部分。
protected void | BasicTreeUI.pathWasCollapsed(TreePath path) 在折叠 VisibleTreeNode 后，从其传递消息。
protected void | BasicTreeUI.pathWasExpanded(TreePath path) 在展开 VisibleTreeNode 后，从其传递消息。
protected void | BasicTreeUI.selectPathForEvent(TreePath path, MouseEvent event) 传递消息以基于特定行上的 MouseEvent 更新选择。
protected boolean | BasicTreeUI.shouldPaintExpandControl(TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 如果应该为指定行绘制展开（切换）控件，则返回 true。
protected boolean | BasicTreeUI.startEditing(TreePath path, MouseEvent event) 如果存在 cellEditor 并且 shouldSelectCell 返回 true，则启动节点的编辑操作。
void | BasicTreeUI.startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并尝试对其进行编辑。
protected void | BasicTreeUI.toggleExpandState(TreePath path) 如果路径不是展开的，则展开它；如果它是展开的，则折叠它。
protected void | BasicTreeUI.updateExpandedDescendants(TreePath path) 通过从树获取展开的子代并将其转发到树状态来更新 path 的所有子代的展开状态。

javax.swing.plaf.metal 中 TreePath 的使用

参数类型为 TreePath 的 javax.swing.plaf.metal 中的方法
protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

javax.swing.plaf.multi 中 TreePath 的使用

返回 TreePath 的 javax.swing.plaf.multi 中的方法
TreePath | MultiTreeUI.getClosestPathForLocation(JTree a, int b, int c) 在由此对象处理的每个 UI 上调用 getClosestPathForLocation 方法。
TreePath | MultiTreeUI.getEditingPath(JTree a) 在由此对象处理的每个 UI 上调用 getEditingPath 方法。
TreePath | MultiTreeUI.getPathForRow(JTree a, int b) 在由此对象处理的每个 UI 上调用 getPathForRow 方法。

参数类型为 TreePath 的 javax.swing.plaf.multi 中的方法
Rectangle | MultiTreeUI.getPathBounds(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getPathBounds 方法。
int | MultiTreeUI.getRowForPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getRowForPath 方法。
void | MultiTreeUI.startEditingAtPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 startEditingAtPath 方法。

javax.swing.tree 中 TreePath 的使用

声明为 TreePath 的 javax.swing.tree 中的字段
protected TreePath | DefaultTreeCellEditor.lastPath 选择的最后路径。
protected TreePath | DefaultTreeSelectionModel.leadPath 添加的最后一条路径。
protected TreePath[] | DefaultTreeSelectionModel.selection 当前选择的路径。

返回 TreePath 的 javax.swing.tree 中的方法
TreePath | DefaultTreeSelectionModel.getLeadSelectionPath() 返回添加的最后一条路径。
TreePath | TreeSelectionModel.getLeadSelectionPath() 返回添加的最后一个路径。
TreePath | TreePath.getParentPath() 返回包含除最后一个路径组件之外的此对象所有元素的路径。
TreePath | FixedHeightLayoutCache.getPathClosestTo(int x, int y) 返回最接近 x,y 的节点的路径。
TreePath | VariableHeightLayoutCache.getPathClosestTo(int x, int y) 返回最接近 x,y 的节点的路径。
abstract TreePath | AbstractLayoutCache.getPathClosestTo(int x, int y) 返回最接近 x,y 节点的路径。
TreePath | FixedHeightLayoutCache.getPathForRow(int row) 返回传入行的路径。
TreePath | VariableHeightLayoutCache.getPathForRow(int row) 返回 row 的路径。
abstract TreePath | AbstractLayoutCache.getPathForRow(int row) 返回传入行的路径。
TreePath | DefaultTreeSelectionModel.getSelectionPath() 返回 selection 中的第一个路径。
TreePath | TreeSelectionModel.getSelectionPath() 返回选择中的第一个路径。
TreePath[] | DefaultTreeSelectionModel.getSelectionPaths() 返回 selection 中的路径。
TreePath[] | TreeSelectionModel.getSelectionPaths() 返回选择中的路径。
TreePath | TreePath.pathByAddingChild(Object child) 返回包含此对象的所有元素加上 child 的新路径。

返回变量类型为 TreePath 的类型的 javax.swing.tree 中的方法
Enumeration<TreePath> | FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回表示从传入位置开始的可见路径的增量的 Enumerator。
Enumeration<TreePath> | VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回从传入位置开始的可见路径的增量的 Enumerator。
abstract Enumeration<TreePath> | AbstractLayoutCache.getVisiblePathsFrom(TreePath path) 返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。

参数类型为 TreePath 的 javax.swing.tree 中的方法
void | DefaultTreeSelectionModel.addSelectionPath(TreePath path) 将路径添加到当前的 selection 中。
void | TreeSelectionModel.addSelectionPath(TreePath path) 将路径添加到当前的选择中。
void | DefaultTreeSelectionModel.addSelectionPaths(TreePath[] paths) 向当前的 selection 中添加路径。
void | TreeSelectionModel.addSelectionPaths(TreePath[] paths) 向当前的选择中添加路径。
protected boolean | DefaultTreeSelectionModel.arePathsContiguous(TreePath[] paths) 如果路径是连续的，或者此对象没有 RowMapper，则返回 true。
protected boolean | DefaultTreeSelectionModel.canPathsBeAdded(TreePath[] paths) 用于测试是否可以添加特定的 TreePath 集合。
protected boolean | DefaultTreeSelectionModel.canPathsBeRemoved(TreePath[] paths) 如果可以移除该路径而不中断该模型的连续性，则返回 true。
Rectangle | FixedHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回给出绘制路径所需边界的矩形。
Rectangle | VariableHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
abstract Rectangle | AbstractLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回一个矩形，该矩形给出了绘制路径所需的 bounds。
boolean | FixedHeightLayoutCache.getExpandedState(TreePath path) 如果该路径已扩展，并且可见，则返回 true。
boolean | VariableHeightLayoutCache.getExpandedState(TreePath path) 如果路径已扩展，并且可见，则返回 true。
abstract boolean | AbstractLayoutCache.getExpandedState(TreePath path) 如果路径已扩展并且可视，则返回 true。
int | FixedHeightLayoutCache.getRowForPath(TreePath path) 返回路径中标识的最后一项可见的行。
int | VariableHeightLayoutCache.getRowForPath(TreePath path) 返回路径中标识的最后一项在其中可见的行。
abstract int | AbstractLayoutCache.getRowForPath(TreePath path) 返回其路径中标识的最后一项可视的行。
int[] | AbstractLayoutCache.getRowsForPaths(TreePath[] paths) 返回在其中显示 path 中 TreePath 实例的行。
int[] | RowMapper.getRowsForPaths(TreePath[] path) 返回显示 path 中的 TreePath 实例的行。
int | FixedHeightLayoutCache.getVisibleChildCount(TreePath path) 返回行的可见子对象数。
int | VariableHeightLayoutCache.getVisibleChildCount(TreePath path) 返回 path 的可见子路径数。
abstract int | AbstractLayoutCache.getVisibleChildCount(TreePath path) 返回行的可视子节点数。
Enumeration<TreePath> | FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回表示从传入位置开始的可见路径的增量的 Enumerator。
Enumeration<TreePath> | VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回从传入位置开始的可见路径的增量的 Enumerator。
abstract Enumeration<TreePath> | AbstractLayoutCache.getVisiblePathsFrom(TreePath path) 返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。
void | FixedHeightLayoutCache.invalidatePathBounds(TreePath path) 不执行任何操作，FixedHeightLayoutCache 不缓存宽度（即所有可以更改的宽度）。
void | VariableHeightLayoutCache.invalidatePathBounds(TreePath path) 指示 LayoutCache path 的边界无效，需要更新。
abstract void | AbstractLayoutCache.invalidatePathBounds(TreePath path) 指示 LayoutCache，path 的边界无效，需要进行更新。
boolean | TreePath.isDescendant(TreePath aTreePath) 如果 aTreePath 为此 TreePath 的后代，则返回 true。
boolean | FixedHeightLayoutCache.isExpanded(TreePath path) 如果当前扩展了由行标识的值，则返回 true。
boolean | VariableHeightLayoutCache.isExpanded(TreePath path) 如果当前扩展了 path 标识的值，则返回 true。
abstract boolean | AbstractLayoutCache.isExpanded(TreePath path) 如果当前扩展了由行标识的值，则返回 true。
boolean | DefaultTreeSelectionModel.isPathSelected(TreePath path) 如果当前选择了路径 path，则返回 true。
boolean | TreeSelectionModel.isPathSelected(TreePath path) 如果路径 path 在当前的选择中，则返回 true。
protected void | DefaultTreeSelectionModel.notifyPathChange(Vector<javax.swing.tree.PathPlaceHolder> changedPaths, TreePath oldLeadSelection) 通知侦听器路径中的更改。
void | DefaultTreeSelectionModel.removeSelectionPath(TreePath path) 从 selection 中移除路径。
void | TreeSelectionModel.removeSelectionPath(TreePath path) 从选择中移除路径。
void | DefaultTreeSelectionModel.removeSelectionPaths(TreePath[] paths) 从 selection 中移除路径。
void | TreeSelectionModel.removeSelectionPaths(TreePath[] paths) 从选择中移除路径。
void | FixedHeightLayoutCache.setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的扩展状态标记为 isExpanded。
void | VariableHeightLayoutCache.setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的扩展状态标记为 isExpanded。
abstract void | AbstractLayoutCache.setExpandedState(TreePath path, boolean isExpanded) 将路径 path 的已扩展状态标记为 isExpanded。
void | DefaultTreeSelectionModel.setSelectionPath(TreePath path) 为该选择设置路径。
void | TreeSelectionModel.setSelectionPath(TreePath path) 为该选择设置路径。
void | DefaultTreeSelectionModel.setSelectionPaths(TreePath[] pPaths) 为该选择设置路径中的路径。
void | TreeSelectionModel.setSelectionPaths(TreePath[] paths) 为该选择设置路径。
void | DefaultTreeModel.valueForPathChanged(TreePath path, Object newValue) 此方法设置由路径标识的 TreeNode 的用户对象，并发送更改的节点。
void | TreeModel.valueForPathChanged(TreePath path, Object newValue) 用户已将 path 标识的项的值更改为 newValue 时，进行通知。

参数类型为 TreePath 的 javax.swing.tree 中的构造方法
TreePath(TreePath parent, Object lastElement)
构造一个新的 TreePath，它是以 lastElement 结束的 parent 标识的路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeSelectionModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeSelectionModel
的使用

使用 DefaultTreeSelectionModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultTreeSelectionModel 的使用

javax.swing 中 DefaultTreeSelectionModel 的子类
protected static class JTree.EmptySelectionModel
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.tree.TreeCellEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeCellEditor
的使用

使用 TreeCellEditor 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeCellEditor 的使用

实现 TreeCellEditor 的 javax.swing 中的类
 class DefaultCellEditor
表单元格和树单元格的默认编辑器。

声明为 TreeCellEditor 的 javax.swing 中的字段
protected  TreeCellEditor JTree.cellEditor
条目编辑器。

返回 TreeCellEditor 的 javax.swing 中的方法
 TreeCellEditor JTree.getCellEditor()
返回用于编辑树中条目的编辑器。

参数类型为 TreeCellEditor 的 javax.swing 中的方法
 void JTree.setCellEditor(TreeCellEditor cellEditor)
设置单元格编辑器。

javax.swing.plaf.basic 中 TreeCellEditor 的使用

声明为 TreeCellEditor 的 javax.swing.plaf.basic 中的字段
protected  TreeCellEditor BasicTreeUI.cellEditor
树的编辑器。

返回 TreeCellEditor 的 javax.swing.plaf.basic 中的方法
protected TreeCellEditor | BasicTreeUI.createDefaultCellEditor() 创建默认单元格编辑器。
protected TreeCellEditor | BasicTreeUI.getCellEditor()

参数类型为 TreeCellEditor 的 javax.swing.plaf.basic 中的方法
protected  void BasicTreeUI.setCellEditor(TreeCellEditor editor)
设置单元格编辑器。

javax.swing.tree 中 TreeCellEditor 的使用

实现 TreeCellEditor 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

声明为 TreeCellEditor 的 javax.swing.tree 中的字段
protected  TreeCellEditor DefaultTreeCellEditor.realEditor
处理该编辑的编辑器。

返回 TreeCellEditor 的 javax.swing.tree 中的方法
protected  TreeCellEditor DefaultTreeCellEditor.createTreeCellEditor()
如果构造方法中没有提供 TreeCellEditor，则调用此方法。

参数类型为 TreeCellEditor 的 javax.swing.tree 中的构造方法
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.tree.DefaultTreeCellRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.tree.DefaultTreeCellRenderer
的使用

使用 DefaultTreeCellRenderer 的软件包
javax.swing.tree 提供处理 javax.swing.JTree 的类和接口。

javax.swing.tree 中 DefaultTreeCellRenderer 的使用

声明为 DefaultTreeCellRenderer 的 javax.swing.tree 中的字段
protected  DefaultTreeCellRenderer DefaultTreeCellEditor.renderer
用于从中获取边框和偏移量的呈现器。

参数类型为 DefaultTreeCellRenderer 的 javax.swing.tree 中的构造方法
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
使用指定呈现器和默认编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.tree.TreeCellRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeCellRenderer
的使用

使用 TreeCellRenderer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeCellRenderer 的使用

声明为 TreeCellRenderer 的 javax.swing 中的字段
protected  TreeCellRenderer JTree.cellRenderer
用于绘制节点的单元格。

返回 TreeCellRenderer 的 javax.swing 中的方法
 TreeCellRenderer JTree.getCellRenderer()
返回正在呈现每个单元格的当前 TreeCellRenderer。

参数类型为 TreeCellRenderer 的 javax.swing 中的方法
 void JTree.setCellRenderer(TreeCellRenderer x)
设置将用于绘制每个单元格的 TreeCellRenderer。

javax.swing.plaf.basic 中 TreeCellRenderer 的使用

声明为 TreeCellRenderer 的 javax.swing.plaf.basic 中的字段
protected  TreeCellRenderer BasicTreeUI.currentCellRenderer
要用于进行实际单元格绘制的渲染器。

返回 TreeCellRenderer 的 javax.swing.plaf.basic 中的方法
protected TreeCellRenderer | BasicTreeUI.createDefaultCellRenderer() 返回用于为每个节点添加标志的默认单元格渲染器。
protected TreeCellRenderer | BasicTreeUI.getCellRenderer() 返回 currentCellRenderer，可以为树渲染器，也可以为 defaultCellRenderer，无论哪个都不为 null。

参数类型为 TreeCellRenderer 的 javax.swing.plaf.basic 中的方法
protected  void BasicTreeUI.setCellRenderer(TreeCellRenderer tcr)
将 TreeCellRenderer 设置为 tcr。

javax.swing.tree 中 TreeCellRenderer 的使用

实现 TreeCellRenderer 的 javax.swing.tree 中的类
 class DefaultTreeCellRenderer
显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.tree.TreeSelectionModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeSelectionModel
的使用

使用 TreeSelectionModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeSelectionModel 的使用

实现 TreeSelectionModel 的 javax.swing 中的类
protected static class JTree.EmptySelectionModel
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。

声明为 TreeSelectionModel 的 javax.swing 中的字段
protected  TreeSelectionModel JTree.selectionModel
对此树中选择的节点集建模。

返回 TreeSelectionModel 的 javax.swing 中的方法
 TreeSelectionModel JTree.getSelectionModel()
返回选择的模型。

参数类型为 TreeSelectionModel 的 javax.swing 中的方法
 void JTree.setSelectionModel(TreeSelectionModel selectionModel)
设置树的选择模型。

javax.swing.plaf.basic 中 TreeSelectionModel 的使用

声明为 TreeSelectionModel 的 javax.swing.plaf.basic 中的字段
protected  TreeSelectionModel BasicTreeUI.treeSelectionModel
维护选择的模型。

返回 TreeSelectionModel 的 javax.swing.plaf.basic 中的方法
protected  TreeSelectionModel BasicTreeUI.getSelectionModel()

参数类型为 TreeSelectionModel 的 javax.swing.plaf.basic 中的方法
protected  void BasicTreeUI.setSelectionModel(TreeSelectionModel newLSM)
重置选择模型。

javax.swing.tree 中 TreeSelectionModel 的使用

实现 TreeSelectionModel 的 javax.swing.tree 中的类
 class DefaultTreeSelectionModel
TreeSelectionModel 的默认实现。

声明为 TreeSelectionModel 的 javax.swing.tree 中的字段
protected  TreeSelectionModel AbstractLayoutCache.treeSelectionModel
选择模型。

返回 TreeSelectionModel 的 javax.swing.tree 中的方法
 TreeSelectionModel AbstractLayoutCache.getSelectionModel()
返回用于维护该选择的模型。

参数类型为 TreeSelectionModel 的 javax.swing.tree 中的方法
 void AbstractLayoutCache.setSelectionModel(TreeSelectionModel newLSM)
将用于管理选择的 TreeSelectionModel 设置为新的 LSM。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.tree.TreeModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeModel
的使用

使用 TreeModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeModel 的使用

声明为 TreeModel 的 javax.swing 中的字段
protected  TreeModel JTree.treeModel
定义此对象显示的树的模型。

返回 TreeModel 的 javax.swing 中的方法
protected static TreeModel | JTree.createTreeModel(Object value) 返回一个 TreeModel，它包装指定的对象。
protected static TreeModel | JTree.getDefaultTreeModel() 创建并返回一个示例 TreeModel。
TreeModel | JTree.getModel() 返回正在提供数据的 TreeModel。

参数类型为 TreeModel 的 javax.swing 中的方法
 void JTree.setModel(TreeModel newModel)
设置将提供数据的 TreeModel。

参数类型为 TreeModel 的 javax.swing 中的构造方法
JTree(TreeModel newModel)
返回 JTree 的一个实例，它显示根节点 - 使用指定的数据模型创建树。

javax.swing.plaf.basic 中 TreeModel 的使用

声明为 TreeModel 的 javax.swing.plaf.basic 中的字段
protected  TreeModel BasicTreeUI.treeModel
用于确定要显示的内容。

返回 TreeModel 的 javax.swing.plaf.basic 中的方法
protected  TreeModel BasicTreeUI.getModel()

参数类型为 TreeModel 的 javax.swing.plaf.basic 中的方法
protected  void BasicTreeUI.setModel(TreeModel model)
设置 TreeModel。

javax.swing.tree 中 TreeModel 的使用

实现 TreeModel 的 javax.swing.tree 中的类
 class DefaultTreeModel
使用 TreeNodes 的简单树数据模型。

声明为 TreeModel 的 javax.swing.tree 中的字段
protected  TreeModel AbstractLayoutCache.treeModel
提供信息的模型。

返回 TreeModel 的 javax.swing.tree 中的方法
 TreeModel AbstractLayoutCache.getModel()
返回要提供数据的 TreeModel。

参数类型为 TreeModel 的 javax.swing.tree 中的方法
void | FixedHeightLayoutCache.setModel(TreeModel newModel) 设置将提供数据的 TreeModel。
void | VariableHeightLayoutCache.setModel(TreeModel newModel) 设置将提供数据的 TreeModel。
void | AbstractLayoutCache.setModel(TreeModel newModel) 设置将提供数据的 TreeModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.tree.TreeNode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.tree.TreeNode
的使用

使用 TreeNode 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeNode 的使用

实现 TreeNode 的 javax.swing 中的类
static class JTree.DynamicUtilTreeNode
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。

返回 TreeNode 的 javax.swing 中的方法
 TreeNode JTree.DynamicUtilTreeNode.getChildAt(int index)
必要时创建子类以加载此子节点。

参数类型为 TreeNode 的 javax.swing 中的构造方法
JTree(TreeNode root)
返回 JTree，指定的 TreeNode 作为其根，它显示根节点。
JTree(TreeNode root, boolean asksAllowsChildren)
返回 JTree，指定的 TreeNode 作为其根，它用指定的方式显示根节点，并确定节点是否为叶节点。

javax.swing.text 中 TreeNode 的使用

实现 TreeNode 的 javax.swing.text 中的类
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。

返回 TreeNode 的 javax.swing.text 中的方法
TreeNode | AbstractDocument.AbstractElement.getChildAt(int childIndex) 在索引 childIndex 处返回子级 TreeNode。
TreeNode | AbstractDocument.AbstractElement.getParent() 返回接收方的父级 TreeNode。

参数类型为 TreeNode 的 javax.swing.text 中的方法
 int AbstractDocument.AbstractElement.getIndex(TreeNode node)
返回接收方子级中 node 的索引。

javax.swing.text.html 中 TreeNode 的使用

实现 TreeNode 的 javax.swing.text.html 中的类
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

javax.swing.tree 中 TreeNode 的使用

javax.swing.tree 中 TreeNode 的子接口
 interface MutableTreeNode
定义针对树节点对象的要求，这些树节点可以通过以下操作更改：添加或移除子节点，或更改该节点中存储的用户对象的内容。

实现 TreeNode 的 javax.swing.tree 中的类
 class DefaultMutableTreeNode
DefaultMutableTreeNode 是树数据结构中的通用节点。

声明为 TreeNode 的 javax.swing.tree 中的字段
protected  TreeNode DefaultTreeModel.root
树的根。

类型参数类型为 TreeNode 的 javax.swing.tree 中的字段
static Enumeration<TreeNode> DefaultMutableTreeNode.EMPTY_ENUMERATION
始终为空的枚举。

返回 TreeNode 的 javax.swing.tree 中的方法
TreeNode | DefaultMutableTreeNode.getChildAfter(TreeNode aChild) 返回此节点的子节点数组中刚好跟在 aChild 之后的子节点，它必须是此节点的子节点。
TreeNode | DefaultMutableTreeNode.getChildAt(int index) 返回此节点的子节点数组中指定索引处的子节点。
TreeNode | TreeNode.getChildAt(int childIndex) 返回索引 childIndex 位置的子 TreeNode。
TreeNode | DefaultMutableTreeNode.getChildBefore(TreeNode aChild) 返回此节点的子节点数组中刚好在 aChild 之前的子节点，它必须是此节点的子节点。
TreeNode | DefaultMutableTreeNode.getFirstChild() 返回此节点的第一个子节点。
TreeNode | DefaultMutableTreeNode.getLastChild() 返回此节点的最后一个子节点。
TreeNode | DefaultMutableTreeNode.getParent() 返回此节点的父节点，如果此节点没有父节点，则返回 null。
TreeNode | TreeNode.getParent() 返回接收者的父 TreeNode。
TreeNode[] | DefaultMutableTreeNode.getPath() 返回从根到达此节点的路径。
TreeNode[] | DefaultTreeModel.getPathToRoot(TreeNode aNode) 向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected TreeNode[] | DefaultTreeModel.getPathToRoot(TreeNode aNode, int depth) 向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected TreeNode[] | DefaultMutableTreeNode.getPathToRoot(TreeNode aNode, int depth) 构建节点的父节点一直到根节点（包括根节点），其中源节点是返回数组中的最后一个元素。
TreeNode | DefaultMutableTreeNode.getRoot() 返回包含此节点的树的根。
TreeNode | DefaultMutableTreeNode.getSharedAncestor(DefaultMutableTreeNode aNode) 返回此节点和 aNode 最近的共同祖先。

参数类型为 TreeNode 的 javax.swing.tree 中的方法
TreeNode | DefaultMutableTreeNode.getChildAfter(TreeNode aChild) 返回此节点的子节点数组中刚好跟在 aChild 之后的子节点，它必须是此节点的子节点。
TreeNode | DefaultMutableTreeNode.getChildBefore(TreeNode aChild) 返回此节点的子节点数组中刚好在 aChild 之前的子节点，它必须是此节点的子节点。
int | DefaultMutableTreeNode.getIndex(TreeNode aChild) 返回此节点的子节点数组中指定子节点的索引。
int | TreeNode.getIndex(TreeNode node) 返回接收者子节点中的 node 的索引。
TreeNode[] | DefaultTreeModel.getPathToRoot(TreeNode aNode) 向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected TreeNode[] | DefaultTreeModel.getPathToRoot(TreeNode aNode, int depth) 向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
protected TreeNode[] | DefaultMutableTreeNode.getPathToRoot(TreeNode aNode, int depth) 构建节点的父节点一直到根节点（包括根节点），其中源节点是返回数组中的最后一个元素。
boolean | DefaultMutableTreeNode.isNodeAncestor(TreeNode anotherNode) 如果 anotherNode 是此节点的祖先 -- 如果它是此节点、此节点的父节点或此节点的父节点的祖先，则返回 true。
boolean | DefaultMutableTreeNode.isNodeChild(TreeNode aNode) 如果 aNode 是此节点的子节点，则返回 true。
boolean | DefaultMutableTreeNode.isNodeSibling(TreeNode anotherNode) 如果 anotherNode 是此节点的兄弟节点（与此节点共享同一父节点），则返回 true。
void | DefaultTreeModel.nodeChanged(TreeNode node) 更改节点在树中的表示方式之后，调用此方法。
void | DefaultTreeModel.nodesChanged(TreeNode node, int[] childIndices) 更改由 childIndicies 标识的子对象在树中的表示方式之后，调用此方法。
void | DefaultTreeModel.nodeStructureChanged(TreeNode node) 如果完全更改了节点的子节点、子节点的子节点、依此类推，则调用此方法。
void | DefaultTreeModel.nodesWereInserted(TreeNode node, int[] childIndices) 将某些 TreeNodes 插入节点之后，调用此方法。
void | DefaultTreeModel.nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren) 从节点移除一些 TreeNodes 之后，调用此方法。
Enumeration | DefaultMutableTreeNode.pathFromAncestorEnumeration(TreeNode ancestor) 创建并返回沿着从 ancestor 到此节点的路径的一个枚举。
void | DefaultTreeModel.reload(TreeNode node) 如果已修改此模型依赖的 TreeNode，则调用此方法。
void | DefaultTreeModel.setRoot(TreeNode root) 将根设置为 root。

参数类型为 TreeNode 的 javax.swing.tree 中的构造方法
DefaultTreeModel(TreeNode root)
创建其中任何节点都可以有子节点的树。
DefaultTreeModel(TreeNode root, boolean asksAllowsChildren)
创建一棵树，指定某个节点是否可以有子节点，或者是否仅某些节点可以有子节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AbstractUndoableEdit (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
类 AbstractUndoableEdit

java.lang.Object
    继承者  javax.swing.undo.AbstractUndoableEdit
所有已实现的接口：
Serializable, UndoableEdit
直接已知子类：
AbstractDocument.ElementEdit, CompoundEdit, DefaultStyledDocument.AttributeUndoableEdit, StateEdit
public class AbstractUndoableEdit
extends Object
implements UndoableEdit, Serializable

UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。

字段摘要
protected static String | RedoName 由 getRedoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此段落。
protected static String | UndoName 由 getUndoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此字段。
构造方法摘要
AbstractUndoableEdit()
创建一个 AbstractUndoableEdit，其将 hasBeenDone 和 alive 默认为 true。
方法摘要
boolean | addEdit(UndoableEdit anEdit) 此默认实现返回 false。
boolean | canRedo() 如果此编辑为 alive 并且 hasBeenDone 为 false，则返回 true。
boolean | canUndo() 如果此编辑为 alive 并且 hasBeenDone 为 true，则返回 true。
void | die() 将 alive 设置为 false。
String | getPresentationName() 此默认实现返回 ""。
String | getRedoPresentationName() 检索默认表中 AbstractUndoableEdit.redoText 键的值，并返回该值，后跟一个空格和 getPresentationName。
String | getUndoPresentationName() 检索默认表中 AbstractUndoableEdit.undoText 键的值，并返回该值，后跟一个空格和 getPresentationName。
boolean | isSignificant() 此默认实现返回 true。
void | redo() 如果 canRedo 返回 false，则抛出 CannotRedoException。
boolean | replaceEdit(UndoableEdit anEdit) 此默认实现返回 false。
String | toString() 返回显示和标识此对象属性的字符串。
void | undo() 如果 canUndo 返回 false，则抛出 CannotUndoException。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

UndoName

protected static final String UndoName
由 getUndoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此字段。此值现在已本地化，并且来源于默认表，键为 AbstractUndoableEdit.undoText。

另请参见：
UIDefaults, 常量字段值

RedoName

protected static final String RedoName
由 getRedoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此段落。此值现在已本地化，并且来源于默认表，键为 AbstractUndoableEdit.redoText。

另请参见：
UIDefaults, 常量字段值
构造方法详细信息

AbstractUndoableEdit

public AbstractUndoableEdit()
创建一个 AbstractUndoableEdit，其将 hasBeenDone 和 alive 默认为 true。

方法详细信息

die

public void die()
将 alive 设置为 false。注意，这是一种单向操作；终止的编辑不能重新使启用。将 undo 或 redo 发送到一个终止的编辑将导致抛出异常。

通常，一个编辑与另一编辑的 addEdit 或 replaceEdit 方法合并，或离开 UndoManager 队列时，该方法会被终止。

指定者：
接口 UndoableEdit 中的 die
另请参见：
CompoundEdit.die()

undo

public void undo()
          throws CannotUndoException
如果 canUndo 返回 false，则抛出 CannotUndoException。将 hasBeenDone 设置为 false。子类应该重写以撤消此编辑所表示的操作。重写应该从调用超类开始。

指定者：
接口 UndoableEdit 中的 undo
抛出：
CannotUndoException - 如果 canUndo 返回 false
另请参见：
canUndo()

canUndo

public boolean canUndo()
如果此编辑为 alive 并且 hasBeenDone 为 true，则返回 true。

指定者：
接口 UndoableEdit 中的 canUndo
返回：
如果此编辑为 alive 并且 hasBeenDone 为 true，则返回 true
另请参见：
die(),
undo(),
redo()

redo

public void redo()
          throws CannotRedoException
如果 canRedo 返回 false，则抛出 CannotRedoException。将 hasBeenDone 设置为 true。子类应该重写以重新执行此编辑所表示的操作。重写应该从调用超类开始。

指定者：
接口 UndoableEdit 中的 redo
抛出：
CannotRedoException - 如果 canRedo 返回 false
另请参见：
canRedo()

canRedo

public boolean canRedo()
如果此编辑为 alive 并且 hasBeenDone 为 false，则返回 true。

指定者：
接口 UndoableEdit 中的 canRedo
返回：
如果此编辑为 alive 并且 hasBeenDone 为 false，则返回 true
另请参见：
die(),
undo(),
redo()

addEdit

public boolean addEdit(UndoableEdit anEdit)
此默认实现返回 false。

指定者：
接口 UndoableEdit 中的 addEdit
参数：
anEdit - 要添加的编辑
返回：
false
另请参见：
UndoableEdit.addEdit(javax.swing.undo.UndoableEdit)

replaceEdit

public boolean replaceEdit(UndoableEdit anEdit)
此默认实现返回 false。

指定者：
接口 UndoableEdit 中的 replaceEdit
参数：
anEdit - 要替换的编辑
返回：
false
另请参见：
UndoableEdit.replaceEdit(javax.swing.undo.UndoableEdit)

isSignificant

public boolean isSignificant()
此默认实现返回 true。

指定者：
接口 UndoableEdit 中的 isSignificant
返回：
true
另请参见：
UndoableEdit.isSignificant()

getPresentationName

public String getPresentationName()
此默认实现返回 ""。由 getUndoPresentationName 和 getRedoPresentationName 使用以构造它们返回的字符串。子类应该重写以返回此编辑所表示的操作的适当描述。

指定者：
接口 UndoableEdit 中的 getPresentationName
返回：
空字符串 ""
另请参见：
getUndoPresentationName(), getRedoPresentationName()

getUndoPresentationName

public String getUndoPresentationName()
检索默认表中 AbstractUndoableEdit.undoText 键的值，并返回该值，后跟一个空格和 getPresentationName。如果 getPresentationName 返回 ""，则单独返回默认值。

指定者：
接口 UndoableEdit 中的 getUndoPresentationName
返回：
默认表中 AbstractUndoableEdit.undoText 键的值，如果 getPresentationName 不为 ""，则后跟一个空格和 getPresentationName，否则，单独返回默认值。
另请参见：
getPresentationName()

getRedoPresentationName

public String getRedoPresentationName()
检索默认表中 AbstractUndoableEdit.redoText 键的值，并返回该值，后跟一个空格和 getPresentationName。如果 getPresentationName 返回 ""，则单独返回默认值。

指定者：
接口 UndoableEdit 中的 getRedoPresentationName
返回：
默认表中 AbstractUndoableEdit.redoText 键的值，如果 getPresentationName 不为 ""，则后跟一个空格和 getPresentationName，否则，只返回默认值。
另请参见：
getPresentationName()

toString

public String toString()
返回显示和标识此对象属性的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CannotRedoException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
类 CannotRedoException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.swing.undo.CannotRedoException
所有已实现的接口：
Serializable
public class CannotRedoException
extends RuntimeException

当 UndoableEdit 被通知 redo() 但无法执行时抛出。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
CannotRedoException()
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CannotRedoException

public CannotRedoException()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CannotUndoException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
类 CannotUndoException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.swing.undo.CannotUndoException
所有已实现的接口：
Serializable
public class CannotUndoException
extends RuntimeException

当 UndoableEdit 被通知 undo() 但无法执行时抛出。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
CannotUndoException()
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CannotUndoException

public CannotUndoException()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompoundEdit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
类 CompoundEdit

java.lang.Object
    继承者  javax.swing.undo.AbstractUndoableEdit
        继承者  javax.swing.undo.CompoundEdit
所有已实现的接口：
Serializable, UndoableEdit
直接已知子类：
AbstractDocument.DefaultDocumentEvent, UndoManager
public class CompoundEdit
extends AbstractUndoableEdit

AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。

字段摘要
protected  Vector<UndoableEdit> edits
由此 CompoundEdit 全部撤消/恢复的 UndoableEdit 的集合。
从类 javax.swing.undo.AbstractUndoableEdit 继承的字段
RedoName, UndoName
构造方法摘要
CompoundEdit()
方法摘要
boolean | addEdit(UndoableEdit anEdit) 如果此编辑为 inProgress，则接受 anEdit 并返回 true。
boolean | canRedo() 如果 isInProgress 或者超类返回 false，则此方法返回 false。
boolean | canUndo() 如果 isInProgress 或者超类返回 false，则此方法返回 false。
void | die() 按添加时相反的顺序将 die 发送到每个子编辑。
void | end() 将 inProgress 设置为 false。
String | getPresentationName() 从添加到 edits 的最后 UndoableEdit 返回 getPresentationName。
String | getRedoPresentationName() 从添加到 edits 的最后 UndoableEdit 返回 getRedoPresentationName。
String | getUndoPresentationName() 从添加到 edits 的最后 UndoableEdit 返回 getUndoPresentationName。
boolean | isInProgress() 如果此编辑正在进行中（即未收到结束通知），则返回 true。
boolean | isSignificant() 如果 edits 中的任何 UndoableEdit 返回 true，则返回 true。
protected UndoableEdit | lastEdit() 返回 edits 中最后一个 UndoableEdit，如果 edits 为空，则返回 null。
void | redo() 按添加时的顺序将 redo 发送到所有包含的 UndoableEdit 中。
String | toString() 返回一个显示并标识此对象属性的字符串。
void | undo() 按与添加时相反的顺序将 undo 发送到所有包含的 UndoableEdits 中。
从类 javax.swing.undo.AbstractUndoableEdit 继承的方法
replaceEdit
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

edits

protected Vector<UndoableEdit> edits
由此 CompoundEdit 全部撤消/恢复的 UndoableEdit 的集合。

构造方法详细信息

CompoundEdit

public CompoundEdit()
方法详细信息

undo

public void undo()
          throws CannotUndoException
按与添加时相反的顺序将 undo 发送到所有包含的 UndoableEdits 中。

指定者：
接口 UndoableEdit 中的 undo
覆盖：
类 AbstractUndoableEdit 中的 undo
抛出：
CannotUndoException - 如果 canUndo 返回 false
另请参见：
AbstractUndoableEdit.canUndo()

redo

public void redo()
          throws CannotRedoException
按添加时的顺序将 redo 发送到所有包含的 UndoableEdit 中。

指定者：
接口 UndoableEdit 中的 redo
覆盖：
类 AbstractUndoableEdit 中的 redo
抛出：
CannotRedoException - 如果 canRedo 返回 false
另请参见：
AbstractUndoableEdit.canRedo()

lastEdit

protected UndoableEdit lastEdit()
返回 edits 中最后一个 UndoableEdit，如果 edits 为空，则返回 null。

die

public void die()
按添加时相反的顺序将 die 发送到每个子编辑。

指定者：
接口 UndoableEdit 中的 die
覆盖：
类 AbstractUndoableEdit 中的 die
另请参见：
die()

addEdit

public boolean addEdit(UndoableEdit anEdit)
如果此编辑为 inProgress，则接受 anEdit 并返回 true。

对添加到此 CompoundEdit 的最后编辑执行 addEdit(anEdit) 操作。如果拒绝（返回 false），则对 anEdit 执行对最后编辑进行 replaceEdit 的操作。如果此处 anEdit 返回 false，则将它添加到 edits。

指定者：
接口 UndoableEdit 中的 addEdit
覆盖：
类 AbstractUndoableEdit 中的 addEdit
参数：
anEdit - 要添加的编辑
返回：
如果该编辑为 inProgress，则返回 true；否则返回 false
另请参见：
UndoableEdit.addEdit(javax.swing.undo.UndoableEdit)

end

public void end()
将 inProgress 设置为 false。

另请参见：
canUndo(), canRedo()

canUndo

public boolean canUndo()
如果 isInProgress 或者超类返回 false，则此方法返回 false。

指定者：
接口 UndoableEdit 中的 canUndo
覆盖：
类 AbstractUndoableEdit 中的 canUndo
返回：
如果此编辑为 alive 并且 hasBeenDone 为 true，则返回 true
另请参见：
isInProgress()

canRedo

public boolean canRedo()
如果 isInProgress 或者超类返回 false，则此方法返回 false。

指定者：
接口 UndoableEdit 中的 canRedo
覆盖：
类 AbstractUndoableEdit 中的 canRedo
返回：
如果此编辑为 alive 并且 hasBeenDone 为 false，则返回 true
另请参见：
isInProgress()

isInProgress

public boolean isInProgress()
如果此编辑正在进行中（即未收到结束通知），则返回 true。这通常意味着还在向其中添加编辑。

另请参见：
end()

isSignificant

public boolean isSignificant()
如果 edits 中的任何 UndoableEdit 返回 true，则返回 true。如果它们都返回 false，则返回 false。

指定者：
接口 UndoableEdit 中的 isSignificant
覆盖：
类 AbstractUndoableEdit 中的 isSignificant
返回：
true
另请参见：
UndoableEdit.isSignificant()

getPresentationName

public String getPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getPresentationName。如果 edits 为空，则调用超类。

指定者：
接口 UndoableEdit 中的 getPresentationName
覆盖：
类 AbstractUndoableEdit 中的 getPresentationName
返回：
空字符串 ""
另请参见：
AbstractUndoableEdit.getUndoPresentationName(), AbstractUndoableEdit.getRedoPresentationName()

getUndoPresentationName

public String getUndoPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getUndoPresentationName。如果 edits 为空，则调用超类。

指定者：
接口 UndoableEdit 中的 getUndoPresentationName
覆盖：
类 AbstractUndoableEdit 中的 getUndoPresentationName
返回：
默认表中 AbstractUndoableEdit.undoText 键的值，如果 getPresentationName 不为 ""，则后跟一个空格和 getPresentationName，否则，单独返回默认值。
另请参见：
AbstractUndoableEdit.getPresentationName()

getRedoPresentationName

public String getRedoPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getRedoPresentationName。如果 edits 为空，则调用超类。

指定者：
接口 UndoableEdit 中的 getRedoPresentationName
覆盖：
类 AbstractUndoableEdit 中的 getRedoPresentationName
返回：
默认表中 AbstractUndoableEdit.redoText 键的值，如果 getPresentationName 不为 ""，则后跟一个空格和 getPresentationName，否则，只返回默认值。
另请参见：
AbstractUndoableEdit.getPresentationName()

toString

public String toString()
返回一个显示并标识此对象属性的字符串。

覆盖：
类 AbstractUndoableEdit 中的 toString
返回：
此对象的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StateEdit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
类 StateEdit

java.lang.Object
    继承者  javax.swing.undo.AbstractUndoableEdit
        继承者  javax.swing.undo.StateEdit
所有已实现的接口：
Serializable, UndoableEdit
public class StateEdit
extends AbstractUndoableEdit

StateEdit 是更改状态的对象的通用编辑。被编辑的对象必须遵守 StateEditable 接口。

此编辑类的工作方式是，在编辑发生之前和发生之后，请求对象将其状态存储在 Hashtable 中。通过撤消或恢复操作，通知该对象从这些 Hashtable 中恢复其状态。

按如下方式使用状态编辑：
        // Create the edit during the "before" state of the object
        StateEdit newEdit = new StateEdit(myObject);
        // Modify the object
        myObject.someStateModifyingMethod();
        // "end" the edit when you are done modifying the object
        newEdit.end();

注意，当 StateEdit 结束时，它将从 Hashtable 中移除多余的状态 - 状态 Hashtable 并不保证包含在存储状态时放入其中的所有键/值！

另请参见：
StateEditable

字段摘要
protected StateEditable | object 被编辑的对象
protected Hashtable<Object,Object> | postState 编辑之后的状态信息
protected Hashtable<Object,Object> | preState 编辑之前的状态信息
protected static String | RCSID
protected String | undoRedoName 撤消/恢复的表示名称
从类 javax.swing.undo.AbstractUndoableEdit 继承的字段
RedoName, UndoName
构造方法摘要
StateEdit(StateEditable anObject)
创建并返回新的 StateEdit。
StateEdit(StateEditable anObject, String name)
创建并返回具有表示名称的新 StateEdit。
方法摘要
void | end() 获取 StateEditable 对象的后编辑状态，并结束编辑。
String | getPresentationName() 获取此编辑的表示名称
protected void | init(StateEditable anObject, String name)
void | redo() 通知编辑对象应用编辑之后的状态
protected void | removeRedundantState() 移除状态哈希表中多余的键/值。
void | undo() 通知被编辑的对象应用编辑之前的状态
从类 javax.swing.undo.AbstractUndoableEdit 继承的方法
addEdit, canRedo, canUndo, die, getRedoPresentationName, getUndoPresentationName, isSignificant, replaceEdit, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

RCSID

protected static final String RCSID
另请参见：
常量字段值

object

protected StateEditable object
被编辑的对象

preState

protected Hashtable<Object,Object> preState
编辑之前的状态信息

postState

protected Hashtable<Object,Object> postState
编辑之后的状态信息

undoRedoName

protected String undoRedoName
撤消/恢复的表示名称

构造方法详细信息

StateEdit

public StateEdit(StateEditable anObject)
创建并返回新的 StateEdit。

参数：
anObject - 监视更改状态的对象
另请参见：
StateEdit

StateEdit

public StateEdit(StateEditable anObject,
                 String name)
创建并返回具有表示名称的新 StateEdit。

参数：
anObject - 监视更改状态的对象
name - 将用于此编辑的表示名称
另请参见：
StateEdit
方法详细信息

init

protected void init(StateEditable anObject,
                    String name)

end

public void end()
获取 StateEditable 对象的后编辑状态，并结束编辑。

undo

public void undo()
通知被编辑的对象应用编辑之前的状态

指定者：
接口 UndoableEdit 中的 undo
覆盖：
类 AbstractUndoableEdit 中的 undo
另请参见：
AbstractUndoableEdit.canUndo()

redo

public void redo()
通知编辑对象应用编辑之后的状态

指定者：
接口 UndoableEdit 中的 redo
覆盖：
类 AbstractUndoableEdit 中的 redo
另请参见：
AbstractUndoableEdit.canRedo()

getPresentationName

public String getPresentationName()
获取此编辑的表示名称

指定者：
接口 UndoableEdit 中的 getPresentationName
覆盖：
类 AbstractUndoableEdit 中的 getPresentationName
返回：
空字符串 ""
另请参见：
AbstractUndoableEdit.getUndoPresentationName(), AbstractUndoableEdit.getRedoPresentationName()

removeRedundantState

protected void removeRedundantState()
移除状态哈希表中多余的键/值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StateEditable (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
接口 StateEditable

public interface StateEditable

StateEditable 定义可以由 StateEdit 撤消/恢复其状态的对象的接口。

另请参见：
StateEdit

字段摘要
static String RCSID
此类的资源 ID。
方法摘要
void | restoreState(Hashtable<?,?> state) 收到此消息时，接收者应从 state 中提取任何相关状态。
void | storeState(Hashtable<Object,Object> state) 收到此消息时，接收者应把任何相关状态放置到 state 中。

字段详细信息

RCSID

static final String RCSID
此类的资源 ID。

另请参见：
常量字段值
方法详细信息

storeState

void storeState(Hashtable<Object,Object> state)
收到此消息时，接收者应把任何相关状态放置到 state 中。

restoreState

void restoreState(Hashtable<?,?> state)
收到此消息时，接收者应从 state 中提取任何相关状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UndoableEdit (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
接口 UndoableEdit

所有已知实现类：
AbstractDocument.DefaultDocumentEvent, AbstractDocument.ElementEdit, AbstractUndoableEdit, CompoundEdit, DefaultStyledDocument.AttributeUndoableEdit, StateEdit, UndoManager
public interface UndoableEdit

UndoableEdit 表示一个编辑。该编辑可被撤消，如果已撤消，该编辑可恢复。

设计 UndoableEdit 与 UndoManager 一起使用。由于 UndoableEdit 是由 UndoableEditListener 生成的，所以通常将它们添加到 UndoManager。当将 UndoableEdit 添加到 UndoManager 时，会发生以下事件（假定没有在 UndoManager 上调用 end）：

  1. 如果 UndoManager 包含编辑，则它将在当前编辑上调用 addEdit，传入新的编辑作为参数。如果 addEdit 返回 true，则新的编辑被视为已合并到当前编辑中，并且不会将新的编辑添加到当前编辑列表。编辑可以使用 addEdit 将多个较小编辑合并到较大编辑中，并且将合并后的编辑视为单个编辑。
  2. 如果 addEdit 返回 false，则以传入的当前编辑对新的编辑调用 replaceEdit。这与 addEdit 截然相反 — 如果新的编辑从 replaceEdit 返回 true，则新的编辑将替换当前编辑。
UndoManager 使用 isSignificant 确定应该撤消或恢复多少编辑。UndoManager 将撤消或恢复当前编辑与最后一个或下一个有效编辑之间的所有无效编辑（isSignificant 返回 false）。addEdit 和 replaceEdit 可用于将多个编辑视为单个编辑，从 isSignificant 返回 false 允许 treating 可用于一次撤消或恢复多个较小编辑。也可以使用 addEdit 方法完成类似的功能。

方法摘要
boolean | addEdit(UndoableEdit anEdit) 将 UndoableEdit 添加到此 UndoableEdit。
boolean | canRedo() 如果可以恢复此编辑，则返回 true。
boolean | canUndo() 如果可以撤消此编辑，则返回 true。
void | die() 通知某个编辑不应再使用它。
String | getPresentationName() 返回此编辑的本地化可读描述，例如，适于在更改日志中使用。
String | getRedoPresentationName() 返回此编辑可恢复形式的本地化可读描述，例如，适于用作 “Redo” 菜单项。
String | getUndoPresentationName() 返回此编辑可撤消形式的本地化可读描述，例如，适于用作 “Undo” 菜单项。
boolean | isSignificant() 如果认为此编辑有效，则返回 true。
void | redo() 重新应用编辑。
boolean | replaceEdit(UndoableEdit anEdit) 如果此 UndoableEdit 应替换 anEdit，则返回 true。
void | undo() 撤消编辑。

方法详细信息

undo

void undo()
          throws CannotUndoException
撤消编辑。

抛出：
CannotUndoException - 如果不能撤消此编辑

canUndo

boolean canUndo()
如果可以撤消此编辑，则返回 true。

返回：
如果可以撤消此编辑，则返回 true

redo

void redo()
          throws CannotRedoException
重新应用编辑。

抛出：
CannotRedoException - 如果不能恢复此编辑

canRedo

boolean canRedo()
如果可以恢复此编辑，则返回 true。

返回：
如果可以恢复此编辑，则返回 true

die

void die()
通知某个编辑不应再使用它。一旦将 UndoableEdit 标记为停用，则不能再对它进行撤消或恢复。

对于不可能撤消或恢复时清除不再需要的状态而言，这是一个有用的钩子 (hook)。例如，删除不能再恢复的对象所使用的文件资源。UndoManager 在其离开编辑队列之前调用它。

注意，这是一个单向操作。不存在 "un-die" 方法。

另请参见：
CompoundEdit.die()

addEdit

boolean addEdit(UndoableEdit anEdit)
将 UndoableEdit 添加到此 UndoableEdit。此方法可用于将多个较小编辑合并为一个较大的复合编辑。例如，文本编辑器通常允许对单词或句子应用撤消操作。文本编辑器可以选择在每个关键事件上生成编辑，但允许将这些编辑合并为一个更加用户友好的单元，比如一个单词。在这种情况下，当可以合并编辑时，UndoableEdit 将重写 addEdit 以返回 true。

返回值为 true 指示已将 anEdit 合并到此编辑。返回值为 false 指示不能将 anEdit 合并到此编辑。

通常，接收者已经在 UndoManager（或者其他 UndoableEditListener）队列中，并且可以合并 anEdit，而不是将它按顺序添加到队列中。

如果返回 true，则从现在开始，anEdit 必须从 canUndo 和 canRedo 返回 false，并且必须对 undo 或 redo 抛出适当的异常。

参数：
anEdit - 要添加的编辑
返回：
如果可以将 anEdit 合并到此编辑，则返回 true

replaceEdit

boolean replaceEdit(UndoableEdit anEdit)
如果此 UndoableEdit 应替换 anEdit，则返回 true。此方法由 CompoundEdit 和 UndoManager 使用；如果不能将 anEdit 添加到当前编辑（addEdit 返回 false），则调用此方法。

此方法提供了某个编辑替换现有编辑的方法。

此消息与 addEdit 相反 -- anEdit 通常已经在 UndoManager（或者其他 UndoableEditListener）的队列中，并且接收者可以替换它。

如果返回 true，则从现在开始，anEdit 必须从 canUndo() 和 canRedo() 返回 false，并且必须对 undo() 或 redo() 抛出适当的异常。

参数：
anEdit - 替换当前编辑的编辑
返回：
如果此编辑应该替换 anEdit，则返回 true

isSignificant

boolean isSignificant()
如果认为此编辑有效，则返回 true。有效编辑通常是指应该呈现给用户的编辑，可能在菜单项或工具提示上。UndoManager 将为下一个有效编辑撤消或恢复所有无效编辑。

返回：
如果此编辑有效，则返回 true

getPresentationName

String getPresentationName()
返回此编辑的本地化可读描述，例如，适于在更改日志中使用。

返回：
此编辑的描述

getUndoPresentationName

String getUndoPresentationName()
返回此编辑可撤消形式的本地化可读描述，例如，适于用作 “Undo” 菜单项。此方法通常派生自 getPresentationName。

返回：
此编辑可撤消形式的描述

getRedoPresentationName

String getRedoPresentationName()
返回此编辑可恢复形式的本地化可读描述，例如，适于用作 “Redo” 菜单项。此方法通常派生自 getPresentationName。

返回：
此编辑可恢复形式的描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UndoableEditSupport (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
类 UndoableEditSupport

java.lang.Object
    继承者  javax.swing.undo.UndoableEditSupport

public class UndoableEditSupport
extends Object

用于管理 UndoableEdit 侦听器的支持类。

字段摘要
protected CompoundEdit | compoundEdit
protected Vector<UndoableEditListener> | listeners
protected Object | realSource
protected int | updateLevel
构造方法摘要
UndoableEditSupport()
构造一个 UndoableEditSupport 对象。
UndoableEditSupport(Object r)
构造一个 UndoableEditSupport 对象。
方法摘要
protected  void _postEdit(UndoableEdit e)
仅从 postEdit 和 endUpdate 调用。
 void addUndoableEditListener(UndoableEditListener l)
注册一个 UndoableEditListener。
 void beginUpdate()
protected  CompoundEdit createCompoundEdit()
仅从 beginUpdate 调用。
 void endUpdate()
死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。
 UndoableEditListener[] getUndoableEditListeners()
返回使用 addUndoableEditListener() 添加到此 UndoableEditSupport 中的所有 UndoableEditListener 组成的数组。
 int getUpdateLevel()
返回更新级别值。
 void postEdit(UndoableEdit e)
死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。
 void removeUndoableEditListener(UndoableEditListener l)
移除一个 UndoableEditListener。
 String toString()
返回显示和标识此对象属性的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

updateLevel

protected int updateLevel

compoundEdit

protected CompoundEdit compoundEdit

listeners

protected Vector<UndoableEditListener> listeners

realSource

protected Object realSource
构造方法详细信息

UndoableEditSupport

public UndoableEditSupport()
构造一个 UndoableEditSupport 对象。

UndoableEditSupport

public UndoableEditSupport(Object r)
构造一个 UndoableEditSupport 对象。

参数：
r - 一个 Object
方法详细信息

addUndoableEditListener

public void addUndoableEditListener(UndoableEditListener l)
注册一个 UndoableEditListener。每当可撤消的编辑产生时就通知侦听器。

参数：
l - 一个 UndoableEditListener 对象
另请参见：
removeUndoableEditListener(javax.swing.event.UndoableEditListener)

removeUndoableEditListener

public void removeUndoableEditListener(UndoableEditListener l)
移除一个 UndoableEditListener。

参数：
l - 要移除的 UndoableEditListener
另请参见：
addUndoableEditListener(javax.swing.event.UndoableEditListener)

getUndoableEditListeners

public UndoableEditListener[] getUndoableEditListeners()
返回使用 addUndoableEditListener() 添加到此 UndoableEditSupport 中的所有 UndoableEditListener 组成的数组。

返回：
添加的所有 UndoableEditListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

_postEdit

protected void _postEdit(UndoableEdit e)
仅从 postEdit 和 endUpdate 调用。调用所有侦听器中的 undoableEditHappened。此处不执行同步，因为两个调用方法已同步。

postEdit

public void postEdit(UndoableEdit e)
死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。从它的一个侦听器中调用此方法是不明智的。

getUpdateLevel

public int getUpdateLevel()
返回更新级别值。

返回：
表示更新级别的整数

beginUpdate

public void beginUpdate()

createCompoundEdit

protected CompoundEdit createCompoundEdit()
仅从 beginUpdate 调用。在此处公开供子类使用。

endUpdate

public void endUpdate()
死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。从它的一个侦听器中调用此方法是不明智的。

toString

public String toString()
返回显示和标识此对象属性的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UndoManager (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.undo
类 UndoManager

java.lang.Object
    继承者  javax.swing.undo.AbstractUndoableEdit
        继承者  javax.swing.undo.CompoundEdit
            继承者  javax.swing.undo.UndoManager
所有已实现的接口：
Serializable, EventListener, UndoableEditListener, UndoableEdit
public class UndoManager
extends CompoundEdit
implements UndoableEditListener

UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。有两个方法可以将编辑添加到 UndoManager。直接使用 addEdit 方法添加编辑，或将 UndoManager 添加到支持 UndoableEditListener 的 bean。下面的例子创建了一个 UndoManager 并将它作为 UndoableEditListener 添加到 JTextField：

   UndoManager undoManager = new UndoManager();
   JTextField tf = ...;
   tf.getDocument().addUndoableEditListener(undoManager);

UndoManager 维护编辑的有序列表以及该列表中下一个编辑的索引。下一个编辑的索引为当前编辑列表的大小，如果已经调用了 undo，则该索引对应于已撤消的最后一个有效编辑的索引。调用 undo 时，所有的编辑（从下一个编辑的索引到最后一个有效编辑）都将以相反的顺序被撤消。例如，考虑由以下编辑组成的 UndoManager ：A b c D。粗体大写字母的编辑为有效编辑，斜体小写字母的编辑为无效编辑。

Figure 1

如 figure 1 中所示，如果刚刚添加了 D，则下一个编辑的索引为 4。调用 undo 导致在 D 上调用 undo 并将下一个编辑的索引设置为 3（编辑 c），如下图所示。

Figure 2

最后一个有效编辑为 A，所以调用 undo 会在 c、b、和A 上以该顺序再次调用 undo，并将下一个编辑的索引设置为 0，如下图所示。

Figure 3

调用 redo 会导致在下一个编辑的索引和下一个有效编辑（或列表结尾位置）之间的所有编辑上调用 redo。继续上一个例子，如果调用了 redo，则将依次在 A、b 和 c 上调用 redo。此外，下一个编辑的索引被设置为 3 （如 figure 2 中所示）。

将一个编辑添加到 UndoManager 会移除从下一个编辑的索引到列表结尾位置的所有编辑。继续上一个例子，如果添加一个新的编辑 e，则从列表中移除编辑 D （在它上面调用 die 之后）。如果下一个编辑没有合并（c.addEdit(e) 返回 true）或替换（e.replaceEdit(c) 返回 true）c，则将新的编辑添加到 c 的后面，如下图所示。

Figure 4

在 UndoManager 上调用了 end 后，超类行为将用于所有 UndoableEdit 方法。有关其行为的详细信息，请参阅 CompoundEdit。

不同于 Swing 的其他类，此类是线程安全的。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.undo.CompoundEdit 继承的字段
edits
从类 javax.swing.undo.AbstractUndoableEdit 继承的字段
RedoName, UndoName
构造方法摘要
UndoManager()
创建一个新的 UndoManager。
方法摘要
boolean | addEdit(UndoableEdit anEdit) 如果可能，将一个 UndoableEdit 添加到此 UndoManager。
boolean | canRedo() 如果可以恢复编辑，则返回 true。
boolean | canUndo() 如果可以撤消编辑，则返回 true。
boolean | canUndoOrRedo() 如果可以调用 undo 或 redo，则返回 true。
void | discardAllEdits() 清空撤消管理器，向进程中的每个编辑发送一个 die 消息。
protected UndoableEdit | editToBeRedone() 如果调用 redo，则返回下一个要恢复的有效编辑。
protected UndoableEdit | editToBeUndone() 如果调用 undo，则返回下一个要撤消的有效编辑。
void | end() 将此 UndoManager 转换为标准 CompoundEdit。
int | getLimit() 返回此 UndoManager 保持的最大编辑数。
String | getRedoPresentationName() 返回此编辑可恢复形式的描述。
String | getUndoOrRedoPresentationName() 一个便捷方法，它返回 getUndoPresentationName 或 getRedoPresentationName。
String | getUndoPresentationName() 返回此编辑可撤消形式的描述。
void | redo() 恢复适当的编辑。
protected void | redoTo(UndoableEdit edit) 恢复从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
void | setLimit(int l) 设置此 UndoManager 保持的最大编辑数。
String | toString() 返回显示和标识此对象属性的字符串。
protected void | trimEdits(int from, int to) 移除指定范围内的编辑。
protected void | trimForLimit() 以下一个编辑的索引为中心，将已排队编辑的数量减少到限制的大小范围内。
void | undo() 撤消适当的编辑。
void | undoableEditHappened(UndoableEditEvent e) 一个 UndoableEditListener 方法。
void | undoOrRedo() 一个便捷方法，它调用 undo 或 redo。
protected void | undoTo(UndoableEdit edit) 撤消从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
从类 javax.swing.undo.CompoundEdit 继承的方法
die, getPresentationName, isInProgress, isSignificant, lastEdit
从类 javax.swing.undo.AbstractUndoableEdit 继承的方法
replaceEdit
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UndoManager

public UndoManager()
创建一个新的 UndoManager。

方法详细信息

getLimit

public int getLimit()
返回此 UndoManager 保持的最大编辑数。小于 0 的值指示编辑数不受限制。

返回：
此 UndoManager 保持的最大编辑数
另请参见：
addEdit(javax.swing.undo.UndoableEdit), setLimit(int)

discardAllEdits

public void discardAllEdits()
清空撤消管理器，向进程中的每个编辑发送一个 die 消息。

另请参见：
AbstractUndoableEdit.die()

trimForLimit

protected void trimForLimit()
以下一个编辑的索引为中心，将已排队编辑的数量减少到限制的大小范围内。

trimEdits

protected void trimEdits(int from,
                         int to)
移除指定范围内的编辑。对给定范围内的所有编辑（包括两端，以相反顺序）调用 die， 并从编辑列表中移除它们。如果 from > to，则此方法没有任何效果。

参数：
from - 要移除的最小索引
to - 要移除的最大索引

setLimit

public void setLimit(int l)
设置此 UndoManager 保持的最大编辑数。小于 0 的值指示编辑数不受限制。如果需要丢弃编辑以缩小限制，则将以添加编辑的相反顺序对其调用 die。默认值为 100。

参数：
l - 新的限制
抛出：
RuntimeException - 如果不再执行此 UndoManager（调用了 end）
另请参见：
CompoundEdit.isInProgress(),
end(),
addEdit(javax.swing.undo.UndoableEdit),
getLimit()

editToBeUndone

protected UndoableEdit editToBeUndone()
如果调用 undo，则返回下一个要撤消的有效编辑。如果没有要撤消的编辑，则此方法返回 null。

返回：
下一个要撤消的有效编辑

editToBeRedone

protected UndoableEdit editToBeRedone()
如果调用 redo，则返回下一个要恢复的有效编辑。如果没有要恢复的编辑，则此方法返回 null。

返回：
下一个要恢复的有效编辑

undoTo

protected void undoTo(UndoableEdit edit)
               throws CannotUndoException
撤消从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。

抛出：
CannotUndoException - 如果其中一个编辑抛出 CannotUndoException

redoTo

protected void redoTo(UndoableEdit edit)
               throws CannotRedoException
恢复从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。

抛出：
CannotUndoException - 如果其中一个编辑抛出 CannotUndoException
CannotRedoException

undoOrRedo

public void undoOrRedo()
                throws CannotRedoException,
                       CannotUndoException
一个便捷方法，它调用 undo 或 redo。如果已撤消了所有编辑（下一个编辑的索引小于编辑列表的长度），则此方法调用 redo，否则调用 undo。

抛出：
CannotUndoException - 如果其中一个编辑抛出 CannotUndoException
CannotRedoException - 如果其中一个编辑抛出 CannotRedoException
另请参见：
canUndoOrRedo(), getUndoOrRedoPresentationName()

canUndoOrRedo

public boolean canUndoOrRedo()
如果可以调用 undo 或 redo，则返回 true。

返回：
如果调用 canUndoOrRedo 有效，则返回 true
另请参见：
undoOrRedo()

undo

public void undo()
          throws CannotUndoException
撤消适当的编辑。如果已调用了 end，则通过此方法调用超类，否则此方法对下一个编辑的索引和最后一个有效编辑之间的所有编辑调用 undo，适当地更新下一个编辑的索引。

指定者：
接口 UndoableEdit 中的 undo
覆盖：
类 CompoundEdit 中的 undo
抛出：
CannotUndoException - 如果其中一个编辑抛出 CannotUndoException 或没有要撤消的编辑
另请参见：
CompoundEdit.end(),
canUndo(),
editToBeUndone()

canUndo

public boolean canUndo()
如果可以撤消编辑，则返回 true。如果已调用了 end，则此方法返回来自超类的值。否则，如果有要撤消的编辑（editToBeUndone 返回非 null），则此方法返回 true。

指定者：
接口 UndoableEdit 中的 canUndo
覆盖：
类 CompoundEdit 中的 canUndo
返回：
如果有要撤消的编辑，则返回 true
另请参见：
CompoundEdit.canUndo(), editToBeUndone()

redo

public void redo()
          throws CannotRedoException
恢复适当的编辑。如果已调用了 end，则此方法调用超类，否则此方法对下一个编辑的索引和下一个有效编辑之间的所有编辑调用 redo，适当地更新下一个编辑的索引。

指定者：
接口 UndoableEdit 中的 redo
覆盖：
类 CompoundEdit 中的 redo
抛出：
CannotRedoException - 如果其中一个编辑抛出 CannotRedoException 或没有要恢复的编辑
另请参见：
CompoundEdit.end(),
canRedo(),
editToBeRedone()

canRedo

public boolean canRedo()
如果可以恢复编辑，则返回 true。如果已调用了 end，则此方法返回来自超类的值。否则，如果有要恢复的编辑（editToBeRedone 返回非 null），则此方法返回 true。

指定者：
接口 UndoableEdit 中的 canRedo
覆盖：
类 CompoundEdit 中的 canRedo
返回：
如果有要恢复的编辑，则返回 true
另请参见：
CompoundEdit.canRedo(), editToBeRedone()

addEdit

public boolean addEdit(UndoableEdit anEdit)
如果可能，将一个 UndoableEdit 添加到此 UndoManager。此方法移除从下一个编辑的索引到编辑列表结尾位置的所有编辑。如果已调用了 end，则不添加该编辑并返回 false。如果没有调用 end，则此方法返回 true。

指定者：
接口 UndoableEdit 中的 addEdit
覆盖：
类 CompoundEdit 中的 addEdit
参数：
anEdit - 要添加的编辑
返回：
如果可以将 anEdit 合并到此编辑，则返回 true
另请参见：
CompoundEdit.end(), CompoundEdit.addEdit(javax.swing.undo.UndoableEdit)

end

public void end()
将此 UndoManager 转换为标准 CompoundEdit。这将移除所有已撤消的编辑。

覆盖：
类 CompoundEdit 中的 end
另请参见：
CompoundEdit.end()

getUndoOrRedoPresentationName

public String getUndoOrRedoPresentationName()
一个便捷方法，它返回 getUndoPresentationName 或 getRedoPresentationName。如果下一个编辑的索引等于编辑列表的大小，则返回 getUndoPresentationName，否则返回 getRedoPresentationName。

返回：
撤消或恢复的名称

getUndoPresentationName

public String getUndoPresentationName()
返回此编辑可撤消形式的描述。如果已调用了 end，则通过此方法调用超类。否则，如果有要撤消的编辑，则此方法返回下一个将要撤消的有效编辑的值。如果没有要撤消的编辑且没有调用 end，则此方法返回取自 UIManager 属性“AbstractUndoableEdit.undoText”的值。

指定者：
接口 UndoableEdit 中的 getUndoPresentationName
覆盖：
类 CompoundEdit 中的 getUndoPresentationName
返回：
此编辑可撤消形式的描述
另请参见：
undo(), CompoundEdit.getUndoPresentationName()

getRedoPresentationName

public String getRedoPresentationName()
返回此编辑可恢复形式的描述。如果已调用了 end ，则此方法调用到超类。否则，如果有要恢复的编辑，此方法返回下一个将要恢复的有效编辑的值。如果没有要恢复的编辑且没有调用 end，则此方法返回取自 UIManager 属性“AbstractUndoableEdit.redoText”的值。

指定者：
接口 UndoableEdit 中的 getRedoPresentationName
覆盖：
类 CompoundEdit 中的 getRedoPresentationName
返回：
此编辑可恢复形式的描述
另请参见：
redo(), CompoundEdit.getRedoPresentationName()

undoableEditHappened

public void undoableEditHappened(UndoableEditEvent e)
一个 UndoableEditListener 方法。此方法使用 e.getEdit() 调用 addEdit。

指定者：
接口 UndoableEditListener 中的 undoableEditHappened
参数：
e - 要从中添加 UndoableEditEvent 的 UndoableEditEvent
另请参见：
addEdit(javax.swing.undo.UndoableEdit)

toString

public String toString()
返回显示和标识此对象属性的字符串。

覆盖：
类 CompoundEdit 中的 toString
返回：
此对象的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.undo (Java Platform SE 6)

 javax.swing.undo
接口
StateEditable
UndoableEdit
类
AbstractUndoableEdit
CompoundEdit
StateEdit
UndoableEditSupport
UndoManager
异常
CannotRedoException
CannotUndoException


javax.swing.undo (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.undo

允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

请参见：
描述

接口摘要
StateEditable | StateEditable 定义可以由 StateEdit 撤消/恢复其状态的对象的接口。
UndoableEdit | UndoableEdit 表示一个编辑。

类摘要
AbstractUndoableEdit | UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
CompoundEdit | AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
StateEdit | StateEdit 是更改状态的对象的通用编辑。
UndoableEditSupport | 用于管理 UndoableEdit 侦听器的支持类。
UndoManager | UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

异常摘要
CannotRedoException | 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
CannotUndoException | 当 UndoableEdit 被通知 undo() 但无法执行时抛出。

软件包 javax.swing.undo 的描述

允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

注：大多数 Swing API 都不是 线程安全的。有关详细信息，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • The Java Tutorial 中的 Implementing Undo and Redo 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.undo 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.undo 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.undo.AbstractUndoableEdit (implements java.io.Serializable, javax.swing.undo.UndoableEdit)
      • javax.swing.undo.CompoundEdit
        • javax.swing.undo.UndoManager (implements javax.swing.event.UndoableEditListener)
      • javax.swing.undo.StateEdit
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.swing.undo.CannotRedoException
          • javax.swing.undo.CannotUndoException
    • javax.swing.undo.UndoableEditSupport

接口分层结构

  • javax.swing.undo.StateEditable
  • javax.swing.undo.UndoableEdit
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.undo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.undo
的使用

使用 javax.swing.undo 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.event 使用的 javax.swing.undo 中的类
UndoableEdit
UndoableEdit 表示一个编辑。

javax.swing.text 使用的 javax.swing.undo 中的类
AbstractUndoableEdit
UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
CannotRedoException
当 UndoableEdit 被通知 redo() 但无法执行时抛出。
CannotUndoException
当 UndoableEdit 被通知 undo() 但无法执行时抛出。
CompoundEdit
AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
UndoableEdit
UndoableEdit 表示一个编辑。

javax.swing.undo 使用的 javax.swing.undo 中的类
AbstractUndoableEdit
UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
CannotRedoException
当 UndoableEdit 被通知 redo() 但无法执行时抛出。
CannotUndoException
当 UndoableEdit 被通知 undo() 但无法执行时抛出。
CompoundEdit
AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
StateEditable
StateEditable 定义可以由 StateEdit 撤消/恢复其状态的对象的接口。
UndoableEdit
UndoableEdit 表示一个编辑。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.undo.CannotRedoException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.CannotRedoException
的使用

使用 CannotRedoException 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 CannotRedoException 的使用

抛出 CannotRedoException 的 javax.swing.text 中的方法
void | DefaultStyledDocument.AttributeUndoableEdit.redo() 重复更改。
void | AbstractDocument.DefaultDocumentEvent.redo() 重复执行更改。
void | AbstractDocument.ElementEdit.redo() 重复执行更改。

javax.swing.undo 中 CannotRedoException 的使用

抛出 CannotRedoException 的 javax.swing.undo 中的方法
void | UndoManager.redo() 恢复适当的编辑。
void | CompoundEdit.redo() 按添加时的顺序将 redo 发送到所有包含的 UndoableEdit 中。
void | AbstractUndoableEdit.redo() 如果 canRedo 返回 false，则抛出 CannotRedoException。
void | UndoableEdit.redo() 重新应用编辑。
protected void | UndoManager.redoTo(UndoableEdit edit) 恢复从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
void | UndoManager.undoOrRedo() 一个便捷方法，它调用 undo 或 redo。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.undo.CannotUndoException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.CannotUndoException
的使用

使用 CannotUndoException 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 CannotUndoException 的使用

抛出 CannotUndoException 的 javax.swing.text 中的方法
void | DefaultStyledDocument.AttributeUndoableEdit.undo() 撤消更改。
void | AbstractDocument.DefaultDocumentEvent.undo() 撤消更改。
void | AbstractDocument.ElementEdit.undo() 撤消更改。

javax.swing.undo 中 CannotUndoException 的使用

抛出 CannotUndoException 的 javax.swing.undo 中的方法
void | UndoManager.undo() 撤消适当的编辑。
void | CompoundEdit.undo() 按与添加时相反的顺序将 undo 发送到所有包含的 UndoableEdits 中。
void | AbstractUndoableEdit.undo() 如果 canUndo 返回 false，则抛出 CannotUndoException。
void | UndoableEdit.undo() 撤消编辑。
void | UndoManager.undoOrRedo() 一个便捷方法，它调用 undo 或 redo。
protected void | UndoManager.undoTo(UndoableEdit edit) 撤消从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.undo.StateEdit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.StateEdit
的使用

没有 javax.swing.undo.StateEdit 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.undo.StateEditable 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.undo.StateEditable
的使用

使用 StateEditable 的软件包
javax.swing.undo 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.undo 中 StateEditable 的使用

声明为 StateEditable 的 javax.swing.undo 中的字段
protected  StateEditable StateEdit.object
被编辑的对象

参数类型为 StateEditable 的 javax.swing.undo 中的方法
protected  void StateEdit.init(StateEditable anObject, String name)

参数类型为 StateEditable 的 javax.swing.undo 中的构造方法
StateEdit(StateEditable anObject)
创建并返回新的 StateEdit。
StateEdit(StateEditable anObject, String name)
创建并返回具有表示名称的新 StateEdit。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.undo.UndoManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.UndoManager
的使用

没有 javax.swing.undo.UndoManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.undo.UndoableEditSupport 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.UndoableEditSupport
的使用

没有 javax.swing.undo.UndoableEditSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.undo.CompoundEdit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.CompoundEdit
的使用

使用 CompoundEdit 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 CompoundEdit 的使用

javax.swing.text 中 CompoundEdit 的子类
 class AbstractDocument.DefaultDocumentEvent
存储修改文档时发生的文档更改。

javax.swing.undo 中 CompoundEdit 的使用

javax.swing.undo 中 CompoundEdit 的子类
 class UndoManager
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

声明为 CompoundEdit 的 javax.swing.undo 中的字段
protected  CompoundEdit UndoableEditSupport.compoundEdit

返回 CompoundEdit 的 javax.swing.undo 中的方法
protected  CompoundEdit UndoableEditSupport.createCompoundEdit()
仅从 beginUpdate 调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.undo.AbstractUndoableEdit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.undo.AbstractUndoableEdit
的使用

使用 AbstractUndoableEdit 的软件包
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.text 中 AbstractUndoableEdit 的使用

javax.swing.text 中 AbstractUndoableEdit 的子类
class | AbstractDocument.DefaultDocumentEvent 存储修改文档时发生的文档更改。
static class | AbstractDocument.ElementEdit 一个 ElementChange 实现，可将其添加到文档事件中。
static class | DefaultStyledDocument.AttributeUndoableEdit 用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。

javax.swing.undo 中 AbstractUndoableEdit 的使用

javax.swing.undo 中 AbstractUndoableEdit 的子类
class | CompoundEdit AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
class | StateEdit StateEdit 是更改状态的对象的通用编辑。
class | UndoManager UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.undo.UndoableEdit 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.undo.UndoableEdit
的使用

使用 UndoableEdit 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing.event 中 UndoableEdit 的使用

返回 UndoableEdit 的 javax.swing.event 中的方法
 UndoableEdit UndoableEditEvent.getEdit()
返回 edit 值。

参数类型为 UndoableEdit 的 javax.swing.event 中的构造方法
UndoableEditEvent(Object source, UndoableEdit edit)
构造一个 UndoableEditEvent 对象。

javax.swing.text 中 UndoableEdit 的使用

实现 UndoableEdit 的 javax.swing.text 中的类
class | AbstractDocument.DefaultDocumentEvent 存储修改文档时发生的文档更改。
static class | AbstractDocument.ElementEdit 一个 ElementChange 实现，可将其添加到文档事件中。
static class | DefaultStyledDocument.AttributeUndoableEdit 用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。

返回 UndoableEdit 的 javax.swing.text 中的方法
 UndoableEdit StringContent.insertString(int where, String str)
将字符串插入到内容中。
 UndoableEdit GapContent.insertString(int where, String str)
在内容中插入字符串。
 UndoableEdit AbstractDocument.Content.insertString(int where, String str)
向序列中插入一个字符串。
 UndoableEdit StringContent.remove(int where, int nitems)
移除部分内容，其中 where ＋ nitems 必须 < length()。
 UndoableEdit GapContent.remove(int where, int nitems)
移除部分内容。
 UndoableEdit AbstractDocument.Content.remove(int where, int nitems)
移除该序列的某一部分。

参数类型为 UndoableEdit 的 javax.swing.text 中的方法
 boolean AbstractDocument.DefaultDocumentEvent.addEdit(UndoableEdit anEdit)
添加文档编辑。

javax.swing.undo 中 UndoableEdit 的使用

实现 UndoableEdit 的 javax.swing.undo 中的类
class | AbstractUndoableEdit UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
class | CompoundEdit AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
class | StateEdit StateEdit 是更改状态的对象的通用编辑。
class | UndoManager UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

类型参数类型为 UndoableEdit 的 javax.swing.undo 中的字段
protected  Vector<UndoableEdit> CompoundEdit.edits
由此 CompoundEdit 全部撤消/恢复的 UndoableEdit 的集合。

返回 UndoableEdit 的 javax.swing.undo 中的方法
protected UndoableEdit | UndoManager.editToBeRedone() 如果调用 redo，则返回下一个要恢复的有效编辑。
protected UndoableEdit | UndoManager.editToBeUndone() 如果调用 undo，则返回下一个要撤消的有效编辑。
protected UndoableEdit | CompoundEdit.lastEdit() 返回 edits 中最后一个 UndoableEdit，如果 edits 为空，则返回 null。

参数类型为 UndoableEdit 的 javax.swing.undo 中的方法
protected void | UndoableEditSupport._postEdit(UndoableEdit e) 仅从 postEdit 和 endUpdate 调用。
boolean | UndoManager.addEdit(UndoableEdit anEdit) 如果可能，将一个 UndoableEdit 添加到此 UndoManager。
boolean | CompoundEdit.addEdit(UndoableEdit anEdit) 如果此编辑为 inProgress，则接受 anEdit 并返回 true。
boolean | AbstractUndoableEdit.addEdit(UndoableEdit anEdit) 此默认实现返回 false。
boolean | UndoableEdit.addEdit(UndoableEdit anEdit) 将 UndoableEdit 添加到此 UndoableEdit。
void | UndoableEditSupport.postEdit(UndoableEdit e) 死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。
protected void | UndoManager.redoTo(UndoableEdit edit) 恢复从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
boolean | AbstractUndoableEdit.replaceEdit(UndoableEdit anEdit) 此默认实现返回 false。
boolean | UndoableEdit.replaceEdit(UndoableEdit anEdit) 如果此 UndoableEdit 应替换 anEdit，则返回 true。
protected void | UndoManager.undoTo(UndoableEdit edit) 撤消从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


ActionMapUIResource (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ActionMapUIResource

java.lang.Object
    继承者  javax.swing.ActionMap
        继承者  javax.swing.plaf.ActionMapUIResource
所有已实现的接口：
Serializable, UIResource
public class ActionMapUIResource
extends ActionMap
implements UIResource

实现 UIResource 的 javax.swing.ActionMap 的子类。提供 ActionMap 的 UI 类应该使用此类。

从以下版本开始：
1.3

构造方法摘要
ActionMapUIResource()
方法摘要
从类 javax.swing.ActionMap 继承的方法
allKeys, clear, get, getParent, keys, put, remove, setParent, size
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActionMapUIResource

public ActionMapUIResource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BorderUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 BorderUIResource

java.lang.Object
    继承者  javax.swing.plaf.BorderUIResource
所有已实现的接口：
Serializable, Border, UIResource
public class BorderUIResource
extends Object
implements Border, UIResource, Serializable

嵌套类摘要
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource
构造方法摘要
BorderUIResource(Border delegate)
创建一个 UIResource 边框对象，该对象包装了一个现有 Border 实例。
方法摘要
static Border | getBlackLineBorderUIResource()
Insets | getBorderInsets(Component c) 返回该边框的 insets。
static Border | getEtchedBorderUIResource()
static Border | getLoweredBevelBorderUIResource()
static Border | getRaisedBevelBorderUIResource()
boolean | isBorderOpaque() 返回此边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BorderUIResource

public BorderUIResource(Border delegate)
创建一个 UIResource 边框对象，该对象包装了一个现有 Border 实例。

参数：
delegate - 将被包装的边框
方法详细信息

getEtchedBorderUIResource

public static Border getEtchedBorderUIResource()

getLoweredBevelBorderUIResource

public static Border getLoweredBevelBorderUIResource()

getRaisedBevelBorderUIResource

public static Border getRaisedBevelBorderUIResource()

getBlackLineBorderUIResource

public static Border getBlackLineBorderUIResource()

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
从接口 Border 复制的描述
按指定的位置和尺寸绘制指定组件的边框。

指定者：
接口 Border 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从接口 Border 复制的描述
返回该边框的 insets。

指定者：
接口 Border 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件

isBorderOpaque

public boolean isBorderOpaque()
从接口 Border 复制的描述
返回此边框是否透明。如果边框为不透明，则在绘制它时将用自身的背景来填充。

指定者：
接口 Border 中的 isBorderOpaque
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderUIResource.BevelBorderUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 BorderUIResource.BevelBorderUIResource

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.BevelBorder
            继承者  javax.swing.plaf.BorderUIResource.BevelBorderUIResource
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BorderUIResource
public static class BorderUIResource.BevelBorderUIResource
extends BevelBorder
implements UIResource

字段摘要
从类 javax.swing.border.BevelBorder 继承的字段
bevelType, highlightInner, highlightOuter, LOWERED, RAISED, shadowInner, shadowOuter
构造方法摘要
BorderUIResource.BevelBorderUIResource(int bevelType)
BorderUIResource.BevelBorderUIResource(int bevelType, Color highlight, Color shadow)
BorderUIResource.BevelBorderUIResource(int bevelType, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
方法摘要
从类 javax.swing.border.BevelBorder 继承的方法
getBevelType, getBorderInsets, getBorderInsets, getHighlightInnerColor, getHighlightInnerColor, getHighlightOuterColor, getHighlightOuterColor, getShadowInnerColor, getShadowInnerColor, getShadowOuterColor, getShadowOuterColor, isBorderOpaque, paintBorder, paintLoweredBevel, paintRaisedBevel
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BorderUIResource.BevelBorderUIResource

public BorderUIResource.BevelBorderUIResource(int bevelType)

BorderUIResource.BevelBorderUIResource

public BorderUIResource.BevelBorderUIResource(int bevelType,
                                              Color highlight,
                                              Color shadow)

BorderUIResource.BevelBorderUIResource

public BorderUIResource.BevelBorderUIResource(int bevelType,
                                              Color highlightOuter,
                                              Color highlightInner,
                                              Color shadowOuter,
                                              Color shadowInner)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderUIResource.CompoundBorderUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 BorderUIResource.CompoundBorderUIResource

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.CompoundBorder
            继承者  javax.swing.plaf.BorderUIResource.CompoundBorderUIResource
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BorderUIResource
public static class BorderUIResource.CompoundBorderUIResource
extends CompoundBorder
implements UIResource

字段摘要
从类 javax.swing.border.CompoundBorder 继承的字段
insideBorder, outsideBorder
构造方法摘要
BorderUIResource.CompoundBorderUIResource(Border outsideBorder, Border insideBorder)
方法摘要
从类 javax.swing.border.CompoundBorder 继承的方法
getBorderInsets, getBorderInsets, getInsideBorder, getOutsideBorder, isBorderOpaque, paintBorder
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BorderUIResource.CompoundBorderUIResource

public BorderUIResource.CompoundBorderUIResource(Border outsideBorder,
                                                 Border insideBorder)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderUIResource.EmptyBorderUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 BorderUIResource.EmptyBorderUIResource

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.EmptyBorder
            继承者  javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BorderUIResource
public static class BorderUIResource.EmptyBorderUIResource
extends EmptyBorder
implements UIResource

字段摘要
从类 javax.swing.border.EmptyBorder 继承的字段
bottom, left, right, top
构造方法摘要
BorderUIResource.EmptyBorderUIResource(Insets insets)
BorderUIResource.EmptyBorderUIResource(int top, int left, int bottom, int right)
方法摘要
从类 javax.swing.border.EmptyBorder 继承的方法
getBorderInsets, getBorderInsets, getBorderInsets, isBorderOpaque, paintBorder
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BorderUIResource.EmptyBorderUIResource

public BorderUIResource.EmptyBorderUIResource(int top,
                                              int left,
                                              int bottom,
                                              int right)

BorderUIResource.EmptyBorderUIResource

public BorderUIResource.EmptyBorderUIResource(Insets insets)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderUIResource.EtchedBorderUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 BorderUIResource.EtchedBorderUIResource

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.EtchedBorder
            继承者  javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BorderUIResource
public static class BorderUIResource.EtchedBorderUIResource
extends EtchedBorder
implements UIResource

字段摘要
从类 javax.swing.border.EtchedBorder 继承的字段
etchType, highlight, LOWERED, RAISED, shadow
构造方法摘要
BorderUIResource.EtchedBorderUIResource()
BorderUIResource.EtchedBorderUIResource(Color highlight, Color shadow)
BorderUIResource.EtchedBorderUIResource(int etchType)
BorderUIResource.EtchedBorderUIResource(int etchType, Color highlight, Color shadow)
方法摘要
从类 javax.swing.border.EtchedBorder 继承的方法
getBorderInsets, getBorderInsets, getEtchType, getHighlightColor, getHighlightColor, getShadowColor, getShadowColor, isBorderOpaque, paintBorder
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BorderUIResource.EtchedBorderUIResource

public BorderUIResource.EtchedBorderUIResource()

BorderUIResource.EtchedBorderUIResource

public BorderUIResource.EtchedBorderUIResource(int etchType)

BorderUIResource.EtchedBorderUIResource

public BorderUIResource.EtchedBorderUIResource(Color highlight,
                                               Color shadow)

BorderUIResource.EtchedBorderUIResource

public BorderUIResource.EtchedBorderUIResource(int etchType,
                                               Color highlight,
                                               Color shadow)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderUIResource.LineBorderUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 BorderUIResource.LineBorderUIResource

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.LineBorder
            继承者  javax.swing.plaf.BorderUIResource.LineBorderUIResource
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BorderUIResource
public static class BorderUIResource.LineBorderUIResource
extends LineBorder
implements UIResource

字段摘要
从类 javax.swing.border.LineBorder 继承的字段
lineColor, roundedCorners, thickness
构造方法摘要
BorderUIResource.LineBorderUIResource(Color color)
BorderUIResource.LineBorderUIResource(Color color, int thickness)
方法摘要
从类 javax.swing.border.LineBorder 继承的方法
createBlackLineBorder, createGrayLineBorder, getBorderInsets, getBorderInsets, getLineColor, getRoundedCorners, getThickness, isBorderOpaque, paintBorder
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BorderUIResource.LineBorderUIResource

public BorderUIResource.LineBorderUIResource(Color color)

BorderUIResource.LineBorderUIResource

public BorderUIResource.LineBorderUIResource(Color color,
                                             int thickness)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderUIResource.MatteBorderUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 BorderUIResource.MatteBorderUIResource

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.EmptyBorder
            继承者  javax.swing.border.MatteBorder
                继承者  javax.swing.plaf.BorderUIResource.MatteBorderUIResource
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BorderUIResource
public static class BorderUIResource.MatteBorderUIResource
extends MatteBorder
implements UIResource

字段摘要
从类 javax.swing.border.MatteBorder 继承的字段
color, tileIcon
从类 javax.swing.border.EmptyBorder 继承的字段
bottom, left, right, top
构造方法摘要
BorderUIResource.MatteBorderUIResource(Icon tileIcon)
BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Color color)
BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Icon tileIcon)
方法摘要
从类 javax.swing.border.MatteBorder 继承的方法
getBorderInsets, getBorderInsets, getBorderInsets, getMatteColor, getTileIcon, isBorderOpaque, paintBorder
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BorderUIResource.MatteBorderUIResource

public BorderUIResource.MatteBorderUIResource(int top,
                                              int left,
                                              int bottom,
                                              int right,
                                              Color color)

BorderUIResource.MatteBorderUIResource

public BorderUIResource.MatteBorderUIResource(int top,
                                              int left,
                                              int bottom,
                                              int right,
                                              Icon tileIcon)

BorderUIResource.MatteBorderUIResource

public BorderUIResource.MatteBorderUIResource(Icon tileIcon)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderUIResource.TitledBorderUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 BorderUIResource.TitledBorderUIResource

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.TitledBorder
            继承者  javax.swing.plaf.BorderUIResource.TitledBorderUIResource
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BorderUIResource
public static class BorderUIResource.TitledBorderUIResource
extends TitledBorder
implements UIResource

字段摘要
从类 javax.swing.border.TitledBorder 继承的字段
ABOVE_BOTTOM, ABOVE_TOP, BELOW_BOTTOM, BELOW_TOP, border, BOTTOM, CENTER, DEFAULT_JUSTIFICATION, DEFAULT_POSITION, EDGE_SPACING, LEADING, LEFT, RIGHT, TEXT_INSET_H, TEXT_SPACING, title, titleColor, titleFont, titleJustification, titlePosition, TOP, TRAILING
构造方法摘要
BorderUIResource.TitledBorderUIResource(Border border)
BorderUIResource.TitledBorderUIResource(Border border, String title)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
BorderUIResource.TitledBorderUIResource(String title)
方法摘要
从类 javax.swing.border.TitledBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getBorder, getBorderInsets, getBorderInsets, getFont, getMinimumSize, getTitle, getTitleColor, getTitleFont, getTitleJustification, getTitlePosition, isBorderOpaque, paintBorder, setBorder, setTitle, setTitleColor, setTitleFont, setTitleJustification, setTitlePosition
从类 javax.swing.border.AbstractBorder 继承的方法
getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BorderUIResource.TitledBorderUIResource

public BorderUIResource.TitledBorderUIResource(String title)

BorderUIResource.TitledBorderUIResource

public BorderUIResource.TitledBorderUIResource(Border border)

BorderUIResource.TitledBorderUIResource

public BorderUIResource.TitledBorderUIResource(Border border,
                                               String title)

BorderUIResource.TitledBorderUIResource

public BorderUIResource.TitledBorderUIResource(Border border,
                                               String title,
                                               int titleJustification,
                                               int titlePosition)

BorderUIResource.TitledBorderUIResource

public BorderUIResource.TitledBorderUIResource(Border border,
                                               String title,
                                               int titleJustification,
                                               int titlePosition,
                                               Font titleFont)

BorderUIResource.TitledBorderUIResource

public BorderUIResource.TitledBorderUIResource(Border border,
                                               String title,
                                               int titleJustification,
                                               int titlePosition,
                                               Font titleFont,
                                               Color titleColor)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ButtonUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ButtonUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
直接已知子类：
BasicButtonUI, MenuItemUI, MultiButtonUI
public abstract class ButtonUI
extends ComponentUI

JButton 的可插入外观界面。

构造方法摘要
ButtonUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ButtonUI

public ButtonUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ListUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ListUI
直接已知子类：
BasicListUI, MultiListUI
public abstract class ListUI
extends ComponentUI

JList 的可插入外观代理。

构造方法摘要
ListUI()
方法摘要
abstract Rectangle | getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
abstract Point | indexToLocation(JList list, int index) 返回列表坐标系统中给定 JList 中指定项的原点。
abstract int | locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ListUI

public ListUI()
方法详细信息

locationToIndex

public abstract int locationToIndex(JList list,
                                    Point location)
返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。要确定该单元是否真正包含指定位置，可比较该点与单元的边界，单元的边界通过 getCellBounds 提供。如果列表的模式为空，则此方法返回 -1。

参数：
list - 列表
location - 点的坐标
返回：
与给定位置最接近的单元索引或 -1
抛出：
NullPointerException - 如果 location 为 null

indexToLocation

public abstract Point indexToLocation(JList list,
                                      int index)
返回列表坐标系统中给定 JList 中指定项的原点。如果索引无效，则返回 null 。

参数：
list - 列表
index - 单元索引
返回：
单元的原点或 null

getCellBounds

public abstract Rectangle getCellBounds(JList list,
                                        int index1,
                                        int index2)
返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。可以按任意顺序提供索引。

如果较小索引超出单元的列表范围，则此方法返回 null。如果较小索引有效，但较大索引超出列表范围，则只返回第一个索引的边界。否则，返回有效范围的边界。

参数：
list - 列表
index1 - 范围内第一个索引
index2 - 范围内第二个索引
返回：
单元范围的有界矩形或 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ColorChooserUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ColorChooserUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ColorChooserUI
直接已知子类：
BasicColorChooserUI, MultiColorChooserUI
public abstract class ColorChooserUI
extends ComponentUI

JColorChooser 的可插入外观界面。

构造方法摘要
ColorChooserUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ColorChooserUI

public ColorChooserUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ColorUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ColorUIResource

java.lang.Object
    继承者  java.awt.Color
        继承者  javax.swing.plaf.ColorUIResource
所有已实现的接口：
Paint, Transparency, Serializable, UIResource
public class ColorUIResource
extends Color
implements UIResource

字段摘要
从类 java.awt.Color 继承的字段
black, BLACK, blue, BLUE, cyan, CYAN, DARK_GRAY, darkGray, gray, GRAY, green, GREEN, LIGHT_GRAY, lightGray, magenta, MAGENTA, orange, ORANGE, pink, PINK, red, RED, white, WHITE, yellow, YELLOW
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
ColorUIResource(Color c)
ColorUIResource(float r, float g, float b)
ColorUIResource(int rgb)
ColorUIResource(int r, int g, int b)
方法摘要
从类 java.awt.Color 继承的方法
brighter, createContext, darker, decode, equals, getAlpha, getBlue, getColor, getColor, getColor, getColorComponents, getColorComponents, getColorSpace, getComponents, getComponents, getGreen, getHSBColor, getRed, getRGB, getRGBColorComponents, getRGBComponents, getTransparency, hashCode, HSBtoRGB, RGBtoHSB, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ColorUIResource

public ColorUIResource(int r,
                       int g,
                       int b)

ColorUIResource

public ColorUIResource(int rgb)

ColorUIResource

public ColorUIResource(float r,
                       float g,
                       float b)

ColorUIResource

public ColorUIResource(Color c)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComboBoxUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ComboBoxUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ComboBoxUI
直接已知子类：
BasicComboBoxUI, MultiComboBoxUI
public abstract class ComboBoxUI
extends ComponentUI

JComboBox 的可插入外观界面。

构造方法摘要
ComboBoxUI()
方法摘要
abstract boolean | isFocusTraversable(JComboBox c) 确定组合框本身是否是可遍历的
abstract boolean | isPopupVisible(JComboBox c) 确定弹出窗口的可见性
abstract void | setPopupVisible(JComboBox c, boolean v) 设置弹出菜单的可见性
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComboBoxUI

public ComboBoxUI()
方法详细信息

setPopupVisible

public abstract void setPopupVisible(JComboBox c,
                                     boolean v)
设置弹出菜单的可见性

isPopupVisible

public abstract boolean isPopupVisible(JComboBox c)
确定弹出窗口的可见性

isFocusTraversable

public abstract boolean isFocusTraversable(JComboBox c)
确定组合框本身是否是可遍历的

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentInputMapUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ComponentInputMapUIResource

java.lang.Object
    继承者  javax.swing.InputMap
        继承者  javax.swing.ComponentInputMap
            继承者  javax.swing.plaf.ComponentInputMapUIResource
所有已实现的接口：
Serializable, UIResource
public class ComponentInputMapUIResource
extends ComponentInputMap
implements UIResource

实现 UIResource 的 javax.swing.ComponentInputMap 的子类。提供 ComponentInputMap 的 UI 类应该使用此类。

从以下版本开始：
1.3

构造方法摘要
ComponentInputMapUIResource(JComponent component)
方法摘要
从类 javax.swing.ComponentInputMap 继承的方法
clear, getComponent, put, remove, setParent
从类 javax.swing.InputMap 继承的方法
allKeys, get, getParent, keys, size
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComponentInputMapUIResource

public ComponentInputMapUIResource(JComponent component)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ComponentUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
直接已知子类：
ButtonUI, ColorChooserUI, ComboBoxUI, DesktopIconUI, DesktopPaneUI, FileChooserUI, InternalFrameUI, LabelUI, ListUI, MenuBarUI, OptionPaneUI, PanelUI, PopupMenuUI, ProgressBarUI, RootPaneUI, ScrollBarUI, ScrollPaneUI, SeparatorUI, SliderUI, SpinnerUI, SplitPaneUI, TabbedPaneUI, TableHeaderUI, TableUI, TextUI, ToolBarUI, ToolTipUI, TreeUI, ViewportUI
public abstract class ComponentUI
extends Object

用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。Swing 组件的 UI 委托对象负责实现依赖于外观的那些组件的某些方面。为了委托那些可能随所安装的外观而改变的操作（绘制、布局计算等等），JComponent 类要调用来自此类的方法。客户端程序不应在此类上直接调用这些方法。

另请参见：
JComponent, UIManager

构造方法摘要
ComponentUI()
单独的构造方法。
方法摘要
boolean | contains(JComponent c, int x, int y) 如果指定 x,y 位置包含在指定组件外观的已定义形状中，则返回 true。
static ComponentUI | createUI(JComponent c) 返回指定组件的一个 UI 委托实例。
Accessible | getAccessibleChild(JComponent c, int i) 返回对象的第 i 个 Accessible 子对象。
int | getAccessibleChildrenCount(JComponent c) 返回对象中的可访问子对象数。
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
void | update(Graphics g, JComponent c) 通知此 UI 委托开始绘制指定的组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComponentUI

public ComponentUI()
单独的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

installUI

public void installUI(JComponent c)
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

参数：
c - 将安装此 UI 委托的组件
另请参见：
uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics g,
                  JComponent c)
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
update(java.awt.Graphics, javax.swing.JComponent)

update

public void update(Graphics g,
                   JComponent c)
通知此 UI 委托开始绘制指定的组件。在将要绘制指定组件时，由 JComponent 调用此方法。默认情况下，此方法将使用其背景色填充指定组件（如果其 opaque 属性为 true），然后立刻调用 paint。通常无需由子类重写此方法；所有呈现代码的外观都应位于 paint 方法中。

参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

contains

public boolean contains(JComponent c,
                        int x,
                        int y)
如果指定 x,y 位置包含在指定组件外观的已定义形状中，则返回 true。x 和 y 都是相对于指定组件的坐标系统定义的。尽管组件的 bounds 被限制为一个矩形，但为了进行命中检测，此方法提供了在这些边界内定义非矩形形状的办法。

参数：
c - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
x - 点的 x 坐标
y - 点的 y 坐标
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

createUI

public static ComponentUI createUI(JComponent c)
返回指定组件的一个 UI 委托实例。每个子类都必须提供自己的静态 createUI 方法，该方法返回 UI 委托子类的一个实例。如果 UI 委托子类是无状态的，则该方法可以返回一个由多个组件共享的实例。如果 UI 委托是有状态的，则该方法应该为每个组件返回一个新实例。此方法的默认实现抛出一个错误，因为它永远都不应该被调用。

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。从组件的顶部测量基线。此方法主要供 LayoutManager 用来沿其基线对齐组件。小于 0 的返回值指示此组件不具有合理的基线以及 LayoutManager 不应在其基线上对齐此组件。

此方法返回 -1。具有有意义的基线的子类应该适当地进行重写。

参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int,int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，指示组件的基线如何随大小的改变而发生更改。此方法主要供布局管理器和 GUI 生成器使用。

此方法返回 BaselineResizeBehavior.OTHER。支持基线的子类应该适当地进行重写。

参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent c)
返回对象中的可访问子对象数。如果此对象的所有子对象都实现 Accessible，那么此方法应返回此对象的子对象数。如果 UI 在可看作组件的屏幕上呈现一些区域，那么它们可能希望重写此方法，但实际组件并不用于呈现那些区域。 注：从 v1.3 开始，建议开发人员调用 Component.AccessibleAWTComponent.getAccessibleChildrenCount() 替代此方法。

返回：
该对象中可访问的子对象数
另请参见：
getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent c,
                                     int i)
返回对象的第 i 个 Accessible 子对象。如果 UI 在可看作组件的屏幕上呈现一些区域，那么它们可能需要重写此方法，但实际组件并不用于呈现那些区域。

注：从 v1.3 开始，建议开发人员调用 Component.AccessibleAWTComponent.getAccessibleChild() 替代此方法。

参数：
i - 子对象的从零开始的索引
返回：
对象的第 i 个 Accessible 子对象
另请参见：
getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DesktopIconUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 DesktopIconUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.DesktopIconUI
直接已知子类：
BasicDesktopIconUI, MultiDesktopIconUI
public abstract class DesktopIconUI
extends ComponentUI

JDesktopIcon 的可插入外观界面。

构造方法摘要
DesktopIconUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DesktopIconUI

public DesktopIconUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DesktopPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 DesktopPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.DesktopPaneUI
直接已知子类：
BasicDesktopPaneUI, MultiDesktopPaneUI
public abstract class DesktopPaneUI
extends ComponentUI

JDesktopPane 的可插入外观界面。

构造方法摘要
DesktopPaneUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DesktopPaneUI

public DesktopPaneUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DimensionUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 DimensionUIResource

java.lang.Object
    继承者  java.awt.geom.Dimension2D
        继承者  java.awt.Dimension
            继承者  javax.swing.plaf.DimensionUIResource
所有已实现的接口：
Serializable, Cloneable, UIResource
public class DimensionUIResource
extends Dimension
implements UIResource

字段摘要
从类 java.awt.Dimension 继承的字段
height, width
构造方法摘要
DimensionUIResource(int width, int height)
方法摘要
从类 java.awt.Dimension 继承的方法
equals, getHeight, getSize, getWidth, hashCode, setSize, setSize, setSize, toString
从类 java.awt.geom.Dimension2D 继承的方法
clone, setSize
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DimensionUIResource

public DimensionUIResource(int width,
                           int height)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileChooserUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 FileChooserUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.FileChooserUI
直接已知子类：
BasicFileChooserUI, MultiFileChooserUI
public abstract class FileChooserUI
extends ComponentUI

JFileChooser 的可插入外观界面。

构造方法摘要
FileChooserUI()
方法摘要
abstract void | ensureFileIsVisible(JFileChooser fc, File f)
abstract FileFilter | getAcceptAllFileFilter(JFileChooser fc)
abstract String | getApproveButtonText(JFileChooser fc)
abstract String | getDialogTitle(JFileChooser fc)
abstract FileView | getFileView(JFileChooser fc)
abstract void | rescanCurrentDirectory(JFileChooser fc)
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileChooserUI

public FileChooserUI()
方法详细信息

getAcceptAllFileFilter

public abstract FileFilter getAcceptAllFileFilter(JFileChooser fc)

getFileView

public abstract FileView getFileView(JFileChooser fc)

getApproveButtonText

public abstract String getApproveButtonText(JFileChooser fc)

getDialogTitle

public abstract String getDialogTitle(JFileChooser fc)

rescanCurrentDirectory

public abstract void rescanCurrentDirectory(JFileChooser fc)

ensureFileIsVisible

public abstract void ensureFileIsVisible(JFileChooser fc,
                                         File f)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FontUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 FontUIResource

java.lang.Object
    继承者  java.awt.Font
        继承者  javax.swing.plaf.FontUIResource
所有已实现的接口：
Serializable, UIResource
public class FontUIResource
extends Font
implements UIResource

实现 UIResource 的 java.awt.Font 的子类。设置默认字体属性的 UI 类应该使用此类。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
UIResource

字段摘要
从类 java.awt.Font 继承的字段
BOLD, CENTER_BASELINE, DIALOG, DIALOG_INPUT, HANGING_BASELINE, ITALIC, LAYOUT_LEFT_TO_RIGHT, LAYOUT_NO_LIMIT_CONTEXT, LAYOUT_NO_START_CONTEXT, LAYOUT_RIGHT_TO_LEFT, MONOSPACED, name, PLAIN, pointSize, ROMAN_BASELINE, SANS_SERIF, SERIF, size, style, TRUETYPE_FONT, TYPE1_FONT
构造方法摘要
FontUIResource(Font font)
FontUIResource(String name, int style, int size)
方法摘要
从类 java.awt.Font 继承的方法
canDisplay, canDisplay, canDisplayUpTo, canDisplayUpTo, canDisplayUpTo, createFont, createFont, createGlyphVector, createGlyphVector, createGlyphVector, createGlyphVector, decode, deriveFont, deriveFont, deriveFont, deriveFont, deriveFont, deriveFont, equals, finalize, getAttributes, getAvailableAttributes, getBaselineFor, getFamily, getFamily, getFont, getFont, getFont, getFontName, getFontName, getItalicAngle, getLineMetrics, getLineMetrics, getLineMetrics, getLineMetrics, getMaxCharBounds, getMissingGlyphCode, getName, getNumGlyphs, getPeer, getPSName, getSize, getSize2D, getStringBounds, getStringBounds, getStringBounds, getStringBounds, getStyle, getTransform, hashCode, hasLayoutAttributes, hasUniformLineMetrics, isBold, isItalic, isPlain, isTransformed, layoutGlyphVector, toString
从类 java.lang.Object 继承的方法
clone, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

FontUIResource

public FontUIResource(String name,
                      int style,
                      int size)

FontUIResource

public FontUIResource(Font font)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IconUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 IconUIResource

java.lang.Object
    继承者  javax.swing.plaf.IconUIResource
所有已实现的接口：
Serializable, Icon, UIResource
public class IconUIResource
extends Object
implements Icon, UIResource, Serializable

实现 UIResource 的 Icon 包装类。设置图标属性的 UI 类应该使用此类包装所有指定为默认值的图标。 此类将所有方法调用委托给构造时指定的 Icon“委托”对象。

警告： 此类已序列化的对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 开始，对所有 JavaBeansTM 长期存储的支持已被添加到 java.beans 包。请参阅 XMLEncoder。

另请参见：
UIResource

构造方法摘要
IconUIResource(Icon delegate)
创建一个 UIResource 图标对象，该对象包装了一个现有 Icon 实例。
方法摘要
int | getIconHeight() 返回图标的高度。
int | getIconWidth() 返回图标的宽度。
void | paintIcon(Component c, Graphics g, int x, int y) 在指定位置上绘制图标。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IconUIResource

public IconUIResource(Icon delegate)
创建一个 UIResource 图标对象，该对象包装了一个现有 Icon 实例。

参数：
delegate - 将被包装的图标
方法详细信息

paintIcon

public void paintIcon(Component c,
                      Graphics g,
                      int x,
                      int y)
从接口 Icon 复制的描述
在指定位置上绘制图标。图标实现可以使用 Component 参数来获得对绘制有用的属性，例如前景色和背景色。

指定者：
接口 Icon 中的 paintIcon

getIconWidth

public int getIconWidth()
从接口 Icon 复制的描述
返回图标的宽度。

指定者：
接口 Icon 中的 getIconWidth
返回：
一个指定图标的固定宽度的 int 值。

getIconHeight

public int getIconHeight()
从接口 Icon 复制的描述
返回图标的高度。

指定者：
接口 Icon 中的 getIconHeight
返回：
一个指定图标的固定高度的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputMapUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 InputMapUIResource

java.lang.Object
    继承者  javax.swing.InputMap
        继承者  javax.swing.plaf.InputMapUIResource
所有已实现的接口：
Serializable, UIResource
public class InputMapUIResource
extends InputMap
implements UIResource

实现 UIResource 的 javax.swing.InputMap 的子类。提供 InputMap 的 UI 类应该使用此类。

从以下版本开始：
1.3

构造方法摘要
InputMapUIResource()
方法摘要
从类 javax.swing.InputMap 继承的方法
allKeys, clear, get, getParent, keys, put, remove, setParent, size
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputMapUIResource

public InputMapUIResource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InsetsUIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 InsetsUIResource

java.lang.Object
    继承者  java.awt.Insets
        继承者  javax.swing.plaf.InsetsUIResource
所有已实现的接口：
Serializable, Cloneable, UIResource
public class InsetsUIResource
extends Insets
implements UIResource

字段摘要
从类 java.awt.Insets 继承的字段
bottom, left, right, top
构造方法摘要
InsetsUIResource(int top, int left, int bottom, int right)
方法摘要
从类 java.awt.Insets 继承的方法
clone, equals, hashCode, set, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

InsetsUIResource

public InsetsUIResource(int top,
                        int left,
                        int bottom,
                        int right)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InternalFrameUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 InternalFrameUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.InternalFrameUI
直接已知子类：
BasicInternalFrameUI, MultiInternalFrameUI
public abstract class InternalFrameUI
extends ComponentUI

JInternalFrame 的可插入外观界面。

构造方法摘要
InternalFrameUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InternalFrameUI

public InternalFrameUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LabelUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 LabelUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.LabelUI
直接已知子类：
BasicLabelUI, MultiLabelUI
public abstract class LabelUI
extends ComponentUI

JLabel 的可插入外观界面。

构造方法摘要
LabelUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LabelUI

public LabelUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 MenuBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.MenuBarUI
直接已知子类：
BasicMenuBarUI, MultiMenuBarUI
public abstract class MenuBarUI
extends ComponentUI

JMenuBar 的可插入外观界面。

构造方法摘要
MenuBarUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MenuBarUI

public MenuBarUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuItemUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 MenuItemUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.MenuItemUI
直接已知子类：
BasicMenuItemUI, MultiMenuItemUI
public abstract class MenuItemUI
extends ButtonUI

JMenuItem 的可插入外观界面。

构造方法摘要
MenuItemUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MenuItemUI

public MenuItemUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OptionPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 OptionPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.OptionPaneUI
直接已知子类：
BasicOptionPaneUI, MultiOptionPaneUI
public abstract class OptionPaneUI
extends ComponentUI

JOptionPane 的可插入外观界面。

构造方法摘要
OptionPaneUI()
方法摘要
abstract boolean | containsCustomComponents(JOptionPane op) 如果用户已经为选项或消息提供 Component 实例，则返回 true。
abstract void | selectInitialValue(JOptionPane op) 请求表示默认值的组件拥有焦点。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OptionPaneUI

public OptionPaneUI()
方法详细信息

selectInitialValue

public abstract void selectInitialValue(JOptionPane op)
请求表示默认值的组件拥有焦点。

containsCustomComponents

public abstract boolean containsCustomComponents(JOptionPane op)
如果用户已经为选项或消息提供 Component 实例，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PanelUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 PanelUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.PanelUI
直接已知子类：
BasicPanelUI, MultiPanelUI
public abstract class PanelUI
extends ComponentUI

Panel 的可插入外观界面。

构造方法摘要
PanelUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PanelUI

public PanelUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PopupMenuUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 PopupMenuUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.PopupMenuUI
直接已知子类：
BasicPopupMenuUI, MultiPopupMenuUI
public abstract class PopupMenuUI
extends ComponentUI

JPopupMenu 的可插入外观界面。

构造方法摘要
PopupMenuUI()
方法摘要
Popup | getPopup(JPopupMenu popup, int x, int y) 返回将负责显示 JPopupMenu 的 Popup。
boolean | isPopupTrigger(MouseEvent e)
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PopupMenuUI

public PopupMenuUI()
方法详细信息

isPopupTrigger

public boolean isPopupTrigger(MouseEvent e)
从以下版本开始：
1.3

getPopup

public Popup getPopup(JPopupMenu popup,
                      int x,
                      int y)
返回将负责显示 JPopupMenu 的 Popup。

参数：
popup - 请求 Popup 的 JPopupMenu
x - 屏幕上将显示 Popup 的 x 位置
y - 屏幕上将显示 Popup 的 y 位置。
返回：
将显示 JPopupMenu 的 Popup
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProgressBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ProgressBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ProgressBarUI
直接已知子类：
BasicProgressBarUI, MultiProgressBarUI
public abstract class ProgressBarUI
extends ComponentUI

JProgressBar 的可插入外观界面。

构造方法摘要
ProgressBarUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ProgressBarUI

public ProgressBarUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RootPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 RootPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.RootPaneUI
直接已知子类：
BasicRootPaneUI, MultiRootPaneUI
public abstract class RootPaneUI
extends ComponentUI

JRootPane 的可插入外观界面。

从以下版本开始：
1.3

构造方法摘要
RootPaneUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RootPaneUI

public RootPaneUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScrollBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ScrollBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ScrollBarUI
直接已知子类：
BasicScrollBarUI, MultiScrollBarUI
public abstract class ScrollBarUI
extends ComponentUI

JScrollBar 的可插入外观界面。

构造方法摘要
ScrollBarUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScrollBarUI

public ScrollBarUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScrollPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ScrollPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ScrollPaneUI
直接已知子类：
BasicScrollPaneUI, MultiScrollPaneUI
public abstract class ScrollPaneUI
extends ComponentUI

JScrollPane 的可插入外观界面。

构造方法摘要
ScrollPaneUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScrollPaneUI

public ScrollPaneUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SeparatorUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 SeparatorUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SeparatorUI
直接已知子类：
BasicSeparatorUI, MultiSeparatorUI
public abstract class SeparatorUI
extends ComponentUI

JSeparator 的可插入外观界面。

构造方法摘要
SeparatorUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SeparatorUI

public SeparatorUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SliderUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 SliderUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SliderUI
直接已知子类：
BasicSliderUI, MultiSliderUI
public abstract class SliderUI
extends ComponentUI

JSlider 的可插入外观界面。

构造方法摘要
SliderUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SliderUI

public SliderUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpinnerUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 SpinnerUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SpinnerUI
直接已知子类：
BasicSpinnerUI, MultiSpinnerUI
public abstract class SpinnerUI
extends ComponentUI

JSpinner 的可插入外观界面

从以下版本开始：
1.4

构造方法摘要
SpinnerUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SpinnerUI

public SpinnerUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SplitPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 SplitPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SplitPaneUI
直接已知子类：
BasicSplitPaneUI, MultiSplitPaneUI
public abstract class SplitPaneUI
extends ComponentUI

JSplitPane 的可插入外观界面。

构造方法摘要
SplitPaneUI()
方法摘要
abstract void | finishedPaintingChildren(JSplitPane jc, Graphics g) 在 JSplitPane 接收方提供外观来绘制其子组件之后传递消息。
abstract int | getDividerLocation(JSplitPane jc) 返回分隔符的位置。
abstract int | getMaximumDividerLocation(JSplitPane jc) 返回分隔符的最大可能位置。
abstract int | getMinimumDividerLocation(JSplitPane jc) 返回分隔符的最小可能位置。
abstract void | resetToPreferredSizes(JSplitPane jc) 传递消息，以便基于子组件的首选大小重新布置 JSplitPane。
abstract void | setDividerLocation(JSplitPane jc, int location) 将分隔符的位置设置到 location。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SplitPaneUI

public SplitPaneUI()
方法详细信息

resetToPreferredSizes

public abstract void resetToPreferredSizes(JSplitPane jc)
传递消息，以便基于子组件的首选大小重新布置 JSplitPane。

setDividerLocation

public abstract void setDividerLocation(JSplitPane jc,
                                        int location)
将分隔符的位置设置到 location。

getDividerLocation

public abstract int getDividerLocation(JSplitPane jc)
返回分隔符的位置。

getMinimumDividerLocation

public abstract int getMinimumDividerLocation(JSplitPane jc)
返回分隔符的最小可能位置。

getMaximumDividerLocation

public abstract int getMaximumDividerLocation(JSplitPane jc)
返回分隔符的最大可能位置。

finishedPaintingChildren

public abstract void finishedPaintingChildren(JSplitPane jc,
                                              Graphics g)
在 JSplitPane 接收方提供外观来绘制其子组件之后传递消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TabbedPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 TabbedPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TabbedPaneUI
直接已知子类：
BasicTabbedPaneUI, MultiTabbedPaneUI
public abstract class TabbedPaneUI
extends ComponentUI

JTabbedPane 的可插入外观界面。

构造方法摘要
TabbedPaneUI()
方法摘要
abstract Rectangle | getTabBounds(JTabbedPane pane, int index)
abstract int | getTabRunCount(JTabbedPane pane)
abstract int | tabForCoordinate(JTabbedPane pane, int x, int y)
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TabbedPaneUI

public TabbedPaneUI()
方法详细信息

tabForCoordinate

public abstract int tabForCoordinate(JTabbedPane pane,
                                     int x,
                                     int y)

getTabBounds

public abstract Rectangle getTabBounds(JTabbedPane pane,
                                       int index)

getTabRunCount

public abstract int getTabRunCount(JTabbedPane pane)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableHeaderUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 TableHeaderUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TableHeaderUI
直接已知子类：
BasicTableHeaderUI, MultiTableHeaderUI
public abstract class TableHeaderUI
extends ComponentUI

JTableHeader 的可插入外观界面。

构造方法摘要
TableHeaderUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableHeaderUI

public TableHeaderUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 TableUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TableUI
直接已知子类：
BasicTableUI, MultiTableUI
public abstract class TableUI
extends ComponentUI

JTable 的可插入外观界面。

构造方法摘要
TableUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TableUI

public TableUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 TextUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
直接已知子类：
BasicTextUI, MultiTextUI
public abstract class TextUI
extends ComponentUI

文本编辑器用户界面

构造方法摘要
TextUI()
方法摘要
abstract void | damageRange(JTextComponent t, int p0, int p1) 促使重新绘制负责模型给定部分的那部分视图。
abstract void | damageRange(JTextComponent t, int p0, int p1, Position.Bias firstBias, Position.Bias secondBias) 促使重新绘制负责模型给定部分的那部分视图。
abstract EditorKit | getEditorKit(JTextComponent t) 获取为要编辑的文档类型设置策略的服务绑定。
abstract int | getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
abstract View | getRootView(JTextComponent t) 获取分配了相关文本组件（即层次结构的根）的 View，可遍历这些组件来确定在空间中表示模型的形式。
String | getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
abstract Rectangle | modelToView(JTextComponent t, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract Rectangle | modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract int | viewToModel(JTextComponent t, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
abstract int | viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射关系。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TextUI

public TextUI()
方法详细信息

modelToView

public abstract Rectangle modelToView(JTextComponent t,
                                      int pos)
                               throws BadLocationException
将模型中的给定位置转换成视图坐标系统中的某一个位置。

参数：
pos - 模型中要转换的本地位置，该位置 >= 0
返回：
矩形形式的坐标
抛出：
BadLocationException - 如果给定位置并不表示相关文档中的一个有效位置

modelToView

public abstract Rectangle modelToView(JTextComponent t,
                                      int pos,
                                      Position.Bias bias)
                               throws BadLocationException
将模型中的给定位置转换成视图坐标系统中的某一个位置。

参数：
pos - 模型中要转换的本地位置，该位置 >= 0
返回：
矩形形式的坐标
抛出：
BadLocationException - 如果给定位置并不表示相关文档中的一个有效位置

viewToModel

public abstract int viewToModel(JTextComponent t,
                                Point pt)
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。

参数：
pt - 视图中要转换的位置。此位置应该与鼠标事件在同一坐标系统中。
返回：
距文档起始位置的偏移量，该偏移量 >= 0

viewToModel

public abstract int viewToModel(JTextComponent t,
                                Point pt,
                                Position.Bias[] biasReturn)
提供从视图坐标空间到模型的逻辑坐标空间的映射关系。

参数：
pt - 视图中要转换的位置。此位置应该与鼠标事件在同一坐标系统中。
biasReturn - 由此方法填充，以指示给定点是更接近于模型中的前一个字符，还是更接近于模型中的下一个字符
返回：
模型中最好地表示视图中的给定点的位置，该位置 >= 0

getNextVisualPositionFrom

public abstract int getNextVisualPositionFrom(JTextComponent t,
                                              int pos,
                                              Position.Bias b,
                                              int direction,
                                              Position.Bias[] biasRet)
                                       throws BadLocationException
提供确定下一个可以放置一个插入符的可见模型位置的方法。一些视图可能是不可见的，它们的顺序可能与模型中的顺序不同，或者它们可能不允许访问模型中的某些位置。

参数：
t - 为其安装此 UI 的文本组件
pos - 要转换的位置，该位置 >= 0
b - 位置的偏差
direction - 以当前位置开始的方向，可以将它们设想为通常出现在键盘上的箭头键。该参数可以是 SwingConstants.WEST、SwingConstants.EAST、SwingConstants.NORTH 或 SwingConstants.SOUTH
biasRet - 包含返回位置偏差的数组
返回：
模型中能最好地表示下一个可见位置的位置
抛出：
BadLocationException
IllegalArgumentException - 如果方向无效

damageRange

public abstract void damageRange(JTextComponent t,
                                 int p0,
                                 int p1)
促使重新绘制负责模型给定部分的那部分视图。

参数：
p0 - 范围的起始位置，该位置 >= 0
p1 - 范围的结束位置，该位置 >= p0

damageRange

public abstract void damageRange(JTextComponent t,
                                 int p0,
                                 int p1,
                                 Position.Bias firstBias,
                                 Position.Bias secondBias)
促使重新绘制负责模型给定部分的那部分视图。

参数：
p0 - 范围的起始位置，该位置 >= 0
p1 - 范围的结束位置，该位置 >= p0

getEditorKit

public abstract EditorKit getEditorKit(JTextComponent t)
获取为要编辑的文档类型设置策略的服务绑定。这包含诸如可用命令、流 reader 和 writer 等这类东西。

返回：
编辑器工具包绑定

getRootView

public abstract View getRootView(JTextComponent t)
获取分配了相关文本组件（即层次结构的根）的 View，可遍历这些组件来确定在空间中表示模型的形式。

返回：
视图

getToolTipText

public String getToolTipText(JTextComponent t,
                             Point pt)
返回在传入位置上用作工具提示的字符串。

从以下版本开始：
1.4
另请参见：
JTextComponent.getToolTipText(java.awt.event.MouseEvent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ToolBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ToolBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ToolBarUI
直接已知子类：
BasicToolBarUI, MultiToolBarUI
public abstract class ToolBarUI
extends ComponentUI

JToolBar 的可插入外观界面。

构造方法摘要
ToolBarUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ToolBarUI

public ToolBarUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ToolTipUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ToolTipUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ToolTipUI
直接已知子类：
BasicToolTipUI, MultiToolTipUI
public abstract class ToolTipUI
extends ComponentUI

JToolTip 的可插入外观界面。

构造方法摘要
ToolTipUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ToolTipUI

public ToolTipUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 TreeUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TreeUI
直接已知子类：
BasicTreeUI, MultiTreeUI
public abstract class TreeUI
extends ComponentUI

JTree 的可插入外观界面。

构造方法摘要
TreeUI()
方法摘要
abstract void | cancelEditing(JTree tree) 取消当前编辑会话。
abstract TreePath | getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
abstract TreePath | getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
abstract Rectangle | getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
abstract TreePath | getPathForRow(JTree tree, int row) 返回传入的 row 的路径。
abstract int | getRowCount(JTree tree) 返回将显示的行数。
abstract int | getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
abstract boolean | isEditing(JTree tree) 如果树正被编辑，则返回 true。
abstract void | startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并试着编辑它。
abstract boolean | stopEditing(JTree tree) 停止当前编辑会话。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TreeUI

public TreeUI()
方法详细信息

getPathBounds

public abstract Rectangle getPathBounds(JTree tree,
                                        TreePath path)
返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。如果路径中的任何组件当前都是有效的，则返回 null。

getPathForRow

public abstract TreePath getPathForRow(JTree tree,
                                       int row)
返回传入的 row 的路径。如果 row 不可见，则返回 null。

getRowForPath

public abstract int getRowForPath(JTree tree,
                                  TreePath path)
返回可在其中看见路径中标识的最后一个项的行。如果路径中的所有元素当前都是不可见的，则返回 -1。

getRowCount

public abstract int getRowCount(JTree tree)
返回将显示的行数。

getClosestPathForLocation

public abstract TreePath getClosestPathForLocation(JTree tree,
                                                   int x,
                                                   int y)
返回到达最接近于 x,y 的那个节点的路径。如果当前不可见，则返回 null，否则该方法总是返回一条有效路径。如果要测试返回的对象是否正好位于 x, y，则应该获取返回路径的边界，并根据该边界测试 x,y。

isEditing

public abstract boolean isEditing(JTree tree)
如果树正被编辑，则返回 true。正被编辑的项可由 getEditingPath() 返回。

stopEditing

public abstract boolean stopEditing(JTree tree)
停止当前编辑会话。如果不在编辑树，则此方法无效。如果编辑器允许停止编辑会话，则返回 true。

cancelEditing

public abstract void cancelEditing(JTree tree)
取消当前编辑会话。如果不在编辑树，则此方法无效。如果编辑器允许停止编辑会话，则返回 true。

startEditingAtPath

public abstract void startEditingAtPath(JTree tree,
                                        TreePath path)
选择路径中的最后一个项并试着编辑它。如果 CellEditor 不允许对所选项进行编辑操作，则编辑将失败。

getEditingPath

public abstract TreePath getEditingPath(JTree tree)
返回到达正被编辑的元素的路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
接口 UIResource

所有已知实现类：
ActionMapUIResource, BasicBorders.ButtonBorder, BasicBorders.FieldBorder, BasicBorders.MarginBorder, BasicBorders.MenuBarBorder, BasicBorders.RadioButtonBorder, BasicBorders.RolloverButtonBorder, BasicBorders.SplitPaneBorder, BasicBorders.ToggleButtonBorder, BasicComboBoxEditor.UIResource, BasicComboBoxRenderer.UIResource, BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter, BorderUIResource, BorderUIResource.BevelBorderUIResource, BorderUIResource.CompoundBorderUIResource, BorderUIResource.EmptyBorderUIResource, BorderUIResource.EtchedBorderUIResource, BorderUIResource.LineBorderUIResource, BorderUIResource.MatteBorderUIResource, BorderUIResource.TitledBorderUIResource, ColorUIResource, ComponentInputMapUIResource, DefaultListCellRenderer.UIResource, DefaultMenuLayout, DefaultTableCellRenderer.UIResource, DimensionUIResource, FontUIResource, IconUIResource, InputMapUIResource, InsetsUIResource, JScrollPane.ScrollBar, MetalBorders.ButtonBorder, MetalBorders.Flush3DBorder, MetalBorders.InternalFrameBorder, MetalBorders.MenuBarBorder, MetalBorders.MenuItemBorder, MetalBorders.OptionDialogBorder, MetalBorders.PaletteBorder, MetalBorders.PopupMenuBorder, MetalBorders.RolloverButtonBorder, MetalBorders.ScrollPaneBorder, MetalBorders.TextFieldBorder, MetalBorders.ToggleButtonBorder, MetalBorders.ToolBarBorder, MetalCheckBoxIcon, MetalComboBoxEditor.UIResource, MetalIconFactory.PaletteCloseIcon, ScrollPaneLayout.UIResource
public interface UIResource

此接口用于标记由 ComponentUI 委托创建的对象。ComponentUI.installUI() 和 ComponentUI.uninstallUI() 方法可以使用此接口确定属性值是否已经被重写。例如，JList cellRenderer 属性只在其初始值为 null 时由 BasicListUI.installUI() 初始化：

 if (list.getCellRenderer() == null) {
     list.setCellRenderer((ListCellRenderer)(UIManager.get("List.cellRenderer")));
 }
在执行 uninstallUI() 时，如果该属性的值是 UIResource 的一个实例，则将该属性重置为 null：
 if (list.getCellRenderer() instanceof UIResource) {
     list.setCellRenderer(null);
 }
此模式应用于除 java.awt.Component 属性 font、foreground 和 background 之外的所有属性。如果这些属性中有一个未被初始化，或者被显式设置为 null，则其容器将提供该值。因此，在调用 installUI() 来动态更新组件外观时，"== null" 是不可靠的。因此，在执行 installUI() 时，要检查当前值是否是一个 UIResource：
 if (!(list.getFont() instanceof UIResource)) {
     list.setFont(UIManager.getFont("List.font"));
 }

另请参见：
ComponentUI

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewportUI (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf
类 ViewportUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ViewportUI
直接已知子类：
BasicViewportUI, MultiViewportUI
public abstract class ViewportUI
extends ComponentUI

JViewport 的可插入外观界面。

构造方法摘要
ViewportUI()
方法摘要
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installUI, paint, uninstallUI, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ViewportUI

public ViewportUI()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.plaf (Java Platform SE 6)

 javax.swing.plaf
接口
UIResource
类
ActionMapUIResource
BorderUIResource
BorderUIResource.BevelBorderUIResource
BorderUIResource.CompoundBorderUIResource
BorderUIResource.EmptyBorderUIResource
BorderUIResource.EtchedBorderUIResource
BorderUIResource.LineBorderUIResource
BorderUIResource.MatteBorderUIResource
BorderUIResource.TitledBorderUIResource
ButtonUI
ColorChooserUI
ColorUIResource
ComboBoxUI
ComponentInputMapUIResource
ComponentUI
DesktopIconUI
DesktopPaneUI
DimensionUIResource
FileChooserUI
FontUIResource
IconUIResource
InputMapUIResource
InsetsUIResource
InternalFrameUI
LabelUI
ListUI
MenuBarUI
MenuItemUI
OptionPaneUI
PanelUI
PopupMenuUI
ProgressBarUI
RootPaneUI
ScrollBarUI
ScrollPaneUI
SeparatorUI
SliderUI
SpinnerUI
SplitPaneUI
TabbedPaneUI
TableHeaderUI
TableUI
TextUI
ToolBarUI
ToolTipUI
TreeUI
ViewportUI


javax.swing.plaf (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.plaf

提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

请参见：
描述

接口摘要
UIResource 此接口用于标记由 ComponentUI 委托创建的对象。

类摘要
ActionMapUIResource | 实现 UIResource 的 javax.swing.ActionMap 的子类。
BorderUIResource |
BorderUIResource.BevelBorderUIResource |
BorderUIResource.CompoundBorderUIResource |
BorderUIResource.EmptyBorderUIResource |
BorderUIResource.EtchedBorderUIResource |
BorderUIResource.LineBorderUIResource |
BorderUIResource.MatteBorderUIResource |
BorderUIResource.TitledBorderUIResource |
ButtonUI | JButton 的可插入外观界面。
ColorChooserUI | JColorChooser 的可插入外观界面。
ColorUIResource |
ComboBoxUI | JComboBox 的可插入外观界面。
ComponentInputMapUIResource | 实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
ComponentUI | 用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
DesktopIconUI | JDesktopIcon 的可插入外观界面。
DesktopPaneUI | JDesktopPane 的可插入外观界面。
DimensionUIResource |
FileChooserUI | JFileChooser 的可插入外观界面。
FontUIResource | 实现 UIResource 的 java.awt.Font 的子类。
IconUIResource | 实现 UIResource 的 Icon 包装类。
InputMapUIResource | 实现 UIResource 的 javax.swing.InputMap 的子类。
InsetsUIResource |
InternalFrameUI | JInternalFrame 的可插入外观界面。
LabelUI | JLabel 的可插入外观界面。
ListUI | JList 的可插入外观代理。
MenuBarUI | JMenuBar 的可插入外观界面。
MenuItemUI | JMenuItem 的可插入外观界面。
OptionPaneUI | JOptionPane 的可插入外观界面。
PanelUI | Panel 的可插入外观界面。
PopupMenuUI | JPopupMenu 的可插入外观界面。
ProgressBarUI | JProgressBar 的可插入外观界面。
RootPaneUI | JRootPane 的可插入外观界面。
ScrollBarUI | JScrollBar 的可插入外观界面。
ScrollPaneUI | JScrollPane 的可插入外观界面。
SeparatorUI | JSeparator 的可插入外观界面。
SliderUI | JSlider 的可插入外观界面。
SpinnerUI | JSpinner 的可插入外观界面
SplitPaneUI | JSplitPane 的可插入外观界面。
TabbedPaneUI | JTabbedPane 的可插入外观界面。
TableHeaderUI | JTableHeader 的可插入外观界面。
TableUI | JTable 的可插入外观界面。
TextUI | 文本编辑器用户界面
ToolBarUI | JToolBar 的可插入外观界面。
ToolTipUI | JToolTip 的可插入外观界面。
TreeUI | JTree 的可插入外观界面。
ViewportUI | JViewport 的可插入外观界面。

软件包 javax.swing.plaf 的描述

提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。它的类由外观 UI（比如 Basic 外观和 Java 外观 (Metal)）实现并为其创建子类。此包仅由那些无法通过为现有外观组件（比如 javax.swing.plaf.basic 和 javax.swing.plaf.metal 包提供的那些组件）创建子类来创建新外观的开发人员使用。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.plaf 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.border.BevelBorder
        • javax.swing.plaf.BorderUIResource.BevelBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.CompoundBorder
        • javax.swing.plaf.BorderUIResource.CompoundBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EmptyBorder (implements java.io.Serializable)
        • javax.swing.plaf.BorderUIResource.EmptyBorderUIResource (implements javax.swing.plaf.UIResource)
        • javax.swing.border.MatteBorder
          • javax.swing.plaf.BorderUIResource.MatteBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EtchedBorder
        • javax.swing.plaf.BorderUIResource.EtchedBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.LineBorder
        • javax.swing.plaf.BorderUIResource.LineBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.TitledBorder
        • javax.swing.plaf.BorderUIResource.TitledBorderUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.ActionMap (implements java.io.Serializable)
      • javax.swing.plaf.ActionMapUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.BorderUIResource (implements javax.swing.border.Border, java.io.Serializable, javax.swing.plaf.UIResource)
    • java.awt.Color (implements java.awt.Paint, java.io.Serializable)
      • javax.swing.plaf.ColorUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
      • javax.swing.plaf.ColorChooserUI
      • javax.swing.plaf.ComboBoxUI
      • javax.swing.plaf.DesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
      • javax.swing.plaf.FileChooserUI
      • javax.swing.plaf.InternalFrameUI
      • javax.swing.plaf.LabelUI
      • javax.swing.plaf.ListUI
      • javax.swing.plaf.MenuBarUI
      • javax.swing.plaf.OptionPaneUI
      • javax.swing.plaf.PanelUI
      • javax.swing.plaf.PopupMenuUI
      • javax.swing.plaf.ProgressBarUI
      • javax.swing.plaf.RootPaneUI
      • javax.swing.plaf.ScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
      • javax.swing.plaf.SeparatorUI
      • javax.swing.plaf.SliderUI
      • javax.swing.plaf.SpinnerUI
      • javax.swing.plaf.SplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
      • javax.swing.plaf.TableHeaderUI
      • javax.swing.plaf.TableUI
      • javax.swing.plaf.TextUI
      • javax.swing.plaf.ToolBarUI
      • javax.swing.plaf.ToolTipUI
      • javax.swing.plaf.TreeUI
      • javax.swing.plaf.ViewportUI
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
      • java.awt.Dimension (implements java.io.Serializable)
        • javax.swing.plaf.DimensionUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.Font (implements java.io.Serializable)
      • javax.swing.plaf.FontUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.IconUIResource (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.InputMap (implements java.io.Serializable)
      • javax.swing.ComponentInputMap
        • javax.swing.plaf.ComponentInputMapUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.InputMapUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.Insets (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.InsetsUIResource (implements javax.swing.plaf.UIResource)

接口分层结构

  • javax.swing.plaf.UIResource
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.plaf 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf
的使用

使用 javax.swing.plaf 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 使用的 javax.swing.plaf 中的类
ButtonUI
JButton 的可插入外观界面。
ColorChooserUI
JColorChooser 的可插入外观界面。
ComboBoxUI
JComboBox 的可插入外观界面。
ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
DesktopIconUI
JDesktopIcon 的可插入外观界面。
DesktopPaneUI
JDesktopPane 的可插入外观界面。
FileChooserUI
JFileChooser 的可插入外观界面。
InternalFrameUI
JInternalFrame 的可插入外观界面。
LabelUI
JLabel 的可插入外观界面。
ListUI
JList 的可插入外观代理。
MenuBarUI
JMenuBar 的可插入外观界面。
MenuItemUI
JMenuItem 的可插入外观界面。
OptionPaneUI
JOptionPane 的可插入外观界面。
PanelUI
Panel 的可插入外观界面。
PopupMenuUI
JPopupMenu 的可插入外观界面。
ProgressBarUI
JProgressBar 的可插入外观界面。
RootPaneUI
JRootPane 的可插入外观界面。
ScrollBarUI
JScrollBar 的可插入外观界面。
ScrollPaneUI
JScrollPane 的可插入外观界面。
SeparatorUI
JSeparator 的可插入外观界面。
SliderUI
JSlider 的可插入外观界面。
SpinnerUI
JSpinner 的可插入外观界面
SplitPaneUI
JSplitPane 的可插入外观界面。
TabbedPaneUI
JTabbedPane 的可插入外观界面。
TableUI
JTable 的可插入外观界面。
ToolBarUI
JToolBar 的可插入外观界面。
ToolTipUI
JToolTip 的可插入外观界面。
TreeUI
JTree 的可插入外观界面。
UIResource
此接口用于标记由 ComponentUI 委托创建的对象。
ViewportUI
JViewport 的可插入外观界面。

javax.swing.plaf 使用的 javax.swing.plaf 中的类
ButtonUI
JButton 的可插入外观界面。
ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
UIResource
此接口用于标记由 ComponentUI 委托创建的对象。

javax.swing.plaf.basic 使用的 javax.swing.plaf 中的类
ButtonUI
JButton 的可插入外观界面。
ColorChooserUI
JColorChooser 的可插入外观界面。
ComboBoxUI
JComboBox 的可插入外观界面。
ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
DesktopIconUI
JDesktopIcon 的可插入外观界面。
DesktopPaneUI
JDesktopPane 的可插入外观界面。
FileChooserUI
JFileChooser 的可插入外观界面。
InternalFrameUI
JInternalFrame 的可插入外观界面。
LabelUI
JLabel 的可插入外观界面。
ListUI
JList 的可插入外观代理。
MenuBarUI
JMenuBar 的可插入外观界面。
MenuItemUI
JMenuItem 的可插入外观界面。
OptionPaneUI
JOptionPane 的可插入外观界面。
PanelUI
Panel 的可插入外观界面。
PopupMenuUI
JPopupMenu 的可插入外观界面。
ProgressBarUI
JProgressBar 的可插入外观界面。
RootPaneUI
JRootPane 的可插入外观界面。
ScrollBarUI
JScrollBar 的可插入外观界面。
ScrollPaneUI
JScrollPane 的可插入外观界面。
SeparatorUI
JSeparator 的可插入外观界面。
SliderUI
JSlider 的可插入外观界面。
SpinnerUI
JSpinner 的可插入外观界面
SplitPaneUI
JSplitPane 的可插入外观界面。
TabbedPaneUI
JTabbedPane 的可插入外观界面。
TableHeaderUI
JTableHeader 的可插入外观界面。
TableUI
JTable 的可插入外观界面。
TextUI
文本编辑器用户界面
ToolBarUI
JToolBar 的可插入外观界面。
ToolTipUI
JToolTip 的可插入外观界面。
TreeUI
JTree 的可插入外观界面。
UIResource
此接口用于标记由 ComponentUI 委托创建的对象。
ViewportUI
JViewport 的可插入外观界面。

javax.swing.plaf.metal 使用的 javax.swing.plaf 中的类
ButtonUI
JButton 的可插入外观界面。
ColorUIResource
ComboBoxUI
JComboBox 的可插入外观界面。
ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
DesktopIconUI
JDesktopIcon 的可插入外观界面。
FileChooserUI
JFileChooser 的可插入外观界面。
FontUIResource
实现 UIResource 的 java.awt.Font 的子类。
InternalFrameUI
JInternalFrame 的可插入外观界面。
LabelUI
JLabel 的可插入外观界面。
MenuBarUI
JMenuBar 的可插入外观界面。
ProgressBarUI
JProgressBar 的可插入外观界面。
RootPaneUI
JRootPane 的可插入外观界面。
ScrollBarUI
JScrollBar 的可插入外观界面。
ScrollPaneUI
JScrollPane 的可插入外观界面。
SeparatorUI
JSeparator 的可插入外观界面。
SliderUI
JSlider 的可插入外观界面。
SplitPaneUI
JSplitPane 的可插入外观界面。
TabbedPaneUI
JTabbedPane 的可插入外观界面。
TextUI
文本编辑器用户界面
ToolBarUI
JToolBar 的可插入外观界面。
ToolTipUI
JToolTip 的可插入外观界面。
TreeUI
JTree 的可插入外观界面。
UIResource
此接口用于标记由 ComponentUI 委托创建的对象。

javax.swing.plaf.multi 使用的 javax.swing.plaf 中的类
ButtonUI
JButton 的可插入外观界面。
ColorChooserUI
JColorChooser 的可插入外观界面。
ComboBoxUI
JComboBox 的可插入外观界面。
ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
DesktopIconUI
JDesktopIcon 的可插入外观界面。
DesktopPaneUI
JDesktopPane 的可插入外观界面。
FileChooserUI
JFileChooser 的可插入外观界面。
InternalFrameUI
JInternalFrame 的可插入外观界面。
LabelUI
JLabel 的可插入外观界面。
ListUI
JList 的可插入外观代理。
MenuBarUI
JMenuBar 的可插入外观界面。
MenuItemUI
JMenuItem 的可插入外观界面。
OptionPaneUI
JOptionPane 的可插入外观界面。
PanelUI
Panel 的可插入外观界面。
PopupMenuUI
JPopupMenu 的可插入外观界面。
ProgressBarUI
JProgressBar 的可插入外观界面。
RootPaneUI
JRootPane 的可插入外观界面。
ScrollBarUI
JScrollBar 的可插入外观界面。
ScrollPaneUI
JScrollPane 的可插入外观界面。
SeparatorUI
JSeparator 的可插入外观界面。
SliderUI
JSlider 的可插入外观界面。
SpinnerUI
JSpinner 的可插入外观界面
SplitPaneUI
JSplitPane 的可插入外观界面。
TabbedPaneUI
JTabbedPane 的可插入外观界面。
TableHeaderUI
JTableHeader 的可插入外观界面。
TableUI
JTable 的可插入外观界面。
TextUI
文本编辑器用户界面
ToolBarUI
JToolBar 的可插入外观界面。
ToolTipUI
JToolTip 的可插入外观界面。
TreeUI
JTree 的可插入外观界面。
ViewportUI
JViewport 的可插入外观界面。

javax.swing.plaf.synth 使用的 javax.swing.plaf 中的类
ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。

javax.swing.table 使用的 javax.swing.plaf 中的类
TableHeaderUI
JTableHeader 的可插入外观界面。
UIResource
此接口用于标记由 ComponentUI 委托创建的对象。

javax.swing.text 使用的 javax.swing.plaf 中的类
ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
TextUI
文本编辑器用户界面

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


BasicArrowButton (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicArrowButton

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JButton
                        继承者  javax.swing.plaf.basic.BasicArrowButton
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
直接已知子类：
MetalScrollButton
public class BasicArrowButton
extends JButton
implements SwingConstants

一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JButton 继承的嵌套类/接口
JButton.AccessibleJButton
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected  int direction
箭头的方向。
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
BasicArrowButton(int direction)
创建一个在指定方向上绘制其箭头的 BasicArrowButton。
BasicArrowButton(int direction, Color background, Color shadow, Color darkShadow, Color highlight)
创建一个在指定方向上绘制其箭头并具有指定颜色的 BasicArrowButton。
方法摘要
int | getDirection() 返回箭头的方向。
Dimension | getMaximumSize() 返回 BasicArrowButton 的最大大小。
Dimension | getMinimumSize() 返回 BasicArrowButton 的最小大小。
Dimension | getPreferredSize() 返回 BasicArrowButton 的首选大小。
boolean | isFocusTraversable() 返回箭头按钮是否应该获取焦点。
void | paint(Graphics g) 由 Swing 调用，以绘制组件。
void | paintTriangle(Graphics g, int x, int y, int size, int direction, boolean isEnabled) 绘制一个三角形。
void | setDirection(int dir) 设置箭头的方向。
从类 javax.swing.JButton 继承的方法
getAccessibleContext, getUIClassID, isDefaultButton, isDefaultCapable, paramString, removeNotify, setDefaultCapable, updateUI
从类 javax.swing.AbstractButton 继承的方法
actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

direction

protected int direction
箭头的方向。SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一。

构造方法详细信息

BasicArrowButton

public BasicArrowButton(int direction,
                        Color background,
                        Color shadow,
                        Color darkShadow,
                        Color highlight)
创建一个在指定方向上绘制其箭头并具有指定颜色的 BasicArrowButton。

参数：
direction - 箭头的方向；SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一
background - 按钮的背景色
shadow - 阴影的颜色
darkShadow - 黑阴影的颜色
highlight - 高亮显示的颜色
从以下版本开始：
1.4

BasicArrowButton

public BasicArrowButton(int direction)
创建一个在指定方向上绘制其箭头的 BasicArrowButton。

参数：
direction - 箭头的方向；SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一
方法详细信息

getDirection

public int getDirection()
返回箭头的方向。

参数：
direction - 箭头的方向；SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一

setDirection

public void setDirection(int dir)
设置箭头的方向。

参数：
direction - 箭头的方向；SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一

paint

public void paint(Graphics g)
从类 JComponent 复制的描述
由 Swing 调用，以绘制组件。应用程序不应直接调用 paint，而是应该使用 repaint 方法来安排重绘组件。

此方法实际上将绘制工作委托给三个受保护的方法：paintComponent、paintBorder 和 paintChildren。按列出的顺序调用这些方法，以确保子组件出现在组件本身的顶部。一般来说，不应在分配给边框的 insets 区域绘制组件及其子组件。子类可以始终重写此方法。只想特殊化 UI（外观）委托的 paint 方法的子类只需重写 paintComponent。

覆盖：
类 JComponent 中的 paint
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

getPreferredSize

public Dimension getPreferredSize()
返回 BasicArrowButton 的首选大小。

覆盖：
类 JComponent 中的 getPreferredSize
返回：
首选大小
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

getMinimumSize

public Dimension getMinimumSize()
返回 BasicArrowButton 的最小大小。

覆盖：
类 JComponent 中的 getMinimumSize
返回：
最小大小
另请参见：
JComponent.setMinimumSize(java.awt.Dimension), ComponentUI

getMaximumSize

public Dimension getMaximumSize()
返回 BasicArrowButton 的最大大小。

覆盖：
类 JComponent 中的 getMaximumSize
返回：
最大大小
另请参见：
JComponent.setMaximumSize(java.awt.Dimension), ComponentUI

isFocusTraversable

public boolean isFocusTraversable()
返回箭头按钮是否应该获取焦点。BasicArrowButton 用作复合组件（如 JScrollBar 和 JComboBox）的子组件。因为通常是复合组件获取焦点，所以重写此方法以返回 false。

覆盖：
类 Component 中的 isFocusTraversable
返回：
false
另请参见：
Component.setFocusable(boolean)

paintTriangle

public void paintTriangle(Graphics g,
                          int x,
                          int y,
                          int size,
                          int direction,
                          boolean isEnabled)
绘制一个三角形。

参数：
g - 要在其上进行绘制的 Graphics
x - x 坐标
y - y 坐标
size - 要绘制的三角形的大小
direction - 绘制箭头的方向；SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一
isEnabled - 是否已启用绘制箭头
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BasicBorders (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicBorders

public class BasicBorders
extends Object

可以提供适合基本 L&F 的 Border 的工厂对象。

嵌套类摘要
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.SplitPaneBorder 绘制围绕拆分窗格的边框。
static class | BasicBorders.ToggleButtonBorder
构造方法摘要
BasicBorders()
方法摘要
static Border | getButtonBorder()
static Border | getInternalFrameBorder()
static Border | getMenuBarBorder()
static Border | getProgressBarBorder()
static Border | getRadioButtonBorder()
static Border | getSplitPaneBorder()
static Border | getSplitPaneDividerBorder() 返回 JSplitPane 分隔符的边框实例
static Border | getTextFieldBorder()
static Border | getToggleButtonBorder()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicBorders

public BasicBorders()
方法详细信息

getButtonBorder

public static Border getButtonBorder()

getRadioButtonBorder

public static Border getRadioButtonBorder()

getToggleButtonBorder

public static Border getToggleButtonBorder()

getMenuBarBorder

public static Border getMenuBarBorder()

getSplitPaneBorder

public static Border getSplitPaneBorder()

getSplitPaneDividerBorder

public static Border getSplitPaneDividerBorder()
返回 JSplitPane 分隔符的边框实例

从以下版本开始：
1.3

getTextFieldBorder

public static Border getTextFieldBorder()

getProgressBarBorder

public static Border getProgressBarBorder()

getInternalFrameBorder

public static Border getInternalFrameBorder()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicBorders.ButtonBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders.ButtonBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.basic.BasicBorders.ButtonBorder
所有已实现的接口：
Serializable, Border, UIResource
直接已知子类：
BasicBorders.RadioButtonBorder, BasicBorders.RolloverButtonBorder, BasicBorders.ToggleButtonBorder
正在封闭类：
BasicBorders
public static class BasicBorders.ButtonBorder
extends AbstractBorder
implements UIResource

字段摘要
protected Color | darkShadow
protected Color | highlight
protected Color | lightHighlight
protected Color | shadow
构造方法摘要
BasicBorders.ButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

shadow

protected Color shadow

darkShadow

protected Color darkShadow

highlight

protected Color highlight

lightHighlight

protected Color lightHighlight
构造方法详细信息

BasicBorders.ButtonBorder

public BasicBorders.ButtonBorder(Color shadow,
                                 Color darkShadow,
                                 Color highlight,
                                 Color lightHighlight)
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicBorders.FieldBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders.FieldBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.basic.BasicBorders.FieldBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BasicBorders
public static class BasicBorders.FieldBorder
extends AbstractBorder
implements UIResource

字段摘要
protected Color | darkShadow
protected Color | highlight
protected Color | lightHighlight
protected Color | shadow
构造方法摘要
BasicBorders.FieldBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

shadow

protected Color shadow

darkShadow

protected Color darkShadow

highlight

protected Color highlight

lightHighlight

protected Color lightHighlight
构造方法详细信息

BasicBorders.FieldBorder

public BasicBorders.FieldBorder(Color shadow,
                                Color darkShadow,
                                Color highlight,
                                Color lightHighlight)
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicBorders.MarginBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders.MarginBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.basic.BasicBorders.MarginBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BasicBorders
public static class BasicBorders.MarginBorder
extends AbstractBorder
implements UIResource

构造方法摘要
BasicBorders.MarginBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque, paintBorder
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicBorders.MarginBorder

public BasicBorders.MarginBorder()
方法详细信息

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicBorders.MenuBarBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders.MenuBarBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.basic.BasicBorders.MenuBarBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BasicBorders
public static class BasicBorders.MenuBarBorder
extends AbstractBorder
implements UIResource

构造方法摘要
BasicBorders.MenuBarBorder(Color shadow, Color highlight)
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicBorders.MenuBarBorder

public BasicBorders.MenuBarBorder(Color shadow,
                                  Color highlight)
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicBorders.RadioButtonBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders.RadioButtonBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.basic.BasicBorders.ButtonBorder
            继承者  javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BasicBorders
public static class BasicBorders.RadioButtonBorder
extends BasicBorders.ButtonBorder

字段摘要
从类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 继承的字段
darkShadow, highlight, lightHighlight, shadow
构造方法摘要
BasicBorders.RadioButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicBorders.RadioButtonBorder

public BasicBorders.RadioButtonBorder(Color shadow,
                                      Color darkShadow,
                                      Color highlight,
                                      Color lightHighlight)
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 BasicBorders.ButtonBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 BasicBorders.ButtonBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 BasicBorders.ButtonBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicBorders.RolloverButtonBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders.RolloverButtonBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.basic.BasicBorders.ButtonBorder
            继承者  javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BasicBorders
public static class BasicBorders.RolloverButtonBorder
extends BasicBorders.ButtonBorder

用于翻转工具栏按钮的特殊细边框。

从以下版本开始：
1.4

字段摘要
从类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 继承的字段
darkShadow, highlight, lightHighlight, shadow
构造方法摘要
BasicBorders.RolloverButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
方法摘要
 void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
此默认实现不执行绘制操作。
从类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 继承的方法
getBorderInsets, getBorderInsets
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicBorders.RolloverButtonBorder

public BasicBorders.RolloverButtonBorder(Color shadow,
                                         Color darkShadow,
                                         Color highlight,
                                         Color lightHighlight)
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 BasicBorders.ButtonBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicBorders.SplitPaneBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders.SplitPaneBorder

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
所有已实现的接口：
Border, UIResource
正在封闭类：
BasicBorders
public static class BasicBorders.SplitPaneBorder
extends Object
implements Border, UIResource

绘制围绕拆分窗格的边框。要使工作正常进行，还应该在分隔符（属性 SplitPaneDivider.border）上安装边框。

字段摘要
protected Color | highlight
protected Color | shadow
构造方法摘要
BasicBorders.SplitPaneBorder(Color highlight, Color shadow)
方法摘要
Insets | getBorderInsets(Component c) 返回该边框的 insets。
boolean | isBorderOpaque() 返回此边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

highlight

protected Color highlight

shadow

protected Color shadow
构造方法详细信息

BasicBorders.SplitPaneBorder

public BasicBorders.SplitPaneBorder(Color highlight,
                                    Color shadow)
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
从接口 Border 复制的描述
按指定的位置和尺寸绘制指定组件的边框。

指定者：
接口 Border 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从接口 Border 复制的描述
返回该边框的 insets。

指定者：
接口 Border 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件

isBorderOpaque

public boolean isBorderOpaque()
从接口 Border 复制的描述
返回此边框是否透明。如果边框为不透明，则在绘制它时将用自身的背景来填充。

指定者：
接口 Border 中的 isBorderOpaque
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicBorders.ToggleButtonBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicBorders.ToggleButtonBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.basic.BasicBorders.ButtonBorder
            继承者  javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
BasicBorders
public static class BasicBorders.ToggleButtonBorder
extends BasicBorders.ButtonBorder

字段摘要
从类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 继承的字段
darkShadow, highlight, lightHighlight, shadow
构造方法摘要
BasicBorders.ToggleButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicBorders.ToggleButtonBorder

public BasicBorders.ToggleButtonBorder(Color shadow,
                                       Color darkShadow,
                                       Color highlight,
                                       Color lightHighlight)
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 BasicBorders.ButtonBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 BasicBorders.ButtonBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 BasicBorders.ButtonBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicButtonListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicButtonListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicButtonListener
所有已实现的接口：
FocusListener, MouseListener, MouseMotionListener, PropertyChangeListener, EventListener, ChangeListener
public class BasicButtonListener
extends Object
implements MouseListener, MouseMotionListener, FocusListener, ChangeListener, PropertyChangeListener

按钮侦听器。

构造方法摘要
BasicButtonListener(AbstractButton b)
方法摘要
protected void | checkOpacity(AbstractButton b)
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
void | installKeyboardActions(JComponent c) 注册默认键动作：按下空格键以“单击”按钮并注册键盘助记符（如果有）。
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
void | propertyChange(PropertyChangeEvent e) 在绑定属性发生更改时调用此方法。
void | stateChanged(ChangeEvent e) 当侦听器的目标已更改其状态时调用。
void | uninstallKeyboardActions(JComponent c) 未注册的默认键动作
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicButtonListener

public BasicButtonListener(AbstractButton b)
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。

checkOpacity

protected void checkOpacity(AbstractButton b)

installKeyboardActions

public void installKeyboardActions(JComponent c)
注册默认键动作：按下空格键以“单击”按钮并注册键盘助记符（如果有）。

uninstallKeyboardActions

public void uninstallKeyboardActions(JComponent c)
未注册的默认键动作

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象

focusGained

public void focusGained(FocusEvent e)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased

mouseEntered

public void mouseEntered(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicButtonUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicButtonUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.basic.BasicButtonUI
直接已知子类：
BasicToggleButtonUI, MetalButtonUI
public class BasicButtonUI
extends ButtonUI

BasicButton 实现

字段摘要
protected int | defaultTextIconGap
protected int | defaultTextShiftOffset
构造方法摘要
BasicButtonUI()
方法摘要
protected void | clearTextShiftOffset()
protected BasicButtonListener | createButtonListener(AbstractButton b)
static ComponentUI | createUI(JComponent c)
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
int | getDefaultTextIconGap(AbstractButton b)
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected String | getPropertyPrefix()
protected int | getTextShiftOffset()
protected void | installDefaults(AbstractButton b)
protected void | installKeyboardActions(AbstractButton b)
protected void | installListeners(AbstractButton b)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | paintButtonPressed(Graphics g, AbstractButton b)
protected void | paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | paintIcon(Graphics g, JComponent c, Rectangle iconRect)
protected void | paintText(Graphics g, AbstractButton b, Rectangle textRect, String text) 呈现当前按钮文本的方法。
protected void | paintText(Graphics g, JComponent c, Rectangle textRect, String text) 从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
protected void | setTextShiftOffset()
protected void | uninstallDefaults(AbstractButton b)
protected void | uninstallKeyboardActions(AbstractButton b)
protected void | uninstallListeners(AbstractButton b)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

defaultTextIconGap

protected int defaultTextIconGap

defaultTextShiftOffset

protected int defaultTextShiftOffset
构造方法详细信息

BasicButtonUI

public BasicButtonUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

getPropertyPrefix

protected String getPropertyPrefix()

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

installDefaults

protected void installDefaults(AbstractButton b)

installListeners

protected void installListeners(AbstractButton b)

installKeyboardActions

protected void installKeyboardActions(AbstractButton b)

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

uninstallKeyboardActions

protected void uninstallKeyboardActions(AbstractButton b)

uninstallListeners

protected void uninstallListeners(AbstractButton b)

uninstallDefaults

protected void uninstallDefaults(AbstractButton b)

createButtonListener

protected BasicButtonListener createButtonListener(AbstractButton b)

getDefaultTextIconGap

public int getDefaultTextIconGap(AbstractButton b)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintIcon

protected void paintIcon(Graphics g,
                         JComponent c,
                         Rectangle iconRect)

paintText

protected void paintText(Graphics g,
                         JComponent c,
                         Rectangle textRect,
                         String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。改为使用带有 AbstractButton 参数的 paintText 方法。

paintText

protected void paintText(Graphics g,
                         AbstractButton b,
                         Rectangle textRect,
                         String text)
呈现当前按钮文本的方法。

参数：
g - 图形上下文
b - 要呈现的当前按钮
textRect - 呈现文本的边界矩形。
text - 要呈现的字符串
从以下版本开始：
1.4

paintFocus

protected void paintFocus(Graphics g,
                          AbstractButton b,
                          Rectangle viewRect,
                          Rectangle textRect,
                          Rectangle iconRect)

paintButtonPressed

protected void paintButtonPressed(Graphics g,
                                  AbstractButton b)

clearTextShiftOffset

protected void clearTextShiftOffset()

setTextShiftOffset

protected void setTextShiftOffset()

getTextShiftOffset

protected int getTextShiftOffset()

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicCheckBoxMenuItemUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicCheckBoxMenuItemUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.MenuItemUI
                继承者  javax.swing.plaf.basic.BasicMenuItemUI
                    继承者  javax.swing.plaf.basic.BasicCheckBoxMenuItemUI

public class BasicCheckBoxMenuItemUI
extends BasicMenuItemUI

BasicCheckboxMenuItem 实现

嵌套类摘要
从类 javax.swing.plaf.basic.BasicMenuItemUI 继承的嵌套类/接口
BasicMenuItemUI.MouseInputHandler
字段摘要
从类 javax.swing.plaf.basic.BasicMenuItemUI 继承的字段
acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground
构造方法摘要
BasicCheckBoxMenuItemUI()
方法摘要
static ComponentUI | createUI(JComponent c)
protected String | getPropertyPrefix()
void | processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
从类 javax.swing.plaf.basic.BasicMenuItemUI 继承的方法
createMenuDragMouseListener, createMenuKeyListener, createMouseInputListener, createPropertyChangeListener, doClick, getMaximumSize, getMinimumSize, getPath, getPreferredMenuItemSize, getPreferredSize, installComponents, installDefaults, installKeyboardActions, installListeners, installUI, paint, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicCheckBoxMenuItemUI

public BasicCheckBoxMenuItemUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

getPropertyPrefix

protected String getPropertyPrefix()
覆盖：
类 BasicMenuItemUI 中的 getPropertyPrefix

processMouseEvent

public void processMouseEvent(JMenuItem item,
                              MouseEvent e,
                              MenuElement[] path,
                              MenuSelectionManager manager)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicCheckBoxUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicCheckBoxUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.basic.BasicButtonUI
                继承者  javax.swing.plaf.basic.BasicToggleButtonUI
                    继承者  javax.swing.plaf.basic.BasicRadioButtonUI
                        继承者  javax.swing.plaf.basic.BasicCheckBoxUI

public class BasicCheckBoxUI
extends BasicRadioButtonUI

BasicCheckboxUI 的 CheckboxUI 实现

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.plaf.basic.BasicRadioButtonUI 继承的字段
icon
从类 javax.swing.plaf.basic.BasicButtonUI 继承的字段
defaultTextIconGap, defaultTextShiftOffset
构造方法摘要
BasicCheckBoxUI()
方法摘要
static ComponentUI | createUI(JComponent b)
String | getPropertyPrefix()
从类 javax.swing.plaf.basic.BasicRadioButtonUI 继承的方法
getDefaultIcon, getPreferredSize, installDefaults, paint, paintFocus, uninstallDefaults
从类 javax.swing.plaf.basic.BasicToggleButtonUI 继承的方法
getTextShiftOffset, paintIcon
从类 javax.swing.plaf.basic.BasicButtonUI 继承的方法
clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicCheckBoxUI

public BasicCheckBoxUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent b)

getPropertyPrefix

public String getPropertyPrefix()
覆盖：
类 BasicRadioButtonUI 中的 getPropertyPrefix
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicColorChooserUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicColorChooserUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ColorChooserUI
            继承者  javax.swing.plaf.basic.BasicColorChooserUI

public class BasicColorChooserUI
extends ColorChooserUI

为 JColorChooser 提供基本外观。

嵌套类摘要
 class BasicColorChooserUI.PropertyHandler
因编译器故障而被标记为 "public" 的内部类。
字段摘要
protected JColorChooser | chooser 在其上安装此 BasicColorChooserUI 的 JColorChooser。
protected AbstractColorChooserPanel[] | defaultChoosers
protected ChangeListener | previewListener
protected PropertyChangeListener | propertyChangeListener
构造方法摘要
BasicColorChooserUI()
方法摘要
protected AbstractColorChooserPanel[] | createDefaultChoosers()
protected PropertyChangeListener | createPropertyChangeListener()
static ComponentUI | createUI(JComponent c)
protected void | installDefaults()
protected void | installListeners()
protected void | installPreviewPanel()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected void | uninstallDefaultChoosers()
protected void | uninstallDefaults()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

chooser

protected JColorChooser chooser
在其上安装此 BasicColorChooserUI 的 JColorChooser。

从以下版本开始：
1.5

defaultChoosers

protected AbstractColorChooserPanel[] defaultChoosers

previewListener

protected ChangeListener previewListener

propertyChangeListener

protected PropertyChangeListener propertyChangeListener
构造方法详细信息

BasicColorChooserUI

public BasicColorChooserUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

createDefaultChoosers

protected AbstractColorChooserPanel[] createDefaultChoosers()

uninstallDefaultChoosers

protected void uninstallDefaultChoosers()

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installPreviewPanel

protected void installPreviewPanel()

installDefaults

protected void installDefaults()

uninstallDefaults

protected void uninstallDefaults()

installListeners

protected void installListeners()

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()

uninstallListeners

protected void uninstallListeners()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicColorChooserUI.PropertyHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicColorChooserUI.PropertyHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicColorChooserUI
public class BasicColorChooserUI.PropertyHandler
extends Object
implements PropertyChangeListener

因编译器故障而被标记为 "public" 的内部类。此类应该视为 "protected" 内部类。仅在 BasicComboBoxUI 的子类中实例化此类。

构造方法摘要
BasicColorChooserUI.PropertyHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicColorChooserUI.PropertyHandler

public BasicColorChooserUI.PropertyHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxEditor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxEditor

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxEditor
所有已实现的接口：
FocusListener, EventListener, ComboBoxEditor
直接已知子类：
BasicComboBoxEditor.UIResource, MetalComboBoxEditor
public class BasicComboBoxEditor
extends Object
implements ComboBoxEditor, FocusListener

用于可编辑组合框的默认编辑器。该编辑器被实现为 JTextField。

嵌套类摘要
static class BasicComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的子类。
字段摘要
protected  JTextField editor
构造方法摘要
BasicComboBoxEditor()
方法摘要
void | addActionListener(ActionListener l) 添加一个 ActionListener。
protected JTextField | createEditorComponent() 创建内部编辑器组件。
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
Component | getEditorComponent() 返回应该添加到此编辑器的树层次结构中的组件。
Object | getItem() 返回已编辑项。
void | removeActionListener(ActionListener l) 移除一个 ActionListener
void | selectAll() 请求编辑器开始编辑并选定所有对象
void | setItem(Object anObject) 设置应该编辑的项。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

editor

protected JTextField editor
构造方法详细信息

BasicComboBoxEditor

public BasicComboBoxEditor()
方法详细信息

getEditorComponent

public Component getEditorComponent()
从接口 ComboBoxEditor 复制的描述
返回应该添加到此编辑器的树层次结构中的组件。

指定者：
接口 ComboBoxEditor 中的 getEditorComponent

createEditorComponent

protected JTextField createEditorComponent()
创建内部编辑器组件。重写此方法以提供自定义实现。

返回：
新编辑器组件
从以下版本开始：
1.6

setItem

public void setItem(Object anObject)
设置应该编辑的项。

指定者：
接口 ComboBoxEditor 中的 setItem
参数：
anObject - 编辑器的显示值

getItem

public Object getItem()
从接口 ComboBoxEditor 复制的描述
返回已编辑项。

指定者：
接口 ComboBoxEditor 中的 getItem

selectAll

public void selectAll()
从接口 ComboBoxEditor 复制的描述
请求编辑器开始编辑并选定所有对象

指定者：
接口 ComboBoxEditor 中的 selectAll

focusGained

public void focusGained(FocusEvent e)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost

addActionListener

public void addActionListener(ActionListener l)
从接口 ComboBoxEditor 复制的描述
添加一个 ActionListener。当已编辑的项发生更改时，生成一个操作事件

指定者：
接口 ComboBoxEditor 中的 addActionListener

removeActionListener

public void removeActionListener(ActionListener l)
从接口 ComboBoxEditor 复制的描述
移除一个 ActionListener

指定者：
接口 ComboBoxEditor 中的 removeActionListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxEditor.UIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxEditor.UIResource

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxEditor
        继承者  javax.swing.plaf.basic.BasicComboBoxEditor.UIResource
所有已实现的接口：
FocusListener, EventListener, ComboBoxEditor, UIResource
正在封闭类：
BasicComboBoxEditor
public static class BasicComboBoxEditor.UIResource
extends BasicComboBoxEditor
implements UIResource

实现 UIResource 的 BasicComboBoxEditor 的子类。BasicComboBoxEditor 不直接实现 UIResource，以便应用程序安全地利用 BasicListCellRenderer 子类重写 cellRenderer 属性。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicComboBoxEditor 继承的嵌套类/接口
BasicComboBoxEditor.UIResource
字段摘要
从类 javax.swing.plaf.basic.BasicComboBoxEditor 继承的字段
editor
构造方法摘要
BasicComboBoxEditor.UIResource()
方法摘要
从类 javax.swing.plaf.basic.BasicComboBoxEditor 继承的方法
addActionListener, createEditorComponent, focusGained, focusLost, getEditorComponent, getItem, removeActionListener, selectAll, setItem
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboBoxEditor.UIResource

public BasicComboBoxEditor.UIResource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxRenderer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxRenderer

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.plaf.basic.BasicComboBoxRenderer
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer, SwingConstants
直接已知子类：
BasicComboBoxRenderer.UIResource
public class BasicComboBoxRenderer
extends JLabel
implements ListCellRenderer, Serializable

ComboBox 渲染器

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
static class BasicComboBoxRenderer.UIResource
实现 UIResource 的 BasicComboBoxRenderer 的子类。
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected static Border noFocusBorder
空 Border。
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
BasicComboBoxRenderer()
方法摘要
Component | getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus) 返回已配置用于显示指定值的组件。
Dimension | getPreferredSize() 如果 preferredSize 已设置为一个非 null 值，则返回该值。
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

noFocusBorder

protected static Border noFocusBorder
空 Border。可以不使用此字段。要更改此渲染器所使用的 Border，请使用 setBorder 方法直接设置它。

构造方法详细信息

BasicComboBoxRenderer

public BasicComboBoxRenderer()
方法详细信息

getPreferredSize

public Dimension getPreferredSize()
从类 JComponent 复制的描述
如果 preferredSize 已设置为一个非 null 值，则返回该值。如果 UI 委托的 getPreferredSize 方法返回一个非 null 值，则返回该值；否则服从组件的布局管理器。

覆盖：
类 JComponent 中的 getPreferredSize
返回：
preferredSize 属性的值
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

getListCellRendererComponent

public Component getListCellRendererComponent(JList list,
                                              Object value,
                                              int index,
                                              boolean isSelected,
                                              boolean cellHasFocus)
从接口 ListCellRenderer 复制的描述
返回已配置用于显示指定值的组件。然后调用该组件的 paint 方法来“呈现”单元格。如果由于列表单元格没有固定的大小而有必要计算该列表的尺寸，则调用此方法来生成一个可在其上调用 getPreferredSize 的组件。

指定者：
接口 ListCellRenderer 中的 getListCellRendererComponent
参数：
list - 正在绘制的 JList。
value - 由 list.getModel().getElementAt(index) 返回的值。
index - 单元格索引。
isSelected - 如果选择了指定的单元格，则为 true。
cellHasFocus - 如果指定的单元格拥有焦点，则为 true。
返回：
其 paint() 方法将呈现指定值的组件。
另请参见：
JList, ListSelectionModel, ListModel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxRenderer.UIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxRenderer.UIResource

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.plaf.basic.BasicComboBoxRenderer
                        继承者  javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer, UIResource, SwingConstants
正在封闭类：
BasicComboBoxRenderer
public static class BasicComboBoxRenderer.UIResource
extends BasicComboBoxRenderer
implements UIResource

实现 UIResource 的 BasicComboBoxRenderer 的子类。BasicComboBoxRenderer 不直接实现 UIResource，以便应用程序安全地利用 BasicListCellRenderer 子类重写 cellRenderer 属性。

警告： 此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicComboBoxRenderer 继承的嵌套类/接口
BasicComboBoxRenderer.UIResource
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.plaf.basic.BasicComboBoxRenderer 继承的字段
noFocusBorder
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
BasicComboBoxRenderer.UIResource()
方法摘要
从类 javax.swing.plaf.basic.BasicComboBoxRenderer 继承的方法
getListCellRendererComponent, getPreferredSize
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BasicComboBoxRenderer.UIResource

public BasicComboBoxRenderer.UIResource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ComboBoxUI
            继承者  javax.swing.plaf.basic.BasicComboBoxUI
直接已知子类：
MetalComboBoxUI
public class BasicComboBoxUI
extends ComboBoxUI

JComboBox 的基本 UI 实现。

组合框是一个组合组件，这意味着它是很多简单组件的聚合。此类创建和管理组合框上的侦听器和组合框模型。这些侦听器更新用户界面以响应组合框的属性和状态的更改。

所有事件处理都是由利用 createxxxListener() 方法和内部类创建的侦听器类处理的。通过重写 createxxxListener() 方法，并提供自己的事件侦听器或为此类提供的事件侦听器创建子类，可以更改此类的行为。

为了添加特殊动作，需要重写 installKeyboardActions 来添加响应 KeyStroke 绑定的动作。请参见 The Swing Connection 中的文章 Keyboard Bindings in Swing。

嵌套类摘要
class | BasicComboBoxUI.ComboBoxLayoutManager 此布局管理器处理组合框的“标准”布局。
class | BasicComboBoxUI.FocusHandler 失去焦点时，此侦听器将隐藏弹出部分。
class | BasicComboBoxUI.ItemHandler 此侦听器观察组合框中选择的更改。
class | BasicComboBoxUI.KeyHandler 此侦听器检查键事件是否不是导航键。
class | BasicComboBoxUI.ListDataHandler 此侦听器观察 ComboBoxModel 中的更改。
class | BasicComboBoxUI.PropertyChangeHandler 此侦听器观察在组合框中发生更改的绑定 (bound) 属性。
字段摘要
protected JButton | arrowButton
protected Dimension | cachedMinimumSize
protected JComboBox | comboBox
protected CellRendererPane | currentValuePane
protected Component | editor
protected FocusListener | focusListener 此受保护字段是特定于实现的。
protected boolean | hasFocus 此受保护字段是特定于实现的。
protected boolean | isMinimumSizeDirty
protected ItemListener | itemListener 此受保护字段是特定于实现的。
protected KeyListener | keyListener 此受保护字段是特定于实现的。
protected JList | listBox
protected ListDataListener | listDataListener 此受保护字段是特定于实现的。
protected ComboPopup | popup
protected KeyListener | popupKeyListener
protected MouseListener | popupMouseListener
protected MouseMotionListener | popupMouseMotionListener
protected PropertyChangeListener | propertyChangeListener 此受保护字段是特定于实现的。
构造方法摘要
BasicComboBoxUI()
方法摘要
void | addEditor() 此公共方法是特定于实现的，应该为私有，不要调用或重写。
void | configureArrowButton() 此公共方法是特定于实现的，应该为私有。
protected void | configureEditor() 此受保护方法是特定于实现的，应该为私有，不要调用或重写。
protected JButton | createArrowButton() 创建一个按钮，将使用它来控制显示或隐藏组合框的弹出部分。
protected ComboBoxEditor | createEditor() 创建将在可编辑的组合框中使用的默认编辑器。
protected FocusListener | createFocusListener() 创建将添加到组合框的 FocusListener。
protected ItemListener | createItemListener() 创建将添加到组合框的 ItemListener。
protected KeyListener | createKeyListener() 创建将添加到组合框的 KeyListener。
protected LayoutManager | createLayoutManager() 创建用于管理构成组合框的组件的布局管理器。
protected ListDataListener | createListDataListener() 创建将添加到 ComboBoxModel 的列表数据侦听器。
protected ComboPopup | createPopup() 创建组合框的弹出部分。
protected PropertyChangeListener | createPropertyChangeListener() 创建将添加到组合框的 PropertyChangeListener。
protected ListCellRenderer | createRenderer() 创建将在不可编辑的组合框中使用的默认渲染器。
static ComponentUI | createUI(JComponent c)
Accessible | getAccessibleChild(JComponent c, int i) 返回对象的第 i 个 Accessible 子对象。
int | getAccessibleChildrenCount(JComponent c) 返回对象中的可访问子对象数。
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
protected Dimension | getDefaultSize() 返回使用当前渲染器和字体的组合框的空显示区域的默认大小。
protected Dimension | getDisplaySize() 返回显示区域的计算大小。
protected Insets | getInsets() 获取 JComboBox 的 insets。
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 最小大小为显示区域加上 insets 再加上按钮的大小。
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected void | installComponents() 创建并初始化构成聚合组合框的组件。
protected void | installDefaults() 将默认颜色、默认字体、默认渲染器和默认编辑器安装到 JComboBox 中。
protected void | installKeyboardActions() 将键盘动作添加到 JComboBox。
protected void | installListeners() 为组合框及其模型创建并安装侦听器。
void | installUI(JComponent c) 配置指定组件，使其适合外观。
boolean | isFocusTraversable(JComboBox c) 确定 JComboBox 是否是可焦点遍历的。
protected boolean | isNavigationKey(int keyCode) 返回提供的 keyCode 是否映射到用于导航的键中。
boolean | isPopupVisible(JComboBox c) 告知弹出控件是否可见。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus) 绘制当前所选项。
void | paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus) 绘制当前所选项的背景。
protected Rectangle | rectangleForCurrentValue() 返回为绘制当前所选项而保留的区域。
void | removeEditor() 此公共方法是特定于实现的，应该为私有，不要调用或重写。
protected void | selectNextPossibleValue() 选择列表中的下一项。
protected void | selectPreviousPossibleValue() 选择列表中的上一项。
void | setPopupVisible(JComboBox c, boolean v) 隐藏弹出部分。
protected void | toggleOpenClose() 如果正在显示弹出部分，则隐藏它；如果它是隐藏的，则显示它。
void | unconfigureArrowButton() 此公共方法是特定于实现的，应该为私有。
protected void | unconfigureEditor() 此受保护方法是特定于实现的，应该为私有。
protected void | uninstallComponents() 注销并卸载组成组合框的聚合组件。
protected void | uninstallDefaults() 从 JComboBox 中卸载默认颜色、默认字体、默认渲染器和默认编辑器。
protected void | uninstallKeyboardActions() 移除焦点 InputMap 和 ActionMap。
protected void | uninstallListeners() 从组合框及其模型中移除已安装的侦听器。
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

comboBox

protected JComboBox comboBox

hasFocus

protected boolean hasFocus
此受保护字段是特定于实现的。不要直接访问或重写。

listBox

protected JList listBox

currentValuePane

protected CellRendererPane currentValuePane

popup

protected ComboPopup popup

editor

protected Component editor

arrowButton

protected JButton arrowButton

keyListener

protected KeyListener keyListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为重写侦听器构造方法。

另请参见：
createKeyListener()

focusListener

protected FocusListener focusListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为重写侦听器构造方法。

另请参见：
createFocusListener()

propertyChangeListener

protected PropertyChangeListener propertyChangeListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为重写侦听器构造方法。

另请参见：
createPropertyChangeListener()

itemListener

protected ItemListener itemListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为重写侦听器构造方法。

另请参见：
createItemListener()

popupMouseListener

protected MouseListener popupMouseListener

popupMouseMotionListener

protected MouseMotionListener popupMouseMotionListener

popupKeyListener

protected KeyListener popupKeyListener

listDataListener

protected ListDataListener listDataListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为重写侦听器构造方法。

另请参见：
createListDataListener()

isMinimumSizeDirty

protected boolean isMinimumSizeDirty

cachedMinimumSize

protected Dimension cachedMinimumSize
构造方法详细信息

BasicComboBoxUI

public BasicComboBoxUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults()
将默认颜色、默认字体、默认渲染器和默认编辑器安装到 JComboBox 中。

installListeners

protected void installListeners()
为组合框及其模型创建并安装侦听器。安装 UI 时调用此方法。

uninstallDefaults

protected void uninstallDefaults()
从 JComboBox 中卸载默认颜色、默认字体、默认渲染器和默认编辑器。

uninstallListeners

protected void uninstallListeners()
从组合框及其模型中移除已安装的侦听器。从此方法中移除的侦听器的数目和类型应该与在 installListeners 中添加的相同。

createPopup

protected ComboPopup createPopup()
创建组合框的弹出部分。

返回：
ComboPopup 的实例
另请参见：
ComboPopup

createKeyListener

protected KeyListener createKeyListener()
创建将添加到组合框的 KeyListener。如果此方法返回 null，则不会将其添加到组合框。

返回：
KeyListener 的实例或 null

createFocusListener

protected FocusListener createFocusListener()
创建将添加到组合框的 FocusListener。如果此方法返回 null，则不会将其添加到组合框。

返回：
FocusListener 的实例或 null

createListDataListener

protected ListDataListener createListDataListener()
创建将添加到 ComboBoxModel 的列表数据侦听器。如果此方法返回 null，则不会将其添加到组合框模型。

返回：
ListDataListener 的实例或 null

createItemListener

protected ItemListener createItemListener()
创建将添加到组合框的 ItemListener。如果此方法返回 null，则不会将其添加到组合框。

子类可以重写此方法以返回其 ItemEvent 处理程序的实例。

返回：
ItemListener 的实例或 null

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
创建将添加到组合框的 PropertyChangeListener。如果此方法返回 null，则不会将其添加到组合框。

返回：
PropertyChangeListener 的实例或 null

createLayoutManager

protected LayoutManager createLayoutManager()
创建用于管理构成组合框的组件的布局管理器。

返回：
布局管理器的实例

createRenderer

protected ListCellRenderer createRenderer()
创建将在不可编辑的组合框中使用的默认渲染器。仅当没有利用 setRenderer 显式设置渲染器时才使用默认渲染器。

返回：
用于组合框的 ListCellRender
另请参见：
JComboBox.setRenderer(javax.swing.ListCellRenderer)

createEditor

protected ComboBoxEditor createEditor()
创建将在可编辑的组合框中使用的默认编辑器。仅当没有利用 setEditor 显式设置编辑器时才使用默认编辑器。

返回：
用于组合框的 ComboBoxEditor
另请参见：
JComboBox.setEditor(javax.swing.ComboBoxEditor)

installComponents

protected void installComponents()
创建并初始化构成聚合组合框的组件。此方法作为 UI 安装进程的一部分调用。

uninstallComponents

protected void uninstallComponents()
注销并卸载组成组合框的聚合组件。此方法作为 UI 卸载进程的一部分调用。

addEditor

public void addEditor()
此公共方法是特定于实现的，应该为私有，不要调用或重写。要实现特定编辑器，请创建自定义 ComboBoxEditor

另请参见：
createEditor(), JComboBox.setEditor(javax.swing.ComboBoxEditor), ComboBoxEditor

removeEditor

public void removeEditor()
此公共方法是特定于实现的，应该为私有，不要调用或重写。

另请参见：
addEditor()

configureEditor

protected void configureEditor()
此受保护方法是特定于实现的，应该为私有，不要调用或重写。

另请参见：
addEditor()

unconfigureEditor

protected void unconfigureEditor()
此受保护方法是特定于实现的，应该为私有。不要调用或重写。

另请参见：
addEditor()

configureArrowButton

public void configureArrowButton()
此公共方法是特定于实现的，应该为私有。不要调用或重写。

另请参见：
createArrowButton()

unconfigureArrowButton

public void unconfigureArrowButton()
此公共方法是特定于实现的，应该为私有。不要调用或重写。

另请参见：
createArrowButton()

createArrowButton

protected JButton createArrowButton()
创建一个按钮，将使用它来控制显示或隐藏组合框的弹出部分。

返回：
表示弹出控件的按钮

isPopupVisible

public boolean isPopupVisible(JComboBox c)
告知弹出控件是否可见。

指定者：
类 ComboBoxUI 中的 isPopupVisible

setPopupVisible

public void setPopupVisible(JComboBox c,
                            boolean v)
隐藏弹出部分。

指定者：
类 ComboBoxUI 中的 setPopupVisible

isFocusTraversable

public boolean isFocusTraversable(JComboBox c)
确定 JComboBox 是否是可焦点遍历的。如果 JComboBox 可编辑，则其返回 false；否则，返回 true。

指定者：
类 ComboBoxUI 中的 isFocusTraversable

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
最小大小为显示区域加上 insets 再加上按钮的大小。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent c)
从类 ComponentUI 复制的描述
返回对象中的可访问子对象数。如果此对象的所有子对象都实现 Accessible，那么此方法应返回此对象的子对象数。如果 UI 在可看作组件的屏幕上呈现一些区域，那么它们可能希望重写此方法，但实际组件并不用于呈现那些区域。 注：从 v1.3 开始，建议开发人员调用 Component.AccessibleAWTComponent.getAccessibleChildrenCount() 替代此方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
该对象中可访问的子对象数
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent c,
                                     int i)
从类 ComponentUI 复制的描述
返回对象的第 i 个 Accessible 子对象。如果 UI 在可看作组件的屏幕上呈现一些区域，那么它们可能需要重写此方法，但实际组件并不用于呈现那些区域。

注：从 v1.3 开始，建议开发人员调用 Component.AccessibleAWTComponent.getAccessibleChild() 替代此方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
i - 子对象的从零开始的索引
返回：
对象的第 i 个 Accessible 子对象
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)

isNavigationKey

protected boolean isNavigationKey(int keyCode)
返回提供的 keyCode 是否映射到用于导航的键中。它用于仅通过将非导航键传递到提前键入机制来优化键输入。如果子类更改导航键，则其应该重写此方法。

selectNextPossibleValue

protected void selectNextPossibleValue()
选择列表中的下一项。如果当前所选项已经是最后一项，则其不更改选择。

selectPreviousPossibleValue

protected void selectPreviousPossibleValue()
选择列表中的上一项。如果当前选择的项已经是第一项，则其不更改选择。

toggleOpenClose

protected void toggleOpenClose()
如果正在显示弹出部分，则隐藏它；如果它是隐藏的，则显示它。

rectangleForCurrentValue

protected Rectangle rectangleForCurrentValue()
返回为绘制当前所选项而保留的区域。

getInsets

protected Insets getInsets()
获取 JComboBox 的 insets。

paintCurrentValue

public void paintCurrentValue(Graphics g,
                              Rectangle bounds,
                              boolean hasFocus)
绘制当前所选项。

paintCurrentValueBackground

public void paintCurrentValueBackground(Graphics g,
                                        Rectangle bounds,
                                        boolean hasFocus)
绘制当前所选项的背景。

getDefaultSize

protected Dimension getDefaultSize()
返回使用当前渲染器和字体的组合框的空显示区域的默认大小。

返回：
空显示区域的大小
另请参见：
getDisplaySize()

getDisplaySize

protected Dimension getDisplaySize()
返回显示区域的计算大小。显示区域是组合框的一部分，用于显示所选项。如果已经将显示区域设置为原型显示值，则此方法将使用原型显示值。

对于项数不多的组合框，建议使用原型显示值，使用原型显示值可以大大加速显示大小的计算。

返回：
根据组合框项计算出的显示区域的大小
另请参见：
JComboBox.setPrototypeDisplayValue(java.lang.Object)

installKeyboardActions

protected void installKeyboardActions()
将键盘动作添加到 JComboBox。Enter 键和 Esc 键上的动作已提供。根据需要添加更多动作。

uninstallKeyboardActions

protected void uninstallKeyboardActions()
移除焦点 InputMap 和 ActionMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxUI.ComboBoxLayoutManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxUI.ComboBoxLayoutManager

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
所有已实现的接口：
LayoutManager
直接已知子类：
MetalComboBoxUI.MetalComboBoxLayoutManager
正在封闭类：
BasicComboBoxUI
public class BasicComboBoxUI.ComboBoxLayoutManager
extends Object
implements LayoutManager

此布局管理器处理组合框的“标准”布局。它将箭头按钮放在右边，将编辑器放在左边。即使不存在编辑器，它仍然将箭头按钮放在右边。 此公开内部类应该视为受保护内部类。仅在 BasicComboBoxUI 的子类中实例化此类。

构造方法摘要
BasicComboBoxUI.ComboBoxLayoutManager()
方法摘要
void | addLayoutComponent(String name, Component comp) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
void | layoutContainer(Container parent) 布置指定容器。
Dimension | minimumLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的最小大小维数。
Dimension | preferredLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | removeLayoutComponent(Component comp) 从布局移除指定组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboBoxUI.ComboBoxLayoutManager

public BasicComboBoxUI.ComboBoxLayoutManager()
方法详细信息

addLayoutComponent

public void addLayoutComponent(String name,
                               Component comp)
从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
comp - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从接口 LayoutManager 复制的描述
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的首选大小维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的最小大小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 要布置的组件

layoutContainer

public void layoutContainer(Container parent)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要布置的容器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxUI.FocusHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxUI.FocusHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
BasicComboBoxUI
public class BasicComboBoxUI.FocusHandler
extends Object
implements FocusListener

失去焦点时，此侦听器将隐藏弹出部分。获得或失去焦点时，它还将重绘。 此公开内部类应该视为受保护内部类。仅在 BasicComboBoxUI 的子类中实例化此类。

构造方法摘要
BasicComboBoxUI.FocusHandler()
方法摘要
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboBoxUI.FocusHandler

public BasicComboBoxUI.FocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent e)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxUI.ItemHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxUI.ItemHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
所有已实现的接口：
ItemListener, EventListener
正在封闭类：
BasicComboBoxUI
public class BasicComboBoxUI.ItemHandler
extends Object
implements ItemListener

此侦听器观察组合框中选择的更改。

此公开内部类应该视为受保护内部类。仅在 BasicComboBoxUI 的子类中实例化此类。

另请参见：
BasicComboBoxUI.createItemListener()

构造方法摘要
BasicComboBoxUI.ItemHandler()
方法摘要
 void itemStateChanged(ItemEvent e)
在用户已选定或取消选定某项时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboBoxUI.ItemHandler

public BasicComboBoxUI.ItemHandler()
方法详细信息

itemStateChanged

public void itemStateChanged(ItemEvent e)
从接口 ItemListener 复制的描述
在用户已选定或取消选定某项时调用。为此方法编写的代码将执行需要在已选定（或已取消选定）项时发生的操作。

指定者：
接口 ItemListener 中的 itemStateChanged
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxUI.KeyHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxUI.KeyHandler

java.lang.Object
    继承者  java.awt.event.KeyAdapter
        继承者  javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
所有已实现的接口：
KeyListener, EventListener
正在封闭类：
BasicComboBoxUI
public class BasicComboBoxUI.KeyHandler
extends KeyAdapter

此侦听器检查键事件是否不是导航键。如果它发现某个键事件不是导航键，则其将该键事件指派给 JComboBox.selectWithKeyChar()，让它执行提前输入操作。 此公开内部类应该视为受保护内部类。仅在 BasicComboBoxUI 的子类中实例化此类。

构造方法摘要
BasicComboBoxUI.KeyHandler()
方法摘要
 void keyPressed(KeyEvent e)
按下某个键时调用此方法。
从类 java.awt.event.KeyAdapter 继承的方法
keyReleased, keyTyped
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboBoxUI.KeyHandler

public BasicComboBoxUI.KeyHandler()
方法详细信息

keyPressed

public void keyPressed(KeyEvent e)
从类 KeyAdapter 复制的描述
按下某个键时调用此方法。

指定者：
接口 KeyListener 中的 keyPressed
覆盖：
类 KeyAdapter 中的 keyPressed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxUI.ListDataHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxUI.ListDataHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
所有已实现的接口：
EventListener, ListDataListener
正在封闭类：
BasicComboBoxUI
public class BasicComboBoxUI.ListDataHandler
extends Object
implements ListDataListener

此侦听器观察 ComboBoxModel 中的更改。

此公开内部类应该视为受保护内部类。仅在 BasicComboBoxUI 的子类中实例化此类。

另请参见：
BasicComboBoxUI.createListDataListener()

构造方法摘要
BasicComboBoxUI.ListDataHandler()
方法摘要
void | contentsChanged(ListDataEvent e) 在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。
void | intervalAdded(ListDataEvent e) 在已将 index0,index1 区间中的索引插入数据模型中之后发送。
void | intervalRemoved(ListDataEvent e) 在已将 index0,index1 区间中的索引从数据模型中移除后发送。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboBoxUI.ListDataHandler

public BasicComboBoxUI.ListDataHandler()
方法详细信息

contentsChanged

public void contentsChanged(ListDataEvent e)
从接口 ListDataListener 复制的描述
在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。例如，在已经替换某个项时发送此方法。Index0 和 index1 括出了该范围。

指定者：
接口 ListDataListener 中的 contentsChanged
参数：
e - 封装事件信息的 ListDataEvent

intervalAdded

public void intervalAdded(ListDataEvent e)
从接口 ListDataListener 复制的描述
在已将 index0,index1 区间中的索引插入数据模型中之后发送。新区间既包括 index0 也包括 index1。

指定者：
接口 ListDataListener 中的 intervalAdded
参数：
e - 封装事件信息的 ListDataEvent

intervalRemoved

public void intervalRemoved(ListDataEvent e)
从接口 ListDataListener 复制的描述
在已将 index0,index1 区间中的索引从数据模型中移除后发送。该区间既包括 index0 也包括 index1。

指定者：
接口 ListDataListener 中的 intervalRemoved
参数：
e - 封装事件信息的 ListDataEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboBoxUI.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboBoxUI.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
直接已知子类：
MetalComboBoxUI.MetalPropertyChangeListener
正在封闭类：
BasicComboBoxUI
public class BasicComboBoxUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

此侦听器观察在组合框中发生更改的绑定 (bound) 属性。

希望侦听组合框属性更改的子类应该调用超类方法来确保组合框 UI 正确处理属性更改。

此公开内部类应该视为受保护内部类。仅在 BasicComboBoxUI 的子类中实例化此类。

另请参见：
BasicComboBoxUI.createPropertyChangeListener()

构造方法摘要
BasicComboBoxUI.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboBoxUI.PropertyChangeHandler

public BasicComboBoxUI.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPopupMenu
                    继承者  javax.swing.plaf.basic.BasicComboPopup
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, MenuElement, ComboPopup
直接已知子类：
MetalComboBoxUI.MetalComboPopup
public class BasicComboPopup
extends JPopupMenu
implements ComboPopup

此为 ComboPopup 接口的基本实现。 此类表示组合框的弹出部分的 UI。

所有事件处理都是由利用 createxxxListener() 方法和内部类创建的侦听器类处理的。通过重写 createxxxListener() 方法，并提供自己的事件侦听器或者从此类提供的事件侦听器创建子类，可以更改此类的行为。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
class | BasicComboPopup.InvocationKeyHandler 从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.InvocationMouseMotionHandler 此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
protected class | BasicComboPopup.ItemHandler 此侦听器观察组合框中选择的更改。
class | BasicComboPopup.ListDataHandler 从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
protected class | BasicComboPopup.ListMouseMotionHandler 在列表上移动鼠标时，此侦听器更改所选项。
protected class | BasicComboPopup.ListSelectionHandler 从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
protected class | BasicComboPopup.PropertyChangeHandler 此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。
从类 javax.swing.JPopupMenu 继承的嵌套类/接口
JPopupMenu.AccessibleJPopupMenu, JPopupMenu.Separator
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected Timer | autoscrollTimer 此受保护字段是特定于实现的。
protected JComboBox | comboBox
protected boolean | hasEntered
protected boolean | isAutoScrolling
protected ItemListener | itemListener 此受保护字段是特定于实现的。
protected KeyListener | keyListener 此受保护字段是特定于实现的。
protected JList | list 此受保护字段是特定于实现的。
protected ListDataListener | listDataListener 此受保护字段是特定于实现的。
protected MouseListener | listMouseListener 此受保护字段是特定于实现的。
protected MouseMotionListener | listMouseMotionListener 此受保护字段是特定于实现的。
protected ListSelectionListener | listSelectionListener 此受保护字段是特定于实现的。
protected MouseListener | mouseListener 此受保护字段是特定于实现的。
protected MouseMotionListener | mouseMotionListener 此受保护字段是特定于实现的。
protected PropertyChangeListener | propertyChangeListener 此受保护字段是特定于实现的。
protected static int | SCROLL_DOWN
protected static int | SCROLL_UP
protected int | scrollDirection
protected JScrollPane | scroller 此受保护字段是特定于实现的。
protected boolean | valueIsAdjusting 从 Java 2 平台 v1.4 开始，不再使用这种以前没有记录的字段。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
BasicComboPopup(JComboBox combo)
方法摘要
protected  void autoScrollDown()
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
protected  void autoScrollUp()
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
protected  Rectangle computePopupBounds(int px, int py, int pw, int ph)
基于组合框的位置和封闭的屏幕界限计算组合框的弹出部分的位置和大小。
protected  void configureList()
配置用于保存弹出部分中的组合框项的列表。
protected  void configurePopup()
配置组合框的弹出部分。
protected  void configureScroller()
配置在组合框弹出控件中保存列表的可滚动部分。
protected  MouseEvent convertMouseEvent(MouseEvent e)
protected  ItemListener createItemListener()
创建将添加到组合框的 ItemListener。
protected  KeyListener createKeyListener()
创建将添加到组合框的键侦听器。
protected  JList createList()
创建在显示组合框模型项的弹出控件中使用的 JList。
protected  ListDataListener createListDataListener()
创建将添加到 ComboBoxModel 的列表数据侦听器。
protected  MouseListener createListMouseListener()
创建观察弹出列表中的鼠标事件的鼠标侦听器。
protected  MouseMotionListener createListMouseMotionListener()
创建观察弹出列表中的鼠标移动事件的鼠标移动侦听器。
protected  ListSelectionListener createListSelectionListener()
创建观察弹出列表中的选择更改的列表选择侦听器。
protected  MouseListener createMouseListener()
创建将观察组合框上的鼠标按下和释放事件的侦听器。
protected  MouseMotionListener createMouseMotionListener()
创建将添加到组合框的鼠标移动侦听器。
protected  PropertyChangeListener createPropertyChangeListener()
创建将添加到组合框的 PropertyChangeListener。
protected  JScrollPane createScroller()
创建容纳可滚动列表的滚动窗格。
protected  void delegateFocus(MouseEvent e)
此为一种实用程序方法，用于帮助事件处理程序计算出在调出弹出控件时将焦点发送到的位置。
protected  void firePopupMenuCanceled()
通知 PopupMenuListener 此弹出菜单将被取消。
protected  void firePopupMenuWillBecomeInvisible()
通知 PopupMenuListener 此弹出菜单将变得不可见。
protected  void firePopupMenuWillBecomeVisible()
通知 PopupMenuListener 此弹出菜单将变得可见。
 AccessibleContext getAccessibleContext()
获取与此 BasicComboPopup 关联的 AccessibleContext。
 KeyListener getKeyListener()
ComboPopup.getKeyListener() 的实现。
 JList getList()
ComboPopup.getList() 的实现。
 MouseListener getMouseListener()
ComboPopup.getMouseListener() 的实现。
 MouseMotionListener getMouseMotionListener()
ComboPopup.getMouseMotionListener() 的实现。
protected  int getPopupHeightForRowCount(int maxRowCount)
基于当前 ListCellRenderer 和最大行数检索弹出部分的高度。
 void hide()
ComboPopup.hide() 的实现。
protected  void installComboBoxListeners()
此方法在 JComboBox 中添加必需的侦听器。
protected  void installComboBoxModelListeners(ComboBoxModel model)
在组合框模型中安装侦听器。
protected  void installKeyboardActions()
protected  void installListListeners()
将侦听器添加到列表控件。
 boolean isFocusTraversable()
重写以无条件返回 false。
 void show()
ComboPopup.show() 的实现。
protected  void startAutoScrolling(int direction)
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
protected  void stopAutoScrolling()
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
protected  void togglePopup()
如果弹出部分是隐藏的，则使其可见；如果它是可见的，则将其隐藏。
protected  void uninstallComboBoxModelListeners(ComboBoxModel model)
从组合框模型中移除侦听器
 void uninstallingUI()
卸载 UI 时调用。
protected  void uninstallKeyboardActions()
protected  void updateListBoxSelectionForEvent(MouseEvent anEvent, boolean shouldScroll)
供事件侦听器使用的实用程序方法。
从类 javax.swing.JPopupMenu 继承的方法
add, add, add, addMenuKeyListener, addPopupMenuListener, addSeparator, createActionChangeListener, createActionComponent, getComponent, getComponentAtIndex, getComponentIndex, getDefaultLightWeightPopupEnabled, getInvoker, getLabel, getMargin, getMenuKeyListeners, getPopupMenuListeners, getSelectionModel, getSubElements, getUI, getUIClassID, insert, insert, isBorderPainted, isLightWeightPopupEnabled, isPopupTrigger, isVisible, menuSelectionChanged, pack, paintBorder, paramString, processFocusEvent, processKeyEvent, processKeyEvent, processMouseEvent, remove, removeMenuKeyListener, removePopupMenuListener, setBorderPainted, setDefaultLightWeightPopupEnabled, setInvoker, setLabel, setLightWeightPopupEnabled, setLocation, setPopupSize, setPopupSize, setSelected, setSelectionModel, setUI, setVisible, show, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setName, setSize, setSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 javax.swing.plaf.basic.ComboPopup 继承的方法
isVisible

字段详细信息

comboBox

protected JComboBox comboBox

list

protected JList list
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用访问器方法。

另请参见：
getList(), createList()

scroller

protected JScrollPane scroller
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createScroller()

valueIsAdjusting

protected boolean valueIsAdjusting
从 Java 2 平台 v1.4 开始，不再使用这种以前没有记录的字段。

mouseMotionListener

protected MouseMotionListener mouseMotionListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用访问器或创建方法。

另请参见：
getMouseMotionListener(), createMouseMotionListener()

mouseListener

protected MouseListener mouseListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用访问器或创建方法。

另请参见：
getMouseListener(), createMouseListener()

keyListener

protected KeyListener keyListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用访问器或创建方法。

另请参见：
getKeyListener(), createKeyListener()

listSelectionListener

protected ListSelectionListener listSelectionListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createListSelectionListener()

listMouseListener

protected MouseListener listMouseListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createListMouseListener()

listMouseMotionListener

protected MouseMotionListener listMouseMotionListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createListMouseMotionListener()

propertyChangeListener

protected PropertyChangeListener propertyChangeListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createPropertyChangeListener()

listDataListener

protected ListDataListener listDataListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createListDataListener()

itemListener

protected ItemListener itemListener
此受保护字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createItemListener()

autoscrollTimer

protected Timer autoscrollTimer
此受保护字段是特定于实现的。不要直接访问或重写。

hasEntered

protected boolean hasEntered

isAutoScrolling

protected boolean isAutoScrolling

scrollDirection

protected int scrollDirection

SCROLL_UP

protected static final int SCROLL_UP
另请参见：
常量字段值

SCROLL_DOWN

protected static final int SCROLL_DOWN
另请参见：
常量字段值
构造方法详细信息

BasicComboPopup

public BasicComboPopup(JComboBox combo)
方法详细信息

show

public void show()
ComboPopup.show() 的实现。

指定者：
接口 ComboPopup 中的 show
覆盖：
类 Component 中的 show

hide

public void hide()
ComboPopup.hide() 的实现。

指定者：
接口 ComboPopup 中的 hide
覆盖：
类 Component 中的 hide

getList

public JList getList()
ComboPopup.getList() 的实现。

指定者：
接口 ComboPopup 中的 getList

getMouseListener

public MouseListener getMouseListener()
ComboPopup.getMouseListener() 的实现。

指定者：
接口 ComboPopup 中的 getMouseListener
返回：
MouseListener 或 null
另请参见：
ComboPopup.getMouseListener()

getMouseMotionListener

public MouseMotionListener getMouseMotionListener()
ComboPopup.getMouseMotionListener() 的实现。

指定者：
接口 ComboPopup 中的 getMouseMotionListener
返回：
MouseMotionListener 或 null
另请参见：
ComboPopup.getMouseMotionListener()

getKeyListener

public KeyListener getKeyListener()
ComboPopup.getKeyListener() 的实现。

指定者：
接口 ComboPopup 中的 getKeyListener
返回：
KeyListener 或 null
另请参见：
ComboPopup.getKeyListener()

uninstallingUI

public void uninstallingUI()
卸载 UI 时调用。由于此弹出部分不在组件树中，因此其 uninstallUI() 不会被调用。它移除已添加在 addComboBoxListeners() 中的侦听器。

指定者：
接口 ComboPopup 中的 uninstallingUI

uninstallComboBoxModelListeners

protected void uninstallComboBoxModelListeners(ComboBoxModel model)
从组合框模型中移除侦听器

参数：
model - 要安装侦听器的组合框
另请参见：
installComboBoxModelListeners(javax.swing.ComboBoxModel)

uninstallKeyboardActions

protected void uninstallKeyboardActions()

firePopupMenuWillBecomeVisible

protected void firePopupMenuWillBecomeVisible()
从类 JPopupMenu 复制的描述
通知 PopupMenuListener 此弹出菜单将变得可见。

覆盖：
类 JPopupMenu 中的 firePopupMenuWillBecomeVisible

firePopupMenuWillBecomeInvisible

protected void firePopupMenuWillBecomeInvisible()
从类 JPopupMenu 复制的描述
通知 PopupMenuListener 此弹出菜单将变得不可见。

覆盖：
类 JPopupMenu 中的 firePopupMenuWillBecomeInvisible

firePopupMenuCanceled

protected void firePopupMenuCanceled()
从类 JPopupMenu 复制的描述
通知 PopupMenuListener 此弹出菜单将被取消。

覆盖：
类 JPopupMenu 中的 firePopupMenuCanceled

createMouseListener

protected MouseListener createMouseListener()
创建将观察组合框上的鼠标按下和释放事件的侦听器。 警告：重写此方法时，确保维护现有行为。

返回：
将添加到组合框的 MouseListener，或者返回 null

createMouseMotionListener

protected MouseMotionListener createMouseMotionListener()
创建将添加到组合框的鼠标移动侦听器。 警告：重写此方法时，确保维护现有行为。

返回：
将添加到组合框的 MouseMotionListener，或者返回 null

createKeyListener

protected KeyListener createKeyListener()
创建将添加到组合框的键侦听器。如果此方法返回 null，则不会将其添加到组合框。

返回：
KeyListener 的实例或 null

createListSelectionListener

protected ListSelectionListener createListSelectionListener()
创建观察弹出列表中的选择更改的列表选择侦听器。如果此方法返回 null，则不会将其添加到弹出列表。

返回：
ListSelectionListener 的实例或 null

createListDataListener

protected ListDataListener createListDataListener()
创建将添加到 ComboBoxModel 的列表数据侦听器。如果此方法返回 null，则不会将其添加到组合框模型。

返回：
ListDataListener 的实例或 null

createListMouseListener

protected MouseListener createListMouseListener()
创建观察弹出列表中的鼠标事件的鼠标侦听器。如果此方法返回 null，则不会将其添加到组合框。

返回：
MouseListener 的实例或 null

createListMouseMotionListener

protected MouseMotionListener createListMouseMotionListener()
创建观察弹出列表中的鼠标移动事件的鼠标移动侦听器。如果此方法返回 null，则不会将其添加到组合框。

返回：
MouseMotionListener 的实例或 null

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
创建将添加到组合框的 PropertyChangeListener。如果此方法返回 null，则不会将其添加到组合框。

返回：
PropertyChangeListener 的实例或 null

createItemListener

protected ItemListener createItemListener()
创建将添加到组合框的 ItemListener。如果此方法返回 null，则不会将其添加到组合框。

子类可以重写此方法以返回其 ItemEvent 处理程序的实例。

返回：
ItemListener 的实例或 null

createList

protected JList createList()
创建在显示组合框模型项的弹出控件中使用的 JList。创建 UI 类时调用此方法。

返回：
用于显示组合框项的 JList

configureList

protected void configureList()
配置用于保存弹出部分中的组合框项的列表。创建 UI 类时调用此方法。

另请参见：
createList()

installListListeners

protected void installListListeners()
将侦听器添加到列表控件。

createScroller

protected JScrollPane createScroller()
创建容纳可滚动列表的滚动窗格。

configureScroller

protected void configureScroller()
配置在组合框弹出控件中保存列表的可滚动部分。创建 UI 类时调用此方法。

configurePopup

protected void configurePopup()
配置组合框的弹出部分。创建 UI 类时调用此方法。

installComboBoxListeners

protected void installComboBoxListeners()
此方法在 JComboBox 中添加必需的侦听器。

installComboBoxModelListeners

protected void installComboBoxModelListeners(ComboBoxModel model)
在组合框模型中安装侦听器。应该用 uninstallComboBoxModelListeners 移除添加到组合框模型上的所有侦听器。

参数：
model - 要安装侦听器的组合框模型
另请参见：
uninstallComboBoxModelListeners(javax.swing.ComboBoxModel)

installKeyboardActions

protected void installKeyboardActions()

isFocusTraversable

public boolean isFocusTraversable()
重写以无条件返回 false。

覆盖：
类 Component 中的 isFocusTraversable
返回：
如果此 Component 是可以获得焦点的，则返回 true；否则返回 false
另请参见：
Component.setFocusable(boolean)

startAutoScrolling

protected void startAutoScrolling(int direction)
此受保护方法是特定于实现的，应该为私有，不要调用或重写。

stopAutoScrolling

protected void stopAutoScrolling()
此受保护方法是特定于实现的，应该为私有，不要调用或重写。

autoScrollUp

protected void autoScrollUp()
此受保护方法是特定于实现的，应该为私有，不要调用或重写。

autoScrollDown

protected void autoScrollDown()
此受保护方法是特定于实现的，应该为私有，不要调用或重写。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 BasicComboPopup 关联的 AccessibleContext。将 AccessibleContext 的父级设置为 ComboBox。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JPopupMenu 中的 getAccessibleContext
返回：
用于 BasicComboPopup 的 AccessibleContext
从以下版本开始：
1.5

delegateFocus

protected void delegateFocus(MouseEvent e)
此为一种实用程序方法，用于帮助事件处理程序计算出在调出弹出控件时将焦点发送到的位置。标准实现将焦点委托给编辑器（如果组合框可编辑）或者 JComboBox（如果组合框不可编辑）。

togglePopup

protected void togglePopup()
如果弹出部分是隐藏的，则使其可见；如果它是可见的，则将其隐藏。

convertMouseEvent

protected MouseEvent convertMouseEvent(MouseEvent e)

getPopupHeightForRowCount

protected int getPopupHeightForRowCount(int maxRowCount)
基于当前 ListCellRenderer 和最大行数检索弹出部分的高度。

computePopupBounds

protected Rectangle computePopupBounds(int px,
                                       int py,
                                       int pw,
                                       int ph)
基于组合框的位置和封闭的屏幕界限计算组合框的弹出部分的位置和大小。如果不需要进行转换，则返回的矩形将具有相同的参数值。

参数：
px - 初始 x 位置
py - 初始 y 位置
pw - 初始宽度
ph - 初始高度
返回：
表示弹出部分的位置和大小的矩形

updateListBoxSelectionForEvent

protected void updateListBoxSelectionForEvent(MouseEvent anEvent,
                                              boolean shouldScroll)
供事件侦听器使用的实用程序方法。如果给定鼠标事件，则其将列表选择更改为鼠标指针所在的列表项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.InvocationKeyHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.InvocationKeyHandler

java.lang.Object
    继承者  java.awt.event.KeyAdapter
        继承者  javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
所有已实现的接口：
KeyListener, EventListener
正在封闭类：
BasicComboPopup
public class BasicComboPopup.InvocationKeyHandler
extends KeyAdapter

从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。不要实例化或子类化此类。

此类的所有功能都已包括在 BasicComboBoxUI ActionMap/InputMap 方法中。

构造方法摘要
BasicComboPopup.InvocationKeyHandler()
方法摘要
 void keyReleased(KeyEvent e)
释放某个键时调用此方法。
从类 java.awt.event.KeyAdapter 继承的方法
keyPressed, keyTyped
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.InvocationKeyHandler

public BasicComboPopup.InvocationKeyHandler()
方法详细信息

keyReleased

public void keyReleased(KeyEvent e)
从类 KeyAdapter 复制的描述
释放某个键时调用此方法。

指定者：
接口 KeyListener 中的 keyReleased
覆盖：
类 KeyAdapter 中的 keyReleased
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.InvocationMouseHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.InvocationMouseHandler

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
BasicComboPopup
protected class BasicComboPopup.InvocationMouseHandler
extends MouseAdapter

要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。此侦听器的主要用途在于显示和隐藏弹出菜单。此侦听器也用于单击并拖动（click-and-drag）场景：如果拖动过程中在列表上释放鼠标，此侦听器将设置选择。

警告：建议不要 创建此类的子类。如果一定要创建子类，则确保调用每个方法的超类方法。

另请参见：
BasicComboPopup.createMouseListener()

构造方法摘要
protected BasicComboPopup.InvocationMouseHandler()
方法摘要
void | mousePressed(MouseEvent e) 响应组合框上的鼠标按下事件。
void | mouseReleased(MouseEvent e) 响应用户终止从组合框开始的单击或拖动操作。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.InvocationMouseHandler

protected BasicComboPopup.InvocationMouseHandler()
方法详细信息

mousePressed

public void mousePressed(MouseEvent e)
响应组合框上的鼠标按下事件。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed
参数：
e - 要处理的鼠标按下事件

mouseReleased

public void mouseReleased(MouseEvent e)
响应用户终止从组合框开始的单击或拖动操作。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased
参数：
e - 要处理的鼠标释放事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.InvocationMouseMotionHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.InvocationMouseMotionHandler

java.lang.Object
    继承者  java.awt.event.MouseMotionAdapter
        继承者  javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
所有已实现的接口：
MouseMotionListener, EventListener
正在封闭类：
BasicComboPopup
protected class BasicComboPopup.InvocationMouseMotionHandler
extends MouseMotionAdapter

此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。

构造方法摘要
protected BasicComboPopup.InvocationMouseMotionHandler()
方法摘要
 void mouseDragged(MouseEvent e)
鼠标按键在组件上按下并拖动时调用。
从类 java.awt.event.MouseMotionAdapter 继承的方法
mouseMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.InvocationMouseMotionHandler

protected BasicComboPopup.InvocationMouseMotionHandler()
方法详细信息

mouseDragged

public void mouseDragged(MouseEvent e)
从类 MouseMotionAdapter 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，鼠标拖动事件被连续地传递到首先发起该事件的组件（而不管鼠标位置是否处于该组件的边界内）。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseMotionAdapter 中的 mouseDragged
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.ItemHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.ItemHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboPopup.ItemHandler
所有已实现的接口：
ItemListener, EventListener
正在封闭类：
BasicComboPopup
protected class BasicComboPopup.ItemHandler
extends Object
implements ItemListener

此侦听器观察组合框中选择的更改。

构造方法摘要
protected BasicComboPopup.ItemHandler()
方法摘要
 void itemStateChanged(ItemEvent e)
在用户已选定或取消选定某项时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.ItemHandler

protected BasicComboPopup.ItemHandler()
方法详细信息

itemStateChanged

public void itemStateChanged(ItemEvent e)
从接口 ItemListener 复制的描述
在用户已选定或取消选定某项时调用。为此方法编写的代码将执行需要在已选定（或已取消选定）项时发生的操作。

指定者：
接口 ItemListener 中的 itemStateChanged
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.ListDataHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.ListDataHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
所有已实现的接口：
EventListener, ListDataListener
正在封闭类：
BasicComboPopup
public class BasicComboPopup.ListDataHandler
extends Object
implements ListDataListener

从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。不要调用或重写。

其功能已移植到 ItemHandler 中。

另请参见：
BasicComboPopup.createItemListener()

构造方法摘要
BasicComboPopup.ListDataHandler()
方法摘要
void | contentsChanged(ListDataEvent e) 在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。
void | intervalAdded(ListDataEvent e) 在已将 index0,index1 区间中的索引插入数据模型中之后发送。
void | intervalRemoved(ListDataEvent e) 在已将 index0,index1 区间中的索引从数据模型中移除后发送。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.ListDataHandler

public BasicComboPopup.ListDataHandler()
方法详细信息

contentsChanged

public void contentsChanged(ListDataEvent e)
从接口 ListDataListener 复制的描述
在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。例如，在已经替换某个项时发送此方法。Index0 和 index1 括出了该范围。

指定者：
接口 ListDataListener 中的 contentsChanged
参数：
e - 封装事件信息的 ListDataEvent

intervalAdded

public void intervalAdded(ListDataEvent e)
从接口 ListDataListener 复制的描述
在已将 index0,index1 区间中的索引插入数据模型中之后发送。新区间既包括 index0 也包括 index1。

指定者：
接口 ListDataListener 中的 intervalAdded
参数：
e - 封装事件信息的 ListDataEvent

intervalRemoved

public void intervalRemoved(ListDataEvent e)
从接口 ListDataListener 复制的描述
在已将 index0,index1 区间中的索引从数据模型中移除后发送。该区间既包括 index0 也包括 index1。

指定者：
接口 ListDataListener 中的 intervalRemoved
参数：
e - 封装事件信息的 ListDataEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.ListMouseHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.ListMouseHandler

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
BasicComboPopup
protected class BasicComboPopup.ListMouseHandler
extends MouseAdapter

在列表中释放鼠标时，此侦听器隐藏弹出部分。

构造方法摘要
protected BasicComboPopup.ListMouseHandler()
方法摘要
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent anEvent) 鼠标按钮在组件上释放时调用。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.ListMouseHandler

protected BasicComboPopup.ListMouseHandler()
方法详细信息

mousePressed

public void mousePressed(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent anEvent)
从类 MouseAdapter 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDesktopIconUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDesktopIconUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.DesktopIconUI
            继承者  javax.swing.plaf.basic.BasicDesktopIconUI
直接已知子类：
MetalDesktopIconUI
public class BasicDesktopIconUI
extends DesktopIconUI

用于桌面最小化窗口的 L&F。

嵌套类摘要
 class BasicDesktopIconUI.MouseInputHandler
侦听鼠标移动及对其操作。
字段摘要
protected JInternalFrame.JDesktopIcon | desktopIcon
protected JInternalFrame | frame
protected JComponent | iconPane 在桌面图标中使用的标题窗格组件。
构造方法摘要
BasicDesktopIconUI()
方法摘要
protected MouseInputListener | createMouseInputListener()
static ComponentUI | createUI(JComponent c)
void | deiconize()
Insets | getInsets(JComponent c)
Dimension | getMaximumSize(JComponent c) 不能调整桌面图标的大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected void | installComponents()
protected void | installDefaults()
protected void | installListeners()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected void | uninstallComponents()
protected void | uninstallDefaults()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

desktopIcon

protected JInternalFrame.JDesktopIcon desktopIcon

frame

protected JInternalFrame frame

iconPane

protected JComponent iconPane
在桌面图标中使用的标题窗格组件。

从以下版本开始：
1.5
构造方法详细信息

BasicDesktopIconUI

public BasicDesktopIconUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installComponents

protected void installComponents()

uninstallComponents

protected void uninstallComponents()

installListeners

protected void installListeners()

uninstallListeners

protected void uninstallListeners()

installDefaults

protected void installDefaults()

uninstallDefaults

protected void uninstallDefaults()

createMouseInputListener

protected MouseInputListener createMouseInputListener()

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
不能调整桌面图标的大小。因此，应该始终返回桌面图标的最小大小。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
getMinimumSize(javax.swing.JComponent)

getInsets

public Insets getInsets(JComponent c)

deiconize

public void deiconize()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.ListMouseMotionHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.ListMouseMotionHandler

java.lang.Object
    继承者  java.awt.event.MouseMotionAdapter
        继承者  javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
所有已实现的接口：
MouseMotionListener, EventListener
正在封闭类：
BasicComboPopup
protected class BasicComboPopup.ListMouseMotionHandler
extends MouseMotionAdapter

在列表上移动鼠标时，此侦听器更改所选项。选择更改不会提交到模型，只用于用户反馈。

构造方法摘要
protected BasicComboPopup.ListMouseMotionHandler()
方法摘要
 void mouseMoved(MouseEvent anEvent)
鼠标按键在组件上移动（无按键按下）时调用。
从类 java.awt.event.MouseMotionAdapter 继承的方法
mouseDragged
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.ListMouseMotionHandler

protected BasicComboPopup.ListMouseMotionHandler()
方法详细信息

mouseMoved

public void mouseMoved(MouseEvent anEvent)
从类 MouseMotionAdapter 复制的描述
鼠标按键在组件上移动（无按键按下）时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseMotionAdapter 中的 mouseMoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.ListSelectionHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.ListSelectionHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler
所有已实现的接口：
EventListener, ListSelectionListener
正在封闭类：
BasicComboPopup
protected class BasicComboPopup.ListSelectionHandler
extends Object
implements ListSelectionListener

从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。不要调用或重写。

构造方法摘要
protected BasicComboPopup.ListSelectionHandler()
方法摘要
 void valueChanged(ListSelectionEvent e)
每当选择值发生更改时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.ListSelectionHandler

protected BasicComboPopup.ListSelectionHandler()
方法详细信息

valueChanged

public void valueChanged(ListSelectionEvent e)
从接口 ListSelectionListener 复制的描述
每当选择值发生更改时调用。

指定者：
接口 ListSelectionListener 中的 valueChanged
参数：
e - 表现更改的特征的事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicComboPopup.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicComboPopup.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicComboPopup
protected class BasicComboPopup.PropertyChangeHandler
extends Object
implements PropertyChangeListener

此侦听器观察已在组合框中更改的绑定 (bound) 属性

希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。

另请参见：
BasicComboPopup.createPropertyChangeListener()

构造方法摘要
protected BasicComboPopup.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicComboPopup.PropertyChangeHandler

protected BasicComboPopup.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDesktopIconUI.MouseInputHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDesktopIconUI.MouseInputHandler

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.event.MouseInputAdapter
            继承者  javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener, MouseInputListener
正在封闭类：
BasicDesktopIconUI
public class BasicDesktopIconUI.MouseInputHandler
extends MouseInputAdapter

侦听鼠标移动及对其操作。 因编译器故障而将此内部类标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicDesktopIconUI 的子类中实例化此类。

构造方法摘要
BasicDesktopIconUI.MouseInputHandler()
方法摘要
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
void | moveAndRepaint(JComponent f, int newX, int newY, int newWidth, int newHeight)
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseEntered, mouseExited, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.event.MouseListener 继承的方法
mouseClicked, mouseEntered, mouseExited

构造方法详细信息

BasicDesktopIconUI.MouseInputHandler

public BasicDesktopIconUI.MouseInputHandler()
方法详细信息

mouseReleased

public void mouseReleased(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased

mousePressed

public void mousePressed(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed

mouseMoved

public void mouseMoved(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseAdapter 中的 mouseMoved

mouseDragged

public void mouseDragged(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseAdapter 中的 mouseDragged

moveAndRepaint

public void moveAndRepaint(JComponent f,
                           int newX,
                           int newY,
                           int newWidth,
                           int newHeight)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDesktopPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDesktopPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.DesktopPaneUI
            继承者  javax.swing.plaf.basic.BasicDesktopPaneUI

public class BasicDesktopPaneUI
extends DesktopPaneUI

桌面的基本 L&F。

嵌套类摘要
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
字段摘要
protected KeyStroke | closeKey 已过时。 从 1.3 开始。
protected JDesktopPane | desktop
protected DesktopManager | desktopManager
protected KeyStroke | maximizeKey 已过时。 从 1.3 开始。
protected KeyStroke | minimizeKey 已过时。 从 1.3 开始。
protected KeyStroke | navigateKey 已过时。 从 1.3 开始。
protected KeyStroke | navigateKey2 已过时。 从 1.3 开始。
构造方法摘要
BasicDesktopPaneUI()
方法摘要
protected PropertyChangeListener | createPropertyChangeListener() 返回要安装到 JDesktopPane 上的 PropertyChangeListener。
static ComponentUI | createUI(JComponent c)
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected void | installDefaults()
protected void | installDesktopManager()
protected void | installKeyboardActions()
protected void | installListeners() 将从 createPropertyChangeListener 返回的 PropertyChangeListener 安装到 JDesktopPane 上。
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | registerKeyboardActions()
protected void | uninstallDefaults()
protected void | uninstallDesktopManager()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners() 从 JDesktopPane 卸载从 createPropertyChangeListener 返回的 PropertyChangeListener。
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
protected void | unregisterKeyboardActions()
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

desktop

protected JDesktopPane desktop

desktopManager

protected DesktopManager desktopManager

minimizeKey

@Deprecated
protected KeyStroke minimizeKey
已过时。 从 1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

maximizeKey

@Deprecated
protected KeyStroke maximizeKey
已过时。 从 1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

closeKey

@Deprecated
protected KeyStroke closeKey
已过时。 从 1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

navigateKey

@Deprecated
protected KeyStroke navigateKey
已过时。 从 1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

navigateKey2

@Deprecated
protected KeyStroke navigateKey2
已过时。 从 1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

构造方法详细信息

BasicDesktopPaneUI

public BasicDesktopPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults()

uninstallDefaults

protected void uninstallDefaults()

installListeners

protected void installListeners()
将从 createPropertyChangeListener 返回的 PropertyChangeListener 安装到 JDesktopPane 上。

从以下版本开始：
1.5
另请参见：
createPropertyChangeListener()

uninstallListeners

protected void uninstallListeners()
从 JDesktopPane 卸载从 createPropertyChangeListener 返回的 PropertyChangeListener。

从以下版本开始：
1.5
另请参见：
createPropertyChangeListener()

installDesktopManager

protected void installDesktopManager()

uninstallDesktopManager

protected void uninstallDesktopManager()

installKeyboardActions

protected void installKeyboardActions()

registerKeyboardActions

protected void registerKeyboardActions()

unregisterKeyboardActions

protected void unregisterKeyboardActions()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
返回要安装到 JDesktopPane 上的 PropertyChangeListener。

返回：
将添加以跟踪桌面窗格中的更改的 PropertyChangeListener。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDesktopPaneUI.CloseAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDesktopPaneUI.CloseAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicDesktopPaneUI
protected class BasicDesktopPaneUI.CloseAction
extends AbstractAction

处理关闭一个内部窗体。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicDesktopPaneUI.CloseAction()
方法摘要
void | actionPerformed(ActionEvent evt) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicDesktopPaneUI.CloseAction

protected BasicDesktopPaneUI.CloseAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent evt)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDesktopPaneUI.MaximizeAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDesktopPaneUI.MaximizeAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicDesktopPaneUI
protected class BasicDesktopPaneUI.MaximizeAction
extends AbstractAction

处理最大化一个内部窗体。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicDesktopPaneUI.MaximizeAction()
方法摘要
void | actionPerformed(ActionEvent evt) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicDesktopPaneUI.MaximizeAction

protected BasicDesktopPaneUI.MaximizeAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent evt)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDesktopPaneUI.MinimizeAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDesktopPaneUI.MinimizeAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicDesktopPaneUI
protected class BasicDesktopPaneUI.MinimizeAction
extends AbstractAction

处理最小化一个内部窗体。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicDesktopPaneUI.MinimizeAction()
方法摘要
void | actionPerformed(ActionEvent evt) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicDesktopPaneUI.MinimizeAction

protected BasicDesktopPaneUI.MinimizeAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent evt)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDesktopPaneUI.NavigateAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDesktopPaneUI.NavigateAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicDesktopPaneUI
protected class BasicDesktopPaneUI.NavigateAction
extends AbstractAction

处理导航到下一个内部窗体。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicDesktopPaneUI.NavigateAction()
方法摘要
void | actionPerformed(ActionEvent evt) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicDesktopPaneUI.NavigateAction

protected BasicDesktopPaneUI.NavigateAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent evt)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDesktopPaneUI.OpenAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDesktopPaneUI.OpenAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicDesktopPaneUI
protected class BasicDesktopPaneUI.OpenAction
extends AbstractAction

处理恢复一个最小化或最大化的内部窗体。

从以下版本开始：
1.3

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicDesktopPaneUI.OpenAction()
方法摘要
void | actionPerformed(ActionEvent evt) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicDesktopPaneUI.OpenAction

protected BasicDesktopPaneUI.OpenAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent evt)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicDirectoryModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicDirectoryModel

java.lang.Object
    继承者  javax.swing.AbstractListModel
        继承者  javax.swing.plaf.basic.BasicDirectoryModel
所有已实现的接口：
PropertyChangeListener, Serializable, EventListener, ListModel
public class BasicDirectoryModel
extends AbstractListModel
implements PropertyChangeListener

文件列表的基本实现。

字段摘要
从类 javax.swing.AbstractListModel 继承的字段
listenerList
构造方法摘要
BasicDirectoryModel(JFileChooser filechooser)
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表。
boolean | contains(Object o)
void | fireContentsChanged()
protected void | firePropertyChange(String propertyName, Object oldValue, Object newValue) 支持报告 boolean 属性的绑定属性的改变。
Vector<File> | getDirectories()
Object | getElementAt(int index) 返回指定索引处的值。
Vector<File> | getFiles()
PropertyChangeListener[] | getPropertyChangeListeners() 返回一个在此组件上注册的所有属性更改侦听器的数组。
int | getSize() 返回列表的长度。
int | indexOf(Object o)
void | intervalAdded(ListDataEvent e) 废弃，不使用。
void | intervalRemoved(ListDataEvent e) 废弃，不使用。
void | invalidateFileCache() 此方法用于中断文件加载线程。
protected boolean | lt(File a, File b)
void | propertyChange(PropertyChangeEvent e) 在绑定属性发生更改时调用此方法。
void | removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
boolean | renameFile(File oldFile, File newFile) 重命名底层文件系统中的文件。
protected void | sort(Vector<? extends File> v)
void | validateFileCache()
从类 javax.swing.AbstractListModel 继承的方法
addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicDirectoryModel

public BasicDirectoryModel(JFileChooser filechooser)
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。

invalidateFileCache

public void invalidateFileCache()
此方法用于中断文件加载线程。

getDirectories

public Vector<File> getDirectories()

getFiles

public Vector<File> getFiles()

validateFileCache

public void validateFileCache()

renameFile

public boolean renameFile(File oldFile,
                          File newFile)
重命名底层文件系统中的文件。

参数：
oldFile - 表示现有文件的 File 对象
newFile - 表示所需新文件名的 File 对象
返回：
如果重命名成功，则返回 true；否则返回 false
从以下版本开始：
1.4

fireContentsChanged

public void fireContentsChanged()

getSize

public int getSize()
从接口 ListModel 复制的描述
返回列表的长度。

指定者：
接口 ListModel 中的 getSize
返回：
列表的长度

contains

public boolean contains(Object o)

indexOf

public int indexOf(Object o)

getElementAt

public Object getElementAt(int index)
从接口 ListModel 复制的描述
返回指定索引处的值。

指定者：
接口 ListModel 中的 getElementAt
参数：
index - 请求的索引
返回：
index 处的值

intervalAdded

public void intervalAdded(ListDataEvent e)
废弃，不使用。

intervalRemoved

public void intervalRemoved(ListDataEvent e)
废弃，不使用。

sort

protected void sort(Vector<? extends File> v)

lt

protected boolean lt(File a,
                     File b)

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到侦听器列表。该侦听器是为此类的所有绑定属性注册的。

如果 listener 为 null，则不抛出异常并且不执行任何动作。

参数：
listener - 要添加的属性更改侦听器
从以下版本开始：
1.6
另请参见：
removePropertyChangeListener(java.beans.PropertyChangeListener), getPropertyChangeListeners()

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。

如果 listener 为 null，则不抛出异常并且不执行任何动作。

参数：
listener - 要移除的 PropertyChangeListener
从以下版本开始：
1.6
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), getPropertyChangeListeners()

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回一个在此组件上注册的所有属性更改侦听器的数组。

返回：
所有此组件的 PropertyChangeListener；如果当前没有注册任何属性更改侦听器，则返回一个空数组
从以下版本开始：
1.6
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener),
removePropertyChangeListener(java.beans.PropertyChangeListener),
PropertyChangeSupport.getPropertyChangeListeners()

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
支持报告 boolean 属性的绑定属性的改变。当绑定属性更改并且它将向任意已注册 PropertyChangeListeners 发送适当的 PropertyChangeEvent 时，可以调用此方法。

参数：
propertyName - 其值已更改的属性
oldValue - 该属性的以前值
newValue - 该属性的新值
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicEditorPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicEditorPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
                继承者  javax.swing.plaf.basic.BasicEditorPaneUI
所有已实现的接口：
ViewFactory
直接已知子类：
BasicTextPaneUI
public class BasicEditorPaneUI
extends BasicTextUI

为 JEditorPane 提供外观。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的嵌套类/接口
BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter
构造方法摘要
BasicEditorPaneUI()
创建新的 BasicEditorPaneUI。
方法摘要
static ComponentUI | createUI(JComponent c) 创建 JTextPane 的 UI。
EditorKit | getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。
protected String | getPropertyPrefix() 获取用作键以通过 UIManager 查找属性的名称。
void | installUI(JComponent c) 安装组件的 UI。
protected void | propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，调用此方法。
void | uninstallUI(JComponent c) 卸载组件的 UI。
从类 javax.swing.plaf.basic.BasicTextUI 继承的方法
create, create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, update, viewToModel, viewToModel
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicEditorPaneUI

public BasicEditorPaneUI()
创建新的 BasicEditorPaneUI。

方法详细信息

createUI

public static ComponentUI createUI(JComponent c)
创建 JTextPane 的 UI。

参数：
c - JTextPane 组件
返回：
UI

getPropertyPrefix

protected String getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。它用作所有标准文本属性的前缀。

指定者：
类 BasicTextUI 中的 getPropertyPrefix
返回：
名称 ("EditorPane")

installUI

public void installUI(JComponent c)
安装组件的 UI。此方法执行以下操作。
  1. 将关联组件设置为不透明（可以由子类或直接在 JTextComponent 上方便地更改），这种情况是最常见的。此操作将导致绘制组件的背景色。
  2. 将默认的插入符和 highlighter 安装到关联组件中。
  3. 附加到编辑器和模型。如果不存在模型，则创建一个默认模型。
  4. 创建用于表示模型的视图工厂和视图层次结构。

覆盖：
类 BasicTextUI 中的 installUI
参数：
c - 编辑器组件
从以下版本开始：
1.5
另请参见：
ComponentUI.installUI(javax.swing.JComponent)

uninstallUI

public void uninstallUI(JComponent c)
卸载组件的 UI。此方法移除侦听器、卸载 highlighter、移除视图并将 keymap 全部设为 null。

覆盖：
类 BasicTextUI 中的 uninstallUI
参数：
c - 编辑器组件
从以下版本开始：
1.5
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent)

getEditorKit

public EditorKit getEditorKit(JTextComponent tc)
获取 UI 的 EditorKit。它是在关联的 JEditorPane 中的任何当前设置。

覆盖：
类 BasicTextUI 中的 getEditorKit
参数：
tc - 文本组件，为其安装此 UI
返回：
编辑器功能
另请参见：
TextUI.getEditorKit(javax.swing.text.JTextComponent)

propertyChange

protected void propertyChange(PropertyChangeEvent evt)
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，调用此方法。此为一个钩子 (hook)，UI 实现可以更改它来反映 UI 显示 JTextComponent 子类的绑定属性的方式。可以通过实现它来基于 EditorKit 更改重新构建 ActionMap。

覆盖：
类 BasicTextUI 中的 propertyChange
参数：
evt - 属性更改事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.FileChooserUI
            继承者  javax.swing.plaf.basic.BasicFileChooserUI
直接已知子类：
MetalFileChooserUI
public class BasicFileChooserUI
extends FileChooserUI

FileChooser 的基本 L&F 实现。

嵌套类摘要
protected class | BasicFileChooserUI.AcceptAllFileFilter
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.BasicFileView
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.SelectionListener
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
字段摘要
protected int | cancelButtonMnemonic
protected String | cancelButtonText
protected String | cancelButtonToolTipText
protected Icon | computerIcon
protected Icon | detailsViewIcon
protected Icon | directoryIcon
protected int | directoryOpenButtonMnemonic 选择了目录且当前选择模式是 FILES_ONLY 时用于确认按钮的助记符键代码。
protected String | directoryOpenButtonText 选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的标签文本。
protected String | directoryOpenButtonToolTipText 选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的工具提示文本。
protected Icon | fileIcon
protected Icon | floppyDriveIcon
protected Icon | hardDriveIcon
protected int | helpButtonMnemonic
protected String | helpButtonText
protected String | helpButtonToolTipText
protected Icon | homeFolderIcon
protected Icon | listViewIcon
protected Icon | newFolderIcon
protected int | openButtonMnemonic
protected String | openButtonText
protected String | openButtonToolTipText
protected int | saveButtonMnemonic
protected String | saveButtonText
protected String | saveButtonToolTipText
protected int | updateButtonMnemonic
protected String | updateButtonText
protected String | updateButtonToolTipText
protected Icon | upFolderIcon
构造方法摘要
BasicFileChooserUI(JFileChooser b)
方法摘要
void | clearIconCache()
protected MouseListener | createDoubleClickListener(JFileChooser fc, JList list)
ListSelectionListener | createListSelectionListener(JFileChooser fc)
protected void | createModel()
PropertyChangeListener | createPropertyChangeListener(JFileChooser fc)
void | ensureFileIsVisible(JFileChooser fc, File f)
FileFilter | getAcceptAllFileFilter(JFileChooser fc) 返回默认接受所有文件过滤器
JPanel | getAccessoryPanel()
protected JButton | getApproveButton(JFileChooser fc)
int | getApproveButtonMnemonic(JFileChooser fc)
String | getApproveButtonText(JFileChooser fc)
String | getApproveButtonToolTipText(JFileChooser fc)
Action | getApproveSelectionAction()
Action | getCancelSelectionAction()
Action | getChangeToParentDirectoryAction()
String | getDialogTitle(JFileChooser fc) 返回此对话框的标题
protected File | getDirectory() 记忆当前在 UI 中选择的目录的属性。
String | getDirectoryName()
JFileChooser | getFileChooser()
String | getFileName()
FileView | getFileView(JFileChooser fc)
Action | getGoHomeAction()
BasicDirectoryModel | getModel()
Action | getNewFolderAction()
Action | getUpdateAction()
void | installComponents(JFileChooser fc)
protected void | installDefaults(JFileChooser fc)
protected void | installIcons(JFileChooser fc)
protected void | installListeners(JFileChooser fc)
protected void | installStrings(JFileChooser fc)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected boolean | isDirectorySelected() 记忆当前是否在 UI 中选择了目录的属性。
void | rescanCurrentDirectory(JFileChooser fc)
protected void | setDirectory(File f) 记忆当前在 UI 中选择的目录的属性。
void | setDirectoryName(String dirname)
protected void | setDirectorySelected(boolean b) 记忆当前是否在 UI 中选择了目录的属性。
void | setFileName(String filename)
void | uninstallComponents(JFileChooser fc)
protected void | uninstallDefaults(JFileChooser fc)
protected void | uninstallIcons(JFileChooser fc)
protected void | uninstallListeners(JFileChooser fc)
protected void | uninstallStrings(JFileChooser fc)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

directoryIcon

protected Icon directoryIcon

fileIcon

protected Icon fileIcon

computerIcon

protected Icon computerIcon

hardDriveIcon

protected Icon hardDriveIcon

floppyDriveIcon

protected Icon floppyDriveIcon

newFolderIcon

protected Icon newFolderIcon

upFolderIcon

protected Icon upFolderIcon

homeFolderIcon

protected Icon homeFolderIcon

listViewIcon

protected Icon listViewIcon

detailsViewIcon

protected Icon detailsViewIcon

saveButtonMnemonic

protected int saveButtonMnemonic

openButtonMnemonic

protected int openButtonMnemonic

cancelButtonMnemonic

protected int cancelButtonMnemonic

updateButtonMnemonic

protected int updateButtonMnemonic

helpButtonMnemonic

protected int helpButtonMnemonic

directoryOpenButtonMnemonic

protected int directoryOpenButtonMnemonic
选择了目录且当前选择模式是 FILES_ONLY 时用于确认按钮的助记符键代码。

从以下版本开始：
1.4

saveButtonText

protected String saveButtonText

openButtonText

protected String openButtonText

cancelButtonText

protected String cancelButtonText

updateButtonText

protected String updateButtonText

helpButtonText

protected String helpButtonText

directoryOpenButtonText

protected String directoryOpenButtonText
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的标签文本。

从以下版本开始：
1.4

saveButtonToolTipText

protected String saveButtonToolTipText

openButtonToolTipText

protected String openButtonToolTipText

cancelButtonToolTipText

protected String cancelButtonToolTipText

updateButtonToolTipText

protected String updateButtonToolTipText

helpButtonToolTipText

protected String helpButtonToolTipText

directoryOpenButtonToolTipText

protected String directoryOpenButtonToolTipText
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的工具提示文本。

从以下版本开始：
1.4
构造方法详细信息

BasicFileChooserUI

public BasicFileChooserUI(JFileChooser b)
方法详细信息

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installComponents

public void installComponents(JFileChooser fc)

uninstallComponents

public void uninstallComponents(JFileChooser fc)

installListeners

protected void installListeners(JFileChooser fc)

uninstallListeners

protected void uninstallListeners(JFileChooser fc)

installDefaults

protected void installDefaults(JFileChooser fc)

installIcons

protected void installIcons(JFileChooser fc)

installStrings

protected void installStrings(JFileChooser fc)

uninstallDefaults

protected void uninstallDefaults(JFileChooser fc)

uninstallIcons

protected void uninstallIcons(JFileChooser fc)

uninstallStrings

protected void uninstallStrings(JFileChooser fc)

createModel

protected void createModel()

getModel

public BasicDirectoryModel getModel()

createPropertyChangeListener

public PropertyChangeListener createPropertyChangeListener(JFileChooser fc)

getFileName

public String getFileName()

getDirectoryName

public String getDirectoryName()

setFileName

public void setFileName(String filename)

setDirectoryName

public void setDirectoryName(String dirname)

rescanCurrentDirectory

public void rescanCurrentDirectory(JFileChooser fc)
指定者：
类 FileChooserUI 中的 rescanCurrentDirectory

ensureFileIsVisible

public void ensureFileIsVisible(JFileChooser fc,
                                File f)
指定者：
类 FileChooserUI 中的 ensureFileIsVisible

getFileChooser

public JFileChooser getFileChooser()

getAccessoryPanel

public JPanel getAccessoryPanel()

getApproveButton

protected JButton getApproveButton(JFileChooser fc)

getApproveButtonToolTipText

public String getApproveButtonToolTipText(JFileChooser fc)

clearIconCache

public void clearIconCache()

createDoubleClickListener

protected MouseListener createDoubleClickListener(JFileChooser fc,
                                                  JList list)

createListSelectionListener

public ListSelectionListener createListSelectionListener(JFileChooser fc)

isDirectorySelected

protected boolean isDirectorySelected()
记忆当前是否在 UI 中选择了目录的属性。

返回：
当且仅当当前选择了目录时，返回 true。
从以下版本开始：
1.4

setDirectorySelected

protected void setDirectorySelected(boolean b)
记忆当前是否在 UI 中选择了目录的属性。通常由 UI 在选择事件上调用。

参数：
b - 当前是否选择了目录。
从以下版本开始：
1.4

getDirectory

protected File getDirectory()
记忆当前在 UI 中选择的目录的属性。

返回：
directory 属性的值
从以下版本开始：
1.4
另请参见：
setDirectory(java.io.File)

setDirectory

protected void setDirectory(File f)
记忆当前在 UI 中选择的目录的属性。通常由 UI 在选择事件上调用。

参数：
f - 表示当前选择的目录的 File 对象
从以下版本开始：
1.4

getAcceptAllFileFilter

public FileFilter getAcceptAllFileFilter(JFileChooser fc)
返回默认接受所有文件过滤器

指定者：
类 FileChooserUI 中的 getAcceptAllFileFilter

getFileView

public FileView getFileView(JFileChooser fc)
指定者：
类 FileChooserUI 中的 getFileView

getDialogTitle

public String getDialogTitle(JFileChooser fc)
返回此对话框的标题

指定者：
类 FileChooserUI 中的 getDialogTitle

getApproveButtonMnemonic

public int getApproveButtonMnemonic(JFileChooser fc)

getApproveButtonText

public String getApproveButtonText(JFileChooser fc)
指定者：
类 FileChooserUI 中的 getApproveButtonText

getNewFolderAction

public Action getNewFolderAction()

getGoHomeAction

public Action getGoHomeAction()

getChangeToParentDirectoryAction

public Action getChangeToParentDirectoryAction()

getApproveSelectionAction

public Action getApproveSelectionAction()

getCancelSelectionAction

public Action getCancelSelectionAction()

getUpdateAction

public Action getUpdateAction()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.AcceptAllFileFilter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.AcceptAllFileFilter

java.lang.Object
    继承者  javax.swing.filechooser.FileFilter
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.AcceptAllFileFilter
extends FileFilter

构造方法摘要
BasicFileChooserUI.AcceptAllFileFilter()
方法摘要
boolean | accept(File f) 此过滤器是否接受给定的文件。
String | getDescription() 此过滤器的描述。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.AcceptAllFileFilter

public BasicFileChooserUI.AcceptAllFileFilter()
方法详细信息

accept

public boolean accept(File f)
从类 FileFilter 复制的描述
此过滤器是否接受给定的文件。

指定者：
类 FileFilter 中的 accept

getDescription

public String getDescription()
从类 FileFilter 复制的描述
此过滤器的描述。例如："JPG and GIF Images"

指定者：
类 FileFilter 中的 getDescription
另请参见：
FileView.getName(java.io.File)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.ApproveSelectionAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.ApproveSelectionAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.ApproveSelectionAction
extends AbstractAction

响应 Open 或 Save 请求

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicFileChooserUI.ApproveSelectionAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.ApproveSelectionAction

protected BasicFileChooserUI.ApproveSelectionAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.BasicFileView (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.BasicFileView

java.lang.Object
    继承者  javax.swing.filechooser.FileView
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.BasicFileView
extends FileView

字段摘要
protected  Hashtable<File,Icon> iconCache
构造方法摘要
BasicFileChooserUI.BasicFileView()
方法摘要
void | cacheIcon(File f, Icon i)
void | clearIconCache()
Icon | getCachedIcon(File f)
String | getDescription(File f) 文件的可读描述。
Icon | getIcon(File f) 表示 JFileChooser 中此文件的图标。
String | getName(File f) 文件名称。
String | getTypeDescription(File f) 文件类型的可读描述。
Boolean | isHidden(File f)
从类 javax.swing.filechooser.FileView 继承的方法
isTraversable
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

iconCache

protected Hashtable<File,Icon> iconCache
构造方法详细信息

BasicFileChooserUI.BasicFileView

public BasicFileChooserUI.BasicFileView()
方法详细信息

clearIconCache

public void clearIconCache()

getName

public String getName(File f)
从类 FileView 复制的描述
文件名称。通常此名称就是 f.getName()。

覆盖：
类 FileView 中的 getName

getDescription

public String getDescription(File f)
从类 FileView 复制的描述
文件的可读描述。例如，名为 jag.jpg 的文件可能有这样一个描述："A JPEG image file of James Gosling's face"。

覆盖：
类 FileView 中的 getDescription

getTypeDescription

public String getTypeDescription(File f)
从类 FileView 复制的描述
文件类型的可读描述。例如，jpg 文件可能有这样一个类型描述："A JPEG Compressed Image File"

覆盖：
类 FileView 中的 getTypeDescription

getCachedIcon

public Icon getCachedIcon(File f)

cacheIcon

public void cacheIcon(File f,
                      Icon i)

getIcon

public Icon getIcon(File f)
从类 FileView 复制的描述
表示 JFileChooser 中此文件的图标。

覆盖：
类 FileView 中的 getIcon

isHidden

public Boolean isHidden(File f)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.CancelSelectionAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.CancelSelectionAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.CancelSelectionAction
extends AbstractAction

响应取消请求。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicFileChooserUI.CancelSelectionAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.CancelSelectionAction

protected BasicFileChooserUI.CancelSelectionAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.ChangeToParentDirectoryAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.ChangeToParentDirectoryAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.ChangeToParentDirectoryAction
extends AbstractAction

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicFileChooserUI.ChangeToParentDirectoryAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.ChangeToParentDirectoryAction

protected BasicFileChooserUI.ChangeToParentDirectoryAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.DoubleClickListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.DoubleClickListener

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.DoubleClickListener
extends MouseAdapter

构造方法摘要
BasicFileChooserUI.DoubleClickListener(JList list)
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseEntered(MouseEvent e) 用于表示文件的 JList 由子类创建，但是在此类中监视选择。
从类 java.awt.event.MouseAdapter 继承的方法
mouseDragged, mouseExited, mouseMoved, mousePressed, mouseReleased, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.DoubleClickListener

public BasicFileChooserUI.DoubleClickListener(JList list)
方法详细信息

mouseEntered

public void mouseEntered(MouseEvent e)
用于表示文件的 JList 由子类创建，但是在此类中监视选择。作为实际传输源使用时，安装在 JFileChooser 中的 TransferHandler 也被安装在文件列表中。列表在鼠标进入时更新，以反映文件选择器的当前数据传输状态。

指定者：
接口 MouseListener 中的 mouseEntered
覆盖：
类 MouseAdapter 中的 mouseEntered

mouseClicked

public void mouseClicked(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked
覆盖：
类 MouseAdapter 中的 mouseClicked
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.GoHomeAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.GoHomeAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.GoHomeAction
extends AbstractAction

基于“Home”键事件或等效事件的动作。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicFileChooserUI.GoHomeAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.GoHomeAction

protected BasicFileChooserUI.GoHomeAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.NewFolderAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.NewFolderAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.NewFolderAction
extends AbstractAction

创建新文件夹。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicFileChooserUI.NewFolderAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.NewFolderAction

protected BasicFileChooserUI.NewFolderAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicHTML (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicHTML

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicHTML

public class BasicHTML
extends Object

支持为 swing 组件提供 html 视图。它将简单的 html 字符串转换为 javax.swing.text.View 实现，它能呈现 html 并提供必需的布局语义。

从以下版本开始：
1.3

字段摘要
static String | documentBaseKey 存储为客户端属性以指示用作解析相关引用的基址的键。
static String | propertyKey 存储为 JComponent 的客户端属性时用于 html 渲染器的键。
构造方法摘要
BasicHTML()
方法摘要
static View | createHTMLView(JComponent c, String html) 创建给定组件和 html 字符串的 html 渲染器。
static int | getHTMLBaseline(View view, int w, int h) 返回 html 渲染器的基线。
static boolean | isHTMLString(String s) 检查给定字符串以查看它是否应该在支持 html 呈现的非文本组件中触发 html 呈现逻辑。
static void | updateRenderer(JComponent c, String text) 将给定文本的 HTML 渲染器隐藏在给定 JComponent 的客户端属性中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

propertyKey

public static final String propertyKey
存储为 JComponent 的客户端属性时用于 html 渲染器的键。

另请参见：
常量字段值

documentBaseKey

public static final String documentBaseKey
存储为客户端属性以指示用作解析相关引用的基址的键。例如，假设要将图像保存在相对于代码路径的目录资源中，应该使用以下代码设置基址：
   jComponent.putClientProperty(documentBaseKey,
                                xxx.class.getResource("resources/"));

另请参见：
常量字段值
构造方法详细信息

BasicHTML

public BasicHTML()
方法详细信息

createHTMLView

public static View createHTMLView(JComponent c,
                                  String html)
创建给定组件和 html 字符串的 html 渲染器。

getHTMLBaseline

public static int getHTMLBaseline(View view,
                                  int w,
                                  int h)
返回 html 渲染器的基线。

参数：
view - 为其获取基线的视图
w - 为其获取基线的宽度
h - 为其获取基线的高度
返回：
基线；或者返回值 < 0，指示没有合理的基线
抛出：
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
FontMetrics, JComponent.getBaseline(int,int)

isHTMLString

public static boolean isHTMLString(String s)
检查给定字符串以查看它是否应该在支持 html 呈现的非文本组件中触发 html 呈现逻辑。

updateRenderer

public static void updateRenderer(JComponent c,
                                  String text)
将给定文本的 HTML 渲染器隐藏在给定 JComponent 的客户端属性中。如果给定文本是非 HTML，则属性中的所有渲染器都将被清除掉。

此方法对于静态（即共享）ComponentUI 实现十分有用，可以完全从 JComponent 中获取其状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.SelectionListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.SelectionListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener
所有已实现的接口：
EventListener, ListSelectionListener
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.SelectionListener
extends Object
implements ListSelectionListener

构造方法摘要
protected BasicFileChooserUI.SelectionListener()
方法摘要
 void valueChanged(ListSelectionEvent e)
每当选择值发生更改时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.SelectionListener

protected BasicFileChooserUI.SelectionListener()
方法详细信息

valueChanged

public void valueChanged(ListSelectionEvent e)
从接口 ListSelectionListener 复制的描述
每当选择值发生更改时调用。

指定者：
接口 ListSelectionListener 中的 valueChanged
参数：
e - 表现更改的特征的事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFileChooserUI.UpdateAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFileChooserUI.UpdateAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicFileChooserUI
protected class BasicFileChooserUI.UpdateAction
extends AbstractAction

重新扫描当前目录中的文件。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected BasicFileChooserUI.UpdateAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFileChooserUI.UpdateAction

protected BasicFileChooserUI.UpdateAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicFormattedTextFieldUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicFormattedTextFieldUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
                继承者  javax.swing.plaf.basic.BasicTextFieldUI
                    继承者  javax.swing.plaf.basic.BasicFormattedTextFieldUI
所有已实现的接口：
ViewFactory
public class BasicFormattedTextFieldUI
extends BasicTextFieldUI

提供 JFormattedTextField 的外观实现。

从以下版本开始：
1.4

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的嵌套类/接口
BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter
构造方法摘要
BasicFormattedTextFieldUI()
方法摘要
static ComponentUI | createUI(JComponent c) 创建 JFormattedTextField 的 UI。
protected String | getPropertyPrefix() 获取用作键以通过 UIManager 查找属性的名称。
从类 javax.swing.plaf.basic.BasicTextFieldUI 继承的方法
create, getBaseline, getBaselineResizeBehavior
从类 javax.swing.plaf.basic.BasicTextUI 继承的方法
create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, propertyChange, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicFormattedTextFieldUI

public BasicFormattedTextFieldUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)
创建 JFormattedTextField 的 UI。

参数：
c - 已编排格式的文本字段
返回：
UI

getPropertyPrefix

protected String getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。它用作所有标准文本属性的前缀。

覆盖：
类 BasicTextFieldUI 中的 getPropertyPrefix
返回：
名称 "FormattedTextField"
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicGraphicsUtils (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicGraphicsUtils

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicGraphicsUtils

public class BasicGraphicsUtils
extends Object

构造方法摘要
BasicGraphicsUtils()
方法摘要
static void drawBezel(Graphics g, int x, int y, int w, int h, boolean isPressed, boolean isDefault, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void drawDashedRect(Graphics g, int x, int y, int width, int height)
static void drawEtchedRect(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void drawGroove(Graphics g, int x, int y, int w, int h, Color shadow, Color highlight)
static void drawLoweredBezel(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void drawString(Graphics g, String text, int underlinedChar, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x,y) 绘制字符串。
static void drawStringUnderlineCharAt(Graphics g, String text, int underlinedIndex, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x, y) 绘制字符串。
static Insets getEtchedInsets()
返回 drawEtchedRect() 绘制边框占用的空间量。
static Insets getGrooveInsets()
返回 drawGroove() 绘制边框占用的空间量。
static Dimension getPreferredButtonSize(AbstractButton b, int textIconGap)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicGraphicsUtils

public BasicGraphicsUtils()
方法详细信息

drawEtchedRect

public static void drawEtchedRect(Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h,
                                  Color shadow,
                                  Color darkShadow,
                                  Color highlight,
                                  Color lightHighlight)

getEtchedInsets

public static Insets getEtchedInsets()
返回 drawEtchedRect() 绘制边框占用的空间量。

返回：
浮雕化矩形的镶边

drawGroove

public static void drawGroove(Graphics g,
                              int x,
                              int y,
                              int w,
                              int h,
                              Color shadow,
                              Color highlight)

getGrooveInsets

public static Insets getGrooveInsets()
返回 drawGroove() 绘制边框占用的空间量。

返回：
凹槽边框的 inset

drawBezel

public static void drawBezel(Graphics g,
                             int x,
                             int y,
                             int w,
                             int h,
                             boolean isPressed,
                             boolean isDefault,
                             Color shadow,
                             Color darkShadow,
                             Color highlight,
                             Color lightHighlight)

drawLoweredBezel

public static void drawLoweredBezel(Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h,
                                    Color shadow,
                                    Color darkShadow,
                                    Color highlight,
                                    Color lightHighlight)

drawString

public static void drawString(Graphics g,
                              String text,
                              int underlinedChar,
                              int x,
                              int y)
像 g.drawString 那样利用图形 g 在位置 (x,y) 绘制字符串。underlineChar 在文本中第一次出现时将带有下划线。匹配算法不区分大小写。

drawStringUnderlineCharAt

public static void drawStringUnderlineCharAt(Graphics g,
                                             String text,
                                             int underlinedIndex,
                                             int x,
                                             int y)
像 g.drawString 那样利用图形 g 在位置 (x, y) 绘制字符串。文本中 underlinedIndex 处的字符将带有下划线。如果 index 超出 text（包括 < 0）的边界，则没有任何内容有下划线。

参数：
g - 用于绘制的图形
text - 要绘制的字符串
underlinedIndex - 文本中要加下划线的字符的索引
x - 绘制位置的 x 坐标
y - 绘制位置的 y 坐标
从以下版本开始：
1.4

drawDashedRect

public static void drawDashedRect(Graphics g,
                                  int x,
                                  int y,
                                  int width,
                                  int height)

getPreferredButtonSize

public static Dimension getPreferredButtonSize(AbstractButton b,
                                               int textIconGap)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicIconFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicIconFactory

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicIconFactory
所有已实现的接口：
Serializable
public class BasicIconFactory
extends Object
implements Serializable

提供适于基本 L & F 使用的 Icon 的工厂对象。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
BasicIconFactory()
方法摘要
static Icon | createEmptyFrameIcon()
static Icon | getCheckBoxIcon()
static Icon | getCheckBoxMenuItemIcon()
static Icon | getMenuArrowIcon()
static Icon | getMenuItemArrowIcon()
static Icon | getMenuItemCheckIcon()
static Icon | getRadioButtonIcon()
static Icon | getRadioButtonMenuItemIcon()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicIconFactory

public BasicIconFactory()
方法详细信息

getMenuItemCheckIcon

public static Icon getMenuItemCheckIcon()

getMenuItemArrowIcon

public static Icon getMenuItemArrowIcon()

getMenuArrowIcon

public static Icon getMenuArrowIcon()

getCheckBoxIcon

public static Icon getCheckBoxIcon()

getRadioButtonIcon

public static Icon getRadioButtonIcon()

getCheckBoxMenuItemIcon

public static Icon getCheckBoxMenuItemIcon()

getRadioButtonMenuItemIcon

public static Icon getRadioButtonMenuItemIcon()

createEmptyFrameIcon

public static Icon createEmptyFrameIcon()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable
直接已知子类：
MetalInternalFrameTitlePane
public class BasicInternalFrameTitlePane
extends JComponent

管理基本标题栏的类

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.PropertyChangeHandler 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.TitlePaneLayout 此类应视为“受保护”内部类。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected static String | CLOSE_CMD
protected Action | closeAction
protected JButton | closeButton
protected Icon | closeIcon
protected JInternalFrame | frame
protected JButton | iconButton
protected Icon | iconIcon
protected static String | ICONIFY_CMD
protected Action | iconifyAction
protected JButton | maxButton
protected Icon | maxIcon
protected static String | MAXIMIZE_CMD
protected Action | maximizeAction
protected JMenuBar | menuBar
protected Icon | minIcon
protected static String | MOVE_CMD
protected Action | moveAction
protected Color | notSelectedTextColor
protected Color | notSelectedTitleColor
protected PropertyChangeListener | propertyChangeListener
protected static String | RESTORE_CMD
protected Action | restoreAction
protected Color | selectedTextColor
protected Color | selectedTitleColor
protected static String | SIZE_CMD
protected Action | sizeAction
protected JMenu | windowMenu
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
BasicInternalFrameTitlePane(JInternalFrame f)
方法摘要
protected void | addSubComponents()
protected void | addSystemMenuItems(JMenu systemMenu)
protected void | assembleSystemMenu()
protected void | createActions()
protected void | createButtons()
protected LayoutManager | createLayout()
protected PropertyChangeListener | createPropertyChangeListener()
protected JMenu | createSystemMenu()
protected JMenuBar | createSystemMenuBar()
protected void | enableActions()
protected String | getTitle(String text, FontMetrics fm, int availTextWidth)
protected void | installDefaults()
protected void | installListeners()
protected void | installTitlePane()
void | paintComponent(Graphics g) 如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。
protected void | paintTitleBackground(Graphics g) 从 paintComponent 调用。
protected void | postClosingEvent(JInternalFrame frame) 将类似于 WINDOW_CLOSING 的事件发送到窗体，以便将其当作规则的 Frame 来对待。
protected void | setButtonIcons()
protected void | showSystemMenu()
protected void | uninstallDefaults()
protected void | uninstallListeners()
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getAccessibleContext, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

menuBar

protected JMenuBar menuBar

iconButton

protected JButton iconButton

maxButton

protected JButton maxButton

closeButton

protected JButton closeButton

windowMenu

protected JMenu windowMenu

frame

protected JInternalFrame frame

selectedTitleColor

protected Color selectedTitleColor

selectedTextColor

protected Color selectedTextColor

notSelectedTitleColor

protected Color notSelectedTitleColor

notSelectedTextColor

protected Color notSelectedTextColor

maxIcon

protected Icon maxIcon

minIcon

protected Icon minIcon

iconIcon

protected Icon iconIcon

closeIcon

protected Icon closeIcon

propertyChangeListener

protected PropertyChangeListener propertyChangeListener

closeAction

protected Action closeAction

maximizeAction

protected Action maximizeAction

iconifyAction

protected Action iconifyAction

restoreAction

protected Action restoreAction

moveAction

protected Action moveAction

sizeAction

protected Action sizeAction

CLOSE_CMD

protected static final String CLOSE_CMD

ICONIFY_CMD

protected static final String ICONIFY_CMD

RESTORE_CMD

protected static final String RESTORE_CMD

MAXIMIZE_CMD

protected static final String MAXIMIZE_CMD

MOVE_CMD

protected static final String MOVE_CMD

SIZE_CMD

protected static final String SIZE_CMD
构造方法详细信息

BasicInternalFrameTitlePane

public BasicInternalFrameTitlePane(JInternalFrame f)
方法详细信息

installTitlePane

protected void installTitlePane()

addSubComponents

protected void addSubComponents()

createActions

protected void createActions()

installListeners

protected void installListeners()

uninstallListeners

protected void uninstallListeners()

installDefaults

protected void installDefaults()

uninstallDefaults

protected void uninstallDefaults()

createButtons

protected void createButtons()

setButtonIcons

protected void setButtonIcons()

assembleSystemMenu

protected void assembleSystemMenu()

addSystemMenuItems

protected void addSystemMenuItems(JMenu systemMenu)

createSystemMenu

protected JMenu createSystemMenu()

createSystemMenuBar

protected JMenuBar createSystemMenuBar()

showSystemMenu

protected void showSystemMenu()

paintComponent

public void paintComponent(Graphics g)
从类 JComponent 复制的描述
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。向该委托传递 Graphics 对象的副本，以保护其余的 paint 代码免遭不可取消的更改（例如 Graphics.translate）。

如果在子类中重写此方法，则不应该对传入的 Graphics 进行永久更改。例如，不应更改剪贴区的 Rectangle 或修改转换。如果需要进行这些操作，您会发现根据传入的 Graphics 创建一个新 Graphics 并进行操作更加方便。另外，如果不调用超类的实现，则必须遵守不透明属性，也就是说，如果此组件是不透明的，则必须以透明的颜色完全填充背景。如果不遵守不透明属性，则很可能看到可视的人为内容。

传入的 Graphics 对象可能安装了恒等转换以外的转换。在这种情况下，如果多次应用其他转换，则可能得到不可预料的结果。

覆盖：
类 JComponent 中的 paintComponent
参数：
g - 要保护的 Graphics 对象
另请参见：
JComponent.paint(java.awt.Graphics), ComponentUI

paintTitleBackground

protected void paintTitleBackground(Graphics g)
从 paintComponent 调用。绘制标题窗格的背景。然后在此背景的顶部呈现所有文本和图标。

参数：
g - 用于呈现背景的图形
从以下版本开始：
1.4

getTitle

protected String getTitle(String text,
                          FontMetrics fm,
                          int availTextWidth)

postClosingEvent

protected void postClosingEvent(JInternalFrame frame)
将类似于 WINDOW_CLOSING 的事件发送到窗体，以便将其当作规则的 Frame 来对待。

enableActions

protected void enableActions()

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()

createLayout

protected LayoutManager createLayout()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.CloseAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.CloseAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.CloseAction
extends AbstractAction

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicInternalFrameTitlePane.CloseAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.CloseAction

public BasicInternalFrameTitlePane.CloseAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.IconifyAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.IconifyAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.IconifyAction
extends AbstractAction

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicInternalFrameTitlePane.IconifyAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.IconifyAction

public BasicInternalFrameTitlePane.IconifyAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.MaximizeAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.MaximizeAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.MaximizeAction
extends AbstractAction

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicInternalFrameTitlePane.MaximizeAction()
方法摘要
 void actionPerformed(ActionEvent evt)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.MaximizeAction

public BasicInternalFrameTitlePane.MaximizeAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent evt)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.MoveAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.MoveAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.MoveAction
extends AbstractAction

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicInternalFrameTitlePane.MoveAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.MoveAction

public BasicInternalFrameTitlePane.MoveAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.InternalFrameUI
            继承者  javax.swing.plaf.basic.BasicInternalFrameUI
直接已知子类：
MetalInternalFrameUI
public class BasicInternalFrameUI
extends InternalFrameUI

JInternalFrame 的基本 L&F 实现。

嵌套类摘要
protected class | BasicInternalFrameUI.BasicInternalFrameListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.ComponentHandler
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicInternalFrameUI.InternalFrameLayout
class | BasicInternalFrameUI.InternalFramePropertyChangeListener
字段摘要
protected MouseInputAdapter | borderListener
protected ComponentListener | componentListener
protected JComponent | eastPane
protected JInternalFrame | frame
protected MouseInputListener | glassPaneDispatcher
protected LayoutManager | internalFrameLayout
protected JComponent | northPane
protected KeyStroke | openMenuKey 已过时。 从 Java 2 platform v1.3 开始。
protected PropertyChangeListener | propertyChangeListener
protected JComponent | southPane
protected BasicInternalFrameTitlePane | titlePane
protected JComponent | westPane
构造方法摘要
BasicInternalFrameUI(JInternalFrame b)
方法摘要
protected void | activateFrame(JInternalFrame f) 窗体变为被选择状态时调用此方法。
protected void | closeFrame(JInternalFrame f) 当用户要关闭窗体时调用此方法。
protected MouseInputAdapter | createBorderListener(JInternalFrame w)
protected ComponentListener | createComponentListener()
protected DesktopManager | createDesktopManager()
protected JComponent | createEastPane(JInternalFrame w)
protected MouseInputListener | createGlassPaneDispatcher()
protected void | createInternalFrameListener()
protected LayoutManager | createLayoutManager()
protected JComponent | createNorthPane(JInternalFrame w)
protected PropertyChangeListener | createPropertyChangeListener()
protected JComponent | createSouthPane(JInternalFrame w)
static ComponentUI | createUI(JComponent b)
protected JComponent | createWestPane(JInternalFrame w)
protected void | deactivateFrame(JInternalFrame f) 窗体不再是被选择状态时调用此方法。
protected void | deiconifyFrame(JInternalFrame f) 当用户要取消图标化窗体时调用此方法。
protected void | deinstallMouseHandlers(JComponent c)
protected DesktopManager | getDesktopManager() 返回适当的 DesktopManager。
JComponent | getEastPane()
Dimension | getMaximumSize(JComponent x) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent x) 返回指定组件的适合外观的最小大小。
JComponent | getNorthPane()
Dimension | getPreferredSize(JComponent x) 返回指定组件的适合外观的首选大小。
JComponent | getSouthPane()
JComponent | getWestPane()
protected void | iconifyFrame(JInternalFrame f) 当用户要图标化窗体时调用此方法。
protected void | installComponents()
protected void | installDefaults()
protected void | installKeyboardActions()
protected void | installListeners()
protected void | installMouseHandlers(JComponent c)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
boolean | isKeyBindingActive()
protected boolean | isKeyBindingRegistered()
protected void | maximizeFrame(JInternalFrame f) 当用户要最大化窗体时调用此方法。
protected void | minimizeFrame(JInternalFrame f) 当用户要最小化窗体时调用此方法。
protected void | replacePane(JComponent currentPane, JComponent newPane) 将必需的鼠标处理程序安装在 newPane 上并将其添加到窗体。
void | setEastPane(JComponent c)
protected void | setKeyBindingActive(boolean b)
protected void | setKeyBindingRegistered(boolean b)
void | setNorthPane(JComponent c)
void | setSouthPane(JComponent c)
protected void | setupMenuCloseKey()
protected void | setupMenuOpenKey()
void | setWestPane(JComponent c)
protected void | uninstallComponents()
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

frame

protected JInternalFrame frame

borderListener

protected MouseInputAdapter borderListener

propertyChangeListener

protected PropertyChangeListener propertyChangeListener

internalFrameLayout

protected LayoutManager internalFrameLayout

componentListener

protected ComponentListener componentListener

glassPaneDispatcher

protected MouseInputListener glassPaneDispatcher

northPane

protected JComponent northPane

southPane

protected JComponent southPane

westPane

protected JComponent westPane

eastPane

protected JComponent eastPane

titlePane

protected BasicInternalFrameTitlePane titlePane

openMenuKey

@Deprecated
protected KeyStroke openMenuKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

构造方法详细信息

BasicInternalFrameUI

public BasicInternalFrameUI(JInternalFrame b)
方法详细信息

createUI

public static ComponentUI createUI(JComponent b)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults()

installKeyboardActions

protected void installKeyboardActions()

installComponents

protected void installComponents()

installListeners

protected void installListeners()
从以下版本开始：
1.3

uninstallDefaults

protected void uninstallDefaults()

uninstallComponents

protected void uninstallComponents()

uninstallListeners

protected void uninstallListeners()
从以下版本开始：
1.3

uninstallKeyboardActions

protected void uninstallKeyboardActions()

createLayoutManager

protected LayoutManager createLayoutManager()

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()

getPreferredSize

public Dimension getPreferredSize(JComponent x)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
x - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent x)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
x - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent x)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
x - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

replacePane

protected void replacePane(JComponent currentPane,
                           JComponent newPane)
将必需的鼠标处理程序安装在 newPane 上并将其添加到窗体。对 currentPane 应用相反的进程。

deinstallMouseHandlers

protected void deinstallMouseHandlers(JComponent c)

installMouseHandlers

protected void installMouseHandlers(JComponent c)

createNorthPane

protected JComponent createNorthPane(JInternalFrame w)

createSouthPane

protected JComponent createSouthPane(JInternalFrame w)

createWestPane

protected JComponent createWestPane(JInternalFrame w)

createEastPane

protected JComponent createEastPane(JInternalFrame w)

createBorderListener

protected MouseInputAdapter createBorderListener(JInternalFrame w)

createInternalFrameListener

protected void createInternalFrameListener()

isKeyBindingRegistered

protected final boolean isKeyBindingRegistered()

setKeyBindingRegistered

protected final void setKeyBindingRegistered(boolean b)

isKeyBindingActive

public final boolean isKeyBindingActive()

setKeyBindingActive

protected final void setKeyBindingActive(boolean b)

setupMenuOpenKey

protected void setupMenuOpenKey()

setupMenuCloseKey

protected void setupMenuCloseKey()

getNorthPane

public JComponent getNorthPane()

setNorthPane

public void setNorthPane(JComponent c)

getSouthPane

public JComponent getSouthPane()

setSouthPane

public void setSouthPane(JComponent c)

getWestPane

public JComponent getWestPane()

setWestPane

public void setWestPane(JComponent c)

getEastPane

public JComponent getEastPane()

setEastPane

public void setEastPane(JComponent c)

getDesktopManager

protected DesktopManager getDesktopManager()
返回适当的 DesktopManager。调用 getDesktopPane() 查找 JDesktop 组件并从其返回 desktopManager。如果此操作失败，则其返回应该在任意父级中使用的默认的 DesktopManager。

createDesktopManager

protected DesktopManager createDesktopManager()

closeFrame

protected void closeFrame(JInternalFrame f)
当用户要关闭窗体时调用此方法。playCloseSound 动作被激发。将此动作委托给 desktopManager。

maximizeFrame

protected void maximizeFrame(JInternalFrame f)
当用户要最大化窗体时调用此方法。playMaximizeSound 动作被激发。将此动作委托给 desktopManager。

minimizeFrame

protected void minimizeFrame(JInternalFrame f)
当用户要最小化窗体时调用此方法。playRestoreDownSound 动作被激发。将此动作委托给 desktopManager。

iconifyFrame

protected void iconifyFrame(JInternalFrame f)
当用户要图标化窗体时调用此方法。playMinimizeSound 动作被激发。将此动作委托给 desktopManager。

deiconifyFrame

protected void deiconifyFrame(JInternalFrame f)
当用户要取消图标化窗体时调用此方法。playRestoreUpSound 动作被激发。将此动作委托给 desktopManager。

activateFrame

protected void activateFrame(JInternalFrame f)
窗体变为被选择状态时调用此方法。将此动作委托给 desktopManager。

deactivateFrame

protected void deactivateFrame(JInternalFrame f)
窗体不再是被选择状态时调用此方法。将此动作委托给 desktopManager。

createComponentListener

protected ComponentListener createComponentListener()

createGlassPaneDispatcher

protected MouseInputListener createGlassPaneDispatcher()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.PropertyChangeHandler
extends Object
implements PropertyChangeListener

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

构造方法摘要
BasicInternalFrameTitlePane.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent evt)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.PropertyChangeHandler

public BasicInternalFrameTitlePane.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent evt)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
evt - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.RestoreAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.RestoreAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.RestoreAction
extends AbstractAction

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicInternalFrameTitlePane.RestoreAction()
方法摘要
 void actionPerformed(ActionEvent evt)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.RestoreAction

public BasicInternalFrameTitlePane.RestoreAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent evt)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.SizeAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.SizeAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.SizeAction
extends AbstractAction

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicInternalFrameTitlePane.SizeAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.SizeAction

public BasicInternalFrameTitlePane.SizeAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.SystemMenuBar (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.SystemMenuBar

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JMenuBar
                    继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, MenuElement
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.SystemMenuBar
extends JMenuBar

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

嵌套类摘要
从类 javax.swing.JMenuBar 继承的嵌套类/接口
JMenuBar.AccessibleJMenuBar
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
BasicInternalFrameTitlePane.SystemMenuBar()
方法摘要
boolean | isFocusTraversable() 返回此 Component 是否可以成为焦点所有者。
boolean | isOpaque() 如果此组件是完全不透明的，则返回 true。
void | paint(Graphics g) 由 Swing 调用，以绘制组件。
void | requestFocus() 请求此 Component 获取输入焦点。
从类 javax.swing.JMenuBar 继承的方法
add, addNotify, getAccessibleContext, getComponent, getComponentAtIndex, getComponentIndex, getHelpMenu, getMargin, getMenu, getMenuCount, getSelectionModel, getSubElements, getUI, getUIClassID, isBorderPainted, isSelected, menuSelectionChanged, paintBorder, paramString, processKeyBinding, processKeyEvent, processMouseEvent, removeNotify, setBorderPainted, setHelpMenu, setMargin, setSelected, setSelectionModel, setUI, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.SystemMenuBar

public BasicInternalFrameTitlePane.SystemMenuBar()
方法详细信息

isFocusTraversable

public boolean isFocusTraversable()
从类 Component 复制的描述
返回此 Component 是否可以成为焦点所有者。

覆盖：
类 Component 中的 isFocusTraversable
返回：
如果此 Component 是可以获得焦点的，则返回 true；否则返回 false
另请参见：
Component.setFocusable(boolean)

requestFocus

public void requestFocus()
从类 JComponent 复制的描述
请求此 Component 获取输入焦点。有关此方法的完整描述，请参阅 Component.requestFocus()。

注意，不推荐使用此方法，因为其行为与平台有关。建议使用 requestFocusInWindow()。若要了解有关焦点的更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

覆盖：
类 JComponent 中的 requestFocus
另请参见：
Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

paint

public void paint(Graphics g)
从类 JComponent 复制的描述
由 Swing 调用，以绘制组件。应用程序不应直接调用 paint，而是应该使用 repaint 方法来安排重绘组件。

此方法实际上将绘制工作委托给三个受保护的方法：paintComponent、paintBorder 和 paintChildren。按列出的顺序调用这些方法，以确保子组件出现在组件本身的顶部。一般来说，不应在分配给边框的 insets 区域绘制组件及其子组件。子类可以始终重写此方法。只想特殊化 UI（外观）委托的 paint 方法的子类只需重写 paintComponent。

覆盖：
类 JComponent 中的 paint
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

isOpaque

public boolean isOpaque()
从类 JComponent 复制的描述
如果此组件是完全不透明的，则返回 true。

不透明组件将每个像素绘制在其矩形边界内。透明的组件则仅绘制部分像素或者不绘制任何像素，允许其底层像素“透视出来”。因此，没有完全绘制其像素的组件则提供了一定程度的透明度。

保证总是完全绘制其内容的子类应该重写此方法并返回 true。

覆盖：
类 JComponent 中的 isOpaque
返回：
如果此组件是完全不透明的，则返回 true
另请参见：
JComponent.setOpaque(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameTitlePane.TitlePaneLayout (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameTitlePane.TitlePaneLayout

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
所有已实现的接口：
LayoutManager
正在封闭类：
BasicInternalFrameTitlePane
public class BasicInternalFrameTitlePane.TitlePaneLayout
extends Object
implements LayoutManager

此类应视为“受保护”内部类。仅在 BasicInternalFrameTitlePane 的子类中实例化此类。

构造方法摘要
BasicInternalFrameTitlePane.TitlePaneLayout()
方法摘要
void | addLayoutComponent(String name, Component c) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
void | layoutContainer(Container c) 布置指定容器。
Dimension | minimumLayoutSize(Container c) 给定指定容器所包含的组件，计算该容器的最小大小维数。
Dimension | preferredLayoutSize(Container c) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | removeLayoutComponent(Component c) 从布局移除指定组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameTitlePane.TitlePaneLayout

public BasicInternalFrameTitlePane.TitlePaneLayout()
方法详细信息

addLayoutComponent

public void addLayoutComponent(String name,
                               Component c)
从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
c - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component c)
从接口 LayoutManager 复制的描述
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
c - 要移除的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container c)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的首选大小维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
c - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container c)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的最小大小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
c - 要布置的组件

layoutContainer

public void layoutContainer(Container c)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
c - 要布置的容器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameUI.BasicInternalFrameListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameUI.BasicInternalFrameListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
所有已实现的接口：
EventListener, InternalFrameListener
正在封闭类：
BasicInternalFrameUI
protected class BasicInternalFrameUI.BasicInternalFrameListener
extends Object
implements InternalFrameListener

构造方法摘要
protected BasicInternalFrameUI.BasicInternalFrameListener()
方法摘要
void | internalFrameActivated(InternalFrameEvent e) 当内部窗体被激活时调用。
void | internalFrameClosed(InternalFrameEvent e) 当内部窗体已关闭时调用。
void | internalFrameClosing(InternalFrameEvent e) 当内部窗体正被关闭时调用。
void | internalFrameDeactivated(InternalFrameEvent e) 当内部窗体被取消激活时调用。
void | internalFrameDeiconified(InternalFrameEvent e) 当内部窗体被取消图标化时调用。
void | internalFrameIconified(InternalFrameEvent e) 当内部窗体被图标化时调用。
void | internalFrameOpened(InternalFrameEvent e) 当内部窗体已打开时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameUI.BasicInternalFrameListener

protected BasicInternalFrameUI.BasicInternalFrameListener()
方法详细信息

internalFrameClosing

public void internalFrameClosing(InternalFrameEvent e)
从接口 InternalFrameListener 复制的描述
当内部窗体正被关闭时调用。此时可重写关闭操作。

指定者：
接口 InternalFrameListener 中的 internalFrameClosing
另请参见：
JInternalFrame.setDefaultCloseOperation(int)

internalFrameClosed

public void internalFrameClosed(InternalFrameEvent e)
从接口 InternalFrameListener 复制的描述
当内部窗体已关闭时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameClosed
另请参见：
JInternalFrame.setClosed(boolean)

internalFrameOpened

public void internalFrameOpened(InternalFrameEvent e)
从接口 InternalFrameListener 复制的描述
当内部窗体已打开时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameOpened
另请参见：
JInternalFrame.show()

internalFrameIconified

public void internalFrameIconified(InternalFrameEvent e)
从接口 InternalFrameListener 复制的描述
当内部窗体被图标化时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameIconified
另请参见：
JInternalFrame.setIcon(boolean)

internalFrameDeiconified

public void internalFrameDeiconified(InternalFrameEvent e)
从接口 InternalFrameListener 复制的描述
当内部窗体被取消图标化时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameDeiconified
另请参见：
JInternalFrame.setIcon(boolean)

internalFrameActivated

public void internalFrameActivated(InternalFrameEvent e)
从接口 InternalFrameListener 复制的描述
当内部窗体被激活时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameActivated
另请参见：
JInternalFrame.setSelected(boolean)

internalFrameDeactivated

public void internalFrameDeactivated(InternalFrameEvent e)
从接口 InternalFrameListener 复制的描述
当内部窗体被取消激活时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameDeactivated
另请参见：
JInternalFrame.setSelected(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameUI.BorderListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameUI.BorderListener

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.event.MouseInputAdapter
            继承者  javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener, MouseInputListener, SwingConstants
正在封闭类：
BasicInternalFrameUI
protected class BasicInternalFrameUI.BorderListener
extends MouseInputAdapter
implements SwingConstants

侦听边框调整。

字段摘要
protected  int RESIZE_NONE
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
protected BasicInternalFrameUI.BorderListener()
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.awt.event.MouseAdapter 继承的方法
mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RESIZE_NONE

protected final int RESIZE_NONE
另请参见：
常量字段值
构造方法详细信息

BasicInternalFrameUI.BorderListener

protected BasicInternalFrameUI.BorderListener()
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked
覆盖：
类 MouseAdapter 中的 mouseClicked

mouseReleased

public void mouseReleased(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased

mousePressed

public void mousePressed(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed

mouseDragged

public void mouseDragged(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseAdapter 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseAdapter 中的 mouseMoved

mouseEntered

public void mouseEntered(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered
覆盖：
类 MouseAdapter 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited
覆盖：
类 MouseAdapter 中的 mouseExited
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameUI.ComponentHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameUI.ComponentHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
所有已实现的接口：
ComponentListener, EventListener
正在封闭类：
BasicInternalFrameUI
protected class BasicInternalFrameUI.ComponentHandler
extends Object
implements ComponentListener

构造方法摘要
protected BasicInternalFrameUI.ComponentHandler()
方法摘要
void | componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | componentMoved(ComponentEvent e) 组件位置更改时调用。
void | componentResized(ComponentEvent e) 当 JInternalFrame 的父级大小更改时调用。
void | componentShown(ComponentEvent e) 组件变得可见时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameUI.ComponentHandler

protected BasicInternalFrameUI.ComponentHandler()
方法详细信息

componentResized

public void componentResized(ComponentEvent e)
当 JInternalFrame 的父级大小更改时调用。

指定者：
接口 ComponentListener 中的 componentResized

componentMoved

public void componentMoved(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件位置更改时调用。

指定者：
接口 ComponentListener 中的 componentMoved

componentShown

public void componentShown(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件变得可见时调用。

指定者：
接口 ComponentListener 中的 componentShown

componentHidden

public void componentHidden(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件变得不可见时调用。

指定者：
接口 ComponentListener 中的 componentHidden
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameUI.GlassPaneDispatcher (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameUI.GlassPaneDispatcher

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
正在封闭类：
BasicInternalFrameUI
protected class BasicInternalFrameUI.GlassPaneDispatcher
extends Object
implements MouseInputListener

构造方法摘要
protected BasicInternalFrameUI.GlassPaneDispatcher()
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameUI.GlassPaneDispatcher

protected BasicInternalFrameUI.GlassPaneDispatcher()
方法详细信息

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseEntered

public void mouseEntered(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mouseReleased

public void mouseReleased(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameUI.InternalFrameLayout (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameUI.InternalFrameLayout

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
所有已实现的接口：
LayoutManager
正在封闭类：
BasicInternalFrameUI
public class BasicInternalFrameUI.InternalFrameLayout
extends Object
implements LayoutManager

构造方法摘要
BasicInternalFrameUI.InternalFrameLayout()
方法摘要
void | addLayoutComponent(String name, Component c) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
void | layoutContainer(Container c) 布置指定容器。
Dimension | minimumLayoutSize(Container c) 给定指定容器所包含的组件，计算该容器的最小大小维数。
Dimension | preferredLayoutSize(Container c) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | removeLayoutComponent(Component c) 从布局移除指定组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameUI.InternalFrameLayout

public BasicInternalFrameUI.InternalFrameLayout()
方法详细信息

addLayoutComponent

public void addLayoutComponent(String name,
                               Component c)
从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
c - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component c)
从接口 LayoutManager 复制的描述
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
c - 要移除的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container c)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的首选大小维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
c - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container c)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的最小大小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
c - 要布置的组件

layoutContainer

public void layoutContainer(Container c)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
c - 要布置的容器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicInternalFrameUI.InternalFramePropertyChangeListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicInternalFrameUI.InternalFramePropertyChangeListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicInternalFrameUI
public class BasicInternalFrameUI.InternalFramePropertyChangeListener
extends Object
implements PropertyChangeListener

构造方法摘要
BasicInternalFrameUI.InternalFramePropertyChangeListener()
方法摘要
 void propertyChange(PropertyChangeEvent evt)
从 JInternalFrame 检测状态更改并处理动作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicInternalFrameUI.InternalFramePropertyChangeListener

public BasicInternalFrameUI.InternalFramePropertyChangeListener()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent evt)
从 JInternalFrame 检测状态更改并处理动作。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
evt - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicLabelUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicLabelUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.LabelUI
            继承者  javax.swing.plaf.basic.BasicLabelUI
所有已实现的接口：
PropertyChangeListener, EventListener
直接已知子类：
MetalLabelUI
public class BasicLabelUI
extends LabelUI
implements PropertyChangeListener

LabelUI 的 Windows L&F 实现。此实现完全是静态的，即所有 JLabel 对象仅共享一种 UIView 实现。

字段摘要
protected static BasicLabelUI labelUI
默认 BasicLabelUI 实例。
构造方法摘要
BasicLabelUI()
方法摘要
static ComponentUI createUI(JComponent c)
 int getBaseline(JComponent c, int width, int height)
返回基线。
 Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
 Dimension getMaximumSize(JComponent c)
返回指定组件的适合外观的最大大小。
 Dimension getMinimumSize(JComponent c)
返回指定组件的适合外观的最小大小。
 Dimension getPreferredSize(JComponent c)
返回指定组件的适合外观的首选大小。
protected  void installComponents(JLabel c)
protected  void installDefaults(JLabel c)
protected  void installKeyboardActions(JLabel l)
protected  void installListeners(JLabel c)
 void installUI(JComponent c)
配置指定组件，使其适合外观。
protected  String layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
 void paint(Graphics g, JComponent c)
使用前景色绘制标签文本，如果标签不透明，则利用背景色绘制整个背景。
protected  void paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。
protected  void paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用标签的前景色将 clippedText 绘制在 textX、textY 处。
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
protected  void uninstallComponents(JLabel c)
protected  void uninstallDefaults(JLabel c)
protected  void uninstallKeyboardActions(JLabel c)
protected  void uninstallListeners(JLabel c)
 void uninstallUI(JComponent c)
在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

labelUI

protected static BasicLabelUI labelUI
默认 BasicLabelUI 实例。可以不使用此字段。要更改默认实例，请使用重写 createUI 方法的子类，并将该类名称置于默认表中 "LabelUI" 键之下。

构造方法详细信息

BasicLabelUI

public BasicLabelUI()
方法详细信息

layoutCL

protected String layoutCL(JLabel label,
                          FontMetrics fontMetrics,
                          String text,
                          Icon icon,
                          Rectangle viewR,
                          Rectangle iconR,
                          Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。此方法位于此处以便子类可执行特定于 Label 的布局，并可以使方法名简化一点。

另请参见：
SwingUtilities.layoutCompoundLabel(javax.swing.JComponent, java.awt.FontMetrics, java.lang.String, javax.swing.Icon, int, int, int, int, java.awt.Rectangle, java.awt.Rectangle, java.awt.Rectangle, int)

paintEnabledText

protected void paintEnabledText(JLabel l,
                                Graphics g,
                                String s,
                                int textX,
                                int textY)
利用标签的前景色将 clippedText 绘制在 textX、textY 处。

另请参见：
paint(java.awt.Graphics, javax.swing.JComponent), paintDisabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int)

paintDisabledText

protected void paintDisabledText(JLabel l,
                                 Graphics g,
                                 String s,
                                 int textX,
                                 int textY)
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。

另请参见：
paint(java.awt.Graphics, javax.swing.JComponent), paintEnabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int)

paint

public void paint(Graphics g,
                  JComponent c)
使用前景色绘制标签文本，如果标签不透明，则利用背景色绘制整个背景。Label 文本是由 paintEnabledText() 或 paintDisabledText() 绘制的。标签部分的位置由 layoutCL 计算。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
paintEnabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int), paintDisabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int), layoutCL(javax.swing.JLabel, java.awt.FontMetrics, java.lang.String, javax.swing.Icon, java.awt.Rectangle, java.awt.Rectangle, java.awt.Rectangle)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
getPreferredSize(c)
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
getPreferredSize(c)
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults(JLabel c)

installListeners

protected void installListeners(JLabel c)

installComponents

protected void installComponents(JLabel c)

installKeyboardActions

protected void installKeyboardActions(JLabel l)

uninstallDefaults

protected void uninstallDefaults(JLabel c)

uninstallListeners

protected void uninstallListeners(JLabel c)

uninstallComponents

protected void uninstallComponents(JLabel c)

uninstallKeyboardActions

protected void uninstallKeyboardActions(JLabel c)

createUI

public static ComponentUI createUI(JComponent c)

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicListUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicListUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ListUI
            继承者  javax.swing.plaf.basic.BasicListUI

public class BasicListUI
extends ListUI

ListUI 的可扩展实现。

多个列表之间不能共享 BasicListUI 实例。

嵌套类摘要
class | BasicListUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicListUI.ListDataHandler 在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。
class | BasicListUI.ListSelectionHandler 在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
class | BasicListUI.PropertyChangeHandler 在 installUI 时添加到 JList 的 PropertyChangeListener。
字段摘要
protected int | cellHeight
protected int[] | cellHeights
protected static int | cellRendererChanged
protected int | cellWidth
protected static int | fixedCellHeightChanged
protected static int | fixedCellWidthChanged
protected FocusListener | focusListener
protected static int | fontChanged
protected JList | list
protected ListDataListener | listDataListener
protected ListSelectionListener | listSelectionListener
protected static int | modelChanged
protected MouseInputListener | mouseInputListener
protected PropertyChangeListener | propertyChangeListener
protected static int | prototypeCellValueChanged
protected CellRendererPane | rendererPane
protected static int | selectionModelChanged
protected int | updateLayoutStateNeeded
构造方法摘要
BasicListUI()
方法摘要
protected  int convertRowToY(int row)
返回指定行的原点的 JList 相对 Y 坐标，如果 row 无效，则返回 -1。
protected  int convertYToRow(int y0)
基于当前布局，将 JList 相对坐标转换为包含它的行。
protected  FocusListener createFocusListener()
protected  ListDataListener createListDataListener()
创建在需要时由模型添加到 JList 的 ListDataListener 的实例。
protected  ListSelectionListener createListSelectionListener()
创建在需要时由 selectionModel 添加到 JList 的 ListSelectionHandler 的实例。
protected  MouseInputListener createMouseInputListener()
创建实现 MouseInputListener 的委托。
protected  PropertyChangeListener createPropertyChangeListener()
创建由 installUI() 添加到 JList 的 PropertyChangeHandler 的实例。
static ComponentUI createUI(JComponent list)
返回 BasicListUI 的新实例。
 int getBaseline(JComponent c, int width, int height)
返回基线。
 Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Rectangle getCellBounds(JList list, int index1, int index2)
返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
 Dimension getPreferredSize(JComponent c)
列表的 preferredSize 依赖于布局方向。
protected  int getRowHeight(int row)
返回基于当前布局的指定行的高度。
 Point indexToLocation(JList list, int index)
返回列表坐标系统中给定 JList 中指定项的原点。
protected  void installDefaults()
初始化 JList 属性（如字体、前景和背景）并添加 CellRendererPane。
protected  void installKeyboardActions()
在与 BasicListUI 关联的 JList 上注册键盘绑定。
protected  void installListeners()
为 JList、其模型及其 selectionModel 创建并安装侦听器。
 void installUI(JComponent c)
按顺序调用 installDefaults()、installListeners() 和 installKeyboardActions() 来初始化 this.list。
 int locationToIndex(JList list, Point location)
返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
protected  void maybeUpdateLayoutState()
如果 updateLayoutStateNeeded 为非 0，则调用 updateLayoutState() 并重置 updateLayoutStateNeeded。
 void paint(Graphics g, JComponent c)
绘制与 Graphics 对象 clipRect 相交的行。
protected  void paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。
protected  void selectNextIndex()
选择下一行并强行使其可见。
protected  void selectPreviousIndex()
选择前一行并强行使其可见。
protected  void uninstallDefaults()
将尚未显式重写的 JList 属性设置为 null。
protected  void uninstallKeyboardActions()
注销根据 installKeyboardActions 安装的键盘动作。
protected  void uninstallListeners()
移除 JList、其模型及其 selectionModel 的侦听器。
 void uninstallUI(JComponent c)
按顺序调用 uninstallListeners()、uninstallKeyboardActions() 和 uninstallDefaults() 来取消初始化 this.list。
protected  void updateLayoutState()
基于当前字体和 fixedCellWidth、fixedCellHeight 和 prototypeCellValue 的当前值重新计算 cellHeight（一个或多个）和 cellWidth 的值。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

list

protected JList list

rendererPane

protected CellRendererPane rendererPane

focusListener

protected FocusListener focusListener

mouseInputListener

protected MouseInputListener mouseInputListener

listSelectionListener

protected ListSelectionListener listSelectionListener

listDataListener

protected ListDataListener listDataListener

propertyChangeListener

protected PropertyChangeListener propertyChangeListener

cellHeights

protected int[] cellHeights

cellHeight

protected int cellHeight

cellWidth

protected int cellWidth

updateLayoutStateNeeded

protected int updateLayoutStateNeeded

modelChanged

protected static final int modelChanged
另请参见：
常量字段值

selectionModelChanged

protected static final int selectionModelChanged
另请参见：
常量字段值

fontChanged

protected static final int fontChanged
另请参见：
常量字段值

fixedCellWidthChanged

protected static final int fixedCellWidthChanged
另请参见：
常量字段值

fixedCellHeightChanged

protected static final int fixedCellHeightChanged
另请参见：
常量字段值

prototypeCellValueChanged

protected static final int prototypeCellValueChanged
另请参见：
常量字段值

cellRendererChanged

protected static final int cellRendererChanged
另请参见：
常量字段值
构造方法详细信息

BasicListUI

public BasicListUI()
方法详细信息

paintCell

protected void paintCell(Graphics g,
                         int row,
                         Rectangle rowBounds,
                         ListCellRenderer cellRenderer,
                         ListModel dataModel,
                         ListSelectionModel selModel,
                         int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。子类可能要重写此方法（而非 paint() 方法）。

另请参见：
paint(java.awt.Graphics, javax.swing.JComponent)

paint

public void paint(Graphics g,
                  JComponent c)
绘制与 Graphics 对象 clipRect 相交的行。此方法在必要时调用 paintCell。子类可能要重写这些方法。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
paintCell(java.awt.Graphics, int, java.awt.Rectangle, javax.swing.ListCellRenderer, javax.swing.ListModel, javax.swing.ListSelectionModel, int)

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
列表的 preferredSize 依赖于布局方向。
布局方向 | 首选大小
JList.VERTICAL | 列表的 preferredSize 是行的总高度和单元格的最大宽度。如果指定了 JList.fixedCellHeight，则行的总高度为 (cellVerticalMargins + fixedCellHeight) * model.getSize()，其中，rowVerticalMargins 是为绘制黄色焦点轮廓所分配的空间。同样，如果指定了 fixedCellWidth，则使用它即可。
JList.VERTICAL_WRAP | 如果可见行计数大于 0，则 preferredHeight 为最大单元格高度 * visibleRowCount。如果可见行计数 <= 0，则首选高度为列表的当前高度或最大单元格调试，取其中的较大者。首选宽度则为最大单元格宽度 * 所需的列数。其中所需的列数为 list.height / 最大单元格高度。最大单元格高度或者是固定单元高度，或者通过对所有单元格进行迭代以从 ListCellRenderer 中查找最大高度来确定。
JList.HORIZONTAL_WRAP 如果可见行计数大于 0，则 preferredHeight 即为最大单元格高度 * adjustedRowCount。其中 visibleRowCount 用于确定列数。因为此操作进行水平布置，所以行数将根据列数来确定。例如，假设一个模型有 10 个项和 8 个可见行计数。显示此模型所需的列数是 2，但是不再需要 8 行来显示，只需 5 行，因此 adjustedRowCount 为 5。

如果可见行计数 <= 0，则首选高度由列数规定，列数的多少以适合 JList 的宽度为准（宽度 / 最大单元格宽度），但至少为一列。首选高度则为模型大小 / 列数 * 最大单元格高度。最大单元格高度或者是固定单元高度，或者通过对所有单元格进行迭代以从 ListCellRenderer 中查找最大高度来确定。

上述内容指定原始首选宽度和高度。所产生的首选宽度为上述宽度 + insets.left + insets.right，所产生的首选高度为上述高度 + insets.top + insets.bottom。其中 Insets 根据 list.getInsets() 确定。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - JList 组件。
返回：
列表的总大小。
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

selectPreviousIndex

protected void selectPreviousIndex()
选择前一行并强行使其可见。

另请参见：
JList.ensureIndexIsVisible(int)

selectNextIndex

protected void selectNextIndex()
选择下一行并强行使其可见。

另请参见：
JList.ensureIndexIsVisible(int)

installKeyboardActions

protected void installKeyboardActions()
在与 BasicListUI 关联的 JList 上注册键盘绑定。此方法在 installUI() 时调用。

另请参见：
installUI(javax.swing.JComponent)

uninstallKeyboardActions

protected void uninstallKeyboardActions()
注销根据 installKeyboardActions 安装的键盘动作。此方法在 uninstallUI() 时调用，该时刻子类应该确保已从此处移除在 installUI 时注册的所有键盘动作。

另请参见：
installUI(javax.swing.JComponent)

installListeners

protected void installListeners()
为 JList、其模型及其 selectionModel 创建并安装侦听器。此方法在 installUI() 时调用。

另请参见：
installUI(javax.swing.JComponent), uninstallListeners()

uninstallListeners

protected void uninstallListeners()
移除 JList、其模型及其 selectionModel 的侦听器。所有侦听器字段都将在此被重置为 null。在 uninstallUI() 时调用此方法，它应该与 installListeners 保持同步。

另请参见：
uninstallUI(javax.swing.JComponent), installListeners()

installDefaults

protected void installDefaults()
初始化 JList 属性（如字体、前景和背景）并添加 CellRendererPane。仅当字体、前景和背景属性的当前值为 null 或 UIResource 时才设置这些属性，其他属性在当前值为 null 时设置。

另请参见：
uninstallDefaults(), installUI(javax.swing.JComponent), CellRendererPane

uninstallDefaults

protected void uninstallDefaults()
将尚未显式重写的 JList 属性设置为 null。如果某个属性的当前值不是 UIResource，则视为被重写。

另请参见：
installDefaults(), uninstallUI(javax.swing.JComponent), CellRendererPane

installUI

public void installUI(JComponent c)
按顺序调用 installDefaults()、installListeners() 和 installKeyboardActions() 来初始化 this.list。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
installDefaults(),
installListeners(),
installKeyboardActions()

uninstallUI

public void uninstallUI(JComponent c)
按顺序调用 uninstallListeners()、uninstallKeyboardActions() 和 uninstallDefaults() 来取消初始化 this.list。将 this.list 设置为 null。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
uninstallListeners(),
uninstallKeyboardActions(),
uninstallDefaults()

createUI

public static ComponentUI createUI(JComponent list)
返回 BasicListUI 的新实例。为每个 JList 分配一个 BasicListUI 委托。

返回：
Windows 外观的新的 ListUI 实现。

locationToIndex

public int locationToIndex(JList list,
                           Point location)
返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。要确定该单元是否真正包含指定位置，可比较该点与单元的边界，单元的边界通过 getCellBounds 提供。如果列表的模式为空，则此方法返回 -1。

指定者：
类 ListUI 中的 locationToIndex
参数：
list - 列表
location - 点的坐标
返回：
与给定位置最接近的单元索引或 -1
抛出：
NullPointerException - 如果 location 为 null

indexToLocation

public Point indexToLocation(JList list,
                             int index)
返回列表坐标系统中给定 JList 中指定项的原点。如果索引无效，则返回 null 。

指定者：
类 ListUI 中的 indexToLocation
参数：
list - 列表
index - 单元索引
返回：
单元的原点或 null

getCellBounds

public Rectangle getCellBounds(JList list,
                               int index1,
                               int index2)
返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。可以按任意顺序提供索引。

如果较小索引超出单元的列表范围，则此方法返回 null。如果较小索引有效，但较大索引超出列表范围，则只返回第一个索引的边界。否则，返回有效范围的边界。

指定者：
类 ListUI 中的 getCellBounds
参数：
list - 列表
index1 - 范围内第一个索引
index2 - 范围内第二个索引
返回：
单元范围的有界矩形或 null

getRowHeight

protected int getRowHeight(int row)
返回基于当前布局的指定行的高度。

返回：
指定行高度，如果 row 无效，则返回 -1。
另请参见：
convertYToRow(int), convertRowToY(int), updateLayoutState()

convertYToRow

protected int convertYToRow(int y0)
基于当前布局，将 JList 相对坐标转换为包含它的行。如果 y0 没有落在任何行中，则返回 -1。

返回：
包含 y0 的行，或者返回 -1。
另请参见：
getRowHeight(int), updateLayoutState()

convertRowToY

protected int convertRowToY(int row)
返回指定行的原点的 JList 相对 Y 坐标，如果 row 无效，则返回 -1。

返回：
包含行原点的 Y 坐标，或者返回 -1。
另请参见：
getRowHeight(int), updateLayoutState()

maybeUpdateLayoutState

protected void maybeUpdateLayoutState()
如果 updateLayoutStateNeeded 为非 0，则调用 updateLayoutState() 并重置 updateLayoutStateNeeded。各种方法在进行任何基于列表几何形状的计算之前应该调用此方法。例如，在 paint() 和 getPreferredSize() 中首先调用此方法。

另请参见：
updateLayoutState()

updateLayoutState

protected void updateLayoutState()
基于当前字体和 fixedCellWidth、fixedCellHeight 和 prototypeCellValue 的当前值重新计算 cellHeight（一个或多个）和 cellWidth 的值。

另请参见：
maybeUpdateLayoutState()

createMouseInputListener

protected MouseInputListener createMouseInputListener()
创建实现 MouseInputListener 的委托。委托在 installUI() 时被添加到相应的 java.awt.Component 侦听器列表中。子类可以重写此方法以返回自定义 MouseInputListener，例如
 class MyListUI extends BasicListUI {
    protected MouseInputListener createMouseInputListener() {
        return new MyMouseInputHandler();
    }
    public class MyMouseInputHandler extends MouseInputHandler {
        public void mouseMoved(MouseEvent e) {
            // do some extra work when the mouse moves
            super.mouseMoved(e);
        }
    }
 }

另请参见：
BasicListUI.MouseInputHandler, installUI(javax.swing.JComponent)

createFocusListener

protected FocusListener createFocusListener()

createListSelectionListener

protected ListSelectionListener createListSelectionListener()
创建在需要时由 selectionModel 添加到 JList 的 ListSelectionHandler 的实例。子类可以重写此方法以返回自定义 ListSelectionListener，例如
 class MyListUI extends BasicListUI {
    protected ListSelectionListener createListSelectionListener() {
        return new MySelectionListener();
    }
    public class MySelectionListener extends ListSelectionHandler {
        public void valueChanged(ListSelectionEvent e) {
            // do some extra work when the selection changes
            super.valueChange(e);
        }
    }
 }

另请参见：
BasicListUI.ListSelectionHandler, installUI(javax.swing.JComponent)

createListDataListener

protected ListDataListener createListDataListener()
创建在需要时由模型添加到 JList 的 ListDataListener 的实例。子类可以重写此方法以返回自定义 ListDataListener，例如
 class MyListUI extends BasicListUI {
    protected ListDataListener createListDataListener() {
        return new MyListDataListener();
    }
    public class MyListDataListener extends ListDataHandler {
        public void contentsChanged(ListDataEvent e) {
            // do some extra work when the models contents change
            super.contentsChange(e);
        }
    }
 }

另请参见：
ListDataListener, JList.getModel(), installUI(javax.swing.JComponent)

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
创建由 installUI() 添加到 JList 的 PropertyChangeHandler 的实例。子类可以重写此方法以返回自定义 PropertyChangeListener，例如
 class MyListUI extends BasicListUI {
    protected PropertyChangeListener createPropertyChangeListener() {
        return new MyPropertyChangeListener();
    }
    public class MyPropertyChangeListener extends PropertyChangeHandler {
        public void propertyChange(PropertyChangeEvent e) {
            if (e.getPropertyName().equals("model")) {
                // do some extra work when the model changes
            }
            super.propertyChange(e);
        }
    }
 }

另请参见：
PropertyChangeListener, installUI(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicListUI.FocusHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicListUI.FocusHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicListUI.FocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
BasicListUI
public class BasicListUI.FocusHandler
extends Object
implements FocusListener

此内部类因编译器故障而被标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicTableUI 的子类中实例化此类。

构造方法摘要
BasicListUI.FocusHandler()
方法摘要
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
protected void | repaintCellFocus()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicListUI.FocusHandler

public BasicListUI.FocusHandler()
方法详细信息

repaintCellFocus

protected void repaintCellFocus()

focusGained

public void focusGained(FocusEvent e)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicListUI.ListDataHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicListUI.ListDataHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicListUI.ListDataHandler
所有已实现的接口：
EventListener, ListDataListener
正在封闭类：
BasicListUI
public class BasicListUI.ListDataHandler
extends Object
implements ListDataListener

在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JList.getModel(),
BasicListUI.maybeUpdateLayoutState(),
BasicListUI.createListDataListener(),
BasicListUI.installUI(javax.swing.JComponent)

构造方法摘要
BasicListUI.ListDataHandler()
方法摘要
void | contentsChanged(ListDataEvent e) 在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。
void | intervalAdded(ListDataEvent e) 在已将 index0,index1 区间中的索引插入数据模型中之后发送。
void | intervalRemoved(ListDataEvent e) 在已将 index0,index1 区间中的索引从数据模型中移除后发送。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicListUI.ListDataHandler

public BasicListUI.ListDataHandler()
方法详细信息

intervalAdded

public void intervalAdded(ListDataEvent e)
从接口 ListDataListener 复制的描述
在已将 index0,index1 区间中的索引插入数据模型中之后发送。新区间既包括 index0 也包括 index1。

指定者：
接口 ListDataListener 中的 intervalAdded
参数：
e - 封装事件信息的 ListDataEvent

intervalRemoved

public void intervalRemoved(ListDataEvent e)
从接口 ListDataListener 复制的描述
在已将 index0,index1 区间中的索引从数据模型中移除后发送。该区间既包括 index0 也包括 index1。

指定者：
接口 ListDataListener 中的 intervalRemoved
参数：
e - 封装事件信息的 ListDataEvent

contentsChanged

public void contentsChanged(ListDataEvent e)
从接口 ListDataListener 复制的描述
在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。例如，在已经替换某个项时发送此方法。Index0 和 index1 括出了该范围。

指定者：
接口 ListDataListener 中的 contentsChanged
参数：
e - 封装事件信息的 ListDataEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicListUI.ListSelectionHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicListUI.ListSelectionHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicListUI.ListSelectionHandler
所有已实现的接口：
EventListener, ListSelectionListener
正在封闭类：
BasicListUI
public class BasicListUI.ListSelectionHandler
extends Object
implements ListSelectionListener

在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。选择更改时，重绘受影响的行。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
BasicListUI.createListSelectionListener(),
BasicListUI.getCellBounds(javax.swing.JList, int, int),
BasicListUI.installUI(javax.swing.JComponent)

构造方法摘要
BasicListUI.ListSelectionHandler()
方法摘要
 void valueChanged(ListSelectionEvent e)
每当选择值发生更改时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicListUI.ListSelectionHandler

public BasicListUI.ListSelectionHandler()
方法详细信息

valueChanged

public void valueChanged(ListSelectionEvent e)
从接口 ListSelectionListener 复制的描述
每当选择值发生更改时调用。

指定者：
接口 ListSelectionListener 中的 valueChanged
参数：
e - 表现更改的特征的事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicListUI.MouseInputHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicListUI.MouseInputHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicListUI.MouseInputHandler
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
正在封闭类：
BasicListUI
public class BasicListUI.MouseInputHandler
extends Object
implements MouseInputListener

鼠标输入和 JList 的焦点处理。在 installUI() 时将此类的实例添加到适当的 java.awt.Component 列表中。注意，利用 JComponent KeyboardAction 处理键盘输入，请参阅 installKeyboardActions()。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
BasicListUI.createMouseInputListener(),
BasicListUI.installKeyboardActions(),
BasicListUI.installUI(javax.swing.JComponent)

构造方法摘要
BasicListUI.MouseInputHandler()
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicListUI.MouseInputHandler

public BasicListUI.MouseInputHandler()
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mouseEntered

public void mouseEntered(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved

mouseReleased

public void mouseReleased(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicListUI.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicListUI.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicListUI
public class BasicListUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

在 installUI 时添加到 JList 的 PropertyChangeListener。当影响布局的 JList 属性的值更改时，需要在 updateLayoutStateNeeded 中设置一个位。此外，如果 JList 模型更改，还需要从旧模型中移除侦听器。对于 JList selectionModel 也是如此。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
BasicListUI.maybeUpdateLayoutState(),
BasicListUI.createPropertyChangeListener(),
BasicListUI.installUI(javax.swing.JComponent)

构造方法摘要
BasicListUI.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicListUI.PropertyChangeHandler

public BasicListUI.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicLookAndFeel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicLookAndFeel

java.lang.Object
    继承者  javax.swing.LookAndFeel
        继承者  javax.swing.plaf.basic.BasicLookAndFeel
所有已实现的接口：
Serializable
直接已知子类：
MetalLookAndFeel, SynthLookAndFeel
public abstract class BasicLookAndFeel
extends LookAndFeel
implements Serializable

为 Swing 创建外观时要使用的基类。

BasicLookAndFeel 提供的每个 ComponentUI 根据默认表派生其行为。除非另行说明，否则此包中的每个 ComponentUI 将记录他们所使用的默认值集合。除非另行说明，否则在调用 installUI 时将安装该默认值，并在安装默认值时遵循 LookAndFeel 中所描述的建议。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
BasicLookAndFeel()
方法摘要
protected Action | createAudioAction(Object key) 创建并返回用于播放音频的 Action。
protected ActionMap | getAudioActionMap() 返回包含此外观音频动作的 ActionMap。
UIDefaults | getDefaults() 返回外观默认值。
protected void | initClassDefaults(UIDefaults table) 用从 uiClassID 到 ui 类的完全限定名称的映射关系填充 table。
protected void | initComponentDefaults(UIDefaults table) 用基本外观的默认值填充 table。
void | initialize() 初始化外观。
protected void | initSystemColorDefaults(UIDefaults table) 用系统颜色填充 table。
protected void | loadSystemColors(UIDefaults table, String[] systemColors, boolean useNative) 用 systemColors 中的 name-color 对填充 table。
protected void | playSound(Action audioAction) 如有必要，在 audioAction 上调用 actionPerformed 以播放声音。
void | uninitialize() 取消初始化外观。
从类 javax.swing.LookAndFeel 继承的方法
getDescription, getDesktopPropertyValue, getDisabledIcon, getDisabledSelectedIcon, getID, getLayoutStyle, getName, getSupportsWindowDecorations, installBorder, installColors, installColorsAndFont, installProperty, isNativeLookAndFeel, isSupportedLookAndFeel, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, provideErrorFeedback, toString, uninstallBorder
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BasicLookAndFeel

public BasicLookAndFeel()
方法详细信息

getDefaults

public UIDefaults getDefaults()
返回外观默认值。通过按顺序调用 initClassDefaults、initSystemColorDefaults 和 initComponentDefaults 填充返回的 UIDefaults。

尽管此方法是公共的，但它只有在外观被设置为当前外观并在调用 initialize 之后时才由 UIManager 调用。

覆盖：
类 LookAndFeel 中的 getDefaults
返回：
外观默认值
另请参见：
initClassDefaults(javax.swing.UIDefaults),
initSystemColorDefaults(javax.swing.UIDefaults),
initComponentDefaults(javax.swing.UIDefaults)

initialize

public void initialize()
初始化外观。尽管此方法是公共的，但只有在外观作为当前外观安装时才能由 UIManager 调用。在 UIManager 调用 getDefaults 之前调用此方法。此方法用于执行外观的任何初始化。子类应该用此方法而不是静态初始化程序来执行它们需要的任何一次设置，因为也可能只是为了发现 isSupportedLookAndFeel() 返回 false 而加载外观类对象。

覆盖：
类 LookAndFeel 中的 initialize
另请参见：
LookAndFeel.uninitialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

uninitialize

public void uninitialize()
取消初始化外观。尽管此方法是公共的，但只有在卸载外观时才能由 UIManager 调用。例如，外观更改时 UIManager.setLookAndFeel 调用此方法。

子类在此处可以选择释放一些资源。

覆盖：
类 LookAndFeel 中的 uninitialize
另请参见：
LookAndFeel.initialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

initClassDefaults

protected void initClassDefaults(UIDefaults table)
用从 uiClassID 到 ui 类的完全限定名称的映射关系填充 table。特定 uiClassID 的值为 "javax.swing.plaf.basic.Basic + uiClassID"。例如，uiClassID TreeUI 的值为 "javax.swing.plaf.basic.BasicTreeUI"。

参数：
table - 要添加项的 UIDefaults 实例
抛出：
NullPointerException - 如果 table 为 null
另请参见：
LookAndFeel, getDefaults()

initSystemColorDefaults

protected void initSystemColorDefaults(UIDefaults table)
用系统颜色填充 table。此方法创建一个 name-color 对的数组并调用 loadSystemColors。

该名称是对应于 SystemColor 类中一个静态 SystemColor 字段名称的 String。名称-颜色对用于创建每个这样的 SystemColor 字段。

color 对应于 Color.decode 所理解的十六进制 String。例如，一个 name-color 对是 "desktop"-"#005C5C"。这对应于 SystemColor 字段 desktop，其颜色值为 new Color(0x005C5C)。

以下显示了两个 name-color 对：

   String[] nameColorPairs = new String[] {
          "desktop", "#005C5C",
    "activeCaption", "#000080" };
   loadSystemColors(table, nameColorPairs, isNativeLookAndFeel());
如前所述，此方法使用提供的 table 和 name-color 对数组调用 loadSystemColors。loadSystemColors 的最后一个参数指示是否应该使用 SystemColor 中字段的值。此方法将 isNativeLookAndFeel() 的值作为最后一个参数传递给 loadSystemColors。

参数：
table - 要添加值的 UIDefaults 对象
抛出：
NullPointerException - 如果 table 为 null
另请参见：
SystemColor, getDefaults(), loadSystemColors(javax.swing.UIDefaults, java.lang.String[], boolean)

loadSystemColors

protected void loadSystemColors(UIDefaults table,
                                String[] systemColors,
                                boolean useNative)
用 systemColors 中的 name-color 对填充 table。有关 systemColors 格式的详细信息，请参阅 initSystemColorDefaults(UIDefaults)。

为 systemColors 中的每个 name-color 对添加一个项到 table。该项键是 name-color 对的 name。

该项的值对应于 name-color 对的 color。该项的值以两种方式之一进行计算。无论使用哪种方法，该值始终是 ColorUIResource。

如果 useNative 为 false，则通过使用 Color.decode 将 String 转换为 Color 来创建 color。如果 decode 不能将 String 转换为 Color（抛出 NumberFormatException），则使用黑色的 ColorUIResource。

如果 useNative 为 true，则 color 是 SystemColor 中字段的值，其名称与 name-color 对的 name 相同。如果该字段无效，则使用黑色的 ColorUIResource。

参数：
table - 要添加值的 UIDefaults 对象
systemColors - initSystemColorDefaults(UIDefaults) 中所述的 name-color 对数组
useNative - 该颜色是否可以从 SystemColor 或 Color.decode 获得
抛出：
NullPointerException - 如果 systemColors 为 null；或者 systemColors 不为空，并且 table 为 null；或者 name-color 对的 name 之一为 null；或者 useNative 为 false ，并且 name-color 对的 color 之一为 null
ArrayIndexOutOfBoundsException - 如果 useNative 为 false ，并且 systemColors.length 为奇数
另请参见：
initSystemColorDefaults(javax.swing.UIDefaults), SystemColor, Color.decode(String)

initComponentDefaults

protected void initComponentDefaults(UIDefaults table)
用基本外观的默认值填充 table。

参数：
table - 要添加值的 UIDefaults
抛出：
NullPointerException - 如果 table 为 null

getAudioActionMap

protected ActionMap getAudioActionMap()
返回包含此外观音频动作的 ActionMap。

返回的 ActionMap 包含具有呈现听觉提示能力的 Action。这些听觉提示映射到用户和可能帮助最终用户了解的系统活动（如对话框的出现）。

在适当时间，ComponentUI 负责从 ActionMap 获得 Action 并将它传递给 playSound。

此方法首先使用 "AuditoryCues.actionMap" 键从默认值中查找 ActionMap。

如果值为非 null，则返回该值。如果默认 "AuditoryCues.actionMap" 的值为 null ，并且默认 "AuditoryCues.cueList" 的值为非 null，则创建一个 ActionMapUIResource 并进行填充。通过对 "AuditoryCues.cueList" 数组中的每个元素进行迭代来完成填充，通过调用 createAudioAction() 为每个元素创建 Action。以数组元素为键将所得的 Action 置于 ActionMapUIResource 中。例如，如果 "AuditoryCues.cueList" 数组包含单个元素（"audioKey"），则创建一个 ActionMapUIResource，然后通过 actionMap.put(cueList[0], createAudioAction(cueList[0])) 填充。

如果默认 "AuditoryCues.actionMap" 的值为 null ，并且默认 "AuditoryCues.cueList" 的值为 null，则创建一个空 ActionMapUIResource。

返回：
包含负责播放听觉提示的 Action 的 ActionMap
抛出：
ClassCastException - 如果默认 "AuditoryCues.actionMap" 的值不为 ActionMap，或者默认 "AuditoryCues.cueList" 的值不为 Object[]
从以下版本开始：
1.4
另请参见：
createAudioAction(java.lang.Object), playSound(Action)

createAudioAction

protected Action createAudioAction(Object key)
创建并返回用于播放音频的 Action。

如果 key 为非 null，则使用取自带有 key 键的默认值的值创建 Action。当在 Action 上调用 actionPerformed 时，该值标识要加载的音源。通过 getClass().getResourceAsStream() 将音源加载到 byte[]。

参数：
key - 标识音频动作的键
返回：
用于播放该源的 Action；如果 key 为 null，则返回 null
从以下版本开始：
1.4
另请参见：
playSound(Action)

playSound

protected void playSound(Action audioAction)
如有必要，在 audioAction 上调用 actionPerformed 以播放声音。如果 "AuditoryCues.playList" 默认的值为非 null Object[]（包含与 audioAction 的名称相等的 String 项），则调用 actionPerformed 方法。

参数：
audioAction - 知道如何呈现与系统或用户活动关联的正在发生的 Action；忽略 null 值
抛出：
ClassCastException - 如果 audioAction 为非 null ，并且默认 "AuditoryCues.playList" 的值不为 Object[]
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicMenuBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicMenuBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.MenuBarUI
            继承者  javax.swing.plaf.basic.BasicMenuBarUI
直接已知子类：
MetalMenuBarUI
public class BasicMenuBarUI
extends MenuBarUI

MenuBarUI 的默认 L&F 实现。此实现是一个“组合的”视图/控制器。

字段摘要
protected ChangeListener | changeListener
protected ContainerListener | containerListener
protected JMenuBar | menuBar
构造方法摘要
BasicMenuBarUI()
方法摘要
protected ChangeListener | createChangeListener()
protected ContainerListener | createContainerListener()
static ComponentUI | createUI(JComponent x)
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
protected void | installDefaults()
protected void | installKeyboardActions()
protected void | installListeners()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

menuBar

protected JMenuBar menuBar

containerListener

protected ContainerListener containerListener

changeListener

protected ChangeListener changeListener
构造方法详细信息

BasicMenuBarUI

public BasicMenuBarUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

installDefaults

protected void installDefaults()

installListeners

protected void installListeners()

installKeyboardActions

protected void installKeyboardActions()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

uninstallDefaults

protected void uninstallDefaults()

uninstallListeners

protected void uninstallListeners()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

createContainerListener

protected ContainerListener createContainerListener()

createChangeListener

protected ChangeListener createChangeListener()

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicMenuItemUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicMenuItemUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.MenuItemUI
                继承者  javax.swing.plaf.basic.BasicMenuItemUI
直接已知子类：
BasicCheckBoxMenuItemUI, BasicMenuUI, BasicRadioButtonMenuItemUI
public class BasicMenuItemUI
extends MenuItemUI

BasicMenuItem 实现

嵌套类摘要
protected  class BasicMenuItemUI.MouseInputHandler
字段摘要
protected Font | acceleratorFont
protected Color | acceleratorForeground
protected Color | acceleratorSelectionForeground
protected Icon | arrowIcon
protected Icon | checkIcon
protected int | defaultTextIconGap
protected Color | disabledForeground
protected MenuDragMouseListener | menuDragMouseListener
protected JMenuItem | menuItem
protected MenuKeyListener | menuKeyListener
protected MouseInputListener | mouseInputListener
protected boolean | oldBorderPainted
protected PropertyChangeListener | propertyChangeListener 从 createPropertyChangeListener 返回的 PropertyChangeListener。
protected Color | selectionBackground
protected Color | selectionForeground
构造方法摘要
BasicMenuItemUI()
方法摘要
protected  MenuDragMouseListener createMenuDragMouseListener(JComponent c)
protected  MenuKeyListener createMenuKeyListener(JComponent c)
protected  MouseInputListener createMouseInputListener(JComponent c)
protected  PropertyChangeListener createPropertyChangeListener(JComponent c)
创建一个将被添加到菜单项的 PropertyChangeListener。
static ComponentUI createUI(JComponent c)
protected  void doClick(MenuSelectionManager msm)
要激活菜单项时调用此方法。
 Dimension getMaximumSize(JComponent c)
返回指定组件的适合外观的最大大小。
 Dimension getMinimumSize(JComponent c)
返回指定组件的适合外观的最小大小。
 MenuElement[] getPath()
protected  Dimension getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
 Dimension getPreferredSize(JComponent c)
返回指定组件的适合外观的首选大小。
protected  String getPropertyPrefix()
protected  void installComponents(JMenuItem menuItem)
protected  void installDefaults()
protected  void installKeyboardActions()
protected  void installListeners()
 void installUI(JComponent c)
配置指定组件，使其适合外观。
 void paint(Graphics g, JComponent c)
绘制指定组件，使其适合外观。
protected  void paintBackground(Graphics g, JMenuItem menuItem, Color bgColor)
绘制菜单项的背景。
protected  void paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
protected  void paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
呈现当前菜单项的文本。
protected  void uninstallComponents(JMenuItem menuItem)
protected  void uninstallDefaults()
protected  void uninstallKeyboardActions()
protected  void uninstallListeners()
 void uninstallUI(JComponent c)
在 installUI 期间，在指定组件上反向执行的配置操作。
 void update(Graphics g, JComponent c)
使用 paintMenuItem() 绘制背景，从而重写 update（默认情况下填充不透明组件的背景）以调用 paint()。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

menuItem

protected JMenuItem menuItem

selectionBackground

protected Color selectionBackground

selectionForeground

protected Color selectionForeground

disabledForeground

protected Color disabledForeground

acceleratorForeground

protected Color acceleratorForeground

acceleratorSelectionForeground

protected Color acceleratorSelectionForeground

defaultTextIconGap

protected int defaultTextIconGap

acceleratorFont

protected Font acceleratorFont

mouseInputListener

protected MouseInputListener mouseInputListener

menuDragMouseListener

protected MenuDragMouseListener menuDragMouseListener

menuKeyListener

protected MenuKeyListener menuKeyListener

propertyChangeListener

protected PropertyChangeListener propertyChangeListener
从 createPropertyChangeListener 返回的 PropertyChangeListener。不需要访问此字段，如果想要定制 PropertyChangeListener，则重写 createPropertyChangeListener。

从以下版本开始：
1.6
另请参见：
createPropertyChangeListener(javax.swing.JComponent)

arrowIcon

protected Icon arrowIcon

checkIcon

protected Icon checkIcon

oldBorderPainted

protected boolean oldBorderPainted
构造方法详细信息

BasicMenuItemUI

public BasicMenuItemUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

installDefaults

protected void installDefaults()

installComponents

protected void installComponents(JMenuItem menuItem)
从以下版本开始：
1.3

getPropertyPrefix

protected String getPropertyPrefix()

installListeners

protected void installListeners()

installKeyboardActions

protected void installKeyboardActions()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

uninstallDefaults

protected void uninstallDefaults()

uninstallComponents

protected void uninstallComponents(JMenuItem menuItem)
从以下版本开始：
1.3

uninstallListeners

protected void uninstallListeners()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

createMouseInputListener

protected MouseInputListener createMouseInputListener(JComponent c)

createMenuDragMouseListener

protected MenuDragMouseListener createMenuDragMouseListener(JComponent c)

createMenuKeyListener

protected MenuKeyListener createMenuKeyListener(JComponent c)

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener(JComponent c)
创建一个将被添加到菜单项的 PropertyChangeListener。如果此方法返回 null，则它将不会被添加到菜单项。

返回：
PropertyChangeListener 的实例或 null
从以下版本开始：
1.6

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getPreferredMenuItemSize

protected Dimension getPreferredMenuItemSize(JComponent c,
                                             Icon checkIcon,
                                             Icon arrowIcon,
                                             int defaultTextIconGap)

update

public void update(Graphics g,
                   JComponent c)
使用 paintMenuItem() 绘制背景，从而重写 update（默认情况下填充不透明组件的背景）以调用 paint()。

覆盖：
类 ComponentUI 中的 update
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintMenuItem

protected void paintMenuItem(Graphics g,
                             JComponent c,
                             Icon checkIcon,
                             Icon arrowIcon,
                             Color background,
                             Color foreground,
                             int defaultTextIconGap)

paintBackground

protected void paintBackground(Graphics g,
                               JMenuItem menuItem,
                               Color bgColor)
绘制菜单项的背景。

参数：
g - 绘制图形
menuItem - 要绘制的菜单项
bgColor - 选择背景色
从以下版本开始：
1.4

paintText

protected void paintText(Graphics g,
                         JMenuItem menuItem,
                         Rectangle textRect,
                         String text)
呈现当前菜单项的文本。

参数：
g - 图形上下文
menuItem - 要呈现的菜单项
textRect - 用于呈现文本的边界矩形
text - 要呈现的字符串
从以下版本开始：
1.4

getPath

public MenuElement[] getPath()

doClick

protected void doClick(MenuSelectionManager msm)
要激活菜单项时调用此方法。此方法处理某些菜单项激活的细节，如清除所选路径和传递 JMenuItem's doClick() 方法的消息。

参数：
msm - MenuSelectionManager。将可视化反馈和内部簿记任务委托给此 MenuSelectionManager。如果将 null 作为此方法的参数传递，则使用 MenuSelectionManager.defaultManager。
从以下版本开始：
1.4
另请参见：
MenuSelectionManager, AbstractButton.doClick(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicMenuItemUI.MouseInputHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicMenuItemUI.MouseInputHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
正在封闭类：
BasicMenuItemUI
protected class BasicMenuItemUI.MouseInputHandler
extends Object
implements MouseInputListener

构造方法摘要
protected BasicMenuItemUI.MouseInputHandler()
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicMenuItemUI.MouseInputHandler

protected BasicMenuItemUI.MouseInputHandler()
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased

mouseEntered

public void mouseEntered(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicMenuUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicMenuUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.MenuItemUI
                继承者  javax.swing.plaf.basic.BasicMenuItemUI
                    继承者  javax.swing.plaf.basic.BasicMenuUI

public class BasicMenuUI
extends BasicMenuItemUI

MenuUI 的默认 L&F 实现。此实现是一个“组合的”视图/控制器。

嵌套类摘要
class | BasicMenuUI.ChangeHandler 从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
字段摘要
protected ChangeListener | changeListener
protected MenuListener | menuListener
从类 javax.swing.plaf.basic.BasicMenuItemUI 继承的字段
acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground
构造方法摘要
BasicMenuUI()
方法摘要
protected ChangeListener | createChangeListener(JComponent c)
protected MenuDragMouseListener | createMenuDragMouseListener(JComponent c)
protected MenuKeyListener | createMenuKeyListener(JComponent c)
protected MenuListener | createMenuListener(JComponent c)
protected MouseInputListener | createMouseInputListener(JComponent c)
protected PropertyChangeListener | createPropertyChangeListener(JComponent c) 创建一个将被添加到菜单项的 PropertyChangeListener。
static ComponentUI | createUI(JComponent x)
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
protected String | getPropertyPrefix()
protected void | installDefaults()
protected void | installKeyboardActions()
protected void | installListeners()
protected void | setupPostTimer(JMenu menu)
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
从类 javax.swing.plaf.basic.BasicMenuItemUI 继承的方法
doClick, getMinimumSize, getPath, getPreferredMenuItemSize, getPreferredSize, installComponents, installUI, paint, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallUI, update
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

changeListener

protected ChangeListener changeListener

menuListener

protected MenuListener menuListener
构造方法详细信息

BasicMenuUI

public BasicMenuUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

installDefaults

protected void installDefaults()
覆盖：
类 BasicMenuItemUI 中的 installDefaults

getPropertyPrefix

protected String getPropertyPrefix()
覆盖：
类 BasicMenuItemUI 中的 getPropertyPrefix

installListeners

protected void installListeners()
覆盖：
类 BasicMenuItemUI 中的 installListeners

installKeyboardActions

protected void installKeyboardActions()
覆盖：
类 BasicMenuItemUI 中的 installKeyboardActions

uninstallKeyboardActions

protected void uninstallKeyboardActions()
覆盖：
类 BasicMenuItemUI 中的 uninstallKeyboardActions

createMouseInputListener

protected MouseInputListener createMouseInputListener(JComponent c)
覆盖：
类 BasicMenuItemUI 中的 createMouseInputListener

createMenuListener

protected MenuListener createMenuListener(JComponent c)

createChangeListener

protected ChangeListener createChangeListener(JComponent c)

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener(JComponent c)
从类 BasicMenuItemUI 复制的描述
创建一个将被添加到菜单项的 PropertyChangeListener。如果此方法返回 null，则它将不会被添加到菜单项。

覆盖：
类 BasicMenuItemUI 中的 createPropertyChangeListener
返回：
PropertyChangeListener 的实例或 null

uninstallDefaults

protected void uninstallDefaults()
覆盖：
类 BasicMenuItemUI 中的 uninstallDefaults

uninstallListeners

protected void uninstallListeners()
覆盖：
类 BasicMenuItemUI 中的 uninstallListeners

createMenuDragMouseListener

protected MenuDragMouseListener createMenuDragMouseListener(JComponent c)
覆盖：
类 BasicMenuItemUI 中的 createMenuDragMouseListener

createMenuKeyListener

protected MenuKeyListener createMenuKeyListener(JComponent c)
覆盖：
类 BasicMenuItemUI 中的 createMenuKeyListener

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 BasicMenuItemUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

setupPostTimer

protected void setupPostTimer(JMenu menu)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicMenuUI.ChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicMenuUI.ChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
所有已实现的接口：
EventListener, ChangeListener
正在封闭类：
BasicMenuUI
public class BasicMenuUI.ChangeHandler
extends Object
implements ChangeListener

从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。KeyBinding 现在由弹出菜单管理。

字段摘要
boolean | isSelected
JMenu | menu
BasicMenuUI | ui
Component | wasFocused
构造方法摘要
BasicMenuUI.ChangeHandler(JMenu m, BasicMenuUI ui)
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

menu

public JMenu menu

ui

public BasicMenuUI ui

isSelected

public boolean isSelected

wasFocused

public Component wasFocused
构造方法详细信息

BasicMenuUI.ChangeHandler

public BasicMenuUI.ChangeHandler(JMenu m,
                                 BasicMenuUI ui)
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicMenuUI.MouseInputHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicMenuUI.MouseInputHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
正在封闭类：
BasicMenuUI
protected class BasicMenuUI.MouseInputHandler
extends Object
implements MouseInputListener

实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。MouseInputHandler 处理所有鼠标事件，将其转发到 MenuSelectionManager 的共享实例。

此类是受保护的，其他外观可以为其创建子类以实现它们自己的鼠标处理行为。所有重写方法都应该调用父方法以便正确选择菜单。

从以下版本开始：
1.4
另请参见：
MenuSelectionManager

构造方法摘要
protected BasicMenuUI.MouseInputHandler()
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 在菜单上按下鼠标按键并随后拖动鼠标时调用。
void | mouseEntered(MouseEvent e) 在指针进入菜单时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 在菜单上单击鼠标时调用。
void | mouseReleased(MouseEvent e) 在菜单上释放鼠标时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicMenuUI.MouseInputHandler

protected BasicMenuUI.MouseInputHandler()
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mousePressed

public void mousePressed(MouseEvent e)
在菜单上单击鼠标时调用。此方法清除或设置 MenuSelectionManager 的选择路径。

指定者：
接口 MouseListener 中的 mousePressed
参数：
e - 鼠标事件

mouseReleased

public void mouseReleased(MouseEvent e)
在菜单上释放鼠标时调用。将鼠标事件委托给 MenuSelectionManager。

指定者：
接口 MouseListener 中的 mouseReleased
参数：
e - 鼠标事件

mouseEntered

public void mouseEntered(MouseEvent e)
在指针进入菜单时调用。此方法为 MenuSelectionManager 设置所选路径，并处理层次菜单系统中使用菜单项弹出附加菜单的情况。

指定者：
接口 MouseListener 中的 mouseEntered
参数：
e - 鼠标事件；不使用

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited

mouseDragged

public void mouseDragged(MouseEvent e)
在菜单上按下鼠标按键并随后拖动鼠标时调用。将鼠标事件委托给 MenuSelectionManager。

指定者：
接口 MouseMotionListener 中的 mouseDragged
参数：
e - 鼠标事件
另请参见：
MouseMotionListener.mouseDragged(java.awt.event.MouseEvent)

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicOptionPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicOptionPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.OptionPaneUI
            继承者  javax.swing.plaf.basic.BasicOptionPaneUI

public class BasicOptionPaneUI
extends OptionPaneUI

为 JOptionPane 提供基本外观。BasicMessagePaneUI 提供将图标、消息和按钮置于 Container 中的方法。一般情况下，布局如下所示：

        ------------------
        | i | message    |
        | c | message    |
        | o | message    |
        | n | message    |
        ------------------
        |     buttons    |
        |________________|
图标是 Icon 的实例，包装在 JLabel 中。消息是不透明对象，用于测试：如果消息为 Component，则将其添加到 Container；如果其为 Icon，则将其包装在 JLabel 中并添加到 Container，否则将其包装在 JLabel 中。

当选项窗格的 ComponentOrientation 属性为水平的从左到右时，使用上述布局。布局将针对其他方向进行适当调整。

Container、消息、图标和按钮都是根据抽象方法确定的。

嵌套类摘要
class | BasicOptionPaneUI.ButtonActionListener 此内部类因编译器故障而被标记为“公开”。
static class | BasicOptionPaneUI.ButtonAreaLayout ButtonAreaLayout 的行为方式类似于 FlowLayout。
class | BasicOptionPaneUI.PropertyChangeHandler 此内部类因编译器故障而被标记为“公开”。
字段摘要
protected boolean | hasCustomComponents 如果 Component 包含在消息或按钮中，则将其设置为 true。
protected Component | initialFocusComponent 利用 selectInitialValue 传递消息时接收焦点的组件。
protected JComponent | inputComponent 如果 optionPane.getWantsInput() 返回 true，则 JComponent 提供输入。
static int | MinimumHeight
protected Dimension | minimumSize
static int | MinimumWidth
protected JOptionPane | optionPane 接收者为其提供外观的 JOptionPane。
protected PropertyChangeListener | propertyChangeListener
构造方法摘要
BasicOptionPaneUI()
方法摘要
protected void | addButtonComponents(Container container, Object[] buttons, int initialIndex) 创建表示 buttons 中每个对象的适当对象并将其添加到 container。
protected void | addIcon(Container top) 创建并添加 JLabel，它表示对 top 调用 getIcon 所返回的图标。
protected void | addMessageComponents(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated) 创建表示 msg 的适当对象并将其置于 container 中。
protected void | burstStringInto(Container c, String d, int maxll) 递归式创建表示 d 的新 JLabel 实例每个 JLabel 实例都将被添加到 c。
boolean | containsCustomComponents(JOptionPane op) 如果在上一次对 validateComponent 的调用中消息或按钮包含 Component 的子类，则返回 true。
protected ActionListener | createButtonActionListener(int buttonIndex)
protected Container | createButtonArea() 创建并返回包含按钮的 Container。
protected LayoutManager | createLayoutManager()
protected Container | createMessageArea() 从 installComponents 获取消息以创建包含消息正文的 Container。
protected PropertyChangeListener | createPropertyChangeListener()
protected Container | createSeparator()
static ComponentUI | createUI(JComponent x) 创建一个新的 BasicOptionPaneUI 实例。
protected Object[] | getButtons() 返回从接收者为其提供外观的 JOptionPane 显示的按钮。
protected Icon | getIcon() 返回来自接收者为其提供外观的 JOptionPane 的图标，或者从 getDefaultIcon 返回的默认图标。
protected Icon | getIconForType(int messageType) 返回用于传入类型的图标。
protected int | getInitialValueIndex() 将初始索引返回给要选择的按钮。
protected int | getMaxCharactersPerLineCount() 返回要置于行中的最大字符数。
protected Object | getMessage() 返回从接收者为其提供外观的 JOptionPane 显示的消息。
Dimension | getMinimumOptionPaneSize() 返回选项窗格应该具有的最小大小。
Dimension | getPreferredSize(JComponent c) 如果 c 为包含接收者的 JOptionPane，则返回的首选大小为 JOptionPane 的 LayoutManager 的最大首选大小和 getMinimumOptionPaneSize。
protected boolean | getSizeButtonsToSameWidth() 返回 true，基本 L&F 希望所有按钮具有相同的宽度。
protected void | installComponents()
protected void | installDefaults()
protected void | installKeyboardActions()
protected void | installListeners()
void | installUI(JComponent c) 安装作为传入 JOptionPane 的 L&F 的接收者。
protected void | resetInputValue() 基于 inputComponent 中的值，设置接收者为其提供外观的选项窗格中的输入值。
void | selectInitialValue(JOptionPane op) 如果 inputComponent 为非 null，则请求焦点位于其上；否则请求焦点位于默认值上
protected void | uninstallComponents()
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 从传入拆分窗格的 L&F 控制器移除接收者。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MinimumWidth

public static final int MinimumWidth
另请参见：
常量字段值

MinimumHeight

public static final int MinimumHeight
另请参见：
常量字段值

optionPane

protected JOptionPane optionPane
接收者为其提供外观的 JOptionPane。

minimumSize

protected Dimension minimumSize

inputComponent

protected JComponent inputComponent
如果 optionPane.getWantsInput() 返回 true，则 JComponent 提供输入。

initialFocusComponent

protected Component initialFocusComponent
利用 selectInitialValue 传递消息时接收焦点的组件。

hasCustomComponents

protected boolean hasCustomComponents
如果 Component 包含在消息或按钮中，则将其设置为 true。

propertyChangeListener

protected PropertyChangeListener propertyChangeListener
构造方法详细信息

BasicOptionPaneUI

public BasicOptionPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)
创建一个新的 BasicOptionPaneUI 实例。

installUI

public void installUI(JComponent c)
安装作为传入 JOptionPane 的 L&F 的接收者。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从传入拆分窗格的 L&F 控制器移除接收者。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults()

uninstallDefaults

protected void uninstallDefaults()

installComponents

protected void installComponents()

uninstallComponents

protected void uninstallComponents()

createLayoutManager

protected LayoutManager createLayoutManager()

installListeners

protected void installListeners()

uninstallListeners

protected void uninstallListeners()

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()

installKeyboardActions

protected void installKeyboardActions()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

getMinimumOptionPaneSize

public Dimension getMinimumOptionPaneSize()
返回选项窗格应该具有的最小大小。主要供希望提供不同最小大小的子类使用。

getPreferredSize

public Dimension getPreferredSize(JComponent c)
如果 c 为包含接收者的 JOptionPane，则返回的首选大小为 JOptionPane 的 LayoutManager 的最大首选大小和 getMinimumOptionPaneSize。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

createMessageArea

protected Container createMessageArea()
从 installComponents 获取消息以创建包含消息正文的 Container。通过调用 addIcon 创建图标。

addMessageComponents

protected void addMessageComponents(Container container,
                                    GridBagConstraints cons,
                                    Object msg,
                                    int maxll,
                                    boolean internallyCreated)
创建表示 msg 的适当对象并将其置于 container 中。如果 msg 为 Component 的实例，则直接添加它；如果其为 Icon，则创建 JLabel 来表示它；否则，如果 d 为 Object[]，则为该字符串创建 JLabel，将为其子级递归式调用此方法。如果 Objc 为 Component 的实例并且由此方法内部创建，则 internallyCreated 为 true（仅当 !internallyCreated 时，使用此方法正确设置 hasCustomComponents）。

getMessage

protected Object getMessage()
返回从接收者为其提供外观的 JOptionPane 显示的消息。

addIcon

protected void addIcon(Container top)
创建并添加 JLabel，它表示对 top 调用 getIcon 所返回的图标。此方法获得从 createMessageArea 传递的消息

getIcon

protected Icon getIcon()
返回来自接收者为其提供外观的 JOptionPane 的图标，或者从 getDefaultIcon 返回的默认图标。

getIconForType

protected Icon getIconForType(int messageType)
返回用于传入类型的图标。

getMaxCharactersPerLineCount

protected int getMaxCharactersPerLineCount()
返回要置于行中的最大字符数。

burstStringInto

protected void burstStringInto(Container c,
                               String d,
                               int maxll)
递归式创建表示 d 的新 JLabel 实例每个 JLabel 实例都将被添加到 c。

createSeparator

protected Container createSeparator()

createButtonArea

protected Container createButtonArea()
创建并返回包含按钮的 Container。通过调用 getButtons 创建按钮。

addButtonComponents

protected void addButtonComponents(Container container,
                                   Object[] buttons,
                                   int initialIndex)
创建表示 buttons 中每个对象的适当对象并将其添加到 container。这与 addMessageComponents 不同，不同点在于它将在 buttons 上递归，并且如果按钮不是 Component，它将创建一个 JButton 的实例。

createButtonActionListener

protected ActionListener createButtonActionListener(int buttonIndex)

getButtons

protected Object[] getButtons()
返回从接收者为其提供外观的 JOptionPane 显示的按钮。如果 JOptionPane 设置了选项，则提供它们；否则，如果 optionType 为 YES_NO_OPTION，则返回 yesNoOptions；如果类型为 YES_NO_CANCEL_OPTION，则返回 yesNoCancelOptions；否则返回 defaultButtons。

getSizeButtonsToSameWidth

protected boolean getSizeButtonsToSameWidth()
返回 true，基本 L&F 希望所有按钮具有相同的宽度。

getInitialValueIndex

protected int getInitialValueIndex()
将初始索引返回给要选择的按钮。索引是根据 JOptionPane 的初始值和 JOptionPane 的选项计算出的，或者为 0。

resetInputValue

protected void resetInputValue()
基于 inputComponent 中的值，设置接收者为其提供外观的选项窗格中的输入值。

selectInitialValue

public void selectInitialValue(JOptionPane op)
如果 inputComponent 为非 null，则请求焦点位于其上；否则请求焦点位于默认值上

指定者：
类 OptionPaneUI 中的 selectInitialValue

containsCustomComponents

public boolean containsCustomComponents(JOptionPane op)
如果在上一次对 validateComponent 的调用中消息或按钮包含 Component 的子类，则返回 true。

指定者：
类 OptionPaneUI 中的 containsCustomComponents
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicOptionPaneUI.ButtonActionListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicOptionPaneUI.ButtonActionListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
BasicOptionPaneUI
public class BasicOptionPaneUI.ButtonActionListener
extends Object
implements ActionListener

此内部类因编译器故障而被标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicOptionPaneUI 的子类中实例化此类。

字段摘要
protected  int buttonIndex
构造方法摘要
BasicOptionPaneUI.ButtonActionListener(int buttonIndex)
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

buttonIndex

protected int buttonIndex
构造方法详细信息

BasicOptionPaneUI.ButtonActionListener

public BasicOptionPaneUI.ButtonActionListener(int buttonIndex)
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicOptionPaneUI.ButtonAreaLayout (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicOptionPaneUI.ButtonAreaLayout

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
所有已实现的接口：
LayoutManager
正在封闭类：
BasicOptionPaneUI
public static class BasicOptionPaneUI.ButtonAreaLayout
extends Object
implements LayoutManager

ButtonAreaLayout 的行为方式类似于 FlowLayout。它从左到右布置所有组件。如果 syncAllWidths 为 true，则将每个组件的宽度设置为最大首选大小的宽度。 因编辑器故障而将此内部类标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicOptionPaneUI 的子类中实例化此类。

字段摘要
protected boolean | centersChildren 如果为 true，则子级将在父级中汇总在一起。
protected int | padding
protected boolean | syncAllWidths
构造方法摘要
BasicOptionPaneUI.ButtonAreaLayout(boolean syncAllWidths, int padding)
方法摘要
void | addLayoutComponent(String string, Component comp) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
boolean | getCentersChildren()
int | getPadding()
boolean | getSyncAllWidths()
void | layoutContainer(Container container) 布置指定容器。
Dimension | minimumLayoutSize(Container c) 给定指定容器所包含的组件，计算该容器的最小大小维数。
Dimension | preferredLayoutSize(Container c) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | removeLayoutComponent(Component c) 从布局移除指定组件。
void | setCentersChildren(boolean newValue)
void | setPadding(int newPadding)
void | setSyncAllWidths(boolean newValue)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

syncAllWidths

protected boolean syncAllWidths

padding

protected int padding

centersChildren

protected boolean centersChildren
如果为 true，则子级将在父级中汇总在一起。

构造方法详细信息

BasicOptionPaneUI.ButtonAreaLayout

public BasicOptionPaneUI.ButtonAreaLayout(boolean syncAllWidths,
                                          int padding)
方法详细信息

setSyncAllWidths

public void setSyncAllWidths(boolean newValue)

getSyncAllWidths

public boolean getSyncAllWidths()

setPadding

public void setPadding(int newPadding)

getPadding

public int getPadding()

setCentersChildren

public void setCentersChildren(boolean newValue)

getCentersChildren

public boolean getCentersChildren()

addLayoutComponent

public void addLayoutComponent(String string,
                               Component comp)
从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
string - 要与组件关联的字符串
comp - 要添加的组件

layoutContainer

public void layoutContainer(Container container)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
container - 要布置的容器

minimumLayoutSize

public Dimension minimumLayoutSize(Container c)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的最小大小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
c - 要布置的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container c)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的首选大小维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
c - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

removeLayoutComponent

public void removeLayoutComponent(Component c)
从接口 LayoutManager 复制的描述
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
c - 要移除的组件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicOptionPaneUI.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicOptionPaneUI.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicOptionPaneUI
public class BasicOptionPaneUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

此内部类因编译器故障而被标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicOptionPaneUI 的子类中实例化它。

构造方法摘要
BasicOptionPaneUI.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
如果 PropertyChangeEvent e 的源等于 optionPane 并且为 ICON_PROPERTY、MESSAGE_PROPERTY、OPTIONS_PROPERTY 或 INITIAL_VALUE_PROPERTY 之一，则调用 validateComponent。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicOptionPaneUI.PropertyChangeHandler

public BasicOptionPaneUI.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
如果 PropertyChangeEvent e 的源等于 optionPane 并且为 ICON_PROPERTY、MESSAGE_PROPERTY、OPTIONS_PROPERTY 或 INITIAL_VALUE_PROPERTY 之一，则调用 validateComponent。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicPanelUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicPanelUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.PanelUI
            继承者  javax.swing.plaf.basic.BasicPanelUI

public class BasicPanelUI
extends PanelUI

BasicPanel 实现

构造方法摘要
BasicPanelUI()
方法摘要
static ComponentUI | createUI(JComponent c)
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
protected void | installDefaults(JPanel p)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected void | uninstallDefaults(JPanel p)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicPanelUI

public BasicPanelUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults(JPanel p)

uninstallDefaults

protected void uninstallDefaults(JPanel p)

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicPasswordFieldUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicPasswordFieldUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
                继承者  javax.swing.plaf.basic.BasicTextFieldUI
                    继承者  javax.swing.plaf.basic.BasicPasswordFieldUI
所有已实现的接口：
ViewFactory
public class BasicPasswordFieldUI
extends BasicTextFieldUI

为密码字段提供 Windows 外观。它与标准文本字段的惟一不同点在于文本视图只是一个在 JPasswordField 中指定的回显字符的字符串，而不是包含在字段中的真正文本。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的嵌套类/接口
BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter
构造方法摘要
BasicPasswordFieldUI()
方法摘要
View | create(Element elem) 创建元素的视图 (PasswordView)。
static ComponentUI | createUI(JComponent c) 创建 JPasswordField 的 UI。
protected String | getPropertyPrefix() 获取用作键以通过 UIManager 查找属性的名称。
protected void | installDefaults() 在 JPasswordField 上安装所需的属性。
从类 javax.swing.plaf.basic.BasicTextFieldUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 javax.swing.plaf.basic.BasicTextUI 继承的方法
create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, propertyChange, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicPasswordFieldUI

public BasicPasswordFieldUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)
创建 JPasswordField 的 UI。

参数：
c - JPasswordField
返回：
UI

getPropertyPrefix

protected String getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。它用作所有标准文本属性的前缀。

覆盖：
类 BasicTextFieldUI 中的 getPropertyPrefix
返回：
名称 ("PasswordField")

installDefaults

protected void installDefaults()
在 JPasswordField 上安装所需的属性。

覆盖：
类 BasicTextUI 中的 installDefaults
从以下版本开始：
1.6
另请参见：
BasicTextUI.uninstallDefaults(), BasicTextUI.installUI(javax.swing.JComponent)

create

public View create(Element elem)
创建元素的视图 (PasswordView)。

指定者：
接口 ViewFactory 中的 create
覆盖：
类 BasicTextFieldUI 中的 create
参数：
elem - 元素
返回：
视图
另请参见：
View
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicPopupMenuSeparatorUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicPopupMenuSeparatorUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SeparatorUI
            继承者  javax.swing.plaf.basic.BasicSeparatorUI
                继承者  javax.swing.plaf.basic.BasicPopupMenuSeparatorUI

public class BasicPopupMenuSeparatorUI
extends BasicSeparatorUI

PopupMenuSeparatorUI 的基本 L&F 实现。此实现是一个“组合的”视图/控制器。

字段摘要
从类 javax.swing.plaf.basic.BasicSeparatorUI 继承的字段
highlight, shadow
构造方法摘要
BasicPopupMenuSeparatorUI()
方法摘要
static ComponentUI | createUI(JComponent c)
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
从类 javax.swing.plaf.basic.BasicSeparatorUI 继承的方法
getMaximumSize, getMinimumSize, installDefaults, installListeners, installUI, uninstallDefaults, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicPopupMenuSeparatorUI

public BasicPopupMenuSeparatorUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 BasicSeparatorUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 BasicSeparatorUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicPopupMenuUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicPopupMenuUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.PopupMenuUI
            继承者  javax.swing.plaf.basic.BasicPopupMenuUI

public class BasicPopupMenuUI
extends PopupMenuUI

PopupMenuUI 的 Windows L&F 实现。此实现是一个“组合的”视图/控制器。

字段摘要
protected  JPopupMenu popupMenu
构造方法摘要
BasicPopupMenuUI()
方法摘要
static ComponentUI | createUI(JComponent x)
void | installDefaults()
protected void | installKeyboardActions()
protected void | installListeners()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
boolean | isPopupTrigger(MouseEvent e)
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.PopupMenuUI 继承的方法
getPopup
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

popupMenu

protected JPopupMenu popupMenu
构造方法详细信息

BasicPopupMenuUI

public BasicPopupMenuUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

installDefaults

public void installDefaults()

installListeners

protected void installListeners()

installKeyboardActions

protected void installKeyboardActions()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

uninstallDefaults

protected void uninstallDefaults()

uninstallListeners

protected void uninstallListeners()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

isPopupTrigger

public boolean isPopupTrigger(MouseEvent e)
覆盖：
类 PopupMenuUI 中的 isPopupTrigger
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSliderUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSliderUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SliderUI
            继承者  javax.swing.plaf.basic.BasicSliderUI
直接已知子类：
MetalSliderUI
public class BasicSliderUI
extends SliderUI

SliderUI 的基本 L&F 实现。

嵌套类摘要
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicSliderUI.ChangeHandler 数据模型侦听器。
class | BasicSliderUI.ComponentHandler 调整事件大小的侦听器。
class | BasicSliderUI.FocusHandler 焦点更改侦听器。
class | BasicSliderUI.PropertyChangeHandler
class | BasicSliderUI.ScrollListener 滚动事件侦听器。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
字段摘要
protected ChangeListener | changeListener
protected ComponentListener | componentListener
protected Rectangle | contentRect
protected Insets | focusInsets
protected FocusListener | focusListener
protected Rectangle | focusRect
protected Insets | insetCache
protected Rectangle | labelRect
protected boolean | leftToRightCache
static int | MAX_SCROLL
static int | MIN_SCROLL
static int | NEGATIVE_SCROLL
static int | POSITIVE_SCROLL
protected PropertyChangeListener | propertyChangeListener
protected BasicSliderUI.ScrollListener | scrollListener
protected Timer | scrollTimer
protected JSlider | slider
protected Rectangle | thumbRect
protected Rectangle | tickRect
protected int | trackBuffer
protected BasicSliderUI.TrackListener | trackListener
protected Rectangle | trackRect
构造方法摘要
BasicSliderUI(JSlider b)
方法摘要
protected void | calculateContentRect()
protected void | calculateFocusRect()
protected void | calculateGeometry()
protected void | calculateLabelRect()
protected void | calculateThumbLocation()
protected void | calculateThumbSize()
protected void | calculateTickRect()
protected void | calculateTrackBuffer()
protected void | calculateTrackRect()
protected ChangeListener | createChangeListener(JSlider slider)
protected ComponentListener | createComponentListener(JSlider slider)
protected FocusListener | createFocusListener(JSlider slider)
protected PropertyChangeListener | createPropertyChangeListener(JSlider slider)
protected BasicSliderUI.ScrollListener | createScrollListener(JSlider slider)
protected BasicSliderUI.TrackListener | createTrackListener(JSlider slider)
static ComponentUI | createUI(JComponent b)
protected boolean | drawInverted()
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
protected Color | getFocusColor()
protected int | getHeightOfHighValueLabel()
protected int | getHeightOfLowValueLabel()
protected int | getHeightOfTallestLabel()
protected Integer | getHighestValue() 返回在标签表中有一个项的最大值。
protected Component | getHighestValueLabel() 返回与标签表中的最低滑块值相对应的标签。
protected Color | getHighlightColor()
protected Integer | getLowestValue() 返回在标签表中有一个项的最小值。
protected Component | getLowestValueLabel() 返回与标签表中的最高滑块值相对应的标签。
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumHorizontalSize()
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | getMinimumVerticalSize()
Dimension | getPreferredHorizontalSize()
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
Dimension | getPreferredVerticalSize()
protected Color | getShadowColor()
protected Dimension | getThumbSize()
protected int | getTickLength() 获取水平滑块的刻度区域的高度和垂直滑块的刻度区域的宽度。
protected int | getWidthOfHighValueLabel()
protected int | getWidthOfLowValueLabel()
protected int | getWidthOfWidestLabel()
protected void | installDefaults(JSlider slider)
protected void | installKeyboardActions(JSlider slider)
protected void | installListeners(JSlider slider)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected boolean | isDragging() 如果用户在拖动滑块，则返回 true。
protected boolean | labelsHaveSameBaselines() 如果标签表中的所有标签具有相同的基线，则返回 true。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | paintFocus(Graphics g)
protected void | paintHorizontalLabel(Graphics g, int value, Component label) 为标签表中的每个标签调用此方法。
void | paintLabels(Graphics g)
protected void | paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected void | paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
void | paintThumb(Graphics g)
void | paintTicks(Graphics g)
void | paintTrack(Graphics g)
protected void | paintVerticalLabel(Graphics g, int value, Component label) 为标签表中的每个标签调用此方法。
protected void | recalculateIfInsetsChanged()
protected void | recalculateIfOrientationChanged()
void | scrollByBlock(int direction)
void | scrollByUnit(int direction)
protected void | scrollDueToClickInTrack(int dir) 在滑道（而非 thumb）中检测到 mousePressed 时调用此方法。
void | setThumbLocation(int x, int y)
protected void | uninstallKeyboardActions(JSlider slider)
protected void | uninstallListeners(JSlider slider)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
int | valueForXPosition(int xPos) 返回给出 x 位置的值。
int | valueForYPosition(int yPos) 返回给出 y 位置的值。
protected int | xPositionForValue(int value)
protected int | yPositionForValue(int value)
protected int | yPositionForValue(int value, int trackY, int trackHeight) 返回指定值的 y 位置。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

POSITIVE_SCROLL

public static final int POSITIVE_SCROLL
另请参见：
常量字段值

NEGATIVE_SCROLL

public static final int NEGATIVE_SCROLL
另请参见：
常量字段值

MIN_SCROLL

public static final int MIN_SCROLL
另请参见：
常量字段值

MAX_SCROLL

public static final int MAX_SCROLL
另请参见：
常量字段值

scrollTimer

protected Timer scrollTimer

slider

protected JSlider slider

focusInsets

protected Insets focusInsets

insetCache

protected Insets insetCache

leftToRightCache

protected boolean leftToRightCache

focusRect

protected Rectangle focusRect

contentRect

protected Rectangle contentRect

labelRect

protected Rectangle labelRect

tickRect

protected Rectangle tickRect

trackRect

protected Rectangle trackRect

thumbRect

protected Rectangle thumbRect

trackBuffer

protected int trackBuffer

trackListener

protected BasicSliderUI.TrackListener trackListener

changeListener

protected ChangeListener changeListener

componentListener

protected ComponentListener componentListener

focusListener

protected FocusListener focusListener

scrollListener

protected BasicSliderUI.ScrollListener scrollListener

propertyChangeListener

protected PropertyChangeListener propertyChangeListener
构造方法详细信息

BasicSliderUI

public BasicSliderUI(JSlider b)
方法详细信息

getShadowColor

protected Color getShadowColor()

getHighlightColor

protected Color getHighlightColor()

getFocusColor

protected Color getFocusColor()

isDragging

protected boolean isDragging()
如果用户在拖动滑块，则返回 true。

返回：
如果用户在拖动滑块，则返回 true
从以下版本开始：
1.5

createUI

public static ComponentUI createUI(JComponent b)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults(JSlider slider)

createTrackListener

protected BasicSliderUI.TrackListener createTrackListener(JSlider slider)

createChangeListener

protected ChangeListener createChangeListener(JSlider slider)

createComponentListener

protected ComponentListener createComponentListener(JSlider slider)

createFocusListener

protected FocusListener createFocusListener(JSlider slider)

createScrollListener

protected BasicSliderUI.ScrollListener createScrollListener(JSlider slider)

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener(JSlider slider)

installListeners

protected void installListeners(JSlider slider)

uninstallListeners

protected void uninstallListeners(JSlider slider)

installKeyboardActions

protected void installKeyboardActions(JSlider slider)

uninstallKeyboardActions

protected void uninstallKeyboardActions(JSlider slider)

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

labelsHaveSameBaselines

protected boolean labelsHaveSameBaselines()
如果标签表中的所有标签具有相同的基线，则返回 true。

返回：
如果标签表中的所有标签具有相同的基线，则返回 true
从以下版本开始：
1.6

getPreferredHorizontalSize

public Dimension getPreferredHorizontalSize()

getPreferredVerticalSize

public Dimension getPreferredVerticalSize()

getMinimumHorizontalSize

public Dimension getMinimumHorizontalSize()

getMinimumVerticalSize

public Dimension getMinimumVerticalSize()

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

calculateGeometry

protected void calculateGeometry()

calculateFocusRect

protected void calculateFocusRect()

calculateThumbSize

protected void calculateThumbSize()

calculateContentRect

protected void calculateContentRect()

calculateThumbLocation

protected void calculateThumbLocation()

calculateTrackBuffer

protected void calculateTrackBuffer()

calculateTrackRect

protected void calculateTrackRect()

getTickLength

protected int getTickLength()
获取水平滑块的刻度区域的高度和垂直滑块的刻度区域的宽度。BasicSliderUI 使用返回值确定刻度区域矩形。如果要给刻度一些空间，则使此宽度大于所需宽度并使用 paintTicks() 远离边绘制刻度。

calculateTickRect

protected void calculateTickRect()

calculateLabelRect

protected void calculateLabelRect()

getThumbSize

protected Dimension getThumbSize()

getWidthOfWidestLabel

protected int getWidthOfWidestLabel()

getHeightOfTallestLabel

protected int getHeightOfTallestLabel()

getWidthOfHighValueLabel

protected int getWidthOfHighValueLabel()

getWidthOfLowValueLabel

protected int getWidthOfLowValueLabel()

getHeightOfHighValueLabel

protected int getHeightOfHighValueLabel()

getHeightOfLowValueLabel

protected int getHeightOfLowValueLabel()

drawInverted

protected boolean drawInverted()

getHighestValue

protected Integer getHighestValue()
返回在标签表中有一个项的最大值。

返回：
在标签表中有一个项的最大值，或则返回 null。
从以下版本开始：
1.6

getLowestValue

protected Integer getLowestValue()
返回在标签表中有一个项的最小值。

返回：
在标签表中有一个项的最小值，或则返回 null。
从以下版本开始：
1.6

getLowestValueLabel

protected Component getLowestValueLabel()
返回与标签表中的最高滑块值相对应的标签。

另请参见：
JSlider.setLabelTable(java.util.Dictionary)

getHighestValueLabel

protected Component getHighestValueLabel()
返回与标签表中的最低滑块值相对应的标签。

另请参见：
JSlider.setLabelTable(java.util.Dictionary)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

recalculateIfInsetsChanged

protected void recalculateIfInsetsChanged()

recalculateIfOrientationChanged

protected void recalculateIfOrientationChanged()

paintFocus

public void paintFocus(Graphics g)

paintTrack

public void paintTrack(Graphics g)

paintTicks

public void paintTicks(Graphics g)

paintMinorTickForHorizSlider

protected void paintMinorTickForHorizSlider(Graphics g,
                                            Rectangle tickBounds,
                                            int x)

paintMajorTickForHorizSlider

protected void paintMajorTickForHorizSlider(Graphics g,
                                            Rectangle tickBounds,
                                            int x)

paintMinorTickForVertSlider

protected void paintMinorTickForVertSlider(Graphics g,
                                           Rectangle tickBounds,
                                           int y)

paintMajorTickForVertSlider

protected void paintMajorTickForVertSlider(Graphics g,
                                           Rectangle tickBounds,
                                           int y)

paintLabels

public void paintLabels(Graphics g)

paintHorizontalLabel

protected void paintHorizontalLabel(Graphics g,
                                    int value,
                                    Component label)
为标签表中的每个标签调用此方法。用于绘制水平滑块的标签。已将图形转换为 labelRect.y。

另请参见：
JSlider.setLabelTable(java.util.Dictionary)

paintVerticalLabel

protected void paintVerticalLabel(Graphics g,
                                  int value,
                                  Component label)
为标签表中的每个标签调用此方法。用于绘制垂直平滑块的标签。已将图形转换为 labelRect.x。

另请参见：
JSlider.setLabelTable(java.util.Dictionary)

paintThumb

public void paintThumb(Graphics g)

setThumbLocation

public void setThumbLocation(int x,
                             int y)

scrollByBlock

public void scrollByBlock(int direction)

scrollByUnit

public void scrollByUnit(int direction)

scrollDueToClickInTrack

protected void scrollDueToClickInTrack(int dir)
在滑道（而非 thumb）中检测到 mousePressed 时调用此方法。默认行为按块滚动。可以重写此方法来阻止滚动或者添加其他行为。

xPositionForValue

protected int xPositionForValue(int value)

yPositionForValue

protected int yPositionForValue(int value)

yPositionForValue

protected int yPositionForValue(int value,
                                int trackY,
                                int trackHeight)
返回指定值的 y 位置。不对该参数进行检查。尤其是，如果 trackHeight 负数，则结果是不确定的。

参数：
value - 要获取其位置的滑块值
trackY - 滑道 y 原点
trackHeight - 滑道高度
从以下版本开始：
1.6

valueForYPosition

public int valueForYPosition(int yPos)
返回给出 y 位置的值。如果 yPos 越过了滑道顶部或底部，则它会将该值设置为滑块的最小值或最大值，这一点取决于是否反转了滑块。

valueForXPosition

public int valueForXPosition(int xPos)
返回给出 x 位置的值。如果 xPos 越过了滑道左边或右边，则它会将该值设置为滑块的最小值或最大值，这一点取决于是否了反转滑块。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicProgressBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicProgressBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ProgressBarUI
            继承者  javax.swing.plaf.basic.BasicProgressBarUI
直接已知子类：
MetalProgressBarUI
public class BasicProgressBarUI
extends ProgressBarUI

ProgressBarUI 的基本 L&F 实现。

嵌套类摘要
 class BasicProgressBarUI.ChangeHandler
此内部类因编译器故障而被标记为“公开”。
字段摘要
protected Rectangle | boxRect 用于保存要绘制的跳动框（由 getBox 返回）的位置和大小。
protected ChangeListener | changeListener
protected JProgressBar | progressBar
构造方法摘要
BasicProgressBarUI()
方法摘要
static ComponentUI | createUI(JComponent x)
protected int | getAmountFull(Insets b, int width, int height) 此方法确定进度条的量，该量应该基于从模型搜集的完成百分比填充。
protected int | getAnimationIndex() 获取当前动画窗体的索引。
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
protected Rectangle | getBox(Rectangle r) 存储将为 r 中的当前动画索引绘制并返回 r 的跳动框中位置和大小。
protected int | getBoxLength(int availableLength, int otherDimension) 返回要绘制的“跳动框”的长度。
protected int | getCellLength() 返回要在进度条中呈现的每个单个单元格/单元的宽度（如果为 HORIZONTAL）或高度（如果为 VERTICAL）。
protected int | getCellSpacing() 返回进度条中每个单元格/单元之间的间隔。
protected int | getFrameCount() 返回不确定 JProgessBar 所使用的完整动画循环的窗体数。
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 此组件的最小大小为 10。
protected Dimension | getPreferredInnerHorizontal()
protected Dimension | getPreferredInnerVertical()
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected Color | getSelectionBackground() 如果在进度条的未填充区域上绘制文本，则文本的颜色为 "selectionBackground"。
protected Color | getSelectionForeground() 如果在进度条的填充区域上绘制文本，文本的颜色为 "selectionForeground"。
protected Point | getStringPlacement(Graphics g, String progressString, int x, int y, int width, int height) 指定将绘制进度字符串的位置。
protected void | incrementAnimationIndex() 将当前动画窗体的索引设置为下一个有效值，这将导致进度条的重绘。
protected void | installDefaults()
protected void | installListeners()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | paint(Graphics g, JComponent c) 将绘制委托给两种方法之一：paintDeterminate 和 paintIndeterminate。
protected void | paintDeterminate(Graphics g, JComponent c) 对几乎所有线性、确定进度条都能正确执行操作的多用途绘制方法。
protected void | paintIndeterminate(Graphics g, JComponent c) 对所有线性跳动框进度条都能正确执行操作的多用途绘制方法。
protected void | paintString(Graphics g, int x, int y, int width, int height, int amountFull, Insets b)
protected void | setAnimationIndex(int newValue) 将当前动画窗体的索引设置为指定的值，并请求重绘进度条。
protected void | setCellLength(int cellLen)
protected void | setCellSpacing(int cellSpace)
protected void | startAnimationTimer() 启动动画线程，如果必要则创建并初始化它。
protected void | stopAnimationTimer() 停止动画线程。
protected void | uninstallDefaults()
protected void | uninstallListeners() 移除此对象安装的所有侦听器。
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

progressBar

protected JProgressBar progressBar

changeListener

protected ChangeListener changeListener

boxRect

protected Rectangle boxRect
用于保存要绘制的跳动框（由 getBox 返回）的位置和大小。

从以下版本开始：
1.5
构造方法详细信息

BasicProgressBarUI

public BasicProgressBarUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults()

uninstallDefaults

protected void uninstallDefaults()

installListeners

protected void installListeners()

startAnimationTimer

protected void startAnimationTimer()
启动动画线程，如果必要则创建并初始化它。当不确定的进度条应该启动动画时，调用此方法。此操作的理由包括：
  • 此进度条是确定的并变得可显示
  • 此进度条是可显示的并变得确定
  • 进度条是可显示和确定的，并且安装了此 UI
如果实现自己的动画线程，则必须重写此线程。

从以下版本开始：
1.4
另请参见：
stopAnimationTimer()

stopAnimationTimer

protected void stopAnimationTimer()
停止动画线程。应该停止不确定的动画时调用此方法。此操作的理由包括：
  • 进度条更改为确定
  • 进度条不再是可显示层次结构的一部分
  • 未安装此 UI
如果实现自己的动画线程，则必须重写此线程。

从以下版本开始：
1.4
另请参见：
startAnimationTimer()

uninstallListeners

protected void uninstallListeners()
移除此对象安装的所有侦听器。

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getPreferredInnerHorizontal

protected Dimension getPreferredInnerHorizontal()

getPreferredInnerVertical

protected Dimension getPreferredInnerVertical()

getSelectionForeground

protected Color getSelectionForeground()
如果在进度条的填充区域上绘制文本，文本的颜色为 "selectionForeground"。

getSelectionBackground

protected Color getSelectionBackground()
如果在进度条的未填充区域上绘制文本，则文本的颜色为 "selectionBackground"。

getCellLength

protected int getCellLength()
返回要在进度条中呈现的每个单个单元格/单元的宽度（如果为 HORIZONTAL）或高度（如果为 VERTICAL）。但是，为了文本呈现的简易性和出于审美考虑，呈现进度字符串时，此方法将返回 1。

返回：
表示单元格之间间隔的值
另请参见：
setCellLength(int), JProgressBar.isStringPainted()

setCellLength

protected void setCellLength(int cellLen)

getCellSpacing

protected int getCellSpacing()
返回进度条中每个单元格/单元之间的间隔。但是，为了文本呈现的简易性和出于审美考虑，呈现进度字符串时，此方法将返回 0。

返回：
表示单元格之间间隔的值
另请参见：
setCellSpacing(int), JProgressBar.isStringPainted()

setCellSpacing

protected void setCellSpacing(int cellSpace)

getAmountFull

protected int getAmountFull(Insets b,
                            int width,
                            int height)
此方法确定进度条的量，该量应该基于从模型搜集的完成百分比填充。此方法是一种共同的操作，所以被作为抽象方法提出来。它假定进度条是线性的。就是说，如果要制作圆形进度指示器，则要重写此方法。

paint

public void paint(Graphics g,
                  JComponent c)
将绘制委托给两种方法之一：paintDeterminate 和 paintIndeterminate。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getBox

protected Rectangle getBox(Rectangle r)
存储将为 r 中的当前动画索引绘制并返回 r 的跳动框中位置和大小。在 paintIndeterminate 的此类的实现中执行添加绘制的子类（例如，围绕跳动框绘制轮廓）可以使用此方法获取刚刚绘制的跳动框的位置。通过重写此方法，可以完全控制跳动框的大小和位置，无需重新实现 paintIndeterminate。

参数：
r - 要修改的 Rectangle 实例；可能为 null
返回：
如果不应该绘制框，则返回 null；否则返回传入的矩形（如果非 null）或新矩形
从以下版本开始：
1.4
另请参见：
setAnimationIndex(int)

getBoxLength

protected int getBoxLength(int availableLength,
                           int otherDimension)
返回要绘制的“跳动框”的长度。paintIndeterminate 的默认实现调用此方法来获取框的宽度（如果进度条是水平的）或高度（如果是垂直的）。例如：
boxRect.width = getBoxLength(componentInnards.width,
                             componentInnards.height);

参数：
availableLength - 跳动框可移动的空间量；对于水平进度条而言，此空间量应为进度条的内部宽度（组件宽度减去边框）
otherDimension - 对于水平进度条，此空间量应为进度条的内部高度；此值可能用于约束或确定返回值。
返回：
要确定的框的尺寸；必须不大于 availableLength
从以下版本开始：
1.5
另请参见：
SwingUtilities.calculateInnerArea(javax.swing.JComponent, java.awt.Rectangle)

paintIndeterminate

protected void paintIndeterminate(Graphics g,
                                  JComponent c)
对所有线性跳动框进度条都能正确执行操作的多用途绘制方法。如果要制作另一种进度条，则重写此方法。

从以下版本开始：
1.4
另请参见：
paintDeterminate(java.awt.Graphics, javax.swing.JComponent)

paintDeterminate

protected void paintDeterminate(Graphics g,
                                JComponent c)
对几乎所有线性、确定进度条都能正确执行操作的多用途绘制方法。通过在默认表中设置几个值，就可以很好地绘制进度条了。如果要制作圆形或半圆形进度条，自然要重写此方法。

从以下版本开始：
1.4
另请参见：
paintIndeterminate(java.awt.Graphics, javax.swing.JComponent)

paintString

protected void paintString(Graphics g,
                           int x,
                           int y,
                           int width,
                           int height,
                           int amountFull,
                           Insets b)

getStringPlacement

protected Point getStringPlacement(Graphics g,
                                   String progressString,
                                   int x,
                                   int y,
                                   int width,
                                   int height)
指定将绘制进度字符串的位置。此实现将其置于进度条的中心（x 和 y 都是如此）。如果要向右、向左、向上或向下对齐进度字符串或者不管出于何种原因需要轻微移动它，则重写此方法。

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
此组件的最小大小为 10。此处的基本原理是，每 10％ 应该至少有一个像素。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAnimationIndex

protected int getAnimationIndex()
获取当前动画窗体的索引。

从以下版本开始：
1.4

getFrameCount

protected final int getFrameCount()
返回不确定 JProgessBar 所使用的完整动画循环的窗体数。进度块在整个循环过程中将从一端移动到另一端并返回。此可视行为可由其他外观中的子类更改。

返回：
窗体数
从以下版本开始：
1.6

setAnimationIndex

protected void setAnimationIndex(int newValue)
将当前动画窗体的索引设置为指定的值，并请求重绘进度条。不使用默认绘制代码的子类可能需要重写此方法来更改 repaint 方法的调用方式。

参数：
newValue - 新动画索引；没有对其值执行检查
从以下版本开始：
1.4
另请参见：
incrementAnimationIndex()

incrementAnimationIndex

protected void incrementAnimationIndex()
将当前动画窗体的索引设置为下一个有效值，这将导致进度条的重绘。默认情况下下一个有效值是当前动画索引加上一。如果新值过大，则此方法将索引设置为 0。子类可能需要重写此方法以确保索引不超越特定进度条实例所需的窗体数。默认的动画线程每隔 X 毫秒就会调用一次此方法，其中 X 由 "ProgressBar.repaintInterval" UI 默认值指定。

从以下版本开始：
1.4
另请参见：
setAnimationIndex(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicProgressBarUI.ChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicProgressBarUI.ChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler
所有已实现的接口：
EventListener, ChangeListener
正在封闭类：
BasicProgressBarUI
public class BasicProgressBarUI.ChangeHandler
extends Object
implements ChangeListener

此内部类因编译器故障而被标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicProgressBarUI 的子类中实例化此类。

构造方法摘要
BasicProgressBarUI.ChangeHandler()
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicProgressBarUI.ChangeHandler

public BasicProgressBarUI.ChangeHandler()
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicRadioButtonMenuItemUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicRadioButtonMenuItemUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.MenuItemUI
                继承者  javax.swing.plaf.basic.BasicMenuItemUI
                    继承者  javax.swing.plaf.basic.BasicRadioButtonMenuItemUI

public class BasicRadioButtonMenuItemUI
extends BasicMenuItemUI

BasicRadioButtonMenuItem 实现

嵌套类摘要
从类 javax.swing.plaf.basic.BasicMenuItemUI 继承的嵌套类/接口
BasicMenuItemUI.MouseInputHandler
字段摘要
从类 javax.swing.plaf.basic.BasicMenuItemUI 继承的字段
acceleratorFont, acceleratorForeground, acceleratorSelectionForeground, arrowIcon, checkIcon, defaultTextIconGap, disabledForeground, menuDragMouseListener, menuItem, menuKeyListener, mouseInputListener, oldBorderPainted, propertyChangeListener, selectionBackground, selectionForeground
构造方法摘要
BasicRadioButtonMenuItemUI()
方法摘要
static ComponentUI | createUI(JComponent b)
protected String | getPropertyPrefix()
void | processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
从类 javax.swing.plaf.basic.BasicMenuItemUI 继承的方法
createMenuDragMouseListener, createMenuKeyListener, createMouseInputListener, createPropertyChangeListener, doClick, getMaximumSize, getMinimumSize, getPath, getPreferredMenuItemSize, getPreferredSize, installComponents, installDefaults, installKeyboardActions, installListeners, installUI, paint, paintBackground, paintMenuItem, paintText, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicRadioButtonMenuItemUI

public BasicRadioButtonMenuItemUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent b)

getPropertyPrefix

protected String getPropertyPrefix()
覆盖：
类 BasicMenuItemUI 中的 getPropertyPrefix

processMouseEvent

public void processMouseEvent(JMenuItem item,
                              MouseEvent e,
                              MenuElement[] path,
                              MenuSelectionManager manager)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicRadioButtonUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicRadioButtonUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.basic.BasicButtonUI
                继承者  javax.swing.plaf.basic.BasicToggleButtonUI
                    继承者  javax.swing.plaf.basic.BasicRadioButtonUI
直接已知子类：
BasicCheckBoxUI, MetalRadioButtonUI
public class BasicRadioButtonUI
extends BasicToggleButtonUI

BasicRadioButtonUI 的 RadioButtonUI 实现

字段摘要
protected  Icon icon
从类 javax.swing.plaf.basic.BasicButtonUI 继承的字段
defaultTextIconGap, defaultTextShiftOffset
构造方法摘要
BasicRadioButtonUI()
方法摘要
static ComponentUI | createUI(JComponent b)
Icon | getDefaultIcon()
Dimension | getPreferredSize(JComponent c) 单选按钮的首选大小。
protected String | getPropertyPrefix()
protected void | installDefaults(AbstractButton b)
void | paint(Graphics g, JComponent c) 绘制单选按钮
protected void | paintFocus(Graphics g, Rectangle textRect, Dimension size)
protected void | uninstallDefaults(AbstractButton b)
从类 javax.swing.plaf.basic.BasicToggleButtonUI 继承的方法
getTextShiftOffset, paintIcon
从类 javax.swing.plaf.basic.BasicButtonUI 继承的方法
clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

icon

protected Icon icon
构造方法详细信息

BasicRadioButtonUI

public BasicRadioButtonUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent b)

getPropertyPrefix

protected String getPropertyPrefix()
覆盖：
类 BasicToggleButtonUI 中的 getPropertyPrefix

installDefaults

protected void installDefaults(AbstractButton b)
覆盖：
类 BasicButtonUI 中的 installDefaults

uninstallDefaults

protected void uninstallDefaults(AbstractButton b)
覆盖：
类 BasicButtonUI 中的 uninstallDefaults

getDefaultIcon

public Icon getDefaultIcon()

paint

public void paint(Graphics g,
                  JComponent c)
绘制单选按钮

覆盖：
类 BasicToggleButtonUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintFocus

protected void paintFocus(Graphics g,
                          Rectangle textRect,
                          Dimension size)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
单选按钮的首选大小。

覆盖：
类 BasicButtonUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicRootPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicRootPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.RootPaneUI
            继承者  javax.swing.plaf.basic.BasicRootPaneUI
所有已实现的接口：
PropertyChangeListener, EventListener
直接已知子类：
MetalRootPaneUI
public class BasicRootPaneUI
extends RootPaneUI
implements PropertyChangeListener

RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。

从以下版本开始：
1.3

构造方法摘要
BasicRootPaneUI()
方法摘要
static ComponentUI | createUI(JComponent c)
protected void | installComponents(JRootPane root)
protected void | installDefaults(JRootPane c)
protected void | installKeyboardActions(JRootPane root)
protected void | installListeners(JRootPane root)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | propertyChange(PropertyChangeEvent e) 在根窗格上发生属性更改时调用。
protected void | uninstallComponents(JRootPane root)
protected void | uninstallDefaults(JRootPane root)
protected void | uninstallKeyboardActions(JRootPane root)
protected void | uninstallListeners(JRootPane root)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicRootPaneUI

public BasicRootPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults(JRootPane c)

installComponents

protected void installComponents(JRootPane root)

installListeners

protected void installListeners(JRootPane root)

installKeyboardActions

protected void installKeyboardActions(JRootPane root)

uninstallDefaults

protected void uninstallDefaults(JRootPane root)

uninstallComponents

protected void uninstallComponents(JRootPane root)

uninstallListeners

protected void uninstallListeners(JRootPane root)

uninstallKeyboardActions

protected void uninstallKeyboardActions(JRootPane root)

propertyChange

public void propertyChange(PropertyChangeEvent e)
在根窗格上发生属性更改时调用。如果事件指示 defaultButton 已更改，则重新安装键盘动作。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ScrollBarUI
            继承者  javax.swing.plaf.basic.BasicScrollBarUI
所有已实现的接口：
LayoutManager, SwingConstants
直接已知子类：
MetalScrollBarUI
public class BasicScrollBarUI
extends ScrollBarUI
implements LayoutManager, SwingConstants

基本外观的 ScrollBarUI 的实现

嵌套类摘要
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.ModelListener 侦听模型更改的侦听器。
class | BasicScrollBarUI.PropertyChangeHandler
protected class | BasicScrollBarUI.ScrollListener 在 ScrollPane 中发起的滚动事件的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
字段摘要
protected BasicScrollBarUI.ArrowButtonListener | buttonListener
protected JButton | decrButton
protected static int | DECREASE_HIGHLIGHT
protected JButton | incrButton
protected static int | INCREASE_HIGHLIGHT
protected boolean | isDragging
protected Dimension | maximumThumbSize
protected Dimension | minimumThumbSize
protected BasicScrollBarUI.ModelListener | modelListener
protected static int | NO_HIGHLIGHT
protected PropertyChangeListener | propertyChangeListener
protected JScrollBar | scrollbar
protected BasicScrollBarUI.ScrollListener | scrollListener
protected Timer | scrollTimer
protected Color | thumbColor
protected Color | thumbDarkShadowColor
protected Color | thumbHighlightColor
protected Color | thumbLightShadowColor
protected Rectangle | thumbRect
protected Color | trackColor
protected int | trackHighlight
protected Color | trackHighlightColor
protected BasicScrollBarUI.TrackListener | trackListener
protected Rectangle | trackRect
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
BasicScrollBarUI()
方法摘要
void | addLayoutComponent(String name, Component child) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
protected void | configureScrollBarColors()
protected BasicScrollBarUI.ArrowButtonListener | createArrowButtonListener()
protected JButton | createDecreaseButton(int orientation)
protected JButton | createIncreaseButton(int orientation)
protected BasicScrollBarUI.ModelListener | createModelListener()
protected PropertyChangeListener | createPropertyChangeListener()
protected BasicScrollBarUI.ScrollListener | createScrollListener()
protected BasicScrollBarUI.TrackListener | createTrackListener()
static ComponentUI | createUI(JComponent c)
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
protected Dimension | getMaximumThumbSize() 返回 thumb 的最大可接受大小。
protected Dimension | getMinimumThumbSize() 返回 thumb 的最小可接受大小。
Dimension | getPreferredSize(JComponent c) 垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。
boolean | getSupportsAbsolutePositioning() 指示用户是否可以利用鼠标动作（通常使用中间的鼠标按键）来绝对定位 thumb。
protected Rectangle | getThumbBounds() 返回 thumb 的当前大小/位置。
protected Rectangle | getTrackBounds() 返回滑道的当前边界，即递增和递减按钮之间的空间（减去 insets）。
protected void | installComponents()
protected void | installDefaults()
protected void | installKeyboardActions()
protected void | installListeners()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
boolean | isThumbRollover() 如果鼠标当前位于 thumb 上，则返回 true。
void | layoutContainer(Container scrollbarContainer) 布置指定容器。
protected void | layoutHScrollbar(JScrollBar sb)
protected void | layoutVScrollbar(JScrollBar sb)
Dimension | minimumLayoutSize(Container scrollbarContainer) 给定指定容器所包含的组件，计算该容器的最小大小维数。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | paintDecreaseHighlight(Graphics g)
protected void | paintIncreaseHighlight(Graphics g)
protected void | paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected void | paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
Dimension | preferredLayoutSize(Container scrollbarContainer) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | removeLayoutComponent(Component child) 从布局移除指定组件。
protected void | scrollByBlock(int direction)
protected void | scrollByUnit(int direction)
protected void | setThumbBounds(int x, int y, int width, int height) 设置 thumb 的边界并强制进行包括新旧 thumbBounds 在内的重绘。
protected void | setThumbRollover(boolean active) 设置鼠标当前是否位于 thumb 上。
protected void | uninstallComponents()
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMinimumSize, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

minimumThumbSize

protected Dimension minimumThumbSize

maximumThumbSize

protected Dimension maximumThumbSize

thumbHighlightColor

protected Color thumbHighlightColor

thumbLightShadowColor

protected Color thumbLightShadowColor

thumbDarkShadowColor

protected Color thumbDarkShadowColor

thumbColor

protected Color thumbColor

trackColor

protected Color trackColor

trackHighlightColor

protected Color trackHighlightColor

scrollbar

protected JScrollBar scrollbar

incrButton

protected JButton incrButton

decrButton

protected JButton decrButton

isDragging

protected boolean isDragging

trackListener

protected BasicScrollBarUI.TrackListener trackListener

buttonListener

protected BasicScrollBarUI.ArrowButtonListener buttonListener

modelListener

protected BasicScrollBarUI.ModelListener modelListener

thumbRect

protected Rectangle thumbRect

trackRect

protected Rectangle trackRect

trackHighlight

protected int trackHighlight

NO_HIGHLIGHT

protected static final int NO_HIGHLIGHT
另请参见：
常量字段值

DECREASE_HIGHLIGHT

protected static final int DECREASE_HIGHLIGHT
另请参见：
常量字段值

INCREASE_HIGHLIGHT

protected static final int INCREASE_HIGHLIGHT
另请参见：
常量字段值

scrollListener

protected BasicScrollBarUI.ScrollListener scrollListener

propertyChangeListener

protected PropertyChangeListener propertyChangeListener

scrollTimer

protected Timer scrollTimer
构造方法详细信息

BasicScrollBarUI

public BasicScrollBarUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

configureScrollBarColors

protected void configureScrollBarColors()

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults()

installComponents

protected void installComponents()

uninstallComponents

protected void uninstallComponents()

installListeners

protected void installListeners()

installKeyboardActions

protected void installKeyboardActions()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

uninstallListeners

protected void uninstallListeners()

uninstallDefaults

protected void uninstallDefaults()

createTrackListener

protected BasicScrollBarUI.TrackListener createTrackListener()

createArrowButtonListener

protected BasicScrollBarUI.ArrowButtonListener createArrowButtonListener()

createModelListener

protected BasicScrollBarUI.ModelListener createModelListener()

createScrollListener

protected BasicScrollBarUI.ScrollListener createScrollListener()

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()

setThumbRollover

protected void setThumbRollover(boolean active)
设置鼠标当前是否位于 thumb 上。

参数：
active - 为 true 指示 thumb 当前处于激活状态。
从以下版本开始：
1.5

isThumbRollover

public boolean isThumbRollover()
如果鼠标当前位于 thumb 上，则返回 true。

返回：
如果 thumb 当前处于激活状态，则返回 true
从以下版本开始：
1.5

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。首选高度是相同部分的首选高度之和。水平滚动条的首选大小的基础与此类似。

preferredSize 仅计算一次，此方法的后续调用仅返回缓存的大小。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 委托此方法的 JScrollBar
返回：
Basic JScrollBar 的首选大小
另请参见：
getMaximumSize(javax.swing.JComponent), ComponentUI.getMinimumSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 委托此方法的 JScrollBar。
返回：
新的 Dimension(Integer.MAX_VALUE, Integer.MAX_VALUE)；
另请参见：
ComponentUI.getMinimumSize(javax.swing.JComponent), getPreferredSize(javax.swing.JComponent)

createDecreaseButton

protected JButton createDecreaseButton(int orientation)

createIncreaseButton

protected JButton createIncreaseButton(int orientation)

paintDecreaseHighlight

protected void paintDecreaseHighlight(Graphics g)

paintIncreaseHighlight

protected void paintIncreaseHighlight(Graphics g)

paintTrack

protected void paintTrack(Graphics g,
                          JComponent c,
                          Rectangle trackBounds)

paintThumb

protected void paintThumb(Graphics g,
                          JComponent c,
                          Rectangle thumbBounds)

getMinimumThumbSize

protected Dimension getMinimumThumbSize()
返回 thumb 的最小可接受大小。如果滚动条变得非常小，此大小不适用，则 thumb 将被隐藏。

警告：不应修改此方法返回的值，它是一个共享的静态常量。

返回：
thumb 的最小可接受大小。
另请参见：
getMaximumThumbSize()

getMaximumThumbSize

protected Dimension getMaximumThumbSize()
返回 thumb 的最大可接受大小。要创建固定大小的 thumb，需要让此方法和 getMinimumThumbSize 返回相同的值。

警告：不应修改此方法返回的值，它是一个共享的静态常量。

返回：
thumb 的最大可接受大小。
另请参见：
getMinimumThumbSize()

addLayoutComponent

public void addLayoutComponent(String name,
                               Component child)
从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
child - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component child)
从接口 LayoutManager 复制的描述
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
child - 要移除的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container scrollbarContainer)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的首选大小维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
scrollbarContainer - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container scrollbarContainer)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的最小大小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
scrollbarContainer - 要布置的组件

layoutVScrollbar

protected void layoutVScrollbar(JScrollBar sb)

layoutHScrollbar

protected void layoutHScrollbar(JScrollBar sb)

layoutContainer

public void layoutContainer(Container scrollbarContainer)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
scrollbarContainer - 要布置的容器

setThumbBounds

protected void setThumbBounds(int x,
                              int y,
                              int width,
                              int height)
设置 thumb 的边界并强制进行包括新旧 thumbBounds 在内的重绘。

另请参见：
getThumbBounds()

getThumbBounds

protected Rectangle getThumbBounds()
返回 thumb 的当前大小/位置。

警告：不应修改此方法返回的值，它是一个到实际矩形的引用，而不是一个副本。

返回：
thumb 的当前大小/位置。
另请参见：
setThumbBounds(int, int, int, int)

getTrackBounds

protected Rectangle getTrackBounds()
返回滑道的当前边界，即递增和递减按钮之间的空间（减去 insets）。每次布置滚动条时（确认后）此方法返回的值都会更新。

警告：不应修改此方法返回的值，它是一个到实际矩形的引用，而不是一个副本。

返回：
滚动条滑道的当前边界
另请参见：
layoutContainer(java.awt.Container)

scrollByBlock

protected void scrollByBlock(int direction)

scrollByUnit

protected void scrollByUnit(int direction)

getSupportsAbsolutePositioning

public boolean getSupportsAbsolutePositioning()
指示用户是否可以利用鼠标动作（通常使用中间的鼠标按键）来绝对定位 thumb。

返回：
如果鼠标运行可以绝对定位 thumb，则返回 true
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollBarUI.ArrowButtonListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollBarUI.ArrowButtonListener

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
BasicScrollBarUI
protected class BasicScrollBarUI.ArrowButtonListener
extends MouseAdapter

光标键的侦听器。

构造方法摘要
protected BasicScrollBarUI.ArrowButtonListener()
方法摘要
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollBarUI.ArrowButtonListener

protected BasicScrollBarUI.ArrowButtonListener()
方法详细信息

mousePressed

public void mousePressed(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollBarUI.ModelListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollBarUI.ModelListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicScrollBarUI.ModelListener
所有已实现的接口：
EventListener, ChangeListener
正在封闭类：
BasicScrollBarUI
protected class BasicScrollBarUI.ModelListener
extends Object
implements ChangeListener

侦听模型更改的侦听器。

构造方法摘要
protected BasicScrollBarUI.ModelListener()
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollBarUI.ModelListener

protected BasicScrollBarUI.ModelListener()
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollBarUI.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollBarUI.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicScrollBarUI
public class BasicScrollBarUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

构造方法摘要
BasicScrollBarUI.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollBarUI.PropertyChangeHandler

public BasicScrollBarUI.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollBarUI.ScrollListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollBarUI.ScrollListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
BasicScrollBarUI
protected class BasicScrollBarUI.ScrollListener
extends Object
implements ActionListener

在 ScrollPane 中发起的滚动事件的侦听器。

构造方法摘要
BasicScrollBarUI.ScrollListener()
BasicScrollBarUI.ScrollListener(int dir, boolean block)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
void | setDirection(int direction)
void | setScrollByBlock(boolean block)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollBarUI.ScrollListener

public BasicScrollBarUI.ScrollListener()

BasicScrollBarUI.ScrollListener

public BasicScrollBarUI.ScrollListener(int dir,
                                       boolean block)
方法详细信息

setDirection

public void setDirection(int direction)

setScrollByBlock

public void setScrollByBlock(boolean block)

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollBarUI.TrackListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollBarUI.TrackListener

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
BasicScrollBarUI
protected class BasicScrollBarUI.TrackListener
extends MouseAdapter
implements MouseMotionListener

跟踪鼠标拖动。

字段摘要
protected int | currentMouseX
protected int | currentMouseY
protected int | offset
构造方法摘要
protected BasicScrollBarUI.TrackListener()
方法摘要
void | mouseDragged(MouseEvent e) 将模型值设置为 thumb 的 Vertical 滚动条顶部的位置，或者相对于滑道原点的从左到右/从右到左滚动条中 Horizontal 滚动条的左部/右部位置。
void | mouseExited(MouseEvent e) 当鼠标退出滚动条时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按下鼠标则将滚动条值增加一页。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseEntered, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

offset

protected transient int offset

currentMouseX

protected transient int currentMouseX

currentMouseY

protected transient int currentMouseY
构造方法详细信息

BasicScrollBarUI.TrackListener

protected BasicScrollBarUI.TrackListener()
方法详细信息

mouseReleased

public void mouseReleased(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased

mousePressed

public void mousePressed(MouseEvent e)
如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按下鼠标则将滚动条值增加一页。如果不存在 thumb，则鼠标位于滑道的上半部分时向上翻页。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed

mouseDragged

public void mouseDragged(MouseEvent e)
将模型值设置为 thumb 的 Vertical 滚动条顶部的位置，或者相对于滑道原点的从左到右/从右到左滚动条中 Horizontal 滚动条的左部/右部位置。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseAdapter 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseAdapter 中的 mouseMoved

mouseExited

public void mouseExited(MouseEvent e)
当鼠标退出滚动条时调用。

指定者：
接口 MouseListener 中的 mouseExited
覆盖：
类 MouseAdapter 中的 mouseExited
参数：
e - 进一步描述事件的 MouseEvent
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ScrollPaneUI
            继承者  javax.swing.plaf.basic.BasicScrollPaneUI
所有已实现的接口：
ScrollPaneConstants
直接已知子类：
MetalScrollPaneUI
public class BasicScrollPaneUI
extends ScrollPaneUI
implements ScrollPaneConstants

ScrollPaneUI 的默认 L&F 实现。

嵌套类摘要
class | BasicScrollPaneUI.HSBChangeListener 水平滚动条侦听器。
protected class | BasicScrollPaneUI.MouseWheelHandler MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。
class | BasicScrollPaneUI.PropertyChangeHandler
class | BasicScrollPaneUI.ViewportChangeHandler 视口事件的侦听器。
class | BasicScrollPaneUI.VSBChangeListener 垂直滚动条侦听器。
字段摘要
protected ChangeListener | hsbChangeListener
protected JScrollPane | scrollpane
protected PropertyChangeListener | spPropertyChangeListener
protected ChangeListener | viewportChangeListener
protected ChangeListener | vsbChangeListener
从接口 javax.swing.ScrollPaneConstants 继承的字段
COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT
构造方法摘要
BasicScrollPaneUI()
方法摘要
protected  ChangeListener createHSBChangeListener()
protected  MouseWheelListener createMouseWheelListener()
创建一个 MouseWheelListener 的实例，该实例由 installUI() 添加到 JScrollPane。
protected  PropertyChangeListener createPropertyChangeListener()
创建由 installUI() 添加到 JScrollPane 的 PropertyChangeListener 的实例。
static ComponentUI createUI(JComponent x)
protected  ChangeListener createViewportChangeListener()
protected  ChangeListener createVSBChangeListener()
 int getBaseline(JComponent c, int width, int height)
返回基线。
 Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Dimension getMaximumSize(JComponent c)
返回指定组件的适合外观的最大大小。
protected  void installDefaults(JScrollPane scrollpane)
protected  void installKeyboardActions(JScrollPane c)
protected  void installListeners(JScrollPane c)
 void installUI(JComponent x)
配置指定组件，使其适合外观。
 void paint(Graphics g, JComponent c)
绘制指定组件，使其适合外观。
protected  void syncScrollPaneWithViewport()
protected  void uninstallDefaults(JScrollPane c)
protected  void uninstallKeyboardActions(JScrollPane c)
protected  void uninstallListeners(JComponent c)
 void uninstallUI(JComponent c)
在 installUI 期间，在指定组件上反向执行的配置操作。
protected  void updateColumnHeader(PropertyChangeEvent e)
protected  void updateRowHeader(PropertyChangeEvent e)
protected  void updateScrollBarDisplayPolicy(PropertyChangeEvent e)
protected  void updateViewport(PropertyChangeEvent e)
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getMinimumSize, getPreferredSize, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

scrollpane

protected JScrollPane scrollpane

vsbChangeListener

protected ChangeListener vsbChangeListener

hsbChangeListener

protected ChangeListener hsbChangeListener

viewportChangeListener

protected ChangeListener viewportChangeListener

spPropertyChangeListener

protected PropertyChangeListener spPropertyChangeListener
构造方法详细信息

BasicScrollPaneUI

public BasicScrollPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
新 Dimension(Short.MAX_VALUE, Short.MAX_VALUE)
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

installDefaults

protected void installDefaults(JScrollPane scrollpane)

installListeners

protected void installListeners(JScrollPane c)

installKeyboardActions

protected void installKeyboardActions(JScrollPane c)

installUI

public void installUI(JComponent x)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
x - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallDefaults

protected void uninstallDefaults(JScrollPane c)

uninstallListeners

protected void uninstallListeners(JComponent c)

uninstallKeyboardActions

protected void uninstallKeyboardActions(JScrollPane c)

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

syncScrollPaneWithViewport

protected void syncScrollPaneWithViewport()

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

createViewportChangeListener

protected ChangeListener createViewportChangeListener()

createHSBChangeListener

protected ChangeListener createHSBChangeListener()

createVSBChangeListener

protected ChangeListener createVSBChangeListener()

createMouseWheelListener

protected MouseWheelListener createMouseWheelListener()
创建一个 MouseWheelListener 的实例，该实例由 installUI() 添加到 JScrollPane。返回的 MouseWheelListener 用于处理鼠标滚轮驱动的滚动。

返回：
实现鼠标滚轮驱动滚动的 MouseWheelListener
从以下版本开始：
1.4
另请参见：
installUI(javax.swing.JComponent), BasicScrollPaneUI.MouseWheelHandler

updateScrollBarDisplayPolicy

protected void updateScrollBarDisplayPolicy(PropertyChangeEvent e)

updateViewport

protected void updateViewport(PropertyChangeEvent e)

updateRowHeader

protected void updateRowHeader(PropertyChangeEvent e)

updateColumnHeader

protected void updateColumnHeader(PropertyChangeEvent e)

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
创建由 installUI() 添加到 JScrollPane 的 PropertyChangeListener 的实例。子类可以重写此方法以返回自定义 PropertyChangeListener，例如
 class MyScrollPaneUI extends BasicScrollPaneUI {
    protected PropertyChangeListener createPropertyChangeListener() {
        return new MyPropertyChangeListener();
    }
    public class MyPropertyChangeListener extends PropertyChangeListener {
        public void propertyChange(PropertyChangeEvent e) {
            if (e.getPropertyName().equals("viewport")) {
                // do some extra work when the viewport changes
            }
            super.propertyChange(e);
        }
    }
 }

另请参见：
PropertyChangeListener, installUI(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComboPopup (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
接口 ComboPopup

所有已知实现类：
BasicComboPopup, MetalComboBoxUI.MetalComboPopup
public interface ComboPopup

定义实现组合框弹出部分所需方法的接口。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

方法摘要
KeyListener | getKeyListener() 返回将添加到组合框的键侦听器或 null。
JList | getList() 返回要用于在组合框中绘制项的列表。
MouseListener | getMouseListener() 返回将添加到组合框的鼠标侦听器或 null。
MouseMotionListener | getMouseMotionListener() 返回将添加到组合框的鼠标移动侦听器或 null。
void | hide() 隐藏弹出菜单
boolean | isVisible() 如果弹出菜单可见（当前显示的），则返回 true。
void | show() 显示弹出菜单
void | uninstallingUI() 调用以通知 ComboPopup 正在卸载 UI。

方法详细信息

show

void show()
显示弹出菜单

hide

void hide()
隐藏弹出菜单

isVisible

boolean isVisible()
如果弹出菜单可见（当前显示的），则返回 true。

返回：
如果此组件可见，则返回 true；否则返回 false。

getList

JList getList()
返回要用于在组合框中绘制项的列表。此方法是高度特定于实现的，不应该用于一般列表操作。

getMouseListener

MouseListener getMouseListener()
返回将添加到组合框的鼠标侦听器或 null。如果此方法返回 null，则不会将鼠标移动侦听器添加到组合框。

返回：
MouseListener 或 null

getMouseMotionListener

MouseMotionListener getMouseMotionListener()
返回将添加到组合框的鼠标移动侦听器或 null。如果此方法返回 null，则不会将鼠标移动侦听器添加到组合框。

返回：
MouseMotionListener 或 null

getKeyListener

KeyListener getKeyListener()
返回将添加到组合框的键侦听器或 null。如果此方法返回 null，则不会将鼠标移动侦听器添加到组合框。

uninstallingUI

void uninstallingUI()
调用以通知 ComboPopup 正在卸载 UI。如果 ComboPopup 在组件中添加了侦听器，则其应该在这里移除它们。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollPaneUI.HSBChangeListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollPaneUI.HSBChangeListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener
所有已实现的接口：
EventListener, ChangeListener
正在封闭类：
BasicScrollPaneUI
public class BasicScrollPaneUI.HSBChangeListener
extends Object
implements ChangeListener

水平滚动条侦听器。

构造方法摘要
BasicScrollPaneUI.HSBChangeListener()
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollPaneUI.HSBChangeListener

public BasicScrollPaneUI.HSBChangeListener()
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollPaneUI.MouseWheelHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollPaneUI.MouseWheelHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler
所有已实现的接口：
MouseWheelListener, EventListener
正在封闭类：
BasicScrollPaneUI
protected class BasicScrollPaneUI.MouseWheelHandler
extends Object
implements MouseWheelListener

MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。MouseWheelHandler 通过适当滚动 JScrollPane 来响应 MouseWheelEvent。如果滚动窗格的 isWheelScrollingEnabled 方法返回 false，则不发生任何滚动操作。

从以下版本开始：
1.4
另请参见：
JScrollPane.isWheelScrollingEnabled(), BasicScrollPaneUI.createMouseWheelListener(), MouseWheelListener, MouseWheelEvent

构造方法摘要
protected BasicScrollPaneUI.MouseWheelHandler()
方法摘要
 void mouseWheelMoved(MouseWheelEvent e)
当鼠标滚轮在 JScrollPane 上转动时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollPaneUI.MouseWheelHandler

protected BasicScrollPaneUI.MouseWheelHandler()
方法详细信息

mouseWheelMoved

public void mouseWheelMoved(MouseWheelEvent e)
当鼠标滚轮在 JScrollPane 上转动时调用。

指定者：
接口 MouseWheelListener 中的 mouseWheelMoved
参数：
e - 要处理的 MouseWheelEvent
从以下版本开始：
1.4
另请参见：
MouseWheelEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollPaneUI.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollPaneUI.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicScrollPaneUI
public class BasicScrollPaneUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

构造方法摘要
BasicScrollPaneUI.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollPaneUI.PropertyChangeHandler

public BasicScrollPaneUI.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollPaneUI.ViewportChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollPaneUI.ViewportChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler
所有已实现的接口：
EventListener, ChangeListener
正在封闭类：
BasicScrollPaneUI
public class BasicScrollPaneUI.ViewportChangeHandler
extends Object
implements ChangeListener

视口事件的侦听器。

构造方法摘要
BasicScrollPaneUI.ViewportChangeHandler()
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollPaneUI.ViewportChangeHandler

public BasicScrollPaneUI.ViewportChangeHandler()
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicScrollPaneUI.VSBChangeListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicScrollPaneUI.VSBChangeListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener
所有已实现的接口：
EventListener, ChangeListener
正在封闭类：
BasicScrollPaneUI
public class BasicScrollPaneUI.VSBChangeListener
extends Object
implements ChangeListener

垂直滚动条侦听器。

构造方法摘要
BasicScrollPaneUI.VSBChangeListener()
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicScrollPaneUI.VSBChangeListener

public BasicScrollPaneUI.VSBChangeListener()
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSeparatorUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSeparatorUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SeparatorUI
            继承者  javax.swing.plaf.basic.BasicSeparatorUI
直接已知子类：
BasicPopupMenuSeparatorUI, BasicToolBarSeparatorUI, MetalSeparatorUI
public class BasicSeparatorUI
extends SeparatorUI

SeparatorUI 的基本 L&F 实现。此实现是一个“组合的”视图/控制器。

字段摘要
protected Color | highlight
protected Color | shadow
构造方法摘要
BasicSeparatorUI()
方法摘要
static ComponentUI | createUI(JComponent c)
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected void | installDefaults(JSeparator s)
protected void | installListeners(JSeparator s)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | uninstallDefaults(JSeparator s)
protected void | uninstallListeners(JSeparator s)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

shadow

protected Color shadow

highlight

protected Color highlight
构造方法详细信息

BasicSeparatorUI

public BasicSeparatorUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults(JSeparator s)

uninstallDefaults

protected void uninstallDefaults(JSeparator s)

installListeners

protected void installListeners(JSeparator s)

uninstallListeners

protected void uninstallListeners(JSeparator s)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSliderUI.ActionScroller (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSliderUI.ActionScroller

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicSliderUI.ActionScroller
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicSliderUI
public class BasicSliderUI.ActionScroller
extends AbstractAction

从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。创建绑定的推荐方法是使用一个 ActionMap（用来包含动作）和 InputMap（用来包含从 KeyStroke 到动作描述的映射）的组合。InputMap 通常在 LookAndFeel 表中描述。

有关进一步的细节，请参阅键绑定规范。

此类应该视为“受保护”内部类。仅在 BasicSliderUI 的子类中实例化此类。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicSliderUI.ActionScroller(JSlider slider, int dir, boolean block)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSliderUI.ActionScroller

public BasicSliderUI.ActionScroller(JSlider slider,
                                    int dir,
                                    boolean block)
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSliderUI.ChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSliderUI.ChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSliderUI.ChangeHandler
所有已实现的接口：
EventListener, ChangeListener
正在封闭类：
BasicSliderUI
public class BasicSliderUI.ChangeHandler
extends Object
implements ChangeListener

数据模型侦听器。 此类应该视为“受保护”内部类。仅在 BasicSliderUI 的子类中实例化此类。

构造方法摘要
BasicSliderUI.ChangeHandler()
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSliderUI.ChangeHandler

public BasicSliderUI.ChangeHandler()
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSliderUI.ComponentHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSliderUI.ComponentHandler

java.lang.Object
    继承者  java.awt.event.ComponentAdapter
        继承者  javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
所有已实现的接口：
ComponentListener, EventListener
正在封闭类：
BasicSliderUI
public class BasicSliderUI.ComponentHandler
extends ComponentAdapter

调整事件大小的侦听器。

此类应该视为“受保护”内部类。仅在 BasicSliderUI 的子类中实例化此类。

构造方法摘要
BasicSliderUI.ComponentHandler()
方法摘要
 void componentResized(ComponentEvent e)
组件大小更改时调用。
从类 java.awt.event.ComponentAdapter 继承的方法
componentHidden, componentMoved, componentShown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSliderUI.ComponentHandler

public BasicSliderUI.ComponentHandler()
方法详细信息

componentResized

public void componentResized(ComponentEvent e)
从类 ComponentAdapter 复制的描述
组件大小更改时调用。

指定者：
接口 ComponentListener 中的 componentResized
覆盖：
类 ComponentAdapter 中的 componentResized
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSliderUI.FocusHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSliderUI.FocusHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSliderUI.FocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
BasicSliderUI
public class BasicSliderUI.FocusHandler
extends Object
implements FocusListener

焦点更改侦听器。

此类应该视为“受保护”内部类。仅在 BasicSliderUI 的子类中实例化此类。

构造方法摘要
BasicSliderUI.FocusHandler()
方法摘要
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSliderUI.FocusHandler

public BasicSliderUI.FocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent e)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSpinnerUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSpinnerUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SpinnerUI
            继承者  javax.swing.plaf.basic.BasicSpinnerUI

public class BasicSpinnerUI
extends SpinnerUI

默认 Spinner UI 委托。

从以下版本开始：
1.4

字段摘要
protected  JSpinner spinner
作为 UI 委托的 spinner。
构造方法摘要
BasicSpinnerUI()
方法摘要
protected JComponent | createEditor() installUI 通过调用此方法获取 JSpinner 的编辑器组件。
protected LayoutManager | createLayout() 创建管理 JSpinner 的 editor、nextButton 和 previousButton 子级的 LayoutManager。
protected Component | createNextButton() 创建将用 spinner.getNextValue 返回的对象取代 spinner 模型值的组件。
protected Component | createPreviousButton() 创建将用 spinner.getPreviousValue 返回的对象取代 spinner 模型值的组件。
protected PropertyChangeListener | createPropertyChangeListener() 创建一个可以添加到 JSpinner 本身的 PropertyChangeListener。
static ComponentUI | createUI(JComponent c) 返回 BasicSpinnerUI 的新实例。
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
protected void | installDefaults() 初始化 JSpinner border、foreground、background 属性以及基于默认表中对应的 "Spinner.*" 属性。
protected void | installKeyboardActions() 在 JSpinner 上安装键盘动作。
protected void | installListeners() 用将感兴趣的 PropertyChangeEvent 委托给受保护方法的共享对象初始化 PropertyChangeListener。
protected void | installNextButtonListeners(Component c) 在下一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
protected void | installPreviousButtonListeners(Component c) 在上一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
void | installUI(JComponent c) 调用 installDefaults、installListeners，然后添加由 createNextButton、createPreviousButton 和 createEditor 返回的组件。
protected void | replaceEditor(JComponent oldEditor, JComponent newEditor) 当 JSpinner 编辑器属性更改时，由 PropertyChangeListener 调用。
protected void | uninstallDefaults() 将 JSpinner 的布局管理器设置为 null。
protected void | uninstallListeners() 移除 installListeners 添加的 PropertyChangeListener。
void | uninstallUI(JComponent c) 调用 uninstallDefaults、uninstallListeners，然后移除所有子 spinner。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

spinner

protected JSpinner spinner
作为 UI 委托的 spinner。由 installUI 方法初始化，并由 uninstallUI 重置为 null。

另请参见：
installUI(javax.swing.JComponent), uninstallUI(javax.swing.JComponent)
构造方法详细信息

BasicSpinnerUI

public BasicSpinnerUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)
返回 BasicSpinnerUI 的新实例。每个 JSpinner 分配一个 SpinnerListUI 委托。

参数：
c - JSpinner（未使用）
返回：
新 BasicSpinnerUI 对象
另请参见：
ComponentUI.createUI(javax.swing.JComponent)

installUI

public void installUI(JComponent c)
调用 installDefaults、installListeners，然后添加由 createNextButton、createPreviousButton 和 createEditor 返回的组件。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - JSpinner
另请参见：
installDefaults(),
installListeners(),
createNextButton(),
createPreviousButton(),
createEditor()

uninstallUI

public void uninstallUI(JComponent c)
调用 uninstallDefaults、uninstallListeners，然后移除所有子 spinner。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - JSpinner（不使用）
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installListeners

protected void installListeners()
用将感兴趣的 PropertyChangeEvent 委托给受保护方法的共享对象初始化 PropertyChangeListener。

此方法由 installUI 调用。

另请参见：
replaceEditor(javax.swing.JComponent, javax.swing.JComponent), uninstallListeners()

uninstallListeners

protected void uninstallListeners()
移除 installListeners 添加的 PropertyChangeListener。

此方法由 uninstallUI 调用。

另请参见：
installListeners()

installDefaults

protected void installDefaults()
初始化 JSpinner border、foreground、background 属性以及基于默认表中对应的 "Spinner.*" 属性。将 JSpinner 布局设置为 createLayout 返回的值。此方法由 installUI 调用。

另请参见：
uninstallDefaults(),
installUI(javax.swing.JComponent),
createLayout(),
LookAndFeel.installBorder(javax.swing.JComponent, java.lang.String),
LookAndFeel.installColors(javax.swing.JComponent, java.lang.String, java.lang.String)

uninstallDefaults

protected void uninstallDefaults()
将 JSpinner 的布局管理器设置为 null。此方法由 uninstallUI 调用。

另请参见：
installDefaults(), uninstallUI(javax.swing.JComponent)

installNextButtonListeners

protected void installNextButtonListeners(Component c)
在下一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。

参数：
c - 要在其上安装侦听器的组件
抛出：
NullPointerException - 如果 c 为 null。
从以下版本开始：
1.5
另请参见：
createNextButton()

installPreviousButtonListeners

protected void installPreviousButtonListeners(Component c)
在上一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。

参数：
c - 要在其上安装侦听器的组件。
抛出：
NullPointerException - 如果 c 为 null。
从以下版本开始：
1.5
另请参见：
createPreviousButton()

createLayout

protected LayoutManager createLayout()
创建管理 JSpinner 的 editor、nextButton 和 previousButton 子级的 LayoutManager。必须用标识其职责的约束添加这三个子级："Editor"、"Next"、和 "Previous"。默认的布局管理器可以处理缺少这些子级中任意一个的情况。

返回：
编辑器、下一个和上一个按钮的 LayoutManager。
另请参见：
createNextButton(),
createPreviousButton(),
createEditor()

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
创建一个可以添加到 JSpinner 本身的 PropertyChangeListener。通常，此侦听器将在“编辑器”属性更改时调用 replaceEditor，因为它的 SpinnerUI 负责将编辑器添加到 JSpinner（并移除旧的）。此方法由 installListeners 调用。

返回：
JSpinner 本身的 PropertyChangeListener
另请参见：
installListeners()

createPreviousButton

protected Component createPreviousButton()
创建将用 spinner.getPreviousValue 返回的对象取代 spinner 模型值的组件。默认情况下 previousButton 为 JButton。此方法通过调用 installPreviousButtonListeners 安装必需的侦听器以更新 JSpinner 的模型来响应用户动作。如果不需要 previousButton（在子类中），则重写此方法以返回 null。

返回：
将用序列中的下一个值取代 spinner 模型的组件，或返回 null
另请参见：
installUI(javax.swing.JComponent),
createNextButton(),
installPreviousButtonListeners(java.awt.Component)

createNextButton

protected Component createNextButton()
创建将用 spinner.getNextValue 返回的对象取代 spinner 模型值的组件。默认情况下，nextButton 即为 JButton，其 ActionListener 更新其 JSpinner 祖先模型。如果不需要 nextButton（在子类中），则重写此方法以返回 null。

返回：
将用序列中的下一个值取代 spinner 模型的组件，或 null
另请参见：
installUI(javax.swing.JComponent),
createPreviousButton(),
installNextButtonListeners(java.awt.Component)

createEditor

protected JComponent createEditor()
installUI 通过调用此方法获取 JSpinner 的编辑器组件。默认情况下它仅返回 JSpinner.getEditor()。如果子类要使用重写的 installUI 将编辑器添加到 JSpinner 中，则其可以重写 createEditor 来返回包含 spinner 的编辑器的组件或 null。

通常重写此方法以利用带有自定义边框的容器包装编辑器，因为不能假定可以直接设置编辑器的边框。

利用 JSpinner.setEditor 更改 spinner 的编辑器时调用 replaceEditor 方法。如果已重写此方法，则可能还要重写 replaceEditor。

返回：
JSpinner 编辑器 JComponent，默认情况下返回 spinner.getEditor()
另请参见：
installUI(javax.swing.JComponent),
replaceEditor(javax.swing.JComponent, javax.swing.JComponent),
JSpinner.getEditor()

replaceEditor

protected void replaceEditor(JComponent oldEditor,
                             JComponent newEditor)
当 JSpinner 编辑器属性更改时，由 PropertyChangeListener 调用。此方法负责移除旧编辑器并添加新编辑器。默认情况下，此操作为：
 spinner.remove(oldEditor);
 spinner.add(newEditor, "Editor");
replaceEditor 的实现应该配合 createEditor 方法使用。

另请参见：
createEditor(), createPropertyChangeListener()

installKeyboardActions

protected void installKeyboardActions()
在 JSpinner 上安装键盘动作。

从以下版本开始：
1.5

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSliderUI.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSliderUI.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
直接已知子类：
MetalSliderUI.MetalPropertyListener
正在封闭类：
BasicSliderUI
public class BasicSliderUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

构造方法摘要
BasicSliderUI.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSliderUI.PropertyChangeHandler

public BasicSliderUI.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSliderUI.ScrollListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSliderUI.ScrollListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSliderUI.ScrollListener
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
BasicSliderUI
public class BasicSliderUI.ScrollListener
extends Object
implements ActionListener

滚动事件侦听器。 此类应该视为“受保护”内部类。仅在 BasicSliderUI 的子类中实例化此类。

构造方法摘要
BasicSliderUI.ScrollListener()
BasicSliderUI.ScrollListener(int dir, boolean block)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
void | setDirection(int direction)
void | setScrollByBlock(boolean block)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSliderUI.ScrollListener

public BasicSliderUI.ScrollListener()

BasicSliderUI.ScrollListener

public BasicSliderUI.ScrollListener(int dir,
                                    boolean block)
方法详细信息

setDirection

public void setDirection(int direction)

setScrollByBlock

public void setScrollByBlock(boolean block)

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSliderUI.TrackListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSliderUI.TrackListener

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.event.MouseInputAdapter
            继承者  javax.swing.plaf.basic.BasicSliderUI.TrackListener
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener, MouseInputListener
正在封闭类：
BasicSliderUI
public class BasicSliderUI.TrackListener
extends MouseInputAdapter

跟踪鼠标移动。 此类应该视为“受保护”内部类。仅在 BasicSliderUI 的子类中实例化此类。

字段摘要
protected int | currentMouseX
protected int | currentMouseY
protected int | offset
构造方法摘要
BasicSliderUI.TrackListener()
方法摘要
void | mouseDragged(MouseEvent e) 将模型值设置为相对于滑道原点的 thumb 顶部/左部位置。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按鼠标则将滚动条值增加一页。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
boolean | shouldScroll(int direction)
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseEntered, mouseExited, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.event.MouseListener 继承的方法
mouseClicked, mouseEntered, mouseExited

字段详细信息

offset

protected transient int offset

currentMouseX

protected transient int currentMouseX

currentMouseY

protected transient int currentMouseY
构造方法详细信息

BasicSliderUI.TrackListener

public BasicSliderUI.TrackListener()
方法详细信息

mouseReleased

public void mouseReleased(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased

mousePressed

public void mousePressed(MouseEvent e)
如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按鼠标则将滚动条值增加一页。如果不存在 thumb，则鼠标位于滑道的上半部分时向上翻页。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed

shouldScroll

public boolean shouldScroll(int direction)

mouseDragged

public void mouseDragged(MouseEvent e)
将模型值设置为相对于滑道原点的 thumb 顶部/左部位置。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseAdapter 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseAdapter 中的 mouseMoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneDivider (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneDivider

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.plaf.basic.BasicSplitPaneDivider
所有已实现的接口：
ImageObserver, MenuContainer, PropertyChangeListener, Serializable, EventListener
public class BasicSplitPaneDivider
extends Container
implements PropertyChangeListener

BasicSplitPaneUI 使用的分隔符。子类可能希望重写 paint 以进行某些更有趣的操作。边框效果是在 BasicSplitPaneUI 中绘制的，所以如果不喜欢该边框，可以在那里重置。要有条件地从某些区域拖动，请为 mousePressed 创建子类并在希望开始拖动时调用 super。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected class | BasicSplitPaneDivider.DividerLayout 用于布置 BasicSplitPaneDivider。
protected class | BasicSplitPaneDivider.DragController 在面向 HORIZONTAL_SPLIT 的拆分窗格的拖动会话期间处理事件。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
protected class | BasicSplitPaneDivider.VerticalDragController 在面向 VERTICAL_SPLIT 的拆分窗格的拖动会话期间处理事件。
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected int | dividerSize 分隔符的大小。
protected BasicSplitPaneDivider.DragController | dragger 处理要进行实际拖动操作的鼠标拖动消息。
protected Component | hiddenDivider 用于非连续布局模式的分隔符。
protected JButton | leftButton 用于快速切换左边组件的按钮。
protected BasicSplitPaneDivider.MouseHandler | mouseHandler 处理发自此类和拆分窗格的鼠标事件。
protected static int | ONE_TOUCH_OFFSET
protected static int | ONE_TOUCH_SIZE 基于 BasicSplitPaneUI 添加到它的两个方向的分隔符宽度和高度。
protected int | orientation JSplitPane 的方向。
protected JButton | rightButton 用于快速切换右边组件的按钮。
protected JSplitPane | splitPane 其中包含接收者的 JSplitPane。
protected BasicSplitPaneUI | splitPaneUI 从其创建此实例的 UI。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
BasicSplitPaneDivider(BasicSplitPaneUI ui)
创建 BasicSplitPaneDivider 的实例。
方法摘要
protected JButton | createLeftOneTouchButton() 创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的左边组件。
protected JButton | createRightOneTouchButton() 创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的右边组件。
protected void | dragDividerTo(int location) 利用包含此实例的 dragDividerTo 传递 BasicSplitPaneUI 的消息。
protected void | finishDraggingTo(int location) 利用包含此实例的 finishDraggingTo 传递 BasicSplitPaneUI 的消息。
BasicSplitPaneUI | getBasicSplitPaneUI() 返回接收者当前位于其中的 SplitPaneUI。
Border | getBorder() 返回此组件的边框，如果当前没有设置边框，则返回 null。
int | getDividerSize() 返回分隔符的大小。
Insets | getInsets() 如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
Dimension | getMinimumSize() 返回 dividerSize x dividerSize
Dimension | getPreferredSize() 返回 dividerSize x dividerSize
boolean | isMouseOver() 返回鼠标当前是否位于分隔符上
protected void | oneTouchExpandableChanged() 当包含接收者的 JSplitPane 的 oneTouchExpandable 值发生更改时传递消息。
void | paint(Graphics g) 绘制分隔符。
protected void | prepareForDragging() 传递消息以准备拖动操作。
void | propertyChange(PropertyChangeEvent e) 属性更改事件（假定发自 JSplitPane）将在必要时传递 updateOrientation 的消息。
void | setBasicSplitPaneUI(BasicSplitPaneUI newUI) 设置要使用接收者的 SplitPaneUI。
void | setBorder(Border border) 设置此组件的边框。
void | setDividerSize(int newSize) 将分隔符的大小设置为 newSize。
protected void | setMouseOver(boolean mouseOver) 设置鼠标当前是否位于分隔符上。
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addNotify, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getListeners, getMaximumSize, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ONE_TOUCH_SIZE

protected static final int ONE_TOUCH_SIZE
基于 BasicSplitPaneUI 添加到它的两个方向的分隔符宽度和高度。

另请参见：
常量字段值

ONE_TOUCH_OFFSET

protected static final int ONE_TOUCH_OFFSET
另请参见：
常量字段值

dragger

protected BasicSplitPaneDivider.DragController dragger
处理要进行实际拖动操作的鼠标拖动消息。

splitPaneUI

protected BasicSplitPaneUI splitPaneUI
从其创建此实例的 UI。

dividerSize

protected int dividerSize
分隔符的大小。

hiddenDivider

protected Component hiddenDivider
用于非连续布局模式的分隔符。

splitPane

protected JSplitPane splitPane
其中包含接收者的 JSplitPane。

mouseHandler

protected BasicSplitPaneDivider.MouseHandler mouseHandler
处理发自此类和拆分窗格的鼠标事件。为拆分窗格处理鼠标事件是因为在分隔符的边框上单击时希望能够拖动它，而该边框不是由分隔符绘制的。

orientation

protected int orientation
JSplitPane 的方向。

leftButton

protected JButton leftButton
用于快速切换左边组件的按钮。

rightButton

protected JButton rightButton
用于快速切换右边组件的按钮。

构造方法详细信息

BasicSplitPaneDivider

public BasicSplitPaneDivider(BasicSplitPaneUI ui)
创建 BasicSplitPaneDivider 的实例。为鼠标事件和鼠标拖动事件注册此实例。

方法详细信息

setBasicSplitPaneUI

public void setBasicSplitPaneUI(BasicSplitPaneUI newUI)
设置要使用接收者的 SplitPaneUI。

getBasicSplitPaneUI

public BasicSplitPaneUI getBasicSplitPaneUI()
返回接收者当前位于其中的 SplitPaneUI。

setDividerSize

public void setDividerSize(int newSize)
将分隔符的大小设置为 newSize。如果拆分窗格为 HORIZONTAL_SPLIT，则此为宽度；拆分窗格为 VERTICAL_SPLIT 则其为高度。

getDividerSize

public int getDividerSize()
返回分隔符的大小。如果拆分窗格为 HORIZONTAL_SPLIT，则此为宽度；拆分窗格为 VERTICAL_SPLIT 则其为高度。

setBorder

public void setBorder(Border border)
设置此组件的边框。

从以下版本开始：
1.3

getBorder

public Border getBorder()
返回此组件的边框，如果当前没有设置边框，则返回 null。

返回：
此组件的边框对象
从以下版本开始：
1.3
另请参见：
setBorder(javax.swing.border.Border)

getInsets

public Insets getInsets()
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。

覆盖：
类 Container 中的 getInsets
返回：
insets 属性的值。
另请参见：
setBorder(javax.swing.border.Border)

setMouseOver

protected void setMouseOver(boolean mouseOver)
设置鼠标当前是否位于分隔符上。

参数：
mouseOver - 鼠标当前是否位于分隔符上
从以下版本开始：
1.5

isMouseOver

public boolean isMouseOver()
返回鼠标当前是否位于分隔符上

返回：
鼠标当前是否位于分隔符上
从以下版本开始：
1.5

getPreferredSize

public Dimension getPreferredSize()
返回 dividerSize x dividerSize

覆盖：
类 Container 中的 getPreferredSize
返回：
表示此容器的首选大小的 Dimension 实例。
另请参见：
Container.getMinimumSize(),
Container.getMaximumSize(),
Container.getLayout(),
LayoutManager.preferredLayoutSize(Container),
Component.getPreferredSize()

getMinimumSize

public Dimension getMinimumSize()
返回 dividerSize x dividerSize

覆盖：
类 Container 中的 getMinimumSize
返回：
表示此容器的最小大小的 Dimension 实例。
另请参见：
Container.getPreferredSize(),
Container.getMaximumSize(),
Container.getLayout(),
LayoutManager.minimumLayoutSize(Container),
Component.getMinimumSize()

propertyChange

public void propertyChange(PropertyChangeEvent e)
属性更改事件（假定发自 JSplitPane）将在必要时传递 updateOrientation 的消息。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。

paint

public void paint(Graphics g)
绘制分隔符。

覆盖：
类 Container 中的 paint
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

oneTouchExpandableChanged

protected void oneTouchExpandableChanged()
当包含接收者的 JSplitPane 的 oneTouchExpandable 值发生更改时传递消息。将创建如果 leftButton 和 rightButton 为 null，则创建它们，同时使接收者无效。

createLeftOneTouchButton

protected JButton createLeftOneTouchButton()
创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的左边组件。

createRightOneTouchButton

protected JButton createRightOneTouchButton()
创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的右边组件。

prepareForDragging

protected void prepareForDragging()
传递消息以准备拖动操作。它利用 startDragging 传递 BasicSplitPaneUI 的消息。

dragDividerTo

protected void dragDividerTo(int location)
利用包含此实例的 dragDividerTo 传递 BasicSplitPaneUI 的消息。

finishDraggingTo

protected void finishDraggingTo(int location)
利用包含此实例的 finishDraggingTo 传递 BasicSplitPaneUI 的消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneDivider.DividerLayout (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneDivider.DividerLayout

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
所有已实现的接口：
LayoutManager
正在封闭类：
BasicSplitPaneDivider
protected class BasicSplitPaneDivider.DividerLayout
extends Object
implements LayoutManager

用于布置 BasicSplitPaneDivider。分隔器的布局涉及适当地到处移动左/右按钮。

构造方法摘要
protected BasicSplitPaneDivider.DividerLayout()
方法摘要
void | addLayoutComponent(String string, Component c) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
void | layoutContainer(Container c) 布置指定容器。
Dimension | minimumLayoutSize(Container c) 给定指定容器所包含的组件，计算该容器的最小大小维数。
Dimension | preferredLayoutSize(Container c) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | removeLayoutComponent(Component c) 从布局移除指定组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneDivider.DividerLayout

protected BasicSplitPaneDivider.DividerLayout()
方法详细信息

layoutContainer

public void layoutContainer(Container c)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
c - 要布置的容器

minimumLayoutSize

public Dimension minimumLayoutSize(Container c)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的最小大小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
c - 要布置的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container c)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的首选大小维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
c - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

removeLayoutComponent

public void removeLayoutComponent(Component c)
从接口 LayoutManager 复制的描述
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
c - 要移除的组件

addLayoutComponent

public void addLayoutComponent(String string,
                               Component c)
从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
string - 要与组件关联的字符串
c - 要添加的组件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneDivider.DragController (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneDivider.DragController

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
直接已知子类：
BasicSplitPaneDivider.VerticalDragController
正在封闭类：
BasicSplitPaneDivider
protected class BasicSplitPaneDivider.DragController
extends Object

在面向 HORIZONTAL_SPLIT 的拆分窗格的拖动会话期间处理事件。此操作会继续传递 dragDividerTo 的消息，到完成时传递 finishDraggingTo 的消息。创建实例时，它应该利用 isValid 传递消息来确保执行拖动操作（如果无法调整两个视图的大小，则不允许拖动）。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
protected BasicSplitPaneDivider.DragController(MouseEvent e)
方法摘要
protected void | completeDrag(int x, int y)
protected void | completeDrag(MouseEvent e) 用鼠标事件的新位置传递 finishDraggingTo 的消息。
protected void | continueDrag(int newX, int newY)
protected void | continueDrag(MouseEvent e) 用鼠标事件的新位置传递 dragDividerTo 的消息。
protected int | getNeededLocation(int x, int y) 返回 x 参数，因为可以将其用于水平拆分。
protected boolean | isValid() 如果拖动会话有效，则返回 true。
protected int | positionForMouseEvent(MouseEvent e) 返回基于传入的 MouseEvent 放置分隔器的新位置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneDivider.DragController

protected BasicSplitPaneDivider.DragController(MouseEvent e)
方法详细信息

isValid

protected boolean isValid()
如果拖动会话有效，则返回 true。

positionForMouseEvent

protected int positionForMouseEvent(MouseEvent e)
返回基于传入的 MouseEvent 放置分隔器的新位置。

getNeededLocation

protected int getNeededLocation(int x,
                                int y)
返回 x 参数，因为可以将其用于水平拆分。

continueDrag

protected void continueDrag(int newX,
                            int newY)

continueDrag

protected void continueDrag(MouseEvent e)
用鼠标事件的新位置传递 dragDividerTo 的消息。

completeDrag

protected void completeDrag(int x,
                            int y)

completeDrag

protected void completeDrag(MouseEvent e)
用鼠标事件的新位置传递 finishDraggingTo 的消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneDivider.MouseHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneDivider.MouseHandler

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
BasicSplitPaneDivider
protected class BasicSplitPaneDivider.MouseHandler
extends MouseAdapter
implements MouseMotionListener

MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。

构造方法摘要
protected BasicSplitPaneDivider.MouseHandler()
方法摘要
void | mouseDragged(MouseEvent e) 如果拖动器不为 null，则此方法利用 continueDrag 传递消息。
void | mouseEntered(MouseEvent e) 鼠标进入组件时调用。
void | mouseExited(MouseEvent e) 鼠标退出组件时调用。
void | mouseMoved(MouseEvent e) 基于方向重置光标。
void | mousePressed(MouseEvent e) 通过创建 DragController 的适当实例启动拖动会话。
void | mouseReleased(MouseEvent e) 如果拖动器不为 null，则此方法利用 completeDrag 传递消息。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneDivider.MouseHandler

protected BasicSplitPaneDivider.MouseHandler()
方法详细信息

mousePressed

public void mousePressed(MouseEvent e)
通过创建 DragController 的适当实例启动拖动会话。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent e)
如果拖动器不为 null，则此方法利用 completeDrag 传递消息。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased

mouseDragged

public void mouseDragged(MouseEvent e)
如果拖动器不为 null，则此方法利用 continueDrag 传递消息。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseAdapter 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
基于方向重置光标。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseAdapter 中的 mouseMoved

mouseEntered

public void mouseEntered(MouseEvent e)
鼠标进入组件时调用。

指定者：
接口 MouseListener 中的 mouseEntered
覆盖：
类 MouseAdapter 中的 mouseEntered
参数：
e - MouseEvent 描述进入事件的详细消息。
从以下版本开始：
1.5

mouseExited

public void mouseExited(MouseEvent e)
鼠标退出组件时调用。

指定者：
接口 MouseListener 中的 mouseExited
覆盖：
类 MouseAdapter 中的 mouseExited
参数：
e - MouseEvent 描述退出事件的详细消息。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneDivider.VerticalDragController (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneDivider.VerticalDragController

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
        继承者  javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
正在封闭类：
BasicSplitPaneDivider
protected class BasicSplitPaneDivider.VerticalDragController
extends BasicSplitPaneDivider.DragController

在面向 VERTICAL_SPLIT 的拆分窗格的拖动会话期间处理事件。此操作会继续传递 dragDividerTo 的消息，到完成时传递 finishDraggingTo 的消息。创建实例时，它应该利用 isValid 传递消息来确保执行拖动操作（如果无法调整两个视图的大小，则不允许拖动）。

构造方法摘要
protected BasicSplitPaneDivider.VerticalDragController(MouseEvent e)
方法摘要
protected int | getNeededLocation(int x, int y) 返回 y 参数，因为可以将其用于垂直拆分。
protected int | positionForMouseEvent(MouseEvent e) 返回基于传入的 MouseEvent 放置分隔器的新位置。
从类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 继承的方法
completeDrag, completeDrag, continueDrag, continueDrag, isValid
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneDivider.VerticalDragController

protected BasicSplitPaneDivider.VerticalDragController(MouseEvent e)
方法详细信息

getNeededLocation

protected int getNeededLocation(int x,
                                int y)
返回 y 参数，因为可以将其用于垂直拆分。

覆盖：
类 BasicSplitPaneDivider.DragController 中的 getNeededLocation

positionForMouseEvent

protected int positionForMouseEvent(MouseEvent e)
返回基于传入的 MouseEvent 放置分隔器的新位置。

覆盖：
类 BasicSplitPaneDivider.DragController 中的 positionForMouseEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SplitPaneUI
            继承者  javax.swing.plaf.basic.BasicSplitPaneUI
直接已知子类：
MetalSplitPaneUI
public class BasicSplitPaneUI
extends SplitPaneUI

SplitPaneUI 的基本 L&F 实现。

嵌套类摘要
class | BasicSplitPaneUI.BasicHorizontalLayoutManager 具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。
class | BasicSplitPaneUI.BasicVerticalLayoutManager 用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。
class | BasicSplitPaneUI.FocusHandler JSplitPane UI 使用的 FocusListener 的实现。
class | BasicSplitPaneUI.KeyboardDownRightHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardEndHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardHomeHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardResizeToggleHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardUpLeftHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.PropertyHandler JSplitPane UI 使用的 PropertyChangeListener 的实现。
字段摘要
protected int | beginDragDividerLocation 拖动会话开始时分隔符的位置。
protected BasicSplitPaneDivider | divider 此 JSplitPane 的分隔符的实例。
protected KeyStroke | dividerResizeToggleKey 已过时。 从 Java 2 platform v1.3 开始。
protected int | dividerSize 拖动会话有效时分隔符的大小。
protected KeyStroke | downKey 已过时。 从 Java 2 platform v1.3 开始。
protected boolean | draggingHW 如果任何一个子级（不包括 nonContinuousLayoutDivider）是重量级的，则在 startDragging 中设置 true。
protected KeyStroke | endKey 已过时。 从 Java 2 platform v1.3 开始。
protected FocusListener | focusListener 此 JSplitPane 的 FocusListener 的实例。
protected KeyStroke | homeKey 已过时。 从 Java 2 platform v1.3 开始。
protected static int | KEYBOARD_DIVIDER_MOVE_OFFSET 通过键盘上的光标键移动分隔符时移动的距离（相对）。
protected ActionListener | keyboardDownRightListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | keyboardEndListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | keyboardHomeListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | keyboardResizeToggleListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | keyboardUpLeftListener 已过时。 从 Java 2 platform v1.3 开始。
protected BasicSplitPaneUI.BasicHorizontalLayoutManager | layoutManager 创建并放到拆分窗格中的 LayoutManager。
protected KeyStroke | leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected static String | NON_CONTINUOUS_DIVIDER 用于非连续布局的分隔符通过此对象添加到拆分窗格。
protected Component | nonContinuousLayoutDivider 使用非连续布局时分隔符阴影的实例。
protected PropertyChangeListener | propertyChangeListener 此 JSplitPane 的 PropertyChangeListener 的实例。
protected KeyStroke | rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected JSplitPane | splitPane 此实例为其提供外观的 JSplitPane 实例。
protected KeyStroke | upKey 已过时。 从 Java 2 platform v1.3 开始。
构造方法摘要
BasicSplitPaneUI()
方法摘要
BasicSplitPaneDivider | createDefaultDivider() 创建默认的分隔符。
protected Component | createDefaultNonContinuousLayoutDivider() 返回默认的非连续布局分隔符，该分隔符是使用深灰色填充背景的 Canvas 的实例。
protected FocusListener | createFocusListener() 创建 JSplitPane UI 的 FocusListener。
protected ActionListener | createKeyboardDownRightListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | createKeyboardEndListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | createKeyboardHomeListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | createKeyboardResizeToggleListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | createKeyboardUpLeftListener() 已过时。 从 Java 2 platform v1.3 开始。
protected PropertyChangeListener | createPropertyChangeListener() 创建 JSplitPane UI 的 PropertyChangeListener。
static ComponentUI | createUI(JComponent x) 创建新的 BasicSplitPaneUI 实例
protected void | dragDividerTo(int location) 拖动会话期间传递消息以便将分隔符移动到传入位置。
protected void | finishDraggingTo(int location) 传递消息以完成拖动会话。
void | finishedPaintingChildren(JSplitPane jc, Graphics g) 在 JSplitPane 接收者将为绘制其子级提供外观后传递消息。
BasicSplitPaneDivider | getDivider() 返回顶层 Component 之间的分隔符。
protected int | getDividerBorderSize() 已过时。 从 Java 2 平台 v1.3 开始，由在分隔符上设置边框取代。
int | getDividerLocation(JSplitPane jc) 返回分隔符的位置，该位置可能不同于拆分窗格认为分隔符所在的位置。
Insets | getInsets(JComponent jc) 返回 insets。
int | getLastDragLocation() 返回 JSplitPane 的最后拖动位置。
int | getMaximumDividerLocation(JSplitPane jc) 获取分隔符的最大位置。
Dimension | getMaximumSize(JComponent jc) 返回传入组件的最大大小，该大小将传递给当前布局管理器。
int | getMinimumDividerLocation(JSplitPane jc) 获取分隔符的最小位置。
Dimension | getMinimumSize(JComponent jc) 返回传入组件的最小大小，该大小将传递给当前布局管理器。
Component | getNonContinuousLayoutDivider() 返回要在将 splitPane 配置为非连续布局时使用的分隔符。
int | getOrientation() 返回 JSplitPane 的方向。
Dimension | getPreferredSize(JComponent jc) 返回传入组件的首选大小，该大小将传递给当前布局管理器。
JSplitPane | getSplitPane() 返回当前包含此实例的拆分窗格。
protected void | installDefaults() 安装 UI 默认值。
protected void | installKeyboardActions() 安装 UI 的键盘动作。
protected void | installListeners() 安装 UI 的事件侦听器。
void | installUI(JComponent c) 安装 UI。
boolean | isContinuousLayout() 确定是否将 JSplitPane 设置为使用连续布局。
void | paint(Graphics g, JComponent jc) 传递消息以绘制外观。
protected void | resetLayoutManager() 基于方向重置布局管理器，并利用 invalidateLayout 传递其消息以拉入适当的 Component。
void | resetToPreferredSizes(JSplitPane jc) 传递消息以重置首选大小。
void | setContinuousLayout(boolean b) 打开/关闭连续布局。
void | setDividerLocation(JSplitPane jc, int location) 将分隔符的位置设置到 location。
void | setLastDragLocation(int l) 设置 JSplitPane 的最后拖动位置。
protected void | setNonContinuousLayoutDivider(Component newDivider) 设置要在将 splitPane 配置为非连续布局时使用的分隔符。
protected void | setNonContinuousLayoutDivider(Component newDivider, boolean rememberSizes) 设置要使用的分隔符。
void | setOrientation(int orientation) 设置 JSplitPane 的方向。
protected void | startDragging() 应该在拖动会话开始、重置 lastDragLocation 和 dividerSize 之前传递消息。
protected void | uninstallDefaults() 卸载 UI 默认值。
protected void | uninstallKeyboardActions() 卸载 UI 的键盘动作。
protected void | uninstallListeners() 卸载 UI 的事件侦听器。
void | uninstallUI(JComponent c) 卸载 UI。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NON_CONTINUOUS_DIVIDER

protected static final String NON_CONTINUOUS_DIVIDER
用于非连续布局的分隔符通过此对象添加到拆分窗格。

另请参见：
常量字段值

KEYBOARD_DIVIDER_MOVE_OFFSET

protected static int KEYBOARD_DIVIDER_MOVE_OFFSET
通过键盘上的光标键移动分隔符时移动的距离（相对）。

splitPane

protected JSplitPane splitPane
此实例为其提供外观的 JSplitPane 实例。

layoutManager

protected BasicSplitPaneUI.BasicHorizontalLayoutManager layoutManager
创建并放到拆分窗格中的 LayoutManager。

divider

protected BasicSplitPaneDivider divider
此 JSplitPane 的分隔符的实例。

propertyChangeListener

protected PropertyChangeListener propertyChangeListener
此 JSplitPane 的 PropertyChangeListener 的实例。

focusListener

protected FocusListener focusListener
此 JSplitPane 的 FocusListener 的实例。

dividerSize

protected int dividerSize
拖动会话有效时分隔符的大小。

nonContinuousLayoutDivider

protected Component nonContinuousLayoutDivider
使用非连续布局时分隔符阴影的实例。

draggingHW

protected boolean draggingHW
如果任何一个子级（不包括 nonContinuousLayoutDivider）是重量级的，则在 startDragging 中设置 true。

beginDragDividerLocation

protected int beginDragDividerLocation
拖动会话开始时分隔符的位置。

upKey

@Deprecated
protected KeyStroke upKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

downKey

@Deprecated
protected KeyStroke downKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

leftKey

@Deprecated
protected KeyStroke leftKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

rightKey

@Deprecated
protected KeyStroke rightKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

homeKey

@Deprecated
protected KeyStroke homeKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

endKey

@Deprecated
protected KeyStroke endKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

dividerResizeToggleKey

@Deprecated
protected KeyStroke dividerResizeToggleKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

keyboardUpLeftListener

@Deprecated
protected ActionListener keyboardUpLeftListener
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

keyboardDownRightListener

@Deprecated
protected ActionListener keyboardDownRightListener
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

keyboardHomeListener

@Deprecated
protected ActionListener keyboardHomeListener
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

keyboardEndListener

@Deprecated
protected ActionListener keyboardEndListener
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

keyboardResizeToggleListener

@Deprecated
protected ActionListener keyboardResizeToggleListener
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，有关更多详细信息，请参阅键绑定规范。

构造方法详细信息

BasicSplitPaneUI

public BasicSplitPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)
创建新的 BasicSplitPaneUI 实例

installUI

public void installUI(JComponent c)
安装 UI。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

installDefaults

protected void installDefaults()
安装 UI 默认值。

installListeners

protected void installListeners()
安装 UI 的事件侦听器。

installKeyboardActions

protected void installKeyboardActions()
安装 UI 的键盘动作。

uninstallUI

public void uninstallUI(JComponent c)
卸载 UI。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

uninstallDefaults

protected void uninstallDefaults()
卸载 UI 默认值。

uninstallListeners

protected void uninstallListeners()
卸载 UI 的事件侦听器。

uninstallKeyboardActions

protected void uninstallKeyboardActions()
卸载 UI 的键盘动作。

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
创建 JSplitPane UI 的 PropertyChangeListener。

createFocusListener

protected FocusListener createFocusListener()
创建 JSplitPane UI 的 FocusListener。

createKeyboardUpLeftListener

@Deprecated
protected ActionListener createKeyboardUpLeftListener()
已过时。 从 Java 2 platform v1.3 开始。

从 Java 2 平台 v1.3 开始，不再使用此方法。以前使用此方法的子类应改为创建包装 ActionListener 的 Action，再通过重写 installKeyboardActions 并将其置于 SplitPane 的 ActionMap 中来注册该 Action。有关进一步的细节，请参阅键绑定规范。

创建侦听特定按键的 JSplitPane UI 的 ActionListener。

createKeyboardDownRightListener

@Deprecated
protected ActionListener createKeyboardDownRightListener()
已过时。 从 Java 2 platform v1.3 开始。

从 Java 2 平台 v1.3 开始，不再使用此方法。以前使用此方法的子类应改为创建包装 ActionListener 的 Action，再通过重写 installKeyboardActions 并将其置于 SplitPane 的 ActionMap 中来注册该 Action。有关进一步的细节，请参阅键绑定规范。

创建侦听特定按键的 JSplitPane UI 的 ActionListener。

createKeyboardHomeListener

@Deprecated
protected ActionListener createKeyboardHomeListener()
已过时。 从 Java 2 platform v1.3 开始。

从 Java 2 平台 v1.3 开始，不再使用此方法。以前使用此方法的子类应改为创建包装 ActionListener 的 Action，再通过重写 installKeyboardActions 并将其置于 SplitPane 的 ActionMap 中来注册该 Action。有关进一步的细节，请参阅键绑定规范。

创建侦听特定按键的 JSplitPane UI 的 ActionListener。

createKeyboardEndListener

@Deprecated
protected ActionListener createKeyboardEndListener()
已过时。 从 Java 2 platform v1.3 开始。

从 Java 2 平台 v1.3 开始，不再使用此方法。以前使用此方法的子类应改为创建包装 ActionListener 的 Action，再通过重写 installKeyboardActions 并将其置于 SplitPane 的 ActionMap 中来注册该 Action。有关进一步的细节，请参阅键绑定规范。

创建侦听特定按键的 JSplitPane UI 的 ActionListener。

createKeyboardResizeToggleListener

@Deprecated
protected ActionListener createKeyboardResizeToggleListener()
已过时。 从 Java 2 platform v1.3 开始。

从 Java 2 平台 v1.3 开始，不再使用此方法。以前使用此方法的子类应改为创建包装 ActionListener 的 Action，再通过重写 installKeyboardActions 并将其置于 SplitPane 的 ActionMap 中来注册该 Action。有关进一步的细节，请参阅键绑定规范。

创建侦听特定按键的 JSplitPane UI 的 ActionListener。

getOrientation

public int getOrientation()
返回 JSplitPane 的方向。

setOrientation

public void setOrientation(int orientation)
设置 JSplitPane 的方向。

isContinuousLayout

public boolean isContinuousLayout()
确定是否将 JSplitPane 设置为使用连续布局。

setContinuousLayout

public void setContinuousLayout(boolean b)
打开/关闭连续布局。

getLastDragLocation

public int getLastDragLocation()
返回 JSplitPane 的最后拖动位置。

setLastDragLocation

public void setLastDragLocation(int l)
设置 JSplitPane 的最后拖动位置。

getDivider

public BasicSplitPaneDivider getDivider()
返回顶层 Component 之间的分隔符。

createDefaultNonContinuousLayoutDivider

protected Component createDefaultNonContinuousLayoutDivider()
返回默认的非连续布局分隔符，该分隔符是使用深灰色填充背景的 Canvas 的实例。

setNonContinuousLayoutDivider

protected void setNonContinuousLayoutDivider(Component newDivider)
设置要在将 splitPane 配置为非连续布局时使用的分隔符。此分隔符仅在拖动会话期间才能使用。建议传入重量级的组件。

setNonContinuousLayoutDivider

protected void setNonContinuousLayoutDivider(Component newDivider,
                                             boolean rememberSizes)
设置要使用的分隔符。

getNonContinuousLayoutDivider

public Component getNonContinuousLayoutDivider()
返回要在将 splitPane 配置为非连续布局时使用的分隔符。此分隔符仅在拖动会话期间才能使用。

getSplitPane

public JSplitPane getSplitPane()
返回当前包含此实例的拆分窗格。

createDefaultDivider

public BasicSplitPaneDivider createDefaultDivider()
创建默认的分隔符。

resetToPreferredSizes

public void resetToPreferredSizes(JSplitPane jc)
传递消息以重置首选大小。

指定者：
类 SplitPaneUI 中的 resetToPreferredSizes

setDividerLocation

public void setDividerLocation(JSplitPane jc,
                               int location)
将分隔符的位置设置到 location。

指定者：
类 SplitPaneUI 中的 setDividerLocation

getDividerLocation

public int getDividerLocation(JSplitPane jc)
返回分隔符的位置，该位置可能不同于拆分窗格认为分隔符所在的位置。

指定者：
类 SplitPaneUI 中的 getDividerLocation

getMinimumDividerLocation

public int getMinimumDividerLocation(JSplitPane jc)
获取分隔符的最小位置。

指定者：
类 SplitPaneUI 中的 getMinimumDividerLocation

getMaximumDividerLocation

public int getMaximumDividerLocation(JSplitPane jc)
获取分隔符的最大位置。

指定者：
类 SplitPaneUI 中的 getMaximumDividerLocation

finishedPaintingChildren

public void finishedPaintingChildren(JSplitPane jc,
                                     Graphics g)
在 JSplitPane 接收者将为绘制其子级提供外观后传递消息。

指定者：
类 SplitPaneUI 中的 finishedPaintingChildren

paint

public void paint(Graphics g,
                  JComponent jc)
传递消息以绘制外观。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
jc - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent jc)
返回传入组件的首选大小，该大小将传递给当前布局管理器。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
jc - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent jc)
返回传入组件的最小大小，该大小将传递给当前布局管理器。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
jc - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent jc)
返回传入组件的最大大小，该大小将传递给当前布局管理器。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
jc - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getInsets

public Insets getInsets(JComponent jc)
返回 insets。该 insets 是从当前边框的边框 insets 返回的。

resetLayoutManager

protected void resetLayoutManager()
基于方向重置布局管理器，并利用 invalidateLayout 传递其消息以拉入适当的 Component。

startDragging

protected void startDragging()
应该在拖动会话开始、重置 lastDragLocation 和 dividerSize 之前传递消息。

dragDividerTo

protected void dragDividerTo(int location)
拖动会话期间传递消息以便将分隔符移动到传入位置。如果 continuousLayout 为 true，则重置位置并验证 splitPane。

finishDraggingTo

protected void finishDraggingTo(int location)
传递消息以完成拖动会话。如果非连续显示，则重置分隔符的位置。

getDividerBorderSize

@Deprecated
protected int getDividerBorderSize()
已过时。 从 Java 2 平台 v1.3 开始，由在分隔符上设置边框取代。

从 Java 2 平台 v1.3 开始，不再使用此方法。应该在分隔符上设置边框。

返回一边的分隔符边框的宽度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.BasicHorizontalLayoutManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.BasicHorizontalLayoutManager

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
所有已实现的接口：
LayoutManager, LayoutManager2
直接已知子类：
BasicSplitPaneUI.BasicVerticalLayoutManager
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.BasicHorizontalLayoutManager
extends Object
implements LayoutManager2

具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。

字段摘要
protected Component[] | components
protected int[] | sizes
方法摘要
void | addLayoutComponent(Component comp, Object constraints) 使用指定的约束对象将指定组件添加到布局中。
void | addLayoutComponent(String place, Component component) 在 place 位置添加组件。
protected int | getAvailableSize(Dimension containerSize, Insets insets) 返回基于容器大小和 Insets 的可用宽度。
protected int | getInitialLocation(Insets insets) 如果 Insets 不为 null，则返回左边 inset；如果其为 null，则返回 0。
float | getLayoutAlignmentX(Container target) 返回容器沿 X 轴的对齐方式。
float | getLayoutAlignmentY(Container target) 返回容器沿 Y 轴的对齐方式。
protected int | getPreferredSizeOfComponent(Component c) 返回传入 Component 的首选大小的宽度。
protected int | getSizeOfComponent(Component c) 返回传入组件的宽度。
protected int[] | getSizes() 返回组件的大小。
void | invalidateLayout(Container c) 不执行任何操作。
void | layoutContainer(Container container) 进行实际布局。
Dimension | maximumLayoutSize(Container target) 返回最大布局大小，该大小在两个方向上都是 Integer.MAX_VALUE。
Dimension | minimumLayoutSize(Container container) 返回包含子级所需的最小大小。
Dimension | preferredLayoutSize(Container container) 返回包含子级所需的首选大小。
void | removeLayoutComponent(Component component) 根据了解的情况移除指定的组件。
protected void | resetSizeAt(int index) 在传入位置重置 Component 的大小。
void | resetToPreferredSizes() 标记接收者，以便下一次布置此实例时它将请求首选大小。
protected void | setComponentToSize(Component c, int size, int location, Insets insets, Dimension containerSize) 将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。
protected void | setSizes(int[] newSizes) 将大小设置为 newSizes。
protected void | updateComponents() 确定组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

sizes

protected int[] sizes

components

protected Component[] components
方法详细信息

layoutContainer

public void layoutContainer(Container container)
进行实际布局。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
container - 要布置的容器

addLayoutComponent

public void addLayoutComponent(String place,
                               Component component)
在 place 位置添加组件。Place 必须为 JSplitPane.LEFT、RIGHT、TOP、BOTTOM 或 null（用于分隔器）之一。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
place - 要与组件关联的字符串
component - 要添加的组件

minimumLayoutSize

public Dimension minimumLayoutSize(Container container)
返回包含子级所需的最小大小。宽度为所有子级的最小宽度之和，高度为子级的最小高度中的最大者。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
container - 要布置的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container container)
返回包含子级所需的首选大小。宽度为所有子级的首选宽度之和，高度为子级的首选高度中的最大者。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
container - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

removeLayoutComponent

public void removeLayoutComponent(Component component)
根据了解的情况移除指定的组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
component - 要移除的组件

addLayoutComponent

public void addLayoutComponent(Component comp,
                               Object constraints)
使用指定的约束对象将指定组件添加到布局中。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
comp - 要添加的组件
constraints - 如何将组件添加到布局以及添加到何处。

getLayoutAlignmentX

public float getLayoutAlignmentX(Container target)
返回容器沿 X 轴的对齐方式。这指出相对于其他组件将如何排列该组件。该值应该在 0 到 1 之间，其中，0 表示沿原点进行对齐，1 表示在距原点最远的地方对齐，0.5 表示居中等等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX

getLayoutAlignmentY

public float getLayoutAlignmentY(Container target)
返回容器沿 Y 轴的对齐方式。这指出相对于其他组件将如何排列该组件。该值应该在 0 到 1 之间，其中，0 表示沿原点进行对齐，1 表示在距原点最远的地方对齐，0.5 表示居中等等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY

invalidateLayout

public void invalidateLayout(Container c)
不执行任何操作。如果开发人员确实希望更改其中某个视图的大小，应该传递 JSplitPane.resetToPreferredSizes 的消息。

指定者：
接口 LayoutManager2 中的 invalidateLayout

maximumLayoutSize

public Dimension maximumLayoutSize(Container target)
返回最大布局大小，该大小在两个方向上都是 Integer.MAX_VALUE。

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
另请参见：
Component.getMaximumSize(), LayoutManager

resetToPreferredSizes

public void resetToPreferredSizes()
标记接收者，以便下一次布置此实例时它将请求首选大小。

resetSizeAt

protected void resetSizeAt(int index)
在传入位置重置 Component 的大小。

setSizes

protected void setSizes(int[] newSizes)
将大小设置为 newSizes。

getSizes

protected int[] getSizes()
返回组件的大小。

getPreferredSizeOfComponent

protected int getPreferredSizeOfComponent(Component c)
返回传入 Component 的首选大小的宽度。

getSizeOfComponent

protected int getSizeOfComponent(Component c)
返回传入组件的宽度。

getAvailableSize

protected int getAvailableSize(Dimension containerSize,
                               Insets insets)
返回基于容器大小和 Insets 的可用宽度。

getInitialLocation

protected int getInitialLocation(Insets insets)
如果 Insets 不为 null，则返回左边 inset；如果其为 null，则返回 0。

setComponentToSize

protected void setComponentToSize(Component c,
                                  int size,
                                  int location,
                                  Insets insets,
                                  Dimension containerSize)
将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。

updateComponents

protected void updateComponents()
确定组件。只要将其新实例安装到现有 SplitPane 中就应该调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTabbedPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTabbedPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TabbedPaneUI
            继承者  javax.swing.plaf.basic.BasicTabbedPaneUI
所有已实现的接口：
SwingConstants
直接已知子类：
MetalTabbedPaneUI
public class BasicTabbedPaneUI
extends TabbedPaneUI
implements SwingConstants

TabbedPaneUI 的基本 L&F 实现。

嵌套类摘要
class | BasicTabbedPaneUI.FocusHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.PropertyChangeHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.TabbedPaneLayout 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.TabSelectionHandler 此类应视为“受保护”内部类。
字段摘要
protected Rectangle | calcRect 用于通用布局计算以避免运行中构造多个新 Rectangle 的矩形。
protected Insets | contentBorderInsets
protected Color | darkShadow
protected KeyStroke | downKey 已过时。 从 Java 2 platform v1.3 开始。
protected Color | focus
protected FocusListener | focusListener
protected Color | highlight
protected KeyStroke | leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected Color | lightHighlight
protected int | maxTabHeight
protected int | maxTabWidth
protected MouseListener | mouseListener
protected PropertyChangeListener | propertyChangeListener
protected Rectangle[] | rects
protected KeyStroke | rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected int | runCount
protected int | selectedRun
protected Insets | selectedTabPadInsets
protected Color | shadow
protected Insets | tabAreaInsets
protected ChangeListener | tabChangeListener
protected Insets | tabInsets
protected JTabbedPane | tabPane
protected int | tabRunOverlay
protected int[] | tabRuns
protected int | textIconGap
protected KeyStroke | upKey 已过时。 从 Java 2 platform v1.3 开始。
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
BasicTabbedPaneUI()
方法摘要
protected void | assureRectsCreated(int tabCount)
protected int | calculateMaxTabHeight(int tabPlacement)
protected int | calculateMaxTabWidth(int tabPlacement)
protected int | calculateTabAreaHeight(int tabPlacement, int horizRunCount, int maxTabHeight)
protected int | calculateTabAreaWidth(int tabPlacement, int vertRunCount, int maxTabWidth)
protected int | calculateTabHeight(int tabPlacement, int tabIndex, int fontHeight)
protected int | calculateTabWidth(int tabPlacement, int tabIndex, FontMetrics metrics)
protected ChangeListener | createChangeListener()
protected FocusListener | createFocusListener()
protected LayoutManager | createLayoutManager() 由 installUI 调用，用于创建布局管理器对象以管理 JTabbedPane。
protected MouseListener | createMouseListener()
protected PropertyChangeListener | createPropertyChangeListener()
protected JButton | createScrollButton(int direction) 创建并返回一个 JButton，它将为用户提供朝某一特定方向滚动选项卡的方式。
static ComponentUI | createUI(JComponent c)
protected void | expandTabRunsArray()
protected int | getBaseline(int tab) 返回指定选项卡的基线。
int | getBaseline(JComponent c, int width, int height) 返回基线。
protected int | getBaselineOffset() 返回基线偏移的距离。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
protected Insets | getContentBorderInsets(int tabPlacement)
protected int | getFocusIndex() 返回具有焦点的选项卡的索引。
protected FontMetrics | getFontMetrics()
protected Icon | getIconForTab(int tabIndex)
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
protected int | getNextTabIndex(int base)
protected int | getNextTabIndexInRun(int tabCount, int base)
protected int | getNextTabRun(int baseRun)
protected int | getPreviousTabIndex(int base)
protected int | getPreviousTabIndexInRun(int tabCount, int base)
protected int | getPreviousTabRun(int baseRun)
protected int | getRolloverTab() 返回当前有鼠标位于其上方的选项卡；如果鼠标不再位于任何选项卡上，则返回 -1。
protected int | getRunForTab(int tabCount, int tabIndex)
protected Insets | getSelectedTabPadInsets(int tabPlacement)
protected Insets | getTabAreaInsets(int tabPlacement)
protected Rectangle | getTabBounds(int tabIndex, Rectangle dest) 返回 JTabbedPane 组件的坐标空间中指定选项卡的边界。
Rectangle | getTabBounds(JTabbedPane pane, int i) 返回指定选项卡索引的边界。
protected Insets | getTabInsets(int tabPlacement, int tabIndex)
protected int | getTabLabelShiftX(int tabPlacement, int tabIndex, boolean isSelected)
protected int | getTabLabelShiftY(int tabPlacement, int tabIndex, boolean isSelected)
int | getTabRunCount(JTabbedPane pane)
protected int | getTabRunIndent(int tabPlacement, int run)
protected int | getTabRunOffset(int tabPlacement, int tabCount, int tabIndex, boolean forward)
protected int | getTabRunOverlay(int tabPlacement)
protected View | getTextViewForTab(int tabIndex) 返回为指定选项卡呈现样式化文本 (HTML) 所需的文本 View 对象；如果此选项卡不需要任何特殊化的文本呈现，则返回 null。
protected Component | getVisibleComponent()
protected void | installComponents() 创建并安装 JTabbedPane 的所有必需的子组件。
protected void | installDefaults()
protected void | installKeyboardActions()
protected void | installListeners()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected int | lastTabInRun(int tabCount, int run)
protected void | layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | navigateSelectedTab(int direction)
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | paintContentBorder(Graphics g, int tabPlacement, int selectedIndex)
protected void | paintContentBorderBottomEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | paintContentBorderLeftEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | paintContentBorderRightEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | paintContentBorderTopEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
protected void | paintTab(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
protected void | paintTabArea(Graphics g, int tabPlacement, int selectedIndex) 在选项卡区域绘制选项卡。
protected void | paintTabBackground(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
protected void | paintTabBorder(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected) 此方法围绕每个选项卡绘制边框。
protected void | paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
protected static void | rotateInsets(Insets topInsets, Insets targetInsets, int targetPlacement)
protected void | selectAdjacentRunTab(int tabPlacement, int tabIndex, int offset)
protected void | selectNextTab(int current)
protected void | selectNextTabInRun(int current)
protected void | selectPreviousTab(int current)
protected void | selectPreviousTabInRun(int current)
protected void | setRolloverTab(int index) 将当前有鼠标位于其上方的选项卡设置为 index。
protected void | setVisibleComponent(Component component)
protected boolean | shouldPadTabRun(int tabPlacement, int run)
protected boolean | shouldRotateTabRuns(int tabPlacement)
int | tabForCoordinate(JTabbedPane pane, int x, int y) 返回与 JTabbedPane 的坐标空间中的指定点相交的选项卡索引。
protected void | uninstallComponents() 从 JTabbedPane 移除所有已安装的子组件。
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getPreferredSize, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

tabPane

protected JTabbedPane tabPane

highlight

protected Color highlight

lightHighlight

protected Color lightHighlight

shadow

protected Color shadow

darkShadow

protected Color darkShadow

focus

protected Color focus

textIconGap

protected int textIconGap

tabRunOverlay

protected int tabRunOverlay

tabInsets

protected Insets tabInsets

selectedTabPadInsets

protected Insets selectedTabPadInsets

tabAreaInsets

protected Insets tabAreaInsets

contentBorderInsets

protected Insets contentBorderInsets

upKey

@Deprecated
protected KeyStroke upKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

downKey

@Deprecated
protected KeyStroke downKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

leftKey

@Deprecated
protected KeyStroke leftKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

rightKey

@Deprecated
protected KeyStroke rightKey
已过时。 从 Java 2 platform v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

tabRuns

protected int[] tabRuns

runCount

protected int runCount

selectedRun

protected int selectedRun

rects

protected Rectangle[] rects

maxTabHeight

protected int maxTabHeight

maxTabWidth

protected int maxTabWidth

tabChangeListener

protected ChangeListener tabChangeListener

propertyChangeListener

protected PropertyChangeListener propertyChangeListener

mouseListener

protected MouseListener mouseListener

focusListener

protected FocusListener focusListener

calcRect

protected transient Rectangle calcRect
用于通用布局计算以避免运行中构造多个新 Rectangle 的矩形。

构造方法详细信息

BasicTabbedPaneUI

public BasicTabbedPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

createLayoutManager

protected LayoutManager createLayoutManager()
由 installUI 调用，用于创建布局管理器对象以管理 JTabbedPane。

返回：
布局管理器对象
另请参见：
BasicTabbedPaneUI.TabbedPaneLayout, JTabbedPane.getTabLayoutPolicy()

installComponents

protected void installComponents()
创建并安装 JTabbedPane 的所有必需的子组件。由 installUI 调用。

从以下版本开始：
1.4

createScrollButton

protected JButton createScrollButton(int direction)
创建并返回一个 JButton，它将为用户提供朝某一特定方向滚动选项卡的方式。返回的 JButton 必须为 UIResource 的实例。

参数：
direction - SwingConstants 常量之一：SOUTH、NORTH、EAST 或 WEST
返回：
供用户使用的 Widget
抛出：
IllegalArgumentException - 如果方向不为 NORTH、SOUTH、EAST 或 WEST 之一
从以下版本开始：
1.5
另请参见：
JTabbedPane.setTabPlacement(int), SwingConstants

uninstallComponents

protected void uninstallComponents()
从 JTabbedPane 移除所有已安装的子组件。由 uninstallUI 调用。

从以下版本开始：
1.4

installDefaults

protected void installDefaults()

uninstallDefaults

protected void uninstallDefaults()

installListeners

protected void installListeners()

uninstallListeners

protected void uninstallListeners()

createMouseListener

protected MouseListener createMouseListener()

createFocusListener

protected FocusListener createFocusListener()

createChangeListener

protected ChangeListener createChangeListener()

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()

installKeyboardActions

protected void installKeyboardActions()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

setRolloverTab

protected void setRolloverTab(int index)
将当前有鼠标位于其上方的选项卡设置为 index。如果鼠标不再位于任何选项卡上，则 index 将为 -1。没有执行任何检查来确保传入的索引标识有效的选项卡。

参数：
index - 鼠标位于其上方的选项卡的索引。
从以下版本开始：
1.5

getRolloverTab

protected int getRolloverTab()
返回当前有鼠标位于其上方的选项卡；如果鼠标不再位于任何选项卡上，则返回 -1。

返回：
当前有鼠标位于其上方的选项卡；如果鼠标不再位于任何选项卡上，则返回 -1
从以下版本开始：
1.5

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaseline

protected int getBaseline(int tab)
返回指定选项卡的基线。

参数：
tab - 获取其基线的选项卡的索引
返回：
基线，或返回 < 0 的值指示没有合理的基线
抛出：
IndexOutOfBoundsException - 如果索引超出范围（index < 0 || index >= tab count）
从以下版本开始：
1.6

getBaselineOffset

protected int getBaselineOffset()
返回基线偏移的距离。这通常与 getTabLabelShiftY 相同。

返回：
基线偏移的距离
从以下版本开始：
1.6

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintTabArea

protected void paintTabArea(Graphics g,
                            int tabPlacement,
                            int selectedIndex)
在选项卡区域绘制选项卡。由 paint() 调用。图形参数必须为有效的 Graphics 对象。布局可以是以下几种之一：JTabbedPane.TOP、JTabbedPane.BOTTOM、JTabbedPane.LEFT 或 JTabbedPane.RIGHT。选择的索引必须为有效的选项卡窗格选项卡索引（0 至选项卡数 - 1，包括两者）；如果当前没有选项选项卡，则为 -1。无效参数的处理没有指定。

参数：
g - 要用于呈现的图形对象
tabPlacement - JTabbedPane 中选项卡的位置
selectedIndex - 所选组件的选项卡索引
从以下版本开始：
1.4

paintTab

protected void paintTab(Graphics g,
                        int tabPlacement,
                        Rectangle[] rects,
                        int tabIndex,
                        Rectangle iconRect,
                        Rectangle textRect)

layoutLabel

protected void layoutLabel(int tabPlacement,
                           FontMetrics metrics,
                           int tabIndex,
                           String title,
                           Icon icon,
                           Rectangle tabRect,
                           Rectangle iconRect,
                           Rectangle textRect,
                           boolean isSelected)

paintIcon

protected void paintIcon(Graphics g,
                         int tabPlacement,
                         int tabIndex,
                         Icon icon,
                         Rectangle iconRect,
                         boolean isSelected)

paintText

protected void paintText(Graphics g,
                         int tabPlacement,
                         Font font,
                         FontMetrics metrics,
                         int tabIndex,
                         String title,
                         Rectangle textRect,
                         boolean isSelected)

getTabLabelShiftX

protected int getTabLabelShiftX(int tabPlacement,
                                int tabIndex,
                                boolean isSelected)

getTabLabelShiftY

protected int getTabLabelShiftY(int tabPlacement,
                                int tabIndex,
                                boolean isSelected)

paintFocusIndicator

protected void paintFocusIndicator(Graphics g,
                                   int tabPlacement,
                                   Rectangle[] rects,
                                   int tabIndex,
                                   Rectangle iconRect,
                                   Rectangle textRect,
                                   boolean isSelected)

paintTabBorder

protected void paintTabBorder(Graphics g,
                              int tabPlacement,
                              int tabIndex,
                              int x,
                              int y,
                              int w,
                              int h,
                              boolean isSelected)
此方法围绕每个选项卡绘制边框。注意，此方法现在已经能够绘制选项卡的背景，这在其他地方完成。

paintTabBackground

protected void paintTabBackground(Graphics g,
                                  int tabPlacement,
                                  int tabIndex,
                                  int x,
                                  int y,
                                  int w,
                                  int h,
                                  boolean isSelected)

paintContentBorder

protected void paintContentBorder(Graphics g,
                                  int tabPlacement,
                                  int selectedIndex)

paintContentBorderTopEdge

protected void paintContentBorderTopEdge(Graphics g,
                                         int tabPlacement,
                                         int selectedIndex,
                                         int x,
                                         int y,
                                         int w,
                                         int h)

paintContentBorderLeftEdge

protected void paintContentBorderLeftEdge(Graphics g,
                                          int tabPlacement,
                                          int selectedIndex,
                                          int x,
                                          int y,
                                          int w,
                                          int h)

paintContentBorderBottomEdge

protected void paintContentBorderBottomEdge(Graphics g,
                                            int tabPlacement,
                                            int selectedIndex,
                                            int x,
                                            int y,
                                            int w,
                                            int h)

paintContentBorderRightEdge

protected void paintContentBorderRightEdge(Graphics g,
                                           int tabPlacement,
                                           int selectedIndex,
                                           int x,
                                           int y,
                                           int w,
                                           int h)

getTabBounds

public Rectangle getTabBounds(JTabbedPane pane,
                              int i)
返回指定选项卡索引的边界。这些边界与 JTabbedPane 的坐标空间有关。

指定者：
类 TabbedPaneUI 中的 getTabBounds

getTabRunCount

public int getTabRunCount(JTabbedPane pane)
指定者：
类 TabbedPaneUI 中的 getTabRunCount

tabForCoordinate

public int tabForCoordinate(JTabbedPane pane,
                            int x,
                            int y)
返回与 JTabbedPane 的坐标空间中的指定点相交的选项卡索引。

指定者：
类 TabbedPaneUI 中的 tabForCoordinate

getTabBounds

protected Rectangle getTabBounds(int tabIndex,
                                 Rectangle dest)
返回 JTabbedPane 组件的坐标空间中指定选项卡的边界。这一点是必需的，因为默认情况下选项卡矩形是在呈现它们的组件的坐标空间中定义的，该组件可以为 JTabbedPane（对于 WRAP_TAB_LAYOUT）或 ScrollableTabPanel（对于 SCROLL_TAB_LAYOUT）。只要选项卡矩形必须相对于 JTabbedPane 本身就应该使用此方法，并且应该将结果置于指定的 Rectangle 对象中（而不是每次都要实例化并返回新的 Rectangle）。选项卡索引参数必须为有效的选项卡窗格选项卡索引（0 至选项卡数 - 1，包括两者）。目标矩形参数必须为有效的 Rectangle 实例。无效参数的处理没有指定。

参数：
tabIndex - 选项卡的索引
dest - 应将结果置于其中的矩形
返回：
得到的矩形
从以下版本开始：
1.4

getVisibleComponent

protected Component getVisibleComponent()

setVisibleComponent

protected void setVisibleComponent(Component component)

assureRectsCreated

protected void assureRectsCreated(int tabCount)

expandTabRunsArray

protected void expandTabRunsArray()

getRunForTab

protected int getRunForTab(int tabCount,
                           int tabIndex)

lastTabInRun

protected int lastTabInRun(int tabCount,
                           int run)

getTabRunOverlay

protected int getTabRunOverlay(int tabPlacement)

getTabRunIndent

protected int getTabRunIndent(int tabPlacement,
                              int run)

shouldPadTabRun

protected boolean shouldPadTabRun(int tabPlacement,
                                  int run)

shouldRotateTabRuns

protected boolean shouldRotateTabRuns(int tabPlacement)

getIconForTab

protected Icon getIconForTab(int tabIndex)

getTextViewForTab

protected View getTextViewForTab(int tabIndex)
返回为指定选项卡呈现样式化文本 (HTML) 所需的文本 View 对象；如果此选项卡不需要任何特殊化的文本呈现，则返回 null。提供它是为了支持在选项卡内进行的 html 呈现。

参数：
tabIndex - 选项卡的索引
返回：
呈现选项卡文本的文本视图；如果不需要任何特殊化的呈现，则返回 null
从以下版本开始：
1.4

calculateTabHeight

protected int calculateTabHeight(int tabPlacement,
                                 int tabIndex,
                                 int fontHeight)

calculateMaxTabHeight

protected int calculateMaxTabHeight(int tabPlacement)

calculateTabWidth

protected int calculateTabWidth(int tabPlacement,
                                int tabIndex,
                                FontMetrics metrics)

calculateMaxTabWidth

protected int calculateMaxTabWidth(int tabPlacement)

calculateTabAreaHeight

protected int calculateTabAreaHeight(int tabPlacement,
                                     int horizRunCount,
                                     int maxTabHeight)

calculateTabAreaWidth

protected int calculateTabAreaWidth(int tabPlacement,
                                    int vertRunCount,
                                    int maxTabWidth)

getTabInsets

protected Insets getTabInsets(int tabPlacement,
                              int tabIndex)

getSelectedTabPadInsets

protected Insets getSelectedTabPadInsets(int tabPlacement)

getTabAreaInsets

protected Insets getTabAreaInsets(int tabPlacement)

getContentBorderInsets

protected Insets getContentBorderInsets(int tabPlacement)

getFontMetrics

protected FontMetrics getFontMetrics()

navigateSelectedTab

protected void navigateSelectedTab(int direction)

selectNextTabInRun

protected void selectNextTabInRun(int current)

selectPreviousTabInRun

protected void selectPreviousTabInRun(int current)

selectNextTab

protected void selectNextTab(int current)

selectPreviousTab

protected void selectPreviousTab(int current)

selectAdjacentRunTab

protected void selectAdjacentRunTab(int tabPlacement,
                                    int tabIndex,
                                    int offset)

getFocusIndex

protected int getFocusIndex()
返回具有焦点的选项卡的索引。

返回：
具有焦点的选项卡的索引
从以下版本开始：
1.5

getTabRunOffset

protected int getTabRunOffset(int tabPlacement,
                              int tabCount,
                              int tabIndex,
                              boolean forward)

getPreviousTabIndex

protected int getPreviousTabIndex(int base)

getNextTabIndex

protected int getNextTabIndex(int base)

getNextTabIndexInRun

protected int getNextTabIndexInRun(int tabCount,
                                   int base)

getPreviousTabIndexInRun

protected int getPreviousTabIndexInRun(int tabCount,
                                       int base)

getPreviousTabRun

protected int getPreviousTabRun(int baseRun)

getNextTabRun

protected int getNextTabRun(int baseRun)

rotateInsets

protected static void rotateInsets(Insets topInsets,
                                   Insets targetInsets,
                                   int targetPlacement)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.BasicVerticalLayoutManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.BasicVerticalLayoutManager

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
        继承者  javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
所有已实现的接口：
LayoutManager, LayoutManager2
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.BasicVerticalLayoutManager
extends BasicSplitPaneUI.BasicHorizontalLayoutManager

用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。

字段摘要
从类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 继承的字段
components, sizes
构造方法摘要
BasicSplitPaneUI.BasicVerticalLayoutManager()
方法摘要
从类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 继承的方法
addLayoutComponent, addLayoutComponent, getAvailableSize, getInitialLocation, getLayoutAlignmentX, getLayoutAlignmentY, getPreferredSizeOfComponent, getSizeOfComponent, getSizes, invalidateLayout, layoutContainer, maximumLayoutSize, minimumLayoutSize, preferredLayoutSize, removeLayoutComponent, resetSizeAt, resetToPreferredSizes, setComponentToSize, setSizes, updateComponents
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneUI.BasicVerticalLayoutManager

public BasicSplitPaneUI.BasicVerticalLayoutManager()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.FocusHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.FocusHandler

java.lang.Object
    继承者  java.awt.event.FocusAdapter
        继承者  javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.FocusHandler
extends FocusAdapter

JSplitPane UI 使用的 FocusListener 的实现。

此类应该视为“受保护”内部类。仅在 BasicSplitPaneUI 的子类中实例化此类。

构造方法摘要
BasicSplitPaneUI.FocusHandler()
方法摘要
void | focusGained(FocusEvent ev) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent ev) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneUI.FocusHandler

public BasicSplitPaneUI.FocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent ev)
从类 FocusAdapter 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained
覆盖：
类 FocusAdapter 中的 focusGained

focusLost

public void focusLost(FocusEvent ev)
从类 FocusAdapter 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
覆盖：
类 FocusAdapter 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.KeyboardDownRightHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.KeyboardDownRightHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.KeyboardDownRightHandler
extends Object
implements ActionListener

ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

此类应该视为“受保护”内部类。仅在 BasicSplitPaneUI 的子类中实例化此类。

构造方法摘要
BasicSplitPaneUI.KeyboardDownRightHandler()
方法摘要
 void actionPerformed(ActionEvent ev)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneUI.KeyboardDownRightHandler

public BasicSplitPaneUI.KeyboardDownRightHandler()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent ev)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.KeyboardEndHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.KeyboardEndHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.KeyboardEndHandler
extends Object
implements ActionListener

ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

此类应该视为“受保护”内部类。仅在 BasicSplitPaneUI 的子类中实例化此类。

构造方法摘要
BasicSplitPaneUI.KeyboardEndHandler()
方法摘要
 void actionPerformed(ActionEvent ev)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneUI.KeyboardEndHandler

public BasicSplitPaneUI.KeyboardEndHandler()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent ev)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.KeyboardHomeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.KeyboardHomeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.KeyboardHomeHandler
extends Object
implements ActionListener

ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

此类应该视为“受保护”内部类。仅在 BasicSplitPaneUI 的子类中实例化此类。

构造方法摘要
BasicSplitPaneUI.KeyboardHomeHandler()
方法摘要
 void actionPerformed(ActionEvent ev)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneUI.KeyboardHomeHandler

public BasicSplitPaneUI.KeyboardHomeHandler()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent ev)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.KeyboardResizeToggleHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.KeyboardResizeToggleHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.KeyboardResizeToggleHandler
extends Object
implements ActionListener

ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

此类应该视为“受保护”内部类。仅在 BasicSplitPaneUI 的子类中实例化此类。

构造方法摘要
BasicSplitPaneUI.KeyboardResizeToggleHandler()
方法摘要
 void actionPerformed(ActionEvent ev)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneUI.KeyboardResizeToggleHandler

public BasicSplitPaneUI.KeyboardResizeToggleHandler()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent ev)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.KeyboardUpLeftHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.KeyboardUpLeftHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.KeyboardUpLeftHandler
extends Object
implements ActionListener

ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

此类应该视为“受保护”内部类。仅在 BasicSplitPaneUI 的子类中实例化此类。

构造方法摘要
BasicSplitPaneUI.KeyboardUpLeftHandler()
方法摘要
 void actionPerformed(ActionEvent ev)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneUI.KeyboardUpLeftHandler

public BasicSplitPaneUI.KeyboardUpLeftHandler()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent ev)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicSplitPaneUI.PropertyHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicSplitPaneUI.PropertyHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicSplitPaneUI
public class BasicSplitPaneUI.PropertyHandler
extends Object
implements PropertyChangeListener

JSplitPane UI 使用的 PropertyChangeListener 的实现。

此类应该视为“受保护”内部类。仅在 BasicSplitPaneUI 的子类中实例化此类。

构造方法摘要
BasicSplitPaneUI.PropertyHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
从包含接收者的 JSplitPane 传递消息。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicSplitPaneUI.PropertyHandler

public BasicSplitPaneUI.PropertyHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从包含接收者的 JSplitPane 传递消息。可能需要重置布局管理器并导致发送 validate。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTabbedPaneUI.FocusHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTabbedPaneUI.FocusHandler

java.lang.Object
    继承者  java.awt.event.FocusAdapter
        继承者  javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
BasicTabbedPaneUI
public class BasicTabbedPaneUI.FocusHandler
extends FocusAdapter

此类应视为“受保护”内部类。仅在 BasicTabbedPaneUI 的子类中实例化此类。

构造方法摘要
BasicTabbedPaneUI.FocusHandler()
方法摘要
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTabbedPaneUI.FocusHandler

public BasicTabbedPaneUI.FocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent e)
从类 FocusAdapter 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained
覆盖：
类 FocusAdapter 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
从类 FocusAdapter 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
覆盖：
类 FocusAdapter 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTabbedPaneUI.MouseHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTabbedPaneUI.MouseHandler

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
BasicTabbedPaneUI
public class BasicTabbedPaneUI.MouseHandler
extends MouseAdapter

此类应视为“受保护”内部类。仅在 BasicTabbedPaneUI 的子类中实例化此类。

构造方法摘要
BasicTabbedPaneUI.MouseHandler()
方法摘要
 void mousePressed(MouseEvent e)
鼠标按键在组件上按下时调用。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mouseReleased, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTabbedPaneUI.MouseHandler

public BasicTabbedPaneUI.MouseHandler()
方法详细信息

mousePressed

public void mousePressed(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTabbedPaneUI.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTabbedPaneUI.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicTabbedPaneUI
public class BasicTabbedPaneUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

此类应视为“受保护”内部类。仅在 BasicTabbedPaneUI 的子类中实例化此类。

构造方法摘要
BasicTabbedPaneUI.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTabbedPaneUI.PropertyChangeHandler

public BasicTabbedPaneUI.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTabbedPaneUI.TabbedPaneLayout (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTabbedPaneUI.TabbedPaneLayout

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
所有已实现的接口：
LayoutManager
直接已知子类：
MetalTabbedPaneUI.TabbedPaneLayout
正在封闭类：
BasicTabbedPaneUI
public class BasicTabbedPaneUI.TabbedPaneLayout
extends Object
implements LayoutManager

此类应视为“受保护”内部类。仅在 BasicTabbedPaneUI 的子类中实例化此类。

构造方法摘要
BasicTabbedPaneUI.TabbedPaneLayout()
方法摘要
void | addLayoutComponent(String name, Component comp) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
void | calculateLayoutInfo()
protected Dimension | calculateSize(boolean minimum)
protected void | calculateTabRects(int tabPlacement, int tabCount)
void | layoutContainer(Container parent) 布置指定容器。
Dimension | minimumLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的最小大小维数。
protected void | normalizeTabRuns(int tabPlacement, int tabCount, int start, int max)
protected void | padSelectedTab(int tabPlacement, int selectedIndex)
protected void | padTabRun(int tabPlacement, int start, int end, int max)
Dimension | preferredLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的首选大小维数。
protected int | preferredTabAreaHeight(int tabPlacement, int width)
protected int | preferredTabAreaWidth(int tabPlacement, int height)
void | removeLayoutComponent(Component comp) 从布局移除指定组件。
protected void | rotateTabRuns(int tabPlacement, int selectedRun)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTabbedPaneUI.TabbedPaneLayout

public BasicTabbedPaneUI.TabbedPaneLayout()
方法详细信息

addLayoutComponent

public void addLayoutComponent(String name,
                               Component comp)
从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
comp - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从接口 LayoutManager 复制的描述
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的首选大小维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的最小大小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 要布置的组件

calculateSize

protected Dimension calculateSize(boolean minimum)

preferredTabAreaHeight

protected int preferredTabAreaHeight(int tabPlacement,
                                     int width)

preferredTabAreaWidth

protected int preferredTabAreaWidth(int tabPlacement,
                                    int height)

layoutContainer

public void layoutContainer(Container parent)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要布置的容器

calculateLayoutInfo

public void calculateLayoutInfo()

calculateTabRects

protected void calculateTabRects(int tabPlacement,
                                 int tabCount)

rotateTabRuns

protected void rotateTabRuns(int tabPlacement,
                             int selectedRun)

normalizeTabRuns

protected void normalizeTabRuns(int tabPlacement,
                                int tabCount,
                                int start,
                                int max)

padTabRun

protected void padTabRun(int tabPlacement,
                         int start,
                         int end,
                         int max)

padSelectedTab

protected void padSelectedTab(int tabPlacement,
                              int selectedIndex)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTabbedPaneUI.TabSelectionHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTabbedPaneUI.TabSelectionHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler
所有已实现的接口：
EventListener, ChangeListener
正在封闭类：
BasicTabbedPaneUI
public class BasicTabbedPaneUI.TabSelectionHandler
extends Object
implements ChangeListener

此类应视为“受保护”内部类。仅在 BasicTabbedPaneUI 的子类中实例化此类。

构造方法摘要
BasicTabbedPaneUI.TabSelectionHandler()
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTabbedPaneUI.TabSelectionHandler

public BasicTabbedPaneUI.TabSelectionHandler()
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTableHeaderUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTableHeaderUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TableHeaderUI
            继承者  javax.swing.plaf.basic.BasicTableHeaderUI

public class BasicTableHeaderUI
extends TableHeaderUI

BasicTableHeaderUI 实现

嵌套类摘要
 class BasicTableHeaderUI.MouseInputHandler
此内部类因编译器故障而被标记为“公开”。
字段摘要
protected JTableHeader | header 要将绘制委托给此 UI 的 JTableHeader。
protected MouseInputListener | mouseInputListener
protected CellRendererPane | rendererPane
构造方法摘要
BasicTableHeaderUI()
方法摘要
protected MouseInputListener | createMouseInputListener() 创建 JTableHeader 的鼠标侦听器。
static ComponentUI | createUI(JComponent h)
int | getBaseline(JComponent c, int width, int height) 返回基线。
Dimension | getMaximumSize(JComponent c) 返回标题的最大大小。
Dimension | getMinimumSize(JComponent c) 返回标题的最小大小。
Dimension | getPreferredSize(JComponent c) 返回标题的首选大小。
protected int | getRolloverColumn() 返回鼠标当前位于其上的列标题的索引。
protected void | installDefaults() 初始化 JTableHeader 属性，例如，字体、前景和背景。
protected void | installKeyboardActions() 在 JTableHeader 上注册所有的键盘动作。
protected void | installListeners() 将侦听器附加到 JTableHeader 上。
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | rolloverColumnUpdated(int oldColumn, int newColumn) 每次更新表标题中的翻转列时调用此方法。
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions() 注销默认键动作。
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

header

protected JTableHeader header
要将绘制委托给此 UI 的 JTableHeader。

rendererPane

protected CellRendererPane rendererPane

mouseInputListener

protected MouseInputListener mouseInputListener
构造方法详细信息

BasicTableHeaderUI

public BasicTableHeaderUI()
方法详细信息

createMouseInputListener

protected MouseInputListener createMouseInputListener()
创建 JTableHeader 的鼠标侦听器。

createUI

public static ComponentUI createUI(JComponent h)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

installDefaults

protected void installDefaults()
初始化 JTableHeader 属性，例如，字体、前景和背景。仅当字体、前景和背景属性的当前值为 null 或 UIResource 时才设置这些属性，其他属性在当前值为 null 时设置。

另请参见：
installUI(javax.swing.JComponent)

installListeners

protected void installListeners()
将侦听器附加到 JTableHeader 上。

installKeyboardActions

protected void installKeyboardActions()
在 JTableHeader 上注册所有的键盘动作。

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

uninstallDefaults

protected void uninstallDefaults()

uninstallListeners

protected void uninstallListeners()

uninstallKeyboardActions

protected void uninstallKeyboardActions()
注销默认键动作。

getRolloverColumn

protected int getRolloverColumn()
返回鼠标当前位于其上的列标题的索引。当鼠标不位于表标题时，则返回 -1。

返回：
当前翻转列的索引
从以下版本开始：
1.6
另请参见：
rolloverColumnUpdated(int, int)

rolloverColumnUpdated

protected void rolloverColumnUpdated(int oldColumn,
                                     int newColumn)
每次更新表标题中的翻转列时调用此方法。支持表标题中翻转效果的每个外观都应该重写此方法并重绘该标题。

参数：
oldColumn - 以前翻转列的索引；如果鼠标不在列上，则为 -1
newColumn - 新翻转列的索引；如果鼠标不在列上，则为 -1
从以下版本开始：
1.6
另请参见：
getRolloverColumn(), JTableHeader.getHeaderRect(int)

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
返回标题的最小大小。最小宽度是每列的最小宽度的和（加上内部单元格间隔）。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
返回标题的首选大小。首选高度是由标题渲染器提供的所有组件的首选高度中的最大者。首选宽度是每列的首选宽度的和（加上内部单元格间隔）。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
返回标题的最大大小。最大宽度是每列的最大宽度的和（加上内部单元格间隔）。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTableHeaderUI.MouseInputHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTableHeaderUI.MouseInputHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
正在封闭类：
BasicTableHeaderUI
public class BasicTableHeaderUI.MouseInputHandler
extends Object
implements MouseInputListener

此内部类因编译器故障而被标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicTableUI 的子类中实例化此类。

构造方法摘要
BasicTableHeaderUI.MouseInputHandler()
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTableHeaderUI.MouseInputHandler

public BasicTableHeaderUI.MouseInputHandler()
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged

mouseReleased

public void mouseReleased(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased

mouseEntered

public void mouseEntered(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTableUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTableUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TableUI
            继承者  javax.swing.plaf.basic.BasicTableUI

public class BasicTableUI
extends TableUI

BasicTableUI 实现

嵌套类摘要
class | BasicTableUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.KeyHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
字段摘要
protected FocusListener | focusListener
protected KeyListener | keyListener
protected MouseInputListener | mouseInputListener
protected CellRendererPane | rendererPane
protected JTable | table
构造方法摘要
BasicTableUI()
方法摘要
protected  FocusListener createFocusListener()
创建在 JTable 中处理键盘导航的焦点侦听器。
protected  KeyListener createKeyListener()
创建在 JTable 中处理键盘导航的键侦听器。
protected  MouseInputListener createMouseInputListener()
创建 JTable 的鼠标侦听器。
static ComponentUI createUI(JComponent c)
 int getBaseline(JComponent c, int width, int height)
返回基线。
 Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回指示该组件的基线如何随大小的改变而发生更改的枚举。
 Dimension getMaximumSize(JComponent c)
返回表的最大大小。
 Dimension getMinimumSize(JComponent c)
返回表的最小大小。
 Dimension getPreferredSize(JComponent c)
返回表的首选大小。
protected  void installDefaults()
初始化 JTable 属性，例如，字体、前景和背景。
protected  void installKeyboardActions()
在 JTable 上注册所有的键盘动作。
protected  void installListeners()
将侦听器附加到 JTable 上。
 void installUI(JComponent c)
配置指定组件，使其适合外观。
 void paint(Graphics g, JComponent c)
绘制用 installUI() 设置的 table 实例的表示形式。
protected  void uninstallDefaults()
protected  void uninstallKeyboardActions()
protected  void uninstallListeners()
 void uninstallUI(JComponent c)
在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

table

protected JTable table

rendererPane

protected CellRendererPane rendererPane

keyListener

protected KeyListener keyListener

focusListener

protected FocusListener focusListener

mouseInputListener

protected MouseInputListener mouseInputListener
构造方法详细信息

BasicTableUI

public BasicTableUI()
方法详细信息

createKeyListener

protected KeyListener createKeyListener()
创建在 JTable 中处理键盘导航的键侦听器。

createFocusListener

protected FocusListener createFocusListener()
创建在 JTable 中处理键盘导航的焦点侦听器。

createMouseInputListener

protected MouseInputListener createMouseInputListener()
创建 JTable 的鼠标侦听器。

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

installDefaults

protected void installDefaults()
初始化 JTable 属性，例如，字体、前景和背景。仅当字体、前景和背景属性的当前值为 null 或 UIResource 时才设置这些属性，其他属性在当前值为 null 时设置。

另请参见：
installUI(javax.swing.JComponent)

installListeners

protected void installListeners()
将侦听器附加到 JTable 上。

installKeyboardActions

protected void installKeyboardActions()
在 JTable 上注册所有的键盘动作。

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

uninstallDefaults

protected void uninstallDefaults()

uninstallListeners

protected void uninstallListeners()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回指示该组件的基线如何随大小的改变而发生更改的枚举。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
返回表的最小大小。最小高度为行高度乘行数。最小宽度是每列的最小宽度之和。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
返回表的首选大小。首选高度为行高度乘行数。首选宽度是每列的首选宽度之和。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
返回表的最大大小。最大高度为行高度乘行数。最大宽度是每列的最大宽度之和。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

paint

public void paint(Graphics g,
                  JComponent c)
绘制用 installUI() 设置的 table 实例的表示形式。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTableUI.FocusHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTableUI.FocusHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTableUI.FocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
BasicTableUI
public class BasicTableUI.FocusHandler
extends Object
implements FocusListener

此内部类因编译器故障而被标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicTableUI 的子类中实例化此类。

构造方法摘要
BasicTableUI.FocusHandler()
方法摘要
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTableUI.FocusHandler

public BasicTableUI.FocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent e)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTableUI.KeyHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTableUI.KeyHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTableUI.KeyHandler
所有已实现的接口：
KeyListener, EventListener
正在封闭类：
BasicTableUI
public class BasicTableUI.KeyHandler
extends Object
implements KeyListener

此内部类因编译器故障而被标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicTableUI 的子类中实例化此类。

从 Java 2 平台 v1.3 开始，不再使用此类。转而通过 JTable 重写 processKeyBinding 将事件指派给当前的 TableCellEditor。

构造方法摘要
BasicTableUI.KeyHandler()
方法摘要
void | keyPressed(KeyEvent e) 按下某个键时调用此方法。
void | keyReleased(KeyEvent e) 释放某个键时调用此方法。
void | keyTyped(KeyEvent e) 键入某个键时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTableUI.KeyHandler

public BasicTableUI.KeyHandler()
方法详细信息

keyPressed

public void keyPressed(KeyEvent e)
从接口 KeyListener 复制的描述
按下某个键时调用此方法。有关按下键事件的定义，请参见 KeyEvent 的类描述。

指定者：
接口 KeyListener 中的 keyPressed

keyReleased

public void keyReleased(KeyEvent e)
从接口 KeyListener 复制的描述
释放某个键时调用此方法。有关释放键事件的定义，请参见 KeyEvent 的类描述。

指定者：
接口 KeyListener 中的 keyReleased

keyTyped

public void keyTyped(KeyEvent e)
从接口 KeyListener 复制的描述
键入某个键时调用此方法。有关键入键事件的定义，请参见 KeyEvent 的类描述。

指定者：
接口 KeyListener 中的 keyTyped
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTableUI.MouseInputHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTableUI.MouseInputHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
正在封闭类：
BasicTableUI
public class BasicTableUI.MouseInputHandler
extends Object
implements MouseInputListener

此内部类因编译器故障而被标记为“公开”。此类应该视为“受保护”内部类。仅在 BasicTableUI 的子类中实例化此类。

构造方法摘要
BasicTableUI.MouseInputHandler()
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTableUI.MouseInputHandler

public BasicTableUI.MouseInputHandler()
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased

mouseEntered

public void mouseEntered(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTextAreaUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTextAreaUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
                继承者  javax.swing.plaf.basic.BasicTextAreaUI
所有已实现的接口：
ViewFactory
public class BasicTextAreaUI
extends BasicTextUI

为纯文本编辑器提供外观。在此实现中，扩展了默认的 UI 以充当简单的视图工厂。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的嵌套类/接口
BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter
构造方法摘要
BasicTextAreaUI()
构造新的 BasicTextAreaUI 对象。
方法摘要
View | create(Element elem) 创建元素的视图。
static ComponentUI | createUI(JComponent ta) 创建 JTextArea 的 UI。
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Dimension | getMinimumSize(JComponent c) 重写此方法以将插入符的宽度考虑在内。
Dimension | getPreferredSize(JComponent c) 重写此方法以将插入符的宽度考虑在内。
protected String | getPropertyPrefix() 获取用作键以通过 UIManager 查找属性的名称。
protected void | installDefaults() 初始化组件属性，例如，字体、前景、背景、插入符颜色、选择颜色、所选文本颜色、禁用文本颜色，以及边框颜色。
protected void | propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
从类 javax.swing.plaf.basic.BasicTextUI 继承的方法
create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getNextVisualPositionFrom, getRootView, getToolTipText, getVisibleEditorRect, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTextAreaUI

public BasicTextAreaUI()
构造新的 BasicTextAreaUI 对象。

方法详细信息

createUI

public static ComponentUI createUI(JComponent ta)
创建 JTextArea 的 UI。

参数：
ta - 文本区域
返回：
UI

getPropertyPrefix

protected String getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。它用作所有标准文本属性的前缀。

指定者：
类 BasicTextUI 中的 getPropertyPrefix
返回：
名称 ("TextArea")

installDefaults

protected void installDefaults()
从类 BasicTextUI 复制的描述
初始化组件属性，例如，字体、前景、背景、插入符颜色、选择颜色、所选文本颜色、禁用文本颜色，以及边框颜色。仅当字体、前景和背景属性的当前值为 null 或 UIResource 时才设置这些属性，其他属性在当前值为 null 时设置。

覆盖：
类 BasicTextUI 中的 installDefaults
另请参见：
BasicTextUI.uninstallDefaults(), BasicTextUI.installUI(javax.swing.JComponent)

propertyChange

protected void propertyChange(PropertyChangeEvent evt)
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。此为一个 (hook)，UI 实现可以更改它来反映 UI 显示 JTextComponent 子类的绑定属性的方式。当 WrapLine 或 WrapStyleWord 属性更改时，实现它以重新构建 View。

覆盖：
类 BasicTextUI 中的 propertyChange
参数：
evt - 属性更改事件

getPreferredSize

public Dimension getPreferredSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。

覆盖：
类 BasicTextUI 中的 getPreferredSize
参数：
c - 编辑器组件
返回：
首选大小
抛出：
IllegalArgumentException - 如果传递了无效的值
从以下版本开始：
1.5
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。

覆盖：
类 BasicTextUI 中的 getMinimumSize
参数：
c - 编辑器组件
返回：
最小大小
抛出：
IllegalArgumentException - 如果传递了无效的值
从以下版本开始：
1.5
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

create

public View create(Element elem)
创建元素的视图。返回 WrappedPlainView 或 PlainView。

指定者：
接口 ViewFactory 中的 create
覆盖：
类 BasicTextUI 中的 create
参数：
elem - 元素
返回：
视图
另请参见：
View

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTextFieldUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTextFieldUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
                继承者  javax.swing.plaf.basic.BasicTextFieldUI
所有已实现的接口：
ViewFactory
直接已知子类：
BasicFormattedTextFieldUI, BasicPasswordFieldUI, MetalTextFieldUI
public class BasicTextFieldUI
extends BasicTextUI

JTextField 的外观的基础。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的嵌套类/接口
BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter
构造方法摘要
BasicTextFieldUI()
创建新的 BasicTextFieldUI。
方法摘要
View | create(Element elem) 基于元素创建视图 (FieldView)。
static ComponentUI | createUI(JComponent c) 创建 JTextField 的 UI。
int | getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
protected String | getPropertyPrefix() 获取用作键以通过 UIManager 查找属性的名称。
从类 javax.swing.plaf.basic.BasicTextUI 继承的方法
create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, propertyChange, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTextFieldUI

public BasicTextFieldUI()
创建新的 BasicTextFieldUI。

方法详细信息

createUI

public static ComponentUI createUI(JComponent c)
创建 JTextField 的 UI。

参数：
c - 文本字段
返回：
UI

getPropertyPrefix

protected String getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。它用作所有标准文本属性的前缀。

指定者：
类 BasicTextUI 中的 getPropertyPrefix
返回：
名称 ("TextField")

create

public View create(Element elem)
基于元素创建视图 (FieldView)。

指定者：
接口 ViewFactory 中的 create
覆盖：
类 BasicTextUI 中的 create
参数：
elem - 元素
返回：
视图
另请参见：
View

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTextPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTextPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
                继承者  javax.swing.plaf.basic.BasicEditorPaneUI
                    继承者  javax.swing.plaf.basic.BasicTextPaneUI
所有已实现的接口：
ViewFactory
public class BasicTextPaneUI
extends BasicEditorPaneUI

为样式化文本编辑器提供外观。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的嵌套类/接口
BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter
构造方法摘要
BasicTextPaneUI()
创建新的 BasicTextPaneUI。
方法摘要
static ComponentUI | createUI(JComponent c) 创建 JTextPane 的 UI。
protected String | getPropertyPrefix() 获取用作键以通过 UIManager 查找属性的名称。
void | installUI(JComponent c) 安装组件的 UI。
protected void | propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
从类 javax.swing.plaf.basic.BasicEditorPaneUI 继承的方法
getEditorKit, uninstallUI
从类 javax.swing.plaf.basic.BasicTextUI 继承的方法
create, create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, update, viewToModel, viewToModel
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTextPaneUI

public BasicTextPaneUI()
创建新的 BasicTextPaneUI。

方法详细信息

createUI

public static ComponentUI createUI(JComponent c)
创建 JTextPane 的 UI。

参数：
c - JTextPane 对象
返回：
UI

getPropertyPrefix

protected String getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。它用作所有标准文本属性的前缀。

覆盖：
类 BasicEditorPaneUI 中的 getPropertyPrefix
返回：
名称 ("TextPane")

installUI

public void installUI(JComponent c)
从类 BasicEditorPaneUI 复制的描述
安装组件的 UI。此方法执行以下操作。
  1. 将关联组件设置为不透明（可以由子类或直接在 JTextComponent 上方便地更改），这种情况是最常见的。此操作将导致绘制组件的背景色。
  2. 将默认的插入符和 highlighter 安装到关联组件中。
  3. 附加到编辑器和模型。如果不存在模型，则创建一个默认模型。
  4. 创建用于表示模型的视图工厂和视图层次结构。

覆盖：
类 BasicEditorPaneUI 中的 installUI
参数：
c - 编辑器组件
另请参见：
ComponentUI.installUI(javax.swing.JComponent)

propertyChange

protected void propertyChange(PropertyChangeEvent evt)
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。此为一个钩子 (hook)，UI 实现可以更改它来反映 UI 显示 JTextComponent 子类的绑定属性的方式。如果字体、前景或文档已更改，则适当的属性将使用默认的文档样式设置。

覆盖：
类 BasicEditorPaneUI 中的 propertyChange
参数：
evt - 属性更改事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTextUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTextUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
所有已实现的接口：
ViewFactory
直接已知子类：
BasicEditorPaneUI, BasicTextAreaUI, BasicTextFieldUI, DefaultTextUI
public abstract class BasicTextUI
extends TextUI
implements ViewFactory

此类是文本组件外观的基础。它提供基本的编辑器视图和控制器服务，在为 JTextComponent 的扩展类创建外观时非常有用。

大多数状态作为绑定 (bound) 属性保存在关联的 JTextComponent 中，UI 为各种属性安装默认值。此默认值将为所有属性安装某些内容。但是，通常 LAF 实现所做的不止如此。LAF 一般至少会安装键绑定。

如果与 JTextComponent 关联的 Document 是 AbstractDocument 的子类，则此类还将提供某些并发支持。在任一更改模型的线程与 Swing 事件线程（希望用来呈现、进行模型/视图坐标转换等）之间，对 View（或 View 层次结构）的访问都是序列化的。对根视图的任何访问首先应该获取一个 AbstractDocument 上的读锁 (read-lock)，并在 finally 代码块中释放该锁。

要定义的一个重要方法是 getPropertyPrefix() 方法，该方法作为从 UIManager 获取默认值的键的基础。字符串应该反映 TextUI（例如，TextField、TextArea 等）的类型，并且不带名称的特定 LAF 部分（例如，Metal、Motif 等）。

要构建模型的视图，可以使用以下策略之一。

  1. 一种策略是简单地重新定义 UI 中的 ViewFactory 接口。默认情况下，此 UI 本身充当 View 实现的工厂。这对于简单工厂很有用。要做到这一点，需要重新实现 create(javax.swing.text.Element) 方法。
  2. 创建较复杂的文档类型的常见策略是让 EditorKit 实现返回一个工厂。因为 EditorKit 绑定了维护文档类型所需的全部内容，所以工厂通常是它的一个重要部分，应该由 EditorKit 实现生成。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
static class | BasicTextUI.BasicCaret
static class | BasicTextUI.BasicHighlighter
构造方法摘要
BasicTextUI()
创建新的 UI。
方法摘要
View | create(Element elem) 创建元素的视图。
View | create(Element elem, int p0, int p1) 创建元素的视图。
protected Caret | createCaret() 创建用于插入符的对象。
protected Highlighter | createHighlighter() 创建用于添加高亮显示的对象。
protected Keymap | createKeymap() 创建用于文本组件的 keymap，并在其中安装必需的绑定。
void | damageRange(JTextComponent tc, int p0, int p1) 促使重新绘制负责模型给定部分的那部分视图。
void | damageRange(JTextComponent t, int p0, int p1, Position.Bias p0Bias, Position.Bias p1Bias) 促使重新绘制负责模型给定部分的那部分视图。
protected JTextComponent | getComponent() 获取与此 UI 实现关联的文本组件。
EditorKit | getEditorKit(JTextComponent tc) 获取 UI 的 EditorKit。
protected String | getKeymapName() 获取默认情况下为此 UI 安装或用于此 UI 的 keymap 的名称。
Dimension | getMaximumSize(JComponent c) 获取编辑器组件的最大大小。
Dimension | getMinimumSize(JComponent c) 获取编辑器组件的最小大小。
int | getNextVisualPositionFrom(JTextComponent t, int pos, Position.Bias b, int direction, Position.Bias[] biasRet) 提供确定下一个可以放置一个插入符的可见模型位置的方法。
Dimension | getPreferredSize(JComponent c) 获取编辑器组件的首选大小。
protected abstract String | getPropertyPrefix() 获取通过 UIManager 查找属性时用作键的名称。
View | getRootView(JTextComponent tc) 获取分配了相关文本组件（即层次结构的根）的 View，可通过遍历该视图确定模型在空间中的表示形式。
String | getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
protected Rectangle | getVisibleEditorRect() 获取给出根 View 的分配。
protected void | installDefaults() 初始化组件属性，例如，字体、前景、背景、插入符颜色、选择颜色、所选文本颜色、禁用文本颜色，以及边框颜色。
protected void | installKeyboardActions()
protected void | installListeners() 安装 UI 的侦听器。
void | installUI(JComponent c) 安装组件的 UI。
protected void | modelChanged() 标志模型更改。
Rectangle | modelToView(JTextComponent tc, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
Rectangle | modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
void | paint(Graphics g, JComponent c) 绘制界面。
protected void | paintBackground(Graphics g) 绘制视图的背景。
protected void | paintSafely(Graphics g) 安全地绘制界面，保证模型不会根据此线程的视图发生更改。
protected void | propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定属性更改时，此方法被调用。
protected void | setView(View v) 设置视图层次结构的当前根并调用 invalidate()。
protected void | uninstallDefaults() 将尚未显式重写的组件属性设置为 null。
protected void | uninstallKeyboardActions()
protected void | uninstallListeners() 卸载 UI 的侦听器。
void | uninstallUI(JComponent c) 卸载组件的 UI。
void | update(Graphics g, JComponent c) 超类以无法控制的方式绘制背景（即有人可能希望将图像平铺在背景中）。
int | viewToModel(JTextComponent tc, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
int | viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, createUI, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTextUI

public BasicTextUI()
创建新的 UI。

方法详细信息

createCaret

protected Caret createCaret()
创建用于插入符的对象。默认情况下创建一个 BasicCaret 的实例。可以重新定义此方法，让它提供实现 InputPosition 接口或 JCaret 子类的一些其他内容。

返回：
插入符对象

createHighlighter

protected Highlighter createHighlighter()
创建用于添加高亮显示的对象。默认情况下创建一个 BasicHighlighter 的实例。可以重新定义此方法，让它提供实现 Highlighter 接口或 DefaultHighlighter 子类的一些其他内容。

返回：
highlighter

getKeymapName

protected String getKeymapName()
获取默认情况下为此 UI 安装或用于此 UI 的 keymap 的名称。实现此方法来创建基于类名的名称。该名称是移除了包前缀的类名。

返回：
名称

createKeymap

protected Keymap createKeymap()
创建用于文本组件的 keymap，并在其中安装必需的绑定。默认情况下，keymap 在此 TextUI 类型的所有实例之间共享。keymap 的名称由 getKeymapName 方法定义。如果找不到 keymap，则使用 JTextComponent 的 DEFAULT_KEYMAP。

用于创建 keymap 的绑定集从 UIManager 获取，方法是使用通过组合 getPropertyPrefix() 方法和字符串 .keyBindings 而形成的键。期望的类型为 JTextComponent.KeyBinding[]。

返回：
keymap
另请参见：
getKeymapName(), JTextComponent

propertyChange

protected void propertyChange(PropertyChangeEvent evt)
当关联的 JTextComponent 上有一个绑定属性更改时，此方法被调用。此方法是一个钩子 (hook)，UI 实现可以更改它来反映 UI 显示 JTextComponent 子类的绑定属性的方式。实现此方法并不执行任何操作。（即处理对 JTextComponent 中属性的响应是在调用此方法之前）。 如果可编辑和/或已启用状态发生更改，则此实现更新文本组件的背景。

参数：
evt - 属性更改事件

getPropertyPrefix

protected abstract String getPropertyPrefix()
获取通过 UIManager 查找属性时用作键的名称。它会作为所有标准文本属性的前缀。

返回：
名称

installDefaults

protected void installDefaults()
初始化组件属性，例如，字体、前景、背景、插入符颜色、选择颜色、所选文本颜色、禁用文本颜色，以及边框颜色。仅当字体、前景和背景属性的当前值为 null 或 UIResource 时才设置这些属性，其他属性在当前值为 null 时设置。

另请参见：
uninstallDefaults(), installUI(javax.swing.JComponent)

uninstallDefaults

protected void uninstallDefaults()
将尚未显式重写的组件属性设置为 null。如果某个属性的当前值不是 UIResource，则视为被重写。

另请参见：
installDefaults(), uninstallUI(javax.swing.JComponent)

installListeners

protected void installListeners()
安装 UI 的侦听器。

uninstallListeners

protected void uninstallListeners()
卸载 UI 的侦听器。

installKeyboardActions

protected void installKeyboardActions()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

paintBackground

protected void paintBackground(Graphics g)
绘制视图的背景。仅当关联组件上的 isOpaque() 为 true 时才调用此方法。默认情况下绘制组件的背景色。

参数：
g - 图形上下文

getComponent

protected final JTextComponent getComponent()
获取与此 UI 实现关联的文本组件。在安装 UI 之前，此方法将一直为 null。

返回：
编辑器组件

modelChanged

protected void modelChanged()
标志模型更改。只要模型更改就会调用此方法。实现此方法来重新构建视图层次结构，从而表示关联模型的默认根元素。

setView

protected final void setView(View v)
设置视图层次结构的当前根并调用 invalidate()。如果存在子组件，则将其移除（即假定这些子组件来自嵌入视图的组件）。

参数：
v - 根视图

paintSafely

protected void paintSafely(Graphics g)
安全地绘制界面，保证模型不会根据此线程的视图发生更改。此方法执行以下操作，从后往前呈现。
  1. 如果组件被标记为不透明，则以组件的当前背景色绘制背景。
  2. 绘制高亮显示（如果有）。
  3. 绘制视图层次结构。
  4. 绘制插入符。

参数：
g - 图形上下文

installUI

public void installUI(JComponent c)
安装组件的 UI。此方法执行以下操作。
  1. 将关联组件设置为不透明（可以由子类或直接在 JTextComponent 上方便地更改），这种情况是最常见的。此操作将导致绘制组件的背景色。
  2. 将默认的插入符和 highlighter 安装到关联组件中。
  3. 附加到编辑器和模型。如果不存在模型，则创建一个默认模型。
  4. 创建用于表示模型的视图工厂和视图层次结构。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 编辑器组件
另请参见：
ComponentUI.installUI(javax.swing.JComponent)

uninstallUI

public void uninstallUI(JComponent c)
卸载组件的 UI。此方法移除侦听器、卸载 highlighter、移除视图并将 keymap 全部设为 null。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 编辑器组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent)

update

public void update(Graphics g,
                   JComponent c)
超类以无法控制的方式绘制背景（即有人可能希望将图像平铺在背景中）。要防止发生两次这样的操作，重新实现此方法以进行简单绘制即可。

注： 超类在其背景呈现中也不是线程安全的，尽管在默认呈现中不存在这样的问题。

覆盖：
类 ComponentUI 中的 update
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

paint

public final void paint(Graphics g,
                        JComponent c)
绘制界面。此方法会被传递到 paintSafely 方法中，同时保证模型在呈现时不会根据此线程的视图发生更改（如果关联的模型从 AbstractDocument 派生）。这使得模型能够进行可能的异步更新。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 图形上下文
c - 编辑器组件
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
获取编辑器组件的首选大小。如果在接收此请求前已经给出了组件的大小，则此方法在请求视图层次结构的首选大小之前将设置视图层次结构的大小，以反映组件的大小。这允许格式化视图在答复请求之前格式化当前组件的大小。其他视图不关心当前的格式化大小，因此均会给出相同的答复。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 编辑器组件
返回：
大小
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
获取编辑器组件的最小大小。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 编辑器组件
返回：
大小
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
获取编辑器组件的最大大小。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 编辑器组件
返回：
大小
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getVisibleEditorRect

protected Rectangle getVisibleEditorRect()
获取给出根 View 的分配。由于一些不适宜的历史事件，此方法的命名并不合适。返回的 Rectangle 与可见性没有任何关系。组件的大小必须为非零正值，才能计算此转换。

返回：
根视图的边界框

modelToView

public Rectangle modelToView(JTextComponent tc,
                             int pos)
                      throws BadLocationException
将模型中的给定位置转换成视图坐标系统中的某一个位置。组件的大小必须为非零正值，才能计算此转换。

指定者：
类 TextUI 中的 modelToView
参数：
tc - 文本组件，为其安装此 UI
pos - 要转换的模型中的本地位置，该值 >= 0
返回：
作为矩形的坐标；如果没有绘制模型，则返回 null
抛出：
BadLocationException - 如果给定位置不表示关联文档中的有效位置
另请参见：
TextUI.modelToView(javax.swing.text.JTextComponent, int)

modelToView

public Rectangle modelToView(JTextComponent tc,
                             int pos,
                             Position.Bias bias)
                      throws BadLocationException
将模型中的给定位置转换成视图坐标系统中的某一个位置。组件的大小必须为非零正值，才能计算此转换。

指定者：
类 TextUI 中的 modelToView
参数：
tc - 文本组件，为其安装此 UI
pos - 要转换的模型中的本地位置，该值 >= 0
返回：
作为矩形的坐标；如果没有绘制模型，则返回 null
抛出：
BadLocationException - 如果给定位置不表示关联文档中的有效位置
另请参见：
TextUI.modelToView(javax.swing.text.JTextComponent, int)

viewToModel

public int viewToModel(JTextComponent tc,
                       Point pt)
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。组件的大小必须为非零正值，才能计算此转换。

指定者：
类 TextUI 中的 viewToModel
参数：
tc - 文本组件，为其安装此 UI
pt - 视图中要转换的位置。此位置应该与鼠标事件在同一坐标系统中。
返回：
距文档起始位置的偏移量，该值 >= 0；如果没有绘制，则返回 -1
另请参见：
TextUI.viewToModel(javax.swing.text.JTextComponent, java.awt.Point)

viewToModel

public int viewToModel(JTextComponent tc,
                       Point pt,
                       Position.Bias[] biasReturn)
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。组件的大小必须为非零正值，才能计算此转换。

指定者：
类 TextUI 中的 viewToModel
参数：
tc - 为其安装此 UI 的文本组件
pt - 视图中要转换的位置。此位置应该与鼠标事件在同一坐标系统中。
biasReturn - 由此方法填充，以指示给定点是更接近于模型中的前一个字符，还是更接近于模型中的下一个字符
返回：
距文档起始位置的偏移量，该值 >= 0；如果组件的大小为非正值，则返回 -1。
另请参见：
TextUI.viewToModel(javax.swing.text.JTextComponent, java.awt.Point)

getNextVisualPositionFrom

public int getNextVisualPositionFrom(JTextComponent t,
                                     int pos,
                                     Position.Bias b,
                                     int direction,
                                     Position.Bias[] biasRet)
                              throws BadLocationException
提供确定下一个可以放置一个插入符的可见模型位置的方法。一些视图可能是不可见的，它们的顺序可能与模型中的顺序不同，或者它们可能不允许访问模型中的某些位置。

指定者：
类 TextUI 中的 getNextVisualPositionFrom
参数：
t - 为其安装此 UI 的文本组件
pos - 要转换的位置，该位置 >= 0
b - 位置的偏差
direction - 以当前位置开始的方向，可以将它们设想为通常出现在键盘上的箭头键。该参数可以是 SwingConstants.WEST、SwingConstants.EAST、SwingConstants.NORTH 或 SwingConstants.SOUTH
biasRet - 包含返回位置偏差的数组
返回：
模型中能最好地表示下一个可见位置的位置
抛出：
BadLocationException

damageRange

public void damageRange(JTextComponent tc,
                        int p0,
                        int p1)
促使重新绘制负责模型给定部分的那部分视图。如果当前没有绘制视图，则不执行任何操作。

指定者：
类 TextUI 中的 damageRange
参数：
tc - 文本组件，为其安装此 UI
p0 - 范围的开头，该值 >= 0
p1 - 范围的结尾，该值 >= p0
另请参见：
TextUI.damageRange(javax.swing.text.JTextComponent, int, int)

damageRange

public void damageRange(JTextComponent t,
                        int p0,
                        int p1,
                        Position.Bias p0Bias,
                        Position.Bias p1Bias)
促使重新绘制负责模型给定部分的那部分视图。

指定者：
类 TextUI 中的 damageRange
参数：
p0 - 范围的起始位置，该值 >= 0
p1 - 范围的结束位置，该值 >= p0

getEditorKit

public EditorKit getEditorKit(JTextComponent tc)
获取 UI 的 EditorKit。

指定者：
类 TextUI 中的 getEditorKit
参数：
tc - 文本组件，为其安装此 UI
返回：
编辑器功能
另请参见：
TextUI.getEditorKit(javax.swing.text.JTextComponent)

getRootView

public View getRootView(JTextComponent tc)
获取分配了相关文本组件（即层次结构的根）的 View，可通过遍历该视图确定模型在空间中的表示形式。

注：可以从根视图遍历 View 层次结构，其他操作也可以如此。以此方式完成的操作不会像通过 TextUI 的简单方法调用那样受到保护。因此，存在并发操作时必须按照调用此方法的逻辑安排适当的操作！

指定者：
类 TextUI 中的 getRootView
参数：
tc - 文本组件，为其安装此 UI
返回：
视图
另请参见：
TextUI.getRootView(javax.swing.text.JTextComponent)

getToolTipText

public String getToolTipText(JTextComponent t,
                             Point pt)
返回在传入位置上用作工具提示的字符串。这会将该方法转发到根视图上。

覆盖：
类 TextUI 中的 getToolTipText
从以下版本开始：
1.4
另请参见：
JTextComponent.getToolTipText(java.awt.event.MouseEvent), View.getToolTipText(float, float, java.awt.Shape)

create

public View create(Element elem)
创建元素的视图。如果子类希望直接实现生成视图的工厂，则其应该重新实现此方法。默认情况下，它就返回 null，指示它无法表示该元素。

指定者：
接口 ViewFactory 中的 create
参数：
elem - 元素
返回：
视图
另请参见：
View

create

public View create(Element elem,
                   int p0,
                   int p1)
创建元素的视图。如果子类希望直接实现生成视图的工厂，则其应该重新实现此方法。默认情况下，它就返回 null，指示它无法表示该元素。

参数：
elem - 元素
p0 - 开始偏移量，该值 >= 0
p1 - 结束偏移量，该值 >= p0
返回：
视图
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTextUI.BasicCaret (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTextUI.BasicCaret

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Rectangle2D
            继承者  java.awt.Rectangle
                继承者  javax.swing.text.DefaultCaret
                    继承者  javax.swing.plaf.basic.BasicTextUI.BasicCaret
所有已实现的接口：
FocusListener, MouseListener, MouseMotionListener, Shape, Serializable, Cloneable, EventListener, UIResource, Caret
正在封闭类：
BasicTextUI
public static class BasicTextUI.BasicCaret
extends DefaultCaret
implements UIResource

嵌套类摘要
从类 java.awt.geom.Rectangle2D 继承的嵌套类/接口
Rectangle2D.Double, Rectangle2D.Float
字段摘要
从类 javax.swing.text.DefaultCaret 继承的字段
ALWAYS_UPDATE, changeEvent, listenerList, NEVER_UPDATE, UPDATE_WHEN_ON_EDT
从类 java.awt.Rectangle 继承的字段
height, width, x, y
从类 java.awt.geom.Rectangle2D 继承的字段
OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP
构造方法摘要
BasicTextUI.BasicCaret()
方法摘要
从类 javax.swing.text.DefaultCaret 继承的方法
addChangeListener, adjustVisibility, damage, deinstall, equals, fireStateChanged, focusGained, focusLost, getBlinkRate, getChangeListeners, getComponent, getDot, getDotBias, getListeners, getMagicCaretPosition, getMark, getMarkBias, getSelectionPainter, getUpdatePolicy, install, isActive, isSelectionVisible, isVisible, mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mousePressed, mouseReleased, moveCaret, moveDot, moveDot, paint, positionCaret, removeChangeListener, repaint, setBlinkRate, setDot, setDot, setMagicCaretPosition, setSelectionVisible, setUpdatePolicy, setVisible, toString
从类 java.awt.Rectangle 继承的方法
add, add, add, contains, contains, contains, contains, createIntersection, createUnion, getBounds, getBounds2D, getHeight, getLocation, getSize, getWidth, getX, getY, grow, inside, intersection, intersects, isEmpty, move, outcode, reshape, resize, setBounds, setBounds, setLocation, setLocation, setRect, setSize, setSize, translate, union
从类 java.awt.geom.Rectangle2D 继承的方法
add, add, add, contains, contains, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, setRect, union
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.awt.Shape 继承的方法
contains, contains, contains, contains, getPathIterator, getPathIterator, intersects, intersects

构造方法详细信息

BasicTextUI.BasicCaret

public BasicTextUI.BasicCaret()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTextUI.BasicHighlighter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTextUI.BasicHighlighter

java.lang.Object
    继承者  javax.swing.text.LayeredHighlighter
        继承者  javax.swing.text.DefaultHighlighter
            继承者  javax.swing.plaf.basic.BasicTextUI.BasicHighlighter
所有已实现的接口：
UIResource, Highlighter
正在封闭类：
BasicTextUI
public static class BasicTextUI.BasicHighlighter
extends DefaultHighlighter
implements UIResource

嵌套类摘要
从类 javax.swing.text.DefaultHighlighter 继承的嵌套类/接口
DefaultHighlighter.DefaultHighlightPainter
从类 javax.swing.text.LayeredHighlighter 继承的嵌套类/接口
LayeredHighlighter.LayerPainter
从接口 javax.swing.text.Highlighter 继承的嵌套类/接口
Highlighter.Highlight, Highlighter.HighlightPainter
字段摘要
从类 javax.swing.text.DefaultHighlighter 继承的字段
DefaultPainter
构造方法摘要
BasicTextUI.BasicHighlighter()
方法摘要
从类 javax.swing.text.DefaultHighlighter 继承的方法
addHighlight, changeHighlight, deinstall, getDrawsLayeredHighlights, getHighlights, install, paint, paintLayeredHighlights, removeAllHighlights, removeHighlight, setDrawsLayeredHighlights
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTextUI.BasicHighlighter

public BasicTextUI.BasicHighlighter()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToggleButtonUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToggleButtonUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.basic.BasicButtonUI
                继承者  javax.swing.plaf.basic.BasicToggleButtonUI
直接已知子类：
BasicRadioButtonUI, MetalToggleButtonUI
public class BasicToggleButtonUI
extends BasicButtonUI

BasicToggleButton 实现

字段摘要
从类 javax.swing.plaf.basic.BasicButtonUI 继承的字段
defaultTextIconGap, defaultTextShiftOffset
构造方法摘要
BasicToggleButtonUI()
方法摘要
static ComponentUI | createUI(JComponent b)
protected String | getPropertyPrefix()
protected int | getTextShiftOffset() 重写以便不用为 Toggle 按钮和子类交替呈现文本。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
从类 javax.swing.plaf.basic.BasicButtonUI 继承的方法
clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, getPreferredSize, installDefaults, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicToggleButtonUI

public BasicToggleButtonUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent b)

getPropertyPrefix

protected String getPropertyPrefix()
覆盖：
类 BasicButtonUI 中的 getPropertyPrefix

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 BasicButtonUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintIcon

protected void paintIcon(Graphics g,
                         AbstractButton b,
                         Rectangle iconRect)

getTextShiftOffset

protected int getTextShiftOffset()
重写以便不用为 Toggle 按钮和子类交替呈现文本。

覆盖：
类 BasicButtonUI 中的 getTextShiftOffset
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolBarSeparatorUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolBarSeparatorUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SeparatorUI
            继承者  javax.swing.plaf.basic.BasicSeparatorUI
                继承者  javax.swing.plaf.basic.BasicToolBarSeparatorUI

public class BasicToolBarSeparatorUI
extends BasicSeparatorUI

ToolBarSeparatorUI 的基本 L&F 实现。此实现是一个“组合的”视图/控制器。

字段摘要
从类 javax.swing.plaf.basic.BasicSeparatorUI 继承的字段
highlight, shadow
构造方法摘要
BasicToolBarSeparatorUI()
方法摘要
static ComponentUI | createUI(JComponent c)
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected void | installDefaults(JSeparator s)
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
从类 javax.swing.plaf.basic.BasicSeparatorUI 继承的方法
getMaximumSize, getMinimumSize, installListeners, installUI, uninstallDefaults, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicToolBarSeparatorUI

public BasicToolBarSeparatorUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installDefaults

protected void installDefaults(JSeparator s)
覆盖：
类 BasicSeparatorUI 中的 installDefaults

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 BasicSeparatorUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 BasicSeparatorUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ToolBarUI
            继承者  javax.swing.plaf.basic.BasicToolBarUI
所有已实现的接口：
SwingConstants
直接已知子类：
MetalToolBarUI
public class BasicToolBarUI
extends ToolBarUI
implements SwingConstants

ToolBarUI 的基本 L&F 实现。此实现是一个“组合的”视图/控制器。

嵌套类摘要
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
protected class | BasicToolBarUI.DragWindow
protected class | BasicToolBarUI.FrameListener
protected class | BasicToolBarUI.PropertyListener
protected class | BasicToolBarUI.ToolBarContListener
protected class | BasicToolBarUI.ToolBarFocusListener
字段摘要
protected String | constraintBeforeFloating
protected Color | dockingBorderColor
protected Color | dockingColor
protected MouseInputListener | dockingListener
protected KeyStroke | downKey 已过时。 从 Java 2 平台 v1.3 开始。
protected BasicToolBarUI.DragWindow | dragWindow
protected Color | floatingBorderColor
protected Color | floatingColor
protected int | focusedCompIndex
protected KeyStroke | leftKey 已过时。 从 Java 2 平台 v1.3 开始。
protected PropertyChangeListener | propertyListener
protected KeyStroke | rightKey 已过时。 从 Java 2 平台 v1.3 开始。
protected JToolBar | toolBar
protected ContainerListener | toolBarContListener
protected FocusListener | toolBarFocusListener
protected KeyStroke | upKey 已过时。 从 Java 2 平台 v1.3 开始。
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
BasicToolBarUI()
方法摘要
boolean | canDock(Component c, Point p)
protected MouseInputListener | createDockingListener()
protected BasicToolBarUI.DragWindow | createDragWindow(JToolBar toolbar)
protected JFrame | createFloatingFrame(JToolBar toolbar) 不再使用，使用 BasicToolBarUI.createFloatingWindow(JToolBar)
protected RootPaneContainer | createFloatingWindow(JToolBar toolbar) 创建将工具栏拖出其容器后包含该工具栏的窗口
protected WindowListener | createFrameListener()
protected Border | createNonRolloverBorder() 创建工具栏组件的非翻转边框。
protected PropertyChangeListener | createPropertyListener()
protected Border | createRolloverBorder() 创建工具栏组件的翻转边框。
protected ContainerListener | createToolBarContListener()
protected FocusListener | createToolBarFocusListener()
static ComponentUI | createUI(JComponent c)
protected void | dragTo(Point position, Point origin)
protected void | floatAt(Point position, Point origin)
Color | getDockingColor() 获取在连接 (docking) 区域上时显示的颜色。
Color | getFloatingColor() 获取在浮动区域上时显示的颜色。
protected Border | getNonRolloverBorder(AbstractButton b) 返回按钮的非翻转边框。
protected Border | getRolloverBorder(AbstractButton b) 返回按钮的翻转边框。
protected void | installComponents()
protected void | installDefaults()
protected void | installKeyboardActions()
protected void | installListeners()
protected void | installNonRolloverBorders(JComponent c) 在 JComponent 的所有子组件上安装非翻转边框。
protected void | installNormalBorders(JComponent c) 在 JComponent 的所有子组件上安装普通边框。
protected void | installRolloverBorders(JComponent c) 在 JComponent 的所有子组件上安装翻转边框。
void | installUI(JComponent c) 配置指定组件，使其适合外观。
boolean | isFloating()
boolean | isRolloverBorders() 返回一个标志，用于确定是否启用翻转按钮边框。
protected void | navigateFocusedComp(int direction)
protected void | paintDragWindow(Graphics g) 绘制用于拖动的窗口的内容。
protected void | setBorderToNonRollover(Component c) 将组件的边框设置为具有由 createNonRolloverBorder 创建的翻转边框。
protected void | setBorderToNormal(Component c) 将组件的边框设置为具有普通边框。
protected void | setBorderToRollover(Component c) 将组件的边框设置为具有由 createRolloverBorder 创建的翻转边框。
void | setDockingColor(Color c) 设置在连接区域上时显示的颜色。
void | setFloating(boolean b, Point p)
void | setFloatingColor(Color c) 设置在浮动区域上时显示的颜色。
void | setFloatingLocation(int x, int y)
void | setOrientation(int orientation)
void | setRolloverBorders(boolean rollover) 在工具栏上设置启用翻转边框的标志并根据标志的状态安装适当的边框。
protected void | uninstallComponents()
protected void | uninstallDefaults()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

toolBar

protected JToolBar toolBar

dragWindow

protected BasicToolBarUI.DragWindow dragWindow

focusedCompIndex

protected int focusedCompIndex

dockingColor

protected Color dockingColor

floatingColor

protected Color floatingColor

dockingBorderColor

protected Color dockingBorderColor

floatingBorderColor

protected Color floatingBorderColor

dockingListener

protected MouseInputListener dockingListener

propertyListener

protected PropertyChangeListener propertyListener

toolBarContListener

protected ContainerListener toolBarContListener

toolBarFocusListener

protected FocusListener toolBarFocusListener

constraintBeforeFloating

protected String constraintBeforeFloating

upKey

@Deprecated
protected KeyStroke upKey
已过时。 从 Java 2 平台 v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

downKey

@Deprecated
protected KeyStroke downKey
已过时。 从 Java 2 平台 v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

leftKey

@Deprecated
protected KeyStroke leftKey
已过时。 从 Java 2 平台 v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

rightKey

@Deprecated
protected KeyStroke rightKey
已过时。 从 Java 2 平台 v1.3 开始。
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的字段。键绑定现在由 LookAndFeel 定义，请参阅键绑定规范以了解更多详细信息。

构造方法详细信息

BasicToolBarUI

public BasicToolBarUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults()

uninstallDefaults

protected void uninstallDefaults()

installComponents

protected void installComponents()

uninstallComponents

protected void uninstallComponents()

installListeners

protected void installListeners()

uninstallListeners

protected void uninstallListeners()

installKeyboardActions

protected void installKeyboardActions()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

navigateFocusedComp

protected void navigateFocusedComp(int direction)

createRolloverBorder

protected Border createRolloverBorder()
创建工具栏组件的翻转边框。如果启用了翻转边框，则将安装翻转边框。

重写此方法以提供备用翻转边框。

从以下版本开始：
1.4

createNonRolloverBorder

protected Border createNonRolloverBorder()
创建工具栏组件的非翻转边框。如果启用翻转边框，则此边框将作为添加到工具栏的组件的边框安装。

重写此方法以提供备用翻转边框。

从以下版本开始：
1.4

createFloatingFrame

protected JFrame createFloatingFrame(JToolBar toolbar)
不再使用，使用 BasicToolBarUI.createFloatingWindow(JToolBar)

另请参见：
createFloatingWindow(javax.swing.JToolBar)

createFloatingWindow

protected RootPaneContainer createFloatingWindow(JToolBar toolbar)
创建将工具栏拖出其容器后包含该工具栏的窗口

返回：
RootPaneContainer 对象，包含工具栏。
从以下版本开始：
1.4

createDragWindow

protected BasicToolBarUI.DragWindow createDragWindow(JToolBar toolbar)

isRolloverBorders

public boolean isRolloverBorders()
返回一个标志，用于确定是否启用翻转按钮边框。

返回：
如果启用翻转按钮边框，则返回 true；否则返回 false
从以下版本开始：
1.4
另请参见：
setRolloverBorders(boolean)

setRolloverBorders

public void setRolloverBorders(boolean rollover)
在工具栏上设置启用翻转边框的标志并根据标志的状态安装适当的边框。

参数：
rollover - 如果为 true，则安装翻转边框。否则，安装非翻转边框
从以下版本开始：
1.4
另请参见：
isRolloverBorders()

installRolloverBorders

protected void installRolloverBorders(JComponent c)
在 JComponent 的所有子组件上安装翻转边框。

此方法是为每个子组件调用 setBorderToRollover 的便捷方法。

参数：
c - 保存子组件（通常为 JToolBar）的容器
从以下版本开始：
1.4
另请参见：
setBorderToRollover(java.awt.Component)

installNonRolloverBorders

protected void installNonRolloverBorders(JComponent c)
在 JComponent 的所有子组件上安装非翻转边框。非翻转边框是一种当子组件在工具栏中时安装在该子组件上的边框。

此方法是为每个子组件调用 setBorderToNonRollover 的便捷方法。

参数：
c - 保存子组件（通常为 JToolBar）的容器
从以下版本开始：
1.4
另请参见：
setBorderToNonRollover(java.awt.Component)

installNormalBorders

protected void installNormalBorders(JComponent c)
在 JComponent 的所有子组件上安装普通边框。普通边框指添加到工具栏前安装在子组件上的原始边框。

此方法是为每个子组件调用 setBorderNormal 的便捷方法。

参数：
c - 保存子组件（通常为 JToolBar）的容器
从以下版本开始：
1.4
另请参见：
setBorderToNonRollover(java.awt.Component)

setBorderToRollover

protected void setBorderToRollover(Component c)
将组件的边框设置为具有由 createRolloverBorder 创建的翻转边框。

参数：
c - 将安装翻转边框的组件
从以下版本开始：
1.4
另请参见：
createRolloverBorder()

getRolloverBorder

protected Border getRolloverBorder(AbstractButton b)
返回按钮的翻转边框。

参数：
b - 为其计算翻转边框的按钮
返回：
翻转边框
从以下版本开始：
1.6
另请参见：
setBorderToRollover(java.awt.Component)

setBorderToNonRollover

protected void setBorderToNonRollover(Component c)
将组件的边框设置为具有由 createNonRolloverBorder 创建的翻转边框。

参数：
c - 将安装翻转边框的组件
从以下版本开始：
1.4
另请参见：
createNonRolloverBorder()

getNonRolloverBorder

protected Border getNonRolloverBorder(AbstractButton b)
返回按钮的非翻转边框。

参数：
b - 为其计算非翻转边框的按钮
返回：
非翻转边框
从以下版本开始：
1.6
另请参见：
setBorderToNonRollover(java.awt.Component)

setBorderToNormal

protected void setBorderToNormal(Component c)
将组件的边框设置为具有普通边框。普通边框指添加到工具栏前安装在子组件上的原始边框。

参数：
c - 将重新安装普通边框的组件
从以下版本开始：
1.4
另请参见：
createNonRolloverBorder()

setFloatingLocation

public void setFloatingLocation(int x,
                                int y)

isFloating

public boolean isFloating()

setFloating

public void setFloating(boolean b,
                        Point p)

setOrientation

public void setOrientation(int orientation)

getDockingColor

public Color getDockingColor()
获取在连接 (docking) 区域上时显示的颜色。

setDockingColor

public void setDockingColor(Color c)
设置在连接区域上时显示的颜色。

getFloatingColor

public Color getFloatingColor()
获取在浮动区域上时显示的颜色。

setFloatingColor

public void setFloatingColor(Color c)
设置在浮动区域上时显示的颜色。

canDock

public boolean canDock(Component c,
                       Point p)

dragTo

protected void dragTo(Point position,
                      Point origin)

floatAt

protected void floatAt(Point position,
                       Point origin)

createToolBarContListener

protected ContainerListener createToolBarContListener()

createToolBarFocusListener

protected FocusListener createToolBarFocusListener()

createPropertyListener

protected PropertyChangeListener createPropertyListener()

createDockingListener

protected MouseInputListener createDockingListener()

createFrameListener

protected WindowListener createFrameListener()

paintDragWindow

protected void paintDragWindow(Graphics g)
绘制用于拖动的窗口的内容。

参数：
g - 要绘制的图形。
抛出：
NullPointerException - 如果 g 为 null
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolBarUI.DockingListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolBarUI.DockingListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicToolBarUI.DockingListener
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
直接已知子类：
MetalToolBarUI.MetalDockingListener
正在封闭类：
BasicToolBarUI
public class BasicToolBarUI.DockingListener
extends Object
implements MouseInputListener

此类应视为“受保护”内部类。仅在 BasicToolBarUI 的子类中实例化此类。

字段摘要
protected boolean | isDragging
protected Point | origin
protected JToolBar | toolBar
构造方法摘要
BasicToolBarUI.DockingListener(JToolBar t)
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

toolBar

protected JToolBar toolBar

isDragging

protected boolean isDragging

origin

protected Point origin
构造方法详细信息

BasicToolBarUI.DockingListener

public BasicToolBarUI.DockingListener(JToolBar t)
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased

mouseEntered

public void mouseEntered(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolBarUI.DragWindow (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolBarUI.DragWindow

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Window
                继承者  javax.swing.plaf.basic.BasicToolBarUI.DragWindow
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
正在封闭类：
BasicToolBarUI
protected class BasicToolBarUI.DragWindow
extends Window

嵌套类摘要
从类 java.awt.Window 继承的嵌套类/接口
Window.AccessibleAWTWindow
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
方法摘要
Color | getBorderColor()
Insets | getInsets() 确定此容器的 insets，它指示容器边框的大小。
Point | getOffset()
int | getOrientation() 当工具栏浮动时，返回工具栏窗口的方向。
void | paint(Graphics g) 绘制容器。
void | setBorderColor(Color c)
void | setOffset(Point p)
void | setOrientation(int o)
从类 java.awt.Window 继承的方法
addNotify, addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getAccessibleContext, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getGraphicsConfiguration, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOwnedWindows, getOwner, getOwnerlessWindows, getToolkit, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, hide, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isShowing, pack, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setVisible, show, toBack, toFront
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setBackground, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getOrientation

public int getOrientation()
当工具栏浮动时，返回工具栏窗口的方向。该方向为 JToolBar.HORIZONTAL 或 JToolBar.VERTICAL。

返回：
工具栏窗口的方向
从以下版本开始：
1.6

setOrientation

public void setOrientation(int o)

getOffset

public Point getOffset()

setOffset

public void setOffset(Point p)

setBorderColor

public void setBorderColor(Color c)

getBorderColor

public Color getBorderColor()

paint

public void paint(Graphics g)
从类 Container 复制的描述
绘制容器。该方法将 paint 转发给任意一个此容器子组件的轻量级组件。如果重新实现此方法，那么应该调用 super.paint(g) 方法，从而可以正确地呈现轻量级组件。如果通过 g 中的当前剪切设置完全剪切某个子组件，则不会将 paint() 转发给这个子组件。

覆盖：
类 Container 中的 paint
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

getInsets

public Insets getInsets()
从类 Container 复制的描述
确定此容器的 insets，它指示容器边框的大小。

例如，Frame 对象有一个顶端 inset，它对应于窗体的标题栏的高度。

覆盖：
类 Container 中的 getInsets
返回：
此容器的 inset。
另请参见：
Insets, LayoutManager
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolBarUI.FrameListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolBarUI.FrameListener

java.lang.Object
    继承者  java.awt.event.WindowAdapter
        继承者  javax.swing.plaf.basic.BasicToolBarUI.FrameListener
所有已实现的接口：
WindowFocusListener, WindowListener, WindowStateListener, EventListener
正在封闭类：
BasicToolBarUI
protected class BasicToolBarUI.FrameListener
extends WindowAdapter

构造方法摘要
protected BasicToolBarUI.FrameListener()
方法摘要
 void windowClosing(WindowEvent w)
窗口正处在关闭过程中时调用。
从类 java.awt.event.WindowAdapter 继承的方法
windowActivated, windowClosed, windowDeactivated, windowDeiconified, windowGainedFocus, windowIconified, windowLostFocus, windowOpened, windowStateChanged
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicToolBarUI.FrameListener

protected BasicToolBarUI.FrameListener()
方法详细信息

windowClosing

public void windowClosing(WindowEvent w)
从类 WindowAdapter 复制的描述
窗口正处在关闭过程中时调用。此时可重写关闭操作。

指定者：
接口 WindowListener 中的 windowClosing
覆盖：
类 WindowAdapter 中的 windowClosing
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolBarUI.PropertyListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolBarUI.PropertyListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
所有已实现的接口：
PropertyChangeListener, EventListener
直接已知子类：
MetalToolBarUI.MetalRolloverListener
正在封闭类：
BasicToolBarUI
protected class BasicToolBarUI.PropertyListener
extends Object
implements PropertyChangeListener

构造方法摘要
protected BasicToolBarUI.PropertyListener()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicToolBarUI.PropertyListener

protected BasicToolBarUI.PropertyListener()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolBarUI.ToolBarContListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolBarUI.ToolBarContListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
所有已实现的接口：
ContainerListener, EventListener
直接已知子类：
MetalToolBarUI.MetalContainerListener
正在封闭类：
BasicToolBarUI
protected class BasicToolBarUI.ToolBarContListener
extends Object
implements ContainerListener

构造方法摘要
protected BasicToolBarUI.ToolBarContListener()
方法摘要
void | componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicToolBarUI.ToolBarContListener

protected BasicToolBarUI.ToolBarContListener()
方法详细信息

componentAdded

public void componentAdded(ContainerEvent e)
从接口 ContainerListener 复制的描述
已将组件添加到容器中时调用。

指定者：
接口 ContainerListener 中的 componentAdded

componentRemoved

public void componentRemoved(ContainerEvent e)
从接口 ContainerListener 复制的描述
已从容器中移除组件时调用。

指定者：
接口 ContainerListener 中的 componentRemoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolBarUI.ToolBarFocusListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolBarUI.ToolBarFocusListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
BasicToolBarUI
protected class BasicToolBarUI.ToolBarFocusListener
extends Object
implements FocusListener

构造方法摘要
protected BasicToolBarUI.ToolBarFocusListener()
方法摘要
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicToolBarUI.ToolBarFocusListener

protected BasicToolBarUI.ToolBarFocusListener()
方法详细信息

focusGained

public void focusGained(FocusEvent e)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicToolTipUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicToolTipUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ToolTipUI
            继承者  javax.swing.plaf.basic.BasicToolTipUI
直接已知子类：
MetalToolTipUI
public class BasicToolTipUI
extends ToolTipUI

标准工具提示 L&F。

构造方法摘要
BasicToolTipUI()
方法摘要
static ComponentUI | createUI(JComponent c)
Dimension | getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected void | installDefaults(JComponent c)
protected void | installListeners(JComponent c)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | uninstallDefaults(JComponent c)
protected void | uninstallListeners(JComponent c)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicToolTipUI

public BasicToolTipUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults(JComponent c)

uninstallDefaults

protected void uninstallDefaults(JComponent c)

installListeners

protected void installListeners(JComponent c)

uninstallListeners

protected void uninstallListeners(JComponent c)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最大大小。如果返回 null，则最大大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TreeUI
            继承者  javax.swing.plaf.basic.BasicTreeUI
直接已知子类：
MetalTreeUI
public class BasicTreeUI
extends TreeUI

层次数据结构的基本 L&F。

嵌套类摘要
class | BasicTreeUI.CellEditorHandler 侦听器负责获取单元格编辑事件并相应地更新树。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。
class | BasicTreeUI.FocusHandler 失去/获得焦点时重绘前导选择行。
class | BasicTreeUI.KeyHandler 用于获取多个按键事件以适当生成事件。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。
class | BasicTreeUI.NodeDimensionsHandler 负责获取节点大小的类，其方法被转发到 BasicTreeUI 方法。
class | BasicTreeUI.PropertyChangeHandler 树的 PropertyChangeListener。
class | BasicTreeUI.SelectionModelPropertyChangeHandler TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeExpansionHandler 更新 TreeState 以响应节点的展开/折叠。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreeModelHandler 将所有 TreeModel 事件转发到 TreeState。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeSelectionHandler 侦听选择模型中的更改并相应地更新显示。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。
字段摘要
protected TreeCellEditor | cellEditor 树的编辑器。
protected Icon | collapsedIcon
protected boolean | createdCellEditor 如果当前位于树中的编辑器由此实例创建，则设置为 true。
protected boolean | createdRenderer 如果当前在树中使用的渲染器由此实例创建，则设置为 true。
protected TreeCellRenderer | currentCellRenderer 要用于进行实际单元格绘制的渲染器。
protected int | depthOffset 要正确计算 x 位置应该偏移的深度。
protected Hashtable<TreePath,Boolean> | drawingCache 用于最小化垂直线的绘制。
protected Component | editingComponent 编辑时，它将是进行实际编辑的 Component。
protected TreePath | editingPath 要编辑的路径。
protected int | editingRow 要编辑的行。
protected boolean | editorHasDifferentSize 如果编辑器的大小不同于渲染器，则设置为 true。
protected Icon | expandedIcon
protected boolean | largeModel 如果对 largeModel 进行优化，则为 True。
protected int | lastSelectedRow 上一次选中行的索引。
protected int | leftChildIndent 从左页边空白到将绘制垂直虚线的位置之间的距离。
protected AbstractLayoutCache.NodeDimensions | nodeDimensions 负责告知 TreeState 节点所需的大小。
protected Dimension | preferredMinSize 最小首选大小。
protected Dimension | preferredSize 完全显示所有节点所需的大小。
protected CellRendererPane | rendererPane 用于绘制 TreeCellRenderer。
protected int | rightChildIndent 添加到 leftChildIndent 以确定将绘制单元格内容的位置的距离。
protected boolean | stopEditingInCompleteEditing 编辑时设置为 false，shouldSelectCell() 返回 true 表示应该在编辑前选中节点，在 completeEditing 中使用该字段。
protected int | totalChildIndent 将缩进的总距离。
protected JTree | tree 要在其中进行绘制的组件。
protected TreeModel | treeModel 用于确定要显示的内容。
protected TreeSelectionModel | treeSelectionModel 维护选择的模型。
protected AbstractLayoutCache | treeState 负责处理大小和展开问题的对象。
protected boolean | validCachedPreferredSize preferredSize 是否有效？
构造方法摘要
BasicTreeUI()
方法摘要
 void cancelEditing(JTree tree)
取消当前编辑会话。
protected  void checkForClickInExpandControl(TreePath path, int mouseX, int mouseY)
如果 mouseX 和 mouseY 位于 row 的展开/折叠区域内，则此方法将切换行。
protected  void completeEditing()
传递消息以停止编辑会话。
protected  void completeEditing(boolean messageStop, boolean messageCancel, boolean messageTree)
停止编辑会话。
protected  void completeUIInstall()
在安装所有默认值/侦听器之后根据 installUI 调用。
protected  void completeUIUninstall()
protected  void configureLayoutCache()
基于为其提供外观的树重置 TreeState 实例。
protected  CellEditorListener createCellEditorListener()
创建在当前编辑器中处理事件的侦听器。
protected  CellRendererPane createCellRendererPane()
返回用于放置渲染器组件的渲染器窗格。
protected  ComponentListener createComponentListener()
创建并返回新的 ComponentHandler。
protected  TreeCellEditor createDefaultCellEditor()
创建默认单元格编辑器。
protected  TreeCellRenderer createDefaultCellRenderer()
返回用于为每个节点添加标志的默认单元格渲染器。
protected  FocusListener createFocusListener()
创建失去/获取焦点时负责更新显示的侦听器。
protected  KeyListener createKeyListener()
创建负责从树获取键事件的侦听器。
protected  AbstractLayoutCache createLayoutCache()
创建负责管理展开内容及节点大小的对象。
protected  MouseListener createMouseListener()
创建负责基于鼠标事件更新选择的侦听器。
protected  AbstractLayoutCache.NodeDimensions createNodeDimensions()
创建能够确定树中给定节点大小的 NodeDimensions 的实例。
protected  PropertyChangeListener createPropertyChangeListener()
创建负责基于树的更改方式更新 UI 的侦听器。
protected  PropertyChangeListener createSelectionModelPropertyChangeListener()
创建负责从选择模型获取属性更改事件的侦听器。
protected  TreeExpansionListener createTreeExpansionListener()
创建并返回在节点展开状态更改时负责更新 treestate 的对象。
protected  TreeModelListener createTreeModelListener()
返回可以在模型更改时更新树的侦听器。
protected  TreeSelectionListener createTreeSelectionListener()
创建基于选择更改方法更新显示的侦听器。
static ComponentUI createUI(JComponent x)
protected  void drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
protected  void drawDashedHorizontalLine(Graphics g, int y, int x1, int x2)
protected  void drawDashedVerticalLine(Graphics g, int x, int y1, int y2)
protected  void ensureRowsAreVisible(int beginRow, int endRow)
确保 beginRow 通过 endRow 标识的行是可见的。
 int getBaseline(JComponent c, int width, int height)
返回基线。
 Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
protected  TreeCellEditor getCellEditor()
protected  TreeCellRenderer getCellRenderer()
返回 currentCellRenderer，可以为树渲染器，也可以为 defaultCellRenderer，无论哪个都不为 null。
 TreePath getClosestPathForLocation(JTree tree, int x, int y)
返回到达最接近于 x,y 的那个节点的路径。
 Icon getCollapsedIcon()
 TreePath getEditingPath(JTree tree)
返回到达正被编辑的元素的路径。
 Icon getExpandedIcon()
protected  Color getHashColor()
protected  int getHorizontalLegBuffer()
默认情况下，节点间支路的水平元素开始于子节点左侧的右边。
protected  TreePath getLastChildPath(TreePath parent)
返回到 parent 的最后一个子节点的路径。
 int getLeftChildIndent()
 Dimension getMaximumSize(JComponent c)
返回此组件的最大大小，如果实例当前位于 JTree 中或 0, 0 处，则该大小将为首选大小。
 Dimension getMinimumSize(JComponent c)
返回此组件的最小大小。
protected  TreeModel getModel()
 Rectangle getPathBounds(JTree tree, TreePath path)
返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
 TreePath getPathForRow(JTree tree, int row)
返回传入的 row 的路径。
 Dimension getPreferredMinSize()
返回最小首选大小。
 Dimension getPreferredSize(JComponent c)
返回首选大小以正确显示树，这是一种 getPreferredSize(c, false) 的替代方法。
 Dimension getPreferredSize(JComponent c, boolean checkConsistancy)
返回首选大小以表示 c 中的树。
 int getRightChildIndent()
 int getRowCount(JTree tree)
返回将显示的行数。
 int getRowForPath(JTree tree, TreePath path)
返回可在其中看见路径中标识的最后一个项的行。
protected  int getRowHeight()
protected  int getRowX(int row, int depth)
返回沿 x 轴呈现特定行的位置。
protected  TreeSelectionModel getSelectionModel()
protected  boolean getShowsRootHandles()
protected  int getVerticalLegBuffer()
默认情况下，节点间支路的垂直元素开始于父节点的底部。
protected  void handleExpandControlClick(TreePath path, int mouseX, int mouseY)
当用户单击特定行时传递消息，此方法调用 toggleExpandState。
protected  void installComponents()
安装作为渲染器窗格的树的子组件。
protected  void installDefaults()
protected  void installKeyboardActions()
protected  void installListeners()
 void installUI(JComponent c)
配置指定组件，使其适合外观。
protected  boolean isEditable()
 boolean isEditing(JTree tree)
如果树正被编辑，则返回 true。
protected  boolean isLargeModel()
protected  boolean isLeaf(int row)
protected  boolean isLocationInExpandControl(TreePath path, int mouseX, int mouseY)
如果 mouseX 和 mouseY 落在用于展开/折叠节点的行的区域内，并且 row 的节点不表示叶节点，则返回 true。
protected  boolean isMultiSelectEvent(MouseEvent event)
返回 true 表示节点上的鼠标事件应该根据锚点作出选择。
protected  boolean isRootVisible()
protected  boolean isToggleEvent(MouseEvent event)
返回 true 指示应该基于事件切换鼠标下的行。
protected  boolean isToggleSelectionEvent(MouseEvent event)
返回 true 表示节点上的鼠标事件应该仅切换鼠标下的行的选择。
 void paint(Graphics g, JComponent c)
绘制指定组件，使其适合外观。
protected  void paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的展开（切换）部分。
protected  void paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
绘制水平线。
protected  void paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制支路 (leg) 的水平部分。
protected  void paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的渲染器部分。
protected  void paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
绘制垂直线。
protected  void paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
绘制支路的垂直部分。
protected  void pathWasCollapsed(TreePath path)
在折叠 VisibleTreeNode 后，从其传递消息。
protected  void pathWasExpanded(TreePath path)
在展开 VisibleTreeNode 后，从其传递消息。
protected  void prepareForUIInstall()
在设置 tree 实例变量之后，但在安装任何默认值/侦听器之前调用此方法。
protected  void prepareForUIUninstall()
protected  void selectPathForEvent(TreePath path, MouseEvent event)
传递消息以基于特定行上的 MouseEvent 更新选择。
protected  void setCellEditor(TreeCellEditor editor)
设置单元格编辑器。
protected  void setCellRenderer(TreeCellRenderer tcr)
将 TreeCellRenderer 设置为 tcr。
 void setCollapsedIcon(Icon newG)
protected  void setEditable(boolean newValue)
配置接收者以允许或不允许进行编辑。
 void setExpandedIcon(Icon newG)
protected  void setHashColor(Color color)
protected  void setLargeModel(boolean largeModel)
如果必要，则更新 componentListener。
 void setLeftChildIndent(int newAmount)
protected  void setModel(TreeModel model)
设置 TreeModel。
 void setPreferredMinSize(Dimension newSize)
设置首选最小大小。
 void setRightChildIndent(int newAmount)
protected  void setRootVisible(boolean newValue)
将根设置为可见。
protected  void setRowHeight(int rowHeight)
设置行高度，此方法将被转发到 treeState。
protected  void setSelectionModel(TreeSelectionModel newLSM)
重置选择模型。
protected  void setShowsRootHandles(boolean newValue)
确定是否显示节点句柄。
protected  boolean shouldPaintExpandControl(TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
如果应该为指定行绘制展开（切换）控件，则返回 true。
protected  boolean startEditing(TreePath path, MouseEvent event)
如果存在 cellEditor 并且 shouldSelectCell 返回 true，则启动节点的编辑操作。
 void startEditingAtPath(JTree tree, TreePath path)
选择路径中的最后一个项并尝试对其进行编辑。
 boolean stopEditing(JTree tree)
停止当前编辑会话。
protected  void toggleExpandState(TreePath path)
如果路径不是展开的，则展开它；如果它是展开的，则折叠它。
protected  void uninstallComponents()
卸载渲染器窗格。
protected  void uninstallDefaults()
protected  void uninstallKeyboardActions()
protected  void uninstallListeners()
 void uninstallUI(JComponent c)
在 installUI 期间，在指定组件上反向执行的配置操作。
protected  void updateCachedPreferredSize()
更新 preferredSize 实例变量，该变量从 getPreferredSize() 返回。
protected  void updateCellEditor()
基于包含所在的 JTree 的可编辑性更新 cellEditor。
protected  void updateDepthOffset()
更新每次应该偏移的深度量。
protected  void updateExpandedDescendants(TreePath path)
通过从树获取展开的子代并将其转发到树状态来更新 path 的所有子代的展开状态。
protected  void updateLayoutCacheExpandedNodes()
让在 JTree 中展开的所有节点在 LayoutCache 中展开。
protected  void updateRenderer()
当渲染器更改时从所处的树中传递消息。
protected  void updateSize()
将缓存大小标记为无效并使用 treeDidChange 传递树的信息。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

collapsedIcon

protected transient Icon collapsedIcon

expandedIcon

protected transient Icon expandedIcon

leftChildIndent

protected int leftChildIndent
从左页边空白到将绘制垂直虚线的位置之间的距离。

rightChildIndent

protected int rightChildIndent
添加到 leftChildIndent 以确定将绘制单元格内容的位置的距离。

totalChildIndent

protected int totalChildIndent
将缩进的总距离。leftChildIndent 和 rightChildIndent 的和。

preferredMinSize

protected Dimension preferredMinSize
最小首选大小。

lastSelectedRow

protected int lastSelectedRow
上一次选中行的索引。

tree

protected JTree tree
要在其中进行绘制的组件。

currentCellRenderer

protected transient TreeCellRenderer currentCellRenderer
要用于进行实际单元格绘制的渲染器。

createdRenderer

protected boolean createdRenderer
如果当前在树中使用的渲染器由此实例创建，则设置为 true。

cellEditor

protected transient TreeCellEditor cellEditor
树的编辑器。

createdCellEditor

protected boolean createdCellEditor
如果当前位于树中的编辑器由此实例创建，则设置为 true。

stopEditingInCompleteEditing

protected boolean stopEditingInCompleteEditing
编辑时设置为 false，shouldSelectCell() 返回 true 表示应该在编辑前选中节点，在 completeEditing 中使用该字段。

rendererPane

protected CellRendererPane rendererPane
用于绘制 TreeCellRenderer。

preferredSize

protected Dimension preferredSize
完全显示所有节点所需的大小。

validCachedPreferredSize

protected boolean validCachedPreferredSize
preferredSize 是否有效？

treeState

protected AbstractLayoutCache treeState
负责处理大小和展开问题的对象。

drawingCache

protected Hashtable<TreePath,Boolean> drawingCache
用于最小化垂直线的绘制。

largeModel

protected boolean largeModel
如果对 largeModel 进行优化，则为 True。不支持它的子类可能希望重写 createLayoutCache 以便不返回 FixedHeightLayoutCache 实例。

nodeDimensions

protected AbstractLayoutCache.NodeDimensions nodeDimensions
负责告知 TreeState 节点所需的大小。

treeModel

protected TreeModel treeModel
用于确定要显示的内容。

treeSelectionModel

protected TreeSelectionModel treeSelectionModel
维护选择的模型。

depthOffset

protected int depthOffset
要正确计算 x 位置应该偏移的深度。它依赖于根是否可见以及根句柄是否可见。

editingComponent

protected Component editingComponent
编辑时，它将是进行实际编辑的 Component。

editingPath

protected TreePath editingPath
要编辑的路径。

editingRow

protected int editingRow
要编辑的行。仅当 editingComponent 不为 null 时才引用。

editorHasDifferentSize

protected boolean editorHasDifferentSize
如果编辑器的大小不同于渲染器，则设置为 true。

构造方法详细信息

BasicTreeUI

public BasicTreeUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

getHashColor

protected Color getHashColor()

setHashColor

protected void setHashColor(Color color)

setLeftChildIndent

public void setLeftChildIndent(int newAmount)

getLeftChildIndent

public int getLeftChildIndent()

setRightChildIndent

public void setRightChildIndent(int newAmount)

getRightChildIndent

public int getRightChildIndent()

setExpandedIcon

public void setExpandedIcon(Icon newG)

getExpandedIcon

public Icon getExpandedIcon()

setCollapsedIcon

public void setCollapsedIcon(Icon newG)

getCollapsedIcon

public Icon getCollapsedIcon()

setLargeModel

protected void setLargeModel(boolean largeModel)
如果必要，则更新 componentListener。

isLargeModel

protected boolean isLargeModel()

setRowHeight

protected void setRowHeight(int rowHeight)
设置行高度，此方法将被转发到 treeState。

getRowHeight

protected int getRowHeight()

setCellRenderer

protected void setCellRenderer(TreeCellRenderer tcr)
将 TreeCellRenderer 设置为 tcr。此方法调用 updateRenderer。

getCellRenderer

protected TreeCellRenderer getCellRenderer()
返回 currentCellRenderer，可以为树渲染器，也可以为 defaultCellRenderer，无论哪个都不为 null。

setModel

protected void setModel(TreeModel model)
设置 TreeModel。

getModel

protected TreeModel getModel()

setRootVisible

protected void setRootVisible(boolean newValue)
将根设置为可见。

isRootVisible

protected boolean isRootVisible()

setShowsRootHandles

protected void setShowsRootHandles(boolean newValue)
确定是否显示节点句柄。

getShowsRootHandles

protected boolean getShowsRootHandles()

setCellEditor

protected void setCellEditor(TreeCellEditor editor)
设置单元格编辑器。

getCellEditor

protected TreeCellEditor getCellEditor()

setEditable

protected void setEditable(boolean newValue)
配置接收者以允许或不允许进行编辑。

isEditable

protected boolean isEditable()

setSelectionModel

protected void setSelectionModel(TreeSelectionModel newLSM)
重置选择模型。在模型上安装适当的侦听器。

getSelectionModel

protected TreeSelectionModel getSelectionModel()

getPathBounds

public Rectangle getPathBounds(JTree tree,
                               TreePath path)
返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。如果路径中的任何组件当前有效，则返回 null。

指定者：
类 TreeUI 中的 getPathBounds

getPathForRow

public TreePath getPathForRow(JTree tree,
                              int row)
返回传入的 row 的路径。如果 row 不可见，则返回 null。

指定者：
类 TreeUI 中的 getPathForRow

getRowForPath

public int getRowForPath(JTree tree,
                         TreePath path)
返回可在其中看见路径中标识的最后一个项的行。如果路径中的所有元素当前都是不可见的，则返回 -1。

指定者：
类 TreeUI 中的 getRowForPath

getRowCount

public int getRowCount(JTree tree)
返回将显示的行数。

指定者：
类 TreeUI 中的 getRowCount

getClosestPathForLocation

public TreePath getClosestPathForLocation(JTree tree,
                                          int x,
                                          int y)
返回到达最接近于 x,y 的那个节点的路径。如果当前不可见，则返回 null，否则该方法总是返回一条有效路径。如果要测试返回的对象是否正好位于 x, y，则应该获取返回路径的边界，并根据该边界测试 x,y。

指定者：
类 TreeUI 中的 getClosestPathForLocation

isEditing

public boolean isEditing(JTree tree)
如果树正被编辑，则返回 true。正被编辑的项可由 getEditingPath() 返回。

指定者：
类 TreeUI 中的 isEditing

stopEditing

public boolean stopEditing(JTree tree)
停止当前编辑会话。如果不在编辑树，则此方法无效。如果编辑器允许停止编辑会话，则返回 true。

指定者：
类 TreeUI 中的 stopEditing

cancelEditing

public void cancelEditing(JTree tree)
取消当前编辑会话。

指定者：
类 TreeUI 中的 cancelEditing

startEditingAtPath

public void startEditingAtPath(JTree tree,
                               TreePath path)
选择路径中的最后一个项并尝试对其进行编辑。如果 CellEditor 不允许对所选项进行编辑操作，则编辑将失败。

指定者：
类 TreeUI 中的 startEditingAtPath

getEditingPath

public TreePath getEditingPath(JTree tree)
返回到达正被编辑的元素的路径。

指定者：
类 TreeUI 中的 getEditingPath

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

prepareForUIInstall

protected void prepareForUIInstall()
在设置 tree 实例变量之后，但在安装任何默认值/侦听器之前调用此方法。

completeUIInstall

protected void completeUIInstall()
在安装所有默认值/侦听器之后根据 installUI 调用。

installDefaults

protected void installDefaults()

installListeners

protected void installListeners()

installKeyboardActions

protected void installKeyboardActions()

installComponents

protected void installComponents()
安装作为渲染器窗格的树的子组件。

createNodeDimensions

protected AbstractLayoutCache.NodeDimensions createNodeDimensions()
创建能够确定树中给定节点大小的 NodeDimensions 的实例。

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
创建负责基于树的更改方式更新 UI 的侦听器。

createMouseListener

protected MouseListener createMouseListener()
创建负责基于鼠标事件更新选择的侦听器。

createFocusListener

protected FocusListener createFocusListener()
创建失去/获取焦点时负责更新显示的侦听器。

createKeyListener

protected KeyListener createKeyListener()
创建负责从树获取键事件的侦听器。

createSelectionModelPropertyChangeListener

protected PropertyChangeListener createSelectionModelPropertyChangeListener()
创建负责从选择模型获取属性更改事件的侦听器。

createTreeSelectionListener

protected TreeSelectionListener createTreeSelectionListener()
创建基于选择更改方法更新显示的侦听器。

createCellEditorListener

protected CellEditorListener createCellEditorListener()
创建在当前编辑器中处理事件的侦听器。

createComponentListener

protected ComponentListener createComponentListener()
创建并返回新的 ComponentHandler。它用于大型模型，在组件移动时将 validCachedPreferredSize 标记为无效。

createTreeExpansionListener

protected TreeExpansionListener createTreeExpansionListener()
创建并返回在节点展开状态更改时负责更新 treestate 的对象。

createLayoutCache

protected AbstractLayoutCache createLayoutCache()
创建负责管理展开内容及节点大小的对象。

createCellRendererPane

protected CellRendererPane createCellRendererPane()
返回用于放置渲染器组件的渲染器窗格。

createDefaultCellEditor

protected TreeCellEditor createDefaultCellEditor()
创建默认单元格编辑器。

createDefaultCellRenderer

protected TreeCellRenderer createDefaultCellRenderer()
返回用于为每个节点添加标志的默认单元格渲染器。

createTreeModelListener

protected TreeModelListener createTreeModelListener()
返回可以在模型更改时更新树的侦听器。

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

prepareForUIUninstall

protected void prepareForUIUninstall()

completeUIUninstall

protected void completeUIUninstall()

uninstallDefaults

protected void uninstallDefaults()

uninstallListeners

protected void uninstallListeners()

uninstallKeyboardActions

protected void uninstallKeyboardActions()

uninstallComponents

protected void uninstallComponents()
卸载渲染器窗格。

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 ComponentUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。

覆盖：
类 ComponentUI 中的 getBaselineResizeBehavior
参数：
c - 为其返回调整大小行为的 JComponent
返回：
一个枚举，指示基线如何随组件大小的改变而发生更改
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 ComponentUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintHorizontalPartOfLeg

protected void paintHorizontalPartOfLeg(Graphics g,
                                        Rectangle clipBounds,
                                        Insets insets,
                                        Rectangle bounds,
                                        TreePath path,
                                        int row,
                                        boolean isExpanded,
                                        boolean hasBeenExpanded,
                                        boolean isLeaf)
绘制支路 (leg) 的水平部分。接收者不应修改 clipBounds 或 insets。

注：如果树不可见，则 parentRow 为 -1。

paintVerticalPartOfLeg

protected void paintVerticalPartOfLeg(Graphics g,
                                      Rectangle clipBounds,
                                      Insets insets,
                                      TreePath path)
绘制支路的垂直部分。接收者不应修改 clipBounds、insets。

paintExpandControl

protected void paintExpandControl(Graphics g,
                                  Rectangle clipBounds,
                                  Insets insets,
                                  Rectangle bounds,
                                  TreePath path,
                                  int row,
                                  boolean isExpanded,
                                  boolean hasBeenExpanded,
                                  boolean isLeaf)
绘制 row 的展开（切换）部分。接收者不应修改 clipBounds 或 insets。

paintRow

protected void paintRow(Graphics g,
                        Rectangle clipBounds,
                        Insets insets,
                        Rectangle bounds,
                        TreePath path,
                        int row,
                        boolean isExpanded,
                        boolean hasBeenExpanded,
                        boolean isLeaf)
绘制 row 的渲染器部分。接收者不应修改 clipBounds 或 insets。

shouldPaintExpandControl

protected boolean shouldPaintExpandControl(TreePath path,
                                           int row,
                                           boolean isExpanded,
                                           boolean hasBeenExpanded,
                                           boolean isLeaf)
如果应该为指定行绘制展开（切换）控件，则返回 true。

paintVerticalLine

protected void paintVerticalLine(Graphics g,
                                 JComponent c,
                                 int x,
                                 int top,
                                 int bottom)
绘制垂直线。

paintHorizontalLine

protected void paintHorizontalLine(Graphics g,
                                   JComponent c,
                                   int y,
                                   int left,
                                   int right)
绘制水平线。

getVerticalLegBuffer

protected int getVerticalLegBuffer()
默认情况下，节点间支路的垂直元素开始于父节点的底部。此方法能让支路从该位置以下开始。

getHorizontalLegBuffer

protected int getHorizontalLegBuffer()
默认情况下，节点间支路的水平元素开始于子节点左侧的右边。此方法能让支路在该位置以前结束。

drawCentered

protected void drawCentered(Component c,
                            Graphics graphics,
                            Icon icon,
                            int x,
                            int y)

drawDashedHorizontalLine

protected void drawDashedHorizontalLine(Graphics g,
                                        int y,
                                        int x1,
                                        int x2)

drawDashedVerticalLine

protected void drawDashedVerticalLine(Graphics g,
                                      int x,
                                      int y1,
                                      int y2)

getRowX

protected int getRowX(int row,
                      int depth)
返回沿 x 轴呈现特定行的位置。返回值不包括在 JTree 上指定的任何 Insets。此方法不检查行或深度的有效性，只是假定其正确；如果行或深度与树的行或深度不匹配，则其也不抛出 Exception。

参数：
row - 返回 x 位置的行
depth - 行的深度
返回：
给定行的缩进量。
从以下版本开始：
1.5

updateLayoutCacheExpandedNodes

protected void updateLayoutCacheExpandedNodes()
让在 JTree 中展开的所有节点在 LayoutCache 中展开。此方法通过根路径调用 updateExpandedDescendants。

updateExpandedDescendants

protected void updateExpandedDescendants(TreePath path)
通过从树获取展开的子代并将其转发到树状态来更新 path 的所有子代的展开状态。

getLastChildPath

protected TreePath getLastChildPath(TreePath parent)
返回到 parent 的最后一个子节点的路径。

updateDepthOffset

protected void updateDepthOffset()
更新每次应该偏移的深度量。

updateCellEditor

protected void updateCellEditor()
基于包含所在的 JTree 的可编辑性更新 cellEditor。如果树可编辑但不具有 cellEditor，则使用基本的 cellEditor。

updateRenderer

protected void updateRenderer()
当渲染器更改时从所处的树中传递消息。

configureLayoutCache

protected void configureLayoutCache()
基于为其提供外观的树重置 TreeState 实例。

updateSize

protected void updateSize()
将缓存大小标记为无效并使用 treeDidChange 传递树的信息。

updateCachedPreferredSize

protected void updateCachedPreferredSize()
更新 preferredSize 实例变量，该变量从 getPreferredSize() 返回。

对于从左到右方向，大小是根据当前的 AbstractLayoutCache 确定的。对于 RTL 方向，首选大小为宽度减去最小 x 位置。

pathWasExpanded

protected void pathWasExpanded(TreePath path)
在展开 VisibleTreeNode 后，从其传递消息。

pathWasCollapsed

protected void pathWasCollapsed(TreePath path)
在折叠 VisibleTreeNode 后，从其传递消息。

ensureRowsAreVisible

protected void ensureRowsAreVisible(int beginRow,
                                    int endRow)
确保 beginRow 通过 endRow 标识的行是可见的。

setPreferredMinSize

public void setPreferredMinSize(Dimension newSize)
设置首选最小大小。

getPreferredMinSize

public Dimension getPreferredMinSize()
返回最小首选大小。

getPreferredSize

public Dimension getPreferredSize(JComponent c)
返回首选大小以正确显示树，这是一种 getPreferredSize(c, false) 的替代方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getPreferredSize

public Dimension getPreferredSize(JComponent c,
                                  boolean checkConsistancy)
返回首选大小以表示 c 中的树。如果 checkConsistancy 为 true，则首先传递 checkConsistancy 的消息。

getMinimumSize

public Dimension getMinimumSize(JComponent c)
返回此组件的最小大小。该大小将为最小首选大小或 0, 0。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
返回此组件的最大大小，如果实例当前位于 JTree 中或 0, 0 处，则该大小将为首选大小。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

completeEditing

protected void completeEditing()
传递消息以停止编辑会话。如果接收者为其提供外观的 UI 从 getInvokesStopCellEditing 返回 true，则在当前编辑器上调用 stopCellEditing。然后对 completeEditing 传递 false 或 true 消息，false 表示取消所有遗留的编辑。

completeEditing

protected void completeEditing(boolean messageStop,
                               boolean messageCancel,
                               boolean messageTree)
停止编辑会话。如果 messageStop 为 true，则对编辑器传递 stopEditing 的消息；如果 messageCancel 为 true，则对编辑器传递 cancelEditing 的消息。如果 messageTree 为 true，则对 treeModel 传递 valueForPathChanged 的消息。

startEditing

protected boolean startEditing(TreePath path,
                               MouseEvent event)
如果存在 cellEditor 并且 shouldSelectCell 返回 true，则启动节点的编辑操作。

此方法假定路径有效且可见。

checkForClickInExpandControl

protected void checkForClickInExpandControl(TreePath path,
                                            int mouseX,
                                            int mouseY)
如果 mouseX 和 mouseY 位于 row 的展开/折叠区域内，则此方法将切换行。

isLocationInExpandControl

protected boolean isLocationInExpandControl(TreePath path,
                                            int mouseX,
                                            int mouseY)
如果 mouseX 和 mouseY 落在用于展开/折叠节点的行的区域内，并且 row 的节点不表示叶节点，则返回 true。

handleExpandControlClick

protected void handleExpandControlClick(TreePath path,
                                        int mouseX,
                                        int mouseY)
当用户单击特定行时传递消息，此方法调用 toggleExpandState。

toggleExpandState

protected void toggleExpandState(TreePath path)
如果路径不是展开的，则展开它；如果它是展开的，则折叠它。如果展开路径且 JTree 在展开的基础上滚动，则调用 ensureRowsAreVisible 以滚动尽可能多的可见子节点（试图滚动到路径的最后一个可见子代）。

isToggleSelectionEvent

protected boolean isToggleSelectionEvent(MouseEvent event)
返回 true 表示节点上的鼠标事件应该仅切换鼠标下的行的选择。

isMultiSelectEvent

protected boolean isMultiSelectEvent(MouseEvent event)
返回 true 表示节点上的鼠标事件应该根据锚点作出选择。

isToggleEvent

protected boolean isToggleEvent(MouseEvent event)
返回 true 指示应该基于事件切换鼠标下的行。此方法在 checkForClickInExpandControl 之后调用，暗指该位置不受展开（切换）的控制

selectPathForEvent

protected void selectPathForEvent(TreePath path,
                                  MouseEvent event)
传递消息以基于特定行上的 MouseEvent 更新选择。如果事件为切换选择事件，则或者选择行或者取消选择行。如果事件标识多选择事件，则根据定位点更新选择。否则，选择行；如果事件指定了切换事件，则展开/折叠行。

isLeaf

protected boolean isLeaf(int row)
返回：
如果位于 row 的节点是叶节点，则返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.CellEditorHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.CellEditorHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
所有已实现的接口：
EventListener, CellEditorListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.CellEditorHandler
extends Object
implements CellEditorListener

侦听器负责获取单元格编辑事件并相应地更新树。

构造方法摘要
BasicTreeUI.CellEditorHandler()
方法摘要
void | editingCanceled(ChangeEvent e) 在树中取消编辑时传递消息。
void | editingStopped(ChangeEvent e) 在树中停止编辑时传递消息。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.CellEditorHandler

public BasicTreeUI.CellEditorHandler()
方法详细信息

editingStopped

public void editingStopped(ChangeEvent e)
在树中停止编辑时传递消息。

指定者：
接口 CellEditorListener 中的 editingStopped

editingCanceled

public void editingCanceled(ChangeEvent e)
在树中取消编辑时传递消息。

指定者：
接口 CellEditorListener 中的 editingCanceled
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.ComponentHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.ComponentHandler

java.lang.Object
    继承者  java.awt.event.ComponentAdapter
        继承者  javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
所有已实现的接口：
ActionListener, ComponentListener, EventListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.ComponentHandler
extends ComponentAdapter
implements ActionListener

滚动时更新首选大小（如果需要）。

字段摘要
protected JScrollBar | scrollBar 正在调整的 scrollBar。
protected Timer | timer 在滚动窗格中调整滚动条时使用的 Timer。
构造方法摘要
BasicTreeUI.ComponentHandler()
方法摘要
void | actionPerformed(ActionEvent ae) 因 Timer 而将此方法作为公共方法。
void | componentMoved(ComponentEvent e) 组件位置更改时调用。
protected JScrollPane | getScrollPane() 返回容纳 JTree 的 JScrollPane；如果一个也没有找到，则返回 null。
protected void | startTimer() 在必要时，创建并启动 Timer 来检查是否需要调整边界的大小。
从类 java.awt.event.ComponentAdapter 继承的方法
componentHidden, componentResized, componentShown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

timer

protected Timer timer
在滚动窗格中调整滚动条时使用的 Timer。

scrollBar

protected JScrollBar scrollBar
正在调整的 scrollBar。

构造方法详细信息

BasicTreeUI.ComponentHandler

public BasicTreeUI.ComponentHandler()
方法详细信息

componentMoved

public void componentMoved(ComponentEvent e)
从类 ComponentAdapter 复制的描述
组件位置更改时调用。

指定者：
接口 ComponentListener 中的 componentMoved
覆盖：
类 ComponentAdapter 中的 componentMoved

startTimer

protected void startTimer()
在必要时，创建并启动 Timer 来检查是否需要调整边界的大小。

getScrollPane

protected JScrollPane getScrollPane()
返回容纳 JTree 的 JScrollPane；如果一个也没有找到，则返回 null。

actionPerformed

public void actionPerformed(ActionEvent ae)
因 Timer 而将此方法作为公共方法。如果 scrollBar 为 null 或者没有调整，则其停止计时器并更新大小。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.FocusHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.FocusHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTreeUI.FocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.FocusHandler
extends Object
implements FocusListener

失去/获得焦点时重绘前导选择行。

构造方法摘要
BasicTreeUI.FocusHandler()
方法摘要
void | focusGained(FocusEvent e) 在当前树上激活焦点、重绘前导行时调用。
void | focusLost(FocusEvent e) 在当前树上激活焦点、重绘前导行时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.FocusHandler

public BasicTreeUI.FocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent e)
在当前树上激活焦点、重绘前导行时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
在当前树上激活焦点、重绘前导行时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.KeyHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.KeyHandler

java.lang.Object
    继承者  java.awt.event.KeyAdapter
        继承者  javax.swing.plaf.basic.BasicTreeUI.KeyHandler
所有已实现的接口：
KeyListener, EventListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.KeyHandler
extends KeyAdapter

用于获取多个按键事件以适当生成事件。

字段摘要
protected boolean | isKeyDown keyPressed 处于激活状态时设置为 true。
protected Action | repeatKeyAction 正在生成的键代码。
构造方法摘要
BasicTreeUI.KeyHandler()
方法摘要
void | keyPressed(KeyEvent e) 按下某个键时调用此方法。
void | keyReleased(KeyEvent e) 释放某个键时调用此方法。
void | keyTyped(KeyEvent e) 键入键时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

repeatKeyAction

protected Action repeatKeyAction
正在生成的键代码。

isKeyDown

protected boolean isKeyDown
keyPressed 处于激活状态时设置为 true。

构造方法详细信息

BasicTreeUI.KeyHandler

public BasicTreeUI.KeyHandler()
方法详细信息

keyTyped

public void keyTyped(KeyEvent e)
键入键时调用。 将键盘焦点移动到其第一个字母与用户按下的字母数字键相匹配的第一个元素。后续相同按键将键盘焦点移动到以该字母开头的下一个对象上。

指定者：
接口 KeyListener 中的 keyTyped
覆盖：
类 KeyAdapter 中的 keyTyped

keyPressed

public void keyPressed(KeyEvent e)
从类 KeyAdapter 复制的描述
按下某个键时调用此方法。

指定者：
接口 KeyListener 中的 keyPressed
覆盖：
类 KeyAdapter 中的 keyPressed

keyReleased

public void keyReleased(KeyEvent e)
从类 KeyAdapter 复制的描述
释放某个键时调用此方法。

指定者：
接口 KeyListener 中的 keyReleased
覆盖：
类 KeyAdapter 中的 keyReleased
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.MouseHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.MouseHandler

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.basic.BasicTreeUI.MouseHandler
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.MouseHandler
extends MouseAdapter
implements MouseMotionListener

TreeMouseListener 负责基于鼠标事件更新选择。

构造方法摘要
BasicTreeUI.MouseHandler()
方法摘要
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseMoved(MouseEvent e) 已将鼠标按键移动到组件上（但没有按下任何一个按键）时调用。
void | mousePressed(MouseEvent e) 在组件上按下鼠标按键时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseEntered, mouseExited, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.MouseHandler

public BasicTreeUI.MouseHandler()
方法详细信息

mousePressed

public void mousePressed(MouseEvent e)
在组件上按下鼠标按键时调用。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed

mouseDragged

public void mouseDragged(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseAdapter 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
已将鼠标按键移动到组件上（但没有按下任何一个按键）时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseAdapter 中的 mouseMoved
从以下版本开始：
1.4

mouseReleased

public void mouseReleased(MouseEvent e)
从类 MouseAdapter 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
覆盖：
类 MouseAdapter 中的 mouseReleased
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.MouseInputHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.MouseInputHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.MouseInputHandler
extends Object
implements MouseInputListener

在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。假定所有事件都是源的当前目标。

字段摘要
protected Component | destination 接收所有事件的目的地。
protected Component | source 发起事件的源。
构造方法摘要
BasicTreeUI.MouseInputHandler(Component source, Component destination, MouseEvent event)
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
protected void | removeFromSource()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

source

protected Component source
发起事件的源。

destination

protected Component destination
接收所有事件的目的地。

构造方法详细信息

BasicTreeUI.MouseInputHandler

public BasicTreeUI.MouseInputHandler(Component source,
                                     Component destination,
                                     MouseEvent event)
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased

mouseEntered

public void mouseEntered(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved

removeFromSource

protected void removeFromSource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.NodeDimensionsHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.NodeDimensionsHandler

java.lang.Object
    继承者  javax.swing.tree.AbstractLayoutCache.NodeDimensions
        继承者  javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
正在封闭类：
BasicTreeUI
public class BasicTreeUI.NodeDimensionsHandler
extends AbstractLayoutCache.NodeDimensions

负责获取节点大小的类，其方法被转发到 BasicTreeUI 方法。X 位置不包括 insets，其用 getPathBounds 处理。

构造方法摘要
BasicTreeUI.NodeDimensionsHandler()
方法摘要
Rectangle | getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle size) 负责获取特定节点的大小。
protected int | getRowX(int row, int depth)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.NodeDimensionsHandler

public BasicTreeUI.NodeDimensionsHandler()
方法详细信息

getNodeDimensions

public Rectangle getNodeDimensions(Object value,
                                   int row,
                                   int depth,
                                   boolean expanded,
                                   Rectangle size)
负责获取特定节点的大小。

指定者：
类 AbstractLayoutCache.NodeDimensions 中的 getNodeDimensions
参数：
value - 要表示的 value
row - 查询的行
depth - 行的深度
expanded - 如果行已扩展，则为 true，否则为 false
size - 包含表示 value 所需大小的 Rectangle
返回：
包含节点尺寸的 Rectangle，如果节点没有尺寸，则返回 null

getRowX

protected int getRowX(int row,
                      int depth)
返回：
给定行的缩进量。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.PropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.PropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.PropertyChangeHandler
extends Object
implements PropertyChangeListener

树的 PropertyChangeListener。基于所做的更改更新适当的变量或 TreeState。

构造方法摘要
BasicTreeUI.PropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent event)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.PropertyChangeHandler

public BasicTreeUI.PropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent event)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
event - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.SelectionModelPropertyChangeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.SelectionModelPropertyChangeHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.SelectionModelPropertyChangeHandler
extends Object
implements PropertyChangeListener

TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。

构造方法摘要
BasicTreeUI.SelectionModelPropertyChangeHandler()
方法摘要
 void propertyChange(PropertyChangeEvent event)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.SelectionModelPropertyChangeHandler

public BasicTreeUI.SelectionModelPropertyChangeHandler()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent event)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
event - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreeExpansionHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreeExpansionHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
所有已实现的接口：
EventListener, TreeExpansionListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreeExpansionHandler
extends Object
implements TreeExpansionListener

更新 TreeState 以响应节点的展开/折叠。

构造方法摘要
BasicTreeUI.TreeExpansionHandler()
方法摘要
void | treeCollapsed(TreeExpansionEvent event) 每当树中的项被折叠时调用。
void | treeExpanded(TreeExpansionEvent event) 每当树中的项被展开时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.TreeExpansionHandler

public BasicTreeUI.TreeExpansionHandler()
方法详细信息

treeExpanded

public void treeExpanded(TreeExpansionEvent event)
每当树中的项被展开时调用。

指定者：
接口 TreeExpansionListener 中的 treeExpanded

treeCollapsed

public void treeCollapsed(TreeExpansionEvent event)
每当树中的项被折叠时调用。

指定者：
接口 TreeExpansionListener 中的 treeCollapsed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreeCancelEditingAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreeCancelEditingAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreeCancelEditingAction
extends AbstractAction

执行操作时调用 cancelEditing 的 ActionListener。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicTreeUI.TreeCancelEditingAction(String name)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.TreeCancelEditingAction

public BasicTreeUI.TreeCancelEditingAction(String name)
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreeHomeAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreeHomeAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreeHomeAction
extends AbstractAction

TreeHomeAction 用于处理 end/home 动作。基于某方向滚动第一个单元格或最后一个单元格以使其可见。

字段摘要
protected  int direction
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicTreeUI.TreeHomeAction(int direction, String name)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

direction

protected int direction
构造方法详细信息

BasicTreeUI.TreeHomeAction

public BasicTreeUI.TreeHomeAction(int direction,
                                  String name)
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreeIncrementAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreeIncrementAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreeIncrementAction
extends AbstractAction

TreeIncrementAction 用于处理向上/向下操作。选择基于方向上移或下移。

字段摘要
protected  int direction
指定用于调整选择的方向。
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicTreeUI.TreeIncrementAction(int direction, String name)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

direction

protected int direction
指定用于调整选择的方向。

构造方法详细信息

BasicTreeUI.TreeIncrementAction

public BasicTreeUI.TreeIncrementAction(int direction,
                                       String name)
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreeModelHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreeModelHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
所有已实现的接口：
EventListener, TreeModelListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreeModelHandler
extends Object
implements TreeModelListener

将所有 TreeModel 事件转发到 TreeState。

构造方法摘要
BasicTreeUI.TreeModelHandler()
方法摘要
void | treeNodesChanged(TreeModelEvent e) 在已经以某种方式更改节点（或同级节点集）后调用。
void | treeNodesInserted(TreeModelEvent e) 在已将节点插入树中以后调用。
void | treeNodesRemoved(TreeModelEvent e) 在已从树中移除节点后调用。
void | treeStructureChanged(TreeModelEvent e) 在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.TreeModelHandler

public BasicTreeUI.TreeModelHandler()
方法详细信息

treeNodesChanged

public void treeNodesChanged(TreeModelEvent e)
从接口 TreeModelListener 复制的描述

在已经以某种方式更改节点（或同级节点集）后调用。这些节点在树中的位置没有改变，或者说没有更改其子数组，但其他一些属性已发生更改，并且可能影响表示形式。示例：文件的名称已更改，但它仍然在文件系统中的同一位置上。

要指示根已更改，则 childIndices 和 children 将为 null。

可使用 e.getPath() 获得已更改节点的父节点。e.getChildIndices() 返回已更改节点的索引。

指定者：
接口 TreeModelListener 中的 treeNodesChanged

treeNodesInserted

public void treeNodesInserted(TreeModelEvent e)
从接口 TreeModelListener 复制的描述

在已将节点插入树中以后调用。

可使用 e.getPath() 获得新节点的父节点。e.getChildIndices() 按升序返回新节点的索引。

指定者：
接口 TreeModelListener 中的 treeNodesInserted

treeNodesRemoved

public void treeNodesRemoved(TreeModelEvent e)
从接口 TreeModelListener 复制的描述

在已从树中移除节点后调用。注意，如果从树中移除一个子树，则可能仅对已移除子树的根调用此方法一次，而不是对每个已移除的同级子树集调用一次。

可使用 e.getPath() 获得已删除节点的前父节点。e.getChildIndices() 按升序返回删除此节点前该节点所拥有的索引。

指定者：
接口 TreeModelListener 中的 treeNodesRemoved

treeStructureChanged

public void treeStructureChanged(TreeModelEvent e)
从接口 TreeModelListener 复制的描述

在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。如果由 e.getPath() 返回的路径长度为 1，并且第一个元素并没有标识当前根节点，则第一个元素应该成为树的新根。

可使用 e.getPath() 获得到该节点的路径。e.getChildIndices() 返回 null。

指定者：
接口 TreeModelListener 中的 treeStructureChanged
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreePageAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreePageAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicTreeUI.TreePageAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreePageAction
extends AbstractAction

TreePageAction 处理向上翻页和向下翻页事件。

字段摘要
protected  int direction
指定用于调整选择的方向。
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicTreeUI.TreePageAction(int direction, String name)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

direction

protected int direction
指定用于调整选择的方向。

构造方法详细信息

BasicTreeUI.TreePageAction

public BasicTreeUI.TreePageAction(int direction,
                                  String name)
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreeSelectionHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreeSelectionHandler

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler
所有已实现的接口：
EventListener, TreeSelectionListener
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreeSelectionHandler
extends Object
implements TreeSelectionListener

侦听选择模型中的更改并相应地更新显示。

构造方法摘要
BasicTreeUI.TreeSelectionHandler()
方法摘要
 void valueChanged(TreeSelectionEvent event)
当显示的树中发生选择更改时传递消息。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.TreeSelectionHandler

public BasicTreeUI.TreeSelectionHandler()
方法详细信息

valueChanged

public void valueChanged(TreeSelectionEvent event)
当显示的树中发生选择更改时传递消息。停止编辑、向父级传递消息并显示更改的路径。

指定者：
接口 TreeSelectionListener 中的 valueChanged
参数：
event - 表现更改的特征的事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreeToggleAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreeToggleAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreeToggleAction
extends AbstractAction

对于第一个选定行展开将被切换。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicTreeUI.TreeToggleAction(String name)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicTreeUI.TreeToggleAction

public BasicTreeUI.TreeToggleAction(String name)
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicTreeUI.TreeTraverseAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicTreeUI.TreeTraverseAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
BasicTreeUI
public class BasicTreeUI.TreeTraverseAction
extends AbstractAction

TreeTraverseAction 是用于向左/向右方向键的动作。将切换节点的展开，以及潜在地增加选择。

字段摘要
protected  int direction
确定要遍历的方向，1 意味着展开，-1 意味着折叠。
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
BasicTreeUI.TreeTraverseAction(int direction, String name)
方法摘要
void | actionPerformed(ActionEvent e) 发生操作时调用。
boolean | isEnabled() 如果启用该操作，则返回 true。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

direction

protected int direction
确定要遍历的方向，1 意味着展开，-1 意味着折叠。

构造方法详细信息

BasicTreeUI.TreeTraverseAction

public BasicTreeUI.TreeTraverseAction(int direction,
                                      String name)
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

isEnabled

public boolean isEnabled()
从类 AbstractAction 复制的描述
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
覆盖：
类 AbstractAction 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicViewportUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 BasicViewportUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ViewportUI
            继承者  javax.swing.plaf.basic.BasicViewportUI

public class BasicViewportUI
extends ViewportUI

BasicViewport 实现

构造方法摘要
BasicViewportUI()
方法摘要
static ComponentUI | createUI(JComponent c)
protected void | installDefaults(JComponent c)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected void | uninstallDefaults(JComponent c)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BasicViewportUI

public BasicViewportUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 ComponentUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installDefaults

protected void installDefaults(JComponent c)

uninstallDefaults

protected void uninstallDefaults(JComponent c)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultMenuLayout (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.basic
类 DefaultMenuLayout

java.lang.Object
    继承者  javax.swing.BoxLayout
        继承者  javax.swing.plaf.basic.DefaultMenuLayout
所有已实现的接口：
LayoutManager, LayoutManager2, Serializable, UIResource
public class DefaultMenuLayout
extends BoxLayout
implements UIResource

Popup 菜单和菜单栏的默认布局管理器。此类为 BoxLayout 的扩展，BoxLayout 添加了 UIResource 标记，这样可插入 L&F 即可把它与用户在菜单上安装的布局管理器区分开。

字段摘要
从类 javax.swing.BoxLayout 继承的字段
LINE_AXIS, PAGE_AXIS, X_AXIS, Y_AXIS
构造方法摘要
DefaultMenuLayout(Container target, int axis)
方法摘要
 Dimension preferredLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。
从类 javax.swing.BoxLayout 继承的方法
addLayoutComponent, addLayoutComponent, getAxis, getLayoutAlignmentX, getLayoutAlignmentY, getTarget, invalidateLayout, layoutContainer, maximumLayoutSize, minimumLayoutSize, removeLayoutComponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultMenuLayout

public DefaultMenuLayout(Container target,
                         int axis)
方法详细信息

preferredLayoutSize

public Dimension preferredLayoutSize(Container target)
从类 BoxLayout 复制的描述
在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
覆盖：
类 BoxLayout 中的 preferredLayoutSize
参数：
target - 需要布置的容器
返回：
>= 0 && <= Integer.MAX_VALUE 的尺寸
另请参见：
Container, BoxLayout.minimumLayoutSize(java.awt.Container), BoxLayout.maximumLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.plaf.basic (Java Platform SE 6)

 javax.swing.plaf.basic
接口
ComboPopup
类
BasicArrowButton
BasicBorders
BasicBorders.ButtonBorder
BasicBorders.FieldBorder
BasicBorders.MarginBorder
BasicBorders.MenuBarBorder
BasicBorders.RadioButtonBorder
BasicBorders.RolloverButtonBorder
BasicBorders.SplitPaneBorder
BasicBorders.ToggleButtonBorder
BasicButtonListener
BasicButtonUI
BasicCheckBoxMenuItemUI
BasicCheckBoxUI
BasicColorChooserUI
BasicComboBoxEditor
BasicComboBoxEditor.UIResource
BasicComboBoxRenderer
BasicComboBoxRenderer.UIResource
BasicComboBoxUI
BasicComboPopup
BasicDesktopIconUI
BasicDesktopPaneUI
BasicDirectoryModel
BasicEditorPaneUI
BasicFileChooserUI
BasicFormattedTextFieldUI
BasicGraphicsUtils
BasicHTML
BasicIconFactory
BasicInternalFrameTitlePane
BasicInternalFrameUI
BasicLabelUI
BasicListUI
BasicLookAndFeel
BasicMenuBarUI
BasicMenuItemUI
BasicMenuUI
BasicOptionPaneUI
BasicOptionPaneUI.ButtonAreaLayout
BasicPanelUI
BasicPasswordFieldUI
BasicPopupMenuSeparatorUI
BasicPopupMenuUI
BasicProgressBarUI
BasicRadioButtonMenuItemUI
BasicRadioButtonUI
BasicRootPaneUI
BasicScrollBarUI
BasicScrollPaneUI
BasicSeparatorUI
BasicSliderUI
BasicSpinnerUI
BasicSplitPaneDivider
BasicSplitPaneUI
BasicTabbedPaneUI
BasicTableHeaderUI
BasicTableUI
BasicTextAreaUI
BasicTextFieldUI
BasicTextPaneUI
BasicTextUI
BasicTextUI.BasicCaret
BasicTextUI.BasicHighlighter
BasicToggleButtonUI
BasicToolBarSeparatorUI
BasicToolBarUI
BasicToolTipUI
BasicTreeUI
BasicViewportUI
DefaultMenuLayout


javax.swing.plaf.basic (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.plaf.basic

提供了根据基本外观构建的用户界面对象。

请参见：
描述

接口摘要
ComboPopup 定义实现组合框弹出部分所需方法的接口。

类摘要
BasicArrowButton | 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
BasicBorders | 可以提供适合基本 L&F 的 Border 的工厂对象。
BasicBorders.ButtonBorder |
BasicBorders.FieldBorder |
BasicBorders.MarginBorder |
BasicBorders.MenuBarBorder |
BasicBorders.RadioButtonBorder |
BasicBorders.RolloverButtonBorder | 用于翻转工具栏按钮的特殊细边框。
BasicBorders.SplitPaneBorder | 绘制围绕拆分窗格的边框。
BasicBorders.ToggleButtonBorder |
BasicButtonListener | 按钮侦听器。
BasicButtonUI | BasicButton 实现
BasicCheckBoxMenuItemUI | BasicCheckboxMenuItem 实现
BasicCheckBoxUI | BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicColorChooserUI | 为 JColorChooser 提供基本外观。
BasicComboBoxEditor | 用于可编辑组合框的默认编辑器。
BasicComboBoxEditor.UIResource | 实现 UIResource 的 BasicComboBoxEditor 的子类。
BasicComboBoxRenderer | ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicComboBoxRenderer.UIResource | 实现 UIResource 的 BasicComboBoxRenderer 的子类。
BasicComboBoxUI | JComboBox 的基本 UI 实现。
BasicComboPopup | 此为 ComboPopup 接口的基本实现。
BasicDesktopIconUI | 用于桌面最小化窗口的 L&F。
BasicDesktopPaneUI | 桌面的基本 L&F。
BasicDirectoryModel | 文件列表的基本实现。
BasicEditorPaneUI | 为 JEditorPane 提供外观。
BasicFileChooserUI | FileChooser 的基本 L&F 实现。
BasicFormattedTextFieldUI | 提供 JFormattedTextField 的外观实现。
BasicGraphicsUtils |
BasicHTML | 支持为 swing 组件提供 html 视图。
BasicIconFactory | 提供适于基本 L & F 使用的 Icon 的工厂对象。
BasicInternalFrameTitlePane | 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicInternalFrameUI | JInternalFrame 的基本 L&F 实现。
BasicLabelUI | LabelUI 的 Windows L&F 实现。
BasicListUI | ListUI 的可扩展实现。
BasicLookAndFeel | 为 Swing 创建外观时要使用的基类。
BasicMenuBarUI | MenuBarUI 的默认 L&F 实现。
BasicMenuItemUI | BasicMenuItem 实现
BasicMenuUI | MenuUI 的默认 L&F 实现。
BasicOptionPaneUI | 为 JOptionPane 提供基本外观。
BasicOptionPaneUI.ButtonAreaLayout | ButtonAreaLayout 的行为方式类似于 FlowLayout。
BasicPanelUI | BasicPanel 实现
BasicPasswordFieldUI | 为密码字段提供 Windows 外观。
BasicPopupMenuSeparatorUI | PopupMenuSeparatorUI 的基本 L&F 实现。
BasicPopupMenuUI | PopupMenuUI 的 Windows L&F 实现。
BasicProgressBarUI | ProgressBarUI 的基本 L&F 实现。
BasicRadioButtonMenuItemUI | BasicRadioButtonMenuItem 实现
BasicRadioButtonUI | BasicRadioButtonUI 的 RadioButtonUI 实现
BasicRootPaneUI | RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
BasicScrollBarUI | 基本外观的 ScrollBarUI 的实现
BasicScrollPaneUI | ScrollPaneUI 的默认 L&F 实现。
BasicSeparatorUI | SeparatorUI 的基本 L&F 实现。
BasicSliderUI | SliderUI 的基本 L&F 实现。
BasicSpinnerUI | 默认 Spinner UI 委托。
BasicSplitPaneDivider | BasicSplitPaneUI 使用的分隔符。
BasicSplitPaneUI | SplitPaneUI 的基本 L&F 实现。
BasicTabbedPaneUI | TabbedPaneUI 的基本 L&F 实现。
BasicTableHeaderUI | BasicTableHeaderUI 实现
BasicTableUI | BasicTableUI 实现
BasicTextAreaUI | 为纯文本编辑器提供外观。
BasicTextFieldUI | JTextField 的外观的基础。
BasicTextPaneUI | 为样式化文本编辑器提供外观。
BasicTextUI | 此类是文本组件外观的基础。
BasicTextUI.BasicCaret |
BasicTextUI.BasicHighlighter |
BasicToggleButtonUI | BasicToggleButton 实现
BasicToolBarSeparatorUI | ToolBarSeparatorUI 的基本 L&F 实现。
BasicToolBarUI | ToolBarUI 的基本 L&F 实现。
BasicToolTipUI | 标准工具提示 L&F。
BasicTreeUI | 层次数据结构的基本 L&F。
BasicViewportUI | BasicViewport 实现
DefaultMenuLayout | Popup 菜单和菜单栏的默认布局管理器。

软件包 javax.swing.plaf.basic 的描述

提供了根据基本外观构建的用户界面对象。基本外观提供由很多外观包使用的默认行为。基本外观包含组件、布局管理器、事件、事件侦听器和适配器。可以子类化此包中的类来创建自己自定义的外观。

这些类被设计成在已安装相应的 LookAndFeel 类 (UIManager.setLookAndFeel(new XXXLookAndFeel())) 时使用。安装了不同的 LookAndFeel 时使用它们可能产生不可预料的结果，包括异常。此外，更改由 UIManager 维护的 LookAndFeel 却不更新所有 JComponent 的相应 ComponentUI 也会产生不可预料的结果，比如错误的显示颜色，因而通常不鼓励这样做。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.plaf.basic 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf.basic 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
      • javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
      • javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
      • javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
      • javax.swing.plaf.basic.BasicSliderUI.ActionScroller
      • javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
      • javax.swing.plaf.basic.BasicTreeUI.TreePageAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
        • javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
        • javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
      • javax.swing.plaf.basic.BasicBorders.FieldBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MarginBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
      • javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
    • javax.swing.AbstractListModel (implements javax.swing.ListModel, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDirectoryModel (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicBorders
    • javax.swing.plaf.basic.BasicBorders.SplitPaneBorder (implements javax.swing.border.Border, javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicButtonListener (implements javax.swing.event.ChangeListener, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboBoxEditor (implements javax.swing.ComboBoxEditor, java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboPopup.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicGraphicsUtils
    • javax.swing.plaf.basic.BasicHTML
    • javax.swing.plaf.basic.BasicIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener (implements javax.swing.event.InternalFrameListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler (implements java.awt.event.ComponentListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicListUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicListUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicListUI.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicListUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicMenuUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ModelListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler (implements java.awt.event.MouseWheelListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
      • javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
    • javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager (implements java.awt.LayoutManager2)
      • javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTableUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTableUI.KeyHandler (implements java.awt.event.KeyListener)
    • javax.swing.plaf.basic.BasicTableUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener (implements java.awt.event.ContainerListener)
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler (implements javax.swing.event.CellEditorListener)
    • javax.swing.plaf.basic.BasicTreeUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler (implements javax.swing.event.TreeExpansionListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler (implements javax.swing.event.TreeSelectionListener)
    • javax.swing.BoxLayout (implements java.awt.LayoutManager2, java.io.Serializable)
      • javax.swing.plaf.basic.DefaultMenuLayout (implements javax.swing.plaf.UIResource)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.plaf.basic.BasicSplitPaneDivider (implements java.beans.PropertyChangeListener)
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
              • javax.swing.plaf.basic.BasicArrowButton (implements javax.swing.SwingConstants)
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.plaf.basic.BasicComboBoxRenderer (implements javax.swing.ListCellRenderer, java.io.Serializable)
              • javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource (implements javax.swing.plaf.UIResource)
          • javax.swing.JMenuBar (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicComboPopup (implements javax.swing.plaf.basic.ComboPopup)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • javax.swing.plaf.basic.BasicToolBarUI.DragWindow
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
      • javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
      • javax.swing.plaf.basic.BasicTreeUI.ComponentHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.basic.BasicCheckBoxUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
            • javax.swing.plaf.basic.BasicMenuUI
            • javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.basic.BasicColorChooserUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.basic.BasicDesktopPaneUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.basic.BasicListUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.basic.BasicOptionPaneUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.basic.BasicPanelUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.basic.BasicPopupMenuUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI (implements java.awt.LayoutManager, javax.swing.SwingConstants)
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI (implements javax.swing.ScrollPaneConstants)
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
          • javax.swing.plaf.basic.BasicToolBarSeparatorUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.basic.BasicSpinnerUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI (implements javax.swing.SwingConstants)
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.basic.BasicTableHeaderUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.basic.BasicTableUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.basic.BasicTextPaneUI
          • javax.swing.plaf.basic.BasicTextAreaUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.basic.BasicFormattedTextFieldUI
            • javax.swing.plaf.basic.BasicPasswordFieldUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI (implements javax.swing.SwingConstants)
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.basic.BasicViewportUI
    • javax.swing.filechooser.FileFilter
      • javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
    • javax.swing.filechooser.FileView
      • javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
    • java.awt.event.FocusAdapter (implements java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
      • javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
    • java.awt.event.KeyAdapter (implements java.awt.event.KeyListener)
      • javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
      • javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
      • javax.swing.plaf.basic.BasicTreeUI.KeyHandler
    • javax.swing.text.LayeredHighlighter (implements javax.swing.text.Highlighter)
      • javax.swing.text.DefaultHighlighter
        • javax.swing.plaf.basic.BasicTextUI.BasicHighlighter (implements javax.swing.plaf.UIResource)
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
      • javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
      • javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
      • javax.swing.plaf.basic.BasicScrollBarUI.TrackListener (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
      • javax.swing.plaf.basic.BasicTreeUI.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.event.MouseInputAdapter (implements javax.swing.event.MouseInputListener)
        • javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
        • javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener (implements javax.swing.SwingConstants)
        • javax.swing.plaf.basic.BasicSliderUI.TrackListener
    • java.awt.event.MouseMotionAdapter (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
          • javax.swing.text.DefaultCaret (implements javax.swing.text.Caret, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
            • javax.swing.plaf.basic.BasicTextUI.BasicCaret (implements javax.swing.plaf.UIResource)
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
      • javax.swing.plaf.basic.BasicToolBarUI.FrameListener

接口分层结构

  • javax.swing.plaf.basic.ComboPopup
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.plaf.basic 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf.basic
的使用

使用 javax.swing.plaf.basic 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 使用的 javax.swing.plaf.basic 中的类
BasicBorders.ButtonBorder
BasicButtonListener
按钮侦听器。
BasicButtonUI
BasicButton 实现
BasicComboBoxEditor
用于可编辑组合框的默认编辑器。
BasicComboBoxRenderer
ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicDirectoryModel
文件列表的基本实现。
BasicEditorPaneUI
为 JEditorPane 提供外观。
BasicInternalFrameTitlePane
管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicLabelUI
LabelUI 的 Windows L&F 实现。
BasicMenuItemUI
BasicMenuItem 实现
BasicMenuUI
MenuUI 的默认 L&F 实现。
BasicRadioButtonUI
BasicRadioButtonUI 的 RadioButtonUI 实现
BasicScrollBarUI.ArrowButtonListener
光标键的侦听器。
BasicScrollBarUI.ModelListener
侦听模型更改的侦听器。
BasicScrollBarUI.ScrollListener
在 ScrollPane 中发起的滚动事件的侦听器。
BasicScrollBarUI.TrackListener
跟踪鼠标拖动。
BasicSeparatorUI
SeparatorUI 的基本 L&F 实现。
BasicSliderUI.ScrollListener
滚动事件侦听器。
BasicSliderUI.TrackListener
跟踪鼠标移动。
BasicSplitPaneDivider
BasicSplitPaneUI 使用的分隔符。
BasicSplitPaneDivider.DragController
在面向 HORIZONTAL_SPLIT 的拆分窗格的拖动会话期间处理事件。
BasicSplitPaneDivider.MouseHandler
MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
BasicSplitPaneUI
SplitPaneUI 的基本 L&F 实现。
BasicSplitPaneUI.BasicHorizontalLayoutManager
具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。
BasicTextFieldUI
JTextField 的外观的基础。
BasicTextUI
此类是文本组件外观的基础。
BasicToggleButtonUI
BasicToggleButton 实现
BasicToolBarUI.DragWindow
ComboPopup
定义实现组合框弹出部分所需方法的接口。

javax.swing.plaf.metal 使用的 javax.swing.plaf.basic 中的类
BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
BasicButtonListener
按钮侦听器。
BasicButtonUI
BasicButton 实现
BasicComboBoxEditor
用于可编辑组合框的默认编辑器。
BasicComboBoxUI
JComboBox 的基本 UI 实现。
BasicComboBoxUI.ComboBoxLayoutManager
此布局管理器处理组合框的“标准”布局。
BasicComboBoxUI.PropertyChangeHandler
此侦听器观察在组合框中发生更改的绑定 (bound) 属性。
BasicComboPopup
此为 ComboPopup 接口的基本实现。
BasicDesktopIconUI
用于桌面最小化窗口的 L&F。
BasicFileChooserUI
FileChooser 的基本 L&F 实现。
BasicInternalFrameTitlePane
管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicInternalFrameUI
JInternalFrame 的基本 L&F 实现。
BasicLabelUI
LabelUI 的 Windows L&F 实现。
BasicLookAndFeel
为 Swing 创建外观时要使用的基类。
BasicMenuBarUI
MenuBarUI 的默认 L&F 实现。
BasicProgressBarUI
ProgressBarUI 的基本 L&F 实现。
BasicRadioButtonUI
BasicRadioButtonUI 的 RadioButtonUI 实现
BasicRootPaneUI
RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
BasicScrollBarUI
基本外观的 ScrollBarUI 的实现
BasicScrollPaneUI
ScrollPaneUI 的默认 L&F 实现。
BasicSeparatorUI
SeparatorUI 的基本 L&F 实现。
BasicSliderUI
SliderUI 的基本 L&F 实现。
BasicSliderUI.PropertyChangeHandler
BasicSplitPaneDivider
BasicSplitPaneUI 使用的分隔符。
BasicSplitPaneUI
SplitPaneUI 的基本 L&F 实现。
BasicTabbedPaneUI
TabbedPaneUI 的基本 L&F 实现。
BasicTabbedPaneUI.TabbedPaneLayout
此类应视为“受保护”内部类。
BasicTextFieldUI
JTextField 的外观的基础。
BasicTextUI
此类是文本组件外观的基础。
BasicToggleButtonUI
BasicToggleButton 实现
BasicToolBarUI
ToolBarUI 的基本 L&F 实现。
BasicToolBarUI.DockingListener
此类应视为“受保护”内部类。
BasicToolBarUI.PropertyListener
BasicToolBarUI.ToolBarContListener
BasicToolTipUI
标准工具提示 L&F。
BasicTreeUI
层次数据结构的基本 L&F。
ComboPopup
定义实现组合框弹出部分所需方法的接口。

javax.swing.plaf.synth 使用的 javax.swing.plaf.basic 中的类
BasicLookAndFeel
为 Swing 创建外观时要使用的基类。

javax.swing.text 使用的 javax.swing.plaf.basic 中的类
BasicTextUI
此类是文本组件外观的基础。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicCheckBoxUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicCheckBoxUI
的使用

没有 javax.swing.plaf.basic.BasicCheckBoxUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicColorChooserUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicColorChooserUI
的使用

没有 javax.swing.plaf.basic.BasicColorChooserUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler
的使用

没有 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopIconUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopIconUI
的使用

使用 BasicDesktopIconUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicDesktopIconUI 的使用

javax.swing.plaf.metal 中 BasicDesktopIconUI 的子类
 class MetalDesktopIconUI
Metal 桌面图标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
的使用

没有 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicDirectoryModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicDirectoryModel
的使用

使用 BasicDirectoryModel 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicDirectoryModel 的使用

返回 BasicDirectoryModel 的 javax.swing.plaf.basic 中的方法
 BasicDirectoryModel BasicFileChooserUI.getModel()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicEditorPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicEditorPaneUI
的使用

使用 BasicEditorPaneUI 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicEditorPaneUI 的使用

javax.swing.plaf.basic 中 BasicEditorPaneUI 的子类
 class BasicTextPaneUI
为样式化文本编辑器提供外观。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI
的使用

使用 BasicFileChooserUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicFileChooserUI 的使用

javax.swing.plaf.metal 中 BasicFileChooserUI 的子类
 class MetalFileChooserUI
FileChooser 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI
的使用

使用 BasicInternalFrameUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicInternalFrameUI 的使用

javax.swing.plaf.metal 中 BasicInternalFrameUI 的子类
 class MetalInternalFrameUI
JInternalFrame 的 Metal 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
的使用

没有 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicFormattedTextFieldUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicFormattedTextFieldUI
的使用

没有 javax.swing.plaf.basic.BasicFormattedTextFieldUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane
的使用

使用 BasicInternalFrameTitlePane 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicInternalFrameTitlePane 的使用

声明为 BasicInternalFrameTitlePane 的 javax.swing.plaf.basic 中的字段
protected  BasicInternalFrameTitlePane BasicInternalFrameUI.titlePane

javax.swing.plaf.metal 中 BasicInternalFrameTitlePane 的使用

javax.swing.plaf.metal 中 BasicInternalFrameTitlePane 的子类
 class MetalInternalFrameTitlePane
管理 JLF 标题栏的类

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicOptionPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicOptionPaneUI
的使用

没有 javax.swing.plaf.basic.BasicOptionPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
的使用

没有 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
的使用

没有 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
的使用

没有 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicPasswordFieldUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicPasswordFieldUI
的使用

没有 javax.swing.plaf.basic.BasicPasswordFieldUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
的使用

没有 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSpinnerUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSpinnerUI
的使用

没有 javax.swing.plaf.basic.BasicSpinnerUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextPaneUI
的使用

没有 javax.swing.plaf.basic.BasicTextPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolTipUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolTipUI
的使用

使用 BasicToolTipUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolTipUI 的使用

javax.swing.plaf.metal 中 BasicToolTipUI 的子类
 class MetalToolTipUI
BasicToolTipUI 的 Metal L&F 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicIconFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicIconFactory
的使用

没有 javax.swing.plaf.basic.BasicIconFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
的使用

没有 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
的使用

没有 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI
的使用

使用 BasicSliderUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicSliderUI 的使用

javax.swing.plaf.metal 中 BasicSliderUI 的子类
 class MetalSliderUI
SliderUI 的 Java L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
的使用

使用 BasicSliderUI.PropertyChangeHandler 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicSliderUI.PropertyChangeHandler 的使用

javax.swing.plaf.metal 中 BasicSliderUI.PropertyChangeHandler 的子类
protected  class MetalSliderUI.MetalPropertyListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.TrackListener
的使用

使用 BasicSliderUI.TrackListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSliderUI.TrackListener 的使用

声明为 BasicSliderUI.TrackListener 的 javax.swing.plaf.basic 中的字段
protected  BasicSliderUI.TrackListener BasicSliderUI.trackListener

返回 BasicSliderUI.TrackListener 的 javax.swing.plaf.basic 中的方法
protected  BasicSliderUI.TrackListener BasicSliderUI.createTrackListener(JSlider slider)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener
的使用

使用 BasicSliderUI.ScrollListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSliderUI.ScrollListener 的使用

声明为 BasicSliderUI.ScrollListener 的 javax.swing.plaf.basic 中的字段
protected  BasicSliderUI.ScrollListener BasicSliderUI.scrollListener

返回 BasicSliderUI.ScrollListener 的 javax.swing.plaf.basic 中的方法
protected  BasicSliderUI.ScrollListener BasicSliderUI.createScrollListener(JSlider slider)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
的使用

没有 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller
的使用

没有 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextAreaUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextAreaUI
的使用

没有 javax.swing.plaf.basic.BasicTextAreaUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider
的使用

使用 BasicSplitPaneDivider 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicSplitPaneDivider 的使用

声明为 BasicSplitPaneDivider 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneDivider BasicSplitPaneUI.divider
此 JSplitPane 的分隔符的实例。

返回 BasicSplitPaneDivider 的 javax.swing.plaf.basic 中的方法
BasicSplitPaneDivider | BasicSplitPaneUI.createDefaultDivider() 创建默认的分隔符。
BasicSplitPaneDivider | BasicSplitPaneUI.getDivider() 返回顶层 Component 之间的分隔符。

javax.swing.plaf.metal 中 BasicSplitPaneDivider 的使用

返回 BasicSplitPaneDivider 的 javax.swing.plaf.metal 中的方法
 BasicSplitPaneDivider MetalSplitPaneUI.createDefaultDivider()
创建默认分隔符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
的使用

使用 BasicSplitPaneDivider.MouseHandler 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSplitPaneDivider.MouseHandler 的使用

声明为 BasicSplitPaneDivider.MouseHandler 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneDivider.MouseHandler BasicSplitPaneDivider.mouseHandler
处理发自此类和拆分窗格的鼠标事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
的使用

使用 BasicSplitPaneDivider.DragController 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSplitPaneDivider.DragController 的使用

javax.swing.plaf.basic 中 BasicSplitPaneDivider.DragController 的子类
protected  class BasicSplitPaneDivider.VerticalDragController
在面向 VERTICAL_SPLIT 的拆分窗格的拖动会话期间处理事件。

声明为 BasicSplitPaneDivider.DragController 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneDivider.DragController BasicSplitPaneDivider.dragger
处理要进行实际拖动操作的鼠标拖动消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI
的使用

使用 BasicSplitPaneUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicSplitPaneUI 的使用

声明为 BasicSplitPaneUI 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneUI BasicSplitPaneDivider.splitPaneUI
从其创建此实例的 UI。

返回 BasicSplitPaneUI 的 javax.swing.plaf.basic 中的方法
 BasicSplitPaneUI BasicSplitPaneDivider.getBasicSplitPaneUI()
返回接收者当前位于其中的 SplitPaneUI。

参数类型为 BasicSplitPaneUI 的 javax.swing.plaf.basic 中的方法
 void BasicSplitPaneDivider.setBasicSplitPaneUI(BasicSplitPaneUI newUI)
设置要使用接收者的 SplitPaneUI。

参数类型为 BasicSplitPaneUI 的 javax.swing.plaf.basic 中的构造方法
BasicSplitPaneDivider(BasicSplitPaneUI ui)
创建 BasicSplitPaneDivider 的实例。

javax.swing.plaf.metal 中 BasicSplitPaneUI 的使用

javax.swing.plaf.metal 中 BasicSplitPaneUI 的子类
 class MetalSplitPaneUI
Metal 分隔窗格。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
的使用

使用 BasicSplitPaneUI.BasicHorizontalLayoutManager 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicSplitPaneUI.BasicHorizontalLayoutManager 的使用

javax.swing.plaf.basic 中 BasicSplitPaneUI.BasicHorizontalLayoutManager 的子类
 class BasicSplitPaneUI.BasicVerticalLayoutManager
用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。

声明为 BasicSplitPaneUI.BasicHorizontalLayoutManager 的 javax.swing.plaf.basic 中的字段
protected  BasicSplitPaneUI.BasicHorizontalLayoutManager BasicSplitPaneUI.layoutManager
创建并放到拆分窗格中的 LayoutManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
的使用

没有 javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI
的使用

使用 BasicTreeUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicTreeUI 的使用

javax.swing.plaf.metal 中 BasicTreeUI 的子类
 class MetalTreeUI
TreeUI 的 metal 外观实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableUI
的使用

没有 javax.swing.plaf.basic.BasicTableUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableUI.KeyHandler
的使用

没有 javax.swing.plaf.basic.BasicTableUI.KeyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableUI.FocusHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicTableUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableHeaderUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableHeaderUI
的使用

没有 javax.swing.plaf.basic.BasicTableHeaderUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicProgressBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicProgressBarUI
的使用

使用 BasicProgressBarUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicProgressBarUI 的使用

javax.swing.plaf.metal 中 BasicProgressBarUI 的子类
 class MetalProgressBarUI
ProgressBarUI 的 Metal 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders
的使用

没有 javax.swing.plaf.basic.BasicBorders 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.ButtonBorder
的使用

使用 BasicBorders.ButtonBorder 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicBorders.ButtonBorder 的使用

javax.swing.plaf.basic 中 BasicBorders.ButtonBorder 的子类
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.ToggleButtonBorder

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicRadioButtonUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicRadioButtonUI
的使用

使用 BasicRadioButtonUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicRadioButtonUI 的使用

javax.swing.plaf.basic 中 BasicRadioButtonUI 的子类
 class BasicCheckBoxUI
BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

javax.swing.plaf.metal 中 BasicRadioButtonUI 的使用

javax.swing.plaf.metal 中 BasicRadioButtonUI 的子类
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.MarginBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.MarginBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.MarginBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.FieldBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.FieldBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.FieldBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
的使用

没有 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI
的使用

使用 BasicTabbedPaneUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicTabbedPaneUI 的使用

javax.swing.plaf.metal 中 BasicTabbedPaneUI 的子类
 class MetalTabbedPaneUI
BasicTabbedPaneUI 的 Metal 子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
的使用

使用 BasicTabbedPaneUI.TabbedPaneLayout 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicTabbedPaneUI.TabbedPaneLayout 的使用

javax.swing.plaf.metal 中 BasicTabbedPaneUI.TabbedPaneLayout 的子类
 class MetalTabbedPaneUI.TabbedPaneLayout
此内部类由于编译器故障而被标记为 "public"。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler
的使用

没有 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
的使用

没有 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextUI
的使用

使用 BasicTextUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 BasicTextUI 的使用

javax.swing.plaf.basic 中 BasicTextUI 的子类
class | BasicEditorPaneUI 为 JEditorPane 提供外观。
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。
class | BasicTextAreaUI 为纯文本编辑器提供外观。
class | BasicTextFieldUI JTextField 的外观的基础。
class | BasicTextPaneUI 为样式化文本编辑器提供外观。

javax.swing.plaf.metal 中 BasicTextUI 的使用

javax.swing.plaf.metal 中 BasicTextUI 的子类
 class MetalTextFieldUI
JTextField 外观的基础。

javax.swing.text 中 BasicTextUI 的使用

javax.swing.text 中 BasicTextUI 的子类
 class DefaultTextUI
已过时。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicGraphicsUtils 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicGraphicsUtils
的使用

没有 javax.swing.plaf.basic.BasicGraphicsUtils 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarSeparatorUI
的使用

没有 javax.swing.plaf.basic.BasicToolBarSeparatorUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextFieldUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextFieldUI
的使用

使用 BasicTextFieldUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicTextFieldUI 的使用

javax.swing.plaf.basic 中 BasicTextFieldUI 的子类
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。

javax.swing.plaf.metal 中 BasicTextFieldUI 的使用

javax.swing.plaf.metal 中 BasicTextFieldUI 的子类
 class MetalTextFieldUI
JTextField 外观的基础。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextUI.BasicCaret 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextUI.BasicCaret
的使用

没有 javax.swing.plaf.basic.BasicTextUI.BasicCaret 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicTextUI.BasicHighlighter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicTextUI.BasicHighlighter
的使用

没有 javax.swing.plaf.basic.BasicTextUI.BasicHighlighter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxEditor
的使用

使用 BasicComboBoxEditor 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicComboBoxEditor 的使用

javax.swing.plaf.basic 中 BasicComboBoxEditor 的子类
static class BasicComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的子类。

javax.swing.plaf.metal 中 BasicComboBoxEditor 的使用

javax.swing.plaf.metal 中 BasicComboBoxEditor 的子类
class | MetalComboBoxEditor Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxEditor.UIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxEditor.UIResource
的使用

没有 javax.swing.plaf.basic.BasicComboBoxEditor.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxRenderer
的使用

使用 BasicComboBoxRenderer 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicComboBoxRenderer 的使用

javax.swing.plaf.basic 中 BasicComboBoxRenderer 的子类
static class BasicComboBoxRenderer.UIResource
实现 UIResource 的 BasicComboBoxRenderer 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource
的使用

没有 javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI
的使用

使用 BasicScrollPaneUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicScrollPaneUI 的使用

javax.swing.plaf.metal 中 BasicScrollPaneUI 的子类
 class MetalScrollPaneUI
ScrollPaneUI 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.plaf.basic.ComboPopup 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.plaf.basic.ComboPopup
的使用

使用 ComboPopup 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 ComboPopup 的使用

实现 ComboPopup 的 javax.swing.plaf.basic 中的类
 class BasicComboPopup
此为 ComboPopup 接口的基本实现。

声明为 ComboPopup 的 javax.swing.plaf.basic 中的字段
protected  ComboPopup BasicComboBoxUI.popup

返回 ComboPopup 的 javax.swing.plaf.basic 中的方法
protected  ComboPopup BasicComboBoxUI.createPopup()
创建组合框的弹出部分。

javax.swing.plaf.metal 中 ComboPopup 的使用

实现 ComboPopup 的 javax.swing.plaf.metal 中的类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

返回 ComboPopup 的 javax.swing.plaf.metal 中的方法
protected  ComboPopup MetalComboBoxUI.createPopup()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicViewportUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicViewportUI
的使用

没有 javax.swing.plaf.basic.BasicViewportUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI
的使用

没有 javax.swing.plaf.basic.BasicListUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.FocusHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.ListDataHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.ListDataHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup
的使用

使用 BasicComboPopup 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicComboPopup 的使用

javax.swing.plaf.metal 中 BasicComboPopup 的子类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI
的使用

使用 BasicComboBoxUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicComboBoxUI 的使用

javax.swing.plaf.metal 中 BasicComboBoxUI 的子类
 class MetalComboBoxUI
JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.ItemHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.ItemHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.ItemHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
的使用

没有 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
的使用

没有 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
的使用

没有 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
的使用

没有 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
的使用

使用 BasicComboBoxUI.PropertyChangeHandler 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicComboBoxUI.PropertyChangeHandler 的使用

javax.swing.plaf.metal 中 BasicComboBoxUI.PropertyChangeHandler 的子类
 class MetalComboBoxUI.MetalPropertyChangeListener
此内部类由于编译器故障而被标记为 "public"。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
的使用

使用 BasicComboBoxUI.ComboBoxLayoutManager 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicComboBoxUI.ComboBoxLayoutManager 的使用

javax.swing.plaf.metal 中 BasicComboBoxUI.ComboBoxLayoutManager 的子类
 class MetalComboBoxUI.MetalComboBoxLayoutManager
此内部类因编译器故障而被标记为 "public"。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicArrowButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicArrowButton
的使用

使用 BasicArrowButton 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicArrowButton 的使用

javax.swing.plaf.metal 中 BasicArrowButton 的子类
 class MetalScrollButton
Metal 滚动条箭头的 JButton 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI
的使用

使用 BasicScrollBarUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicScrollBarUI 的使用

javax.swing.plaf.metal 中 BasicScrollBarUI 的子类
 class MetalScrollBarUI
ScrollBarUI 的 Metal 外观实现

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.ModelListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.ModelListener
的使用

使用 BasicScrollBarUI.ModelListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicScrollBarUI.ModelListener 的使用

声明为 BasicScrollBarUI.ModelListener 的 javax.swing.plaf.basic 中的字段
protected  BasicScrollBarUI.ModelListener BasicScrollBarUI.modelListener

返回 BasicScrollBarUI.ModelListener 的 javax.swing.plaf.basic 中的方法
protected  BasicScrollBarUI.ModelListener BasicScrollBarUI.createModelListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
的使用

使用 BasicScrollBarUI.TrackListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicScrollBarUI.TrackListener 的使用

声明为 BasicScrollBarUI.TrackListener 的 javax.swing.plaf.basic 中的字段
protected  BasicScrollBarUI.TrackListener BasicScrollBarUI.trackListener

返回 BasicScrollBarUI.TrackListener 的 javax.swing.plaf.basic 中的方法
protected  BasicScrollBarUI.TrackListener BasicScrollBarUI.createTrackListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
的使用

使用 BasicScrollBarUI.ArrowButtonListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicScrollBarUI.ArrowButtonListener 的使用

声明为 BasicScrollBarUI.ArrowButtonListener 的 javax.swing.plaf.basic 中的字段
protected  BasicScrollBarUI.ArrowButtonListener BasicScrollBarUI.buttonListener

返回 BasicScrollBarUI.ArrowButtonListener 的 javax.swing.plaf.basic 中的方法
protected  BasicScrollBarUI.ArrowButtonListener BasicScrollBarUI.createArrowButtonListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener
的使用

使用 BasicScrollBarUI.ScrollListener 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicScrollBarUI.ScrollListener 的使用

声明为 BasicScrollBarUI.ScrollListener 的 javax.swing.plaf.basic 中的字段
protected  BasicScrollBarUI.ScrollListener BasicScrollBarUI.scrollListener

返回 BasicScrollBarUI.ScrollListener 的 javax.swing.plaf.basic 中的方法
protected  BasicScrollBarUI.ScrollListener BasicScrollBarUI.createScrollListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicSeparatorUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicSeparatorUI
的使用

使用 BasicSeparatorUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicSeparatorUI 的使用

javax.swing.plaf.basic 中 BasicSeparatorUI 的子类
class | BasicPopupMenuSeparatorUI PopupMenuSeparatorUI 的基本 L&F 实现。
class | BasicToolBarSeparatorUI ToolBarSeparatorUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 BasicSeparatorUI 的使用

javax.swing.plaf.metal 中 BasicSeparatorUI 的子类
class | MetalPopupMenuSeparatorUI PopupMenuSeparatorUI 的 Metal L&F 实现。
class | MetalSeparatorUI SeparatorUI 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicPopupMenuUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicPopupMenuUI
的使用

没有 javax.swing.plaf.basic.BasicPopupMenuUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuUI
的使用

使用 BasicMenuUI 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicMenuUI 的使用

声明为 BasicMenuUI 的 javax.swing.plaf.basic 中的字段
 BasicMenuUI BasicMenuUI.ChangeHandler.ui

参数类型为 BasicMenuUI 的 javax.swing.plaf.basic 中的构造方法
BasicMenuUI.ChangeHandler(JMenu m, BasicMenuUI ui)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
的使用

没有 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuItemUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuItemUI
的使用

使用 BasicMenuItemUI 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicMenuItemUI 的使用

javax.swing.plaf.basic 中 BasicMenuItemUI 的子类
class | BasicCheckBoxMenuItemUI BasicCheckboxMenuItem 实现
class | BasicMenuUI MenuUI 的默认 L&F 实现。
class | BasicRadioButtonMenuItemUI BasicRadioButtonMenuItem 实现

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
的使用

没有 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI
的使用

使用 BasicToolBarUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolBarUI 的使用

javax.swing.plaf.metal 中 BasicToolBarUI 的子类
 class MetalToolBarUI
ToolBarUI 的 Metal 外观实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.FrameListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.FrameListener
的使用

没有 javax.swing.plaf.basic.BasicToolBarUI.FrameListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
的使用

使用 BasicToolBarUI.ToolBarContListener 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolBarUI.ToolBarContListener 的使用

javax.swing.plaf.metal 中 BasicToolBarUI.ToolBarContListener 的子类
protected  class MetalToolBarUI.MetalContainerListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
的使用

没有 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.DefaultMenuLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.DefaultMenuLayout
的使用

没有 javax.swing.plaf.basic.DefaultMenuLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
的使用

使用 BasicToolBarUI.PropertyListener 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolBarUI.PropertyListener 的使用

javax.swing.plaf.metal 中 BasicToolBarUI.PropertyListener 的子类
protected  class MetalToolBarUI.MetalRolloverListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener
的使用

使用 BasicToolBarUI.DockingListener 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicToolBarUI.DockingListener 的使用

javax.swing.plaf.metal 中 BasicToolBarUI.DockingListener 的子类
protected  class MetalToolBarUI.MetalDockingListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow
的使用

使用 BasicToolBarUI.DragWindow 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BasicToolBarUI.DragWindow 的使用

声明为 BasicToolBarUI.DragWindow 的 javax.swing.plaf.basic 中的字段
protected  BasicToolBarUI.DragWindow BasicToolBarUI.dragWindow

返回 BasicToolBarUI.DragWindow 的 javax.swing.plaf.basic 中的方法
protected  BasicToolBarUI.DragWindow BasicToolBarUI.createDragWindow(JToolBar toolbar)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicMenuBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicMenuBarUI
的使用

使用 BasicMenuBarUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicMenuBarUI 的使用

javax.swing.plaf.metal 中 BasicMenuBarUI 的子类
 class MetalMenuBarUI
MenuBarUI 的 Metal 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicToggleButtonUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicToggleButtonUI
的使用

使用 BasicToggleButtonUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicToggleButtonUI 的使用

javax.swing.plaf.basic 中 BasicToggleButtonUI 的子类
class | BasicCheckBoxUI BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicRadioButtonUI BasicRadioButtonUI 的 RadioButtonUI 实现

javax.swing.plaf.metal 中 BasicToggleButtonUI 的使用

javax.swing.plaf.metal 中 BasicToggleButtonUI 的子类
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalToggleButtonUI MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicButtonListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicButtonListener
的使用

使用 BasicButtonListener 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicButtonListener 的使用

返回 BasicButtonListener 的 javax.swing.plaf.basic 中的方法
protected  BasicButtonListener BasicButtonUI.createButtonListener(AbstractButton b)

javax.swing.plaf.metal 中 BasicButtonListener 的使用

返回 BasicButtonListener 的 javax.swing.plaf.metal 中的方法
protected  BasicButtonListener MetalButtonUI.createButtonListener(AbstractButton b)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicButtonUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicButtonUI
的使用

使用 BasicButtonUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicButtonUI 的使用

javax.swing.plaf.basic 中 BasicButtonUI 的子类
class | BasicCheckBoxUI BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicRadioButtonUI BasicRadioButtonUI 的 RadioButtonUI 实现
class | BasicToggleButtonUI BasicToggleButton 实现

javax.swing.plaf.metal 中 BasicButtonUI 的使用

javax.swing.plaf.metal 中 BasicButtonUI 的子类
class | MetalButtonUI MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalToggleButtonUI MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicHTML 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicHTML
的使用

没有 javax.swing.plaf.basic.BasicHTML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicLabelUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicLabelUI
的使用

使用 BasicLabelUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 BasicLabelUI 的使用

声明为 BasicLabelUI 的 javax.swing.plaf.basic 中的字段
protected static BasicLabelUI BasicLabelUI.labelUI
默认 BasicLabelUI 实例。

javax.swing.plaf.metal 中 BasicLabelUI 的使用

javax.swing.plaf.metal 中 BasicLabelUI 的子类
 class MetalLabelUI
LabelUI 的 Windows L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicRootPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicRootPaneUI
的使用

使用 BasicRootPaneUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 BasicRootPaneUI 的使用

javax.swing.plaf.metal 中 BasicRootPaneUI 的子类
 class MetalRootPaneUI
提供 RootPaneUI 的 metal 外观实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicPanelUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicPanelUI
的使用

没有 javax.swing.plaf.basic.BasicPanelUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.basic.BasicLookAndFeel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.basic.BasicLookAndFeel
的使用

使用 BasicLookAndFeel 的软件包
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.metal 中 BasicLookAndFeel 的使用

javax.swing.plaf.metal 中 BasicLookAndFeel 的子类
 class MetalLookAndFeel
Java 外观，也称为 Metal。

javax.swing.plaf.synth 中 BasicLookAndFeel 的使用

javax.swing.plaf.synth 中 BasicLookAndFeel 的子类
 class SynthLookAndFeel
SynthLookAndFeel 提供创建定制外观的基础。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DefaultMetalTheme (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 DefaultMetalTheme

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalTheme
        继承者  javax.swing.plaf.metal.DefaultMetalTheme
直接已知子类：
OceanTheme
public class DefaultMetalTheme
extends MetalTheme

提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。有关更改默认主题的详细信息，请参阅 MetalLookAndFeel.setCurrentTheme(javax.swing.plaf.metal.MetalTheme)。

DefaultMetalTheme 返回的所有颜色都是完全不透明的。

字体样式

DefaultMetalTheme 对许多控件使用黑体。要使所有控件（内部窗体标题栏和客户端已装饰窗体标题栏除外）使用无格式字体，可以执行以下操作之一：
  • 将系统属性 swing.boldMetal 设置为 false。例如 java -Dswing.boldMetal=false MyApp。
  • 将默认属性 swing.boldMetal 设置为 Boolean.FALSE。例如：UIManager.put("swing.boldMetal", Boolean.FALSE);
默认属性 swing.boldMetal（如果已设置）优先于同名的系统属性。设置此默认属性后，需要重新安装 MetalLookAndFeel，并更新所有以前创建的窗口小部件的 UI。否则，结果是不确定的。以下代码说明了如何进行此操作：
   // turn off bold fonts
   UIManager.put("swing.boldMetal", Boolean.FALSE);

   // re-install the Metal Look and Feel
   UIManager.setLookAndFeel(new MetalLookAndFeel());

   // Update the ComponentUIs for all Components. This
   // needs to be invoked for all windows.
   SwingUtilities.updateComponentTreeUI(rootComponent);

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
MetalLookAndFeel, MetalLookAndFeel.setCurrentTheme(javax.swing.plaf.metal.MetalTheme)

构造方法摘要
DefaultMetalTheme()
创建并返回 DefaultMetalTheme 的一个实例。
方法摘要
FontUIResource | getControlTextFont() 返回控件文本字体。
FontUIResource | getMenuTextFont() 返回菜单文本字体。
String | getName() 返回此主题的名称。
protected ColorUIResource | getPrimary1() 返回 primary 1 颜色。
protected ColorUIResource | getPrimary2() 返回 primary 2 颜色。
protected ColorUIResource | getPrimary3() 返回 primary 3 颜色。
protected ColorUIResource | getSecondary1() 返回 secondary 1 颜色。
protected ColorUIResource | getSecondary2() 返回 secondary 2 颜色。
protected ColorUIResource | getSecondary3() 返回 secondary 3 颜色。
FontUIResource | getSubTextFont() 返回子文本字体。
FontUIResource | getSystemTextFont() 返回系统文本字体。
FontUIResource | getUserTextFont() 返回用户文本字体。
FontUIResource | getWindowTitleFont() 返回窗口标题字体。
从类 javax.swing.plaf.metal.MetalTheme 继承的方法
addCustomEntriesToTable, getAcceleratorForeground, getAcceleratorSelectedForeground, getBlack, getControl, getControlDarkShadow, getControlDisabled, getControlHighlight, getControlInfo, getControlShadow, getControlTextColor, getDesktopColor, getFocusColor, getHighlightedTextColor, getInactiveControlTextColor, getInactiveSystemTextColor, getMenuBackground, getMenuDisabledForeground, getMenuForeground, getMenuSelectedBackground, getMenuSelectedForeground, getPrimaryControl, getPrimaryControlDarkShadow, getPrimaryControlHighlight, getPrimaryControlInfo, getPrimaryControlShadow, getSeparatorBackground, getSeparatorForeground, getSystemTextColor, getTextHighlightColor, getUserTextColor, getWhite, getWindowBackground, getWindowTitleBackground, getWindowTitleForeground, getWindowTitleInactiveBackground, getWindowTitleInactiveForeground
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultMetalTheme

public DefaultMetalTheme()
创建并返回 DefaultMetalTheme 的一个实例。

方法详细信息

getName

public String getName()
返回此主题的名称。此方法返回 "Steel"。

指定者：
类 MetalTheme 中的 getName
返回：
此主题的名称

getPrimary1

protected ColorUIResource getPrimary1()
返回 primary 1 颜色。此方法返回 rgb 值分别为 102、102 和 153 的颜色。

指定者：
类 MetalTheme 中的 getPrimary1
返回：
primary 1 颜色

getPrimary2

protected ColorUIResource getPrimary2()
返回 primary 2 颜色。此方法返回 rgb 值分别为 153、153、204 的颜色。

指定者：
类 MetalTheme 中的 getPrimary2
返回：
primary 2 颜色

getPrimary3

protected ColorUIResource getPrimary3()
返回 primary 3 颜色。此方法返回 rgb 值分别为 204、204、255 的颜色。

指定者：
类 MetalTheme 中的 getPrimary3
返回：
primary 3 颜色

getSecondary1

protected ColorUIResource getSecondary1()
返回 secondary 1 颜色。此方法返回 rgb 值分别为 102、102 和 102 的颜色。

指定者：
类 MetalTheme 中的 getSecondary1
返回：
secondary 1 颜色

getSecondary2

protected ColorUIResource getSecondary2()
返回 secondary 2 颜色。此方法返回 rgb 值分别为 153、153 和 153 的颜色。

指定者：
类 MetalTheme 中的 getSecondary2
返回：
secondary 2 颜色

getSecondary3

protected ColorUIResource getSecondary3()
返回 secondary 3 颜色。此方法返回 rgb 值分别为 204、204 和 204 的颜色。

指定者：
类 MetalTheme 中的 getSecondary3
返回：
secondary 3 颜色

getControlTextFont

public FontUIResource getControlTextFont()
返回控件文本字体。此方法返回 Dialog、12pt。如果如字体样式中所述启用了无格式字体，则字体样式为无格式的。否则，字体样式为黑体。

指定者：
类 MetalTheme 中的 getControlTextFont
返回：
控件文本字体

getSystemTextFont

public FontUIResource getSystemTextFont()
返回系统文本字体。此方法返回 Dialog、12pt、无格式。

指定者：
类 MetalTheme 中的 getSystemTextFont
返回：
系统文本字体

getUserTextFont

public FontUIResource getUserTextFont()
返回用户文本字体。此方法返回 Dialog、12pt、无格式。

指定者：
类 MetalTheme 中的 getUserTextFont
返回：
用户文本字体

getMenuTextFont

public FontUIResource getMenuTextFont()
返回菜单文本字体。此方法返回 Dialog、12pt。如果如字体样式中所述启用了无格式字体，则字体样式为无格式的。否则，字体样式为黑体。

指定者：
类 MetalTheme 中的 getMenuTextFont
返回：
菜单文本字体

getWindowTitleFont

public FontUIResource getWindowTitleFont()
返回窗口标题字体。此方法返回 Dialog、12pt、黑体。

指定者：
类 MetalTheme 中的 getWindowTitleFont
返回：
窗口标题字体

getSubTextFont

public FontUIResource getSubTextFont()
返回子文本字体。此方法返回 Dialog、10pt、无格式。

指定者：
类 MetalTheme 中的 getSubTextFont
返回：
子文本字体
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MetalBorders (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalBorders

public class MetalBorders
extends Object

可以提供适用于 metal L & F 的 Border 的工厂对象。

嵌套类摘要
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TableHeaderBorder Table Header 的边框
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder
构造方法摘要
MetalBorders()
方法摘要
static Border | getButtonBorder() 返回一个用于 JButton 的 border 实例
static Border | getDesktopIconBorder() 返回一个用于 Desktop Icon 的 border 实例
static Border | getTextBorder() 返回一个用于文本组件的 border 实例
static Border | getTextFieldBorder() 返回一个用于 JTextField 的 border 实例
static Border | getToggleButtonBorder() 返回一个用于 JToggleButton 的 border 实例
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders

public MetalBorders()
方法详细信息

getButtonBorder

public static Border getButtonBorder()
返回一个用于 JButton 的 border 实例

从以下版本开始：
1.3

getTextBorder

public static Border getTextBorder()
返回一个用于文本组件的 border 实例

从以下版本开始：
1.3

getTextFieldBorder

public static Border getTextFieldBorder()
返回一个用于 JTextField 的 border 实例

从以下版本开始：
1.3

getToggleButtonBorder

public static Border getToggleButtonBorder()
返回一个用于 JToggleButton 的 border 实例

从以下版本开始：
1.3

getDesktopIconBorder

public static Border getDesktopIconBorder()
返回一个用于 Desktop Icon 的 border 实例

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.ButtonBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.ButtonBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.ButtonBorder
所有已实现的接口：
Serializable, Border, UIResource
直接已知子类：
MetalBorders.RolloverButtonBorder, MetalBorders.ToggleButtonBorder
正在封闭类：
MetalBorders
public static class MetalBorders.ButtonBorder
extends AbstractBorder
implements UIResource

字段摘要
protected static Insets borderInsets
构造方法摘要
MetalBorders.ButtonBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

borderInsets

protected static Insets borderInsets
构造方法详细信息

MetalBorders.ButtonBorder

public MetalBorders.ButtonBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.Flush3DBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.Flush3DBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.Flush3DBorder
所有已实现的接口：
Serializable, Border, UIResource
直接已知子类：
MetalBorders.TextFieldBorder
正在封闭类：
MetalBorders
public static class MetalBorders.Flush3DBorder
extends AbstractBorder
implements UIResource

构造方法摘要
MetalBorders.Flush3DBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders.Flush3DBorder

public MetalBorders.Flush3DBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.InternalFrameBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.InternalFrameBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.InternalFrameBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.InternalFrameBorder
extends AbstractBorder
implements UIResource

构造方法摘要
MetalBorders.InternalFrameBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders.InternalFrameBorder

public MetalBorders.InternalFrameBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.MenuBarBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.MenuBarBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.MenuBarBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.MenuBarBorder
extends AbstractBorder
implements UIResource

字段摘要
protected static Insets borderInsets
构造方法摘要
MetalBorders.MenuBarBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

borderInsets

protected static Insets borderInsets
构造方法详细信息

MetalBorders.MenuBarBorder

public MetalBorders.MenuBarBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.MenuItemBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.MenuItemBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.MenuItemBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.MenuItemBorder
extends AbstractBorder
implements UIResource

字段摘要
protected static Insets borderInsets
构造方法摘要
MetalBorders.MenuItemBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

borderInsets

protected static Insets borderInsets
构造方法详细信息

MetalBorders.MenuItemBorder

public MetalBorders.MenuItemBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.OptionDialogBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.OptionDialogBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.OptionDialogBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.OptionDialogBorder
extends AbstractBorder
implements UIResource

构造方法摘要
MetalBorders.OptionDialogBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders.OptionDialogBorder

public MetalBorders.OptionDialogBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.PaletteBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.PaletteBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.PaletteBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.PaletteBorder
extends AbstractBorder
implements UIResource

Palette 的边框。

从以下版本开始：
1.3

构造方法摘要
MetalBorders.PaletteBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders.PaletteBorder

public MetalBorders.PaletteBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.PopupMenuBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.PopupMenuBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.PopupMenuBorder
extends AbstractBorder
implements UIResource

字段摘要
protected static Insets borderInsets
构造方法摘要
MetalBorders.PopupMenuBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

borderInsets

protected static Insets borderInsets
构造方法详细信息

MetalBorders.PopupMenuBorder

public MetalBorders.PopupMenuBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.RolloverButtonBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.RolloverButtonBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.ButtonBorder
            继承者  javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.RolloverButtonBorder
extends MetalBorders.ButtonBorder

字段摘要
从类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 继承的字段
borderInsets
构造方法摘要
MetalBorders.RolloverButtonBorder()
方法摘要
 void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
此默认实现不执行绘制操作。
从类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 继承的方法
getBorderInsets, getBorderInsets
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders.RolloverButtonBorder

public MetalBorders.RolloverButtonBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 MetalBorders.ButtonBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalButtonUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalButtonUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.basic.BasicButtonUI
                继承者  javax.swing.plaf.metal.MetalButtonUI

public class MetalButtonUI
extends BasicButtonUI

MetalButtonUI 实现

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected Color | disabledTextColor
protected Color | focusColor
protected Color | selectColor
从类 javax.swing.plaf.basic.BasicButtonUI 继承的字段
defaultTextIconGap, defaultTextShiftOffset
构造方法摘要
MetalButtonUI()
方法摘要
protected BasicButtonListener | createButtonListener(AbstractButton b)
static ComponentUI | createUI(JComponent c)
protected Color | getDisabledTextColor()
protected Color | getFocusColor()
protected Color | getSelectColor()
void | installDefaults(AbstractButton b)
protected void | paintButtonPressed(Graphics g, AbstractButton b)
protected void | paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | paintText(Graphics g, JComponent c, Rectangle textRect, String text) 从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
void | uninstallDefaults(AbstractButton b)
void | update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
从类 javax.swing.plaf.basic.BasicButtonUI 继承的方法
clearTextShiftOffset, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, getPreferredSize, getPropertyPrefix, getTextShiftOffset, installKeyboardActions, installListeners, installUI, paint, paintIcon, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

focusColor

protected Color focusColor

selectColor

protected Color selectColor

disabledTextColor

protected Color disabledTextColor
构造方法详细信息

MetalButtonUI

public MetalButtonUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installDefaults

public void installDefaults(AbstractButton b)
覆盖：
类 BasicButtonUI 中的 installDefaults

uninstallDefaults

public void uninstallDefaults(AbstractButton b)
覆盖：
类 BasicButtonUI 中的 uninstallDefaults

createButtonListener

protected BasicButtonListener createButtonListener(AbstractButton b)
覆盖：
类 BasicButtonUI 中的 createButtonListener

getSelectColor

protected Color getSelectColor()

getDisabledTextColor

protected Color getDisabledTextColor()

getFocusColor

protected Color getFocusColor()

update

public void update(Graphics g,
                   JComponent c)
如果必要，绘制组件的背景，然后调用 paint。

覆盖：
类 ComponentUI 中的 update
参数：
g - 作为绘制目标的 Graphic
c - 要在其上进行绘制的 JComponent
抛出：
NullPointerException - 如果 g 或 c 为 null
从以下版本开始：
1.5
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent), ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent)

paintButtonPressed

protected void paintButtonPressed(Graphics g,
                                  AbstractButton b)
覆盖：
类 BasicButtonUI 中的 paintButtonPressed

paintFocus

protected void paintFocus(Graphics g,
                          AbstractButton b,
                          Rectangle viewRect,
                          Rectangle textRect,
                          Rectangle iconRect)
覆盖：
类 BasicButtonUI 中的 paintFocus

paintText

protected void paintText(Graphics g,
                         JComponent c,
                         Rectangle textRect,
                         String text)
从类 BasicButtonUI 复制的描述
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。改为使用带有 AbstractButton 参数的 paintText 方法。

覆盖：
类 BasicButtonUI 中的 paintText
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.ScrollPaneBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.ScrollPaneBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.ScrollPaneBorder
extends AbstractBorder
implements UIResource

构造方法摘要
MetalBorders.ScrollPaneBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders.ScrollPaneBorder

public MetalBorders.ScrollPaneBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.TableHeaderBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.TableHeaderBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
所有已实现的接口：
Serializable, Border
正在封闭类：
MetalBorders
public static class MetalBorders.TableHeaderBorder
extends AbstractBorder

Table Header 的边框

从以下版本开始：
1.3

字段摘要
protected  Insets editorBorderInsets
构造方法摘要
MetalBorders.TableHeaderBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getBorderInsets, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

editorBorderInsets

protected Insets editorBorderInsets
构造方法详细信息

MetalBorders.TableHeaderBorder

public MetalBorders.TableHeaderBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.TextFieldBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.TextFieldBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.Flush3DBorder
            继承者  javax.swing.plaf.metal.MetalBorders.TextFieldBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.TextFieldBorder
extends MetalBorders.Flush3DBorder

构造方法摘要
MetalBorders.TextFieldBorder()
方法摘要
 void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
此默认实现不执行绘制操作。
从类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 继承的方法
getBorderInsets, getBorderInsets
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders.TextFieldBorder

public MetalBorders.TextFieldBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 MetalBorders.Flush3DBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.ToggleButtonBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.ToggleButtonBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.ButtonBorder
            继承者  javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
所有已实现的接口：
Serializable, Border, UIResource
正在封闭类：
MetalBorders
public static class MetalBorders.ToggleButtonBorder
extends MetalBorders.ButtonBorder

从以下版本开始：
1.3

字段摘要
从类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 继承的字段
borderInsets
构造方法摘要
MetalBorders.ToggleButtonBorder()
方法摘要
 void paintBorder(Component c, Graphics g, int x, int y, int w, int h)
此默认实现不执行绘制操作。
从类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 继承的方法
getBorderInsets, getBorderInsets
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalBorders.ToggleButtonBorder

public MetalBorders.ToggleButtonBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 MetalBorders.ButtonBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalBorders.ToolBarBorder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalBorders.ToolBarBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.plaf.metal.MetalBorders.ToolBarBorder
所有已实现的接口：
Serializable, Border, UIResource, SwingConstants
正在封闭类：
MetalBorders
public static class MetalBorders.ToolBarBorder
extends AbstractBorder
implements UIResource, SwingConstants

字段摘要
protected  javax.swing.plaf.metal.MetalBumps bumps
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
MetalBorders.ToolBarBorder()
方法摘要
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets newInsets) 用此边框的当前 Insets 重新初始化 insets 参数。
void | paintBorder(Component c, Graphics g, int x, int y, int w, int h) 此默认实现不执行绘制操作。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle, isBorderOpaque
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

bumps

protected javax.swing.plaf.metal.MetalBumps bumps
构造方法详细信息

MetalBorders.ToolBarBorder

public MetalBorders.ToolBarBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int w,
                        int h)
从类 AbstractBorder 复制的描述
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
w - 所绘制边框的宽度
h - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
从类 AbstractBorder 复制的描述
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets newInsets)
从类 AbstractBorder 复制的描述
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
newInsets - 要重新初始化的对象
返回：
insets 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalCheckBoxIcon (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalCheckBoxIcon

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalCheckBoxIcon
所有已实现的接口：
Serializable, Icon, UIResource
public class MetalCheckBoxIcon
extends Object
implements Icon, UIResource, Serializable

OrganicCheckBoxUI 的 CheckboxIcon 实现

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
MetalCheckBoxIcon()
方法摘要
protected void | drawCheck(Component c, Graphics g, int x, int y)
protected int | getControlSize()
int | getIconHeight() 返回图标的高度。
int | getIconWidth() 返回图标的宽度。
void | paintIcon(Component c, Graphics g, int x, int y) 在指定位置上绘制图标。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalCheckBoxIcon

public MetalCheckBoxIcon()
方法详细信息

getControlSize

protected int getControlSize()

paintIcon

public void paintIcon(Component c,
                      Graphics g,
                      int x,
                      int y)
从接口 Icon 复制的描述
在指定位置上绘制图标。图标实现可以使用 Component 参数来获得对绘制有用的属性，例如前景色和背景色。

指定者：
接口 Icon 中的 paintIcon

drawCheck

protected void drawCheck(Component c,
                         Graphics g,
                         int x,
                         int y)

getIconWidth

public int getIconWidth()
从接口 Icon 复制的描述
返回图标的宽度。

指定者：
接口 Icon 中的 getIconWidth
返回：
一个指定图标的固定宽度的 int 值。

getIconHeight

public int getIconHeight()
从接口 Icon 复制的描述
返回图标的高度。

指定者：
接口 Icon 中的 getIconHeight
返回：
一个指定图标的固定高度的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalCheckBoxUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalCheckBoxUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.basic.BasicButtonUI
                继承者  javax.swing.plaf.basic.BasicToggleButtonUI
                    继承者  javax.swing.plaf.basic.BasicRadioButtonUI
                        继承者  javax.swing.plaf.metal.MetalRadioButtonUI
                            继承者  javax.swing.plaf.metal.MetalCheckBoxUI

public class MetalCheckBoxUI
extends MetalRadioButtonUI

MetalCheckboxUI 的 CheckboxUI 实现

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.plaf.metal.MetalRadioButtonUI 继承的字段
disabledTextColor, focusColor, selectColor
从类 javax.swing.plaf.basic.BasicRadioButtonUI 继承的字段
icon
从类 javax.swing.plaf.basic.BasicButtonUI 继承的字段
defaultTextIconGap, defaultTextShiftOffset
构造方法摘要
MetalCheckBoxUI()
方法摘要
static ComponentUI | createUI(JComponent b)
String | getPropertyPrefix()
void | installDefaults(AbstractButton b)
protected void | uninstallDefaults(AbstractButton b)
从类 javax.swing.plaf.metal.MetalRadioButtonUI 继承的方法
getDisabledTextColor, getFocusColor, getSelectColor, paint, paintFocus
从类 javax.swing.plaf.basic.BasicRadioButtonUI 继承的方法
getDefaultIcon, getPreferredSize
从类 javax.swing.plaf.basic.BasicToggleButtonUI 继承的方法
getTextShiftOffset, paintIcon
从类 javax.swing.plaf.basic.BasicButtonUI 继承的方法
clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalCheckBoxUI

public MetalCheckBoxUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent b)

getPropertyPrefix

public String getPropertyPrefix()
覆盖：
类 BasicRadioButtonUI 中的 getPropertyPrefix

installDefaults

public void installDefaults(AbstractButton b)
覆盖：
类 MetalRadioButtonUI 中的 installDefaults

uninstallDefaults

protected void uninstallDefaults(AbstractButton b)
覆盖：
类 MetalRadioButtonUI 中的 uninstallDefaults
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalComboBoxButton (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalComboBoxButton

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JButton
                        继承者  javax.swing.plaf.metal.MetalComboBoxButton
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
public class MetalComboBoxButton
extends JButton

协助 MetalComboBoxUI 的 JButton 子类

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
MetalComboBoxButton

嵌套类摘要
从类 javax.swing.JButton 继承的嵌套类/接口
JButton.AccessibleJButton
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected JComboBox | comboBox
protected Icon | comboIcon
protected boolean | iconOnly
protected JList | listBox
protected CellRendererPane | rendererPane
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)
方法摘要
JComboBox | getComboBox()
Icon | getComboIcon()
Dimension | getMinimumSize() 如果已将最小大小设置为一个非 null 值，则返回该值。
boolean | isFocusTraversable() 返回此 Component 是否可以成为焦点所有者。
boolean | isIconOnly()
void | paintComponent(Graphics g) 如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。
void | setComboBox(JComboBox cb)
void | setComboIcon(Icon i)
void | setEnabled(boolean enabled) 启用（或禁用）按钮。
void | setIconOnly(boolean isIconOnly)
从类 javax.swing.JButton 继承的方法
getAccessibleContext, getUIClassID, isDefaultButton, isDefaultCapable, paramString, removeNotify, setDefaultCapable, updateUI
从类 javax.swing.AbstractButton 继承的方法
actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

comboBox

protected JComboBox comboBox

listBox

protected JList listBox

rendererPane

protected CellRendererPane rendererPane

comboIcon

protected Icon comboIcon

iconOnly

protected boolean iconOnly
构造方法详细信息

MetalComboBoxButton

public MetalComboBoxButton(JComboBox cb,
                           Icon i,
                           CellRendererPane pane,
                           JList list)

MetalComboBoxButton

public MetalComboBoxButton(JComboBox cb,
                           Icon i,
                           boolean onlyIcon,
                           CellRendererPane pane,
                           JList list)
方法详细信息

getComboBox

public final JComboBox getComboBox()

setComboBox

public final void setComboBox(JComboBox cb)

getComboIcon

public final Icon getComboIcon()

setComboIcon

public final void setComboIcon(Icon i)

isIconOnly

public final boolean isIconOnly()

setIconOnly

public final void setIconOnly(boolean isIconOnly)

isFocusTraversable

public boolean isFocusTraversable()
从类 Component 复制的描述
返回此 Component 是否可以成为焦点所有者。

覆盖：
类 Component 中的 isFocusTraversable
返回：
如果此 Component 是可以获得焦点的，则返回 true；否则返回 false
另请参见：
Component.setFocusable(boolean)

setEnabled

public void setEnabled(boolean enabled)
从类 AbstractButton 复制的描述
启用（或禁用）按钮。

覆盖：
类 AbstractButton 中的 setEnabled
参数：
enabled - true 表示启用按钮，否则为 false
另请参见：
Component.isEnabled(), Component.isLightweight()

paintComponent

public void paintComponent(Graphics g)
从类 JComponent 复制的描述
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。向该委托传递 Graphics 对象的副本，以保护其余的 paint 代码免遭不可取消的更改（例如 Graphics.translate）。

如果在子类中重写此方法，则不应该对传入的 Graphics 进行永久更改。例如，不应更改剪贴区的 Rectangle 或修改转换。如果需要进行这些操作，您会发现根据传入的 Graphics 创建一个新 Graphics 并进行操作更加方便。另外，如果不调用超类的实现，则必须遵守不透明属性，也就是说，如果此组件是不透明的，则必须以透明的颜色完全填充背景。如果不遵守不透明属性，则很可能看到可视的人为内容。

传入的 Graphics 对象可能安装了恒等转换以外的转换。在这种情况下，如果多次应用其他转换，则可能得到不可预料的结果。

覆盖：
类 JComponent 中的 paintComponent
参数：
g - 要保护的 Graphics 对象
另请参见：
JComponent.paint(java.awt.Graphics), ComponentUI

getMinimumSize

public Dimension getMinimumSize()
从类 JComponent 复制的描述
如果已将最小大小设置为一个非 null 值，则返回该值。如果 UI 委托的 getMinimumSize 方法返回一个非 null 值，则返回该值；否则服从组件的布局管理器。

覆盖：
类 JComponent 中的 getMinimumSize
返回：
minimumSize 属性的值
另请参见：
JComponent.setMinimumSize(java.awt.Dimension), ComponentUI
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalComboBoxEditor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalComboBoxEditor

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxEditor
        继承者  javax.swing.plaf.metal.MetalComboBoxEditor
所有已实现的接口：
FocusListener, EventListener, ComboBoxEditor
直接已知子类：
MetalComboBoxEditor.UIResource
public class MetalComboBoxEditor
extends BasicComboBoxEditor

Metal 可编辑组合框的默认编辑器

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
static class MetalComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的一个子类。
字段摘要
protected static Insets editorBorderInsets
默认编辑器边框 Insets。
从类 javax.swing.plaf.basic.BasicComboBoxEditor 继承的字段
editor
构造方法摘要
MetalComboBoxEditor()
方法摘要
从类 javax.swing.plaf.basic.BasicComboBoxEditor 继承的方法
addActionListener, createEditorComponent, focusGained, focusLost, getEditorComponent, getItem, removeActionListener, selectAll, setItem
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

editorBorderInsets

protected static Insets editorBorderInsets
默认编辑器边框 Insets。可以不使用此字段。

构造方法详细信息

MetalComboBoxEditor

public MetalComboBoxEditor()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalComboBoxEditor.UIResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalComboBoxEditor.UIResource

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxEditor
        继承者  javax.swing.plaf.metal.MetalComboBoxEditor
            继承者  javax.swing.plaf.metal.MetalComboBoxEditor.UIResource
所有已实现的接口：
FocusListener, EventListener, ComboBoxEditor, UIResource
正在封闭类：
MetalComboBoxEditor
public static class MetalComboBoxEditor.UIResource
extends MetalComboBoxEditor
implements UIResource

实现 UIResource 的 BasicComboBoxEditor 的一个子类。BasicComboBoxEditor 不直接实现 UIResource，因此应用程序可以很安全地使用 BasicListCellRenderer 子类重写 cellRenderer 属性。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.metal.MetalComboBoxEditor 继承的嵌套类/接口
MetalComboBoxEditor.UIResource
字段摘要
从类 javax.swing.plaf.metal.MetalComboBoxEditor 继承的字段
editorBorderInsets
从类 javax.swing.plaf.basic.BasicComboBoxEditor 继承的字段
editor
构造方法摘要
MetalComboBoxEditor.UIResource()
方法摘要
从类 javax.swing.plaf.basic.BasicComboBoxEditor 继承的方法
addActionListener, createEditorComponent, focusGained, focusLost, getEditorComponent, getItem, removeActionListener, selectAll, setItem
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalComboBoxEditor.UIResource

public MetalComboBoxEditor.UIResource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalComboBoxIcon (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalComboBoxIcon

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalComboBoxIcon
所有已实现的接口：
Serializable, Icon
public class MetalComboBoxIcon
extends Object
implements Icon, Serializable

此实用工具类绘制指示 MetalComboBox 的水平条

另请参见：
MetalComboBoxUI

构造方法摘要
MetalComboBoxIcon()
方法摘要
int | getIconHeight() 创建一个满足该接口的 stub。
int | getIconWidth() 创建一个满足该接口的 stub。
void | paintIcon(Component c, Graphics g, int x, int y) 绘制 MetalComboBox 的水平条
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalComboBoxIcon

public MetalComboBoxIcon()
方法详细信息

paintIcon

public void paintIcon(Component c,
                      Graphics g,
                      int x,
                      int y)
绘制 MetalComboBox 的水平条

指定者：
接口 Icon 中的 paintIcon

getIconWidth

public int getIconWidth()
创建一个满足该接口的 stub。

指定者：
接口 Icon 中的 getIconWidth
返回：
一个指定图标的固定宽度的 int 值。

getIconHeight

public int getIconHeight()
创建一个满足该接口的 stub。

指定者：
接口 Icon 中的 getIconHeight
返回：
一个指定图标的固定高度的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalComboBoxUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalComboBoxUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ComboBoxUI
            继承者  javax.swing.plaf.basic.BasicComboBoxUI
                继承者  javax.swing.plaf.metal.MetalComboBoxUI

public class MetalComboBoxUI
extends BasicComboBoxUI

JComboBox 的 Metal UI

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
MetalComboBoxEditor, MetalComboBoxButton

嵌套类摘要
class | MetalComboBoxUI.MetalComboBoxLayoutManager 此内部类因编译器故障而被标记为 "public"。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
class | MetalComboBoxUI.MetalPropertyChangeListener 此内部类由于编译器故障而被标记为 "public"。
从类 javax.swing.plaf.basic.BasicComboBoxUI 继承的嵌套类/接口
BasicComboBoxUI.ComboBoxLayoutManager, BasicComboBoxUI.FocusHandler, BasicComboBoxUI.ItemHandler, BasicComboBoxUI.KeyHandler, BasicComboBoxUI.ListDataHandler, BasicComboBoxUI.PropertyChangeHandler
字段摘要
从类 javax.swing.plaf.basic.BasicComboBoxUI 继承的字段
arrowButton, cachedMinimumSize, comboBox, currentValuePane, editor, focusListener, hasFocus, isMinimumSizeDirty, itemListener, keyListener, listBox, listDataListener, popup, popupKeyListener, popupMouseListener, popupMouseMotionListener, propertyChangeListener
构造方法摘要
MetalComboBoxUI()
方法摘要
void | configureEditor() 此受保护方法是特定于实现的，应该为私有，不要调用或重写。
protected JButton | createArrowButton() 创建一个按钮，将使用它来控制显示或隐藏组合框的弹出部分。
protected ComboBoxEditor | createEditor() 创建将在可编辑的组合框中使用的默认编辑器。
protected LayoutManager | createLayoutManager() 创建用于管理构成组合框的组件的布局管理器。
protected ComboPopup | createPopup() 创建组合框的弹出部分。
PropertyChangeListener | createPropertyChangeListener() 创建将添加到组合框的 PropertyChangeListener。
static ComponentUI | createUI(JComponent c)
protected void | editablePropertyChanged(PropertyChangeEvent e) 已过时。 从 Java 2 platform v1.4 开始。
int | getBaseline(JComponent c, int width, int height) 返回基线。
Dimension | getMinimumSize(JComponent c) 最小大小为显示区域加上 insets 再加上按钮的大小。
void | layoutComboBox(Container parent, MetalComboBoxUI.MetalComboBoxLayoutManager manager)
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项。
void | paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项的背景。
protected void | removeListeners() 已过时。 从 Java 2 platform v1.4 开始。
void | unconfigureEditor() 此受保护方法是特定于实现的，应该为私有。
从类 javax.swing.plaf.basic.BasicComboBoxUI 继承的方法
addEditor, configureArrowButton, createFocusListener, createItemListener, createKeyListener, createListDataListener, createRenderer, getAccessibleChild, getAccessibleChildrenCount, getBaselineResizeBehavior, getDefaultSize, getDisplaySize, getInsets, getMaximumSize, getPreferredSize, installComponents, installDefaults, installKeyboardActions, installListeners, installUI, isFocusTraversable, isNavigationKey, isPopupVisible, rectangleForCurrentValue, removeEditor, selectNextPossibleValue, selectPreviousPossibleValue, setPopupVisible, toggleOpenClose, unconfigureArrowButton, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalComboBoxUI

public MetalComboBoxUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 BasicComboBoxUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintCurrentValue

public void paintCurrentValue(Graphics g,
                              Rectangle bounds,
                              boolean hasFocus)
如有必要，绘制当前所选项。

覆盖：
类 BasicComboBoxUI 中的 paintCurrentValue
参数：
g - 作为绘制目标的 Graphic
bounds - 当前值的绘制范围
hasFocus - JComboBox 是否拥有焦点
抛出：
NullPointerException - 如果所有参数均为 null。
从以下版本开始：
1.5

paintCurrentValueBackground

public void paintCurrentValueBackground(Graphics g,
                                        Rectangle bounds,
                                        boolean hasFocus)
如有必要，绘制当前所选项的背景。

覆盖：
类 BasicComboBoxUI 中的 paintCurrentValueBackground
参数：
g - 作为绘制目标的 Graphic
bounds - 背景的绘制范围
hasFocus - JComboBox 是否拥有焦点
抛出：
NullPointerException - 如果所有参数均为 null。
从以下版本开始：
1.5

getBaseline

public int getBaseline(JComponent c,
                       int width,
                       int height)
返回基线。

覆盖：
类 BasicComboBoxUI 中的 getBaseline
参数：
c - 为其请求基线的 JComponent
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果没有合理的基线，则返回 < 0 的值
抛出：
NullPointerException - 如果 c 为 null
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

createEditor

protected ComboBoxEditor createEditor()
从类 BasicComboBoxUI 复制的描述
创建将在可编辑的组合框中使用的默认编辑器。仅当没有利用 setEditor 显式设置编辑器时才使用默认编辑器。

覆盖：
类 BasicComboBoxUI 中的 createEditor
返回：
用于组合框的 ComboBoxEditor
另请参见：
JComboBox.setEditor(javax.swing.ComboBoxEditor)

createPopup

protected ComboPopup createPopup()
从类 BasicComboBoxUI 复制的描述
创建组合框的弹出部分。

覆盖：
类 BasicComboBoxUI 中的 createPopup
返回：
ComboPopup 的实例
另请参见：
ComboPopup

createArrowButton

protected JButton createArrowButton()
从类 BasicComboBoxUI 复制的描述
创建一个按钮，将使用它来控制显示或隐藏组合框的弹出部分。

覆盖：
类 BasicComboBoxUI 中的 createArrowButton
返回：
表示弹出控件的按钮

createPropertyChangeListener

public PropertyChangeListener createPropertyChangeListener()
从类 BasicComboBoxUI 复制的描述
创建将添加到组合框的 PropertyChangeListener。如果此方法返回 null，则不会将其添加到组合框。

覆盖：
类 BasicComboBoxUI 中的 createPropertyChangeListener
返回：
PropertyChangeListener 的实例或 null

editablePropertyChanged

@Deprecated
protected void editablePropertyChanged(PropertyChangeEvent e)
已过时。 从 Java 2 platform v1.4 开始。

从 Java 2 platform v1.4 开始，此方法不再使用。不要调用或重写此方法。此方法的所有功能都在 MetalPropertyChangeListener 中。

createLayoutManager

protected LayoutManager createLayoutManager()
从类 BasicComboBoxUI 复制的描述
创建用于管理构成组合框的组件的布局管理器。

覆盖：
类 BasicComboBoxUI 中的 createLayoutManager
返回：
布局管理器的实例

layoutComboBox

public void layoutComboBox(Container parent,
                           MetalComboBoxUI.MetalComboBoxLayoutManager manager)

removeListeners

@Deprecated
protected void removeListeners()
已过时。 从 Java 2 platform v1.4 开始。

从 Java 2 platform v1.4 开始，此方法不再使用。

configureEditor

public void configureEditor()
从类 BasicComboBoxUI 复制的描述
此受保护方法是特定于实现的，应该为私有，不要调用或重写。

覆盖：
类 BasicComboBoxUI 中的 configureEditor
另请参见：
BasicComboBoxUI.addEditor()

unconfigureEditor

public void unconfigureEditor()
从类 BasicComboBoxUI 复制的描述
此受保护方法是特定于实现的，应该为私有。不要调用或重写。

覆盖：
类 BasicComboBoxUI 中的 unconfigureEditor
另请参见：
BasicComboBoxUI.addEditor()

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 BasicComboBoxUI 复制的描述
最小大小为显示区域加上 insets 再加上按钮的大小。

覆盖：
类 BasicComboBoxUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalComboBoxUI.MetalComboPopup (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalComboBoxUI.MetalComboPopup

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPopupMenu
                    继承者  javax.swing.plaf.basic.BasicComboPopup
                        继承者  javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, MenuElement, ComboPopup
正在封闭类：
MetalComboBoxUI
已过时。 从 Java 2 platform v1.4 开始。

@Deprecated
public class MetalComboBoxUI.MetalComboPopup
extends BasicComboPopup

此内部类由于编译器故障而被标记为 "public"。此类应该视为“受保护”内部类。仅在 MetalComboBoxUI 的子类中实例化此类。 此类现在已经废弃，不再做任何操作，包括它只是为了向后 API 兼容。不要调用或重写。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicComboPopup 继承的嵌套类/接口
BasicComboPopup.InvocationKeyHandler, BasicComboPopup.InvocationMouseHandler, BasicComboPopup.InvocationMouseMotionHandler, BasicComboPopup.ItemHandler, BasicComboPopup.ListDataHandler, BasicComboPopup.ListMouseHandler, BasicComboPopup.ListMouseMotionHandler, BasicComboPopup.ListSelectionHandler, BasicComboPopup.PropertyChangeHandler
从类 javax.swing.JPopupMenu 继承的嵌套类/接口
JPopupMenu.AccessibleJPopupMenu, JPopupMenu.Separator
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.plaf.basic.BasicComboPopup 继承的字段
autoscrollTimer, comboBox, hasEntered, isAutoScrolling, itemListener, keyListener, list, listDataListener, listMouseListener, listMouseMotionListener, listSelectionListener, mouseListener, mouseMotionListener, propertyChangeListener, SCROLL_DOWN, SCROLL_UP, scrollDirection, scroller, valueIsAdjusting
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
MetalComboBoxUI.MetalComboPopup(JComboBox cBox)
已过时。
方法摘要
 void delegateFocus(MouseEvent e)
已过时。 此为一种实用程序方法，用于帮助事件处理程序计算出在调出弹出控件时将焦点发送到的位置。
从类 javax.swing.plaf.basic.BasicComboPopup 继承的方法
autoScrollDown, autoScrollUp, computePopupBounds, configureList, configurePopup, configureScroller, convertMouseEvent, createItemListener, createKeyListener, createList, createListDataListener, createListMouseListener, createListMouseMotionListener, createListSelectionListener, createMouseListener, createMouseMotionListener, createPropertyChangeListener, createScroller, firePopupMenuCanceled, firePopupMenuWillBecomeInvisible, firePopupMenuWillBecomeVisible, getAccessibleContext, getKeyListener, getList, getMouseListener, getMouseMotionListener, getPopupHeightForRowCount, hide, installComboBoxListeners, installComboBoxModelListeners, installKeyboardActions, installListListeners, isFocusTraversable, show, startAutoScrolling, stopAutoScrolling, togglePopup, uninstallComboBoxModelListeners, uninstallingUI, uninstallKeyboardActions, updateListBoxSelectionForEvent
从类 javax.swing.JPopupMenu 继承的方法
add, add, add, addMenuKeyListener, addPopupMenuListener, addSeparator, createActionChangeListener, createActionComponent, getComponent, getComponentAtIndex, getComponentIndex, getDefaultLightWeightPopupEnabled, getInvoker, getLabel, getMargin, getMenuKeyListeners, getPopupMenuListeners, getSelectionModel, getSubElements, getUI, getUIClassID, insert, insert, isBorderPainted, isLightWeightPopupEnabled, isPopupTrigger, isVisible, menuSelectionChanged, pack, paintBorder, paramString, processFocusEvent, processKeyEvent, processKeyEvent, processMouseEvent, remove, removeMenuKeyListener, removePopupMenuListener, setBorderPainted, setDefaultLightWeightPopupEnabled, setInvoker, setLabel, setLightWeightPopupEnabled, setLocation, setPopupSize, setPopupSize, setSelected, setSelectionModel, setUI, setVisible, show, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setName, setSize, setSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 javax.swing.plaf.basic.ComboPopup 继承的方法
isVisible

构造方法详细信息

MetalComboBoxUI.MetalComboPopup

public MetalComboBoxUI.MetalComboPopup(JComboBox cBox)
已过时。
方法详细信息

delegateFocus

public void delegateFocus(MouseEvent e)
已过时。
从类 BasicComboPopup 复制的描述
此为一种实用程序方法，用于帮助事件处理程序计算出在调出弹出控件时将焦点发送到的位置。标准实现将焦点委托给编辑器（如果组合框可编辑）或者 JComboBox（如果组合框不可编辑）。

覆盖：
类 BasicComboPopup 中的 delegateFocus
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalComboBoxUI.MetalComboBoxLayoutManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalComboBoxUI.MetalComboBoxLayoutManager

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
        继承者  javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
所有已实现的接口：
LayoutManager
正在封闭类：
MetalComboBoxUI
public class MetalComboBoxUI.MetalComboBoxLayoutManager
extends BasicComboBoxUI.ComboBoxLayoutManager

此内部类因编译器故障而被标记为 "public"。此类应该视为“受保护”内部类。仅在 MetalComboBoxUI 的子类中实例化此类。

构造方法摘要
MetalComboBoxUI.MetalComboBoxLayoutManager()
方法摘要
void | layoutContainer(Container parent) 布置指定容器。
void | superLayout(Container parent)
从类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 继承的方法
addLayoutComponent, minimumLayoutSize, preferredLayoutSize, removeLayoutComponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalComboBoxUI.MetalComboBoxLayoutManager

public MetalComboBoxUI.MetalComboBoxLayoutManager()
方法详细信息

layoutContainer

public void layoutContainer(Container parent)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
覆盖：
类 BasicComboBoxUI.ComboBoxLayoutManager 中的 layoutContainer
参数：
parent - 要布置的容器

superLayout

public void superLayout(Container parent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalComboBoxUI.MetalPropertyChangeListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalComboBoxUI.MetalPropertyChangeListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
        继承者  javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
MetalComboBoxUI
public class MetalComboBoxUI.MetalPropertyChangeListener
extends BasicComboBoxUI.PropertyChangeHandler

此内部类由于编译器故障而被标记为 "public"。此类应该视为“受保护”内部类。仅在 MetalComboBoxUI 的子类中实例化此类。

构造方法摘要
MetalComboBoxUI.MetalPropertyChangeListener()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalComboBoxUI.MetalPropertyChangeListener

public MetalComboBoxUI.MetalPropertyChangeListener()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
覆盖：
类 BasicComboBoxUI.PropertyChangeHandler 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalDesktopIconUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalDesktopIconUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.DesktopIconUI
            继承者  javax.swing.plaf.basic.BasicDesktopIconUI
                继承者  javax.swing.plaf.metal.MetalDesktopIconUI

public class MetalDesktopIconUI
extends BasicDesktopIconUI

Metal 桌面图标。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicDesktopIconUI 继承的嵌套类/接口
BasicDesktopIconUI.MouseInputHandler
字段摘要
从类 javax.swing.plaf.basic.BasicDesktopIconUI 继承的字段
desktopIcon, frame, iconPane
构造方法摘要
MetalDesktopIconUI()
方法摘要
static ComponentUI | createUI(JComponent c)
Dimension | getMaximumSize(JComponent c) 不能调整桌面图标的大小。
Dimension | getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected void | installComponents()
protected void | installDefaults()
protected void | installListeners()
protected void | uninstallComponents()
protected void | uninstallListeners()
从类 javax.swing.plaf.basic.BasicDesktopIconUI 继承的方法
createMouseInputListener, deiconize, getInsets, installUI, uninstallDefaults, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalDesktopIconUI

public MetalDesktopIconUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installDefaults

protected void installDefaults()
覆盖：
类 BasicDesktopIconUI 中的 installDefaults

installComponents

protected void installComponents()
覆盖：
类 BasicDesktopIconUI 中的 installComponents

uninstallComponents

protected void uninstallComponents()
覆盖：
类 BasicDesktopIconUI 中的 uninstallComponents

installListeners

protected void installListeners()
覆盖：
类 BasicDesktopIconUI 中的 installListeners

uninstallListeners

protected void uninstallListeners()
覆盖：
类 BasicDesktopIconUI 中的 uninstallListeners

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 BasicDesktopIconUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的最小大小。如果返回 null，则最小大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现调用 getPreferredSize 并返回该值。

覆盖：
类 BasicDesktopIconUI 中的 getMinimumSize
参数：
c - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
从类 BasicDesktopIconUI 复制的描述
不能调整桌面图标的大小。因此，应该始终返回桌面图标的最小大小。

覆盖：
类 BasicDesktopIconUI 中的 getMaximumSize
参数：
c - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
一个 Dimension 对象或 null
另请参见：
BasicDesktopIconUI.getMinimumSize(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalFileChooserUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalFileChooserUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.FileChooserUI
            继承者  javax.swing.plaf.basic.BasicFileChooserUI
                继承者  javax.swing.plaf.metal.MetalFileChooserUI

public class MetalFileChooserUI
extends BasicFileChooserUI

FileChooser 的 Metal L&F 实现。

嵌套类摘要
protected class | MetalFileChooserUI.DirectoryComboBoxAction 当 DirectoryComboBox 已更改所选项时调用。
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FileRenderer
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
protected class | MetalFileChooserUI.SingleClickListener
从类 javax.swing.plaf.basic.BasicFileChooserUI 继承的嵌套类/接口
BasicFileChooserUI.AcceptAllFileFilter, BasicFileChooserUI.ApproveSelectionAction, BasicFileChooserUI.BasicFileView, BasicFileChooserUI.CancelSelectionAction, BasicFileChooserUI.ChangeToParentDirectoryAction, BasicFileChooserUI.DoubleClickListener, BasicFileChooserUI.GoHomeAction, BasicFileChooserUI.NewFolderAction, BasicFileChooserUI.SelectionListener, BasicFileChooserUI.UpdateAction
字段摘要
从类 javax.swing.plaf.basic.BasicFileChooserUI 继承的字段
cancelButtonMnemonic, cancelButtonText, cancelButtonToolTipText, computerIcon, detailsViewIcon, directoryIcon, directoryOpenButtonMnemonic, directoryOpenButtonText, directoryOpenButtonToolTipText, fileIcon, floppyDriveIcon, hardDriveIcon, helpButtonMnemonic, helpButtonText, helpButtonToolTipText, homeFolderIcon, listViewIcon, newFolderIcon, openButtonMnemonic, openButtonText, openButtonToolTipText, saveButtonMnemonic, saveButtonText, saveButtonToolTipText, updateButtonMnemonic, updateButtonText, updateButtonToolTipText, upFolderIcon
构造方法摘要
MetalFileChooserUI(JFileChooser filechooser)
方法摘要
protected void | addControlButtons()
protected ActionMap | createActionMap()
protected JPanel | createDetailsView(JFileChooser fc)
protected MetalFileChooserUI.DirectoryComboBoxModel | createDirectoryComboBoxModel(JFileChooser fc)
protected javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxRenderer | createDirectoryComboBoxRenderer(JFileChooser fc)
protected MetalFileChooserUI.FilterComboBoxModel | createFilterComboBoxModel()
protected MetalFileChooserUI.FilterComboBoxRenderer | createFilterComboBoxRenderer()
protected JPanel | createList(JFileChooser fc)
ListSelectionListener | createListSelectionListener(JFileChooser fc) 创建一个用于文件和目录列表的选择侦听器。
PropertyChangeListener | createPropertyChangeListener(JFileChooser fc)
static ComponentUI | createUI(JComponent c)
void | ensureFileIsVisible(JFileChooser fc, File f)
protected ActionMap | getActionMap()
protected JButton | getApproveButton(JFileChooser fc)
protected JPanel | getBottomPanel()
protected JPanel | getButtonPanel()
String | getDirectoryName()
String | getFileName()
Dimension | getMaximumSize(JComponent c) 返回 JFileChooser 的最大大小。
Dimension | getMinimumSize(JComponent c) 返回 JFileChooser 的最小大小。
Dimension | getPreferredSize(JComponent c) 返回指定 JFileChooser 的首选大小。
void | installComponents(JFileChooser fc)
protected void | installListeners(JFileChooser fc)
protected void | installStrings(JFileChooser fc)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected void | removeControlButtons()
void | rescanCurrentDirectory(JFileChooser fc)
void | setDirectoryName(String dirname)
protected void | setDirectorySelected(boolean directorySelected) 记忆某个目录在 UI 中当前是否被选择的属性。
void | setFileName(String filename)
void | uninstallComponents(JFileChooser fc)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
void | valueChanged(ListSelectionEvent e)
从类 javax.swing.plaf.basic.BasicFileChooserUI 继承的方法
clearIconCache, createDoubleClickListener, createModel, getAcceptAllFileFilter, getAccessoryPanel, getApproveButtonMnemonic, getApproveButtonText, getApproveButtonToolTipText, getApproveSelectionAction, getCancelSelectionAction, getChangeToParentDirectoryAction, getDialogTitle, getDirectory, getFileChooser, getFileView, getGoHomeAction, getModel, getNewFolderAction, getUpdateAction, installDefaults, installIcons, isDirectorySelected, setDirectory, uninstallDefaults, uninstallIcons, uninstallListeners, uninstallStrings
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalFileChooserUI

public MetalFileChooserUI(JFileChooser filechooser)
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 BasicFileChooserUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallComponents

public void uninstallComponents(JFileChooser fc)
覆盖：
类 BasicFileChooserUI 中的 uninstallComponents

installComponents

public void installComponents(JFileChooser fc)
覆盖：
类 BasicFileChooserUI 中的 installComponents

getButtonPanel

protected JPanel getButtonPanel()

getBottomPanel

protected JPanel getBottomPanel()

installStrings

protected void installStrings(JFileChooser fc)
覆盖：
类 BasicFileChooserUI 中的 installStrings

installListeners

protected void installListeners(JFileChooser fc)
覆盖：
类 BasicFileChooserUI 中的 installListeners

getActionMap

protected ActionMap getActionMap()

createActionMap

protected ActionMap createActionMap()

createList

protected JPanel createList(JFileChooser fc)

createDetailsView

protected JPanel createDetailsView(JFileChooser fc)

createListSelectionListener

public ListSelectionListener createListSelectionListener(JFileChooser fc)
创建一个用于文件和目录列表的选择侦听器。

覆盖：
类 BasicFileChooserUI 中的 createListSelectionListener
参数：
fc - 一个 JFileChooser
返回：
一个 ListSelectionListener

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 BasicFileChooserUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

getPreferredSize

public Dimension getPreferredSize(JComponent c)
返回指定 JFileChooser 的首选大小。首选大小在高度和宽度上至少应该与文件选择器的布局管理器推荐的首选大小一样大。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
c - 一个 JFileChooser
返回：
指定文件选择器的首选宽度和高度的 Dimension
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent c)
返回 JFileChooser 的最小大小。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
c - 一个 JFileChooser
返回：
指定文件选择器的最小宽度和高度的 Dimension
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent c)
返回 JFileChooser 的最大大小。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
c - 一个 JFileChooser
返回：
指定文件选择器的最大宽度和高度的 Dimension
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

createPropertyChangeListener

public PropertyChangeListener createPropertyChangeListener(JFileChooser fc)
覆盖：
类 BasicFileChooserUI 中的 createPropertyChangeListener

removeControlButtons

protected void removeControlButtons()

addControlButtons

protected void addControlButtons()

ensureFileIsVisible

public void ensureFileIsVisible(JFileChooser fc,
                                File f)
覆盖：
类 BasicFileChooserUI 中的 ensureFileIsVisible

rescanCurrentDirectory

public void rescanCurrentDirectory(JFileChooser fc)
覆盖：
类 BasicFileChooserUI 中的 rescanCurrentDirectory

getFileName

public String getFileName()
覆盖：
类 BasicFileChooserUI 中的 getFileName

setFileName

public void setFileName(String filename)
覆盖：
类 BasicFileChooserUI 中的 setFileName

setDirectorySelected

protected void setDirectorySelected(boolean directorySelected)
记忆某个目录在 UI 中当前是否被选择的属性。此方法通常由 UI 在某一选择事件上调用。

覆盖：
类 BasicFileChooserUI 中的 setDirectorySelected
参数：
directorySelected - 如果目录当前处于被选择状态。
从以下版本开始：
1.4

getDirectoryName

public String getDirectoryName()
覆盖：
类 BasicFileChooserUI 中的 getDirectoryName

setDirectoryName

public void setDirectoryName(String dirname)
覆盖：
类 BasicFileChooserUI 中的 setDirectoryName

createDirectoryComboBoxRenderer

protected javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxRenderer createDirectoryComboBoxRenderer(JFileChooser fc)

createDirectoryComboBoxModel

protected MetalFileChooserUI.DirectoryComboBoxModel createDirectoryComboBoxModel(JFileChooser fc)

createFilterComboBoxRenderer

protected MetalFileChooserUI.FilterComboBoxRenderer createFilterComboBoxRenderer()

createFilterComboBoxModel

protected MetalFileChooserUI.FilterComboBoxModel createFilterComboBoxModel()

valueChanged

public void valueChanged(ListSelectionEvent e)

getApproveButton

protected JButton getApproveButton(JFileChooser fc)
覆盖：
类 BasicFileChooserUI 中的 getApproveButton
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalFileChooserUI.DirectoryComboBoxAction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalFileChooserUI.DirectoryComboBoxAction

java.lang.Object
    继承者  javax.swing.AbstractAction
        继承者  javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
正在封闭类：
MetalFileChooserUI
protected class MetalFileChooserUI.DirectoryComboBoxAction
extends AbstractAction

当 DirectoryComboBox 已更改所选项时调用。

字段摘要
从类 javax.swing.AbstractAction 继承的字段
changeSupport, enabled
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
protected MetalFileChooserUI.DirectoryComboBoxAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 javax.swing.AbstractAction 继承的方法
addPropertyChangeListener, clone, firePropertyChange, getKeys, getPropertyChangeListeners, getValue, isEnabled, putValue, removePropertyChangeListener, setEnabled
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalFileChooserUI.DirectoryComboBoxAction

protected MetalFileChooserUI.DirectoryComboBoxAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalFileChooserUI.DirectoryComboBoxModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalFileChooserUI.DirectoryComboBoxModel

java.lang.Object
    继承者  javax.swing.AbstractListModel
        继承者  javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel
所有已实现的接口：
Serializable, ComboBoxModel, ListModel
正在封闭类：
MetalFileChooserUI
protected class MetalFileChooserUI.DirectoryComboBoxModel
extends AbstractListModel
implements ComboBoxModel

字体选择组合框的数据模型。

字段摘要
从类 javax.swing.AbstractListModel 继承的字段
listenerList
构造方法摘要
MetalFileChooserUI.DirectoryComboBoxModel()
方法摘要
int | getDepth(int i)
Object | getElementAt(int index) 返回指定索引处的值。
Object | getSelectedItem() 返回选择的项
int | getSize() 返回列表的长度。
void | setSelectedItem(Object selectedDirectory) 设置选择项。
从类 javax.swing.AbstractListModel 继承的方法
addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.ListModel 继承的方法
addListDataListener, removeListDataListener

构造方法详细信息

MetalFileChooserUI.DirectoryComboBoxModel

public MetalFileChooserUI.DirectoryComboBoxModel()
方法详细信息

getDepth

public int getDepth(int i)

setSelectedItem

public void setSelectedItem(Object selectedDirectory)
从接口 ComboBoxModel 复制的描述
设置选择项。此方法的实现应该通知所有已注册 ListDataListener 内容已更改。

指定者：
接口 ComboBoxModel 中的 setSelectedItem
参数：
selectedDirectory - 要选择的列表对象，为 null 表示清除选择

getSelectedItem

public Object getSelectedItem()
从接口 ComboBoxModel 复制的描述
返回选择的项

指定者：
接口 ComboBoxModel 中的 getSelectedItem
返回：
选择的项，如果没有选择的项，则返回 null

getSize

public int getSize()
从接口 ListModel 复制的描述
返回列表的长度。

指定者：
接口 ListModel 中的 getSize
返回：
列表的长度

getElementAt

public Object getElementAt(int index)
从接口 ListModel 复制的描述
返回指定索引处的值。

指定者：
接口 ListModel 中的 getElementAt
参数：
index - 请求的索引
返回：
index 处的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalFileChooserUI.FileRenderer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalFileChooserUI.FileRenderer

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.DefaultListCellRenderer
                        继承者  javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer, SwingConstants
正在封闭类：
MetalFileChooserUI
protected class MetalFileChooserUI.FileRenderer
extends DefaultListCellRenderer

嵌套类摘要
从类 javax.swing.DefaultListCellRenderer 继承的嵌套类/接口
DefaultListCellRenderer.UIResource
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.DefaultListCellRenderer 继承的字段
noFocusBorder
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
protected MetalFileChooserUI.FileRenderer()
方法摘要
从类 javax.swing.DefaultListCellRenderer 继承的方法
firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getListCellRendererComponent, invalidate, isOpaque, repaint, repaint, repaint, revalidate, validate
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MetalFileChooserUI.FileRenderer

protected MetalFileChooserUI.FileRenderer()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalFileChooserUI.FilterComboBoxModel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalFileChooserUI.FilterComboBoxModel

java.lang.Object
    继承者  javax.swing.AbstractListModel
        继承者  javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel
所有已实现的接口：
PropertyChangeListener, Serializable, EventListener, ComboBoxModel, ListModel
正在封闭类：
MetalFileChooserUI
protected class MetalFileChooserUI.FilterComboBoxModel
extends AbstractListModel
implements ComboBoxModel, PropertyChangeListener

字体选择组合框的数据模型。

字段摘要
protected  FileFilter[] filters
从类 javax.swing.AbstractListModel 继承的字段
listenerList
构造方法摘要
protected MetalFileChooserUI.FilterComboBoxModel()
方法摘要
Object | getElementAt(int index) 返回指定索引处的值。
Object | getSelectedItem() 返回选择的项
int | getSize() 返回列表的长度。
void | propertyChange(PropertyChangeEvent e) 在绑定属性发生更改时调用此方法。
void | setSelectedItem(Object filter) 设置选择项。
从类 javax.swing.AbstractListModel 继承的方法
addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.ListModel 继承的方法
addListDataListener, removeListDataListener

字段详细信息

filters

protected FileFilter[] filters
构造方法详细信息

MetalFileChooserUI.FilterComboBoxModel

protected MetalFileChooserUI.FilterComboBoxModel()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。

setSelectedItem

public void setSelectedItem(Object filter)
从接口 ComboBoxModel 复制的描述
设置选择项。此方法的实现应该通知所有已注册 ListDataListener 内容已更改。

指定者：
接口 ComboBoxModel 中的 setSelectedItem
参数：
filter - 要选择的列表对象，为 null 表示清除选择

getSelectedItem

public Object getSelectedItem()
从接口 ComboBoxModel 复制的描述
返回选择的项

指定者：
接口 ComboBoxModel 中的 getSelectedItem
返回：
选择的项，如果没有选择的项，则返回 null

getSize

public int getSize()
从接口 ListModel 复制的描述
返回列表的长度。

指定者：
接口 ListModel 中的 getSize
返回：
列表的长度

getElementAt

public Object getElementAt(int index)
从接口 ListModel 复制的描述
返回指定索引处的值。

指定者：
接口 ListModel 中的 getElementAt
参数：
index - 请求的索引
返回：
index 处的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalFileChooserUI.FilterComboBoxRenderer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalFileChooserUI.FilterComboBoxRenderer

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.DefaultListCellRenderer
                        继承者  javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer, SwingConstants
正在封闭类：
MetalFileChooserUI
public class MetalFileChooserUI.FilterComboBoxRenderer
extends DefaultListCellRenderer

呈现不同的类型大小和风格。

嵌套类摘要
从类 javax.swing.DefaultListCellRenderer 继承的嵌套类/接口
DefaultListCellRenderer.UIResource
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.DefaultListCellRenderer 继承的字段
noFocusBorder
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
MetalFileChooserUI.FilterComboBoxRenderer()
方法摘要
 Component getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
返回已配置用于显示指定值的组件。
从类 javax.swing.DefaultListCellRenderer 继承的方法
firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, invalidate, isOpaque, repaint, repaint, repaint, revalidate, validate
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MetalFileChooserUI.FilterComboBoxRenderer

public MetalFileChooserUI.FilterComboBoxRenderer()
方法详细信息

getListCellRendererComponent

public Component getListCellRendererComponent(JList list,
                                              Object value,
                                              int index,
                                              boolean isSelected,
                                              boolean cellHasFocus)
从接口 ListCellRenderer 复制的描述
返回已配置用于显示指定值的组件。然后调用该组件的 paint 方法来“呈现”单元格。如果由于列表单元格没有固定的大小而有必要计算该列表的尺寸，则调用此方法来生成一个可在其上调用 getPreferredSize 的组件。

指定者：
接口 ListCellRenderer 中的 getListCellRendererComponent
覆盖：
类 DefaultListCellRenderer 中的 getListCellRendererComponent
参数：
list - 正在绘制的 JList。
value - 由 list.getModel().getElementAt(index) 返回的值。
index - 单元格索引。
isSelected - 如果选择了指定的单元格，则为 true。
cellHasFocus - 如果指定的单元格拥有焦点，则为 true。
返回：
其 paint() 方法将呈现指定值的组件。
另请参见：
JList, ListSelectionModel, ListModel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalFileChooserUI.SingleClickListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalFileChooserUI.SingleClickListener

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
正在封闭类：
MetalFileChooserUI
protected class MetalFileChooserUI.SingleClickListener
extends MouseAdapter

构造方法摘要
MetalFileChooserUI.SingleClickListener(JList list)
方法摘要
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mousePressed, mouseReleased, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalFileChooserUI.SingleClickListener

public MetalFileChooserUI.SingleClickListener(JList list)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalIconFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalIconFactory

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalIconFactory
所有已实现的接口：
Serializable
public class MetalIconFactory
extends Object
implements Serializable

为 JavaTM 外观 (Metal) 提供 Icon 的工厂对象。可以通过默认机制，在 Metal 中扩展使用这些图标。虽然其他外观常常使用 GIF 作为图标，但用代码创建图标便于将它们转换成其他主题。

此类中的每个方法都会返回一个 Icon 或 null，其中 null 意味着没有默认图标。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
static class | MetalIconFactory.FileIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.FolderIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.PaletteCloseIcon 定义一个用于 Palette 关闭的图标
static class | MetalIconFactory.TreeControlIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeFolderIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeLeafIcon
字段摘要
static boolean | DARK
static boolean | LIGHT
构造方法摘要
MetalIconFactory()
方法摘要
static Icon | getCheckBoxIcon() 返回一个复选框图标。
static Icon | getCheckBoxMenuItemIcon()
static Icon | getFileChooserDetailViewIcon()
static Icon | getFileChooserHomeFolderIcon()
static Icon | getFileChooserListViewIcon()
static Icon | getFileChooserNewFolderIcon()
static Icon | getFileChooserUpFolderIcon()
static Icon | getHorizontalSliderThumbIcon()
static Icon | getInternalFrameAltMaximizeIcon(int size)
static Icon | getInternalFrameCloseIcon(int size)
static Icon | getInternalFrameDefaultMenuIcon()
static Icon | getInternalFrameMaximizeIcon(int size)
static Icon | getInternalFrameMinimizeIcon(int size)
static Icon | getMenuArrowIcon()
static Icon | getMenuItemArrowIcon()
static Icon | getMenuItemCheckIcon() 返回一个将由 JCheckBoxMenuItem 使用的图标。
static Icon | getRadioButtonIcon()
static Icon | getRadioButtonMenuItemIcon()
static Icon | getTreeComputerIcon()
static Icon | getTreeControlIcon(boolean isCollapsed)
static Icon | getTreeFloppyDriveIcon()
static Icon | getTreeFolderIcon()
static Icon | getTreeHardDriveIcon()
static Icon | getTreeLeafIcon()
static Icon | getVerticalSliderThumbIcon()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DARK

public static final boolean DARK
另请参见：
常量字段值

LIGHT

public static final boolean LIGHT
另请参见：
常量字段值
构造方法详细信息

MetalIconFactory

public MetalIconFactory()
方法详细信息

getFileChooserDetailViewIcon

public static Icon getFileChooserDetailViewIcon()

getFileChooserHomeFolderIcon

public static Icon getFileChooserHomeFolderIcon()

getFileChooserListViewIcon

public static Icon getFileChooserListViewIcon()

getFileChooserNewFolderIcon

public static Icon getFileChooserNewFolderIcon()

getFileChooserUpFolderIcon

public static Icon getFileChooserUpFolderIcon()

getInternalFrameAltMaximizeIcon

public static Icon getInternalFrameAltMaximizeIcon(int size)

getInternalFrameCloseIcon

public static Icon getInternalFrameCloseIcon(int size)

getInternalFrameDefaultMenuIcon

public static Icon getInternalFrameDefaultMenuIcon()

getInternalFrameMaximizeIcon

public static Icon getInternalFrameMaximizeIcon(int size)

getInternalFrameMinimizeIcon

public static Icon getInternalFrameMinimizeIcon(int size)

getRadioButtonIcon

public static Icon getRadioButtonIcon()

getCheckBoxIcon

public static Icon getCheckBoxIcon()
返回一个复选框图标。

从以下版本开始：
1.3

getTreeComputerIcon

public static Icon getTreeComputerIcon()

getTreeFloppyDriveIcon

public static Icon getTreeFloppyDriveIcon()

getTreeFolderIcon

public static Icon getTreeFolderIcon()

getTreeHardDriveIcon

public static Icon getTreeHardDriveIcon()

getTreeLeafIcon

public static Icon getTreeLeafIcon()

getTreeControlIcon

public static Icon getTreeControlIcon(boolean isCollapsed)

getMenuArrowIcon

public static Icon getMenuArrowIcon()

getMenuItemCheckIcon

public static Icon getMenuItemCheckIcon()
返回一个将由 JCheckBoxMenuItem 使用的图标。

返回：
用于复选框菜单项的默认图标，如果没有默认图标，则返回 null

getMenuItemArrowIcon

public static Icon getMenuItemArrowIcon()

getCheckBoxMenuItemIcon

public static Icon getCheckBoxMenuItemIcon()

getRadioButtonMenuItemIcon

public static Icon getRadioButtonMenuItemIcon()

getHorizontalSliderThumbIcon

public static Icon getHorizontalSliderThumbIcon()

getVerticalSliderThumbIcon

public static Icon getVerticalSliderThumbIcon()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalIconFactory.FileIcon16 (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalIconFactory.FileIcon16

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalIconFactory.FileIcon16
所有已实现的接口：
Serializable, Icon
直接已知子类：
MetalIconFactory.TreeLeafIcon
正在封闭类：
MetalIconFactory
public static class MetalIconFactory.FileIcon16
extends Object
implements Icon, Serializable

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
MetalIconFactory.FileIcon16()
方法摘要
int | getAdditionalHeight()
int | getIconHeight() 返回图标的高度。
int | getIconWidth() 返回图标的宽度。
int | getShift()
void | paintIcon(Component c, Graphics g, int x, int y) 在指定位置上绘制图标。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalIconFactory.FileIcon16

public MetalIconFactory.FileIcon16()
方法详细信息

paintIcon

public void paintIcon(Component c,
                      Graphics g,
                      int x,
                      int y)
从接口 Icon 复制的描述
在指定位置上绘制图标。图标实现可以使用 Component 参数来获得对绘制有用的属性，例如前景色和背景色。

指定者：
接口 Icon 中的 paintIcon

getShift

public int getShift()

getAdditionalHeight

public int getAdditionalHeight()

getIconWidth

public int getIconWidth()
从接口 Icon 复制的描述
返回图标的宽度。

指定者：
接口 Icon 中的 getIconWidth
返回：
一个指定图标的固定宽度的 int 值。

getIconHeight

public int getIconHeight()
从接口 Icon 复制的描述
返回图标的高度。

指定者：
接口 Icon 中的 getIconHeight
返回：
一个指定图标的固定高度的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalIconFactory.FolderIcon16 (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalIconFactory.FolderIcon16

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalIconFactory.FolderIcon16
所有已实现的接口：
Serializable, Icon
直接已知子类：
MetalIconFactory.TreeFolderIcon
正在封闭类：
MetalIconFactory
public static class MetalIconFactory.FolderIcon16
extends Object
implements Icon, Serializable

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
MetalIconFactory.FolderIcon16()
方法摘要
int | getAdditionalHeight()
int | getIconHeight() 返回图标的高度。
int | getIconWidth() 返回图标的宽度。
int | getShift()
void | paintIcon(Component c, Graphics g, int x, int y) 在指定位置上绘制图标。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalIconFactory.FolderIcon16

public MetalIconFactory.FolderIcon16()
方法详细信息

paintIcon

public void paintIcon(Component c,
                      Graphics g,
                      int x,
                      int y)
从接口 Icon 复制的描述
在指定位置上绘制图标。图标实现可以使用 Component 参数来获得对绘制有用的属性，例如前景色和背景色。

指定者：
接口 Icon 中的 paintIcon

getShift

public int getShift()

getAdditionalHeight

public int getAdditionalHeight()

getIconWidth

public int getIconWidth()
从接口 Icon 复制的描述
返回图标的宽度。

指定者：
接口 Icon 中的 getIconWidth
返回：
一个指定图标的固定宽度的 int 值。

getIconHeight

public int getIconHeight()
从接口 Icon 复制的描述
返回图标的高度。

指定者：
接口 Icon 中的 getIconHeight
返回：
一个指定图标的固定高度的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalIconFactory.PaletteCloseIcon (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalIconFactory.PaletteCloseIcon

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon
所有已实现的接口：
Serializable, Icon, UIResource
正在封闭类：
MetalIconFactory
public static class MetalIconFactory.PaletteCloseIcon
extends Object
implements Icon, UIResource, Serializable

定义一个用于 Palette 关闭的图标

从以下版本开始：
1.3

构造方法摘要
MetalIconFactory.PaletteCloseIcon()
方法摘要
int | getIconHeight() 返回图标的高度。
int | getIconWidth() 返回图标的宽度。
void | paintIcon(Component c, Graphics g, int x, int y) 在指定位置上绘制图标。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalIconFactory.PaletteCloseIcon

public MetalIconFactory.PaletteCloseIcon()
方法详细信息

paintIcon

public void paintIcon(Component c,
                      Graphics g,
                      int x,
                      int y)
从接口 Icon 复制的描述
在指定位置上绘制图标。图标实现可以使用 Component 参数来获得对绘制有用的属性，例如前景色和背景色。

指定者：
接口 Icon 中的 paintIcon

getIconWidth

public int getIconWidth()
从接口 Icon 复制的描述
返回图标的宽度。

指定者：
接口 Icon 中的 getIconWidth
返回：
一个指定图标的固定宽度的 int 值。

getIconHeight

public int getIconHeight()
从接口 Icon 复制的描述
返回图标的高度。

指定者：
接口 Icon 中的 getIconHeight
返回：
一个指定图标的固定高度的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalIconFactory.TreeControlIcon (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalIconFactory.TreeControlIcon

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
所有已实现的接口：
Serializable, Icon
正在封闭类：
MetalIconFactory
public static class MetalIconFactory.TreeControlIcon
extends Object
implements Icon, Serializable

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected  boolean isLight
构造方法摘要
MetalIconFactory.TreeControlIcon(boolean isCollapsed)
方法摘要
int | getIconHeight() 返回图标的高度。
int | getIconWidth() 返回图标的宽度。
void | paintIcon(Component c, Graphics g, int x, int y) 在指定位置上绘制图标。
void | paintMe(Component c, Graphics g, int x, int y)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

isLight

protected boolean isLight
构造方法详细信息

MetalIconFactory.TreeControlIcon

public MetalIconFactory.TreeControlIcon(boolean isCollapsed)
方法详细信息

paintIcon

public void paintIcon(Component c,
                      Graphics g,
                      int x,
                      int y)
从接口 Icon 复制的描述
在指定位置上绘制图标。图标实现可以使用 Component 参数来获得对绘制有用的属性，例如前景色和背景色。

指定者：
接口 Icon 中的 paintIcon

paintMe

public void paintMe(Component c,
                    Graphics g,
                    int x,
                    int y)

getIconWidth

public int getIconWidth()
从接口 Icon 复制的描述
返回图标的宽度。

指定者：
接口 Icon 中的 getIconWidth
返回：
一个指定图标的固定宽度的 int 值。

getIconHeight

public int getIconHeight()
从接口 Icon 复制的描述
返回图标的高度。

指定者：
接口 Icon 中的 getIconHeight
返回：
一个指定图标的固定高度的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalIconFactory.TreeFolderIcon (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalIconFactory.TreeFolderIcon

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalIconFactory.FolderIcon16
        继承者  javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
所有已实现的接口：
Serializable, Icon
正在封闭类：
MetalIconFactory
public static class MetalIconFactory.TreeFolderIcon
extends MetalIconFactory.FolderIcon16

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
MetalIconFactory.TreeFolderIcon()
方法摘要
int | getAdditionalHeight()
int | getShift()
从类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 继承的方法
getIconHeight, getIconWidth, paintIcon
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalIconFactory.TreeFolderIcon

public MetalIconFactory.TreeFolderIcon()
方法详细信息

getShift

public int getShift()
覆盖：
类 MetalIconFactory.FolderIcon16 中的 getShift

getAdditionalHeight

public int getAdditionalHeight()
覆盖：
类 MetalIconFactory.FolderIcon16 中的 getAdditionalHeight
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalIconFactory.TreeLeafIcon (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalIconFactory.TreeLeafIcon

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalIconFactory.FileIcon16
        继承者  javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
所有已实现的接口：
Serializable, Icon
正在封闭类：
MetalIconFactory
public static class MetalIconFactory.TreeLeafIcon
extends MetalIconFactory.FileIcon16

构造方法摘要
MetalIconFactory.TreeLeafIcon()
方法摘要
int | getAdditionalHeight()
int | getShift()
从类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 继承的方法
getIconHeight, getIconWidth, paintIcon
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalIconFactory.TreeLeafIcon

public MetalIconFactory.TreeLeafIcon()
方法详细信息

getShift

public int getShift()
覆盖：
类 MetalIconFactory.FileIcon16 中的 getShift

getAdditionalHeight

public int getAdditionalHeight()
覆盖：
类 MetalIconFactory.FileIcon16 中的 getAdditionalHeight
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalInternalFrameTitlePane (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalInternalFrameTitlePane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.plaf.basic.BasicInternalFrameTitlePane
                    继承者  javax.swing.plaf.metal.MetalInternalFrameTitlePane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable
public class MetalInternalFrameTitlePane
extends BasicInternalFrameTitlePane

管理 JLF 标题栏的类

从以下版本开始：
1.3

嵌套类摘要
从类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 继承的嵌套类/接口
BasicInternalFrameTitlePane.CloseAction, BasicInternalFrameTitlePane.IconifyAction, BasicInternalFrameTitlePane.MaximizeAction, BasicInternalFrameTitlePane.MoveAction, BasicInternalFrameTitlePane.PropertyChangeHandler, BasicInternalFrameTitlePane.RestoreAction, BasicInternalFrameTitlePane.SizeAction, BasicInternalFrameTitlePane.SystemMenuBar, BasicInternalFrameTitlePane.TitlePaneLayout
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected boolean | isPalette
protected Icon | paletteCloseIcon
protected int | paletteTitleHeight
从类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 继承的字段
CLOSE_CMD, closeAction, closeButton, closeIcon, frame, iconButton, iconIcon, ICONIFY_CMD, iconifyAction, maxButton, maxIcon, MAXIMIZE_CMD, maximizeAction, menuBar, minIcon, MOVE_CMD, moveAction, notSelectedTextColor, notSelectedTitleColor, propertyChangeListener, RESTORE_CMD, restoreAction, selectedTextColor, selectedTitleColor, SIZE_CMD, sizeAction, windowMenu
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
MetalInternalFrameTitlePane(JInternalFrame f)
方法摘要
void | addNotify() 通知此组件它现在已有了一个父组件。
protected void | addSubComponents() 重写父级的方法，避免创建一个菜单栏。
protected void | addSystemMenuItems(JMenu systemMenu) 重写父级的方法，使其不执行任何操作。
protected void | assembleSystemMenu() 重写父级的方法，使其不执行任何操作。
protected void | createButtons()
protected LayoutManager | createLayout()
protected PropertyChangeListener | createPropertyChangeListener()
protected void | installDefaults()
void | paintComponent(Graphics g) 如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。
void | paintPalette(Graphics g)
void | setPalette(boolean b)
protected void | showSystemMenu() 重写父级的方法，使其不执行任何操作。
protected void | uninstallDefaults()
从类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 继承的方法
createActions, createSystemMenu, createSystemMenuBar, enableActions, getTitle, installListeners, installTitlePane, paintTitleBackground, postClosingEvent, setButtonIcons, uninstallListeners
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getAccessibleContext, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

isPalette

protected boolean isPalette

paletteCloseIcon

protected Icon paletteCloseIcon

paletteTitleHeight

protected int paletteTitleHeight
构造方法详细信息

MetalInternalFrameTitlePane

public MetalInternalFrameTitlePane(JInternalFrame f)
方法详细信息

addNotify

public void addNotify()
从类 JComponent 复制的描述
通知此组件它现在已有了一个父组件。调用此方法时，通过 KeyboardAction 事件侦听器设置父组件链。

覆盖：
类 JComponent 中的 addNotify
另请参见：
JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

installDefaults

protected void installDefaults()
覆盖：
类 BasicInternalFrameTitlePane 中的 installDefaults

uninstallDefaults

protected void uninstallDefaults()
覆盖：
类 BasicInternalFrameTitlePane 中的 uninstallDefaults

createButtons

protected void createButtons()
覆盖：
类 BasicInternalFrameTitlePane 中的 createButtons

assembleSystemMenu

protected void assembleSystemMenu()
重写父级的方法，使其不执行任何操作。Metal 窗体没有系统菜单。

覆盖：
类 BasicInternalFrameTitlePane 中的 assembleSystemMenu

addSystemMenuItems

protected void addSystemMenuItems(JMenu systemMenu)
重写父级的方法，使其不执行任何操作。Metal 窗体没有系统菜单。

覆盖：
类 BasicInternalFrameTitlePane 中的 addSystemMenuItems

showSystemMenu

protected void showSystemMenu()
重写父级的方法，使其不执行任何操作。Metal 窗体没有系统菜单。

覆盖：
类 BasicInternalFrameTitlePane 中的 showSystemMenu

addSubComponents

protected void addSubComponents()
重写父级的方法，避免创建一个菜单栏。Metal 窗体没有系统菜单。

覆盖：
类 BasicInternalFrameTitlePane 中的 addSubComponents

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
覆盖：
类 BasicInternalFrameTitlePane 中的 createPropertyChangeListener

createLayout

protected LayoutManager createLayout()
覆盖：
类 BasicInternalFrameTitlePane 中的 createLayout

paintPalette

public void paintPalette(Graphics g)

paintComponent

public void paintComponent(Graphics g)
从类 JComponent 复制的描述
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。向该委托传递 Graphics 对象的副本，以保护其余的 paint 代码免遭不可取消的更改（例如 Graphics.translate）。

如果在子类中重写此方法，则不应该对传入的 Graphics 进行永久更改。例如，不应更改剪贴区的 Rectangle 或修改转换。如果需要进行这些操作，您会发现根据传入的 Graphics 创建一个新 Graphics 并进行操作更加方便。另外，如果不调用超类的实现，则必须遵守不透明属性，也就是说，如果此组件是不透明的，则必须以透明的颜色完全填充背景。如果不遵守不透明属性，则很可能看到可视的人为内容。

传入的 Graphics 对象可能安装了恒等转换以外的转换。在这种情况下，如果多次应用其他转换，则可能得到不可预料的结果。

覆盖：
类 BasicInternalFrameTitlePane 中的 paintComponent
参数：
g - 要保护的 Graphics 对象
另请参见：
JComponent.paint(java.awt.Graphics), ComponentUI

setPalette

public void setPalette(boolean b)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalInternalFrameUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalInternalFrameUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.InternalFrameUI
            继承者  javax.swing.plaf.basic.BasicInternalFrameUI
                继承者  javax.swing.plaf.metal.MetalInternalFrameUI

public class MetalInternalFrameUI
extends BasicInternalFrameUI

JInternalFrame 的 Metal 实现。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicInternalFrameUI 继承的嵌套类/接口
BasicInternalFrameUI.BasicInternalFrameListener, BasicInternalFrameUI.BorderListener, BasicInternalFrameUI.ComponentHandler, BasicInternalFrameUI.GlassPaneDispatcher, BasicInternalFrameUI.InternalFrameLayout, BasicInternalFrameUI.InternalFramePropertyChangeListener
字段摘要
protected static String IS_PALETTE
从类 javax.swing.plaf.basic.BasicInternalFrameUI 继承的字段
borderListener, componentListener, eastPane, frame, glassPaneDispatcher, internalFrameLayout, northPane, openMenuKey, propertyChangeListener, southPane, titlePane, westPane
构造方法摘要
MetalInternalFrameUI(JInternalFrame b)
方法摘要
protected MouseInputAdapter | createBorderListener(JInternalFrame w) 返回将在 TitlePane 上安装的 MouseInputAdapter。
protected JComponent | createNorthPane(JInternalFrame w)
static ComponentUI | createUI(JComponent c)
protected void | installKeyboardActions()
protected void | installListeners()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | setPalette(boolean isPalette)
protected void | uninstallComponents()
protected void | uninstallKeyboardActions()
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.basic.BasicInternalFrameUI 继承的方法
activateFrame, closeFrame, createComponentListener, createDesktopManager, createEastPane, createGlassPaneDispatcher, createInternalFrameListener, createLayoutManager, createPropertyChangeListener, createSouthPane, createWestPane, deactivateFrame, deiconifyFrame, deinstallMouseHandlers, getDesktopManager, getEastPane, getMaximumSize, getMinimumSize, getNorthPane, getPreferredSize, getSouthPane, getWestPane, iconifyFrame, installComponents, installDefaults, installMouseHandlers, isKeyBindingActive, isKeyBindingRegistered, maximizeFrame, minimizeFrame, replacePane, setEastPane, setKeyBindingActive, setKeyBindingRegistered, setNorthPane, setSouthPane, setupMenuCloseKey, setupMenuOpenKey, setWestPane, uninstallDefaults
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_PALETTE

protected static String IS_PALETTE
构造方法详细信息

MetalInternalFrameUI

public MetalInternalFrameUI(JInternalFrame b)
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 BasicInternalFrameUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 BasicInternalFrameUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installListeners

protected void installListeners()
覆盖：
类 BasicInternalFrameUI 中的 installListeners

uninstallListeners

protected void uninstallListeners()
覆盖：
类 BasicInternalFrameUI 中的 uninstallListeners

installKeyboardActions

protected void installKeyboardActions()
覆盖：
类 BasicInternalFrameUI 中的 installKeyboardActions

uninstallKeyboardActions

protected void uninstallKeyboardActions()
覆盖：
类 BasicInternalFrameUI 中的 uninstallKeyboardActions

uninstallComponents

protected void uninstallComponents()
覆盖：
类 BasicInternalFrameUI 中的 uninstallComponents

createNorthPane

protected JComponent createNorthPane(JInternalFrame w)
覆盖：
类 BasicInternalFrameUI 中的 createNorthPane

setPalette

public void setPalette(boolean isPalette)

createBorderListener

protected MouseInputAdapter createBorderListener(JInternalFrame w)
返回将在 TitlePane 上安装的 MouseInputAdapter。

覆盖：
类 BasicInternalFrameUI 中的 createBorderListener
参数：
w - JInternalFrame
返回：
将在 TitlePane 上安装的 MouseInputAdapter
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalLabelUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalLabelUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.LabelUI
            继承者  javax.swing.plaf.basic.BasicLabelUI
                继承者  javax.swing.plaf.metal.MetalLabelUI
所有已实现的接口：
PropertyChangeListener, EventListener
public class MetalLabelUI
extends BasicLabelUI

LabelUI 的 Windows L&F 实现。此实现完全是静态的，也就是说，只有一个由所有 JLabel 对象共享的 UIView 实现。

字段摘要
protected static MetalLabelUI metalLabelUI
默认的 MetalLabelUI 实例。
从类 javax.swing.plaf.basic.BasicLabelUI 继承的字段
labelUI
构造方法摘要
MetalLabelUI()
方法摘要
static ComponentUI | createUI(JComponent c)
protected void | paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY) 只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。
从类 javax.swing.plaf.basic.BasicLabelUI 继承的方法
getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, installComponents, installDefaults, installKeyboardActions, installListeners, installUI, layoutCL, paint, paintEnabledText, propertyChange, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

metalLabelUI

protected static MetalLabelUI metalLabelUI
默认的 MetalLabelUI 实例。可以不使用此字段。要更改默认实例，使用重写 createUI 方法的子类，并替换默认表中键“LabelUI”下的类名。

构造方法详细信息

MetalLabelUI

public MetalLabelUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

paintDisabledText

protected void paintDisabledText(JLabel l,
                                 Graphics g,
                                 String s,
                                 int textX,
                                 int textY)
只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。

覆盖：
类 BasicLabelUI 中的 paintDisabledText
另请参见：
BasicLabelUI.paint(java.awt.Graphics, javax.swing.JComponent), BasicLabelUI.paintEnabledText(javax.swing.JLabel, java.awt.Graphics, java.lang.String, int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalLookAndFeel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalLookAndFeel

java.lang.Object
    继承者  javax.swing.LookAndFeel
        继承者  javax.swing.plaf.basic.BasicLookAndFeel
            继承者  javax.swing.plaf.metal.MetalLookAndFeel
所有已实现的接口：
Serializable
public class MetalLookAndFeel
extends BasicLookAndFeel

Java 外观，也称为 Metal。

每个由 MetalLookAndFeel 提供的 ComponentUI 从默认表中派生其行为。除非另行说明，否则此包中每个 ComponentUI 实现都记录它们所使用的默认值集合。除非另行说明，否则调用 installUI 时，将安装默认值并遵循 LookAndFeel 中描述的安装默认值的建议。

MetalLookAndFeel 从 MetalTheme 派生其调色板和字体。默认主题为 OceanTheme。可以使用 setCurrentTheme 方法更改主题，有关更改主题的详细信息，请参阅该方法。在 1.5 之前，默认主题为 DefaultMetalTheme。可以将系统属性 "swing.metalTheme" 设置为 "steel"，指示默认主题应该为 DefaultMetalTheme。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
MetalTheme, DefaultMetalTheme, OceanTheme

构造方法摘要
MetalLookAndFeel()
方法摘要
protected void | createDefaultTheme() 确保当前 MetalTheme 为非 null。
static ColorUIResource | getAcceleratorForeground() 返回当前主题的加速器前景颜色。
static ColorUIResource | getAcceleratorSelectedForeground() 返回当前主题的加速器选中前景颜色。
static ColorUIResource | getBlack() 返回当前主题的黑色。
static ColorUIResource | getControl() 返回当前主题的控件颜色。
static ColorUIResource | getControlDarkShadow() 返回当前主题的控件加黑阴影颜色。
static ColorUIResource | getControlDisabled() 返回当前主题的控件禁用颜色。
static ColorUIResource | getControlHighlight() 返回当前主题的控件高亮显示颜色。
static ColorUIResource | getControlInfo() 返回当前主题的控件信息颜色。
static ColorUIResource | getControlShadow() 返回当前主题的控件阴影颜色。
static ColorUIResource | getControlTextColor() 返回当前主题的控件文本颜色。
static FontUIResource | getControlTextFont() 返回当前主题的控件文本字体。
static MetalTheme | getCurrentTheme() 返回 MetalLookAndFeel 当前正在使用的主题。
UIDefaults | getDefaults() 返回外观的默认值。
String | getDescription() 返回此外观的简短描述。
static ColorUIResource | getDesktopColor() 返回当前主题的桌面颜色。
Icon | getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
static ColorUIResource | getFocusColor() 返回当前主题的焦点颜色。
static ColorUIResource | getHighlightedTextColor() 返回当前主题的加亮文本颜色。
String | getID() 此外观的标识符。
static ColorUIResource | getInactiveControlTextColor() 返回当前主题的非活动控件文本颜色。
static ColorUIResource | getInactiveSystemTextColor() 返回当前主题的非活动系统文本颜色。
LayoutStyle | getLayoutStyle() 返回一个 LayoutStyle，它实现 http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html 中指定的 Java 外观设计原则。
static ColorUIResource | getMenuBackground() 返回当前主题的菜单背景颜色。
static ColorUIResource | getMenuDisabledForeground() 返回当前主题的菜单禁用前景颜色。
static ColorUIResource | getMenuForeground() 返回当前主题的菜单前景颜色。
static ColorUIResource | getMenuSelectedBackground() 返回当前主题的菜单选中背景颜色。
static ColorUIResource | getMenuSelectedForeground() 返回当前主题的菜单选中前景颜色。
static FontUIResource | getMenuTextFont() 返回当前主题的菜单文本字体。
String | getName() 返回此外观的名称。
static ColorUIResource | getPrimaryControl() 返回当前主题的 primary 控件颜色。
static ColorUIResource | getPrimaryControlDarkShadow() 返回当前主题的 primary 控件加黑阴影颜色。
static ColorUIResource | getPrimaryControlHighlight() 返回当前主题的 primary 控件高亮显示颜色。
static ColorUIResource | getPrimaryControlInfo() 返回当前主题的 primary 控件信息颜色。
static ColorUIResource | getPrimaryControlShadow() 返回当前主题的 primary 控件阴影颜色。
static ColorUIResource | getSeparatorBackground() 返回当前主题的分隔符背景颜色。
static ColorUIResource | getSeparatorForeground() 返回当前主题的分隔符前景颜色。
static FontUIResource | getSubTextFont() 返回当前主题的子文本字体。
boolean | getSupportsWindowDecorations() 返回 true； metal 可以提供 Window 装饰。
static ColorUIResource | getSystemTextColor() 返回当前主题的系统文本颜色。
static FontUIResource | getSystemTextFont() 返回当前主题的系统文本字体。
static ColorUIResource | getTextHighlightColor() 返回当前主题的文本高亮显示颜色。
static ColorUIResource | getUserTextColor() 返回当前主题的用户文本颜色。
static FontUIResource | getUserTextFont() 返回当前主题的用户文本字体。
static ColorUIResource | getWhite() 返回当前主题的白色。
static ColorUIResource | getWindowBackground() 返回当前主题的窗口背景颜色。
static ColorUIResource | getWindowTitleBackground() 返回当前主题的窗口标题背景颜色。
static FontUIResource | getWindowTitleFont() 返回当前主题的窗口标题字体。
static ColorUIResource | getWindowTitleForeground() 返回当前主题的窗口标题前景色。
static ColorUIResource | getWindowTitleInactiveBackground() 返回当前主题的窗口标题非活动背景颜色。
static ColorUIResource | getWindowTitleInactiveForeground() 返回当前主题的窗口标题非活动前景颜色。
protected void | initClassDefaults(UIDefaults table) 用从 uiClassID 到 ui 类完全限定名的映射关系填充 table。
protected void | initComponentDefaults(UIDefaults table) 用 metal 的默认值填充 table。
protected void | initSystemColorDefaults(UIDefaults table) 用系统颜色填充 table。
boolean | isNativeLookAndFeel() 返回 false；MetalLookAndFeel 不是本机外观。
boolean | isSupportedLookAndFeel() 返回 true；可以在任意平台上运行 MetalLookAndFeel。
void | provideErrorFeedback(Component component) 在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
static void | setCurrentTheme(MetalTheme theme) 设置 MetalLookAndFeel 使用的主题。
从类 javax.swing.plaf.basic.BasicLookAndFeel 继承的方法
createAudioAction, getAudioActionMap, initialize, loadSystemColors, playSound, uninitialize
从类 javax.swing.LookAndFeel 继承的方法
getDesktopPropertyValue, installBorder, installColors, installColorsAndFont, installProperty, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, toString, uninstallBorder
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MetalLookAndFeel

public MetalLookAndFeel()
方法详细信息

getName

public String getName()
返回此外观的名称。此方法返回 "Metal"。

指定者：
类 LookAndFeel 中的 getName
返回：
此外观的名称

getID

public String getID()
此外观的标识符。此方法返回 "Metal"。

指定者：
类 LookAndFeel 中的 getID
返回：
此外观的标识符

getDescription

public String getDescription()
返回此外观的简短描述。此方法返回 "The Java(tm) Look and Feel"。

指定者：
类 LookAndFeel 中的 getDescription
返回：
外观的简短描述

isNativeLookAndFeel

public boolean isNativeLookAndFeel()
返回 false；MetalLookAndFeel 不是本机外观。

指定者：
类 LookAndFeel 中的 isNativeLookAndFeel
返回：
false

isSupportedLookAndFeel

public boolean isSupportedLookAndFeel()
返回 true；可以在任意平台上运行 MetalLookAndFeel。

指定者：
类 LookAndFeel 中的 isSupportedLookAndFeel
返回：
true
另请参见：
UIManager.setLookAndFeel(javax.swing.LookAndFeel)

getSupportsWindowDecorations

public boolean getSupportsWindowDecorations()
返回 true； metal 可以提供 Window 装饰。

覆盖：
类 LookAndFeel 中的 getSupportsWindowDecorations
返回：
true
从以下版本开始：
1.4
另请参见：
JDialog.setDefaultLookAndFeelDecorated(boolean),
JFrame.setDefaultLookAndFeelDecorated(boolean),
JRootPane.setWindowDecorationStyle(int)

initClassDefaults

protected void initClassDefaults(UIDefaults table)
用从 uiClassID 到 ui 类完全限定名的映射关系填充 table。MetalLookAndFeel 在名为 MetalXXXUI 的 javax.swing.plaf.metal 包为每个类注册一个条目。字符串 XXX 为 Swing 的一个 uiClassID。对于在 metal 中没有类的 uiClassID，使用 javax.swing.plaf.basic 中对应的类。例如，metal 没有名为 "MetalColorChooserUI" 的类，这种情况下使用 javax.swing.plaf.basic.BasicColorChooserUI。

覆盖：
类 BasicLookAndFeel 中的 initClassDefaults
参数：
table - 要添加条目的 UIDefaults 实例
抛出：
NullPointerException - 如果 table 为 null
另请参见：
BasicLookAndFeel.initClassDefaults(javax.swing.UIDefaults)

initSystemColorDefaults

protected void initSystemColorDefaults(UIDefaults table)
用系统颜色填充 table。将以下值添加到 table：
Key | Value
"desktop" | theme.getDesktopColor()
"activeCaption" | theme.getWindowTitleBackground()
"activeCaptionText" | theme.getWindowTitleForeground()
"activeCaptionBorder" | theme.getPrimaryControlShadow()
"inactiveCaption" | theme.getWindowTitleInactiveBackground()
"inactiveCaptionText" | theme.getWindowTitleInactiveForeground()
"inactiveCaptionBorder" | theme.getControlShadow()
"window" | theme.getWindowBackground()
"windowBorder" | theme.getControl()
"windowText" | theme.getUserTextColor()
"menu" | theme.getMenuBackground()
"menuText" | theme.getMenuForeground()
"text" | theme.getWindowBackground()
"textText" | theme.getUserTextColor()
"textHighlight" | theme.getTextHighlightColor()
"textHighlightText" | theme.getHighlightedTextColor()
"textInactiveText" | theme.getInactiveSystemTextColor()
"control" | theme.getControl()
"controlText" | theme.getControlTextColor()
"controlHighlight" | theme.getControlHighlight()
"controlLtHighlight" | theme.getControlHighlight()
"controlShadow" | theme.getControlShadow()
"controlDkShadow" | theme.getControlDarkShadow()
"scrollbar" | theme.getControl()
"info" | theme.getPrimaryControl()
"infoText" | theme.getPrimaryControlInfo()
值 theme 对应于当前 MetalTheme。

覆盖：
类 BasicLookAndFeel 中的 initSystemColorDefaults
参数：
table - 要添加值的 UIDefaults 对象
抛出：
NullPointerException - 如果 table 为 null
另请参见：
SystemColor, BasicLookAndFeel.getDefaults(), BasicLookAndFeel.loadSystemColors(javax.swing.UIDefaults, java.lang.String[], boolean)

initComponentDefaults

protected void initComponentDefaults(UIDefaults table)
用 metal 的默认值填充 table。

覆盖：
类 BasicLookAndFeel 中的 initComponentDefaults
参数：
table - 要添加值的 UIDefaults
抛出：
NullPointerException - 如果 table 为 null

createDefaultTheme

protected void createDefaultTheme()
确保当前 MetalTheme 为非 null。此方法是 getCurrentTheme 的覆盖方法。

另请参见：
getCurrentTheme()

getDefaults

public UIDefaults getDefaults()
返回外观的默认值。此方法按顺序调用 createDefaultTheme()、super.getDefaults() 和 getCurrentTheme().addCustomEntriesToTable(table)。

虽然此方法是公共方法，但只当外观被设置为当前外观并调用了 initialize 之后才应该由 UIManager 调用此方法。

覆盖：
类 BasicLookAndFeel 中的 getDefaults
返回：
外观默认值
另请参见：
createDefaultTheme(),
BasicLookAndFeel.getDefaults(),
MetalTheme.addCustomEntriesToTable(UIDefaults)

provideErrorFeedback

public void provideErrorFeedback(Component component)
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。默认实现蜂鸣。期待不同行为的子类应重写它，并提供其他的反馈。

覆盖：
类 LookAndFeel 中的 provideErrorFeedback
参数：
component - 其中发生错误的 Component，可以为 null，指示错误条件与某个 Component 并无直接关联
从以下版本开始：
1.4

setCurrentTheme

public static void setCurrentTheme(MetalTheme theme)
设置 MetalLookAndFeel 使用的主题。

设置主题后，需要重新安装 MetalLookAndFeel 并重新创建 ui。以下代码说明了如何完成此操作：

   MetalLookAndFeel.setCurrentTheme(theme);

   // re-install the Metal Look and Feel
   UIManager.setLookAndFeel(new MetalLookAndFeel());

   // Update the ComponentUIs for all Components. This
   // needs to be invoked for all windows.
   SwingUtilities.updateComponentTreeUI(rootComponent);
如果此操作未完成，则结果是不确定的。

参数：
theme - 要使用的主题
抛出：
NullPointerException - 如果 theme 为 null
另请参见：
getCurrentTheme()

getCurrentTheme

public static MetalTheme getCurrentTheme()
返回 MetalLookAndFeel 当前正在使用的主题。如果当前主题为 null，则创建默认主题。

返回：
当前主题
从以下版本开始：
1.5
另请参见：
setCurrentTheme(javax.swing.plaf.metal.MetalTheme)

getDisabledIcon

public Icon getDisabledIcon(JComponent component,
                            Icon icon)
返回具有禁用外观的 Icon。此方法用于在未指定图标时生成被禁用的 Icon。例如，如果创建了一个 JButton，并通过 setIcon 仅指定了一个 Icon，则会调用此方法来生成禁用的 Icon。如果将 null 作为 icon 传递，则此方法返回 null。

某些外观可能无法呈现禁用图标，在此情况下，外观将忽略此图标。

覆盖：
类 LookAndFeel 中的 getDisabledIcon
参数：
component - 将显示 Icon 的 JComponent，可以为 null
icon - 从其生成禁用图标的 Icon。
返回：
禁用图标；如果无法生成合适的 Icon，则返回 null。
从以下版本开始：
1.5

getDisabledSelectedIcon

public Icon getDisabledSelectedIcon(JComponent component,
                                    Icon icon)
返回由选定的禁用组件使用的 Icon。此方法用于为以下情况的组件生成一个 Icon：这些组件均为禁用和选中状态，但没有此状态的指定 Icon。例如，如果创建了一个 JButton，并通过 setIcon 仅指定了一个 Icon，则会调用此方法来生成被禁用和选中的 Icon。如果将 null 作为 icon 传递，则此方法返回 null。

有些外观可能不呈现禁用和选中的 Icon，在此情况下这些外观将忽略它。

覆盖：
类 LookAndFeel 中的 getDisabledSelectedIcon
参数：
component - 将显示 Icon 的 JComponent，可以为 null
icon - 从其生成禁用和选中图标的 Icon。
返回：
禁用和选中的图标，如果可以生成合适的 Icon，则返回 null。
从以下版本开始：
1.5

getControlTextFont

public static FontUIResource getControlTextFont()
返回当前主题的控件文本字体。此方法是 getCurrentTheme().getControlTextColor() 的覆盖方法。

返回：
控件文本字体
另请参见：
MetalTheme

getSystemTextFont

public static FontUIResource getSystemTextFont()
返回当前主题的系统文本字体。此方法是 getCurrentTheme().getSystemTextFont() 的覆盖方法。

返回：
系统文本字体
另请参见：
MetalTheme

getUserTextFont

public static FontUIResource getUserTextFont()
返回当前主题的用户文本字体。此方法是 getCurrentTheme().getUserTextFont() 的覆盖方法。

返回：
用户文本字体
另请参见：
MetalTheme

getMenuTextFont

public static FontUIResource getMenuTextFont()
返回当前主题的菜单文本字体。此方法是 getCurrentTheme().getMenuTextFont() 的覆盖方法。

返回：
菜单文本字体
另请参见：
MetalTheme

getWindowTitleFont

public static FontUIResource getWindowTitleFont()
返回当前主题的窗口标题字体。此方法是 getCurrentTheme().getWindowTitleFont() 的覆盖方法。

返回：
窗口标题字体
另请参见：
MetalTheme

getSubTextFont

public static FontUIResource getSubTextFont()
返回当前主题的子文本字体。此方法是 getCurrentTheme().getSubTextFont() 的覆盖方法。

返回：
子文本字体
另请参见：
MetalTheme

getDesktopColor

public static ColorUIResource getDesktopColor()
返回当前主题的桌面颜色。此方法是 getCurrentTheme().getDesktopColor() 的覆盖方法。

返回：
桌面颜色
另请参见：
MetalTheme

getFocusColor

public static ColorUIResource getFocusColor()
返回当前主题的焦点颜色。此方法是 getCurrentTheme().getFocusColor() 的覆盖方法。

返回：
焦点颜色
另请参见：
MetalTheme

getWhite

public static ColorUIResource getWhite()
返回当前主题的白色。此方法是 getCurrentTheme().getWhite() 的覆盖方法。

返回：
白色
另请参见：
MetalTheme

getBlack

public static ColorUIResource getBlack()
返回当前主题的黑色。此方法是 getCurrentTheme().getBlack() 的覆盖方法。

返回：
黑色
另请参见：
MetalTheme

getControl

public static ColorUIResource getControl()
返回当前主题的控件颜色。此方法是 getCurrentTheme().getControl() 的覆盖方法。

返回：
控件颜色
另请参见：
MetalTheme

getControlShadow

public static ColorUIResource getControlShadow()
返回当前主题的控件阴影颜色。此方法是 getCurrentTheme().getControlShadow() 的覆盖方法。

返回：
控件阴影颜色
另请参见：
MetalTheme

getControlDarkShadow

public static ColorUIResource getControlDarkShadow()
返回当前主题的控件加黑阴影颜色。此方法是 getCurrentTheme().getControlDarkShadow() 的覆盖方法。

返回：
控件加黑阴影颜色
另请参见：
MetalTheme

getControlInfo

public static ColorUIResource getControlInfo()
返回当前主题的控件信息颜色。此方法是 getCurrentTheme().getControlInfo() 的覆盖方法。

返回：
控件信息颜色
另请参见：
MetalTheme

getControlHighlight

public static ColorUIResource getControlHighlight()
返回当前主题的控件高亮显示颜色。此方法是 getCurrentTheme().getControlHighlight() 的覆盖方法。

返回：
控件高亮显示颜色
另请参见：
MetalTheme

getControlDisabled

public static ColorUIResource getControlDisabled()
返回当前主题的控件禁用颜色。此方法是 getCurrentTheme().getControlDisabled() 的覆盖方法。

返回：
控件禁用颜色
另请参见：
MetalTheme

getPrimaryControl

public static ColorUIResource getPrimaryControl()
返回当前主题的 primary 控件颜色。此方法是 getCurrentTheme().getPrimaryControl() 的覆盖方法。

返回：
primary 控件颜色
另请参见：
MetalTheme

getPrimaryControlShadow

public static ColorUIResource getPrimaryControlShadow()
返回当前主题的 primary 控件阴影颜色。此方法是 getCurrentTheme().getPrimaryControlShadow() 的覆盖方法。

返回：
primary 控件阴影颜色
另请参见：
MetalTheme

getPrimaryControlDarkShadow

public static ColorUIResource getPrimaryControlDarkShadow()
返回当前主题的 primary 控件加黑阴影颜色。此方法是 getCurrentTheme().getPrimaryControlDarkShadow() 的覆盖方法。

返回：
primary 控件加黑阴影颜色
另请参见：
MetalTheme

getPrimaryControlInfo

public static ColorUIResource getPrimaryControlInfo()
返回当前主题的 primary 控件信息颜色。此方法是 getCurrentTheme().getPrimaryControlInfo() 的覆盖方法。

返回：
primary 控件信息颜色
另请参见：
MetalTheme

getPrimaryControlHighlight

public static ColorUIResource getPrimaryControlHighlight()
返回当前主题的 primary 控件高亮显示颜色。此方法是 getCurrentTheme().getPrimaryControlHighlight() 的覆盖方法。

返回：
primary 控件高亮显示颜色
另请参见：
MetalTheme

getSystemTextColor

public static ColorUIResource getSystemTextColor()
返回当前主题的系统文本颜色。此方法是 getCurrentTheme().getSystemTextColor() 的覆盖方法。

返回：
系统文本颜色
另请参见：
MetalTheme

getControlTextColor

public static ColorUIResource getControlTextColor()
返回当前主题的控件文本颜色。此方法是 getCurrentTheme().getControlTextColor() 的覆盖方法。

返回：
控件文本颜色
另请参见：
MetalTheme

getInactiveControlTextColor

public static ColorUIResource getInactiveControlTextColor()
返回当前主题的非活动控件文本颜色。此方法是 getCurrentTheme().getInactiveControlTextColor() 的覆盖方法。

返回：
非活动控件文本颜色
另请参见：
MetalTheme

getInactiveSystemTextColor

public static ColorUIResource getInactiveSystemTextColor()
返回当前主题的非活动系统文本颜色。此方法是 getCurrentTheme().getInactiveSystemTextColor() 的覆盖方法。

返回：
非活动系统文本颜色
另请参见：
MetalTheme

getUserTextColor

public static ColorUIResource getUserTextColor()
返回当前主题的用户文本颜色。此方法是 getCurrentTheme().getUserTextColor() 的覆盖方法。

返回：
用户文本颜色
另请参见：
MetalTheme

getTextHighlightColor

public static ColorUIResource getTextHighlightColor()
返回当前主题的文本高亮显示颜色。此方法是 getCurrentTheme().getTextHighlightColor() 的覆盖方法。

返回：
文本高亮显示颜色
另请参见：
MetalTheme

getHighlightedTextColor

public static ColorUIResource getHighlightedTextColor()
返回当前主题的加亮文本颜色。此方法是 getCurrentTheme().getHighlightedTextColor() 的覆盖方法。

返回：
加亮文本颜色
另请参见：
MetalTheme

getWindowBackground

public static ColorUIResource getWindowBackground()
返回当前主题的窗口背景颜色。此方法是 getCurrentTheme().getWindowBackground() 的覆盖方法。

返回：
窗口背景颜色
另请参见：
MetalTheme

getWindowTitleBackground

public static ColorUIResource getWindowTitleBackground()
返回当前主题的窗口标题背景颜色。此方法是 getCurrentTheme().getWindowTitleBackground() 的覆盖方法。

返回：
窗口标题背景颜色
另请参见：
MetalTheme

getWindowTitleForeground

public static ColorUIResource getWindowTitleForeground()
返回当前主题的窗口标题前景色。此方法是 getCurrentTheme().getWindowTitleForeground() 的覆盖方法。

返回：
窗口标题前景色
另请参见：
MetalTheme

getWindowTitleInactiveBackground

public static ColorUIResource getWindowTitleInactiveBackground()
返回当前主题的窗口标题非活动背景颜色。此方法是 getCurrentTheme().getWindowTitleInactiveBackground() 的覆盖方法。

返回：
窗口标题非活动背景颜色
另请参见：
MetalTheme

getWindowTitleInactiveForeground

public static ColorUIResource getWindowTitleInactiveForeground()
返回当前主题的窗口标题非活动前景颜色。此方法是 getCurrentTheme().getWindowTitleInactiveForeground() 的覆盖方法。

返回：
窗口标题非活动前景颜色
另请参见：
MetalTheme

getMenuBackground

public static ColorUIResource getMenuBackground()
返回当前主题的菜单背景颜色。此方法是 getCurrentTheme().getMenuBackground() 的覆盖方法。

返回：
菜单背景颜色
另请参见：
MetalTheme

getMenuForeground

public static ColorUIResource getMenuForeground()
返回当前主题的菜单前景颜色。此方法是 getCurrentTheme().getMenuForeground() 的覆盖方法。

返回：
菜单前景颜色
另请参见：
MetalTheme

getMenuSelectedBackground

public static ColorUIResource getMenuSelectedBackground()
返回当前主题的菜单选中背景颜色。此方法是 getCurrentTheme().getMenuSelectedBackground() 的覆盖方法。

返回：
菜单选中背景颜色
另请参见：
MetalTheme

getMenuSelectedForeground

public static ColorUIResource getMenuSelectedForeground()
返回当前主题的菜单选中前景颜色。此方法是 getCurrentTheme().getMenuSelectedForeground() 的覆盖方法。

返回：
菜单选中前景颜色
另请参见：
MetalTheme

getMenuDisabledForeground

public static ColorUIResource getMenuDisabledForeground()
返回当前主题的菜单禁用前景颜色。此方法是 getCurrentTheme().getMenuDisabledForeground() 的覆盖方法。

返回：
菜单禁用前景颜色
另请参见：
MetalTheme

getSeparatorBackground

public static ColorUIResource getSeparatorBackground()
返回当前主题的分隔符背景颜色。此方法是 getCurrentTheme().getSeparatorBackground() 的覆盖方法。

返回：
分隔符背景颜色
另请参见：
MetalTheme

getSeparatorForeground

public static ColorUIResource getSeparatorForeground()
返回当前主题的分隔符前景颜色。此方法是 getCurrentTheme().getSeparatorForeground() 的覆盖方法。

返回：
分隔符前景颜色
另请参见：
MetalTheme

getAcceleratorForeground

public static ColorUIResource getAcceleratorForeground()
返回当前主题的加速器前景颜色。此方法是 getCurrentTheme().getAcceleratorForeground() 的覆盖方法。

返回：
分隔符加速器前景颜色
另请参见：
MetalTheme

getAcceleratorSelectedForeground

public static ColorUIResource getAcceleratorSelectedForeground()
返回当前主题的加速器选中前景颜色。此方法是 getCurrentTheme().getAcceleratorSelectedForeground() 的覆盖方法。

返回：
加速器选中前景颜色
另请参见：
MetalTheme

getLayoutStyle

public LayoutStyle getLayoutStyle()
返回一个 LayoutStyle，它实现 http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html 中指定的 Java 外观设计原则。

覆盖：
类 LookAndFeel 中的 getLayoutStyle
返回：
实现 Java 外观设计原则的 LayoutStyle
从以下版本开始：
1.6
另请参见：
LayoutStyle.getInstance()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalMenuBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalMenuBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.MenuBarUI
            继承者  javax.swing.plaf.basic.BasicMenuBarUI
                继承者  javax.swing.plaf.metal.MetalMenuBarUI

public class MetalMenuBarUI
extends BasicMenuBarUI

MenuBarUI 的 Metal 实现。此类负责为 JMenuBar 提供 metal 外观。

从以下版本开始：
1.5
另请参见：
MenuBarUI

字段摘要
从类 javax.swing.plaf.basic.BasicMenuBarUI 继承的字段
changeListener, containerListener, menuBar
构造方法摘要
MetalMenuBarUI()
方法摘要
static ComponentUI | createUI(JComponent x) 为传入的组件创建 ComponentUI 实现。
void | installUI(JComponent c) 配置指定组件，使其适合 metal 外观。
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
void | update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
从类 javax.swing.plaf.basic.BasicMenuBarUI 继承的方法
createChangeListener, createContainerListener, getMaximumSize, getMinimumSize, installDefaults, installKeyboardActions, installListeners, uninstallDefaults, uninstallKeyboardActions, uninstallListeners
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getPreferredSize, paint
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalMenuBarUI

public MetalMenuBarUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)
为传入的组件创建 ComponentUI 实现。

参数：
x - 要为其创建 ComponentUI 实现的 JComponent
返回：
x 的 ComponentUI 实现
抛出：
NullPointerException - 如果 x 为 null

installUI

public void installUI(JComponent c)
配置指定组件，使其适合 metal 外观。

覆盖：
类 BasicMenuBarUI 中的 installUI
参数：
c - 作为此 UI 委托的安装目的地的组件
抛出：
NullPointerException - 如果 c 为 null。
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
在 installUI 期间，在指定组件上反向执行的配置操作。

覆盖：
类 BasicMenuBarUI 中的 uninstallUI
参数：
c - 作为此 UI 委托的安装目的地的组件
抛出：
NullPointerException - 如果 c 为 null。
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

update

public void update(Graphics g,
                   JComponent c)
如果必要，绘制组件的背景，然后调用 paint。

覆盖：
类 ComponentUI 中的 update
参数：
g - 作为绘制目标的 Graphic
c - 要在其上进行绘制的 JComponent
抛出：
NullPointerException - 如果 g 或 c 为 null
从以下版本开始：
1.5
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent), ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalProgressBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalProgressBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ProgressBarUI
            继承者  javax.swing.plaf.basic.BasicProgressBarUI
                继承者  javax.swing.plaf.metal.MetalProgressBarUI

public class MetalProgressBarUI
extends BasicProgressBarUI

ProgressBarUI 的 Metal 实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicProgressBarUI 继承的嵌套类/接口
BasicProgressBarUI.ChangeHandler
字段摘要
从类 javax.swing.plaf.basic.BasicProgressBarUI 继承的字段
boxRect, changeListener, progressBar
构造方法摘要
MetalProgressBarUI()
方法摘要
static ComponentUI | createUI(JComponent c)
void | paintDeterminate(Graphics g, JComponent c) 在进度条上绘制少量特殊的高亮显示。
void | paintIndeterminate(Graphics g, JComponent c) 在进度条和跳动框上绘制少量特殊的高亮显示。
从类 javax.swing.plaf.basic.BasicProgressBarUI 继承的方法
getAmountFull, getAnimationIndex, getBaseline, getBaselineResizeBehavior, getBox, getBoxLength, getCellLength, getCellSpacing, getFrameCount, getMaximumSize, getMinimumSize, getPreferredInnerHorizontal, getPreferredInnerVertical, getPreferredSize, getSelectionBackground, getSelectionForeground, getStringPlacement, incrementAnimationIndex, installDefaults, installListeners, installUI, paint, paintString, setAnimationIndex, setCellLength, setCellSpacing, startAnimationTimer, stopAnimationTimer, uninstallDefaults, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalProgressBarUI

public MetalProgressBarUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

paintDeterminate

public void paintDeterminate(Graphics g,
                             JComponent c)
在进度条上绘制少量特殊的高亮显示。核心绘制遵从 BasicProgressBar 的 paintDeterminate 方法。

覆盖：
类 BasicProgressBarUI 中的 paintDeterminate
从以下版本开始：
1.4
另请参见：
BasicProgressBarUI.paintIndeterminate(java.awt.Graphics, javax.swing.JComponent)

paintIndeterminate

public void paintIndeterminate(Graphics g,
                               JComponent c)
在进度条和跳动框上绘制少量特殊的高亮显示。核心绘制遵从 BasicProgressBar 的 paintIndeterminate 方法。

覆盖：
类 BasicProgressBarUI 中的 paintIndeterminate
从以下版本开始：
1.4
另请参见：
BasicProgressBarUI.paintDeterminate(java.awt.Graphics, javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalPopupMenuSeparatorUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalPopupMenuSeparatorUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SeparatorUI
            继承者  javax.swing.plaf.basic.BasicSeparatorUI
                继承者  javax.swing.plaf.metal.MetalSeparatorUI
                    继承者  javax.swing.plaf.metal.MetalPopupMenuSeparatorUI

public class MetalPopupMenuSeparatorUI
extends MetalSeparatorUI

PopupMenuSeparatorUI 的 Metal L&F 实现。此实现是一个“组合的”视图/控制器。

字段摘要
从类 javax.swing.plaf.basic.BasicSeparatorUI 继承的字段
highlight, shadow
构造方法摘要
MetalPopupMenuSeparatorUI()
方法摘要
static ComponentUI | createUI(JComponent c)
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
从类 javax.swing.plaf.metal.MetalSeparatorUI 继承的方法
installDefaults
从类 javax.swing.plaf.basic.BasicSeparatorUI 继承的方法
getMaximumSize, getMinimumSize, installListeners, installUI, uninstallDefaults, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalPopupMenuSeparatorUI

public MetalPopupMenuSeparatorUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 MetalSeparatorUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 MetalSeparatorUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalRadioButtonUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalRadioButtonUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.basic.BasicButtonUI
                继承者  javax.swing.plaf.basic.BasicToggleButtonUI
                    继承者  javax.swing.plaf.basic.BasicRadioButtonUI
                        继承者  javax.swing.plaf.metal.MetalRadioButtonUI
直接已知子类：
MetalCheckBoxUI
public class MetalRadioButtonUI
extends BasicRadioButtonUI

MetalRadioButtonUI 的 RadioButtonUI 实现

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected Color | disabledTextColor
protected Color | focusColor
protected Color | selectColor
从类 javax.swing.plaf.basic.BasicRadioButtonUI 继承的字段
icon
从类 javax.swing.plaf.basic.BasicButtonUI 继承的字段
defaultTextIconGap, defaultTextShiftOffset
构造方法摘要
MetalRadioButtonUI()
方法摘要
static ComponentUI | createUI(JComponent c)
protected Color | getDisabledTextColor()
protected Color | getFocusColor()
protected Color | getSelectColor()
void | installDefaults(AbstractButton b)
void | paint(Graphics g, JComponent c) 绘制单选按钮
protected void | paintFocus(Graphics g, Rectangle t, Dimension d)
protected void | uninstallDefaults(AbstractButton b)
从类 javax.swing.plaf.basic.BasicRadioButtonUI 继承的方法
getDefaultIcon, getPreferredSize, getPropertyPrefix
从类 javax.swing.plaf.basic.BasicToggleButtonUI 继承的方法
getTextShiftOffset, paintIcon
从类 javax.swing.plaf.basic.BasicButtonUI 继承的方法
clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, installKeyboardActions, installListeners, installUI, paintButtonPressed, paintFocus, paintIcon, paintText, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

focusColor

protected Color focusColor

selectColor

protected Color selectColor

disabledTextColor

protected Color disabledTextColor
构造方法详细信息

MetalRadioButtonUI

public MetalRadioButtonUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installDefaults

public void installDefaults(AbstractButton b)
覆盖：
类 BasicRadioButtonUI 中的 installDefaults

uninstallDefaults

protected void uninstallDefaults(AbstractButton b)
覆盖：
类 BasicRadioButtonUI 中的 uninstallDefaults

getSelectColor

protected Color getSelectColor()

getDisabledTextColor

protected Color getDisabledTextColor()

getFocusColor

protected Color getFocusColor()

paint

public void paint(Graphics g,
                  JComponent c)
从类 BasicRadioButtonUI 复制的描述
绘制单选按钮

覆盖：
类 BasicRadioButtonUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintFocus

protected void paintFocus(Graphics g,
                          Rectangle t,
                          Dimension d)
覆盖：
类 BasicRadioButtonUI 中的 paintFocus
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalRootPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalRootPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.RootPaneUI
            继承者  javax.swing.plaf.basic.BasicRootPaneUI
                继承者  javax.swing.plaf.metal.MetalRootPaneUI
所有已实现的接口：
PropertyChangeListener, EventListener
public class MetalRootPaneUI
extends BasicRootPaneUI

提供 RootPaneUI 的 metal 外观实现。

MetalRootPaneUI 提供对 JRootPane 的 windowDecorationStyle 属性的支持。MetalRootPaneUI 通过安装一个自定义 LayoutManager、一个呈现适当窗口小部件的私有 Component 和一个私有 Border 来做到这一点。不管 windowDecorationStyle 属性的值如何，总是要安装 LayoutManager，但 Border 和 Component 只在 windowDecorationStyle 不是 JRootPane.NONE 时才被安装/添加。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4

构造方法摘要
MetalRootPaneUI()
方法摘要
static ComponentUI | createUI(JComponent c) 为 JRootPane 创建一个 UI。
void | installUI(JComponent c) 调用 installUI 的超实现来在传入的 JRootPane 上安装必要的状态，以呈现 RootPaneUI 的 metal 外观实现。
void | propertyChange(PropertyChangeEvent e) 属性更改时调用。
void | uninstallUI(JComponent c) 调用超实现来卸载所有状态。
从类 javax.swing.plaf.basic.BasicRootPaneUI 继承的方法
installComponents, installDefaults, installKeyboardActions, installListeners, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalRootPaneUI

public MetalRootPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)
为 JRootPane 创建一个 UI。

参数：
c - 将为其创建 RootPaneUI 的 JRootPane
返回：
所传入 JRootPane 的 RootPaneUI 实现

installUI

public void installUI(JComponent c)
调用 installUI 的超实现来在传入的 JRootPane 上安装必要的状态，以呈现 RootPaneUI 的 metal 外观实现。如果 JRootPane 的 windowDecorationStyle 属性不是 JRootPane.NONE，则此方法将添加一个自定义 Component 来将窗口小部件呈现给 JRootPane，并在 JRootPane 上安装一个自定义 Border 和 LayoutManager。

覆盖：
类 BasicRootPaneUI 中的 installUI
参数：
c - 在其上安装状态的 JRootPane
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
调用超实现来卸载所有状态。此方法还将重置 JRootPane 的 LayoutManager。如果已经将 Component 添加到 JRootPane 中来呈现窗口装饰风格，则此方法将移除它。类似地，此方法会将 JRootPane 的 Border 和 LayoutManager 恢复为调用 installUI 前的样子。

覆盖：
类 BasicRootPaneUI 中的 uninstallUI
参数：
c - 从其中卸载状态的 JRootPane
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

propertyChange

public void propertyChange(PropertyChangeEvent e)
属性更改时调用。MetalRootPaneUI 主要用于源自 JRootPane（已安装它来标识属性 windowDecorationStyle）的事件。如果 windowDecorationStyle 已经更改为不是 JRootPane.NONE 的某个值，则此方法会向 JRootPane 添加一个 Component 来呈现窗口装饰，并在 JRootPane 上安装一个 Border。另一方面，如果 windowDecorationStyle 已更改为 JRootPane.NONE，则此方法将移除已添加到 JRootPane 中的 Component，并将 Border 重置回调用 installUI 以前的样子。

指定者：
接口 PropertyChangeListener 中的 propertyChange
覆盖：
类 BasicRootPaneUI 中的 propertyChange
参数：
e - 描述事件源和已更改的属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalScrollBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalScrollBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ScrollBarUI
            继承者  javax.swing.plaf.basic.BasicScrollBarUI
                继承者  javax.swing.plaf.metal.MetalScrollBarUI
所有已实现的接口：
LayoutManager, SwingConstants
public class MetalScrollBarUI
extends BasicScrollBarUI

ScrollBarUI 的 Metal 外观实现

嵌套类摘要
从类 javax.swing.plaf.basic.BasicScrollBarUI 继承的嵌套类/接口
BasicScrollBarUI.ArrowButtonListener, BasicScrollBarUI.ModelListener, BasicScrollBarUI.PropertyChangeHandler, BasicScrollBarUI.ScrollListener, BasicScrollBarUI.TrackListener
字段摘要
protected javax.swing.plaf.metal.MetalBumps | bumps
protected MetalScrollButton | decreaseButton
static String | FREE_STANDING_PROP
protected MetalScrollButton | increaseButton
protected boolean | isFreeStanding
protected int | scrollBarWidth
从类 javax.swing.plaf.basic.BasicScrollBarUI 继承的字段
buttonListener, decrButton, DECREASE_HIGHLIGHT, incrButton, INCREASE_HIGHLIGHT, isDragging, maximumThumbSize, minimumThumbSize, modelListener, NO_HIGHLIGHT, propertyChangeListener, scrollbar, scrollListener, scrollTimer, thumbDarkShadowColor, thumbLightShadowColor, thumbRect, trackColor, trackHighlight, trackHighlightColor, trackListener, trackRect
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
MetalScrollBarUI()
方法摘要
protected void | configureScrollBarColors()
protected JButton | createDecreaseButton(int orientation) 返回表示减少量视图的视图。
protected JButton | createIncreaseButton(int orientation) 返回表示增加量视图的视图。
protected PropertyChangeListener | createPropertyChangeListener()
static ComponentUI | createUI(JComponent c)
protected Dimension | getMinimumThumbSize() 返回 thumb 的最小可接受大小。
Dimension | getPreferredSize(JComponent c) 垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。
protected void | installDefaults()
protected void | installListeners()
protected void | paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected void | paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected void | setThumbBounds(int x, int y, int width, int height) 重写此方法只是为了增加无效区域。
从类 javax.swing.plaf.basic.BasicScrollBarUI 继承的方法
addLayoutComponent, createArrowButtonListener, createModelListener, createScrollListener, createTrackListener, getMaximumSize, getMaximumThumbSize, getSupportsAbsolutePositioning, getThumbBounds, getTrackBounds, installComponents, installKeyboardActions, installUI, isThumbRollover, layoutContainer, layoutHScrollbar, layoutVScrollbar, minimumLayoutSize, paint, paintDecreaseHighlight, paintIncreaseHighlight, preferredLayoutSize, removeLayoutComponent, scrollByBlock, scrollByUnit, setThumbRollover, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMinimumSize, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

bumps

protected javax.swing.plaf.metal.MetalBumps bumps

increaseButton

protected MetalScrollButton increaseButton

decreaseButton

protected MetalScrollButton decreaseButton

scrollBarWidth

protected int scrollBarWidth

FREE_STANDING_PROP

public static final String FREE_STANDING_PROP
另请参见：
常量字段值

isFreeStanding

protected boolean isFreeStanding
构造方法详细信息

MetalScrollBarUI

public MetalScrollBarUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installDefaults

protected void installDefaults()
覆盖：
类 BasicScrollBarUI 中的 installDefaults

installListeners

protected void installListeners()
覆盖：
类 BasicScrollBarUI 中的 installListeners

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener()
覆盖：
类 BasicScrollBarUI 中的 createPropertyChangeListener

configureScrollBarColors

protected void configureScrollBarColors()
覆盖：
类 BasicScrollBarUI 中的 configureScrollBarColors

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 BasicScrollBarUI 复制的描述
垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。首选高度是相同部分的首选高度之和。水平滚动条的首选大小的基础与此类似。

preferredSize 仅计算一次，此方法的后续调用仅返回缓存的大小。

覆盖：
类 BasicScrollBarUI 中的 getPreferredSize
参数：
c - 委托此方法的 JScrollBar
返回：
Basic JScrollBar 的首选大小
另请参见：
BasicScrollBarUI.getMaximumSize(javax.swing.JComponent), ComponentUI.getMinimumSize(javax.swing.JComponent)

createDecreaseButton

protected JButton createDecreaseButton(int orientation)
返回表示减少量视图的视图。

覆盖：
类 BasicScrollBarUI 中的 createDecreaseButton

createIncreaseButton

protected JButton createIncreaseButton(int orientation)
返回表示增加量视图的视图。

覆盖：
类 BasicScrollBarUI 中的 createIncreaseButton

paintTrack

protected void paintTrack(Graphics g,
                          JComponent c,
                          Rectangle trackBounds)
覆盖：
类 BasicScrollBarUI 中的 paintTrack

paintThumb

protected void paintThumb(Graphics g,
                          JComponent c,
                          Rectangle thumbBounds)
覆盖：
类 BasicScrollBarUI 中的 paintThumb

getMinimumThumbSize

protected Dimension getMinimumThumbSize()
从类 BasicScrollBarUI 复制的描述
返回 thumb 的最小可接受大小。如果滚动条变得非常小，此大小不适用，则 thumb 将被隐藏。

警告：不应修改此方法返回的值，它是一个共享的静态常量。

覆盖：
类 BasicScrollBarUI 中的 getMinimumThumbSize
返回：
thumb 的最小可接受大小。
另请参见：
BasicScrollBarUI.getMaximumThumbSize()

setThumbBounds

protected void setThumbBounds(int x,
                              int y,
                              int width,
                              int height)
重写此方法只是为了增加无效区域。此方法确保滑块下的“阴影”是无效的

覆盖：
类 BasicScrollBarUI 中的 setThumbBounds
另请参见：
BasicScrollBarUI.getThumbBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalScrollButton (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalScrollButton

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JButton
                        继承者  javax.swing.plaf.basic.BasicArrowButton
                            继承者  javax.swing.plaf.metal.MetalScrollButton
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
public class MetalScrollButton
extends BasicArrowButton

Metal 滚动条箭头的 JButton 对象。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JButton 继承的嵌套类/接口
JButton.AccessibleJButton
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.plaf.basic.BasicArrowButton 继承的字段
direction
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
MetalScrollButton(int direction, int width, boolean freeStanding)
方法摘要
int | getButtonWidth()
Dimension | getMaximumSize() 返回 BasicArrowButton 的最大大小。
Dimension | getMinimumSize() 返回 BasicArrowButton 的最小大小。
Dimension | getPreferredSize() 返回 BasicArrowButton 的首选大小。
void | paint(Graphics g) 由 Swing 调用，以绘制组件。
void | setFreeStanding(boolean freeStanding)
从类 javax.swing.plaf.basic.BasicArrowButton 继承的方法
getDirection, isFocusTraversable, paintTriangle, setDirection
从类 javax.swing.JButton 继承的方法
getAccessibleContext, getUIClassID, isDefaultButton, isDefaultCapable, paramString, removeNotify, setDefaultCapable, updateUI
从类 javax.swing.AbstractButton 继承的方法
actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MetalScrollButton

public MetalScrollButton(int direction,
                         int width,
                         boolean freeStanding)
方法详细信息

setFreeStanding

public void setFreeStanding(boolean freeStanding)

paint

public void paint(Graphics g)
从类 JComponent 复制的描述
由 Swing 调用，以绘制组件。应用程序不应直接调用 paint，而是应该使用 repaint 方法来安排重绘组件。

此方法实际上将绘制工作委托给三个受保护的方法：paintComponent、paintBorder 和 paintChildren。按列出的顺序调用这些方法，以确保子组件出现在组件本身的顶部。一般来说，不应在分配给边框的 insets 区域绘制组件及其子组件。子类可以始终重写此方法。只想特殊化 UI（外观）委托的 paint 方法的子类只需重写 paintComponent。

覆盖：
类 BasicArrowButton 中的 paint
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

getPreferredSize

public Dimension getPreferredSize()
从类 BasicArrowButton 复制的描述
返回 BasicArrowButton 的首选大小。

覆盖：
类 BasicArrowButton 中的 getPreferredSize
返回：
首选大小
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

getMinimumSize

public Dimension getMinimumSize()
从类 BasicArrowButton 复制的描述
返回 BasicArrowButton 的最小大小。

覆盖：
类 BasicArrowButton 中的 getMinimumSize
返回：
最小大小
另请参见：
JComponent.setMinimumSize(java.awt.Dimension), ComponentUI

getMaximumSize

public Dimension getMaximumSize()
从类 BasicArrowButton 复制的描述
返回 BasicArrowButton 的最大大小。

覆盖：
类 BasicArrowButton 中的 getMaximumSize
返回：
最大大小
另请参见：
JComponent.setMaximumSize(java.awt.Dimension), ComponentUI

getButtonWidth

public int getButtonWidth()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalScrollPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalScrollPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ScrollPaneUI
            继承者  javax.swing.plaf.basic.BasicScrollPaneUI
                继承者  javax.swing.plaf.metal.MetalScrollPaneUI
所有已实现的接口：
ScrollPaneConstants
public class MetalScrollPaneUI
extends BasicScrollPaneUI

ScrollPaneUI 的 Metal L&F 实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicScrollPaneUI 继承的嵌套类/接口
BasicScrollPaneUI.HSBChangeListener, BasicScrollPaneUI.MouseWheelHandler, BasicScrollPaneUI.PropertyChangeHandler, BasicScrollPaneUI.ViewportChangeHandler, BasicScrollPaneUI.VSBChangeListener
字段摘要
从类 javax.swing.plaf.basic.BasicScrollPaneUI 继承的字段
hsbChangeListener, scrollpane, spPropertyChangeListener, viewportChangeListener, vsbChangeListener
从接口 javax.swing.ScrollPaneConstants 继承的字段
COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT
构造方法摘要
MetalScrollPaneUI()
方法摘要
protected PropertyChangeListener | createScrollBarSwapListener()
static ComponentUI | createUI(JComponent x)
void | installListeners(JScrollPane scrollPane)
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | uninstallListeners(JScrollPane scrollPane)
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.basic.BasicScrollPaneUI 继承的方法
createHSBChangeListener, createMouseWheelListener, createPropertyChangeListener, createViewportChangeListener, createVSBChangeListener, getBaseline, getBaselineResizeBehavior, getMaximumSize, installDefaults, installKeyboardActions, paint, syncScrollPaneWithViewport, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, updateColumnHeader, updateRowHeader, updateScrollBarDisplayPolicy, updateViewport
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getMinimumSize, getPreferredSize, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalScrollPaneUI

public MetalScrollPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 BasicScrollPaneUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 BasicScrollPaneUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installListeners

public void installListeners(JScrollPane scrollPane)
覆盖：
类 BasicScrollPaneUI 中的 installListeners

uninstallListeners

public void uninstallListeners(JScrollPane scrollPane)

createScrollBarSwapListener

protected PropertyChangeListener createScrollBarSwapListener()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalSeparatorUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalSeparatorUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SeparatorUI
            继承者  javax.swing.plaf.basic.BasicSeparatorUI
                继承者  javax.swing.plaf.metal.MetalSeparatorUI
直接已知子类：
MetalPopupMenuSeparatorUI
public class MetalSeparatorUI
extends BasicSeparatorUI

SeparatorUI 的 Metal L&F 实现。此实现是一个“组合的”视图/控制器。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.plaf.basic.BasicSeparatorUI 继承的字段
highlight, shadow
构造方法摘要
MetalSeparatorUI()
方法摘要
static ComponentUI | createUI(JComponent c)
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
protected void | installDefaults(JSeparator s)
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
从类 javax.swing.plaf.basic.BasicSeparatorUI 继承的方法
getMaximumSize, getMinimumSize, installListeners, installUI, uninstallDefaults, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalSeparatorUI

public MetalSeparatorUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installDefaults

protected void installDefaults(JSeparator s)
覆盖：
类 BasicSeparatorUI 中的 installDefaults

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 BasicSeparatorUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 BasicSeparatorUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalSliderUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalSliderUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SliderUI
            继承者  javax.swing.plaf.basic.BasicSliderUI
                继承者  javax.swing.plaf.metal.MetalSliderUI

public class MetalSliderUI
extends BasicSliderUI

SliderUI 的 Java L&F 实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class MetalSliderUI.MetalPropertyListener
从类 javax.swing.plaf.basic.BasicSliderUI 继承的嵌套类/接口
BasicSliderUI.ActionScroller, BasicSliderUI.ChangeHandler, BasicSliderUI.ComponentHandler, BasicSliderUI.FocusHandler, BasicSliderUI.PropertyChangeHandler, BasicSliderUI.ScrollListener, BasicSliderUI.TrackListener
字段摘要
protected static Color | darkShadowColor
protected boolean | filledSlider
protected static Color | highlightColor
protected static Icon | horizThumbIcon 默认水平 thumb Icon。
protected String | SLIDER_FILL
protected static Color | thumbColor
protected int | TICK_BUFFER
protected static int | tickLength
protected static int | trackWidth
protected static Icon | vertThumbIcon 默认垂直 thumb Icon。
从类 javax.swing.plaf.basic.BasicSliderUI 继承的字段
changeListener, componentListener, contentRect, focusInsets, focusListener, focusRect, insetCache, labelRect, leftToRightCache, MAX_SCROLL, MIN_SCROLL, NEGATIVE_SCROLL, POSITIVE_SCROLL, propertyChangeListener, scrollListener, scrollTimer, slider, thumbRect, tickRect, trackBuffer, trackListener, trackRect
构造方法摘要
MetalSliderUI()
方法摘要
protected PropertyChangeListener | createPropertyChangeListener(JSlider slider)
static ComponentUI | createUI(JComponent c)
protected int | getThumbOverhang() 返回 thumb 在滑杆上滑过的量。
protected Dimension | getThumbSize()
int | getTickLength() 获取水平滑块的刻度区域高度和垂直滑块的刻度区域宽度。
protected int | getTrackLength() 返回较长的滑杆尺寸。
protected int | getTrackWidth() 返回较短的滑道尺寸。
void | installUI(JComponent c) 配置指定组件，使其适合外观。
void | paintFocus(Graphics g)
protected void | paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected void | paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
void | paintThumb(Graphics g)
void | paintTrack(Graphics g)
protected void | scrollDueToClickInTrack(int dir) 在滑道（而非 thumb）中检测到 mousePressed 时调用此方法。
从类 javax.swing.plaf.basic.BasicSliderUI 继承的方法
calculateContentRect, calculateFocusRect, calculateGeometry, calculateLabelRect, calculateThumbLocation, calculateThumbSize, calculateTickRect, calculateTrackBuffer, calculateTrackRect, createChangeListener, createComponentListener, createFocusListener, createScrollListener, createTrackListener, drawInverted, getBaseline, getBaselineResizeBehavior, getFocusColor, getHeightOfHighValueLabel, getHeightOfLowValueLabel, getHeightOfTallestLabel, getHighestValue, getHighestValueLabel, getHighlightColor, getLowestValue, getLowestValueLabel, getMaximumSize, getMinimumHorizontalSize, getMinimumSize, getMinimumVerticalSize, getPreferredHorizontalSize, getPreferredSize, getPreferredVerticalSize, getShadowColor, getWidthOfHighValueLabel, getWidthOfLowValueLabel, getWidthOfWidestLabel, installDefaults, installKeyboardActions, installListeners, isDragging, labelsHaveSameBaselines, paint, paintHorizontalLabel, paintLabels, paintTicks, paintVerticalLabel, recalculateIfInsetsChanged, recalculateIfOrientationChanged, scrollByBlock, scrollByUnit, setThumbLocation, uninstallKeyboardActions, uninstallListeners, uninstallUI, valueForXPosition, valueForYPosition, xPositionForValue, yPositionForValue, yPositionForValue
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TICK_BUFFER

protected final int TICK_BUFFER
另请参见：
常量字段值

filledSlider

protected boolean filledSlider

thumbColor

protected static Color thumbColor

highlightColor

protected static Color highlightColor

darkShadowColor

protected static Color darkShadowColor

trackWidth

protected static int trackWidth

tickLength

protected static int tickLength

horizThumbIcon

protected static Icon horizThumbIcon
默认水平 thumb Icon。可以不使用此字段。要更改此委托使用的 Icon，可使用 Slider.horizontalThumbIcon UIManager 属性直接设置它。

vertThumbIcon

protected static Icon vertThumbIcon
默认垂直 thumb Icon。可以不使用此字段。要更改此委托使用的 Icon，可使用 Slider.verticalThumbIcon UIManager 属性直接设置它。

SLIDER_FILL

protected final String SLIDER_FILL
另请参见：
常量字段值
构造方法详细信息

MetalSliderUI

public MetalSliderUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 BasicSliderUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

createPropertyChangeListener

protected PropertyChangeListener createPropertyChangeListener(JSlider slider)
覆盖：
类 BasicSliderUI 中的 createPropertyChangeListener

paintThumb

public void paintThumb(Graphics g)
覆盖：
类 BasicSliderUI 中的 paintThumb

paintTrack

public void paintTrack(Graphics g)
覆盖：
类 BasicSliderUI 中的 paintTrack

paintFocus

public void paintFocus(Graphics g)
覆盖：
类 BasicSliderUI 中的 paintFocus

getThumbSize

protected Dimension getThumbSize()
覆盖：
类 BasicSliderUI 中的 getThumbSize

getTickLength

public int getTickLength()
获取水平滑块的刻度区域高度和垂直滑块的刻度区域宽度。BasicSliderUI 使用返回的值来确定刻度区域矩形。

覆盖：
类 BasicSliderUI 中的 getTickLength

getTrackWidth

protected int getTrackWidth()
返回较短的滑道尺寸。

getTrackLength

protected int getTrackLength()
返回较长的滑杆尺寸。（滑杆仅为直接位于 thumb 下的那一部分）

getThumbOverhang

protected int getThumbOverhang()
返回 thumb 在滑杆上滑过的量。

scrollDueToClickInTrack

protected void scrollDueToClickInTrack(int dir)
从类 BasicSliderUI 复制的描述
在滑道（而非 thumb）中检测到 mousePressed 时调用此方法。默认行为按块滚动。可以重写此方法来阻止滚动或者添加其他行为。

覆盖：
类 BasicSliderUI 中的 scrollDueToClickInTrack

paintMinorTickForHorizSlider

protected void paintMinorTickForHorizSlider(Graphics g,
                                            Rectangle tickBounds,
                                            int x)
覆盖：
类 BasicSliderUI 中的 paintMinorTickForHorizSlider

paintMajorTickForHorizSlider

protected void paintMajorTickForHorizSlider(Graphics g,
                                            Rectangle tickBounds,
                                            int x)
覆盖：
类 BasicSliderUI 中的 paintMajorTickForHorizSlider

paintMinorTickForVertSlider

protected void paintMinorTickForVertSlider(Graphics g,
                                           Rectangle tickBounds,
                                           int y)
覆盖：
类 BasicSliderUI 中的 paintMinorTickForVertSlider

paintMajorTickForVertSlider

protected void paintMajorTickForVertSlider(Graphics g,
                                           Rectangle tickBounds,
                                           int y)
覆盖：
类 BasicSliderUI 中的 paintMajorTickForVertSlider
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalSliderUI.MetalPropertyListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalSliderUI.MetalPropertyListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
        继承者  javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
MetalSliderUI
protected class MetalSliderUI.MetalPropertyListener
extends BasicSliderUI.PropertyChangeHandler

构造方法摘要
protected MetalSliderUI.MetalPropertyListener()
方法摘要
 void propertyChange(PropertyChangeEvent e)
在绑定属性发生更改时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalSliderUI.MetalPropertyListener

protected MetalSliderUI.MetalPropertyListener()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
从接口 PropertyChangeListener 复制的描述
在绑定属性发生更改时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
覆盖：
类 BasicSliderUI.PropertyChangeHandler 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalSplitPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalSplitPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SplitPaneUI
            继承者  javax.swing.plaf.basic.BasicSplitPaneUI
                继承者  javax.swing.plaf.metal.MetalSplitPaneUI

public class MetalSplitPaneUI
extends BasicSplitPaneUI

Metal 分隔窗格。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicSplitPaneUI 继承的嵌套类/接口
BasicSplitPaneUI.BasicHorizontalLayoutManager, BasicSplitPaneUI.BasicVerticalLayoutManager, BasicSplitPaneUI.FocusHandler, BasicSplitPaneUI.KeyboardDownRightHandler, BasicSplitPaneUI.KeyboardEndHandler, BasicSplitPaneUI.KeyboardHomeHandler, BasicSplitPaneUI.KeyboardResizeToggleHandler, BasicSplitPaneUI.KeyboardUpLeftHandler, BasicSplitPaneUI.PropertyHandler
字段摘要
从类 javax.swing.plaf.basic.BasicSplitPaneUI 继承的字段
beginDragDividerLocation, divider, dividerResizeToggleKey, dividerSize, downKey, draggingHW, endKey, focusListener, homeKey, KEYBOARD_DIVIDER_MOVE_OFFSET, keyboardDownRightListener, keyboardEndListener, keyboardHomeListener, keyboardResizeToggleListener, keyboardUpLeftListener, layoutManager, leftKey, NON_CONTINUOUS_DIVIDER, nonContinuousLayoutDivider, propertyChangeListener, rightKey, splitPane, upKey
构造方法摘要
MetalSplitPaneUI()
方法摘要
BasicSplitPaneDivider | createDefaultDivider() 创建默认分隔符。
static ComponentUI | createUI(JComponent x) 创建一个新的 MetalSplitPaneUI 实例
从类 javax.swing.plaf.basic.BasicSplitPaneUI 继承的方法
createDefaultNonContinuousLayoutDivider, createFocusListener, createKeyboardDownRightListener, createKeyboardEndListener, createKeyboardHomeListener, createKeyboardResizeToggleListener, createKeyboardUpLeftListener, createPropertyChangeListener, dragDividerTo, finishDraggingTo, finishedPaintingChildren, getDivider, getDividerBorderSize, getDividerLocation, getInsets, getLastDragLocation, getMaximumDividerLocation, getMaximumSize, getMinimumDividerLocation, getMinimumSize, getNonContinuousLayoutDivider, getOrientation, getPreferredSize, getSplitPane, installDefaults, installKeyboardActions, installListeners, installUI, isContinuousLayout, paint, resetLayoutManager, resetToPreferredSizes, setContinuousLayout, setDividerLocation, setLastDragLocation, setNonContinuousLayoutDivider, setNonContinuousLayoutDivider, setOrientation, startDragging, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalSplitPaneUI

public MetalSplitPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)
创建一个新的 MetalSplitPaneUI 实例

createDefaultDivider

public BasicSplitPaneDivider createDefaultDivider()
创建默认分隔符。

覆盖：
类 BasicSplitPaneUI 中的 createDefaultDivider
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalTabbedPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalTabbedPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TabbedPaneUI
            继承者  javax.swing.plaf.basic.BasicTabbedPaneUI
                继承者  javax.swing.plaf.metal.MetalTabbedPaneUI
所有已实现的接口：
SwingConstants
public class MetalTabbedPaneUI
extends BasicTabbedPaneUI

BasicTabbedPaneUI 的 Metal 子类。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
 class MetalTabbedPaneUI.TabbedPaneLayout
此内部类由于编译器故障而被标记为 "public"。
从类 javax.swing.plaf.basic.BasicTabbedPaneUI 继承的嵌套类/接口
BasicTabbedPaneUI.FocusHandler, BasicTabbedPaneUI.MouseHandler, BasicTabbedPaneUI.PropertyChangeHandler, BasicTabbedPaneUI.TabSelectionHandler
字段摘要
protected int | minTabWidth
protected Color | selectColor
protected Color | selectHighlight
protected Color | tabAreaBackground
从类 javax.swing.plaf.basic.BasicTabbedPaneUI 继承的字段
calcRect, contentBorderInsets, darkShadow, downKey, focus, focusListener, highlight, leftKey, lightHighlight, maxTabHeight, maxTabWidth, mouseListener, propertyChangeListener, rects, rightKey, runCount, selectedRun, selectedTabPadInsets, shadow, tabAreaInsets, tabChangeListener, tabInsets, tabPane, tabRunOverlay, tabRuns, textIconGap, upKey
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
MetalTabbedPaneUI()
方法摘要
protected int | calculateMaxTabHeight(int tabPlacement)
protected LayoutManager | createLayoutManager() 由 installUI 调用，用于创建布局管理器对象以管理 JTabbedPane。
static ComponentUI | createUI(JComponent x)
protected int | getBaselineOffset() 返回基线偏移的距离。
protected Color | getColorForGap(int currentRun, int x, int y)
protected int | getTabLabelShiftX(int tabPlacement, int tabIndex, boolean isSelected) 重写该方法，使其不对 Java L&F 进行任何操作。
protected int | getTabLabelShiftY(int tabPlacement, int tabIndex, boolean isSelected) 重写该方法，使其不对 Java L&F 进行任何操作。
protected int | getTabRunOverlay(int tabPlacement)
protected void | installDefaults()
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | paintBottomTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | paintContentBorderBottomEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | paintContentBorderLeftEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | paintContentBorderRightEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | paintContentBorderTopEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | paintHighlightBelowTab()
protected void | paintLeftTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | paintRightTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | paintTabBackground(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
protected void | paintTabBorder(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected) 此方法围绕每个选项卡绘制边框。
protected void | paintTopTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected boolean | shouldFillGap(int currentRun, int tabIndex, int x, int y)
protected boolean | shouldPadTabRun(int tabPlacement, int run)
protected boolean | shouldRotateTabRuns(int tabPlacement, int selectedRun)
void | update(Graphics g, JComponent c) 通知此 UI 委托开始绘制指定的组件。
从类 javax.swing.plaf.basic.BasicTabbedPaneUI 继承的方法
assureRectsCreated, calculateMaxTabWidth, calculateTabAreaHeight, calculateTabAreaWidth, calculateTabHeight, calculateTabWidth, createChangeListener, createFocusListener, createMouseListener, createPropertyChangeListener, createScrollButton, expandTabRunsArray, getBaseline, getBaseline, getBaselineResizeBehavior, getContentBorderInsets, getFocusIndex, getFontMetrics, getIconForTab, getMaximumSize, getMinimumSize, getNextTabIndex, getNextTabIndexInRun, getNextTabRun, getPreviousTabIndex, getPreviousTabIndexInRun, getPreviousTabRun, getRolloverTab, getRunForTab, getSelectedTabPadInsets, getTabAreaInsets, getTabBounds, getTabBounds, getTabInsets, getTabRunCount, getTabRunIndent, getTabRunOffset, getTextViewForTab, getVisibleComponent, installComponents, installKeyboardActions, installListeners, installUI, lastTabInRun, layoutLabel, navigateSelectedTab, paintContentBorder, paintIcon, paintTab, paintTabArea, paintText, rotateInsets, selectAdjacentRunTab, selectNextTab, selectNextTabInRun, selectPreviousTab, selectPreviousTabInRun, setRolloverTab, setVisibleComponent, shouldRotateTabRuns, tabForCoordinate, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getPreferredSize
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

minTabWidth

protected int minTabWidth

tabAreaBackground

protected Color tabAreaBackground

selectColor

protected Color selectColor

selectHighlight

protected Color selectHighlight
构造方法详细信息

MetalTabbedPaneUI

public MetalTabbedPaneUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

createLayoutManager

protected LayoutManager createLayoutManager()
从类 BasicTabbedPaneUI 复制的描述
由 installUI 调用，用于创建布局管理器对象以管理 JTabbedPane。

覆盖：
类 BasicTabbedPaneUI 中的 createLayoutManager
返回：
布局管理器对象
另请参见：
BasicTabbedPaneUI.TabbedPaneLayout, JTabbedPane.getTabLayoutPolicy()

installDefaults

protected void installDefaults()
覆盖：
类 BasicTabbedPaneUI 中的 installDefaults

paintTabBorder

protected void paintTabBorder(Graphics g,
                              int tabPlacement,
                              int tabIndex,
                              int x,
                              int y,
                              int w,
                              int h,
                              boolean isSelected)
从类 BasicTabbedPaneUI 复制的描述
此方法围绕每个选项卡绘制边框。注意，此方法现在已经能够绘制选项卡的背景，这在其他地方完成。

覆盖：
类 BasicTabbedPaneUI 中的 paintTabBorder

paintTopTabBorder

protected void paintTopTabBorder(int tabIndex,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h,
                                 int btm,
                                 int rght,
                                 boolean isSelected)

shouldFillGap

protected boolean shouldFillGap(int currentRun,
                                int tabIndex,
                                int x,
                                int y)

getColorForGap

protected Color getColorForGap(int currentRun,
                               int x,
                               int y)

paintLeftTabBorder

protected void paintLeftTabBorder(int tabIndex,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h,
                                  int btm,
                                  int rght,
                                  boolean isSelected)

paintBottomTabBorder

protected void paintBottomTabBorder(int tabIndex,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h,
                                    int btm,
                                    int rght,
                                    boolean isSelected)

paintRightTabBorder

protected void paintRightTabBorder(int tabIndex,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h,
                                   int btm,
                                   int rght,
                                   boolean isSelected)

update

public void update(Graphics g,
                   JComponent c)
从类 ComponentUI 复制的描述
通知此 UI 委托开始绘制指定的组件。在将要绘制指定组件时，由 JComponent 调用此方法。默认情况下，此方法将使用其背景色填充指定组件（如果其 opaque 属性为 true），然后立刻调用 paint。通常无需由子类重写此方法；所有呈现代码的外观都应位于 paint 方法中。

覆盖：
类 ComponentUI 中的 update
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

paintTabBackground

protected void paintTabBackground(Graphics g,
                                  int tabPlacement,
                                  int tabIndex,
                                  int x,
                                  int y,
                                  int w,
                                  int h,
                                  boolean isSelected)
覆盖：
类 BasicTabbedPaneUI 中的 paintTabBackground

getTabLabelShiftX

protected int getTabLabelShiftX(int tabPlacement,
                                int tabIndex,
                                boolean isSelected)
重写该方法，使其不对 Java L&F 进行任何操作。

覆盖：
类 BasicTabbedPaneUI 中的 getTabLabelShiftX

getTabLabelShiftY

protected int getTabLabelShiftY(int tabPlacement,
                                int tabIndex,
                                boolean isSelected)
重写该方法，使其不对 Java L&F 进行任何操作。

覆盖：
类 BasicTabbedPaneUI 中的 getTabLabelShiftY

getBaselineOffset

protected int getBaselineOffset()
返回基线偏移的距离。这通常与 getTabLabelShiftY 相同。

覆盖：
类 BasicTabbedPaneUI 中的 getBaselineOffset
返回：
基线偏移的距离
从以下版本开始：
1.6

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 BasicTabbedPaneUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintHighlightBelowTab

protected void paintHighlightBelowTab()

paintFocusIndicator

protected void paintFocusIndicator(Graphics g,
                                   int tabPlacement,
                                   Rectangle[] rects,
                                   int tabIndex,
                                   Rectangle iconRect,
                                   Rectangle textRect,
                                   boolean isSelected)
覆盖：
类 BasicTabbedPaneUI 中的 paintFocusIndicator

paintContentBorderTopEdge

protected void paintContentBorderTopEdge(Graphics g,
                                         int tabPlacement,
                                         int selectedIndex,
                                         int x,
                                         int y,
                                         int w,
                                         int h)
覆盖：
类 BasicTabbedPaneUI 中的 paintContentBorderTopEdge

paintContentBorderBottomEdge

protected void paintContentBorderBottomEdge(Graphics g,
                                            int tabPlacement,
                                            int selectedIndex,
                                            int x,
                                            int y,
                                            int w,
                                            int h)
覆盖：
类 BasicTabbedPaneUI 中的 paintContentBorderBottomEdge

paintContentBorderLeftEdge

protected void paintContentBorderLeftEdge(Graphics g,
                                          int tabPlacement,
                                          int selectedIndex,
                                          int x,
                                          int y,
                                          int w,
                                          int h)
覆盖：
类 BasicTabbedPaneUI 中的 paintContentBorderLeftEdge

paintContentBorderRightEdge

protected void paintContentBorderRightEdge(Graphics g,
                                           int tabPlacement,
                                           int selectedIndex,
                                           int x,
                                           int y,
                                           int w,
                                           int h)
覆盖：
类 BasicTabbedPaneUI 中的 paintContentBorderRightEdge

calculateMaxTabHeight

protected int calculateMaxTabHeight(int tabPlacement)
覆盖：
类 BasicTabbedPaneUI 中的 calculateMaxTabHeight

getTabRunOverlay

protected int getTabRunOverlay(int tabPlacement)
覆盖：
类 BasicTabbedPaneUI 中的 getTabRunOverlay

shouldRotateTabRuns

protected boolean shouldRotateTabRuns(int tabPlacement,
                                      int selectedRun)

shouldPadTabRun

protected boolean shouldPadTabRun(int tabPlacement,
                                  int run)
覆盖：
类 BasicTabbedPaneUI 中的 shouldPadTabRun
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalTabbedPaneUI.TabbedPaneLayout (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalTabbedPaneUI.TabbedPaneLayout

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
        继承者  javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
所有已实现的接口：
LayoutManager
正在封闭类：
MetalTabbedPaneUI
public class MetalTabbedPaneUI.TabbedPaneLayout
extends BasicTabbedPaneUI.TabbedPaneLayout

此内部类由于编译器故障而被标记为 "public"。此类应该视为“受保护”内部类。仅在 MetalTabbedPaneUI 的子类中实例化此类。

构造方法摘要
MetalTabbedPaneUI.TabbedPaneLayout()
方法摘要
protected void | normalizeTabRuns(int tabPlacement, int tabCount, int start, int max)
protected void | padSelectedTab(int tabPlacement, int selectedIndex)
protected void | rotateTabRuns(int tabPlacement, int selectedRun)
从类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 继承的方法
addLayoutComponent, calculateLayoutInfo, calculateSize, calculateTabRects, layoutContainer, minimumLayoutSize, padTabRun, preferredLayoutSize, preferredTabAreaHeight, preferredTabAreaWidth, removeLayoutComponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalTabbedPaneUI.TabbedPaneLayout

public MetalTabbedPaneUI.TabbedPaneLayout()
方法详细信息

normalizeTabRuns

protected void normalizeTabRuns(int tabPlacement,
                                int tabCount,
                                int start,
                                int max)
覆盖：
类 BasicTabbedPaneUI.TabbedPaneLayout 中的 normalizeTabRuns

rotateTabRuns

protected void rotateTabRuns(int tabPlacement,
                             int selectedRun)
覆盖：
类 BasicTabbedPaneUI.TabbedPaneLayout 中的 rotateTabRuns

padSelectedTab

protected void padSelectedTab(int tabPlacement,
                              int selectedIndex)
覆盖：
类 BasicTabbedPaneUI.TabbedPaneLayout 中的 padSelectedTab
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalTextFieldUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalTextFieldUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.basic.BasicTextUI
                继承者  javax.swing.plaf.basic.BasicTextFieldUI
                    继承者  javax.swing.plaf.metal.MetalTextFieldUI
所有已实现的接口：
ViewFactory
public class MetalTextFieldUI
extends BasicTextFieldUI

JTextField 外观的基础。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTextUI 继承的嵌套类/接口
BasicTextUI.BasicCaret, BasicTextUI.BasicHighlighter
构造方法摘要
MetalTextFieldUI()
方法摘要
static ComponentUI | createUI(JComponent c)
void | propertyChange(PropertyChangeEvent evt) 此方法在关联的 JTextComponent 上的绑定 (bound) 属性发生更改时调用。
从类 javax.swing.plaf.basic.BasicTextFieldUI 继承的方法
create, getBaseline, getBaselineResizeBehavior, getPropertyPrefix
从类 javax.swing.plaf.basic.BasicTextUI 继承的方法
create, createCaret, createHighlighter, createKeymap, damageRange, damageRange, getComponent, getEditorKit, getKeymapName, getMaximumSize, getMinimumSize, getNextVisualPositionFrom, getPreferredSize, getRootView, getToolTipText, getVisibleEditorRect, installDefaults, installKeyboardActions, installListeners, installUI, modelChanged, modelToView, modelToView, paint, paintBackground, paintSafely, setView, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, uninstallUI, update, viewToModel, viewToModel
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalTextFieldUI

public MetalTextFieldUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

propertyChange

public void propertyChange(PropertyChangeEvent evt)
此方法在关联的 JTextComponent 上的绑定 (bound) 属性发生更改时调用。此方法是一个钩子 (hook)，UI 实现可以更改它来反映 UI 显示 JTextComponent 子类的绑定属性的方式。

覆盖：
类 BasicTextUI 中的 propertyChange
参数：
evt - 属性更改事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalTheme (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalTheme

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalTheme
直接已知子类：
DefaultMetalTheme
public abstract class MetalTheme
extends Object

MetalTheme 提供 Java 外观所使用的调色板和字体。

MetalTheme 是抽象的，有关具体实现，请参阅 DefaultMetalTheme 和 OceanTheme。

MetalLookAndFeel 维护 metal 的 ComponentUI 实现所使用的当前主题。有关更改当前主题的详细信息，请参阅 MetalLookAndFeel.setCurrentTheme(MetalTheme)。

MetalTheme 提供获取颜色的多个公共方法。根据几个受保护的抽象方法实现这些方法。子类只需要重写受保护的抽象方法（getPrimary1、getPrimary2、getPrimary3、getSecondary1、getSecondary2 和 getSecondary3）；虽然子类也可以重写其他公共方法以对使用的颜色集进行更多控制。

MetalTheme 的具体实现必须从所有方法中返回非 null 值。由于没有指定返回 null 的行为，所以返回 null 将导致不正确的行为。

建议子类最好返回完全不透明颜色。否则会导致呈现问题，比如可视化垃圾（visual garbage）。

另请参见：
DefaultMetalTheme, OceanTheme, MetalLookAndFeel.setCurrentTheme(javax.swing.plaf.metal.MetalTheme)

构造方法摘要
MetalTheme()
方法摘要
void | addCustomEntriesToTable(UIDefaults table) 将特定于此主题的值添加到默认表。
ColorUIResource | getAcceleratorForeground() 返回加速器前景色。
ColorUIResource | getAcceleratorSelectedForeground() 返回加速器选中前景色。
protected ColorUIResource | getBlack() 返回黑色。
ColorUIResource | getControl() 返回控件颜色。
ColorUIResource | getControlDarkShadow() 返回控件加黑阴影颜色。
ColorUIResource | getControlDisabled() 返回控件禁用的颜色。
ColorUIResource | getControlHighlight() 返回控件高亮显示颜色。
ColorUIResource | getControlInfo() 返回控件信息颜色。
ColorUIResource | getControlShadow() 返回控件阴影颜色。
ColorUIResource | getControlTextColor() 返回控件文本颜色。
abstract FontUIResource | getControlTextFont() 返回控件文本字体。
ColorUIResource | getDesktopColor() 返回桌面颜色。
ColorUIResource | getFocusColor() 返回焦点颜色。
ColorUIResource | getHighlightedTextColor() 返回高亮显示的文本颜色。
ColorUIResource | getInactiveControlTextColor() 返回非活动控件文本颜色。
ColorUIResource | getInactiveSystemTextColor() 返回非活动系统文本颜色。
ColorUIResource | getMenuBackground() 返回菜单背景色。
ColorUIResource | getMenuDisabledForeground() 返回菜单禁用前景色。
ColorUIResource | getMenuForeground() 返回菜单前景色。
ColorUIResource | getMenuSelectedBackground() 返回菜单选中背景色。
ColorUIResource | getMenuSelectedForeground() 返回菜单选中前景色。
abstract FontUIResource | getMenuTextFont() 返回菜单文本字体。
abstract String | getName() 返回此主题的名称。
protected abstract ColorUIResource | getPrimary1() 返回 primary 1 颜色。
protected abstract ColorUIResource | getPrimary2() 返回 primary 2 颜色。
protected abstract ColorUIResource | getPrimary3() 返回 primary 3 颜色。
ColorUIResource | getPrimaryControl() 返回 primary 控件颜色。
ColorUIResource | getPrimaryControlDarkShadow() 返回 primary 控件加黑阴影颜色。
ColorUIResource | getPrimaryControlHighlight() 返回 primary 控件高亮显示颜色。
ColorUIResource | getPrimaryControlInfo() 返回 primary 控件信息颜色。
ColorUIResource | getPrimaryControlShadow() 返回 primary 控件阴影颜色。
protected abstract ColorUIResource | getSecondary1() 返回 secondary 1 颜色。
protected abstract ColorUIResource | getSecondary2() 返回 secondary 2 颜色。
protected abstract ColorUIResource | getSecondary3() 返回 secondary 3 颜色。
ColorUIResource | getSeparatorBackground() 返回分隔符背景色。
ColorUIResource | getSeparatorForeground() 返回分隔符前景色。
abstract FontUIResource | getSubTextFont() 返回子文本字体。
ColorUIResource | getSystemTextColor() 返回系统文本颜色。
abstract FontUIResource | getSystemTextFont() 返回系统文本字体。
ColorUIResource | getTextHighlightColor() 返回文本高亮显示的颜色。
ColorUIResource | getUserTextColor() 返回用户文本颜色。
abstract FontUIResource | getUserTextFont() 返回用户文本字体。
protected ColorUIResource | getWhite() 返回白色。
ColorUIResource | getWindowBackground() 返回窗口背景色。
ColorUIResource | getWindowTitleBackground() 返回窗口标题背景色。
abstract FontUIResource | getWindowTitleFont() 返回窗口标题字体。
ColorUIResource | getWindowTitleForeground() 返回窗口标题前景色。
ColorUIResource | getWindowTitleInactiveBackground() 返回窗口标题非活动背景色。
ColorUIResource | getWindowTitleInactiveForeground() 返回窗口标题非活动前景色。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalTheme

public MetalTheme()
方法详细信息

getName

public abstract String getName()
返回此主题的名称。

返回：
此主题的名称

getPrimary1

protected abstract ColorUIResource getPrimary1()
返回 primary 1 颜色。

返回：
primary 1 颜色

getPrimary2

protected abstract ColorUIResource getPrimary2()
返回 primary 2 颜色。

返回：
primary 2 颜色

getPrimary3

protected abstract ColorUIResource getPrimary3()
返回 primary 3 颜色。

返回：
primary 3 颜色

getSecondary1

protected abstract ColorUIResource getSecondary1()
返回 secondary 1 颜色。

返回：
secondary 1 颜色

getSecondary2

protected abstract ColorUIResource getSecondary2()
返回 secondary 2 颜色。

返回：
secondary 2 颜色

getSecondary3

protected abstract ColorUIResource getSecondary3()
返回 secondary 3 颜色。

返回：
secondary 3 颜色

getControlTextFont

public abstract FontUIResource getControlTextFont()
返回控件文本字体。

返回：
控件文本字体

getSystemTextFont

public abstract FontUIResource getSystemTextFont()
返回系统文本字体。

返回：
系统文本字体

getUserTextFont

public abstract FontUIResource getUserTextFont()
返回用户文本字体。

返回：
用户文本字体

getMenuTextFont

public abstract FontUIResource getMenuTextFont()
返回菜单文本字体。

返回：
菜单文本字体

getWindowTitleFont

public abstract FontUIResource getWindowTitleFont()
返回窗口标题字体。

返回：
窗口标题字体

getSubTextFont

public abstract FontUIResource getSubTextFont()
返回子文本字体。

返回：
子文本字体

getWhite

protected ColorUIResource getWhite()
返回白色。此方法返回不透明白色（0xFFFFFFFF）。

返回：
白色

getBlack

protected ColorUIResource getBlack()
返回黑色。此方法返回不透明黑色（0xFF000000）。

返回：
黑色

getFocusColor

public ColorUIResource getFocusColor()
返回焦点颜色。此方法返回 getPrimary2() 的值。

返回：
焦点颜色

getDesktopColor

public ColorUIResource getDesktopColor()
返回桌面颜色。此方法返回 getPrimary2() 的值。

返回：
桌面颜色

getControl

public ColorUIResource getControl()
返回控件颜色。此方法返回 getSecondary3() 的值。

返回：
控件颜色

getControlShadow

public ColorUIResource getControlShadow()
返回控件阴影颜色。此方法返回 getSecondary2() 的值。

返回：
控件阴影颜色

getControlDarkShadow

public ColorUIResource getControlDarkShadow()
返回控件加黑阴影颜色。此方法返回 getSecondary1() 的值。

返回：
控件加黑阴影颜色

getControlInfo

public ColorUIResource getControlInfo()
返回控件信息颜色。此方法返回 getBlack() 的值。

返回：
控件信息颜色

getControlHighlight

public ColorUIResource getControlHighlight()
返回控件高亮显示颜色。此方法返回 getWhite() 的值。

返回：
控件高亮显示颜色

getControlDisabled

public ColorUIResource getControlDisabled()
返回控件禁用的颜色。此方法返回 getSecondary2() 的值。

返回：
控件禁用的颜色

getPrimaryControl

public ColorUIResource getPrimaryControl()
返回 primary 控件颜色。此方法返回 getPrimary3() 的值。

返回：
primary 控件颜色

getPrimaryControlShadow

public ColorUIResource getPrimaryControlShadow()
返回 primary 控件阴影颜色。此方法返回 getPrimary2() 的值。

返回：
primary 控件阴影颜色

getPrimaryControlDarkShadow

public ColorUIResource getPrimaryControlDarkShadow()
返回 primary 控件加黑阴影颜色。此方法返回 getPrimary1() 的值。

返回：
primary 控件加黑阴影颜色

getPrimaryControlInfo

public ColorUIResource getPrimaryControlInfo()
返回 primary 控件信息颜色。此方法返回 getBlack() 的值。

返回：
primary 控件信息颜色

getPrimaryControlHighlight

public ColorUIResource getPrimaryControlHighlight()
返回 primary 控件高亮显示颜色。此方法返回 getWhite() 的值。

返回：
primary 控件高亮显示颜色

getSystemTextColor

public ColorUIResource getSystemTextColor()
返回系统文本颜色。此方法返回 getBlack() 的值。

返回：
系统文本颜色

getControlTextColor

public ColorUIResource getControlTextColor()
返回控件文本颜色。此方法返回 getControlInfo() 的值。

返回：
控件文本颜色

getInactiveControlTextColor

public ColorUIResource getInactiveControlTextColor()
返回非活动控件文本颜色。此方法返回 getControlDisabled() 的值。

返回：
非活动控件文本颜色

getInactiveSystemTextColor

public ColorUIResource getInactiveSystemTextColor()
返回非活动系统文本颜色。此方法返回 getSecondary2() 的值。

返回：
非活动系统文本颜色

getUserTextColor

public ColorUIResource getUserTextColor()
返回用户文本颜色。此方法返回 getBlack() 的值。

返回：
用户文本颜色

getTextHighlightColor

public ColorUIResource getTextHighlightColor()
返回文本高亮显示的颜色。此方法返回 getPrimary3() 的值。

返回：
文本高亮显示的颜色

getHighlightedTextColor

public ColorUIResource getHighlightedTextColor()
返回高亮显示的文本颜色。此方法返回 getControlTextColor() 的值。

返回：
高亮显示的文本颜色

getWindowBackground

public ColorUIResource getWindowBackground()
返回窗口背景色。此方法返回 getWhite() 的值。

返回：
窗口背景色

getWindowTitleBackground

public ColorUIResource getWindowTitleBackground()
返回窗口标题背景色。此方法返回 getPrimary3() 的值。

返回：
窗口标题背景色

getWindowTitleForeground

public ColorUIResource getWindowTitleForeground()
返回窗口标题前景色。此方法返回 getBlack() 的值。

返回：
窗口标题前景色

getWindowTitleInactiveBackground

public ColorUIResource getWindowTitleInactiveBackground()
返回窗口标题非活动背景色。此方法返回 getSecondary3() 的值。

返回：
窗口标题非活动背景色

getWindowTitleInactiveForeground

public ColorUIResource getWindowTitleInactiveForeground()
返回窗口标题非活动前景色。此方法返回 getBlack() 的值。

返回：
窗口标题非活动前景色

getMenuBackground

public ColorUIResource getMenuBackground()
返回菜单背景色。此方法返回 getSecondary3() 的值。

返回：
菜单背景色

getMenuForeground

public ColorUIResource getMenuForeground()
返回菜单前景色。此方法返回 getBlack() 的值。

返回：
菜单前景色

getMenuSelectedBackground

public ColorUIResource getMenuSelectedBackground()
返回菜单选中背景色。此方法返回 getPrimary2() 的值。

返回：
菜单选中背景色

getMenuSelectedForeground

public ColorUIResource getMenuSelectedForeground()
返回菜单选中前景色。此方法返回 getBlack() 的值。

返回：
菜单选中前景色

getMenuDisabledForeground

public ColorUIResource getMenuDisabledForeground()
返回菜单禁用前景色。此方法返回 getSecondary2() 的值。

返回：
菜单禁用前景色

getSeparatorBackground

public ColorUIResource getSeparatorBackground()
返回分隔符背景色。此方法返回 getWhite() 的值。

返回：
分隔符背景色

getSeparatorForeground

public ColorUIResource getSeparatorForeground()
返回分隔符前景色。此方法返回 getPrimary1() 的值。

返回：
分隔符前景色

getAcceleratorForeground

public ColorUIResource getAcceleratorForeground()
返回加速器前景色。此方法返回 getPrimary1() 的值。

返回：
加速器前景色

getAcceleratorSelectedForeground

public ColorUIResource getAcceleratorSelectedForeground()
返回加速器选中前景色。此方法返回 getBlack() 的值。

返回：
加速器选中前景色

addCustomEntriesToTable

public void addCustomEntriesToTable(UIDefaults table)
将特定于此主题的值添加到默认表。从 MetalLookAndFeel 获取外观默认值时调用此方法。

此实现不执行任何操作；它用于要定制默认表的子类。

参数：
table - 要向其中添加值的 UIDefaults
另请参见：
MetalLookAndFeel.getDefaults()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalToolBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalToolBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ToolBarUI
            继承者  javax.swing.plaf.basic.BasicToolBarUI
                继承者  javax.swing.plaf.metal.MetalToolBarUI
所有已实现的接口：
SwingConstants
public class MetalToolBarUI
extends BasicToolBarUI

ToolBarUI 的 Metal 外观实现。此实现是一个“组合的”视图/控制器。

嵌套类摘要
protected class | MetalToolBarUI.MetalContainerListener
protected class | MetalToolBarUI.MetalDockingListener
protected class | MetalToolBarUI.MetalRolloverListener
从类 javax.swing.plaf.basic.BasicToolBarUI 继承的嵌套类/接口
BasicToolBarUI.DockingListener, BasicToolBarUI.DragWindow, BasicToolBarUI.FrameListener, BasicToolBarUI.PropertyListener, BasicToolBarUI.ToolBarContListener, BasicToolBarUI.ToolBarFocusListener
字段摘要
protected ContainerListener | contListener 此受保护的字段是特定于实现的。
protected PropertyChangeListener | rolloverListener 此受保护的字段是特定于实现的。
从类 javax.swing.plaf.basic.BasicToolBarUI 继承的字段
constraintBeforeFloating, dockingBorderColor, dockingColor, dockingListener, downKey, dragWindow, floatingBorderColor, floatingColor, focusedCompIndex, leftKey, propertyListener, rightKey, toolBar, toolBarContListener, toolBarFocusListener, upKey
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
构造方法摘要
MetalToolBarUI()
方法摘要
protected ContainerListener | createContainerListener() 创建一个将添加到 JToolBar 中的容器侦听器。
protected MouseInputListener | createDockingListener()
protected Border | createNonRolloverBorder() 创建工具栏组件的非翻转边框。
protected Border | createRolloverBorder() 创建工具栏组件的翻转边框。
protected PropertyChangeListener | createRolloverListener() 创建一个将添加到 JToolBar 中的属性更改侦听器。
static ComponentUI | createUI(JComponent c)
protected void | installListeners()
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected void | setBorderToNonRollover(Component c) 将组件的边框设置为具有由 createNonRolloverBorder 创建的翻转边框。
protected void | setDragOffset(Point p)
protected void | uninstallListeners()
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
void | update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
从类 javax.swing.plaf.basic.BasicToolBarUI 继承的方法
canDock, createDragWindow, createFloatingFrame, createFloatingWindow, createFrameListener, createPropertyListener, createToolBarContListener, createToolBarFocusListener, dragTo, floatAt, getDockingColor, getFloatingColor, getNonRolloverBorder, getRolloverBorder, installComponents, installDefaults, installKeyboardActions, installNonRolloverBorders, installNormalBorders, installRolloverBorders, isFloating, isRolloverBorders, navigateFocusedComp, paintDragWindow, setBorderToNormal, setBorderToRollover, setDockingColor, setFloating, setFloatingColor, setFloatingLocation, setOrientation, setRolloverBorders, uninstallComponents, uninstallDefaults, uninstallKeyboardActions
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, getMaximumSize, getMinimumSize, getPreferredSize, paint
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

contListener

protected ContainerListener contListener
此受保护的字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createContainerListener()

rolloverListener

protected PropertyChangeListener rolloverListener
此受保护的字段是特定于实现的。不要直接访问或重写。可以改为使用创建方法。

另请参见：
createRolloverListener()
构造方法详细信息

MetalToolBarUI

public MetalToolBarUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 BasicToolBarUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 BasicToolBarUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

installListeners

protected void installListeners()
覆盖：
类 BasicToolBarUI 中的 installListeners

uninstallListeners

protected void uninstallListeners()
覆盖：
类 BasicToolBarUI 中的 uninstallListeners

createRolloverBorder

protected Border createRolloverBorder()
从类 BasicToolBarUI 复制的描述
创建工具栏组件的翻转边框。如果启用了翻转边框，则将安装翻转边框。

重写此方法以提供备用翻转边框。

覆盖：
类 BasicToolBarUI 中的 createRolloverBorder

createNonRolloverBorder

protected Border createNonRolloverBorder()
从类 BasicToolBarUI 复制的描述
创建工具栏组件的非翻转边框。如果启用翻转边框，则此边框将作为添加到工具栏的组件的边框安装。

重写此方法以提供备用翻转边框。

覆盖：
类 BasicToolBarUI 中的 createNonRolloverBorder

setBorderToNonRollover

protected void setBorderToNonRollover(Component c)
从类 BasicToolBarUI 复制的描述
将组件的边框设置为具有由 createNonRolloverBorder 创建的翻转边框。

覆盖：
类 BasicToolBarUI 中的 setBorderToNonRollover
参数：
c - 将安装翻转边框的组件
另请参见：
BasicToolBarUI.createNonRolloverBorder()

createContainerListener

protected ContainerListener createContainerListener()
创建一个将添加到 JToolBar 中的容器侦听器。如果此方法返回 null，则不会将该侦听器添加到工具栏中。

返回：
一个 ContainerListener 实例或 null

createRolloverListener

protected PropertyChangeListener createRolloverListener()
创建一个将添加到 JToolBar 中的属性更改侦听器。如果此方法返回 null，则不会将该侦听器添加到工具栏中。

返回：
一个 PropertyChangeListener 实例或 null

createDockingListener

protected MouseInputListener createDockingListener()
覆盖：
类 BasicToolBarUI 中的 createDockingListener

setDragOffset

protected void setDragOffset(Point p)

update

public void update(Graphics g,
                   JComponent c)
如果必要，绘制组件的背景，然后调用 paint。

覆盖：
类 ComponentUI 中的 update
参数：
g - 作为绘制目标的 Graphic
c - 要在其上进行绘制的 JComponent
抛出：
NullPointerException - 如果 g 或 c 为 null
从以下版本开始：
1.5
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent), ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalToggleButtonUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalToggleButtonUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.basic.BasicButtonUI
                继承者  javax.swing.plaf.basic.BasicToggleButtonUI
                    继承者  javax.swing.plaf.metal.MetalToggleButtonUI

public class MetalToggleButtonUI
extends BasicToggleButtonUI

MetalToggleButton 实现

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected Color | disabledTextColor
protected Color | focusColor
protected Color | selectColor
从类 javax.swing.plaf.basic.BasicButtonUI 继承的字段
defaultTextIconGap, defaultTextShiftOffset
构造方法摘要
MetalToggleButtonUI()
方法摘要
static ComponentUI | createUI(JComponent b)
protected Color | getDisabledTextColor()
protected Color | getFocusColor()
protected Color | getSelectColor()
void | installDefaults(AbstractButton b)
protected void | paintButtonPressed(Graphics g, AbstractButton b)
protected void | paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | paintIcon(Graphics g, AbstractButton b, Rectangle iconRect) 在空间 iconRect 中绘制按钮 b 的适当图标。
protected void | paintText(Graphics g, JComponent c, Rectangle textRect, String text) 从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
protected void | uninstallDefaults(AbstractButton b)
void | update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
从类 javax.swing.plaf.basic.BasicToggleButtonUI 继承的方法
getPropertyPrefix, getTextShiftOffset, paint
从类 javax.swing.plaf.basic.BasicButtonUI 继承的方法
clearTextShiftOffset, createButtonListener, getBaseline, getBaselineResizeBehavior, getDefaultTextIconGap, getMaximumSize, getMinimumSize, getPreferredSize, installKeyboardActions, installListeners, installUI, paintIcon, paintText, setTextShiftOffset, uninstallKeyboardActions, uninstallListeners, uninstallUI
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

focusColor

protected Color focusColor

selectColor

protected Color selectColor

disabledTextColor

protected Color disabledTextColor
构造方法详细信息

MetalToggleButtonUI

public MetalToggleButtonUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent b)

installDefaults

public void installDefaults(AbstractButton b)
覆盖：
类 BasicButtonUI 中的 installDefaults

uninstallDefaults

protected void uninstallDefaults(AbstractButton b)
覆盖：
类 BasicButtonUI 中的 uninstallDefaults

getSelectColor

protected Color getSelectColor()

getDisabledTextColor

protected Color getDisabledTextColor()

getFocusColor

protected Color getFocusColor()

update

public void update(Graphics g,
                   JComponent c)
如果必要，绘制组件的背景，然后调用 paint。

覆盖：
类 ComponentUI 中的 update
参数：
g - 作为绘制目标的 Graphic
c - 要在其上进行绘制的 JComponent
抛出：
NullPointerException - 如果 g 或 c 为 null
从以下版本开始：
1.5
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent), ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent)

paintButtonPressed

protected void paintButtonPressed(Graphics g,
                                  AbstractButton b)
覆盖：
类 BasicButtonUI 中的 paintButtonPressed

paintText

protected void paintText(Graphics g,
                         JComponent c,
                         Rectangle textRect,
                         String text)
从类 BasicButtonUI 复制的描述
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。改为使用带有 AbstractButton 参数的 paintText 方法。

覆盖：
类 BasicButtonUI 中的 paintText

paintFocus

protected void paintFocus(Graphics g,
                          AbstractButton b,
                          Rectangle viewRect,
                          Rectangle textRect,
                          Rectangle iconRect)
覆盖：
类 BasicButtonUI 中的 paintFocus

paintIcon

protected void paintIcon(Graphics g,
                         AbstractButton b,
                         Rectangle iconRect)
在空间 iconRect 中绘制按钮 b 的适当图标。

覆盖：
类 BasicToggleButtonUI 中的 paintIcon
参数：
g - 作为绘制目标的 Graphic
b - 要呈现的按钮
iconRect - 呈现按钮的空间
抛出：
NullPointerException - 如果任意参数为 null。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalToolBarUI.MetalContainerListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalToolBarUI.MetalContainerListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
        继承者  javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
所有已实现的接口：
ContainerListener, EventListener
正在封闭类：
MetalToolBarUI
protected class MetalToolBarUI.MetalContainerListener
extends BasicToolBarUI.ToolBarContListener

构造方法摘要
protected MetalToolBarUI.MetalContainerListener()
方法摘要
从类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 继承的方法
componentAdded, componentRemoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalToolBarUI.MetalContainerListener

protected MetalToolBarUI.MetalContainerListener()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalToolBarUI.MetalDockingListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalToolBarUI.MetalDockingListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicToolBarUI.DockingListener
        继承者  javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
所有已实现的接口：
MouseListener, MouseMotionListener, EventListener, MouseInputListener
正在封闭类：
MetalToolBarUI
protected class MetalToolBarUI.MetalDockingListener
extends BasicToolBarUI.DockingListener

字段摘要
从类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 继承的字段
isDragging, origin, toolBar
构造方法摘要
MetalToolBarUI.MetalDockingListener(JToolBar t)
方法摘要
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
从类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 继承的方法
mouseClicked, mouseEntered, mouseExited, mouseMoved, mouseReleased
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalToolBarUI.MetalDockingListener

public MetalToolBarUI.MetalDockingListener(JToolBar t)
方法详细信息

mousePressed

public void mousePressed(MouseEvent e)
从接口 MouseListener 复制的描述
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 BasicToolBarUI.DockingListener 中的 mousePressed

mouseDragged

public void mouseDragged(MouseEvent e)
从接口 MouseMotionListener 复制的描述
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 BasicToolBarUI.DockingListener 中的 mouseDragged
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalToolBarUI.MetalRolloverListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalToolBarUI.MetalRolloverListener

java.lang.Object
    继承者  javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
        继承者  javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
所有已实现的接口：
PropertyChangeListener, EventListener
正在封闭类：
MetalToolBarUI
protected class MetalToolBarUI.MetalRolloverListener
extends BasicToolBarUI.PropertyListener

构造方法摘要
protected MetalToolBarUI.MetalRolloverListener()
方法摘要
从类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener 继承的方法
propertyChange
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalToolBarUI.MetalRolloverListener

protected MetalToolBarUI.MetalRolloverListener()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalToolTipUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalToolTipUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ToolTipUI
            继承者  javax.swing.plaf.basic.BasicToolTipUI
                继承者  javax.swing.plaf.metal.MetalToolTipUI

public class MetalToolTipUI
extends BasicToolTipUI

BasicToolTipUI 的 Metal L&F 扩展。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
static int padSpaceBetweenStrings
构造方法摘要
MetalToolTipUI()
方法摘要
static ComponentUI | createUI(JComponent c)
String | getAcceleratorString()
Dimension | getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected boolean | isAcceleratorHidden()
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.basic.BasicToolTipUI 继承的方法
getMaximumSize, getMinimumSize, installDefaults, installListeners, uninstallDefaults, uninstallListeners
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, getBaseline, getBaselineResizeBehavior, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

padSpaceBetweenStrings

public static final int padSpaceBetweenStrings
另请参见：
常量字段值
构造方法详细信息

MetalToolTipUI

public MetalToolTipUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent c)

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 BasicToolTipUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 BasicToolTipUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 BasicToolTipUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent c)
从类 ComponentUI 复制的描述
返回指定组件的适合外观的首选大小。如果返回 null，则首选大小将由组件的布局管理器计算（对于安装了特定布局管理器的组件而言，这是首选方法）。此方法的默认实现返回 null。

覆盖：
类 BasicToolTipUI 中的 getPreferredSize
参数：
c - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

isAcceleratorHidden

protected boolean isAcceleratorHidden()

getAcceleratorString

public String getAcceleratorString()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetalTreeUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 MetalTreeUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TreeUI
            继承者  javax.swing.plaf.basic.BasicTreeUI
                继承者  javax.swing.plaf.metal.MetalTreeUI

public class MetalTreeUI
extends BasicTreeUI

TreeUI 的 metal 外观实现。

MetalTreeUI 允许配置如何在视觉上呈现节点之间的间隔和描绘。支持以下提示：

Angled | 绘制一条连接子节点和父节点的线。关于如何处理根节点，请参阅 JTree.setRootVisible(boolean) 和 JTree.setShowsRootHandles(boolean)。
Horizontal | 绘制用来分隔根节点的子节点的一条水平线。
None | 不在节点间绘制任何可见的指示。

因为通常无法从 JTree 中获得 TreeUI 并将它强制转换成 MetalTreeUI 实例，所以要通过客户端属性 JTree.lineStyle 启用此属性。例如，要切换成 Horizontal 风格，需要这样做：tree.putClientProperty("JTree.lineStyle", "Horizontal");

默认值为 Angled。

嵌套类摘要
从类 javax.swing.plaf.basic.BasicTreeUI 继承的嵌套类/接口
BasicTreeUI.CellEditorHandler, BasicTreeUI.ComponentHandler, BasicTreeUI.FocusHandler, BasicTreeUI.KeyHandler, BasicTreeUI.MouseHandler, BasicTreeUI.MouseInputHandler, BasicTreeUI.NodeDimensionsHandler, BasicTreeUI.PropertyChangeHandler, BasicTreeUI.SelectionModelPropertyChangeHandler, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeExpansionHandler, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreeModelHandler, BasicTreeUI.TreePageAction, BasicTreeUI.TreeSelectionHandler, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction
字段摘要
从类 javax.swing.plaf.basic.BasicTreeUI 继承的字段
cellEditor, collapsedIcon, createdCellEditor, createdRenderer, currentCellRenderer, depthOffset, drawingCache, editingComponent, editingPath, editingRow, editorHasDifferentSize, expandedIcon, largeModel, lastSelectedRow, leftChildIndent, nodeDimensions, preferredMinSize, preferredSize, rendererPane, rightChildIndent, stopEditingInCompleteEditing, totalChildIndent, tree, treeModel, treeSelectionModel, treeState, validCachedPreferredSize
构造方法摘要
MetalTreeUI()
方法摘要
static ComponentUI | createUI(JComponent x)
protected void | decodeLineStyle(Object lineStyleFlag) 此方法进行传入客户端属性中的字符串和内部表示形式（当前的并且用 int 值表示）之间的转换
protected int | getHorizontalLegBuffer() 默认情况下，节点间支路的水平元素开始于子节点左侧的右边。
void | installUI(JComponent c) 配置指定组件，使其适合外观。
protected boolean | isLocationInExpandControl(int row, int rowLevel, int mouseX, int mouseY)
void | paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
protected void | paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制支路 (leg) 的水平部分。
protected void | paintHorizontalSeparators(Graphics g, JComponent c)
protected void | paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path) 绘制支路的垂直部分。
void | uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
从类 javax.swing.plaf.basic.BasicTreeUI 继承的方法
cancelEditing, checkForClickInExpandControl, completeEditing, completeEditing, completeUIInstall, completeUIUninstall, configureLayoutCache, createCellEditorListener, createCellRendererPane, createComponentListener, createDefaultCellEditor, createDefaultCellRenderer, createFocusListener, createKeyListener, createLayoutCache, createMouseListener, createNodeDimensions, createPropertyChangeListener, createSelectionModelPropertyChangeListener, createTreeExpansionListener, createTreeModelListener, createTreeSelectionListener, drawCentered, drawDashedHorizontalLine, drawDashedVerticalLine, ensureRowsAreVisible, getBaseline, getBaselineResizeBehavior, getCellEditor, getCellRenderer, getClosestPathForLocation, getCollapsedIcon, getEditingPath, getExpandedIcon, getHashColor, getLastChildPath, getLeftChildIndent, getMaximumSize, getMinimumSize, getModel, getPathBounds, getPathForRow, getPreferredMinSize, getPreferredSize, getPreferredSize, getRightChildIndent, getRowCount, getRowForPath, getRowHeight, getRowX, getSelectionModel, getShowsRootHandles, getVerticalLegBuffer, handleExpandControlClick, installComponents, installDefaults, installKeyboardActions, installListeners, isEditable, isEditing, isLargeModel, isLeaf, isLocationInExpandControl, isMultiSelectEvent, isRootVisible, isToggleEvent, isToggleSelectionEvent, paintExpandControl, paintHorizontalLine, paintRow, paintVerticalLine, pathWasCollapsed, pathWasExpanded, prepareForUIInstall, prepareForUIUninstall, selectPathForEvent, setCellEditor, setCellRenderer, setCollapsedIcon, setEditable, setExpandedIcon, setHashColor, setLargeModel, setLeftChildIndent, setModel, setPreferredMinSize, setRightChildIndent, setRootVisible, setRowHeight, setSelectionModel, setShowsRootHandles, shouldPaintExpandControl, startEditing, startEditingAtPath, stopEditing, toggleExpandState, uninstallComponents, uninstallDefaults, uninstallKeyboardActions, uninstallListeners, updateCachedPreferredSize, updateCellEditor, updateDepthOffset, updateExpandedDescendants, updateLayoutCacheExpandedNodes, updateRenderer, updateSize
从类 javax.swing.plaf.ComponentUI 继承的方法
contains, getAccessibleChild, getAccessibleChildrenCount, update
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MetalTreeUI

public MetalTreeUI()
方法详细信息

createUI

public static ComponentUI createUI(JComponent x)

getHorizontalLegBuffer

protected int getHorizontalLegBuffer()
从类 BasicTreeUI 复制的描述
默认情况下，节点间支路的水平元素开始于子节点左侧的右边。此方法能让支路在该位置以前结束。

覆盖：
类 BasicTreeUI 中的 getHorizontalLegBuffer

installUI

public void installUI(JComponent c)
从类 ComponentUI 复制的描述
配置指定组件，使其适合外观。当 ComponentUI 实例将作为 UI 委托安装在指定组件上时，可调用此方法。此方法应该为外观完整地配置组件，包括以下方面：
  1. 在组件上安装用于颜色、字体、边框、图标、不透明性等方面的所有默认属性值。只要有可能，就不 应该重写由客户端程序初始化的属性值。
  2. 如有必要，可在组件上安装一个 LayoutManager。
  3. 将所需的所有子组件创建/添加到组件中。
  4. 在组件上创建/安装事件侦听器。
  5. 为了检测和适当响应组件属性更改，可在组件上创建/安装一个 PropertyChangeListener。
  6. 在组件上安装键盘 UI（助记符、遍历等等）。
  7. 初始化任何适当的实例数据。

覆盖：
类 BasicTreeUI 中的 installUI
参数：
c - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent c)
从类 ComponentUI 复制的描述
在 installUI 期间，在指定组件上反向执行的配置操作。当此 UIComponent 实例将作为 UI 委托从指定组件上移除时，可调用此方法。此方法应该取消在 installUI 中执行的配置操作，非常小心地使 JComponent 实例处于某种洁净状态（没有额外的侦听器、没有特定于外观的属性对象等等)。配置内容应该包括以下方面：
  1. 从组件中移除所有 UI 设置的边框。
  2. 从组件上移除所有 UI 设置的布局管理器。
  3. 从组件中移除所有 UI 添加的子组件。
  4. 从组件中移除所有 UI 添加的事件/属性侦听器。
  5. 从组件中移除所有 UI 安装的键盘 UI。
  6. 使所有已分配的实例数据对象无效，从而允许进行 GC 操作。

覆盖：
类 BasicTreeUI 中的 uninstallUI
参数：
c - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

decodeLineStyle

protected void decodeLineStyle(Object lineStyleFlag)
此方法进行传入客户端属性中的字符串和内部表示形式（当前的并且用 int 值表示）之间的转换

isLocationInExpandControl

protected boolean isLocationInExpandControl(int row,
                                            int rowLevel,
                                            int mouseX,
                                            int mouseY)

paint

public void paint(Graphics g,
                  JComponent c)
从类 ComponentUI 复制的描述
绘制指定组件，使其适合外观。在将要绘制指定组件时，从 ComponentUI.update 方法中调用此方法。子类应该重写此方法并使用指定 Graphics 对象来呈现组件的内容。

覆盖：
类 BasicTreeUI 中的 paint
参数：
g - 将在其中进行绘制的 Graphics 上下文
c - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

paintHorizontalSeparators

protected void paintHorizontalSeparators(Graphics g,
                                         JComponent c)

paintVerticalPartOfLeg

protected void paintVerticalPartOfLeg(Graphics g,
                                      Rectangle clipBounds,
                                      Insets insets,
                                      TreePath path)
从类 BasicTreeUI 复制的描述
绘制支路的垂直部分。接收者不应修改 clipBounds、insets。

覆盖：
类 BasicTreeUI 中的 paintVerticalPartOfLeg

paintHorizontalPartOfLeg

protected void paintHorizontalPartOfLeg(Graphics g,
                                        Rectangle clipBounds,
                                        Insets insets,
                                        Rectangle bounds,
                                        TreePath path,
                                        int row,
                                        boolean isExpanded,
                                        boolean hasBeenExpanded,
                                        boolean isLeaf)
从类 BasicTreeUI 复制的描述
绘制支路 (leg) 的水平部分。接收者不应修改 clipBounds 或 insets。

注：如果树不可见，则 parentRow 为 -1。

覆盖：
类 BasicTreeUI 中的 paintHorizontalPartOfLeg
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OceanTheme (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.metal
类 OceanTheme

java.lang.Object
    继承者  javax.swing.plaf.metal.MetalTheme
        继承者  javax.swing.plaf.metal.DefaultMetalTheme
            继承者  javax.swing.plaf.metal.OceanTheme

public class OceanTheme
extends DefaultMetalTheme

MetalLookAndFeel 的默认主题。

Metal 外观的设计人员尽量保持默认外观的更新，在将来可能使用新的主题。所以，在希望定制 "Ocean" 外观时，开发人员应该直接使用此类，或强制使用它作为当前主题，不用顾及将来的更新。

OceanTheme 返回的所有颜色都是完全不透明的。

从以下版本开始：
1.5
另请参见：
MetalLookAndFeel.setCurrentTheme(javax.swing.plaf.metal.MetalTheme)

构造方法摘要
OceanTheme()
创建一个 OceanTheme 实例
方法摘要
void | addCustomEntriesToTable(UIDefaults table) 将此主题的自定义条目添加到默认表中。
protected ColorUIResource | getBlack() 返回黑色。
ColorUIResource | getControlTextColor() 返回控件文本颜色。
ColorUIResource | getDesktopColor() 返回桌面颜色。
ColorUIResource | getInactiveControlTextColor() 返回非活动控件文本颜色。
ColorUIResource | getMenuDisabledForeground() 返回菜单禁用前景色。
String | getName() 返回此主题的名称，即 "Ocean"。
protected ColorUIResource | getPrimary1() 返回 primary 1 颜色。
protected ColorUIResource | getPrimary2() 返回 primary 2 颜色。
protected ColorUIResource | getPrimary3() 返回 primary 3 颜色。
protected ColorUIResource | getSecondary1() 返回 secondary 1 颜色。
protected ColorUIResource | getSecondary2() 返回 secondary 2 颜色。
protected ColorUIResource | getSecondary3() 返回 secondary 3 颜色。
从类 javax.swing.plaf.metal.DefaultMetalTheme 继承的方法
getControlTextFont, getMenuTextFont, getSubTextFont, getSystemTextFont, getUserTextFont, getWindowTitleFont
从类 javax.swing.plaf.metal.MetalTheme 继承的方法
getAcceleratorForeground, getAcceleratorSelectedForeground, getControl, getControlDarkShadow, getControlDisabled, getControlHighlight, getControlInfo, getControlShadow, getFocusColor, getHighlightedTextColor, getInactiveSystemTextColor, getMenuBackground, getMenuForeground, getMenuSelectedBackground, getMenuSelectedForeground, getPrimaryControl, getPrimaryControlDarkShadow, getPrimaryControlHighlight, getPrimaryControlInfo, getPrimaryControlShadow, getSeparatorBackground, getSeparatorForeground, getSystemTextColor, getTextHighlightColor, getUserTextColor, getWhite, getWindowBackground, getWindowTitleBackground, getWindowTitleForeground, getWindowTitleInactiveBackground, getWindowTitleInactiveForeground
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OceanTheme

public OceanTheme()
创建一个 OceanTheme 实例

方法详细信息

addCustomEntriesToTable

public void addCustomEntriesToTable(UIDefaults table)
将此主题的自定义条目添加到默认表中。

覆盖：
类 MetalTheme 中的 addCustomEntriesToTable
参数：
table - 非 null 的默认表
抛出：
NullPointerException - 如果 table 为 null
另请参见：
MetalLookAndFeel.getDefaults()

getName

public String getName()
返回此主题的名称，即 "Ocean"。

覆盖：
类 DefaultMetalTheme 中的 getName
返回：
"Ocean"

getPrimary1

protected ColorUIResource getPrimary1()
返回 primary 1 颜色。此方法返回 rgb 十六进制值为 0x6382BF 的颜色。

覆盖：
类 DefaultMetalTheme 中的 getPrimary1
返回：
primary 1 颜色
另请参见：
Color.decode(java.lang.String)

getPrimary2

protected ColorUIResource getPrimary2()
返回 primary 2 颜色。此方法返回 rgb 十六进制值为 0xA3B8CC 的颜色。

覆盖：
类 DefaultMetalTheme 中的 getPrimary2
返回：
primary 2 颜色
另请参见：
Color.decode(java.lang.String)

getPrimary3

protected ColorUIResource getPrimary3()
返回 primary 3 颜色。此方法返回 rgb 十六进制值为 0xB8CFE5 的颜色。

覆盖：
类 DefaultMetalTheme 中的 getPrimary3
返回：
primary 3 颜色
另请参见：
Color.decode(java.lang.String)

getSecondary1

protected ColorUIResource getSecondary1()
返回 secondary 1 颜色。此方法返回 rgb 十六进制值为 0x7A8A99 的颜色。

覆盖：
类 DefaultMetalTheme 中的 getSecondary1
返回：
secondary 1 颜色
另请参见：
Color.decode(java.lang.String)

getSecondary2

protected ColorUIResource getSecondary2()
返回 secondary 2 颜色。此方法返回 rgb 十六进制值为 0xB8CFE5 的颜色。

覆盖：
类 DefaultMetalTheme 中的 getSecondary2
返回：
secondary 2 颜色
另请参见：
Color.decode(java.lang.String)

getSecondary3

protected ColorUIResource getSecondary3()
返回 secondary 3 颜色。此方法返回 rgb 十六进制值为 0xEEEEEE 的颜色。

覆盖：
类 DefaultMetalTheme 中的 getSecondary3
返回：
secondary 3 颜色
另请参见：
Color.decode(java.lang.String)

getBlack

protected ColorUIResource getBlack()
返回黑色。此方法返回 rgb 十六进制值为 0x333333 的颜色。

覆盖：
类 MetalTheme 中的 getBlack
返回：
黑色
另请参见：
Color.decode(java.lang.String)

getDesktopColor

public ColorUIResource getDesktopColor()
返回桌面颜色。此方法返回 rgb 十六进制值为 0xFFFFFF 的颜色。

覆盖：
类 MetalTheme 中的 getDesktopColor
返回：
桌面颜色
另请参见：
Color.decode(java.lang.String)

getInactiveControlTextColor

public ColorUIResource getInactiveControlTextColor()
返回非活动控件文本颜色。此方法返回 rgb 十六进制值为 0x999999 的颜色。

覆盖：
类 MetalTheme 中的 getInactiveControlTextColor
返回：
非活动控件文本颜色

getControlTextColor

public ColorUIResource getControlTextColor()
返回控件文本颜色。此方法返回 rgb 十六进制值为 0x333333 的颜色。

覆盖：
类 MetalTheme 中的 getControlTextColor
返回：
控件文本颜色

getMenuDisabledForeground

public ColorUIResource getMenuDisabledForeground()
返回菜单禁用前景色。此方法返回 rgb 十六进制值为 0x999999 的颜色。

覆盖：
类 MetalTheme 中的 getMenuDisabledForeground
返回：
菜单禁用前景色
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.plaf.metal (Java Platform SE 6)

 javax.swing.plaf.metal
类
DefaultMetalTheme
MetalBorders
MetalBorders.ButtonBorder
MetalBorders.Flush3DBorder
MetalBorders.InternalFrameBorder
MetalBorders.MenuBarBorder
MetalBorders.MenuItemBorder
MetalBorders.OptionDialogBorder
MetalBorders.PaletteBorder
MetalBorders.PopupMenuBorder
MetalBorders.RolloverButtonBorder
MetalBorders.ScrollPaneBorder
MetalBorders.TableHeaderBorder
MetalBorders.TextFieldBorder
MetalBorders.ToggleButtonBorder
MetalBorders.ToolBarBorder
MetalButtonUI
MetalCheckBoxIcon
MetalCheckBoxUI
MetalComboBoxButton
MetalComboBoxEditor
MetalComboBoxEditor.UIResource
MetalComboBoxIcon
MetalComboBoxUI
MetalDesktopIconUI
MetalFileChooserUI
MetalIconFactory
MetalIconFactory.FileIcon16
MetalIconFactory.FolderIcon16
MetalIconFactory.PaletteCloseIcon
MetalIconFactory.TreeControlIcon
MetalIconFactory.TreeFolderIcon
MetalIconFactory.TreeLeafIcon
MetalInternalFrameTitlePane
MetalInternalFrameUI
MetalLabelUI
MetalLookAndFeel
MetalMenuBarUI
MetalPopupMenuSeparatorUI
MetalProgressBarUI
MetalRadioButtonUI
MetalRootPaneUI
MetalScrollBarUI
MetalScrollButton
MetalScrollPaneUI
MetalSeparatorUI
MetalSliderUI
MetalSplitPaneUI
MetalTabbedPaneUI
MetalTextFieldUI
MetalTheme
MetalToggleButtonUI
MetalToolBarUI
MetalToolTipUI
MetalTreeUI
OceanTheme


javax.swing.plaf.metal (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.plaf.metal

提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

请参见：
描述

类摘要
DefaultMetalTheme | 提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。
MetalBorders | 可以提供适用于 metal L & F 的 Border 的工厂对象。
MetalBorders.ButtonBorder |
MetalBorders.Flush3DBorder |
MetalBorders.InternalFrameBorder |
MetalBorders.MenuBarBorder |
MetalBorders.MenuItemBorder |
MetalBorders.OptionDialogBorder |
MetalBorders.PaletteBorder | Palette 的边框。
MetalBorders.PopupMenuBorder |
MetalBorders.RolloverButtonBorder |
MetalBorders.ScrollPaneBorder |
MetalBorders.TableHeaderBorder | Table Header 的边框
MetalBorders.TextFieldBorder |
MetalBorders.ToggleButtonBorder |
MetalBorders.ToolBarBorder |
MetalButtonUI | MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
MetalCheckBoxIcon | OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
MetalCheckBoxUI | MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxButton | 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxEditor | Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxEditor.UIResource | 实现 UIResource 的 BasicComboBoxEditor 的一个子类。
MetalComboBoxIcon | 此实用工具类绘制指示 MetalComboBox 的水平条
MetalComboBoxUI | JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalDesktopIconUI | Metal 桌面图标。
MetalFileChooserUI | FileChooser 的 Metal L&F 实现。
MetalIconFactory | 为 JavaTM 外观 (Metal) 提供 Icon 的工厂对象。
MetalIconFactory.FileIcon16 | 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.FolderIcon16 | 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.PaletteCloseIcon | 定义一个用于 Palette 关闭的图标
MetalIconFactory.TreeControlIcon | 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.TreeFolderIcon | 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.TreeLeafIcon |
MetalInternalFrameTitlePane | 管理 JLF 标题栏的类
MetalInternalFrameUI | JInternalFrame 的 Metal 实现。
MetalLabelUI | LabelUI 的 Windows L&F 实现。
MetalLookAndFeel | Java 外观，也称为 Metal。
MetalMenuBarUI | MenuBarUI 的 Metal 实现。
MetalPopupMenuSeparatorUI | PopupMenuSeparatorUI 的 Metal L&F 实现。
MetalProgressBarUI | ProgressBarUI 的 Metal 实现。
MetalRadioButtonUI | MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalRootPaneUI | 提供 RootPaneUI 的 metal 外观实现。
MetalScrollBarUI | ScrollBarUI 的 Metal 外观实现
MetalScrollButton | Metal 滚动条箭头的 JButton 对象。
MetalScrollPaneUI | ScrollPaneUI 的 Metal L&F 实现。
MetalSeparatorUI | SeparatorUI 的 Metal L&F 实现。
MetalSliderUI | SliderUI 的 Java L&F 实现。
MetalSplitPaneUI | Metal 分隔窗格。
MetalTabbedPaneUI | BasicTabbedPaneUI 的 Metal 子类。
MetalTextFieldUI | JTextField 外观的基础。
MetalTheme | MetalTheme 提供 Java 外观所使用的调色板和字体。
MetalToggleButtonUI | MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalToolBarUI | ToolBarUI 的 Metal 外观实现。
MetalToolTipUI | BasicToolTipUI 的 Metal L&F 扩展。
MetalTreeUI | TreeUI 的 metal 外观实现。
OceanTheme | MetalLookAndFeel 的默认主题。

软件包 javax.swing.plaf.metal 的描述

提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

这些类被设计成在已安装相应的 LookAndFeel 类 (UIManager.setLookAndFeel(new XXXLookAndFeel())) 时使用。安装了不同的 LookAndFeel 时使用它们可能产生不可预料的结果，包括异常。此外，更改由 UIManager 维护的 LookAndFeel 却不更新所有 JComponent 的相应 ComponentUI 也会产生不可预料的结果，比如错误的显示颜色，因而通常不鼓励这样做。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.plaf.metal 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf.metal 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.plaf.metal.MetalBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
        • javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
      • javax.swing.plaf.metal.MetalBorders.Flush3DBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.TextFieldBorder
      • javax.swing.plaf.metal.MetalBorders.InternalFrameBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuItemBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.OptionDialogBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PaletteBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PopupMenuBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
      • javax.swing.plaf.metal.MetalBorders.ToolBarBorder (implements javax.swing.SwingConstants, javax.swing.plaf.UIResource)
    • javax.swing.AbstractListModel (implements javax.swing.ListModel, java.io.Serializable)
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel (implements javax.swing.ComboBoxModel)
      • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel (implements javax.swing.ComboBoxModel, java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboBoxEditor (implements javax.swing.ComboBoxEditor, java.awt.event.FocusListener)
      • javax.swing.plaf.metal.MetalComboBoxEditor
        • javax.swing.plaf.metal.MetalComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener (implements javax.swing.event.MouseInputListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener (implements java.awt.event.ContainerListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
              • javax.swing.plaf.basic.BasicArrowButton (implements javax.swing.SwingConstants)
                • javax.swing.plaf.metal.MetalScrollButton
              • javax.swing.plaf.metal.MetalComboBoxButton
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
            • javax.swing.plaf.metal.MetalInternalFrameTitlePane
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.DefaultListCellRenderer (implements javax.swing.ListCellRenderer, java.io.Serializable)
              • javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
              • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicComboPopup (implements javax.swing.plaf.basic.ComboPopup)
              • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.metal.MetalRadioButtonUI
                • javax.swing.plaf.metal.MetalCheckBoxUI
            • javax.swing.plaf.metal.MetalToggleButtonUI
          • javax.swing.plaf.metal.MetalButtonUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
          • javax.swing.plaf.metal.MetalComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
          • javax.swing.plaf.metal.MetalDesktopIconUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
          • javax.swing.plaf.metal.MetalFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
          • javax.swing.plaf.metal.MetalInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalLabelUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
          • javax.swing.plaf.metal.MetalMenuBarUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
          • javax.swing.plaf.metal.MetalProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalRootPaneUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI (implements java.awt.LayoutManager, javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI (implements javax.swing.ScrollPaneConstants)
          • javax.swing.plaf.metal.MetalScrollPaneUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.metal.MetalSeparatorUI
            • javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
          • javax.swing.plaf.metal.MetalSliderUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
          • javax.swing.plaf.metal.MetalSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalTabbedPaneUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.metal.MetalTextFieldUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalToolBarUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
          • javax.swing.plaf.metal.MetalToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
          • javax.swing.plaf.metal.MetalTreeUI
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
        • javax.swing.plaf.metal.MetalLookAndFeel
    • javax.swing.plaf.metal.MetalBorders
    • javax.swing.plaf.metal.MetalCheckBoxIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalComboBoxIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory.FileIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
    • javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
    • javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalTheme
      • javax.swing.plaf.metal.DefaultMetalTheme
        • javax.swing.plaf.metal.OceanTheme
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.plaf.metal 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf.metal
的使用

使用 javax.swing.plaf.metal 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 使用的 javax.swing.plaf.metal 中的类
DefaultMetalTheme
提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。
MetalBorders.ButtonBorder
MetalBorders.Flush3DBorder
MetalComboBoxEditor
Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxUI.MetalComboBoxLayoutManager
此内部类因编译器故障而被标记为 "public"。
MetalFileChooserUI.DirectoryComboBoxModel
字体选择组合框的数据模型。
MetalFileChooserUI.FilterComboBoxModel
字体选择组合框的数据模型。
MetalFileChooserUI.FilterComboBoxRenderer
呈现不同的类型大小和风格。
MetalIconFactory.FileIcon16
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.FolderIcon16
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalLabelUI
LabelUI 的 Windows L&F 实现。
MetalRadioButtonUI
MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalScrollButton
Metal 滚动条箭头的 JButton 对象。
MetalSeparatorUI
SeparatorUI 的 Metal L&F 实现。
MetalTheme
MetalTheme 提供 Java 外观所使用的调色板和字体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalCheckBoxIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalCheckBoxIcon
的使用

没有 javax.swing.plaf.metal.MetalCheckBoxIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalDesktopIconUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalDesktopIconUI
的使用

没有 javax.swing.plaf.metal.MetalDesktopIconUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI
的使用

没有 javax.swing.plaf.metal.MetalFileChooserUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
的使用

没有 javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
的使用

没有 javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel
的使用

使用 MetalFileChooserUI.DirectoryComboBoxModel 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalFileChooserUI.DirectoryComboBoxModel 的使用

返回 MetalFileChooserUI.DirectoryComboBoxModel 的 javax.swing.plaf.metal 中的方法
protected  MetalFileChooserUI.DirectoryComboBoxModel MetalFileChooserUI.createDirectoryComboBoxModel(JFileChooser fc)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
的使用

使用 MetalFileChooserUI.FilterComboBoxRenderer 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalFileChooserUI.FilterComboBoxRenderer 的使用

返回 MetalFileChooserUI.FilterComboBoxRenderer 的 javax.swing.plaf.metal 中的方法
protected  MetalFileChooserUI.FilterComboBoxRenderer MetalFileChooserUI.createFilterComboBoxRenderer()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel
的使用

使用 MetalFileChooserUI.FilterComboBoxModel 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalFileChooserUI.FilterComboBoxModel 的使用

返回 MetalFileChooserUI.FilterComboBoxModel 的 javax.swing.plaf.metal 中的方法
protected  MetalFileChooserUI.FilterComboBoxModel MetalFileChooserUI.createFilterComboBoxModel()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
的使用

没有 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalInternalFrameTitlePane
的使用

没有 javax.swing.plaf.metal.MetalInternalFrameTitlePane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolTipUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolTipUI
的使用

没有 javax.swing.plaf.metal.MetalToolTipUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalInternalFrameUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalInternalFrameUI
的使用

没有 javax.swing.plaf.metal.MetalInternalFrameUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalSliderUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalSliderUI
的使用

没有 javax.swing.plaf.metal.MetalSliderUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
的使用

没有 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalSplitPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalSplitPaneUI
的使用

没有 javax.swing.plaf.metal.MetalSplitPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTreeUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTreeUI
的使用

没有 javax.swing.plaf.metal.MetalTreeUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalProgressBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalProgressBarUI
的使用

没有 javax.swing.plaf.metal.MetalProgressBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalCheckBoxUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalCheckBoxUI
的使用

没有 javax.swing.plaf.metal.MetalCheckBoxUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalRadioButtonUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalRadioButtonUI
的使用

使用 MetalRadioButtonUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalRadioButtonUI 的使用

javax.swing.plaf.metal 中 MetalRadioButtonUI 的子类
 class MetalCheckBoxUI
MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTabbedPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTabbedPaneUI
的使用

没有 javax.swing.plaf.metal.MetalTabbedPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
的使用

没有 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxIcon
的使用

没有 javax.swing.plaf.metal.MetalComboBoxIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxButton
的使用

没有 javax.swing.plaf.metal.MetalComboBoxButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTextFieldUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTextFieldUI
的使用

没有 javax.swing.plaf.metal.MetalTextFieldUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxEditor
的使用

使用 MetalComboBoxEditor 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalComboBoxEditor 的使用

javax.swing.plaf.metal 中 MetalComboBoxEditor 的子类
static class MetalComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的一个子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.OceanTheme 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.OceanTheme
的使用

没有 javax.swing.plaf.metal.OceanTheme 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxEditor.UIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxEditor.UIResource
的使用

没有 javax.swing.plaf.metal.MetalComboBoxEditor.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalScrollPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalScrollPaneUI
的使用

没有 javax.swing.plaf.metal.MetalScrollPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxUI
的使用

没有 javax.swing.plaf.metal.MetalComboBoxUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
的使用

没有 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
的使用

使用 MetalComboBoxUI.MetalComboBoxLayoutManager 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalComboBoxUI.MetalComboBoxLayoutManager 的使用

参数类型为 MetalComboBoxUI.MetalComboBoxLayoutManager 的 javax.swing.plaf.metal 中的方法
 void MetalComboBoxUI.layoutComboBox(Container parent, MetalComboBoxUI.MetalComboBoxLayoutManager manager)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
的使用

没有 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalScrollButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalScrollButton
的使用

使用 MetalScrollButton 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalScrollButton 的使用

声明为 MetalScrollButton 的 javax.swing.plaf.metal 中的字段
protected MetalScrollButton | MetalScrollBarUI.decreaseButton
protected MetalScrollButton | MetalScrollBarUI.increaseButton

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalScrollBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalScrollBarUI
的使用

没有 javax.swing.plaf.metal.MetalScrollBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
的使用

没有 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalSeparatorUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalSeparatorUI
的使用

使用 MetalSeparatorUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalSeparatorUI 的使用

javax.swing.plaf.metal 中 MetalSeparatorUI 的子类
 class MetalPopupMenuSeparatorUI
PopupMenuSeparatorUI 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory
的使用

没有 javax.swing.plaf.metal.MetalIconFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon
的使用

没有 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalTheme 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalTheme
的使用

使用 MetalTheme 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalTheme 的使用

javax.swing.plaf.metal 中 MetalTheme 的子类
class | DefaultMetalTheme 提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。
class | OceanTheme MetalLookAndFeel 的默认主题。

返回 MetalTheme 的 javax.swing.plaf.metal 中的方法
static MetalTheme MetalLookAndFeel.getCurrentTheme()
返回 MetalLookAndFeel 当前正在使用的主题。

参数类型为 MetalTheme 的 javax.swing.plaf.metal 中的方法
static void MetalLookAndFeel.setCurrentTheme(MetalTheme theme)
设置 MetalLookAndFeel 使用的主题。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16
的使用

使用 MetalIconFactory.FolderIcon16 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalIconFactory.FolderIcon16 的使用

javax.swing.plaf.metal 中 MetalIconFactory.FolderIcon16 的子类
static class MetalIconFactory.TreeFolderIcon
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
的使用

没有 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16
的使用

使用 MetalIconFactory.FileIcon16 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalIconFactory.FileIcon16 的使用

javax.swing.plaf.metal 中 MetalIconFactory.FileIcon16 的子类
static class MetalIconFactory.TreeLeafIcon

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
的使用

没有 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
的使用

没有 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolBarUI
的使用

没有 javax.swing.plaf.metal.MetalToolBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
的使用

没有 javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
的使用

没有 javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
的使用

没有 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalMenuBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalMenuBarUI
的使用

没有 javax.swing.plaf.metal.MetalMenuBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalToggleButtonUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalToggleButtonUI
的使用

没有 javax.swing.plaf.metal.MetalToggleButtonUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders
的使用

没有 javax.swing.plaf.metal.MetalBorders 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder
的使用

使用 MetalBorders.Flush3DBorder 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalBorders.Flush3DBorder 的使用

javax.swing.plaf.metal 中 MetalBorders.Flush3DBorder 的子类
static class MetalBorders.TextFieldBorder

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.ButtonBorder
的使用

使用 MetalBorders.ButtonBorder 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalBorders.ButtonBorder 的使用

javax.swing.plaf.metal 中 MetalBorders.ButtonBorder 的子类
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ToggleButtonBorder

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.PaletteBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.PaletteBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.TextFieldBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.TextFieldBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.TextFieldBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalButtonUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalButtonUI
的使用

没有 javax.swing.plaf.metal.MetalButtonUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
的使用

没有 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalLabelUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalLabelUI
的使用

使用 MetalLabelUI 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 MetalLabelUI 的使用

声明为 MetalLabelUI 的 javax.swing.plaf.metal 中的字段
protected static MetalLabelUI MetalLabelUI.metalLabelUI
默认的 MetalLabelUI 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalRootPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalRootPaneUI
的使用

没有 javax.swing.plaf.metal.MetalRootPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.DefaultMetalTheme 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.DefaultMetalTheme
的使用

使用 DefaultMetalTheme 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 DefaultMetalTheme 的使用

javax.swing.plaf.metal 中 DefaultMetalTheme 的子类
 class OceanTheme
MetalLookAndFeel 的默认主题。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.metal.MetalLookAndFeel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.metal.MetalLookAndFeel
的使用

没有 javax.swing.plaf.metal.MetalLookAndFeel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


MultiButtonUI (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiButtonUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.multi.MultiButtonUI

public class MultiButtonUI
extends ButtonUI

用于组合 ButtonUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiButtonUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiButtonUI

public MultiButtonUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则,只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MultiColorChooserUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiColorChooserUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ColorChooserUI
            继承者  javax.swing.plaf.multi.MultiColorChooserUI

public class MultiColorChooserUI
extends ColorChooserUI

用于组合 ColorChooserUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiColorChooserUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiColorChooserUI

public MultiColorChooserUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则，只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiComboBoxUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiComboBoxUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ComboBoxUI
            继承者  javax.swing.plaf.multi.MultiComboBoxUI

public class MultiComboBoxUI
extends ComboBoxUI

用于组合 ComboBoxUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiComboBoxUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
boolean | isFocusTraversable(JComboBox a) 在由此对象处理的每个 UI 上调用 isFocusTraversable 方法。
boolean | isPopupVisible(JComboBox a) 在由此对象处理的每个 UI 上调用 isPopupVisible 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | setPopupVisible(JComboBox a, boolean b) 在由此对象处理的每个 UI 上调用 setPopupVisible 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiComboBoxUI

public MultiComboBoxUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

isFocusTraversable

public boolean isFocusTraversable(JComboBox a)
在由此对象处理的每个 UI 上调用 isFocusTraversable 方法。

指定者：
类 ComboBoxUI 中的 isFocusTraversable
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

setPopupVisible

public void setPopupVisible(JComboBox a,
                            boolean b)
在由此对象处理的每个 UI 上调用 setPopupVisible 方法。

指定者：
类 ComboBoxUI 中的 setPopupVisible

isPopupVisible

public boolean isPopupVisible(JComboBox a)
在由此对象处理的每个 UI 上调用 isPopupVisible 方法。

指定者：
类 ComboBoxUI 中的 isPopupVisible
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiDesktopIconUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiDesktopIconUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.DesktopIconUI
            继承者  javax.swing.plaf.multi.MultiDesktopIconUI

public class MultiDesktopIconUI
extends DesktopIconUI

用于组合 DesktopIconUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiDesktopIconUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiDesktopIconUI

public MultiDesktopIconUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiDesktopPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiDesktopPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.DesktopPaneUI
            继承者  javax.swing.plaf.multi.MultiDesktopPaneUI

public class MultiDesktopPaneUI
extends DesktopPaneUI

用于组合 DesktopPaneUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiDesktopPaneUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiDesktopPaneUI

public MultiDesktopPaneUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiFileChooserUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiFileChooserUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.FileChooserUI
            继承者  javax.swing.plaf.multi.MultiFileChooserUI

public class MultiFileChooserUI
extends FileChooserUI

用于组合 FileChooserUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiFileChooserUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
void | ensureFileIsVisible(JFileChooser a, File b) 在由此对象处理的每个 UI 上调用 ensureFileIsVisible 方法。
FileFilter | getAcceptAllFileFilter(JFileChooser a) 在由此对象处理的每个 UI 上调用 getAcceptAllFileFilter 方法。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
String | getApproveButtonText(JFileChooser a) 在由此对象处理的每个 UI 上调用 getApproveButtonText 方法。
String | getDialogTitle(JFileChooser a) 在由此对象处理的每个 UI 上调用 getDialogTitle 方法。
FileView | getFileView(JFileChooser a) 在由此对象处理的每个 UI 上调用 getFileView 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | rescanCurrentDirectory(JFileChooser a) 在由此对象处理的每个 UI 上调用 rescanCurrentDirectory 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiFileChooserUI

public MultiFileChooserUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

getAcceptAllFileFilter

public FileFilter getAcceptAllFileFilter(JFileChooser a)
在由此对象处理的每个 UI 上调用 getAcceptAllFileFilter 方法。

指定者：
类 FileChooserUI 中的 getAcceptAllFileFilter
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getFileView

public FileView getFileView(JFileChooser a)
在由此对象处理的每个 UI 上调用 getFileView 方法。

指定者：
类 FileChooserUI 中的 getFileView
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getApproveButtonText

public String getApproveButtonText(JFileChooser a)
在由此对象处理的每个 UI 上调用 getApproveButtonText 方法。

指定者：
类 FileChooserUI 中的 getApproveButtonText
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getDialogTitle

public String getDialogTitle(JFileChooser a)
在由此对象处理的每个 UI 上调用 getDialogTitle 方法。

指定者：
类 FileChooserUI 中的 getDialogTitle
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

rescanCurrentDirectory

public void rescanCurrentDirectory(JFileChooser a)
在由此对象处理的每个 UI 上调用 rescanCurrentDirectory 方法。

指定者：
类 FileChooserUI 中的 rescanCurrentDirectory

ensureFileIsVisible

public void ensureFileIsVisible(JFileChooser a,
                                File b)
在由此对象处理的每个 UI 上调用 ensureFileIsVisible 方法。

指定者：
类 FileChooserUI 中的 ensureFileIsVisible

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiInternalFrameUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiInternalFrameUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.InternalFrameUI
            继承者  javax.swing.plaf.multi.MultiInternalFrameUI

public class MultiInternalFrameUI
extends InternalFrameUI

用于组合 InternalFrameUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiInternalFrameUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiInternalFrameUI

public MultiInternalFrameUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiLabelUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiLabelUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.LabelUI
            继承者  javax.swing.plaf.multi.MultiLabelUI

public class MultiLabelUI
extends LabelUI

用于组合 LabelUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiLabelUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiLabelUI

public MultiLabelUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiListUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiListUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ListUI
            继承者  javax.swing.plaf.multi.MultiListUI

public class MultiListUI
extends ListUI

用于组合 ListUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiListUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Rectangle | getCellBounds(JList a, int b, int c) 在由此对象处理的每个 UI 上调用 getCellBounds 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
Point | indexToLocation(JList a, int b) 在由此对象处理的每个 UI 上调用 indexToLocation 方法。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
int | locationToIndex(JList a, Point b) 在由此对象处理的每个 UI 上调用 locationToIndex 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiListUI

public MultiListUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

locationToIndex

public int locationToIndex(JList a,
                           Point b)
在由此对象处理的每个 UI 上调用 locationToIndex 方法。

指定者：
类 ListUI 中的 locationToIndex
参数：
a - 列表
b - 点的坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

indexToLocation

public Point indexToLocation(JList a,
                             int b)
在由此对象处理的每个 UI 上调用 indexToLocation 方法。

指定者：
类 ListUI 中的 indexToLocation
参数：
a - 列表
b - 单元索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getCellBounds

public Rectangle getCellBounds(JList a,
                               int b,
                               int c)
在由此对象处理的每个 UI 上调用 getCellBounds 方法。

指定者：
类 ListUI 中的 getCellBounds
参数：
a - 列表
b - 范围内第一个索引
c - 范围内第二个索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiLookAndFeel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiLookAndFeel

java.lang.Object
    继承者  javax.swing.LookAndFeel
        继承者  javax.swing.plaf.multi.MultiLookAndFeel

public class MultiLookAndFeel
extends LookAndFeel

多路外观允许同时将多个 UI 与一个组件相关联。主外观称为默认 外观，而其他外观则称为辅助 外观。

有关更多信息，请参阅 Using the Multiplexing Look and Feel。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
UIManager.addAuxiliaryLookAndFeel(javax.swing.LookAndFeel), javax.swing.plaf.multi

构造方法摘要
MultiLookAndFeel()
方法摘要
static ComponentUI | createUIs(ComponentUI mui, Vector uis, JComponent target) 创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
UIDefaults | getDefaults() 创建、初始化并返回特定于外观的默认值。
String | getDescription() 返回对此外观的一行描述。
String | getID() 返回适合应用程序/服务使用、标识此外观的 string。
String | getName() 返回适合在菜单中使用、标识此外观的 string。
boolean | isNativeLookAndFeel() 返回 false；此外观对于任意平台而言不是本机的。
boolean | isSupportedLookAndFeel() 返回 true；所有平台都允许此外观。
protected static ComponentUI[] | uisToArray(Vector uis) 创建一个数组，使用来自传入向量的 UI 对象填充它并返回该数组。
从类 javax.swing.LookAndFeel 继承的方法
getDesktopPropertyValue, getDisabledIcon, getDisabledSelectedIcon, getLayoutStyle, getSupportsWindowDecorations, initialize, installBorder, installColors, installColorsAndFont, installProperty, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, provideErrorFeedback, toString, uninitialize, uninstallBorder
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MultiLookAndFeel

public MultiLookAndFeel()
方法详细信息

getName

public String getName()
返回适合在菜单中使用、标识此外观的 string。

指定者：
类 LookAndFeel 中的 getName
返回：
一个 string，如 "Multiplexing Look and Feel"

getID

public String getID()
返回适合应用程序/服务使用、标识此外观的 string。

指定者：
类 LookAndFeel 中的 getID
返回：
"Multiplex"

getDescription

public String getDescription()
返回对此外观的一行描述。

指定者：
类 LookAndFeel 中的 getDescription
返回：
描述性的 string，如 "Allows multiple UI instances per component instance"

isNativeLookAndFeel

public boolean isNativeLookAndFeel()
返回 false；此外观对于任意平台而言不是本机的。

指定者：
类 LookAndFeel 中的 isNativeLookAndFeel
返回：
false

isSupportedLookAndFeel

public boolean isSupportedLookAndFeel()
返回 true；所有平台都允许此外观。

指定者：
类 LookAndFeel 中的 isSupportedLookAndFeel
返回：
true
另请参见：
UIManager.setLookAndFeel(javax.swing.LookAndFeel)

getDefaults

public UIDefaults getDefaults()
创建、初始化并返回特定于外观的默认值。对于此外观，默认仅包括 UI 类 ID（如 "ButtonUI"）与 ComponentUI 类名称（如 "javax.swing.plaf.multi.MultiButtonUI"）的映射关系。

覆盖：
类 LookAndFeel 中的 getDefaults
返回：
已初始化的 UIDefaults 对象
另请参见：
JComponent.getUIClassID()

createUIs

public static ComponentUI createUIs(ComponentUI mui,
                                    Vector uis,
                                    JComponent target)
创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。此方法查找 ComponentUI 对象，方法是在当前使用的所有默认和辅助外观上调用 getDefaults().getUI(target)。此方法添加到 uis 向量中的第一个 UI 对象是针对默认外观的。

此方法由 MultiXxxxUI 类的 createUI 方法调用。

参数：
mui - 表示 target 组件完整 UI 的 ComponentUI 对象；这应该是某个 MultiXxxxUI 类的实例
uis - 一个 Vector；通常这是 mui 参数的 uis 字段
target - 一个组件，由 mui 表示其 UI
返回：
如果该组件有辅助 UI 对象，则返回 mui；否则返回默认外观的 UI 对象，如果无法找到默认 UI 对象，则返回 null
另请参见：
UIManager.getAuxiliaryLookAndFeels(), UIDefaults.getUI(javax.swing.JComponent), MultiButtonUI.uis, MultiButtonUI.createUI(javax.swing.JComponent)

uisToArray

protected static ComponentUI[] uisToArray(Vector uis)
创建一个数组，使用来自传入向量的 UI 对象填充它并返回该数组。如果 uis 为 null，则此方法返回具有零元素的数组。如果 uis 是空向量，则此方法返回 null。如果 uis 向量中的任何对象不是 ComponentUI 类型的，则出现运行时错误。

参数：
uis - 包含 ComponentUI 对象的向量
返回：
等同于传入向量的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiMenuBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiMenuBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.MenuBarUI
            继承者  javax.swing.plaf.multi.MultiMenuBarUI

public class MultiMenuBarUI
extends MenuBarUI

用于组合 MenuBarUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiMenuBarUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiMenuBarUI

public MultiMenuBarUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiMenuItemUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiMenuItemUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ButtonUI
            继承者  javax.swing.plaf.MenuItemUI
                继承者  javax.swing.plaf.multi.MultiMenuItemUI

public class MultiMenuItemUI
extends MenuItemUI

用于组合 MenuItemUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiMenuItemUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiMenuItemUI

public MultiMenuItemUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiOptionPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiOptionPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.OptionPaneUI
            继承者  javax.swing.plaf.multi.MultiOptionPaneUI

public class MultiOptionPaneUI
extends OptionPaneUI

用于组合 OptionPaneUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiOptionPaneUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | containsCustomComponents(JOptionPane a) 在由此对象处理的每个 UI 上调用 containsCustomComponents 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | selectInitialValue(JOptionPane a) 在由此对象处理的每个 UI 上调用 selectInitialValue 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiOptionPaneUI

public MultiOptionPaneUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

selectInitialValue

public void selectInitialValue(JOptionPane a)
在由此对象处理的每个 UI 上调用 selectInitialValue 方法。

指定者：
类 OptionPaneUI 中的 selectInitialValue

containsCustomComponents

public boolean containsCustomComponents(JOptionPane a)
在由此对象处理的每个 UI 上调用 containsCustomComponents 方法。

指定者：
类 OptionPaneUI 中的 containsCustomComponents
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiPanelUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiPanelUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.PanelUI
            继承者  javax.swing.plaf.multi.MultiPanelUI

public class MultiPanelUI
extends PanelUI

用于组合 PanelUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiPanelUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiPanelUI

public MultiPanelUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiPopupMenuUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiPopupMenuUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.PopupMenuUI
            继承者  javax.swing.plaf.multi.MultiPopupMenuUI

public class MultiPopupMenuUI
extends PopupMenuUI

用于组合 PopupMenuUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiPopupMenuUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Popup | getPopup(JPopupMenu a, int b, int c) 在由此对象处理的每个 UI 上调用 getPopup 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
boolean | isPopupTrigger(MouseEvent a) 在由此对象处理的每个 UI 上调用 isPopupTrigger 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiPopupMenuUI

public MultiPopupMenuUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

isPopupTrigger

public boolean isPopupTrigger(MouseEvent a)
在由此对象处理的每个 UI 上调用 isPopupTrigger 方法。

覆盖：
类 PopupMenuUI 中的 isPopupTrigger
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
从以下版本开始：
1.3

getPopup

public Popup getPopup(JPopupMenu a,
                      int b,
                      int c)
在由此对象处理的每个 UI 上调用 getPopup 方法。

覆盖：
类 PopupMenuUI 中的 getPopup
参数：
a - 请求 Popup 的 JPopupMenu
b - 屏幕上将显示 Popup 的 x 位置
c - 屏幕上将显示 Popup 的 y 位置。
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
从以下版本开始：
1.4

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiProgressBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiProgressBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ProgressBarUI
            继承者  javax.swing.plaf.multi.MultiProgressBarUI

public class MultiProgressBarUI
extends ProgressBarUI

用于组合 ProgressBarUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiProgressBarUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiProgressBarUI

public MultiProgressBarUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiRootPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiRootPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.RootPaneUI
            继承者  javax.swing.plaf.multi.MultiRootPaneUI

public class MultiRootPaneUI
extends RootPaneUI

用于组合 RootPaneUI 的多路 UI。

此文件由 AutoMulti 自动生成。

从以下版本开始：
1.4

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiRootPaneUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiRootPaneUI

public MultiRootPaneUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiScrollBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiScrollBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ScrollBarUI
            继承者  javax.swing.plaf.multi.MultiScrollBarUI

public class MultiScrollBarUI
extends ScrollBarUI

用于组合 ScrollBarUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiScrollBarUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiScrollBarUI

public MultiScrollBarUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiScrollPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiScrollPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ScrollPaneUI
            继承者  javax.swing.plaf.multi.MultiScrollPaneUI

public class MultiScrollPaneUI
extends ScrollPaneUI

用于组合 ScrollPaneUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiScrollPaneUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiScrollPaneUI

public MultiScrollPaneUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiSeparatorUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiSeparatorUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SeparatorUI
            继承者  javax.swing.plaf.multi.MultiSeparatorUI

public class MultiSeparatorUI
extends SeparatorUI

用于组合 SeparatorUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiSeparatorUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiSeparatorUI

public MultiSeparatorUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiSliderUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiSliderUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SliderUI
            继承者  javax.swing.plaf.multi.MultiSliderUI

public class MultiSliderUI
extends SliderUI

用于组合 SliderUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiSliderUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiSliderUI

public MultiSliderUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiSpinnerUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiSpinnerUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SpinnerUI
            继承者  javax.swing.plaf.multi.MultiSpinnerUI

public class MultiSpinnerUI
extends SpinnerUI

用于组合 SpinnerUI 的多路 UI。

此文件由 AutoMulti 自动生成。

从以下版本开始：
1.4

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiSpinnerUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiSpinnerUI

public MultiSpinnerUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiSplitPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiSplitPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.SplitPaneUI
            继承者  javax.swing.plaf.multi.MultiSplitPaneUI

public class MultiSplitPaneUI
extends SplitPaneUI

用于组合 SplitPaneUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiSplitPaneUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
void | finishedPaintingChildren(JSplitPane a, Graphics b) 在由此对象处理的每个 UI 上调用 finishedPaintingChildren 方法。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | getDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getDividerLocation 方法。
int | getMaximumDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getMaximumDividerLocation 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
int | getMinimumDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getMinimumDividerLocation 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | resetToPreferredSizes(JSplitPane a) 在由此对象处理的每个 UI 上调用 resetToPreferredSizes 方法。
void | setDividerLocation(JSplitPane a, int b) 在由此对象处理的每个 UI 上调用 setDividerLocation 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiSplitPaneUI

public MultiSplitPaneUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

resetToPreferredSizes

public void resetToPreferredSizes(JSplitPane a)
在由此对象处理的每个 UI 上调用 resetToPreferredSizes 方法。

指定者：
类 SplitPaneUI 中的 resetToPreferredSizes

setDividerLocation

public void setDividerLocation(JSplitPane a,
                               int b)
在由此对象处理的每个 UI 上调用 setDividerLocation 方法。

指定者：
类 SplitPaneUI 中的 setDividerLocation

getDividerLocation

public int getDividerLocation(JSplitPane a)
在由此对象处理的每个 UI 上调用 getDividerLocation 方法。

指定者：
类 SplitPaneUI 中的 getDividerLocation
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getMinimumDividerLocation

public int getMinimumDividerLocation(JSplitPane a)
在由此对象处理的每个 UI 上调用 getMinimumDividerLocation 方法。

指定者：
类 SplitPaneUI 中的 getMinimumDividerLocation
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getMaximumDividerLocation

public int getMaximumDividerLocation(JSplitPane a)
在由此对象处理的每个 UI 上调用 getMaximumDividerLocation 方法。

指定者：
类 SplitPaneUI 中的 getMaximumDividerLocation
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

finishedPaintingChildren

public void finishedPaintingChildren(JSplitPane a,
                                     Graphics b)
在由此对象处理的每个 UI 上调用 finishedPaintingChildren 方法。

指定者：
类 SplitPaneUI 中的 finishedPaintingChildren

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiTabbedPaneUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiTabbedPaneUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TabbedPaneUI
            继承者  javax.swing.plaf.multi.MultiTabbedPaneUI

public class MultiTabbedPaneUI
extends TabbedPaneUI

用于组合 TabbedPaneUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiTabbedPaneUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Rectangle | getTabBounds(JTabbedPane a, int b) 在由此对象处理的每个 UI 上调用 getTabBounds 方法。
int | getTabRunCount(JTabbedPane a) 在由此对象处理的每个 UI 上调用 getTabRunCount 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
int | tabForCoordinate(JTabbedPane a, int b, int c) 在由此对象处理的每个 UI 上调用 tabForCoordinate 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiTabbedPaneUI

public MultiTabbedPaneUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

tabForCoordinate

public int tabForCoordinate(JTabbedPane a,
                            int b,
                            int c)
在由此对象处理的每个 UI 上调用 tabForCoordinate 方法。

指定者：
类 TabbedPaneUI 中的 tabForCoordinate
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getTabBounds

public Rectangle getTabBounds(JTabbedPane a,
                              int b)
在由此对象处理的每个 UI 上调用 getTabBounds 方法。

指定者：
类 TabbedPaneUI 中的 getTabBounds
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getTabRunCount

public int getTabRunCount(JTabbedPane a)
在由此对象处理的每个 UI 上调用 getTabRunCount 方法。

指定者：
类 TabbedPaneUI 中的 getTabRunCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiTableHeaderUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiTableHeaderUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TableHeaderUI
            继承者  javax.swing.plaf.multi.MultiTableHeaderUI

public class MultiTableHeaderUI
extends TableHeaderUI

用于组合 TableHeaderUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiTableHeaderUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiTableHeaderUI

public MultiTableHeaderUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiTableUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiTableUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TableUI
            继承者  javax.swing.plaf.multi.MultiTableUI

public class MultiTableUI
extends TableUI

用于组合 TableUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiTableUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiTableUI

public MultiTableUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiTextUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiTextUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TextUI
            继承者  javax.swing.plaf.multi.MultiTextUI

public class MultiTextUI
extends TextUI

用于组合 TextUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiTextUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
void | damageRange(JTextComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 damageRange 方法。
void | damageRange(JTextComponent a, int b, int c, Position.Bias d, Position.Bias e) 在由此对象处理的每个 UI 上调用 damageRange 方法。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
EditorKit | getEditorKit(JTextComponent a) 在由此对象处理的每个 UI 上调用 getEditorKit 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
int | getNextVisualPositionFrom(JTextComponent a, int b, Position.Bias c, int d, Position.Bias[] e) 在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
View | getRootView(JTextComponent a) 在由此对象处理的每个 UI 上调用 getRootView 方法。
String | getToolTipText(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 getToolTipText 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
Rectangle | modelToView(JTextComponent a, int b) 在由此对象处理的每个 UI 上调用 modelToView 方法。
Rectangle | modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
int | viewToModel(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 viewToModel 方法。
int | viewToModel(JTextComponent a, Point b, Position.Bias[] c) 在由此对象处理的每个 UI 上调用 viewToModel 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiTextUI

public MultiTextUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

getToolTipText

public String getToolTipText(JTextComponent a,
                             Point b)
在由此对象处理的每个 UI 上调用 getToolTipText 方法。

覆盖：
类 TextUI 中的 getToolTipText
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
从以下版本开始：
1.4
另请参见：
JTextComponent.getToolTipText(java.awt.event.MouseEvent)

modelToView

public Rectangle modelToView(JTextComponent a,
                             int b)
                      throws BadLocationException
在由此对象处理的每个 UI 上调用 modelToView 方法。

指定者：
类 TextUI 中的 modelToView
b - 模型中要转换的本地位置，该位置 >= 0
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
抛出：
BadLocationException - 如果给定位置并不表示相关文档中的一个有效位置

modelToView

public Rectangle modelToView(JTextComponent a,
                             int b,
                             Position.Bias c)
                      throws BadLocationException
在由此对象处理的每个 UI 上调用 modelToView 方法。

指定者：
类 TextUI 中的 modelToView
b - 模型中要转换的本地位置，该位置 >= 0
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
抛出：
BadLocationException - 如果给定位置并不表示相关文档中的一个有效位置

viewToModel

public int viewToModel(JTextComponent a,
                       Point b)
在由此对象处理的每个 UI 上调用 viewToModel 方法。

指定者：
类 TextUI 中的 viewToModel
b - 视图中要转换的位置。此位置应该与鼠标事件在同一坐标系统中。
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

viewToModel

public int viewToModel(JTextComponent a,
                       Point b,
                       Position.Bias[] c)
在由此对象处理的每个 UI 上调用 viewToModel 方法。

指定者：
类 TextUI 中的 viewToModel
b - 视图中要转换的位置。此位置应该与鼠标事件在同一坐标系统中。
c - 由此方法填充，以指示给定点是更接近于模型中的前一个字符，还是更接近于模型中的下一个字符
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getNextVisualPositionFrom

public int getNextVisualPositionFrom(JTextComponent a,
                                     int b,
                                     Position.Bias c,
                                     int d,
                                     Position.Bias[] e)
                              throws BadLocationException
在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。

指定者：
类 TextUI 中的 getNextVisualPositionFrom
参数：
a - 为其安装此 UI 的文本组件
b - 要转换的位置，该位置 >= 0
c - 位置的偏差
d - 以当前位置开始的方向，可以将它们设想为通常出现在键盘上的箭头键。该参数可以是 SwingConstants.WEST、SwingConstants.EAST、SwingConstants.NORTH 或 SwingConstants.SOUTH
e - 包含返回位置偏差的数组
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
抛出：
BadLocationException

damageRange

public void damageRange(JTextComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 damageRange 方法。

指定者：
类 TextUI 中的 damageRange
b - 范围的起始位置，该位置 >= 0
c - 范围的结束位置，该位置 >= p0

damageRange

public void damageRange(JTextComponent a,
                        int b,
                        int c,
                        Position.Bias d,
                        Position.Bias e)
在由此对象处理的每个 UI 上调用 damageRange 方法。

指定者：
类 TextUI 中的 damageRange
b - 范围的起始位置，该位置 >= 0
c - 范围的结束位置，该位置 >= p0

getEditorKit

public EditorKit getEditorKit(JTextComponent a)
在由此对象处理的每个 UI 上调用 getEditorKit 方法。

指定者：
类 TextUI 中的 getEditorKit
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getRootView

public View getRootView(JTextComponent a)
在由此对象处理的每个 UI 上调用 getRootView 方法。

指定者：
类 TextUI 中的 getRootView
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiToolBarUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiToolBarUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ToolBarUI
            继承者  javax.swing.plaf.multi.MultiToolBarUI

public class MultiToolBarUI
extends ToolBarUI

用于组合 ToolBarUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiToolBarUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiToolBarUI

public MultiToolBarUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiToolTipUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiToolTipUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ToolTipUI
            继承者  javax.swing.plaf.multi.MultiToolTipUI

public class MultiToolTipUI
extends ToolTipUI

用于组合 ToolTipUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiToolTipUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiToolTipUI

public MultiToolTipUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiTreeUI (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiTreeUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.TreeUI
            继承者  javax.swing.plaf.multi.MultiTreeUI

public class MultiTreeUI
extends TreeUI

用于组合 TreeUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiTreeUI()
方法摘要
void | cancelEditing(JTree a) 在由此对象处理的每个 UI 上调用 cancelEditing 方法。
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
TreePath | getClosestPathForLocation(JTree a, int b, int c) 在由此对象处理的每个 UI 上调用 getClosestPathForLocation 方法。
TreePath | getEditingPath(JTree a) 在由此对象处理的每个 UI 上调用 getEditingPath 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Rectangle | getPathBounds(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getPathBounds 方法。
TreePath | getPathForRow(JTree a, int b) 在由此对象处理的每个 UI 上调用 getPathForRow 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
int | getRowCount(JTree a) 在由此对象处理的每个 UI 上调用 getRowCount 方法。
int | getRowForPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getRowForPath 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
boolean | isEditing(JTree a) 在由此对象处理的每个 UI 上调用 isEditing 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | startEditingAtPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 startEditingAtPath 方法。
boolean | stopEditing(JTree a) 在由此对象处理的每个 UI 上调用 stopEditing 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiTreeUI

public MultiTreeUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

getPathBounds

public Rectangle getPathBounds(JTree a,
                               TreePath b)
在由此对象处理的每个 UI 上调用 getPathBounds 方法。

指定者：
类 TreeUI 中的 getPathBounds
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getPathForRow

public TreePath getPathForRow(JTree a,
                              int b)
在由此对象处理的每个 UI 上调用 getPathForRow 方法。

指定者：
类 TreeUI 中的 getPathForRow
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getRowForPath

public int getRowForPath(JTree a,
                         TreePath b)
在由此对象处理的每个 UI 上调用 getRowForPath 方法。

指定者：
类 TreeUI 中的 getRowForPath
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getRowCount

public int getRowCount(JTree a)
在由此对象处理的每个 UI 上调用 getRowCount 方法。

指定者：
类 TreeUI 中的 getRowCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

getClosestPathForLocation

public TreePath getClosestPathForLocation(JTree a,
                                          int b,
                                          int c)
在由此对象处理的每个 UI 上调用 getClosestPathForLocation 方法。

指定者：
类 TreeUI 中的 getClosestPathForLocation
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

isEditing

public boolean isEditing(JTree a)
在由此对象处理的每个 UI 上调用 isEditing 方法。

指定者：
类 TreeUI 中的 isEditing
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

stopEditing

public boolean stopEditing(JTree a)
在由此对象处理的每个 UI 上调用 stopEditing 方法。

指定者：
类 TreeUI 中的 stopEditing
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

cancelEditing

public void cancelEditing(JTree a)
在由此对象处理的每个 UI 上调用 cancelEditing 方法。

指定者：
类 TreeUI 中的 cancelEditing

startEditingAtPath

public void startEditingAtPath(JTree a,
                               TreePath b)
在由此对象处理的每个 UI 上调用 startEditingAtPath 方法。

指定者：
类 TreeUI 中的 startEditingAtPath

getEditingPath

public TreePath getEditingPath(JTree a)
在由此对象处理的每个 UI 上调用 getEditingPath 方法。

指定者：
类 TreeUI 中的 getEditingPath
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiViewportUI (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.multi
类 MultiViewportUI

java.lang.Object
    继承者  javax.swing.plaf.ComponentUI
        继承者  javax.swing.plaf.ViewportUI
            继承者  javax.swing.plaf.multi.MultiViewportUI

public class MultiViewportUI
extends ViewportUI

用于组合 ViewportUI 的多路 UI。

此文件由 AutoMulti 自动生成。

字段摘要
protected  Vector uis
包含实际 UI 的向量。
构造方法摘要
MultiViewportUI()
方法摘要
boolean | contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
Accessible | getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
ComponentUI[] | getUIs() 返回与此多路 UI 关联的 UI 列表。
void | installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
从类 javax.swing.plaf.ComponentUI 继承的方法
getBaseline, getBaselineResizeBehavior
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

uis

protected Vector uis
包含实际 UI 的向量。这是在对 createUI 的调用中生成的，并且可通过调用 getUIs 方法获得它。可以保证第一个元素是从默认外观获得的实际 UI。

构造方法详细信息

MultiViewportUI

public MultiViewportUI()
方法详细信息

getUIs

public ComponentUI[] getUIs()
返回与此多路 UI 关联的 UI 列表。这允许由意识到组件上多路 UI 的应用程序进行 UI 处理。

contains

public boolean contains(JComponent a,
                        int b,
                        int c)
在由此对象处理的每个 UI 上调用 contains 方法。

覆盖：
类 ComponentUI 中的 contains
参数：
a - 将在其中查询 x,y 的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
b - 点的 x 坐标
c - 点的 y 坐标
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.contains(int, int), Component.contains(int, int)

update

public void update(Graphics a,
                   JComponent b)
在由此对象处理的每个 UI 上调用 update 方法。

覆盖：
类 ComponentUI 中的 update
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.paint(java.awt.Graphics, javax.swing.JComponent), JComponent.paintComponent(java.awt.Graphics)

createUI

public static ComponentUI createUI(JComponent a)
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。否则只返回从默认 LookAndFeel 获得的 UI 对象。

installUI

public void installUI(JComponent a)
在由此对象处理的每个 UI 上调用 installUI 方法。

覆盖：
类 ComponentUI 中的 installUI
参数：
a - 将安装此 UI 委托的组件
另请参见：
ComponentUI.uninstallUI(javax.swing.JComponent),
JComponent.setUI(javax.swing.plaf.ComponentUI),
JComponent.updateUI()

uninstallUI

public void uninstallUI(JComponent a)
在由此对象处理的每个 UI 上调用 uninstallUI 方法。

覆盖：
类 ComponentUI 中的 uninstallUI
参数：
a - 从中移除此 UI 委托的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.installUI(javax.swing.JComponent), JComponent.updateUI()

paint

public void paint(Graphics a,
                  JComponent b)
在由此对象处理的每个 UI 上调用 paint 方法。

覆盖：
类 ComponentUI 中的 paint
参数：
a - 将在其中进行绘制的 Graphics 上下文
b - 将绘制的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
另请参见：
ComponentUI.update(java.awt.Graphics, javax.swing.JComponent)

getPreferredSize

public Dimension getPreferredSize(JComponent a)
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

覆盖：
类 ComponentUI 中的 getPreferredSize
参数：
a - 将查询其首选大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getPreferredSize(), LayoutManager.preferredLayoutSize(java.awt.Container)

getMinimumSize

public Dimension getMinimumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。

覆盖：
类 ComponentUI 中的 getMinimumSize
参数：
a - 将查询其最小大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMinimumSize(),
LayoutManager.minimumLayoutSize(java.awt.Container),
ComponentUI.getPreferredSize(javax.swing.JComponent)

getMaximumSize

public Dimension getMaximumSize(JComponent a)
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。

覆盖：
类 ComponentUI 中的 getMaximumSize
参数：
a - 将查询其最大大小的组件；此参数常被忽略，但如果 UI 对象是无状态的并由多个组件共享，则可以使用该参数
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
JComponent.getMaximumSize(), LayoutManager2.maximumLayoutSize(java.awt.Container)

getAccessibleChildrenCount

public int getAccessibleChildrenCount(JComponent a)
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChildrenCount
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChild(javax.swing.JComponent, int)

getAccessibleChild

public Accessible getAccessibleChild(JComponent a,
                                     int b)
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

覆盖：
类 ComponentUI 中的 getAccessibleChild
b - 子对象的从零开始的索引
返回：
从第一个 UI 获得的值，该 UI 是从默认 LookAndFeel 获得的 UI
另请参见：
ComponentUI.getAccessibleChildrenCount(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.plaf.multi (Java Platform SE 6)

 javax.swing.plaf.multi
类
MultiButtonUI
MultiColorChooserUI
MultiComboBoxUI
MultiDesktopIconUI
MultiDesktopPaneUI
MultiFileChooserUI
MultiInternalFrameUI
MultiLabelUI
MultiListUI
MultiLookAndFeel
MultiMenuBarUI
MultiMenuItemUI
MultiOptionPaneUI
MultiPanelUI
MultiPopupMenuUI
MultiProgressBarUI
MultiRootPaneUI
MultiScrollBarUI
MultiScrollPaneUI
MultiSeparatorUI
MultiSliderUI
MultiSpinnerUI
MultiSplitPaneUI
MultiTabbedPaneUI
MultiTableHeaderUI
MultiTableUI
MultiTextUI
MultiToolBarUI
MultiToolTipUI
MultiTreeUI
MultiViewportUI


javax.swing.plaf.multi (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.plaf.multi

提供了组合两个或多个外观的用户界面对象。

请参见：
描述

类摘要
MultiButtonUI | 用于组合 ButtonUI 的多路 UI。
MultiColorChooserUI | 用于组合 ColorChooserUI 的多路 UI。
MultiComboBoxUI | 用于组合 ComboBoxUI 的多路 UI。
MultiDesktopIconUI | 用于组合 DesktopIconUI 的多路 UI。
MultiDesktopPaneUI | 用于组合 DesktopPaneUI 的多路 UI。
MultiFileChooserUI | 用于组合 FileChooserUI 的多路 UI。
MultiInternalFrameUI | 用于组合 InternalFrameUI 的多路 UI。
MultiLabelUI | 用于组合 LabelUI 的多路 UI。
MultiListUI | 用于组合 ListUI 的多路 UI。
MultiLookAndFeel | 多路外观允许同时将多个 UI 与一个组件相关联。
MultiMenuBarUI | 用于组合 MenuBarUI 的多路 UI。
MultiMenuItemUI | 用于组合 MenuItemUI 的多路 UI。
MultiOptionPaneUI | 用于组合 OptionPaneUI 的多路 UI。
MultiPanelUI | 用于组合 PanelUI 的多路 UI。
MultiPopupMenuUI | 用于组合 PopupMenuUI 的多路 UI。
MultiProgressBarUI | 用于组合 ProgressBarUI 的多路 UI。
MultiRootPaneUI | 用于组合 RootPaneUI 的多路 UI。
MultiScrollBarUI | 用于组合 ScrollBarUI 的多路 UI。
MultiScrollPaneUI | 用于组合 ScrollPaneUI 的多路 UI。
MultiSeparatorUI | 用于组合 SeparatorUI 的多路 UI。
MultiSliderUI | 用于组合 SliderUI 的多路 UI。
MultiSpinnerUI | 用于组合 SpinnerUI 的多路 UI。
MultiSplitPaneUI | 用于组合 SplitPaneUI 的多路 UI。
MultiTabbedPaneUI | 用于组合 TabbedPaneUI 的多路 UI。
MultiTableHeaderUI | 用于组合 TableHeaderUI 的多路 UI。
MultiTableUI | 用于组合 TableUI 的多路 UI。
MultiTextUI | 用于组合 TextUI 的多路 UI。
MultiToolBarUI | 用于组合 ToolBarUI 的多路 UI。
MultiToolTipUI | 用于组合 ToolTipUI 的多路 UI。
MultiTreeUI | 用于组合 TreeUI 的多路 UI。
MultiViewportUI | 用于组合 ViewportUI 的多路 UI。

软件包 javax.swing.plaf.multi 的描述

提供了组合两个或多个外观的用户界面对象。当某个组件请求其 UI 时，此外观返回一个处理与默认外观和一个或多个辅助外观之间通信的多路 UI。例如，如果用户组合了一个辅助音频外观和 Motif 外观，则 JButton.getUI 方法将返回一个 MultiButtonUI 实例，该实例处理 MotifButtonUI 和 AudioButtonUI

有关更多信息，请参阅 Using the Multiplexing Look and Feel。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.plaf.multi 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf.multi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.multi.MultiMenuItemUI
        • javax.swing.plaf.multi.MultiButtonUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.multi.MultiColorChooserUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.multi.MultiComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.multi.MultiDesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.multi.MultiDesktopPaneUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.multi.MultiFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.multi.MultiInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.multi.MultiLabelUI
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.multi.MultiListUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.multi.MultiMenuBarUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.multi.MultiOptionPaneUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.multi.MultiPanelUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.multi.MultiPopupMenuUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.multi.MultiProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.multi.MultiRootPaneUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.multi.MultiScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.multi.MultiScrollPaneUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.multi.MultiSeparatorUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.multi.MultiSliderUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.multi.MultiSpinnerUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.multi.MultiSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.multi.MultiTabbedPaneUI
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.multi.MultiTableHeaderUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.multi.MultiTableUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.multi.MultiTextUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.multi.MultiToolBarUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.multi.MultiToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.multi.MultiTreeUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.multi.MultiViewportUI
    • javax.swing.LookAndFeel
      • javax.swing.plaf.multi.MultiLookAndFeel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.plaf.multi 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf.multi
的使用

没有 javax.swing.plaf.multi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


 Using the Multiplexing Look and Feel

This document is based on an article originally published in The Swing Connection.

The Multiplexing look and feel lets you supplement an ordinary look and feel (called the default look and feel) with one or more auxiliary look and feels. For example, you could simultaneously provide text-to-speech and Braille outputs, in addition to the ordinary visual output that a Swing-based application generates, by adding two auxiliary look and feels (one for text-to-speech, the other for Braille) to the default look and feel. The default look and feel can be any ordinary look and feel -- the Java or Windows look and feel, for example -- and requires no modifications to work with auxiliary look and feels.

This document has the following sections:

  • Overview
  • How to Use Auxiliary Look and Feels
  • Tips for Writing an Auxiliary Look and Feel
    • Dos and Don'ts
    • Extending UIDefaults
    • Examining Other UI Objects
  • How the Multiplexing Look and Feel is Implemented
  • How to Provide a Custom Multiplexing Look and Feel

Before reading further, you should be familiar with the concept of pluggable look and feels. For basic information, see Choosing the Look and Feel, a section in The Java Tutorial. For architectural details, you can read Pluggable look-and-feel architecture, a section within a Swing Connection article.

Overview

The classes in the javax.swing.plaf.multi package implement a multiplexing look and feel. A multiplexing look and feel transparently creates -- and simultaneously supports -- UI objects from several different look and feels in response to a component requesting its UI object (with the getUI method).

Without a multiplexing look and feel, a developer who wanted to enhance a particular look and feel would need to extend the classes supporting that look and feel. For example, to add text-to-speech support to the Java look and feel without using a multiplexing look and feel, the developer would need to create a group of classes that extend those of the Java look and feel, and add text-to-speech support to the new classes. If the developer also wanted to add text-to-speech support to other look and feels, such as Motif or Windows, the developers would need to create subclasses of those classes as well.

This approach has at least two shortcomings:

  • First, each subclass must use what is essentially a copy of the same code, potentially creating a difficult support situation for the developer.
  • Second, and more significantly for the end user, some application developers might force a particular look and feel to be used. When this approach is used, the end user can't even use the enhanced look and feel.

A multiplexing look and feel both these problems simultaneously because it allows multiple look and feels to be combined. The first problem (having to use what amounts to a second copy of the same code) is solved because the developer can create a specialized look and feel that can then be combined with other look and feels.

The second problem (having to force the use of a particular look and feel) is solved because a specialized look and feel can be used with whatever default look and feel the application may have locked in place.

The default multiplexing look and feel implementation, represented by the MultiLookAndFeel class in the javax.swing.plaf.multi package, is called (unsurprisingly) the Multiplexing look and feel.

How to Use Auxiliary Look and Feels

It's easy to use auxiliary look and feels with Swing. To instruct Swing to use the Multiplexing look and feel, all an application has to do is modify the $JDKHOME/lib/swing.properties file to include a definition of the swing.auxiliarylaf property. Swing treats the swing.auxiliarylaf property as a comma-separated list of LookAndFeel subclasses that specify what auxiliary look and feels should be used in addition to the default look and feel. If at least one valid LookAndFeel subclass is specified in the swing.auxiliarylaf property, Swing automatically uses the Multiplexing look and feel to load and support the default and auxiliary look and feels.

For example, let's assume that an application makes use of a look and feel that supports text-to-speech feedback, and also uses an look and feel that adds support for a device that emits perfume. Let's assume that the text-to-speech look and feel is named com.myco.TextTalkerLookAndFeel, and the look and feel that adds support for perfume is named com.smellco.OlfactoryLookAndFeel.

To tell Swing to use both these look and feels -- and to use a default look and feel at the same time -- your application could simply add the following line to the $JDKHOME/lib/swing.properties file:

    swing.auxiliarylaf=com.myco.TextTalkerLookAndFeel,
        com.smellco.OlfactoryLookAndFeel

This statement tells Swing to obtain a component's UI from the Multiplexing look and feel automatically, instead of obtaining it directly from the default look and feel. The resulting multiplexing UI is a small delegate that obtains and maintains UIs from the default and auxiliary look and feels. As a result, when a method is invoked in a multiplexing UI object, the multiplexing UI invokes the same method on each of the UIs obtained from the default and auxiliary look and feels.

Tips for Writing an Auxiliary Look and Feel

An auxiliary look and feel is like any other look and feel, except that it doesn't have to provide the complete support that a default look and feel must. For example, an auxiliary look and feel that supports just text-to-speech feedback doesn't need to provide any code for painting. Also, it might not need to support all components -- JSeparators, for example, might be ignored.

Auxiliary look and feels tend to be simple, so developing one can be easier than developing a visual look and feel. The developer can concentrate solely on providing the specialized functionality.

Because the primary purpose of an auxiliary look and feel is to enhance the default look and feel, auxiliary look and feels tend be nonvisual. Since an auxiliary look and feel is a genuine look and feel, however, there is nothing to prevent it from rendering information on the display.

Just like for any other look and feel, you implement an auxiliary look and feel by writing a subclass of javax.swing.LookAndFeel and creating subclasses of the FooUI classes defined in the javax.swing.plaf package.

Dos and Don'ts

The following paragraphs provide some general recommendations for developing auxiliary look and feels.

Use the installUI method to perform all initialization, and the uninstallUI method to perform all cleanup.

    The installUI and uninstallUI methods are invoked when a component's look and feel is set. The installUI method gives the new UI object a chance to add listeners on the component and its data model. Similarly, the uninstallUI method lets the previous UI object remove its listeners.

Don't extend visual look and feels.

    We recommended that you don't implement UI classes of an auxiliary look and feel as subclasses of the UI classes of a visual look and feel.�Why not? Because they might accidentally inherit code that installs listeners on a component object or renders the component on the display.�As a result, your auxiliary look and feel would compete with the default look and feel rather than cooperating with it.

    Instead, we recommend that the UI classes of an auxiliary look and feel directly extend the abstract UI classes in the javax.swing.plaf package.�By using this strategy, the developer of an auxiliary look and feel can avoid competing with the default look and feel.

Override all UI-specific methods your UI classes inherit.

    We recommend that each UI class of an auxiliary look and feel override the methods defined in the javax.swing.plaf UI classes it descends from The reasons for this recommendation are similar to those for not extending a visual look and feel. For example, the ComponentUI class, from which all UI classes descend, provides a default implementation for the update method. This default implementation paints on the display if the component is opaque. If a UI class from a non-visual auxiliary look and feel does not override this method, all opaque components appear as blank areas on the screen!

Extending UIDefaults

In many cases, you might want an auxiliary look and feel to be "incomplete."�That is, you might not need to support the complete set of components. For example, an auxiliary look and feel might choose to provide a ButtonUI subclass but no LabelUI subclass. This option is allowed, and the multiplexing look and feel gracefully handles such situations.

By default, however, Swing issues an error message when it asks a look and feel for a UI object and the look and feel does not support that UI. This message can be annoying, especially to auxiliary look-and-feel developers who don't want to support a particular component.

Fortunately, you can prevent this error message by creating a subclass of the UIDefaults class and returning an instance of it from the getDefaults method of your LookAndFeel class. For example:

public class MyAuxLookAndFeel
              extends LookAndFeel {
��� ...
��� public UIDefaults getDefaults() {
������� UIDefaults table =
new MyAuxUIDefaults();
������� Object[] uiDefaults = {
��������� "ButtonUI", "MyAuxButtonUI",
��������� ...
������� }
������� table.putDefaults(uiDefaults);
������� return table;
��� }
}

class MyAuxUIDefaults extends UIDefaults {
��� protected void getUIError(String msg) {
������� //System.err.println
//   ("An
              annoying message!");
��� }
}

In the preceding example, an auxiliary look and feel named MyAux creates a UIDefaults subclass that overrides the getUIError method.�The getUIError method is the method that is invoked when Swing cannot find a UI object in a look and feel.�By merely doing nothing in this method, you can avoid the error message.

Examining Other UI Objects

In rare instances, a UI object from an auxiliary look and feel may be interested in the default UI object used by the component.�In these cases, the UI object from auxiliary look and feel can obtain the UI from a component by calling its getUI method.�The returned UI is an instance of one of the multiplexing look and feel UI classes (for example, MultiButtonUI). The UI object from the auxiliary look and feel can call the getUIs method of the returned object to obtain an array containing a complete list of all UI objects handled by the multiplexing UI. The first element is guaranteed to be the UI created from the default look and feel.

How the Multiplexing Look and Feel Is Implemented

The Multiplexing look and feel (represented by javax.swing.plaf.multi.MultiLookAndFeel) is meant to be transparent to all developers and users.�It should "just work" -- and it is used only when the user tells Swing to use an auxiliary look and feel.

When the Multiplexing look and feel is in use, the type of the UI object associated with each component depends on whether any of the auxiliary look and feels currently in use support the component. If so, the component's UI object is an instance of a multiplexing UI. If only the default look and feel supports the component, then the component gets a UI object from the default look and feel, just as if no auxiliary look and feels were installed.

A multiplexing UI object obtains and maintains UI objects from the default and auxiliary look and feels, referring to these UIs in the following manner:

  • The UI object from the default look and feel is always the first to be created. After that, a UI object is created from each auxiliary look and feel in the order they are specified in the swing.auxiliarylaf property.

  • When a method that requests information from a UI object is invoked, the multiplexing UI object invokes the method on all the UI objects, but returns only the results from the UI for the default look and feel. For example, when the getPreferredSize method is invoked on a multiplexing UI, the UI returns only the results of invoking getPreferredSize on the UI obtained from the default look and feel. The getPreferredSize method is also invoked on the UI object for each auxiliary look and feel, but the return values are ignored.

  • When a method that does not request information from the UI object is invoked, the multiplexing UI object invokes that method on all UIs -- on the UI object obtained from the default look and feel and on all the UIs obtained from the auxiliary look and feels, as well. For example, invoking the installUI method on a multiplexing UI causes the multiplexing UI to invoke installUI on the UI obtained from the default look and feel and the UIs obtained from the auxiliary factories.

In all cases, the UI object obtained from the default look and feel is acted upon first, and then the auxiliary look and feels are acted upon in the order they are specified in the swing.auxiliarylaf property.

How to Provide a Custom Multiplexing Look and Feel

While we hope the behavior of the Multiplexing look and feel is flexible enough not to require an alternative multiplexing look and feel, Swing allows the user to specify another multiplexing look and feel to use.

To do that, all the user has to do is modify the $JDKHOME/lib/swing.properties file to include a definition of the swing.plaf.multiplexinglaf property.�Swing then treats the swing.plaf.multiplexinglaf property as a LookAndFeel subclass that supports multiplexing.

For example, if a user has a multiplexing look and feel represented by com.myco.SuperMultiLookAndFeel that is a better match for their needs than the Multiplexing look and feel (javax.swing.plaf.multi.MultiLookAndFeel), the user could include the following line in $JDKHOME/lib/swing.properties:

swing.plaf.multiplexinglaf = com.myco.SuperMultiLookAndFeel

This statement instructs Swing to use com.myco.SuperMultiLookAndFeel instead of javax.swing.plaf.multi.MultiLookAndFeel. But if you use this kind of statement, be careful, because the suppliers of auxiliary look and feels will most likely have developed and tested against our Multiplexing look and feel.


类 javax.swing.plaf.multi.MultiButtonUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiButtonUI
的使用

没有 javax.swing.plaf.multi.MultiButtonUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiColorChooserUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiColorChooserUI
的使用

没有 javax.swing.plaf.multi.MultiColorChooserUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiComboBoxUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiComboBoxUI
的使用

没有 javax.swing.plaf.multi.MultiComboBoxUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiDesktopIconUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiDesktopIconUI
的使用

没有 javax.swing.plaf.multi.MultiDesktopIconUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiDesktopPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiDesktopPaneUI
的使用

没有 javax.swing.plaf.multi.MultiDesktopPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiFileChooserUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiFileChooserUI
的使用

没有 javax.swing.plaf.multi.MultiFileChooserUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiInternalFrameUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiInternalFrameUI
的使用

没有 javax.swing.plaf.multi.MultiInternalFrameUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiLabelUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiLabelUI
的使用

没有 javax.swing.plaf.multi.MultiLabelUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiListUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiListUI
的使用

没有 javax.swing.plaf.multi.MultiListUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiLookAndFeel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiLookAndFeel
的使用

没有 javax.swing.plaf.multi.MultiLookAndFeel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiMenuBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiMenuBarUI
的使用

没有 javax.swing.plaf.multi.MultiMenuBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiMenuItemUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiMenuItemUI
的使用

没有 javax.swing.plaf.multi.MultiMenuItemUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiOptionPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiOptionPaneUI
的使用

没有 javax.swing.plaf.multi.MultiOptionPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiPanelUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiPanelUI
的使用

没有 javax.swing.plaf.multi.MultiPanelUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiPopupMenuUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiPopupMenuUI
的使用

没有 javax.swing.plaf.multi.MultiPopupMenuUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiProgressBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiProgressBarUI
的使用

没有 javax.swing.plaf.multi.MultiProgressBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiRootPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiRootPaneUI
的使用

没有 javax.swing.plaf.multi.MultiRootPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiScrollBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiScrollBarUI
的使用

没有 javax.swing.plaf.multi.MultiScrollBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiScrollPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiScrollPaneUI
的使用

没有 javax.swing.plaf.multi.MultiScrollPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiSeparatorUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiSeparatorUI
的使用

没有 javax.swing.plaf.multi.MultiSeparatorUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiSliderUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiSliderUI
的使用

没有 javax.swing.plaf.multi.MultiSliderUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiSpinnerUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiSpinnerUI
的使用

没有 javax.swing.plaf.multi.MultiSpinnerUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiSplitPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiSplitPaneUI
的使用

没有 javax.swing.plaf.multi.MultiSplitPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTabbedPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTabbedPaneUI
的使用

没有 javax.swing.plaf.multi.MultiTabbedPaneUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTableHeaderUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTableHeaderUI
的使用

没有 javax.swing.plaf.multi.MultiTableHeaderUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTableUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTableUI
的使用

没有 javax.swing.plaf.multi.MultiTableUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTextUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTextUI
的使用

没有 javax.swing.plaf.multi.MultiTextUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiToolBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiToolBarUI
的使用

没有 javax.swing.plaf.multi.MultiToolBarUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiToolTipUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiToolTipUI
的使用

没有 javax.swing.plaf.multi.MultiToolTipUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiTreeUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiTreeUI
的使用

没有 javax.swing.plaf.multi.MultiTreeUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.multi.MultiViewportUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.multi.MultiViewportUI
的使用

没有 javax.swing.plaf.multi.MultiViewportUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


ColorType (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
类 ColorType

java.lang.Object
    继承者  javax.swing.plaf.synth.ColorType

public class ColorType
extends Object

可从某种风格中获取的一些颜色的类型安全枚举。

每个 SynthStyle 都有一组 ColorType，可以使用 SynthStyle.getColor(SynthContext, ColorType) 方法来访问它们。SynthStyle 的 installDefaults 将安装 FOREGROUND 颜色作为 Component 的前景色，并安装 BACKGROUND 颜色作为组件的背景色（假定您没有显式指定前景色和背景色）。一些组件支持更多基于颜色的属性，例如，JList 拥有属性 selectionForeground，该属性将在组件状态为 SynthConstants.SELECTED 的情况下被映射到 FOREGROUND。

以下示例显示了一个自定义 SynthStyle，对于 DISABLED 状态，它返回红色，其他情况返回黑色。

 class MyStyle extends SynthStyle {
     private Color disabledColor = new ColorUIResource(Color.RED);
     private Color color = new ColorUIResource(Color.BLACK);
     protected Color getColorForState(SynthContext context, ColorType type){
         if (context.getComponentState() == SynthConstants.DISABLED) {
             return disabledColor;
         }
         return color;
     }
 }

从以下版本开始：
1.5

字段摘要
static ColorType | BACKGROUND 某一 region 背景的 ColorType。
static ColorType | FOCUS 焦点的 ColorType。
static ColorType | FOREGROUND 某一 region 前景的 ColorType。
static int | MAX_COUNT 最大 ColorType 数。
static ColorType | TEXT_BACKGROUND 某一 region 背景的 ColorType。
static ColorType | TEXT_FOREGROUND 某一 region 前景的 ColorType。
构造方法摘要
protected ColorType(String description)
创建一个具有指定描述的 ColorType。
方法摘要
int | getID() 以整数形式返回此 ColorType 的唯一 id。
String | toString() 返回此 ColorType 的文本描述。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

FOREGROUND

public static final ColorType FOREGROUND
某一 region 前景的 ColorType。

BACKGROUND

public static final ColorType BACKGROUND
某一 region 背景的 ColorType。

TEXT_FOREGROUND

public static final ColorType TEXT_FOREGROUND
某一 region 前景的 ColorType。

TEXT_BACKGROUND

public static final ColorType TEXT_BACKGROUND
某一 region 背景的 ColorType。

FOCUS

public static final ColorType FOCUS
焦点的 ColorType。

MAX_COUNT

public static final int MAX_COUNT
最大 ColorType 数。

构造方法详细信息

ColorType

protected ColorType(String description)
创建一个具有指定描述的 ColorType。

参数：
description - ColorType 的字符串描述。
方法详细信息

getID

public final int getID()
以整数形式返回此 ColorType 的唯一 id。

返回：
以整数形式返回此 ColorType 的唯一 id。

toString

public String toString()
返回此 ColorType 的文本描述。 返回值就是用来创建 ColorType 的那个值。

覆盖：
类 Object 中的 toString
返回：
字符串的描述。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Region (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
类 Region

java.lang.Object
    继承者  javax.swing.plaf.synth.Region

public class Region
extends Object

Swing 组件的独特呈现区域。一个组件可以支持一个或多个 region。特定组件 region 由此类中的类型安全枚举定义。

通常使用 region 作为标识将应用特殊样式的 Component 和区域的方法。Synth 的文件格式允许基于 Region 的名称来绑定样式。该名称源自常量的字段名称：

  1. 将所有字符映射为小写字母。
  2. 将第一个字符映射为大写字母。
  3. 将第一个字符加下划线后映射为大写字母。
  4. 移除所有下划线。
例如，要标识 SPLIT_PANE Region，应该使用 SplitPane。以下展示了一个自定义 SynthStyleFactory，它为分隔窗格返回一个特定样式：
    public SynthStyle getStyle(JComponent c, Region id) {
        if (id == Region.SPLIT_PANE) {
            return splitPaneStyle;
        }
        ...
    }
以下 xml 实现了相同的目标：
 <style id="splitPaneStyle">
   ...
 </style>
 <bind style="splitPaneStyle" type="region" key="SplitPane"/>

从以下版本开始：
1.5

字段摘要
static Region | ARROW_BUTTON ArrowButton 是特殊类型的按钮，也呈现了一个方向指示器（通常是一个箭头）。
static Region | BUTTON Button 的 region。
static Region | CHECK_BOX CheckBox 的 region。
static Region | CHECK_BOX_MENU_ITEM CheckBoxMenuItem 的 region。
static Region | COLOR_CHOOSER ColorChooser 的 region。
static Region | COMBO_BOX ComboBox 的 region。
static Region | DESKTOP_ICON DesktopIcon 的 region。
static Region | DESKTOP_PANE DesktopPane 的 region。
static Region | EDITOR_PANE EditorPane 的 region。
static Region | FILE_CHOOSER FileChooser 的 region。
static Region | FORMATTED_TEXT_FIELD FormattedTextField 的 region。
static Region | INTERNAL_FRAME InternalFrame 的 region。
static Region | INTERNAL_FRAME_TITLE_PANE InternalFrame 的 TitlePane。
static Region | LABEL Label 的 region。
static Region | LIST List 的 region。
static Region | MENU Menu 的 region。
static Region | MENU_BAR MenuBar 的 region。
static Region | MENU_ITEM MenuItem 的 region。
static Region | MENU_ITEM_ACCELERATOR MenuItem 的加速器 region。
static Region | OPTION_PANE OptionPane 的 region。
static Region | PANEL Panel 的 region。
static Region | PASSWORD_FIELD PasswordField 的 region。
static Region | POPUP_MENU PopupMenu 的 region。
static Region | POPUP_MENU_SEPARATOR PopupMenuSeparator 的 region。
static Region | PROGRESS_BAR ProgressBar 的 region。
static Region | RADIO_BUTTON RadioButton 的 region。
static Region | RADIO_BUTTON_MENU_ITEM RegionButtonMenuItem 的 region。
static Region | ROOT_PANE RootPane 的 region。
static Region | SCROLL_BAR ScrollBar 的 region。
static Region | SCROLL_BAR_THUMB ScrollBar 的 thumb。
static Region | SCROLL_BAR_TRACK ScrollBar 的滑道。
static Region | SCROLL_PANE ScrollPane 的 region。
static Region | SEPARATOR Separator 的 region。
static Region | SLIDER Slider 的 region。
static Region | SLIDER_THUMB 滑块的 thumb。
static Region | SLIDER_TRACK Slider 的滑道。
static Region | SPINNER Spinner 的 region。
static Region | SPLIT_PANE SplitPane 的 region。
static Region | SPLIT_PANE_DIVIDER SplitPane 的分隔器。
static Region | TABBED_PANE TabbedPane 的 region。
static Region | TABBED_PANE_CONTENT 包含内容的 TabbedPane 的 region。
static Region | TABBED_PANE_TAB 某一选项卡的 TabbedPane 的 region。
static Region | TABBED_PANE_TAB_AREA 包含选项卡的 TabbedPane 的 region。
static Region | TABLE Table 的 region。
static Region | TABLE_HEADER TableHeader 的 region。
static Region | TEXT_AREA TextArea 的 region。
static Region | TEXT_FIELD TextField 的 region。
static Region | TEXT_PANE TextPane 的 region。
static Region | TOGGLE_BUTTON ToggleButton 的 region。
static Region | TOOL_BAR ToolBar 的 region。
static Region | TOOL_BAR_CONTENT 包含内容的 ToolBar 的 region。
static Region | TOOL_BAR_DRAG_WINDOW 包含 ToolBar 的 Window 的 region。
static Region | TOOL_BAR_SEPARATOR ToolBar 分隔器的 region。
static Region | TOOL_TIP ToolTip 的 region。
static Region | TREE Tree 的 region。
static Region | TREE_CELL 用于某一单元格的 Tree 的 region。
static Region | VIEWPORT Viewport 的 region。
构造方法摘要
protected Region(String name, String ui, boolean subregion)
创建具有指定名称的 Region。
方法摘要
String | getName() 返回 region 的名称。
boolean | isSubregion() 如果 Region 是 Component 的子 region，则返回 true，否则返回 false。
String | toString() 返回 Region 的名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ARROW_BUTTON

public static final Region ARROW_BUTTON
ArrowButton 是特殊类型的按钮，也呈现了一个方向指示器（通常是一个箭头）。ArrowButton 由复合组件使用，例如 ScrollBar 的某些 ArrowButton。要将某一样式绑定到此 Region，使用名称 ArrowButton。

BUTTON

public static final Region BUTTON
Button 的 region。要将某一样式绑定到此 Region，使用名称 Button。

CHECK_BOX

public static final Region CHECK_BOX
CheckBox 的 region。要将某一样式绑定到此 Region，使用名称 CheckBox。

CHECK_BOX_MENU_ITEM

public static final Region CHECK_BOX_MENU_ITEM
CheckBoxMenuItem 的 region。要将某一样式绑定到此 Region，使用名称 CheckBoxMenuItem。

COLOR_CHOOSER

public static final Region COLOR_CHOOSER
ColorChooser 的 region。要将某一样式绑定到此 Region，使用名称 ColorChooser。

COMBO_BOX

public static final Region COMBO_BOX
ComboBox 的 region。要将某一样式绑定到此 Region，使用名称 ComboBox。

DESKTOP_PANE

public static final Region DESKTOP_PANE
DesktopPane 的 region。要将某一样式绑定到此 Region，使用名称 DesktopPane。

DESKTOP_ICON

public static final Region DESKTOP_ICON
DesktopIcon 的 region。要将某一样式绑定到此 Region，使用名称 DesktopIcon。

EDITOR_PANE

public static final Region EDITOR_PANE
EditorPane 的 region。要将某一样式绑定到此 Region，使用名称 EditorPane。

FILE_CHOOSER

public static final Region FILE_CHOOSER
FileChooser 的 region。要将某一样式绑定到此 Region，使用名称 FileChooser。

FORMATTED_TEXT_FIELD

public static final Region FORMATTED_TEXT_FIELD
FormattedTextField 的 region。要将某一样式绑定到此 Region，使用名称 FormattedTextField。

INTERNAL_FRAME

public static final Region INTERNAL_FRAME
InternalFrame 的 region。要将某一样式绑定到此 Region，使用名称 InternalFrame。

INTERNAL_FRAME_TITLE_PANE

public static final Region INTERNAL_FRAME_TITLE_PANE
InternalFrame 的 TitlePane。TitlePane 通常显示操作内部窗体的菜单、标题和窗口小部件。要将某一样式绑定到此 Region，使用名称 InternalFrameTitlePane。

LABEL

public static final Region LABEL
Label 的 region。要将某一样式绑定到此 Region，使用名称 Label。

LIST

public static final Region LIST
List 的 region。要将某一样式绑定到此 Region，使用名称 List。

MENU

public static final Region MENU
Menu 的 region。要将某一样式绑定到此 Region，使用名称 Menu。

MENU_BAR

public static final Region MENU_BAR
MenuBar 的 region。要将某一样式绑定到此 Region，使用名称 MenuBar。

MENU_ITEM

public static final Region MENU_ITEM
MenuItem 的 region。要将某一样式绑定到此 Region，使用名称 MenuItem。

MENU_ITEM_ACCELERATOR

public static final Region MENU_ITEM_ACCELERATOR
MenuItem 的加速器 region。要将某一样式绑定到此 Region，使用名称 MenuItemAccelerator。

OPTION_PANE

public static final Region OPTION_PANE
OptionPane 的 region。要将某一样式绑定到此 Region，使用名称 OptionPane。

PANEL

public static final Region PANEL
Panel 的 region。要将某一样式绑定到此 Region，使用名称 Panel。

PASSWORD_FIELD

public static final Region PASSWORD_FIELD
PasswordField 的 region。要将某一样式绑定到此 Region，使用名称 PasswordField。

POPUP_MENU

public static final Region POPUP_MENU
PopupMenu 的 region。要将某一样式绑定到此 Region，使用名称 PopupMenu。

POPUP_MENU_SEPARATOR

public static final Region POPUP_MENU_SEPARATOR
PopupMenuSeparator 的 region。要将某一样式绑定到此 Region，使用名称 PopupMenuSeparator。

PROGRESS_BAR

public static final Region PROGRESS_BAR
ProgressBar 的 region。要将某一样式绑定到此 Region，使用名称 ProgressBar。

RADIO_BUTTON

public static final Region RADIO_BUTTON
RadioButton 的 region。要将某一样式绑定到此 Region，使用名称 RadioButton。

RADIO_BUTTON_MENU_ITEM

public static final Region RADIO_BUTTON_MENU_ITEM
RegionButtonMenuItem 的 region。要将某一样式绑定到此 Region，使用名称 RadioButtonMenuItem。

ROOT_PANE

public static final Region ROOT_PANE
RootPane 的 region。要将某一样式绑定到此 Region，使用名称 RootPane。

SCROLL_BAR

public static final Region SCROLL_BAR
ScrollBar 的 region。要将某一样式绑定到此 Region，使用名称 ScrollBar。

SCROLL_BAR_TRACK

public static final Region SCROLL_BAR_TRACK
ScrollBar 的滑道。要将某一样式绑定到此 Region，使用名称 ScrollBarTrack。

SCROLL_BAR_THUMB

public static final Region SCROLL_BAR_THUMB
ScrollBar 的 thumb。Thumb 是 ScrollBar 的一个 region，它给出了 View 当前可见百分比的图形描述。要将某一样式绑定到此 Region，使用名称 ScrollBarThumb。

SCROLL_PANE

public static final Region SCROLL_PANE
ScrollPane 的 region。要将某一样式绑定到此 Region，使用名称 ScrollPane。

SEPARATOR

public static final Region SEPARATOR
Separator 的 region。要将某一样式绑定到此 Region，使用名称 Separator。

SLIDER

public static final Region SLIDER
Slider 的 region。要将某一样式绑定到此 Region，使用名称 Slider。

SLIDER_TRACK

public static final Region SLIDER_TRACK
Slider 的滑道。要将某一样式绑定到此 Region，使用名称 SliderTrack。

SLIDER_THUMB

public static final Region SLIDER_THUMB
滑块的 thumb。滑块的 thumb 标识当前值。要将某一样式绑定到此 Region，使用名称 SliderThumb。

SPINNER

public static final Region SPINNER
Spinner 的 region。要将某一样式绑定到此 Region，使用名称 Spinner。

SPLIT_PANE

public static final Region SPLIT_PANE
SplitPane 的 region。要将某一样式绑定到此 Region，使用名称 SplitPane。

SPLIT_PANE_DIVIDER

public static final Region SPLIT_PANE_DIVIDER
SplitPane 的分隔器。要将某一样式绑定到此 Region，使用名称 SplitPaneDivider。

TABBED_PANE

public static final Region TABBED_PANE
TabbedPane 的 region。要将某一样式绑定到此 Region，使用名称 TabbedPane。

TABBED_PANE_TAB

public static final Region TABBED_PANE_TAB
某一选项卡的 TabbedPane 的 region。要将某一样式绑定到此 Region，使用名称 TabbedPaneTab。

TABBED_PANE_TAB_AREA

public static final Region TABBED_PANE_TAB_AREA
包含选项卡的 TabbedPane 的 region。要将某一样式绑定到此 Region，使用名称 TabbedPaneTabArea。

TABBED_PANE_CONTENT

public static final Region TABBED_PANE_CONTENT
包含内容的 TabbedPane 的 region。要将某一样式绑定到此 Region，使用名称 TabbedPaneContent。

TABLE

public static final Region TABLE
Table 的 region。要将某一样式绑定到此 Region，使用名称 Table。

TABLE_HEADER

public static final Region TABLE_HEADER
TableHeader 的 region。要将某一样式绑定到此 Region，使用名称 TableHeader。

TEXT_AREA

public static final Region TEXT_AREA
TextArea 的 region。要将某一样式绑定到此 Region，使用名称 TextArea。

TEXT_FIELD

public static final Region TEXT_FIELD
TextField 的 region。要将某一样式绑定到此 Region，使用名称 TextField。

TEXT_PANE

public static final Region TEXT_PANE
TextPane 的 region。要将某一样式绑定到此 Region，使用名称 TextPane。

TOGGLE_BUTTON

public static final Region TOGGLE_BUTTON
ToggleButton 的 region。要将某一样式绑定到此 Region，使用名称 ToggleButton。

TOOL_BAR

public static final Region TOOL_BAR
ToolBar 的 region。要将某一样式绑定到此 Region，使用名称 ToolBar。

TOOL_BAR_CONTENT

public static final Region TOOL_BAR_CONTENT
包含内容的 ToolBar 的 region。要将某一样式绑定到此 Region，使用名称 ToolBarContent。

TOOL_BAR_DRAG_WINDOW

public static final Region TOOL_BAR_DRAG_WINDOW
包含 ToolBar 的 Window 的 region。要将某一样式绑定到此 Region，使用名称 ToolBarDragWindow。

TOOL_TIP

public static final Region TOOL_TIP
ToolTip 的 region。要将某一样式绑定到此 Region，使用名称 ToolTip。

TOOL_BAR_SEPARATOR

public static final Region TOOL_BAR_SEPARATOR
ToolBar 分隔器的 region。要将某一样式绑定到此 Region，使用名称 ToolBarSeparator。

TREE

public static final Region TREE
Tree 的 region。要将某一样式绑定到此 Region，使用名称 Tree。

TREE_CELL

public static final Region TREE_CELL
用于某一单元格的 Tree 的 region。要将某一样式绑定到此 Region，使用名称 TreeCell。

VIEWPORT

public static final Region VIEWPORT
Viewport 的 region。要将某一样式绑定到此 Region，使用名称 Viewport。

构造方法详细信息

Region

protected Region(String name,
                 String ui,
                 boolean subregion)
创建具有指定名称的 Region。应该只在想使用自定义 ComponentUI 类创建自己的 JComponent 子类时使用此方法。

参数：
name - region 的名称
ui - 将从 component.getUIClassID 中返回的字符串。如果是一个子 region，则该参数将为 null。
subregion - 判断是否是一个子 region。
方法详细信息

isSubregion

public boolean isSubregion()
如果 Region 是 Component 的子 region，则返回 true，否则返回 false。例如，Region.BUTTON 对应于某个 Component，因此 Region.BUTTON.isSubregion() 返回 false。

返回：
如果 Region 是 Component 的子 region，则返回 true。

getName

public String getName()
返回 region 的名称。

返回：
Region 的名称。

toString

public String toString()
返回 Region 的名称。

覆盖：
类 Object 中的 toString
返回：
Region 的名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynthConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
接口 SynthConstants

public interface SynthConstants

由 Synth 使用的常量。并不是所有的 Component 都支持所有状态。Component 至少将处于某种基本状态之一。也就是说，从 SynthContext.getComponentState() 中返回的值至少是以下值之一：ENABLED、MOUSE_OVER、PRESSED 或 DISABLED，这些值中还可能包含 FOCUSED、SELECTED 或 DEFAULT。

从以下版本开始：
1.5

字段摘要
static int | DEFAULT 指示 region 是默认区域。
static int | DISABLED 指示 region 未被启用的基本状态。
static int | ENABLED 指示组件被启用的基本状态。
static int | FOCUSED 指示 region 拥有焦点。
static int | MOUSE_OVER 指示鼠标位于 region 之上的基本状态。
static int | PRESSED 指示 region 处于被按下状态的基本状态。
static int | SELECTED 指示 region 被选定。

字段详细信息

ENABLED

static final int ENABLED
指示组件被启用的基本状态。

另请参见：
常量字段值

MOUSE_OVER

static final int MOUSE_OVER
指示鼠标位于 region 之上的基本状态。

另请参见：
常量字段值

PRESSED

static final int PRESSED
指示 region 处于被按下状态的基本状态。按下并不意味着用户已经按下鼠标按键。

另请参见：
常量字段值

DISABLED

static final int DISABLED
指示 region 未被启用的基本状态。

另请参见：
常量字段值

FOCUSED

static final int FOCUSED
指示 region 拥有焦点。

另请参见：
常量字段值

SELECTED

static final int SELECTED
指示 region 被选定。

另请参见：
常量字段值

DEFAULT

static final int DEFAULT
指示 region 是默认区域。此常量通常用于指示此按钮是某种特殊按钮。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynthContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
类 SynthContext

java.lang.Object
    继承者  javax.swing.plaf.synth.SynthContext

public class SynthContext
extends Object

一个不可变的瞬态对象，它包含有关 Region 的上下文信息。SynthContext 只在它传入的方法的使用期间被认为是有效的。换句话说，不应缓存传入的 SynthContext 并希望它仍然有效。

从以下版本开始：
1.5

构造方法摘要
SynthContext(JComponent component, Region region, SynthStyle style, int state)
创建一个具有指定值的 SynthContext。
方法摘要
JComponent | getComponent() 返回包含 region 的承载组件。
int | getComponentState() 返回窗口小部件的状态，它是 SynthConstants 中定义的值的位掩码。
Region | getRegion() 返回标识此状态的 Region。
SynthStyle | getStyle() 返回与此 Region 相关的样式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SynthContext

public SynthContext(JComponent component,
                    Region region,
                    SynthStyle style,
                    int state)
创建一个具有指定值的 SynthContext。这意味着为自定义 UI 实现器并为其创建子类。您几乎不需要构造一个 SynthContext，尽管一些方法将构造一个 SynthContext。

参数：
component - JComponent
region - 标识 JComponent 的一部分
style - 与组件有关的样式
state - SynthConstants 中定义的组件状态。
抛出：
NullPointerException - 如果 component、region 或 style 为 null。
方法详细信息

getComponent

public JComponent getComponent()
返回包含 region 的承载组件。

返回：
承载组件

getRegion

public Region getRegion()
返回标识此状态的 Region。

返回：
承载组件的 Region

getStyle

public SynthStyle getStyle()
返回与此 Region 相关的样式。

返回：
与此 region 相关的 SynthStyle。

getComponentState

public int getComponentState()
返回窗口小部件的状态，它是 SynthConstants 中定义的值的位掩码。Region 至少将处于以下状态之一：ENABLED、MOUSE_OVER、PRESSED 或 DISABLED。

返回：
Component 的状态
另请参见：
SynthConstants
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynthGraphicsUtils (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
类 SynthGraphicsUtils

java.lang.Object
    继承者  javax.swing.plaf.synth.SynthGraphicsUtils

public class SynthGraphicsUtils
extends Object

用于基本图形调用的包装器。

从以下版本开始：
1.5

构造方法摘要
SynthGraphicsUtils()
创建一个 SynthGraphicsUtils。
方法摘要
int | computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text) 返回传入字符串的大小。
void | drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2) 在两个端点之间绘制一条线。
void | drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey) 在两个端点之间绘制一条线。
int | getMaximumCharHeight(SynthContext context) 根据传入的 SynthContext 返回 Font 的最大高度。
Dimension | getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
Dimension | getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。
String | layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。
void | paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset) 绘制图标和文本。
void | paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex) 在指定位置上绘制文本。
void | paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex) 在指定位置上绘制文本。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SynthGraphicsUtils

public SynthGraphicsUtils()
创建一个 SynthGraphicsUtils。

方法详细信息

drawLine

public void drawLine(SynthContext context,
                     Object paintKey,
                     Graphics g,
                     int x1,
                     int y1,
                     int x2,
                     int y2)
在两个端点之间绘制一条线。

参数：
context - 指示承载区域。
paintKey - 标识请求绘制的组件部分，可以为 null。
g - 要绘制的 Graphics 对象
x1 - x 原点
y1 - y 原点
x2 - x 目标
y2 - y 目标

drawLine

public void drawLine(SynthContext context,
                     Object paintKey,
                     Graphics g,
                     int x1,
                     int y1,
                     int x2,
                     int y2,
                     Object styleKey)
在两个端点之间绘制一条线。

此实现只支持一个线风格键 "dashed"。"dashed" 线风格只应用于垂直和水平的线。

指定 null 或任何 "dashed" 以外的键将绘制出实线。

参数：
context - 指示承载区域
paintKey - 标识请求绘制的组件部分，可以为 null。
g - 要绘制的 Graphics 对象
x1 - x 原点
y1 - y 原点
x2 - x 目标
y2 - y 目标
styleKey - 标识所请求的线风格（例如，"dashed"）
从以下版本开始：
1.6

layoutText

public String layoutText(SynthContext ss,
                         FontMetrics fm,
                         String text,
                         Icon icon,
                         int hAlign,
                         int vAlign,
                         int hTextPosition,
                         int vTextPosition,
                         Rectangle viewR,
                         Rectangle iconR,
                         Rectangle textR,
                         int iconTextGap)
根据通过引用返回的放置图标和文本的位置，布局文本和图标。

参数：
ss - SynthContext
fm - 将使用的 Font 的 FontMetric，该参数可以忽略
text - 要布置的文本
icon - 要布置的图标
hAlign - 水平对齐方式
vAlign - 垂直对齐方式
hTextPosition - 水平文本位置
vTextPosition - 垂直文本位置
viewR - 在其中布置文本和图标的矩形。
iconR - 将图标边界放入其中的矩形
textR - 将文本放入其中的矩形
iconTextGap - 图标和文本之间的间隙

computeStringWidth

public int computeStringWidth(SynthContext ss,
                              Font font,
                              FontMetrics metrics,
                              String text)
返回传入字符串的大小。

参数：
ss - SynthContext
font - 要使用的字体
metrics - FontMetrics，可以忽略
text - 将获得其大小的文本。

getMinimumSize

public Dimension getMinimumSize(SynthContext ss,
                                Font font,
                                String text,
                                Icon icon,
                                int hAlign,
                                int vAlign,
                                int hTextPosition,
                                int vTextPosition,
                                int iconTextGap,
                                int mnemonicIndex)
返回正确呈现图标和文本所需的最小大小。

参数：
ss - SynthContext
font - 要使用的字体
text - 要布置的文本
icon - 要布置的图标
hAlign - 水平对齐方式
vAlign - 垂直对齐方式
hTextPosition - 水平文本位置
vTextPosition - 垂直文本位置
iconTextGap - 图标与文本之间的间隙
mnemonicIndex - 文本中的索引，在该处呈现助记符，-1 表示没有助记符。

getMaximumSize

public Dimension getMaximumSize(SynthContext ss,
                                Font font,
                                String text,
                                Icon icon,
                                int hAlign,
                                int vAlign,
                                int hTextPosition,
                                int vTextPosition,
                                int iconTextGap,
                                int mnemonicIndex)
返回正确呈现图标和文本所需的最大大小。

参数：
ss - SynthContext
font - 要使用的字体
text - 要布置的文本
icon - 要布置的图标
hAlign - 水平对齐方式
vAlign - 垂直对齐方式
hTextPosition - 水平文本位置
vTextPosition - 垂直文本位置
iconTextGap - 图标与文本之间的间隙
mnemonicIndex - 文本中的索引，在该处呈现助记符，-1 表示没有助记符。

getMaximumCharHeight

public int getMaximumCharHeight(SynthContext context)
根据传入的 SynthContext 返回 Font 的最大高度。

参数：
context - 确定字体使用的 SynthContext。
返回：
根据传入的上下文，返回字体中字符的最大高度。

getPreferredSize

public Dimension getPreferredSize(SynthContext ss,
                                  Font font,
                                  String text,
                                  Icon icon,
                                  int hAlign,
                                  int vAlign,
                                  int hTextPosition,
                                  int vTextPosition,
                                  int iconTextGap,
                                  int mnemonicIndex)
返回正确呈现图标和文本所需的首选大小。

参数：
ss - SynthContext
font - 要使用的字体
text - 要布置的文本
icon - 要布置的图标
hAlign - 水平对齐方式
vAlign - 垂直对齐方式
hTextPosition - 水平文本位置
vTextPosition - 垂直文本位置
iconTextGap - 图标与文本之间的间隙
mnemonicIndex - 文本中的索引，在该处呈现助记符，-1 表示没有助记符。

paintText

public void paintText(SynthContext ss,
                      Graphics g,
                      String text,
                      Rectangle bounds,
                      int mnemonicIndex)
在指定位置上绘制文本。此方法不会尝试以 html 形式呈现文本，也不会根据组件的 insets 进行偏移。

参数：
ss - SynthContext
g - 用来在其中呈现字符串的图形。
text - 要呈现的文本
bounds - 文本的绘制边界。
mnemonicIndex - 索引，在该处绘制字符串。

paintText

public void paintText(SynthContext ss,
                      Graphics g,
                      String text,
                      int x,
                      int y,
                      int mnemonicIndex)
在指定位置上绘制文本。此方法不会尝试以 html 形式呈现文本，也不会根据组件的 insets 进行偏移。

参数：
ss - SynthContext
g - 用来在其中呈现字符串的图形。
text - 要呈现的文本
x - 绘制文本的位置的 X 位置。
y - 绘制文本的位置的左上角。
mnemonicIndex - 索引，在该处绘制字符串。

paintText

public void paintText(SynthContext ss,
                      Graphics g,
                      String text,
                      Icon icon,
                      int hAlign,
                      int vAlign,
                      int hTextPosition,
                      int vTextPosition,
                      int iconTextGap,
                      int mnemonicIndex,
                      int textOffset)
绘制图标和文本。如有必要，此方法将以 html 形式呈现文本，并根据组件的 insets 对位置进行偏移。

参数：
ss - SynthContext
g - 在其中呈现字符串和图标的图形
text - 要布置的文本
icon - 要布置的图标
hAlign - 水平对齐方式
vAlign - 垂直对齐方式
hTextPosition - 水平文本位置
vTextPosition - 垂直文本位置
iconTextGap - 图标与文本之间的间隙
mnemonicIndex - 文本中的索引，在该处呈现助记符，-1 表示没有助记符。
textOffset - 进行绘制时文本的偏移量
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynthLookAndFeel (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
类 SynthLookAndFeel

java.lang.Object
    继承者  javax.swing.LookAndFeel
        继承者  javax.swing.plaf.basic.BasicLookAndFeel
            继承者  javax.swing.plaf.synth.SynthLookAndFeel
所有已实现的接口：
Serializable
public class SynthLookAndFeel
extends BasicLookAndFeel

SynthLookAndFeel 提供创建定制外观的基础。SynthLookAndFeel 不直接提供一个外观，所有绘制都被委托。您需要通过 load(java.io.InputStream, java.lang.Class) 方法提供一个配置文件，或者给 setStyleFactory(javax.swing.plaf.synth.SynthStyleFactory) 提供自己的 SynthStyleFactory。有关加载文件的示例，请参阅包摘要，有关为 setStyleFactory 提供自己的 SynthStyleFactory 的示例，请参阅 SynthStyleFactory。

警告：此类实现 Serializable，这是扩展 BasicLookAndFeel 的副作用。此类并不打算被序列化。试图对该类进行序列化将导致 NotSerializableException。

从以下版本开始：
1.5

构造方法摘要
SynthLookAndFeel()
创建一个 SynthLookAndFeel。
方法摘要
static ComponentUI | createUI(JComponent c) 为传入的 JComponent 创建 Synth 外观 ComponentUI。
UIDefaults | getDefaults() 返回此 SynthLookAndFeel 的默认值。
String | getDescription() 返回 SynthLookAndFeel 的文本描述。
String | getID() 返回一个标识此外观的短字符串。
String | getName() 返回一个标识此外观的短字符串。
static Region | getRegion(JComponent c) 返回 JComponent c 的 Region。
static SynthStyle | getStyle(JComponent c, Region region) 获取指定组件的指定 region 的 SynthStyle。
static SynthStyleFactory | getStyleFactory() 返回当前 SynthStyleFactory。
void | initialize() 在安装此外观时由 UIManager 调用。
boolean | isNativeLookAndFeel() 返回 false，SynthLookAndFeel 不是一个本机外观。
boolean | isSupportedLookAndFeel() 返回 true，SynthLookAndFeel 总是受支持。
void | load(InputStream input, Class<?> resourceBase) 加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。
void | load(URL url) 加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。
static void | setStyleFactory(SynthStyleFactory cache) 设置 SynthStyleFactory，由 synth 提供的 UI 类将使用它来获取 SynthStyle。
boolean | shouldUpdateStyleOnAncestorChanged() 返回在 JComponent 的祖先发生更改时，UI 是否应该更新 SynthStyleFactory 中的 SynthStyles。
void | uninitialize() 在卸载此外观时由 UIManager 调用。
static void | updateStyles(Component c) 更新与 c 关联的样式以及其所有子样式。
从类 javax.swing.plaf.basic.BasicLookAndFeel 继承的方法
createAudioAction, getAudioActionMap, initClassDefaults, initComponentDefaults, initSystemColorDefaults, loadSystemColors, playSound
从类 javax.swing.LookAndFeel 继承的方法
getDesktopPropertyValue, getDisabledIcon, getDisabledSelectedIcon, getLayoutStyle, getSupportsWindowDecorations, installBorder, installColors, installColorsAndFont, installProperty, loadKeyBindings, makeComponentInputMap, makeIcon, makeInputMap, makeKeyBindings, provideErrorFeedback, toString, uninstallBorder
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SynthLookAndFeel

public SynthLookAndFeel()
创建一个 SynthLookAndFeel。

为使返回的 SynthLookAndFeel 变得有用，需要调用 load 来指定 SynthStyle 的集合，或调用 setStyleFactory。

另请参见：
load(java.io.InputStream, java.lang.Class), setStyleFactory(javax.swing.plaf.synth.SynthStyleFactory)
方法详细信息

setStyleFactory

public static void setStyleFactory(SynthStyleFactory cache)
设置 SynthStyleFactory，由 synth 提供的 UI 类将使用它来获取 SynthStyle。

参数：
cache - UI 应该使用的 SynthStyleFactory。

getStyleFactory

public static SynthStyleFactory getStyleFactory()
返回当前 SynthStyleFactory。

返回：
SynthStyleFactory

getStyle

public static SynthStyle getStyle(JComponent c,
                                  Region region)
获取指定组件的指定 region 的 SynthStyle。这并非用于一般的使用情况，只有自定义 UI 才应该使用此方法。

参数：
c - 要获取 SynthStyle 的 JComponent
region - 标识指定组件的 region
返回：
要使用的 SynthStyle。

updateStyles

public static void updateStyles(Component c)
更新与 c 关联的样式以及其所有子样式。这是一个颜色更浅的 SwingUtilities.updateComponentTreeUI。

参数：
c - 要更新样式的 Component。

getRegion

public static Region getRegion(JComponent c)
返回 JComponent c 的 Region。

参数：
c - 要获取 Region 的 JComponent
返回：
对应于 c 的 Region

createUI

public static ComponentUI createUI(JComponent c)
为传入的 JComponent 创建 Synth 外观 ComponentUI。

参数：
c - 要创建 ComponentUI 的 JComponent
返回：
用于 c 的 ComponentUI

load

public void load(InputStream input,
                 Class<?> resourceBase)
          throws ParseException
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。resourceBase 用于解析所有基于路径的资源，例如，Image 将由 resourceBase.getResource(path) 解析。有关更多信息，请参阅 Synth File Format。

参数：
input - 从中加载数据的 InputStream
resourceBase - 用于解析所有图像或其他资源
抛出：
ParseException - 如果解析过程中发生错误
IllegalArgumentException - 如果 input 或 resourceBase 为 null

load

public void load(URL url)
          throws ParseException,
                 IOException
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。基于路径的资源相对于指定的风格 URL 进行解析。例如，Image 将通过 new URL(synthFile, path) 进行解析。有关更多信息，请参阅 Synth File Format。

参数：
url - 从中加载 SynthStyle 集合的 URL。
抛出：
ParseException - 如果解析过程中发生错误
IllegalArgumentException - 如果 synthSet 为 null
IOException - 如果 synthSet 不能作为 InputStream 打开
从以下版本开始：
1.6

initialize

public void initialize()
在安装此外观时由 UIManager 调用。

覆盖：
类 BasicLookAndFeel 中的 initialize
另请参见：
LookAndFeel.uninitialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

uninitialize

public void uninitialize()
在卸载此外观时由 UIManager 调用。

覆盖：
类 BasicLookAndFeel 中的 uninitialize
另请参见：
LookAndFeel.initialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

getDefaults

public UIDefaults getDefaults()
返回此 SynthLookAndFeel 的默认值。

覆盖：
类 BasicLookAndFeel 中的 getDefaults
返回：
默认表。
另请参见：
BasicLookAndFeel.initClassDefaults(javax.swing.UIDefaults),
BasicLookAndFeel.initSystemColorDefaults(javax.swing.UIDefaults),
BasicLookAndFeel.initComponentDefaults(javax.swing.UIDefaults)

isSupportedLookAndFeel

public boolean isSupportedLookAndFeel()
返回 true，SynthLookAndFeel 总是受支持。

指定者：
类 LookAndFeel 中的 isSupportedLookAndFeel
返回：
true。
另请参见：
UIManager.setLookAndFeel(javax.swing.LookAndFeel)

isNativeLookAndFeel

public boolean isNativeLookAndFeel()
返回 false，SynthLookAndFeel 不是一个本机外观。

指定者：
类 LookAndFeel 中的 isNativeLookAndFeel
返回：
false。

getDescription

public String getDescription()
返回 SynthLookAndFeel 的文本描述。

指定者：
类 LookAndFeel 中的 getDescription
返回：
synth 的文本描述。

getName

public String getName()
返回一个标识此外观的短字符串。

指定者：
类 LookAndFeel 中的 getName
返回：
标识此外观的短字符串。

getID

public String getID()
返回一个标识此外观的短字符串。

指定者：
类 LookAndFeel 中的 getID
返回：
标识此外观的短字符串。

shouldUpdateStyleOnAncestorChanged

public boolean shouldUpdateStyleOnAncestorChanged()
返回在 JComponent 的祖先发生更改时，UI 是否应该更新 SynthStyleFactory 中的 SynthStyles。提供了 SynthStyleFactory（基于容器层次结构的 getStyle 中返回的值）的子类将重写此方法以返回 true。

返回：
在祖先发生更改时，UI 是否应该更新 SynthStyleFactory 中的 SynthStyles。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynthPainter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
类 SynthPainter

java.lang.Object
    继承者  javax.swing.plaf.synth.SynthPainter

public abstract class SynthPainter
extends Object

SynthPainter 用于绘制 JComponent 的某些部分。每个 JComponent 至少有两个绘制方法：一个用于边框，另一个用于背景。有些 JComponent 有多个 Region，因此具有更多的绘制方法。

SynthPainter 的实例可通过 SynthStyle.getPainter(javax.swing.plaf.synth.SynthContext) 方法获取。

通常，可以通过 Synth 的 file 格式提供一个 SynthPainter。以下示例为所有将呈现图像 myImage.png 的 JButton 注册一个 painter：

  <style id="buttonStyle">
    <imagePainter path="myImage.png" sourceInsets="2 2 2 2"
                  paintCenter="true" stretch="true"/>
    <insets top="2" bottom="2" left="2" right="2"/>
  </style>
  <bind style="buttonStyle" type="REGION" key="button"/>

就不进行绘制这一点而言，SynthPainter 是抽象的，所有方法都是空的。尽管这些方法都不会抛出异常，但子类可以假定传入的是有效参数，或者它们也可以抛出 NullPointerException 或 IllegalArgumentException 来响应无效参数。

从以下版本开始：
1.5

构造方法摘要
SynthPainter()
方法摘要
void | paintArrowButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的背景。
void | paintArrowButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的边框。
void | paintArrowButtonForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int direction) 绘制箭头按钮的前景。
void | paintButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的背景。
void | paintButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的边框。
void | paintCheckBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的背景。
void | paintCheckBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的边框。
void | paintCheckBoxMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的背景。
void | paintCheckBoxMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的边框。
void | paintColorChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的背景。
void | paintColorChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的边框。
void | paintComboBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的背景。
void | paintComboBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的边框。
void | paintDesktopIconBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的背景。
void | paintDesktopIconBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的边框。
void | paintDesktopPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的背景。
void | paintDesktopPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的边框。
void | paintEditorPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的背景。
void | paintEditorPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的边框。
void | paintFileChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的背景。
void | paintFileChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的边框。
void | paintFormattedTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的背景。
void | paintFormattedTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的边框。
void | paintInternalFrameBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的背景。
void | paintInternalFrameBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的边框。
void | paintInternalFrameTitlePaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的背景。
void | paintInternalFrameTitlePaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的边框。
void | paintLabelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的背景。
void | paintLabelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的边框。
void | paintListBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的背景。
void | paintListBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的边框。
void | paintMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的背景。
void | paintMenuBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的背景。
void | paintMenuBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的边框。
void | paintMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的边框。
void | paintMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的背景。
void | paintMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的边框。
void | paintOptionPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的背景。
void | paintOptionPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的边框。
void | paintPanelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的背景。
void | paintPanelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的边框。
void | paintPasswordFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的背景。
void | paintPasswordFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的边框。
void | paintPopupMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的背景。
void | paintPopupMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的边框。
void | paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的背景。
void | paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的背景。
void | paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的边框。
void | paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的边框。
void | paintProgressBarForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的前景。
void | paintRadioButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的背景。
void | paintRadioButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的边框。
void | paintRadioButtonMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的背景。
void | paintRadioButtonMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的边框。
void | paintRootPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的背景。
void | paintRootPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的边框。
void | paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的背景。
void | paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的背景。
void | paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的边框。
void | paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的边框。
void | paintScrollBarThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的背景。
void | paintScrollBarThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的边框。
void | paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的背景。
void | paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的背景。
void | paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的边框。
void | paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的边框。
void | paintScrollPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的背景。
void | paintScrollPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的边框。
void | paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的背景。
void | paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的背景。
void | paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的边框。
void | paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的边框。
void | paintSeparatorForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的前景。
void | paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的背景。
void | paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的背景。
void | paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的边框。
void | paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的边框。
void | paintSliderThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的背景。
void | paintSliderThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的边框。
void | paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的背景。
void | paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的背景。
void | paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的边框。
void | paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的边框。
void | paintSpinnerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的背景。
void | paintSpinnerBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的边框。
void | paintSplitPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的背景。
void | paintSplitPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的边框。
void | paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的分隔栏的背景。
void | paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的背景。
void | paintSplitPaneDividerForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的前景。
void | paintSplitPaneDragDivider(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 当用户拖动分隔符时，绘制分隔窗格的分隔栏。
void | paintTabbedPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的背景。
void | paintTabbedPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的边框。
void | paintTabbedPaneContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的背景。
void | paintTabbedPaneContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的边框。
void | paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的背景。
void | paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的背景。
void | paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的边框。
void | paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的边框。
void | paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的背景。
void | paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的背景。
void | paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的边框。
void | paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的边框。
void | paintTableBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的背景。
void | paintTableBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的边框。
void | paintTableHeaderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的背景。
void | paintTableHeaderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的边框。
void | paintTextAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的背景。
void | paintTextAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的边框。
void | paintTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的背景。
void | paintTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的边框。
void | paintTextPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的背景。
void | paintTextPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的边框。
void | paintToggleButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的背景。
void | paintToggleButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的边框。
void | paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的背景。
void | paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的背景。
void | paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的边框。
void | paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的边框。
void | paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的背景。
void | paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的背景。
void | paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的边框。
void | paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的边框。
void | paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | paintToolTipBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的背景。
void | paintToolTipBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的边框。
void | paintTreeBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的背景。
void | paintTreeBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的边框。
void | paintTreeCellBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的背景。
void | paintTreeCellBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的边框。
void | paintTreeCellFocus(SynthContext context, Graphics g, int x, int y, int w, int h) 当树中某个单元格拥有焦点时，绘制该单元格的焦点指示器。
void | paintViewportBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的背景。
void | paintViewportBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的边框。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SynthPainter

public SynthPainter()
方法详细信息

paintArrowButtonBackground

public void paintArrowButtonBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h)
绘制箭头按钮的背景。箭头按钮由 JScrollBar 之类的组件创建。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintArrowButtonBorder

public void paintArrowButtonBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制箭头按钮的边框。箭头按钮由 JScrollBar 之类的组件创建。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintArrowButtonForeground

public void paintArrowButtonForeground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h,
                                       int direction)
绘制箭头按钮的前景。此方法负责绘制某一方向的图形表示形式，通常是一个箭头。箭头按钮由 JScrollBar 之类的组件创建。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
direction - SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一

paintButtonBackground

public void paintButtonBackground(SynthContext context,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h)
绘制按钮的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintButtonBorder

public void paintButtonBorder(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
绘制按钮的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintCheckBoxMenuItemBackground

public void paintCheckBoxMenuItemBackground(SynthContext context,
                                            Graphics g,
                                            int x,
                                            int y,
                                            int w,
                                            int h)
绘制复选框菜单项的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintCheckBoxMenuItemBorder

public void paintCheckBoxMenuItemBorder(SynthContext context,
                                        Graphics g,
                                        int x,
                                        int y,
                                        int w,
                                        int h)
绘制复选框菜单项的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintCheckBoxBackground

public void paintCheckBoxBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制复选框的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintCheckBoxBorder

public void paintCheckBoxBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制复选框的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintColorChooserBackground

public void paintColorChooserBackground(SynthContext context,
                                        Graphics g,
                                        int x,
                                        int y,
                                        int w,
                                        int h)
绘制颜色选择器的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintColorChooserBorder

public void paintColorChooserBorder(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制颜色选择器的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintComboBoxBackground

public void paintComboBoxBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制组合框的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintComboBoxBorder

public void paintComboBoxBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制组合框的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintDesktopIconBackground

public void paintDesktopIconBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h)
绘制桌面图标的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintDesktopIconBorder

public void paintDesktopIconBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制桌面图标的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintDesktopPaneBackground

public void paintDesktopPaneBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h)
绘制桌面窗格的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintDesktopPaneBorder

public void paintDesktopPaneBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制桌面窗格的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintEditorPaneBackground

public void paintEditorPaneBackground(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h)
绘制编辑器窗格的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintEditorPaneBorder

public void paintEditorPaneBorder(SynthContext context,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h)
绘制编辑器窗格的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintFileChooserBackground

public void paintFileChooserBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h)
绘制文件选择器的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintFileChooserBorder

public void paintFileChooserBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制文件选择器的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintFormattedTextFieldBackground

public void paintFormattedTextFieldBackground(SynthContext context,
                                              Graphics g,
                                              int x,
                                              int y,
                                              int w,
                                              int h)
绘制已格式化文本字段的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintFormattedTextFieldBorder

public void paintFormattedTextFieldBorder(SynthContext context,
                                          Graphics g,
                                          int x,
                                          int y,
                                          int w,
                                          int h)
绘制已格式化文本字段的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintInternalFrameTitlePaneBackground

public void paintInternalFrameTitlePaneBackground(SynthContext context,
                                                  Graphics g,
                                                  int x,
                                                  int y,
                                                  int w,
                                                  int h)
绘制内部窗体标题窗格的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintInternalFrameTitlePaneBorder

public void paintInternalFrameTitlePaneBorder(SynthContext context,
                                              Graphics g,
                                              int x,
                                              int y,
                                              int w,
                                              int h)
绘制内部窗体标题窗格的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintInternalFrameBackground

public void paintInternalFrameBackground(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h)
绘制内部窗体的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintInternalFrameBorder

public void paintInternalFrameBorder(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
绘制内部窗体的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintLabelBackground

public void paintLabelBackground(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
绘制标签的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintLabelBorder

public void paintLabelBorder(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
绘制标签的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintListBackground

public void paintListBackground(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制列表的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintListBorder

public void paintListBorder(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
绘制列表的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintMenuBarBackground

public void paintMenuBarBackground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制菜单栏的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintMenuBarBorder

public void paintMenuBarBorder(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h)
绘制菜单栏的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintMenuItemBackground

public void paintMenuItemBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制菜单项的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintMenuItemBorder

public void paintMenuItemBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制菜单项的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintMenuBackground

public void paintMenuBackground(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制菜单的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintMenuBorder

public void paintMenuBorder(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
绘制菜单的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintOptionPaneBackground

public void paintOptionPaneBackground(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h)
绘制选项窗格的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintOptionPaneBorder

public void paintOptionPaneBorder(SynthContext context,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h)
绘制选项窗格的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintPanelBackground

public void paintPanelBackground(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
绘制面板的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintPanelBorder

public void paintPanelBorder(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
绘制面板的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintPasswordFieldBackground

public void paintPasswordFieldBackground(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h)
绘制密码字段的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintPasswordFieldBorder

public void paintPasswordFieldBorder(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
绘制密码字段的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintPopupMenuBackground

public void paintPopupMenuBackground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
绘制弹出菜单的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintPopupMenuBorder

public void paintPopupMenuBorder(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
绘制弹出菜单的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintProgressBarBackground

public void paintProgressBarBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h)
绘制进度条的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintProgressBarBackground

public void paintProgressBarBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h,
                                       int orientation)
绘制进度条的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JProgressBar.HORIZONTAL 或 JProgressBar.VERTICAL
从以下版本开始：
1.6

paintProgressBarBorder

public void paintProgressBarBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制进度条的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintProgressBarBorder

public void paintProgressBarBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h,
                                   int orientation)
绘制进度条的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JProgressBar.HORIZONTAL 或 JProgressBar.VERTICAL
从以下版本开始：
1.6

paintProgressBarForeground

public void paintProgressBarForeground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h,
                                       int orientation)
绘制进度条的前景。此方法负责提供进度条的进度指示。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - 为 JProgressBar.HORIZONTAL 或 JProgressBar.VERTICAL 之一

paintRadioButtonMenuItemBackground

public void paintRadioButtonMenuItemBackground(SynthContext context,
                                               Graphics g,
                                               int x,
                                               int y,
                                               int w,
                                               int h)
绘制单选钮菜单项的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintRadioButtonMenuItemBorder

public void paintRadioButtonMenuItemBorder(SynthContext context,
                                           Graphics g,
                                           int x,
                                           int y,
                                           int w,
                                           int h)
绘制单选钮菜单项的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintRadioButtonBackground

public void paintRadioButtonBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h)
绘制单选钮的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintRadioButtonBorder

public void paintRadioButtonBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制单选钮的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintRootPaneBackground

public void paintRootPaneBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制根窗体的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintRootPaneBorder

public void paintRootPaneBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制根窗体的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintScrollBarBackground

public void paintScrollBarBackground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
绘制滚动条的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintScrollBarBackground

public void paintScrollBarBackground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h,
                                     int orientation)
绘制滚动条的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JScrollBar 的方向，JScrollBar.HORIZONTAL 或 JScrollBar.VERTICAL
从以下版本开始：
1.6

paintScrollBarBorder

public void paintScrollBarBorder(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
绘制滚动条的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintScrollBarBorder

public void paintScrollBarBorder(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h,
                                 int orientation)
绘制滚动条的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JScrollBar 的方向，JScrollBar.HORIZONTAL 或 JScrollBar.VERTICAL
从以下版本开始：
1.6

paintScrollBarThumbBackground

public void paintScrollBarThumbBackground(SynthContext context,
                                          Graphics g,
                                          int x,
                                          int y,
                                          int w,
                                          int h,
                                          int orientation)
绘制滚动条的 thumb 的背景。该 thumb 提供关于 Component 在 JScrollPane 中的可见程度的图形指示。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JScrollBar 的方向，JScrollBar.HORIZONTAL 或 JScrollBar.VERTICAL

paintScrollBarThumbBorder

public void paintScrollBarThumbBorder(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h,
                                      int orientation)
绘制滚动条的 thumb 的边框。该 thumb 提供关于 Component 在 JScrollPane 中的可见程度的图形指示。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JScrollBar 的方向，JScrollBar.HORIZONTAL 或 JScrollBar.VERTICAL

paintScrollBarTrackBackground

public void paintScrollBarTrackBackground(SynthContext context,
                                          Graphics g,
                                          int x,
                                          int y,
                                          int w,
                                          int h)
绘制滚动条滑道的背景。该滑道包含 thumb。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintScrollBarTrackBackground

public void paintScrollBarTrackBackground(SynthContext context,
                                          Graphics g,
                                          int x,
                                          int y,
                                          int w,
                                          int h,
                                          int orientation)
绘制滚动条滑道的背景。该滑道包含 thumb。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JScrollBar 的方向，JScrollBar.HORIZONTAL 或 JScrollBar.VERTICAL
从以下版本开始：
1.6

paintScrollBarTrackBorder

public void paintScrollBarTrackBorder(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h)
绘制滚动条滑道的边框。该滑道包含 thumb。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintScrollBarTrackBorder

public void paintScrollBarTrackBorder(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h,
                                      int orientation)
绘制滚动条滑道的边框。该滑道包含 thumb。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JScrollBar 的方向，JScrollBar.HORIZONTAL 或 JScrollBar.VERTICAL
从以下版本开始：
1.6

paintScrollPaneBackground

public void paintScrollPaneBackground(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h)
绘制滚动窗格的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintScrollPaneBorder

public void paintScrollPaneBorder(SynthContext context,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h)
绘制滚动窗格的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSeparatorBackground

public void paintSeparatorBackground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
绘制分隔符的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSeparatorBackground

public void paintSeparatorBackground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h,
                                     int orientation)
绘制分隔符的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSeparator.HORIZONTAL 或 JSeparator.VERTICAL
从以下版本开始：
1.6

paintSeparatorBorder

public void paintSeparatorBorder(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
绘制分隔符的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSeparatorBorder

public void paintSeparatorBorder(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h,
                                 int orientation)
绘制分隔符的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSeparator.HORIZONTAL 或 JSeparator.VERTICAL
从以下版本开始：
1.6

paintSeparatorForeground

public void paintSeparatorForeground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h,
                                     int orientation)
绘制分隔符的前景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSeparator.HORIZONTAL 或 JSeparator.VERTICAL

paintSliderBackground

public void paintSliderBackground(SynthContext context,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h)
绘制滑块的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSliderBackground

public void paintSliderBackground(SynthContext context,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h,
                                  int orientation)
绘制滑块的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSlider.HORIZONTAL 或 JSlider.VERTICAL
从以下版本开始：
1.6

paintSliderBorder

public void paintSliderBorder(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h)
绘制滑块的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSliderBorder

public void paintSliderBorder(SynthContext context,
                              Graphics g,
                              int x,
                              int y,
                              int w,
                              int h,
                              int orientation)
绘制滑块的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSlider.HORIZONTAL 或 JSlider.VERTICAL
从以下版本开始：
1.6

paintSliderThumbBackground

public void paintSliderThumbBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h,
                                       int orientation)
绘制滑块的 thumb 的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSlider.HORIZONTAL 或 JSlider.VERTICAL

paintSliderThumbBorder

public void paintSliderThumbBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h,
                                   int orientation)
绘制滑块的 thumb 的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSlider.HORIZONTAL 或 JSlider.VERTICAL

paintSliderTrackBackground

public void paintSliderTrackBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h)
绘制滑块的滑道的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSliderTrackBackground

public void paintSliderTrackBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h,
                                       int orientation)
绘制滑块的滑道的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSlider.HORIZONTAL 或 JSlider.VERTICAL
从以下版本开始：
1.6

paintSliderTrackBorder

public void paintSliderTrackBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制滑块的滑道的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSliderTrackBorder

public void paintSliderTrackBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h,
                                   int orientation)
绘制滑块的滑道的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSlider.HORIZONTAL 或 JSlider.VERTICAL
从以下版本开始：
1.6

paintSpinnerBackground

public void paintSpinnerBackground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制 spinner 的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSpinnerBorder

public void paintSpinnerBorder(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h)
绘制 spinner 的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSplitPaneDividerBackground

public void paintSplitPaneDividerBackground(SynthContext context,
                                            Graphics g,
                                            int x,
                                            int y,
                                            int w,
                                            int h)
绘制分隔窗格的分隔栏的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSplitPaneDividerBackground

public void paintSplitPaneDividerBackground(SynthContext context,
                                            Graphics g,
                                            int x,
                                            int y,
                                            int w,
                                            int h,
                                            int orientation)
绘制分隔窗格的分隔栏的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSplitPane.HORIZONTAL_SPLIT 或 JSplitPane.VERTICAL_SPLIT
从以下版本开始：
1.6

paintSplitPaneDividerForeground

public void paintSplitPaneDividerForeground(SynthContext context,
                                            Graphics g,
                                            int x,
                                            int y,
                                            int w,
                                            int h,
                                            int orientation)
绘制分隔窗格的分隔栏的前景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSplitPane.HORIZONTAL_SPLIT 或 JSplitPane.VERTICAL_SPLIT

paintSplitPaneDragDivider

public void paintSplitPaneDragDivider(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h,
                                      int orientation)
当用户拖动分隔符时，绘制分隔窗格的分隔栏。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JSplitPane.HORIZONTAL_SPLIT 或 JSplitPane.VERTICAL_SPLIT

paintSplitPaneBackground

public void paintSplitPaneBackground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
绘制分隔窗格的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintSplitPaneBorder

public void paintSplitPaneBorder(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
绘制分隔窗格的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTabbedPaneBackground

public void paintTabbedPaneBackground(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h)
绘制选项卡窗格的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTabbedPaneBorder

public void paintTabbedPaneBorder(SynthContext context,
                                  Graphics g,
                                  int x,
                                  int y,
                                  int w,
                                  int h)
绘制选项卡窗格的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTabbedPaneTabAreaBackground

public void paintTabbedPaneTabAreaBackground(SynthContext context,
                                             Graphics g,
                                             int x,
                                             int y,
                                             int w,
                                             int h)
绘制选项卡窗格的选项卡背后区域的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTabbedPaneTabAreaBackground

public void paintTabbedPaneTabAreaBackground(SynthContext context,
                                             Graphics g,
                                             int x,
                                             int y,
                                             int w,
                                             int h,
                                             int orientation)
绘制选项卡窗格的选项卡背后区域的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JTabbedPane.TOP、JTabbedPane.LEFT、JTabbedPane.BOTTOM、或 JTabbedPane.RIGHT 之一
从以下版本开始：
1.6

paintTabbedPaneTabAreaBorder

public void paintTabbedPaneTabAreaBorder(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h)
绘制选项卡窗格的选项卡背后区域的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTabbedPaneTabAreaBorder

public void paintTabbedPaneTabAreaBorder(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h,
                                         int orientation)
绘制选项卡窗格的选项卡背后区域的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JTabbedPane.TOP、JTabbedPane.LEFT、JTabbedPane.BOTTOM、或 JTabbedPane.RIGHT 之一
从以下版本开始：
1.6

paintTabbedPaneTabBackground

public void paintTabbedPaneTabBackground(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h,
                                         int tabIndex)
绘制选项卡窗格的选项卡的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
tabIndex - 要绘制选项卡的索引。

paintTabbedPaneTabBackground

public void paintTabbedPaneTabBackground(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h,
                                         int tabIndex,
                                         int orientation)
绘制选项卡窗格的选项卡的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
tabIndex - 要绘制选项卡的索引。
orientation - JTabbedPane.TOP、JTabbedPane.LEFT、JTabbedPane.BOTTOM、或 JTabbedPane.RIGHT 之一
从以下版本开始：
1.6

paintTabbedPaneTabBorder

public void paintTabbedPaneTabBorder(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h,
                                     int tabIndex)
绘制选项卡窗格的选项卡的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
tabIndex - 要绘制选项卡的索引。

paintTabbedPaneTabBorder

public void paintTabbedPaneTabBorder(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h,
                                     int tabIndex,
                                     int orientation)
绘制选项卡窗格的选项卡的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
tabIndex - 要绘制选项卡的索引。
orientation - JTabbedPane.TOP、JTabbedPane.LEFT、JTabbedPane.BOTTOM、或 JTabbedPane.RIGHT 之一
从以下版本开始：
1.6

paintTabbedPaneContentBackground

public void paintTabbedPaneContentBackground(SynthContext context,
                                             Graphics g,
                                             int x,
                                             int y,
                                             int w,
                                             int h)
绘制包含选项卡窗格中所选选项卡内容的区域的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTabbedPaneContentBorder

public void paintTabbedPaneContentBorder(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h)
绘制包含选项卡窗格中所选选项卡内容的区域的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTableHeaderBackground

public void paintTableHeaderBackground(SynthContext context,
                                       Graphics g,
                                       int x,
                                       int y,
                                       int w,
                                       int h)
绘制表标题的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTableHeaderBorder

public void paintTableHeaderBorder(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制表标题的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTableBackground

public void paintTableBackground(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
绘制表的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTableBorder

public void paintTableBorder(SynthContext context,
                             Graphics g,
                             int x,
                             int y,
                             int w,
                             int h)
绘制表的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTextAreaBackground

public void paintTextAreaBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制文本区域的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTextAreaBorder

public void paintTextAreaBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制文本区域的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTextPaneBackground

public void paintTextPaneBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制文本窗格的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTextPaneBorder

public void paintTextPaneBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制文本窗格的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTextFieldBackground

public void paintTextFieldBackground(SynthContext context,
                                     Graphics g,
                                     int x,
                                     int y,
                                     int w,
                                     int h)
绘制文本字段的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTextFieldBorder

public void paintTextFieldBorder(SynthContext context,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int w,
                                 int h)
绘制文本字段的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToggleButtonBackground

public void paintToggleButtonBackground(SynthContext context,
                                        Graphics g,
                                        int x,
                                        int y,
                                        int w,
                                        int h)
绘制切换按钮的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToggleButtonBorder

public void paintToggleButtonBorder(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制切换按钮的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToolBarBackground

public void paintToolBarBackground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制工具栏的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToolBarBackground

public void paintToolBarBackground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h,
                                   int orientation)
绘制工具栏的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JToolBar.HORIZONTAL 或 JToolBar.VERTICAL
从以下版本开始：
1.6

paintToolBarBorder

public void paintToolBarBorder(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h)
绘制工具栏的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToolBarBorder

public void paintToolBarBorder(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h,
                               int orientation)
绘制工具栏的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JToolBar.HORIZONTAL 或 JToolBar.VERTICAL
从以下版本开始：
1.6

paintToolBarContentBackground

public void paintToolBarContentBackground(SynthContext context,
                                          Graphics g,
                                          int x,
                                          int y,
                                          int w,
                                          int h)
绘制工具栏内容区的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToolBarContentBackground

public void paintToolBarContentBackground(SynthContext context,
                                          Graphics g,
                                          int x,
                                          int y,
                                          int w,
                                          int h,
                                          int orientation)
绘制工具栏内容区的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JToolBar.HORIZONTAL 或 JToolBar.VERTICAL
从以下版本开始：
1.6

paintToolBarContentBorder

public void paintToolBarContentBorder(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h)
绘制工具栏内容区的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToolBarContentBorder

public void paintToolBarContentBorder(SynthContext context,
                                      Graphics g,
                                      int x,
                                      int y,
                                      int w,
                                      int h,
                                      int orientation)
绘制工具栏内容区的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JToolBar.HORIZONTAL 或 JToolBar.VERTICAL
从以下版本开始：
1.6

paintToolBarDragWindowBackground

public void paintToolBarDragWindowBackground(SynthContext context,
                                             Graphics g,
                                             int x,
                                             int y,
                                             int w,
                                             int h)
绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToolBarDragWindowBackground

public void paintToolBarDragWindowBackground(SynthContext context,
                                             Graphics g,
                                             int x,
                                             int y,
                                             int w,
                                             int h,
                                             int orientation)
绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JToolBar.HORIZONTAL 或 JToolBar.VERTICAL
从以下版本开始：
1.6

paintToolBarDragWindowBorder

public void paintToolBarDragWindowBorder(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h)
绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToolBarDragWindowBorder

public void paintToolBarDragWindowBorder(SynthContext context,
                                         Graphics g,
                                         int x,
                                         int y,
                                         int w,
                                         int h,
                                         int orientation)
绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。此实现调用不带 orientation 的同名方法。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
orientation - JToolBar.HORIZONTAL 或 JToolBar.VERTICAL
从以下版本开始：
1.6

paintToolTipBackground

public void paintToolTipBackground(SynthContext context,
                                   Graphics g,
                                   int x,
                                   int y,
                                   int w,
                                   int h)
绘制工具提示的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintToolTipBorder

public void paintToolTipBorder(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h)
绘制工具提示的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTreeBackground

public void paintTreeBackground(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制树的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTreeBorder

public void paintTreeBorder(SynthContext context,
                            Graphics g,
                            int x,
                            int y,
                            int w,
                            int h)
绘制树的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTreeCellBackground

public void paintTreeCellBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制包含树中某个单元格的行的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTreeCellBorder

public void paintTreeCellBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制包含树中某个单元格的行的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintTreeCellFocus

public void paintTreeCellFocus(SynthContext context,
                               Graphics g,
                               int x,
                               int y,
                               int w,
                               int h)
当树中某个单元格拥有焦点时，绘制该单元格的焦点指示器。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintViewportBackground

public void paintViewportBackground(SynthContext context,
                                    Graphics g,
                                    int x,
                                    int y,
                                    int w,
                                    int h)
绘制视口的背景。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度

paintViewportBorder

public void paintViewportBorder(SynthContext context,
                                Graphics g,
                                int x,
                                int y,
                                int w,
                                int h)
绘制视口的边框。

参数：
context - 标识要绘制的 JComponent 和 Region 的 SynthContext
g - 要绘制的 Graphics
x - 要绘制区域的 X 坐标
y - 要绘制区域的 Y 坐标
w - 要绘制区域的宽度
h - 要绘制区域的高度
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynthStyle (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
类 SynthStyle

java.lang.Object
    继承者  javax.swing.plaf.synth.SynthStyle

public abstract class SynthStyle
extends Object

SynthStyle 是一个样式属性集。每个 SynthUI 至少引用一个 SynthStyle，SynthStyle 是使用 SynthStyleFactory 获得的。通常不需要直接与此类进行交互，而是要将一个 Synth File Format 文件加载到 SynthLookAndFeel 中，后者将创建一个 SynthStyle 集。

从以下版本开始：
1.5
另请参见：
SynthLookAndFeel, SynthStyleFactory

构造方法摘要
SynthStyle()
构造一个 SynthStyle。
方法摘要
Object | get(SynthContext context, Object key) 某个 region 特定样式属性的获取器。
boolean | getBoolean(SynthContext context, Object key, boolean defaultValue) 获得其值是一个 Boolean 值的特定样式属性的便捷方法。
Color | getColor(SynthContext context, ColorType type) 返回指定状态的颜色。
protected abstract Color | getColorForState(SynthContext context, ColorType type) 返回指定状态的颜色。
Font | getFont(SynthContext context) 返回指定状态的 Font。
protected abstract Font | getFontForState(SynthContext context) 返回指定状态的字体。
SynthGraphicsUtils | getGraphicsUtils(SynthContext context) 返回指定上下文的 SynthGraphicUtils。
Icon | getIcon(SynthContext context, Object key) 获得其值是一个 Icon 的特定样式属性的便捷方法。
Insets | getInsets(SynthContext context, Insets insets) 返回用来计算大小调整信息的 Insets。
int | getInt(SynthContext context, Object key, int defaultValue) 获得值为 Number 的一个特定样式属性的便捷方法。
SynthPainter | getPainter(SynthContext context) 返回将用于绘制的 SynthPainter。
String | getString(SynthContext context, Object key, String defaultValue) 获得其值是一个 String 值的特定样式属性的便捷方法。
void | installDefaults(SynthContext context) 在 context 的 JComponent 上根据此 Style 安装必要的状态。
boolean | isOpaque(SynthContext context) 如果 region 是不透明的，则返回 true。
void | uninstallDefaults(SynthContext context) 卸载此样式在 context 的 JComponent 上安装的任何状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SynthStyle

public SynthStyle()
构造一个 SynthStyle。

方法详细信息

getGraphicsUtils

public SynthGraphicsUtils getGraphicsUtils(SynthContext context)
返回指定上下文的 SynthGraphicUtils。

参数：
context - 标识请求者的 SynthContext
返回：
SynthGraphicsUtils

getColor

public Color getColor(SynthContext context,
                      ColorType type)
返回指定状态的颜色。此方法为 JComponent 的前景和背景提供了优先权。如果 JComponent 中的 Color 不合适，或者未被使用，则此方法将调用 getColorForState。子类通常不必重写此方法，而是重写 getColorForState(javax.swing.plaf.synth.SynthContext, javax.swing.plaf.synth.ColorType)。

参数：
context - 标识请求者的 SynthContext
type - 将请求的颜色的类型。
返回：
颜色

getColorForState

protected abstract Color getColorForState(SynthContext context,
                                          ColorType type)
返回指定状态的颜色。此方法不应调用 JComponent 上的任何方法。

参数：
context - 标识请求者的 SynthContext
type - 将请求的颜色的类型。
返回：
要呈现的颜色

getFont

public Font getFont(SynthContext context)
返回指定状态的 Font。如有必要，此方法可重定向到 context 中的 JComponent。如果此方法没有重定向到 JComponent，则调用 getFontForState(javax.swing.plaf.synth.SynthContext)。

参数：
context - 标识请求者的 SynthContext
返回：
要呈现的 Font

getFontForState

protected abstract Font getFontForState(SynthContext context)
返回指定状态的字体。此方法不应调用 JComponent 上的任何方法。

参数：
context - 标识请求者的 SynthContext
返回：
要呈现的 Font

getInsets

public Insets getInsets(SynthContext context,
                        Insets insets)
返回用来计算大小调整信息的 Insets。

参数：
context - 标识请求者的 SynthContext
insets - 在其中放置返回值的 Insets。
返回：
将调整大小的 Insets。

getPainter

public SynthPainter getPainter(SynthContext context)
返回将用于绘制的 SynthPainter。此方法可以返回 null。

参数：
context - 标识请求者的 SynthContext
返回：
要使用的 SynthPainter

isOpaque

public boolean isOpaque(SynthContext context)
如果 region 是不透明的，则返回 true。

参数：
context - 标识请求者的 SynthContext
返回：
如果 region 是不透明的，则返回 true。

get

public Object get(SynthContext context,
                  Object key)
某个 region 特定样式属性的获取器。

参数：
context - 标识请求者的 SynthContext
key - 将请求的属性。
返回：
指定属性的值

installDefaults

public void installDefaults(SynthContext context)
在 context 的 JComponent 上根据此 Style 安装必要的状态。

参数：
context - 标识要安装属性的组件的 SynthContext。

uninstallDefaults

public void uninstallDefaults(SynthContext context)
卸载此样式在 context 的 JComponent 上安装的任何状态。

样式不应依赖调用此方法，在某些情况下，此方法可能从不被调用。

参数：
context - 标识要安装属性的组件的 SynthContext。

getInt

public int getInt(SynthContext context,
                  Object key,
                  int defaultValue)
获得值为 Number 的一个特定样式属性的便捷方法。如果该值为 Number，则返回 intValue，否则返回 defaultValue。

参数：
context - 标识请求者的 SynthContext
key - 将请求的属性。
defaultValue - 如果该属性还未被指定，或者该值不是一个 Number，则该参数表示要返回的值
返回：
指定属性的值

getBoolean

public boolean getBoolean(SynthContext context,
                          Object key,
                          boolean defaultValue)
获得其值是一个 Boolean 值的特定样式属性的便捷方法。

参数：
context - 标识请求者的 SynthContext
key - 将请求的属性。
defaultValue - 如果该属性还未被指定，或者该值不是一个 Boolean，则该参数表示要返回的值
返回：
指定属性的值

getIcon

public Icon getIcon(SynthContext context,
                    Object key)
获得其值是一个 Icon 的特定样式属性的便捷方法。

参数：
context - 标识请求者的 SynthContext
key - 将请求的属性。
返回：
指定属性的值，如果没有指定属性，则返回 null

getString

public String getString(SynthContext context,
                        Object key,
                        String defaultValue)
获得其值是一个 String 值的特定样式属性的便捷方法。

参数：
context - 标识请求者的 SynthContext
key - 将请求的属性。
defaultValue - 如果该属性还未被指定，或者该值不是一个 String，则该参数表示要返回的值
返回：
指定属性的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynthStyleFactory (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.plaf.synth
类 SynthStyleFactory

java.lang.Object
    继承者  javax.swing.plaf.synth.SynthStyleFactory

public abstract class SynthStyleFactory
extends Object

用于获得 SynthStyle 的工厂。每个 Synth ComponentUI 都将调用当前 SynthStyleFactory 来为它们所拥有的每个不同 region 获得一个 SynthStyle。

以下示例创建了一个自定义 SynthStyleFactory，它基于 Region 返回不同的样式：

 class MyStyleFactory extends SynthStyleFactory {
     public SynthStyle getStyle(JComponent c, Region id) {
         if (id == Region.BUTTON) {
             return buttonStyle;
         }
         else if (id == Region.TREE) {
             return treeStyle;
         }
         return defaultStyle;
     }
 }
 SynthLookAndFeel laf = new SynthLookAndFeel();
 UIManager.setLookAndFeel(laf);
 SynthLookAndFeel.setStyleFactory(new MyStyleFactory());

从以下版本开始：
1.5
另请参见：
SynthStyleFactory, SynthStyle

构造方法摘要
SynthStyleFactory()
创建一个 SynthStyleFactory。
方法摘要
abstract  SynthStyle getStyle(JComponent c, Region id)
返回指定 Component 的样式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SynthStyleFactory

public SynthStyleFactory()
创建一个 SynthStyleFactory。

方法详细信息

getStyle

public abstract SynthStyle getStyle(JComponent c,
                                    Region id)
返回指定 Component 的样式。

参数：
c - 要请求的组件
id - Region 标识符
返回：
region 的 SynthStyle。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.plaf.synth (Java Platform SE 6)

 javax.swing.plaf.synth
接口
SynthConstants
类
ColorType
Region
SynthContext
SynthGraphicsUtils
SynthLookAndFeel
SynthPainter
SynthStyle
SynthStyleFactory


javax.swing.plaf.synth (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.plaf.synth

Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

请参见：
描述

接口摘要
SynthConstants 由 Synth 使用的常量。

类摘要
ColorType | 可从某种风格中获取的一些颜色的类型安全枚举。
Region | Swing 组件的独特呈现区域。
SynthContext | 一个不可变的瞬态对象，它包含有关 Region 的上下文信息。
SynthGraphicsUtils | 用于基本图形调用的包装器。
SynthLookAndFeel | SynthLookAndFeel 提供创建定制外观的基础。
SynthPainter | SynthPainter 用于绘制 JComponent 的某些部分。
SynthStyle | SynthStyle 是一个样式属性集。
SynthStyleFactory | 用于获得 SynthStyle 的工厂。

软件包 javax.swing.plaf.synth 的描述

Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。Synth 不提供默认外观。为了使用 Synth，需要指定一个 file，或提供一个 SynthStyleFactory。两种配置选项都要求了解 synth 的架构（该架构如下所示），并了解 Swing 的架构。

除非另行指定，否则 null 对于 synth 包中定义的所有方法而言都不是合法值，如果传入 null，将导致 NullPointerException。

Synth

Synth 中的每个 ComponentUI 实现都将自身与每个 Region 的一个 SynthStyle 相关联，大多数 Component 只能有一个 Region，所以也就只有一个 SynthStyle。SynthStyle 用于访问所有与样式有关的属性：fonts、colors 和其他 Component 属性。此外，SynthStyle 用于获得绘制背景、边框、焦点和 Component 的其他部分的 SynthPainter。ComponentUI 从 SynthStyleFactory 中获得 SynthStyle。可直接通过 SynthLookAndFeel.setStyleFactory(javax.swing.plaf.synth.SynthStyleFactory) 或间接通过 SynthLookAndFeel.load(java.io.InputStream, java.lang.Class) 提供 SynthStyleFactory。以下示例使用 SynthLookAndFeel.load() 方法来配置 SynthLookAndFeel，并将它设置为当前外观：

  SynthLookAndFeel laf = new SynthLookAndFeel();
  laf.load(MyClass.class.getResourceAsStream("laf.xml"), MyClass.class);
  UIManager.setLookAndFeel(laf);

许多 JComponent 被拆分成更小的块，并由 Region 中类型安全的枚举来标识。例如，JTabbedPane 由 JTabbedPane 的 Region (Region.TABBED_PANE)、内容区域 (Region.TABBED_PANE_CONTENT)、选项卡背后的区域 (Region.TABBED_PANE_TAB_AREA) 和选项卡 (Region.TABBED_PANE_TAB) 组成。每个 JComponent 的每个 Region 都将有一个 SynthStyle。这允许您定制每个 JComponent 的每个区域的个别片段。

许多 Synth 方法都采用一个 SynthContext。SynthContext 用于提供有关当前 Component 的信息，这些信息包括：与当前 Region 关联的 SynthStyle、位掩码形式的 Component 状态（有关有效状态，请参阅 SynthConstants）和一个标识正被绘制的 Component 部分的 Region。

由非 JTextComponent 呈现的所有文本都被委托给 SynthGraphicsUtils，可以使用 SynthStyle 的方法 SynthStyle.getGraphicsUtils(javax.swing.plaf.synth.SynthContext) 获取。通过提供自己的 SynthGraphicsUtils，可以定制文本呈现。

特定组件注意事项

JTree

Synth 为树单元提供一个区域：Region.TREE_CELL。要指定渲染器的颜色，可以为 TREE_CELL 区域提供一个风格。以下代码展示了这一点：

  <style id="treeCellStyle">
    <opaque value="TRUE"/>
    <state>
      <color value="WHITE" type="TEXT_FOREGROUND"/>
      <color value="RED" type="TEXT_BACKGROUND"/>
    </state>
    <state value="SELECTED">
      <color value="RED" type="TEXT_FOREGROUND"/>
      <color value="WHITE" type="BACKGROUND"/>
    </state>
  </style>
  <bind style="treeCellStyle" type="region" key="TreeCell"/>

这指定了一个颜色组合，当选中时，红色将在白色之上；未选中时，白色在红色之上。要查看背景，需要指定标签是透明的，用以下 XML 代码段可以做到这一点：

  <style id="labelStyle">
    <opaque value="FALSE"/>
  </style>
  <bind style="labelStyle" type="region" key="Label"/>

JList 和 JTable

JList 和 JTable 渲染器所使用的颜色通过列表和表 Region 的方式指定。以下 XML 代码段展示了如何在选中时指定红色在白色之上，未选中时白色在红色之上：

  <style id="style">
    <opaque value="TRUE"/>
    <state>
      <color value="WHITE" type="TEXT_FOREGROUND"/>
      <color value="RED" type="TEXT_BACKGROUND"/>
      <color value="RED" type="BACKGROUND"/>
    </state>
    <state value="SELECTED">
      <color value="RED" type="TEXT_FOREGROUND"/>
      <color value="WHITE" type="TEXT_BACKGROUND"/>
    </state>
  </style>
  <bind style="style" type="region" key="Table"/>
  <bind style="style" type="region" key="List"/>

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.plaf.synth 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf.synth 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.plaf.synth.ColorType
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
        • javax.swing.plaf.synth.SynthLookAndFeel
    • javax.swing.plaf.synth.Region
    • javax.swing.plaf.synth.SynthContext
    • javax.swing.plaf.synth.SynthGraphicsUtils
    • javax.swing.plaf.synth.SynthPainter
    • javax.swing.plaf.synth.SynthStyle
    • javax.swing.plaf.synth.SynthStyleFactory

接口分层结构

  • javax.swing.plaf.synth.SynthConstants
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.swing.plaf.synth 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.plaf.synth
的使用

使用 javax.swing.plaf.synth 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 使用的 javax.swing.plaf.synth 中的类
ColorType
可从某种风格中获取的一些颜色的类型安全枚举。
Region
Swing 组件的独特呈现区域。
SynthContext
一个不可变的瞬态对象，它包含有关 Region 的上下文信息。
SynthGraphicsUtils
用于基本图形调用的包装器。
SynthPainter
SynthPainter 用于绘制 JComponent 的某些部分。
SynthStyle
SynthStyle 是一个样式属性集。
SynthStyleFactory
用于获得 SynthStyle 的工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Component Specific Properties

The look, and to some degree the feel of Synth can be customized by way of component specific properties. These properties are accessed from SynthStyle#get. Refer to synth file format for examples of how to specify these properties in a synth configuration file.

This file specifies the expected class type each of the values are to take. The behavior of supplying the wrong type is unspecified: typically a ClassCastException is thrown, but it is implementation specific.

ArrowButton

ArrowButton is a special type of JButton that renders an arrow. ArrowButton is typically not created directly, rather some of the Components will create it to render a button with an arrow. The components that make use of ArrowButton are: JComboBox, JScrollBar and JSplitPane (for the buttons on the divider). In addition to the Button properties, ArrowButton supports the following propeties:

ArrowButton Specific Properties
Property | Expected Type | Default Value | Description
ArrowButton.size | Integer | 16 | Preferred size of the arrow button.

JButton

JButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JButton supports the following property:

JButton Specific Properties
Property | Expected Type | Default Value | Description
Button.defaultButtonFollowsFocus | Boolean | true | Whether or not the default JButton should change to the button that is receiving focus.

JCheckBox

JCheckBox paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JCheckBox supports the following property:

JCheckBox Specific Properties
Property | Expected Type | Default Value | Description
CheckBox.icon | Icon | null | Icon used to render the check.

JComboBox

JComboBox is a composite component that consists of the following child Components:

Name | Type | Description
ComboBox.arrowButton | SynthArrowButton | Renders the drop down indicator.
ComboBox.list | JList | JList used to render the values.
ComboBox.listRenderer | Component | The renderer used for the JComboBox's JList.
ComboBox.popup | JPopupMenu | JPopupMenu used to show the ComboBox.list of the JComboBox.
ComboBox.renderer | Component | The renderer used for the JComboBox. This is ONLY set if the renderer is a UIResource.
ComboBox.scrollPane | JScrollPane | JScrollPane containing the JList.
ComboBox.textField | JTextField | The editor.

JComboBox Specific Properties
Property | Expected Type | Default Value | Description
ComboBox.showPopupOnNavigation | Boolean | false | Whether or not the JPopupMenu should appear when navigating with the keyboard.

JFileChooser

JFileChooser Specific Properties
Property | Expected Type | Default Value | Description
FileChooser.cancelIcon | Icon | null | Icon displayed on cancel button of the file chooser.
FileChooser.okIcon | Icon | null | Icon displayed on the ok button of the file chooser.
FileView.directoryIcon | Icon | null | Icon used for directories.
FileView.fileIcon | Icon | null | Icon used for files.
FileView.computerIcon | Icon | null | Icon used for directories that represent the computer. Not all platforms will make use of this icon.
FileView.hardDriveIcon | Icon | null | Icon used to represent the root of a hard drive. For example, on Windows this would be used when viewing the C drive.
FileView.floppyDriveIcon | Icon | null | Icon used to represent a floppy disk.
FileChooser.newFolderIcon | Icon | null | Icon used by the button that creates a new folder.
FileChooser.upFolderIcon | Icon | null | Icon used by the button that navigates to the parent folder.
FileChooser.homeFolderIcon | Icon | null | Icon used by the button that navigates to the current user's home directory.
FileChooser.detailsViewIcon | Icon | null | Icon used by the button that toggles the detailed files list view.
FileChooser.listViewIcon | Icon | null | Icon used by the button that toggles the regular files list view, showing only an icon and the name of each file and directory.

JInternalFrame

JInternalFrame Specific Properties
Property | Expected Type | DefaultValue | Description
InternalFrame.icon | Icon | null | Icon drawn representing the system icon of the internal frame. If pressed the system menu will be shown.

JInternalFrameTitlePane

JInternalFrameTitlePane is the control bar located at the top of the internal frame similar to that found in a frame.

JInternalFrameTitlePane Specific Properties
Property | Expected Type | Default Value | Description
InternalFrameTitlePane.maximizeIcon | Icon | null | Icon drawn to indicate the ability to maximize the internal frame.
InternalFrameTitlePane.minimizeIcon | Icon | null | Icon drawn to indicate the ability to restore the internal frame back to its previous state.
InternalFrameTitlePane.iconifyIcon | Icon | null | Icon drawn to indicate the ability to minimize the internal frame.
InternalFrameTitlePane.closeIcon | Icon | null | Icon drawn to indicate the abililty to close the internal frame.
InternalFrameTitlePane.titleSpacing | Integer | 2 | Space between the buttons on the title pane and the title.
InternalFrameTitlePane.buttonSpacing | Integer | 2 | Space between the buttons on the title pane.
InternalFrameTitlePane.maxFrameIconSize | Dimension | 16x16 | Maximum size of the frame icon that will be rendered on the title pane. If the icon is bigger than this size, it will be scaled down.
InternalFrameTitlePane.titleAlignment | leading|trailing|center | leading | Alignment for the title. With a left to right component orientation leading is left and trailing right. With a right to left component orientation leading is right and trailing left.

JList

JList's sets the name of the renderer to List.renderer. JList supports the following properties:

JList Specific Properties
Property | Expected Type | Default Value | Description
List.rendererUseListColors | Boolean | true | If true the renderers state is not updated, and the text colors come from JList's getSelectionBackground and getSelectionForeground methods. If false, the renderer's state is updated and the colors will instead come from the Style.
List.rendererUseUIBorder | Boolean | true | If true setBorder on the renderer will succeed regardless of the border passed in, otherwise setBorder on the renderer will only succeed if it is a Synth Border.
List.cellHeight | Integer | -1 | Cell height of the JList. Is this is -1, setFixedCellHeight is not invoked.

Menu Properties

The Menu classes (JCheckBoxMenuItem, JMenu, JMenuItem, and JRadioButtonMenuItem) all support the same set of properties and behave similarly. Each component consists of two Regions: the region specific to the component and Region.MENU_ITEM_ACCELERATOR. MENU_ITEM_ACCELERATOR is used for painting the accelerator. Both Regions paint text using the TEXT_FOREGROUND ColorType. The following set of properties are supported:

Property | Expected Type | Default Value | Description
prefix.acceleratorDelimiter | String | + | String separator between the description of the modifiers and the key, for example Ctrl <acceleratorDelimiter> X.
prefix.arrowIcon | Icon | null | Icon drawn to the right of the text (or left when the ComponentOrientation is right to left) of the text. This is typically only defined for JMenu.
prefix.checkIcon | Icon | null | Icon drawn to the left of the text (or right when the ComponentOrientation is right to left) of the text. This is typically only defined for JCheckBoxMenuItem and JRadioButtonMenuItem to provide the check or radio button.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0) | Margin for the JMenuItem. Refer to the javadoc of javax.swing.AbstractButton#setMargin(java.awt.Insets) for details of how the margin is used.
prefix.textIconGap | Integer | 4 | Padding between the icon and text. Refer to the javadoc for javax.swing.AbstractButton#setIconTextGap(int) for details of how this is used.

Prefix is one of: CheckBoxMenuItem, Menu, MenuItem, or RadioButtonMenuItem.

JMenu also supports the following properties:

Property | Expected Type | Default Value | Description
Menu.delay | Integer | 200 | Sets the delay before the menu appears.
Menu.shortcutKeys | int[] | KeyEvent.ALT_MASK | Array of the KeyEvent modifiers to use for shortcut keys.

JOptionPane

JOptionPane is a composite component and may consist of numerous child components, they are: OptionPane.button, OptionPane.label, OptionPane.comboBox, OptionPane.scrollPane, OptionPane.list, OptionPane.textField, OptionPane.iconLabel.

JOptionPane Specific Properties
Property | Expected Type | Default Value | Description
OptionPane.buttonAreaBorder | Border | null | Border around the button area.
OptionPane.buttonClickThreshhold | Integer | 0 | Passed to the created buttons setMultiClickThreshhold.
OptionPane.buttonOrientation | Integer | SwingConstants.CENTER | How the buttons should be layed out, one of SwingConstants.LEFT, SwingConstants.RIGHT or SwingConstants.CENTER (this will be flipped when in a right to left locale).
OptionPane.buttonPadding | Integer | 6 | Amount of space between buttons.
OptionPane.cancelIcon | Icon | null | Icon for the cancel button.
OptionPane.errorIcon | Icon | null | Icon used for ERROR_MESSAGE.
OptionPane.informationIcon | Icon | null | Icon used for INFORMATION_MESSAGE.
OptionPane.isYesLast | Boolean | false | If true the 'yes' button leads other buttons, otherwise it follows the other buttons.
OptionPane.questionIcon | Icon | null | Icon used for error QUESTION_MESSAGE.
OptionPane.minimumSize | Dimension | 262x90 | Minimum size for the JOptionPane.
OptionPane.noIcon | Icon | null | Icon for the no button.
OptionPane.okIcon | Icon | null | Icon for the ok button.
OptionPane.sameSizeButtons | Boolean | true | Whether or not all the buttons should be the same size.
OptionPane.separatorPadding | Integer | 6 | Amount of padding between the message area and separator.
OptionPane.yesIcon | Icon | null | Icon for the yes button.
OptionPane.warningIcon | Icon | null | Icon used for error WARNING_MESSAGE

JProgressBar

JProgressBar Specific Properties
Property | Expected Type | Default Value | Description
ProgressBar.repaintInterval | Integer | 50 | Number of milliseconds between repaints for indeterminate progress bars.
ProgressBar.cycleTime | Integer | 3000 | Number of milliseconds used to determine how far to move the bouncing box per frame when the progress bar is indeterminate.

JRadioButton

JRadioButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JRadioButton supports the following property:

JRadioButton Specific Properties
Property | Expected Type | Default Value | Description
RadioButton.icon | Icon | null | Icon used to render the radio indicator.

JScrollBar

JScrollBar is a composite component that consists of the following child Components:

Name | Type | Description
ScrollBar.button | SynthArrowButton | Identifies the increment/decrement buttons.

JScrollBar Specific Properties
Property | Expected Type | Default Value | Description
ScrollBar.allowsAbsolutePositioning | Boolean | false | If true, middle mouse click in the track will set the position of the track to where the mouse is.
ScrollBar.maximumThumbSize | Dimension | 4096x4096 | Maximum thumb size.
ScrollBar.minimumThumbSize | Dimension | Derived from ScrollBar.thumbHeight | The minimum thumb size. If this is not specified the minimum thumb size is ScrollBar.thumbHeight plus the insets of the scrollbar along the opposite axis of the scrollbar and 7 along the other axis. For example, if you have not specified Insets for a scrollbar, and the orientation of the scrollbar is vertical, than the minimum thumb size width is ScrollBar.thumbHeight with a height of 7.
ScrollBar.squareButtons | Boolean | false | If true, the width and height of the scrollbar buttons will be made equal.
ScrollBar.thumbHeight | Integer | 14 | The preferred height, when the orientation of the scrollbar is horizontal, or preferred width when the orientation of the scrollbar is vertical.

Separators

All of the separator classes, JSeparator, JPopupMenu.Separator and JToolBar.Separator use the same property:

Property | Expected Type | Default Value | Description
Separator.thickness | Integer | 2 | Preferred width, for vertically aligned separators, or preferred height for horizontally aligned separators. The resulting preferred size will include the Insets.

JToolBar.Separator also supports the following property:

Property | Expected Type | Default Value | Description
ToolBar.separatorSize | Dimension | null | The value of this is passed to the javax.swing.JToolBar$Separator#setSeparatorSize(java.awt.Dimension) method. If unspecified setSeparatorSize is not invoked.

JScrollPane

JScrollPane is unique in that it provides a method for setting the Border around the JViewport with JViewport throwing an IllegalArgumentException from setBorder. To accomodate this a special border is installed on the JScrollPane that uses the insets from the key ScrollPane.viewportBorderInsets. The SynthPainter method paintViewportBorder is called to paint the Viewports border.

JScrollPane Specific Properties
Property | Expected Type | Default Value | Description
ScrollPane.viewportBorderInsets | Insets | null | Insets for the viewport Border.

JSplitPane

JSplitPane is a composite component that will contain a divider and potentially two buttons, if setOneTouchExpandable(true) has been invoked. The two buttons will be named: SplitPaneDivider.leftOneTouchButton and SplitPaneDivider.rightOneTouchButton.

JSplitPane Specific Properties
Property | Expected Type | Default Value | Description
SplitPane.centerOneTouchButtons | Boolean | true | If true, the one touch buttons are centered on the divider.
SplitPane.oneTouchButtonOffset | Integer | 2 | Distance between the one touch buttons.
SplitPane.oneTouchButtonSize | Integer | 6 | Size to make the one touch buttons.
SplitPane.oneTouchExpandable | Boolean | null | If non null, the value of this is passed to setOneTouchExpandable.
SplitPane.size | Integer | 6 | Size of the divider

JSlider

JSlider Specific Properties
Property | Expected Type | Default Value | Description
Slider.thumbWidth | Integer | 30 | Width of the slider thumb
Slider.thumbHeight | Integer | 14 | Height of the slider thumb
Slider.trackBorder | Integer | 1 | Width of the track border
Slider.paintValue | Boolean | true | Whether or not to paint the current value of the slider.

JTabbedPane

JTabbedPane Specific Properties
Property | Expected Type | Default Value | Description
TabbedPane.tabRunOverlay | Integer | 0 | Number of pixels to overlap tabs when there is more than one row.
TabbedPane.textIconGap | Integer | 0 | Padding added between the icon and text on a tab. If there is no text or icon this value is not used.
TabbedPane.selectedTabPadInsets | Insets | Empty Insets (0, 0, 0, 0) | Extra insets added to the selected tab.
TabbedPane.selectionFollowsFocus | Boolean | true | If true the selection of the tabbed pane changes as the user navigates the tabs with a mouse.

JTable

JTable sets the name of the renderer to Table.cellRenderer. JTable supports the following properties:

JTable Specific Properties
Property | Expected Type | Default Value | Description
Table.gridColor | Color | null | Color used for the grid. If null the foreground from the style is used.
Table.rendererUseTableColors | Boolean | true | If true the renderers state is not updated, and the text colors come from JTable's getSelectionBackground and getSelectionForeground methods. If false, the renderer's state is updated and the colors will instead come from the Style.
Table.rendererUseUIBorder | Boolean | true | If true setBorder on the renderer will succeed regardless of the border passed in, otherwise setBorder on the renderer will only succeed if it is a Synth Border.
Table.rowHeight | Integer | -1 | If not -1 setRowHeight is invoked on the JTable.

JTree

JTree sets the name of the renderer to Tree.renderer, the name of the editor is Tree.cellEditor.

JTree Specific Properties
Property | Expected Type | Default Value | Description
Tree.collapsedIcon | Icon | null | Icon to use when a node is collapsed.
Tree.drawHorizontalLines | Boolean | true | If true nodes have a horizontal connecting them to the leading edge of their parent.
Tree.drawVerticalLines | Boolean | true | If true a vertical line is drawn down from expanded nodes.
Tree.expandedIcon | Icon | null | Icon to use when a node has been expanded.
Tree.leftChildIndent | Integer | 0 | This plus Tree.rightChildIndent account for the total space, along the y axis, to offset nodes from their parent.
Tree.rightChildIndent | Integer | 0 | This plus Tree.leftChildIndent account for the total space, along the y axis, to offset nodes from their parent.
Tree.rowHeight | Integer | -1 | Row height for the Tree.
Tree.scrollsHorizontallyAndVertically | Boolean | false | If false and scrolling needs to happen to accomodate cells it will only happen along the vertical axis, if true, scrolling may happen along both the horizontal and vertical axis.
Tree.scrollsOnExpand | Boolean | true | Whether or not the JTree should scroll when a node is expanded.
Tree.linesStyle | String |  | The styles of the lines in the tree. Synth supports solid lines (empty value) and dashed lines ("dashed" value). It is possible to add new styles by creating a new SynthGraphicsUtils and binding it to the tree.

JToggleButton

JToggleButton paints text using the TEXT_FOREGROUND ColorType. In addition to the Button properties, JToggleButton supports the following property:

JToggleButton Specific Properties
Property | Expected Type | Default Value | Description
ToggleButton.icon | Icon | null | Icon used to render the radio indicator.

Button Properties

Each of the Button classes (JButton, JCheckBox, JRadioButton, JToggleButton and SynthArrowButton) support a similar set of properties. These properties are:

Property | Expected Type | Default Value | Description
prefix.contentAreaFilled | Integer | true | Refer to the javadoc of javax.swing.AbstractButton#contentAreaFilled(boolean) for details of how this is used. It is up to the Painter to properly honor this property.
prefix.iconTextGap | Integer | If unspecified, JButton.setIconTextGap is not invoked. | Padding between the icon and text. Refer to the javadoc of javax.swing.AbstractButton#setIconTextGap(int) for details of how this is used.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0) | Margin for the JButton. Refer to the javadoc of javax.swing.AbstractButton#setMargin(java.awt.Insets) for details of how the margin is used.
prefix.textShiftOffset | Integer | 0 | Amount to shift the text and icon, along the x and y axis, from where it would normally be layed out. This is only used when the button is in a pressed state and does not have a pressed icon.

Prefix is one of: Button, CheckBox, RadioButton or JToggleButton.

Text Properties

Property | Expected Type | Default Value | Description
prefix.caretForeground | Color | #000000 | Color of the caret.
prefix.margin | Insets | Empty Insets (0, 0, 0, 0), EditorPane and TextPane (3, 3, 3, 3) | Margins of the text component.
prefix.caretBlinkRate | Integer | 500 | Number of milliseconds defining the blink rate fo the caret.

Prefix is one of: EditorPane, FormattedTextField, PasswordField, TextArea, TextField or TextPane.


Synth File Format

File Format

Synth's file format (dtd) allows for specifying all the pieces necessary to create your own look and feel. A synth file is loaded by way of the SynthLookAndFeel.load(InputStream, Class) or SynthLookAndFeel.load(URL) methods. The following example uses the load method to configure a SynthLookAndFeel and sets it as the current look and feel:

  SynthLookAndFeel laf = new SynthLookAndFeel();
  laf.load(MyClass.class.getResourceAsStream("laf.xml"), MyClass.class);
  UIManager.setLookAndFeel(laf);

This example loads the look and feel from an input stream, using the specified class as the resource base to resolve paths. It is also possible to load a look and feel from an arbitrary URL as in the following example.

  SynthLookAndFeel laf = new SynthLookAndFeel();
  laf.load(new URL("file:///C:/java/synth/laf/laf.xml"));
  UIManager.setLookAndFeel(laf);

The method SynthLookAndFeel.load(URL) can be used, for instance, to load a look and feel from any of the following:

  • File, e.g. file:///C:/java/synth/laf/laf.xml
  • Web server, e.g. http://host/laf.xml
  • JAR file, e.g. jar:file:///C:/synth-laf.jar!/laf.xml
  • Remote JAR file, e.g. jar:http://host/synth-laf.jar!/laf.xml

While the DTD for synth is specified, the parser is not validating. Parsing will fail only if a necessary attribute is not specified, or of the wrong type.

The synth element

<!ELEMENT synth ((%beansPersistance;) | style | bind | font | color |
                 imagePainter | imageIcon | defaultsProperty)*>
<!ATTLIST synth
          version              CDATA          #IMPLIED
>

Attribute definitions

version
File format version, should be 1

The synth element contains all the other elements that make up a SynthLookAndFeel definition.

The style element

<!ELEMENT style (property | defaultsProperty | state | font | graphicsUtils |
                 insets | painter | imagePainter | opaque | (%beansPersistance;) |
                 imageIcon)*>
<!ATTLIST style
          id              ID          #IMPLIED
          clone           IDREF       #IMPLIED
>

Attribute definitions

id
Unique identifier for the style.
clone
Identifier of a previously defined style that is copied and used for the new style. This provides a conveniant mechanism for overriding only a portion of an existing style.

A style element corresponds to a SynthStyle, with the child elements specifying properties that apply to all states or state elements which contain properties specific to a particular state. The following example creates an opaque style with the id button, insets of 4, 4, 4, 4 and a font of Dialog 12.

<style id="button">
  <opaque value="true"/>
  <insets top="4" left="4" right="4" bottom="4"/>
  <font name="Dialog" size="12"/>
</style>

The following example creates a new style with an id of clonedButton that is a copy of the style with id button and has a font of Dialog, 14. The resulting style will be opaque, have insets of 4, 4, 4, 4 and a font of Dialog 14.

<style id="clonedButton" clone="button">
  <font name="Dialog" size="14"/>
</style>

The state element

<!ELEMENT state (color | font | painter | imagePainter | (%beansPersistance;) |
                 property |  imageIcon)*>
<!ATTLIST state
          id              ID             #IMPLIED
          clone           IDREF          #IMPLIED
          value           CDATA          #IMPLIED
          idref           IDREF          #IMPLIED
>

Attribute definitions

id
Unique identifier for the state.
clone
Identifier of a previously defined state that is copied and used for the new state.
value
Identifies the state of the Component the properties are to apply to. This is a list of: ENABLED, MOUSE_OVER, PRESSED, DISABLED, FOCUSED, SELECTED or DEFAULT. Multiple states should be separated by 'and.' If you do not specify a value, the contents apply to all states.
idref
Indicates this state should be the same as a previously defined state. This is useful for multiple styles that wish to share the same visual properties for a particular state.

The state element specifies the visual properties that are to be used for a particular state of a component. For example, you could specify the background color when the Component is enabled should look different than the background color when the component is disabled. Not all Components support all states. For example, a Panel only supports the states ENABLED and DISABLED.

The following example creates a state with a red background that will be used when the component is in an a selected and pressed state:

<state value="SELECTED AND PRESSED">
  <color value="RED" type="BACKGROUND"/>
</state>

The state with the most individual matches will be chosen. For example, the following defines two states:

<state value="SELECTED and PRESSED" id="one">
  <color value="RED" type="BACKGROUND"/>
</state>
<state value="SELECTED" id="two">
  <color value="RED" type="BACKGROUND"/>
</state>

State one is used when the Component is SELECTED and PRESSED, and state two when the Component is SELECTED. If the state of the Component contains at least SELECTED and PRESSED, state one will be chosen, otherwise if the state is SELECTED, but not does not contain PRESSED, state two will be used.

The font element

<!ELEMENT font EMPTY>
<!ATTLIST font
          id              ID             #IMPLIED
          clone           IDREF          #IMPLIED
          name            CDATA          #IMPLIED
          style           CDATA          #IMPLIED
          size            CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the Font.
idref
Identifier of a previously defined font.
name
Name of the font.
style
Style of the font. This is a list of the styles defined by Font separated by spaces: PLAIN, BOLD or ITALIC. If unspecified PLAIN is used.
size
Size of the font, in pixels

Defines the font for the current state, or style. You must specify either an idref or a name and size.

The following example creates a style with a Font of Dialog 12 Bold.

<style id="test">
  <font name="DIALOG" size="12" style="BOLD"/>
</style>

The following example creates a style with a font of Dialog 12 Bold that will be used if the component is ENABLED, otherwise Dialog 12 Italic will be used.

<style id="test">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <state value="ENABLED">
    <font name="DIALOG" size="12" style="BOLD"/>
  </state>
</style>

While you can supply a different font per state, in general widgets will NOT revalidate when the state changes, so that you may run into sizing problems if you try to use a font with a significantly different size for different states.

The color element

<!ELEMENT color EMPTY>
<!ATTLIST color
          id              ID             #IMPLIED
          idref           IDREF          #IMPLIED
          type            CDATA          #IMPLIED
          value           CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the color.
idref
Identifier of a previously defined color.
type
Describes where this color should be used. This is typically one of the constants defined by ColorType: FOREGROUND, BACKGROUND, TEXT_FOREGROUND, TEXT_BACKGROUND or FOCUS. Alternatively you can specify the complete path to a class and field, for example javax.swing.plaf.synth.ColorType.FOREGROUND, this is useful for subclasses of synth that define additional color types.
value
Value for the color. This accepts the following forms.
  • The name of a constant in the Color class, for example RED.
  • A hex value of the form #RRGGBB where RR gives the red component, GG the green component and BB the blue component. You need not specify all color components. For example, #123 is equivalent to #000123.
  • A hex value of the form #ARRGGBB or #AARRGGBB. This is useful for alpha values other than 0xFF. The form #ARRGGBB is equivalent to #0ARRGGBB.

Color defines a color and what portion of the Component it should be applied to. The following example will use a background color of RED when the component is enabled.

<state value="ENABLED">
  <color value="RED" type="BACKGROUND"/>
</state>

The following example will have a red background when the Component is enabled, otherwise blue.

<style id="test">
  <state value="ENABLED">
    <color value="RED" type="BACKGROUND"/>
  </state>
  <state>
    <color value="#00FF00" type="BACKGROUND"/>
  </state>
</style>

The property element

<!ELEMENT property EMPTY>
<!ATTLIST property
          key               CDATA                                             #REQUIRED
          type              (idref|boolean|dimension|insets|integer|string)          "idref"
          value             CDATA                                             #REQUIRED
>

Attribute definitions

key
Name of the property.
type
Indicates the type of the property.
value
Value for the property. For boolean properties this will be be true or false, for integer properties this will be a valid integer, for dimensions this will be the width and height separated by a space, for insets properties this will be the top, left, bottom and right separated by a space and for idref properties this will be the unique id of a previously defined object.

Property elements are used to add key value pairs to a SynthStyle that can be accessed by way of the get method. Many Components use the key value pairs for configuring their visual appearance. Refer to property table for a list of the properties each Component supports. The following creates the properties ScrollBar.allowsAbsolutePositioning, OptionPane.minimumSize, ScrollPane.viewportBorderInsets, Tree.rowHeight and foreground with the values false, a dimensions of 262x90, an insets of 5, 5, 5, 5, the integer 20 and an instance of the class ArrowButtonPainter.

<style id="test">
  <property key="ScrollBar.allowsAbsolutePositioning" type="boolean" value="false"/>
  <property key="OptionPane.minimumSize" type="dimension" value="262 90"/>
  <property key="ScrollPane.viewportBorderInsets" type="insets" value="5 5 5 5"/>
  <property key="Tree.rowHeight" type="integer" value="20"/>
  <object class="ArrowButtonPainter" id="ArrowButtonPainter"/>
  <property key="foreground" type="idref" value="ArrowButtonPainter"/>
</style>

You can also specify properties that are to apply to specific states. Whether or not the property is accessed for each state depends upon how the property is used. For example, the following specifies a default icon and an icon to use while the mouse is over the component.

<style id="test">
  <imageIcon id="defaultIcon" path="resources/myImage.png"/>
  <property key="RadioButton.icon" value="defaultIcon"/>
  <state value="MOUSE_OVER">
    <imageIcon id="mouseOverIcon" path="resources/myMouseOverImage.png"/>
    <property key="RadioButton.icon" value="mouseOverIcon"/>
  </state>
</style>

<!ELEMENT defaultsProperty EMPTY>
<!ATTLIST defaultsProperty
          key               CDATA                                             #REQUIRED
          type              (idref|boolean|dimension|insets|integer|string)   "idref"
          value             CDATA                                             #REQUIRED
>

Attribute definitions

key
Name of the property.
type
Indicates the type of the property.
value
Value for the property. For boolean properties this will be true or false, for integer properties this will be a valid integer, for dimensions this will be the width and height separated by a space, for insets properties this will be the top, left, bottom and right separated by a space and for idref properties this will be the unique id of a previously defined object.

DefaultsProperty elements are used to define properties that will be placed in the UIDefaults table that SynthLookAndFeel supplies to the UIManager. The following assigns the the Color red to the value Table.focusCellForeground.

<style id="test">
  <object class="javax.swing.plaf.ColorUIResource" id="color">
    <int>255</int>
    <int>0</int>
    <int>0</int>
  </object>
  <defaultsProperty key="Table.focusCellForeground" type="idref" value="color"/>
</style>

This value could then be asked by way of UIManager.get("Table.focusCellForeground").

The graphicsUtils element

<!ELEMENT graphicsUtils EMPTY>
<!ATTLIST graphicsUtils
          idref           IDREF             #REQUIRED
>

Attribute definitions

idref
Identifer of a previously defined SynthGraphicsUtils object that is to be used as the SynthGraphicsUtils for the current style.

GraphicsUtils elements are used to define the SynthGraphicsUtils that the current style will use. The following example creates a style with an instance of CustomGraphicsUtils for the SynthGraphicsUtils.

<style id="test">
  <object class="CustomGraphicsUtils" id="graphics"/>
  <graphicsUtils idref="graphics"/>
</style>

The insets element

<!ELEMENT insets EMPTY>
<!ATTLIST insets
          id           ID             #IMPLIED
          idref        IDREF          #IMPLIED
          top          CDATA          #IMPLIED
          bottom       CDATA          #IMPLIED
          left         CDATA          #IMPLIED
          right        CDATA          #IMPLIED
>

Attribute definitions

id
Unique identifier for the Insets.
idref
Identifier of a previously defined Insets.
top
Top component of the Insets.
bottom
Bottom component of the Insets.
left
Left component of the Insets.
right
Right component of the Insets.

Insets elements are used to define the Insets for the current style. The insets will be set on any Components the style is associated with. The following example creates a style with insets of 1, 2, 3, 0.

<style id="test">
  <insets top="1" bottom="2" left="3"/>
</style>

The bind element

<!ELEMENT bind EMPTY>
<!ATTLIST bind
          style        IDREF             #REQUIRED
          type         (name|region)     #REQUIRED
          key          CDATA             #REQUIRED
>

Attribute definitions

style
Unique identifier of a previously defined style.
type
One of name or region. For type name component.getName() is used, otherwise the name of the Region is used.
key
Regular expression applied to the name of the Component, or the name of the Region, depending upon the value of type.

Bind elements specify which Regions a style is to be used for. The following example applies the style test to any Component whose name starts with test.

<style id="test">
  <insets top="1" bottom="2" left="3"/>
</style>
<bind style="test" type="name" key="test.*"/>

Numerous styles may apply to a region, in which case each of the matching styles is merged into a resulting style that is used. Precedence is given to styles defined later in the file. For example, the following defines two styles, a and b. Style a is applied to any component with a name starting with test, and style b is used for button regions.

<style id="a">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <insets top="1" bottom="2" left="3"/>
</style>
<bind style="a" type="name" key="test.*"/>
<style id="b">
  <font name="DIALOG" size="12" style="BOLD"/>
</style>
<bind style="b" type="region" key="button"/>

For a button with the name test this is equivalent to:

<style>
  <font name="DIALOG" size="12" style="BOLD"/>
  <insets top="1" bottom="2" left="3"/>
</style>

Merging happens for states of a style as well.

<style id="a">
  <font name="DIALOG" size="12" style="ITALIC"/>
  <insets top="1" bottom="2" left="3"/>
  <state value="ENABLED">
    <object id="customPainter" class="CustomPainter"/>
    <painter idref="customPainter"/>
  </state>
</style>
<bind style="a" type="name" key="test.*"/>
<style id="b">
  <font name="DIALOG" size="12" style="BOLD"/>
  <state value="ENABLED">
    <font name="Lucida" size="12" style="ITALIC"/>
  </state>
</style>
<bind style="b" type="region" key="button"/>

For a button with the name test this is equivalent to:

<style>
  <font name="DIALOG" size="12" style="BOLD"/>
  <insets top="1" bottom="2" left="3"/>
  <state value="ENABLED">
    <object id="customPainter" class="CustomPainter"/>
    <painter idref="customPainter"/>
    <font name="Lucida" size="12" style="ITALIC"/>
  </state>
</style>

The painter element

<!ELEMENT painter EMPTY>
<!ATTLIST painter
          idref                 IDREF          #IMPLIED
          method                CDATA          #IMPLIED
          direction             (north|south|east|west|top|left|bottom|right|horizontal|vertical|horizontal_split|vertical_split)          #IMPLIED
>

Attribute definitions

idref
Identifier of a previously defined SynthPainter.
method
Identifies the SynthPainter method this is to be used for. The name corresponds to the method name of a paint method in SynthPainter with the paint prefix dropped, the remainder is case insensitive (using the latin1 case folding rules). For example SynthPainter.paintButtonBackground is identified by 'buttonBackground' or 'buttonbackground'. If this is not specified the painter is used for all methods that don't have a a specific painter for them.
direction
Identifies the direction, or orientation, this painter is to be used for. This is only useful for the SynthPainter methods that take a direction or orientation. If this is not specified the painter is used for all directions.

Painter defines a SynthPainter for the current style or the state of the current style. The following example binds an instance of the class MyPainter which must be a SynthPainter to the style test.

<style id="test">
  <object class="MyPainter" id="MyPainter"/>
  <painter idref="MyPainter"/>
</style>

The painter that is used for a particular method and state is determined as follows:

  1. Painter specified for the current state, method and direction.
  2. Painter specified for the current state and method.
  3. Painter specified for the current state.
  4. Painter specified for the style, method and direction.
  5. Painter specified for the style and method.
  6. Painter specified for the style.

Consider the following:

<style id="test">
  <painter idref="fallbackPainter"/>
  <painter idref="styleButtonBackgroundPainter" method="buttonBackground"/>
  <state value="SELECTED">
    <painter idref="stateFallbackPainter"/>
    <painter idref="stateButtonBackgroundPainter" method="buttonBackground"/>
  </state>
</style>

The following outlines which painter will be used for what SynthPainter method:

State | Method | Painter
SELECTED | paintButtonBackground | stateButtonBackgroundPainter
SELECTED | Anything but paintButtonBackground | stateFallbackPainter
Anything but SELECTED | paintButtonBackground | styleButtonBackgroundPainter
Anything but SELECTED | Anything but paintButtonBackground | fallbackPainter

When several identical painters are declared, they are aggregated into a single one. Two painters are identical if their direction and method attributes values are equal. Consider the following:

<style id="panelStyle">
  <imagePainter method="panelBackground" path="red.png" />
  <imagePainter method="panelBackground" path="green.png" />
  <imagePainter method="panelBackground" path="blue.png" />
</style>

These three painters are identical for they use the same method and the same direction (all directions by default). Synth aggregates these painters to create a single one that will paint its children painters in the order of declaration. Hence, Synth will first paint the red picture, then the green one and finally the blue one. Each child painter can be seen as a layer of the aggregate painter.

Painter aggregation, or multi-layering, is very useful to reuse elements. Imagine you want to use an highlight effect on buttons and on selected menu items. With painter aggregation, you just need to create a separate highlighting painter instead of having buttons and menu items painters handle it.

The imagePainter element

<!ELEMENT imagePainter EMPTY>
<!ATTLIST imagePainter
          id                    ID             #IMPLIED
          method                CDATA          #IMPLIED
          direction             (north|south|east|west|top|left|bottom|right|horizontal|vertical|horizontal_split|vertical_split)          #IMPLIED
          path                  CDATA          #REQUIRED
          sourceInsets          CDATA          #IMPLIED
          destinationInsets     CDATA          #IMPLIED
          paintCenter           (true|false)   "true"
          stretch               (true|false)   "true"
          center                (true|false)   "false"
>

Attribute definitions

id
Unique identifier for the imagePainter.
method
Identifies the SynthPainter method this is to be used for. The name corresponds to the method name of a paint method in SynthPainter with the paint prefix dropped, the remainder is case insensitive (using the latin1 case folding rules). For example SynthPainter.paintButtonBackground is identified by 'buttonBackground' or 'buttonbackground'. If this is not specified the painter is used for all methods that don't have a a specific painter for them.
direction
Identifies the direction, or orientation, this image is to be used for. This is only useful for the SynthPainter methods that take a direction or orientation. If this is not specified the image is used for all directions.
path
Path to the image. Path to the image. If SynthLookAndFeel.load is passed a Class this will use the Class method getResource (with with the Class suplied to the load method). If load is passed a URL this will use the URL constructor URL(context, path) to resolve the path.
sourceInsets
Insets on the source image. This is top, left, bottom, right with each component separated by a space.
destinationInsets
Insets of the destination image. This is top, left, bottom, right with each component separated by a space. If not specified the sourceInsets are used.
paintCenter
Whether or not the center of the image should be drawn.
stretch
Whether or not the north, south, east and west components of the resulting image should be scaled or tiled.
center
Whether or not the image is centered.

The ImagePainter element defines a painter for the current style or state that will render using the specified image. ImagePainter offers two distinct rendering modes. The first mode is used to center an image in the space provided. This is commonly used in rendering decorations on top of a widget, for example, to specify an arrow for a scroll button use the center mode. The following example illustrates this:

<style id="test">
  <imagePainter path="resources/myImage.png" center="true"/>
</style>

The second mode is used in scaling an image to fit in the provided space. In this mode sourceInsets is used to specify a border around an image where the north, south, east and west edges of the border are either stretched or tiled (stretch attribute), the four corners of the border drawn in place, and the center is stretched. In this mode you must specify sourceInsets. The following example illustrates an ImagePainter that is using the image MyImage.png and insets of 2 all the way around:

<style id="test">
  <imagePainter path="resources/myImage.png"
                sourceInsets="2 2 2 2"/>
</style>

Refer to the description of the painter element for details as to the precedence in choosing a painter and to understand how identical painters are handled.

The imageIcon element

<!ELEMENT imageIcon EMPTY>
<!ATTLIST imageIcon
          id                    ID             #REQUIRED
          path                  CDATA          #REQUIRED
>

Attribute definitions

id
Unique identifier for the imageIcon.
path
Path to the image. This uses the Class method getResource to resolve the path, with the Class supplied to SynthLookAndFeel.load.

ImageIcon is used to assign an Icon implementation that is wrapping an Image to a unique identifier. This is typically used for properties that take an Icon. The following example binds an ImageIcon to the property RadioButton.icon.

<style id="test">
  <imageIcon id="icon" path="resources/myImage.png"/>
  <property key="RadioButton.icon" value="icon"/>
</style>

The opaque element

<!ELEMENT opaque EMPTY>
<!ATTLIST opaque
          value              (true|false)   "true"
>

Attribute definitions

id
Whether or not the style should be opaque, if unspecified the style is opaque.

The opaque element indicates whether or not any Components the style is associated with are to be made opaque. The painter will be asked to paint regardless of the opacity of the associated Component. The following example creates a style that is not opaque.

<style id="test">
  <opaque value="FALSE">
  <painter idref="painter"/>
</style>

The beansPersistance entity

Beans persistance can be used to embed any Object. This is typically used for embedding your own Painters, but can be used for other arbritrary objects as well. Refer to http://java.sun.com/products/jfc/tsc/articles/persistence3/ for details on beans persistance.

Backing Style

In creating a Synth file it's good practice to create a backing style that is used by all components. This will make sure that any components that do not match a specific style will have a default font, foreground, background and opacity. The following example illustrates this:

<synth>
  <style id="backingStyle">
    <opaque value="true"/>
    <font name="Dialog" size="12"/>
    <state>
      <color value="BLACK" type="BACKGROUND"/>
      <color value="WHITE" type="FOREGROUND"/>
    </state>
  </style>
  <bind style="backingStyle" type="region" key=".*"/>
</synth>


类 javax.swing.plaf.synth.SynthPainter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthPainter
的使用

使用 SynthPainter 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthPainter 的使用

返回 SynthPainter 的 javax.swing.plaf.synth 中的方法
 SynthPainter SynthStyle.getPainter(SynthContext context)
返回将用于绘制的 SynthPainter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthContext
的使用

使用 SynthContext 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthContext 的使用

参数类型为 SynthContext 的 javax.swing.plaf.synth 中的方法
int | SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text) 返回传入字符串的大小。
void | SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2) 在两个端点之间绘制一条线。
void | SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey) 在两个端点之间绘制一条线。
Object | SynthStyle.get(SynthContext context, Object key) 某个 region 特定样式属性的获取器。
boolean | SynthStyle.getBoolean(SynthContext context, Object key, boolean defaultValue) 获得其值是一个 Boolean 值的特定样式属性的便捷方法。
Color | SynthStyle.getColor(SynthContext context, ColorType type) 返回指定状态的颜色。
protected abstract Color | SynthStyle.getColorForState(SynthContext context, ColorType type) 返回指定状态的颜色。
Font | SynthStyle.getFont(SynthContext context) 返回指定状态的 Font。
protected abstract Font | SynthStyle.getFontForState(SynthContext context) 返回指定状态的字体。
SynthGraphicsUtils | SynthStyle.getGraphicsUtils(SynthContext context) 返回指定上下文的 SynthGraphicUtils。
Icon | SynthStyle.getIcon(SynthContext context, Object key) 获得其值是一个 Icon 的特定样式属性的便捷方法。
Insets | SynthStyle.getInsets(SynthContext context, Insets insets) 返回用来计算大小调整信息的 Insets。
int | SynthStyle.getInt(SynthContext context, Object key, int defaultValue) 获得值为 Number 的一个特定样式属性的便捷方法。
int | SynthGraphicsUtils.getMaximumCharHeight(SynthContext context) 根据传入的 SynthContext 返回 Font 的最大高度。
Dimension | SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
SynthPainter | SynthStyle.getPainter(SynthContext context) 返回将用于绘制的 SynthPainter。
Dimension | SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。
String | SynthStyle.getString(SynthContext context, Object key, String defaultValue) 获得其值是一个 String 值的特定样式属性的便捷方法。
void | SynthStyle.installDefaults(SynthContext context) 在 context 的 JComponent 上根据此 Style 安装必要的状态。
boolean | SynthStyle.isOpaque(SynthContext context) 如果 region 是不透明的，则返回 true。
String | SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。
void | SynthPainter.paintArrowButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的背景。
void | SynthPainter.paintArrowButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的边框。
void | SynthPainter.paintArrowButtonForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int direction) 绘制箭头按钮的前景。
void | SynthPainter.paintButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的背景。
void | SynthPainter.paintButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的边框。
void | SynthPainter.paintCheckBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的背景。
void | SynthPainter.paintCheckBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的边框。
void | SynthPainter.paintCheckBoxMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的背景。
void | SynthPainter.paintCheckBoxMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的边框。
void | SynthPainter.paintColorChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的背景。
void | SynthPainter.paintColorChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的边框。
void | SynthPainter.paintComboBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的背景。
void | SynthPainter.paintComboBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的边框。
void | SynthPainter.paintDesktopIconBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的背景。
void | SynthPainter.paintDesktopIconBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的边框。
void | SynthPainter.paintDesktopPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的背景。
void | SynthPainter.paintDesktopPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的边框。
void | SynthPainter.paintEditorPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的背景。
void | SynthPainter.paintEditorPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的边框。
void | SynthPainter.paintFileChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的背景。
void | SynthPainter.paintFileChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的边框。
void | SynthPainter.paintFormattedTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的背景。
void | SynthPainter.paintFormattedTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的边框。
void | SynthPainter.paintInternalFrameBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的背景。
void | SynthPainter.paintInternalFrameBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的边框。
void | SynthPainter.paintInternalFrameTitlePaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的背景。
void | SynthPainter.paintInternalFrameTitlePaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的边框。
void | SynthPainter.paintLabelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的背景。
void | SynthPainter.paintLabelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的边框。
void | SynthPainter.paintListBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的背景。
void | SynthPainter.paintListBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的边框。
void | SynthPainter.paintMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的背景。
void | SynthPainter.paintMenuBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的背景。
void | SynthPainter.paintMenuBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的边框。
void | SynthPainter.paintMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的边框。
void | SynthPainter.paintMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的背景。
void | SynthPainter.paintMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的边框。
void | SynthPainter.paintOptionPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的背景。
void | SynthPainter.paintOptionPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的边框。
void | SynthPainter.paintPanelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的背景。
void | SynthPainter.paintPanelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的边框。
void | SynthPainter.paintPasswordFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的背景。
void | SynthPainter.paintPasswordFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的边框。
void | SynthPainter.paintPopupMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的背景。
void | SynthPainter.paintPopupMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的边框。
void | SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的背景。
void | SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的背景。
void | SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的边框。
void | SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的边框。
void | SynthPainter.paintProgressBarForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的前景。
void | SynthPainter.paintRadioButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的背景。
void | SynthPainter.paintRadioButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的边框。
void | SynthPainter.paintRadioButtonMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的背景。
void | SynthPainter.paintRadioButtonMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的边框。
void | SynthPainter.paintRootPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的背景。
void | SynthPainter.paintRootPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的边框。
void | SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的背景。
void | SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的背景。
void | SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的边框。
void | SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的边框。
void | SynthPainter.paintScrollBarThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的背景。
void | SynthPainter.paintScrollBarThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的边框。
void | SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的背景。
void | SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的背景。
void | SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的边框。
void | SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的边框。
void | SynthPainter.paintScrollPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的背景。
void | SynthPainter.paintScrollPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的边框。
void | SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的背景。
void | SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的背景。
void | SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的边框。
void | SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的边框。
void | SynthPainter.paintSeparatorForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的前景。
void | SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的背景。
void | SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的背景。
void | SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的边框。
void | SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的边框。
void | SynthPainter.paintSliderThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的背景。
void | SynthPainter.paintSliderThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的边框。
void | SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的背景。
void | SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的背景。
void | SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的边框。
void | SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的边框。
void | SynthPainter.paintSpinnerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的背景。
void | SynthPainter.paintSpinnerBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的边框。
void | SynthPainter.paintSplitPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的背景。
void | SynthPainter.paintSplitPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的边框。
void | SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的分隔栏的背景。
void | SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的背景。
void | SynthPainter.paintSplitPaneDividerForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的前景。
void | SynthPainter.paintSplitPaneDragDivider(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 当用户拖动分隔符时，绘制分隔窗格的分隔栏。
void | SynthPainter.paintTabbedPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的背景。
void | SynthPainter.paintTabbedPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的边框。
void | SynthPainter.paintTabbedPaneContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的背景。
void | SynthPainter.paintTabbedPaneContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的边框。
void | SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的背景。
void | SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的背景。
void | SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的边框。
void | SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的边框。
void | SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的背景。
void | SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的背景。
void | SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的边框。
void | SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的边框。
void | SynthPainter.paintTableBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的背景。
void | SynthPainter.paintTableBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的边框。
void | SynthPainter.paintTableHeaderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的背景。
void | SynthPainter.paintTableHeaderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的边框。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset) 绘制图标和文本。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex) 在指定位置上绘制文本。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex) 在指定位置上绘制文本。
void | SynthPainter.paintTextAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的背景。
void | SynthPainter.paintTextAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的边框。
void | SynthPainter.paintTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的背景。
void | SynthPainter.paintTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的边框。
void | SynthPainter.paintTextPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的背景。
void | SynthPainter.paintTextPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的边框。
void | SynthPainter.paintToggleButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的背景。
void | SynthPainter.paintToggleButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的边框。
void | SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的背景。
void | SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的背景。
void | SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的边框。
void | SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的边框。
void | SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的背景。
void | SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的背景。
void | SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的边框。
void | SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的边框。
void | SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | SynthPainter.paintToolTipBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的背景。
void | SynthPainter.paintToolTipBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的边框。
void | SynthPainter.paintTreeBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的背景。
void | SynthPainter.paintTreeBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的边框。
void | SynthPainter.paintTreeCellBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的背景。
void | SynthPainter.paintTreeCellBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的边框。
void | SynthPainter.paintTreeCellFocus(SynthContext context, Graphics g, int x, int y, int w, int h) 当树中某个单元格拥有焦点时，绘制该单元格的焦点指示器。
void | SynthPainter.paintViewportBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的背景。
void | SynthPainter.paintViewportBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的边框。
void | SynthStyle.uninstallDefaults(SynthContext context) 卸载此样式在 context 的 JComponent 上安装的任何状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.plaf.synth.SynthConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.plaf.synth.SynthConstants
的使用

没有 javax.swing.plaf.synth.SynthConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.synth.ColorType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.ColorType
的使用

使用 ColorType 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 ColorType 的使用

声明为 ColorType 的 javax.swing.plaf.synth 中的字段
static ColorType | ColorType.BACKGROUND 某一 region 背景的 ColorType。
static ColorType | ColorType.FOCUS 焦点的 ColorType。
static ColorType | ColorType.FOREGROUND 某一 region 前景的 ColorType。
static ColorType | ColorType.TEXT_BACKGROUND 某一 region 背景的 ColorType。
static ColorType | ColorType.TEXT_FOREGROUND 某一 region 前景的 ColorType。

参数类型为 ColorType 的 javax.swing.plaf.synth 中的方法
Color | SynthStyle.getColor(SynthContext context, ColorType type) 返回指定状态的颜色。
protected abstract Color | SynthStyle.getColorForState(SynthContext context, ColorType type) 返回指定状态的颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthGraphicsUtils 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthGraphicsUtils
的使用

使用 SynthGraphicsUtils 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthGraphicsUtils 的使用

返回 SynthGraphicsUtils 的 javax.swing.plaf.synth 中的方法
 SynthGraphicsUtils SynthStyle.getGraphicsUtils(SynthContext context)
返回指定上下文的 SynthGraphicUtils。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthStyle 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthStyle
的使用

使用 SynthStyle 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthStyle 的使用

返回 SynthStyle 的 javax.swing.plaf.synth 中的方法
SynthStyle | SynthContext.getStyle() 返回与此 Region 相关的样式。
abstract SynthStyle | SynthStyleFactory.getStyle(JComponent c, Region id) 返回指定 Component 的样式。
static SynthStyle | SynthLookAndFeel.getStyle(JComponent c, Region region) 获取指定组件的指定 region 的 SynthStyle。

参数类型为 SynthStyle 的 javax.swing.plaf.synth 中的构造方法
SynthContext(JComponent component, Region region, SynthStyle style, int state)
创建一个具有指定值的 SynthContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.synth.Region 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.Region
的使用

使用 Region 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 Region 的使用

声明为 Region 的 javax.swing.plaf.synth 中的字段
static Region | Region.ARROW_BUTTON ArrowButton 是特殊类型的按钮，也呈现了一个方向指示器（通常是一个箭头）。
static Region | Region.BUTTON Button 的 region。
static Region | Region.CHECK_BOX CheckBox 的 region。
static Region | Region.CHECK_BOX_MENU_ITEM CheckBoxMenuItem 的 region。
static Region | Region.COLOR_CHOOSER ColorChooser 的 region。
static Region | Region.COMBO_BOX ComboBox 的 region。
static Region | Region.DESKTOP_ICON DesktopIcon 的 region。
static Region | Region.DESKTOP_PANE DesktopPane 的 region。
static Region | Region.EDITOR_PANE EditorPane 的 region。
static Region | Region.FILE_CHOOSER FileChooser 的 region。
static Region | Region.FORMATTED_TEXT_FIELD FormattedTextField 的 region。
static Region | Region.INTERNAL_FRAME InternalFrame 的 region。
static Region | Region.INTERNAL_FRAME_TITLE_PANE InternalFrame 的 TitlePane。
static Region | Region.LABEL Label 的 region。
static Region | Region.LIST List 的 region。
static Region | Region.MENU Menu 的 region。
static Region | Region.MENU_BAR MenuBar 的 region。
static Region | Region.MENU_ITEM MenuItem 的 region。
static Region | Region.MENU_ITEM_ACCELERATOR MenuItem 的加速器 region。
static Region | Region.OPTION_PANE OptionPane 的 region。
static Region | Region.PANEL Panel 的 region。
static Region | Region.PASSWORD_FIELD PasswordField 的 region。
static Region | Region.POPUP_MENU PopupMenu 的 region。
static Region | Region.POPUP_MENU_SEPARATOR PopupMenuSeparator 的 region。
static Region | Region.PROGRESS_BAR ProgressBar 的 region。
static Region | Region.RADIO_BUTTON RadioButton 的 region。
static Region | Region.RADIO_BUTTON_MENU_ITEM RegionButtonMenuItem 的 region。
static Region | Region.ROOT_PANE RootPane 的 region。
static Region | Region.SCROLL_BAR ScrollBar 的 region。
static Region | Region.SCROLL_BAR_THUMB ScrollBar 的 thumb。
static Region | Region.SCROLL_BAR_TRACK ScrollBar 的滑道。
static Region | Region.SCROLL_PANE ScrollPane 的 region。
static Region | Region.SEPARATOR Separator 的 region。
static Region | Region.SLIDER Slider 的 region。
static Region | Region.SLIDER_THUMB 滑块的 thumb。
static Region | Region.SLIDER_TRACK Slider 的滑道。
static Region | Region.SPINNER Spinner 的 region。
static Region | Region.SPLIT_PANE SplitPane 的 region。
static Region | Region.SPLIT_PANE_DIVIDER SplitPane 的分隔器。
static Region | Region.TABBED_PANE TabbedPane 的 region。
static Region | Region.TABBED_PANE_CONTENT 包含内容的 TabbedPane 的 region。
static Region | Region.TABBED_PANE_TAB 某一选项卡的 TabbedPane 的 region。
static Region | Region.TABBED_PANE_TAB_AREA 包含选项卡的 TabbedPane 的 region。
static Region | Region.TABLE Table 的 region。
static Region | Region.TABLE_HEADER TableHeader 的 region。
static Region | Region.TEXT_AREA TextArea 的 region。
static Region | Region.TEXT_FIELD TextField 的 region。
static Region | Region.TEXT_PANE TextPane 的 region。
static Region | Region.TOGGLE_BUTTON ToggleButton 的 region。
static Region | Region.TOOL_BAR ToolBar 的 region。
static Region | Region.TOOL_BAR_CONTENT 包含内容的 ToolBar 的 region。
static Region | Region.TOOL_BAR_DRAG_WINDOW 包含 ToolBar 的 Window 的 region。
static Region | Region.TOOL_BAR_SEPARATOR ToolBar 分隔器的 region。
static Region | Region.TOOL_TIP ToolTip 的 region。
static Region | Region.TREE Tree 的 region。
static Region | Region.TREE_CELL 用于某一单元格的 Tree 的 region。
static Region | Region.VIEWPORT Viewport 的 region。

返回 Region 的 javax.swing.plaf.synth 中的方法
Region | SynthContext.getRegion() 返回标识此状态的 Region。
static Region | SynthLookAndFeel.getRegion(JComponent c) 返回 JComponent c 的 Region。

参数类型为 Region 的 javax.swing.plaf.synth 中的方法
abstract SynthStyle | SynthStyleFactory.getStyle(JComponent c, Region id) 返回指定 Component 的样式。
static SynthStyle | SynthLookAndFeel.getStyle(JComponent c, Region region) 获取指定组件的指定 region 的 SynthStyle。

参数类型为 Region 的 javax.swing.plaf.synth 中的构造方法
SynthContext(JComponent component, Region region, SynthStyle style, int state)
创建一个具有指定值的 SynthContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthStyleFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthStyleFactory
的使用

使用 SynthStyleFactory 的软件包
javax.swing.plaf.synth Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.plaf.synth 中 SynthStyleFactory 的使用

返回 SynthStyleFactory 的 javax.swing.plaf.synth 中的方法
static SynthStyleFactory SynthLookAndFeel.getStyleFactory()
返回当前 SynthStyleFactory。

参数类型为 SynthStyleFactory 的 javax.swing.plaf.synth 中的方法
static void SynthLookAndFeel.setStyleFactory(SynthStyleFactory cache)
设置 SynthStyleFactory，由 synth 提供的 UI 类将使用它来获取 SynthStyle。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.synth.SynthLookAndFeel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.synth.SynthLookAndFeel
的使用

没有 javax.swing.plaf.synth.SynthLookAndFeel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ColorChooserUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ColorChooserUI
的使用

使用 ColorChooserUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ColorChooserUI 的使用

返回 ColorChooserUI 的 javax.swing 中的方法
 ColorChooserUI JColorChooser.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 ColorChooserUI 的 javax.swing 中的方法
 void JColorChooser.setUI(ColorChooserUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ColorChooserUI 的使用

javax.swing.plaf.basic 中 ColorChooserUI 的子类
 class BasicColorChooserUI
为 JColorChooser 提供基本外观。

javax.swing.plaf.multi 中 ColorChooserUI 的使用

javax.swing.plaf.multi 中 ColorChooserUI 的子类
 class MultiColorChooserUI
用于组合 ColorChooserUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.DesktopIconUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.DesktopIconUI
的使用

使用 DesktopIconUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 DesktopIconUI 的使用

返回 DesktopIconUI 的 javax.swing 中的方法
 DesktopIconUI JInternalFrame.JDesktopIcon.getUI()
返回呈现此组件的外观对象。

参数类型为 DesktopIconUI 的 javax.swing 中的方法
 void JInternalFrame.JDesktopIcon.setUI(DesktopIconUI ui)
设置呈现此组件的外观对象。

javax.swing.plaf.basic 中 DesktopIconUI 的使用

javax.swing.plaf.basic 中 DesktopIconUI 的子类
 class BasicDesktopIconUI
用于桌面最小化窗口的 L&F。

javax.swing.plaf.metal 中 DesktopIconUI 的使用

javax.swing.plaf.metal 中 DesktopIconUI 的子类
 class MetalDesktopIconUI
Metal 桌面图标。

javax.swing.plaf.multi 中 DesktopIconUI 的使用

javax.swing.plaf.multi 中 DesktopIconUI 的子类
 class MultiDesktopIconUI
用于组合 DesktopIconUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.DesktopPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.DesktopPaneUI
的使用

使用 DesktopPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 DesktopPaneUI 的使用

返回 DesktopPaneUI 的 javax.swing 中的方法
 DesktopPaneUI JDesktopPane.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 DesktopPaneUI 的 javax.swing 中的方法
 void JDesktopPane.setUI(DesktopPaneUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 DesktopPaneUI 的使用

javax.swing.plaf.basic 中 DesktopPaneUI 的子类
 class BasicDesktopPaneUI
桌面的基本 L&F。

javax.swing.plaf.multi 中 DesktopPaneUI 的使用

javax.swing.plaf.multi 中 DesktopPaneUI 的子类
 class MultiDesktopPaneUI
用于组合 DesktopPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.FileChooserUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.FileChooserUI
的使用

使用 FileChooserUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 FileChooserUI 的使用

返回 FileChooserUI 的 javax.swing 中的方法
 FileChooserUI JFileChooser.getUI()
获得实现此组件 L&F 的 UI 对象。

javax.swing.plaf.basic 中 FileChooserUI 的使用

javax.swing.plaf.basic 中 FileChooserUI 的子类
 class BasicFileChooserUI
FileChooser 的基本 L&F 实现。

javax.swing.plaf.metal 中 FileChooserUI 的使用

javax.swing.plaf.metal 中 FileChooserUI 的子类
 class MetalFileChooserUI
FileChooser 的 Metal L&F 实现。

javax.swing.plaf.multi 中 FileChooserUI 的使用

javax.swing.plaf.multi 中 FileChooserUI 的子类
 class MultiFileChooserUI
用于组合 FileChooserUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.IconUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.IconUIResource
的使用

没有 javax.swing.plaf.IconUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.InternalFrameUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.InternalFrameUI
的使用

使用 InternalFrameUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 InternalFrameUI 的使用

返回 InternalFrameUI 的 javax.swing 中的方法
 InternalFrameUI JInternalFrame.getUI()
返回呈现此组件的外观对象。

参数类型为 InternalFrameUI 的 javax.swing 中的方法
 void JInternalFrame.setUI(InternalFrameUI ui)
设置此 JInternalFrame 的 UI 委托。

javax.swing.plaf.basic 中 InternalFrameUI 的使用

javax.swing.plaf.basic 中 InternalFrameUI 的子类
 class BasicInternalFrameUI
JInternalFrame 的基本 L&F 实现。

javax.swing.plaf.metal 中 InternalFrameUI 的使用

javax.swing.plaf.metal 中 InternalFrameUI 的子类
 class MetalInternalFrameUI
JInternalFrame 的 Metal 实现。

javax.swing.plaf.multi 中 InternalFrameUI 的使用

javax.swing.plaf.multi 中 InternalFrameUI 的子类
 class MultiInternalFrameUI
用于组合 InternalFrameUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.OptionPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.OptionPaneUI
的使用

使用 OptionPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 OptionPaneUI 的使用

返回 OptionPaneUI 的 javax.swing 中的方法
 OptionPaneUI JOptionPane.getUI()
返回实现此组件 L&F 的 UI 对象。

参数类型为 OptionPaneUI 的 javax.swing 中的方法
 void JOptionPane.setUI(OptionPaneUI ui)
设置实现此组件 L&F 的 UI 对象。

javax.swing.plaf.basic 中 OptionPaneUI 的使用

javax.swing.plaf.basic 中 OptionPaneUI 的子类
 class BasicOptionPaneUI
为 JOptionPane 提供基本外观。

javax.swing.plaf.multi 中 OptionPaneUI 的使用

javax.swing.plaf.multi 中 OptionPaneUI 的子类
 class MultiOptionPaneUI
用于组合 OptionPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.SpinnerUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.SpinnerUI
的使用

使用 SpinnerUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 SpinnerUI 的使用

返回 SpinnerUI 的 javax.swing 中的方法
 SpinnerUI JSpinner.getUI()
返回呈现此组件的外观 (L&F) 对象。

参数类型为 SpinnerUI 的 javax.swing 中的方法
 void JSpinner.setUI(SpinnerUI ui)
设置呈现此组件的外观 (L&F) 对象。

javax.swing.plaf.basic 中 SpinnerUI 的使用

javax.swing.plaf.basic 中 SpinnerUI 的子类
 class BasicSpinnerUI
默认 Spinner UI 委托。

javax.swing.plaf.multi 中 SpinnerUI 的使用

javax.swing.plaf.multi 中 SpinnerUI 的子类
 class MultiSpinnerUI
用于组合 SpinnerUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ToolTipUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ToolTipUI
的使用

使用 ToolTipUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ToolTipUI 的使用

返回 ToolTipUI 的 javax.swing 中的方法
 ToolTipUI JToolTip.getUI()
返回呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ToolTipUI 的使用

javax.swing.plaf.basic 中 ToolTipUI 的子类
 class BasicToolTipUI
标准工具提示 L&F。

javax.swing.plaf.metal 中 ToolTipUI 的使用

javax.swing.plaf.metal 中 ToolTipUI 的子类
 class MetalToolTipUI
BasicToolTipUI 的 Metal L&F 扩展。

javax.swing.plaf.multi 中 ToolTipUI 的使用

javax.swing.plaf.multi 中 ToolTipUI 的子类
 class MultiToolTipUI
用于组合 ToolTipUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.SliderUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.SliderUI
的使用

使用 SliderUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 SliderUI 的使用

返回 SliderUI 的 javax.swing 中的方法
 SliderUI JSlider.getUI()
获取实现此组件 L&F 的 UI 对象。

参数类型为 SliderUI 的 javax.swing 中的方法
 void JSlider.setUI(SliderUI ui)
设置实现此组件 L&F 的 UI 对象。

javax.swing.plaf.basic 中 SliderUI 的使用

javax.swing.plaf.basic 中 SliderUI 的子类
 class BasicSliderUI
SliderUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 SliderUI 的使用

javax.swing.plaf.metal 中 SliderUI 的子类
 class MetalSliderUI
SliderUI 的 Java L&F 实现。

javax.swing.plaf.multi 中 SliderUI 的使用

javax.swing.plaf.multi 中 SliderUI 的子类
 class MultiSliderUI
用于组合 SliderUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.SplitPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.SplitPaneUI
的使用

使用 SplitPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 SplitPaneUI 的使用

返回 SplitPaneUI 的 javax.swing 中的方法
 SplitPaneUI JSplitPane.getUI()
返回提供当前外观的 SplitPaneUI。

参数类型为 SplitPaneUI 的 javax.swing 中的方法
 void JSplitPane.setUI(SplitPaneUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 SplitPaneUI 的使用

javax.swing.plaf.basic 中 SplitPaneUI 的子类
 class BasicSplitPaneUI
SplitPaneUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 SplitPaneUI 的使用

javax.swing.plaf.metal 中 SplitPaneUI 的子类
 class MetalSplitPaneUI
Metal 分隔窗格。

javax.swing.plaf.multi 中 SplitPaneUI 的使用

javax.swing.plaf.multi 中 SplitPaneUI 的子类
 class MultiSplitPaneUI
用于组合 SplitPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.TreeUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TreeUI
的使用

使用 TreeUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 TreeUI 的使用

返回 TreeUI 的 javax.swing 中的方法
 TreeUI JTree.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 TreeUI 的 javax.swing 中的方法
 void JTree.setUI(TreeUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 TreeUI 的使用

javax.swing.plaf.basic 中 TreeUI 的子类
 class BasicTreeUI
层次数据结构的基本 L&F。

javax.swing.plaf.metal 中 TreeUI 的使用

javax.swing.plaf.metal 中 TreeUI 的子类
 class MetalTreeUI
TreeUI 的 metal 外观实现。

javax.swing.plaf.multi 中 TreeUI 的使用

javax.swing.plaf.multi 中 TreeUI 的子类
 class MultiTreeUI
用于组合 TreeUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.TableUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TableUI
的使用

使用 TableUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 TableUI 的使用

返回 TableUI 的 javax.swing 中的方法
 TableUI JTable.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 TableUI 的 javax.swing 中的方法
 void JTable.setUI(TableUI ui)
设置呈现此组件并进行重新绘制的 L&F 对象。

javax.swing.plaf.basic 中 TableUI 的使用

javax.swing.plaf.basic 中 TableUI 的子类
 class BasicTableUI
BasicTableUI 实现

javax.swing.plaf.multi 中 TableUI 的使用

javax.swing.plaf.multi 中 TableUI 的子类
 class MultiTableUI
用于组合 TableUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.TableHeaderUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TableHeaderUI
的使用

使用 TableHeaderUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.plaf.basic 中 TableHeaderUI 的使用

javax.swing.plaf.basic 中 TableHeaderUI 的子类
 class BasicTableHeaderUI
BasicTableHeaderUI 实现

javax.swing.plaf.multi 中 TableHeaderUI 的使用

javax.swing.plaf.multi 中 TableHeaderUI 的子类
 class MultiTableHeaderUI
用于组合 TableHeaderUI 的多路 UI。

javax.swing.table 中 TableHeaderUI 的使用

返回 TableHeaderUI 的 javax.swing.table 中的方法
 TableHeaderUI JTableHeader.getUI()
返回渲染此组件的外观 (L&F) 对象。

参数类型为 TableHeaderUI 的 javax.swing.table 中的方法
 void JTableHeader.setUI(TableHeaderUI ui)
设置渲染此组件的 (L&F) 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ProgressBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ProgressBarUI
的使用

使用 ProgressBarUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ProgressBarUI 的使用

返回 ProgressBarUI 的 javax.swing 中的方法
 ProgressBarUI JProgressBar.getUI()
返回呈现此组件的外观对象。

参数类型为 ProgressBarUI 的 javax.swing 中的方法
 void JProgressBar.setUI(ProgressBarUI ui)
设置呈现此组件的外观对象。

javax.swing.plaf.basic 中 ProgressBarUI 的使用

javax.swing.plaf.basic 中 ProgressBarUI 的子类
 class BasicProgressBarUI
ProgressBarUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 ProgressBarUI 的使用

javax.swing.plaf.metal 中 ProgressBarUI 的子类
 class MetalProgressBarUI
ProgressBarUI 的 Metal 实现。

javax.swing.plaf.multi 中 ProgressBarUI 的使用

javax.swing.plaf.multi 中 ProgressBarUI 的子类
 class MultiProgressBarUI
用于组合 ProgressBarUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.TabbedPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TabbedPaneUI
的使用

使用 TabbedPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 TabbedPaneUI 的使用

返回 TabbedPaneUI 的 javax.swing 中的方法
 TabbedPaneUI JTabbedPane.getUI()
返回实现此组件的 L&F 的 UI 对象。

参数类型为 TabbedPaneUI 的 javax.swing 中的方法
 void JTabbedPane.setUI(TabbedPaneUI ui)
设置实现此组件的 L&F 的 UI 对象。

javax.swing.plaf.basic 中 TabbedPaneUI 的使用

javax.swing.plaf.basic 中 TabbedPaneUI 的子类
 class BasicTabbedPaneUI
TabbedPaneUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 TabbedPaneUI 的使用

javax.swing.plaf.metal 中 TabbedPaneUI 的子类
 class MetalTabbedPaneUI
BasicTabbedPaneUI 的 Metal 子类。

javax.swing.plaf.multi 中 TabbedPaneUI 的使用

javax.swing.plaf.multi 中 TabbedPaneUI 的子类
 class MultiTabbedPaneUI
用于组合 TabbedPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.TextUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.TextUI
的使用

使用 TextUI 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 TextUI 的使用

javax.swing.plaf.basic 中 TextUI 的子类
class | BasicEditorPaneUI 为 JEditorPane 提供外观。
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。
class | BasicTextAreaUI 为纯文本编辑器提供外观。
class | BasicTextFieldUI JTextField 的外观的基础。
class | BasicTextPaneUI 为样式化文本编辑器提供外观。
class | BasicTextUI 此类是文本组件外观的基础。

javax.swing.plaf.metal 中 TextUI 的使用

javax.swing.plaf.metal 中 TextUI 的子类
 class MetalTextFieldUI
JTextField 外观的基础。

javax.swing.plaf.multi 中 TextUI 的使用

javax.swing.plaf.multi 中 TextUI 的子类
 class MultiTextUI
用于组合 TextUI 的多路 UI。

javax.swing.text 中 TextUI 的使用

javax.swing.text 中 TextUI 的子类
 class DefaultTextUI
已过时。

返回 TextUI 的 javax.swing.text 中的方法
 TextUI JTextComponent.getUI()
获取此面向文本的编辑器的用户界面工厂。

参数类型为 TextUI 的 javax.swing.text 中的方法
 void JTextComponent.setUI(TextUI ui)
设置此面向文本的编辑器的用户界面工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.CompoundBorderUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.CompoundBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.CompoundBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.LineBorderUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.LineBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.LineBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource
的使用

没有 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ScrollPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ScrollPaneUI
的使用

使用 ScrollPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ScrollPaneUI 的使用

返回 ScrollPaneUI 的 javax.swing 中的方法
 ScrollPaneUI JScrollPane.getUI()
返回呈现此组件的外观 (L&F) 对象。

参数类型为 ScrollPaneUI 的 javax.swing 中的方法
 void JScrollPane.setUI(ScrollPaneUI ui)
设置 ScrollPaneUI 对象，它为此组件提供外观 (L&F)。

javax.swing.plaf.basic 中 ScrollPaneUI 的使用

javax.swing.plaf.basic 中 ScrollPaneUI 的子类
 class BasicScrollPaneUI
ScrollPaneUI 的默认 L&F 实现。

javax.swing.plaf.metal 中 ScrollPaneUI 的使用

javax.swing.plaf.metal 中 ScrollPaneUI 的子类
 class MetalScrollPaneUI
ScrollPaneUI 的 Metal L&F 实现。

javax.swing.plaf.multi 中 ScrollPaneUI 的使用

javax.swing.plaf.multi 中 ScrollPaneUI 的子类
 class MultiScrollPaneUI
用于组合 ScrollPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ViewportUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ViewportUI
的使用

使用 ViewportUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ViewportUI 的使用

返回 ViewportUI 的 javax.swing 中的方法
 ViewportUI JViewport.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 ViewportUI 的 javax.swing 中的方法
 void JViewport.setUI(ViewportUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ViewportUI 的使用

javax.swing.plaf.basic 中 ViewportUI 的子类
 class BasicViewportUI
BasicViewport 实现

javax.swing.plaf.multi 中 ViewportUI 的使用

javax.swing.plaf.multi 中 ViewportUI 的子类
 class MultiViewportUI
用于组合 ViewportUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ListUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ListUI
的使用

使用 ListUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ListUI 的使用

返回 ListUI 的 javax.swing 中的方法
 ListUI JList.getUI()
返回呈现此组件的外观对象 ListUI。

参数类型为 ListUI 的 javax.swing 中的方法
 void JList.setUI(ListUI ui)
设置呈现此组件的外观对象 ListUI。

javax.swing.plaf.basic 中 ListUI 的使用

javax.swing.plaf.basic 中 ListUI 的子类
 class BasicListUI
ListUI 的可扩展实现。

javax.swing.plaf.multi 中 ListUI 的使用

javax.swing.plaf.multi 中 ListUI 的子类
 class MultiListUI
用于组合 ListUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ComboBoxUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ComboBoxUI
的使用

使用 ComboBoxUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ComboBoxUI 的使用

返回 ComboBoxUI 的 javax.swing 中的方法
 ComboBoxUI JComboBox.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 ComboBoxUI 的 javax.swing 中的方法
 void JComboBox.setUI(ComboBoxUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ComboBoxUI 的使用

javax.swing.plaf.basic 中 ComboBoxUI 的子类
 class BasicComboBoxUI
JComboBox 的基本 UI 实现。

javax.swing.plaf.metal 中 ComboBoxUI 的使用

javax.swing.plaf.metal 中 ComboBoxUI 的子类
 class MetalComboBoxUI
JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

javax.swing.plaf.multi 中 ComboBoxUI 的使用

javax.swing.plaf.multi 中 ComboBoxUI 的子类
 class MultiComboBoxUI
用于组合 ComboBoxUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ScrollBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ScrollBarUI
的使用

使用 ScrollBarUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ScrollBarUI 的使用

返回 ScrollBarUI 的 javax.swing 中的方法
 ScrollBarUI JScrollBar.getUI()
返回实现此组件的外观的委托。

参数类型为 ScrollBarUI 的 javax.swing 中的方法
 void JScrollBar.setUI(ScrollBarUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ScrollBarUI 的使用

javax.swing.plaf.basic 中 ScrollBarUI 的子类
 class BasicScrollBarUI
基本外观的 ScrollBarUI 的实现

javax.swing.plaf.metal 中 ScrollBarUI 的使用

javax.swing.plaf.metal 中 ScrollBarUI 的子类
 class MetalScrollBarUI
ScrollBarUI 的 Metal 外观实现

javax.swing.plaf.multi 中 ScrollBarUI 的使用

javax.swing.plaf.multi 中 ScrollBarUI 的子类
 class MultiScrollBarUI
用于组合 ScrollBarUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.SeparatorUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.SeparatorUI
的使用

使用 SeparatorUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 SeparatorUI 的使用

返回 SeparatorUI 的 javax.swing 中的方法
 SeparatorUI JSeparator.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 SeparatorUI 的 javax.swing 中的方法
 void JSeparator.setUI(SeparatorUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 SeparatorUI 的使用

javax.swing.plaf.basic 中 SeparatorUI 的子类
class | BasicPopupMenuSeparatorUI PopupMenuSeparatorUI 的基本 L&F 实现。
class | BasicSeparatorUI SeparatorUI 的基本 L&F 实现。
class | BasicToolBarSeparatorUI ToolBarSeparatorUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 SeparatorUI 的使用

javax.swing.plaf.metal 中 SeparatorUI 的子类
class | MetalPopupMenuSeparatorUI PopupMenuSeparatorUI 的 Metal L&F 实现。
class | MetalSeparatorUI SeparatorUI 的 Metal L&F 实现。

javax.swing.plaf.multi 中 SeparatorUI 的使用

javax.swing.plaf.multi 中 SeparatorUI 的子类
 class MultiSeparatorUI
用于组合 SeparatorUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.PopupMenuUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.PopupMenuUI
的使用

使用 PopupMenuUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 PopupMenuUI 的使用

返回 PopupMenuUI 的 javax.swing 中的方法
 PopupMenuUI JPopupMenu.getUI()
返回用于呈现此组件的外观 (L&F) 对象。

参数类型为 PopupMenuUI 的 javax.swing 中的方法
 void JPopupMenu.setUI(PopupMenuUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 PopupMenuUI 的使用

javax.swing.plaf.basic 中 PopupMenuUI 的子类
 class BasicPopupMenuUI
PopupMenuUI 的 Windows L&F 实现。

javax.swing.plaf.multi 中 PopupMenuUI 的使用

javax.swing.plaf.multi 中 PopupMenuUI 的子类
 class MultiPopupMenuUI
用于组合 PopupMenuUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.MenuItemUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.MenuItemUI
的使用

使用 MenuItemUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 MenuItemUI 的使用

参数类型为 MenuItemUI 的 javax.swing 中的方法
 void JMenuItem.setUI(MenuItemUI ui)
设置呈现此组件的外观对象。

javax.swing.plaf.basic 中 MenuItemUI 的使用

javax.swing.plaf.basic 中 MenuItemUI 的子类
class | BasicCheckBoxMenuItemUI BasicCheckboxMenuItem 实现
class | BasicMenuItemUI BasicMenuItem 实现
class | BasicMenuUI MenuUI 的默认 L&F 实现。
class | BasicRadioButtonMenuItemUI BasicRadioButtonMenuItem 实现

javax.swing.plaf.multi 中 MenuItemUI 的使用

javax.swing.plaf.multi 中 MenuItemUI 的子类
 class MultiMenuItemUI
用于组合 MenuItemUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ToolBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ToolBarUI
的使用

使用 ToolBarUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ToolBarUI 的使用

返回 ToolBarUI 的 javax.swing 中的方法
 ToolBarUI JToolBar.getUI()
返回工具栏的当前 UI。

参数类型为 ToolBarUI 的 javax.swing 中的方法
 void JToolBar.setUI(ToolBarUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 ToolBarUI 的使用

javax.swing.plaf.basic 中 ToolBarUI 的子类
 class BasicToolBarUI
ToolBarUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 ToolBarUI 的使用

javax.swing.plaf.metal 中 ToolBarUI 的子类
 class MetalToolBarUI
ToolBarUI 的 Metal 外观实现。

javax.swing.plaf.multi 中 ToolBarUI 的使用

javax.swing.plaf.multi 中 ToolBarUI 的子类
 class MultiToolBarUI
用于组合 ToolBarUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.MenuBarUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.MenuBarUI
的使用

使用 MenuBarUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 MenuBarUI 的使用

返回 MenuBarUI 的 javax.swing 中的方法
 MenuBarUI JMenuBar.getUI()
返回菜单栏的当前 UI。

参数类型为 MenuBarUI 的 javax.swing 中的方法
 void JMenuBar.setUI(MenuBarUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 MenuBarUI 的使用

javax.swing.plaf.basic 中 MenuBarUI 的子类
 class BasicMenuBarUI
MenuBarUI 的默认 L&F 实现。

javax.swing.plaf.metal 中 MenuBarUI 的使用

javax.swing.plaf.metal 中 MenuBarUI 的子类
 class MetalMenuBarUI
MenuBarUI 的 Metal 实现。

javax.swing.plaf.multi 中 MenuBarUI 的使用

javax.swing.plaf.multi 中 MenuBarUI 的子类
 class MultiMenuBarUI
用于组合 MenuBarUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ButtonUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ButtonUI
的使用

使用 ButtonUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 ButtonUI 的使用

返回 ButtonUI 的 javax.swing 中的方法
 ButtonUI AbstractButton.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 ButtonUI 的 javax.swing 中的方法
 void AbstractButton.setUI(ButtonUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf 中 ButtonUI 的使用

javax.swing.plaf 中 ButtonUI 的子类
 class MenuItemUI
JMenuItem 的可插入外观界面。

javax.swing.plaf.basic 中 ButtonUI 的使用

javax.swing.plaf.basic 中 ButtonUI 的子类
class | BasicButtonUI BasicButton 实现
class | BasicCheckBoxMenuItemUI BasicCheckboxMenuItem 实现
class | BasicCheckBoxUI BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicMenuItemUI BasicMenuItem 实现
class | BasicMenuUI MenuUI 的默认 L&F 实现。
class | BasicRadioButtonMenuItemUI BasicRadioButtonMenuItem 实现
class | BasicRadioButtonUI BasicRadioButtonUI 的 RadioButtonUI 实现
class | BasicToggleButtonUI BasicToggleButton 实现

javax.swing.plaf.metal 中 ButtonUI 的使用

javax.swing.plaf.metal 中 ButtonUI 的子类
class | MetalButtonUI MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalToggleButtonUI MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

javax.swing.plaf.multi 中 ButtonUI 的使用

javax.swing.plaf.multi 中 ButtonUI 的子类
class | MultiButtonUI 用于组合 ButtonUI 的多路 UI。
class | MultiMenuItemUI 用于组合 MenuItemUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.LabelUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.LabelUI
的使用

使用 LabelUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 LabelUI 的使用

返回 LabelUI 的 javax.swing 中的方法
 LabelUI JLabel.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 LabelUI 的 javax.swing 中的方法
 void JLabel.setUI(LabelUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 LabelUI 的使用

javax.swing.plaf.basic 中 LabelUI 的子类
 class BasicLabelUI
LabelUI 的 Windows L&F 实现。

javax.swing.plaf.metal 中 LabelUI 的使用

javax.swing.plaf.metal 中 LabelUI 的子类
 class MetalLabelUI
LabelUI 的 Windows L&F 实现。

javax.swing.plaf.multi 中 LabelUI 的使用

javax.swing.plaf.multi 中 LabelUI 的子类
 class MultiLabelUI
用于组合 LabelUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ActionMapUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ActionMapUIResource
的使用

没有 javax.swing.plaf.ActionMapUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.InputMapUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.InputMapUIResource
的使用

没有 javax.swing.plaf.InputMapUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ComponentInputMapUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ComponentInputMapUIResource
的使用

没有 javax.swing.plaf.ComponentInputMapUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.RootPaneUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.RootPaneUI
的使用

使用 RootPaneUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 RootPaneUI 的使用

返回 RootPaneUI 的 javax.swing 中的方法
 RootPaneUI JRootPane.getUI()
返回呈现此组件的 L&F 对象。

参数类型为 RootPaneUI 的 javax.swing 中的方法
 void JRootPane.setUI(RootPaneUI ui)
设置呈现此组件的 L&F 对象。

javax.swing.plaf.basic 中 RootPaneUI 的使用

javax.swing.plaf.basic 中 RootPaneUI 的子类
 class BasicRootPaneUI
RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。

javax.swing.plaf.metal 中 RootPaneUI 的使用

javax.swing.plaf.metal 中 RootPaneUI 的子类
 class MetalRootPaneUI
提供 RootPaneUI 的 metal 外观实现。

javax.swing.plaf.multi 中 RootPaneUI 的使用

javax.swing.plaf.multi 中 RootPaneUI 的子类
 class MultiRootPaneUI
用于组合 RootPaneUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.PanelUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.PanelUI
的使用

使用 PanelUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 PanelUI 的使用

返回 PanelUI 的 javax.swing 中的方法
 PanelUI JPanel.getUI()
返回呈现此组件的外观 (L&F) 对象。

参数类型为 PanelUI 的 javax.swing 中的方法
 void JPanel.setUI(PanelUI ui)
设置呈现此组件的外观 (L&F) 对象。

javax.swing.plaf.basic 中 PanelUI 的使用

javax.swing.plaf.basic 中 PanelUI 的子类
 class BasicPanelUI
BasicPanel 实现

javax.swing.plaf.multi 中 PanelUI 的使用

javax.swing.plaf.multi 中 PanelUI 的子类
 class MultiPanelUI
用于组合 PanelUI 的多路 UI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ComponentUI 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ComponentUI
的使用

使用 ComponentUI 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 ComponentUI 的使用

声明为 ComponentUI 的 javax.swing 中的字段
protected  ComponentUI JComponent.ui
此组件的外观委托。

返回 ComponentUI 的 javax.swing 中的方法
ComponentUI | UIDefaults.getUI(JComponent target) 创建一个指定组件的 ComponentUI 实现。
static ComponentUI | UIManager.getUI(JComponent target) 返回 target 的适当 ComponentUI 实现。

返回变量类型为 ComponentUI 的类型的 javax.swing 中的方法
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID) 返回呈现此组件的 L&F 类。
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader) get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。

参数类型为 ComponentUI 的 javax.swing 中的方法
protected  void JComponent.setUI(ComponentUI newUI)
设置此组件的外观委托。

javax.swing.plaf 中 ComponentUI 的使用

javax.swing.plaf 中 ComponentUI 的子类
class | ButtonUI JButton 的可插入外观界面。
class | ColorChooserUI JColorChooser 的可插入外观界面。
class | ComboBoxUI JComboBox 的可插入外观界面。
class | DesktopIconUI JDesktopIcon 的可插入外观界面。
class | DesktopPaneUI JDesktopPane 的可插入外观界面。
class | FileChooserUI JFileChooser 的可插入外观界面。
class | InternalFrameUI JInternalFrame 的可插入外观界面。
class | LabelUI JLabel 的可插入外观界面。
class | ListUI JList 的可插入外观代理。
class | MenuBarUI JMenuBar 的可插入外观界面。
class | MenuItemUI JMenuItem 的可插入外观界面。
class | OptionPaneUI JOptionPane 的可插入外观界面。
class | PanelUI Panel 的可插入外观界面。
class | PopupMenuUI JPopupMenu 的可插入外观界面。
class | ProgressBarUI JProgressBar 的可插入外观界面。
class | RootPaneUI JRootPane 的可插入外观界面。
class | ScrollBarUI JScrollBar 的可插入外观界面。
class | ScrollPaneUI JScrollPane 的可插入外观界面。
class | SeparatorUI JSeparator 的可插入外观界面。
class | SliderUI JSlider 的可插入外观界面。
class | SpinnerUI JSpinner 的可插入外观界面
class | SplitPaneUI JSplitPane 的可插入外观界面。
class | TabbedPaneUI JTabbedPane 的可插入外观界面。
class | TableHeaderUI JTableHeader 的可插入外观界面。
class | TableUI JTable 的可插入外观界面。
class | TextUI 文本编辑器用户界面
class | ToolBarUI JToolBar 的可插入外观界面。
class | ToolTipUI JToolTip 的可插入外观界面。
class | TreeUI JTree 的可插入外观界面。
class | ViewportUI JViewport 的可插入外观界面。

返回 ComponentUI 的 javax.swing.plaf 中的方法
static ComponentUI ComponentUI.createUI(JComponent c)
返回指定组件的一个 UI 委托实例。

javax.swing.plaf.basic 中 ComponentUI 的使用

javax.swing.plaf.basic 中 ComponentUI 的子类
class | BasicButtonUI BasicButton 实现
class | BasicCheckBoxMenuItemUI BasicCheckboxMenuItem 实现
class | BasicCheckBoxUI BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicColorChooserUI 为 JColorChooser 提供基本外观。
class | BasicComboBoxUI JComboBox 的基本 UI 实现。
class | BasicDesktopIconUI 用于桌面最小化窗口的 L&F。
class | BasicDesktopPaneUI 桌面的基本 L&F。
class | BasicEditorPaneUI 为 JEditorPane 提供外观。
class | BasicFileChooserUI FileChooser 的基本 L&F 实现。
class | BasicFormattedTextFieldUI 提供 JFormattedTextField 的外观实现。
class | BasicInternalFrameUI JInternalFrame 的基本 L&F 实现。
class | BasicLabelUI LabelUI 的 Windows L&F 实现。
class | BasicListUI ListUI 的可扩展实现。
class | BasicMenuBarUI MenuBarUI 的默认 L&F 实现。
class | BasicMenuItemUI BasicMenuItem 实现
class | BasicMenuUI MenuUI 的默认 L&F 实现。
class | BasicOptionPaneUI 为 JOptionPane 提供基本外观。
class | BasicPanelUI BasicPanel 实现
class | BasicPasswordFieldUI 为密码字段提供 Windows 外观。
class | BasicPopupMenuSeparatorUI PopupMenuSeparatorUI 的基本 L&F 实现。
class | BasicPopupMenuUI PopupMenuUI 的 Windows L&F 实现。
class | BasicProgressBarUI ProgressBarUI 的基本 L&F 实现。
class | BasicRadioButtonMenuItemUI BasicRadioButtonMenuItem 实现
class | BasicRadioButtonUI BasicRadioButtonUI 的 RadioButtonUI 实现
class | BasicRootPaneUI RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
class | BasicScrollBarUI 基本外观的 ScrollBarUI 的实现
class | BasicScrollPaneUI ScrollPaneUI 的默认 L&F 实现。
class | BasicSeparatorUI SeparatorUI 的基本 L&F 实现。
class | BasicSliderUI SliderUI 的基本 L&F 实现。
class | BasicSpinnerUI 默认 Spinner UI 委托。
class | BasicSplitPaneUI SplitPaneUI 的基本 L&F 实现。
class | BasicTabbedPaneUI TabbedPaneUI 的基本 L&F 实现。
class | BasicTableHeaderUI BasicTableHeaderUI 实现
class | BasicTableUI BasicTableUI 实现
class | BasicTextAreaUI 为纯文本编辑器提供外观。
class | BasicTextFieldUI JTextField 的外观的基础。
class | BasicTextPaneUI 为样式化文本编辑器提供外观。
class | BasicTextUI 此类是文本组件外观的基础。
class | BasicToggleButtonUI BasicToggleButton 实现
class | BasicToolBarSeparatorUI ToolBarSeparatorUI 的基本 L&F 实现。
class | BasicToolBarUI ToolBarUI 的基本 L&F 实现。
class | BasicToolTipUI 标准工具提示 L&F。
class | BasicTreeUI 层次数据结构的基本 L&F。
class | BasicViewportUI BasicViewport 实现

返回 ComponentUI 的 javax.swing.plaf.basic 中的方法
static ComponentUI | BasicCheckBoxUI.createUI(JComponent b)
static ComponentUI | BasicColorChooserUI.createUI(JComponent c)
static ComponentUI | BasicDesktopIconUI.createUI(JComponent c)
static ComponentUI | BasicDesktopPaneUI.createUI(JComponent c)
static ComponentUI | BasicEditorPaneUI.createUI(JComponent c) 创建 JTextPane 的 UI。
static ComponentUI | BasicFormattedTextFieldUI.createUI(JComponent c) 创建 JFormattedTextField 的 UI。
static ComponentUI | BasicInternalFrameUI.createUI(JComponent b)
static ComponentUI | BasicOptionPaneUI.createUI(JComponent x) 创建一个新的 BasicOptionPaneUI 实例。
static ComponentUI | BasicPasswordFieldUI.createUI(JComponent c) 创建 JPasswordField 的 UI。
static ComponentUI | BasicPopupMenuSeparatorUI.createUI(JComponent c)
static ComponentUI | BasicSpinnerUI.createUI(JComponent c) 返回 BasicSpinnerUI 的新实例。
static ComponentUI | BasicTextPaneUI.createUI(JComponent c) 创建 JTextPane 的 UI。
static ComponentUI | BasicToolTipUI.createUI(JComponent c)
static ComponentUI | BasicRadioButtonMenuItemUI.createUI(JComponent b)
static ComponentUI | BasicCheckBoxMenuItemUI.createUI(JComponent c)
static ComponentUI | BasicSliderUI.createUI(JComponent b)
static ComponentUI | BasicTextAreaUI.createUI(JComponent ta) 创建 JTextArea 的 UI。
static ComponentUI | BasicSplitPaneUI.createUI(JComponent x) 创建新的 BasicSplitPaneUI 实例
static ComponentUI | BasicTreeUI.createUI(JComponent x)
static ComponentUI | BasicTableUI.createUI(JComponent c)
static ComponentUI | BasicTableHeaderUI.createUI(JComponent h)
static ComponentUI | BasicProgressBarUI.createUI(JComponent x)
static ComponentUI | BasicRadioButtonUI.createUI(JComponent b)
static ComponentUI | BasicTabbedPaneUI.createUI(JComponent c)
static ComponentUI | BasicToolBarSeparatorUI.createUI(JComponent c)
static ComponentUI | BasicTextFieldUI.createUI(JComponent c) 创建 JTextField 的 UI。
static ComponentUI | BasicScrollPaneUI.createUI(JComponent x)
static ComponentUI | BasicViewportUI.createUI(JComponent c)
static ComponentUI | BasicListUI.createUI(JComponent list) 返回 BasicListUI 的新实例。
static ComponentUI | BasicComboBoxUI.createUI(JComponent c)
static ComponentUI | BasicScrollBarUI.createUI(JComponent c)
static ComponentUI | BasicSeparatorUI.createUI(JComponent c)
static ComponentUI | BasicPopupMenuUI.createUI(JComponent x)
static ComponentUI | BasicMenuUI.createUI(JComponent x)
static ComponentUI | BasicMenuItemUI.createUI(JComponent c)
static ComponentUI | BasicToolBarUI.createUI(JComponent c)
static ComponentUI | BasicMenuBarUI.createUI(JComponent x)
static ComponentUI | BasicToggleButtonUI.createUI(JComponent b)
static ComponentUI | BasicButtonUI.createUI(JComponent c)
static ComponentUI | BasicLabelUI.createUI(JComponent c)
static ComponentUI | BasicRootPaneUI.createUI(JComponent c)
static ComponentUI | BasicPanelUI.createUI(JComponent c)

javax.swing.plaf.metal 中 ComponentUI 的使用

javax.swing.plaf.metal 中 ComponentUI 的子类
class | MetalButtonUI MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalCheckBoxUI MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalDesktopIconUI Metal 桌面图标。
class | MetalFileChooserUI FileChooser 的 Metal L&F 实现。
class | MetalInternalFrameUI JInternalFrame 的 Metal 实现。
class | MetalLabelUI LabelUI 的 Windows L&F 实现。
class | MetalMenuBarUI MenuBarUI 的 Metal 实现。
class | MetalPopupMenuSeparatorUI PopupMenuSeparatorUI 的 Metal L&F 实现。
class | MetalProgressBarUI ProgressBarUI 的 Metal 实现。
class | MetalRadioButtonUI MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalRootPaneUI 提供 RootPaneUI 的 metal 外观实现。
class | MetalScrollBarUI ScrollBarUI 的 Metal 外观实现
class | MetalScrollPaneUI ScrollPaneUI 的 Metal L&F 实现。
class | MetalSeparatorUI SeparatorUI 的 Metal L&F 实现。
class | MetalSliderUI SliderUI 的 Java L&F 实现。
class | MetalSplitPaneUI Metal 分隔窗格。
class | MetalTabbedPaneUI BasicTabbedPaneUI 的 Metal 子类。
class | MetalTextFieldUI JTextField 外观的基础。
class | MetalToggleButtonUI MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalToolBarUI ToolBarUI 的 Metal 外观实现。
class | MetalToolTipUI BasicToolTipUI 的 Metal L&F 扩展。
class | MetalTreeUI TreeUI 的 metal 外观实现。

返回 ComponentUI 的 javax.swing.plaf.metal 中的方法
static ComponentUI | MetalDesktopIconUI.createUI(JComponent c)
static ComponentUI | MetalFileChooserUI.createUI(JComponent c)
static ComponentUI | MetalInternalFrameUI.createUI(JComponent c)
static ComponentUI | MetalToolTipUI.createUI(JComponent c)
static ComponentUI | MetalSliderUI.createUI(JComponent c)
static ComponentUI | MetalSplitPaneUI.createUI(JComponent x) 创建一个新的 MetalSplitPaneUI 实例
static ComponentUI | MetalTreeUI.createUI(JComponent x)
static ComponentUI | MetalProgressBarUI.createUI(JComponent c)
static ComponentUI | MetalCheckBoxUI.createUI(JComponent b)
static ComponentUI | MetalRadioButtonUI.createUI(JComponent c)
static ComponentUI | MetalTabbedPaneUI.createUI(JComponent x)
static ComponentUI | MetalTextFieldUI.createUI(JComponent c)
static ComponentUI | MetalScrollPaneUI.createUI(JComponent x)
static ComponentUI | MetalComboBoxUI.createUI(JComponent c)
static ComponentUI | MetalScrollBarUI.createUI(JComponent c)
static ComponentUI | MetalPopupMenuSeparatorUI.createUI(JComponent c)
static ComponentUI | MetalSeparatorUI.createUI(JComponent c)
static ComponentUI | MetalToolBarUI.createUI(JComponent c)
static ComponentUI | MetalMenuBarUI.createUI(JComponent x) 为传入的组件创建 ComponentUI 实现。
static ComponentUI | MetalToggleButtonUI.createUI(JComponent b)
static ComponentUI | MetalButtonUI.createUI(JComponent c)
static ComponentUI | MetalLabelUI.createUI(JComponent c)
static ComponentUI | MetalRootPaneUI.createUI(JComponent c) 为 JRootPane 创建一个 UI。

javax.swing.plaf.multi 中 ComponentUI 的使用

javax.swing.plaf.multi 中 ComponentUI 的子类
class | MultiButtonUI 用于组合 ButtonUI 的多路 UI。
class | MultiColorChooserUI 用于组合 ColorChooserUI 的多路 UI。
class | MultiComboBoxUI 用于组合 ComboBoxUI 的多路 UI。
class | MultiDesktopIconUI 用于组合 DesktopIconUI 的多路 UI。
class | MultiDesktopPaneUI 用于组合 DesktopPaneUI 的多路 UI。
class | MultiFileChooserUI 用于组合 FileChooserUI 的多路 UI。
class | MultiInternalFrameUI 用于组合 InternalFrameUI 的多路 UI。
class | MultiLabelUI 用于组合 LabelUI 的多路 UI。
class | MultiListUI 用于组合 ListUI 的多路 UI。
class | MultiMenuBarUI 用于组合 MenuBarUI 的多路 UI。
class | MultiMenuItemUI 用于组合 MenuItemUI 的多路 UI。
class | MultiOptionPaneUI 用于组合 OptionPaneUI 的多路 UI。
class | MultiPanelUI 用于组合 PanelUI 的多路 UI。
class | MultiPopupMenuUI 用于组合 PopupMenuUI 的多路 UI。
class | MultiProgressBarUI 用于组合 ProgressBarUI 的多路 UI。
class | MultiRootPaneUI 用于组合 RootPaneUI 的多路 UI。
class | MultiScrollBarUI 用于组合 ScrollBarUI 的多路 UI。
class | MultiScrollPaneUI 用于组合 ScrollPaneUI 的多路 UI。
class | MultiSeparatorUI 用于组合 SeparatorUI 的多路 UI。
class | MultiSliderUI 用于组合 SliderUI 的多路 UI。
class | MultiSpinnerUI 用于组合 SpinnerUI 的多路 UI。
class | MultiSplitPaneUI 用于组合 SplitPaneUI 的多路 UI。
class | MultiTabbedPaneUI 用于组合 TabbedPaneUI 的多路 UI。
class | MultiTableHeaderUI 用于组合 TableHeaderUI 的多路 UI。
class | MultiTableUI 用于组合 TableUI 的多路 UI。
class | MultiTextUI 用于组合 TextUI 的多路 UI。
class | MultiToolBarUI 用于组合 ToolBarUI 的多路 UI。
class | MultiToolTipUI 用于组合 ToolTipUI 的多路 UI。
class | MultiTreeUI 用于组合 TreeUI 的多路 UI。
class | MultiViewportUI 用于组合 ViewportUI 的多路 UI。

返回 ComponentUI 的 javax.swing.plaf.multi 中的方法
static ComponentUI | MultiButtonUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiColorChooserUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiComboBoxUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiDesktopIconUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiDesktopPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiFileChooserUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiInternalFrameUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiLabelUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiListUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiMenuBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiMenuItemUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiOptionPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiPanelUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiPopupMenuUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiProgressBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiRootPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiScrollBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiScrollPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSeparatorUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSliderUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSpinnerUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSplitPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTabbedPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTableHeaderUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTableUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTextUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiToolBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiToolTipUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTreeUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiViewportUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target) 创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
ComponentUI[] | MultiButtonUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiColorChooserUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiComboBoxUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiDesktopIconUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiDesktopPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiFileChooserUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiInternalFrameUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiLabelUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiListUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiMenuBarUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiMenuItemUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiOptionPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiPanelUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiPopupMenuUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiProgressBarUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiRootPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiScrollBarUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiScrollPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiSeparatorUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiSliderUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiSpinnerUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiSplitPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTabbedPaneUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTableHeaderUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTableUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTextUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiToolBarUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiToolTipUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiTreeUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
ComponentUI[] | MultiViewportUI.getUIs() 返回与此多路 UI 关联的 UI 列表。
protected static ComponentUI[] | MultiLookAndFeel.uisToArray(Vector uis) 创建一个数组，使用来自传入向量的 UI 对象填充它并返回该数组。

参数类型为 ComponentUI 的 javax.swing.plaf.multi 中的方法
static ComponentUI MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target)
创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。

javax.swing.plaf.synth 中 ComponentUI 的使用

返回 ComponentUI 的 javax.swing.plaf.synth 中的方法
static ComponentUI SynthLookAndFeel.createUI(JComponent c)
为传入的 JComponent 创建 Synth 外观 ComponentUI。

javax.swing.text 中 ComponentUI 的使用

javax.swing.text 中 ComponentUI 的子类
 class DefaultTextUI
已过时。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.DimensionUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.DimensionUIResource
的使用

没有 javax.swing.plaf.DimensionUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.InsetsUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.InsetsUIResource
的使用

没有 javax.swing.plaf.InsetsUIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.FontUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.FontUIResource
的使用

使用 FontUIResource 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 FontUIResource 的使用

返回 FontUIResource 的 javax.swing.plaf.metal 中的方法
FontUIResource | DefaultMetalTheme.getControlTextFont() 返回控件文本字体。
abstract FontUIResource | MetalTheme.getControlTextFont() 返回控件文本字体。
static FontUIResource | MetalLookAndFeel.getControlTextFont() 返回当前主题的控件文本字体。
FontUIResource | DefaultMetalTheme.getMenuTextFont() 返回菜单文本字体。
abstract FontUIResource | MetalTheme.getMenuTextFont() 返回菜单文本字体。
static FontUIResource | MetalLookAndFeel.getMenuTextFont() 返回当前主题的菜单文本字体。
FontUIResource | DefaultMetalTheme.getSubTextFont() 返回子文本字体。
abstract FontUIResource | MetalTheme.getSubTextFont() 返回子文本字体。
static FontUIResource | MetalLookAndFeel.getSubTextFont() 返回当前主题的子文本字体。
FontUIResource | DefaultMetalTheme.getSystemTextFont() 返回系统文本字体。
abstract FontUIResource | MetalTheme.getSystemTextFont() 返回系统文本字体。
static FontUIResource | MetalLookAndFeel.getSystemTextFont() 返回当前主题的系统文本字体。
FontUIResource | DefaultMetalTheme.getUserTextFont() 返回用户文本字体。
abstract FontUIResource | MetalTheme.getUserTextFont() 返回用户文本字体。
static FontUIResource | MetalLookAndFeel.getUserTextFont() 返回当前主题的用户文本字体。
FontUIResource | DefaultMetalTheme.getWindowTitleFont() 返回窗口标题字体。
abstract FontUIResource | MetalTheme.getWindowTitleFont() 返回窗口标题字体。
static FontUIResource | MetalLookAndFeel.getWindowTitleFont() 返回当前主题的窗口标题字体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.plaf.ColorUIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.plaf.ColorUIResource
的使用

使用 ColorUIResource 的软件包
javax.swing.plaf.metal 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.metal 中 ColorUIResource 的使用

返回 ColorUIResource 的 javax.swing.plaf.metal 中的方法
ColorUIResource | MetalTheme.getAcceleratorForeground() 返回加速器前景色。
static ColorUIResource | MetalLookAndFeel.getAcceleratorForeground() 返回当前主题的加速器前景颜色。
ColorUIResource | MetalTheme.getAcceleratorSelectedForeground() 返回加速器选中前景色。
static ColorUIResource | MetalLookAndFeel.getAcceleratorSelectedForeground() 返回当前主题的加速器选中前景颜色。
protected ColorUIResource | OceanTheme.getBlack() 返回黑色。
protected ColorUIResource | MetalTheme.getBlack() 返回黑色。
static ColorUIResource | MetalLookAndFeel.getBlack() 返回当前主题的黑色。
ColorUIResource | MetalTheme.getControl() 返回控件颜色。
static ColorUIResource | MetalLookAndFeel.getControl() 返回当前主题的控件颜色。
ColorUIResource | MetalTheme.getControlDarkShadow() 返回控件加黑阴影颜色。
static ColorUIResource | MetalLookAndFeel.getControlDarkShadow() 返回当前主题的控件加黑阴影颜色。
ColorUIResource | MetalTheme.getControlDisabled() 返回控件禁用的颜色。
static ColorUIResource | MetalLookAndFeel.getControlDisabled() 返回当前主题的控件禁用颜色。
ColorUIResource | MetalTheme.getControlHighlight() 返回控件高亮显示颜色。
static ColorUIResource | MetalLookAndFeel.getControlHighlight() 返回当前主题的控件高亮显示颜色。
ColorUIResource | MetalTheme.getControlInfo() 返回控件信息颜色。
static ColorUIResource | MetalLookAndFeel.getControlInfo() 返回当前主题的控件信息颜色。
ColorUIResource | MetalTheme.getControlShadow() 返回控件阴影颜色。
static ColorUIResource | MetalLookAndFeel.getControlShadow() 返回当前主题的控件阴影颜色。
ColorUIResource | OceanTheme.getControlTextColor() 返回控件文本颜色。
ColorUIResource | MetalTheme.getControlTextColor() 返回控件文本颜色。
static ColorUIResource | MetalLookAndFeel.getControlTextColor() 返回当前主题的控件文本颜色。
ColorUIResource | OceanTheme.getDesktopColor() 返回桌面颜色。
ColorUIResource | MetalTheme.getDesktopColor() 返回桌面颜色。
static ColorUIResource | MetalLookAndFeel.getDesktopColor() 返回当前主题的桌面颜色。
ColorUIResource | MetalTheme.getFocusColor() 返回焦点颜色。
static ColorUIResource | MetalLookAndFeel.getFocusColor() 返回当前主题的焦点颜色。
ColorUIResource | MetalTheme.getHighlightedTextColor() 返回高亮显示的文本颜色。
static ColorUIResource | MetalLookAndFeel.getHighlightedTextColor() 返回当前主题的加亮文本颜色。
ColorUIResource | OceanTheme.getInactiveControlTextColor() 返回非活动控件文本颜色。
ColorUIResource | MetalTheme.getInactiveControlTextColor() 返回非活动控件文本颜色。
static ColorUIResource | MetalLookAndFeel.getInactiveControlTextColor() 返回当前主题的非活动控件文本颜色。
ColorUIResource | MetalTheme.getInactiveSystemTextColor() 返回非活动系统文本颜色。
static ColorUIResource | MetalLookAndFeel.getInactiveSystemTextColor() 返回当前主题的非活动系统文本颜色。
ColorUIResource | MetalTheme.getMenuBackground() 返回菜单背景色。
static ColorUIResource | MetalLookAndFeel.getMenuBackground() 返回当前主题的菜单背景颜色。
ColorUIResource | OceanTheme.getMenuDisabledForeground() 返回菜单禁用前景色。
ColorUIResource | MetalTheme.getMenuDisabledForeground() 返回菜单禁用前景色。
static ColorUIResource | MetalLookAndFeel.getMenuDisabledForeground() 返回当前主题的菜单禁用前景颜色。
ColorUIResource | MetalTheme.getMenuForeground() 返回菜单前景色。
static ColorUIResource | MetalLookAndFeel.getMenuForeground() 返回当前主题的菜单前景颜色。
ColorUIResource | MetalTheme.getMenuSelectedBackground() 返回菜单选中背景色。
static ColorUIResource | MetalLookAndFeel.getMenuSelectedBackground() 返回当前主题的菜单选中背景颜色。
ColorUIResource | MetalTheme.getMenuSelectedForeground() 返回菜单选中前景色。
static ColorUIResource | MetalLookAndFeel.getMenuSelectedForeground() 返回当前主题的菜单选中前景颜色。
protected ColorUIResource | OceanTheme.getPrimary1() 返回 primary 1 颜色。
protected ColorUIResource | DefaultMetalTheme.getPrimary1() 返回 primary 1 颜色。
protected abstract ColorUIResource | MetalTheme.getPrimary1() 返回 primary 1 颜色。
protected ColorUIResource | OceanTheme.getPrimary2() 返回 primary 2 颜色。
protected ColorUIResource | DefaultMetalTheme.getPrimary2() 返回 primary 2 颜色。
protected abstract ColorUIResource | MetalTheme.getPrimary2() 返回 primary 2 颜色。
protected ColorUIResource | OceanTheme.getPrimary3() 返回 primary 3 颜色。
protected ColorUIResource | DefaultMetalTheme.getPrimary3() 返回 primary 3 颜色。
protected abstract ColorUIResource | MetalTheme.getPrimary3() 返回 primary 3 颜色。
ColorUIResource | MetalTheme.getPrimaryControl() 返回 primary 控件颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControl() 返回当前主题的 primary 控件颜色。
ColorUIResource | MetalTheme.getPrimaryControlDarkShadow() 返回 primary 控件加黑阴影颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControlDarkShadow() 返回当前主题的 primary 控件加黑阴影颜色。
ColorUIResource | MetalTheme.getPrimaryControlHighlight() 返回 primary 控件高亮显示颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControlHighlight() 返回当前主题的 primary 控件高亮显示颜色。
ColorUIResource | MetalTheme.getPrimaryControlInfo() 返回 primary 控件信息颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControlInfo() 返回当前主题的 primary 控件信息颜色。
ColorUIResource | MetalTheme.getPrimaryControlShadow() 返回 primary 控件阴影颜色。
static ColorUIResource | MetalLookAndFeel.getPrimaryControlShadow() 返回当前主题的 primary 控件阴影颜色。
protected ColorUIResource | OceanTheme.getSecondary1() 返回 secondary 1 颜色。
protected ColorUIResource | DefaultMetalTheme.getSecondary1() 返回 secondary 1 颜色。
protected abstract ColorUIResource | MetalTheme.getSecondary1() 返回 secondary 1 颜色。
protected ColorUIResource | OceanTheme.getSecondary2() 返回 secondary 2 颜色。
protected ColorUIResource | DefaultMetalTheme.getSecondary2() 返回 secondary 2 颜色。
protected abstract ColorUIResource | MetalTheme.getSecondary2() 返回 secondary 2 颜色。
protected ColorUIResource | OceanTheme.getSecondary3() 返回 secondary 3 颜色。
protected ColorUIResource | DefaultMetalTheme.getSecondary3() 返回 secondary 3 颜色。
protected abstract ColorUIResource | MetalTheme.getSecondary3() 返回 secondary 3 颜色。
ColorUIResource | MetalTheme.getSeparatorBackground() 返回分隔符背景色。
static ColorUIResource | MetalLookAndFeel.getSeparatorBackground() 返回当前主题的分隔符背景颜色。
ColorUIResource | MetalTheme.getSeparatorForeground() 返回分隔符前景色。
static ColorUIResource | MetalLookAndFeel.getSeparatorForeground() 返回当前主题的分隔符前景颜色。
ColorUIResource | MetalTheme.getSystemTextColor() 返回系统文本颜色。
static ColorUIResource | MetalLookAndFeel.getSystemTextColor() 返回当前主题的系统文本颜色。
ColorUIResource | MetalTheme.getTextHighlightColor() 返回文本高亮显示的颜色。
static ColorUIResource | MetalLookAndFeel.getTextHighlightColor() 返回当前主题的文本高亮显示颜色。
ColorUIResource | MetalTheme.getUserTextColor() 返回用户文本颜色。
static ColorUIResource | MetalLookAndFeel.getUserTextColor() 返回当前主题的用户文本颜色。
protected ColorUIResource | MetalTheme.getWhite() 返回白色。
static ColorUIResource | MetalLookAndFeel.getWhite() 返回当前主题的白色。
ColorUIResource | MetalTheme.getWindowBackground() 返回窗口背景色。
static ColorUIResource | MetalLookAndFeel.getWindowBackground() 返回当前主题的窗口背景颜色。
ColorUIResource | MetalTheme.getWindowTitleBackground() 返回窗口标题背景色。
static ColorUIResource | MetalLookAndFeel.getWindowTitleBackground() 返回当前主题的窗口标题背景颜色。
ColorUIResource | MetalTheme.getWindowTitleForeground() 返回窗口标题前景色。
static ColorUIResource | MetalLookAndFeel.getWindowTitleForeground() 返回当前主题的窗口标题前景色。
ColorUIResource | MetalTheme.getWindowTitleInactiveBackground() 返回窗口标题非活动背景色。
static ColorUIResource | MetalLookAndFeel.getWindowTitleInactiveBackground() 返回当前主题的窗口标题非活动背景颜色。
ColorUIResource | MetalTheme.getWindowTitleInactiveForeground() 返回窗口标题非活动前景色。
static ColorUIResource | MetalLookAndFeel.getWindowTitleInactiveForeground() 返回当前主题的窗口标题非活动前景颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.plaf.UIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.plaf.UIResource
的使用

使用 UIResource 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 UIResource 的使用

实现 UIResource 的 javax.swing 中的类
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
static class | ScrollPaneLayout.UIResource ScrollPaneLayout 的 UI 资源版本。

javax.swing.plaf 中 UIResource 的使用

实现 UIResource 的 javax.swing.plaf 中的类
class | ActionMapUIResource 实现 UIResource 的 javax.swing.ActionMap 的子类。
class | BorderUIResource
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource
class | ColorUIResource
class | ComponentInputMapUIResource 实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
class | DimensionUIResource
class | FontUIResource 实现 UIResource 的 java.awt.Font 的子类。
class | IconUIResource 实现 UIResource 的 Icon 包装类。
class | InputMapUIResource 实现 UIResource 的 javax.swing.InputMap 的子类。
class | InsetsUIResource

javax.swing.plaf.basic 中 UIResource 的使用

实现 UIResource 的 javax.swing.plaf.basic 中的类
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.SplitPaneBorder 绘制围绕拆分窗格的边框。
static class | BasicBorders.ToggleButtonBorder
static class | BasicComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的子类。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
static class | BasicTextUI.BasicCaret
static class | BasicTextUI.BasicHighlighter
class | DefaultMenuLayout Popup 菜单和菜单栏的默认布局管理器。

javax.swing.plaf.metal 中 UIResource 的使用

实现 UIResource 的 javax.swing.plaf.metal 中的类
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder
class | MetalCheckBoxIcon OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。
static class | MetalIconFactory.PaletteCloseIcon 定义一个用于 Palette 关闭的图标

javax.swing.table 中 UIResource 的使用

实现 UIResource 的 javax.swing.table 中的类
static class DefaultTableCellRenderer.UIResource
DefaultTableCellRenderer 的一个子类，它实现 UIResource。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.AbstractSpinnerModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractSpinnerModel
的使用

使用 AbstractSpinnerModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AbstractSpinnerModel 的使用

javax.swing 中 AbstractSpinnerModel 的子类
class | SpinnerDateModel Date 序列的一个 SpinnerModel。
class | SpinnerListModel 其值由数组或 List 定义的 SpinnerModel 的简单实现。
class | SpinnerNumberModel 用于数字序列的 SpinnerModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DebugGraphics 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DebugGraphics
的使用

没有 javax.swing.DebugGraphics 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultDesktopManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultDesktopManager
的使用

没有 javax.swing.DefaultDesktopManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultFocusManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultFocusManager
的使用

没有 javax.swing.DefaultFocusManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultRowSorter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultRowSorter
的使用

使用 DefaultRowSorter 的软件包
javax.swing.table 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.table 中 DefaultRowSorter 的使用

javax.swing.table 中 DefaultRowSorter 的子类
 class TableRowSorter<M extends TableModel>
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultRowSorter.ModelWrapper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultRowSorter.ModelWrapper
的使用

使用 DefaultRowSorter.ModelWrapper 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultRowSorter.ModelWrapper 的使用

返回 DefaultRowSorter.ModelWrapper 的 javax.swing 中的方法
protected  DefaultRowSorter.ModelWrapper<M,I> DefaultRowSorter.getModelWrapper()
返回模型包装器，它提供将要进行排序和过滤的数据。

参数类型为 DefaultRowSorter.ModelWrapper 的 javax.swing 中的方法
protected  void DefaultRowSorter.setModelWrapper(DefaultRowSorter.ModelWrapper<M,I> modelWrapper)
设置模型包装器，它提供将要进行排序和过滤的数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.DesktopManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.DesktopManager
的使用

使用 DesktopManager 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 DesktopManager 的使用

实现 DesktopManager 的 javax.swing 中的类
 class DefaultDesktopManager
此类是 DesktopManager 的实现。

返回 DesktopManager 的 javax.swing 中的方法
 DesktopManager JDesktopPane.getDesktopManager()
返回处理特定于桌面 UI 操作的 DesktopManger。

参数类型为 DesktopManager 的 javax.swing 中的方法
 void JDesktopPane.setDesktopManager(DesktopManager d)
设置处理特定于桌面 UI 操作的 DesktopManger。

javax.swing.plaf.basic 中 DesktopManager 的使用

声明为 DesktopManager 的 javax.swing.plaf.basic 中的字段
protected  DesktopManager BasicDesktopPaneUI.desktopManager

返回 DesktopManager 的 javax.swing.plaf.basic 中的方法
protected DesktopManager | BasicInternalFrameUI.createDesktopManager()
protected DesktopManager | BasicInternalFrameUI.getDesktopManager() 返回适当的 DesktopManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.FocusManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.FocusManager
的使用

使用 FocusManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 FocusManager 的使用

javax.swing 中 FocusManager 的子类
 class DefaultFocusManager
此类已被废弃，用 1.4 focus API 取代。

返回 FocusManager 的 javax.swing 中的方法
static FocusManager FocusManager.getCurrentManager()
返回调用线程上下文的当前 KeyboardFocusManager 实例。

参数类型为 FocusManager 的 javax.swing 中的方法
static void FocusManager.setCurrentManager(FocusManager aFocusManager)
设置调用线程上下文的当前 KeyboardFocusManager 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.GroupLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout
的使用

没有 javax.swing.GroupLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.GroupLayout.Alignment 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout.Alignment
的使用

使用 GroupLayout.Alignment 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 GroupLayout.Alignment 的使用

返回 GroupLayout.Alignment 的 javax.swing 中的方法
static GroupLayout.Alignment | GroupLayout.Alignment.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static GroupLayout.Alignment[] | GroupLayout.Alignment.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 GroupLayout.Alignment 的 javax.swing 中的方法
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment) 使用指定的对齐方式将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max) 使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group) 使用指定的对齐方式将 Group 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup(GroupLayout.Alignment alignment) 使用指定的对齐方式创建并返回一个 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup(GroupLayout.Alignment alignment, boolean resizable) 使用指定的对齐方式和调整大小行为创建并返回一个 ParallelGroup。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.GroupLayout.Group 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout.Group
的使用

使用 GroupLayout.Group 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 GroupLayout.Group 的使用

javax.swing 中 GroupLayout.Group 的子类
class | GroupLayout.ParallelGroup 一个 Group，它对齐其子元素并确定其大小。
class | GroupLayout.SequentialGroup 一个 Group，它按顺序一个接一个地确定其元素的位置和大小。

返回 GroupLayout.Group 的 javax.swing 中的方法
GroupLayout.Group | GroupLayout.Group.addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.Group | GroupLayout.Group.addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.Group | GroupLayout.Group.addGap(int size) 将固定间隙添加到此 Group。
GroupLayout.Group | GroupLayout.Group.addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.Group | GroupLayout.Group.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。

参数类型为 GroupLayout.Group 的 javax.swing 中的方法
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGroup(boolean useAsBaseline, GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group) 使用指定的对齐方式将 Group 添加到此 ParallelGroup。
GroupLayout.Group | GroupLayout.Group.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
void | GroupLayout.setHorizontalGroup(GroupLayout.Group group) 设置沿水平轴确定组件位置和大小的 Group。
void | GroupLayout.setVerticalGroup(GroupLayout.Group group) 设置沿垂直轴确定组件位置和大小的 Group。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.GroupLayout.SequentialGroup 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout.SequentialGroup
的使用

使用 GroupLayout.SequentialGroup 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 GroupLayout.SequentialGroup 的使用

返回 GroupLayout.SequentialGroup 的 javax.swing 中的方法
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component) 将 Component 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addContainerGap() 添加一个表示容器边缘和触到容器边框的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addContainerGap(int pref, int max) 使用指定大小添加一个元素，它表示容器的一个边缘和下一个或前一个 Component 之间的首选间隙。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGap(int size) 将固定间隙添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGroup(boolean useAsBaseline, GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type) 添加一个表示两个距离最近的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个距离最近的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.createSequentialGroup() 创建并返回一个 SequentialGroup。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.GroupLayout.ParallelGroup 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GroupLayout.ParallelGroup
的使用

使用 GroupLayout.ParallelGroup 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 GroupLayout.ParallelGroup 的使用

返回 GroupLayout.ParallelGroup 的 javax.swing 中的方法
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment) 使用指定的对齐方式将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max) 使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGap(int pref) 将固定间隙添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group) 使用指定的对齐方式将 Group 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.ParallelGroup.addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.ParallelGroup | GroupLayout.createBaselineGroup(boolean resizable, boolean anchorBaselineToTop) 创建并返回一个沿基线对齐其元素的 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup() 使用 Alignment.LEADING 的对齐方式创建并返回一个 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup(GroupLayout.Alignment alignment) 使用指定的对齐方式创建并返回一个 ParallelGroup。
GroupLayout.ParallelGroup | GroupLayout.createParallelGroup(GroupLayout.Alignment alignment, boolean resizable) 使用指定的对齐方式和调整大小行为创建并返回一个 ParallelGroup。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.InputVerifier 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.InputVerifier
的使用

使用 InputVerifier 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 InputVerifier 的使用

返回 InputVerifier 的 javax.swing 中的方法
 InputVerifier JComponent.getInputVerifier()
返回此组件的输入校验器。

参数类型为 InputVerifier 的 javax.swing 中的方法
 void JComponent.setInputVerifier(InputVerifier inputVerifier)
设置此组件的输入校验器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JColorChooser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JColorChooser
的使用

使用 JColorChooser 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JColorChooser 的使用

参数类型为 JColorChooser 的 javax.swing 中的方法
static JDialog JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。

javax.swing.colorchooser 中 JColorChooser 的使用

参数类型为 JColorChooser 的 javax.swing.colorchooser 中的方法
void | AbstractColorChooserPanel.installChooserPanel(JColorChooser enclosingChooser) 将面板添加到选取器时被调用。
void | AbstractColorChooserPanel.uninstallChooserPanel(JColorChooser enclosingChooser) 从选取器中移除面板时被调用。

javax.swing.plaf.basic 中 JColorChooser 的使用

声明为 JColorChooser 的 javax.swing.plaf.basic 中的字段
protected  JColorChooser BasicColorChooserUI.chooser
在其上安装此 BasicColorChooserUI 的 JColorChooser。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JColorChooser.AccessibleJColorChooser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JColorChooser.AccessibleJColorChooser
的使用

没有 javax.swing.JColorChooser.AccessibleJColorChooser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JDesktopPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JDesktopPane
的使用

使用 JDesktopPane 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JDesktopPane 的使用

返回 JDesktopPane 的 javax.swing 中的方法
JDesktopPane | JInternalFrame.getDesktopPane() 在祖先层次结构中搜索 JDesktop 实例的便捷方法。
JDesktopPane | JInternalFrame.JDesktopIcon.getDesktopPane() 询问该图标所属的 Desktop 对象的便捷方法。
static JDesktopPane | JOptionPane.getDesktopPaneForComponent(Component parentComponent) 返回指定组件的桌面窗格。

javax.swing.plaf.basic 中 JDesktopPane 的使用

声明为 JDesktopPane 的 javax.swing.plaf.basic 中的字段
protected  JDesktopPane BasicDesktopPaneUI.desktop

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JDesktopPane.AccessibleJDesktopPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JDesktopPane.AccessibleJDesktopPane
的使用

没有 javax.swing.JDesktopPane.AccessibleJDesktopPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JEditorPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane
的使用

使用 JEditorPane 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JEditorPane 的使用

javax.swing 中 JEditorPane 的子类
 class JTextPane
可以用以图形方式表示的属性来标记的文本组件。

javax.swing.text 中 JEditorPane 的使用

返回 JEditorPane 的 javax.swing.text 中的方法
protected  JEditorPane StyledEditorKit.StyledTextAction.getEditor(ActionEvent e)
获得操作的目标编辑器。

参数类型为 JEditorPane 的 javax.swing.text 中的方法
void | StyledEditorKit.deinstall(JEditorPane c) 工具包从 JEditorPane 移除时调用。
void | EditorKit.deinstall(JEditorPane c) 从 JEditorPane 中移除工具包时调用。
protected StyledDocument | StyledEditorKit.StyledTextAction.getStyledDocument(JEditorPane e) 获取与编辑器窗格相关的文档。
protected StyledEditorKit | StyledEditorKit.StyledTextAction.getStyledEditorKit(JEditorPane e) 获取与编辑器窗格相关的编辑器工具包。
void | StyledEditorKit.install(JEditorPane c) 工具包安装到 JEditorPane 时调用。
void | EditorKit.install(JEditorPane c) 将工具包安装到 JEditorPane 中时调用。
protected void | StyledEditorKit.StyledTextAction.setCharacterAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对字符内容应用给定的属性。
protected void | StyledEditorKit.StyledTextAction.setParagraphAttributes(JEditorPane editor, AttributeSet attr, boolean replace) 对段落应用给定的属性。

javax.swing.text.html 中 JEditorPane 的使用

参数类型为 JEditorPane 的 javax.swing.text.html 中的方法
protected void | HTMLEditorKit.LinkController.activateLink(int pos, JEditorPane editor) 如果给定位置表示一个链接，则调用关联 JEditorPane 上的 linkActivated。
void | HTMLEditorKit.deinstall(JEditorPane c) 工具包从 JEditorPane 移除时调用。
protected HTMLDocument | HTMLEditorKit.HTMLTextAction.getHTMLDocument(JEditorPane e)
protected HTMLEditorKit | HTMLEditorKit.HTMLTextAction.getHTMLEditorKit(JEditorPane e)
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 当在边界上插入时调用。
protected void | HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag) 已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
protected void | HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag) HTMLEditorKit.insertHTML 的一个覆盖。
void | HTMLEditorKit.install(JEditorPane c) 将工具包安装到 JEditorPane 中时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JEditorPane.AccessibleJEditorPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane.AccessibleJEditorPane
的使用

使用 JEditorPane.AccessibleJEditorPane 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JEditorPane.AccessibleJEditorPane 的使用

javax.swing 中 JEditorPane.AccessibleJEditorPane 的子类
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML
的使用

没有 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport
的使用

没有 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
的使用

没有 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JFileChooser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFileChooser
的使用

使用 JFileChooser 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf 中 JFileChooser 的使用

参数类型为 JFileChooser 的 javax.swing.plaf 中的方法
abstract void | FileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
abstract FileFilter | FileChooserUI.getAcceptAllFileFilter(JFileChooser fc)
abstract String | FileChooserUI.getApproveButtonText(JFileChooser fc)
abstract String | FileChooserUI.getDialogTitle(JFileChooser fc)
abstract FileView | FileChooserUI.getFileView(JFileChooser fc)
abstract void | FileChooserUI.rescanCurrentDirectory(JFileChooser fc)

javax.swing.plaf.basic 中 JFileChooser 的使用

返回 JFileChooser 的 javax.swing.plaf.basic 中的方法
 JFileChooser BasicFileChooserUI.getFileChooser()

参数类型为 JFileChooser 的 javax.swing.plaf.basic 中的方法
protected MouseListener | BasicFileChooserUI.createDoubleClickListener(JFileChooser fc, JList list)
ListSelectionListener | BasicFileChooserUI.createListSelectionListener(JFileChooser fc)
PropertyChangeListener | BasicFileChooserUI.createPropertyChangeListener(JFileChooser fc)
void | BasicFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
FileFilter | BasicFileChooserUI.getAcceptAllFileFilter(JFileChooser fc) 返回默认接受所有文件过滤器
protected JButton | BasicFileChooserUI.getApproveButton(JFileChooser fc)
int | BasicFileChooserUI.getApproveButtonMnemonic(JFileChooser fc)
String | BasicFileChooserUI.getApproveButtonText(JFileChooser fc)
String | BasicFileChooserUI.getApproveButtonToolTipText(JFileChooser fc)
String | BasicFileChooserUI.getDialogTitle(JFileChooser fc) 返回此对话框的标题
FileView | BasicFileChooserUI.getFileView(JFileChooser fc)
void | BasicFileChooserUI.installComponents(JFileChooser fc)
protected void | BasicFileChooserUI.installDefaults(JFileChooser fc)
protected void | BasicFileChooserUI.installIcons(JFileChooser fc)
protected void | BasicFileChooserUI.installListeners(JFileChooser fc)
protected void | BasicFileChooserUI.installStrings(JFileChooser fc)
void | BasicFileChooserUI.rescanCurrentDirectory(JFileChooser fc)
void | BasicFileChooserUI.uninstallComponents(JFileChooser fc)
protected void | BasicFileChooserUI.uninstallDefaults(JFileChooser fc)
protected void | BasicFileChooserUI.uninstallIcons(JFileChooser fc)
protected void | BasicFileChooserUI.uninstallListeners(JFileChooser fc)
protected void | BasicFileChooserUI.uninstallStrings(JFileChooser fc)

参数类型为 JFileChooser 的 javax.swing.plaf.basic 中的构造方法
BasicDirectoryModel(JFileChooser filechooser)
BasicFileChooserUI(JFileChooser b)

javax.swing.plaf.metal 中 JFileChooser 的使用

参数类型为 JFileChooser 的 javax.swing.plaf.metal 中的方法
protected JPanel | MetalFileChooserUI.createDetailsView(JFileChooser fc)
protected MetalFileChooserUI.DirectoryComboBoxModel | MetalFileChooserUI.createDirectoryComboBoxModel(JFileChooser fc)
protected javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxRenderer | MetalFileChooserUI.createDirectoryComboBoxRenderer(JFileChooser fc)
protected JPanel | MetalFileChooserUI.createList(JFileChooser fc)
ListSelectionListener | MetalFileChooserUI.createListSelectionListener(JFileChooser fc) 创建一个用于文件和目录列表的选择侦听器。
PropertyChangeListener | MetalFileChooserUI.createPropertyChangeListener(JFileChooser fc)
void | MetalFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
protected JButton | MetalFileChooserUI.getApproveButton(JFileChooser fc)
void | MetalFileChooserUI.installComponents(JFileChooser fc)
protected void | MetalFileChooserUI.installListeners(JFileChooser fc)
protected void | MetalFileChooserUI.installStrings(JFileChooser fc)
void | MetalFileChooserUI.rescanCurrentDirectory(JFileChooser fc)
void | MetalFileChooserUI.uninstallComponents(JFileChooser fc)

参数类型为 JFileChooser 的 javax.swing.plaf.metal 中的构造方法
MetalFileChooserUI(JFileChooser filechooser)

javax.swing.plaf.multi 中 JFileChooser 的使用

参数类型为 JFileChooser 的 javax.swing.plaf.multi 中的方法
void | MultiFileChooserUI.ensureFileIsVisible(JFileChooser a, File b) 在由此对象处理的每个 UI 上调用 ensureFileIsVisible 方法。
FileFilter | MultiFileChooserUI.getAcceptAllFileFilter(JFileChooser a) 在由此对象处理的每个 UI 上调用 getAcceptAllFileFilter 方法。
String | MultiFileChooserUI.getApproveButtonText(JFileChooser a) 在由此对象处理的每个 UI 上调用 getApproveButtonText 方法。
String | MultiFileChooserUI.getDialogTitle(JFileChooser a) 在由此对象处理的每个 UI 上调用 getDialogTitle 方法。
FileView | MultiFileChooserUI.getFileView(JFileChooser a) 在由此对象处理的每个 UI 上调用 getFileView 方法。
void | MultiFileChooserUI.rescanCurrentDirectory(JFileChooser a) 在由此对象处理的每个 UI 上调用 rescanCurrentDirectory 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JFileChooser.AccessibleJFileChooser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFileChooser.AccessibleJFileChooser
的使用

没有 javax.swing.JFileChooser.AccessibleJFileChooser 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JFormattedTextField 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFormattedTextField
的使用

使用 JFormattedTextField 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JFormattedTextField 的使用

返回 JFormattedTextField 的 javax.swing 中的方法
protected JFormattedTextField | JFormattedTextField.AbstractFormatter.getFormattedTextField() 返回 AbstractFormatter 所安装到的当前 JFormattedTextField。
JFormattedTextField | JSpinner.DefaultEditor.getTextField() 返回此编辑器的子 JFormattedTextField。

参数类型为 JFormattedTextField 的 javax.swing 中的方法
abstract JFormattedTextField.AbstractFormatter | JFormattedTextField.AbstractFormatterFactory.getFormatter(JFormattedTextField tf) 返回一个 AbstractFormatter，它对传入的 JFormattedTextField 进行格式化。
void | JFormattedTextField.AbstractFormatter.install(JFormattedTextField ftf) 将 AbstractFormatter 安装到特定的 JFormattedTextField。

javax.swing.text 中 JFormattedTextField 的使用

参数类型为 JFormattedTextField 的 javax.swing.text 中的方法
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getFormatter(JFormattedTextField source) 根据 JFormattedTextField 的状态返回默认的 formatter、显示 formatter、编辑器 formatter 或 null formatter。
void | DefaultFormatter.install(JFormattedTextField ftf) 将 DefaultFormatter 安装到特定的 JFormattedTextField。
void | InternationalFormatter.install(JFormattedTextField ftf) 将 DefaultFormatter 安装到特定的 JFormattedTextField 上。
void | MaskFormatter.install(JFormattedTextField ftf) 将 DefaultFormatter 安装在特定的 JFormattedTextField 上。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JFormattedTextField.AbstractFormatterFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFormattedTextField.AbstractFormatterFactory
的使用

使用 JFormattedTextField.AbstractFormatterFactory 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JFormattedTextField.AbstractFormatterFactory 的使用

返回 JFormattedTextField.AbstractFormatterFactory 的 javax.swing 中的方法
 JFormattedTextField.AbstractFormatterFactory JFormattedTextField.getFormatterFactory()
返回当前的 AbstractFormatterFactory。

参数类型为 JFormattedTextField.AbstractFormatterFactory 的 javax.swing 中的方法
 void JFormattedTextField.setFormatterFactory(JFormattedTextField.AbstractFormatterFactory tf)
设置 AbstractFormatterFactory。

参数类型为 JFormattedTextField.AbstractFormatterFactory 的 javax.swing 中的构造方法
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory)
创建一个具有指定 AbstractFormatterFactory 的 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory, Object currentValue)
创建一个具有指定 AbstractFormatterFactory 和初始值的 JFormattedTextField。

javax.swing.text 中 JFormattedTextField.AbstractFormatterFactory 的使用

javax.swing.text 中 JFormattedTextField.AbstractFormatterFactory 的子类
 class DefaultFormatterFactory
JFormattedTextField.AbstractFormatterFactory 的一个实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JFormattedTextField.AbstractFormatter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFormattedTextField.AbstractFormatter
的使用

使用 JFormattedTextField.AbstractFormatter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JFormattedTextField.AbstractFormatter 的使用

返回 JFormattedTextField.AbstractFormatter 的 javax.swing 中的方法
JFormattedTextField.AbstractFormatter | JFormattedTextField.getFormatter() 返回用于格式化和分析当前值的 AbstractFormatter。
abstract JFormattedTextField.AbstractFormatter | JFormattedTextField.AbstractFormatterFactory.getFormatter(JFormattedTextField tf) 返回一个 AbstractFormatter，它对传入的 JFormattedTextField 进行格式化。

参数类型为 JFormattedTextField.AbstractFormatter 的 javax.swing 中的方法
protected  void JFormattedTextField.setFormatter(JFormattedTextField.AbstractFormatter format)
设置当前的 AbstractFormatter。

参数类型为 JFormattedTextField.AbstractFormatter 的 javax.swing 中的构造方法
JFormattedTextField(JFormattedTextField.AbstractFormatter formatter)
创建一个具有指定 AbstractFormatter 的 JFormattedTextField。

javax.swing.text 中 JFormattedTextField.AbstractFormatter 的使用

javax.swing.text 中 JFormattedTextField.AbstractFormatter 的子类
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | DefaultFormatter DefaultFormatter 格式化任意对象。
class | InternationalFormatter InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
class | MaskFormatter MaskFormatter 用于格式化和编辑字符串。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。

返回 JFormattedTextField.AbstractFormatter 的 javax.swing.text 中的方法
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getDefaultFormatter() 返回供最后选择使用的 JFormattedTextField.AbstractFormatter，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getDisplayFormatter() 返回在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getEditFormatter() 返回在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getFormatter(JFormattedTextField source) 根据 JFormattedTextField 的状态返回默认的 formatter、显示 formatter、编辑器 formatter 或 null formatter。
JFormattedTextField.AbstractFormatter | DefaultFormatterFactory.getNullFormatter() 返回值为 null 时使用的 formatter。

参数类型为 JFormattedTextField.AbstractFormatter 的 javax.swing.text 中的方法
void | DefaultFormatterFactory.setDefaultFormatter(JFormattedTextField.AbstractFormatter atf) 设置 JFormattedTextField.AbstractFormatter 供最后选择使用，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
void | DefaultFormatterFactory.setDisplayFormatter(JFormattedTextField.AbstractFormatter atf) 设置在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
void | DefaultFormatterFactory.setEditFormatter(JFormattedTextField.AbstractFormatter atf) 设置在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
void | DefaultFormatterFactory.setNullFormatter(JFormattedTextField.AbstractFormatter atf) 设置在 JFormattedTextField 值为 null 时使用的 formatter。

参数类型为 JFormattedTextField.AbstractFormatter 的 javax.swing.text 中的构造方法
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter defaultFormat, JFormattedTextField.AbstractFormatter displayFormat, JFormattedTextField.AbstractFormatter editFormat, JFormattedTextField.AbstractFormatter nullFormat)
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JOptionPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JOptionPane
的使用

使用 JOptionPane 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf 中 JOptionPane 的使用

参数类型为 JOptionPane 的 javax.swing.plaf 中的方法
abstract boolean | OptionPaneUI.containsCustomComponents(JOptionPane op) 如果用户已经为选项或消息提供 Component 实例，则返回 true。
abstract void | OptionPaneUI.selectInitialValue(JOptionPane op) 请求表示默认值的组件拥有焦点。

javax.swing.plaf.basic 中 JOptionPane 的使用

声明为 JOptionPane 的 javax.swing.plaf.basic 中的字段
protected  JOptionPane BasicOptionPaneUI.optionPane
接收者为其提供外观的 JOptionPane。

参数类型为 JOptionPane 的 javax.swing.plaf.basic 中的方法
boolean | BasicOptionPaneUI.containsCustomComponents(JOptionPane op) 如果在上一次对 validateComponent 的调用中消息或按钮包含 Component 的子类，则返回 true。
void | BasicOptionPaneUI.selectInitialValue(JOptionPane op) 如果 inputComponent 为非 null，则请求焦点位于其上；否则请求焦点位于默认值上

javax.swing.plaf.multi 中 JOptionPane 的使用

参数类型为 JOptionPane 的 javax.swing.plaf.multi 中的方法
boolean | MultiOptionPaneUI.containsCustomComponents(JOptionPane a) 在由此对象处理的每个 UI 上调用 containsCustomComponents 方法。
void | MultiOptionPaneUI.selectInitialValue(JOptionPane a) 在由此对象处理的每个 UI 上调用 selectInitialValue 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JOptionPane.AccessibleJOptionPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JOptionPane.AccessibleJOptionPane
的使用

没有 javax.swing.JOptionPane.AccessibleJOptionPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JPasswordField 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPasswordField
的使用

没有 javax.swing.JPasswordField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JPasswordField.AccessibleJPasswordField 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPasswordField.AccessibleJPasswordField
的使用

没有 javax.swing.JPasswordField.AccessibleJPasswordField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSpinner 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner
的使用

使用 JSpinner 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JSpinner 的使用

返回 JSpinner 的 javax.swing 中的方法
 JSpinner JSpinner.DefaultEditor.getSpinner()
如果此编辑器的 JSpinner 祖先，如果祖先都不为 JSpinner，则返回 null。

参数类型为 JSpinner 的 javax.swing 中的方法
 void JSpinner.DefaultEditor.dismiss(JSpinner spinner)
将此编辑器从指定的 JSpinner 断开连接。

参数类型为 JSpinner 的 javax.swing 中的构造方法
JSpinner.DateEditor(JSpinner spinner)
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DateEditor(JSpinner spinner, String dateFormatPattern)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DefaultEditor(JSpinner spinner)
构造一个针对指定 JSpinner 的编辑器组件。
JSpinner.ListEditor(JSpinner spinner)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerListModel 的值的显示和编辑。
JSpinner.NumberEditor(JSpinner spinner)
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerNumberModel 值的显示和编辑。
JSpinner.NumberEditor(JSpinner spinner, String decimalFormatPattern)
构造一个 JSpinner，使其支持具有一个 JFormattedTextField 的 SpinnerNumberModel 的值。

javax.swing.plaf.basic 中 JSpinner 的使用

声明为 JSpinner 的 javax.swing.plaf.basic 中的字段
protected  JSpinner BasicSpinnerUI.spinner
作为 UI 委托的 spinner。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSpinner.DefaultEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.DefaultEditor
的使用

使用 JSpinner.DefaultEditor 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JSpinner.DefaultEditor 的使用

javax.swing 中 JSpinner.DefaultEditor 的子类
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSpinner.DateEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.DateEditor
的使用

没有 javax.swing.JSpinner.DateEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSpinner.NumberEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.NumberEditor
的使用

没有 javax.swing.JSpinner.NumberEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSpinner.ListEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.ListEditor
的使用

没有 javax.swing.JSpinner.ListEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTextPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextPane
的使用

没有 javax.swing.JTextPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSpinner.AccessibleJSpinner 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSpinner.AccessibleJSpinner
的使用

没有 javax.swing.JSpinner.AccessibleJSpinner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.LayoutStyle 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.LayoutStyle
的使用

使用 LayoutStyle 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 LayoutStyle 的使用

返回 LayoutStyle 的 javax.swing 中的方法
static LayoutStyle | LayoutStyle.getInstance() 返回 LayoutStyle 的共享实例。
LayoutStyle | GroupLayout.getLayoutStyle() 返回 LayoutStyle，用于计算组件之间的首选间隙。
LayoutStyle | LookAndFeel.getLayoutStyle() 返回此外观的 LayoutStyle。

参数类型为 LayoutStyle 的 javax.swing 中的方法
static void | LayoutStyle.setInstance(LayoutStyle style) 设置 LayoutStyle 的共享实例。
void | GroupLayout.setLayoutStyle(LayoutStyle layoutStyle) 设置用于计算组件之间首选间隙的 LayoutStyle。

javax.swing.plaf.metal 中 LayoutStyle 的使用

返回 LayoutStyle 的 javax.swing.plaf.metal 中的方法
 LayoutStyle MetalLookAndFeel.getLayoutStyle()
返回一个 LayoutStyle，它实现 http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html 中指定的 Java 外观设计原则。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.LayoutStyle.ComponentPlacement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.LayoutStyle.ComponentPlacement
的使用

使用 LayoutStyle.ComponentPlacement 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 LayoutStyle.ComponentPlacement 的使用

返回 LayoutStyle.ComponentPlacement 的 javax.swing 中的方法
static LayoutStyle.ComponentPlacement | LayoutStyle.ComponentPlacement.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static LayoutStyle.ComponentPlacement[] | LayoutStyle.ComponentPlacement.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 LayoutStyle.ComponentPlacement 的 javax.swing 中的方法
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type) 添加一个表示两个距离最近的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | GroupLayout.SequentialGroup.addPreferredGap(LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个距离最近的组件之间首选间隙的元素。
abstract int | LayoutStyle.getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent) 返回两个组件之间使用的空格的数量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.OverlayLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.OverlayLayout
的使用

没有 javax.swing.OverlayLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.Popup 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Popup
的使用

使用 Popup 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 Popup 的使用

返回 Popup 的 javax.swing 中的方法
 Popup PopupFactory.getPopup(Component owner, Component contents, int x, int y)
为包含 Component contents 的 Component owner 创建 Popup。

javax.swing.plaf 中 Popup 的使用

返回 Popup 的 javax.swing.plaf 中的方法
 Popup PopupMenuUI.getPopup(JPopupMenu popup, int x, int y)
返回将负责显示 JPopupMenu 的 Popup。

javax.swing.plaf.multi 中 Popup 的使用

返回 Popup 的 javax.swing.plaf.multi 中的方法
 Popup MultiPopupMenuUI.getPopup(JPopupMenu a, int b, int c)
在由此对象处理的每个 UI 上调用 getPopup 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.PopupFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.PopupFactory
的使用

使用 PopupFactory 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 PopupFactory 的使用

返回 PopupFactory 的 javax.swing 中的方法
static PopupFactory PopupFactory.getSharedInstance()
返回共享 PopupFactory，它可用于获取 Popup。

参数类型为 PopupFactory 的 javax.swing 中的方法
static void PopupFactory.setSharedInstance(PopupFactory factory)
设置用于获取 Popup 的 PopupFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ProgressMonitor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ProgressMonitor
的使用

使用 ProgressMonitor 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ProgressMonitor 的使用

返回 ProgressMonitor 的 javax.swing 中的方法
 ProgressMonitor ProgressMonitorInputStream.getProgressMonitor()
获取此流使用的 ProgressMonitor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ProgressMonitor.AccessibleProgressMonitor
的使用

没有 javax.swing.ProgressMonitor.AccessibleProgressMonitor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ProgressMonitorInputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ProgressMonitorInputStream
的使用

没有 javax.swing.ProgressMonitorInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.Renderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.Renderer
的使用

没有 javax.swing.Renderer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.RowFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowFilter
的使用

使用 RowFilter 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowFilter 的使用

返回 RowFilter 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。
 RowFilter<? super M,? super I> DefaultRowSorter.getRowFilter()
返回用于确定哪些行（如果有）应该在视图中隐藏的过滤器。
static
<M,I> RowFilter<M,I>
RowFilter.notFilter(RowFilter<M,I> filter)
返回一个 RowFilter，它包含提供的过滤器不包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。
static
<M,I> RowFilter<M,I>
RowFilter.orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.regexFilter(String regex, int... indices)
返回一个 RowFilter，它使用正则表达式确定要包含哪些条目。

参数类型为 RowFilter 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.notFilter(RowFilter<M,I> filter)
返回一个 RowFilter，它包含提供的过滤器不包含的条目。
 void DefaultRowSorter.setRowFilter(RowFilter<? super M,? super I> filter)
设置用于确定哪些行（如果有）应该在视图中隐藏的过滤器。

类型变量类型为 RowFilter 的 javax.swing 中的方法参数
static
<M,I> RowFilter<M,I>
RowFilter.andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.RowFilter.ComparisonType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowFilter.ComparisonType
的使用

使用 RowFilter.ComparisonType 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowFilter.ComparisonType 的使用

返回 RowFilter.ComparisonType 的 javax.swing 中的方法
static RowFilter.ComparisonType | RowFilter.ComparisonType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowFilter.ComparisonType[] | RowFilter.ComparisonType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 RowFilter.ComparisonType 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。
static
<M,I> RowFilter<M,I>
RowFilter.numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.RowFilter.Entry 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowFilter.Entry
的使用

使用 RowFilter.Entry 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowFilter.Entry 的使用

参数类型为 RowFilter.Entry 的 javax.swing 中的方法
abstract  boolean RowFilter.include(RowFilter.Entry<? extends M,? extends I> entry)
如果应该显示指定的条目，则返回 true；如果应该隐藏该条目，则返回 false。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.RowSorter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowSorter
的使用

使用 RowSorter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 RowSorter 的使用

javax.swing 中 RowSorter 的子类
 class DefaultRowSorter<M,I>
RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。

返回 RowSorter 的 javax.swing 中的方法
 RowSorter<? extends TableModel> JTable.getRowSorter()
返回负责排序的对象。

参数类型为 RowSorter 的 javax.swing 中的方法
 void JTable.setRowSorter(RowSorter<? extends TableModel> sorter)
设置 RowSorter。

javax.swing.event 中 RowSorter 的使用

返回 RowSorter 的 javax.swing.event 中的方法
 RowSorter RowSorterEvent.getSource()
返回以 RowSorter 形式表示的事件源。

参数类型为 RowSorter 的 javax.swing.event 中的构造方法
RowSorterEvent(RowSorter source)
创建类型为 SORT_ORDER_CHANGED 的 RowSorterEvent。
RowSorterEvent(RowSorter source, RowSorterEvent.Type type, int[] previousRowIndexToModel)
创建一个 RowSorterEvent。

javax.swing.table 中 RowSorter 的使用

javax.swing.table 中 RowSorter 的子类
 class TableRowSorter<M extends TableModel>
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.RowSorter.SortKey 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RowSorter.SortKey
的使用

使用 RowSorter.SortKey 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RowSorter.SortKey 的使用

返回变量类型为 RowSorter.SortKey 的类型的 javax.swing 中的方法
List<? extends RowSorter.SortKey> | DefaultRowSorter.getSortKeys() 返回当前排序键。
abstract List<? extends RowSorter.SortKey> | RowSorter.getSortKeys() 返回当前排序键。

类型变量类型为 RowSorter.SortKey 的 javax.swing 中的方法参数
void | DefaultRowSorter.setSortKeys(List<? extends RowSorter.SortKey> sortKeys) 设置排序键。
abstract void | RowSorter.setSortKeys(List<? extends RowSorter.SortKey> keys) 设置当前排序键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SizeSequence 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SizeSequence
的使用

没有 javax.swing.SizeSequence 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SortOrder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SortOrder
的使用

使用 SortOrder 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SortOrder 的使用

返回 SortOrder 的 javax.swing 中的方法
SortOrder | RowSorter.SortKey.getSortOrder() 返回列的排序顺序。
static SortOrder | SortOrder.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SortOrder[] | SortOrder.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 SortOrder 的 javax.swing 中的构造方法
RowSorter.SortKey(int column, SortOrder sortOrder)
使用指定的排序顺序创建指定列的 SortKey。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SpinnerDateModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpinnerDateModel
的使用

使用 SpinnerDateModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpinnerDateModel 的使用

返回 SpinnerDateModel 的 javax.swing 中的方法
 SpinnerDateModel JSpinner.DateEditor.getModel()
返回微调器祖先的 SpinnerDateModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SpinnerListModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpinnerListModel
的使用

使用 SpinnerListModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpinnerListModel 的使用

返回 SpinnerListModel 的 javax.swing 中的方法
 SpinnerListModel JSpinner.ListEditor.getModel()
返回 spinner 祖先的 SpinnerNumberModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.SpinnerModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.SpinnerModel
的使用

使用 SpinnerModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpinnerModel 的使用

实现 SpinnerModel 的 javax.swing 中的类
class | AbstractSpinnerModel 此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。
class | SpinnerDateModel Date 序列的一个 SpinnerModel。
class | SpinnerListModel 其值由数组或 List 定义的 SpinnerModel 的简单实现。
class | SpinnerNumberModel 用于数字序列的 SpinnerModel。

返回 SpinnerModel 的 javax.swing 中的方法
 SpinnerModel JSpinner.getModel()
返回定义此 spinner 值序列的 SpinnerModel。

参数类型为 SpinnerModel 的 javax.swing 中的方法
protected JComponent | JSpinner.createEditor(SpinnerModel model) 此方法由构造方法调用，以创建显示序列当前值的 JComponent。
void | JSpinner.setModel(SpinnerModel model) 更改表示此 spinner 值的模型。

参数类型为 SpinnerModel 的 javax.swing 中的构造方法
JSpinner(SpinnerModel model)
构造具有一对 next/previous 按钮和 SpinnerModel 编辑器的完整 spinner。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SpinnerNumberModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpinnerNumberModel
的使用

使用 SpinnerNumberModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpinnerNumberModel 的使用

返回 SpinnerNumberModel 的 javax.swing 中的方法
 SpinnerNumberModel JSpinner.NumberEditor.getModel()
返回 spinner 祖先的 SpinnerNumberModel。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.Spring 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Spring
的使用

使用 Spring 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Spring 的使用

返回 Spring 的 javax.swing 中的方法
static Spring Spring.constant(int pref)
返回一个 strut -- 一个其 minimum、preferred 和 maximum 值每个都有值 pref 的 spring。
static Spring Spring.constant(int min, int pref, int max)
返回一个其 minimum、preferred 和 maximum 值具有以下值的 spring：分别是 min、pref 和 max。
 Spring SpringLayout.Constraints.getConstraint(String edgeName)
返回指定边的值，它可以为一个派生值，甚至可以为 null。
 Spring SpringLayout.getConstraint(String edgeName, Component c)
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。
 Spring SpringLayout.Constraints.getHeight()
返回 height 属性的值。
 Spring SpringLayout.Constraints.getWidth()
返回 width 属性的值。
 Spring SpringLayout.Constraints.getX()
返回 x 属性的值。
 Spring SpringLayout.Constraints.getY()
返回 y 属性的值。
static Spring Spring.height(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的高度定义。
static Spring Spring.max(Spring s1, Spring s2)
返回 max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring。
static Spring Spring.minus(Spring s)
返回 -s：一个以与 s 相反方向运行的 spring。
static Spring Spring.scale(Spring s, float factor)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性都是参数 spring s 的属性的倍数。
static Spring Spring.sum(Spring s1, Spring s2)
返回 s1+s2：一个连续表示 s1 和 s2 的 spring。
static Spring Spring.width(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的宽度定义。

参数类型为 Spring 的 javax.swing 中的方法
static Spring Spring.max(Spring s1, Spring s2)
返回 max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring。
static Spring Spring.minus(Spring s)
返回 -s：一个以与 s 相反方向运行的 spring。
 void SpringLayout.putConstraint(String e1, Component c1, Spring s, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2。
static Spring Spring.scale(Spring s, float factor)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性都是参数 spring s 的属性的倍数。
 void SpringLayout.Constraints.setConstraint(String edgeName, Spring s)
设置控制指定边的 spring。
 void SpringLayout.Constraints.setHeight(Spring height)
设置 height 属性，该属性控制组件的高度。
 void SpringLayout.Constraints.setWidth(Spring width)
设置 width 属性，该属性控制组件的宽度。
 void SpringLayout.Constraints.setX(Spring x)
设置 x 属性，该属性控制组件位置的 x 值。
 void SpringLayout.Constraints.setY(Spring y)
设置 y 属性，该属性控制组件位置的 y 值。
static Spring Spring.sum(Spring s1, Spring s2)
返回 s1+s2：一个连续表示 s1 和 s2 的 spring。

参数类型为 Spring 的 javax.swing 中的构造方法
SpringLayout.Constraints(Spring x, Spring y)
创建一个指定了 x 和 y 属性值的 Constraints 对象。
SpringLayout.Constraints(Spring x, Spring y, Spring width, Spring height)
创建一个指定了 x、y、width 和 height 属性值的 Constraints 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SpringLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpringLayout
的使用

没有 javax.swing.SpringLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SpringLayout.Constraints 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SpringLayout.Constraints
的使用

使用 SpringLayout.Constraints 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SpringLayout.Constraints 的使用

返回 SpringLayout.Constraints 的 javax.swing 中的方法
 SpringLayout.Constraints SpringLayout.getConstraints(Component c)
返回指定组件的约束。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SwingWorker 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SwingWorker
的使用

没有 javax.swing.SwingWorker 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SwingWorker.StateValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SwingWorker.StateValue
的使用

使用 SwingWorker.StateValue 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SwingWorker.StateValue 的使用

返回 SwingWorker.StateValue 的 javax.swing 中的方法
SwingWorker.StateValue | SwingWorker.getState() 返回 SwingWorker 状态绑定属性。
static SwingWorker.StateValue | SwingWorker.StateValue.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SwingWorker.StateValue[] | SwingWorker.StateValue.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JApplet 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JApplet
的使用

没有 javax.swing.JApplet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JApplet.AccessibleJApplet 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JApplet.AccessibleJApplet
的使用

没有 javax.swing.JApplet.AccessibleJApplet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JRadioButtonMenuItem 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRadioButtonMenuItem
的使用

没有 javax.swing.JRadioButtonMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
的使用

没有 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultListModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultListModel
的使用

没有 javax.swing.DefaultListModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSlider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSlider
的使用

使用 JSlider 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 JSlider 的使用

声明为 JSlider 的 javax.swing.plaf.basic 中的字段
protected  JSlider BasicSliderUI.slider

参数类型为 JSlider 的 javax.swing.plaf.basic 中的方法
protected ChangeListener | BasicSliderUI.createChangeListener(JSlider slider)
protected ComponentListener | BasicSliderUI.createComponentListener(JSlider slider)
protected FocusListener | BasicSliderUI.createFocusListener(JSlider slider)
protected PropertyChangeListener | BasicSliderUI.createPropertyChangeListener(JSlider slider)
protected BasicSliderUI.ScrollListener | BasicSliderUI.createScrollListener(JSlider slider)
protected BasicSliderUI.TrackListener | BasicSliderUI.createTrackListener(JSlider slider)
protected void | BasicSliderUI.installDefaults(JSlider slider)
protected void | BasicSliderUI.installKeyboardActions(JSlider slider)
protected void | BasicSliderUI.installListeners(JSlider slider)
protected void | BasicSliderUI.uninstallKeyboardActions(JSlider slider)
protected void | BasicSliderUI.uninstallListeners(JSlider slider)

参数类型为 JSlider 的 javax.swing.plaf.basic 中的构造方法
BasicSliderUI.ActionScroller(JSlider slider, int dir, boolean block)
BasicSliderUI(JSlider b)

javax.swing.plaf.metal 中 JSlider 的使用

参数类型为 JSlider 的 javax.swing.plaf.metal 中的方法
protected  PropertyChangeListener MetalSliderUI.createPropertyChangeListener(JSlider slider)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSlider.AccessibleJSlider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSlider.AccessibleJSlider
的使用

没有 javax.swing.JSlider.AccessibleJSlider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultCellEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultCellEditor
的使用

没有 javax.swing.DefaultCellEditor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultCellEditor.EditorDelegate 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultCellEditor.EditorDelegate
的使用

使用 DefaultCellEditor.EditorDelegate 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultCellEditor.EditorDelegate 的使用

声明为 DefaultCellEditor.EditorDelegate 的 javax.swing 中的字段
protected  DefaultCellEditor.EditorDelegate DefaultCellEditor.delegate
处理从 CellEditor 发送的所有方法的委托类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.AbstractCellEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractCellEditor
的使用

使用 AbstractCellEditor 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AbstractCellEditor 的使用

javax.swing 中 AbstractCellEditor 的子类
 class DefaultCellEditor
表单元格和树单元格的默认编辑器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JToolTip 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolTip
的使用

使用 JToolTip 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JToolTip 的使用

返回 JToolTip 的 javax.swing 中的方法
 JToolTip JComponent.createToolTip()
返回用于显示工具提示的 JToolTip 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JToolTip.AccessibleJToolTip 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolTip.AccessibleJToolTip
的使用

没有 javax.swing.JToolTip.AccessibleJToolTip 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.CellEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.CellEditor
的使用

使用 CellEditor 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 CellEditor 的使用

实现 CellEditor 的 javax.swing 中的类
class | AbstractCellEditor
class | DefaultCellEditor 表单元格和树单元格的默认编辑器。

javax.swing.table 中 CellEditor 的使用

javax.swing.table 中 CellEditor 的子接口
 interface TableCellEditor
此接口定义了要成为组件（如 JListBox、JComboBox、JTree 或 JTable）的值编辑器的任意对象需要实现的方法。

javax.swing.tree 中 CellEditor 的使用

javax.swing.tree 中 CellEditor 的子接口
 interface TreeCellEditor
向 CellEditor 添加配置树中编辑器必需的扩展。

实现 CellEditor 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTree 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree
的使用

使用 JTree 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JTree 的使用

参数类型为 JTree 的 javax.swing 中的方法
 Component DefaultCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
实现 TreeCellEditor 接口。

参数类型为 JTree 的 javax.swing 中的构造方法
JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
构造一个 AccessibleJTreeNode

javax.swing.plaf 中 JTree 的使用

参数类型为 JTree 的 javax.swing.plaf 中的方法
abstract void | TreeUI.cancelEditing(JTree tree) 取消当前编辑会话。
abstract TreePath | TreeUI.getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
abstract TreePath | TreeUI.getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
abstract Rectangle | TreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
abstract TreePath | TreeUI.getPathForRow(JTree tree, int row) 返回传入的 row 的路径。
abstract int | TreeUI.getRowCount(JTree tree) 返回将显示的行数。
abstract int | TreeUI.getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
abstract boolean | TreeUI.isEditing(JTree tree) 如果树正被编辑，则返回 true。
abstract void | TreeUI.startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并试着编辑它。
abstract boolean | TreeUI.stopEditing(JTree tree) 停止当前编辑会话。

javax.swing.plaf.basic 中 JTree 的使用

声明为 JTree 的 javax.swing.plaf.basic 中的字段
protected  JTree BasicTreeUI.tree
要在其中进行绘制的组件。

参数类型为 JTree 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.cancelEditing(JTree tree) 取消当前编辑会话。
TreePath | BasicTreeUI.getClosestPathForLocation(JTree tree, int x, int y) 返回到达最接近于 x,y 的那个节点的路径。
TreePath | BasicTreeUI.getEditingPath(JTree tree) 返回到达正被编辑的元素的路径。
Rectangle | BasicTreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
TreePath | BasicTreeUI.getPathForRow(JTree tree, int row) 返回传入的 row 的路径。
int | BasicTreeUI.getRowCount(JTree tree) 返回将显示的行数。
int | BasicTreeUI.getRowForPath(JTree tree, TreePath path) 返回可在其中看见路径中标识的最后一个项的行。
boolean | BasicTreeUI.isEditing(JTree tree) 如果树正被编辑，则返回 true。
void | BasicTreeUI.startEditingAtPath(JTree tree, TreePath path) 选择路径中的最后一个项并尝试对其进行编辑。
boolean | BasicTreeUI.stopEditing(JTree tree) 停止当前编辑会话。

javax.swing.plaf.multi 中 JTree 的使用

参数类型为 JTree 的 javax.swing.plaf.multi 中的方法
void | MultiTreeUI.cancelEditing(JTree a) 在由此对象处理的每个 UI 上调用 cancelEditing 方法。
TreePath | MultiTreeUI.getClosestPathForLocation(JTree a, int b, int c) 在由此对象处理的每个 UI 上调用 getClosestPathForLocation 方法。
TreePath | MultiTreeUI.getEditingPath(JTree a) 在由此对象处理的每个 UI 上调用 getEditingPath 方法。
Rectangle | MultiTreeUI.getPathBounds(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getPathBounds 方法。
TreePath | MultiTreeUI.getPathForRow(JTree a, int b) 在由此对象处理的每个 UI 上调用 getPathForRow 方法。
int | MultiTreeUI.getRowCount(JTree a) 在由此对象处理的每个 UI 上调用 getRowCount 方法。
int | MultiTreeUI.getRowForPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getRowForPath 方法。
boolean | MultiTreeUI.isEditing(JTree a) 在由此对象处理的每个 UI 上调用 isEditing 方法。
void | MultiTreeUI.startEditingAtPath(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 startEditingAtPath 方法。
boolean | MultiTreeUI.stopEditing(JTree a) 在由此对象处理的每个 UI 上调用 stopEditing 方法。

javax.swing.tree 中 JTree 的使用

声明为 JTree 的 javax.swing.tree 中的字段
protected  JTree DefaultTreeCellEditor.tree
JTree 实例侦听。

参数类型为 JTree 的 javax.swing.tree 中的方法
protected void | DefaultTreeCellEditor.determineOffset(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
Component | DefaultTreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 配置编辑器。
Component | TreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 设置编辑器的初始值。
Component | DefaultTreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus) 配置基于传入组件的渲染器。
Component | TreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus) 将当前树单元格的值设置为 value。
protected void | DefaultTreeCellEditor.setTree(JTree newTree) 设置当前正在为其编辑的树。

参数类型为 JTree 的 javax.swing.tree 中的构造方法
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer)
使用指定呈现器和默认编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor(JTree tree, DefaultTreeCellRenderer renderer, TreeCellEditor editor)
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTree.DropLocation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.DropLocation
的使用

使用 JTree.DropLocation 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTree.DropLocation 的使用

返回 JTree.DropLocation 的 javax.swing 中的方法
 JTree.DropLocation JTree.getDropLocation()
返回该组件上 DnD 操作期间此组件应该视觉上指示为放置操作的位置；如果当前未显示任何位置，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTree.EmptySelectionModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.EmptySelectionModel
的使用

使用 JTree.EmptySelectionModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTree.EmptySelectionModel 的使用

声明为 JTree.EmptySelectionModel 的 javax.swing 中的字段
protected static JTree.EmptySelectionModel JTree.EmptySelectionModel.sharedInstance
独有的共享实例。

返回 JTree.EmptySelectionModel 的 javax.swing 中的方法
static JTree.EmptySelectionModel JTree.EmptySelectionModel.sharedInstance()
返回空选择模型的共享实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTree.TreeSelectionRedirector 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.TreeSelectionRedirector
的使用

使用 JTree.TreeSelectionRedirector 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTree.TreeSelectionRedirector 的使用

声明为 JTree.TreeSelectionRedirector 的 javax.swing 中的字段
protected  JTree.TreeSelectionRedirector JTree.selectionRedirector
创建一个新事件，并将它传递给 selectionListeners。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTree.TreeModelHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.TreeModelHandler
的使用

没有 javax.swing.JTree.TreeModelHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTree.DynamicUtilTreeNode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.DynamicUtilTreeNode
的使用

没有 javax.swing.JTree.DynamicUtilTreeNode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTree.AccessibleJTree 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.AccessibleJTree
的使用

没有 javax.swing.JTree.AccessibleJTree 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
的使用

没有 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTable 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable
的使用

使用 JTable 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 JTable 的使用

参数类型为 JTable 的 javax.swing 中的方法
static JScrollPane | JTable.createScrollPaneForTable(JTable aTable) 已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。
Component | DefaultCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column) 实现 TableCellEditor 接口。

参数类型为 JTable 的 javax.swing 中的构造方法
JTable.AccessibleJTable.AccessibleJTableCell(JTable t, int r, int c, int i)
构造一个 AccessibleJTableHeaderEntry。

javax.swing.plaf.basic 中 JTable 的使用

声明为 JTable 的 javax.swing.plaf.basic 中的字段
protected  JTable BasicTableUI.table

javax.swing.table 中 JTable 的使用

声明为 JTable 的 javax.swing.table 中的字段
protected  JTable JTableHeader.table
将此对象作为其头的表，默认值为 null。

返回 JTable 的 javax.swing.table 中的方法
 JTable JTableHeader.getTable()
返回与此头关联的表。

参数类型为 JTable 的 javax.swing.table 中的方法
Component | TableCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column) 为编辑器设置初始 value。
Component | DefaultTableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回默认的表单元格渲染器。
Component | TableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回用于绘制单元格的组件。
void | JTableHeader.setTable(JTable table) 设置与此头关联的表。

参数类型为 JTable 的 javax.swing.table 中的构造方法
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int c, JTableHeader p, JTable t)
构造一个 AccessiblJTableHeaaderEntry

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTable.PrintMode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.PrintMode
的使用

使用 JTable.PrintMode 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTable.PrintMode 的使用

返回 JTable.PrintMode 的 javax.swing 中的方法
static JTable.PrintMode | JTable.PrintMode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static JTable.PrintMode[] | JTable.PrintMode.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 JTable.PrintMode 的 javax.swing 中的方法
Printable | JTable.getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 返回打印此 JTable 中所使用的 Printable。
boolean | JTable.print(JTable.PrintMode printMode) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，不打印标题或脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTable.DropLocation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.DropLocation
的使用

使用 JTable.DropLocation 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTable.DropLocation 的使用

返回 JTable.DropLocation 的 javax.swing 中的方法
 JTable.DropLocation JTable.getDropLocation()
返回对组件的 DnD 操作期间此组件应该可见地指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTable.AccessibleJTable 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.AccessibleJTable
的使用

没有 javax.swing.JTable.AccessibleJTable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
的使用

没有 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
的使用

没有 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JProgressBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JProgressBar
的使用

使用 JProgressBar 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 JProgressBar 的使用

声明为 JProgressBar 的 javax.swing.plaf.basic 中的字段
protected  JProgressBar BasicProgressBarUI.progressBar

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JProgressBar.AccessibleJProgressBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JProgressBar.AccessibleJProgressBar
的使用

没有 javax.swing.JProgressBar.AccessibleJProgressBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JCheckBox 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JCheckBox
的使用

使用 JCheckBox 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JCheckBox 的使用

参数类型为 JCheckBox 的 javax.swing 中的构造方法
DefaultCellEditor(JCheckBox checkBox)
构造一个使用复选框的 DefaultCellEditor 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JCheckBox.AccessibleJCheckBox 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JCheckBox.AccessibleJCheckBox
的使用

没有 javax.swing.JCheckBox.AccessibleJCheckBox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.GrayFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.GrayFilter
的使用

没有 javax.swing.GrayFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTabbedPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTabbedPane
的使用

使用 JTabbedPane 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf 中 JTabbedPane 的使用

参数类型为 JTabbedPane 的 javax.swing.plaf 中的方法
abstract Rectangle | TabbedPaneUI.getTabBounds(JTabbedPane pane, int index)
abstract int | TabbedPaneUI.getTabRunCount(JTabbedPane pane)
abstract int | TabbedPaneUI.tabForCoordinate(JTabbedPane pane, int x, int y)

javax.swing.plaf.basic 中 JTabbedPane 的使用

声明为 JTabbedPane 的 javax.swing.plaf.basic 中的字段
protected  JTabbedPane BasicTabbedPaneUI.tabPane

参数类型为 JTabbedPane 的 javax.swing.plaf.basic 中的方法
Rectangle | BasicTabbedPaneUI.getTabBounds(JTabbedPane pane, int i) 返回指定选项卡索引的边界。
int | BasicTabbedPaneUI.getTabRunCount(JTabbedPane pane)
int | BasicTabbedPaneUI.tabForCoordinate(JTabbedPane pane, int x, int y) 返回与 JTabbedPane 的坐标空间中的指定点相交的选项卡索引。

javax.swing.plaf.multi 中 JTabbedPane 的使用

参数类型为 JTabbedPane 的 javax.swing.plaf.multi 中的方法
Rectangle | MultiTabbedPaneUI.getTabBounds(JTabbedPane a, int b) 在由此对象处理的每个 UI 上调用 getTabBounds 方法。
int | MultiTabbedPaneUI.getTabRunCount(JTabbedPane a) 在由此对象处理的每个 UI 上调用 getTabRunCount 方法。
int | MultiTabbedPaneUI.tabForCoordinate(JTabbedPane a, int b, int c) 在由此对象处理的每个 UI 上调用 tabForCoordinate 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTabbedPane.ModelListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTabbedPane.ModelListener
的使用

没有 javax.swing.JTabbedPane.ModelListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTabbedPane.AccessibleJTabbedPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTabbedPane.AccessibleJTabbedPane
的使用

没有 javax.swing.JTabbedPane.AccessibleJTabbedPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JRadioButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRadioButton
的使用

没有 javax.swing.JRadioButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JRadioButton.AccessibleJRadioButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRadioButton.AccessibleJRadioButton
的使用

没有 javax.swing.JRadioButton.AccessibleJRadioButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.BorderFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.BorderFactory
的使用

没有 javax.swing.BorderFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.UnsupportedLookAndFeelException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UnsupportedLookAndFeelException
的使用

使用 UnsupportedLookAndFeelException 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 UnsupportedLookAndFeelException 的使用

抛出 UnsupportedLookAndFeelException 的 javax.swing 中的方法
static void | UIManager.setLookAndFeel(LookAndFeel newLookAndFeel) 将当前外观设置为 newLookAndFeel。
static void | UIManager.setLookAndFeel(String className) 使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JWindow 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JWindow
的使用

没有 javax.swing.JWindow 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JWindow.AccessibleJWindow 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JWindow.AccessibleJWindow
的使用

没有 javax.swing.JWindow.AccessibleJWindow 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTextArea 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextArea
的使用

没有 javax.swing.JTextArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTextArea.AccessibleJTextArea 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextArea.AccessibleJTextArea
的使用

没有 javax.swing.JTextArea.AccessibleJTextArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SizeRequirements 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SizeRequirements
的使用

使用 SizeRequirements 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 SizeRequirements 的使用

返回 SizeRequirements 的 javax.swing 中的方法
static SizeRequirements | SizeRequirements.getAlignedSizeRequirements(SizeRequirements[] children) 确定对齐一组组件所需的总空间。
static SizeRequirements | SizeRequirements.getTiledSizeRequirements(SizeRequirements[] children) 确定端到端放置一组组件需要占用的总空间。

参数类型为 SizeRequirements 的 javax.swing 中的方法
static int[] | SizeRequirements.adjustSizes(int delta, SizeRequirements[] children) 按给定总量调整指定的大小数组。
static void | SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组偏移量/区域对，指定如何按照指定对齐方式对一组组件进行布局。
static void | SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组偏移量/区域对，指定如何按照指定对齐方式对一组组件进行布局。
static void | SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean normal) 创建一组偏移量/区域对，指定如何按指定对齐方式对一组组件进行布局。
static void | SizeRequirements.calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean normal) 创建一组偏移量/区域对，指定如何按指定对齐方式对一组组件进行布局。
static void | SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static void | SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static void | SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean forward) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static void | SizeRequirements.calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean forward) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static SizeRequirements | SizeRequirements.getAlignedSizeRequirements(SizeRequirements[] children) 确定对齐一组组件所需的总空间。
static SizeRequirements | SizeRequirements.getTiledSizeRequirements(SizeRequirements[] children) 确定端到端放置一组组件需要占用的总空间。

javax.swing.text 中 SizeRequirements 的使用

返回 SizeRequirements 的 javax.swing.text 中的方法
protected SizeRequirements | BoxView.baselineRequirements(int axis, SizeRequirements r) 通过检查每个子视图的大小计算此 BoxView 的大小要求。
protected SizeRequirements | BoxView.calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算主轴 axis 的大小要求。
protected SizeRequirements | BoxView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴 axis 的大小要求。
protected SizeRequirements | FlowView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算沿辅轴的要求。
protected SizeRequirements | TableView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴的所需大小。

参数类型为 SizeRequirements 的 javax.swing.text 中的方法
protected SizeRequirements | BoxView.baselineRequirements(int axis, SizeRequirements r) 通过检查每个子视图的大小计算此 BoxView 的大小要求。
protected SizeRequirements | BoxView.calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算主轴 axis 的大小要求。
protected SizeRequirements | BoxView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴 axis 的大小要求。
protected SizeRequirements | FlowView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算沿辅轴的要求。
protected SizeRequirements | TableView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算辅轴的所需大小。
protected void | TableView.layoutColumns(int targetSpan, int[] offsets, int[] spans, SizeRequirements[] reqs) 布局列，使其符合给定的目标跨距。

javax.swing.text.html 中 SizeRequirements 的使用

返回 SizeRequirements 的 javax.swing.text.html 中的方法
protected SizeRequirements | BlockView.calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算块沿主轴的要求（即沿其平铺的轴）。
protected SizeRequirements | BlockView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算块沿辅轴的要求（即垂直沿其平铺的轴的轴）。
protected SizeRequirements | ParagraphView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算段落沿辅轴的要求。

参数类型为 SizeRequirements 的 javax.swing.text.html 中的方法
protected SizeRequirements | BlockView.calculateMajorAxisRequirements(int axis, SizeRequirements r) 计算块沿主轴的要求（即沿其平铺的轴）。
protected SizeRequirements | BlockView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算块沿辅轴的要求（即垂直沿其平铺的轴的轴）。
protected SizeRequirements | ParagraphView.calculateMinorAxisRequirements(int axis, SizeRequirements r) 计算段落沿辅轴的要求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.AbstractAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractAction
的使用

使用 AbstractAction 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.plaf.basic 中 AbstractAction 的使用

javax.swing.plaf.basic 中 AbstractAction 的子类
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

javax.swing.plaf.metal 中 AbstractAction 的使用

javax.swing.plaf.metal 中 AbstractAction 的子类
protected  class MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

javax.swing.text 中 AbstractAction 的使用

javax.swing.text 中 AbstractAction 的子类
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

javax.swing.text.html 中 AbstractAction 的使用

javax.swing.text.html 中 AbstractAction 的子类
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTextField 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextField
的使用

使用 JTextField 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JTextField 的使用

javax.swing 中 JTextField 的子类
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。

参数类型为 JTextField 的 javax.swing 中的构造方法
DefaultCellEditor(JTextField textField)
构造一个使用文本字段的 DefaultCellEditor。

javax.swing.plaf.basic 中 JTextField 的使用

声明为 JTextField 的 javax.swing.plaf.basic 中的字段
protected  JTextField BasicComboBoxEditor.editor

返回 JTextField 的 javax.swing.plaf.basic 中的方法
protected  JTextField BasicComboBoxEditor.createEditorComponent()
创建内部编辑器组件。

javax.swing.tree 中 JTextField 的使用

javax.swing.tree 中 JTextField 的子类
 class DefaultTreeCellEditor.DefaultTextField
不提供任何编辑器时所使用的 TextField。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JTextField.AccessibleJTextField 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JTextField.AccessibleJTextField
的使用

使用 JTextField.AccessibleJTextField 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JTextField.AccessibleJTextField 的使用

javax.swing 中 JTextField.AccessibleJTextField 的子类
protected  class JPasswordField.AccessibleJPasswordField
此类实现对 JPasswordField 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.ComboBoxEditor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ComboBoxEditor
的使用

使用 ComboBoxEditor 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ComboBoxEditor 的使用

声明为 ComboBoxEditor 的 javax.swing 中的字段
protected  ComboBoxEditor JComboBox.editor
此受保护字段是特定于实现的。

返回 ComboBoxEditor 的 javax.swing 中的方法
 ComboBoxEditor JComboBox.getEditor()
返回用于绘制和编辑 JComboBox 字段中所选项的编辑器。

参数类型为 ComboBoxEditor 的 javax.swing 中的方法
void | JComboBox.configureEditor(ComboBoxEditor anEditor, Object anItem) 利用指定项初始化编辑器。
void | JComboBox.setEditor(ComboBoxEditor anEditor) 设置用于绘制和编辑 JComboBox 字段中所选项的编辑器。

javax.swing.plaf.basic 中 ComboBoxEditor 的使用

实现 ComboBoxEditor 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxEditor 用于可编辑组合框的默认编辑器。
static class | BasicComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的子类。

返回 ComboBoxEditor 的 javax.swing.plaf.basic 中的方法
protected  ComboBoxEditor BasicComboBoxUI.createEditor()
创建将在可编辑的组合框中使用的默认编辑器。

javax.swing.plaf.metal 中 ComboBoxEditor 的使用

实现 ComboBoxEditor 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxEditor Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。

返回 ComboBoxEditor 的 javax.swing.plaf.metal 中的方法
protected  ComboBoxEditor MetalComboBoxUI.createEditor()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ViewportLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ViewportLayout
的使用

没有 javax.swing.ViewportLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JViewport 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JViewport
的使用

使用 JViewport 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JViewport 的使用

声明为 JViewport 的 javax.swing 中的字段
protected JViewport | ScrollPaneLayout.colHead 子级列标题。
protected JViewport | JScrollPane.columnHeader 列标题子级。
protected JViewport | ScrollPaneLayout.rowHead 子级行标题。
protected JViewport | JScrollPane.rowHeader 行标题子级。
protected JViewport | ScrollPaneLayout.viewport 滚动窗格的子级视口。
protected JViewport | JScrollPane.viewport 滚动窗格的视口子级。
protected JViewport | JScrollPane.AccessibleJScrollPane.viewPort

返回 JViewport 的 javax.swing 中的方法
protected JViewport | JScrollPane.createViewport() 默认返回新的 JViewport。
JViewport | ScrollPaneLayout.getColumnHeader() 返回列标题对应的 JViewport 对象。
JViewport | JScrollPane.getColumnHeader() 返回列标题。
JViewport | ScrollPaneLayout.getRowHeader() 返回行标题对应的 JViewport 对象。
JViewport | JScrollPane.getRowHeader() 返回行标题。
JViewport | ScrollPaneLayout.getViewport() 返回显示滚动组件内容的 JViewport 对象。
JViewport | JScrollPane.getViewport() 返回当前的 JViewport。

参数类型为 JViewport 的 javax.swing 中的方法
void | JScrollPane.setColumnHeader(JViewport columnHeader) 移除旧的 columnHeader，如果有的话；如果新的 columnHeader 不为 null，将其 viewPosition 的 x 坐标与视口（如果有）同步然后将其添加到滚动窗格。
void | JScrollPane.setRowHeader(JViewport rowHeader) 移除旧的 rowHeader，如果存在；如果新的 rowHeader 不为 null，将其 viewPosition 的 y 坐标与视口（如果有）同步然后将其添加到滚动窗格。
void | JScrollPane.setViewport(JViewport viewport) 移除旧视口（如果有）；强制新视口的 viewPosition 位于 +x,+y 象限中；将行和列标题（如果有）与新视口同步；最后将滚动条和标题与新视口同步。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JViewport.ViewListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JViewport.ViewListener
的使用

使用 JViewport.ViewListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JViewport.ViewListener 的使用

返回 JViewport.ViewListener 的 javax.swing 中的方法
protected  JViewport.ViewListener JViewport.createViewListener()
为该视图创建侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JViewport.AccessibleJViewport 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JViewport.AccessibleJViewport
的使用

没有 javax.swing.JViewport.AccessibleJViewport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ScrollPaneLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ScrollPaneLayout
的使用

使用 ScrollPaneLayout 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ScrollPaneLayout 的使用

javax.swing 中 ScrollPaneLayout 的子类
static class ScrollPaneLayout.UIResource
ScrollPaneLayout 的 UI 资源版本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ScrollPaneLayout.UIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ScrollPaneLayout.UIResource
的使用

没有 javax.swing.ScrollPaneLayout.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JScrollPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollPane
的使用

使用 JScrollPane 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JScrollPane 的使用

返回 JScrollPane 的 javax.swing 中的方法
static JScrollPane JTable.createScrollPaneForTable(JTable aTable)
已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。

参数类型为 JScrollPane 的 javax.swing 中的方法
 Rectangle ScrollPaneLayout.getViewportBorderBounds(JScrollPane scrollpane)
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
 void ScrollPaneLayout.syncWithScrollPane(JScrollPane sp)
在 ScrollPaneLayout 被设置为 JScrollPane 的 LayoutManager 后，此方法被调用。

javax.swing.plaf.basic 中 JScrollPane 的使用

声明为 JScrollPane 的 javax.swing.plaf.basic 中的字段
protected JScrollPane | BasicComboPopup.scroller 此受保护字段是特定于实现的。
protected JScrollPane | BasicScrollPaneUI.scrollpane

返回 JScrollPane 的 javax.swing.plaf.basic 中的方法
protected JScrollPane | BasicComboPopup.createScroller() 创建容纳可滚动列表的滚动窗格。
protected JScrollPane | BasicTreeUI.ComponentHandler.getScrollPane() 返回容纳 JTree 的 JScrollPane；如果一个也没有找到，则返回 null。

参数类型为 JScrollPane 的 javax.swing.plaf.basic 中的方法
protected void | BasicScrollPaneUI.installDefaults(JScrollPane scrollpane)
protected void | BasicScrollPaneUI.installKeyboardActions(JScrollPane c)
protected void | BasicScrollPaneUI.installListeners(JScrollPane c)
protected void | BasicScrollPaneUI.uninstallDefaults(JScrollPane c)
protected void | BasicScrollPaneUI.uninstallKeyboardActions(JScrollPane c)

javax.swing.plaf.metal 中 JScrollPane 的使用

参数类型为 JScrollPane 的 javax.swing.plaf.metal 中的方法
void | MetalScrollPaneUI.installListeners(JScrollPane scrollPane)
void | MetalScrollPaneUI.uninstallListeners(JScrollPane scrollPane)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JScrollPane.ScrollBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollPane.ScrollBar
的使用

没有 javax.swing.JScrollPane.ScrollBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JScrollPane.AccessibleJScrollPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollPane.AccessibleJScrollPane
的使用

没有 javax.swing.JScrollPane.AccessibleJScrollPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.ScrollPaneConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ScrollPaneConstants
的使用

使用 ScrollPaneConstants 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ScrollPaneConstants 的使用

实现 ScrollPaneConstants 的 javax.swing 中的类
class | JScrollPane 提供轻量级组件的 scrollable 视图。
class | ScrollPaneLayout JScrollPane 使用的布局管理器。
static class | ScrollPaneLayout.UIResource ScrollPaneLayout 的 UI 资源版本。

javax.swing.plaf.basic 中 ScrollPaneConstants 的使用

实现 ScrollPaneConstants 的 javax.swing.plaf.basic 中的类
 class BasicScrollPaneUI
ScrollPaneUI 的默认 L&F 实现。

javax.swing.plaf.metal 中 ScrollPaneConstants 的使用

实现 ScrollPaneConstants 的 javax.swing.plaf.metal 中的类
 class MetalScrollPaneUI
ScrollPaneUI 的 Metal L&F 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultListCellRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultListCellRenderer
的使用

使用 DefaultListCellRenderer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 DefaultListCellRenderer 的使用

javax.swing 中 DefaultListCellRenderer 的子类
static class DefaultListCellRenderer.UIResource
实现 UIResource 的 DefaultListCellRenderer 的子类。

javax.swing.plaf.metal 中 DefaultListCellRenderer 的使用

javax.swing.plaf.metal 中 DefaultListCellRenderer 的子类
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.TransferHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.TransferHandler
的使用

使用 TransferHandler 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 TransferHandler 的使用

返回 TransferHandler 的 javax.swing 中的方法
TransferHandler | JApplet.getTransferHandler() 获取 transferHandler 属性。
TransferHandler | JWindow.getTransferHandler() 获取 transferHandler 属性。
TransferHandler | JDialog.getTransferHandler() 获取 transferHandler 属性。
TransferHandler | JComponent.getTransferHandler() 获取 transferHandler 属性。
TransferHandler | JFrame.getTransferHandler() 获取 transferHandler 属性。

参数类型为 TransferHandler 的 javax.swing 中的方法
void | JApplet.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
void | JWindow.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
void | JDialog.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。
void | JComponent.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性；如果该组件不支持数据传输操作，则为 null。
void | JFrame.setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultListCellRenderer.UIResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultListCellRenderer.UIResource
的使用

没有 javax.swing.DefaultListCellRenderer.UIResource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.TransferHandler.DropLocation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.TransferHandler.DropLocation
的使用

使用 TransferHandler.DropLocation 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 TransferHandler.DropLocation 的使用

javax.swing 中 TransferHandler.DropLocation 的子类
static class | JList.DropLocation TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。
static class | JTable.DropLocation TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。
static class | JTree.DropLocation TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。

返回 TransferHandler.DropLocation 的 javax.swing 中的方法
 TransferHandler.DropLocation TransferHandler.TransferSupport.getDropLocation()
此 TransferSupport 表示一个放置操作时，返回组件的当前放置位置（非 null）。

javax.swing.text 中 TransferHandler.DropLocation 的使用

javax.swing.text 中 TransferHandler.DropLocation 的子类
static class JTextComponent.DropLocation
表示 JTextComponent 的放置位置 (drop location)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.TransferHandler.TransferSupport 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.TransferHandler.TransferSupport
的使用

使用 TransferHandler.TransferSupport 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 TransferHandler.TransferSupport 的使用

参数类型为 TransferHandler.TransferSupport 的 javax.swing 中的方法
boolean | TransferHandler.canImport(TransferHandler.TransferSupport support) 在拖放操作期间重复调用此方法，以允许开发人员配置传输的可接受性属性，并返回传输的可接受性；返回 true 值指示给定 TransferSupport（它包含该传输的所有细节）所表示的传输在当前是可以接受的，false 值指示拒绝该传输。
boolean | TransferHandler.importData(TransferHandler.TransferSupport support) 导致从剪贴板或拖放操作的传输。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultListSelectionModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultListSelectionModel
的使用

使用 DefaultListSelectionModel 的软件包
javax.swing.tree 提供处理 javax.swing.JTree 的类和接口。

javax.swing.tree 中 DefaultListSelectionModel 的使用

声明为 DefaultListSelectionModel 的 javax.swing.tree 中的字段
protected  DefaultListSelectionModel DefaultTreeSelectionModel.listSelectionModel
维护列表选择模型的句柄。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.ListSelectionModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ListSelectionModel
的使用

使用 ListSelectionModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

javax.swing 中 ListSelectionModel 的使用

实现 ListSelectionModel 的 javax.swing 中的类
 class DefaultListSelectionModel
列表选择的默认数据模型。

声明为 ListSelectionModel 的 javax.swing 中的字段
protected  ListSelectionModel JTable.selectionModel
表的 ListSelectionModel，用来追踪行选择。

返回 ListSelectionModel 的 javax.swing 中的方法
protected ListSelectionModel | JTable.createDefaultSelectionModel() 返回默认的选择模型对象，它是一个 DefaultListSelectionModel。
protected ListSelectionModel | JList.createSelectionModel() 返回一个 DefaultListSelectionModel 实例；在构造期间调用此方法初始化列表的选择模型属性。
ListSelectionModel | JTable.getSelectionModel() 返回用来维持行选择状态的 ListSelectionModel。
ListSelectionModel | JList.getSelectionModel() 返回当前选择模型。

参数类型为 ListSelectionModel 的 javax.swing 中的方法
void | JTable.setSelectionModel(ListSelectionModel newModel) 将此表的行选择模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
void | JList.setSelectionModel(ListSelectionModel selectionModel) 将列表的 selectionModel 设置为非 null 的 ListSelectionModel 实现。

参数类型为 ListSelectionModel 的 javax.swing 中的构造方法
JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。

javax.swing.plaf.basic 中 ListSelectionModel 的使用

参数类型为 ListSelectionModel 的 javax.swing.plaf.basic 中的方法
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。

javax.swing.table 中 ListSelectionModel 的使用

声明为 ListSelectionModel 的 javax.swing.table 中的字段
protected  ListSelectionModel DefaultTableColumnModel.selectionModel
跟踪列选择的模型

返回 ListSelectionModel 的 javax.swing.table 中的方法
protected ListSelectionModel | DefaultTableColumnModel.createSelectionModel() 创建新的默认列表选择模型。
ListSelectionModel | DefaultTableColumnModel.getSelectionModel() 返回用来维护列选择状态的 ListSelectionModel。
ListSelectionModel | TableColumnModel.getSelectionModel() 返回当前的选择模型。

参数类型为 ListSelectionModel 的 javax.swing.table 中的方法
void | DefaultTableColumnModel.setSelectionModel(ListSelectionModel newModel) 将此 TableColumnModel 的选择模型设置为 newModel，并为来自新选择模型的侦听器通知注册它。
void | TableColumnModel.setSelectionModel(ListSelectionModel newModel) 设置选择模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DropMode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DropMode
的使用

使用 DropMode 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 DropMode 的使用

返回 DropMode 的 javax.swing 中的方法
DropMode | JTree.getDropMode() 返回此组件的放置模式。
DropMode | JTable.getDropMode() 返回此组件的放置模式。
DropMode | JList.getDropMode() 返回此组件的放置模式。
static DropMode | DropMode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static DropMode[] | DropMode.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 DropMode 的 javax.swing 中的方法
void | JTree.setDropMode(DropMode dropMode) 设置此组件的放置模式。
void | JTable.setDropMode(DropMode dropMode) 设置此组件的放置模式。
void | JList.setDropMode(DropMode dropMode) 设置此组件的放置模式。

javax.swing.text 中 DropMode 的使用

返回 DropMode 的 javax.swing.text 中的方法
 DropMode JTextComponent.getDropMode()
返回此组件的放置模式。

参数类型为 DropMode 的 javax.swing.text 中的方法
 void JTextComponent.setDropMode(DropMode dropMode)
设置此组件的放置模式，为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JList
的使用

使用 JList 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 JList 的使用

参数类型为 JList 的 javax.swing 中的方法
Component | DefaultListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
Component | ListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus) 返回已配置用于显示指定值的组件。

参数类型为 JList 的 javax.swing 中的构造方法
JList.AccessibleJList.AccessibleJListChild(JList parent, int indexInParent)

javax.swing.plaf 中 JList 的使用

参数类型为 JList 的 javax.swing.plaf 中的方法
abstract Rectangle | ListUI.getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
abstract Point | ListUI.indexToLocation(JList list, int index) 返回列表坐标系统中给定 JList 中指定项的原点。
abstract int | ListUI.locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。

javax.swing.plaf.basic 中 JList 的使用

声明为 JList 的 javax.swing.plaf.basic 中的字段
protected JList | BasicListUI.list
protected JList | BasicComboPopup.list 此受保护字段是特定于实现的。
protected JList | BasicComboBoxUI.listBox

返回 JList 的 javax.swing.plaf.basic 中的方法
protected  JList BasicComboPopup.createList()
创建在显示组合框模型项的弹出控件中使用的 JList。
 JList BasicComboPopup.getList()
ComboPopup.getList() 的实现。
 JList ComboPopup.getList()
返回要用于在组合框中绘制项的列表。

参数类型为 JList 的 javax.swing.plaf.basic 中的方法
protected MouseListener | BasicFileChooserUI.createDoubleClickListener(JFileChooser fc, JList list)
Rectangle | BasicListUI.getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
Component | BasicComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
Point | BasicListUI.indexToLocation(JList list, int index) 返回列表坐标系统中给定 JList 中指定项的原点。
int | BasicListUI.locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。

参数类型为 JList 的 javax.swing.plaf.basic 中的构造方法
BasicFileChooserUI.DoubleClickListener(JList list)

javax.swing.plaf.metal 中 JList 的使用

声明为 JList 的 javax.swing.plaf.metal 中的字段
protected  JList MetalComboBoxButton.listBox

参数类型为 JList 的 javax.swing.plaf.metal 中的方法
 Component MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

参数类型为 JList 的 javax.swing.plaf.metal 中的构造方法
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)
MetalFileChooserUI.SingleClickListener(JList list)

javax.swing.plaf.multi 中 JList 的使用

参数类型为 JList 的 javax.swing.plaf.multi 中的方法
Rectangle | MultiListUI.getCellBounds(JList a, int b, int c) 在由此对象处理的每个 UI 上调用 getCellBounds 方法。
Point | MultiListUI.indexToLocation(JList a, int b) 在由此对象处理的每个 UI 上调用 indexToLocation 方法。
int | MultiListUI.locationToIndex(JList a, Point b) 在由此对象处理的每个 UI 上调用 locationToIndex 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JList.DropLocation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JList.DropLocation
的使用

使用 JList.DropLocation 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JList.DropLocation 的使用

返回 JList.DropLocation 的 javax.swing 中的方法
 JList.DropLocation JList.getDropLocation()
返回在该组件上执行 DnD 操作期间此组件应该视觉上指示为放置位置的位置；如果当前没有任何显示的位置，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JList.AccessibleJList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JList.AccessibleJList
的使用

没有 javax.swing.JList.AccessibleJList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JList.AccessibleJList.AccessibleJListChild 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JList.AccessibleJList.AccessibleJListChild
的使用

没有 javax.swing.JList.AccessibleJList.AccessibleJListChild 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.Scrollable 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.Scrollable
的使用

使用 Scrollable 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 Scrollable 的使用

实现 Scrollable 的 javax.swing 中的类
class | JEditorPane 可编辑各种内容的文本组件。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JTree 将分层数据集显示为轮廓的控件。

javax.swing.text 中 Scrollable 的使用

实现 Scrollable 的 javax.swing.text 中的类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.tree 中 Scrollable 的使用

实现 Scrollable 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor.DefaultTextField
不提供任何编辑器时所使用的 TextField。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultComboBoxModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultComboBoxModel
的使用

没有 javax.swing.DefaultComboBoxModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.AbstractListModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractListModel
的使用

使用 AbstractListModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 AbstractListModel 的使用

javax.swing 中 AbstractListModel 的子类
class | DefaultComboBoxModel 组合框的默认模型。
class | DefaultListModel 此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。

javax.swing.plaf.basic 中 AbstractListModel 的使用

javax.swing.plaf.basic 中 AbstractListModel 的子类
 class BasicDirectoryModel
文件列表的基本实现。

javax.swing.plaf.metal 中 AbstractListModel 的使用

javax.swing.plaf.metal 中 AbstractListModel 的子类
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.MutableComboBoxModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.MutableComboBoxModel
的使用

使用 MutableComboBoxModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 MutableComboBoxModel 的使用

实现 MutableComboBoxModel 的 javax.swing 中的类
 class DefaultComboBoxModel
组合框的默认模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.ListCellRenderer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ListCellRenderer
的使用

使用 ListCellRenderer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ListCellRenderer 的使用

实现 ListCellRenderer 的 javax.swing 中的类
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。

声明为 ListCellRenderer 的 javax.swing 中的字段
protected  ListCellRenderer JComboBox.renderer
此受保护字段是特定于实现的。

返回 ListCellRenderer 的 javax.swing 中的方法
ListCellRenderer | JList.getCellRenderer() 返回负责绘制列表项的对象。
ListCellRenderer | JComboBox.getRenderer() 返回用于显示 JComboBox 字段中所选项的渲染器。

参数类型为 ListCellRenderer 的 javax.swing 中的方法
void | JList.setCellRenderer(ListCellRenderer cellRenderer) 设置用于绘制列表中每个单元的委托。
void | JComboBox.setRenderer(ListCellRenderer aRenderer) 设置渲染器，该渲染器用于绘制列表项和从 JComboBox 字段的列表中选择的项。

javax.swing.plaf.basic 中 ListCellRenderer 的使用

实现 ListCellRenderer 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。

返回 ListCellRenderer 的 javax.swing.plaf.basic 中的方法
protected  ListCellRenderer BasicComboBoxUI.createRenderer()
创建将在不可编辑的组合框中使用的默认渲染器。

参数类型为 ListCellRenderer 的 javax.swing.plaf.basic 中的方法
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。

javax.swing.plaf.metal 中 ListCellRenderer 的使用

实现 ListCellRenderer 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.ComboBoxModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ComboBoxModel
的使用

使用 ComboBoxModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ComboBoxModel 的使用

javax.swing 中 ComboBoxModel 的子接口
 interface MutableComboBoxModel
ComboBoxModel 的可变版本。

实现 ComboBoxModel 的 javax.swing 中的类
 class DefaultComboBoxModel
组合框的默认模型。

声明为 ComboBoxModel 的 javax.swing 中的字段
protected  ComboBoxModel JComboBox.dataModel
此受保护字段是特定于实现的。

返回 ComboBoxModel 的 javax.swing 中的方法
 ComboBoxModel JComboBox.getModel()
返回 JComboBox 当前使用的数据模型。

参数类型为 ComboBoxModel 的 javax.swing 中的方法
int | JComboBox.KeySelectionManager.selectionForKey(char aKey, ComboBoxModel aModel) 给定的 aKey 和模型返回应该被选择的行。
void | JComboBox.setModel(ComboBoxModel aModel) 设置 JComboBox 用于获取项列表的数据模型。

参数类型为 ComboBoxModel 的 javax.swing 中的构造方法
JComboBox(ComboBoxModel aModel)
创建一个 JComboBox，其项取自现有的 ComboBoxModel。

javax.swing.plaf.basic 中 ComboBoxModel 的使用

参数类型为 ComboBoxModel 的 javax.swing.plaf.basic 中的方法
protected void | BasicComboPopup.installComboBoxModelListeners(ComboBoxModel model) 在组合框模型中安装侦听器。
protected void | BasicComboPopup.uninstallComboBoxModelListeners(ComboBoxModel model) 从组合框模型中移除侦听器

javax.swing.plaf.metal 中 ComboBoxModel 的使用

实现 ComboBoxModel 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.ListModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ListModel
的使用

使用 ListModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ListModel 的使用

javax.swing 中 ListModel 的子接口
interface | ComboBoxModel 用于组合框的数据模型。
interface | MutableComboBoxModel ComboBoxModel 的可变版本。

实现 ListModel 的 javax.swing 中的类
class | AbstractListModel 该数据模型的抽象定义提供一个带内容的 List。
class | DefaultComboBoxModel 组合框的默认模型。
class | DefaultListModel 此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。

返回 ListModel 的 javax.swing 中的方法
 ListModel JList.getModel()
返回保存由 JList 组件显示的项列表的数据模型。

参数类型为 ListModel 的 javax.swing 中的方法
 void JList.setModel(ListModel model)
设置表示列表内容或列表“值”的模型，通知属性更改侦听器，然后清除列表选择。

参数类型为 ListModel 的 javax.swing 中的构造方法
JList(ListModel dataModel)
根据指定的非 null 模型构造一个显示元素的 JList。

javax.swing.plaf.basic 中 ListModel 的使用

实现 ListModel 的 javax.swing.plaf.basic 中的类
 class BasicDirectoryModel
文件列表的基本实现。

参数类型为 ListModel 的 javax.swing.plaf.basic 中的方法
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。

javax.swing.plaf.metal 中 ListModel 的使用

实现 ListModel 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.CellRendererPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.CellRendererPane
的使用

使用 CellRendererPane 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 CellRendererPane 的使用

声明为 CellRendererPane 的 javax.swing.plaf.basic 中的字段
protected CellRendererPane | BasicComboBoxUI.currentValuePane
protected CellRendererPane | BasicTreeUI.rendererPane 用于绘制 TreeCellRenderer。
protected CellRendererPane | BasicTableUI.rendererPane
protected CellRendererPane | BasicTableHeaderUI.rendererPane
protected CellRendererPane | BasicListUI.rendererPane

返回 CellRendererPane 的 javax.swing.plaf.basic 中的方法
protected  CellRendererPane BasicTreeUI.createCellRendererPane()
返回用于放置渲染器组件的渲染器窗格。

javax.swing.plaf.metal 中 CellRendererPane 的使用

声明为 CellRendererPane 的 javax.swing.plaf.metal 中的字段
protected  CellRendererPane MetalComboBoxButton.rendererPane

参数类型为 CellRendererPane 的 javax.swing.plaf.metal 中的构造方法
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.CellRendererPane.AccessibleCellRendererPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.CellRendererPane.AccessibleCellRendererPane
的使用

没有 javax.swing.CellRendererPane.AccessibleCellRendererPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultBoundedRangeModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultBoundedRangeModel
的使用

没有 javax.swing.DefaultBoundedRangeModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.BoundedRangeModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.BoundedRangeModel
的使用

使用 BoundedRangeModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 BoundedRangeModel 的使用

实现 BoundedRangeModel 的 javax.swing 中的类
 class DefaultBoundedRangeModel
BoundedRangeModel 的一般实现。

声明为 BoundedRangeModel 的 javax.swing 中的字段
protected BoundedRangeModel | JProgressBar.model 保存进度条数据的对象。
protected BoundedRangeModel | JScrollBar.model 表示滚动条的最小、最大、跨度（也叫 "visibleAmount"）和当前值的模型。
protected BoundedRangeModel | JSlider.sliderModel 处理滑块的数字最大值、最小值和当前位置值的数据模型。

返回 BoundedRangeModel 的 javax.swing 中的方法
BoundedRangeModel | JTextField.getHorizontalVisibility() 获取文本字段的可见性。
BoundedRangeModel | JSlider.getModel() 返回处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
BoundedRangeModel | JProgressBar.getModel() 返回此进度条使用的数据模型。
BoundedRangeModel | JScrollBar.getModel() 返回处理滚动条的四个基本属性的数据模型：minimum、maximum、value 和 extent。

参数类型为 BoundedRangeModel 的 javax.swing 中的方法
void | JSlider.setModel(BoundedRangeModel newModel) 设置处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
void | JProgressBar.setModel(BoundedRangeModel newModel) 设置 JProgressBar 使用的数据模型。
void | JScrollBar.setModel(BoundedRangeModel newModel) 设置处理滚动条的以下四个基本属性的模型：minimum、maximum、value 和 extent。

参数类型为 BoundedRangeModel 的 javax.swing 中的构造方法
JProgressBar(BoundedRangeModel newModel)
创建使用指定的保存进度条数据模型的水平进度条。
JSlider(BoundedRangeModel brm)
使用指定的 BoundedRangeModel 创建一个水平滑块。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JScrollBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollBar
的使用

使用 JScrollBar 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JScrollBar 的使用

javax.swing 中 JScrollBar 的子类
protected  class JScrollPane.ScrollBar
默认情况下，JScrollPane 创建的滚动条为此类的实例。

声明为 JScrollBar 的 javax.swing 中的字段
protected JScrollBar | JScrollPane.horizontalScrollBar 滚动窗格的水平滚动条子级。
protected JScrollBar | ScrollPaneLayout.hsb 滚动窗格的子级水平滚动条。
protected JScrollBar | JScrollPane.verticalScrollBar 滚动窗格的垂直滚动条子级。
protected JScrollBar | ScrollPaneLayout.vsb 滚动窗格的子级垂直滚动条。

返回 JScrollBar 的 javax.swing 中的方法
JScrollBar | JScrollPane.createHorizontalScrollBar() 默认返回 JScrollPane.ScrollBar。
JScrollBar | JScrollPane.createVerticalScrollBar() 默认返回 JScrollPane.ScrollBar。
JScrollBar | ScrollPaneLayout.getHorizontalScrollBar() 返回处理水平滚动的 JScrollBar 对象。
JScrollBar | JScrollPane.getHorizontalScrollBar() 返回控制视口的水平视图位置的水平滚动条。
JScrollBar | ScrollPaneLayout.getVerticalScrollBar() 返回处理垂直滚动的 JScrollBar 对象。
JScrollBar | JScrollPane.getVerticalScrollBar() 返回控制视口垂直视图位置的垂直滚动条。

参数类型为 JScrollBar 的 javax.swing 中的方法
void | JScrollPane.setHorizontalScrollBar(JScrollBar horizontalScrollBar) 将控制视口水平视图位置的水平滚动条添加到滚动窗格中。
void | JScrollPane.setVerticalScrollBar(JScrollBar verticalScrollBar) 将控制视口垂直视图位置的滚动条添加到滚动窗格中。

javax.swing.plaf.basic 中 JScrollBar 的使用

声明为 JScrollBar 的 javax.swing.plaf.basic 中的字段
protected JScrollBar | BasicScrollBarUI.scrollbar
protected JScrollBar | BasicTreeUI.ComponentHandler.scrollBar 正在调整的 scrollBar。

参数类型为 JScrollBar 的 javax.swing.plaf.basic 中的方法
protected void | BasicScrollBarUI.layoutHScrollbar(JScrollBar sb)
protected void | BasicScrollBarUI.layoutVScrollbar(JScrollBar sb)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JScrollBar.AccessibleJScrollBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JScrollBar.AccessibleJScrollBar
的使用

没有 javax.swing.JScrollBar.AccessibleJScrollBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JComboBox 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComboBox
的使用

使用 JComboBox 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 JComboBox 的使用

参数类型为 JComboBox 的 javax.swing 中的构造方法
DefaultCellEditor(JComboBox comboBox)
构造一个使用组合框的 DefaultCellEditor 对象。

javax.swing.plaf 中 JComboBox 的使用

参数类型为 JComboBox 的 javax.swing.plaf 中的方法
abstract boolean | ComboBoxUI.isFocusTraversable(JComboBox c) 确定组合框本身是否是可遍历的
abstract boolean | ComboBoxUI.isPopupVisible(JComboBox c) 确定弹出窗口的可见性
abstract void | ComboBoxUI.setPopupVisible(JComboBox c, boolean v) 设置弹出菜单的可见性

javax.swing.plaf.basic 中 JComboBox 的使用

声明为 JComboBox 的 javax.swing.plaf.basic 中的字段
protected JComboBox | BasicComboPopup.comboBox
protected JComboBox | BasicComboBoxUI.comboBox

参数类型为 JComboBox 的 javax.swing.plaf.basic 中的方法
boolean | BasicComboBoxUI.isFocusTraversable(JComboBox c) 确定 JComboBox 是否是可焦点遍历的。
boolean | BasicComboBoxUI.isPopupVisible(JComboBox c) 告知弹出控件是否可见。
void | BasicComboBoxUI.setPopupVisible(JComboBox c, boolean v) 隐藏弹出部分。

参数类型为 JComboBox 的 javax.swing.plaf.basic 中的构造方法
BasicComboPopup(JComboBox combo)

javax.swing.plaf.metal 中 JComboBox 的使用

声明为 JComboBox 的 javax.swing.plaf.metal 中的字段
protected  JComboBox MetalComboBoxButton.comboBox

返回 JComboBox 的 javax.swing.plaf.metal 中的方法
 JComboBox MetalComboBoxButton.getComboBox()

参数类型为 JComboBox 的 javax.swing.plaf.metal 中的方法
 void MetalComboBoxButton.setComboBox(JComboBox cb)

参数类型为 JComboBox 的 javax.swing.plaf.metal 中的构造方法
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)
MetalComboBoxUI.MetalComboPopup(JComboBox cBox)
已过时。

javax.swing.plaf.multi 中 JComboBox 的使用

参数类型为 JComboBox 的 javax.swing.plaf.multi 中的方法
boolean | MultiComboBoxUI.isFocusTraversable(JComboBox a) 在由此对象处理的每个 UI 上调用 isFocusTraversable 方法。
boolean | MultiComboBoxUI.isPopupVisible(JComboBox a) 在由此对象处理的每个 UI 上调用 isPopupVisible 方法。
void | MultiComboBoxUI.setPopupVisible(JComboBox a, boolean b) 在由此对象处理的每个 UI 上调用 setPopupVisible 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.JComboBox.KeySelectionManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.JComboBox.KeySelectionManager
的使用

使用 JComboBox.KeySelectionManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JComboBox.KeySelectionManager 的使用

声明为 JComboBox.KeySelectionManager 的 javax.swing 中的字段
protected  JComboBox.KeySelectionManager JComboBox.keySelectionManager
此受保护字段是特定于实现的。

返回 JComboBox.KeySelectionManager 的 javax.swing 中的方法
protected JComboBox.KeySelectionManager | JComboBox.createDefaultKeySelectionManager() 返回默认键选择管理器的实例。
JComboBox.KeySelectionManager | JComboBox.getKeySelectionManager() 返回列表的键选择管理器。

参数类型为 JComboBox.KeySelectionManager 的 javax.swing 中的方法
 void JComboBox.setKeySelectionManager(JComboBox.KeySelectionManager aManager)
设置将键盘字符转换为列表选择的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JComboBox.AccessibleJComboBox 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComboBox.AccessibleJComboBox
的使用

没有 javax.swing.JComboBox.AccessibleJComboBox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSeparator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSeparator
的使用

使用 JSeparator 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JSeparator 的使用

javax.swing 中 JSeparator 的子类
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。

javax.swing.plaf.basic 中 JSeparator 的使用

参数类型为 JSeparator 的 javax.swing.plaf.basic 中的方法
protected void | BasicToolBarSeparatorUI.installDefaults(JSeparator s)
protected void | BasicSeparatorUI.installDefaults(JSeparator s)
protected void | BasicSeparatorUI.installListeners(JSeparator s)
protected void | BasicSeparatorUI.uninstallDefaults(JSeparator s)
protected void | BasicSeparatorUI.uninstallListeners(JSeparator s)

javax.swing.plaf.metal 中 JSeparator 的使用

参数类型为 JSeparator 的 javax.swing.plaf.metal 中的方法
protected  void MetalSeparatorUI.installDefaults(JSeparator s)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSeparator.AccessibleJSeparator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSeparator.AccessibleJSeparator
的使用

没有 javax.swing.JSeparator.AccessibleJSeparator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.MenuSelectionManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.MenuSelectionManager
的使用

使用 MenuSelectionManager 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 MenuSelectionManager 的使用

返回 MenuSelectionManager 的 javax.swing 中的方法
static MenuSelectionManager MenuSelectionManager.defaultManager()
返回默认菜单选项管理器。

参数类型为 MenuSelectionManager 的 javax.swing 中的方法
void | JPopupMenu.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | JMenuBar.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | MenuElement.processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager) 处理键事件。
void | JPopupMenu.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 要求此方法遵守 MenuElement 接口，但它没有被实现。
void | JMenuBar.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
void | MenuElement.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 处理鼠标事件。

javax.swing.event 中 MenuSelectionManager 的使用

返回 MenuSelectionManager 的 javax.swing.event 中的方法
MenuSelectionManager | MenuDragMouseEvent.getMenuSelectionManager() 返回当前菜单选项管理器。
MenuSelectionManager | MenuKeyEvent.getMenuSelectionManager() 返回当前菜单选项管理器。

参数类型为 MenuSelectionManager 的 javax.swing.event 中的构造方法
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuKeyEvent 对象。

javax.swing.plaf.basic 中 MenuSelectionManager 的使用

参数类型为 MenuSelectionManager 的 javax.swing.plaf.basic 中的方法
protected void | BasicMenuItemUI.doClick(MenuSelectionManager msm) 要激活菜单项时调用此方法。
void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JPopupMenu 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPopupMenu
的使用

使用 JPopupMenu 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 JPopupMenu 的使用

返回 JPopupMenu 的 javax.swing 中的方法
JPopupMenu | JComponent.getComponentPopupMenu() 返回为此组件分配的 JPopupMenu。
JPopupMenu | JMenu.getPopupMenu() 返回与此菜单关联的弹出菜单。

参数类型为 JPopupMenu 的 javax.swing 中的方法
protected JMenu.WinListener | JMenu.createWinListener(JPopupMenu p) 创建弹出菜单的窗口关闭侦听器。
void | JComponent.setComponentPopupMenu(JPopupMenu popup) 设置此 JComponent 的 JPopupMenu。

参数类型为 JPopupMenu 的 javax.swing 中的构造方法
JMenu.WinListener(JPopupMenu p)
创建指定弹出菜单的窗口侦听器。

javax.swing.plaf 中 JPopupMenu 的使用

参数类型为 JPopupMenu 的 javax.swing.plaf 中的方法
 Popup PopupMenuUI.getPopup(JPopupMenu popup, int x, int y)
返回将负责显示 JPopupMenu 的 Popup。

javax.swing.plaf.basic 中 JPopupMenu 的使用

javax.swing.plaf.basic 中 JPopupMenu 的子类
 class BasicComboPopup
此为 ComboPopup 接口的基本实现。

声明为 JPopupMenu 的 javax.swing.plaf.basic 中的字段
protected  JPopupMenu BasicPopupMenuUI.popupMenu

javax.swing.plaf.metal 中 JPopupMenu 的使用

javax.swing.plaf.metal 中 JPopupMenu 的子类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

javax.swing.plaf.multi 中 JPopupMenu 的使用

参数类型为 JPopupMenu 的 javax.swing.plaf.multi 中的方法
 Popup MultiPopupMenuUI.getPopup(JPopupMenu a, int b, int c)
在由此对象处理的每个 UI 上调用 getPopup 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JPopupMenu.AccessibleJPopupMenu 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPopupMenu.AccessibleJPopupMenu
的使用

没有 javax.swing.JPopupMenu.AccessibleJPopupMenu 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JPopupMenu.Separator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPopupMenu.Separator
的使用

没有 javax.swing.JPopupMenu.Separator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultSingleSelectionModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultSingleSelectionModel
的使用

没有 javax.swing.DefaultSingleSelectionModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.SingleSelectionModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.SingleSelectionModel
的使用

使用 SingleSelectionModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SingleSelectionModel 的使用

实现 SingleSelectionModel 的 javax.swing 中的类
 class DefaultSingleSelectionModel
SingleSelectionModel 的一般实现。

声明为 SingleSelectionModel 的 javax.swing 中的字段
protected  SingleSelectionModel JTabbedPane.model
默认的选择模型。

返回 SingleSelectionModel 的 javax.swing 中的方法
SingleSelectionModel | JTabbedPane.getModel() 返回与此选项卡窗格关联的模型。
SingleSelectionModel | JPopupMenu.getSelectionModel() 返回处理单个选择的模型对象。
SingleSelectionModel | JMenuBar.getSelectionModel() 返回处理单个选择的模型对象。

参数类型为 SingleSelectionModel 的 javax.swing 中的方法
void | JTabbedPane.setModel(SingleSelectionModel model) 设置要用于此选项卡窗格的模型。
void | JPopupMenu.setSelectionModel(SingleSelectionModel model) 设置处理单个选择的模型对象。
void | JMenuBar.setSelectionModel(SingleSelectionModel model) 设置处理单个选择的模型对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JMenuBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenuBar
的使用

使用 JMenuBar 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JMenuBar 的使用

声明为 JMenuBar 的 javax.swing 中的字段
protected  JMenuBar JRootPane.menuBar
菜单栏。

返回 JMenuBar 的 javax.swing 中的方法
 JMenuBar JApplet.getJMenuBar()
返回此 applet 上的菜单栏设置。
 JMenuBar JDialog.getJMenuBar()
返回此对话框上设置的菜单栏。
 JMenuBar JInternalFrame.getJMenuBar()
返回此 JInternalFrame 的当前 JMenuBar；如果尚未设置菜单栏，则返回 null。
 JMenuBar JRootPane.getJMenuBar()
返回窗格层的菜单栏。
 JMenuBar JFrame.getJMenuBar()
返回此窗体上设置的菜单栏。
 JMenuBar JInternalFrame.getMenuBar()
已过时。 从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。
 JMenuBar JRootPane.getMenuBar()
已过时。 从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。

参数类型为 JMenuBar 的 javax.swing 中的方法
void | JApplet.setJMenuBar(JMenuBar menuBar) 设置此 applet 的菜单栏。
void | JDialog.setJMenuBar(JMenuBar menu) 设置此对话框的菜单栏。
void | JInternalFrame.setJMenuBar(JMenuBar m) 设置此 JInternalFrame 的 menuBar 属性。
void | JRootPane.setJMenuBar(JMenuBar menu) 添加或更改在分层窗格中使用的菜单栏。
void | JFrame.setJMenuBar(JMenuBar menubar) 设置此窗体的菜单栏。
void | JInternalFrame.setMenuBar(JMenuBar m) 已过时。 从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。
void | JRootPane.setMenuBar(JMenuBar menu) 已过时。 从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。

javax.swing.plaf.basic 中 JMenuBar 的使用

javax.swing.plaf.basic 中 JMenuBar 的子类
 class BasicInternalFrameTitlePane.SystemMenuBar
此类应视为“受保护”内部类。

声明为 JMenuBar 的 javax.swing.plaf.basic 中的字段
protected JMenuBar | BasicInternalFrameTitlePane.menuBar
protected JMenuBar | BasicMenuBarUI.menuBar

返回 JMenuBar 的 javax.swing.plaf.basic 中的方法
protected  JMenuBar BasicInternalFrameTitlePane.createSystemMenuBar()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JMenuBar.AccessibleJMenuBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenuBar.AccessibleJMenuBar
的使用

没有 javax.swing.JMenuBar.AccessibleJMenuBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.BoxLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.BoxLayout
的使用

使用 BoxLayout 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 BoxLayout 的使用

javax.swing.plaf.basic 中 BoxLayout 的子类
 class DefaultMenuLayout
Popup 菜单和菜单栏的默认布局管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.Box 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Box
的使用

使用 Box 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Box 的使用

返回 Box 的 javax.swing 中的方法
static Box | Box.createHorizontalBox() 创建一个从左到右显示其组件的 Box。
static Box | Box.createVerticalBox() 创建一个从上到下显示其组件的 Box。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.Box.Filler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Box.Filler
的使用

没有 javax.swing.Box.Filler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.Box.Filler.AccessibleBoxFiller 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Box.Filler.AccessibleBoxFiller
的使用

没有 javax.swing.Box.Filler.AccessibleBoxFiller 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.Box.AccessibleBox 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Box.AccessibleBox
的使用

没有 javax.swing.Box.AccessibleBox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ButtonGroup 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ButtonGroup
的使用

使用 ButtonGroup 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ButtonGroup 的使用

声明为 ButtonGroup 的 javax.swing 中的字段
protected  ButtonGroup DefaultButtonModel.group
按钮所属的按钮组。

返回 ButtonGroup 的 javax.swing 中的方法
 ButtonGroup DefaultButtonModel.getGroup()
返回该按钮所属的组。

参数类型为 ButtonGroup 的 javax.swing 中的方法
void | DefaultButtonModel.setGroup(ButtonGroup group) 标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。
void | ButtonModel.setGroup(ButtonGroup group) 标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.DefaultButtonModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.DefaultButtonModel
的使用

使用 DefaultButtonModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultButtonModel 的使用

javax.swing 中 DefaultButtonModel 的子类
static class JToggleButton.ToggleButtonModel
ToggleButton 模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.ButtonModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.ButtonModel
的使用

使用 ButtonModel 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ButtonModel 的使用

实现 ButtonModel 的 javax.swing 中的类
class | DefaultButtonModel Button 组件的数据模型的默认实现。
static class | JToggleButton.ToggleButtonModel ToggleButton 模型。

声明为 ButtonModel 的 javax.swing 中的字段
protected  ButtonModel AbstractButton.model
确定按钮状态的数据模型。

返回 ButtonModel 的 javax.swing 中的方法
ButtonModel | AbstractButton.getModel() 返回此按钮表示的模型。
ButtonModel | ButtonGroup.getSelection() 返回选择按钮的模型。

参数类型为 ButtonModel 的 javax.swing 中的方法
boolean | ButtonGroup.isSelected(ButtonModel m) 返回对是否已选择一个 ButtonModel 的判断。
void | JMenu.setModel(ButtonModel newModel) 设置“菜单按钮”的数据模型，即用户单击可以打开或关闭菜单的标签。
void | JMenuItem.setModel(ButtonModel newModel) 设置此按钮表示的模型。
void | AbstractButton.setModel(ButtonModel newModel) 设置此按钮表示的模型。
void | ButtonGroup.setSelected(ButtonModel m, boolean b) 为 ButtonModel 设置选择值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JToggleButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToggleButton
的使用

使用 JToggleButton 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JToggleButton 的使用

javax.swing 中 JToggleButton 的子类
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JToggleButton.ToggleButtonModel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToggleButton.ToggleButtonModel
的使用

没有 javax.swing.JToggleButton.ToggleButtonModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JToggleButton.AccessibleJToggleButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToggleButton.AccessibleJToggleButton
的使用

使用 JToggleButton.AccessibleJToggleButton 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JToggleButton.AccessibleJToggleButton 的使用

javax.swing 中 JToggleButton.AccessibleJToggleButton 的子类
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSplitPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSplitPane
的使用

使用 JSplitPane 的软件包
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf 中 JSplitPane 的使用

参数类型为 JSplitPane 的 javax.swing.plaf 中的方法
abstract void | SplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g) 在 JSplitPane 接收方提供外观来绘制其子组件之后传递消息。
abstract int | SplitPaneUI.getDividerLocation(JSplitPane jc) 返回分隔符的位置。
abstract int | SplitPaneUI.getMaximumDividerLocation(JSplitPane jc) 返回分隔符的最大可能位置。
abstract int | SplitPaneUI.getMinimumDividerLocation(JSplitPane jc) 返回分隔符的最小可能位置。
abstract void | SplitPaneUI.resetToPreferredSizes(JSplitPane jc) 传递消息，以便基于子组件的首选大小重新布置 JSplitPane。
abstract void | SplitPaneUI.setDividerLocation(JSplitPane jc, int location) 将分隔符的位置设置到 location。

javax.swing.plaf.basic 中 JSplitPane 的使用

声明为 JSplitPane 的 javax.swing.plaf.basic 中的字段
protected JSplitPane | BasicSplitPaneDivider.splitPane 其中包含接收者的 JSplitPane。
protected JSplitPane | BasicSplitPaneUI.splitPane 此实例为其提供外观的 JSplitPane 实例。

返回 JSplitPane 的 javax.swing.plaf.basic 中的方法
 JSplitPane BasicSplitPaneUI.getSplitPane()
返回当前包含此实例的拆分窗格。

参数类型为 JSplitPane 的 javax.swing.plaf.basic 中的方法
void | BasicSplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g) 在 JSplitPane 接收者将为绘制其子级提供外观后传递消息。
int | BasicSplitPaneUI.getDividerLocation(JSplitPane jc) 返回分隔符的位置，该位置可能不同于拆分窗格认为分隔符所在的位置。
int | BasicSplitPaneUI.getMaximumDividerLocation(JSplitPane jc) 获取分隔符的最大位置。
int | BasicSplitPaneUI.getMinimumDividerLocation(JSplitPane jc) 获取分隔符的最小位置。
void | BasicSplitPaneUI.resetToPreferredSizes(JSplitPane jc) 传递消息以重置首选大小。
void | BasicSplitPaneUI.setDividerLocation(JSplitPane jc, int location) 将分隔符的位置设置到 location。

javax.swing.plaf.multi 中 JSplitPane 的使用

参数类型为 JSplitPane 的 javax.swing.plaf.multi 中的方法
void | MultiSplitPaneUI.finishedPaintingChildren(JSplitPane a, Graphics b) 在由此对象处理的每个 UI 上调用 finishedPaintingChildren 方法。
int | MultiSplitPaneUI.getDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getDividerLocation 方法。
int | MultiSplitPaneUI.getMaximumDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getMaximumDividerLocation 方法。
int | MultiSplitPaneUI.getMinimumDividerLocation(JSplitPane a) 在由此对象处理的每个 UI 上调用 getMinimumDividerLocation 方法。
void | MultiSplitPaneUI.resetToPreferredSizes(JSplitPane a) 在由此对象处理的每个 UI 上调用 resetToPreferredSizes 方法。
void | MultiSplitPaneUI.setDividerLocation(JSplitPane a, int b) 在由此对象处理的每个 UI 上调用 setDividerLocation 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JSplitPane.AccessibleJSplitPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JSplitPane.AccessibleJSplitPane
的使用

没有 javax.swing.JSplitPane.AccessibleJSplitPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JToolBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolBar
的使用

使用 JToolBar 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.basic 中 JToolBar 的使用

声明为 JToolBar 的 javax.swing.plaf.basic 中的字段
protected JToolBar | BasicToolBarUI.toolBar
protected JToolBar | BasicToolBarUI.DockingListener.toolBar

参数类型为 JToolBar 的 javax.swing.plaf.basic 中的方法
protected  BasicToolBarUI.DragWindow BasicToolBarUI.createDragWindow(JToolBar toolbar)
protected  JFrame BasicToolBarUI.createFloatingFrame(JToolBar toolbar)
不再使用，使用 BasicToolBarUI.createFloatingWindow(JToolBar)
protected  RootPaneContainer BasicToolBarUI.createFloatingWindow(JToolBar toolbar)
创建将工具栏拖出其容器后包含该工具栏的窗口

参数类型为 JToolBar 的 javax.swing.plaf.basic 中的构造方法
BasicToolBarUI.DockingListener(JToolBar t)

javax.swing.plaf.metal 中 JToolBar 的使用

参数类型为 JToolBar 的 javax.swing.plaf.metal 中的构造方法
MetalToolBarUI.MetalDockingListener(JToolBar t)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JToolBar.Separator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolBar.Separator
的使用

没有 javax.swing.JToolBar.Separator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JToolBar.AccessibleJToolBar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JToolBar.AccessibleJToolBar
的使用

没有 javax.swing.JToolBar.AccessibleJToolBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.Action 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.Action
的使用

使用 Action 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 Action 的使用

实现 Action 的 javax.swing 中的类
 class AbstractAction
此类提供 JFC Action 接口的默认实现。

返回 Action 的 javax.swing 中的方法
Action | ActionMap.get(Object key) 返回 key 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 ActionMap。
Action | JTextField.getAction() 返回此 ActionEvent 源当前设置的 Action，如果没有设置 Action 则返回 null。
Action | JComboBox.getAction() 返回此 ActionEvent 源当前设置的 Action，如果没有设置任何 Action，则返回 null。
Action | AbstractButton.getAction() 返回当前为此 ActionEvent 源设置的 Action，如果没有设置任何 Action，则返回 null。
Action[] | JFormattedTextField.getActions() 获取编辑器的命令列表。
protected Action[] | JFormattedTextField.AbstractFormatter.getActions() 如果想提供自定义的 Action 集合，则应进行子类化和重写。
Action[] | JTextField.getActions() 获取编辑器的命令列表。
static Action | TransferHandler.getCopyAction() 返回一个执行复制到剪贴板操作的 Action。
static Action | TransferHandler.getCutAction() 返回一个执行剪切到剪贴板操作的 Action。
static Action | TransferHandler.getPasteAction() 返回一个从剪贴板执行粘贴操作的 Action。

参数类型为 Action 的 javax.swing 中的方法
protected void | JTextField.actionPropertyChanged(Action action, String propertyName) 更新文本字段的状态以响应关联动作中的属性更改。
protected void | JComboBox.actionPropertyChanged(Action action, String propertyName) 更新组合框的状态以响应关联动作中的属性更改。
protected void | JMenuItem.actionPropertyChanged(Action action, String propertyName) 更新按钮的状态以响应相关的操作中的属性更改。
protected void | AbstractButton.actionPropertyChanged(Action action, String propertyName) 更新按钮的状态以响应相关的操作中的属性更改。
JMenuItem | JPopupMenu.add(Action a) 将指派指定 Action 对象的新菜单项添加到菜单的末尾。
JButton | JToolBar.add(Action a) 添加一个指派动作的新的 JButton。
JMenuItem | JMenu.add(Action a) 创建连接到指定 Action 对象的新菜单项，并将其追加到此菜单的末尾。
protected void | JTextField.configurePropertiesFromAction(Action a) 在此文本字段上设置属性，以匹配指定 Action 中的值。
protected void | JComboBox.configurePropertiesFromAction(Action a) 在此组合框上设置属性以匹配指定 Action 中的属性。
protected void | JMenuItem.configurePropertiesFromAction(Action a) 在此按钮上设置属性以匹配指定 Action 中的属性。
protected void | AbstractButton.configurePropertiesFromAction(Action a) 在此按钮上设置属性以匹配指定 Action 中的属性。
protected JMenuItem | JPopupMenu.createActionComponent(Action a) 该工厂方法为添加到 JPopupMenu 的 Action 创建对应的 JMenuItem。
protected JButton | JToolBar.createActionComponent(Action a) 将为 Action 创建 JButton 的工厂方法添加到 JToolBar 中。
protected JMenuItem | JMenu.createActionComponent(Action a) 该工厂方法创建添加到 JMenu 的 Action 的 JMenuItem。
protected PropertyChangeListener | JTextField.createActionPropertyChangeListener(Action a) 创建并返回一个负责侦听指定 Action 的更改以及更新适当属性的 PropertyChangeListener。
protected PropertyChangeListener | JComboBox.createActionPropertyChangeListener(Action a) 创建并返回一个 PropertyChangeListener，它负责侦听指定 Action 的更改并更新适当属性。
protected PropertyChangeListener | AbstractButton.createActionPropertyChangeListener(Action a) 创建并返回 PropertyChangeListener，它负责侦听指定 Action 的更改以及更新适当的属性。
void | JPopupMenu.insert(Action a, int index) 在给定位置插入指定 Action 对象的菜单项。
JMenuItem | JMenu.insert(Action a, int pos) 在给定位置插入连接到指定 Action 对象的新菜单项。
static boolean | SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers) 如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
void | ActionMap.put(Object key, Action action) 添加一个 key 到 action 的绑定。
void | JTextField.setAction(Action a) 设置 ActionEvent 源的 Action。
void | JComboBox.setAction(Action a) 设置 ActionEvent 源的 Action。
void | AbstractButton.setAction(Action a) 设置 Action。

参数类型为 Action 的 javax.swing 中的构造方法
JButton(Action a)
创建一个按钮，其属性从所提供的 Action 中获取。
JCheckBox(Action a)
创建一个复选框，其属性从所提供的 Action 获取。
JCheckBoxMenuItem(Action a)
创建一个从所提供的 Action 中获取其属性的菜单项。
JMenu(Action a)
构造一个从提供的 Action 获取其属性的菜单。
JMenuItem(Action a)
创建从指定的 Action 获取其属性的菜单项。
JRadioButton(Action a)
创建一个单选按钮，其属性来自提供的 Action。
JRadioButtonMenuItem(Action a)
创建一个单选按钮菜单项，其属性来自提供的 Action。
JToggleButton(Action a)
创建一个切换按钮，其属性从所提供的 Action 获取。

javax.swing.plaf.basic 中 Action 的使用

实现 Action 的 javax.swing.plaf.basic 中的类
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

声明为 Action 的 javax.swing.plaf.basic 中的字段
protected Action | BasicInternalFrameTitlePane.closeAction
protected Action | BasicInternalFrameTitlePane.iconifyAction
protected Action | BasicInternalFrameTitlePane.maximizeAction
protected Action | BasicInternalFrameTitlePane.moveAction
protected Action | BasicTreeUI.KeyHandler.repeatKeyAction 正在生成的键代码。
protected Action | BasicInternalFrameTitlePane.restoreAction
protected Action | BasicInternalFrameTitlePane.sizeAction

返回 Action 的 javax.swing.plaf.basic 中的方法
protected Action | BasicLookAndFeel.createAudioAction(Object key) 创建并返回用于播放音频的 Action。
Action | BasicFileChooserUI.getApproveSelectionAction()
Action | BasicFileChooserUI.getCancelSelectionAction()
Action | BasicFileChooserUI.getChangeToParentDirectoryAction()
Action | BasicFileChooserUI.getGoHomeAction()
Action | BasicFileChooserUI.getNewFolderAction()
Action | BasicFileChooserUI.getUpdateAction()

参数类型为 Action 的 javax.swing.plaf.basic 中的方法
protected  void BasicLookAndFeel.playSound(Action audioAction)
如有必要，在 audioAction 上调用 actionPerformed 以播放声音。

javax.swing.plaf.metal 中 Action 的使用

实现 Action 的 javax.swing.plaf.metal 中的类
protected  class MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

javax.swing.text 中 Action 的使用

实现 Action 的 javax.swing.text 中的类
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

返回 Action 的 javax.swing.text 中的方法
static Action[] | TextAction.augmentList(Action[] list1, Action[] list2) 取一个命令列表并用另一个命令列表去扩充。
Action | Keymap.getAction(KeyStroke key) 获取适合于给定符号事件序列的操作。
protected Action[] | InternationalFormatter.getActions() 如果 getSupportsIncrement 返回 true，则这将返回两个适合增加/减少该值的 Action。
Action[] | StyledEditorKit.getActions() 获取编辑器的命令列表。
Action[] | DefaultEditorKit.getActions() 获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
abstract Action[] | EditorKit.getActions() 获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
Action[] | JTextComponent.getActions() 获取编辑器的命令列表。
Action[] | Keymap.getBoundActions() 获取在此 keymap 中定义的所有操作。
Action | Keymap.getDefaultAction() 当击键（即接收 KEY_TYPED KeyEvent）且该键没有绑定操作的情况下获取激发的默认操作。

参数类型为 Action 的 javax.swing.text 中的方法
void | Keymap.addActionForKeyStroke(KeyStroke key, Action a) 向 keymap 添加绑定。
static Action[] | TextAction.augmentList(Action[] list1, Action[] list2) 取一个命令列表并用另一个命令列表去扩充。
static Action[] | TextAction.augmentList(Action[] list1, Action[] list2) 取一个命令列表并用另一个命令列表去扩充。
KeyStroke[] | Keymap.getKeyStrokesForAction(Action a) 获取将导致给定操作的击键。
static void | JTextComponent.loadKeymap(Keymap map, JTextComponent.KeyBinding[] bindings, Action[] actions) 加载带有一组绑定的 keymap。
void | Keymap.setDefaultAction(Action a) 在进行击键的情况下设置要激发的默认操作。

javax.swing.text.html 中 Action 的使用

实现 Action 的 javax.swing.text.html 中的类
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

返回 Action 的 javax.swing.text.html 中的方法
 Action[] HTMLEditorKit.getActions()
获取编辑器的命令列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ToolTipManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ToolTipManager
的使用

使用 ToolTipManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 ToolTipManager 的使用

返回 ToolTipManager 的 javax.swing 中的方法
static ToolTipManager ToolTipManager.sharedInstance()
返回共享的 ToolTipManager 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ToolTipManager.insideTimerAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ToolTipManager.insideTimerAction
的使用

没有 javax.swing.ToolTipManager.insideTimerAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ToolTipManager.outsideTimerAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ToolTipManager.outsideTimerAction
的使用

没有 javax.swing.ToolTipManager.outsideTimerAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.Timer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.Timer
的使用

使用 Timer 的软件包
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing.plaf.basic 中 Timer 的使用

声明为 Timer 的 javax.swing.plaf.basic 中的字段
protected Timer | BasicComboPopup.autoscrollTimer 此受保护字段是特定于实现的。
protected Timer | BasicSliderUI.scrollTimer
protected Timer | BasicScrollBarUI.scrollTimer
protected Timer | BasicTreeUI.ComponentHandler.timer 在滚动窗格中调整滚动条时使用的 Timer。

javax.swing.tree 中 Timer 的使用

声明为 Timer 的 javax.swing.tree 中的字段
protected  Timer DefaultTreeCellEditor.timer
在启动编辑会话之前使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.Icon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.Icon
的使用

使用 Icon 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 Icon 的使用

实现 Icon 的 javax.swing 中的类
 class ImageIcon
一个 Icon 接口的实现，它根据 Image 绘制 Icon。

声明为 Icon 的 javax.swing 中的字段
protected Icon | JInternalFrame.frameIcon 此内部窗体左上角显示的图标。
protected Icon | JOptionPane.icon 在窗格中使用的图标。

返回 Icon 的 javax.swing 中的方法
Icon | AbstractButton.getDisabledIcon() 返回禁用按钮时按钮使用的图标。
Icon | JLabel.getDisabledIcon() 返回该标签被禁用时所使用的图标。
Icon | LookAndFeel.getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | JTabbedPane.getDisabledIconAt(int index) 返回 index 位置的选项卡禁用图标。
Icon | AbstractButton.getDisabledSelectedIcon() 返回禁用并选择按钮时按钮使用的图标。
Icon | LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
Icon | JInternalFrame.getFrameIcon() 返回要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
Icon | JOptionPane.getIcon() 返回此窗格显示的图标。
Icon | AbstractButton.getIcon() 返回默认图标。
Icon | JLabel.getIcon() 返回该标签显示的图形图像（字形、图标）。
Icon | JFileChooser.getIcon(File f) 返回此文件或文件类型的图标，这取决于系统。
Icon | UIDefaults.getIcon(Object key) 如果 key 值为一个 Icon，则返回该 Icon，否则返回 null。
static Icon | UIManager.getIcon(Object key) 从默认值中返回一个 Icon。
Icon | UIDefaults.getIcon(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。
static Icon | UIManager.getIcon(Object key, Locale l) 从适合给定语言环境的默认值中返回一个 Icon。
Icon | JTabbedPane.getIconAt(int index) 返回 index 位置的选项卡图标。
Icon | AbstractButton.getPressedIcon() 返回按钮的按下图标。
Icon | AbstractButton.getRolloverIcon() 返回按钮的翻转图标。
Icon | AbstractButton.getRolloverSelectedIcon() 返回按钮的翻转选定图标。
Icon | AbstractButton.getSelectedIcon() 返回按钮的选择图标。
Icon | TransferHandler.getVisualRepresentation(Transferable t) 返回一个建立传输外观的对象。

参数类型为 Icon 的 javax.swing 中的方法
 void JTabbedPane.addTab(String title, Icon icon, Component component)
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。
 void JTabbedPane.addTab(String title, Icon icon, Component component, String tip)
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。
static MatteBorder BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
创建一个由多层指定图标组成的、类似衬边的边框。
 Icon LookAndFeel.getDisabledIcon(JComponent component, Icon icon)
返回具有禁用外观的 Icon。
 Icon LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
返回由选定的禁用组件使用的 Icon。
 int JTabbedPane.indexOfTab(Icon icon)
返回具有给定的 icon 的第一个选项卡索引，如果没有具有此图标的选项卡，则返回 -1。
protected  void JMenuItem.init(String text, Icon icon)
利用指定文本和图标初始化菜单项。
protected  void AbstractButton.init(String text, Icon icon)
 void JTextPane.insertIcon(Icon g)
将一个图标插入文档中，以替换当前选择的内容。
 void JTabbedPane.insertTab(String title, Icon icon, Component component, String tip, int index)
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。
static String SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static String SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
 void AbstractButton.setDisabledIcon(Icon disabledIcon)
设置按钮的禁用图标。
 void JLabel.setDisabledIcon(Icon disabledIcon)
设置如果此 JLabel 是“禁用的”(JLabel.setEnabled(false))，则要显示的图标。
 void JTabbedPane.setDisabledIconAt(int index, Icon disabledIcon)
将 index 位置的禁用图标设置为 icon，它可以为 null。
 void AbstractButton.setDisabledSelectedIcon(Icon disabledSelectedIcon)
设置按钮的禁用选择图标。
 void JInternalFrame.setFrameIcon(Icon icon)
设置要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
 void JOptionPane.setIcon(Icon newIcon)
设置要显示的图标。
 void AbstractButton.setIcon(Icon defaultIcon)
设置按钮的默认图标。
 void JLabel.setIcon(Icon icon)
定义此组件将要显示的图标。
 void JTabbedPane.setIconAt(int index, Icon icon)
将 index 位置的图标设置为 icon，它可以为 null。
 void AbstractButton.setPressedIcon(Icon pressedIcon)
设置按钮的按下图标。
 void AbstractButton.setRolloverIcon(Icon rolloverIcon)
设置按钮的翻转图标。
 void AbstractButton.setRolloverSelectedIcon(Icon rolloverSelectedIcon)
设置按钮的翻转选择图标。
 void AbstractButton.setSelectedIcon(Icon selectedIcon)
设置按钮的选择图标。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
static Object JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。
static Object JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。
static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。
static int JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
static void JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示信息的对话框，为其指定了所有参数。
static int JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

参数类型为 Icon 的 javax.swing 中的构造方法
AbstractAction(String name, Icon icon)
用指定描述字符串和指定图标定义一个 Action 对象。
JButton(Icon icon)
创建一个带图标的按钮。
JButton(String text, Icon icon)
创建一个带初始文本和图标的按钮。
JCheckBox(Icon icon)
创建有一个图标、最初未被选定的复选框。
JCheckBox(Icon icon, boolean selected)
创建一个带图标的复选框，并指定其最初是否处于选定状态。
JCheckBox(String text, Icon icon)
创建带有指定文本和图标的、最初未选定的复选框。
JCheckBox(String text, Icon icon, boolean selected)
创建一个带文本和图标的复选框，并指定其最初是否处于选定状态。
JCheckBoxMenuItem(Icon icon)
创建有一个带图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String text, Icon icon)
创建带有指定文本和图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String text, Icon icon, boolean b)
创建带有指定文本、图标和选择状态的复选框菜单项。
JLabel(Icon image)
创建具有指定图像的 JLabel 实例。
JLabel(Icon image, int horizontalAlignment)
创建具有指定图像和水平对齐方式的 JLabel 实例。
JLabel(String text, Icon icon, int horizontalAlignment)
创建具有指定文本、图像和水平对齐方式的 JLabel 实例。
JMenuItem(Icon icon)
创建带有指定图标的 JMenuItem。
JMenuItem(String text, Icon icon)
创建带有指定文本和图标的 JMenuItem。
JOptionPane(Object message, int messageType, int optionType, Icon icon)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、选项和图标。
JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JRadioButton(Icon icon)
创建一个初始化为未选择的单选按钮，其具有指定的图像但无文本。
JRadioButton(Icon icon, boolean selected)
创建一个具有指定图像和选择状态的单选按钮，但无文本。
JRadioButton(String text, Icon icon)
创建一个具有指定的文本和图像并初始化为未选择的单选按钮。
JRadioButton(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮。
JRadioButtonMenuItem(Icon icon)
创建一个带图标的 JRadioButtonMenuItem。
JRadioButtonMenuItem(Icon icon, boolean selected)
创建一个具有指定图像和选择状态的单选按钮菜单项，但无文本。
JRadioButtonMenuItem(String text, Icon icon)
创建一个具有指定文本和 Icon 的单选按钮菜单项。
JRadioButtonMenuItem(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮菜单项。
JToggleButton(Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的图像但是没有文本。
JToggleButton(Icon icon, boolean selected)
创建具有指定图像和选择状态但没有文本的切换按钮。
JToggleButton(String text, Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的文本和图像。
JToggleButton(String text, Icon icon, boolean selected)
创建具有指定文本、图像和选择状态的切换按钮。

javax.swing.border 中 Icon 的使用

声明为 Icon 的 javax.swing.border 中的字段
protected  Icon MatteBorder.tileIcon

返回 Icon 的 javax.swing.border 中的方法
 Icon MatteBorder.getTileIcon()
返回平铺边框的图标，如果使用了纯色，则返回 null。

参数类型为 Icon 的 javax.swing.border 中的构造方法
MatteBorder(Icon tileIcon)
创建具有指定平铺图标的衬边边框。
MatteBorder(Insets borderInsets, Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。
MatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。

javax.swing.colorchooser 中 Icon 的使用

返回 Icon 的 javax.swing.colorchooser 中的方法
abstract Icon | AbstractColorChooserPanel.getLargeDisplayIcon() 返回此面板的大显示图标。
abstract Icon | AbstractColorChooserPanel.getSmallDisplayIcon() 返回此面板的小图标。

javax.swing.filechooser 中 Icon 的使用

返回 Icon 的 javax.swing.filechooser 中的方法
Icon | FileView.getIcon(File f) 表示 JFileChooser 中此文件的图标。
Icon | FileSystemView.getSystemIcon(File f) 在系统文件浏览器中显示的文件、目录或文件夹的图标。

javax.swing.plaf 中 Icon 的使用

实现 Icon 的 javax.swing.plaf 中的类
 class IconUIResource
实现 UIResource 的 Icon 包装类。

参数类型为 Icon 的 javax.swing.plaf 中的构造方法
BorderUIResource.MatteBorderUIResource(Icon tileIcon)
BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Icon tileIcon)
IconUIResource(Icon delegate)
创建一个 UIResource 图标对象，该对象包装了一个现有 Icon 实例。

javax.swing.plaf.basic 中 Icon 的使用

声明为 Icon 的 javax.swing.plaf.basic 中的字段
protected Icon | BasicMenuItemUI.arrowIcon
protected Icon | BasicMenuItemUI.checkIcon
protected Icon | BasicInternalFrameTitlePane.closeIcon
protected Icon | BasicTreeUI.collapsedIcon
protected Icon | BasicFileChooserUI.computerIcon
protected Icon | BasicFileChooserUI.detailsViewIcon
protected Icon | BasicFileChooserUI.directoryIcon
protected Icon | BasicTreeUI.expandedIcon
protected Icon | BasicFileChooserUI.fileIcon
protected Icon | BasicFileChooserUI.floppyDriveIcon
protected Icon | BasicFileChooserUI.hardDriveIcon
protected Icon | BasicFileChooserUI.homeFolderIcon
protected Icon | BasicRadioButtonUI.icon
protected Icon | BasicInternalFrameTitlePane.iconIcon
protected Icon | BasicFileChooserUI.listViewIcon
protected Icon | BasicInternalFrameTitlePane.maxIcon
protected Icon | BasicInternalFrameTitlePane.minIcon
protected Icon | BasicFileChooserUI.newFolderIcon
protected Icon | BasicFileChooserUI.upFolderIcon

类型参数类型为 Icon 的 javax.swing.plaf.basic 中的字段
protected  Hashtable<File,Icon> BasicFileChooserUI.BasicFileView.iconCache

返回 Icon 的 javax.swing.plaf.basic 中的方法
static Icon | BasicIconFactory.createEmptyFrameIcon()
Icon | BasicFileChooserUI.BasicFileView.getCachedIcon(File f)
static Icon | BasicIconFactory.getCheckBoxIcon()
static Icon | BasicIconFactory.getCheckBoxMenuItemIcon()
Icon | BasicTreeUI.getCollapsedIcon()
Icon | BasicRadioButtonUI.getDefaultIcon()
Icon | BasicTreeUI.getExpandedIcon()
protected Icon | BasicOptionPaneUI.getIcon() 返回来自接收者为其提供外观的 JOptionPane 的图标，或者从 getDefaultIcon 返回的默认图标。
Icon | BasicFileChooserUI.BasicFileView.getIcon(File f)
protected Icon | BasicTabbedPaneUI.getIconForTab(int tabIndex)
protected Icon | BasicOptionPaneUI.getIconForType(int messageType) 返回用于传入类型的图标。
static Icon | BasicIconFactory.getMenuArrowIcon()
static Icon | BasicIconFactory.getMenuItemArrowIcon()
static Icon | BasicIconFactory.getMenuItemCheckIcon()
static Icon | BasicIconFactory.getRadioButtonIcon()
static Icon | BasicIconFactory.getRadioButtonMenuItemIcon()

参数类型为 Icon 的 javax.swing.plaf.basic 中的方法
 void BasicFileChooserUI.BasicFileView.cacheIcon(File f, Icon i)
protected  void BasicTreeUI.drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
protected  Dimension BasicMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
protected  String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
protected  void BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicTabbedPaneUI.paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
protected  void BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
 void BasicTreeUI.setCollapsedIcon(Icon newG)
 void BasicTreeUI.setExpandedIcon(Icon newG)

javax.swing.plaf.metal 中 Icon 的使用

实现 Icon 的 javax.swing.plaf.metal 中的类
class | MetalCheckBoxIcon OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxIcon 此实用工具类绘制指示 MetalComboBox 的水平条
static class | MetalIconFactory.FileIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.FolderIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.PaletteCloseIcon 定义一个用于 Palette 关闭的图标
static class | MetalIconFactory.TreeControlIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeFolderIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeLeafIcon

声明为 Icon 的 javax.swing.plaf.metal 中的字段
protected Icon | MetalComboBoxButton.comboIcon
protected static Icon | MetalSliderUI.horizThumbIcon 默认水平 thumb Icon。
protected Icon | MetalInternalFrameTitlePane.paletteCloseIcon
protected static Icon | MetalSliderUI.vertThumbIcon 默认垂直 thumb Icon。

返回 Icon 的 javax.swing.plaf.metal 中的方法
static Icon | MetalIconFactory.getCheckBoxIcon() 返回一个复选框图标。
static Icon | MetalIconFactory.getCheckBoxMenuItemIcon()
Icon | MetalComboBoxButton.getComboIcon()
Icon | MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
static Icon | MetalIconFactory.getFileChooserDetailViewIcon()
static Icon | MetalIconFactory.getFileChooserHomeFolderIcon()
static Icon | MetalIconFactory.getFileChooserListViewIcon()
static Icon | MetalIconFactory.getFileChooserNewFolderIcon()
static Icon | MetalIconFactory.getFileChooserUpFolderIcon()
static Icon | MetalIconFactory.getHorizontalSliderThumbIcon()
static Icon | MetalIconFactory.getInternalFrameAltMaximizeIcon(int size)
static Icon | MetalIconFactory.getInternalFrameCloseIcon(int size)
static Icon | MetalIconFactory.getInternalFrameDefaultMenuIcon()
static Icon | MetalIconFactory.getInternalFrameMaximizeIcon(int size)
static Icon | MetalIconFactory.getInternalFrameMinimizeIcon(int size)
static Icon | MetalIconFactory.getMenuArrowIcon()
static Icon | MetalIconFactory.getMenuItemArrowIcon()
static Icon | MetalIconFactory.getMenuItemCheckIcon() 返回一个将由 JCheckBoxMenuItem 使用的图标。
static Icon | MetalIconFactory.getRadioButtonIcon()
static Icon | MetalIconFactory.getRadioButtonMenuItemIcon()
static Icon | MetalIconFactory.getTreeComputerIcon()
static Icon | MetalIconFactory.getTreeControlIcon(boolean isCollapsed)
static Icon | MetalIconFactory.getTreeFloppyDriveIcon()
static Icon | MetalIconFactory.getTreeFolderIcon()
static Icon | MetalIconFactory.getTreeHardDriveIcon()
static Icon | MetalIconFactory.getTreeLeafIcon()
static Icon | MetalIconFactory.getVerticalSliderThumbIcon()

参数类型为 Icon 的 javax.swing.plaf.metal 中的方法
Icon | MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
void | MetalComboBoxButton.setComboIcon(Icon i)

参数类型为 Icon 的 javax.swing.plaf.metal 中的构造方法
MetalComboBoxButton(JComboBox cb, Icon i, boolean onlyIcon, CellRendererPane pane, JList list)
MetalComboBoxButton(JComboBox cb, Icon i, CellRendererPane pane, JList list)

javax.swing.plaf.synth 中 Icon 的使用

返回 Icon 的 javax.swing.plaf.synth 中的方法
 Icon SynthStyle.getIcon(SynthContext context, Object key)
获得其值是一个 Icon 的特定样式属性的便捷方法。

参数类型为 Icon 的 javax.swing.plaf.synth 中的方法
Dimension | SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
Dimension | SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。
String | SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset) 绘制图标和文本。

javax.swing.text 中 Icon 的使用

返回 Icon 的 javax.swing.text 中的方法
static Icon StyleConstants.getIcon(AttributeSet a)
从属性列表中获取图标设置。

参数类型为 Icon 的 javax.swing.text 中的方法
static void StyleConstants.setIcon(MutableAttributeSet a, Icon c)
设置图标属性。

javax.swing.text.html 中 Icon 的使用

返回 Icon 的 javax.swing.text.html 中的方法
Icon | ImageView.getLoadingImageIcon() 返回加载图像过程中要使用的图标。
Icon | ImageView.getNoImageIcon() 如果不能找到图像，则返回要使用的图标。

javax.swing.tree 中 Icon 的使用

声明为 Icon 的 javax.swing.tree 中的字段
protected Icon | DefaultTreeCellRenderer.closedIcon 用于显示无扩展的非叶节点的图标。
protected Icon | DefaultTreeCellEditor.editingIcon 编辑时要使用的图标。
protected Icon | DefaultTreeCellRenderer.leafIcon 用于显示叶节点的图标。
protected Icon | DefaultTreeCellRenderer.openIcon 用于显示扩展的非叶节点的图标。

返回 Icon 的 javax.swing.tree 中的方法
Icon | DefaultTreeCellRenderer.getClosedIcon() 返回用于表示没有扩展的非叶节点的图标。
Icon | DefaultTreeCellRenderer.getDefaultClosedIcon() 返回默认图标，对于当前的 laf，它用于表示没有扩展的非叶节点。
Icon | DefaultTreeCellRenderer.getDefaultLeafIcon() 返回默认图标，对于当前的 laf，它用于表示叶节点。
Icon | DefaultTreeCellRenderer.getDefaultOpenIcon() 返回默认图标，对于当前的 laf，它用于表示扩展的非叶节点。
Icon | DefaultTreeCellRenderer.getLeafIcon() 返回用于表示叶节点的图标。
Icon | DefaultTreeCellRenderer.getOpenIcon() 返回用于表示扩展的非叶节点的图标。

参数类型为 Icon 的 javax.swing.tree 中的方法
void | DefaultTreeCellRenderer.setClosedIcon(Icon newIcon) 设置用于表示没有扩展的非叶节点的图标。
void | DefaultTreeCellRenderer.setLeafIcon(Icon newIcon) 设置用于表示叶节点的图标。
void | DefaultTreeCellRenderer.setOpenIcon(Icon newIcon) 设置用于表示扩展的非叶节点的图标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ToolTipManager.stillInsideTimerAction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ToolTipManager.stillInsideTimerAction
的使用

没有 javax.swing.ToolTipManager.stillInsideTimerAction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JDialog 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JDialog
的使用

使用 JDialog 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JDialog 的使用

返回 JDialog 的 javax.swing 中的方法
protected JDialog | JFileChooser.createDialog(Component parent) 创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
JDialog | JOptionPane.createDialog(Component parentComponent, String title) 创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
static JDialog | JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener) 创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
JDialog | JOptionPane.createDialog(String title) 创建并返回一个新的带有指定标题的无父 JDialog。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JDialog.AccessibleJDialog 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JDialog.AccessibleJDialog
的使用

没有 javax.swing.JDialog.AccessibleJDialog 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ImageIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ImageIcon
的使用

没有 javax.swing.ImageIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ImageIcon.AccessibleImageIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ImageIcon.AccessibleImageIcon
的使用

没有 javax.swing.ImageIcon.AccessibleImageIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JButton
的使用

使用 JButton 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JButton 的使用

声明为 JButton 的 javax.swing 中的字段
protected  JButton JRootPane.defaultButton
当窗格成为焦点并有类似按下 Enter 键的特定于 UI 的操作发生时被激活的按钮。

返回 JButton 的 javax.swing 中的方法
JButton | JToolBar.add(Action a) 添加一个指派动作的新的 JButton。
protected JButton | JToolBar.createActionComponent(Action a) 将为 Action 创建 JButton 的工厂方法添加到 JToolBar 中。
JButton | JRootPane.getDefaultButton() 返回 defaultButton 属性的值。

参数类型为 JButton 的 javax.swing 中的方法
protected PropertyChangeListener | JToolBar.createActionChangeListener(JButton b) 返回正确配置的 PropertyChangeListener，它根据 Action 的更改对控件进行更新，如果需要使用默认的属性更改侦听器，则为 null。
void | JRootPane.setDefaultButton(JButton defaultButton) 设置 defaultButton 属性，它确定此 JRootPane 的当前默认按钮。

javax.swing.plaf.basic 中 JButton 的使用

javax.swing.plaf.basic 中 JButton 的子类
 class BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

声明为 JButton 的 javax.swing.plaf.basic 中的字段
protected JButton | BasicComboBoxUI.arrowButton
protected JButton | BasicInternalFrameTitlePane.closeButton
protected JButton | BasicScrollBarUI.decrButton
protected JButton | BasicInternalFrameTitlePane.iconButton
protected JButton | BasicScrollBarUI.incrButton
protected JButton | BasicSplitPaneDivider.leftButton 用于快速切换左边组件的按钮。
protected JButton | BasicInternalFrameTitlePane.maxButton
protected JButton | BasicSplitPaneDivider.rightButton 用于快速切换右边组件的按钮。

返回 JButton 的 javax.swing.plaf.basic 中的方法
protected JButton | BasicComboBoxUI.createArrowButton() 创建一个按钮，将使用它来控制显示或隐藏组合框的弹出部分。
protected JButton | BasicScrollBarUI.createDecreaseButton(int orientation)
protected JButton | BasicScrollBarUI.createIncreaseButton(int orientation)
protected JButton | BasicSplitPaneDivider.createLeftOneTouchButton() 创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的左边组件。
protected JButton | BasicSplitPaneDivider.createRightOneTouchButton() 创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的右边组件。
protected JButton | BasicTabbedPaneUI.createScrollButton(int direction) 创建并返回一个 JButton，它将为用户提供朝某一特定方向滚动选项卡的方式。
protected JButton | BasicFileChooserUI.getApproveButton(JFileChooser fc)

javax.swing.plaf.metal 中 JButton 的使用

javax.swing.plaf.metal 中 JButton 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

返回 JButton 的 javax.swing.plaf.metal 中的方法
protected JButton | MetalComboBoxUI.createArrowButton()
protected JButton | MetalScrollBarUI.createDecreaseButton(int orientation) 返回表示减少量视图的视图。
protected JButton | MetalScrollBarUI.createIncreaseButton(int orientation) 返回表示增加量视图的视图。
protected JButton | MetalFileChooserUI.getApproveButton(JFileChooser fc)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JButton.AccessibleJButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JButton.AccessibleJButton
的使用

没有 javax.swing.JButton.AccessibleJButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JCheckBoxMenuItem 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JCheckBoxMenuItem
的使用

没有 javax.swing.JCheckBoxMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
的使用

没有 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JMenu 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenu
的使用

使用 JMenu 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JMenu 的使用

返回 JMenu 的 javax.swing 中的方法
JMenu | JMenuBar.add(JMenu c) 将指定的菜单追加到菜单栏的末尾。
JMenu | JMenuBar.getHelpMenu() 获取菜单栏的帮助菜单。
JMenu | JMenuBar.getMenu(int index) 返回菜单栏中指定位置的菜单。

参数类型为 JMenu 的 javax.swing 中的方法
JMenu | JMenuBar.add(JMenu c) 将指定的菜单追加到菜单栏的末尾。
void | JMenuBar.setHelpMenu(JMenu menu) 设置用户选择菜单栏中的“帮助”选项时显示的帮助菜单。

javax.swing.plaf.basic 中 JMenu 的使用

声明为 JMenu 的 javax.swing.plaf.basic 中的字段
JMenu | BasicMenuUI.ChangeHandler.menu
protected JMenu | BasicInternalFrameTitlePane.windowMenu

返回 JMenu 的 javax.swing.plaf.basic 中的方法
protected  JMenu BasicInternalFrameTitlePane.createSystemMenu()

参数类型为 JMenu 的 javax.swing.plaf.basic 中的方法
protected void | BasicInternalFrameTitlePane.addSystemMenuItems(JMenu systemMenu)
protected void | BasicMenuUI.setupPostTimer(JMenu menu)

参数类型为 JMenu 的 javax.swing.plaf.basic 中的构造方法
BasicMenuUI.ChangeHandler(JMenu m, BasicMenuUI ui)

javax.swing.plaf.metal 中 JMenu 的使用

参数类型为 JMenu 的 javax.swing.plaf.metal 中的方法
protected  void MetalInternalFrameTitlePane.addSystemMenuItems(JMenu systemMenu)
重写父级的方法，使其不执行任何操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JMenu.WinListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenu.WinListener
的使用

使用 JMenu.WinListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JMenu.WinListener 的使用

声明为 JMenu.WinListener 的 javax.swing 中的字段
protected  JMenu.WinListener JMenu.popupListener
弹出菜单的窗口关闭侦听器。

返回 JMenu.WinListener 的 javax.swing 中的方法
protected  JMenu.WinListener JMenu.createWinListener(JPopupMenu p)
创建弹出菜单的窗口关闭侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JMenu.AccessibleJMenu 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenu.AccessibleJMenu
的使用

没有 javax.swing.JMenu.AccessibleJMenu 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JMenuItem 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenuItem
的使用

使用 JMenuItem 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JMenuItem 的使用

javax.swing 中 JMenuItem 的子类
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。

返回 JMenuItem 的 javax.swing 中的方法
JMenuItem | JPopupMenu.add(Action a) 将指派指定 Action 对象的新菜单项添加到菜单的末尾。
JMenuItem | JMenu.add(Action a) 创建连接到指定 Action 对象的新菜单项，并将其追加到此菜单的末尾。
JMenuItem | JPopupMenu.add(JMenuItem menuItem) 将指定菜单项添加到此菜单的末尾。
JMenuItem | JMenu.add(JMenuItem menuItem) 将某个菜单项追加到此菜单的末尾。
JMenuItem | JPopupMenu.add(String s) 创建具有指定文本的菜单项，并将其添加到此菜单的末尾。
JMenuItem | JMenu.add(String s) 创建具有指定文本的新菜单项，并将其追加到此菜单的末尾。
protected JMenuItem | JPopupMenu.createActionComponent(Action a) 该工厂方法为添加到 JPopupMenu 的 Action 创建对应的 JMenuItem。
protected JMenuItem | JMenu.createActionComponent(Action a) 该工厂方法创建添加到 JMenu 的 Action 的 JMenuItem。
JMenuItem | JMenu.getItem(int pos) 返回指定位置的 JMenuItem。
JMenuItem | JMenu.insert(Action a, int pos) 在给定位置插入连接到指定 Action 对象的新菜单项。
JMenuItem | JMenu.insert(JMenuItem mi, int pos) 在给定位置插入指定的 JMenuitem。

参数类型为 JMenuItem 的 javax.swing 中的方法
JMenuItem | JPopupMenu.add(JMenuItem menuItem) 将指定菜单项添加到此菜单的末尾。
JMenuItem | JMenu.add(JMenuItem menuItem) 将某个菜单项追加到此菜单的末尾。
protected PropertyChangeListener | JPopupMenu.createActionChangeListener(JMenuItem b) 返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
protected PropertyChangeListener | JMenu.createActionChangeListener(JMenuItem b) 返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
JMenuItem | JMenu.insert(JMenuItem mi, int pos) 在给定位置插入指定的 JMenuitem。
void | JMenu.remove(JMenuItem item) 从此菜单移除指定的菜单项。

javax.swing.plaf.basic 中 JMenuItem 的使用

声明为 JMenuItem 的 javax.swing.plaf.basic 中的字段
protected  JMenuItem BasicMenuItemUI.menuItem

参数类型为 JMenuItem 的 javax.swing.plaf.basic 中的方法
protected void | BasicMenuItemUI.installComponents(JMenuItem menuItem)
protected void | BasicMenuItemUI.paintBackground(Graphics g, JMenuItem menuItem, Color bgColor) 绘制菜单项的背景。
protected void | BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text) 呈现当前菜单项的文本。
void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
protected void | BasicMenuItemUI.uninstallComponents(JMenuItem menuItem)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JMenuItem.AccessibleJMenuItem 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JMenuItem.AccessibleJMenuItem
的使用

使用 JMenuItem.AccessibleJMenuItem 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JMenuItem.AccessibleJMenuItem 的使用

javax.swing 中 JMenuItem.AccessibleJMenuItem 的子类
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.AbstractButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractButton
的使用

使用 AbstractButton 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 AbstractButton 的使用

javax.swing 中 AbstractButton 的子类
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuItem 菜单中的项的实现。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。

类型参数类型为 AbstractButton 的 javax.swing 中的字段
protected  Vector<AbstractButton> ButtonGroup.buttons

返回变量类型为 AbstractButton 的类型的 javax.swing 中的方法
 Enumeration<AbstractButton> ButtonGroup.getElements()
返回此组中的所有按钮。

参数类型为 AbstractButton 的 javax.swing 中的方法
void | ButtonGroup.add(AbstractButton b) 将按钮添加到组中。
void | ButtonGroup.remove(AbstractButton b) 从组中移除按钮。

javax.swing.plaf.basic 中 AbstractButton 的使用

javax.swing.plaf.basic 中 AbstractButton 的子类
 class BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

参数类型为 AbstractButton 的 javax.swing.plaf.basic 中的方法
protected void | BasicButtonListener.checkOpacity(AbstractButton b)
protected BasicButtonListener | BasicButtonUI.createButtonListener(AbstractButton b)
int | BasicButtonUI.getDefaultTextIconGap(AbstractButton b)
protected Border | BasicToolBarUI.getNonRolloverBorder(AbstractButton b) 返回按钮的非翻转边框。
static Dimension | BasicGraphicsUtils.getPreferredButtonSize(AbstractButton b, int textIconGap)
protected Border | BasicToolBarUI.getRolloverBorder(AbstractButton b) 返回按钮的翻转边框。
protected void | BasicRadioButtonUI.installDefaults(AbstractButton b)
protected void | BasicButtonUI.installDefaults(AbstractButton b)
protected void | BasicButtonUI.installKeyboardActions(AbstractButton b)
protected void | BasicButtonUI.installListeners(AbstractButton b)
protected void | BasicButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected void | BasicButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | BasicToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
protected void | BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text) 呈现当前按钮文本的方法。
protected void | BasicRadioButtonUI.uninstallDefaults(AbstractButton b)
protected void | BasicButtonUI.uninstallDefaults(AbstractButton b)
protected void | BasicButtonUI.uninstallKeyboardActions(AbstractButton b)
protected void | BasicButtonUI.uninstallListeners(AbstractButton b)

参数类型为 AbstractButton 的 javax.swing.plaf.basic 中的构造方法
BasicButtonListener(AbstractButton b)

javax.swing.plaf.metal 中 AbstractButton 的使用

javax.swing.plaf.metal 中 AbstractButton 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

参数类型为 AbstractButton 的 javax.swing.plaf.metal 中的方法
protected BasicButtonListener | MetalButtonUI.createButtonListener(AbstractButton b)
void | MetalCheckBoxUI.installDefaults(AbstractButton b)
void | MetalRadioButtonUI.installDefaults(AbstractButton b)
void | MetalToggleButtonUI.installDefaults(AbstractButton b)
void | MetalButtonUI.installDefaults(AbstractButton b)
protected void | MetalToggleButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected void | MetalButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected void | MetalToggleButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect) 在空间 iconRect 中绘制按钮 b 的适当图标。
protected void | MetalCheckBoxUI.uninstallDefaults(AbstractButton b)
protected void | MetalRadioButtonUI.uninstallDefaults(AbstractButton b)
protected void | MetalToggleButtonUI.uninstallDefaults(AbstractButton b)
void | MetalButtonUI.uninstallDefaults(AbstractButton b)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.AbstractButton.ButtonChangeListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractButton.ButtonChangeListener
的使用

没有 javax.swing.AbstractButton.ButtonChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.AbstractButton.AccessibleAbstractButton 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.AbstractButton.AccessibleAbstractButton
的使用

使用 AbstractButton.AccessibleAbstractButton 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AbstractButton.AccessibleAbstractButton 的使用

javax.swing 中 AbstractButton.AccessibleAbstractButton 的子类
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.MenuElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.MenuElement
的使用

使用 MenuElement 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 MenuElement 的使用

实现 MenuElement 的 javax.swing 中的类
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。

返回 MenuElement 的 javax.swing 中的方法
MenuElement[] | MenuSelectionManager.getSelectedPath() 返回当前选择菜单项的路径
MenuElement[] | JPopupMenu.getSubElements() 返回 MenuElement 组成的数组，包含此菜单组件的子菜单。
MenuElement[] | JMenuBar.getSubElements() 实现为 MenuElement（返回此菜单栏中的菜单）。
MenuElement[] | JMenu.getSubElements() 返回由 MenuElement 组成的数组，其中包含此菜单组件的子菜单。
MenuElement[] | JMenuItem.getSubElements() 此方法返回包含此菜单组件的子菜单组件的数组。
MenuElement[] | MenuElement.getSubElements() 此方法应返回一个包含接收菜单元素的子元素的数组

参数类型为 MenuElement 的 javax.swing 中的方法
void | JPopupMenu.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | JMenuBar.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | MenuElement.processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager) 处理键事件。
void | JPopupMenu.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 要求此方法遵守 MenuElement 接口，但它没有被实现。
void | JMenuBar.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
void | MenuElement.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 处理鼠标事件。
void | MenuSelectionManager.setSelectedPath(MenuElement[] path) 更改菜单层次结构中的选项。

javax.swing.event 中 MenuElement 的使用

返回 MenuElement 的 javax.swing.event 中的方法
MenuElement[] | MenuDragMouseEvent.getPath() 返回选定菜单项所在的路径。
MenuElement[] | MenuKeyEvent.getPath() 返回到达此事件引用的菜单项的路径。

参数类型为 MenuElement 的 javax.swing.event 中的构造方法
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuKeyEvent 对象。

javax.swing.plaf.basic 中 MenuElement 的使用

实现 MenuElement 的 javax.swing.plaf.basic 中的类
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。

返回 MenuElement 的 javax.swing.plaf.basic 中的方法
 MenuElement[] BasicMenuItemUI.getPath()

参数类型为 MenuElement 的 javax.swing.plaf.basic 中的方法
void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)

javax.swing.plaf.metal 中 MenuElement 的使用

实现 MenuElement 的 javax.swing.plaf.metal 中的类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.LayoutFocusTraversalPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.LayoutFocusTraversalPolicy
的使用

没有 javax.swing.LayoutFocusTraversalPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SortingFocusTraversalPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SortingFocusTraversalPolicy
的使用

使用 SortingFocusTraversalPolicy 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SortingFocusTraversalPolicy 的使用

javax.swing 中 SortingFocusTraversalPolicy 的子类
 class LayoutFocusTraversalPolicy
根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.InternalFrameFocusTraversalPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.InternalFrameFocusTraversalPolicy
的使用

使用 InternalFrameFocusTraversalPolicy 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 InternalFrameFocusTraversalPolicy 的使用

javax.swing 中 InternalFrameFocusTraversalPolicy 的子类
class | LayoutFocusTraversalPolicy 根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
class | SortingFocusTraversalPolicy 通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ActionMap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ActionMap
的使用

使用 ActionMap 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 ActionMap 的使用

返回 ActionMap 的 javax.swing 中的方法
ActionMap | JComponent.getActionMap() 返回用于确定为特定 KeyStroke 绑定触发何种 Action 的 ActionMap。
ActionMap | ActionMap.getParent() 返回此 ActionMap 的父级。
static ActionMap | SwingUtilities.getUIActionMap(JComponent component) 返回该 UI 在组件 component 中提供的 ActionMap。

参数类型为 ActionMap 的 javax.swing 中的方法
static void | SwingUtilities.replaceUIActionMap(JComponent component, ActionMap uiActionMap) 将 component 的 UI ActionMap 更改为 uiActionMap 的便捷方法。
void | JComponent.setActionMap(ActionMap am) 将 ActionMap 设置为 am。
void | ActionMap.setParent(ActionMap map) 设置此 ActionMap 的父级。

javax.swing.plaf 中 ActionMap 的使用

javax.swing.plaf 中 ActionMap 的子类
 class ActionMapUIResource
实现 UIResource 的 javax.swing.ActionMap 的子类。

javax.swing.plaf.basic 中 ActionMap 的使用

返回 ActionMap 的 javax.swing.plaf.basic 中的方法
protected  ActionMap BasicLookAndFeel.getAudioActionMap()
返回包含此外观音频动作的 ActionMap。

javax.swing.plaf.metal 中 ActionMap 的使用

返回 ActionMap 的 javax.swing.plaf.metal 中的方法
protected ActionMap | MetalFileChooserUI.createActionMap()
protected ActionMap | MetalFileChooserUI.getActionMap()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.KeyStroke 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.KeyStroke
的使用

使用 KeyStroke 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 KeyStroke 的使用

返回 KeyStroke 的 javax.swing 中的方法
KeyStroke[] | InputMap.allKeys() 返回在此 InputMap 及其父级中定义的 KeyStroke 组成的数组。
KeyStroke | JMenuItem.getAccelerator() 返回作为菜单项的加速器的 KeyStroke。
static KeyStroke | KeyStroke.getKeyStroke(char keyChar) 返回 KeyStroke 的共享实例，前者表示指定字符的 KEY_TYPED 事件。
static KeyStroke | KeyStroke.getKeyStroke(Character keyChar, int modifiers) 返回 KeyStroke 的一个共享实例，它表示指定 Character 对象和一组修饰符的 KEY_TYPED 事件。
static KeyStroke | KeyStroke.getKeyStroke(char keyChar, boolean onKeyRelease) 已过时。 使用 getKeyStroke(char)
static KeyStroke | KeyStroke.getKeyStroke(int keyCode, int modifiers) 在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例。
static KeyStroke | KeyStroke.getKeyStroke(int keyCode, int modifiers, boolean onKeyRelease) 在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例，指定该键在按下或释放时是否为已激活。
static KeyStroke | KeyStroke.getKeyStroke(String s) 分析字符串并返回 KeyStroke。
static KeyStroke | KeyStroke.getKeyStrokeForEvent(KeyEvent anEvent) 返回一个 KeyStroke，它表示生成给定 KeyEvent 的快捷键事件。
KeyStroke[] | JComponent.getRegisteredKeyStrokes() 返回启动已注册动作的 KeyStrokes。
KeyStroke[] | InputMap.keys() 返回绑定在此 InputMap 中的 KeyStroke。

参数类型为 KeyStroke 的 javax.swing 中的方法
 Object InputMap.get(KeyStroke keyStroke)
返回 keyStroke 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 InputMap。
 ActionListener JComponent.getActionForKeyStroke(KeyStroke aKeyStroke)
返回执行针对给定键击而注册的操作的对象。
 int JComponent.getConditionForKeyStroke(KeyStroke aKeyStroke)
返回确定是否发生已注册动作以响应指定键击事件的条件。
static boolean SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)
如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
protected  boolean JTable.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
protected  boolean JMenuBar.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
子类化以检查所有子菜单。
protected  boolean JComponent.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。
 void ComponentInputMap.put(KeyStroke keyStroke, Object actionMapKey)
将一个 keyStroke 的绑定添加到 actionMapKey。
 void InputMap.put(KeyStroke keyStroke, Object actionMapKey)
将 keyStroke 的一个绑定添加到 actionMapKey。
 void JComponent.registerKeyboardAction(ActionListener anAction, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void JComponent.registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void ComponentInputMap.remove(KeyStroke key)
从此对象中移除 key 的绑定。
 void InputMap.remove(KeyStroke key)
从此 InputMap 中移除 key 的绑定。
 void JMenu.setAccelerator(KeyStroke keyStroke)
没有为 JMenu 定义 setAccelerator。
 void JMenuItem.setAccelerator(KeyStroke keyStroke)
设置修改键，它能直接调用菜单项的操作侦听器而不必显示菜单的层次结构。
 void JComponent.unregisterKeyboardAction(KeyStroke aKeyStroke)
此方法现在已过时。

javax.swing.plaf.basic 中 KeyStroke 的使用

声明为 KeyStroke 的 javax.swing.plaf.basic 中的字段
protected KeyStroke | BasicDesktopPaneUI.closeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicSplitPaneUI.dividerResizeToggleKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.downKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.downKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.downKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.endKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.homeKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.leftKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.maximizeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.minimizeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.navigateKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.navigateKey2 已过时。 从 1.3 开始。
protected KeyStroke | BasicInternalFrameUI.openMenuKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.rightKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.upKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.upKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.upKey 已过时。 从 Java 2 平台 v1.3 开始。

javax.swing.text 中 KeyStroke 的使用

声明为 KeyStroke 的 javax.swing.text 中的字段
 KeyStroke JTextComponent.KeyBinding.key
键。

返回 KeyStroke 的 javax.swing.text 中的方法
KeyStroke[] | Keymap.getBoundKeyStrokes() 获取在此映射中绑定到其他操作的所有击键。
KeyStroke[] | Keymap.getKeyStrokesForAction(Action a) 获取将导致给定操作的击键。

参数类型为 KeyStroke 的 javax.swing.text 中的方法
void | Keymap.addActionForKeyStroke(KeyStroke key, Action a) 向 keymap 添加绑定。
Action | Keymap.getAction(KeyStroke key) 获取适合于给定符号事件序列的操作。
boolean | Keymap.isLocallyDefined(KeyStroke key) 确定是否本地定义给定的键序列。
void | Keymap.removeKeyStrokeBinding(KeyStroke keys) 从 keymap 移除绑定。

参数类型为 KeyStroke 的 javax.swing.text 中的构造方法
JTextComponent.KeyBinding(KeyStroke key, String actionName)
创建新的键绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.ComponentInputMap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.ComponentInputMap
的使用

使用 ComponentInputMap 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 ComponentInputMap 的使用

返回 ComponentInputMap 的 javax.swing 中的方法
static ComponentInputMap LookAndFeel.makeComponentInputMap(JComponent c, Object[] keys)
根据 keys 创建一个 ComponentInputMapUIResource。

javax.swing.plaf 中 ComponentInputMap 的使用

javax.swing.plaf 中 ComponentInputMap 的子类
 class ComponentInputMapUIResource
实现 UIResource 的 javax.swing.ComponentInputMap 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.InputMap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.InputMap
的使用

使用 InputMap 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 InputMap 的使用

javax.swing 中 InputMap 的子类
 class ComponentInputMap
ComponentInputMap 是与特定 JComponent 相关联的 InputMap。

返回 InputMap 的 javax.swing 中的方法
InputMap | JComponent.getInputMap() 返回组件具有焦点时所使用的 InputMap。
InputMap | JComponent.getInputMap(int condition) 返回 condition 中所使用的 InputMap。
InputMap | InputMap.getParent() 获得此 InputMap 的父级。
static InputMap | SwingUtilities.getUIInputMap(JComponent component, int condition) 返回由组件 component 中的条件 condition 的 UI 提供的 InputMap。
static InputMap | LookAndFeel.makeInputMap(Object[] keys) 根据 keys 创建一个 InputMapUIResource。

参数类型为 InputMap 的 javax.swing 中的方法
static void | LookAndFeel.loadKeyBindings(InputMap retMap, Object[] keys) 使用指定绑定填充 InputMap。
static void | SwingUtilities.replaceUIInputMap(JComponent component, int type, InputMap uiInputMap) 将 component 的 UI InputMap 更改为 uiInputMap 的便捷方法。
void | JComponent.setInputMap(int condition, InputMap map) 设置在 map 的 condition 条件下要使用的 InputMap。
void | ComponentInputMap.setParent(InputMap map) 设置父组件，该组件必须是一个和与此 ComponentInputMap 相同的组件相关联的 ComponentInputMap。
void | InputMap.setParent(InputMap map) 设置此 InputMap 的父级。

javax.swing.plaf 中 InputMap 的使用

javax.swing.plaf 中 InputMap 的子类
class | ComponentInputMapUIResource 实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
class | InputMapUIResource 实现 UIResource 的 javax.swing.InputMap 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JInternalFrame 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JInternalFrame
的使用

使用 JInternalFrame 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JInternalFrame 的使用

返回 JInternalFrame 的 javax.swing 中的方法
JInternalFrame | JOptionPane.createInternalFrame(Component parentComponent, String title) 创建并返回 JInternalFrame 的实例。
JInternalFrame[] | JDesktopPane.getAllFrames() 返回桌面中当前显示的所有 JInternalFrames。
JInternalFrame[] | JDesktopPane.getAllFramesInLayer(int layer) 返回桌面指定层中当前所显示的所有 JInternalFrames。
JInternalFrame | JInternalFrame.JDesktopIcon.getInternalFrame() 返回与此 DesktopIcon 关联的 JInternalFrame。
JInternalFrame | JDesktopPane.getSelectedFrame() 返回此 JDesktopPane 中当前活动的 JInternalFrame，如果当前没有活动的 JInternalFrame，则返回 null。
JInternalFrame | JDesktopPane.selectFrame(boolean forward) 选择此桌面窗格中的下一个 JInternalFrame。

参数类型为 JInternalFrame 的 javax.swing 中的方法
 void DefaultDesktopManager.activateFrame(JInternalFrame f)
此方法将激活 f，将它移动到前台。
 void DesktopManager.activateFrame(JInternalFrame f)
通常指示此窗体拥有焦点。
 void DefaultDesktopManager.closeFrame(JInternalFrame f)
从父窗体中移除窗体，如有必要，还要移除 desktopIcon。
 void DesktopManager.closeFrame(JInternalFrame f)
通常，此调用应该从其父窗体中移除窗体。
 void DefaultDesktopManager.deactivateFrame(JInternalFrame f)
 void DesktopManager.deactivateFrame(JInternalFrame f)
通常指示此窗体失去焦点。
 void DefaultDesktopManager.deiconifyFrame(JInternalFrame f)
从父窗体中移除 desktopIcon，并将其窗体添加到父窗体中。
 void DesktopManager.deiconifyFrame(JInternalFrame f)
通常移除现有的任何图标表示形式，并将窗体恢复到其原始大小和位置。
protected  Rectangle DefaultDesktopManager.getBoundsForIconOf(JInternalFrame f)
iconifyFrame() 代码调用此方法来确定 desktopIcon 的适当边界。
 Component InternalFrameFocusTraversalPolicy.getInitialComponent(JInternalFrame frame)
返回第一次选择 JInternalFrame 时应该接收焦点的 Component。
protected  Rectangle DefaultDesktopManager.getPreviousBounds(JInternalFrame f)
在将组件最大化之前，获得该组件的普通边界。
 void DefaultDesktopManager.iconifyFrame(JInternalFrame f)
从父窗体中移除窗体，并将其 desktopIcon 添加到父窗体中。
 void DesktopManager.iconifyFrame(JInternalFrame f)
通常从父窗体中移除此窗体，并添加一个图标表示形式。
 void DefaultDesktopManager.maximizeFrame(JInternalFrame f)
重新调整窗体的大小，使其满足其父窗体的限制。
 void DesktopManager.maximizeFrame(JInternalFrame f)
通常，应该重新调整窗体的大小，使其满足其父窗体的限制。
 void DefaultDesktopManager.minimizeFrame(JInternalFrame f)
使窗体恢复回调用 maximizeFrame 之前的大小和位置。
 void DesktopManager.minimizeFrame(JInternalFrame f)
通常，这指示应该将窗体恢复到调用 maximizeFrame() 前的大小和位置。
 void DefaultDesktopManager.openFrame(JInternalFrame f)
通常不调用此方法。
 void DesktopManager.openFrame(JInternalFrame f)
如有可能，在适当的位置显示此窗体。
protected  void DefaultDesktopManager.removeIconFor(JInternalFrame f)
在需要时移除 f 的 desktopIcon 的便捷方法。
 void JInternalFrame.JDesktopIcon.setInternalFrame(JInternalFrame f)
设置与此 DesktopIcon 关联的 JInternalFrame。
protected  void DefaultDesktopManager.setPreviousBounds(JInternalFrame f, Rectangle r)
在进行 maximize 调用之前存储组件的边界。
 void JDesktopPane.setSelectedFrame(JInternalFrame f)
设置此 JDesktopPane 中当前活动的 JInternalFrame。
protected  void DefaultDesktopManager.setWasIcon(JInternalFrame f, Boolean value)
设定组件已被图标化并且 desktopIcon 的边界是有效的。
protected  boolean DefaultDesktopManager.wasIcon(JInternalFrame f)
如果组件已被图标化并且 desktopIcon 的边界是有效的，则返回 true，否则返回 false。

参数类型为 JInternalFrame 的 javax.swing 中的构造方法
JInternalFrame.JDesktopIcon(JInternalFrame f)
为内部 frame 创建一个图标。

javax.swing.event 中 JInternalFrame 的使用

返回 JInternalFrame 的 javax.swing.event 中的方法
 JInternalFrame InternalFrameEvent.getInternalFrame()
返回事件的发起者。

参数类型为 JInternalFrame 的 javax.swing.event 中的构造方法
InternalFrameEvent(JInternalFrame source, int id)
构造一个 InternalFrameEvent 对象。

javax.swing.plaf.basic 中 JInternalFrame 的使用

声明为 JInternalFrame 的 javax.swing.plaf.basic 中的字段
protected JInternalFrame | BasicDesktopIconUI.frame
protected JInternalFrame | BasicInternalFrameTitlePane.frame
protected JInternalFrame | BasicInternalFrameUI.frame

参数类型为 JInternalFrame 的 javax.swing.plaf.basic 中的方法
protected void | BasicInternalFrameUI.activateFrame(JInternalFrame f) 窗体变为被选择状态时调用此方法。
protected void | BasicInternalFrameUI.closeFrame(JInternalFrame f) 当用户要关闭窗体时调用此方法。
protected MouseInputAdapter | BasicInternalFrameUI.createBorderListener(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createEastPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createNorthPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createSouthPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createWestPane(JInternalFrame w)
protected void | BasicInternalFrameUI.deactivateFrame(JInternalFrame f) 窗体不再是被选择状态时调用此方法。
protected void | BasicInternalFrameUI.deiconifyFrame(JInternalFrame f) 当用户要取消图标化窗体时调用此方法。
protected void | BasicInternalFrameUI.iconifyFrame(JInternalFrame f) 当用户要图标化窗体时调用此方法。
protected void | BasicInternalFrameUI.maximizeFrame(JInternalFrame f) 当用户要最大化窗体时调用此方法。
protected void | BasicInternalFrameUI.minimizeFrame(JInternalFrame f) 当用户要最小化窗体时调用此方法。
protected void | BasicInternalFrameTitlePane.postClosingEvent(JInternalFrame frame) 将类似于 WINDOW_CLOSING 的事件发送到窗体，以便将其当作规则的 Frame 来对待。

参数类型为 JInternalFrame 的 javax.swing.plaf.basic 中的构造方法
BasicInternalFrameTitlePane(JInternalFrame f)
BasicInternalFrameUI(JInternalFrame b)

javax.swing.plaf.metal 中 JInternalFrame 的使用

参数类型为 JInternalFrame 的 javax.swing.plaf.metal 中的方法
protected MouseInputAdapter | MetalInternalFrameUI.createBorderListener(JInternalFrame w) 返回将在 TitlePane 上安装的 MouseInputAdapter。
protected JComponent | MetalInternalFrameUI.createNorthPane(JInternalFrame w)

参数类型为 JInternalFrame 的 javax.swing.plaf.metal 中的构造方法
MetalInternalFrameTitlePane(JInternalFrame f)
MetalInternalFrameUI(JInternalFrame b)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JInternalFrame.AccessibleJInternalFrame 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JInternalFrame.AccessibleJInternalFrame
的使用

没有 javax.swing.JInternalFrame.AccessibleJInternalFrame 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JLayeredPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JLayeredPane
的使用

使用 JLayeredPane 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 JLayeredPane 的使用

javax.swing 中 JLayeredPane 的子类
 class JDesktopPane
用于创建多文档界面或虚拟桌面的容器。

声明为 JLayeredPane 的 javax.swing 中的字段
protected  JLayeredPane JRootPane.layeredPane
管理菜单栏和内容窗格的分层窗格。

返回 JLayeredPane 的 javax.swing 中的方法
protected JLayeredPane | JRootPane.createLayeredPane() 由构造方法调用以便创建默认的 layeredPane。
JLayeredPane | JApplet.getLayeredPane() 返回此 applet 的 layeredPane 对象。
JLayeredPane | JWindow.getLayeredPane() 返回此窗口的 layeredPane 对象。
JLayeredPane | JDialog.getLayeredPane() 返回此对话框的 layeredPane 对象。
JLayeredPane | JInternalFrame.getLayeredPane() 返回此内部窗体的分层窗格。
JLayeredPane | JRootPane.getLayeredPane() 获取供根窗格使用的分层窗格。
JLayeredPane | JFrame.getLayeredPane() 返回此窗体的 layeredPane 对象。
JLayeredPane | RootPaneContainer.getLayeredPane() 返回 layeredPane。
static JLayeredPane | JLayeredPane.getLayeredPaneAbove(Component c) 一个便捷方法，它返回包含指定组件的第一个 JLayeredPane。

参数类型为 JLayeredPane 的 javax.swing 中的方法
void | JApplet.setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | JWindow.setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | JDialog.setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | JInternalFrame.setLayeredPane(JLayeredPane layered) 设置此 JInternalFrame 的 layeredPane 属性。
void | JRootPane.setLayeredPane(JLayeredPane layered) 设置供根窗格使用的分层窗格。
void | JFrame.setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | RootPaneContainer.setLayeredPane(JLayeredPane layeredPane) 管理 contentPane 的 Container，在某些情况下为菜单栏。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JInternalFrame.JDesktopIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JInternalFrame.JDesktopIcon
的使用

使用 JInternalFrame.JDesktopIcon 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JInternalFrame.JDesktopIcon 的使用

声明为 JInternalFrame.JDesktopIcon 的 javax.swing 中的字段
protected  JInternalFrame.JDesktopIcon JInternalFrame.desktopIcon
此内部窗体图标化时所显示的图标。

返回 JInternalFrame.JDesktopIcon 的 javax.swing 中的方法
 JInternalFrame.JDesktopIcon JInternalFrame.getDesktopIcon()
返回图标化此 JInternalFrame 时使用的 JDesktopIcon。

参数类型为 JInternalFrame.JDesktopIcon 的 javax.swing 中的方法
 void JInternalFrame.setDesktopIcon(JInternalFrame.JDesktopIcon d)
设置与此 JInternalFrame 关联的 JDesktopIcon。

javax.swing.plaf.basic 中 JInternalFrame.JDesktopIcon 的使用

声明为 JInternalFrame.JDesktopIcon 的 javax.swing.plaf.basic 中的字段
protected  JInternalFrame.JDesktopIcon BasicDesktopIconUI.desktopIcon

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
的使用

没有 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JLayeredPane.AccessibleJLayeredPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JLayeredPane.AccessibleJLayeredPane
的使用

没有 javax.swing.JLayeredPane.AccessibleJLayeredPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.RepaintManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.RepaintManager
的使用

使用 RepaintManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RepaintManager 的使用

返回 RepaintManager 的 javax.swing 中的方法
static RepaintManager | RepaintManager.currentManager(Component c) 在给定 Component 的情况下，返回调用线程的 RepaintManager。
static RepaintManager | RepaintManager.currentManager(JComponent c) 在给定 JComponent 的情况下，返回调用线程的 RepaintManager。

参数类型为 RepaintManager 的 javax.swing 中的方法
static void RepaintManager.setCurrentManager(RepaintManager aRepaintManager)
设置用于调用线程的 RepaintManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.LookAndFeel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.LookAndFeel
的使用

使用 LookAndFeel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing 中 LookAndFeel 的使用

返回 LookAndFeel 的 javax.swing 中的方法
static LookAndFeel[] | UIManager.getAuxiliaryLookAndFeels() 返回辅助外观的列表（可以为 null）。
static LookAndFeel | UIManager.getLookAndFeel() 返回当前外观或 null。

参数类型为 LookAndFeel 的 javax.swing 中的方法
static void | UIManager.addAuxiliaryLookAndFeel(LookAndFeel laf) 将 LookAndFeel 添加到辅助外观的列表中。
static boolean | UIManager.removeAuxiliaryLookAndFeel(LookAndFeel laf) 从辅助外观列表移除一个 LookAndFeel。
static void | UIManager.setLookAndFeel(LookAndFeel newLookAndFeel) 将当前外观设置为 newLookAndFeel。

javax.swing.plaf.basic 中 LookAndFeel 的使用

javax.swing.plaf.basic 中 LookAndFeel 的子类
 class BasicLookAndFeel
为 Swing 创建外观时要使用的基类。

javax.swing.plaf.metal 中 LookAndFeel 的使用

javax.swing.plaf.metal 中 LookAndFeel 的子类
 class MetalLookAndFeel
Java 外观，也称为 Metal。

javax.swing.plaf.multi 中 LookAndFeel 的使用

javax.swing.plaf.multi 中 LookAndFeel 的子类
 class MultiLookAndFeel
多路外观允许同时将多个 UI 与一个组件相关联。

javax.swing.plaf.synth 中 LookAndFeel 的使用

javax.swing.plaf.synth 中 LookAndFeel 的子类
 class SynthLookAndFeel
SynthLookAndFeel 提供创建定制外观的基础。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.UIDefaults 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIDefaults
的使用

使用 UIDefaults 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing 中的方法
UIDefaults | LookAndFeel.getDefaults() 返回外观的默认值。
static UIDefaults | UIManager.getDefaults() 返回该默认值。
static UIDefaults | UIManager.getLookAndFeelDefaults() 从当前外观返回 UIDefaults，UIDefaults 在安装该外观时获得。

参数类型为 UIDefaults 的 javax.swing 中的方法
Object | UIDefaults.LazyValue.createValue(UIDefaults table) 创建从 UIDefaults 表中检索的实际值。
Object | UIDefaults.ActiveValue.createValue(UIDefaults table) 创建从 UIDefaults 表中检索的值。
Object | UIDefaults.ProxyLazyValue.createValue(UIDefaults table) 创建从 UIDefaults 表中检索的值。
Object | UIDefaults.LazyInputMap.createValue(UIDefaults table) 使用传入的绑定创建一个 InputMap。

javax.swing.plaf.basic 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing.plaf.basic 中的方法
 UIDefaults BasicLookAndFeel.getDefaults()
返回外观默认值。

参数类型为 UIDefaults 的 javax.swing.plaf.basic 中的方法
protected void | BasicLookAndFeel.initClassDefaults(UIDefaults table) 用从 uiClassID 到 ui 类的完全限定名称的映射关系填充 table。
protected void | BasicLookAndFeel.initComponentDefaults(UIDefaults table) 用基本外观的默认值填充 table。
protected void | BasicLookAndFeel.initSystemColorDefaults(UIDefaults table) 用系统颜色填充 table。
protected void | BasicLookAndFeel.loadSystemColors(UIDefaults table, String[] systemColors, boolean useNative) 用 systemColors 中的 name-color 对填充 table。

javax.swing.plaf.metal 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing.plaf.metal 中的方法
 UIDefaults MetalLookAndFeel.getDefaults()
返回外观的默认值。

参数类型为 UIDefaults 的 javax.swing.plaf.metal 中的方法
void | OceanTheme.addCustomEntriesToTable(UIDefaults table) 将此主题的自定义条目添加到默认表中。
void | MetalTheme.addCustomEntriesToTable(UIDefaults table) 将特定于此主题的值添加到默认表。
protected void | MetalLookAndFeel.initClassDefaults(UIDefaults table) 用从 uiClassID 到 ui 类完全限定名的映射关系填充 table。
protected void | MetalLookAndFeel.initComponentDefaults(UIDefaults table) 用 metal 的默认值填充 table。
protected void | MetalLookAndFeel.initSystemColorDefaults(UIDefaults table) 用系统颜色填充 table。

javax.swing.plaf.multi 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing.plaf.multi 中的方法
 UIDefaults MultiLookAndFeel.getDefaults()
创建、初始化并返回特定于外观的默认值。

javax.swing.plaf.synth 中 UIDefaults 的使用

返回 UIDefaults 的 javax.swing.plaf.synth 中的方法
 UIDefaults SynthLookAndFeel.getDefaults()
返回此 SynthLookAndFeel 的默认值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.UIDefaults.LazyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.UIDefaults.LazyValue
的使用

使用 UIDefaults.LazyValue 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 UIDefaults.LazyValue 的使用

实现 UIDefaults.LazyValue 的 javax.swing 中的类
static class | UIDefaults.LazyInputMap LazyInputMap 将在其 createValue 方法中创建一个 InputMap。
static class | UIDefaults.ProxyLazyValue 此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.UIDefaults.ActiveValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.UIDefaults.ActiveValue
的使用

没有 javax.swing.UIDefaults.ActiveValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.UIDefaults.ProxyLazyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIDefaults.ProxyLazyValue
的使用

没有 javax.swing.UIDefaults.ProxyLazyValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.UIDefaults.LazyInputMap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIDefaults.LazyInputMap
的使用

没有 javax.swing.UIDefaults.LazyInputMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.UIManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIManager
的使用

没有 javax.swing.UIManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.UIManager.LookAndFeelInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.UIManager.LookAndFeelInfo
的使用

使用 UIManager.LookAndFeelInfo 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 UIManager.LookAndFeelInfo 的使用

返回 UIManager.LookAndFeelInfo 的 javax.swing 中的方法
static UIManager.LookAndFeelInfo[] UIManager.getInstalledLookAndFeels()
返回表示当前可用的 LookAndFeel 实现的 LookAndFeelInfo 数组。

参数类型为 UIManager.LookAndFeelInfo 的 javax.swing 中的方法
static void | UIManager.installLookAndFeel(UIManager.LookAndFeelInfo info) 将指定的外观添加到可用外观的集合中。
static void | UIManager.setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos) 设置可用外观的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JPanel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPanel
的使用

使用 JPanel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing 中 JPanel 的使用

javax.swing 中 JPanel 的子类
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。

javax.swing.colorchooser 中 JPanel 的使用

javax.swing.colorchooser 中 JPanel 的子类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.plaf.basic 中 JPanel 的使用

返回 JPanel 的 javax.swing.plaf.basic 中的方法
 JPanel BasicFileChooserUI.getAccessoryPanel()

参数类型为 JPanel 的 javax.swing.plaf.basic 中的方法
protected void | BasicPanelUI.installDefaults(JPanel p)
protected void | BasicPanelUI.uninstallDefaults(JPanel p)

javax.swing.plaf.metal 中 JPanel 的使用

返回 JPanel 的 javax.swing.plaf.metal 中的方法
protected JPanel | MetalFileChooserUI.createDetailsView(JFileChooser fc)
protected JPanel | MetalFileChooserUI.createList(JFileChooser fc)
protected JPanel | MetalFileChooserUI.getBottomPanel()
protected JPanel | MetalFileChooserUI.getButtonPanel()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JRootPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRootPane
的使用

使用 JRootPane 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 JRootPane 的使用

声明为 JRootPane 的 javax.swing 中的字段
protected JRootPane | JApplet.rootPane
protected JRootPane | JWindow.rootPane 管理此框架的 contentPane 和可选 menuBar 以及 glassPane 的 JRootPane 实例。
protected JRootPane | JDialog.rootPane
protected JRootPane | JInternalFrame.rootPane JRootPane 实例，它管理此内部窗体的内容窗格和可选菜单栏以及玻璃窗格（glass pane）。
protected JRootPane | JFrame.rootPane JRootPane 实例管理此窗体的 contentPane 和可选的 menuBar，以及 glassPane。

返回 JRootPane 的 javax.swing 中的方法
protected JRootPane | JApplet.createRootPane() 构造方法调用此方法创建默认 rootPane。
protected JRootPane | JWindow.createRootPane() 由该构造方法调用以创建默认的 rootPane。
protected JRootPane | JDialog.createRootPane() 构造方法调用此方法来创建默认的 rootPane。
protected JRootPane | JInternalFrame.createRootPane() 构造方法调用此方法来设置 JRootPane。
protected JRootPane | JFrame.createRootPane() 由构造方法调用，以创建默认的 rootPane。
JRootPane | JApplet.getRootPane() 返回此 applet 的 rootPane 对象。
JRootPane | JWindow.getRootPane() 返回此窗口的 rootPane 对象。
JRootPane | JDialog.getRootPane() 返回此对话框的 rootPane 对象。
JRootPane | JInternalFrame.getRootPane() 返回此内部窗体的 rootPane 对象。
JRootPane | JComponent.getRootPane() 返回此组件的 JRootPane 祖先。
JRootPane | JFrame.getRootPane() 返回此窗体的 rootPane 对象。
JRootPane | RootPaneContainer.getRootPane() 返回此组件的单个 JRootPane 子组件。
static JRootPane | SwingUtilities.getRootPane(Component c) 如果 c 是一个 JRootPane 后代，则返回其 JRootPane 祖先。

参数类型为 JRootPane 的 javax.swing 中的方法
protected void | JApplet.setRootPane(JRootPane root) 设置 rootPane 属性。
protected void | JWindow.setRootPane(JRootPane root) 设置此窗口的新 rootPane 对象。
protected void | JDialog.setRootPane(JRootPane root) 设置 rootPane 属性。
protected void | JInternalFrame.setRootPane(JRootPane root) 设置此 JInternalFrame 的 rootPane 属性。
protected void | JFrame.setRootPane(JRootPane root) 设置 rootPane 属性。

javax.swing.plaf.basic 中 JRootPane 的使用

参数类型为 JRootPane 的 javax.swing.plaf.basic 中的方法
protected void | BasicRootPaneUI.installComponents(JRootPane root)
protected void | BasicRootPaneUI.installDefaults(JRootPane c)
protected void | BasicRootPaneUI.installKeyboardActions(JRootPane root)
protected void | BasicRootPaneUI.installListeners(JRootPane root)
protected void | BasicRootPaneUI.uninstallComponents(JRootPane root)
protected void | BasicRootPaneUI.uninstallDefaults(JRootPane root)
protected void | BasicRootPaneUI.uninstallKeyboardActions(JRootPane root)
protected void | BasicRootPaneUI.uninstallListeners(JRootPane root)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JPanel.AccessibleJPanel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JPanel.AccessibleJPanel
的使用

没有 javax.swing.JPanel.AccessibleJPanel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JRootPane.RootLayout 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRootPane.RootLayout
的使用

没有 javax.swing.JRootPane.RootLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JRootPane.AccessibleJRootPane 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JRootPane.AccessibleJRootPane
的使用

没有 javax.swing.JRootPane.AccessibleJRootPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.SwingUtilities 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.SwingUtilities
的使用

没有 javax.swing.SwingUtilities 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JLabel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JLabel
的使用

使用 JLabel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JLabel 的使用

javax.swing 中 JLabel 的子类
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。

javax.swing.plaf.basic 中 JLabel 的使用

javax.swing.plaf.basic 中 JLabel 的子类
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。

参数类型为 JLabel 的 javax.swing.plaf.basic 中的方法
protected  void BasicLabelUI.installComponents(JLabel c)
protected  void BasicLabelUI.installDefaults(JLabel c)
protected  void BasicLabelUI.installKeyboardActions(JLabel l)
protected  void BasicLabelUI.installListeners(JLabel c)
protected  String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
protected  void BasicLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。
protected  void BasicLabelUI.paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用标签的前景色将 clippedText 绘制在 textX、textY 处。
protected  void BasicLabelUI.uninstallComponents(JLabel c)
protected  void BasicLabelUI.uninstallDefaults(JLabel c)
protected  void BasicLabelUI.uninstallKeyboardActions(JLabel c)
protected  void BasicLabelUI.uninstallListeners(JLabel c)

javax.swing.plaf.metal 中 JLabel 的使用

javax.swing.plaf.metal 中 JLabel 的子类
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。

参数类型为 JLabel 的 javax.swing.plaf.metal 中的方法
protected  void MetalLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。

javax.swing.table 中 JLabel 的使用

javax.swing.table 中 JLabel 的子类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。

javax.swing.tree 中 JLabel 的使用

javax.swing.tree 中 JLabel 的子类
 class DefaultTreeCellRenderer
显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JLabel.AccessibleJLabel 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JLabel.AccessibleJLabel
的使用

没有 javax.swing.JLabel.AccessibleJLabel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JComponent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComponent
的使用

使用 JComponent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 JComponent 的使用

javax.swing 中 JComponent 的子类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。

声明为 JComponent 的 javax.swing 中的字段
protected  JComponent DefaultCellEditor.editorComponent
正被编辑的 Swing 组件。

返回 JComponent 的 javax.swing 中的方法
protected JComponent | JSpinner.createEditor(SpinnerModel model) 此方法由构造方法调用，以创建显示序列当前值的 JComponent。
JComponent | JFileChooser.getAccessory() 返回 accessory 组件。
JComponent | JToolTip.getComponent() 返回工具提示所描述的组件。
JComponent | ComponentInputMap.getComponent() 返回为其创建 InputMap 的组件。
JComponent | JSpinner.getEditor() 返回显示和潜在更改模型值的组件。
JComponent | JColorChooser.getPreviewPanel() 返回显示选取颜色的预览面板。

参数类型为 JComponent 的 javax.swing 中的方法
 void RepaintManager.addDirtyRegion(JComponent c, int x, int y, int w, int h)
在应刷新的组件列表中添加组件。
 void RepaintManager.addInvalidComponent(JComponent invalidComponent)
按照布局需要标记组件，并将事件指派线程的 runnable 排入队列，该线程将验证组件的第一个 isValidateRoot() 祖先。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type)
添加一个表示两个组件之间首选间隙的元素。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max)
添加一个表示两个组件之间首选间隙的元素。
 void DefaultDesktopManager.beginDraggingFrame(JComponent f)
 void DesktopManager.beginDraggingFrame(JComponent f)
通常在用户已经指示他们将开始拖动某个组件时调用此方法。
 void DefaultDesktopManager.beginResizingFrame(JComponent f, int direction)
 void DesktopManager.beginResizingFrame(JComponent f, int direction)
通常在用户已经指示他们将开始重新调整窗体的大小时调用此方法。
static Rectangle SwingUtilities.calculateInnerArea(JComponent c, Rectangle r)
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
 boolean TransferHandler.canImport(JComponent comp, DataFlavor[] transferFlavors)
指示一个组件在实际尝试导入给定数据 flavor 的集合之前是否接受其导入。
protected  Transferable TransferHandler.createTransferable(JComponent c)
创建一个要用作数据传输源的 Transferable。
static RepaintManager RepaintManager.currentManager(JComponent c)
在给定 JComponent 的情况下，返回调用线程的 RepaintManager。
 void DefaultDesktopManager.dragFrame(JComponent f, int newX, int newY)
将正被拖动窗体的可见位置移动到指定位置。
 void DesktopManager.dragFrame(JComponent f, int newX, int newY)
用户已经移动窗体。
 void DefaultDesktopManager.endDraggingFrame(JComponent f)
 void DesktopManager.endDraggingFrame(JComponent f)
此方法在拖动会话结束时发出信号。
 void DefaultDesktopManager.endResizingFrame(JComponent f)
 void DesktopManager.endResizingFrame(JComponent f)
此方法在重新调整大小会话结束时发出信号。
 void TransferHandler.exportAsDrag(JComponent comp, InputEvent e, int action)
导致 Swing 拖动支持的启用。
protected  void TransferHandler.exportDone(JComponent source, Transferable data, int action)
在导出数据之后调用。
 void TransferHandler.exportToClipboard(JComponent comp, Clipboard clip, int action)
导致从给定组件到给定剪贴板的传输。
abstract  int LayoutStyle.getContainerGap(JComponent component, int position, Container parent)
返回组件与其父容器的指定边缘之间放置的空格数量。
 Rectangle RepaintManager.getDirtyRegion(JComponent aComponent)
返回组件的当前脏区。
 Icon LookAndFeel.getDisabledIcon(JComponent component, Icon icon)
返回具有禁用外观的 Icon。
 Icon LookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon)
返回由选定的禁用组件使用的 Icon。
static int JLayeredPane.getLayer(JComponent c)
获得 JComponent 的 layer 属性，此方法不会产生与 setLayer() 类似的副作用（绘制、添加/移除等）。
abstract  int LayoutStyle.getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent)
返回两个组件之间使用的空格的数量。
 int TransferHandler.getSourceActions(JComponent c)
返回源支持的传输动作的类型；COPY、MOVE 和 LINK 的任意按位或组合。
 ComponentUI UIDefaults.getUI(JComponent target)
创建一个指定组件的 ComponentUI 实现。
static ComponentUI UIManager.getUI(JComponent target)
返回 target 的适当 ComponentUI 实现。
static ActionMap SwingUtilities.getUIActionMap(JComponent component)
返回该 UI 在组件 component 中提供的 ActionMap。
static InputMap SwingUtilities.getUIInputMap(JComponent component, int condition)
返回由组件 component 中的条件 condition 的 UI 提供的 InputMap。
 boolean TransferHandler.importData(JComponent comp, Transferable t)
导致从剪贴板或 DND 放置操作向组件的传输。
static void LookAndFeel.installBorder(JComponent c, String defaultBorderName)
使用默认的值设置组件边框属性的便捷方法。
static void LookAndFeel.installColors(JComponent c, String defaultBgName, String defaultFgName)
使用默认的值设置组件的前景和背景颜色属性的便捷方法。
static void LookAndFeel.installColorsAndFont(JComponent c, String defaultBgName, String defaultFgName, String defaultFontName)
使用默认的值设置组件的前景、背景和字体属性的便捷方法。
static void LookAndFeel.installProperty(JComponent c, String propertyName, Object propertyValue)
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。
 boolean RepaintManager.isCompletelyDirty(JComponent aComponent)
在下一个 paintDirtyRegions() 中全部绘制 aComponent 时返回 true 的便捷方法。
static String SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static ComponentInputMap LookAndFeel.makeComponentInputMap(JComponent c, Object[] keys)
根据 keys 创建一个 ComponentInputMapUIResource。
 void RepaintManager.markCompletelyClean(JComponent aComponent)
标记完全干净的组件。
 void RepaintManager.markCompletelyDirty(JComponent aComponent)
标记完全弄脏的组件。
static void JLayeredPane.putLayer(JComponent c, int layer)
设置 JComponent 上的 layer 属性。
 void ToolTipManager.registerComponent(JComponent component)
注册一个工具提示管理组件。
 void RepaintManager.removeInvalidComponent(JComponent component)
从无效组件的列表移除组件。
static void SwingUtilities.replaceUIActionMap(JComponent component, ActionMap uiActionMap)
将 component 的 UI ActionMap 更改为 uiActionMap 的便捷方法。
static void SwingUtilities.replaceUIInputMap(JComponent component, int type, InputMap uiInputMap)
将 component 的 UI InputMap 更改为 uiInputMap 的便捷方法。
 void DefaultDesktopManager.resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
使用新值调用 setBoundsForFrame。
 void DesktopManager.resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
用户已经重新调整组件的大小。
 void JFileChooser.setAccessory(JComponent newAccessory)
设置 accessory 组件。
 void DefaultDesktopManager.setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
此方法移动 JComponent 并重新绘制已毁坏的区域。
 void DesktopManager.setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight)
这是一个基本重塑方法。
 void JToolTip.setComponent(JComponent c)
指定工具提示所描述的组件。
 void JSpinner.setEditor(JComponent editor)
更改显示 SpinnerModel 当前值的 JComponent。
 void JColorChooser.setPreviewPanel(JComponent preview)
设置当前预览面板。
 boolean InputVerifier.shouldYieldFocus(JComponent input)
调用 verify(input) 来确保输入是有效的。
static void LookAndFeel.uninstallBorder(JComponent c)
卸载边框的便捷方法。
 void ToolTipManager.unregisterComponent(JComponent component)
从工具提示控件中移除一个组件。
abstract  boolean InputVerifier.verify(JComponent input)
检查 JComponent 的输入是否有效。

参数类型为 JComponent 的 javax.swing 中的构造方法
ComponentInputMap(JComponent component)
创建一个与给定组件相关联的 ComponentInputMap。
DebugGraphics(Graphics graphics, JComponent component)
根据现有图形上下文构造一个调试图形上下文，该上下文可以减慢指定组件的绘制。

javax.swing.colorchooser 中 JComponent 的使用

javax.swing.colorchooser 中 JComponent 的子类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

返回 JComponent 的 javax.swing.colorchooser 中的方法
static JComponent ColorChooserComponentFactory.getPreviewPanel()

javax.swing.event 中 JComponent 的使用

返回 JComponent 的 javax.swing.event 中的方法
 JComponent AncestorEvent.getComponent()
返回添加了侦听器的组件。

参数类型为 JComponent 的 javax.swing.event 中的构造方法
AncestorEvent(JComponent source, int id, Container ancestor, Container ancestorParent)
构造一个 AncestorEvent 对象，以标识祖先组件显示状态的更改。

javax.swing.plaf 中 JComponent 的使用

参数类型为 JComponent 的 javax.swing.plaf 中的方法
boolean | ComponentUI.contains(JComponent c, int x, int y) 如果指定 x,y 位置包含在指定组件外观的已定义形状中，则返回 true。
static ComponentUI | ComponentUI.createUI(JComponent c) 返回指定组件的一个 UI 委托实例。
Accessible | ComponentUI.getAccessibleChild(JComponent c, int i) 返回对象的第 i 个 Accessible 子对象。
int | ComponentUI.getAccessibleChildrenCount(JComponent c) 返回对象中的可访问子对象数。
int | ComponentUI.getBaseline(JComponent c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | ComponentUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
Dimension | ComponentUI.getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | ComponentUI.getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | ComponentUI.getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。
void | ComponentUI.installUI(JComponent c) 配置指定组件，使其适合外观。
void | ComponentUI.paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | ComponentUI.uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
void | ComponentUI.update(Graphics g, JComponent c) 通知此 UI 委托开始绘制指定的组件。

参数类型为 JComponent 的 javax.swing.plaf 中的构造方法
ComponentInputMapUIResource(JComponent component)

javax.swing.plaf.basic 中 JComponent 的使用

javax.swing.plaf.basic 中 JComponent 的子类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。

声明为 JComponent 的 javax.swing.plaf.basic 中的字段
protected JComponent | BasicInternalFrameUI.eastPane
protected JComponent | BasicDesktopIconUI.iconPane 在桌面图标中使用的标题窗格组件。
protected JComponent | BasicOptionPaneUI.inputComponent 如果 optionPane.getWantsInput() 返回 true，则 JComponent 提供输入。
protected JComponent | BasicInternalFrameUI.northPane
protected JComponent | BasicInternalFrameUI.southPane
protected JComponent | BasicInternalFrameUI.westPane

返回 JComponent 的 javax.swing.plaf.basic 中的方法
protected JComponent | BasicInternalFrameUI.createEastPane(JInternalFrame w)
protected JComponent | BasicSpinnerUI.createEditor() installUI 通过调用此方法获取 JSpinner 的编辑器组件。
protected JComponent | BasicInternalFrameUI.createNorthPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createSouthPane(JInternalFrame w)
protected JComponent | BasicInternalFrameUI.createWestPane(JInternalFrame w)
JComponent | BasicInternalFrameUI.getEastPane()
JComponent | BasicInternalFrameUI.getNorthPane()
JComponent | BasicInternalFrameUI.getSouthPane()
JComponent | BasicInternalFrameUI.getWestPane()

参数类型为 JComponent 的 javax.swing.plaf.basic 中的方法
protected  ChangeListener BasicMenuUI.createChangeListener(JComponent c)
static View BasicHTML.createHTMLView(JComponent c, String html)
创建给定组件和 html 字符串的 html 渲染器。
protected  MenuDragMouseListener BasicMenuUI.createMenuDragMouseListener(JComponent c)
protected  MenuDragMouseListener BasicMenuItemUI.createMenuDragMouseListener(JComponent c)
protected  MenuKeyListener BasicMenuUI.createMenuKeyListener(JComponent c)
protected  MenuKeyListener BasicMenuItemUI.createMenuKeyListener(JComponent c)
protected  MenuListener BasicMenuUI.createMenuListener(JComponent c)
protected  MouseInputListener BasicMenuUI.createMouseInputListener(JComponent c)
protected  MouseInputListener BasicMenuItemUI.createMouseInputListener(JComponent c)
protected  PropertyChangeListener BasicMenuUI.createPropertyChangeListener(JComponent c)
protected  PropertyChangeListener BasicMenuItemUI.createPropertyChangeListener(JComponent c)
创建一个将被添加到菜单项的 PropertyChangeListener。
static ComponentUI BasicCheckBoxUI.createUI(JComponent b)
static ComponentUI BasicColorChooserUI.createUI(JComponent c)
static ComponentUI BasicDesktopIconUI.createUI(JComponent c)
static ComponentUI BasicDesktopPaneUI.createUI(JComponent c)
static ComponentUI BasicEditorPaneUI.createUI(JComponent c)
创建 JTextPane 的 UI。
static ComponentUI BasicFormattedTextFieldUI.createUI(JComponent c)
创建 JFormattedTextField 的 UI。
static ComponentUI BasicInternalFrameUI.createUI(JComponent b)
static ComponentUI BasicOptionPaneUI.createUI(JComponent x)
创建一个新的 BasicOptionPaneUI 实例。
static ComponentUI BasicPasswordFieldUI.createUI(JComponent c)
创建 JPasswordField 的 UI。
static ComponentUI BasicPopupMenuSeparatorUI.createUI(JComponent c)
static ComponentUI BasicSpinnerUI.createUI(JComponent c)
返回 BasicSpinnerUI 的新实例。
static ComponentUI BasicTextPaneUI.createUI(JComponent c)
创建 JTextPane 的 UI。
static ComponentUI BasicToolTipUI.createUI(JComponent c)
static ComponentUI BasicRadioButtonMenuItemUI.createUI(JComponent b)
static ComponentUI BasicCheckBoxMenuItemUI.createUI(JComponent c)
static ComponentUI BasicSliderUI.createUI(JComponent b)
static ComponentUI BasicTextAreaUI.createUI(JComponent ta)
创建 JTextArea 的 UI。
static ComponentUI BasicSplitPaneUI.createUI(JComponent x)
创建新的 BasicSplitPaneUI 实例
static ComponentUI BasicTreeUI.createUI(JComponent x)
static ComponentUI BasicTableUI.createUI(JComponent c)
static ComponentUI BasicTableHeaderUI.createUI(JComponent h)
static ComponentUI BasicProgressBarUI.createUI(JComponent x)
static ComponentUI BasicRadioButtonUI.createUI(JComponent b)
static ComponentUI BasicTabbedPaneUI.createUI(JComponent c)
static ComponentUI BasicToolBarSeparatorUI.createUI(JComponent c)
static ComponentUI BasicTextFieldUI.createUI(JComponent c)
创建 JTextField 的 UI。
static ComponentUI BasicScrollPaneUI.createUI(JComponent x)
static ComponentUI BasicViewportUI.createUI(JComponent c)
static ComponentUI BasicListUI.createUI(JComponent list)
返回 BasicListUI 的新实例。
static ComponentUI BasicComboBoxUI.createUI(JComponent c)
static ComponentUI BasicScrollBarUI.createUI(JComponent c)
static ComponentUI BasicSeparatorUI.createUI(JComponent c)
static ComponentUI BasicPopupMenuUI.createUI(JComponent x)
static ComponentUI BasicMenuUI.createUI(JComponent x)
static ComponentUI BasicMenuItemUI.createUI(JComponent c)
static ComponentUI BasicToolBarUI.createUI(JComponent c)
static ComponentUI BasicMenuBarUI.createUI(JComponent x)
static ComponentUI BasicToggleButtonUI.createUI(JComponent b)
static ComponentUI BasicButtonUI.createUI(JComponent c)
static ComponentUI BasicLabelUI.createUI(JComponent c)
static ComponentUI BasicRootPaneUI.createUI(JComponent c)
static ComponentUI BasicPanelUI.createUI(JComponent c)
protected  void BasicInternalFrameUI.deinstallMouseHandlers(JComponent c)
 Accessible BasicComboBoxUI.getAccessibleChild(JComponent c, int i)
 int BasicComboBoxUI.getAccessibleChildrenCount(JComponent c)
 int BasicSpinnerUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicSliderUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTextAreaUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTreeUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTableUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTableHeaderUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicProgressBarUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTabbedPaneUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicTextFieldUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicScrollPaneUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicListUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicComboBoxUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicButtonUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicLabelUI.getBaseline(JComponent c, int width, int height)
返回基线。
 int BasicPanelUI.getBaseline(JComponent c, int width, int height)
返回基线。
 Component.BaselineResizeBehavior BasicSpinnerUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicSliderUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTextAreaUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTreeUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTableUI.getBaselineResizeBehavior(JComponent c)
返回指示该组件的基线如何随大小的改变而发生更改的枚举。
 Component.BaselineResizeBehavior BasicProgressBarUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTabbedPaneUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicTextFieldUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicScrollPaneUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicListUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicComboBoxUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicButtonUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicLabelUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
 Component.BaselineResizeBehavior BasicPanelUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
 Insets BasicDesktopIconUI.getInsets(JComponent c)
 Insets BasicSplitPaneUI.getInsets(JComponent jc)
返回 insets。
 Dimension BasicDesktopIconUI.getMaximumSize(JComponent c)
不能调整桌面图标的大小。
 Dimension BasicDesktopPaneUI.getMaximumSize(JComponent c)
 Dimension BasicInternalFrameUI.getMaximumSize(JComponent x)
 Dimension BasicToolTipUI.getMaximumSize(JComponent c)
 Dimension BasicSliderUI.getMaximumSize(JComponent c)
 Dimension BasicSplitPaneUI.getMaximumSize(JComponent jc)
返回传入组件的最大大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getMaximumSize(JComponent c)
返回此组件的最大大小，如果实例当前位于 JTree 中或 0, 0 处，则该大小将为首选大小。
 Dimension BasicTableUI.getMaximumSize(JComponent c)
返回表的最大大小。
 Dimension BasicTableHeaderUI.getMaximumSize(JComponent c)
返回标题的最大大小。
 Dimension BasicProgressBarUI.getMaximumSize(JComponent c)
 Dimension BasicTabbedPaneUI.getMaximumSize(JComponent c)
 Dimension BasicTextUI.getMaximumSize(JComponent c)
获取编辑器组件的最大大小。
 Dimension BasicScrollPaneUI.getMaximumSize(JComponent c)
 Dimension BasicComboBoxUI.getMaximumSize(JComponent c)
 Dimension BasicScrollBarUI.getMaximumSize(JComponent c)
 Dimension BasicSeparatorUI.getMaximumSize(JComponent c)
 Dimension BasicMenuUI.getMaximumSize(JComponent c)
 Dimension BasicMenuItemUI.getMaximumSize(JComponent c)
 Dimension BasicMenuBarUI.getMaximumSize(JComponent c)
 Dimension BasicButtonUI.getMaximumSize(JComponent c)
 Dimension BasicLabelUI.getMaximumSize(JComponent c)
 Dimension BasicDesktopIconUI.getMinimumSize(JComponent c)
 Dimension BasicDesktopPaneUI.getMinimumSize(JComponent c)
 Dimension BasicInternalFrameUI.getMinimumSize(JComponent x)
 Dimension BasicToolTipUI.getMinimumSize(JComponent c)
 Dimension BasicSliderUI.getMinimumSize(JComponent c)
 Dimension BasicTextAreaUI.getMinimumSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。
 Dimension BasicSplitPaneUI.getMinimumSize(JComponent jc)
返回传入组件的最小大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getMinimumSize(JComponent c)
返回此组件的最小大小。
 Dimension BasicTableUI.getMinimumSize(JComponent c)
返回表的最小大小。
 Dimension BasicTableHeaderUI.getMinimumSize(JComponent c)
返回标题的最小大小。
 Dimension BasicProgressBarUI.getMinimumSize(JComponent c)
此组件的最小大小为 10。
 Dimension BasicTabbedPaneUI.getMinimumSize(JComponent c)
 Dimension BasicTextUI.getMinimumSize(JComponent c)
获取编辑器组件的最小大小。
 Dimension BasicComboBoxUI.getMinimumSize(JComponent c)
最小大小为显示区域加上 insets 再加上按钮的大小。
 Dimension BasicSeparatorUI.getMinimumSize(JComponent c)
 Dimension BasicMenuItemUI.getMinimumSize(JComponent c)
 Dimension BasicMenuBarUI.getMinimumSize(JComponent c)
 Dimension BasicButtonUI.getMinimumSize(JComponent c)
 Dimension BasicLabelUI.getMinimumSize(JComponent c)
protected  Dimension BasicMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
 Dimension BasicDesktopIconUI.getPreferredSize(JComponent c)
 Dimension BasicDesktopPaneUI.getPreferredSize(JComponent c)
 Dimension BasicInternalFrameUI.getPreferredSize(JComponent x)
 Dimension BasicOptionPaneUI.getPreferredSize(JComponent c)
如果 c 为包含接收者的 JOptionPane，则返回的首选大小为 JOptionPane 的 LayoutManager 的最大首选大小和 getMinimumOptionPaneSize。
 Dimension BasicPopupMenuSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicToolTipUI.getPreferredSize(JComponent c)
 Dimension BasicSliderUI.getPreferredSize(JComponent c)
 Dimension BasicTextAreaUI.getPreferredSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。
 Dimension BasicSplitPaneUI.getPreferredSize(JComponent jc)
返回传入组件的首选大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getPreferredSize(JComponent c)
返回首选大小以正确显示树，这是一种 getPreferredSize(c, false) 的替代方法。
 Dimension BasicTableUI.getPreferredSize(JComponent c)
返回表的首选大小。
 Dimension BasicTableHeaderUI.getPreferredSize(JComponent c)
返回标题的首选大小。
 Dimension BasicProgressBarUI.getPreferredSize(JComponent c)
 Dimension BasicRadioButtonUI.getPreferredSize(JComponent c)
单选按钮的首选大小。
 Dimension BasicToolBarSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicTextUI.getPreferredSize(JComponent c)
获取编辑器组件的首选大小。
 Dimension BasicListUI.getPreferredSize(JComponent c)
列表的 preferredSize 依赖于布局方向。
 Dimension BasicComboBoxUI.getPreferredSize(JComponent c)
 Dimension BasicScrollBarUI.getPreferredSize(JComponent c)
垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。
 Dimension BasicSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicMenuItemUI.getPreferredSize(JComponent c)
 Dimension BasicButtonUI.getPreferredSize(JComponent c)
 Dimension BasicLabelUI.getPreferredSize(JComponent c)
 Dimension BasicTreeUI.getPreferredSize(JComponent c, boolean checkConsistancy)
返回首选大小以表示 c 中的树。
protected  void BasicToolTipUI.installDefaults(JComponent c)
protected  void BasicViewportUI.installDefaults(JComponent c)
 void BasicButtonListener.installKeyboardActions(JComponent c)
注册默认键动作：按下空格键以“单击”按钮并注册键盘助记符（如果有）。
protected  void BasicToolTipUI.installListeners(JComponent c)
protected  void BasicInternalFrameUI.installMouseHandlers(JComponent c)
protected  void BasicToolBarUI.installNonRolloverBorders(JComponent c)
在 JComponent 的所有子组件上安装非翻转边框。
protected  void BasicToolBarUI.installNormalBorders(JComponent c)
在 JComponent 的所有子组件上安装普通边框。
protected  void BasicToolBarUI.installRolloverBorders(JComponent c)
在 JComponent 的所有子组件上安装翻转边框。
 void BasicColorChooserUI.installUI(JComponent c)
 void BasicDesktopIconUI.installUI(JComponent c)
 void BasicDesktopPaneUI.installUI(JComponent c)
 void BasicEditorPaneUI.installUI(JComponent c)
安装组件的 UI。
 void BasicFileChooserUI.installUI(JComponent c)
 void BasicInternalFrameUI.installUI(JComponent c)
 void BasicOptionPaneUI.installUI(JComponent c)
安装作为传入 JOptionPane 的 L&F 的接收者。
 void BasicSpinnerUI.installUI(JComponent c)
调用 installDefaults、installListeners，然后添加由 createNextButton、createPreviousButton 和 createEditor 返回的组件。
 void BasicTextPaneUI.installUI(JComponent c)
 void BasicToolTipUI.installUI(JComponent c)
 void BasicSliderUI.installUI(JComponent c)
 void BasicSplitPaneUI.installUI(JComponent c)
安装 UI。
 void BasicTreeUI.installUI(JComponent c)
 void BasicTableUI.installUI(JComponent c)
 void BasicTableHeaderUI.installUI(JComponent c)
 void BasicProgressBarUI.installUI(JComponent c)
 void BasicTabbedPaneUI.installUI(JComponent c)
 void BasicTextUI.installUI(JComponent c)
安装组件的 UI。
 void BasicScrollPaneUI.installUI(JComponent x)
 void BasicViewportUI.installUI(JComponent c)
 void BasicListUI.installUI(JComponent c)
按顺序调用 installDefaults()、installListeners() 和 installKeyboardActions() 来初始化 this.list。
 void BasicComboBoxUI.installUI(JComponent c)
 void BasicScrollBarUI.installUI(JComponent c)
 void BasicSeparatorUI.installUI(JComponent c)
 void BasicPopupMenuUI.installUI(JComponent c)
 void BasicMenuItemUI.installUI(JComponent c)
 void BasicToolBarUI.installUI(JComponent c)
 void BasicMenuBarUI.installUI(JComponent c)
 void BasicButtonUI.installUI(JComponent c)
 void BasicLabelUI.installUI(JComponent c)
 void BasicRootPaneUI.installUI(JComponent c)
 void BasicPanelUI.installUI(JComponent c)
 void BasicDesktopIconUI.MouseInputHandler.moveAndRepaint(JComponent f, int newX, int newY, int newWidth, int newHeight)
 void BasicDesktopPaneUI.paint(Graphics g, JComponent c)
 void BasicPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
 void BasicToolTipUI.paint(Graphics g, JComponent c)
 void BasicSliderUI.paint(Graphics g, JComponent c)
 void BasicSplitPaneUI.paint(Graphics g, JComponent jc)
传递消息以绘制外观。
 void BasicTreeUI.paint(Graphics g, JComponent c)
 void BasicTableUI.paint(Graphics g, JComponent c)
绘制用 installUI() 设置的 table 实例的表示形式。
 void BasicTableHeaderUI.paint(Graphics g, JComponent c)
 void BasicProgressBarUI.paint(Graphics g, JComponent c)
将绘制委托给两种方法之一：paintDeterminate 和 paintIndeterminate。
 void BasicRadioButtonUI.paint(Graphics g, JComponent c)
绘制单选按钮
 void BasicTabbedPaneUI.paint(Graphics g, JComponent c)
 void BasicToolBarSeparatorUI.paint(Graphics g, JComponent c)
 void BasicTextUI.paint(Graphics g, JComponent c)
绘制界面。
 void BasicScrollPaneUI.paint(Graphics g, JComponent c)
 void BasicListUI.paint(Graphics g, JComponent c)
绘制与 Graphics 对象 clipRect 相交的行。
 void BasicComboBoxUI.paint(Graphics g, JComponent c)
 void BasicScrollBarUI.paint(Graphics g, JComponent c)
 void BasicSeparatorUI.paint(Graphics g, JComponent c)
 void BasicMenuItemUI.paint(Graphics g, JComponent c)
 void BasicToggleButtonUI.paint(Graphics g, JComponent c)
 void BasicButtonUI.paint(Graphics g, JComponent c)
 void BasicLabelUI.paint(Graphics g, JComponent c)
使用前景色绘制标签文本，如果标签不透明，则利用背景色绘制整个背景。
protected  void BasicProgressBarUI.paintDeterminate(Graphics g, JComponent c)
对几乎所有线性、确定进度条都能正确执行操作的多用途绘制方法。
protected  void BasicTreeUI.paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
绘制水平线。
protected  void BasicButtonUI.paintIcon(Graphics g, JComponent c, Rectangle iconRect)
protected  void BasicProgressBarUI.paintIndeterminate(Graphics g, JComponent c)
对所有线性跳动框进度条都能正确执行操作的多用途绘制方法。
protected  void BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
protected  void BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
protected  void BasicScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected  void BasicScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected  void BasicTreeUI.paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
绘制垂直线。
protected  void BasicSpinnerUI.replaceEditor(JComponent oldEditor, JComponent newEditor)
当 JSpinner 编辑器属性更改时，由 PropertyChangeListener 调用。
protected  void BasicInternalFrameUI.replacePane(JComponent currentPane, JComponent newPane)
将必需的鼠标处理程序安装在 newPane 上并将其添加到窗体。
 void BasicInternalFrameUI.setEastPane(JComponent c)
 void BasicInternalFrameUI.setNorthPane(JComponent c)
 void BasicInternalFrameUI.setSouthPane(JComponent c)
 void BasicInternalFrameUI.setWestPane(JComponent c)
protected  void BasicToolTipUI.uninstallDefaults(JComponent c)
protected  void BasicViewportUI.uninstallDefaults(JComponent c)
 void BasicButtonListener.uninstallKeyboardActions(JComponent c)
未注册的默认键动作
protected  void BasicToolTipUI.uninstallListeners(JComponent c)
protected  void BasicScrollPaneUI.uninstallListeners(JComponent c)
 void BasicColorChooserUI.uninstallUI(JComponent c)
 void BasicDesktopIconUI.uninstallUI(JComponent c)
 void BasicDesktopPaneUI.uninstallUI(JComponent c)
 void BasicEditorPaneUI.uninstallUI(JComponent c)
卸载组件的 UI。
 void BasicFileChooserUI.uninstallUI(JComponent c)
 void BasicInternalFrameUI.uninstallUI(JComponent c)
 void BasicOptionPaneUI.uninstallUI(JComponent c)
从传入拆分窗格的 L&F 控制器移除接收者。
 void BasicSpinnerUI.uninstallUI(JComponent c)
调用 uninstallDefaults、uninstallListeners，然后移除所有子 spinner。
 void BasicToolTipUI.uninstallUI(JComponent c)
 void BasicSliderUI.uninstallUI(JComponent c)
 void BasicSplitPaneUI.uninstallUI(JComponent c)
卸载 UI。
 void BasicTreeUI.uninstallUI(JComponent c)
 void BasicTableUI.uninstallUI(JComponent c)
 void BasicTableHeaderUI.uninstallUI(JComponent c)
 void BasicProgressBarUI.uninstallUI(JComponent c)
 void BasicTabbedPaneUI.uninstallUI(JComponent c)
 void BasicTextUI.uninstallUI(JComponent c)
卸载组件的 UI。
 void BasicScrollPaneUI.uninstallUI(JComponent c)
 void BasicViewportUI.uninstallUI(JComponent c)
 void BasicListUI.uninstallUI(JComponent c)
按顺序调用 uninstallListeners()、uninstallKeyboardActions() 和 uninstallDefaults() 来取消初始化 this.list。
 void BasicComboBoxUI.uninstallUI(JComponent c)
 void BasicScrollBarUI.uninstallUI(JComponent c)
 void BasicSeparatorUI.uninstallUI(JComponent c)
 void BasicPopupMenuUI.uninstallUI(JComponent c)
 void BasicMenuItemUI.uninstallUI(JComponent c)
 void BasicToolBarUI.uninstallUI(JComponent c)
 void BasicMenuBarUI.uninstallUI(JComponent c)
 void BasicButtonUI.uninstallUI(JComponent c)
 void BasicLabelUI.uninstallUI(JComponent c)
 void BasicRootPaneUI.uninstallUI(JComponent c)
 void BasicPanelUI.uninstallUI(JComponent c)
 void BasicTextUI.update(Graphics g, JComponent c)
超类以无法控制的方式绘制背景（即有人可能希望将图像平铺在背景中）。
 void BasicMenuItemUI.update(Graphics g, JComponent c)
使用 paintMenuItem() 绘制背景，从而重写 update（默认情况下填充不透明组件的背景）以调用 paint()。
static void BasicHTML.updateRenderer(JComponent c, String text)
将给定文本的 HTML 渲染器隐藏在给定 JComponent 的客户端属性中。

javax.swing.plaf.metal 中 JComponent 的使用

javax.swing.plaf.metal 中 JComponent 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

返回 JComponent 的 javax.swing.plaf.metal 中的方法
protected  JComponent MetalInternalFrameUI.createNorthPane(JInternalFrame w)

参数类型为 JComponent 的 javax.swing.plaf.metal 中的方法
static ComponentUI | MetalDesktopIconUI.createUI(JComponent c)
static ComponentUI | MetalFileChooserUI.createUI(JComponent c)
static ComponentUI | MetalInternalFrameUI.createUI(JComponent c)
static ComponentUI | MetalToolTipUI.createUI(JComponent c)
static ComponentUI | MetalSliderUI.createUI(JComponent c)
static ComponentUI | MetalSplitPaneUI.createUI(JComponent x) 创建一个新的 MetalSplitPaneUI 实例
static ComponentUI | MetalTreeUI.createUI(JComponent x)
static ComponentUI | MetalProgressBarUI.createUI(JComponent c)
static ComponentUI | MetalCheckBoxUI.createUI(JComponent b)
static ComponentUI | MetalRadioButtonUI.createUI(JComponent c)
static ComponentUI | MetalTabbedPaneUI.createUI(JComponent x)
static ComponentUI | MetalTextFieldUI.createUI(JComponent c)
static ComponentUI | MetalScrollPaneUI.createUI(JComponent x)
static ComponentUI | MetalComboBoxUI.createUI(JComponent c)
static ComponentUI | MetalScrollBarUI.createUI(JComponent c)
static ComponentUI | MetalPopupMenuSeparatorUI.createUI(JComponent c)
static ComponentUI | MetalSeparatorUI.createUI(JComponent c)
static ComponentUI | MetalToolBarUI.createUI(JComponent c)
static ComponentUI | MetalMenuBarUI.createUI(JComponent x) 为传入的组件创建 ComponentUI 实现。
static ComponentUI | MetalToggleButtonUI.createUI(JComponent b)
static ComponentUI | MetalButtonUI.createUI(JComponent c)
static ComponentUI | MetalLabelUI.createUI(JComponent c)
static ComponentUI | MetalRootPaneUI.createUI(JComponent c) 为 JRootPane 创建一个 UI。
int | MetalComboBoxUI.getBaseline(JComponent c, int width, int height) 返回基线。
Icon | MetalLookAndFeel.getDisabledIcon(JComponent component, Icon icon) 返回具有禁用外观的 Icon。
Icon | MetalLookAndFeel.getDisabledSelectedIcon(JComponent component, Icon icon) 返回由选定的禁用组件使用的 Icon。
Dimension | MetalDesktopIconUI.getMaximumSize(JComponent c)
Dimension | MetalFileChooserUI.getMaximumSize(JComponent c) 返回 JFileChooser 的最大大小。
Dimension | MetalDesktopIconUI.getMinimumSize(JComponent c)
Dimension | MetalFileChooserUI.getMinimumSize(JComponent c) 返回 JFileChooser 的最小大小。
Dimension | MetalComboBoxUI.getMinimumSize(JComponent c)
Dimension | MetalDesktopIconUI.getPreferredSize(JComponent c)
Dimension | MetalFileChooserUI.getPreferredSize(JComponent c) 返回指定 JFileChooser 的首选大小。
Dimension | MetalToolTipUI.getPreferredSize(JComponent c)
Dimension | MetalScrollBarUI.getPreferredSize(JComponent c)
Dimension | MetalPopupMenuSeparatorUI.getPreferredSize(JComponent c)
Dimension | MetalSeparatorUI.getPreferredSize(JComponent c)
void | MetalFileChooserUI.installUI(JComponent c)
void | MetalInternalFrameUI.installUI(JComponent c)
void | MetalToolTipUI.installUI(JComponent c)
void | MetalSliderUI.installUI(JComponent c)
void | MetalTreeUI.installUI(JComponent c)
void | MetalScrollPaneUI.installUI(JComponent c)
void | MetalToolBarUI.installUI(JComponent c)
void | MetalMenuBarUI.installUI(JComponent c) 配置指定组件，使其适合 metal 外观。
void | MetalRootPaneUI.installUI(JComponent c) 调用 installUI 的超实现来在传入的 JRootPane 上安装必要的状态，以呈现 RootPaneUI 的 metal 外观实现。
void | MetalToolTipUI.paint(Graphics g, JComponent c)
void | MetalTreeUI.paint(Graphics g, JComponent c)
void | MetalRadioButtonUI.paint(Graphics g, JComponent c)
void | MetalTabbedPaneUI.paint(Graphics g, JComponent c)
void | MetalComboBoxUI.paint(Graphics g, JComponent c)
void | MetalPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
void | MetalSeparatorUI.paint(Graphics g, JComponent c)
void | MetalProgressBarUI.paintDeterminate(Graphics g, JComponent c) 在进度条上绘制少量特殊的高亮显示。
protected void | MetalTreeUI.paintHorizontalSeparators(Graphics g, JComponent c)
void | MetalProgressBarUI.paintIndeterminate(Graphics g, JComponent c) 在进度条和跳动框上绘制少量特殊的高亮显示。
protected void | MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected void | MetalScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
void | MetalFileChooserUI.uninstallUI(JComponent c)
void | MetalInternalFrameUI.uninstallUI(JComponent c)
void | MetalToolTipUI.uninstallUI(JComponent c)
void | MetalTreeUI.uninstallUI(JComponent c)
void | MetalScrollPaneUI.uninstallUI(JComponent c)
void | MetalToolBarUI.uninstallUI(JComponent c)
void | MetalMenuBarUI.uninstallUI(JComponent c) 在 installUI 期间，在指定组件上反向执行的配置操作。
void | MetalRootPaneUI.uninstallUI(JComponent c) 调用超实现来卸载所有状态。
void | MetalTabbedPaneUI.update(Graphics g, JComponent c)
void | MetalToolBarUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalMenuBarUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalToggleButtonUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalButtonUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。

javax.swing.plaf.multi 中 JComponent 的使用

参数类型为 JComponent 的 javax.swing.plaf.multi 中的方法
boolean | MultiButtonUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiColorChooserUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiComboBoxUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiDesktopIconUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiDesktopPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiFileChooserUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiInternalFrameUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiLabelUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiListUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiMenuBarUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiMenuItemUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiOptionPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiPanelUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiPopupMenuUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiProgressBarUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiRootPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiScrollBarUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiScrollPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiSeparatorUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiSliderUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiSpinnerUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiSplitPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTabbedPaneUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTableHeaderUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTableUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTextUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiToolBarUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiToolTipUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiTreeUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
boolean | MultiViewportUI.contains(JComponent a, int b, int c) 在由此对象处理的每个 UI 上调用 contains 方法。
static ComponentUI | MultiButtonUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiColorChooserUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiComboBoxUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiDesktopIconUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiDesktopPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiFileChooserUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiInternalFrameUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiLabelUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiListUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiMenuBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiMenuItemUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiOptionPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiPanelUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiPopupMenuUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiProgressBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiRootPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiScrollBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiScrollPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSeparatorUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSliderUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSpinnerUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiSplitPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTabbedPaneUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTableHeaderUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTableUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTextUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiToolBarUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiToolTipUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiTreeUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiViewportUI.createUI(JComponent a) 如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
static ComponentUI | MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target) 创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
Accessible | MultiButtonUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiColorChooserUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiComboBoxUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiDesktopIconUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiDesktopPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiFileChooserUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiInternalFrameUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiLabelUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiListUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiMenuBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiMenuItemUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiOptionPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiPanelUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiPopupMenuUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiProgressBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiRootPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiScrollBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiScrollPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSeparatorUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSliderUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSpinnerUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSplitPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTabbedPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTableHeaderUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTableUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTextUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiToolBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiToolTipUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTreeUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiViewportUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
int | MultiButtonUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiColorChooserUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiComboBoxUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiDesktopIconUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiDesktopPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiFileChooserUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiInternalFrameUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiLabelUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiListUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiMenuBarUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiMenuItemUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiOptionPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiPanelUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiPopupMenuUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiProgressBarUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiRootPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiScrollBarUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiScrollPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiSeparatorUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiSliderUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiSpinnerUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiSplitPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTabbedPaneUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTableHeaderUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTableUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTextUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiToolBarUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiToolTipUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiTreeUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
int | MultiViewportUI.getAccessibleChildrenCount(JComponent a) 在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
Dimension | MultiButtonUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiColorChooserUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiComboBoxUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiDesktopIconUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiDesktopPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiFileChooserUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法
Dimension | MultiInternalFrameUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiLabelUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiListUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiMenuBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiMenuItemUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiOptionPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiPanelUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiPopupMenuUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiProgressBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiRootPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiScrollBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiScrollPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSeparatorUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSliderUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSpinnerUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSplitPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTabbedPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTableHeaderUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTableUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTextUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiToolBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiToolTipUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTreeUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiViewportUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiButtonUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiColorChooserUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiComboBoxUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiDesktopIconUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiDesktopPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiFileChooserUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiInternalFrameUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiLabelUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiListUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiMenuBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiMenuItemUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiOptionPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiPanelUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiPopupMenuUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiProgressBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiRootPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiScrollBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiScrollPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSeparatorUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSliderUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSpinnerUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSplitPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTabbedPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTableHeaderUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTableUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTextUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiToolBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiToolTipUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTreeUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiViewportUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiButtonUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiColorChooserUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiComboBoxUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiDesktopIconUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiDesktopPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiFileChooserUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiInternalFrameUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiLabelUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiListUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiMenuBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiMenuItemUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiOptionPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiPanelUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiPopupMenuUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiProgressBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiRootPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiScrollBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiScrollPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSeparatorUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSliderUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSpinnerUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSplitPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTabbedPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTableHeaderUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTableUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTextUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiToolBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiToolTipUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTreeUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiViewportUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
void | MultiButtonUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiColorChooserUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiComboBoxUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiDesktopIconUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiDesktopPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiFileChooserUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiInternalFrameUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiLabelUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiListUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiMenuBarUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiMenuItemUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiOptionPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiPanelUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiPopupMenuUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiProgressBarUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiRootPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiScrollBarUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiScrollPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiSeparatorUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiSliderUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiSpinnerUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiSplitPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTabbedPaneUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTableHeaderUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTableUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTextUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiToolBarUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiToolTipUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiTreeUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiViewportUI.installUI(JComponent a) 在由此对象处理的每个 UI 上调用 installUI 方法。
void | MultiButtonUI.paint(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 paint 方法。
void | MultiColorChooserUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法
void | MultiComboBoxUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiDesktopIconUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiDesktopPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiFileChooserUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiInternalFrameUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiLabelUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiListUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiMenuBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiMenuItemUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiOptionPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiPanelUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiPopupMenuUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiProgressBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiRootPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiScrollBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiScrollPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSeparatorUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSliderUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSpinnerUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSplitPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTabbedPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTableHeaderUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTableUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTextUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiToolBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiToolTipUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTreeUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiViewportUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiButtonUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiColorChooserUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiComboBoxUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiDesktopIconUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiDesktopPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiFileChooserUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiInternalFrameUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiLabelUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiListUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiMenuBarUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiMenuItemUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiOptionPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiPanelUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiPopupMenuUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiProgressBarUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiRootPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiScrollBarUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiScrollPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiSeparatorUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiSliderUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiSpinnerUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiSplitPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTabbedPaneUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTableHeaderUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTableUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTextUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiToolBarUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiToolTipUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiTreeUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiViewportUI.uninstallUI(JComponent a) 在由此对象处理的每个 UI 上调用 uninstallUI 方法。
void | MultiButtonUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiColorChooserUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiComboBoxUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiDesktopIconUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiDesktopPaneUI.update(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 update 方法。
void | MultiFileChooserUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiInternalFrameUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiLabelUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiListUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiMenuBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiMenuItemUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiOptionPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiPanelUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiPopupMenuUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiProgressBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiRootPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiScrollBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiScrollPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSeparatorUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSliderUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSpinnerUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSplitPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTabbedPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTableHeaderUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTableUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTextUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiToolBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiToolTipUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTreeUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiViewportUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。

javax.swing.plaf.synth 中 JComponent 的使用

返回 JComponent 的 javax.swing.plaf.synth 中的方法
 JComponent SynthContext.getComponent()
返回包含 region 的承载组件。

参数类型为 JComponent 的 javax.swing.plaf.synth 中的方法
static ComponentUI | SynthLookAndFeel.createUI(JComponent c) 为传入的 JComponent 创建 Synth 外观 ComponentUI。
static Region | SynthLookAndFeel.getRegion(JComponent c) 返回 JComponent c 的 Region。
abstract SynthStyle | SynthStyleFactory.getStyle(JComponent c, Region id) 返回指定 Component 的样式。
static SynthStyle | SynthLookAndFeel.getStyle(JComponent c, Region region) 获取指定组件的指定 region 的 SynthStyle。

参数类型为 JComponent 的 javax.swing.plaf.synth 中的构造方法
SynthContext(JComponent component, Region region, SynthStyle style, int state)
创建一个具有指定值的 SynthContext。

javax.swing.table 中 JComponent 的使用

javax.swing.table 中 JComponent 的子类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

javax.swing.text 中 JComponent 的使用

javax.swing.text 中 JComponent 的子类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.tree 中 JComponent 的使用

javax.swing.tree 中 JComponent 的子类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JComponent.AccessibleJComponent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComponent.AccessibleJComponent
的使用

使用 JComponent.AccessibleJComponent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 JComponent.AccessibleJComponent 的使用

javax.swing 中 JComponent.AccessibleJComponent 的子类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。

javax.swing.table 中 JComponent.AccessibleJComponent 的使用

javax.swing.table 中 JComponent.AccessibleJComponent 的子类
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

javax.swing.text 中 JComponent.AccessibleJComponent 的使用

javax.swing.text 中 JComponent.AccessibleJComponent 的子类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
的使用

没有 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
的使用

没有 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.SwingConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.SwingConstants
的使用

使用 SwingConstants 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing 中的类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuItem 菜单中的项的实现。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | SwingUtilities Swing 实用方法的集合。

javax.swing.plaf.basic 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
class | BasicScrollBarUI 基本外观的 ScrollBarUI 的实现
class | BasicTabbedPaneUI TabbedPaneUI 的基本 L&F 实现。
class | BasicToolBarUI ToolBarUI 的基本 L&F 实现。

javax.swing.plaf.metal 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.plaf.metal 中的类
static class | MetalBorders.ToolBarBorder
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalScrollBarUI ScrollBarUI 的 Metal 外观实现
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。
class | MetalTabbedPaneUI BasicTabbedPaneUI 的 Metal 子类。
class | MetalToolBarUI ToolBarUI 的 Metal 外观实现。

javax.swing.table 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。

javax.swing.text 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.text 中的类
class | AsyncBoxView 异步执行布局处理的框。
class | BoxView 一个视图，它通过沿某轴平铺将其子级排列到框形状中。
class | ComponentView 实现视图接口的组件装饰器。
class | CompositeView CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
class | FieldView 扩展多行纯文本视图，使其适合单行编辑器视图。
class | FlowView 试图将其子级流入某个部分受约束的空间的视图。
class | GlyphView GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
class | IconView 实现视图接口的图标修饰符。
class | LabelView LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
class | ParagraphView 存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
class | PasswordView 实现适用于 JPasswordField UI 实现的视图。
class | PlainView 实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
class | TableView 为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。
class | TableView.TableRow 以行为中心的表格中的行视图。
class | View View 类是 text 包极为重要的一部分。
class | WrappedPlainView 进行换行的纯文本（仅有一种字体和颜色的文本）视图。
class | ZoneView ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

javax.swing.text.html 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.text.html 中的类
class | BlockView 用来显示具有 CSS 规范的块（作为一个框）的视图实现。
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
class | ImageView 图像视图，用于支持 HTML <IMG> 标记。
class | InlineView 显示基于 css 属性的 inline element 样式。
class | ListView 用于显示 html 列表的视图实现。
class | ObjectView 实现 <object> 元素视图接口的组件装饰符。

javax.swing.tree 中 SwingConstants 的使用

实现 SwingConstants 的 javax.swing.tree 中的类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JFrame 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFrame
的使用

使用 JFrame 的软件包
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt.im.spi 中 JFrame 的使用

返回 JFrame 的 java.awt.im.spi 中的方法
 JFrame InputMethodContext.createInputMethodJFrame(String title, boolean attachToInputContext)
创建输入方法使用的顶层 Swing JFrame。

javax.swing.plaf.basic 中 JFrame 的使用

返回 JFrame 的 javax.swing.plaf.basic 中的方法
protected  JFrame BasicToolBarUI.createFloatingFrame(JToolBar toolbar)
不再使用，使用 BasicToolBarUI.createFloatingWindow(JToolBar)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.swing.JFrame.AccessibleJFrame 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.JFrame.AccessibleJFrame
的使用

没有 javax.swing.JFrame.AccessibleJFrame 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.RootPaneContainer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.RootPaneContainer
的使用

使用 RootPaneContainer 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 RootPaneContainer 的使用

实现 RootPaneContainer 的 javax.swing 中的类
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JDialog 创建对话框窗口的主要类。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

javax.swing.plaf.basic 中 RootPaneContainer 的使用

返回 RootPaneContainer 的 javax.swing.plaf.basic 中的方法
protected  RootPaneContainer BasicToolBarUI.createFloatingWindow(JToolBar toolbar)
创建将工具栏拖出其容器后包含该工具栏的窗口

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.swing.WindowConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.WindowConstants
的使用

使用 WindowConstants 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 WindowConstants 的使用

实现 WindowConstants 的 javax.swing 中的类
class | JDialog 创建对话框窗口的主要类。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Diagnostic (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 Diagnostic<S>

类型参数：
S - 此诊断使用的源对象类型
public interface Diagnostic<S>

用于来自工具的诊断的接口。诊断通常报告源文件中指定位置处的问题。但是，并非所有的诊断都与位置或文件关联。

位置是指距文件开始位置的字符偏移量（从 0 开始）。负值（除 NOPOS 以外）不是有效位置。

行号和列号从 1 开始。负值（除 NOPOS 以外）和 0 不是有效的行号或列号。

从以下版本开始：
1.6

嵌套类摘要
static class Diagnostic.Kind
诊断的种类，例如，错误或者警告。
字段摘要
static long NOPOS
用于指示没有可用的位置。
方法摘要
 String getCode()
获取指示诊断类型的诊断代码。
 long getColumnNumber()
返回由 getPosition() 返回的字符偏移量的列号。
 long getEndPosition()
获取距文件开始位置的字符偏移量，其中文件与指示问题结束位置的此诊断关联。
 Diagnostic.Kind getKind()
获取此诊断的类型，例如，错误或者警告。
 long getLineNumber()
返回由 getPosition() 返回的字符偏移量的行号。
 String getMessage(Locale locale)
获取给定语言环境的本地化消息。
 long getPosition()
获取距源对象开始位置的字符偏移量，其中源对象与指示问题位置的此诊断关联。
 S getSource()
获取与此诊断关联的源对象。
 long getStartPosition()
获取距文件开始位置的字符偏移量，其中文件与指示问题开始位置的此诊断关联。

字段详细信息

NOPOS

static final long NOPOS
用于指示没有可用的位置。

另请参见：
常量字段值
方法详细信息

getKind

Diagnostic.Kind getKind()
获取此诊断的类型，例如，错误或者警告。

返回：
此诊断的类型

getSource

S getSource()
获取与此诊断关联的源对象。

返回：
与此诊断关联的源对象。如果没有源对象与此诊断关联，则返回 null。

getPosition

long getPosition()
获取距源对象开始位置的字符偏移量，其中源对象与指示问题位置的此诊断关联。此外，以下表达式必须为 true：

getStartPostion() &lt;= getPosition()

getPosition() &lt;= getEndPosition()

返回：
距源开始位置的字符偏移量；如果 getSource() 返回 null 或者没有合适的位置，则返回 NOPOS

getStartPosition

long getStartPosition()
获取距文件开始位置的字符偏移量，其中文件与指示问题开始位置的此诊断关联。

返回：
距文件开始位置的偏移量；当且仅当 getPosition() 返回 NOPOS 时，返回 NOPOS

getEndPosition

long getEndPosition()
获取距文件开始位置的字符偏移量，其中文件与指示问题结束位置的此诊断关联。

返回：
距文件开始位置的偏移量；当且仅当 getPosition() 返回 NOPOS 时，返回 NOPOS

getLineNumber

long getLineNumber()
返回由 getPosition() 返回的字符偏移量的行号。

返回：
行号；当且仅当 getPosition() 返回 NOPOS 时，返回 NOPOS

getColumnNumber

long getColumnNumber()
返回由 getPosition() 返回的字符偏移量的列号。

返回：
列号；当且仅当 getPosition() 返回 NOPOS 时，返回 NOPOS

getCode

String getCode()
获取指示诊断类型的诊断代码。该代码是依赖于实现的，可以为 null。

返回：
诊断代码

getMessage

String getMessage(Locale locale)
获取给定语言环境的本地化消息。实际消息是依赖于实现的。如果 locale 为 null，则使用默认的语言环境。

参数：
locale - 语言环境；可以为 null
返回：
本地化消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Diagnostic.Kind (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.tools
枚举 Diagnostic.Kind

java.lang.Object
    继承者  java.lang.Enum<Diagnostic.Kind>
        继承者  javax.tools.Diagnostic.Kind
所有已实现的接口：
Serializable, Comparable<Diagnostic.Kind>
正在封闭接口：
Diagnostic<S>
public static enum Diagnostic.Kind
extends Enum<Diagnostic.Kind>

诊断的种类，例如，错误或者警告。

枚举常量摘要
ERROR
阻止工具正常完成的问题。
MANDATORY_WARNING
类似于警告，但由工具规范规定的问题。
NOTE
来自工具的包含许多信息的消息。
OTHER
不适合以上所有种类的诊断。
WARNING
通常不阻止工具正常完成的问题。
方法摘要
static Diagnostic.Kind | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Diagnostic.Kind[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

ERROR

public static final Diagnostic.Kind ERROR
阻止工具正常完成的问题。

WARNING

public static final Diagnostic.Kind WARNING
通常不阻止工具正常完成的问题。

MANDATORY_WARNING

public static final Diagnostic.Kind MANDATORY_WARNING
类似于警告，但由工具规范规定的问题。例如，Java™ Language Specification, 3rd Ed. 规定了有关某些未检查操作及使用已过时方法的警告。

NOTE

public static final Diagnostic.Kind NOTE
来自工具的包含许多信息的消息。

OTHER

public static final Diagnostic.Kind OTHER
不适合以上所有种类的诊断。

方法详细信息

values

public static final Diagnostic.Kind[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Diagnostic.Kind c : Diagnostic.Kind.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Diagnostic.Kind valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


DiagnosticCollector (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
类 DiagnosticCollector<S>

java.lang.Object
    继承者  javax.tools.DiagnosticCollector<S>
类型参数：
S - 此对象收到的诊断所使用的源对象的类型
所有已实现的接口：
DiagnosticListener<S>
public final class DiagnosticCollector<S>
extends Object
implements DiagnosticListener<S>

提供将诊断收集到一个列表中的简单方法。

从以下版本开始：
1.6

构造方法摘要
DiagnosticCollector()
方法摘要
List<Diagnostic<? extends S>> | getDiagnostics() 获取此对象收集的诊断所组成的列表视图。
void | report(Diagnostic<? extends S> diagnostic) 发现问题时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DiagnosticCollector

public DiagnosticCollector()
方法详细信息

report

public void report(Diagnostic<? extends S> diagnostic)
从接口 DiagnosticListener 复制的描述
发现问题时调用此方法。

指定者：
接口 DiagnosticListener<S> 中的 report
参数：
diagnostic - 表示所发现问题的诊断

getDiagnostics

public List<Diagnostic<? extends S>> getDiagnostics()
获取此对象收集的诊断所组成的列表视图。

返回：
诊断列表视图
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DiagnosticListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 DiagnosticListener<S>

类型参数：
S - 此侦听器收到的诊断所使用的源对象的类型
所有已知实现类：
DiagnosticCollector
public interface DiagnosticListener<S>

用于接收来自工具的诊断的接口。

从以下版本开始：
1.6

方法摘要
 void report(Diagnostic<? extends S> diagnostic)
发现问题时调用此方法。

方法详细信息

report

void report(Diagnostic<? extends S> diagnostic)
发现问题时调用此方法。

参数：
diagnostic - 表示所发现问题的诊断
抛出：
NullPointerException - 如果 diagnostic 参数为 null 并且该实现不能处理 null 参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 FileObject

所有已知子接口：
JavaFileObject
所有已知实现类：
ForwardingFileObject, ForwardingJavaFileObject, SimpleJavaFileObject
public interface FileObject

工具的文件抽象。在这里，文件 是指常规文件和其他数据源的抽象。例如，文件对象可用于表示常规文件、内存缓存或数据库中的数据。

如果发生安全异常，则此接口中的所有方法都将抛出 SecurityException。

除非明确允许，否则只要给定 null 参数，此接口中的所有方法都将抛出 NullPointerException。

从以下版本开始：
1.6

方法摘要
boolean | delete() 删除此文件对象。
CharSequence | getCharContent(boolean ignoreEncodingErrors) 返回此文件对象的字符内容（如果有）。
long | getLastModified() 获取最后一次修改此文件对象的时间。
String | getName() 获取此文件对象的用户友好 (user-friendly) 的名称。
InputStream | openInputStream() 获取此文件对象的 InputStream。
OutputStream | openOutputStream() 获取此文件对象的 OutputStream。
Reader | openReader(boolean ignoreEncodingErrors) 获取此对象的 reader。
Writer | openWriter() 获取此文件对象的 Writer。
URI | toUri() 返回标识此文件对象的 URI。

方法详细信息

toUri

URI toUri()
返回标识此文件对象的 URI。

返回：
URI

getName

String getName()
获取此文件对象的用户友好 (user-friendly) 的名称。没有指定返回的准确值，但是实现应该负责保存用户给定的名称。例如，如果用户在命令行中写入文件名 &quot;BobsApp\Test.java&quot;，则此方法应该返回 &quot;BobsApp\Test.java&quot;，而 toUri 方法可能返回 file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java。

返回：
用户友好的名称

openInputStream

InputStream openInputStream()
                            throws IOException
获取此文件对象的 InputStream。

返回：
InputStream
抛出：
IllegalStateException - 如果此文件对象是为写入而打开的，不支持读取操作
UnsupportedOperationException - 如果这种文件对象不支持字节访问
IOException - 如果发生 I/O 错误

openOutputStream

OutputStream openOutputStream()
                              throws IOException
获取此文件对象的 OutputStream。

返回：
OutputStream
抛出：
IllegalStateException - 如果此文件对象是为读取而打开的，不支持写入操作
UnsupportedOperationException - 如果这种对象不支持字节访问
IOException - 如果发生 I/O 错误

openReader

Reader openReader(boolean ignoreEncodingErrors)
                  throws IOException
获取此对象的 reader。返回的 reader 将代替不能用默认转换字符解码的字节。此外，除非 ignoreEncodingErrors 为 true，否则 reader 可能报告一个诊断。

参数：
ignoreEncodingErrors - 如果为 true，则忽略编码错误
返回：
Reader
抛出：
IllegalStateException - 如果此文件对象是为写入而打开的，不支持读取操作
UnsupportedOperationException - 如果这种文件对象不支持字符访问
IOException - 如果发生 I/O 错误

getCharContent

CharSequence getCharContent(boolean ignoreEncodingErrors)
                            throws IOException
返回此文件对象的字符内容（如果有）。默认的转换字符将代替任何不能被解码的字节。此外，除非 ignoreEncodingErrors 为 true，否则可能报告一个诊断。

参数：
ignoreEncodingErrors - 如果为 true，则忽略编码错误
返回：
CharSequence（如果有）；否则返回 null
抛出：
IllegalStateException - 如果此文件对象是为写入而打开的，不支持读取操作
UnsupportedOperationException - 如果这种文件对象不支持字符访问
IOException - 如果发生 I/O 错误

openWriter

Writer openWriter()
                  throws IOException
获取此文件对象的 Writer。

返回：
Writer
抛出：
IllegalStateException - 如果此文件对象是为读取而打开的，不支持写入操作
UnsupportedOperationException - 如果这种文件对象不支持字符访问
IOException - 如果发生 I/O 错误

getLastModified

long getLastModified()
获取最后一次修改此文件对象的时间。该时间用距历元（1970 年 1 月 1 日 00:00:00，格林威治时间）的毫秒数计算。

返回：
最后一次修改此文件对象的时间；如果该文件对象不存在，发生 I/O 错误或者不支持该操作，则返回 0

delete

boolean delete()
删除此文件对象。如果发生错误，则返回 false。

返回：
当且仅当成功删除此文件对象时，返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ForwardingFileObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
类 ForwardingFileObject<F extends FileObject>

java.lang.Object
    继承者  javax.tools.ForwardingFileObject<F>
类型参数：
F - 此对象将转发到的文件对象的类型
所有已实现的接口：
FileObject
直接已知子类：
ForwardingJavaFileObject
public class ForwardingFileObject<F extends FileObject>
extends Object
implements FileObject

将调用转发到给定的文件对象。此类的子类可以重写其中某些方法，还可以提供附加字段和方法。

从以下版本开始：
1.6

字段摘要
protected  F fileObject
一个文件对象，所有方法都将委托给它。
构造方法摘要
protected ForwardingFileObject(F fileObject)
创建一个新的 ForwardingFileObject 实例。
方法摘要
boolean | delete() 删除此文件对象。
CharSequence | getCharContent(boolean ignoreEncodingErrors) 返回此文件对象的字符内容（如果有）。
long | getLastModified() 获取最后一次修改此文件对象的时间。
String | getName() 获取此文件对象的用户友好 (user-friendly) 的名称。
InputStream | openInputStream() 获取此文件对象的 InputStream。
OutputStream | openOutputStream() 获取此文件对象的 OutputStream。
Reader | openReader(boolean ignoreEncodingErrors) 获取此对象的 reader。
Writer | openWriter() 获取此文件对象的 Writer。
URI | toUri() 返回标识此文件对象的 URI。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

fileObject

protected final F extends FileObject fileObject
一个文件对象，所有方法都将委托给它。

构造方法详细信息

ForwardingFileObject

protected ForwardingFileObject(F fileObject)
创建一个新的 ForwardingFileObject 实例。

参数：
fileObject - 委托给此文件对象
方法详细信息

toUri

public URI toUri()
从接口 FileObject 复制的描述
返回标识此文件对象的 URI。

指定者：
接口 FileObject 中的 toUri
返回：
URI

getName

public String getName()
从接口 FileObject 复制的描述
获取此文件对象的用户友好 (user-friendly) 的名称。没有指定返回的准确值，但是实现应该负责保存用户给定的名称。例如，如果用户在命令行中写入文件名 &quot;BobsApp\Test.java&quot;，则此方法应该返回 &quot;BobsApp\Test.java&quot;，而 toUri 方法可能返回 file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java。

指定者：
接口 FileObject 中的 getName
返回：
用户友好的名称

openInputStream

public InputStream openInputStream()
                            throws IOException
从接口 FileObject 复制的描述
获取此文件对象的 InputStream。

指定者：
接口 FileObject 中的 openInputStream
返回：
InputStream
抛出：
IllegalStateException - 如果此文件对象是为写入而打开的，不支持读取操作
UnsupportedOperationException - 如果这种文件对象不支持字节访问
IOException - 如果发生 I/O 错误

openOutputStream

public OutputStream openOutputStream()
                              throws IOException
从接口 FileObject 复制的描述
获取此文件对象的 OutputStream。

指定者：
接口 FileObject 中的 openOutputStream
返回：
OutputStream
抛出：
IllegalStateException - 如果此文件对象是为读取而打开的，不支持写入操作
UnsupportedOperationException - 如果这种对象不支持字节访问
IOException - 如果发生 I/O 错误

openReader

public Reader openReader(boolean ignoreEncodingErrors)
                  throws IOException
从接口 FileObject 复制的描述
获取此对象的 reader。返回的 reader 将代替不能用默认转换字符解码的字节。此外，除非 ignoreEncodingErrors 为 true，否则 reader 可能报告一个诊断。

指定者：
接口 FileObject 中的 openReader
参数：
ignoreEncodingErrors - 如果为 true，则忽略编码错误
返回：
Reader
抛出：
IllegalStateException - 如果此文件对象是为写入而打开的，不支持读取操作
UnsupportedOperationException - 如果这种文件对象不支持字符访问
IOException - 如果发生 I/O 错误

getCharContent

public CharSequence getCharContent(boolean ignoreEncodingErrors)
                            throws IOException
从接口 FileObject 复制的描述
返回此文件对象的字符内容（如果有）。默认的转换字符将代替任何不能被解码的字节。此外，除非 ignoreEncodingErrors 为 true，否则可能报告一个诊断。

指定者：
接口 FileObject 中的 getCharContent
参数：
ignoreEncodingErrors - 如果为 true，则忽略编码错误
返回：
CharSequence（如果有）；否则返回 null
抛出：
IllegalStateException - 如果此文件对象是为写入而打开的，不支持读取操作
UnsupportedOperationException - 如果这种文件对象不支持字符访问
IOException - 如果发生 I/O 错误

openWriter

public Writer openWriter()
                  throws IOException
从接口 FileObject 复制的描述
获取此文件对象的 Writer。

指定者：
接口 FileObject 中的 openWriter
返回：
Writer
抛出：
IllegalStateException - 如果此文件对象是为读取而打开的，不支持写入操作
UnsupportedOperationException - 如果这种文件对象不支持字符访问
IOException - 如果发生 I/O 错误

getLastModified

public long getLastModified()
从接口 FileObject 复制的描述
获取最后一次修改此文件对象的时间。该时间用距历元（1970 年 1 月 1 日 00:00:00，格林威治时间）的毫秒数计算。

指定者：
接口 FileObject 中的 getLastModified
返回：
最后一次修改此文件对象的时间；如果该文件对象不存在，发生 I/O 错误或者不支持该操作，则返回 0

delete

public boolean delete()
从接口 FileObject 复制的描述
删除此文件对象。如果发生错误，则返回 false。

指定者：
接口 FileObject 中的 delete
返回：
当且仅当成功删除此文件对象时，返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ForwardingJavaFileManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
类 ForwardingJavaFileManager<M extends JavaFileManager>

java.lang.Object
    继承者  javax.tools.ForwardingJavaFileManager<M>
类型参数：
M - 此对象将转发到的文件管理器的类型
所有已实现的接口：
Closeable, Flushable, JavaFileManager, OptionChecker
public class ForwardingJavaFileManager<M extends JavaFileManager>
extends Object
implements JavaFileManager

将调用转发到给定的文件管理器。此类的子类可以重写其中某些方法，还可以提供附加字段和方法。

从以下版本开始：
1.6

嵌套类摘要
从接口 javax.tools.JavaFileManager 继承的嵌套类/接口
JavaFileManager.Location
字段摘要
protected  M fileManager
一个文件管理器，所有方法都将委托给它。
构造方法摘要
protected ForwardingJavaFileManager(M fileManager)
创建一个新的 ForwardingJavaFileManager 的实例。
方法摘要
void | close() 释放此文件管理器直接或间接打开的所有资源。
void | flush() 刷新此文件管理器直接或间接为输出打开的所有资源。
ClassLoader | getClassLoader(JavaFileManager.Location location) 获取可从给定位置加载插件的类加载器。
FileObject | getFileForInput(JavaFileManager.Location location, String packageName, String relativeName) 获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
FileObject | getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
JavaFileObject | getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind) 获取输入的文件对象，它表示给定位置处指定类型的指定类。
JavaFileObject | getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。
boolean | handleOption(String current, Iterator<String> remaining) 处理一个选项。
boolean | hasLocation(JavaFileManager.Location location) 确定此文件管理器是否已知某位置。
String | inferBinaryName(JavaFileManager.Location location, JavaFileObject file) 根据位置推断文件对象的二进制名称。
boolean | isSameFile(FileObject a, FileObject b) 比较两个文件对象，如果它们表示相同的底层对象，则返回 true。
int | isSupportedOption(String option) 确定是否支持给定选项，如果支持，则返回该选项所使用的参数数量。
Iterable<JavaFileObject> | list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

fileManager

protected final M extends JavaFileManager fileManager
一个文件管理器，所有方法都将委托给它。

构造方法详细信息

ForwardingJavaFileManager

protected ForwardingJavaFileManager(M fileManager)
创建一个新的 ForwardingJavaFileManager 的实例。

参数：
fileManager - 委托给此文件管理器
方法详细信息

getClassLoader

public ClassLoader getClassLoader(JavaFileManager.Location location)
从接口 JavaFileManager 复制的描述
获取可从给定位置加载插件的类加载器。例如，要加载注释处理器，编译器将请求 ANNOTATION_PROCESSOR_PATH 位置的类加载器。

指定者：
接口 JavaFileManager 中的 getClassLoader
参数：
location - 位置
返回：
给定位置的类加载器；如果不能从给定位置加载插件或位置未知，则返回 null
抛出：
SecurityException - 如果在当前安全上下文中不能创建类加载器
IllegalStateException - 如果已经调用了 JavaFileManager.close() 并且不能重新打开此文件管理器

list

public Iterable<JavaFileObject> list(JavaFileManager.Location location,
                                     String packageName,
                                     Set<JavaFileObject.Kind> kinds,
                                     boolean recurse)
                              throws IOException
从接口 JavaFileManager 复制的描述
列出给定位置处符合给定标准的所有文件对象。如果 recurse 为 true，则列出“子包”中的文件对象。

注：即使给定位置对于此文件管理器是未知的，此方法也不会返回 null。未知位置也不会导致异常。

指定者：
接口 JavaFileManager 中的 list
参数：
location - 位置
packageName - 包名称
kinds - 只返回这些类型的对象
recurse - 如果为 true，则包含“子包”
返回：
符合给定标准的文件对象的 Iterable
抛出：
IOException - 如果发生 I/O 错误，或者已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器
IllegalStateException - 如果已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器

inferBinaryName

public String inferBinaryName(JavaFileManager.Location location,
                              JavaFileObject file)
从接口 JavaFileManager 复制的描述
根据位置推断文件对象的二进制名称。返回的二进制名称可能不是有效的 JLS 二进制名称。

指定者：
接口 JavaFileManager 中的 inferBinaryName
参数：
location - 位置
file - 文件对象
返回：
二进制名称；如果在给定位置没有找到文件对象，则返回 null
抛出：
IllegalStateException - 如果已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器

isSameFile

public boolean isSameFile(FileObject a,
                          FileObject b)
从接口 JavaFileManager 复制的描述
比较两个文件对象，如果它们表示相同的底层对象，则返回 true。

指定者：
接口 JavaFileManager 中的 isSameFile
参数：
a - 文件对象
b - 文件对象
返回：
如果给定的文件对象表示相同的底层对象，则返回 true
抛出：
IllegalArgumentException - 如果其中一个参数是用另一个文件管理器创建的，并且此文件管理器不支持外部文件对象

handleOption

public boolean handleOption(String current,
                            Iterator<String> remaining)
从接口 JavaFileManager 复制的描述
处理一个选项。如果 current 是此文件管理器的一个选项，则它将通过 remaining 获得该选项的所有参数并返回 true，否则返回 false。

指定者：
接口 JavaFileManager 中的 handleOption
参数：
current - 当前选项
remaining - 剩余选项
返回：
如果由此文件管理器处理此选项，则返回 true，否则返回 false
抛出：
IllegalArgumentException - 如果错误地使用了此文件管理器的选项
IllegalStateException - 如果已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器

hasLocation

public boolean hasLocation(JavaFileManager.Location location)
从接口 JavaFileManager 复制的描述
确定此文件管理器是否已知某位置。

指定者：
接口 JavaFileManager 中的 hasLocation
参数：
location - 位置
返回：
如果已知该位置，则返回 true

isSupportedOption

public int isSupportedOption(String option)
从接口 OptionChecker 复制的描述
确定是否支持给定选项，如果支持，则返回该选项所使用的参数数量。

指定者：
接口 OptionChecker 中的 isSupportedOption
参数：
option - 选项
返回：
给定选项所使用的参数数量；如果不支持该选项，则返回 -1

getJavaFileForInput

public JavaFileObject getJavaFileForInput(JavaFileManager.Location location,
                                          String className,
                                          JavaFileObject.Kind kind)
                                   throws IOException
从接口 JavaFileManager 复制的描述
获取输入的文件对象，它表示给定位置处指定类型的指定类。

指定者：
接口 JavaFileManager 中的 getJavaFileForInput
参数：
location - 位置
className - 类的名称
kind - 文件的类型，必须是 SOURCE 或 CLASS
返回：
一个文件对象；如果文件不存在，则可能返回 null
抛出：
IllegalArgumentException - 如果位置对于此文件管理器未知并且该文件管理器不支持未知位置，或者类型无效
IllegalStateException - 如果已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器
IOException - 如果发生 I/O 错误，或者已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器

getJavaFileForOutput

public JavaFileObject getJavaFileForOutput(JavaFileManager.Location location,
                                           String className,
                                           JavaFileObject.Kind kind,
                                           FileObject sibling)
                                    throws IOException
从接口 JavaFileManager 复制的描述
获取输出的文件对象，它表示给定位置处指定类型的指定类。

此文件管理器可以将 sibling 视为对放置输出位置的提示（可选）。没有指定此提示的确切语义。除非提供了类文件输出目录，否则 Sun 的编译器（例如 javac）将把类文件放到与原始源文件相同的目录下。要实现此行为，调用此方法时 javac 可以提供原始源文件作为 sibling。

指定者：
接口 JavaFileManager 中的 getJavaFileForOutput
参数：
location - 位置
className - 类的名称
kind - 文件的类型，必须是 SOURCE 或 CLASS
sibling - 用作位置提示的文件对象，可以为 null
返回：
输出的文件对象
抛出：
IllegalArgumentException - 如果 sibling 对于此文件管理器是未知的，或者位置对于此文件管理器是未知的并且该文件管理器不支持未知位置，或者类型无效
IllegalStateException - 已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器
IOException - 如果发生 I/O 错误，或者已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器

getFileForInput

public FileObject getFileForInput(JavaFileManager.Location location,
                                  String packageName,
                                  String relativeName)
                           throws IOException
从接口 JavaFileManager 复制的描述
获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。

如果返回的对象表示源或类文件，则它必须是 JavaFileObject 的一个实例。

非严格意义上来讲，在位置、包名称和相对名称的串联中查找此方法返回的文件对象。例如，要在 SOURCE_PATH 位置处的 "com.sun.tools.javac" 包中查找属性文件 "resources/compiler.properties"，将调用此方法，如下：

getFileForInput(SOURCE_PATH, "com.sun.tools.javac", "resources/compiler.properties");

如果在 Windows 上执行该调用，其中 SOURCE_PATH 设置为 "C:\Documents and Settings\UncleBob\src\share\classes"，那么有效的结果将是表示文件 "C:\Documents and Settings\UncleBob\src\share\classes\com\sun\tools\javac\resources\compiler.properties" 的文件对象。

指定者：
接口 JavaFileManager 中的 getFileForInput
参数：
location - 位置
packageName - 包名称
relativeName - 相对名称
返回：
文件对象；如果文件不存在，则可能返回 null
抛出：
IllegalArgumentException - 如果位置对于此文件管理器是未知的并且该文件管理器不支持未知位置，或者 relativeName 无效
IllegalStateException - 如果已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器
IOException - 如果发生 I/O 错误，或者已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器

getFileForOutput

public FileObject getFileForOutput(JavaFileManager.Location location,
                                   String packageName,
                                   String relativeName,
                                   FileObject sibling)
                            throws IOException
从接口 JavaFileManager 复制的描述
获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。

此文件管理器可能将 sibling 视为对放置输出位置的提示（可选）。没有指定此提示的确切语义。除非提供了类文件输出目录，否则 Sun 的编译器（例如 javac）将把类文件放到与原始源文件相同的目录下。要实现此行为，调用此方法时 javac 可以提供原始源文件作为 sibling。

如果返回的对象表示源或类文件，则它必须是 JavaFileObject 的一个实例。

非正式情况下，在位置、包名称和相对名称的串联或 sibling 参数的同级元素中查找此方法返回的文件对象。有关示例，请参阅 getFileForInput。

指定者：
接口 JavaFileManager 中的 getFileForOutput
参数：
location - 位置
packageName - 包名称
relativeName - 相对名称
sibling - 用作位置提示的文件对象；可以为 null
返回：
文件对象
抛出：
IllegalArgumentException - 如果 sibling 对于此文件管理器是未知的，或者位置对于此文件管理器是未知的并且该文件管理器不支持未知位置，或者 relativeName 无效
IllegalStateException - 如果已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器
IOException - 如果发生 I/O 错误，或者已经调用了 JavaFileManager.close() 并且无法重新打开此文件管理器

flush

public void flush()
           throws IOException
从接口 JavaFileManager 复制的描述
刷新此文件管理器直接或间接为输出打开的所有资源。刷新已关闭的文件管理器没有任何效果。

指定者：
接口 Flushable 中的 flush
指定者：
接口 JavaFileManager 中的 flush
抛出：
IOException - 如果发生 I/O 错误
另请参见：
JavaFileManager.close()

close

public void close()
           throws IOException
从接口 JavaFileManager 复制的描述
释放此文件管理器直接或间接打开的所有资源。这会使得此文件管理器无效，除非明确允许，否则对此对象上的方法或通过此对象获取的所有对象进行后续调用都将导致不确定的结果。但是，关闭已经关闭的文件管理器没有任何效果。

指定者：
接口 Closeable 中的 close
指定者：
接口 JavaFileManager 中的 close
抛出：
IOException - 如果发生 I/O 错误
另请参见：
JavaFileManager.flush()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ForwardingJavaFileObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
类 ForwardingJavaFileObject<F extends JavaFileObject>

java.lang.Object
    继承者  javax.tools.ForwardingFileObject<F>
        继承者  javax.tools.ForwardingJavaFileObject<F>
类型参数：
F - 此对象将转发到的文件对象的类型
所有已实现的接口：
FileObject, JavaFileObject
public class ForwardingJavaFileObject<F extends JavaFileObject>
extends ForwardingFileObject<F>
implements JavaFileObject

将调用转发到给定的文件对象。此类的子类可以重写其中某些方法，还可以提供附加字段和方法。

从以下版本开始：
1.6

嵌套类摘要
从接口 javax.tools.JavaFileObject 继承的嵌套类/接口
JavaFileObject.Kind
字段摘要
从类 javax.tools.ForwardingFileObject 继承的字段
fileObject
构造方法摘要
protected ForwardingJavaFileObject(F fileObject)
创建一个新的 ForwardingJavaFileObject 实例。
方法摘要
Modifier | getAccessLevel() 提供有关此文件对象表示的类的访问级别的提示。
JavaFileObject.Kind | getKind() 获取此文件对象的种类。
NestingKind | getNestingKind() 提供有关此文件对象表示的类的嵌套层次的提示。
boolean | isNameCompatible(String simpleName, JavaFileObject.Kind kind) 检查此文件对象是否与指定的简单名称和种类兼容。
从类 javax.tools.ForwardingFileObject 继承的方法
delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.tools.FileObject 继承的方法
delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri

构造方法详细信息

ForwardingJavaFileObject

protected ForwardingJavaFileObject(F fileObject)
创建一个新的 ForwardingJavaFileObject 实例。

参数：
fileObject - 委托给此文件对象
方法详细信息

getKind

public JavaFileObject.Kind getKind()
从接口 JavaFileObject 复制的描述
获取此文件对象的种类。

指定者：
接口 JavaFileObject 中的 getKind
返回：
种类

isNameCompatible

public boolean isNameCompatible(String simpleName,
                                JavaFileObject.Kind kind)
从接口 JavaFileObject 复制的描述
检查此文件对象是否与指定的简单名称和种类兼容。简单名称是 Java Language Specification 3rd ed.，6.2 节“名称和标识符”中定义的单个标识符（非限定）。

指定者：
接口 JavaFileObject 中的 isNameCompatible
参数：
simpleName - 类的简单名称
kind - 种类
返回：
如果此文件对象兼容，则返回 true；否则返回 false

getNestingKind

public NestingKind getNestingKind()
从接口 JavaFileObject 复制的描述
提供有关此文件对象表示的类的嵌套层次的提示。此方法可能返回 NestingKind.MEMBER，表示 NestingKind.LOCAL 或 NestingKind.ANONYMOUS。如果嵌套层次未知或此文件对象不表示类文件，那么此方法返回 null。

指定者：
接口 JavaFileObject 中的 getNestingKind
返回：
嵌套种类；如果嵌套种类未知，则返回 null

getAccessLevel

public Modifier getAccessLevel()
从接口 JavaFileObject 复制的描述
提供有关此文件对象表示的类的访问级别的提示。如果访问级别未知或此文件对象不表示类文件，那么此方法返回 null。

指定者：
接口 JavaFileObject 中的 getAccessLevel
返回：
访问级别
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JavaCompiler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 JavaCompiler

所有超级接口：
OptionChecker, Tool
public interface JavaCompiler
extends Tool, OptionChecker

从程序中调用 Java™ 编程语言编译器的接口。

编译过程中，编译器可能生成诊断信息（例如，错误消息）。如果提供了诊断侦听器，那么诊断信息将被提供给该侦听器。如果没有提供侦听器，那么除非另行指定，否则诊断信息将被格式化为未指定的格式，并被写入到默认输出 System.err。即使提供了诊断侦听器，某些诊断信息也可能不适合 Diagnostic，并将被写入到默认输出。

编译器工具具有关联的标准文件管理器，此文件管理器是工具本地的（或内置的）。可以通过调用 getStandardFileManager 获取该标准文件管理器。

只要满足下面方法详细描述中的任意附加需求，编译器工具就必须与文件管理器一起运行。如果没有提供文件管理器，则编译器工具将使用标准文件管理器，比如 getStandardFileManager 返回的标准文件管理器。

实现此接口的实例必须符合 Java Language Specification 并遵照 Java Virtual Machine 规范生成类文件。Tool 接口中定义了这些规范的版本。 此外，支持 SourceVersion.RELEASE_6 或更高版本的此接口的实例还必须支持注释处理。

编译器依赖于两种服务：诊断侦听器和文件管理器。虽然此包中的大多数类和接口都定义了编译器（和一般工具）的 API，但最好不要在应用程序中使用接口 DiagnosticListener、JavaFileManager、FileObject 和 JavaFileObject。应该实现这些接口，用于为编译器提供自定义服务，从而定义编译器的 SPI。

此包中有很多类和接口，它们被设计用于简化 SPI 的实现，以自定义编译器行为：

StandardJavaFileManager
实现此接口的每个编译器都提供一个标准的文件管理器，以便在常规文件上进行操作。StandardJavaFileManager 接口定义了从常规文件创建文件对象的其他方法。

标准文件管理器有两个用途：

  • 自定义编译器如何读写文件的基本构建块
  • 在多个编译任务之间共享

重新使用文件管理器可能会减少扫描文件系统和读取 jar 文件的开销。标准文件管理器必须与多个顺序编译共同工作，尽管这样做并不能减少开销，下例是建议的编码模式：

Files[] files1 = ...; // input for first compilation task
Files[] files2 = ...; // input for second compilation task

JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
StandardJavaFileManager fileManager = compiler.getStandardFileManager(null, null, null);

Iterable<? extends JavaFileObject> compilationUnits1 =
fileManager.getJavaFileObjectsFromFiles(Arrays.asList(files1));
compiler.getTask(null, fileManager, null, null, null, compilationUnits1).call();

Iterable<? extends JavaFileObject> compilationUnits2 =
fileManager.getJavaFileObjects(files2); // use alternative method
// reuse the same file manager to allow caching of jar files
compiler.getTask(null, fileManager, null, null, null, compilationUnits2).call();

fileManager.close();
DiagnosticCollector
用于将诊断信息收集在一个列表中，例如：
Iterable<? extends JavaFileObject> compilationUnits = ...;
JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
DiagnosticCollector<JavaFileObject> diagnostics = new DiagnosticCollector<JavaFileObject>();
StandardJavaFileManager fileManager = compiler.getStandardFileManager(diagnostics, null, null);
compiler.getTask(null, fileManager, diagnostics, null, null, compilationUnits).call();

for (Diagnostic diagnostic :diagnostics.getDiagnostics())
System.out.format("Error on line %d in %d%n",
diagnostic.getLineNumber()
diagnostic.getSource().toUri());

fileManager.close();
ForwardingJavaFileManager、ForwardingFileObject 和 ForwardingJavaFileObject
子类化不可用于重写标准文件管理器的行为，因为标准文件管理器是通过调用编译器上的方法创建的，而不是通过调用构造方法创建的。应该使用转发（或委托）。允许自定义行为时，这些类使得将多个调用转发到给定文件管理器或文件对象变得容易。例如，考虑如何将所有的调用记录到 JavaFileManager.flush()：
final Logger logger = ...;
Iterable<? extends JavaFileObject> compilationUnits = ...;
JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
StandardJavaFileManager stdFileManager = compiler.getStandardFileManager(null, null, null);
JavaFileManager fileManager = new ForwardingJavaFileManager(stdFileManager) {
public void flush() {
logger.entering(StandardJavaFileManager.class.getName(), "flush");
super.flush();
logger.exiting(StandardJavaFileManager.class.getName(), "flush");
           }
       };
compiler.getTask(null, fileManager, null, null, null, compilationUnits).call();
SimpleJavaFileObject
此类提供基本文件对象实现，该实现可用作创建文件对象的构建块。例如，下例显示了如何定义表示存储在字符串中的源代码的文件对象：
       /**
* A file object used to represent source coming from a string.
*/
public class JavaSourceFromString extends SimpleJavaFileObject {
           /**
* The source code of this "file".
*/
final String code;

           /**
* Constructs a new JavaSourceFromString.
* @param name the name of the compilation unit represented by this file object
* @param code the source code for the compilation unit represented by this file object
*/
JavaSourceFromString(String name, String code) {
super(URI.create("string:///" + name.replace('.','/') + Kind.SOURCE.extension),
Kind.SOURCE);
this.code = code;
           }

@Override
public CharSequence getCharContent(boolean ignoreEncodingErrors) {
return code;
           }
       }

从以下版本开始：
1.6
另请参见：
DiagnosticListener, Diagnostic, JavaFileManager

嵌套类摘要
static interface JavaCompiler.CompilationTask
表示编译任务的 future 的接口。
方法摘要
StandardJavaFileManager | getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset) 为此工具获取一个标准文件管理器实现的新实例。
JavaCompiler.CompilationTask | getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
从接口 javax.tools.Tool 继承的方法
getSourceVersions, run
从接口 javax.tools.OptionChecker 继承的方法
isSupportedOption

方法详细信息

getTask

JavaCompiler.CompilationTask getTask(Writer out,
                                     JavaFileManager fileManager,
                                     DiagnosticListener<? super JavaFileObject> diagnosticListener,
                                     Iterable<String> options,
                                     Iterable<String> classes,
                                     Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。该编译可能没有完成，正如 CompilationTask 接口中所述。

如果提供了文件管理器，则它必须能够处理 StandardLocation 中定义的所有位置。

参数：
out - 用于来自编译器的其他输出的 Writer；如果为 null，则使用 System.err
fileManager - 文件管理器；如果为 null，则使用编译器的标准文件管理器
diagnosticListener - 诊断侦听器；如果为 null，则使用编译器的默认方法报告诊断信息
options - 编译器选项；null 表示没有选项
classes - 类名称（用于注释处理），null 表示没有类名称
compilationUnits - 要编译的编译单元；null 表示没有编译单元
返回：
表示编译的对象
抛出：
RuntimeException - 如果在用户提供的组件中发生不可恢复的错误。cause 为用户代码中的错误。
IllegalArgumentException - 如果给定的任一编译单元具有不同于 source 的类型

getStandardFileManager

StandardJavaFileManager getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener,
                                               Locale locale,
                                               Charset charset)
为此工具获取一个标准文件管理器实现的新实例。文件管理器将使用给定的诊断侦听器来生成所有非致命诊断信息。将用适当的异常来指示致命错误。

如果调用 flush 或 close 后访问标准文件管理器，则它将被自动重新打开。标准文件管理器必须与其他工具一起使用。

参数：
diagnosticListener - 用于非致命诊断信息的诊断侦听器；如果为 null，则使用编译器的默认方法来报告诊断信息
locale - 格式化诊断信息时要应用的语言环境；如果为 null，则使用默认语言环境。
charset - 用于解码字节的字符集；如果为 null，则使用平台默认的字符集
返回：
标准文件管理器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JavaCompiler.CompilationTask (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 JavaCompiler.CompilationTask

所有超级接口：
Callable<Boolean>
正在封闭接口：
JavaCompiler
public static interface JavaCompiler.CompilationTask
extends Callable<Boolean>

表示编译任务的 future 的接口。编译任务尚未开始。要开始任务，请调用 call 方法。

在调用 call 方法之前，还可以通过调用 setProcessors 之类的方法配置任务的其他方面。

方法摘要
Boolean | call() 执行此编译任务。
void | setLocale(Locale locale) 设置格式化诊断和其他本地化数据时要应用的语言环境。
void | setProcessors(Iterable<? extends Processor> processors) 设置处理器（用于注释处理）。

方法详细信息

setProcessors

void setProcessors(Iterable<? extends Processor> processors)
设置处理器（用于注释处理）。这将绕过正常的发现机制。

参数：
processors - 处理器（用于注释处理）
抛出：
IllegalStateException - 如果任务已经开始

setLocale

void setLocale(Locale locale)
设置格式化诊断和其他本地化数据时要应用的语言环境。

参数：
locale - 要应用的语言环境；如果为 null，则表示没有应用语言环境
抛出：
IllegalStateException - 如果任务已经开始

call

Boolean call()
执行此编译任务。编译只能被执行一次。此方法的后续调用将抛出 IllegalStateException。

指定者：
接口 Callable<Boolean> 中的 call
返回：
当且仅当编译了所有文件且没有出现错误时，返回 true；否则返回 false
抛出：
RuntimeException - 如果在用户提供的组件中发生不可恢复的错误。cause 为用户代码中的错误。
IllegalStateException - 如果多次调用此方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JavaFileManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 JavaFileManager

所有超级接口：
Closeable, Flushable, OptionChecker
所有已知子接口：
StandardJavaFileManager
所有已知实现类：
ForwardingJavaFileManager
public interface JavaFileManager
extends Closeable, Flushable, OptionChecker

在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。在这里，文件 是指常规文件和其他数据源的抽象。

构建新的 JavaFileObject 时，文件管理器必须确定创建它们的位置。例如，如果文件管理器在文件系统上管理常规文件，那么在创建或查找文件时，此文件管理器很可能将当前/工作目录作为默认位置使用。可以向文件管理器提供许多关于在何处创建文件的提示。文件管理器可以选择忽略这些提示。

此接口中的某些方法使用类名称。这种类名称必须以完全限定类和接口名称的 Java Virtual Machine 内部形式给定。为了方便起见，'.' 和 '/' 可以互换使用。在 Java Virtual Machine Specification 第四章中定义了内部形式。

讨论：这意味着名称 "java/lang.package-info"、"java/lang/package-info"、"java.lang.package-info" 有效并且相等。比较 Java Language Specification (JLS) 第 13.1 节 "The Form of a Binary" 中定义的二进制名称。

名称的大小写很重要。所有名称都应该区分大小写。例如，某些文件系统的文件名称大小写不敏感 (case-insensitive)、但可区分大小写 (case-aware)。表示此类文件的文件对象应该通过使用 File.getCanonicalFile() 或类似方法来保存大小写形式。如果系统不可区分大小写，那么文件对象必须使用其他方法来保存大小写。

相对名称：此接口中的某些方法使用相对名称。相对名称是指用 '/' 分隔的路径段的非 null、非空序列。'.' 或 '..' 为无效路径段。有效的相对名称必须符合 RFC 3986 的第 3.3 节的“无根路径”规则。非正式情况下，下式应该为 true：

  URI.create(relativeName).normalize().getPath().equals(relativeName)

此接口中的所有方法都可能抛出 SecurityException。

不要求此接口的对象支持多线程访问，也就是说，此接口中的对象是同步的。但是，它必须支持对此对象创建的不同文件对象的并发访问。

实现注意事项： 此要求使得对 JarOutputStream 的输出的普通实现将不够充分。也就是说，不是创建直接返回 JarOutputStream 的 JavaFileObject，而是在关闭前必须缓存内容，然后将内容写入 JarOutputStream。

除非明确允许，否则只要给定 null 参数，此接口中的所有方法都将抛出 NullPointerException。

从以下版本开始：
1.6
另请参见：
JavaFileObject, FileObject

嵌套类摘要
static interface JavaFileManager.Location
文件对象位置的接口。
方法摘要
void | close() 释放此文件管理器直接或间接打开的所有资源。
void | flush() 刷新此文件管理器直接或间接为输出打开的所有资源。
ClassLoader | getClassLoader(JavaFileManager.Location location) 获取可从给定位置加载插件的类加载器。
FileObject | getFileForInput(JavaFileManager.Location location, String packageName, String relativeName) 获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
FileObject | getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
JavaFileObject | getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind) 获取输入的文件对象，它表示给定位置处指定类型的指定类。
JavaFileObject | getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。
boolean | handleOption(String current, Iterator<String> remaining) 处理一个选项。
boolean | hasLocation(JavaFileManager.Location location) 确定此文件管理器是否已知某位置。
String | inferBinaryName(JavaFileManager.Location location, JavaFileObject file) 根据位置推断文件对象的二进制名称。
boolean | isSameFile(FileObject a, FileObject b) 比较两个文件对象，如果它们表示相同的底层对象，则返回 true。
Iterable<JavaFileObject> | list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。
从接口 javax.tools.OptionChecker 继承的方法
isSupportedOption

方法详细信息

getClassLoader

ClassLoader getClassLoader(JavaFileManager.Location location)
获取可从给定位置加载插件的类加载器。例如，要加载注释处理器，编译器将请求 ANNOTATION_PROCESSOR_PATH 位置的类加载器。

参数：
location - 位置
返回：
给定位置的类加载器；如果不能从给定位置加载插件或位置未知，则返回 null
抛出：
SecurityException - 如果在当前安全上下文中不能创建类加载器
IllegalStateException - 如果已经调用了 close() 并且不能重新打开此文件管理器

list

Iterable<JavaFileObject> list(JavaFileManager.Location location,
                              String packageName,
                              Set<JavaFileObject.Kind> kinds,
                              boolean recurse)
                              throws IOException
列出给定位置处符合给定标准的所有文件对象。如果 recurse 为 true，则列出“子包”中的文件对象。

注：即使给定位置对于此文件管理器是未知的，此方法也不会返回 null。未知位置也不会导致异常。

参数：
location - 位置
packageName - 包名称
kinds - 只返回这些类型的对象
recurse - 如果为 true，则包含“子包”
返回：
符合给定标准的文件对象的 Iterable
抛出：
IOException - 如果发生 I/O 错误，或者已经调用了 close() 并且无法重新打开此文件管理器
IllegalStateException - 如果已经调用了 close() 并且无法重新打开此文件管理器

inferBinaryName

String inferBinaryName(JavaFileManager.Location location,
                       JavaFileObject file)
根据位置推断文件对象的二进制名称。返回的二进制名称可能不是有效的 JLS 二进制名称。

参数：
location - 位置
file - 文件对象
返回：
二进制名称；如果在给定位置没有找到文件对象，则返回 null
抛出：
IllegalStateException - 如果已经调用了 close() 并且无法重新打开此文件管理器

isSameFile

boolean isSameFile(FileObject a,
                   FileObject b)
比较两个文件对象，如果它们表示相同的底层对象，则返回 true。

参数：
a - 文件对象
b - 文件对象
返回：
如果给定的文件对象表示相同的底层对象，则返回 true
抛出：
IllegalArgumentException - 如果其中一个参数是用另一个文件管理器创建的，并且此文件管理器不支持外部文件对象

handleOption

boolean handleOption(String current,
                     Iterator<String> remaining)
处理一个选项。如果 current 是此文件管理器的一个选项，则它将通过 remaining 获得该选项的所有参数并返回 true，否则返回 false。

参数：
current - 当前选项
remaining - 剩余选项
返回：
如果由此文件管理器处理此选项，则返回 true，否则返回 false
抛出：
IllegalArgumentException - 如果错误地使用了此文件管理器的选项
IllegalStateException - 如果已经调用了 close() 并且无法重新打开此文件管理器

hasLocation

boolean hasLocation(JavaFileManager.Location location)
确定此文件管理器是否已知某位置。

参数：
location - 位置
返回：
如果已知该位置，则返回 true

getJavaFileForInput

JavaFileObject getJavaFileForInput(JavaFileManager.Location location,
                                   String className,
                                   JavaFileObject.Kind kind)
                                   throws IOException
获取输入的文件对象，它表示给定位置处指定类型的指定类。

参数：
location - 位置
className - 类的名称
kind - 文件的类型，必须是 SOURCE 或 CLASS
返回：
一个文件对象；如果文件不存在，则可能返回 null
抛出：
IllegalArgumentException - 如果位置对于此文件管理器未知并且该文件管理器不支持未知位置，或者类型无效
IOException - 如果发生 I/O 错误，或者已经调用了 close() 并且无法重新打开此文件管理器
IllegalStateException - 如果已经调用了 close() 并且无法重新打开此文件管理器

getJavaFileForOutput

JavaFileObject getJavaFileForOutput(JavaFileManager.Location location,
                                    String className,
                                    JavaFileObject.Kind kind,
                                    FileObject sibling)
                                    throws IOException
获取输出的文件对象，它表示给定位置处指定类型的指定类。

此文件管理器可以将 sibling 视为对放置输出位置的提示（可选）。没有指定此提示的确切语义。除非提供了类文件输出目录，否则 Sun 的编译器（例如 javac）将把类文件放到与原始源文件相同的目录下。要实现此行为，调用此方法时 javac 可以提供原始源文件作为 sibling。

参数：
location - 位置
className - 类的名称
kind - 文件的类型，必须是 SOURCE 或 CLASS
sibling - 用作位置提示的文件对象，可以为 null
返回：
输出的文件对象
抛出：
IllegalArgumentException - 如果 sibling 对于此文件管理器是未知的，或者位置对于此文件管理器是未知的并且该文件管理器不支持未知位置，或者类型无效
IOException - 如果发生 I/O 错误，或者已经调用了 close() 并且无法重新打开此文件管理器
IllegalStateException - 已经调用了 close() 并且无法重新打开此文件管理器

getFileForInput

FileObject getFileForInput(JavaFileManager.Location location,
                           String packageName,
                           String relativeName)
                           throws IOException
获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。

如果返回的对象表示源或类文件，则它必须是 JavaFileObject 的一个实例。

非严格意义上来讲，在位置、包名称和相对名称的串联中查找此方法返回的文件对象。例如，要在 SOURCE_PATH 位置处的 "com.sun.tools.javac" 包中查找属性文件 "resources/compiler.properties"，将调用此方法，如下：

getFileForInput(SOURCE_PATH, "com.sun.tools.javac", "resources/compiler.properties");

如果在 Windows 上执行该调用，其中 SOURCE_PATH 设置为 "C:\Documents and Settings\UncleBob\src\share\classes"，那么有效的结果将是表示文件 "C:\Documents and Settings\UncleBob\src\share\classes\com\sun\tools\javac\resources\compiler.properties" 的文件对象。

参数：
location - 位置
packageName - 包名称
relativeName - 相对名称
返回：
文件对象；如果文件不存在，则可能返回 null
抛出：
IllegalArgumentException - 如果位置对于此文件管理器是未知的并且该文件管理器不支持未知位置，或者 relativeName 无效
IOException - 如果发生 I/O 错误，或者已经调用了 close() 并且无法重新打开此文件管理器
IllegalStateException - 如果已经调用了 close() 并且无法重新打开此文件管理器

getFileForOutput

FileObject getFileForOutput(JavaFileManager.Location location,
                            String packageName,
                            String relativeName,
                            FileObject sibling)
                            throws IOException
获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。

此文件管理器可能将 sibling 视为对放置输出位置的提示（可选）。没有指定此提示的确切语义。除非提供了类文件输出目录，否则 Sun 的编译器（例如 javac）将把类文件放到与原始源文件相同的目录下。要实现此行为，调用此方法时 javac 可以提供原始源文件作为 sibling。

如果返回的对象表示源或类文件，则它必须是 JavaFileObject 的一个实例。

非正式情况下，在位置、包名称和相对名称的串联或 sibling 参数的同级元素中查找此方法返回的文件对象。有关示例，请参阅 getFileForInput。

参数：
location - 位置
packageName - 包名称
relativeName - 相对名称
sibling - 用作位置提示的文件对象；可以为 null
返回：
文件对象
抛出：
IllegalArgumentException - 如果 sibling 对于此文件管理器是未知的，或者位置对于此文件管理器是未知的并且该文件管理器不支持未知位置，或者 relativeName 无效
IOException - 如果发生 I/O 错误，或者已经调用了 close() 并且无法重新打开此文件管理器
IllegalStateException - 如果已经调用了 close() 并且无法重新打开此文件管理器

flush

void flush()
           throws IOException
刷新此文件管理器直接或间接为输出打开的所有资源。刷新已关闭的文件管理器没有任何效果。

指定者：
接口 Flushable 中的 flush
抛出：
IOException - 如果发生 I/O 错误
另请参见：
close()

close

void close()
           throws IOException
释放此文件管理器直接或间接打开的所有资源。这会使得此文件管理器无效，除非明确允许，否则对此对象上的方法或通过此对象获取的所有对象进行后续调用都将导致不确定的结果。但是，关闭已经关闭的文件管理器没有任何效果。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果发生 I/O 错误
另请参见：
flush()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JavaFileManager.Location (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 JavaFileManager.Location

所有已知实现类：
StandardLocation
正在封闭接口：
JavaFileManager
public static interface JavaFileManager.Location

文件对象位置的接口。文件管理器用它来确定放置或搜索文件对象的位置。

方法摘要
String | getName() 获取此位置的名称。
boolean | isOutputLocation() 确定此位置是否为输出位置。

方法详细信息

getName

String getName()
获取此位置的名称。

返回：
名称

isOutputLocation

boolean isOutputLocation()
确定此位置是否为输出位置。输出位置是指按照惯例用于输出的位置。

返回：
如果此位置是输出位置，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JavaFileObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 JavaFileObject

所有超级接口：
FileObject
所有已知实现类：
ForwardingJavaFileObject, SimpleJavaFileObject
public interface JavaFileObject
extends FileObject

在 Java™ 编程语言源和类文件上进行操作的工具的文件抽象。

如果发生安全异常，则此接口中的所有方法都将抛出 SecurityException。

除非明确允许，否则只要给定 null 参数，此接口中的所有方法都将抛出 NullPointerException。

从以下版本开始：
1.6
另请参见：
JavaFileManager

嵌套类摘要
static class JavaFileObject.Kind
JavaFileObject 的种类。
方法摘要
Modifier | getAccessLevel() 提供有关此文件对象表示的类的访问级别的提示。
JavaFileObject.Kind | getKind() 获取此文件对象的种类。
NestingKind | getNestingKind() 提供有关此文件对象表示的类的嵌套层次的提示。
boolean | isNameCompatible(String simpleName, JavaFileObject.Kind kind) 检查此文件对象是否与指定的简单名称和种类兼容。
从接口 javax.tools.FileObject 继承的方法
delete, getCharContent, getLastModified, getName, openInputStream, openOutputStream, openReader, openWriter, toUri

方法详细信息

getKind

JavaFileObject.Kind getKind()
获取此文件对象的种类。

返回：
种类

isNameCompatible

boolean isNameCompatible(String simpleName,
                         JavaFileObject.Kind kind)
检查此文件对象是否与指定的简单名称和种类兼容。简单名称是 Java Language Specification 3rd ed.，6.2 节“名称和标识符”中定义的单个标识符（非限定）。

参数：
simpleName - 类的简单名称
kind - 种类
返回：
如果此文件对象兼容，则返回 true；否则返回 false

getNestingKind

NestingKind getNestingKind()
提供有关此文件对象表示的类的嵌套层次的提示。此方法可能返回 NestingKind.MEMBER，表示 NestingKind.LOCAL 或 NestingKind.ANONYMOUS。如果嵌套层次未知或此文件对象不表示类文件，那么此方法返回 null。

返回：
嵌套种类；如果嵌套种类未知，则返回 null

getAccessLevel

Modifier getAccessLevel()
提供有关此文件对象表示的类的访问级别的提示。如果访问级别未知或此文件对象不表示类文件，那么此方法返回 null。

返回：
访问级别
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JavaFileObject.Kind (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.tools
枚举 JavaFileObject.Kind

java.lang.Object
    继承者  java.lang.Enum<JavaFileObject.Kind>
        继承者  javax.tools.JavaFileObject.Kind
所有已实现的接口：
Serializable, Comparable<JavaFileObject.Kind>
正在封闭接口：
JavaFileObject
public static enum JavaFileObject.Kind
extends Enum<JavaFileObject.Kind>

JavaFileObject 的种类。

枚举常量摘要
CLASS
Java Virtual Machine 的类文件。
HTML
HTML 文件。
OTHER
其他任意种类。
SOURCE
用 Java 编程语言编写的源文件。
字段摘要
 String extension
通常用于此类文件对象的扩展名（按照约定）。
方法摘要
static JavaFileObject.Kind | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static JavaFileObject.Kind[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

SOURCE

public static final JavaFileObject.Kind SOURCE
用 Java 编程语言编写的源文件。例如，以 .java 结尾的常规文件。

CLASS

public static final JavaFileObject.Kind CLASS
Java Virtual Machine 的类文件。例如，以 .class 结尾的常规文件。

HTML

public static final JavaFileObject.Kind HTML
HTML 文件。例如，以 .html 结尾的常规文件。

OTHER

public static final JavaFileObject.Kind OTHER
其他任意种类。

字段详细信息

extension

public final String extension
通常用于此类文件对象的扩展名（按照约定）。如果没有约定，则使用空字符串（&quot;&quot;）。

方法详细信息

values

public static final JavaFileObject.Kind[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(JavaFileObject.Kind c : JavaFileObject.Kind.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static JavaFileObject.Kind valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


OptionChecker (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 OptionChecker

所有已知子接口：
JavaCompiler, JavaFileManager, StandardJavaFileManager
所有已知实现类：
ForwardingJavaFileManager
public interface OptionChecker

识别选项的接口。

从以下版本开始：
1.6

方法摘要
 int isSupportedOption(String option)
确定是否支持给定选项，如果支持，则返回该选项所使用的参数数量。

方法详细信息

isSupportedOption

int isSupportedOption(String option)
确定是否支持给定选项，如果支持，则返回该选项所使用的参数数量。

参数：
option - 选项
返回：
给定选项所使用的参数数量；如果不支持该选项，则返回 -1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleJavaFileObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
类 SimpleJavaFileObject

java.lang.Object
    继承者  javax.tools.SimpleJavaFileObject
所有已实现的接口：
FileObject, JavaFileObject
public class SimpleJavaFileObject
extends Object
implements JavaFileObject

为 JavaFileObject 中的大多数方法提供简单实现。应子类化此类并用作 JavaFileObject 实现的基础。子类可以重写此类任意方法的实现和规范，只要不违背 JavaFileObject 的常规协定。

从以下版本开始：
1.6

嵌套类摘要
从接口 javax.tools.JavaFileObject 继承的嵌套类/接口
JavaFileObject.Kind
字段摘要
protected JavaFileObject.Kind | kind 此文件对象的种类。
protected URI | uri 此文件对象的 URI。
构造方法摘要
protected SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
使用给定 URI 构建给定种类的 SimpleJavaFileObject。
方法摘要
boolean | delete() 此实现不执行任何操作。
Modifier | getAccessLevel() 此实现返回 null。
CharSequence | getCharContent(boolean ignoreEncodingErrors) 此实现总是抛出 UnsupportedOperationException。
JavaFileObject.Kind | getKind() 获取此文件对象的种类。
long | getLastModified() 此实现返回 0L。
String | getName() 获取此文件对象的用户友好 (user-friendly) 的名称。
NestingKind | getNestingKind() 此实现返回 null。
boolean | isNameCompatible(String simpleName, JavaFileObject.Kind kind) 此实现对其 URI 路径和给定简单名称进行比较。
InputStream | openInputStream() 此实现总是抛出 UnsupportedOperationException。
OutputStream | openOutputStream() 此实现总是抛出 UnsupportedOperationException。
Reader | openReader(boolean ignoreEncodingErrors) 在 Reader 中包装 getCharContent(boolean) 的结果。
Writer | openWriter() 在 Writer 中包装 openOutputStream 的结果。
String | toString() 返回该对象的字符串表示。
URI | toUri() 返回标识此文件对象的 URI。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

uri

protected final URI uri
此文件对象的 URI。

kind

protected final JavaFileObject.Kind kind
此文件对象的种类。

构造方法详细信息

SimpleJavaFileObject

protected SimpleJavaFileObject(URI uri,
                               JavaFileObject.Kind kind)
使用给定 URI 构建给定种类的 SimpleJavaFileObject。

参数：
uri - 此文件对象的 URI
kind - 此文件对象的种类
方法详细信息

toUri

public URI toUri()
从接口 FileObject 复制的描述
返回标识此文件对象的 URI。

指定者：
接口 FileObject 中的 toUri
返回：
URI

getName

public String getName()
从接口 FileObject 复制的描述
获取此文件对象的用户友好 (user-friendly) 的名称。没有指定返回的准确值，但是实现应该负责保存用户给定的名称。例如，如果用户在命令行中写入文件名 &quot;BobsApp\Test.java&quot;，则此方法应该返回 &quot;BobsApp\Test.java&quot;，而 toUri 方法可能返回 file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java。

指定者：
接口 FileObject 中的 getName
返回：
用户友好的名称

openInputStream

public InputStream openInputStream()
                            throws IOException
此实现总是抛出 UnsupportedOperationException。子类可以更改此行为，只要不违背 FileObject 的协定。

指定者：
接口 FileObject 中的 openInputStream
返回：
InputStream
抛出：
IOException - 如果发生 I/O 错误

openOutputStream

public OutputStream openOutputStream()
                              throws IOException
此实现总是抛出 UnsupportedOperationException。子类可以更改此行为，只要不违背 FileObject 的协定。

指定者：
接口 FileObject 中的 openOutputStream
返回：
OutputStream
抛出：
IOException - 如果发生 I/O 错误

openReader

public Reader openReader(boolean ignoreEncodingErrors)
                  throws IOException
在 Reader 中包装 getCharContent(boolean) 的结果。子类可以更改此行为，只要不违背 FileObject 的协定。

指定者：
接口 FileObject 中的 openReader
参数：
ignoreEncodingErrors - 如果为 true，则忽略编码错误
返回：
包装 getCharContent 结果的 Reader
抛出：
IllegalStateException - 如果此文件对象是为写入而打开的，不支持读取操作
UnsupportedOperationException - 如果这种文件对象不支持字符访问
IOException - 如果发生 I/O 错误

getCharContent

public CharSequence getCharContent(boolean ignoreEncodingErrors)
                            throws IOException
此实现总是抛出 UnsupportedOperationException。子类可以更改此行为，只要不违背 FileObject 的协定。

指定者：
接口 FileObject 中的 getCharContent
参数：
ignoreEncodingErrors - 如果为 true，则忽略编码错误
返回：
CharSequence（如果有）；否则返回 null
抛出：
IOException - 如果发生 I/O 错误

openWriter

public Writer openWriter()
                  throws IOException
在 Writer 中包装 openOutputStream 的结果。子类可以更改此行为，只要不违背 FileObject 的协定。

指定者：
接口 FileObject 中的 openWriter
返回：
包装 openOutputStream 结果的 Writer
抛出：
IllegalStateException - 如果此文件对象是为读取而打开的，不支持写入操作
UnsupportedOperationException - 如果这种文件对象不支持字符访问
IOException - 如果发生 I/O 错误

getLastModified

public long getLastModified()
此实现返回 0L。子类可以更改此行为，只要不违背 FileObject 的协定。

指定者：
接口 FileObject 中的 getLastModified
返回：
0L

delete

public boolean delete()
此实现不执行任何操作。子类可以更改此行为，只要不违背 FileObject 的协定。

指定者：
接口 FileObject 中的 delete
返回：
false

getKind

public JavaFileObject.Kind getKind()
从接口 JavaFileObject 复制的描述
获取此文件对象的种类。

指定者：
接口 JavaFileObject 中的 getKind
返回：
this.kind

isNameCompatible

public boolean isNameCompatible(String simpleName,
                                JavaFileObject.Kind kind)
此实现对其 URI 路径和给定简单名称进行比较。如果给定种类等于此对象的种类，并且路径等于 simpleName + kind.extension 或者路径以 &quot;/&quot; + simpleName + kind.extension 结尾，则此方法返回 true。

此方法调用 getKind() 和 toUri() 并且不直接访问 uri 和 kind 字段。

子类可以更改此行为，只要不违背 JavaFileObject 的协定。

指定者：
接口 JavaFileObject 中的 isNameCompatible
参数：
simpleName - 类的简单名称
kind - 种类
返回：
如果此文件对象兼容，则返回 true；否则返回 false

getNestingKind

public NestingKind getNestingKind()
此实现返回 null。子类可以更改此行为，只要不违背 JavaFileObject 的协定。

指定者：
接口 JavaFileObject 中的 getNestingKind
返回：
嵌套种类；如果嵌套种类未知，则返回 null

getAccessLevel

public Modifier getAccessLevel()
此实现返回 null。子类可以更改此行为，只要不违背 JavaFileObject 的协定。

指定者：
接口 JavaFileObject 中的 getAccessLevel
返回：
访问级别

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StandardJavaFileManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 StandardJavaFileManager

所有超级接口：
Closeable, Flushable, JavaFileManager, OptionChecker
public interface StandardJavaFileManager
extends JavaFileManager

基于 java.io.File 的文件管理器。获取此类实例的一般方法是使用 getStandardFileManager，例如：

JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();
DiagnosticCollector<JavaFileObject> diagnostics =
new DiagnosticCollector<JavaFileObject>();
StandardJavaFileManager fm = compiler.getStandardFileManager(diagnostics, null, null);
此文件管理器创建的文件对象表示常规文件、zip 文件条目或者基于类似文件系统的容器中的条目。从实现此接口的文件管理器返回的任何文件对象都必须遵守以下行为：
  • 文件名称不需要规范。
  • 对于表示常规文件的文件对象
    • 方法 FileObject.delete() 等效于 File.delete()，
    • 方法 FileObject.getLastModified() 等效于 File.lastModified()，
    • 如果以下代码成功执行（忽略编码问题），则方法 FileObject.getCharContent(boolean)、FileObject.openInputStream() 和 FileObject.openReader(boolean) 必须成功执行：
      new FileInputStream(new File(fileObject.toUri()))
    • 如果以下代码成功执行（忽略编码问题），则方法 FileObject.openOutputStream() 和 FileObject.openWriter() 必须成功执行：
      new FileOutputStream(new File(fileObject.toUri()))
  • 从 FileObject.toUri() 返回的 URI
    • 必须是绝对的（有模式），并且
    • 必须具有标准化的 路径组件，它能够在没有任何特定于进程的上下文（比如当前目录）的情况下被解析（文件名称必须是绝对的）。
根据这些规则，以下 URI 是允许的：
  • file:///C:/Documents%20and%20Settings/UncleBob/BobsApp/Test.java
  • jar:///C:/Documents%20and%20Settings/UncleBob/lib/vendorA.jar!com/vendora/LibraryClass.class
而以下 URI 不允许（原因在括号中注明）：
  • file:BobsApp/Test.java （文件名称是相对的并且依赖于当前目录）
  • jar:lib/vendorA.jar!com/vendora/LibraryClass.class （路径的前半部分依赖于当前路径，而 ! 后面的部分合法）
  • Test.java （此 URI 依赖于当前目录并且没有模式）
  • jar:///C:/Documents%20and%20Settings/UncleBob/BobsApp/../lib/vendorA.jar!com/vendora/LibraryClass.class （路径没有标准化）

从以下版本开始：
1.6

嵌套类摘要
从接口 javax.tools.JavaFileManager 继承的嵌套类/接口
JavaFileManager.Location
方法摘要
Iterable<? extends JavaFileObject> | getJavaFileObjects(File... files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | getJavaFileObjects(String... names) 获取表示给定文件名称的文件对象。
Iterable<? extends JavaFileObject> | getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | getJavaFileObjectsFromStrings(Iterable<String> names) 获取表示给定文件名称的文件对象。
Iterable<? extends File> | getLocation(JavaFileManager.Location location) 获取与给定位置关联的路径。
boolean | isSameFile(FileObject a, FileObject b) 比较两个文件对象，如果它们表示相同的规范文件、zip 文件条目或者基于任何文件系统的容器中的条目，则返回 true。
void | setLocation(JavaFileManager.Location location, Iterable<? extends File> path) 将给定路径与给定位置关联。
从接口 javax.tools.JavaFileManager 继承的方法
close, flush, getClassLoader, getFileForInput, getFileForOutput, getJavaFileForInput, getJavaFileForOutput, handleOption, hasLocation, inferBinaryName, list
从接口 javax.tools.OptionChecker 继承的方法
isSupportedOption

方法详细信息

isSameFile

boolean isSameFile(FileObject a,
                   FileObject b)
比较两个文件对象，如果它们表示相同的规范文件、zip 文件条目或者基于任何文件系统的容器中的条目，则返回 true。

指定者：
接口 JavaFileManager 中的 isSameFile
参数：
a - 文件对象
b - 文件对象
返回：
如果给定的文件对象表示相同的规范文件或 zip 文件条目，则返回 true；否则返回 false。
抛出：
IllegalArgumentException - 如果其中一个参数是使用另一个文件管理器实现创建的

getJavaFileObjectsFromFiles

Iterable<? extends JavaFileObject> getJavaFileObjectsFromFiles(Iterable<? extends File> files)
获取表示给定文件的文件对象。

参数：
files - 文件列表
返回：
文件对象列表
抛出：
IllegalArgumentException - 如果文件列表包含目录

getJavaFileObjects

Iterable<? extends JavaFileObject> getJavaFileObjects(File... files)
获取表示给定文件的文件对象。一个便捷方法，等效于：
getJavaFileObjectsFromFiles(Arrays.asList(files))

参数：
files - 文件数组
返回：
文件对象列表
抛出：
IllegalArgumentException - 如果文件数组包含目录
NullPointerException - 如果给定数组包含 null 元素

getJavaFileObjectsFromStrings

Iterable<? extends JavaFileObject> getJavaFileObjectsFromStrings(Iterable<String> names)
获取表示给定文件名称的文件对象。

参数：
names - 文件名称列表
返回：
文件对象列表
抛出：
IllegalArgumentException - 如果文件名称列表包含目录

getJavaFileObjects

Iterable<? extends JavaFileObject> getJavaFileObjects(String... names)
获取表示给定文件名称的文件对象。一个便捷方法，等效于：
getJavaFileObjectsFromStrings(Arrays.asList(names))

参数：
names - 文件名称列表
返回：
文件对象列表
抛出：
IllegalArgumentException - 如果文件名称数组包含目录
NullPointerException - 如果给定数组包含 null 元素

setLocation

void setLocation(JavaFileManager.Location location,
                 Iterable<? extends File> path)
                 throws IOException
将给定路径与给定位置关联。丢弃所有以前的值。

参数：
location - 位置
path - 文件列表，如果为 null，则使用此位置的默认路径
抛出：
IllegalArgumentException - 如果位置为一个输出位置并且路径不完全包含一个元素
IOException - 如果位置是一个输出位置并且路径不表示现有目录
另请参见：
getLocation(javax.tools.JavaFileManager.Location)

getLocation

Iterable<? extends File> getLocation(JavaFileManager.Location location)
获取与给定位置关联的路径。

参数：
location - 位置
返回：
文件列表，如果此位置没有关联路径，则返回 null
另请参见：
setLocation(javax.tools.JavaFileManager.Location, java.lang.Iterable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StandardLocation (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.tools
枚举 StandardLocation

java.lang.Object
    继承者  java.lang.Enum<StandardLocation>
        继承者  javax.tools.StandardLocation
所有已实现的接口：
Serializable, Comparable<StandardLocation>, JavaFileManager.Location
public enum StandardLocation
extends Enum<StandardLocation>
implements JavaFileManager.Location

文件对象的标准位置。

从以下版本开始：
1.6

枚举常量摘要
ANNOTATION_PROCESSOR_PATH
搜索注释处理器的位置。
CLASS_OUTPUT
新的类文件的位置。
CLASS_PATH
搜索用户类文件的位置。
PLATFORM_CLASS_PATH
搜索平台类的位置。
SOURCE_OUTPUT
新的源文件的位置。
SOURCE_PATH
搜索现有源文件的位置。
方法摘要
String | getName() 获取此位置的名称。
boolean | isOutputLocation() 确定此位置是否为输出位置。
static JavaFileManager.Location | locationFor(String name) 使用给定名称获取位置对象。
static StandardLocation | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static StandardLocation[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

CLASS_OUTPUT

public static final StandardLocation CLASS_OUTPUT
新的类文件的位置。

SOURCE_OUTPUT

public static final StandardLocation SOURCE_OUTPUT
新的源文件的位置。

CLASS_PATH

public static final StandardLocation CLASS_PATH
搜索用户类文件的位置。

SOURCE_PATH

public static final StandardLocation SOURCE_PATH
搜索现有源文件的位置。

ANNOTATION_PROCESSOR_PATH

public static final StandardLocation ANNOTATION_PROCESSOR_PATH
搜索注释处理器的位置。

PLATFORM_CLASS_PATH

public static final StandardLocation PLATFORM_CLASS_PATH
搜索平台类的位置。有时调用引导类路径。

方法详细信息

values

public static final StandardLocation[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(StandardLocation c : StandardLocation.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static StandardLocation valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

locationFor

public static JavaFileManager.Location locationFor(String name)
使用给定名称获取位置对象。必须保留以下属性：当且仅当 x.equals(y) 时 locationFor(x) == locationFor(y)。当且仅当名称以 &quot;_OUTPUT&quot; 结束时，返回的位置将是一个输出位置。

参数：
name - 名称
返回：
位置

getName

public String getName()
从接口 JavaFileManager.Location 复制的描述
获取此位置的名称。

指定者：
接口 JavaFileManager.Location 中的 getName
返回：
名称

isOutputLocation

public boolean isOutputLocation()
从接口 JavaFileManager.Location 复制的描述
确定此位置是否为输出位置。输出位置是指按照惯例用于输出的位置。

指定者：
接口 JavaFileManager.Location 中的 isOutputLocation
返回：
如果此位置是输出位置，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Tool (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.tools
接口 Tool

所有已知子接口：
JavaCompiler
public interface Tool

可以从程序中调用的工具的公共接口。工具通常指命令行程序，比如编译器。由供应商定义某个平台上的可用工具集合。

可以使用 ServiceLoader.load(Class) 查找工具。

从以下版本开始：
1.6

方法摘要
Set<SourceVersion> | getSourceVersions() 获取此工具支持的 Java™ 编程语言的源版本。
int | run(InputStream in, OutputStream out, OutputStream err, String... arguments) 使用给定 I/O 通道和参数运行工具。

方法详细信息

run

int run(InputStream in,
        OutputStream out,
        OutputStream err,
        String... arguments)
使用给定 I/O 通道和参数运行工具。按照惯例，工具如果运行成功，则返回 0；如果出现错误，则返回非 0 值。任何生成的诊断都将以某种未指定的格式写入 out 或 err。

参数：
in - “标准”输入；如果为 null，则使用 System.in
out - “标准”输出；如果为 null，则使用 System.out
err - “标准”错误；如果为 null，则使用 System.err
arguments - 要传递给工具的参数
返回：
如果成功，则返回 0；否则返回非 0 值
抛出：
NullPointerException - 如果参数数组包含任何 null 元素。

getSourceVersions

Set<SourceVersion> getSourceVersions()
获取此工具支持的 Java™ 编程语言的源版本。

返回：
支持的源版本集合
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ToolProvider (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.tools
类 ToolProvider

java.lang.Object
    继承者  javax.tools.ToolProvider

public class ToolProvider
extends Object

为查找工具提供者提供方法，例如，编译器的提供者。此类实现 ServiceLoader 功能。

从以下版本开始：
1.6

方法摘要
static JavaCompiler | getSystemJavaCompiler() 获取此平台提供的 Java™ 编程语言编译器。
static ClassLoader | getSystemToolClassLoader() 返回此平台提供的工具的类加载器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getSystemJavaCompiler

public static JavaCompiler getSystemJavaCompiler()
获取此平台提供的 Java™ 编程语言编译器。

返回：
此平台提供的编译器；如果没有提供编译器，则返回 null

getSystemToolClassLoader

public static ClassLoader getSystemToolClassLoader()
返回此平台提供的工具的类加载器。这不包括用户安装的工具。使用服务提供者机制查找用户安装工具。

返回：
此平台提供的工具的类加载器；如果没有提供工具，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.tools (Java Platform SE 6)

 javax.tools
接口
Diagnostic
DiagnosticListener
FileObject
JavaCompiler
JavaCompiler.CompilationTask
JavaFileManager
JavaFileManager.Location
JavaFileObject
OptionChecker
StandardJavaFileManager
Tool
类
DiagnosticCollector
ForwardingFileObject
ForwardingJavaFileManager
ForwardingJavaFileObject
SimpleJavaFileObject
ToolProvider
枚举
Diagnostic.Kind
JavaFileObject.Kind
StandardLocation


javax.tools (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.tools

为能够从程序（例如，编译器）中调用的工具提供接口。

请参见：
描述

接口摘要
Diagnostic<S> | 用于来自工具的诊断的接口。
DiagnosticListener<S> | 用于接收来自工具的诊断的接口。
FileObject | 工具的文件抽象。
JavaCompiler | 从程序中调用 Java™ 编程语言编译器的接口。
JavaCompiler.CompilationTask | 表示编译任务的 future 的接口。
JavaFileManager | 在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
JavaFileManager.Location | 文件对象位置的接口。
JavaFileObject | 在 Java™ 编程语言源和类文件上进行操作的工具的文件抽象。
OptionChecker | 识别选项的接口。
StandardJavaFileManager | 基于 java.io.File 的文件管理器。
Tool | 可以从程序中调用的工具的公共接口。

类摘要
DiagnosticCollector<S> | 提供将诊断收集到一个列表中的简单方法。
ForwardingFileObject<F extends FileObject> | 将调用转发到给定的文件对象。
ForwardingJavaFileManager<M extends JavaFileManager> | 将调用转发到给定的文件管理器。
ForwardingJavaFileObject<F extends JavaFileObject> | 将调用转发到给定的文件对象。
SimpleJavaFileObject | 为 JavaFileObject 中的大多数方法提供简单实现。
ToolProvider | 为查找工具提供者提供方法，例如，编译器的提供者。

枚举摘要
Diagnostic.Kind | 诊断的种类，例如，错误或者警告。
JavaFileObject.Kind | JavaFileObject 的种类。
StandardLocation | 文件对象的标准位置。

软件包 javax.tools 的描述

为能够从程序（例如，编译器）中调用的工具提供接口。

要求这些接口和类作为 Java™Platform, Standard Edition (Java SE) 的一部分，但是不要求提供任何实现它们的工具。

除非明确允许，否则只要给定 null 参数或给定包含 null 元素的列表或集合，此包中的所有方法都将抛出 NullPointerException。类似地，除非明确允许，否则所有方法都不可以返回 null。

此包是 Java 编程语言编译器框架的主要部分。此框架允许框架的客户端查找并运行程序中的编译器。该框架还为结构化访问诊断（DiagnosticListener）提供服务提供者接口（SPI），为重写文件访问提供文件抽象（JavaFileManager 和 JavaFileObject）。有关使用 SPI 的详细信息，请参阅 JavaCompiler。

运行时不需要编译器。然而，如果提供了默认编译器，则可以使用 ToolProvider 查找它，例如：

JavaCompiler compiler = ToolProvider.getSystemJavaCompiler();

可以通过服务提供者机制提供可选编译器或工具。

例如，如果 com.vendor.VendorJavaCompiler 是 JavaCompiler 工具的提供者，则其 jar 文件应包含 META-INF/services/javax.tools.JavaCompiler 文件。此文件将包含单行：

com.vendor.VendorJavaCompiler

如果 jar 文件在类路径上，则可以使用以下代码查找 VendorJavaCompiler：

JavaCompiler compiler = ServiceLoader.load(JavaCompiler.class).iterator().next();

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.tools 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.tools 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.tools.DiagnosticCollector<S> (implements javax.tools.DiagnosticListener<S>)
    • javax.tools.ForwardingFileObject<F> (implements javax.tools.FileObject)
      • javax.tools.ForwardingJavaFileObject<F> (implements javax.tools.JavaFileObject)
    • javax.tools.ForwardingJavaFileManager<M> (implements javax.tools.JavaFileManager)
    • javax.tools.SimpleJavaFileObject (implements javax.tools.JavaFileObject)
    • javax.tools.ToolProvider

接口分层结构

  • java.util.concurrent.Callable<V>
    • javax.tools.JavaCompiler.CompilationTask
  • java.io.Closeable
    • javax.tools.JavaFileManager (并 extends java.io.Flushable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
  • javax.tools.Diagnostic<S>
  • javax.tools.DiagnosticListener<S>
  • javax.tools.FileObject
    • javax.tools.JavaFileObject
  • java.io.Flushable
    • javax.tools.JavaFileManager (并 extends java.io.Closeable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
  • javax.tools.JavaFileManager.Location
  • javax.tools.OptionChecker
    • javax.tools.JavaCompiler (并 extends javax.tools.Tool)
    • javax.tools.JavaFileManager (并 extends java.io.Closeable, java.io.Flushable)
      • javax.tools.StandardJavaFileManager
  • javax.tools.Tool
    • javax.tools.JavaCompiler (并 extends javax.tools.OptionChecker)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.tools.StandardLocation (implements javax.tools.JavaFileManager.Location)
      • javax.tools.Diagnostic.Kind
      • javax.tools.JavaFileObject.Kind
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.tools 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.tools
的使用

使用 javax.tools 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 使用的 javax.tools 中的类
Diagnostic.Kind
诊断的种类，例如，错误或者警告。
FileObject
工具的文件抽象。
JavaFileManager.Location
文件对象位置的接口。
JavaFileObject
在 Java™ 编程语言源和类文件上进行操作的工具的文件抽象。

javax.tools 使用的 javax.tools 中的类
Diagnostic
用于来自工具的诊断的接口。
Diagnostic.Kind
诊断的种类，例如，错误或者警告。
DiagnosticListener
用于接收来自工具的诊断的接口。
FileObject
工具的文件抽象。
ForwardingFileObject
将调用转发到给定的文件对象。
JavaCompiler
从程序中调用 Java™ 编程语言编译器的接口。
JavaCompiler.CompilationTask
表示编译任务的 future 的接口。
JavaFileManager
在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
JavaFileManager.Location
文件对象位置的接口。
JavaFileObject
在 Java™ 编程语言源和类文件上进行操作的工具的文件抽象。
JavaFileObject.Kind
JavaFileObject 的种类。
OptionChecker
识别选项的接口。
StandardJavaFileManager
基于 java.io.File 的文件管理器。
StandardLocation
文件对象的标准位置。
Tool
可以从程序中调用的工具的公共接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.StandardLocation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.StandardLocation
的使用

使用 StandardLocation 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 StandardLocation 的使用

返回 StandardLocation 的 javax.tools 中的方法
static StandardLocation | StandardLocation.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static StandardLocation[] | StandardLocation.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.JavaCompiler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaCompiler
的使用

使用 JavaCompiler 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 JavaCompiler 的使用

返回 JavaCompiler 的 javax.tools 中的方法
static JavaCompiler ToolProvider.getSystemJavaCompiler()
获取此平台提供的 Java™ 编程语言编译器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.JavaCompiler.CompilationTask 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaCompiler.CompilationTask
的使用

使用 JavaCompiler.CompilationTask 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 JavaCompiler.CompilationTask 的使用

返回 JavaCompiler.CompilationTask 的 javax.tools 中的方法
 JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.Diagnostic 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.Diagnostic
的使用

使用 Diagnostic 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 Diagnostic 的使用

返回变量类型为 Diagnostic 的类型的 javax.tools 中的方法
 List<Diagnostic<? extends S>> DiagnosticCollector.getDiagnostics()
获取此对象收集的诊断所组成的列表视图。

参数类型为 Diagnostic 的 javax.tools 中的方法
void | DiagnosticCollector.report(Diagnostic<? extends S> diagnostic)
void | DiagnosticListener.report(Diagnostic<? extends S> diagnostic) 发现问题时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.Diagnostic.Kind 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.Diagnostic.Kind
的使用

使用 Diagnostic.Kind 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 Diagnostic.Kind 的使用

参数类型为 Diagnostic.Kind 的 javax.annotation.processing 中的方法
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg) 打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e) 在元素的位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.tools 中 Diagnostic.Kind 的使用

返回 Diagnostic.Kind 的 javax.tools 中的方法
Diagnostic.Kind | Diagnostic.getKind() 获取此诊断的类型，例如，错误或者警告。
static Diagnostic.Kind | Diagnostic.Kind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Diagnostic.Kind[] | Diagnostic.Kind.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.DiagnosticCollector 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.DiagnosticCollector
的使用

没有 javax.tools.DiagnosticCollector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.DiagnosticListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.DiagnosticListener
的使用

使用 DiagnosticListener 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 DiagnosticListener 的使用

实现 DiagnosticListener 的 javax.tools 中的类
 class DiagnosticCollector<S>
提供将诊断收集到一个列表中的简单方法。

参数类型为 DiagnosticListener 的 javax.tools 中的方法
StandardJavaFileManager | JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset) 为此工具获取一个标准文件管理器实现的新实例。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.FileObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.FileObject
的使用

使用 FileObject 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 FileObject 的使用

返回 FileObject 的 javax.annotation.processing 中的方法
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
FileObject | Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。

javax.tools 中 FileObject 的使用

类型参数类型为 FileObject 的 javax.tools 中的类
 class ForwardingFileObject<F extends FileObject>
将调用转发到给定的文件对象。

javax.tools 中 FileObject 的子接口
 interface JavaFileObject
在 Java™ 编程语言源和类文件上进行操作的工具的文件抽象。

实现 FileObject 的 javax.tools 中的类
class | ForwardingFileObject<F extends FileObject> 将调用转发到给定的文件对象。
class | ForwardingJavaFileObject<F extends JavaFileObject> 将调用转发到给定的文件对象。
class | SimpleJavaFileObject 为 JavaFileObject 中的大多数方法提供简单实现。

声明为 FileObject 的 javax.tools 中的字段
protected  F ForwardingFileObject.fileObject
一个文件对象，所有方法都将委托给它。

返回 FileObject 的 javax.tools 中的方法
FileObject | ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
FileObject | JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName) 获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
FileObject | JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。

参数类型为 FileObject 的 javax.tools 中的方法
FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
FileObject | JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
JavaFileObject | JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。
boolean | ForwardingJavaFileManager.isSameFile(FileObject a, FileObject b)
boolean | JavaFileManager.isSameFile(FileObject a, FileObject b) 比较两个文件对象，如果它们表示相同的底层对象，则返回 true。
boolean | StandardJavaFileManager.isSameFile(FileObject a, FileObject b) 比较两个文件对象，如果它们表示相同的规范文件、zip 文件条目或者基于任何文件系统的容器中的条目，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.ForwardingFileObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.ForwardingFileObject
的使用

使用 ForwardingFileObject 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 ForwardingFileObject 的使用

javax.tools 中 ForwardingFileObject 的子类
 class ForwardingJavaFileObject<F extends JavaFileObject>
将调用转发到给定的文件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.ForwardingJavaFileManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.ForwardingJavaFileManager
的使用

没有 javax.tools.ForwardingJavaFileManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.ForwardingJavaFileObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.ForwardingJavaFileObject
的使用

没有 javax.tools.ForwardingJavaFileObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.JavaFileManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaFileManager
的使用

使用 JavaFileManager 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 JavaFileManager 的使用

类型参数类型为 JavaFileManager 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

javax.tools 中 JavaFileManager 的子接口
 interface StandardJavaFileManager
基于 java.io.File 的文件管理器。

实现 JavaFileManager 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

声明为 JavaFileManager 的 javax.tools 中的字段
protected  M ForwardingJavaFileManager.fileManager
一个文件管理器，所有方法都将委托给它。

参数类型为 JavaFileManager 的 javax.tools 中的方法
 JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.JavaFileManager.Location 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaFileManager.Location
的使用

使用 JavaFileManager.Location 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 JavaFileManager.Location 的使用

参数类型为 JavaFileManager.Location 的 javax.annotation.processing 中的方法
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
FileObject | Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。

javax.tools 中 JavaFileManager.Location 的使用

实现 JavaFileManager.Location 的 javax.tools 中的类
 class StandardLocation
文件对象的标准位置。

返回 JavaFileManager.Location 的 javax.tools 中的方法
static JavaFileManager.Location StandardLocation.locationFor(String name)
使用给定名称获取位置对象。

参数类型为 JavaFileManager.Location 的 javax.tools 中的方法
ClassLoader | ForwardingJavaFileManager.getClassLoader(JavaFileManager.Location location)
ClassLoader | JavaFileManager.getClassLoader(JavaFileManager.Location location) 获取可从给定位置加载插件的类加载器。
FileObject | ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
FileObject | JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName) 获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
FileObject | ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
FileObject | JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
JavaFileObject | JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind) 获取输入的文件对象，它表示给定位置处指定类型的指定类。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
JavaFileObject | JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。
Iterable<? extends File> | StandardJavaFileManager.getLocation(JavaFileManager.Location location) 获取与给定位置关联的路径。
boolean | ForwardingJavaFileManager.hasLocation(JavaFileManager.Location location)
boolean | JavaFileManager.hasLocation(JavaFileManager.Location location) 确定此文件管理器是否已知某位置。
String | ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
String | JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file) 根据位置推断文件对象的二进制名称。
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。
void | StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path) 将给定路径与给定位置关联。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.JavaFileObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.JavaFileObject
的使用

使用 JavaFileObject 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 JavaFileObject 的使用

返回 JavaFileObject 的 javax.annotation.processing 中的方法
JavaFileObject | Filer.createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
JavaFileObject | Filer.createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。

javax.tools 中 JavaFileObject 的使用

类型参数类型为 JavaFileObject 的 javax.tools 中的类
 class ForwardingJavaFileObject<F extends JavaFileObject>
将调用转发到给定的文件对象。

实现 JavaFileObject 的 javax.tools 中的类
class | ForwardingJavaFileObject<F extends JavaFileObject> 将调用转发到给定的文件对象。
class | SimpleJavaFileObject 为 JavaFileObject 中的大多数方法提供简单实现。

返回 JavaFileObject 的 javax.tools 中的方法
JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
JavaFileObject | JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind) 获取输入的文件对象，它表示给定位置处指定类型的指定类。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
JavaFileObject | JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。

返回变量类型为 JavaFileObject 的类型的 javax.tools 中的方法
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjects(File... files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjects(String... names) 获取表示给定文件名称的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names) 获取表示给定文件名称的文件对象。
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。

参数类型为 JavaFileObject 的 javax.tools 中的方法
String | ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
String | JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file) 根据位置推断文件对象的二进制名称。

类型变量类型为 JavaFileObject 的 javax.tools 中的方法参数
StandardJavaFileManager | JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset) 为此工具获取一个标准文件管理器实现的新实例。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.Tool 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.Tool
的使用

使用 Tool 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 Tool 的使用

javax.tools 中 Tool 的子接口
 interface JavaCompiler
从程序中调用 Java™ 编程语言编译器的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.JavaFileObject.Kind 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.JavaFileObject.Kind
的使用

使用 JavaFileObject.Kind 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 JavaFileObject.Kind 的使用

声明为 JavaFileObject.Kind 的 javax.tools 中的字段
protected  JavaFileObject.Kind SimpleJavaFileObject.kind
此文件对象的种类。

返回 JavaFileObject.Kind 的 javax.tools 中的方法
JavaFileObject.Kind | ForwardingJavaFileObject.getKind()
JavaFileObject.Kind | JavaFileObject.getKind() 获取此文件对象的种类。
JavaFileObject.Kind | SimpleJavaFileObject.getKind()
static JavaFileObject.Kind | JavaFileObject.Kind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static JavaFileObject.Kind[] | JavaFileObject.Kind.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 JavaFileObject.Kind 的 javax.tools 中的方法
JavaFileObject | ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
JavaFileObject | JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind) 获取输入的文件对象，它表示给定位置处指定类型的指定类。
JavaFileObject | ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
JavaFileObject | JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling) 获取输出的文件对象，它表示给定位置处指定类型的指定类。
boolean | ForwardingJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
boolean | JavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind) 检查此文件对象是否与指定的简单名称和种类兼容。
boolean | SimpleJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind) 此实现对其 URI 路径和给定简单名称进行比较。

类型变量类型为 JavaFileObject.Kind 的 javax.tools 中的方法参数
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。

参数类型为 JavaFileObject.Kind 的 javax.tools 中的构造方法
SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
使用给定 URI 构建给定种类的 SimpleJavaFileObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.OptionChecker 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.OptionChecker
的使用

使用 OptionChecker 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 OptionChecker 的使用

javax.tools 中 OptionChecker 的子接口
interface | JavaCompiler 从程序中调用 Java™ 编程语言编译器的接口。
interface | JavaFileManager 在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
interface | StandardJavaFileManager 基于 java.io.File 的文件管理器。

实现 OptionChecker 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.SimpleJavaFileObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.SimpleJavaFileObject
的使用

没有 javax.tools.SimpleJavaFileObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.tools.StandardJavaFileManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.tools.StandardJavaFileManager
的使用

使用 StandardJavaFileManager 的软件包
javax.tools 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.tools 中 StandardJavaFileManager 的使用

返回 StandardJavaFileManager 的 javax.tools 中的方法
 StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
为此工具获取一个标准文件管理器实现的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.tools.ToolProvider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.tools.ToolProvider
的使用

没有 javax.tools.ToolProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


InvalidTransactionException (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.transaction
类 InvalidTransactionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  javax.transaction.InvalidTransactionException
所有已实现的接口：
Serializable
public class InvalidTransactionException
extends RemoteException

此异常指示该请求带来了无效的事务上下文。例如，在尝试注册资源时如果发生错误，则会引发此异常。

另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
InvalidTransactionException()
InvalidTransactionException(String msg)
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidTransactionException

public InvalidTransactionException()

InvalidTransactionException

public InvalidTransactionException(String msg)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


TransactionRequiredException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.transaction
类 TransactionRequiredException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  javax.transaction.TransactionRequiredException
所有已实现的接口：
Serializable
public class TransactionRequiredException
extends RemoteException

此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。

另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
TransactionRequiredException()
TransactionRequiredException(String msg)
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TransactionRequiredException

public TransactionRequiredException()

TransactionRequiredException

public TransactionRequiredException(String msg)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransactionRolledbackException (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.transaction
类 TransactionRolledbackException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  javax.transaction.TransactionRolledbackException
所有已实现的接口：
Serializable
public class TransactionRolledbackException
extends RemoteException

此异常指示与请求处理关联的事务已回滚，或已标记为回滚。因此，请求操作不能执行或没有执行，因为代表事务进行下一步计算是无结果的。

另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
TransactionRolledbackException()
TransactionRolledbackException(String msg)
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TransactionRolledbackException

public TransactionRolledbackException()

TransactionRolledbackException

public TransactionRolledbackException(String msg)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.transaction (Java Platform SE 6)

 javax.transaction
异常
InvalidTransactionException
TransactionRequiredException
TransactionRolledbackException


javax.transaction (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.transaction

包含解组期间通过 ORB 机制抛出的三个异常。

请参见：
描述

异常摘要
InvalidTransactionException | 此异常指示该请求带来了无效的事务上下文。
TransactionRequiredException | 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
TransactionRolledbackException | 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

软件包 javax.transaction 的描述

包含解组期间通过 ORB 机制抛出的三个异常。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.transaction 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.transaction 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.transaction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.transaction
的使用

没有 javax.transaction 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


XAException (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.transaction.xa
类 XAException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.transaction.xa.XAException
所有已实现的接口：
Serializable
public class XAException
extends Exception

资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

另请参见：
序列化表格

字段摘要
int | errorCode 用其创建 SystemException 的错误代码。
static int | XA_HEURCOM 以启发式方式提交事务分支。
static int | XA_HEURHAZ 以启发式方式完成事务分支。
static int | XA_HEURMIX 以启发式方式提交并回滚事务分支。
static int | XA_HEURRB 以启发式方式回滚事务分支。
static int | XA_NOMIGRATE 必须在发生挂起的地方发生恢复。
static int | XA_RBBASE 回滚代码包含的下边界。
static int | XA_RBCOMMFAIL 指示通讯失败导致该回滚。
static int | XA_RBDEADLOCK 检测死锁。
static int | XA_RBEND 回滚错误代码包含的上边界。
static int | XA_RBINTEGRITY 检测违反资源完整性的条件。
static int | XA_RBOTHER 由于一个不在此列表上的原因，资源管理器回滚事务分支。
static int | XA_RBPROTO 在资源管理器中发生协议错误。
static int | XA_RBROLLBACK 指示未指定的原因导致该回滚。
static int | XA_RBTIMEOUT 事务分支占用时间太长。
static int | XA_RBTRANSIENT 可以重试事务分支。
static int | XA_RDONLY 事务分支是只读的，并且已提交。
static int | XA_RETRY 返回的例程无效，可以重新发布。
static int | XAER_ASYNC 已存在明显的异步操作。
static int | XAER_DUPID XID 已存在。
static int | XAER_INVAL 提供了无效的参数。
static int | XAER_NOTA XID 无效。
static int | XAER_OUTSIDE 资源管理器进行全局事务之外的工作。
static int | XAER_PROTO 在不合适的上下文中调用例程。
static int | XAER_RMERR 在事务分支中发生资源管理器错误。
static int | XAER_RMFAIL 资源管理器不可用。
构造方法摘要
XAException()
创建一个 XAException。
XAException(int errcode)
创建一个具有给定错误代码的 XAException。
XAException(String s)
创建一个具有给定字符串的 XAException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

errorCode

public int errorCode
用其创建 SystemException 的错误代码。

XA_RBBASE

public static final int XA_RBBASE
回滚代码包含的下边界。

另请参见：
常量字段值

XA_RBROLLBACK

public static final int XA_RBROLLBACK
指示未指定的原因导致该回滚。

另请参见：
常量字段值

XA_RBCOMMFAIL

public static final int XA_RBCOMMFAIL
指示通讯失败导致该回滚。

另请参见：
常量字段值

XA_RBDEADLOCK

public static final int XA_RBDEADLOCK
检测死锁。

另请参见：
常量字段值

XA_RBINTEGRITY

public static final int XA_RBINTEGRITY
检测违反资源完整性的条件。

另请参见：
常量字段值

XA_RBOTHER

public static final int XA_RBOTHER
由于一个不在此列表上的原因，资源管理器回滚事务分支。

另请参见：
常量字段值

XA_RBPROTO

public static final int XA_RBPROTO
在资源管理器中发生协议错误。

另请参见：
常量字段值

XA_RBTIMEOUT

public static final int XA_RBTIMEOUT
事务分支占用时间太长。

另请参见：
常量字段值

XA_RBTRANSIENT

public static final int XA_RBTRANSIENT
可以重试事务分支。

另请参见：
常量字段值

XA_RBEND

public static final int XA_RBEND
回滚错误代码包含的上边界。

另请参见：
常量字段值

XA_NOMIGRATE

public static final int XA_NOMIGRATE
必须在发生挂起的地方发生恢复。

另请参见：
常量字段值

XA_HEURHAZ

public static final int XA_HEURHAZ
以启发式方式完成事务分支。

另请参见：
常量字段值

XA_HEURCOM

public static final int XA_HEURCOM
以启发式方式提交事务分支。

另请参见：
常量字段值

XA_HEURRB

public static final int XA_HEURRB
以启发式方式回滚事务分支。

另请参见：
常量字段值

XA_HEURMIX

public static final int XA_HEURMIX
以启发式方式提交并回滚事务分支。

另请参见：
常量字段值

XA_RETRY

public static final int XA_RETRY
返回的例程无效，可以重新发布。

另请参见：
常量字段值

XA_RDONLY

public static final int XA_RDONLY
事务分支是只读的，并且已提交。

另请参见：
常量字段值

XAER_ASYNC

public static final int XAER_ASYNC
已存在明显的异步操作。

另请参见：
常量字段值

XAER_RMERR

public static final int XAER_RMERR
在事务分支中发生资源管理器错误。

另请参见：
常量字段值

XAER_NOTA

public static final int XAER_NOTA
XID 无效。

另请参见：
常量字段值

XAER_INVAL

public static final int XAER_INVAL
提供了无效的参数。

另请参见：
常量字段值

XAER_PROTO

public static final int XAER_PROTO
在不合适的上下文中调用例程。

另请参见：
常量字段值

XAER_RMFAIL

public static final int XAER_RMFAIL
资源管理器不可用。

另请参见：
常量字段值

XAER_DUPID

public static final int XAER_DUPID
XID 已存在。

另请参见：
常量字段值

XAER_OUTSIDE

public static final int XAER_OUTSIDE
资源管理器进行全局事务之外的工作。

另请参见：
常量字段值
构造方法详细信息

XAException

public XAException()
创建一个 XAException。

XAException

public XAException(String s)
创建一个具有给定字符串的 XAException。

参数：
s - 包含异常消息的 String 对象。

XAException

public XAException(int errcode)
创建一个具有给定错误代码的 XAException。

参数：
errcode - 标识异常的错误代码。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


XAResource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.transaction.xa
接口 XAResource

public interface XAResource

XAResource 接口是基于 X/Open CAE 规范（分布式事务处理：XA 规范）的工业标准 XA 接口的 Java 映射。

在分布式事务处理 (DTP) 环境中，XA 接口定义资源管理器和事务管理器之间的协定。JDBC 驱动程序或 JMS 提供者实现此接口，以支持全局事务与数据库或消息服务连接之间的关联。

可由应用程序在外部事务管理器控制事务的环境中使用的任何事务资源均可支持 XAResource 接口。数据库管理系统就属于此类资源。应用程序可以通过多个数据库连接访问数据。通过事务管理器将每个数据库连接作为事务资源添加到列表中。事务管理器为参与全局事务的每个连接获取 XAResource。事务管理器使用 start 方法建立全局事务与资源之间的关联，而使用 end 方法取消事务与资源之间的关联。资源管理器负责将全局事务关联到在 start 与 end 方法调用之间对其数据执行的所有工作。

在事务提交时，事务管理器通知资源管理器根据二阶段提交协议准备、提交或回滚事务。

字段摘要
static int | TMENDRSCAN 终止恢复扫描。
static int | TMFAIL 取消关联调用者，并将事务分支标记为只回滚。
static int | TMJOIN 调用者正连接现有事务分支。
static int | TMNOFLAGS 使用 TMNOFLAGS 指示不选择任何标志值。
static int | TMONEPHASE 调用者正在使用一阶段优化。
static int | TMRESUME 调用者正在恢复与挂起的事务分支的关联。
static int | TMSTARTRSCAN 启动恢复扫描。
static int | TMSUCCESS 取消调用者与事务分支的关联。
static int | TMSUSPEND 调用者正挂起（不是终止）其与事务分支的关联。
static int | XA_OK 事务工作正常准备就绪。
static int | XA_RDONLY 事务分支是只读的，并且已提交。
方法摘要
void | commit(Xid xid, boolean onePhase) 提交 xid 指定的全局事务。
void | end(Xid xid, int flags) 终止代表事务分支所执行的工作。
void | forget(Xid xid) 告知资源管理器忽略以启发式完成的事务分支。
int | getTransactionTimeout() 获取为此 XAResource 实例设置的当前事务超时值。
boolean | isSameRM(XAResource xares) 调用此方法，以确定目标对象表示的资源管理器实例是否与参数 xares 表示的资源管理器实例相同。
int | prepare(Xid xid) 请求资源管理器准备好 xid 中指定的事务的事务提交工作。
Xid[] | recover(int flag) 从资源管理器获取准备的事务分支的列表。
void | rollback(Xid xid) 通知资源管理器回滚代表事务分支执行的工作。
boolean | setTransactionTimeout(int seconds) 为此 XAResource 实例设置当前事务超时值。
void | start(Xid xid, int flags) 代表 xid 中指定的事务分支开始工作。

字段详细信息

TMENDRSCAN

static final int TMENDRSCAN
终止恢复扫描。

另请参见：
常量字段值

TMFAIL

static final int TMFAIL
取消关联调用者，并将事务分支标记为只回滚。

另请参见：
常量字段值

TMJOIN

static final int TMJOIN
调用者正连接现有事务分支。

另请参见：
常量字段值

TMNOFLAGS

static final int TMNOFLAGS
使用 TMNOFLAGS 指示不选择任何标志值。

另请参见：
常量字段值

TMONEPHASE

static final int TMONEPHASE
调用者正在使用一阶段优化。

另请参见：
常量字段值

TMRESUME

static final int TMRESUME
调用者正在恢复与挂起的事务分支的关联。

另请参见：
常量字段值

TMSTARTRSCAN

static final int TMSTARTRSCAN
启动恢复扫描。

另请参见：
常量字段值

TMSUCCESS

static final int TMSUCCESS
取消调用者与事务分支的关联。

另请参见：
常量字段值

TMSUSPEND

static final int TMSUSPEND
调用者正挂起（不是终止）其与事务分支的关联。

另请参见：
常量字段值

XA_RDONLY

static final int XA_RDONLY
事务分支是只读的，并且已提交。

另请参见：
常量字段值

XA_OK

static final int XA_OK
事务工作正常准备就绪。

另请参见：
常量字段值
方法详细信息

commit

void commit(Xid xid,
            boolean onePhase)
            throws XAException
提交 xid 指定的全局事务。

参数：
xid - 全局事务标识符
onePhase - 如果为 true，则资源管理器应使用单阶段提交协议提交代表 xid 执行的工作。
抛出：
XAException - 发生错误。可能的 XAExceptions 为 XA_HEURHAZ、XA_HEURCOM、XA_HEURRB、XA_HEURMIX、XAER_RMERR、XAER_RMFAIL、XAER_NOTA、XAER_INVAL 或 XAER_PROTO。

如果资源管理器不提交事务，并且将参数 onePhase 设置为 true，则资源管理器可能抛出 XA_RB* 异常之一。返回时，资源管理器已经回滚分支的工作，并且已经释放所有占用的资源。

end

void end(Xid xid,
         int flags)
         throws XAException
终止代表事务分支所执行的工作。资源管理器取消 XA 资源与指定的事务分支的关联，并使事务完成。

如果在标志中指定 TMSUSPEND，则事务分支将以未完成状态中暂时挂起。事务上下文处于挂起状态，必须通过 start 方法且将标志指定为 TMRESUME 来恢复。

如果指定 TMFAIL，则部分工作将失败。资源管理器可以将事务标记为只回滚

如果指定 TMSUCCESS，则将完成部分工作。

参数：
xid - 全局事务标识符，它与以前在 start 方法中使用的标识符相同。
flags - TMSUCCESS、TMFAIL 或 TMSUSPEND 之一。
抛出：
XAException - 发生错误。可能的 XAException 值为 XAER_RMERR、XAER_RMFAILED、XAER_NOTA、XAER_INVAL、XAER_PROTO 或 XA_RB*。

forget

void forget(Xid xid)
            throws XAException
告知资源管理器忽略以启发式完成的事务分支。

参数：
xid - 全局事务标识符
抛出：
XAException - 发生错误。可能的异常值为 XAER_RMERR、XAER_RMFAIL、XAER_NOTA、XAER_INVAL 或 XAER_PROTO。

getTransactionTimeout

int getTransactionTimeout()
                          throws XAException
获取为此 XAResource 实例设置的当前事务超时值。如果在调用此方法之前不使用 XAResource.setTransactionTimeout，则返回值是资源管理器的默认超时集；否则，返回在以前 setTransactionTimeout 调用中使用的值。

返回：
以秒为单位的事务超时值。
抛出：
XAException - 发生错误。可能的异常值为 XAER_RMERR 和 XAER_RMFAIL。

isSameRM

boolean isSameRM(XAResource xares)
                 throws XAException
调用此方法，以确定目标对象表示的资源管理器实例是否与参数 xares 表示的资源管理器实例相同。

参数：
xares - 其资源管理器实例将与目标对象的资源管理器实例进行比较的 XAResource 对象。
返回：
如果是相同的 RM 实例，则返回 true；否则返回 false。
抛出：
XAException - 发生错误。可能的异常值为 XAER_RMERR 和 XAER_RMFAIL。

prepare

int prepare(Xid xid)
            throws XAException
请求资源管理器准备好 xid 中指定的事务的事务提交工作。

参数：
xid - 全局事务标识符
返回：
一个值，它指示资源管理器对事务结果的表决。可能的值为：XA_RDONLY 或 XA_OK。如果资源管理器要回滚事务，则应通过 prepare 方法中引发相应的 XAException 来实现此操作。
抛出：
XAException - 发生错误。可能的异常值为：XA_RB*、XAER_RMERR、XAER_RMFAIL、XAER_NOTA、XAER_INVAL 或 XAER_PROTO。

recover

Xid[] recover(int flag)
              throws XAException
从资源管理器获取准备的事务分支的列表。恢复过程中，事务管理器调用此方法以获取当前处于准备或以启发式完成的状态的事务分支列表。

参数：
flag - TMSTARTRSCAN、MENDRSCAN、MNOFLAGS 之一。参数中没有设置任何其他标志时，必须使用 MNOFLAGS。
返回：
资源管理器返回当前处于准备或以启发式完成的状态的事务分支的零或多个 XID。如果在操作过程中发生错误，则资源管理器应抛出适当的 XAException。
抛出：
XAException - 发生错误。可能的值为 XAER_RMERR、XAER_RMFAIL、XAER_INVAL 和 XAER_PROTO。

rollback

void rollback(Xid xid)
              throws XAException
通知资源管理器回滚代表事务分支执行的工作。

参数：
xid - 全局事务标识符
抛出：
XAException - 发生错误。

setTransactionTimeout

boolean setTransactionTimeout(int seconds)
                              throws XAException

为此 XAResource 实例设置当前事务超时值。设置后，在使用其他值再次调用 setTransactionTimeout 之前，此超时值是有效的。要将超时值重设为资源管理器使用的默认值，请将该值设置为零。 如果执行超时操作成功，则方法返回 true；否则返回 false。如果资源管理器不支持显式设置事务超时值，则此方法返回 false。

参数：
seconds - 以秒为单位的事务超时值。
返回：
如果成功设置事务超时值，则返回 true；否则返回 false。
抛出：
XAException - 发生错误。可能的异常值为 XAER_RMERR、XAER_RMFAIL 或 XAER_INVAL。

start

void start(Xid xid,
           int flags)
           throws XAException
代表 xid 中指定的事务分支开始工作。 如果指定 TMJOIN，则该启动适用于连接资源管理器以前看到的事务。如果指定 TMRESUME，该启动适用于恢复参数 xid 中指定的挂起事务。 如果 TMJOIN 和 TMRESUME 都没有指定，并且资源管理器以前查看到 xid 指定的事务，则资源管理器抛出带有 XAER_DUPID 错误代码的 XAException 异常。

参数：
xid - 与资源关联的全局事务标识符。
flags - TMNOFLAGS、TMJOIN 或 TMRESUME 之一。
抛出：
XAException - 发生错误。可能的异常为 XA_RB*、XAER_RMERR、XAER_RMFAIL、XAER_DUPID、XAER_OUTSIDE、XAER_NOTA、XAER_INVAL 或 XAER_PROTO。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Xid (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.transaction.xa
接口 Xid

public interface Xid

Xid 接口是 X/Open 事务标识符 XID 结构的 Java 映射。此接口指定三个存取方法，以检索全局事务格式 ID、全局事务 ID 和分支限定符。Xid 接口供事务管理器和资源管理器使用。此接口对应用程序不可见。

字段摘要
static int | MAXBQUALSIZE getBqual 返回的最大字节数。
static int | MAXGTRIDSIZE getGtrid 返回的最大字节数。
方法摘要
byte[] | getBranchQualifier() 获取 XID 的事务分支标识符部分作为字节数组。
int | getFormatId() 获取 XID 的格式标识符部分。
byte[] | getGlobalTransactionId() 获取 XID 的全局事务标识符部分作为字节数组。

字段详细信息

MAXGTRIDSIZE

static final int MAXGTRIDSIZE
getGtrid 返回的最大字节数。

另请参见：
常量字段值

MAXBQUALSIZE

static final int MAXBQUALSIZE
getBqual 返回的最大字节数。

另请参见：
常量字段值
方法详细信息

getFormatId

int getFormatId()
获取 XID 的格式标识符部分。

返回：
格式标识符。O 指 OSI CCR 格式。

getGlobalTransactionId

byte[] getGlobalTransactionId()
获取 XID 的全局事务标识符部分作为字节数组。

返回：
全局事务标识符。

getBranchQualifier

byte[] getBranchQualifier()
获取 XID 的事务分支标识符部分作为字节数组。

返回：
全局事务标识符。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.transaction.xa (Java Platform SE 6)

 javax.transaction.xa
接口
XAResource
Xid
异常
XAException


javax.transaction.xa (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.transaction.xa

提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

请参见：
描述

接口摘要
XAResource | XAResource 接口是基于 X/Open CAE 规范（分布式事务处理：XA 规范）的工业标准 XA 接口的 Java 映射。
Xid | Xid 接口是 X/Open 事务标识符 XID 结构的 Java 映射。

异常摘要
XAException 资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

软件包 javax.transaction.xa 的描述

提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。特殊资源管理器的驱动程序供应商提供此 API 的实现。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.transaction.xa 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.transaction.xa 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.transaction.xa.XAException

接口分层结构

  • javax.transaction.xa.XAResource
  • javax.transaction.xa.Xid
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.transaction.xa 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.transaction.xa
的使用

使用 javax.transaction.xa 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.sql 使用的 javax.transaction.xa 中的类
XAResource
XAResource 接口是基于 X/Open CAE 规范（分布式事务处理：XA 规范）的工业标准 XA 接口的 Java 映射。

javax.transaction.xa 使用的 javax.transaction.xa 中的类
XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。
XAResource
XAResource 接口是基于 X/Open CAE 规范（分布式事务处理：XA 规范）的工业标准 XA 接口的 Java 映射。
Xid
Xid 接口是 X/Open 事务标识符 XID 结构的 Java 映射。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.transaction.xa.XAException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.transaction.xa.XAException
的使用

使用 XAException 的软件包
javax.transaction.xa 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.transaction.xa 中 XAException 的使用

抛出 XAException 的 javax.transaction.xa 中的方法
void | XAResource.commit(Xid xid, boolean onePhase) 提交 xid 指定的全局事务。
void | XAResource.end(Xid xid, int flags) 终止代表事务分支所执行的工作。
void | XAResource.forget(Xid xid) 告知资源管理器忽略以启发式完成的事务分支。
int | XAResource.getTransactionTimeout() 获取为此 XAResource 实例设置的当前事务超时值。
boolean | XAResource.isSameRM(XAResource xares) 调用此方法，以确定目标对象表示的资源管理器实例是否与参数 xares 表示的资源管理器实例相同。
int | XAResource.prepare(Xid xid) 请求资源管理器准备好 xid 中指定的事务的事务提交工作。
Xid[] | XAResource.recover(int flag) 从资源管理器获取准备的事务分支的列表。
void | XAResource.rollback(Xid xid) 通知资源管理器回滚代表事务分支执行的工作。
boolean | XAResource.setTransactionTimeout(int seconds) 为此 XAResource 实例设置当前事务超时值。
void | XAResource.start(Xid xid, int flags) 代表 xid 中指定的事务分支开始工作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.transaction.xa.XAResource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.transaction.xa.XAResource
的使用

使用 XAResource 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.sql 中 XAResource 的使用

返回 XAResource 的 javax.sql 中的方法
 XAResource XAConnection.getXAResource()
获取 XAResource 对象，事务管理器将使用该对象管理此 XAConnection 对象如何参与到分布式事务中。

javax.transaction.xa 中 XAResource 的使用

参数类型为 XAResource 的 javax.transaction.xa 中的方法
 boolean XAResource.isSameRM(XAResource xares)
调用此方法，以确定目标对象表示的资源管理器实例是否与参数 xares 表示的资源管理器实例相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.transaction.xa.Xid 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.transaction.xa.Xid
的使用

使用 Xid 的软件包
javax.transaction.xa 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.transaction.xa 中 Xid 的使用

返回 Xid 的 javax.transaction.xa 中的方法
 Xid[] XAResource.recover(int flag)
从资源管理器获取准备的事务分支的列表。

参数类型为 Xid 的 javax.transaction.xa 中的方法
void | XAResource.commit(Xid xid, boolean onePhase) 提交 xid 指定的全局事务。
void | XAResource.end(Xid xid, int flags) 终止代表事务分支所执行的工作。
void | XAResource.forget(Xid xid) 告知资源管理器忽略以启发式完成的事务分支。
int | XAResource.prepare(Xid xid) 请求资源管理器准备好 xid 中指定的事务的事务提交工作。
void | XAResource.rollback(Xid xid) 通知资源管理器回滚代表事务分支执行的工作。
void | XAResource.start(Xid xid, int flags) 代表 xid 中指定的事务分支开始工作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.transaction.InvalidTransactionException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.transaction.InvalidTransactionException
的使用

没有 javax.transaction.InvalidTransactionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.transaction.TransactionRequiredException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.transaction.TransactionRequiredException
的使用

没有 javax.transaction.TransactionRequiredException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.transaction.TransactionRolledbackException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.transaction.TransactionRolledbackException
的使用

没有 javax.transaction.TransactionRolledbackException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


XMLConstants (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml
类 XMLConstants

java.lang.Object
    继承者  javax.xml.XMLConstants

public final class XMLConstants
extends Object

包含基本 XML 值作为常量的实用工具类。

从以下版本开始：
1.5
另请参见：
Extensible Markup Language (XML) 1.1, Extensible Markup Language (XML) 1.0 (Second Edition), XML 1.0 Second Edition Specification Errata, Namespaces in XML 1.1, Namespaces in XML, Namespaces in XML Errata, XML Schema Part 1: Structures

字段摘要
static String | DEFAULT_NS_PREFIX 用于表示默认 XML 名称空间的前缀。
static String | FEATURE_SECURE_PROCESSING 用于安全处理的功能。
static String | NULL_NS_URI 用于表示不存在名称空间的名称空间 URI。
static String | RELAXNG_NS_URI RELAX NG Namespace URI. 被定义为 "http://relaxng.org/ns/structure/1.0"。
static String | W3C_XML_SCHEMA_INSTANCE_NS_URI W3C XML Schema Instance Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。
static String | W3C_XML_SCHEMA_NS_URI W3C XML Schema Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。
static String | W3C_XPATH_DATATYPE_NS_URI W3C XPath Datatype Namespace URI. 被定义为 "http://www.w3.org/2003/11/xpath-datatypes"。
static String | XML_DTD_NS_URI 作为属性值的 XML 文档类型声明名称空间 URI。
static String | XML_NS_PREFIX 正式的 XML 名称空间前缀。
static String | XML_NS_URI 正式的 XML 名称空间名称 URI。
static String | XMLNS_ATTRIBUTE 用于指定 XML 名称空间声明的正式 XML 属性。
static String | XMLNS_ATTRIBUTE_NS_URI 用于指定 XML 名称空间声明、XMLConstants.XMLNS_ATTRIBUTE、名称空间名称 URI 的正式 XML 属性。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NULL_NS_URI

public static final String NULL_NS_URI

用于表示不存在名称空间的名称空间 URI。

根据名称空间规范将其定义为 ""。

另请参见：
Namespaces in XML 中的 5.2 小节 Namespace Defaulting, 常量字段值

DEFAULT_NS_PREFIX

public static final String DEFAULT_NS_PREFIX

用于表示默认 XML 名称空间的前缀。

根据 XML 规范将其定义为 ""。

另请参见：
Namespaces in XML 中的 3. 小节 Qualified Names, 常量字段值

XML_NS_URI

public static final String XML_NS_URI

正式的 XML 名称空间名称 URI。

根据 XML 规范将其定义为 "http://www.w3.org/XML/1998/namespace"。

另请参见：
Namespaces in XML 中的 3. 小节 Qualified Names, 常量字段值

XML_NS_PREFIX

public static final String XML_NS_PREFIX

正式的 XML 名称空间前缀。

根据 XML 规范将其定义为 "xml"。

另请参见：
Namespaces in XML 中的 3. 小节 Qualified Names<</a>, 常量字段值

XMLNS_ATTRIBUTE_NS_URI

public static final String XMLNS_ATTRIBUTE_NS_URI

用于指定 XML 名称空间声明、XMLConstants.XMLNS_ATTRIBUTE、名称空间名称 URI 的正式 XML 属性。

根据 XML 规范将其定义为 "http://www.w3.org/2000/xmlns/"。

另请参见：
Namespaces in XML 中的 3. 小节 Qualified Names, Namespaces in XML 勘误表, 常量字段值

XMLNS_ATTRIBUTE

public static final String XMLNS_ATTRIBUTE

用于指定 XML 名称空间声明的正式 XML 属性。

将它用作前缀是无 效的。根据 XML 规范将其定义为 "xmlns"。

另请参见：
Namespaces in XML 中的 3. 小节 Qualified Names, 常量字段值

W3C_XML_SCHEMA_NS_URI

public static final String W3C_XML_SCHEMA_NS_URI

W3C XML Schema Namespace URI.

被定义为 "http://www.w3.org/2001/XMLSchema"。

另请参见：
XML Schema 第一部分：Structures 中的 2.6 小节 Schema-Related Markup in Documents Being Validated, 常量字段值

W3C_XML_SCHEMA_INSTANCE_NS_URI

public static final String W3C_XML_SCHEMA_INSTANCE_NS_URI

W3C XML Schema Instance Namespace URI.

被定义为 "http://www.w3.org/2001/XMLSchema"。

另请参见：
XML Schema 第一部分：Structures 中的 2.6 小节 Schema-Related Markup in Documents Being Validated, 常量字段值

W3C_XPATH_DATATYPE_NS_URI

public static final String W3C_XPATH_DATATYPE_NS_URI

W3C XPath Datatype Namespace URI.

被定义为 "http://www.w3.org/2003/11/xpath-datatypes"。

另请参见：
XQuery 1.0 and XPath 2.0 Data Model, 常量字段值

XML_DTD_NS_URI

public static final String XML_DTD_NS_URI

作为属性值的 XML 文档类型声明名称空间 URI。

由于任何现有标准没有正式定义，因此随意定义为 "http://www.w3.org/TR/REC-xml"。

另请参见：
常量字段值

RELAXNG_NS_URI

public static final String RELAXNG_NS_URI

RELAX NG Namespace URI.

被定义为 "http://relaxng.org/ns/structure/1.0"。

另请参见：
RELAX NG 规范, 常量字段值

FEATURE_SECURE_PROCESSING

public static final String FEATURE_SECURE_PROCESSING

用于安全处理的功能。

  • true 指示安全处理 XML 的实现。这可以在 XML 构造上设置限制，以避免拒绝服务攻击之类的情形。
  • false 指示实现按照 XML 规范的字母、忽略安全性问题（如对 XML 构造的限制）来处理 XML，以避免拒绝服务攻击之类的情形。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml (Java Platform SE 6)

 javax.xml
类
XMLConstants


javax.xml (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml

根据 XML 规范定义核心 XML 常量和功能。

请参见：
描述

类摘要
XMLConstants 包含基本 XML 值作为常量的实用工具类。

软件包 javax.xml 的描述

根据 XML 规范定义核心 XML 常量和功能。

应用以下核心 XML 标准：

  • 可扩展标记语言（Extensible Markup Language，XML） 1.1
  • 可扩展标记语言（Extensible Markup Language，XML） 1.0 （第二版）
  • XML 1.0 第二版规范勘误表
  • Namespaces in XML 1.1
  • Namespaces in XML
  • Namespaces in XML 勘误表

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.XMLConstants
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml
的使用

没有 javax.xml 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DocumentBuilder (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.parsers
类 DocumentBuilder

java.lang.Object
    继承者  javax.xml.parsers.DocumentBuilder

public abstract class DocumentBuilder
extends Object

定义 API， 使其从 XML 文档获取 DOM 文档实例。使用此类，应用程序员可以从 XML 获取一个 Document。

此类的实例可以从 DocumentBuilderFactory.newDocumentBuilder() 方法获取。获取此类的实例之后，将可以从各种输入源解析 XML。 这些输入源有 InputStreams、Files、URL 和 SAX InputSources。

注意，此类重用了 SAX API 中的一些类。这并不要求底层 DOM 实现的实现者使用 SAX 解析器将 XML 文档解析为 Document。它仅要求该实现使用这些现有的 API 与应用程序交流。

构造方法摘要
protected DocumentBuilder()
受保护的构造方法
方法摘要
abstract DOMImplementation | getDOMImplementation() 获取 DOMImplementation 对象的一个实例。
Schema | getSchema() 获取由 XML 处理器使用的 Schema 的引用。
abstract boolean | isNamespaceAware() 指示此解析器是否被配置为可识别名称空间。
abstract boolean | isValidating() 指示此解析器是否被配置为验证 XML 文档。
boolean | isXIncludeAware() 获取此解析器的 XInclude 处理模式。
abstract Document | newDocument() 获取 DOM Document 对象的一个新实例来生成一个 DOM 树。
Document | parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
abstract Document | parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | parse(String uri) 将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | reset() 将此 DocumentBuilder 重置为其原始配置。
abstract void | setEntityResolver(EntityResolver er) 指定使用 EntityResolver 解析要解析的 XML 文档中存在的实体。
abstract void | setErrorHandler(ErrorHandler eh) 指定解析器要使用的 ErrorHandler。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentBuilder

protected DocumentBuilder()
受保护的构造方法

方法详细信息

reset

public void reset()

将此 DocumentBuilder 重置为其原始配置。

DocumentBuilder 被重置为使用 DocumentBuilderFactory.newDocumentBuilder() 创建它时的状态。设计 reset() 旨在允许重用现有的 DocumentBuilder，从而节省与创建新的 DocumentBuilder 相关的资源。

重置的 DocumentBuilder 不能保证具有相同的 EntityResolver 或 ErrorHandler Object，如 Object.equals(Object obj)。可以保证具有功能相等的 EntityResolver 和 ErrorHandler。

抛出：
UnsupportedOperationException - 当实现没有重写此方法时。
从以下版本开始：
1.5

parse

public Document parse(InputStream is)
               throws SAXException,
                      IOException
将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。如果 InputStream 为 null，则抛出 IllegalArgumentException。

参数：
is - 包含要解析内容的 InputStream。
返回：
解析 InputStream 的 Document 结果。
抛出：
IOException - 如果发生任何 IO 错误。
SAXException - 如果发生任何解析错误。
IllegalArgumentException - 当 is 为 null 时
另请参见：
DocumentHandler

parse

public Document parse(InputStream is,
                      String systemId)
               throws SAXException,
                      IOException
将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。如果 InputStream 为 null，则抛出 IllegalArgumentException。

参数：
is - 包含要解析内容的 InputStream。
systemId - 提供一个与解析相关的 URI 的基础。
返回：
一个新的 DOM Document 对象。
抛出：
IOException - 如果发生任何 IO 错误。
SAXException - 如果发生任何解析错误。
IllegalArgumentException - 当 is 为 null 时
另请参见：
DocumentHandler

parse

public Document parse(String uri)
               throws SAXException,
                      IOException
将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。如果 URI 为 null，则抛出 IllegalArgumentException。

参数：
uri - 要解析的内容的位置。
返回：
一个新的 DOM Document 对象。
抛出：
IOException - 如果发生任何 IO 错误。
SAXException - 如果发生任何解析错误。
IllegalArgumentException - 当 uri 为 null 时
另请参见：
DocumentHandler

parse

public Document parse(File f)
               throws SAXException,
                      IOException
将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。如果 File 为 null，则抛出 IllegalArgumentException。

参数：
f - 包含要解析的 XML 的文件。
返回：
一个新的 DOM Document 对象。
抛出：
IOException - 如果发生任何 IO 错误。
SAXException - 如果发生任何解析错误。
IllegalArgumentException - 当 f 为 null 时
另请参见：
DocumentHandler

parse

public abstract Document parse(InputSource is)
                        throws SAXException,
                               IOException
将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。如果 InputSource 为 null，则抛出 IllegalArgumentException。

参数：
is - 包含要解析内容的 InputSource。
返回：
一个新的 DOM Document 对象。
抛出：
IOException - 如果发生任何 IO 错误。
SAXException - 如果发生任何解析错误。
IllegalArgumentException - 当 is 为 null 时
另请参见：
DocumentHandler

isNamespaceAware

public abstract boolean isNamespaceAware()
指示此解析器是否被配置为可识别名称空间。

返回：
如果此解析器被配置为可识别名称空间，则返回 true；否则返回 false。

isValidating

public abstract boolean isValidating()
指示此解析器是否被配置为验证 XML 文档。

返回：
此解析器被配置为验证 XML 文档，则返回 true；否则返回 false。

setEntityResolver

public abstract void setEntityResolver(EntityResolver er)
指定使用 EntityResolver 解析要解析的 XML 文档中存在的实体。将其设置为 null 将会导致底层实现使用其自身的默认实现和行为。

参数：
er - EntityResolver，用于解析要解析的 XML 文档中存在的实体。

setErrorHandler

public abstract void setErrorHandler(ErrorHandler eh)
指定解析器要使用的 ErrorHandler。将其设置为 null 将会导致底层实现使用其自身的默认实现和行为。

参数：
eh - 解析器将要使用的 ErrorHandler。

newDocument

public abstract Document newDocument()
获取 DOM Document 对象的一个新实例来生成一个 DOM 树。

返回：
DOM Document 对象的一个新实例。

getDOMImplementation

public abstract DOMImplementation getDOMImplementation()
获取 DOMImplementation 对象的一个实例。

返回：
新的 DOMImplementation 实例。

getSchema

public Schema getSchema()

获取由 XML 处理器使用的 Schema 的引用。

如果没有使用 schema，则返回 null。

返回：
返回正在使用的 Schema，如果一个也没有使用，则返回 null
抛出：
UnsupportedOperationException - 当实现没有重写此方法时
从以下版本开始：
1.5

isXIncludeAware

public boolean isXIncludeAware()

获取此解析器的 XInclude 处理模式。

返回：
当从工厂创建此解析器时，返回 DocumentBuilderFactory.isXIncludeAware() 的返回值。
抛出：
UnsupportedOperationException - 当实现没有重写此方法时
从以下版本开始：
1.5
另请参见：
DocumentBuilderFactory.setXIncludeAware(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DocumentBuilderFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.parsers
类 DocumentBuilderFactory

java.lang.Object
    继承者  javax.xml.parsers.DocumentBuilderFactory

public abstract class DocumentBuilderFactory
extends Object

定义工厂 API，使应用程序能够从 XML 文档获取生成 DOM 对象树的解析器。

构造方法摘要
protected DocumentBuilderFactory()
用于阻止实例化的受保护构造方法。
方法摘要
abstract Object | getAttribute(String name) 允许用户在底层实现上检索特定属性。
abstract boolean | getFeature(String name) 获取指定功能的状态。
Schema | getSchema() 获取通过 setSchema(Schema schema) 方法指定的 Schema 对象。
boolean | isCoalescing() 指示是否将工厂配置为生成满足以下条件的解析器：该解析器将 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点。
boolean | isExpandEntityReferences() 指示是否将工厂配置为生成扩展实体引用节点的解析器。
boolean | isIgnoringComments() 指示是否将工厂配置为生成忽略注释的解析器。
boolean | isIgnoringElementContentWhitespace() 指示是否将工厂配置为生成解析器，该解析器忽略元素内容中的可忽略空格。
boolean | isNamespaceAware() 指示是否将工厂配置为生成具有感知名称空间功能的解析器。
boolean | isValidating() 指示是否将工厂配置为生成解析器，该解析器在解析时验证 XML 内容。
boolean | isXIncludeAware() 获取 XInclude 处理的状态。
abstract DocumentBuilder | newDocumentBuilder() 使用当前配置的参数创建一个新的 DocumentBuilder 实例。
static DocumentBuilderFactory | newInstance() 获取 DocumentBuilderFactory 的新实例。
static DocumentBuilderFactory | newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DocumentBuilderFactory 实例。
abstract void | setAttribute(String name, Object value) 允许用户在底层实现上设置特定属性。
void | setCoalescing(boolean coalescing) 指定由此代码生成的解析器将把 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点。
void | setExpandEntityReferences(boolean expandEntityRef) 指定由此代码生成的解析器将扩展实体引用节点。
abstract void | setFeature(String name, boolean value) 设置由此工厂创建的此 DocumentBuilderFactory 和 DocumentBuilder 的功能。
void | setIgnoringComments(boolean ignoreComments) 指定由此代码生成的解析器将忽略注释。
void | setIgnoringElementContentWhitespace(boolean whitespace) 指定由此工厂创建的解析器在解析 XML 文档时，必须删除元素内容中的空格（有时也可以称作“可忽略空格”，请参阅 XML Rec 2.10）。
void | setNamespaceAware(boolean awareness) 指定由此代码生成的解析器将提供对 XML 名称空间的支持。
void | setSchema(Schema schema) 设置将由解析器使用的 Schema，该解析器从此工厂创建。
void | setValidating(boolean validating) 指定由此代码生成的解析器将验证被解析的文档。
void | setXIncludeAware(boolean state) 设置 XInclude 处理的状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DocumentBuilderFactory

protected DocumentBuilderFactory()

用于阻止实例化的受保护构造方法。请使用 newInstance()。

方法详细信息

newInstance

public static DocumentBuilderFactory newInstance()
获取 DocumentBuilderFactory 的新实例。此 static 方法创建一个新的工厂实例。此方法使用以下查找过程顺序来确定要加载的 DocumentBuilderFactory 实现类：
  • 使用 javax.xml.parsers.DocumentBuilderFactory 系统属性。
  • 使用 JRE 文件夹中的属性文件 "lib/jaxp.properties"。此配置文件格式为标准的 java.util.Properties 且包含实现类的完全限定名，其中实现类的键是上述定义的系统属性。 JAXP 实现只读取一次 jaxp.properties 文件，然后缓存其值供以后使用。如果首次尝试读取文件时，文件不存在，则不会再次尝试检查该文件是否存在。首次读取 jaxp.properties 后，其中的属性值不能再更改。
  • 如果可以，使用 Services API（在 JAR 规范中进行了详细描述）来确定类名称。Services API 将查找在运行时可用的 jar 中 META-INF/services/javax.xml.parsers.DocumentBuilderFactory 文件中的类名。
  • 平台默认的 DocumentBuilderFactory 实例。
在应用程序获取对 DocumentBuilderFactory 的引用后，它可以使用工厂来配置和获取解析器实例。

疑难解答提示

设置 jaxp.debug 系统属性将导致此方法将许多调试消息打印到 System.err，以说明其执行的操作以及在何处查找。

如果加载 DocumentBuilder 有问题，请尝试：

 java -Djaxp.debug=1 YourProgram ....

返回：
新的 DocumentBuilderFactory 实例
抛出：
FactoryConfigurationError - 如果该实现不可用，或者无法实例化。

newInstance

public static DocumentBuilderFactory newInstance(String factoryClassName,
                                                 ClassLoader classLoader)

从类名称中获取新的 DocumentBuilderFactory 实例。此函数在类路径中有多个提供者时很有用。它可以对应用程序提供更多的控制，因为它可以指定应该加载哪个提供者。

在应用程序获取对 DocumentBuilderFactory 的引用后，它可以使用工厂来配置和获取解析器实例。

疑难解答提示

设置 jaxp.debug 系统属性将导致此方法将许多调试消息打印到 System.err，这些消息说明了正在执行的操作以及何处可以找到它。

如有问题，可尝试使用以下代码：

 java -Djaxp.debug=1 YourProgram ....

参数：
factoryClassName - 提供 javax.xml.parsers.DocumentBuilderFactory 的实现的完全限定工厂类名称。
classLoader - 用来加载工厂类的 ClassLoader。如果该参数为 null，则使用当前 Thread 的上下文类加载器来加载工厂类。
返回：
新的 DocumentBuilderFactory 实例
抛出：
FactoryConfigurationError - 如果 factoryClassName 为 null，或者无法加载和实例化工厂类。
从以下版本开始：
1.6
另请参见：
newInstance()

newDocumentBuilder

public abstract DocumentBuilder newDocumentBuilder()
                                            throws ParserConfigurationException
使用当前配置的参数创建一个新的 DocumentBuilder 实例。

返回：
新的 DocumentBuilder 实例。
抛出：
ParserConfigurationException - 如果无法创建满足所请求配置的 DocumentBuilder，将抛出该异常。

setNamespaceAware

public void setNamespaceAware(boolean awareness)
指定由此代码生成的解析器将提供对 XML 名称空间的支持。默认情况下，其值设置为 false。

参数：
awareness - 如果生成的解析器将提供对 XML 名称空间的支持，则为 true；否则为 false。

setValidating

public void setValidating(boolean validating)
指定由此代码生成的解析器将验证被解析的文档。默认情况下，其值设置为 false。

注意，此处“验证”是指 XML 规范中定义的验证解析器。换句话说，它实际上仅控制 DTD 验证。（JAXP 1.2 中定义的两个遗留属性除外。）

要使用现代模式语言（如 W3C XML Schema 或 RELAX NG）而不使用 DTD，您可以将解析器配置为非验证解析器，方法是将 setValidating(boolean) 方法保留为 false，然后使用 setSchema(Schema) 方法将一个模式与解析器关联。

参数：
validating - 如果由此代码生成的解析器在解析文档时验证文档，则为 true；否则为 false。

setIgnoringElementContentWhitespace

public void setIgnoringElementContentWhitespace(boolean whitespace)
指定由此工厂创建的解析器在解析 XML 文档时，必须删除元素内容中的空格（有时也可以称作“可忽略空格”，请参阅 XML Rec 2.10）。注意，只有在空格直接包含在元素内容中，并且该元素内容是只有一个元素的内容模式时，才能删除空格（请参阅 XML Rec 3.2.1）。由于依赖于内容模式，因此此设置要求解析器处于验证模式。默认情况下，其值设置为 false。

参数：
whitespace - 如果创建的解析器在解析 XML 文档时必须删除元素内容中的空格，则为 true；否则为 false。

setExpandEntityReferences

public void setExpandEntityReferences(boolean expandEntityRef)
指定由此代码生成的解析器将扩展实体引用节点。默认情况下，此值设置为 true。

参数：
expandEntityRef - 如果生成的解析器将扩展实体引用节点，则为 true；否则为 false。

setIgnoringComments

public void setIgnoringComments(boolean ignoreComments)

指定由此代码生成的解析器将忽略注释。默认情况下，其值设置为 false。

参数：
ignoreComments - 在处理过程中忽略注释的 boolean 值。

setCoalescing

public void setCoalescing(boolean coalescing)
指定由此代码生成的解析器将把 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点。默认情况下，其值设置为 false。

参数：
coalescing - 生成的解析器将把 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的文本节点，则为 true；否则为 false。

isNamespaceAware

public boolean isNamespaceAware()
指示是否将工厂配置为生成具有感知名称空间功能的解析器。

返回：
如果将工厂配置为生成具有感知名称空间功能的解析器，则返回 true；否则返回 false。

isValidating

public boolean isValidating()
指示是否将工厂配置为生成解析器，该解析器在解析时验证 XML 内容。

返回：
如果将工厂配置为生成在解析时验证 XML 内容的解析器，则返回 true；否则返回 false。

isIgnoringElementContentWhitespace

public boolean isIgnoringElementContentWhitespace()
指示是否将工厂配置为生成解析器，该解析器忽略元素内容中的可忽略空格。

返回：
如果将工厂配置为生成忽略元素内容中可忽略空格的解析器，则返回 true；否则返回 false。

isExpandEntityReferences

public boolean isExpandEntityReferences()
指示是否将工厂配置为生成扩展实体引用节点的解析器。

返回：
如果将工厂配置为生成扩展实体引用节点的解析器，则返回 true；否则返回 false。

isIgnoringComments

public boolean isIgnoringComments()
指示是否将工厂配置为生成忽略注释的解析器。

返回：
如果将工厂配置为生成忽略注释的解析器，则返回 true；否则返回 false。

isCoalescing

public boolean isCoalescing()
指示是否将工厂配置为生成满足以下条件的解析器：该解析器将 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点。

返回：
将工厂配置为满足以下条件的解析器：该解析器将 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点，则返回 true；否则返回 false。

setAttribute

public abstract void setAttribute(String name,
                                  Object value)
                           throws IllegalArgumentException
允许用户在底层实现上设置特定属性。

参数：
name - 属性名称。
value - 属性值。
抛出：
IllegalArgumentException - 如果底层实现无法识别该属性，则抛出该异常。

getAttribute

public abstract Object getAttribute(String name)
                             throws IllegalArgumentException
允许用户在底层实现上检索特定属性。

参数：
name - 属性名称。
返回：
value 属性值。
抛出：
IllegalArgumentException - 如果底层实现无法识别该属性，则抛出该异常。

setFeature

public abstract void setFeature(String name,
                                boolean value)
                         throws ParserConfigurationException

设置由此工厂创建的此 DocumentBuilderFactory 和 DocumentBuilder 的功能。

功能名称是完全限定的 URI。实现可以定义它们自己的功能。如果此 DocumentBuilderFactory 或其创建的 DocumentBuilder 不支持该功能，则抛出 ParserConfigurationException。DocumentBuilderFactory 可以公开一个功能值，但无法更改其状态。

所有实现必须支持 XMLConstants.FEATURE_SECURE_PROCESSING 功能。当功能为以下情况时：

  • true：该实现将限制 XML 处理遵守实现限制。示例包括实体扩展限制和将使用大量资源的 XML 模式构造。如果出于安全原因限制 XML 处理，将通过调用注册的 ErrorHandler.fatalError(SAXParseException exception) 进行报告。请参阅 DocumentBuilder.setErrorHandler(org.xml.sax.ErrorHandler errorHandler)。
  • false：实现将根据 XML 规范来处理 XML，而无需考虑可能的实现限制。

参数：
name - 功能名称。
value - 功能状态为 true 或 false。
抛出：
ParserConfigurationException - 如果此 DocumentBuilderFactory 或其创建的 DocumentBuilder 不能支持此功能。
NullPointerException - 如果 name 参数为 null。

getFeature

public abstract boolean getFeature(String name)
                            throws ParserConfigurationException

获取指定功能的状态。

功能名称是完全限定的 URI。实现可以定义它们自己的功能。如果此 DocumentBuilderFactory 或其创建的 DocumentBuilder 不支持该功能，则抛出 ParserConfigurationException。DocumentBuilderFactory 可以公开一个功能值，但无法更改其状态。

参数：
name - 功能名称。
返回：
指定功能的状态。
抛出：
ParserConfigurationException - 如果此 DocumentBuilderFactory 或其创建的 DocumentBuilder 不能支持此功能。

getSchema

public Schema getSchema()
获取通过 setSchema(Schema schema) 方法指定的 Schema 对象。

返回：
最后通过 setSchema(Schema) 方法设置的 Schema 对象，如果由于创建了 DocumentBuilderFactory 而没有调用该方法，则返回 null。
抛出：
UnsupportedOperationException - 当实现没有重写此方法时。
从以下版本开始：
1.5

setSchema

public void setSchema(Schema schema)

设置将由解析器使用的 Schema，该解析器从此工厂创建。

如果 Schema 为非 null，则在将信息向下传递到应用程序之前，解析器将使用从中创建的验证器来验证文档。

验证器发现错误后，解析器负责向用户指定的 ErrorHandler 报告这些错误（如果未设置错误处理程序，则忽略或抛出这些错误），就像由解析器本身发现的其他任何错误一样。换句话说，如果设置了用户指定的 ErrorHandler，则它必须接收这些错误，否则，必须根据特定于实现的默认错误处理规则来处理它们。

验证器可以修改解析器的结果（例如，通过在文档中添加丢失的默认值），解析器负责确保应用程序接收修改的 DOM 树。

最初，null 被设置为 Schema。

即使 isValidating() 方法返回 false，此过程也将生效。

将 http://java.sun.com/xml/jaxp/properties/schemaSource 属性和/或 http://java.sun.com/xml/jaxp/properties/schemaLanguage 属性与 Schema 对象一起使用将发生错误。这些配置将导致在调用 newDocumentBuilder() 时出现 ParserConfigurationException 异常。

实现者请注意：

解析器必须能够与任何 Schema 实现一起使用。但是，只要能够生成规范中描述的结果，就允许解析器和模式使用特定于实现的自定义机制。

参数：
schema - 要使用的 Schema，或者为 null，表示移除一个模式。
抛出：
UnsupportedOperationException - 当实现没有重写此方法时。
从以下版本开始：
1.5

setXIncludeAware

public void setXIncludeAware(boolean state)

设置 XInclude 处理的状态。

如果在文档实例中发现 XInclude 标记，则应按 XML Inclusions (XInclude) Version 1.0 中指定的方式处理。

XInclude 处理默认为 false。

参数：
state - 将 XInclude 处理设置为 true 或 false
抛出：
UnsupportedOperationException - 当实现没有重写此方法时。
从以下版本开始：
1.5

isXIncludeAware

public boolean isXIncludeAware()

获取 XInclude 处理的状态。

返回：
XInclude 处理的当前状态
抛出：
UnsupportedOperationException - 当实现没有重写此方法时。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FactoryConfigurationError (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.parsers
类 FactoryConfigurationError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  javax.xml.parsers.FactoryConfigurationError
所有已实现的接口：
Serializable
public class FactoryConfigurationError
extends Error

当解析器工厂的配置存在问题时抛出该异常。当找不到系统属性中指定的解析器工厂的类时，或者该类不能被实例化时，通常抛出此错误。

另请参见：
序列化表格

构造方法摘要
FactoryConfigurationError()
创建一个新的不带详细消息的 FactoryConfigurationError。
FactoryConfigurationError(Exception e)
使用错误的给定 Exception 基本原因创建一个新的 FactoryConfigurationError。
FactoryConfigurationError(Exception e, String msg)
使用给定 Exception 的基本原因和详细消息创建一个新的 FactoryConfigurationError。
FactoryConfigurationError(String msg)
创建一个新的 FactoryConfigurationError，并将 String 指定为一个错误消息。
方法摘要
Exception | getException() 返回引发此异常的实际异常（如果有）。
String | getMessage() 返回此错误的消息（如果有）。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FactoryConfigurationError

public FactoryConfigurationError()
创建一个新的不带详细消息的 FactoryConfigurationError。

FactoryConfigurationError

public FactoryConfigurationError(String msg)
创建一个新的 FactoryConfigurationError，并将 String 指定为一个错误消息。

参数：
msg - 该异常的错误消息。

FactoryConfigurationError

public FactoryConfigurationError(Exception e)
使用错误的给定 Exception 基本原因创建一个新的 FactoryConfigurationError。

参数：
e - FactoryConfigurationError 中要封装的异常。

FactoryConfigurationError

public FactoryConfigurationError(Exception e,
                                 String msg)
使用给定 Exception 的基本原因和详细消息创建一个新的 FactoryConfigurationError。

参数：
e - FactoryConfigurationError 中要封装的异常
msg - 详细消息。
方法详细信息

getMessage

public String getMessage()
返回此错误的消息（如果有）。如果不存在该异常的消息，且存在一个封装的异常，则将返回该异常的消息（如果存在）。否则,封装异常的名称将被返回。

覆盖：
类 Throwable 中的 getMessage
返回：
错误消息。

getException

public Exception getException()
返回引发此异常的实际异常（如果有）。

返回：
封装的异常，如果没有，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParserConfigurationException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.parsers
类 ParserConfigurationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.parsers.ParserConfigurationException
所有已实现的接口：
Serializable
public class ParserConfigurationException
extends Exception

指示一个严重的配置错误。

另请参见：
序列化表格

构造方法摘要
ParserConfigurationException()
创建一个新的不带详细消息的 ParserConfigurationException。
ParserConfigurationException(String msg)
创建一个新的 ParserConfigurationException，并将 String 指定为一个错误消息。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ParserConfigurationException

public ParserConfigurationException()
创建一个新的不带详细消息的 ParserConfigurationException。

ParserConfigurationException

public ParserConfigurationException(String msg)
创建一个新的 ParserConfigurationException，并将 String 指定为一个错误消息。

参数：
msg - 该异常的错误消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAXParser (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.parsers
类 SAXParser

java.lang.Object
    继承者  javax.xml.parsers.SAXParser

public abstract class SAXParser
extends Object

定义包装 XMLReader 实现类的 API。在 JAXP 1.0 中，此类包装 Parser 接口，但是此接口由 XMLReader 取代。为了便于过渡，此类继续支持相同的名称和接口，并支持新方法。 此类的实例可以从 SAXParserFactory.newSAXParser() 方法获得。获取此类的实例之后，将可以从各种输入源解析 XML。这些输入源为 InputStream、File、URL 和 SAX InputSource。

此静态方法根据系统属性设置创建新的工厂实例，如果未定义属性，则使用平台默认值。

控制创建哪个工厂实现的系统属性名为 "javax.xml.parsers.SAXParserFactory"。此属性指定一个类，该类为此抽象类的具体子类。如果未定义属性，将使用默认的平台。

由于内容由底层解析器解析，因此将调用给定 HandlerBase 或 DefaultHandler 的方法。

包装底层实现的此类的实现程序可以考虑使用 ParserAdapter 类，从而使其 SAX1 实现最初在此修订类下工作。

构造方法摘要
protected SAXParser()
将阻止实例化的受保护构造方法。
方法摘要
abstract Parser | getParser() 返回由此类的实现封装的 SAX 解析器。
abstract Object | getProperty(String name) 返回 XMLReader 的底层实现中请求的特定属性。
Schema | getSchema() 获取对 XML 处理器使用的 Schema 的引用。
abstract XMLReader | getXMLReader() 返回由此类的实现封装的 XMLReader。
abstract boolean | isNamespaceAware() 指示此解析器是否被配置为可识别名称空间。
abstract boolean | isValidating() 指示此解析器是否被配置为验证 XML 文档。
boolean | isXIncludeAware() 获取此解析器的 XInclude 处理模式。
void | parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。
void | parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
void | parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | parse(String uri, DefaultHandler dh) 使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
void | parse(String uri, HandlerBase hb) 使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
void | reset() 将此 SAXParser 重置为其原始配置。
abstract void | setProperty(String name, Object value) 设置 XMLReader 的底层实现中的特定属性。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SAXParser

protected SAXParser()

将阻止实例化的受保护构造方法。使用 SAXParserFactory.newSAXParser()。

方法详细信息

reset

public void reset()

将此 SAXParser 重置为其原始配置。

SAXParser 被重置为使用 SAXParserFactory.newSAXParser() 创建它时的状态。设计 reset() 旨在允许重用现有的 SAXParser，从而节省与创建新的 SAXParser 相关的资源。

重置的 SAXParser 不能保证具有相同的 Schema Object，如 Object.equals(Object obj)。可以保证具有功能相等的 Schema。

抛出：
UnsupportedOperationException - 当这些实现没有重写此方法时
从以下版本开始：
1.5

parse

public void parse(InputStream is,
                  HandlerBase hb)
           throws SAXException,
                  IOException

使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。建议使用此方法的 DefaultHandler 版本，因为 HandlerBase 类在 SAX 2.0 中已过时。

参数：
is - 包含要解析内容的 InputStream。
hb - 要使用的 SAX HandlerBase。
抛出：
IllegalArgumentException - 如果给定的 InputStream 为 null。
SAXException - 如果解析产生 SAX 错误。
IOException - 如果在与 InputStream 的交互过程中发生 IO 错误。
另请参见：
DocumentHandler

parse

public void parse(InputStream is,
                  HandlerBase hb,
                  String systemId)
           throws SAXException,
                  IOException

使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。建议使用此方法的 DefaultHandler 版本，因为 HandlerBase 类在 SAX 2.0 中已过时。

参数：
is - 包含要解析内容的 InputStream。
hb - 要使用的 SAX HandlerBase。
systemId - 解析相关 URI 所需的 systemId。
抛出：
IllegalArgumentException - 如果给定的 InputStream 为 null。
IOException - 如果在与 InputStream 的交互过程中发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
中的此方法。

parse

public void parse(InputStream is,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。

参数：
is - 包含要解析内容的 InputStream。
dh - 要使用的 SAX DefaultHandler。
抛出：
IllegalArgumentException - 如果给定的 InputStream 为 null。
IOException - 如果发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
DocumentHandler

parse

public void parse(InputStream is,
                  DefaultHandler dh,
                  String systemId)
           throws SAXException,
                  IOException
使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。

参数：
is - 包含要解析内容的 InputStream。
dh - 要使用的 SAX DefaultHandler。
systemId - 解析相关 URL 所需的 systemId。
抛出：
IllegalArgumentException - 如果给定的 InputStream 为 null。
IOException - 如果发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
org.xml.sax.DocumentHandler 版本。

parse

public void parse(String uri,
                  HandlerBase hb)
           throws SAXException,
                  IOException
使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。建议使用此方法的 DefaultHandler 版本，因为 HandlerBase 类在 SAX 2.0 中已过时

参数：
uri - 要解析的内容的位置。
hb - 要使用的 SAX HandlerBase。
抛出：
IllegalArgumentException - 如果 uri 为 null。
IOException - 如果发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
DocumentHandler

parse

public void parse(String uri,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

参数：
uri - 要解析的内容的位置。
dh - 要使用的 SAX DefaultHandler。
抛出：
IllegalArgumentException - 如果 uri 为 null。
IOException - 如果发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
DocumentHandler

parse

public void parse(File f,
                  HandlerBase hb)
           throws SAXException,
                  IOException
使用指定的 HandlerBase 将指定文件的内容解析为 XML。 建议使用此方法的 DefaultHandler 版本，因为 HandlerBase 类在 SAX 2.0 中已过时。

参数：
f - 包含要解析的 XML 的文件
hb - 要使用的 SAX HandlerBase。
抛出：
IllegalArgumentException - 如果 File 对象为 null。
IOException - 如果发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
DocumentHandler

parse

public void parse(File f,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
使用指定的 DefaultHandler 将指定文件的内容解析为 XML。

参数：
f - 包含要解析的 XML 的文件
dh - 要使用的 SAX DefaultHandler。
抛出：
IllegalArgumentException - 如果 File 对象为 null。
IOException - 如果发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
DocumentHandler

parse

public void parse(InputSource is,
                  HandlerBase hb)
           throws SAXException,
                  IOException
使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。建议使用此方法的 DefaultHandler 版本，因为 HandlerBase 类在 SAX 2.0 中已过时。

参数：
is - 包含要解析内容的 InputSource。
hb - 要使用的 SAX HandlerBase。
抛出：
IllegalArgumentException - 如果 InputSource 对象为 null。
IOException - 如果发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
DocumentHandler

parse

public void parse(InputSource is,
                  DefaultHandler dh)
           throws SAXException,
                  IOException
使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。

参数：
is - 包含要解析内容的 InputSource。
dh - 要使用的 SAX DefaultHandler。
抛出：
IllegalArgumentException - 如果 InputSource 对象为 null。
IOException - 如果发生任何 IO 错误。
SAXException - 如果在处理过程中发生任何 SAX 错误。
另请参见：
DocumentHandler

getParser

public abstract Parser getParser()
                          throws SAXException
返回由此类的实现封装的 SAX 解析器。

返回：
由此类的实现封装的 SAX 解析器。
抛出：
SAXException - 如果在处理过程中发生任何 SAX 错误。

getXMLReader

public abstract XMLReader getXMLReader()
                                throws SAXException
返回由此类的实现封装的 XMLReader。

返回：
由此类的实现封装的 XMLReader。
抛出：
SAXException - 如果在处理过程中发生任何 SAX 错误。

isNamespaceAware

public abstract boolean isNamespaceAware()
指示此解析器是否被配置为可识别名称空间。

返回：
如果此解析器被配置为可识别名称空间，则返回 true；否则返回 false。

isValidating

public abstract boolean isValidating()
指示此解析器是否被配置为验证 XML 文档。

返回：
此解析器被配置为验证 XML 文档，则返回 true；否则返回 false。

setProperty

public abstract void setProperty(String name,
                                 Object value)
                          throws SAXNotRecognizedException,
                                 SAXNotSupportedException

设置 XMLReader 的底层实现中的特定属性。核心功能和属性列表可以在 http://sax.sourceforge.net/?selected=get-set 中找到。

参数：
name - 要设置的属性的名称。
value - 要设置的属性的值。
抛出：
SAXNotRecognizedException - 当底层 XMLReader 不能识别属性名称时。
SAXNotSupportedException - 当底层 XMLReader 可以识别属性名称，但不支持该属性时。
另请参见：
XMLReader.setProperty(java.lang.String, java.lang.Object)

getProperty

public abstract Object getProperty(String name)
                            throws SAXNotRecognizedException,
                                   SAXNotSupportedException

返回 XMLReader 的底层实现中请求的特定属性。

参数：
name - 要检索的属性的名称。
返回：
所请求属性的值。
抛出：
SAXNotRecognizedException - 当底层 XMLReader 不能识别属性名称时。
SAXNotSupportedException - 当底层 XMLReader 可以识别属性名称，但不支持该属性时。
另请参见：
XMLReader.getProperty(java.lang.String)

getSchema

public Schema getSchema()

获取对 XML 处理器使用的 Schema 的引用。

如果没有使用 schema，则返回 null。

返回：
返回正在使用的 Schema，如果一个也没有使用，则返回 null
抛出：
UnsupportedOperationException - 当该实现没有重写此方法时
从以下版本开始：
1.5

isXIncludeAware

public boolean isXIncludeAware()

获取此解析器的 XInclude 处理模式。

返回：
当从工厂创建此解析器时，返回 SAXParserFactory.isXIncludeAware() 的返回值。
抛出：
UnsupportedOperationException - 当该实现没有重写此方法时
从以下版本开始：
1.5
另请参见：
SAXParserFactory.setXIncludeAware(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAXParserFactory (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.parsers
类 SAXParserFactory

java.lang.Object
    继承者  javax.xml.parsers.SAXParserFactory

public abstract class SAXParserFactory
extends Object

定义工厂 API，使应用程序能够配置和获取基于 SAX 的解析器以解析 XML 文档。

构造方法摘要
protected SAXParserFactory()
受保护构造方法，以强制使用 newInstance()。
方法摘要
abstract boolean | getFeature(String name) 返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
Schema | getSchema() 获取通过 setSchema(Schema schema) 方法指定的 Schema 对象。
boolean | isNamespaceAware() 指示是否将工厂配置为生成具有感知名称空间功能的解析器。
boolean | isValidating() 指示是否将工厂配置为生成解析器，该解析器在解析时验证 XML 内容。
boolean | isXIncludeAware() 获取 XInclude 处理的状态。
static SAXParserFactory | newInstance() 获取 SAXParserFactory 的一个新实例。
static SAXParserFactory | newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 SAXParserFactory 实例。
abstract SAXParser | newSAXParser() 使用当前配置的工厂参数创建 SAXParser 的一个新实例。
abstract void | setFeature(String name, boolean value) 在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
void | setNamespaceAware(boolean awareness) 指定由此代码生成的解析器将提供对 XML 名称空间的支持。
void | setSchema(Schema schema) 设置将由解析器使用的 Schema，该解析器从此工厂创建。
void | setValidating(boolean validating) 指定由此代码生成的解析器将验证被解析的文档。
void | setXIncludeAware(boolean state) 设置 XInclude 处理的状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SAXParserFactory

protected SAXParserFactory()

受保护构造方法，以强制使用 newInstance()。

方法详细信息

newInstance

public static SAXParserFactory newInstance()
获取 SAXParserFactory 的一个新实例。此静态方法创建一个新的工厂实例，此方法按照以下查找过程顺序来确定要加载的 SAXParserFactory 实例类：
  • 使用 javax.xml.parsers.SAXParserFactory 系统属性。
  • 使用 JRE 文件夹中的属性文件 "lib/jaxp.properties"。此配置文件格式为标准的 java.util.Properties 且包含实现类的完全限定名，其中实现类的键是上述定义的系统属性。 JAXP 实现只读取一次 jaxp.properties 文件，然后缓存其值供以后使用。如果首次尝试读取文件时，文件不存在，则不会再次尝试检查该文件是否存在。首次读取 jaxp.properties 后，其中的属性值不能再更改。
  • 如果可以，使用 Services API（在 JAR 规范中进行了详细描述）来确定类名称。Services API 将查找在运行时可用的 jar 中 META-INF/services/javax.xml.parsers.SAXParserFactory 文件中的类名。
  • 平台默认的 SAXParserFactory 实例。
在应用程序获取对 SAXParserFactory 的引用后，它可以使用工厂来配置和获取解析器实例。

疑难解答提示

设置 jaxp.debug 系统属性将导致此方法将许多调试消息打印到 System.err，以说明其执行的操作以及在何处查找。

如果加载 DocumentBuilder 有问题，请尝试：

 java -Djaxp.debug=1 YourProgram ....

返回：
新的 SAXParserFactory 实例。
抛出：
FactoryConfigurationError - 如果该实现不可用，或者无法被实例化。

newInstance

public static SAXParserFactory newInstance(String factoryClassName,
                                           ClassLoader classLoader)

从类名称中获取新的 SAXParserFactory 实例。此函数在类路径中有多个提供者时很有用。它可以对应用程序提供更多的控制，因为它可以指定应该加载哪个提供者。

在应用程序获取对 SAXParserFactory 的引用后，它可以使用工厂来配置和获取解析器实例。

疑难解答提示

设置 jaxp.debug 系统属性将导致此方法将许多调试消息打印到 System.err，这些消息说明了正在执行的操作以及何处可以找到它。

如有问题，可尝试使用以下代码：

 java -Djaxp.debug=1 YourProgram ....

参数：
factoryClassName - 提供 javax.xml.parsers.SAXParserFactory 的实现的完全限定工厂类名称。
classLoader - 用来加载工厂类的 ClassLoader。如果该参数为 null，则使用当前 Thread 的上下文类加载器来加载工厂类。
返回：
新的 SAXParserFactory 实例
抛出：
FactoryConfigurationError - 如果 factoryClassName 为 null，或者无法加载和实例化工厂类。
从以下版本开始：
1.6
另请参见：
newInstance()

newSAXParser

public abstract SAXParser newSAXParser()
                                throws ParserConfigurationException,
                                       SAXException

使用当前配置的工厂参数创建 SAXParser 的一个新实例。

返回：
新的 SAXParser 实例。
抛出：
ParserConfigurationException - 如果无法创建满足所请求配置的解析器，将抛出该异常。
SAXException - 用于 SAX 错误。

setNamespaceAware

public void setNamespaceAware(boolean awareness)
指定由此代码生成的解析器将提供对 XML 名称空间的支持。默认情况下，其值设置为 false。

参数：
awareness - 如果由此代码生成的解析器将提供对 XML 名称空间的支持，则为 true；否则为 false。

setValidating

public void setValidating(boolean validating)
指定由此代码生成的解析器将验证被解析的文档。默认情况下，其值设置为 false。

注意，此处“验证”是指 XML 规范中定义的验证解析器。换句话说，它实际上仅控制 DTD 验证。（JAXP 1.2 中定义的两个遗留属性除外。）

要使用现代模式语言（如 W3C XML Schema 或 RELAX NG）而不使用 DTD，您可以将解析器配置为非验证解析器，方法是将 setValidating(boolean) 方法保留为 false，然后使用 setSchema(Schema) 方法将一个模式与解析器关联。

参数：
validating - 如果由此代码生成的解析器在解析文档时验证文档，则为 true；否则为 false。

isNamespaceAware

public boolean isNamespaceAware()
指示是否将工厂配置为生成具有感知名称空间功能的解析器。

返回：
如果将工厂配置为生成具有感知名称空间功能的解析器，则返回 true；否则返回 false。

isValidating

public boolean isValidating()
指示是否将工厂配置为生成解析器，该解析器在解析时验证 XML 内容。

返回：
如果将工厂配置为生成在解析时验证 XML 内容的解析器，则返回 true；否则返回 false。

setFeature

public abstract void setFeature(String name,
                                boolean value)
                         throws ParserConfigurationException,
                                SAXNotRecognizedException,
                                SAXNotSupportedException

在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。核心功能和属性列表可以在 http://www.saxproject.org/ 中找到。

所有实现必须支持 XMLConstants.FEATURE_SECURE_PROCESSING 功能。当功能为以下情况时：

  • true：该实现将限制 XML 处理遵守实现限制。示例包括实体扩展限制和将使用大量资源的 XML 模式构造。如果出于安全原因限制 XML 处理，将通过调用注册的 ErrorHandler.fatalError(SAXParseException exception) 进行报告。请参见处理程序规范的 SAXParser parse 方法。
  • 当该功能为 false 时，该实现将根据 XML 规范处理 XML，而无需考虑可能的实现限制。

参数：
name - 要设置的功能的名称。
value - 要设置的功能值。
抛出：
ParserConfigurationException - 如果无法创建满足所请求配置的解析器。
SAXNotRecognizedException - 当底层 XMLReader 不能识别属性名称时。
SAXNotSupportedException - 当底层 XMLReader 可以识别属性名称，但不支持该属性时。
NullPointerException - 如果 name 参数为 null。
另请参见：
XMLReader.setFeature(java.lang.String, boolean)

getFeature

public abstract boolean getFeature(String name)
                            throws ParserConfigurationException,
                                   SAXNotRecognizedException,
                                   SAXNotSupportedException

返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。

参数：
name - 要检索的属性的名称。
返回：
所请求属性的值。
抛出：
ParserConfigurationException - 如果无法创建满足所请求配置的解析器，将抛出该异常。
SAXNotRecognizedException - 当底层 XMLReader 不能识别属性名称时。
SAXNotSupportedException - 当底层 XMLReader 可以识别属性名称，但不支持该属性时。
另请参见：
XMLReader.getProperty(java.lang.String)

getSchema

public Schema getSchema()
获取通过 setSchema(Schema schema) 方法指定的 Schema 对象。

返回：
最后通过 setSchema(Schema) 方法设置的 Schema 对象，如果该方法由于创建了 SAXParserFactory 而没有被调用，则返回 null。
抛出：
UnsupportedOperationException - 当该实现没有重写此方法时
从以下版本开始：
1.5

setSchema

public void setSchema(Schema schema)

设置将由解析器使用的 Schema，该解析器从此工厂创建。

如果 Schema 为非 null，则在将信息向下传递到应用程序之前，解析器将使用从中创建的验证器来验证文档。

在验证器发现警告/错误/致命错误时，解析器必须处理它们，就好像这些错误是由解析器自己发现的一样。换句话说，如果设置了用户指定的 ErrorHandler，则它必须接收这些错误，否则，必须根据特定于实现的默认错误处理规则来处理它们。

验证器可以修改 SAX 事件流（例如，通过添加在文档中缺少的默认值），解析器负责确保应用程序将接收这些修改的事件流。

最初，null 被设置为 Schema。

即使 isValidating() 方法返回 false，此过程也将生效。

将 http://java.sun.com/xml/jaxp/properties/schemaSource 属性和/或 http://java.sun.com/xml/jaxp/properties/schemaLanguage 属性与非 null Schema 对象一起使用将发生错误。当在 SAXParser 上设置这些属性时，此类配置将导致 SAXException 异常。

实现者请注意：

解析器必须能够与任何 Schema 实现一起使用。但是，只要能够产生规范中描述的结果，就允许解析器和模式使用特定于实现的自定义机制。

参数：
schema - 要使用的 Schema，如果移除一个模式，则为 null。
抛出：
UnsupportedOperationException - 当该实现没有重写此方法时
从以下版本开始：
1.5

setXIncludeAware

public void setXIncludeAware(boolean state)

设置 XInclude 处理的状态。

如果在文档实例中发现 XInclude 标记，则应按 XML Inclusions (XInclude) Version 1.0 中指定的方式处理。

XInclude 处理默认为 false。

参数：
state - 将 XInclude 处理设置为 true 或 false
抛出：
UnsupportedOperationException - 当该实现没有重写此方法时
从以下版本开始：
1.5

isXIncludeAware

public boolean isXIncludeAware()

获取 XInclude 处理的状态。

返回：
XInclude 处理的当前状态
抛出：
UnsupportedOperationException - 当实现没有重写此方法时
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.parsers (Java Platform SE 6)

 javax.xml.parsers
类
DocumentBuilder
DocumentBuilderFactory
SAXParser
SAXParserFactory
异常
ParserConfigurationException
错误
FactoryConfigurationError


javax.xml.parsers (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.parsers

提供允许处理 XML 文档的类。

请参见：
描述

类摘要
DocumentBuilder | 定义 API， 使其从 XML 文档获取 DOM 文档实例。
DocumentBuilderFactory | 定义工厂 API，使应用程序能够从 XML 文档获取生成 DOM 对象树的解析器。
SAXParser | 定义包装 XMLReader 实现类的 API。
SAXParserFactory | 定义工厂 API，使应用程序能够配置和获取基于 SAX 的解析器以解析 XML 文档。

异常摘要
ParserConfigurationException 指示一个严重的配置错误。

错误摘要
FactoryConfigurationError 当解析器工厂的配置存在问题时抛出该异常。

软件包 javax.xml.parsers 的描述

提供允许处理 XML 文档的类。支持两种类型的可插入解析器：

  • SAX（用于 XML 的简单 API）
  • DOM（文档对象模型）

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.parsers 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.parsers 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.parsers.DocumentBuilder
    • javax.xml.parsers.DocumentBuilderFactory
    • javax.xml.parsers.SAXParser
    • javax.xml.parsers.SAXParserFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.parsers.FactoryConfigurationError
      • java.lang.Exception
        • javax.xml.parsers.ParserConfigurationException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.parsers 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.parsers
的使用

使用 javax.xml.parsers 的软件包
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.parsers | 提供允许处理 XML 文档的类。

javax.xml.bind.annotation 使用的 javax.xml.parsers 中的类
DocumentBuilder
定义 API， 使其从 XML 文档获取 DOM 文档实例。

javax.xml.parsers 使用的 javax.xml.parsers 中的类
DocumentBuilder
定义 API， 使其从 XML 文档获取 DOM 文档实例。
DocumentBuilderFactory
定义工厂 API，使应用程序能够从 XML 文档获取生成 DOM 对象树的解析器。
ParserConfigurationException
指示一个严重的配置错误。
SAXParser
定义包装 XMLReader 实现类的 API。
SAXParserFactory
定义工厂 API，使应用程序能够配置和获取基于 SAX 的解析器以解析 XML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.parsers.FactoryConfigurationError 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.FactoryConfigurationError
的使用

没有 javax.xml.parsers.FactoryConfigurationError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.parsers.SAXParser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.SAXParser
的使用

使用 SAXParser 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 SAXParser 的使用

返回 SAXParser 的 javax.xml.parsers 中的方法
abstract  SAXParser SAXParserFactory.newSAXParser()
使用当前配置的工厂参数创建 SAXParser 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.parsers.SAXParserFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.SAXParserFactory
的使用

使用 SAXParserFactory 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 SAXParserFactory 的使用

返回 SAXParserFactory 的 javax.xml.parsers 中的方法
static SAXParserFactory | SAXParserFactory.newInstance() 获取 SAXParserFactory 的一个新实例。
static SAXParserFactory | SAXParserFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 SAXParserFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.parsers.DocumentBuilder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.DocumentBuilder
的使用

使用 DocumentBuilder 的软件包
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.parsers | 提供允许处理 XML 文档的类。

javax.xml.bind.annotation 中 DocumentBuilder 的使用

返回 DocumentBuilder 的 javax.xml.bind.annotation 中的方法
 DocumentBuilder W3CDomHandler.getBuilder()

参数类型为 DocumentBuilder 的 javax.xml.bind.annotation 中的方法
 void W3CDomHandler.setBuilder(DocumentBuilder builder)

参数类型为 DocumentBuilder 的 javax.xml.bind.annotation 中的构造方法
W3CDomHandler(DocumentBuilder builder)
允许应用程序指定使用哪一个 DOM 实现的构造方法。

javax.xml.parsers 中 DocumentBuilder 的使用

返回 DocumentBuilder 的 javax.xml.parsers 中的方法
abstract  DocumentBuilder DocumentBuilderFactory.newDocumentBuilder()
使用当前配置的参数创建一个新的 DocumentBuilder 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.parsers.DocumentBuilderFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.DocumentBuilderFactory
的使用

使用 DocumentBuilderFactory 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 DocumentBuilderFactory 的使用

返回 DocumentBuilderFactory 的 javax.xml.parsers 中的方法
static DocumentBuilderFactory | DocumentBuilderFactory.newInstance() 获取 DocumentBuilderFactory 的新实例。
static DocumentBuilderFactory | DocumentBuilderFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DocumentBuilderFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.parsers.ParserConfigurationException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.parsers.ParserConfigurationException
的使用

使用 ParserConfigurationException 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 ParserConfigurationException 的使用

抛出 ParserConfigurationException 的 javax.xml.parsers 中的方法
abstract boolean | SAXParserFactory.getFeature(String name) 返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
abstract boolean | DocumentBuilderFactory.getFeature(String name) 获取指定功能的状态。
abstract DocumentBuilder | DocumentBuilderFactory.newDocumentBuilder() 使用当前配置的参数创建一个新的 DocumentBuilder 实例。
abstract SAXParser | SAXParserFactory.newSAXParser() 使用当前配置的工厂参数创建 SAXParser 的一个新实例。
abstract void | SAXParserFactory.setFeature(String name, boolean value) 在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
abstract void | DocumentBuilderFactory.setFeature(String name, boolean value) 设置由此工厂创建的此 DocumentBuilderFactory 和 DocumentBuilder 的功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Binder (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 Binder<XmlNode>

java.lang.Object
    继承者  javax.xml.bind.Binder<XmlNode>

public abstract class Binder<XmlNode>
extends Object

在 XML 信息集节点和表示相同 XML 文档的 JAXB 对象之间启用同步。

此类的实例维护了保留视图的信息集的 XML 节点与 XML 文档的 JAXB 表示形式之间的关联。两个视图之间的导航由方法 getXMLNode(Object) 和 getJAXBNode(Object) 提供。

可以在其他视图保持不变的情况下，对保留视图的信息集或文档的 JAXB 表示形式进行修改。Binder 能够使用适当的 Binder 更新方法（updateXML(Object, Object) 或 updateJAXB(Object)）将在修改视图中所做的更改同步到其他视图中。

下面是一个典型的使用场景：

  • 将 XML 文档加载为 XML 信息集表示形式
  • 将 unmarshal(Object) XML 信息集视图加载到 JAXB 视图。（注意保存资源，可以只将 XML 信息集视图的子树解组为 JAXB 视图。）
  • XML 文档的应用程序访问/更新 JAXB 视图。
  • updateXML(Object) 可将对 JAXB 视图的修改同步到 XML 信息集视图中。更新操作将尽可能多地保留原始 XML 信息集（如注释、PI 等等）

Binder 实例是使用工厂方法 JAXBContext.createBinder() 或 JAXBContext.createBinder(Class) 创建的。

模板参数 XmlNode 是保留表示形式的 XML 信息集的根接口/类。Binder 实现至少需要支持 org.w3c.dom.Node.class 的一个 XmlNode 值。Binder 实现可以支持保留表示形式的备用 XML 信息集。

从以下版本开始：
JAXB 2.0

构造方法摘要
Binder()
方法摘要
abstract  ValidationEventHandler getEventHandler()
当前的事件处理程序；如果没有设置，则返回默认事件处理程序。
abstract  Object getJAXBNode(XmlNode xmlNode)
获取与给定 XML 元素关联的 JAXB 对象。
abstract  Object getProperty(String name)
获取 Binder 的基础实现中的特定属性。
abstract  Schema getSchema()
获取 setSchema(Schema) 方法设置的最后一个 Schema 对象（包括 null）。
abstract  XmlNode getXMLNode(Object jaxbObject)
获取与给定 JAXB 对象关联的 XML 元素。
abstract  void marshal(Object jaxbObject, XmlNode xmlNode)
将 JAXB 对象树编组为新的 XML 文档。
abstract  void setEventHandler(ValidationEventHandler handler)
允许应用程序注册 ValidationEventHandler。
abstract  void setProperty(String name, Object value)
设置 Binder 的基础实现中的特定属性。
abstract  void setSchema(Schema schema)
指定 marshal、unmarshal 和 update 方法是否在其 XML 内容上执行验证。
abstract  Object unmarshal(XmlNode xmlNode)
将 XML 信息集视图解组为 JAXB 对象树。
abstract
<T> JAXBElement<T>
unmarshal(XmlNode xmlNode, Class<T> declaredType)
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
abstract  Object updateJAXB(XmlNode xmlNode)
取一个 XML 节点，并更新与其关联的 JAXB 对象和该对象的子级。
abstract  XmlNode updateXML(Object jaxbObject)
取一个 JAXB 对象，并更新与其关联的 XML 节点和该节点的子级。
abstract  XmlNode updateXML(Object jaxbObject, XmlNode xmlNode)
JAXB 对象树中所做的更改在与其关联的 XML 解析树中得到更新。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Binder

public Binder()
方法详细信息

unmarshal

public abstract Object unmarshal(XmlNode xmlNode)
                          throws JAXBException
将 XML 信息集视图解组为 JAXB 对象树。

此方法类似于添加了维持 XML 节点与生成的 JAXB 对象之间关联功能的 Unmarshaller.unmarshal(Node)，它还支持未来更新操作，如 updateXML(Object, Object) 或 updateJAXB(Object)。

当 getSchema() 为非 null 时，可以在执行此操作期间验证 xmlNode 及其子节点。

当 Binder 的 JAXBContext 不存在将 xmlNode 的 XML 元素名称或类型（通过 @xsi:type 指定）映射到 JAXB 映射类的映射关系时，此方法抛出 UnmarshalException。unmarshal(Object, Class) 方法使应用程序能够指定 xmlNode 应该映射到哪个 JAXB 映射类。

参数：
xmlNode - 要解组其中的 XML 数据的文档/元素。
返回：
JAXB 对象树的新创建的根对象。
抛出：
JAXBException - 如果进行解组期间发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Binder 不能执行 XML 到 Java 的绑定。
IllegalArgumentException - 如果节点参数为 null

unmarshal

public abstract <T> JAXBElement<T> unmarshal(XmlNode xmlNode,
                                             Class<T> declaredType)
                                  throws JAXBException
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。

通过声明的类型实现解组

此方法类似于添加了维持 XML 节点与生成的 JAXB 对象之间关联功能的 Unmarshaller.unmarshal(Node, Class)，它还支持未来更新操作，如 updateXML(Object, Object) 或 updateJAXB(Object)。

当 getSchema() 为非 null 时，可以在执行此操作期间验证 xmlNode 及其子节点。

参数：
xmlNode - 要解组其中的 XML 数据的文档/元素。
declaredType - 用来保存 node 的 XML 数据的适当 JAXB 映射类。
返回：
node 的 JAXB 元素表示形式
抛出：
JAXBException - 如果进行解组期间发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Binder 不能执行 XML 到 Java 的绑定。
IllegalArgumentException - 如果任何输入参数为 null
从以下版本开始：
JAXB2.0

marshal

public abstract void marshal(Object jaxbObject,
                             XmlNode xmlNode)
                      throws JAXBException
将 JAXB 对象树编组为新的 XML 文档。

此方法类似于添加了维持 JAXB 对象和产生的 XML 节点之间关联功能的 Marshaller.marshal(Object, Node)，它还支持未来更新操作，如 updateXML(Object, Object) 或 updateJAXB(Object)。

当 getSchema() 为非 null 时，可在执行此操作期间验证已编组的 xml 内容。

参数：
jaxbObject - 将被编组的内容树。
xmlNode - 该参数必须是一个接受子节点的节点。
抛出：
JAXBException - 如果进行解组期间发生不可预料的错误。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Binder 不能编组 jaxbObject（或任何可从 jaxbObject 获得的对象）。
IllegalArgumentException - 如果任何方法的参数为 null

getXMLNode

public abstract XmlNode getXMLNode(Object jaxbObject)
获取与给定 JAXB 对象关联的 XML 元素。

一旦 JAXB 对象树与 XML 片段关联，此方法将在两树之间启用导航。

XML 元素与 JAXB 对象之间的关联是通过 bind 方法和 update 方法建立的。注意，此关联是片面的；并不是所有 XML 元素都有关联的 JAXB 对象，也不是所有 JAXB 对象都有关联的 XML 元素。

参数：
jaxbObject - 可从以前对返回 JAXB 对象树的 bind 或 update 方法的调用中获得的实例。
返回：
如果指定的 JAXB 对象对于此 Binder 为未知对象，或者该对象与 XML 元素没有任何关联，则返回 null。
抛出：
IllegalArgumentException - 如果 jaxbObject 参数为 null

getJAXBNode

public abstract Object getJAXBNode(XmlNode xmlNode)
获取与给定 XML 元素关联的 JAXB 对象。

一旦 JAXB 对象树与 XML 片段关联，此方法将在两树之间启用导航。

XML 元素和 JAXB 对象之间的关联是通过 unmarshal、marshal 和 update 方法建立的。注意，此关联是片面的；并不是所有 XML 元素都有关联的 JAXB 对象，也不是所有 JAXB 对象都有关联的 XML 元素。

返回：
如果 XML 节点对于此 Binder 为未知节点，或者该节点与 JAXB 对象没有任何关联，则返回 null。
抛出：
IllegalArgumentException - 如果节点参数为 null

updateXML

public abstract XmlNode updateXML(Object jaxbObject)
                           throws JAXBException
取一个 JAXB 对象，并更新与其关联的 XML 节点和该节点的子级。

这是如下调用的一种便捷方法：

updateXML( jaxbObject, getXMLNode(jaxbObject));

抛出：
JAXBException - 如果更新相应的 XML 内容时出现任何不可预料的问题。
IllegalArgumentException - 如果 jaxbObject 参数为 null

updateXML

public abstract XmlNode updateXML(Object jaxbObject,
                                  XmlNode xmlNode)
                           throws JAXBException
JAXB 对象树中所做的更改在与其关联的 XML 解析树中得到更新。

可将此操作视为“原地（in-place）”编组。不同点在于，此操作不是创建一个全新的 XML 树，而是在试图尽可能多地保留 XML 的同时更新现有的树。

例如，没有绑定到 JAXB 的 XML 中的未知元素/属性将保持不变（而编组操作将创建一个不包含任何元素/属性的新树。）

另一方面，此操作会更新 XML 节点与 JAXB 对象之间的关联。

参数：
jaxbObject - 可能已修改的 JAXB 对象树的根
xmlNode - 更新目标 XML 解析树的根
返回：
返回已更新的 XML 节点。通常，此节点是作为 xmlNode 传入的同一节点，但可能是不同的对象，例如在对象的标记名称发生更改时。
抛出：
JAXBException - 如果更新相应 XML 内容时出现任何不可预料的问题。
IllegalArgumentException - 如何任何输入参数为 null

updateJAXB

public abstract Object updateJAXB(XmlNode xmlNode)
                           throws JAXBException
取一个 XML 节点，并更新与其关联的 JAXB 对象和该对象的子级。

可将此操作视为“原地”解组。不同点在于，此操作不是创建一个全新 JAXB 树，而是更新现有的树，尽可能多地重用 JAXB 对象。

另一方面，此操作会更新 XML 节点与 JAXB 对象之间的关联。

返回：
返回已更新的 JAXB 对象。通常，此对象是从较早的 marshal(Object,Object) 或 updateJAXB(Object) 方法调用中返回的同一对象，但可以是不同的对象，例如在 XML 元素的名称发生更改时。
抛出：
JAXBException - 如果更新相应的 JAXB 映射内容时出现任何不可预料的问题。
IllegalArgumentException - 如果节点参数为 null

setSchema

public abstract void setSchema(Schema schema)
指定 marshal、unmarshal 和 update 方法是否在其 XML 内容上执行验证。

参数：
schema - 可将此参数设置为 null 来禁用验证。
另请参见：
Unmarshaller.setSchema(Schema)

getSchema

public abstract Schema getSchema()
获取 setSchema(Schema) 方法设置的最后一个 Schema 对象（包括 null）。

返回：
用于验证的 Schema 对象，如果不存在这样的对象，则返回 null

setEventHandler

public abstract void setEventHandler(ValidationEventHandler handler)
                              throws JAXBException
允许应用程序注册 ValidationEventHandler。

如果在调用任何 Binder 的 unmarshal、marshal 和 update 方法期间遇到验证错误，JAXB 提供者将调用 ValidationEventHandler。

调用带有 null 参数的此方法将导致 Binder 转而调用默认事件处理程序。

参数：
handler - 验证事件处理程序
抛出：
JAXBException - 如果在设置事件处理程序时发生错误

getEventHandler

public abstract ValidationEventHandler getEventHandler()
                                                throws JAXBException
当前的事件处理程序；如果没有设置，则返回默认事件处理程序。

返回：
当前的 ValidationEventHandler；如果没有设置，则返回默认的事件处理程序
抛出：
JAXBException - 如果获取当前的事件处理程序时发生错误

setProperty

public abstract void setProperty(String name,
                                 Object value)
                          throws PropertyException
设置 Binder 的基础实现中的特定属性。此方法只用于设置某个标准 JAXB 定义的 unmarshal/marshal 属性或者特定于提供者的 binder、unmarshal 或 marshal 属性。试图设置未定义的属性将导致抛出 PropertyException。请参阅受支持的 Unmarshal 属性和受支持的 Marshal 属性。

参数：
name - 要设置的属性的名称。此值可以使用一个常量字段来指定，也可以是一个用户提供的字符串。
value - 要设置的属性值
抛出：
PropertyException - 如果处理给定属性或值时发生错误
IllegalArgumentException - 如果 name 参数为 null

getProperty

public abstract Object getProperty(String name)
                            throws PropertyException
获取 Binder 的基础实现中的特定属性。此方法只用于获取某个标准 JAXB 定义的 unmarshal/marshal 属性或者特定于提供者的 binder、unmarshal 或 marshal 属性。试图获取未定义的属性将导致抛出 PropertyException。请参阅受支持的 Unmarshal 属性和受支持的 Marshal 属性。

参数：
name - 将检索的属性名称
返回：
所请求属性的值
抛出：
PropertyException - 如果检索给定属性或值属性名称时发生错误
IllegalArgumentException - 如果 name 参数为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DatatypeConverter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 DatatypeConverter

java.lang.Object
    继承者  javax.xml.bind.DatatypeConverter

public final class DatatypeConverter
extends Object

可以使用 javaType 绑定声明来自定义 XML 模式数据类型到 Java 数据类型的绑定。自定义可能涉及编写分别用来解析和打印 XML 模式数据类型的词汇表示形式的 parse 和 print 方法。不过，编写 parse 和 print 方法需要了解词汇表示形式（ XML Schema Part2: Datatypes 规范），因此可能很难编写。

此类使编写 parse 和 print 方法变得更容易。它定义了静态 parse 和 print 方法，以便访问 JAXB 提供者的 parse 和 print 方法的实现。这些方法由自定义 parse 和 print 方法调用。例如，可以使用如下 parse 和 print 方法来自定义 xsd:dateTime 到 long 值的绑定：

// Customized parse method
public long myParseCal( String dateTimeString ) {
java.util.Calendar cal = DatatypeConverter.parseDateTime(dateTimeString);
long longval = convert_calendar_to_long(cal); //application specific
return longval;
    }

// Customized print method
public String myPrintCal( Long longval ) {
java.util.Calendar cal = convert_long_to_calendar(longval) ; //application specific
String dateTimeString = DatatypeConverter.printDateTime(cal);
return dateTimeString;
    }

在 DatatypeConverterInterface 中有分别对应于每个 parse 和 print 方法的静态 parse 和 print 方法。

在该类中定义的静态方法还可以用于指定 javaType 绑定声明中的 parse 和 print 方法。

JAXB 提供者需要在第一次执行编组或解组操作之前（可能是在调用 JAXBContext.newInstance 期间）的某个时间点调用 setDatatypeConverter API。要配置用于执行打印和解析功能的转换器，这一步是必需的。

XML 模式数据类型的 print 方法可以输出对于 XML 模式数据类型有效的任何词汇表示形式。如果在转换期间发生错误，则该方法将抛出 IllegalArgumentException，或者抛出 IllegalArgumentException 的子类。

从以下版本开始：
JAXB1.0
另请参见：
DatatypeConverterInterface, ParseConversionEvent, PrintConversionEvent

方法摘要
static String | parseAnySimpleType(String lexicalXSDAnySimpleType) 返回包含简单类型的词汇表示形式的字符串。
static byte[] | parseBase64Binary(String lexicalXSDBase64Binary) 将字符串参数转换为一个字节数组。
static boolean | parseBoolean(String lexicalXSDBoolean) 将字符串参数转换为一个 boolean 值。
static byte | parseByte(String lexicalXSDByte) 将字符串参数转换为一个 byte 值。
static Calendar | parseDate(String lexicalXSDDate) 将字符串参数转换为一个 Calendar 值。
static Calendar | parseDateTime(String lexicalXSDDateTime) 将字符串参数转换为一个 Calendar 值。
static BigDecimal | parseDecimal(String lexicalXSDDecimal) 将字符串参数转换为一个 BigDecimal 值。
static double | parseDouble(String lexicalXSDDouble) 将字符串参数转换为一个 double 值。
static float | parseFloat(String lexicalXSDFloat) 将字符串参数转换为一个 float 值。
static byte[] | parseHexBinary(String lexicalXSDHexBinary) 将字符串参数转换为一个字节数组。
static int | parseInt(String lexicalXSDInt) 将字符串参数转换为一个 int 值。
static BigInteger | parseInteger(String lexicalXSDInteger) 将字符串参数转换为一个 BigInteger 值。
static long | parseLong(String lexicalXSDLong) 将字符串参数转换为一个 long 值。
static QName | parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 byte 值。
static short | parseShort(String lexicalXSDShort) 将字符串参数转换为一个 short 值。
static String | parseString(String lexicalXSDString) 将词汇 XSD 字符串参数转换为一个 String 值。
static Calendar | parseTime(String lexicalXSDTime) 将字符串参数转换为一个 Calendar 值。
static long | parseUnsignedInt(String lexicalXSDUnsignedInt) 将字符串参数转换为一个 long 值。
static int | parseUnsignedShort(String lexicalXSDUnsignedShort) 将字符串参数转换为一个 int 值。
static String | printAnySimpleType(String val) 将字符串值转换为一个字符串。
static String | printBase64Binary(byte[] val) 将字节数组转换为一个字符串。
static String | printBoolean(boolean val) 将 boolean 值转换为一个字符串。
static String | printByte(byte val) 将 byte 值转换为一个字符串。
static String | printDate(Calendar val) 将 Calendar 值转换为一个字符串。
static String | printDateTime(Calendar val) 将 Calendar 值转换为一个字符串。
static String | printDecimal(BigDecimal val) 将 BigDecimal 值转换为一个字符串。
static String | printDouble(double val) 将 double 值转换为一个字符串。
static String | printFloat(float val) 将 float 值转换为一个字符串。
static String | printHexBinary(byte[] val) 将字节数组转换为一个字符串。
static String | printInt(int val) 将 int 值转换为一个字符串。
static String | printInteger(BigInteger val) 将 BigInteger 值转换为一个字符串。
static String | printLong(long val) 将 long 值转换为一个字符串。
static String | printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。
static String | printShort(short val) 将 short 值转换为一个字符串。
static String | printString(String val) 将字符串参数转换为一个字符串。
static String | printTime(Calendar val) 将 Calendar 值转换为一个字符串。
static String | printUnsignedInt(long val) 将 long 值转换为一个字符串。
static String | printUnsignedShort(int val) 将 int 值转换为一个字符串。
static void | setDatatypeConverter(DatatypeConverterInterface converter) 此方法仅适用于 JAXB 提供者。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

setDatatypeConverter

public static void setDatatypeConverter(DatatypeConverterInterface converter)
此方法仅适用于 JAXB 提供者。

JAXB 提供者需要在允许执行任何 JAXB 客户端编组或解组操作之前的某个时间点调用此方法。要配置用于执行打印和解析功能的转换器，这一步是必需的。

重复调用此 API 是无效的，传入第一次调用中的 DatatypeConverterInterface 实例将始终用于后续调用。

参数：
converter - 实现 DatatypeConverterInterface 类的类实例，此参数不能为 null。
抛出：
IllegalArgumentException - 如果参数为 null

parseString

public static String parseString(String lexicalXSDString)

将词汇 XSD 字符串参数转换为一个 String 值。

参数：
lexicalXSDString - 包含 xsd:string 的词汇表示形式的字符串。
返回：
字符串参数表示的 String 值。

parseInteger

public static BigInteger parseInteger(String lexicalXSDInteger)

将字符串参数转换为一个 BigInteger 值。

参数：
lexicalXSDInteger - 包含 xsd:integer 的词汇表示形式的字符串。
返回：
字符串参数表示的 BigInteger 值。
抛出：
NumberFormatException - 如果 lexicalXSDInteger 不是 BigInteger 值的有效字符串表示形式。

parseInt

public static int parseInt(String lexicalXSDInt)

将字符串参数转换为一个 int 值。

参数：
lexicalXSDInt - 包含 xsd:int 的词汇表示形式的字符串。
返回：
字符串参数表示的 int 值。
抛出：
NumberFormatException - 如果 lexicalXSDInt 不是 int 值的有效字符串表示形式。

parseLong

public static long parseLong(String lexicalXSDLong)

将字符串参数转换为一个 long 值。

参数：
lexicalXSDLong - 包含 xsd:long 的词汇表示形式的字符串。
返回：
字符串参数表示的 long 值。
抛出：
NumberFormatException - 如果 lexicalXSDLong 不是 long 值的有效字符串表示形式。

parseShort

public static short parseShort(String lexicalXSDShort)

将字符串参数转换为一个 short 值。

参数：
lexicalXSDShort - 包含 xsd:short 的词汇表示形式的字符串。
返回：
字符串参数表示的 short 值。
抛出：
NumberFormatException - 如果 lexicalXSDShort 不是 short 值的有效字符串表示形式。

parseDecimal

public static BigDecimal parseDecimal(String lexicalXSDDecimal)

将字符串参数转换为一个 BigDecimal 值。

参数：
lexicalXSDDecimal - 包含 xsd:decimal 的词汇表示形式的字符串。
返回：
字符串参数表示的 BigDecimal 值。
抛出：
NumberFormatException - 如果 lexicalXSDDecimal 不是 BigDecimal 的有效字符串表示形式。

parseFloat

public static float parseFloat(String lexicalXSDFloat)

将字符串参数转换为一个 float 值。

参数：
lexicalXSDFloat - 包含 xsd:float 的词汇表示形式的字符串。
返回：
字符串参数表示的 float 值。
抛出：
NumberFormatException - 如果 lexicalXSDFloat 不是 float 值的有效字符串表示形式。

parseDouble

public static double parseDouble(String lexicalXSDDouble)

将字符串参数转换为一个 double 值。

参数：
lexicalXSDDouble - 包含 xsd:double 的词汇表示形式的字符串。
返回：
字符串参数表示的 double 值。
抛出：
NumberFormatException - 如果 lexicalXSDDouble 不是 double 值的有效字符串表示形式。

parseBoolean

public static boolean parseBoolean(String lexicalXSDBoolean)

将字符串参数转换为一个 boolean 值。

参数：
lexicalXSDBoolean - 包含 xsd:boolean 的词汇表示形式的字符串。
返回：
字符串参数表示的 boolean 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes 中为 xsd:boolean 定义的词汇值空间。

parseByte

public static byte parseByte(String lexicalXSDByte)

将字符串参数转换为一个 byte 值。

参数：
lexicalXSDByte - 包含 xsd:byte 的词汇表示形式的字符串。
返回：
字符串参数表示的 byte 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes 为 xsd:byte 定义的词汇值空间。

parseQName

public static QName parseQName(String lexicalXSDQName,
                               NamespaceContext nsc)

将字符串参数转换为一个 byte 值。

字符串参数 lexicalXSDQname 必须符合 XML Schema Part 2: Datatypes 规范：QName 中指定的词汇值空间。

参数：
lexicalXSDQName - 包含 xsd:QName 的词汇表示形式的字符串。
nsc - 解释 QName 中前缀的名称空间上下文。
返回：
字符串参数表示的 QName 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2 规范，或者 lexicalXSDQname 的名称空间前缀未绑定到 NamespaceContext nsc 中的 URI。

parseDateTime

public static Calendar parseDateTime(String lexicalXSDDateTime)

将字符串参数转换为一个 Calendar 值。

参数：
lexicalXSDDateTime - 包含 xsd:datetime 的词汇表示形式的字符串。
返回：
字符串参数表示的 Calendar 对象。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes 为 xsd:dateTime 定义的词汇值空间。

parseBase64Binary

public static byte[] parseBase64Binary(String lexicalXSDBase64Binary)

将字符串参数转换为一个字节数组。

参数：
lexicalXSDBase64Binary - 包含 xsd:base64Binary 的词汇表示形式的字符串。
返回：
字符串参数表示的字节数组。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes 为 xsd:base64Binary 定义的词汇值空间。

parseHexBinary

public static byte[] parseHexBinary(String lexicalXSDHexBinary)

将字符串参数转换为一个字节数组。

参数：
lexicalXSDHexBinary - 包含 xsd:hexBinary 的词汇表示形式的字符串。
返回：
字符串参数表示的字节数组。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes 为 xsd:hexBinary 定义的词汇值空间。

parseUnsignedInt

public static long parseUnsignedInt(String lexicalXSDUnsignedInt)

将字符串参数转换为一个 long 值。

参数：
lexicalXSDUnsignedInt - 包含 xsd:unsignedInt 的词汇表示形式的字符串。
返回：
字符串参数表示的 long 值。
抛出：
NumberFormatException - 如果不能将字符串参数解析为 long 值。

parseUnsignedShort

public static int parseUnsignedShort(String lexicalXSDUnsignedShort)

将字符串参数转换为一个 int 值。

参数：
lexicalXSDUnsignedShort - 包含 xsd:unsignedShort 的词汇表示形式的字符串。
返回：
字符串参数表示的 int 值。
抛出：
NumberFormatException - 如果不能将字符串参数解析为 int 值。

parseTime

public static Calendar parseTime(String lexicalXSDTime)

将字符串参数转换为一个 Calendar 值。

参数：
lexicalXSDTime - 包含 xsd:time 的词汇表示形式的字符串。
返回：
字符串参数表示的 Calendar 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes 为 xsd:Time 定义的词汇值空间。

parseDate

public static Calendar parseDate(String lexicalXSDDate)

将字符串参数转换为一个 Calendar 值。

参数：
lexicalXSDDate - 包含 xsd:Date 的词汇表示形式的字符串。
返回：
字符串参数表示的 Calendar 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes 为 xsd:Date 定义的词汇值空间。

parseAnySimpleType

public static String parseAnySimpleType(String lexicalXSDAnySimpleType)

返回包含简单类型的词汇表示形式的字符串。

参数：
lexicalXSDAnySimpleType - 包含简单类型的词汇表示形式的字符串。
返回：
包含简单类型的词汇表示形式的字符串。

printString

public static String printString(String val)

将字符串参数转换为一个字符串。

参数：
val - 字符串值。
返回：
包含 xsd:string 的词汇表示形式的字符串。

printInteger

public static String printInteger(BigInteger val)

将 BigInteger 值转换为一个字符串。

参数：
val - 一个 BigInteger 值
返回：
包含 xsd:integer 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printInt

public static String printInt(int val)

将 int 值转换为一个字符串。

参数：
val - 一个 int 值
返回：
包含 xsd:int 的词汇表示形式的字符串

printLong

public static String printLong(long val)

将 long 值转换为一个字符串。

参数：
val - 一个 long 值
返回：
包含 xsd:long 的词汇表示形式的字符串

printShort

public static String printShort(short val)

将 short 值转换为一个字符串。

参数：
val - 一个 short 值
返回：
包含 xsd:short 的词汇表示形式的字符串

printDecimal

public static String printDecimal(BigDecimal val)

将 BigDecimal 值转换为一个字符串。

参数：
val - 一个 BigDecimal 值
返回：
包含 xsd:decimal 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printFloat

public static String printFloat(float val)

将 float 值转换为一个字符串。

参数：
val - 一个 float 值
返回：
包含 xsd:float 的词汇表示形式的字符串

printDouble

public static String printDouble(double val)

将 double 值转换为一个字符串。

参数：
val - 一个 double 值
返回：
包含 xsd:double 的词汇表示形式的字符串

printBoolean

public static String printBoolean(boolean val)

将 boolean 值转换为一个字符串。

参数：
val - 一个 boolean 值
返回：
包含 xsd:boolean 的词汇表示形式的字符串

printByte

public static String printByte(byte val)

将 byte 值转换为一个字符串。

参数：
val - 一个 byte 值
返回：
包含 xsd:byte 的词汇表示形式的字符串

printQName

public static String printQName(QName val,
                                NamespaceContext nsc)

将 QName 实例转换为一个字符串。

参数：
val - 一个 QName 值
nsc - 解释 QName 中前缀的名称空间上下文。
返回：
包含 QName 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null、nsc 为非 null 或 nsc.getPrefix(nsprefixFromVal) 为 null。

printDateTime

public static String printDateTime(Calendar val)

将 Calendar 值转换为一个字符串。

参数：
val - 一个 Calendar 值
返回：
包含 xsd:dateTime 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printBase64Binary

public static String printBase64Binary(byte[] val)

将字节数组转换为一个字符串。

参数：
val - 一个字节数组
返回：
包含 xsd:base64Binary 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printHexBinary

public static String printHexBinary(byte[] val)

将字节数组转换为一个字符串。

参数：
val - 一个字节数组
返回：
包含 xsd:hexBinary 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printUnsignedInt

public static String printUnsignedInt(long val)

将 long 值转换为一个字符串。

参数：
val - 一个 long 值
返回：
包含 xsd:unsignedInt 的词汇表示形式的字符串

printUnsignedShort

public static String printUnsignedShort(int val)

将 int 值转换为一个字符串。

参数：
val - 一个 int 值
返回：
包含 xsd:unsignedShort 的词汇表示形式的字符串

printTime

public static String printTime(Calendar val)

将 Calendar 值转换为一个字符串。

参数：
val - 一个 Calendar 值
返回：
包含 xsd:time 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printDate

public static String printDate(Calendar val)

将 Calendar 值转换为一个字符串。

参数：
val - 一个 Calendar 值
返回：
包含 xsd:date 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printAnySimpleType

public static String printAnySimpleType(String val)

将字符串值转换为一个字符串。

参数：
val - 字符串值
返回：
包含 xsd:AnySimpleType 的词汇表示形式的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatatypeConverterInterface (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 DatatypeConverterInterface

public interface DatatypeConverterInterface

该 DatatypeConverterInterface 仅适用于 JAXB 提供者。JAXB 提供者必须提供一个实现此接口的类。JAXB 提供者需要在第一次执行编组或解组操作之前（可能在调用 JAXBContext.newInstance 期间）的某个时间点调用 DatatypeConverter.setDatatypeConverter。要配置用于执行打印和解析功能的转换器，这一步是必需的。重复调用此 api 是无效的，传入第一个调用中的 DatatypeConverter 实例将是将从那时起有效的实例。

此接口定义了一些 parse 和 print 方法。在 JAXB 规范的默认绑定 Table 5-1 中指定的每个 XML 模式数据类型都有一个 parse 和 print 方法。

此处定义的 parse 和 print 方法由 DatatypeConverter 类中定义的静态 parse 和 print 方法调用。

XML 模式数据类型的 parse 方法必须能够将 XML 模式数据类型的任何词汇表示形式（由 XML Schema Part 2: Datatypes specification 指定）转换为 XML 模式数据类型的值空间中的值。如果在转换期间发生错误，则该方法将抛出 IllegalArgumentException，或者抛出 IllegalArgumentException 的子类。

XML 模式数据类型的 print 方法可以输出对于 XML 模式数据类型有效的任何词汇表示形式。如果在转换期间发生错误，则该方法将抛出 IllegalArgumentException，或者抛出 IllegalArgumentException 的子类。

前缀 xsd：用于引用 XML 模式数据类型 XML Schema Part 2: Datatypes specification。

从以下版本开始：
JAXB1.0
另请参见：
DatatypeConverter, ParseConversionEvent, PrintConversionEvent

方法摘要
String | parseAnySimpleType(String lexicalXSDAnySimpleType) 返回包含简单类型的词汇表示形式的字符串。
byte[] | parseBase64Binary(String lexicalXSDBase64Binary) 将字符串参数转换为一个字节数组。
boolean | parseBoolean(String lexicalXSDBoolean) 将字符串参数转换为一个 boolean 值。
byte | parseByte(String lexicalXSDByte) 将字符串参数转换为一个 byte 值。
Calendar | parseDate(String lexicalXSDDate) 将字符串参数转换为一个 Calendar 值。
Calendar | parseDateTime(String lexicalXSDDateTime) 将字符串参数转换为一个 Calendar 值。
BigDecimal | parseDecimal(String lexicalXSDDecimal) 将字符串参数转换为一个 BigDecimal 值。
double | parseDouble(String lexicalXSDDouble) 将字符串参数转换为一个 double 值。
float | parseFloat(String lexicalXSDFloat) 将字符串参数转换为一个 float 值。
byte[] | parseHexBinary(String lexicalXSDHexBinary) 将字符串参数转换为一个字节数组。
int | parseInt(String lexicalXSDInt) 将字符串参数转换为一个 int 值。
BigInteger | parseInteger(String lexicalXSDInteger) 将字符串参数转换为一个 BigInteger 值。
long | parseLong(String lexicalXSDLong) 将字符串参数转换为一个 long 值。
QName | parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 QName 值。
short | parseShort(String lexicalXSDShort) 将字符串参数转换为一个 short 值。
String | parseString(String lexicalXSDString) 将字符串参数转换为一个字符串。
Calendar | parseTime(String lexicalXSDTime) 将字符串参数转换为一个 Calendar 值。
long | parseUnsignedInt(String lexicalXSDUnsignedInt) 将字符串参数转换为一个 long 值。
int | parseUnsignedShort(String lexicalXSDUnsignedShort) 将字符串参数转换为一个 int 值。
String | printAnySimpleType(String val) 将字符串值转换为一个字符串。
String | printBase64Binary(byte[] val) 将字节数组转换为一个字符串。
String | printBoolean(boolean val) 将 boolean 值转换为一个字符串。
String | printByte(byte val) 将 byte 值转换为一个字符串。
String | printDate(Calendar val) 将 Calendar 值转换为一个字符串。
String | printDateTime(Calendar val) 将 Calendar 值转换为一个字符串。
String | printDecimal(BigDecimal val) 将 BigDecimal 值转换为一个字符串。
String | printDouble(double val) 将 double 值转换为一个字符串。
String | printFloat(float val) 将 float 值转换为一个字符串。
String | printHexBinary(byte[] val) 将字节数组转换为一个字符串。
String | printInt(int val) 将 int 值转换为一个字符串。
String | printInteger(BigInteger val) 将 BigInteger 值转换为一个字符串。
String | printLong(long val) 将 long 值转换为一个字符串。
String | printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。
String | printShort(short val) 将 short 值转换为一个字符串。
String | printString(String val) 将字符串参数转换为一个字符串。
String | printTime(Calendar val) 将 Calendar 值转换为一个字符串。
String | printUnsignedInt(long val) 将 long 值转换为一个字符串。
String | printUnsignedShort(int val) 将 int 值转换为一个字符串。

方法详细信息

parseString

String parseString(String lexicalXSDString)

将字符串参数转换为一个字符串。

参数：
lexicalXSDString - XML 模式数据类型 xsd:string 的词汇表示形式
返回：
与输入字符串相同的字符串。

parseInteger

BigInteger parseInteger(String lexicalXSDInteger)

将字符串参数转换为一个 BigInteger 值。

参数：
lexicalXSDInteger - 包含 xsd:integer 的词汇表示形式的字符串。
返回：
字符串参数表示的 BigInteger 值。
抛出：
NumberFormatException - 如果 lexicalXSDInteger 不是 BigInteger 值的有效字符串表示形式。

parseInt

int parseInt(String lexicalXSDInt)

将字符串参数转换为一个 int 值。

参数：
lexicalXSDInt - 包含 xsd:int 的词汇表示形式的字符串。
返回：
字符串参数表示的 int 值。
抛出：
NumberFormatException - 如果 lexicalXSDInt 不是 int 值的有效字符串表示形式。

parseLong

long parseLong(String lexicalXSDLong)

将字符串参数转换为一个 long 值。

参数：
lexicalXSDLong - 包含 xsd:long 的词汇表示形式的字符串。
返回：
字符串参数表示的 long 值。
抛出：
NumberFormatException - 如果 lexicalXSDLong 不是 long 值的有效字符串表示形式。

parseShort

short parseShort(String lexicalXSDShort)

将字符串参数转换为一个 short 值。

参数：
lexicalXSDShort - 包含 xsd:short 的词汇表示形式的字符串。
返回：
字符串参数表示的 short 值。
抛出：
NumberFormatException - 如果 lexicalXSDShort 不是 short 值的有效字符串表示形式。

parseDecimal

BigDecimal parseDecimal(String lexicalXSDDecimal)

将字符串参数转换为一个 BigDecimal 值。

参数：
lexicalXSDDecimal - 包含 xsd:decimal 的词汇表示形式的字符串。
返回：
字符串参数表示的 BigDecimal 值。
抛出：
NumberFormatException - 如果 lexicalXSDDecimal 不是 BigDecimal 的有效字符串表示形式。

parseFloat

float parseFloat(String lexicalXSDFloat)

将字符串参数转换为一个 float 值。

参数：
lexicalXSDFloat - 包含 xsd:float 的词汇表示形式的字符串。
返回：
字符串参数表示的 float 值。
抛出：
NumberFormatException - 如果 lexicalXSDFloat 不是 float 值的有效字符串表示形式。

parseDouble

double parseDouble(String lexicalXSDDouble)

将字符串参数转换为一个 double 值。

参数：
lexicalXSDDouble - 包含 xsd:double 的词汇表示形式的字符串。
返回：
字符串参数表示的 double 值。
抛出：
NumberFormatException - 如果 lexicalXSDDouble 不是 double 值的有效字符串表示形式。

parseBoolean

boolean parseBoolean(String lexicalXSDBoolean)

将字符串参数转换为一个 boolean 值。

参数：
lexicalXSDBoolean - 包含 xsd:boolean 的词汇表示形式的字符串。
返回：
字符串参数表示的 boolean 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes for xsd:boolean 中定义的词汇值空间。

parseByte

byte parseByte(String lexicalXSDByte)

将字符串参数转换为一个 byte 值。

参数：
lexicalXSDByte - 包含 xsd:byte 的词汇表示形式的字符串。
返回：
字符串参数表示的 byte 值。
抛出：
NumberFormatException - 如果 lexicalXSDByte 不包含可解析的字节。
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes for xsd:byte 中定义的词汇值空间。

parseQName

QName parseQName(String lexicalXSDQName,
                 NamespaceContext nsc)

将字符串参数转换为一个 QName 值。

字符串参数 lexicalXSDQname 必须符合 XML Schema Part 2: Datatypes specification:QNames 中指定的词汇值空间。

参数：
lexicalXSDQName - 包含 xsd:QName 的词汇表示形式的字符串。
nsc - 解释 QName 中前缀的名称空间上下文。
返回：
字符串参数表示的 QName 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2 规范，或者 lexicalXSDQname 的名称空间前缀未绑定到 NamespaceContext nsc 中的 URI。

parseDateTime

Calendar parseDateTime(String lexicalXSDDateTime)

将字符串参数转换为一个 Calendar 值。

参数：
lexicalXSDDateTime - 包含 xsd:datetime 的词汇表示形式的字符串。
返回：
字符串参数表示的 Calendar 对象。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes for xsd:dateTime 中定义的词汇值空间。

parseBase64Binary

byte[] parseBase64Binary(String lexicalXSDBase64Binary)

将字符串参数转换为一个字节数组。

参数：
lexicalXSDBase64Binary - 包含 xsd:base64Binary 的词汇表示形式的字符串。
返回：
字符串参数表示的字节数组。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes for xsd:base64Binary 中定义的词汇值空间。

parseHexBinary

byte[] parseHexBinary(String lexicalXSDHexBinary)

将字符串参数转换为一个字节数组。

参数：
lexicalXSDHexBinary - 包含 xsd:hexBinary 的词汇表示形式的字符串。
返回：
字符串参数表示的字节数组。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes for xsd:hexBinary 中定义的词汇值空间。

parseUnsignedInt

long parseUnsignedInt(String lexicalXSDUnsignedInt)

将字符串参数转换为一个 long 值。

参数：
lexicalXSDUnsignedInt - 包含 xsd:unsignedInt 的词汇表示形式的字符串。
返回：
字符串参数表示的 long 值。
抛出：
NumberFormatException - 如果不能将字符串参数解析为 long 值。

parseUnsignedShort

int parseUnsignedShort(String lexicalXSDUnsignedShort)

将字符串参数转换为一个 int 值。

参数：
lexicalXSDUnsignedShort - 包含 xsd:unsignedShort 的词汇表示形式的字符串。
返回：
字符串参数表示的 int 值。
抛出：
NumberFormatException - 如果不能将字符串参数解析为 int 值。

parseTime

Calendar parseTime(String lexicalXSDTime)

将字符串参数转换为一个 Calendar 值。

参数：
lexicalXSDTime - 包含 xsd:Time 的词汇表示形式的字符串。
返回：
字符串参数表示的 Calendar 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes for xsd:Time 中定义的词汇值空间。

parseDate

Calendar parseDate(String lexicalXSDDate)

将字符串参数转换为一个 Calendar 值。

参数：
lexicalXSDDate - 包含 xsd:Date 的词汇表示形式的字符串。
返回：
字符串参数表示的 Calendar 值。
抛出：
IllegalArgumentException - 如果字符串参数不符合 XML Schema Part 2: Datatypes for xsd:Time 中定义的词汇值空间。

parseAnySimpleType

String parseAnySimpleType(String lexicalXSDAnySimpleType)

返回包含简单类型的词汇表示形式的字符串。

参数：
lexicalXSDAnySimpleType - 包含简单类型的词汇表示形式的字符串。
返回：
包含简单类型的词汇表示形式的字符串。

printString

String printString(String val)

将字符串参数转换为一个字符串。

参数：
val - 字符串值。
返回：
包含 xsd:string 的词汇表示形式的字符串

printInteger

String printInteger(BigInteger val)

将 BigInteger 值转换为一个字符串。

参数：
val - 一个 BigInteger 值
返回：
包含 xsd:integer 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printInt

String printInt(int val)

将 int 值转换为一个字符串。

参数：
val - 一个 int 值
返回：
包含 xsd:int 的词汇表示形式的字符串

printLong

String printLong(long val)

将 long 值转换为一个字符串。

参数：
val - 一个 long 值
返回：
包含 xsd:long 的词汇表示形式的字符串

printShort

String printShort(short val)

将 short 值转换为一个字符串。

参数：
val - 一个 short 值
返回：
包含 xsd:short 的词汇表示形式的字符串

printDecimal

String printDecimal(BigDecimal val)

将 BigDecimal 值转换为一个字符串。

参数：
val - 一个 BigDecimal 值
返回：
包含 xsd:decimal 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printFloat

String printFloat(float val)

将 float 值转换为一个字符串。

参数：
val - 一个 float 值
返回：
包含 xsd:float 的词汇表示形式的字符串

printDouble

String printDouble(double val)

将 double 值转换为一个字符串。

参数：
val - 一个 double 值
返回：
包含 xsd:double 的词汇表示形式的字符串

printBoolean

String printBoolean(boolean val)

将 boolean 值转换为一个字符串。

参数：
val - 一个 boolean 值
返回：
包含 xsd:boolean 的词汇表示形式的字符串

printByte

String printByte(byte val)

将 byte 值转换为一个字符串。

参数：
val - 一个 byte 值
返回：
包含 xsd:byte 的词汇表示形式的字符串

printQName

String printQName(QName val,
                  NamespaceContext nsc)

将 QName 实例转换为一个字符串。

参数：
val - 一个 QName 值
nsc - 解释 QName 中前缀的名称空间上下文。
返回：
包含 QName 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null、nsc 为非 null 或 nsc.getPrefix(nsprefixFromVal) 为 null。

printDateTime

String printDateTime(Calendar val)

将 Calendar 值转换为一个字符串。

参数：
val - 一个 Calendar 值
返回：
包含 xsd:dateTime 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printBase64Binary

String printBase64Binary(byte[] val)

将字节数组转换为一个字符串。

参数：
val - 一个字节数组
返回：
包含 xsd:base64Binary 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printHexBinary

String printHexBinary(byte[] val)

将字节数组转换为一个字符串。

参数：
val - 一个字节数组
返回：
包含 xsd:hexBinary 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printUnsignedInt

String printUnsignedInt(long val)

将 long 值转换为一个字符串。

参数：
val - 一个 long 值
返回：
包含 xsd:unsignedInt 的词汇表示形式的字符串

printUnsignedShort

String printUnsignedShort(int val)

将 int 值转换为一个字符串。

参数：
val - 一个 int 值
返回：
包含 xsd:unsignedShort 的词汇表示形式的字符串

printTime

String printTime(Calendar val)

将 Calendar 值转换为一个字符串。

参数：
val - 一个 Calendar 值
返回：
包含 xsd:time 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printDate

String printDate(Calendar val)

将 Calendar 值转换为一个字符串。

参数：
val - 一个 Calendar 值
返回：
包含 xsd:date 的词汇表示形式的字符串
抛出：
IllegalArgumentException - 如果 val 为 null。

printAnySimpleType

String printAnySimpleType(String val)

将字符串值转换为一个字符串。

参数：
val - 字符串值
返回：
包含 xsd:AnySimpleType 的词汇表示形式的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Element (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 Element

public interface Element

这是一个元素标记接口。 在某些情况下，绑定编译器必须生成实现此接口的派生的 java 内容类。在这些情况下，客户端应用程序必须提供元素实例，而不是元素的类型。有关详细信息，请参阅该规范的 5.7 节“元素声明”和 5.7.1 节“绑定到 Java 元素接口”。

从以下版本开始：
JAXB1.0

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JAXBContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 JAXBContext

java.lang.Object
    继承者  javax.xml.bind.JAXBContext

public abstract class JAXBContext
extends Object

JAXBContext 类提供到 JAXB API 的客户端入口点。它提供了管理实现 JAXB 绑定框架操作所需的 XML/Java 绑定信息的抽象，这些操作包括：解组、编组和验证。

客户端应用程序通常使用以下两种风格的 newInstance 方法之一来获得此类的新实例，但是该方法还有其他可用的特殊形式：

  • JAXBContext.newInstance( "com.acme.foo:com.acme.bar" )
    JAXBContext 实例是根据冒号分隔的 Java 包名称的列表进行初始化的。每个 java 包都包含 JAXB 映射类、模式派生类和/或用户注释类。此外，java 包可能包含必须处理的 JAXB 包注释。（请参阅 JLS 第 3 版的第 7.4.1 节“包注释”）。
  • JAXBContext.newInstance( com.acme.foo.Foo.class )
    JAXBContext 实例是使用作为参数传递的类以及可从这些类静态获得的类来实现初始化的。有关详细信息，请参见 newInstance(Class...)。

特别要求：该提供者必须提供包含以下方法签名的实现类：
public static JAXBContext createContext( String contextPath, ClassLoader classLoader, Map properties ) throws JAXBException
public static JAXBContext createContext( Class[] classes, Map properties ) throws JAXBException

以下 JAXB 1.0 要求只是 java 接口/实现绑定的模式所需要的。它不适用于 JAXB 注释类。JAXB 提供者必须在每个包含模式派生类的包中生成一个 jaxb.properties 文件。该属性文件必须包含名为 javax.xml.bind.context.factory 的属性，其值为实现 createContext API 的类的名称。

该提供者提供的类不一定是可分配给 javax.xml.bind.JAXBContext 的，只是必须提供一个实现 createContext API 的类。

此外，提供者必须在执行 marshal 和 unmarshal 方法的任何客户端调用之前调用 DatatypeConverter.setDatatypeConverter api。这在配置将在执行这些操作期间使用的数据类型转换器时是必需的。

解组

Unmarshaller 类使客户端应用程序能够将 XML 数据转换为 Java 内容对象树。unmarshal 方法允许将模式中声明的任何全局 XML 元素解组为实例文档的根。此外，unmarshal 方法允许将未被识别的根元素（该元素具有一个引用了模式中声明的类型定义的 xsi:type 属性值）解组为实例文档的根。JAXBContext 对象允许跨模式集合（已在 contextPath 中列出）合并全局元素和类型定义。因为模式集合中的每个模式可能属于不同的名称空间，所以统一解组上下文的模式应该与名称空间无关。这意味着客户端应用程序能够解组 contextPath 中列出的任何模式实例的 XML 文档。例如：
JAXBContext jc = JAXBContext.newInstance( "com.acme.foo:com.acme.bar" );
Unmarshaller u = jc.createUnmarshaller();
FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) ); // ok
BarObject barObj = (BarObject)u.unmarshal( new File( "bar.xml" ) ); // ok
BazObject bazObj = (BazObject)u.unmarshal( new File( "baz.xml" ) ); // error, "com.acme.baz" not in contextPath

客户端应用程序还可以显式生成 Java 内容树，而不是解组现有的 XML 数据。对于所有 JAXB 注释值类，应用程序可以使用构造方法来创建内容。对于模式派生的接口/实现类以及未绑定到 JAXB 注释类的元素的创建，应用程序需要访问和了解每个模式派生的 ObjectFactory 类，这些类存在于 contextPath 中包含的每个 java 包中。对于每个模式派生的 java 类，都有一个生成该类型的对象的静态工厂方法。例如，假定在编译模式之后有一个包 com.acme.foo，它包含一个名为 PurchaseOrder 的模式派生接口。为了创建该类型的对象，客户端应用程序将使用如下工厂方法：

com.acme.foo.PurchaseOrder po =
com.acme.foo.ObjectFactory.createPurchaseOrder();

一旦客户端应用程序有一个模式派生对象的实例，它就可以使用 mutator 方法在该实例上设置内容。

有关生成的 ObjectFactory 类的更多信息，请参阅该规范的第 4.2 节“Java 包”。

特别要求：在包含名为 ObjectFactory 的包所需的所有对象工厂方法以及静态 newInstance( javaContentInterface ) 方法的每个包中，该提供者都必须生成一个类。

编组

Marshaller 类使客户端应用程序能够将 Java 内容树转换回 XML 数据。对使用工厂方法手动创建的内容树进行编组与对作为 unmarshal 操作结果的内容树进行编组没有什么区别。客户端可以将 java 内容树编组回 java.io.OutputStream 或 java.io.Writer 的 XML 数据。编组进程可以生成已注册 ContentHandler 的 SAX2 事件流，也可以生成一个 DOM 节点对象。客户端应用程序控制着输出编码，还控制着是将 XML 数据编组为一个完整的文档还是编组为一个片段。

下面是一个解组 XML 文档、然后将其编组回来的简单示例：

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );

// unmarshal from foo.xml
Unmarshaller u = jc.createUnmarshaller();
FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) );

// marshal to System.out
Marshaller m = jc.createMarshaller();
m.marshal( fooObj, System.out );

验证

自 JAXB 1.0 以后，验证已经发生了很大的变化。Validator 类已经废弃，成为了一个可选项。这意味着建议您不要使用此类，实际上，根据您的 JAXB 提供者，该类甚至根本不可用。在 JAXB 1.0 运行时系统上进行部署时，依赖 Validator 的 JAXB 1.0 客户端仍然可以正常工作。在 JAXB 2.0 中，Unmarshaller 已包括一些公开 JAXP 1.3 javax.xml.validation 框架的便捷方法。有关详细信息，请参阅 Unmarshaller.setSchema(javax.xml.validation.Schema) API。

JAXB 运行时绑定框架的兼容性

以下 JAXB 1.0 限制仅适用于将模式绑定到接口/实现类。因为此绑定不需要通用的运行时系统，所以 JAXB 客户端应用程序不必尝试混合使用不同的提供者提供的运行时对象（JAXBContext、Marshaller 等）。这并不意味着客户端应用程序是不可移植的，只是意味着客户端必须使用由用来编译模式的同一提供者提供的运行时系统。

从以下版本开始：
JAXB1.0
另请参见：
Marshaller, Unmarshaller, S 7.4.1.1 "Package Annotations" in Java Language Specification, 3rd Edition

字段摘要
static String JAXB_CONTEXT_FACTORY
属性名称，它包含能够创建新的 JAXBContext 对象的类名称。
构造方法摘要
protected JAXBContext()
方法摘要
 Binder<Node> createBinder()
为 W3C DOM 创建一个 Binder。
<T> Binder<T>
createBinder(Class<T> domType)
创建一个可用于关联/原地解组/编组操作的 Binder 对象。
 JAXBIntrospector createJAXBIntrospector()
创建一个可以用于内省 JAXB 对象的 JAXBIntrospector 对象。
abstract  Marshaller createMarshaller()
创建一个可以用来将 java 内容树转换为 XML 数据的 Marshaller 对象。
abstract  Unmarshaller createUnmarshaller()
创建一个可以用来将 XML 数据转换为 java 内容树的 Unmarshaller 对象。
abstract  Validator createValidator()
已过时。 从 JAXB 2.0 开始
 void generateSchema(SchemaOutputResolver outputResolver)
生成此上下文的模式文档。
static JAXBContext newInstance(Class... classesToBeBound)
获得 JAXBContext 类的新实例。
static JAXBContext newInstance(Class[] classesToBeBound, Map<String,?> properties)
获得 JAXBContext 类的新实例。
static JAXBContext newInstance(String contextPath)
获得 JAXBContext 类的新实例。
static JAXBContext newInstance(String contextPath, ClassLoader classLoader)
获得 JAXBContext 类的新实例。
static JAXBContext newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
获得 JAXBContext 类的新实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

JAXB_CONTEXT_FACTORY

public static final String JAXB_CONTEXT_FACTORY
属性名称，它包含能够创建新的 JAXBContext 对象的类名称。

另请参见：
常量字段值
构造方法详细信息

JAXBContext

protected JAXBContext()
方法详细信息

newInstance

public static JAXBContext newInstance(String contextPath)
                               throws JAXBException

获得 JAXBContext 类的新实例。

这是 newInstance 方法的一个便捷方法。它使用当前线程的上下文类加载器。要指定如何使用不同的类加载器，可以通过 Thread.setContextClassLoader() api 设置它，或者使用 newInstance 方法。

抛出：
JAXBException - 如果在创建 JAXBContext 时遇到错误，比如：
  1. 在包中查找 ObjectFactory.class 或 jaxb.index 失败
  2. 包含在 contextPath 中的全局元素之间出现混淆
  3. 查找上下文工厂提供者属性的值失败
  4. 混合使用相同 contextPath 上的不同提供者的模式派生包

newInstance

public static JAXBContext newInstance(String contextPath,
                                      ClassLoader classLoader)
                               throws JAXBException

获得 JAXBContext 类的新实例。

客户端应用程序必须提供上下文路径，该路径是一个冒号 (':', \u003A) 分隔的 java 包名称列表，它包含模式派生类和/或完全限定的 JAXB 注释类。模式派生的代码是通过为每个包生成的 ObjectFactory.class 在 JAXBContext 中注册的。程序员注释的 JAXB 映射类在 jaxb.index 资源文件中列出，而不是在上下文路径中列出，列出这些类所采用的格式如下所述。注意，java 包可以包含模式派生类和用户注释 JAXB 类。此外，java 包可能包含必须处理的 JAXB 包注释。（请参阅 JLS 第 3 版的第 7.4.1 节“包注释”）。

每个 contextPath 上列出的包都必须满足下面的一个或两个条件，否则将抛出 JAXBException：

  1. 必须包含 ObjectFactory.class
  2. 必须包含 jaxb.index

jaxb.index 的格式

该文件应该包含换行符分隔的类名称列表。空格、制表符和空行被忽略。注释字符是 '#' (0x23)；每行上的第一个注释字符后面的所有字符都被忽略。文件必须使用 UTF-8 编码。从列出的类中获得的类也可以在 JAXBContext 中注册，正如 newInstance(Class...) 定义的那样。

对 jaxb.index 文件中出现的类名称的限制是：

  • 不一定以 ".class" 结尾。
  • 类名称与包含 jaxb.index 文件的包相关。只允许使用直接出现在包含 jaxb.index 文件的包中的类。
  • 不允许使用完全限定的类名称。只允许与当前包相关的限定类名称指定一个嵌套类或内部类。

为了维护与将 JAXB 1.0 模式绑定到 java 接口/实现的兼容（可通过将模式自定义为 jaxb:globalBindings valueClass="false" 来启用此绑定）, JAXB 提供者需要确保上下文路径上的每个包都有一个 jaxb.properties 文件，该文件包含一个 javax.xml.bind.context.factory 属性值，以及解析为相同提供者的所有值。

此要求不适用于 JAXB 注释类。如果 contextPath 上列出的各种包之间存在任何全局 XML 元素名称冲突，则将抛出 JAXBException。

在相同的上下文路径中混合使用从多个 JAXB 提供者中生成的接口/实现绑定可能导致抛出 JAXBException。

参数：
contextPath - 包含模式派生类和/或 java 模式（JAXB 注释）映射类的 java 包名称的列表
classLoader - 此类加载器将用于定位实现类。
返回：
新的 JAXBContext 实例
抛出：
JAXBException - 如果创建 JAXBContext 时遇到错误，如下所示：
  1. 在包中查找 ObjectFactory.class 或 jaxb.index 失败
  2. 包含在 contextPath 中的全局元素之间出现混淆
  3. 查找上下文工厂提供者属性的值失败
  4. 混合使用相同 contextPath 上的不同提供者的模式派生包

newInstance

public static JAXBContext newInstance(String contextPath,
                                      ClassLoader classLoader,
                                      Map<String,?> properties)
                               throws JAXBException

获得 JAXBContext 类的新实例。

多数情况下，这与 newInstance(String, ClassLoader) 相同，但此版本允许传入特定于提供者的属性来配置 JAXBContext 的实例。

属性的解释取决于实现。

参数：
contextPath - 包含模式派生类的 java 包名称的列表
classLoader - 此类加载器将用于定位实现类。
properties - 特定于提供者的属性
返回：
新的 JAXBContext 实例
抛出：
JAXBException - 如果创建 JAXBContext 时遇到错误，如下所示：
  1. 在包中查找 ObjectFactory.class 或 jaxb.index 失败
  2. 包含在 contextPath 中的全局元素之间出现混淆
  3. 查找上下文工厂提供者属性的值失败
  4. 混合使用相同 contextPath 上的不同提供者的模式派生包
从以下版本开始：
JAXB 2.0

newInstance

public static JAXBContext newInstance(Class... classesToBeBound)
                               throws JAXBException

获得 JAXBContext 类的新实例。

客户端应用程序必须提供新上下文对象需要识别的类的列表。 新的上下文不仅要识别所有指定的类，还要识别直接/间接从指定类中静态引用的所有类。所引用类的子类或 @XmlTransient 引用类都不用在 JAXBContext 中注册。例如，在下面的 Java 代码中，如果执行 newInstance(Foo.class)，则新创建的 JAXBContext 将识别 Foo 和 Bar，但不识别 Zot 或 FooBar：

 class Foo {
      @XmlTransient FooBar c;
      Bar b;
 }
 class Bar { int x; }
 class Zot extends Bar { int y; }
 class FooBar { }
因此，典型的客户端应用程序只需指定最高层类，但需要小心。

注意，对于每个在 JAXBContext 中注册的 java 包，当存在可选的包注释时，必须对它们进行处理。（请参阅 JLS 第 3 版的第 7.4.1 节“包注释”）。

参数：
classesToBeBound - 将通过新的 JAXBContext 识别的 java 类的列表。可以为空，在这种情况下，将返回只知道规范中定义的类的 JAXBContext。
返回：
新的 JAXBContext 实例。该实例始终是一个非 null 的有效对象。
抛出：
JAXBException - 如果创建 JAXBContext 时遇到错误（但不限于这些错误），如下所示：
  1. 未发现任何 JAXB 实现
  2. 类以不正确的方式使用了 JAXB 注释
  3. 类包含有冲突的注释（比如有相同类型名称的两个类）
  4. JAXB 实现不能查找特定于提供者的带外信息（例如在开发时生成的附加文件）。
IllegalArgumentException - 如果参数中包含 null（即 newInstance(null);）
从以下版本开始：
JAXB 2.0

newInstance

public static JAXBContext newInstance(Class[] classesToBeBound,
                                      Map<String,?> properties)
                               throws JAXBException

获得 JAXBContext 类的新实例。

可重载 newInstance(Class...) 来配置“属性”，以实例化 JAXBContext。

属性的解释是特定于实现的。

参数：
classesToBeBound - 将通过新 JAXBContext 识别的 java 类的列表。可以为空，在这种情况下，将返回只知道规范中定义的类的 JAXBContext。
返回：
新的 JAXBContext 实例。该实例始终是一个非 null 的有效对象。
抛出：
JAXBException - 如果创建 JAXBContext 时遇到错误（但不限于这些错误），比如：
  1. 未发现任何 JAXB 实现
  2. 类以不正确的方式使用了 JAXB 注释
  3. 类包含有冲突的注释（比如有相同类型名称的两个类）
  4. JAXB 实现不能查找特定于提供者的带外信息（例如在开发时生成的附加文件）。
IllegalArgumentException - 如果参数中包含 null（即 newInstance(null);）
从以下版本开始：
JAXB 2.0

createUnmarshaller

public abstract Unmarshaller createUnmarshaller()
                                         throws JAXBException
创建一个可以用来将 XML 数据转换为 java 内容树的 Unmarshaller 对象。

返回：
Unmarshaller 对象
抛出：
JAXBException - 如果创建 Unmarshaller 对象时遇到错误

createMarshaller

public abstract Marshaller createMarshaller()
                                     throws JAXBException
创建一个可以用来将 java 内容树转换为 XML 数据的 Marshaller 对象。

返回：
Marshaller 对象
抛出：
JAXBException - 如果创建 Marshaller 对象时遇到错误

createValidator

public abstract Validator createValidator()
                                   throws JAXBException
已过时。 从 JAXB 2.0 开始

Validator 已成为一个可选项，并且在 JAXB 2.0 中已过时。有关详细信息，请参阅 Validator 的 javadoc。

创建一个可用于根据源模式验证 java 内容树的 Validator 对象。

返回：
一个 Validator 对象
抛出：
JAXBException - 如果创建 Validator 对象时遇到错误

createBinder

public <T> Binder<T> createBinder(Class<T> domType)
创建一个可用于关联/原地解组/编组操作的 Binder 对象。

参数：
domType - 选择通过传入其 DOM 节点类获得使用的 DOM API。
返回：
总是返回新的有效 Binder 对象。
抛出：
UnsupportedOperationException - 如果该实现不支持对应于 domType 的 DOM API。
从以下版本开始：
JAXB 2.0

createBinder

public Binder<Node> createBinder()
为 W3C DOM 创建一个 Binder。

返回：
总是返回新的有效 Binder 对象。
从以下版本开始：
JAXB 2.0

createJAXBIntrospector

public JAXBIntrospector createJAXBIntrospector()
创建一个可以用于内省 JAXB 对象的 JAXBIntrospector 对象。

返回：
总是返回非 null 的有效 JAXBIntrospector 对象。
抛出：
UnsupportedOperationException - 在 JAXB 1.0 实现上调用此方法将抛出 UnsupportedOperationException。
从以下版本开始：
JAXB 2.0

generateSchema

public void generateSchema(SchemaOutputResolver outputResolver)
                    throws IOException
生成此上下文的模式文档。

参数：
outputResolver - 此对象控制模式将被发送的输出。
抛出：
IOException - 如果 SchemaOutputResolver 抛出 IOException。
UnsupportedOperationException - 在 JAXB 1.0 实现上调用此方法将抛出 UnsupportedOperationException。
从以下版本开始：
JAXB 2.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JAXBElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 JAXBElement<T>

java.lang.Object
    继承者  javax.xml.bind.JAXBElement<T>
所有已实现的接口：
Serializable
public class JAXBElement<T>
extends Object
implements Serializable

Xml 元素的 JAXB 表示形式。

此类表示关于 Xml 元素的信息，这些信息包括模式中的元素声明，以及具有以下属性的 xml 文档中的元素实例值，如下所示：

  • 元素的 xml 标记 name
  • value 表示元素实例的属性和内容模式
  • 元素声明的 declaredType（xs:element @type 属性）
  • 元素声明的 scope
  • boolean 值形式的 nil 属性。（元素实例的 xsi:nil 属性）

declaredType 和 scope 属性是 xml 类型定义的 JAXB 类绑定。

Scope 可以是 JAXBElement.GlobalScope，也可以是表示包含模式元素声明的复杂类型定义的 Java 类。

这里有一个属性约束，即如果 value 为 null，则 nil 一定为 true。反之则不然，以支持表示包含属性的 nil 元素。如果 nil 为 true，则 value 可能为非 null，这样它可以保存与 nil 元素关联的属性值。

从以下版本开始：
JAXB 2.0
另请参见：
序列化表格

嵌套类摘要
static class JAXBElement.GlobalScope
为 xml 元素指定全局作用域。
字段摘要
protected Class<T> | declaredType xml 元素声明类型的 Java 数据类型绑定。
protected QName | name xml 元素标记名称。
protected boolean | nil 如果 xml 元素实例具有 xsi:nil="true" 属性，则 nil 为 true。
protected Class | scope 表示此 xml 元素实例的 xml 元素声明的作用域。
protected T | value xml 元素值。
构造方法摘要
JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
构造一个 xml 元素实例。
JAXBElement(QName name, Class<T> declaredType, T value)
构造一个 xml 元素实例。
方法摘要
Class<T> | getDeclaredType() 返回 xml 元素声明的类型属性的 Java 绑定。
QName | getName() 返回 xml 元素标记名称。
Class | getScope() 返回 xml 元素声明的作用域。
T | getValue() 返回此元素的内容模式和属性值。
boolean | isGlobalScope() 如果此 xml 元素声明是全局性的，则返回 true。
boolean | isNil() 如果此元素实例内容模式为 nil，则返回 true。
boolean | isTypeSubstituted() 如果此 xml 元素实例的值的类型与 xml 元素声明的声明类型不同，则返回 true。
void | setNil(boolean value) 设置此属性是否包含 nil 内容。
void | setValue(T t) 设置此 xml 元素的内容模式和属性。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

name

protected final QName name
xml 元素标记名称。

declaredType

protected final Class<T> declaredType
xml 元素声明类型的 Java 数据类型绑定。

scope

protected final Class scope
表示此 xml 元素实例的 xml 元素声明的作用域。可以是以下值之一：全局 xml 元素声明的 JAXBElement.GlobalScope。局部元素声明有一个被设置为包含 xml 元素声明的复杂类型定义的 Java 类表示形式的作用域。

value

protected T value
xml 元素值。表示 xml 元素实例的内容模式和属性。

nil

protected boolean nil
如果 xml 元素实例具有 xsi:nil="true" 属性，则 nil 为 true。

构造方法详细信息

JAXBElement

public JAXBElement(QName name,
                   Class<T> declaredType,
                   Class scope,
                   T value)

构造一个 xml 元素实例。

参数：
name - xml 元素标记名称的 Java 绑定
declaredType - xml 元素声明类型的 Java 绑定
scope - xml 元素声明作用域的 Java 绑定。传递 null 与传递 GlobalScope.class 相同
value - 表示 xml 元素值的 Java 实例。
另请参见：
getScope(), isTypeSubstituted()

JAXBElement

public JAXBElement(QName name,
                   Class<T> declaredType,
                   T value)
构造一个 xml 元素实例。这只是 new JAXBElement(name,declaredType,GlobalScope.class,value) 的一个便捷方法。

方法详细信息

getDeclaredType

public Class<T> getDeclaredType()
返回 xml 元素声明的类型属性的 Java 绑定。

getName

public QName getName()
返回 xml 元素标记名称。

setValue

public void setValue(T t)

设置此 xml 元素的内容模式和属性。

在将此属性设置为 null 时，isNil() 一定为 true。在 isNil() 中描述了约束的详细信息。

另请参见：
isTypeSubstituted()

getValue

public T getValue()

返回此元素的内容模式和属性值。

关于此值为 null 时的属性约束的描述，请参见 isNil()。

getScope

public Class getScope()
返回 xml 元素声明的作用域。

返回：
如果此元素位于全局作用域中，则返回 GlobalScope.class。
另请参见：
isGlobalScope()

isNil

public boolean isNil()

如果此元素实例内容模式为 nil，则返回 true。

当 getValue() 为 null 时，此属性总是返回 true。注意，反之则不然，当此属性为 true 时，getValue() 可以包含非 null 属性值。对于 nil xml 元素，包含属性是有效的。

setNil

public void setNil(boolean value)

设置此属性是否包含 nil 内容。

另请参见：
isNil()

isGlobalScope

public boolean isGlobalScope()
如果此 xml 元素声明是全局性的，则返回 true。

isTypeSubstituted

public boolean isTypeSubstituted()
如果此 xml 元素实例的值的类型与 xml 元素声明的声明类型不同，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JAXBElement.GlobalScope (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 JAXBElement.GlobalScope

java.lang.Object
    继承者  javax.xml.bind.JAXBElement.GlobalScope
正在封闭类：
JAXBElement<T>
public static final class JAXBElement.GlobalScope
extends Object

为 xml 元素指定全局作用域。

构造方法摘要
JAXBElement.GlobalScope()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JAXBElement.GlobalScope

public JAXBElement.GlobalScope()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JAXBException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 JAXBException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.bind.JAXBException
所有已实现的接口：
Serializable
直接已知子类：
MarshalException, PropertyException, UnmarshalException, ValidationException
public class JAXBException
extends Exception

这是所有 JAXB 异常的根异常类。

从以下版本开始：
JAXB1.0
另请参见：
JAXBContext, Marshaller, Unmarshaller, 序列化表格

构造方法摘要
JAXBException(String message)
构造带指定详细消息的 JAXBException。
JAXBException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 JAXBException。
JAXBException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 JAXBException。
JAXBException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 JAXBException。
JAXBException(Throwable exception)
构造带有一个 linkedException 的 JAXBException。
方法摘要
Throwable | getCause() 返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
String | getErrorCode() 获取特定于供应商的错误代码。
Throwable | getLinkedException() 获取链接的异常。
void | printStackTrace() 打印此 JAXBException 及其对 System.err 的堆栈跟踪（如果为非 null，则包括 linkedException 的堆栈跟踪）。
void | printStackTrace(PrintStream s) 打印此 JAXBException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
void | printStackTrace(PrintWriter s) 打印此 JAXBException 及其对 PrintWriter 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
void | setLinkedException(Throwable exception) 添加链接的异常。
String | toString() 返回此 JAXBException 的简短描述。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JAXBException

public JAXBException(String message)
构造带指定详细消息的 JAXBException。errorCode 和 linkedException 将默认为 null。

参数：
message - 对异常的描述

JAXBException

public JAXBException(String message,
                     String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 JAXBException。linkedException 将默认为 null。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串

JAXBException

public JAXBException(Throwable exception)
构造带有一个 linkedException 的 JAXBException。详细消息和特定于供应商的 errorCode 将默认为 null。

参数：
exception - 链接的异常

JAXBException

public JAXBException(String message,
                     Throwable exception)
构造带指定的详细消息和 linkedException 的 JAXBException。errorCode 将默认为 null。

参数：
message - 对异常的描述
exception - 链接的异常

JAXBException

public JAXBException(String message,
                     String errorCode,
                     Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 JAXBException。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串
exception - 链接的异常
方法详细信息

getErrorCode

public String getErrorCode()
获取特定于供应商的错误代码。

返回：
指定特定于供应商的错误代码的字符串

getLinkedException

public Throwable getLinkedException()
获取链接的异常。

返回：
链接的异常；如果不存在，则返回 null

setLinkedException

public void setLinkedException(Throwable exception)
添加链接的异常。

参数：
exception - 链接的异常（允许使用 null 值，该值指示链接的异常不存在或者是未知的）。

toString

public String toString()
返回此 JAXBException 的简短描述。

覆盖：
类 Throwable 中的 toString
返回：
该 throwable 的字符串表示形式。

printStackTrace

public void printStackTrace(PrintStream s)
打印此 JAXBException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace()
打印此 JAXBException 及其对 System.err 的堆栈跟踪（如果为非 null，则包括 linkedException 的堆栈跟踪）。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintWriter s)
打印此 JAXBException 及其对 PrintWriter 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintWriter

getCause

public Throwable getCause()
从类 Throwable 复制的描述
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。（该 Cause 是导致抛出此 throwable 的throwable。）

此实现返回由一个需要 Throwable 的构造方法提供的 cause，或者在创建之后通过 Throwable.initCause(Throwable) 方法进行设置的 cause。虽然通常不需要重写此方法，但子类可以重写它，以返回一个通过某些其他方式设置的 cause。这适用于在异常链（异常嵌套）机制被加入到 Throwable 之前存在“遗留 Throwable 链机制”的情况。注意，不必 重写任何 PrintStackTrace 方法，所有方法都调用 getCause 方法来确定 throwable 的 cause。

覆盖：
类 Throwable 中的 getCause
返回：
此 throwable 的 cause，如果 cause 不存在或是未知的，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JAXBIntrospector (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 JAXBIntrospector

java.lang.Object
    继承者  javax.xml.bind.JAXBIntrospector

public abstract class JAXBIntrospector
extends Object

提供对 JAXB 对象的 JAXB xml 绑定数据的访问。

最初，此类只用于从概念上说明 JAXB 应用程序开发人员如何访问 xml 绑定信息，与绑定模型是从 java 到 schema 还是从 schema 到 java 无关。由于访问与 JAXB 元素相关的 XML 元素名称是经常被请求的功能，所以我们将演示如何访问此绑定信息。获取 JAXBIntrospector 实例的工厂方法是 JAXBContext.createJAXBIntrospector()。

从以下版本开始：
JAXB2.0
另请参见：
JAXBContext.createJAXBIntrospector()

构造方法摘要
JAXBIntrospector()
方法摘要
abstract QName | getElementName(Object jaxbElement) 获取 jaxbElement 的 xml 元素 qname。
static Object | getValue(Object jaxbElement) 获取 JAXB 元素的元素值。
abstract boolean | isElement(Object object) 如果 object 表示一个 JAXB 元素，则返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JAXBIntrospector

public JAXBIntrospector()
方法详细信息

isElement

public abstract boolean isElement(Object object)

如果 object 表示一个 JAXB 元素，则返回 true。

在以下情况中，参数 object 是一个 JAXB 元素：

  1. 它是 javax.xml.bind.JAXBElement 的实例。
  2. object 的类是使用 @ 注释的。

另请参见：
getElementName(Object)

getElementName

public abstract QName getElementName(Object jaxbElement)

获取 jaxbElement 的 xml 元素 qname。

参数：
jaxbElement - isElement(Object) 返回 true 的对象。
返回：
与 jaxbElement 关联的 xml 元素 qname；如果 jaxbElement 不是 JAXB 元素，则返回 null。

getValue

public static Object getValue(Object jaxbElement)

获取 JAXB 元素的元素值。

对是与 javax.xml.bind.JAXBElement 实例一起使用还是与用 >@XmlRootElement 注释的 Java 类实例一起使用进行抽象的便捷方法。

参数：
jaxbElement - #isElement(Object) 返回 true 的对象。
返回：
jaxbElement 的元素值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MarshalException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 MarshalException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.bind.JAXBException
                继承者  javax.xml.bind.MarshalException
所有已实现的接口：
Serializable
public class MarshalException
extends JAXBException

此异常指示在执行提供者无法恢复的编组操作时发生错误。

ValidationEventHandler 可能导致执行编组操作期间抛出此异常。请参阅 ValidationEventHandler.handleEvent(ValidationEvent)。

从以下版本开始：
JAXB1.0
另请参见：
JAXBException, Marshaller, 序列化表格

构造方法摘要
MarshalException(String message)
构造带指定详细消息的 MarshalException。
MarshalException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 MarshalException。
MarshalException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 MarshalException。
MarshalException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 MarshalException。
MarshalException(Throwable exception)
构造带有一个 linkedException 的 MarshalException。
方法摘要
从类 javax.xml.bind.JAXBException 继承的方法
getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MarshalException

public MarshalException(String message)
构造带指定详细消息的 MarshalException。errorCode 和 linkedException 将默认为 null。

参数：
message - 对异常的描述

MarshalException

public MarshalException(String message,
                        String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 MarshalException。linkedException 将默认为 null。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串

MarshalException

public MarshalException(Throwable exception)
构造带有一个 linkedException 的 MarshalException。详细消息和特定于供应商的 errorCode 将默认为 null。

参数：
exception - 链接的异常

MarshalException

public MarshalException(String message,
                        Throwable exception)
构造带指定的详细消息和 linkedException 的 MarshalException。errorCode 将默认为 null。

参数：
message - 对异常的描述
exception - 链接的异常

MarshalException

public MarshalException(String message,
                        String errorCode,
                        Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 MarshalException。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串
exception - 链接的异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Marshaller (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 Marshaller

所有已知实现类：
AbstractMarshallerImpl
public interface Marshaller

Marshaller 类负责管理将 Java 内容树序列化回 XML 数据的过程。它提供了基本的编组方法：

假定以下安装代码适用于下列所有代码片段：

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();
Object element = u.unmarshal( new File( "foo.xml" ) );
Marshaller m = jc.createMarshaller();

编组到 File 中：

OutputStream os = new FileOutputStream( "nosferatu.xml" );
m.marshal( element, os );

编组到 SAX ContentHandler 中：

// assume MyContentHandler instanceof ContentHandler
m.marshal( element, new MyContentHandler() );

编组到 DOM Node 中：

DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
dbf.setNamespaceAware(true);
DocumentBuilder db = dbf.newDocumentBuilder();
Document doc = db.newDocument();

m.marshal( element, doc );

编组到 java.io.OutputStream 中：

m.marshal( element, System.out );

编组到 java.io.Writer 中：

m.marshal( element, new PrintWriter( System.out ) );

编组到 javax.xml.transform.SAXResult 中：

// assume MyContentHandler instanceof ContentHandler
SAXResult result = new SAXResult( new MyContentHandler() );

m.marshal( element, result );

编组到 javax.xml.transform.DOMResult 中：

DOMResult result = new DOMResult();

m.marshal( element, result );

编组到 javax.xml.transform.StreamResult 中：

StreamResult result = new StreamResult( System.out );

m.marshal( element, result );

编组到 javax.xml.stream.XMLStreamWriter 中：

XMLStreamWriter xmlStreamWriter =
XMLOutputFactory.newInstance().createXMLStreamWriter( ... );

m.marshal( element, xmlStreamWriter );

编组到 javax.xml.stream.XMLEventWriter 中：

XMLEventWriter xmlEventWriter =
XMLOutputFactory.newInstance().createXMLEventWriter( ... );

m.marshal( element, xmlEventWriter );

对通过 JAXB 元素确定的内容树进行编组

重载的 Marshaller.marshal(java.lang.Object, ...) 方法的第一个参数必须是由 JAXBIntrospector.isElement(java.lang.Object) 计算的 JAXB 元素；否则，Marshaller.marshal 方法必须抛出 MarshalException。存在两种能编组非 JAXB 元素实例的机制。一种方法是将该实例包装为 JAXBElement 值，并将包装器对象作为第一个参数传递给 Marshaller.marshal 方法。对于 java 到模式的绑定，还可以简单地使用 @XmlRootElement 注释该实例的类。

编码

默认情况下，在将 XML 数据生成到 java.io.OutputStream 或 java.io.Writer 中时，Marshaller 将使用 UTF-8 编码。可以使用 setProperty API 更改执行这些编组操作期间所使用的输出编码。期望客户端应用程序根据 W3C XML 1.0 Recommendation 中的定义提供 Java 平台支持的有效字符编码名称。

验证和格式良好性

客户端应用程序不需要在调用任何编组 API 之前验证 Java 内容树。此外，在将 Java 内容树编组回 XML 数据时，不要求它对于其源模式有效。不同的 JAXB 提供者可支持编组各种级别的无效 Java 内容树，但所有 JAXB 提供者都必须能够将有效的内容树编组回 XML 数据。当因为无效内容导致 JAXB 提供者无法完成编组操作时，JAXB 提供者必须抛出 MarshalException。一些 JAXB 提供者完全允许编组无效内容，而另一些 JAXB 提供者将在出现第一个验证错误时失败。

即使没有为编组操作显式地启用模式验证，但在操作过程中可能要检测某些类型的验证事件。这些验证事件将被报告给已注册的事件处理程序。如果客户端应用程序没有在调用某个编组 API 之前注册事件处理程序，则事件将被转发给默认的事件处理程序，默认处理程序将在遇到第一个错误或遇到致命错误之后终止编组操作。注意，对于 JAXB 2.0 和以后的版本，不再使用 DefaultValidationEventHandler。

支持的属性

所有 JAXB 提供者都要支持以下这组属性。某些提供者还可以支持其他属性。

jaxb.encoding：值必须是 java.lang.String
编组 XML 数据时使用的输出编码。默认情况下，如果未指定此属性，则 Marshaller 将使用 "UTF-8"。
jaxb.formatted.output：值必须是 java.lang.Boolean
此属性控制 Marshaller 是否使用换行和缩排对得到的 XML 数据进行格式化。此属性为 true 值表示可读性强的缩排 xml 数据，而属性值为 false 则表示未格式化的 xml 数据。如果未指定此属性，则 Marshaller 将该属性值默认为 false（未格式化）。
jaxb.schemaLocation：值必须是 java.lang.String
此属性允许客户端应用程序在生成的 XML 数据中指定 xsi:schemaLocation 属性。该 schemaLocation 属性值的格式将以便于理解的、非标准的形式在 W3C XML Schema Part 0:Primer 的第 5.6 节中讨论，并在 W3C XML Schema Part 1:Structures 的第 2.6 节中指定。
jaxb.noNamespaceSchemaLocation：值必须是 java.lang.String
此属性允许客户端应用程序在生成的 XML 数据中指定 xsi:noNamespaceSchemaLocation 属性。该 schemaLocation 属性值的格式将以便于理解的、非标准的形式在 W3C XML Schema Part 0:Primer 的第 5.6 节中讨论，并在 W3C XML Schema Part 1:Structures 的第 2.6 节中指定。
jaxb.fragment：值必须是 java.lang.Boolean
此属性决定 Marshaller 是否将生成文档级事件。如果未指定该属性，则默认为 false。将其设置为 true 时，根据所使用的编组 API，此属性具有不同的含义：
  • marshal(Object,ContentHandler)：Marshaller 不会调用 ContentHandler.startDocument() 和 ContentHandler.endDocument()。
  • marshal(Object,Node)：该属性对此 API 没有影响。
  • marshal(Object,OutputStream)：Marshaller 不会生成 xml 声明。
  • marshal(Object,Writer)：Marshaller 不会生成 xml 声明。
  • marshal(Object,Result)：取决于 Result 对象的类型，请参见 Node、ContentHandler 和 Stream API 的语义。
  • marshal(Object,XMLEventWriter)：Marshaller 不会生成 XMLStreamConstants.START_DOCUMENT 和 XMLStreamConstants.END_DOCUMENT 事件。
  • marshal(Object,XMLStreamWriter)：Marshaller 不会生成 XMLStreamConstants.START_DOCUMENT 和 XMLStreamConstants.END_DOCUMENT 事件。

编组事件回调

Marshaller 提供了两种风格的回调机制，这些机制允许在解组过程的关键点上进行特定于应用程序的处理。在“类定义的”事件回调中，编组期间会触发位于 JAXB 映射类中的特定于应用程序的代码。“外部侦听器”允许用一个回调方法集中处理编组事件，而不是通过各种类型事件回调处理。

类定义的事件回调方法允许任何 JAXB 映射类通过定义带有以下方法签名的方法指定自己的特定回调方法：

// Invoked by Marshaller after it has created an instance of this object.
boolean beforeMarshal(Marshaller, Object parent);

// Invoked by Marshaller after it has marshalled all properties of this object.
void afterMmarshal(Marshaller, Object parent);
类定义的事件回调方法应该在回调方法需要访问该类的非公共方法和/或字段时使用。

外部侦听器回调机制支持 Marshaller.Listener 实例使用 setListener(Listener) 的注册。外部侦听器接收所有回调事件，从而允许用比逐个类地定义回调方法更为集中的方式处理事件。

“类定义的”事件回调方法和外部侦听器事件回调方法相互独立，可以对一个事件同时调用。两种侦听器回调方法都存在时，按照 Marshaller.Listener.beforeMarshal(Object) 和 Marshaller.Listener.afterMarshal(Object) 中定义的顺序对它们进行调用。

抛出异常的事件回调方法会终止当前的编组进程。

从以下版本开始：
JAXB 1.0
另请参见：
JAXBContext, Validator, Unmarshaller

嵌套类摘要
static class Marshaller.Listener

向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。

字段摘要
static String | JAXB_ENCODING 用来指定已编组 XML 数据中输出编码的属性名称。
static String | JAXB_FORMATTED_OUTPUT 用来指定是否使用换行和缩排对已编组 XML 数据进行格式化的属性名称。
static String | JAXB_FRAGMENT 用来指定 marshaller 是否将生成文档级事件（即调用 startDocument 或 endDocument）的属性名称。
static String | JAXB_NO_NAMESPACE_SCHEMA_LOCATION 用来指定将放置在已编组 XML 输出中的 xsi:noNamespaceSchemaLocation 属性值的属性名称。
static String | JAXB_SCHEMA_LOCATION 用来指定将放置在已编组 XML 输出中的 xsi:schemaLocation 属性值的属性名称。
方法摘要
<A extends XmlAdapter>
A
getAdapter(Class<A> type)
获取与指定类型关联的适配器。
 AttachmentMarshaller getAttachmentMarshaller()
 ValidationEventHandler getEventHandler()
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
 Marshaller.Listener getListener()
返回向此 Marshaller 注册的 Marshaller.Listener。
 Node getNode(Object contentTree)
获取内容树的 DOM 树视图（可选）。
 Object getProperty(String name)
获取 Marshaller 底层实现中的特定属性。
 Schema getSchema()
获取用于执行编组时验证的 JAXP 1.3 Schema 对象。
 void marshal(Object jaxbElement, ContentHandler handler)
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。
 void marshal(Object jaxbElement, Node node)
将以 jaxbElement 为根的内容树编组到 DOM 树中。
 void marshal(Object jaxbElement, OutputStream os)
将以 jaxbElement 为根的内容树编组到输出流中。
 void marshal(Object jaxbElement, Result result)
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。
 void marshal(Object jaxbElement, Writer writer)
将以 jaxbElement 为根的内容树编组到 Writer 中。
 void marshal(Object jaxbElement, XMLEventWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。
 void marshal(Object jaxbElement, XMLStreamWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。
<A extends XmlAdapter>
void
setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。
 void setAdapter(XmlAdapter adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。
 void setAttachmentMarshaller(AttachmentMarshaller am)
与上下文关联，使 XML 文档内的二进制数据能够以优化的 XML 二进制附件的形式传送。
 void setEventHandler(ValidationEventHandler handler)
允许应用程序注册一个验证事件处理程序。
 void setListener(Marshaller.Listener listener)
向此 Marshaller 注册编组事件回调 Marshaller.Listener。
 void setProperty(String name, Object value)
设置 Marshaller 底层实现中的特定属性。
 void setSchema(Schema schema)
指定应该用作验证后续编组操作依据的 JAXP 1.3 Schema 对象。

字段详细信息

JAXB_ENCODING

static final String JAXB_ENCODING
用来指定已编组 XML 数据中输出编码的属性名称。

另请参见：
常量字段值

JAXB_FORMATTED_OUTPUT

static final String JAXB_FORMATTED_OUTPUT
用来指定是否使用换行和缩排对已编组 XML 数据进行格式化的属性名称。

另请参见：
常量字段值

JAXB_SCHEMA_LOCATION

static final String JAXB_SCHEMA_LOCATION
用来指定将放置在已编组 XML 输出中的 xsi:schemaLocation 属性值的属性名称。

另请参见：
常量字段值

JAXB_NO_NAMESPACE_SCHEMA_LOCATION

static final String JAXB_NO_NAMESPACE_SCHEMA_LOCATION
用来指定将放置在已编组 XML 输出中的 xsi:noNamespaceSchemaLocation 属性值的属性名称。

另请参见：
常量字段值

JAXB_FRAGMENT

static final String JAXB_FRAGMENT
用来指定 marshaller 是否将生成文档级事件（即调用 startDocument 或 endDocument）的属性名称。

另请参见：
常量字段值
方法详细信息

marshal

void marshal(Object jaxbElement,
             Result result)
             throws JAXBException
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。

所有 JAXB 提供者至少必须支持 DOMResult、SAXResult 和 StreamResult。它也可以支持 Result 的其他派生类。

参数：
jaxbElement - 要编组的内容树的根。
result - XML 将被发送到此 Result
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。
IllegalArgumentException - 如果任何方法参数为 null

marshal

void marshal(Object jaxbElement,
             OutputStream os)
             throws JAXBException
将以 jaxbElement 为根的内容树编组到输出流中。

参数：
jaxbElement - 要编组的内容树的根。
os - XML 将被添加到此流。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。
IllegalArgumentException - 如果任何方法参数为 null

marshal

void marshal(Object jaxbElement,
             Writer writer)
             throws JAXBException
将以 jaxbElement 为根的内容树编组到 Writer 中。

参数：
jaxbElement - 要编组的内容树的根。
writer - XML 将被发送到此编写器。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。
IllegalArgumentException - 如果任何方法参数为 null

marshal

void marshal(Object jaxbElement,
             ContentHandler handler)
             throws JAXBException
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。

参数：
jaxbElement - 要编组的内容树的根。
handler - XML 将被作为 SAX2 事件发送到此处理程序。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。
IllegalArgumentException - 如果任何方法参数为 null

marshal

void marshal(Object jaxbElement,
             Node node)
             throws JAXBException
将以 jaxbElement 为根的内容树编组到 DOM 树中。

参数：
jaxbElement - 要编组的内容树。
node - DOM 节点将作为此节点的子节点添加。此参数必须是一个可接受子节点（Document、DocumentFragment 或 Element）的 Node。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 jaxbElement（或任何可从 jaxbElement 获得的对象）。请参阅编组 JAXB 元素。
IllegalArgumentException - 如果任何方法参数为 null

marshal

void marshal(Object jaxbElement,
             XMLStreamWriter writer)
             throws JAXBException
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。

参数：
jaxbElement - 要编组的内容树。
writer - XML 将被发送到此编写器。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。
IllegalArgumentException - 如果任何方法参数为 null
从以下版本开始：
JAXB 2.0

marshal

void marshal(Object jaxbElement,
             XMLEventWriter writer)
             throws JAXBException
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。

参数：
jaxbElement - 要编组的以 jaxbElement 为根的内容树。
writer - XML 将被发送到此编写器。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。
IllegalArgumentException - 如果任何方法参数为 null
从以下版本开始：
JAXB 2.0

getNode

Node getNode(Object contentTree)
             throws JAXBException
获取内容树的 DOM 树视图（可选）。 如果更新了返回的 DOM 树，则这些更改也可以在内容树中看见。使用 marshal(Object, org.w3c.dom.Node) 强行将内容树的深层复制转换成 DOM 表示形式。

参数：
contentTree - XML 内容的 JAXB Java 表示形式
返回：
contentTree 的 DOM 树视图
抛出：
UnsupportedOperationException - 如果 JAXB 提供者实现不支持内容树的 DOM 视图
IllegalArgumentException - 如果任何方法参数为 null
JAXBException - 如果发生任何不可预料的问题

setProperty

void setProperty(String name,
                 Object value)
                 throws PropertyException
设置 Marshaller 底层实现中的特定属性。此方法只能用于设置上文中标准 JAXB 定义的属性之一或特定于提供者的属性。试图设置未定义的属性将导致抛出 PropertyException。请参阅支持的属性。

参数：
name - 要设置的属性的名称。此值可以使用一个常量字段来指定，也可以是一个用户提供的字符串。
value - 要设置的属性值
抛出：
PropertyException - 如果处理给定属性或值时发生错误
IllegalArgumentException - 如果 name 参数为 null

getProperty

Object getProperty(String name)
                   throws PropertyException
获取 Marshaller 底层实现中的特定属性。此方法只能用于获取上文中标准 JAXB 定义的属性之一或特定于提供者的属性。试图获取未定义的属性将导致抛出 PropertyException。请参阅支持的属性。

参数：
name - 将检索的属性的名称
返回：
所请求属性的值
抛出：
PropertyException - 如果检索给定属性或值属性名称时发生错误
IllegalArgumentException - 如果 name 参数为 null

setEventHandler

void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
允许应用程序注册一个验证事件处理程序。

如果在调用任何编组 API 期间遇到任何验证错误，则 JAXB 提供者将调用验证事件处理程序。如果客户端应用程序没有在调用某个 marshal 方法之前注册验证事件处理程序，则将使用默认事件处理程序处理验证事件，默认处理程序将在遇到第一个错误或致命错误之后将终止编组操作。

调用带有 null 参数的此方法将导致 Marshaller 重新使用默认事件处理程序。

参数：
handler - 验证事件处理程序
抛出：
JAXBException - 如果在设置事件处理程序时遇到错误

getEventHandler

ValidationEventHandler getEventHandler()
                                       throws JAXBException
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。

返回：
当前的 ValidationEventHandler，如果没有设置该处理程序，则返回默认的事件处理程序
抛出：
JAXBException - 如果获取当前的事件处理程序时遇到错误

setAdapter

void setAdapter(XmlAdapter adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。

这是调用 setAdapter(adapter.getClass(),adapter) 的一个便捷方法。

抛出：
IllegalArgumentException - 如果 adapter 参数为 null。
UnsupportedOperationException - 如果基于 JAXB 1.0 实现调用。
从以下版本开始：
JAXB 2.0
另请参见：
setAdapter(Class,XmlAdapter)

setAdapter

<A extends XmlAdapter> void setAdapter(Class<A> type,
                                       A adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。

每个 marshaller 都可以在内部维护一个 Map<Class,XmlAdapter>，可用来编组使用 XmlJavaTypeAdapter 注释其字段/方法的类。

此方法允许应用程序使用已配置好的 XmlAdapter 实例。如果没有给出适配器实例，则 marshaller 将调用其默认构造方法创建一个实例。

参数：
type - 适配器的类型。当 XmlJavaTypeAdapter.value() 引用此类型时，将使用指定的实例。
adapter - 将要使用的适配器实例。如果为 null，则将注销此类型的当前适配器集合。
抛出：
IllegalArgumentException - 如果 type 参数为 null。
UnsupportedOperationException - 如果基于 JAXB 1.0 实现调用。
从以下版本开始：
JAXB 2.0

getAdapter

<A extends XmlAdapter> A getAdapter(Class<A> type)
获取与指定类型关联的适配器。 这是 setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) 方法的反向操作。

抛出：
IllegalArgumentException - 如果 type 参数为 null。
UnsupportedOperationException - 如果基于 JAXB 1.0 实现调用。
从以下版本开始：
JAXB 2.0

setAttachmentMarshaller

void setAttachmentMarshaller(AttachmentMarshaller am)

与上下文关联，使 XML 文档内的二进制数据能够以优化的 XML 二进制附件的形式传送。可以使用存储在 xml 文档中的内容 id URI (cid) 从 XML 文档内容模式引用附件。

抛出：
IllegalStateException - 如果试图在执行编组操作期间同时调用此方法。

getAttachmentMarshaller

AttachmentMarshaller getAttachmentMarshaller()

setSchema

void setSchema(Schema schema)
指定应该用作验证后续编组操作依据的 JAXP 1.3 Schema 对象。向此方法传递 null 将禁用验证。

此方法允许调用者在对已编组的 XML 进行编组时验证它。

最初，此属性被设置为 null。

参数：
schema - 作为验证编组操作依据的 Schema 对象；为 null 表示禁用验证
抛出：
UnsupportedOperationException - 如果对根据引用 JAXB 1.0 映射类的 JAXBContext 而创建的 Marshaller 调用此方法，则抛出该异常
从以下版本开始：
JAXB 2.0

getSchema

Schema getSchema()
获取用于执行编组时验证的 JAXP 1.3 Schema 对象。如果未在 marshaller 上设置 Schema，则此方法将返回 null，指示不执行编组时验证。

返回：
返回用于执行编组时验证的 Schema 对象；如果该对象不存在，则返回 null。
抛出：
UnsupportedOperationException - 如果对根据引用 JAXB 1.0 映射类的 JAXBContext 而创建的 Marshaller 调用此方法，则抛出该异常
从以下版本开始：
JAXB 2.0

setListener

void setListener(Marshaller.Listener listener)

向此 Marshaller 注册编组事件回调 Marshaller.Listener。

每个 Marshaller 只有一个 Listener。设置 Listener 将替换以前设置的 Listener。通过将 listener 设置为 null 可注销当前的 Listener。

参数：
listener - 实现 Marshaller.Listener 的类的实例
从以下版本开始：
JAXB 2.0

getListener

Marshaller.Listener getListener()

返回向此 Marshaller 注册的 Marshaller.Listener。

返回：
注册的 Marshaller.Listener；如果未向此 Marshaller 注册任何 Listener，则返回 null。
从以下版本开始：
JAXB 2.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Marshaller.Listener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 Marshaller.Listener

java.lang.Object
    继承者  javax.xml.bind.Marshaller.Listener
正在封闭接口：
Marshaller
public abstract static class Marshaller.Listener
extends Object

向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。

此类支持对每个已编组的对象进行预处理和后处理。从映射到 xml 元素或复杂类型定义的实例进行编组时，将调用事件回调。从表示简单类型定义的 Java 数据类型的实例进行编组时，不需要调用事件回调。

外部侦听器是用于定义编组事件回调的两个不同机制之一。请参阅 Marshal Event Callbacks 获得对方面的概括。

从以下版本开始：
JAXB2.0
另请参见：
Marshaller.setListener(Listener), Marshaller.getListener()

构造方法摘要
Marshaller.Listener()
方法摘要
void | afterMarshal(Object source) 将 source 编组到 XML 之后调用的回调方法。
void | beforeMarshal(Object source) 从 source 编组到 XML 之前调用的回调方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Marshaller.Listener

public Marshaller.Listener()
方法详细信息

beforeMarshal

public void beforeMarshal(Object source)

从 source 编组到 XML 之前调用的回调方法。

只在编组进程开始编组 source 之前才调用此方法。注意，如果 source 的类定义了自己的 beforeMarshal 方法，则只在调用此方法之前调用特定于类的回调方法。

参数：
source - 编组之前的 JAXB 映射类的实例。

afterMarshal

public void afterMarshal(Object source)

将 source 编组到 XML 之后调用的回调方法。

在编组 source 及其所有子代之前调用此方法。注意，如果 source 的类定义了自己的 afterMarshal 方法，则只在调用此方法之前调用特定于类的回调方法。

参数：
source - 编组之后的 JAXB 映射类的实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotIdentifiableEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 NotIdentifiableEvent

所有超级接口：
ValidationEvent
所有已知实现类：
NotIdentifiableEventImpl
public interface NotIdentifiableEvent
extends ValidationEvent

此事件指示解析 ID/IDREF 时遇到一个问题。

从以下版本开始：
JAXB1.0
另请参见：
Validator, ValidationEventHandler

字段摘要
从接口 javax.xml.bind.ValidationEvent 继承的字段
ERROR, FATAL_ERROR, WARNING
方法摘要
从接口 javax.xml.bind.ValidationEvent 继承的方法
getLinkedException, getLocator, getMessage, getSeverity

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParseConversionEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 ParseConversionEvent

所有超级接口：
ValidationEvent
所有已知实现类：
ParseConversionEventImpl
public interface ParseConversionEvent
extends ValidationEvent

此事件指示将 XML 数据中的字符串转换为目标 Java 数据类型的值时遇到一个问题。

从以下版本开始：
JAXB1.0
另请参见：
ValidationEvent, ValidationEventHandler, Unmarshaller

字段摘要
从接口 javax.xml.bind.ValidationEvent 继承的字段
ERROR, FATAL_ERROR, WARNING
方法摘要
从接口 javax.xml.bind.ValidationEvent 继承的方法
getLinkedException, getLocator, getMessage, getSeverity

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintConversionEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 PrintConversionEvent

所有超级接口：
ValidationEvent
所有已知实现类：
PrintConversionEventImpl
public interface PrintConversionEvent
extends ValidationEvent

此事件指示将 Java 内容树中的数据转换为其词汇表示形式时遇到一个问题。

从以下版本开始：
JAXB1.0
另请参见：
ValidationEvent, ValidationEventHandler, Marshaller

字段摘要
从接口 javax.xml.bind.ValidationEvent 继承的字段
ERROR, FATAL_ERROR, WARNING
方法摘要
从接口 javax.xml.bind.ValidationEvent 继承的方法
getLinkedException, getLocator, getMessage, getSeverity

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 PropertyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.bind.JAXBException
                继承者  javax.xml.bind.PropertyException
所有已实现的接口：
Serializable
public class PropertyException
extends JAXBException

此异常指示在获取或设置属性时遇到一个错误。

从以下版本开始：
JAXB1.0
另请参见：
JAXBContext, Validator, Unmarshaller, 序列化表格

构造方法摘要
PropertyException(String message)
构造带指定详细消息的 PropertyException。
PropertyException(String name, Object value)
构造一个基于属性名称和 value.toString() 设置其消息字段的 PropertyException。
PropertyException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 PropertyException。
PropertyException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 PropertyException。
PropertyException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 PropertyException。
PropertyException(Throwable exception)
构造带有一个 linkedException 的 PropertyException。
方法摘要
从类 javax.xml.bind.JAXBException 继承的方法
getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PropertyException

public PropertyException(String message)
构造带指定详细消息的 PropertyException。errorCode 和 linkedException 将默认为 null。

参数：
message - 对异常的描述

PropertyException

public PropertyException(String message,
                         String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 PropertyException。linkedException 将默认为 null。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串

PropertyException

public PropertyException(Throwable exception)
构造带有一个 linkedException 的 PropertyException。详细消息和特定于供应商的 errorCode 将默认为 null。

参数：
exception - 链接的异常

PropertyException

public PropertyException(String message,
                         Throwable exception)
构造带指定详细消息和 linkedException 的 PropertyException。errorCode 将默认为 null。

参数：
message - 对异常的描述
exception - 链接的异常

PropertyException

public PropertyException(String message,
                         String errorCode,
                         Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 PropertyException。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串
exception - 链接的异常

PropertyException

public PropertyException(String name,
                         Object value)
构造一个基于属性名称和 value.toString() 设置其消息字段的 PropertyException。

参数：
name - 与此异常相关的属性的名称
value - 与此异常相关的属性的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SchemaOutputResolver (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 SchemaOutputResolver

java.lang.Object
    继承者  javax.xml.bind.SchemaOutputResolver

public abstract class SchemaOutputResolver
extends Object

控制 JAXB 实现放置生成的模式文件的位置。

此抽象类的实现必须由生成模式的调用应用程序提供。

这是一个类，不是接口，这使得以后的版本可在不破坏兼容性的情况下进行改进。

构造方法摘要
SchemaOutputResolver()
方法摘要
abstract  Result createOutput(String namespaceUri, String suggestedFileName)
确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SchemaOutputResolver

public SchemaOutputResolver()
方法详细信息

createOutput

public abstract Result createOutput(String namespaceUri,
                                    String suggestedFileName)
                             throws IOException
确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。

对于任何给定名称空间，此方法只调用一次。换句话说，一个名称空间中的所有组件总是写入相同的模式文档。

参数：
namespaceUri - 模式声明的名称空间 URI。可以为空字符串，但永远不能为 null。
suggestedFileName - JAXB 实现生成一个唯一文件名（如 "schema1.xsd"），以方便调用者使用。此名称可用于模式的文件名，或者调用者可以忽略此名称并提供自己的名称。这只是一个提示。
返回：
封装实际的模式目的地的 Result 对象。如果 Result 对象有系统 ID，则该 ID 必须是绝对系统 ID。这些系统 ID 是相对于调用者的，并且可用于 <xs:import> 语句。如果 Result 对象没有系统 ID，则生成一个用于名称空间 URI 的模式，但它不能从其他模式显式地 <xs:import>。 如果返回 null，则跳过此名称空间 URI 的模式生成。
抛出：
IOException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeConstraintException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 TypeConstraintException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.xml.bind.TypeConstraintException
所有已实现的接口：
Serializable
public class TypeConstraintException
extends RuntimeException

此异常指示已检测到存在违反动态检查的类型约束的情况。

此异常可由生成的模式派生 Java 内容类的设置方法抛出。但是，由于快速修复验证是 JAXB 提供者支持的一项可选功能，所以并非所有设置方法都将在违反类型约束时抛出此异常。

如果在调用快速失败设置方法时抛出此异常，则要保证属性值保持不变，如同从未调用过该设置方法一样。

从以下版本开始：
JAXB1.0
另请参见：
ValidationEvent, 序列化表格

构造方法摘要
TypeConstraintException(String message)
构造带指定详细消息的 TypeConstraintException。
TypeConstraintException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 TypeConstraintException。
TypeConstraintException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 TypeConstraintException。
TypeConstraintException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 TypeConstraintException。
TypeConstraintException(Throwable exception)
构造带有一个 linkedException 的 TypeConstraintException。
方法摘要
String | getErrorCode() 获取特定于供应商的错误代码。
Throwable | getLinkedException() 获取链接的异常。
void | printStackTrace() 打印此 TypeConstraintException 及其对 System.err 的堆栈跟踪（如果为非 null，则包括 linkedException 的堆栈跟踪。
void | printStackTrace(PrintStream s) 打印此 TypeConstraintException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
void | setLinkedException(Throwable exception) 添加一个链接的异常。
String | toString() 返回此 TypeConstraintException 的简短描述。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TypeConstraintException

public TypeConstraintException(String message)
构造带指定详细消息的 TypeConstraintException。errorCode 和 linkedException 将默认为 null。

参数：
message - 对异常的描述

TypeConstraintException

public TypeConstraintException(String message,
                               String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 TypeConstraintException。linkedException 将默认为 null。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串

TypeConstraintException

public TypeConstraintException(Throwable exception)
构造带有一个 linkedException 的 TypeConstraintException。详细消息和特定于供应商的 errorCode 将默认为 null。

参数：
exception - 链接的异常

TypeConstraintException

public TypeConstraintException(String message,
                               Throwable exception)
构造带指定详细消息和 linkedException 的 TypeConstraintException。errorCode 将默认为 null。

参数：
message - 对异常的描述
exception - 链接的异常

TypeConstraintException

public TypeConstraintException(String message,
                               String errorCode,
                               Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 TypeConstraintException。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串
exception - 链接的异常
方法详细信息

getErrorCode

public String getErrorCode()
获取特定于供应商的错误代码。

返回：
指定特定于供应商的错误代码的字符串

getLinkedException

public Throwable getLinkedException()
获取链接的异常。

返回：
链接的异常；如果不存在，则返回 null

setLinkedException

public void setLinkedException(Throwable exception)
添加一个链接的异常。

参数：
exception - 链接的异常（允许使用 null 值，该值指示链接的异常不存在或者是未知的）。

toString

public String toString()
返回此 TypeConstraintException 的简短描述。

覆盖：
类 Throwable 中的 toString
返回：
该 throwable 的字符串表示形式。

printStackTrace

public void printStackTrace(PrintStream s)
打印此 TypeConstraintException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace()
打印此 TypeConstraintException 及其对 System.err 的堆栈跟踪（如果为非 null，则包括 linkedException 的堆栈跟踪。

覆盖：
类 Throwable 中的 printStackTrace
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnmarshalException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 UnmarshalException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.bind.JAXBException
                继承者  javax.xml.bind.UnmarshalException
所有已实现的接口：
Serializable
public class UnmarshalException
extends JAXBException

此异常指示在执行阻止 JAXB 提供者完成操作的解组操作时遇到一个错误。

ValidationEventHandler 可能导致执行解组操作期间抛出此异常。请参阅 ValidationEventHandler.handleEvent(ValidationEvent)。

从以下版本开始：
JAXB1.0
另请参见：
JAXBException, Unmarshaller, ValidationEventHandler, 序列化表格

构造方法摘要
UnmarshalException(String message)
构造带指定详细消息的 UnmarshalException。
UnmarshalException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 UnmarshalException。
UnmarshalException(String message, String errorCode, Throwable exception)
构造带指定详细消息、特定于供应商的 errorCode 和 linkedException 的 UnmarshalException。
UnmarshalException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 UnmarshalException。
UnmarshalException(Throwable exception)
构造带有一个 linkedException 的 UnmarshalException。
方法摘要
从类 javax.xml.bind.JAXBException 继承的方法
getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnmarshalException

public UnmarshalException(String message)
构造带指定详细消息的 UnmarshalException。errorCode 和 linkedException 将默认为 null。

参数：
message - 对异常的描述

UnmarshalException

public UnmarshalException(String message,
                          String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 UnmarshalException。linkedException 将默认为 null。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串

UnmarshalException

public UnmarshalException(Throwable exception)
构造带有一个 linkedException 的 UnmarshalException。详细消息和特定于供应商的 errorCode 将默认为 null。

参数：
exception - 链接的异常

UnmarshalException

public UnmarshalException(String message,
                          Throwable exception)
构造带指定详细消息和 linkedException 的 UnmarshalException。errorCode 将默认为 null。

参数：
message - 对异常的描述
exception - 链接的异常

UnmarshalException

public UnmarshalException(String message,
                          String errorCode,
                          Throwable exception)
构造带指定详细消息、特定于供应商的 errorCode 和 linkedException 的 UnmarshalException。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串
exception - 链接的异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Unmarshaller (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 Unmarshaller

所有已知实现类：
AbstractUnmarshallerImpl
public interface Unmarshaller

Unmarshaller 类管理将 XML 数据反序列化为新创建的 Java 内容树的过程，并可在解组时有选择地验证 XML 数据。它针对各种不同的输入种类提供各种重载的 unmarshal 方法。

从 File 解组：

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();
Object o = u.unmarshal( new File( "nosferatu.xml" ) );

从 InputStream 解组：

InputStream is = new FileInputStream( "nosferatu.xml" );
JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();
Object o = u.unmarshal( is );

从 URL 解组：

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();
URL url = new URL( "http://beaker.east/nosferatu.xml" );
Object o = u.unmarshal( url );

使用 javax.xml.transform.stream.StreamSource 从 StringBuffer 解组：

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();
StringBuffer xmlStr = new StringBuffer( "<?xml version="1.0"?>..." );
Object o = u.unmarshal( new StreamSource( new StringReader( xmlStr.toString() ) ) );

从 org.w3c.dom.Node 解组：

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();

DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
dbf.setNamespaceAware(true);
DocumentBuilder db = dbf.newDocumentBuilder();
Document doc = db.parse(new File( "nosferatu.xml"));

Object o = u.unmarshal( doc );

使用客户端指定的验证 SAX2.0 解析器从 javax.xml.transform.sax.SAXSource 解组：

// configure a validating SAX2.0 parser (Xerces2)
static final String JAXP_SCHEMA_LANGUAGE =
"http://java.sun.com/xml/jaxp/properties/schemaLanguage";
static final String JAXP_SCHEMA_LOCATION =
"http://java.sun.com/xml/jaxp/properties/schemaSource";
static final String W3C_XML_SCHEMA =
"http://www.w3.org/2001/XMLSchema";

System.setProperty( "javax.xml.parsers.SAXParserFactory",
"org.apache.xerces.jaxp.SAXParserFactoryImpl" );

SAXParserFactory spf = SAXParserFactory.newInstance();
spf.setNamespaceAware(true);
spf.setValidating(true);
SAXParser saxParser = spf.newSAXParser();

try {
saxParser.setProperty(JAXP_SCHEMA_LANGUAGE, W3C_XML_SCHEMA);
saxParser.setProperty(JAXP_SCHEMA_LOCATION, "http://....");
} catch (SAXNotRecognizedException x) {
// exception handling omitted
       }

XMLReader xmlReader = saxParser.getXMLReader();
SAXSource source =
new SAXSource( xmlReader, new InputSource( "http://..." ) );

// Setup JAXB to unmarshal
JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();
ValidationEventCollector vec = new ValidationEventCollector();
u.setEventHandler( vec );

// turn off the JAXB provider's default validation mechanism to
// avoid duplicate validation
u.setValidating( false )

// unmarshal
Object o = u.unmarshal( source );

// check for events
if( vec.hasEvents() ) {
// iterate over events
       }

从 StAX XMLStreamReader 解组：

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();

javax.xml.stream.XMLStreamReader xmlStreamReader =
javax.xml.stream.XMLInputFactory().newInstance().createXMLStreamReader( ... );

Object o = u.unmarshal( xmlStreamReader );

从 StAX XMLEventReader 解组：

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();

javax.xml.stream.XMLEventReader xmlEventReader =
javax.xml.stream.XMLInputFactory().newInstance().createXMLEventReader( ... );

Object o = u.unmarshal( xmlEventReader );

解组 XML 数据

解组可以反序列化表示整个 XML 文档或 XML 文档子树的 XML 数据。通常，使用解组全局声明的根元素所描述的 unmarshal 方法便已足够。通过利用全局元素声明和类型定义到 JAXB 映射类的 JAXBContext 映射，这些 unmarshal 方法可以启动对 XML 数据的根元素的解组。当 JAXBContext 映射不足以解组 XML 数据的根元素时，应用程序可以使用借助 declaredType 进行解组的方法帮助解组过程。在 XML 数据的根元素对应于模式中的本地元素声明的情况下，这些方法对于解组很有用。
unmarshal 方法从不返回 null。如果解组过程无法将 XML 内容的根解组到 JAXB 映射对象，则将报告一个致命错误，通过抛出 JAXBException 终止处理过程。

解组全局声明的根元素

不带 declaredType 参数的 unmarshal 方法使用 JAXBContext 来解组 XML 数据的根元素。JAXBContext 实例是用来创建此 Unmarshaller 的实例。JAXBContext 实例维护全局声明的 XML 元素和类型定义名称到 JAXB 映射类的映射。该 unmarshal 方法检查 JAXBContext 是否存在根元素的 XML 名称和/或 @xsi:type 到 JAXB 映射类的映射。如果存在这种映射，则使用适当的 JAXB 映射类来解组 XML 数据。注意，当根元素名称未知且根元素具有 @xsi:type 时，将使用该 JAXB 映射类作为 JAXBElement 值来解组 XML 数据。当 JAXBContext 对象没有根元素名称的映射，也没有其 @xsi:type（如果存在） 的映射时，那么将通过抛出 UnmarshalException 立即中止解组操作。通过使用下一节描述的借助 declaredType 的 unmarshal 方法，可以解决这种异常现象。

借助声明的类型进行解组

带 declaredType 参数的 unmarshal 方法使应用程序即使在根元素 XML 名称的 JAXBContext 中不存在映射时，也能够反序列化 XML 数据的根元素。该 unmarshaller 使用指定为 declaredType 参数的、应用程序提供的映射来解组根元素。注意，即使根元素的元素名称是通过 JAXBContext 映射的，declaredType 参数也会重写该映射，以便在使用这些 unmarshal 方法时反序列化根元素。此外，当 XML 数据的根元素具有 xsi:type 属性，且该属性的值引用一个通过 JAXBContext 映射到 JAXB 映射类的类型定义时，根元素的 xsi:type 属性将优先于 unmarshal 方法的 declaredType 参数。这些方法总是返回一个 JAXBElement<declaredType> 实例。下表显示了如何设置返回 JAXBElement 实例的属性。

通过声明的类型进行解组所返回的 JAXBElement
JAXBElement 属性 | 值
名称 | xml 元素名称
值 | declaredType 的实例
declaredType | unmarshal 方法的 declaredType 参数
作用域 | null （实际作用域未知）

以下是通过 declaredType 进行解组的方法的一个示例。

借助 declaredType 从 org.w3c.dom.Node 解组：

Schema fragment for example
<xs:schema>
<xs:complexType name="FooType">...<\xs:complexType>
<!-- global element declaration "PurchaseOrder" -->
<xs:element name="PurchaseOrder">
<xs:complexType>
<xs:sequence>
<!-- local element declaration "foo" -->
<xs:element name="foo" type="FooType"/>
                    ...
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:schema>

JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
Unmarshaller u = jc.createUnmarshaller();

DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
dbf.setNamespaceAware(true);
DocumentBuilder db = dbf.newDocumentBuilder();
Document doc = db.parse(new File( "nosferatu.xml"));
Element  fooSubtree = ...; // traverse DOM till reach xml element foo, constrained by a
// local element declaration in schema.

// FooType is the JAXB mapping of the type of local element declaration foo.
JAXBElement<FooType> foo = u.unmarshal( fooSubtree, FooType.class);

支持兼容 SAX2.0 的解析器

客户端应用程序能够选择自己的兼容 SAX2.0 的解析器。如果没有选择 SAX 解析器，则将使用 JAXB 提供者的默认解析器。尽管 JAXB 提供者的默认解析器不必是与 SAX2.0 兼容的，但所有提供者必须允许客户端应用程序指定它们自己的 SAX2.0 解析器。一些提供者可能要求客户端应用程序在模式编译时指定 SAX2.0 解析器。有关详细信息，请参阅 unmarshal(Source)。

验证和格式良好性

客户端应用程序可以通过 setSchema(javax.xml.validation.Schema) API 来启用或禁用 JAXP 1.3 验证机制。复杂的客户端可以指定它们自己的兼容 SAX 2.0 的解析器，并使用 unmarshal(Source) API 来绕开 JAXP 1.3 验证机制。

由于要解组的无效 XML 内容是在 JAXB 2.0 中定义的，这使 Unmarshaller 默认的验证事件处理程序比在 JAXB 1.0 中更为宽松。当向 JAXBContext 注册由 JAXB 1.0 绑定解析器所生成的模式派生代码时，默认的解组验证处理程序是 DefaultValidationEventHandler，它将在遇到致命错误（或错误）之后终止编组操作。对于 JAXB 2.0 客户端应用程序，不存在显式定义的默认验证处理程序，默认事件处理只在遇到致命错误时终止编组操作。

支持的属性

当前没有任何需要 Unmarshaller 上的所有 JAXB 提供者都支持的属性。但是，一些提供者可能支持它们自己的特定于提供者的属性集。

解组事件回调

Unmarshaller 提供了两种风格的回调机制，这些机制允许在解组过程的关键点上进行特定于应用程序的处理。在“类定义的”事件回调中，解组期间会触发放置在 JAXB 映射类中的特定于应用程序的代码。“外部侦听器”允许用一个回调方法集中处理解组事件，而不是通过各种类型事件回调处理。

“类定义”的事件回调方法允许任何 JAXB 映射类通过定义带有以下方法签名的方法指定自己的特定回调方法：

// This method is called immediately after the object is created and before the unmarshalling of this
// object begins.The callback provides an opportunity to initialize JavaBean properties prior to unmarshalling.
   void beforeUnmarshal(Unmarshaller, Object parent);

//This method is called after all the properties (except IDREF) are unmarshalled for this object,
//but before this object is set to the parent object.
void afterUnmarshal(Unmarshaller, Object parent);
类定义的回调方法应该在回调方法需要访问类的非公共方法和/或字段时使用。

外部侦听器回调机制允许 Unmarshaller.Listener 实例使用 setListener(Listener) 注册。外部侦听器接收所有回调事件，从而允许用比逐个类地定义回调方法更为集中的方式处理事件。外部侦听器在解组过程将编组到 JAXB 元素或 JAXB 映射类时接收事件。

“类定义的”事件回调方法和外部侦听器事件回调方法相互独立，可以对一个事件同时调用。两种侦听器回调方法都存在时，按照 Unmarshaller.Listener.beforeUnmarshal(Object, Object) 和 Unmarshaller.Listener.afterUnmarshal(Object, Object) 中定义的顺序对它们进行调用。

抛出异常的事件回调方法会终止当前的解组过程。

从以下版本开始：
JAXB 1.0
另请参见：
JAXBContext, Marshaller, Validator

嵌套类摘要
static class Unmarshaller.Listener

向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

方法摘要
<A extends XmlAdapter>
A
getAdapter(Class<A> type)
获取与指定类型关联的适配器。
 AttachmentUnmarshaller getAttachmentUnmarshaller()
 ValidationEventHandler getEventHandler()
返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认的事件处理程序。
 Unmarshaller.Listener getListener()
返回向此 Unmarshaller 注册的 Unmarshaller.Listener。
 Object getProperty(String name)
获取 Unmarshaller 底层实现中的特定属性。
 Schema getSchema()
获取用于执行解组时验证的 JAXP 1.3 Schema 对象。
 UnmarshallerHandler getUnmarshallerHandler()
获取可用作 XML 管线中的组件的 unmarshaller 处理程序对象。
 boolean isValidating()
已过时。 从 JAXB 2.0 开始，请参阅 getSchema()
<A extends XmlAdapter>
void
setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
 void setAdapter(XmlAdapter adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
 void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
将解析 cid（内容 id URI）的上下文与作为附件传递的二进制数据关联。
 void setEventHandler(ValidationEventHandler handler)
允许应用程序注册 ValidationEventHandler。
 void setListener(Unmarshaller.Listener listener)
向此 Unmarshaller 注册解组事件回调 Unmarshaller.Listener。
 void setProperty(String name, Object value)
设置 Unmarshaller 底层实现中的特定属性。
 void setSchema(Schema schema)
指定应用作验证后续解组操作依据的 JAXP 1.3 Schema 对象。
 void setValidating(boolean validating)
已过时。 从 JAXB2.0 开始，请参阅 setSchema(javax.xml.validation.Schema)
 Object unmarshal(File f)
从指定的文件解组 XML 数据并返回得到的内容树。
 Object unmarshal(InputSource source)
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。
 Object unmarshal(InputStream is)
从指定的 InputStream 解组 XML 数据并返回得到的内容树。
 Object unmarshal(Node node)
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
 Object unmarshal(Reader reader)
从指定的 Reader 解组 XML 数据并返回得到的内容树。
 Object unmarshal(Source source)
从指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
 Object unmarshal(URL url)
从指定的 URL 解组 XML 数据并返回得到的内容树。
 Object unmarshal(XMLEventReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
 Object unmarshal(XMLStreamReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

方法详细信息

unmarshal

Object unmarshal(File f)
                 throws JAXBException
从指定的文件解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

参数：
f - 将从中解组 XML 数据的文件
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或着 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 File 参数为 null

unmarshal

Object unmarshal(InputStream is)
                 throws JAXBException
从指定的 InputStream 解组 XML 数据并返回得到的内容树。使用这种形式的 unmarshal API 时，验证事件位置信息可能不完整。

实现解组全局根元素。

参数：
is - 将从中解组 XML 数据的 InputStream
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 InputStream 参数为 null

unmarshal

Object unmarshal(Reader reader)
                 throws JAXBException
从指定的 Reader 解组 XML 数据并返回得到的内容树。使用这种形式的 unmarshal API 时，验证事件位置信息可能不完整，这是因为 Reader 不提供系统 ID。

实现解组全局根元素。

参数：
reader - 将从中解组 XML 数据的 Reader
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 InputStream 参数为 null
从以下版本开始：
JAXB 2.0

unmarshal

Object unmarshal(URL url)
                 throws JAXBException
从指定的 URL 解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

参数：
url - 将从中解组 XML 数据的 URL
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 URL 参数为 null

unmarshal

Object unmarshal(InputSource source)
                 throws JAXBException
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

参数：
source - 将从中解组 XML 数据的输入源
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 InputSource 参数为 null

unmarshal

Object unmarshal(Node node)
                 throws JAXBException
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。

实现解组全局根元素。

参数：
node - 要从中解组 XML 数据的文档/元素。调用者至少必须支持 Document 和 Element。
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 Node 参数为 nul
另请参见：
unmarshal(org.w3c.dom.Node, Class)

unmarshal

<T> JAXBElement<T> unmarshal(Node node,
                             Class<T> declaredType)
                         throws JAXBException
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。

实现借助声明的类型进行解组。

参数：
node - 从中解组 XML 数据的文档/元素。调用者至少必须支持 Document 和 Element。
declaredType - 用来保存 node 的 XML 数据的适当 JAXB 映射类。
返回：
node 的 JAXB Element 表示形式
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果任何参数为 null
从以下版本开始：
6.0

unmarshal

Object unmarshal(Source source)
                 throws JAXBException
从指定的 XML Source 解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

SAX 2.0 解析器的可插入性

客户端应用程序可以选择不使用随 JAXB 提供者一起提供的默认解析器机制。任何兼容 SAX 2.0 的解析器都可以取代 JAXB 提供者的默认机制。要实现这一点，客户端应用程序必须正确配置一个包含 XMLReader 的 SAXSource，并且该 XMLReader 是由 SAX 2.0 解析器提供者实现的。如果 XMLReader 有一个向它注册的 org.xml.sax.ErrorHandler，则将使用 JAXB 提供者替换它，以便通过 JAXB 的 ValidationEventHandler 机制报告验证错误。如果 SAXSource 不包含 XMLReader，则将使用 JAXB 提供者的默认解析器机制。

也可以使用此解析器替换机制来替换 JAXB 提供者的解组时验证引擎。客户端应用程序必须正确配置其兼容 SAX 2.0 的解析器来执行验证（如上例所示）。解析器在解组操作期间遇到的任何 SAXParserExceptions 都将由 JAXB 提供者处理，并将其转换为 JAXB ValidationEvent 对象，这些对象将通过已经向 Unmarshaller 注册的 ValidationEventHandler 报告给客户端。注： 在为了实现解组而指定一个替换验证 SAX 2.0 解析器时，无需替换 JAXB 提供者使用的验证引擎来执行按需应变的验证。

客户端应用程序指定将在解组期间使用的替换解析器机制的唯一方法是通过 unmarshal(SAXSource) API。所有其他形式的 unmarshal 方法（文件、URL、Node 等等）将使用 JAXB 提供者的默认解析器和验证器机制。

参数：
source - 将从中解组 XML 数据的 XML Source（提供者只需支持 SAXSource、DOMSource 和 StreamSource）
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 Source 参数为 nul
另请参见：
unmarshal(javax.xml.transform.Source, Class)

unmarshal

<T> JAXBElement<T> unmarshal(Source source,
                             Class<T> declaredType)
                         throws JAXBException
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。

实现借助声明的类型进行解组。

请参阅 SAX 2.0 解析器的可插入性

参数：
source - 将从中解组 XML 数据的 XML Source（提供者只需支持 SAXSource、DOMSource 和 StreamSource）
declaredType - 用来保存 source 的 xml 根元素的适当 JAXB 映射类
返回：
通过 JAXB Element 确定的 Java 内容
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果任何参数为 null
从以下版本开始：
JAXB 2.0

unmarshal

Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

此方法假定该解析器处于 START_DOCUMENT 或 START_ELEMENT 事件上。解组将从起始事件开始，到相应的终止事件结束。如果此方法成功返回，则 reader 将指向终止事件后面的标记。

参数：
reader - 要读取的解析器。
返回：
新创建的 java 内容树的根对象。
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 reader 参数为 null
IllegalStateException - 如果 reader 没有指向 START_DOCUMENT 或 START_ELEMENT 事件。
从以下版本开始：
JAXB 2.0
另请参见：
unmarshal(javax.xml.stream.XMLStreamReader, Class)

unmarshal

<T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                             Class<T> declaredType)
                         throws JAXBException
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

此方法实现借助 declaredType 进行解组。

此方法假定该解析器处于 START_DOCUMENT 或 START_ELEMENT 事件上。解组将从起始事件开始，到相应的终止事件结束。如果此方法成功返回，则 reader 将指向终止事件后面的标记。

参数：
reader - 要读取的解析器。
declaredType - 用来保存 reader 的 START_ELEMENT XML 数据的适当 JAXB 映射类。
返回：
通过 JAXB Element 表示形式确定的内容树
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果任何参数为 null
从以下版本开始：
JAXB 2.0

unmarshal

Object unmarshal(XMLEventReader reader)
                 throws JAXBException
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。

此方法是一个解组全局根方法。

此方法假定该解析器处于 START_DOCUMENT 或 START_ELEMENT 事件上。解组将从起始事件开始，到相应的终止事件结束。如果此方法成功返回，则 reader 将指向终止事件后面的标记。

参数：
reader - 要读取的解析器。
返回：
新创建的 java 内容树的根对象。
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果 reader 参数为 null
IllegalStateException - 如果 reader 没有指向 START_DOCUMENT 或 START_ELEMENT 事件。
从以下版本开始：
JAXB 2.0
另请参见：
unmarshal(javax.xml.stream.XMLEventReader, Class)

unmarshal

<T> JAXBElement<T> unmarshal(XMLEventReader reader,
                             Class<T> declaredType)
                         throws JAXBException
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

此方法实现借助 declaredType 进行解组。

此方法假定该解析器处于 START_DOCUMENT 或 START_ELEMENT 事件上。解组将从起始事件开始，到相应的终止事件结束。如果此方法成功返回，则 reader 将指向终止事件后面的标记。

参数：
reader - 要读取的解析器。
declaredType - 用来保存 reader 的 START_ELEMENT XML 数据的适当 JAXB 映射类。
返回：
通过 JAXB Element 表示形式确定的内容树
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
IllegalArgumentException - 如果任何参数为 null
从以下版本开始：
JAXB 2.0

getUnmarshallerHandler

UnmarshallerHandler getUnmarshallerHandler()
获取可用作 XML 管线中的组件的 unmarshaller 处理程序对象。

JAXB 提供者可以为此方法的多次调用返回相同的处理程序对象。换句话说，此方法不必创建新的 UnmarshallerHandler 实例。如果应用程序需要使用多个 UnmarshallerHandler，那么它应该创建多个 Unmarshaller。

返回：
返回 unmarshaller 处理程序对象
另请参见：
UnmarshallerHandler

setValidating

void setValidating(boolean validating)
                   throws JAXBException
已过时。 从 JAXB2.0 开始，请参阅 setSchema(javax.xml.validation.Schema)

指定 Unmarshaller 的默认验证机制是否应在解组操作期间执行验证。默认情况下，Unmarshaller 不执行验证。

此方法只能在调用某一 unmarshal 方法之前或之后调用。

此方法只控制 JAXB 提供者的默认解组时验证机制，不会影响指定自己的验证兼容 SAX 2.0 的解析器的客户端。指定自己的解组时验证机制的客户端可能希望通过此 API 关闭 JAXB 提供者的默认验证机制，以避免“双重验证”。

此方法从 JAXB 2.0 开始已经废弃，请使用新的 setSchema(javax.xml.validation.Schema) API。

参数：
validating - 如果 Unmarshaller 应该在解组期间执行验证，则该参数为 true；否则为 false
抛出：
JAXBException - 如果在解组期间启用或禁用验证时发生错误
UnsupportedOperationException - 如果对根据引用 JAXB 2.0 映射类的 JAXBContext 而创建的 Unmarshaller 调用此方法，则抛出该异常

isValidating

boolean isValidating()
                     throws JAXBException
已过时。 从 JAXB 2.0 开始，请参阅 getSchema()

指示是否将 Unmarshaller 配置为在解组操作期间执行验证。

此 API 返回 JAXB 提供者的默认解组时验证机制的状态。

此方法从 JAXB 2.0 开始已经废弃，请使用新的 getSchema() API。

返回：
如果将 Unmarshaller 配置为在解组操作期间执行验证，则返回 true；否则返回 false
抛出：
JAXBException - 如果在检索验证标志时发生错误
UnsupportedOperationException - 如果对根据引用 JAXB 映射类的 JAXBContext 而创建的 Unmarshaller 调用此方法，则抛出该异常

setEventHandler

void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
允许应用程序注册 ValidationEventHandler。

如果在调用任何 unmarshal 方法期间遇到任何错误，则 ValidationEventHandler 将由 JAXB 提供者调用。如果客户端应用程序没有在调用 unmarshal 方法之前注册 ValidationEventHandler，则 ValidationEvents 将由默认事件处理程序处理，默认事件处理程序将在遇到第一个错误或致命错误时终止解组操作。

调用带有 null 参数的此方法将导致 Unmarshaller 重新使用默认事件处理程序。

参数：
handler - 验证事件处理程序
抛出：
JAXBException - 如果在设置事件处理程序期间遇到错误

getEventHandler

ValidationEventHandler getEventHandler()
                                       throws JAXBException
返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认的事件处理程序。

返回：
当前的 ValidationEventHandler，如果没有设置处理程序，则返回默认的事件处理程序
抛出：
JAXBException - 如果获取当前的事件处理程序时遇到错误

setProperty

void setProperty(String name,
                 Object value)
                 throws PropertyException
设置 Unmarshaller 底层实现中的特定属性。此方法只能用于设置上文中标准 JAXB 定义的属性之一或特定于提供者的属性。试图设置未定义的属性将导致抛出 PropertyException。请参阅支持的属性。

参数：
name - 要设置的属性的名称。此值可以使用一个常量字段来指定，也可以是一个用户提供的字符串。
value - 要设置的属性值
抛出：
PropertyException - 如果处理给定属性或值时发生错误
IllegalArgumentException - 如果 name 参数为 null

getProperty

Object getProperty(String name)
                   throws PropertyException
获取 Unmarshaller 底层实现中的特定属性。此方法只能用于获取上文中标准 JAXB 定义的属性之一或特定于提供者的属性。试图获取未定义的属性将导致抛出 PropertyException。请参阅支持的属性。

参数：
name - 要检索的属性的名称
返回：
所请求属性的值
抛出：
PropertyException - 如果检索给定属性或值属性名称时发生错误
IllegalArgumentException - 如果 name 参数为 null

setSchema

void setSchema(Schema schema)
指定应用作验证后续解组操作依据的 JAXP 1.3 Schema 对象。向此方法传递 null 将禁用验证。

此方法将替换已过时的 setValidating(boolean) API。

最初，此属性被设置为 null。

参数：
schema - 作为验证解组操作依据的 Schema 对象；为 null 表示禁用验证
抛出：
UnsupportedOperationException - 如果对根据引用 JAXB 1.0 映射类的 JAXBContext 而创建的 Unmarshaller 调用此方法，则抛出该异常
从以下版本开始：
JAXB 2.0

getSchema

Schema getSchema()
获取用于执行解组时验证的 JAXP 1.3 Schema 对象。如果没有在 unmarshaller 上设置 Schema，则此方法将返回 null，指示不会执行解组时验证。

此方法用于替换已过时的 isValidating() API，并可访问 Schema 对象。要确定 Unmarshaller 是否启用了验证，只需测试返回类型是否为 null：

boolean isValidating = u.getSchema()!=null;

返回：
返回用于执行解组时验证的 Schema 对象；如果该对象不存在，则返回 null
抛出：
UnsupportedOperationException - 如果对根据引用 JAXB 1.0 映射类的 JAXBContext 而创建的 Unmarshaller 调用此方法，则抛出该异常
从以下版本开始：
JAXB 2.0

setAdapter

void setAdapter(XmlAdapter adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。

这是调用 setAdapter(adapter.getClass(),adapter); 的一个便捷方法。

抛出：
IllegalArgumentException - 如果 adapter 参数为 null。
UnsupportedOperationException - 如果基于 JAXB 1.0 实现调用。
从以下版本开始：
JAXB 2.0
另请参见：
setAdapter(Class,XmlAdapter)

setAdapter

<A extends XmlAdapter> void setAdapter(Class<A> type,
                                       A adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。

每个 unmarshaller 都可以在内部维护一个 Map<Class,XmlAdapter>，可用来解组使用 XmlJavaTypeAdapter 注释其字段/方法的类。

此方法允许应用程序使用已配置好的 XmlAdapter 实例。如果没有给出适配器实例，则 unmarshaller 将调用其默认构造方法创建一个实例。

参数：
type - 适配器的类型。当 XmlJavaTypeAdapter.value() 引用此类型时，将使用指定的实例。
adapter - 将要使用的适配器实例。如果为 null，则将注销此类型的当前适配器集合。
抛出：
IllegalArgumentException - 如果 type 参数为 null。
UnsupportedOperationException - 如果基于 JAXB 1.0 实现调用。
从以下版本开始：
JAXB 2.0

getAdapter

<A extends XmlAdapter> A getAdapter(Class<A> type)
获取与指定类型关联的适配器。 这是 setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) 方法的反向操作。

抛出：
IllegalArgumentException - 如果 type 参数为 null。
UnsupportedOperationException - 如果基于 JAXB 1.0 实现调用。
从以下版本开始：
JAXB 2.0

setAttachmentUnmarshaller

void setAttachmentUnmarshaller(AttachmentUnmarshaller au)

将解析 cid（内容 id URI）的上下文与作为附件传递的二进制数据关联。

通过 setSchema(Schema) 启用的解组时验证，即使在 unmarshaller 执行 XOP 处理时也必须支持。

抛出：
IllegalStateException - 如果试图在解组操作期间同时调用此方法。

getAttachmentUnmarshaller

AttachmentUnmarshaller getAttachmentUnmarshaller()

setListener

void setListener(Unmarshaller.Listener listener)

向此 Unmarshaller 注册解组事件回调 Unmarshaller.Listener。

每个 Unmarshaller 只有一个 Listener。设置 Listener 将替换以前设置的 Listener。通过将 listener 设置为 null 可注销当前的 Listener。

参数：
listener - 为此 Unmarshaller 提供解组事件回调
从以下版本开始：
JAXB 2.0

getListener

Unmarshaller.Listener getListener()

返回向此 Unmarshaller 注册的 Unmarshaller.Listener。

返回：
注册的 Unmarshaller.Listener；如果未向此 Unmarshaller 注册任何 Listener，则返回 null。
从以下版本开始：
JAXB 2.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Unmarshaller.Listener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 Unmarshaller.Listener

java.lang.Object
    继承者  javax.xml.bind.Unmarshaller.Listener
正在封闭接口：
Unmarshaller
public abstract static class Unmarshaller.Listener
extends Object

向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

此类可以在将 XML 数据解组到 JAXB 映射类中时启用对 JAXB 映射类实例的预处理和后处理。在将 XML 内容解组到 JAXBElement 实例或表示复杂类型定义的 JAXB 映射类中时，将调用事件回调。解组到表示简单类型定义的 Java 数据类型的实例时，不需要调用事件回调。

外部侦听器是用于定义解组事件回调的两个不同机制之一。请参阅 Unmarshal Event Callbacks 获得对这方面的概括。

(@link #setListener(Listener)} (@link #getListener()}

从以下版本开始：
JAXB2.0

构造方法摘要
Unmarshaller.Listener()
方法摘要
void | afterUnmarshal(Object target, Object parent) 将 XML 数据解组到 target 之后调用的回调方法。
void | beforeUnmarshal(Object target, Object parent) 在解组到 target 之前调用的回调方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Unmarshaller.Listener

public Unmarshaller.Listener()
方法详细信息

beforeUnmarshal

public void beforeUnmarshal(Object target,
                            Object parent)

在解组到 target 之前调用的回调方法。

在创建 target 之后且在开始解组此对象之前立即调用此方法。注意，如果 target 的类定义了自己的 beforeUnmarshal 方法，则在调用此方法之前调用特定于类的回调方法。

参数：
target - 解组之前的 JAXB 映射类的非 null 实例。
parent - 将最终引用 target 的 JAXB 映射类的实例。当 target 是根元素时，该参数为 null。

afterUnmarshal

public void afterUnmarshal(Object target,
                           Object parent)

将 XML 数据解组到 target 之后调用的回调方法。

在将所有属性（IDREF 除外）解组到 target 之后、但在将 target 设置为其 parent 对象之前调用此方法。注意，如果 target 的类定义了自己的 afterUnmarshal 方法，则在调用此方法之前调用特定于类的回调方法。

参数：
target - 解组之前的 JAXB 映射类的非 null 实例。
parent - 将引用 target 的 JAXB 映射类的实例。当 target 是根元素时，该参数为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnmarshallerHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 UnmarshallerHandler

所有超级接口：
ContentHandler
public interface UnmarshallerHandler
extends ContentHandler

作为 SAX ContentHandler 实现的 Unmarshaller。

应用程序可以使用此接口将其 JAXB 提供者用作 XML 管线中的一个组件。例如：

JAXBContext context = JAXBContext.newInstance( "org.acme.foo" );

Unmarshaller unmarshaller = context.createUnmarshaller();

UnmarshallerHandler unmarshallerHandler = unmarshaller.getUnmarshallerHandler();

SAXParserFactory spf = SAXParserFactory.newInstance();
spf.setNamespaceAware( true );

XMLReader xmlReader = spf.newSAXParser().getXMLReader();
xmlReader.setContentHandler( unmarshallerHandler );
xmlReader.parse(new InputSource( new FileInputStream( XML_FILE ) ) );

MyObject myObject= (MyObject)unmarshallerHandler.getResult();

此接口是可重用的：即使用户解组某一对象时失败，她/他仍可开始新一轮的解组。

从以下版本开始：
JAXB1.0
另请参见：
Unmarshaller.getUnmarshallerHandler()

方法摘要
 Object getResult()
获得解组的结果。
从接口 org.xml.sax.ContentHandler 继承的方法
characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

方法详细信息

getResult

Object getResult()
                 throws JAXBException,
                        IllegalStateException
获得解组的结果。此方法只能在此处理程序接收 endDocument SAX 事件之后调用。

返回：
总是返回被解组的非 null 有效对象。
抛出：
IllegalStateException - 如果在此处理程序接收 endDocument 事件之前调用此方法。
JAXBException - 如果出现任何解组错误。注意，允许该实现在解析错误期间抛出 SAXException。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValidationEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 ValidationEvent

所有已知子接口：
NotIdentifiableEvent, ParseConversionEvent, PrintConversionEvent
所有已知实现类：
NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl, ValidationEventImpl
public interface ValidationEvent

此事件指示在执行解组操作期间验证传入的 XML 数据时、对 Java 内容树执行按需验证时或将 Java 内容树编组回 XML 数据时遇到问题。

从以下版本开始：
JAXB1.0
另请参见：
Validator, ValidationEventHandler

字段摘要
static int | ERROR 对应于 W3C XML 1.0 Recommendation 第 1.2 节中的“错误”的定义的条件。
static int | FATAL_ERROR 对应于 W3C XML 1.0 Recommendation 第 1.2 节中的“致命错误”的定义的条件。
static int | WARNING 根据 XML 1.0 Recommendation 的定义，不属于错误或致命错误的那些条件。
方法摘要
Throwable | getLinkedException() 检索此警告/错误的链接异常。
ValidationEventLocator | getLocator() 检索此警告/错误的定位符。
String | getMessage() 检索此警告/错误的文本消息。
int | getSeverity() 检索此警告/错误的严重性代码。

字段详细信息

WARNING

static final int WARNING
根据 XML 1.0 Recommendation 的定义，不属于错误或致命错误的那些条件。

另请参见：
常量字段值

ERROR

static final int ERROR
对应于 W3C XML 1.0 Recommendation 第 1.2 节中的“错误”的定义的条件。

另请参见：
常量字段值

FATAL_ERROR

static final int FATAL_ERROR
对应于 W3C XML 1.0 Recommendation 第 1.2 节中的“致命错误”的定义的条件。

另请参见：
常量字段值
方法详细信息

getSeverity

int getSeverity()
检索此警告/错误的严重性代码。

必须是 ValidationError.WARNING、ValidationError.ERROR 或 ValidationError.FATAL_ERROR 之一。

返回：
此警告/错误的严重性代码

getMessage

String getMessage()
检索此警告/错误的文本消息。

返回：
此警告/错误的文本消息；如果没有设置此消息，则返回 null

getLinkedException

Throwable getLinkedException()
检索此警告/错误的链接异常。

返回：
此警告/错误的链接异常；如果未设置此异常，则返回 null

getLocator

ValidationEventLocator getLocator()
检索此警告/错误的定位符。

返回：
指示发生此警告/错误的位置的定位符
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValidationEventHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 ValidationEventHandler

所有已知实现类：
DefaultValidationEventHandler, ValidationEventCollector
public interface ValidationEventHandler

用来验证错误的基本事件处理程序接口。

如果应用程序需要实现自定义事件处理，那么它必须实现此接口，然后向 Unmarshaller、Validator 或 Marshaller 注册。JAXB 提供者随后将向这些事件处理程序报告在执行解组、编组和验证操作期间遇到的验证错误和警告。

如果 handleEvent 方法抛出未经检查的运行时异常，则 JAXB 提供者必须像该方法返回 false 那样作出相应对待，有效地终止当时正在运行的任何操作（解组、验证或编组）。

在事件处理程序中修改 Java 内容树不是规范中定义的行为，并且可能导致不可预料的行为。

遇到致命错误后未能从 handleEvent 方法返回 false 也不是一种规范中定义的行为，并且可能导致不可预料的行为。

默认事件处理程序

请参阅：Validator javadocs

从以下版本开始：
JAXB1.0
另请参见：
Unmarshaller, Validator, Marshaller, ValidationEvent, ValidationEventCollector

方法摘要
 boolean handleEvent(ValidationEvent event)
接收验证警告或错误的通知。

方法详细信息

handleEvent

boolean handleEvent(ValidationEvent event)
接收验证警告或错误的通知。ValidationEvent 将 ValidationEventLocator 嵌入通知中，以指示发生错误或警告的位置。

如果从此方法抛出未经检查的运行时异常，则 JAXB 提供者会像该方法返回 false 那样作出相应对待，并中断当前的解组、验证和编组操作。

参数：
event - 封装的验证事件信息。如果为 null，则该信息是一个提供者错误。
返回：
如果 JAXB 提供者应该在处理此警告/错误之后尝试继续执行当前的解组、验证或编组操作，则返回 true；如果提供者应该使用适当的 UnmarshalException、ValidationException 或 MarshalException 终止当前操作，则返回 false。
抛出：
IllegalArgumentException - 如果事件对象为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValidationEventLocator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 ValidationEventLocator

所有已知实现类：
ValidationEventLocatorImpl
public interface ValidationEventLocator

封装 ValidationEvent 的位置。

该 ValidationEventLocator 指示发生 ValidationEvent 的位置。根据检测到错误或警告时将要执行的验证类型来设置不同的字段。例如，按需验证（on-demand validation）应生成包含对 Java 内容树中对象的引用的定位符，而解组时验证（unmarshal-time validation）应生成包含适用于 XML 数据源（文件、url、Node 等）的信息的定位符。

从以下版本开始：
JAXB1.0
另请参见：
Validator, ValidationEvent

方法摘要
int | getColumnNumber() 返回列号（如果可用）。
int | getLineNumber() 返回行号（如果可用）。
Node | getNode() 返回对 DOM Node 的引用（如果可用）。
Object | getObject() 返回对 Java 内容树中对象的引用（如果可用）。
int | getOffset() 返回字节偏移量（如果可用）。
URL | getURL() 返回 URL 形式的 XML 源名称（如果可用）。

方法详细信息

getURL

URL getURL()
返回 URL 形式的 XML 源名称（如果可用）。

返回：
返回 URL 形式的 XML 源名称；如果没有可用的名称，则返回 null

getOffset

int getOffset()
返回字节偏移量（如果可用）。

返回：
到输入源的字节偏移量，如果不可用，则返回 -1

getLineNumber

int getLineNumber()
返回行号（如果可用）。

返回：
行号；如果不可用，则返回 -1

getColumnNumber

int getColumnNumber()
返回列号（如果可用）。

返回：
列号；如果不可用，则返回 -1

getObject

Object getObject()
返回对 Java 内容树中对象的引用（如果可用）。

返回：
对 Java 内容树中对象的引用；如果不可用，则返回 null

getNode

Node getNode()
返回对 DOM Node 的引用（如果可用）。

返回：
对 DOM Node 的引用；如果不可用，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValidationException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
类 ValidationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.bind.JAXBException
                继承者  javax.xml.bind.ValidationException
所有已实现的接口：
Serializable
public class ValidationException
extends JAXBException

此异常指示在执行验证操作时发生错误。

ValidationEventHandler 可能导致执行验证操作期间抛出此异常。请参阅 ValidationEventHandler.handleEvent(ValidationEvent)。

从以下版本开始：
JAXB1.0
另请参见：
JAXBException, Validator, 序列化表格

构造方法摘要
ValidationException(String message)
构造带指定详细消息的 ValidationException。
ValidationException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 ValidationException。
ValidationException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 ValidationException。
ValidationException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 ValidationException。
ValidationException(Throwable exception)
构造带有一个 linkedException 的 ValidationException。
方法摘要
从类 javax.xml.bind.JAXBException 继承的方法
getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ValidationException

public ValidationException(String message)
构造带指定详细消息的 ValidationException。errorCode 和 linkedException 将默认为 null。

参数：
message - 对异常的描述

ValidationException

public ValidationException(String message,
                           String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 ValidationException。linkedException 将默认为 null。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串

ValidationException

public ValidationException(Throwable exception)
构造带有一个 linkedException 的 ValidationException。详细消息和特定于供应商的 errorCode 将默认为 null。

参数：
exception - 链接的异常

ValidationException

public ValidationException(String message,
                           Throwable exception)
构造带指定的详细消息和 linkedException 的 ValidationException。errorCode 将默认为 null。

参数：
message - 对异常的描述
exception - 链接的异常

ValidationException

public ValidationException(String message,
                           String errorCode,
                           Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 ValidationException。

参数：
message - 对异常的描述
errorCode - 指定特定于供应商的错误代码的字符串
exception - 链接的异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Validator (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind
接口 Validator

已过时。 从 JAXB 2.0 开始

public interface Validator

自 JAXB 2.0 开始，此类已过时，成为一个可选项。

该 Validator 类负责控制运行时期间对内容树的验证。

三种形式的验证

解组时验证
这种形式的验证使客户端应用程序能够接收关于将 XML 数据解组到 Java 内容树中时检测到的验证错误和警告的信息，并且与其他类型的验证完全没有关系。要启用或禁用它，请参阅 Unmarshaller.setValidating 的 javadoc。所有 JAXB 1.0 提供者都必须支持此操作。
按需验证
这种形式的验证使客户端应用程序能够接收关于在 Java 内容树中检测到的验证错误和警告的信息。客户端应用程序在任何点上都可以在 Java 内容树（或其任意子树）上调用 Validator.validate 方法。所有 JAXB 1.0 提供这都必须支持此操作。
快速失败验证
当对 Java 内容树所做的修改违反规范中定义的 Java 属性的类型约束时，这种形式的验证使客户端应用程序能够接收关于这些修改的即时反馈。JAXB 提供者不需要支持这种类型的验证。在不支持这种类型的验证的 JAXB 提供者中，一些提供者可能要求在模式编译时确定是否允许客户端应用程序在运行时请求进行快速失败验证。

Validator 类负责管理按需验证。Unmarshaller 类负责管理解组操作期间的解组时验证。虽然没有在编组操作期间启用验证的正式方法，但 Marshaller 可以检测错误，并将这些错误报告给已在它自身上注册的 ValidationEventHandler。

使用默认事件处理程序

如果客户端应用程序没有在调用 validate、unmarshal 或 marshal 方法之前在其 Validator、Unmarshaller 或 Marshaller 上设置事件处理程序，则默认事件处理程序将接收遇到的所有错误或警告的通知。默认事件处理程序将使当前操作在遇到第一个错误或致命错误之后暂停（但将在接收警告后尝试继续完成操作）。

处理验证事件

有三种处理解组、验证和编组期间遇到的事件的方式：
使用默认事件处理程序
如果没有通过 setEventHandler API 在 Validator、Unmarshaller 或 Marshaller 上指定事件处理程序，则将使用默认事件处理程序。
实现和注册一个自定义事件处理程序
复杂事件处理的客户端应用程序可以实现 ValidationEventHandler 接口，并向 Unmarshaller 和/或 Validator 注册它。
使用 ValidationEventCollector 实用工具
为了方便起见，可以提供特殊的事件处理程序，只收集执行解组、验证和编组操作期间创建的任何 ValidationEvent 对象，并将它们作为 java.util.Collection 返回给客户端应用程序。

验证和格式良好

验证事件的处理因为客户端应用程序配置方式的不同而各有不同，以便能够按前一节中描述的方式处理它们。但是，在某些情况下，JAXB 提供者指示无法再以可靠的方式检测和报告错误。在这些情况下，JAXB 提供者会将 ValidationEvent 的严重性设置为 FATAL_ERROR，以指示应该终止解组、验证或编组操作。默认事件处理程序和 ValidationEventCollector 实用工具类必须在收到致命错误通知后终止处理。提供自己的 ValidationEventHandler 的客户端应用程序也应该在收到致命错误通知后终止处理。如果不终止处理，则可能发生不可预料的行为。

支持的属性

当前没有任何需要 Validator 上的所有 JAXB 提供者都支持的属性。但是，一些提供者可能支持它们自己的特定于提供者的属性集。

从以下版本开始：
JAXB1.0
另请参见：
JAXBContext, Unmarshaller, ValidationEventHandler, ValidationEvent, ValidationEventCollector

方法摘要
ValidationEventHandler | getEventHandler() 已过时。 从 JAXB2.0 开始
Object | getProperty(String name) 已过时。 从 JAXB2.0 开始
void | setEventHandler(ValidationEventHandler handler) 已过时。 从 JAXB2.0 开始
void | setProperty(String name, Object value) 已过时。 从 JAXB2.0 开始
boolean | validate(Object subrootObj) 已过时。 从 JAXB2.0 开始
boolean | validateRoot(Object rootObj) 已过时。 从 JAXB2.0 开始

方法详细信息

setEventHandler

void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
已过时。 从 JAXB2.0 开始

允许应用程序注册一个验证事件处理程序。

如果调用 validate 期间遇到任何验证错误，则 JAXB 提供者将调用验证事件处理程序。如果客户端应用程序没有在调用验证方法之前注册验证事件处理程序，那么验证事件将由默认事件处理程序处理，默认事件处理程序将在遇到第一个错误或致命错误之后终止验证操作。

调用带有 null 参数的此方法将导致 Validator 重新使用默认事件处理程序。

参数：
handler - 验证事件处理程序
抛出：
JAXBException - 如果在设置事件处理程序期间遇到错误

getEventHandler

ValidationEventHandler getEventHandler()
                                       throws JAXBException
已过时。 从 JAXB2.0 开始

返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认事件处理程序。

返回：
当前的 ValidationEventHandler，如果没有设置该处理程序，则返回默认事件处理程序
抛出：
JAXBException - 如果在设置当前事件处理程序时遇到错误

validate

boolean validate(Object subrootObj)
                 throws JAXBException
已过时。 从 JAXB2.0 开始

从 subrootObj 开始验证 Java 内容树。

客户端应用程序可以使用此方法在运行时根据需要来验证 Java 内容树。此方法可用于验证 Java 内容树的任意子树。全局约束检查不会作为此操作的一部分执行（即 ID/IDREF 约束）。

参数：
subrootObj - 将从其所在位置开始执行验证的对象
返回：
如果以 subrootObj 为根的子树有效，则返回 true；否则返回 false
抛出：
JAXBException - 如果验证期间发生任何预料不到的问题
ValidationException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Validator 无法验证以 subrootObj 为根的内容树
IllegalArgumentException - 如果 subrootObj 参数为 null

validateRoot

boolean validateRoot(Object rootObj)
                     throws JAXBException
已过时。 从 JAXB2.0 开始

验证以 rootObj 为根的 Java 内容树。

客户端应用程序可以使用此方法在运行时根据需要来验证 Java 内容树。此方法用于验证整个 Java 内容树。全局约束检查将作为此操作的一部分执行（即 ID/IDREF 约束）。

参数：
rootObj - 将从其所在位置开始执行验证的根对象
返回：
如果以 rootObj 为根的树有效，则返回 true；否则返回 false
抛出：
JAXBException - 如果验证期间发生任何不可预料的问题
ValidationException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Validator 无法验证以 rootObj 为根的内容树
IllegalArgumentException - 如果 rootObj 参数为 null

setProperty

void setProperty(String name,
                 Object value)
                 throws PropertyException
已过时。 从 JAXB2.0 开始

设置 Validator 底层实现中的特定属性。此方法只能用于设置上文中标准 JAXB 定义的属性之一或特定于提供者的属性。试图设置未定义的属性将导致抛出 PropertyException。请参阅支持的属性。

参数：
name - 要设置的属性的名称。此值可以使用一个常量字段来指定，也可以是用户提供的字符串。
value - 要设置的属性值
抛出：
PropertyException - 如果处理给定属性或值时发生错误
IllegalArgumentException - 如果 name 参数为 null

getProperty

Object getProperty(String name)
                   throws PropertyException
已过时。 从 JAXB2.0 开始

获取 Validator 底层实现中的特定属性。此方法只可用于获取上文中标准 JAXB 定义的属性之一或特定于提供者的属性。试图获取未定义的属性将导致抛出 PropertyException。请参阅支持的属性。

参数：
name - 将检索的属性的名称
返回：
所请求属性的值
抛出：
PropertyException - 如果检索给定属性或值属性名称时发生错误
IllegalArgumentException - 如果 name 参数为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.bind (Java Platform SE 6)

 javax.xml.bind
接口
DatatypeConverterInterface
Element
Marshaller
NotIdentifiableEvent
ParseConversionEvent
PrintConversionEvent
Unmarshaller
UnmarshallerHandler
ValidationEvent
ValidationEventHandler
ValidationEventLocator
Validator
类
Binder
DatatypeConverter
JAXBContext
JAXBElement
JAXBElement.GlobalScope
JAXBIntrospector
Marshaller.Listener
SchemaOutputResolver
Unmarshaller.Listener
异常
JAXBException
MarshalException
PropertyException
TypeConstraintException
UnmarshalException
ValidationException


javax.xml.bind (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.bind

为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

请参见：
描述

接口摘要
DatatypeConverterInterface | 该 DatatypeConverterInterface 仅适用于 JAXB 提供者。
Element | 这是一个元素标记接口。
Marshaller | Marshaller 类负责管理将 Java 内容树序列化回 XML 数据的过程。
NotIdentifiableEvent | 此事件指示解析 ID/IDREF 时遇到一个问题。
ParseConversionEvent | 此事件指示将 XML 数据中的字符串转换为目标 Java 数据类型的值时遇到一个问题。
PrintConversionEvent | 此事件指示将 Java 内容树中的数据转换为其词汇表示形式时遇到一个问题。
Unmarshaller | Unmarshaller 类管理将 XML 数据反序列化为新创建的 Java 内容树的过程，并可在解组时有选择地验证 XML 数据。
UnmarshallerHandler | 作为 SAX ContentHandler 实现的 Unmarshaller。
ValidationEvent | 此事件指示在执行解组操作期间验证传入的 XML 数据时、对 Java 内容树执行按需验证时或将 Java 内容树编组回 XML 数据时遇到问题。
ValidationEventHandler | 用来验证错误的基本事件处理程序接口。
ValidationEventLocator | 封装 ValidationEvent 的位置。
Validator | 已过时。 从 JAXB 2.0 开始

类摘要
Binder<XmlNode> | 在 XML 信息集节点和表示相同 XML 文档的 JAXB 对象之间启用同步。
DatatypeConverter | 可以使用 javaType 绑定声明来自定义 XML 模式数据类型到 Java 数据类型的绑定。
JAXBContext | JAXBContext 类提供到 JAXB API 的客户端入口点。
JAXBElement<T> | Xml 元素的 JAXB 表示形式。
JAXBElement.GlobalScope | 为 xml 元素指定全局作用域。
JAXBIntrospector | 提供对 JAXB 对象的 JAXB xml 绑定数据的访问。
Marshaller.Listener | 向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。
SchemaOutputResolver | 控制 JAXB 实现放置生成的模式文件的位置。
Unmarshaller.Listener | 向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

异常摘要
JAXBException | 这是所有 JAXB 异常的根异常类。
MarshalException | 此异常指示在执行提供者无法恢复的编组操作时发生错误。
PropertyException | 此异常指示在获取或设置属性时遇到一个错误。
TypeConstraintException | 此异常指示已检测到存在违反动态检查的类型约束的情况。
UnmarshalException | 此异常指示在执行阻止 JAXB 提供者完成操作的解组操作时遇到一个错误。
ValidationException | 此异常指示在执行验证操作时发生错误。

软件包 javax.xml.bind 的描述

为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

JAXBContext 是运行时绑定框架的客户端入口点。

包规范

  • JAXB 规范

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • JAXB 网站

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.bind 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.bind.Binder<XmlNode>
    • javax.xml.bind.DatatypeConverter
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.xml.bind.Marshaller.Listener
    • javax.xml.bind.SchemaOutputResolver
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • java.lang.RuntimeException
          • javax.xml.bind.TypeConstraintException
    • javax.xml.bind.Unmarshaller.Listener

接口分层结构

  • org.xml.sax.ContentHandler
    • javax.xml.bind.UnmarshallerHandler
  • javax.xml.bind.DatatypeConverterInterface
  • javax.xml.bind.Element
  • javax.xml.bind.Marshaller
  • javax.xml.bind.Unmarshaller
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.bind 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind
的使用

使用 javax.xml.bind 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.bind 使用的 javax.xml.bind 中的类
Binder
在 XML 信息集节点和表示相同 XML 文档的 JAXB 对象之间启用同步。
DatatypeConverterInterface
该 DatatypeConverterInterface 仅适用于 JAXB 提供者。
JAXBContext
JAXBContext 类提供到 JAXB API 的客户端入口点。
JAXBElement
Xml 元素的 JAXB 表示形式。
JAXBException
这是所有 JAXB 异常的根异常类。
JAXBIntrospector
提供对 JAXB 对象的 JAXB xml 绑定数据的访问。
Marshaller
Marshaller 类负责管理将 Java 内容树序列化回 XML 数据的过程。
Marshaller.Listener

向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。

PropertyException
此异常指示在获取或设置属性时遇到一个错误。
SchemaOutputResolver
控制 JAXB 实现放置生成的模式文件的位置。
Unmarshaller
Unmarshaller 类管理将 XML 数据反序列化为新创建的 Java 内容树的过程，并可在解组时有选择地验证 XML 数据。
Unmarshaller.Listener

向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

UnmarshallerHandler
作为 SAX ContentHandler 实现的 Unmarshaller。
ValidationEvent
此事件指示在执行解组操作期间验证传入的 XML 数据时、对 Java 内容树执行按需验证时或将 Java 内容树编组回 XML 数据时遇到问题。
ValidationEventHandler
用来验证错误的基本事件处理程序接口。
ValidationEventLocator
封装 ValidationEvent 的位置。
Validator
已过时。 从 JAXB 2.0 开始

javax.xml.bind.annotation 使用的 javax.xml.bind 中的类
ValidationEventHandler
用来验证错误的基本事件处理程序接口。

javax.xml.bind.helpers 使用的 javax.xml.bind 中的类
JAXBElement
Xml 元素的 JAXB 表示形式。
JAXBException
这是所有 JAXB 异常的根异常类。
Marshaller
Marshaller 类负责管理将 Java 内容树序列化回 XML 数据的过程。
Marshaller.Listener

向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。

NotIdentifiableEvent
此事件指示解析 ID/IDREF 时遇到一个问题。
ParseConversionEvent
此事件指示将 XML 数据中的字符串转换为目标 Java 数据类型的值时遇到一个问题。
PrintConversionEvent
此事件指示将 Java 内容树中的数据转换为其词汇表示形式时遇到一个问题。
PropertyException
此异常指示在获取或设置属性时遇到一个错误。
UnmarshalException
此异常指示在执行阻止 JAXB 提供者完成操作的解组操作时遇到一个错误。
Unmarshaller
Unmarshaller 类管理将 XML 数据反序列化为新创建的 Java 内容树的过程，并可在解组时有选择地验证 XML 数据。
Unmarshaller.Listener

向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

ValidationEvent
此事件指示在执行解组操作期间验证传入的 XML 数据时、对 Java 内容树执行按需验证时或将 Java 内容树编组回 XML 数据时遇到问题。
ValidationEventHandler
用来验证错误的基本事件处理程序接口。
ValidationEventLocator
封装 ValidationEvent 的位置。

javax.xml.bind.util 使用的 javax.xml.bind 中的类
JAXBContext
JAXBContext 类提供到 JAXB API 的客户端入口点。
JAXBException
这是所有 JAXB 异常的根异常类。
Marshaller
Marshaller 类负责管理将 Java 内容树序列化回 XML 数据的过程。
Unmarshaller
Unmarshaller 类管理将 XML 数据反序列化为新创建的 Java 内容树的过程，并可在解组时有选择地验证 XML 数据。
ValidationEvent
此事件指示在执行解组操作期间验证传入的 XML 数据时、对 Java 内容树执行按需验证时或将 Java 内容树编组回 XML 数据时遇到问题。
ValidationEventHandler
用来验证错误的基本事件处理程序接口。

javax.xml.ws 使用的 javax.xml.bind 中的类
JAXBContext
JAXBContext 类提供到 JAXB API 的客户端入口点。

javax.xml.ws.handler.soap 使用的 javax.xml.bind 中的类
JAXBContext
JAXBContext 类提供到 JAXB API 的客户端入口点。

javax.xml.ws.spi 使用的 javax.xml.bind 中的类
JAXBContext
JAXBContext 类提供到 JAXB API 的客户端入口点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AbstractMarshallerImpl (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.helpers
类 AbstractMarshallerImpl

java.lang.Object
    继承者  javax.xml.bind.helpers.AbstractMarshallerImpl
所有已实现的接口：
Marshaller
public abstract class AbstractMarshallerImpl
extends Object
implements Marshaller

部分默认 Marshaller 实现。

此类提供 Marshaller 接口的部分默认实现。

JAXB 提供者必须实现的方法只有 marshal(Object, javax.xml.transform.Result)、marshal(Object, javax.xml.stream.XMLStreamWriter) 和 marshal(Object, javax.xml.stream.XMLEventWriter)。

从以下版本开始：
JAXB1.0
另请参见：
=======, >>>>>>> 1.3

嵌套类摘要
从接口 javax.xml.bind.Marshaller 继承的嵌套类/接口
Marshaller.Listener
字段摘要
从接口 javax.xml.bind.Marshaller 继承的字段
JAXB_ENCODING, JAXB_FORMATTED_OUTPUT, JAXB_FRAGMENT, JAXB_NO_NAMESPACE_SCHEMA_LOCATION, JAXB_SCHEMA_LOCATION
构造方法摘要
AbstractMarshallerImpl()
方法摘要
<A extends XmlAdapter>
A
getAdapter(Class<A> type)
获取与指定类型关联的适配器。
 AttachmentMarshaller getAttachmentMarshaller()
protected  String getEncoding()
获取当前输出编码的便捷方法。
 ValidationEventHandler getEventHandler()
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
protected  String getJavaEncoding(String encoding)
从 IANA 名称获取相应的 Java 编码名称。
 Marshaller.Listener getListener()
返回向此 Marshaller 注册的 Marshaller.Listener。
 Node getNode(Object obj)
默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。
protected  String getNoNSSchemaLocation()
获取当前 noNamespaceSchemaLocation 的便捷方法。
 Object getProperty(String name)
getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
 Schema getSchema()
获取用于执行编组时验证的 JAXP 1.3 Schema 对象。
protected  String getSchemaLocation()
获取当前 schemaLocation 的便捷方法。
protected  boolean isFormattedOutput()
获取格式化输出标志的便捷方法。
protected  boolean isFragment()
获取片段标志的便捷方法。
 void marshal(Object obj, ContentHandler handler)
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。
 void marshal(Object obj, Node node)
将以 jaxbElement 为根的内容树编组到 DOM 树中。
 void marshal(Object obj, OutputStream os)
将以 jaxbElement 为根的内容树编组到输出流中。
 void marshal(Object obj, Writer w)
将以 jaxbElement 为根的内容树编组到 Writer 中。
 void marshal(Object obj, XMLEventWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。
 void marshal(Object obj, XMLStreamWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。
<A extends XmlAdapter>
void
setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。
 void setAdapter(XmlAdapter adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。
 void setAttachmentMarshaller(AttachmentMarshaller am)
与上下文关联，使 XML 文档内的二进制数据能够以优化的 XML 二进制附件的形式传送。
protected  void setEncoding(String encoding)
设置输出编码的便捷方法。
 void setEventHandler(ValidationEventHandler handler)
允许应用程序注册一个验证事件处理程序。
protected  void setFormattedOutput(boolean v)
设置格式化输出标志的便捷方法。
protected  void setFragment(boolean v)
设置片段标志的便捷方法。
 void setListener(Marshaller.Listener listener)
向此 Marshaller 注册编组事件回调 Marshaller.Listener。
protected  void setNoNSSchemaLocation(String location)
设置 noNamespaceSchemaLocation 的便捷方法。
 void setProperty(String name, Object value)
setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
 void setSchema(Schema schema)
指定应该用作验证后续编组操作依据的 JAXP 1.3 Schema 对象。
protected  void setSchemaLocation(String location)
设置 schemaLocation 的便捷方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.xml.bind.Marshaller 继承的方法
marshal

构造方法详细信息

AbstractMarshallerImpl

public AbstractMarshallerImpl()
方法详细信息

marshal

public final void marshal(Object obj,
                          OutputStream os)
                   throws JAXBException
从接口 Marshaller 复制的描述
将以 jaxbElement 为根的内容树编组到输出流中。

指定者：
接口 Marshaller 中的 marshal
参数：
obj - 要编组的内容树的根。
os - XML 将被添加到此流。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。

marshal

public final void marshal(Object obj,
                          Writer w)
                   throws JAXBException
从接口 Marshaller 复制的描述
将以 jaxbElement 为根的内容树编组到 Writer 中。

指定者：
接口 Marshaller 中的 marshal
参数：
obj - 要编组的内容树的根。
w - XML 将被发送到此编写器。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。

marshal

public final void marshal(Object obj,
                          ContentHandler handler)
                   throws JAXBException
从接口 Marshaller 复制的描述
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。

指定者：
接口 Marshaller 中的 marshal
参数：
obj - 要编组的内容树的根。
handler - XML 将被作为 SAX2 事件发送到此处理程序。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。

marshal

public final void marshal(Object obj,
                          Node node)
                   throws JAXBException
从接口 Marshaller 复制的描述
将以 jaxbElement 为根的内容树编组到 DOM 树中。

指定者：
接口 Marshaller 中的 marshal
参数：
obj - 要编组的内容树。
node - DOM 节点将作为此节点的子节点添加。此参数必须是一个可接受子节点（Document、DocumentFragment 或 Element）的 Node。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 jaxbElement（或任何可从 jaxbElement 获得的对象）。请参阅编组 JAXB 元素。

getNode

public Node getNode(Object obj)
             throws JAXBException
默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。 选择支持此方法的实现必须重写此方法。

指定者：
接口 Marshaller 中的 getNode
参数：
obj - XML 内容的 JAXB Java 表示形式
返回：
contentTree 的 DOM 树视图
抛出：
JAXBException - 如果发生任何不可预料的问题

getEncoding

protected String getEncoding()
获取当前输出编码的便捷方法。

返回：
当前的编码，如果没有设置编码，则返回 "UTF-8"。

setEncoding

protected void setEncoding(String encoding)
设置输出编码的便捷方法。

参数：
encoding - Marshaller 类文档中指定的有效编码

getSchemaLocation

protected String getSchemaLocation()
获取当前 schemaLocation 的便捷方法。

返回：
当前的 schemaLocation，如果没有设置 schemaLocation，则返回 null

setSchemaLocation

protected void setSchemaLocation(String location)
设置 schemaLocation 的便捷方法。

参数：
location - schemaLocation 值

getNoNSSchemaLocation

protected String getNoNSSchemaLocation()
获取当前 noNamespaceSchemaLocation 的便捷方法。

返回：
当前的 noNamespaceSchemaLocation；如果没有设置 noNamespaceSchemaLocation，则返回 null

setNoNSSchemaLocation

protected void setNoNSSchemaLocation(String location)
设置 noNamespaceSchemaLocation 的便捷方法。

参数：
location - noNamespaceSchemaLocation 值

isFormattedOutput

protected boolean isFormattedOutput()
获取格式化输出标志的便捷方法。

返回：
格式化输出标志的当前值；如果没有设置该值，则返回 false。

setFormattedOutput

protected void setFormattedOutput(boolean v)
设置格式化输出标志的便捷方法。

参数：
v - 格式化输出标志的值。

isFragment

protected boolean isFragment()
获取片段标志的便捷方法。

返回：
片段标志的当前值；如果没有设置该值，则返回 false。

setFragment

protected void setFragment(boolean v)
设置片段标志的便捷方法。

参数：
v - 片段标志的值。

getJavaEncoding

protected String getJavaEncoding(String encoding)
                          throws UnsupportedEncodingException
从 IANA 名称获取相应的 Java 编码名称。 此方法是派生类用来转换编码名称的 helper 方法。

抛出：
UnsupportedEncodingException - 如果此实现无法找到 Java 编码名称。

setProperty

public void setProperty(String name,
                        Object value)
                 throws PropertyException
setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。如果提供者需要处理其他属性，则应该在派生类中重写此方法。

指定者：
接口 Marshaller 中的 setProperty
参数：
name - 要设置的属性的名称。此值可以使用一个常量字段来指定，也可以是一个用户提供的字符串。
value - 要设置的属性值
抛出：
PropertyException - 如果处理给定属性或值时发生错误

getProperty

public Object getProperty(String name)
                   throws PropertyException
getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。如果提供者需要支持特定于其他提供者的属性，则应该在派生类中重写此方法。

指定者：
接口 Marshaller 中的 getProperty
参数：
name - 将检索的属性的名称
返回：
所请求属性的值
抛出：
PropertyException - 如果检索给定属性或值属性名称时发生错误

getEventHandler

public ValidationEventHandler getEventHandler()
                                       throws JAXBException
从接口 Marshaller 复制的描述
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。

指定者：
接口 Marshaller 中的 getEventHandler
返回：
当前的 ValidationEventHandler，如果没有设置该处理程序，则返回默认的事件处理程序
抛出：
JAXBException - 如果获取当前的事件处理程序时遇到错误
另请参见：
Marshaller.getEventHandler()

setEventHandler

public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
从接口 Marshaller 复制的描述
允许应用程序注册一个验证事件处理程序。

如果在调用任何编组 API 期间遇到任何验证错误，则 JAXB 提供者将调用验证事件处理程序。如果客户端应用程序没有在调用某个 marshal 方法之前注册验证事件处理程序，则将使用默认事件处理程序处理验证事件，默认处理程序将在遇到第一个错误或致命错误之后将终止编组操作。

调用带有 null 参数的此方法将导致 Marshaller 重新使用默认事件处理程序。

指定者：
接口 Marshaller 中的 setEventHandler
参数：
handler - 验证事件处理程序
抛出：
JAXBException - 如果在设置事件处理程序时遇到错误
另请参见：
Marshaller.setEventHandler(ValidationEventHandler)

marshal

public void marshal(Object obj,
                    XMLEventWriter writer)
             throws JAXBException
从接口 Marshaller 复制的描述
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。

指定者：
接口 Marshaller 中的 marshal
参数：
obj - 要编组的以 jaxbElement 为根的内容树。
writer - XML 将被发送到此编写器。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。

marshal

public void marshal(Object obj,
                    XMLStreamWriter writer)
             throws JAXBException
从接口 Marshaller 复制的描述
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。

指定者：
接口 Marshaller 中的 marshal
参数：
obj - 要编组的内容树。
writer - XML 将被发送到此编写器。
抛出：
JAXBException - 如果在编组期间发生任何不可预料的问题。
MarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false，或者 Marshaller 不能编组 obj（或任何可从 obj 获得的对象）。请参阅编组 JAXB 元素。

setSchema

public void setSchema(Schema schema)
从接口 Marshaller 复制的描述
指定应该用作验证后续编组操作依据的 JAXP 1.3 Schema 对象。向此方法传递 null 将禁用验证。

此方法允许调用者在对已编组的 XML 进行编组时验证它。

最初，此属性被设置为 null。

指定者：
接口 Marshaller 中的 setSchema
参数：
schema - 作为验证编组操作依据的 Schema 对象；为 null 表示禁用验证

getSchema

public Schema getSchema()
从接口 Marshaller 复制的描述
获取用于执行编组时验证的 JAXP 1.3 Schema 对象。如果未在 marshaller 上设置 Schema，则此方法将返回 null，指示不执行编组时验证。

指定者：
接口 Marshaller 中的 getSchema
返回：
返回用于执行编组时验证的 Schema 对象；如果该对象不存在，则返回 null。

setAdapter

public void setAdapter(XmlAdapter adapter)
从接口 Marshaller 复制的描述
将已配置的 XmlAdapter 实例与此 marshaller 关联。

这是调用 setAdapter(adapter.getClass(),adapter) 的一个便捷方法。

指定者：
接口 Marshaller 中的 setAdapter
另请参见：
Marshaller.setAdapter(Class,XmlAdapter)

setAdapter

public <A extends XmlAdapter> void setAdapter(Class<A> type,
                                              A adapter)
从接口 Marshaller 复制的描述
将已配置的 XmlAdapter 实例与此 marshaller 关联。

每个 marshaller 都可以在内部维护一个 Map<Class,XmlAdapter>，可用来编组使用 XmlJavaTypeAdapter 注释其字段/方法的类。

此方法允许应用程序使用已配置好的 XmlAdapter 实例。如果没有给出适配器实例，则 marshaller 将调用其默认构造方法创建一个实例。

指定者：
接口 Marshaller 中的 setAdapter
参数：
type - 适配器的类型。当 XmlJavaTypeAdapter.value() 引用此类型时，将使用指定的实例。
adapter - 将要使用的适配器实例。如果为 null，则将注销此类型的当前适配器集合。

getAdapter

public <A extends XmlAdapter> A getAdapter(Class<A> type)
从接口 Marshaller 复制的描述
获取与指定类型关联的适配器。 这是 Marshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) 方法的反向操作。

指定者：
接口 Marshaller 中的 getAdapter

setAttachmentMarshaller

public void setAttachmentMarshaller(AttachmentMarshaller am)
从接口 Marshaller 复制的描述

与上下文关联，使 XML 文档内的二进制数据能够以优化的 XML 二进制附件的形式传送。可以使用存储在 xml 文档中的内容 id URI (cid) 从 XML 文档内容模式引用附件。

指定者：
接口 Marshaller 中的 setAttachmentMarshaller

getAttachmentMarshaller

public AttachmentMarshaller getAttachmentMarshaller()
指定者：
接口 Marshaller 中的 getAttachmentMarshaller

setListener

public void setListener(Marshaller.Listener listener)
从接口 Marshaller 复制的描述

向此 Marshaller 注册编组事件回调 Marshaller.Listener。

每个 Marshaller 只有一个 Listener。设置 Listener 将替换以前设置的 Listener。通过将 listener 设置为 null 可注销当前的 Listener。

指定者：
接口 Marshaller 中的 setListener
参数：
listener - 实现 Marshaller.Listener 的类的实例

getListener

public Marshaller.Listener getListener()
从接口 Marshaller 复制的描述

返回向此 Marshaller 注册的 Marshaller.Listener。

指定者：
接口 Marshaller 中的 getListener
返回：
注册的 Marshaller.Listener；如果未向此 Marshaller 注册任何 Listener，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AbstractUnmarshallerImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.helpers
类 AbstractUnmarshallerImpl

java.lang.Object
    继承者  javax.xml.bind.helpers.AbstractUnmarshallerImpl
所有已实现的接口：
Unmarshaller
public abstract class AbstractUnmarshallerImpl
extends Object
implements Unmarshaller

部分默认 Unmarshaller 实现。

此类提供 Unmarshaller 接口的部分默认实现。

JAXB 提供者必须实现 5 个方法：getUnmarshallerHandler、unmarshal(Node)、unmarshal(XMLReader,InputSource)、unmarshal(XMLStreamReader) 和 unmarshal(XMLEventReader)。

从以下版本开始：
JAXB1.0
另请参见：
Unmarshaller

嵌套类摘要
从接口 javax.xml.bind.Unmarshaller 继承的嵌套类/接口
Unmarshaller.Listener
字段摘要
protected  boolean validating
指示 Unmarshaller 是否将执行验证。
构造方法摘要
AbstractUnmarshallerImpl()
方法摘要
protected  UnmarshalException createUnmarshalException(SAXException e)
从 SAXException 创建 UnmarshalException。
<A extends XmlAdapter>
A
getAdapter(Class<A> type)
获取与指定类型关联的适配器。
 AttachmentUnmarshaller getAttachmentUnmarshaller()
 ValidationEventHandler getEventHandler()
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
 Unmarshaller.Listener getListener()
返回向此 Unmarshaller 注册的 Unmarshaller.Listener。
 Object getProperty(String name)
由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。
 Schema getSchema()
获取用于执行解组时验证的 JAXP 1.3 Schema 对象。
protected  XMLReader getXMLReader()
获取配置好的 XMLReader。
 boolean isValidating()
指示 Unmarshaller 是否被配置为在执行解组操作期间进行验证。
<A extends XmlAdapter>
void
setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
 void setAdapter(XmlAdapter adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
 void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
将解析 cid（内容 id URI）的上下文与作为附件传递的二进制数据关联。
 void setEventHandler(ValidationEventHandler handler)
允许应用程序注册一个验证事件处理程序。
 void setListener(Unmarshaller.Listener listener)
向此 Unmarshaller 注册解组事件回调 Unmarshaller.Listener。
 void setProperty(String name, Object value)
由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。
 void setSchema(Schema schema)
指定应用作验证后续解组操作依据的 JAXP 1.3 Schema 对象。
 void setValidating(boolean validating)
指定 Unmarshaller 是否应该在执行解组操作期间进行验证。
 Object unmarshal(File f)
从指定的文件解组 XML 数据并返回得到的内容树。
 Object unmarshal(InputSource source)
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。
 Object unmarshal(InputStream is)
从指定的 InputStream 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
unmarshal(Node node, Class<T> expectedType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
 Object unmarshal(Reader reader)
从指定的 Reader 解组 XML 数据并返回得到的内容树。
 Object unmarshal(Source source)
从指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
unmarshal(Source source, Class<T> expectedType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
 Object unmarshal(URL url)
从指定的 URL 解组 XML 数据并返回得到的内容树。
 Object unmarshal(XMLEventReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
unmarshal(XMLEventReader reader, Class<T> expectedType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
protected abstract  Object unmarshal(XMLReader reader, InputSource source)
使用指定的 XMLReader 和 InputSource 解组对象。
 Object unmarshal(XMLStreamReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
unmarshal(XMLStreamReader reader, Class<T> expectedType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.xml.bind.Unmarshaller 继承的方法
getUnmarshallerHandler, unmarshal

字段详细信息

validating

protected boolean validating
指示 Unmarshaller 是否将执行验证。

构造方法详细信息

AbstractUnmarshallerImpl

public AbstractUnmarshallerImpl()
方法详细信息

getXMLReader

protected XMLReader getXMLReader()
                          throws JAXBException
获取配置好的 XMLReader。 此方法在客户端指定的 SAXSource 对象没有 XMLReader 时使用。 Unmarshaller 不可重入，因此我们只能使用一个 XMLReader 实例。

抛出：
JAXBException

unmarshal

public Object unmarshal(Source source)
                 throws JAXBException
从接口 Unmarshaller 复制的描述
从指定的 XML Source 解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

SAX 2.0 解析器的可插入性

客户端应用程序可以选择不使用随 JAXB 提供者一起提供的默认解析器机制。任何兼容 SAX 2.0 的解析器都可以取代 JAXB 提供者的默认机制。要实现这一点，客户端应用程序必须正确配置一个包含 XMLReader 的 SAXSource，并且该 XMLReader 是由 SAX 2.0 解析器提供者实现的。如果 XMLReader 有一个向它注册的 org.xml.sax.ErrorHandler，则将使用 JAXB 提供者替换它，以便通过 JAXB 的 ValidationEventHandler 机制报告验证错误。如果 SAXSource 不包含 XMLReader，则将使用 JAXB 提供者的默认解析器机制。

也可以使用此解析器替换机制来替换 JAXB 提供者的解组时验证引擎。客户端应用程序必须正确配置其兼容 SAX 2.0 的解析器来执行验证（如上例所示）。解析器在解组操作期间遇到的任何 SAXParserExceptions 都将由 JAXB 提供者处理，并将其转换为 JAXB ValidationEvent 对象，这些对象将通过已经向 Unmarshaller 注册的 ValidationEventHandler 报告给客户端。注： 在为了实现解组而指定一个替换验证 SAX 2.0 解析器时，无需替换 JAXB 提供者使用的验证引擎来执行按需应变的验证。

客户端应用程序指定将在解组期间使用的替换解析器机制的唯一方法是通过 unmarshal(SAXSource) API。所有其他形式的 unmarshal 方法（文件、URL、Node 等等）将使用 JAXB 提供者的默认解析器和验证器机制。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
source - 将从中解组 XML 数据的 XML Source（提供者只需支持 SAXSource、DOMSource 和 StreamSource）
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
另请参见：
Unmarshaller.unmarshal(javax.xml.transform.Source, Class)

unmarshal

protected abstract Object unmarshal(XMLReader reader,
                                    InputSource source)
                             throws JAXBException
使用指定的 XMLReader 和 InputSource 解组对象。 被调用者应调用 XMLReader 的 setErrorHandler 方法，这样错误才能传递给客户端指定的 ValidationEventHandler。

抛出：
JAXBException

unmarshal

public final Object unmarshal(InputSource source)
                       throws JAXBException
从接口 Unmarshaller 复制的描述
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
source - 将从中解组 XML 数据的输入源
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

unmarshal

public final Object unmarshal(URL url)
                       throws JAXBException
从接口 Unmarshaller 复制的描述
从指定的 URL 解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
url - 将从中解组 XML 数据的 URL
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

unmarshal

public final Object unmarshal(File f)
                       throws JAXBException
从接口 Unmarshaller 复制的描述
从指定的文件解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
f - 将从中解组 XML 数据的文件
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或着 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

unmarshal

public final Object unmarshal(InputStream is)
                       throws JAXBException
从接口 Unmarshaller 复制的描述
从指定的 InputStream 解组 XML 数据并返回得到的内容树。使用这种形式的 unmarshal API 时，验证事件位置信息可能不完整。

实现解组全局根元素。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
is - 将从中解组 XML 数据的 InputStream
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

unmarshal

public final Object unmarshal(Reader reader)
                       throws JAXBException
从接口 Unmarshaller 复制的描述
从指定的 Reader 解组 XML 数据并返回得到的内容树。使用这种形式的 unmarshal API 时，验证事件位置信息可能不完整，这是因为 Reader 不提供系统 ID。

实现解组全局根元素。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
reader - 将从中解组 XML 数据的 Reader
返回：
新创建的 java 内容树的根对象
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

isValidating

public boolean isValidating()
                     throws JAXBException
指示 Unmarshaller 是否被配置为在执行解组操作期间进行验证。

注： 为了与 JAXP 保持一致，我将该方法命名为 isValidating()，而不是 getValidating()。

指定者：
接口 Unmarshaller 中的 isValidating
返回：
如果 Unmarshaller 被配置为在执行解组操作期间进行验证，则返回 true，否则返回 false
抛出：
JAXBException - 如果检索验证标志时发生错误

setEventHandler

public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
允许应用程序注册一个验证事件处理程序。

如果在调用任一 unmarshal 方法期间发生验证错误，则 JAXB 提供者将调用验证事件处理程序。如果在调用解组方法之前客户端应用程序没有注册验证事件处理程序，那么将忽略所有验证事件，并有可能导致不可预料的行为。

指定者：
接口 Unmarshaller 中的 setEventHandler
参数：
handler - 验证事件处理程序
抛出：
JAXBException - 如果在设置事件处理程序时发生错误

setValidating

public void setValidating(boolean validating)
                   throws JAXBException
指定 Unmarshaller 是否应该在执行解组操作期间进行验证。默认情况下，Unmarshaller 不进行验证。

此方法仅在调用某一解组方法之前或之后调用。

指定者：
接口 Unmarshaller 中的 setValidating
参数：
validating - 如果 Unmarshaller 应该在执行解组操作期间进行验证，则该参数为 true，否则为 false
抛出：
JAXBException - 如果在执行解组操作期间启用或禁用验证时发生错误

getEventHandler

public ValidationEventHandler getEventHandler()
                                       throws JAXBException
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。

指定者：
接口 Unmarshaller 中的 getEventHandler
返回：
当前 ValidationEventHandler，如果没有设置该处理程序，则返回默认的事件处理程序
抛出：
JAXBException - 如果获取当前事件处理程序时发生错误

createUnmarshalException

protected UnmarshalException createUnmarshalException(SAXException e)
从 SAXException 创建 UnmarshalException。 这是一个为派生类提供的实用方法。

当提供者实现的 ContentHandler 希望抛出 JAXBException 时，它需要通过 SAXException 包装该异常。如果 unmarshaller 实现盲目地使用 JAXBException 包装 SAXException ，则异常将是用另一个 JAXBException 包装的 SAXException 包装的 JAXBException。这样做很不明智。

此方法检查 SAXException 的嵌套异常并可减少过多的包装。

返回：
得到的 UnmarshalException

setProperty

public void setProperty(String name,
                        Object value)
                 throws PropertyException
由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。如果提供商需要处理其他属性，则应该在派生类中重写此方法。

指定者：
接口 Unmarshaller 中的 setProperty
参数：
name - 要设置的属性的名称。此值可以使用一个常量字段来指定，也可以是一个用户提供的字符串。
value - 要设置的属性值
抛出：
PropertyException - 如果处理给定属性或值时发生错误

getProperty

public Object getProperty(String name)
                   throws PropertyException
由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。如果提供者需要处理其他属性，则应该在派生类中重写此方法。

指定者：
接口 Unmarshaller 中的 getProperty
参数：
name - 要检索的属性的名称
返回：
所请求属性的值
抛出：
PropertyException - 如果检索给定属性或值属性名称时发生错误

unmarshal

public Object unmarshal(XMLEventReader reader)
                 throws JAXBException
从接口 Unmarshaller 复制的描述
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。

此方法是一个解组全局根方法。

此方法假定该解析器处于 START_DOCUMENT 或 START_ELEMENT 事件上。解组将从起始事件开始，到相应的终止事件结束。如果此方法成功返回，则 reader 将指向终止事件后面的标记。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
reader - 要读取的解析器。
返回：
新创建的 java 内容树的根对象。
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
另请参见：
Unmarshaller.unmarshal(javax.xml.stream.XMLEventReader, Class)

unmarshal

public Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
从接口 Unmarshaller 复制的描述
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。

实现解组全局根元素。

此方法假定该解析器处于 START_DOCUMENT 或 START_ELEMENT 事件上。解组将从起始事件开始，到相应的终止事件结束。如果此方法成功返回，则 reader 将指向终止事件后面的标记。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
reader - 要读取的解析器。
返回：
新创建的 java 内容树的根对象。
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据
另请参见：
Unmarshaller.unmarshal(javax.xml.stream.XMLStreamReader, Class)

unmarshal

public <T> JAXBElement<T> unmarshal(Node node,
                                    Class<T> expectedType)
                         throws JAXBException
从接口 Unmarshaller 复制的描述
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。

实现借助声明的类型进行解组。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
node - 从中解组 XML 数据的文档/元素。调用者至少必须支持 Document 和 Element。
expectedType - 用来保存 node 的 XML 数据的适当 JAXB 映射类。
返回：
node 的 JAXB Element 表示形式
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

unmarshal

public <T> JAXBElement<T> unmarshal(Source source,
                                    Class<T> expectedType)
                         throws JAXBException
从接口 Unmarshaller 复制的描述
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。

实现借助声明的类型进行解组。

请参阅 SAX 2.0 解析器的可插入性

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
source - 将从中解组 XML 数据的 XML Source（提供者只需支持 SAXSource、DOMSource 和 StreamSource）
expectedType - 用来保存 source 的 xml 根元素的适当 JAXB 映射类
返回：
通过 JAXB Element 确定的 Java 内容
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

unmarshal

public <T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                                    Class<T> expectedType)
                         throws JAXBException
从接口 Unmarshaller 复制的描述
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

此方法实现借助 declaredType 进行解组。

此方法假定该解析器处于 START_DOCUMENT 或 START_ELEMENT 事件上。解组将从起始事件开始，到相应的终止事件结束。如果此方法成功返回，则 reader 将指向终止事件后面的标记。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
reader - 要读取的解析器。
expectedType - 用来保存 reader 的 START_ELEMENT XML 数据的适当 JAXB 映射类。
返回：
通过 JAXB Element 表示形式确定的内容树
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

unmarshal

public <T> JAXBElement<T> unmarshal(XMLEventReader reader,
                                    Class<T> expectedType)
                         throws JAXBException
从接口 Unmarshaller 复制的描述
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

此方法实现借助 declaredType 进行解组。

此方法假定该解析器处于 START_DOCUMENT 或 START_ELEMENT 事件上。解组将从起始事件开始，到相应的终止事件结束。如果此方法成功返回，则 reader 将指向终止事件后面的标记。

指定者：
接口 Unmarshaller 中的 unmarshal
参数：
reader - 要读取的解析器。
expectedType - 用来保存 reader 的 START_ELEMENT XML 数据的适当 JAXB 映射类。
返回：
通过 JAXB Element 表示形式确定的内容树
抛出：
JAXBException - 如果在解组时发生不可预料的错误
UnmarshalException - 如果 ValidationEventHandler 从其 handleEvent 方法返回 false 或者 Unmarshaller 不能执行 XML 到 Java 的绑定。请参阅解组 XML 数据

setSchema

public void setSchema(Schema schema)
从接口 Unmarshaller 复制的描述
指定应用作验证后续解组操作依据的 JAXP 1.3 Schema 对象。向此方法传递 null 将禁用验证。

此方法将替换已过时的 setValidating(boolean) API。

最初，此属性被设置为 null。

指定者：
接口 Unmarshaller 中的 setSchema
参数：
schema - 作为验证解组操作依据的 Schema 对象；为 null 表示禁用验证

getSchema

public Schema getSchema()
从接口 Unmarshaller 复制的描述
获取用于执行解组时验证的 JAXP 1.3 Schema 对象。如果没有在 unmarshaller 上设置 Schema，则此方法将返回 null，指示不会执行解组时验证。

此方法用于替换已过时的 Unmarshaller.isValidating() API，并可访问 Schema 对象。要确定 Unmarshaller 是否启用了验证，只需测试返回类型是否为 null：

boolean isValidating = u.getSchema()!=null;

指定者：
接口 Unmarshaller 中的 getSchema
返回：
返回用于执行解组时验证的 Schema 对象；如果该对象不存在，则返回 null

setAdapter

public void setAdapter(XmlAdapter adapter)
从接口 Unmarshaller 复制的描述
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。

这是调用 setAdapter(adapter.getClass(),adapter); 的一个便捷方法。

指定者：
接口 Unmarshaller 中的 setAdapter
另请参见：
Unmarshaller.setAdapter(Class,XmlAdapter)

setAdapter

public <A extends XmlAdapter> void setAdapter(Class<A> type,
                                              A adapter)
从接口 Unmarshaller 复制的描述
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。

每个 unmarshaller 都可以在内部维护一个 Map<Class,XmlAdapter>，可用来解组使用 XmlJavaTypeAdapter 注释其字段/方法的类。

此方法允许应用程序使用已配置好的 XmlAdapter 实例。如果没有给出适配器实例，则 unmarshaller 将调用其默认构造方法创建一个实例。

指定者：
接口 Unmarshaller 中的 setAdapter
参数：
type - 适配器的类型。当 XmlJavaTypeAdapter.value() 引用此类型时，将使用指定的实例。
adapter - 将要使用的适配器实例。如果为 null，则将注销此类型的当前适配器集合。

getAdapter

public <A extends XmlAdapter> A getAdapter(Class<A> type)
从接口 Unmarshaller 复制的描述
获取与指定类型关联的适配器。 这是 Unmarshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) 方法的反向操作。

指定者：
接口 Unmarshaller 中的 getAdapter

setAttachmentUnmarshaller

public void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
从接口 Unmarshaller 复制的描述

将解析 cid（内容 id URI）的上下文与作为附件传递的二进制数据关联。

通过 Unmarshaller.setSchema(Schema) 启用的解组时验证，即使在 unmarshaller 执行 XOP 处理时也必须支持。

指定者：
接口 Unmarshaller 中的 setAttachmentUnmarshaller

getAttachmentUnmarshaller

public AttachmentUnmarshaller getAttachmentUnmarshaller()
指定者：
接口 Unmarshaller 中的 getAttachmentUnmarshaller

setListener

public void setListener(Unmarshaller.Listener listener)
从接口 Unmarshaller 复制的描述

向此 Unmarshaller 注册解组事件回调 Unmarshaller.Listener。

每个 Unmarshaller 只有一个 Listener。设置 Listener 将替换以前设置的 Listener。通过将 listener 设置为 null 可注销当前的 Listener。

指定者：
接口 Unmarshaller 中的 setListener
参数：
listener - 为此 Unmarshaller 提供解组事件回调

getListener

public Unmarshaller.Listener getListener()
从接口 Unmarshaller 复制的描述

返回向此 Unmarshaller 注册的 Unmarshaller.Listener。

指定者：
接口 Unmarshaller 中的 getListener
返回：
注册的 Unmarshaller.Listener；如果未向此 Unmarshaller 注册任何 Listener，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultValidationEventHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.helpers
类 DefaultValidationEventHandler

java.lang.Object
    继承者  javax.xml.bind.helpers.DefaultValidationEventHandler
所有已实现的接口：
ValidationEventHandler
public class DefaultValidationEventHandler
extends Object
implements ValidationEventHandler

唯一的 JAXB 1.0 默认验证事件处理程序。对于所有根据管理模式派生代码（该代码由 JAXB 1.0 绑定编译器生成）的 JAXBContext 而创建的对象，此类是默认处理程序。

此处理程序在第一次出现错误或出现严重错误时将导致解组和验证操作失败。

对于遵守 JAXB 2.0 和以后版本的映射 JAXB 的类，此处理程序不再是默认处理器。默认验证事件处理已经更改，它在 Unmarshaller 和 Marshaller 中指定。

从以下版本开始：
JAXB1.0
另请参见：
Unmarshaller, Validator, ValidationEventHandler

构造方法摘要
DefaultValidationEventHandler()
方法摘要
 boolean handleEvent(ValidationEvent event)
接收验证警告或错误的通知。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultValidationEventHandler

public DefaultValidationEventHandler()
方法详细信息

handleEvent

public boolean handleEvent(ValidationEvent event)
从接口 ValidationEventHandler 复制的描述
接收验证警告或错误的通知。ValidationEvent 将 ValidationEventLocator 嵌入通知中，以指示发生错误或警告的位置。

如果从此方法抛出未经检查的运行时异常，则 JAXB 提供者会像该方法返回 false 那样作出相应对待，并中断当前的解组、验证和编组操作。

指定者：
接口 ValidationEventHandler 中的 handleEvent
参数：
event - 封装的验证事件信息。如果为 null，则该信息是一个提供者错误。
返回：
如果 JAXB 提供者应该在处理此警告/错误之后尝试继续执行当前的解组、验证或编组操作，则返回 true；如果提供者应该使用适当的 UnmarshalException、ValidationException 或 MarshalException 终止当前操作，则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotIdentifiableEventImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.helpers
类 NotIdentifiableEventImpl

java.lang.Object
    继承者  javax.xml.bind.helpers.ValidationEventImpl
        继承者  javax.xml.bind.helpers.NotIdentifiableEventImpl
所有已实现的接口：
NotIdentifiableEvent, ValidationEvent
public class NotIdentifiableEventImpl
extends ValidationEventImpl
implements NotIdentifiableEvent

NotIdentifiableEvent 接口的默认实现。

允许 JAXB 提供者使用可实现 ValidationEvent 接口的任何类。提供此类只是为了方便使用。

从以下版本开始：
JAXB1.0
另请参见：
NotIdentifiableEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

字段摘要
从接口 javax.xml.bind.ValidationEvent 继承的字段
ERROR, FATAL_ERROR, WARNING
构造方法摘要
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 NotIdentifiableEventImpl。
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 NotIdentifiableEventImpl。
方法摘要
从类 javax.xml.bind.helpers.ValidationEventImpl 继承的方法
getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 javax.xml.bind.ValidationEvent 继承的方法
getLinkedException, getLocator, getMessage, getSeverity

构造方法详细信息

NotIdentifiableEventImpl

public NotIdentifiableEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
创建新的 NotIdentifiableEventImpl。

参数：
_severity - 此事件的 severity 值。必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一
_message - 此事件的文本消息，可以为 null。
_locator - 此事件的 Locator 对象，可以为 null。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段

NotIdentifiableEventImpl

public NotIdentifiableEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
创建新的 NotIdentifiableEventImpl。

参数：
_severity - 此事件的 severity 值。必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一
_message - 此事件的文本消息，可以为 null。
_locator - 此事件的 Locator 对象，可以为 null。
_linkedException - 一个可以提供事件的其他信息的可选链接异常，可以为 null。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParseConversionEventImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.helpers
类 ParseConversionEventImpl

java.lang.Object
    继承者  javax.xml.bind.helpers.ValidationEventImpl
        继承者  javax.xml.bind.helpers.ParseConversionEventImpl
所有已实现的接口：
ParseConversionEvent, ValidationEvent
public class ParseConversionEventImpl
extends ValidationEventImpl
implements ParseConversionEvent

ParseConversionEvent 接口的默认实现。

允许 JAXB 提供者使用实现了 ValidationEvent 接口的任何类。提供此类只是为了方便使用。

从以下版本开始：
JAXB1.0
另请参见：
ParseConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

字段摘要
从接口 javax.xml.bind.ValidationEvent 继承的字段
ERROR, FATAL_ERROR, WARNING
构造方法摘要
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ParseConversionEventImpl。
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ParseConversionEventImpl。
方法摘要
从类 javax.xml.bind.helpers.ValidationEventImpl 继承的方法
getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 javax.xml.bind.ValidationEvent 继承的方法
getLinkedException, getLocator, getMessage, getSeverity

构造方法详细信息

ParseConversionEventImpl

public ParseConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
创建新的 ParseConversionEventImpl。

参数：
_severity - 此事件的 severity 值。必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一
_message - 此事件的文本消息，可以为 null。
_locator - 此事件的 Locator 对象，可以为 null。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段

ParseConversionEventImpl

public ParseConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
创建新的 ParseConversionEventImpl。

参数：
_severity - 此事件的 severity 值。必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一
_message - 此事件的文本消息，可以为 null。
_locator - 此事件的 Locator 对象，可以为 null。
_linkedException - 一个可以提供事件其他信息的可选链接异常，可以为 null。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintConversionEventImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.helpers
类 PrintConversionEventImpl

java.lang.Object
    继承者  javax.xml.bind.helpers.ValidationEventImpl
        继承者  javax.xml.bind.helpers.PrintConversionEventImpl
所有已实现的接口：
PrintConversionEvent, ValidationEvent
public class PrintConversionEventImpl
extends ValidationEventImpl
implements PrintConversionEvent

PrintConversionEvent 接口的默认实现。

允许 JAXB 提供者使用实现了 ValidationEvent 接口的任何类。提供此类只是为了方便使用。

从以下版本开始：
JAXB1.0
另请参见：
PrintConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

字段摘要
从接口 javax.xml.bind.ValidationEvent 继承的字段
ERROR, FATAL_ERROR, WARNING
构造方法摘要
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 PrintConversionEventImpl。
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 PrintConversionEventImpl。
方法摘要
从类 javax.xml.bind.helpers.ValidationEventImpl 继承的方法
getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 javax.xml.bind.ValidationEvent 继承的方法
getLinkedException, getLocator, getMessage, getSeverity

构造方法详细信息

PrintConversionEventImpl

public PrintConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
创建新的 PrintConversionEventImpl。

参数：
_severity - 此事件的 severity 值。必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一
_message - 此事件的文本消息，可以为 null。
_locator - 此事件的 Locator 对象，可以为 null。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段

PrintConversionEventImpl

public PrintConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
创建新的 PrintConversionEventImpl。

参数：
_severity - 此事件的 severity 值。必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一
_message - 此事件的文本消息，可以为 null。
_locator - 此事件的 Locator 对象，可以为 null。
_linkedException - 一个可以提供事件其他信息的可选链接异常，可以为 null。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValidationEventImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.helpers
类 ValidationEventImpl

java.lang.Object
    继承者  javax.xml.bind.helpers.ValidationEventImpl
所有已实现的接口：
ValidationEvent
直接已知子类：
NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl
public class ValidationEventImpl
extends Object
implements ValidationEvent

ValidationEvent 接口的默认实现。

允许 JAXB 提供者使用实现了 ValidationEvent 接口的任何类。提供此类只是为了方便使用。

从以下版本开始：
JAXB1.0
另请参见：
Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

字段摘要
从接口 javax.xml.bind.ValidationEvent 继承的字段
ERROR, FATAL_ERROR, WARNING
构造方法摘要
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ValidationEventImpl。
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ValidationEventImpl。
方法摘要
Throwable | getLinkedException() 检索此警告/错误的链接异常。
ValidationEventLocator | getLocator() 检索此警告/错误的定位符。
String | getMessage() 检索此警告/错误的文本消息。
int | getSeverity() 检索此警告/错误的严重性代码。
void | setLinkedException(Throwable _linkedException) 设置此事件的 linked exception 字段。
void | setLocator(ValidationEventLocator _locator) 设置此事件的 Locator 对象。
void | setMessage(String _message) 设置此事件的 message 字段。
void | setSeverity(int _severity) 设置此事件的 severity 字段。
String | toString() 以有助于调试的格式返回此对象的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ValidationEventImpl

public ValidationEventImpl(int _severity,
                           String _message,
                           ValidationEventLocator _locator)
创建新的 ValidationEventImpl。

参数：
_severity - 此事件的 severity 值。必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一
_message - 此事件的文本消息，可以为 null。
_locator - 此事件的 Locator 对象，可以为 null。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段

ValidationEventImpl

public ValidationEventImpl(int _severity,
                           String _message,
                           ValidationEventLocator _locator,
                           Throwable _linkedException)
创建新的 ValidationEventImpl。

参数：
_severity - 此事件的 severity 值。必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一
_message - 此事件的文本消息，可以为 null。
_locator - 此事件的 Locator 对象，可以为 null。
_linkedException - 一个可以提供事件的其他信息的可选链接异常，可以为 null。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段
方法详细信息

getSeverity

public int getSeverity()
从接口 ValidationEvent 复制的描述
检索此警告/错误的严重性代码。

必须是 ValidationError.WARNING、ValidationError.ERROR 或 ValidationError.FATAL_ERROR 之一。

指定者：
接口 ValidationEvent 中的 getSeverity
返回：
此警告/错误的严重性代码

setSeverity

public void setSeverity(int _severity)
设置此事件的 severity 字段。

参数：
_severity - 必须是 ValidationEvent.WARNING、ValidationEvent.ERROR 或 ValidationEvent.FATAL_ERROR 之一。
抛出：
IllegalArgumentException - 如果提供了非法的 severity 字段

getMessage

public String getMessage()
从接口 ValidationEvent 复制的描述
检索此警告/错误的文本消息。

指定者：
接口 ValidationEvent 中的 getMessage
返回：
此警告/错误的文本消息；如果没有设置此消息，则返回 null

setMessage

public void setMessage(String _message)
设置此事件的 message 字段。

参数：
_message - 字符串消息，可以为 null。

getLinkedException

public Throwable getLinkedException()
从接口 ValidationEvent 复制的描述
检索此警告/错误的链接异常。

指定者：
接口 ValidationEvent 中的 getLinkedException
返回：
此警告/错误的链接异常；如果未设置此异常，则返回 null

setLinkedException

public void setLinkedException(Throwable _linkedException)
设置此事件的 linked exception 字段。

参数：
_linkedException - 可选链接异常，可以为 null。

getLocator

public ValidationEventLocator getLocator()
从接口 ValidationEvent 复制的描述
检索此警告/错误的定位符。

指定者：
接口 ValidationEvent 中的 getLocator
返回：
指示发生此警告/错误的位置的定位符

setLocator

public void setLocator(ValidationEventLocator _locator)
设置此事件的 Locator 对象。

参数：
_locator - 定位符，可以为 null。

toString

public String toString()
以有助于调试的格式返回此对象的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
另请参见：
Object.equals(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValidationEventLocatorImpl (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.helpers
类 ValidationEventLocatorImpl

java.lang.Object
    继承者  javax.xml.bind.helpers.ValidationEventLocatorImpl
所有已实现的接口：
ValidationEventLocator
public class ValidationEventLocatorImpl
extends Object
implements ValidationEventLocator

ValidationEventLocator 接口的默认实现。

允许 JAXB 提供者使用实现了 ValidationEventLocator 接口的任何类。提供此类只是为了方便使用。

从以下版本开始：
JAXB1.0
另请参见：
Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

构造方法摘要
ValidationEventLocatorImpl()
创建所有字段都不可用的对象。
ValidationEventLocatorImpl(Locator loc)
根据 org.xml.sax.Locator 构造一个对象。
ValidationEventLocatorImpl(Node _node)
构造一个指向 DOM Node 的对象。
ValidationEventLocatorImpl(Object _object)
构造一个指向 JAXB 内容对象的对象。
ValidationEventLocatorImpl(SAXParseException e)
根据 SAXParseException 的位置信息构造一个对象。
方法摘要
int | getColumnNumber() 返回列号（如果可用）。
int | getLineNumber() 返回行号（如果可用）。
Node | getNode() 返回对 DOM Node 的引用（如果可用）。
Object | getObject() 返回对 Java 内容树中对象的引用（如果可用）。
int | getOffset() 返回字节偏移量（如果可用）。
URL | getURL() 返回 URL 形式的 XML 源名称（如果可用）。
void | setColumnNumber(int _columnNumber) 在此事件定位符上设置 columnNumber 字段。
void | setLineNumber(int _lineNumber) 在此事件定位符上设置 lineNumber 字段。
void | setNode(Node _node) 在此事件定位符上设置 Node 字段。
void | setObject(Object _object) 在此事件定位符上设置 Object 字段。
void | setOffset(int _offset) 在此事件定位符上设置 offset 字段。
void | setURL(URL _url) 在此事件定位符上设置 URL 字段。
String | toString() 以有助于调试的格式返回此对象的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ValidationEventLocatorImpl

public ValidationEventLocatorImpl()
创建所有字段都不可用的对象。

ValidationEventLocatorImpl

public ValidationEventLocatorImpl(Locator loc)
根据 org.xml.sax.Locator 构造一个对象。 对象的 ColumnNumber、LineNumber 和 URL 可以分别从 Locator 的 getColumnNumber()、getLineNumber() 和 getSystemId() 方法的返回值得到。而 Node、Object 和 Offset 均不可用。

参数：
loc - 用于填充此事件定位符的 SAX Locator 对象。
抛出：
IllegalArgumentException - 如果 Locator 为 null

ValidationEventLocatorImpl

public ValidationEventLocatorImpl(SAXParseException e)
根据 SAXParseException 的位置信息构造一个对象。 对象的 ColumnNumber、LineNumber 和 URL 可以分别从 Locator 的 getColumnNumber()、getLineNumber() 和 getSystemId() 方法的返回值得到。而 Node、Object 和 Offset 均不可用。

参数：
e - 用于填充此事件定位符的 SAXParseException 对象。
抛出：
IllegalArgumentException - 如果 SAXParseException 为 null

ValidationEventLocatorImpl

public ValidationEventLocatorImpl(Node _node)
构造一个指向 DOM Node 的对象。 该对象的 Node 变得可用。ColumnNumber、LineNumber、Object、Offset 和 URL 不可用。

参数：
_node - 用于填充此事件定位符的 DOM Node 对象。
抛出：
IllegalArgumentException - 如果 Node 为 null

ValidationEventLocatorImpl

public ValidationEventLocatorImpl(Object _object)
构造一个指向 JAXB 内容对象的对象。 该对象的 Object 变得可用。ColumnNumber、LineNumber、Node、Offset 和 URL 不可用。

参数：
_object - 用于填充此事件定位符的 Object。
抛出：
IllegalArgumentException - 如果 Object 为 null
方法详细信息

getURL

public URL getURL()
从接口 ValidationEventLocator 复制的描述
返回 URL 形式的 XML 源名称（如果可用）。

指定者：
接口 ValidationEventLocator 中的 getURL
返回：
返回 URL 形式的 XML 源名称；如果没有可用的名称，则返回 null
另请参见：
ValidationEventLocator.getURL()

setURL

public void setURL(URL _url)
在此事件定位符上设置 URL 字段。允许使用 null 值。

参数：
_url - URL

getOffset

public int getOffset()
从接口 ValidationEventLocator 复制的描述
返回字节偏移量（如果可用）。

指定者：
接口 ValidationEventLocator 中的 getOffset
返回：
到输入源的字节偏移量，如果不可用，则返回 -1
另请参见：
ValidationEventLocator.getOffset()

setOffset

public void setOffset(int _offset)
在此事件定位符上设置 offset 字段。

参数：
_offset - 偏移量

getLineNumber

public int getLineNumber()
从接口 ValidationEventLocator 复制的描述
返回行号（如果可用）。

指定者：
接口 ValidationEventLocator 中的 getLineNumber
返回：
行号；如果不可用，则返回 -1
另请参见：
ValidationEventLocator.getLineNumber()

setLineNumber

public void setLineNumber(int _lineNumber)
在此事件定位符上设置 lineNumber 字段。

参数：
_lineNumber - 行数

getColumnNumber

public int getColumnNumber()
从接口 ValidationEventLocator 复制的描述
返回列号（如果可用）。

指定者：
接口 ValidationEventLocator 中的 getColumnNumber
返回：
列号；如果不可用，则返回 -1
另请参见：
ValidationEventLocator.getColumnNumber()

setColumnNumber

public void setColumnNumber(int _columnNumber)
在此事件定位符上设置 columnNumber 字段。

参数：
_columnNumber - 列数

getObject

public Object getObject()
从接口 ValidationEventLocator 复制的描述
返回对 Java 内容树中对象的引用（如果可用）。

指定者：
接口 ValidationEventLocator 中的 getObject
返回：
对 Java 内容树中对象的引用；如果不可用，则返回 null
另请参见：
ValidationEventLocator.getObject()

setObject

public void setObject(Object _object)
在此事件定位符上设置 Object 字段。允许使用 null 值。

参数：
_object - java 内容对象

getNode

public Node getNode()
从接口 ValidationEventLocator 复制的描述
返回对 DOM Node 的引用（如果可用）。

指定者：
接口 ValidationEventLocator 中的 getNode
返回：
对 DOM Node 的引用；如果不可用，则返回 null
另请参见：
ValidationEventLocator.getNode()

setNode

public void setNode(Node _node)
在此事件定位符上设置 Node 字段。允许使用 null 值。

参数：
_node - 节点

toString

public String toString()
以有助于调试的格式返回此对象的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
另请参见：
Object.equals(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.bind.helpers (Java Platform SE 6)

 javax.xml.bind.helpers
类
AbstractMarshallerImpl
AbstractUnmarshallerImpl
DefaultValidationEventHandler
NotIdentifiableEventImpl
ParseConversionEventImpl
PrintConversionEventImpl
ValidationEventImpl
ValidationEventLocatorImpl


javax.xml.bind.helpers (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.bind.helpers

仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

请参见：
描述

类摘要
AbstractMarshallerImpl | 部分默认 Marshaller 实现。
AbstractUnmarshallerImpl | 部分默认 Unmarshaller 实现。
DefaultValidationEventHandler | 唯一的 JAXB 1.0 默认验证事件处理程序。
NotIdentifiableEventImpl | NotIdentifiableEvent 接口的默认实现。
ParseConversionEventImpl | ParseConversionEvent 接口的默认实现。
PrintConversionEventImpl | PrintConversionEvent 接口的默认实现。
ValidationEventImpl | ValidationEvent 接口的默认实现。
ValidationEventLocatorImpl | ValidationEventLocator 接口的默认实现。

软件包 javax.xml.bind.helpers 的描述

仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

JAXB 提供者可以扩展这些类并实现抽象方法。

包规范

  • JAXB 规范

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • JAXB 网站

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.bind.helpers 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.helpers 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.bind.helpers 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.helpers
的使用

使用 javax.xml.bind.helpers 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 使用的 javax.xml.bind.helpers 中的类
ValidationEventImpl
ValidationEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.helpers.AbstractMarshallerImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.AbstractMarshallerImpl
的使用

没有 javax.xml.bind.helpers.AbstractMarshallerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.AbstractUnmarshallerImpl
的使用

没有 javax.xml.bind.helpers.AbstractUnmarshallerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.helpers.DefaultValidationEventHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.DefaultValidationEventHandler
的使用

没有 javax.xml.bind.helpers.DefaultValidationEventHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.helpers.NotIdentifiableEventImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.NotIdentifiableEventImpl
的使用

没有 javax.xml.bind.helpers.NotIdentifiableEventImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.helpers.ParseConversionEventImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.ParseConversionEventImpl
的使用

没有 javax.xml.bind.helpers.ParseConversionEventImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.helpers.PrintConversionEventImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.PrintConversionEventImpl
的使用

没有 javax.xml.bind.helpers.PrintConversionEventImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.helpers.ValidationEventImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.ValidationEventImpl
的使用

使用 ValidationEventImpl 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 ValidationEventImpl 的使用

javax.xml.bind.helpers 中 ValidationEventImpl 的子类
class | NotIdentifiableEventImpl NotIdentifiableEvent 接口的默认实现。
class | ParseConversionEventImpl ParseConversionEvent 接口的默认实现。
class | PrintConversionEventImpl PrintConversionEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.helpers.ValidationEventLocatorImpl
的使用

没有 javax.xml.bind.helpers.ValidationEventLocatorImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DomHandler (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
接口 DomHandler<ElementT,ResultT extends Result>

所有已知实现类：
W3CDomHandler
public interface DomHandler<ElementT,ResultT extends Result>

在元素（及其子代）与 DOM（或类似对象）表示形式之间相互转换。

此接口的实现将与 XmlAnyElement 注释一起使用，将 XML 的元素映射到信息集（如 W3C DOM）的表示形式。

实现隐藏 XML 的一部分与这些类 DOM 表示形式之间相互转换的方式，并允许 JAXB 提供者处理任意这样的库。

此接口将由库编写器实现，并由 JAXB 提供者使用。这些方法都不应该从应用程序调用。

从以下版本开始：
JAXB2.0

方法摘要
ResultT | createUnmarshaller(ValidationEventHandler errorHandler) 当 JAXB 提供者需要将文档的一部分解组为信息集表示形式时，首先要调用此方法创建一个 Result 对象。
ElementT | getElement(ResultT rt) 将部分发送到 Result 后，JAXB 提供者将调用此方法来获取已解组元素表示形式。
Source | marshal(ElementT n, ValidationEventHandler errorHandler) 在 JAXB 提供者需要将元素编组为 XML 时调用此方法。

方法详细信息

createUnmarshaller

ResultT createUnmarshaller(ValidationEventHandler errorHandler)
当 JAXB 提供者需要将文档的一部分解组为信息集表示形式时，首先要调用此方法创建一个 Result 对象。

然后 JAXB 提供者将 XML 的一部分发送到给定的结果中。这一部分 XML 总是可以形成整个 XML 文档（该文档以某个元素为根）的子树。

参数：
errorHandler - 如果在调用此方法和调用 getElement(Result) 之间发生任何错误，则必须向此处理程序报告。 调用者必须提供一个非 null 错误处理程序。 从此方法创建的 Result 对象可以保存对此错误处理程序的引用。
返回：
如果操作失败，则返回 null。必须向错误处理程序报告错误。

getElement

ElementT getElement(ResultT rt)
将部分发送到 Result 后，JAXB 提供者将调用此方法来获取已解组元素表示形式。

多次调用此方法可能返回不同的对象。在将整个子树填充到 Result 对象时，才可以调用此方法。

参数：
rt - 由 createUnmarshaller(ValidationEventHandler) 创建的 Result 对象。
返回：
如果操作失败，则返回 null。必须向错误处理程序报告错误。

marshal

Source marshal(ElementT n,
               ValidationEventHandler errorHandler)
在 JAXB 提供者需要将元素编组为 XML 时调用此方法。

如果为非 null，则返回的 Source 必须包含以一个元素为根的整个文档，该文档随后将被编制成一个将由 JAXB 提供者编组的更大文档。

参数：
errorHandler - 接收将元素转换成 Source 的过程中发生的任何错误。 调用者必须提供一个非 null 错误处理程序。
返回：
如果有错误，则返回 null。应该向处理程序报告该错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


W3CDomHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 W3CDomHandler

java.lang.Object
    继承者  javax.xml.bind.annotation.W3CDomHandler
所有已实现的接口：
DomHandler<Element,DOMResult>
public class W3CDomHandler
extends Object
implements DomHandler<Element,DOMResult>

W3C DOM（org.w3c.dom 包）的 DomHandler 实现。

从以下版本开始：
JAXB2.0

构造方法摘要
W3CDomHandler()
默认的构造方法。
W3CDomHandler(DocumentBuilder builder)
允许应用程序指定使用哪一个 DOM 实现的构造方法。
方法摘要
DOMResult | createUnmarshaller(ValidationEventHandler errorHandler) 当 JAXB 提供者需要将文档的一部分解组为信息集表示形式时，首先要调用此方法创建一个 Result 对象。
DocumentBuilder | getBuilder()
Element | getElement(DOMResult r) 将部分发送到 Result 后，JAXB 提供者将调用此方法来获取已解组元素表示形式。
Source | marshal(Element element, ValidationEventHandler errorHandler) 在 JAXB 提供者需要将元素编组为 XML 时调用此方法。
void | setBuilder(DocumentBuilder builder)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

W3CDomHandler

public W3CDomHandler()
默认的构造方法。 它取决于 JAXB 提供者决定使用哪一个 DOM 实现或如何进行配置。

W3CDomHandler

public W3CDomHandler(DocumentBuilder builder)
允许应用程序指定使用哪一个 DOM 实现的构造方法。

参数：
builder - 不得为 null。JAXB 使用此 DocumentBuilder 创建新的元素。
方法详细信息

getBuilder

public DocumentBuilder getBuilder()

setBuilder

public void setBuilder(DocumentBuilder builder)

createUnmarshaller

public DOMResult createUnmarshaller(ValidationEventHandler errorHandler)
从接口 DomHandler 复制的描述
当 JAXB 提供者需要将文档的一部分解组为信息集表示形式时，首先要调用此方法创建一个 Result 对象。

然后 JAXB 提供者将 XML 的一部分发送到给定的结果中。这一部分 XML 总是可以形成整个 XML 文档（该文档以某个元素为根）的子树。

指定者：
接口 DomHandler<Element,DOMResult> 中的 createUnmarshaller
参数：
errorHandler - 如果在调用此方法和调用 DomHandler.getElement(Result) 之间发生任何错误，则必须向此处理程序报告。 调用者必须提供一个非 null 错误处理程序。 从此方法创建的 Result 对象可以保存对此错误处理程序的引用。
返回：
如果操作失败，则返回 null。必须向错误处理程序报告错误。

getElement

public Element getElement(DOMResult r)
从接口 DomHandler 复制的描述
将部分发送到 Result 后，JAXB 提供者将调用此方法来获取已解组元素表示形式。

多次调用此方法可能返回不同的对象。在将整个子树填充到 Result 对象时，才可以调用此方法。

指定者：
接口 DomHandler<Element,DOMResult> 中的 getElement
参数：
r - 由 DomHandler.createUnmarshaller(ValidationEventHandler) 创建的 Result 对象。
返回：
如果操作失败，则返回 null。必须向错误处理程序报告错误。

marshal

public Source marshal(Element element,
                      ValidationEventHandler errorHandler)
从接口 DomHandler 复制的描述
在 JAXB 提供者需要将元素编组为 XML 时调用此方法。

如果为非 null，则返回的 Source 必须包含以一个元素为根的整个文档，该文档随后将被编制成一个将由 JAXB 提供者编组的更大文档。

指定者：
接口 DomHandler<Element,DOMResult> 中的 marshal
errorHandler - 接收将元素转换成 Source 的过程中发生的任何错误。 调用者必须提供一个非 null 错误处理程序。
返回：
如果有错误，则返回 null。应该向处理程序报告该错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlAccessOrder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.xml.bind.annotation
枚举 XmlAccessOrder

java.lang.Object
    继承者  java.lang.Enum<XmlAccessOrder>
        继承者  javax.xml.bind.annotation.XmlAccessOrder
所有已实现的接口：
Serializable, Comparable<XmlAccessOrder>
public enum XmlAccessOrder
extends Enum<XmlAccessOrder>

由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。

从以下版本开始：
JAXB2.0
另请参见：
XmlAccessorOrder

枚举常量摘要
ALPHABETICAL
类中的字段和属性是按照方法 java.lang.String.compareTo(String anotherString) 确定的字母顺序进行排列的。
UNDEFINED
类中字段和属性的排序是不确定的。
方法摘要
static XmlAccessOrder | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlAccessOrder[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

UNDEFINED

public static final XmlAccessOrder UNDEFINED
类中字段和属性的排序是不确定的。

ALPHABETICAL

public static final XmlAccessOrder ALPHABETICAL
类中的字段和属性是按照方法 java.lang.String.compareTo(String anotherString) 确定的字母顺序进行排列的。

方法详细信息

values

public static final XmlAccessOrder[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(XmlAccessOrder c : XmlAccessOrder.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static XmlAccessOrder valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


XmlAccessorOrder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlAccessorOrder

@Inherited
@Retention(value=RUNTIME)
@Target(value={PACKAGE,TYPE})
public @interface XmlAccessorOrder

控制类中字段和属性的排序。

用法

@XmlAccessorOrder 注释可以与以下程序元素一起使用：

  • 包
  • 顶层类

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

包上的 @XmlAccessorOrder 注释可应用于包中的所有类。继承语义的应用如下：

  • 如果类中有 @XmlAccessorOrder，则使用它。
  • 如果 @XmlAccessorOrder 存在于某个超类中，则继承它。
  • 否则，将继承包中 @XmlAccessorOrder。

默认规则：

默认情况下，如果包中不存在 @XmlAccessorOrder，那么假定使用以下包级别注释。

@XmlAccessorType(XmlAccessOrder.UNDEFINED)

默认情况下，如果类中不存在 @XmlAccessorOrder，并且没有任何超类是使用 @XmlAccessorOrder 注释的，则假定在类中使用以下默认注释：

@XmlAccessorType(XmlAccessOrder.UNDEFINED)

此注释可以于以下注释一起使用：XmlType、XmlRootElement、XmlAccessorType、XmlSchema、XmlSchemaType、XmlSchemaTypes 和 XmlJavaTypeAdapter。在包级别上它还可以与以下注释一起使用：XmlJavaTypeAdapter。

从以下版本开始：
JAXB2.0
另请参见：
XmlAccessOrder

可选元素摘要
 XmlAccessOrder value

value

public abstract XmlAccessOrder value
默认值：
javax.xml.bind.annotation.XmlAccessOrder.UNDEFINED
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlAccessorType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlAccessorType

@Inherited
@Retention(value=RUNTIME)
@Target(value={PACKAGE,TYPE})
public @interface XmlAccessorType

控制默认情况下是否对字段或 Javabean 属性进行系列化。

用法

@XmlAccessorType 注释可以与以下程序元素一起使用：

  • 包
  • 顶层类

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

此注释可控制类中的属性和字段的默认序列化。

包上的 @XmlAccessorType 注释可应用于包中的所有类。继承语义的应用如下：

  • 如果类中有 @XmlAccessorType，则使用它。
  • 如果 @XmlAccessorType 存在于该类的一个超类中，则继承它。
  • 否则，将继承包中的 @XmlAccessorOrder。

默认规则：

默认情况下，如果包中不存在 @XmlAccessorType，那么假定使用以下包级别注释。

@XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

默认情况下，如果类中不存在 @XmlAccessorType，并且没有任何超类是使用 @XmlAccessorType 注释的，则假定在类中使用以下默认注释：

@XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

此注释可与以下注释一起使用：XmlType、XmlRootElement、XmlAccessorOrder、{@link XmlSchema}、{@link XmlSchemaType}、{@link XmlSchemaTypes} 和 {@link XmlJavaTypeAdapter}。在包级别上它还可以与以下注释一起使用：{@link XmlJavaTypeAdapter}。

从以下版本开始：
JAXB 2.0
另请参见：
XmlAccessType

可选元素摘要
 XmlAccessType value
指定是否对字段或属性进行系列化。

value

public abstract XmlAccessType value
指定是否对字段或属性进行系列化。

另请参见：
XmlAccessType
默认值：
javax.xml.bind.annotation.XmlAccessType.PUBLIC_MEMBER
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlAccessType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.xml.bind.annotation
枚举 XmlAccessType

java.lang.Object
    继承者  java.lang.Enum<XmlAccessType>
        继承者  javax.xml.bind.annotation.XmlAccessType
所有已实现的接口：
Serializable, Comparable<XmlAccessType>
public enum XmlAccessType
extends Enum<XmlAccessType>

由 XmlAccessorType 使用，用于控制字段或属性的序列化。

从以下版本开始：
JAXB2.0
另请参见：
XmlAccessorType

枚举常量摘要
FIELD
JAXB 绑定类中的每个非静态、非瞬态字段将会自动绑定到 XML，除非由 XmlTransient 注释。
NONE
所有字段或属性都不能绑定到 XML，除非使用一些 JAXB 注释专门对它们进行注释。
PROPERTY
JAXB 绑定类中的每个获取方法/设置方法对将会自动绑定到 XML，除非由 XmlTransient 注释。
PUBLIC_MEMBER
每个公共获取方法/设置方法对和每个公共字段将会自动绑定到 XML，除非由 XmlTransient 注释。
方法摘要
static XmlAccessType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlAccessType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

PROPERTY

public static final XmlAccessType PROPERTY
JAXB 绑定类中的每个获取方法/设置方法对将会自动绑定到 XML，除非由 XmlTransient 注释。 只在用一些 JAXB 注释来显式注释字段时，这些字段才绑定到 XML。

FIELD

public static final XmlAccessType FIELD
JAXB 绑定类中的每个非静态、非瞬态字段将会自动绑定到 XML，除非由 XmlTransient 注释。 只在用一些 JAXB 注释来显式注释字段时，getter/setter 对才绑定到 XML。

PUBLIC_MEMBER

public static final XmlAccessType PUBLIC_MEMBER
每个公共获取方法/设置方法对和每个公共字段将会自动绑定到 XML，除非由 XmlTransient 注释。 只在用适当的 JAXB 注释来显式注释那些仅对打包访问而言专用、受保护或默认的字段或获取方法/设置方法对时，才将它们绑定到 XML。

NONE

public static final XmlAccessType NONE
所有字段或属性都不能绑定到 XML，除非使用一些 JAXB 注释专门对它们进行注释。

方法详细信息

values

public static final XmlAccessType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(XmlAccessType c : XmlAccessType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static XmlAccessType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


XmlAnyAttribute (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlAnyAttribute

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAnyAttribute

将 JavaBean 属性映射到通配符属性的映射表中。

用法

@XmlAnyAttribute 注释可以与以下程序元素一起使用：

  • JavaBean 属性
  • 非 static、非 transient 字段

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

用法受到以下约束的限制：
  • 最多只能使用 @XmlAnyAttribute 注释类中的一个字段或属性。
  • 属性或字段的类型必须是 java.util.Map。

在处理将解组成为一个值类的属性时，与另一个 JavaBean 属性不存在静态关联的（通过 XmlAttribute）每个属性都被输入 Map<QName,Object> 表示的通配符属性映射表中。属性 QName 是映射表的键。键值是属性的字符串值。

从以下版本开始：
JAXB2.0

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlAnyElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlAnyElement

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAnyElement

将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。

在将 xml 内容解组到 JAXB 注释类的实例中时，此注释充当 "catch-all" 属性。它通常注释多值的 JavaBean 属性，但它也能够出现在单值的 JavaBean 属性中。在解组过程中，与类中用于其他 JavaBean 属性的静态 @XmlElement 或 @XmlElementRef 注释不匹配的每个 xml 元素都将被添加到此 "catch-all" 属性中。

用法：

 @XmlAnyElement
 public Element[] others;

 // Collection of Element or JAXB elements.
 @XmlAnyElement(lax="true")
 public Object[] others;

 @XmlAnyElement
 private List<Element> nodes;

 @XmlAnyElement
 private Element node;

限制用法约束

此注释与 XmlElement、XmlAttribute、XmlValue、XmlElements、XmlID 和 XmlIDREF 互斥。

在类及其超类中只能有一个 XmlAnyElement 注释的 JavaBean 属性。

与其他注释的关系

此注释可与 XmlJavaTypeAdapter 一起使用，以便用户能够将他们自己的数据结构映射到 DOM，然后可将这些 DOM 组成 XML。

此注释可以按如下方式与 XmlMixed 一起使用：

 // List of java.lang.String or DOM nodes.
 @XmlAnyElement @XmlMixed
 List<Object> others;

将模式转换为 Java 类的示例

以下模式将生成以下 Java 类：

 <xs:complexType name="foo">
   <xs:sequence>
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
   </xs:sequence>
 </xs:complexType>

 class Foo {
   int a;
   int b;
   @XmlAnyElement
   List<Element> any;
 }
它可以按如下方式解组实例：

 <foo xmlns:e="extra">
   <a>1</a>
<e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3</b>
   <e:other />
<c>5</c>     // this will be bound to DOM, because the annotation doesn't remember namespaces.
 </foo>
以下模式将生成以下 Java 类：

 <xs:complexType name="bar">
   <xs:complexContent>
   <xs:extension base="foo">
     <xs:sequence>
       <xs:element name="c" type="xs:int" />
       <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
     </xs:sequence>
   </xs:extension>
 </xs:complexType>

class Bar extends Foo {
int c;
// Foo.getAny() also represents wildcard content for type definition bar.
 }
它可以按如下方式解组实例：

 <bar xmlns:e="extra">
   <a>1</a>
<e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3</b>
   <e:other />
<c>5</c>     // this now goes to Bar.c
<e:other />  // this will go to Foo.any
 </bar>

将 XmlElementRef 与 XmlAnyElement 一起使用

XmlAnyElement 注释可与 XmlElementRef 一起使用，用于指派能够参与目录树的其他元素。

以下模式将生成以下 Java 类：

 <xs:complexType name="foo">
   <xs:choice maxOccurs="unbounded" minOccurs="0">
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" />
   </xs:choice>
 </xs:complexType>

 class Foo {
   @XmlAnyElement(lax="true")
   @XmlElementRefs({
     @XmlElementRef(name="a", type="JAXBElement.class")
     @XmlElementRef(name="b", type="JAXBElement.class")
   })
   List<Object> others;
 }

 @XmlRegistry
 class ObjectFactory {
   ...
   @XmlElementDecl(name = "a", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooA( Integer i ) { ... }

   @XmlElementDecl(name = "b", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooB( Integer i ) { ... }
它可以按如下方式解组实例：

 <foo xmlns:e="extra">
<a>1</a>     // this will unmarshal to a <A HREF="../../../../javax/xml/bind/JAXBElement.html" title="javax.xml.bind 中的类"><CODE>JAXBElement</CODE></A> instance whose value is 1.
<e:other />  // this will unmarshal to a DOM <A HREF="../../../../org/w3c/dom/Element.html" title="org.w3c.dom 中的接口"><CODE>Element</CODE></A>.
<b>3</b>     // this will unmarshal to a <A HREF="../../../../javax/xml/bind/JAXBElement.html" title="javax.xml.bind 中的类"><CODE>JAXBElement</CODE></A> instance whose value is 1.
 </foo>

W3C XML 模式 "lax" 通配符仿真

注释的 lax 元素启用了 "lax" 通配符语义的仿真。例如，当按如下方式注释 Java 源代码时：
 @XmlRootElement
 class Foo {
   @XmlAnyElement(lax=true)
   public Object[] others;
 }
那么下列文档将按如下方式解组：

 <foo>
   <unknown />
   <foo />
 </foo>

Foo foo = unmarshal();
// 1 for 'unknown', another for 'foo'
assert foo.others.length==2;
// 'unknown' unmarshals to a DOM element
assert foo.others[0] instanceof Element;
// because of lax=true, the 'foo' element eagerly
// unmarshals to a Foo object.
assert foo.others[1] instanceof Foo;

从以下版本开始：
JAXB2.0

可选元素摘要
boolean | lax 在查看当前 JAXBContext 中的已知元素时控制解组行为。
Class<? extends DomHandler> | value 指定 DomHandler，它负责实际执行 XML 与类 DOM 数据结构之间的转换。

lax

public abstract boolean lax
在查看当前 JAXBContext 中的已知元素时控制解组行为。

当为 false 时

如果为 false，则所有与该属性匹配的元素都将被解组为 DOM，并且该属性将只包含 DOM 元素。

当为 true 时

如果为 true，则当某一元素与使用 JAXBContext 已知的 XmlAnyElement 标记的属性匹配时（例如，存在具有相同标记名称的带有 XmlRootElement 的类，或者存在具有相同标记名称的 XmlElementDecl），unmarshaller 会立即将此元素解组到 JAXB 对象，而不是解组到 DOM。此外，如果元素是未知的，但它有一个已知的 xsi:type，则通过使用未知的元素名称和设置为已知 xsi:type 的 JAXB 映射实例的 JAXBElement 值，unmarshaller 可立即将此元素解组到 JAXBElement。

因此，在解组之后，属性可能变得完全不同，它可能在包含 DOM 节点的同时还包含一些 JAXB 对象。

可以使用这种特性来仿真 W3C XML 模式的 "lax" 通配符语义。

默认值：
false

value

public abstract Class<? extends DomHandler> value
指定 DomHandler，它负责实际执行 XML 与类 DOM 数据结构之间的转换。

默认值：
javax.xml.bind.annotation.W3CDomHandler.class
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlAttachmentRef (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlAttachmentRef

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlAttachmentRef

标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。MIME 内容作为附件被优化存储在行外（out-of-line）。 字段/属性必须始终映射到 DataHandler 类。

用法

从以下版本开始：

JAXB2.0

      概述
      软件包
    类
      使用
      树
      已过时
      索引
      帮助

JavaTM Platform
Standard Ed. 6

 上一个类
 下一个类

  框架
 无框架

  摘要： 必需 | 可选

详细信息： 元素


XmlAttribute (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlAttribute

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAttribute

将 JavaBean 属性映射到 XML 属性。

用法

@XmlAttribute 注释能够与下列程序元素一起使用：

  • JavaBean 属性
  • 字段

一个 static final 字段将被映射到 XML fixed 属性。

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

用法受到以下约束的限制：
  • 如果字段或属性的类型是集合类型，则必须将集合项类型必须映射到简单模式类型。
         // Examples
     @XmlAttribute List<Integer> items; //legal
     @XmlAttribute List<Bar> foo; // illegal if Bar does not map to a schema simple type
  • 如果字段或属性的类型是非集合类型，则必须将属性或字段的类型映射到简单模式类型。
         // Examples
     @XmlAttribute int foo; // legal
     @XmlAttribute Foo foo; // illegal if Foo does not map to a schema simple type
  • 此注释可与以下注释一起使用：XmlID、XmlIDREF、XmlList、XmlSchemaType、XmlValue、XmlAttachmentRef、XmlMimeType、XmlInlineBinaryData 和 XmlJavaTypeAdapter。
    • .

示例 1：将 JavaBean 属性映射到 XML 属性。

     //Example: Code fragment
     public class USPrice {
         @XmlAttribute
         public java.math.BigDecimal getPrice() {...} ;
         public void setPrice(java.math.BigDecimal ) {...};
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="USPrice">
       <xs:sequence>
       </xs:sequence>
       <xs:attribute name="price" type="xs:decimal"/>
     </xs:complexType>

示例 2：将 JavaBean 属性映射到带有匿名类型的 XML 属性。

请参阅 @XmlType 中的示例 7。

示例 3：将 JavaBean 集合属性映射到 XML 属性。

     // Example: Code fragment
     class Foo {
         ...
         @XmlAttribute List<Integer> items;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="foo">
         ...
       <xs:attribute name="items">
         <xs:simpleType>
           <xs:list itemType="xs:int"/>
         </xs:simpleType>
     </xs:complexType>

从以下版本开始：
JAXB2.0
另请参见：
XmlType

可选元素摘要
String | name XML 模式属性的名称。
String | namespace 指定 XML 模式属性的 XML 目标名称空间。
boolean | required 指定 XML 模式属性是可选的还是必需的。

name

public abstract String name
XML 模式属性的名称。默认情况下，XML 模式属性名称派生自 JavaBean 属性名称。

默认值：
"##default"

required

public abstract boolean required
指定 XML 模式属性是可选的还是必需的。如果为 true，则将 JavaBean 属性映射到必需的 XML 模式属性。否则，将它映射到可选的 XML 模式属性。

默认值：
false

namespace

public abstract String namespace
指定 XML 模式属性的 XML 目标名称空间。

默认值：
"##default"
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlElement

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElement

将 JavaBean 属性映射到派生于属性名称的 XML 元素。

用法

@XmlElement 注释可以与以下程序元素一起使用：

  • JavaBean 属性
  • 非 static、非 transient 字段
  • XmlElements 中的程序元素

用法受到以下约束的限制：
  • 此注释可与以下注释一起使用：XmlID、XmlIDREF、XmlList、XmlSchemaType、XmlValue、XmlAttachmentRef、XmlMimeType、XmlInlineBinaryData、XmlElementWrapper 和 XmlJavaTypeAdapter。
  • 如果 JavaBean 属性的类型是数组的集合类型、索引 (indexed) 属性或参数化列表，并且此注释与 XmlElements 一起使用，那么 @XmlElement.type() 在集合条目类型已知的情况下必须是 DEFAULT.class。

在使用 @XmlElement 注释进行注释时，JavaBean 属性被映射到 XML 模式复杂类型中的本地元素，包含的类被映射到此 XML 模式复杂类型。

示例 1：将 public 非 static 非 final 字段映射到本地元素。

     //Example: Code fragment
     public class USPrice {
         @XmlElement(name="itemprice")
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="itemprice" type="xs:decimal" minOccurs="0"/>
       </sequence>
     </xs:complexType>

示例 2：将字段映射到 nillable 元素。

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="0"/>
       </sequence>
     </xs:complexType>

示例 3: 将字段映射到 nillable、required 元素。

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true, required=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="1"/>
       </sequence>
     </xs:complexType>

示例 4：将 JavaBean 属性映射到具有匿名类型的 XML 元素。

请参阅 @XmlType 中的示例 6。

从以下版本开始：
JAXB 2.0

可选元素摘要
String | defaultValue 此元素的默认值。
String | name XML 模式元素的名称。
String | namespace XML 模式元素的 XML 目标名称空间。
boolean | nillable 将元素声明自定义为 nillable。
boolean | required 自定义所需的元素声明。
Class | type 正被引用的 Java 类。

name

public abstract String name
XML 模式元素的名称。

如果值为 "##default"，那么元素名称派生于 JavaBean 属性名称。

默认值：
"##default"

nillable

public abstract boolean nillable
将元素声明自定义为 nillable。

如果 nillable() 为 true，那么 JavaBean 属性被映射到 XML 模式 nillable 元素声明。

默认值：
false

required

public abstract boolean required
自定义所需的元素声明。

如果 required() 为 true，则将 Javabean 属性映射到一个 minOccurs="1" 的 XML 模式元素声明。maxOccurs 为 "1" 表示单个赋值的属性，maxOccurs 为 "unbounded" 则表示多个赋值的属性。

如果 required() 为 false，则将 Javabean 属性映射到一个 minOccurs="0" 的 XML 模式元素声明。maxOccurs 为 "1" 表示单个赋值的属性，maxOccurs 为 "unbounded" 则表示多个赋值的属性。

默认值：
false

namespace

public abstract String namespace
XML 模式元素的 XML 目标名称空间。

如果该值为 "##default"，则名称空间通过以下方式确定：

  1. 如果封闭包中包含 XmlSchema 注释，并且其 elementFormDefault 为 QUALIFIED，则名称空间为封闭类的名称空间。
  2. 否则名称空间为 ""（这将导致在默认名称空间中生成非限定元素）。

默认值：
"##default"

defaultValue

public abstract String defaultValue
此元素的默认值。

作为此注释元素的默认值指定的 '' 值被用作 null 的替代，从而允许识别 'no default value' 状态。

默认值：
"\u0000"

type

public abstract Class type
正被引用的 Java 类。

默认值：
javax.xml.bind.annotation.XmlElement.DEFAULT.class
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlElement.DEFAULT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlElement.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlElement.DEFAULT
正在封闭类：
XmlElement
public static final class XmlElement.DEFAULT
extends Object

在 XmlElement.type() 中使用，用于表示根据属性签名推断出来的类型。

构造方法摘要
XmlElement.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlElement.DEFAULT

public XmlElement.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlElementDecl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlElementDecl

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface XmlElementDecl

将工厂方法映射到 XML 元素。

用法

该注释在 XML 模式元素声明与元素工厂方法之间创建了映射关系，元素工厂方法返回表示元素声明的 JAXBElement 实例。通常，元素工厂方法是根据 Java 包的 ObjectFactory 类中的模式生成（并注解）的，它表示元素声明的目标名称空间的绑定。因此，当注释语法允许在任何方法上使用 @XmlElementDecl 时，从语义上说，它的使用受限于元素工厂方法的注释。 用法受到以下约束的限制：
  • 包含使用 @XmlElementDecl 注释的元素工厂方法的类必须使用 XmlRegistry 标记。
  • 元素工厂方法必须采用一个可分配给 Object 的参数。

示例 1：工厂方法上的注释

     // Example: code fragment
     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="foo")
         JAXBElement<String> createFoo(String s) { ... }
     }

     <!-- XML input -->
       <foo>string</foo>

     // Example: code fragment corresponding to XML input
     JAXBElement<String> o =
     (JAXBElement<String>)unmarshaller.unmarshal(aboveDocument);
     // print JAXBElement instance to show values
     System.out.println(o.getName());   // prints  "{}foo"
     System.out.println(o.getValue());  // prints  "string"
     System.out.println(o.getValue().getClass()); // prints "java.lang.String"

     <!-- Example: XML schema definition -->
     <xs:element name="foo" type="xs:string"/>

示例 2：具有非本地作用域的元素声明

以下示例演示了如何在模式派生代码的元素声明绑定中使用作用域注释参数。

在此 javadoc 以后的版本中可能会替换以下示例。

     <!-- Example: XML schema definition -->
     <xs:schema>
       <xs:complexType name="pea">
         <xs:choice maxOccurs="unbounded">
           <xs:element name="foo" type="xs:string"/>
           <xs:element name="bar" type="xs:string"/>
         </xs:choice>
       </xs:complexType>
       <xs:element name="foo" type="xs:int"/>
     </xs:schema>

     // Example: expected default binding
     class Pea {
         @XmlElementRefs({
             @XmlElementRef(name="foo",type=JAXBElement.class)
             @XmlElementRef(name="bar",type=JAXBElement.class)
         })
         List<JAXBElement<String>> fooOrBar;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(scope=Pea.class,name="foo")
         JAXBElement createPeaFoo(String s);

         @XmlElementDecl(scope=Pea.class,name="bar")
         JAXBElement createPeaBar(String s);

         @XmlElementDecl(name="foo")
         JAXBElement createFoo(Integer i);
     }
没有作用域，createFoo 和 createPeaFoo 将变得不明确，因为它们两个都使用相同的本地名称 "foo" 映射到 XML 模式元素。

从以下版本开始：
JAXB 2.0
另请参见：
XmlRegistry

必需元素摘要
 String name
XML 元素的本地名称。
可选元素摘要
String | defaultValue 此元素的默认值。
String | namespace XML 元素的名称空间名。
Class | scope 映射的作用域。
String | substitutionHeadName 替换组的头元素的 XML 本地名称。
String | substitutionHeadNamespace 替换组的头 XML 元素的名称空间名。

元素详细信息

name

public abstract String name
XML 元素的本地名称。

审阅者的注释：没有默认名称；因为注释是在工厂方法上，所以能否从工厂方法名称派生方法名称不是很清楚。

另请参见：
namespace()

scope

public abstract Class scope
映射的作用域。

如果此值不是 XmlElementDecl.GLOBAL，那么此元素声明映射只有在指定类中才是活动的。

默认值：
javax.xml.bind.annotation.XmlElementDecl.GLOBAL.class

namespace

public abstract String namespace
XML 元素的名称空间名。

如果值是 "##default"，那么该值是实现包含此工厂方法类的包的名称空间名。

另请参见：
name()
默认值：
"##default"

substitutionHeadNamespace

public abstract String substitutionHeadNamespace
替换组的头 XML 元素的名称空间名。

此值指定本地名称由 substitutionHeadName() 指定的 XML 元素的名称空间名。

如果 susbtitutionHeadName() 为 ""，则此值只能是 "##default"。但该值被忽略，因为在 susbstitutionHeadName() 的值是 "" 时，此元素不是替换组的一部分。

如果 susbtitutionHeadName() 不是 ""，并且值为 "##default"，那么名称空间名是包含用 XmlRegistry 标记的类的包所映射到的名称空间名。

如果 susbtitutionHeadName() 不是 "" 并且值不是 "##default"，那么该值是名称空间名。

另请参见：
substitutionHeadName()
默认值：
"##default"

substitutionHeadName

public abstract String substitutionHeadName
替换组的头元素的 XML 本地名称。

如果值是 ""，那么此元素不是任何替换组的一部分。

另请参见：
substitutionHeadNamespace()
默认值：
""

defaultValue

public abstract String defaultValue
此元素的默认值。

作为此注释元素的默认值指定的 '' 值被用作 null 的替代，从而允许识别 'no default value' 状态。

默认值：
"\u0000"
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlElementDecl.GLOBAL (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlElementDecl.GLOBAL

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlElementDecl.GLOBAL
正在封闭类：
XmlElementDecl
public static final class XmlElementDecl.GLOBAL
extends Object

在 XmlElementDecl.scope() 中使用，指示声明是全局范围的。

构造方法摘要
XmlElementDecl.GLOBAL()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlElementDecl.GLOBAL

public XmlElementDecl.GLOBAL()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlElementRef (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlElementRef

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementRef

将 JavaBean 属性映射到派生于属性类型的 XML 元素。

用法

@XmlElementRef 注释可以与 JavaBean 属性一起使用或在 XmlElementRefs 中使用。

此注释将 XML 元素名称与 JavaBean 属性动态关联起来。当 JavaBean 属性使用 XmlElement 进行注释时，XML 元素名称以静态方式派生于 JavaBean 属性名称。但是，在使用此注释时，XML 元素名称派生于运行时的 JavaBean 属性类型的实例。

XML 模式替换组支持

XML 模式允许 XML 文档作者使用 XML 元素名称，这里的名称指没有在使用替换组的模式的内容模式中静态指定的名称。模式派生代码为使用元素属性的替换组提供了支持（请参阅 JAXB 2.0 规范的第 5.5.5 节：“元素属性”）。元素属性方法签名的形式如下：

public void setTerm(JAXBElement<? extends Operator>);
public JAXBElement<? extends Operator> getTerm();

用 XmlElementDecl 注释的元素工厂方法用于创建包含 XML 元素名称的 JAXBElement 实例。元素属性中出现 @XmlElementRef 注释则表示使用取自 JAXBElement 实例的元素名称，而不是从 JavaBean 属性名称中派生一个 XML 元素名称。

  • 如果集合条目类型（用于集合属性）或属性类型（用于单个赋值属性）是 JAXBElement，则 @XmlElementRef}.name() 和 @XmlElementRef.namespace() 必须指向一个元素工厂方法，并在使用 @XmlRegistry 注释的类中存在一个 @XmlElementDecl 注释（通常 ObjectFactory 类由模式编译器生成）：
    • @XmlElementDecl.name() 必须等于 @XmlElementRef.name()
    • @XmlElementDecl.namespace() 必须等于 @XmlElementRef.namespace()。
  • 如果集合条目类型（用于集合属性）或属性类型（用于单个赋值属性）不是 JAXBElement，则由属性或字段引用的类型必须是使用 XmlRootElement 注释的。
  • 此注释可以与以下注释一起使用：XmlElementWrapper 和 XmlJavaTypeAdapter。

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

示例 1：Ant 任务示例

以下 Java 类层次结构建立了 Ant 构建脚本模型。Ant 任务对应于类层次结构中的类。Ant 任务的 XML 元素名称由其对应类上的 @XmlRootElement 注释指示。
     @XmlRootElement(name="target")
     class Target {
         // The presence of @XmlElementRef indicates that the XML
         // element name will be derived from the @XmlRootElement
         // annotation on the type (for e.g. "jar" for JarTask).
         @XmlElementRef
         List<Task> tasks;
     }

     abstract class Task {
     }

     @XmlRootElement(name="jar")
     class JarTask extends Task {
         ...
     }

     @XmlRootElement(name="javac")
     class JavacTask extends Task {
         ...
     }

     <!-- XML Schema fragment -->
     <xs:element name="target" type="Target">
     <xs:complexType name="Target">
       <xs:sequence>
         <xs:choice maxOccurs="unbounded">
           <xs:element ref="jar">
           <xs:element ref="javac">
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

因此下列代码片段

Target target = new Target();
target.tasks.add(new JarTask());
target.tasks.add(new JavacTask());
marshal(target);
将生成以下 XML 输出：

     <target>
       <jar>
         ....
       </jar>
       <javac>
         ....
       </javac>
     </target>

有一个类扩展了不具有 XmlRootElement 的 Task 并不是一个错误。但是这些类将无法出现在 XML 实例中（因为它们没有 XML 元素名称）。

示例 2：XML 模式替换组支持

以下示例显示用于 XML 模式替换组的注释。注释和 ObjectFactory 都派生于模式。

     @XmlElement
     class Math {
         //  The value of type()is
         //  JAXBElement.class , which indicates the XML
         //  element name ObjectFactory - in general a class marked
         //  with @XmlRegistry. (See ObjectFactory below)
         //
         //  The name() is "operator", a pointer to a
         // factory method annotated with a
         //  XmlElementDecl with the name "operator". Since
         //  "operator" is the head of a substitution group that
         //  contains elements "add" and "sub" elements, "operator"
         //  element can be substituted in an instance document by
         //  elements "add" or "sub". At runtime, JAXBElement
         //  instance contains the element name that has been
         //  substituted in the XML document.
         //
         @XmlElementRef(type=JAXBElement.class,name="operator")
         JAXBElement<? extends Operator> term;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="operator")
         JAXBElement<Operator> createOperator(Operator o) {...}
         @XmlElementDecl(name="add",substitutionHeadName="operator")
         JAXBElement<Operator> createAdd(Operator o) {...}
         @XmlElementDecl(name="sub",substitutionHeadName="operator")
         JAXBElement<Operator> createSub(Operator o) {...}
     }

     class Operator {
         ...
     }

因此以下代码片段

Math m = new Math();
m.term = new ObjectFactory().createAdd(new Operator());
marshal(m);
将生成以下 XML 输出：
<math>
<add>...</add>
</math>

从以下版本开始：
JAXB 2.0
另请参见：
XmlElementRefs

可选元素摘要
String | name
String | namespace 可以使用此参数和 name() 来确定 JavaBean 属性的 XML 元素。
Class | type 被引用的 Java 类型。

type

public abstract Class type
被引用的 Java 类型。

如果该值为 DEFAULT.class，则可以从 JavaBean 属性类型推导出该类型。

默认值：
javax.xml.bind.annotation.XmlElementRef.DEFAULT.class

namespace

public abstract String namespace
可以使用此参数和 name() 来确定 JavaBean 属性的 XML 元素。

如果 type() 是 JAXBElement.class，那么 namespace() 和 name() 指向带有 XmlElementDecl 的工厂方法。XML 元素名称是工厂方法的 XmlElementDecl 注释的元素名称，如果取自其替换组中的元素（替换组的头元素）在 XML 文档中已被替换，则 XML 元素名称取自替换元素的 XmlElementDecl。

如果 type() 不是 JAXBElement.class，那么 XML 元素名称是与使用该类型上的 XmlRootElement 注释的类型静态关联的 XML 元素名称。如果没有使用 XmlElementDecl 注释该类型，那么它是一个错误。

如果 type() 不是 JAXBElement.class，那么此值必须是 ""。

默认值：
""

name

public abstract String name
另请参见：
namespace()
默认值：
"##default"
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlElementRef.DEFAULT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlElementRef.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlElementRef.DEFAULT
正在封闭类：
XmlElementRef
public static final class XmlElementRef.DEFAULT
extends Object

在 XmlElementRef.type() 中使用，用于表示根据属性签名推断出来的类型。

构造方法摘要
XmlElementRef.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlElementRef.DEFAULT

public XmlElementRef.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlElementRefs (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlElementRefs

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementRefs

标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。

与元素属性（带有 XmlElement 注释的属性）比较，引用属性具有不同的替换语义。在将子类分配给属性时，元素属性将生成带有 @xsi:type 的相同标记名称，而引用属性则生成一个不同的标记名称（子类上的标记名称）。

此注释可与下列注释一起使用：XmlJavaTypeAdapter 和 XmlElementWrapper。

从以下版本开始：
JAXB 2.0
另请参见：
XmlElementWrapper, XmlElementRef

必需元素摘要
 XmlElementRef[] value

元素详细信息

value

public abstract XmlElementRef[] value
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlElements (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlElements

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElements

多个 @XmlElement 注释的容器。 在一个程序元素上不允许使用多个相同类型的注释。因此此注释用于充当多个 @XmlElements 的容器注释，如下所示：

 @XmlElements({ @XmlElement(...),@XmlElement(...) })

@XmlElements 注释可以与以下程序元素一起使用：

  • JavaBean 属性
  • 非 static、非 transient 字段
此注释用于注释 JavaBean 集合属性（如列表）。

用法

用法受到以下约束的限制：

  • 此注释可与以下注释一起使用：@XmlIDREF 和 @XmlElementWrapper。
  • 如果将 @XmlIDREF 也指定到 JavaBean 属性，那么每个 @XmlElement.type() 都必须包含使用 @XmlID 注释的 JavaBean 属性。

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

示例 1：映射到元素列表

    // Mapped code fragment
    public class Foo {
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
         }
         public List items;
    }

    <!-- XML Representation for a List of {1,2.5}
            XML output is not wrapped using another element -->
    ...
     1
     2.5
    ...

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:choice minOccurs="0" maxOccurs="unbounded">
          <xs:element name="A" type="xs:int"/>
          <xs:element name="B" type="xs:float"/>
        <xs:choice>
      </xs:sequence>
    </xs:complexType>

示例 2：映射到使用另一个元素包装的元素列表

    // Mapped code fragment
    public class Foo {
        @XmlElementWrapper(name="bar")
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
        }
        public List items;
    }

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="xs:int"/>
              <xs:element name="B" type="xs:float"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>

示例 3：根据类型使用适配器更改元素名称。

    class Foo {
       @XmlJavaTypeAdapter(QtoPAdapter.class)
       @XmlElements({
           @XmlElement(name="A",type=PX.class),
           @XmlElement(name="B",type=PY.class)
       })
       Q bar;
    }

    @XmlType abstract class P {...}
    @XmlType(name="PX") class PX extends P {...}
    @XmlType(name="PY") class PY extends P {...}

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="PX"/>
              <xs:element name="B" type="PY"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>

从以下版本开始：
JAXB2.0
另请参见：
XmlElement, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter

必需元素摘要
 XmlElement[] value
@XmlElement 注释的集合。

元素详细信息

value

public abstract XmlElement[] value
@XmlElement 注释的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlElementWrapper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlElementWrapper

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementWrapper

生成一个包装 XML 表示形式的包装器元素。 此元素主要用于生成一个包装集合的包装器 XML 元素。因此，该注释支持以下两种形式的序列化。

//Example:code fragment
int[] names;

// XML Serialization Form 1 (Unwrapped collection)
<names> ...</names>
<names> ...</names>

// XML Serialization Form 2 ( Wrapped collection )
<wrapperElement>
<names> value-of-item </names>
<names> value-of-item </names>
       ....
</wrapperElement>

通过使用或不使用具有 nillable 属性的元素，两种序列化的 XML 形式可以表示 null 集合。

使用

@XmlElementWrapper 注释可以与以下程序元素一起使用：

  • JavaBean 属性
  • 非 static、非 transient 字段

用法受到以下约束的限制：

  • 该属性必须是一个集合属性
  • 此注释可与以下注释一起使用：XmlElement、XmlElements、XmlElementRef、XmlElementRefs、XmlJavaTypeAdapter。

有关其他公共消息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

从以下版本开始：
JAXB 2.0
另请参见：
XmlElement, XmlElements, XmlElementRef, XmlElementRefs

可选元素摘要
String | name XML 包装器元素的名称。
String | namespace XML 包装器元素的 XML 目标名称空间。
boolean | nillable 如果为 true，则使用 xsi:nil='true' 表示集合不存在。

name

public abstract String name
XML 包装器元素的名称。默认情况下，XML 包装器元素的名称派生于 JavaBean 属性名称。

默认值：
"##default"

namespace

public abstract String namespace
XML 包装器元素的 XML 目标名称空间。

如果该值为 "##default"，则名称空间通过以下方式确定：

  1. 如果封闭包中包含 XmlSchema 注释，并且其 elementFormDefault 为 QUALIFIED，则名称空间为封闭类的名称空间。
  2. 否则名称空间为 ""（这将导致在默认名称空间中生成非限定的元素）。

默认值：
"##default"

nillable

public abstract boolean nillable
如果为 true，则使用 xsi:nil='true' 表示集合不存在。否则通过不使用该元素来表示集合不存在。

默认值：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlEnum (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlEnum

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlEnum

将枚举类型 Enum 映射到 XML 表示形式。

此注释以及 XmlEnumValue 提供了枚举类型到 XML 表示形式的映射。

用法

@XmlEnum 注释能够与以下程序元素一起使用：

  • 枚举类型

用法受到以下约束的限制：

  • 此注释能够与以下其他注释一起使用：XmlType 和 XmlRootElement。

有关公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

枚举类型被映射到带有 enumeration facet 的模式简单类型。模式类型派生于 @XmlEnum.value() 中指定的 Java 类型。每个枚举常量 @XmlEnumValue 都必须有一个用于 @XmlEnum.value() 类型的有效词法表示形式。

示例：请参阅 XmlEnumValue 中的示例。

从以下版本开始：
JAXB2.0

可选元素摘要
 Class<?> value
映射到 XML 简单类型的 Java 类型。

value

public abstract Class<?> value
映射到 XML 简单类型的 Java 类型。

默认值：
java.lang.String.class
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlEnumValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlEnumValue

@Retention(value=RUNTIME)
@Target(value=FIELD)
public @interface XmlEnumValue

将 Enum 类型中的枚举常量映射到 XML 表示形式。

用法

@XmlEnumValue 注释可以与以下程序元素一起使用：

  • 枚举常量

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

此注释以及 XmlEnum 提供枚举类型到 XML 表示形式的映射。

枚举类型被映射到带有 enumeration facet 的模式简单类型。模式类型派生于 @XmlEnum.value() 中指定的 Java 类型。每个枚举常量 @XmlEnumValue 都必须有一个用于 @XmlEnum.value() 类型的有效词法表示形式。

在没有此注释的情况下，Enum.name() 用作 XML 表示形式。

示例 1：映射枚举常量名称 -> enumeration facet

     //Example: Code fragment
     @XmlEnum(String.class)
     public enum Card { CLUBS, DIAMONDS, HEARTS, SPADES }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Card">
       <xs:restriction base="xs:string"/>
         <xs:enumeration value="CLUBS"/>
         <xs:enumeration value="DIAMONDS"/>
         <xs:enumeration value="HEARTS"/>
         <xs:enumeration value="SPADES"/>
     </xs:simpleType>

示例 2：映射枚举常量名称（值） -> enumeration facet

     //Example: code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Coin {
         @XmlEnumValue("1") PENNY(1),
         @XmlEnumValue("5") NICKEL(5),
         @XmlEnumValue("10") DIME(10),
         @XmlEnumValue("25") QUARTER(25) }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Coin">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="5"/>
         <xs:enumeration value="10"/>
         <xs:enumeration value="25"/>
       </xs:restriction>
     </xs:simpleType>

示例 3：映射枚举常量名称 -> enumeration facet

     //Code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Code {
         @XmlEnumValue("1") ONE,
         @XmlEnumValue("2") TWO;
     }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Code">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="2"/>
       </xs:restriction>
     </xs:simpleType>

从以下版本开始：
JAXB 2.0

必需元素摘要
 String value

元素详细信息

value

public abstract String value
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlID

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlID

将 JavaBean 属性映射到 XML ID。

要在 XML 序列化然后反序列化这一过程中保持对象图形的引用完整性，需要通过使用引用或容器适当地对对象引用进行编组。注释 @XmlID 和 @XmlIDREF 一起使用时允许通过容器或引用来实现 JavaBean 属性类型的自定义映射。

用法

@XmlID 注释能够与以下程序元素一起使用：
  • JavaBean 属性
  • 非 static、非 transient 字段

有关公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

用法受到以下约束的限制：
  • 只能使用 @XmlID 注释一个类中最多一个字段或属性。
  • JavaBean 属性的类型必须是 java.lang.String。
  • 能够与 @XmlID 一起使用的其他映射注释只有 @XmlElement 和 @XmlAttribute。

示例：将 JavaBean 属性的类型映射到 xs:ID

    // Example: code fragment
    public class Customer {
        @XmlAttribute
        @XmlID
        public String getCustomerID();
        public void setCustomerID(String id);
        .... other properties not shown
    }

    <!-- Example: XML Schema fragment -->
    <xs:complexType name="Customer">
      <xs:complexContent>
        <xs:sequence>
          ....
        </xs:sequence>
        <xs:attribute name="customerID" type="xs:ID"/>
      </xs:complexContent>
    </xs:complexType>

从以下版本开始：
JAXB2.0
另请参见：
XmlIDREF

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlIDREF (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlIDREF

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlIDREF

将 JavaBean 属性映射到 XML IDREF。

要在 XML 序列化然后反序列化这一过程中保持对象图形的引用完整性，需要通过使用引用或容器适当地对对象引用进行编组。注释 @XmlID 和 @XmlIDREF 一起使用时允许通过容器或引用来实现 JavaBean 属性类型的自定义映射。

用法

@XmlIDREF 注释能够与以下程序元素一起使用：
  • JavaBean 属性
  • 非 static、非 transient 字段

有关其他公共消息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

用法受到以下约束的限制：

  • 如果字段或属性的类型是一个 collection 类型，则集合项类型必须包含一个用 @XmlID 注释的属性或字段。
  • 如果字段或属性的类型是 single valued，则属性或字段的类型必须包含一个用 @XmlID 注释的属性或字段。

    注：如果集合项类型或属性的类型（用于非 collection 类型）是 java.lang.Object，则该实例必须包含一个用 @XmlID 属性注释的属性/字段。

  • 此注释可与以下注释一起使用：XmlElement、XmlAttribute、XmlList 和 XmlElements。

示例：将 JavaBean 属性映射到 xs:IDREF（即通过引用而不是通过包含）。

   //EXAMPLE: Code fragment
   public class Shipping {
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
       ....
    }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

示例 2：以下是一个对比容器与引用的完整示例。

    // By default, Customer maps to complex type xs:Customer
    public class Customer {

        // map JavaBean property type to xs:ID
        @XmlID public String getCustomerID();
        public void setCustomerID(String id);

        // .... other properties not shown
    }

   // By default, Invoice maps to a complex type xs:Invoice
   public class Invoice {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);

      // .... other properties not shown here
   }

   // By default, Shipping maps to complex type xs:Shipping
   public class Shipping {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
   }

   // at least one class must reference Customer by containment;
   // Customer instances won't be marshalled.
   @XmlElement(name="CustomerData")
   public class CustomerData {
       // map reference to Customer by containment by default.
       public Customer getCustomer();

       // maps reference to Shipping by containment by default.
       public Shipping getShipping();

       // maps reference to Invoice by containment by default.
       public Invoice getInvoice();
   }

   <!-- XML Schema mapping for above code frament -->

   <xs:complexType name="Invoice">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Customer">
     <xs:complexContent>
       <xs:sequence>
         ....
       </xs:sequence>
       <xs:attribute name="CustomerID" type="xs:ID"/>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="CustomerData">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:Customer"/>
         <xs:element name="shipping" type="xs:Shipping"/>
         <xs:element name="invoice"  type="xs:Invoice"/>
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:element name"customerData" type="xs:CustomerData"/>

   <!-- Instance document conforming to the above XML Schema -->
    <customerData>
       <customer customerID="Alice">
           ....
       </customer>

       <shipping customer="Alice">
           ....
       </shipping>

       <invoice customer="Alice">
           ....
       </invoice>
   </customerData>

示例 3：将列表映射到 IDREF 类型的重复元素。

     // Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElement(name="Alice")
             public List customers;
     }

     <!-- XML schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

示例 4：将列表映射到 IDREF 类型的元素列表。

     //Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElements(
             @XmlElement(name="Alice", type="Customer.class")
              @XmlElement(name="John", type="InternationalCustomer.class")
         public List customers;
     }

     <!-- XML Schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
           <xs:element name="John" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

从以下版本开始：
JAXB2.0
另请参见：
XmlID

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlInlineBinaryData (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlInlineBinaryData

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,TYPE})
public @interface XmlInlineBinaryData

禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。

当启用 XOP 编码时（如 AttachmentMarshaller.isXOPPackage() 中所述），此注释禁用绑定到 base64-encoded 二进制数据的数据类型（如 Image、Source 或 byte[]），从而防止对它们进行 XOP 编码。如果 JAXB 属性使用此注释进行注释，或者 JAXB 属性的基本类型使用此注释进行注释，那么永远不会对该属性调用 AttachmentMarshaller.addMtomAttachment(DataHandler, String, String) 和 AttachmentMarshaller.addMtomAttachment(byte[], int, int, String, String, String)。二进制数据将总是被内联。

从以下版本开始：
JAXB2.0

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlList (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlList

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlList

用来将属性映射到列表简单类型。

用法

@XmlList 注释能够与以下程序元素一起使用：

  • JavaBean 属性
  • 字段

在集合属性仅使用 @XmlElement 进行注释时，将通过元素包装集合中的每一个项。例如，

 @XmlRootElement
 class Foo {
     @XmlElement
     List<String> data;
 }
将生成如下 XML：

 <foo>
<data>abc</data>
<data>def</data>
 </foo>
另一方面，@XmlList 注释允许将多个值表示为单个元素中以空格分隔的标记。例如，
 @XmlRootElement
 class Foo {
     @XmlElement
     @XmlList
     List<String> data;
 }
上述代码将生成如下 XML：

 <foo>
<data>abc def</data>
 </foo>

此注释可与以下注释一起使用：XmlElement、XmlAttribute、XmlValue 和 XmlIDREF。

  • 使用 @XmlList 和 XmlValue（在允许的情况下）是多余的，因为 XmlList 将集合类型映射到一个简单模式类型，该简单模式类型就像 XmlValue 那样是由列表派生的。
  • 使用 @XmlList 和 XmlAttribute（在允许的情况下）是多余的，因为 XmlList 将集合类型映射到一个简单模式类型，该简单模式类型就像 XmlAttribute 那样是由列表派生的。

从以下版本开始：
JAXB2.0

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlMimeType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlMimeType

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlMimeType

关联控制属性 XML 表示形式的 MIME 类型。

此注释与绑定到 XML 中 base64-encoded 二进制数据的数据类型（如 Image 或 Source ）一起使用。

如果包含此注释的属性具有绑定到 xmime:contentType 属性的同级属性，并且该属性的实例中有一个值，那么该属性值具有优先权并且将控制编组。

从以下版本开始：
JAXB2.0

必需元素摘要
 String value
MIME 类型的文本表现形式，如 "image/jpeg"、"image/*"、"text/xml; charset=iso-8859-1" 等等。

元素详细信息

value

public abstract String value
MIME 类型的文本表现形式，如 "image/jpeg"、"image/*"、"text/xml; charset=iso-8859-1" 等等。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlMixed (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlMixed

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlMixed

注释 JavaBean 多值属性，以支持混合内容。

用法受到以下约束的限制：

  • 能够与 @XmlElementRef、@XmlElementRefs 或 @XmlAnyElement 一起使用。

以下内容可以插入 @XmlMixed 注释的多值属性中：

  • XML 文本信息项将作为 java.lang.String 值添加。
  • 子元素信息项将作为 JAXBElement 实例或带有使用 @XmlRootElement 注释的类的实例添加。
  • 没有绑定到 JAXB 映射类的未知内容将作为 Element 插入。（假定已使用 @XmlAnyElement 对属性进行注释。）
以下是绑定和创建混合内容的一个示例：

  <!-- schema fragment having  mixed content -->
  <xs:complexType name="letterBody" mixed="true">
    <xs:sequence>
        <xs:element name="name" type="xs:string"/>
        <xs:element name="quantity" type="xs:positiveInteger"/>
        <xs:element name="productName" type="xs:string"/>
        <!-- etc. -->
    </xs:sequence>
  </xs:complexType>
  <xs:element name="letterBody" type="letterBody"/>

 // Schema-derived Java code:
 // (Only annotations relevant to mixed content are shown below,
 //  others are ommitted.)
 import java.math.BigInteger;
 public class ObjectFactory {
        // element instance factories
        JAXBElement<LetterBody> createLetterBody(LetterBody value);
        JAXBElement<String>     createLetterBodyName(String value);
        JAXBElement<BigInteger> createLetterBodyQuantity(BigInteger value);
        JAXBElement<String>     createLetterBodyProductName(String value);
      // type instance factory
        LetterBody> createLetterBody();
 }

 public class LetterBody {
        // Mixed content can contain instances of Element classes
        // Name, Quantity and ProductName. Text data is represented as
        // java.util.String for text.
        @XmlMixed
        @XmlElementRefs({
                @XmlElementRef(name="productName", type=JAXBElement.class),
                @XmlElementRef(name="quantity", type=JAXBElement.class),
                @XmlElementRef(name="name", type=JAXBElement.class)})
        List getContent(){...}
 }
以下是具有混合内容的一个 XML 实例文档：

 <letterBody>
Dear Mr.<name>Robert Smith</name>
Your order of <quantity>1</quantity> <productName>Baby
Monitor</productName> shipped from our warehouse. ....
 </letterBody>
可以使用以下 JAXB API 调用来构造上述文档：

LetterBody lb = ObjectFactory.createLetterBody();
JAXBElement<LetterBody> lbe = ObjectFactory.createLetterBody(lb);
List gcl = lb.getContent();  //add mixed content to general content property.
gcl.add(&quot;Dear Mr.&quot;);  // add text information item as a String.

// add child element information item
gcl.add(ObjectFactory.createLetterBodyName(&quot;Robert Smith&quot;));
gcl.add(&quot;Your order of &quot;); // add text information item as a String

// add children element information items
gcl.add(ObjectFactory.
                        createLetterBodyQuantity(new BigInteger(&quot;1&quot;)));
gcl.add(ObjectFactory.createLetterBodyProductName(&quot;Baby Monitor&quot;));
gcl.add(&quot;shipped from our warehouse&quot;);  // add text information item

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

从以下版本开始：
JAXB2.0

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlNs (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlNs

@Retention(value=RUNTIME)
@Target(value={})
public @interface XmlNs

关联名称空间前缀与 XML 名称空间 URI。

用法

@XmlNs 注释用于从其他程序注释中使用。

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

示例：有关示例，请参阅 XmlSchema 注释类型。

从以下版本开始：
JAXB2.0

必需元素摘要
String | namespaceURI 名称空间 URI。
String | prefix 名称空间前缀。

元素详细信息

prefix

public abstract String prefix
名称空间前缀。

namespaceURI

public abstract String namespaceURI
名称空间 URI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlNsForm (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.xml.bind.annotation
枚举 XmlNsForm

java.lang.Object
    继承者  java.lang.Enum<XmlNsForm>
        继承者  javax.xml.bind.annotation.XmlNsForm
所有已实现的接口：
Serializable, Comparable<XmlNsForm>
public enum XmlNsForm
extends Enum<XmlNsForm>

XML 模式名称空间限定的枚举。

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

用法

名称空间限定值用于此包中定义的注释。枚举值的映射如下所示：

枚举值 | XML 模式值
UNQUALIFIED | 非限定的
QUALIFIED | 限定的
UNSET | 名称空间限定属性并不存在于 XML 模式片段中。

从以下版本开始：
JAXB2.0

枚举常量摘要
QUALIFIED
UNQUALIFIED
UNSET
方法摘要
static XmlNsForm | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlNsForm[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

UNQUALIFIED

public static final XmlNsForm UNQUALIFIED

QUALIFIED

public static final XmlNsForm QUALIFIED

UNSET

public static final XmlNsForm UNSET
方法详细信息

values

public static final XmlNsForm[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(XmlNsForm c : XmlNsForm.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static XmlNsForm valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


XmlRegistry (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlRegistry

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlRegistry

标记具有 XmlElementDecl 的类。

从以下版本开始：
JAXB 2.0
另请参见：
XmlElementDecl

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlRootElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlRootElement

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlRootElement

将类或枚举类型映射到 XML 元素。

用法

@XmlRootElement 注释可以与以下程序元素一起使用：

  • 顶层类
  • 枚举类型

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

当使用 @XmlRootElement 注释对顶层类或枚举类型进行注释时，类型值被表示为 XML 文档中的 XML 元素。

此注释可与以下注释一起使用： XmlType、XmlEnum、XmlAccessorType、 XmlAccessorOrder。

示例 1：将元素与 XML 模式类型关联

     // Example: Code fragment
     @XmlRootElement
     class Point {
        int x;
        int y;
        Point(int _x,int _y) {x=_x;y=_y;}
     }

     //Example: Code fragment corresponding to XML output
     marshal( new Point(3,5), System.out);

     <!-- Example: XML output -->
     <point>
       <x> 3 </x>
       <y> 5 </y>
     </point>
该注释会导致在模式中生成全局元素声明。全局元素声明与类映射到的 XML 模式类型关联。

&lt;!-- Example:XML schema definition --&gt;
     <xs:element name="point" type="point"/>
     <xs:complexType name="point">
       <xs:sequence>
         <xs:element name="x" type="xs:int"/>
         <xs:element name="y" type="xs:int"/>
       </xs:sequence>
     </xs:complexType>

示例 2：类型继承的正交性

某一类型上注释的元素声明不会被其派生类型继承。以下示例显示了这一点：

     // Example: Code fragment
     @XmlRootElement
     class Point3D extends Point {
         int z;
         Point3D(int _x,int _y,int _z) {super(_x,_y);z=_z;}
     }

     //Example: Code fragment corresponding to XML output *
     marshal( new Point3D(3,5,0), System.out );

     <!-- Example: XML output -->
     <!-- The element name is point3D not point -->
     <point3D>
       <x>3</x>
       <y>5</y>
       <z>0</z>
     </point3D>

     <!-- Example: XML schema definition -->
     <xs:element name="point3D" type="point3D"/>
     <xs:complexType name="point3D">
       <xs:complexContent>
         <xs:extension base="point">
           <xs:sequence>
             <xs:element name="z" type="xs:int"/>
           </xs:sequence>
         </xs:extension>
       </xs:complexContent>
     </xs:complexType>
示例 3：将全局元素与该类映射到的 XML 模式类型关联。
     //Example: Code fragment
     @XmlRootElement(name="PriceElement")
     public class USPrice {
         @XmlElement
         public java.math.BigDecimal price;
     }

     <!-- Example: XML schema definition -->
     <xs:element name="PriceElement" type="USPrice"/>
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal"/>
       </sequence>
     </xs:complexType>

从以下版本开始：
JAXB2.0

可选元素摘要
String | name XML 元素的本地名称。
String | namespace XML 元素的名称空间名。

namespace

public abstract String namespace
XML 元素的名称空间名。

如果该值为 "##default"，那么 XML 名称空间名派生于类 (XmlSchema) 的包。如果没有对包命名，那么 XML 名称空间是默认的空名称空间。

默认值：
"##default"

name

public abstract String name
XML 元素的本地名称。

如果值为 "##default"，则名称派生于类名称。

默认值：
"##default"
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlSchema (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlSchema

@Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlSchema

将包名称映射到 XML 名称空间。

用法

XmlSchema 注释可以与以下程序元素一起使用：

  • 包
这是一个包级别注释，它遵循 JSR 175 的第 III 节“注释”中的建议和限制。因此用法受到以下约束和建议的限制：
  • 正如 JSR 175 的第 III 节“注释”中所指出的那样，只能有一个包声明。
  • JSR 175 建议对包级别注释使用 package-info.java。遵循此建议的 JAXB 提供者将允许在 package-info.java 中定义包级别注释。

示例 1：自定义包将要映射到的 XML 名称空间名。

    @javax.xml.bind.annotation.XmlSchema (
      namespace = "http://www.example.com/MYPO1"
    )

    <!-- XML Schema fragment -->
    <schema
      xmlns=...
      xmlns:po=....
      targetNamespace="http://www.example.com/MYPO1"
    >
    <!-- prefixes generated by default are implementation
            depedenent -->

示例 2：自定义名称空间前缀、名称空间 URI 映射

    // Package level annotation
    @javax.xml.bind.annotation.XmlSchema (
      xmlns = {
        @javax.xml.bind.annotation.XmlNs(prefix = "po",
                   namespaceURI="http://www.example.com/myPO1"),

        @javax.xml.bind.annotation.XmlNs(prefix="xs",
                   namespaceURI="http://www.w3.org/2001/XMLSchema")
      )
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns:xs="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        targetNamespace="http://www.example.com/PO1">

示例 3：自定义 elementFormDefault

    @javax.xml.bind.annotation.XmlSchema (
      elementFormDefault=XmlNsForm.UNQUALIFIED
      ...
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        elementFormDefault="unqualified">

从以下版本开始：
JAXB2.0

可选元素摘要
XmlNsForm | attributeFormDefault 属性的名称空间限制。
XmlNsForm | elementFormDefault 元素的名称空间限制。
String | namespace XML 名称空间名。
XmlNs[] | xmlns 自定义名称空间 URI 和前缀的关联性。

xmlns

public abstract XmlNs[] xmlns
自定义名称空间 URI 和前缀的关联性。默认情况下，XML 名称空间的名称空间前缀是由 JAXB 提供者以与实现相关的方式生成的。

默认值：
{}

namespace

public abstract String namespace
XML 名称空间名。

默认值：
""

elementFormDefault

public abstract XmlNsForm elementFormDefault
元素的名称空间限制。默认情况下，元素默认属性不在 XML 模式片段中。

默认值：
javax.xml.bind.annotation.XmlNsForm.UNSET

attributeFormDefault

public abstract XmlNsForm attributeFormDefault
属性的名称空间限制。默认情况下，attributesFormDefault 不在 XML 模式片段中。

默认值：
javax.xml.bind.annotation.XmlNsForm.UNSET
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlSchemaType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlSchemaType

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PACKAGE})
public @interface XmlSchemaType

将 Java 类型映射到一个简单的模式内置类型。

用法

@XmlSchemaType 注释可以与以下程序元素一起使用：

  • JavaBean 属性
  • 字段
  • 包

为 Java 类型定义的 @XmlSchemaType 注释可应用于所有对属性/字段中的 Java 类型的引用。在属性/字段中指定的 @XmlSchemaType 注释重写在包级别上指定的 @XmlSchemaType 注释。

此注释可与以下注释一起使用： XmlElement、XmlAttribute。

示例 1：自定义字段上的 XMLGregorianCalendar 的映射。

     //Example: Code fragment
     public class USPrice {
         @XmlElement
         @XmlSchemaType(name="date")
         public XMLGregorianCalendar date;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="date" type="xs:date"/>
       </sequence>
     </xs:complexType>

示例 2：自定义包级别的 XMLGregorianCalendar 的映射。

     package foo;
     @javax.xml.bind.annotation.XmlSchemaType(
          name="date", type=javax.xml.datatype.XMLGregorianCalendar.class)
     }

从以下版本开始：
JAXB2.0

必需元素摘要
 String name
可选元素摘要
String | namespace
Class | type 如果此注释用于包级别上，那么必须指定 type() 的值。

元素详细信息

name

public abstract String name

namespace

public abstract String namespace
默认值：
"http://www.w3.org/2001/XMLSchema"

type

public abstract Class type
如果此注释用于包级别上，那么必须指定 type() 的值。

默认值：
javax.xml.bind.annotation.XmlSchemaType.DEFAULT.class
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlSchemaType.DEFAULT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlSchemaType.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlSchemaType.DEFAULT
正在封闭类：
XmlSchemaType
public static final class XmlSchemaType.DEFAULT
extends Object

在 XmlSchemaType.type() 中使用，用于表示根据属性签名推断出来的类型。

构造方法摘要
XmlSchemaType.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlSchemaType.DEFAULT

public XmlSchemaType.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlSchemaTypes (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlSchemaTypes

@Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlSchemaTypes

多个 @XmlSchemaType 注释的容器。

在程序元素上不允许使用多个相同类型的注释。因此此注释用于充当多个 @XmlSchemaType 的容器注释，如下所示：

 @XmlSchemaTypes({ @XmlSchemaType(...), @XmlSchemaType(...) })

@XmlSchemaTypes 注释可用来在包级别上的定义不同类型的 XmlSchemaType。

有关其他公共消息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

从以下版本开始：
JAXB2.0
另请参见：
XmlSchemaType

必需元素摘要
 XmlSchemaType[] value
@XmlSchemaType 注释的集合。

元素详细信息

value

public abstract XmlSchemaType[] value
@XmlSchemaType 注释的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlTransient (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlTransient

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlTransient

阻止将 JavaBean 属性映射到 XML 表示形式。

@XmlTransient 注释对于解决 JavaBean 属性名称与字段名称之间的名称冲突，或者用于防止字段/属性的映射。当取消首字母大写的 JavaBean 属性名称与字段名称相同时，就可能发生名称冲突。如果 JavaBean 属性引用该字段，那么可以通过防止映射使用 @XmlTransient 注释的字段或 JavaBean 属性来解决名称冲突。

用法

@XmlTransient 注释可以与以下程序元素一起使用：

  • JavaBean 属性
  • 字段

@XmlTransient 与所有其他定义于 JAXB 的注释互相排斥。

有关其他公共消息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

示例：解决 JavaBean 属性与字段名称之间的名称冲突

   // Example: Code fragment
   public class USAddress {

       // The field name "name" collides with the property name
       // obtained by bean decapitalization of getName() below
       @XmlTransient public String name;

       String getName() {..};
       String setName() {..};
   }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="name" type="xs:string"/>
     </xs:sequence>
   </xs:complexType>

从以下版本开始：
JAXB2.0

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlType

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlType

将类或枚举类型映射到 XML 模式类型。

用法

@XmlType 注释可以与以下程序元素一起使用：

  • 顶层类
  • 枚举类型

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

映射一个类

将一个类映射到 XML 模式类型。类是通过属性和字段表示的值的数据容器。模式类型是一个数据容器，用于模式类型的内容模式中的模式组件（如模型组件、属性等）所表示的值。

要被映射，类必须拥有一个不带参数的公共构造方法，或者一个静态的不带参数的工厂方法。静态工厂方法可以使用 factoryMethod() 和 factoryClass() 注释元素来指定。在解组过程中将使用静态工厂方法或不带参数的构造方法来创建此类的实例。如果两者同时存在，则静态工厂方法将重写不带参数的构造方法。

将类映射到 XML 模式复杂类型或 XML 模式简单类型。XML 模式类型是基于类中包含的 JavaBean 属性和字段的映射派生出来的。类将要映射到的模式类型可以是已命名的，也可以是匿名的。通过使用 @(name="") 对类进行注释，可以将该类映射到匿名模式类型。

全局元素、本地元素或本地属性都可以与匿名类型关联，如下所示：

  • 全局元素：通过使用 @XmlRootElement 对类进行注释，可以派生出一个匿名类型的全局元素。请参阅下文示例 3。
  • 本地元素： JavaBean 属性，引用使用 @XmlType(name="") 注释的类且映射到与匿名类型关联的某一元素。请参阅下文示例 4。
  • 属性： JavaBean 属性，引用使用 @XmlType(name="") 注释的类且映射到与匿名类型关联的某一属性。请参阅下文示例 5。
映射到 XML 模式复杂类型
  • 如果使用 @XmlType(name="") 对类进行注释，那么该类将被映射到匿名类型。否则将类名称映射到复杂类型名称。可以使用 XmlName() 注释元素来自定义名称。
  • 映射到元素的属性和字段将映射到复杂类型中的内容模式。可以使用注释元素 propOrder() 将内容模式自定义为 xs:all 或 xs:sequence，还可以使用该元素指定 xs:sequence 中 XML 元素的顺序。
  • 可以映射到复杂类型中的属性的属性和字段。
  • XML 模式类型的 targetnamespace 可以使用注释元素 namespace() 自定义。

将类映射到 XML 模式简单类型

可以使用 @XmlValue 注释将类映射到 XML 模式简单类型。有关其他详细信息和示例，请参阅 @XmlValue 注释类型。

下表显示了类到 XML 模式复杂类型或简单类型的映射。表中使用的标志符号是：

  • -> : 代表一个映射
  • [x]+ :x 出现一次或多次
  • [ @XmlValue property ]:使用 @XmlValue 注释的 JavaBean 属性
  • X :任意
Target propOrder ClassBody ComplexType SimpleType
Class {} [property]+ -> elements complexcontent
xs:all
Class non empty [property]+ -> elements complexcontent
xs:sequence
Class X no property -> element complexcontent
empty sequence
Class X 1 [ @XmlValue property] &&
[property]+ ->attributes 		simplecontent
Class X 1 [ @XmlValue property ]&&
no properties -> attribute 		simpletype

映射一个枚举类型

将枚举类型映射到带有 enumeration facet 的 XML 模式简单类型。由于没有意义，以下注释元素将被忽略：propOrder()、factoryMethod() 和 factoryClass()。

与其他注释一起使用的方法

此类可与以下注释一起使用： XmlRootElement、XmlAccessorOrder、XmlAccessorType、 XmlEnum。但是，当此注释用于枚举类型时，将忽略 XmlAccessorOrder 和 XmlAccessorType。

示例 1：将类映射到具有 xs:sequence 属性和自定义的 JavaBean 排序的复杂类型。

   @XmlType(propOrder={"street", "city" , "state", "zip", "name" })
   public class USAddress {
     String getName() {..};
     void setName(String) {..};

     String getStreet() {..};
     void setStreet(String) {..};

     String getCity() {..};
     void setCity(String) {..};

     String getState() {..};
     void setState(String) {..};

     java.math.BigDecimal getZip() {..};
     void setZip(java.math.BigDecimal) {..};
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="street" type="xs:string"/>
       <xs:element name="city" type="xs:string"/>
       <xs:element name="state" type="xs:string"/>
       <xs:element name="zip" type="xs:decimal"/>
       <xs:element name="name" type="xs:string"/>
     </xs:all>
   </xs:complexType>

示例 2：将类映射到具有 xs:all 属性的复杂类型

 @XmlType(propOrder={})
 public class USAddress { ...}

 <!-- XML Schema mapping for USAddress -->
 <xs:complexType name="USAddress">
   <xs:all>
     <xs:element name="name" type="xs:string"/>
     <xs:element name="street" type="xs:string"/>
     <xs:element name="city" type="xs:string"/>
     <xs:element name="state" type="xs:string"/>
     <xs:element name="zip" type="xs:decimal"/>
   </xs:sequence>
 </xs:complexType>

示例 3：将类映射到具有匿名类型的全局元素。

   @XmlRootElement
   @XmlType(name="")
   public class USAddress { ...}

   <!-- XML Schema mapping for USAddress -->
   <xs:element name="USAddress">
     <xs:complexType>
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:element name="street" type="xs:string"/>
         <xs:element name="city" type="xs:string"/>
         <xs:element name="state" type="xs:string"/>
         <xs:element name="zip" type="xs:decimal"/>
       </xs:sequence>
     </xs:complexType>
   </xs:element>

示例 4：将属性映射到具有匿名类型的本地元素。

   //Example: Code fragment
   public class Invoice {
       USAddress addr;
           ...
       }

   @XmlType(name="")
   public class USAddress { ... }
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="Invoice">
     <xs:sequence>
       <xs:element name="addr">
         <xs:complexType>
           <xs:element name="name", type="xs:string"/>
           <xs:element name="city", type="xs:string"/>
           <xs:element name="city" type="xs:string"/>
           <xs:element name="state" type="xs:string"/>
           <xs:element name="zip" type="xs:decimal"/>
         </xs:complexType>
       ...
     </xs:sequence>
   </xs:complexType>

示例 5：将属性映射到具有匿名类型的属性。

     //Example: Code fragment
     public class Item {
         public String name;
         @XmlAttribute
         public USPrice price;
     }

     // map class to anonymous simple type.
     @XmlType(name="")
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="Item">
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:attribute name="price">
           <xs:simpleType>
             <xs:restriction base="xs:decimal"/>
           </xs:simpleType>
         </xs:attribute>
       </xs:sequence>
     </xs:complexType>

示例 6: 定义 factoryClass 和 factoryMethod

      @XmlType(name="USAddressType", factoryClass=USAddressFactory.class,
      factoryMethod="getUSAddress")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

      public USAddress(String name, String street, String city,
          String state, int zip) {
          this.name = name;
          this.street = street;
          this.city = city;
          this.state = state;
          this.zip = zip;
      }
  }

  public class USAddressFactory {
      public static USAddress getUSAddress(){
       return new USAddress("Mark Baker", "23 Elm St",
          "Dayton", "OH", 90952);
  }

示例 7：定义 factoryMethod 并使用默认 factoryClass

      @XmlType(name="USAddressType", factoryMethod="getNewInstance")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

          private USAddress() {}

          public static USAddress getNewInstance(){
              return new USAddress();
          }
      }

从以下版本开始：
JAXB2.0
另请参见：
XmlElement, XmlAttribute, XmlValue, XmlSchema

可选元素摘要
Class | factoryClass 包含用来创建此类实例的不带参数的工厂方法的类。
String | factoryMethod 一个不带参数的构造方法的名称，该构造方法在 factoryClass factoryClass() 所指定的类。
String | name 类被映射到的 XML 模式类型名称。
String | namespace XML 模式类型的目标名称空间名。
String[] | propOrder 在将类映射到 XML 模式复杂类型时，指定 XML 模式元素的顺序。

name

public abstract String name
类被映射到的 XML 模式类型名称。

默认值：
"##default"

propOrder

public abstract String[] propOrder
在将类映射到 XML 模式复杂类型时，指定 XML 模式元素的顺序。

有关 propOrder 影响类映射的方式，请参见上表。

propOrder 是类中 JavaBean 属性的名称列表。列表中的每个名称都是 JavaBean 属性的 Java 标识符的名称。JavaBean 属性被列出的顺序是 JavaBean 属性映射到 XML 模式元素的顺序。

必须列出所有映射到 XML 模式元素的 JavaBean 属性。

以 propOrder 顺序列出的 JavaBean 属性或字段不得为 transient 或使用 @XmlTransient 注释。

JavaBean 属性的默认顺序由 @XmlAccessorOrder 确定。

默认值：
""

namespace

public abstract String namespace
XML 模式类型的目标名称空间名。默认情况下，这是包含类的包将被映射到的目标名称空间。

默认值：
"##default"

factoryClass

public abstract Class factoryClass
包含用来创建此类实例的不带参数的工厂方法的类。默认值为此类。

如果 factoryClass 为 DEFAULT.class 且 factoryMethod 为 ""，则没有静态工厂方法。

如果 factoryClass 为 DEFAULT.class 且 factoryMethod 不为 ""，则 factoryMethod 是此类中静态工厂方法的名称。

如果 factoryClass 不是 DEFAULT.class，则 factoryMethod 不得为 ""，且必须是 factoryClass 中指定的静态工厂方法的名称。

默认值：
javax.xml.bind.annotation.XmlType.DEFAULT.class

factoryMethod

public abstract String factoryMethod
一个不带参数的构造方法的名称，该构造方法在 factoryClass factoryClass() 所指定的类。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlType.DEFAULT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation
类 XmlType.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.XmlType.DEFAULT
正在封闭类：
XmlType
public static final class XmlType.DEFAULT
extends Object

在 XmlType.factoryClass() 中使用，指示工厂方法未被使用或者在具有此 XmlType 的类中。

构造方法摘要
XmlType.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlType.DEFAULT

public XmlType.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlValue (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.xml.bind.annotation
注释类型 XmlValue

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlValue

支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。

用法：

@XmlValue 注释可以与以下程序元素一起使用：

  • JavaBean 属性。
  • 非 static、非 transient 字段。

有关其他公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

用法受到以下使用约束的限制：
  • 可以使用 @XmlValue 注释注释最多一个字段或属性。
  • @XmlValue 可以与以下注释一起使用：XmlList。但是这是多余的，因为 XmlList 将类型映射到像 XmlValue 那样由列表派生的简单模式类型。
  • 如果字段或属性的类型是集合类型，那么集合项类型必须映射到简单模式类型。
  • 如果字段或属性的类型不是集合类型，那么类型必须映射到 XML 模式简单类型。

如果已注释的 JavaBean 属性是映射到 XML 模式构造的唯一类成员，那么该类将被映射到一个简单类型。 如果存在映射到 XML 属性的其他 JavaBean 属性（使用 @XmlValue 注释注释的 JavaBean 除外），那么类将被映射到带有 simpleContent 的复杂类型。

示例 1：将类映射到 XML 模式 simpleType

     // Example 1: Code fragment
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example 1: XML Schema fragment -->
     <xs:simpleType name="USPrice">
       <xs:restriction base="xs:decimal"/>
     </xs:simpleType>

示例 2：将类映射到带有 simpleContent的 XML 模式 complexType。

   // Example 2: Code fragment
   public class InternationalPrice {
       @XmlValue
       public java.math.BigDecimal price;

       @XmlAttribute
       public String currency;
   }

   <!-- Example 2: XML Schema fragment -->
   <xs:complexType name="InternationalPrice">
     <xs:simpleContent>
       <xs:extension base="xs:decimal">
         <xs:attribute name="currency" type="xs:string"/>
       </xs:extension>
     </xs:simpleContent>
   </xs:complexType>

从以下版本开始：
JAXB2.0
另请参见：
XmlType

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


javax.xml.bind.annotation (Java Platform SE 6)

 javax.xml.bind.annotation
接口
DomHandler
类
W3CDomHandler
XmlElement.DEFAULT
XmlElementDecl.GLOBAL
XmlElementRef.DEFAULT
XmlSchemaType.DEFAULT
XmlType.DEFAULT
枚举
XmlAccessOrder
XmlAccessType
XmlNsForm
注释类型
XmlAccessorOrder
XmlAccessorType
XmlAnyAttribute
XmlAnyElement
XmlAttachmentRef
XmlAttribute
XmlElement
XmlElementDecl
XmlElementRef
XmlElementRefs
XmlElements
XmlElementWrapper
XmlEnum
XmlEnumValue
XmlID
XmlIDREF
XmlInlineBinaryData
XmlList
XmlMimeType
XmlMixed
XmlNs
XmlRegistry
XmlRootElement
XmlSchema
XmlSchemaType
XmlSchemaTypes
XmlTransient
XmlType
XmlValue


javax.xml.bind.annotation (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.bind.annotation

定义将 Java 程序元素定制成 XML 模式映射的注释。

请参见：
描述

接口摘要
DomHandler<ElementT,ResultT extends Result> 在元素（及其子代）与 DOM（或类似对象）表示形式之间相互转换。

类摘要
W3CDomHandler | W3C DOM（org.w3c.dom 包）的 DomHandler 实现。
XmlElement.DEFAULT | 在 XmlElement.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlElementDecl.GLOBAL | 在 XmlElementDecl.scope() 中使用，指示声明是全局范围的。
XmlElementRef.DEFAULT | 在 XmlElementRef.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlSchemaType.DEFAULT | 在 XmlSchemaType.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlType.DEFAULT | 在 XmlType.factoryClass() 中使用，指示工厂方法未被使用或者在具有此 XmlType 的类中。

枚举摘要
XmlAccessOrder | 由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。
XmlAccessType | 由 XmlAccessorType 使用，用于控制字段或属性的序列化。
XmlNsForm | XML 模式名称空间限定的枚举。

注释类型摘要
XmlAccessorOrder | 控制类中字段和属性的排序。
XmlAccessorType | 控制默认情况下是否对字段或 Javabean 属性进行系列化。
XmlAnyAttribute | 将 JavaBean 属性映射到通配符属性的映射表中。
XmlAnyElement | 将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
XmlAttachmentRef | 标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
XmlAttribute | 将 JavaBean 属性映射到 XML 属性。
XmlElement | 将 JavaBean 属性映射到派生于属性名称的 XML 元素。
XmlElementDecl | 将工厂方法映射到 XML 元素。
XmlElementRef | 将 JavaBean 属性映射到派生于属性类型的 XML 元素。
XmlElementRefs | 标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
XmlElements | 多个 @XmlElement 注释的容器。
XmlElementWrapper | 生成一个包装 XML 表示形式的包装器元素。
XmlEnum | 将枚举类型 Enum 映射到 XML 表示形式。
XmlEnumValue | 将 Enum 类型中的枚举常量映射到 XML 表示形式。
XmlID | 将 JavaBean 属性映射到 XML ID。
XmlIDREF | 将 JavaBean 属性映射到 XML IDREF。
XmlInlineBinaryData | 禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
XmlList | 用来将属性映射到列表简单类型。
XmlMimeType | 关联控制属性 XML 表示形式的 MIME 类型。
XmlMixed | 注释 JavaBean 多值属性，以支持混合内容。
XmlNs | 关联名称空间前缀与 XML 名称空间 URI。
XmlRegistry | 标记具有 XmlElementDecl 的类。
XmlRootElement | 将类或枚举类型映射到 XML 元素。
XmlSchema | 将包名称映射到 XML 名称空间。
XmlSchemaType | 将 Java 类型映射到一个简单的模式内置类型。
XmlSchemaTypes | 多个 @XmlSchemaType 注释的容器。
XmlTransient | 阻止将 JavaBean 属性映射到 XML 表示形式。
XmlType | 将类或枚举类型映射到 XML 模式类型。
XmlValue | 支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。

软件包 javax.xml.bind.annotation 的描述

定义将 Java 程序元素定制成 XML 模式映射的注释。

包规范

下表显示了可与每个程序元素关联的 JAXB 映射注释。

程序元素 JAXB 注释
包
XmlAccessorOrder
XmlAccessorType
XmlSchema
XmlSchemaType
XmlSchemaTypes
XmlJavaTypeAdapter
XmlJavaTypeAdapters
类
XmlAccessorOrder
XmlAccessorType
XmlInlineBinaryData
XmlRootElement
XmlType
XmlJavaTypeAdapter
枚举类型
XmlEnum
XmlEnumValue（仅限枚举常量）
XmlRootElement
XmlType
XmlJavaTypeAdapter
JavaBean 属性/字段
XmlElement
XmlElements
XmlElementRef
XmlElementRefs
XmlElementWrapper
XmlAnyElement
XmlAttribute
XmlAnyAttribute
XmlTransient
XmlValue
XmlID
XmlIDREF
XmlList
XmlMixed
XmlMimeType
XmlAttachmentRef
XmlInlineBinaryData
XmlElementDecl（仅用于方法）
XmlJavaTypeAdapter
参数
XmlList
XmlAttachmentRef
XmlMimeType
XmlJavaTypeAdapter

术语

JavaBean 属性和字段： 从映射的用途考虑，字段和 JavaBean 属性之间没有语义上的差别。因此，可以应用于 JavaBean 属性的注释总是可以应用于字段。简言之，在 Javadoc 文档中，使用术语 JavaBean 属性或属性表示 JavaBean 属性或字段。如有需要，两者可以不加区别的同时使用。

顶层类： 从映射的用途考虑，顶层类和静态嵌套类之间没有语义上的差别。因此，可以应用于顶层类的注释总是可以应用于嵌套静态类。简言之，在 Javadoc 文档中，使用术语“顶层类”或类表示顶层类或嵌套静态类。

映射注释：JAXB 2.0 基于 JSR 175 编程注释工具定义的程序注释。

公共用法约束

在这里定义以下用法约束，因为它们并不仅限于供注释使用：

  • 对于属性，给出的注释可以应用于 read 或 write 属性，但不能同时应用于二者。
  • 属性名称必须不同于将被映射类的任何超类中的其他任何属性名称。
  • 一个类中映射属性的映射字段名称或取消大写化的名称必须唯一。

    • 计数法

    名称空间前缀

    在此包中，以下名称空间前缀用于 XML 模式片段。

    前缀 | 名称空间 | 注释
xs | http://www.w3.org/2001/XMLSchema | XML 模式名称空间的名称空间
ref | http://ws-i.org/profiles/basic/1.1/xsd | swaref 模式组件的名称空间
xsi | http://www.w3.org/2001/XMLSchema-instance | 实例的 XML 模式名称空间

    从以下版本开始：
    JAXB 2.0
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM Platform
    Standard Ed. 6
    上一个软件包 下一个软件包 框架 无框架


javax.xml.bind.annotation 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.annotation 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.bind.annotation.XmlType.DEFAULT

接口分层结构

  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>

注释类型分层结构

  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.bind.annotation.XmlAccessOrder
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlNsForm
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.bind.annotation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.annotation
的使用

使用 javax.xml.bind.annotation 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 使用的 javax.xml.bind.annotation 中的类
DomHandler
在元素（及其子代）与 DOM（或类似对象）表示形式之间相互转换。
XmlAccessOrder
由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。
XmlAccessType
由 XmlAccessorType 使用，用于控制字段或属性的序列化。
XmlNsForm
XML 模式名称空间限定的枚举。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


CollapsedStringAdapter (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation.adapters
类 CollapsedStringAdapter

java.lang.Object
    继承者  javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
        继承者  javax.xml.bind.annotation.adapters.CollapsedStringAdapter

public class CollapsedStringAdapter
extends XmlAdapter<String,String>

用来处理 xs:token 及其派生类型的内置 XmlAdapter。

此适配器移除前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。

从以下版本开始：
JAXB 2.0

构造方法摘要
CollapsedStringAdapter()
方法摘要
protected static boolean | isWhiteSpace(char ch) 如果指定的 char 是空白字符，则返回 true。
String | marshal(String s) 无任何操作。
String | unmarshal(String text) 移除作为参数提供的字符串的前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CollapsedStringAdapter

public CollapsedStringAdapter()
方法详细信息

unmarshal

public String unmarshal(String text)
移除作为参数提供的字符串的前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。

指定者：
类 XmlAdapter<String,String> 中的 unmarshal
参数：
text - 要转换的值。可以为 null。

marshal

public String marshal(String s)
无任何操作。仅返回作为参数提供的字符串。

指定者：
类 XmlAdapter<String,String> 中的 marshal
参数：
s - 要转换的值。可以为 null。

isWhiteSpace

protected static boolean isWhiteSpace(char ch)
如果指定的 char 是空白字符，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


HexBinaryAdapter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation.adapters
类 HexBinaryAdapter

java.lang.Object
    继承者  javax.xml.bind.annotation.adapters.XmlAdapter<String,byte[]>
        继承者  javax.xml.bind.annotation.adapters.HexBinaryAdapter

public final class HexBinaryAdapter
extends XmlAdapter<String,byte[]>

xs:hexBinary 的 XmlAdapter。

此 XmlAdapter 将 byte[] 绑定到 XML 中的 hexBinary 表示形式。

从以下版本开始：
JAXB 2.0

构造方法摘要
HexBinaryAdapter()
方法摘要
String | marshal(byte[] bytes) 将 bound 类型转换为 value 类型。
byte[] | unmarshal(String s) 将 value 类型转换为 bound 类型。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HexBinaryAdapter

public HexBinaryAdapter()
方法详细信息

unmarshal

public byte[] unmarshal(String s)
从类 XmlAdapter 复制的描述
将 value 类型转换为 bound 类型。

指定者：
类 XmlAdapter<String,byte[]> 中的 unmarshal
参数：
s - 要转换的值。可以为 null。

marshal

public String marshal(byte[] bytes)
从类 XmlAdapter 复制的描述
将 bound 类型转换为 value 类型。

指定者：
类 XmlAdapter<String,byte[]> 中的 marshal
参数：
bytes - 要转换的值。可以为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NormalizedStringAdapter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation.adapters
类 NormalizedStringAdapter

java.lang.Object
    继承者  javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
        继承者  javax.xml.bind.annotation.adapters.NormalizedStringAdapter

public final class NormalizedStringAdapter
extends XmlAdapter<String,String>

处理 xs:normalizedString 的 XmlAdapter。

此适配器移除前导空白和尾部空白，然后用单个空白字符“ ”截断所有制表符、CR 和 LF。

从以下版本开始：
JAXB 2.0

构造方法摘要
NormalizedStringAdapter()
方法摘要
protected static boolean | isWhiteSpaceExceptSpace(char ch) 如果指定的 char 是空白字符但不是 0x20，则返回 true。
String | marshal(String s) 无任何操作。
String | unmarshal(String text) 移除作为参数给定的字符串的前导空白和尾部空白，然后用单个空白字符“ ”替换所有制表符、CR 和 LF。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NormalizedStringAdapter

public NormalizedStringAdapter()
方法详细信息

unmarshal

public String unmarshal(String text)
移除作为参数给定的字符串的前导空白和尾部空白，然后用单个空白字符“ ”替换所有制表符、CR 和 LF。

指定者：
类 XmlAdapter<String,String> 中的 unmarshal
参数：
text - 要转换的值。可以为 null。

marshal

public String marshal(String s)
无任何操作。仅返回作为参数提供的字符串。

指定者：
类 XmlAdapter<String,String> 中的 marshal
参数：
s - 要转换的值。可以为 null。

isWhiteSpaceExceptSpace

protected static boolean isWhiteSpaceExceptSpace(char ch)
如果指定的 char 是空白字符但不是 0x20，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlAdapter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation.adapters
类 XmlAdapter<ValueType,BoundType>

java.lang.Object
    继承者  javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
类型参数：
BoundType - JAXB 不知道如何处理的一些类型。编写一个适配器，以便允许通过 ValueType 将此类型用作内存表示形式。
ValueType - JAXB 无需其他操作便知道如何处理的类型。
直接已知子类：
CollapsedStringAdapter, HexBinaryAdapter, NormalizedStringAdapter
public abstract class XmlAdapter<ValueType,BoundType>
extends Object

修改 Java 类型以适应自定义编组。

用法：

一些 Java 类型不能自然映射到 XML 表示形式，例如，HashMap 或其他非 JavaBean 类。反之，XML 表示形式可以映射到 Java 类型，但是应用程序可能会选择使用另一种 Java 类型访问 XML 表示形式。例如，默认情况下，Java 绑定规则模式将 xs:DateTime 绑定到 XmlGregorianCalendar。但应用程序可能需要将 xs:DateTime 绑定到自定义类型，例如 MyXmlGregorianCalendar。在这两种情况下，应用程序用来访问 XML 内容的 bound 类型 与映射到 XML 表示形式的 value 类型 不匹配。

此抽象类定义将 bound 类型修改为 value 类型或将 value 类型修改为 bound 类型的方法。在编组或解组过程中，由 JAXB 绑定框架调用这些方法：

  • XmlAdapter.marshal(...)：编组过程中，JAXB 绑定框架调用 XmlAdapter.marshal(..) 将 bound 类型修改为 value 类型，然后将 value 类型编组为 XML 表示形式。
  • XmlAdapter.unmarshal(...)：解组过程中，JAXB 绑定框架首先将 XML 表示形式解组为 value 类型，然后调用 XmlAdapter.unmarshal(..) 将 value 类型修改为 bound 类型。
因此编写一个适配器涉及以下步骤：
  • 编写实现此抽象类的适配器。
  • 安装使用注释 XmlJavaTypeAdapter 的适配器。

示例：自定义 HashMap 的映射。

以下示例演示了如何使用 @XmlAdapter 和 @XmlJavaTypeAdapter 自定义 HashMap 的映射。

步骤 1：确定 HashMap 需要的 XML 表示形式。

<hashmap>
<entry key="id123">this is a value</entry>
<entry key="id312">this is another value</entry>
         ...
</hashmap>

步骤 2：确定上文所示的所需 XML 表示形式应当遵循的模式定义。

     <xs:complexType name="myHashMapType">
       <xs:sequence>
         <xs:element name="entry" type="myHashMapEntryType"
                        minOccurs = "0" maxOccurs="unbounded"/>
       </xs:sequence>
     </xs:complexType>

     <xs:complexType name="myHashMapEntryType">
       <xs:simpleContent>
         <xs:extension base="xs:string">
           <xs:attribute name="key" type="xs:int"/>
         </xs:extension>
       </xs:simpleContent>
     </xs:complexType>

步骤 3：编写能够生成上述模式定义的 value 类型。

     public class MyHashMapType {
         List<MyHashMapEntryType> entry;
     }

     public class MyHashMapEntryType {
         @XmlAttribute
         public Integer key;

         @XmlValue
         public String value;
     }

步骤 4：编写将 value 类型 (MyHashMapType) 修改为 bound 类型（应用程序使用的 HashMap）的适配器。

public final class MyHashMapAdapter extends
XmlAdapter<HashMap, MyHashMapType> { ... }

步骤 5：使用适配器。

     public class Foo {
         @XmlJavaTypeAdapter(MyHashMapAdapter.class)
         HashMap hashmap;
         ...
     }
上述代码片段将映射到以下模式：
<xs:complexType name="Foo">
<xs:sequence>
<xs:element name="hashmap" type="myHashMapType"
</xs:sequence>
</xs:complexType>

从以下版本开始：
JAXB 2.0
另请参见：
XmlJavaTypeAdapter

构造方法摘要
protected XmlAdapter()
派生类的构造方法，不执行任何操作。
方法摘要
abstract ValueType | marshal(BoundType v) 将 bound 类型转换为 value 类型。
abstract BoundType | unmarshal(ValueType v) 将 value 类型转换为 bound 类型。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlAdapter

protected XmlAdapter()
派生类的构造方法，不执行任何操作。

方法详细信息

unmarshal

public abstract BoundType unmarshal(ValueType v)
                             throws Exception
将 value 类型转换为 bound 类型。

参数：
v - 要转换的值。可以为 null。
抛出：
Exception - 如果在转换过程中发生错误。调用者通过 ValidationEventHandler 负责向用户报告错误。

marshal

public abstract ValueType marshal(BoundType v)
                           throws Exception
将 bound 类型转换为 value 类型。

参数：
v - 要转换的值。可以为 null。
抛出：
Exception - 如果在转换过程中发生错误。调用者通过 ValidationEventHandler 负责向用户报告错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlJavaTypeAdapter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.bind.annotation.adapters
注释类型 XmlJavaTypeAdapter

@Retention(value=RUNTIME)
@Target(value={PACKAGE,FIELD,METHOD,TYPE,PARAMETER})
public @interface XmlJavaTypeAdapter

对自定义编组使用实现 XmlAdapter 的适配器。

用法：

@XmlJavaTypeAdapter 注释可以与下列编程元素一起使用：

  • JavaBean 属性
  • 字段
  • 参数
  • 包
  • XmlJavaTypeAdapters 内部的元素

当对一个类定义了 @XmlJavaTypeAdapter 注释时，它将适用于该类的所有引用。

当在包级别上定义了 @XmlJavaTypeAdapter 注释时，它将适用于从该包内部到 @XmlJavaTypeAdapter.type() 的所有引用。

当对字段、属性或参数定义了 @XmlJavaTypeAdapter 注释时，注释将仅适用于这些字段、属性或参数。

字段、属性或参数上的 @XmlJavaTypeAdapter 注释重写与字段、属性或参数所引用的类关联的 @XmlJavaTypeAdapter 注释。

类上的 @XmlJavaTypeAdapter 注释重写在该类的包级别上指定的 @XmlJavaTypeAdapter 注释。

此注释可与以下注释一起使用：XmlElement、XmlAttribute、XmlElementRef、 XmlElementRefs、XmlAnyElement。此注释也可以在包级别与以下注释一起使用： XmlAccessorType、XmlSchema、XmlSchemaType、 XmlSchemaTypes。

示例：请参阅 XmlAdapter 中的示例

从以下版本开始：
JAXB2.0
另请参见：
XmlAdapter

必需元素摘要
 Class<? extends XmlAdapter> value
指向将 value 类型转换为 bound 类型或将 bound 类型转换为 value 类型的类。
可选元素摘要
 Class type
如果此注释在包级别使用，则必须指定 type() 的值。

元素详细信息

value

public abstract Class<? extends XmlAdapter> value
指向将 value 类型转换为 bound 类型或将 bound 类型转换为 value 类型的类。更多详细信息，请参阅 XmlAdapter。

type

public abstract Class type
如果此注释在包级别使用，则必须指定 type() 的值。

默认值：
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT.class
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


XmlJavaTypeAdapter.DEFAULT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.annotation.adapters
类 XmlJavaTypeAdapter.DEFAULT

java.lang.Object
    继承者  javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
正在封闭类：
XmlJavaTypeAdapter
public static final class XmlJavaTypeAdapter.DEFAULT
extends Object

此类在 XmlJavaTypeAdapter.type() 中使用，用来表示从字段、属性、参数或类的签名推导出的类型。

构造方法摘要
XmlJavaTypeAdapter.DEFAULT()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XmlJavaTypeAdapter.DEFAULT

public XmlJavaTypeAdapter.DEFAULT()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlJavaTypeAdapters (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.xml.bind.annotation.adapters
注释类型 XmlJavaTypeAdapters

@Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlJavaTypeAdapters

多个 @XmlJavaTypeAdapter 注释的容器。

一个编程元素上不允许使用多个相同类型的注释。因此，此注释充当多个 @XmlJavaTypeAdapter 的容器注释，如下所示：

 @XmlJavaTypeAdapters ({ @XmlJavaTypeAdapter(...),@XmlJavaTypeAdapter(...) })

@XmlJavaTypeAdapters 注释对于定义包级别上不同类型的 XmlJavaTypeAdapter 注释很有用。

有关附加的公共信息，请参阅 javax.xml.bind.package javadoc 中的“包规范”。

从以下版本开始：
JAXB2.0
另请参见：
XmlJavaTypeAdapter

必需元素摘要
 XmlJavaTypeAdapter[] value
@XmlJavaTypeAdapter 注释的集合。

元素详细信息

value

public abstract XmlJavaTypeAdapter[] value
@XmlJavaTypeAdapter 注释的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


javax.xml.bind.annotation.adapters (Java Platform SE 6)

 javax.xml.bind.annotation.adapters
类
CollapsedStringAdapter
HexBinaryAdapter
NormalizedStringAdapter
XmlAdapter
XmlJavaTypeAdapter.DEFAULT
注释类型
XmlJavaTypeAdapter
XmlJavaTypeAdapters


javax.xml.bind.annotation.adapters (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.bind.annotation.adapters

XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。

请参见：
描述

类摘要
CollapsedStringAdapter | 用来处理 xs:token 及其派生类型的内置 XmlAdapter。
HexBinaryAdapter | xs:hexBinary 的 XmlAdapter。
NormalizedStringAdapter | 处理 xs:normalizedString 的 XmlAdapter。
XmlAdapter<ValueType,BoundType> | 修改 Java 类型以适应自定义编组。
XmlJavaTypeAdapter.DEFAULT | 此类在 XmlJavaTypeAdapter.type() 中使用，用来表示从字段、属性、参数或类的签名推导出的类型。

注释类型摘要
XmlJavaTypeAdapter | 对自定义编组使用实现 XmlAdapter 的适配器。
XmlJavaTypeAdapters | 多个 @XmlJavaTypeAdapter 注释的容器。

软件包 javax.xml.bind.annotation.adapters 的描述

XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。

包规范

  • JAXB 规范

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • JAXB Website

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.bind.annotation.adapters 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.annotation.adapters 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

注释类型分层结构

  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.bind.annotation.adapters 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.annotation.adapters
的使用

使用 javax.xml.bind.annotation.adapters 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 使用的 javax.xml.bind.annotation.adapters 中的类
XmlAdapter
修改 Java 类型以适应自定义编组。

javax.xml.bind.annotation.adapters 使用的 javax.xml.bind.annotation.adapters 中的类
XmlAdapter
修改 Java 类型以适应自定义编组。

javax.xml.bind.helpers 使用的 javax.xml.bind.annotation.adapters 中的类
XmlAdapter
修改 Java 类型以适应自定义编组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter
的使用

没有 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.HexBinaryAdapter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.HexBinaryAdapter
的使用

没有 javax.xml.bind.annotation.adapters.HexBinaryAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter
的使用

没有 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.XmlAdapter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.XmlAdapter
的使用

使用 XmlAdapter 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 XmlAdapter 的使用

类型参数类型为 XmlAdapter 的 javax.xml.bind 中的方法
<A extends XmlAdapter>
A
Marshaller.getAdapter(Class<A> type)
获取与指定类型关联的适配器。
<A extends XmlAdapter>
A
Unmarshaller.getAdapter(Class<A> type)
获取与指定类型关联的适配器。
<A extends XmlAdapter>
void
Marshaller.setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。
<A extends XmlAdapter>
void
Unmarshaller.setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。

参数类型为 XmlAdapter 的 javax.xml.bind 中的方法
void | Marshaller.setAdapter(XmlAdapter adapter) 将已配置的 XmlAdapter 实例与此 marshaller 关联。
void | Unmarshaller.setAdapter(XmlAdapter adapter) 将已配置的 XmlAdapter 实例与此 unmarshaller 关联。

javax.xml.bind.annotation.adapters 中 XmlAdapter 的使用

javax.xml.bind.annotation.adapters 中 XmlAdapter 的子类
class | CollapsedStringAdapter 用来处理 xs:token 及其派生类型的内置 XmlAdapter。
class | HexBinaryAdapter xs:hexBinary 的 XmlAdapter。
class | NormalizedStringAdapter 处理 xs:normalizedString 的 XmlAdapter。

javax.xml.bind.helpers 中 XmlAdapter 的使用

类型参数类型为 XmlAdapter 的 javax.xml.bind.helpers 中的方法
<A extends XmlAdapter>
A
AbstractMarshallerImpl.getAdapter(Class<A> type)
<A extends XmlAdapter>
A
AbstractUnmarshallerImpl.getAdapter(Class<A> type)
<A extends XmlAdapter>
void
AbstractMarshallerImpl.setAdapter(Class<A> type, A adapter)
<A extends XmlAdapter>
void
AbstractUnmarshallerImpl.setAdapter(Class<A> type, A adapter)

参数类型为 XmlAdapter 的 javax.xml.bind.helpers 中的方法
void | AbstractMarshallerImpl.setAdapter(XmlAdapter adapter)
void | AbstractUnmarshallerImpl.setAdapter(XmlAdapter adapter)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter
的使用

没有 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
的使用

没有 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters
的使用

没有 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.annotation.DomHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.annotation.DomHandler
的使用

使用 DomHandler 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 中 DomHandler 的使用

实现 DomHandler 的 javax.xml.bind.annotation 中的类
 class W3CDomHandler
W3C DOM（org.w3c.dom 包）的 DomHandler 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.W3CDomHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.W3CDomHandler
的使用

没有 javax.xml.bind.annotation.W3CDomHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAccessOrder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAccessOrder
的使用

使用 XmlAccessOrder 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 中 XmlAccessOrder 的使用

返回 XmlAccessOrder 的 javax.xml.bind.annotation 中的方法
static XmlAccessOrder | XmlAccessOrder.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlAccessOrder[] | XmlAccessOrder.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAccessType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAccessType
的使用

使用 XmlAccessType 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 中 XmlAccessType 的使用

返回 XmlAccessType 的 javax.xml.bind.annotation 中的方法
static XmlAccessType | XmlAccessType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlAccessType[] | XmlAccessType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAccessorOrder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAccessorOrder
的使用

没有 javax.xml.bind.annotation.XmlAccessorOrder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAccessorType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAccessorType
的使用

没有 javax.xml.bind.annotation.XmlAccessorType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAnyAttribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAnyAttribute
的使用

没有 javax.xml.bind.annotation.XmlAnyAttribute 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAnyElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAnyElement
的使用

没有 javax.xml.bind.annotation.XmlAnyElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAttachmentRef 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAttachmentRef
的使用

没有 javax.xml.bind.annotation.XmlAttachmentRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlAttribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlAttribute
的使用

没有 javax.xml.bind.annotation.XmlAttribute 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElement
的使用

没有 javax.xml.bind.annotation.XmlElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElement.DEFAULT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElement.DEFAULT
的使用

没有 javax.xml.bind.annotation.XmlElement.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementDecl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementDecl
的使用

没有 javax.xml.bind.annotation.XmlElementDecl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementDecl.GLOBAL 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementDecl.GLOBAL
的使用

没有 javax.xml.bind.annotation.XmlElementDecl.GLOBAL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementRef 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementRef
的使用

没有 javax.xml.bind.annotation.XmlElementRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementRef.DEFAULT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementRef.DEFAULT
的使用

没有 javax.xml.bind.annotation.XmlElementRef.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementRefs 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementRefs
的使用

没有 javax.xml.bind.annotation.XmlElementRefs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElementWrapper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElementWrapper
的使用

没有 javax.xml.bind.annotation.XmlElementWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlElements 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlElements
的使用

没有 javax.xml.bind.annotation.XmlElements 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlEnum 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlEnum
的使用

没有 javax.xml.bind.annotation.XmlEnum 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlEnumValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlEnumValue
的使用

没有 javax.xml.bind.annotation.XmlEnumValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlID
的使用

没有 javax.xml.bind.annotation.XmlID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlIDREF 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlIDREF
的使用

没有 javax.xml.bind.annotation.XmlIDREF 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlInlineBinaryData 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlInlineBinaryData
的使用

没有 javax.xml.bind.annotation.XmlInlineBinaryData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlList
的使用

没有 javax.xml.bind.annotation.XmlList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlMimeType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlMimeType
的使用

没有 javax.xml.bind.annotation.XmlMimeType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlMixed 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlMixed
的使用

没有 javax.xml.bind.annotation.XmlMixed 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlNs 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlNs
的使用

没有 javax.xml.bind.annotation.XmlNs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlNsForm 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlNsForm
的使用

使用 XmlNsForm 的软件包
javax.xml.bind.annotation 定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation 中 XmlNsForm 的使用

返回 XmlNsForm 的 javax.xml.bind.annotation 中的方法
static XmlNsForm | XmlNsForm.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static XmlNsForm[] | XmlNsForm.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlRegistry 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlRegistry
的使用

没有 javax.xml.bind.annotation.XmlRegistry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlRootElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlRootElement
的使用

没有 javax.xml.bind.annotation.XmlRootElement 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlSchema 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlSchema
的使用

没有 javax.xml.bind.annotation.XmlSchema 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlSchemaType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlSchemaType
的使用

没有 javax.xml.bind.annotation.XmlSchemaType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlSchemaType.DEFAULT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlSchemaType.DEFAULT
的使用

没有 javax.xml.bind.annotation.XmlSchemaType.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlSchemaTypes 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlSchemaTypes
的使用

没有 javax.xml.bind.annotation.XmlSchemaTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlTransient 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlTransient
的使用

没有 javax.xml.bind.annotation.XmlTransient 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlType
的使用

没有 javax.xml.bind.annotation.XmlType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlType.DEFAULT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlType.DEFAULT
的使用

没有 javax.xml.bind.annotation.XmlType.DEFAULT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.annotation.XmlValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.annotation.XmlValue
的使用

没有 javax.xml.bind.annotation.XmlValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AttachmentMarshaller (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.attachment
类 AttachmentMarshaller

java.lang.Object
    继承者  javax.xml.bind.attachment.AttachmentMarshaller

public abstract class AttachmentMarshaller
extends Object

启用 JAXB 编组来优化二进制数据存储。

此 API 支持 JAXB 编组过程与基于 MIME 的包处理器之间的协作，有效地创建优化的二进制数据格式。JAXB 实现对基于 MIME 的包的根正文进行编组，将可引用 MIME 部分的创建委托给实现此抽象的基于 MIME 的包处理器。

当 isXOPPackage() 为 true 时启用 XOP 处理。有关详细信息，请参阅 addMtomAttachment(DataHandler, String, String)。

addSwaRefAttachment(DataHandler) 支持 WS-I Attachment Profile 1.0，编组程序针对每个与 {http://ws-i.org/profiles/basic/1.1/xsd}swaRef 相关的 JAXB 属性调用该方法。

从以下版本开始：
JAXB 2.0
另请参见：
Marshaller.setAttachmentMarshaller(AttachmentMarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0.

构造方法摘要
AttachmentMarshaller()
方法摘要
abstract String | addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName) 将用于优化二进制存储的二进制 data 作为附件。
abstract String | addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName) 将用于优化二进制存储的 MIME 内容 data 作为附件。
abstract String | addSwaRefAttachment(DataHandler data) 将 MIME data 作为附件添加，并返回附件的内容 id（即 cid）。
boolean | isXOPPackage() 只读属性，如果 JAXB 编组器应该启用 XOP 创建，则返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AttachmentMarshaller

public AttachmentMarshaller()
方法详细信息

addMtomAttachment

public abstract String addMtomAttachment(DataHandler data,
                                         String elementNamespace,
                                         String elementLocalName)

将用于优化二进制存储的 MIME 内容 data 作为附件。

正如 Creating XOP Packages 中的步骤 3 所述，当 isXOPPackage() 为 true 时，JAXB 编组过程针对每个数据类型为 "base64Binary" 的元素调用此方法。

方法实现程序决定是将 data 单独附加还是作为 base64Binary 数据内嵌。如果实现选择将二进制数据存储作为 MIME 的一部分进行优化，则实现负责将 data 附加到基于 MIME 的包中，然后分配一个唯一的内容 id（即 cid），用来标识 MIME 消息中的 MIME 部分。此方法返回 cid，cid 使 JAXB 编组程序能够编组一个引用该 cid 的 XOP 元素，而不是编组二进制数据。当该方法返回 null 时，JAXB 编组程序将 data 作为 base64binary 数据内嵌。

此方法的调用程序要求满足以下约束条件。如果包含 data 的元素 infoset 项具有属性 xmime:contentType，或者代表 data 的 JAXB 属性/字段使用已知的 MIME 类型进行注解，则 data.getContentType() 应该被设置为 MIME 类型。

elementNamespace 和 elementLocalName 参数提供包含二进制数据的上下文。基于 MIME 的包处理器可以使用此信息，以确定二进制数据应该被内嵌还是作为附件优化。

参数：
data - 表示将被附加的数据。必须为非 null。
elementNamespace - 封装 base64Binary 数据的元素名称空间 URI。可以为空但不能为 null。
elementLocalName - 元素的本地名称。始终是非 null 的有效字符串。
返回：
一个有效的内容 id URI（参见 RFC 2387），它标识包含 data 的附件。如果没有添加附件，而是应该内嵌在消息中，则返回 null。
另请参见：
XML-binary Optimized Packaging, Describing Media Content of Binary Data in XML

addMtomAttachment

public abstract String addMtomAttachment(byte[] data,
                                         int offset,
                                         int length,
                                         String mimeType,
                                         String elementNamespace,
                                         String elementLocalName)

将用于优化二进制存储的二进制 data 作为附件。

由于内容类型未知，所以附件的 MIME 内容类型必须设置为“application/octet-stream”。

elementNamespace 和 elementLocalName 参数提供包含二进制数据的上下文。基于 MIME 的包处理器可以使用此信息，以确定二进制数据应该被内嵌，还是作为附件优化。

参数：
data - 表示将被附加的数据。必须为非 null。实际数据区域由 (data,offset,length) 元组指定。
offset - 要读取的第一个字节在数组中的偏移量；必须为非负且不大于 array.length。
length - 要从给定数组读取的字节数；必须为非负且不大于 array.length。
mimeType - 如果数据具有 JAXB 已知的关联 MIME 类型，则使用此参数传递。如果所有类型未知，则使用“application/octet-stream”。此参数不可以为 null。
elementNamespace - 封装 base64Binary 数据的元素名称空间 URI。可以为空但不能为 null。
elementLocalName - 元素的本地名称。始终是非 null 的有效字符串。
返回：
包含 data 的附件的内容 id URI（即 cid）；如果数据应该内嵌，则返回 null。
另请参见：
addMtomAttachment(DataHandler, String, String)

isXOPPackage

public boolean isXOPPackage()

只读属性，如果 JAXB 编组器应该启用 XOP 创建，则返回 true。

编组过程中此值不得更改。如果此值为 true，则当编组过程遇到适当的二进制数据类型时，将调用 addMtomAttachment(...) 方法。

如果此值为 true 且要编组的 XML 内容违反 Creating XOP Pacakgeshttp://www.w3.org/TR/2005/REC-xop10-20050125/#creating_xop_packages 中的步骤 1，则 Marshaller.marshal() 必须抛出 IllegalStateException。步骤 1 中写道：“Ensure the Original XML Infoset contains no element information item with a [namespace name] of "http://www.w3.org/2004/08/xop/include" and a [local name] of Include”。

若此方法返回 true，并且在编组过程中至少有一次调用 addMtomAttachment(...) 返回内容 id，则根据 Creating XOP Pacakges 中步骤 5 的描述，基于 MIME 的包处理器必须使用 application/xop+xml 媒体类型来标记根部分。

返回：
当 MIME 上下文是一个 XOP 包时，返回 true。

addSwaRefAttachment

public abstract String addSwaRefAttachment(DataHandler data)

将 MIME data 作为附件添加，并返回附件的内容 id（即 cid）。

JAXB 编组过程针对每个归类为 {http://ws-i.org/profiles/basic/1.1/xsd}swaRef 的元素/属性调用此方法。实现此方法的基于 MIME 的包处理器负责将指定的数据附加到 MIME 附件中，并生成一个内容 id（即 cid），用来唯一地标识基于 MIME 的包内的附件。

调用程序将返回内容 id（即 cid）插入正在编组的 XML 内容中。

参数：
data - 表示将被附加的数据。必须为非 null。
返回：
必须为用作 cid 的有效 URI。必须满足 WS-I Attachments Profile Version 1.0 的一致性要求 R2928。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AttachmentUnmarshaller (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.attachment
类 AttachmentUnmarshaller

java.lang.Object
    继承者  javax.xml.bind.attachment.AttachmentUnmarshaller

public abstract class AttachmentUnmarshaller
extends Object

启用包含优化的二进制数据格式的根文档的 JAXB 解组。

此 API 支持 JAXB 2.0 实现与基于 MIME 的包处理器（MTOM/XOP 和 WS-I AP 1.0）之间的协作，有效地处理优化的二进制数据格式。JAXB 解组包的正文，把理解将使用的打包格式这项任务委托给实现此抽象类的基于 MIME 的包处理器。

此抽象类标识包是否需要 XOP 处理（isXOPPackage()），并提供对使用内容 id 存储为附件的二进制内容的检索。

标识要传递给 getAttachment*(String cid) 的内容 id（即 cid）。

  • 对于 XOP 处理，cid 的信息集表示形式在 3.2 节 Interpreting XOP Packages 步骤 2a 中描述。
  • 对于 WS-I AP 1.0，cid 被标识为一个元素，或者 4.4 节 Referencing Attachments from the SOAP Envelope 中指定的类型 ref:swaRef 的属性。

从以下版本开始：
JAXB 2.0
另请参见：
Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0., Describing Media Content of Binary Data in XML

构造方法摘要
AttachmentUnmarshaller()
方法摘要
abstract byte[] | getAttachmentAsByteArray(String cid) 以 byte[] 形式检索由内容 id（即 cid）标识的附件。
abstract DataHandler | getAttachmentAsDataHandler(String cid) 通过内容 id（即 cid）查找 MIME 内容，并作为 DataHandler 返回。
boolean | isXOPPackage() 只读属性，如果 JAXB 解组程序需要执行 XOP 处理，则返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AttachmentUnmarshaller

public AttachmentUnmarshaller()
方法详细信息

getAttachmentAsDataHandler

public abstract DataHandler getAttachmentAsDataHandler(String cid)

通过内容 id（即 cid）查找 MIME 内容，并作为 DataHandler 返回。

返回的 DataHandler 实例必须配置为满足以下必需的映射关系约束条件。

MIME 和 Java 类型之间的必需的映射关系
MIME 类型 | Java 类型
DataHandler.getContentType() | instanceof DataHandler.getContent()
image/gif | java.awt.Image
image/jpeg | java.awt.Image
text/xml or application/xml | javax.xml.transform.Source
注意，允许支持其他映射关系。

参数：
cid - 需要它是 XML 模式 xs:anyURI 数据类型的有效词法形式。如果 isXOPPackage() ==true，则对于每个 cid: URI 模式，它都必须是有效的 URI（参见 RFC 2387）。
返回：
表示 MIME 附件的 DataHandler。
抛出：
IllegalArgumentException - 如果未找到给定 cid 的附件。

getAttachmentAsByteArray

public abstract byte[] getAttachmentAsByteArray(String cid)

以 byte[] 形式检索由内容 id（即 cid）标识的附件。

.

参数：
cid - 需要它是 XML 模式 xs:anyURI 数据类型的有效词法形式。如果 isXOPPackage() ==true，则对于每个 cid: URI 模式，它都必须是有效的 URI（参见 RFC 2387）。
返回：
由 cid 所标识的附件的 byte[] 表示形式。
抛出：
IllegalArgumentException - 如果未找到给定 cid 的附件。

isXOPPackage

public boolean isXOPPackage()

只读属性，如果 JAXB 解组程序需要执行 XOP 处理，则返回 true。

当满足 Identifying XOP Documents 中指定的约束条件时，此方法返回 true。解组过程中此值不得更改。

返回：
当 MIME 上下文是一个 XOP 文档时，返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.bind.attachment (Java Platform SE 6)

 javax.xml.bind.attachment
类
AttachmentMarshaller
AttachmentUnmarshaller


javax.xml.bind.attachment (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.bind.attachment

此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。

请参见：
描述

类摘要
AttachmentMarshaller | 启用 JAXB 编组来优化二进制数据存储。
AttachmentUnmarshaller | 启用包含优化的二进制数据格式的根文档的 JAXB 解组。

软件包 javax.xml.bind.attachment 的描述

此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。

Soap MTOM[1]、XOP([2][3]) 和 WS-I AP[4] 标准化附件形式的二进制数据类型的优化传输方法。为了在消息传递环境中最好地支持这些标准，此包在基于 MIME 的包处理器和 JAXB 解组/编组处理器之间启用了集成解决方案。

包规范

  • JAXB 规范

相关标准

  • [1]SOAP Message Transmission Optimization Mechanism
  • [2]XML-binary Optimized Packaging
  • [3]WS-I Attachments Profile Version 1.0
  • [4]Describing Media Content of Binary Data in XML

从以下版本开始：
JAXB 2.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.bind.attachment 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.attachment 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.bind.attachment.AttachmentUnmarshaller
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.bind.attachment 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.attachment
的使用

使用 javax.xml.bind.attachment 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 使用的 javax.xml.bind.attachment 中的类
AttachmentMarshaller
启用 JAXB 编组来优化二进制数据存储。
AttachmentUnmarshaller
启用包含优化的二进制数据格式的根文档的 JAXB 解组。

javax.xml.bind.helpers 使用的 javax.xml.bind.attachment 中的类
AttachmentMarshaller
启用 JAXB 编组来优化二进制数据存储。
AttachmentUnmarshaller
启用包含优化的二进制数据格式的根文档的 JAXB 解组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.attachment.AttachmentMarshaller 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.attachment.AttachmentMarshaller
的使用

使用 AttachmentMarshaller 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 AttachmentMarshaller 的使用

返回 AttachmentMarshaller 的 javax.xml.bind 中的方法
 AttachmentMarshaller Marshaller.getAttachmentMarshaller()

参数类型为 AttachmentMarshaller 的 javax.xml.bind 中的方法
 void Marshaller.setAttachmentMarshaller(AttachmentMarshaller am)
与上下文关联，使 XML 文档内的二进制数据能够以优化的 XML 二进制附件的形式传送。

javax.xml.bind.helpers 中 AttachmentMarshaller 的使用

返回 AttachmentMarshaller 的 javax.xml.bind.helpers 中的方法
 AttachmentMarshaller AbstractMarshallerImpl.getAttachmentMarshaller()

参数类型为 AttachmentMarshaller 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.setAttachmentMarshaller(AttachmentMarshaller am)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.attachment.AttachmentUnmarshaller 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.attachment.AttachmentUnmarshaller
的使用

使用 AttachmentUnmarshaller 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 AttachmentUnmarshaller 的使用

返回 AttachmentUnmarshaller 的 javax.xml.bind 中的方法
 AttachmentUnmarshaller Unmarshaller.getAttachmentUnmarshaller()

参数类型为 AttachmentUnmarshaller 的 javax.xml.bind 中的方法
 void Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller au)
将解析 cid（内容 id URI）的上下文与作为附件传递的二进制数据关联。

javax.xml.bind.helpers 中 AttachmentUnmarshaller 的使用

返回 AttachmentUnmarshaller 的 javax.xml.bind.helpers 中的方法
 AttachmentUnmarshaller AbstractUnmarshallerImpl.getAttachmentUnmarshaller()

参数类型为 AttachmentUnmarshaller 的 javax.xml.bind.helpers 中的方法
 void AbstractUnmarshallerImpl.setAttachmentUnmarshaller(AttachmentUnmarshaller au)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


JAXBResult (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.util
类 JAXBResult

java.lang.Object
    继承者  javax.xml.transform.sax.SAXResult
        继承者  javax.xml.bind.util.JAXBResult
所有已实现的接口：
Result
public class JAXBResult
extends SAXResult

解组 JAXB 对象的 JAXP Result 实现。

此实用工具类对于将 JAXB 与其他 Java/XML 技术组合很有用。

以下示例显示了如何使用 JAXB 解组 XSLT 转换得到的文档。

JAXBResult result = new JAXBResult(
JAXBContext.newInstance("org.acme.foo") );

// set up XSLT transformation
TransformerFactory tf = TransformerFactory.newInstance();
Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

// run transformation
t.transform(new StreamSource("document.xml"),result);

// obtain the unmarshalled content tree
Object o = result.getResult();

SAXResult 派生于 JAXBResult 是一个实现细节。因此，通常应用程序最好不要访问 SAXResult 上定义的方法。

尤其不能尝试调用 setHandler、setLexicalHandler 和 setSystemId 方法。

字段摘要
从类 javax.xml.transform.sax.SAXResult 继承的字段
FEATURE
从接口 javax.xml.transform.Result 继承的字段
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
构造方法摘要
JAXBResult(JAXBContext context)
创建一个使用指定 JAXBContext 来解组的新实例。
JAXBResult(Unmarshaller _unmarshaller)
创建一个使用指定 Unmarshaller 来解组对象的新实例。
方法摘要
 Object getResult()
获取通过转换创建的已解组对象。
从类 javax.xml.transform.sax.SAXResult 继承的方法
getHandler, getLexicalHandler, getSystemId, setHandler, setLexicalHandler, setSystemId
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JAXBResult

public JAXBResult(JAXBContext context)
           throws JAXBException
创建一个使用指定 JAXBContext 来解组的新实例。

参数：
context - 用于创建必需的 Unmarshaller 的 JAXBContext。此参数不能为 null。
抛出：
JAXBException - 如果创建 JAXBResult 时发生错误，或者上下文参数为 null。

JAXBResult

public JAXBResult(Unmarshaller _unmarshaller)
           throws JAXBException
创建一个使用指定 Unmarshaller 来解组对象的新实例。

此 JAXBResult 对象将使用指定的 Unmarshaller 实例。在此对象使用某个 Unmarshaller 时，调用者负责保证该 Unmarshaller 不做其他用途。

此方法的主要目的是允许客户端配置 Unmarshaller。如果不知道操作的后果，更容易也更安全的方式是传递 JAXBContext。

参数：
_unmarshaller - Unmarshaller。此参数不得为 null。
抛出：
JAXBException - 如果创建 JAXBResult 时遇到错误，或者 Unmarshaller 参数为 null。
方法详细信息

getResult

public Object getResult()
                 throws JAXBException
获取通过转换创建的已解组对象。

返回：
总是返回非 null 对象。
抛出：
IllegalStateException - 如果在解组对象前调用此方法。
JAXBException - 如果发生解组错误。注意，允许实现在解析错误期间抛出 SAXException。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


JAXBSource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.util
类 JAXBSource

java.lang.Object
    继承者  javax.xml.transform.sax.SAXSource
        继承者  javax.xml.bind.util.JAXBSource
所有已实现的接口：
Source
public class JAXBSource
extends SAXSource

编组 JAXB 生成的对象的 JAXP Source 实现。

此实用工具类对于将 JAXB 与其他 Java/XML 技术组合很有用。

以下示例显示了如何使用 JAXB 编组将由 XSLT 转换的文档。

MyObject o = // get JAXB content tree

// jaxbContext is a JAXBContext object from which 'o' is created.
JAXBSource source = new JAXBSource( jaxbContext, o );

// set up XSLT transformation
TransformerFactory tf = TransformerFactory.newInstance();
Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

// run transformation
t.transform(source,new StreamResult(System.out));

SAXSource 派生于 JAXBSource 是一个实现细节。因此，通常应用程序最好不要访问 SAXSource 上定义的方法。尤其不能调用 setXMLReader 和 setInputSource 方法。通过 getXMLReader 方法获取的 XMLReader 对象只能用于解析 getInputSource 方法返回的 InputSource 对象。

同样，通过 getInputSource 方法获得的 InputSource 对象只能由 getXMLReader 返回的 XMLReader 对象来解析。

字段摘要
从类 javax.xml.transform.sax.SAXSource 继承的字段
FEATURE
构造方法摘要
JAXBSource(JAXBContext context, Object contentObject)
针对给定的内容对象创建一个新 Source。
JAXBSource(Marshaller marshaller, Object contentObject)
针对给定的内容对象创建一个新 Source。
方法摘要
从类 javax.xml.transform.sax.SAXSource 继承的方法
getInputSource, getSystemId, getXMLReader, setInputSource, setSystemId, setXMLReader, sourceToInputSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JAXBSource

public JAXBSource(JAXBContext context,
                  Object contentObject)
           throws JAXBException
针对给定的内容对象创建一个新 Source。

参数：
context - 用于创建 contentObject 的 JAXBContext。此上下文用于创建 marshaller 的新实例，不得为 null。
contentObject - JAXB 生成的类的实例，将用作 Source（通过将它编组到 XML）。它不得为 null。
抛出：
JAXBException - 如果创建 JAXBSource 时遇到错误，或者任何一个参数为 null。

JAXBSource

public JAXBSource(Marshaller marshaller,
                  Object contentObject)
           throws JAXBException
针对给定的内容对象创建一个新 Source。

参数：
marshaller - 用于将 contentObject 编组到 XML 的 marshaller 实例。此实例必须根据用来构建 contentObject 的 JAXBContext 创建，不得为 null。
contentObject - JAXB 生成的类的实例，将用作 Source（通过将它编组到 XML）。它不得为 null。
抛出：
JAXBException - 如果创建 JAXBSource 时遇到错误，或者任何一个参数为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValidationEventCollector (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.bind.util
类 ValidationEventCollector

java.lang.Object
    继承者  javax.xml.bind.util.ValidationEventCollector
所有已实现的接口：
ValidationEventHandler
public class ValidationEventCollector
extends Object
implements ValidationEventHandler

收集所有事件的 ValidationEventHandler 实现。

要使用此类，则需要创建一个新实例并将其传递给 Validator、Unmarshaller 和 Marshaller 类的 setEventHandler 方法。完成对验证和解组的调用之后，调用 getEvents 方法来检索所有报告的错误和警告。

从以下版本开始：
JAXB1.0
另请参见：
Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

构造方法摘要
ValidationEventCollector()
方法摘要
ValidationEvent[] | getEvents() 返回一个 ValidationEvent 对象数组，这些对象包含所有收集的错误和警告的副本。
boolean | handleEvent(ValidationEvent event) 接收验证警告或错误的通知。
boolean | hasEvents() 如果此事件收集器至少包含一个 ValidationEvent，则返回 true。
void | reset() 清除所有收集的错误和警告。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ValidationEventCollector

public ValidationEventCollector()
方法详细信息

getEvents

public ValidationEvent[] getEvents()
返回一个 ValidationEvent 对象数组，这些对象包含所有收集的错误和警告的副本。

返回：
所有收集的错误和警告的副本；如果没有收集的错误和警告，则返回一个空数组

reset

public void reset()
清除所有收集的错误和警告。

hasEvents

public boolean hasEvents()
如果此事件收集器至少包含一个 ValidationEvent，则返回 true。

返回：
如果此事件收集器至少包含一个 ValidationEvent，则返回 true，否则返回 false

handleEvent

public boolean handleEvent(ValidationEvent event)
从接口 ValidationEventHandler 复制的描述
接收验证警告或错误的通知。ValidationEvent 将 ValidationEventLocator 嵌入通知中，以指示发生错误或警告的位置。

如果从此方法抛出未经检查的运行时异常，则 JAXB 提供者会像该方法返回 false 那样作出相应对待，并中断当前的解组、验证和编组操作。

指定者：
接口 ValidationEventHandler 中的 handleEvent
参数：
event - 封装的验证事件信息。如果为 null，则该信息是一个提供者错误。
返回：
如果 JAXB 提供者应该在处理此警告/错误之后尝试继续执行当前的解组、验证或编组操作，则返回 true；如果提供者应该使用适当的 UnmarshalException、ValidationException 或 MarshalException 终止当前操作，则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.bind.util (Java Platform SE 6)

 javax.xml.bind.util
类
JAXBResult
JAXBSource
ValidationEventCollector


javax.xml.bind.util (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.bind.util

有用的客户端实用工具类。

请参见：
描述

类摘要
JAXBResult | 解组 JAXB 对象的 JAXP Result 实现。
JAXBSource | 编组 JAXB 生成的对象的 JAXP Source 实现。
ValidationEventCollector | 收集所有事件的 ValidationEventHandler 实现。

软件包 javax.xml.bind.util 的描述

有用的客户端实用工具类。

包规范

  • JAXB 规范

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • JAXB 网站

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.bind.util 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.bind.util 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.bind.util
的使用

没有 javax.xml.bind.util 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.util.JAXBResult 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.util.JAXBResult
的使用

没有 javax.xml.bind.util.JAXBResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.util.JAXBSource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.util.JAXBSource
的使用

没有 javax.xml.bind.util.JAXBSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.util.ValidationEventCollector 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.util.ValidationEventCollector
的使用

没有 javax.xml.bind.util.ValidationEventCollector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.Binder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.Binder
的使用

使用 Binder 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 Binder 的使用

返回 Binder 的 javax.xml.bind 中的方法
 Binder<Node> JAXBContext.createBinder()
为 W3C DOM 创建一个 Binder。
<T> Binder<T>
JAXBContext.createBinder(Class<T> domType)
创建一个可用于关联/原地解组/编组操作的 Binder 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.DatatypeConverter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.DatatypeConverter
的使用

没有 javax.xml.bind.DatatypeConverter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.DatatypeConverterInterface 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.DatatypeConverterInterface
的使用

使用 DatatypeConverterInterface 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 DatatypeConverterInterface 的使用

参数类型为 DatatypeConverterInterface 的 javax.xml.bind 中的方法
static void DatatypeConverter.setDatatypeConverter(DatatypeConverterInterface converter)
此方法仅适用于 JAXB 提供者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.Element 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.Element
的使用

没有 javax.xml.bind.Element 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.JAXBContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBContext
的使用

使用 JAXBContext 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.bind 中 JAXBContext 的使用

返回 JAXBContext 的 javax.xml.bind 中的方法
static JAXBContext | JAXBContext.newInstance(Class... classesToBeBound) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties) 获得 JAXBContext 类的新实例。

javax.xml.bind.util 中 JAXBContext 的使用

参数类型为 JAXBContext 的 javax.xml.bind.util 中的构造方法
JAXBResult(JAXBContext context)
创建一个使用指定 JAXBContext 来解组的新实例。
JAXBSource(JAXBContext context, Object contentObject)
针对给定的内容对象创建一个新 Source。

javax.xml.ws 中 JAXBContext 的使用

参数类型为 JAXBContext 的 javax.xml.ws 中的方法
Dispatch<Object> | Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode) 创建与生成的 JAXB 对象一起使用的 Dispatch 实例。
Object | LogicalMessage.getPayload(JAXBContext context) 以 JAXB 对象的形式获取消息负载。
void | LogicalMessage.setPayload(Object payload, JAXBContext context) 设置消息负载

javax.xml.ws.handler.soap 中 JAXBContext 的使用

参数类型为 JAXBContext 的 javax.xml.ws.handler.soap 中的方法
 Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
从消息上下文的消息中获得具有特定限定名的头。

javax.xml.ws.spi 中 JAXBContext 的使用

参数类型为 JAXBContext 的 javax.xml.ws.spi 中的方法
abstract  Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.JAXBElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBElement
的使用

使用 JAXBElement 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 JAXBElement 的使用

返回 JAXBElement 的 javax.xml.bind 中的方法
<T> JAXBElement<T>
Unmarshaller.unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
abstract
<T> JAXBElement<T>
Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

javax.xml.bind.helpers 中 JAXBElement 的使用

返回 JAXBElement 的 javax.xml.bind.helpers 中的方法
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.JAXBElement.GlobalScope 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBElement.GlobalScope
的使用

没有 javax.xml.bind.JAXBElement.GlobalScope 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.JAXBException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBException
的使用

使用 JAXBException 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 JAXBException 的使用

javax.xml.bind 中 JAXBException 的子类
class | MarshalException 此异常指示在执行提供者无法恢复的编组操作时发生错误。
class | PropertyException 此异常指示在获取或设置属性时遇到一个错误。
class | UnmarshalException 此异常指示在执行阻止 JAXB 提供者完成操作的解组操作时遇到一个错误。
class | ValidationException 此异常指示在执行验证操作时发生错误。

抛出 JAXBException 的 javax.xml.bind 中的方法
abstract  Marshaller JAXBContext.createMarshaller()
创建一个可以用来将 java 内容树转换为 XML 数据的 Marshaller 对象。
abstract  Unmarshaller JAXBContext.createUnmarshaller()
创建一个可以用来将 XML 数据转换为 java 内容树的 Unmarshaller 对象。
abstract  Validator JAXBContext.createValidator()
已过时。 从 JAXB 2.0 开始
abstract  ValidationEventHandler Binder.getEventHandler()
当前的事件处理程序；如果没有设置，则返回默认事件处理程序。
 ValidationEventHandler Marshaller.getEventHandler()
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
 ValidationEventHandler Unmarshaller.getEventHandler()
返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认的事件处理程序。
 ValidationEventHandler Validator.getEventHandler()
已过时。 从 JAXB2.0 开始
 Node Marshaller.getNode(Object contentTree)
获取内容树的 DOM 树视图（可选）。
 Object UnmarshallerHandler.getResult()
获得解组的结果。
 boolean Unmarshaller.isValidating()
已过时。 从 JAXB 2.0 开始，请参阅 Unmarshaller.getSchema()
 void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。
 void Marshaller.marshal(Object jaxbElement, Node node)
将以 jaxbElement 为根的内容树编组到 DOM 树中。
 void Marshaller.marshal(Object jaxbElement, OutputStream os)
将以 jaxbElement 为根的内容树编组到输出流中。
 void Marshaller.marshal(Object jaxbElement, Result result)
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。
 void Marshaller.marshal(Object jaxbElement, Writer writer)
将以 jaxbElement 为根的内容树编组到 Writer 中。
 void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。
abstract  void Binder.marshal(Object jaxbObject, XmlNode xmlNode)
将 JAXB 对象树编组为新的 XML 文档。
 void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。
static JAXBContext JAXBContext.newInstance(Class... classesToBeBound)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(String contextPath)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
获得 JAXBContext 类的新实例。
abstract  void Binder.setEventHandler(ValidationEventHandler handler)
允许应用程序注册 ValidationEventHandler。
 void Marshaller.setEventHandler(ValidationEventHandler handler)
允许应用程序注册一个验证事件处理程序。
 void Unmarshaller.setEventHandler(ValidationEventHandler handler)
允许应用程序注册 ValidationEventHandler。
 void Validator.setEventHandler(ValidationEventHandler handler)
已过时。 从 JAXB2.0 开始
 void Unmarshaller.setValidating(boolean validating)
已过时。 从 JAXB2.0 开始，请参阅 Unmarshaller.setSchema(javax.xml.validation.Schema)
 Object Unmarshaller.unmarshal(File f)
从指定的文件解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(InputSource source)
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(InputStream is)
从指定的 InputStream 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(Node node)
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(Reader reader)
从指定的 Reader 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(Source source)
从指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(URL url)
从指定的 URL 解组 XML 数据并返回得到的内容树。
 Object Unmarshaller.unmarshal(XMLEventReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
abstract  Object Binder.unmarshal(XmlNode xmlNode)
将 XML 信息集视图解组为 JAXB 对象树。
abstract
<T> JAXBElement<T>
Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
 Object Unmarshaller.unmarshal(XMLStreamReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
abstract  Object Binder.updateJAXB(XmlNode xmlNode)
取一个 XML 节点，并更新与其关联的 JAXB 对象和该对象的子级。
abstract  XmlNode Binder.updateXML(Object jaxbObject)
取一个 JAXB 对象，并更新与其关联的 XML 节点和该节点的子级。
abstract  XmlNode Binder.updateXML(Object jaxbObject, XmlNode xmlNode)
JAXB 对象树中所做的更改在与其关联的 XML 解析树中得到更新。
 boolean Validator.validate(Object subrootObj)
已过时。 从 JAXB2.0 开始
 boolean Validator.validateRoot(Object rootObj)
已过时。 从 JAXB2.0 开始

javax.xml.bind.helpers 中 JAXBException 的使用

抛出 JAXBException 的 javax.xml.bind.helpers 中的方法
 ValidationEventHandler AbstractMarshallerImpl.getEventHandler()
 ValidationEventHandler AbstractUnmarshallerImpl.getEventHandler()
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
 Node AbstractMarshallerImpl.getNode(Object obj)
默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。
protected  XMLReader AbstractUnmarshallerImpl.getXMLReader()
获取配置好的 XMLReader。
 boolean AbstractUnmarshallerImpl.isValidating()
指示 Unmarshaller 是否被配置为在执行解组操作期间进行验证。
 void AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)
 void AbstractMarshallerImpl.marshal(Object obj, Node node)
 void AbstractMarshallerImpl.marshal(Object obj, OutputStream os)
 void AbstractMarshallerImpl.marshal(Object obj, Writer w)
 void AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)
 void AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)
 void AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)
 void AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler)
允许应用程序注册一个验证事件处理程序。
 void AbstractUnmarshallerImpl.setValidating(boolean validating)
指定 Unmarshaller 是否应该在执行解组操作期间进行验证。
 Object AbstractUnmarshallerImpl.unmarshal(File f)
 Object AbstractUnmarshallerImpl.unmarshal(InputSource source)
 Object AbstractUnmarshallerImpl.unmarshal(InputStream is)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
 Object AbstractUnmarshallerImpl.unmarshal(Reader reader)
 Object AbstractUnmarshallerImpl.unmarshal(Source source)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
 Object AbstractUnmarshallerImpl.unmarshal(URL url)
 Object AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
protected abstract  Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
使用指定的 XMLReader 和 InputSource 解组对象。
 Object AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

javax.xml.bind.util 中 JAXBException 的使用

抛出 JAXBException 的 javax.xml.bind.util 中的方法
 Object JAXBResult.getResult()
获取通过转换创建的已解组对象。

抛出 JAXBException 的 javax.xml.bind.util 中的构造方法
JAXBResult(JAXBContext context)
创建一个使用指定 JAXBContext 来解组的新实例。
JAXBResult(Unmarshaller _unmarshaller)
创建一个使用指定 Unmarshaller 来解组对象的新实例。
JAXBSource(JAXBContext context, Object contentObject)
针对给定的内容对象创建一个新 Source。
JAXBSource(Marshaller marshaller, Object contentObject)
针对给定的内容对象创建一个新 Source。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.JAXBIntrospector 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.JAXBIntrospector
的使用

使用 JAXBIntrospector 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 JAXBIntrospector 的使用

返回 JAXBIntrospector 的 javax.xml.bind 中的方法
 JAXBIntrospector JAXBContext.createJAXBIntrospector()
创建一个可以用于内省 JAXB 对象的 JAXBIntrospector 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.MarshalException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.MarshalException
的使用

没有 javax.xml.bind.MarshalException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.Marshaller 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.Marshaller
的使用

使用 Marshaller 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 Marshaller 的使用

返回 Marshaller 的 javax.xml.bind 中的方法
abstract  Marshaller JAXBContext.createMarshaller()
创建一个可以用来将 java 内容树转换为 XML 数据的 Marshaller 对象。

javax.xml.bind.helpers 中 Marshaller 的使用

实现 Marshaller 的 javax.xml.bind.helpers 中的类
 class AbstractMarshallerImpl
部分默认 Marshaller 实现。

javax.xml.bind.util 中 Marshaller 的使用

参数类型为 Marshaller 的 javax.xml.bind.util 中的构造方法
JAXBSource(Marshaller marshaller, Object contentObject)
针对给定的内容对象创建一个新 Source。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.Marshaller.Listener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.Marshaller.Listener
的使用

使用 Marshaller.Listener 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 Marshaller.Listener 的使用

返回 Marshaller.Listener 的 javax.xml.bind 中的方法
 Marshaller.Listener Marshaller.getListener()
返回向此 Marshaller 注册的 Marshaller.Listener。

参数类型为 Marshaller.Listener 的 javax.xml.bind 中的方法
 void Marshaller.setListener(Marshaller.Listener listener)
向此 Marshaller 注册编组事件回调 Marshaller.Listener。

javax.xml.bind.helpers 中 Marshaller.Listener 的使用

返回 Marshaller.Listener 的 javax.xml.bind.helpers 中的方法
 Marshaller.Listener AbstractMarshallerImpl.getListener()

参数类型为 Marshaller.Listener 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.setListener(Marshaller.Listener listener)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.NotIdentifiableEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.NotIdentifiableEvent
的使用

使用 NotIdentifiableEvent 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 NotIdentifiableEvent 的使用

实现 NotIdentifiableEvent 的 javax.xml.bind.helpers 中的类
 class NotIdentifiableEventImpl
NotIdentifiableEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.ParseConversionEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.ParseConversionEvent
的使用

使用 ParseConversionEvent 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 ParseConversionEvent 的使用

实现 ParseConversionEvent 的 javax.xml.bind.helpers 中的类
 class ParseConversionEventImpl
ParseConversionEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.PrintConversionEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.PrintConversionEvent
的使用

使用 PrintConversionEvent 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 PrintConversionEvent 的使用

实现 PrintConversionEvent 的 javax.xml.bind.helpers 中的类
 class PrintConversionEventImpl
PrintConversionEvent 接口的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.PropertyException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.PropertyException
的使用

使用 PropertyException 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 PropertyException 的使用

抛出 PropertyException 的 javax.xml.bind 中的方法
abstract Object | Binder.getProperty(String name) 获取 Binder 的基础实现中的特定属性。
Object | Marshaller.getProperty(String name) 获取 Marshaller 底层实现中的特定属性。
Object | Unmarshaller.getProperty(String name) 获取 Unmarshaller 底层实现中的特定属性。
Object | Validator.getProperty(String name) 已过时。 从 JAXB2.0 开始
abstract void | Binder.setProperty(String name, Object value) 设置 Binder 的基础实现中的特定属性。
void | Marshaller.setProperty(String name, Object value) 设置 Marshaller 底层实现中的特定属性。
void | Unmarshaller.setProperty(String name, Object value) 设置 Unmarshaller 底层实现中的特定属性。
void | Validator.setProperty(String name, Object value) 已过时。 从 JAXB2.0 开始

javax.xml.bind.helpers 中 PropertyException 的使用

抛出 PropertyException 的 javax.xml.bind.helpers 中的方法
Object | AbstractMarshallerImpl.getProperty(String name) getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
Object | AbstractUnmarshallerImpl.getProperty(String name) 由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。
void | AbstractMarshallerImpl.setProperty(String name, Object value) setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
void | AbstractUnmarshallerImpl.setProperty(String name, Object value) 由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.SchemaOutputResolver 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.SchemaOutputResolver
的使用

使用 SchemaOutputResolver 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 SchemaOutputResolver 的使用

参数类型为 SchemaOutputResolver 的 javax.xml.bind 中的方法
 void JAXBContext.generateSchema(SchemaOutputResolver outputResolver)
生成此上下文的模式文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.TypeConstraintException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.TypeConstraintException
的使用

没有 javax.xml.bind.TypeConstraintException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.UnmarshalException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.UnmarshalException
的使用

使用 UnmarshalException 的软件包
javax.xml.bind.helpers 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.helpers 中 UnmarshalException 的使用

返回 UnmarshalException 的 javax.xml.bind.helpers 中的方法
protected  UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
从 SAXException 创建 UnmarshalException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.Unmarshaller 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.Unmarshaller
的使用

使用 Unmarshaller 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 Unmarshaller 的使用

返回 Unmarshaller 的 javax.xml.bind 中的方法
abstract  Unmarshaller JAXBContext.createUnmarshaller()
创建一个可以用来将 XML 数据转换为 java 内容树的 Unmarshaller 对象。

javax.xml.bind.helpers 中 Unmarshaller 的使用

实现 Unmarshaller 的 javax.xml.bind.helpers 中的类
 class AbstractUnmarshallerImpl
部分默认 Unmarshaller 实现。

javax.xml.bind.util 中 Unmarshaller 的使用

参数类型为 Unmarshaller 的 javax.xml.bind.util 中的构造方法
JAXBResult(Unmarshaller _unmarshaller)
创建一个使用指定 Unmarshaller 来解组对象的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.Unmarshaller.Listener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.Unmarshaller.Listener
的使用

使用 Unmarshaller.Listener 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 Unmarshaller.Listener 的使用

返回 Unmarshaller.Listener 的 javax.xml.bind 中的方法
 Unmarshaller.Listener Unmarshaller.getListener()
返回向此 Unmarshaller 注册的 Unmarshaller.Listener。

参数类型为 Unmarshaller.Listener 的 javax.xml.bind 中的方法
 void Unmarshaller.setListener(Unmarshaller.Listener listener)
向此 Unmarshaller 注册解组事件回调 Unmarshaller.Listener。

javax.xml.bind.helpers 中 Unmarshaller.Listener 的使用

返回 Unmarshaller.Listener 的 javax.xml.bind.helpers 中的方法
 Unmarshaller.Listener AbstractUnmarshallerImpl.getListener()

参数类型为 Unmarshaller.Listener 的 javax.xml.bind.helpers 中的方法
 void AbstractUnmarshallerImpl.setListener(Unmarshaller.Listener listener)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.UnmarshallerHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.UnmarshallerHandler
的使用

使用 UnmarshallerHandler 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 UnmarshallerHandler 的使用

返回 UnmarshallerHandler 的 javax.xml.bind 中的方法
 UnmarshallerHandler Unmarshaller.getUnmarshallerHandler()
获取可用作 XML 管线中的组件的 unmarshaller 处理程序对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.ValidationEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.ValidationEvent
的使用

使用 ValidationEvent 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 ValidationEvent 的使用

javax.xml.bind 中 ValidationEvent 的子接口
interface | NotIdentifiableEvent 此事件指示解析 ID/IDREF 时遇到一个问题。
interface | ParseConversionEvent 此事件指示将 XML 数据中的字符串转换为目标 Java 数据类型的值时遇到一个问题。
interface | PrintConversionEvent 此事件指示将 Java 内容树中的数据转换为其词汇表示形式时遇到一个问题。

参数类型为 ValidationEvent 的 javax.xml.bind 中的方法
 boolean ValidationEventHandler.handleEvent(ValidationEvent event)
接收验证警告或错误的通知。

javax.xml.bind.helpers 中 ValidationEvent 的使用

实现 ValidationEvent 的 javax.xml.bind.helpers 中的类
class | NotIdentifiableEventImpl NotIdentifiableEvent 接口的默认实现。
class | ParseConversionEventImpl ParseConversionEvent 接口的默认实现。
class | PrintConversionEventImpl PrintConversionEvent 接口的默认实现。
class | ValidationEventImpl ValidationEvent 接口的默认实现。

参数类型为 ValidationEvent 的 javax.xml.bind.helpers 中的方法
 boolean DefaultValidationEventHandler.handleEvent(ValidationEvent event)

javax.xml.bind.util 中 ValidationEvent 的使用

返回 ValidationEvent 的 javax.xml.bind.util 中的方法
 ValidationEvent[] ValidationEventCollector.getEvents()
返回一个 ValidationEvent 对象数组，这些对象包含所有收集的错误和警告的副本。

参数类型为 ValidationEvent 的 javax.xml.bind.util 中的方法
 boolean ValidationEventCollector.handleEvent(ValidationEvent event)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.ValidationEventHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.ValidationEventHandler
的使用

使用 ValidationEventHandler 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。

javax.xml.bind 中 ValidationEventHandler 的使用

返回 ValidationEventHandler 的 javax.xml.bind 中的方法
abstract ValidationEventHandler | Binder.getEventHandler() 当前的事件处理程序；如果没有设置，则返回默认事件处理程序。
ValidationEventHandler | Marshaller.getEventHandler() 返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
ValidationEventHandler | Unmarshaller.getEventHandler() 返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认的事件处理程序。
ValidationEventHandler | Validator.getEventHandler() 已过时。 从 JAXB2.0 开始

参数类型为 ValidationEventHandler 的 javax.xml.bind 中的方法
abstract void | Binder.setEventHandler(ValidationEventHandler handler) 允许应用程序注册 ValidationEventHandler。
void | Marshaller.setEventHandler(ValidationEventHandler handler) 允许应用程序注册一个验证事件处理程序。
void | Unmarshaller.setEventHandler(ValidationEventHandler handler) 允许应用程序注册 ValidationEventHandler。
void | Validator.setEventHandler(ValidationEventHandler handler) 已过时。 从 JAXB2.0 开始

javax.xml.bind.annotation 中 ValidationEventHandler 的使用

参数类型为 ValidationEventHandler 的 javax.xml.bind.annotation 中的方法
ResultT | DomHandler.createUnmarshaller(ValidationEventHandler errorHandler) 当 JAXB 提供者需要将文档的一部分解组为信息集表示形式时，首先要调用此方法创建一个 Result 对象。
DOMResult | W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)
Source | DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler) 在 JAXB 提供者需要将元素编组为 XML 时调用此方法。
Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

javax.xml.bind.helpers 中 ValidationEventHandler 的使用

实现 ValidationEventHandler 的 javax.xml.bind.helpers 中的类
 class DefaultValidationEventHandler
唯一的 JAXB 1.0 默认验证事件处理程序。

返回 ValidationEventHandler 的 javax.xml.bind.helpers 中的方法
ValidationEventHandler | AbstractMarshallerImpl.getEventHandler()
ValidationEventHandler | AbstractUnmarshallerImpl.getEventHandler() 返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。

参数类型为 ValidationEventHandler 的 javax.xml.bind.helpers 中的方法
void | AbstractMarshallerImpl.setEventHandler(ValidationEventHandler handler)
void | AbstractUnmarshallerImpl.setEventHandler(ValidationEventHandler handler) 允许应用程序注册一个验证事件处理程序。

javax.xml.bind.util 中 ValidationEventHandler 的使用

实现 ValidationEventHandler 的 javax.xml.bind.util 中的类
 class ValidationEventCollector
收集所有事件的 ValidationEventHandler 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.ValidationEventLocator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.ValidationEventLocator
的使用

使用 ValidationEventLocator 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind 中 ValidationEventLocator 的使用

返回 ValidationEventLocator 的 javax.xml.bind 中的方法
 ValidationEventLocator ValidationEvent.getLocator()
检索此警告/错误的定位符。

javax.xml.bind.helpers 中 ValidationEventLocator 的使用

实现 ValidationEventLocator 的 javax.xml.bind.helpers 中的类
 class ValidationEventLocatorImpl
ValidationEventLocator 接口的默认实现。

返回 ValidationEventLocator 的 javax.xml.bind.helpers 中的方法
 ValidationEventLocator ValidationEventImpl.getLocator()

参数类型为 ValidationEventLocator 的 javax.xml.bind.helpers 中的方法
 void ValidationEventImpl.setLocator(ValidationEventLocator _locator)
设置此事件的 Locator 对象。

参数类型为 ValidationEventLocator 的 javax.xml.bind.helpers 中的构造方法
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 NotIdentifiableEventImpl。
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 NotIdentifiableEventImpl。
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ParseConversionEventImpl。
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ParseConversionEventImpl。
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 PrintConversionEventImpl。
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 PrintConversionEventImpl。
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ValidationEventImpl。
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ValidationEventImpl。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.bind.ValidationException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.bind.ValidationException
的使用

没有 javax.xml.bind.ValidationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.bind.Validator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.bind.Validator
的使用

使用 Validator 的软件包
javax.xml.bind 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind 中 Validator 的使用

返回 Validator 的 javax.xml.bind 中的方法
abstract  Validator JAXBContext.createValidator()
已过时。 从 JAXB 2.0 开始

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AttachmentPart (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 AttachmentPart

java.lang.Object
    继承者  javax.xml.soap.AttachmentPart

public abstract class AttachmentPart
extends Object

SOAPMessage 对象的一个附件。SOAPMessage 对象可以包含 0 个、1 个或多个 AttachmentPart 对象。每个 AttachmentPart 对象由两部分组成：特定于应用程序的内容和关联的 MIME 头。MIME 头由可用于标识和描述内容的名称/值对组成。

AttachmentPart 对象必须符合某些标准。

  1. 它必须符合 MIME [RFC2045] 标准
  2. 它必须包含内容
  3. 头部分必须包含以下头内容：
    • Content-Type
      此头标识 AttachmentPart 对象内容中的数据类型，必须符合 [RFC2045]。以下是一个 Content-Type 头的示例：
      Content-Type:application/xml
      以下代码行（其中 ap 是一个 AttachmentPart 对象）设置前一示例中显示的头。
      ap.setMimeHeader("Content-Type", "application/xml");

AttachmentPart 对象的内容部分没有任何限制。内容可以是简单的纯文本对象、复杂的 XML 文档或图像文件。

AttachmentPart 对象是使用方法 SOAPMessage.createAttachmentPart 创建的。设置 MIME 头之后，使用方法 SOAPMessage.addAttachmentPart 将 AttachmentPart 对象添加到创建它的消息中。

以下代码片段（其中 m 是一个 SOAPMessage 对象，contentStringl 是一个 String）创建 AttachmentPart 的实例，使用一些内容和头信息设置 AttachmentPart 对象，并将 AttachmentPart 对象添加到 SOAPMessage 对象。

AttachmentPart ap1 = m.createAttachmentPart();
ap1.setContent(contentString1, "text/plain");
m.addAttachmentPart(ap1);

以下代码片段创建第二个 AttachmentPart 实例并将其添加到同一消息中。jpegData 是表示 jpeg 文件的一个二进制字节缓冲区。

AttachmentPart ap2 = m.createAttachmentPart();
byte[] jpegData =  ...;
ap2.setContent(new ByteArrayInputStream(jpegData), "image/jpeg");
m.addAttachmentPart(ap2);

getContent 方法检索 AttachmentPart 对象的内容和头。根据存在 DataContentHandler 对象的不同，返回的 Object 可能是与 MIME 类型相对应的类型化的 Java 对象，也可能是以字节形式包含内容的 InputStream 对象。

String content1 = ap1.getContent();
java.io.InputStream content2 = ap2.getContent();
方法 clearContent 从 AttachmentPart 对象中移除所有内容，但不影响其头信息。
ap1.clearContent();

构造方法摘要
AttachmentPart()
方法摘要
abstract void | addMimeHeader(String name, String value) 将带有指定名称和值的 MIME 头添加到此 AttachmentPart 对象。
abstract void | clearContent() 清除此 AttachmentPart 对象的内容。
abstract Iterator | getAllMimeHeaders() 以 MimeHeader 对象上的迭代器形式，检索此 AttachmentPart 对象的所有头。
abstract InputStream | getBase64Content() 以 Base64 编码字符数据的形式返回可用于获取 AttachmentPart 内容的 InputStream，此方法将对附件的原始字节进行 Base64 编码，然后返回该内容。
abstract Object | getContent() 以 Java 对象的形式获取此 AttachmentPart 对象的内容。
String | getContentId() 获取名为 "Content-ID" 的 MIME 头的值。
String | getContentLocation() 获取名为 "Content-Location" 的 MIME 头的值。
String | getContentType() 获取名为 "Content-Type" 的 MIME 头的值。
abstract DataHandler | getDataHandler() 获取针对此 AttachmentPart 对象的 DataHandler 对象。
abstract Iterator | getMatchingMimeHeaders(String[] names) 检索匹配给定数组中名称的所有 MimeHeader 对象。
abstract String[] | getMimeHeader(String name) 获取给定 String 所标识的头的所有值。
abstract Iterator | getNonMatchingMimeHeaders(String[] names) 检索所有名称不匹配给定数组中任一名称的 MimeHeader 对象。
abstract InputStream | getRawContent() 以 InputStream 的形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
abstract byte[] | getRawContentBytes() 以 byte[] 数组形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
abstract int | getSize() 返回此 AttachmentPart 对象中的字节数。
abstract void | removeAllMimeHeaders() 移除所有 MIME 头条目。
abstract void | removeMimeHeader(String header) 移除匹配给定名称的所有 MIME 头。
abstract void | setBase64Content(InputStream content, String contentType) 根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。
abstract void | setContent(Object object, String contentType) 将此附件部分的内容设置为给定 Object 的内容，并将 Content-Type 头的值设置为给定类型。
void | setContentId(String contentId) 使用给定值设置名为 "Content-ID" 的 MIME 头。
void | setContentLocation(String contentLocation) 使用给定值设置名为 "Content-Location" 的 MIME 头。
void | setContentType(String contentType) 使用给定值设置名为 "Content-Type" 的 MIME 头。
abstract void | setDataHandler(DataHandler dataHandler) 将给定的 DataHandler 对象设置为此 AttachmentPart 对象的数据处理程序。
abstract void | setMimeHeader(String name, String value) 将匹配给定名称的第一个头条目的值更改为给定值，如果现有的头都不匹配，则添加一个新的头。
abstract void | setRawContent(InputStream content, String contentType) 将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
abstract void | setRawContentBytes(byte[] content, int offset, int len, String contentType) 将此附件部分的内容设置为 byte[] 数组 content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AttachmentPart

public AttachmentPart()
方法详细信息

getSize

public abstract int getSize()
                     throws SOAPException
返回此 AttachmentPart 对象中的字节数。

返回：
此 AttachmentPart 对象的大小，以字节为单位；如果无法确定其大小，则返回 -1
抛出：
SOAPException - 如果此附件的内容已损坏，或者尝试确定其大小时引发异常。

clearContent

public abstract void clearContent()
清除此 AttachmentPart 对象的内容。MIME 头部分保持不变。

getContent

public abstract Object getContent()
                           throws SOAPException
以 Java 对象的形式获取此 AttachmentPart 对象的内容。返回的 Java 对象的类型取决于：(1) 用来解释字节的 DataContentHandler 对象；(2) 头中给定的 Content-Type。

对于 MIME 内容类型 "text/plain"、"text/html" 和 "text/xml"，DataContentHandler 对象执行与对应于 MIME 类型的 Java 类型之间的转换。对于其他 MIME 类型，DataContentHandler 对象可以返回以原始字节形式包含内容的 InputStream 对象。

符合 SAAJ 的实现至少必须返回一个 java.lang.String 对象（与 Content-Type 值为 text/plain 的任何内容流相对应）、一个 javax.xml.transform.stream.StreamSource 对象（与 Content-Type 值为 text/xml 的内容流相对应）、以及一个 java.awt.Image 对象（与 Content-Type 值为 image/gif 或 image/jpeg 的内容流相对应）。对于已安装的 DataContentHandler 对象不理解的内容类型，DataContentHandler 对象要返回带有原始字节的 java.io.InputStream 对象。

返回：
带有此 AttachmentPart 对象内容的 Java 对象
抛出：
SOAPException - 如果此 AttachmentPart 对象中没有设置任何内容，或者出现数据转换错误

getRawContent

public abstract InputStream getRawContent()
                                   throws SOAPException
以 InputStream 的形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。

注意，读取返回的 InputStream 可能导致消耗流中的数据。调用者负责在调用 Subsequent API 之前适当地重置 InputStream。如果需要附件原始内容的一个副本，则应改用 getRawContentBytes() API。

返回：
一个 InputStream 对象，从中可以访问 AttachmentPart 包含的原始数据。
抛出：
SOAPException - 如果此 AttachmentPart 对象中没有设置任何内容，或者出现数据转换错误。
从以下版本开始：
SAAJ 1.3
另请参见：
getRawContentBytes()

getRawContentBytes

public abstract byte[] getRawContentBytes()
                                   throws SOAPException
以 byte[] 数组形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。

返回：
包含 AttachmentPart 原始数据的 byte[] 数组。
抛出：
SOAPException - 如果此 AttachmentPart 对象中没有设置任何内容，或者出现数据转换错误。
从以下版本开始：
SAAJ 1.3

getBase64Content

public abstract InputStream getBase64Content()
                                      throws SOAPException
以 Base64 编码字符数据的形式返回可用于获取 AttachmentPart 内容的 InputStream，此方法将对附件的原始字节进行 Base64 编码，然后返回该内容。

返回：
一个 InputStream 对象，从中可以读取 Base64 编码的 AttachmentPart。
抛出：
SOAPException - 如果此 AttachmentPart 对象中没有设置任何内容，或者出现数据转换错误。
从以下版本开始：
SAAJ 1.3

setContent

public abstract void setContent(Object object,
                                String contentType)
将此附件部分的内容设置为给定 Object 的内容，并将 Content-Type 头的值设置为给定类型。Object 的类型应该对应于指定给 Content-Type 的值。这取决于所使用的特定 DataContentHandler 对象集合。

参数：
object - 组成此附件部分内容的 Java 对象
contentType - 指定内容类型的 MIME 字符串
抛出：
IllegalArgumentException - 如果 contentType 不匹配内容对象的类型，或者没有针对此内容对象的 DataContentHandler 对象
另请参见：
getContent()

setRawContent

public abstract void setRawContent(InputStream content,
                                   String contentType)
                            throws SOAPException
将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。

后续调用 getSize() 可能无法准确度量内容的大小。

参数：
content - 要添加到附件部分的原始数据
contentType - 将在 Content-Type 头中设置的值
抛出：
SOAPException - 如果设置内容时发生错误
NullPointerException - 如果 content 为 null
从以下版本开始：
SAAJ 1.3

setRawContentBytes

public abstract void setRawContentBytes(byte[] content,
                                        int offset,
                                        int len,
                                        String contentType)
                                 throws SOAPException
将此附件部分的内容设置为 byte[] 数组 content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。

参数：
content - 要添加到附件部分的原始数据
contentType - 要在 Content-Type 头中设置的值
offset - 内容字节数组中的偏移量
len - 组成内容的字节数
抛出：
SOAPException - 如果设置内容时发生错误，或者内容为 null
从以下版本开始：
SAAJ 1.3

setBase64Content

public abstract void setBase64Content(InputStream content,
                                      String contentType)
                               throws SOAPException
根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。

后续调用 getSize() 可能无法准确度量内容的大小。

参数：
content - 要添加到附件部分的 Base64 解码数据
contentType - 要在 Content-Type 头中设置的值
抛出：
SOAPException - 如果设置内容时发生错误
NullPointerException - 如果 content 为 null
从以下版本开始：
SAAJ 1.3

getDataHandler

public abstract DataHandler getDataHandler()
                                    throws SOAPException
获取针对此 AttachmentPart 对象的 DataHandler 对象。

返回：
与此 AttachmentPart 对象关联的 DataHandler 对象
抛出：
SOAPException - 如果此 AttachmentPart 对象中没有数据

setDataHandler

public abstract void setDataHandler(DataHandler dataHandler)
将给定的 DataHandler 对象设置为此 AttachmentPart 对象的数据处理程序。通常，对于传入的消息，数据处理程序是自动设置的。创建消息并填充内容之后，可以使用 setDataHandler 方法从各种数据源获取数据并转入该消息中。

参数：
dataHandler - 要设置的 DataHandler 对象
抛出：
IllegalArgumentException - 如果指定的 DataHandler 对象存在问题

getContentId

public String getContentId()
获取名为 "Content-ID" 的 MIME 头的值。

返回：
给出 "Content-ID" 头值的 String；如果不存在此类字符串，则返回 null
另请参见：
setContentId(java.lang.String)

getContentLocation

public String getContentLocation()
获取名为 "Content-Location" 的 MIME 头的值。

返回：
给出 "Content-Location" 头值的 String；如果不存在此类字符串，则返回 null

getContentType

public String getContentType()
获取名为 "Content-Type" 的 MIME 头的值。

返回：
给出 "Content-Type" 头值的 String；如果不存在此类字符串，则返回 null

setContentId

public void setContentId(String contentId)
使用给定值设置名为 "Content-ID" 的 MIME 头。

参数：
contentId - 给出 "Content-ID" 头值的 String
抛出：
IllegalArgumentException - 如果指定的 contentId 值存在问题
另请参见：
getContentId()

setContentLocation

public void setContentLocation(String contentLocation)
使用给定值设置名为 "Content-Location" 的 MIME 头。

参数：
contentLocation - 给出 "Content-Location" 头值的 String
抛出：
IllegalArgumentException - 如果指定的内容位置存在问题

setContentType

public void setContentType(String contentType)
使用给定值设置名为 "Content-Type" 的 MIME 头。

参数：
contentType - 给出 "Content-Type" 头值的 String
抛出：
IllegalArgumentException - 如果指定的内容类型存在问题

removeMimeHeader

public abstract void removeMimeHeader(String header)
移除匹配给定名称的所有 MIME 头。

参数：
header - 要移除的 MIME 头的字符串名

removeAllMimeHeaders

public abstract void removeAllMimeHeaders()
移除所有 MIME 头条目。

getMimeHeader

public abstract String[] getMimeHeader(String name)
获取给定 String 所标识的头的所有值。

参数：
name - 头的名称；示例："Content-Type"
返回：
给出指定头值的 String 数组
另请参见：
setMimeHeader(java.lang.String, java.lang.String)

setMimeHeader

public abstract void setMimeHeader(String name,
                                   String value)
将匹配给定名称的第一个头条目的值更改为给定值，如果现有的头都不匹配，则添加一个新的头。此方法还将移除第一个匹配头以外的所有匹配的头。

注意，RFC822 头只能包含 US-ASCII 字符。

参数：
name - 一个 String，用于提供要搜索的头的名称
value - 一个 String，用于提供将用来设置名称匹配给定名称的头的值
抛出：
IllegalArgumentException - 如果指定的 MIME 头名称或值存在问题

addMimeHeader

public abstract void addMimeHeader(String name,
                                   String value)
将带有指定名称和值的 MIME 头添加到此 AttachmentPart 对象。

注意，RFC822 头只能包含 US-ASCII 字符。

参数：
name - 一个 String，用于提供要添加的头的名称
value - 一个 String，用于提供要添加的头的值
抛出：
IllegalArgumentException - 如果指定的 MIME 头名称或值存在问题

getAllMimeHeaders

public abstract Iterator getAllMimeHeaders()
以 MimeHeader 对象上的迭代器形式，检索此 AttachmentPart 对象的所有头。

返回：
带有此 AttachmentPart 对象所有 MIME 头的 Iterator 对象

getMatchingMimeHeaders

public abstract Iterator getMatchingMimeHeaders(String[] names)
检索匹配给定数组中名称的所有 MimeHeader 对象。

参数：
names - 一个 String 数组，带有要返回的 MIME 头的名称
返回：
所有匹配给定数组中任一名称的 MIME 头（Iterator 对象的形式）

getNonMatchingMimeHeaders

public abstract Iterator getNonMatchingMimeHeaders(String[] names)
检索所有名称不匹配给定数组中任一名称的 MimeHeader 对象。

参数：
names - 一个 String 数组，带有无需返回的 MIME 头的名称
返回：
此 AttachmentPart 对象中的所有 MIME 头，但匹配给定数组中任一名称的 MIME 头除外。以 Iterator 对象的形式返回不匹配的 MIME 头。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Detail (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 Detail

所有超级接口：
Element, Node, SOAPElement, SOAPFaultElement
public interface Detail
extends SOAPFaultElement

DetailEntry 对象的容器。DetailEntry 对象给出特定于应用程序的详细错误信息，以及与包含该对象的 SOAPBody 对象相关的详细错误信息。

可以使用方法 SOAPFault.getDetail 来检索 Detail 对象（SOAPFault 对象的一部分）。该 Detail 接口提供两个方法。第一种方法创建一个新 DetailEntry 对象，且自动将其添加到 Detail 对象。第二种方法获取 Detail 对象中包含的 DetailEntry 对象列表。

以下代码片段（其中 sf 是 SOAPFault 对象）获取它的 Detail 对象 (d)，将新的 DetailEntry 对象添加到 d，然后获取 d 中所有 DetailEntry 对象列表。该代码片段还创建要传递给方法 addDetailEntry 的 Name 对象。变量 se（用于创建 Name 对象）是一个 SOAPEnvelope 对象。

Detail d = sf.getDetail();
Name name = se.createName("GetLastTradePrice", "WOMBAT",
"http://www.wombat.org/trader");
d.addDetailEntry(name);
Iterator it = d.getDetailEntries();

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
DetailEntry | addDetailEntry(Name name) 使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
DetailEntry | addDetailEntry(QName qname) 使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
Iterator | getDetailEntries() 获取在此 Detail 对象中所有 DetailEntry 上进行迭代的迭代器。
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

addDetailEntry

DetailEntry addDetailEntry(Name name)
                           throws SOAPException
使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。

参数：
name - 标识新 DetailEntry 对象的 Name 对象
抛出：
SOAPException - 当将 DetailEntry 对象添加到此 Detail 对象过程中存在问题时，抛出该异常。
另请参见：
addDetailEntry(QName qname)

addDetailEntry

DetailEntry addDetailEntry(QName qname)
                           throws SOAPException
使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。与使用 Name 的方法相比，应优先考虑此方法。

参数：
qname - 标识新 DetailEntry 对象的 QName 对象
抛出：
SOAPException - 当将 DetailEntry 对象添加到此 Detail 对象过程中存在问题时，抛出该异常。
从以下版本开始：
SAAJ 1.3
另请参见：
addDetailEntry(Name name)

getDetailEntries

Iterator getDetailEntries()
获取在此 Detail 对象中所有 DetailEntry 上进行迭代的迭代器。

返回：
一个 Iterator 对象，可在此 Detail 对象中的 DetailEntry 对象上进行迭代
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DetailEntry (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 DetailEntry

所有超级接口：
Element, Node, SOAPElement
public interface DetailEntry
extends SOAPElement

Detail 对象的内容，给出 SOAPFault 对象的详细信息。DetailEntry 对象是特定于应用程序的，它携带与包含它的 SOAPBody 对象相关的错误信息。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 MessageFactory

java.lang.Object
    继承者  javax.xml.soap.MessageFactory

public abstract class MessageFactory
extends Object

创建 SOAPMessage 对象的工厂。

SAAJ 客户端可以使用方法 newInstance 创建 MessageFactory 对象，如以下代码行所示。

MessageFactory mf = MessageFactory.newInstance();
MessageFactory mf12 = MessageFactory.newInstance(SOAPConstants.SOAP_1_2_PROTOCOL);

默认情况下，所有 MessageFactory 对象（无论它们是如何创建的）都将生成具有以下元素的 SOAPMessage 对象：

  • 一个 SOAPPart 对象
  • 一个 SOAPEnvelope 对象
  • 一个 SOAPBody 对象
  • 一个 SOAPHeader 对象
在某些情况下，可以获取特殊的 MessageFactory 对象来生成用 SOAPHeader 对象和 SOAPBody 对象中的附加条目预填充的消息。新的 SOAPMessage 对象的内容取决于使用两种 MessageFactory 方法中的哪一种创建该对象。
  • createMessage()
    这是客户端通常用来创建请求消息的方法。
  • createMessage(MimeHeaders, java.io.InputStream) -- 消息的内容取自 InputStream 对象，头取自 MimeHeaders 对象。
    此方法可以供服务实现在内部用来创建响应请求的消息。

构造方法摘要
MessageFactory()
方法摘要
abstract SOAPMessage | createMessage() 使用默认的 SOAPPart、SOAPEnvelope、SOAPBody 和 SOAPHeader 对象创建新的 SOAPMessage 对象。
abstract SOAPMessage | createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
static MessageFactory | newInstance() 创建新的 MessageFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static MessageFactory | newInstance(String protocol) 创建新的 MessageFactory 对象，该对象是指定实现的实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageFactory

public MessageFactory()
方法详细信息

newInstance

public static MessageFactory newInstance()
                                  throws SOAPException
创建新的 MessageFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。 此方法使用以下查找过程顺序来确定要加载的 MessageFactory 实现类：
  • 使用 javax.xml.soap.MessageFactory 系统属性。
  • 使用 JRE 文件夹中的属性文件 "lib/jaxm.properties"。此配置文件格式是标准的 java.util.Properties 格式且包含实现类的完全限定名，其中实现类的键是上文定义的系统属性。
  • 如果 Services API（在 JAR 规范中进行了详细描述）可用，可以使用它来确定类名称。Services API 将查找在运行时可用的 jar 中 META-INF/services/javax.xml.soap.MessageFactory 文件中的类名称。
  • 使用 SAAJMetaFactory 实例来定位 MessageFactory 实现类。

返回：
新的 MessageFactory 实例
抛出：
SOAPException - 如果创建默认的 MessageFactory 实现时存在错误。
另请参见：
SAAJMetaFactory

newInstance

public static MessageFactory newInstance(String protocol)
                                  throws SOAPException
创建新的 MessageFactory 对象，该对象是指定实现的实例。可以是动态消息工厂、SOAP 1.1 消息工厂或 SOAP 1.2 消息工厂。动态消息工厂根据作为 createMessage 方法参数指定的 MIME 头创建消息。此方法使用 SAAJMetaFactory 来定位实现类并创建 MessageFactory 实例。

参数：
protocol - 字符串常量，表示指定消息工厂实现的类。可以是 DYNAMIC_SOAP_PROTOCOL、DEFAULT_SOAP_PROTOCOL（等同于 SOAP_1_1_PROTOCOL）或 SOAP_1_2_PROTOCOL。
返回：
新的 MessageFactory 实例
抛出：
SOAPException - 如果创建指定的 MessageFactory 实例时存在错误。
从以下版本开始：
SAAJ 1.3
另请参见：
SAAJMetaFactory

createMessage

public abstract SOAPMessage createMessage()
                                   throws SOAPException
使用默认的 SOAPPart、SOAPEnvelope、SOAPBody 和 SOAPHeader 对象创建新的 SOAPMessage 对象。特定于配置文件的消息工厂可以选择用特定于配置文件的头预填充 SOAPMessage 对象。

可以向此消息的 SOAPPart 对象添加内容，如果一个只包含 SOAP 部分的消息便已足够，则可以按“原样”发送消息。否则，SOAPMessage 对象需要创建一个或多个 AttachmentPart 对象并将其添加到自身。任何非 XML 格式的内容必须在 AttachmentPart 对象中。

返回：
一个新的 SOAPMessage 对象
抛出：
SOAPException - 如果发生 SOAP 错误
UnsupportedOperationException - 如果此 MessageFactory 实例的协议是 DYNAMIC_SOAP_PROTOCOL

createMessage

public abstract SOAPMessage createMessage(MimeHeaders headers,
                                          InputStream in)
                                   throws IOException,
                                          SOAPException
将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。

参数：
in - 包含消息数据的 InputStream 对象
headers - 用于创建消息的特定于传输的头，使用与传输无关的方式传递给消息
返回：
一个新的 SOAPMessage 对象，包含给定 InputStream 对象的数据
抛出：
IOException - 如果读取输入流的数据时存在错误
SOAPException - 消息无效时抛出
IllegalArgumentException - 如果 MessageFactory 需要一个或多个 MIME 头存在于 headers 参数中，但是它们丢失了。SOAP_1_1_PROTOCOL 或 SOAP_1_2_PROTOCOL 的 MessageFactory 实现不得因此抛出 IllegalArgumentException。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MimeHeader (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 MimeHeader

java.lang.Object
    继承者  javax.xml.soap.MimeHeader

public class MimeHeader
extends Object

存储 MIME 头名称及其值的对象。一个 MimeHeaders 对象中可以包含一个或多个 MimeHeader 对象。

另请参见：
MimeHeaders

构造方法摘要
MimeHeader(String name, String value)
构造使用给定的名称和值初始化的 MimeHeader 对象。
方法摘要
String | getName() 返回此 MimeHeader 对象的名称。
String | getValue() 返回此 MimeHeader 对象的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MimeHeader

public MimeHeader(String name,
                  String value)
构造使用给定的名称和值初始化的 MimeHeader 对象。

参数：
name - 给出头名称的 String
value - 给出头值的 String
方法详细信息

getName

public String getName()
返回此 MimeHeader 对象的名称。

返回：
String 形式的头名称

getValue

public String getValue()
返回此 MimeHeader 对象的值。

返回：
String 形式的头值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MimeHeaders (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 MimeHeaders

java.lang.Object
    继承者  javax.xml.soap.MimeHeaders

public class MimeHeaders
extends Object

MimeHeader 对象的容器，这些对象表示出现在消息的 MIME 部分的 MIME 头。

此类主要在应用程序要根据某些 MIME 头和值来检索特定的附件时使用。该类最有可能由 AttachmentPart 的实现和 SAAJ API 的其他与 MIME 有关的部分使用。

另请参见：
SOAPMessage.getAttachments(), AttachmentPart

构造方法摘要
MimeHeaders()
构造一个用空 Vector 对象初始化的默认 MimeHeaders 对象。
方法摘要
void | addHeader(String name, String value) 将带有指定名称和值的 MimeHeader 对象添加到此 MimeHeaders 对象的头列表。
Iterator | getAllHeaders() 返回此 MimeHeaders 对象中的所有 MimeHeader。
String[] | getHeader(String name) 以 String 对象数组的形式返回指定头的所有值。
Iterator | getMatchingHeaders(String[] names) 返回其名称与给定名称数组中的任一名称匹配的所有 MimeHeader 对象。
Iterator | getNonMatchingHeaders(String[] names) 返回其名称与给定名称数组中的任何名称都不匹配的所有 MimeHeader 对象。
void | removeAllHeaders() 从此 MimeHeaders 对象中移除所有头条目。
void | removeHeader(String name) 移除其名称与给定名称匹配的所有 MimeHeader 对象。
void | setHeader(String name, String value) 将其名称与给定名称匹配的第一个头条目的当前值替换为给定值，如果现有的头名称都不匹配，则添加一个新的头。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MimeHeaders

public MimeHeaders()
构造一个用空 Vector 对象初始化的默认 MimeHeaders 对象。

方法详细信息

getHeader

public String[] getHeader(String name)
以 String 对象数组的形式返回指定头的所有值。

参数：
name - 将返回其值的头的名称
返回：
带有指定头的所有值的 String 数组
另请参见：
setHeader(java.lang.String, java.lang.String)

setHeader

public void setHeader(String name,
                      String value)
将其名称与给定名称匹配的第一个头条目的当前值替换为给定值，如果现有的头名称都不匹配，则添加一个新的头。此方法还移第一个匹配头之后的所有匹配的头。

注意，RFC822 头只能包含 US-ASCII 字符。

参数：
name - 一个 String，带有要搜索的头的名称
value - 一个 String，带有用来替换指定头的当前值的值
抛出：
IllegalArgumentException - 如果设置 MIME 头名称或值时存在问题
另请参见：
getHeader(java.lang.String)

addHeader

public void addHeader(String name,
                      String value)
将带有指定名称和值的 MimeHeader 对象添加到此 MimeHeaders 对象的头列表。

注意，RFC822 头只能包含 US-ASCII 字符。

参数：
name - 一个 String，带有要添加的头的名称
value - 一个 String，带有要添加的头的值
抛出：
IllegalArgumentException - 如果添加 MIME 头名称或值时存在问题

removeHeader

public void removeHeader(String name)
移除其名称与给定名称匹配的所有 MimeHeader 对象。

参数：
name - 一个 String，带有要搜索的头名称

removeAllHeaders

public void removeAllHeaders()
从此 MimeHeaders 对象中移除所有头条目。

getAllHeaders

public Iterator getAllHeaders()
返回此 MimeHeaders 对象中的所有 MimeHeader。

返回：
一个 Iterator 对象，可在此 MimeHeaders 对象的 MimeHeader 对象列表上进行迭代

getMatchingHeaders

public Iterator getMatchingHeaders(String[] names)
返回其名称与给定名称数组中的任一名称匹配的所有 MimeHeader 对象。

参数：
names - 带有要搜索的名称的 String 对象数组
返回：
一个 Iterator 对象，可在其名称与给定列表中的任一名称匹配的 MimeHeader 对象上进行迭代

getNonMatchingHeaders

public Iterator getNonMatchingHeaders(String[] names)
返回其名称与给定名称数组中的任何名称都不匹配的所有 MimeHeader 对象。

参数：
names - 带有要搜索的名称的 String 对象数组
返回：
一个 Iterator 对象，可在其名称与给定列表中的任何名称都不匹配的 MimeHeader 对象上进行迭代
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Name (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 Name

public interface Name

XML 名称的表示形式。此接口提供的方法可获取本地和限定于命名空间的名称，以及与名称的命名空间关联的前缀。它还能够获取命名空间的 URI。

以下是一个元素中命名空间声明的示例。

<wombat:GetLastTradePrice xmlns:wombat="http://www.wombat.org/trader">
（"xmlns" 代表 "XML namespace"。）下文显示了 Name 接口中的方法将返回的内容。
  • getQualifiedName 将返回 "prefix:LocalName" = "WOMBAT:GetLastTradePrice"
  • getURI 将返回 "http://www.wombat.org/trader"
  • getLocalName 将返回 "GetLastTracePrice"
  • getPrefix 将返回 "WOMBAT"

XML 命名空间用于辨别 SOAP 标识符与特定于应用程序的标识符。

Name 对象是使用方法 SOAPEnvelope.createName 创建的，该方法有两种形式。一种方法创建带有本地名称、命名空间前缀和命名空间 URI 的 Name 对象，另一种方法创建只带有本地名称的 Name 对象。以下代码行（其中 se 是一个 SOAPEnvelope 对象）创建带有所有三个元素的新 Name 对象。

Name name = se.createName("GetLastTradePrice", "WOMBAT",
"http://www.wombat.org/trader");
以下代码行给出一个如何使用对象 Name 的示例。变量 element 是一个 SOAPElement 对象。此代码创建带有给定名称的新 SOAPElement 对象并将其添加到 element。
element.addChildElement(name);

Name 接口在将来的 SAAJ 版本中可能会被废弃，并被 javax.xml.namespace.QName 取代。

另请参见：
SOAPEnvelope.createName, SOAPFactory.createName

方法摘要
String | getLocalName() 获取此 Name 对象表示的 XML 名称的本地名称部分。
String | getPrefix() 返回初始化此 Name 对象时指定的前缀。
String | getQualifiedName() 获取此 Name 对象表示的 XML 名称限定于命名空间的名称。
String | getURI() 返回此 Name 对象表示的 XML 名称命名空间的 URI。

方法详细信息

getLocalName

String getLocalName()
获取此 Name 对象表示的 XML 名称的本地名称部分。

返回：
给出本地名称的字符串

getQualifiedName

String getQualifiedName()
获取此 Name 对象表示的 XML 名称限定于命名空间的名称。

返回：
字符串形式的限定于命名空间的名称。

getPrefix

String getPrefix()
返回初始化此 Name 对象时指定的前缀。此前缀与此 Name 对象表示的 XML 名称的命名空间关联。

返回：
字符串形式的数据

getURI

String getURI()
返回此 Name 对象表示的 XML 名称命名空间的 URI。

返回：
字符串形式的 URI
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Node (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 Node

所有超级接口：
Node
所有已知子接口：
Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text
public interface Node
extends Node

XML 文档中节点（元素）的表示形式。此接口扩展了标准的 DOM Node 接口，具有一些能获取和设置节点值、获取和设置父节点、移除节点的方法。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
void | detachNode() 从树中移除此 Node 对象。
SOAPElement | getParentElement() 返回此 Node 对象的父元素。
String | getValue() 如果这是一个 Text 节点，则返回此节点的值，否则返回此节点的直接子节点值。
void | recycleNode() 通知实现此 Node 对象不再由应用程序使用，对于以后可能创建的节点，实现可以随意重用此对象。
void | setParentElement(SOAPElement parent) 将此 Node 对象的父节点设置为给定的 SOAPElement 对象。
void | setValue(String value) 如果这是一个 Text 节点，则此方法会设置它的值，否则该方法设置此节点的直接 (Text) 子节点值。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getValue

String getValue()
如果这是一个 Text 节点，则返回此节点的值，否则返回此节点的直接子节点值。如果此 Node 有一个直接子节点是 Text 节点，则返回该直接子节点的值。如果存在一个以上的 Text 节点，则返回第一个 Text 节点的值。否则返回 null。

返回：
如果此节点是一个 Text 节点或该文本由此 Node 对象（该对象是一个 Text 对象）的第一个直接子节点（如果这种子节点存在）包含，则返回带有此节点文本的 String；否则返回 null。

setValue

void setValue(String value)
如果这是一个 Text 节点，则此方法会设置它的值，否则该方法设置此节点的直接 (Text) 子节点值。仅当存在子节点且该节点是 Text 节点时，才能设置此节点的直接子节点值，如果没有子节点，则将创建 Text 子节点。

抛出：
IllegalStateException - 如果该节点不是 Text 节点，也没有子节点或者有一个子节点但不是 Text 节点。
从以下版本开始：
SAAJ 1.2

setParentElement

void setParentElement(SOAPElement parent)
                      throws SOAPException
将此 Node 对象的父节点设置为给定的 SOAPElement 对象。

参数：
parent - 要设置为此 Node 对象父节点的 SOAPElement 对象
抛出：
SOAPException - 如果将父节点设置为给定元素时出现错误
另请参见：
getParentElement()

getParentElement

SOAPElement getParentElement()
返回此 Node 对象的父元素。如果树没有存入内存，则此方法抛出 UnsupportedOperationException。

返回：
此 Node 对象的父节点 SOAPElement 对象；如果此 Node 对象为根节点，则返回 null
抛出：
UnsupportedOperationException - 如果整个树没有存入内存
另请参见：
setParentElement(javax.xml.soap.SOAPElement)

detachNode

void detachNode()
从树中移除此 Node 对象。

recycleNode

void recycleNode()
通知实现此 Node 对象不再由应用程序使用，对于以后可能创建的节点，实现可以随意重用此对象。

调用 recycleNode 方法意味着以前调用过 detachNode 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAAJMetaFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SAAJMetaFactory

java.lang.Object
    继承者  javax.xml.soap.SAAJMetaFactory

public abstract class SAAJMetaFactory
extends Object

SAAJ API 中定义的工厂实现类的访问点。SAAJ 1.3 中的工厂上定义的所有 newInstance 方法都要此类实例来创建实际对象。当 SAAJ 1.2 定义的查询无法定位 Factory 实现类名称时，存在于 SAAJ 1.2 中的 newInstance() 方法（SOAPFactory 和 MessageFactory 中）的实现被更新为（并委派给）SAAJMetaFactory。

SAAJMetaFactory 是一个服务提供者接口。在此类上没有 public 方法。

从以下版本开始：
SAAJ 1.3

构造方法摘要
protected SAAJMetaFactory()
方法摘要
protected abstract MessageFactory | newMessageFactory(String protocol) 创建给定 String 协议的 MessageFactory 对象。
protected abstract SOAPFactory | newSOAPFactory(String protocol) 创建给定 String 协议的 SOAPFactory 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SAAJMetaFactory

protected SAAJMetaFactory()
方法详细信息

newMessageFactory

protected abstract MessageFactory newMessageFactory(String protocol)
                                             throws SOAPException
创建给定 String 协议的 MessageFactory 对象。

参数：
protocol - 指示该协议的 String
抛出：
SOAPException - 如果在创建 MessageFactory 时出现错误
另请参见：
SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL

newSOAPFactory

protected abstract SOAPFactory newSOAPFactory(String protocol)
                                       throws SOAPException
创建给定 String 协议的 SOAPFactory 对象。

参数：
protocol - 指示该协议的 String
抛出：
SOAPException - 如果在创建 SOAPFactory 时出现错误
另请参见：
SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAAJResult (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SAAJResult

java.lang.Object
    继承者  javax.xml.transform.dom.DOMResult
        继承者  javax.xml.soap.SAAJResult
所有已实现的接口：
Result
public class SAAJResult
extends DOMResult

以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。这些结果应通过使用 getResult() 方法访问。几乎在所有情况下，都应避免使用 DOMResult.getNode() 方法。

从以下版本开始：
SAAJ 1.3

字段摘要
从类 javax.xml.transform.dom.DOMResult 继承的字段
FEATURE
从接口 javax.xml.transform.Result 继承的字段
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
构造方法摘要
SAAJResult()
创建一个 SAAJResult，此类将以支持默认 (SOAP 1.1) 协议的 SAAJ 树的形式显示结果。
SAAJResult(SOAPElement rootNode)
创建一个 SAAJResult，它会将结果编写为指定 SOAPElement 的子节点。
SAAJResult(SOAPMessage message)
创建一个 SAAJResult，它会将结果写入提供的 SOAPMessage 的 SOAPPart 中。
SAAJResult(String protocol)
创建一个 SAAJResult，它将以支持指定协议的 SAAJ 树的形式显示结果。
方法摘要
 Node getResult()
从类 javax.xml.transform.dom.DOMResult 继承的方法
getNextSibling, getNode, getSystemId, setNextSibling, setNode, setSystemId
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SAAJResult

public SAAJResult()
           throws SOAPException
创建一个 SAAJResult，此类将以支持默认 (SOAP 1.1) 协议的 SAAJ 树的形式显示结果。

这种 SAAJResult 用在结果将被用作方法参数的情况下，其中的方法指带有其类型（如 SOAPElement）取自 SAAJ API 的方法。当用于转换时，结果被填充到内部创建的 SOAPMessage 的 SOAPPart 中。由 DOMResult.getNode() 返回的 SOAPPart 不能保证格式良好。

抛出：
SOAPException - 如果在创建 SOAPMessage 时出现问题
从以下版本开始：
SAAJ 1.3

SAAJResult

public SAAJResult(String protocol)
           throws SOAPException
创建一个 SAAJResult，它将以支持指定协议的 SAAJ 树的形式显示结果。DYNAMIC_SOAP_PROTOCOL 在此上下文中不明确，并会导致此构造方法抛出 UnsupportedOperationException。

这种 SAAJResult 用在结果将被用作方法参数的情况下，其中的方法指带有其类型（如 SOAPElement）取自 SAAJ API 的方法。当用于转换时，结果被填充到内部创建的 SOAPMessage 的 SOAPPart 中。由 DOMResult.getNode() 返回的 SOAPPart 不能保证格式良好。

参数：
protocol - 所得 SAAJ 树应支持的 SOAP 协议的名称
抛出：
SOAPException - 如果无法创建支持指定协议的 SOAPMessage
从以下版本开始：
SAAJ 1.3

SAAJResult

public SAAJResult(SOAPMessage message)
创建一个 SAAJResult，它会将结果写入提供的 SOAPMessage 的 SOAPPart 中。在正常情况下，将使用 DOM API 编写这些结果，因此，如果用来创建 SOAPPart 的数据不是格式良好的，则不保证完成的 SOAPPart 格式良好。当在转换中使用时，转换之后 SOAPMessage 的有效性只有通过 SAAJ 规范之外的方式才能得到保证。

参数：
message - 消息，该消息的 SOAPPart 将会由于某些转换或编组操作而被填充
从以下版本开始：
SAAJ 1.3

SAAJResult

public SAAJResult(SOAPElement rootNode)
创建一个 SAAJResult，它会将结果编写为指定 SOAPElement 的子节点。在正常情况下，将使用 DOM API 编写这些结果，因此可能使 SAAJ 树结构无效。只有在传入数据的有效性可以通过 SAAJ 规范之外的方式得到保证的情况下，才使用这种 SAAJResult。

参数：
rootNode - 将追加结果的根节点
从以下版本开始：
SAAJ 1.3
方法详细信息

getResult

public Node getResult()
返回：
在指定根 Node 下创建的结果 Tree。
从以下版本开始：
SAAJ 1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPBody (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPBody

所有超级接口：
Element, Node, SOAPElement
public interface SOAPBody
extends SOAPElement

表示 SOAP 消息中 SOAP 正文元素内容的对象。SOAP 正文元素由能影响特定于应用程序内容的处理方式的 XML 数据组成。

SOAPBody 对象包含了 SOAPBodyElement 对象，后者具有 SOAP 正文的内容。携带状态和/或错误信息的 SOAPFault 对象是 SOAPBodyElement 对象的一个示例。

另请参见：
SOAPFault

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
SOAPBodyElement | addBodyElement(Name name) 使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
SOAPBodyElement | addBodyElement(QName qname) 使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
SOAPBodyElement | addDocument(Document document) 将 DOM Document 的根节点添加到此 SOAPBody 对象。
SOAPFault | addFault() 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | addFault(Name faultCode, String faultString) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | addFault(Name faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | addFault(QName faultCode, String faultString) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | addFault(QName faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
Document | extractContentAsDocument() 创建新的 DOM Document，并将此 SOAPBody 的第一个子元素设置为它的文档元素。
SOAPFault | getFault() 返回此 SOAPBody 对象中的 SOAPFault 对象。
boolean | hasFault() 指示此 SOAPBody 对象中是否存在 SOAPFault 对象。
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

addFault

SOAPFault addFault()
                   throws SOAPException
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。新的 SOAPFault 会将强制性 (mandatory) 子元素设置为默认值。SOAPFault 的类型可以是 SOAP 1.1 或 SOAP 1.2 SOAPFault，这取决于创建 MessageFactory 实例时指定的 protocol。

一个 SOAPBody 最多只能包含一个 SOAPFault 子元素。

返回：
新的 SOAPFault 对象
抛出：
SOAPException - 如果存在 SOAP 错误

addFault

SOAPFault addFault(Name faultCode,
                   String faultString,
                   Locale locale)
                   throws SOAPException
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。SOAPFault 的类型可以是 SOAP 1.1 或 SOAP 1.2 SOAPFault，这取决于创建 MessageFactory 实例时指定的 protocol。

对于 SOAP 1.2，faultCode 参数是 Fault/Code/Value 元素的值，faultString 参数是 Fault/Reason/Text 元素的值。对于 SOAP 1.1，faultCode 参数是 faultcode 元素的值，faultString 参数是 faultstring 元素的值。

一个 SOAPBody 最多只能包含一个 SOAPFault 子元素。

参数：
faultCode - Name 对象，给出要设置的错误代码；必须是正使用的 SOAP 规范的版本中定义的错误代码之一
faultString - String，给出错误的解释
locale - Locale 对象，指示 faultString 的本地语言
返回：
新的 SOAPFault 对象
抛出：
SOAPException - 如果存在 SOAP 错误
从以下版本开始：
SAAJ 1.2
另请参见：
SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

addFault

SOAPFault addFault(QName faultCode,
                   String faultString,
                   Locale locale)
                   throws SOAPException
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。SOAPFault 的类型可以是 SOAP 1.1 或 SOAP 1.2 SOAPFault，这取决于创建 MessageFactory 实例时指定的 protocol。

对于 SOAP 1.2，faultCode 参数是 Fault/Code/Value 元素的值，faultString 参数是 Fault/Reason/Text 元素的值。对于 SOAP 1.1，faultCode 参数是 faultcode 元素的值，faultString 参数是 faultstring 元素的值。

一个 SOAPBody 最多只能包含一个 SOAPFault 子元素。

参数：
faultCode - QName 对象，给出要设置的错误代码；必须是正使用的 SOAP 规范的版本中定义的错误代码之一。
faultString - String，给出错误的解释
locale - Locale 对象，指示 faultString 的本地语言
返回：
新的 SOAPFault 对象
抛出：
SOAPException - 如果存在 SOAP 错误
从以下版本开始：
SAAJ 1.3
另请参见：
SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString, Locale locale)

addFault

SOAPFault addFault(Name faultCode,
                   String faultString)
                   throws SOAPException
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。SOAPFault 的类型可以是 SOAP 1.1 或 SOAP 1.2 SOAPFault，这取决于创建 MessageFactory 实例时指定的 protocol。

对于 SOAP 1.2，faultCode 参数是 Fault/Code/Value 元素的值，faultString 参数是 Fault/Reason/Text 元素的值。对于 SOAP 1.1，faultCode 参数是 faultcode 元素的值，faultString 参数是 faultstring 元素的值。

如果是 SOAP 1.2 错误，Fault/Reason/Text 元素上强制性 xml:lang 属性的默认值将设置为 java.util.Locale.getDefault()

一个 SOAPBody 最多只能包含一个 SOAPFault 子元素。

参数：
faultCode - Name 对象，给出要设置的错误代码；必须是正使用的 SOAP 规范的版本中定义的错误代码之一
faultString - String，给出错误的解释
返回：
新的 SOAPFault 对象
抛出：
SOAPException - 如果存在 SOAP 错误
从以下版本开始：
SAAJ 1.2
另请参见：
SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

addFault

SOAPFault addFault(QName faultCode,
                   String faultString)
                   throws SOAPException
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。SOAPFault 的类型可以是 SOAP 1.1 或 SOAP 1.2 SOAPFault，这取决于创建 MessageFactory 实例时指定的 protocol。

对于 SOAP 1.2，faultCode 参数是 Fault/Code/Value 元素的值，faultString 参数是 Fault/Reason/Text 元素的值。对于 SOAP 1.1，faultCode 参数是 faultcode 元素的值，faultString 参数是 faultstring 元素的值。

如果是 SOAP 1.2 错误，Fault/Reason/Text 元素上强制性 xml:lang 属性的默认值将设置为 java.util.Locale.getDefault()

一个 SOAPBody 最多只能包含一个 SOAPFault 子元素

参数：
faultCode - QName 对象，给出要设置的错误代码；必须是正使用的 SOAP 规范的版本中定义的错误代码之一
faultString - String，给出错误的解释
返回：
新的 SOAPFault 对象
抛出：
SOAPException - 如果存在 SOAP 错误
从以下版本开始：
SAAJ 1.3
另请参见：
SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString)

hasFault

boolean hasFault()
指示此 SOAPBody 对象中是否存在 SOAPFault 对象。

返回：
如果此 SOAPBody 对象中存在 SOAPFault 对象，则返回 true；否则返回 false

getFault

SOAPFault getFault()
返回此 SOAPBody 对象中的 SOAPFault 对象。

返回：
此 SOAPBody 对象中的 SOAPFault 对象（如果存在）；若不存在，则返回 null。

addBodyElement

SOAPBodyElement addBodyElement(Name name)
                               throws SOAPException
使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。

参数：
name - Name 对象，带有新 SOAPBodyElement 对象的名称
返回：
新的 SOAPBodyElement 对象
抛出：
SOAPException - 如果发生 SOAP 错误
另请参见：
addBodyElement(javax.xml.namespace.QName)

addBodyElement

SOAPBodyElement addBodyElement(QName qname)
                               throws SOAPException
使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。

参数：
qname - QName 对象，带有新 SOAPBodyElement 对象的名称
返回：
新的 SOAPBodyElement 对象
抛出：
SOAPException - 如果发生 SOAP 错误
从以下版本开始：
SAAJ 1.3
另请参见：
addBodyElement(Name)

addDocument

SOAPBodyElement addDocument(Document document)
                            throws SOAPException
将 DOM Document 的根节点添加到此 SOAPBody 对象。

调用此方法会使 document 参数失效。在调用 addDocument 时，客户端应用程序应丢弃所有对此 Document 及其内容的引用。继续使用此类引用的应用程序将产生不确定的行为。

参数：
document - Document 对象，该对象的根节点将被添加到此 SOAPBody。
返回：
表示被添加根节点的 SOAPBodyElement。
抛出：
SOAPException - 如果无法添加 Document
从以下版本开始：
SAAJ 1.2

extractContentAsDocument

Document extractContentAsDocument()
                                  throws SOAPException
创建新的 DOM Document，并将此 SOAPBody 的第一个子元素设置为它的文档元素。子 SOAPElement 作为进程的一部分被移除。

返回：
SOAPBody 内容的 Document 表示形式。
抛出：
SOAPException - 如果不存在任何 SOAPBody 的子 SOAPElement。
从以下版本开始：
SAAJ 1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPBodyElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPBodyElement

所有超级接口：
Element, Node, SOAPElement
所有已知子接口：
SOAPFault
public interface SOAPBodyElement
extends SOAPElement

表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。SOAPFault 接口是一个已经定义的 SOAPBodyElement 对象。

可以创建新的 SOAPBodyElement 对象，并使用 SOAPBody 的 addBodyElement 方法将其添加到 SOAPBody 对象。在以下代码行中，sb 是一个 SOAPBody 对象，myName 是一个 Name 对象。

SOAPBodyElement sbe = sb.addBodyElement(myName);

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPConnection (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SOAPConnection

java.lang.Object
    继承者  javax.xml.soap.SOAPConnection

public abstract class SOAPConnection
extends Object

客户端可以用于直接将消息发送到（例如，用 URL 表示的）远程方的点对点连接。

SOAPConnection 类是可选的。某些实现可能无法实现此接口，在这种情况下，调用 SOAPConnectionFactory.newInstance()（参见以下内容）将抛出 UnsupportedOperationException。

客户端可以使用 SOAPConnectionFactory 对象获取 SOAPConnection 对象，如下例所示：

SOAPConnectionFactory factory = SOAPConnectionFactory.newInstance();
SOAPConnection con = factory.createConnection();
SOAPConnection 对象可用来将消息直接发送到请求/响应范例后面的 URL。也就是说，使用方法 call 来发送消息，该方法发送消息并等到收到应答为止。

构造方法摘要
SOAPConnection()
方法摘要
abstract SOAPMessage | call(SOAPMessage request, Object to) 将给定消息发送到指定端点，在返回应答前将一直阻塞。
abstract void | close() 关闭此 SOAPConnection 对象。
SOAPMessage | get(Object to) 从特定端点获取消息，在收到消息前将一直阻塞。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SOAPConnection

public SOAPConnection()
方法详细信息

call

public abstract SOAPMessage call(SOAPMessage request,
                                 Object to)
                          throws SOAPException
将给定消息发送到指定端点，在返回应答前将一直阻塞。

参数：
request - 要发送的 SOAPMessage 对象
to - 标识消息发送目的地的 Object。必须支持 java.lang.String、java.net.URL，以及 javax.xml.messaging.URLEndpoint 类型（JAXM 存在时）的 Object。
返回：
响应已发送消息的 SOAPMessage 对象
抛出：
SOAPException - 如果存在 SOAP 错误

get

public SOAPMessage get(Object to)
                throws SOAPException
从特定端点获取消息，在收到消息前将一直阻塞。

参数：
to - 标识请求发送目的地的 Object。必须支持 java.lang.String 和 java.net.URL 类型的 Object。
返回：
响应获取消息请求的 SOAPMessage 对象
抛出：
SOAPException - 如果存在 SOAP 错误
从以下版本开始：
SAAJ 1.3

close

public abstract void close()
                    throws SOAPException
关闭此 SOAPConnection 对象。

抛出：
SOAPException - 如果存在 SOAP 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPConnectionFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SOAPConnectionFactory

java.lang.Object
    继承者  javax.xml.soap.SOAPConnectionFactory

public abstract class SOAPConnectionFactory
extends Object

创建 SOAPConnection 对象的工厂。此类的实现是可选的。如果 SOAPConnectionFactory.newInstance() 抛出 UnsupportedOperationException，则该实现不支持 SAAJ 通信基础设施。否则，可以通过在新创建的 SOAPConnectionFactory 对象上调用 createConnection() 来创建 SOAPConnection 对象。

构造方法摘要
SOAPConnectionFactory()
方法摘要
abstract SOAPConnection | createConnection() 创建新的 SOAPConnection。
static SOAPConnectionFactory | newInstance() 创建默认 SOAPConnectionFactory 对象的实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SOAPConnectionFactory

public SOAPConnectionFactory()
方法详细信息

newInstance

public static SOAPConnectionFactory newInstance()
                                         throws SOAPException,
                                                UnsupportedOperationException
创建默认 SOAPConnectionFactory 对象的实例。

返回：
默认 SOAPConnectionFactory 对象的新实例
抛出：
SOAPException - 如果在创建 SOAPConnectionFactory 时出现问题
UnsupportedOperationException - 如果不支持新实例。

createConnection

public abstract SOAPConnection createConnection()
                                         throws SOAPException
创建新的 SOAPConnection。

返回：
新的 SOAPConnection 对象。
抛出：
SOAPException - 如果在创建 SOAPConnection 时出现异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPConstants

public interface SOAPConstants

与 SOAP 协议有关的常量的定义。

字段摘要
static String | DEFAULT_SOAP_PROTOCOL 默认协议：向后兼容的 SOAP 1.1。
static String | DYNAMIC_SOAP_PROTOCOL 用于创建 MessageFactory 实例，该实例可创建 SOAPMessages，SOAPMessages 的具体类型取决于传递给 createMessage 方法的 Content-Type MIME 头。
static String | SOAP_1_1_CONTENT_TYPE SOAP 1.1 中 Content-Type MIME 头的媒体类型。
static String | SOAP_1_1_PROTOCOL 用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.1 规范的 SOAPMessages。
static String | SOAP_1_2_CONTENT_TYPE SOAP 1.2 中 Content-Type MIME 头的媒体类型。
static String | SOAP_1_2_PROTOCOL 用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.2 规范的 SOAPMessages
static QName | SOAP_DATAENCODINGUNKNOWN_FAULT SOAP 1.2 DataEncodingUnknown 错误。
static String | SOAP_ENV_PREFIX http://www.w3.org/2003/05/soap-envelope 的默认名称空间前缀。
static QName | SOAP_MUSTUNDERSTAND_FAULT SOAP 1.2 MustUnderstand 错误。
static QName | SOAP_RECEIVER_FAULT SOAP 1.2 Receiver 错误。
static QName | SOAP_SENDER_FAULT SOAP 1.2 Sender 错误。
static QName | SOAP_VERSIONMISMATCH_FAULT SOAP 1.2 VersionMismatch 错误。
static String | URI_NS_SOAP_1_1_ENVELOPE SOAP 1.1 信封的名称空间标识符。
static String | URI_NS_SOAP_1_2_ENCODING SOAP 1.2 编码的名称空间标识符。
static String | URI_NS_SOAP_1_2_ENVELOPE SOAP 1.2 信封的名称空间标识符。
static String | URI_NS_SOAP_ENCODING SOAP 1.1 编码的名称空间标识符。
static String | URI_NS_SOAP_ENVELOPE SOAP 1.1 信封的名称空间标识符，此名称空间中的所有 SOAPElements 是由 SOAP 1.1 规范定义的。
static String | URI_SOAP_1_2_ROLE_NEXT 该 URI 标识将 SOAP 请求处理为 SOAP 1.2 头条目预定角色 (intended role) 的下一个应用程序（请参阅 SOAP 1.2 规范第 1 部分第 2.2 节）。
static String | URI_SOAP_1_2_ROLE_NONE 该 URI 指定 SOAP 1.2 中的角色 None。
static String | URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER 该 URI 标识 SOAP 1.2 消息的最终接收者。
static String | URI_SOAP_ACTOR_NEXT 该 URI 标识将 SOAP 请求处理为 SOAP 1.1 头条目预定参与者的下一个应用程序（请参阅 SOAP 1.1 规范的第 4.2.2 节）。

字段详细信息

DYNAMIC_SOAP_PROTOCOL

static final String DYNAMIC_SOAP_PROTOCOL
用于创建 MessageFactory 实例，该实例可创建 SOAPMessages，SOAPMessages 的具体类型取决于传递给 createMessage 方法的 Content-Type MIME 头。如果没有传递 Content-Type 头，那么 createMessage 可能抛出 IllegalArgumentException，如果是不带参数的 createMessage 方法，则抛出 UnsupportedOperationException。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

SOAP_1_1_PROTOCOL

static final String SOAP_1_1_PROTOCOL
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.1 规范的 SOAPMessages。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

SOAP_1_2_PROTOCOL

static final String SOAP_1_2_PROTOCOL
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.2 规范的 SOAPMessages

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

DEFAULT_SOAP_PROTOCOL

static final String DEFAULT_SOAP_PROTOCOL
默认协议：向后兼容的 SOAP 1.1。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

URI_NS_SOAP_1_1_ENVELOPE

static final String URI_NS_SOAP_1_1_ENVELOPE
SOAP 1.1 信封的名称空间标识符。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

URI_NS_SOAP_1_2_ENVELOPE

static final String URI_NS_SOAP_1_2_ENVELOPE
SOAP 1.2 信封的名称空间标识符。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

URI_NS_SOAP_ENVELOPE

static final String URI_NS_SOAP_ENVELOPE
SOAP 1.1 信封的名称空间标识符，此名称空间中的所有 SOAPElements 是由 SOAP 1.1 规范定义的。

另请参见：
常量字段值

URI_NS_SOAP_ENCODING

static final String URI_NS_SOAP_ENCODING
SOAP 1.1 编码的名称空间标识符。URI_NS_SOAP_ENVELOPE 名称空间中命名为 encodingStyle 并且值被设置为 URI_NS_SOAP_ENCODING 的属性可以添加到某一元素，以指示该元素是使用 SOAP 1.1 规范第 5 节中的规则编码的。

另请参见：
常量字段值

URI_NS_SOAP_1_2_ENCODING

static final String URI_NS_SOAP_1_2_ENCODING
SOAP 1.2 编码的名称空间标识符。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

SOAP_1_1_CONTENT_TYPE

static final String SOAP_1_1_CONTENT_TYPE
SOAP 1.1 中 Content-Type MIME 头的媒体类型。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

SOAP_1_2_CONTENT_TYPE

static final String SOAP_1_2_CONTENT_TYPE
SOAP 1.2 中 Content-Type MIME 头的媒体类型。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

URI_SOAP_ACTOR_NEXT

static final String URI_SOAP_ACTOR_NEXT
该 URI 标识将 SOAP 请求处理为 SOAP 1.1 头条目预定参与者的下一个应用程序（请参阅 SOAP 1.1 规范的第 4.2.2 节）。

此值可以传递给 SOAPHeader.examineMustUnderstandHeaderElements(String)、SOAPHeader.examineHeaderElements(String) 和 SOAPHeader.extractHeaderElements(String)

另请参见：
常量字段值

URI_SOAP_1_2_ROLE_NEXT

static final String URI_SOAP_1_2_ROLE_NEXT
该 URI 标识将 SOAP 请求处理为 SOAP 1.2 头条目预定角色 (intended role) 的下一个应用程序（请参阅 SOAP 1.2 规范第 1 部分第 2.2 节）。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

URI_SOAP_1_2_ROLE_NONE

static final String URI_SOAP_1_2_ROLE_NONE
该 URI 指定 SOAP 1.2 中的角色 None。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER

static final String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
该 URI 标识 SOAP 1.2 消息的最终接收者。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

SOAP_ENV_PREFIX

static final String SOAP_ENV_PREFIX
http://www.w3.org/2003/05/soap-envelope 的默认名称空间前缀。

从以下版本开始：
SAAJ 1.3
另请参见：
常量字段值

SOAP_VERSIONMISMATCH_FAULT

static final QName SOAP_VERSIONMISMATCH_FAULT
SOAP 1.2 VersionMismatch 错误。

从以下版本开始：
SAAJ 1.3

SOAP_MUSTUNDERSTAND_FAULT

static final QName SOAP_MUSTUNDERSTAND_FAULT
SOAP 1.2 MustUnderstand 错误。

从以下版本开始：
SAAJ 1.3

SOAP_DATAENCODINGUNKNOWN_FAULT

static final QName SOAP_DATAENCODINGUNKNOWN_FAULT
SOAP 1.2 DataEncodingUnknown 错误。

从以下版本开始：
SAAJ 1.3

SOAP_SENDER_FAULT

static final QName SOAP_SENDER_FAULT
SOAP 1.2 Sender 错误。

从以下版本开始：
SAAJ 1.3

SOAP_RECEIVER_FAULT

static final QName SOAP_RECEIVER_FAULT
SOAP 1.2 Receiver 错误。

从以下版本开始：
SAAJ 1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPElement

所有超级接口：
Element, Node
所有已知子接口：
Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement
public interface SOAPElement
extends Node, Element

表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。此接口充当 SOAP 规范特别规定的那些对象的基本接口。

此接口中要求返回特定于 SAAJ 的对象的那些方法可以“安静地”替换树中的节点，以便按要求成功返回正确类型的对象。有关详细信息，请参见 getChildElements() 和 javax.xml.soap。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
SOAPElement | addAttribute(Name name, String value) 将带有指定名称和值的属性添加到此 SOAPElement 对象。
SOAPElement | addAttribute(QName qname, String value) 将带有指定名称和值的属性添加到此 SOAPElement 对象。
SOAPElement | addChildElement(Name name) 创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
SOAPElement | addChildElement(QName qname) 创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
SOAPElement | addChildElement(SOAPElement element) 将 SOAPElement 作为此 SOAPElement 实例的子级添加。
SOAPElement | addChildElement(String localName) 创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
SOAPElement | addChildElement(String localName, String prefix) 创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
SOAPElement | addChildElement(String localName, String prefix, String uri) 创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
SOAPElement | addNamespaceDeclaration(String prefix, String uri) 将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。
SOAPElement | addTextNode(String text) 创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。
QName | createQName(String localName, String prefix) 创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。
Iterator | getAllAttributes() 返回可在此 SOAPElement 对象中所有属性 Name 对象上进行迭代的 Iterator。
Iterator | getAllAttributesAsQNames() 返回可在此 SOAPElement 对象（以 QName 对象的形式）中的所有属性上进行迭代的 Iterator。
String | getAttributeValue(Name name) 返回带有指定名称的属性值。
String | getAttributeValue(QName qname) 返回带有指定 qname 的属性值。
Iterator | getChildElements() 返回可在此元素的所有直接子 Node 上进行迭代的 Iterator。
Iterator | getChildElements(Name name) 返回可在带有指定名称的此元素所有直接子 Node 上进行迭代的 Iterator。
Iterator | getChildElements(QName qname) 返回可在带有指定 qname 的此元素所有直接子 Node 上进行迭代的 Iterator。
Name | getElementName() 返回此 SOAPElement 对象的名称。
QName | getElementQName() 返回此 SOAPElement 对象的 qname。
String | getEncodingStyle() 返回此 SOAPElement 对象的编码样式。
Iterator | getNamespacePrefixes() 返回可在此元素声明的名称空间前缀 String 上进行迭代的 Iterator。
String | getNamespaceURI(String prefix) 返回带有给定前缀的名称空间的 URI。
Iterator | getVisibleNamespacePrefixes() 返回在此元素可见的名称空间前缀 String 上进行迭代的 Iterator。
boolean | removeAttribute(Name name) 移除带有指定名称的属性。
boolean | removeAttribute(QName qname) 移除带有指定 qname 的属性。
void | removeContents() 分离此 SOAPElement 的所有子级。
boolean | removeNamespaceDeclaration(String prefix) 移除对应于给定前缀的名称空间声明。
SOAPElement | setElementQName(QName newName) 如果可能，将此 Element 的名称更改为 newName。
void | setEncodingStyle(String encodingStyle) 将此 SOAPElement 对象的编码样式设置为指定样式。
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

addChildElement

SOAPElement addChildElement(Name name)
                            throws SOAPException
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

此方法在以后的 SAAJ 版本中可能会被废弃，并用 addChildElement(javax.xml.namespace.QName) 取代。

参数：
name - Name 对象，带有新元素的 XML 名称
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时发生错误
另请参见：
addChildElement(javax.xml.namespace.QName)

addChildElement

SOAPElement addChildElement(QName qname)
                            throws SOAPException
创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。新 SOAPElement 的 namespace、localname 和 prefix 都取自 qname 参数。

参数：
qname - QName 对象，带有新元素的 XML 名称
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时发生错误
从以下版本开始：
SAAJ 1.3
另请参见：
addChildElement(Name)

addChildElement

SOAPElement addChildElement(String localName)
                            throws SOAPException
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。新的 SOAPElement 继承任何作用域内的默认名称空间。

参数：
localName - 给出元素本地名称的 String
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时发生错误

addChildElement

SOAPElement addChildElement(String localName,
                            String prefix)
                            throws SOAPException
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

参数：
localName - 给出新元素本地名称的 String
prefix - 给出新元素名称空间前缀的 String
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果 prefix 在此 SOAPElement 上下文中无效，或者在创建 SOAPElement 对象时发生错误

addChildElement

SOAPElement addChildElement(String localName,
                            String prefix,
                            String uri)
                            throws SOAPException
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

参数：
localName - 给出新元素本地名称的 String
prefix - 给出新元素名称空间前缀的 String
uri - 给出新元素所属空间名称 URI 的 String
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时发生错误

addChildElement

SOAPElement addChildElement(SOAPElement element)
                            throws SOAPException
将 SOAPElement 作为此 SOAPElement 实例的子级添加。应该由 SOAPFactory 来创建 SOAPElement。调用者不应依靠此方式添加到 XML 树的元素实例。实现最后可以将传递的 SOAPElement 的内容复制到一个不同 SOAPElement 实现的实例中。例如，如果对 SOAPHeader 调用 addChildElement()，则 element 将被复制到 SOAPHeaderElement 的实例中。

以 element 为根的片段将作为一个整体添加，如果发生错误，则不添加。

以 element 为根的片段不能包含名为 "Envelope"、"Header" 或 "Body" 且属于 SOAP 名称空间的元素。片段中出现的任何名称空间前缀都应该使用片段本身中适当的名称空间声明来完整解析。

参数：
element - 要作为新子级添加的 SOAPElement
返回：
一个实例，表示实际添加到树的新 SOAP 元素。
抛出：
SOAPException - 如果在作为子级添加此元素时出现错误

removeContents

void removeContents()
分离此 SOAPElement 的所有子级。

此方法对回滚部分完成的 SOAPHeaders 和 SOAPBodys 的构造很有用，便于准备在检测到错误条件时发送错误。它对于回收 SOAP 消息中的文档各部分也很有用。

从以下版本开始：
SAAJ 1.2

addTextNode

SOAPElement addTextNode(String text)
                        throws SOAPException
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。

参数：
text - 带有要添加文本内容的 String 对象
返回：
将插入新 Text 对象的 SOAPElement 对象
抛出：
SOAPException - 如果在创建新 Text 时发生错误，或者将它作为子级附加到此 SOAPElement 不合法

addAttribute

SOAPElement addAttribute(Name name,
                         String value)
                         throws SOAPException
将带有指定名称和值的属性添加到此 SOAPElement 对象。

参数：
name - 带有属性名称的 Name 对象
value - 给出属性值的 String
返回：
将插入属性的 SOAPElement 对象
抛出：
SOAPException - 如果在创建属性时发生错误，或者在此 SOAPElement 上设置带有 Name name 的属性无效。
另请参见：
addAttribute(javax.xml.namespace.QName, String)

addAttribute

SOAPElement addAttribute(QName qname,
                         String value)
                         throws SOAPException
将带有指定名称和值的属性添加到此 SOAPElement 对象。

参数：
qname - 带有属性名称的 QName 对象
value - 给出属性值的 String
返回：
将插入属性的 SOAPElement 对象
抛出：
SOAPException - 如果在创建属性时出现错误，如果在此 SOAPElement 上设置带有 QName qname 的属性无效。
从以下版本开始：
SAAJ 1.3
另请参见：
addAttribute(Name, String)

addNamespaceDeclaration

SOAPElement addNamespaceDeclaration(String prefix,
                                    String uri)
                                    throws SOAPException
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。

参数：
prefix - 给出名称空间前缀的 String
uri - 给出名称空间 URI 的 String
返回：
将插入名称空间声明的 SOAPElement 对象。
抛出：
SOAPException - 如果在创建名称空间时发生错误

getAttributeValue

String getAttributeValue(Name name)
返回带有指定名称的属性值。

参数：
name - 带有属性名称的 Name 对象
返回：
给出指定属性值的 String，如果没有这种属性，则返回 Null
另请参见：
getAttributeValue(javax.xml.namespace.QName)

getAttributeValue

String getAttributeValue(QName qname)
返回带有指定 qname 的属性值。

参数：
qname - 带有属性 qname 的 QName 对象
返回：
给出指定属性值的 String，如果没有这种属性，则返回 Null
从以下版本开始：
SAAJ 1.3
另请参见：
getAttributeValue(Name)

getAllAttributes

Iterator getAllAttributes()
返回可在此 SOAPElement 对象中所有属性 Name 对象上进行迭代的 Iterator。迭代器可以用于获取属性名称，然后可将这些名称传递给方法 getAttributeValue 以检索每个属性的值。

返回：
在属性名称上进行迭代的迭代器
另请参见：
getAllAttributesAsQNames()

getAllAttributesAsQNames

Iterator getAllAttributesAsQNames()
返回可在此 SOAPElement 对象（以 QName 对象的形式）中的所有属性上进行迭代的 Iterator。迭代器可以用于获取属性 QName，然后可将这些名称传递给方法 getAttributeValue 以检索每个属性的值。

返回：
在属性的 QNames 上进行迭代的迭代器
从以下版本开始：
SAAJ 1.3
另请参见：
getAllAttributes()

getNamespaceURI

String getNamespaceURI(String prefix)
返回带有给定前缀的名称空间的 URI。

参数：
prefix - 一个 String，给出用来搜索的名称空间前缀
返回：
一个 String，带有给定前缀名称空间的 URI

getNamespacePrefixes

Iterator getNamespacePrefixes()
返回可在此元素声明的名称空间前缀 String 上进行迭代的 Iterator。由此迭代器返回的前缀可以传递给方法 getNamespaceURI，以检索每个名称空间的 URI。

返回：
在此 SOAPElement 对象的名称空间前缀上进行迭代的迭代器

getVisibleNamespacePrefixes

Iterator getVisibleNamespacePrefixes()
返回在此元素可见的名称空间前缀 String 上进行迭代的 Iterator。由此迭代器返回的前缀可以传递给方法 getNamespaceURI，以检索每个名称空间的 URI。

返回：
在此 SOAPElement 对象作用域内的名称空间前缀上进行迭代的迭代器
从以下版本开始：
SAAJ 1.2

createQName

QName createQName(String localName,
                  String prefix)
                  throws SOAPException
创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。新 QName 的其余元素都直接取自参数、localName 和 prefix。

参数：
localName - 包含名称本地部分的 String。
prefix - 包含名称前缀的 String。
返回：
一个 QName，带有指定的 localName 和 prefix，以及与此 SOAPElement 上下文中的 prefix 关联的名称空间。如果将 prefix 作为参数提供给 getNamespaceURI(String)，则此名称空间将与该方法返回的名称空间相同。
抛出：
SOAPException - 如果无法创建 QName。
从以下版本开始：
SAAJ 1.3

getElementName

Name getElementName()
返回此 SOAPElement 对象的名称。

返回：
具有此 SOAPElement 对象名称的 Name 对象

getElementQName

QName getElementQName()
返回此 SOAPElement 对象的 qname。

返回：
具有此 SOAPElement 对象 qname 的 QName 对象
从以下版本开始：
SAAJ 1.3
另请参见：
getElementName()

setElementQName

SOAPElement setElementQName(QName newName)
                            throws SOAPException
如果可能，将此 Element 的名称更改为 newName。SOAP 定义的元素，如 SOAPEnvelope、SOAPHeader、SOAPBody 等，都无法使用此方法更改它们的名称。任何此类尝试都会导致抛出 SOAPException。

调用者不应依靠按此方式重命名的元素实例。实现最后可以将 SOAPElement 的内容复制到重命名实例。

参数：
newName - Element 的新名称。
返回：
重命名的节点
抛出：
SOAPException - 如果不允许更改此 Element 的名称。
从以下版本开始：
SAAJ 1.3

removeAttribute

boolean removeAttribute(Name name)
移除带有指定名称的属性。

参数：
name - Name 对象，带有要移除属性的名称
返回：
如果成功移除了属性，则返回 true；否则返回 false
另请参见：
removeAttribute(javax.xml.namespace.QName)

removeAttribute

boolean removeAttribute(QName qname)
移除带有指定 qname 的属性。

参数：
qname - QName 对象，带有要移除属性的 qname
返回：
如果成功移除了属性，则返回 true；否则返回 false
从以下版本开始：
SAAJ 1.3
另请参见：
removeAttribute(Name)

removeNamespaceDeclaration

boolean removeNamespaceDeclaration(String prefix)
移除对应于给定前缀的名称空间声明。

参数：
prefix - 一个 String，给出用来搜索的前缀
返回：
如果成功移除了名称空间声明，则返回 true；否则返回 false

getChildElements

Iterator getChildElements()
返回可在此元素的所有直接子 Node 上进行迭代的 Iterator。这包括 javax.xml.soap.Text 对象以及 SOAPElement 对象。

调用此方法可能导致子 Element、SOAPElement 和 org.w3c.dom.Text 节点被适合于此父节点类型的 SOAPElement、SOAPHeaderElement、SOAPBodyElement 或 javax.xml.soap.Text 节点替换。因此，调用的应用程序必须将任何现有的对通过 DOM API 获取的那些子节点的引用视为无效，并将其丢弃或用此 Iterator 返回的值进行更新。可以通过调用等效的 DOM API 来避免此行为。有关更多信息，请参阅 javax.xml.soap。

返回：
带有此 SOAPElement 对象内容的迭代器

getChildElements

Iterator getChildElements(Name name)
返回可在带有指定名称的此元素所有直接子 Node 上进行迭代的 Iterator。所有这些子节点都将是 SOAPElement 节点。

调用此方法可能导致子 Element、SOAPElement 和 org.w3c.dom.Text 节点被适合于此父节点类型的 SOAPElement、SOAPHeaderElement、SOAPBodyElement 或 javax.xml.soap.Text 节点替换。因此，调用的应用程序必须将任何现有的对通过 DOM API 获取的那些子节点的引用视为无效，并将其丢弃或用此 Iterator 返回的值进行更新。可以通过调用等效的 DOM API 来避免此行为。有关更多信息，请参阅 javax.xml.soap。

参数：
name - Name 对象，带有要返回的子元素的名称
返回：
在带有指定名称的此 SOAPElement 对象的所有元素上进行迭代的 Iterator 对象
另请参见：
getChildElements(javax.xml.namespace.QName)

getChildElements

Iterator getChildElements(QName qname)
返回可在带有指定 qname 的此元素所有直接子 Node 上进行迭代的 Iterator。所有这些子节点都将是 SOAPElement 节点。

调用此方法可能导致子 Element、SOAPElement 和 org.w3c.dom.Text 节点被适合于此父节点类型的 SOAPElement、SOAPHeaderElement、SOAPBodyElement 或 javax.xml.soap.Text 节点替换。因此，调用的应用程序必须将任何现有的对通过 DOM API 获取的那些子节点的引用视为无效，并将其丢弃或用此 Iterator 返回的值进行更新。可以通过调用等效的 DOM API 来避免此行为。有关更多信息，请参阅 javax.xml.soap。

参数：
qname - QName 对象，带有要返回的子元素的 qname
返回：
在带有指定 qname 的此 SOAPElement 对象的所有元素上进行迭代的 Iterator 对象
从以下版本开始：
SAAJ 1.3
另请参见：
getChildElements(Name)

setEncodingStyle

void setEncodingStyle(String encodingStyle)
                      throws SOAPException
将此 SOAPElement 对象的编码样式设置为指定样式。

参数：
encodingStyle - 给出编码样式的 String
抛出：
IllegalArgumentException - 如果在设置编码样式时出现问题。
SOAPException - 如果为此 SOAPElement 设置的编码样式无效。
另请参见：
getEncodingStyle()

getEncodingStyle

String getEncodingStyle()
返回此 SOAPElement 对象的编码样式。

返回：
给出编码样式的 String
另请参见：
setEncodingStyle(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPElementFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SOAPElementFactory

java.lang.Object
    继承者  javax.xml.soap.SOAPElementFactory
已过时。 - 使用 javax.xml.soap.SOAPFactory 创建 SOAPElements。

public class SOAPElementFactory
extends Object

SOAPElementFactory 是最终成为 SOAP 部分的 XML 片段的工厂。这些片段可以作为 SOAPHeader 或 SOAPBody 或 SOAPEnvelope 的子元素插入。

使用此工厂创建的元素没有 SOAP 头文档中所含元素的属性。当插入这些元素时，它们被复制到 XML 文档树。

另请参见：
SOAPFactory

方法摘要
 SOAPElement create(Name name)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
 SOAPElement create(String localName)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换
 SOAPElement create(String localName, String prefix, String uri)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换
static SOAPElementFactory newInstance()
已过时。 创建新的 SOAPElementFactory 实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

create

public SOAPElement create(Name name)
                   throws SOAPException
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换

创建使用给定 Name 对象初始化的 SOAPElement 对象。

参数：
name - 带有新元素 XML 名称的 Name 对象
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时存在错误
另请参见：
SOAPFactory.createElement(javax.xml.soap.Name), SOAPFactory.createElement(javax.xml.namespace.QName)

create

public SOAPElement create(String localName)
                   throws SOAPException
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换

创建使用给定本地名称初始化的 SOAPElement 对象。

参数：
localName - 给出新元素本地名称的 String
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时出现错误
另请参见：
SOAPFactory.createElement(java.lang.String)

create

public SOAPElement create(String localName,
                          String prefix,
                          String uri)
                   throws SOAPException
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换

使用给定的本地名称、前缀和 URL 创建新的 SOAPElement 对象。

参数：
localName - 给出新元素本地名称的 String
prefix - 此 SOAPElement 的前缀
uri - 给出新元素所属命名空间 URI 的 String
抛出：
SOAPException - 如果在创建 SOAPElement 对象时出现错误
另请参见：
SOAPFactory.createElement(java.lang.String, java.lang.String, java.lang.String)

newInstance

public static SOAPElementFactory newInstance()
                                      throws SOAPException
已过时。
创建新的 SOAPElementFactory 实例。

返回：
新的 SOAPElementFactory 实例
抛出：
SOAPException - 如果在创建默认 SOAPElementFactory 时出现错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPEnvelope (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPEnvelope

所有超级接口：
Element, Node, SOAPElement
public interface SOAPEnvelope
extends SOAPElement

SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。默认情况下，使用带有 SOAPEnvelope 对象的 SOAPPart 对象创建 SOAPMessage 对象。SOAPEnvelope 对象默认带有空 SOAPBody 对象和空 SOAPHeader 对象。SOAPBody 对象是必需的，SOAPHeader 对象虽然是可选的，但在大多数情况下都会用到。如果不需要 SOAPHeader 对象，则可以删除该对象（稍后将显示该操作）。

客户端可以通过调用方法 SOAPEnvelope.getHeader 和 SOAPEnvelope.getBody 来访问 SOAPHeader 和 SOAPBody 对象。以下代码行首先使用 SOAPMessage 对象 message 获取 SOAPPart 对象 sp，然后使用后者获取 SOAPEnvelope 对象 se，最后调用上述的两种方法。

SOAPPart sp = message.getSOAPPart();
SOAPEnvelope se = sp.getEnvelope();
SOAPHeader sh = se.getHeader();
SOAPBody sb = se.getBody();

检索 SOAPEnvelope 对象当前的正文或头，然后将其删除并添加一个新正文或头，这样就能更改该对象的正文或头。javax.xml.soap.Node 方法 deleteNode 删除调用它的 XML 元素（节点）。例如，以下代码行删除由方法 getBody 检索的 SOAPBody 对象。

se.getBody().detachNode();
要创建用来替换被移除对象的 SOAPHeader 对象，客户端应使用方法 SOAPEnvelope.addHeader，该方法创建一个新头并将其添加到 SOAPEnvelope 对象。类似地，方法 addBody 创建一个新 SOAPBody 对象并将其添加到 SOAPEnvelope 对象。以下代码片段检索当前的头，然后将其删除并添加一个新头。接下来检索当前的正文，然后将其删除并添加一个新正文。
SOAPPart sp = message.getSOAPPart();
SOAPEnvelope se = sp.getEnvelope();
se.getHeader().detachNode();
SOAPHeader sh = se.addHeader();
se.getBody().detachNode();
SOAPBody sb = se.addBody();
在已经存在的情况下添加 SOAPBody 或 SOAPHeader 是错误的。

SOAPEnvelope 接口提供了三种创建 Name 对象的方法。第一种方法使用本地名称、名称空间前缀以及名称空间 URI 创建 Name 对象。第二种方法使用本地名称和名称空间前缀创建 Name 对象，第三种方法只使用本地名称创建 Name 对象。以下代码行（其中 se 是一个 SOAPEnvelope 对象）创建带有所有三个元素的新 Name 对象。

Name name = se.createName("GetLastTradePrice", "WOMBAT",
"http://www.wombat.org/trader");

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
SOAPBody | addBody() 创建一个 SOAPBody 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPBody 对象。
SOAPHeader | addHeader() 创建一个 SOAPHeader 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPHeader 对象。
Name | createName(String localName) 创建使用给定本地名称初始化的新 Name 对象。
Name | createName(String localName, String prefix, String uri) 创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。
SOAPBody | getBody() 返回与此 SOAPEnvelope 对象关联的 SOAPBody 对象。
SOAPHeader | getHeader() 返回此 SOAPEnvelope 对象的 SOAPHeader 对象。
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

createName

Name createName(String localName,
                String prefix,
                String uri)
                throws SOAPException
创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。

此工厂方法创建在 SOAP/XML 文档中使用的 Name 对象。

参数：
localName - 给出本地名称的 String
prefix - 给出名称空间前缀的 String
uri - 给出名称空间 URI 的 String
返回：
使用给定本地名称、名称空间前缀和名称空间 URL 初始化的 Name 对象
抛出：
SOAPException - 如果存在 SOAP 错误

createName

Name createName(String localName)
                throws SOAPException
创建使用给定本地名称初始化的新 Name 对象。

此工厂方法创建在 SOAP/XML 文档中使用的 Name 对象。

参数：
localName - 给出本地名称的 String
返回：
使用给定本地名称初始化的 Name 对象
抛出：
SOAPException - 如果存在 SOAP 错误

getHeader

SOAPHeader getHeader()
                     throws SOAPException
返回此 SOAPEnvelope 对象的 SOAPHeader 对象。

默认情况下，使用包含空 SOAPHeader 对象的 SOAPEnvelope 对象创建新 SOAPMessage 对象。因此，只要没有移除了头且尚未添加新头，方法 getHeader 将总是返回 SOAPHeader 对象。

返回：
SOAPHeader 对象，如果没有该对象，则返回 null
抛出：
SOAPException - 如果在获取 SOAPHeader 对象时出现问题

getBody

SOAPBody getBody()
                 throws SOAPException
返回与此 SOAPEnvelope 对象关联的 SOAPBody 对象。

默认情况下，使用包含空 SOAPBody 对象的 SOAPEnvelope 对象创建 SOAPMessage 对象。因此，只要没有移除了正文且尚未添加新正文，方法 getBody 将总是返回 SOAPBody 对象。

返回：
此 SOAPEnvelope 对象的 SOAPBody 的对象，如果没有该对象，则返回 null
抛出：
SOAPException - 如果在获取 SOAPBody 对象时出现问题

addHeader

SOAPHeader addHeader()
                     throws SOAPException
创建一个 SOAPHeader 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPHeader 对象。

当信封已包含头时，添加头是非法的。因此，此方法应该在移除了现有的头之后调用。

返回：
新的 SOAPHeader 对象
抛出：
SOAPException - 如果此 SOAPEnvelope 对象已包含一个有效的 SOAPHeader 对象

addBody

SOAPBody addBody()
                 throws SOAPException
创建一个 SOAPBody 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPBody 对象。

当信封已包含正文时，添加正文是非法的。因此，此方法应该在移除了现有的正文之后调用。

返回：
新的 SOAPBody 对象
抛出：
SOAPException - 如果此 SOAPEnvelope 对象已包含一个有效的 SOAPBody 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SOAPException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.soap.SOAPException
所有已实现的接口：
Serializable
public class SOAPException
extends Exception

当发生 SOAP 异常时，抛出此异常。SOAPException 对象可以包含给出异常原因的 String 或嵌入的 Throwable 对象，也可以同时包含两者。此类提供检索原因消息的方法和检索嵌入 Throwable 对象的方法。

抛出 SOAPException 对象的通常原因是难以设置头、无法发送消息以及无法获取与提供者的连接之类的问题。嵌入 Throwable 对象的原因包括诸如输入/输出错误之类的问题或解析问题，如解析头时出现错误。

另请参见：
序列化表格

构造方法摘要
SOAPException()
构造不带原因或内置 Throwable 对象的 SOAPException 对象。
SOAPException(String reason)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因。
SOAPException(String reason, Throwable cause)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因，使用给定 Throwable 对象作为嵌入的异常。
SOAPException(Throwable cause)
构造使用给定 Throwable 对象初始化的 SOAPException 对象。
方法摘要
Throwable | getCause() 返回此 SOAPException 中嵌入的 Throwable 对象（如果有）。
String | getMessage() 返回此 SOAPException 对象的详细消息。
Throwable | initCause(Throwable cause) 使用给定的 Throwable 对象初始化此 SOAPException 对象的 cause 字段。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SOAPException

public SOAPException()
构造不带原因或内置 Throwable 对象的 SOAPException 对象。

SOAPException

public SOAPException(String reason)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因。

参数：
reason - 对导致异常的原因的描述

SOAPException

public SOAPException(String reason,
                     Throwable cause)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因，使用给定 Throwable 对象作为嵌入的异常。

参数：
reason - 对导致异常的原因的描述
cause - 要嵌入此 SOAPException 对象的 Throwable 对象

SOAPException

public SOAPException(Throwable cause)
构造使用给定 Throwable 对象初始化的 SOAPException 对象。

方法详细信息

getMessage

public String getMessage()
返回此 SOAPException 对象的详细消息。

如果有嵌入的 Throwable 对象，并且 SOAPException 对象没有自己的详细消息，则此方法将返回嵌入的 Throwable 对象的详细消息。

覆盖：
类 Throwable 中的 getMessage
返回：
此 SOAPException 的错误或警告消息，如果没有此类消息，则返回嵌入的 Throwable 对象（如果有）的消息

getCause

public Throwable getCause()
返回此 SOAPException 中嵌入的 Throwable 对象（如果有）。否则，此方法返回 null。

覆盖：
类 Throwable 中的 getCause
返回：
嵌入的 Throwable 对象，如果没有此类对象，则返回 null

initCause

public Throwable initCause(Throwable cause)
使用给定的 Throwable 对象初始化此 SOAPException 对象的 cause 字段。

此方法至多可以调用一次。此方法通常从构造方法中调用，或者在构造方法返回新的 SOAPException 对象后立即调用。如果此 SOAPException 对象是使用构造方法 SOAPException(Throwable) 或 SOAPException(String,Throwable) 创建的，则意味着它的 cause 字段已经有一个值，此方法一次也不能调用。

覆盖：
类 Throwable 中的 initCause
参数：
cause - 导致抛出此 SOAPException 对象的 Throwable 对象。保存此参数的值，以便以后通过 getCause() 方法检索它。此参数值可以为 null，指示 cause 不存在或是未知的。
返回：
对此 SOAPException 实例的引用
抛出：
IllegalArgumentException - 如果 cause 是此 Throwable 对象。（Throwable 对象不能是它自己的 cause。）
IllegalStateException - 如果此 SOAPException 对象的 cause 已经初始化
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SOAPFactory

java.lang.Object
    继承者  javax.xml.soap.SOAPFactory

public abstract class SOAPFactory
extends Object

SOAPFactory 是用来创建存在于 SOAP XML 树中的各种对象的工厂。SOAPFactory 可以用于创建最终成为 SOAP 部分的 XML 片段。这些片段可以作为 SOAPHeaderElement、SOAPBodyElement、SOAPEnvelope 或其他 SOAPElement 对象的子级插入。SOAPFactory 还具有创建 javax.xml.soap.Detail 对象以及 java.xml.soap.Name 对象的方法。

构造方法摘要
SOAPFactory()
方法摘要
abstract Detail | createDetail() 创建充当 DetailEntry 对象容器的新 Detail 对象。
SOAPElement | createElement(Element domElement) 根据现有的 DOM Element 创建 SOAPElement 对象。
abstract SOAPElement | createElement(Name name) 创建使用给定 Name 对象初始化的 SOAPElement 对象。
SOAPElement | createElement(QName qname) 创建使用给定 QName 对象初始化的 SOAPElement 对象。
abstract SOAPElement | createElement(String localName) 创建使用给定本地名称初始化的 SOAPElement 对象。
abstract SOAPElement | createElement(String localName, String prefix, String uri) 使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。
abstract SOAPFault | createFault() 创建一个新的默认 SOAPFault 对象
abstract SOAPFault | createFault(String reasonText, QName faultCode) 创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
abstract Name | createName(String localName) 创建使用给定本地名称初始化的新 Name 对象。
abstract Name | createName(String localName, String prefix, String uri) 创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。
static SOAPFactory | newInstance() 创建新的 SOAPFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static SOAPFactory | newInstance(String protocol) 创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SOAPFactory

public SOAPFactory()
方法详细信息

createElement

public SOAPElement createElement(Element domElement)
                          throws SOAPException
根据现有的 DOM Element 创建 SOAPElement 对象。如果作为参数传入的 DOM Element 已经是一个 SOAPElement，那么此方法必须不作任何修改地返回该参数。否则，会创建新的 SOAPElement 并进行此 domElement 参数的深层复制。返回值的具体类型将取决于 domElement 参数的名称。如果以 domElement 为根的树的任何部分违背了 SOAP 规则，则会抛出 SOAPException。

参数：
domElement - 要复制的 Element。
返回：
一个新的 SOAPElement，它是 domElement 的副本。
抛出：
SOAPException - 如果在创建 SOAPElement 对象时存在错误
从以下版本开始：
SAAJ 1.3

createElement

public abstract SOAPElement createElement(Name name)
                                   throws SOAPException
创建使用给定 Name 对象初始化的 SOAPElement 对象。返回值的具体类型将取决于提供给新 SOAPElement 的名称。例如，一个带有名称 "{http://www.w3.org/2003/05/soap-envelope}Envelope" 的新 SOAPElement 会导致创建支持 SOAP 1.2 行为的 SOAPEnvelope。

参数：
name - 带有新元素 XML 名称的 Name 对象
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时出现错误
另请参见：
createElement(javax.xml.namespace.QName)

createElement

public SOAPElement createElement(QName qname)
                          throws SOAPException
创建使用给定 QName 对象初始化的 SOAPElement 对象。返回值的具体类型将取决于提供给新 SOAPElement 的名称。例如，一个带有名称 "{http://www.w3.org/2003/05/soap-envelope}Envelope" 的新 SOAPElement 会导致创建支持 SOAP 1.2 行为的 SOAPEnvelope。

参数：
qname - 带有新元素 XML 名称的 QName 对象
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时出现错误
从以下版本开始：
SAAJ 1.3
另请参见：
createElement(Name)

createElement

public abstract SOAPElement createElement(String localName)
                                   throws SOAPException
创建使用给定本地名称初始化的 SOAPElement 对象。

参数：
localName - 给出新元素本地名称的 String
返回：
创建的新 SOAPElement 对象
抛出：
SOAPException - 如果在创建 SOAPElement 对象时存在错误

createElement

public abstract SOAPElement createElement(String localName,
                                          String prefix,
                                          String uri)
                                   throws SOAPException
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。返回值的具体类型将取决于提供给新 SOAPElement 的名称。例如，一个带有名称 "{http://www.w3.org/2003/05/soap-envelope}Envelope" 的新 SOAPElement 会导致创建支持 SOAP 1.2 行为的 SOAPEnvelope。

参数：
localName - 给出新元素本地名称的 String
prefix - 此 SOAPElement 的前缀
uri - 给出新元素所属名称空间 URI 的 String
抛出：
SOAPException - 如果在创建 SOAPElement 对象时存在错误

createDetail

public abstract Detail createDetail()
                             throws SOAPException
创建充当 DetailEntry 对象容器的新 Detail 对象。

此工厂方法创建 Detail 对象，用于不可能使用 SOAPFault 抽象的情况。

返回：
一个 Detail 对象
抛出：
SOAPException - 如果存在 SOAP 错误
UnsupportedOperationException - 如果为 SOAPFactory 指定的协议是 DYNAMIC_SOAP_PROTOCOL

createFault

public abstract SOAPFault createFault(String reasonText,
                                      QName faultCode)
                               throws SOAPException
创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象

参数：
reasonText - 错误的 ReasonText/FaultString
faultCode - 错误的 FaultCode
返回：
一个 SOAPFault 对象
抛出：
SOAPException - 如果存在 SOAP 错误
从以下版本开始：
SAAJ 1.3

createFault

public abstract SOAPFault createFault()
                               throws SOAPException
创建一个新的默认 SOAPFault 对象

返回：
一个 SOAPFault 对象
抛出：
SOAPException - 如果存在 SOAP 错误
从以下版本开始：
SAAJ 1.3

createName

public abstract Name createName(String localName,
                                String prefix,
                                String uri)
                         throws SOAPException
创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。

此工厂方法创建 Name 对象，用于不可能使用 SOAPEnvelope 抽象的情况。

参数：
localName - 给出本地名称的 String
prefix - 给出名称空间前缀的 String
uri - 给出名称空间 URI 的 String
返回：
使用给定本地名称、名称空间前缀和名称空间 URI 初始化的 Name 对象
抛出：
SOAPException - 如果存在 SOAP 错误

createName

public abstract Name createName(String localName)
                         throws SOAPException
创建使用给定本地名称初始化的新 Name 对象。

此工厂方法创建 Name 对象，用于不可能使用 SOAPEnvelope 抽象的情况。

参数：
localName - 给出本地名称的 String
返回：
使用给定本地名称初始化的 Name 对象
抛出：
SOAPException - 如果存在 SOAP 错误

newInstance

public static SOAPFactory newInstance()
                               throws SOAPException
创建新的 SOAPFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。 此方法使用以下查找过程顺序来确定要加载的 SOAPFactory 实现类：
  • 使用 javax.xml.soap.SOAPFactory 系统属性。
  • 使用 JRE 文件夹中的属性文件 "lib/jaxm.properties"。此配置文件格式是标准的 java.util.Properties 格式且包含实现类的完全限定名，其中实现类的键是上文定义的系统属性。
  • 如果 Services API（在 JAR 规范中进行了详细描述）可用，可以使用它来确定类名称。Services API 将查找在运行时可用的 jar 中 META-INF/services/javax.xml.soap.SOAPFactory 文件中的类名称。
  • 使用 SAAJMetaFactory 实例来定位 SOAPFactory 实现类。

返回：
新的 SOAPFactory 实例
抛出：
SOAPException - 如果在创建默认 SOAPFactory 时出现错误
另请参见：
SAAJMetaFactory

newInstance

public static SOAPFactory newInstance(String protocol)
                               throws SOAPException
创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。

参数：
protocol - 字符串常量，表示指定 SOAP 工厂实现的协议。可以是 DYNAMIC_SOAP_PROTOCOL、DEFAULT_SOAP_PROTOCOL（等同于 SOAP_1_1_PROTOCOL）或 SOAP_1_2_PROTOCOL。
返回：
新的 SOAPFactory 实例
抛出：
SOAPException - 如果在创建指定 SOAPFactory 时出现错误
从以下版本开始：
SAAJ 1.3
另请参见：
SAAJMetaFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPFault (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPFault

所有超级接口：
Element, Node, SOAPBodyElement, SOAPElement
public interface SOAPFault
extends SOAPBodyElement

SOAPBody 对象中的元素，包含错误和/或状态信息。此信息可能与 SOAPMessage 对象中的错误相关，也可能与和消息本身的内容无关的问题相关。与消息本身无关的问题通常是处理过程中的错误，如无法与上游服务器通信。

SOAPFault 具有 SOAP 1.1 或 SOAP 1.2 规范中定义的子元素，具体取决于创建 MessageFactory 实例时指定的 protocol。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
Detail | addDetail() 创建可选的 Detail 对象，并将其设置为此 SOAPFault 对象的 Detail 对象。
void | addFaultReasonText(String text, Locale locale) 追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。
void | appendFaultSubcode(QName subcode) 将 Subcode 添加到此 SOAPFault 包含的 Subcode 序列的末尾。
Detail | getDetail() 返回此 SOAPFault 对象的可选 detail 元素。
String | getFaultActor() 获取此 SOAPFault 对象的错误参与者。
String | getFaultCode() 获取此 SOAPFault 对象的错误代码。
Name | getFaultCodeAsName() 以 SAAJ Name 对象形式获取此 SOAPFault 对象的强制性 SOAP 1.1 错误代码。
QName | getFaultCodeAsQName() 以 QName 对象形式获取此 SOAPFault 对象的错误代码。
String | getFaultNode() 返回此 SOAPFault 对象的可选 Node 元素值。
Iterator | getFaultReasonLocales() 返回一个 Iterator，它可以在与 Reason Text 项关联的 Locale 独特序列上进行迭代。
String | getFaultReasonText(Locale locale) 返回与给定 Locale 关联的 Reason Text。
Iterator | getFaultReasonTexts() 返回一个 Iterator，它可以在包含此 SOAPFault 所有 Reason Text 项的 String 对象序列上进行迭代。
String | getFaultRole() 返回此 SOAPFault 对象的可选 Role 元素值。
String | getFaultString() 获取此 SOAPFault 对象的错误字符串。
Locale | getFaultStringLocale() 获取此 SOAPFault 对象错误字符串的语言环境。
Iterator | getFaultSubcodes() 以 QNames 迭代器形式获取此 SOAPFault 的 Subcode。
boolean | hasDetail() 如果此 SOAPFault 有一个 Detail 子元素，则返回 true，否则返回 false。
void | removeAllFaultSubcodes() 移除此 SOAPFault 可能包含的任何 Subcode。
void | setFaultActor(String faultActor) 使用给定的错误参与者 (actor) 设置此 SOAPFault 对象。
void | setFaultCode(Name faultCodeQName) 使用给定的错误代码设置此 SOAPFault 对象。
void | setFaultCode(QName faultCodeQName) 使用给定的错误代码设置此 SOAPFault 对象。
void | setFaultCode(String faultCode) 使用给定的错误代码设置此 SOAPFault 对象。
void | setFaultNode(String uri) 创建或替换此 SOAPFault 对象的任何现有 Node 元素。
void | setFaultRole(String uri) 创建或替换此 SOAPFault 对象的任何现有 Role 元素。
void | setFaultString(String faultString) 将此 SOAPFault 对象的错误字符串设定为给定字符串。
void | setFaultString(String faultString, Locale locale) 将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

setFaultCode

void setFaultCode(Name faultCodeQName)
                  throws SOAPException
使用给定的错误代码设置此 SOAPFault 对象。

给出有关错误信息的错误代码是在 SOAP 1.1 规范中定义的。错误代码是强制性的 (mandatory)，必须是 QName 类型。此方法提供设置错误代码的便捷方式。例如，

SOAPEnvelope se = ...;
// Create a qualified name in the SOAP namespace with a localName
// of "Client".Note that prefix parameter is optional and is null
// here which causes the implementation to use an appropriate prefix.
Name qname = se.createName("Client", null,
SOAPConstants.URI_NS_SOAP_ENVELOPE);
SOAPFault fault = ...;
fault.setFaultCode(qname);
相比 setFaultCode(String) 方法，最好优先使用此方法。

参数：
faultCodeQName - 给出要设置的错误代码的 Name 对象。它必须是限定于名称空间的。
抛出：
SOAPException - 如果在将 faultcode 元素添加到底层 XML 树时出现错误。
从以下版本开始：
SAAJ 1.2
另请参见：
getFaultCodeAsName()

setFaultCode

void setFaultCode(QName faultCodeQName)
                  throws SOAPException
使用给定的错误代码设置此 SOAPFault 对象。相比 setFaultCode(Name) 方法，最好优先使用此方法。

参数：
faultCodeQName - 提供要设置的错误代码的 QName 对象。它必须是限定于名称空间的。
抛出：
SOAPException - 如果在将 faultcode 元素添加到底层 XML 树时出现错误。
从以下版本开始：
SAAJ 1.3
另请参见：
getFaultCodeAsQName(), setFaultCode(Name), getFaultCodeAsQName()

setFaultCode

void setFaultCode(String faultCode)
                  throws SOAPException
使用给定的错误代码设置此 SOAPFault 对象。

给出有关错误信息的错误代码是在 SOAP 1.1 规范中定义的。此元素在 SOAP 1.1 中是强制性的。因为错误代码要求是 QName，所以最好使用此方法的 setFaultCode(Name) 形式。

参数：
faultCode - 提供要设置的错误代码的 String。它必须是 "prefix:localName" 形式，其中前缀是用名称空间声明定义的。
抛出：
SOAPException - 如果在将 faultCode 添加到底层 XML 树时出现错误。
另请参见：
setFaultCode(Name), getFaultCode(), SOAPElement.addNamespaceDeclaration(java.lang.String, java.lang.String)

getFaultCodeAsName

Name getFaultCodeAsName()
以 SAAJ Name 对象形式获取此 SOAPFault 对象的强制性 SOAP 1.1 错误代码。SOAP 1.1 规范要求 "faultcode" 元素的值为 QName 类型。此方法以 SAAJ Name 对象的形式返回 QName 形式的元素内容。应该使用此方法来代替 getFaultCode 方法，因为它允许应用程序方便地访问名称空间名，而不需要其他解析。

返回：
表示错误代码的 Name
从以下版本开始：
SAAJ 1.2
另请参见：
setFaultCode(Name)

getFaultCodeAsQName

QName getFaultCodeAsQName()
以 QName 对象形式获取此 SOAPFault 对象的错误代码。

返回：
表示错误代码的 QName
从以下版本开始：
SAAJ 1.3
另请参见：
setFaultCode(QName)

getFaultSubcodes

Iterator getFaultSubcodes()
以 QNames 迭代器形式获取此 SOAPFault 的 Subcode。

返回：
访问 QNames 序列的 Iterator 此 Iterator 不应支持可选的 remove 方法。Subcode 返回的顺序反映了 Subcode 在错误代码中从上到下的层次结构。
抛出：
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Subcode。
从以下版本开始：
SAAJ 1.3

removeAllFaultSubcodes

void removeAllFaultSubcodes()
移除此 SOAPFault 可能包含的任何 Subcode。在调用 appendFaultSubcode 之前，对 getFaultSubcodes 的后续调用将返回空迭代器。

抛出：
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Subcode。
从以下版本开始：
SAAJ 1.3

appendFaultSubcode

void appendFaultSubcode(QName subcode)
                        throws SOAPException
将 Subcode 添加到此 SOAPFault 包含的 Subcode 序列的末尾。SOAP 1.2 中引入的 Subcode 由递归子元素序列表示，该序列由 SOAP Fault 的强制 Code 子元素排列形成。

参数：
subcode - 包含 Subcode 值的 QName。
抛出：
SOAPException - 如果在设置 Subcode 时出现错误
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Subcode。
从以下版本开始：
SAAJ 1.3

getFaultCode

String getFaultCode()
获取此 SOAPFault 对象的错误代码。

返回：
带有错误代码的 String
另请参见：
getFaultCodeAsName(), setFaultCode(javax.xml.soap.Name)

setFaultActor

void setFaultActor(String faultActor)
                   throws SOAPException
使用给定的错误参与者 (actor) 设置此 SOAPFault 对象。

错误参与者是消息路径中导致发生错误的接收方。

如果此 SOAPFault 支持 SOAP 1.2，则此调用等效于 setFaultRole(String)

参数：
faultActor - 一个 String，标识导致此 SOAPFault 对象的参与者
抛出：
SOAPException - 如果在将 faultActor 添加到底层 XML 树时出现错误。
另请参见：
getFaultActor()

getFaultActor

String getFaultActor()
获取此 SOAPFault 对象的错误参与者。

如果此 SOAPFault 支持 SOAP 1.2，那么此调用等效于 getFaultRole()。

返回：
一个 String，给出消息路径中导致此 SOAPFault 对象的参与者
另请参见：
setFaultActor(java.lang.String)

setFaultString

void setFaultString(String faultString)
                    throws SOAPException
将此 SOAPFault 对象的错误字符串设定为给定字符串。

如果此 SOAPFault 是支持 SOAP 1.2 的消息的一部分，则此调用等效于：

addFaultReasonText(faultString, Locale.getDefault());

参数：
faultString - 一个 String，给出对错误的解释
抛出：
SOAPException - 如果在将 faultString 添加到底层 XML 树时出现错误。
另请参见：
getFaultString()

setFaultString

void setFaultString(String faultString,
                    Locale locale)
                    throws SOAPException
将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。

如果此 SOAPFault 是支持 SOAP 1.2 的消息的一部分，则此调用等效于：

addFaultReasonText(faultString, locale);

参数：
faultString - 一个 String，给出对错误的解释
locale - 一个 Locale 对象，指示 faultString 的本地语言
抛出：
SOAPException - 如果在将 faultString 添加到底层 XML 树时出现错误。
从以下版本开始：
SAAJ 1.2
另请参见：
getFaultString()

getFaultString

String getFaultString()
获取此 SOAPFault 对象的错误字符串。

如果此 SOAPFault 是支持 SOAP 1.2 的消息的一部分，则此调用等效于：

String reason = null;
try {
reason = (String) getFaultReasonTexts().next();
} catch (SOAPException e) {}
return reason;

返回：
一个 String，给出对错误的解释
另请参见：
setFaultString(String), setFaultString(String, Locale)

getFaultStringLocale

Locale getFaultStringLocale()
获取此 SOAPFault 对象错误字符串的语言环境。

如果此 SOAPFault 是支持 SOAP 1.2 的消息的一部分，则此调用等效于：

Locale locale = null;
try {
locale = (Locale) getFaultReasonLocales().next();
} catch (SOAPException e) {}
return locale;

返回：
一个 Locale 对象，指示默认字符串的本地语言，如果没有指定语言环境，则返回 null
从以下版本开始：
SAAJ 1.2
另请参见：
setFaultString(String, Locale)

hasDetail

boolean hasDetail()
如果此 SOAPFault 有一个 Detail 子元素，则返回 true，否则返回 false。与 (getDetail()!=null) 等效。

返回：
如果此 SOAPFault 有一个 Detail 子元素，则返回 true，否则返回 false。
从以下版本开始：
SAAJ 1.3

getDetail

Detail getDetail()
返回此 SOAPFault 对象的可选 detail 元素。

Detail 对象携带了特定于应用程序的错误信息，如果该错误信息是 SOAP 1.1 Fault，则其范围限于 SOAPBodyElement 对象中的错误。

返回：
带有特定于应用程序的错误信息的 Detail 对象（如果存在）；如果不存在此类对象，则返回 null。

addDetail

Detail addDetail()
                 throws SOAPException
创建可选的 Detail 对象，并将其设置为此 SOAPFault 对象的 Detail 对象。

当错误已包含详细信息时，添加详细信息是非法的。因此，此方法应该在移除了现有的详细信息之后调用。

返回：
新的 Detail 对象
抛出：
SOAPException - 如果此 SOAPFault 对象已包含一个有效的 Detail 对象

getFaultReasonLocales

Iterator getFaultReasonLocales()
                               throws SOAPException
返回一个 Iterator，它可以在与 Reason Text 项关联的 Locale 独特序列上进行迭代。这些 Locale 都可以用于对 getFaultReasonText 的调用，以便获取 Reason Text 字符串的本地化版本。

返回：
一个 Iterator，可在与 Reason Text 项关联的 Locale 对象序列上进行迭代。
抛出：
SOAPException - 如果检索错误 Reason 语言环境时出现错误。
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Reason。
从以下版本开始：
SAAJ 1.3

getFaultReasonTexts

Iterator getFaultReasonTexts()
                             throws SOAPException
返回一个 Iterator，它可以在包含此 SOAPFault 所有 Reason Text 项的 String 对象序列上进行迭代。

返回：
一个 Iterator，可在 env:Fault/env:Reason/env:Text 项上进行迭代。
抛出：
SOAPException - 如果检索错误 Reason 文本时出现错误。
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Reason。
从以下版本开始：
SAAJ 1.3

getFaultReasonText

String getFaultReasonText(Locale locale)
                          throws SOAPException
返回与给定 Locale 关联的 Reason Text。如果存在一个以上这种 Reason Text，则返回第一个与 Text 匹配的 Reason Text。

参数：
locale - 本地化 Reason Text 时需要的 Locale
返回：
与 locale 关联的 Reason Text
抛出：
SOAPException - 如果针对指定语言环境检索错误 Reason 文本时出现错误。
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Reason。
从以下版本开始：
SAAJ 1.3
另请参见：
getFaultString()

addFaultReasonText

void addFaultReasonText(String text,
                        Locale locale)
                        throws SOAPException
追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。如果已经存在带有此 xml:lang 的 Reason Text 项，则其文本值将被 text 替换。locale 参数不应为 null。

代码示例：

SOAPFault fault = ...;
fault.addFaultReasonText("Version Mismatch", Locale.ENGLISH);

参数：
text - 原因消息字符串
locale - 表示消息语言环境的 Locale 对象
抛出：
SOAPException - 如果在添加 Reason 文本时出现错误，或者传递的 locale 为 null。
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Reason。
从以下版本开始：
SAAJ 1.3

getFaultNode

String getFaultNode()
返回此 SOAPFault 对象的可选 Node 元素值。Node 元素在 SOAP 1.2 中是可选的。

返回：
String 形式的 env:Fault/env:Node 元素的内容，如果没有此类内容，则返回 null
抛出：
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Node。
从以下版本开始：
SAAJ 1.3

setFaultNode

void setFaultNode(String uri)
                  throws SOAPException
创建或替换此 SOAPFault 对象的任何现有 Node 元素。Node 元素在 SOAP 1.2 中是可选的。

抛出：
SOAPException - 如果在设置此 SOAPFault 对象的 Node 时出现错误。
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Node。
从以下版本开始：
SAAJ 1.3

getFaultRole

String getFaultRole()
返回此 SOAPFault 对象的可选 Role 元素值。Role 元素在 SOAP 1.2 中是可选的。

返回：
String 形式的 env:Fault/env:Role 元素的内容，如果没有此类内容，则返回 null
抛出：
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Role。
从以下版本开始：
SAAJ 1.3

setFaultRole

void setFaultRole(String uri)
                  throws SOAPException
创建或替换此 SOAPFault 对象的任何现有 Role 元素。Role 元素在 SOAP 1.2 中是可选的。

参数：
uri - Role 的 URI
抛出：
SOAPException - 如果在设置此 SOAPFault 对象的 Role 时出现错误。
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Role。
从以下版本开始：
SAAJ 1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPFaultElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPFaultElement

所有超级接口：
Element, Node, SOAPElement
所有已知子接口：
Detail
public interface SOAPFaultElement
extends SOAPElement

SOAPFault 对象内容的表示形式。Detail 接口是一个 SOAPFaultElement。

使用 SOAPElement 的 addTextNode 方法向 SOAPFaultElement 添加内容。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPHeader (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPHeader

所有超级接口：
Element, Node, SOAPElement
public interface SOAPHeader
extends SOAPElement

SOAP 头元素的表示形式。SOAP 头元素由能影响消息提供者处理特定于应用程序内容的方式的 XML 数据组成。例如，事务语义、验证信息等，都可以被指定为 SOAPHeader 对象的内容。

SOAPEnvelope 对象默认包含一个空 SOAPHeader 对象。如果不需要 SOAPHeader 对象（可选），则可以使用以下代码行检索和删除该对象。变量 se 是一个 SOAPEnvelope 对象。

se.getHeader().detachNode();
SOAPHeader 对象是使用 SOAPEnvelope 的 addHeader 方法创建的。只有在移除现有的头之后，才能调用此方法创建新头并将其添加到信封中。
se.getHeader().detachNode();
SOAPHeader sh = se.addHeader();

SOAPHeader 对象只能将 SOAPHeaderElement 对象作为其直接子级。方法 addHeaderElement 创建一个新 HeaderElement 对象并将其添加到 SOAPHeader 对象。在以下代码行中，方法 addHeaderElement 的参数是一个 Name 对象，该对象是新 HeaderElement 对象的名称。

SOAPHeaderElement shElement = sh.addHeaderElement(name);

另请参见：
SOAPHeaderElement

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
SOAPHeaderElement | addHeaderElement(Name name) 创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | addHeaderElement(QName qname) 创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | addNotUnderstoodHeaderElement(QName name) 创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | addUpgradeHeaderElement(Iterator supportedSOAPURIs) 创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | addUpgradeHeaderElement(String supportedSoapUri) 创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | addUpgradeHeaderElement(String[] supportedSoapUris) 创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
Iterator | examineAllHeaderElements() 返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator。
Iterator | examineHeaderElements(String actor) 返回可在此 SOAPHeader 对象中具有指定的 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator。
Iterator | examineMustUnderstandHeaderElements(String actor) 返回可在此 SOAPHeader 对象中所有符合以下条件的 SOAPHeaderElement 对象上进行迭代的 Iterator：具有指定的 actor 以及一个值等于 true 的 MustUnderstand 属性。
Iterator | extractAllHeaderElements() 返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
Iterator | extractHeaderElements(String actor) 返回可在此 SOAPHeader 对象中所有具有指定 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

addHeaderElement

SOAPHeaderElement addHeaderElement(Name name)
                                   throws SOAPException
创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

参数：
name - 带有新 SOAPHeaderElement 对象名称的 Name 对象
返回：
插入此 SOAPHeader 对象的新的 SOAPHeaderElement 对象
抛出：
SOAPException - 如果发生 SOAP 错误
另请参见：
addHeaderElement(javax.xml.namespace.QName)

addHeaderElement

SOAPHeaderElement addHeaderElement(QName qname)
                                   throws SOAPException
创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

参数：
qname - 带有新 SOAPHeaderElement 对象 qname 的 QName 对象
返回：
插入此 SOAPHeader 对象的新的 SOAPHeaderElement 对象
抛出：
SOAPException - 如果发生 SOAP 错误
从以下版本开始：
SAAJ 1.3
另请参见：
addHeaderElement(Name)

examineMustUnderstandHeaderElements

Iterator examineMustUnderstandHeaderElements(String actor)
返回可在此 SOAPHeader 对象中所有符合以下条件的 SOAPHeaderElement 对象上进行迭代的 Iterator：具有指定的 actor 以及一个值等于 true 的 MustUnderstand 属性。

在 SOAP 1.2 中，env:actor 属性应替换为 env:role 属性，但实质上语义是相同的。

参数：
actor - 一个 String，给出要搜索的 actor/role 的 URI
返回：
一个 Iterator 对象，可在所有符合以下条件的 SOAPHeaderElement 对象上进行迭代：包含指定的 actor / role 并标记为 MustUnderstand
从以下版本开始：
SAAJ 1.2
另请参见：
examineHeaderElements(java.lang.String), extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

examineHeaderElements

Iterator examineHeaderElements(String actor)
返回可在此 SOAPHeader 对象中具有指定的 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator。actor 是一个全局属性，指示消息到达其最终接收者之前应对该消息进行处理的中间参与方。actor 接收并处理消息，然后将该消息发送到下一个 actor。默认 actor 是消息的最终预定接收方，所以如果 SOAPHeader 对象中没有包括 actor 属性，那么 message 将与消息正文一起发送到最终接收者。

在 SOAP 1.2 中，env:actor 属性应替换为 env:role 属性，但实质上语义是相同的。

参数：
actor - 一个 String，给出要搜索的 actor / role 的 URI
返回：
一个 Iterator 对象，可在所有包含指定的 actor / role 的 SOAPHeaderElement 对象上进行迭代
另请参见：
extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

extractHeaderElements

Iterator extractHeaderElements(String actor)
返回可在此 SOAPHeader 对象中所有具有指定 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。

此方法允许 actor 处理并移除适用于它的 SOAPHeader 对象部分，然后将该消息发送到下一个 actor。

在 SOAP 1.2 中，env:actor 属性应替换为 env:role 属性，但实质上语义是相同的。

参数：
actor - 一个 String，给出要搜索的 actor / role 的 URI
返回：
一个 Iterator 对象，可在所有包含指定 actor / role 的 SOAPHeaderElement 对象上进行迭代
另请参见：
examineHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

addNotUnderstoodHeaderElement

SOAPHeaderElement addNotUnderstoodHeaderElement(QName name)
                                                throws SOAPException
创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。只有 SOAP 1.2 支持此操作。

参数：
name - 带有不可理解的 SOAPHeaderElement 对象名称的 QName 对象。
返回：
插入此 SOAPHeader 对象的新的 SOAPHeaderElement 对象
抛出：
SOAPException - 如果发生 SOAP 错误。
UnsupportedOperationException - 如果这是一个 SOAP 1.1 Header。
从以下版本开始：
SAAJ 1.3

addUpgradeHeaderElement

SOAPHeaderElement addUpgradeHeaderElement(Iterator supportedSOAPURIs)
                                          throws SOAPException
创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。SOAP 1.1 头和 SOAP 1.2 头上都支持此操作。

参数：
supportedSOAPURIs - 带有受支持 SOAP 版本 URI 的 Iterator 对象。
返回：
插入此 SOAPHeader 对象的新的 SOAPHeaderElement 对象
抛出：
SOAPException - 如果发生 SOAP 错误。
从以下版本开始：
SAAJ 1.3

addUpgradeHeaderElement

SOAPHeaderElement addUpgradeHeaderElement(String[] supportedSoapUris)
                                          throws SOAPException
创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。SOAP 1.1 头和 SOAP 1.2 头上都支持此操作。

参数：
supportedSoapUris - 受支持 SOAP 版本的 URI 数组
返回：
插入此 SOAPHeader 对象的新的 SOAPHeaderElement 对象
抛出：
SOAPException - 如果发生 SOAP 错误。
从以下版本开始：
SAAJ 1.3

addUpgradeHeaderElement

SOAPHeaderElement addUpgradeHeaderElement(String supportedSoapUri)
                                          throws SOAPException
创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。SOAP 1.1 头和 SOAP 1.2 头上都支持此操作。

参数：
supportedSoapUri - 受支持 SOAP 版本的 URI。
返回：
插入此 SOAPHeader 对象的新的 SOAPHeaderElement 对象
抛出：
SOAPException - 如果发生 SOAP 错误。
从以下版本开始：
SAAJ 1.3

examineAllHeaderElements

Iterator examineAllHeaderElements()
返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator。

返回：
一个 Iterator 对象，可在此 SOAPHeader 对象包含的所有 SOAPHeaderElement 对象上进行迭代
从以下版本开始：
SAAJ 1.2
另请参见：
extractAllHeaderElements()

extractAllHeaderElements

Iterator extractAllHeaderElements()
返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。

返回：
一个 Iterator 对象，可在此 SOAPHeader 对象包含的所有 SOAPHeaderElement 对象上进行迭代
从以下版本开始：
SAAJ 1.2
另请参见：
examineAllHeaderElements()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPHeaderElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 SOAPHeaderElement

所有超级接口：
Element, Node, SOAPElement
public interface SOAPHeaderElement
extends SOAPElement

表示 SOAP 信封 SOAP 头部分的内容的对象。SOAPHeader 对象的直接子级只能用 SOAPHeaderElement 对象的形式表示。

SOAPHeaderElement 对象可以将其他 SOAPElement 对象作为其子级。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
String | getActor() 返回此 SOAPHeaderElement actor 属性的 URL。
boolean | getMustUnderstand() 返回此 SOAPHeaderElement mustUnderstand 属性的 boolean 值。
boolean | getRelay() 返回此 SOAPHeaderElement relay 属性的 boolean 值。
String | getRole() 返回此 SOAPHeaderElement Role 属性的值。
void | setActor(String actorURI) 将与此 SOAPHeaderElement 对象关联的 actor 设置为指定 actor。
void | setMustUnderstand(boolean mustUnderstand) 将此 SOAPHeaderElement 对象的 mustUnderstand 属性设置为 true 或 false。
void | setRelay(boolean relay) 将此 SOAPHeaderElement 的 relay 属性设置为 true 或 false。
void | setRole(String uri) 将与此 SOAPHeaderElement 对象关联的 Role 设置为指定 Role。
从接口 javax.xml.soap.SOAPElement 继承的方法
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Element 继承的方法
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

setActor

void setActor(String actorURI)
将与此 SOAPHeaderElement 对象关联的 actor 设置为指定 actor。actor 的默认值为：SOAPConstants.URI_SOAP_ACTOR_NEXT。

如果此 SOAPHeaderElement 支持 SOAP 1.2，则此调用等效于 setRole(String)

参数：
actorURI - 给出要设置 actor URI 的 String
抛出：
IllegalArgumentException - 如果在设置 actor 时出现问题。
另请参见：
getActor()

setRole

void setRole(String uri)
             throws SOAPException
将与此 SOAPHeaderElement 对象关联的 Role 设置为指定 Role。

参数：
uri - Role 的 URI
抛出：
SOAPException - 如果在设置 role 时出现错误
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Role。
从以下版本开始：
SAAJ 1.3

getActor

String getActor()
返回此 SOAPHeaderElement actor 属性的 URL。

如果此 SOAPHeaderElement 支持 SOAP 1.2，则此调用等效于 getRole()

返回：
给出 actor URI 的 String
另请参见：
setActor(java.lang.String)

getRole

String getRole()
返回此 SOAPHeaderElement Role 属性的值。

返回：
给出 Role URI 的 String
抛出：
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Fault Role。
从以下版本开始：
SAAJ 1.3

setMustUnderstand

void setMustUnderstand(boolean mustUnderstand)
将此 SOAPHeaderElement 对象的 mustUnderstand 属性设置为 true 或 false。

如果 mustUnderstand 属性处于开状态，则收到 SOAPHeaderElement 的 actor 必须对其进行正确处理。在 SOAPHeaderElement 对象修改消息的情况下，这可确保消息能被正确的修改。

参数：
mustUnderstand - 该参数为 true 时，将 mustUnderstand 属性设置为 true；该参数为 false 时，则将其设置为 false
抛出：
IllegalArgumentException - 如果在设置 mustUnderstand 属性时出现问题。
另请参见：
getMustUnderstand(), setRelay(boolean)

getMustUnderstand

boolean getMustUnderstand()
返回此 SOAPHeaderElement mustUnderstand 属性的 boolean 值。

返回：
如果启用了此 SOAPHeaderElement 对象的 mustUnderstand 属性，则返回 true；否则返回 false

setRelay

void setRelay(boolean relay)
              throws SOAPException
将此 SOAPHeaderElement 的 relay 属性设置为 true 或 false。

SOAP relay 属性设置为 true 指示 SOAP 头块必须通过其指定的所有节点进行中继，但实际并不处理该头块。此属性在 mustUnderstand 属性设置为 true 或被最终接收者（默认）指定的头块处被忽略。此属性的默认值为 false。

参数：
relay - relay 属性的新值
抛出：
SOAPException - 如果在设置 relay 属性时出现问题。
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Relay 属性。
从以下版本开始：
SAAJ 1.3
另请参见：
setMustUnderstand(boolean), getRelay()

getRelay

boolean getRelay()
返回此 SOAPHeaderElement relay 属性的 boolean 值。

返回：
如果 relay 属性已开启，则返回 true；否则返回 false
抛出：
UnsupportedOperationException - 如果此消息不支持 SOAP 1.2 定义的 Relay 属性。
从以下版本开始：
SAAJ 1.3
另请参见：
getMustUnderstand(), setRelay(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPMessage (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SOAPMessage

java.lang.Object
    继承者  javax.xml.soap.SOAPMessage

public abstract class SOAPMessage
extends Object

所有 SOAP 消息的根类。因为 SOAP 消息是通过“导线”传输的，所以它是 XML 文档或第一个正文部分为 XML/SOAP 文档的 MIME 消息。

SOAPMessage 对象由一个 SOAP 部分和一个或多个附件部分（可选）组成。SOAPMessage 对象的 SOAP 部分是一个 SOAPPart 对象，包含了用于消息路由和标识的信息，并可以包含特定于应用程序的内容。消息 SOAP 部分中的所有数据都必须是 XML 格式。

默认情况下，新的 SOAPMessage 对象包含以下对象：

  • 一个 SOAPPart 对象
  • 一个 SOAPEnvelope 对象
  • 一个 SOAPBody 对象
  • 一个 SOAPHeader 对象
可以通过调用方法 SOAPMessage.getSOAPPart() 检索消息的 SOAP 部分。SOAPEnvelope 对象是从 SOAPPart 对象检索的，SOAPEnvelope 对象用于检索 SOAPBody 和 SOAPHeader 对象。
SOAPPart sp = message.getSOAPPart();
SOAPEnvelope se = sp.getEnvelope();
SOAPBody sb = se.getBody();
SOAPHeader sh = se.getHeader();

除强制性 SOAPPart 对象之外，SOAPMessage 对象还可以包含零个或多个 AttachmentPart 对象，每个 AttachmentPart 对象都包含特定于应用程序的数据。SOAPMessage 接口提供了一些用于创建 AttachmentPart 对象的方法，以及一些将它们添加到 SOAPMessage 对象的方法。收到 SOAPMessage 对象的一方可以通过检索各个附件部分来检查消息内容。

与 SOAP 消息的其余部分不同，附件不需要是 XML 格式，因此可以是简单文本或图像文件等任何形式。因此，任何非 XML 格式的消息内容必须在 AttachmentPart 对象中。

MessageFactory 对象可以创建行为特定于具体 SAAJ 实现或应用程序的 SOAPMessage 对象。例如，MessageFactory 对象可以生成符合特定配置文件（如 ebXML）的 SOAPMessage 对象。在这种情况下，MessageFactory 对象可以生成使用 ebXML 头初始化的 SOAPMessage 对象。

为了确保与后向源的兼容性，在 SAAJ 规范的 1.1 版本之后添加到此类的方法都是具体而非抽象的，它们都具有默认实现。除在 JavaDocs 中有对这些方法的另行说明外，默认实现只是抛出 UnsupportedOperationException，并且 SAAJ 实现代码必须使用提供指定行为的方法重写它们。但是，只要没有声明符合初始版本之后的某些更高版本规范，遗留客户端代码就没有这种限制。可以根据 SAAJ API 的未修改后续版本来编译和/或运行扩展 SOAPMessage 类的遗留类。如果正确实现了这样的类，则对于规范的更高版本（相对于初始版本）来说，该类将继续有效。

另请参见：
MessageFactory, AttachmentPart

字段摘要
static String | CHARACTER_SET_ENCODING 指定 SOAP Message 的字符类型编码。
static String | WRITE_XML_DECLARATION 指定 SOAP Message 在发送时是否包含 XML 声明。
构造方法摘要
SOAPMessage()
方法摘要
abstract void | addAttachmentPart(AttachmentPart AttachmentPart) 将给定的 AttachmentPart 对象添加到此 SOAPMessage 对象。
abstract int | countAttachments() 获取此消息中附件数量的计数。
abstract AttachmentPart | createAttachmentPart() 创建一个新的空 AttachmentPart 对象。
AttachmentPart | createAttachmentPart(DataHandler dataHandler) 创建 AttachmentPart 对象并使用给定的 DataHandler 对象填充。
AttachmentPart | createAttachmentPart(Object content, String contentType) 创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。
abstract AttachmentPart | getAttachment(SOAPElement element) 返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。
abstract Iterator | getAttachments() 检索所有作为此 SOAPMessage 对象一部分的 AttachmentPart 对象。
abstract Iterator | getAttachments(MimeHeaders headers) 检索所有头条目匹配指定头的 AttachmentPart 对象。
abstract String | getContentDescription() 检索此 SOAPMessage 对象内容的描述。
abstract MimeHeaders | getMimeHeaders() 以与传输无关的方式返回此 SOAPMessage 对象所有特定于传输的 MIME 头。
Object | getProperty(String property) 检索指定属性的值。
SOAPBody | getSOAPBody() 获取此 SOAPMessage 对象中包含的 SOAP Body。
SOAPHeader | getSOAPHeader() 获取此 SOAPMessage 对象中包含的 SOAP Header。
abstract SOAPPart | getSOAPPart() 获取此 SOAPMessage 对象的 SOAP 部分。
abstract void | removeAllAttachments() 移除所有已经添加到此 SOAPMessage 对象的 AttachmentPart 对象。
abstract void | removeAttachments(MimeHeaders headers) 移除所有头条目匹配指定头的 AttachmentPart 对象。
abstract void | saveChanges() 使用对其所作的所有更改更新此 SOAPMessage 对象。
abstract boolean | saveRequired() 指示是否此 SOAPMessage 对象需要调用方法 saveChanges。
abstract void | setContentDescription(String description) 使用给定描述设置此 SOAPMessage 对象内容的描述。
void | setProperty(String property, Object value) 将指定值与指定属性关联。
abstract void | writeTo(OutputStream out) 将此 SOAPMessage 对象写入给定输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CHARACTER_SET_ENCODING

public static final String CHARACTER_SET_ENCODING
指定 SOAP Message 的字符类型编码。有效值包括 "utf-8" 和 "utf-16"。有关其他受支持的值，请参阅供应商文档。默认值是 "utf-8"。

从以下版本开始：
SAAJ 1.2
另请参见：
SOAPMessage.setProperty, 常量字段值

WRITE_XML_DECLARATION

public static final String WRITE_XML_DECLARATION
指定 SOAP Message 在发送时是否包含 XML 声明。仅有的有效值为 "true" 和 "false"。默认值为 "false"。

从以下版本开始：
SAAJ 1.2
另请参见：
SOAPMessage.setProperty, 常量字段值
构造方法详细信息

SOAPMessage

public SOAPMessage()
方法详细信息

setContentDescription

public abstract void setContentDescription(String description)
使用给定描述设置此 SOAPMessage 对象内容的描述。

参数：
description - 描述此消息内容的 String
另请参见：
getContentDescription()

getContentDescription

public abstract String getContentDescription()
检索此 SOAPMessage 对象内容的描述。

返回：
描述此消息内容的 String，如果没有设置描述，则返回 null
另请参见：
setContentDescription(java.lang.String)

getSOAPPart

public abstract SOAPPart getSOAPPart()
获取此 SOAPMessage 对象的 SOAP 部分。

SOAPMessage 对象包含一个或多个附件，SOAP 部分必须是消息中的第一个 MIME 正文部分。

返回：
此 SOAPMessage 对象的 SOAPPart 对象

getSOAPBody

public SOAPBody getSOAPBody()
                     throws SOAPException
获取此 SOAPMessage 对象中包含的 SOAP Body。

返回：
此 SOAPMessage 对象包含的 SOAPBody 对象
抛出：
SOAPException - 如果 SOAP Body 不存在或无法被检索
从以下版本开始：
SAAJ 1.2

getSOAPHeader

public SOAPHeader getSOAPHeader()
                         throws SOAPException
获取此 SOAPMessage 对象中包含的 SOAP Header。

返回：
此 SOAPMessage 对象包含的 SOAPHeader 对象
抛出：
SOAPException - 如果 SOAP Header 不存在或无法被检索
从以下版本开始：
SAAJ 1.2

removeAllAttachments

public abstract void removeAllAttachments()
移除所有已经添加到此 SOAPMessage 对象的 AttachmentPart 对象。

此方法不接触 SOAP 部分。

countAttachments

public abstract int countAttachments()
获取此消息中附件数量的计数。此计数不包括 SOAP 部分。

返回：
作为此 SOAPMessage 对象一部分的 AttachmentPart 对象的数量

getAttachments

public abstract Iterator getAttachments()
检索所有作为此 SOAPMessage 对象一部分的 AttachmentPart 对象。

返回：
可在此消息中所有附件上进行迭代的迭代器。

getAttachments

public abstract Iterator getAttachments(MimeHeaders headers)
检索所有头条目匹配指定头的 AttachmentPart 对象。注意，返回的附件除指定的头之外，还可以有其他头。

参数：
headers - 包含要搜索的 MIME 头的 MimeHeaders 对象
返回：
一个迭代器，可在所有头匹配任一给定头的附件上进行迭代

removeAttachments

public abstract void removeAttachments(MimeHeaders headers)
移除所有头条目匹配指定头的 AttachmentPart 对象。注意，移除的附件除指定的头之外，还可以有其他头。

参数：
headers - 包含要搜索的 MIME 头的 MimeHeaders 对象
从以下版本开始：
SAAJ 1.3

getAttachment

public abstract AttachmentPart getAttachment(SOAPElement element)
                                      throws SOAPException
返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。可以通过 SOAP Messages with Attachments 中描述的 href 属性，或者包含 WS-I Attachments Profile 1.0（用于模式类型 ref:swaRef(ref:swaRef) 的元素）中所描述的 URI 的一个 Text 子节点来进行引用。必须支持这两种机制。支持通过 href 属性获取引用同时意味着，对于作为 xop:Include 元素 (XOP) 的元素也应该支持此方法。其他引用机制可以由此标准的各个实现支持。有关详细信息，请与您的供应商联系。

参数：
element - 包含对附件引用的 SOAPElement
返回：
引用的 AttachmentPart；如果不存在此类 AttachmentPart 或在此 SOAPElement 中找不到引用，则返回 null。
抛出：
SOAPException - 如果尝试访问附件时出现错误
从以下版本开始：
SAAJ 1.3

addAttachmentPart

public abstract void addAttachmentPart(AttachmentPart AttachmentPart)
将给定的 AttachmentPart 对象添加到此 SOAPMessage 对象。必须先创建 AttachmentPart 对象，然后才能将其添加到消息。

参数：
AttachmentPart - 将作为此 SOAPMessage 对象一部分的 AttachmentPart 对象
抛出：
IllegalArgumentException

createAttachmentPart

public abstract AttachmentPart createAttachmentPart()
创建一个新的空 AttachmentPart 对象。注意，调用方法 addAttachmentPart 时必须将此新 AttachmentPart 对象作为参数，以便该对象成为此 SOAPMessage 对象的附件。

返回：
可以填充并添加到此 SOAPMessage 对象的新的 AttachmentPart 对象

createAttachmentPart

public AttachmentPart createAttachmentPart(DataHandler dataHandler)
创建 AttachmentPart 对象并使用给定的 DataHandler 对象填充。

参数：
dataHandler - 将生成此 SOAPMessage 对象内容的 javax.activation.DataHandler 对象
返回：
包含给定 DataHandler 对象生成数据的新的 AttachmentPart 对象
抛出：
IllegalArgumentException - 如果指定的 DataHandler 对象存在问题
另请参见：
DataHandler, DataContentHandler

getMimeHeaders

public abstract MimeHeaders getMimeHeaders()
以与传输无关的方式返回此 SOAPMessage 对象所有特定于传输的 MIME 头。

返回：
包含 MimeHeader 对象的 MimeHeaders 对象

createAttachmentPart

public AttachmentPart createAttachmentPart(Object content,
                                           String contentType)
创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。Object 的类型应该对应于指定给 Content-Type 的值。

参数：
content - 包含要创建的 AttachmentPart 对象内容的 Object
contentType - 给出内容类型的 String 对象；例如 "text/xml"、"text/plain" 和 "image/jpeg"
返回：
包含给定数据的新的 AttachmentPart 对象
抛出：
IllegalArgumentException - 如果 contentType 不匹配内容对象的类型，或者没有给定内容对象的 DataContentHandler 对象时抛出
另请参见：
DataHandler, DataContentHandler

saveChanges

public abstract void saveChanges()
                          throws SOAPException
使用对其所作的所有更改更新此 SOAPMessage 对象。调用 writeTo(OutputStream) 时自动调用此方法。但是，如果是对已收到或已发送的消息进行更改，则需要显式调用方法 saveChanges 保存这些更改。方法 saveChanges 还生成任何可以回读的更改（例如，支持消息 id 的配置文件中 MessageId）。只有在调用 saveChanges 之后，才能保证为发送而创建的消息中的所有 MIME 头具有有效值。

此外，此方法标记了位置点，取自所有 AttachmentPart 对象组件的数据在该点处被拉入消息。

抛出：
SOAPException - 如果在保存此消息的更改时出现问题。
SOAPException

saveRequired

public abstract boolean saveRequired()
指示是否此 SOAPMessage 对象需要调用方法 saveChanges。

返回：
如果需要调用 saveChanges，则返回 true；否则返回 false。

writeTo

public abstract void writeTo(OutputStream out)
                      throws SOAPException,
                             IOException
将此 SOAPMessage 对象写入给定输出流。具体化格式在 SOAP 1.1 with Attachments 规范中定义。

如果没有附件，则只写出 XML 流。对于有附件的消息，writeTo 写出 MIME 编码的字节流。

注意，此方法不写出特定于传输的消息的 MIME Header

参数：
out - SOAPMessage 对象将写入的 OutputStream 对象
抛出：
IOException - 如果发生 I/O 错误
SOAPException - 在具体化此 SOAP 消息时出现问题

setProperty

public void setProperty(String property,
                        Object value)
                 throws SOAPException
将指定值与指定属性关联。如果已经有与此属性关联的值，则替换旧值。

有效属性名包括 WRITE_XML_DECLARATION 和 CHARACTER_SET_ENCODING。所有这些标准 SAAJ 属性都以 "javax.xml.soap" 为前缀。供应商也可以添加特定于实现的属性。这些属性必须以供应商所独有的包名称为前缀。

将属性 WRITE_XML_DECLARATION 设置为 "true" 会导致在 SOAP 消息的起始处写出 XML Declaration。默认值 "false" 表示取消此声明。

属性 CHARACTER_SET_ENCODING 默认为值 "utf-8"，该值将导致使用 UTF-8 编码 SOAP 消息。将 CHARACTER_SET_ENCODING 设置为 "utf-16" 将导致使用 UTF-16 编码 SOAP 消息。

某些实现可能允许除 UTF-8 和 UTF-16 之外的编码。有关详细信息，请参阅供应商文档。

参数：
property - 要关联指定值的属性。
value - 要与指定属性关联的值
抛出：
SOAPException - 如果无法识别属性名。
从以下版本开始：
SAAJ 1.2

getProperty

public Object getProperty(String property)
                   throws SOAPException
检索指定属性的值。

参数：
property - 要检索的属性名称
返回：
与指定属性关联的值；如果不存在此类属性，则返回 null。
抛出：
SOAPException - 如果无法识别属性名。
从以下版本开始：
SAAJ 1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SOAPPart (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
类 SOAPPart

java.lang.Object
    继承者  javax.xml.soap.SOAPPart
所有已实现的接口：
Document, Node
public abstract class SOAPPart
extends Object
implements Document, Node

SOAPMessage 对象中特定于 SOAP 部分的容器。所有消息都必须有一个 SOAP 部分，因此 SOAPMessage 对象在创建之后将自动获得一个 SOAPPart 对象。

SOAPPart 对象是一个 MIME 部分，并具有 MIME 头 Content-Id、Content-Location 和 Content-Type。因为 Content-Type 的值必须为 "text/xml"，所以 SOAPPart 对象自动获得 Content-Type 的 MIME 头，且 Content-Type 值已设置为 "text/xml"。消息 SOAP 部分中的所有数据都必须是 XML 格式，因此值必须为 "text/xml"。不是 "text/xml" 类型的内容不能在 SOAPPart 对象中，而必须在 AttachmentPart 对象中。

发送消息时，其 SOAP 部分必须将 MIME 头 Content-Type 设置为 "text/xml"。或者换个角度来说，已收到消息的 SOAP 部分必须具有值为 "text/xml" 的 MIME 头 Content-Type。

客户端可以通过调用方法 SOAPMessage.getSOAPPart 来访问 SOAPMessage 对象的 SOAPPart 对象。以下代码行（其中 message 是一个 SOAPMessage 对象）检索消息的 SOAP 部分。

SOAPPart soapPart = message.getSOAPPart();

SOAPPart 对象包含一个 SOAPEnvelope 对象，SOAPEnvelope 对象包含一个 SOAPBody 对象和一个 SOAPHeader 对象。SOAPPart 的 getEnvelope 方法可以用于检索 SOAPEnvelope 对象。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
构造方法摘要
SOAPPart()
方法摘要
abstract void | addMimeHeader(String name, String value) 使用指定名称和值创建 MimeHeader 对象，并将其添加到此 SOAPPart 对象。
abstract Iterator | getAllMimeHeaders() 以可在 MimeHeader 对象上进行迭代的迭代器形式，检索此 SOAPPart 对象的所有头。
abstract Source | getContent() 以 JAXP Source 对象的形式返回 SOAPEnvelope 的内容。
String | getContentId() 检索名为 "Content-Id" 的 MIME 头的值。
String | getContentLocation() 检索名为 "Content-Location" 的 MIME 头的值。
abstract SOAPEnvelope | getEnvelope() 获取与此 SOAPPart 对象关联的 SOAPEnvelope 对象。
abstract Iterator | getMatchingMimeHeaders(String[] names) 检索与给定数组中的名称匹配的所有 MimeHeader 对象。
abstract String[] | getMimeHeader(String name) 获取此 SOAPPart 对象中所有由给定 String 标识的 MimeHeader 对象的值。
abstract Iterator | getNonMatchingMimeHeaders(String[] names) 检索名称与给定数组中任一名称不匹配的所有 MimeHeader 对象。
abstract void | removeAllMimeHeaders() 移除此 SOAPEnvelope 对象的所有 MimeHeader 对象。
abstract void | removeMimeHeader(String header) 移除所有与给定名称匹配的 MIME 头。
abstract void | setContent(Source source) 使用取自给定 Source 对象的数据设置 SOAPEnvelope 对象的内容。
void | setContentId(String contentId) 将名为 "Content-Id" 的 MIME 头的值设置为给定 String。
void | setContentLocation(String contentLocation) 将 MIME 头 "Content-Location" 的值设置为给定 String。
abstract void | setMimeHeader(String name, String value) 将与给定头名称匹配的第一个头条目的值更改为给定值，如果现有头都不匹配，则添加一个带有给定名称和值的新头。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.w3c.dom.Document 继承的方法
adoptNode, createAttribute, createAttributeNS, createCDATASection, createComment, createDocumentFragment, createElement, createElementNS, createEntityReference, createProcessingInstruction, createTextNode, getDoctype, getDocumentElement, getDocumentURI, getDomConfig, getElementById, getElementsByTagName, getElementsByTagNameNS, getImplementation, getInputEncoding, getStrictErrorChecking, getXmlEncoding, getXmlStandalone, getXmlVersion, importNode, normalizeDocument, renameNode, setDocumentURI, setStrictErrorChecking, setXmlStandalone, setXmlVersion
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

构造方法详细信息

SOAPPart

public SOAPPart()
方法详细信息

getEnvelope

public abstract SOAPEnvelope getEnvelope()
                                  throws SOAPException
获取与此 SOAPPart 对象关联的 SOAPEnvelope 对象。获取 SOAP 信封后，可以用此方法来获取它的内容。

返回：
此 SOAPPart 对象的 SOAPEnvelope 对象
抛出：
SOAPException - 如果存在 SOAP 错误

getContentId

public String getContentId()
检索名为 "Content-Id" 的 MIME 头的值。

返回：
一个 String，给出名为 "Content-Id" 的 MIME 头的值
另请参见：
setContentId(java.lang.String)

getContentLocation

public String getContentLocation()
检索名为 "Content-Location" 的 MIME 头的值。

返回：
一个 String，给出名为 "Content-Location" 的 MIME 头的值
另请参见：
setContentLocation(java.lang.String)

setContentId

public void setContentId(String contentId)
将名为 "Content-Id" 的 MIME 头的值设置为给定 String。

参数：
contentId - 一个 String，给出 MIME 头 "Content-Id" 的值
抛出：
IllegalArgumentException - 如果在设置内容 id 时出现问题
另请参见：
getContentId()

setContentLocation

public void setContentLocation(String contentLocation)
将 MIME 头 "Content-Location" 的值设置为给定 String。

参数：
contentLocation - 一个 String，给出 MIME 头 "Content-Location" 的值
抛出：
IllegalArgumentException - 如果在设置内容位置时出现问题。
另请参见：
getContentLocation()

removeMimeHeader

public abstract void removeMimeHeader(String header)
移除所有与给定名称匹配的 MIME 头。

参数：
header - 一个 String，给出要移除的 MIME 头的名称

removeAllMimeHeaders

public abstract void removeAllMimeHeaders()
移除此 SOAPEnvelope 对象的所有 MimeHeader 对象。

getMimeHeader

public abstract String[] getMimeHeader(String name)
获取此 SOAPPart 对象中所有由给定 String 标识的 MimeHeader 对象的值。

参数：
name - 头的名称；示例："Content-Type"
返回：
一个 String 数组，给出所有指定头的值
另请参见：
setMimeHeader(java.lang.String, java.lang.String)

setMimeHeader

public abstract void setMimeHeader(String name,
                                   String value)
将与给定头名称匹配的第一个头条目的值更改为给定值，如果现有头都不匹配，则添加一个带有给定名称和值的新头。如果有匹配的头，则此方法清除第一个匹配头的所有现有值，并设置为给定的值。如果多个头都具有给定名称，则此方法移除第一个匹配头之后的所有匹配头。

注意，RFC822 头只能包含 US-ASCII 字符。

参数：
name - 一个 String，给出要搜索的头的名称
value - 一个 String，给出要设置的值。此值将替换第一个匹配头（如果有）的当前值。如果没有匹配的头，则此值将是新 MimeHeader 对象的值。
抛出：
IllegalArgumentException - 如果指定的 mime 头名称或值存在问题
另请参见：
getMimeHeader(java.lang.String)

addMimeHeader

public abstract void addMimeHeader(String name,
                                   String value)
使用指定名称和值创建 MimeHeader 对象，并将其添加到此 SOAPPart 对象。如果已经存在带有指定名称的 MimeHeader，则此方法将指定值添加到已经存在的值中。

注意，RFC822 头只能包含 US-ASCII 字符。

参数：
name - 一个 String，给出头名称
value - 一个 String，给出要设置或要添加的值
抛出：
IllegalArgumentException - 如果指定的 mime 头名称或值存在问题

getAllMimeHeaders

public abstract Iterator getAllMimeHeaders()
以可在 MimeHeader 对象上进行迭代的迭代器形式，检索此 SOAPPart 对象的所有头。

返回：
一个 Iterator 对象，具有此 SOAPPart 对象的所有 Mime 头

getMatchingMimeHeaders

public abstract Iterator getMatchingMimeHeaders(String[] names)
检索与给定数组中的名称匹配的所有 MimeHeader 对象。

参数：
names - 一个 String 数组，带有要返回的 Mime 头的名称
返回：
以 Iterator 对象形式返回的与给定数组中任一名称匹配的所有 MIME 头

getNonMatchingMimeHeaders

public abstract Iterator getNonMatchingMimeHeaders(String[] names)
检索名称与给定数组中任一名称不匹配的所有 MimeHeader 对象。

参数：
names - 一个 String 数组，带有不要返回的 Mime 头的名称
返回：
此 SOAPPart 对象中与给定数组中任一名称匹配的 MIME 头之外的所有 MIME 头。以 Iterator 对象的形式返回不匹配的 MIME 头。

setContent

public abstract void setContent(Source source)
                         throws SOAPException
使用取自给定 Source 对象的数据设置 SOAPEnvelope 对象的内容。此 Source 必须包含一个有效的 SOAP 文档。

参数：
source - javax.xml.transform.Source 对象，带有要发送的数据
抛出：
SOAPException - 如果在设置源时出现错误。
另请参见：
getContent()

getContent

public abstract Source getContent()
                           throws SOAPException
以 JAXP Source 对象的形式返回 SOAPEnvelope 的内容。

返回：
javax.xml.transform.Source 对象形式的内容
抛出：
SOAPException - 如果实现无法转换指定的 Source 对象
另请参见：
setContent(javax.xml.transform.Source)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Text (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.soap
接口 Text

所有超级接口：
CharacterData, Node, Text
public interface Text
extends Node, Text

值为文本的节点的表示形式。Text 对象可以表示是内容注释或文本注释的文本。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
 boolean isComment()
检索此 Text 对象是否表示一个注释。
从接口 javax.xml.soap.Node 继承的方法
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
从接口 org.w3c.dom.Text 继承的方法
getWholeText, isElementContentWhitespace, replaceWholeText, splitText
从接口 org.w3c.dom.CharacterData 继承的方法
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

isComment

boolean isComment()
检索此 Text 对象是否表示一个注释。

返回：
如果此 Text 对象是一个注释，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.soap (Java Platform SE 6)

 javax.xml.soap
接口
Detail
DetailEntry
Name
Node
SOAPBody
SOAPBodyElement
SOAPConstants
SOAPElement
SOAPEnvelope
SOAPFault
SOAPFaultElement
SOAPHeader
SOAPHeaderElement
Text
类
AttachmentPart
MessageFactory
MimeHeader
MimeHeaders
SAAJMetaFactory
SAAJResult
SOAPConnection
SOAPConnectionFactory
SOAPElementFactory
SOAPFactory
SOAPMessage
SOAPPart
异常
SOAPException


javax.xml.soap (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.soap

提供用于创建和构建 SOAP 消息的 API。

请参见：
描述

接口摘要
Detail | DetailEntry 对象的容器。
DetailEntry | Detail 对象的内容，给出 SOAPFault 对象的详细信息。
Name | XML 名称的表示形式。
Node | XML 文档中节点（元素）的表示形式。
SOAPBody | 表示 SOAP 消息中 SOAP 正文元素内容的对象。
SOAPBodyElement | 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
SOAPConstants | 与 SOAP 协议有关的常量的定义。
SOAPElement | 表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
SOAPEnvelope | SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
SOAPFault | SOAPBody 对象中的元素，包含错误和/或状态信息。
SOAPFaultElement | SOAPFault 对象内容的表示形式。
SOAPHeader | SOAP 头元素的表示形式。
SOAPHeaderElement | 表示 SOAP 信封 SOAP 头部分的内容的对象。
Text | 值为文本的节点的表示形式。

类摘要
AttachmentPart | SOAPMessage 对象的一个附件。
MessageFactory | 创建 SOAPMessage 对象的工厂。
MimeHeader | 存储 MIME 头名称及其值的对象。
MimeHeaders | MimeHeader 对象的容器，这些对象表示出现在消息的 MIME 部分的 MIME 头。
SAAJMetaFactory | SAAJ API 中定义的工厂实现类的访问点。
SAAJResult | 以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。
SOAPConnection | 客户端可以用于直接将消息发送到（例如，用 URL 表示的）远程方的点对点连接。
SOAPConnectionFactory | 创建 SOAPConnection 对象的工厂。
SOAPElementFactory | 已过时。 - 使用 javax.xml.soap.SOAPFactory 创建 SOAPElements。
SOAPFactory | SOAPFactory 是用来创建存在于 SOAP XML 树中的各种对象的工厂。
SOAPMessage | 所有 SOAP 消息的根类。
SOAPPart | SOAPMessage 对象中特定于 SOAP 部分的容器。

异常摘要
SOAPException 当发生 SOAP 异常时，抛出此异常。

软件包 javax.xml.soap 的描述

提供用于创建和构建 SOAP 消息的 API。此包在 SOAP with Attachments API for JavaTM (SAAJ) 1.3 规范中进行了定义。

javax.xml.soap 包中的 API 允许执行以下操作：

  • 创建到指定端点的点对点连接
  • 创建 SOAP 消息
  • 创建 XML 片段
  • 将内容添加到 SOAP 消息的头
  • 将内容添加到 SOAP 消息的正文
  • 创建附件部分并向其添加内容
  • 访问/添加/修改 SOAP 消息的一部分
  • 创建/添加/修改 SOAP 错误信息
  • 提取 SOAP 消息的内容
  • 发送 SOAP 请求-响应消息

此外，javax.xml.soap 包中的 API 在 org.w3c.dom 包中扩展了它们的对等项。这意味着 SOAPMessage 的 SOAPPart 也是一个 DOM Level 2 Document，它同样可以由使用 DOM 的应用程序、工具和库来操纵（有关更多信息，请参阅 http://www.w3.org/DOM/）。务必注意，虽然可以使用 DOM API 将普通的 DOM 节点添加到 SAAJ 树，但在检查或操纵树时，SAAJ API 仍需要返回 SAAJ 类型。要实现这一点，应允许 SAAJ API（特别是 SOAPElement.getChildElements()）用所需类型的等效对象正常地替换相对于 SAAJ 需求来说未正确类型化的对象。这些替换一定不能导致树的逻辑结构发生更改，所以从 DOM API 的角度来看，树将保持不变。但是，树的物理混合将更改，从而对被替换的节点的引用将引用不再是树的一部分的节点。如果不需要，则不允许 SAAJ API 进行这些替换，因此替换对象以后就不会被 SAAJ API 的后续调用正常地替换。

这实际上意味着，在使用 DOM API 操纵树之后，开始使用 SAAJ API 来操纵树的应用程序必须假定该树已转换为一个纯 SAAJ 树，并且使用 DOM API 获取的对树中对象的任何引用不再有效。从 SAAJ API 切换到 DOM API 不会导致无效引用，独占地使用 SAAJ API 也不会导致无效引用。只有从在特定 SAAJ 树上使用 DOM API 切换到使用 SAAJ API 时，才有导致无效引用的风险。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.soap 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.soap 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.soap.AttachmentPart
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.xml.soap.MessageFactory
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.xml.soap.SAAJMetaFactory
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.soap.SOAPException

接口分层结构

  • javax.xml.soap.Name
  • org.w3c.dom.Node
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Text
        • javax.xml.soap.Text (并 extends javax.xml.soap.Node)
    • org.w3c.dom.Element
      • javax.xml.soap.SOAPElement (并 extends javax.xml.soap.Node)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.Node
      • javax.xml.soap.SOAPElement (并 extends org.w3c.dom.Element)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (并 extends org.w3c.dom.Text)
  • javax.xml.soap.SOAPConstants
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.soap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.soap
的使用

使用 javax.xml.soap 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.soap 使用的 javax.xml.soap 中的类
AttachmentPart
SOAPMessage 对象的一个附件。
Detail
DetailEntry 对象的容器。
DetailEntry
Detail 对象的内容，给出 SOAPFault 对象的详细信息。
MessageFactory
创建 SOAPMessage 对象的工厂。
MimeHeaders
MimeHeader 对象的容器，这些对象表示出现在消息的 MIME 部分的 MIME 头。
Name
XML 名称的表示形式。
Node
XML 文档中节点（元素）的表示形式。
SOAPBody
表示 SOAP 消息中 SOAP 正文元素内容的对象。
SOAPBodyElement
表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
SOAPConnection
客户端可以用于直接将消息发送到（例如，用 URL 表示的）远程方的点对点连接。
SOAPConnectionFactory
创建 SOAPConnection 对象的工厂。
SOAPElement
表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
SOAPElementFactory
已过时。 - 使用 javax.xml.soap.SOAPFactory 创建 SOAPElements。
SOAPEnvelope
SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
SOAPException
当发生 SOAP 异常时，抛出此异常。
SOAPFactory
SOAPFactory 是用来创建存在于 SOAP XML 树中的各种对象的工厂。
SOAPFault
SOAPBody 对象中的元素，包含错误和/或状态信息。
SOAPFaultElement
SOAPFault 对象内容的表示形式。
SOAPHeader
SOAP 头元素的表示形式。
SOAPHeaderElement
表示 SOAP 信封 SOAP 头部分的内容的对象。
SOAPMessage
所有 SOAP 消息的根类。
SOAPPart
SOAPMessage 对象中特定于 SOAP 部分的容器。

javax.xml.ws.handler.soap 使用的 javax.xml.soap 中的类
SOAPMessage
所有 SOAP 消息的根类。

javax.xml.ws.soap 使用的 javax.xml.soap 中的类
MessageFactory
创建 SOAPMessage 对象的工厂。
SOAPFactory
SOAPFactory 是用来创建存在于 SOAP XML 树中的各种对象的工厂。
SOAPFault
SOAPBody 对象中的元素，包含错误和/或状态信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.AttachmentPart 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.AttachmentPart
的使用

使用 AttachmentPart 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 AttachmentPart 的使用

返回 AttachmentPart 的 javax.xml.soap 中的方法
abstract AttachmentPart | SOAPMessage.createAttachmentPart() 创建一个新的空 AttachmentPart 对象。
AttachmentPart | SOAPMessage.createAttachmentPart(DataHandler dataHandler) 创建 AttachmentPart 对象并使用给定的 DataHandler 对象填充。
AttachmentPart | SOAPMessage.createAttachmentPart(Object content, String contentType) 创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。
abstract AttachmentPart | SOAPMessage.getAttachment(SOAPElement element) 返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。

参数类型为 AttachmentPart 的 javax.xml.soap 中的方法
abstract  void SOAPMessage.addAttachmentPart(AttachmentPart AttachmentPart)
将给定的 AttachmentPart 对象添加到此 SOAPMessage 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.Detail 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.Detail
的使用

使用 Detail 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 Detail 的使用

返回 Detail 的 javax.xml.soap 中的方法
Detail | SOAPFault.addDetail() 创建可选的 Detail 对象，并将其设置为此 SOAPFault 对象的 Detail 对象。
abstract Detail | SOAPFactory.createDetail() 创建充当 DetailEntry 对象容器的新 Detail 对象。
Detail | SOAPFault.getDetail() 返回此 SOAPFault 对象的可选 detail 元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.DetailEntry 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.DetailEntry
的使用

使用 DetailEntry 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 DetailEntry 的使用

返回 DetailEntry 的 javax.xml.soap 中的方法
DetailEntry | Detail.addDetailEntry(Name name) 使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
DetailEntry | Detail.addDetailEntry(QName qname) 使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.MessageFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.MessageFactory
的使用

使用 MessageFactory 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.soap 中 MessageFactory 的使用

返回 MessageFactory 的 javax.xml.soap 中的方法
static MessageFactory | MessageFactory.newInstance() 创建新的 MessageFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static MessageFactory | MessageFactory.newInstance(String protocol) 创建新的 MessageFactory 对象，该对象是指定实现的实例。
protected abstract MessageFactory | SAAJMetaFactory.newMessageFactory(String protocol) 创建给定 String 协议的 MessageFactory 对象。

javax.xml.ws.soap 中 MessageFactory 的使用

返回 MessageFactory 的 javax.xml.ws.soap 中的方法
 MessageFactory SOAPBinding.getMessageFactory()
获取此 SOAP 绑定使用的 SAAJ MessageFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.MimeHeader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.MimeHeader
的使用

没有 javax.xml.soap.MimeHeader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.MimeHeaders 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.MimeHeaders
的使用

使用 MimeHeaders 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 MimeHeaders 的使用

返回 MimeHeaders 的 javax.xml.soap 中的方法
abstract  MimeHeaders SOAPMessage.getMimeHeaders()
以与传输无关的方式返回此 SOAPMessage 对象所有特定于传输的 MIME 头。

参数类型为 MimeHeaders 的 javax.xml.soap 中的方法
abstract SOAPMessage | MessageFactory.createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
abstract Iterator | SOAPMessage.getAttachments(MimeHeaders headers) 检索所有头条目匹配指定头的 AttachmentPart 对象。
abstract void | SOAPMessage.removeAttachments(MimeHeaders headers) 移除所有头条目匹配指定头的 AttachmentPart 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.Name 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.Name
的使用

使用 Name 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 Name 的使用

返回 Name 的 javax.xml.soap 中的方法
Name | SOAPEnvelope.createName(String localName) 创建使用给定本地名称初始化的新 Name 对象。
abstract Name | SOAPFactory.createName(String localName) 创建使用给定本地名称初始化的新 Name 对象。
Name | SOAPEnvelope.createName(String localName, String prefix, String uri) 创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。
abstract Name | SOAPFactory.createName(String localName, String prefix, String uri) 创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。
Name | SOAPElement.getElementName() 返回此 SOAPElement 对象的名称。
Name | SOAPFault.getFaultCodeAsName() 以 SAAJ Name 对象形式获取此 SOAPFault 对象的强制性 SOAP 1.1 错误代码。

参数类型为 Name 的 javax.xml.soap 中的方法
 SOAPElement SOAPElement.addAttribute(Name name, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPBodyElement SOAPBody.addBodyElement(Name name)
使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
 SOAPElement SOAPElement.addChildElement(Name name)
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 DetailEntry Detail.addDetailEntry(Name name)
使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
 SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPElement SOAPElementFactory.create(Name name)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
abstract  SOAPElement SOAPFactory.createElement(Name name)
创建使用给定 Name 对象初始化的 SOAPElement 对象。
 String SOAPElement.getAttributeValue(Name name)
返回带有指定名称的属性值。
 Iterator SOAPElement.getChildElements(Name name)
返回可在带有指定名称的此元素所有直接子 Node 上进行迭代的 Iterator。
 boolean SOAPElement.removeAttribute(Name name)
移除带有指定名称的属性。
 void SOAPFault.setFaultCode(Name faultCodeQName)
使用给定的错误代码设置此 SOAPFault 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.Node 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.Node
的使用

使用 Node 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 Node 的使用

javax.xml.soap 中 Node 的子接口
interface | Detail DetailEntry 对象的容器。
interface | DetailEntry Detail 对象的内容，给出 SOAPFault 对象的详细信息。
interface | SOAPBody 表示 SOAP 消息中 SOAP 正文元素内容的对象。
interface | SOAPBodyElement 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
interface | SOAPElement 表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
interface | SOAPEnvelope SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
interface | SOAPFault SOAPBody 对象中的元素，包含错误和/或状态信息。
interface | SOAPFaultElement SOAPFault 对象内容的表示形式。
interface | SOAPHeader SOAP 头元素的表示形式。
interface | SOAPHeaderElement 表示 SOAP 信封 SOAP 头部分的内容的对象。
interface | Text 值为文本的节点的表示形式。

返回 Node 的 javax.xml.soap 中的方法
 Node SAAJResult.getResult()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SAAJMetaFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SAAJMetaFactory
的使用

没有 javax.xml.soap.SAAJMetaFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SAAJResult 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SAAJResult
的使用

没有 javax.xml.soap.SAAJResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPBody 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPBody
的使用

使用 SOAPBody 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPBody 的使用

返回 SOAPBody 的 javax.xml.soap 中的方法
SOAPBody | SOAPEnvelope.addBody() 创建一个 SOAPBody 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPBody 对象。
SOAPBody | SOAPEnvelope.getBody() 返回与此 SOAPEnvelope 对象关联的 SOAPBody 对象。
SOAPBody | SOAPMessage.getSOAPBody() 获取此 SOAPMessage 对象中包含的 SOAP Body。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPBodyElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPBodyElement
的使用

使用 SOAPBodyElement 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPBodyElement 的使用

javax.xml.soap 中 SOAPBodyElement 的子接口
 interface SOAPFault
SOAPBody 对象中的元素，包含错误和/或状态信息。

返回 SOAPBodyElement 的 javax.xml.soap 中的方法
SOAPBodyElement | SOAPBody.addBodyElement(Name name) 使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
SOAPBodyElement | SOAPBody.addBodyElement(QName qname) 使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
SOAPBodyElement | SOAPBody.addDocument(Document document) 将 DOM Document 的根节点添加到此 SOAPBody 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SOAPConnection 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPConnection
的使用

使用 SOAPConnection 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPConnection 的使用

返回 SOAPConnection 的 javax.xml.soap 中的方法
abstract  SOAPConnection SOAPConnectionFactory.createConnection()
创建新的 SOAPConnection。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SOAPConnectionFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPConnectionFactory
的使用

使用 SOAPConnectionFactory 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPConnectionFactory 的使用

返回 SOAPConnectionFactory 的 javax.xml.soap 中的方法
static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
创建默认 SOAPConnectionFactory 对象的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPConstants
的使用

没有 javax.xml.soap.SOAPConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPElement
的使用

使用 SOAPElement 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPElement 的使用

javax.xml.soap 中 SOAPElement 的子接口
interface | Detail DetailEntry 对象的容器。
interface | DetailEntry Detail 对象的内容，给出 SOAPFault 对象的详细信息。
interface | SOAPBody 表示 SOAP 消息中 SOAP 正文元素内容的对象。
interface | SOAPBodyElement 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
interface | SOAPEnvelope SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
interface | SOAPFault SOAPBody 对象中的元素，包含错误和/或状态信息。
interface | SOAPFaultElement SOAPFault 对象内容的表示形式。
interface | SOAPHeader SOAP 头元素的表示形式。
interface | SOAPHeaderElement 表示 SOAP 信封 SOAP 头部分的内容的对象。

返回 SOAPElement 的 javax.xml.soap 中的方法
 SOAPElement SOAPElement.addAttribute(Name name, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addAttribute(QName qname, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(Name name)
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(QName qname)
创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(SOAPElement element)
将 SOAPElement 作为此 SOAPElement 实例的子级添加。
 SOAPElement SOAPElement.addChildElement(String localName)
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(String localName, String prefix)
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addTextNode(String text)
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。
 SOAPElement SOAPElementFactory.create(Name name)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
 SOAPElement SOAPElementFactory.create(String localName)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换
 SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换
 SOAPElement SOAPFactory.createElement(Element domElement)
根据现有的 DOM Element 创建 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(Name name)
创建使用给定 Name 对象初始化的 SOAPElement 对象。
 SOAPElement SOAPFactory.createElement(QName qname)
创建使用给定 QName 对象初始化的 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(String localName)
创建使用给定本地名称初始化的 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。
 SOAPElement Node.getParentElement()
返回此 Node 对象的父元素。
 SOAPElement SOAPElement.setElementQName(QName newName)
如果可能，将此 Element 的名称更改为 newName。

参数类型为 SOAPElement 的 javax.xml.soap 中的方法
SOAPElement | SOAPElement.addChildElement(SOAPElement element) 将 SOAPElement 作为此 SOAPElement 实例的子级添加。
abstract AttachmentPart | SOAPMessage.getAttachment(SOAPElement element) 返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。
void | Node.setParentElement(SOAPElement parent) 将此 Node 对象的父节点设置为给定的 SOAPElement 对象。

参数类型为 SOAPElement 的 javax.xml.soap 中的构造方法
SAAJResult(SOAPElement rootNode)
创建一个 SAAJResult，它会将结果编写为指定 SOAPElement 的子节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SOAPElementFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPElementFactory
的使用

使用 SOAPElementFactory 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPElementFactory 的使用

返回 SOAPElementFactory 的 javax.xml.soap 中的方法
static SOAPElementFactory SOAPElementFactory.newInstance()
已过时。 创建新的 SOAPElementFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPEnvelope 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPEnvelope
的使用

使用 SOAPEnvelope 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPEnvelope 的使用

返回 SOAPEnvelope 的 javax.xml.soap 中的方法
abstract  SOAPEnvelope SOAPPart.getEnvelope()
获取与此 SOAPPart 对象关联的 SOAPEnvelope 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SOAPException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPException
的使用

使用 SOAPException 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPException 的使用

抛出 SOAPException 的 javax.xml.soap 中的方法
 SOAPElement SOAPElement.addAttribute(Name name, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addAttribute(QName qname, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。
 SOAPBody SOAPEnvelope.addBody()
创建一个 SOAPBody 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPBody 对象。
 SOAPBodyElement SOAPBody.addBodyElement(Name name)
使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
 SOAPBodyElement SOAPBody.addBodyElement(QName qname)
使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
 SOAPElement SOAPElement.addChildElement(Name name)
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(QName qname)
创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(SOAPElement element)
将 SOAPElement 作为此 SOAPElement 实例的子级添加。
 SOAPElement SOAPElement.addChildElement(String localName)
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(String localName, String prefix)
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 SOAPElement SOAPElement.addChildElement(String localName, String prefix, String uri)
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
 Detail SOAPFault.addDetail()
创建可选的 Detail 对象，并将其设置为此 SOAPFault 对象的 Detail 对象。
 DetailEntry Detail.addDetailEntry(Name name)
使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
 DetailEntry Detail.addDetailEntry(QName qname)
使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
 SOAPBodyElement SOAPBody.addDocument(Document document)
将 DOM Document 的根节点添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault()
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(Name faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(QName faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 SOAPFault SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
 void SOAPFault.addFaultReasonText(String text, Locale locale)
追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。
 SOAPHeader SOAPEnvelope.addHeader()
创建一个 SOAPHeader 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPHeader 对象。
 SOAPHeaderElement SOAPHeader.addHeaderElement(Name name)
创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPHeaderElement SOAPHeader.addHeaderElement(QName qname)
创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPElement SOAPElement.addNamespaceDeclaration(String prefix, String uri)
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。
 SOAPHeaderElement SOAPHeader.addNotUnderstoodHeaderElement(QName name)
创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPElement SOAPElement.addTextNode(String text)
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。
 SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
 void SOAPFault.appendFaultSubcode(QName subcode)
将 Subcode 添加到此 SOAPFault 包含的 Subcode 序列的末尾。
abstract  SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
将给定消息发送到指定端点，在返回应答前将一直阻塞。
abstract  void SOAPConnection.close()
关闭此 SOAPConnection 对象。
 SOAPElement SOAPElementFactory.create(Name name)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
 SOAPElement SOAPElementFactory.create(String localName)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换
 SOAPElement SOAPElementFactory.create(String localName, String prefix, String uri)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换
abstract  SOAPConnection SOAPConnectionFactory.createConnection()
创建新的 SOAPConnection。
abstract  Detail SOAPFactory.createDetail()
创建充当 DetailEntry 对象容器的新 Detail 对象。
 SOAPElement SOAPFactory.createElement(Element domElement)
根据现有的 DOM Element 创建 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(Name name)
创建使用给定 Name 对象初始化的 SOAPElement 对象。
 SOAPElement SOAPFactory.createElement(QName qname)
创建使用给定 QName 对象初始化的 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(String localName)
创建使用给定本地名称初始化的 SOAPElement 对象。
abstract  SOAPElement SOAPFactory.createElement(String localName, String prefix, String uri)
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。
abstract  SOAPFault SOAPFactory.createFault()
创建一个新的默认 SOAPFault 对象
abstract  SOAPFault SOAPFactory.createFault(String reasonText, QName faultCode)
创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
abstract  SOAPMessage MessageFactory.createMessage()
使用默认的 SOAPPart、SOAPEnvelope、SOAPBody 和 SOAPHeader 对象创建新的 SOAPMessage 对象。
abstract  SOAPMessage MessageFactory.createMessage(MimeHeaders headers, InputStream in)
将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
 Name SOAPEnvelope.createName(String localName)
创建使用给定本地名称初始化的新 Name 对象。
abstract  Name SOAPFactory.createName(String localName)
创建使用给定本地名称初始化的新 Name 对象。
 Name SOAPEnvelope.createName(String localName, String prefix, String uri)
创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。
abstract  Name SOAPFactory.createName(String localName, String prefix, String uri)
创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。
 QName SOAPElement.createQName(String localName, String prefix)
创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。
 Document SOAPBody.extractContentAsDocument()
创建新的 DOM Document，并将此 SOAPBody 的第一个子元素设置为它的文档元素。
 SOAPMessage SOAPConnection.get(Object to)
从特定端点获取消息，在收到消息前将一直阻塞。
abstract  AttachmentPart SOAPMessage.getAttachment(SOAPElement element)
返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。
abstract  InputStream AttachmentPart.getBase64Content()
以 Base64 编码字符数据的形式返回可用于获取 AttachmentPart 内容的 InputStream，此方法将对附件的原始字节进行 Base64 编码，然后返回该内容。
 SOAPBody SOAPEnvelope.getBody()
返回与此 SOAPEnvelope 对象关联的 SOAPBody 对象。
abstract  Object AttachmentPart.getContent()
以 Java 对象的形式获取此 AttachmentPart 对象的内容。
abstract  Source SOAPPart.getContent()
以 JAXP Source 对象的形式返回 SOAPEnvelope 的内容。
abstract  DataHandler AttachmentPart.getDataHandler()
获取针对此 AttachmentPart 对象的 DataHandler 对象。
abstract  SOAPEnvelope SOAPPart.getEnvelope()
获取与此 SOAPPart 对象关联的 SOAPEnvelope 对象。
 Iterator SOAPFault.getFaultReasonLocales()
返回一个 Iterator，它可以在与 Reason Text 项关联的 Locale 独特序列上进行迭代。
 String SOAPFault.getFaultReasonText(Locale locale)
返回与给定 Locale 关联的 Reason Text。
 Iterator SOAPFault.getFaultReasonTexts()
返回一个 Iterator，它可以在包含此 SOAPFault 所有 Reason Text 项的 String 对象序列上进行迭代。
 SOAPHeader SOAPEnvelope.getHeader()
返回此 SOAPEnvelope 对象的 SOAPHeader 对象。
 Object SOAPMessage.getProperty(String property)
检索指定属性的值。
abstract  InputStream AttachmentPart.getRawContent()
以 InputStream 的形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
abstract  byte[] AttachmentPart.getRawContentBytes()
以 byte[] 数组形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
abstract  int AttachmentPart.getSize()
返回此 AttachmentPart 对象中的字节数。
 SOAPBody SOAPMessage.getSOAPBody()
获取此 SOAPMessage 对象中包含的 SOAP Body。
 SOAPHeader SOAPMessage.getSOAPHeader()
获取此 SOAPMessage 对象中包含的 SOAP Header。
static MessageFactory MessageFactory.newInstance()
创建新的 MessageFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
创建默认 SOAPConnectionFactory 对象的实例。
static SOAPElementFactory SOAPElementFactory.newInstance()
已过时。 创建新的 SOAPElementFactory 实例。
static SOAPFactory SOAPFactory.newInstance()
创建新的 SOAPFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static MessageFactory MessageFactory.newInstance(String protocol)
创建新的 MessageFactory 对象，该对象是指定实现的实例。
static SOAPFactory SOAPFactory.newInstance(String protocol)
创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。
protected abstract  MessageFactory SAAJMetaFactory.newMessageFactory(String protocol)
创建给定 String 协议的 MessageFactory 对象。
protected abstract  SOAPFactory SAAJMetaFactory.newSOAPFactory(String protocol)
创建给定 String 协议的 SOAPFactory 对象。
abstract  void SOAPMessage.saveChanges()
使用对其所作的所有更改更新此 SOAPMessage 对象。
abstract  void AttachmentPart.setBase64Content(InputStream content, String contentType)
根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。
abstract  void SOAPPart.setContent(Source source)
使用取自给定 Source 对象的数据设置 SOAPEnvelope 对象的内容。
 SOAPElement SOAPElement.setElementQName(QName newName)
如果可能，将此 Element 的名称更改为 newName。
 void SOAPElement.setEncodingStyle(String encodingStyle)
将此 SOAPElement 对象的编码样式设置为指定样式。
 void SOAPFault.setFaultActor(String faultActor)
使用给定的错误参与者 (actor) 设置此 SOAPFault 对象。
 void SOAPFault.setFaultCode(Name faultCodeQName)
使用给定的错误代码设置此 SOAPFault 对象。
 void SOAPFault.setFaultCode(QName faultCodeQName)
使用给定的错误代码设置此 SOAPFault 对象。
 void SOAPFault.setFaultCode(String faultCode)
使用给定的错误代码设置此 SOAPFault 对象。
 void SOAPFault.setFaultNode(String uri)
创建或替换此 SOAPFault 对象的任何现有 Node 元素。
 void SOAPFault.setFaultRole(String uri)
创建或替换此 SOAPFault 对象的任何现有 Role 元素。
 void SOAPFault.setFaultString(String faultString)
将此 SOAPFault 对象的错误字符串设定为给定字符串。
 void SOAPFault.setFaultString(String faultString, Locale locale)
将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。
 void Node.setParentElement(SOAPElement parent)
将此 Node 对象的父节点设置为给定的 SOAPElement 对象。
 void SOAPMessage.setProperty(String property, Object value)
将指定值与指定属性关联。
abstract  void AttachmentPart.setRawContent(InputStream content, String contentType)
将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
abstract  void AttachmentPart.setRawContentBytes(byte[] content, int offset, int len, String contentType)
将此附件部分的内容设置为 byte[] 数组 content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
 void SOAPHeaderElement.setRelay(boolean relay)
将此 SOAPHeaderElement 的 relay 属性设置为 true 或 false。
 void SOAPHeaderElement.setRole(String uri)
将与此 SOAPHeaderElement 对象关联的 Role 设置为指定 Role。
abstract  void SOAPMessage.writeTo(OutputStream out)
将此 SOAPMessage 对象写入给定输出流。

抛出 SOAPException 的 javax.xml.soap 中的构造方法
SAAJResult()
创建一个 SAAJResult，此类将以支持默认 (SOAP 1.1) 协议的 SAAJ 树的形式显示结果。
SAAJResult(String protocol)
创建一个 SAAJResult，它将以支持指定协议的 SAAJ 树的形式显示结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SOAPFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPFactory
的使用

使用 SOAPFactory 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.soap 中 SOAPFactory 的使用

返回 SOAPFactory 的 javax.xml.soap 中的方法
static SOAPFactory | SOAPFactory.newInstance() 创建新的 SOAPFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
static SOAPFactory | SOAPFactory.newInstance(String protocol) 创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。
protected abstract SOAPFactory | SAAJMetaFactory.newSOAPFactory(String protocol) 创建给定 String 协议的 SOAPFactory 对象。

javax.xml.ws.soap 中 SOAPFactory 的使用

返回 SOAPFactory 的 javax.xml.ws.soap 中的方法
 SOAPFactory SOAPBinding.getSOAPFactory()
获取此 SOAP 绑定使用的 SAAJ SOAPFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPFault 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPFault
的使用

使用 SOAPFault 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.soap 中 SOAPFault 的使用

返回 SOAPFault 的 javax.xml.soap 中的方法
SOAPFault | SOAPBody.addFault() 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(Name faultCode, String faultString) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(Name faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
abstract SOAPFault | SOAPFactory.createFault() 创建一个新的默认 SOAPFault 对象
abstract SOAPFault | SOAPFactory.createFault(String reasonText, QName faultCode) 创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
SOAPFault | SOAPBody.getFault() 返回此 SOAPBody 对象中的 SOAPFault 对象。

javax.xml.ws.soap 中 SOAPFault 的使用

返回 SOAPFault 的 javax.xml.ws.soap 中的方法
 SOAPFault SOAPFaultException.getFault()
获取嵌入的 SOAPFault 实例。

参数类型为 SOAPFault 的 javax.xml.ws.soap 中的构造方法
SOAPFaultException(SOAPFault fault)
SOAPFaultException 的构造方法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPFaultElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPFaultElement
的使用

使用 SOAPFaultElement 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPFaultElement 的使用

javax.xml.soap 中 SOAPFaultElement 的子接口
 interface Detail
DetailEntry 对象的容器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPHeader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPHeader
的使用

使用 SOAPHeader 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPHeader 的使用

返回 SOAPHeader 的 javax.xml.soap 中的方法
SOAPHeader | SOAPEnvelope.addHeader() 创建一个 SOAPHeader 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPHeader 对象。
SOAPHeader | SOAPEnvelope.getHeader() 返回此 SOAPEnvelope 对象的 SOAPHeader 对象。
SOAPHeader | SOAPMessage.getSOAPHeader() 获取此 SOAPMessage 对象中包含的 SOAP Header。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.SOAPHeaderElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.SOAPHeaderElement
的使用

使用 SOAPHeaderElement 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPHeaderElement 的使用

返回 SOAPHeaderElement 的 javax.xml.soap 中的方法
SOAPHeaderElement | SOAPHeader.addHeaderElement(Name name) 创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addHeaderElement(QName qname) 创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addNotUnderstoodHeaderElement(QName name) 创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs) 创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri) 创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris) 创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SOAPMessage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPMessage
的使用

使用 SOAPMessage 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.soap 中 SOAPMessage 的使用

返回 SOAPMessage 的 javax.xml.soap 中的方法
abstract SOAPMessage | SOAPConnection.call(SOAPMessage request, Object to) 将给定消息发送到指定端点，在返回应答前将一直阻塞。
abstract SOAPMessage | MessageFactory.createMessage() 使用默认的 SOAPPart、SOAPEnvelope、SOAPBody 和 SOAPHeader 对象创建新的 SOAPMessage 对象。
abstract SOAPMessage | MessageFactory.createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
SOAPMessage | SOAPConnection.get(Object to) 从特定端点获取消息，在收到消息前将一直阻塞。

参数类型为 SOAPMessage 的 javax.xml.soap 中的方法
abstract  SOAPMessage SOAPConnection.call(SOAPMessage request, Object to)
将给定消息发送到指定端点，在返回应答前将一直阻塞。

参数类型为 SOAPMessage 的 javax.xml.soap 中的构造方法
SAAJResult(SOAPMessage message)
创建一个 SAAJResult，它会将结果写入提供的 SOAPMessage 的 SOAPPart 中。

javax.xml.ws.handler.soap 中 SOAPMessage 的使用

返回 SOAPMessage 的 javax.xml.ws.handler.soap 中的方法
 SOAPMessage SOAPMessageContext.getMessage()
从此消息上下文中获取 SOAPMessage。

参数类型为 SOAPMessage 的 javax.xml.ws.handler.soap 中的方法
 void SOAPMessageContext.setMessage(SOAPMessage message)
在此消息上下文中设置 SOAPMessage。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.soap.SOAPPart 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.soap.SOAPPart
的使用

使用 SOAPPart 的软件包
javax.xml.soap 提供用于创建和构建 SOAP 消息的 API。

javax.xml.soap 中 SOAPPart 的使用

返回 SOAPPart 的 javax.xml.soap 中的方法
abstract  SOAPPart SOAPMessage.getSOAPPart()
获取此 SOAPMessage 对象的 SOAP 部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.soap.Text 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.soap.Text
的使用

没有 javax.xml.soap.Text 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AsyncHandler (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
接口 AsyncHandler<T>

public interface AsyncHandler<T>

AsyncHandler 接口由希望接收关于完成了异步调用服务端点操作的回调通知的客户端实现。

从以下版本开始：
JAX-WS 2.0

方法摘要
 void handleResponse(Response<T> res)
当可以获得对异步操作的响应时调用。

方法详细信息

handleResponse

void handleResponse(Response<T> res)
当可以获得对异步操作的响应时调用。

参数：
res - 对操作调用的响应。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Binding (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
接口 Binding

所有已知子接口：
HTTPBinding, SOAPBinding
public interface Binding

Binding 接口是 JAX-WS 协议绑定的基本接口。

从以下版本开始：
JAX-WS 2.0

方法摘要
List<Handler> | getHandlerChain() 获取协议绑定实例处理程序链的副本。
void | setHandlerChain(List<Handler> chain) 设置协议绑定实例的处理程序链。

方法详细信息

getHandlerChain

List<Handler> getHandlerChain()
获取协议绑定实例处理程序链的副本。如果返回的链已修改，则需要调用 setHandlerChain 以使用新链配置绑定实例。

返回：
java.util.List Handler 链

setHandlerChain

void setHandlerChain(List<Handler> chain)
设置协议绑定实例的处理程序链。

参数：
chain - 处理程序配置条目的列表
抛出：
WebServiceException - 处理程序链的配置发生错误
UnsupportedOperationException - 如果不支持该操作。可以执行该操作以避免重写任何预先配置的处理程序链。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingProvider (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
接口 BindingProvider

所有已知子接口：
Dispatch<T>
public interface BindingProvider

BindingProvider 接口提供对用于请求和响应消息处理的协议绑定及关联上下文对象的访问。

从以下版本开始：
JAX-WS 2.0
另请参见：
Binding

字段摘要
static String | ENDPOINT_ADDRESS_PROPERTY 标准属性：目标服务端点地址。
static String | PASSWORD_PROPERTY 标准属性：用于验证的密码。
static String | SESSION_MAINTAIN_PROPERTY 标准属性：服务客户端使用此 boolean 属性指示它是否希望参与与服务端点的会话。
static String | SOAPACTION_URI_PROPERTY SOAPAction 的标准属性。
static String | SOAPACTION_USE_PROPERTY SOAPAction 的标准属性。
static String | USERNAME_PROPERTY 标准属性：用于验证的用户名。
方法摘要
Binding | getBinding() 获取此绑定提供者的 Binding。
Map<String,Object> | getRequestContext() 获取用于初始化请求消息的消息上下文的上下文。
Map<String,Object> | getResponseContext() 获取处理响应消息所得的上下文。

字段详细信息

USERNAME_PROPERTY

static final String USERNAME_PROPERTY
标准属性：用于验证的用户名。

类型：java.lang.String

另请参见：
常量字段值

PASSWORD_PROPERTY

static final String PASSWORD_PROPERTY
标准属性：用于验证的密码。

类型：java.lang.String

另请参见：
常量字段值

ENDPOINT_ADDRESS_PROPERTY

static final String ENDPOINT_ADDRESS_PROPERTY
标准属性：目标服务端点地址。端点地址规范的 URI 方案必须符合所使用绑定的协议/传输绑定。

类型：java.lang.String

另请参见：
常量字段值

SESSION_MAINTAIN_PROPERTY

static final String SESSION_MAINTAIN_PROPERTY
标准属性：服务客户端使用此 boolean 属性指示它是否希望参与与服务端点的会话。如果此属性设置为 true，则服务客户端指示它想保持会话。如果设置为 false，则不保持会话。此属性的默认值为 false。

类型：java.lang.Boolean

另请参见：
常量字段值

SOAPACTION_USE_PROPERTY

static final String SOAPACTION_USE_PROPERTY
SOAPAction 的标准属性。此 boolean 属性指示是否使用 SOAPAction。此属性的默认值为 false，指示不使用 SOAPAction。

类型：java.lang.Boolean

另请参见：
常量字段值

SOAPACTION_URI_PROPERTY

static final String SOAPACTION_URI_PROPERTY
SOAPAction 的标准属性。如果 javax.xml.ws.soap.http.soapaction.use 属性设置为 true，则指示 SOAPAction URI。

类型：java.lang.String

另请参见：
常量字段值
方法详细信息

getRequestContext

Map<String,Object> getRequestContext()
获取用于初始化请求消息的消息上下文的上下文。 对请求上下文进行的修改并不影响已经启动的同步或异步操作的消息上下文。

返回：
在处理请求消息的过程中使用的上下文。

getResponseContext

Map<String,Object> getResponseContext()
获取处理响应消息所得的上下文。 返回的上下文用于最新完成的同步操作。随后的同步操作调用重写响应上下文。异步操作通过 Response 接口返回它们的响应上下文。

返回：
处理最新响应消息所得的上下文。

getBinding

Binding getBinding()
获取此绑定提供者的 Binding。

返回：
此绑定提供者的 Binding。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 BindingType

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface BindingType

BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。

根据所使用的平台，可以以编程方式或通过部署描述符重写此注释。

从以下版本开始：
JAX-WS 2.0

可选元素摘要
 String value
绑定标识符 (URI)。

value

public abstract String value
绑定标识符 (URI)。如果未指定，则默认值为 SOAP 1.1 / HTTP 绑定。

有关标准绑定标识符的定义，请参阅 SOAPBinding 和 HTTPBinding。

另请参见：
Binding, SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING
默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


Dispatch (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
接口 Dispatch<T>

所有超级接口：
BindingProvider
public interface Dispatch<T>
extends BindingProvider

Dispatch 接口提供对动态调用服务端点操作的支持。javax.xml.ws.Service 接口作为创建 Dispatch 实例的工厂。

从以下版本开始：
JAX-WS 2.0

字段摘要
从接口 javax.xml.ws.BindingProvider 继承的字段
ENDPOINT_ADDRESS_PROPERTY, PASSWORD_PROPERTY, SESSION_MAINTAIN_PROPERTY, SOAPACTION_URI_PROPERTY, SOAPACTION_USE_PROPERTY, USERNAME_PROPERTY
方法摘要
T | invoke(T msg) 同步调用服务操作。
Response<T> | invokeAsync(T msg) 异步调用服务操作。
Future<?> | invokeAsync(T msg, AsyncHandler<T> handler) 异步调用服务操作。
void | invokeOneWay(T msg) 使用单向交互模式调用服务操作。
从接口 javax.xml.ws.BindingProvider 继承的方法
getBinding, getRequestContext, getResponseContext

方法详细信息

invoke

T invoke(T msg)
同步调用服务操作。 客户端负责确保在编组 msg 对象时根据所用协议绑定的要求形成它们。

参数：
msg - 一个对象，将形成用来调用操作的消息或消息负载。
返回：
用来调用操作的响应消息或消息负载。
抛出：
WebServiceException - 如果在与服务通信的过程中发生故障
WebServiceException - 如果在配置 Dispatch 实例时出现任何错误

invokeAsync

Response<T> invokeAsync(T msg)
异步调用服务操作。该方法无需等待对操作调用的响应即可返回，操作的结果可以通过轮询返回的 Response 获得。 客户端负责确保在编组 msg 对象时根据所用协议绑定的要求形成它们。

参数：
msg - 一个对象，将形成用来调用操作的消息或消息负载。
返回：
用来调用操作的响应消息或消息负载。
抛出：
WebServiceException - 如果在配置 Dispatch 实例时出现任何错误

invokeAsync

Future<?> invokeAsync(T msg,
                      AsyncHandler<T> handler)
异步调用服务操作。该方法无需等待对操作调用的响应即可返回，操作的结果可以通过传入的处理程序与客户端进行通信。 客户端负责确保在编组 msg 对象时根据所用协议绑定的要求形成它们。

参数：
msg - 一个对象，将形成用来调用操作的消息或消息负载。
handler - 将接收对操作调用的响应的处理程序对象。
返回：
一个 Future 对象，可以用来检查操作调用的状态。此对象不得用来尝试获得操作的结果 - 从 Future<?>.get() 返回的对象与实现有关，并且使用该对象将导致不可移植的行为。
抛出：
WebServiceException - 如果在配置 Dispatch 实例时出现任何错误

invokeOneWay

void invokeOneWay(T msg)
使用单向交互模式调用服务操作。该操作调用逻辑上是非阻塞的，受到底层协议功能的限制，不返回结果。当使用的协议为 SOAP/HTTP 时，在收到 HTTP 响应代码或发生错误前，此方法必须阻塞。 客户端负责确保在编组 msg 对象时根据所用协议绑定的要求形成它们。

参数：
msg - 一个对象，将形成用于调用操作的消息或消息负载。
抛出：
WebServiceException - 如果在配置 Dispatch 实例时出现任何错误，或者在调用过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Endpoint (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
类 Endpoint

java.lang.Object
    继承者  javax.xml.ws.Endpoint

public abstract class Endpoint
extends Object

Web 服务端点。

使用在此类中定义的静态方法创建端点。一个端点总是绑定到一个 Binding 和一个实现者，这两项都是在创建端点时设置的。

端点要么处于已发布状态，要么处于未发布状态。可以使用 publish 方法开始发布端点，此时端点开始接受传入请求。相反，可以使用 stop 方法停止接受传入请求并取消端点。一旦停止，就不能再次发布该端点。

可以在端点上设置 Executor 以便更好地控制用来指派传入请求的线程。例如，通过创建 ThreadPoolExecutor 并向端点注册可以启用带有特定参数的线程池。

处理程序链可以使用所含的 Binding 来设置。

端点可以使一个元数据文档（如 WSDL 和 XMLSchema 文档）列表与之绑定。发布时，JAX-WS 实现将根据实现者上存在的注释，尽可能多地重用这些元数据，而不是生成新的元数据。

从以下版本开始：
JAX-WS 2.0
另请参见：
Binding, BindingType, SOAPBinding, Executor

字段摘要
static String | WSDL_PORT 标准属性：WSDL 端口的名称。
static String | WSDL_SERVICE 标准属性：WSDL 服务的名称。
构造方法摘要
Endpoint()
方法摘要
static Endpoint | create(Object implementor) 创建具有指定实现者对象的端点。
static Endpoint | create(String bindingId, Object implementor) 创建具有指定绑定类型和实现者对象的端点。
abstract Binding | getBinding() 返回此端点的绑定。
abstract Executor | getExecutor() 返回此 Endpoint 实例的执行程序。
abstract Object | getImplementor() 返回此端点的实现对象。
abstract List<Source> | getMetadata() 返回服务的元数据文档列表。
abstract Map<String,Object> | getProperties() 返回此 Endpoint 实例的属性包。
abstract boolean | isPublished() 如果端点已处于发布状态，则返回 true。
abstract void | publish(Object serverContext) 在提供的服务器上下文中发布此端点。
abstract void | publish(String address) 在给定地址处发布此端点。
static Endpoint | publish(String address, Object implementor) 在给定地址处针对指定的实现者对象创建并发布端点。
abstract void | setExecutor(Executor executor) 设置此 Endpoint 实例的执行程序。
abstract void | setMetadata(List<Source> metadata) 设置此端点的元数据。
abstract void | setProperties(Map<String,Object> properties) 设置此 Endpoint 实例的属性包。
abstract void | stop() 停止发布此端点。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

WSDL_SERVICE

public static final String WSDL_SERVICE
标准属性：WSDL 服务的名称。

类型：javax.xml.namespace.QName

另请参见：
常量字段值

WSDL_PORT

public static final String WSDL_PORT
标准属性：WSDL 端口的名称。

类型：javax.xml.namespace.QName

另请参见：
常量字段值
构造方法详细信息

Endpoint

public Endpoint()
方法详细信息

create

public static Endpoint create(Object implementor)
创建具有指定实现者对象的端点。如果存在通过 BindingType 注释指定的绑定，则必须使用该绑定，否则必须使用默认的 SOAP 1.1 / HTTP 绑定。

可以通过调用 javax.xml.ws.Endpoint#publish(String) 和 javax.xml.ws.Endpoint#publish(Object) 方法之一来发布新创建的端点。

参数：
implementor - 端点实现者。
返回：
新创建的端点。

create

public static Endpoint create(String bindingId,
                              Object implementor)
创建具有指定绑定类型和实现者对象的端点。

可以通过调用 javax.xml.ws.Endpoint#publish(String) 和 javax.xml.ws.Endpoint#publish(Object) 方法之一来发布新创建的端点。

参数：
bindingId - 一个 URI，指定要使用的绑定。如果 bindingID 为 null 并且没有通过 BindingType 注释指定任何绑定，则必须使用默认的 SOAP 1.1 / HTTP 绑定。
implementor - 端点实现者。
返回：
新创建的端点。

getBinding

public abstract Binding getBinding()
返回此端点的绑定。

返回：
此端点的绑定

getImplementor

public abstract Object getImplementor()
返回此端点的实现对象。

返回：
此端点的实现者

publish

public abstract void publish(String address)
在给定地址处发布此端点。JAX-WS 实现将使用一些默认的配置创建和配置所需的服务器基础设施。若要更多地控制服务器配置，请使用 javax.xml.ws.Endpoint#publish(Object) 方法。

参数：
address - 一个 URI，指定要使用的地址。地址必须与创建端点时指定的绑定兼容。
抛出：
IllegalArgumentException - 如果提供的地址 URI 不能与端点的绑定结合使用。
IllegalStateException - 如果已发布端点或者已停止端点。

publish

public static Endpoint publish(String address,
                               Object implementor)
在给定地址处针对指定的实现者对象创建并发布端点。

JAX-WS 实现将使用一些默认的配置创建和配置所需的服务器基础设施。 若要更多地控制服务器配置，请使用 javax.xml.ws.Endpoint#create(String,Object) 和 javax.xml.ws.Endpoint#publish(Object) 方法。

参数：
address - 一个 URI，指定要使用的地址和传输/协议。http:URI 一定会导致使用 SOAP 1.1/HTTP 绑定。实现可以支持其他 URI 方案。
implementor - 端点实现者。
返回：
新创建的端点。

publish

public abstract void publish(Object serverContext)
在提供的服务器上下文中发布此端点。服务器上下文封装了用于特定传输的服务器基础设施和寻址信息。要成功调用该方法，作为参数传递给它的服务器上下文必须与端点的绑定兼容。

参数：
serverContext - 表示发布端点所用服务器上下文的对象。
抛出：
IllegalArgumentException - 如果实现不支持提供的服务器上下文，或者被证明无法与端点的绑定结合使用。
IllegalStateException - 如果已发布端点或者已停止端点。

stop

public abstract void stop()
停止发布此端点。 如果端点未处于已发布状态，则此方法无效。

isPublished

public abstract boolean isPublished()
如果端点已处于发布状态，则返回 true。

返回：
如果端点已处于发布状态，则返回 true

getMetadata

public abstract List<Source> getMetadata()
返回服务的元数据文档列表。

返回：
List<javax.xml.transform.Source> 服务的元数据文档列表

setMetadata

public abstract void setMetadata(List<Source> metadata)
设置此端点的元数据。

参数：
metadata - 包含端点元数据信息的 XML 文档源（例如，WSDL 或 XML 模式文档）列表
抛出：
IllegalStateException - 如果已发布端点。

getExecutor

public abstract Executor getExecutor()
返回此 Endpoint 实例的执行程序。 执行程序用于向实现者对象指派传入请求。

返回：
将用来指派请求的 java.util.concurrent.Executor。
另请参见：
Executor

setExecutor

public abstract void setExecutor(Executor executor)
设置此 Endpoint 实例的执行程序。 执行程序用于向实现者对象指派传入请求。 如果此 Endpoint 使用 publish(Object) 方法发布，并且指定的服务器上下文定义它自己的线程行为，则可以忽略执行程序。

参数：
executor - 将用来指派请求的 java.util.concurrent.Executor。
抛出：
SecurityException - 如果出于安全的原因（例如，缺少必要的权限），实例不支持设置执行程序。
另请参见：
Executor

getProperties

public abstract Map<String,Object> getProperties()
返回此 Endpoint 实例的属性包。

返回：
Map<String,Object>，与此实例关联的属性包。

setProperties

public abstract void setProperties(Map<String,Object> properties)
设置此 Endpoint 实例的属性包。

参数：
properties - 与此实例关联的属性包。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Holder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
类 Holder<T>

java.lang.Object
    继承者  javax.xml.ws.Holder<T>

public final class Holder<T>
extends Object

包含类型为 T 的值。

从以下版本开始：
JAX-WS 2.0

字段摘要
 T value
持有者中包含的值。
构造方法摘要
Holder()
创建一个新的持有者，其值为 null。
Holder(T value)
创建具有指定值的新持有者。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public T value
持有者中包含的值。

构造方法详细信息

Holder

public Holder()
创建一个新的持有者，其值为 null。

Holder

public Holder(T value)
创建具有指定值的新持有者。

参数：
value - 将存储在持有者中的值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogicalMessage (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
接口 LogicalMessage

public interface LogicalMessage

LogicalMessage 接口表示协议无关的 (protocol agnostic) XML 消息，并包含一些方法提供对消息负载的访问。

从以下版本开始：
JAX-WS 2.0

方法摘要
Source | getPayload() 以 XML 源的形式获取消息负载，可以在相同的 LogicalMessage 实例上多次调用，总是返回可以用来检索整个消息负载的新的 Source。
Object | getPayload(JAXBContext context) 以 JAXB 对象的形式获取消息负载。
void | setPayload(Object payload, JAXBContext context) 设置消息负载
void | setPayload(Source payload) 设置消息负载

方法详细信息

getPayload

Source getPayload()
以 XML 源的形式获取消息负载，可以在相同的 LogicalMessage 实例上多次调用，总是返回可以用来检索整个消息负载的新的 Source。

如果返回的 Source 是 DOMSource 的实例，则对封装的 DOM 树的修改现场更改消息负载，不需要随后调用 setPayload。其他类型的 Source 只提供对消息负载的读取访问。

返回：
所含的消息负载；如果此消息中没有净荷，则返回 null。

setPayload

void setPayload(Source payload)
设置消息负载

参数：
payload - 消息负载
抛出：
WebServiceException - 如果在此消息中设置净荷过程中发生任何错误
UnsupportedOperationException - 如果不支持该操作

getPayload

Object getPayload(JAXBContext context)
以 JAXB 对象的形式获取消息负载。注意，返回的对象和消息负载之间没有任何连接，更改净荷需要调用 setPayload。

参数：
context - 应该用来解组消息负载的 JAXBContext
返回：
所含的消息负载；如果此消息中没有净荷，则返回 null
抛出：
WebServiceException - 如果使用提供的 JAXBContext 解组净荷时发生错误。WebServiceException 的 cause 是初始 JAXBException。

setPayload

void setPayload(Object payload,
                JAXBContext context)
设置消息负载

参数：
payload - 消息负载
context - 应该用来对净荷进行编组的 JAXBContext
抛出：
UnsupportedOperationException - 如果不支持此操作
WebServiceException - 如果在使用提供的 JAXBContext 对净荷进行编组时发生错误。WebServiceException 的 cause 是初始 JAXBException。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProtocolException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
类 ProtocolException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.xml.ws.WebServiceException
                    继承者  javax.xml.ws.ProtocolException
所有已实现的接口：
Serializable
直接已知子类：
HTTPException, SOAPFaultException
public class ProtocolException
extends WebServiceException

ProtocolException 类是与特定协议绑定有关的异常的基类。子类用来与客户端交流协议级别故障的信息，也可以在服务器上使用，以控制特定于协议的故障表示形式。

从以下版本开始：
JAX-WS 2.0
另请参见：
序列化表格

构造方法摘要
ProtocolException()
构造一个新的协议异常，将 null 作为它的详细消息。
ProtocolException(String message)
构造一个具有指定详细消息的新协议异常。
ProtocolException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新运行时异常。
ProtocolException(Throwable cause)
构造具有指定 cause 和详细消息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新运行时异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ProtocolException

public ProtocolException()
构造一个新的协议异常，将 null 作为它的详细消息。cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 进行初始化。

ProtocolException

public ProtocolException(String message)
构造一个具有指定详细消息的新协议异常。cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 进行初始化。

参数：
message - 详细消息。保存该详细消息，以便以后通过 Throwable.getMessage() 方法进行检索。

ProtocolException

public ProtocolException(String message,
                         Throwable cause)
构造一个具有指定详细消息和 cause 的新运行时异常。 注意，与 cause 相关的详细消息不会自动地合并到此运行时异常的详细消息中。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法检索它）。
cause - cause （保存此 cause，以便以后通过 Throwable.getCause() 方法检索它）。（允许 null 值，指示 cause 是不存在的或是未知的。）

ProtocolException

public ProtocolException(Throwable cause)
构造具有指定 cause 和详细消息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新运行时异常。该构造方法对于那些与其他可抛出异常的包装器一样的运行时异常来说是很有用的。

参数：
cause - cause （保存此 cause，以便以后通过 Throwable.getCause() 方法检索它）。（允许 null 值，指示 cause 是不存在的或是未知的。）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Provider (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
接口 Provider<T>

public interface Provider<T>

服务端点可以将 Provider 接口作为 SEI 的动态替代方法实现。

实现要求支持 Provider<Source>、Provider<SOAPMessage> 和 Provider<DataSource>，具体取决于使用的绑定和服务模式。

ServiceMode 注释可以用来控制 Provider 实例是收到整个协议消息还是只收到消息负载。

从以下版本开始：
JAX-WS 2.0
另请参见：
Source, SOAPMessage, ServiceMode

方法摘要
 T invoke(T request)
根据请求消息的内容调用操作。

方法详细信息

invoke

T invoke(T request)
根据请求消息的内容调用操作。

参数：
request - 请求消息或消息负载。
返回：
响应消息或消息负载。如果没有响应，则为 null。
抛出：
WebServiceException - 如果在处理请求的过程中发生错误。WebServiceException 的 cause 可以设置为 ProtocolException 的子类，以控制异常的协议级别表示形式。
另请参见：
MessageContext, ProtocolException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestWrapper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 RequestWrapper

@Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface RequestWrapper

此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。正如 WebMethod 注释中所定义的，localName 的默认值是 operationName；targetNamespace 是 SEI 的目标名称空间。

当从 Java 中启动时，此注释用来解决文档字面值模式中的重载冲突。在此情况下只需要 className。

从以下版本开始：
JAX-WS 2.0

可选元素摘要
String | className 请求包装器 bean 名称。
String | localName 元素本地名称。
String | targetNamespace 元素名称空间名称。

localName

public abstract String localName
元素本地名称。

默认值：
""

targetNamespace

public abstract String targetNamespace
元素名称空间名称。

默认值：
""

className

public abstract String className
请求包装器 bean 名称。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


Response (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
接口 Response<T>

所有超级接口：
Future<T>
public interface Response<T>
extends Future<T>

Response 接口提供一些方法，用来获得为响应操作调用而发送的消息的净荷和上下文。

针对异步操作调用，它还提供了其他一些方法来检查请求状态。get(...) 方法可能抛出一组标准异常，这些异常的 cause 可能是 RemoteException 或 WebServiceException，表示在异步方法调用的过程中发生错误。

从以下版本开始：
JAX-WS 2.0

方法摘要
 Map<String,Object> getContext()
获取所含的响应上下文。
从接口 java.util.concurrent.Future 继承的方法
cancel, get, get, isCancelled, isDone

方法详细信息

getContext

Map<String,Object> getContext()
获取所含的响应上下文。

返回：
所含的响应上下文。如果响应尚不可用，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResponseWrapper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 ResponseWrapper

@Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface ResponseWrapper

此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。正如附加了 Response 的 WebMethod 注释中所定义的，localName 的默认值是 operationName；targetNamespace 是 SEI 的目标名称空间。

当从 Java 中启动时，此注释用来解决文档字面值模式中的重载冲突。在此情况下只需要 className。

从以下版本开始：
JAX-WS 2.0

可选元素摘要
String | className 响应包装器 bean 名称。
String | localName 元素本地名称。
String | targetNamespace 元素名称空间名称。

localName

public abstract String localName
元素本地名称。

默认值：
""

targetNamespace

public abstract String targetNamespace
元素名称空间名称。

默认值：
""

className

public abstract String className
响应包装器 bean 名称。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


Service (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
类 Service

java.lang.Object
    继承者  javax.xml.ws.Service

public class Service
extends Object

Service 对象提供 Web 服务的客户端视图。

Service 作为以下内容的工厂：

  • 目标服务端点的代理。
  • 用于远程操作的动态面向消息调用的 javax.xml.ws.Dispatch 实例。

    • 使用 getPorts 方法可以对服务上可用的端口进行枚举。此外，还可以将一个服务端点接口传递给一元的 getPort 方法，并允许运行时选择兼容的端口。

    可以通过 HandlerResolver 设置由 Service 创建的所有对象的处理程序链。

    可以在服务上设置 Executor 以便更好地控制用来指派异步回调的线程。例如，通过创建 ThreadPoolExecutor 并向服务注册它可以启用带有特定参数的线程池。

    从以下版本开始：
    JAX-WS 2.0
    另请参见：
    Provider, HandlerResolver, Executor

    嵌套类摘要
    static class Service.Mode
    动态客户端或服务的方向。
    构造方法摘要
    protected Service(URL wsdlDocumentLocation, QName serviceName)
    方法摘要
     void addPort(QName portName, String bindingId, String endpointAddress)
    为服务创建新的端口。
    static Service create(QName serviceName)
    创建 Service 实例。
    static Service create(URL wsdlDocumentLocation, QName serviceName)
    创建 Service 实例。
    <T> Dispatch<T>
            createDispatch(QName portName, Class<T> type, Service.Mode mode)
    创建与用户选择的对象一起使用的 Dispatch 实例。
     Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
    创建与生成的 JAXB 对象一起使用的 Dispatch 实例。
     Executor getExecutor()
    返回此 Service 实例的执行程序。
     HandlerResolver getHandlerResolver()
    返回已配置的处理程序解析器。
    <T> T
            getPort(Class<T> serviceEndpointInterface)
    getPort 返回 stub。
    <T> T
            getPort(QName portName, Class<T> serviceEndpointInterface)
    getPort 方法返回 stub。
     Iterator<QName> getPorts()
    返回一个 Iterator，它用于此服务所组合的服务端点的 QName 列表。
     QName getServiceName()
    获取此服务的名称。
     URL getWSDLDocumentLocation()
    获取此 Service 的 WSDL 文档的位置。
     void setExecutor(Executor executor)
    设置此 Service 实例的执行程序。
     void setHandlerResolver(HandlerResolver handlerResolver)
    设置此 Service 实例的 HandlerResolver。
    从类 java.lang.Object 继承的方法
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    构造方法详细信息

    Service

    protected Service(URL wsdlDocumentLocation,
                  QName serviceName)
    方法详细信息

    getPort

    public <T> T getPort(QName portName,
                     Class<T> serviceEndpointInterface)
    getPort 方法返回 stub。服务客户端使用此 stub 调用目标服务端点上的操作。serviceEndpointInterface 指定创建的动态代理或 stub 实例所支持的服务端点接口。

    参数：
    portName - WSDL 服务描述中服务端点的限定名称
    serviceEndpointInterface - 动态代理或 stub 实例所支持的服务端点接口
    返回：
    支持指定服务端点接口的对象代理实例
    抛出：
    WebServiceException - 在以下情况下抛出此异常：
    • 如果创建代理的过程中出现错误
    • 如果缺少此方法所需的任何 WSDL 元数据
    • 如果指定了非法的 serviceEndpointInterface 或 portName
    另请参见：
    Proxy, InvocationHandler

    getPort

    public <T> T getPort(Class<T> serviceEndpointInterface)
    getPort 返回 stub。参数 serviceEndpointInterface 指定返回的代理所支持的服务端点接口。在此方法的实现中，JAX-WS 运行时系统承担选择协议绑定（和端口）以及配置相应代理的责任。返回的代理不应该由客户端进行配置。

    参数：
    serviceEndpointInterface - 服务端点接口
    返回：
    支持指定服务端点接口的对象实例
    抛出：
    WebServiceException -
    • 如果创建代理的过程中出现错误
    • 如果缺少此方法所需的任何 WSDL 元数据
    • 如果指定了非法的 serviceEndpointInterface

    addPort

    public void addPort(QName portName,
                    String bindingId,
                    String endpointAddress)
    为服务创建新的端口。以这种方法创建的端口不包含 WSDL 端口类型信息，并且只能用于创建 Dispatch 实例。

    参数：
    portName - 目标服务端点的限定名称
    bindingId - 绑定的 String 标识符。
    endpointAddress - URI 形式的目标服务端点地址
    抛出：
    WebServiceException - 如果创建端口的过程中出现错误
    另请参见：
    SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

    createDispatch

    public <T> Dispatch<T> createDispatch(QName portName,
                                      Class<T> type,
                                      Service.Mode mode)
    创建与用户选择的对象一起使用的 Dispatch 实例。

    参数：
    portName - 目标服务端点的限定名称
    type - 用于消息或消息负载的对象类。要求实现支持 javax.xml.transform.Source、javax.xml.soap.SOAPMessage 和 javax.activation.DataSource，具体取决于使用的绑定。
    mode - 控制创建的 Dispatch 实例是消息还是所面向的净荷，即用户使用完整的协议消息还是消息负载。例如，当使用 SOAP 协议时，此参数控制用户将使用 SOAP 消息还是使用 SOAP 正文的内容。当类型为 SOAPMessage 时，模式必须为 MESSAGE。
    返回：
    Dispatch 实例
    抛出：
    WebServiceException - 如果创建 Dispatch 对象的过程中出现错误
    另请参见：
    Source, SOAPMessage

    createDispatch

    public Dispatch<Object> createDispatch(QName portName,
                                       JAXBContext context,
                                       Service.Mode mode)
    创建与生成的 JAXB 对象一起使用的 Dispatch 实例。

    参数：
    portName - 目标服务端点的限定名称
    context - 用来对消息或消息负载进行编组和解组的 JAXB 上下文。
    mode - 控制创建的 Dispatch 实例是消息还是所面向的净荷，即用户使用完整的协议消息还是消息负载。例如，当使用 SOAP 协议时，此参数控制用户将使用 SOAP 消息还是使用 SOAP 正文的内容。
    返回：
    Dispatch 实例
    抛出：
    ServiceException - 如果创建 Dispatch 对象的过程中出现错误
    另请参见：
    JAXBContext

    getServiceName

    public QName getServiceName()
    获取此服务的名称。

    返回：
    此服务的限定名称

    getPorts

    public Iterator<QName> getPorts()
    返回一个 Iterator，它用于此服务所组合的服务端点的 QName 列表。

    返回：
    返回元素类型为 javax.xml.namespace.QName 的 java.util.Iterator
    抛出：
    WebServiceException - 如果此 Service 类没有对所需 WSDL 元数据的访问权限

    getWSDLDocumentLocation

    public URL getWSDLDocumentLocation()
    获取此 Service 的 WSDL 文档的位置。

    返回：
    此服务 WSDL 文档位置的 URL

    getHandlerResolver

    public HandlerResolver getHandlerResolver()
    返回已配置的处理程序解析器。

    返回：
    HandlerResolver，此 Service 实例所使用的 HandlerResolver，如果不存在，则返回 null。

    setHandlerResolver

    public void setHandlerResolver(HandlerResolver handlerResolver)
    设置此 Service 实例的 HandlerResolver。

    如果存在处理程序解析器，则创建每个代理或 Dispatch 实例时将调用一次该解析器，并且将在实例上设置解析器所返回的处理程序链。

    参数：
    handlerResolver - 用于随后创建的代理/指派对象的 HandlerResolver。
    另请参见：
    HandlerResolver

    getExecutor

    public Executor getExecutor()
    返回此 Service 实例的执行程序。 执行程序用于所有需要回调的异步调用。

    返回：
    将用来调用回调的 java.util.concurrent.Executor。
    另请参见：
    Executor

    setExecutor

    public void setExecutor(Executor executor)
    设置此 Service 实例的执行程序。 执行程序用于所有需要回调的异步调用。

    参数：
    executor - 将用来调用回调的 java.util.concurrent.Executor。
    抛出：
    SecurityException - 如果出于安全的原因（例如，缺少必要的权限），实例不支持设置执行程序。
    另请参见：
    Executor

    create

    public static Service create(URL wsdlDocumentLocation,
                             QName serviceName)
    创建 Service 实例。 指定的 WSDL 文档位置和服务限定名称必须唯一标识 wsdl:service 元素。

    参数：
    wsdlDocumentLocation - 服务 WSDL 文档位置的 URL
    serviceName - 服务的 QName
    抛出：
    WebServiceException - 如果在创建指定服务的过程中发生任何错误

    create

    public static Service create(QName serviceName)
    创建 Service 实例。

    参数：
    serviceName - 服务的 QName
    抛出：
    WebServiceException - 如果在创建指定服务的过程中发生任何错误
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM Platform
    Standard Ed. 6
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Service.Mode (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.xml.ws
枚举 Service.Mode

java.lang.Object
    继承者  java.lang.Enum<Service.Mode>
        继承者  javax.xml.ws.Service.Mode
所有已实现的接口：
Serializable, Comparable<Service.Mode>
正在封闭类：
Service
public static enum Service.Mode
extends Enum<Service.Mode>

动态客户端或服务的方向。MESSAGE 提供对整个协议消息的访问，而 PAYLOAD 只提供对协议消息负载的访问。

枚举常量摘要
MESSAGE
PAYLOAD
方法摘要
static Service.Mode | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Service.Mode[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

MESSAGE

public static final Service.Mode MESSAGE

PAYLOAD

public static final Service.Mode PAYLOAD
方法详细信息

values

public static final Service.Mode[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Service.Mode c : Service.Mode.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Service.Mode valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


ServiceMode (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 ServiceMode

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Inherited
@Documented
public @interface ServiceMode

用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。

从以下版本开始：
JAX-WS 2.0

可选元素摘要
 Service.Mode value
服务模式。

value

public abstract Service.Mode value
服务模式。PAYLOAD 指示 Provider 实现只希望使用协议消息负载。MESSAGE 指示 Provider 实现希望使用整个协议消息。

默认值：
javax.xml.ws.Service.Mode.PAYLOAD
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebEndpoint (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 WebEndpoint

@Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface WebEndpoint

此类用来注释所生成服务接口的 getPortName() 方法。

此注释中指定的信息足以唯一标识 wsdl:service 中的 wsdl:port 元素。前者根据所生成服务接口自身的 WebServiceClient 注释值来确定。

从以下版本开始：
JAX-WS 2.0
另请参见：
WebServiceClient

可选元素摘要
 String name
端点的本地名称。

name

public abstract String name
端点的本地名称。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebFault (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 WebFault

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebFault

此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。

从以下版本开始：
JAX-WS 2.0

可选元素摘要
String | faultBean 故障 bean 名称。
String | name 元素本地名称。
String | targetNamespace 元素名称空间名称。

name

public abstract String name
元素本地名称。

默认值：
""

targetNamespace

public abstract String targetNamespace
元素名称空间名称。

默认值：
""

faultBean

public abstract String faultBean
故障 bean 名称。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebServiceClient (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 WebServiceClient

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceClient

此类用来注释生成的服务接口。

此注释中指定的信息足以唯一标识 WSDL 文档中的 wsdl:service 元素。此 wsdl:service 元素表示生成的服务接口为之提供客户端视图的 Web 服务。

从以下版本开始：
JAX-WS 2.0

可选元素摘要
String | name Web 服务的本地名称。
String | targetNamespace Web 服务的名称空间。
String | wsdlLocation 服务 WSDL 文档的位置 (URL)。

name

public abstract String name
Web 服务的本地名称。

默认值：
""

targetNamespace

public abstract String targetNamespace
Web 服务的名称空间。

默认值：
""

wsdlLocation

public abstract String wsdlLocation
服务 WSDL 文档的位置 (URL)。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebServiceContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
接口 WebServiceContext

public interface WebServiceContext

WebServiceContext 能使 Web 服务端点实现类访问与服务的请求有关的消息上下文和安全信息。 通常，使用 Resource 注释将 WebServiceContext 注入到端点实现类中。

从以下版本开始：
JAX-WS 2.0
另请参见：
Resource

方法摘要
MessageContext | getMessageContext() 调用此方法时，返回正在服务的请求的 MessageContext。
Principal | getUserPrincipal() 返回标识当前正服务请求发送方的 Principal。
boolean | isUserInRole(String role) 返回一个布尔值，指示指定的逻辑角色中是否包含经过验证的用户。

方法详细信息

getMessageContext

MessageContext getMessageContext()
调用此方法时，返回正在服务的请求的 MessageContext。应用程序只能看到具有 APPLICATION 作用域的属性。

返回：
MessageContext 消息上下文。
抛出：
IllegalStateException - 如果调用该方法但不存在任何正被服务的请求，则抛出该异常。
另请参见：
MessageContext, MessageContext.Scope, IllegalStateException

getUserPrincipal

Principal getUserPrincipal()
返回标识当前正服务请求发送方的 Principal。如果发送方没有经过验证，则该方法返回 null。

返回：
Principal 主体对象。
抛出：
IllegalStateException - 如果调用该方法但不存在任何正被服务的请求，则抛出该异常。
另请参见：
Principal, IllegalStateException

isUserInRole

boolean isUserInRole(String role)
返回一个布尔值，指示指定的逻辑角色中是否包含经过验证的用户。如果用户没有经过验证，则该方法返回 false。

参数：
role - 指定角色名称的 String
返回：
一个 boolean 值，指示请求的发送方是否属于给定角色
抛出：
IllegalStateException - 如果调用该方法但不存在任何正被服务的请求，则抛出该异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebServiceException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
类 WebServiceException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.xml.ws.WebServiceException
所有已实现的接口：
Serializable
直接已知子类：
ProtocolException
public class WebServiceException
extends RuntimeException

WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

从以下版本开始：
JAX-WS 2.0
另请参见：
序列化表格

构造方法摘要
WebServiceException()
构造一个新异常，它的详细消息为 null。
WebServiceException(String message)
构造具有指定详细消息的新异常。
WebServiceException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新异常。
WebServiceException(Throwable cause)
构造具有指定 cause 和详细信息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新 WebServiceException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

WebServiceException

public WebServiceException()
构造一个新异常，它的详细消息为 null。cause 没有初始化。

WebServiceException

public WebServiceException(String message)
构造具有指定详细消息的新异常。cause 没有初始化。

参数：
message - 详细消息，以后可使用 getMessage 方法检索

WebServiceException

public WebServiceException(String message,
                           Throwable cause)
构造一个具有指定详细消息和 cause 的新异常。

参数：
message - 详细消息，以后可使用 getMessage 方法检索
cause - 保存此 cause，以便以后通过 getCause 方法检索

WebServiceException

public WebServiceException(Throwable cause)
构造具有指定 cause 和详细信息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新 WebServiceException。

参数：
cause - 保存此 cause，以便以后通过 getCause 方法检索。（允许 null 值，指示 cause 是不存在的或是未知的。）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebServicePermission (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws
类 WebServicePermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  javax.xml.ws.WebServicePermission
所有已实现的接口：
Serializable, Guard
public final class WebServicePermission
extends BasicPermission

此类定义 Web 服务权限。

Web 服务权限由名称（也称为“目标名称”）单独标识。没有与它们关联的操作。

定义以下权限目标名称：

publishEndpoint

publishEndpoint 权限允许使用 javax.xml.ws.Endpoint 类定义的 publish 方法发布 Web 服务端点。

另请参见：
Endpoint, BasicPermission, Permission, Permissions, SecurityManager, 序列化表格

构造方法摘要
WebServicePermission(String name)
创建具有指定名称的新权限。
WebServicePermission(String name, String actions)
创建具有指定名称和操作的新权限。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

WebServicePermission

public WebServicePermission(String name)
创建具有指定名称的新权限。

参数：
name - WebServicePermission 的名称

WebServicePermission

public WebServicePermission(String name,
                            String actions)
创建具有指定名称和操作的新权限。 当前不使用 actions 参数，它应该为 null。

参数：
name - WebServicePermission 的名称
actions - 应该为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebServiceProvider (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 WebServiceProvider

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceProvider

此类用来注释 Provider 实现类。

从以下版本开始：
JAX-WS 2.0
另请参见：
Provider

可选元素摘要
String | portName 端口名称。
String | serviceName 服务名称。
String | targetNamespace 服务的目标名称空间
String | wsdlLocation 服务 WSDL 描述的位置。

wsdlLocation

public abstract String wsdlLocation
服务 WSDL 描述的位置。

默认值：
""

serviceName

public abstract String serviceName
服务名称。

默认值：
""

targetNamespace

public abstract String targetNamespace
服务的目标名称空间

默认值：
""

portName

public abstract String portName
端口名称。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebServiceRef (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.xml.ws
注释类型 WebServiceRef

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceRef

WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。 对于 Java EE 5 来说 Web 服务引用属于资源。

从以下版本开始：
JAX-WS 2.0
另请参见：
Resource

可选元素摘要
String | mappedName 此资源必须映射到的特定产品名称。
String | name 资源的 JNDI 名称。
Class | type 资源的 Java 类型。
Class | value 服务类，总是扩展 javax.xml.ws.Service 的类型。
String | wsdlLocation 指向 Web 服务 WSDL 文档的 URL。

name

public abstract String name
资源的 JNDI 名称。对于字段注释，默认为字段名称。对于方法注释，默认为与该方法相对应的 JavaBeans 属性名称。对于类注释，没有默认值，必须指定该项。

默认值：
""

type

public abstract Class type
资源的 Java 类型。对于字段注释，默认为字段的类型。对于方法注释，默认为 JavaBeans 属性的类型。对于类注释，没有默认值，必须指定该项。

默认值：
java.lang.Object.class

mappedName

public abstract String mappedName
此资源必须映射到的特定产品名称。此资源的名称（由 name 元素定义或默认）是使用该资源的应用程序组件的本地名称。（它的名称位于 JNDI java:comp/env 名称空间中。）许多应用程序服务器都提供一种方式将这些本地名称映射到应用程序服务器已知的资源名称。此映射的名称通常是全局 JNDI 名称，但是也可以是任何形式的名称。

应用程序服务器不需要支持任何特殊形式或映射名称的类型，也不需要具有使用映射名称的能力。映射的名称与产品有关，并且通常与安装有关。任何对映射名称的使用都不可移植。

默认值：
""

value

public abstract Class value
服务类，总是扩展 javax.xml.ws.Service 的类型。只要引用的类型是服务端点接口，就必须指定此元素。

默认值：
java.lang.Object.class

wsdlLocation

public abstract String wsdlLocation
指向 Web 服务 WSDL 文档的 URL。如果没有指定，则使用在资源类型上由注释指定的 WSDL 位置。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebServiceRefs (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.xml.ws
注释类型 WebServiceRefs

@Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface WebServiceRefs

WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

从以下版本开始：
2.0
另请参见：
WebServiceRef

必需元素摘要
 WebServiceRef[] value
用于多个 web 服务引用声明的数组。

元素详细信息

value

public abstract WebServiceRef[] value
用于多个 web 服务引用声明的数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


javax.xml.ws (Java Platform SE 6)

 javax.xml.ws
接口
AsyncHandler
Binding
BindingProvider
Dispatch
LogicalMessage
Provider
Response
WebServiceContext
类
Endpoint
Holder
Service
WebServicePermission
枚举
Service.Mode
异常
ProtocolException
WebServiceException
注释类型
BindingType
RequestWrapper
ResponseWrapper
ServiceMode
WebEndpoint
WebFault
WebServiceClient
WebServiceProvider
WebServiceRef
WebServiceRefs


javax.xml.ws (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.ws

此包包含核心 JAX-WS API。

请参见：
描述

接口摘要
AsyncHandler<T> | AsyncHandler 接口由希望接收关于完成了异步调用服务端点操作的回调通知的客户端实现。
Binding | Binding 接口是 JAX-WS 协议绑定的基本接口。
BindingProvider | BindingProvider 接口提供对用于请求和响应消息处理的协议绑定及关联上下文对象的访问。
Dispatch<T> | Dispatch 接口提供对动态调用服务端点操作的支持。
LogicalMessage | LogicalMessage 接口表示协议无关的 (protocol agnostic) XML 消息，并包含一些方法提供对消息负载的访问。
Provider<T> | 服务端点可以将 Provider 接口作为 SEI 的动态替代方法实现。
Response<T> | Response 接口提供一些方法，用来获得为响应操作调用而发送的消息的净荷和上下文。
WebServiceContext | WebServiceContext 能使 Web 服务端点实现类访问与服务的请求有关的消息上下文和安全信息。

类摘要
Endpoint | Web 服务端点。
Holder<T> | 包含类型为 T 的值。
Service | Service 对象提供 Web 服务的客户端视图。
WebServicePermission | 此类定义 Web 服务权限。

枚举摘要
Service.Mode 动态客户端或服务的方向。

异常摘要
ProtocolException | ProtocolException 类是与特定协议绑定有关的异常的基类。
WebServiceException | WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

注释类型摘要
BindingType | BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
RequestWrapper | 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
ResponseWrapper | 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
ServiceMode | 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
WebEndpoint | 此类用来注释所生成服务接口的 getPortName() 方法。
WebFault | 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
WebServiceClient | 此类用来注释生成的服务接口。
WebServiceProvider | 此类用来注释 Provider 实现类。
WebServiceRef | WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
WebServiceRefs | WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

软件包 javax.xml.ws 的描述

此包包含核心 JAX-WS API。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.ws 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.ws.Endpoint
    • javax.xml.ws.Holder<T>
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.ws.WebServicePermission
    • javax.xml.ws.Service
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException

接口分层结构

  • javax.xml.ws.AsyncHandler<T>
  • javax.xml.ws.Binding
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
  • javax.xml.ws.LogicalMessage
  • javax.xml.ws.Provider<T>
  • javax.xml.ws.WebServiceContext

注释类型分层结构

  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.Service.Mode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.ws 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws
的使用

使用 javax.xml.ws 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 使用的 javax.xml.ws 中的类
AsyncHandler
AsyncHandler 接口由希望接收关于完成了异步调用服务端点操作的回调通知的客户端实现。
Binding
Binding 接口是 JAX-WS 协议绑定的基本接口。
BindingProvider
BindingProvider 接口提供对用于请求和响应消息处理的协议绑定及关联上下文对象的访问。
Dispatch
Dispatch 接口提供对动态调用服务端点操作的支持。
Endpoint
Web 服务端点。
Response
Response 接口提供一些方法，用来获得为响应操作调用而发送的消息的净荷和上下文。
Service
Service 对象提供 Web 服务的客户端视图。
Service.Mode
动态客户端或服务的方向。
WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

javax.xml.ws.handler 使用的 javax.xml.ws 中的类
LogicalMessage
LogicalMessage 接口表示协议无关的 (protocol agnostic) XML 消息，并包含一些方法提供对消息负载的访问。

javax.xml.ws.http 使用的 javax.xml.ws 中的类
Binding
Binding 接口是 JAX-WS 协议绑定的基本接口。
ProtocolException
ProtocolException 类是与特定协议绑定有关的异常的基类。
WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

javax.xml.ws.soap 使用的 javax.xml.ws 中的类
Binding
Binding 接口是 JAX-WS 协议绑定的基本接口。
ProtocolException
ProtocolException 类是与特定协议绑定有关的异常的基类。
WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

javax.xml.ws.spi 使用的 javax.xml.ws 中的类
Dispatch
Dispatch 接口提供对动态调用服务端点操作的支持。
Endpoint
Web 服务端点。
Service.Mode
动态客户端或服务的方向。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Handler (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.handler
接口 Handler<C extends MessageContext>

所有已知子接口：
LogicalHandler<C>, SOAPHandler<T>
public interface Handler<C extends MessageContext>

Handler 接口是 JAX-WS 处理程序的基本接口。

从以下版本开始：
JAX-WS 2.0

方法摘要
void | close(MessageContext context) 消息交换模式结束时调用，正好发生在 JAX-WS 运行时指派消息、错误或异常之前。
boolean | handleFault(C context) 可调用 handleFault 方法进行错误消息处理。
boolean | handleMessage(C context) 可调用 handleMessage 方法进行普通的入站和出站消息处理。

方法详细信息

handleMessage

boolean handleMessage(C context)
可调用 handleMessage 方法进行普通的入站和出站消息处理。有关完整信息，请参阅 JAX-WS 规范中处理程序框架的描述。

参数：
context - 消息上下文。
返回：
指示处理程序是否应该继续处理当前消息。
  • 返回 true 表示继续处理。
  • 返回 false 表示停止处理。
抛出：
RuntimeException - 使 JAX-WS 运行时停止处理程序的处理并生成一个错误。
ProtocolException - 使 JAX-WS 运行时切换到错误消息的处理。

handleFault

boolean handleFault(C context)
可调用 handleFault 方法进行错误消息处理。有关完整信息，请参阅 JAX-WS 规范中处理程序框架的描述。

参数：
context - 消息上下文
返回：
指示处理程序错误处理是否应该继续处理当前消息
  • 返回 true 表示继续处理。
  • 返回 false 表示停止处理。
抛出：
RuntimeException - 使 JAX-WS 运行时停止处理程序的错误处理并指派该错误。
ProtocolException - 使 JAX-WS 运行时停止处理程序的错误处理并指派该错误。

close

void close(MessageContext context)
消息交换模式结束时调用，正好发生在 JAX-WS 运行时指派消息、错误或异常之前。有关完整信息，请参阅 JAX-WS 规范中处理程序框架的描述。

参数：
context - 消息上下文
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


HandlerResolver (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.handler
接口 HandlerResolver

public interface HandlerResolver

HandlerResolver 是由应用程序实现的接口，用于控制创建 proxy/dispatch 对象时设置在这些对象上的处理程序链。

可以使用 setHandlerResolver 方法在 Service 上设置 HandlerResolver。

当运行时调用 HandlerResolver 时，将向它传递一个 PortInfo 对象，该对象中包含 proxy/dispatch 对象将访问的端口的信息。

从以下版本开始：
JAX-WS 2.0
另请参见：
Service.setHandlerResolver(javax.xml.ws.handler.HandlerResolver)

方法摘要
 List<Handler> getHandlerChain(PortInfo portInfo)
获取指定端口的处理程序链。

方法详细信息

getHandlerChain

List<Handler> getHandlerChain(PortInfo portInfo)
获取指定端口的处理程序链。

参数：
portInfo - 包含正被访问的端口的信息。
返回：
java.util.List 处理程序链
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogicalHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.handler
接口 LogicalHandler<C extends LogicalMessageContext>

所有超级接口：
Handler<C>
public interface LogicalHandler<C extends LogicalMessageContext>
extends Handler<C>

LogicalHandler 扩展了 Handler，以便为消息上下文参数提供输入安全性。

从以下版本开始：
JAX-WS 2.0

方法摘要
从接口 javax.xml.ws.handler.Handler 继承的方法
close, handleFault, handleMessage

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogicalMessageContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.handler
接口 LogicalMessageContext

所有超级接口：
Map<String,Object>, MessageContext
public interface LogicalMessageContext
extends MessageContext

LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。

从以下版本开始：
JAX-WS 2.0

嵌套类摘要
从接口 javax.xml.ws.handler.MessageContext 继承的嵌套类/接口
MessageContext.Scope
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
字段摘要
从接口 javax.xml.ws.handler.MessageContext 继承的字段
HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE
方法摘要
 LogicalMessage getMessage()
从此消息上下文中获得消息。
从接口 javax.xml.ws.handler.MessageContext 继承的方法
getScope, setScope
从接口 java.util.Map 继承的方法
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

方法详细信息

getMessage

LogicalMessage getMessage()
从此消息上下文中获得消息。

返回：
包含的消息；如果此消息上下文中没有消息，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.handler
接口 MessageContext

所有超级接口：
Map<String,Object>
所有已知子接口：
LogicalMessageContext, SOAPMessageContext
public interface MessageContext
extends Map<String,Object>

接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。

MessageContext 接口提供管理属性集的方法。MessageContext 属性使处理程序链中的处理程序能够共享相关处理状态。

从以下版本开始：
JAX-WS 2.0

嵌套类摘要
static class MessageContext.Scope
属性作用域。
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
字段摘要
static String | HTTP_REQUEST_HEADERS 标准属性：HTTP 请求头。
static String | HTTP_REQUEST_METHOD 标准属性：HTTP 请求方法。
static String | HTTP_RESPONSE_CODE 标准属性：HTTP 响应状态代码。
static String | HTTP_RESPONSE_HEADERS 标准属性：HTTP 响应头。
static String | INBOUND_MESSAGE_ATTACHMENTS 标准属性：用于入站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。
static String | MESSAGE_OUTBOUND_PROPERTY 标准属性：消息方向，对于出站消息为 true，对于入站消息为 false。
static String | OUTBOUND_MESSAGE_ATTACHMENTS 标准属性: 用于出站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。
static String | PATH_INFO 标准属性：请求路径信息
static String | QUERY_STRING 标准属性：请求的查询字符串。
static String | SERVLET_CONTEXT 标准属性：servlet 上下文对象
static String | SERVLET_REQUEST 标准属性：servlet 请求对象。
static String | SERVLET_RESPONSE 标准属性：servlet 响应对象。
static String | WSDL_DESCRIPTION 标准属性：WSDL 文档的输入源。
static String | WSDL_INTERFACE 标准属性：wsdl 接口 (2.0) 或端口类型 (1.1) 的名称。
static String | WSDL_OPERATION 标准属性：WSDL 操作的名称。
static String | WSDL_PORT 标准属性：WSDL 端口的名称。
static String | WSDL_SERVICE 标准属性：WSDL 服务的名称。
方法摘要
MessageContext.Scope | getScope(String name) 获得属性的作用域。
void | setScope(String name, MessageContext.Scope scope) 设置属性的作用域。
从接口 java.util.Map 继承的方法
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

字段详细信息

MESSAGE_OUTBOUND_PROPERTY

static final String MESSAGE_OUTBOUND_PROPERTY
标准属性：消息方向，对于出站消息为 true，对于入站消息为 false。

类型：boolean

另请参见：
常量字段值

INBOUND_MESSAGE_ATTACHMENTS

static final String INBOUND_MESSAGE_ATTACHMENTS
标准属性：用于入站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。

类型：java.util.Map

另请参见：
常量字段值

OUTBOUND_MESSAGE_ATTACHMENTS

static final String OUTBOUND_MESSAGE_ATTACHMENTS
标准属性: 用于出站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。

类型：java.util.Map

另请参见：
常量字段值

WSDL_DESCRIPTION

static final String WSDL_DESCRIPTION
标准属性：WSDL 文档的输入源。

类型：org.xml.sax.InputSource

另请参见：
常量字段值

WSDL_SERVICE

static final String WSDL_SERVICE
标准属性：WSDL 服务的名称。

类型：javax.xml.namespace.QName

另请参见：
常量字段值

WSDL_PORT

static final String WSDL_PORT
标准属性：WSDL 端口的名称。

类型：javax.xml.namespace.QName

另请参见：
常量字段值

WSDL_INTERFACE

static final String WSDL_INTERFACE
标准属性：wsdl 接口 (2.0) 或端口类型 (1.1) 的名称。

类型：javax.xml.namespace.QName

另请参见：
常量字段值

WSDL_OPERATION

static final String WSDL_OPERATION
标准属性：WSDL 操作的名称。

类型：javax.xml.namespace.QName

另请参见：
常量字段值

HTTP_RESPONSE_CODE

static final String HTTP_RESPONSE_CODE
标准属性：HTTP 响应状态代码。

类型：java.lang.Integer

另请参见：
常量字段值

HTTP_REQUEST_HEADERS

static final String HTTP_REQUEST_HEADERS
标准属性：HTTP 请求头。

类型：java.util.Map>

另请参见：
常量字段值

HTTP_RESPONSE_HEADERS

static final String HTTP_RESPONSE_HEADERS
标准属性：HTTP 响应头。

类型：java.util.Map>

另请参见：
常量字段值

HTTP_REQUEST_METHOD

static final String HTTP_REQUEST_METHOD
标准属性：HTTP 请求方法。

类型：java.lang.String

另请参见：
常量字段值

SERVLET_REQUEST

static final String SERVLET_REQUEST
标准属性：servlet 请求对象。

类型：javax.servlet.http.HttpServletRequest

另请参见：
常量字段值

SERVLET_RESPONSE

static final String SERVLET_RESPONSE
标准属性：servlet 响应对象。

类型：javax.servlet.http.HttpServletResponse

另请参见：
常量字段值

SERVLET_CONTEXT

static final String SERVLET_CONTEXT
标准属性：servlet 上下文对象

类型：javax.servlet.ServletContext

另请参见：
常量字段值

QUERY_STRING

static final String QUERY_STRING
标准属性：请求的查询字符串。

类型：String

另请参见：
常量字段值

PATH_INFO

static final String PATH_INFO
标准属性：请求路径信息

类型：String

另请参见：
常量字段值
方法详细信息

setScope

void setScope(String name,
              MessageContext.Scope scope)
设置属性的作用域。

参数：
name - 与 MessageContext 关联的属性的名称
scope - 所需的属性作用域
抛出：
IllegalArgumentException - 如果指定的属性名称不合法

getScope

MessageContext.Scope getScope(String name)
获得属性的作用域。

参数：
name - 属性的名称
返回：
属性的作用域
抛出：
IllegalArgumentException - 如果指定的属性名称不存在
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageContext.Scope (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.xml.ws.handler
枚举 MessageContext.Scope

java.lang.Object
    继承者  java.lang.Enum<MessageContext.Scope>
        继承者  javax.xml.ws.handler.MessageContext.Scope
所有已实现的接口：
Serializable, Comparable<MessageContext.Scope>
正在封闭接口：
MessageContext
public static enum MessageContext.Scope
extends Enum<MessageContext.Scope>

属性作用域。作用域为 APPLICATION 的属性对于处理程序、客户端应用程序和服务端点是可看的；作用域为 HANDLER 的属性通常只对于处理程序是可见的。

枚举常量摘要
APPLICATION
HANDLER
方法摘要
static MessageContext.Scope | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MessageContext.Scope[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

APPLICATION

public static final MessageContext.Scope APPLICATION

HANDLER

public static final MessageContext.Scope HANDLER
方法详细信息

values

public static final MessageContext.Scope[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(MessageContext.Scope c : MessageContext.Scope.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static MessageContext.Scope valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


PortInfo (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.handler
接口 PortInfo

public interface PortInfo

HandlerResolver 使用 PortInfo 接口查询有关要用来创建处理程序链的端口的信息。

此接口不能由应用程序实现，只能由 JAX-WS 实现实现。

从以下版本开始：
JAX-WS 2.0

方法摘要
String | getBindingID() 获取标识正由被访问的端口所用绑定的 URI。
QName | getPortName() 获取正被访问的 WSDL 端口的限定名。
QName | getServiceName() 获取包含正被访问端口的 WSDL 服务名称的限定名。

方法详细信息

getServiceName

QName getServiceName()
获取包含正被访问端口的 WSDL 服务名称的限定名。

返回：
javax.xml.namespace.QName WSDL 服务的限定名。

getPortName

QName getPortName()
获取正被访问的 WSDL 端口的限定名。

返回：
javax.xml.namespace.QName WSDL 端口的限定名。

getBindingID

String getBindingID()
获取标识正由被访问的端口所用绑定的 URI。

返回：
String 端口的绑定标识符。
另请参见：
Binding
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.ws.handler (Java Platform SE 6)

 javax.xml.ws.handler
接口
Handler
HandlerResolver
LogicalHandler
LogicalMessageContext
MessageContext
PortInfo
枚举
MessageContext.Scope


javax.xml.ws.handler (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.ws.handler

该包定义用于消息处理程序的 API。

请参见：
描述

接口摘要
Handler<C extends MessageContext> | Handler 接口是 JAX-WS 处理程序的基本接口。
HandlerResolver | HandlerResolver 是由应用程序实现的接口，用于控制创建 proxy/dispatch 对象时设置在这些对象上的处理程序链。
LogicalHandler<C extends LogicalMessageContext> | LogicalHandler 扩展了 Handler，以便为消息上下文参数提供输入安全性。
LogicalMessageContext | LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。
MessageContext | 接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。
PortInfo | HandlerResolver 使用 PortInfo 接口查询有关要用来创建处理程序链的端口的信息。

枚举摘要
MessageContext.Scope 属性作用域。

软件包 javax.xml.ws.handler 的描述

该包定义用于消息处理程序的 API。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.ws.handler 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.handler 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
  • javax.xml.ws.handler.HandlerResolver
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
  • javax.xml.ws.handler.PortInfo

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.handler.MessageContext.Scope
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.ws.handler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.handler
的使用

使用 javax.xml.ws.handler 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 使用的 javax.xml.ws.handler 中的类
Handler
Handler 接口是 JAX-WS 处理程序的基本接口。
HandlerResolver
HandlerResolver 是由应用程序实现的接口，用于控制创建 proxy/dispatch 对象时设置在这些对象上的处理程序链。
MessageContext
接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。

javax.xml.ws.handler 使用的 javax.xml.ws.handler 中的类
Handler
Handler 接口是 JAX-WS 处理程序的基本接口。
LogicalMessageContext
LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。
MessageContext
接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。
MessageContext.Scope
属性作用域。
PortInfo
HandlerResolver 使用 PortInfo 接口查询有关要用来创建处理程序链的端口的信息。

javax.xml.ws.handler.soap 使用的 javax.xml.ws.handler 中的类
Handler
Handler 接口是 JAX-WS 处理程序的基本接口。
MessageContext
接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。

javax.xml.ws.spi 使用的 javax.xml.ws.handler 中的类
HandlerResolver
HandlerResolver 是由应用程序实现的接口，用于控制创建 proxy/dispatch 对象时设置在这些对象上的处理程序链。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


SOAPHandler (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.handler.soap
接口 SOAPHandler<T extends SOAPMessageContext>

所有超级接口：
Handler<T>
public interface SOAPHandler<T extends SOAPMessageContext>
extends Handler<T>

SOAPHandler 类扩展了 Handler，以便为消息上下文参数提供输入安全性，并添加了一个方法，以访问可能由该处理程序处理的头。

从以下版本开始：
JAX-WS 2.0

方法摘要
 Set<QName> getHeaders()
获取可以由此处理程序实例处理的头块。
从接口 javax.xml.ws.handler.Handler 继承的方法
close, handleFault, handleMessage

方法详细信息

getHeaders

Set<QName> getHeaders()
获取可以由此处理程序实例处理的头块。

返回：
由此处理程序实例处理的头块的 QName 集合。QName 是头块最外部元素的限定名。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SOAPMessageContext (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.handler.soap
接口 SOAPMessageContext

所有超级接口：
Map<String,Object>, MessageContext
public interface SOAPMessageContext
extends MessageContext

接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。javax.xml.soap.SOAPMessage 为带有附件的 SOAP 1.1 消息表示形式指定标准的 Java API。

从以下版本开始：
JAX-WS 2.0
另请参见：
SOAPMessage

嵌套类摘要
从接口 javax.xml.ws.handler.MessageContext 继承的嵌套类/接口
MessageContext.Scope
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
字段摘要
从接口 javax.xml.ws.handler.MessageContext 继承的字段
HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE
方法摘要
Object[] | getHeaders(QName header, JAXBContext context, boolean allRoles) 从消息上下文的消息中获得具有特定限定名的头。
SOAPMessage | getMessage() 从此消息上下文中获取 SOAPMessage。
Set<String> | getRoles() 获取与执行处理程序链关联的 SOAP 参与者角色。
void | setMessage(SOAPMessage message) 在此消息上下文中设置 SOAPMessage。
从接口 javax.xml.ws.handler.MessageContext 继承的方法
getScope, setScope
从接口 java.util.Map 继承的方法
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

方法详细信息

getMessage

SOAPMessage getMessage()
从此消息上下文中获取 SOAPMessage。对返回的 SOAPMessage 所做的修改会原地更改消息，因此没有必要随后调用 setMessage。

返回：
返回 SOAPMessage；如果此消息上下文中没有 SOAPMessage，则返回 null。

setMessage

void setMessage(SOAPMessage message)
在此消息上下文中设置 SOAPMessage。

参数：
message - SOAP 消息
抛出：
WebServiceException - 如果在此消息上下文中设置 SOAPMessage 时发生任何错误
UnsupportedOperationException - 如果此操作不受支持

getHeaders

Object[] getHeaders(QName header,
                    JAXBContext context,
                    boolean allRoles)
从消息上下文的消息中获得具有特定限定名的头。注意，SOAP 消息可以包含具有相同限定名的多个头。

参数：
header - SOAP 头的 XML 限定名。
context - 应该用于解组头的 JAXBContext
allRoles - 如果该参数为 true，则返回所有 SOAP 角色的头；如果该参数为 false，则只返回以此 SOAP 节点当前正扮演的角色为目标的头，请参见 getRoles。
返回：
已解组的头的数组；如果此消息上下文中没有消息，或者没有与提供的限定名相匹配的头，则返回空数组。
抛出：
WebServiceException - 如果在使用提供的 JAXBContext 进行解组时发生错误。WebServiceException 的 cause 是初始 JAXBException。

getRoles

Set<String> getRoles()
获取与执行处理程序链关联的 SOAP 参与者角色。注意，SOAP 参与者角色适用于 SOAP 节点，并使用 SOAPBinding.setRoles 和 SOAPBinding.getRoles 进行管理。处理程序链中的处理程序实例使用有关 SOAP 参与者角色的信息来处理 SOAP 头块。注意，在通过处理程序链处理 SOAP 消息的过程中，SOAP 参与者角色是不变的。

返回：
SOAP 参与者角色的 String 数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.ws.handler.soap (Java Platform SE 6)

 javax.xml.ws.handler.soap
接口
SOAPHandler
SOAPMessageContext


javax.xml.ws.handler.soap (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.ws.handler.soap

该包定义用于 SOAP 消息处理程序的 API。

请参见：
描述

接口摘要
SOAPHandler<T extends SOAPMessageContext> | SOAPHandler 类扩展了 Handler，以便为消息上下文参数提供输入安全性，并添加了一个方法，以访问可能由该处理程序处理的头。
SOAPMessageContext | 接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。

软件包 javax.xml.ws.handler.soap 的描述

该包定义用于 SOAP 消息处理程序的 API。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.ws.handler.soap 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.handler.soap 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.ws.handler.soap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.handler.soap
的使用

使用 javax.xml.ws.handler.soap 的软件包
javax.xml.ws.handler.soap 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws.handler.soap 使用的 javax.xml.ws.handler.soap 中的类
SOAPMessageContext
接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.handler.soap.SOAPHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.soap.SOAPHandler
的使用

没有 javax.xml.ws.handler.soap.SOAPHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.handler.soap.SOAPMessageContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.soap.SOAPMessageContext
的使用

使用 SOAPMessageContext 的软件包
javax.xml.ws.handler.soap 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws.handler.soap 中 SOAPMessageContext 的使用

类型参数类型为 SOAPMessageContext 的 javax.xml.ws.handler.soap 中的类
 interface SOAPHandler<T extends SOAPMessageContext>
SOAPHandler 类扩展了 Handler，以便为消息上下文参数提供输入安全性，并添加了一个方法，以访问可能由该处理程序处理的头。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.handler.Handler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.Handler
的使用

使用 Handler 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws 中 Handler 的使用

返回变量类型为 Handler 的类型的 javax.xml.ws 中的方法
 List<Handler> Binding.getHandlerChain()
获取协议绑定实例处理程序链的副本。

类型变量类型为 Handler 的 javax.xml.ws 中的方法参数
 void Binding.setHandlerChain(List<Handler> chain)
设置协议绑定实例的处理程序链。

javax.xml.ws.handler 中 Handler 的使用

javax.xml.ws.handler 中 Handler 的子接口
 interface LogicalHandler<C extends LogicalMessageContext>
LogicalHandler 扩展了 Handler，以便为消息上下文参数提供输入安全性。

返回变量类型为 Handler 的类型的 javax.xml.ws.handler 中的方法
 List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
获取指定端口的处理程序链。

javax.xml.ws.handler.soap 中 Handler 的使用

javax.xml.ws.handler.soap 中 Handler 的子接口
 interface SOAPHandler<T extends SOAPMessageContext>
SOAPHandler 类扩展了 Handler，以便为消息上下文参数提供输入安全性，并添加了一个方法，以访问可能由该处理程序处理的头。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.handler.HandlerResolver 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.HandlerResolver
的使用

使用 HandlerResolver 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 中 HandlerResolver 的使用

返回 HandlerResolver 的 javax.xml.ws 中的方法
 HandlerResolver Service.getHandlerResolver()
返回已配置的处理程序解析器。

参数类型为 HandlerResolver 的 javax.xml.ws 中的方法
 void Service.setHandlerResolver(HandlerResolver handlerResolver)
设置此 Service 实例的 HandlerResolver。

javax.xml.ws.spi 中 HandlerResolver 的使用

返回 HandlerResolver 的 javax.xml.ws.spi 中的方法
abstract  HandlerResolver ServiceDelegate.getHandlerResolver()
返回已配置的处理程序解析器。

参数类型为 HandlerResolver 的 javax.xml.ws.spi 中的方法
abstract  void ServiceDelegate.setHandlerResolver(HandlerResolver handlerResolver)
为此 Service 实例设置 HandlerResolver。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.handler.LogicalHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.LogicalHandler
的使用

没有 javax.xml.ws.handler.LogicalHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.handler.LogicalMessageContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.LogicalMessageContext
的使用

使用 LogicalMessageContext 的软件包
javax.xml.ws.handler 该包定义用于消息处理程序的 API。

javax.xml.ws.handler 中 LogicalMessageContext 的使用

类型参数类型为 LogicalMessageContext 的 javax.xml.ws.handler 中的类
 interface LogicalHandler<C extends LogicalMessageContext>
LogicalHandler 扩展了 Handler，以便为消息上下文参数提供输入安全性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.handler.MessageContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.MessageContext
的使用

使用 MessageContext 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws 中 MessageContext 的使用

返回 MessageContext 的 javax.xml.ws 中的方法
 MessageContext WebServiceContext.getMessageContext()
调用此方法时，返回正在服务的请求的 MessageContext。

javax.xml.ws.handler 中 MessageContext 的使用

类型参数类型为 MessageContext 的 javax.xml.ws.handler 中的类
 interface Handler<C extends MessageContext>
Handler 接口是 JAX-WS 处理程序的基本接口。

javax.xml.ws.handler 中 MessageContext 的子接口
 interface LogicalMessageContext
LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。

参数类型为 MessageContext 的 javax.xml.ws.handler 中的方法
 void Handler.close(MessageContext context)
消息交换模式结束时调用，正好发生在 JAX-WS 运行时指派消息、错误或异常之前。

javax.xml.ws.handler.soap 中 MessageContext 的使用

javax.xml.ws.handler.soap 中 MessageContext 的子接口
 interface SOAPMessageContext
接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.handler.MessageContext.Scope 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.handler.MessageContext.Scope
的使用

使用 MessageContext.Scope 的软件包
javax.xml.ws.handler 该包定义用于消息处理程序的 API。

javax.xml.ws.handler 中 MessageContext.Scope 的使用

返回 MessageContext.Scope 的 javax.xml.ws.handler 中的方法
MessageContext.Scope | MessageContext.getScope(String name) 获得属性的作用域。
static MessageContext.Scope | MessageContext.Scope.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MessageContext.Scope[] | MessageContext.Scope.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 MessageContext.Scope 的 javax.xml.ws.handler 中的方法
 void MessageContext.setScope(String name, MessageContext.Scope scope)
设置属性的作用域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.handler.PortInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.handler.PortInfo
的使用

使用 PortInfo 的软件包
javax.xml.ws.handler 该包定义用于消息处理程序的 API。

javax.xml.ws.handler 中 PortInfo 的使用

参数类型为 PortInfo 的 javax.xml.ws.handler 中的方法
 List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
获取指定端口的处理程序链。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


HTTPBinding (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.http
接口 HTTPBinding

所有超级接口：
Binding
public interface HTTPBinding
extends Binding

HTTPBinding 接口是 XML/HTTP 绑定的抽象。

从以下版本开始：
JAX-WS 2.0

字段摘要
static String HTTP_BINDING
表示 XML/HTTP 绑定标识的常量。
方法摘要
从接口 javax.xml.ws.Binding 继承的方法
getHandlerChain, setHandlerChain

字段详细信息

HTTP_BINDING

static final String HTTP_BINDING
表示 XML/HTTP 绑定标识的常量。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


HTTPException (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.http
类 HTTPException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.xml.ws.WebServiceException
                    继承者  javax.xml.ws.ProtocolException
                        继承者  javax.xml.ws.http.HTTPException
所有已实现的接口：
Serializable
public class HTTPException
extends ProtocolException

HTTPException 异常表示一个 XML/HTTP 故障。

由于在 XML/HTTP 消息传递中没有故障或异常的标准格式，因此只捕获 HTTP 状态代码。

从以下版本开始：
JAX-WS 2.0
另请参见：
序列化表格

构造方法摘要
HTTPException(int statusCode)
HTTPException 的构造方法
方法摘要
 int getStatusCode()
获取 HTTP 状态代码。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HTTPException

public HTTPException(int statusCode)
HTTPException 的构造方法

参数：
statusCode - HTTP 状态代码的 int 值
方法详细信息

getStatusCode

public int getStatusCode()
获取 HTTP 状态代码。

返回：
HTTP 状态代码
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.ws.http (Java Platform SE 6)

 javax.xml.ws.http
接口
HTTPBinding
异常
HTTPException


javax.xml.ws.http (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.ws.http

该包定义特定于 HTTP 绑定的 API。

请参见：
描述

接口摘要
HTTPBinding HTTPBinding 接口是 XML/HTTP 绑定的抽象。

异常摘要
HTTPException HTTPException 异常表示一个 XML/HTTP 故障。

软件包 javax.xml.ws.http 的描述

该包定义特定于 HTTP 绑定的 API。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.ws.http 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.http 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException

接口分层结构

  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.ws.http 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.http
的使用

没有 javax.xml.ws.http 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.http.HTTPBinding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.http.HTTPBinding
的使用

没有 javax.xml.ws.http.HTTPBinding 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.http.HTTPException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.http.HTTPException
的使用

没有 javax.xml.ws.http.HTTPException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


SOAPBinding (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.soap
接口 SOAPBinding

所有超级接口：
Binding
public interface SOAPBinding
extends Binding

SOAPBinding 接口是 SOAP 绑定的抽象。

从以下版本开始：
JAX-WS 2.0

字段摘要
static String | SOAP11HTTP_BINDING 表示 HTTP 绑定上的 SOAP 1.1 标识的常量。
static String | SOAP11HTTP_MTOM_BINDING 表示 HTTP 绑定上的 SOAP 1.1 标识，且默认启用 MTOM 的常量。
static String | SOAP12HTTP_BINDING 表示 HTTP 绑定上的 SOAP 1.2 标识的常量。
static String | SOAP12HTTP_MTOM_BINDING 表示 HTTP 绑定上的 SOAP 1.2 标识，且默认启用 MTOM 的常量。
方法摘要
MessageFactory | getMessageFactory() 获取此 SOAP 绑定使用的 SAAJ MessageFactory 实例。
Set<String> | getRoles() 获取 SOAP 绑定实例所扮演的角色。
SOAPFactory | getSOAPFactory() 获取此 SOAP 绑定使用的 SAAJ SOAPFactory 实例。
boolean | isMTOMEnabled() 如果启用了 MTOM，则返回 true。
void | setMTOMEnabled(boolean flag) 启用或禁用 MTOM。
void | setRoles(Set<String> roles) 设置由 SOAP 绑定实例扮演的角色。
从接口 javax.xml.ws.Binding 继承的方法
getHandlerChain, setHandlerChain

字段详细信息

SOAP11HTTP_BINDING

static final String SOAP11HTTP_BINDING
表示 HTTP 绑定上的 SOAP 1.1 标识的常量。

另请参见：
常量字段值

SOAP12HTTP_BINDING

static final String SOAP12HTTP_BINDING
表示 HTTP 绑定上的 SOAP 1.2 标识的常量。

另请参见：
常量字段值

SOAP11HTTP_MTOM_BINDING

static final String SOAP11HTTP_MTOM_BINDING
表示 HTTP 绑定上的 SOAP 1.1 标识，且默认启用 MTOM 的常量。

另请参见：
常量字段值

SOAP12HTTP_MTOM_BINDING

static final String SOAP12HTTP_MTOM_BINDING
表示 HTTP 绑定上的 SOAP 1.2 标识，且默认启用 MTOM 的常量。

另请参见：
常量字段值
方法详细信息

getRoles

Set<String> getRoles()
获取 SOAP 绑定实例所扮演的角色。

返回：
Set 绑定实例所扮演的角色的集合。

setRoles

void setRoles(Set<String> roles)
设置由 SOAP 绑定实例扮演的角色。

参数：
roles - 绑定实例所扮演的角色的集合。
抛出：
WebServiceException - 当角色列表的配置中发生错误时。

isMTOMEnabled

boolean isMTOMEnabled()
如果启用了 MTOM，则返回 true。

返回：
当且仅当启用 MTOM 时，返回 true。

setMTOMEnabled

void setMTOMEnabled(boolean flag)
启用或禁用 MTOM。

参数：
flag - 指定是应该启用 MTOM 还是应该禁用 MTOM 的 boolean。
抛出：
WebServiceException - 如果此绑定实例不支持指定的设置。

getSOAPFactory

SOAPFactory getSOAPFactory()
获取此 SOAP 绑定使用的 SAAJ SOAPFactory 实例。

返回：
此 SOAP 绑定使用的 SOAPFactory 实例。

getMessageFactory

MessageFactory getMessageFactory()
获取此 SOAP 绑定使用的 SAAJ MessageFactory 实例。

返回：
此 SOAP 绑定使用的 MessageFactory 实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SOAPFaultException (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.soap
类 SOAPFaultException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.xml.ws.WebServiceException
                    继承者  javax.xml.ws.ProtocolException
                        继承者  javax.xml.ws.soap.SOAPFaultException
所有已实现的接口：
Serializable
public class SOAPFaultException
extends ProtocolException

SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

SOAPFaultException 包装了一个管理特定于 SOAP 的故障表示形式的 SAAJ SOAPFault。可以使用 javax.xml.soap.SOAPFactory 的 createFault 方法创建一个 javax.xml.soap.SOAPFault 实例，以供构造方法使用。SOAPBinding 包含一个存取程序，该存取程序用于由绑定实例使用的 SOAPFactory。

注意，getFault 的值是序列化 SOAP 故障时所使用的唯一异常部分。

有关 SOAP 故障的完整描述，请参考 SOAP 规范。

从以下版本开始：
JAX-WS 2.0
另请参见：
SOAPFault, SOAPBinding.getSOAPFactory(), ProtocolException, 序列化表格

构造方法摘要
SOAPFaultException(SOAPFault fault)
SOAPFaultException 的构造方法
方法摘要
 SOAPFault getFault()
获取嵌入的 SOAPFault 实例。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SOAPFaultException

public SOAPFaultException(SOAPFault fault)
SOAPFaultException 的构造方法

参数：
fault - 表示故障的 SOAPFault
另请参见：
SOAPFactory.createFault(java.lang.String, javax.xml.namespace.QName)
方法详细信息

getFault

public SOAPFault getFault()
获取嵌入的 SOAPFault 实例。

返回：
javax.xml.soap.SOAPFault SOAP 故障元素
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.ws.soap (Java Platform SE 6)

 javax.xml.ws.soap
接口
SOAPBinding
异常
SOAPFaultException


javax.xml.ws.soap (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.ws.soap

该包定义特定于 SOAP 绑定的 API。

请参见：
描述

接口摘要
SOAPBinding SOAPBinding 接口是 SOAP 绑定的抽象。

异常摘要
SOAPFaultException SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

软件包 javax.xml.ws.soap 的描述

该包定义特定于 SOAP 绑定的 API。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.ws.soap 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.soap 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.soap.SOAPFaultException

接口分层结构

  • javax.xml.ws.Binding
    • javax.xml.ws.soap.SOAPBinding
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.ws.soap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.soap
的使用

没有 javax.xml.ws.soap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.soap.SOAPBinding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.soap.SOAPBinding
的使用

没有 javax.xml.ws.soap.SOAPBinding 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.soap.SOAPFaultException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.soap.SOAPFaultException
的使用

没有 javax.xml.ws.soap.SOAPFaultException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Provider (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.spi
类 Provider

java.lang.Object
    继承者  javax.xml.ws.spi.Provider

public abstract class Provider
extends Object

ServiceDelegate 和 Endpoint 对象的服务提供者。

从以下版本开始：
JAX-WS 2.0

字段摘要
static String JAXWSPROVIDER_PROPERTY
表示用于查找 Provider 实现类名称的属性的常量。
构造方法摘要
protected Provider()
创建一个新的 Provider 实例。
方法摘要
abstract Endpoint | createAndPublishEndpoint(String address, Object implementor) 创建和发布具有指定地址和实现对象的端点对象。
abstract Endpoint | createEndpoint(String bindingId, Object implementor) 创建具有提供的绑定和实现对象的端点对象。
abstract ServiceDelegate | createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass) 创建一个服务委托对象。
static Provider | provider() 创建一个新的提供者对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

JAXWSPROVIDER_PROPERTY

public static final String JAXWSPROVIDER_PROPERTY
表示用于查找 Provider 实现类名称的属性的常量。

另请参见：
常量字段值
构造方法详细信息

Provider

protected Provider()
创建一个新的 Provider 实例。

方法详细信息

provider

public static Provider provider()
创建一个新的提供者对象。

用于查找将要使用的提供者子类的算法由以下几个步骤组成：

  • 如果存在名为 META-INF/services/javax.xml.ws.spi.Provider 的资源，则它的第一行（如果存在）被用作实现类的 UTF-8 编码名称。
  • 如果存在 $java.home/lib/jaxws.properties 文件，可以通过 java.util.Properties.load(InputStream) 方法读取它，并且该文件包含键为 javax.xml.ws.spi.Provider 的条目，则该条目的值被用作实现类的名称。
  • 如果定义了名为 javax.xml.ws.spi.Provider 的系统属性，则它的值被用作实现类的名称。
  • 最后，使用默认的实现类名称。

createServiceDelegate

public abstract ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation,
                                                      QName serviceName,
                                                      Class serviceClass)
创建一个服务委托对象。

参数：
wsdlDocumentLocation - 指向服务的 WSDL 文档的 URL，如果不存在 URL，则该参数为 null。
serviceName - 服务的限定名。
serviceClass - 服务类，它必须是 javax.xml.ws.Service 或其一个子类。
返回：
新创建的服务委托。

createEndpoint

public abstract Endpoint createEndpoint(String bindingId,
                                        Object implementor)
创建具有提供的绑定和实现对象的端点对象。

参数：
bindingId - 指定所需绑定的 URI（例如 SOAP/HTTP）
implementor - 服务实现对象，传入请求将被指派到该对象。必须使用所有必要的 Web 服务注释对相应的类进行注释。
返回：
新创建的端点。

createAndPublishEndpoint

public abstract Endpoint createAndPublishEndpoint(String address,
                                                  Object implementor)
创建和发布具有指定地址和实现对象的端点对象。

参数：
address - 指定要使用的地址和传输/协议的 URI。一个 http 地址：URI 必须指向正使用的 SOAP 1.1/HTTP。实现可以支持其他 URI 方案。
implementor - 服务实现对象，传入请求将被指派到该对象。必须使用所有必要的 Web 服务注释对相应的类进行注释。
返回：
新创建的端点。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ServiceDelegate (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.ws.spi
类 ServiceDelegate

java.lang.Object
    继承者  javax.xml.ws.spi.ServiceDelegate

public abstract class ServiceDelegate
extends Object

服务委托由 Service 对象内部使用，以允许插入 JAX-WS 实现。

每个 Service 对象都有自己的代理，这些代理是使用 javax.xml.ws.Provider#createServiceDelegate 方法创建的。Service 对象将其所有实例方法都委托给它的代理。

从以下版本开始：
JAX-WS 2.0
另请参见：
Service, Provider

构造方法摘要
protected ServiceDelegate()
方法摘要
abstract  void addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。
abstract
<T> Dispatch<T>
createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。
abstract  Executor getExecutor()
返回此 Service 实例的执行程序。
abstract  HandlerResolver getHandlerResolver()
返回已配置的处理程序解析器。
abstract
<T> T
getPort(Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块。
abstract
<T> T
getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块 (stub)。
abstract  Iterator<QName> getPorts()
返回一个 Iterator，该迭代器用于根据此服务分组的服务端点的 QName 列表。
abstract  QName getServiceName()
获取此服务的名称。
abstract  URL getWSDLDocumentLocation()
获取此服务的 WSDL 文档的位置。
abstract  void setExecutor(Executor executor)
设置此 Service 实例的执行程序。
abstract  void setHandlerResolver(HandlerResolver handlerResolver)
为此 Service 实例设置 HandlerResolver。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceDelegate

protected ServiceDelegate()
方法详细信息

getPort

public abstract <T> T getPort(QName portName,
                              Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块 (stub)。服务客户端使用此桩模块调用目标服务端点上的操作。serviceEndpointInterface 指定受已创建的动态代理或桩模块实例支持的服务端点接口。

参数：
portName - WSDL 服务描述中的服务端点的限定名称
serviceEndpointInterface - 动态代理或桩模块实例支持的服务端点接口
返回：
支持指定服务端点接口的对象代理实例
抛出：
WebServiceException - 出现以下情况时会抛出该异常：
  • 如果创建代理的过程中发生错误
  • 如果缺少此方法所需的任何 WSDL 元数据
  • 如果指定了非法的 serviceEndpointInterface 或 portName
另请参见：
Proxy, InvocationHandler

getPort

public abstract <T> T getPort(Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块。参数 serviceEndpointInterface 指定返回代理所支持的服务端点接口。在实现此方法的过程中，JAX-WS 运行时系统负责选择协议绑定（和端口）并相应地配置代理。返回的代理不应该由客户端进行配置。

参数：
serviceEndpointInterface - 服务端点接口
返回：
支持指定服务端点接口的对象实例
抛出：
WebServiceException -
  • 如果创建代理的过程中发生错误
  • 如果缺少此方法所需的任何 WSDL 元数据
  • 如果指定了非法的 serviceEndpointInterface

addPort

public abstract void addPort(QName portName,
                             String bindingId,
                             String endpointAddress)
为服务创建新的端口。用这种方式创建的端口不包含 WSDL 端口类型信息，并且只能用于创建 Dispatch 实例。

参数：
portName - 目标服务端点的限定名称
bindingId - 绑定的 URI 标识符。
endpointAddress - URI 形式的目标服务端点地址
抛出：
WebServiceException - 如果创建端口的过程中发生错误
另请参见：
SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

createDispatch

public abstract <T> Dispatch<T> createDispatch(QName portName,
                                               Class<T> type,
                                               Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。

参数：
portName - 目标服务端点的限定名称
type - 用于消息或消息负载的对象的类。支持 javax.xml.transform.Source 和 javax.xml.soap.SOAPMessage 所需的实现
mode - 控制创建的 dispatch 实例是消息还是消息负载，即用户使用的是完整的协议消息还是消息负载。例如，当使用 SOAP 协议时，该参数将控制用户是使用 SOAP 消息还是使用 SOAP 正文的内容。当类型为 SOAPMessage 时，模式必须为 MESSAGE。
返回：
Dispatch 实例
抛出：
WebServiceException - 如果创建 Dispatch 对象的过程中发生错误
另请参见：
Source, SOAPMessage

createDispatch

public abstract Dispatch<Object> createDispatch(QName portName,
                                                JAXBContext context,
                                                Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

参数：
portName - 目标服务端点的限定名称
context - 用来对消息或消息负载进行编组和解组的 JAXB 上下文。
mode - 控制创建的 dispatch 实例是消息还是消息负载，即用户使用的是完整的协议消息还是消息负载。例如，当使用 SOAP 协议时，该参数将控制用户是使用 SOAP 消息还是使用 SOAP 正文的内容。
返回：
dispatch 实例
抛出：
ServiceException - 如果创建 Dispatch 对象的过程中发生错误
另请参见：
JAXBContext

getServiceName

public abstract QName getServiceName()
获取此服务的名称。

返回：
此服务的限定名称

getPorts

public abstract Iterator<QName> getPorts()
返回一个 Iterator，该迭代器用于根据此服务分组的服务端点的 QName 列表。

返回：
返回元素类型为 javax.xml.namespace.QName 的 java.util.Iterator
抛出：
WebServiceException - 如果此服务类没有访问所需 WSDL 元数据的权限

getWSDLDocumentLocation

public abstract URL getWSDLDocumentLocation()
获取此服务的 WSDL 文档的位置。

返回：
此服务的 WSDL 文档位置的 URL

getHandlerResolver

public abstract HandlerResolver getHandlerResolver()
返回已配置的处理程序解析器。

返回：
此 Service 实例正在使用的 HandlerResolver；如果不存在该解析器，则返回 null。

setHandlerResolver

public abstract void setHandlerResolver(HandlerResolver handlerResolver)
为此 Service 实例设置 HandlerResolver。

如果存在处理程序解析器，则对每个已创建的代理或 dispatch 实例调用一次该解析器，然后在实例上设置解析器返回的处理程序链。

参数：
handlerResolver - 用于所有随后创建的代理/调度对象的 HandlerResolver。
另请参见：
HandlerResolver

getExecutor

public abstract Executor getExecutor()
返回此 Service 实例的执行程序。 该执行程序将用于所有需要回调的异步调用。

返回：
将用来调用回调的 java.util.concurrent.Executor。
另请参见：
Executor

setExecutor

public abstract void setExecutor(Executor executor)
设置此 Service 实例的执行程序。 该执行程序将用于所有需要回调的异步调用。

参数：
executor - 将用来调用回调的 java.util.concurrent.Executor。
抛出：
SecurityException - 如果出于安全的原因（例如，缺少必要的权限）该实例不支持设置执行程序。
另请参见：
Executor
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.ws.spi (Java Platform SE 6)

 javax.xml.ws.spi
类
Provider
ServiceDelegate


javax.xml.ws.spi (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.ws.spi

该包定义用于 JAX-WS 2.0 的 SPI。

请参见：
描述

类摘要
Provider | ServiceDelegate 和 Endpoint 对象的服务提供者。
ServiceDelegate | 服务委托由 Service 对象内部使用，以允许插入 JAX-WS 实现。

软件包 javax.xml.ws.spi 的描述

该包定义用于 JAX-WS 2.0 的 SPI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.ws.spi 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.ws.spi.Provider
    • javax.xml.ws.spi.ServiceDelegate
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.ws.spi 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.ws.spi
的使用

使用 javax.xml.ws.spi 的软件包
javax.xml.ws.spi 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws.spi 使用的 javax.xml.ws.spi 中的类
Provider
ServiceDelegate 和 Endpoint 对象的服务提供者。
ServiceDelegate
服务委托由 Service 对象内部使用，以允许插入 JAX-WS 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.spi.Provider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.spi.Provider
的使用

使用 Provider 的软件包
javax.xml.ws.spi 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws.spi 中 Provider 的使用

返回 Provider 的 javax.xml.ws.spi 中的方法
static Provider Provider.provider()
创建一个新的提供者对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.spi.ServiceDelegate 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.spi.ServiceDelegate
的使用

使用 ServiceDelegate 的软件包
javax.xml.ws.spi 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws.spi 中 ServiceDelegate 的使用

返回 ServiceDelegate 的 javax.xml.ws.spi 中的方法
abstract  ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass)
创建一个服务委托对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.AsyncHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.AsyncHandler
的使用

使用 AsyncHandler 的软件包
javax.xml.ws 此包包含核心 JAX-WS API。

javax.xml.ws 中 AsyncHandler 的使用

参数类型为 AsyncHandler 的 javax.xml.ws 中的方法
 Future<?> Dispatch.invokeAsync(T msg, AsyncHandler<T> handler)
异步调用服务操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.Binding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.Binding
的使用

使用 Binding 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.ws 中 Binding 的使用

返回 Binding 的 javax.xml.ws 中的方法
Binding | BindingProvider.getBinding() 获取此绑定提供者的 Binding。
abstract Binding | Endpoint.getBinding() 返回此端点的绑定。

javax.xml.ws.http 中 Binding 的使用

javax.xml.ws.http 中 Binding 的子接口
 interface HTTPBinding
HTTPBinding 接口是 XML/HTTP 绑定的抽象。

javax.xml.ws.soap 中 Binding 的使用

javax.xml.ws.soap 中 Binding 的子接口
 interface SOAPBinding
SOAPBinding 接口是 SOAP 绑定的抽象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.BindingProvider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.BindingProvider
的使用

使用 BindingProvider 的软件包
javax.xml.ws 此包包含核心 JAX-WS API。

javax.xml.ws 中 BindingProvider 的使用

javax.xml.ws 中 BindingProvider 的子接口
 interface Dispatch<T>
Dispatch 接口提供对动态调用服务端点操作的支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.BindingType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.BindingType
的使用

没有 javax.xml.ws.BindingType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.Dispatch 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.Dispatch
的使用

使用 Dispatch 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 中 Dispatch 的使用

返回 Dispatch 的 javax.xml.ws 中的方法
<T> Dispatch<T>
Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
 Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。

javax.xml.ws.spi 中 Dispatch 的使用

返回 Dispatch 的 javax.xml.ws.spi 中的方法
abstract
<T> Dispatch<T>
ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.Endpoint 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.Endpoint
的使用

使用 Endpoint 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 中 Endpoint 的使用

返回 Endpoint 的 javax.xml.ws 中的方法
static Endpoint | Endpoint.create(Object implementor) 创建具有指定实现者对象的端点。
static Endpoint | Endpoint.create(String bindingId, Object implementor) 创建具有指定绑定类型和实现者对象的端点。
static Endpoint | Endpoint.publish(String address, Object implementor) 在给定地址处针对指定的实现者对象创建并发布端点。

javax.xml.ws.spi 中 Endpoint 的使用

返回 Endpoint 的 javax.xml.ws.spi 中的方法
abstract Endpoint | Provider.createAndPublishEndpoint(String address, Object implementor) 创建和发布具有指定地址和实现对象的端点对象。
abstract Endpoint | Provider.createEndpoint(String bindingId, Object implementor) 创建具有提供的绑定和实现对象的端点对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.Holder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.Holder
的使用

没有 javax.xml.ws.Holder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.LogicalMessage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.LogicalMessage
的使用

使用 LogicalMessage 的软件包
javax.xml.ws.handler 该包定义用于消息处理程序的 API。

javax.xml.ws.handler 中 LogicalMessage 的使用

返回 LogicalMessage 的 javax.xml.ws.handler 中的方法
 LogicalMessage LogicalMessageContext.getMessage()
从此消息上下文中获得消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.ProtocolException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.ProtocolException
的使用

使用 ProtocolException 的软件包
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.ws.http 中 ProtocolException 的使用

javax.xml.ws.http 中 ProtocolException 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 ProtocolException 的使用

javax.xml.ws.soap 中 ProtocolException 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.Provider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.Provider
的使用

没有 javax.xml.ws.Provider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.RequestWrapper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.RequestWrapper
的使用

没有 javax.xml.ws.RequestWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.Response 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.Response
的使用

使用 Response 的软件包
javax.xml.ws 此包包含核心 JAX-WS API。

javax.xml.ws 中 Response 的使用

返回 Response 的 javax.xml.ws 中的方法
 Response<T> Dispatch.invokeAsync(T msg)
异步调用服务操作。

参数类型为 Response 的 javax.xml.ws 中的方法
 void AsyncHandler.handleResponse(Response<T> res)
当可以获得对异步操作的响应时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.ResponseWrapper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.ResponseWrapper
的使用

没有 javax.xml.ws.ResponseWrapper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.Service 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.Service
的使用

使用 Service 的软件包
javax.xml.ws 此包包含核心 JAX-WS API。

javax.xml.ws 中 Service 的使用

返回 Service 的 javax.xml.ws 中的方法
static Service | Service.create(QName serviceName) 创建 Service 实例。
static Service | Service.create(URL wsdlDocumentLocation, QName serviceName) 创建 Service 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.Service.Mode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.Service.Mode
的使用

使用 Service.Mode 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.ws 中 Service.Mode 的使用

返回 Service.Mode 的 javax.xml.ws 中的方法
static Service.Mode | Service.Mode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Service.Mode[] | Service.Mode.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Service.Mode 的 javax.xml.ws 中的方法
<T> Dispatch<T>
Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
 Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。

javax.xml.ws.spi 中 Service.Mode 的使用

参数类型为 Service.Mode 的 javax.xml.ws.spi 中的方法
abstract
<T> Dispatch<T>
ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.ServiceMode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.ServiceMode
的使用

没有 javax.xml.ws.ServiceMode 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.WebEndpoint 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebEndpoint
的使用

没有 javax.xml.ws.WebEndpoint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.WebFault 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebFault
的使用

没有 javax.xml.ws.WebFault 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceClient 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceClient
的使用

没有 javax.xml.ws.WebServiceClient 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.ws.WebServiceContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.ws.WebServiceContext
的使用

没有 javax.xml.ws.WebServiceContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceException
的使用

使用 WebServiceException 的软件包
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

javax.xml.ws 中 WebServiceException 的使用

javax.xml.ws 中 WebServiceException 的子类
 class ProtocolException
ProtocolException 类是与特定协议绑定有关的异常的基类。

javax.xml.ws.http 中 WebServiceException 的使用

javax.xml.ws.http 中 WebServiceException 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 WebServiceException 的使用

javax.xml.ws.soap 中 WebServiceException 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.WebServicePermission 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServicePermission
的使用

没有 javax.xml.ws.WebServicePermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceProvider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceProvider
的使用

没有 javax.xml.ws.WebServiceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceRef 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceRef
的使用

没有 javax.xml.ws.WebServiceRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.ws.WebServiceRefs 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.ws.WebServiceRefs
的使用

没有 javax.xml.ws.WebServiceRefs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


ErrorListener (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
接口 ErrorListener

public interface ErrorListener

要提供自定义错误处理，则需实现此接口并使用 setErrorListener 方法注册一个带有 Transformer 的实现的实例。然后由 Transformer 通过此接口来报告所有错误和警告。

如果应用程序没有 注册自己的自定义 ErrorListener，则使用默认的 ErrorListener，它向 System.err 报告所有警告和错误，但不抛出任何 Exception。建议 应用程序注册和使用 ErrorListener，以确保正确的警告和错误行为。

对于转换错误，Transformer 必须使用此接口，而不是抛出 Exception：应用程序负责决定对于不同类型的错误和警告是否抛出 Exception。但要注意，在调用 fatalError(TransformerException exception) 后，不再需要对转换使用 Transformer。

Transformer 可以使用此机制来报告 XML 分析错误和转换错误。

方法摘要
void | error(TransformerException exception) 接收可恢复错误的通知。
void | fatalError(TransformerException exception) 接收不可恢复错误的通知。
void | warning(TransformerException exception) 接收警告通知。

方法详细信息

warning

void warning(TransformerException exception)
             throws TransformerException
接收警告通知。

Transformer 可以使用此方法来报告不是错误或致命错误的条件。默认行为是不采取动作。

调用此方法后，必须继续对转换使用 Transformer。应用程序应该仍有可能处理文档，直到文档结尾。

参数：
exception - transformer 异常中封装的警告信息。
抛出：
TransformerException - 如果应用程序选择中止转换。
另请参见：
TransformerException

error

void error(TransformerException exception)
           throws TransformerException
接收可恢复错误的通知。

调用此方法后，转换器必须继续尝试并提供正常转换。如果未遇到其他错误，应用程序应该仍有可能处理文档，直到文档结尾。

参数：
exception - transformer 异常中封装的错误信息。
抛出：
TransformerException - 如果应用程序选择中止转换。
另请参见：
TransformerException

fatalError

void fatalError(TransformerException exception)
                throws TransformerException

接收不可恢复错误的通知。

处理器可能会选择继续执行处理操作，但无法正常成功地完成处理。

如果不能处理错误，或者希望立即终止执行，则该方法应该抛出异常。服务器不一定响应此请求。

参数：
exception - TransformerException 中封装的错误信息。
抛出：
TransformerException - 如果应用程序选择中止转换。
另请参见：
TransformerException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


OutputKeys (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
类 OutputKeys

java.lang.Object
    继承者  javax.xml.transform.OutputKeys

public class OutputKeys
extends Object

提供可用于设置 Transformer 的输出属性或从 Transformer 或 Templates 对象检索输出属性的字符串常量。

此类中的所有字段均为只读的。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节

字段摘要
static String | CDATA_SECTION_ELEMENTS cdata-section-elements = expanded names. cdata-section-elements 指定了由空白分隔的元素名称列表，其中的文本节点子级应使用 CDATA 部分来输出。
static String | DOCTYPE_PUBLIC doctype-public = string. 有关关键值应为何值的描述，请参阅 DOCTYPE_SYSTEM 属性文档。
static String | DOCTYPE_SYSTEM doctype-system = string. doctype-system 指定了要在文档类型声明中使用的系统标识符。
static String | ENCODING encoding = string. encoding 指定了首选的字符编码，Transformer 应使用此编码将字符序列编码作为字节序列进行编码。
static String | INDENT indent = "yes" | "no". indent 指定了当输出结果树时，Transformer 是否可以添加额外的空白；其值必须为 yes 或 no。
static String | MEDIA_TYPE media-type = string. media-type 指定了输出结果树得到的数据的介质类型（MIME 内容类型）。
static String | METHOD method = "xml" | "html" | "text" | expanded name。
static String | OMIT_XML_DECLARATION omit-xml-declaration = "yes" | "no". omit-xml-declaration 指定了 XSLT 处理器是否应输出 XML 声明，其值必须为 yes 或 no。
static String | STANDALONE standalone = "yes" | "no". standalone 指定了 Transformer 是否应输出单独的文档声明，其值必须为 yes 或 no。
static String | VERSION version = nmtoken. version 指定了输出方法的版本。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

METHOD

public static final String METHOD
method = "xml" | "html" | "text" | expanded name。

方法属性的值标识了应用于输出结果树的总体方法。可以使用其他非名称空间的值，例如 "xhtml"，但如果接受的话，这样的值的处理是由实现定义的。如果不接受任何方法值，或方法值不是名称空间限定的，则 Transformer.setOutputProperty(java.lang.String, java.lang.String) 或 Transformer.setOutputProperties(java.util.Properties) 将抛出 IllegalArgumentException。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节, 常量字段值

VERSION

public static final String VERSION
version = nmtoken.

version 指定了输出方法的版本。

当输出方法为 "xml" 时，版本值指定了要用于输出结果树的 XML 的版本。xml 输出方法的默认值为 1.0。当输出方法为 "html" 时，版本值指示了 HTML 的版本。xml 输出方法的置信值为 4.0，它指定了结果应以遵守 HTML 4.0 Recommendation [HTML] 的 HTML 格式输出。如果输出方法为 "text"，则忽略版本属性。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节, 常量字段值

ENCODING

public static final String ENCODING
encoding = string.

encoding 指定了首选的字符编码，Transformer 应使用此编码将字符序列编码作为字节序列进行编码。编码属性值应是不区分大小写的。该值必须只包含 #x21 到 #x7E（即可打印的 ASCII 字符）范围内的字符。值要么为 Internet Assigned Numbers Authority [IANA], [RFC2278] 中注册的 charset，要么以 X- 开头。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节, 常量字段值

OMIT_XML_DECLARATION

public static final String OMIT_XML_DECLARATION
omit-xml-declaration = "yes" | "no".

omit-xml-declaration 指定了 XSLT 处理器是否应输出 XML 声明，其值必须为 yes 或 no。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节, 常量字段值

STANDALONE

public static final String STANDALONE
standalone = "yes" | "no".

standalone 指定了 Transformer 是否应输出单独的文档声明，其值必须为 yes 或 no。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节, 常量字段值

DOCTYPE_PUBLIC

public static final String DOCTYPE_PUBLIC
doctype-public = string.

有关关键值应为何值的描述，请参阅 DOCTYPE_SYSTEM 属性文档。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节, 常量字段值

DOCTYPE_SYSTEM

public static final String DOCTYPE_SYSTEM
doctype-system = string.

doctype-system 指定了要在文档类型声明中使用的系统标识符。

如果指定了 doctype-system 属性，则 xml 输出方法应在首个元素的正前面输出文档类型声明。紧跟 <!DOCTYPE 后面的名称应为第一个元素的名称。如果还指定了 doctype-public 属性，则 xml 输出方法应输出 PUBLIC，后跟公共标识符，再后跟系统标识符，否则，它应输出 SYSTEM，后跟系统标识符。内部子集应为空。如果没有指定 doctype-system 属性，则应忽略 doctype-public 属性值。

如果指定了 doctype-public 或 doctype-system 属性，则 html 输出方法应在第一个元素的正前面输出文档类型声明。紧跟 <!DOCTYPE 后面的名称应为 HTML 或 html。如果指定了 doctype-public 属性，则输出方法应输出 PUBLIC，后跟指定的公共标识符；如果还指定了 doctype-system 属性，则它还应在公共标识符后面输出指定的系统标识符。如果指定了 doctype-system 属性但未指定 doctype-public 属性，则输出方法应输出 SYSTEM，后跟指定的系统标识符。

doctype-system 指定了要在文档类型声明中使用的系统标识符。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节, 常量字段值

CDATA_SECTION_ELEMENTS

public static final String CDATA_SECTION_ELEMENTS
cdata-section-elements = expanded names.

cdata-section-elements 指定了由空白分隔的元素名称列表，其中的文本节点子级应使用 CDATA 部分来输出。注意这些名称必须使用 javax.xml.transform 的 Qualfied Name Representation 节中描述的格式。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节., 常量字段值

INDENT

public static final String INDENT
indent = "yes" | "no".

indent 指定了当输出结果树时，Transformer 是否可以添加额外的空白；其值必须为 yes 或 no。

另请参见：
XSL Transformations (XSLT) W3C Recommendation 的第 16 小节, 常量字段值

MEDIA_TYPE

public static final String MEDIA_TYPE
media-type = string.

media-type 指定了输出结果树得到的数据的介质类型（MIME 内容类型）。不应显式指定charset 参数；相反，当顶层介质类型为 text 时，应根据输出方法实际使用的字符编码来添加 charset 参数。

另请参见：
s ection 16 of the XSL Transformations (XSLT) W3C Recommendation, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Result (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
接口 Result

所有已知实现类：
DOMResult, JAXBResult, SAAJResult, SAXResult, StAXResult, StreamResult
public interface Result

实现此接口的对象包含构建转换结果树所需的信息。

字段摘要
static String | PI_DISABLE_OUTPUT_ESCAPING 如果结果树禁用了输出转义，则为发送处理指令的名称。
static String | PI_ENABLE_OUTPUT_ESCAPING 如果结果树在已接收 PI_DISABLE_OUTPUT_ESCAPING 处理指令后的某时刻启用了输出转义，则发送处理指令的名称。
方法摘要
String | getSystemId() 获取通过 setSystemId 设置的系统标识符。
void | setSystemId(String systemId) 设置此 Result 的系统标识符。

字段详细信息

PI_DISABLE_OUTPUT_ESCAPING

static final String PI_DISABLE_OUTPUT_ESCAPING
如果结果树禁用了输出转义，则为发送处理指令的名称。

通常，当输出文本节点时，结果树序列化对 & 和 <（可能还有其他字符）进行转义处理。这确保输出是格式良好的 XML。但是为方便起见，有时需要生成几乎但不是非常格式良好的 XML；例如，输出可以包含非良好格式的部分，然后通过后续的非 XML 感知过程将它们转换为格式良好的 XML。如果以此名称发送处理指令，则序列化在输出时不应带有任何转义。

结果 DOM 树还具有插入树中的 PI_DISABLE_OUTPUT_ESCAPING 和 PI_ENABLE_OUTPUT_ESCAPING。

另请参见：
disable-output-escaping in XSLT Specification, 常量字段值

PI_ENABLE_OUTPUT_ESCAPING

static final String PI_ENABLE_OUTPUT_ESCAPING
如果结果树在已接收 PI_DISABLE_OUTPUT_ESCAPING 处理指令后的某时刻启用了输出转义，则发送处理指令的名称。

另请参见：
disable-output-escaping in XSLT Specification, 常量字段值
方法详细信息

setSystemId

void setSystemId(String systemId)
设置此 Result 的系统标识符。

如果不能将 Result 写入文件中，则系统标识符是可选的。但是，应用程序仍可能希望提供一个系统标识符用于错误消息和警告，或者希望解析输出标识符。

参数：
systemId - URI 字符串形式的系统标识符。

getSystemId

String getSystemId()
获取通过 setSystemId 设置的系统标识符。

返回：
通过 setSystemId 设置的系统标识符，如果未调用 setSystemId，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Source (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
接口 Source

所有已知实现类：
DOMSource, JAXBSource, SAXSource, StAXSource, StreamSource
public interface Source

实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

方法摘要
String | getSystemId() 获取通过 setSystemId 设置的系统标识符。
void | setSystemId(String systemId) 设置此 Source 的系统标识符。

方法详细信息

setSystemId

void setSystemId(String systemId)
设置此 Source 的系统标识符。

如果源未从 URL 获取其数据，则系统标识符是可选的，但提供一个系统标识符仍然是有用的。例如，应用程序可以使用系统标识符来解析相对 URI，以及将其包括在错误消息和警告中。

参数：
systemId - URL 字符串形式的系统标识符。

getSystemId

String getSystemId()
获取通过 setSystemId 设置的系统标识符。

返回：
通过 setSystemId 设置的系统标识符，如果未调用 setSystemId，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SourceLocator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
接口 SourceLocator

所有已知子接口：
DOMLocator
public interface SourceLocator

此接口的主要目的是报告在 XML 源或转换指令中发生错误的位置。

方法摘要
int | getColumnNumber() 返回当前文档事件结束的字符位置。
int | getLineNumber() 返回当前文档事件结束位置的行数。
String | getPublicId() 返回当前文档事件的公共标识符。
String | getSystemId() 返回当前文档事件的系统标识符。

方法详细信息

getPublicId

String getPublicId()
返回当前文档事件的公共标识符。

返回值为文档实体或外部解析的实体（其中出现触发事件的标记）的公共标识符。

返回：
包含公共标识符的字符串，如果没有，则返回 null。
另请参见：
getSystemId()

getSystemId

String getSystemId()
返回当前文档事件的系统标识符。

返回值为文档实体或外部解析的实体（其中出现触发事件的标记）的系统标识符。

如果系统标识符为 URL，则解析器必须在将其传递到应用程序之前完全解析它。

返回：
包含系统标识符的字符串，如果没有，则返回 null。
另请参见：
getPublicId()

getLineNumber

int getLineNumber()
返回当前文档事件结束位置的行数。

警告：从方法返回的值只作为近似值（由于错误报告）；它不用于提供足够信息来编辑源 XML 文档的字符内容。

返回值为文档实体或外部解析的实体（其中出现触发事件的标记）中行数的近似值。

返回：
行数，如果没有，则返回 -1。
另请参见：
getColumnNumber()

getColumnNumber

int getColumnNumber()
返回当前文档事件结束的字符位置。

警告：从方法返回的值只作为近似值（由于错误报告）；它不用于提供足够信息来编辑源 XML 文档的字符内容。

返回值为文档实体或外部解析的实体（其中出现触发事件的标记）中列数的近似值。

返回：
列数，如果没有，则返回 -1。
另请参见：
getLineNumber()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Templates (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
接口 Templates

public interface Templates

实现此接口的对象是处理后的转换指令的运行时表示形式。

Templates 对于多线程同时运行的给定实例必须是线程安全的，且在给定会话中可多次使用。

方法摘要
Properties | getOutputProperties() 获取对应于有效 xsl:output 元素的属性。
Transformer | newTransformer() 创建此 Templates 对象的新转换上下文。

方法详细信息

newTransformer

Transformer newTransformer()
                           throws TransformerConfigurationException
创建此 Templates 对象的新转换上下文。

返回：
Transformer 的有效非 null 实例。
抛出：
TransformerConfigurationException - 如果不能创建 Transformer。

getOutputProperties

Properties getOutputProperties()
获取对应于有效 xsl:output 元素的属性。返回的对象将是内部值的副本。相应地，可以在不改变 Templates 对象的情况下改变它，然后传递给 Transformer.setOutputProperties(java.util.Properties)。

返回的属性应包含通过 stylesheet 设置的属性，且这些属性将 section 16 of the XSL Transformations (XSLT) W3C Recommendation 所指定的默认属性作为“默认值”。通过 stylesheet 特定设置的属性应位于基本 Properties 列表中，而未特定设置的 XSLT 默认属性应位于 "default" Properties 列表中。因此，getOutputProperties().getProperty(String key) 将包含通过 stylesheet 设置的任何属性，或者默认属性，而 getOutputProperties().get(String key) 将只检索 stylesheet 中显式设置的属性。

对于 XSLT，将返回未展开的 Attribute Value Templates 属性值（因为此时没有上下文）。Attribute Value Templates 中的名称空间前缀将不展开，因此它们保持有效的 XPath 值。

返回：
Properties 对象，不会返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Transformer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
类 Transformer

java.lang.Object
    继承者  javax.xml.transform.Transformer

public abstract class Transformer
extends Object

此抽象类的实例能够将源树转换为结果树。

可以通过 TransformerFactory.newTransformer 方法获取此类的实例。然后可以使用此实例处理来自不同源的 XML，并将转换输出写入各种接收器。

在多线程同时运行时不能使用此类的对象。不同线程可以同时使用不同的 Transformers。

Transformer 可以多次使用。可以在转换之间保留参数和输出属性。

构造方法摘要
protected Transformer()
默认构造方法受到有意保护。
方法摘要
abstract  void clearParameters()
清除所有通过 setParameter 设置的参数。
abstract  ErrorListener getErrorListener()
获取转换的实际错误事件处理程序。
abstract  Properties getOutputProperties()
获取转换的输出属性的副本。
abstract  String getOutputProperty(String name)
获取对转换器有效的输出属性。
abstract  Object getParameter(String name)
获取通过 setParameter 显式设置的参数。
abstract  URIResolver getURIResolver()
获取将用于解析在 document() 中使用的 URI 的对象。
 void reset()
将此 Transformer 重置为其初始配置。
abstract  void setErrorListener(ErrorListener listener)
设置转换的实际错误事件侦听器。
abstract  void setOutputProperties(Properties oformat)
设置转换的输出属性。
abstract  void setOutputProperty(String name, String value)
设置转换中实际的输出属性。
abstract  void setParameter(String name, Object value)
添加一个转换参数。
abstract  void setURIResolver(URIResolver resolver)
设置将用于解析在 document() 中使用的 URI 的对象。
abstract  void transform(Source xmlSource, Result outputTarget)
将 XML Source 转换为 Result。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Transformer

protected Transformer()
默认构造方法受到有意保护。

方法详细信息

reset

public void reset()

将此 Transformer 重置为其初始配置。

Transformer 被重置为通过 TransformerFactory.newTransformer()、TransformerFactory.newTransformer(Source source) 或 Templates.newTransformer() 创建它时的状态。reset() 的设计目标是允许重用现有 Transformer，以节省与创建新 Transformer 有关的资源。

不保证重置的 Transformer 具有相同的 URIResolver 或 ErrorListener Object，例如 Object.equals(Object obj)。但保证具有功能相同的 URIResolver 和 ErrorListener。

抛出：
UnsupportedOperationException - 当实现不能重写此方法时。
从以下版本开始：
1.5

transform

public abstract void transform(Source xmlSource,
                               Result outputTarget)
                        throws TransformerException

将 XML Source 转换为 Result。当实例化 Transformer 和对 Transformer 实例进行任何修改时，指定的转换行为由 TransformerFactory 的实际设置决定。

空 Source 表示为由 DocumentBuilder.newDocument() 构造的空文档。空 Source 的转换结果取决于转换行为；结果不总为空 Result。

参数：
xmlSource - 要转换的 XML 输入。
outputTarget - 转换 xmlSource 的 Result。
抛出：
TransformerException - 如果转换过程中发生不可恢复的错误。

setParameter

public abstract void setParameter(String name,
                                  Object value)
添加一个转换参数。

以两部分字符串形式传递限定名称，即用花括号括起来的名称空间 URI，后跟本地名称。如果名称中有 null URL，则 String 只包含本地名称。应用程序可以通过测试安全地检查非 null URI，以查看名称的首字符是否为 '{' 字符。

例如，如果 URI 和本地名称是从通过 <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/> 定义的元素获取的，则限定名称将为 "{http://xyz.foo.com/yada/baz.html}foo"。注意，不使用前缀。

参数：
name - 参数名称，它可以以花括号（{}）中的名称空间 URI 开始。
value - 值对象。它可以为任何有效的 Java 对象。处理器负责提供正确的对象 coersion，或只传递在扩展中使用的对象。
抛出：
NullPointerException - 如果值为 null。

getParameter

public abstract Object getParameter(String name)
获取通过 setParameter 显式设置的参数。

此方法不返回默认参数值，默认参数值直到在转换过程中计算了节点上下文后才能确定。

参数：
name - 要获取的 Object
返回：
已通过 setParameter 设置的参数。

clearParameters

public abstract void clearParameters()
清除所有通过 setParameter 设置的参数。

setURIResolver

public abstract void setURIResolver(URIResolver resolver)
设置将用于解析在 document() 中使用的 URI 的对象。

如果解析器参数为 null，则将清除 URIResolver 值，且转换器将不再拥有解析器。

参数：
resolver - 实现 URIResolver 接口的对象，或为 null。

getURIResolver

public abstract URIResolver getURIResolver()
获取将用于解析在 document() 中使用的 URI 的对象。

返回：
实现 URIResolver 接口的对象，或返回 null。

setOutputProperties

public abstract void setOutputProperties(Properties oformat)
设置转换的输出属性。这些属性将重写通过 xsl:output 在 Templates 中设置的属性。

如果此函数的参数为 null，则移除任何以前设置的属性，且值将恢复为 templates 对象中定义的值。

以两部分字符串形式传递限定属性，即用花括号括起来的名称空间 URI，后跟本地名称。如果名称中有 null URL，则 String 只包含本地名称。应用程序可以通过测试安全地检查非 null URI，以查看名称的首字符是否为 '{' 字符。

例如，如果 URI 和本地名称是从通过 <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/> 定义的元素获取的，则限定名称将为 "{http://xyz.foo.com/yada/baz.html}foo"。注意，不使用前缀。

如果任何参数键不能被识别且不是名称空间限定的，则抛出 IllegalArgumentException。

参数：
oformat - 将用于重写在实际转换中任何相同属性的输出属性集。
抛出：
IllegalArgumentException - 当键无法识别且不是限定于名称空间的键时。
另请参见：
OutputKeys, Properties

getOutputProperties

public abstract Properties getOutputProperties()

获取转换的输出属性的副本。

返回的属性应包含由用户设置的属性，以及通过样式表设置的属性，且这些属性将 section 16 of the XSL Transformations (XSLT) W3C Recommendation 指定的默认属性作为“默认值”。由用户或通过样式表特定设置的属性应位于基本 Properties 列表中，而未特定设置的 XSLT 默认属性应位于默认的 Properties 列表中。因此，getOutputProperties().getProperty(String key) 将包含通过 setOutputProperty(java.lang.String, java.lang.String)、setOutputProperties(java.util.Properties) 设置的任何属性，或者在样式表或 默认属性中设置的任何属性，而 getOutputProperties().get(String key) 将只检索通过 setOutputProperty(java.lang.String, java.lang.String)、setOutputProperties(java.util.Properties) 显式设置的属性，或在样式表中显式设置的属性。

注意返回的 Properties 对象的变化将不影响转换器所包含的属性。

如果任何参数键不能被识别且不是名称空间限定的键，则属性将被忽略且不返回。换句话说，行为与 setOutputProperties 无关。

返回：
下一个实际转换中的输出属性集的副本。
另请参见：
OutputKeys, Properties, XSL Transformations (XSLT) Version 1.0

setOutputProperty

public abstract void setOutputProperty(String name,
                                       String value)
                                throws IllegalArgumentException
设置转换中实际的输出属性。

以两部分字符串形式传递限定属性名称，即用花括号括起来的名称空间 URI，后跟本地名称。如果名称中有 null URL，则 String 只包含本地名称。应用程序可以通过测试安全地检查非 null URI，以查看名称的首字符是否为 '{' 字符。

例如，如果 URI 和本地名称是从通过 <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/> 定义的元素获取的，则限定名称将为 "{http://xyz.foo.com/yada/baz.html}foo"。注意，不使用前缀。

传递给 setOutputProperties(java.util.Properties) 的 Properties 对象不会受到调用此方法的影响。

参数：
name - 指定了输出属性名称的非 null String，它可以是名称空间限定的。
value - 输出属性的非 null 字符串值。
抛出：
IllegalArgumentException - 如果不支持属性，且该属性没有限定于某一名称空间。
另请参见：
OutputKeys

getOutputProperty

public abstract String getOutputProperty(String name)
                                  throws IllegalArgumentException

获取对转换器有效的输出属性。

如果已经使用 setOutputProperty(java.lang.String, java.lang.String) 设置了属性，则返回所设置的值。如果在样式表中显式地指定了属性，则返回所指定的值。如果使用默认属性值，即没有使用 setOutputProperty(java.lang.String, java.lang.String) 或在样式表中显式地设置了任何值，则结果将随实现以及输入样式表而改变。

参数：
name - 指定了输出属性名称的非 null String，它可以是名称空间限定的。
返回：
输出属性的字符串值，如果找不到属性，则返回 null。
抛出：
IllegalArgumentException - 如果不支持属性。
另请参见：
OutputKeys

setErrorListener

public abstract void setErrorListener(ErrorListener listener)
                               throws IllegalArgumentException
设置转换的实际错误事件侦听器。

参数：
listener - 新错误侦听器。
抛出：
IllegalArgumentException - 如果侦听器为 null。

getErrorListener

public abstract ErrorListener getErrorListener()
获取转换的实际错误事件处理程序。实现必须提供默认错误侦听器。

返回：
当前错误处理程序，它永远不应为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformerConfigurationException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
类 TransformerConfigurationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.transform.TransformerException
                继承者  javax.xml.transform.TransformerConfigurationException
所有已实现的接口：
Serializable
public class TransformerConfigurationException
extends TransformerException

指示严重的配置错误。

另请参见：
序列化表格

构造方法摘要
TransformerConfigurationException()
创建不带详细消息的新 TransformerConfigurationException。
TransformerConfigurationException(String msg)
创建带有指定为错误消息的 String 的新 TransformerConfigurationException。
TransformerConfigurationException(String message, SourceLocator locator)
从消息和 Locator 创建新 TransformerConfigurationException。
TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
包装了 TransformerConfigurationException 中的现有异常。
TransformerConfigurationException(String msg, Throwable e)
创建带有给定 Exception 基本原因和详细消息的新 TransformerConfigurationException。
TransformerConfigurationException(Throwable e)
创建带有错误的给定 Exception 基本原因的新 TransformerConfigurationException。
方法摘要
从类 javax.xml.transform.TransformerException 继承的方法
getCause, getException, getLocationAsString, getLocator, getMessageAndLocation, initCause, printStackTrace, printStackTrace, printStackTrace, setLocator
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TransformerConfigurationException

public TransformerConfigurationException()
创建不带详细消息的新 TransformerConfigurationException。

TransformerConfigurationException

public TransformerConfigurationException(String msg)
创建带有指定为错误消息的 String 的新 TransformerConfigurationException。

参数：
msg - 异常的错误消息。

TransformerConfigurationException

public TransformerConfigurationException(Throwable e)
创建带有错误的给定 Exception 基本原因的新 TransformerConfigurationException。

参数：
e - 要封装在 TransformerConfigurationException 中的异常。

TransformerConfigurationException

public TransformerConfigurationException(String msg,
                                         Throwable e)
创建带有给定 Exception 基本原因和详细消息的新 TransformerConfigurationException。

参数：
e - 要封装在 TransformerConfigurationException 中的异常
msg - 详细消息。

TransformerConfigurationException

public TransformerConfigurationException(String message,
                                         SourceLocator locator)
从消息和 Locator 创建新 TransformerConfigurationException。

当应用程序从 DocumentHandler 回调中创建其自己的异常时，此构造方法特别有用。

参数：
message - 错误或警告消息。
locator - 错误或警告的定位符对象。

TransformerConfigurationException

public TransformerConfigurationException(String message,
                                         SourceLocator locator,
                                         Throwable e)
包装了 TransformerConfigurationException 中的现有异常。

参数：
message - 错误或警告消息，或者当要使用来自嵌入异常的消息时为 null。
locator - 错误或警告的定位符对象。
e - 任何异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformerException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
类 TransformerException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.transform.TransformerException
所有已实现的接口：
Serializable
直接已知子类：
TransformerConfigurationException
public class TransformerException
extends Exception

此类指定了转换过程中发生的异常条件。

另请参见：
序列化表格

构造方法摘要
TransformerException(String message)
创建一个新的 TransformerException。
TransformerException(String message, SourceLocator locator)
从消息和 Locator 创建一个新 TransformerException。
TransformerException(String message, SourceLocator locator, Throwable e)
包装了 TransformerException 中的现有异常。
TransformerException(String message, Throwable e)
包装 TransformerException 中的一个现有异常。
TransformerException(Throwable e)
创建一个包装了现有异常的新 TransformerException。
方法摘要
Throwable | getCause() 返回此抛出对象的原因，如果原因不存在或未知，则返回 null。
Throwable | getException() 此方法检索此异常所包装的异常。
String | getLocationAsString() 获取字符串形式的位置信息。
SourceLocator | getLocator() getLocator 方法检索 SourceLocator 对象的实例，此对象指定了错误发生的位置。
String | getMessageAndLocation() 获取带有追加的位置信息的错误消息。
Throwable | initCause(Throwable cause) 将此抛出对象的原因 初始化为指定值。
void | printStackTrace() 打印从中产生错误的方法跟踪。
void | printStackTrace(PrintStream s) 打印从中产生错误的方法跟踪。
void | printStackTrace(PrintWriter s) 打印从中产生错误的方法跟踪。
void | setLocator(SourceLocator location) setLocator 方法设置 SourceLocator 对象的实例，此对象指定了错误发生的位置。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TransformerException

public TransformerException(String message)
创建一个新的 TransformerException。

参数：
message - 错误或警告消息。

TransformerException

public TransformerException(Throwable e)
创建一个包装了现有异常的新 TransformerException。

参数：
e - 要包装的异常。

TransformerException

public TransformerException(String message,
                            Throwable e)
包装 TransformerException 中的一个现有异常。

这用于在开始处理之前抛出处理器异常。

参数：
message - 错误或警告消息，当要使用来自嵌入异常的消息时为 null。
e - 任何异常

TransformerException

public TransformerException(String message,
                            SourceLocator locator)
从消息和 Locator 创建一个新 TransformerException。

当应用程序从 DocumentHandler 回调中创建其自己的异常时，此构造方法特别有用。

参数：
message - 错误或警告消息。
locator - 错误或警告的定位符对象。

TransformerException

public TransformerException(String message,
                            SourceLocator locator,
                            Throwable e)
包装了 TransformerException 中的现有异常。

参数：
message - 错误或警告消息，当要使用来自嵌入异常的消息时为 null。
locator - 错误或警告的定位符对象。
e - 任何异常
方法详细信息

getLocator

public SourceLocator getLocator()
getLocator 方法检索 SourceLocator 对象的实例，此对象指定了错误发生的位置。

返回：
SourceLocator 对象，如果未指定，则返回 null。

setLocator

public void setLocator(SourceLocator location)
setLocator 方法设置 SourceLocator 对象的实例，此对象指定了错误发生的位置。

参数：
location - SourceLocator 对象，或为 null 以清除位置。

getException

public Throwable getException()
此方法检索此异常所包装的异常。

返回：
Throwable 对象，或返回 null。
另请参见：
getCause()

getCause

public Throwable getCause()
返回此抛出对象的原因，如果原因不存在或未知，则返回 null。（原因是抛出此抛出对象引起的抛出对象。）

覆盖：
类 Throwable 中的 getCause
返回：
此 throwable 的 cause，如果 cause 不存在或是未知的，则返回 null。

initCause

public Throwable initCause(Throwable cause)
将此抛出对象的原因 初始化为指定值。（原因是抛出此抛出对象引起的抛出对象。）

此方法至多可以调用一次。此方法通常从构造方法中调用，或者在创建抛出对象后立即调用。如果此抛出对象通过 TransformerException(Throwable) 或 TransformerException(String,Throwable) 创建，则此方法甚至一次也不能调用。

覆盖：
类 Throwable 中的 initCause
参数：
cause - cause（保存此 cause，以便以后通过 getCause() 方法检索它）。（允许 null 值，指出原因是不存在的或是未知的。）
返回：
对此 Throwable 实例的引用。
抛出：
IllegalArgumentException - 如果 cause 是此抛出对象。（抛出对象不能是它自己的原因。）
IllegalStateException - 如果此抛出对象通过 TransformerException(Throwable) 或 TransformerException(String,Throwable) 创建，或者此方法已经在此抛出对象上进行调用。

getMessageAndLocation

public String getMessageAndLocation()
获取带有追加的位置信息的错误消息。

返回：
表示带有追加的位置信息的错误消息的 String。

getLocationAsString

public String getLocationAsString()
获取字符串形式的位置信息。

返回：
带有位置信息的字符串，如果没有位置信息，则返回 null。

printStackTrace

public void printStackTrace()
打印从中产生错误的方法跟踪。这将跟踪所有嵌套的异常对象，包括此对象。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintStream s)
打印从中产生错误的方法跟踪。这将跟踪所有嵌套的异常对象，包括此对象。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 将从中发送转储的流。

printStackTrace

public void printStackTrace(PrintWriter s)
打印从中产生错误的方法跟踪。这将跟踪所有嵌套的异常对象，包括此对象。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 将从中发送转储的 writer。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformerFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
类 TransformerFactory

java.lang.Object
    继承者  javax.xml.transform.TransformerFactory
直接已知子类：
SAXTransformerFactory
public abstract class TransformerFactory
extends Object

TransformerFactory 实例可用于创建 Transformer 和 Templates 对象。

确定要创建的哪一个 Factory 实现被命名为 "javax.xml.transform.TransformerFactory" 的系统属性。此属性命名了 TransformerFactory 抽象类的一个具体子类。如果未定义此属性，则使用平台默认的属性。

构造方法摘要
protected TransformerFactory()
默认构造方法受到有意保护。
方法摘要
abstract  Source getAssociatedStylesheet(Source source, String media, String title, String charset)
通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
abstract  Object getAttribute(String name)
允许用户在底层实现上检索指定属性。
abstract  ErrorListener getErrorListener()
获取 TransformerFactory 的错误事件处理程序。
abstract  boolean getFeature(String name)
查找功能值。
abstract  URIResolver getURIResolver()
获取在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。
static TransformerFactory newInstance()
获取 TransformerFactory 的新实例。
static TransformerFactory newInstance(String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 TransformerFactory 实例。
abstract  Templates newTemplates(Source source)
将 Source 处理为 Templates 对象，后者是源的编译后表示形式。
abstract  Transformer newTransformer()
创建执行从 Source 到 Result 的复制的新 Transformer。
abstract  Transformer newTransformer(Source source)
将 Source 处理为 Transformer Object。
abstract  void setAttribute(String name, Object value)
允许用户设置底层实现上的指定属性。
abstract  void setErrorListener(ErrorListener listener)
设置此 TransformerFactory 的错误事件侦听器，它将用于转换指令的处理，而不用于转换本身。
abstract  void setFeature(String name, boolean value)
设置通过此工厂创建的此 TransformerFactory 和 Transformer 或 Template 的功能。
abstract  void setURIResolver(URIResolver resolver)
设置在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TransformerFactory

protected TransformerFactory()
默认构造方法受到有意保护。

方法详细信息

newInstance

public static TransformerFactory newInstance()
                                      throws TransformerFactoryConfigurationError

获取 TransformerFactory 的新实例。此静态方法创建新的工厂实例。此方法使用以下顺序的查找程序来确定要加载的 TransformerFactory 实现类：

  • 使用 javax.xml.transform.TransformerFactory 系统属性。
  • 使用 JRE 文件夹中的属性文件 "lib/jaxp.properties"。此配置文件格式为标准的 java.util.Properties 且包含实现类的完全限定名，其中实现类的键是上述定义的系统属性。 JAXP 实现只读取一次 jaxp.properties 文件，然后缓存其值供以后使用。如果首次尝试读取文件时，文件不存在，则不会再次尝试检查该文件是否存在。首次读取 jaxp.properties 后，其中的属性值不能再更改。
  • 如果 Services API（在 JAR 规范中进行了详细描述）可用，可以使用它来确定类名称。Services API 将查找在运行时可用的 jar 文件中 META-INF/services/javax.xml.transform.TransformerFactory 中的类名称。
  • 平台默认的 TransformerFactory 实例。

在应用程序已获取对 TransformerFactory 的引用后，它可以使用工厂来配置和获取转换器实例。

返回：
新的 TransformerFactory 实例，永远不能为 null。
抛出：
TransformerFactoryConfigurationError - 如果实现不可用或不能被实例化。

newInstance

public static TransformerFactory newInstance(String factoryClassName,
                                             ClassLoader classLoader)
                                      throws TransformerFactoryConfigurationError

根据类名称获得一个新 TransformerFactory 实例。当类路径中有多个提供者时此功能很有用。它给了应用程序更多的控制权，因为它能指定应该加载哪个提供者。

在应用程序已获取对 TransformerFactory 的引用后，它可以使用工厂来配置和获取转换器实例。

疑难解答提示

设置 jaxp.debug 系统属性将导致此方法将许多调试消息打印到 System.err，以说明其执行的操作以及在何处查找这些操作。

如有问题，请尝试：

 java -Djaxp.debug=1 YourProgram ....

参数：
factoryClassName - 完全限定工厂类名称，提供 javax.xml.transform.TransformerFactory 的实现。
classLoader - 用来加载工厂类的 ClassLoader。如果为 null，则使用当前 Thread 的上下文 classLoader 来加载工厂类。
返回：
新 TransformerFactory 实例，永远不能为 null。
抛出：
TransformerFactoryConfigurationError - 如果 factoryClassName 为 null，或者不能加载或实例化工厂类。
从以下版本开始：
1.6
另请参见：
newInstance()

newTransformer

public abstract Transformer newTransformer(Source source)
                                    throws TransformerConfigurationException

将 Source 处理为 Transformer Object。Source 是遵守 XSL Transformations (XSLT) Version 1.0 的 XSLT 文档。必须注意的是，在多个 Thread 并发运行中不能使用此 Transformer。不同 Thread 可以并发使用不同的 TransformerFactories。

参数：
用于创建 - Transformer 的 XSLT 文档的源 Source。XML Source 的示例包括 DOMSource、SAXSource 和 StreamSource。
返回：
可用于在单个 Thread 中执行转换的 Transformer 对象，永远不能返回 null。
抛出：
TransformerConfigurationException - 如果当解析 Source 时发生错误，或不能创建 Transformer 实例。
另请参见：
XSL Transformations (XSLT) Version 1.0

newTransformer

public abstract Transformer newTransformer()
                                    throws TransformerConfigurationException

创建执行从 Source 到 Result 的复制的新 Transformer。即 "identity transform"。

返回：
可用于在单个进程中执行转换的 Transformer 对象，永远不能返回 null。
抛出：
TransformerConfigurationException - 当不能创建 Transformer 实例时。

newTemplates

public abstract Templates newTemplates(Source source)
                                throws TransformerConfigurationException
将 Source 处理为 Templates 对象，后者是源的编译后表示形式。然后此 Templates 对象可由多个线程并发使用。创建 Templates 对象允许 TransformerFactory 执行转换指令的详细性能优化，而不影响运行时转换。

参数：
source - 保持 URL、输入流等的对象。
返回：
可用于转换目的的 Templates 对象，永远不能返回 null。
抛出：
TransformerConfigurationException - 当对构造 Templates 对象进行解析失败时。

getAssociatedStylesheet

public abstract Source getAssociatedStylesheet(Source source,
                                               String media,
                                               String title,
                                               String charset)
                                        throws TransformerConfigurationException

通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。注意，可能返回几个样式表，在这种情况下它们作为导入列表或单个样式表中的层叠列表来使用。

参数：
source - XML 源文档。
media - 要匹配的介质属性。可以为 null，此时将使用首选的 template（即 alternate = no）。
title - 要匹配的标题属性值。可以为 null。
charset - 要匹配的字符集属性值。可以为 null。
返回：
适合传递给 TransformerFactory 的 Source Object。
抛出：
TransformerConfigurationException - 如果 source 的解析过程中发生错误，则抛出 Exception。
另请参见：
与 1.0 版本的 XML 文档关联的样式表

setURIResolver

public abstract void setURIResolver(URIResolver resolver)
设置在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。

参数：
resolver - 实现 URIResolver 接口的对象，或为 null。

getURIResolver

public abstract URIResolver getURIResolver()
获取在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。

返回：
通过 setURIResolver 设置的 URIResolver。

setFeature

public abstract void setFeature(String name,
                                boolean value)
                         throws TransformerConfigurationException

设置通过此工厂创建的此 TransformerFactory 和 Transformer 或 Template 的功能。

功能名称是完全限定的 URI。实现可以定义它们自己的功能。如果它创建的此 TransformerFactory 或 Transformer 或 Template 不支持该功能，则抛出 TransformerConfigurationException。TransformerFactory 可以公开功能值，但不能更改其状态。

所有实现必须支持 XMLConstants.FEATURE_SECURE_PROCESSING 功能。当功能为以下情况时：

  • true: 实现将限制 XML 处理遵守实现限制，并且实现方式为实现所定义的安全方式。示例包括解析用户定义的样式表和函数。如果出于安全原因使 XML 处理受到限制，则将通过对注册的 ErrorListener.fatalError(TransformerException exception) 的调用来报告此情况。参见 setErrorListener(ErrorListener listener)。
  • false: 实现将根据 XML 规范来处理 XML，而不管可能的实现限制。

参数：
name - 功能名称。
value - 功能状态为 true 或 false。
抛出：
TransformerConfigurationException - 如果它创建的此 TransformerFactory 或 Transformer 或 Template 不支持此功能。
NullPointerException - 如果 name 参数为 null。

getFeature

public abstract boolean getFeature(String name)
查找功能值。

功能名称为完全限定的 URI。实现可以定义其自己的功能。如果其创建的 TransformerFactory 或 Transformer 或 Template 不支持该功能，则返回 false。TransformerFactory 可以公开功能值，但不能更改其状态。

参数：
name - 功能名称。
返回：
功能的当前状态，true 或 false。
抛出：
NullPointerException - 如果 name 参数为 null。

setAttribute

public abstract void setAttribute(String name,
                                  Object value)
允许用户设置底层实现上的指定属性。此上下文中的属性定义为实现所提供的一个选项。如果底层实现不识别该属性，则抛出 IllegalArgumentException。

参数：
name - 属性名称。
value - 属性值。
抛出：
IllegalArgumentException - 当实现不能识别属性时。

getAttribute

public abstract Object getAttribute(String name)
允许用户在底层实现上检索指定属性。如果底层实现不识别该属性，则抛出 IllegalArgumentException。

参数：
name - 属性名称。
value - 属性值。
抛出：
IllegalArgumentException - 当实现不能识别属性时。

setErrorListener

public abstract void setErrorListener(ErrorListener listener)
设置此 TransformerFactory 的错误事件侦听器，它将用于转换指令的处理，而不用于转换本身。如果 ErrorListener 侦听器为 null，则抛出 IllegalArgumentException。

参数：
listener - 新错误侦听器。
抛出：
IllegalArgumentException - 当 listener 为 null 时。

getErrorListener

public abstract ErrorListener getErrorListener()
获取 TransformerFactory 的错误事件处理程序。

返回：
当前错误处理程序，它永远不应为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformerFactoryConfigurationError (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
类 TransformerFactoryConfigurationError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  javax.xml.transform.TransformerFactoryConfigurationError
所有已实现的接口：
Serializable
public class TransformerFactoryConfigurationError
extends Error

当通过 Transformer Factories 进行的配置存在问题时抛出此异常。当找不到或不能实例化系统属性中指定的转换工厂类时，通常抛出此错误。

另请参见：
序列化表格

构造方法摘要
TransformerFactoryConfigurationError()
创建不带详细消息的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(Exception e)
创建带有错误的给定 Exception 基本原因的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(Exception e, String msg)
创建带有给定 Exception 基本原因和详细消息的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(String msg)
创建带有指定为错误消息的 String 的新 TransformerFactoryConfigurationError。
方法摘要
Exception | getException() 返回引发此异常的实际异常（如果有）。
String | getMessage() 返回针对此错误的消息（如果有）。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TransformerFactoryConfigurationError

public TransformerFactoryConfigurationError()
创建不带详细消息的新 TransformerFactoryConfigurationError。

TransformerFactoryConfigurationError

public TransformerFactoryConfigurationError(String msg)
创建带有指定为错误消息的 String 的新 TransformerFactoryConfigurationError。

参数：
msg - 针对该异常的错误消息。

TransformerFactoryConfigurationError

public TransformerFactoryConfigurationError(Exception e)
创建带有错误的给定 Exception 基本原因的新 TransformerFactoryConfigurationError。

参数：
e - 要封装在 TransformerFactoryConfigurationError 中的异常。

TransformerFactoryConfigurationError

public TransformerFactoryConfigurationError(Exception e,
                                            String msg)
创建带有给定 Exception 基本原因和详细消息的新 TransformerFactoryConfigurationError。

参数：
e - 要封装在 TransformerFactoryConfigurationError 中的异常
msg - 详细消息。
方法详细信息

getMessage

public String getMessage()
返回针对此错误的消息（如果有）。如果存在此错误的消息而存在封装的异常，则返回该异常的消息。

覆盖：
类 Throwable 中的 getMessage
返回：
错误消息。

getException

public Exception getException()
返回引发此异常的实际异常（如果有）。

返回：
封装的异常，如果没有，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URIResolver (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform
接口 URIResolver

public interface URIResolver

实现此接口的对象可由处理器进行调用，以将 document()、xsl:import 或 xsl:include 中使用的 URI 转换为 Source 对象。

方法摘要
 Source resolve(String href, String base)
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。

方法详细信息

resolve

Source resolve(String href,
               String base)
               throws TransformerException
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。

参数：
href - href 属性，可以是相对的或绝对的。
base - 首个参数将相对于其成为绝对参数的基本 URI（如果需要绝对 URI）。
返回：
Source 对象，如果不能解析 href，则返回 null，且处理器本身应尝试解析 URI。
抛出：
TransformerException - 如果尝试解析 URI 时发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.transform (Java Platform SE 6)

 javax.xml.transform
接口
ErrorListener
Result
Source
SourceLocator
Templates
URIResolver
类
OutputKeys
Transformer
TransformerFactory
异常
TransformerConfigurationException
TransformerException
错误
TransformerFactoryConfigurationError


javax.xml.transform (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.transform

此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

请参见：
描述

接口摘要
ErrorListener | 要提供自定义错误处理，则需实现此接口并使用 setErrorListener 方法注册一个带有 Transformer 的实现的实例。
Result | 实现此接口的对象包含构建转换结果树所需的信息。
Source | 实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息
SourceLocator | 此接口的主要目的是报告在 XML 源或转换指令中发生错误的位置。
Templates | 实现此接口的对象是处理后的转换指令的运行时表示形式。
URIResolver | 实现此接口的对象可由处理器进行调用，以将 document()、xsl:import 或 xsl:include 中使用的 URI 转换为 Source 对象。

类摘要
OutputKeys | 提供可用于设置 Transformer 的输出属性或从 Transformer 或 Templates 对象检索输出属性的字符串常量。
Transformer | 此抽象类的实例能够将源树转换为结果树。
TransformerFactory | TransformerFactory 实例可用于创建 Transformer 和 Templates 对象。

异常摘要
TransformerConfigurationException | 指示严重的配置错误。
TransformerException | 此类指定了转换过程中发生的异常条件。

错误摘要
TransformerFactoryConfigurationError 当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

软件包 javax.xml.transform 的描述

此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。这些接口不依赖于 SAX 或 DOM 标准，且尽可能少地进行有关转换的源和结果的细节的假定。它通过定义 Source 和 Result 接口来实现这一点。

为了定义具体的用户类，API 定义了根级接口规范。这些接口可以在 javax.xml.transform.sax、javax.xml.transform.dom 和 javax.xml.transform.stream 中找到。

创建对象

API 从静态函数 TransformerFactory.newInstance() 创建具体 TransformerFactory 对象。

输入和输出规范

此 API 定义了两个接口对象，它们称为 Source 和 Result。为将 Source 和 Result 对象传递到接口，必须使用具体类。为每个对象定义了三个具体表示形式：StreamSource 和 StreamResult、SAXSource 和 SAXResult、DOMSource 和 DOMResult。这些对象中的每一个对象均定义了一个 FEATURE 字符串，可以将它传递到 TransformerFactory.getFeature(java.lang.String) 中以查看是否支持给定类型的 Source 或 Result 对象。例如，要测试是否支持 DOMSource 和 StreamResult，可以使用以下测试。

TransformerFactory tfactory = TransformerFactory.newInstance();
if (tfactory.getFeature(DOMSource.FEATURE) && tfactory.getFeature(StreamResult.FEATURE)) {
...
}

Qualified Name 表示形式

当处理 XML 对象时，Namespaces 存在某些问题。XML 中出现的 Qualified Names 标记为带前缀的名称。但前缀本身不保持标识。而由它们在上下文中所映射到的 URI 来保持标识。因此，当在 Java 程序中传递像 "xyz:foo" 这样的 Qualified Name 时，必须提供将 "xyz" 映射到名称空间的方式。

一种解决方案是创建一个保持名称空间以及前缀和本地名称的 "QName" 对象，但这不总是最佳解决方案，例如，当要将唯一字符串用作字典中的键时就是如此。没有字符串表示形式还将导致难以在 XML 文档的上下文之外指定名称空间的标识。

为了将名称空间的值传递给转换，例如当设置 Transformer 上的属性或参数时，此规范定义 String "qname" 对象参数作为两部分字符串来传递，即用花括号（{}）括起来的名称空间 URI，后跟本地名称。如果 qname 有 null URI，则 String 对象只包含本地名称。应用程序可以通过测试安全地检查非 null URI，以查看名称的首字符是否为 '{' 字符。

例如，如果 URI 和本地名称是从通过 <xyz:foo xmlns:xyz="http://xyz.foo.com/yada/baz.html"/> 定义的元素获取的，则 Qualified Name 将为 "{http://xyz.foo.com/yada/baz.html}foo"。注意不使用前缀。

结果树序列化

结果树到流的序列化可以通过 Transformer.setOutputProperties(java.util.Properties) 和 Transformer.setOutputProperty(java.lang.String, java.lang.String) 方法来控制。这些属性只应用于流结果，当结果为 DOM 树或 SAX 事件流时，它们无效。

可以从 OutputKeys 类引用匹配 XSLT specification for xsl:output attributes 的字符串。也可以指定其他字符串。如果转换器不识别输出键，则抛出 IllegalArgumentException，除非键名称为 namespace qualified。虽然某些实现可能会忽略名称空间限定的输出键名称，但它们总是允许的。

如果只需从源到结果的简单标识转换，则 TransformerFactory 提供一个不带参数的 TransformerFactory.newTransformer() 方法。此方法创建一个将源有效复制到结果的 Transformer。此方法可用于从 SAX 事件创建 DOM，或从 DOM 或 SAX 事件创建 XML。

异常和错误报告

转换 API 抛出三种类型的特殊异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.transform 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.transform.OutputKeys
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.transform.TransformerFactoryConfigurationError
      • java.lang.Exception
        • javax.xml.transform.TransformerException
          • javax.xml.transform.TransformerConfigurationException
    • javax.xml.transform.Transformer
    • javax.xml.transform.TransformerFactory

接口分层结构

  • javax.xml.transform.ErrorListener
  • javax.xml.transform.Result
  • javax.xml.transform.Source
  • javax.xml.transform.SourceLocator
  • javax.xml.transform.Templates
  • javax.xml.transform.URIResolver
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.transform 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform
的使用

使用 javax.xml.transform 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.sql 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.bind 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.bind.annotation 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.bind.helpers 使用的 javax.xml.transform 中的类
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.bind.util 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.soap 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.stream 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.transform 使用的 javax.xml.transform 中的类
ErrorListener
要提供自定义错误处理，则需实现此接口并使用 setErrorListener 方法注册一个带有 Transformer 的实现的实例。
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息
SourceLocator
此接口的主要目的是报告在 XML 源或转换指令中发生错误的位置。
Templates
实现此接口的对象是处理后的转换指令的运行时表示形式。
Transformer
此抽象类的实例能够将源树转换为结果树。
TransformerConfigurationException
指示严重的配置错误。
TransformerException
此类指定了转换过程中发生的异常条件。
TransformerFactory
TransformerFactory 实例可用于创建 Transformer 和 Templates 对象。
TransformerFactoryConfigurationError
当通过 Transformer Factories 进行的配置存在问题时抛出此异常。
URIResolver
实现此接口的对象可由处理器进行调用，以将 document()、xsl:import 或 xsl:include 中使用的 URI 转换为 Source 对象。

javax.xml.transform.dom 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息
SourceLocator
此接口的主要目的是报告在 XML 源或转换指令中发生错误的位置。

javax.xml.transform.sax 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息
Templates
实现此接口的对象是处理后的转换指令的运行时表示形式。
Transformer
此抽象类的实例能够将源树转换为结果树。
TransformerConfigurationException
指示严重的配置错误。
TransformerFactory
TransformerFactory 实例可用于创建 Transformer 和 Templates 对象。

javax.xml.transform.stax 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.transform.stream 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.validation 使用的 javax.xml.transform 中的类
Result
实现此接口的对象包含构建转换结果树所需的信息。
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

javax.xml.ws 使用的 javax.xml.transform 中的类
Source
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


SAXResult (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.sax
类 SAXResult

java.lang.Object
    继承者  javax.xml.transform.sax.SAXResult
所有已实现的接口：
Result
直接已知子类：
JAXBResult
public class SAXResult
extends Object
implements Result

充当转换 Result 的持有者。

字段摘要
static String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
从接口 javax.xml.transform.Result 继承的字段
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
构造方法摘要
SAXResult()
零参数的默认构造方法。
SAXResult(ContentHandler handler)
创建以 SAX2 ContentHandler 为目标的 SAXResult。
方法摘要
ContentHandler | getHandler() 获取作为 Result 的 ContentHandler。
LexicalHandler | getLexicalHandler() 获取输出的 SAX2 LexicalHandler。
String | getSystemId() 获取通过 setSystemId 设置的系统标识符。
void | setHandler(ContentHandler handler) 设置要作为 SAX2 ContentHandler 的目标。
void | setLexicalHandler(LexicalHandler handler) 设置输出的 SAX2 LexicalHandler。
void | setSystemId(String systemId) setSystemId 方法设置可与 ContentHandler 关联使用的 systemID。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

另请参见：
常量字段值
构造方法详细信息

SAXResult

public SAXResult()
零参数的默认构造方法。

SAXResult

public SAXResult(ContentHandler handler)
创建以 SAX2 ContentHandler 为目标的 SAXResult。

参数：
handler - 必须为非 null ContentHandler 引用。
方法详细信息

setHandler

public void setHandler(ContentHandler handler)
设置要作为 SAX2 ContentHandler 的目标。

参数：
handler - 必须为非 null ContentHandler 引用。

getHandler

public ContentHandler getHandler()
获取作为 Result 的 ContentHandler。

返回：
要作为转换输出的 ContentHandler。

setLexicalHandler

public void setLexicalHandler(LexicalHandler handler)
设置输出的 SAX2 LexicalHandler。

这需要处理 XML 及类似的注释。如果未设置词法处理程序，则转换器应尝试将 ContentHandler 强制转换为 LexicalHandler。

参数：
handler - 用于处理词法分析事件的非 null LexicalHandler。

getLexicalHandler

public LexicalHandler getLexicalHandler()
获取输出的 SAX2 LexicalHandler。

返回：
LexicalHandler，或 null。

setSystemId

public void setSystemId(String systemId)
setSystemId 方法设置可与 ContentHandler 关联使用的 systemID。

指定者：
接口 Result 中的 setSystemId
参数：
systemId - URI 字符串形式的系统标识符。

getSystemId

public String getSystemId()
获取通过 setSystemId 设置的系统标识符。

指定者：
接口 Result 中的 getSystemId
返回：
通过 setSystemId 设置的系统标识符，如果未调用 setSystemId，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SAXSource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.sax
类 SAXSource

java.lang.Object
    继承者  javax.xml.transform.sax.SAXSource
所有已实现的接口：
Source
直接已知子类：
JAXBSource
public class SAXSource
extends Object
implements Source

充当 SAX 样式 Source 的持有者。

注意，XSLT 要求名称空间支持。尝试转换不是通过名称空间感知的解析器生成的输入源可能导致错误。通过调用 SAXParserFactory.setNamespaceAware(boolean awareness) 方法可以使解析器具有名称空间感知的功能。

字段摘要
static String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。
构造方法摘要
SAXSource()
零参数的默认构造方法。
SAXSource(InputSource inputSource)
使用 SAX InputSource，创建 SAXSource。
SAXSource(XMLReader reader, InputSource inputSource)
使用 XMLReader 和 SAX InputSource 创建 SAXSource。
方法摘要
InputSource | getInputSource() 获取要用于 Source 的 SAX InputSource。
String | getSystemId() 获取要从其解析 URI 的基本 ID（URI 或系统 ID）。
XMLReader | getXMLReader() 获取要用于 Source 的 XMLReader。
void | setInputSource(InputSource inputSource) 设置要用于 Source 的 SAX InputSource。
void | setSystemId(String systemId) 设置此 Source 的系统标识符。
void | setXMLReader(XMLReader reader) 设置要用于 Source 的 XMLReader。
static InputSource | sourceToInputSource(Source source) 尝试从 Source 对象获取 SAX InputSource 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。

另请参见：
常量字段值
构造方法详细信息

SAXSource

public SAXSource()

零参数的默认构造方法。如果使用了此构造方法，且未使用 setInputSource(InputSource inputSource) 设置 SAX 源，则 Transformer 将使用 new InputSource() 创建空的源 InputSource。

另请参见：
Transformer.transform(Source xmlSource, Result outputTarget)

SAXSource

public SAXSource(XMLReader reader,
                 InputSource inputSource)
使用 XMLReader 和 SAX InputSource 创建 SAXSource。Transformer 或 SAXTransformerFactory 将其本身设置为 reader 的 ContentHandler，然后将调用 reader.parse(inputSource)。

参数：
reader - 要用于解析的 XMLReader。
inputSource - 必须为非 null 且将被传递给 reader 解析方法的 SAX 输入源引用。

SAXSource

public SAXSource(InputSource inputSource)
使用 SAX InputSource，创建 SAXSource。Transformer 或 SAXTransformerFactory 通过 XMLReaderFactory（如果未使用 setXMLReader）创建 reader，将其本身设置为该 reader 的 ContentHandler，并调用 reader.parse(inputSource)。

参数：
inputSource - 必须为非 null 且将传递给 reader 的解析方法的输入源引用。
方法详细信息

setXMLReader

public void setXMLReader(XMLReader reader)
设置要用于 Source 的 XMLReader。

参数：
reader - 有效的 XMLReader 或 XMLFilter 引用。

getXMLReader

public XMLReader getXMLReader()
获取要用于 Source 的 XMLReader。

返回：
有效的 XMLReader 或 XMLFilter 引用，或者返回 null。

setInputSource

public void setInputSource(InputSource inputSource)
设置要用于 Source 的 SAX InputSource。

参数：
inputSource - 有效的 InputSource 引用。

getInputSource

public InputSource getInputSource()
获取要用于 Source 的 SAX InputSource。

返回：
有效的 InputSource 引用，或 null。

setSystemId

public void setSystemId(String systemId)
设置此 Source 的系统标识符。如果已设置输入源，则它将设置系统 ID 或该输入源，否则它将创建新输入源。

如果有字节流或字符流，则系统标识符是可选的，但提供系统标识符仍然很有用，因为应用程序可以用它来解析相对 URI，并可以将它包括在错误消息和警告中（仅当未指定字节流或字符流时，解析器才尝试打开到 URI 的连接）。

指定者：
接口 Source 中的 setSystemId
参数：
systemId - URI 字符串形式的系统标识符。

getSystemId

public String getSystemId()

获取要从其解析 URI 的基本 ID（URI 或系统 ID）。

指定者：
接口 Source 中的 getSystemId
返回：
Source 的基本 URL，或 null。

sourceToInputSource

public static InputSource sourceToInputSource(Source source)
尝试从 Source 对象获取 SAX InputSource 对象。

参数：
source - 必须为非 null Source 引用。
返回：
InputSource，如果不能转换 Source，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAXTransformerFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.sax
类 SAXTransformerFactory

java.lang.Object
    继承者  javax.xml.transform.TransformerFactory
        继承者  javax.xml.transform.sax.SAXTransformerFactory

public abstract class SAXTransformerFactory
extends TransformerFactory

此类扩展了 TransformerFactory 以提供特定于 SAX 的工厂方法。它提供两种类型的 ContentHandler，一种用于创建 Transformer，另一种用于创建 Templates 对象。

如果应用程序希望设置转换期间所使用的 XMLReader 的 ErrorHandler 或 EntityResolver，那么它应使用 URIResolver 来返回提供了（通过 getXMLReader）对 XMLReader 引用的 SAXSource。

字段摘要
static String | FEATURE 当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则从 TransformerFactory.newInstance() 返回的 TransformerFactory 可以安全地被转换为 SAXTransformerFactory。
static String | FEATURE_XMLFILTER 当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 newXMLFilter(Source src) 和 newXMLFilter(Templates templates) 方法是受支持的。
构造方法摘要
protected SAXTransformerFactory()
默认构造方法受到有意保护。
方法摘要
abstract TemplatesHandler | newTemplatesHandler() 获取能够将 SAX ContentHandler 事件处理为 Templates 对象的 TemplatesHandler 对象。
abstract TransformerHandler | newTransformerHandler() 获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | newTransformerHandler(Source src) 基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | newTransformerHandler(Templates templates) 基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract XMLFilter | newXMLFilter(Source src) 创建使用给定 Source 作为转换指令的 XMLFilter。
abstract XMLFilter | newXMLFilter(Templates templates) 基于 Templates 参数，创建 XMLFilter。
从类 javax.xml.transform.TransformerFactory 继承的方法
getAssociatedStylesheet, getAttribute, getErrorListener, getFeature, getURIResolver, newInstance, newInstance, newTemplates, newTransformer, newTransformer, setAttribute, setErrorListener, setFeature, setURIResolver
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则从 TransformerFactory.newInstance() 返回的 TransformerFactory 可以安全地被转换为 SAXTransformerFactory。

另请参见：
常量字段值

FEATURE_XMLFILTER

public static final String FEATURE_XMLFILTER
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 newXMLFilter(Source src) 和 newXMLFilter(Templates templates) 方法是受支持的。

另请参见：
常量字段值
构造方法详细信息

SAXTransformerFactory

protected SAXTransformerFactory()
默认构造方法受到有意保护。

方法详细信息

newTransformerHandler

public abstract TransformerHandler newTransformerHandler(Source src)
                                                  throws TransformerConfigurationException
基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。

参数：
src - 转换指令的 Source。
返回：
准备好转换 SAX 事件的 TransformerHandler。
抛出：
TransformerConfigurationException - 如果由于某种原因不能创建 TransformerHandler。

newTransformerHandler

public abstract TransformerHandler newTransformerHandler(Templates templates)
                                                  throws TransformerConfigurationException
基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。

参数：
templates - 编译后的转换指令。
返回：
准备好转换 SAX 事件的 TransformerHandler。
抛出：
TransformerConfigurationException - 如果由于某种原因不能创建 TransformerHandler。

newTransformerHandler

public abstract TransformerHandler newTransformerHandler()
                                                  throws TransformerConfigurationException
获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。转换定义为标识（或复制）转换，例如要将一系列 SAX 分析事件复制到 DOM 树中。

返回：
对 TransformerHandler 的非 null 引用，可用作 SAX 分析事件的 ContentHandler。
抛出：
TransformerConfigurationException - 如果由于某种原因不能创建 TransformerHandler。

newTemplatesHandler

public abstract TemplatesHandler newTemplatesHandler()
                                              throws TransformerConfigurationException
获取能够将 SAX ContentHandler 事件处理为 Templates 对象的 TemplatesHandler 对象。

返回：
对 TransformerHandler 的非 null 引用，可用作 SAX 分析事件的 ContentHandler。
抛出：
TransformerConfigurationException - 如果由于某种原因不能创建 TemplatesHandler。

newXMLFilter

public abstract XMLFilter newXMLFilter(Source src)
                                throws TransformerConfigurationException
创建使用给定 Source 作为转换指令的 XMLFilter。

参数：
src - 转换指令的 Source。
返回：
XMLFilter 对象，如果不支持此功能，则返回 null。
抛出：
TransformerConfigurationException - 如果由于某种原因不能创建 TemplatesHandler。

newXMLFilter

public abstract XMLFilter newXMLFilter(Templates templates)
                                throws TransformerConfigurationException
基于 Templates 参数，创建 XMLFilter。

参数：
templates - 编译后的转换指令。
返回：
XMLFilter 对象，如果不支持此功能，则返回 null。
抛出：
TransformerConfigurationException - 如果由于某种原因不能创建 TemplatesHandler。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TemplatesHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.sax
接口 TemplatesHandler

所有超级接口：
ContentHandler
public interface TemplatesHandler
extends ContentHandler

可用于将 SAX 解析事件（解析转换指令）处理为 Templates 对象的 SAX ContentHandler。

注意，TemplatesHandler 无需实现 LexicalHandler。

方法摘要
String | getSystemId() 获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
Templates | getTemplates() 当 TemplatesHandler 对象用作 ContentHandler（用于转换指令的解析）时，它创建 Templates 对象，调用者可以在 SAX 事件已完成后获取该对象。
void | setSystemId(String systemID) 设置此生成器所创建的 Templates 对象的基本 ID（URI 或系统 ID）。
从接口 org.xml.sax.ContentHandler 继承的方法
characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

方法详细信息

getTemplates

Templates getTemplates()
当 TemplatesHandler 对象用作 ContentHandler（用于转换指令的解析）时，它创建 Templates 对象，调用者可以在 SAX 事件已完成后获取该对象。

返回：
SAX 事件处理期间创建的 Templates 对象，如果未创建 Templates 对象，则返回 null。

setSystemId

void setSystemId(String systemID)
设置此生成器所创建的 Templates 对象的基本 ID（URI 或系统 ID）。必须进行此设置以解析 stylesheet 中的相对 URI。必须在 startDocument 之前调用此方法。

参数：
systemID - 此 stylesheet 的基本 URI。

getSystemId

String getSystemId()
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

返回：
通过 setSystemId(java.lang.String) 设置的 systemID。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformerHandler (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.sax
接口 TransformerHandler

所有超级接口：
ContentHandler, DTDHandler, LexicalHandler
public interface TransformerHandler
extends ContentHandler, LexicalHandler, DTDHandler

侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

方法摘要
String | getSystemId() 获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
Transformer | getTransformer() 获取与此处理程序关联的 Transformer，用于设置参数和输出属性。
void | setResult(Result result) 设置与用于转换的此 TransformerHandler 关联的 Result。
void | setSystemId(String systemID) 设置要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
从接口 org.xml.sax.ContentHandler 继承的方法
characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping
从接口 org.xml.sax.ext.LexicalHandler 继承的方法
comment, endCDATA, endDTD, endEntity, startCDATA, startDTD, startEntity
从接口 org.xml.sax.DTDHandler 继承的方法
notationDecl, unparsedEntityDecl

方法详细信息

setResult

void setResult(Result result)
               throws IllegalArgumentException

设置与用于转换的此 TransformerHandler 关联的 Result。

参数：
result - Result 实例，不应为 null。
抛出：
IllegalArgumentException - 如果由于某种原因结果无效。

setSystemId

void setSystemId(String systemID)
设置要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

参数：
systemID - 源树的基本 URI。

getSystemId

String getSystemId()
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

返回：
通过 setSystemId(java.lang.String) 设置的 systemID。

getTransformer

Transformer getTransformer()

获取与此处理程序关联的 Transformer，用于设置参数和输出属性。

返回：
与此 TransformerHandler 关联的 Transformer。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.transform.sax (Java Platform SE 6)

 javax.xml.transform.sax
接口
TemplatesHandler
TransformerHandler
类
SAXResult
SAXSource
SAXTransformerFactory


javax.xml.transform.sax (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.transform.sax

此包实现特定于 SAX2 的转换 API。

请参见：
描述

接口摘要
TemplatesHandler | 可用于将 SAX 解析事件（解析转换指令）处理为 Templates 对象的 SAX ContentHandler。
TransformerHandler | 侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

类摘要
SAXResult | 充当转换 Result 的持有者。
SAXSource | 充当 SAX 样式 Source 的持有者。
SAXTransformerFactory | 此类扩展了 TransformerFactory 以提供特定于 SAX 的工厂方法。

软件包 javax.xml.transform.sax 的描述

此包实现特定于 SAX2 的转换 API。它提供了允许从 ContentHandler 事件输入的类，还提供了生成 org.xml.sax.ContentHandler 事件的类。它还提供了用于将输入源设置为 XMLReader，或使用 InputSource 作为源的方法。它还允许创建 XMLFilter，这支持从其他转换“拉入”的转换，并使转换器通过多种形式作为 XMLReader 使用。

SAXSource 类允许设置用于“拉入”解析事件的 XMLReader，以及用于指定 SAX 源的 InputSource。

SAXResult 类允许设置用作来自转换的 SAX2 事件接收器的 ContentHandler。

SAXTransformerFactory 扩展了 TransformerFactory，以提供用于创建 TemplatesHandler、TransformerHandler 和 XMLReader 实例的工厂方法。

要获取 SAXTransformerFactory，调用者必须强制转换从 TransformerFactory.newInstance() 返回的 TransformerFactory 实例。

@link javax.xml.transform.sax.TransformerHandler} 接口允许从 SAX2 解析事件创建转换，这是 "push"（推）模型，而不是转换中通常发生的 "pull"（拉）模型。正常解析事件通过 ContentHandler 接口接收，词法事件（例如 startCDATA 和 endCDATA）通过 LexicalHandler 接口接收，标记禁用输出转义的开始或结束的事件通过 ContentHandler.processingInstruction(java.lang.String, java.lang.String) 接收，目标参数为 Result.PI_DISABLE_OUTPUT_ESCAPING 和 Result.PI_ENABLE_OUTPUT_ESCAPING。如果要在 Transformer 处理程序中设置参数、输出属性或其他功能，则需要从 TransformerHandler.getTransformer() 获取 Transformer 引用，以及从该引用调用的方法。

TemplatesHandler 接口允许从 SAX2 解析事件创建 Templates 对象。当 ContentHandler 事件完成后，可以从 TemplatesHandler.getTemplates() 获取 Templates 对象。注意，应正常调用 TemplatesHandler.setSystemId(java.lang.String)，以建立可以从其解析 URL 的基本系统 ID。

SAXTransformerFactory.newXMLFilter(javax.xml.transform.Source) 方法允许创建 XMLFilter，它封装了 "pull" 转换的 SAX2 概念。以下阐释了互相形成链的几种转换。每个过滤器均指向一个父 XMLReader，且通过调用链中最后的 reader 上的 XMLReader.parse(org.xml.sax.InputSource) 来引发最后的转换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.transform.sax 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform.sax 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
    • javax.xml.transform.TransformerFactory
      • javax.xml.transform.sax.SAXTransformerFactory

接口分层结构

  • org.xml.sax.ContentHandler
    • javax.xml.transform.sax.TemplatesHandler
    • javax.xml.transform.sax.TransformerHandler (并 extends org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
  • org.xml.sax.DTDHandler
    • javax.xml.transform.sax.TransformerHandler (并 extends org.xml.sax.ContentHandler, org.xml.sax.ext.LexicalHandler)
  • org.xml.sax.ext.LexicalHandler
    • javax.xml.transform.sax.TransformerHandler (并 extends org.xml.sax.ContentHandler, org.xml.sax.DTDHandler)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.transform.sax 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform.sax
的使用

使用 javax.xml.transform.sax 的软件包
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.bind.util 使用的 javax.xml.transform.sax 中的类
SAXResult
充当转换 Result 的持有者。
SAXSource
充当 SAX 样式 Source 的持有者。

javax.xml.transform.sax 使用的 javax.xml.transform.sax 中的类
TemplatesHandler
可用于将 SAX 解析事件（解析转换指令）处理为 Templates 对象的 SAX ContentHandler。
TransformerHandler
侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.sax.SAXResult 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.sax.SAXResult
的使用

使用 SAXResult 的软件包
javax.xml.bind.util 有用的客户端实用工具类。

javax.xml.bind.util 中 SAXResult 的使用

javax.xml.bind.util 中 SAXResult 的子类
 class JAXBResult
解组 JAXB 对象的 JAXP Result 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.sax.SAXSource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.sax.SAXSource
的使用

使用 SAXSource 的软件包
javax.xml.bind.util 有用的客户端实用工具类。

javax.xml.bind.util 中 SAXSource 的使用

javax.xml.bind.util 中 SAXSource 的子类
 class JAXBSource
编组 JAXB 生成的对象的 JAXP Source 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.sax.SAXTransformerFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.sax.SAXTransformerFactory
的使用

没有 javax.xml.transform.sax.SAXTransformerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.sax.TemplatesHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.sax.TemplatesHandler
的使用

使用 TemplatesHandler 的软件包
javax.xml.transform.sax 此包实现特定于 SAX2 的转换 API。

javax.xml.transform.sax 中 TemplatesHandler 的使用

返回 TemplatesHandler 的 javax.xml.transform.sax 中的方法
abstract  TemplatesHandler SAXTransformerFactory.newTemplatesHandler()
获取能够将 SAX ContentHandler 事件处理为 Templates 对象的 TemplatesHandler 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.sax.TransformerHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.sax.TransformerHandler
的使用

使用 TransformerHandler 的软件包
javax.xml.transform.sax 此包实现特定于 SAX2 的转换 API。

javax.xml.transform.sax 中 TransformerHandler 的使用

返回 TransformerHandler 的 javax.xml.transform.sax 中的方法
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler() 获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Source src) 基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Templates templates) 基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DOMLocator (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.dom
接口 DOMLocator

所有超级接口：
SourceLocator
public interface DOMLocator
extends SourceLocator

指示源 DOM 中节点的位置，主要用于错误报告。要使用 DOMLocator，错误接收器必须向下转换异常所返回的 SourceLocator 对象。Transformer 可以将此对象用于错误报告以外的目的，例如，用于指示产生结果节点的源节点。

方法摘要
 Node getOriginatingNode()
返回事件发生的节点位置。
从接口 javax.xml.transform.SourceLocator 继承的方法
getColumnNumber, getLineNumber, getPublicId, getSystemId

方法详细信息

getOriginatingNode

Node getOriginatingNode()
返回事件发生的节点位置。

返回：
事件位置的节点。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DOMResult (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.dom
类 DOMResult

java.lang.Object
    继承者  javax.xml.transform.dom.DOMResult
所有已实现的接口：
Result
直接已知子类：
SAAJResult
public class DOMResult
extends Object
implements Result

以 Document Object Model（DOM）树的形式充当转换结果树的持有者。

如果未设置输出 DOM 源，则转换将创建 Document 节点作为转换结果的持有者，可以通过 getNode() 来检索该节点。

字段摘要
static String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
从接口 javax.xml.transform.Result 继承的字段
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
构造方法摘要
DOMResult()
零参数的默认构造方法。
DOMResult(Node node)
使用 DOM 节点创建新输出目标。
DOMResult(Node node, Node nextSibling)
使用 DOM 节点创建新输出目标，此目标指定了应该插入的结果节点之后的子节点。
DOMResult(Node node, Node nextSibling, String systemId)
使用 DOM 节点创建新输出目标，此目标指定了子节点，其中结果节点为指定 System ID 且应该插入到该子节点之前。
DOMResult(Node node, String systemId)
使用 DOM 节点创建带有指定 System ID 的新输出目标。
方法摘要
Node | getNextSibling() 获取将要插入的结果节点之后的子节点。
Node | getNode() 获取将包含结果 DOM 树的节点。
String | getSystemId() 获取系统标识符。
void | setNextSibling(Node nextSibling) 设置将要插入的结果节点之后的子节点。
void | setNode(Node node) 设置将包含结果 DOM 树的节点。
void | setSystemId(String systemId) 设置可与此节点联合使用的 systemId。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE

当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

另请参见：
常量字段值
构造方法详细信息

DOMResult

public DOMResult()

零参数的默认构造方法。

node、siblingNode 和 systemId 将被设置为 null。

DOMResult

public DOMResult(Node node)

使用 DOM 节点创建新输出目标。

实际上，该节点应该是 Document 节点、DocumentFragment 节点或 Element 节点。换句话说，应该是接受子级的节点。

siblingNode 和 systemId 将被设置为 null。

参数：
node - 将包含结果树的 DOM 节点。

DOMResult

public DOMResult(Node node,
                 String systemId)

使用 DOM 节点创建带有指定 System ID 的新输出目标。

实际上，该节点应该是 Document 节点、DocumentFragment 节点或 Element 节点。换句话说，应该是是接受子级的节点。

siblingNode 将被设置为 null。

参数：
node - 将包含结果树的 DOM 节点。
systemId - 可与此节点联合使用的系统标识符。

DOMResult

public DOMResult(Node node,
                 Node nextSibling)

使用 DOM 节点创建新输出目标，此目标指定了应该插入的结果节点之后的子节点。

实际上，node 和 nextSibling 应该是 Document 节点、DocumentFragment 节点或 Element 节点。换句话说，应该是接受子级的节点。

使用 nextSibling 来指定应该插入的结果节点之后的子节点。如果 nextSibling 不是 node 的兄弟结点，则抛出 IllegalArgumentException。如果 node 为 null 且 nextSibling 不为 null，则抛出 IllegalArgumentException。如果 nextSibling 为 null，则行为将与调用 DOMResult(Node node) 相同，即将结果节点追加为指定 node 的最后一个子节点。

systemId 将被设置为 null。

参数：
node - 将包含结果树的 DOM 节点。
nextSibling - 应该插入的结果节点之后的子节点。
抛出：
IllegalArgumentException - 如果 nextSibling 不是 node 的兄弟节点，或者 node 为 null 且 nextSibling 不为 null。
从以下版本开始：
1.5

DOMResult

public DOMResult(Node node,
                 Node nextSibling,
                 String systemId)

使用 DOM 节点创建新输出目标，此目标指定了子节点，其中结果节点为指定 System ID 且应该插入到该子节点之前。

实际上，node 和 nextSibling 应该是 Document 节点、DocumentFragment 节点或 Element 节点。换句话说，应该是接受子级的节点。

使用 nextSibling 来指定应该插入的结果节点之后的子节点。如果 nextSibling 不是 node 的兄弟结点，则抛出 IllegalArgumentException。如果 node 为 null 且 nextSibling 不为 null，则抛出 IllegalArgumentException。如果 nextSibling 为 null，则行为将与调用 DOMResult(Node node, String systemId) 相同，即将结果节点追加为指定节点的最后一个子节点，并使用指定 System ID。

参数：
node - 将包含结果树的 DOM 节点。
nextSibling - 应该插入的结果节点之后的子节点。
systemId - 可与此节点关联使用的系统标识符。
抛出：
IllegalArgumentException - 如果 nextSibling 不是 node 的兄弟节点，或者 node 为 null 且 nextSibling 不为 null。
从以下版本开始：
1.5
方法详细信息

setNode

public void setNode(Node node)

设置将包含结果 DOM 树的节点。

实际上，该节点应该是 Document 节点、DocumentFragment 节点或 Element 节点。换句话说，应该是接受子级的节点。

如果 nextSibling 不为 null 且 node 不是 nextSibling 的父级，则抛出 IllegalStateException。如果 node 为 null 且 nextSibling 不为 null，则抛出 IllegalStateException。

参数：
node - 转换将被追加到的节点。
抛出：
IllegalStateException - 如果 nextSibling 不为 null 且 nextSibling 不是 node 的子节点，或者 node 为 null 且 nextSibling 不为 null。

getNode

public Node getNode()

获取将包含结果 DOM 树的节点。

如果节点不是通过 DOMResult(Node node)、DOMResult(Node node, String systeId)、DOMResult(Node node, Node nextSibling)、DOMResult(Node node, Node nextSibling, String systemId) 或 setNode(Node node) 设置的，则节点将通过转换进行设置，且当转换完成后可以从此方法获取。在转换之前调用此方法将返回 null。

返回：
转换将被追加到的节点。

setNextSibling

public void setNextSibling(Node nextSibling)

设置将要插入的结果节点之后的子节点。

使用 nextSibling 来指定将要插入的结果节点之后的子节点。如果 nextSibling 不是 node 的后代，则抛出 IllegalArgumentException。如果 node 为 null 且 nextSibling 不为 null，则抛出 IllegalStateException。如果 nextSibling 为 null，则行为将与调用 DOMResult(Node node) 相同，即将结果节点追加为指定 node 的最后一个子节点。

参数：
nextSibling - 将要插入的结果节点之后的子节点。
抛出：
IllegalArgumentException - 如果 nextSibling 不是 node 的后代。
IllegalStateException - 如果 node 为 null 且 nextSibling 不为 null。
从以下版本开始：
1.5

getNextSibling

public Node getNextSibling()

获取将要插入的结果节点之后的子节点。

如果没有通过 DOMResult(Node node, Node nextSibling)、DOMResult(Node node, Node nextSibling, String systemId) 或 setNextSibling(Node nextSibling) 设置节点，则将返回 null。

返回：
将要插入的结果节点之后的子节点。
从以下版本开始：
1.5

setSystemId

public void setSystemId(String systemId)

设置可与此节点联合使用的 systemId。

指定者：
接口 Result 中的 setSystemId
参数：
systemId - URI 字符串形式的系统标识符。

getSystemId

public String getSystemId()

获取系统标识符。

如果没有通过 DOMResult(Node node, String systemId)、DOMResult(Node node, Node nextSibling, String systemId) 或 setSystemId(String systemId) 设置 System ID，则将返回 null。

指定者：
接口 Result 中的 getSystemId
返回：
系统标识符。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMSource (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.dom
类 DOMSource

java.lang.Object
    继承者  javax.xml.transform.dom.DOMSource
所有已实现的接口：
Source
public class DOMSource
extends Object
implements Source

以 Document Object Model（DOM）树的形式充当转换 Source 树的持有者。

注意，XSLT 要求名称空间支持。尝试转换不是通过名称空间感知的解析器构造的 DOM 可能导致错误。通过调用 DocumentBuilderFactory.setNamespaceAware(boolean awareness) 可以使解析器具有名称空间感知的功能。

另请参见：
Document Object Model (DOM) Level 2 Specification

字段摘要
static String FEATURE
当将此值作为参数传递时如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。
构造方法摘要
DOMSource()
零参数的默认构造方法。
DOMSource(Node n)
创建带有 DOM 节点的新输入源。
DOMSource(Node node, String systemID)
创建带有 DOM 节点的新输入源，系统 ID 也作为基本 URI 被传入。
方法摘要
Node | getNode() 获取表示 Source DOM 树的节点。
String | getSystemId() 获取将从其解析 URL 的基本 ID（URL 或系统 ID）。
void | setNode(Node node) 设置将表示 Source DOM 树的节点。
void | setSystemId(String systemID) 设置将从其解析 URL 的基本 ID（URL 或系统 ID）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE
当将此值作为参数传递时如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。

另请参见：
常量字段值
构造方法详细信息

DOMSource

public DOMSource()

零参数的默认构造方法。如果使用此构造方法，且没有使用 setNode(Node node) 设置 DOM，则 Transformer 将使用 DocumentBuilder.newDocument() 创建空的源 Document。

另请参见：
Transformer.transform(Source xmlSource, Result outputTarget)

DOMSource

public DOMSource(Node n)
创建带有 DOM 节点的新输入源。该操作将应用于以此节点为根的子树。在 XSLT 中，"/" 模式仍意味着树的根（不是子树），全局变量和参数的计算也从根节点进行。

参数：
n - 将包含 Source 树的 DOM 节点。

DOMSource

public DOMSource(Node node,
                 String systemID)
创建带有 DOM 节点的新输入源，系统 ID 也作为基本 URI 被传入。

参数：
node - 将包含 Source 树的 DOM 节点。
systemID - 指定与节点关联的基本 URI。
方法详细信息

setNode

public void setNode(Node node)
设置将表示 Source DOM 树的节点。

参数：
node - 要转换的节点。

getNode

public Node getNode()
获取表示 Source DOM 树的节点。

返回：
要转换的节点。

setSystemId

public void setSystemId(String systemID)
设置将从其解析 URL 的基本 ID（URL 或系统 ID）。

指定者：
接口 Source 中的 setSystemId
参数：
systemID - 此 DOM 树的基本 URL。

getSystemId

public String getSystemId()
获取将从其解析 URL 的基本 ID（URL 或系统 ID）。

指定者：
接口 Source 中的 getSystemId
返回：
此 DOM 树的基本 URL。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.transform.dom (Java Platform SE 6)

 javax.xml.transform.dom
接口
DOMLocator
类
DOMResult
DOMSource


javax.xml.transform.dom (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.transform.dom

此包实现特定于 DOM 的转换 API。

请参见：
描述

接口摘要
DOMLocator 指示源 DOM 中节点的位置，主要用于错误报告。

类摘要
DOMResult | 以 Document Object Model（DOM）树的形式充当转换结果树的持有者。
DOMSource | 以 Document Object Model（DOM）树的形式充当转换 Source 树的持有者。

软件包 javax.xml.transform.dom 的描述

此包实现特定于 DOM 的转换 API。

DOMSource 类允许实现此 API 的客户端将 DOM Node 指定为输入树的源。Transformer 如何处理与 XSLT 数据模型 或其他数据模型不匹配的 DOM 树的模型超出了本文档的讨论范围。从 Node 派生的任何节点均是合法输入。

DOMResult 类允许指定 Node，其中结果 DOM 节点将被追加到 Node。如果未指定输出节点，则转换器将使用 DocumentBuilder.newDocument() 来创建输出 Document 节点。如果指定了节点，则它应为以下之一：Document、Element 或 DocumentFragment。任何其他节点类型规范均与实现有关且未由此 API 定义。如果结果为 Document，则转换的输出必须具有一个设置为文档元素的单个元素根。

可以将 DOMLocator 节点传递到 TransformerException 对象，并可以通过尝试强制转换 TransformerException.getLocator() 方法的结果来检索它。实现不负责使用 DOMLocator 来替代 SourceLocator（通过行数且这种可能性对于 DOM 无太大意义），因此必须总是通过 instanceof 来测试 getLocator 的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.transform.dom 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform.dom 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
    • javax.xml.transform.dom.DOMSource (implements javax.xml.transform.Source)

接口分层结构

  • javax.xml.transform.SourceLocator
    • javax.xml.transform.dom.DOMLocator
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.transform.dom 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform.dom
的使用

使用 javax.xml.transform.dom 的软件包
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。

javax.xml.bind.annotation 使用的 javax.xml.transform.dom 中的类
DOMResult
以 Document Object Model（DOM）树的形式充当转换结果树的持有者。

javax.xml.soap 使用的 javax.xml.transform.dom 中的类
DOMResult
以 Document Object Model（DOM）树的形式充当转换结果树的持有者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.dom.DOMLocator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.dom.DOMLocator
的使用

没有 javax.xml.transform.dom.DOMLocator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.dom.DOMResult 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.dom.DOMResult
的使用

使用 DOMResult 的软件包
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。

javax.xml.bind.annotation 中 DOMResult 的使用

返回 DOMResult 的 javax.xml.bind.annotation 中的方法
 DOMResult W3CDomHandler.createUnmarshaller(ValidationEventHandler errorHandler)

参数类型为 DOMResult 的 javax.xml.bind.annotation 中的方法
 Element W3CDomHandler.getElement(DOMResult r)

javax.xml.soap 中 DOMResult 的使用

javax.xml.soap 中 DOMResult 的子类
 class SAAJResult
以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.dom.DOMSource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.dom.DOMSource
的使用

没有 javax.xml.transform.dom.DOMSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


StAXResult (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.stax
类 StAXResult

java.lang.Object
    继承者  javax.xml.transform.stax.StAXResult
所有已实现的接口：
Result
public class StAXResult
extends Object
implements Result

以 StAX writer 的形式（即 XMLStreamWriter 或 XMLEventWriter）充当 XML Result 的持有者。各种接受 Result 的情况下都可以使用 StAXResult，例如，将 Result 作为输入接受的 Transformer 和 Validator。

从以下版本开始：
1.6
另请参见：
JSR 173:Streaming API for XML, XMLStreamWriter, XMLEventWriter

字段摘要
static String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Result 输出。
从接口 javax.xml.transform.Result 继承的字段
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
构造方法摘要
StAXResult(XMLEventWriter xmlEventWriter)
通过提供 XMLEventWriter 创建 StAXResult 的一个新实例。
StAXResult(XMLStreamWriter xmlStreamWriter)
通过提供 XMLStreamWriter 创建 StAXResult 的一个新实例。
方法摘要
String | getSystemId() 返回的系统标识符始终为 null。
XMLEventWriter | getXMLEventWriter() 获取此 StAXResult 使用的 XMLEventWriter。
XMLStreamWriter | getXMLStreamWriter() 获取此 StAXResult 使用的 XMLStreamWriter。
void | setSystemId(String systemId) 在 StAXResult 的上下文中，它不适合显示设置系统标识符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Result 输出。

另请参见：
常量字段值
构造方法详细信息

StAXResult

public StAXResult(XMLEventWriter xmlEventWriter)

通过提供 XMLEventWriter 创建 StAXResult 的一个新实例。

XMLEventWriter 必须为非 null 引用。

参数：
xmlEventWriter - 用于创建此 StAXResult 的 XMLEventWriter。
抛出：
IllegalArgumentException - 如果 xmlEventWriter == null。

StAXResult

public StAXResult(XMLStreamWriter xmlStreamWriter)

通过提供 XMLStreamWriter 创建 StAXResult 的一个新实例。

XMLStreamWriter 必须为非 null 引用。

参数：
xmlStreamWriter - 用于创建此 StAXResult 的 XMLStreamWriter。
抛出：
IllegalArgumentException - 如果 xmlStreamWriter == null。
方法详细信息

getXMLEventWriter

public XMLEventWriter getXMLEventWriter()

获取此 StAXResult 使用的 XMLEventWriter。

如果此 StAXResult 是使用 XMLStreamWriter 创建的，那么 XMLEventWriter 将为 null。

返回：
此 StAXResult 使用的 XMLEventWriter。

getXMLStreamWriter

public XMLStreamWriter getXMLStreamWriter()

获取此 StAXResult 使用的 XMLStreamWriter。

如果此 StAXResult 是使用 XMLEventWriter 创建的，那么 XMLStreamWriter 将为 null。

返回：
此 StAXResult 使用的 XMLStreamWriter。

setSystemId

public void setSystemId(String systemId)

在 StAXResult 的上下文中，它不适合显示设置系统标识符。用于构造此 StAXResult 的 XMLEventWriter 或 XMLStreamWriter 确定 XML 结果的系统标识符。

此方法始终抛出 UnsupportedOperationException。

指定者：
接口 Result 中的 setSystemId
参数：
systemId - 忽略。
抛出：
UnsupportedOperationException - 此方法始终抛出该异常。

getSystemId

public String getSystemId()

返回的系统标识符始终为 null。

指定者：
接口 Result 中的 getSystemId
返回：
返回的系统标识符始终为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


StAXSource (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.stax
类 StAXSource

java.lang.Object
    继承者  javax.xml.transform.stax.StAXSource
所有已实现的接口：
Source
public class StAXSource
extends Object
implements Source

以 StAX reader 的形式（即 XMLStreamReader 或 XMLEventReader）充当 XML Source 的持有者。各种接受 Source 的情况下都可以使用 StAXSource，例如，将 Source 作为输入接受的 Transformer 和 Validator。

在处理期间使用 StAXSource 并且不能重复使用。

从以下版本开始：
1.6
另请参见：
JSR 173:Streaming API for XML, XMLStreamReader, XMLEventReader

字段摘要
static String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Source 输入。
构造方法摘要
StAXSource(XMLEventReader xmlEventReader)
通过提供 XMLEventReader 创建 StAXSource 的一个新实例。
StAXSource(XMLStreamReader xmlStreamReader)
通过 XMLStreamReader 创建 StAXSource 的一个新实例。
方法摘要
String | getSystemId() 获取此 StAXSource 使用的系统标识符。
XMLEventReader | getXMLEventReader() 获取此 StAXSource 使用的 XMLEventReader。
XMLStreamReader | getXMLStreamReader() 获取此 StAXSource 使用的 XMLStreamReader。
void | setSystemId(String systemId) 在 StAXSource 的上下文中，它不适合显示设置系统标识符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Source 输入。

另请参见：
常量字段值
构造方法详细信息

StAXSource

public StAXSource(XMLEventReader xmlEventReader)
           throws XMLStreamException

通过提供 XMLEventReader 创建 StAXSource 的一个新实例。

XMLEventReader 必须为非 null 引用。

XMLEventReader 必须处于 XMLStreamConstants.START_DOCUMENT 或 XMLStreamConstants.START_ELEMENT 状态。

参数：
xmlEventReader - 用于创建此 StAXSource 的 XMLEventReader。
抛出：
XMLStreamException - 如果 xmlEventReader 访问抛出 Exception。
IllegalArgumentException - 如果 xmlEventReader == null。
IllegalStateException - 如果 xmlEventReader 不处于 XMLStreamConstants.START_DOCUMENT 或 XMLStreamConstants.START_ELEMENT 状态。

StAXSource

public StAXSource(XMLStreamReader xmlStreamReader)

通过 XMLStreamReader 创建 StAXSource 的一个新实例。

XMLStreamReader 必须为非 null 引用。

XMLStreamReader 必须处于 XMLStreamConstants.START_DOCUMENT 或 XMLStreamConstants.START_ELEMENT 状态。

参数：
xmlStreamReader - 用于创建此 StAXSource 的 XMLStreamReader。
抛出：
IllegalArgumentException - 如果 xmlStreamReader == null。
IllegalStateException - 如果 xmlStreamReader 不处于 XMLStreamConstants.START_DOCUMENT 或 XMLStreamConstants.START_ELEMENT 状态。
方法详细信息

getXMLEventReader

public XMLEventReader getXMLEventReader()

获取此 StAXSource 使用的 XMLEventReader。

如果此 StAXSource 是使用 XMLStreamReader 创建的，那么 XMLEventReader 将为 null。

返回：
此 StAXSource 使用的 XMLEventReader。

getXMLStreamReader

public XMLStreamReader getXMLStreamReader()

获取此 StAXSource 使用的 XMLStreamReader。

如果此 StAXSource 是使用 XMLEventReader 创建的，那么 XMLStreamReader 将为 null。

返回：
此 StAXSource 使用的 XMLStreamReader。

setSystemId

public void setSystemId(String systemId)

在 StAXSource 的上下文中，它不适合显示设置系统标识符。用于构造此 StAXSource 的 XMLStreamReader 或 XMLEventReader 确定 XML 源的系统标识符。

此方法始终抛出 UnsupportedOperationException。

指定者：
接口 Source 中的 setSystemId
参数：
systemId - 忽略。
抛出：
UnsupportedOperationException - 此方法始终抛出该异常。

getSystemId

public String getSystemId()

获取此 StAXSource 使用的系统标识符。

查询用于构造此 StAXSource 的 XMLStreamReader 或 XMLEventReader 以确定 XML 源的系统标识符。

系统标识符可以为 null 或空 "" String。

指定者：
接口 Source 中的 getSystemId
返回：
此 StAXSource 使用的系统标识符。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.transform.stax (Java Platform SE 6)

 javax.xml.transform.stax
类
StAXResult
StAXSource


javax.xml.transform.stax (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.transform.stax

提供特定于 StAX 的转换 API。

请参见：
描述

类摘要
StAXResult | 以 StAX writer 的形式（即 XMLStreamWriter 或 XMLEventWriter）充当 XML Result 的持有者。
StAXSource | 以 StAX reader 的形式（即 XMLStreamReader 或 XMLEventReader）充当 XML Source 的持有者。

软件包 javax.xml.transform.stax 的描述

提供特定于 StAX 的转换 API。代办事项：更好的描述。

包规范

  • JSR 173:Streaming API for XML

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：

  • 代办事项：请参阅非规范文档
  • XMLStreamReader
  • XMLEventReader

从以下版本开始：
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.transform.stax 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform.stax 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.transform.stax.StAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stax.StAXSource (implements javax.xml.transform.Source)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.transform.stax 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform.stax
的使用

没有 javax.xml.transform.stax 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.stax.StAXResult 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.stax.StAXResult
的使用

没有 javax.xml.transform.stax.StAXResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.stax.StAXSource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.stax.StAXSource
的使用

没有 javax.xml.transform.stax.StAXSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


StreamResult (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.stream
类 StreamResult

java.lang.Object
    继承者  javax.xml.transform.stream.StreamResult
所有已实现的接口：
Result
public class StreamResult
extends Object
implements Result

充当转换结果的持有者，可以为 XML、纯文本、HTML 或某些其他格式的标记。

字段摘要
static String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
从接口 javax.xml.transform.Result 继承的字段
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
构造方法摘要
StreamResult()
零参数的默认构造方法。
StreamResult(File f)
从 File 构造 StreamResult。
StreamResult(OutputStream outputStream)
从字节流构造 StreamResult。
StreamResult(String systemId)
从 URL 构造 StreamResult。
StreamResult(Writer writer)
从字符流构造 StreamResult。
方法摘要
OutputStream | getOutputStream() 获取通过 setOutputStream 设置的字节流。
String | getSystemId() 获取通过 setSystemId 设置的系统标识符。
Writer | getWriter() 获取通过 setWriter 设置的字符流。
void | setOutputStream(OutputStream outputStream) 设置要写入的 ByteStream。
void | setSystemId(File f) 设置来自 File 引用的系统 ID。
void | setSystemId(String systemId) 设置可以与字节流或字符流关联使用的 systemID，如果未设置，则使用此值作为 writeable URI（可能是文件名）。
void | setWriter(Writer writer) 设置要接收结果的 writer。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

另请参见：
常量字段值
构造方法详细信息

StreamResult

public StreamResult()
零参数的默认构造方法。

StreamResult

public StreamResult(OutputStream outputStream)
从字节流构造 StreamResult。通常，应使用流而不是 reader，以便转换器可以使用转换指令中包含的指令来控制编码。

参数：
outputStream - 有效的 OutputStream 引用。

StreamResult

public StreamResult(Writer writer)
从字符流构造 StreamResult。通常，应使用流而不是 reader，以便转换器可以使用转换指令中包含的指令来控制编码。但是，有时写入字符流是很有用的，例如当使用 StringWriter 时。

参数：
writer - 有效的 Writer 引用。

StreamResult

public StreamResult(String systemId)
从 URL 构造 StreamResult。

参数：
systemId - 必须为遵守 URI 语法的 String。

StreamResult

public StreamResult(File f)
从 File 构造 StreamResult。

参数：
f - 必须为非 null File 引用。
方法详细信息

setOutputStream

public void setOutputStream(OutputStream outputStream)
设置要写入的 ByteStream。通常，应使用流而不是 reader，以便转换器可以使用转换指令中包含的指令来控制编码。

参数：
outputStream - 有效的 OutputStream 引用。

getOutputStream

public OutputStream getOutputStream()
获取通过 setOutputStream 设置的字节流。

返回：
通过 setOutputStream 设置的字节流，如果未调用 setOutputStream 或 ByteStream 构造方法，则返回 null。

setWriter

public void setWriter(Writer writer)
设置要接收结果的 writer。通常，应使用流而不是 writer，以便转换器可以使用转换指令中包含的指令来控制编码。但是，有时写入 writer 是很有用的，例如当使用 StringWriter 时。

参数：
writer - 有效的 Writer 引用。

getWriter

public Writer getWriter()
获取通过 setWriter 设置的字符流。

返回：
通过 setWriter 设置的字符流，如果未调用 setWriter 或 Writer 构造方法，则返回 null。

setSystemId

public void setSystemId(String systemId)
设置可以与字节流或字符流关联使用的 systemID，如果未设置，则使用此值作为 writeable URI（可能是文件名）。

指定者：
接口 Result 中的 setSystemId
参数：
systemId - URI 字符串形式的系统标识符。

setSystemId

public void setSystemId(File f)

设置来自 File 引用的系统 ID。

参数：
f - 必须为非 null File 引用。

getSystemId

public String getSystemId()
获取通过 setSystemId 设置的系统标识符。

指定者：
接口 Result 中的 getSystemId
返回：
通过 setSystemId 设置的系统标识符，如果未调用 setSystemId，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


StreamSource (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.transform.stream
类 StreamSource

java.lang.Object
    继承者  javax.xml.transform.stream.StreamSource
所有已实现的接口：
Source
public class StreamSource
extends Object
implements Source

以 XML 标记流的形式充当转换 Source 的持有者。

注： 由于内部使用了 Reader 或 InputStream 实例的缘故，StreamSource 实例只能使用一次。

字段摘要
static String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source。
构造方法摘要
StreamSource()
零参数的默认构造方法。
StreamSource(File f)
从 File 构造 StreamSource。
StreamSource(InputStream inputStream)
从字节流构造 StreamSource。
StreamSource(InputStream inputStream, String systemId)
从字节流构造 StreamSource。
StreamSource(Reader reader)
从字符 reader 构造 StreamSource。
StreamSource(Reader reader, String systemId)
从字符 reader 构造 StreamSource。
StreamSource(String systemId)
从 URL 构造 StreamSource。
方法摘要
InputStream | getInputStream() 获取通过 setByteStream 设置的字节流。
String | getPublicId() 获取通过 setPublicId 设置的公共标识符。
Reader | getReader() 获取通过 setReader 设置的字符流。
String | getSystemId() 获取通过 setSystemId 设置的系统标识符。
void | setInputStream(InputStream inputStream) 设置要用作输入的字节流。
void | setPublicId(String publicId) 设置此 Source 的公共标识符。
void | setReader(Reader reader) 调用要作为字符 reader 的输入。
void | setSystemId(File f) 设置来自 File 引用的系统 ID。
void | setSystemId(String systemId) 设置此 Source 的系统标识符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FEATURE

public static final String FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source。

另请参见：
常量字段值
构造方法详细信息

StreamSource

public StreamSource()

零参数的默认构造方法。如果使用了此构造方法，且未使用 setInputStream(java.io.InputStream inputStream) 或 setReader(java.io.Reader reader) 设置 Stream 源，则 Transformer 将使用 new InputStream() 创建空的源 InputStream。

另请参见：
Transformer.transform(Source xmlSource, Result outputTarget)

StreamSource

public StreamSource(InputStream inputStream)
从字节流构造 StreamSource。通常，应使用流而不是 reader，以便 XML 解析器可以解析 XML 声明所指定的字符编码。

如果此构造方法用于处理 stylesheet，通常还应调用 setSystemId，以便可以解析相对 URI 引用。

参数：
inputStream - 对 XML 流的有效 InputStream 引用。

StreamSource

public StreamSource(InputStream inputStream,
                    String systemId)
从字节流构造 StreamSource。通常，应使用流而不是 reader，以便 XML 解析器可以解析 XML 声明所指定的字符编码。

此构造方法除允许设置输入流外，还允许设置 systemID，从而允许处理相对 URI。

参数：
inputStream - 对 XML 流的有效 InputStream 引用。
systemId - 必须为遵守 URI 语法的 String。

StreamSource

public StreamSource(Reader reader)
从字符 reader 构造 StreamSource。通常，应使用流而不是 reader，以便 XML 解析器可以解析 XML 声明所指定的字符编码。但是，许多情况下输入流编码已得到解析，例如从 StringReader 读取 XML 的情况。

参数：
reader - 对 XML 字符流的有效 Reader 引用。

StreamSource

public StreamSource(Reader reader,
                    String systemId)
从字符 reader 构造 StreamSource。通常，应使用流而不是 reader，以便 XML 解析器可以解析 XML 声明所指定的字符编码。但是，许多情况下输入流编码已得到解析，例如从 StringReader 读取 XML 的情况。

参数：
reader - 对 XML 字符流的有效 Reader 引用。
systemId - 必须为遵守 URI 语法的 String。

StreamSource

public StreamSource(String systemId)
从 URL 构造 StreamSource。

参数：
systemId - 必须为遵守 URI 语法的 String。

StreamSource

public StreamSource(File f)
从 File 构造 StreamSource。

参数：
f - 必须为非 null File 引用。
方法详细信息

setInputStream

public void setInputStream(InputStream inputStream)
设置要用作输入的字节流。通常，应使用流而不是 reader，以便 XML 解析器可以解析 XML 声明所指定的字符编码。

如果此 Source 对象用于处理 stylesheet，通常还应调用 setSystemId，以便可以解析相对 URL 引用。

参数：
inputStream - 对 XML 流的有效 InputStream 引用。

getInputStream

public InputStream getInputStream()
获取通过 setByteStream 设置的字节流。

返回：
通过 setByteStream 设置的字节流，如果未调用 setByteStream 或 ByteStream 构造方法，则返回 null。

setReader

public void setReader(Reader reader)
调用要作为字符 reader 的输入。通常，应使用流而不是 reader，以便 XML 解析器可以解析 XML 声明所指定的字符编码。但是，许多情况下输入流编码已得到解析，例如从 StringReader 读取 XML 的情况。

参数：
reader - 对 XML CharacterStream 的有效 Reader 引用。

getReader

public Reader getReader()
获取通过 setReader 设置的字符流。

返回：
通过 setReader 设置字符流，如果未调用 setReader 或 Reader 构造方法，则返回 null。

setPublicId

public void setPublicId(String publicId)
设置此 Source 的公共标识符。

公共标识符总是可选的：如果应用程序 writer 包含一个公共标识符，则它将作为本地信息的一部分来提供。

参数：
publicId - 字符串形式的公共标识符。

getPublicId

public String getPublicId()
获取通过 setPublicId 设置的公共标识符。

返回：
通过 setPublicId 设置的公共标识符，如果未调用 setPublicId，则返回 null。

setSystemId

public void setSystemId(String systemId)
设置此 Source 的系统标识符。

如果有字节流或字符流，则系统标识符是可选的，但提供系统标识符仍然很有用，因为应用程序可以用它来解析相对 URI，并可以将它包括在错误消息和警告中（仅当未指定字节流或字符流时，解析器才尝试打开到 URI 的连接）。

指定者：
接口 Source 中的 setSystemId
参数：
systemId - URL 字符串形式的系统标识符。

getSystemId

public String getSystemId()
获取通过 setSystemId 设置的系统标识符。

指定者：
接口 Source 中的 getSystemId
返回：
通过 setSystemId 设置的系统标识符，如果未调用 setSystemId，则返回 null。

setSystemId

public void setSystemId(File f)
设置来自 File 引用的系统 ID。

参数：
f - 必须为非 null File 引用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.transform.stream (Java Platform SE 6)

 javax.xml.transform.stream
类
StreamResult
StreamSource


javax.xml.transform.stream (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.transform.stream

此包实现特定于流和 URI 的转换 API。

请参见：
描述

类摘要
StreamResult | 充当转换结果的持有者，可以为 XML、纯文本、HTML 或某些其他格式的标记。
StreamSource | 以 XML 标记流的形式充当转换 Source 的持有者。

软件包 javax.xml.transform.stream 的描述

此包实现特定于流和 URI 的转换 API。

StreamSource 类提供了以字符串形式指定 InputStream 输入、Reader 输入和 URL 输入的方法。虽然已将输入流或 reader 指定为源，但仍应调用 StreamSource.setSystemId(java.lang.String)，以便转换器可以知道从何处解析相对 URI。公共标识符总是可选的：如果应用程序 writer 包含一个公共标识符，则它将作为 SourceLocator 信息的一部分来提供。

StreamResult 类提供了以转换结果输出形式指定 OutputStream、Writer 或输出系统 ID 的方法。

通常，对于 Source 和 Result，应使用流而不是 reader 或 writer，因为 reader 和 writer 已经建立了在内部 Unicode 格式之间的编码。但是，有时写入字符流是很有用的，例如当使用 StringWriter 来写入 String 时，或从 StringReader 读取源 XML 时。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.transform.stream 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform.stream 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.transform.stream.StreamResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stream.StreamSource (implements javax.xml.transform.Source)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.transform.stream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.transform.stream
的使用

没有 javax.xml.transform.stream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.stream.StreamResult 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.stream.StreamResult
的使用

没有 javax.xml.transform.stream.StreamResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.stream.StreamSource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.stream.StreamSource
的使用

没有 javax.xml.transform.stream.StreamSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.ErrorListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.ErrorListener
的使用

使用 ErrorListener 的软件包
javax.xml.transform 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform 中 ErrorListener 的使用

返回 ErrorListener 的 javax.xml.transform 中的方法
abstract ErrorListener | Transformer.getErrorListener() 获取转换的实际错误事件处理程序。
abstract ErrorListener | TransformerFactory.getErrorListener() 获取 TransformerFactory 的错误事件处理程序。

参数类型为 ErrorListener 的 javax.xml.transform 中的方法
abstract void | Transformer.setErrorListener(ErrorListener listener) 设置转换的实际错误事件侦听器。
abstract void | TransformerFactory.setErrorListener(ErrorListener listener) 设置此 TransformerFactory 的错误事件侦听器，它将用于转换指令的处理，而不用于转换本身。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.OutputKeys 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.OutputKeys
的使用

没有 javax.xml.transform.OutputKeys 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.Result 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.Result
的使用

使用 Result 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。

java.sql 中 Result 的使用

类型参数类型为 Result 的 java.sql 中的方法
<T extends Result>
T
SQLXML.setResult(Class<T> resultClass)
返回设置此 SQLXML 实例指定的 XML 值的 Result。

javax.xml.bind 中 Result 的使用

返回 Result 的 javax.xml.bind 中的方法
abstract  Result SchemaOutputResolver.createOutput(String namespaceUri, String suggestedFileName)
确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。

参数类型为 Result 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, Result result)
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。

javax.xml.bind.annotation 中 Result 的使用

类型参数类型为 Result 的 javax.xml.bind.annotation 中的类
 interface DomHandler<ElementT,ResultT extends Result>
在元素（及其子代）与 DOM（或类似对象）表示形式之间相互转换。

javax.xml.bind.util 中 Result 的使用

实现 Result 的 javax.xml.bind.util 中的类
 class JAXBResult
解组 JAXB 对象的 JAXP Result 实现。

javax.xml.soap 中 Result 的使用

实现 Result 的 javax.xml.soap 中的类
 class SAAJResult
以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。

javax.xml.stream 中 Result 的使用

参数类型为 Result 的 javax.xml.stream 中的方法
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLEventWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLStreamWriter。

javax.xml.transform 中 Result 的使用

参数类型为 Result 的 javax.xml.transform 中的方法
abstract  void Transformer.transform(Source xmlSource, Result outputTarget)
将 XML Source 转换为 Result。

javax.xml.transform.dom 中 Result 的使用

实现 Result 的 javax.xml.transform.dom 中的类
 class DOMResult
以 Document Object Model（DOM）树的形式充当转换结果树的持有者。

javax.xml.transform.sax 中 Result 的使用

实现 Result 的 javax.xml.transform.sax 中的类
 class SAXResult
充当转换 Result 的持有者。

参数类型为 Result 的 javax.xml.transform.sax 中的方法
 void TransformerHandler.setResult(Result result)
设置与用于转换的此 TransformerHandler 关联的 Result。

javax.xml.transform.stax 中 Result 的使用

实现 Result 的 javax.xml.transform.stax 中的类
 class StAXResult
以 StAX writer 的形式（即 XMLStreamWriter 或 XMLEventWriter）充当 XML Result 的持有者。

javax.xml.transform.stream 中 Result 的使用

实现 Result 的 javax.xml.transform.stream 中的类
 class StreamResult
充当转换结果的持有者，可以为 XML、纯文本、HTML 或某些其他格式的标记。

javax.xml.validation 中 Result 的使用

参数类型为 Result 的 javax.xml.validation 中的方法
abstract  void Validator.validate(Source source, Result result)
验证指定输入并将扩充的验证结果发送到指定输出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.Source 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.Source
的使用

使用 Source 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.sql 中 Source 的使用

类型参数类型为 Source 的 java.sql 中的方法
<T extends Source>
T
SQLXML.getSource(Class<T> sourceClass)
返回读取此 SQLXML 实例指定的 XML 值的 Source。

javax.xml.bind 中 Source 的使用

参数类型为 Source 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(Source source)
从指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。

javax.xml.bind.annotation 中 Source 的使用

返回 Source 的 javax.xml.bind.annotation 中的方法
Source | DomHandler.marshal(ElementT n, ValidationEventHandler errorHandler) 在 JAXB 提供者需要将元素编组为 XML 时调用此方法。
Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

javax.xml.bind.helpers 中 Source 的使用

参数类型为 Source 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(Source source)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)

javax.xml.bind.util 中 Source 的使用

实现 Source 的 javax.xml.bind.util 中的类
 class JAXBSource
编组 JAXB 生成的对象的 JAXP Source 实现。

javax.xml.soap 中 Source 的使用

返回 Source 的 javax.xml.soap 中的方法
abstract  Source SOAPPart.getContent()
以 JAXP Source 对象的形式返回 SOAPEnvelope 的内容。

参数类型为 Source 的 javax.xml.soap 中的方法
abstract  void SOAPPart.setContent(Source source)
使用取自给定 Source 对象的数据设置 SOAPEnvelope 对象的内容。

javax.xml.stream 中 Source 的使用

参数类型为 Source 的 javax.xml.stream 中的方法
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(Source source) 根据 JAXP 源创建一个新 XMLEventReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(Source source) 根据 JAXP 源创建一个新 XMLStreamReader。

javax.xml.transform 中 Source 的使用

返回 Source 的 javax.xml.transform 中的方法
abstract  Source TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
 Source URIResolver.resolve(String href, String base)
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。

参数类型为 Source 的 javax.xml.transform 中的方法
abstract Source | TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset) 通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
abstract Templates | TransformerFactory.newTemplates(Source source) 将 Source 处理为 Templates 对象，后者是源的编译后表示形式。
abstract Transformer | TransformerFactory.newTransformer(Source source) 将 Source 处理为 Transformer Object。
abstract void | Transformer.transform(Source xmlSource, Result outputTarget) 将 XML Source 转换为 Result。

javax.xml.transform.dom 中 Source 的使用

实现 Source 的 javax.xml.transform.dom 中的类
 class DOMSource
以 Document Object Model（DOM）树的形式充当转换 Source 树的持有者。

javax.xml.transform.sax 中 Source 的使用

实现 Source 的 javax.xml.transform.sax 中的类
 class SAXSource
充当 SAX 样式 Source 的持有者。

参数类型为 Source 的 javax.xml.transform.sax 中的方法
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Source src) 基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Source src) 创建使用给定 Source 作为转换指令的 XMLFilter。
static InputSource | SAXSource.sourceToInputSource(Source source) 尝试从 Source 对象获取 SAX InputSource 对象。

javax.xml.transform.stax 中 Source 的使用

实现 Source 的 javax.xml.transform.stax 中的类
 class StAXSource
以 StAX reader 的形式（即 XMLStreamReader 或 XMLEventReader）充当 XML Source 的持有者。

javax.xml.transform.stream 中 Source 的使用

实现 Source 的 javax.xml.transform.stream 中的类
 class StreamSource
以 XML 标记流的形式充当转换 Source 的持有者。

javax.xml.validation 中 Source 的使用

参数类型为 Source 的 javax.xml.validation 中的方法
Schema | SchemaFactory.newSchema(Source schema) 解析作为模式的指定源并以模式形式返回它。
abstract Schema | SchemaFactory.newSchema(Source[] schemas) 解析作为模式的指定源（或多个源），并以模式形式返回它。
void | Validator.validate(Source source) 验证指定的输入。
abstract void | Validator.validate(Source source, Result result) 验证指定输入并将扩充的验证结果发送到指定输出。

javax.xml.ws 中 Source 的使用

返回 Source 的 javax.xml.ws 中的方法
 Source LogicalMessage.getPayload()
以 XML 源的形式获取消息负载，可以在相同的 LogicalMessage 实例上多次调用，总是返回可以用来检索整个消息负载的新的 Source。

返回变量类型为 Source 的类型的 javax.xml.ws 中的方法
abstract  List<Source> Endpoint.getMetadata()
返回服务的元数据文档列表。

参数类型为 Source 的 javax.xml.ws 中的方法
 void LogicalMessage.setPayload(Source payload)
设置消息负载

类型变量类型为 Source 的 javax.xml.ws 中的方法参数
abstract  void Endpoint.setMetadata(List<Source> metadata)
设置此端点的元数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.SourceLocator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.SourceLocator
的使用

使用 SourceLocator 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。

javax.xml.transform 中 SourceLocator 的使用

返回 SourceLocator 的 javax.xml.transform 中的方法
 SourceLocator TransformerException.getLocator()
getLocator 方法检索 SourceLocator 对象的实例，此对象指定了错误发生的位置。

参数类型为 SourceLocator 的 javax.xml.transform 中的方法
 void TransformerException.setLocator(SourceLocator location)
setLocator 方法设置 SourceLocator 对象的实例，此对象指定了错误发生的位置。

参数类型为 SourceLocator 的 javax.xml.transform 中的构造方法
TransformerConfigurationException(String message, SourceLocator locator)
从消息和 Locator 创建新 TransformerConfigurationException。
TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
包装了 TransformerConfigurationException 中的现有异常。
TransformerException(String message, SourceLocator locator)
从消息和 Locator 创建一个新 TransformerException。
TransformerException(String message, SourceLocator locator, Throwable e)
包装了 TransformerException 中的现有异常。

javax.xml.transform.dom 中 SourceLocator 的使用

javax.xml.transform.dom 中 SourceLocator 的子接口
 interface DOMLocator
指示源 DOM 中节点的位置，主要用于错误报告。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.Templates 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.Templates
的使用

使用 Templates 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.transform 中 Templates 的使用

返回 Templates 的 javax.xml.transform 中的方法
abstract  Templates TransformerFactory.newTemplates(Source source)
将 Source 处理为 Templates 对象，后者是源的编译后表示形式。

javax.xml.transform.sax 中 Templates 的使用

返回 Templates 的 javax.xml.transform.sax 中的方法
 Templates TemplatesHandler.getTemplates()
当 TemplatesHandler 对象用作 ContentHandler（用于转换指令的解析）时，它创建 Templates 对象，调用者可以在 SAX 事件已完成后获取该对象。

参数类型为 Templates 的 javax.xml.transform.sax 中的方法
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Templates templates) 基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Templates templates) 基于 Templates 参数，创建 XMLFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.Transformer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.Transformer
的使用

使用 Transformer 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.transform 中 Transformer 的使用

返回 Transformer 的 javax.xml.transform 中的方法
Transformer | Templates.newTransformer() 创建此 Templates 对象的新转换上下文。
abstract Transformer | TransformerFactory.newTransformer() 创建执行从 Source 到 Result 的复制的新 Transformer。
abstract Transformer | TransformerFactory.newTransformer(Source source) 将 Source 处理为 Transformer Object。

javax.xml.transform.sax 中 Transformer 的使用

返回 Transformer 的 javax.xml.transform.sax 中的方法
 Transformer TransformerHandler.getTransformer()
获取与此处理程序关联的 Transformer，用于设置参数和输出属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.TransformerConfigurationException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.TransformerConfigurationException
的使用

使用 TransformerConfigurationException 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.transform 中 TransformerConfigurationException 的使用

抛出 TransformerConfigurationException 的 javax.xml.transform 中的方法
abstract Source | TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset) 通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
abstract Templates | TransformerFactory.newTemplates(Source source) 将 Source 处理为 Templates 对象，后者是源的编译后表示形式。
Transformer | Templates.newTransformer() 创建此 Templates 对象的新转换上下文。
abstract Transformer | TransformerFactory.newTransformer() 创建执行从 Source 到 Result 的复制的新 Transformer。
abstract Transformer | TransformerFactory.newTransformer(Source source) 将 Source 处理为 Transformer Object。
abstract void | TransformerFactory.setFeature(String name, boolean value) 设置通过此工厂创建的此 TransformerFactory 和 Transformer 或 Template 的功能。

javax.xml.transform.sax 中 TransformerConfigurationException 的使用

抛出 TransformerConfigurationException 的 javax.xml.transform.sax 中的方法
abstract TemplatesHandler | SAXTransformerFactory.newTemplatesHandler() 获取能够将 SAX ContentHandler 事件处理为 Templates 对象的 TemplatesHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler() 获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Source src) 基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract TransformerHandler | SAXTransformerFactory.newTransformerHandler(Templates templates) 基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Source src) 创建使用给定 Source 作为转换指令的 XMLFilter。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Templates templates) 基于 Templates 参数，创建 XMLFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.TransformerException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.TransformerException
的使用

使用 TransformerException 的软件包
javax.xml.transform 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform 中 TransformerException 的使用

javax.xml.transform 中 TransformerException 的子类
 class TransformerConfigurationException
指示严重的配置错误。

参数类型为 TransformerException 的 javax.xml.transform 中的方法
void | ErrorListener.error(TransformerException exception) 接收可恢复错误的通知。
void | ErrorListener.fatalError(TransformerException exception) 接收不可恢复错误的通知。
void | ErrorListener.warning(TransformerException exception) 接收警告通知。

抛出 TransformerException 的 javax.xml.transform 中的方法
 void ErrorListener.error(TransformerException exception)
接收可恢复错误的通知。
 void ErrorListener.fatalError(TransformerException exception)
接收不可恢复错误的通知。
 Source URIResolver.resolve(String href, String base)
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。
abstract  void Transformer.transform(Source xmlSource, Result outputTarget)
将 XML Source 转换为 Result。
 void ErrorListener.warning(TransformerException exception)
接收警告通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.TransformerFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.TransformerFactory
的使用

使用 TransformerFactory 的软件包
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

javax.xml.transform 中 TransformerFactory 的使用

返回 TransformerFactory 的 javax.xml.transform 中的方法
static TransformerFactory | TransformerFactory.newInstance() 获取 TransformerFactory 的新实例。
static TransformerFactory | TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader) 根据类名称获得一个新 TransformerFactory 实例。

javax.xml.transform.sax 中 TransformerFactory 的使用

javax.xml.transform.sax 中 TransformerFactory 的子类
 class SAXTransformerFactory
此类扩展了 TransformerFactory 以提供特定于 SAX 的工厂方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.transform.TransformerFactoryConfigurationError 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.transform.TransformerFactoryConfigurationError
的使用

使用 TransformerFactoryConfigurationError 的软件包
javax.xml.transform 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform 中 TransformerFactoryConfigurationError 的使用

抛出 TransformerFactoryConfigurationError 的 javax.xml.transform 中的方法
static TransformerFactory | TransformerFactory.newInstance() 获取 TransformerFactory 的新实例。
static TransformerFactory | TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader) 根据类名称获得一个新 TransformerFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.transform.URIResolver 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.transform.URIResolver
的使用

使用 URIResolver 的软件包
javax.xml.transform 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform 中 URIResolver 的使用

返回 URIResolver 的 javax.xml.transform 中的方法
abstract  URIResolver Transformer.getURIResolver()
获取将用于解析在 document() 中使用的 URI 的对象。
abstract  URIResolver TransformerFactory.getURIResolver()
获取在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。

参数类型为 URIResolver 的 javax.xml.transform 中的方法
abstract  void Transformer.setURIResolver(URIResolver resolver)
设置将用于解析在 document() 中使用的 URI 的对象。
abstract  void TransformerFactory.setURIResolver(URIResolver resolver)
设置在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AlgorithmMethod (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
接口 AlgorithmMethod

所有已知子接口：
CanonicalizationMethod, DigestMethod, SignatureMethod, Transform
所有已知实现类：
TransformService
public interface AlgorithmMethod

XML Security 规范中定义的算法的抽象表示。子类表示特定类型的 XML 安全算法，例如 Transform。

从以下版本开始：
1.6

方法摘要
String | getAlgorithm() 返回此 AlgorithmMethod 的算法 URI。
AlgorithmParameterSpec | getParameterSpec() 返回此 AlgorithmMethod 的算法参数。

方法详细信息

getAlgorithm

String getAlgorithm()
返回此 AlgorithmMethod 的算法 URI。

返回：
此 AlgorithmMethod 的算法 URI

getParameterSpec

AlgorithmParameterSpec getParameterSpec()
返回此 AlgorithmMethod 的算法参数。

返回：
此 AlgorithmMethod 的算法参数。如果此 AlgorithmMethod 不需要参数且未指定参数，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Data (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
接口 Data

所有已知子接口：
NodeSetData
所有已知实现类：
OctetStreamData
public interface Data

取消引用 URIReference 或后续 Transform 的输入/输出所得结果的抽象表示。此接口的主要用途是对所有 Data 子类型进行分组并提供类型安全。

从以下版本开始：
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeySelector (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
类 KeySelector

java.lang.Object
    继承者  javax.xml.crypto.KeySelector

public abstract class KeySelector
extends Object

一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。此类实现的一个示例是：搜索与 KeyInfo 中所含信息相匹配的受信任密钥的 KeyStore。

返回的密钥是否受信任，以及用来确定的机制是特定于实现的。

从以下版本开始：
1.6

嵌套类摘要
static class KeySelector.Purpose
将被选中的密钥的用途。
构造方法摘要
protected KeySelector()
默认的不带参数的构造方法；仅由子类调用。
方法摘要
abstract KeySelectorResult | select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context) 尝试查找满足指定约束的密钥。
static KeySelector | singletonKeySelector(Key key) 返回一个总是选择指定密钥的 KeySelector，不管传递给它的 KeyInfo 是什么。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeySelector

protected KeySelector()
默认的不带参数的构造方法；仅由子类调用。

方法详细信息

select

public abstract KeySelectorResult select(KeyInfo keyInfo,
                                         KeySelector.Purpose purpose,
                                         AlgorithmMethod method,
                                         XMLCryptoContext context)
                                  throws KeySelectorException
尝试查找满足指定约束的密钥。

参数：
keyInfo - 一个 KeyInfo（可以为 null）
purpose - 密钥的用途（KeySelector.Purpose.SIGN、KeySelector.Purpose.VERIFY、KeySelector.Purpose.ENCRYPT 或 KeySelector.Purpose.DECRYPT）
method - 使用此密钥的算法方法。应该只返回与算法兼容且满足指定算法的约束条件的密钥。
context - 可能包含对查找某一适当密钥有用的信息的 XMLCryptoContext。如果此密钥选择器支持解析 RetrievalMethod 类型，则选择器应该使用上下文的 baseURI 和 dereferencer 参数（如果指定）来解析 URI，并取消对 URI 的引用。
返回：
密钥选择器的结果
抛出：
KeySelectorException - 如果试图查找某个密钥时发生异常条件。注意，无法查找密钥不被视为异常（在这种情况下，应该返回 null）。但是，阻止 KeySelector 查找某个可能密钥的错误条件（例如：网络通讯失败）应被视为异常。
ClassCastException - 如果 method 的数据类型不受此密钥选择器支持。

singletonKeySelector

public static KeySelector singletonKeySelector(Key key)
返回一个总是选择指定密钥的 KeySelector，不管传递给它的 KeyInfo 是什么。

参数：
key - 将存储到密钥选择器中的单独密钥
返回：
总是选择指定密钥的密钥选择器
抛出：
NullPointerException - 如果 key 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeySelector.Purpose (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
类 KeySelector.Purpose

java.lang.Object
    继承者  javax.xml.crypto.KeySelector.Purpose
正在封闭类：
KeySelector
public static class KeySelector.Purpose
extends Object

将被选中的密钥的用途。

字段摘要
static KeySelector.Purpose | DECRYPT 用于解密的密钥。
static KeySelector.Purpose | ENCRYPT 用于加密的密钥。
static KeySelector.Purpose | SIGN 用于签名的密钥。
static KeySelector.Purpose | VERIFY 用于验证的密钥。
方法摘要
 String toString()
返回此用途的字符串表示形式（“sign”、“verify”、“encrypt”或“decrypt”）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SIGN

public static final KeySelector.Purpose SIGN
用于签名的密钥。

VERIFY

public static final KeySelector.Purpose VERIFY
用于验证的密钥。

ENCRYPT

public static final KeySelector.Purpose ENCRYPT
用于加密的密钥。

DECRYPT

public static final KeySelector.Purpose DECRYPT
用于解密的密钥。

方法详细信息

toString

public String toString()
返回此用途的字符串表示形式（“sign”、“verify”、“encrypt”或“decrypt”）。

覆盖：
类 Object 中的 toString
返回：
此用途的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeySelectorException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
类 KeySelectorException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.crypto.KeySelectorException
所有已实现的接口：
Serializable
public class KeySelectorException
extends Exception

指示由 KeySelector 抛出的异常条件。

KeySelectorException 可以包含一个 cause：即另一个导致抛出此 KeySelectorException 的 throwable。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
KeySelectorException()
构造用 null 作为其详细消息的新 KeySelectorException。
KeySelectorException(String message)
构造带指定详细信息的新 KeySelectorException。
KeySelectorException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 KeySelectorException。
KeySelectorException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 KeySelectorException（它通常包含 cause 的类和详细消息）。
方法摘要
Throwable | getCause() 返回此 KeySelectorException 的 cause，如果 cause 不存在或未知，则返回 null。
void | printStackTrace() 将此 KeySelectorException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
void | printStackTrace(PrintStream s) 将此 KeySelectorException、它的追踪和 cause 追踪打印到指定的打印流。
void | printStackTrace(PrintWriter s) 将此 KeySelectorException、它的追踪和 cause 追踪打印到指定打印编写器。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

KeySelectorException

public KeySelectorException()
构造用 null 作为其详细消息的新 KeySelectorException。

KeySelectorException

public KeySelectorException(String message)
构造带指定详细信息的新 KeySelectorException。

参数：
message - 详细消息

KeySelectorException

public KeySelectorException(String message,
                            Throwable cause)
构造带指定详细消息和 cause 的新 KeySelectorException。

注意，与 cause 相关的详细消息不是自动合并到此异常的详细消息中的。

参数：
message - 详细消息
cause - cause（允许为 null 值，指示 cause 不存在或未知。）

KeySelectorException

public KeySelectorException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 KeySelectorException（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（允许为 null 值，指示 cause 不存在或未知。）
方法详细信息

getCause

public Throwable getCause()
返回此 KeySelectorException 的 cause，如果 cause 不存在或未知，则返回 null。（cause 是导致抛出此 KeySelectorException 的 throwable。）

覆盖：
类 Throwable 中的 getCause
返回：
此 KeySelectorException 的 cause，如果 cause 不存在或未知，则返回 null。

printStackTrace

public void printStackTrace()
将此 KeySelectorException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintStream s)
将此 KeySelectorException、它的追踪和 cause 追踪打印到指定的打印流。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace(PrintWriter s)
将此 KeySelectorException、它的追踪和 cause 追踪打印到指定打印编写器。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintWriter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeySelectorResult (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
接口 KeySelectorResult

public interface KeySelectorResult

由 KeySelector.select 方法返回的结果。

KeySelectorResult 至少包含由 KeySelector 选择的 Key。此接口的实现可以添加一些方法来返回特定于实现或算法的信息，比如证书链信息或调试信息。

从以下版本开始：
1.6
另请参见：
KeySelector

方法摘要
 Key getKey()
返回选定的密钥。

方法详细信息

getKey

Key getKey()
返回选定的密钥。

返回：
已选定的密钥；如果不存在这样的密钥，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MarshalException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
类 MarshalException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.crypto.MarshalException
所有已实现的接口：
Serializable
public class MarshalException
extends Exception

指示 XML 编组或解组过程中发生的异常条件。

MarshalException 可以包含一个 cause：另一个导致抛出此 MarshalException 的 throwable。

从以下版本开始：
1.6
另请参见：
XMLSignature.sign(XMLSignContext), XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext), 序列化表格

构造方法摘要
MarshalException()
构造使用 null 作为其详细消息的新 MarshalException。
MarshalException(String message)
构造带指定详细消息的新 MarshalException。
MarshalException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 MarshalException。
MarshalException(Throwable cause)
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的 MarshalException（它通常包含 cause 的类和详细消息）。
方法摘要
Throwable | getCause() 返回此 MarshalException 的 cause；如果 cause 不存在或未知，则返回 null。
void | printStackTrace() 将此 MarshalException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
void | printStackTrace(PrintStream s) 将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印流。
void | printStackTrace(PrintWriter s) 将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印编写器。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MarshalException

public MarshalException()
构造使用 null 作为其详细消息的新 MarshalException。

MarshalException

public MarshalException(String message)
构造带指定详细消息的新 MarshalException。

参数：
message - 详细消息

MarshalException

public MarshalException(String message,
                        Throwable cause)
构造一个带指定详细消息和 cause 的新 MarshalException。

注意，与 cause 相关的详细消息不是自动合并到此异常的详细消息中的。

参数：
message - 详细消息
cause - cause（允许为 null 值，指示 cause 不存在或未知。）

MarshalException

public MarshalException(Throwable cause)
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的 MarshalException（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（允许为 null 值，指示 cause 不存在或未知。）
方法详细信息

getCause

public Throwable getCause()
返回此 MarshalException 的 cause；如果 cause 不存在或未知，则返回 null。（cause 是导致抛出此 MarshalException 的 throwable。）

覆盖：
类 Throwable 中的 getCause
返回：
此 MarshalException 的 cause；如果 cause 不存在或未知，则返回 null。

printStackTrace

public void printStackTrace()
将此 MarshalException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintStream s)
将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印流。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace(PrintWriter s)
将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印编写器。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintWriter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NodeSetData (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
接口 NodeSetData

所有超级接口：
Data
public interface NodeSetData
extends Data

包含节点集的 Data 类型的抽象表示。节点集中节点的类型（类）和顺序不是由此类定义的；而行为应由 NodeSetData 子类定义。

从以下版本开始：
1.6

方法摘要
 Iterator iterator()
返回可按照文档顺序在此 NodeSetData 中包含的节点上进行迭代的只读迭代器。

方法详细信息

iterator

Iterator iterator()
返回可按照文档顺序在此 NodeSetData 中包含的节点上进行迭代的只读迭代器。试图通过 remove 方法修改返回的迭代器将导致抛出 UnsupportedOperationException。

返回：
按文档顺序在此 NodeSetData 中的节点上进行迭代的 Iterator
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchMechanismException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
类 NoSuchMechanismException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.xml.crypto.NoSuchMechanismException
所有已实现的接口：
Serializable
public class NoSuchMechanismException
extends RuntimeException

当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。

NoSuchMechanismException 可以包含一个 cause：另一个导致抛出此 NoSuchMechanismException 的 throwable。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.getInstance, KeyInfoFactory.getInstance, 序列化表格

构造方法摘要
NoSuchMechanismException()
构造使用 null 作为其详细消息的新 NoSuchMechanismException。
NoSuchMechanismException(String message)
构造带指定详细消息的新 NoSuchMechanismException。
NoSuchMechanismException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 NoSuchMechanismException。
NoSuchMechanismException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 NoSuchMechanismException（它通常包含 cause 的类和详细消息）。
方法摘要
Throwable | getCause() 返回此 NoSuchMechanismException 的 cause，如果 cause 不存在或未知，则返回 null。
void | printStackTrace() 将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到标准错误流中。
void | printStackTrace(PrintStream s) 将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定的打印流。
void | printStackTrace(PrintWriter s) 将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定打印编写器。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchMechanismException

public NoSuchMechanismException()
构造使用 null 作为其详细消息的新 NoSuchMechanismException。

NoSuchMechanismException

public NoSuchMechanismException(String message)
构造带指定详细消息的新 NoSuchMechanismException。

参数：
message - 详细消息

NoSuchMechanismException

public NoSuchMechanismException(String message,
                                Throwable cause)
构造带指定详细消息和 cause 的新 NoSuchMechanismException。

注意，与 cause 相关的详细消息不是自动合并到此异常的详细消息中的。

参数：
message - 详细消息
cause - cause（允许为 null 值，指示 cause 不存在或未知。）

NoSuchMechanismException

public NoSuchMechanismException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 NoSuchMechanismException（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（允许为 null 值，指示 cause 不存在或未知。）
方法详细信息

getCause

public Throwable getCause()
返回此 NoSuchMechanismException 的 cause，如果 cause 不存在或未知，则返回 null。（cause 是导致抛出此 NoSuchMechanismException 的 throwable。）

覆盖：
类 Throwable 中的 getCause
返回：
导致抛出此 NoSuchMechanismException 的 cause；如果 cause 不存在或未知，则返回 null。

printStackTrace

public void printStackTrace()
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到标准错误流中。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintStream s)
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定的打印流。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace(PrintWriter s)
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定打印编写器。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintWriter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OctetStreamData (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
类 OctetStreamData

java.lang.Object
    继承者  javax.xml.crypto.OctetStreamData
所有已实现的接口：
Data
public class OctetStreamData
extends Object
implements Data

包含一个八位组流的 Data 类型的表示形式。

从以下版本开始：
1.6

构造方法摘要
OctetStreamData(InputStream octetStream)
创建新的 SocketImpl。
OctetStreamData(InputStream octetStream, String uri, String mimeType)
创建新的 OctetStreamData。
方法摘要
String | getMimeType() 返回与由此 OctetStreamData 表示的数据对象关联的 MIME 类型。
InputStream | getOctetStream() 返回此 OctetStreamData 的输入流。
String | getURI() 返回用来标识由此 OctetStreamData 表示的数据对象的 URI String。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OctetStreamData

public OctetStreamData(InputStream octetStream)
创建新的 SocketImpl。

参数：
octetStream - 包含八位组的输入流
抛出：
NullPointerException - 如果 octetStream 为 null

OctetStreamData

public OctetStreamData(InputStream octetStream,
                       String uri,
                       String mimeType)
创建新的 OctetStreamData。

参数：
octetStream - 包含八位组的输入流
uri - 标识数据对象的 URI String（可以为 null）
mimeType - 与数据对象关联的 MIME 类型（可以为 null）
抛出：
NullPointerException - 如果 octetStream 为 null
方法详细信息

getOctetStream

public InputStream getOctetStream()
返回此 OctetStreamData 的输入流。

返回：
此 OctetStreamData 的输入流。

getURI

public String getURI()
返回用来标识由此 OctetStreamData 表示的数据对象的 URI String。

返回：
URI String；如果不适用，则返回 null

getMimeType

public String getMimeType()
返回与由此 OctetStreamData 表示的数据对象关联的 MIME 类型。

返回：
MIME 类型；如果不适用，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URIDereferencer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
接口 URIDereferencer

public interface URIDereferencer

URIReference 的 dereferencer。

取消引用 URIReference 的结果是一个 OctetStreamData 实例或 NodeSetData 实例。根据 XML-Signature Syntax and Processing 的 W3C Recommendation 中第 4.2 节的定义，只要 URIReference 不是一个相同文档引用，取消引用 URIReference 都必须得到 OctetStreamData。

从以下版本开始：
1.6
另请参见：
XMLCryptoContext.setURIDereferencer(URIDereferencer), XMLCryptoContext.getURIDereferencer()

方法摘要
 Data dereference(URIReference uriReference, XMLCryptoContext context)
取消引用指定 URIReference 并返回已取消引用的数据。

方法详细信息

dereference

Data dereference(URIReference uriReference,
                 XMLCryptoContext context)
                 throws URIReferenceException
取消引用指定 URIReference 并返回已取消引用的数据。

参数：
uriReference - URIReference
context - 一个 XMLCryptoContext，可能包含用于取消引用 URI 的其他有用信息。此实现应根据上下文的 baseURI 参数（如果指定）来取消引用指定 URIReference。
返回：
已取消引用的数据
抛出：
NullPointerException - 如果 uriReference 或 context 为 null
URIReferenceException - 如果取消引用指定的 uriReference 时发生异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URIReference (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
接口 URIReference

所有已知子接口：
DOMURIReference, Reference, RetrievalMethod
public interface URIReference

通过 URI-Reference 标识数据对象，正如 RFC 2396 所指定的。

注意，一些子类可能没有 type 属性，对于这些类型的对象，getType() 方法将始终返回 null。

从以下版本开始：
1.6
另请参见：
URIDereferencer

方法摘要
String | getType() 返回通过此 URI 引用的数据类型。
String | getURI() 返回所引用数据对象的 URI。

方法详细信息

getURI

String getURI()
返回所引用数据对象的 URI。

返回：
RFC 2396 格式的数据对象的 URI（如果未指定 URI，则返回 null）

getType

String getType()
返回通过此 URI 引用的数据类型。

返回：
数据对象的类型 (URI)（如果未指定 URI，则返回 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URIReferenceException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
类 URIReferenceException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.crypto.URIReferenceException
所有已实现的接口：
Serializable
public class URIReferenceException
extends Exception

指示取消引用 URIReference 时抛出的异常条件。

URIReferenceException 可以包含一个 cause：另一个导致抛出此 URIReferenceException 的 throwable。

从以下版本开始：
1.6
另请参见：
URIDereferencer.dereference(URIReference, XMLCryptoContext), RetrievalMethod.dereference(XMLCryptoContext), 序列化表格

构造方法摘要
URIReferenceException()
构造使用 null 作为其详细消息的新 URIReferenceException。
URIReferenceException(String message)
构造带指定详细消息的新 URIReferenceException。
URIReferenceException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 URIReferenceException。
URIReferenceException(String message, Throwable cause, URIReference uriReference)
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。
URIReferenceException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 URIReferenceException（它通常包含 cause 的类和详细消息）。
方法摘要
Throwable | getCause() 返回此 URIReferenceException 的 cause，如果 cause 不存在或未知，则返回 null。
URIReference | getURIReference() 返回抛出异常时正被取消引用的 URIReference。
void | printStackTrace() 将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
void | printStackTrace(PrintStream s) 将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流。
void | printStackTrace(PrintWriter s) 将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印编写器。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

URIReferenceException

public URIReferenceException()
构造使用 null 作为其详细消息的新 URIReferenceException。

URIReferenceException

public URIReferenceException(String message)
构造带指定详细消息的新 URIReferenceException。

参数：
message - 详细消息

URIReferenceException

public URIReferenceException(String message,
                             Throwable cause)
构造带指定详细消息和 cause 的新 URIReferenceException。

注意，与 cause 相关的详细消息不是自动合并到此异常的详细消息中的。

参数：
message - 详细消息
cause - cause（允许为 null 值，指示 cause 不存在或未知。）

URIReferenceException

public URIReferenceException(String message,
                             Throwable cause,
                             URIReference uriReference)
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。

注意，与 cause 相关的详细消息不是自动合并到此异常的详细消息中的。

参数：
message - 详细消息
cause - cause（允许为 null 值，指示 cause 不存在或未知。）
uriReference - 遇到错误时正被取消引用的 URIReference
抛出：
NullPointerException - 如果 uriReference 为 null

URIReferenceException

public URIReferenceException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 URIReferenceException（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（允许为 null 值，指示 cause 不存在或未知。）
方法详细信息

getURIReference

public URIReference getURIReference()
返回抛出异常时正被取消引用的 URIReference。

返回：
抛出异常时正被取消引用的 URIReference；如果未指定 URIReference，则返回 null

getCause

public Throwable getCause()
返回此 URIReferenceException 的 cause，如果 cause 不存在或未知，则返回 null。（cause 是导致抛出此 URIReferenceException 的 throwable。）

覆盖：
类 Throwable 中的 getCause
返回：
导致抛出此 URIReferenceException 的 cause，如果 cause 不存在或未知，则返回 null。

printStackTrace

public void printStackTrace()
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintStream s)
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace(PrintWriter s)
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印编写器。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintWriter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLCryptoContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
接口 XMLCryptoContext

所有已知子接口：
XMLSignContext, XMLValidateContext
所有已知实现类：
DOMCryptoContext, DOMSignContext, DOMValidateContext
public interface XMLCryptoContext

包含用于 XML 加密操作的通用上下文信息。

此接口包含一些方法可用来设置和检索那些影响 XML 签名或 XML 加密结构处理的属性。

注意，XMLCryptoContext 实例可以包含特定于所使用的 XML 加密结构的信息和状态。如果 XMLCryptoContext 使用多个结构（例如，不应该使用相同的 XMLValidateContext 实例来验证两个不同的 XMLSignature 对象），则结果是不可预知的。

从以下版本开始：
1.6

方法摘要
Object | get(Object key) 返回此上下文将指定键映射到的值。
String | getBaseURI() 返回基本 URI。
String | getDefaultNamespacePrefix() 返回默认名称空间前缀。
KeySelector | getKeySelector() 返回用于查找某个密钥的密钥选择器。
String | getNamespacePrefix(String namespaceURI, String defaultPrefix) 返回与指定的名称空间 URI 关联的名称空间前缀。
Object | getProperty(String name) 返回指定属性的值。
URIDereferencer | getURIDereferencer() 返回用来取消引用 URIReference 的 URIDereferencer。
Object | put(Object key, Object value) 将指定值与此上下文中的指定键关联。
String | putNamespacePrefix(String namespaceURI, String prefix) 将指定的名称空间 URI 映射到指定的前缀。
void | setBaseURI(String baseURI) 设置基本 URI。
void | setDefaultNamespacePrefix(String defaultPrefix) 设置默认的名称空间前缀。
void | setKeySelector(KeySelector ks) 设置用于查找某个密钥的密钥选择器。
Object | setProperty(String name, Object value) 设置指定的属性。
void | setURIDereferencer(URIDereferencer dereferencer) 设置用来取消引用 URIReference 的 URIDereferencer。

方法详细信息

getBaseURI

String getBaseURI()
返回基本 URI。

返回：
基本 URI；如果未指定，则返回 null
另请参见：
setBaseURI(String)

setBaseURI

void setBaseURI(String baseURI)
设置基本 URI。

参数：
baseURI - 基本 URI；或者为 null，表示移除当前值
抛出：
IllegalArgumentException - 如果 baseURI 与 RFC 2396 不兼容
另请参见：
getBaseURI()

getKeySelector

KeySelector getKeySelector()
返回用于查找某个密钥的密钥选择器。

返回：
密钥选择器；如果未指定，则返回 null
另请参见：
setKeySelector(KeySelector)

setKeySelector

void setKeySelector(KeySelector ks)
设置用于查找某个密钥的密钥选择器。

参数：
ks - 密钥选择器；或者为 null，表示移除当前设置
另请参见：
getKeySelector()

getURIDereferencer

URIDereferencer getURIDereferencer()
返回用来取消引用 URIReference 的 URIDereferencer。

返回：
URIDereferencer；如果未指定，则返回 null
另请参见：
setURIDereferencer(URIDereferencer)

setURIDereferencer

void setURIDereferencer(URIDereferencer dereferencer)
设置用来取消引用 URIReference 的 URIDereferencer。使用指定的 URIDereferencer 来代替某一实现的默认 URIDereferencer。

参数：
dereferencer - URIDereferencer；或者为 null，表示移除任何当前设置
另请参见：
getURIDereferencer()

getNamespacePrefix

String getNamespacePrefix(String namespaceURI,
                          String defaultPrefix)
返回与指定的名称空间 URI 关联的名称空间前缀。如果没有将指定的名称空间 URI 绑定到某一前缀，则返回指定的默认前缀。要将名称空间 URI 绑定到某一前缀，请调用 putNamespacePrefix 方法。

参数：
namespaceURI - 名称空间 URI
defaultPrefix - 在没有将指定的名称空间 URI 绑定到某一前缀的情况下将被返回的前缀。
返回：
与指定的名称空间 URI 相关联的前缀，如果没有注册 URI，则返回 defaultPrefix。如果已注册名称空间 URI，但没有前缀，则返回一个空字符串 ("")。
抛出：
NullPointerException - 如果 namespaceURI 为 null
另请参见：
putNamespacePrefix(String, String)

putNamespacePrefix

String putNamespacePrefix(String namespaceURI,
                          String prefix)
将指定的名称空间 URI 映射到指定的前缀。如果已经存在与指定的名称空间 URI 关联的前缀，则用指定前缀替换以前使用的前缀。

参数：
namespaceURI - 名称空间 URI
prefix - 名称空间前缀（或者为 null，表示移除所有现有映射）。指定空字符串 ("") 则表示不将任何前缀绑定到名称空间 URI。
返回：
与指定的名称空间 URI 关联以前使用的前缀，如果没有任何前缀，则返回 null
抛出：
NullPointerException - 如果 namespaceURI 为 null
另请参见：
getNamespacePrefix(String, String)

getDefaultNamespacePrefix

String getDefaultNamespacePrefix()
返回默认名称空间前缀。默认的名称空间前缀是用于所有名称空间 URI 的前缀，该前缀未通过 putNamespacePrefix 方法显式设置。

返回：
默认的名称空间前缀；如果未设置任何前缀，则返回 null。
另请参见：
setDefaultNamespacePrefix(String)

setDefaultNamespacePrefix

void setDefaultNamespacePrefix(String defaultPrefix)
设置默认的名称空间前缀。此方法可设置用于所有没有通过 putNamespacePrefix 方法显式设置的名称空间 URI 的名称空间前缀。

参数：
defaultPrefix - 默认的名称空间前缀；或者为 null，表示移除当前设置。指定空字符串 ("") 则表示不绑定任何前缀。
另请参见：
getDefaultNamespacePrefix()

setProperty

Object setProperty(String name,
                   Object value)
设置指定的属性。

参数：
name - 属性名称
value - 要设置的属性值
返回：
指定属性的先前值；如果没有这样值，则返回 null
抛出：
NullPointerException - 如果 name 为 null
另请参见：
getProperty(String)

getProperty

Object getProperty(String name)
返回指定属性的值。

参数：
name - 属性名称
返回：
指定的属性的当前值；如果没有这样的值，则返回 null
抛出：
NullPointerException - 如果 name 为 null
另请参见：
setProperty(String, Object)

get

Object get(Object key)
返回此上下文将指定键映射到的值。

更正式地说，如果此上下文包含键 k 到值 v 的映射关系：(key==null ? k==null :key.equals(k))，则此方法返回 v；否则返回 null。（最多只能有一个这样的映射关系）。

对于检索特定于使用此上下文的加密操作的任意信息，此方法很有用。

参数：
key - 关联值将被返回的键
返回：
此上下文将指定键映射到的值；如果没有与该键有关的映射关系，则返回 null
另请参见：
put(Object, Object)

put

Object put(Object key,
           Object value)
将指定值与此上下文中的指定键关联。如果此上下文中以前包含一个此键的映射关系，则用指定值替换原来的值。

对于存储特定于使用此上下文的加密操作的任意信息，此方法很有用。

参数：
key - 将与指定值关联的键
value - 将与指定键关联的值
返回：
与指定键关联的以前的值；如果没有与该键有关的映射关系，则返回 null
抛出：
IllegalArgumentException - 如果此键或值的某个方面阻止它存储在此上下文中
另请参见：
get(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLStructure (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto
接口 XMLStructure

所有已知子接口：
CanonicalizationMethod, DigestMethod, KeyInfo, KeyName, KeyValue, Manifest, PGPData, Reference, RetrievalMethod, SignatureMethod, SignatureProperties, SignatureProperty, SignedInfo, Transform, X509Data, X509IssuerSerial, XMLObject, XMLSignature, XMLSignature.SignatureValue
所有已知实现类：
DOMStructure, TransformService
public interface XMLStructure

任何名称空间的 XML 结构的表示形式。此接口用于对所有 XML 结构的表示形式进行分组（并为之提供类型安全）。

从以下版本开始：
1.6

方法摘要
 boolean isFeatureSupported(String feature)
指示是否支持指定的功能。

方法详细信息

isFeatureSupported

boolean isFeatureSupported(String feature)
指示是否支持指定的功能。

参数：
feature - 功能的名称（以抽象 URI 形式）
返回：
如果支持指定功能，则返回 true，否则返回 false
抛出：
NullPointerException - 如果 feature 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.crypto (Java Platform SE 6)

 javax.xml.crypto
接口
AlgorithmMethod
Data
KeySelectorResult
NodeSetData
URIDereferencer
URIReference
XMLCryptoContext
XMLStructure
类
KeySelector
KeySelector.Purpose
OctetStreamData
异常
KeySelectorException
MarshalException
NoSuchMechanismException
URIReferenceException


javax.xml.crypto (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.crypto

用于 XML 加密的通用类。

请参见：
描述

接口摘要
AlgorithmMethod | XML Security 规范中定义的算法的抽象表示。
Data | 取消引用 URIReference 或后续 Transform 的输入/输出所得结果的抽象表示。
KeySelectorResult | 由 KeySelector.select 方法返回的结果。
NodeSetData | 包含节点集的 Data 类型的抽象表示。
URIDereferencer | URIReference 的 dereferencer。
URIReference | 通过 URI-Reference 标识数据对象，正如 RFC 2396 所指定的。
XMLCryptoContext | 包含用于 XML 加密操作的通用上下文信息。
XMLStructure | 任何名称空间的 XML 结构的表示形式。

类摘要
KeySelector | 一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。
KeySelector.Purpose | 将被选中的密钥的用途。
OctetStreamData | 包含一个八位组流的 Data 类型的表示形式。

异常摘要
KeySelectorException | 指示由 KeySelector 抛出的异常条件。
MarshalException | 指示 XML 编组或解组过程中发生的异常条件。
NoSuchMechanismException | 当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
URIReferenceException | 指示取消引用 URIReference 时抛出的异常条件。

软件包 javax.xml.crypto 的描述

用于 XML 加密的通用类。此包中包括用于执行 XML 加密操作的通用类，这些操作包括生成 XML 签名或加密 XML 数据。

包规范

  • XML-Signature Syntax and Processing:W3C Recommendation
  • RFC 3275:XML-Signature Syntax and Processing

Since:
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.crypto 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.crypto.KeySelector
    • javax.xml.crypto.KeySelector.Purpose
    • javax.xml.crypto.OctetStreamData (implements javax.xml.crypto.Data)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.crypto.KeySelectorException
        • javax.xml.crypto.MarshalException
        • java.lang.RuntimeException
          • javax.xml.crypto.NoSuchMechanismException
        • javax.xml.crypto.URIReferenceException

接口分层结构

  • javax.xml.crypto.AlgorithmMethod
  • javax.xml.crypto.Data
    • javax.xml.crypto.NodeSetData
  • javax.xml.crypto.KeySelectorResult
  • javax.xml.crypto.URIDereferencer
  • javax.xml.crypto.URIReference
  • javax.xml.crypto.XMLCryptoContext
  • javax.xml.crypto.XMLStructure
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.crypto 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto
的使用

使用 javax.xml.crypto 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto 使用的 javax.xml.crypto 中的类
AlgorithmMethod
XML Security 规范中定义的算法的抽象表示。
Data
取消引用 URIReference 或后续 Transform 的输入/输出所得结果的抽象表示。
KeySelector
一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。
KeySelector.Purpose
将被选中的密钥的用途。
KeySelectorException
指示由 KeySelector 抛出的异常条件。
KeySelectorResult
由 KeySelector.select 方法返回的结果。
URIDereferencer
URIReference 的 dereferencer。
URIReference
通过 URI-Reference 标识数据对象，正如 RFC 2396 所指定的。
URIReferenceException
指示取消引用 URIReference 时抛出的异常条件。
XMLCryptoContext
包含用于 XML 加密操作的通用上下文信息。

javax.xml.crypto.dom 使用的 javax.xml.crypto 中的类
KeySelector
一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。
URIDereferencer
URIReference 的 dereferencer。
URIReference
通过 URI-Reference 标识数据对象，正如 RFC 2396 所指定的。
XMLCryptoContext
包含用于 XML 加密操作的通用上下文信息。
XMLStructure
任何名称空间的 XML 结构的表示形式。

javax.xml.crypto.dsig 使用的 javax.xml.crypto 中的类
AlgorithmMethod
XML Security 规范中定义的算法的抽象表示。
Data
取消引用 URIReference 或后续 Transform 的输入/输出所得结果的抽象表示。
KeySelectorResult
由 KeySelector.select 方法返回的结果。
MarshalException
指示 XML 编组或解组过程中发生的异常条件。
URIDereferencer
URIReference 的 dereferencer。
URIReference
通过 URI-Reference 标识数据对象，正如 RFC 2396 所指定的。
XMLCryptoContext
包含用于 XML 加密操作的通用上下文信息。
XMLStructure
任何名称空间的 XML 结构的表示形式。

javax.xml.crypto.dsig.dom 使用的 javax.xml.crypto 中的类
KeySelector
一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。
XMLCryptoContext
包含用于 XML 加密操作的通用上下文信息。

javax.xml.crypto.dsig.keyinfo 使用的 javax.xml.crypto 中的类
Data
取消引用 URIReference 或后续 Transform 的输入/输出所得结果的抽象表示。
MarshalException
指示 XML 编组或解组过程中发生的异常条件。
URIDereferencer
URIReference 的 dereferencer。
URIReference
通过 URI-Reference 标识数据对象，正如 RFC 2396 所指定的。
URIReferenceException
指示取消引用 URIReference 时抛出的异常条件。
XMLCryptoContext
包含用于 XML 加密操作的通用上下文信息。
XMLStructure
任何名称空间的 XML 结构的表示形式。

javax.xml.crypto.dsig.spec 使用的 javax.xml.crypto 中的类
XMLStructure
任何名称空间的 XML 结构的表示形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DOMCryptoContext (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dom
类 DOMCryptoContext

java.lang.Object
    继承者  javax.xml.crypto.dom.DOMCryptoContext
所有已实现的接口：
XMLCryptoContext
直接已知子类：
DOMSignContext, DOMValidateContext
public class DOMCryptoContext
extends Object
implements XMLCryptoContext

此类提供 XMLCryptoContext 接口特定于 DOM 的实现。它还包括特定于基于 DOM 的实现的其他方法，用于注册和检索包含类型 ID 的属性的元素。

从以下版本开始：
1.6

构造方法摘要
protected DOMCryptoContext()
默认的构造方法。
方法摘要
Object | get(Object key) 此实现使用内部 HashMap 获取指定键所映射的对象。
String | getBaseURI() 返回基本 URI。
String | getDefaultNamespacePrefix() 返回默认名称空间前缀。
Element | getElementById(String idValue) 返回具有指定 ID 属性值的 Element。
KeySelector | getKeySelector() 返回用于查找某个密钥的密钥选择器。
String | getNamespacePrefix(String namespaceURI, String defaultPrefix) 此实现使用内部 HashMap 来获取指定 URI 所映射的前缀。
Object | getProperty(String name) 此实现使用内部 HashMap 获取指定名称所映射的对象。
URIDereferencer | getURIDereferencer() 返回用来取消引用 URIReference 的 URIDereferencer。
Iterator | iterator() 返回可在此 DOMCryptoContext 的 Id/Element 映射集上进行迭代的只读迭代器。
Object | put(Object key, Object value) 此实现使用内部 HashMap 将键映射到指定的对象。
String | putNamespacePrefix(String namespaceURI, String prefix) 此实现使用内部 HashMap 将 URI 映射到指定的前缀。
void | setBaseURI(String baseURI) 设置基本 URI。
void | setDefaultNamespacePrefix(String defaultPrefix) 设置默认的名称空间前缀。
void | setIdAttributeNS(Element element, String namespaceURI, String localName) 将名称空间 URI 和本地名称指定的元素属性注册为类型 ID。
void | setKeySelector(KeySelector ks) 设置用于查找某个密钥的密钥选择器。
Object | setProperty(String name, Object value) 此实现使用内部 HashMap 将名称映射到指定对象。
void | setURIDereferencer(URIDereferencer dereferencer) 设置用来取消引用 URIReference 的 URIDereferencer。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DOMCryptoContext

protected DOMCryptoContext()
默认的构造方法。（由子类构造方法调用）。

方法详细信息

getNamespacePrefix

public String getNamespacePrefix(String namespaceURI,
                                 String defaultPrefix)
此实现使用内部 HashMap 来获取指定 URI 所映射的前缀。如果指定的 URI 映射到 null，则返回 defaultPrefix。

指定者：
接口 XMLCryptoContext 中的 getNamespacePrefix
参数：
namespaceURI - 名称空间 URI
defaultPrefix - 在没有将指定的名称空间 URI 绑定到某一前缀的情况下将被返回的前缀。
返回：
与指定的名称空间 URI 相关联的前缀，如果没有注册 URI，则返回 defaultPrefix。如果已注册名称空间 URI，但没有前缀，则返回一个空字符串 ("")。
抛出：
NullPointerException - 如果 namespaceURI 为 null
另请参见：
XMLCryptoContext.putNamespacePrefix(String, String)

putNamespacePrefix

public String putNamespacePrefix(String namespaceURI,
                                 String prefix)
此实现使用内部 HashMap 将 URI 映射到指定的前缀。

指定者：
接口 XMLCryptoContext 中的 putNamespacePrefix
参数：
namespaceURI - 名称空间 URI
prefix - 名称空间前缀（或者为 null，表示移除所有现有映射）。指定空字符串 ("") 则表示不将任何前缀绑定到名称空间 URI。
返回：
与指定的名称空间 URI 关联以前使用的前缀，如果没有任何前缀，则返回 null
抛出：
NullPointerException - 如果 namespaceURI 为 null
另请参见：
XMLCryptoContext.getNamespacePrefix(String, String)

getDefaultNamespacePrefix

public String getDefaultNamespacePrefix()
从接口 XMLCryptoContext 复制的描述
返回默认名称空间前缀。默认的名称空间前缀是用于所有名称空间 URI 的前缀，该前缀未通过 putNamespacePrefix 方法显式设置。

指定者：
接口 XMLCryptoContext 中的 getDefaultNamespacePrefix
返回：
默认的名称空间前缀；如果未设置任何前缀，则返回 null。
另请参见：
XMLCryptoContext.setDefaultNamespacePrefix(String)

setDefaultNamespacePrefix

public void setDefaultNamespacePrefix(String defaultPrefix)
从接口 XMLCryptoContext 复制的描述
设置默认的名称空间前缀。此方法可设置用于所有没有通过 putNamespacePrefix 方法显式设置的名称空间 URI 的名称空间前缀。

指定者：
接口 XMLCryptoContext 中的 setDefaultNamespacePrefix
参数：
defaultPrefix - 默认的名称空间前缀；或者为 null，表示移除当前设置。指定空字符串 ("") 则表示不绑定任何前缀。
另请参见：
XMLCryptoContext.getDefaultNamespacePrefix()

getBaseURI

public String getBaseURI()
从接口 XMLCryptoContext 复制的描述
返回基本 URI。

指定者：
接口 XMLCryptoContext 中的 getBaseURI
返回：
基本 URI；如果未指定，则返回 null
另请参见：
XMLCryptoContext.setBaseURI(String)

setBaseURI

public void setBaseURI(String baseURI)
从接口 XMLCryptoContext 复制的描述
设置基本 URI。

指定者：
接口 XMLCryptoContext 中的 setBaseURI
参数：
baseURI - 基本 URI；或者为 null，表示移除当前值
抛出：
IllegalArgumentException - 如果 baseURI 与 RFC 2396 不兼容
另请参见：
XMLCryptoContext.getBaseURI()

getURIDereferencer

public URIDereferencer getURIDereferencer()
从接口 XMLCryptoContext 复制的描述
返回用来取消引用 URIReference 的 URIDereferencer。

指定者：
接口 XMLCryptoContext 中的 getURIDereferencer
返回：
URIDereferencer；如果未指定，则返回 null
另请参见：
XMLCryptoContext.setURIDereferencer(URIDereferencer)

setURIDereferencer

public void setURIDereferencer(URIDereferencer dereferencer)
从接口 XMLCryptoContext 复制的描述
设置用来取消引用 URIReference 的 URIDereferencer。使用指定的 URIDereferencer 来代替某一实现的默认 URIDereferencer。

指定者：
接口 XMLCryptoContext 中的 setURIDereferencer
参数：
dereferencer - URIDereferencer；或者为 null，表示移除任何当前设置
另请参见：
XMLCryptoContext.getURIDereferencer()

getProperty

public Object getProperty(String name)
此实现使用内部 HashMap 获取指定名称所映射的对象。

指定者：
接口 XMLCryptoContext 中的 getProperty
参数：
name - 属性名称
返回：
指定的属性的当前值；如果没有这样的值，则返回 null
抛出：
NullPointerException - 如果 name 为 null
另请参见：
XMLCryptoContext.setProperty(String, Object)

setProperty

public Object setProperty(String name,
                          Object value)
此实现使用内部 HashMap 将名称映射到指定对象。

指定者：
接口 XMLCryptoContext 中的 setProperty
参数：
name - 属性名称
value - 要设置的属性值
返回：
指定属性的先前值；如果没有这样值，则返回 null
抛出：
NullPointerException - 如果 name 为 null
另请参见：
XMLCryptoContext.getProperty(String)

getKeySelector

public KeySelector getKeySelector()
从接口 XMLCryptoContext 复制的描述
返回用于查找某个密钥的密钥选择器。

指定者：
接口 XMLCryptoContext 中的 getKeySelector
返回：
密钥选择器；如果未指定，则返回 null
另请参见：
XMLCryptoContext.setKeySelector(KeySelector)

setKeySelector

public void setKeySelector(KeySelector ks)
从接口 XMLCryptoContext 复制的描述
设置用于查找某个密钥的密钥选择器。

指定者：
接口 XMLCryptoContext 中的 setKeySelector
参数：
ks - 密钥选择器；或者为 null，表示移除当前设置
另请参见：
XMLCryptoContext.getKeySelector()

getElementById

public Element getElementById(String idValue)
返回具有指定 ID 属性值的 Element。

此实现使用内部 HashMap 获取指定属性值所映射的元素。

参数：
idValue - ID 值
返回：
具有指定 ID 属性值的 Element；如果没有，则返回 null。
抛出：
NullPointerException - 如果 idValue 为 null
另请参见：
setIdAttributeNS(org.w3c.dom.Element, java.lang.String, java.lang.String)

setIdAttributeNS

public void setIdAttributeNS(Element element,
                             String namespaceURI,
                             String localName)
将名称空间 URI 和本地名称指定的元素属性注册为类型 ID。该属性必须有一个非空值。

此实现使用内部 HashMap 将属性值映射到指定元素。

参数：
element - 元素
namespaceURI - 属性的名称空间 URI（如果不适用，则指定 null）
localName - 属性的本地名称
抛出：
IllegalArgumentException - 如果 localName 不是指定元素的属性，或者它不包含特定值
NullPointerException - 如果 element 或 localName 为 null
另请参见：
getElementById(java.lang.String)

iterator

public Iterator iterator()
返回可在此 DOMCryptoContext 的 Id/Element 映射集上进行迭代的只读迭代器。试图通过 Iterator.remove() 方法修改该映射集将导致抛出 UnsupportedOperationException。返回的映射没有特定的顺序。迭代的每个元素都被表示为一个 Map.Entry。如果在进行迭代期间修改了 DOMCryptoContext，则迭代的结果是不确定的。

返回：
可在映射集上进行迭代的只读迭代器

get

public Object get(Object key)
此实现使用内部 HashMap 获取指定键所映射的对象。

指定者：
接口 XMLCryptoContext 中的 get
参数：
key - 关联值将被返回的键
返回：
此上下文将指定键映射到的值；如果没有与该键有关的映射关系，则返回 null
另请参见：
XMLCryptoContext.put(Object, Object)

put

public Object put(Object key,
                  Object value)
此实现使用内部 HashMap 将键映射到指定的对象。

指定者：
接口 XMLCryptoContext 中的 put
参数：
key - 将与指定值关联的键
value - 将与指定键关联的值
返回：
与指定键关联的以前的值；如果没有与该键有关的映射关系，则返回 null
抛出：
IllegalArgumentException - 如果此键或值的某个方面阻止它存储在此上下文中
另请参见：
XMLCryptoContext.get(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DOMStructure (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dom
类 DOMStructure

java.lang.Object
    继承者  javax.xml.crypto.dom.DOMStructure
所有已实现的接口：
XMLStructure
public class DOMStructure
extends Object
implements XMLStructure

特定于 DOM 的 XMLStructure。此类的目的是允许使用 DOM 节点表示 XML Signature 结构中的可扩展内容（任何元素或混合内容）。

如果需要节点序列，那么包含在 DOMStructure 中的节点将是该序列的第一个节点，随后的节点可以通过调用 Node.getNextSibling() 访问。

如果 DOMStructure 的所有者文档与 XMLSignature 的目标文档不同，则在生成签名前，XMLSignature.sign(XMLSignContext) 方法会将节点导入目标文档。

从以下版本开始：
1.6

构造方法摘要
DOMStructure(Node node)
创建包含指定节点的 DOMStructure。
方法摘要
Node | getNode() 返回包含在此 DOMStructure 中的节点。
boolean | isFeatureSupported(String feature) 指示是否支持指定的功能。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DOMStructure

public DOMStructure(Node node)
创建包含指定节点的 DOMStructure。

参数：
node - 节点
抛出：
NullPointerException - 如果 node 为 null
方法详细信息

getNode

public Node getNode()
返回包含在此 DOMStructure 中的节点。

返回：
节点

isFeatureSupported

public boolean isFeatureSupported(String feature)
从接口 XMLStructure 复制的描述
指示是否支持指定的功能。

指定者：
接口 XMLStructure 中的 isFeatureSupported
参数：
feature - 功能的名称（以抽象 URI 形式）
返回：
如果支持指定功能，则返回 true，否则返回 false
抛出：
NullPointerException - 如果 feature 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMURIReference (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dom
接口 DOMURIReference

所有超级接口：
URIReference
public interface DOMURIReference
extends URIReference

特定于 DOM 的 URIReference。此类的目的是提供解析 XPointer URI 或同文档引用所必需的其他上下文。

从以下版本开始：
1.6

方法摘要
 Node getHere()
返回当前位置的节点。
从接口 javax.xml.crypto.URIReference 继承的方法
getType, getURI

方法详细信息

getHere

Node getHere()
返回当前位置的节点。

返回：
属性节点、处理指令节点或直接包含 URI 的文本节点的父元素
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.crypto.dom (Java Platform SE 6)

 javax.xml.crypto.dom
接口
DOMURIReference
类
DOMCryptoContext
DOMStructure


javax.xml.crypto.dom (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.crypto.dom

javax.xml.crypto 包的特定于 DOM 的类。

请参见：
描述

接口摘要
DOMURIReference 特定于 DOM 的 URIReference。

类摘要
DOMCryptoContext | 此类提供 XMLCryptoContext 接口特定于 DOM 的实现。
DOMStructure | 特定于 DOM 的 XMLStructure。

软件包 javax.xml.crypto.dom 的描述

javax.xml.crypto 包的特定于 DOM 的类。只有那些使用基于 DOM 的 XML 加密实现（比如：XMLSignatureFactory 或 KeyInfoFactory) 的用户才需要直接使用此包。

包规范

  • XML-Signature Syntax and Processing:W3C Recommendation
  • RFC 3275:XML-Signature Syntax and Processing

Since:
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.crypto.dom 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dom 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
    • javax.xml.crypto.dom.DOMStructure (implements javax.xml.crypto.XMLStructure)

接口分层结构

  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dom.DOMURIReference
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.crypto.dom 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dom
的使用

使用 javax.xml.crypto.dom 的软件包
javax.xml.crypto.dsig.dom javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig.dom 使用的 javax.xml.crypto.dom 中的类
DOMCryptoContext
此类提供 XMLCryptoContext 接口特定于 DOM 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dom.DOMCryptoContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dom.DOMCryptoContext
的使用

使用 DOMCryptoContext 的软件包
javax.xml.crypto.dsig.dom javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig.dom 中 DOMCryptoContext 的使用

javax.xml.crypto.dsig.dom 中 DOMCryptoContext 的子类
class | DOMSignContext 特定于 DOM 的 XMLSignContext。
class | DOMValidateContext 特定于 DOM 的 XMLValidateContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dom.DOMStructure 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dom.DOMStructure
的使用

没有 javax.xml.crypto.dom.DOMStructure 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dom.DOMURIReference 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dom.DOMURIReference
的使用

没有 javax.xml.crypto.dom.DOMURIReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


CanonicalizationMethod (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 CanonicalizationMethod

所有超级接口：
AlgorithmMethod, Transform, XMLStructure
public interface CanonicalizationMethod
extends Transform

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。XML Schema Definition 的定义如下：

<element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>
<complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>
可以通过调用 XMLSignatureFactory 类的 newCanonicalizationMethod 方法创建 CanonicalizationMethod 实例。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newCanonicalizationMethod(String, C14NMethodParameterSpec)

字段摘要
static String | EXCLUSIVE Exclusive Canonical XML（不带注释）规范化方法的算法 URI。
static String | EXCLUSIVE_WITH_COMMENTS 带注释的 Exclusive Canonical XML 规范化方法的算法 URI。
static String | INCLUSIVE Canonical XML（不带注释）的规范化方法的算法 URI。
static String | INCLUSIVE_WITH_COMMENTS 带注释的 Canonical XML 的规范化方法的算法 URI。
从接口 javax.xml.crypto.dsig.Transform 继承的字段
BASE64, ENVELOPED, XPATH, XPATH2, XSLT
方法摘要
 AlgorithmParameterSpec getParameterSpec()
返回与此 CanonicalizationMethod 关联的特定于算法的输入参数。
从接口 javax.xml.crypto.dsig.Transform 继承的方法
transform, transform
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported
从接口 javax.xml.crypto.AlgorithmMethod 继承的方法
getAlgorithm

字段详细信息

INCLUSIVE

static final String INCLUSIVE
Canonical XML（不带注释）的规范化方法的算法 URI。

另请参见：
常量字段值

INCLUSIVE_WITH_COMMENTS

static final String INCLUSIVE_WITH_COMMENTS
带注释的 Canonical XML 的规范化方法的算法 URI。

另请参见：
常量字段值

EXCLUSIVE

static final String EXCLUSIVE
Exclusive Canonical XML（不带注释）规范化方法的算法 URI。

另请参见：
常量字段值

EXCLUSIVE_WITH_COMMENTS

static final String EXCLUSIVE_WITH_COMMENTS
带注释的 Exclusive Canonical XML 规范化方法的算法 URI。

另请参见：
常量字段值
方法详细信息

getParameterSpec

AlgorithmParameterSpec getParameterSpec()
返回与此 CanonicalizationMethod 关联的特定于算法的输入参数。

可将所返回的参数强制转换为 C14NMethodParameterSpec 对象。

指定者：
接口 AlgorithmMethod 中的 getParameterSpec
指定者：
接口 Transform 中的 getParameterSpec
返回：
特定于算法的输入参数（如果未指定该参数，则返回 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DigestMethod (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 DigestMethod

所有超级接口：
AlgorithmMethod, XMLStructure
public interface DigestMethod
extends XMLStructure, AlgorithmMethod

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。XML Schema Definition 的定义如下：

<element name="DigestMethod" type="ds:DigestMethodType"/>
<complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>
可以通过调用 XMLSignatureFactory 类的 newDigestMethod 方法创建 DigestMethod 实例。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newDigestMethod(String, DigestMethodParameterSpec)

字段摘要
static String | RIPEMD160 RIPEMD-160 摘要方法的算法 URI。
static String | SHA1 SHA1 摘要方法的算法 URI。
static String | SHA256 SHA256 摘要方法的算法 URI。
static String | SHA512 SHA512 摘要方法的算法 URI。
方法摘要
 AlgorithmParameterSpec getParameterSpec()
返回与此 DigestMethod 关联的特定于算法的输入参数。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported
从接口 javax.xml.crypto.AlgorithmMethod 继承的方法
getAlgorithm

字段详细信息

SHA1

static final String SHA1
SHA1 摘要方法的算法 URI。

另请参见：
常量字段值

SHA256

static final String SHA256
SHA256 摘要方法的算法 URI。

另请参见：
常量字段值

SHA512

static final String SHA512
SHA512 摘要方法的算法 URI。

另请参见：
常量字段值

RIPEMD160

static final String RIPEMD160
RIPEMD-160 摘要方法的算法 URI。

另请参见：
常量字段值
方法详细信息

getParameterSpec

AlgorithmParameterSpec getParameterSpec()
返回与此 DigestMethod 关联的特定于算法的输入参数。

可将返回的参数强制转换为 DigestMethodParameterSpec 对象。

指定者：
接口 AlgorithmMethod 中的 getParameterSpec
返回：
特定于算法的参数（如果未指定该参数，则返回 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Manifest (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 Manifest

所有超级接口：
XMLStructure
public interface Manifest
extends XMLStructure

在 W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Manifest 元素的表示形式。XML Schema Definition 定义如下：

<element name="Manifest" type="ds:ManifestType"/>
<complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>
调用 XMLSignatureFactory 类的一个 newManifest 方法可以创建 Manifest 实例，例如：
XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
List references = Collections.singletonList(factory.newReference
("#reference-1", DigestMethod.SHA1));
Manifest manifest = factory.newManifest(references, "manifest-1");

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newManifest(List), XMLSignatureFactory.newManifest(List, String)

字段摘要
static String TYPE
标识 Manifest 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
方法摘要
String | getId() 返回此 Manifest 的 Id。
List | getReferences() 返回一个不可修改的列表，由包含在此 Manifest 中的一个或多个 Reference 组成。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

字段详细信息

TYPE

static final String TYPE
标识 Manifest 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

另请参见：
常量字段值
方法详细信息

getId

String getId()
返回此 Manifest 的 Id。

返回：
此 Manifest 的 Id（如果未指定，则返回 null）

getReferences

List getReferences()
返回一个不可修改的列表，由包含在此 Manifest 中的一个或多个 Reference 组成。

返回：
一个或多个 Reference 的不可修改列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Reference (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 Reference

所有超级接口：
URIReference, XMLStructure
public interface Reference
extends URIReference, XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。XML Schema 的定义如下：

<element name="Reference" type="ds:ReferenceType"/>
<complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>

<element name="DigestValue" type="ds:DigestValueType"/>
<simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>

调用 XMLSignatureFactory 类的一个 newReference 方法可以创建 Reference 实例，例如：

XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
Reference ref = factory.newReference
("http://www.ietf.org/rfc/rfc3275.txt",
        factory.newDigestMethod(DigestMethod.SHA1, null));

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newReference(String, DigestMethod), XMLSignatureFactory.newReference(String, DigestMethod, List, String, String)

方法摘要
byte[] | getCalculatedDigestValue() 返回执行验证操作后计算的此 Reference 的摘要值。
Data | getDereferencedData() 如果已启用引用缓存，则返回被取消引用的数据。
InputStream | getDigestInputStream() 如果已启用引用缓存，则返回预整理的输入流。
DigestMethod | getDigestMethod() 返回此 Reference 的摘要方法。
byte[] | getDigestValue() 返回此 Reference 的摘要值。
String | getId() 返回此 Reference 的可选 Id 属性，该属性允许从其他地方引用此 Reference。
List | getTransforms() 返回一个 不可修改的列表，由包含在此 Reference 中的 Transform 组成。
boolean | validate(XMLValidateContext validateContext) 验证此引用。
从接口 javax.xml.crypto.URIReference 继承的方法
getType, getURI
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

方法详细信息

getTransforms

List getTransforms()
返回一个 不可修改的列表，由包含在此 Reference 中的 Transform 组成。

返回：
一个不可修改的 Transform 列表（可以为空，但不能为 null）

getDigestMethod

DigestMethod getDigestMethod()
返回此 Reference 的摘要方法。

返回：
摘要方法

getId

String getId()
返回此 Reference 的可选 Id 属性，该属性允许从其他地方引用此 Reference。

返回：
Id 属性（如果未指定，则返回 null）

getDigestValue

byte[] getDigestValue()
返回此 Reference 的摘要值。

返回：
原始摘要值，如果此引用没有摘要，则返回 null。每次调用此方法都将返回一个新的副本，以防止随后被修改。

getCalculatedDigestValue

byte[] getCalculatedDigestValue()
返回执行验证操作后计算的此 Reference 的摘要值。如果验证引用失败，则此方法对于调试很有用。

返回：
计算的摘要值；如果尚未验证此引用，则返回 null。每次调用此方法都将返回一个新的副本，以防止随后被修改。

validate

boolean validate(XMLValidateContext validateContext)
                 throws XMLSignatureException
验证此引用。此方法将验证此引用的摘要。

此方法只在首次调用时验证引用。在进行后续调用时，它将返回一个缓存的结果。

参数：
validateContext - 验证的上下文
返回：
如果成功验证此引用，则返回 true；否则返回 false
抛出：
NullPointerException - 如果 validateContext 为 null
XMLSignatureException - 如果在验证引用时发生不可预料的异常

getDereferencedData

Data getDereferencedData()
如果已启用引用缓存，则返回被取消引用的数据。在执行验证或生成操作期间取消引用此引用的 URI 时，会产生上述结果。

返回：
被取消引用的数据；如果未启用引用缓存或者没有生成或验证此引用，则返回 null

getDigestInputStream

InputStream getDigestInputStream()
如果已启用引用缓存，则返回预整理的输入流。这是执行验证或签名操作期间摘要操作的输入。

返回：
包含预整理输入的输入流；如果没有启用引用缓存，或者没有生成或验证此引用，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SignatureMethod (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 SignatureMethod

所有超级接口：
AlgorithmMethod, XMLStructure
public interface SignatureMethod
extends XMLStructure, AlgorithmMethod

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。XML Schema Definition 的定义如下：

<element name="SignatureMethod" type="ds:SignatureMethodType"/>
<complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" minOccurs="0" type="ds:HMACOutputLengthType"/>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>
调用 XMLSignatureFactory 类的 newSignatureMethod 方法可以创建 SignatureMethod 实例。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newSignatureMethod(String, SignatureMethodParameterSpec)

字段摘要
static String | DSA_SHA1 DSAwithSHA1 (DSS) 签名方法的算法 URI。
static String | HMAC_SHA1 HMAC-SHA1 MAC 签名方法的算法 URI。
static String | RSA_SHA1 RSAwithSHA1 (PKCS #1) 签名方法的算法 URI。
方法摘要
 AlgorithmParameterSpec getParameterSpec()
返回此 SignatureMethod 的特定于算法的输入参数。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported
从接口 javax.xml.crypto.AlgorithmMethod 继承的方法
getAlgorithm

字段详细信息

DSA_SHA1

static final String DSA_SHA1
DSAwithSHA1 (DSS) 签名方法的算法 URI。

另请参见：
常量字段值

RSA_SHA1

static final String RSA_SHA1
RSAwithSHA1 (PKCS #1) 签名方法的算法 URI。

另请参见：
常量字段值

HMAC_SHA1

static final String HMAC_SHA1
HMAC-SHA1 MAC 签名方法的算法 URI。

另请参见：
常量字段值
方法详细信息

getParameterSpec

AlgorithmParameterSpec getParameterSpec()
返回此 SignatureMethod 的特定于算法的输入参数。

可将返回的参数强制转换为 SignatureMethodParameterSpec 对象。

指定者：
接口 AlgorithmMethod 中的 getParameterSpec
返回：
此 SignatureMethod 的特定于算法的输入参数（如果未指定，则返回 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SignatureProperties (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 SignatureProperties

所有超级接口：
XMLStructure
public interface SignatureProperties
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperties 元素的表示形式。XML Schema Definition 的定义如下：

<element name="SignatureProperties" type="ds:SignaturePropertiesType"/>
<complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>
调用 XMLSignatureFactory 类的 newSignatureProperties 方法可以创建 SignatureProperties 实例，例如：
XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
SignatureProperties properties =
        factory.newSignatureProperties(props, "signature-properties-1");

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newSignatureProperties(List, String), SignatureProperty

字段摘要
static String TYPE
标识 SignatureProperties 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
方法摘要
String | getId() 返回此 SignatureProperties 的 Id。
List | getProperties() 返回一个可修改的列表，由包含此在 SignatureProperties 中的一个或多个 SignatureProperty 组成。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

字段详细信息

TYPE

static final String TYPE
标识 SignatureProperties 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

另请参见：
常量字段值
方法详细信息

getId

String getId()
返回此 SignatureProperties 的 Id。

返回：
此 SignatureProperties 的 Id（如果未指定，则返回 null）

getProperties

List getProperties()
返回一个可修改的列表，由包含此在 SignatureProperties 中的一个或多个 SignatureProperty 组成。

返回：
一个或多个 SignatureProperty 的不可修改列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SignatureProperty (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 SignatureProperty

所有超级接口：
XMLStructure
public interface SignatureProperty
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperty 元素的表示形式。XML Schema Definition 的定义如下：

<element name="SignatureProperty" type="ds:SignaturePropertyType"/>
<complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1, unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>
调用 XMLSignatureFactory 类的 newSignatureProperty 方法可以创建 SignatureProperty 实例，例如：
XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");
SignatureProperty property = factory.newSignatureProperty
        (Collections.singletonList(content), "#Signature-1", "TimeStamp");

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newSignatureProperty(List, String, String), SignatureProperties

方法摘要
List | getContent() 返回一个不可修改的列表，由包含在此 SignatureProperty 中的一个或多个 XMLStructure 组成。
String | getId() 返回此 SignatureProperty 的 Id。
String | getTarget() 返回此 SignatureProperty 的目标 URI。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

方法详细信息

getTarget

String getTarget()
返回此 SignatureProperty 的目标 URI。

返回：
此 SignatureProperty 的目标 URI（不能为 null）

getId

String getId()
返回此 SignatureProperty 的 Id。

返回：
此 SignatureProperty 的 Id（如果未指定，则返回 null）

getContent

List getContent()
返回一个不可修改的列表，由包含在此 SignatureProperty 中的一个或多个 XMLStructure 组成。这些列表项表示与生成 XMLSignature 有关的其他信息项（即签名生成中使用的日期/时间戳或加密硬件的序列号）。

返回：
一个或多个 XMLStructure 的不可修改列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SignedInfo (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 SignedInfo

所有超级接口：
XMLStructure
public interface SignedInfo
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignedInfo 元素的表示形式。XML Schema Definition 的定义如下：

<element name="SignedInfo" type="ds:SignedInfoType"/>
<complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>
调用 XMLSignatureFactory 类的一个 newSignedInfo 方法可以创建 SignedInfo 实例。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newSignedInfo(CanonicalizationMethod, SignatureMethod, List), XMLSignatureFactory.newSignedInfo(CanonicalizationMethod, SignatureMethod, List, String)

方法摘要
CanonicalizationMethod | getCanonicalizationMethod() 返回此 SignedInfo 的规范化方法。
InputStream | getCanonicalizedData() 在执行签名或验证操作后，返回规范化的签名信息字节。
String | getId() 返回此 SignedInfo 的可选 Id 属性。
List | getReferences() 返回一个或多个 Reference 的不可修改的列表。
SignatureMethod | getSignatureMethod() 返回此 SignedInfo 的签名方法。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

方法详细信息

getCanonicalizationMethod

CanonicalizationMethod getCanonicalizationMethod()
返回此 SignedInfo 的规范化方法。

返回：
规范化方法

getSignatureMethod

SignatureMethod getSignatureMethod()
返回此 SignedInfo 的签名方法。

返回：
签名方法

getReferences

List getReferences()
返回一个或多个 Reference 的不可修改的列表。

返回：
一个或多个 Reference 的不可修改列表

getId

String getId()
返回此 SignedInfo 的可选 Id 属性。

返回：
id（如果未指定，则返回 null）

getCanonicalizedData

InputStream getCanonicalizedData()
在执行签名或验证操作后，返回规范化的签名信息字节。此方法对调试很有用。

返回：
包含规范化字节的 InputStream；如果尚未签名或验证此 SignedInfo，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Transform (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 Transform

所有超级接口：
AlgorithmMethod, XMLStructure
所有已知子接口：
CanonicalizationMethod
所有已知实现类：
TransformService
public interface Transform
extends XMLStructure, AlgorithmMethod

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。XML Schema Definition 的定义如下：

<element name="Transform" type="ds:TransformType"/>
<complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>
调用 XMLSignatureFactory 类的 newTransform 方法可以创建 Transform 实例。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newTransform(String, TransformParameterSpec)

字段摘要
static String | BASE64 Base64 转换算法 URI。
static String | ENVELOPED Enveloped Signature 转换算法 URI。
static String | XPATH XPath 转换算法 URI。
static String | XPATH2 XPath Filter 2 转换算法 URI。
static String | XSLT XSLT 转换算法 URI。
方法摘要
AlgorithmParameterSpec | getParameterSpec() 返回与此 Transform 关联的特定于算法的输入参数。
Data | transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported
从接口 javax.xml.crypto.AlgorithmMethod 继承的方法
getAlgorithm

字段详细信息

BASE64

static final String BASE64
Base64 转换算法 URI。

另请参见：
常量字段值

ENVELOPED

static final String ENVELOPED
Enveloped Signature 转换算法 URI。

另请参见：
常量字段值

XPATH

static final String XPATH
XPath 转换算法 URI。

另请参见：
常量字段值

XPATH2

static final String XPATH2
XPath Filter 2 转换算法 URI。

另请参见：
常量字段值

XSLT

static final String XSLT
XSLT 转换算法 URI。

另请参见：
常量字段值
方法详细信息

getParameterSpec

AlgorithmParameterSpec getParameterSpec()
返回与此 Transform 关联的特定于算法的输入参数。

可将返回的参数强制转换为 TransformParameterSpec 对象。

指定者：
接口 AlgorithmMethod 中的 getParameterSpec
返回：
特定于算法的输入参数（如果未指定，则返回 null）

transform

Data transform(Data data,
               XMLCryptoContext context)
               throws TransformException
使用底层转换算法对指定数据进行转换。

参数：
data - 要转换的数据
context - 包含其他上下文的 XMLCryptoContext（如果不适用，则该参数为 null）
返回：
已转换的数据
抛出：
NullPointerException - 如果 data 为 null
TransformException - 如果执行转换时发生错误

transform

Data transform(Data data,
               XMLCryptoContext context,
               OutputStream os)
               throws TransformException
使用底层转换算法对指定数据进行转换。如果此转换的输出是一个 OctetStreamData，则此方法将返回 null，并且将字节写入指定的 OutputStream。否则，将忽略 OutputStream，并且该方法的行为将类似于调用 transform(Data, XMLCryptoContext)。

参数：
data - 要转换的数据
context - 包含其他上下文的 XMLCryptoContext（如果不适用，则该参数为 null）
os - 应写入已转换数据的 OutputStream
返回：
已转换的数据（如果将数据写入 OutputStream 参数，则返回 null）
抛出：
NullPointerException - 如果 data 或 os 为 null
TransformException - 如果执行转换时出现错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
类 TransformException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.crypto.dsig.TransformException
所有已实现的接口：
Serializable
public class TransformException
extends Exception

指示执行转换算法时出现异常的异常条件。

TransformException 可以包含一个 cause：另一个导致抛出此 TransformException 的 throwable。

从以下版本开始：
1.6
另请参见：
Transform.transform(javax.xml.crypto.Data, javax.xml.crypto.XMLCryptoContext), 序列化表格

构造方法摘要
TransformException()
构造用 null 作为其详细消息的新 TransformException。
TransformException(String message)
构造带有指定详细消息的新 TransformException。
TransformException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 TransformException。
TransformException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 TransformException（它通常包含 cause 的类和详细消息）。
方法摘要
Throwable | getCause() 返回此 TransformException 的 cause，如果 cause 不存在或未知，则返回 null。
void | printStackTrace() 将此 TransformException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
void | printStackTrace(PrintStream s) 将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印流中。
void | printStackTrace(PrintWriter s) 将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印编写器。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TransformException

public TransformException()
构造用 null 作为其详细消息的新 TransformException。

TransformException

public TransformException(String message)
构造带有指定详细消息的新 TransformException。

参数：
message - 详细消息

TransformException

public TransformException(String message,
                          Throwable cause)
构造带指定详细消息和 cause 的新 TransformException。

注意，与 cause 相关的详细消息不是自动合并到这个异常的详细消息中的。

参数：
message - 详细消息
cause - cause（允许使用 null 值，指出 cause 是不存在的或是未知的。）

TransformException

public TransformException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 TransformException（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（允许为 null 值，指出 cause 不存在或未知。）
方法详细信息

getCause

public Throwable getCause()
返回此 TransformException 的 cause，如果 cause 不存在或未知，则返回 null。（cause 是导致抛出此 TransformException 的 throwable。）

覆盖：
类 Throwable 中的 getCause
返回：
导致抛出此 TransformException 的 cause，如果 cause 不存在或未知，则返回 null。

printStackTrace

public void printStackTrace()
将此 TransformException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintStream s)
将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印流中。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace(PrintWriter s)
将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印编写器。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintWriter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformService (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
类 TransformService

java.lang.Object
    继承者  javax.xml.crypto.dsig.TransformService
所有已实现的接口：
AlgorithmMethod, Transform, XMLStructure
public abstract class TransformService
extends Object
implements Transform

转换算法和规范算法的服务提供者接口。

每个 TransformService 实例都支持一个特定的转换或规范算法以及 XML 机制类型。要创建 TransformService，需要调用一个静态 getInstance 方法，并传入所需的算法 URI 和 XML 机制类型，例如：

TransformService ts = TransformService.getInstance(Transform.XPATH2, "DOM");

使用 Provider 机制来注册和加载 TransformService 实现。每个 TransformService 服务提供者实现都应该包括一个 MechanismType 服务属性，用它来标识所支持的 XML 机制类型。如果未指定该属性，则假定 XML 机制类型为 “DOM”。例如，支持 XPath Filter 2 Transform 和 DOM 机制的服务提供者将在 Provider 子类中指定，如下所示：

put("TransformService."+ Transform.XPATH2,
"org.example.XPath2TransformService");
put("TransformService."+ Transform.XPATH2 + " MechanismType", "DOM");
支持 DOM 机制类型的 TransformService 实现必须遵守 DOM 互操作性要求，正如 API 概述中 DOM Mechanism Requirements 部分的定义。参见 API 概述的 Service Providers 部分的标准机制类型列表。

一旦创建了 TransformService，就可以使用它来处理 Transform 或 CanonicalizationMethod 对象。如果 Transform 或 CanonicalizationMethod 以 XML 形式存在（例如，在验证现有的 XMLSignature 时），则必须先调用 init(XMLStructure, XMLCryptoContext) 方法来初始化该转换并提供文档上下文（即使没有参数）。此外，如果从头创建 Transform 或 CanonicalizationMethod，则将调用 init(TransformParameterSpec) 方法来初始化带参数的转换，并调用 marshalParams 方法将参数编组到 XML 且提供带文档上下文的转换。最后，调用 transform 方法来执行转换。

并发访问

可保证此类的静态方法是线程安全的。多个线程可以并发调用此类中所定义的静态方法，而不会产生不良效果。

但是，对于此类所定义的非静态方法并非如此。除非具体的提供者另行指定，否则需要并发访问单个 TransformService 实例的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同 TransformService 实例的多个线程而言，无需实现同步。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.crypto.dsig.Transform 继承的字段
BASE64, ENVELOPED, XPATH, XPATH2, XSLT
构造方法摘要
protected TransformService()
默认的构造方法，由子类调用。
方法摘要
String | getAlgorithm() 返回此 TransformService 支持的算法 URI。
static TransformService | getInstance(String algorithm, String mechanismType) 返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。
static TransformService | getInstance(String algorithm, String mechanismType, Provider provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
static TransformService | getInstance(String algorithm, String mechanismType, String provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
String | getMechanismType() 返回此 TransformService 支持的机制类型。
Provider | getProvider() 返回此 TransformService 的提供者。
abstract void | init(TransformParameterSpec params) 使用指定的参数初始化此 TransformService。
abstract void | init(XMLStructure parent, XMLCryptoContext context) 使用指定的参数和文档上下文初始化此 TransformService。
abstract void | marshalParams(XMLStructure parent, XMLCryptoContext context) 对特定于算法的参数进行编组。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.xml.crypto.dsig.Transform 继承的方法
getParameterSpec, transform, transform
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

构造方法详细信息

TransformService

protected TransformService()
默认的构造方法，由子类调用。

方法详细信息

getInstance

public static TransformService getInstance(String algorithm,
                                           String mechanismType)
                                    throws NoSuchAlgorithmException
返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。

此方法使用标准的 JCA 提供者查找机制来查找并实例化所需算法的 TransformService 实现和 MechanismType 服务属性。它将从首选的 Provider 开始，遍历已注册的安全 Provider 列表。返回取自第一个支持指定算法和机制类型的 Provider 的新 TransformService 对象。

注意，已注册提供者的列表可以通过 Security.getProviders() 方法获得。

参数：
algorithm - 算法的 URI
mechanismType - XML 处理机制和表示形式的类型
返回：
新的 TransformService
抛出：
NullPointerException - 如果 algorithm 或 mechanismType 为 null
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法和机制类型的 TransformService 实现
另请参见：
Provider

getInstance

public static TransformService getInstance(String algorithm,
                                           String mechanismType,
                                           Provider provider)
                                    throws NoSuchAlgorithmException
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。注意，指定的 Provider 对象不必已经在提供者列表中注册。

参数：
algorithm - 算法的 URI
mechanismType - XML 处理机制和表示形式的类型
provider - Provider 对象
返回：
新的 TransformService
抛出：
NullPointerException - 如果 provider、algorithm 或 mechanismType 为 null
NoSuchAlgorithmException - 如果不能从指定的 Provider 对象得到指定算法和机制类型的 TransformService 实现
另请参见：
Provider

getInstance

public static TransformService getInstance(String algorithm,
                                           String mechanismType,
                                           String provider)
                                    throws NoSuchAlgorithmException,
                                           NoSuchProviderException
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。指定的提供者必须是已在安全提供者列表中注册的。

注意，已注册提供者的列表可以通过 Security.getProviders() 方法获得。

参数：
algorithm - 算法的 URI
mechanismType - XML 处理机制和表示形式的类型
provider - 提供者的字符串名称
返回：
新的 TransformService
抛出：
NoSuchProviderException - 如果指定的提供者没有在安全提供者列表中注册
NullPointerException - 如果 provider、mechanismType 或 algorithm 为 null
NoSuchAlgorithmException - 如果不能从指定的提供者得到指定算法和机制类型的 TransformService 实现
另请参见：
Provider

getMechanismType

public final String getMechanismType()
返回此 TransformService 支持的机制类型。

返回：
机制类型

getAlgorithm

public final String getAlgorithm()
返回此 TransformService 支持的算法 URI。

指定者：
接口 AlgorithmMethod 中的 getAlgorithm
返回：
算法 URI

getProvider

public final Provider getProvider()
返回此 TransformService 的提供者。

返回：
提供者

init

public abstract void init(TransformParameterSpec params)
                   throws InvalidAlgorithmParameterException
使用指定的参数初始化此 TransformService。

如果参数以 XML 形式存在，则应该使用 init(XMLStructure, XMLCryptoContext) 方法初始化 TransformService。

参数：
params - 算法参数（如果该参数不是必需的或是可选的，则为 null）
抛出：
InvalidAlgorithmParameterException - 如果指定参数对于此算法无效

marshalParams

public abstract void marshalParams(XMLStructure parent,
                                   XMLCryptoContext context)
                            throws MarshalException
对特定于算法的参数进行编组。如果没有要编组的参数，则此方法将返回且不会抛出异常。

参数：
parent - 特定于机制的结构，包含应追加到已编组参数中的父节点
context - 包含其他上下文的 XMLCryptoContext（如果不适用，则该参数为 null）
抛出：
ClassCastException - 如果 parent 类型或 context 类型与此 TransformService 不兼容
NullPointerException - 如果 parent 为 null
MarshalException - 如果无法对参数进行编组

init

public abstract void init(XMLStructure parent,
                          XMLCryptoContext context)
                   throws InvalidAlgorithmParameterException
使用指定的参数和文档上下文初始化此 TransformService。

参数：
parent - 包含父结构的特定于机制的结构
context - 包含其他上下文的 XMLCryptoContext （如果不适用，则该参数为 null）
抛出：
ClassCastException - 如果 parent 类型或 context 类型与此 TransformService 不兼容
NullPointerException - 如果 parent 为 null
InvalidAlgorithmParameterException - 如果指定参数对于此算法无效
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 XMLObject

所有超级接口：
XMLStructure
public interface XMLObject
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Object 元素的表示形式。XMLObject 可以包含任何数据，也可以包含可选的 MIME 类型、ID 和编码属性。XML Schema Definition 的定义如下：

<element name="Object" type="ds:ObjectType"/>
<complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>
通过调用 XMLSignatureFactory 类的 newXMLObject 方法，可以创建 XMLObject 实例，例如：
XMLSignatureFactory fac = XMLSignatureFactory.getInstance("DOM");
List content = Collections.singletonList(fac.newManifest(references)));
XMLObject object = factory.newXMLObject(content, "object-1", null, null);

注意，为避免与现有 java.lang.Object 类存在命名冲突，此类被命名为 XMLObject，而不是 Object。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newXMLObject(List, String, String, String)

字段摘要
static String TYPE
标识 Object 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
方法摘要
List | getContent() 返回一个可修改列表，由包含在此 XMLObject 中的 XMLStructure 组成，其中 XMLObject 表示来自任何命名空间的元素。
String | getEncoding() 返回此 XMLObject 的编码 URI。
String | getId() 返回此 XMLObject 的 Id。
String | getMimeType() 返回此 XMLObject 的 MIME 类型。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

字段详细信息

TYPE

static final String TYPE
标识 Object 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

另请参见：
常量字段值
方法详细信息

getContent

List getContent()
返回一个可修改列表，由包含在此 XMLObject 中的 XMLStructure 组成，其中 XMLObject 表示来自任何命名空间的元素。

如果有一个表示 XMLStructure 类型的公共子类，那么它将作为该类的实例返回（比如：SignatureProperties 元素将作为 SignatureProperties 的实例返回）。

返回：
不可修改的 XMLStructure 列表（可以为空，但不能为 null）

getId

String getId()
返回此 XMLObject 的 Id。

返回：
Id（如果未指定此 Id，则返回 null）

getMimeType

String getMimeType()
返回此 XMLObject 的 MIME 类型。MIME 类型是一个可选属性，它描述了此 XMLObject 中的数据）（与其编码无关）。

返回：
MIME 类型（如果未指定类型，则返回 null）

getEncoding

String getEncoding()
返回此 XMLObject 的编码 URI。编码 URI 标识编码该对象的方法。

返回：
编码 URI（如果未指定该 URI，则返回 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLSignature (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 XMLSignature

所有超级接口：
XMLStructure
public interface XMLSignature
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Signature 元素的表示形式。此类包含一些方法使用 W3C 规范定义的行为对 XML 签名进行签名或验证。XML Schema Definition 的定义如下：

<element name="Signature" type="ds:SignatureType"/>
<complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>

通过调用 XMLSignatureFactory 类的一个 newXMLSignature 方法，可以创建 XMLSignature 实例。

如果随后修改了包含 XMLSignature 的底层文档的内容，则行为是不确定的。

注意，为避免与现有 java.security.Signature 类发生命名冲突，此类被命名为 XMLSignature，而不是 Signature。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.newXMLSignature(SignedInfo, KeyInfo), XMLSignatureFactory.newXMLSignature(SignedInfo, KeyInfo, List, String, String)

嵌套类摘要
static interface XMLSignature.SignatureValue
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureValue 元素的表示形式。
字段摘要
static String XMLNS
W3C Recommendation for XML-Signature Syntax and Processing 的 XML 名称空间 URI。
方法摘要
String | getId() 返回此 XMLSignature 的可选 Id。
KeyInfo | getKeyInfo() 返回此 XMLSignature 的密钥信息。
KeySelectorResult | getKeySelectorResult() 在对此 XMLSignature 进行签名或验证后，返回密钥选择器 KeySelector（如果已指定）的结果。
List | getObjects() 返回一个可修改的列表，由包含在此 XMLSignature 中的 XMLObject 组成。
XMLSignature.SignatureValue | getSignatureValue() 返回此 XMLSignature 的签名值。
SignedInfo | getSignedInfo() 返回此 XMLSignature 的签名信息。
void | sign(XMLSignContext signContext) 为此 XMLSignature 签名。
boolean | validate(XMLValidateContext validateContext) 根据核心验证处理规则来验证签名。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

字段详细信息

XMLNS

static final String XMLNS
W3C Recommendation for XML-Signature Syntax and Processing 的 XML 名称空间 URI。

另请参见：
常量字段值
方法详细信息

validate

boolean validate(XMLValidateContext validateContext)
                 throws XMLSignatureException
根据核心验证处理规则来验证签名。此方法使用现有状态验证签名，它并没有使用在上下文中指定的位置信息来解组和重新初始化 XMLSignature 的内容。

此方法只在第一次调用时验证签名。在后续调用时，它将返回一个缓存的结果。

参数：
validateContext - 验证的上下文
返回：
如果签名传递了核心验证，则返回 true，否则返回 false
抛出：
ClassCastException - 如果 validateContext 类型与此 XMLSignature 不兼容
NullPointerException - 如果 validateContext 为 null
XMLSignatureException - 如果验证期间出现不可预料的错误，从而阻止完成验证操作

getKeyInfo

KeyInfo getKeyInfo()
返回此 XMLSignature 的密钥信息。

返回：
密钥信息（如果未指定该信息，则返回 null）

getSignedInfo

SignedInfo getSignedInfo()
返回此 XMLSignature 的签名信息。

返回：
签名信息（永远不能为 null）

getObjects

List getObjects()
返回一个可修改的列表，由包含在此 XMLSignature 中的 XMLObject 组成。

返回：
一个不可修改的 XMLObject 列表（可以为空，但不能为 null）

getId

String getId()
返回此 XMLSignature 的可选 Id。

返回：
Id（如果未指定此 Id，则可能返回 null）

getSignatureValue

XMLSignature.SignatureValue getSignatureValue()
返回此 XMLSignature 的签名值。

返回：
签名值

sign

void sign(XMLSignContext signContext)
          throws MarshalException,
                 XMLSignatureException
为此 XMLSignature 签名。

如果此方法抛出异常，则此 XMLSignature 和 signContext 参数将保持其调用前的状态。

参数：
signContext - 签名的上下文
抛出：
ClassCastException - 如果 signContext 类型与此 XMLSignature 不兼容
NullPointerException - 如果 signContext 为 null
MarshalException - 如果编组时出现异常
XMLSignatureException - 如果生成签名时出现不可预料的异常

getKeySelectorResult

KeySelectorResult getKeySelectorResult()
在对此 XMLSignature 进行签名或验证后，返回密钥选择器 KeySelector（如果已指定）的结果。

返回：
密钥选择器的结果；如果尚未指定密钥选择器，或尚未对此 XMLSignature 进行签名或验证，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLSignature.SignatureValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 XMLSignature.SignatureValue

所有超级接口：
XMLStructure
正在封闭接口：
XMLSignature
public static interface XMLSignature.SignatureValue
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureValue 元素的表示形式。XML Schema Definition 的定义如下：

<element name="SignatureValue" type="ds:SignatureValueType"/>
<complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>

方法摘要
String | getId() 返回此 SignatureValue 的可选 Id 属性，该属性允许从其他地方引用此元素。
byte[] | getValue() 返回此 SignatureValue 的签名值。
boolean | validate(XMLValidateContext validateContext) 验证签名值。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

方法详细信息

getId

String getId()
返回此 SignatureValue 的可选 Id 属性，该属性允许从其他地方引用此元素。

返回：
Id 属性（如果未指定，则返回 null）

getValue

byte[] getValue()
返回此 SignatureValue 的签名值。

返回：
签名值（如果尚未对 XMLSignature 进行签名，则返回 null）。每次调用此方法都将返回一个数组的新副本，以防止随后被修改。

validate

boolean validate(XMLValidateContext validateContext)
                 throws XMLSignatureException
验证签名值。此方法对根据 XMLSignature 的 SignedInfo 计算所得的签名执行加密验证。

此方法只在第一次调用时验证签名。在后续调用时，它将返回一个缓存的结果。

参数：
validateContext - 验证上下文
返回：
如果成功验证签名，则返回 true；否则返回 false
抛出：
NullPointerException - 如果 validateContext 为 null
XMLSignatureException - 如果验证签名时发生不可预料的异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLSignatureException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
类 XMLSignatureException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.crypto.dsig.XMLSignatureException
所有已实现的接口：
Serializable
public class XMLSignatureException
extends Exception

指示生成或验证 XML 签名过程中发生的异常条件。

XMLSignatureException 可以包含一个 cause：另一个导致抛出此 XMLSignatureException 的 throwable。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
XMLSignatureException()
构造用 null 作为其详细消息的新 XMLSignatureException。
XMLSignatureException(String message)
构造带指定详细消息的新 XMLSignatureException。
XMLSignatureException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 XMLSignatureException。
XMLSignatureException(Throwable cause)
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 XMLSignatureException（它通常包含 cause 的类和详细消息）。
方法摘要
Throwable | getCause() 返回此 XMLSignatureException 的 cause；如果 cause 不存在或未知，则返回 null。
void | printStackTrace() 将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
void | printStackTrace(PrintStream s) 将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。
void | printStackTrace(PrintWriter s) 将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XMLSignatureException

public XMLSignatureException()
构造用 null 作为其详细消息的新 XMLSignatureException。

XMLSignatureException

public XMLSignatureException(String message)
构造带指定详细消息的新 XMLSignatureException。

参数：
message - 详细消息

XMLSignatureException

public XMLSignatureException(String message,
                             Throwable cause)
构造一个带指定详细消息和 cause 的新 XMLSignatureException。

注意，与 cause 相关的详细消息不是自动合并到此异常的详细消息中的。

参数：
message - 详细消息
cause - cause（允许为 null 值，指示原因不存在或未知。）

XMLSignatureException

public XMLSignatureException(Throwable cause)
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 XMLSignatureException（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（允许为 null 值，指示原因不存在或未知。）
方法详细信息

getCause

public Throwable getCause()
返回此 XMLSignatureException 的 cause；如果 cause 不存在或未知，则返回 null。（cause 是导致抛出此 XMLSignatureException 的 throwable。）

覆盖：
类 Throwable 中的 getCause
返回：
导致抛出此 XMLSignatureException 的 cause，如果 cause 不存在或未知，则返回 null。

printStackTrace

public void printStackTrace()
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintStream s)
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace(PrintWriter s)
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 用于输出的 PrintWriter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLSignContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 XMLSignContext

所有超级接口：
XMLCryptoContext
所有已知实现类：
DOMSignContext
public interface XMLSignContext
extends XMLCryptoContext

包含用于生成 XML Signature 的上下文信息。使用此接口主要是为了获得类型安全。

注意，XMLSignContext 实例可以包含特定于与其一起使用的 XML 签名结构的信息和状态。如果 XMLSignContext 与不同的签名结构一起使用（例如，不应该使用相同的 XMLSignContext 实例对两个不同的 XMLSignature 对象进行签名），则结果是不可预料的。

支持的属性

使用 setProperty 方法可以对以下属性进行设置：

  • javax.xml.crypto.dsig.cacheReference：值必须是一个 Boolean。此属性控制已分类的 Reference 对象是否将通过 Reference.getDereferencedData 和 Reference.getDigestInputStream 方法来缓存已取消引用的内容以及后续检索的预分类输入。如果没有指定，则默认值为 Boolean.FALSE。

从以下版本开始：
1.6
另请参见：
XMLSignature.sign(XMLSignContext)

方法摘要
从接口 javax.xml.crypto.XMLCryptoContext 继承的方法
get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLSignatureFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
类 XMLSignatureFactory

java.lang.Object
    继承者  javax.xml.crypto.dsig.XMLSignatureFactory

public abstract class XMLSignatureFactory
extends Object

用于从头创建 XMLSignature 对象或从相应的 XML 表示形式解组 XMLSignature 对象的工厂。

XMLSignatureFactory 类型

每个 XMLSignatureFactory 实例都支持一个特定的 XML 机制类型。要创建 XMLSignatureFactory，则需要调用一个静态 getInstance 方法，以传入所需的 XML 机制类型，例如：

XMLSignatureFactory factory = XMLSignatureFactory.getInstance("DOM");

此工厂生成的对象将基于 DOM 并遵守 DOM 互操作性要求，正如 API 概述的 DOM Mechanism Requirements 部分中所定义的。标准机制类型列表，请参阅 API 概述的 Service Providers 部分。

使用 Provider 机制来注册和加载 XMLSignatureFactory 实现。例如，支持 DOM 机制的服务提供者将在 Provider 子类中指定，如下所示：

put("XMLSignatureFactory.DOM", "org.example.DOMXMLSignatureFactory");

实现至少必须支持默认的机制类型：DOM。

注意，调用者必须使用相同的 XMLSignatureFactory 实例来创建要生成的特定 XMLStructure 的 XMLSignature。如果同时使用取自不同提供者或不同机制类型的 XMLStructure，则行为是不明确的。

同时，由此工厂创建的 XMLStructure 可能包含特定于 XMLSignature 的状态，并且该状态是不可重用的。

从头创建 XMLSignature

创建了 XMLSignatureFactory 后，就可以通过调用适当的方法来实例化这些对象。例如，可以通过调用一个 newReference 方法来创建 Reference 实例。

从 XML 解组 XMLSignature

此外，通过调用 unmarshalXMLSignature 方法，并向其传递包含 XML 内容的特定于机制的 XMLValidateContext 实例，可以从现有 XML 表示形式创建 XMLSignature：

DOMValidateContext context = new DOMValidateContext(key, signatureElement);
XMLSignature signature = factory.unmarshalXMLSignature(context);
每个 XMLSignatureFactory 都必须支持该工厂类型所需的 XMLValidateContext 类型，但也可以支持其他类型。DOM XMLSignatureFactory 必须支持 DOMValidateContext 对象。

将 XMLSignatures 签名并编组到 XML

通过调用 XMLSignature 对象的 sign 方法，并向其传递包含签名密钥和编组参数（参见 DOMSignContext）的特定于机制的 XMLSignContext 对象，可以将工厂创建的每个 XMLSignature 编组为 XML 表示形式并对其进行签名。例如：
DOMSignContext context = new DOMSignContext(privateKey, document);
signature.sign(context);
并发访问

可保证此类的静态方法是线程安全的。多个线程可以并发调用此类中所定义的静态方法，而不会产生不良效果。

但是，对于此类所定义的非静态方法并非如此。除非具体的提供者另行指定，否则需要并发访问单个 XMLSignatureFactory 实例的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同 XMLSignatureFactory 实例的多个线程而言，无需实现同步。

从以下版本开始：
1.6

构造方法摘要
protected XMLSignatureFactory()
默认的构造方法，由子类调用。
方法摘要
static XMLSignatureFactory | getInstance() 返回支持默认的 XML 处理机制和表示形式类型（“DOM”） 的 XMLSignatureFactory。
static XMLSignatureFactory | getInstance(String mechanismType) 返回 XMLSignatureFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
static XMLSignatureFactory | getInstance(String mechanismType, Provider provider) 返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
static XMLSignatureFactory | getInstance(String mechanismType, String provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
KeyInfoFactory | getKeyInfoFactory() 返回创建 KeyInfo 对象的 KeyInfoFactory。
String | getMechanismType() 返回此 XMLSignatureFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。
Provider | getProvider() 返回此 XMLSignatureFactory 的提供者。
abstract URIDereferencer | getURIDereferencer() 返回对 URIDereferencer 的引用，默认情况下该引用用于取消 Reference 对象中对 URI 的引用。
abstract boolean | isFeatureSupported(String feature) 指示是否支持指定的功能。
abstract CanonicalizationMethod | newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract CanonicalizationMethod | newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract DigestMethod | newDigestMethod(String algorithm, DigestMethodParameterSpec params) 针对指定的算法 URI 和参数创建 DigestMethod。
abstract Manifest | newManifest(List references) 创建包含指定的 Reference 列表的 Manifest。
abstract Manifest | newManifest(List references, String id) 创建包含指定的 Reference 列表和可选 id 的 Manifest。
abstract Reference | newReference(String uri, DigestMethod dm) 创建带指定 URI 和摘要方法的 Reference。
abstract Reference | newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | newReference(String uri, DigestMethod dm, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue) 创建带指定参数和预计算的摘要值的 Reference。
abstract SignatureMethod | newSignatureMethod(String algorithm, SignatureMethodParameterSpec params) 针对指定的算法 URI 和参数创建 SignatureMethod。
abstract SignatureProperties | newSignatureProperties(List properties, String id) 创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。
abstract SignatureProperty | newSignatureProperty(List content, String target, String id) 创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。
abstract SignedInfo | newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。
abstract Transform | newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。
abstract Transform | newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。
abstract XMLObject | newXMLObject(List content, String id, String mimeType, String encoding) 根据指定参数创建 XMLObject。
abstract XMLSignature | newXMLSignature(SignedInfo si, KeyInfo ki) 创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
abstract XMLSignature | newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。
abstract XMLSignature | unmarshalXMLSignature(XMLStructure xmlStructure) 从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。
abstract XMLSignature | unmarshalXMLSignature(XMLValidateContext context) 从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLSignatureFactory

protected XMLSignatureFactory()
默认的构造方法，由子类调用。

方法详细信息

getInstance

public static XMLSignatureFactory getInstance(String mechanismType)
返回 XMLSignatureFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。

此方法使用标准的 JCA 提供者查找机制来查找并实例化所需机制类型的 XMLSignatureFactory 实现。它将从首选的 Provider 开始，遍历已注册的安全 Provider 的列表。返回取自第一个支持指定机制的 Provider 中的新 XMLSignatureFactory 对象。

注意，已注册提供者的列表可以通过 Security.getProviders() 方法获得。

参数：
mechanismType - XML 处理机制和表示形式的类型。有关标准机制类型列表，请参阅 API 概述的 Service Providers 部分。
返回：
新的 XMLSignatureFactory
抛出：
NullPointerException - 如果 mechanismType 为 null
NoSuchMechanismException - 如果没有任何 Provider 支持指定机制的 XMLSignatureFactory 实现
另请参见：
Provider

getInstance

public static XMLSignatureFactory getInstance(String mechanismType,
                                              Provider provider)
返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。注意，指定的 Provider 对象不必已经在提供者列表中注册。

参数：
mechanismType - XML 处理机制和表示形式的类型。有关标准机制类型列表，请参阅 API 概述的 Service Providers 部分。
provider - Provider 对象
返回：
新的 XMLSignatureFactory
抛出：
NullPointerException - 如果 provider 或 mechanismType 为 null
NoSuchMechanismException - 如果不能从指定的 Provider 对象得到指定机制的 XMLSignatureFactory 实现
另请参见：
Provider

getInstance

public static XMLSignatureFactory getInstance(String mechanismType,
                                              String provider)
                                       throws NoSuchProviderException
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。指定的提供者必须已在安全提供者列表中注册。

注意，已注册提供者的列表可以通过 Security.getProviders() 方法获得。

参数：
mechanismType - XML 处理机制和表示形式的类型。有关标准机制类型列表，请参阅 API 概述的 Service Providers 部分。
provider - 提供者的字符串名称
返回：
新的 XMLSignatureFactory
抛出：
NoSuchProviderException - 如果指定的提供者没有在安全提供者列表中进行注册
NullPointerException - 如果 provider 或 mechanismType 为 null
NoSuchMechanismException - 如果从指定的提供者不能得到指定机制的 XMLSignatureFactory 实现
另请参见：
Provider

getInstance

public static XMLSignatureFactory getInstance()
返回支持默认的 XML 处理机制和表示形式类型（“DOM”） 的 XMLSignatureFactory。

此方法使用标准的 JCA 提供者查找机制来查找并实例化默认机制类型的 XMLSignatureFactory 实现。它将从首选的 Provider 开始，遍历已注册的安全 Provider 的列表。返回取自第一个支持 DOM 机制的Provider 中的新 XMLSignatureFactory 对象。

注意，已注册提供者的列表可以通过 Security.getProviders() 方法获得。

返回：
新的 XMLSignatureFactory
抛出：
NoSuchMechanismException - 如果没有任何 Provider 支持 DOM 机制的 XMLSignatureFactory 实现
另请参见：
Provider

getMechanismType

public final String getMechanismType()
返回此 XMLSignatureFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。

返回：
此 XMLSignatureFactory 支持的 XML 处理机制类型

getProvider

public final Provider getProvider()
返回此 XMLSignatureFactory 的提供者。

返回：
此 XMLSignatureFactory 的提供者

newXMLSignature

public abstract XMLSignature newXMLSignature(SignedInfo si,
                                             KeyInfo ki)
创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。

参数：
si - 签名信息
ki - 密钥信息（可能为 null）
返回：
XMLSignature
抛出：
NullPointerException - 如果 si 为 null

newXMLSignature

public abstract XMLSignature newXMLSignature(SignedInfo si,
                                             KeyInfo ki,
                                             List objects,
                                             String id,
                                             String signatureValueId)
创建一个 XMLSignature，并使用指定的参数对其进行初始化。

参数：
si - 签名信息
ki - 密钥信息（可以为 null）
objects - XMLObject 列表（可以为空或 null）
id - Id（可以为 null）
signatureValueId - SignatureValue Id（可以为 null）
返回：
XMLSignature
抛出：
NullPointerException - 如果 si 为 null
ClassCastException - 如果有些 objects 的类型不是 XMLObject

newReference

public abstract Reference newReference(String uri,
                                       DigestMethod dm)
创建带指定 URI 和摘要方法的 Reference。

参数：
uri - 引用 URI（可以为 null）
dm - 摘要方法
返回：
Reference
抛出：
IllegalArgumentException - 如果 uri 与 RFC 2396 不兼容
NullPointerException - 如果 dm 为 null

newReference

public abstract Reference newReference(String uri,
                                       DigestMethod dm,
                                       List transforms,
                                       String type,
                                       String id)
创建带指定参数的 Reference。

参数：
uri - 引用 URI（可以为 null）
dm - 摘要方法
transforms - Transform 列表。需要复制该列表，以防止随后被修改。可以为 null 或空。
type - URI 形式的引用类型（可以为 null）
id - 引用 ID（可以为 null）
返回：
Reference
抛出：
ClassCastException - 如果有些 transforms 的类型不是 Transform
IllegalArgumentException - 如果 uri 与 RFC 2396 不兼容
NullPointerException - 如果 dm 为 null

newReference

public abstract Reference newReference(String uri,
                                       DigestMethod dm,
                                       List transforms,
                                       String type,
                                       String id,
                                       byte[] digestValue)
创建带指定参数和预计算的摘要值的 Reference。

如果先前已经计算了 Reference 的摘要值，则此方法很有用。有关示例，请参阅 OASIS-DSS（数字签名服务）规范。

参数：
uri - 引用 URI（可以为 null）
dm - 摘要方法
transforms - Transform 列表。需要复制该列表，以防止随后被修改。可以为 null 或空。
type - URI 形式的引用类型（可以为 null）
id - 引用 ID（可以为 null）
digestValue - 摘要值。复制该数组，以防止随后被修改。
返回：
Reference
抛出：
ClassCastException - 如果任何 transforms 的类型不是 Transform
IllegalArgumentException - 如果 uri 与 RFC 2396 不兼容
NullPointerException - 如果 dm 或 digestValue 为 null

newReference

public abstract Reference newReference(String uri,
                                       DigestMethod dm,
                                       List appliedTransforms,
                                       Data result,
                                       List transforms,
                                       String type,
                                       String id)
创建带指定参数的 Reference。

在已将转换列表应用于 Reference 时，此方法很有用。例如，请参阅 OASIS-DSS（数字签名服务）规范。

生成了包含此引用的 XMLSignature 之后，将指定的 transforms（如果为非空）应用于指定的 result。所得 Reference 元素的 Transforms 元素被设置为 appliedTransforms 和 transforms 的串联。

参数：
uri - 引用 URI（可以为 null）
dm - 摘要方法
appliedTransforms - 已应用的 Transform 的列表。需要复制该列表，以防止随后被修改。列表至少必须包含一个条目。
result - 处理 appliedTransforms 的序列的结果
transforms - 生成签名时将应用的 Transform 的列表。需要复制该列表，以防止随后被修改。可以为 null 或空。
type - URI 形式的引用类型（可以为 null）
id - 引用 ID（可以为 null）
返回：
Reference
抛出：
ClassCastException - 如果任何转换（任一列表中）的类型不是 Transform
IllegalArgumentException - 如果 uri 与 RFC 2396 不兼容或 appliedTransforms 为空
NullPointerException - 如果 dm、appliedTransforms 或 result 为 null

newSignedInfo

public abstract SignedInfo newSignedInfo(CanonicalizationMethod cm,
                                         SignatureMethod sm,
                                         List references)
创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。

参数：
cm - 规范化方法
sm - 签名方法
references - 一个列表，由一个或多个 Reference 组成。需要复制该列表，以防止随后被修改。
返回：
SignedInfo
抛出：
ClassCastException - 如果任何引用的类型不是 Reference
IllegalArgumentException - 如果 references 为空
NullPointerException - 如果任何参数为 null

newSignedInfo

public abstract SignedInfo newSignedInfo(CanonicalizationMethod cm,
                                         SignatureMethod sm,
                                         List references,
                                         String id)
创建带指定参数的 SignedInfo。

参数：
cm - 规范化方法
sm - 签名方法
references - 一个列表，由一个或多个 Reference 组成。需要复制该列表，以防止随后被修改。
id - id（可以为 null）
返回：
SignedInfo
抛出：
ClassCastException - 如果任何引用的类型不是 Reference
IllegalArgumentException - 如果 references 为空
NullPointerException - 如果 cm、sm 或 references 为 null

newXMLObject

public abstract XMLObject newXMLObject(List content,
                                       String id,
                                       String mimeType,
                                       String encoding)
根据指定参数创建 XMLObject。

参数：
content - XMLStructure 的列表。需要复制该列表，以防止随后被修改。可以为 null 或空。
id - Id（可以为 null）
mimeType - MIME 类型（可以为 null）
encoding - 编码（可以为 null）
返回：
XMLObject
抛出：
ClassCastException - 如果 content 包含任何类型不是 XMLStructure 的条目

newManifest

public abstract Manifest newManifest(List references)
创建包含指定的 Reference 列表的 Manifest。

参数：
references - 一个列表，由一个或多个 Reference 组成。需要复制该列表，以防止随后被修改。
返回：
Manifest
抛出：
NullPointerException - 如果 references 为 null
IllegalArgumentException - 如果 references 为空
ClassCastException - 如果 references 包含任何类型不是 Reference 的条目

newManifest

public abstract Manifest newManifest(List references,
                                     String id)
创建包含指定的 Reference 列表和可选 id 的 Manifest。

参数：
references - 一个列表，由一个或多个 Reference 组成。需要复制该列表，以防止随后被修改。
id - id（可以为 null）
返回：
Manifest
抛出：
NullPointerException - 如果 references 为 null
IllegalArgumentException - 如果 references 为空
ClassCastException - 如果 references 包含任何类型不是 Reference 的条目

newSignatureProperty

public abstract SignatureProperty newSignatureProperty(List content,
                                                       String target,
                                                       String id)
创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。

参数：
content - 一个列表，由一个或多个 XMLStructure 组成。需要复制该列表，以防止随后被修改。
target - 使用此属性的 Signature 的目标 URI
id - id（可以为 null）
返回：
SignatureProperty
抛出：
NullPointerException - 如果 content 或 target 为 null
IllegalArgumentException - 如果 content 为空
ClassCastException - 如果 content 包含任何类型不是 XMLStructure 的条目

newSignatureProperties

public abstract SignatureProperties newSignatureProperties(List properties,
                                                           String id)
创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。

参数：
properties - 一个列表，由一个或多个 SignatureProperty 组成。需要复制该列表，以防止随后被修改。
id - id（可以为 null）
返回：
SignatureProperties
抛出：
NullPointerException - 如果 properties 为 null
IllegalArgumentException - 如果 properties 为空
ClassCastException - 如果 properties 包含任何类型不是 SignatureProperty 的条目

newDigestMethod

public abstract DigestMethod newDigestMethod(String algorithm,
                                             DigestMethodParameterSpec params)
                                      throws NoSuchAlgorithmException,
                                             InvalidAlgorithmParameterException
针对指定的算法 URI 和参数创建 DigestMethod。

参数：
algorithm - 标识摘要算法的 URI
params - 特定于算法的摘要参数（可以为 null）
返回：
DigestMethod
抛出：
InvalidAlgorithmParameterException - 如果指定的参数不适合请求的算法
NoSuchAlgorithmException - 如果无法找到指定算法的实现
NullPointerException - 如果 algorithm 为 null

newSignatureMethod

public abstract SignatureMethod newSignatureMethod(String algorithm,
                                                   SignatureMethodParameterSpec params)
                                            throws NoSuchAlgorithmException,
                                                   InvalidAlgorithmParameterException
针对指定的算法 URI 和参数创建 SignatureMethod。

参数：
algorithm - 标识签名算法的 URI
params - 特定于算法的签名参数（可以为 null）
返回：
SignatureMethod
抛出：
InvalidAlgorithmParameterException - 如果指定的参数不适合请求的算法
NoSuchAlgorithmException - 如果无法找到指定算法的实现
NullPointerException - 如果 algorithm 为 null

newTransform

public abstract Transform newTransform(String algorithm,
                                       TransformParameterSpec params)
                                throws NoSuchAlgorithmException,
                                       InvalidAlgorithmParameterException
针对指定的算法 URI 和参数创建 Transform。

参数：
algorithm - 标识转换算法的 URI
params - 特定于算法的转换参数（可以为 null）
返回：
Transform
抛出：
InvalidAlgorithmParameterException - 如果指定的参数不适合请求的算法
NoSuchAlgorithmException - 如果无法找到指定算法的实现
NullPointerException - 如果 algorithm 为 null

newTransform

public abstract Transform newTransform(String algorithm,
                                       XMLStructure params)
                                throws NoSuchAlgorithmException,
                                       InvalidAlgorithmParameterException
针对指定的算法 URI 和参数创建 Transform。该参数被指定为特定于机制的 XMLStructure（比如：DOMStructure）。当参数是 XML 形式或没有任何用于指定参数的标准类时，此方法很有用。

参数：
algorithm - 标识转换算法的 URI
params - 从中解组参数的特定于机制的 XML 结构（如果该结构不是必需的或是可选的，则此参数为 null）
返回：
Transform
抛出：
ClassCastException - 如果 params 类型不适合此 XMLSignatureFactory
InvalidAlgorithmParameterException - 如果指定的参数不适合请求的算法
NoSuchAlgorithmException - 如果无法找到指定算法的实现
NullPointerException - 如果 algorithm 为 null

newCanonicalizationMethod

public abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm,
                                                                 C14NMethodParameterSpec params)
                                                          throws NoSuchAlgorithmException,
                                                                 InvalidAlgorithmParameterException
针对指定的算法 URI 和参数创建 CanonicalizationMethod。

参数：
algorithm - 标识规范化算法的 URI
params - 特定于算法的规范化参数（可以为 null）
返回：
CanonicalizationMethod
抛出：
InvalidAlgorithmParameterException - 如果指定的参数不适合请求的算法
NoSuchAlgorithmException - 如果无法找到指定算法的实现
NullPointerException - 如果 algorithm 为 null

newCanonicalizationMethod

public abstract CanonicalizationMethod newCanonicalizationMethod(String algorithm,
                                                                 XMLStructure params)
                                                          throws NoSuchAlgorithmException,
                                                                 InvalidAlgorithmParameterException
针对指定的算法 URI 和参数创建 CanonicalizationMethod。该参数被指定为特定于机制的 XMLStructure（比如：DOMStructure）。当参数是 XML 形式或没有任何用于指定参数的标准类时，此方法很有用。

参数：
algorithm - 标识规范化算法的 URI
params - 从中解组参数的特定于机制的 XML 结构（如果该结构不是必需的或是可选的，则此参数为 null）
返回：
CanonicalizationMethod
抛出：
ClassCastException - 如果 params 类型不适合此 XMLSignatureFactory
InvalidAlgorithmParameterException - 如果指定的参数不适合请求的算法
NoSuchAlgorithmException - 如果无法找到指定算法的实现
NullPointerException - 如果 algorithm 为 null

getKeyInfoFactory

public final KeyInfoFactory getKeyInfoFactory()
返回创建 KeyInfo 对象的 KeyInfoFactory。返回的 KeyInfoFactory 具有与此 XMLSignatureFactory 相同的机制类型和提供者。

返回：
KeyInfoFactory
抛出：
NoSuchMechanismException - 如果具有相同机制类型和提供者的 KeyFactory 实现不可用

unmarshalXMLSignature

public abstract XMLSignature unmarshalXMLSignature(XMLValidateContext context)
                                            throws MarshalException
从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。

参数：
context - 从中解组签名的特定于机制的上下文
返回：
XMLSignature
抛出：
NullPointerException - 如果 context 为 null
ClassCastException - 如果 context 类型不适合此工厂
MarshalException - 如果解组过程中发生不可恢复的异常

unmarshalXMLSignature

public abstract XMLSignature unmarshalXMLSignature(XMLStructure xmlStructure)
                                            throws MarshalException
从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。如果只想解组（且不验证） XMLSignature 时，此方法很有用。

参数：
xmlStructure - 从中解组签名的特定于机制的 XML 结构
返回：
XMLSignature
抛出：
NullPointerException - 如果 xmlStructure 为 null
ClassCastException - 如果 xmlStructure 类型不适合此工厂
MarshalException - 如果解组过程中发生不可恢复的异常。

isFeatureSupported

public abstract boolean isFeatureSupported(String feature)
指示是否支持指定的功能。

参数：
feature - 功能名称（作为抽象 URI）
返回：
如果支持指定功能，则返回 true，否则返回 false
抛出：
NullPointerException - 如果 feature 为 null

getURIDereferencer

public abstract URIDereferencer getURIDereferencer()
返回对 URIDereferencer 的引用，默认情况下该引用用于取消 Reference 对象中对 URI 的引用。

返回：
对默认 URIDereferencer 的引用（不能为 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLValidateContext (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig
接口 XMLValidateContext

所有超级接口：
XMLCryptoContext
所有已知实现类：
DOMValidateContext
public interface XMLValidateContext
extends XMLCryptoContext

包含用于验证 XML Signature 的上下文信息。使用此接口主要是为了获得类型安全。

注意，XMLValidateContext 实例可以包含特定于与其一起使用的 XML 签名结构的信息和状态。如果 XMLValidateContext 与不同的签名结构一起使用（例如，不应该使用相同的 XMLValidateContext 实例来验证两个不同的 XMLSignature 对象），则结果是不可预料的。

支持的属性

应用程序可以使用 setProperty 方法对以下属性进行设置：

  • javax.xml.crypto.dsig.cacheReference：值必须是一个 Boolean。此属性控制 Reference.validate 方法是否通过 Reference.getDereferencedData 和 Reference.getDigestInputStream 方法来缓存已取消引用的内容和后续检索的预分类输入。如果没有指定，则默认值为 Boolean.FALSE。

从以下版本开始：
1.6
另请参见：
XMLSignature.validate(XMLValidateContext), Reference.validate(XMLValidateContext)

方法摘要
从接口 javax.xml.crypto.XMLCryptoContext 继承的方法
get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.crypto.dsig (Java Platform SE 6)

 javax.xml.crypto.dsig
接口
CanonicalizationMethod
DigestMethod
Manifest
Reference
SignatureMethod
SignatureProperties
SignatureProperty
SignedInfo
Transform
XMLObject
XMLSignature
XMLSignature.SignatureValue
XMLSignContext
XMLValidateContext
类
TransformService
XMLSignatureFactory
异常
TransformException
XMLSignatureException


javax.xml.crypto.dsig (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.crypto.dsig

用于生成和验证 XML 数字签名的类。

请参见：
描述

接口摘要
CanonicalizationMethod | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。
DigestMethod | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。
Manifest | 在 W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Manifest 元素的表示形式。
Reference | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。
SignatureMethod | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。
SignatureProperties | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperties 元素的表示形式。
SignatureProperty | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperty 元素的表示形式。
SignedInfo | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignedInfo 元素的表示形式。
Transform | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。
XMLObject | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Object 元素的表示形式。
XMLSignature | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Signature 元素的表示形式。
XMLSignature.SignatureValue | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureValue 元素的表示形式。
XMLSignContext | 包含用于生成 XML Signature 的上下文信息。
XMLValidateContext | 包含用于验证 XML Signature 的上下文信息。

类摘要
TransformService | 转换算法和规范算法的服务提供者接口。
XMLSignatureFactory | 用于从头创建 XMLSignature 对象或从相应的 XML 表示形式解组 XMLSignature 对象的工厂。

异常摘要
TransformException | 指示执行转换算法时出现异常的异常条件。
XMLSignatureException | 指示生成或验证 XML 签名过程中发生的异常条件。

软件包 javax.xml.crypto.dsig 的描述

用于生成和验证 XML 数字签名的类。此包包括那些表示 W3C XML 数字签名规范中定义的核心元素的类：XMLSignature、SignedInfo、CanonicalizationMethod、SignatureMethod、Reference、DigestMethod、XMLObject、Manifest、SignatureProperties 和 SignatureProperty。在 javax.xml.crypto.dsig.keyinfo 子包中定义了 KeyInfo 类型。XMLSignatureFactory 是一个抽象工厂，它将从头或根据已有 XML 表示形式（如 DOM 节点）创建 XMLSignature 对象。TransformService 是一个服务提供者接口，用于创建并插入转换算法和规范化算法的实现。

此包的主要意义在于 XMLSignature 类，该类允许签名并验证 XML 数字签名。

包规范

  • XML-Signature Syntax and Processing:W3C Recommendation
  • RFC 3275:XML-Signature Syntax and Processing

Since:
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.crypto.dsig 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dsig 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.crypto.dsig.TransformException
        • javax.xml.crypto.dsig.XMLSignatureException
    • javax.xml.crypto.dsig.TransformService (implements javax.xml.crypto.dsig.Transform)
    • javax.xml.crypto.dsig.XMLSignatureFactory

接口分层结构

  • javax.xml.crypto.AlgorithmMethod
    • javax.xml.crypto.dsig.DigestMethod (并 extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.SignatureMethod (并 extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.Transform (并 extends javax.xml.crypto.XMLStructure)
      • javax.xml.crypto.dsig.CanonicalizationMethod
  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dsig.Reference (并 extends javax.xml.crypto.XMLStructure)
  • javax.xml.crypto.XMLCryptoContext
    • javax.xml.crypto.dsig.XMLSignContext
    • javax.xml.crypto.dsig.XMLValidateContext
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.DigestMethod (并 extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.Manifest
    • javax.xml.crypto.dsig.Reference (并 extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.SignatureMethod (并 extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.SignatureProperties
    • javax.xml.crypto.dsig.SignatureProperty
    • javax.xml.crypto.dsig.SignedInfo
    • javax.xml.crypto.dsig.Transform (并 extends javax.xml.crypto.AlgorithmMethod)
      • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.XMLObject
    • javax.xml.crypto.dsig.XMLSignature
    • javax.xml.crypto.dsig.XMLSignature.SignatureValue
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.crypto.dsig 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dsig
的使用

使用 javax.xml.crypto.dsig 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig 使用的 javax.xml.crypto.dsig 中的类
CanonicalizationMethod
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。
DigestMethod
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。
Manifest
在 W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Manifest 元素的表示形式。
Reference
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。
SignatureMethod
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。
SignatureProperties
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperties 元素的表示形式。
SignatureProperty
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperty 元素的表示形式。
SignedInfo
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignedInfo 元素的表示形式。
Transform
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。
TransformException
指示执行转换算法时出现异常的异常条件。
TransformService
转换算法和规范算法的服务提供者接口。
XMLObject
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Object 元素的表示形式。
XMLSignature
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Signature 元素的表示形式。
XMLSignature.SignatureValue
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureValue 元素的表示形式。
XMLSignatureException
指示生成或验证 XML 签名过程中发生的异常条件。
XMLSignatureFactory
用于从头创建 XMLSignature 对象或从相应的 XML 表示形式解组 XMLSignature 对象的工厂。
XMLSignContext
包含用于生成 XML Signature 的上下文信息。
XMLValidateContext
包含用于验证 XML Signature 的上下文信息。

javax.xml.crypto.dsig.dom 使用的 javax.xml.crypto.dsig 中的类
XMLSignContext
包含用于生成 XML Signature 的上下文信息。
XMLValidateContext
包含用于验证 XML Signature 的上下文信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DOMSignContext (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.dom
类 DOMSignContext

java.lang.Object
    继承者  javax.xml.crypto.dom.DOMCryptoContext
        继承者  javax.xml.crypto.dsig.dom.DOMSignContext
所有已实现的接口：
XMLSignContext, XMLCryptoContext
public class DOMSignContext
extends DOMCryptoContext
implements XMLSignContext

特定于 DOM 的 XMLSignContext。此类包含一些其他方法，用来指定生成签名时被编组的 XMLSignature 对象在 DOM 树中的位置。

注意，DOMSignContext 实例可以包含特定于与其一起使用的 XML 签名结构的信息和状态。如果 DOMSignContext 与不同的签名结构一起使用（例如，不应该使用相同的 DOMSignContext 实例对两个不同的 XMLSignature 对象进行签名），则结果是不可预料的。

从以下版本开始：
1.6

构造方法摘要
DOMSignContext(Key signingKey, Node parent)
创建带有指定签名密钥和父节点的 DOMSignContext。
DOMSignContext(Key signingKey, Node parent, Node nextSibling)
创建带有指定的签名密钥、父节点和下一个兄弟节点的 DOMSignContext。
DOMSignContext(KeySelector ks, Node parent)
创建带有指定密钥选择器和父节点的 DOMSignContext。
DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
创建带有指定密钥选择器、父节点和下一个兄弟节点的 DOMSignContext。
方法摘要
Node | getNextSibling() 返回 nextSibling 节点。
Node | getParent() 返回父节点。
void | setNextSibling(Node nextSibling) 设置下一个兄弟节点。
void | setParent(Node parent) 设置父节点。
从类 javax.xml.crypto.dom.DOMCryptoContext 继承的方法
get, getBaseURI, getDefaultNamespacePrefix, getElementById, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, iterator, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setIdAttributeNS, setKeySelector, setProperty, setURIDereferencer
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.xml.crypto.XMLCryptoContext 继承的方法
get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer

构造方法详细信息

DOMSignContext

public DOMSignContext(Key signingKey,
                      Node parent)
创建带有指定签名密钥和父节点的 DOMSignContext。签名密钥存储在 getKeySelector 方法返回的 singleton KeySelector 中。已编组的 XMLSignature 将被添加为指定父节点的最后一个子元素，除非调用 setNextSibling 方法指定了下一个兄弟节点。

参数：
signingKey - 签名密钥
parent - 父节点
抛出：
NullPointerException - 如果 signingKey 或 parent 为 null

DOMSignContext

public DOMSignContext(Key signingKey,
                      Node parent,
                      Node nextSibling)
创建带有指定的签名密钥、父节点和下一个兄弟节点的 DOMSignContext。签名密钥存储在 getKeySelector 方法返回的 singleton KeySelector 中。已编组的 XMLSignature 将插入为指定父节点的一个子元素，且位于指定的下一个兄弟节点前面。

参数：
signingKey - 签名密钥
parent - 父节点
nextSibling - 下一个兄弟节点
抛出：
NullPointerException - 如果 signingKey、parent 或 nextSibling 为 null

DOMSignContext

public DOMSignContext(KeySelector ks,
                      Node parent)
创建带有指定密钥选择器和父节点的 DOMSignContext。已编组的 XMLSignature 将添加为指定父节点的最后一个子元素，除非调用 setNextSibling 方法指定了下一个兄弟节点。

参数：
ks - 密钥选择器
parent - 父节点
抛出：
NullPointerException - 如果 ks 或 parent 为 null

DOMSignContext

public DOMSignContext(KeySelector ks,
                      Node parent,
                      Node nextSibling)
创建带有指定密钥选择器、父节点和下一个兄弟节点的 DOMSignContext。已编组的 XMLSignature 将插入为指定父节点的一个子元素，且位于指定的下一个兄弟节点前面。

参数：
ks - 密钥选择器
parent - 父节点
nextSibling - 下一个兄弟节点
抛出：
NullPointerException - 如果 ks、parent 或 nextSibling 为 null
方法详细信息

setParent

public void setParent(Node parent)
设置父节点。

参数：
parent - 父节点。已编组的 XMLSignature 将添加为此节点的子元素。
抛出：
NullPointerException - 如果 parent 为 null
另请参见：
getParent()

setNextSibling

public void setNextSibling(Node nextSibling)
设置下一个兄弟节点。

参数：
nextSibling - 下一个兄弟节点。已编组的 XMLSignature 将插入到此节点的前面。指定 null 表示移除当前设置。
另请参见：
getNextSibling()

getParent

public Node getParent()
返回父节点。

返回：
父节点（不能为 null）
另请参见：
setParent(Node)

getNextSibling

public Node getNextSibling()
返回 nextSibling 节点。

返回：
nextSibling 节点；如果没有指定，则返回 null。
另请参见：
setNextSibling(Node)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DOMValidateContext (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.dom
类 DOMValidateContext

java.lang.Object
    继承者  javax.xml.crypto.dom.DOMCryptoContext
        继承者  javax.xml.crypto.dsig.dom.DOMValidateContext
所有已实现的接口：
XMLValidateContext, XMLCryptoContext
public class DOMValidateContext
extends DOMCryptoContext
implements XMLValidateContext

特定于 DOM 的 XMLValidateContext。此类包含一些其他方法，用来指定在 DOM 树中对 XMLSignature 进行解组和验证的位置。

注意，如果调用者在创建 XMLSignature 之后对底层 DOM 树的内容进行修改，则已解组 XMLSignature 的行为是不确定的。

还要注意的是，DOMValidateContext 实例可以包含特定于与其一起使用的 XML 签名结构的信息和状态。如果 DOMValidateContext 与不同的签名结构一起使用（例如，不应该使用相同的 DOMValidateContext 实例来验证两个不同的 XMLSignature 对象），则结果是不可预料的。

从以下版本开始：
1.6
另请参见：
XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext)

构造方法摘要
DOMValidateContext(Key validatingKey, Node node)
创建包含指定密钥和节点的 DOMValidateContext。
DOMValidateContext(KeySelector ks, Node node)
创建包含指定密钥选择器和节点的 DOMValidateContext。
方法摘要
Node | getNode() 返回节点。
void | setNode(Node node) 设置节点。
从类 javax.xml.crypto.dom.DOMCryptoContext 继承的方法
get, getBaseURI, getDefaultNamespacePrefix, getElementById, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, iterator, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setIdAttributeNS, setKeySelector, setProperty, setURIDereferencer
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.xml.crypto.XMLCryptoContext 继承的方法
get, getBaseURI, getDefaultNamespacePrefix, getKeySelector, getNamespacePrefix, getProperty, getURIDereferencer, put, putNamespacePrefix, setBaseURI, setDefaultNamespacePrefix, setKeySelector, setProperty, setURIDereferencer

构造方法详细信息

DOMValidateContext

public DOMValidateContext(KeySelector ks,
                          Node node)
创建包含指定密钥选择器和节点的 DOMValidateContext。

参数：
ks - 用于查找验证密钥的密钥选择器
node - 节点
抛出：
NullPointerException - 如果 ks 或 node 为 null

DOMValidateContext

public DOMValidateContext(Key validatingKey,
                          Node node)
创建包含指定密钥和节点的 DOMValidateContext。验证密钥将存储在调用 getKeySelector 方法时返回的 singleton KeySelector 中。

参数：
validatingKey - 验证密钥
node - 节点
抛出：
NullPointerException - 如果 validatingKey 或 node 为 null
方法详细信息

setNode

public void setNode(Node node)
设置节点。

参数：
node - 节点
抛出：
NullPointerException - 如果 node 为 null
另请参见：
getNode()

getNode

public Node getNode()
返回节点。

返回：
节点（不能为 null）
另请参见：
setNode(Node)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.crypto.dsig.dom (Java Platform SE 6)

 javax.xml.crypto.dsig.dom
类
DOMSignContext
DOMValidateContext


javax.xml.crypto.dsig.dom (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.crypto.dsig.dom

javax.xml.crypto.dsig 包特定于 DOM 的类。

请参见：
描述

类摘要
DOMSignContext | 特定于 DOM 的 XMLSignContext。
DOMValidateContext | 特定于 DOM 的 XMLValidateContext。

软件包 javax.xml.crypto.dsig.dom 的描述

javax.xml.crypto.dsig 包特定于 DOM 的类。只有使用基于 DOM 的 XMLSignatureFactory 或 KeyInfoFactory 的用户才需要直接使用此包。

包规范

  • XML-Signature Syntax and Processing:W3C Recommendation
  • RFC 3275:XML-Signature Syntax and Processing

Since:
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.crypto.dsig.dom 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dsig.dom 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
      • javax.xml.crypto.dsig.dom.DOMSignContext (implements javax.xml.crypto.dsig.XMLSignContext)
      • javax.xml.crypto.dsig.dom.DOMValidateContext (implements javax.xml.crypto.dsig.XMLValidateContext)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.crypto.dsig.dom 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dsig.dom
的使用

没有 javax.xml.crypto.dsig.dom 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.dom.DOMSignContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.dom.DOMSignContext
的使用

没有 javax.xml.crypto.dsig.dom.DOMSignContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.dom.DOMValidateContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.dom.DOMValidateContext
的使用

没有 javax.xml.crypto.dsig.dom.DOMValidateContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


KeyInfo (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.keyinfo
接口 KeyInfo

所有超级接口：
XMLStructure
public interface KeyInfo
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。KeyInfo 包含 XMLStructure 的列表，其中每一个 XMLStructure 都包含支持接受方获取验证 XML 签名所需的密钥的信息。XML Schema Definition 的定义如下：

<element name="KeyInfo" type="ds:KeyInfoType"/>
<complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any processContents="lax" namespace="##other"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>
通过调用 KeyInfoFactory 类的 newKeyInfo 方法之一，并向其传递一个或多个 XMLStructure 列表以及一个可选的 id 参数，可以创建 KeyInfo 实例，例如：
KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
KeyInfo keyInfo = factory.newKeyInfo
        (Collections.singletonList(factory.newKeyName("Alice"), "keyinfo-1"));

还可以通过调用 marshal 方法将 KeyInfo 对象编组为 XML。

从以下版本开始：
1.6
另请参见：
KeyInfoFactory.newKeyInfo(List), KeyInfoFactory.newKeyInfo(List, String)

方法摘要
List | getContent() 返回包含密钥信息的 unmodifiable list。
String | getId() 返回此 KeyInfo 的可选 Id 属性，这对于从其他 XML 结构引用此 KeyInfo 可能很有用。
void | marshal(XMLStructure parent, XMLCryptoContext context) 将密钥信息编组为 XML。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

方法详细信息

getContent

List getContent()
返回包含密钥信息的 unmodifiable list。列表中的每一项都是一个 XMLStructure。

如果有一个表示 XMLStructure 类型的公共子类，那么它将作为该类的实例返回（比如：X509Data 元素将作为 X509Data 的实例返回）。

返回：
此 KeyInfo 中的一个或多个 XMLStructure 的不可修改列表。不会返回 null 或空列表。

getId

String getId()
返回此 KeyInfo 的可选 Id 属性，这对于从其他 XML 结构引用此 KeyInfo 可能很有用。

返回：
此 KeyInfo 的 Id 属性（如果未指定，则返回 null）

marshal

void marshal(XMLStructure parent,
             XMLCryptoContext context)
             throws MarshalException
将密钥信息编组为 XML。

参数：
parent - 特定于机制的结构，包含将追加已编组密钥信息中的父节点
context - 包含其他上下文的 XMLCryptoContext（如果不适用，则为 null）
抛出：
ClassCastException - 如果 parent 或 context 的类型与此密钥信息不兼容
MarshalException - 如果无法编组密钥信息
NullPointerException - 如果 parent 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


KeyInfoFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.keyinfo
类 KeyInfoFactory

java.lang.Object
    继承者  javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

public abstract class KeyInfoFactory
extends Object

用于从头创建 KeyInfo 对象或从相应的 XML 表示形式解组 KeyInfo 对象的工厂。

每个 KeyInfoFactory 实例都支持一个特定的 XML 机制类型。要创建 KeyInfoFactory，则需要调用一个静态 getInstance 方法，并传入所需的 XML 机制类型，例如：

KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");

此工厂生成的对象将基于 DOM 并遵守 DOM 互操作性要求，正如 API 概述的 DOM Mechanism Requirements 部分所定义的。有关标准机制类型列表，请参阅 API 概述的 Service Providers 部分。

使用 Provider 机制来注册和加载 KeyInfoFactory 实现。例如，支持 DOM 机制的服务提供者将在 Provider 子类中指定，如下所示：

   put("KeyInfoFactory.DOM", "org.example.DOMKeyInfoFactory");

同时，由此工厂创建的 XMLStructure 可能包含特定于 KeyInfo 的状态，并且该状态是不可重用的。

实现至少必须支持默认的机制类型：DOM。

注意，调用者必须使用相同的 KeyInfoFactory 实例来创建特定 KeyInfo 对象的 XMLStructure。如果同时使用来自不同提供者或不同机制类型的 XMLStructure，则行为是不明确的。

并发访问

可保证此类的静态方法是线程安全的。多个线程可以并发调用此类中所定义的静态方法，而不会产生不良效果。

但是，对于此类所定义的非静态方法并非如此。除非具体的提供者另行指定，否则需要并发访问单个 KeyInfoFactory 实例的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同 KeyInfoFactory 实例的多个线程而言，无需实现同步。

从以下版本开始：
1.6

构造方法摘要
protected KeyInfoFactory()
默认的构造方法，由子类调用。
方法摘要
static KeyInfoFactory | getInstance() 返回支持默认 XML 处理机制和表示形式类型（“DOM”） 的 KeyInfoFactory。
static KeyInfoFactory | getInstance(String mechanismType) 返回 KeyInfoFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
static KeyInfoFactory | getInstance(String mechanismType, Provider provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。
static KeyInfoFactory | getInstance(String mechanismType, String provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。
String | getMechanismType() 返回此 KeyInfoFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。
Provider | getProvider() 返回此 KeyInfoFactory 的提供者。
abstract URIDereferencer | getURIDereferencer() 返回对 URIDereferencer 的引用，默认情况下用于取消引用 RetrievalMethod 对象中的 URI。
abstract boolean | isFeatureSupported(String feature) 指示是否支持指定的功能。
abstract KeyInfo | newKeyInfo(List content) 创建包含指定的密钥信息类型列表的 KeyInfo。
abstract KeyInfo | newKeyInfo(List content, String id) 创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。
abstract KeyName | newKeyName(String name) 根据指定的名称创建 KeyName。
abstract KeyValue | newKeyValue(PublicKey key) 根据指定的公钥创建 KeyValue。
abstract PGPData | newPGPData(byte[] keyId) 根据指定的 PGP 公钥标识符创建 PGPData。
abstract PGPData | newPGPData(byte[] keyId, byte[] keyPacket, List other) 根据指定的 PGP 公钥标识符、可选的密钥材料包和外部元素的列表，创建 PGPData。
abstract PGPData | newPGPData(byte[] keyPacket, List other) 根据指定的 PGP 密钥材料包和可选的外部元素列表创建 PGPData。
abstract RetrievalMethod | newRetrievalMethod(String uri) 根据指定的 URI 创建 RetrievalMethod。
abstract RetrievalMethod | newRetrievalMethod(String uri, String type, List transforms) 根据指定的参数创建 RetrievalMethod。
abstract X509Data | newX509Data(List content) 创建包含指定的 X.509 内容列表的 X509Data。
abstract X509IssuerSerial | newX509IssuerSerial(String issuerName, BigInteger serialNumber) 根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。
abstract KeyInfo | unmarshalKeyInfo(XMLStructure xmlStructure) 根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyInfoFactory

protected KeyInfoFactory()
默认的构造方法，由子类调用。

方法详细信息

getInstance

public static KeyInfoFactory getInstance(String mechanismType)
返回 KeyInfoFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。

此方法使用标准的 JCA 提供者查找机制来查找并实例化所需机制类型的 KeyInfoFactory 实现。它将从首选的 Provider 开始，遍历已注册的安全 Provider 的列表。返回取自第一个支持指定机制的 Provider 中的新 KeyInfoFactory 对象。

注意，已注册提供者的列表可以通过 Security.getProviders() 方法获得。

参数：
mechanismType - XML 处理机制和表示形式的类型。有关标准机制类型列表，请参阅 API 概述的 Service Providers 部分。
返回：
新的 KeyInfoFactory
抛出：
NullPointerException - 如果 mechanismType 为 null
NoSuchMechanismException - 如果没有任何 Provider 支持指定机制的 KeyInfoFactory 实现
另请参见：
Provider

getInstance

public static KeyInfoFactory getInstance(String mechanismType,
                                         Provider provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。注意，指定的 Provider 对象不必已经在提供者列表中注册。

参数：
mechanismType - XML 处理机制和表示形式的类型。有关标准机制类型列表，请参阅 API 概述的 Service Providers 部分。
provider - Provider 对象
返回：
新的 KeyInfoFactory
抛出：
NullPointerException - 如果 mechanismType 或 provider 为 null
NoSuchMechanismException - 如果不能从指定的 Provider 对象使用指定机制的 KeyInfoFactory 实现
另请参见：
Provider

getInstance

public static KeyInfoFactory getInstance(String mechanismType,
                                         String provider)
                                  throws NoSuchProviderException
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。指定的提供者必须已在安全提供者列表中注册。

注意，已注册提供者的列表可以通过 Security.getProviders() 方法获得。

参数：
mechanismType - XML 处理机制和表示形式的类型。有关标准机制类型列表，请参阅 API 概述的 Service Providers 部分。
provider - 提供者的字符串名称
返回：
新的 KeyInfoFactory
抛出：
NoSuchProviderException - 如果指定的提供者没有在安全提供者列表中注册
NullPointerException - 如果 mechanismType 或 provider 为 null
NoSuchMechanismException - 如果从指定的提供者不能使用指定机制的 KeyInfoFactory 实现
另请参见：
Provider

getInstance

public static KeyInfoFactory getInstance()
返回支持默认 XML 处理机制和表示形式类型（“DOM”） 的 KeyInfoFactory。

此方法使用标准的 JCA 提供者查找机制来查找并实例化默认机制类型的 KeyInfoFactory 实现。它将从首选的 Provider 开始，遍历已注册的安全 Provider 的列表。返回取自第一个支持 DOM 机制的 Provider 中的新 KeyInfoFactory 对象。

注意，已注册提供者的列表可以通过 Security.getProviders() 方法获得。

返回：
新的 KeyInfoFactory
抛出：
NoSuchMechanismException - 如果没有任何 Provider 支持 DOM 机制的 KeyInfoFactory 实现
另请参见：
Provider

getMechanismType

public final String getMechanismType()
返回此 KeyInfoFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。

返回：
此 KeyInfoFactory 支持的 XML 处理机制类型

getProvider

public final Provider getProvider()
返回此 KeyInfoFactory 的提供者。

返回：
此 KeyInfoFactory 的提供者

newKeyInfo

public abstract KeyInfo newKeyInfo(List content)
创建包含指定的密钥信息类型列表的 KeyInfo。

参数：
content - 一个列表，由一个或多个表示密钥信息类型的 XMLStructure 组成。需要复制该列表，以防止随后被修改。
返回：
KeyInfo
抛出：
NullPointerException - 如果 content 为 null
IllegalArgumentException - 如果 content 为空
ClassCastException - 如果 content 包含任何不是类型 XMLStructure 的条目

newKeyInfo

public abstract KeyInfo newKeyInfo(List content,
                                   String id)
创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。id 参数表示 XML ID 属性值，对于从其他 XML 结构引用 KeyInfo 很有用。

参数：
content - 一个列表，由一个或多个表示密钥信息类型的 XMLStructure 组成。需要复制该列表，以防止随后被修改。
id - XML ID 的值（可以为 null）
返回：
KeyInfo
抛出：
NullPointerException - 如果 content 为 null
IllegalArgumentException - 如果 content 为空
ClassCastException - 如果 content 包含任何不是类型 XMLStructure 的条目

newKeyName

public abstract KeyName newKeyName(String name)
根据指定的名称创建 KeyName。

参数：
name - 标识密钥的名称
返回：
KeyName
抛出：
NullPointerException - 如果 name 为 null

newKeyValue

public abstract KeyValue newKeyValue(PublicKey key)
                              throws KeyException
根据指定的公钥创建 KeyValue。

参数：
key - 公钥
返回：
KeyValue
抛出：
KeyException - 如果 key 的算法不可识别或不受 KeyInfoFactory 的支持
NullPointerException - 如果 key 为 null

newPGPData

public abstract PGPData newPGPData(byte[] keyId)
根据指定的 PGP 公钥标识符创建 PGPData。

参数：
keyId - RFC 2440 第 11.2 节定义的 PGP 公钥标识符。复制该数组，以防止随后被修改。
返回：
PGPData
抛出：
NullPointerException - 如果 keyId 为 null
IllegalArgumentException - 如果密钥 id 的格式不正确

newPGPData

public abstract PGPData newPGPData(byte[] keyId,
                                   byte[] keyPacket,
                                   List other)
根据指定的 PGP 公钥标识符、可选的密钥材料包和外部元素的列表，创建 PGPData。

参数：
keyId - RFC 2440 第 11.2 节定义的 PGP 公钥标识符。复制该数组，以防止随后被修改。
keyPacket - RFC 2440 第 5.5 节定义的 PGP 密钥材料包。复制该数组，以防止随后被修改。可以为 null。
other - 一个列表，由表示外部名称空间中的元素的 XMLStructure 组成。需要复制该列表，以防止随后被修改。可以为 null 或空。
返回：
PGPData
抛出：
NullPointerException - 如果 keyId 为 null
IllegalArgumentException - 如果 keyId 或 keyPacket 的格式不正确。对于 keyPacket，将检查包头的格式，并验证标记，确定它属于哪种类型的密钥材料。包正文的内容和格式无需检查。
ClassCastException - 如果 other 包含任何不是类型 XMLStructure 的条目

newPGPData

public abstract PGPData newPGPData(byte[] keyPacket,
                                   List other)
根据指定的 PGP 密钥材料包和可选的外部元素列表创建 PGPData。

参数：
keyPacket - RFC 2440 第 5.5 节定义的 PGP 密钥材料包。复制该数组，以防止随后被修改。
other - 一个列表，由表示外部名称空间中的元素的 XMLStructure 组成。需要复制该列表，以防止随后被修改。可以为 null 或空。
返回：
PGPData
抛出：
NullPointerException - 如果 keyPacket 为 null
IllegalArgumentException - 如果 keyPacket 的格式不正确。对于 keyPacket，将检查包头的格式，并验证标记，确定它属于哪种类型的密钥材料。包正文的内容和格式无需检查。
ClassCastException - 如果 other 包含任何不是类型 XMLStructure 的条目

newRetrievalMethod

public abstract RetrievalMethod newRetrievalMethod(String uri)
根据指定的 URI 创建 RetrievalMethod。

参数：
uri - 标识将要检索的 KeyInfo 信息的 URI
返回：
RetrievalMethod
抛出：
NullPointerException - 如果 uri 为 null
IllegalArgumentException - 如果 uri 与 RFC 2396 不兼容

newRetrievalMethod

public abstract RetrievalMethod newRetrievalMethod(String uri,
                                                   String type,
                                                   List transforms)
根据指定的参数创建 RetrievalMethod。

参数：
uri - 标识将要检索的 KeyInfo 信息的 URI
type - 标识将要检索的 KeyInfo 信息的类型的 URI （可以为 null）
transforms - Transform 的列表。需要复制该列表，以防止随后被修改。可以为 null 或空。
返回：
RetrievalMethod
抛出：
NullPointerException - 如果 uri 为 null
IllegalArgumentException - 如果 uri 与 RFC 2396 不兼容
ClassCastException - 如果 transforms 包含不是类型 Transform 的任何条目

newX509Data

public abstract X509Data newX509Data(List content)
创建包含指定的 X.509 内容列表的 X509Data。

参数：
content - 一个列表，由一个或多个 X.509 内容类型组成。有效的类型有 String（主体名称）、byte[]（主体的密钥 id）、X509Certificate、X509CRL 或 XMLStructure（来自外部名称空间的 X509IssuerSerial 对象或元素）。主体名称是 RFC 2253 String 格式的标识名。这些实现必须支持 RFC 2253（CN、L、ST、O、OU、C、STREET、DC 和 UID）中定义的属性类型关键字。这些实现可能还支持其他关键字。需要复制该列表，以防止随后被修改。
返回：
X509Data
抛出：
NullPointerException - 如果 content 为 null
IllegalArgumentException - 如果 content 为空，或者主体与 RFC 2253 不兼容或无法识别其中一个属性类型关键字。
ClassCastException - 如果 content 包含不是上述任何有效类型的任何条目

newX509IssuerSerial

public abstract X509IssuerSerial newX509IssuerSerial(String issuerName,
                                                     BigInteger serialNumber)
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。

参数：
issuerName - RFC 2253 String 格式的发布方标识名。这些实现必须支持 RFC 2253（CN、L、ST、O、OU、C、STREET、DC 和 UID）中定义的属性类型关键字。这些实现可能还支持其他关键字。
serialNumber - 序列号
返回：
X509IssuerSerial
抛出：
NullPointerException - 如果 issuerName 或 serialNumber 为 null
IllegalArgumentException - 如果发布方名称与 RFC 2253 不兼容，或者无法识别其中一个属性类型关键字。

isFeatureSupported

public abstract boolean isFeatureSupported(String feature)
指示是否支持指定的功能。

参数：
feature - 功能名称（以抽象 URI 形式）
返回：
如果支持指定功能，则返回 true，否则返回 false
抛出：
NullPointerException - 如果 feature 为 null

getURIDereferencer

public abstract URIDereferencer getURIDereferencer()
返回对 URIDereferencer 的引用，默认情况下用于取消引用 RetrievalMethod 对象中的 URI。

返回：
对默认 URIDereferencer 的引用

unmarshalKeyInfo

public abstract KeyInfo unmarshalKeyInfo(XMLStructure xmlStructure)
                                  throws MarshalException
根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。

参数：
xmlStructure - 从中解组 keyinfo 的特定于机制的 XML 结构
返回：
KeyInfo
抛出：
NullPointerException - 如果 xmlStructure 为 null
ClassCastException - 如果 xmlStructure 的类型不适合此工厂
MarshalException - 如果解组过程中发生不可恢复的异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyName (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.keyinfo
接口 KeyName

所有超级接口：
XMLStructure
public interface KeyName
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyName 元素的表示形式。KeyName 对象包含一个字符串值，签名人可以使用该字符串值让接受方了解密钥标识符。XML Schema Definition 的定义如下：

<element name="KeyInfo" type="ds:KeyInfoType"/>
通过调用 KeyInfoFactory 类的 newKeyName 方法，并向其传递表示密钥名称的 String，可以创建 KeyName 实例，例如：
KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
KeyName keyName = factory.newKeyName("Alice");

从以下版本开始：
1.6
另请参见：
KeyInfoFactory.newKeyName(String)

方法摘要
 String getName()
返回此 KeyName 的名称。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

方法详细信息

getName

String getName()
返回此 KeyName 的名称。

返回：
此 KeyName 的名称（不能为 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.keyinfo
接口 KeyValue

所有超级接口：
XMLStructure
public interface KeyValue
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyValue 元素的表示形式。KeyValue 对象包含一个在验证签名时很有用的公钥。XML Schema Definition 的定义如下：

    <element name="KeyValue" type="ds:KeyValueType"/>
    <complexType name="KeyValueType" mixed="true">
      <choice>
        <element ref="ds:DSAKeyValue"/>
        <element ref="ds:RSAKeyValue"/>
        <any namespace="##other" processContents="lax"/>
      </choice>
    </complexType>

    <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>
    <complexType name="DSAKeyValueType">
      <sequence>
        <sequence minOccurs="0">
          <element name="P" type="ds:CryptoBinary"/>
          <element name="Q" type="ds:CryptoBinary"/>
        </sequence>
        <element name="G" type="ds:CryptoBinary" minOccurs="0"/>
        <element name="Y" type="ds:CryptoBinary"/>
        <element name="J" type="ds:CryptoBinary" minOccurs="0"/>
        <sequence minOccurs="0">
          <element name="Seed" type="ds:CryptoBinary"/>
          <element name="PgenCounter" type="ds:CryptoBinary"/>
        </sequence>
      </sequence>
    </complexType>

    <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>
    <complexType name="RSAKeyValueType">
      <sequence>
        <element name="Modulus" type="ds:CryptoBinary"/>
        <element name="Exponent" type="ds:CryptoBinary"/>
      </sequence>
    </complexType>
通过调用 KeyInfoFactory 类的 newKeyValue 方法，并向其传递表示公钥值的 PublicKey，可以创建 KeyValue 实例。下面是一个示例，该示例根据 KeyStore 中存储的 Certificate 的 DSAPublicKey 创建了一个 KeyValue：
KeyStore keyStore = KeyStore.getInstance(KeyStore.getDefaultType());
PublicKey dsaPublicKey = keyStore.getCertificate("myDSASigningCert").getPublicKey();
KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
KeyValue keyValue = factory.newKeyValue(dsaPublicKey);
此类将分别以类型 DSAPublicKey 和 RSAPublicKey 对象的形式返回 DSAKeyValue 和 RSAKeyValue 元素。注意，并非模式中的所有字段都可以作为这些类型的参数进行访问。

从以下版本开始：
1.6
另请参见：
KeyInfoFactory.newKeyValue(PublicKey)

字段摘要
static String | DSA_TYPE 标识 DSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#DSAKeyValue。
static String | RSA_TYPE 标识 RSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#RSAKeyValue。
方法摘要
 PublicKey getPublicKey()
返回此 KeyValue 的公钥。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

字段详细信息

DSA_TYPE

static final String DSA_TYPE
标识 DSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#DSAKeyValue。可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 DSAKeyValue 结构。

另请参见：
常量字段值

RSA_TYPE

static final String RSA_TYPE
标识 RSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#RSAKeyValue。可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 RSAKeyValue 结构。

另请参见：
常量字段值
方法详细信息

getPublicKey

PublicKey getPublicKey()
                       throws KeyException
返回此 KeyValue 的公钥。

返回：
此 KeyValue 的公钥
抛出：
KeyException - 如果无法将此 KeyValue 转换为 PublicKey
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PGPData (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.keyinfo
接口 PGPData

所有超级接口：
XMLStructure
public interface PGPData
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML PGPData 元素的表示形式。PGPData 对象用于传送与 PGP 公钥对和此类密钥上的签名有关的信息。XML Schema Definition 的定义如下：

    <element name="PGPData" type="ds:PGPDataType"/>
    <complexType name="PGPDataType">
      <choice>
        <sequence>
          <element name="PGPKeyID" type="base64Binary"/>
          <element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
          <any namespace="##other" processContents="lax" minOccurs="0"
           maxOccurs="unbounded"/>
        </sequence>
        <sequence>
          <element name="PGPKeyPacket" type="base64Binary"/>
          <any namespace="##other" processContents="lax" minOccurs="0"
           maxOccurs="unbounded"/>
        </sequence>
      </choice>
    </complexType>
通过调用 KeyInfoFactory 类的一个 newPGPData 方法，并向其传递表示 PGP 公钥标识符和/或 PGP 密钥材料包内容的 byte 数组，以及外部名称空间中的元素的可选列表，可以创建 PGPData 实例。

从以下版本开始：
1.6
另请参见：
KeyInfoFactory.newPGPData(byte[]),
KeyInfoFactory.newPGPData(byte[], byte[], List),
KeyInfoFactory.newPGPData(byte[], List)

字段摘要
static String TYPE
标识 PGPData KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#PGPData.可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 PGPData 结构。
方法摘要
List | getExternalElements() 返回一个不可修改列表，由表示外部名称空间元素中的 XMLStructure 组成。
byte[] | getKeyId() 返回此 PGPData 的 PGP 公钥标识符，正如第 11.2 节的 RFC 2440 中所定义的。
byte[] | getKeyPacket() 返回此 PGPData 的 PGP 密钥材料包，正如第 5.5 节的 RFC 2440 中所定义的。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

字段详细信息

TYPE

static final String TYPE
标识 PGPData KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#PGPData.可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 PGPData 结构。

另请参见：
常量字段值
方法详细信息

getKeyId

byte[] getKeyId()
返回此 PGPData 的 PGP 公钥标识符，正如第 11.2 节的 RFC 2440 中所定义的。

返回：
PGP 公钥标识符（如果未指定该标识符，则返回 null）。每次调用此方法都将返回一个新的副本，以防止随后被修改。

getKeyPacket

byte[] getKeyPacket()
返回此 PGPData 的 PGP 密钥材料包，正如第 5.5 节的 RFC 2440 中所定义的。

返回：
PGP 密钥材料包（如果未指定，则返回 null）。每次调用此方法都将返回一个新的副本，以防止随后被修改。

getExternalElements

List getExternalElements()
返回一个不可修改列表，由表示外部名称空间元素中的 XMLStructure 组成。

返回：
不可修改的 XMLStructure 列表（可以为空，但不能为 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RetrievalMethod (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.keyinfo
接口 RetrievalMethod

所有超级接口：
URIReference, XMLStructure
public interface RetrievalMethod
extends URIReference, XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。RetrievalMethod 对象用于传送对存储在另一个位置上的 KeyInfo 信息的引用。XML Schema Definition 的定义如下：

   <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>
   <complexType name="RetrievalMethodType">
     <sequence>
       <element name="Transforms" type="ds:TransformsType" minOccurs="0"/>
     </sequence>
     <attribute name="URI" type="anyURI"/>
     <attribute name="Type" type="anyURI" use="optional"/>
   </complexType>
通过调用 KeyInfoFactory 类的一个 newRetrievalMethod 方法，并向其传递标识 KeyInfo 位置的 URI、可选的标识 KeyInfo 类型的类型 URI 和可选的 Transform 列表，可以创建 RetrievalMethod 实例，例如：
KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
RetrievalMethod rm = factory.newRetrievalMethod
("#KeyValue-1", KeyValue.DSA_TYPE, Collections.singletonList(Transform.BASE64));

从以下版本开始：
1.6
另请参见：
KeyInfoFactory.newRetrievalMethod(String), KeyInfoFactory.newRetrievalMethod(String, String, List)

方法摘要
Data | dereference(XMLCryptoContext context) 取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。
List | getTransforms() 返回一个不可修改的列表，由此 RetrievalMethod 的 Transform 组成。
String | getURI() 返回已引用的 KeyInfo 信息的 URI。
从接口 javax.xml.crypto.URIReference 继承的方法
getType
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

方法详细信息

getTransforms

List getTransforms()
返回一个不可修改的列表，由此 RetrievalMethod 的 Transform 组成。

返回：
不可修改的 Transform 对象列表（可以为空，但不能为 null）。

getURI

String getURI()
返回已引用的 KeyInfo 信息的 URI。

指定者：
接口 URIReference 中的 getURI
返回：
已引用 KeyInfo 信息（RFC 2396 格式）的 URI（不能为 null）

dereference

Data dereference(XMLCryptoContext context)
                 throws URIReferenceException
取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。

参数：
context - XMLCryptoContext，包含用来取消引用 URI 的其他有用信息。上下文的 baseURI 和 dereferencer 参数（如果已指定）用于解析和取消引用此 RetrievalMethod
返回：
表示此 RetrievalMethod 引用的 KeyInfo 信息的原始内容的 Data 对象。调用者负责将返回的数据转换成适当的 KeyInfo 对象。
抛出：
NullPointerException - 如果 context 为 null
URIReferenceException - 如果在取消引用时发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509Data (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.keyinfo
接口 X509Data

所有超级接口：
XMLStructure
public interface X509Data
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509Data 元素的表示形式。X509Data 对象包含一个或多个密钥标识符或 X.509 证书（或者证书的标识符或撤销列表）。XML Schema Definition 的定义如下：

    <element name="X509Data" type="ds:X509DataType"/>
    <complexType name="X509DataType">
        <sequence maxOccurs="unbounded">
          <choice>
            <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
            <element name="X509SKI" type="base64Binary"/>
            <element name="X509SubjectName" type="string"/>
            <element name="X509Certificate" type="base64Binary"/>
            <element name="X509CRL" type="base64Binary"/>
            <any namespace="##other" processContents="lax"/>
          </choice>
        </sequence>
    </complexType>

    <complexType name="X509IssuerSerialType">
      <sequence>
        <element name="X509IssuerName" type="string"/>
        <element name="X509SerialNumber" type="integer"/>
      </sequence>
    </complexType>
通过调用 KeyInfoFactory 类的 newX509Data 方法，并向其传递表示 X.509 内容的一个或多个 XMLStructure 的列表，可以创建 X509Data 实例，例如：
KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
X509Data x509Data = factory.newX509Data
(Collections.singletonList("cn=Alice"));

从以下版本开始：
1.6
另请参见：
KeyInfoFactory.newX509Data(List)

字段摘要
static String | RAW_X509_CERTIFICATE_TYPE 标识二进制 (ASN.1 DER) X.509 Certificate KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#rawX509Certificate。
static String | TYPE 标识 X509Data KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#X509Data。
方法摘要
 List getContent()
返回一个不可修改的列表，由此 X509Data 的内容组成。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

字段详细信息

TYPE

static final String TYPE
标识 X509Data KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#X509Data。可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 X509Data 结构。

另请参见：
常量字段值

RAW_X509_CERTIFICATE_TYPE

static final String RAW_X509_CERTIFICATE_TYPE
标识二进制 (ASN.1 DER) X.509 Certificate KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#rawX509Certificate。可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 X509Data Certificate。

另请参见：
常量字段值
方法详细信息

getContent

List getContent()
返回一个不可修改的列表，由此 X509Data 的内容组成。有效的类型有 String（主体名称）、byte[]（主体的密钥 id）、X509Certificate、X509CRL 或 XMLStructure（来自外部名称空间的 X509IssuerSerial 对象或元素）。

返回：
此 X509Data 的内容的不可修改列表（不能为 null 或空）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509IssuerSerial (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.keyinfo
接口 X509IssuerSerial

所有超级接口：
XMLStructure
public interface X509IssuerSerial
extends XMLStructure

W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509IssuerSerial 元素的表示形式。X509IssuerSerial 对象包含 X.509 发布方标识名 (DN) 和序列号对。XML Schema Definition 的定义如下：

   <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
   <complexType name="X509IssuerSerialType">
     <sequence>
       <element name="X509IssuerName" type="string"/>
       <element name="X509SerialNumber" type="integer"/>
     </sequence>
   </complexType>
通过调用 KeyInfoFactory 类的 newX509IssuerSerial 方法，并向其传递表示 X.500 DN 和序列号的 String 和 BigInteger，可以创建 X509IssuerSerial 实例。下面是一个示例，该示例根据现有 X509Certificate 的发布方 DN 和序列号来创建 X509IssuerSerial：
KeyInfoFactory factory = KeyInfoFactory.getInstance("DOM");
X509IssuerSerial issuer = factory.newX509IssuerSerial
   (cert.getIssuerX500Principal().getName(), cert.getSerialNumber());

从以下版本开始：
1.6
另请参见：
X509Data.getContent(), KeyInfoFactory.newX509IssuerSerial(String, BigInteger)

方法摘要
String | getIssuerName() 返回 RFC 2253 String 格式的此 X509IssuerSerial 的 X.500 标识名。
BigInteger | getSerialNumber() 返回此 X509IssuerSerial 的序列号。
从接口 javax.xml.crypto.XMLStructure 继承的方法
isFeatureSupported

方法详细信息

getIssuerName

String getIssuerName()
返回 RFC 2253 String 格式的此 X509IssuerSerial 的 X.500 标识名。

返回：
RFC 2253 String 格式的 X.500 标识名（不能为 null）

getSerialNumber

BigInteger getSerialNumber()
返回此 X509IssuerSerial 的序列号。

返回：
序列号（不能为 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.crypto.dsig.keyinfo (Java Platform SE 6)

 javax.xml.crypto.dsig.keyinfo
接口
KeyInfo
KeyName
KeyValue
PGPData
RetrievalMethod
X509Data
X509IssuerSerial
类
KeyInfoFactory


javax.xml.crypto.dsig.keyinfo (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.crypto.dsig.keyinfo

用来解析和处理 KeyInfo 元素和结构的类。

请参见：
描述

接口摘要
KeyInfo | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。
KeyName | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyName 元素的表示形式。
KeyValue | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyValue 元素的表示形式。
PGPData | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML PGPData 元素的表示形式。
RetrievalMethod | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。
X509Data | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509Data 元素的表示形式。
X509IssuerSerial | W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509IssuerSerial 元素的表示形式。

类摘要
KeyInfoFactory 用于从头创建 KeyInfo 对象或从相应的 XML 表示形式解组 KeyInfo 对象的工厂。

软件包 javax.xml.crypto.dsig.keyinfo 的描述

用来解析和处理 KeyInfo 元素和结构的类。KeyInfo 是可选元素，它使接受方可以获取验证 XMLSignature 所需的密钥。KeyInfo 可以包含密钥、名称、证书和其他公钥管理信息，比如 in-band 密钥分发或密钥协议数据。此包包含一些类表示 W3C specification for XML Signatures 中定义的类型，如 KeyName、KeyValue、RetrievalMethod、X509Data、X509IssuerSerial 和 PGPData。KeyInfoFactory 是一个从头创建 KeyInfo 对象的抽象工厂。

包规范

  • XML-Signature Syntax and Processing:W3C Recommendation
  • RFC 3275:XML-Signature Syntax and Processing

Since:
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.crypto.dsig.keyinfo 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dsig.keyinfo 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

接口分层结构

  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (并 extends javax.xml.crypto.XMLStructure)
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.keyinfo.KeyInfo
    • javax.xml.crypto.dsig.keyinfo.KeyName
    • javax.xml.crypto.dsig.keyinfo.KeyValue
    • javax.xml.crypto.dsig.keyinfo.PGPData
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (并 extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.keyinfo.X509Data
    • javax.xml.crypto.dsig.keyinfo.X509IssuerSerial
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.crypto.dsig.keyinfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dsig.keyinfo
的使用

使用 javax.xml.crypto.dsig.keyinfo 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 使用的 javax.xml.crypto.dsig.keyinfo 中的类
KeyInfo
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。

javax.xml.crypto.dsig 使用的 javax.xml.crypto.dsig.keyinfo 中的类
KeyInfo
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。
KeyInfoFactory
用于从头创建 KeyInfo 对象或从相应的 XML 表示形式解组 KeyInfo 对象的工厂。

javax.xml.crypto.dsig.keyinfo 使用的 javax.xml.crypto.dsig.keyinfo 中的类
KeyInfo
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。
KeyInfoFactory
用于从头创建 KeyInfo 对象或从相应的 XML 表示形式解组 KeyInfo 对象的工厂。
KeyName
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyName 元素的表示形式。
KeyValue
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyValue 元素的表示形式。
PGPData
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML PGPData 元素的表示形式。
RetrievalMethod
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。
X509Data
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509Data 元素的表示形式。
X509IssuerSerial
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509IssuerSerial 元素的表示形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.KeyInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.KeyInfo
的使用

使用 KeyInfo 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 KeyInfo 的使用

参数类型为 KeyInfo 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

javax.xml.crypto.dsig 中 KeyInfo 的使用

返回 KeyInfo 的 javax.xml.crypto.dsig 中的方法
 KeyInfo XMLSignature.getKeyInfo()
返回此 XMLSignature 的密钥信息。

参数类型为 KeyInfo 的 javax.xml.crypto.dsig 中的方法
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki) 创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。

javax.xml.crypto.dsig.keyinfo 中 KeyInfo 的使用

返回 KeyInfo 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract KeyInfo | KeyInfoFactory.newKeyInfo(List content) 创建包含指定的密钥信息类型列表的 KeyInfo。
abstract KeyInfo | KeyInfoFactory.newKeyInfo(List content, String id) 创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。
abstract KeyInfo | KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure) 根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
的使用

使用 KeyInfoFactory 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig 中 KeyInfoFactory 的使用

返回 KeyInfoFactory 的 javax.xml.crypto.dsig 中的方法
 KeyInfoFactory XMLSignatureFactory.getKeyInfoFactory()
返回创建 KeyInfo 对象的 KeyInfoFactory。

javax.xml.crypto.dsig.keyinfo 中 KeyInfoFactory 的使用

返回 KeyInfoFactory 的 javax.xml.crypto.dsig.keyinfo 中的方法
static KeyInfoFactory | KeyInfoFactory.getInstance() 返回支持默认 XML 处理机制和表示形式类型（“DOM”） 的 KeyInfoFactory。
static KeyInfoFactory | KeyInfoFactory.getInstance(String mechanismType) 返回 KeyInfoFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
static KeyInfoFactory | KeyInfoFactory.getInstance(String mechanismType, Provider provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。
static KeyInfoFactory | KeyInfoFactory.getInstance(String mechanismType, String provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.KeyName 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.KeyName
的使用

使用 KeyName 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 KeyName 的使用

返回 KeyName 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  KeyName KeyInfoFactory.newKeyName(String name)
根据指定的名称创建 KeyName。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.KeyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.KeyValue
的使用

使用 KeyValue 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 KeyValue 的使用

返回 KeyValue 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  KeyValue KeyInfoFactory.newKeyValue(PublicKey key)
根据指定的公钥创建 KeyValue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.PGPData 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.PGPData
的使用

使用 PGPData 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 PGPData 的使用

返回 PGPData 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyId) 根据指定的 PGP 公钥标识符创建 PGPData。
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyId, byte[] keyPacket, List other) 根据指定的 PGP 公钥标识符、可选的密钥材料包和外部元素的列表，创建 PGPData。
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyPacket, List other) 根据指定的 PGP 密钥材料包和可选的外部元素列表创建 PGPData。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod
的使用

使用 RetrievalMethod 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 RetrievalMethod 的使用

返回 RetrievalMethod 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract RetrievalMethod | KeyInfoFactory.newRetrievalMethod(String uri) 根据指定的 URI 创建 RetrievalMethod。
abstract RetrievalMethod | KeyInfoFactory.newRetrievalMethod(String uri, String type, List transforms) 根据指定的参数创建 RetrievalMethod。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.X509Data 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.X509Data
的使用

使用 X509Data 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 X509Data 的使用

返回 X509Data 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  X509Data KeyInfoFactory.newX509Data(List content)
创建包含指定的 X.509 内容列表的 X509Data。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.keyinfo.X509IssuerSerial 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.keyinfo.X509IssuerSerial
的使用

使用 X509IssuerSerial 的软件包
javax.xml.crypto.dsig.keyinfo 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.keyinfo 中 X509IssuerSerial 的使用

返回 X509IssuerSerial 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  X509IssuerSerial KeyInfoFactory.newX509IssuerSerial(String issuerName, BigInteger serialNumber)
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


C14NMethodParameterSpec (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
接口 C14NMethodParameterSpec

所有超级接口：
AlgorithmParameterSpec, TransformParameterSpec
所有已知实现类：
ExcC14NParameterSpec
public interface C14NMethodParameterSpec
extends TransformParameterSpec

CanonicalizationMethod 算法的算法参数规范。此接口的用途是对所有规范化的 (C14N) 参数规范进行分组（并为它们提供类型安全）。所有规范化的参数规范都必须实现此接口。

从以下版本开始：
1.6
另请参见：
CanonicalizationMethod

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DigestMethodParameterSpec (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
接口 DigestMethodParameterSpec

所有超级接口：
AlgorithmParameterSpec
public interface DigestMethodParameterSpec
extends AlgorithmParameterSpec

用于 DigestMethod 算法的算法参数的规范。此接口的用途是对所有摘要方法参数规范进行分组（并为它们提供类型安全）。所有摘要方法参数规范都必须实现此接口。

从以下版本开始：
1.6
另请参见：
DigestMethod

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExcC14NParameterSpec (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
类 ExcC14NParameterSpec

java.lang.Object
    继承者  javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
所有已实现的接口：
AlgorithmParameterSpec, C14NMethodParameterSpec, TransformParameterSpec
public final class ExcC14NParameterSpec
extends Object
implements C14NMethodParameterSpec

W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。参数包含一个可选的相容名称空间前缀列表。Exclusive XML Canonicalization 参数的 XML Schema Definition 定义如下：

 <schema xmlns="http://www.w3.org/2001/XMLSchema"
         xmlns:ec="http://www.w3.org/2001/10/xml-exc-c14n#"
         targetNamespace="http://www.w3.org/2001/10/xml-exc-c14n#"
         version="0.1" elementFormDefault="qualified">

 <element name="InclusiveNamespaces" type="ec:InclusiveNamespaces"/>
 <complexType name="InclusiveNamespaces">
   <attribute name="PrefixList" type="xsd:string"/>
 </complexType>
 </schema>

从以下版本开始：
1.6
另请参见：
CanonicalizationMethod

字段摘要
static String DEFAULT
指示默认名称空间（“#default”）。
构造方法摘要
ExcC14NParameterSpec()
创建带有空前缀列表的 ExcC14NParameterSpec。
ExcC14NParameterSpec(List prefixList)
创建带有指定前缀列表的 ExcC14NParameterSpec。
方法摘要
 List getPrefixList()
返回相容名称空间前缀列表。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT

public static final String DEFAULT
指示默认名称空间（“#default”）。

另请参见：
常量字段值
构造方法详细信息

ExcC14NParameterSpec

public ExcC14NParameterSpec()
创建带有空前缀列表的 ExcC14NParameterSpec。

ExcC14NParameterSpec

public ExcC14NParameterSpec(List prefixList)
创建带有指定前缀列表的 ExcC14NParameterSpec。复制该列表，以防止随后被修改。

参数：
prefixList - 相容名称空间前缀列表。列表中的每一项都是一个表示名称空间前缀的 String。
抛出：
NullPointerException - 如果 prefixList 为 null
ClassCastException - 如果任何列表项的类型不是 String
方法详细信息

getPrefixList

public List getPrefixList()
返回相容名称空间前缀列表。列表中的每一项都是一个表示名称空间前缀的 String。

此实现将返回一个不可修改的列表。

返回：
相容名称空间前缀列表（可以为空，但不能为 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HMACParameterSpec (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
类 HMACParameterSpec

java.lang.Object
    继承者  javax.xml.crypto.dsig.spec.HMACParameterSpec
所有已实现的接口：
AlgorithmParameterSpec, SignatureMethodParameterSpec
public final class HMACParameterSpec
extends Object
implements SignatureMethodParameterSpec

XML Signature HMAC Algorithm 的参数。这些参数包括一个可选的输出长度，该长度指定了 MAC 截断长度（以位为单位）。得到的 HMAC 将被截断为指定的位数。如果未指定该参数，则意味着输出哈希值的所有位。HMACOutputLength 元素的 XML Schema Definition 定义如下：

<element name="HMACOutputLength" minOccurs="0" type="ds:HMACOutputLengthType"/>
<simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>

从以下版本开始：
1.6
另请参见：
SignatureMethod, RFC 2104

构造方法摘要
HMACParameterSpec(int outputLength)
创建具有指定截断长度的 HMACParameterSpec。
方法摘要
 int getOutputLength()
返回截断长度。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HMACParameterSpec

public HMACParameterSpec(int outputLength)
创建具有指定截断长度的 HMACParameterSpec。

参数：
outputLength - 截断长度的位数
方法详细信息

getOutputLength

public int getOutputLength()
返回截断长度。

返回：
截断长度的位数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SignatureMethodParameterSpec (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
接口 SignatureMethodParameterSpec

所有超级接口：
AlgorithmParameterSpec
所有已知实现类：
HMACParameterSpec
public interface SignatureMethodParameterSpec
extends AlgorithmParameterSpec

用于 XML SignatureMethod 算法的算法参数规范。此接口的用途是对所有签名方法参数规范进行分组（并为它们提供类型安全）。所有签名方法参数规范都必须实现此接口。

从以下版本开始：
1.6
另请参见：
SignatureMethod

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformParameterSpec (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
接口 TransformParameterSpec

所有超级接口：
AlgorithmParameterSpec
所有已知子接口：
C14NMethodParameterSpec
所有已知实现类：
ExcC14NParameterSpec, XPathFilter2ParameterSpec, XPathFilterParameterSpec, XSLTTransformParameterSpec
public interface TransformParameterSpec
extends AlgorithmParameterSpec

用于 Transform 算法的算法参数规范。此接口的用途是对所有转换参数规范进行分组（并为它们提供类型安全）。所有转换参数规范都必须实现此接口。

从以下版本开始：
1.6
另请参见：
Transform

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathFilter2ParameterSpec (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
类 XPathFilter2ParameterSpec

java.lang.Object
    继承者  javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
所有已实现的接口：
AlgorithmParameterSpec, TransformParameterSpec
public final class XPathFilter2ParameterSpec
extends Object
implements TransformParameterSpec

W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。这些参数包括一个由一个或多个 XPathType 对象所组成的列表。

从以下版本开始：
1.6
另请参见：
Transform, XPathFilterParameterSpec

构造方法摘要
XPathFilter2ParameterSpec(List xPathList)
创建一个 XPathFilter2ParameterSpec。
方法摘要
 List getXPathList()
返回一个列表，由一个或多个 XPathType 对象组成。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XPathFilter2ParameterSpec

public XPathFilter2ParameterSpec(List xPathList)
创建一个 XPathFilter2ParameterSpec。

参数：
xPathList - 一个列表，由一个或多个 XPathType 对象组成。需要复制该列表，以防止随后被修改。
抛出：
ClassCastException - 如果 xPathList 包含任何类型不是 XPathType 的项
IllegalArgumentException - 如果 xPathList 为空
NullPointerException - 如果 xPathList 为 null
方法详细信息

getXPathList

public List getXPathList()
返回一个列表，由一个或多个 XPathType 对象组成。

此实现返回一个不可修改的列表。

返回：
XPathType 对象的 List（不能为 null 或空）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathFilterParameterSpec (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
类 XPathFilterParameterSpec

java.lang.Object
    继承者  javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
所有已实现的接口：
AlgorithmParameterSpec, TransformParameterSpec
public final class XPathFilterParameterSpec
extends Object
implements TransformParameterSpec

XPath Filtering Transform Algorithm 的参数。该参数包括 XPath 表达式，以及一个可选的其他名称空间前缀映射 Map。XPath Filtering 转换参数的 XML Schema Definition 定义如下：

<element name="XPath" type="string"/>

从以下版本开始：
1.6
另请参见：
Transform

构造方法摘要
XPathFilterParameterSpec(String xPath)
创建带有指定 XPath 表达式的 XPathFilterParameterSpec。
XPathFilterParameterSpec(String xPath, Map namespaceMap)
创建带有指定 XPath 表达式和名称空间映射表的 XPathFilterParameterSpec。
方法摘要
Map | getNamespaceMap() 返回名称空间前缀的映射表。
String | getXPath() 返回要计算的 XPath 表达式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XPathFilterParameterSpec

public XPathFilterParameterSpec(String xPath)
创建带有指定 XPath 表达式的 XPathFilterParameterSpec。

参数：
xPath - 要计算的 XPath 表达式
抛出：
NullPointerException - 如果 xPath 为 null

XPathFilterParameterSpec

public XPathFilterParameterSpec(String xPath,
                                Map namespaceMap)
创建带有指定 XPath 表达式和名称空间映射表的 XPathFilterParameterSpec。复制该映射表，以防止随后被修改。

参数：
xPath - 要计算的 XPath 表达式
namespaceMap - 名称空间前缀的映射表。每个密钥都是一个名称空间前缀 String，它将映射到相应的名称空间 URI String。
抛出：
NullPointerException - 如果 xPath 或 namespaceMap 为 null
ClassCastException - 如果任何映射表的密钥或条目的类型不是 String
方法详细信息

getXPath

public String getXPath()
返回要计算的 XPath 表达式。

返回：
要计算的 XPath 表达式

getNamespaceMap

public Map getNamespaceMap()
返回名称空间前缀的映射表。每个密钥都是一个名称空间前缀 String，它将映射到相应的名称空间 URI String。

此实现返回一个不可修改的映射表。

返回：
名称空间前缀到名称空间 URI 的 Map（可以为空，但不能为 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
类 XPathType

java.lang.Object
    继承者  javax.xml.crypto.dsig.spec.XPathType

public class XPathType
extends Object

W3C Recommendation for XML-Signature XPath Filter 2.0 中所定义的 XPath 元素的 XML 模式定义：

 <schema xmlns="http://www.w3.org/2001/XMLSchema"
         xmlns:xf="http://www.w3.org/2002/06/xmldsig-filter2"
         targetNamespace="http://www.w3.org/2002/06/xmldsig-filter2"
         version="0.1" elementFormDefault="qualified">

 <element name="XPath"
          type="xf:XPathType"/>

 <complexType name="XPathType">
   <simpleContent>
     <extension base="string">
       <attribute name="Filter">
         <simpleType>
           <restriction base="string">
             <enumeration value="intersect"/>
             <enumeration value="subtract"/>
             <enumeration value="union"/>
           </restriction>
         </simpleType>
       </attribute>
     </extension>
   </simpleContent>
 </complexType>

从以下版本开始：
1.6
另请参见：
XPathFilter2ParameterSpec

嵌套类摘要
static class XPathType.Filter
表示过滤器设置操作。
构造方法摘要
XPathType(String expression, XPathType.Filter filter)
创建带有指定 XPath 表达式和过滤器的 XPathType 实例。
XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。
方法摘要
String | getExpression() 返回要计算的 XPath 表达式。
XPathType.Filter | getFilter() 返回过滤操作。
Map | getNamespaceMap() 返回名称空间前缀的映射表。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XPathType

public XPathType(String expression,
                 XPathType.Filter filter)
创建带有指定 XPath 表达式和过滤器的 XPathType 实例。

参数：
expression - 要计算的 XPath 表达式
filter - 过滤操作 (XPathType.Filter.INTERSECT、XPathType.Filter.SUBTRACT 或 XPathType.Filter.UNION)
抛出：
NullPointerException - 如果 expression 或 filter 为 null

XPathType

public XPathType(String expression,
                 XPathType.Filter filter,
                 Map namespaceMap)
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。复制该映射表，以防止随后被修改。

参数：
expression - 要计算的 XPath 表达式
filter - 过滤操作 (XPathType.Filter.INTERSECT、XPathType.Filter.SUBTRACT 或 XPathType.Filter.UNION)
namespaceMap - 名称空间前缀的映射表。每个密钥都是一个命名空间前缀 String，它将映射到相应的命名空间 URI String。
抛出：
NullPointerException - 如果 expression、filter 或 namespaceMap 为 null
ClassCastException - 如果任何映射密钥或条目的类型不是 String
方法详细信息

getExpression

public String getExpression()
返回要计算的 XPath 表达式。

返回：
要计算的 XPath 表达式

getFilter

public XPathType.Filter getFilter()
返回过滤操作。

返回：
过滤操作

getNamespaceMap

public Map getNamespaceMap()
返回名称空间前缀的映射表。每个密钥都是一个命名空间前缀 String，它将映射到相应的命名空间 URI String。

此实现返回一个不可修改的映射表。

返回：
命名空间前缀到名称空间 URI 的 Map（可以为空，但不能为 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathType.Filter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
类 XPathType.Filter

java.lang.Object
    继承者  javax.xml.crypto.dsig.spec.XPathType.Filter
正在封闭类：
XPathType
public static class XPathType.Filter
extends Object

表示过滤器设置操作。

字段摘要
static XPathType.Filter | INTERSECT 相交过滤操作。
static XPathType.Filter | SUBTRACT 减少过滤操作。
static XPathType.Filter | UNION 联合过滤操作。
方法摘要
 String toString()
返回操作的字符串形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

INTERSECT

public static final XPathType.Filter INTERSECT
相交过滤操作。

SUBTRACT

public static final XPathType.Filter SUBTRACT
减少过滤操作。

UNION

public static final XPathType.Filter UNION
联合过滤操作。

方法详细信息

toString

public String toString()
返回操作的字符串形式。

覆盖：
类 Object 中的 toString
返回：
操作的字符串形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XSLTTransformParameterSpec (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.crypto.dsig.spec
类 XSLTTransformParameterSpec

java.lang.Object
    继承者  javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
所有已实现的接口：
AlgorithmParameterSpec, TransformParameterSpec
public final class XSLTTransformParameterSpec
extends Object
implements TransformParameterSpec

XSLT Transform Algorithm 的参数。该参数包括名称空间限定的样式表元素。

XSLTTransformParameterSpec 使用与机制（如：DOM）有关的样式表元素进行实例化。例如：

DOMStructure stylesheet = new DOMStructure(element)
XSLTTransformParameterSpec spec = new XSLTransformParameterSpec(stylesheet);
其中 element 是一个包含名称空间限定的样式表元素的 Element。

从以下版本开始：
1.6
另请参见：
Transform

构造方法摘要
XSLTTransformParameterSpec(XMLStructure stylesheet)
创建带有指定样式表的 XSLTTransformParameterSpec。
方法摘要
 XMLStructure getStylesheet()
返回样式表。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XSLTTransformParameterSpec

public XSLTTransformParameterSpec(XMLStructure stylesheet)
创建带有指定样式表的 XSLTTransformParameterSpec。

参数：
stylesheet - 要使用的 XSLT 样式表
抛出：
NullPointerException - 如果 stylesheet 为 null
方法详细信息

getStylesheet

public XMLStructure getStylesheet()
返回样式表。

返回：
样式表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.crypto.dsig.spec (Java Platform SE 6)

 javax.xml.crypto.dsig.spec
接口
C14NMethodParameterSpec
DigestMethodParameterSpec
SignatureMethodParameterSpec
TransformParameterSpec
类
ExcC14NParameterSpec
HMACParameterSpec
XPathFilter2ParameterSpec
XPathFilterParameterSpec
XPathType
XPathType.Filter
XSLTTransformParameterSpec


javax.xml.crypto.dsig.spec (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.crypto.dsig.spec

XML 数字签名的参数类。

请参见：
描述

接口摘要
C14NMethodParameterSpec | CanonicalizationMethod 算法的算法参数规范。
DigestMethodParameterSpec | 用于 DigestMethod 算法的算法参数的规范。
SignatureMethodParameterSpec | 用于 XML SignatureMethod 算法的算法参数规范。
TransformParameterSpec | 用于 Transform 算法的算法参数规范。

类摘要
ExcC14NParameterSpec | W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。
HMACParameterSpec | XML Signature HMAC Algorithm 的参数。
XPathFilter2ParameterSpec | W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。
XPathFilterParameterSpec | XPath Filtering Transform Algorithm 的参数。
XPathType | W3C Recommendation for XML-Signature XPath Filter 2.0 中所定义的 XPath 元素的 XML 模式定义：
XPathType.Filter | 表示过滤器设置操作。
XSLTTransformParameterSpec | XSLT Transform Algorithm 的参数。

软件包 javax.xml.crypto.dsig.spec 的描述

XML 数字签名的参数类。此包包含一些接口和类，用于表示 XML 签名过程中使用的摘要、签名、转换或规范化算法的输入参数。

包规范

  • XML-Signature Syntax and Processing:W3C Recommendation
  • RFC 3275:XML-Signature Syntax and Processing
  • Exclusive XML Canonicalization algorithm:W3C Recommendation
  • XPath Filter 2.0 Transform Algorithm:W3C Recommendation

Since:
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.crypto.dsig.spec 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dsig.spec 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec (implements javax.xml.crypto.dsig.spec.C14NMethodParameterSpec)
    • javax.xml.crypto.dsig.spec.HMACParameterSpec (implements javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilterParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathType
    • javax.xml.crypto.dsig.spec.XPathType.Filter
    • javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)

接口分层结构

  • java.security.spec.AlgorithmParameterSpec
    • javax.xml.crypto.dsig.spec.DigestMethodParameterSpec
    • javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec
    • javax.xml.crypto.dsig.spec.TransformParameterSpec
      • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.crypto.dsig.spec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.crypto.dsig.spec
的使用

使用 javax.xml.crypto.dsig.spec 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dsig 使用的 javax.xml.crypto.dsig.spec 中的类
C14NMethodParameterSpec
CanonicalizationMethod 算法的算法参数规范。
DigestMethodParameterSpec
用于 DigestMethod 算法的算法参数的规范。
SignatureMethodParameterSpec
用于 XML SignatureMethod 算法的算法参数规范。
TransformParameterSpec
用于 Transform 算法的算法参数规范。

javax.xml.crypto.dsig.spec 使用的 javax.xml.crypto.dsig.spec 中的类
C14NMethodParameterSpec
CanonicalizationMethod 算法的算法参数规范。
SignatureMethodParameterSpec
用于 XML SignatureMethod 算法的算法参数规范。
TransformParameterSpec
用于 Transform 算法的算法参数规范。
XPathType.Filter
表示过滤器设置操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.spec.C14NMethodParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
的使用

使用 C14NMethodParameterSpec 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dsig 中 C14NMethodParameterSpec 的使用

参数类型为 C14NMethodParameterSpec 的 javax.xml.crypto.dsig 中的方法
abstract  CanonicalizationMethod XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
针对指定的算法 URI 和参数创建 CanonicalizationMethod。

javax.xml.crypto.dsig.spec 中 C14NMethodParameterSpec 的使用

实现 C14NMethodParameterSpec 的 javax.xml.crypto.dsig.spec 中的类
 class ExcC14NParameterSpec
W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.spec.DigestMethodParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.spec.DigestMethodParameterSpec
的使用

使用 DigestMethodParameterSpec 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 DigestMethodParameterSpec 的使用

参数类型为 DigestMethodParameterSpec 的 javax.xml.crypto.dsig 中的方法
abstract  DigestMethod XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params)
针对指定的算法 URI 和参数创建 DigestMethod。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.HMACParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.HMACParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.HMACParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec
的使用

使用 SignatureMethodParameterSpec 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dsig 中 SignatureMethodParameterSpec 的使用

参数类型为 SignatureMethodParameterSpec 的 javax.xml.crypto.dsig 中的方法
abstract  SignatureMethod XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
针对指定的算法 URI 和参数创建 SignatureMethod。

javax.xml.crypto.dsig.spec 中 SignatureMethodParameterSpec 的使用

实现 SignatureMethodParameterSpec 的 javax.xml.crypto.dsig.spec 中的类
 class HMACParameterSpec
XML Signature HMAC Algorithm 的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.spec.TransformParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.spec.TransformParameterSpec
的使用

使用 TransformParameterSpec 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dsig 中 TransformParameterSpec 的使用

参数类型为 TransformParameterSpec 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.init(TransformParameterSpec params) 使用指定的参数初始化此 TransformService。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。

javax.xml.crypto.dsig.spec 中 TransformParameterSpec 的使用

javax.xml.crypto.dsig.spec 中 TransformParameterSpec 的子接口
 interface C14NMethodParameterSpec
CanonicalizationMethod 算法的算法参数规范。

实现 TransformParameterSpec 的 javax.xml.crypto.dsig.spec 中的类
class | ExcC14NParameterSpec W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。
class | XPathFilter2ParameterSpec W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。
class | XPathFilterParameterSpec XPath Filtering Transform Algorithm 的参数。
class | XSLTTransformParameterSpec XSLT Transform Algorithm 的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XPathType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XPathType
的使用

没有 javax.xml.crypto.dsig.spec.XPathType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XPathType.Filter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XPathType.Filter
的使用

使用 XPathType.Filter 的软件包
javax.xml.crypto.dsig.spec XML 数字签名的参数类。

javax.xml.crypto.dsig.spec 中 XPathType.Filter 的使用

声明为 XPathType.Filter 的 javax.xml.crypto.dsig.spec 中的字段
static XPathType.Filter | XPathType.Filter.INTERSECT 相交过滤操作。
static XPathType.Filter | XPathType.Filter.SUBTRACT 减少过滤操作。
static XPathType.Filter | XPathType.Filter.UNION 联合过滤操作。

返回 XPathType.Filter 的 javax.xml.crypto.dsig.spec 中的方法
 XPathType.Filter XPathType.getFilter()
返回过滤操作。

参数类型为 XPathType.Filter 的 javax.xml.crypto.dsig.spec 中的构造方法
XPathType(String expression, XPathType.Filter filter)
创建带有指定 XPath 表达式和过滤器的 XPathType 实例。
XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
的使用

没有 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.CanonicalizationMethod 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.CanonicalizationMethod
的使用

使用 CanonicalizationMethod 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 CanonicalizationMethod 的使用

返回 CanonicalizationMethod 的 javax.xml.crypto.dsig 中的方法
CanonicalizationMethod | SignedInfo.getCanonicalizationMethod() 返回此 SignedInfo 的规范化方法。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。

参数类型为 CanonicalizationMethod 的 javax.xml.crypto.dsig 中的方法
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.DigestMethod 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.DigestMethod
的使用

使用 DigestMethod 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 DigestMethod 的使用

返回 DigestMethod 的 javax.xml.crypto.dsig 中的方法
DigestMethod | Reference.getDigestMethod() 返回此 Reference 的摘要方法。
abstract DigestMethod | XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params) 针对指定的算法 URI 和参数创建 DigestMethod。

参数类型为 DigestMethod 的 javax.xml.crypto.dsig 中的方法
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm) 创建带指定 URI 和摘要方法的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue) 创建带指定参数和预计算的摘要值的 Reference。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.Manifest 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.Manifest
的使用

使用 Manifest 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 Manifest 的使用

返回 Manifest 的 javax.xml.crypto.dsig 中的方法
abstract Manifest | XMLSignatureFactory.newManifest(List references) 创建包含指定的 Reference 列表的 Manifest。
abstract Manifest | XMLSignatureFactory.newManifest(List references, String id) 创建包含指定的 Reference 列表和可选 id 的 Manifest。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.Reference 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.Reference
的使用

使用 Reference 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 Reference 的使用

返回 Reference 的 javax.xml.crypto.dsig 中的方法
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm) 创建带指定 URI 和摘要方法的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue) 创建带指定参数和预计算的摘要值的 Reference。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.SignatureMethod 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.SignatureMethod
的使用

使用 SignatureMethod 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 SignatureMethod 的使用

返回 SignatureMethod 的 javax.xml.crypto.dsig 中的方法
SignatureMethod | SignedInfo.getSignatureMethod() 返回此 SignedInfo 的签名方法。
abstract SignatureMethod | XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params) 针对指定的算法 URI 和参数创建 SignatureMethod。

参数类型为 SignatureMethod 的 javax.xml.crypto.dsig 中的方法
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.SignatureProperties 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.SignatureProperties
的使用

使用 SignatureProperties 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 SignatureProperties 的使用

返回 SignatureProperties 的 javax.xml.crypto.dsig 中的方法
abstract  SignatureProperties XMLSignatureFactory.newSignatureProperties(List properties, String id)
创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.SignatureProperty 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.SignatureProperty
的使用

使用 SignatureProperty 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 SignatureProperty 的使用

返回 SignatureProperty 的 javax.xml.crypto.dsig 中的方法
abstract  SignatureProperty XMLSignatureFactory.newSignatureProperty(List content, String target, String id)
创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.SignedInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.SignedInfo
的使用

使用 SignedInfo 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 SignedInfo 的使用

返回 SignedInfo 的 javax.xml.crypto.dsig 中的方法
SignedInfo | XMLSignature.getSignedInfo() 返回此 XMLSignature 的签名信息。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。

参数类型为 SignedInfo 的 javax.xml.crypto.dsig 中的方法
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki) 创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.Transform 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.Transform
的使用

使用 Transform 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 Transform 的使用

javax.xml.crypto.dsig 中 Transform 的子接口
 interface CanonicalizationMethod
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。

实现 Transform 的 javax.xml.crypto.dsig 中的类
 class TransformService
转换算法和规范算法的服务提供者接口。

返回 Transform 的 javax.xml.crypto.dsig 中的方法
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.TransformException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.TransformException
的使用

使用 TransformException 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 TransformException 的使用

抛出 TransformException 的 javax.xml.crypto.dsig 中的方法
Data | Transform.transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | Transform.transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.TransformService 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.TransformService
的使用

使用 TransformService 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 TransformService 的使用

返回 TransformService 的 javax.xml.crypto.dsig 中的方法
static TransformService | TransformService.getInstance(String algorithm, String mechanismType) 返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, Provider provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, String provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLObject
的使用

使用 XMLObject 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLObject 的使用

返回 XMLObject 的 javax.xml.crypto.dsig 中的方法
abstract  XMLObject XMLSignatureFactory.newXMLObject(List content, String id, String mimeType, String encoding)
根据指定参数创建 XMLObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLSignContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLSignContext
的使用

使用 XMLSignContext 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig 中 XMLSignContext 的使用

参数类型为 XMLSignContext 的 javax.xml.crypto.dsig 中的方法
 void XMLSignature.sign(XMLSignContext signContext)
为此 XMLSignature 签名。

javax.xml.crypto.dsig.dom 中 XMLSignContext 的使用

实现 XMLSignContext 的 javax.xml.crypto.dsig.dom 中的类
 class DOMSignContext
特定于 DOM 的 XMLSignContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLSignature 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLSignature
的使用

使用 XMLSignature 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLSignature 的使用

返回 XMLSignature 的 javax.xml.crypto.dsig 中的方法
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki) 创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure) 从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context) 从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue
的使用

使用 XMLSignature.SignatureValue 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLSignature.SignatureValue 的使用

返回 XMLSignature.SignatureValue 的 javax.xml.crypto.dsig 中的方法
 XMLSignature.SignatureValue XMLSignature.getSignatureValue()
返回此 XMLSignature 的签名值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.XMLSignatureException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.XMLSignatureException
的使用

使用 XMLSignatureException 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLSignatureException 的使用

抛出 XMLSignatureException 的 javax.xml.crypto.dsig 中的方法
void | XMLSignature.sign(XMLSignContext signContext) 为此 XMLSignature 签名。
boolean | Reference.validate(XMLValidateContext validateContext) 验证此引用。
boolean | XMLSignature.validate(XMLValidateContext validateContext) 根据核心验证处理规则来验证签名。
boolean | XMLSignature.SignatureValue.validate(XMLValidateContext validateContext) 验证签名值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.dsig.XMLSignatureFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.dsig.XMLSignatureFactory
的使用

使用 XMLSignatureFactory 的软件包
javax.xml.crypto.dsig 用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig 中 XMLSignatureFactory 的使用

返回 XMLSignatureFactory 的 javax.xml.crypto.dsig 中的方法
static XMLSignatureFactory | XMLSignatureFactory.getInstance() 返回支持默认的 XML 处理机制和表示形式类型（“DOM”） 的 XMLSignatureFactory。
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType) 返回 XMLSignatureFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType, Provider provider) 返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType, String provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.dsig.XMLValidateContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.dsig.XMLValidateContext
的使用

使用 XMLValidateContext 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig 中 XMLValidateContext 的使用

参数类型为 XMLValidateContext 的 javax.xml.crypto.dsig 中的方法
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context) 从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。
boolean | Reference.validate(XMLValidateContext validateContext) 验证此引用。
boolean | XMLSignature.validate(XMLValidateContext validateContext) 根据核心验证处理规则来验证签名。
boolean | XMLSignature.SignatureValue.validate(XMLValidateContext validateContext) 验证签名值。

javax.xml.crypto.dsig.dom 中 XMLValidateContext 的使用

实现 XMLValidateContext 的 javax.xml.crypto.dsig.dom 中的类
 class DOMValidateContext
特定于 DOM 的 XMLValidateContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.AlgorithmMethod 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.AlgorithmMethod
的使用

使用 AlgorithmMethod 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。

javax.xml.crypto 中 AlgorithmMethod 的使用

参数类型为 AlgorithmMethod 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

javax.xml.crypto.dsig 中 AlgorithmMethod 的使用

javax.xml.crypto.dsig 中 AlgorithmMethod 的子接口
interface | CanonicalizationMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。
interface | DigestMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。
interface | SignatureMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。
interface | Transform W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。

实现 AlgorithmMethod 的 javax.xml.crypto.dsig 中的类
 class TransformService
转换算法和规范算法的服务提供者接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.Data 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.Data
的使用

使用 Data 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 Data 的使用

javax.xml.crypto 中 Data 的子接口
 interface NodeSetData
包含节点集的 Data 类型的抽象表示。

实现 Data 的 javax.xml.crypto 中的类
 class OctetStreamData
包含一个八位组流的 Data 类型的表示形式。

返回 Data 的 javax.xml.crypto 中的方法
 Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
取消引用指定 URIReference 并返回已取消引用的数据。

javax.xml.crypto.dsig 中 Data 的使用

返回 Data 的 javax.xml.crypto.dsig 中的方法
Data | Reference.getDereferencedData() 如果已启用引用缓存，则返回被取消引用的数据。
Data | Transform.transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | Transform.transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。

参数类型为 Data 的 javax.xml.crypto.dsig 中的方法
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
Data | Transform.transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | Transform.transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。

javax.xml.crypto.dsig.keyinfo 中 Data 的使用

返回 Data 的 javax.xml.crypto.dsig.keyinfo 中的方法
 Data RetrievalMethod.dereference(XMLCryptoContext context)
取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.KeySelector 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.KeySelector
的使用

使用 KeySelector 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto 中 KeySelector 的使用

返回 KeySelector 的 javax.xml.crypto 中的方法
KeySelector | XMLCryptoContext.getKeySelector() 返回用于查找某个密钥的密钥选择器。
static KeySelector | KeySelector.singletonKeySelector(Key key) 返回一个总是选择指定密钥的 KeySelector，不管传递给它的 KeyInfo 是什么。

参数类型为 KeySelector 的 javax.xml.crypto 中的方法
 void XMLCryptoContext.setKeySelector(KeySelector ks)
设置用于查找某个密钥的密钥选择器。

javax.xml.crypto.dom 中 KeySelector 的使用

返回 KeySelector 的 javax.xml.crypto.dom 中的方法
 KeySelector DOMCryptoContext.getKeySelector()

参数类型为 KeySelector 的 javax.xml.crypto.dom 中的方法
 void DOMCryptoContext.setKeySelector(KeySelector ks)

javax.xml.crypto.dsig.dom 中 KeySelector 的使用

参数类型为 KeySelector 的 javax.xml.crypto.dsig.dom 中的构造方法
DOMSignContext(KeySelector ks, Node parent)
创建带有指定密钥选择器和父节点的 DOMSignContext。
DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
创建带有指定密钥选择器、父节点和下一个兄弟节点的 DOMSignContext。
DOMValidateContext(KeySelector ks, Node node)
创建包含指定密钥选择器和节点的 DOMValidateContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.KeySelector.Purpose 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.KeySelector.Purpose
的使用

使用 KeySelector.Purpose 的软件包
javax.xml.crypto 用于 XML 加密的通用类。

javax.xml.crypto 中 KeySelector.Purpose 的使用

声明为 KeySelector.Purpose 的 javax.xml.crypto 中的字段
static KeySelector.Purpose | KeySelector.Purpose.DECRYPT 用于解密的密钥。
static KeySelector.Purpose | KeySelector.Purpose.ENCRYPT 用于加密的密钥。
static KeySelector.Purpose | KeySelector.Purpose.SIGN 用于签名的密钥。
static KeySelector.Purpose | KeySelector.Purpose.VERIFY 用于验证的密钥。

参数类型为 KeySelector.Purpose 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.KeySelectorException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.KeySelectorException
的使用

使用 KeySelectorException 的软件包
javax.xml.crypto 用于 XML 加密的通用类。

javax.xml.crypto 中 KeySelectorException 的使用

抛出 KeySelectorException 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.KeySelectorResult 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.KeySelectorResult
的使用

使用 KeySelectorResult 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。

javax.xml.crypto 中 KeySelectorResult 的使用

返回 KeySelectorResult 的 javax.xml.crypto 中的方法
abstract  KeySelectorResult KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context)
尝试查找满足指定约束的密钥。

javax.xml.crypto.dsig 中 KeySelectorResult 的使用

返回 KeySelectorResult 的 javax.xml.crypto.dsig 中的方法
 KeySelectorResult XMLSignature.getKeySelectorResult()
在对此 XMLSignature 进行签名或验证后，返回密钥选择器 KeySelector（如果已指定）的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.MarshalException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.MarshalException
的使用

使用 MarshalException 的软件包
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig 中 MarshalException 的使用

抛出 MarshalException 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context) 对特定于算法的参数进行编组。
void | XMLSignature.sign(XMLSignContext signContext) 为此 XMLSignature 签名。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure) 从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLValidateContext context) 从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。

javax.xml.crypto.dsig.keyinfo 中 MarshalException 的使用

抛出 MarshalException 的 javax.xml.crypto.dsig.keyinfo 中的方法
void | KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context) 将密钥信息编组为 XML。
abstract KeyInfo | KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure) 根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.NoSuchMechanismException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.NoSuchMechanismException
的使用

没有 javax.xml.crypto.NoSuchMechanismException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.NodeSetData 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.NodeSetData
的使用

没有 javax.xml.crypto.NodeSetData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.OctetStreamData 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.OctetStreamData
的使用

没有 javax.xml.crypto.OctetStreamData 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.URIDereferencer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.URIDereferencer
的使用

使用 URIDereferencer 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 URIDereferencer 的使用

返回 URIDereferencer 的 javax.xml.crypto 中的方法
 URIDereferencer XMLCryptoContext.getURIDereferencer()
返回用来取消引用 URIReference 的 URIDereferencer。

参数类型为 URIDereferencer 的 javax.xml.crypto 中的方法
 void XMLCryptoContext.setURIDereferencer(URIDereferencer dereferencer)
设置用来取消引用 URIReference 的 URIDereferencer。

javax.xml.crypto.dom 中 URIDereferencer 的使用

返回 URIDereferencer 的 javax.xml.crypto.dom 中的方法
 URIDereferencer DOMCryptoContext.getURIDereferencer()

参数类型为 URIDereferencer 的 javax.xml.crypto.dom 中的方法
 void DOMCryptoContext.setURIDereferencer(URIDereferencer dereferencer)

javax.xml.crypto.dsig 中 URIDereferencer 的使用

返回 URIDereferencer 的 javax.xml.crypto.dsig 中的方法
abstract  URIDereferencer XMLSignatureFactory.getURIDereferencer()
返回对 URIDereferencer 的引用，默认情况下该引用用于取消 Reference 对象中对 URI 的引用。

javax.xml.crypto.dsig.keyinfo 中 URIDereferencer 的使用

返回 URIDereferencer 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  URIDereferencer KeyInfoFactory.getURIDereferencer()
返回对 URIDereferencer 的引用，默认情况下用于取消引用 RetrievalMethod 对象中的 URI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.URIReference 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.URIReference
的使用

使用 URIReference 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 URIReference 的使用

返回 URIReference 的 javax.xml.crypto 中的方法
 URIReference URIReferenceException.getURIReference()
返回抛出异常时正被取消引用的 URIReference。

参数类型为 URIReference 的 javax.xml.crypto 中的方法
 Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
取消引用指定 URIReference 并返回已取消引用的数据。

参数类型为 URIReference 的 javax.xml.crypto 中的构造方法
URIReferenceException(String message, Throwable cause, URIReference uriReference)
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。

javax.xml.crypto.dom 中 URIReference 的使用

javax.xml.crypto.dom 中 URIReference 的子接口
 interface DOMURIReference
特定于 DOM 的 URIReference。

javax.xml.crypto.dsig 中 URIReference 的使用

javax.xml.crypto.dsig 中 URIReference 的子接口
 interface Reference
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。

javax.xml.crypto.dsig.keyinfo 中 URIReference 的使用

javax.xml.crypto.dsig.keyinfo 中 URIReference 的子接口
 interface RetrievalMethod
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.crypto.URIReferenceException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.crypto.URIReferenceException
的使用

使用 URIReferenceException 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 URIReferenceException 的使用

抛出 URIReferenceException 的 javax.xml.crypto 中的方法
 Data URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context)
取消引用指定 URIReference 并返回已取消引用的数据。

javax.xml.crypto.dsig.keyinfo 中 URIReferenceException 的使用

抛出 URIReferenceException 的 javax.xml.crypto.dsig.keyinfo 中的方法
 Data RetrievalMethod.dereference(XMLCryptoContext context)
取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.XMLCryptoContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.XMLCryptoContext
的使用

使用 XMLCryptoContext 的软件包
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto 中 XMLCryptoContext 的使用

参数类型为 XMLCryptoContext 的 javax.xml.crypto 中的方法
Data | URIDereferencer.dereference(URIReference uriReference, XMLCryptoContext context) 取消引用指定 URIReference 并返回已取消引用的数据。
abstract KeySelectorResult | KeySelector.select(KeyInfo keyInfo, KeySelector.Purpose purpose, AlgorithmMethod method, XMLCryptoContext context) 尝试查找满足指定约束的密钥。

javax.xml.crypto.dom 中 XMLCryptoContext 的使用

实现 XMLCryptoContext 的 javax.xml.crypto.dom 中的类
 class DOMCryptoContext
此类提供 XMLCryptoContext 接口特定于 DOM 的实现。

javax.xml.crypto.dsig 中 XMLCryptoContext 的使用

javax.xml.crypto.dsig 中 XMLCryptoContext 的子接口
interface | XMLSignContext 包含用于生成 XML Signature 的上下文信息。
interface | XMLValidateContext 包含用于验证 XML Signature 的上下文信息。

参数类型为 XMLCryptoContext 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.init(XMLStructure parent, XMLCryptoContext context) 使用指定的参数和文档上下文初始化此 TransformService。
abstract void | TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context) 对特定于算法的参数进行编组。
Data | Transform.transform(Data data, XMLCryptoContext context) 使用底层转换算法对指定数据进行转换。
Data | Transform.transform(Data data, XMLCryptoContext context, OutputStream os) 使用底层转换算法对指定数据进行转换。

javax.xml.crypto.dsig.dom 中 XMLCryptoContext 的使用

实现 XMLCryptoContext 的 javax.xml.crypto.dsig.dom 中的类
class | DOMSignContext 特定于 DOM 的 XMLSignContext。
class | DOMValidateContext 特定于 DOM 的 XMLValidateContext。

javax.xml.crypto.dsig.keyinfo 中 XMLCryptoContext 的使用

参数类型为 XMLCryptoContext 的 javax.xml.crypto.dsig.keyinfo 中的方法
Data | RetrievalMethod.dereference(XMLCryptoContext context) 取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。
void | KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context) 将密钥信息编组为 XML。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.crypto.XMLStructure 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.crypto.XMLStructure
的使用

使用 XMLStructure 的软件包
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

javax.xml.crypto.dom 中 XMLStructure 的使用

实现 XMLStructure 的 javax.xml.crypto.dom 中的类
 class DOMStructure
特定于 DOM 的 XMLStructure。

javax.xml.crypto.dsig 中 XMLStructure 的使用

javax.xml.crypto.dsig 中 XMLStructure 的子接口
interface | CanonicalizationMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。
interface | DigestMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。
interface | Manifest 在 W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Manifest 元素的表示形式。
interface | Reference W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。
interface | SignatureMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。
interface | SignatureProperties W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperties 元素的表示形式。
interface | SignatureProperty W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperty 元素的表示形式。
interface | SignedInfo W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignedInfo 元素的表示形式。
interface | Transform W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。
interface | XMLObject W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Object 元素的表示形式。
interface | XMLSignature W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Signature 元素的表示形式。
static interface | XMLSignature.SignatureValue W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureValue 元素的表示形式。

实现 XMLStructure 的 javax.xml.crypto.dsig 中的类
 class TransformService
转换算法和规范算法的服务提供者接口。

参数类型为 XMLStructure 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.init(XMLStructure parent, XMLCryptoContext context) 使用指定的参数和文档上下文初始化此 TransformService。
abstract void | TransformService.marshalParams(XMLStructure parent, XMLCryptoContext context) 对特定于算法的参数进行编组。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。
abstract XMLSignature | XMLSignatureFactory.unmarshalXMLSignature(XMLStructure xmlStructure) 从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。

javax.xml.crypto.dsig.keyinfo 中 XMLStructure 的使用

javax.xml.crypto.dsig.keyinfo 中 XMLStructure 的子接口
interface | KeyInfo W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。
interface | KeyName W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyName 元素的表示形式。
interface | KeyValue W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyValue 元素的表示形式。
interface | PGPData W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML PGPData 元素的表示形式。
interface | RetrievalMethod W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。
interface | X509Data W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509Data 元素的表示形式。
interface | X509IssuerSerial W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509IssuerSerial 元素的表示形式。

参数类型为 XMLStructure 的 javax.xml.crypto.dsig.keyinfo 中的方法
void | KeyInfo.marshal(XMLStructure parent, XMLCryptoContext context) 将密钥信息编组为 XML。
abstract KeyInfo | KeyInfoFactory.unmarshalKeyInfo(XMLStructure xmlStructure) 根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。

javax.xml.crypto.dsig.spec 中 XMLStructure 的使用

返回 XMLStructure 的 javax.xml.crypto.dsig.spec 中的方法
 XMLStructure XSLTTransformParameterSpec.getStylesheet()
返回样式表。

参数类型为 XMLStructure 的 javax.xml.crypto.dsig.spec 中的构造方法
XSLTTransformParameterSpec(XMLStructure stylesheet)
创建带有指定样式表的 XSLTTransformParameterSpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DatatypeConfigurationException (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.datatype
类 DatatypeConfigurationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.datatype.DatatypeConfigurationException
所有已实现的接口：
Serializable
public class DatatypeConfigurationException
extends Exception

指示严重的配置错误。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
DatatypeConfigurationException()
创建不带任何指定详细消息和原因的新 DatatypeConfigurationException。
DatatypeConfigurationException(String message)
创建带指定详细消息的新 DatatypeConfigurationException。
DatatypeConfigurationException(String message, Throwable cause)
创建带有指定详细消息和原因的新 DatatypeConfigurationException。
DatatypeConfigurationException(Throwable cause)
使用指定的原因创建一个新的 DatatypeConfigurationException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DatatypeConfigurationException

public DatatypeConfigurationException()

创建不带任何指定详细消息和原因的新 DatatypeConfigurationException。

DatatypeConfigurationException

public DatatypeConfigurationException(String message)

创建带指定详细消息的新 DatatypeConfigurationException。

参数：
message - 详细消息。

DatatypeConfigurationException

public DatatypeConfigurationException(String message,
                                      Throwable cause)

创建带有指定详细消息和原因的新 DatatypeConfigurationException。

参数：
message - 详细消息。
cause - 原因。允许通过 null 值指示原因是不存在的或是未知的。

DatatypeConfigurationException

public DatatypeConfigurationException(Throwable cause)

使用指定的原因创建一个新的 DatatypeConfigurationException。

参数：
cause - 原因。允许通过 null 值指示原因是不存在的或是未知的。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DatatypeConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.datatype
类 DatatypeConstants

java.lang.Object
    继承者  javax.xml.datatype.DatatypeConstants

public final class DatatypeConstants
extends Object

包含基本 Datatype 值作为常量的实用工具类。

从以下版本开始：
1.5

嵌套类摘要
static class DatatypeConstants.Field
类型安全的枚举类，它表示 Duration 类的六个字段。
字段摘要
static int | APRIL 用于一年第四个月的值。
static int | AUGUST 用于一年第八个月的值。
static QName | DATE W3C XML 模式 1.0 数据类型 date 的完全限定名称。
static QName | DATETIME W3C XML 模式 1.0 数据类型 dateTime 的完全限定名称。
static DatatypeConstants.Field | DAYS 表示日字段的常量。
static int | DECEMBER 用于一年第十二个月的值。
static QName | DURATION W3C XML 模式数据类型 duration 的完全限定名称。
static QName | DURATION_DAYTIME XQuery 1.0 和 Path 2.0 数据类型 dayTimeDuration 的完全限定名称。
static QName | DURATION_YEARMONTH XQuery 1.0 和 XPath 2.0 数据类型 yearMonthDuration 的完全限定名称。
static int | EQUAL 比较结果。
static int | FEBRUARY 用于一年第二个月的值。
static int | FIELD_UNDEFINED 指定不设置“int”字段。
static QName | GDAY W3C XML 模式 1.0 数据类型 gDay 的完全限定名称。
static QName | GMONTH W3C XML 模式 1.0 数据类型 gMonth 的完全限定名称。
static QName | GMONTHDAY W3C XML 模式 1.0 数据类型 gMonthDay 的完全限定名称。
static int | GREATER 比较结果。
static QName | GYEAR W3C XML 模式 1.0 数据类型 gYear 的完全限定名称。
static QName | GYEARMONTH W3C XML 模式 1.0 数据类型 gYearMonth 的完全限定名称。
static DatatypeConstants.Field | HOURS 表示小时字段的常量。
static int | INDETERMINATE 比较结果。
static int | JANUARY 用于一年第一个月的值。
static int | JULY 用于一年第七个月的值。
static int | JUNE 用于一年第六个月的值。
static int | LESSER 比较结果。
static int | MARCH 用于一年第三个月的值。
static int | MAX_TIMEZONE_OFFSET W3C XML 模式最大时区偏移量是 -14:00。
static int | MAY 用于一年第五个月的值。
static int | MIN_TIMEZONE_OFFSET W3C XML 模式最小时区偏移量是 +14:00。
static DatatypeConstants.Field | MINUTES 表示分钟字段的常量。
static DatatypeConstants.Field | MONTHS 表示月字段的常量。
static int | NOVEMBER 用于一年第十一个月的值。
static int | OCTOBER 用于一年第十个月的值。
static DatatypeConstants.Field | SECONDS 表示秒字段的常量。
static int | SEPTEMBER 用于一年第九个月的值。
static QName | TIME W3C XML 模式 1.0 数据类型 time 的完全限定名称。
static DatatypeConstants.Field | YEARS 表示年字段的常量。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

JANUARY

public static final int JANUARY
用于一年第一个月的值。

另请参见：
常量字段值

FEBRUARY

public static final int FEBRUARY
用于一年第二个月的值。

另请参见：
常量字段值

MARCH

public static final int MARCH
用于一年第三个月的值。

另请参见：
常量字段值

APRIL

public static final int APRIL
用于一年第四个月的值。

另请参见：
常量字段值

MAY

public static final int MAY
用于一年第五个月的值。

另请参见：
常量字段值

JUNE

public static final int JUNE
用于一年第六个月的值。

另请参见：
常量字段值

JULY

public static final int JULY
用于一年第七个月的值。

另请参见：
常量字段值

AUGUST

public static final int AUGUST
用于一年第八个月的值。

另请参见：
常量字段值

SEPTEMBER

public static final int SEPTEMBER
用于一年第九个月的值。

另请参见：
常量字段值

OCTOBER

public static final int OCTOBER
用于一年第十个月的值。

另请参见：
常量字段值

NOVEMBER

public static final int NOVEMBER
用于一年第十一个月的值。

另请参见：
常量字段值

DECEMBER

public static final int DECEMBER
用于一年第十二个月的值。

另请参见：
常量字段值

LESSER

public static final int LESSER

比较结果。

另请参见：
常量字段值

EQUAL

public static final int EQUAL

比较结果。

另请参见：
常量字段值

GREATER

public static final int GREATER

比较结果。

另请参见：
常量字段值

INDETERMINATE

public static final int INDETERMINATE

比较结果。

另请参见：
常量字段值

FIELD_UNDEFINED

public static final int FIELD_UNDEFINED
指定不设置“int”字段。

另请参见：
常量字段值

YEARS

public static final DatatypeConstants.Field YEARS

表示年字段的常量。

MONTHS

public static final DatatypeConstants.Field MONTHS

表示月字段的常量。

DAYS

public static final DatatypeConstants.Field DAYS

表示日字段的常量。

HOURS

public static final DatatypeConstants.Field HOURS

表示小时字段的常量。

MINUTES

public static final DatatypeConstants.Field MINUTES

表示分钟字段的常量。

SECONDS

public static final DatatypeConstants.Field SECONDS

表示秒字段的常量。

DATETIME

public static final QName DATETIME

W3C XML 模式 1.0 数据类型 dateTime 的完全限定名称。

TIME

public static final QName TIME

W3C XML 模式 1.0 数据类型 time 的完全限定名称。

DATE

public static final QName DATE

W3C XML 模式 1.0 数据类型 date 的完全限定名称。

GYEARMONTH

public static final QName GYEARMONTH

W3C XML 模式 1.0 数据类型 gYearMonth 的完全限定名称。

GMONTHDAY

public static final QName GMONTHDAY

W3C XML 模式 1.0 数据类型 gMonthDay 的完全限定名称。

GYEAR

public static final QName GYEAR

W3C XML 模式 1.0 数据类型 gYear 的完全限定名称。

GMONTH

public static final QName GMONTH

W3C XML 模式 1.0 数据类型 gMonth 的完全限定名称。

GDAY

public static final QName GDAY

W3C XML 模式 1.0 数据类型 gDay 的完全限定名称。

DURATION

public static final QName DURATION

W3C XML 模式数据类型 duration 的完全限定名称。

DURATION_DAYTIME

public static final QName DURATION_DAYTIME

XQuery 1.0 和 Path 2.0 数据类型 dayTimeDuration 的完全限定名称。

DURATION_YEARMONTH

public static final QName DURATION_YEARMONTH

XQuery 1.0 和 XPath 2.0 数据类型 yearMonthDuration 的完全限定名称。

MAX_TIMEZONE_OFFSET

public static final int MAX_TIMEZONE_OFFSET
W3C XML 模式最大时区偏移量是 -14:00。时区偏移量以分钟为单位。

另请参见：
常量字段值

MIN_TIMEZONE_OFFSET

public static final int MIN_TIMEZONE_OFFSET
W3C XML 模式最小时区偏移量是 +14:00。时区偏移量以分钟为单位。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatatypeConstants.Field (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.datatype
类 DatatypeConstants.Field

java.lang.Object
    继承者  javax.xml.datatype.DatatypeConstants.Field
正在封闭类：
DatatypeConstants
public static final class DatatypeConstants.Field
extends Object

类型安全的枚举类，它表示 Duration 类的六个字段。

从以下版本开始：
1.5

方法摘要
int | getId() 获取此字段的 ID。
String | toString() 以英文返回字段名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

toString

public String toString()
以英文返回字段名称。此方法主要用于调试/诊断，不用于向终端用户显示。

覆盖：
类 Object 中的 toString
返回：
非 null 的有效字符串常量。

getId

public int getId()

获取此字段的 ID。

返回：
字段的 ID。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatatypeFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.datatype
类 DatatypeFactory

java.lang.Object
    继承者  javax.xml.datatype.DatatypeFactory

public abstract class DatatypeFactory
extends Object

创建新 javax.xml.datatype Object 的工厂，创建的对象可提供 XML 和 Java Object 之间的映射。

newInstance() 用于创建新的 DatatypeFactory。按下列顺序使用以下实现解析机制：

  1. 如果 DATATYPEFACTORY_PROPERTY 指定的系统属性 "javax.xml.datatype.DatatypeFactory" 存在，则实例化具有属性值名称的类。将实例化进程中抛出的任何异常包装为 DatatypeConfigurationException。
  2. 如果文件 ${JAVA_HOME}/lib/jaxp.properties 存在，则在 Properties Object 中加载它。然后查询 Properties Object，以获取前面步骤中的文档介绍的属性，并按照前面步骤中文档的介绍进行处理。
  3. 使用服务解析机制，例如 META-INF/services/java.xml.datatype.DatatypeFactory。将实例化进程中抛出的任何异常包装为 DatatypeConfigurationException。
  4. 最终机制将尝试实例化 DATATYPEFACTORY_IMPLEMENTATION_CLASS 指定的 Class。实例化进程中抛出的任何异常将被包装为 DatatypeConfigurationException。

从以下版本开始：
1.5

字段摘要
static String | DATATYPEFACTORY_IMPLEMENTATION_CLASS JSR 206: Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。
static String | DATATYPEFACTORY_PROPERTY JSR 206:Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。
构造方法摘要
protected DatatypeFactory()
受保护的构造方法，包外无法实例化。
方法摘要
abstract Duration | newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
Duration | newDuration(boolean isPositive, int years, int months, int days, int hours, int minutes, int seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
abstract Duration | newDuration(long durationInMilliSeconds) 获取新的 Duration 实例，它将 Duration 指定为毫秒。
abstract Duration | newDuration(String lexicalRepresentation) 获取新的 Duration 实例，它根据 XML 模式 1.0 第 3.2.6.1 节中的定义将 Duration 指定为其字符串表示形式 "PnYnMnDTnHnMnS"。
Duration | newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | newDurationDayTime(boolean isPositive, int day, int hour, int minute, int second) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | newDurationDayTime(long durationInMilliseconds) 使用 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中定义的指定毫秒创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | newDurationDayTime(String lexicalRepresentation) 通过解析其 String 表示形式 "PnDTnHnMnS"（XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration）创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | newDurationYearMonth(boolean isPositive, int year, int month) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | newDurationYearMonth(long durationInMilliseconds) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定毫秒创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | newDurationYearMonth(String lexicalRepresentation) 通过解析其 String 表示形式 "PnYnM"（XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration）创建类型为 xdt:yearMonthDuration 的 Duration。
static DatatypeFactory | newInstance() 获取新的 DatatypeFactory 实例。
static DatatypeFactory | newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DatatypeFactory 实例。
abstract XMLGregorianCalendar | newXMLGregorianCalendar() 创建新的 XMLGregorianCalendar 实例。
abstract XMLGregorianCalendar | newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone) W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
abstract XMLGregorianCalendar | newXMLGregorianCalendar(GregorianCalendar cal) 根据 GregorianCalendar 创建 XMLGregorianCalendar。
XMLGregorianCalendar | newXMLGregorianCalendar(int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone) java.util.GregorianCalendar 实例需要转换为 XMLGregorianCalendar 实例的值空间的构造方法。
abstract XMLGregorianCalendar | newXMLGregorianCalendar(String lexicalRepresentation) 通过将字符串解析为词汇表示形式，创建新的 XMLGregorianCalendar。
XMLGregorianCalendar | newXMLGregorianCalendarDate(int year, int month, int day, int timezone) 创建 XML 模式内置数据类型 date 或 g* 的 Java 表示形式。
XMLGregorianCalendar | newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
XMLGregorianCalendar | newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
XMLGregorianCalendar | newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int milliseconds, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DATATYPEFACTORY_PROPERTY

public static final String DATATYPEFACTORY_PROPERTY

JSR 206:Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。

默认值为 javax.xml.datatype.DatatypeFactory。

另请参见：
常量字段值

DATATYPEFACTORY_IMPLEMENTATION_CLASS

public static final String DATATYPEFACTORY_IMPLEMENTATION_CLASS

JSR 206: Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。

如果其他实现解析机制都没有成功，则实现者应该指定将被实例化的恰当类的名称。

用户不应该引用此字段；该字段只用来记录工厂实现详细信息。

构造方法详细信息

DatatypeFactory

protected DatatypeFactory()

受保护的构造方法，包外无法实例化。

使用 newInstance() 创建 DatatypeFactory。

方法详细信息

newInstance

public static DatatypeFactory newInstance()
                                   throws DatatypeConfigurationException

获取新的 DatatypeFactory 实例。

实现解析机制定义在此 Class 的文档中。

返回：
新的 DatatypeFactory 实例
抛出：
DatatypeConfigurationException - 如果该实现不可用，或者无法实例化。
另请参见：
newInstance(String factoryClassName, ClassLoader classLoader)

newInstance

public static DatatypeFactory newInstance(String factoryClassName,
                                          ClassLoader classLoader)
                                   throws DatatypeConfigurationException

从类名称中获取新的 DatatypeFactory 实例。此函数在类路径中有多个提供者时很有用。它可以对应用程序提供更多的控制，因为它可以指定应该加载哪个提供者。

在应用程序获取对 DatatypeFactory 的引用后，它可以使用工厂来配置和获取数据类型实例。

疑难解答提示

设置 jaxp.debug 系统属性将导致此方法将许多调试消息打印到 System.err，这些消息说明了正在执行的操作以及何处可以找到它。

如有问题，可以尝试使用以下代码：

 java -Djaxp.debug=1 YourProgram ....

参数：
factoryClassName - 提供 javax.xml.datatype.DatatypeFactory 实现的完全限定工厂类名称。
classLoader - 用来加载工厂类的 ClassLoader。如果该参数为 null，则使用当前 Thread 的上下文类加载器来加载工厂类。
返回：
新的 DatatypeFactory 实例
抛出：
DatatypeConfigurationException - 如果 factoryClassName 为 null，或者无法加载和实例化工厂类。
从以下版本开始：
1.6
另请参见：
newInstance()

newDuration

public abstract Duration newDuration(String lexicalRepresentation)

获取新的 Duration 实例，它根据 XML 模式 1.0 第 3.2.6.1 节中的定义将 Duration 指定为其字符串表示形式 "PnYnMnDTnHnMnS"。

XML 模式第二部分 Datatypes 中的 3.2.6 节 duration 将持续时间定义如下：

持续时间表示某一时间段。持续时间的值空间是六维空间，其中坐标分别指定 [ISO 8601] 的第 5.5.3.2 节中定义的 Gregorian year、month、day、hour、minute 和 second 组件。这些组件根据其重要性按其出现顺序（即 year、month、day、hour、minute、second）排序。

六个值都可以通过创建的 Duration 设置和获得

XML 模式规范说明值可以为任意大小。实现可以选择不（或不能）支持任意大和/或小的值。如果超过实现容量，则抛出 UnsupportedOperationException 和指示实现限制的消息。

参数：
lexicalRepresentation - Duration 的 String 表示形式。
返回：
通过解析 lexicalRepresentation 创建的新 Duration。
抛出：
IllegalArgumentException - 如果 lexicalRepresentation 不是 Duration 的有效表示形式。
UnsupportedOperationException - 如果实现无法支持请求值。
NullPointerException - 如果 lexicalRepresentation 为 null。

newDuration

public abstract Duration newDuration(long durationInMilliSeconds)

获取新的 Duration 实例，它将 Duration 指定为毫秒。

XML 模式第二部分 Datatypes 中的 3.2.6 节将持续时间定义为：

持续时间表示某一时间段。持续时间的值空间是六维空间，其中坐标分别指定 [ISO 8601] 的第 5.5.3.2 节中定义的 Gregorian year、month、day、hour、minute 和 second 组件。这些组件根据其重要性按其出现顺序（即 year、month、day、hour、minute 和 second）排序。

六个值都可以通过计算指定毫秒的值来设置，通过创建的 Duration 的 get 方法获得。该值符合以下规范并由其定义：

  • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
  • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
  • XMLGregorianCalendar XML 模式 1.0 和 Java 表示形式之间的日期/时间数据类型字段映射关系

通过 GregorianCalendar 使用的历元开始时间定义默认开始实例：即 Calendar.YEAR = 1970、Calendar.MONTH = Calendar.JANUARY、Calendar.DATE = 1 等。这非常重要，因为阳历中存在变化，例如，对于 month = Calendar.FEBRUARY，闰年会有不同的天数，所以 Duration.getMonths() 和 Duration.getDays() 的结果都会受到影响。

参数：
durationInMilliSeconds - 要创建的 Duration，以毫秒为单位。
返回：
表示 durationInMilliSeconds 的新 Duration。

newDuration

public abstract Duration newDuration(boolean isPositive,
                                     BigInteger years,
                                     BigInteger months,
                                     BigInteger days,
                                     BigInteger hours,
                                     BigInteger minutes,
                                     BigDecimal seconds)

获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。

XML 模式规范说明值可以为任意大小。实现可以选择不（或不能）支持任意大和/或小的值。如果超过实现容量，则抛出 UnsupportedOperationException 和指示实现限制的消息。

null 值指示不设置字段。

参数：
isPositive - 设置为 false 将创建负的 Duration。当 Duration 的长度为零时，将忽略此参数。
years - 此 Duration 的年
months - 此 Duration 的月
days - 此 Duration 的日
hours - 此 Duration 的时
minutes - 此 Duration 的分
seconds - 此 Duration 的秒
返回：
从指定的值创建的新 Duration。
抛出：
IllegalArgumentException - 如果值不是 Duration 的有效表示形式：如果所有这些字段（years、months 等等）为 null，或者任何一个为负。
UnsupportedOperationException - 如果实现无法支持请求值。

newDuration

public Duration newDuration(boolean isPositive,
                            int years,
                            int months,
                            int days,
                            int hours,
                            int minutes,
                            int seconds)

获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。

DatatypeConstants.FIELD_UNDEFINED 值指示不设置字段。

参数：
isPositive - 设置为 false 将创建负的 Duration。当 Duration 的长度为零时，将忽略此参数。
years - 此 Duration 的年
months - 此 Duration 的月
days - 此 Duration 的日
hours - 此 Duration 的时
minutes - 此 Duration 的分
seconds - 此 Duration 的秒
返回：
根据指定值创建的新 Duration。
抛出：
IllegalArgumentException - 如果值不是 Duration 的有效表示形式：如果任一字段为负。
另请参见：
newDuration( boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds)

newDurationDayTime

public Duration newDurationDayTime(String lexicalRepresentation)

通过解析其 String 表示形式 "PnDTnHnMnS"（XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration）创建类型为 xdt:dayTimeDuration 的 Duration。

数据类型 xdt:dayTimeDuration 是 xs:duration 的子类型，xs:duration 的词汇表示形式只包含 day、hour、minute 和 second 组件。此数据类型位于名称空间 http://www.w3.org/2003/11/xpath-datatypes 中。

四个值都可以从创建的 Duration 设置和获得。

XML 模式规范说明值可以为任意大小。实现可以选择不（或不能）支持任意大和/或小的值。如果超过实现容量，则抛出 UnsupportedOperationException 和指示实现限制的消息。

参数：
lexicalRepresentation - Duration 的词汇表示形式。
返回：
使用指定 lexicalRepresentation 创建的新 Duration。
抛出：
IllegalArgumentException - 如果 lexicalRepresentation 不是只以日期和时间形式表达的 Duration 的有效表示形式。
UnsupportedOperationException - 如果实现无法支持请求值。
NullPointerException - 如果 lexicalRepresentation 为 null。

newDurationDayTime

public Duration newDurationDayTime(long durationInMilliseconds)

使用 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中定义的指定毫秒创建类型为 xdt:dayTimeDuration 的 Duration。

数据类型 xdt:dayTimeDuration 是 xs:duration 的子类型，xs:duration 词汇表示形式只包含 day、hour、minute 和 second 组件。此数据类型位于名称空间 http://www.w3.org/2003/11/xpath-datatypes 中。

四个值都可以通过计算指定毫秒的值设置，通过创建的 Duration 的 get 方法获得。该值符合以下规范并由其定义：

  • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
  • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
  • XMLGregorianCalendar XML 模式 1.0 和 Java 表示形式之间的日期/时间数据类型字段映射关系

通过 GregorianCalendar 使用的历元开始时间定义默认开始实例：即 Calendar.YEAR = 1970、Calendar.MONTH = Calendar.JANUARY、Calendar.DATE = 1 等。这非常重要，因为阳历中存在变化，例如，对于 month = Calendar.FEBRUARY，闰年会有不同的天数，所以 Duration.getDays() 的结果将受到影响。

丢弃确定 day、hour、minute 和 second 之后所有剩余毫秒。

参数：
durationInMilliseconds - 要创建的 Duration 的毫秒。
返回：
使用指定 durationInMilliseconds 创建的新 Duration。
另请参见：
XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration

newDurationDayTime

public Duration newDurationDayTime(boolean isPositive,
                                   BigInteger day,
                                   BigInteger hour,
                                   BigInteger minute,
                                   BigInteger second)

根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。

数据类型 xdt:dayTimeDuration 是 xs:duration 的子类型，xs:duration 词汇表示形式只包含 day、hour、minute 和 second 组件。此数据类型位于名称空间 http://www.w3.org/2003/11/xpath-datatypes 中。

XML 模式规范说明值可以为任意大小。实现可以选择不（或不能）支持任意大和/或小的值。如果超过实现容量，则抛出 UnsupportedOperationException 和指示实现限制的消息。

null 值指示不设置字段。

参数：
isPositive - 设置为 false 将创建负的 Duration。当 Duration 的长度为零时，将忽略此参数。
day - Duration 的日。
hour - Duration 的时。
minute - Duration 的分。
second - Duration 的秒。
返回：
使用指定的 day、hour、minute 和 second 创建新的 Duration。
抛出：
IllegalArgumentException - 如果值不是 Duration 的有效表示形式：如果所有这些字段（years、months 等等）为 null，或者任何一个为负。
UnsupportedOperationException - 如果实现无法支持请求值。

newDurationDayTime

public Duration newDurationDayTime(boolean isPositive,
                                   int day,
                                   int hour,
                                   int minute,
                                   int second)

根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。

数据类型 xdt:dayTimeDuration 是 xs:duration 的子类型，xs:duration 词汇表示形式仅包含 day、hour、minute 和 second 组件。此数据类型位于名称空间 http://www.w3.org/2003/11/xpath-datatypes 中。

DatatypeConstants.FIELD_UNDEFINED 值指示不设置字段。

参数：
isPositive - 设置为 false 将创建负的 Duration。当 Duration 的长度为零时，将忽略此参数。
day - Duration 的日。
hour - Duration 的时。
minute - Duration 的分。
second - Duration 的秒。
返回：
使用指定的 day、hour、minute 和 second 创建新的 Duration。
抛出：
IllegalArgumentException - 如果值不是 Duration 的有效表示形式：如果所有这些字段（years、months 等等）为 null，或者任何一个为负。

newDurationYearMonth

public Duration newDurationYearMonth(String lexicalRepresentation)

通过解析其 String 表示形式 "PnYnM"（XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration）创建类型为 xdt:yearMonthDuration 的 Duration。

数据类型 xdt:yearMonthDuration 是 xs:duration 的子类型，xs:duration 词汇表示形式仅包含 year 和 month 组件。此数据类型位于名称空间 XMLConstants.W3C_XPATH_DATATYPE_NS_URI 中。

这两个值都可以从创建的 Duration 设置和获得

XML 模式规范说明值可以为任意大小。实现可以选择不（或不能）支持任意大和/或小的值。如果超过实现容量，则抛出 UnsupportedOperationException 和指示实现限制的消息。

参数：
lexicalRepresentation - Duration 的词汇表示形式。
返回：
使用指定 lexicalRepresentation 创建的新 Duration。
抛出：
IllegalArgumentException - 如果 lexicalRepresentation 不是通过 years 和 months 表示的 Duration 的有效表示形式。
UnsupportedOperationException - 如果实现无法支持请求值。
NullPointerException - 如果 lexicalRepresentation 为 null。

newDurationYearMonth

public Duration newDurationYearMonth(long durationInMilliseconds)

根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定毫秒创建类型为 xdt:yearMonthDuration 的 Duration。

数据类型 xdt:yearMonthDuration 是 xs:duration 的子类型，xs:duration 词汇表示形式只包含 year 和 month 组件。此数据类型位于名称空间 XMLConstants.W3C_XPATH_DATATYPE_NS_URI 中。

两个值都可以通过计算指定毫秒的值设置，通过创建的 Duration 的 get 方法获得。该值符合以下规范并由其定义：

  • ISO 8601:2000(E) Section 5.5.3.2 Alternative format
  • W3C XML Schema 1.0 Part 2, Appendix D, ISO 8601 Date and Time Formats
  • XMLGregorianCalendar XML 模式 1.0 和 Java 表示形式之间的日期/时间数据类型字段映射关系

通过 GregorianCalendar 使用的历元开始时间定义默认开始实例：即 Calendar.YEAR = 1970、Calendar.MONTH = Calendar.JANUARY、Calendar.DATE = 1 等。这非常重要，因为阳历中存在变化，例如，对于 month = Calendar.FEBRUARY，闰年会有不同的天数，所以 Duration.getMonths() 的结果将受到影响。

丢弃确定 year 和 month 之后所有剩余毫秒。

参数：
durationInMilliseconds - 要创建的 Duration 的毫秒。
返回：
使用指定 durationInMilliseconds 创建的新 Duration。

newDurationYearMonth

public Duration newDurationYearMonth(boolean isPositive,
                                     BigInteger year,
                                     BigInteger month)

根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。

XML 模式规范说明值可以为任意大小。实现可以选择不（或不能）支持任意大和/或小的值。如果超过实现容量，则抛出 UnsupportedOperationException 和指示实现限制的消息。

null 值指示不设置字段。

参数：
isPositive - 设置为 false 将创建负的 Duration。当 Duration 的长度为零时，将忽略此参数。
year - Duration 的年。
month - Duration 的月。
返回：
使用指定的 year 和 month 创建的新 Duration。
抛出：
IllegalArgumentException - 如果值不是 Duration 的有效表示形式：如果所有这些字段（years、months 等等）为 null，或者任何一个为负。
UnsupportedOperationException - 如果实现无法支持请求值。

newDurationYearMonth

public Duration newDurationYearMonth(boolean isPositive,
                                     int year,
                                     int month)

根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。

DatatypeConstants.FIELD_UNDEFINED 值指示不设置字段。

参数：
isPositive - 设置为 false 将创建负的 Duration。当 Duration 的长度为零时，将忽略此参数。
year - Duration 的年。
month - Duration 的月。
返回：
使用指定的 year 和 month 创建的新 Duration。
抛出：
IllegalArgumentException - 如果值不是 Duration 的有效表示形式：如果这些字段（year 和 month）中的任何一个为负。

newXMLGregorianCalendar

public abstract XMLGregorianCalendar newXMLGregorianCalendar()

创建新的 XMLGregorianCalendar 实例。

设置为 DatatypeConstants.FIELD_UNDEFINED 或 null 的所有日期/时间数据类型字段。

返回：
新的 XMLGregorianCalendar，其所有日期/时间数据类型字段设置为 DatatypeConstants.FIELD_UNDEFINED 或 null。

newXMLGregorianCalendar

public abstract XMLGregorianCalendar newXMLGregorianCalendar(String lexicalRepresentation)

通过将字符串解析为词汇表示形式，创建新的 XMLGregorianCalendar。

在 XML Schema 1.0 Part 2, Section 3.2.[7-14].1, Lexical Representation 中定义了解析词汇字符串表示形式。

字符串表示形式不能存在任何前导和尾部空格。

逐字段执行解析，以便以下内容保存任何词汇正确的字符串 x：

 newXMLGregorianCalendar(x).toXMLFormat().equals(x)

XML Schema 1.0 errata, Section 3.2.7.2 中列出的注释词汇/规范化表示形式不匹配的情况除外。

参数：
lexicalRepresentation - 八个 XML 模式日期/时间数据数型之一的词汇表示形式。
返回：
根据 lexicalRepresentation 创建的 XMLGregorianCalendar。
抛出：
IllegalArgumentException - 如果 lexicalRepresentation 不是有效的 XMLGregorianCalendar。
NullPointerException - 如果 lexicalRepresentation 为 null。

newXMLGregorianCalendar

public abstract XMLGregorianCalendar newXMLGregorianCalendar(GregorianCalendar cal)

根据 GregorianCalendar 创建 XMLGregorianCalendar。

从 GregorianCalendar 到 XMLGregorianCalendar 的逐字段转换
java.util.GregorianCalendar 字段 | javax.xml.datatype.XMLGregorianCalendar 字段
ERA == GregorianCalendar.BC ? -YEAR :YEAR | XMLGregorianCalendar.setYear(int year)
MONTH + 1 | XMLGregorianCalendar.setMonth(int month)
DAY_OF_MONTH | XMLGregorianCalendar.setDay(int day)
HOUR_OF_DAY, MINUTE, SECOND, MILLISECOND | XMLGregorianCalendar.setTime(int hour, int minute, int second, BigDecimal fractional)
(ZONE_OFFSET + DST_OFFSET) / (60*1000)
（以分为单位） 		XMLGregorianCalendar.setTimezone(int offset) *

* 转换丢失信息。不能以 XML 模式 1.0 日期/时间数据类型表示形式表示 java.util.GregorianCalendar 夏令时时区 id。

要计算返回值的 TimeZone 字段，

  • 当 this.getTimezone() != FIELD_UNDEFINED 时，使用 this.getTimezone() 创建带有自定义时区 id 的 java.util.TimeZone。
  • 此外，对主机使用 GregorianCalendar 默认时区值按 java.util.TimeZone.getDefault() 指定的方式定义。

    • 参数：
    cal - 用于创建 XMLGregorianCalendar 的 java.util.GregorianCalendar。
    返回：
    从 java.util.GregorianCalendar 创建的 XMLGregorianCalendar
    抛出：
    NullPointerException - 如果 cal 为 null。

newXMLGregorianCalendar

public abstract XMLGregorianCalendar newXMLGregorianCalendar(BigInteger year,
                                                             int month,
                                                             int day,
                                                             int hour,
                                                             int minute,
                                                             int second,
                                                             BigDecimal fractionalSecond,
                                                             int timezone)

W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。注意，year 参数支持任意大的数字，fractionalSecond 具有无限精度。

null 值指示不设置字段。

参数：
year - 要创建的 XMLGregorianCalendar 的年。
month - 要创建的 XMLGregorianCalendar 的月。
day - 要创建的 XMLGregorianCalendar 的日。
hour - 要创建的 XMLGregorianCalendar 的时。
minute - 要创建的 XMLGregorianCalendar 的分。
second - 要创建的 XMLGregorianCalendar 的秒。
fractionalSecond - 要创建的 XMLGregorianCalendar 的 fractionalSecond。
timezone - 要创建的 XMLGregorianCalendar 的时区。
返回：
根据指定值创建的 XMLGregorianCalendar。
抛出：
IllegalArgumentException - 如果任一参数的值超出由 XMLGregorianCalendar 中词汇 Data Mapping 表确定的字段的最大值约束，或者复合值组成了 XMLGregorianCalendar.isValid() 确定为无效的 XMLGregorianCalendar 实例。

newXMLGregorianCalendar

public XMLGregorianCalendar newXMLGregorianCalendar(int year,
                                                    int month,
                                                    int day,
                                                    int hour,
                                                    int minute,
                                                    int second,
                                                    int millisecond,
                                                    int timezone)

java.util.GregorianCalendar 实例需要转换为 XMLGregorianCalendar 实例的值空间的构造方法。

将 XMLGregorianCalendar eon 和 fractionalSecond 设置为 null

DatatypeConstants.FIELD_UNDEFINED 值指示不设置字段。

参数：
year - 要创建的 XMLGregorianCalendar 的年。
month - 要创建的 XMLGregorianCalendar 的月。
day - 要创建的 XMLGregorianCalendar 的日。
hour - 要创建的 XMLGregorianCalendar 的时。
minute - 要创建的 XMLGregorianCalendar 的分。
second - 要创建的 XMLGregorianCalendar 的秒。
millisecond - 要创建的 XMLGregorianCalendar 的毫秒。
timezone - 要创建的 XMLGregorianCalendar 的时区。
返回：
根据指定值创建的 XMLGregorianCalendar。
抛出：
IllegalArgumentException - 如果任一参数的值超出由 XMLGregorianCalendar 中词汇 Data Mapping 表确定的字段的最大值约束，或者复合值组成了 XMLGregorianCalendar.isValid() 确定为无效的 XMLGregorianCalendar 实例。

newXMLGregorianCalendarDate

public XMLGregorianCalendar newXMLGregorianCalendarDate(int year,
                                                        int month,
                                                        int day,
                                                        int timezone)

创建 XML 模式内置数据类型 date 或 g* 的 Java 表示形式。

例如，通过调用此工厂，并将 month 和 day 参数设置为 DatatypeConstants.FIELD_UNDEFINED，可以创建 gYear 实例。

DatatypeConstants.FIELD_UNDEFINED 值指示不设置字段。

参数：
year - 要创建的 XMLGregorianCalendar 的年。
month - 要创建的 XMLGregorianCalendar 的月。
day - 要创建的 XMLGregorianCalendar 的日。
timezone - 以分为单位的偏移量。DatatypeConstants.FIELD_UNDEFINED 指示未设置可选字段。
返回：
根据参数值创建的 XMLGregorianCalendar。
抛出：
IllegalArgumentException - 如果任一参数的值超出由 XMLGregorianCalendar 中词汇 Data Mapping 表确定的字段的最大值约束，或者复合值组成了 XMLGregorianCalendar.isValid() 确定为无效的 XMLGregorianCalendar 实例。
另请参见：
DatatypeConstants.FIELD_UNDEFINED

newXMLGregorianCalendarTime

public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                                        int minutes,
                                                        int seconds,
                                                        int timezone)

创建 XML 模式内置数据类型 time 的 Java 实例。

DatatypeConstants.FIELD_UNDEFINED 值指示不设置字段。

参数：
hours - 小时数
minutes - 分钟数
seconds - 秒数
timezone - 以分钟为单位的偏移量。DatatypeConstants.FIELD_UNDEFINED 指示未设置可选字段。
返回：
根据参数值创建的 XMLGregorianCalendar。
抛出：
IllegalArgumentException - 如果任何单个参数的值超出由 XMLGregorianCalendar 中词汇 Data Mapping 表确定的字段的最大值约束，或者复合值组成了 XMLGregorianCalendar.isValid() 确定为无效的 XMLGregorianCalendar 实例。
另请参见：
DatatypeConstants.FIELD_UNDEFINED

newXMLGregorianCalendarTime

public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                                        int minutes,
                                                        int seconds,
                                                        BigDecimal fractionalSecond,
                                                        int timezone)

创建 XML 模式内置数据类型 time 的 Java 实例。

null 值指示不设置字段。

DatatypeConstants.FIELD_UNDEFINED 值指示不设置字段。

参数：
hours - 小时数
minutes - 分钟数
seconds - 秒数
fractionalSecond - null 的值，它指示未设置此可选字段。
timezone - 以分为单位的偏移量。DatatypeConstants.FIELD_UNDEFINED 指示未设置可选字段。
返回：
根据参数值创建的 XMLGregorianCalendar。
抛出：
IllegalArgumentException - 如果任一参数的值超出由 XMLGregorianCalendar 中词汇 Data Mapping 表确定的字段的最大值约束，或者复合值组成了 XMLGregorianCalendar.isValid() 确定为无效的 XMLGregorianCalendar 实例。
另请参见：
DatatypeConstants.FIELD_UNDEFINED

newXMLGregorianCalendarTime

public XMLGregorianCalendar newXMLGregorianCalendarTime(int hours,
                                                        int minutes,
                                                        int seconds,
                                                        int milliseconds,
                                                        int timezone)

创建 XML 模式内置数据类型 time 的 Java 实例。

DatatypeConstants.FIELD_UNDEFINED 值指示不设置字段。

参数：
hours - 小时数
minutes - 分钟数
seconds - 秒数
milliseconds - 毫秒数
timezone - 以分钟为单位的偏移量。DatatypeConstants.FIELD_UNDEFINED 指示未设置可选字段。
返回：
根据参数值创建的 XMLGregorianCalendar。
抛出：
IllegalArgumentException - 如果任一参数的值超出由 XMLGregorianCalendar 中词汇 Data Mapping 表确定的字段的最大值约束，或者复合值了 XMLGregorianCalendar.isValid() 确定为无效的 XMLGregorianCalendar 实例。
另请参见：
DatatypeConstants.FIELD_UNDEFINED
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Duration (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.datatype
类 Duration

java.lang.Object
    继承者  javax.xml.datatype.Duration

public abstract class Duration
extends Object

W3C XML 模式 1.0 规范中定义的时间范围的不可变表示形式。

Duration 对象表示一段阳历时间，它由六个字段（years、months、days、hours、minutes 和 seconds）加上符号 (+/-) 字段组成。

前五个字段为非负 (>=0) 整数或 null（表示不设置字段），seconds 字段为非负小数或 null。负号指示负的持续时间。

此类提供大量的方法，使 XML 模式 1.0 及勘误中的 duration 数据类型的使用更简单。

顺序关系

Duration 对象只有部分顺序，其中值 A 和 B 可以是以下任一顺序：

  1. A<B（A 比 B 短）
  2. A>B（A 比 B 长）
  3. A==B（A 和 B 的持续时间相同）
  4. A<>B（A 和 B 之间的比较是不确定的）

例如，将 30 天与一个月比较没有意义。compare(Duration duration) 方法实现此关系。

有关 Duration 对象之间顺序关系的详细信息，请参阅 isLongerThan(Duration) 方法。

对 Duration 的操作

此类提供一组基本的算术运算，如加、减和乘。因为持续时间没有整体顺序，对一些组合操作，操作可能失败。例如，不能从 1 个月减去 15 天。有关发生此情形的详细情况，请参阅这些方法的 javadoc。

另外，不提供持续时间除以数字的除法，因为 Duration 类仅处理有限精度的十进制数字。例如，无法表示 1 秒除以 3。

但可以用乘以数字（如 0.3 或 0.333）替代除以 3 的除法。

允许值的范围

即使 Duration 可以保持非常大或非常小的值，因为某些 Duration 的操作依赖于 Calendar，所以一些方法不能在此类 Duration 上正常工作。受影响的方法记录其对 Calendar 的依赖。

从以下版本开始：
1.5
另请参见：
XMLGregorianCalendar.add(Duration)

构造方法摘要
Duration()
默认的无参数构造方法。
方法摘要
abstract Duration | add(Duration rhs) 计算值为 this+rhs 的新持续时间。
abstract void | addTo(Calendar calendar) 将此持续时间添加到 Calendar 对象。
void | addTo(Date date) 将此持续时间添加到 Date 对象。
abstract int | compare(Duration duration) 与此 Duration 实例的部分顺序关系比较。
boolean | equals(Object duration) 检查此持续时间对象是否与另一个 Duration 对象具有相同的持续时间。
int | getDays() 获取整数值形式的 DAYS 字段的值，如果不存在，则值为 0。
abstract Number | getField(DatatypeConstants.Field field) 获取字段的值。
int | getHours() 获取整数值形式的 HOURS 字段的值，如果不存在，则值为 0。
int | getMinutes() 获取整数值形式的 MINUTES 字段的值，如果不存在，则值为 0。
int | getMonths() 获取整数值形式的 MONTHS 字段的值，如果不存在，则值为 0。
int | getSeconds() 获取整数值形式的 SECONDS 字段的值，如果不存在，则值为 0。
abstract int | getSign() 以 -1、0 或 1 的形式返回此持续时间的符号。
long | getTimeInMillis(Calendar startInstant) 返回以毫秒为单位的持续时间的长度。
long | getTimeInMillis(Date startInstant) 返回以毫秒为单位的持续时间的长度。
QName | getXMLSchemaType() 返回此实例映射到的 XML 模式日期/时间类型的名称。
int | getYears() 获取此 Duration 以 int 表示的 years 值，如果不存在，则值为 0。
abstract int | hashCode() 返回与 equals 方法的定义一致的哈希码。
boolean | isLongerThan(Duration duration) 检查此持续时间对象是否严格长于另一个 Duration 对象。
abstract boolean | isSet(DatatypeConstants.Field field) 检查是否设置了字段。
boolean | isShorterThan(Duration duration) 检查此持续时间对象是否严格短于另一个 Duration 对象。
abstract Duration | multiply(BigDecimal factor) 计算新的持续时间，其值是此持续时间值的 factor 倍。
Duration | multiply(int factor) 计算新的持续时间，值为此持续时间值的 factor 倍。
abstract Duration | negate() 返回值为 -this 的新 Duration 对象。
abstract Duration | normalizeWith(Calendar startTimeInstant) 通过使用特定的时间点作为参考点，将 years 和 months 字段转换为 days 字段。
Duration | subtract(Duration rhs) 计算值为 this-rhs 的新持续时间。
String | toString() 返回此 Duration Object 的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Duration

public Duration()
默认的无参数构造方法。

注：总是使用 DatatypeFactory 来构造 Duration 实例。无法保证此类上的构造方法生成具有一致状态并可在以后移除的对象。

方法详细信息

getXMLSchemaType

public QName getXMLSchemaType()

返回此实例映射到的 XML 模式日期/时间类型的名称。类型根据设置的字段来计算，即 isSet(DatatypeConstants.Field field) == true。

XML 模式 1.0 日期/时间数据类型的必需字段。
（对于所有日期/时间数据类型，时区是可选的）
数据类型 | year | month | day | hour | minute | second
DatatypeConstants.DURATION | X | X | X | X | X | X
DatatypeConstants.DURATION_DAYTIME | X | X | X | X
DatatypeConstants.DURATION_YEARMONTH | X | X

返回：
以下常量之一：DatatypeConstants.DURATION、DatatypeConstants.DURATION_DAYTIME 或 DatatypeConstants.DURATION_YEARMONTH。
抛出：
IllegalStateException - 如果设置字段的组合与 XML 模式日期/时间数据类型之一不匹配。

getSign

public abstract int getSign()
以 -1、0 或 1 的形式返回此持续时间的符号。

返回：
如果此持续时间为负，则返回 -1；如果持续时间为零，则返回 0；如果持续时间为正，则返回 1。

getYears

public int getYears()

获取此 Duration 以 int 表示的 years 值，如果不存在，则值为 0。

getYears() 是 getField(DatatypeConstants.YEARS) 的一个便捷方法。

由于返回值是 int，所以对于具有超出 int 范围的年值的 Duration，返回不正确的值。使用 getField(DatatypeConstants.YEARS) 避免可能的精度丢失。

返回：
如果存在 years 字段，则返回以 int 表示的值，否则返回 0。

getMonths

public int getMonths()
获取整数值形式的 MONTHS 字段的值，如果不存在，则值为 0。 除了对 MONTHS 字段的作用之外，此方法的其他功能与 getYears() 相似。

返回：
此 Duration 的月。

getDays

public int getDays()
获取整数值形式的 DAYS 字段的值，如果不存在，则值为 0。 除了对 MONTHS 字段的作用之外，此方法的其他功能与 getYears() 相似。

返回：
此 Duration 的日。

getHours

public int getHours()
获取整数值形式的 HOURS 字段的值，如果不存在，则值为 0。 除了对 HOURS 字段的作用之外，此方法的其他功能与 getYears() 相似。

返回：
此 Duration 的时。

getMinutes

public int getMinutes()
获取整数值形式的 MINUTES 字段的值，如果不存在，则值为 0。 除了对 MINUTES 字段的作用之外，此方法的其他功能与 getYears() 相似。

返回：
此 Duration 的分。

getSeconds

public int getSeconds()
获取整数值形式的 SECONDS 字段的值，如果不存在，则值为 0。 除了对 SECONDS 字段的作用之外，此方法的其他功能与 getYears() 相似。

返回：
秒的整数值。将丢弃秒的小数部分（例如，如果实际值是 2.5，则此方法返回 2）

getTimeInMillis

public long getTimeInMillis(Calendar startInstant)

返回以毫秒为单位的持续时间的长度。

如果秒字段比毫秒字段带的位数更多，则丢弃多余的位数（即去尾舍入）。例如，对于任何日历值 x，

new Duration("PT10.00099S").getTimeInMills(x) == 10000。
new Duration("-PT10.00099S").getTimeInMills(x) == -10000。

注意，此方法使用 addTo(Calendar) 方法，使用在其字段中具有更大值的 Duration 对象可能无法正确工作。有关详细信息，请参阅 addTo(Calendar) 方法。

参数：
startInstant - 月/年的长度不同。使用 startInstant 确定此偏差。明确地说，此方法返回 startInstant 和 startInstant+duration 之间的差异
返回：
startInstant 和 startInstant 之间的毫秒加上此 Duration
抛出：
NullPointerException - 如果 startInstant 参数为 null。

getTimeInMillis

public long getTimeInMillis(Date startInstant)

返回以毫秒为单位的持续时间的长度。

如果秒字段比毫秒字段带的位数更多，则丢弃多余的位数（即去尾舍入）。例如，对于任何 Date 值 x，

new Duration("PT10.00099S").getTimeInMills(x) == 10000。
new Duration("-PT10.00099S").getTimeInMills(x) == -10000。

注意，此方法使用 addTo(Date) 方法，该方法对于具有较大字段值的 Duration 对象工作正常。有关详细信息，请参阅 addTo(Date) 方法。

参数：
startInstant - 月/年的长度不同。使用 startInstant 确定此偏差。明确地说，此方法返回 startInstant 和 startInstant+duration 之间的差异
返回：
startInstant 和 startInstant 之间的毫秒加上此 Duration
抛出：
NullPointerException - 如果 startInstant 参数为 null。
另请参见：
getTimeInMillis(Calendar)

getField

public abstract Number getField(DatatypeConstants.Field field)
获取字段的值。 duration 对象的字段可以包含任意大的值。因此，设计此方法的目的是返回 Number 对象。 就 YEARS、MONTHS、DAYS、HOURS 和 MINUTES 来说，返回的数字将是一个非负整数。就 seconds 来说，返回的数字可以是一个非负的十进制值。

参数：
field - 六个字段常量之一（YEARS、MONTHS、DAYS、HOURS、MINUTES 或 SECONDS。）
返回：
如果指定的字段存在，则此方法返回表示其值的非 null 的非负 Number 对象。如果不存在，则返回 null。对于 YEARS、MONTHS、DAYS、HOURS 和 MINUTES，此方法返回 BigInteger 对象。对于 SECONDS，此方法返回 BigDecimal。
抛出：
NullPointerException - 如果 field 为 null。

isSet

public abstract boolean isSet(DatatypeConstants.Field field)
检查是否设置了字段。 duration 对象的字段不一定存在。可以使用此方法测试字段是否存在。

参数：
field - 六个字段常量之一（YEARS、MONTHS、DAYS、HOURS、MINUTES 或 SECONDS。）
返回：
如果字段存在，则返回 true，否则返回 false。
抛出：
NullPointerException - 如果字段参数为 null。

add

public abstract Duration add(Duration rhs)

计算值为 this+rhs 的新持续时间。

例如，

 "1 day" + "-3 days" = "-2 days"
 "1 year" + "1 day" = "1 year and 1 day"
 "-(1 hour,50 minutes)" + "-20 minutes" = "-(1 hours,70 minutes)"
 "15 hours" + "-3 days" = "-(2 days,9 hours)"
 "1 year" + "-1 day" = IllegalStateException

由于从 1 月减去 1 天没有意义，所以 IllegalStateException 中存在操作失败的情况。

正式地说，应按以下方法定义计算。

首先，在一般意义下，可以假设要添加的两个 Duration 是两个正数（即 (-X)+Y=Y-X、X+(-Y)=X-Y、(-X)+(-Y)=-(X+Y)）

根据逐字段相加定义两个正 Duration 的相加，其中缺少的字段视为 0。

当且仅当未设置两个输入 Duration 的各自字段时，将不设置产生的 Duration 的字段。

注意，如果 lhs.signum()*rhs.signum()!=-1，或将它们两个标准化，则 lhs.add(rhs) 将总是成功的。

参数：
rhs - 要添加到此 Duration 的 Duration
返回：
非 null 的有效 Duration 对象。
抛出：
NullPointerException - 如果 rhs 参数为 null。
IllegalStateException - 如果两个持续时间的相加没有意义。例如，将负的一天添加到一月将导致此异常。
另请参见：
subtract(Duration)

addTo

public abstract void addTo(Calendar calendar)
将此持续时间添加到 Calendar 对象。

按 YEARS、MONTHS、DAYS、HOURS、MINUTES、SECONDS 和 MILLISECONDS 的顺序调用 Calendar.add(int,int)，如果这些字段存在的话。因为 Calendar 类使用整数保持值，所以存在此方法不能正确工作的情况（例如，如果字段的值超出整数的范围。）

另外，由于此 duration 类是阳历持续时间，所以如果给定的 Calendar 对象基于一些其他日历系统，则此方法将不能正确工作。

对于此 Duration 对象的小数部分，只忽略毫秒之外的数字。例如，如果此持续时间是“P1.23456S”，那么将 1 添加到 SECONDS，将 234 添加到 MILLISECONDS，不使用其余部分。

注意，因为 Calendar.add(int, int) 正在使用 int，所以带有超出其字段中 int 范围值的 Duration 将导致给定 Calendar 的上溢/下溢。link XMLGregorianCalendar#add(Duration)} 提供与此方法相同的基本操作，同时避免上溢/下溢问题。

参数：
calendar - 值将被修改的日历对象。
抛出：
NullPointerException - 如果日历参数为 null。

addTo

public void addTo(Date date)
将此持续时间添加到 Date 对象。

将给定的数据首先转换为 GregorianCalendar，然后完全按照 addTo(Calendar) 方法添加持续时间。

然后将更新的时间点转换回 Date 对象，并用于更新给定的 Date 对象。

此冗余计算对明确地确定月和年的持续时间是必需的。

参数：
date - 值将被修改的日期对象。
抛出：
NullPointerException - 如果日期参数为 null。

subtract

public Duration subtract(Duration rhs)

计算值为 this-rhs 的新持续时间。

例如：

 "1 day" - "-3 days" = "4 days"
 "1 year" - "1 day" = IllegalStateException
 "-(1 hour,50 minutes)" - "-20 minutes" = "-(1hours,30 minutes)"
 "15 hours" - "-3 days" = "3 days and 15 hours"
 "1 year" - "-1 day" = "1 year and 1 day"

由于从 1 月减去 1 天没有意义，所以 IllegalStateException 中存在操作失败的情形。

正式地说，应按以下方法定义计算。首先，在一般意义下，可以假设两个 Duration 都是两个正数。（即 (-X)-Y=-(X+Y)、X-(-Y)=X+Y、(-X)-(-Y)=-(X-Y)）

然后，逐字段减去两个持续时间。如果任何非零字段 F 的符号与最重要的字段的符号不同，则将从 F 的下一个较大单位借用 1（如果 F 为负）或 -1（如果为非负）。

重复此过程，直到所有的非零字段具有相同符号。

如果在 days 字段中发生借用（换句话说，如果计算需要借用 1 或 -1 月，以补偿 days），那么计算会失败，并抛出 IllegalStateException。

参数：
rhs - 从 Duration 减去的 Duration。
返回：
通过从此 Duration 减去 rhs 创建的新 Duration。
抛出：
IllegalStateException - 如果两个持续时间的相减没有意义。例如，从一月减去一天会导致此异常。
NullPointerException - 如果 rhs 参数为 null。
另请参见：
add(Duration)

multiply

public Duration multiply(int factor)

计算新的持续时间，值为此持续时间值的 factor 倍。

提供此方法是为了方便使用。它在功能上等同于以下代码：

 multiply(new BigDecimal(String.valueOf(factor)))

参数：
factor - 要创建的新 Duration 的 Factor 倍数。
返回：
作为此 Duration 的 factor 倍的新 Duration。
另请参见：
multiply(BigDecimal)

multiply

public abstract Duration multiply(BigDecimal factor)
计算新的持续时间，其值是此持续时间值的 factor 倍。

例如，

 "P1M" (1 month) * "12" = "P12M" (12 months)
 "PT1M" (1 min) * "0.3" = "PT18S" (18 seconds)
 "P1M" (1 month) * "1.5" = IllegalStateException

由于 Duration 类是不可变的，所以此方法不更改此对象的值。它仅计算新的 Duration 对象，并返回它。

将通过 BigDecimal 的精度逐字段执行操作。由于除 seconds 外的所有字段限于保持整数，计算产生的任何小数向下进位到下一个低单位。例如，如果 "P1D"（1 天）乘 "0.5"，那么将得到 0.5 天，它将向下进位到 "PT12H"（12 小时）。当月的小数向下进位到日或年的小数向下进位到月没有意义时，将导致抛出 IllegalStateException。例如，将一个月乘以 0.5 时将抛出上述异常。

要避免 IllegalStateException，请使用 normalizeWith(Calendar) 方法移除 years 和 months 字段。

参数：
factor - 相乘的因子
返回：
返回非 null 的有效 Duration 对象
抛出：
IllegalStateException - 如果操作在 months 字段中生成小数。
NullPointerException - 如果 factor 参数为 null。

negate

public abstract Duration negate()
返回值为 -this 的新 Duration 对象。

由于 Duration 类是不可变的，所以此方法不更改此对象的值。它仅计算新的 Duration 对象，并返回它。

返回：
总是返回非 null 的有效 Duration 对象。

normalizeWith

public abstract Duration normalizeWith(Calendar startTimeInstant)

通过使用特定的时间点作为参考点，将 years 和 months 字段转换为 days 字段。

例如，一个月的持续时间可以标准化为 31 天，给出的时间点是 "July 8th 2003, 17:40:32"。

正式地说，应按以下方法进行计算：

  1. 复制给定的 Calendar 对象
  2. 使用 Calendar.add(int,int) 方法将 years、months 和 days 字段添加到 Calendar 对象
  3. 两个 Calendar 在以毫秒计算并转换为天数上存在差异，如果由于夏令时 (Daylight Savings Time) 而发生余数，则丢弃该余数。
  4. 计算的 days 以及此持续时间对象的 hours、minutes 和 seconds 字段用于构造新的持续时间对象。

注意，由于 Calendar 类使用 int 保持年和月的值，所以如果此持续时间对象在 years 或 months 字段中保持非常大的值，则此方法可能产生不可预料的结果。

参数：
startTimeInstant - Calendar 引用点。
返回：
以日为单位返回此 Duration 的年和月的 Duration。
抛出：
NullPointerException - 如果 startTimeInstant 参数为 null。

compare

public abstract int compare(Duration duration)

与此 Duration 实例的部分顺序关系比较。

比较结果必须依照 W3C XML 模式 1.0 第二部分 3.2.7.6.2 节 Order relation on duration。

返回：

  • DatatypeConstants.LESSER 如果此 Duration 比 duration 参数短
  • DatatypeConstants.EQUAL 如果此 Duration 等于 duration 参数
  • DatatypeConstants.GREATER 如果此 Duration 比 duration 参数长
  • DatatypeConstants.INDETERMINATE 如果无法确定最终的部分顺序关系

参数：
duration - 要比较的持续时间
返回：
此 Duration 和 duration 参数之间的关系：DatatypeConstants.LESSER、DatatypeConstants.EQUAL、DatatypeConstants.GREATER 或 DatatypeConstants.INDETERMINATE。
抛出：
UnsupportedOperationException - 如果底层实现无法合理处理该请求，例如，W3C XML 模式允许任意大/小/精确的值，该请求可能超出实现功能。
NullPointerException - 如果 duration 为 null。
另请参见：
isShorterThan(Duration), isLongerThan(Duration)

isLongerThan

public boolean isLongerThan(Duration duration)

检查此持续时间对象是否严格长于另一个 Duration 对象。

根据 XML 模式 1.0 规范的第 3.2.6.2 节中的定义，当且仅当 X>Y 时，持续时间 X 比 Y“长”。

例如，"P1D"（一天）> "PT12H"（12 小时），并且 "P2Y"（两年）>"P23M"（23 月）。

参数：
duration - 测试此 Duration 的 Duration。
返回：
如果此对象表示的持续时间比给定的持续时间长，则返回 true，否则返回 false。
抛出：
UnsupportedOperationException - 如果底层实现无法合理处理该请求，例如，W3C XML 模式允许任意大/小/精确的值，该请求可能超出实现功能。
NullPointerException - 如果 duration 为 null。
另请参见：
isShorterThan(Duration), compare(Duration duration)

isShorterThan

public boolean isShorterThan(Duration duration)

检查此持续时间对象是否严格短于另一个 Duration 对象。

参数：
duration - 测试此 Duration 的 Duration。
返回：
如果 duration 参数比此 Duration 短，则返回 true，否则返回 false。
抛出：
UnsupportedOperationException - 如果底层实现无法合理处理该请求，例如，W3C XML 模式允许任意大/小/精确的值，该请求可能超出实现功能。
NullPointerException - 如果 duration 为 null。
另请参见：
isLongerThan(Duration duration), compare(Duration duration)

equals

public boolean equals(Object duration)

检查此持续时间对象是否与另一个 Duration 对象具有相同的持续时间。

例如，"P1D"（1 天）等于 "PT24H"（24 小时）。

当且仅当时间点 t+X 和 t+Y 对 XML 模式 1.0 规范的第 3.2.6.2 节中指定的所有测试时间点都相同时，持续时间 X 才等于 Y。

注意，存在两个 Duration 互相“不能比较”的情况，如一个月和 30 天。例如，

 !new Duration("P1M").isShorterThan(new Duration("P30D"))
 !new Duration("P1M").isLongerThan(new Duration("P30D"))
 !new Duration("P1M").equals(new Duration("P30D"))

覆盖：
类 Object 中的 equals
参数：
duration - 用来对照比较此 Duration 的对象。
返回：
如果此持续时间与 duration 长度相同，则返回 true。如果 duration 是 null，而不是 Duration 对象，或者其长度与此持续时间不同，则返回 false。
抛出：
UnsupportedOperationException - 如果底层实现无法合理处理该请求，例如，W3C XML 模式允许任意大/小/精确的值，该请求可能超出实现功能。
另请参见：
compare(Duration duration)

hashCode

public abstract int hashCode()
返回与 equals 方法的定义一致的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.hashCode()

toString

public String toString()

返回此 Duration Object 的 String 表示形式。

根据 XML 模式 1.0 规范格式化该结果，之后始终可以通过 DatatypeFactory.newDuration(String lexicalRepresentation) 将其解析为等效的 Duration Object。

正式地说，以下内容保持任何 Duration Object x：

 new Duration(x.toString()).equals(x)

覆盖：
类 Object 中的 toString
返回：
此 Duration 的非 null 有效 String 表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLGregorianCalendar (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.datatype
类 XMLGregorianCalendar

java.lang.Object
    继承者  javax.xml.datatype.XMLGregorianCalendar
所有已实现的接口：
Cloneable
public abstract class XMLGregorianCalendar
extends Object
implements Cloneable

W3C XML 模式 1.0 日期/时间数据类型的表示形式。明确地说，这些日期/时间数据类型是 XML 名称空间 "http://www.w3.org/2001/XMLSchema" 中定义的 dateTime、time、date、gYearMonth、gMonthDay、gYear gMonth 和 gDay。在 W3C XML 模式 1.0 第二部分 3.2.7-14 节中以标准形式定义了这些数据类型。

下表定义了 XML 模式 1.0 日期/时间数据类型字段和此类的字段之间的映射关系。还总结了 W3C XML 模式 1.0 第二部分的附录 D ISO 8601 Date and Time Formats 中定义的日期和时间字段的值约束。

XML 模式 1.0 和 Java 表示形式之间的日期/时间数据类型字段映射关系
XML 模式 1.0
数据类型
字段 		相关的
XMLGregorianCalendar
Accessor(s) 		值范围
year getYear() + getEon() 或
getEonAndYear() 		getYear() 是 -(10^9-1) 到 (10^9)-1 或 DatatypeConstants.FIELD_UNDEFINED 之间的值。
getEon() 是以十亿年为单位的高顺序年值。
getEon() 是大于或等于 (10^9) 或者小于或等于 -(10^9) 的值。null 值指示字段未定义。
若 XML 模式 1.0 勘误表说明 year 0 是 XML 模式以后版本中的一个有效词汇值，那么此类允许将 year 字段设置为0。否则，完全按照勘误表和 [ISO-8601-1988] 中的描述处理 year 字段值。注意，W3C XML 模式 1.0 验证不允许 year 字段具有 0 值。
month | getMonth() | 1 到 12 或 DatatypeConstants.FIELD_UNDEFINED
day getDay() 与 month 无关，最大范围是 1 到 31 或 DatatypeConstants.FIELD_UNDEFINED。
相对于 month 字段的值说明的标准化值约束位于 W3C XML 模式 1.0 第二部分附录 D 中。
hour | getHour() | 0 到 24 或 DatatypeConstants.FIELD_UNDEFINED。对于值 24，根据 XML 模式勘误表，minute 和 second 字段必须为 0。
minute | getMinute() | 0 到 59 或 DatatypeConstants.FIELD_UNDEFINED
second getSecond() + getMillisecond()/1000 或
getSecond() + getFractionalSecond() 		getSecond() 范围是 0 到 60 或 DatatypeConstants.FIELD_UNDEFINED。
（注：60 仅允许闰秒。）
在定义 getSecond() 时，getFractionalSecond() 在范围 0.0 到 1.0 上允许无限精度。
FractionalSecond 是可选的，并且当它未定义时，值为 null。
getMillisecond() 是值 getFractionalSecond() 的有用毫秒精度。
timezone | getTimezone() | 分钟数或 DatatypeConstants.FIELD_UNDEFINED。从 -14 小时（-14 * 60 分钟）到 14 小时（14 * 60 分钟）的值范围。

通过此类的工厂方法、DatatypeFactory、设置方法和解析方法检查上面表中为字段列出的所有最大值空间约束。若参数的值超出字段的值约束，或者复合值组成一个无效 XMLGregorianCalendar 实例（例如，如果指定六月的第 31 日），则抛出 IllegalArgumentException。

为此类定义以下操作：

  • 用于独立日期/时间字段的 accessors/mutators
  • 此类与 W3C XML 模式 1.0 词汇表示形式、toString()、DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation) 之间的转换
  • 此类与 GregorianCalendar、toGregorianCalendar(java.util.TimeZone timezone, java.util.Locale aLocale, XMLGregorianCalendar defaults)、DatatypeFactory 之间的转换
  • 部分顺序关系比较器方法 compare(XMLGregorianCalendar xmlGregorianCalendar)
  • 相对于 compare(XMLGregorianCalendar xmlGregorianCalendar) 定义的 equals(Object)。
  • W3C XML 模式 1.0 第二部分的附录 E Adding durations to dateTimes 中定义的 Duration 实例的其他操作。

从以下版本开始：
1.5
另请参见：
Duration, DatatypeFactory

构造方法摘要
XMLGregorianCalendar()
默认的无参数构造方法。
方法摘要
abstract  void add(Duration duration)
将 duration 添加到此实例。
abstract  void clear()
取消设置所有未定义的字段。
abstract  Object clone()
创建并返回此对象的一个副本。
abstract  int compare(XMLGregorianCalendar xmlGregorianCalendar)
根据 W3C XML 模式 1.0 第二部分 3.2.7.3 小节 Order relation on dateTime 中定义的部分顺序关系，比较 W3C XML 模式 1.0 日期/时间数据类型的两个实例。
 boolean equals(Object obj)
将此日历与指定的对象进行比较。
abstract  int getDay()
返回月中的日或 DatatypeConstants.FIELD_UNDEFINED。
abstract  BigInteger getEon()
返回 year XML 模式 1.0 日期时间数据类型字段的高顺序组件。
abstract  BigInteger getEonAndYear()
返回 year XML 模式 1.0 的日期时间数据类型字段。
abstract  BigDecimal getFractionalSecond()
返回小数秒。
abstract  int getHour()
返回时或 DatatypeConstants.FIELD_UNDEFINED。
 int getMillisecond()
返回 getFractionalSecond() 的毫秒精度。
abstract  int getMinute()
返回分或 DatatypeConstants.FIELD_UNDEFINED。
abstract  int getMonth()
返回月数或 DatatypeConstants.FIELD_UNDEFINED。
abstract  int getSecond()
返回秒或 DatatypeConstants.FIELD_UNDEFINED。
abstract  int getTimezone()
返回以分为单位的时区偏移量，如果未定义此可选字段，则返回 DatatypeConstants.FIELD_UNDEFINED。
abstract  TimeZone getTimeZone(int defaultZoneoffset)
返回此类的 java.util.TimeZone。
abstract  QName getXMLSchemaType()
返回此实例映射到的 XML 模式日期/时间类型的名称。
abstract  int getYear()
返回 year 或 DatatypeConstants.FIELD_UNDEFINED XML 模式 1.0 日期时间数据类型字段的低顺序组件。
 int hashCode()
返回与 equals 方法的定义一致的哈希码。
abstract  boolean isValid()
通过 getXMLSchemaType() 约束来验证实例。
abstract  XMLGregorianCalendar normalize()
将此实例标准化为 UTC。
abstract  void reset()
将此 XMLGregorianCalendar 重设为其原始值。
abstract  void setDay(int day)
设置月中的日。
abstract  void setFractionalSecond(BigDecimal fractional)
设置小数秒。
abstract  void setHour(int hour)
设置小时。
abstract  void setMillisecond(int millisecond)
设置毫秒。
abstract  void setMinute(int minute)
设置分。
abstract  void setMonth(int month)
设置月。
abstract  void setSecond(int second)
设置秒。
 void setTime(int hour, int minute, int second)
将时间设置为一个单元。
 void setTime(int hour, int minute, int second, BigDecimal fractional)
将时间设置为一个单元，包括可选无限精度小数秒。
 void setTime(int hour, int minute, int second, int millisecond)
将时间设置为一个单元，包括可选的毫秒。
abstract  void setTimezone(int offset)
设置时区偏移量中的分钟数。
abstract  void setYear(BigInteger year)
设置 XSD dateTime year 字段的低和高顺序组件。
abstract  void setYear(int year)
设置 XSD dateTime year 字段的年。
abstract  GregorianCalendar toGregorianCalendar()
将此 XMLGregorianCalendar 转换为 GregorianCalendar。
abstract  GregorianCalendar toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。
 String toString()
返回此 XMLGregorianCalendar Object 的 String 表示形式。
abstract  String toXMLFormat()
返回 this 实例的词汇表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

XMLGregorianCalendar

public XMLGregorianCalendar()
默认的无参数构造方法。

注：总是使用 DatatypeFactory 来构造 XMLGregorianCalendar 实例。无法保证该类上的构造方法生成具有一致状态且可在以后移除的对象。

方法详细信息

clear

public abstract void clear()

取消设置所有未定义的字段。

将所有 int 字段设置为 DatatypeConstants.FIELD_UNDEFINED，并将引用字段设置为 null。

reset

public abstract void reset()

将此 XMLGregorianCalendar 重设为其原始值。

将 XMLGregorianCalendar 重置为与使用 DatatypeFactory.newXMLGregorianCalendar()、DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation)、DatatypeFactory.newXMLGregorianCalendar( BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone)、DatatypeFactory.newXMLGregorianCalendar( int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone)、DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal)、DatatypeFactory.newXMLGregorianCalendarDate( int year, int month, int day, int timezone)、DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, int timezone)、DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone) 或 DatatypeFactory.newXMLGregorianCalendarTime( int hours, int minutes, int seconds, int milliseconds, int timezone) 创建时相同的值。

reset() 的设计目的是允许重用现有的 XMLGregorianCalendar，从而节省与创建新 XMLGregorianCalendar 相关的资源。

setYear

public abstract void setYear(BigInteger year)

设置 XSD dateTime year 字段的低和高顺序组件。

通过使用参数值 null 调用设置方法取消设置此字段。

参数：
year - 日期/时间字段映射表中 year 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 year 参数超出日期/时间映射表中指定字段的值约束。

setYear

public abstract void setYear(int year)

设置 XSD dateTime year 字段的年。

通过使用 DatatypeConstants.FIELD_UNDEFINED 的参数值调用设置方法取消设置此字段。

注：如果 year 参数的绝对值小于 10^9，则通过此方法将 XSD year 字段的 eon 组件设置为 null。

参数：
year - 日期/时间字段映射表中 year 字段中总结的值约束。如果 year 是 DatatypeConstants.FIELD_UNDEFINED，那么将 eon 设置为 null。

setMonth

public abstract void setMonth(int month)

设置月。

通过使用 DatatypeConstants.FIELD_UNDEFINED 的参数值调用设置方法取消设置此字段。

参数：
month - 日期/时间映射表的 month 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 month 参数超出日期/时间映射表中指定字段的值约束。

setDay

public abstract void setDay(int day)

设置月中的日。

通过使用 DatatypeConstants.FIELD_UNDEFINED 的参数值调用设置方法取消设置此字段。

参数：
day - 日期/时间字段映射表的 day 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 day 参数超出日期/时间映射表中指定字段的值约束。

setTimezone

public abstract void setTimezone(int offset)

设置时区偏移量中的分钟数。

通过使用 DatatypeConstants.FIELD_UNDEFINED 的参数值调用设置方法取消设置此字段。

参数：
offset - 日期/时间字段映射表的 timezone 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 offset 参数超出日期/时间映射表中指定字段的值约束。

setTime

public void setTime(int hour,
                    int minute,
                    int second)

将时间设置为一个单元。

参数：
hour - 日期/时间字段映射表的 hour 字段中总结的值约束。
minute - 日期/时间字段映射表的 minute 字段中总结的值约束。
second - 日期/时间字段映射表的 second 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果任何参数超出日期/时间映射表中指定字段的值约束。
另请参见：
setTime(int, int, int, BigDecimal)

setHour

public abstract void setHour(int hour)

设置小时。

通过使用 DatatypeConstants.FIELD_UNDEFINED 的参数值调用设置方法取消设置此字段。

参数：
hour - 日期/时间字段映射表的 hour 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 hour 参数超出日期/时间映射表中指定字段的值约束。

setMinute

public abstract void setMinute(int minute)

设置分。

通过使用 DatatypeConstants.FIELD_UNDEFINED 的参数值调用设置方法取消设置此字段。

参数：
minute - 日期/时间字段映射表的 minute 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 minute 参数超出日期/时间映射表中指定字段的值约束。

setSecond

public abstract void setSecond(int second)

设置秒。

通过使用 DatatypeConstants.FIELD_UNDEFINED 的参数值调用设置方法取消设置此字段。

参数：
second - 日期/时间字段映射表的 second 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 second 参数超出日期/时间映射表中指定字段的值约束。

setMillisecond

public abstract void setMillisecond(int millisecond)

设置毫秒。

通过使用 DatatypeConstants.FIELD_UNDEFINED 的参数值调用设置方法取消设置此字段。

参数：
millisecond - 日期/时间字段映射表的 second 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 millisecond 参数超出日期/时间映射表中指定字段的值约束。

setFractionalSecond

public abstract void setFractionalSecond(BigDecimal fractional)

设置小数秒。

通过使用参数值 null 调用设置方法取消设置此字段。

参数：
fractional - 日期/时间字段映射表的 second 字段中总结的值约束。
抛出：
IllegalArgumentException - 如果 fractional 参数超出日期/时间映射表中指定字段的值约束。

setTime

public void setTime(int hour,
                    int minute,
                    int second,
                    BigDecimal fractional)

将时间设置为一个单元，包括可选无限精度小数秒。

参数：
hour - 日期/时间字段映射表的 hour 字段中总结的值约束。
minute - 日期/时间字段映射表的 minute 字段中总结的值约束。
second - 日期/时间字段映射表的 second 字段中总结的值约束。
fractional - 值 null 指示不设置此可选字段。
抛出：
IllegalArgumentException - 如果任何参数超出日期/时间映射表中指定字段的值约束。

setTime

public void setTime(int hour,
                    int minute,
                    int second,
                    int millisecond)

将时间设置为一个单元，包括可选的毫秒。

参数：
hour - 日期/时间字段映射表的 hour 字段中总结的值约束。
minute - 日期/时间字段映射表的 minute 字段中总结的值约束。
second - 日期/时间字段映射表的 second 字段中总结的值约束。
millisecond - DatatypeConstants.FIELD_UNDEFINED 的值指示未设置此可选字段。
抛出：
IllegalArgumentException - 如果任何参数超出日期/时间映射表中指定字段的值约束。

getEon

public abstract BigInteger getEon()

返回 year XML 模式 1.0 日期时间数据类型字段的高顺序组件。如果未定义 year 字段的此可选部分，则返回 null。

日期/时间字段映射表中 year 字段中总结了此值的值约束。

返回：
此 XMLGregorianCalendar 的 eon。返回的值是 10^9 的整数倍数。
另请参见：
getYear(), getEonAndYear()

getYear

public abstract int getYear()

返回 year 或 DatatypeConstants.FIELD_UNDEFINED XML 模式 1.0 日期时间数据类型字段的低顺序组件。

日期/时间字段映射表中 year 字段中总结了此值的值约束。

返回：
此 XMLGregorianCalendar 的年。
另请参见：
getEon(), getEonAndYear()

getEonAndYear

public abstract BigInteger getEonAndYear()

返回 year XML 模式 1.0 的日期时间数据类型字段。

日期/时间字段映射表中 year 字段中总结了此值的值约束。

返回：
当同时定义了 eon 和 BigInteger.valueOf(year) 两个字段时，返回它们的总和。只定义了 year 时，返回 year。当 eon 和 year 都未定义时，返回 null。
另请参见：
getEon(), getYear()

getMonth

public abstract int getMonth()

返回月数或 DatatypeConstants.FIELD_UNDEFINED。

日期/时间映射表的 month 字段中总结了此值的值约束。

返回：
此 XMLGregorianCalendar 的年。

getDay

public abstract int getDay()
返回月中的日或 DatatypeConstants.FIELD_UNDEFINED。

日期/时间字段映射表的 day 字段中总结了此值的值约束。

另请参见：
setDay(int)

getTimezone

public abstract int getTimezone()
返回以分为单位的时区偏移量，如果未定义此可选字段，则返回 DatatypeConstants.FIELD_UNDEFINED。

日期/时间字段映射表的 timezone 字段中总结了此值的值约束。

另请参见：
setTimezone(int)

getHour

public abstract int getHour()
返回时或 DatatypeConstants.FIELD_UNDEFINED。如果未定义此字段，则返回 DatatypeConstants.FIELD_UNDEFINED。

日期/时间字段映射表的 hour 字段中总结了此值的值约束。

另请参见：
setTime(int, int, int)

getMinute

public abstract int getMinute()
返回分或 DatatypeConstants.FIELD_UNDEFINED。

如果未定义此字段，则返回 DatatypeConstants.FIELD_UNDEFINED。

日期/时间字段映射表的 minute 字段中总结了此值的值约束。

另请参见：
setTime(int, int, int)

getSecond

public abstract int getSecond()

返回秒或 DatatypeConstants.FIELD_UNDEFINED。

如果未定义此字段，则返回 DatatypeConstants.FIELD_UNDEFINED。当未定义此字段时，不得定义由 getFractionalSecond() 和 getMillisecond() 表示的可选 xs:dateTime 小数 seconds 字段。

日期/时间字段映射表的 second 字段中总结此值的值约束。

返回：
此 XMLGregorianCalendar 的秒。
另请参见：
getFractionalSecond(),
getMillisecond(),
setTime(int, int, int)

getMillisecond

public int getMillisecond()

返回 getFractionalSecond() 的毫秒精度。

此方法表示由 getFractionalSecond() 返回的无限精度小数秒值的有用存取程序。返回的值是 getFractionalSecond() 的毫秒值的下舍入值。当 getFractionalSecond() 返回 null 时，此方法必须返回 DatatypeConstants.FIELD_UNDEFINED。

日期/时间字段映射表的 second 字段中总结此值的值约束。

返回：
此 XMLGregorianCalendar 的毫秒。
另请参见：
getFractionalSecond(), setTime(int, int, int)

getFractionalSecond

public abstract BigDecimal getFractionalSecond()

返回小数秒。

当未定义此可选字段时，返回 null。

在 日期/时间字段映射表的 second 字段中详细描述了值约束。

当 getSecond() 表示的 xs:dateTime 秒字段未返回 DatatypeConstants.FIELD_UNDEFINED 时，此可选字段只能有一个已定义的值。

返回：
此 XMLGregorianCalendar 的小数秒。
另请参见：
getSecond(), setTime(int, int, int, BigDecimal)

compare

public abstract int compare(XMLGregorianCalendar xmlGregorianCalendar)

根据 W3C XML 模式 1.0 第二部分 3.2.7.3 小节 Order relation on dateTime 中定义的部分顺序关系，比较 W3C XML 模式 1.0 日期/时间数据类型的两个实例。

在日期/时间映射表中定义了到此类的存取程序的 xsd:dateTime 数据类型字段映射。

参数：
xmlGregorianCalendar - 要比较的 XMLGregorianCalendar 实例
返回：
此 XMLGregorianCalendar 与 xmlGregorianCalendar 之间的关系：DatatypeConstants.LESSER、DatatypeConstants.EQUAL、DatatypeConstants.GREATER 或 DatatypeConstants.INDETERMINATE。
抛出：
NullPointerException - 如果 xmlGregorianCalendar 为 null。

normalize

public abstract XMLGregorianCalendar normalize()

将此实例标准化为 UTC。

2000-03-04T23:00:00+03:00 标准化为 2000-03-04T20:00:00Z

实现 W3C XML 模式 第二部分 3.2.7.3 (A) 节。

返回：
标准化为 UTC 的此 XMLGregorianCalendar。

equals

public boolean equals(Object obj)

将此日历与指定的对象进行比较。当且仅当该参数不为 null，并且是表示与该对象相同时点的 XMLGregorianCalendar 对象时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的对象。
返回：
当 obj 是 XMLGregorianCalendar 的实例，并且 compare(XMLGregorianCalendar obj) 返回 DatatypeConstants.EQUAL 时，返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回与 equals 方法的定义一致的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toXMLFormat

public abstract String toXMLFormat()

返回 this 实例的词汇表示形式。在 XML 模式 1.0 第二部分 3.2.[7-14].1 小节 "Lexical Representation". 中指定了该格式。

getXMLSchemaType() 确定特定目标词汇表示形式的格式。

返回：
XML，此 XMLGregorianCalendar 的 String 表示形式
抛出：
IllegalStateException - 如果设置字段的组合与定义的八个 XML 模式内置日期/时间数据类型之一不匹配。

getXMLSchemaType

public abstract QName getXMLSchemaType()

返回此实例映射到的 XML 模式日期/时间类型的名称。该类型根据设置的字段来计算。

XML 模式 1.0 日期/时间数据类型的必需字段。
（对于所有日期/时间数据类型，时区是可选的）
数据类型 | year | month | day | hour | minute | second
DatatypeConstants.DATETIME | X | X | X | X | X | X
DatatypeConstants.DATE | X | X | X
DatatypeConstants.TIME | X | X | X
DatatypeConstants.GYEARMONTH | X | X
DatatypeConstants.GMONTHDAY | X | X
DatatypeConstants.GYEAR | X
DatatypeConstants.GMONTH | X
DatatypeConstants.GDAY | X

返回：
以下类常量之一：DatatypeConstants#DATETIE、DatatypeConstants.TIME、DatatypeConstants.DATE、DatatypeConstants.GYEARMONTH、DatatypeConstants.GMONTHDAY、DatatypeConstants.GYEAR、DatatypeConstants.GMONTH 或 DatatypeConstants.GDAY。
抛出：
IllegalStateException - 如果设置字段的组合与定义的八个 XML 模式内置日期/时间数据类型之一不匹配。

toString

public String toString()

返回此 XMLGregorianCalendar Object 的 String 表示形式。

结果是 toXMLFormat() 生成的词汇表示形式。

覆盖：
类 Object 中的 toString
返回：
此 XMLGregorianCalendar 的非 null 有效 String 表示形式。
抛出：
IllegalStateException - 如果设置字段的组合与定义的八个 XML 模式内置日期/时间数据类型之一不匹配。
另请参见：
toXMLFormat()

isValid

public abstract boolean isValid()
通过 getXMLSchemaType() 约束来验证实例。

返回：
如果数据值有效，则返回 true。

add

public abstract void add(Duration duration)

将 duration 添加到此实例。

计算方式在 XML 模式 1.0 第二部分附录 E Adding durations to dateTimes> 中指定。日期/时间字段映射表定义了从 XML 模式 1.0 dateTime 字段到此类的这些字段的表示形式的映射。

参数：
duration - 添加到此 XMLGregorianCalendar 的持续时间。
抛出：
NullPointerException - 当 duration 参数为 null 时。

toGregorianCalendar

public abstract GregorianCalendar toGregorianCalendar()

将此 XMLGregorianCalendar 转换为 GregorianCalendar。

当 this 实例具有未定义的字段时，此转换依赖于其相应字段的 java.util.GregorianCalendar 默认值。 XML 模式 1.0 日期/时间数据类型和 java.util.GregorianCalendar 之间的显著差异是时区值对于日期/时间数据类型是可选的，并且它是 java.util.GregorianCalendar 的必需字段。有关如何确定默认的 java.util.TimeZone.getDefault()，请参阅 javadoc。要显式指定 TimeZone 实例，请参阅 toGregorianCalendar(TimeZone, Locale, XMLGregorianCalendar)。

从此类到 java.util.GregorianCalendar 的逐字段转换
java.util.GregorianCalendar 字段 | javax.xml.datatype.XMLGregorianCalendar 字段
ERA | getEonAndYear() .signum() < 0 ? GregorianCalendar.BC : GregorianCalendar.AD
YEAR | getEonAndYear() .abs().intValue()*
MONTH | getMonth() - DatatypeConstants.JANUARY + Calendar.JANUARY
DAY_OF_MONTH | getDay()
HOUR_OF_DAY | getHour()
MINUTE | getMinute()
SECOND | getSecond()
MILLISECOND | 从 getFractionalSecond() * 获取毫秒顺序
GregorianCalendar.setTimeZone(TimeZone) | 格式化为自定义时区 id 的 getTimezone()
* 由于源数据类型具有比目标数据类型更高的精度，在转换过程中指定可能丢失的精度。

要确保转换实现中的一致性，应使用以下方式实例化新的 GregorianCalendar。

  • 使用以上定义的 timeZone 值，创建一个新的 java.util.GregorianCalendar(timeZone,Locale.getDefault())。
  • 通过调用 Calendar.clear() 初始化所有 GregorianCalendar 字段。
  • 通过调用 GregorianCalendar.setGregorianChange( new Date(Long.MIN_VALUE)) 获取纯阳历。
  • 使用方法 Calendar.set(int,int) 设置其字段 ERA、YEAR、MONTH、DAY_OF_MONTH、HOUR_OF_DAY、MINUTE、SECOND 和 MILLISECOND

另请参见：
toGregorianCalendar(java.util.TimeZone, java.util.Locale, XMLGregorianCalendar)

toGregorianCalendar

public abstract GregorianCalendar toGregorianCalendar(TimeZone timezone,
                                                      Locale aLocale,
                                                      XMLGregorianCalendar defaults)

将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

由于 XML 模式 1.0 日期/时间日期类型没有时区 id 或夏令时 id 的概念，所以此转换操作允许用户使用 timezone 参数显式指定一个 id。

要计算返回值的 TimeZone 字段，

  • 当参数 timeZone 为非 null 时，它是时区字段。
  • 当 this.getTimezone() != FIELD_UNDEFINED 时，使用 this.getTimezone() 创建带有自定义时区 id 的 java.util.TimeZone。
  • 当 defaults.getTimezone() != FIELD_UNDEFINED 时，使用 this.getTimezone() 创建带有自定义时区 id 的 defaults.getTimezone()。
  • 另外,对主机使用 GregorianCalendar 默认时区值按 java.util.TimeZone.getDefault() 指定的方式定义。

    • 要确保转换实现中的一致性，应使用以下方式实例化新的 GregorianCalendar。

    • 使用上面指定的时区设置和 Locale 参数创建新的 java.util.GregorianCalendar(TimeZone, Locale)。
    • 通过调用 Calendar.clear() 初始化所有 GregorianCalendar 字段
    • 通过调用 GregorianCalendar.setGregorianChange( new Date(Long.MIN_VALUE)) 获取纯阳历。
    • 使用方法 Calendar.set(int,int) 设置其字段 ERA、YEAR、MONTH、DAY_OF_MONTH、HOUR_OF_DAY、MINUTE、SECOND 和 MILLISECOND

    参数：
    timezone - 提供时区。null 是一个合法值。
    aLocale - 提供明确的语言环境。如果值为 null，则使用默认 GregorianCalendar 语言环境。
    defaults - 当此实例的相应字段为 FIELD_UNDEFINED 或 null 时，它提供要使用的默认字段值。如果 defaults 为 null 或指定 defaults 中的字段未定义，则仅使用 java.util.GregorianCalendar 默认值。
    返回：
    此实例的 java.util.GregorianCalendar 转换。

getTimeZone

public abstract TimeZone getTimeZone(int defaultZoneoffset)

返回此类的 java.util.TimeZone。

如果未定义此实例的时区字段，则返回使用时区偏移量的自定义时区 id 初始化的 TimeZone。如果未定义时区字段，则尝试传入的 defaultZoneoffset。如果 defaultZoneoffset 为 FIELD_UNDEFINED，则返回此主机的默认时区。（与 java.util.GregorianCalendar 相同的默认值）。

参数：
defaultZoneoffset - 如果此时区偏移量为 DatatypeConstants.FIELD_UNDEFINED，则为默认时区偏移量。
返回：
为其返回 TimeZone。

clone

public abstract Object clone()

创建并返回此对象的一个副本。

覆盖：
类 Object 中的 clone
返回：
此 Object 的副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.datatype (Java Platform SE 6)

 javax.xml.datatype
类
DatatypeConstants
DatatypeConstants.Field
DatatypeFactory
Duration
XMLGregorianCalendar
异常
DatatypeConfigurationException


javax.xml.datatype (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.datatype

XML/Java 类型映射关系。

请参见：
描述

类摘要
DatatypeConstants | 包含基本 Datatype 值作为常量的实用工具类。
DatatypeConstants.Field | 类型安全的枚举类，它表示 Duration 类的六个字段。
DatatypeFactory | 创建新 javax.xml.datatype Object 的工厂，创建的对象可提供 XML 和 Java Object 之间的映射。
Duration | W3C XML 模式 1.0 规范中定义的时间范围的不可变表示形式。
XMLGregorianCalendar | W3C XML 模式 1.0 日期/时间数据类型的表示形式。

异常摘要
DatatypeConfigurationException 指示严重的配置错误。

软件包 javax.xml.datatype 的描述

XML/Java 类型映射关系。

javax.xml.datatypeAPI 提供 XML/Java 类型映射关系。

应用以下 XML 标准：

  • W3C XML 模式 1.0 Part 2, Section 3.2.7-14
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
W3C XML 模式数据类型 | Java 数据类型
xs:date | XMLGregorianCalendar
xs:dateTime | XMLGregorianCalendar
xs:duration | Duration
xs:gDay | XMLGregorianCalendar
xs:gMonth | XMLGregorianCalendar
xs:gMonthDay | XMLGregorianCalendar
xs:gYear | XMLGregorianCalendar
xs:gYearMonth | XMLGregorianCalendar
xs:time | XMLGregorianCalendar
XQuery 1.0 and XPath 2.0 Data Model | Java 数据类型
xdt:dayTimeDuration | Duration
xdt:yearMonthDuration | Duration

具有到 Java 类型的“自然”映射的 W3C XML 模式数据类型由 JSR 31 ：Java™ Architecture for XML Binding (JAXB) Specification, Binding XML Schema to Java Representations 定义。JAXB 为 XML 模式内置数据类型定义的映射关系包括：

  • xs:anySimpleType
  • xs:base64Binary
  • xs:boolean
  • xs:byte
  • xs:decimal
  • xs:double
  • xs:float
  • xs:hexBinary
  • xs:int
  • xs:integer
  • xs:long
  • xs:QName
  • xs:short
  • xs:string
  • xs:unsignedByte
  • xs:unsignedInt
  • xs:unsignedShort
  • 作者：Jeff Suttor
  • 请参阅 W3C XML Schema 1.0 Part 2, Section 3.2.7-14
  • 请参阅 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration
  • 请参阅 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration
  • Since 1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.datatype 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.datatype 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.datatype.DatatypeConstants
    • javax.xml.datatype.DatatypeConstants.Field
    • javax.xml.datatype.DatatypeFactory
    • javax.xml.datatype.Duration
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.datatype.DatatypeConfigurationException
    • javax.xml.datatype.XMLGregorianCalendar (implements java.lang.Cloneable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.datatype 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.datatype
的使用

使用 javax.xml.datatype 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 使用的 javax.xml.datatype 中的类
DatatypeConfigurationException
指示严重的配置错误。
DatatypeConstants.Field
类型安全的枚举类，它表示 Duration 类的六个字段。
DatatypeFactory
创建新 javax.xml.datatype Object 的工厂，创建的对象可提供 XML 和 Java Object 之间的映射。
Duration
W3C XML 模式 1.0 规范中定义的时间范围的不可变表示形式。
XMLGregorianCalendar
W3C XML 模式 1.0 日期/时间数据类型的表示形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.datatype.DatatypeConfigurationException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.DatatypeConfigurationException
的使用

使用 DatatypeConfigurationException 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 DatatypeConfigurationException 的使用

抛出 DatatypeConfigurationException 的 javax.xml.datatype 中的方法
static DatatypeFactory | DatatypeFactory.newInstance() 获取新的 DatatypeFactory 实例。
static DatatypeFactory | DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DatatypeFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.datatype.DatatypeConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.DatatypeConstants
的使用

没有 javax.xml.datatype.DatatypeConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.datatype.DatatypeConstants.Field 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.DatatypeConstants.Field
的使用

使用 DatatypeConstants.Field 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 DatatypeConstants.Field 的使用

声明为 DatatypeConstants.Field 的 javax.xml.datatype 中的字段
static DatatypeConstants.Field | DatatypeConstants.DAYS 表示日字段的常量。
static DatatypeConstants.Field | DatatypeConstants.HOURS 表示小时字段的常量。
static DatatypeConstants.Field | DatatypeConstants.MINUTES 表示分钟字段的常量。
static DatatypeConstants.Field | DatatypeConstants.MONTHS 表示月字段的常量。
static DatatypeConstants.Field | DatatypeConstants.SECONDS 表示秒字段的常量。
static DatatypeConstants.Field | DatatypeConstants.YEARS 表示年字段的常量。

参数类型为 DatatypeConstants.Field 的 javax.xml.datatype 中的方法
abstract Number | Duration.getField(DatatypeConstants.Field field) 获取字段的值。
abstract boolean | Duration.isSet(DatatypeConstants.Field field) 检查是否设置了字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.datatype.DatatypeFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.DatatypeFactory
的使用

使用 DatatypeFactory 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 DatatypeFactory 的使用

返回 DatatypeFactory 的 javax.xml.datatype 中的方法
static DatatypeFactory | DatatypeFactory.newInstance() 获取新的 DatatypeFactory 实例。
static DatatypeFactory | DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DatatypeFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.datatype.Duration 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.Duration
的使用

使用 Duration 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 Duration 的使用

返回 Duration 的 javax.xml.datatype 中的方法
abstract Duration | Duration.add(Duration rhs) 计算值为 this+rhs 的新持续时间。
abstract Duration | Duration.multiply(BigDecimal factor) 计算新的持续时间，其值是此持续时间值的 factor 倍。
Duration | Duration.multiply(int factor) 计算新的持续时间，值为此持续时间值的 factor 倍。
abstract Duration | Duration.negate() 返回值为 -this 的新 Duration 对象。
abstract Duration | DatatypeFactory.newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
Duration | DatatypeFactory.newDuration(boolean isPositive, int years, int months, int days, int hours, int minutes, int seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
abstract Duration | DatatypeFactory.newDuration(long durationInMilliSeconds) 获取新的 Duration 实例，它将 Duration 指定为毫秒。
abstract Duration | DatatypeFactory.newDuration(String lexicalRepresentation) 获取新的 Duration 实例，它根据 XML 模式 1.0 第 3.2.6.1 节中的定义将 Duration 指定为其字符串表示形式 "PnYnMnDTnHnMnS"。
Duration | DatatypeFactory.newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationDayTime(boolean isPositive, int day, int hour, int minute, int second) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationDayTime(long durationInMilliseconds) 使用 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中定义的指定毫秒创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationDayTime(String lexicalRepresentation) 通过解析其 String 表示形式 "PnDTnHnMnS"（XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration）创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(boolean isPositive, int year, int month) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(long durationInMilliseconds) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定毫秒创建类型为 xdt:yearMonthDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(String lexicalRepresentation) 通过解析其 String 表示形式 "PnYnM"（XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration）创建类型为 xdt:yearMonthDuration 的 Duration。
abstract Duration | Duration.normalizeWith(Calendar startTimeInstant) 通过使用特定的时间点作为参考点，将 years 和 months 字段转换为 days 字段。
Duration | Duration.subtract(Duration rhs) 计算值为 this-rhs 的新持续时间。

参数类型为 Duration 的 javax.xml.datatype 中的方法
abstract Duration | Duration.add(Duration rhs) 计算值为 this+rhs 的新持续时间。
abstract void | XMLGregorianCalendar.add(Duration duration) 将 duration 添加到此实例。
abstract int | Duration.compare(Duration duration) 与此 Duration 实例的部分顺序关系比较。
boolean | Duration.isLongerThan(Duration duration) 检查此持续时间对象是否严格长于另一个 Duration 对象。
boolean | Duration.isShorterThan(Duration duration) 检查此持续时间对象是否严格短于另一个 Duration 对象。
Duration | Duration.subtract(Duration rhs) 计算值为 this-rhs 的新持续时间。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.datatype.XMLGregorianCalendar 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.datatype.XMLGregorianCalendar
的使用

使用 XMLGregorianCalendar 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 XMLGregorianCalendar 的使用

返回 XMLGregorianCalendar 的 javax.xml.datatype 中的方法
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar() 创建新的 XMLGregorianCalendar 实例。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone) W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal) 根据 GregorianCalendar 创建 XMLGregorianCalendar。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(int year, int month, int day, int hour, int minute, int second, int millisecond, int timezone) java.util.GregorianCalendar 实例需要转换为 XMLGregorianCalendar 实例的值空间的构造方法。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation) 通过将字符串解析为词汇表示形式，创建新的 XMLGregorianCalendar。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarDate(int year, int month, int day, int timezone) 创建 XML 模式内置数据类型 date 或 g* 的 Java 表示形式。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, int milliseconds, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
abstract XMLGregorianCalendar | XMLGregorianCalendar.normalize() 将此实例标准化为 UTC。

参数类型为 XMLGregorianCalendar 的 javax.xml.datatype 中的方法
abstract int | XMLGregorianCalendar.compare(XMLGregorianCalendar xmlGregorianCalendar) 根据 W3C XML 模式 1.0 第二部分 3.2.7.3 小节 Order relation on dateTime 中定义的部分顺序关系，比较 W3C XML 模式 1.0 日期/时间数据类型的两个实例。
abstract GregorianCalendar | XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults) 将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Schema (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.validation
类 Schema

java.lang.Object
    继承者  javax.xml.validation.Schema

public abstract class Schema
extends Object

不可变的语法存储表示形式。

此对象表示可以根据 XML 文档检查/实施的约束集。

Schema 对象是线程安全的，鼓励应用程序跨多个线程中的多个解析器共享它。

Schema 对象是不可变的，从某种意义来说就是，一旦创建约束集后，就不应再更改约束集。换句话说，如果应用程序根据相同 Schema 两次验证相同文档，那么它必须总是生成相同的结果。

Schema 对象通常是从 SchemaFactory 创建的。

可以从 Schema 对象创建两种验证器。一种是 Validator，它提供了覆盖典型用例的高层验证操作。另一种是 ValidatorHandler，它作用于 SAX 的顶层，以实现更好的模块性。

此规范不改进 Object.equals(java.lang.Object) 方法。换句话说，如果第二次解析相同的模式，则仍将得到 !schemaA.equals(schemaB)。

从以下版本开始：
1.5
另请参见：
XML Schema Part 1: Structures, Extensible Markup Language (XML) 1.1, Extensible Markup Language (XML) 1.0 (Second Edition)

构造方法摘要
protected Schema()
派生类的构造方法。
方法摘要
abstract Validator | newValidator() 创建此 Schema 的新 Validator。
abstract ValidatorHandler | newValidatorHandler() 创建此 Schema 的新 ValidatorHandler。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Schema

protected Schema()
派生类的构造方法。

构造方法不执行任何动作。

方法详细信息

newValidator

public abstract Validator newValidator()
创建此 Schema 的新 Validator。

验证器实施/检查此对象表示的约束集。

实现者应该确保在创建此 Schema 的 SchemaFactory 上设置的属性也设置在构造的 Validator 上。

返回：
总返回非 null 的有效对象。

newValidatorHandler

public abstract ValidatorHandler newValidatorHandler()
创建此 Schema 的新 ValidatorHandler。

实现者应该确保在创建此 Schema 的 SchemaFactory 上设置的属性也设置在构造的 ValidatorHandler 上。

返回：
总返回非 null 的有效对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SchemaFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.validation
类 SchemaFactory

java.lang.Object
    继承者  javax.xml.validation.SchemaFactory

public abstract class SchemaFactory
extends Object

创建 Schema 对象的工厂。验证 API 的入口点。

SchemaFactory 是一个模式编译器。它读取模式的外部表示形式并准备验证它们。

SchemaFactory 类不是线程安全的。换句话说，应用程序负责确保任意给定时刻至多只有一个线程使用 SchemaFactory 对象。鼓励实现将方法标记为 synchronized，以保护客户机不至于崩溃。

SchemaFactory 不是重入（re-entrant）方法。当正在调用某个 newSchema 方法时，应用程序不能试图以递归方式调用 newSchema 方法，甚至不能从相同线程调用该方法。

模式语言

此规范使用名称空间 URI 来指定模式语言。下表显示了此规范定义的值。

要遵守此规范，实现只需支持 W3C XML 模式 1.0 即可。但是，如果实现选择支持其他模式语言，那么它必须遵守此规范中所描述的相关行为。

此处未列出的模式语言应引用它们自己的 URI 来表示它们本身。SchemaFactory 类能够在运行时定位其他模式语言的其他实现。

注意，因为 XML DTD 与解析过程有紧密联系，并对解析过程产生很大影响，因此不能将 DTD 验证定义为与解析无关的过程。出于此原因，此规范不定义 XML DTD 的语义。这并不限制实现者以他们了解的合适方式来实现它，但这里提醒用户，此接口上实现的任何 DTD 验证必然偏离 XML 1.0 中所定义的 XML DTD 语义。

值 | 语言
XMLConstants.W3C_XML_SCHEMA_NS_URI ("http://www.w3.org/2001/XMLSchema") | W3C XML Schema 1.0
XMLConstants.RELAXNG_NS_URI ("http://relaxng.org/ns/structure/1.0") | RELAX NG 1.0

从以下版本开始：
1.5

构造方法摘要
protected SchemaFactory()
派生类的构造方法。
方法摘要
abstract ErrorHandler | getErrorHandler() 获取设置为此 SchemaFactory 的当前 ErrorHandler。
boolean | getFeature(String name) 查找功能标志的值。
Object | getProperty(String name) 查找属性值。
abstract LSResourceResolver | getResourceResolver() 获取设置为此 SchemaFactory 的当前 LSResourceResolver。
abstract boolean | isSchemaLanguageSupported(String schemaLanguage) 此 SchemaFactory 支持指定的模式吗？
static SchemaFactory | newInstance(String schemaLanguage) 查找支持指定模式语言的 SchemaFactory 的实现并返回它。
static SchemaFactory | newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader) 根据类名称获得一个新 SchemaFactory 实例。
abstract Schema | newSchema() 创建特殊的 Schema 对象。
Schema | newSchema(File schema) 解析作为模式的指定 File 并以 Schema 的形式返回它。
Schema | newSchema(Source schema) 解析作为模式的指定源并以模式形式返回它。
abstract Schema | newSchema(Source[] schemas) 解析作为模式的指定源（或多个源），并以模式形式返回它。
Schema | newSchema(URL schema) 解析作为模式的指定 URL 并以 Schema 形式返回它。
abstract void | setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收在 newSchema 方法调用期间遇到的错误。
void | setFeature(String name, boolean value) 设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。
void | setProperty(String name, Object object) 设置属性值。
abstract void | setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义解析模式时的资源解析。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SchemaFactory

protected SchemaFactory()

派生类的构造方法。

构造方法不执行任何动作。

派生类必须创建具有 null ErrorHandler 和 null LSResourceResolver 的 SchemaFactory 对象。

方法详细信息

newInstance

public static final SchemaFactory newInstance(String schemaLanguage)

查找支持指定模式语言的 SchemaFactory 的实现并返回它。

为了查找给定模式语言的 SchemaFactory 对象，此方法按照以下顺序查找以下位置，其中“类加载器”指上下文类加载器：

  1. 如果系统属性 "javax.xml.validation.SchemaFactory:schemaLanguage" 存在（其中 schemaLanguage 是此方法的参数），那么可以将它的值作为类名称来读取。该方法试图通过使用类加载器来创建此类的新实例，如果创建成功，则返回它。
  2. 读取 $java.home/lib/jaxp.properties，并查找与作为系统属性的键关联的值。如果存在这样的值，则按上面的方式处理该值。

  3. 类加载器要求服务提供者的提供者配置文件与资源目录 META-INF/services 中的 javax.xml.validation.SchemaFactory 匹配。参见文件格式和解析规则的 JAR File Specification。每个可能的服务提供者均要实现以下方法：

            isSchemaLanguageSupported(String schemaLanguage)
    返回支持指定模式语言的类加载器顺序中的第一个服务提供者。
  4. 以特定于实现的方式来定位平台默认的 SchemaFactory。必须存在 W3C XML 模式的平台默认 SchemaFactory。

如果这些都失败，则将抛出 IllegalArgumentException。

疑难解答提示：

有关如何精确解析属性文件的信息，请参阅 Properties.load(java.io.InputStream)。尤其要指出的是，冒号 ':'在属性文件中需要转义，因此要确保模式语言 URI 在其中进行正确转义。例如：

 http\://www.w3.org/2001/XMLSchema=org.acme.foo.XSSchemaFactory

参数：
schemaLanguage - 指定返回的 SchemaFactory 理解的模式语言。有关可能的值，请参阅 可用模式语言列表。
返回：
新的 SchemaFactory 实例
抛出：
IllegalArgumentException - 如果没有可用的模式语言实现。
NullPointerException - 如果 schemaLanguage 参数为 null。
另请参见：
newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)

newInstance

public static SchemaFactory newInstance(String schemaLanguage,
                                        String factoryClassName,
                                        ClassLoader classLoader)

根据类名称获得一个新 SchemaFactory 实例。如果指定的工厂类支持指定的模式语言，则返回 SchemaFactory。当类路径中有多个提供者时此功能很有用。它给了应用程序更多的控制权，因为它能指定应该加载哪个提供者。

疑难解答提示

设置 jaxp.debug 系统属性将导致此方法将许多调试消息打印到 System.err，以说明它执行的操作以及在何处查找这些操作。

如有问题，请尝试：

 java -Djaxp.debug=1 YourProgram ....

参数：
schemaLanguage - 指定返回的 SchemaFactory 理解的模式语言。有关可能的值，请参阅 the list of available schema languages。
factoryClassName - 完全限定工厂类名称，提供 javax.xml.validation.SchemaFactory 的实现。
classLoader - 用来加载工厂类的 ClassLoader。如果为 null，则使用当前 Thread 的上下文 classLoader 来加载工厂类。
返回：
新的 SchemaFactory 实例
抛出：
IllegalArgumentException - 如果 factoryClassName 为 null、工厂类不能被加载或实例化、工厂类不支持 schemLanguage 参数中指定的模式语言。
NullPointerException - 如果 schemaLanguage 参数为 null。
从以下版本开始：
1.6
另请参见：
newInstance(String schemaLanguage)

isSchemaLanguageSupported

public abstract boolean isSchemaLanguageSupported(String schemaLanguage)

此 SchemaFactory 支持指定的模式吗？

参数：
schemaLanguage - 指定返回的 SchemaFactory 理解的模式语言。schemaLanguage 必须指定有效的模式语言。
返回：
如果 SchemaFactory 支持 schemaLanguage，则返回 true，否则返回 false。
抛出：
NullPointerException - 如果 schemaLanguage 为 null。
IllegalArgumentException - 如果 schemaLanguage.length() == 0 或 schemaLanguage 未指定有效的模式语言。

getFeature

public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找功能标志的值。

功能名称是任何完全限定的 URI。SchemaFactory 有可能识别功能名称，但暂时不能返回其值。

实现者可随意选择（鼓励）创建自己的功能，方法是使用在它们自己的 URI 上构建的名称。

参数：
name - 功能名称，它是非 null 的完全限定 URI。
返回：
功能的当前值（true 或 false）。
抛出：
SAXNotRecognizedException - 如果不能分配或检索功能值。
SAXNotSupportedException - 当 SchemaFactory 可以识别功能名称但不能确定它此时的值时。
NullPointerException - 如果 name 为 null。
另请参见：
setFeature(String, boolean)

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException

设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。

实现者和开发人员应该特别注意 newSchema() 返回的特殊 Schema 对象是如何处理的。在某些情况下，例如，当 SchemaFactory 和类实际上加载来自不同实现的模式时，SchemaFactory 特性将无法自动继承。开发人员应该确保在两个地方都显式地设置了特性（如安全处理）。

功能名称是任何完全限定的 URI。SchemaFactory 有可能公开功能值，但不能更改当前值。

所有实现必须支持 XMLConstants.FEATURE_SECURE_PROCESSING 功能。当功能为以下情况时：

  • true：该实现将限制 XML 处理遵守实现限制。示例包括实体扩展限制和将使用大量资源的 XML 模式构造。如果由于安全原因 XML 处理受到限制，则将通过调用注册的 ErrorHandler.fatalError(SAXParseException exception) 来报告此情况。参见 setErrorHandler(ErrorHandler errorHandler)。
  • false：实现将根据 XML 规范来处理 XML，而不管可能的实现限制。

参数：
name - 功能名称，它是非 null 的完全限定 URI。
value - 所请求的功能值（true 或 false）。
抛出：
SAXNotRecognizedException - 如果不能分配或检索功能值。
SAXNotSupportedException - 当 SchemaFactory 可以识别功能名称，但不能设置请求的值时。
NullPointerException - 如果 name 为 null。
另请参见：
getFeature(String)

setProperty

public void setProperty(String name,
                        Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
设置属性值。

属性名称是任何完全限定的 URI。SchemaFactory 有可能识别属性名称，但不能更改当前值。

SchemaFactory 无需识别设置任何特定的属性名称。

参数：
name - 属性名称，它是非 null 的完全限定 URI。
object - 所请求的属性值。
抛出：
SAXNotRecognizedException - 如果不能分配或检索属性值。
SAXNotSupportedException - 当 SchemaFactory 可以识别属性名称，但不能设置请求的值时。
NullPointerException - 如果 name 为 null。

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找属性值。

属性名称是任何完全限定的 URI。SchemaFactory 有可能识别属性名称，但暂时不能返回其值。

SchemaFactory 无需识别任何特定的属性名称。

实现者可随意选择（鼓励）创建自己的属性，方法是使用在它们自己的 URI 上构建的名称。

参数：
name - 属性名称，它是非 null 的完全限定 URI。
返回：
属性的当前值。
抛出：
SAXNotRecognizedException - 如果不能分配或检索属性值。
SAXNotSupportedException - 当 XMLReader 可以识别属性名称，但不能确定它此时的值时。
NullPointerException - 如果 name 为 null。
另请参见：
setProperty(String, Object)

setErrorHandler

public abstract void setErrorHandler(ErrorHandler errorHandler)
设置 ErrorHandler 以接收在 newSchema 方法调用期间遇到的错误。

错误处理程序可用于自定义模式解析期间的错误处理过程。当设置 ErrorHandler 时，模式解析期间发现的错误将首先发送到 ErrorHandler。

通过抛出处理程序中的 SAXException，错误处理程序可以立即中止模式的解析。例如，它可以将错误打印到屏幕上，并尝试通过从 ErrorHandler 正常返回来继续该过程。

如果从 ErrorHandler 抛出任何 Throwable（或其派生类的实例），则 newSchema 方法的调用者将接收相同的 Throwable 对象。

在 SchemaFactory 没有先向 ErrorHandler 报告之前，不能抛出 SAXException。

甚至正在解析 Schema 期间，应用程序也可以调用此方法。

当 ErrorHandler 为 null 时，实现的行为就好像设置了以下 ErrorHandler 一样。

 class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

当创建新 SchemaFactory 对象时，此字段在初始化时被设置为 null。不要 将此字段继承给从此 SchemaFactory 创建的 Schema、Validator 或 ValidatorHandler。

参数：
errorHandler - 要设置的新错误处理程序。此参数可以为 null。

getErrorHandler

public abstract ErrorHandler getErrorHandler()
获取设置为此 SchemaFactory 的当前 ErrorHandler。

返回：
此方法返回通过 setErrorHandler(ErrorHandler) 方法设置的最后一个对象，如果自从创建此 SchemaFactory 以来一直未调用该方法，则返回 null。
另请参见：
setErrorHandler(ErrorHandler)

setResourceResolver

public abstract void setResourceResolver(LSResourceResolver resourceResolver)
设置 LSResourceResolver 以自定义解析模式时的资源解析。

在模式解析中，SchemaFactory 在需要查找外部资源时使用 LSResourceResolver，虽然“查找外部资源”的准确含义取决于每个模式语言。例如，对于 W3C XML Schema，这包括文件 <include>d 或 <import>ed，以及从模式文件引用的 DTD 等。

甚至正在解析 Schema 期间，应用程序也可以调用此方法。

当 LSResourceResolver 为 null 时，实现的行为就好像设置了以下 LSResourceResolver 一样：

 class DumbDOMResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

如果 LSResourceResolver 抛出 RuntimeException（或其派生类的实例），则 SchemaFactory 将中止解析，且 newSchema 方法的调用者将接收相同的 RuntimeException。

当创建新 SchemaFactory 对象时，此字段在初始化时被设置为 null。不要 将此字段继承给从此 SchemaFactory 创建的 Schema、Validator 或 ValidatorHandler。

参数：
resourceResolver - 要设置的新资源解析器。此参数可以为 null。

getResourceResolver

public abstract LSResourceResolver getResourceResolver()
获取设置为此 SchemaFactory 的当前 LSResourceResolver。

返回：
此方法返回通过 setResourceResolver(LSResourceResolver) 方法设置的最后一个对象，如果自从创建此 SchemaFactory 以来一直未调用该方法，则返回 null。
另请参见：
setErrorHandler(ErrorHandler)

newSchema

public Schema newSchema(Source schema)
                 throws SAXException

解析作为模式的指定源并以模式形式返回它。

这是一个针对 newSchema(Source[] schemas) 的便捷方法。

参数：
schema - 表示模式的源。
返回：
从解析 schema 得到的新 Schema。
抛出：
SAXException - 如果解析期间发生 SAX 错误。
NullPointerException - 如果 schema 为 null。

newSchema

public Schema newSchema(File schema)
                 throws SAXException

解析作为模式的指定 File 并以 Schema 的形式返回它。

这是一个针对 newSchema(Source schema) 的便捷方法。

参数：
schema - 表示模式的 File。
返回：
从解析 schema 得到的新 Schema。
抛出：
SAXException - 如果解析期间发生 SAX 错误。
NullPointerException - 如果 schema 为 null。

newSchema

public Schema newSchema(URL schema)
                 throws SAXException

解析作为模式的指定 URL 并以 Schema 形式返回它。

这是一个针对 newSchema(Source schema) 的便捷方法。

参数：
schema - 表示模式的 URL。
返回：
从解析 schema 得到的新 Schema。
抛出：
SAXException - 如果解析期间发生 SAX 错误。
NullPointerException - 如果 schema 为 null。

newSchema

public abstract Schema newSchema(Source[] schemas)
                          throws SAXException
解析作为模式的指定源（或多个源），并以模式形式返回它。

被调用者将读取所有 Source 并将它们组合到一个模式中。组合的精确语义取决于此 SchemaFactory 对象为其创建的模式语言。

当设置 ErrorHandler 时，被调用者将向处理程序报告源中发现的所有错误。如果处理程序执行异常，则它将中止模式组合，且将从此方法抛出相同的异常。同样，向处理程序报告错误后，允许被调用者通过抛出该错误来中止下一步处理。如果未设置错误处理程序，则被调用者将抛出在源中发现的第一个错误。

W3C XML 模式 1.0

得到的模式包含来自指定源的组件。如果使用合适的 schemaLocation 值和名称空间值将所有这些源导入具有不同 targetNamespace 且没有其自己组件的单个模式文档中，如果以与源相同的顺序给定导入元素，则将得到相同结果。XML 模式建议的第 4.2.3 节描述了处理器关于这方面的选项。当处理器应与其 JAXP 模式源和 XML 模式导入的处理一致时，JAXP 兼容的解析器之间的行为可能不同，特别是解析器可能选择忽略所有给定名称空间的 <import>（第一个除外），而不管 schemaLocation 中所提供的信息。

如果解析后的模式集包含 XML 模式规范第 5.1 节指定的错误（或多个错误），则必须将错误报告给 ErrorHandler。

RELAX NG

对于 RELAX NG，如果 schemas.length!=1，则此方法必须抛出 UnsupportedOperationException。

参数：
schemas - 要解析的输入。SchemaFactory 必须识别 SAXSource、StreamSource、StAXSource 和 DOMSource。输入模式必须是 XML 文档或 XML 元素，并且不得为 null。为了向后兼容，传递文档或元素以外的任何内容的所得结果都由实现决定。实现必须能识别并处理输入，否则将抛出 IllegalArgumentException。
返回：
总返回非 null 的有效 Schema 对象。注意，当已报告错误后，不保证返回的 Schema 对象有意义。
抛出：
SAXException - 如果在处理指定输入期间发现错误。当设置 ErrorHandler 时，首先将错误报告到该处。参见 setErrorHandler(ErrorHandler)。
NullPointerException - 如果 schemas 参数本身为 null，或数组中的任何项为 null。
IllegalArgumentException - 如果此方法不识别数组中的任何项。
UnsupportedOperationException - 如果模式语言不支持此操作。

newSchema

public abstract Schema newSchema()
                          throws SAXException
创建特殊的 Schema 对象。

返回的 Schema 对象的精确语义取决于此 SchemaFactory 为其创建的模式语言。

同样，允许实现使用特定于实现的属性/功能来更改此方法的语义。

实现者和开发人员应该特别注意此 SchemaFactory 上设置的特性是如何由此特殊 Schema 对象处理的。在某些情况下，例如，当 SchemaFactory 和类实际上加载来自不同实现的模式时，SchemaFactory 特性将无法自动继承。开发人员应该确保在两个地方都显式地设置了特性（如安全处理）。

W3C XML 模式 1.0

对于 XML 模式，此方法创建 Schema 对象，该对象通过使用文档中指定的位置提示来执行验证。

返回的 Schema 对象假定如果文档指向模式位置提示中的相同 URL，则它们将总是解析为相同的模式文档。此假定允许实现重用解析后的模式文档结果，以便相对于相同模式的多个验证可以更快地运行。

注意，模式位置提示的使用引入了恶意的拒绝服务攻击。

RELAX NG

RELAX NG 不支持此操作。

返回：
总返回非 null 的有效 Schema 对象。
抛出：
UnsupportedOperationException - 如果被调用者不支持此操作。
SAXException - 如果此操作受支持但由于某种原因而失败。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SchemaFactoryLoader (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.validation
类 SchemaFactoryLoader

java.lang.Object
    继承者  javax.xml.validation.SchemaFactoryLoader

public abstract class SchemaFactoryLoader
extends Object

创建 SchemaFactory 的工厂。

不要使用此类

此类是在 JSR-206 标准化期间作为早期提案的一部分引入的。该提案最终被废弃，但是此类很意外地被保留在源树中，因此出现在最终版本中。

此类不参加任何 JAXP 1.3 或 JAXP 1.4 处理。用户或 JAXP 实现不得使用该类。

从以下版本开始：
1.5

构造方法摘要
protected SchemaFactoryLoader()
不执行操作的构造方法。
方法摘要
abstract  SchemaFactory newFactory(String schemaLanguage)
创建指定模式语言的新 SchemaFactory 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SchemaFactoryLoader

protected SchemaFactoryLoader()
不执行操作的构造方法。

方法详细信息

newFactory

public abstract SchemaFactory newFactory(String schemaLanguage)
创建指定模式语言的新 SchemaFactory 对象。

参数：
schemaLanguage - 参见可用模式语言列表.
返回：
如果被调用者无法创建该对象，则返回 null。
抛出：
NullPointerException - 如果 schemaLanguage 参数为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeInfoProvider (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.validation
类 TypeInfoProvider

java.lang.Object
    继承者  javax.xml.validation.TypeInfoProvider

public abstract class TypeInfoProvider
extends Object

此类提供了对 ValidatorHandler 所确定的类型信息的访问。

某些模式语言（例如 W3C XML Schema）鼓励验证器报告它分配给每个属性/元素的“类型”。那些希望访问此类型信息的应用程序可以调用此“接口”上的方法来访问这样的类型信息。

此“接口”的实现可以通过 ValidatorHandler.getTypeInfoProvider() 方法获取。

从以下版本开始：
1.5
另请参见：
TypeInfo

构造方法摘要
protected TypeInfoProvider()
派生类的构造方法。
方法摘要
abstract TypeInfo | getAttributeTypeInfo(int index) 返回指定的当前元素属性的不可变的 TypeInfo 对象。
abstract TypeInfo | getElementTypeInfo() 返回当前元素的不可变的 TypeInfo 对象。
abstract boolean | isIdAttribute(int index) 如果指定属性确定为 ID，则返回 true。
abstract boolean | isSpecified(int index) 如果属性是通过验证器添加的，则返回 false。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TypeInfoProvider

protected TypeInfoProvider()
派生类的构造方法。

构造方法不执行任何动作。

方法详细信息

getElementTypeInfo

public abstract TypeInfo getElementTypeInfo()

返回当前元素的不可变的 TypeInfo 对象。

该方法只能由 ContentHandler（应用程序将其设置为 ValidatorHandler）的 startElement 事件或 endElement 事件调用。

当正在执行 W3C XML 模式验证时，在元素具有 union 类型的情况下，对 startElement 事件调用 getElementTypeInfo() 所返回的 TypeInfo 将是 union 类型。endElement 事件的调用所返回的 TypeInfo 将是实际用来验证元素的数字类型。

返回：
表示当前元素类型的不可变的 TypeInfo 对象。注意，调用者保持对所获得的 TypeInfo 的引用时间可能要长于回调作用时间。否则，如果由于某种原因验证器不能确定当前元素的类型（例如，如果验证器正从较早的错误中恢复），则此方法返回 null。
抛出：
IllegalStateException - 如果从其他 ContentHandler 方法调用了此方法。

getAttributeTypeInfo

public abstract TypeInfo getAttributeTypeInfo(int index)
返回指定的当前元素属性的不可变的 TypeInfo 对象。

该方法只能由 ContentHandler（应用程序将其设置为 ValidatorHandler）的 startElement 事件调用。

参数：
index - 属性的索引。传递给 startElement 回调的 Attributes 对象的相同索引。
返回：
表示指定属性类型的不可变的 TypeInfo 对象。注意，调用者保持对所获得的 TypeInfo 的引用时间可能要长于回调作用时间。否则，如果验证器无法确定类型，则此方法返回 null。
抛出：
IndexOutOfBoundsException - 如果索引无效。
IllegalStateException - 如果从其他 ContentHandler 方法调用了此方法。

isIdAttribute

public abstract boolean isIdAttribute(int index)
如果指定属性确定为 ID，则返回 true。

属性如何“确定为 ID”的准确方式取决于模式语言。在 W3C XML 模式中，这意味着实际的属性类型为内置的 ID 类型或其派生类型。

DocumentBuilder 使用此信息来正确地实现 Attr.isId()。

该方法只能由 ContentHandler（应用程序将其设置为 ValidatorHandler）的 startElement 事件调用。

参数：
index - 属性的索引。传递给 startElement 回调的 Attributes 对象的相同索引。
返回：
如果指定属性的类型为 ID，则返回 true。
抛出：
IndexOutOfBoundsException - 如果索引无效。
IllegalStateException - 如果从其他 ContentHandler 方法调用了此方法。

isSpecified

public abstract boolean isSpecified(int index)
如果属性是通过验证器添加的，则返回 false。

此方法为 DocumentBuilder 提供了所需的信息，以确定 DOM 树应从 Attr.getSpecified() 方法返回的内容。

该方法只能由 ContentHandler（应用程序将其设置为 ValidatorHandler）的 startElement 事件调用。

验证器的通用指导原则是：如果属性最初就在管线中存在，则返回 true，如果它是通过验证器添加的，则返回 false。

参数：
index - 属性的索引。传递给 startElement 回调的 Attributes 对象的相同索引。
返回：
如果在验证器处理输入之前属性已存在，则返回 true，如果属性是通过验证器添加的，则返回 false。
抛出：
IndexOutOfBoundsException - 如果索引无效。
IllegalStateException - 如果从其他 ContentHandler 方法调用了此方法。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Validator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.validation
类 Validator

java.lang.Object
    继承者  javax.xml.validation.Validator

public abstract class Validator
extends Object

根据 Schema 检查 XML 文档的处理器。

Validator 对象不是线程安全的，也不能重入。换句话说，应用程序负责确保在任意给定时刻不能有多个线程同时使用 Validator 对象，且当调用 validate 方法时，应用程序不能以递归方式调用 validate 方法。

从以下版本开始：
1.5

构造方法摘要
protected Validator()
派生类的构造方法。
方法摘要
abstract ErrorHandler | getErrorHandler() 获取设置为此 Validator 的当前 ErrorHandler。
boolean | getFeature(String name) 查找功能标志的值。
Object | getProperty(String name) 查找属性值。
abstract LSResourceResolver | getResourceResolver() 获取设置为此 Validator 的当前 LSResourceResolver。
abstract void | reset() 将此 Validator 重置为其初始配置。
abstract void | setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收在 validate 方法调用期间遇到的错误。
void | setFeature(String name, boolean value) 设置功能标志的值。
void | setProperty(String name, Object object) 设置属性值。
abstract void | setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义验证期间的资源解析。
void | validate(Source source) 验证指定的输入。
abstract void | validate(Source source, Result result) 验证指定输入并将扩充的验证结果发送到指定输出。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Validator

protected Validator()
派生类的构造方法。

构造方法不执行任何操作。

派生类必须创建具有 null ErrorHandler 和 null LSResourceResolver 的 Validator 对象。

方法详细信息

reset

public abstract void reset()

将此 Validator 重置为其初始配置。

Validator 被重置为通过 Schema.newValidator() 创建它时的状态。reset() 在设目标是允许重用现有的 Validator，从而节省与创建新的 Validator 相关的资源。

不保证重置的 Validator 具有相同的 LSResourceResolver 或 ErrorHandler Object，例如 Object.equals(Object obj)。但保证具有功能相等的 LSResourceResolver 和 ErrorHandler。

validate

public void validate(Source source)
              throws SAXException,
                     IOException
验证指定的输入。

这只是 validate(Source source, Result result)（result 为 null）的一个便捷方法。

参数：
source - 要验证的 XML。该参数必须为 XML 文档或 XML 元素，不可以为 null。为了向后兼容，试图验证文档或元素以外的任何内容的所得结果都由实现决定。实现必须能识别并处理输入，否则将抛出 IllegalArgumentException。
抛出：
IllegalArgumentException - 如果 Source 是实现无法验证的 XML 人为因素（例如，一个处理指令）。
SAXException - 如果 ErrorHandler 抛出 SAXException，或者发现致命错误且 ErrorHandler 正常返回。
IOException - 如果验证器正在处理 SAXSource 且底层 XMLReader 抛出了 IOException。
NullPointerException - 如果 source 为 null。
另请参见：
validate(Source source, Result result)

validate

public abstract void validate(Source source,
                              Result result)
                       throws SAXException,
                              IOException

验证指定输入并将扩充的验证结果发送到指定输出。

此方法对所接受的 Source/Result 的类型设置了以下限制。

所接受的 Source / Result
StreamSource SAXSource DOMSource StAXSource
null | OK | OK | OK | OK
StreamResult | OK | IllegalArgumentException | IllegalArgumentException | IllegalArgumentException
SAXResult | IllegalArgumentException | OK | IllegalArgumentException | IllegalArgumentException
DOMResult | IllegalArgumentException | IllegalArgumentException | OK | IllegalArgumentException
StAXResult | IllegalArgumentException | IllegalArgumentException | IllegalArgumentException | OK

要验证一个 Source 并输出到另一种类型的 Result 中，请使用恒等转换器（参见 TransformerFactory.newTransformer()）。

将验证中发现的错误发送到指定的 ErrorHandler。

如果文档有效，或者文档包含某些错误但无致命错误且 ErrorHandler 不抛出任何异常，则该方法正常返回。

参数：
source - 要验证的 XML。该参数必须为 XML 文档或 XML 元素，不可以为 null。为了向后兼容，试图验证文档或元素以外的任何内容的所得结果都由实现决定。实现必须能识别并处理输入，否则将抛出 IllegalArgumentException。
result - 接收（可能是扩充的）XML 的 Result 对象。如果调用者不需要它，则此参数可以为 null。注意，当使用 DOMResult 时，验证器可以只是将来自 DOMSource 的相同 DOM 节点传递到 DOMResult（在这种情况下，source.getNode()==result.getNode()），它可能复制整个 DOM 树，或者更改源所给定的节点。
抛出：
IllegalArgumentException - 如果 Result 类型与 Source 类型不匹配，或者 Source 是实现无法验证的 XML 人为因素（例如，一个处理指令）。
SAXException - 如果 ErrorHandler 抛出 SAXException，或者出现致命错误且 ErrorHandler 正常返回。
IOException - 如果验证器正在处理 SAXSource，且底层 XMLReader 抛出 IOException。
NullPointerException - 如果 source 参数为 null。
另请参见：
validate(Source source)

setErrorHandler

public abstract void setErrorHandler(ErrorHandler errorHandler)
设置 ErrorHandler 以接收在 validate 方法调用期间遇到的错误。

错误处理程序可用于自定义验证期间的错误处理过程。当设置 ErrorHandler 时，验证期间发现的错误将首先发送到 ErrorHandler。

错误处理程序通过抛出来自处理程序的 SAXException 可以立即中止进一步的验证。例如，它可以将错误打印到屏幕上，并尝试通过从 ErrorHandler 正常返回来继续该验证。

如果从 ErrorHandler 抛出任何 Throwable，则 validate 方法的调用者将接收相同的 Throwable 对象。

在 Validator 没有先向 ErrorHandler 报告之前，不能抛出 SAXException。

当 ErrorHandler 为 null 时，实现的行为就好像设置了以下 ErrorHandler 一样。

 class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

当创建新 Validator 对象时，此字段在初始化时被设置为 null。

参数：
errorHandler - 要设置的新错误处理程序。此参数可以为 null。

getErrorHandler

public abstract ErrorHandler getErrorHandler()
获取设置为此 Validator 的当前 ErrorHandler。

返回：
此方法返回通过 setErrorHandler(ErrorHandler) 方法设置的最后一个对象，如果自从创建此 Validator 以来一直未调用该方法，则返回 null。
另请参见：
setErrorHandler(ErrorHandler)

setResourceResolver

public abstract void setResourceResolver(LSResourceResolver resourceResolver)
设置 LSResourceResolver 以自定义验证期间的资源解析。

在验证期间，Validator 在需要查找外部资源时使用 LSResourceResolver，虽然“查找外部资源”的准确含义取决于每种模式语言。

当 LSResourceResolver 为 null 时，实现的行为就好像设置了以下 LSResourceResolver 一样。

 class DumbLSResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

如果 LSResourceResolver 抛出 RuntimeException（或其派生类的实例），则 Validator 将中止解析，且 validate 方法的调用者将接收相同的 RuntimeException。

当创建新 Validator 对象时，此字段在初始化时被设置为 null。

参数：
resourceResolver - 要设置的新资源解析器。此参数可以为 null。

getResourceResolver

public abstract LSResourceResolver getResourceResolver()
获取设置为此 Validator 的当前 LSResourceResolver。

返回：
此方法返回通过 setResourceResolver(LSResourceResolver) 方法设置的最后一个对象，如果自从创建此 Validator 以来一直未调用该方法，则返回 null。
另请参见：
setErrorHandler(ErrorHandler)

getFeature

public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找功能标志的值。

功能名称是任何完全限定的 URI。Validator 有可能识别功能名称，但暂时不能返回其值。某些功能值可能只有在特定上下文中才能使用，例如在验证前、验证中或验证之后。

实现者可随意选择（鼓励）创建自己的功能，方法是使用在它们自己的 URI 上构建的名称。

参数：
name - 功能名称，它是非 null 的完全限定 URI。
返回：
功能的当前值（true 或 false）。
抛出：
SAXNotRecognizedException - 如果不能分配或检索功能值。
SAXNotSupportedException - 当 Validator 可以识别功能名称但不能确定它此时的值时。
NullPointerException - 当 name 参数为 null 时。
另请参见：
setFeature(String, boolean)

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
设置功能标志的值。

功能可用于控制 Validator 解析模式的方法，虽然 Validator 无需识别任何指定的特性名称。

功能名称是任何完全限定的 URI。Validator 有可能公开功能值，但不能更改当前值。某些功能值可能只有在特定上下文中才是不可变的或可变的，例如在验证前、验证中或验证之后。

参数：
name - 功能名称，它是非 null 的完全限定 URI。
value - 所请求的功能值（true 或 false）。
抛出：
SAXNotRecognizedException - 如果不能分配或检索功能值。
SAXNotSupportedException - 当 Validator 可以识别功能名称，但不能设置请求的值时。
NullPointerException - 当 name 参数为 null 时。
另请参见：
getFeature(String)

setProperty

public void setProperty(String name,
                        Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
设置属性值。

属性名称是任何完全限定的 URI。Validator 有可能识别属性名称，但不能更改当前值。某些属性值可能只有在特定上下文中才是不可变的或可变的，例如在验证前、验证中或验证之后。

Validator 无需识别设置任何指定的属性名称。

参数：
name - 属性名称，它是非 null 的完全限定 URI。
object - 所请求的属性值。
抛出：
SAXNotRecognizedException - 如果不能分配或检索属性值。
SAXNotSupportedException - 当 Validator 可以识别属性名称，但不能设置请求的值时。
NullPointerException - 当 name 参数为 null 时。

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找属性值。

属性名称是任何完全限定的 URI。Validator 有可能识别属性名称，但暂时不能返回其值。某些属性值可能只有在特定上下文中才能使用，例如在验证前、验证中或验证之后。

Validator 无需识别任何指定的属性名称。

实现者可随意选择（鼓励）创建自己的属性，方法是使用在它们自己的 URI 上构建的名称。

参数：
name - 属性名称，它是非 null 的完全限定 URI。
返回：
属性的当前值。
抛出：
SAXNotRecognizedException - 如果不能分配或检索属性值。
SAXNotSupportedException - 当 XMLReader 可以识别属性名称，但不能确定它此时的值时。
NullPointerException - 当 name 参数为 null 时。
另请参见：
setProperty(String, Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValidatorHandler (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.validation
类 ValidatorHandler

java.lang.Object
    继承者  javax.xml.validation.ValidatorHandler
所有已实现的接口：
ContentHandler
public abstract class ValidatorHandler
extends Object
implements ContentHandler

处理 SAX 流的流验证器。

ValidatorHandler 对象不是线程安全的，也不能重入。换句话说，应用程序负责确保在任何给定时刻使用 ValidatorHandler 对象的线程不多于一个。

ValidatorHandler 检查 SAX 事件是否遵守关联的 Schema 中所描述的约束集，此外它可以修改 SAX 事件（例如添加默认值等）。

ValidatorHandler 扩展自 ContentHandler，但它按以下方式修改了底层 ContentHandler：

  1. 对于 uri、localName 和 qname，即使 SAX 允许当中一些值为 null，startElement/endElement 事件也必须接收非 null String。类似地，对于这 3 个参数，用户指定的 ContentHandler 也将接收非 null String。
  2. 应用程序必须确保正确调用 ValidatorHandler 的 ContentHandler.startPrefixMapping(String,String) 和 ContentHandler.endPrefixMapping(String)。类似地，用户指定的 ContentHandler 将接收 startPrefixMapping/endPrefixMapping 事件。如果 ValidatorHandler 引入了额外的名称空间绑定，则用户指定的 ContentHandler 将接收额外的 startPrefixMapping/endPrefixMapping 事件。
  3. ContentHandler.startElement(String,String,String,Attributes) 的 Attributes 可以包括也可以不包括 xmlns* 属性。

每次调用 startDocument 方法时将自动重置 ValidatorHandler。

识别的属性和特性

此规范定义了以下特性，所有 ValidatorHandler 实现必须识别这些特性。

http://xml.org/sax/features/namespace-prefixes

此特性控制 ValidatorHandler 如何引入原始 SAX 事件流中不存在的名称空间绑定。当此特性设置为 true 时，它必须确保用户的 ContentHandler 将看到 ContentHandler.startElement(String,String,String,Attributes) 回调的 Attributes 对象中相应的 xmlns* 属性。否则，不得将 xmlns* 属性添加到传递给用户指定的 ContentHandler 的 Attributes。

（注意，无论特性如何切换，名称空间绑定总是通过用户所指定的 ContentHandler 的 ContentHandler.startPrefixMapping(String,String) 和 ContentHandler.endPrefixMapping(String) 方法通知应用程序。）

注意，此特性不 影响 ValidatorHandler 接收 SAX 事件的方式。它仅更改其扩充 SAX 事件的方式。

此特性默认设置为 false。

从以下版本开始：
1.5

构造方法摘要
protected ValidatorHandler()
派生类的构造方法。
方法摘要
abstract ContentHandler | getContentHandler() 获取接收扩充的验证结果的 ContentHandler。
abstract ErrorHandler | getErrorHandler() 获取设置为此 ValidatorHandler 的当前 ErrorHandler。
boolean | getFeature(String name) 查找特性标志的值。
Object | getProperty(String name) 查找属性值。
abstract LSResourceResolver | getResourceResolver() 获取设置到此 ValidatorHandler 的当前 LSResourceResolver。
abstract TypeInfoProvider | getTypeInfoProvider() 获取此 ValidatorHandler 的 TypeInfoProvider 实现。
abstract void | setContentHandler(ContentHandler receiver) 设置 ContentHandler，它接收扩充的验证结果。
abstract void | setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收验证期间遇到的错误。
void | setFeature(String name, boolean value) 设置此 ValidatorHandler 的特性。
void | setProperty(String name, Object object) 设置属性值。
abstract void | setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义验证期间的资源解析。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.xml.sax.ContentHandler 继承的方法
characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

构造方法详细信息

ValidatorHandler

protected ValidatorHandler()

派生类的构造方法。

该构造方法不执行任何操作。

派生类必须创建具有 null ErrorHandler 和 null LSResourceResolver 的 ValidatorHandler 对象。

方法详细信息

setContentHandler

public abstract void setContentHandler(ContentHandler receiver)
设置 ContentHandler，它接收扩充的验证结果。

当指定了 ContentHandler 时，ValidatorHandler 将充当过滤器，实际上是将输入事件复制到指定的 ContentHandler。

在复制过程中，ValidatorHandler 可以修改事件，例如添加默认属性。

ValidatorHandler 可以对事件进行一定程度的缓冲，但要使解析器使用 ValidatorHandler，必须满足以下要求。

  1. 当对 ValidatorHandler 调用 ContentHandler.startElement(String, String, String, Attributes)、ContentHandler.endElement(String, String, String)、ContentHandler.startDocument() 或 ContentHandler.endDocument() 时，在回调返回之前，必须针对相同事件对用户指定的 ContentHandler 调用相同的方法。
  2. ValidatorHandler 不能引入输入中不存在的新元素。
  3. ValidatorHandler 不能移除输入中存在的属性。

当对指定的 ContentHandler 调用回调方法抛出异常时，必须从 ValidatorHandler 抛出相同的异常对象。ErrorHandler 不应该获得此类异常的通知。

甚至在验证期间也可以调用此方法。

参数：
receiver - ContentHandler 或 null 值。

getContentHandler

public abstract ContentHandler getContentHandler()
获取接收扩充的验证结果的 ContentHandler。

返回：
此方法返回通过 getContentHandler() 方法设置的最后一个对象；如果自从创建此 ValidatorHandler 以来一直未调用该方法，则返回 null。
另请参见：
setContentHandler(ContentHandler)

setErrorHandler

public abstract void setErrorHandler(ErrorHandler errorHandler)
设置 ErrorHandler 以接收验证期间遇到的错误。

错误处理程序可用于自定义验证期间的错误处理过程。设置了 ErrorHandler 时，验证期间发现的错误将首先被发送到 ErrorHandler。

错误处理程序通过抛出来自处理程序的 SAXException 可以立即中止进一步验证。或者，它可以将错误打印到屏幕上，并尝试通过从 ErrorHandler 正常返回来继续该验证。

如果从 ErrorHandler 抛出任何 Throwable，则将向调用堆栈的根抛出相同的 Throwable 对象。

在 ValidatorHandler 首先向 ErrorHandler 报告之前，不允许抛出 SAXException。

当 ErrorHandler 为 null 时，实现的行为就好像设置了以下 ErrorHandler 一样：

 class DraconianErrorHandler implements ErrorHandler {
     public void fatalError( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void error( SAXParseException e ) throws SAXException {
         throw e;
     }
     public void warning( SAXParseException e ) throws SAXException {
         // noop
     }
 }

当创建新 ValidatorHandler 对象时，此字段最初被设置为 null。

参数：
errorHandler - 要设置的新错误处理程序。此参数可以为 null。

getErrorHandler

public abstract ErrorHandler getErrorHandler()
获取设置为此 ValidatorHandler 的当前 ErrorHandler。

返回：
此方法返回通过 setErrorHandler(ErrorHandler) 方法设置的最后一个对象；如果自从创建此 ValidatorHandler 以来一直未调用该方法，则返回 null。
另请参见：
setErrorHandler(ErrorHandler)

setResourceResolver

public abstract void setResourceResolver(LSResourceResolver resourceResolver)
设置 LSResourceResolver 以自定义验证期间的资源解析。

验证期间，ValidatorHandler 在需要查找外部资源时使用 LSResourceResolver，虽然组成“查找外部资源”的准确语句取决于每个模式语言。

当 LSResourceResolver 为 null 时，实现的行为就好像设置了以下 LSResourceResolver 一样：

 class DumbLSResourceResolver implements LSResourceResolver {
     public LSInput resolveResource(
         String publicId, String systemId, String baseURI) {

         return null; // always return null
     }
 }

如果 LSResourceResolver 抛出 RuntimeException（或其派生类的实例），则 ValidatorHandler 将中止解析，且 validate 方法的调用者将接收相同的 RuntimeException。

当创建新 ValidatorHandler 对象时，此字段最初被设置为 null。

参数：
resourceResolver - 要设置的新资源解析器。此参数可以为 null。

getResourceResolver

public abstract LSResourceResolver getResourceResolver()
获取设置到此 ValidatorHandler 的当前 LSResourceResolver。

返回：
此方法返回通过 setResourceResolver(LSResourceResolver) 方法设置的最后一个对象；如果自从创建此 ValidatorHandler 以来一直未调用该方法，则返回 null。
另请参见：
setErrorHandler(ErrorHandler)

getTypeInfoProvider

public abstract TypeInfoProvider getTypeInfoProvider()
获取此 ValidatorHandler 的 TypeInfoProvider 实现。

在解析期间可以查询所获取的 TypeInfoProvider，以访问验证器确定的类型信息。

某些模式语言未定义类型概念，对于这些语言，此方法可能不受支持。但是，为了遵守此规范，W3C XML 模式 1.0 实现必须支持此操作。

返回：
如果验证器/模式语言不支持 TypeInfo 概念，则返回 null。否则返回非 null 的有效 TypeInfoProvider。

getFeature

public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找特性标志的值。

特性名称是任何完全限定的 URI。ValidatorHandler 可以识别特性名称，但暂时不能返回其值。某些特性值只有在特定上下文中才能使用，例如在验证前、验证中或验证之后。

使用在自己的 URI 上构建的名称，实现者可随意选择（鼓励）创建自己的特性。

参数：
name - 特性名称，它是非 null 的完全限定 URI。
返回：
特性的当前值（true 或 false）。
抛出：
SAXNotRecognizedException - 如果不能分配或检索特性值。
SAXNotSupportedException - 当 ValidatorHandler 可以识别特性名称但不能确定其此时的值时。
NullPointerException - 当 name 为 null 时。
另请参见：
setFeature(String, boolean)

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException

设置此 ValidatorHandler 的特性。

特性可用于控制 ValidatorHandler 解析模式的方式。特性名称是任何完全限定的 URI。ValidatorHandler 可以公开特性值，但不能更改当前值。某些特性值只有在特定上下文中才是不可变的或可变的，例如在验证前、验证中或验证之后。

所有实现必须支持 XMLConstants.FEATURE_SECURE_PROCESSING 特性。当特性为以下情况时：

  • true：该实现将限制 XML 处理遵守实现限制。示例包括实体扩展限制和将使用大量资源的 XML 模式构造。如果由于安全原因 XML 处理受到限制，则将通过调用注册的 ErrorHandler.fatalError(SAXParseException exception) 来报告此情况。参见 setErrorHandler(ErrorHandler errorHandler)。
  • false：实现将根据 XML 规范来处理 XML，而不管可能的实现限制。

参数：
name - 特性名称，它是非 null 的完全限定 URI。
value - 所请求的特性值（true 或 false）。
抛出：
SAXNotRecognizedException - 如果不能分配或检索特性值。
SAXNotSupportedException - 当 ValidatorHandler 可以识别特性名称，但不能设置请求的值时。
NullPointerException - 当 name 为 null时。
另请参见：
getFeature(String)

setProperty

public void setProperty(String name,
                        Object object)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
设置属性值。

属性名称是任何完全限定的 URI。ValidatorHandler 可以识别属性名称，但不能更改当前值。某些属性值只有在特定上下文中才是不可变的或可变的，例如在验证前、验证中或验证之后。

ValidatorHandler 无需识别设置任何特定的属性名称。

参数：
name - 属性名称，它是非 null 的完全限定 URI。
object - 所请求的属性值。
抛出：
SAXNotRecognizedException - 如果不能分配或检索属性值。
SAXNotSupportedException - 当 ValidatorHandler 可以识别属性名称，但不能设置请求的值时。
NullPointerException - 当 name 为 null 时。

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找属性值。

属性名称是任何完全限定的 URI。ValidatorHandler 可以识别属性名称，但暂时不能返回其值。某些属性值只有在特定上下文中才能使用，例如在验证前、验证中或验证之后。

ValidatorHandler 无需识别任何指定的属性名称。

使用在自己 URI 上构建的名称，实现者可随意选择（鼓励）创建自己的属性。

参数：
name - 属性名称，它是非 null 的完全限定 URI。
返回：
属性的当前值。
抛出：
SAXNotRecognizedException - 如果不能分配或检索属性值。
SAXNotSupportedException - 当 XMLReader 可以识别属性名称，但不能确定其此时的值时。
NullPointerException - 当 name 为 null 时。
另请参见：
setProperty(String, Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.validation (Java Platform SE 6)

 javax.xml.validation
类
Schema
SchemaFactory
SchemaFactoryLoader
TypeInfoProvider
Validator
ValidatorHandler


javax.xml.validation (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.validation

此包提供了用于 XML 文档验证的 API。

请参见：
描述

类摘要
Schema | 不可变的语法存储表示形式。
SchemaFactory | 创建 Schema 对象的工厂。
SchemaFactoryLoader | 创建 SchemaFactory 的工厂。
TypeInfoProvider | 此类提供了对 ValidatorHandler 所确定的类型信息的访问。
Validator | 根据 Schema 检查 XML 文档的处理器。
ValidatorHandler | 处理 SAX 流的流验证器。

软件包 javax.xml.validation 的描述

此包提供了用于 XML 文档验证的 API。Validation 是验证 XML 文档是否为指定 XML schema 的实例的过程。XML 模式定义了其实例文档将表示的内容模式（也称为 grammar 或 vocabulary）。

有多种流行的技术用于创建 XML 模式。最流行的技术包括：

  • Document Type Definition (DTD) －－ XML 的内置模式语言。
  • W3C XML Schema (WXS) －－ 面向对象的 XML 模式语言。WXS 还提供了用于约束 XML 文档的字符数据的类型系统。WXS 通过 World Wide Web Consortium (W3C) 维护，它是 W3C Recommendation（即公认的 W3C 标准规范）。
  • RELAX NG (RNG) －－ 基于模式的、用户友好的 XML 模式语言。RNG 模式也可以使用类型来约束 XML 字符数据。RNG 通过 Organization for the Advancement of Structured Information Standards (OASIS) 维护，它既是 OASIS 标准也是 ISO (International Organization for Standardization) 标准。
  • Schematron －－ 基于规则的 XML 模式语言。相对于 DTD、WXS 和 RNG 是用于表示内容模式的结构而言，Schematron 的设计是为了实施难以或不能通过其他模式语言表示的个别规则。Schematron 是为了补充以结构化模式语言（例如 aforementioned）编写的模式。Schematron 正在成为一项 ISO 标准。

以前的 JAXP 版本支持作为 XML 解析器的功能的验证，要么通过 SAXParser 实例，要么通过 DocumentBuilder 实例来表示。

JAXP 验证 API 从 XML 文档解析中分离出实例文档的验证。这具有几种优点，一些原因包括：

  • 支持额外的模式语言。 从 JDK 1.5 开始，两种最流行的 JAXP 解析器实现（Crimson 和 Xerces）仅支持可用的 XML 模式语言的子集。Validation API 提供了标准的机制，应用程序通过此机制可利用支持额外模式语言的规范验证库。
  • 简单的 XML 实例与模式的运行时耦合。 指定要用于通过 JAXP 解析器验证的模式位置可能易于混淆。Validation API 使此过程变得简单（参见以下示例）。

用例。以下示例演示了通过 Validation API 验证 XML 文档（为了方便阅读，此例未显示某些异常处理）：

    // parse an XML document into a DOM tree
    DocumentBuilder parser = DocumentBuilderFactory.newInstance().newDocumentBuilder();
    Document document = parser.parse(new File("instance.xml"));

    // create a SchemaFactory capable of understanding WXS schemas
    SchemaFactory factory = SchemaFactory.newInstance(XMLConstants.W3C_XML_SCHEMA_NS_URI);

    // load a WXS schema, represented by a Schema instance
    Source schemaFile = new StreamSource(new File("mySchema.xsd"));
    Schema schema = factory.newSchema(schemaFile);

    // create a Validator instance, which can be used to validate an instance document
    Validator validator = schema.newValidator();

    // validate the DOM tree
    try {
        validator.validate(new DOMSource(document));
    } catch (SAXException e) {
        // instance document is invalid!
    }

JAXP 解析 API 已经与验证 API 进行了集成。应用程序可以通过验证 API 创建 Schema，并通过使用 DocumentBuilderFactory.setSchema(Schema) 和 SAXParserFactory.setSchema(Schema) 方法将其与 DocumentBuilderFactory 或 SAXParserFactory 实例进行关联。您不能既设置模式，又调用解析器工厂上的 setValidating(true)。前者的技术将导致解析器使用新的验证 API，后者将导致解析器使用它们自己的内部验证工具。同时调整这两个选项将导致冗余行为或错误条件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.validation 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.validation 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.validation.Schema
    • javax.xml.validation.SchemaFactory
    • javax.xml.validation.SchemaFactoryLoader
    • javax.xml.validation.TypeInfoProvider
    • javax.xml.validation.Validator
    • javax.xml.validation.ValidatorHandler (implements org.xml.sax.ContentHandler)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.validation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.validation
的使用

使用 javax.xml.validation 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。

javax.xml.bind 使用的 javax.xml.validation 中的类
Schema
不可变的语法存储表示形式。

javax.xml.bind.helpers 使用的 javax.xml.validation 中的类
Schema
不可变的语法存储表示形式。

javax.xml.parsers 使用的 javax.xml.validation 中的类
Schema
不可变的语法存储表示形式。

javax.xml.validation 使用的 javax.xml.validation 中的类
Schema
不可变的语法存储表示形式。
SchemaFactory
创建 Schema 对象的工厂。
TypeInfoProvider
此类提供了对 ValidatorHandler 所确定的类型信息的访问。
Validator
根据 Schema 检查 XML 文档的处理器。
ValidatorHandler
处理 SAX 流的流验证器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.validation.Schema 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.Schema
的使用

使用 Schema 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。

javax.xml.bind 中 Schema 的使用

返回 Schema 的 javax.xml.bind 中的方法
abstract  Schema Binder.getSchema()
获取 Binder.setSchema(Schema) 方法设置的最后一个 Schema 对象（包括 null）。
 Schema Marshaller.getSchema()
获取用于执行编组时验证的 JAXP 1.3 Schema 对象。
 Schema Unmarshaller.getSchema()
获取用于执行解组时验证的 JAXP 1.3 Schema 对象。

参数类型为 Schema 的 javax.xml.bind 中的方法
abstract void | Binder.setSchema(Schema schema) 指定 marshal、unmarshal 和 update 方法是否在其 XML 内容上执行验证。
void | Marshaller.setSchema(Schema schema) 指定应该用作验证后续编组操作依据的 JAXP 1.3 Schema 对象。
void | Unmarshaller.setSchema(Schema schema) 指定应用作验证后续解组操作依据的 JAXP 1.3 Schema 对象。

javax.xml.bind.helpers 中 Schema 的使用

返回 Schema 的 javax.xml.bind.helpers 中的方法
Schema | AbstractMarshallerImpl.getSchema()
Schema | AbstractUnmarshallerImpl.getSchema()

参数类型为 Schema 的 javax.xml.bind.helpers 中的方法
void | AbstractMarshallerImpl.setSchema(Schema schema)
void | AbstractUnmarshallerImpl.setSchema(Schema schema)

javax.xml.parsers 中 Schema 的使用

返回 Schema 的 javax.xml.parsers 中的方法
 Schema SAXParser.getSchema()
获取对 XML 处理器使用的 Schema 的引用。
 Schema SAXParserFactory.getSchema()
获取通过 SAXParserFactory.setSchema(Schema schema) 方法指定的 Schema 对象。
 Schema DocumentBuilder.getSchema()
获取由 XML 处理器使用的 Schema 的引用。
 Schema DocumentBuilderFactory.getSchema()
获取通过 DocumentBuilderFactory.setSchema(Schema schema) 方法指定的 Schema 对象。

参数类型为 Schema 的 javax.xml.parsers 中的方法
void | SAXParserFactory.setSchema(Schema schema) 设置将由解析器使用的 Schema，该解析器从此工厂创建。
void | DocumentBuilderFactory.setSchema(Schema schema) 设置将由解析器使用的 Schema，该解析器从此工厂创建。

javax.xml.validation 中 Schema 的使用

返回 Schema 的 javax.xml.validation 中的方法
abstract Schema | SchemaFactory.newSchema() 创建特殊的 Schema 对象。
Schema | SchemaFactory.newSchema(File schema) 解析作为模式的指定 File 并以 Schema 的形式返回它。
Schema | SchemaFactory.newSchema(Source schema) 解析作为模式的指定源并以模式形式返回它。
abstract Schema | SchemaFactory.newSchema(Source[] schemas) 解析作为模式的指定源（或多个源），并以模式形式返回它。
Schema | SchemaFactory.newSchema(URL schema) 解析作为模式的指定 URL 并以 Schema 形式返回它。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.validation.SchemaFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.SchemaFactory
的使用

使用 SchemaFactory 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 SchemaFactory 的使用

返回 SchemaFactory 的 javax.xml.validation 中的方法
abstract SchemaFactory | SchemaFactoryLoader.newFactory(String schemaLanguage) 创建指定模式语言的新 SchemaFactory 对象。
static SchemaFactory | SchemaFactory.newInstance(String schemaLanguage) 查找支持指定模式语言的 SchemaFactory 的实现并返回它。
static SchemaFactory | SchemaFactory.newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader) 根据类名称获得一个新 SchemaFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.validation.SchemaFactoryLoader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.SchemaFactoryLoader
的使用

没有 javax.xml.validation.SchemaFactoryLoader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.validation.TypeInfoProvider 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.TypeInfoProvider
的使用

使用 TypeInfoProvider 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 TypeInfoProvider 的使用

返回 TypeInfoProvider 的 javax.xml.validation 中的方法
abstract  TypeInfoProvider ValidatorHandler.getTypeInfoProvider()
获取此 ValidatorHandler 的 TypeInfoProvider 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.validation.Validator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.Validator
的使用

使用 Validator 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 Validator 的使用

返回 Validator 的 javax.xml.validation 中的方法
abstract  Validator Schema.newValidator()
创建此 Schema 的新 Validator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.validation.ValidatorHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.validation.ValidatorHandler
的使用

使用 ValidatorHandler 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 ValidatorHandler 的使用

返回 ValidatorHandler 的 javax.xml.validation 中的方法
abstract  ValidatorHandler Schema.newValidatorHandler()
创建此 Schema 的新 ValidatorHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


NamespaceContext (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.namespace
接口 NamespaceContext

public interface NamespaceContext

用于只读 XML 名称空间上下文处理的接口。

XML 名称空间具有以下属性：

  • 名称空间 URI：表示为 URI（前缀将绑定到该 URI）的名称空间名。
  • 前缀：语法上，这是跟在名称空间声明中的 XMLConstants.XMLNS_ATTRIBUTE ("xmlns") 之后的属性名称的一部分

示例：<element xmlns:prefix="http://Namespace-name-URI">

所有 get*(*) 方法都在名称空间 URI 和前缀解析的当前范围中进行操作。

注意，可以将名称空间 URI 绑定到当前范围中的多个 前缀。当多个 XMLConstants.XMLNS_ATTRIBUTE ("xmlns") 名称空间声明出现在同一 Start 标记中，且引用同一名称空间 URI 时，便发生了这种情况，例如

 <element xmlns:prefix1="http://Namespace-name-URI"
          xmlns:prefix2="http://Namespace-name-URI">
当在逻辑父元素结构层次中的多个 XMLConstants.XMLNS_ATTRIBUTE ("xmlns") 名称空间声明中使用同一名称空间 URI 时，也将发生这种情况。例如
 <parent xmlns:prefix1="http://Namespace-name-URI">
   <child xmlns:prefix2="http://Namespace-name-URI">
     ...
   </child>
 </parent>

只能将前缀绑定到当前范围中的单个 名称空间 URI。

从以下版本开始：
1.5
另请参见：
有关公共 XML 值的声明，请参见 javax.xml.XMLConstants, XML Schema Part2: Datatypes, Namespaces in XML, Namespaces in XML Errata

方法摘要
String | getNamespaceURI(String prefix) 获取绑定到当前范围中的前缀的名称空间 URI。
String | getPrefix(String namespaceURI) 获取绑定到当前范围中名称空间 URI 的前缀。
Iterator | getPrefixes(String namespaceURI) 获取绑定到当前范围中名称空间 URI 的所有前缀。

方法详细信息

getNamespaceURI

String getNamespaceURI(String prefix)

获取绑定到当前范围中的前缀的名称空间 URI。

当通过前缀请求名称空间 URI 时，下表描述了针对所有可能的前缀值返回的名称空间 URI 值：

getNamespaceURI(prefix) 返回指定的前缀值
前缀参数 | 名称空间 URI 返回值
DEFAULT_NS_PREFIX ("") | 返回当前范围中的默认名称空间 URI；如果不存在，则返回 XMLConstants.NULL_NS_URI("")
绑定的前缀 | 绑定到当前范围中的前缀的名称空间 URI
未绑定的前缀 | XMLConstants.NULL_NS_URI("")
XMLConstants.XML_NS_PREFIX ("xml") | XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace")
XMLConstants.XMLNS_ATTRIBUTE ("xmlns") | XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/")
null | IllegalArgumentException 被抛出

参数：
prefix - 要查找的前缀
返回：
绑定到当前范围中的前缀的名称空间 URI
抛出：
IllegalArgumentException - 当 prefix 为 null 时

getPrefix

String getPrefix(String namespaceURI)

获取绑定到当前范围中名称空间 URI 的前缀。

要获取绑定到当前范围中名称空间 URI 的所有前缀，请使用 getPrefixes(String namespaceURI)。

当通过名称空间 URI 请求前缀时，下表描述了针对所有名称空间 URI 值返回的前缀值：

对指定的名称空间 URI 调用 getPrefix(namespaceURI) 的返回值
名称空间 URI 参数 | 返回的前缀值
<默认名称空间 URI> | XMLConstants.DEFAULT_NS_PREFIX ("")
绑定名称空间 URI | 绑定到当前范围中名称空间 URI 的前缀，如果将多个前缀绑定到当前范围中的名称空间 URI，则返回其选择与实现有关的任意单个前缀
未绑定的名称空间 URI | null
XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace") | XMLConstants.XML_NS_PREFIX ("xml")
XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/") | XMLConstants.XMLNS_ATTRIBUTE ("xmlns")
null | IllegalArgumentException 被抛出

参数：
namespaceURI - 要查找的名称空间的 URI
返回：
绑定到当前上下文中名称空间 URI 的前缀
抛出：
IllegalArgumentException - 当 namespaceURI 为 null 时

getPrefixes

Iterator getPrefixes(String namespaceURI)

获取绑定到当前范围中名称空间 URI 的所有前缀。

按任意与实现相关顺序返回 String 元素上的迭代器。

Iterator 不 可修改。例如 remove() 方法将抛出 UnsupportedOperationException。

当通过名称空间 URI 请求前缀时，下表描述了针对所有名称空间 URI 值返回的前缀值：

对指定的名称空间 URI 调用 getPrefixes(namespaceURI) 的返回值
名称空间 URI 参数 | 返回的前缀值
绑定的名称空间 URI，包括 <默认名称空间 URI> | 前缀上的 Iterator，以任意与实现相关顺序绑定到当前范围中的名称空间 URI
未绑定的名称空间 URI | 空 Iterator
XMLConstants.XML_NS_URI ("http://www.w3.org/XML/1998/namespace") | 一个元素设置为 XMLConstants.XML_NS_PREFIX ("xml") 的 Iterator
XMLConstants.XMLNS_ATTRIBUTE_NS_URI ("http://www.w3.org/2000/xmlns/") | 一个元素设置为 XMLConstants.XMLNS_ATTRIBUTE ("xmlns") 的 Iterator
null | IllegalArgumentException 被抛出

参数：
namespaceURI - 要查找的名称空间的 URI
返回：
用于绑定到当前范围中名称空间 URI 的所有前缀的 Iterator
抛出：
IllegalArgumentException - 当 namespaceURI 为 null 时
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


QName (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.namespace
类 QName

java.lang.Object
    继承者  javax.xml.namespace.QName
所有已实现的接口：
Serializable
public class QName
extends Object
implements Serializable

QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

QName 的值包含名称空间 URI、本地部分和前缀。

QName 中包括前缀，以保留词汇信息（当在 XML 输入源中存在 时）。前缀不 用于 QName.equals(Object) 或计算 QName.hashCode()。仅 使用名称空间 URI 和本地部分定义相等性和哈希码。

如果没有指定名称空间 URI，则将其设置为 XMLConstants.NULL_NS_URI。如果没有指定前缀，则将其设置为 XMLConstants.DEFAULT_NS_PREFIX。

QName 是不可变的。

从以下版本开始：
1.5
另请参见：
XML 模式第二部分：Datatypes specification, Namespaces in XML, Namespaces in XML 勘误表, 序列化表格

构造方法摘要
QName(String localPart)
指定本地部分的 QName 构造方法。
QName(String namespaceURI, String localPart)
指定名称空间 URI 和本地部分的 QName 构造方法。
QName(String namespaceURI, String localPart, String prefix)
指定名称空间 URI、本地部分和前缀的 QName 构造方法。
方法摘要
boolean | equals(Object objectToTest) 测试此 QName 与另一个 Object 的相等性。
String | getLocalPart() 获取此 QName 的本地部分。
String | getNamespaceURI() 获取此 QName 的名称空间 URI。
String | getPrefix() 获取此 QName 的前缀。
int | hashCode() 生成此 QName 的哈希码。
String | toString() 此 QName 的 String 表示形式。
static QName | valueOf(String qNameAsString) 从解析格式化 String 中派生的 QName。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

QName

public QName(String namespaceURI,
             String localPart)

指定名称空间 URI 和本地部分的 QName 构造方法。

如果名称空间 URI 为 null，则将它设置为 XMLConstants.NULL_NS_URI。此值表示非显式定义的名称空间，在 Namespaces in XML 规范中定义。此操作保持了与 QName 1.0 兼容的行为。显式提供 XMLConstants.NULL_NS_URI 值是首选的编码风格。

如果本地部分为 null，则抛出 IllegalArgumentException。允许 "" 的本地部分保持与 QName 1.0 的兼容行为。

当使用此构造方法时，将前缀设置为 XMLConstants.DEFAULT_NS_PREFIX。

名称空间 URI 不根据 URI 参考验证。没有按 Namespaces in XML 中的指定将本地部分作为 NCName 来验证。

参数：
namespaceURI - QName 的名称空间 URI
localPart - QName 的本地部分
抛出：
IllegalArgumentException - 当 localPart 为 null 时
另请参见：
QName(String namespaceURI, String localPart, String prefix)

QName

public QName(String namespaceURI,
             String localPart,
             String prefix)

指定名称空间 URI、本地部分和前缀的 QName 构造方法。

如果名称空间 URI 为 null，则将它设置为 XMLConstants.NULL_NS_URI。此值表示非显式定义的名称空间，在 Namespaces in XML 规范中定义。此操作保持了与 QName 1.0 兼容的行为。显式提供 XMLConstants.NULL_NS_URI 值是首选的编码风格。

如果本地部分为 null，则抛出 IllegalArgumentException。允许 "" 的本地部分保持与 QName 1.0 的兼容行为。

如果前缀为 null，则抛出 IllegalArgumentException。使用 XMLConstants.DEFAULT_NS_PREFIX 显式指示不存在任何前缀或前缀是不相关的。

名称空间 URI 不根据 URI 参考验证。没有按 Namespaces in XML 中的指定将本地部分和前缀作为 NCName 来验证。

参数：
namespaceURI - QName 的名称空间 URI
localPart - QName 的本地部分
prefix - QName 的前缀
抛出：
IllegalArgumentException - 当 localPart 或 prefix 为 null 时

QName

public QName(String localPart)

指定本地部分的 QName 构造方法。

如果本地部分为 null，则抛出 IllegalArgumentException。允许 "" 的本地部分保持与 QName 1.0 的兼容行为。

使用此构造方法时，将名称空间 URI 设置为 XMLConstants.NULL_NS_URI，并将前缀设置为 XMLConstants.DEFAULT_NS_PREFIX。

在 XML 上下文中，所有元素和属性名称都存在于名称空间的上下文中。在构造 QName 的过程中，使其显式存在有助于避免诊断 XML 有效性错误的难度。优先使用构造方法 QName(String namespaceURI, String localPart) 和 QName(String namespaceURI, String localPart, String prefix)。

没有按 Namespaces in XML 中的指定将本地部分作为 NCName 来验证。

参数：
localPart - QName 的本地部分
抛出：
IllegalArgumentException - 当 localPart 为 null 时
另请参见：
QName(String namespaceURI, String localPart), QName(String namespaceURI, String localPart, String prefix)
方法详细信息

getNamespaceURI

public String getNamespaceURI()

获取此 QName 的名称空间 URI。

返回：
此 QName 的名称空间 URI

getLocalPart

public String getLocalPart()

获取此 QName 的本地部分。

返回：
此 QName 的本地部分

getPrefix

public String getPrefix()

获取此 QName 的前缀。

分配给 QName 的前缀在其他上下文中可能无 效。例如，可以在解析文档的上下文中为 QName 分配一个前缀，但是，该前缀可能在其他文档的上下文中无效。

返回：
此 QName 的前缀

equals

public final boolean equals(Object objectToTest)

测试此 QName 与另一个 Object 的相等性。

如果要测试的 Object 不是 QName，或为 null，那么此方法返回 false。

当且仅当名称空间 URI 和本地部分相等时，才认为两个 QName 相等。此方法使用 String.equals() 检查名称空间 URI 和本地部分的相等性。前缀不能 用于确定相等性。

此方法满足 Object.equals(Object) 的常规协定。

覆盖：
类 Object 中的 equals
参数：
objectToTest - 要测试与此 QName 相等性的 Object
返回：
如果给定的 Object 等于此 QName，则返回 true，否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()

生成此 QName 的哈希码。

使用 QName 的名称空间 URI 和本地部分计算哈希码。前缀不能 用于计算哈希码。

此方法满足 Object.hashCode() 的常规协定。

覆盖：
类 Object 中的 hashCode
返回：
此 QName Object 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()

此 QName 的 String 表示形式。

James Clark 定义了将 QName 表示为 String 的公认方法。虽然这不是标准 规范，但其使用很频繁，例如 Transformer.setParameter(String name, Object value)。此实现将 QName 表示为："{" + Namespace URI + "}" + 本地部分。如果名称空间 URI .equals(XMLConstants.NULL_NS_URI)，则仅返回本地部分。此方法适用于调试或记录人为消耗。

注：前缀值不能 作为 String 表示形式的一部分返回。

此方法满足 Object.toString() 的常规协定。

覆盖：
类 Object 中的 toString
返回：
此 QName 的 String 表示形式

valueOf

public static QName valueOf(String qNameAsString)

从解析格式化 String 中派生的 QName。

如果 String 为 null，或者不符合 QName.toString() 格式，则抛出 IllegalArgumentException。

String 必须 是 QName.toString() 返回的格式。

James Clark 定义了将 QName 表示为 String 的公认方法。虽然这不是标准 规范，但其使用很频繁，例如 Transformer.setParameter(String name, Object value)。此实现将 String 解析为以下格式："{" + Namespace URI + "}" + 本地部分。如果名称空间 URI .equals(XMLConstants.NULL_NS_URI)，则仅提供本地部分。

不能 用 String 表示前缀值，并将它设置为 XMLConstants.DEFAULT_NS_PREFIX。

此方法不能完全验证生成的 QName。

名称空间 URI 不根据 URI 参考验证。没有按 Namespaces in XML 中的指定将本地部分作为 NCName 来验证。

参数：
qNameAsString - QName 的 String 表示形式
返回：
与给定 String 对应的 QName
抛出：
IllegalArgumentException - 当 qNameAsString 为 null 或出错时
另请参见：
QName.toString()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.namespace (Java Platform SE 6)

 javax.xml.namespace
接口
NamespaceContext
类
QName


javax.xml.namespace (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.namespace

XML 名称空间处理。

请参见：
描述

接口摘要
NamespaceContext 用于只读 XML 名称空间上下文处理的接口。

类摘要
QName QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

软件包 javax.xml.namespace 的描述

XML 名称空间处理。

应用以下 XML 标准：

  • XML 模式第二部分：Datatypes specification
  • Namespaces in XML
  • Namespaces in XML 勘误表

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.namespace 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.namespace 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.namespace.QName (implements java.io.Serializable)

接口分层结构

  • javax.xml.namespace.NamespaceContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.namespace 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.namespace
的使用

使用 javax.xml.namespace 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.bind 使用的 javax.xml.namespace 中的类
NamespaceContext
用于只读 XML 名称空间上下文处理的接口。
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.datatype 使用的 javax.xml.namespace 中的类
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.namespace 使用的 javax.xml.namespace 中的类
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.soap 使用的 javax.xml.namespace 中的类
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.stream 使用的 javax.xml.namespace 中的类
NamespaceContext
用于只读 XML 名称空间上下文处理的接口。
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.stream.events 使用的 javax.xml.namespace 中的类
NamespaceContext
用于只读 XML 名称空间上下文处理的接口。
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.stream.util 使用的 javax.xml.namespace 中的类
NamespaceContext
用于只读 XML 名称空间上下文处理的接口。
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.ws 使用的 javax.xml.namespace 中的类
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.ws.handler 使用的 javax.xml.namespace 中的类
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.ws.handler.soap 使用的 javax.xml.namespace 中的类
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.ws.spi 使用的 javax.xml.namespace 中的类
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.xpath 使用的 javax.xml.namespace 中的类
NamespaceContext
用于只读 XML 名称空间上下文处理的接口。
QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.namespace.NamespaceContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.namespace.NamespaceContext
的使用

使用 NamespaceContext 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.bind 中 NamespaceContext 的使用

参数类型为 NamespaceContext 的 javax.xml.bind 中的方法
static QName | DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 byte 值。
QName | DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 QName 值。
static String | DatatypeConverter.printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。
String | DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。

javax.xml.stream 中 NamespaceContext 的使用

返回 NamespaceContext 的 javax.xml.stream 中的方法
NamespaceContext | XMLEventWriter.getNamespaceContext() 返回当前名称空间上下文。
NamespaceContext | XMLStreamReader.getNamespaceContext() 返回当前位置的只读名称空间上下文。
NamespaceContext | XMLStreamWriter.getNamespaceContext() 返回当前名称空间上下文。

参数类型为 NamespaceContext 的 javax.xml.stream 中的方法
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。
void | XMLEventWriter.setNamespaceContext(NamespaceContext context) 设置前缀的当前名称空间上下文和 URI 绑定。
void | XMLStreamWriter.setNamespaceContext(NamespaceContext context) 设置前缀和 URI 绑定的当前名称空间上下文。

javax.xml.stream.events 中 NamespaceContext 的使用

返回 NamespaceContext 的 javax.xml.stream.events 中的方法
 NamespaceContext StartElement.getNamespaceContext()
获取只读名称空间上下文。

javax.xml.stream.util 中 NamespaceContext 的使用

返回 NamespaceContext 的 javax.xml.stream.util 中的方法
 NamespaceContext StreamReaderDelegate.getNamespaceContext()

javax.xml.xpath 中 NamespaceContext 的使用

返回 NamespaceContext 的 javax.xml.xpath 中的方法
 NamespaceContext XPath.getNamespaceContext()
返回当前的名称空间上下文。

参数类型为 NamespaceContext 的 javax.xml.xpath 中的方法
 void XPath.setNamespaceContext(NamespaceContext nsContext)
建立名称空间上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.namespace.QName 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.namespace.QName
的使用

使用 QName 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.bind 中 QName 的使用

声明为 QName 的 javax.xml.bind 中的字段
protected  QName JAXBElement.name
xml 元素标记名称。

返回 QName 的 javax.xml.bind 中的方法
abstract QName | JAXBIntrospector.getElementName(Object jaxbElement) 获取 jaxbElement 的 xml 元素 qname。
QName | JAXBElement.getName() 返回 xml 元素标记名称。
static QName | DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 byte 值。
QName | DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc) 将字符串参数转换为一个 QName 值。

参数类型为 QName 的 javax.xml.bind 中的方法
static String | DatatypeConverter.printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。
String | DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc) 将 QName 实例转换为一个字符串。

参数类型为 QName 的 javax.xml.bind 中的构造方法
JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
构造一个 xml 元素实例。
JAXBElement(QName name, Class<T> declaredType, T value)
构造一个 xml 元素实例。

javax.xml.datatype 中 QName 的使用

声明为 QName 的 javax.xml.datatype 中的字段
static QName | DatatypeConstants.DATE W3C XML 模式 1.0 数据类型 date 的完全限定名称。
static QName | DatatypeConstants.DATETIME W3C XML 模式 1.0 数据类型 dateTime 的完全限定名称。
static QName | DatatypeConstants.DURATION W3C XML 模式数据类型 duration 的完全限定名称。
static QName | DatatypeConstants.DURATION_DAYTIME XQuery 1.0 和 Path 2.0 数据类型 dayTimeDuration 的完全限定名称。
static QName | DatatypeConstants.DURATION_YEARMONTH XQuery 1.0 和 XPath 2.0 数据类型 yearMonthDuration 的完全限定名称。
static QName | DatatypeConstants.GDAY W3C XML 模式 1.0 数据类型 gDay 的完全限定名称。
static QName | DatatypeConstants.GMONTH W3C XML 模式 1.0 数据类型 gMonth 的完全限定名称。
static QName | DatatypeConstants.GMONTHDAY W3C XML 模式 1.0 数据类型 gMonthDay 的完全限定名称。
static QName | DatatypeConstants.GYEAR W3C XML 模式 1.0 数据类型 gYear 的完全限定名称。
static QName | DatatypeConstants.GYEARMONTH W3C XML 模式 1.0 数据类型 gYearMonth 的完全限定名称。
static QName | DatatypeConstants.TIME W3C XML 模式 1.0 数据类型 time 的完全限定名称。

返回 QName 的 javax.xml.datatype 中的方法
QName | Duration.getXMLSchemaType() 返回此实例映射到的 XML 模式日期/时间类型的名称。
abstract QName | XMLGregorianCalendar.getXMLSchemaType() 返回此实例映射到的 XML 模式日期/时间类型的名称。

javax.xml.namespace 中 QName 的使用

返回 QName 的 javax.xml.namespace 中的方法
static QName QName.valueOf(String qNameAsString)
从解析格式化 String 中派生的 QName。

javax.xml.soap 中 QName 的使用

声明为 QName 的 javax.xml.soap 中的字段
static QName | SOAPConstants.SOAP_DATAENCODINGUNKNOWN_FAULT SOAP 1.2 DataEncodingUnknown 错误。
static QName | SOAPConstants.SOAP_MUSTUNDERSTAND_FAULT SOAP 1.2 MustUnderstand 错误。
static QName | SOAPConstants.SOAP_RECEIVER_FAULT SOAP 1.2 Receiver 错误。
static QName | SOAPConstants.SOAP_SENDER_FAULT SOAP 1.2 Sender 错误。
static QName | SOAPConstants.SOAP_VERSIONMISMATCH_FAULT SOAP 1.2 VersionMismatch 错误。

返回 QName 的 javax.xml.soap 中的方法
QName | SOAPElement.createQName(String localName, String prefix) 创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。
QName | SOAPElement.getElementQName() 返回此 SOAPElement 对象的 qname。
QName | SOAPFault.getFaultCodeAsQName() 以 QName 对象形式获取此 SOAPFault 对象的错误代码。

参数类型为 QName 的 javax.xml.soap 中的方法
SOAPElement | SOAPElement.addAttribute(QName qname, String value) 将带有指定名称和值的属性添加到此 SOAPElement 对象。
SOAPBodyElement | SOAPBody.addBodyElement(QName qname) 使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
SOAPElement | SOAPElement.addChildElement(QName qname) 创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
DetailEntry | Detail.addDetailEntry(QName qname) 使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPHeaderElement | SOAPHeader.addHeaderElement(QName qname) 创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
SOAPHeaderElement | SOAPHeader.addNotUnderstoodHeaderElement(QName name) 创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
void | SOAPFault.appendFaultSubcode(QName subcode) 将 Subcode 添加到此 SOAPFault 包含的 Subcode 序列的末尾。
SOAPElement | SOAPFactory.createElement(QName qname) 创建使用给定 QName 对象初始化的 SOAPElement 对象。
abstract SOAPFault | SOAPFactory.createFault(String reasonText, QName faultCode) 创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
String | SOAPElement.getAttributeValue(QName qname) 返回带有指定 qname 的属性值。
Iterator | SOAPElement.getChildElements(QName qname) 返回可在带有指定 qname 的此元素所有直接子 Node 上进行迭代的 Iterator。
boolean | SOAPElement.removeAttribute(QName qname) 移除带有指定 qname 的属性。
SOAPElement | SOAPElement.setElementQName(QName newName) 如果可能，将此 Element 的名称更改为 newName。
void | SOAPFault.setFaultCode(QName faultCodeQName) 使用给定的错误代码设置此 SOAPFault 对象。

javax.xml.stream 中 QName 的使用

返回 QName 的 javax.xml.stream 中的方法
QName | XMLStreamReader.getAttributeName(int index) 返回所提供索引处的属性的 qname
QName | XMLStreamReader.getName() 返回当前 START_ELEMENT 或 END_ELEMENT 事件的 QName

参数类型为 QName 的 javax.xml.stream 中的方法
abstract Attribute | XMLEventFactory.createAttribute(QName name, String value) 创建一个新 Attribute。
abstract EndElement | XMLEventFactory.createEndElement(QName name, Iterator namespaces) 创建一个新 EndElement。
abstract StartElement | XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。

javax.xml.stream.events 中 QName 的使用

返回 QName 的 javax.xml.stream.events 中的方法
QName | Attribute.getName() 返回此属性的 QName。
QName | EndElement.getName() 获取此事件的名称
QName | StartElement.getName() 获取此事件的名称
QName | XMLEvent.getSchemaType() 提供此方法是为了提供有关关联事件的可选类型信息。

参数类型为 QName 的 javax.xml.stream.events 中的方法
 Attribute StartElement.getAttributeByName(QName name)
返回此名称引用的属性

javax.xml.stream.util 中 QName 的使用

返回 QName 的 javax.xml.stream.util 中的方法
QName | StreamReaderDelegate.getAttributeName(int index)
QName | StreamReaderDelegate.getName()

javax.xml.ws 中 QName 的使用

返回 QName 的 javax.xml.ws 中的方法
 QName Service.getServiceName()
获取此服务的名称。

返回变量类型为 QName 的类型的 javax.xml.ws 中的方法
 Iterator<QName> Service.getPorts()
返回一个 Iterator，它用于此服务所组合的服务端点的 QName 列表。

参数类型为 QName 的 javax.xml.ws 中的方法
 void Service.addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。
static Service Service.create(QName serviceName)
创建 Service 实例。
static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
创建 Service 实例。
<T> Dispatch<T>
Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
 Dispatch<Object> Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。
<T> T
Service.getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回 stub。

参数类型为 QName 的 javax.xml.ws 中的构造方法
Service(URL wsdlDocumentLocation, QName serviceName)

javax.xml.ws.handler 中 QName 的使用

返回 QName 的 javax.xml.ws.handler 中的方法
QName | PortInfo.getPortName() 获取正被访问的 WSDL 端口的限定名。
QName | PortInfo.getServiceName() 获取包含正被访问端口的 WSDL 服务名称的限定名。

javax.xml.ws.handler.soap 中 QName 的使用

返回变量类型为 QName 的类型的 javax.xml.ws.handler.soap 中的方法
 Set<QName> SOAPHandler.getHeaders()
获取可以由此处理程序实例处理的头块。

参数类型为 QName 的 javax.xml.ws.handler.soap 中的方法
 Object[] SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
从消息上下文的消息中获得具有特定限定名的头。

javax.xml.ws.spi 中 QName 的使用

返回 QName 的 javax.xml.ws.spi 中的方法
abstract  QName ServiceDelegate.getServiceName()
获取此服务的名称。

返回变量类型为 QName 的类型的 javax.xml.ws.spi 中的方法
abstract  Iterator<QName> ServiceDelegate.getPorts()
返回一个 Iterator，该迭代器用于根据此服务分组的服务端点的 QName 列表。

参数类型为 QName 的 javax.xml.ws.spi 中的方法
abstract  void ServiceDelegate.addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。
abstract
<T> Dispatch<T>
ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  Dispatch<Object> ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。
abstract  ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass)
创建一个服务委托对象。
abstract
<T> T
ServiceDelegate.getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块 (stub)。

javax.xml.xpath 中 QName 的使用

声明为 QName 的 javax.xml.xpath 中的字段
static QName | XPathConstants.BOOLEAN XPath 1.0 布尔值数据类型。
static QName | XPathConstants.NODE XPath 1.0 NodeSet 数据类型。
static QName | XPathConstants.NODESET XPath 1.0 NodeSet 数据类型。
static QName | XPathConstants.NUMBER XPath 1.0 数字数据类型。
static QName | XPathConstants.STRING XPath 1.0 字符串数据类型。

参数类型为 QName 的 javax.xml.xpath 中的方法
Object | XPathExpression.evaluate(InputSource source, QName returnType) 计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
Object | XPathExpression.evaluate(Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。
Object | XPath.evaluate(String expression, InputSource source, QName returnType) 计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。
Object | XPath.evaluate(String expression, Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。
XPathFunction | XPathFunctionResolver.resolveFunction(QName functionName, int arity) 在可用的函数集中查找函数。
Object | XPathVariableResolver.resolveVariable(QName variableName) 在可用的变量集中查找变量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


XPath (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
接口 XPath

public interface XPath

XPath 提供了对 XPath 计算环境和表达式的访问。

XPath 表达式的计算。
上下文 | 如果在没有上下文项的情况下请求计算表达式，则将使用一个空文档节点作为上下文。为计算 XPath 表达式，应将 DocumentFragment 视为 Document 节点。
变量 | 如果表达式包含变量引用，则其值将通过 XPathVariableResolver 找到，其中 XPathVariableResolver 是通过 setXPathVariableResolver(XPathVariableResolver resolver) 设置的。如果变量解析器未定义或解析器对变量返回 null，则引发 XPathExpressionException。在任何单个计算过程中，变量的值必须是不可变的。
函数 | 如果表达式包含函数引用，则函数将通过 XPathFunctionResolver 找到，其中 XPathFunctionResolver 是通过 setXPathFunctionResolver(XPathFunctionResolver resolver) 设置的。如果函数解析器未定义或解析器为函数返回 null，则引发 XPathExpressionException。
QNames | 表达式中的 QNames 根据通过 setNamespaceContext(NamespaceContext nsContext) 设置的 XPath 名称空间上下文来解析。
结果 | 将计算表达式的结果转换为所需的返回类型的实例。XPathConstants 中定义了有效的返回类型。到返回类型的转换遵守 XPath 转换规则。

XPath 对象不是线程安全的，也不能重入。换句话说，应用程序负责确保在任意给定时刻不能有多个线程使用一个 XPath 对象，且当调用 evaluate 方法时，应用程序不能以递归方式调用 evaluate 方法。

从以下版本开始：
1.5
另请参见：
XML Path Language (XPath) Version 1.0

方法摘要
XPathExpression | compile(String expression) 编译 XPath 表达式供以后计算使用。
String | evaluate(String expression, InputSource source) 计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。
Object | evaluate(String expression, InputSource source, QName returnType) 计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。
String | evaluate(String expression, Object item) 计算指定上下文中的 XPath 表达式并返回 String 形式的结果。
Object | evaluate(String expression, Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。
NamespaceContext | getNamespaceContext() 返回当前的名称空间上下文。
XPathFunctionResolver | getXPathFunctionResolver() 返回当前的函数解析器。
XPathVariableResolver | getXPathVariableResolver() 返回当前的变量解析器。
void | reset() 将此 XPath 重置为其初始配置。
void | setNamespaceContext(NamespaceContext nsContext) 建立名称空间上下文。
void | setXPathFunctionResolver(XPathFunctionResolver resolver) 建立函数解析器。
void | setXPathVariableResolver(XPathVariableResolver resolver) 建立变量解析器。

方法详细信息

reset

void reset()

将此 XPath 重置为其初始配置。

XPath 被重置为通过 XPathFactory.newXPath() 创建它时的状态。设计 reset() 旨在允许重用现有的 XPath，从而节省与创建新 XPath 相关的资源。

不保证重置的 XPath 具有相同的 XPathFunctionResolver、XPathVariableResolver 或 NamespaceContext Object，例如 Object.equals(Object obj)。但保证具有功能相同的 XPathFunctionResolver、XPathVariableResolver 和 NamespaceContext。

setXPathVariableResolver

void setXPathVariableResolver(XPathVariableResolver resolver)

建立变量解析器。

如果 resolver 为 null，则抛出 NullPointerException。

参数：
resolver - 变量解析器。
抛出：
NullPointerException - 如果 resolver 为 null。

getXPathVariableResolver

XPathVariableResolver getXPathVariableResolver()

返回当前的变量解析器。

如果不存在有效的变量解析器，则返回 null。

返回：
当前的变量解析器。

setXPathFunctionResolver

void setXPathFunctionResolver(XPathFunctionResolver resolver)

建立函数解析器。

如果 resolver 为 null，则抛出 NullPointerException。

参数：
resolver - XPath 函数解析器。
抛出：
NullPointerException - 如果 resolver 为 null。

getXPathFunctionResolver

XPathFunctionResolver getXPathFunctionResolver()

返回当前的函数解析器。

如果不存在有效的变量解析器，则返回 null。

返回：
当前的函数解析器。

setNamespaceContext

void setNamespaceContext(NamespaceContext nsContext)

建立名称空间上下文。

如果 nsContext 为 null，则抛出 NullPointerException。

参数：
nsContext - 要使用的名称空间上下文。
抛出：
NullPointerException - 如果 nsContext 为 null。

getNamespaceContext

NamespaceContext getNamespaceContext()

返回当前的名称空间上下文。

如果不存在有效的名称空间上下文，则返回 null。

返回：
当前的 Namespace 上下文。

compile

XPathExpression compile(String expression)
                        throws XPathExpressionException

编译 XPath 表达式供以后计算使用。

如果 expression 包含任何 XPathFunction，则它们必须可以通过 XPathFunctionResolver 获取。如果不能通过 XPathFunctionResolver 解析 XPathFunction，则将抛出 XPathExpressionException。

如果 expression 包含任何变量，则将使用在编译时有效的 XPathVariableResolver 来解析这些变量。

如果 expression 为 null，则抛出 NullPointerException。

参数：
expression - XPath 表达式。
返回：
编译后的 XPath 表达式。
抛出：
XPathExpressionException - 如果不能编译 expression。
NullPointerException - 如果 expression 为 null。

evaluate

Object evaluate(String expression,
                Object item,
                QName returnType)
                throws XPathExpressionException

计算指定上下文中的 XPath 表达式并返回指定类型的结果。

有关上下文项计算、变量、函数和 QName 解析，以及返回类型转换，请参阅 Evaluation of XPath Expressions。

如果 returnType 不是 XPathConstants (NUMBER、STRING、BOOLEAN、NODE 或 NODESET) 中定义的某种类型，则抛出 IllegalArgumentException。

如果 item 为 null 值，则将使用一个空文档作为上下文。如果 expression 或 returnType 为 null，则抛出 NullPointerException。

参数：
expression - XPath 表达式。
item - 开始上下文（例如节点）。
returnType - 所需的返回类型。
返回：
以 returnType 的 Object 形式返回 XPath 表达式的计算结果。
抛出：
XPathExpressionException - 如果不能计算 expression。
IllegalArgumentException - 如果 returnType 不是 XPathConstants 中定义的类型之一。
NullPointerException - 如果 expression 或 returnType 为 null。

evaluate

String evaluate(String expression,
                Object item)
                throws XPathExpressionException

计算指定上下文中的 XPath 表达式并返回 String 形式的结果。

此方法通过 XPathConstants.STRING 的 returnType 调用 evaluate(String expression, Object item, QName returnType)。

有关上下文项计算、变量、函数和 QName 解析，以及返回类型转换，请参阅 Evaluation of XPath Expressions。

如果为 item 为 null 值，则将使用一个空文档作为上下文。如果 expression 为 null，则抛出 NullPointerException。

参数：
expression - XPath 表达式。
item - 开始上下文（例如节点）。
返回：
计算表达式并将计算结果转换为 String 所得到的结果 String。
抛出：
XPathExpressionException - 如果不能计算 expression。
NullPointerException - 如果 expression 为 null。

evaluate

Object evaluate(String expression,
                InputSource source,
                QName returnType)
                throws XPathExpressionException

计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。

此方法构建 InputSource 的数据模型并调用得到的文档对象上的 evaluate(String expression, Object item, QName returnType)。

有关上下文项计算、变量、函数和 QName 解析，以及返回类型转换，请参阅 Evaluation of XPath Expressions。

如果 returnType 不是 XPathConstants 中定义的类型之一，则抛出 IllegalArgumentException。

如果 expression、source 或 returnType 为 null，则抛出 NullPointerException。

参数：
expression - XPath 表达式。
source - 要对其计算的文档的输入源。
returnType - 所需的返回类型。
返回：
封装了表达式计算结果的 Object。
抛出：
XPathExpressionException - 如果不能计算表达式。
IllegalArgumentException - 如果 returnType 不是 XPathConstants 中定义的类型之一。
NullPointerException - 如果 expression、source 或 returnType 为 null。

evaluate

String evaluate(String expression,
                InputSource source)
                throws XPathExpressionException

计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。

此方法通过 XPathConstants.STRING 的 returnType 调用 evaluate(String expression, InputSource source, QName returnType)。

有关上下文项计算、变量、函数和 QName 解析，以及返回类型转换，请参阅 Evaluation of XPath Expressions。

如果 expression 或 source 为 null，则抛出 NullPointerException。

参数：
expression - XPath 表达式。
source - 要对其计算的文档的 InputSource。
返回：
计算表达式并将计算结果转换为 String 所得到的结果 String。
抛出：
XPathExpressionException - 如果不能计算表达式。
NullPointerException - 如果 expression 或 source 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


XPathConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
类 XPathConstants

java.lang.Object
    继承者  javax.xml.xpath.XPathConstants

public class XPathConstants
extends Object

XPath 常量。

从以下版本开始：
1.5
另请参见：
XML Path Language (XPath) Version 1.0

字段摘要
static QName | BOOLEAN XPath 1.0 布尔值数据类型。
static String | DOM_OBJECT_MODEL DOM 对象模型的 URI，"http://java.sun.com/jaxp/xpath/dom"。
static QName | NODE XPath 1.0 NodeSet 数据类型。
static QName | NODESET XPath 1.0 NodeSet 数据类型。
static QName | NUMBER XPath 1.0 数字数据类型。
static QName | STRING XPath 1.0 字符串数据类型。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NUMBER

public static final QName NUMBER

XPath 1.0 数字数据类型。

映射到 Java Double。

STRING

public static final QName STRING

XPath 1.0 字符串数据类型。

映射到 String。

BOOLEAN

public static final QName BOOLEAN

XPath 1.0 布尔值数据类型。

映射到 Java Boolean。

NODESET

public static final QName NODESET

XPath 1.0 NodeSet 数据类型。

映射到 Java NodeList。

NODE

public static final QName NODE

XPath 1.0 NodeSet 数据类型。

映射到 Java Node。

DOM_OBJECT_MODEL

public static final String DOM_OBJECT_MODEL

DOM 对象模型的 URI，"http://java.sun.com/jaxp/xpath/dom"。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
类 XPathException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.xpath.XPathException
所有已实现的接口：
Serializable
直接已知子类：
XPathExpressionException, XPathFactoryConfigurationException
public class XPathException
extends Exception

XPathException 表示通用 XPath 异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
XPathException(String message)
构造带指定详细 message 的新 XPathException。
XPathException(Throwable cause)
构造带指定 cause 的新 XPathException。
方法摘要
Throwable | getCause() 获取此 XPathException 的 cause。
void | printStackTrace() 将堆栈跟踪打印到 System.err。
void | printStackTrace(PrintStream s) 将堆栈跟踪打印到指定的 PrintStream。
void | printStackTrace(PrintWriter s) 将堆栈跟踪打印到指定的 PrintWriter。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XPathException

public XPathException(String message)

构造带指定详细 message 的新 XPathException。

cause 未初始化。

如果 message 为 null，则抛出 NullPointerException。

参数：
message - 详细消息。
抛出：
NullPointerException - 当 message 为 null 时。

XPathException

public XPathException(Throwable cause)

构造带指定 cause 的新 XPathException。

如果 cause 为 null，则抛出 NullPointerException。

参数：
cause - cause
抛出：
NullPointerException - 如果 cause 为 null。
方法详细信息

getCause

public Throwable getCause()

获取此 XPathException 的 cause。

覆盖：
类 Throwable 中的 getCause
返回：
此 XPathException 的 cause。

printStackTrace

public void printStackTrace(PrintStream s)

将堆栈跟踪打印到指定的 PrintStream。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 将堆栈跟踪打印到此 PrintStream。

printStackTrace

public void printStackTrace()

将堆栈跟踪打印到 System.err。

覆盖：
类 Throwable 中的 printStackTrace

printStackTrace

public void printStackTrace(PrintWriter s)

将堆栈跟踪打印到指定的 PrintWriter。

覆盖：
类 Throwable 中的 printStackTrace
参数：
s - 将堆栈跟踪打印到此 PrintWriter。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathExpression (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
接口 XPathExpression

public interface XPathExpression

XPathExpression 提供了对编译后的 XPath 表达式的访问。

XPath 表达式的计算。
上下文 | 如果在没有上下文项的情况下请求计算表达式，则将使用一个空文档节点作为上下文。为计算 XPath 表达式，应将 DocumentFragment 视为 Document 节点。
变量 | 如果表达式包含变量引用，则其值将通过 XPathVariableResolver 找到。如果变量解析器未定义或解析器对变量返回 null，则引发 XPathExpressionException。在任何单个计算过程中，变量的值必须是不可变的。
函数 | 如果表达式包含函数引用，则函数将通过 XPathFunctionResolver 找到。如果函数解析器未定义或解析器为函数返回 null，则引发 XPathExpressionException。
QNames | 表达式中的 QNames 根据 XPath 名称空间上下文来解析。
结果 | 将计算表达式的结果转换为所需的返回类型的实例。XPathConstants 中定义了有效的返回类型。转换到返回类型的过程遵守 XPath 转换规则。

XPath 表达式不是线程安全的，也不能重入。换句话说，应用程序负责确保在任意给定时刻不能有多个线程使用一个 XPathExpression 对象，且当调用 evaluate 方法时，应用程序不能以递归方式调用 evaluate 方法。

从以下版本开始：
1.5
另请参见：
XML Path Language (XPath) Version 1.0, Expressions

方法摘要
String | evaluate(InputSource source) 计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。
Object | evaluate(InputSource source, QName returnType) 计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
String | evaluate(Object item) 计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。
Object | evaluate(Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。

方法详细信息

evaluate

Object evaluate(Object item,
                QName returnType)
                throws XPathExpressionException

计算指定上下文中的 XPath 表达式并返回指定类型的结果。

有关上下文项计算、变量、函数和 QName 解析，以及返回类型转换，请参阅 XPath 表达式的计算。

如果 returnType 不是 XPathConstants 中定义的类型之一，则抛出 IllegalArgumentException。

如果为 item 提供了 null 值，则将使用一个空文档作为上下文。如果 returnType 为 null，则抛出 NullPointerException。

参数：
item - 开始上下文（例如节点）。
returnType - 所需的返回类型。
返回：
计算表达式并将计算结果转换为 returnType 所得到的结果 Object。
抛出：
XPathExpressionException - 如果不能计算表达式。
IllegalArgumentException - 如果 returnType 不是 XPathConstants 中定义的类型之一。
NullPointerException - 如果 returnType 为 null。

evaluate

String evaluate(Object item)
                throws XPathExpressionException

计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。

此方法调用 evaluate(Object item, QName returnType)，其中 returnType 为 XPathConstants.STRING。

有关上下文项计算、变量、函数和 QName 解析，以及返回类型转换，请参阅 XPath 表达式的计算。

如果为 item 为 null 值，则将使用一个空文档作为上下文。

参数：
item - 开始上下文（例如节点）。
返回：
计算表达式并将计算结果转换为 String 所得到的结果 String。
抛出：
XPathExpressionException - 如果不能计算表达式。

evaluate

Object evaluate(InputSource source,
                QName returnType)
                throws XPathExpressionException

计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。

此方法构建 InputSource 的数据模型，然后对所得文档对象调用 evaluate(Object item, QName returnType)。

有关上下文项计算、变量、函数和 QName 解析，以及返回类型转换，请参阅 XPath 表达式的计算。

如果 returnType 不是 XPathConstants 中定义的类型之一，则抛出 IllegalArgumentException。

如果 source 或 returnType 为 null，则抛出 NullPointerException。

参数：
source - 要对其计算的文档的 InputSource。
returnType - 所需的返回类型。
返回：
计算表达式并将计算结果转换为 returnType 所得到的结果 Object。
抛出：
XPathExpressionException - 如果不能计算表达式。
IllegalArgumentException - 如果 returnType 不是 XPathConstants 中定义的类型之一。
NullPointerException - 如果 source 或 returnType 为 null。

evaluate

String evaluate(InputSource source)
                throws XPathExpressionException

计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。

此方法调用 evaluate(InputSource source, QName returnType)，其中 returnType 为 XPathConstants.STRING。

有关上下文项计算、变量、函数和 QName 解析，以及返回类型转换，请参阅 XPath 表达式的计算。

如果 source 为 null，则抛出 NullPointerException。

参数：
source - 要对其计算的文档的 InputSource。
返回：
计算表达式并将计算结果转换为 String 所得到的结果 String。
抛出：
XPathExpressionException - 如果不能计算表达式。
NullPointerException - 如果 source 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathExpressionException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
类 XPathExpressionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.xpath.XPathException
                继承者  javax.xml.xpath.XPathExpressionException
所有已实现的接口：
Serializable
直接已知子类：
XPathFunctionException
public class XPathExpressionException
extends XPathException

XPathExpressionException 表示 XPath 表达式中的错误。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
XPathExpressionException(String message)
构造带指定详细 message 的新 XPathExpressionException。
XPathExpressionException(Throwable cause)
构造带指定 cause 的新 XPathExpressionException。
方法摘要
从类 javax.xml.xpath.XPathException 继承的方法
getCause, printStackTrace, printStackTrace, printStackTrace
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XPathExpressionException

public XPathExpressionException(String message)

构造带指定详细 message 的新 XPathExpressionException。

cause 未初始化。

如果 message 为 null，则抛出 NullPointerException。

参数：
message - 详细消息。
抛出：
NullPointerException - 当 message 为 null 时。

XPathExpressionException

public XPathExpressionException(Throwable cause)

构造带指定 cause 的新 XPathExpressionException。

如果 cause 为 null，则抛出 NullPointerException。

参数：
cause - 原因
抛出：
NullPointerException - 如果 cause 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
类 XPathFactory

java.lang.Object
    继承者  javax.xml.xpath.XPathFactory

public abstract class XPathFactory
extends Object

XPathFactory 实例可用于创建 XPath 对象。

有关查找机制，请参阅 newInstance(String uri)。

XPathFactory 类不是线程安全的。换句话说，应用程序负责确保任意给定时刻最多只有一个线程使用 XPathFactory 对象。建议实现将方法标记为 synchronized 以保护客户端不至于崩溃。

XPathFactory 不可重入。当正在调用某个 newInstance 方法时，应用程序不能试图以递归方式调用 newInstance 方法，即使是从相同的线程调用。

从以下版本开始：
1.5

字段摘要
static String | DEFAULT_OBJECT_MODEL_URI 默认 Object Model URI。
static String | DEFAULT_PROPERTY_NAME 遵守 JAXP 规范的默认属性名称。
构造方法摘要
protected XPathFactory()
应使用 newInstance()、newInstance(String uri) 或 newInstance(String uri, String factoryClassName, ClassLoader classLoader) 之类的受保护构造方法创建 XPathFactory 的新实例。
方法摘要
abstract boolean | getFeature(String name) 获取指定功能的状态。
abstract boolean | isObjectModelSupported(String objectModel) 此 XPathFactory 是否支持指定的对象模型
static XPathFactory | newInstance() 获取使用默认对象模型 DEFAULT_OBJECT_MODEL_URI（即 W3C DOM）的新 XPathFactory 实例。
static XPathFactory | newInstance(String uri) 获取使用指定对象模型的新 XPathFactory 实例。
static XPathFactory | newInstance(String uri, String factoryClassName, ClassLoader classLoader) 根据工厂类名称获取一个新 XPathFactory 实例。
abstract XPath | newXPath() 返回使用实例化 XPathFactory 时确定的底层对象模型的新 XPath。
abstract void | setFeature(String name, boolean value) 设置此工厂所创建的此 XPathFactory 和 XPath 的功能。
abstract void | setXPathFunctionResolver(XPathFunctionResolver resolver) 建立默认函数解析器。
abstract void | setXPathVariableResolver(XPathVariableResolver resolver) 建立默认变量解析器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_PROPERTY_NAME

public static final String DEFAULT_PROPERTY_NAME

遵守 JAXP 规范的默认属性名称。

另请参见：
常量字段值

DEFAULT_OBJECT_MODEL_URI

public static final String DEFAULT_OBJECT_MODEL_URI

默认 Object Model URI。

另请参见：
常量字段值
构造方法详细信息

XPathFactory

protected XPathFactory()

应使用 newInstance()、newInstance(String uri) 或 newInstance(String uri, String factoryClassName, ClassLoader classLoader) 之类的受保护构造方法创建 XPathFactory 的新实例。

方法详细信息

newInstance

public static final XPathFactory newInstance()

获取使用默认对象模型 DEFAULT_OBJECT_MODEL_URI（即 W3C DOM）的新 XPathFactory 实例。

此方法的功能等效于：

   newInstance(DEFAULT_OBJECT_MODEL_URI)

因为 W3C DOM 的实现总是可用的，因此此方法永远不会失败。

返回：
XPathFactory 的实例。
抛出：
RuntimeException - 创建默认对象模型的 XPathFactory 遇到故障时。

newInstance

public static final XPathFactory newInstance(String uri)
                                      throws XPathFactoryConfigurationException

获取使用指定对象模型的新 XPathFactory 实例。

为了查找 XPathFactory 对象，此方法按以下顺序查找以下位置，其中“类加载器”指上下文类加载器：

  1. 如果存在系统属性 DEFAULT_PROPERTY_NAME + ":uri"（其中 uri 是此方法的参数），则其值作为类名称读取。该方法将试图通过使用类加载器创建此类的新实例，如果创建成功，则返回它。
  2. 读取 ${java.home}/lib/jaxp.properties，并查找与作为系统属性的键关联的值。如果存在，则按上面的方式处理该值。
  3. 类加载器要求服务提供者的提供者配置文件与资源目录 META-INF/services 中的 javax.xml.xpath.XPathFactory 匹配。有关文件格式和解析规则，请参阅 JAR File Specification。每个可能的服务提供者均要实现该方法：
           isObjectModelSupported(String objectModel)
    返回支持指定对象模型的类加载器顺序中的第一个服务提供者。
  4. 以特定于平台的方式来定位平台默认的 XPathFactory。必须存在 W3C DOM 的平台默认 的 XPathFactory，即 DEFAULT_OBJECT_MODEL_URI。

如果这些都失败，则抛出 XPathFactoryConfigurationException。

疑难解答提示：

有关如何精确解析属性文件的信息，请参阅 Properties.load(java.io.InputStream)。尤其是，冒号 ':'在属性文件中需要转义，因此要确保 URI 在其中进行正确转义。例如：

   http\://java.sun.com/jaxp/xpath/dom=org.acme.DomXPathFactory

参数：
uri - 标识底层对象模型。规范只定义了 URI DEFAULT_OBJECT_MODEL_URI、用于 W3C DOM 的 http://java.sun.com/jaxp/xpath/dom、org.w3c.dom 包。至于其他对象模型，实现可随意引入其他 URI。
返回：
XPathFactory 的实例。
抛出：
XPathFactoryConfigurationException - 如果指定的对象模型不可用。
NullPointerException - 如果 uri 为 null。
IllegalArgumentException - 如果 uri 为 null 或 uri.length() == 0。

newInstance

public static XPathFactory newInstance(String uri,
                                       String factoryClassName,
                                       ClassLoader classLoader)
                                throws XPathFactoryConfigurationException

根据工厂类名称获取一个新 XPathFactory 实例。如果指定的工厂类支持指定的对象模型，则返回 XPathFactory。当类路径中有多个提供者时此函数很有用。它给了应用程序更多的控制权，因为它能指定应该加载哪个提供者。

疑难解答提示

设置 jaxp.debug 系统属性将导致此方法将许多调试消息打印到 System.err，以说明正在执行的操作以及在何处查找。

如有问题，请尝试：

 java -Djaxp.debug=1 YourProgram ....

参数：
uri - 标识底层对象模型。规范只定义了 URI DEFAULT_OBJECT_MODEL_URI、用于 W3C DOM 的 http://java.sun.com/jaxp/xpath/dom、org.w3c.dom 包。至于其他对象模型，实现可随意引入其他 URI。
factoryClassName - 完全限定工厂类名称，提供 javax.xml.xpath.XPathFactory 的实现。
classLoader - 用来加载工厂类的 ClassLoader。如果为 null，则使用当前 Thread 的上下文 classLoader 来加载工厂类。
返回：
新的 XPathFactory 实例
抛出：
XPathFactoryConfigurationException - 如果 factoryClassName 为 null、工厂类不能被加载或实例化、工厂类不支持 uri 参数中指定的对象模型。
NullPointerException - 如果 uri 为 null。
IllegalArgumentException - 如果 uri 为 null 或 uri.length() == 0。
从以下版本开始：
1.6
另请参见：
newInstance(), newInstance(String uri)

isObjectModelSupported

public abstract boolean isObjectModelSupported(String objectModel)

此 XPathFactory 是否支持指定的对象模型

参数：
objectModel - 指定返回的 XPathFactory 理解的对象模型。
返回：
如果 XPathFactory 支持 objectModel，则返回 true，否则返回 false。
抛出：
NullPointerException - 如果 objectModel 为 null。
IllegalArgumentException - 如果 objectModel.length() == 0。

setFeature

public abstract void setFeature(String name,
                                boolean value)
                         throws XPathFactoryConfigurationException

设置此工厂所创建的此 XPathFactory 和 XPath 的功能。

功能名称是完全限定的 URI。实现可以定义它们自己的功能。如果此 XPathFactory 或其创建的 XPath 不支持该功能，则抛出 XPathFactoryConfigurationException。XPathFactory 可以公开功能值，但不能更改其状态。

所有实现必须支持 XMLConstants.FEATURE_SECURE_PROCESSING 功能。当功能为 true 时，任何对外部函数的引用均是错误的。在这些条件下，实现不能调用 XPathFunctionResolver 且必须抛出 XPathFunctionException。

参数：
name - 功能名称。
value - 功能状态为 true 或 false。
抛出：
XPathFactoryConfigurationException - 如果此 XPathFactory 或其创建的 XPath 不支持此功能。
NullPointerException - 如果 name 为 null。

getFeature

public abstract boolean getFeature(String name)
                            throws XPathFactoryConfigurationException

获取指定功能的状态。

功能名称是完全限定的 URI。实现可以定义它们自己的功能。如果此 XPath 或其创建的 XPathFactory 不支持该功能，则抛出 XPathFactoryConfigurationException。XPathFactory 可以公开功能值，但不能更改其状态。

参数：
name - 功能名称。
返回：
指定功能的状态。
抛出：
XPathFactoryConfigurationException - 如果此 XPathFactory 或其创建的 XPath 不支持此功能。
NullPointerException - 如果 name 为 null。

setXPathVariableResolver

public abstract void setXPathVariableResolver(XPathVariableResolver resolver)

建立默认变量解析器。

从此工厂构造的任何 XPath 对象将默认使用指定的解析器。

如果 resolver 为 null，则抛出 NullPointerException。

参数：
resolver - 变量解析器。
抛出：
NullPointerException - 如果 resolver 为 null。

setXPathFunctionResolver

public abstract void setXPathFunctionResolver(XPathFunctionResolver resolver)

建立默认函数解析器。

从此工厂构造的任何 XPath 对象将默认使用指定的解析器。

如果 resolver 为 null，则抛出 NullPointerException。

参数：
resolver - XPath 函数解析器。
抛出：
NullPointerException - 如果 resolver 为 null。

newXPath

public abstract XPath newXPath()

返回使用实例化 XPathFactory 时确定的底层对象模型的新 XPath。

返回：
XPath 的新实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathFactoryConfigurationException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
类 XPathFactoryConfigurationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.xpath.XPathException
                继承者  javax.xml.xpath.XPathFactoryConfigurationException
所有已实现的接口：
Serializable
public class XPathFactoryConfigurationException
extends XPathException

XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
XPathFactoryConfigurationException(String message)
构造带指定详细 message 的新 XPathFactoryConfigurationException。
XPathFactoryConfigurationException(Throwable cause)
构造带指定 cause 的新 XPathFactoryConfigurationException。
方法摘要
从类 javax.xml.xpath.XPathException 继承的方法
getCause, printStackTrace, printStackTrace, printStackTrace
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XPathFactoryConfigurationException

public XPathFactoryConfigurationException(String message)

构造带指定详细 message 的新 XPathFactoryConfigurationException。

cause 未初始化。

如果 message 为 null，则抛出 NullPointerException。

参数：
message - 详细消息。
抛出：
NullPointerException - 当 message 为 null 时。

XPathFactoryConfigurationException

public XPathFactoryConfigurationException(Throwable cause)

构造带指定 cause 的新 XPathFactoryConfigurationException。

如果 cause 为 null，则抛出 NullPointerException。

参数：
cause - 原因
抛出：
NullPointerException - 如果 cause 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathFunction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
接口 XPathFunction

public interface XPathFunction

XPathFunction 提供了对 XPath 函数的访问。

函数由 XPath 中的 QName 和 arity 标识。

从以下版本开始：
1.5

方法摘要
 Object evaluate(List args)
计算带指定参数的函数。

方法详细信息

evaluate

Object evaluate(List args)
                throws XPathFunctionException

计算带指定参数的函数。

在扩展函数的定义中应尽最大可能避免副作用。计算 XPath 表达式的实现不负责以任何特殊顺序或以任何特殊次数调用扩展函数。

参数：
args - 参数，null 为有效值。
返回：
计算 XPath 函数的结果（以 Object 形式）。
抛出：
XPathFunctionException - 如果不能通过此 XPath 函数计算 args。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathFunctionException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
类 XPathFunctionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.xpath.XPathException
                继承者  javax.xml.xpath.XPathExpressionException
                    继承者  javax.xml.xpath.XPathFunctionException
所有已实现的接口：
Serializable
public class XPathFunctionException
extends XPathExpressionException

XPathFunctionException 表示 XPath 函数的错误。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
XPathFunctionException(String message)
构造带指定详细 message 的新 XPathFunctionException。
XPathFunctionException(Throwable cause)
构造带指定 cause 的新 XPathFunctionException。
方法摘要
从类 javax.xml.xpath.XPathException 继承的方法
getCause, printStackTrace, printStackTrace, printStackTrace
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XPathFunctionException

public XPathFunctionException(String message)

构造带指定详细 message 的新 XPathFunctionException。

cause 未初始化。

如果 message 为 null，则抛出 NullPointerException。

参数：
message - 详细消息。
抛出：
NullPointerException - 当 message 为 null 时。

XPathFunctionException

public XPathFunctionException(Throwable cause)

构造带指定 cause 的新 XPathFunctionException。

如果 cause 为 null，则抛出 NullPointerException。

参数：
cause - 原因
抛出：
NullPointerException - 如果 cause 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathFunctionResolver (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
接口 XPathFunctionResolver

public interface XPathFunctionResolver

XPathFunctionResolver 提供了对用户定义的 XPathFunction 集的访问。

XPath 函数通过名称和 arity 解析。XPath 的内置函数无需解析器，且解析器不能 用于重写这些函数。

尤其是，解析器仅供另一个名称空间中的函数（带有显式前缀的函数）调用。这意味着不能使用 XPathFunctionResolver 来实现像 XML-Signature Syntax and Processing 这样的规范（此规范在相同名称空间中扩充了 XPath 1.0 的函数库）。这是解析器的设计结果。

如果要实现额外的内置函数，必须直接扩展基础实现。

从以下版本开始：
1.5
另请参见：
XML Path Language (XPath) Version 1.0, Core Function Library

方法摘要
 XPathFunction resolveFunction(QName functionName, int arity)
在可用的函数集中查找函数。

方法详细信息

resolveFunction

XPathFunction resolveFunction(QName functionName,
                              int arity)

在可用的函数集中查找函数。

如果 functionName 或 arity 为 null，则抛出 NullPointerException。

参数：
functionName - 函数名称。
arity - 返回的函数必须接受的参数数量。
返回：
函数，如果不存在带有 arity 个参数的命名为 functionName 的函数，则返回 null。
抛出：
NullPointerException - 如果 functionName 或 arity 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XPathVariableResolver (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.xpath
接口 XPathVariableResolver

public interface XPathVariableResolver

XPathVariableResolver 提供了对用户定义的 XPath 变量集的访问。

XPathVariableResolver 和 XPath 计算器必须遵守一个协定，即不能直接由 API 强制执行。虽然变量是可变的，即应用程序可能希望多次计算带有不同变量值的相同 XPath 表达式，但在任何单个 XPath 表达式的计算过程中，变量的值必须 不变。

从以下版本开始：
1.5

方法摘要
 Object resolveVariable(QName variableName)
在可用的变量集中查找变量。

方法详细信息

resolveVariable

Object resolveVariable(QName variableName)

在可用的变量集中查找变量。

如果 variableName 为 null，则抛出 NullPointerException。

参数：
variableName - 变量名称的 QName。
返回：
变量值，如果不存在命名为 variableName 的变量，则返回 null。返回的值必须为适合于基础对象模型的类型。
抛出：
NullPointerException - 如果 variableName 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.xpath (Java Platform SE 6)

 javax.xml.xpath
接口
XPath
XPathExpression
XPathFunction
XPathFunctionResolver
XPathVariableResolver
类
XPathConstants
XPathFactory
异常
XPathException
XPathExpressionException
XPathFactoryConfigurationException
XPathFunctionException


javax.xml.xpath (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.xpath

此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

请参见：
描述

接口摘要
XPath | XPath 提供了对 XPath 计算环境和表达式的访问。
XPathExpression | XPathExpression 提供了对编译后的 XPath 表达式的访问。
XPathFunction | XPathFunction 提供了对 XPath 函数的访问。
XPathFunctionResolver | XPathFunctionResolver 提供了对用户定义的 XPathFunction 集的访问。
XPathVariableResolver | XPathVariableResolver 提供了对用户定义的 XPath 变量集的访问。

类摘要
XPathConstants | XPath 常量。
XPathFactory | XPathFactory 实例可用于创建 XPath 对象。

异常摘要
XPathException | XPathException 表示通用 XPath 异常。
XPathExpressionException | XPathExpressionException 表示 XPath 表达式中的错误。
XPathFactoryConfigurationException | XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
XPathFunctionException | XPathFunctionException 表示 XPath 函数的错误。

软件包 javax.xml.xpath 的描述

此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

应用以下 XML 标准：

  • XML Path Language (XPath) Version 1.0

XPath 概述

XPath 语言提供了用于从 XML 文档选择节点的简单、简洁的语法。XPath 还提供了将 XML 文档对象模型（DOM）树中的节点转换为布尔值、double 值或字符串值的规则。XPath 是 W3C 定义的语言和正式的 W3C 推荐，W3C 拥有 XML Path Language (XPath) Version 1.0 规范。

XPath 诞生于 1999 年，作为对 XSLT 和 XPointer 语言的补充，但近来已成为流行的独立语言，因为单个 XPath 表达式可用于替代多行 DOM API 代码。

XPath 表达式

XPath 表达式 由一个位置路径 和一个或多个可选的谓词 组成。表达式还可以包含 XPath 变量。

以下是一个简单的 XPath 表达式的示例：

/foo/bar

此示例将选择如下所示的 XML 文档中的 <bar> 元素：

<foo>
<bar/>
</foo>

表达式 /foo/bar 是位置路径的一个示例。虽然 XPath 位置路径类似于 Unix-style 文件系统路径，但它们存在重要的区别，即 XPath 表达式返回与表达式匹配的所有 节点。因此，/foo/bar 表达式将选中以下文档中的所有三种 <bar> 元素：

<foo>
<bar/>
<bar/>
<bar/>
</foo>

特殊位置路径操作符 // 选择位于 XML 文档中任何深度的节点。以下示例选择所有 <bar> 元素，不管它们在文档中处于什么位置：

//bar

通配符 * 用于选择所有元素节点。以下示例选择 <foo> 元素的所有子元素：

/foo/*

除元素节点外，XPath 位置路径还可用于寻找属性节点、文本节点、注释节点和指令处理节点。下表给出了每种节点类型的位置路径的示例：

位置路径 | 描述
/foo/bar/@id | 选择 <bar> 元素的属性 id
/foo/bar/text() | 选择 <bar> 元素的文本节点。转义和非转义字符数据之间没有区别。
/foo/bar/comment() | 选择 <bar> 元素中包含的所有注释节点。
/foo/bar/processing-instruction() | 选择 <bar> 元素中包含的所有指令处理节点。

谓词允许修改 XPath 位置路径所选中的节点。谓词的形式为 [expression]。以下示例选择包含值为 true 的 include 属性的所有 <foo> 元素：

//foo[@include='true']

谓词可互相追加以进一步修改表达式，例如：

//foo[@include='true'][@mode='bar']

使用 XPath API

以下示例演示了使用 XPath API 来选择一个或多个来自 XML 文档的节点：

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
InputSource inputSource = new InputSource("widgets.xml");
NodeList nodes = (NodeList) xpath.evaluate(expression, inputSource, XPathConstants.NODESET);

XPath 表达式和类型

虽然 XPath 表达式选择的是 XML 文档的节点，但 XPath API 允许将选中的节点组合到以下其他数据类型中：

  • 布尔值
  • 数字
  • 字符串

用于计算表示式的方法调用中的 QName 参数指定了所需的返回类型，其中方法调用要么是调用 XPathExpression.evalute(...)，要么是调用 XPath.evaluate(...) 便捷方法之一。允许的 QName 值指定为 XPathConstants 类中的常量，它们是：

  • XPathConstants.NODESET
  • XPathConstants.NODE
  • XPathConstants.STRING
  • XPathConstants.BOOLEAN
  • XPathConstants.NUMBER

当请求 Boolean 返回类型时，如果选中了一个或多个节点，则返回 Boolean.TRUE，否则返回 Boolean.FALSE。

String 返回类型是从文本节点、注释节点或指令处理节点检索字符数据的便捷方法。当用于元素节点上时，返回子文本节点的值。

Number 返回类型尝试将节点的文本组合到 double 数据类型。

XPath 上下文

XPath 位置路径可以相对于文档中的特殊节点，称为 context。考虑以下 XML 文档：

<widgets>
<widget>
<manufacturer/>
<dimensions/>
</widget>
</widgets>

可以通过以下 XPath API 代码选择 <widget> 元素：

// parse the XML as a W3C Document
DocumentBuilder builder = DocumentBuilderFactory.newInstance().newDocumentBuilder();
Document document = builder.parse(new File("/widgets.xml"));

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "/widgets/widget";
Node widgetNode = (Node) xpath.evaluate(expression, document, XPathConstants.NODE);

通过引用 <widget> 元素，现在可以编写相对 XPath 表达式来选择 <manufacturer> 子元素：

XPath xpath = XPathFactory.newInstance().newXPath();
String expression = "manufacturer";
Node manufacturerNode = (Node) xpath.evaluate(expression, widgetNode, XPathConstants.NODE);
  • Author Ben Galbraith
  • Author Norman Walsh
  • Author Jeff Suttor
  • See XML Path Language (XPath) Version 1.0
  • Since 1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.xpath 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.xpath 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
            • javax.xml.xpath.XPathFunctionException
          • javax.xml.xpath.XPathFactoryConfigurationException
    • javax.xml.xpath.XPathConstants
    • javax.xml.xpath.XPathFactory

接口分层结构

  • javax.xml.xpath.XPath
  • javax.xml.xpath.XPathExpression
  • javax.xml.xpath.XPathFunction
  • javax.xml.xpath.XPathFunctionResolver
  • javax.xml.xpath.XPathVariableResolver
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.xpath 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.xpath
的使用

使用 javax.xml.xpath 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 使用的 javax.xml.xpath 中的类
XPath
XPath 提供了对 XPath 计算环境和表达式的访问。
XPathException
XPathException 表示通用 XPath 异常。
XPathExpression
XPathExpression 提供了对编译后的 XPath 表达式的访问。
XPathExpressionException
XPathExpressionException 表示 XPath 表达式中的错误。
XPathFactory
XPathFactory 实例可用于创建 XPath 对象。
XPathFactoryConfigurationException
XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
XPathFunction
XPathFunction 提供了对 XPath 函数的访问。
XPathFunctionException
XPathFunctionException 表示 XPath 函数的错误。
XPathFunctionResolver
XPathFunctionResolver 提供了对用户定义的 XPathFunction 集的访问。
XPathVariableResolver
XPathVariableResolver 提供了对用户定义的 XPath 变量集的访问。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.xpath.XPath 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPath
的使用

使用 XPath 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPath 的使用

返回 XPath 的 javax.xml.xpath 中的方法
abstract  XPath XPathFactory.newXPath()
返回使用实例化 XPathFactory 时确定的底层对象模型的新 XPath。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.xpath.XPathConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathConstants
的使用

没有 javax.xml.xpath.XPathConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.xpath.XPathException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathException
的使用

使用 XPathException 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathException 的使用

javax.xml.xpath 中 XPathException 的子类
class | XPathExpressionException XPathExpressionException 表示 XPath 表达式中的错误。
class | XPathFactoryConfigurationException XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
class | XPathFunctionException XPathFunctionException 表示 XPath 函数的错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.xpath.XPathExpression 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPathExpression
的使用

使用 XPathExpression 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathExpression 的使用

返回 XPathExpression 的 javax.xml.xpath 中的方法
 XPathExpression XPath.compile(String expression)
编译 XPath 表达式供以后计算使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.xpath.XPathExpressionException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathExpressionException
的使用

使用 XPathExpressionException 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathExpressionException 的使用

javax.xml.xpath 中 XPathExpressionException 的子类
 class XPathFunctionException
XPathFunctionException 表示 XPath 函数的错误。

抛出 XPathExpressionException 的 javax.xml.xpath 中的方法
XPathExpression | XPath.compile(String expression) 编译 XPath 表达式供以后计算使用。
String | XPathExpression.evaluate(InputSource source) 计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。
Object | XPathExpression.evaluate(InputSource source, QName returnType) 计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
String | XPathExpression.evaluate(Object item) 计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。
Object | XPathExpression.evaluate(Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。
String | XPath.evaluate(String expression, InputSource source) 计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。
Object | XPath.evaluate(String expression, InputSource source, QName returnType) 计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。
String | XPath.evaluate(String expression, Object item) 计算指定上下文中的 XPath 表达式并返回 String 形式的结果。
Object | XPath.evaluate(String expression, Object item, QName returnType) 计算指定上下文中的 XPath 表达式并返回指定类型的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.xpath.XPathFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathFactory
的使用

使用 XPathFactory 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFactory 的使用

返回 XPathFactory 的 javax.xml.xpath 中的方法
static XPathFactory | XPathFactory.newInstance() 获取使用默认对象模型 DEFAULT_OBJECT_MODEL_URI（即 W3C DOM）的新 XPathFactory 实例。
static XPathFactory | XPathFactory.newInstance(String uri) 获取使用指定对象模型的新 XPathFactory 实例。
static XPathFactory | XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader) 根据工厂类名称获取一个新 XPathFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.xpath.XPathFactoryConfigurationException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathFactoryConfigurationException
的使用

使用 XPathFactoryConfigurationException 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFactoryConfigurationException 的使用

抛出 XPathFactoryConfigurationException 的 javax.xml.xpath 中的方法
abstract boolean | XPathFactory.getFeature(String name) 获取指定功能的状态。
static XPathFactory | XPathFactory.newInstance(String uri) 获取使用指定对象模型的新 XPathFactory 实例。
static XPathFactory | XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader) 根据工厂类名称获取一个新 XPathFactory 实例。
abstract void | XPathFactory.setFeature(String name, boolean value) 设置此工厂所创建的此 XPathFactory 和 XPath 的功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.xpath.XPathFunction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPathFunction
的使用

使用 XPathFunction 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFunction 的使用

返回 XPathFunction 的 javax.xml.xpath 中的方法
 XPathFunction XPathFunctionResolver.resolveFunction(QName functionName, int arity)
在可用的函数集中查找函数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.xpath.XPathFunctionException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.xpath.XPathFunctionException
的使用

使用 XPathFunctionException 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFunctionException 的使用

抛出 XPathFunctionException 的 javax.xml.xpath 中的方法
 Object XPathFunction.evaluate(List args)
计算带指定参数的函数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.xpath.XPathFunctionResolver 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPathFunctionResolver
的使用

使用 XPathFunctionResolver 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathFunctionResolver 的使用

返回 XPathFunctionResolver 的 javax.xml.xpath 中的方法
 XPathFunctionResolver XPath.getXPathFunctionResolver()
返回当前的函数解析器。

参数类型为 XPathFunctionResolver 的 javax.xml.xpath 中的方法
void | XPath.setXPathFunctionResolver(XPathFunctionResolver resolver) 建立函数解析器。
abstract void | XPathFactory.setXPathFunctionResolver(XPathFunctionResolver resolver) 建立默认函数解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.xpath.XPathVariableResolver 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.xpath.XPathVariableResolver
的使用

使用 XPathVariableResolver 的软件包
javax.xml.xpath 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

javax.xml.xpath 中 XPathVariableResolver 的使用

返回 XPathVariableResolver 的 javax.xml.xpath 中的方法
 XPathVariableResolver XPath.getXPathVariableResolver()
返回当前的变量解析器。

参数类型为 XPathVariableResolver 的 javax.xml.xpath 中的方法
void | XPath.setXPathVariableResolver(XPathVariableResolver resolver) 建立变量解析器。
abstract void | XPathFactory.setXPathVariableResolver(XPathVariableResolver resolver) 建立默认变量解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


EventFilter (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 EventFilter

public interface EventFilter

此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLEventReader。

从以下版本开始：
1.6

方法摘要
 boolean accept(XMLEvent event)
测试此事件是否为此流的一部分。

方法详细信息

accept

boolean accept(XMLEvent event)
测试此事件是否为此流的一部分。如果此过滤器接受此事件，则此方法返回 true，否则返回 false。

参数：
event - 要测试的事件
返回：
如果此过滤器接受此事件，则返回 true，否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FactoryConfigurationError (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
类 FactoryConfigurationError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  javax.xml.stream.FactoryConfigurationError
所有已实现的接口：
Serializable
public class FactoryConfigurationError
extends Error

一个用于报告工厂配置错误的错误类。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
FactoryConfigurationError()
默认构造方法。
FactoryConfigurationError(Exception e)
构造具有嵌套内部异常的异常。
FactoryConfigurationError(Exception e, String msg)
构造具有嵌套内部异常和消息的异常。
FactoryConfigurationError(String msg)
构造具有关联消息的异常。
FactoryConfigurationError(String msg, Exception e)
构造具有嵌套内部异常和消息的异常。
方法摘要
Exception | getException() 返回嵌套异常（如果有）。
String | getMessage() 报告与此错误关联的消息。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FactoryConfigurationError

public FactoryConfigurationError()
默认构造方法。

FactoryConfigurationError

public FactoryConfigurationError(Exception e)
构造具有嵌套内部异常的异常。

参数：
e - 要嵌套的异常

FactoryConfigurationError

public FactoryConfigurationError(Exception e,
                                 String msg)
构造具有嵌套内部异常和消息的异常。

参数：
e - 要嵌套的异常
msg - 要报告的消息

FactoryConfigurationError

public FactoryConfigurationError(String msg,
                                 Exception e)
构造具有嵌套内部异常和消息的异常。

参数：
msg - 要报告的消息
e - 要嵌套的异常

FactoryConfigurationError

public FactoryConfigurationError(String msg)
构造具有关联消息的异常。

参数：
msg - 要报告的消息
方法详细信息

getException

public Exception getException()
返回嵌套异常（如果有）。

返回：
嵌套异常或 null

getMessage

public String getMessage()
报告与此错误关联的消息。

覆盖：
类 Throwable 中的 getMessage
返回：
消息的字符串值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Location (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 Location

public interface Location

提供有关事件位置的信息。Location 提供的所有信息都是可选的。例如，应用程序可以只报告行号。

从以下版本开始：
1.6

方法摘要
int | getCharacterOffset() 返回此位置所指向的输入源中的字节或字符偏移量。
int | getColumnNumber() 返回当前事件结束位置的列号，如果没有可用的列号，则返回 -1。
int | getLineNumber() 返回当前事件结束位置的行号，如果没有可用的行号，则返回 -1。
String | getPublicId() 返回 XML 的公共 ID
String | getSystemId() 返回 XML 的系统 ID

方法详细信息

getLineNumber

int getLineNumber()
返回当前事件结束位置的行号，如果没有可用的行号，则返回 -1。

返回：
当前行号

getColumnNumber

int getColumnNumber()
返回当前事件结束位置的列号，如果没有可用的列号，则返回 -1。

返回：
当前列号

getCharacterOffset

int getCharacterOffset()
返回此位置所指向的输入源中的字节或字符偏移量。如果输入源是一个文件或字节流，则偏移量为该流中的字节偏移量；但如果输入源是字符介质，则偏移量为字符偏移量。如果没有可用的偏移量，则返回 -1。

返回：
当前偏移量

getPublicId

String getPublicId()
返回 XML 的公共 ID

返回：
公共 ID，如果不可用，则返回 null

getSystemId

String getSystemId()
返回 XML 的系统 ID

返回：
系统 ID，如果不可用，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StreamFilter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 StreamFilter

public interface StreamFilter

此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLStreamReader。

从以下版本开始：
1.6

方法摘要
 boolean accept(XMLStreamReader reader)
测试当前状态是否为此流的一部分。

方法详细信息

accept

boolean accept(XMLStreamReader reader)
测试当前状态是否为此流的一部分。如果此过滤器接受此事件，则此方法返回 true，否则返回 false。此方法不应在接受状态时更改 reader 的状态。

参数：
reader - 要测试的事件
返回：
如果此过滤器接收此事件，则返回 true，否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLEventFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
类 XMLEventFactory

java.lang.Object
    继承者  javax.xml.stream.XMLEventFactory

public abstract class XMLEventFactory
extends Object

此接口定义一个创建 XMLEvent 实例的实用工具类。

从以下版本开始：
1.6
另请参见：
StartElement, EndElement, ProcessingInstruction, Comment, Characters, StartDocument, EndDocument, DTD

构造方法摘要
protected XMLEventFactory()
方法摘要
abstract Attribute | createAttribute(QName name, String value) 创建一个新 Attribute。
abstract Attribute | createAttribute(String localName, String value) 创建一个新 Attribute。
abstract Attribute | createAttribute(String prefix, String namespaceURI, String localName, String value) 创建一个新 Attribute。
abstract Characters | createCData(String content) 创建一个 CData 标记设置为 true 的 Character 事件。
abstract Characters | createCharacters(String content) 创建一个 Character 事件，此方法不检查内容是否全部为空白。
abstract Comment | createComment(String text) 创建一个注释。
abstract DTD | createDTD(String dtd) 创建一个文档类型定义事件。
abstract EndDocument | createEndDocument() 创建一个 EndDocument 事件的新实例。
abstract EndElement | createEndElement(QName name, Iterator namespaces) 创建一个新 EndElement。
abstract EndElement | createEndElement(String prefix, String namespaceUri, String localName) 创建一个新 EndElement。
abstract EndElement | createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces) 创建一个新 EndElement。
abstract EntityReference | createEntityReference(String name, EntityDeclaration declaration) 创建一个 EntityReference 事件的新实例。
abstract Characters | createIgnorableSpace(String content) 创建一个可忽略的空间。
abstract Namespace | createNamespace(String namespaceURI) 创建一个新的默认 Namespace。
abstract Namespace | createNamespace(String prefix, String namespaceUri) 创建一个新的 Namespace。
abstract ProcessingInstruction | createProcessingInstruction(String target, String data) 创建一个处理指令。
abstract Characters | createSpace(String content) 创建一个 isSpace 标记设置为 true 的 Character 事件。
abstract StartDocument | createStartDocument() 创建一个 StartDocument 事件的新实例。
abstract StartDocument | createStartDocument(String encoding) 创建一个 StartDocument 事件的新实例。
abstract StartDocument | createStartDocument(String encoding, String version) 创建一个 StartDocument 事件的新实例。
abstract StartDocument | createStartDocument(String encoding, String version, boolean standalone) 创建一个 StartDocument 事件的新实例。
abstract StartElement | createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | createStartElement(String prefix, String namespaceUri, String localName) 创建一个新 StartElement。
abstract StartElement | createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。
static XMLEventFactory | newInstance() 创建一个新的工厂实例。
static XMLEventFactory | newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
abstract void | setLocation(Location location) 此方法允许对此工厂创建的每个事件设置 Location。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLEventFactory

protected XMLEventFactory()
方法详细信息

newInstance

public static XMLEventFactory newInstance()
                                   throws FactoryConfigurationError
创建一个新的工厂实例。

抛出：
FactoryConfigurationError - 如果无法加载此工厂的实例

newInstance

public static XMLEventFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
创建一个新的工厂实例。

参数：
factoryId - 要查找的工厂的名称，与属性名称相同
classLoader - 要使用的类加载器
返回：
工厂实现
抛出：
FactoryConfigurationError - 如果此工厂的实例无法加载

setLocation

public abstract void setLocation(Location location)
此方法允许对此工厂创建的每个事件设置 Location。这些值被复制到此工厂创建的事件中。若要重置位置信息，可将 location 设置为 null。

参数：
location - 要对每个创建的事件设置的位置

createAttribute

public abstract Attribute createAttribute(String prefix,
                                          String namespaceURI,
                                          String localName,
                                          String value)
创建一个新 Attribute。

参数：
prefix - 此属性的前缀，不可以为 null
namespaceURI - 被设置为此值的属性值，不可以为 null
localName - 属性 XML 名称的本地名称，localName 不可以为 null
value - 要设置的属性值，不可以为 null
返回：
带有指定值的 Attribute

createAttribute

public abstract Attribute createAttribute(String localName,
                                          String value)
创建一个新 Attribute。

参数：
localName - 属性 XML 名称的本地名称，localName 不可以为 null
value - 要设置的属性值，不可以为 null
返回：
带有指定值的 Attribute

createAttribute

public abstract Attribute createAttribute(QName name,
                                          String value)
创建一个新 Attribute。

参数：
name - 属性的限定名，不可以为 null
value - 要设置的属性值，不可以为 unll
返回：
带有指定值的 Attribute

createNamespace

public abstract Namespace createNamespace(String namespaceURI)
创建一个新的默认 Namespace。

参数：
namespaceURI - 默认名称空间 URI
返回：
带有指定值的 Namespace

createNamespace

public abstract Namespace createNamespace(String prefix,
                                          String namespaceUri)
创建一个新的 Namespace。

参数：
prefix - 此名称空间的前缀，不可以为 null
namespaceUri - 被设置为此值的属性值，不可以为 null
返回：
带有指定值的 Namespace

createStartElement

public abstract StartElement createStartElement(QName name,
                                                Iterator attributes,
                                                Iterator namespaces)
创建一个新 StartElement。通过传入一个迭代 Namespace 接口集合的 Iterator，可以将名称空间添加到此 StartElement。通过传入一个迭代 Attribute 接口集合的 Iterator，可以将属性添加到此 StartElement。

参数：
name - 属性的限定名，不可以为 null
attributes - 要添加到新 StartElement 的可选无序对象集合，这些对象均实现 Attribute，该参数可以为 null
namespaces - 要添加到新 StartElement 的可选无序对象集合，这些对象均实现 Namespace，该参数可以为 null
返回：
请求的 StartElement 的实例

createStartElement

public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName)
创建一个新 StartElement。此方法默认 NamespaceContext 为空 NamespaceContext。查询此事件的名称空间或属性将导致返回空的迭代器。

参数：
namespaceUri - 新 StartElement QName 的 URI
localName - 新 StartElement QName 的本地名称
prefix - 新 StartElement QName 的前缀
返回：
请求的 StartElement 的实例

createStartElement

public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName,
                                                Iterator attributes,
                                                Iterator namespaces)
创建一个新 StartElement。通过传入一个迭代 Namespace 接口集合的 Iterator，可以将名称空间添加到此 StartElement。通过传入一个迭代 Attribute 接口集合的 Iterator，可以将属性添加到此 StartElement。

参数：
namespaceUri - 新 StartElement QName 的 URI
localName - 新 StartElement QName 的本地名称
prefix - 新 StartElement QName 的前缀
attributes - 要添加到新 StartElement 的无序对象集合，这些对象均实现 Attribute
namespaces - 要添加到新 StartElement 的无序对象集合，这些对象均实现 Namespace
返回：
请求的 StartElement 的实例

createStartElement

public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName,
                                                Iterator attributes,
                                                Iterator namespaces,
                                                NamespaceContext context)
创建一个新 StartElement。通过传入一个迭代 Namespace 接口集合的 Iterator，可以将名称空间添加到此 StartElement。通过传入一个迭代 Attribute 接口集合的 Iterator，可以将属性添加到此 StartElement。

参数：
namespaceUri - 新 StartElement QName 的 URI
localName - 新 StartElement QName 的本地名称
prefix - 新 StartElemente QName 的前缀
attributes - 要添加到新 StartElement 的无序对象集合，这些对象均实现 Attribute，可以为 null
namespaces - 要添加到新 StartElement 的无序对象集合，这些对象均实现 Namespace，可以为 null
context - 此元素的名称空间上下文
返回：
请求的 StartElement 的实例

createEndElement

public abstract EndElement createEndElement(QName name,
                                            Iterator namespaces)
创建一个新 EndElement。

参数：
name - EndElement 的限定名
namespaces - 超出范围的无序对象集合，这些对象均实现 Namespace，该参数可以为 null
返回：
请求的 EndElement 的实例

createEndElement

public abstract EndElement createEndElement(String prefix,
                                            String namespaceUri,
                                            String localName)
创建一个新 EndElement。

参数：
namespaceUri - 新 StartElement QName 的 URI
localName - 新 StartElement QName 的本地名称
prefix - 新 StartElement QName 的前缀
返回：
请求的 EndElement 的实例

createEndElement

public abstract EndElement createEndElement(String prefix,
                                            String namespaceUri,
                                            String localName,
                                            Iterator namespaces)
创建一个新 EndElement。

参数：
namespaceUri - 新 StartElement QName 的 URI
localName - 新 StartElement QName 的本地名称
prefix - 新 StartElement QName 的前缀
namespaces - 超出范围的无序对象集合，这些对象均实现 Namespace，该参数可以为 null
返回：
请求的 EndElement 的实例

createCharacters

public abstract Characters createCharacters(String content)
创建一个 Character 事件，此方法不检查内容是否全部为空白。使用 #createSpace(String) 创建一个空间事件。

参数：
content - 要创建的字符串
返回：
一个 Character 事件

createCData

public abstract Characters createCData(String content)
创建一个 CData 标记设置为 true 的 Character 事件。

参数：
content - 要创建的字符串
返回：
一个 Character 事件

createSpace

public abstract Characters createSpace(String content)
创建一个 isSpace 标记设置为 true 的 Character 事件。

参数：
content - 要创建的空间的内容
返回：
一个 Character 事件

createIgnorableSpace

public abstract Characters createIgnorableSpace(String content)
创建一个可忽略的空间。

参数：
content - 要创建的空间
返回：
一个 Character 事件

createStartDocument

public abstract StartDocument createStartDocument()
创建一个 StartDocument 事件的新实例。

返回：
一个 StartDocument 事件

createStartDocument

public abstract StartDocument createStartDocument(String encoding,
                                                  String version,
                                                  boolean standalone)
创建一个 StartDocument 事件的新实例。

参数：
encoding - 编码样式
version - XML 的版本
standalone - 独立的状态，可以设置为 "true" 或 "false"
返回：
一个 StartDocument 事件

createStartDocument

public abstract StartDocument createStartDocument(String encoding,
                                                  String version)
创建一个 StartDocument 事件的新实例。

参数：
encoding - 编码样式
XML - 的版本
返回：
一个 StartDocument 事件

createStartDocument

public abstract StartDocument createStartDocument(String encoding)
创建一个 StartDocument 事件的新实例。

参数：
encoding - 编码样式
返回：
一个 StartDocument 事件

createEndDocument

public abstract EndDocument createEndDocument()
创建一个 EndDocument 事件的新实例。

返回：
一个 EndDocument 事件

createEntityReference

public abstract EntityReference createEntityReference(String name,
                                                      EntityDeclaration declaration)
创建一个 EntityReference 事件的新实例。

参数：
name - 引用的名称
declaration - 事件的声明
返回：
一个 EntityReference 事件

createComment

public abstract Comment createComment(String text)
创建一个注释。

参数：
text - Comment 事件的注释文本

createProcessingInstruction

public abstract ProcessingInstruction createProcessingInstruction(String target,
                                                                  String data)
创建一个处理指令。

参数：
target - 处理指令的目标
data - 处理指令的文本
返回：
一个 ProcessingInstruction 事件

createDTD

public abstract DTD createDTD(String dtd)
创建一个文档类型定义事件。此字符串包含与 XML 1.0 规范中的 doctypedecl 相匹配的整个文档类型声明。

参数：
dtd - 文档类型定义的文本
返回：
一个 DTD 事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLEventReader (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 XMLEventReader

所有超级接口：
Iterator
所有已知实现类：
EventReaderDelegate
public interface XMLEventReader
extends Iterator

此类是用于解析 XML 事件的顶层接口。它提供查看下一个事件和返回属性接口中的配置信息的功能。

从以下版本开始：
1.6
另请参见：
XMLInputFactory, XMLEventWriter

方法摘要
void | close() 释放所有与此 Reader 关联的资源。
String | getElementText() 读取纯文本元素的内容。
Object | getProperty(String name) 从底层实现获取功能/属性值。
boolean | hasNext() 检查是否有多个事件。
XMLEvent | nextEvent() 获取下一个 XMLEvent。
XMLEvent | nextTag() 在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。
XMLEvent | peek() 检查下一个 XMLEvent，但不从流中读取它。
从接口 java.util.Iterator 继承的方法
next, remove

方法详细信息

nextEvent

XMLEvent nextEvent()
                   throws XMLStreamException
获取下一个 XMLEvent。

抛出：
XMLStreamException - 如果底层 XML 存在错误。
NoSuchElementException - 迭代不再有元素。
另请参见：
XMLEvent

hasNext

boolean hasNext()
检查是否有多个事件。如果有多个事件，则返回 true，否则返回 false。

指定者：
接口 Iterator 中的 hasNext
返回：
如果事件 reader 具有多个事件，则返回 true，否则返回 false。

peek

XMLEvent peek()
              throws XMLStreamException
检查下一个 XMLEvent，但不从流中读取它。如果流位于 EOF 处或者不再有 XMLEvent，则返回 null。调用 peek() 将相当于 next() 的下一个返回。

抛出：
XMLStreamException
另请参见：
XMLEvent

getElementText

String getElementText()
                      throws XMLStreamException
读取纯文本元素的内容。前置条件：当前事件是 START_ELEMENT。后置条件：当前事件是相应的 END_ELEMENT。

抛出：
XMLStreamException - 如果当前事件不是 START_ELEMENT 或者遇到了非文本元素

nextTag

XMLEvent nextTag()
                 throws XMLStreamException
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。如果遇到空格符之外的其他内容，则抛出异常。在处理纯元素内容时应使用此方法，因为如果缺少 DTD 或未解释它，解析器将无法识别可忽略的空格。

抛出：
XMLStreamException - 如果遇到空格符之外的其他内容

getProperty

Object getProperty(String name)
                   throws IllegalArgumentException
从底层实现获取功能/属性值。

参数：
name - 属性的名称
返回：
属性的值
抛出：
IllegalArgumentException - 如果属性不受支持

close

void close()
           throws XMLStreamException
释放所有与此 Reader 关联的资源。此方法不会关闭底层输入源。

抛出：
XMLStreamException - 如果释放关联资源时出现错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLEventWriter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 XMLEventWriter

所有超级接口：
XMLEventConsumer
public interface XMLEventWriter
extends XMLEventConsumer

此类是用于编写 XML 文档的顶层接口。此接口的实例不需要验证 XML 的格式。

从以下版本开始：
1.6
另请参见：
XMLEventReader, XMLEvent, Characters, ProcessingInstruction, StartElement, EndElement

方法摘要
void | add(XMLEvent event) 向输出流添加事件。
void | add(XMLEventReader reader) 将整个流添加到输出流，在 hasNext() 返回 false 前对 inputStream 参数调用 next()。
void | close() 释放所有与此流关联的资源。
void | flush() 将所有缓存事件写入到底层输出机制。
NamespaceContext | getNamespaceContext() 返回当前名称空间上下文。
String | getPrefix(String uri) 获取绑定 URI 的前缀。
void | setDefaultNamespace(String uri) 将 URI 绑定到默认名称空间。
void | setNamespaceContext(NamespaceContext context) 设置前缀的当前名称空间上下文和 URI 绑定。
void | setPrefix(String prefix, String uri) 设置绑定 URI 的前缀。

方法详细信息

flush

void flush()
           throws XMLStreamException
将所有缓存事件写入到底层输出机制。

抛出：
XMLStreamException

close

void close()
           throws XMLStreamException
释放所有与此流关联的资源。

抛出：
XMLStreamException

add

void add(XMLEvent event)
         throws XMLStreamException
向输出流添加事件。添加 START_ELEMENT 将打开新的名称空间作用域，它将在写入相应的 END_ELEMENT 时被关闭。
添加到 writer 的事件的必需字段和可选字段
事件类型 | 必需字段 | 可选字段 | 必需行为
START_ELEMENT | QName name | namespace、attribute | 通过用 XML 1.0 中对 START_ELEMENT 有效的语法写入事件的名称、名称空间和属性来编写 START_ELEMENT。名称是通过查找名称空间 URI 的前缀写入的。writer 可以配置为考虑 QName 的前缀。如果 writer 考虑前缀，则它必须使用在 QName 中设置的前缀。默认行为是在 EventWriter 的内部名称空间上下文中查找前缀的值。每个属性（如果有）使用在此表的属性部分所指定的行为写入。每个名称空间（如果有）使用在此表的名称空间部分所指定的行为写入。
END_ELEMENT | Qname name | 无 | 写入一个格式良好的 END_ELEMENT 标记。名称是通过查找名称空间 URI 的前缀写入的。writer 可以配置为考虑 QName 的前缀。如果 writer 考虑前缀，则它必须使用在 QName 中设置的前缀。默认行为是在 EventWriter 的内部名称空间上下文中查找前缀的值。如果 END_ELEMENT 名称和 START_ELEMENT 名称不匹配，则抛出 XMLStreamException。
ATTRIBUTE | QName name、String value | QName type | 使用同样的算法写入属性，以根据 START_ELEMENT 中使用的词法查找词法格式。默认行为是使用双引号将属性值括起来并转义出现在值中的所有双引号。类型值被忽略。
NAMESPACE | String prefix、String namespaceURI、boolean isDefaultNamespaceDeclaration | 无 | 写入一个名称空间声明。如果名称空间是默认名称空间声明（isDefault 为 true），则写入 xmlns="$namespaceURI"，前缀是可选项。如果 isDefault 为 false，则必须声明前缀，writer 必须将 xmlns 附加为前缀并写出一个标准前缀声明。
PROCESSING_INSTRUCTION | 无 | String target、String data | 数据不需要附加前缀，可以为 null。目标是必需的，不可以为 null。writer 将直接在目标之后编写数据部分，并用合适的 XML 1.0 语法封闭起来
COMMENT | 无 | String comment | 如果存在注释（不为 null），则写入该注释，否则写入一个空注释
START_DOCUMENT | 无 | String encoding、boolean standalone、String version | 不需要将 START_DOCUMENT 事件写入流。如果存在，则属性以适当的 XML 声明语法写入
END_DOCUMENT | 无 | 无 | 不向输出写入任何内容
DTD | String DocumentTypeDefinition | 无 | DocumentTypeDefinition 被写入输出

指定者：
接口 XMLEventConsumer 中的 add
参数：
event - 要被添加的事件
抛出：
XMLStreamException

add

void add(XMLEventReader reader)
         throws XMLStreamException
将整个流添加到输出流，在 hasNext() 返回 false 前对 inputStream 参数调用 next()。此方法应被视为一个便捷方法，它将在事件 reader 中的所有事件中执行以下循环，并对每个事件上调用 add。

参数：
reader - 要添加到输出的事件流
抛出：
XMLStreamException

getPrefix

String getPrefix(String uri)
                 throws XMLStreamException
获取绑定 URI 的前缀。

参数：
uri - 要查找的 URI
抛出：
XMLStreamException

setPrefix

void setPrefix(String prefix,
               String uri)
               throws XMLStreamException
设置绑定 URI 的前缀。前缀在当前 START_ELEMENT / END_ELEMENT 对的范围内绑定。如果在写入 START_ELEMENT 之前调用此方法，则前缀在根范围内绑定。

参数：
prefix - 要绑定到 URI 的前缀
uri - 要绑定到前缀的 URI
抛出：
XMLStreamException

setDefaultNamespace

void setDefaultNamespace(String uri)
                         throws XMLStreamException
将 URI 绑定到默认名称空间。此 URI 在当前 START_ELEMENT / END_ELEMENT 对的范围内绑定。如果在写入 START_ELEMENT 之前调用此方法，则 URI 在根范围内绑定。

参数：
uri - 要绑定到默认名称空间的 URI
抛出：
XMLStreamException

setNamespaceContext

void setNamespaceContext(NamespaceContext context)
                         throws XMLStreamException
设置前缀的当前名称空间上下文和 URI 绑定。此上下文成为用于写入的根名称空间上下文，并将替换当前的根名称空间上下文。对 setPrefix 和 setDefaultNamespace 的后续调用将使用作为解析名称空间的根上下文传递到此方法的上下文来绑定名称空间。

参数：
context - 要用于此 writer 的名称空间上下文
抛出：
XMLStreamException

getNamespaceContext

NamespaceContext getNamespaceContext()
返回当前名称空间上下文。

返回：
当前名称空间上下文
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLInputFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
类 XMLInputFactory

java.lang.Object
    继承者  javax.xml.stream.XMLInputFactory

public abstract class XMLInputFactory
extends Object

定义用于获取流的工厂的抽象实现。下表定义此规范的标准属性。每个属性随每个实现所要求的支持级别的不同而不同。所要求的支持级别在“必需”栏中做了描述。

配置参数
属性名 | 行为 | 返回类型 | 默认值 | 必需
javax.xml.stream.isValidating | 开启/关闭特定于实现的 DTD 验证 | Boolean | False | 否
javax.xml.stream.isNamespaceAware | 开启/关闭用于支持 XML 1.0 的名称空间处理 | Boolean | True | True（必需）/ False （可选）
javax.xml.stream.isCoalescing | 要求处理器组合相临的字符数据 | Boolean | False | 是
javax.xml.stream.isReplacingEntityReferences | 用它们的替换文本替换内部实体引用并将它们作为字符报告 | Boolean | True | 是
javax.xml.stream.isSupportingExternalEntities | 解析外部解析的实体 | Boolean | 未指定 | 是
javax.xml.stream.supportDTD | 使用此属性请求不支持 DTD 的处理器 | Boolean | True | 是
javax.xml.stream.reporter | 设置/获取 XMLReporter 的 impl | javax.xml.stream.XMLReporter | Null | 是
javax.xml.stream.resolver | 设置/获取 XMLResolver 接口的 impl | javax.xml.stream.XMLResolver | Null | 是
javax.xml.stream.allocator | 设置/获取 XMLEventAllocator 接口的 impl | javax.xml.stream.util.XMLEventAllocator | Null | 是

从以下版本开始：
1.6
另请参见：
XMLOutputFactory, XMLEventReader, XMLStreamReader, EventFilter, XMLReporter, XMLResolver, XMLEventAllocator

字段摘要
static String | ALLOCATOR 用于设置/获取分配器实现的属性。
static String | IS_COALESCING 要求解析器组合相邻字符数据部分的属性。
static String | IS_NAMESPACE_AWARE 用于开启/关闭名称空间支持的属性，该属性用于支持 XML 1.0 文档，只有 true 设置是必须受支持的。
static String | IS_REPLACING_ENTITY_REFERENCES 要求解析器用它们的替换文本替换内部实体引用并将它们报告为字符。
static String | IS_SUPPORTING_EXTERNAL_ENTITIES 要求解析器解析外部解析实体的属性。
static String | IS_VALIDATING 用于开启/关闭特定于实现的验证的属性。
static String | REPORTER 用于设置/获取 XMLReporter 接口实现的属性。
static String | RESOLVER 用于设置/获取 XMLResolver 实现的属性。
static String | SUPPORT_DTD 要求解析器支持 DTD 的属性。
构造方法摘要
protected XMLInputFactory()
方法摘要
abstract XMLEventReader | createFilteredReader(XMLEventReader reader, EventFilter filter) 创建过滤的事件 reader，它用过滤器包装事件 reader。
abstract XMLStreamReader | createFilteredReader(XMLStreamReader reader, StreamFilter filter) 创建过滤的 reader，它用过滤器包装 reader。
abstract XMLEventReader | createXMLEventReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | createXMLEventReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | createXMLEventReader(Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLEventReader | createXMLEventReader(Source source) 根据 JAXP 源创建一个新 XMLEventReader。
abstract XMLEventReader | createXMLEventReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | createXMLEventReader(String systemId, Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLEventReader | createXMLEventReader(XMLStreamReader reader) 根据 XMLStreamReader 创建一个新 XMLEventReader。
abstract XMLStreamReader | createXMLStreamReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | createXMLStreamReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | createXMLStreamReader(Reader reader) 根据 reader 创建一个新 XMLStreamReader。
abstract XMLStreamReader | createXMLStreamReader(Source source) 根据 JAXP 源创建一个新 XMLStreamReader。
abstract XMLStreamReader | createXMLStreamReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | createXMLStreamReader(String systemId, Reader reader) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLEventAllocator | getEventAllocator() 获取用此工厂创建的流所使用的分配器。
abstract Object | getProperty(String name) 从底层实现获取功能/属性的值。
abstract XMLReporter | getXMLReporter() 要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。
abstract XMLResolver | getXMLResolver() 要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。
abstract boolean | isPropertySupported(String name) 查询此工厂支持的属性集合。
static XMLInputFactory | newInstance() 创建一个新的工厂实例。
static XMLInputFactory | newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
abstract void | setEventAllocator(XMLEventAllocator allocator) 为事件设置一个用户定义的事件分配器。
abstract void | setProperty(String name, Object value) 允许用户在底层实现上设置特定功能/属性。
abstract void | setXMLReporter(XMLReporter reporter) 要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。
abstract void | setXMLResolver(XMLResolver resolver) 要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_NAMESPACE_AWARE

public static final String IS_NAMESPACE_AWARE
用于开启/关闭名称空间支持的属性，该属性用于支持 XML 1.0 文档，只有 true 设置是必须受支持的。

另请参见：
常量字段值

IS_VALIDATING

public static final String IS_VALIDATING
用于开启/关闭特定于实现的验证的属性。

另请参见：
常量字段值

IS_COALESCING

public static final String IS_COALESCING
要求解析器组合相邻字符数据部分的属性。

另请参见：
常量字段值

IS_REPLACING_ENTITY_REFERENCES

public static final String IS_REPLACING_ENTITY_REFERENCES
要求解析器用它们的替换文本替换内部实体引用并将它们报告为字符。

另请参见：
常量字段值

IS_SUPPORTING_EXTERNAL_ENTITIES

public static final String IS_SUPPORTING_EXTERNAL_ENTITIES
要求解析器解析外部解析实体的属性。

另请参见：
常量字段值

SUPPORT_DTD

public static final String SUPPORT_DTD
要求解析器支持 DTD 的属性。

另请参见：
常量字段值

REPORTER

public static final String REPORTER
用于设置/获取 XMLReporter 接口实现的属性。

另请参见：
常量字段值

RESOLVER

public static final String RESOLVER
用于设置/获取 XMLResolver 实现的属性。

另请参见：
常量字段值

ALLOCATOR

public static final String ALLOCATOR
用于设置/获取分配器实现的属性。

另请参见：
常量字段值
构造方法详细信息

XMLInputFactory

protected XMLInputFactory()
方法详细信息

newInstance

public static XMLInputFactory newInstance()
                                   throws FactoryConfigurationError
创建一个新的工厂实例。此 static 方法创建一个新的工厂实例。此方法按照以下查找过程顺序来确定要加载的 XMLInputFactory 实现类：使用 javax.xml.stream.XMLInputFactory 系统属性。使用 JRE 目录中的属性文件 "lib/stax.properties"。此配置文件是标准的 java.util.Properties 格式，且包含实现类的完全限定名，其中实现类的键是上文定义的系统属性。如果 Services API（在 JAR 规范中进行了详细描述）可用，可以使用它来确定类名称。Services API 将在运行时可用的 jar 文件 META-INF/services/javax.xml.stream.XMLInputFactory 中查找类名称。平台默认的 XMLInputFactory 实例。应用程序获取对 XMLInputFactory 的引用后，它可以使用工厂来配置和获取流实例。

抛出：
FactoryConfigurationError - 如果此工厂的实例无法加载

newInstance

public static XMLInputFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
创建一个新的工厂实例。

参数：
factoryId - 要查找的工厂的名称，与属性名称相同
classLoader - 要使用的类加载器
返回：
工厂实现
抛出：
FactoryConfigurationError - 如果此工厂的实例无法加载

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(Reader reader)
                                               throws XMLStreamException
根据 reader 创建一个新 XMLStreamReader。

参数：
reader - 要从中读取 XMLStreamReader 的 XML 数据
抛出：
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(Source source)
                                               throws XMLStreamException
根据 JAXP 源创建一个新 XMLStreamReader。此方法是可选的。

参数：
source - 要从中读取 XMLStreamReader 的源
抛出：
UnsupportedOperationException - 如果 XMLInputFactory 不支持此方法
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(InputStream stream)
                                               throws XMLStreamException
根据 java.io.InputStream 创建一个新 XMLStreamReader。

参数：
stream - 要从中读取 XMLStreamReader 的 InputStream
抛出：
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(InputStream stream,
                                                      String encoding)
                                               throws XMLStreamException
根据 java.io.InputStream 创建一个新 XMLStreamReader。

参数：
stream - 要从中读取 XMLStreamReader 的 InputStream
encoding - 流的字符编码
抛出：
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(String systemId,
                                                      InputStream stream)
                                               throws XMLStreamException
根据 java.io.InputStream 创建一个新 XMLStreamReader。

参数：
systemId - 流的系统 ID
stream - 要从中读取 XMLStreamReader 的 InputStream
抛出：
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(String systemId,
                                                      Reader reader)
                                               throws XMLStreamException
根据 java.io.InputStream 创建一个新 XMLStreamReader。

参数：
systemId - 流的系统 ID
reader - 要从中读取 XMLStreamReader 的 InputStream
抛出：
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(Reader reader)
                                             throws XMLStreamException
根据 reader 创建一个新 XMLEventReader。

参数：
reader - 要从中读取 XMLEventReader 的 XML 数据
抛出：
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(String systemId,
                                                    Reader reader)
                                             throws XMLStreamException
根据 reader 创建一个新 XMLEventReader。

参数：
systemId - 输入的系统 ID
reader - 要从中读取 XMLEventReader 的 XML 数据
抛出：
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(XMLStreamReader reader)
                                             throws XMLStreamException
根据 XMLStreamReader 创建一个新 XMLEventReader。在被用来构造此方法返回的 XMLEventReader 实例后，MLStreamReader 不得再次使用。

参数：
reader - 要从中读取数据的 XMLStreamReader （不能修改）
返回：
新 XMLEventReader
抛出：
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(Source source)
                                             throws XMLStreamException
根据 JAXP 源创建一个新 XMLEventReader。对此方法的支持是可选的。

参数：
source - 要从中读取 XMLEventReader 的源
抛出：
UnsupportedOperationException - 如果此 XMLInputFactory 不支持此方法
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(InputStream stream)
                                             throws XMLStreamException
根据 java.io.InputStream 创建一个新 XMLEventReader。

参数：
stream - 要从中读取 XMLEventReader 的 InputStream
抛出：
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(InputStream stream,
                                                    String encoding)
                                             throws XMLStreamException
根据 java.io.InputStream 创建一个新 XMLEventReader。

参数：
stream - 要从中读取 XMLEventReader 的 InputStream
encoding - 流的字符编码
抛出：
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(String systemId,
                                                    InputStream stream)
                                             throws XMLStreamException
根据 java.io.InputStream 创建一个新 XMLEventReader。

参数：
systemId - 流的系统 ID
stream - 要从中读取 XMLEventReader 的 InputStream
抛出：
XMLStreamException

createFilteredReader

public abstract XMLStreamReader createFilteredReader(XMLStreamReader reader,
                                                     StreamFilter filter)
                                              throws XMLStreamException
创建过滤的 reader，它用过滤器包装 reader。

参数：
reader - 要过滤的 reader
filter - 要应用到 reader 的过滤器
抛出：
XMLStreamException

createFilteredReader

public abstract XMLEventReader createFilteredReader(XMLEventReader reader,
                                                    EventFilter filter)
                                             throws XMLStreamException
创建过滤的事件 reader，它用过滤器包装事件 reader。

参数：
reader - 要包装的事件 reader
filter - 要应用到事件 reader 的过滤器
抛出：
XMLStreamException

getXMLResolver

public abstract XMLResolver getXMLResolver()
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。

setXMLResolver

public abstract void setXMLResolver(XMLResolver resolver)
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。

参数：
resolver - 要用于解析引用的解析器

getXMLReporter

public abstract XMLReporter getXMLReporter()
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。

setXMLReporter

public abstract void setXMLReporter(XMLReporter reporter)
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。

参数：
reporter - 要用来报告非严重错误的解析器

setProperty

public abstract void setProperty(String name,
                                 Object value)
                          throws IllegalArgumentException
允许用户在底层实现上设置特定功能/属性。底层实现不需要支持规范中每个属性的每个设置，可以使用 IllegalArgumentException 来表示一个不受支持的属性不能用指定的值进行设置。

参数：
name - 属性的名称（不可以为 null）
value - 属性的值
抛出：
IllegalArgumentException - 如果属性不受支持

getProperty

public abstract Object getProperty(String name)
                            throws IllegalArgumentException
从底层实现获取功能/属性的值。

参数：
name - 属性的名称（不可以为 null）
返回：
属性的值
抛出：
IllegalArgumentException - 如果属性不受支持

isPropertySupported

public abstract boolean isPropertySupported(String name)
查询此工厂支持的属性集合。

参数：
name - 属性的名称（不可以为 null）
返回：
如果此属性受支持，则返回 true，否则返回 false

setEventAllocator

public abstract void setEventAllocator(XMLEventAllocator allocator)
为事件设置一个用户定义的事件分配器。

参数：
allocator - 用户定义的分配器

getEventAllocator

public abstract XMLEventAllocator getEventAllocator()
获取用此工厂创建的流所使用的分配器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLOutputFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
类 XMLOutputFactory

java.lang.Object
    继承者  javax.xml.stream.XMLOutputFactory

public abstract class XMLOutputFactory
extends Object

定义用于获取 XMLEventWriter 和 XMLStreamWriter 的工厂抽象实现。下表定义此规范的标准属性。每个属性随每个实现所要求的支持级别的不同而不同。所要求的支持级别在“必需”栏中做了描述。

配置参数
属性名 | 行为 | 返回类型 | 默认值 | 必需
javax.xml.stream.isRepairingNamespaces | 默认输出端前缀 | Boolean | False | 是

以下段落描述了名称空间和前缀修复算法：

属性可以使用以下代码行进行设置：setProperty("javax.xml.stream.isRepairingNamespaces",new Boolean(true|false));

此属性指定 writer 默认名称空间前缀声明。默认值为 false。

如果 writer 是 RepairingNamespaces，则对于任何当前在范围内不具有名称空间声明的属性，它都将在当前的 StartElement 上创建名称空间声明。如果 StartElement 具有 URI，但没有指定前缀，则为其分配一个前缀；如果前缀未在当前 StartElement 的父级中声明，则它将在当前的 StartElement 上声明。如果 defaultNamespace 被绑定，而且在范围内默认名称空间与属性的 URI 或 StartElement QName 相匹配，则不分配任何前缀。

如果元素或属性名称具有前缀，但没有绑定到任何名称空间 URI，则前缀将在序列化时被删除。

如果同一个开始或空元素标记中的元素和/或属性名称被绑定到不同的名称空间 URI，而且使用相同的前缀，则元素或第一个出现的属性将保留原始前缀，而在它之后的属性将用绑定到这些属性名称空间 URI 的新前缀替换它们的前缀。

如果元素或属性名称使用一个绑定到 URI 的前缀，而该 URI 不是从该元素父级的名称空间上下文中继承的，并且在当前元素的上下文中没有名称空间声明，那么将添加一个这样的名称空间声明。

如果元素或属性名称被绑定到一个前缀，而且有一个将此前缀绑定到不同 RUI 的名称空间声明，那么该名称空间声明将被删除（如果从该元素的父上下文中继承了正确的映射），或者被更改为使用该前缀的元素或属性的名称空间 URI。

从以下版本开始：
1.6
另请参见：
XMLInputFactory, XMLEventWriter, XMLStreamWriter

字段摘要
static String IS_REPAIRING_NAMESPACES
用于设置输出端上默认前缀的属性。
构造方法摘要
protected XMLOutputFactory()
方法摘要
abstract XMLEventWriter | createXMLEventWriter(OutputStream stream) 创建一个写入到流的新 XMLEventWriter。
abstract XMLEventWriter | createXMLEventWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLEventWriter。
abstract XMLEventWriter | createXMLEventWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLEventWriter。
abstract XMLEventWriter | createXMLEventWriter(Writer stream) 创建一个写入到 writer 的新 XMLEventWriter。
abstract XMLStreamWriter | createXMLStreamWriter(OutputStream stream) 创建一个写入到流的新 XMLStreamWriter。
abstract XMLStreamWriter | createXMLStreamWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLStreamWriter。
abstract XMLStreamWriter | createXMLStreamWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLStreamWriter。
abstract XMLStreamWriter | createXMLStreamWriter(Writer stream) 创建一个写入到 writer 的新 XMLStreamWriter。
abstract Object | getProperty(String name) 获取底层实现上的功能/属性
abstract boolean | isPropertySupported(String name) 查询此工厂支持的属性集合。
static XMLOutputFactory | newInstance() 创建一个新的工厂实例。
static XMLInputFactory | newInstance(String factoryId, ClassLoader classLoader) 创建一个的新工厂实例。
abstract void | setProperty(String name, Object value) 允许用户在底层实现上设置特定功能/属性。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IS_REPAIRING_NAMESPACES

public static final String IS_REPAIRING_NAMESPACES
用于设置输出端上默认前缀的属性。

另请参见：
常量字段值
构造方法详细信息

XMLOutputFactory

protected XMLOutputFactory()
方法详细信息

newInstance

public static XMLOutputFactory newInstance()
                                    throws FactoryConfigurationError
创建一个新的工厂实例。

抛出：
FactoryConfigurationError - 如果此工厂的实例无法加载

newInstance

public static XMLInputFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
创建一个的新工厂实例。

参数：
factoryId - 要查找的工厂的名称，与属性名称相同
classLoader - 要使用的类加载器
返回：
工厂实现
抛出：
FactoryConfigurationError - 如果此工厂的实例无法加载

createXMLStreamWriter

public abstract XMLStreamWriter createXMLStreamWriter(Writer stream)
                                               throws XMLStreamException
创建一个写入到 writer 的新 XMLStreamWriter。

参数：
stream - 要向其写入 XMLStreamWriter 的 writer
抛出：
XMLStreamException

createXMLStreamWriter

public abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream)
                                               throws XMLStreamException
创建一个写入到流的新 XMLStreamWriter。

参数：
stream - 要向其写入 XMLStreamWriter 的流
抛出：
XMLStreamException

createXMLStreamWriter

public abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream,
                                                      String encoding)
                                               throws XMLStreamException
创建一个写入到流的新 XMLStreamWriter。

参数：
stream - 要向其写入 XMLStreamWriter 的流
encoding - 要使用的编码
抛出：
XMLStreamException

createXMLStreamWriter

public abstract XMLStreamWriter createXMLStreamWriter(Result result)
                                               throws XMLStreamException
创建一个写入到 JAXP 结果的新 XMLStreamWriter。此方法是可选的。

参数：
result - 要向其写入 XMLStreamWriter 的结果
抛出：
UnsupportedOperationException - 如果此 XMLOutputFactory 不支持此方法
XMLStreamException

createXMLEventWriter

public abstract XMLEventWriter createXMLEventWriter(Result result)
                                             throws XMLStreamException
创建一个写入到 JAXP 结果的新 XMLEventWriter。此方法是可选的。

参数：
result - 要向其写入 XMLEventWriter 的结果
抛出：
UnsupportedOperationException - 如果此 XMLOutputFactory 不支持此方法
XMLStreamException

createXMLEventWriter

public abstract XMLEventWriter createXMLEventWriter(OutputStream stream)
                                             throws XMLStreamException
创建一个写入到流的新 XMLEventWriter。

参数：
stream - 要向其写入 XMLEventWriter 的流
抛出：
XMLStreamException

createXMLEventWriter

public abstract XMLEventWriter createXMLEventWriter(OutputStream stream,
                                                    String encoding)
                                             throws XMLStreamException
创建一个写入到流的新 XMLEventWriter。

参数：
stream - 要向其写入 XMLEventWriter 的流
encoding - 要使用的编码
抛出：
XMLStreamException

createXMLEventWriter

public abstract XMLEventWriter createXMLEventWriter(Writer stream)
                                             throws XMLStreamException
创建一个写入到 writer 的新 XMLEventWriter。

参数：
stream - 要向其写入 XMLEventWriter 的流
抛出：
XMLStreamException

setProperty

public abstract void setProperty(String name,
                                 Object value)
                          throws IllegalArgumentException
允许用户在底层实现上设置特定功能/属性。

参数：
name - 属性的名称
value - 属性的值
抛出：
IllegalArgumentException - 如果属性不受支持

getProperty

public abstract Object getProperty(String name)
                            throws IllegalArgumentException
获取底层实现上的功能/属性

参数：
name - 属性的名称
返回：
属性的值
抛出：
IllegalArgumentException - 如果属性不受支持

isPropertySupported

public abstract boolean isPropertySupported(String name)
查询此工厂支持的属性集合。

参数：
name - 属性的名称（不可以为 null）
返回：
如果此属性受支持，则返回 true，否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLReporter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 XMLReporter

public interface XMLReporter

此接口用于报告非严重错误。只有警告才应该通过此接口再次报告。

从以下版本开始：
1.6

方法摘要
 void report(String message, String errorType, Object relatedInformation, Location location)
以特定于应用程序的格式报告所需消息。

方法详细信息

report

void report(String message,
            String errorType,
            Object relatedInformation,
            Location location)
            throws XMLStreamException
以特定于应用程序的格式报告所需消息。只有警告和非严重错误才应该通过此接口报告。严重错误应作为 XMLStreamException 抛出。

参数：
message - 错误消息
errorType - 一个定义错误类型的实现
relatedInformation - 与错误相关的信息（如果可用）
location - 错误的位置（如果可用）
抛出：
XMLStreamException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLResolver (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 XMLResolver

public interface XMLResolver

此接口用于在 XML 解析过程中解析资源。如果应用程序希望执行自定义实体解析，那么它必须使用 setXMLResolver 方法向 XMLInputFactory 注册此接口的一个实例。

从以下版本开始：
1.6

方法摘要
 Object resolveEntity(String publicID, String systemID, String baseURI, String namespace)
检索资源。

方法详细信息

resolveEntity

Object resolveEntity(String publicID,
                     String systemID,
                     String baseURI,
                     String namespace)
                     throws XMLStreamException
检索资源。此资源可以是下列三种返回类型之一：(1) java.io.InputStream (2) javax.xml.stream.XMLStreamReader (3) java.xml.stream.XMLEventReader。如果此方法返回 null，则处理器将尝试用其默认机制解析实体。

参数：
publicID - 被引用的外部实体的公共标识符，如果未提供此类标识符，则该参数为 null。
systemID - 被引用外部实体的系统标识符。
baseURI - 与 systemId 关联的绝对基本 URI。
namespace - 要解析的实体名称空间。
返回：
请求的资源或 null。
抛出：
XMLStreamException - 如果尝试解析资源时出现错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLStreamConstants (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 XMLStreamConstants

所有已知子接口：
Attribute, Characters, Comment, DTD, EndDocument, EndElement, EntityDeclaration, EntityReference, Namespace, NotationDeclaration, ProcessingInstruction, StartDocument, StartElement, XMLEvent, XMLStreamReader
所有已知实现类：
StreamReaderDelegate
public interface XMLStreamConstants

此接口声明此 API 中所使用的常量。从 0 到 256 之间的数字是为规范所保留的，用户定义事件必须使用此范围之外的事件码。

从以下版本开始：
1.6

字段摘要
static int | ATTRIBUTE 指示事件是一个属性
static int | CDATA 指示事件是一个 CDATA 节
static int | CHARACTERS 指示事件是一些字符
static int | COMMENT 指示事件是一个注释
static int | DTD 指示事件是一个 DTD
static int | END_DOCUMENT 指示事件是一个结束文档
static int | END_ELEMENT 指示事件是一个结束元素
static int | ENTITY_DECLARATION 指示一个 Entity Declaration
static int | ENTITY_REFERENCE 指示事件是一个实体引用
static int | NAMESPACE 指示事件是一个名称空间声明
static int | NOTATION_DECLARATION 指示一个 Notation
static int | PROCESSING_INSTRUCTION 指示事件是一条处理指令
static int | SPACE 字符是空格（参阅 [XML], 2.10 "White Space Handling"）。
static int | START_DOCUMENT 指示事件是一个开始文档
static int | START_ELEMENT 指示事件是一个开始元素

字段详细信息

START_ELEMENT

static final int START_ELEMENT
指示事件是一个开始元素

另请参见：
StartElement, 常量字段值

END_ELEMENT

static final int END_ELEMENT
指示事件是一个结束元素

另请参见：
EndElement, 常量字段值

PROCESSING_INSTRUCTION

static final int PROCESSING_INSTRUCTION
指示事件是一条处理指令

另请参见：
ProcessingInstruction, 常量字段值

CHARACTERS

static final int CHARACTERS
指示事件是一些字符

另请参见：
Characters, 常量字段值

COMMENT

static final int COMMENT
指示事件是一个注释

另请参见：
Comment, 常量字段值

SPACE

static final int SPACE
字符是空格（参阅 [XML], 2.10 "White Space Handling"）。只有在它们是可忽略的空格时事件才报告为 SPACE。否则，它们被报告为 CHARACTERS。

另请参见：
Characters, 常量字段值

START_DOCUMENT

static final int START_DOCUMENT
指示事件是一个开始文档

另请参见：
StartDocument, 常量字段值

END_DOCUMENT

static final int END_DOCUMENT
指示事件是一个结束文档

另请参见：
EndDocument, 常量字段值

ENTITY_REFERENCE

static final int ENTITY_REFERENCE
指示事件是一个实体引用

另请参见：
EntityReference, 常量字段值

ATTRIBUTE

static final int ATTRIBUTE
指示事件是一个属性

另请参见：
Attribute, 常量字段值

DTD

static final int DTD
指示事件是一个 DTD

另请参见：
DTD, 常量字段值

CDATA

static final int CDATA
指示事件是一个 CDATA 节

另请参见：
Characters, 常量字段值

NAMESPACE

static final int NAMESPACE
指示事件是一个名称空间声明

另请参见：
Namespace, 常量字段值

NOTATION_DECLARATION

static final int NOTATION_DECLARATION
指示一个 Notation

另请参见：
NotationDeclaration, 常量字段值

ENTITY_DECLARATION

static final int ENTITY_DECLARATION
指示一个 Entity Declaration

另请参见：
NotationDeclaration, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLStreamException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
类 XMLStreamException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.xml.stream.XMLStreamException
所有已实现的接口：
Serializable
public class XMLStreamException
extends Exception

用于不可预料处理错误的基本异常。此异常类用于报告格式良好的错误以及不可预料的处理条件。

从以下版本开始：
1.6
另请参见：
序列化表格

字段摘要
protected Location | location
protected Throwable | nested
构造方法摘要
XMLStreamException()
默认构造方法
XMLStreamException(String msg)
构造具有关联消息的异常。
XMLStreamException(String msg, Location location)
构造具有关联消息、异常和位置的异常。
XMLStreamException(String msg, Location location, Throwable th)
构造具有关联消息、异常和位置的异常。
XMLStreamException(String msg, Throwable th)
构造具有关联消息和异常的异常
XMLStreamException(Throwable th)
构造具有关联异常的异常
方法摘要
Location | getLocation() 获取异常的位置
Throwable | getNestedException() 获取嵌套异常。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

nested

protected Throwable nested

location

protected Location location
构造方法详细信息

XMLStreamException

public XMLStreamException()
默认构造方法

XMLStreamException

public XMLStreamException(String msg)
构造具有关联消息的异常。

参数：
msg - 要报告的消息

XMLStreamException

public XMLStreamException(Throwable th)
构造具有关联异常的异常

参数：
th - 嵌套的异常

XMLStreamException

public XMLStreamException(String msg,
                          Throwable th)
构造具有关联消息和异常的异常

参数：
th - 嵌套异常
msg - 要报告的消息

XMLStreamException

public XMLStreamException(String msg,
                          Location location,
                          Throwable th)
构造具有关联消息、异常和位置的异常。

参数：
th - 嵌套异常
msg - 要报告的消息
location - 错误的位置

XMLStreamException

public XMLStreamException(String msg,
                          Location location)
构造具有关联消息、异常和位置的异常。

参数：
msg - 要报告的消息
location - 错误的位置
方法详细信息

getNestedException

public Throwable getNestedException()
获取嵌套异常。

返回：
嵌套异常

getLocation

public Location getLocation()
获取异常的位置

返回：
异常的位置；如果没有可用位置，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLStreamReader (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 XMLStreamReader

所有超级接口：
XMLStreamConstants
所有已知实现类：
StreamReaderDelegate
public interface XMLStreamReader
extends XMLStreamConstants

XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。它被设计为读取 XML 数据的最低层且最有效的方法。

XMLStreamReader 被设计为使用 next() 和 hasNext() 在 XML 上进行迭代。可以使用诸如 getEventType()、getNamespaceURI()、getLocalName() 和 getText() 之类的方法访问数据：

next() 方法会使 reader 读取下一个解析事件。next() 方法返回一个整数，指示刚才读取的事件类型。

事件类型可以使用 getEventType() 来确定。

解析事件被定义为 XML 声明、DTD、开始标记、字符数据、空格、结束标记、注释或处理指令。属性或名称空间事件可以作为查询操作的结果在文档的根级别出现。

为了遵守 XML 1.0，XML 处理器必须将已声明的未解析实体的标识符、注释声明及其关联标识符传递给应用程序。此信息通过此接口上的属性 API 提供。以下两个属性允许访问此信息：javax.xml.stream.notations 和 javax.xml.stream.entities。当前事件为 DTD 时，以下调用将返回一个 Notation 列表 List l = (List) getProperty("javax.xml.stream.notations"); 以下调用将返回一个实体声明列表：List l = (List) getProperty("javax.xml.stream.entities"); 这些属性只能在 DTD 事件中访问，并且被定义为如果信息不可用，则返回 null。

下表描述了各种状态所对应的有效方法。如果某种方法是在无效状态中调用的，则该方法将抛出 java.lang.IllegalStateException。

每种状态对应的有效方法
事件类型 | 有效方法
所有状态 | getProperty()、hasNext()、require()、close()、getNamespaceURI()、isStartElement()、isEndElement()、isCharacters()、isWhiteSpace()、getNamespaceContext()、getEventType()、getLocation()、hasText()、hasName()
START_ELEMENT | next()、getName()、getLocalName()、hasName()、getPrefix()、getAttributeXXX()、isAttributeSpecified()、getNamespaceXXX()、getElementText()、nextTag()
ATTRIBUTE | next()、nextTag()、getAttributeXXX()、isAttributeSpecified()
NAMESPACE | next()、nextTag()、getNamespaceXXX()
END_ELEMENT | next()、getName()、getLocalName()、hasName()、getPrefix()、getNamespaceXXX()、nextTag()
CHARACTERS | next()、getTextXXX()、nextTag()
CDATA | next()、getTextXXX()、nextTag()
COMMENT | next()、getTextXXX()、nextTag()
SPACE | next()、getTextXXX()、nextTag()
START_DOCUMENT | next()、getEncoding()、getVersion()、isStandalone()、standaloneSet()、getCharacterEncodingScheme()、nextTag()
END_DOCUMENT | close()
PROCESSING_INSTRUCTION | next()、getPITarget()、getPIData()、nextTag()
ENTITY_REFERENCE | next()、getLocalName()、getText()、nextTag()
DTD | next()、getText()、nextTag()

从以下版本开始：
1.6
另请参见：
XMLEvent, XMLInputFactory, XMLStreamWriter

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
 void close()
释放与此 Reader 关联的所有资源。
 int getAttributeCount()
返回此 START_ELEMENT 中的属性计数，此方法仅对 START_ELEMENT 或 ATTRIBUTE 有效。
 String getAttributeLocalName(int index)
返回所提供索引处的属性的 localName
 QName getAttributeName(int index)
返回所提供索引处的属性的 qname
 String getAttributeNamespace(int index)
返回所提供索引处的属性的名称空间
 String getAttributePrefix(int index)
返回所提供索引处的属性的前缀
 String getAttributeType(int index)
返回所提供索引处的属性的 XML 类型
 String getAttributeValue(int index)
返回 index 处的属性值
 String getAttributeValue(String namespaceURI, String localName)
返回带有名称空间和 localName 的属性的规范化属性值。
 String getCharacterEncodingScheme()
返回 xml 声明中声明的字符编码。
 String getElementText()
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。
 String getEncoding()
如果输入编码已知，则返回输入编码；如果未知，则返回 null。
 int getEventType()
返回一个整数码，指示光标所指向的事件的类型。
 String getLocalName()
返回当前事件的（本地）名称。
 Location getLocation()
返回处理器的当前位置。
 QName getName()
返回当前 START_ELEMENT 或 END_ELEMENT 事件的 QName
 NamespaceContext getNamespaceContext()
返回当前位置的只读名称空间上下文。
 int getNamespaceCount()
返回在 START_ELEMENT 或 END_ELEMENT 中声明的名称空间的计数，此方法仅对 START_ELEMENT、END_ELEMENT 或 NAMESPACE 有效。
 String getNamespacePrefix(int index)
返回在 index 处声明的名称空间前缀。
 String getNamespaceURI()
如果当前事件是 START_ELEMENT 或 END_ELEMENT，则此方法返回前缀的 URI 或默认名称空间。
 String getNamespaceURI(int index)
返回在 index 处声明的名称空间 URI。
 String getNamespaceURI(String prefix)
返回给定前缀的 URI。
 String getPIData()
获取处理指令的数据节
 String getPITarget()
获取处理指令的目标
 String getPrefix()
返回当前事件的前缀，如果事件没有前缀，则返回 null
 Object getProperty(String name)
从底层实现获取功能/属性的值
 String getText()
以字符串的形式返回解析事件的当前值，此方法返回 CHARACTERS 事件的字符串值，返回 COMMENT 的值、ENTITY_REFERENCE 的替代值、CDATA 节的字符串值、SPACE 事件的字符串值、DTD 内部子集的字符串值。
 char[] getTextCharacters()
返回一个包含此事件中字符的数组。
 int getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
获取与 CHARACTERS、SPACE 或 CDATA 事件关联的文本。
 int getTextLength()
返回文本字符数组中此文本事件的字符序列长度。
 int getTextStart()
返回存储（此文本事件的）第一个字符位置处的文本字符数组的偏移量。
 String getVersion()
获取在 xml 声明中声明的 xml 版本，如果没有声明版本，则返回 null
 boolean hasName()
如果当前事件有名称（是 START_ELEMENT 或 END_ELEMENT），则返回 ture，否则返回 false
 boolean hasNext()
如果有多个解析事件，则返回 true，如果不再有事件，则返回 false。
 boolean hasText()
如果当前事件具有文本，则返回 true，否则返回 false。
 boolean isAttributeSpecified(int index)
返回一个 boolean 值，它指示此属性是否为默认创建的
 boolean isCharacters()
如果光标指向字符数据事件，则返回 true
 boolean isEndElement()
如果光标指向结束标记，则返回 true（否则返回 false）
 boolean isStandalone()
获取 xml 声明中的独立声明
 boolean isStartElement()
如果光标指向开始标记，则返回 true（否则返回 false）
 boolean isWhiteSpace()
如果光标指向由所有空格组成的字符数据事件，则返回 true
 int next()
获取下一个解析事件??处理器可以用单个存储块返回所有连续的字符数据，它也可以将其分割成几个存储块。
 int nextTag()
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有空格（isWhiteSpace() 返回 true）、COMMENT 或 PROCESSING_INSTRUCTION。
 void require(int type, String namespaceURI, String localName)
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。
 boolean standaloneSet()
检查文档中是否设置了独立

方法详细信息

getProperty

Object getProperty(String name)
                   throws IllegalArgumentException
从底层实现获取功能/属性的值

参数：
name - 属性的名称，不可以为 null
返回：
属性的值
抛出：
IllegalArgumentException - 如果名称为 null

next

int next()
         throws XMLStreamException
获取下一个解析事件??处理器可以用单个存储块返回所有连续的字符数据，它也可以将其分割成几个存储块。如果属性 javax.xml.stream.isCoalescing 设置为 true，则元素内容必须组合，对于连续元素内容或 CDATA 节，只需要返回一个 CHARACTERS 事件。 默认情况下，必须扩展实体引用，并透明地报告给应用程序。如果实体引用不能扩展，则抛出异常。如果元素内容为空（即内容为 ""），则不报告 CHARACTERS 事件。

假设给定以下 XML：
<foo><!--description-->内容文本<![CDATA[<greeting>Hello</greeting>]]>其他内容</foo>
对 foo 调用 next() 的行为将是：
1- 注释 (COMMENT)
2- 然后是字符节 (CHARACTERS)
3- 接下来是 CDATA 节（另一个 CHARACTERS）
4- 再接下来是下一个字符节 （另一个 CHARACTERS）
5- 最后是 END_ELEMENT

注： 空元素（如 <tag/>）将用以下两个单独的事件报告：START_ELEMENT 和 END_ELEMENT??这保证了空元素对 <tag></tag> 解析的等效性。 如果是在 hasNext() 返回 false 之后调用此方法，则此方法将抛出 IllegalStateException。

返回：
与当前解析事件相对应的整数码
抛出：
NoSuchElementException - 如果在 hasNext() 返回 false 时调用
XMLStreamException - 如果处理底层 XML 源时发生错误
另请参见：
XMLEvent

require

void require(int type,
             String namespaceURI,
             String localName)
             throws XMLStreamException
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。如果 namespaceURI 为 null，则该参数不进行相等性检查；如果 localName 为 null，则该参数不进行相等性检查。

参数：
type - 事件类型
namespaceURI - 事件的 URI，可以为 null
localName - 事件的 localName，可以为 null
抛出：
XMLStreamException - 如果所需值不匹配。

getElementText

String getElementText()
                      throws XMLStreamException
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。无论 javax.xml.stream.isCoalescing 的值如何，此方法始终返回组合的内容。
前置条件：当前事件是 START_ELEMENT。
后置条件：当前事件是相应的 END_ELEMENT。
此方法执行下列操作（实现可以随意优化，但必须执行等效处理）：
if(getEventType() != XMLStreamConstants.START_ELEMENT) {
throw new XMLStreamException(
"parser must be on START_ELEMENT to read next text", getLocation());
 }
int eventType = next();
StringBuffer content = new StringBuffer();
while(eventType != XMLStreamConstants.END_ELEMENT ) {
if(eventType == XMLStreamConstants.CHARACTERS
|| eventType == XMLStreamConstants.CDATA
|| eventType == XMLStreamConstants.SPACE
|| eventType == XMLStreamConstants.ENTITY_REFERENCE) {
buf.append(getText());
} else if(eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
|| eventType == XMLStreamConstants.COMMENT) {
// skipping
} else if(eventType == XMLStreamConstants.END_DOCUMENT) {
throw new XMLStreamException(
"unexpected end of document when reading element text content", this);
} else if(eventType == XMLStreamConstants.START_ELEMENT) {
throw new XMLStreamException(
"element text content may not contain START_ELEMENT", getLocation());
} else {
throw new XMLStreamException(
"Unexpected event type "+eventType, getLocation());
 }
eventType = next();
 }
return buf.toString();

抛出：
XMLStreamException - 如果当前事件不是 START_ELEMENT 或者遇到了非文本元素

nextTag

int nextTag()
            throws XMLStreamException
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有空格（isWhiteSpace() 返回 true）、COMMENT 或 PROCESSING_INSTRUCTION。如果遇到空格字符、COMMENT、PROCESSING_INSTRUCTION、START_ELEMENT、END_ELEMENT 以外的其他内容，则抛出异常。在处理以空格分隔的纯元素内容时，应使用此方法。
前置条件：无
后置条件：当前事件为 START_ELEMENT 或 END_ELEMENT，并且光标已经移到任何空格事件上。
它实际上执行下列操作（实现可以随意优化，但必须执行等效处理）：
int eventType = next();
while((eventType == XMLStreamConstants.CHARACTERS && isWhiteSpace()) // skip whitespace
|| (eventType == XMLStreamConstants.CDATA && isWhiteSpace())
// skip whitespace
|| eventType == XMLStreamConstants.SPACE
|| eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
|| eventType == XMLStreamConstants.COMMENT
 ) {
eventType = next();
 }
if (eventType != XMLStreamConstants.START_ELEMENT && eventType != XMLStreamConstants.END_ELEMENT) {
throw new String XMLStreamException("expected start or end tag", getLocation());
 }
return eventType;

返回：
元素读取的事件类型（START_ELEMENT 或 END_ELEMENT）
抛出：
XMLStreamException - 如果当前事件不是空格、PROCESSING_INSTRUCTION、START_ELEMENT 或 END_ELEMENT
NoSuchElementException - 如果它在 hasNext() 返回 false 时被调用

hasNext

boolean hasNext()
                throws XMLStreamException
如果有多个解析事件，则返回 true，如果不再有事件，则返回 false。如果 XMLStreamReader 的当前状态为 END_DOCUMENT，则此方法返回 false

返回：
如果有多个事件，则返回 true，否则返回 false
抛出：
XMLStreamException - 如果检测下一个状态时发生严重错误

close

void close()
           throws XMLStreamException
释放与此 Reader 关联的所有资源。此方法不会关闭底层输入源。

抛出：
XMLStreamException - 如果释放关联资源时发生错误

getNamespaceURI

String getNamespaceURI(String prefix)
返回给定前缀的 URI。返回的 URI 取决于处理器的当前状态。

注：根据 Namespaces in XML 规范中的定义，'xml' 前缀被绑定到 "http://www.w3.org/XML/1998/namespace"。

注：'xmlns' 前缀必须被解析到以下名称空间：http://www.w3.org/2000/xmlns/

参数：
prefix - 要查找的前缀，不可以为 null
返回：
绑定到给定前缀的 URI，如果未绑定，则返回 null
抛出：
IllegalArgumentException - 如果前缀为 null

isStartElement

boolean isStartElement()
如果光标指向开始标记，则返回 true（否则返回 false）

返回：
如果光标指向开始标记，则返回 true，否则返回 false

isEndElement

boolean isEndElement()
如果光标指向结束标记，则返回 true（否则返回 false）

返回：
如果光标指向结束标记，则返回 true，否则返回 false

isCharacters

boolean isCharacters()
如果光标指向字符数据事件，则返回 true

返回：
如果光标指向字符数据，则返回 true，否则返回 false

isWhiteSpace

boolean isWhiteSpace()
如果光标指向由所有空格组成的字符数据事件，则返回 true

返回：
如果光标指向所有空格，则返回 true，否则返回 false

getAttributeValue

String getAttributeValue(String namespaceURI,
                         String localName)
返回带有名称空间和 localName 的属性的规范化属性值。如果 namespaceURI 为 null，则名称空间不进行相等性检查

参数：
namespaceURI - 属性的名称空间
localName - 属性的本地名称，不可以为 null
返回：
返回属性的值，如果未找到，则返回 null
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 ATTRIBUTE

getAttributeCount

int getAttributeCount()
返回此 START_ELEMENT 中的属性计数，此方法仅对 START_ELEMENT 或 ATTRIBUTE 有效。此计数不包括名称空间定义。属性索引从零开始。

返回：
返回属性数
抛出：
IllegalStateException - 如果这不是 START_ELEMENT 或 ATTRIBUTE

getAttributeName

QName getAttributeName(int index)
返回所提供索引处的属性的 qname

参数：
index - 属性的位置
返回：
属性的 QName
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 ATTRIBUTE

getAttributeNamespace

String getAttributeNamespace(int index)
返回所提供索引处的属性的名称空间

参数：
index - 属性的位置
返回：
名称空间 URI（可以为 null）
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 ATTRIBUTE

getAttributeLocalName

String getAttributeLocalName(int index)
返回所提供索引处的属性的 localName

参数：
index - 属性的位置
返回：
属性的 localName
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 ATTRIBUTE

getAttributePrefix

String getAttributePrefix(int index)
返回所提供索引处的属性的前缀

参数：
index - 属性的位置
返回：
属性的前缀
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 ATTRIBUTE

getAttributeType

String getAttributeType(int index)
返回所提供索引处的属性的 XML 类型

参数：
index - 属性的位置
返回：
属性的 XML 类型
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 ATTRIBUTE

getAttributeValue

String getAttributeValue(int index)
返回 index 处的属性值

参数：
index - 属性的位置
返回：
属性值
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 ATTRIBUTE

isAttributeSpecified

boolean isAttributeSpecified(int index)
返回一个 boolean 值，它指示此属性是否为默认创建的

参数：
index - 属性的位置
返回：
如果这是一个默认属性，则返回 true
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 ATTRIBUTE

getNamespaceCount

int getNamespaceCount()
返回在 START_ELEMENT 或 END_ELEMENT 中声明的名称空间的计数，此方法仅对 START_ELEMENT、END_ELEMENT 或 NAMESPACE 有效。对于 END_ELEMENT，计数是最大的名称空间范围。它等同于 SAX 回调所报告的有关结束元素事件的信息。

返回：
返回此特定元素中的名称空间声明数
抛出：
IllegalStateException - 如果不是 START_ELEMENT、END_ELEMENT 或 NAMESPACE

getNamespacePrefix

String getNamespacePrefix(int index)
返回在 index 处声明的名称空间前缀。如果是默认名称空间声明，则返回 null

参数：
index - 名称空间声明的位置
返回：
返回名称空间前缀
抛出：
IllegalStateException - 如果不是 START_ELEMENT、END_ELEMENT 或 NAMESPACE

getNamespaceURI

String getNamespaceURI(int index)
返回在 index 处声明的名称空间 URI。

参数：
index - 名称空间声明的位置
返回：
返回名称空间 URI
抛出：
IllegalStateException - 如果不是 START_ELEMENT、END_ELEMENT 或 NAMESPACE

getNamespaceContext

NamespaceContext getNamespaceContext()
返回当前位置的只读名称空间上下文。上下文为 transient，只在调用 next() 更改 reader 的状态之前才有效。

返回：
返回名称空间上下文

getEventType

int getEventType()
返回一个整数码，指示光标所指向的事件的类型。

getText

String getText()
以字符串的形式返回解析事件的当前值，此方法返回 CHARACTERS 事件的字符串值，返回 COMMENT 的值、ENTITY_REFERENCE 的替代值、CDATA 节的字符串值、SPACE 事件的字符串值、DTD 内部子集的字符串值。如果已经解析了 ENTITY_REFERENCE，则所有字符数据都将被报告为 CHARACTERS 事件。

返回：
当前文本或 null
抛出：
IllegalStateException - 如果此状态不是有效的文本状态。

getTextCharacters

char[] getTextCharacters()
返回一个包含此事件中字符的数组。此数组应被视为只读的和 transient，即在 XMLStreamReader 移动到下一个事件之前，数组将包含文本字符。试图在超出该时间范围后保存到字符数组，或者试图修改数组的内容，这些都是违背此接口约定的行为。

返回：
当前文本或空数组
抛出：
IllegalStateException - 如果此状态不是有效的文本状态。

getTextCharacters

int getTextCharacters(int sourceStart,
                      char[] target,
                      int targetStart,
                      int length)
                      throws XMLStreamException
获取与 CHARACTERS、SPACE 或 CDATA 事件关联的文本。以 "sourceStart" 开始的文本被复制到以 "targetStart" 开始的 "target" 中。最多复制 "length" 个字符。返回实际复制的字符数。 "sourceStart" 参数必须大于等于 0 且小于等于与事件关联的字符数。通常，一个请求文本以 "sourceStart" 为 0 开始。如果实际复制的字符数小于 "length"，则表示没有更多的文本。否则，在检索完所有文本之前，需要进行后续的调用。例如：
int length = 1024; char[] myBuffer = new char[ length ];

for ( int sourceStart = 0 ; ; sourceStart += length ) { int nCopied = stream.getTextCharacters( sourceStart, myBuffer, 0, length );

if (nCopied < length) break; }
 如果在底层源中存在任何 XML 错误，则抛出 XMLStreamException。"targetStart" 参数必须大于等于 0 且小于 "target" 的长度，Length 必须大于 0，而 "targetStart + length" 必须小于等于 "target" 的长度。

参数：
sourceStart - 要复制的源数组中第一个字符的索引
target - 目标数组
targetStart - 目标数组中的起始偏移量
length - 要复制的字符数
返回：
实际复制的字符数
抛出：
XMLStreamException - 如果底层 XML 源不是格式良好的
IndexOutOfBoundsException - 如果 targetStart < 0 或 > 目标长度
IndexOutOfBoundsException - 如果 length < 0 或 targetStart + length > 目标长度
UnsupportedOperationException - 如果此方法不受支持
NullPointerException - 如果目标为 null

getTextStart

int getTextStart()
返回存储（此文本事件的）第一个字符位置处的文本字符数组的偏移量。

抛出：
IllegalStateException - 如果此状态不是有效的文本状态。

getTextLength

int getTextLength()
返回文本字符数组中此文本事件的字符序列长度。

抛出：
IllegalStateException - 如果此状态不是有效的文本状态。

getEncoding

String getEncoding()
如果输入编码已知，则返回输入编码；如果未知，则返回 null。

返回：
此实例的编码或 null

hasText

boolean hasText()
如果当前事件具有文本，则返回 true，否则返回 false。以下事件具有文本：CHARACTERS、DTD、ENTITY_REFERENCE、COMMENT、SPACE

getLocation

Location getLocation()
返回处理器的当前位置。如果 Location 未知，则处理器应返回 Location 的实现，该实现对位置返回 -1，对 publicId 和 systemId 返回 null。位置信息仅在调用 next() 之前有效。

getName

QName getName()
返回当前 START_ELEMENT 或 END_ELEMENT 事件的 QName

返回：
当前 START_ELEMENT 或 END_ELEMENT 事件的 QName
抛出：
IllegalStateException - 如果不是 START_ELEMENT 或 END_ELEMENT

getLocalName

String getLocalName()
返回当前事件的（本地）名称。对于 START_ELEMENT 或 END_ELEMENT，返回当前元素的（本地）名称。对于 ENTITY_REFERENCE，返回实体名称。当前事件必须是 START_ELEMENT、END_ELEMENT 或 ENTITY_REFERENCE

返回：
localName
抛出：
IllegalStateException - 如果不是 START_ELEMENT、END_ELEMENT 或 ENTITY_REFERENCE

hasName

boolean hasName()
如果当前事件有名称（是 START_ELEMENT 或 END_ELEMENT），则返回 ture，否则返回 false

getNamespaceURI

String getNamespaceURI()
如果当前事件是 START_ELEMENT 或 END_ELEMENT，则此方法返回前缀的 URI 或默认名称空间。如果事件没有前缀，则返回 null。

返回：
绑定到此元素前缀的 URI、默认名称空间或 null

getPrefix

String getPrefix()
返回当前事件的前缀，如果事件没有前缀，则返回 null

返回：
前缀或 null

getVersion

String getVersion()
获取在 xml 声明中声明的 xml 版本，如果没有声明版本，则返回 null

返回：
XML 版本或 null

isStandalone

boolean isStandalone()
获取 xml 声明中的独立声明

返回：
如果是独立的，则返回 true，否则返回 false

standaloneSet

boolean standaloneSet()
检查文档中是否设置了独立

返回：
如果文档中设置了独立，则返回 true，否则返回 false

getCharacterEncodingScheme

String getCharacterEncodingScheme()
返回 xml 声明中声明的字符编码。如果没有声明字符编码，则返回 null

返回：
在文档中声明的编码或 null

getPITarget

String getPITarget()
获取处理指令的目标

返回：
目标或 null

getPIData

String getPIData()
获取处理指令的数据节

返回：
数据或 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLStreamWriter (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream
接口 XMLStreamWriter

public interface XMLStreamWriter

XMLStreamWriter 接口指定如何编写 XML。XMLStreamWriter 不在其输入中检查格式是否良好。但是，writeCharacters 方法需要转义属性值的 &、< 和 >。writeAttribute 方法将转义上述字符以及 "，以确保所有字符内容和属性值都是格式良好的。 必须单独编写每个 NAMESPACE 和 ATTRIBUTE。

XML Namespaces、javax.xml.stream.isRepairingNamespaces 和写入方法行为
方法 | isRepairingNamespaces == true | isRepairingNamespaces == false
namespaceURI 绑定 | namespaceURI 未绑定 | namespaceURI 绑定 | namespaceURI 未绑定
writeAttribute(namespaceURI, localName, value) | prefix:localName="value" [1] | xmlns:{generated}="namespaceURI" {generated}:localName="value" | prefix:localName="value" [1] | XMLStreamException
writeAttribute(prefix, namespaceURI, localName, value) 绑定到相同的前缀：
prefix:localName="value" [1]

绑定到不同的前缀：
xmlns:{generated}="namespaceURI" {generated}:localName="value" 		xmlns:prefix="namespaceURI" prefix:localName="value" [3] 绑定到相同的前缀：
prefix:localName="value" [1][2]

绑定到不同的前缀：
XMLStreamException[2] 		xmlns:prefix="namespaceURI" prefix:localName="value" [2][5]
writeStartElement(namespaceURI, localName)

writeEmptyElement(namespaceURI, localName) 		<prefix:localName> [1] <{generated}:localName xmlns:{generated}="namespaceURI"> <prefix:localName> [1] XMLStreamException
writeStartElement(prefix, localName, namespaceURI)

writeEmptyElement(prefix, localName, namespaceURI) 		绑定到相同的前缀：
<prefix:localName> [1]

绑定到不同的前缀：
<{generated}:localName xmlns:{generated}="namespaceURI"> 		<prefix:localName xmlns:prefix="namespaceURI"> [4] 绑定到相同的前缀：
<prefix:localName> [1]

绑定到不同的前缀：
XMLStreamException 		<prefix:localName>
注：
  • [1] 如果 namespaceURI == default Namespace URI，则不写入任何前缀
  • [2] 如果 prefix == "" || null && namespaceURI == ""，则不生成或写入任何前缀或 Namespace 声明
  • [3] 如果 prefix == "" || null，则随机生成前缀
  • [4] 如果 prefix == "" || null，则将其视为默认 Namespace，且不生成或写入任何前缀，如果 namespaceURI 是未绑定的，则生成并写入一个 xmlns 声明
  • [5] 如果 prefix == "" || null，则试图定义默认 Namespace 将被视为无效，且将抛出 XMLStreamException

从以下版本开始：
1.6
另请参见：
XMLOutputFactory, XMLStreamReader

方法摘要
void | close() 关闭此 writer 并释放与 writer 关联的所有资源。
void | flush() 将所有缓存数据写入底层输出机制。
NamespaceContext | getNamespaceContext() 返回当前名称空间上下文。
String | getPrefix(String uri) 获取绑定 URI 的前缀
Object | getProperty(String name) 从底层实现获取功能/属性值
void | setDefaultNamespace(String uri) 将 URI 绑定到默认名称空间。
void | setNamespaceContext(NamespaceContext context) 设置前缀和 URI 绑定的当前名称空间上下文。
void | setPrefix(String prefix, String uri) 设置绑定 URI 的前缀。
void | writeAttribute(String localName, String value) 向输出流写入一个不带前缀的属性。
void | writeAttribute(String namespaceURI, String localName, String value) 向输出流写入一个属性
void | writeAttribute(String prefix, String namespaceURI, String localName, String value) 向输出流写入一个属性
void | writeCData(String data) 编写 CData 节
void | writeCharacters(char[] text, int start, int len) 向输出写入文本
void | writeCharacters(String text) 向输出写入文本
void | writeComment(String data) 编写一个包含数据的 XML 注释
void | writeDefaultNamespace(String namespaceURI) 向流写入默认名称空间
void | writeDTD(String dtd) 编写 DTD 节。
void | writeEmptyElement(String localName) 向输出写入一个空元素标记
void | writeEmptyElement(String namespaceURI, String localName) 向输出写入一个空元素标记
void | writeEmptyElement(String prefix, String localName, String namespaceURI) 向输出写入一个空元素标记
void | writeEndDocument() 关闭所有开始标记并写入相应的结束标记。
void | writeEndElement() 向依赖于 writer 内部状态的输出写入一个结束标记，以此确定事件的前缀和本地名称。
void | writeEntityRef(String name) 编写一个实体引用
void | writeNamespace(String prefix, String namespaceURI) 向输出流写入一个名称空间。
void | writeProcessingInstruction(String target) 编写一条处理指令
void | writeProcessingInstruction(String target, String data) 编写一条处理指令
void | writeStartDocument() 编写 XML 声明。
void | writeStartDocument(String version) 编写 XML 声明。
void | writeStartDocument(String encoding, String version) 编写 XML 声明。
void | writeStartElement(String localName) 向输出写入一个开始标记。
void | writeStartElement(String namespaceURI, String localName) 向输出写入一个开始标记
void | writeStartElement(String prefix, String localName, String namespaceURI) 向输出写入一个开始标记

方法详细信息

writeStartElement

void writeStartElement(String localName)
                       throws XMLStreamException
向输出写入一个开始标记。所有 writeStartElement 方法都在内部名称空间上下文中打开一个新的作用域。编写相应的 EndElement 导致作用域被关闭。

参数：
localName - 标记的本地名称，不可以为 null
抛出：
XMLStreamException

writeStartElement

void writeStartElement(String namespaceURI,
                       String localName)
                       throws XMLStreamException
向输出写入一个开始标记

参数：
namespaceURI - 要使用的前缀的 namespaceURI ，不可以为 null
localName - 标记的本地名称，不可以为 null
抛出：
XMLStreamException - 如果名称空间 URI 未绑定到前缀并且 javax.xml.stream.isRepairingNamespaces 未设置为 true

writeStartElement

void writeStartElement(String prefix,
                       String localName,
                       String namespaceURI)
                       throws XMLStreamException
向输出写入一个开始标记

参数：
localName - 标记的本地名称，不可以为 null
prefix - 标记的前缀，不可以为 null
namespaceURI - 要绑定前缀的 URI，不可以为 null
抛出：
XMLStreamException

writeEmptyElement

void writeEmptyElement(String namespaceURI,
                       String localName)
                       throws XMLStreamException
向输出写入一个空元素标记

参数：
namespaceURI - 要绑定标记的 URI，不可以为 null
localName - 标记的本地名称，不可以为 null
抛出：
XMLStreamException - 如果名称空间 URI 未绑定到前缀并且 javax.xml.stream.isRepairingNamespaces 未设置为 true

writeEmptyElement

void writeEmptyElement(String prefix,
                       String localName,
                       String namespaceURI)
                       throws XMLStreamException
向输出写入一个空元素标记

参数：
prefix - 标记的前缀，不可以为 null
localName - 标记的本地名称，不可以为 null
namespaceURI - 要绑定标记的 URI，不可以为 null
抛出：
XMLStreamException

writeEmptyElement

void writeEmptyElement(String localName)
                       throws XMLStreamException
向输出写入一个空元素标记

参数：
localName - 标记的本地名称，不可以为 null
抛出：
XMLStreamException

writeEndElement

void writeEndElement()
                     throws XMLStreamException
向依赖于 writer 内部状态的输出写入一个结束标记，以此确定事件的前缀和本地名称。

抛出：
XMLStreamException

writeEndDocument

void writeEndDocument()
                      throws XMLStreamException
关闭所有开始标记并写入相应的结束标记。

抛出：
XMLStreamException

close

void close()
           throws XMLStreamException
关闭此 writer 并释放与 writer 关联的所有资源。此方法不得关闭底层输出流。

抛出：
XMLStreamException

flush

void flush()
           throws XMLStreamException
将所有缓存数据写入底层输出机制。

抛出：
XMLStreamException

writeAttribute

void writeAttribute(String localName,
                    String value)
                    throws XMLStreamException
向输出流写入一个不带前缀的属性。

参数：
localName - 属性的本地名称
value - 属性的值
抛出：
IllegalStateException - 如果当前状态不允许 Attribute 写入
XMLStreamException

writeAttribute

void writeAttribute(String prefix,
                    String namespaceURI,
                    String localName,
                    String value)
                    throws XMLStreamException
向输出流写入一个属性

参数：
prefix - 此属性的前缀
namespaceURI - 此属性前缀的 URI
localName - 属性的本地名称
value - 属性的值
抛出：
IllegalStateException - 如果当前状态不允许 Attribute 写入
XMLStreamException - 如果名称空间 URI 未绑定到前缀且 javax.xml.stream.isRepairingNamespaces 未设置为 true

writeAttribute

void writeAttribute(String namespaceURI,
                    String localName,
                    String value)
                    throws XMLStreamException
向输出流写入一个属性

参数：
namespaceURI - 此属性前缀的 URI
localName - 属性的本地名称
value - 属性的值
抛出：
IllegalStateException - 如果当前状态不允许 Attribute 写入
XMLStreamException - 如果名称空间 URI 未绑定到前缀且 javax.xml.stream.isRepairingNamespaces 未设置为 true

writeNamespace

void writeNamespace(String prefix,
                    String namespaceURI)
                    throws XMLStreamException
向输出流写入一个名称空间。如果此方法的 prefix 参数为空字符串、"xmlns" 或 null，则此方法将委托给 writeDefaultNamespace。

参数：
prefix - 要绑定名称空间的前缀
namespaceURI - 要绑定前缀的 URI
抛出：
IllegalStateException - 如果当前状态不允许 Namespace 写入
XMLStreamException

writeDefaultNamespace

void writeDefaultNamespace(String namespaceURI)
                           throws XMLStreamException
向流写入默认名称空间

参数：
namespaceURI - 要绑定默认名称空间的 URI
抛出：
IllegalStateException - 如果当前状态不允许 Namespace 写入
XMLStreamException

writeComment

void writeComment(String data)
                  throws XMLStreamException
编写一个包含数据的 XML 注释

参数：
data - 包含在注释中的数据，可以为 null
抛出：
XMLStreamException

writeProcessingInstruction

void writeProcessingInstruction(String target)
                                throws XMLStreamException
编写一条处理指令

参数：
target - 处理指令的目标，不可以为 null
抛出：
XMLStreamException

writeProcessingInstruction

void writeProcessingInstruction(String target,
                                String data)
                                throws XMLStreamException
编写一条处理指令

参数：
target - 处理指令的目标，不可以为 null
data - 处理指令中包含的数据，不可以为 null
抛出：
XMLStreamException

writeCData

void writeCData(String data)
                throws XMLStreamException
编写 CData 节

参数：
data - CData 节中包含的数据，不可以为 null
抛出：
XMLStreamException

writeDTD

void writeDTD(String dtd)
              throws XMLStreamException
编写 DTD 节。此字符串代表 XML 1.0 规范的整个 doctypedecl 产品。

参数：
dtd - 要编写的 DTD
抛出：
XMLStreamException

writeEntityRef

void writeEntityRef(String name)
                    throws XMLStreamException
编写一个实体引用

参数：
name - 实体的名称
抛出：
XMLStreamException

writeStartDocument

void writeStartDocument()
                        throws XMLStreamException
编写 XML 声明。默认 XML 版本为 1.0，默认编码为 utf-8

抛出：
XMLStreamException

writeStartDocument

void writeStartDocument(String version)
                        throws XMLStreamException
编写 XML 声明。默认 XML 版本为 1.0

参数：
version - xml 文档的版本
抛出：
XMLStreamException

writeStartDocument

void writeStartDocument(String encoding,
                        String version)
                        throws XMLStreamException
编写 XML 声明。注意，编码参数不能设置底层输出的实际编码。它必须在使用 XMLOutputFactory 创建 XMLStreamWriter 实例时进行设置

参数：
encoding - XML 声明的编码
version - XML 文档的版本
抛出：
XMLStreamException - 如果给定编码与底层流的编码不匹配

writeCharacters

void writeCharacters(String text)
                     throws XMLStreamException
向输出写入文本

参数：
text - 要写入的值
抛出：
XMLStreamException

writeCharacters

void writeCharacters(char[] text,
                     int start,
                     int len)
                     throws XMLStreamException
向输出写入文本

参数：
text - 要写入的值
start - 数组中的起始位置
len - 要写入的字符数
抛出：
XMLStreamException

getPrefix

String getPrefix(String uri)
                 throws XMLStreamException
获取绑定 URI 的前缀

返回：
前缀或 null
抛出：
XMLStreamException

setPrefix

void setPrefix(String prefix,
               String uri)
               throws XMLStreamException
设置绑定 URI 的前缀。前缀在当前 START_ELEMENT / END_ELEMENT 对的范围内绑定。如果在写入 START_ELEMENT 之前调用此方法，则前缀在根范围内绑定。

参数：
prefix - 要绑定到 URI 的前缀，不可以为 null
uri - 要绑定到前缀的 URI，不可以为 null
抛出：
XMLStreamException

setDefaultNamespace

void setDefaultNamespace(String uri)
                         throws XMLStreamException
将 URI 绑定到默认名称空间。此 URI 在当前 START_ELEMENT / END_ELEMENT 对的范围内绑定。如果在写入 START_ELEMENT 之前调用此方法，则 URI 在根范围内绑定。

参数：
uri - 要绑定到默认名称空间的 URI，不可以为 null
抛出：
XMLStreamException

setNamespaceContext

void setNamespaceContext(NamespaceContext context)
                         throws XMLStreamException
设置前缀和 URI 绑定的当前名称空间上下文。此上下文成为用于写入的根名称空间上下文，并将替换当前的根名称空间上下文。通过将传递到此方法的上下文用作解析名称空间的根上下文，对 setPrefix 和 setDefaultNamespace 的后续调用将绑定名称空间。此方法只能在文档开始处调用一次。这不会导致名称空间被声明。如果在名称空间上下文中存在前缀映射关系的名称空间 URI，则它将被视为已经声明，并且该前缀可以被 StreamWriter 使用。

参数：
context - 将用于此 writer 的名称空间上下文，不可以为 null
抛出：
XMLStreamException

getNamespaceContext

NamespaceContext getNamespaceContext()
返回当前名称空间上下文。

返回：
当前 NamespaceContext

getProperty

Object getProperty(String name)
                   throws IllegalArgumentException
从底层实现获取功能/属性值

参数：
name - 属性的名称，不可以为 null
返回：
属性的值
抛出：
IllegalArgumentException - 如果属性不受支持
NullPointerException - 如果名称为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.stream (Java Platform SE 6)

 javax.xml.stream
接口
EventFilter
Location
StreamFilter
XMLEventReader
XMLEventWriter
XMLReporter
XMLResolver
XMLStreamConstants
XMLStreamReader
XMLStreamWriter
类
XMLEventFactory
XMLInputFactory
XMLOutputFactory
异常
XMLStreamException
错误
FactoryConfigurationError


javax.xml.stream (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.stream

接口摘要
EventFilter | 此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLEventReader。
Location | 提供有关事件位置的信息。
StreamFilter | 此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLStreamReader。
XMLEventReader | 此类是用于解析 XML 事件的顶层接口。
XMLEventWriter | 此类是用于编写 XML 文档的顶层接口。
XMLReporter | 此接口用于报告非严重错误。
XMLResolver | 此接口用于在 XML 解析过程中解析资源。
XMLStreamConstants | 此接口声明此 API 中所使用的常量。
XMLStreamReader | XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。
XMLStreamWriter | XMLStreamWriter 接口指定如何编写 XML。

类摘要
XMLEventFactory | 此接口定义一个创建 XMLEvent 实例的实用工具类。
XMLInputFactory | 定义用于获取流的工厂的抽象实现。
XMLOutputFactory | 定义用于获取 XMLEventWriter 和 XMLStreamWriter 的工厂抽象实现。

异常摘要
XMLStreamException 用于不可预料处理错误的基本异常。

错误摘要
FactoryConfigurationError 一个用于报告工厂配置错误的错误类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.stream 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.stream 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.stream.FactoryConfigurationError
      • java.lang.Exception
        • javax.xml.stream.XMLStreamException
    • javax.xml.stream.XMLEventFactory
    • javax.xml.stream.XMLInputFactory
    • javax.xml.stream.XMLOutputFactory

接口分层结构

  • javax.xml.stream.EventFilter
  • java.util.Iterator<E>
    • javax.xml.stream.XMLEventReader
  • javax.xml.stream.Location
  • javax.xml.stream.StreamFilter
  • javax.xml.stream.util.XMLEventConsumer
    • javax.xml.stream.XMLEventWriter
  • javax.xml.stream.XMLReporter
  • javax.xml.stream.XMLResolver
  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.XMLStreamReader
  • javax.xml.stream.XMLStreamWriter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.stream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.stream
的使用

使用 javax.xml.stream 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 使用的 javax.xml.stream 中的类
XMLEventReader
此类是用于解析 XML 事件的顶层接口。
XMLEventWriter
此类是用于编写 XML 文档的顶层接口。
XMLStreamReader
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。
XMLStreamWriter
XMLStreamWriter 接口指定如何编写 XML。

javax.xml.bind.helpers 使用的 javax.xml.stream 中的类
XMLEventReader
此类是用于解析 XML 事件的顶层接口。
XMLEventWriter
此类是用于编写 XML 文档的顶层接口。
XMLStreamReader
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。
XMLStreamWriter
XMLStreamWriter 接口指定如何编写 XML。

javax.xml.stream 使用的 javax.xml.stream 中的类
EventFilter
此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLEventReader。
FactoryConfigurationError
一个用于报告工厂配置错误的错误类。
Location
提供有关事件位置的信息。
StreamFilter
此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLStreamReader。
XMLEventFactory
此接口定义一个创建 XMLEvent 实例的实用工具类。
XMLEventReader
此类是用于解析 XML 事件的顶层接口。
XMLEventWriter
此类是用于编写 XML 文档的顶层接口。
XMLInputFactory
定义用于获取流的工厂的抽象实现。
XMLOutputFactory
定义用于获取 XMLEventWriter 和 XMLStreamWriter 的工厂抽象实现。
XMLReporter
此接口用于报告非严重错误。
XMLResolver
此接口用于在 XML 解析过程中解析资源。
XMLStreamConstants
此接口声明此 API 中所使用的常量。
XMLStreamException
用于不可预料处理错误的基本异常。
XMLStreamReader
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。
XMLStreamWriter
XMLStreamWriter 接口指定如何编写 XML。

javax.xml.stream.events 使用的 javax.xml.stream 中的类
Location
提供有关事件位置的信息。
XMLStreamConstants
此接口声明此 API 中所使用的常量。
XMLStreamException
用于不可预料处理错误的基本异常。

javax.xml.stream.util 使用的 javax.xml.stream 中的类
Location
提供有关事件位置的信息。
XMLEventReader
此类是用于解析 XML 事件的顶层接口。
XMLStreamConstants
此接口声明此 API 中所使用的常量。
XMLStreamException
用于不可预料处理错误的基本异常。
XMLStreamReader
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。

javax.xml.transform.stax 使用的 javax.xml.stream 中的类
XMLEventReader
此类是用于解析 XML 事件的顶层接口。
XMLEventWriter
此类是用于编写 XML 文档的顶层接口。
XMLStreamException
用于不可预料处理错误的基本异常。
XMLStreamReader
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。
XMLStreamWriter
XMLStreamWriter 接口指定如何编写 XML。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Attribute (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 Attribute

所有超级接口：
XMLEvent, XMLStreamConstants
所有已知子接口：
Namespace
public interface Attribute
extends XMLEvent

包含关于属性信息的接口。这些属性被报告为可从 StartElement 访问的事件的集合。其他应用程序可能将属性报告为一阶事件，例如作为 XPath 表达式的结果。

从以下版本开始：
1.6
另请参见：
StartElement

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
String | getDTDType() 获取此属性的类型，默认值是字符串 "CDATA"，
QName | getName() 返回此属性的 QName。
String | getValue() 获取此属性的标准化值。
boolean | isSpecified() 一个标志，用于指示此属性实际上是在其元素的开始标记中指定的，还是在模式中默认指定的。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getName

QName getName()
返回此属性的 QName。

getValue

String getValue()
获取此属性的标准化值。

getDTDType

String getDTDType()
获取此属性的类型，默认值是字符串 "CDATA"，

返回：
字符串形式的类型，默认值为 "CDATA"

isSpecified

boolean isSpecified()
一个标志，用于指示此属性实际上是在其元素的开始标记中指定的，还是在模式中默认指定的。

返回：
如果该属性是在开始元素中指定的，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Characters (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 Characters

所有超级接口：
XMLEvent, XMLStreamConstants
public interface Characters
extends XMLEvent

此方法将描述 Characters 事件的接口。所有文本事件都被报告为 Characters 事件。内容、CData 和空格都被报告为 Characters 事件。在大多数情况下，IgnorableWhitespace 被设置为 false，除非元素内容的声明是用于当前元素的。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
String | getData() 获取此事件的字符数据。
boolean | isCData() 如果它是一个 CData 节，则返回 true。
boolean | isIgnorableWhiteSpace() 如果它是 ignorableWhiteSpace，则返回 ture。
boolean | isWhiteSpace() 如果此 Characters 集合中都是空格，则返回 true。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getData

String getData()
获取此事件的字符数据。

isWhiteSpace

boolean isWhiteSpace()
如果此 Characters 集合中都是空格，则返回 true。文档内的空格报告为 CHARACTERS。此方法允许查看 CHARACTERS 事件是否只由空格组成。

isCData

boolean isCData()
如果它是一个 CData 节，则返回 true。如果此事件是 CData，则其事件类型为 CDATA。 如果将 javax.xml.stream.isCoalescing 设置为 true，则由非 CDATA 字符包围的 CDATA 节将被报告为单个字符事件。这种情况下，此方法将返回 false。

isIgnorableWhiteSpace

boolean isIgnorableWhiteSpace()
如果它是 ignorableWhiteSpace，则返回 ture。如果此事件是 ignorableWhiteSpace，则其事件类型为 SPACE。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Comment (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 Comment

所有超级接口：
XMLEvent, XMLStreamConstants
public interface Comment
extends XMLEvent

注释事件的接口。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
 String getText()
返回注释的字符串数据，如果不存在这样的数据，则返回空字符串。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getText

String getText()
返回注释的字符串数据，如果不存在这样的数据，则返回空字符串。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DTD (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 DTD

所有超级接口：
XMLEvent, XMLStreamConstants
public interface DTD
extends XMLEvent

它是处理 DTD 的事件的顶层接口。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
String | getDocumentTypeDeclaration() 以字符串形式返回完整文档类型声明，其中包括内部 DTD 子集。
List | getEntities() 返回一个列表，其中包含在 DTD 中声明的外部和内部常规实体。
List | getNotations() 返回一个 List，其中包含在 DTD 中声明的注释。
Object | getProcessedDTD() 返回定义 DTD 表示形式的实现。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getDocumentTypeDeclaration

String getDocumentTypeDeclaration()
以字符串形式返回完整文档类型声明，其中包括内部 DTD 子集。如果没有内部子集，则返回 null。如果该字符串不为 null，则它必须返回与 XML 1.0 规范中的 doctypedecl 产品匹配的完整文档类型声明。

getProcessedDTD

Object getProcessedDTD()
返回定义 DTD 表示形式的实现。如果没有可用的表示形式，则此方法返回 null。

getNotations

List getNotations()
返回一个 List，其中包含在 DTD 中声明的注释。此列表必须包含 NotationDeclaration 事件。

返回：
NotationDeclaration 事件的无序列表
另请参见：
NotationDeclaration

getEntities

List getEntities()
返回一个列表，其中包含在 DTD 中声明的外部和内部常规实体。此列表必须包含 EntityDeclaration 事件。

返回：
EntityDeclaration 事件的无序列表
另请参见：
EntityDeclaration
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EndDocument (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 EndDocument

所有超级接口：
XMLEvent, XMLStreamConstants
public interface EndDocument
extends XMLEvent

文档结尾的标记接口。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EndElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 EndElement

所有超级接口：
XMLEvent, XMLStreamConstants
public interface EndElement
extends XMLEvent

结束元素事件的接口。EndElement 报告文档中的每个结束标记。

从以下版本开始：
1.6
另请参见：
XMLEvent

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
QName | getName() 获取此事件的名称
Iterator | getNamespaces() 返回超出范围名称空间的 Iterator。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getName

QName getName()
获取此事件的名称

返回：
此事件的限定名

getNamespaces

Iterator getNamespaces()
返回超出范围名称空间的 Iterator。如果没有超出范围的名称空间，则返回一个空迭代器。

返回：
在 Namespace 接口上进行迭代的 Iterator，或者空迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EntityDeclaration (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 EntityDeclaration

所有超级接口：
XMLEvent, XMLStreamConstants
public interface EntityDeclaration
extends XMLEvent

处理实体声明的接口。 此接口用于记录和报告未解析的实体声明。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
String | getBaseURI() 获取此引用的基准 URI，如果此信息不可用，则获得 null
String | getName() 实体的名称
String | getNotationName() 关联的注释的名称。
String | getPublicId() 实体的公共标识符，如果未给定该标识符，则为 null
String | getReplacementText() 实体的替换文本。
String | getSystemId() 实体的系统标识符。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getPublicId

String getPublicId()
实体的公共标识符，如果未给定该标识符，则为 null

返回：
此声明的公共 ID 或 null

getSystemId

String getSystemId()
实体的系统标识符。

返回：
此声明的系统 ID 或 null

getName

String getName()
实体的名称

返回：
名称，不可以为 null

getNotationName

String getNotationName()
关联的注释的名称。

返回：
注释的名称

getReplacementText

String getReplacementText()
实体的替换文本。如果该实体是一个内部实体，则此方法只返回非 null 结果。

返回：
null 或替换文本

getBaseURI

String getBaseURI()
获取此引用的基准 URI，如果此信息不可用，则获得 null

返回：
基准 URI 或 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EntityReference (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 EntityReference

所有超级接口：
XMLEvent, XMLStreamConstants
public interface EntityReference
extends XMLEvent

处理实体事件的接口。 此事件报告尚未解析的实体并报告它们未处理的替换文本（如果可用）。如果将 javax.xml.stream.isReplacingEntityReferences 设置为 false，则报告此事件。如果将 javax.xml.stream.isReplacingEntityReferences 设置为 true，则将以透明的方式解析实体引用。 处理实体的方法有两种： (1)如果将 javax.xml.stream.isReplacingEntityReferences 设置为 true，则以透明的方式解析所有实体引用并将它们作为报告标记。(2)如果将 javax.xml.stream.isReplacingEntityReferences 设置为 false，则将实体引用作为 EntityReference 事件报告。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
EntityDeclaration | getDeclaration() 返回此实体的声明。
String | getName() 实体的名称
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getDeclaration

EntityDeclaration getDeclaration()
返回此实体的声明。

getName

String getName()
实体的名称

返回：
实体的名称，不可以为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Namespace (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 Namespace

所有超级接口：
Attribute, XMLEvent, XMLStreamConstants
public interface Namespace
extends Attribute

包含有关名称空间的信息的接口。 可以从 StartElement 访问名称空间。

从以下版本开始：
1.6
另请参见：
StartElement

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
String | getNamespaceURI() 获取绑定到此名称空间的前缀的 URI。
String | getPrefix() 获取前缀，如果它是默认名称空间声明，则返回 ""。
boolean | isDefaultNamespaceDeclaration() 如果此属性声明的是默认名称空间，则返回 true。
从接口 javax.xml.stream.events.Attribute 继承的方法
getDTDType, getName, getValue, isSpecified
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getPrefix

String getPrefix()
获取前缀，如果它是默认名称空间声明，则返回 ""。

getNamespaceURI

String getNamespaceURI()
获取绑定到此名称空间的前缀的 URI。

isDefaultNamespaceDeclaration

boolean isDefaultNamespaceDeclaration()
如果此属性声明的是默认名称空间，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotationDeclaration (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 NotationDeclaration

所有超级接口：
XMLEvent, XMLStreamConstants
public interface NotationDeclaration
extends XMLEvent

处理注释声明的接口。 接收注释声明事件的通知。这取决于用来记录以后参考的注释的应用程序，publicId 和 systemId 中至少有一个必须为非 null。不能保证任何未解析实体在使用注释声明之前都报告它。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
String | getName() 注释的名称。
String | getPublicId() 注释的公共标识符，如果未提供该标识符，则为 null。
String | getSystemId() 注释的系统标识符，如果未提供该标识符，则为 null。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getName

String getName()
注释的名称。

getPublicId

String getPublicId()
注释的公共标识符，如果未提供该标识符，则为 null。

getSystemId

String getSystemId()
注释的系统标识符，如果未提供该标识符，则为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProcessingInstruction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 ProcessingInstruction

所有超级接口：
XMLEvent, XMLStreamConstants
public interface ProcessingInstruction
extends XMLEvent

描述处理指令中的数据的接口。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
String | getData() 处理指令的数据部分。
String | getTarget() 处理指令的目标部分。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getTarget

String getTarget()
处理指令的目标部分。

返回：
PI 的字符串值或 null

getData

String getData()
处理指令的数据部分。

返回：
PI 数据的字符串值或 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StartDocument (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 StartDocument

所有超级接口：
XMLEvent, XMLStreamConstants
public interface StartDocument
extends XMLEvent

开始文档事件的接口。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
boolean | encodingSet() 如果在文档的编码声明中设置了 CharacterEncodingScheme，则返回 true。
String | getCharacterEncodingScheme() 返回 XML 数据的编码样式
String | getSystemId() 返回 XML 数据的系统 ID
String | getVersion() 返回此 XML 流的 XML 版本
boolean | isStandalone() 如果此 XML 是独立的，则返回 true。
boolean | standaloneSet() 如果在文档的编码声明中设置了单独属性，则返回 ture。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getSystemId

String getSystemId()
返回 XML 数据的系统 ID

返回：
系统ID，默认值为 ""

getCharacterEncodingScheme

String getCharacterEncodingScheme()
返回 XML 数据的编码样式

返回：
字符编码，默认值为 "UTF-8"

encodingSet

boolean encodingSet()
如果在文档的编码声明中设置了 CharacterEncodingScheme，则返回 true。

isStandalone

boolean isStandalone()
如果此 XML 是独立的，则返回 true。

返回：
XML 的独立状态，默认值为 "no"

standaloneSet

boolean standaloneSet()
如果在文档的编码声明中设置了单独属性，则返回 ture。

getVersion

String getVersion()
返回此 XML 流的 XML 版本

返回：
XML 的版本，默认值为 "1.0"
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StartElement (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 StartElement

所有超级接口：
XMLEvent, XMLStreamConstants
public interface StartElement
extends XMLEvent

StartElement 接口提供对有关开始元素的信息的访问。StartElement 报告文档中的每个开始标记。

从以下版本开始：
1.6

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
Attribute | getAttributeByName(QName name) 返回此名称引用的属性
Iterator | getAttributes() 返回在此 START_ELEMENT 上声明的已声明非名称空间属性的 Iterator；如果没有这样的属性，则返回空迭代器。
QName | getName() 获取此事件的名称
NamespaceContext | getNamespaceContext() 获取只读名称空间上下文。
Iterator | getNamespaces() 返回在此元素上声明的名称空间的 Iterator。
String | getNamespaceURI(String prefix) 获取绑定在此元素上下文中的前缀的值。
从接口 javax.xml.stream.events.XMLEvent 继承的方法
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

方法详细信息

getName

QName getName()
获取此事件的名称

返回：
此事件的限定名

getAttributes

Iterator getAttributes()
返回在此 START_ELEMENT 上声明的已声明非名称空间属性的 Iterator；如果没有这样的属性，则返回空迭代器。迭代器必须只包含 javax.xml.stream.Attribute 接口的实现。属性是完全无序的，且不能以任意顺序报告。

返回：
可在 Attribute 接口上进行迭代的只读 Iterator，或者返回空迭代器

getNamespaces

Iterator getNamespaces()
返回在此元素上声明的名称空间的 Iterator。此 Iterator 不包含以前声明的名称空间，除非它们出现在当前 START_ELEMENT 中。因此该列表可能包含重新声明的名称空间和重复的名称空间声明。使用 getNamespaceContext() 方法获取名称空间声明的当前上下文。

迭代器只能包含 javax.xml.stream.Namespace 接口的实现。

名称空间是一个属性。可以以属性列表的方式在名称空间列表上进行迭代。但是，此方法只返回在此 START_ELEMENT 中声明的名称空间的列表，不包含在此 START_ELEMENT 中声明的属性。 如果没有名称空间，则返回空迭代器。

返回：
可在名称空间接口上进行迭代的只读 Iterator，或者返回空迭代器

getAttributeByName

Attribute getAttributeByName(QName name)
返回此名称引用的属性

参数：
name - 所需名称的 qname
返回：
与名称值相对应的属性或 null

getNamespaceContext

NamespaceContext getNamespaceContext()
获取只读名称空间上下文。如果没有可用的上下文，此方法将返回空名称空间上下文。NamespaceContext 包含有关此 StartElement 的作用域中所有名称空间的信息。

返回：
当前名称空间上下文

getNamespaceURI

String getNamespaceURI(String prefix)
获取绑定在此元素上下文中的前缀的值。如果前缀未绑定在此上下文中，则返回 null

参数：
prefix - 要查找的前缀
返回：
绑定到前缀的 URI 或 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLEvent (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.events
接口 XMLEvent

所有超级接口：
XMLStreamConstants
所有已知子接口：
Attribute, Characters, Comment, DTD, EndDocument, EndElement, EntityDeclaration, EntityReference, Namespace, NotationDeclaration, ProcessingInstruction, StartDocument, StartElement
public interface XMLEvent
extends XMLStreamConstants

处理标记事件的基础事件接口。事件是用来与应用程序交流 XML 1.0 InfoSet 的 value 对象。可以在解析完事件之后缓存和引用事件。

从以下版本开始：
1.6
另请参见：
XMLEventReader, Characters, ProcessingInstruction, StartElement, EndElement, StartDocument, EndDocument, EntityReference, EntityDeclaration, NotationDeclaration

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
方法摘要
Characters | asCharacters() 将此事件作为 Characters 返回，如果此事件不是字符，则可能导致类强制转化异常。
EndElement | asEndElement() 将此事件作为结束元素事件返回，如果此事件不是结束元素，则可能导致类强制转换异常。
StartElement | asStartElement() 将此事件作为开始元素事件返回，如果此事件不是开始元素，则可能导致类强制转换异常。
int | getEventType() 返回此事件的整数码。
Location | getLocation() 返回此事件的位置。
QName | getSchemaType() 提供此方法是为了提供有关关联事件的可选类型信息。
boolean | isAttribute() 检查此事件是否为 Attribute 的实用工具函数。
boolean | isCharacters() 检查此事件是否为 Characters 的实用工具函数。
boolean | isEndDocument() 检查此事件是否为 EndDocument 的实用工具函数。
boolean | isEndElement() 检查此事件是否为 EndElement 的实用工具函数。
boolean | isEntityReference() 检查此事件是否为 EntityReference 的实用工具函数。
boolean | isNamespace() 检查此事件是否为 Namespace 的实用工具函数。
boolean | isProcessingInstruction() 检查此事件是否为 ProcessingInstruction 的实用工具函数。
boolean | isStartDocument() 检查此事件是否为 StartDocument 的实用工具函数。
boolean | isStartElement() 检查此事件是否为 StartElement 的实用工具函数。
void | writeAsEncodedUnicode(Writer writer) 此方法根据 XML 1.0 规范将 XMLEvent 编写为 Unicode 字符。

方法详细信息

getEventType

int getEventType()
返回此事件的整数码。

另请参见：
XMLStreamConstants.START_ELEMENT, XMLStreamConstants.END_ELEMENT, XMLStreamConstants.CHARACTERS, XMLStreamConstants.ATTRIBUTE, XMLStreamConstants.NAMESPACE, XMLStreamConstants.PROCESSING_INSTRUCTION, XMLStreamConstants.COMMENT, XMLStreamConstants.START_DOCUMENT, XMLStreamConstants.END_DOCUMENT, XMLStreamConstants.DTD

getLocation

Location getLocation()
返回此事件的位置。此方法返回的 Location 是不易改变的，将保留其信息。

另请参见：
Location

isStartElement

boolean isStartElement()
检查此事件是否为 StartElement 的实用工具函数。

另请参见：
StartElement

isAttribute

boolean isAttribute()
检查此事件是否为 Attribute 的实用工具函数。

另请参见：
Attribute

isNamespace

boolean isNamespace()
检查此事件是否为 Namespace 的实用工具函数。

另请参见：
Namespace

isEndElement

boolean isEndElement()
检查此事件是否为 EndElement 的实用工具函数。

另请参见：
EndElement

isEntityReference

boolean isEntityReference()
检查此事件是否为 EntityReference 的实用工具函数。

另请参见：
EntityReference

isProcessingInstruction

boolean isProcessingInstruction()
检查此事件是否为 ProcessingInstruction 的实用工具函数。

另请参见：
ProcessingInstruction

isCharacters

boolean isCharacters()
检查此事件是否为 Characters 的实用工具函数。

另请参见：
Characters

isStartDocument

boolean isStartDocument()
检查此事件是否为 StartDocument 的实用工具函数。

另请参见：
StartDocument

isEndDocument

boolean isEndDocument()
检查此事件是否为 EndDocument 的实用工具函数。

另请参见：
EndDocument

asStartElement

StartElement asStartElement()
将此事件作为开始元素事件返回，如果此事件不是开始元素，则可能导致类强制转换异常。

asEndElement

EndElement asEndElement()
将此事件作为结束元素事件返回，如果此事件不是结束元素，则可能导致类强制转换异常。

asCharacters

Characters asCharacters()
将此事件作为 Characters 返回，如果此事件不是字符，则可能导致类强制转化异常。

getSchemaType

QName getSchemaType()
提供此方法是为了提供有关关联事件的可选类型信息。信息是可选的，如果没有可用信息，则返回 null。

writeAsEncodedUnicode

void writeAsEncodedUnicode(Writer writer)
                           throws XMLStreamException
此方法根据 XML 1.0 规范将 XMLEvent 编写为 Unicode 字符。不应输出缩排或空格。 在将任何用户定义的事件类型写入输出流时，都应当调用此方法。内置 Event 类型必须实现此方法，但是在将内置 Event 写出到输出流时，为了优化目的，可以选择而不调用这些方法。生成的输出必须与所表示的信息集等效。

参数：
writer - 将输出数据的编写器
抛出：
XMLStreamException - 如果在写入事件时发生严重错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.stream.events (Java Platform SE 6)

 javax.xml.stream.events
接口
Attribute
Characters
Comment
DTD
EndDocument
EndElement
EntityDeclaration
EntityReference
Namespace
NotationDeclaration
ProcessingInstruction
StartDocument
StartElement
XMLEvent


javax.xml.stream.events (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.stream.events

接口摘要
Attribute | 包含关于属性信息的接口。
Characters | 此方法将描述 Characters 事件的接口。
Comment | 注释事件的接口。
DTD | 它是处理 DTD 的事件的顶层接口。
EndDocument | 文档结尾的标记接口。
EndElement | 结束元素事件的接口。
EntityDeclaration | 处理实体声明的接口。
EntityReference | 处理实体事件的接口。
Namespace | 包含有关名称空间的信息的接口。
NotationDeclaration | 处理注释声明的接口。
ProcessingInstruction | 描述处理指令中的数据的接口。
StartDocument | 开始文档事件的接口。
StartElement | StartElement 接口提供对有关开始元素的信息的访问。
XMLEvent | 处理标记事件的基础事件接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.stream.events 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.stream.events 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.events.XMLEvent
      • javax.xml.stream.events.Attribute
        • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.Characters
      • javax.xml.stream.events.Comment
      • javax.xml.stream.events.DTD
      • javax.xml.stream.events.EndDocument
      • javax.xml.stream.events.EndElement
      • javax.xml.stream.events.EntityDeclaration
      • javax.xml.stream.events.EntityReference
      • javax.xml.stream.events.NotationDeclaration
      • javax.xml.stream.events.ProcessingInstruction
      • javax.xml.stream.events.StartDocument
      • javax.xml.stream.events.StartElement
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.stream.events 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.stream.events
的使用

使用 javax.xml.stream.events 的软件包
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util

javax.xml.stream 使用的 javax.xml.stream.events 中的类
Attribute
包含关于属性信息的接口。
Characters
此方法将描述 Characters 事件的接口。
Comment
注释事件的接口。
DTD
它是处理 DTD 的事件的顶层接口。
EndDocument
文档结尾的标记接口。
EndElement
结束元素事件的接口。
EntityDeclaration
处理实体声明的接口。
EntityReference
处理实体事件的接口。
Namespace
包含有关名称空间的信息的接口。
ProcessingInstruction
描述处理指令中的数据的接口。
StartDocument
开始文档事件的接口。
StartElement
StartElement 接口提供对有关开始元素的信息的访问。
XMLEvent
处理标记事件的基础事件接口。

javax.xml.stream.events 使用的 javax.xml.stream.events 中的类
Attribute
包含关于属性信息的接口。
Characters
此方法将描述 Characters 事件的接口。
EndElement
结束元素事件的接口。
EntityDeclaration
处理实体声明的接口。
StartElement
StartElement 接口提供对有关开始元素的信息的访问。
XMLEvent
处理标记事件的基础事件接口。

javax.xml.stream.util 使用的 javax.xml.stream.events 中的类
XMLEvent
处理标记事件的基础事件接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.Attribute 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.Attribute
的使用

使用 Attribute 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 Attribute 的使用

返回 Attribute 的 javax.xml.stream 中的方法
abstract Attribute | XMLEventFactory.createAttribute(QName name, String value) 创建一个新 Attribute。
abstract Attribute | XMLEventFactory.createAttribute(String localName, String value) 创建一个新 Attribute。
abstract Attribute | XMLEventFactory.createAttribute(String prefix, String namespaceURI, String localName, String value) 创建一个新 Attribute。

javax.xml.stream.events 中 Attribute 的使用

javax.xml.stream.events 中 Attribute 的子接口
 interface Namespace
包含有关名称空间的信息的接口。

返回 Attribute 的 javax.xml.stream.events 中的方法
 Attribute StartElement.getAttributeByName(QName name)
返回此名称引用的属性

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.Characters 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.Characters
的使用

使用 Characters 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 Characters 的使用

返回 Characters 的 javax.xml.stream 中的方法
abstract Characters | XMLEventFactory.createCData(String content) 创建一个 CData 标记设置为 true 的 Character 事件。
abstract Characters | XMLEventFactory.createCharacters(String content) 创建一个 Character 事件，此方法不检查内容是否全部为空白。
abstract Characters | XMLEventFactory.createIgnorableSpace(String content) 创建一个可忽略的空间。
abstract Characters | XMLEventFactory.createSpace(String content) 创建一个 isSpace 标记设置为 true 的 Character 事件。

javax.xml.stream.events 中 Characters 的使用

返回 Characters 的 javax.xml.stream.events 中的方法
 Characters XMLEvent.asCharacters()
将此事件作为 Characters 返回，如果此事件不是字符，则可能导致类强制转化异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.Comment 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.Comment
的使用

使用 Comment 的软件包
javax.xml.stream

javax.xml.stream 中 Comment 的使用

返回 Comment 的 javax.xml.stream 中的方法
abstract  Comment XMLEventFactory.createComment(String text)
创建一个注释。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.DTD 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.DTD
的使用

使用 DTD 的软件包
javax.xml.stream

javax.xml.stream 中 DTD 的使用

返回 DTD 的 javax.xml.stream 中的方法
abstract  DTD XMLEventFactory.createDTD(String dtd)
创建一个文档类型定义事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.EndDocument 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.EndDocument
的使用

使用 EndDocument 的软件包
javax.xml.stream

javax.xml.stream 中 EndDocument 的使用

返回 EndDocument 的 javax.xml.stream 中的方法
abstract  EndDocument XMLEventFactory.createEndDocument()
创建一个 EndDocument 事件的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.EndElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.EndElement
的使用

使用 EndElement 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 EndElement 的使用

返回 EndElement 的 javax.xml.stream 中的方法
abstract EndElement | XMLEventFactory.createEndElement(QName name, Iterator namespaces) 创建一个新 EndElement。
abstract EndElement | XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName) 创建一个新 EndElement。
abstract EndElement | XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces) 创建一个新 EndElement。

javax.xml.stream.events 中 EndElement 的使用

返回 EndElement 的 javax.xml.stream.events 中的方法
 EndElement XMLEvent.asEndElement()
将此事件作为结束元素事件返回，如果此事件不是结束元素，则可能导致类强制转换异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.EntityDeclaration 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.EntityDeclaration
的使用

使用 EntityDeclaration 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 EntityDeclaration 的使用

参数类型为 EntityDeclaration 的 javax.xml.stream 中的方法
abstract  EntityReference XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
创建一个 EntityReference 事件的新实例。

javax.xml.stream.events 中 EntityDeclaration 的使用

返回 EntityDeclaration 的 javax.xml.stream.events 中的方法
 EntityDeclaration EntityReference.getDeclaration()
返回此实体的声明。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.EntityReference 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.EntityReference
的使用

使用 EntityReference 的软件包
javax.xml.stream

javax.xml.stream 中 EntityReference 的使用

返回 EntityReference 的 javax.xml.stream 中的方法
abstract  EntityReference XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
创建一个 EntityReference 事件的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.Namespace 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.Namespace
的使用

使用 Namespace 的软件包
javax.xml.stream

javax.xml.stream 中 Namespace 的使用

返回 Namespace 的 javax.xml.stream 中的方法
abstract Namespace | XMLEventFactory.createNamespace(String namespaceURI) 创建一个新的默认 Namespace。
abstract Namespace | XMLEventFactory.createNamespace(String prefix, String namespaceUri) 创建一个新的 Namespace。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.NotationDeclaration 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.NotationDeclaration
的使用

没有 javax.xml.stream.events.NotationDeclaration 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.ProcessingInstruction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.ProcessingInstruction
的使用

使用 ProcessingInstruction 的软件包
javax.xml.stream

javax.xml.stream 中 ProcessingInstruction 的使用

返回 ProcessingInstruction 的 javax.xml.stream 中的方法
abstract  ProcessingInstruction XMLEventFactory.createProcessingInstruction(String target, String data)
创建一个处理指令。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.StartDocument 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.StartDocument
的使用

使用 StartDocument 的软件包
javax.xml.stream

javax.xml.stream 中 StartDocument 的使用

返回 StartDocument 的 javax.xml.stream 中的方法
abstract StartDocument | XMLEventFactory.createStartDocument() 创建一个 StartDocument 事件的新实例。
abstract StartDocument | XMLEventFactory.createStartDocument(String encoding) 创建一个 StartDocument 事件的新实例。
abstract StartDocument | XMLEventFactory.createStartDocument(String encoding, String version) 创建一个 StartDocument 事件的新实例。
abstract StartDocument | XMLEventFactory.createStartDocument(String encoding, String version, boolean standalone) 创建一个 StartDocument 事件的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.StartElement 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.StartElement
的使用

使用 StartElement 的软件包
javax.xml.stream
javax.xml.stream.events

javax.xml.stream 中 StartElement 的使用

返回 StartElement 的 javax.xml.stream 中的方法
abstract StartElement | XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。

javax.xml.stream.events 中 StartElement 的使用

返回 StartElement 的 javax.xml.stream.events 中的方法
 StartElement XMLEvent.asStartElement()
将此事件作为开始元素事件返回，如果此事件不是开始元素，则可能导致类强制转换异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.events.XMLEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.events.XMLEvent
的使用

使用 XMLEvent 的软件包
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util

javax.xml.stream 中 XMLEvent 的使用

返回 XMLEvent 的 javax.xml.stream 中的方法
XMLEvent | XMLEventReader.nextEvent() 获取下一个 XMLEvent。
XMLEvent | XMLEventReader.nextTag() 在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。
XMLEvent | XMLEventReader.peek() 检查下一个 XMLEvent，但不从流中读取它。

参数类型为 XMLEvent 的 javax.xml.stream 中的方法
boolean | EventFilter.accept(XMLEvent event) 测试此事件是否为此流的一部分。
void | XMLEventWriter.add(XMLEvent event) 向输出流添加事件。

javax.xml.stream.events 中 XMLEvent 的使用

javax.xml.stream.events 中 XMLEvent 的子接口
interface | Attribute 包含关于属性信息的接口。
interface | Characters 此方法将描述 Characters 事件的接口。
interface | Comment 注释事件的接口。
interface | DTD 它是处理 DTD 的事件的顶层接口。
interface | EndDocument 文档结尾的标记接口。
interface | EndElement 结束元素事件的接口。
interface | EntityDeclaration 处理实体声明的接口。
interface | EntityReference 处理实体事件的接口。
interface | Namespace 包含有关名称空间的信息的接口。
interface | NotationDeclaration 处理注释声明的接口。
interface | ProcessingInstruction 描述处理指令中的数据的接口。
interface | StartDocument 开始文档事件的接口。
interface | StartElement StartElement 接口提供对有关开始元素的信息的访问。

javax.xml.stream.util 中 XMLEvent 的使用

返回 XMLEvent 的 javax.xml.stream.util 中的方法
XMLEvent | XMLEventAllocator.allocate(XMLStreamReader reader) 此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
XMLEvent | EventReaderDelegate.nextEvent()
XMLEvent | EventReaderDelegate.nextTag()
XMLEvent | EventReaderDelegate.peek()

参数类型为 XMLEvent 的 javax.xml.stream.util 中的方法
 void XMLEventConsumer.add(XMLEvent event)
此方法为使用者添加一个事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


EventReaderDelegate (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.util
类 EventReaderDelegate

java.lang.Object
    继承者  javax.xml.stream.util.EventReaderDelegate
所有已实现的接口：
Iterator, XMLEventReader
public class EventReaderDelegate
extends Object
implements XMLEventReader

该类是用于派生 XMLEventReader 过滤器的基类。 此类设计用于 XMLEventReader 和应用程序的 XMLEventReader 之间。默认情况下，每种方法除了调用父接口中的相应方法之外，不执行任何操作。

从以下版本开始：
1.6
另请参见：
XMLEventReader, StreamReaderDelegate

构造方法摘要
EventReaderDelegate()
构造没有父过滤器的空过滤器。
EventReaderDelegate(XMLEventReader reader)
用指定的父过滤器来构造一个过滤器。
方法摘要
void | close() 释放所有与此 Reader 关联的资源。
String | getElementText() 读取纯文本元素的内容。
XMLEventReader | getParent() 获取此实例的父实例。
Object | getProperty(String name) 从底层实现获取功能/属性值。
boolean | hasNext() 检查是否有多个事件。
Object | next() 返回迭代的下一个元素。
XMLEvent | nextEvent() 获取下一个 XMLEvent。
XMLEvent | nextTag() 在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。
XMLEvent | peek() 检查下一个 XMLEvent，但不从流中读取它。
void | remove() 从迭代器指向的 collection 中移除迭代器返回的最后一个元素（可选操作）。
void | setParent(XMLEventReader reader) 设置此实例的父实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventReaderDelegate

public EventReaderDelegate()
构造没有父过滤器的空过滤器。

EventReaderDelegate

public EventReaderDelegate(XMLEventReader reader)
用指定的父过滤器来构造一个过滤器。

参数：
reader - 父过滤器
方法详细信息

setParent

public void setParent(XMLEventReader reader)
设置此实例的父实例。

参数：
reader - 新的父实例

getParent

public XMLEventReader getParent()
获取此实例的父实例。

返回：
父实例；如果没有设置父实例，则返回 null

nextEvent

public XMLEvent nextEvent()
                   throws XMLStreamException
从接口 XMLEventReader 复制的描述
获取下一个 XMLEvent。

指定者：
接口 XMLEventReader 中的 nextEvent
抛出：
XMLStreamException - 如果底层 XML 存在错误。
另请参见：
XMLEvent

next

public Object next()
从接口 Iterator 复制的描述
返回迭代的下一个元素。

指定者：
接口 Iterator 中的 next
返回：
迭代的下一个元素。

hasNext

public boolean hasNext()
从接口 XMLEventReader 复制的描述
检查是否有多个事件。如果有多个事件，则返回 true，否则返回 false。

指定者：
接口 Iterator 中的 hasNext
指定者：
接口 XMLEventReader 中的 hasNext
返回：
如果事件 reader 具有多个事件，则返回 true，否则返回 false。

peek

public XMLEvent peek()
              throws XMLStreamException
从接口 XMLEventReader 复制的描述
检查下一个 XMLEvent，但不从流中读取它。如果流位于 EOF 处或者不再有 XMLEvent，则返回 null。调用 peek() 将相当于 next() 的下一个返回。

指定者：
接口 XMLEventReader 中的 peek
抛出：
XMLStreamException
另请参见：
XMLEvent

close

public void close()
           throws XMLStreamException
从接口 XMLEventReader 复制的描述
释放所有与此 Reader 关联的资源。此方法不会关闭底层输入源。

指定者：
接口 XMLEventReader 中的 close
抛出：
XMLStreamException - 如果释放关联资源时出现错误

getElementText

public String getElementText()
                      throws XMLStreamException
从接口 XMLEventReader 复制的描述
读取纯文本元素的内容。前置条件：当前事件是 START_ELEMENT。后置条件：当前事件是相应的 END_ELEMENT。

指定者：
接口 XMLEventReader 中的 getElementText
抛出：
XMLStreamException - 如果当前事件不是 START_ELEMENT 或者遇到了非文本元素

nextTag

public XMLEvent nextTag()
                 throws XMLStreamException
从接口 XMLEventReader 复制的描述
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。如果遇到空格符之外的其他内容，则抛出异常。在处理纯元素内容时应使用此方法，因为如果缺少 DTD 或未解释它，解析器将无法识别可忽略的空格。

指定者：
接口 XMLEventReader 中的 nextTag
抛出：
XMLStreamException - 如果遇到空格符之外的其他内容

getProperty

public Object getProperty(String name)
                   throws IllegalArgumentException
从接口 XMLEventReader 复制的描述
从底层实现获取功能/属性值。

指定者：
接口 XMLEventReader 中的 getProperty
参数：
name - 属性的名称
返回：
属性的值
抛出：
IllegalArgumentException - 如果属性不受支持

remove

public void remove()
从接口 Iterator 复制的描述
从迭代器指向的 collection 中移除迭代器返回的最后一个元素（可选操作）。每次调用 next 只能调用一次此方法。如果进行迭代时用调用此方法之外的其他方式修改了该迭代器所指向的 collection，则迭代器的行为是不确定的。

指定者：
接口 Iterator 中的 remove
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


StreamReaderDelegate (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.util
类 StreamReaderDelegate

java.lang.Object
    继承者  javax.xml.stream.util.StreamReaderDelegate
所有已实现的接口：
XMLStreamConstants, XMLStreamReader
public class StreamReaderDelegate
extends Object
implements XMLStreamReader

该类是用于派生 XMLStreamReader 过滤器的基类。 此类设计用于 XMLStreamReader 和应用程序的 XMLStreamReader 之间。默认情况下，每种方法除了调用父接口中的相应方法之外，不执行任何操作。

从以下版本开始：
1.6
另请参见：
XMLStreamReader, EventReaderDelegate

字段摘要
从接口 javax.xml.stream.XMLStreamConstants 继承的字段
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
构造方法摘要
StreamReaderDelegate()
构造没有父过滤器的空过滤器。
StreamReaderDelegate(XMLStreamReader reader)
用指定的父过滤器来构造一个过滤器。
方法摘要
 void close()
释放与此 Reader 关联的所有资源。
 int getAttributeCount()
返回此 START_ELEMENT 中的属性计数，此方法仅对 START_ELEMENT 或 ATTRIBUTE 有效。
 String getAttributeLocalName(int index)
返回所提供索引处的属性的 localName
 QName getAttributeName(int index)
返回所提供索引处的属性的 qname
 String getAttributeNamespace(int index)
返回所提供索引处的属性的名称空间
 String getAttributePrefix(int index)
返回所提供索引处的属性的前缀
 String getAttributeType(int index)
返回所提供索引处的属性的 XML 类型
 String getAttributeValue(int index)
返回 index 处的属性值
 String getAttributeValue(String namespaceUri, String localName)
返回带有名称空间和 localName 的属性的规范化属性值。
 String getCharacterEncodingScheme()
返回 xml 声明中声明的字符编码。
 String getElementText()
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。
 String getEncoding()
如果输入编码已知，则返回输入编码；如果未知，则返回 null。
 int getEventType()
返回一个整数码，指示光标所指向的事件的类型。
 String getLocalName()
返回当前事件的（本地）名称。
 Location getLocation()
返回处理器的当前位置。
 QName getName()
返回当前 START_ELEMENT 或 END_ELEMENT 事件的 QName
 NamespaceContext getNamespaceContext()
返回当前位置的只读名称空间上下文。
 int getNamespaceCount()
返回在 START_ELEMENT 或 END_ELEMENT 中声明的名称空间的计数，此方法仅对 START_ELEMENT、END_ELEMENT 或 NAMESPACE 有效。
 String getNamespacePrefix(int index)
返回在 index 处声明的名称空间前缀。
 String getNamespaceURI()
如果当前事件是 START_ELEMENT 或 END_ELEMENT，则此方法返回前缀的 URI 或默认名称空间。
 String getNamespaceURI(int index)
返回在 index 处声明的名称空间 URI。
 String getNamespaceURI(String prefix)
返回给定前缀的 URI。
 XMLStreamReader getParent()
获取此实例的父实例。
 String getPIData()
获取处理指令的数据节
 String getPITarget()
获取处理指令的目标
 String getPrefix()
返回当前事件的前缀，如果事件没有前缀，则返回 null
 Object getProperty(String name)
从底层实现获取功能/属性的值
 String getText()
以字符串的形式返回解析事件的当前值，此方法返回 CHARACTERS 事件的字符串值，返回 COMMENT 的值、ENTITY_REFERENCE 的替代值、CDATA 节的字符串值、SPACE 事件的字符串值、DTD 内部子集的字符串值。
 char[] getTextCharacters()
返回一个包含此事件中字符的数组。
 int getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
获取与 CHARACTERS、SPACE 或 CDATA 事件关联的文本。
 int getTextLength()
返回文本字符数组中此文本事件的字符序列长度。
 int getTextStart()
返回存储（此文本事件的）第一个字符位置处的文本字符数组的偏移量。
 String getVersion()
获取在 xml 声明中声明的 xml 版本，如果没有声明版本，则返回 null
 boolean hasName()
如果当前事件有名称（是 START_ELEMENT 或 END_ELEMENT），则返回 ture，否则返回 false
 boolean hasNext()
如果有多个解析事件，则返回 true，如果不再有事件，则返回 false。
 boolean hasText()
如果当前事件具有文本，则返回 true，否则返回 false。
 boolean isAttributeSpecified(int index)
返回一个 boolean 值，它指示此属性是否为默认创建的
 boolean isCharacters()
如果光标指向字符数据事件，则返回 true
 boolean isEndElement()
如果光标指向结束标记，则返回 true（否则返回 false）
 boolean isStandalone()
获取 xml 声明中的独立声明
 boolean isStartElement()
如果光标指向开始标记，则返回 true（否则返回 false）
 boolean isWhiteSpace()
如果光标指向由所有空格组成的字符数据事件，则返回 true
 int next()
获取下一个解析事件??处理器可以用单个存储块返回所有连续的字符数据，它也可以将其分割成几个存储块。
 int nextTag()
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有空格（isWhiteSpace() 返回 true）、COMMENT 或 PROCESSING_INSTRUCTION。
 void require(int type, String namespaceURI, String localName)
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。
 void setParent(XMLStreamReader reader)
设置此实例的父实例。
 boolean standaloneSet()
检查文档中是否设置了独立
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StreamReaderDelegate

public StreamReaderDelegate()
构造没有父过滤器的空过滤器。

StreamReaderDelegate

public StreamReaderDelegate(XMLStreamReader reader)
用指定的父过滤器来构造一个过滤器。

参数：
reader - 父过滤器
方法详细信息

setParent

public void setParent(XMLStreamReader reader)
设置此实例的父实例。

参数：
reader - 新的父实例

getParent

public XMLStreamReader getParent()
获取此实例的父实例。

返回：
父实例；如果没有设置父实例，则返回 null

next

public int next()
         throws XMLStreamException
从接口 XMLStreamReader 复制的描述
获取下一个解析事件??处理器可以用单个存储块返回所有连续的字符数据，它也可以将其分割成几个存储块。如果属性 javax.xml.stream.isCoalescing 设置为 true，则元素内容必须组合，对于连续元素内容或 CDATA 节，只需要返回一个 CHARACTERS 事件。 默认情况下，必须扩展实体引用，并透明地报告给应用程序。如果实体引用不能扩展，则抛出异常。如果元素内容为空（即内容为 ""），则不报告 CHARACTERS 事件。

假设给定以下 XML：
<foo><!--description-->内容文本<![CDATA[<greeting>Hello</greeting>]]>其他内容</foo>
对 foo 调用 next() 的行为将是：
1- 注释 (COMMENT)
2- 然后是字符节 (CHARACTERS)
3- 接下来是 CDATA 节（另一个 CHARACTERS）
4- 再接下来是下一个字符节 （另一个 CHARACTERS）
5- 最后是 END_ELEMENT

注： 空元素（如 <tag/>）将用以下两个单独的事件报告：START_ELEMENT 和 END_ELEMENT??这保证了空元素对 <tag></tag> 解析的等效性。 如果是在 hasNext() 返回 false 之后调用此方法，则此方法将抛出 IllegalStateException。

指定者：
接口 XMLStreamReader 中的 next
返回：
与当前解析事件相对应的整数码
抛出：
XMLStreamException - 如果处理底层 XML 源时发生错误
另请参见：
XMLEvent

nextTag

public int nextTag()
            throws XMLStreamException
从接口 XMLStreamReader 复制的描述
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有空格（isWhiteSpace() 返回 true）、COMMENT 或 PROCESSING_INSTRUCTION。如果遇到空格字符、COMMENT、PROCESSING_INSTRUCTION、START_ELEMENT、END_ELEMENT 以外的其他内容，则抛出异常。在处理以空格分隔的纯元素内容时，应使用此方法。
前置条件：无
后置条件：当前事件为 START_ELEMENT 或 END_ELEMENT，并且光标已经移到任何空格事件上。
它实际上执行下列操作（实现可以随意优化，但必须执行等效处理）：
int eventType = next();
while((eventType == XMLStreamConstants.CHARACTERS && isWhiteSpace()) // skip whitespace
|| (eventType == XMLStreamConstants.CDATA && isWhiteSpace())
// skip whitespace
|| eventType == XMLStreamConstants.SPACE
|| eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
|| eventType == XMLStreamConstants.COMMENT
 ) {
eventType = next();
 }
if (eventType != XMLStreamConstants.START_ELEMENT && eventType != XMLStreamConstants.END_ELEMENT) {
throw new String XMLStreamException("expected start or end tag", getLocation());
 }
return eventType;

指定者：
接口 XMLStreamReader 中的 nextTag
返回：
元素读取的事件类型（START_ELEMENT 或 END_ELEMENT）
抛出：
XMLStreamException - 如果当前事件不是空格、PROCESSING_INSTRUCTION、START_ELEMENT 或 END_ELEMENT

getElementText

public String getElementText()
                      throws XMLStreamException
从接口 XMLStreamReader 复制的描述
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。无论 javax.xml.stream.isCoalescing 的值如何，此方法始终返回组合的内容。
前置条件：当前事件是 START_ELEMENT。
后置条件：当前事件是相应的 END_ELEMENT。
此方法执行下列操作（实现可以随意优化，但必须执行等效处理）：
if(getEventType() != XMLStreamConstants.START_ELEMENT) {
throw new XMLStreamException(
"parser must be on START_ELEMENT to read next text", getLocation());
 }
int eventType = next();
StringBuffer content = new StringBuffer();
while(eventType != XMLStreamConstants.END_ELEMENT ) {
if(eventType == XMLStreamConstants.CHARACTERS
|| eventType == XMLStreamConstants.CDATA
|| eventType == XMLStreamConstants.SPACE
|| eventType == XMLStreamConstants.ENTITY_REFERENCE) {
buf.append(getText());
} else if(eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
|| eventType == XMLStreamConstants.COMMENT) {
// skipping
} else if(eventType == XMLStreamConstants.END_DOCUMENT) {
throw new XMLStreamException(
"unexpected end of document when reading element text content", this);
} else if(eventType == XMLStreamConstants.START_ELEMENT) {
throw new XMLStreamException(
"element text content may not contain START_ELEMENT", getLocation());
} else {
throw new XMLStreamException(
"Unexpected event type "+eventType, getLocation());
 }
eventType = next();
 }
return buf.toString();

指定者：
接口 XMLStreamReader 中的 getElementText
抛出：
XMLStreamException - 如果当前事件不是 START_ELEMENT 或者遇到了非文本元素

require

public void require(int type,
                    String namespaceURI,
                    String localName)
             throws XMLStreamException
从接口 XMLStreamReader 复制的描述
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。如果 namespaceURI 为 null，则该参数不进行相等性检查；如果 localName 为 null，则该参数不进行相等性检查。

指定者：
接口 XMLStreamReader 中的 require
参数：
type - 事件类型
namespaceURI - 事件的 URI，可以为 null
localName - 事件的 localName，可以为 null
抛出：
XMLStreamException - 如果所需值不匹配。

hasNext

public boolean hasNext()
                throws XMLStreamException
从接口 XMLStreamReader 复制的描述
如果有多个解析事件，则返回 true，如果不再有事件，则返回 false。如果 XMLStreamReader 的当前状态为 END_DOCUMENT，则此方法返回 false

指定者：
接口 XMLStreamReader 中的 hasNext
返回：
如果有多个事件，则返回 true，否则返回 false
抛出：
XMLStreamException - 如果检测下一个状态时发生严重错误

close

public void close()
           throws XMLStreamException
从接口 XMLStreamReader 复制的描述
释放与此 Reader 关联的所有资源。此方法不会关闭底层输入源。

指定者：
接口 XMLStreamReader 中的 close
抛出：
XMLStreamException - 如果释放关联资源时发生错误

getNamespaceURI

public String getNamespaceURI(String prefix)
从接口 XMLStreamReader 复制的描述
返回给定前缀的 URI。返回的 URI 取决于处理器的当前状态。

注：根据 Namespaces in XML 规范中的定义，'xml' 前缀被绑定到 "http://www.w3.org/XML/1998/namespace"。

注：'xmlns' 前缀必须被解析到以下名称空间：http://www.w3.org/2000/xmlns/

指定者：
接口 XMLStreamReader 中的 getNamespaceURI
参数：
prefix - 要查找的前缀，不可以为 null
返回：
绑定到给定前缀的 URI，如果未绑定，则返回 null

getNamespaceContext

public NamespaceContext getNamespaceContext()
从接口 XMLStreamReader 复制的描述
返回当前位置的只读名称空间上下文。上下文为 transient，只在调用 next() 更改 reader 的状态之前才有效。

指定者：
接口 XMLStreamReader 中的 getNamespaceContext
返回：
返回名称空间上下文

isStartElement

public boolean isStartElement()
从接口 XMLStreamReader 复制的描述
如果光标指向开始标记，则返回 true（否则返回 false）

指定者：
接口 XMLStreamReader 中的 isStartElement
返回：
如果光标指向开始标记，则返回 true，否则返回 false

isEndElement

public boolean isEndElement()
从接口 XMLStreamReader 复制的描述
如果光标指向结束标记，则返回 true（否则返回 false）

指定者：
接口 XMLStreamReader 中的 isEndElement
返回：
如果光标指向结束标记，则返回 true，否则返回 false

isCharacters

public boolean isCharacters()
从接口 XMLStreamReader 复制的描述
如果光标指向字符数据事件，则返回 true

指定者：
接口 XMLStreamReader 中的 isCharacters
返回：
如果光标指向字符数据，则返回 true，否则返回 false

isWhiteSpace

public boolean isWhiteSpace()
从接口 XMLStreamReader 复制的描述
如果光标指向由所有空格组成的字符数据事件，则返回 true

指定者：
接口 XMLStreamReader 中的 isWhiteSpace
返回：
如果光标指向所有空格，则返回 true，否则返回 false

getAttributeValue

public String getAttributeValue(String namespaceUri,
                                String localName)
从接口 XMLStreamReader 复制的描述
返回带有名称空间和 localName 的属性的规范化属性值。如果 namespaceURI 为 null，则名称空间不进行相等性检查

指定者：
接口 XMLStreamReader 中的 getAttributeValue
参数：
namespaceUri - 属性的名称空间
localName - 属性的本地名称，不可以为 null
返回：
返回属性的值，如果未找到，则返回 null

getAttributeCount

public int getAttributeCount()
从接口 XMLStreamReader 复制的描述
返回此 START_ELEMENT 中的属性计数，此方法仅对 START_ELEMENT 或 ATTRIBUTE 有效。此计数不包括名称空间定义。属性索引从零开始。

指定者：
接口 XMLStreamReader 中的 getAttributeCount
返回：
返回属性数

getAttributeName

public QName getAttributeName(int index)
从接口 XMLStreamReader 复制的描述
返回所提供索引处的属性的 qname

指定者：
接口 XMLStreamReader 中的 getAttributeName
参数：
index - 属性的位置
返回：
属性的 QName

getAttributePrefix

public String getAttributePrefix(int index)
从接口 XMLStreamReader 复制的描述
返回所提供索引处的属性的前缀

指定者：
接口 XMLStreamReader 中的 getAttributePrefix
参数：
index - 属性的位置
返回：
属性的前缀

getAttributeNamespace

public String getAttributeNamespace(int index)
从接口 XMLStreamReader 复制的描述
返回所提供索引处的属性的名称空间

指定者：
接口 XMLStreamReader 中的 getAttributeNamespace
参数：
index - 属性的位置
返回：
名称空间 URI（可以为 null）

getAttributeLocalName

public String getAttributeLocalName(int index)
从接口 XMLStreamReader 复制的描述
返回所提供索引处的属性的 localName

指定者：
接口 XMLStreamReader 中的 getAttributeLocalName
参数：
index - 属性的位置
返回：
属性的 localName

getAttributeType

public String getAttributeType(int index)
从接口 XMLStreamReader 复制的描述
返回所提供索引处的属性的 XML 类型

指定者：
接口 XMLStreamReader 中的 getAttributeType
参数：
index - 属性的位置
返回：
属性的 XML 类型

getAttributeValue

public String getAttributeValue(int index)
从接口 XMLStreamReader 复制的描述
返回 index 处的属性值

指定者：
接口 XMLStreamReader 中的 getAttributeValue
参数：
index - 属性的位置
返回：
属性值

isAttributeSpecified

public boolean isAttributeSpecified(int index)
从接口 XMLStreamReader 复制的描述
返回一个 boolean 值，它指示此属性是否为默认创建的

指定者：
接口 XMLStreamReader 中的 isAttributeSpecified
参数：
index - 属性的位置
返回：
如果这是一个默认属性，则返回 true

getNamespaceCount

public int getNamespaceCount()
从接口 XMLStreamReader 复制的描述
返回在 START_ELEMENT 或 END_ELEMENT 中声明的名称空间的计数，此方法仅对 START_ELEMENT、END_ELEMENT 或 NAMESPACE 有效。对于 END_ELEMENT，计数是最大的名称空间范围。它等同于 SAX 回调所报告的有关结束元素事件的信息。

指定者：
接口 XMLStreamReader 中的 getNamespaceCount
返回：
返回此特定元素中的名称空间声明数

getNamespacePrefix

public String getNamespacePrefix(int index)
从接口 XMLStreamReader 复制的描述
返回在 index 处声明的名称空间前缀。如果是默认名称空间声明，则返回 null

指定者：
接口 XMLStreamReader 中的 getNamespacePrefix
参数：
index - 名称空间声明的位置
返回：
返回名称空间前缀

getNamespaceURI

public String getNamespaceURI(int index)
从接口 XMLStreamReader 复制的描述
返回在 index 处声明的名称空间 URI。

指定者：
接口 XMLStreamReader 中的 getNamespaceURI
参数：
index - 名称空间声明的位置
返回：
返回名称空间 URI

getEventType

public int getEventType()
从接口 XMLStreamReader 复制的描述
返回一个整数码，指示光标所指向的事件的类型。

指定者：
接口 XMLStreamReader 中的 getEventType

getText

public String getText()
从接口 XMLStreamReader 复制的描述
以字符串的形式返回解析事件的当前值，此方法返回 CHARACTERS 事件的字符串值，返回 COMMENT 的值、ENTITY_REFERENCE 的替代值、CDATA 节的字符串值、SPACE 事件的字符串值、DTD 内部子集的字符串值。如果已经解析了 ENTITY_REFERENCE，则所有字符数据都将被报告为 CHARACTERS 事件。

指定者：
接口 XMLStreamReader 中的 getText
返回：
当前文本或 null

getTextCharacters

public int getTextCharacters(int sourceStart,
                             char[] target,
                             int targetStart,
                             int length)
                      throws XMLStreamException
从接口 XMLStreamReader 复制的描述
获取与 CHARACTERS、SPACE 或 CDATA 事件关联的文本。以 "sourceStart" 开始的文本被复制到以 "targetStart" 开始的 "target" 中。最多复制 "length" 个字符。返回实际复制的字符数。 "sourceStart" 参数必须大于等于 0 且小于等于与事件关联的字符数。通常，一个请求文本以 "sourceStart" 为 0 开始。如果实际复制的字符数小于 "length"，则表示没有更多的文本。否则，在检索完所有文本之前，需要进行后续的调用。例如：
int length = 1024; char[] myBuffer = new char[ length ];

for ( int sourceStart = 0 ; ; sourceStart += length ) { int nCopied = stream.getTextCharacters( sourceStart, myBuffer, 0, length );

if (nCopied < length) break; }
 如果在底层源中存在任何 XML 错误，则抛出 XMLStreamException。"targetStart" 参数必须大于等于 0 且小于 "target" 的长度，Length 必须大于 0，而 "targetStart + length" 必须小于等于 "target" 的长度。

指定者：
接口 XMLStreamReader 中的 getTextCharacters
参数：
sourceStart - 要复制的源数组中第一个字符的索引
target - 目标数组
targetStart - 目标数组中的起始偏移量
length - 要复制的字符数
返回：
实际复制的字符数
抛出：
XMLStreamException - 如果底层 XML 源不是格式良好的

getTextCharacters

public char[] getTextCharacters()
从接口 XMLStreamReader 复制的描述
返回一个包含此事件中字符的数组。此数组应被视为只读的和 transient，即在 XMLStreamReader 移动到下一个事件之前，数组将包含文本字符。试图在超出该时间范围后保存到字符数组，或者试图修改数组的内容，这些都是违背此接口约定的行为。

指定者：
接口 XMLStreamReader 中的 getTextCharacters
返回：
当前文本或空数组

getTextStart

public int getTextStart()
从接口 XMLStreamReader 复制的描述
返回存储（此文本事件的）第一个字符位置处的文本字符数组的偏移量。

指定者：
接口 XMLStreamReader 中的 getTextStart

getTextLength

public int getTextLength()
从接口 XMLStreamReader 复制的描述
返回文本字符数组中此文本事件的字符序列长度。

指定者：
接口 XMLStreamReader 中的 getTextLength

getEncoding

public String getEncoding()
从接口 XMLStreamReader 复制的描述
如果输入编码已知，则返回输入编码；如果未知，则返回 null。

指定者：
接口 XMLStreamReader 中的 getEncoding
返回：
此实例的编码或 null

hasText

public boolean hasText()
从接口 XMLStreamReader 复制的描述
如果当前事件具有文本，则返回 true，否则返回 false。以下事件具有文本：CHARACTERS、DTD、ENTITY_REFERENCE、COMMENT、SPACE

指定者：
接口 XMLStreamReader 中的 hasText

getLocation

public Location getLocation()
从接口 XMLStreamReader 复制的描述
返回处理器的当前位置。如果 Location 未知，则处理器应返回 Location 的实现，该实现对位置返回 -1，对 publicId 和 systemId 返回 null。位置信息仅在调用 next() 之前有效。

指定者：
接口 XMLStreamReader 中的 getLocation

getName

public QName getName()
从接口 XMLStreamReader 复制的描述
返回当前 START_ELEMENT 或 END_ELEMENT 事件的 QName

指定者：
接口 XMLStreamReader 中的 getName
返回：
当前 START_ELEMENT 或 END_ELEMENT 事件的 QName

getLocalName

public String getLocalName()
从接口 XMLStreamReader 复制的描述
返回当前事件的（本地）名称。对于 START_ELEMENT 或 END_ELEMENT，返回当前元素的（本地）名称。对于 ENTITY_REFERENCE，返回实体名称。当前事件必须是 START_ELEMENT、END_ELEMENT 或 ENTITY_REFERENCE

指定者：
接口 XMLStreamReader 中的 getLocalName
返回：
localName

hasName

public boolean hasName()
从接口 XMLStreamReader 复制的描述
如果当前事件有名称（是 START_ELEMENT 或 END_ELEMENT），则返回 ture，否则返回 false

指定者：
接口 XMLStreamReader 中的 hasName

getNamespaceURI

public String getNamespaceURI()
从接口 XMLStreamReader 复制的描述
如果当前事件是 START_ELEMENT 或 END_ELEMENT，则此方法返回前缀的 URI 或默认名称空间。如果事件没有前缀，则返回 null。

指定者：
接口 XMLStreamReader 中的 getNamespaceURI
返回：
绑定到此元素前缀的 URI、默认名称空间或 null

getPrefix

public String getPrefix()
从接口 XMLStreamReader 复制的描述
返回当前事件的前缀，如果事件没有前缀，则返回 null

指定者：
接口 XMLStreamReader 中的 getPrefix
返回：
前缀或 null

getVersion

public String getVersion()
从接口 XMLStreamReader 复制的描述
获取在 xml 声明中声明的 xml 版本，如果没有声明版本，则返回 null

指定者：
接口 XMLStreamReader 中的 getVersion
返回：
XML 版本或 null

isStandalone

public boolean isStandalone()
从接口 XMLStreamReader 复制的描述
获取 xml 声明中的独立声明

指定者：
接口 XMLStreamReader 中的 isStandalone
返回：
如果是独立的，则返回 true，否则返回 false

standaloneSet

public boolean standaloneSet()
从接口 XMLStreamReader 复制的描述
检查文档中是否设置了独立

指定者：
接口 XMLStreamReader 中的 standaloneSet
返回：
如果文档中设置了独立，则返回 true，否则返回 false

getCharacterEncodingScheme

public String getCharacterEncodingScheme()
从接口 XMLStreamReader 复制的描述
返回 xml 声明中声明的字符编码。如果没有声明字符编码，则返回 null

指定者：
接口 XMLStreamReader 中的 getCharacterEncodingScheme
返回：
在文档中声明的编码或 null

getPITarget

public String getPITarget()
从接口 XMLStreamReader 复制的描述
获取处理指令的目标

指定者：
接口 XMLStreamReader 中的 getPITarget
返回：
目标或 null

getPIData

public String getPIData()
从接口 XMLStreamReader 复制的描述
获取处理指令的数据节

指定者：
接口 XMLStreamReader 中的 getPIData
返回：
数据或 null

getProperty

public Object getProperty(String name)
从接口 XMLStreamReader 复制的描述
从底层实现获取功能/属性的值

指定者：
接口 XMLStreamReader 中的 getProperty
参数：
name - 属性的名称，不可以为 null
返回：
属性的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLEventAllocator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.util
接口 XMLEventAllocator

public interface XMLEventAllocator

此接口定义了一个类，该类允许用户注册给定 XMLStreamReader 的情况下分配事件的方式。实现不需要使用 XMLEventFactory 实现，但推荐这样做。可以使用属性 "javax.xml.stream.allocator" 在 XMLInputFactory 上设置 XMLEventAllocator。

从以下版本开始：
1.6
另请参见：
XMLInputFactory, XMLEventFactory

方法摘要
XMLEvent | allocate(XMLStreamReader reader) 此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
void | allocate(XMLStreamReader reader, XMLEventConsumer consumer) 此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。
XMLEventAllocator | newInstance() 此方法创建一个 XMLEventAllocator 实例。

方法详细信息

newInstance

XMLEventAllocator newInstance()
此方法创建一个 XMLEventAllocator 实例。它允许 XMLInputFactory 为每个 reader 分配一个新实例。

allocate

XMLEvent allocate(XMLStreamReader reader)
                  throws XMLStreamException
此方法在给定 XMLStreamReader 当前状态的情况下分配事件。如果此 XMLEventAllocator 在 reader 状态和事件之间不存在一对一的映射关系，则此方法将返回 null。此方法不能修改 XMLStreamReader 的状态。

参数：
reader - 作为分配根据的 XMLStreamReader
返回：
对应于当前 reader 状态的事件
抛出：
XMLStreamException

allocate

void allocate(XMLStreamReader reader,
              XMLEventConsumer consumer)
              throws XMLStreamException
此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。此方法可将 reader 状态展开或联系到事件状态中。此方法可修改 XMLStreamReader 的状态。

参数：
reader - 作为分配根据的 XMLStreamReader
consumer - 要添加事件的 XMLEventConsumer。
抛出：
XMLStreamException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLEventConsumer (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.xml.stream.util
接口 XMLEventConsumer

所有已知子接口：
XMLEventWriter
public interface XMLEventConsumer

此接口定义了一个事件使用者接口。使用者接口的协定将用于接受事件。此接口可用于将对象标记为可以接收事件。add 方法可能被连续调用几次，因此，使用者必须能够缓存尚未处理的事件。

从以下版本开始：
1.6

方法摘要
 void add(XMLEvent event)
此方法为使用者添加一个事件。

方法详细信息

add

void add(XMLEvent event)
         throws XMLStreamException
此方法为使用者添加一个事件。调用此方法会使 event 参数失效。客户端应用程序应该在调用 add 方法时放弃对此事件的所有引用。应用程序继续使用这些引用的行为是未定义的。

参数：
event - 要添加的事件，不可以为 null
抛出：
XMLStreamException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.xml.stream.util (Java Platform SE 6)

 javax.xml.stream.util
接口
XMLEventAllocator
XMLEventConsumer
类
EventReaderDelegate
StreamReaderDelegate


javax.xml.stream.util (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.xml.stream.util

接口摘要
XMLEventAllocator | 此接口定义了一个类，该类允许用户注册给定 XMLStreamReader 的情况下分配事件的方式。
XMLEventConsumer | 此接口定义了一个事件使用者接口。

类摘要
EventReaderDelegate | 该类是用于派生 XMLEventReader 过滤器的基类。
StreamReaderDelegate | 该类是用于派生 XMLStreamReader 过滤器的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.xml.stream.util 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.stream.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.xml.stream.util.EventReaderDelegate (implements javax.xml.stream.XMLEventReader)
    • javax.xml.stream.util.StreamReaderDelegate (implements javax.xml.stream.XMLStreamReader)

接口分层结构

  • javax.xml.stream.util.XMLEventAllocator
  • javax.xml.stream.util.XMLEventConsumer
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 javax.xml.stream.util 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.xml.stream.util
的使用

使用 javax.xml.stream.util 的软件包
javax.xml.stream
javax.xml.stream.util

javax.xml.stream 使用的 javax.xml.stream.util 中的类
XMLEventAllocator
此接口定义了一个类，该类允许用户注册给定 XMLStreamReader 的情况下分配事件的方式。
XMLEventConsumer
此接口定义了一个事件使用者接口。

javax.xml.stream.util 使用的 javax.xml.stream.util 中的类
XMLEventAllocator
此接口定义了一个类，该类允许用户注册给定 XMLStreamReader 的情况下分配事件的方式。
XMLEventConsumer
此接口定义了一个事件使用者接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.stream.util.EventReaderDelegate 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.util.EventReaderDelegate
的使用

没有 javax.xml.stream.util.EventReaderDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.stream.util.StreamReaderDelegate 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.util.StreamReaderDelegate
的使用

没有 javax.xml.stream.util.StreamReaderDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.util.XMLEventAllocator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.util.XMLEventAllocator
的使用

使用 XMLEventAllocator 的软件包
javax.xml.stream
javax.xml.stream.util

javax.xml.stream 中 XMLEventAllocator 的使用

返回 XMLEventAllocator 的 javax.xml.stream 中的方法
abstract  XMLEventAllocator XMLInputFactory.getEventAllocator()
获取用此工厂创建的流所使用的分配器。

参数类型为 XMLEventAllocator 的 javax.xml.stream 中的方法
abstract  void XMLInputFactory.setEventAllocator(XMLEventAllocator allocator)
为事件设置一个用户定义的事件分配器。

javax.xml.stream.util 中 XMLEventAllocator 的使用

返回 XMLEventAllocator 的 javax.xml.stream.util 中的方法
 XMLEventAllocator XMLEventAllocator.newInstance()
此方法创建一个 XMLEventAllocator 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.util.XMLEventConsumer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.util.XMLEventConsumer
的使用

使用 XMLEventConsumer 的软件包
javax.xml.stream
javax.xml.stream.util

javax.xml.stream 中 XMLEventConsumer 的使用

javax.xml.stream 中 XMLEventConsumer 的子接口
 interface XMLEventWriter
此类是用于编写 XML 文档的顶层接口。

javax.xml.stream.util 中 XMLEventConsumer 的使用

参数类型为 XMLEventConsumer 的 javax.xml.stream.util 中的方法
 void XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer)
此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.EventFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.EventFilter
的使用

使用 EventFilter 的软件包
javax.xml.stream

javax.xml.stream 中 EventFilter 的使用

参数类型为 EventFilter 的 javax.xml.stream 中的方法
abstract  XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
创建过滤的事件 reader，它用过滤器包装事件 reader。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.stream.FactoryConfigurationError 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.FactoryConfigurationError
的使用

使用 FactoryConfigurationError 的软件包
javax.xml.stream

javax.xml.stream 中 FactoryConfigurationError 的使用

抛出 FactoryConfigurationError 的 javax.xml.stream 中的方法
static XMLEventFactory | XMLEventFactory.newInstance() 创建一个新的工厂实例。
static XMLInputFactory | XMLInputFactory.newInstance() 创建一个新的工厂实例。
static XMLOutputFactory | XMLOutputFactory.newInstance() 创建一个新的工厂实例。
static XMLEventFactory | XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个的新工厂实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.Location 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.Location
的使用

使用 Location 的软件包
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util

javax.xml.stream 中 Location 的使用

声明为 Location 的 javax.xml.stream 中的字段
protected  Location XMLStreamException.location

返回 Location 的 javax.xml.stream 中的方法
Location | XMLStreamException.getLocation() 获取异常的位置
Location | XMLStreamReader.getLocation() 返回处理器的当前位置。

参数类型为 Location 的 javax.xml.stream 中的方法
void | XMLReporter.report(String message, String errorType, Object relatedInformation, Location location) 以特定于应用程序的格式报告所需消息。
abstract void | XMLEventFactory.setLocation(Location location) 此方法允许对此工厂创建的每个事件设置 Location。

参数类型为 Location 的 javax.xml.stream 中的构造方法
XMLStreamException(String msg, Location location)
构造具有关联消息、异常和位置的异常。
XMLStreamException(String msg, Location location, Throwable th)
构造具有关联消息、异常和位置的异常。

javax.xml.stream.events 中 Location 的使用

返回 Location 的 javax.xml.stream.events 中的方法
 Location XMLEvent.getLocation()
返回此事件的位置。

javax.xml.stream.util 中 Location 的使用

返回 Location 的 javax.xml.stream.util 中的方法
 Location StreamReaderDelegate.getLocation()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.StreamFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.StreamFilter
的使用

使用 StreamFilter 的软件包
javax.xml.stream

javax.xml.stream 中 StreamFilter 的使用

参数类型为 StreamFilter 的 javax.xml.stream 中的方法
abstract  XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
创建过滤的 reader，它用过滤器包装 reader。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.stream.XMLEventFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.XMLEventFactory
的使用

使用 XMLEventFactory 的软件包
javax.xml.stream

javax.xml.stream 中 XMLEventFactory 的使用

返回 XMLEventFactory 的 javax.xml.stream 中的方法
static XMLEventFactory | XMLEventFactory.newInstance() 创建一个新的工厂实例。
static XMLEventFactory | XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.XMLEventReader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLEventReader
的使用

使用 XMLEventReader 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.stream.util |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 中 XMLEventReader 的使用

参数类型为 XMLEventReader 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(XMLEventReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

javax.xml.bind.helpers 中 XMLEventReader 的使用

参数类型为 XMLEventReader 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)

javax.xml.stream 中 XMLEventReader 的使用

返回 XMLEventReader 的 javax.xml.stream 中的方法
abstract XMLEventReader | XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter) 创建过滤的事件 reader，它用过滤器包装事件 reader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(Source source) 根据 JAXP 源创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(String systemId, Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(XMLStreamReader reader) 根据 XMLStreamReader 创建一个新 XMLEventReader。

参数类型为 XMLEventReader 的 javax.xml.stream 中的方法
 void XMLEventWriter.add(XMLEventReader reader)
将整个流添加到输出流，在 hasNext() 返回 false 前对 inputStream 参数调用 next()。
abstract  XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
创建过滤的事件 reader，它用过滤器包装事件 reader。

javax.xml.stream.util 中 XMLEventReader 的使用

实现 XMLEventReader 的 javax.xml.stream.util 中的类
 class EventReaderDelegate
该类是用于派生 XMLEventReader 过滤器的基类。

返回 XMLEventReader 的 javax.xml.stream.util 中的方法
 XMLEventReader EventReaderDelegate.getParent()
获取此实例的父实例。

参数类型为 XMLEventReader 的 javax.xml.stream.util 中的方法
 void EventReaderDelegate.setParent(XMLEventReader reader)
设置此实例的父实例。

参数类型为 XMLEventReader 的 javax.xml.stream.util 中的构造方法
EventReaderDelegate(XMLEventReader reader)
用指定的父过滤器来构造一个过滤器。

javax.xml.transform.stax 中 XMLEventReader 的使用

返回 XMLEventReader 的 javax.xml.transform.stax 中的方法
 XMLEventReader StAXSource.getXMLEventReader()
获取此 StAXSource 使用的 XMLEventReader。

参数类型为 XMLEventReader 的 javax.xml.transform.stax 中的构造方法
StAXSource(XMLEventReader xmlEventReader)
通过提供 XMLEventReader 创建 StAXSource 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.XMLEventWriter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLEventWriter
的使用

使用 XMLEventWriter 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 中 XMLEventWriter 的使用

参数类型为 XMLEventWriter 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。

javax.xml.bind.helpers 中 XMLEventWriter 的使用

参数类型为 XMLEventWriter 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)

javax.xml.stream 中 XMLEventWriter 的使用

返回 XMLEventWriter 的 javax.xml.stream 中的方法
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(OutputStream stream) 创建一个写入到流的新 XMLEventWriter。
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLEventWriter。
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLEventWriter。
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(Writer stream) 创建一个写入到 writer 的新 XMLEventWriter。

javax.xml.transform.stax 中 XMLEventWriter 的使用

返回 XMLEventWriter 的 javax.xml.transform.stax 中的方法
 XMLEventWriter StAXResult.getXMLEventWriter()
获取此 StAXResult 使用的 XMLEventWriter。

参数类型为 XMLEventWriter 的 javax.xml.transform.stax 中的构造方法
StAXResult(XMLEventWriter xmlEventWriter)
通过提供 XMLEventWriter 创建 StAXResult 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.stream.XMLInputFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.XMLInputFactory
的使用

使用 XMLInputFactory 的软件包
javax.xml.stream

javax.xml.stream 中 XMLInputFactory 的使用

返回 XMLInputFactory 的 javax.xml.stream 中的方法
static XMLInputFactory | XMLInputFactory.newInstance() 创建一个新的工厂实例。
static XMLInputFactory | XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个的新工厂实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.stream.XMLOutputFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.XMLOutputFactory
的使用

使用 XMLOutputFactory 的软件包
javax.xml.stream

javax.xml.stream 中 XMLOutputFactory 的使用

返回 XMLOutputFactory 的 javax.xml.stream 中的方法
static XMLOutputFactory XMLOutputFactory.newInstance()
创建一个新的工厂实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.XMLReporter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLReporter
的使用

使用 XMLReporter 的软件包
javax.xml.stream

javax.xml.stream 中 XMLReporter 的使用

返回 XMLReporter 的 javax.xml.stream 中的方法
abstract  XMLReporter XMLInputFactory.getXMLReporter()
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。

参数类型为 XMLReporter 的 javax.xml.stream 中的方法
abstract  void XMLInputFactory.setXMLReporter(XMLReporter reporter)
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.XMLResolver 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLResolver
的使用

使用 XMLResolver 的软件包
javax.xml.stream

javax.xml.stream 中 XMLResolver 的使用

返回 XMLResolver 的 javax.xml.stream 中的方法
abstract  XMLResolver XMLInputFactory.getXMLResolver()
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。

参数类型为 XMLResolver 的 javax.xml.stream 中的方法
abstract  void XMLInputFactory.setXMLResolver(XMLResolver resolver)
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.XMLStreamConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLStreamConstants
的使用

使用 XMLStreamConstants 的软件包
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util

javax.xml.stream 中 XMLStreamConstants 的使用

javax.xml.stream 中 XMLStreamConstants 的子接口
 interface XMLStreamReader
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。

javax.xml.stream.events 中 XMLStreamConstants 的使用

javax.xml.stream.events 中 XMLStreamConstants 的子接口
interface | Attribute 包含关于属性信息的接口。
interface | Characters 此方法将描述 Characters 事件的接口。
interface | Comment 注释事件的接口。
interface | DTD 它是处理 DTD 的事件的顶层接口。
interface | EndDocument 文档结尾的标记接口。
interface | EndElement 结束元素事件的接口。
interface | EntityDeclaration 处理实体声明的接口。
interface | EntityReference 处理实体事件的接口。
interface | Namespace 包含有关名称空间的信息的接口。
interface | NotationDeclaration 处理注释声明的接口。
interface | ProcessingInstruction 描述处理指令中的数据的接口。
interface | StartDocument 开始文档事件的接口。
interface | StartElement StartElement 接口提供对有关开始元素的信息的访问。
interface | XMLEvent 处理标记事件的基础事件接口。

javax.xml.stream.util 中 XMLStreamConstants 的使用

实现 XMLStreamConstants 的 javax.xml.stream.util 中的类
 class StreamReaderDelegate
该类是用于派生 XMLStreamReader 过滤器的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.stream.XMLStreamException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.stream.XMLStreamException
的使用

使用 XMLStreamException 的软件包
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.stream 中 XMLStreamException 的使用

抛出 XMLStreamException 的 javax.xml.stream 中的方法
 void XMLEventWriter.add(XMLEvent event)
向输出流添加事件。
 void XMLEventWriter.add(XMLEventReader reader)
将整个流添加到输出流，在 hasNext() 返回 false 前对 inputStream 参数调用 next()。
 void XMLEventReader.close()
释放所有与此 Reader 关联的资源。
 void XMLEventWriter.close()
释放所有与此流关联的资源。
 void XMLStreamReader.close()
释放与此 Reader 关联的所有资源。
 void XMLStreamWriter.close()
关闭此 writer 并释放与 writer 关联的所有资源。
abstract  XMLEventReader XMLInputFactory.createFilteredReader(XMLEventReader reader, EventFilter filter)
创建过滤的事件 reader，它用过滤器包装事件 reader。
abstract  XMLStreamReader XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter)
创建过滤的 reader，它用过滤器包装 reader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream)
根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(InputStream stream, String encoding)
根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(Reader reader)
根据 reader 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(Source source)
根据 JAXP 源创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, InputStream stream)
根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(String systemId, Reader reader)
根据 reader 创建一个新 XMLEventReader。
abstract  XMLEventReader XMLInputFactory.createXMLEventReader(XMLStreamReader reader)
根据 XMLStreamReader 创建一个新 XMLEventReader。
abstract  XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream)
创建一个写入到流的新 XMLEventWriter。
abstract  XMLEventWriter XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding)
创建一个写入到流的新 XMLEventWriter。
abstract  XMLEventWriter XMLOutputFactory.createXMLEventWriter(Result result)
创建一个写入到 JAXP 结果的新 XMLEventWriter。
abstract  XMLEventWriter XMLOutputFactory.createXMLEventWriter(Writer stream)
创建一个写入到 writer 的新 XMLEventWriter。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream)
根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding)
根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(Reader reader)
根据 reader 创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(Source source)
根据 JAXP 源创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream)
根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract  XMLStreamReader XMLInputFactory.createXMLStreamReader(String systemId, Reader reader)
根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract  XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream)
创建一个写入到流的新 XMLStreamWriter。
abstract  XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding)
创建一个写入到流的新 XMLStreamWriter。
abstract  XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Result result)
创建一个写入到 JAXP 结果的新 XMLStreamWriter。
abstract  XMLStreamWriter XMLOutputFactory.createXMLStreamWriter(Writer stream)
创建一个写入到 writer 的新 XMLStreamWriter。
 void XMLEventWriter.flush()
将所有缓存事件写入到底层输出机制。
 void XMLStreamWriter.flush()
将所有缓存数据写入底层输出机制。
 String XMLEventReader.getElementText()
读取纯文本元素的内容。
 String XMLStreamReader.getElementText()
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。
 String XMLEventWriter.getPrefix(String uri)
获取绑定 URI 的前缀。
 String XMLStreamWriter.getPrefix(String uri)
获取绑定 URI 的前缀
 int XMLStreamReader.getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
获取与 CHARACTERS、SPACE 或 CDATA 事件关联的文本。
 boolean XMLStreamReader.hasNext()
如果有多个解析事件，则返回 true，如果不再有事件，则返回 false。
 int XMLStreamReader.next()
获取下一个解析事件??处理器可以用单个存储块返回所有连续的字符数据，它也可以将其分割成几个存储块。
 XMLEvent XMLEventReader.nextEvent()
获取下一个 XMLEvent。
 XMLEvent XMLEventReader.nextTag()
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。
 int XMLStreamReader.nextTag()
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有空格（isWhiteSpace() 返回 true）、COMMENT 或 PROCESSING_INSTRUCTION。
 XMLEvent XMLEventReader.peek()
检查下一个 XMLEvent，但不从流中读取它。
 void XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
以特定于应用程序的格式报告所需消息。
 void XMLStreamReader.require(int type, String namespaceURI, String localName)
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。
 Object XMLResolver.resolveEntity(String publicID, String systemID, String baseURI, String namespace)
检索资源。
 void XMLEventWriter.setDefaultNamespace(String uri)
将 URI 绑定到默认名称空间。
 void XMLStreamWriter.setDefaultNamespace(String uri)
将 URI 绑定到默认名称空间。
 void XMLEventWriter.setNamespaceContext(NamespaceContext context)
设置前缀的当前名称空间上下文和 URI 绑定。
 void XMLStreamWriter.setNamespaceContext(NamespaceContext context)
设置前缀和 URI 绑定的当前名称空间上下文。
 void XMLEventWriter.setPrefix(String prefix, String uri)
设置绑定 URI 的前缀。
 void XMLStreamWriter.setPrefix(String prefix, String uri)
设置绑定 URI 的前缀。
 void XMLStreamWriter.writeAttribute(String localName, String value)
向输出流写入一个不带前缀的属性。
 void XMLStreamWriter.writeAttribute(String namespaceURI, String localName, String value)
向输出流写入一个属性
 void XMLStreamWriter.writeAttribute(String prefix, String namespaceURI, String localName, String value)
向输出流写入一个属性
 void XMLStreamWriter.writeCData(String data)
编写 CData 节
 void XMLStreamWriter.writeCharacters(char[] text, int start, int len)
向输出写入文本
 void XMLStreamWriter.writeCharacters(String text)
向输出写入文本
 void XMLStreamWriter.writeComment(String data)
编写一个包含数据的 XML 注释
 void XMLStreamWriter.writeDefaultNamespace(String namespaceURI)
向流写入默认名称空间
 void XMLStreamWriter.writeDTD(String dtd)
编写 DTD 节。
 void XMLStreamWriter.writeEmptyElement(String localName)
向输出写入一个空元素标记
 void XMLStreamWriter.writeEmptyElement(String namespaceURI, String localName)
向输出写入一个空元素标记
 void XMLStreamWriter.writeEmptyElement(String prefix, String localName, String namespaceURI)
向输出写入一个空元素标记
 void XMLStreamWriter.writeEndDocument()
关闭所有开始标记并写入相应的结束标记。
 void XMLStreamWriter.writeEndElement()
向依赖于 writer 内部状态的输出写入一个结束标记，以此确定事件的前缀和本地名称。
 void XMLStreamWriter.writeEntityRef(String name)
编写一个实体引用
 void XMLStreamWriter.writeNamespace(String prefix, String namespaceURI)
向输出流写入一个名称空间。
 void XMLStreamWriter.writeProcessingInstruction(String target)
编写一条处理指令
 void XMLStreamWriter.writeProcessingInstruction(String target, String data)
编写一条处理指令
 void XMLStreamWriter.writeStartDocument()
编写 XML 声明。
 void XMLStreamWriter.writeStartDocument(String version)
编写 XML 声明。
 void XMLStreamWriter.writeStartDocument(String encoding, String version)
编写 XML 声明。
 void XMLStreamWriter.writeStartElement(String localName)
向输出写入一个开始标记。
 void XMLStreamWriter.writeStartElement(String namespaceURI, String localName)
向输出写入一个开始标记
 void XMLStreamWriter.writeStartElement(String prefix, String localName, String namespaceURI)
向输出写入一个开始标记

javax.xml.stream.events 中 XMLStreamException 的使用

抛出 XMLStreamException 的 javax.xml.stream.events 中的方法
 void XMLEvent.writeAsEncodedUnicode(Writer writer)
此方法根据 XML 1.0 规范将 XMLEvent 编写为 Unicode 字符。

javax.xml.stream.util 中 XMLStreamException 的使用

抛出 XMLStreamException 的 javax.xml.stream.util 中的方法
void | XMLEventConsumer.add(XMLEvent event) 此方法为使用者添加一个事件。
XMLEvent | XMLEventAllocator.allocate(XMLStreamReader reader) 此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
void | XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer) 此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。
void | EventReaderDelegate.close()
void | StreamReaderDelegate.close()
String | EventReaderDelegate.getElementText()
String | StreamReaderDelegate.getElementText()
int | StreamReaderDelegate.getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
boolean | StreamReaderDelegate.hasNext()
int | StreamReaderDelegate.next()
XMLEvent | EventReaderDelegate.nextEvent()
XMLEvent | EventReaderDelegate.nextTag()
int | StreamReaderDelegate.nextTag()
XMLEvent | EventReaderDelegate.peek()
void | StreamReaderDelegate.require(int type, String namespaceURI, String localName)

javax.xml.transform.stax 中 XMLStreamException 的使用

抛出 XMLStreamException 的 javax.xml.transform.stax 中的构造方法
StAXSource(XMLEventReader xmlEventReader)
通过提供 XMLEventReader 创建 StAXSource 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.XMLStreamReader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLStreamReader
的使用

使用 XMLStreamReader 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.stream.util |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 中 XMLStreamReader 的使用

参数类型为 XMLStreamReader 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(XMLStreamReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

javax.xml.bind.helpers 中 XMLStreamReader 的使用

参数类型为 XMLStreamReader 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

javax.xml.stream 中 XMLStreamReader 的使用

返回 XMLStreamReader 的 javax.xml.stream 中的方法
abstract XMLStreamReader | XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter) 创建过滤的 reader，它用过滤器包装 reader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(Reader reader) 根据 reader 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(Source source) 根据 JAXP 源创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(String systemId, Reader reader) 根据 java.io.InputStream 创建一个新 XMLStreamReader。

参数类型为 XMLStreamReader 的 javax.xml.stream 中的方法
boolean | StreamFilter.accept(XMLStreamReader reader) 测试当前状态是否为此流的一部分。
abstract XMLStreamReader | XMLInputFactory.createFilteredReader(XMLStreamReader reader, StreamFilter filter) 创建过滤的 reader，它用过滤器包装 reader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(XMLStreamReader reader) 根据 XMLStreamReader 创建一个新 XMLEventReader。

javax.xml.stream.util 中 XMLStreamReader 的使用

实现 XMLStreamReader 的 javax.xml.stream.util 中的类
 class StreamReaderDelegate
该类是用于派生 XMLStreamReader 过滤器的基类。

返回 XMLStreamReader 的 javax.xml.stream.util 中的方法
 XMLStreamReader StreamReaderDelegate.getParent()
获取此实例的父实例。

参数类型为 XMLStreamReader 的 javax.xml.stream.util 中的方法
XMLEvent | XMLEventAllocator.allocate(XMLStreamReader reader) 此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
void | XMLEventAllocator.allocate(XMLStreamReader reader, XMLEventConsumer consumer) 此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。
void | StreamReaderDelegate.setParent(XMLStreamReader reader) 设置此实例的父实例。

参数类型为 XMLStreamReader 的 javax.xml.stream.util 中的构造方法
StreamReaderDelegate(XMLStreamReader reader)
用指定的父过滤器来构造一个过滤器。

javax.xml.transform.stax 中 XMLStreamReader 的使用

返回 XMLStreamReader 的 javax.xml.transform.stax 中的方法
 XMLStreamReader StAXSource.getXMLStreamReader()
获取此 StAXSource 使用的 XMLStreamReader。

参数类型为 XMLStreamReader 的 javax.xml.transform.stax 中的构造方法
StAXSource(XMLStreamReader xmlStreamReader)
通过 XMLStreamReader 创建 StAXSource 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 javax.xml.stream.XMLStreamWriter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.xml.stream.XMLStreamWriter
的使用

使用 XMLStreamWriter 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。

javax.xml.bind 中 XMLStreamWriter 的使用

参数类型为 XMLStreamWriter 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。

javax.xml.bind.helpers 中 XMLStreamWriter 的使用

参数类型为 XMLStreamWriter 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)

javax.xml.stream 中 XMLStreamWriter 的使用

返回 XMLStreamWriter 的 javax.xml.stream 中的方法
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(OutputStream stream) 创建一个写入到流的新 XMLStreamWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLStreamWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(Result result) 创建一个写入到 JAXP 结果的新 XMLStreamWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(Writer stream) 创建一个写入到 writer 的新 XMLStreamWriter。

javax.xml.transform.stax 中 XMLStreamWriter 的使用

返回 XMLStreamWriter 的 javax.xml.transform.stax 中的方法
 XMLStreamWriter StAXResult.getXMLStreamWriter()
获取此 StAXResult 使用的 XMLStreamWriter。

参数类型为 XMLStreamWriter 的 javax.xml.transform.stax 中的构造方法
StAXResult(XMLStreamWriter xmlStreamWriter)
通过提供 XMLStreamWriter 创建 StAXResult 的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 javax.xml.XMLConstants 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 javax.xml.XMLConstants
的使用

没有 javax.xml.XMLConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


ChannelBinding (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.ietf.jgss
类 ChannelBinding

java.lang.Object
    继承者  org.ietf.jgss.ChannelBinding

public class ChannelBinding
extends Object

此类封装关于调用者提供的通道绑定信息的概念。通道绑定用来在上下文创建期间加强对同位体实体进行验证的质量。它们使 GSS-API 调用者能够将安全上下文的创建与相关的特征（如地址）或特定于应用程序的数据进行绑定。

初始化安全上下文的调用者必须确定将在 GSSContext 对象中设置的合适的通道绑定值。接受端必须提供一致的绑定，以便确认接收到的标记具有正确的与通道相关的特征。

在 GSS-API 中是否使用通道绑定是可选的。在初次调用 initSecContext 或执行 acceptSecContext 之前，可以使用 setChannelBinding 方法、针对 GSSContext 来设置 ChannelBinding。除非已将 setChannelBinding 方法用于设置 GSSContext 对象的 ChannelBinding，否则将假定为 null ChannelBinding。

从概念上讲，GSS-API 将初始端和接受端的地址信息与应用程序提供的字节数组连接在一起，构成一个八位字节字符串。验证机制将通过此八位字节字符串计算 MIC，并且将 MIC 绑定到由 GSSContext 接口的 initSecContext 方法发出的上下文创建标记中。同样的绑定将由上下文接受端为其 GSSContext 对象设置，并且在处理 acceptSecContext 方法期间，将用同样的方法来计算 MIC。将把计算出的 MIC 与标记中的值进行比较，如果这两个 MIC 不同，接受端将抛出 GSSException，主代码被设置为 BAD_BINDINGS，并且将不建立上下文。有些验证机制可能在标记（而不仅仅在 MIC ）中包括实际的通道绑定数据；因此，应用程序不应将机密数据用作通道绑定组件。

有些验证机制可能会在那些将出现在通道绑定中的地址上施加一些附加限制。例如，有的验证机制会验证通道绑定的初始端地址字段是否包含主机系统的正确网络地址。因此，那些可移植的应用程序必须确保，它们要么能够提供地址字段的正确信息，要么忽略对说明性信息的设置。

从以下版本开始：
1.4

构造方法摘要
ChannelBinding(byte[] appData)
创建不带任何说明性信息的 ChannelBinding 对象。
ChannelBinding(InetAddress initAddr, InetAddress acceptAddr, byte[] appData)
使用用户提供的地址信息和数据创建 ChannelBinding 对象。
方法摘要
boolean | equals(Object obj) 比较 ChannelBinding 的两个实例。
InetAddress | getAcceptorAddress() 获得此通道绑定的接受端的地址。
byte[] | getApplicationData() 获得此通道绑定的应用程序指定的数据。
InetAddress | getInitiatorAddress() 获得此通道绑定的初始端地址。
int | hashCode() 返回此 ChannelBinding 对象的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChannelBinding

public ChannelBinding(InetAddress initAddr,
                      InetAddress acceptAddr,
                      byte[] appData)
使用用户提供的地址信息和数据创建 ChannelBinding 对象。null 值可用于任何应用程序不想指定的字段。

参数：
initAddr - 上下文初始端的地址。可通过提供 null 值来表示应用程序不想设置此值。
acceptAddr - 上下文接受端的地址。可通过提供 null 值来表示应用程序不想设置此值。
appData - 应用程序提供的数据，用作通道绑定的一部分。可通过提供 null 值来表示应用程序不想设置此值。

ChannelBinding

public ChannelBinding(byte[] appData)
创建不带任何说明性信息的 ChannelBinding 对象。

参数：
appData - 应用程序提供的数据，用作通道绑定的一部分。
方法详细信息

getInitiatorAddress

public InetAddress getInitiatorAddress()
获得此通道绑定的初始端地址。

返回：
初始端的地址。如果地址尚未设置，则返回 null。

getAcceptorAddress

public InetAddress getAcceptorAddress()
获得此通道绑定的接受端的地址。

返回：
接受端的地址。如果地址尚未设置，则返回 null。

getApplicationData

public byte[] getApplicationData()
获得此通道绑定的应用程序指定的数据。

返回：
用作 ChannelBinding 一部分的应用程序数据。如果尚未为该通道绑定指定应用程序数据，则返回 null。

equals

public boolean equals(Object obj)
比较 ChannelBinding 的两个实例。

覆盖：
类 Object 中的 equals
参数：
obj - 将与此 ChannelBinding 进行比较的另外一个 ChannelBinding
返回：
如果这两个 ChannelBinding 包括相同的初始端和接受端地址值及应用程序数据，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 ChannelBinding 对象的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


GSSContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.ietf.jgss
接口 GSSContext

public interface GSSContext

此接口将封装 GSS-API 安全上下文，并提供可通过上下文提供的安全服务。安全上下文是使用本地获取的凭据在同位体之间创建的。在一对同位体之间可能会同时存在多个上下文，它们使用一套相同或不同的凭据。GSS-API 的执行方式与基础传输协议无关，而是取决于其对传输标记的应用程序的调用，这些标记由同位体之间的安全上下文生成。

如果调用者使用默认的 GSSManager 实例实例化上下文，则可保证 Kerberos v5 GSS-API 机制可用于上下文创建。此机制由 Oid "1.2.840.113554.1.2.2" 标识，并在 RFC 1964 中被进行定义。

在初始化上下文创建阶段之前，上下文初始化程序会请求已创建的上下文所需要的特定特征。并非所有的基础机制都支持调用者所需要的全部特征。在创建上下文之后，调用者可以通过多种查询方法来检查由该上下文提供的实际特征和服务。当使用由默认的 GSSManager 实例提供的 Kerberos v5 GSS-API 机制时，所有的可选服务都可本地提供。它们是相互验证、凭据委托、机密性和完整性保护、以及 per-message 重放检测和排序。注意，在 GSS-API 中，消息完整性是消息机密性的先决条件。

上下文创建必须在这样一个环路中进行：初始端调用 initSecContext，接受端调用 acceptSecContext，直到创建好该上下文。同时，在此环路中，initSecContext 和 acceptSecContext 方法将产生应用程序发送给同位体的标记。同位体将根据情况将任何这样的标记作为输入传递给它的 acceptSecContext 或 initSecContext。

在上下文创建阶段，可能会调用 isProtReady 方法来确定是否可以将该上下文用于 wrap 和 getMIC 的 per-message 操作。这将允许应用程序在尚未完全创建的上下文上使用 per-message 操作。

在上下文创建好或 isProtReady 方法返回 true后，可调用查询例程来确定已创建上下文的实际特征和服务。还可以通过使用 wrap 和 getMIC 的 per-message 方法来启动应用程序，以获取对应用程序提供的数据的加密操作。

当不再需要上下文时，应用程序必须调用 dispose 来释放该上下文可能正在使用的任何系统资源。

安全上下文一般都维护有关它所处理的标记的排序和重放检测方面的信息。因此，将标记呈现给此上下文以进行处理的顺序非常重要。还要注意的是，此接口中的任何方法都不同步。因此，除非已经实施了某些应用程序级的同步，否则建议不要在几个线程之间共享 GSSContext。

最后一点是，不同的机制提供商可能会对使用 GSS-API 上下文提出不同的安全限制。这些将由机制提供商记入文档。应用程序需要确保是否具有适当的权限在机制层中进行此类检查。

下面呈现的示例代码演示了使用 GSSContext 接口初始化同位体的情况。它呈现了在 GSSContext 对象上的不同操作，其中包括：对象初始化、所需标志的设置、上下文创建、对实际上下文标志的查询、对应用程序数据的 per-message 操作和最终的上下文删除。

    // Create a context using default credentials
    // and the implementation specific default mechanism
    GSSManager manager ...
    GSSName targetName ...
    GSSContext context = manager.createContext(targetName, null, null,
                                           GSSContext.INDEFINITE_LIFETIME);

    // set desired context options prior to context establishment
    context.requestConf(true);
    context.requestMutualAuth(true);
    context.requestReplayDet(true);
    context.requestSequenceDet(true);

    // establish a context between peers

    byte []inToken = new byte[0];

    // Loop while there still is a token to be processed

    while (!context.isEstablished()) {

        byte[] outToken
            = context.initSecContext(inToken, 0, inToken.length);

        // send the output token if generated
        if (outToken != null)
            sendToken(outToken);

        if (!context.isEstablished()) {
            inToken = readToken();
    }

     // display context information
     System.out.println("Remaining lifetime in seconds = "
                                          + context.getLifetime());
     System.out.println("Context mechanism = " + context.getMech());
     System.out.println("Initiator = " + context.getSrcName());
     System.out.println("Acceptor = " + context.getTargName());

     if (context.getConfState())
             System.out.println("Confidentiality (i.e., privacy) is available");

     if (context.getIntegState())
             System.out.println("Integrity is available");

     // perform wrap on an application supplied message, appMsg,
     // using QOP = 0, and requesting privacy service
     byte [] appMsg ...

     MessageProp mProp = new MessageProp(0, true);

     byte []tok = context.wrap(appMsg, 0, appMsg.length, mProp);

     sendToken(tok);

     // release the local-end of the context
     context.dispose();

从以下版本开始：
1.4

字段摘要
static int | DEFAULT_LIFETIME 一个表示默认的上下文生存期的生存期常量。
static int | INDEFINITE_LIFETIME 一个表示不确定的上下文生存期的生存期常量。
方法摘要
byte[] | acceptSecContext(byte[] inToken, int offset, int len) 由上下文接受端在收到同位体的标记后调用。
void | acceptSecContext(InputStream inStream, OutputStream outStream) 由上下文接受端调用，以处理来自使用流的同位体的标记。
void | dispose() 释放存储在上下文对象中并且使上下文无效的系统资源和加密信息。
byte[] | export() 导出此上下文，以便使其他进程能够导入它。
boolean | getAnonymityState() 确定是否会向上下文接受端对上下文初始端进行匿名验证。
boolean | getConfState() 确定数据机密性是否可用于上下文。
boolean | getCredDelegState() 确定是否在此上下文上启用凭据委托。
GSSCredential | getDelegCred() 获取上下文初始端委托给上下文接受端的凭据。
boolean | getIntegState() 确定数据完整性是否可用于上下文。
int | getLifetime() 确定此上下文剩余的生存期是多长。
Oid | getMech() 确定什么机制正用于此上下文。
byte[] | getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp) 返回包含所提供消息的加密消息完整性代码 (MIC) 的标记，以便传输到同位体应用程序。
void | getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
boolean | getMutualAuthState() 确定是否在此上下文上启用了相互验证。
boolean | getReplayDetState() 确定是否针对此上下文中的 per-message 安全服务启用了重放检测。
boolean | getSequenceDetState() 确定是否针对本上下文中的 per-message 安全服务启用了序列检查。
GSSName | getSrcName() 返回上下文初始端的名称。
GSSName | getTargName() 返回上下文接受端的名称。
int | getWrapSizeLimit(int qop, boolean confReq, int maxTokenSize) 用来确定可以传输给 wrap 的消息的大小限制。
byte[] | initSecContext(byte[] inputBuf, int offset, int len) 由上下文初始端调用，以启动上下文创建阶段，处理由同位体的 acceptSecContext 方法生成的任何标记。
int | initSecContext(InputStream inStream, OutputStream outStream) 由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
boolean | isEstablished() 用来在上下文创建期间确定上下文的状态。
boolean | isInitiator() 确定它是否为上下文初始端。
boolean | isProtReady() 确定上下文是否已为要在其上使用的 per message 准备就绪。
boolean | isTransferable() 确定通过使用 export 方法，该上下文是否可以传输给其他进程。
void | requestAnonymity(boolean state) 请求不要将初始端的身份泄露给接受端。
void | requestConf(boolean state) 请求针对 wrap 方法启用数据机密性。
void | requestCredDeleg(boolean state) 请求在上下文创建期间将初始端的凭据委托给接受端。
void | requestInteg(boolean state) 请求针对 wrap 和 getMIC 方法启用数据完整性。
void | requestLifetime(int lifetime) 请求上下文以秒为单位的生存期。
void | requestMutualAuth(boolean state) 要求相互验证在上下文创建期间完成。
void | requestReplayDet(boolean state) 请求在上下文创建之后针对 per-message 安全服务启用重放检测。
void | requestSequenceDet(boolean state) 请求在上下文创建之后针对 per-message 安全服务启用序列检查。
void | setChannelBinding(ChannelBinding cb) 设置在上下文创建期间使用的通道绑定。
byte[] | unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 用来处理在上下文的另一方由 wrap 方法生成的标记。
void | unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp) 通过提供的消息，检查包含在标记参数中的加密的 MIC。
void | verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp) 通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
byte[] | wrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 将 per-message 安全服务应用于已创建的安全上下文。
void | wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

字段详细信息

DEFAULT_LIFETIME

static final int DEFAULT_LIFETIME
一个表示默认的上下文生存期的生存期常量。此值被设置为 0。

另请参见：
常量字段值

INDEFINITE_LIFETIME

static final int INDEFINITE_LIFETIME
一个表示不确定的上下文生存期的生存期常量。在 Java 中必须将此值设置为最大整数值 -- Integer.MAX_VALUE。

另请参见：
常量字段值
方法详细信息

initSecContext

byte[] initSecContext(byte[] inputBuf,
                      int offset,
                      int len)
                      throws GSSException
由上下文初始端调用，以启动上下文创建阶段，处理由同位体的 acceptSecContext 方法生成的任何标记。此方法会返回一个应用程序需要发送给同位体、以便由其 acceptSecContext 方法进行处理的输出标记。应用程序可以调用 isEstablished 来确定在上下文的这一方是否完成了上下文创建阶段。如果从 isEstablished 中返回的值是 false，则指示希望为 initSecContext 提供更多的标记。完成上下文创建后，可通过 get 方法查询可用的上下文选项。

注意，有可能出现这样一种情况：initSecContext 方法为同位体返回一个标记，isEstablished 也返回 true。这表示，需要将标记发送给同位体，但该上下文的本地端现已完全创建。

有些机制提供商可能会要求调用者授予初始化安全上下文的权限。失败的权限检查可以导致从此方法中抛出 SecurityException。

参数：
inputBuf - 由同位体生成的标记。由于尚未从该同位体中接收到标记，因此在初次调用时此参数将被忽略。
offset - inputBuf 中标记开始处的偏移量。
len - 该标记的长度。
返回：
包含发送给同位体标记的 byte[]。null 指示未生成任何标记。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DEFECTIVE_TOKEN GSSException.DEFECTIVE_TOKEN}、GSSException.BAD_MIC、GSSException.NO_CRED、GSSException.CREDENTIALS_EXPIRED、GSSException.BAD_BINDINGS、GSSException.OLD_TOKEN、GSSException.DUPLICATE_TOKEN、GSSException.BAD_NAMETYPE、GSSException.BAD_MECH、GSSException.FAILURE
GSSException

initSecContext

int initSecContext(InputStream inStream,
                   OutputStream outStream)
                   throws GSSException
由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。此方法将向 OutpuStream 写入输出标记，应用程序需要将此标记发送到同位体以便通过其 acceptSecContext 调用进行处理。一般情况下，应用程序会通过在 OutputStream 上调用 flush 方法来确保封装这两个同位体之间的连接。应用程序可以通过此方法返回的值确定是否向 OutputStream 写入了标记。如果返回的值是 0，则表示没有写入任何值。应用程序可以调用 isEstablished 来确定在上下文的这一方是否完成了上下文创建阶段。如果从 isEstablished 中返回的值是 false，则指示希望为 initSecContext 提供更多的标记。完成上下文创建后，可通过 get 方法查询可用的上下文选项。

注意，有可能出现这样一种情况：initSecContext 方法为同位体返回一个标记，isEstablished 也返回 true。这表示，需要将标记发送给同位体，但该上下文的本地端现已完全创建。

GSS-API 验证标记包括确定的始端和终端。此方法将尝试每次调用时读取其中的一个标记，并且在仅有部分标记可用时阻塞流。在所有其他方面，此方法等同于基于字节数组的 initSecContext。

有些机制提供商可能会要求调用者授予初始化安全上下文的权限。失败的权限检查可能会导致从此方法中抛出 SecurityException。

以下示例代码演示了使用此方法的方式：

     InputStream is ...
     OutputStream os ...
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {

         context.initSecContext(is, os);

         // send output token if generated
         os.flush();
     }

参数：
inStream - 一个包含由同位体生成的标记的 InputStream。由于尚未（不会）从该同位体的该点接收到标记，因此在初次调用时此参数将被忽略。
outStream - 将向其中写入输出标记的 OutputStream。在上下文创建的最终阶段，可能不需要写入字节。
返回：
将作为标记的一部分发送给同位体、写入到 OutputStream 的字节数。0 值指示不需要发送标记。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DEFECTIVE_TOKEN GSSException.DEFECTIVE_TOKEN}、GSSException.BAD_MIC、GSSException.NO_CRED、GSSException.CREDENTIALS_EXPIRED、GSSException.BAD_BINDINGS、GSSException.OLD_TOKEN、GSSException.DUPLICATE_TOKEN、GSSException.BAD_NAMETYPE、GSSException.BAD_MECH、GSSException.FAILURE
GSSException

acceptSecContext

byte[] acceptSecContext(byte[] inToken,
                        int offset,
                        int len)
                        throws GSSException
由上下文接受端在收到同位体的标记后调用。此方法会返回一个输出标记，应用程序将把该标记发送到同位体、以便通过其 initSecContext 调用进行进一步处理。

应用程序可以通过调用 isEstablished 来确定是否完成了此同位体的上下文创建阶段。如果从 isEstablished 中返回的值是 false，则指示希望为此方法提供更多的标记。完成上下文创建后，可通过 get 方法查询可用的上下文选项。

注意，有可能出现这样一种情况：acceptSecContext 为同位体返回一个标记，isEstablished 也返回 true。这表示，需要将标记发送给同位体，但该上下文的本地端现已完全创建。

有些机制提供商可能会要求调用者授予接受安全上下文的权限。失败的权限检查可能会导致从此方法中抛出 SecurityException。

以下示例代码演示了使用此方法的方式：

     byte[] inToken;
     byte[] outToken;
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {
         inToken = readToken();
         outToken = context.acceptSecContext(inToken, 0,
                                             inToken.length);
         // send output token if generated
         if (outToken != null)
             sendToken(outToken);
     }

参数：
inToken - 由同位体生成的标记。
offset - inToken 中标记开始处的偏移量。
len - 该标记的长度。
返回：
包含发送给同位体标记的 byte[]。null 指示未生成任何标记。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DEFECTIVE_TOKEN GSSException.DEFECTIVE_TOKEN}、GSSException.BAD_MIC、GSSException.NO_CRED、GSSException.CREDENTIALS_EXPIRED、GSSException.BAD_BINDINGS、GSSException.OLD_TOKEN、GSSException.DUPLICATE_TOKEN、GSSException.BAD_MECH、GSSException.FAILURE
GSSException

acceptSecContext

void acceptSecContext(InputStream inStream,
                      OutputStream outStream)
                      throws GSSException
由上下文接受端调用，以处理来自使用流的同位体的标记。此方法将向 OutputStream 写入输出标记，应用程序需要将此标记发送到同位体以便通过其 initSecContext 方法进行处理。一般情况下，应用程序会通过在 OutputStream 上调用 flush 方法来确保封装这两个同位体之间的连接。应用程序可以调用 isEstablished 来确定在上下文的这一方是否完成了上下文创建阶段。如果从 isEstablished 中返回的值为 false，则指示希望为 acceptSecContext 提供更多的标记。完成上下文创建后，可通过 get 方法查询可用的上下文选项。

注意，有可能出现这样一种情况：acceptSecContext 为同位体返回一个标记，isEstablished 也返回 true。这表示，需要将标记发送给同位体，但该上下文的本地端现已完全创建。

GSS-API 验证标记包括确定的起始端和终端。此方法将尝试每调用一次读取其中的一个标记，并且在仅有部分标记可用时阻塞流。在所有其他方面，此方法等同于基于字节数组的 acceptSecContext。

有些机制提供商可能会要求调用者授予接受安全上下文的权限。失败的权限检查可能会导致从此方法中抛出 SecurityException。

以下示例代码演示了使用此方法的方式：

     InputStream is ...
     OutputStream os ...
     GSSContext context ...

     // Loop while there is still a token to be processed

     while (!context.isEstablished()) {

         context.acceptSecContext(is, os);

         // send output token if generated
         os.flush();
     }

参数：
inStream - 一个包含由同位体生成的标记的 InputStream。
outStream - 将向其中写入输出标记的 OutputStream。在上下文创建的最终阶段，可能不需要写入字节。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DEFECTIVE_TOKEN GSSException.DEFECTIVE_TOKEN}、GSSException.BAD_MIC、GSSException.NO_CRED、GSSException.CREDENTIALS_EXPIRED、GSSException.BAD_BINDINGS、GSSException.OLD_TOKEN、GSSException.DUPLICATE_TOKEN、GSSException.BAD_MECH、GSSException.FAILURE
GSSException

isEstablished

boolean isEstablished()
用来在上下文创建期间确定上下文的状态。

返回：
如果它是在调用者上完全创建的上下文，并且不再需要来自同位体的标记，则返回 true。

dispose

void dispose()
             throws GSSException
释放存储在上下文对象中并且使上下文无效的系统资源和加密信息。

抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

getWrapSizeLimit

int getWrapSizeLimit(int qop,
                     boolean confReq,
                     int maxTokenSize)
                     throws GSSException
用来确定可以传输给 wrap 的消息的大小限制。如果以相同的 confReq 和 qop 参数呈现给 wrap 方法，则将返回最大的消息大小，这会导致输出标记只包含 maxTokenSize 个字节。

此调用主要供那些通过影响最大消息大小的协议进行通信的应用程序使用。它使应用程序能够在实施保护之前将消息进行分段。

在调用 getWrapSizeLimit 时，推荐实现 GSS-API，但不要求检测无效的 QOP 值。此例程可保证只有最大消息大小，而不是针对消息保护的特定 QOP 值的可用性。

参数：
qop - 将要求 wrap 提供的保护级别。
confReq - 如果要求 wrap 提供保密性，则为 true，否则为 false。
maxTokenSize - 由 wrap 发出的标记所需的最大大小。
返回：
针对给定的输出标记大小的输入标记的最大大小
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#CONTEXT_EXPIRED GSSException.CONTEXT_EXPIRED}、GSSException.BAD_QOP、GSSException.FAILURE
GSSException

wrap

byte[] wrap(byte[] inBuf,
            int offset,
            int len,
            MessageProp msgProp)
            throws GSSException
将 per-message 安全服务应用于已创建的安全上下文。该方法将通过它返回一个带有应用程序提供的数据和加密的 MIC 的标记。如果需要机密性（保密性），则可以对数据进行加密。

MessageProp 对象可以通过应用程序进行实例化，并可用来指定一个选择加密算法的 QOP 值，和可选地对消息进行加密的私密服务。在调用中使用的基础机制可能无法提供私密服务。但它将设置在此 MessageProp 对象中提供的实际私密服务，调用者会在该调用返回后对其进行查询。如果机制不能提供请求的 QOP，则它将抛出带有 BAD_QOP 代码的 GSSException。

由于某些应用程序级的协议希望使用 wrap 发出的标记来提供 "secure framing"（安全分帧），所以实现应该支持包装零长度的消息。

应用程序将负责将标记发送到同位体。

参数：
inBuf - 要保护的应用程序数据。
offset - inBuf 中数据开始处的偏移量。
len - 数据的长度
msgProp - MessageProp 的实例，应用程序使用它来设置需要的 QOP 和私密状态。将需要的 QOP 设置为 0，以便请求默认的 QOP。从此方法返回后，此对象将包含基础机制应用于消息的实际私密状态。
返回：
包含将发送给同位体的标记的 byte[]。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#CONTEXT_EXPIRED GSSException.CONTEXT_EXPIRED}、GSSException.BAD_QOP、GSSException.FAILURE
GSSException

wrap

void wrap(InputStream inStream,
          OutputStream outStream,
          MessageProp msgProp)
          throws GSSException
将 per-message 安全服务应用于已创建的使用流的安全上下文。该方法将通过它返回一个带有应用程序提供的数据和加密的 MIC 的标记。如果需要机密性（保密性），则可以对数据进行加密。此方法等同于基于字节数组的 wrap 方法。

应用程序将负责将标记发送到同位体。一般情况下，应用程序会通过在 OutputStream 上调用 flush 方法来确保封装这两个同位体之间的连接。

MessageProp 对象可以通过应用程序进行实例化，并可用来指定一个选择加密算法的 QOP 值，和可选地对消息进行加密的私密服务。在调用中使用的基础机制可能无法提供私密服务。但它将设置在此 MessageProp 对象中提供的实际私密服务，调用者会在该调用返回后对其进行查询。如果机制不能提供请求的 QOP，则它将抛出带有 BAD_QOP 代码的 GSSException。

由于某些应用程序级的协议希望使用 wrap 发出的标记来提供 "secure framing"（安全分帧），所以实现应该支持包装零长度的消息。

参数：
inStream - 一个包含受保护的应用程序数据的 InputStream。将使用 inStream 中提供的所有数据。
outStream - 向其写入受保护消息的 OutputStream。
msgProp - MessageProp 的实例，应用程序使用它来设置需要的 QOP 和保密状态。将需要的 QOP 设置为 0，以便请求默认的 QOP。从此方法返回后，此对象将包含基础机制应用于消息的实际私密状态。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#CONTEXT_EXPIRED GSSException.CONTEXT_EXPIRED}、GSSException.BAD_QOP、GSSException.FAILURE
GSSException

unwrap

byte[] unwrap(byte[] inBuf,
              int offset,
              int len,
              MessageProp msgProp)
              throws GSSException
用来处理在上下文的另一方由 wrap 方法生成的标记。该方法将由同位体应用程序提供的消息返回到其 wrap 调用，同时验证为该消息嵌入的 MIC。

MessageProp 对象将由应用程序实例化，并由基础机制使用，以便返回给调用者一些信息，如 QOP、是否对消息应用了机密性，以及其他一些增补消息状态信息。

由于某些应用程序级的协议希望使用 wrap 发出的标记来提供 "secure framing"（安全分帧），所以实现必须支持包装和不包装零长度的消息。

参数：
inBuf - 包含从同位体接收的包装标记的字节数组。
offset - 标记开始处的偏移量。
len - 标记的长度
msgProp - 从此方法返回后，此对象将包括所应用的 QOP、消息的保密状态、和说明该标记是否为复制的、旧的、超出序列的或在 gap 后进入的标记的增补信息。
返回：
包含从输入标记中展开的消息的 byte[]。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DEFECTIVE_TOKEN GSSException.DEFECTIVE_TOKEN}、GSSException.BAD_MIC、GSSException.CONTEXT_EXPIRED、GSSException.FAILURE
GSSException

unwrap

void unwrap(InputStream inStream,
            OutputStream outStream,
            MessageProp msgProp)
            throws GSSException
使用流来处理在上下文的另一方由 wrap 方法生成的标记。该方法将由同位体应用程序提供的消息返回到其 wrap 调用，同时验证为该消息嵌入的 MIC。

MessageProp 对象将由应用程序实例化，并由基础机制使用，以便返回给调用者一些信息，如 QOP、是否对消息应用了机密性，以及其他一些增补消息状态信息。

由于某些应用程序级的协议希望使用 wrap 发出的标记来提供 "secure framing"（安全分帧），所以实现必须支持包装和不包装零长度的消息。

此方法读取的输入标记的格式在将要使用的基础机制的规范中定义。此方法将尝试每调用一次读取其中的一个标记。如果机制标记包含确定的始端和终端，则在仅有部分标记可用时，此方法将阻塞 InputStream。如果标记的始端和终端不是确定的，则该方法会尝试将所有的可用字节视为标记的一部分。

与前面介绍的可能出现的阻塞行为不同，此方法等同于基于字节数组的 unwrap 方法。

参数：
inStream - 一个包含由同位体生成的包装标记的 InputStream。
outStream - 向其写入应用程序消息的 OutputStream。
msgProp - 从方法返回后，此对象将包括所用的 QOP、消息的保密状态和说明该标记是否为复制的、旧的、超出序列或在 gap 后进入的标记的增补信息。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DEFECTIVE_TOKEN GSSException.DEFECTIVE_TOKEN}、GSSException.BAD_MIC、GSSException.CONTEXT_EXPIRED、GSSException.FAILURE
GSSException

getMIC

byte[] getMIC(byte[] inMsg,
              int offset,
              int len,
              MessageProp msgProp)
              throws GSSException
返回包含所提供消息的加密消息完整性代码 (MIC) 的标记，以便传输到同位体应用程序。与将用户消息封装在返回的标记中的包装不同，在输出标记中仅返回消息 MIC。

注意，保密性只能应用于 wrap 调用。

由于某些应用程序级的协议希望使用 getMIC 发出的标记来提供 "secure framing"（安全分帧），所以实现必须支持从零长度消息中导出 MIC。

参数：
inMsg - 在其上生成 MIC 的消息。
offset - inMsg 中消息开始处的偏移量。
len - 消息的长度
msgProp - MessageProp 的一个实例，应用程序使用它来设置需要的 QOP。在 msgProp 中将需要的 QOP 设置为 0，以便请求默认的 QOP。还可以通过为 msgProp 传入 null 来请求默认的 QOP。
返回：
包含将发送给同位体标记的 byte[]。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#CONTEXT_EXPIRED GSSException.CONTEXT_EXPIRED}、GSSException.BAD_QOP、GSSException.FAILURE
GSSException

getMIC

void getMIC(InputStream inStream,
            OutputStream outStream,
            MessageProp msgProp)
            throws GSSException
使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。与将用户消息封装在返回的标记中的包装不同，在输出标记中仅产生消息 MIC。此方法等同于基于字节数组的 getMIC 方法。 注意，保密性只能应用于 wrap 调用。

由于某些应用程序级的协议希望使用 getMIC 发出的标记来提供 "secure framing"（安全分帧），所以实现必须支持从零长度消息中导出 MIC。

参数：
inStream - 一个 InputStream，它包含在其上生成 MIC 的消息。将使用 inStream 中提供的所有数据。
outStream - 向其写入输出标记的 OutputStream。
msgProp - MessageProp 的一个实例，应用程序使用它来设置需要的 QOP。在 msgProp 中将需要的 QOP 设置为 0，以便请求默认的 QOP。还可以通过为 msgProp 传入 null 来请求默认的 QOP。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#CONTEXT_EXPIRED GSSException.CONTEXT_EXPIRED}、GSSException.BAD_QOP、GSSException.FAILURE
GSSException

verifyMIC

void verifyMIC(byte[] inToken,
               int tokOffset,
               int tokLen,
               byte[] inMsg,
               int msgOffset,
               int msgLen,
               MessageProp msgProp)
               throws GSSException
通过提供的消息，检查包含在标记参数中的加密的 MIC。

MessageProp 对象将由该应用程序实例化，并由基础机制使用，以便返回给调用者诸如 QOP 之类的信息，从而表明应用于消息的保护的长度和其他一些增补消息状态信息。

由于某些应用程序级的协议希望使用 getMIC 发出的标记来提供 "secure framing"（安全分帧），所以实现必须支持计算和检查零长度消息的 MIC。

参数：
inToken - 由同位体的 getMIC 方法生成的标记。
tokOffset - inToken 中标记开始处的偏移量。
tokLen - 该标记的长度
inMsg - 通过它来验证加密的 MIC 的应用程序消息。
msgOffset - inMsg 中消息开始处的偏移量。
msgLen - 该消息的长度。
msgProp - 从方法返回后，此对象将包括所用的 QOP 和说明该标记是否为复制的、旧的、超出序列或在 gap 后进入的标记的增补信息。
抛出：
GSSException， - 包含以下主要错误代码：GSSException.DEFECTIVE_TOKEN、GSSException.BAD_MIC、GSSException.CONTEXT_EXPIRED、GSSException.FAILURE
GSSException

verifyMIC

void verifyMIC(InputStream tokStream,
               InputStream msgStream,
               MessageProp msgProp)
               throws GSSException
通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。此方法等同于基于字节数组的 verifyMIC 方法。 MessageProp 对象将由该应用程序实例化，并由基础机制使用，以便返回给调用者诸如 QOP 之类的信息，从而表明应用于消息的保护的长度和其他一些增补消息状态信息。

由于某些应用程序级的协议希望使用 getMIC 发出的标记来提供 "secure framing"（安全分帧），所以实现必须支持计算和检查零长度消息的 MIC。

此方法读取的输入标记的格式在将要使用的基础机制的规范中定义。此方法将尝试每调用一次读取其中的一个标记。如果机制标记包含确定的始端和终端，则在仅有部分标记可用时，此方法将阻塞 InputStream。如果标记的始端和终端不是确定的，则该方法会尝试将所有的可用字节视为标记的一部分。

与前面介绍的可能出现的阻塞行为不同，此方法等同于基于字节数组的 verifyMIC 方法。

参数：
tokStream - 一个包含由同位体的 getMIC 方法生成的标记的 InputStream。
msgStream - 一个包含可用来验证加密的 MIC 的应用程序消息的 InputStream。将使用 msgStream 中提供的所有数据。
msgProp - 从方法返回后，此对象将包括所用的 QOP 和说明该标记是否为复制的、旧的、超出序列或在 gap 后进入的标记的增补信息。
抛出：
GSSException， - 包含以下主要错误代码：GSSException.DEFECTIVE_TOKEN、GSSException.BAD_MIC、GSSException.CONTEXT_EXPIRED、GSSException.FAILURE
GSSException

export

byte[] export()
              throws GSSException
导出此上下文，以便使其他进程能够导入它。假设支持在多个进程间共享工作。此例程通常由应用程序中的上下文接受端使用，在该应用程序中，单一进程接收传入的连接请求，并通过它们获得安全上下文，然后将创建的上下文传递给一个或多个其他的进程，从而进行消息交换。

此方法将取消激活安全上下文，并创建一个进程间标记，当将该标记传递给另一个进程中的 GSSManager.createContext 时，它将在第二个进程中重新激活上下文。只有给定上下文的单一实例化可以在任何时间处于活动状态；上下文导出器对导出的安全上下文的后续访问尝试都不会成功。

该实现可以限制进程的 set，可以通过这些进程导入进程间的标记，要么将其作为本地安全策略的一项功能，要么将其作为实现决策的结果。例如，有些实现会限制上下文仅在在同一帐户下运行的进程间传递，或者上下文是同一进程组的一部分。

进程间的标记可以包含安全性敏感信息（例如，加密密钥）。尽管鼓励机制要么避免将此类敏感性信息放在进程间标记中，要么在将标记返回到应用程序前对其进行加密，但在典型的 GSS-API 实现中，这是不可能的。因此，应用程序必须小心地保护进程间的标记，并确保标记将要向其传输的任何进程都是完全受信任的。

不要求实现支持安全上下文的进程间的传输。调用 isTransferable 方法将指示上下文对象是否可传输。

在不可导出的上下文上调用此方法会导致抛出以下异常，并带有错误代码 GSSException.UNAVAILABLE。

返回：
一个包含导出的上下文的 byte[]
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#UNAVAILABLE GSSException.UNAVAILABLE}、GSSException.CONTEXT_EXPIRED、GSSException.NO_CONTEXT、GSSException.FAILURE
GSSException
另请参见：
GSSManager.createContext(byte[])

requestMutualAuth

void requestMutualAuth(boolean state)
                       throws GSSException
要求相互验证在上下文创建期间完成。只能在上下文初始端发出此要求，并且必须在初次调用 initSecContext 之前完成。

并非所有的机制都支持相互验证，并且某些机制在应用程序不要求相互验证的情况下也会要求这样做。因此，应用程序必须进行检查，看请求是否与 getMutualAuthState 方法有关。

参数：
state - 布尔值，指示是否应该使用相互验证。
抛出：
GSSException，包含以下主要错误代码： - GSSException.FAILURE
GSSException
另请参见：
getMutualAuthState()

requestReplayDet

void requestReplayDet(boolean state)
                      throws GSSException
请求在上下文创建之后针对 per-message 安全服务启用重放检测。只能在上下文初始端发出此要求，并且必须在初次调用 initSecContext 之前完成。在上下文创建期间，重放检测不作为选项，而只是基础机制的一项功能。

并非所有的机制都支持重放检测，并且某些机制在应用程序不要求重放检测的情况下也会要求这样做。因此，应用程序必须进行检查，看请求是否与 getReplayDetState 方法有关。如果重放检测已启用，则 MessageProp.isDuplicateToken 和 MessageProp.isOldToken 方法将为传入到 unwrap 方法或 verifyMIC 方法的 MessageProp 对象返回有效结果。

参数：
state - 布尔值，指示在创建的上下文上是否应该启用重放检测。
抛出：
GSSException，包含以下主要错误代码： - GSSException.FAILURE
GSSException
另请参见：
getReplayDetState()

requestSequenceDet

void requestSequenceDet(boolean state)
                        throws GSSException
请求在上下文创建之后针对 per-message 安全服务启用序列检查。只能在上下文初始端发出此要求，并且必须在初次调用 initSecContext 之前完成。在上下文创建期间，序列检查不作为选项，而只是基础机制的一项功能。

并非所有的机制都支持序列检查，并且某些机制在应用程序不要求序列检查的情况下也会要求这样做。因此，应用程序必须进行检查，看请求是否与 getSequenceDetState 方法有关。如果序列检查已启用，则 MessageProp.isDuplicateToken、MessageProp.isOldToken、MessageProp.isUnseqToken 和 MessageProp.isGapToken 方法将为传入到 unwrap 方法或 verifyMIC 方法的 MessageProp 对象返回有效结果。

参数：
state - 布尔值，指示在创建的上下文上是否应该启用序列检查。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException
另请参见：
getSequenceDetState()

requestCredDeleg

void requestCredDeleg(boolean state)
                      throws GSSException
请求在上下文创建期间将初始端的凭据委托给接受端。只能在上下文初始端发出此要求，并且必须在初次调用 initSecContext 之前完成。 并非所有的机制都支持凭据委托。因此，需要委托的应用程序应该进行检查，看请求是否与 getCredDelegState 方法相关。如果应用程序指示不能使用委托，则机制将认可该请求，不执行委托。对于即使在不请求的情况下机制也会启用服务这项常规规则而言，这是个例外。

参数：
state - 布尔值，指示是否应该委托该凭据。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException
另请参见：
getCredDelegState()

requestAnonymity

void requestAnonymity(boolean state)
                      throws GSSException
请求不要将初始端的身份泄露给接受端。只能在上下文初始端发出此要求，并且必须在初次调用 initSecContext 之前完成。 并非所有的机制都支持初始端匿名。因此，应用程序应该进行检查，看请求是否与 getAnonymityState 方法相关。

参数：
state - 布尔值，表示作为匿名主体，是否应该向接受端对初始端进行验证。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException
另请参见：
getAnonymityState()

requestConf

void requestConf(boolean state)
                 throws GSSException
请求针对 wrap 方法启用数据机密性。只能在上下文初始端发出此要求，并且必须在初次调用 initSecContext 之前完成。 并非所有的机制都支持机密性，并且有些机制即使在应用程序不请求时也会启用它。应用程序会进行检查，看请求是否与 getConfState 方法相关。如果已经启用了机密性，则机制仅在此时认可传入到 wrap 方法的 MessageProp 对象中的保密请求。

启用机密性还会自动启用完整性。

参数：
state - 布尔值，指示是否应该启用机密性。
抛出：
GSSException，包含以下主要错误代码： - GSSException.FAILURE
GSSException
另请参见：
getConfState(), getIntegState(), requestInteg(boolean), MessageProp

requestInteg

void requestInteg(boolean state)
                  throws GSSException
请求针对 wrap 和 getMIC 方法启用数据完整性。只能在上下文初始端发出此要求，并且必须在初次调用 initSecContext 之前完成。 并非所有的机制都支持完整性，并且有些机制即使在应用程序不请求时也会启用它。应用程序会进行检查，看请求是否与 getIntegState 方法相关。

禁用完整性也将自动禁用机密性。

参数：
state - 布尔值，指示是否应该启用完整性。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException
另请参见：
getIntegState()

requestLifetime

void requestLifetime(int lifetime)
                     throws GSSException
请求上下文以秒为单位的生存期。只能在上下文初始端调用此方法，并且必须在初次调用 initSecContext 之前完成。

上下文的实际生存期将取决于基础机制的功能，并且应用程序必须通过调用 getLifetime 方法来确定此生存期。

参数：
lifetime - 所需要的以秒为单位的上下文生存期。使用 INDEFINITE_LIFETIME 来请求不确定的生存期，使用 DEFAULT_LIFETIME 来请求默认的生存期。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException
另请参见：
getLifetime()

setChannelBinding

void setChannelBinding(ChannelBinding cb)
                       throws GSSException
设置在上下文创建期间使用的通道绑定。此方法既可以在上下文初始端调用，也可以在上下文接受端调用，但必须是在上下文创建开始前调用。这意味着，初始端必须在初次调用 initSecContext 之前调用它，接受端也必须在初次调用 acceptSecContext 之前调用它。

参数：
cb - 要使用的通道绑定。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

getCredDelegState

boolean getCredDelegState()
确定是否在此上下文上启用凭据委托。上下文初始端和上下文接受端都可以调用它。对于确定的答案，仅在完成上下文创建后才调用此方法。注意，如果初始端请求不允许进行委托，则 requestCredDeleg 方法将认可该请求，并且从该点开始，此方法将在初始端返回 false。

返回：
如果启用了委托，则返回 true；否则返回 false。
另请参见：
requestCredDeleg(boolean)

getMutualAuthState

boolean getMutualAuthState()
确定是否在此上下文上启用了相互验证。上下文初始端和上下文接受端都可以调用它。对于确定的答案，仅在完成上下文创建后才调用此方法。请求相互验证的初始端可以在上下文完成后调用此方法，并且可以在请求未得到认可的情况下处置该上下文。

返回：
如果启用相互验证，则返回 true，否则返回 false。
另请参见：
requestMutualAuth(boolean)

getReplayDetState

boolean getReplayDetState()
确定是否针对此上下文中的 per-message 安全服务启用了重放检测。上下文初始端和上下文接受端都可以调用它。对于确定的答案，仅在完成上下文创建后才调用此方法。请求重放检测的初始端可以在上下文完成后调用此方法，并且可以在请求未得到认可的情况下处置该上下文。

返回：
如果启用重新检测，则返回 true，否则返回 false。
另请参见：
requestReplayDet(boolean)

getSequenceDetState

boolean getSequenceDetState()
确定是否针对本上下文中的 per-message 安全服务启用了序列检查。上下文初始端和上下文接受端都可以调用它。对于确定的答案，仅在完成上下文创建后才调用此方法。请求序列检查的初始端可以在上下文完成后调用此方法，并且可以在请求未得到认可的情况下处置该上下文。

返回：
如果启用了序列检查，则返回 true，否则返回 false。
另请参见：
requestSequenceDet(boolean)

getAnonymityState

boolean getAnonymityState()
确定是否会向上下文接受端对上下文初始端进行匿名验证。上下文初始端和上下文接受端都可以随时调用它。在初始端上，对此方法的调用将确定初始端的身份是否已在到现在为止由 initSecContext 生成的任何上下文创建标记中泄露过。绝对必须进行匿名验证的初始端必须在每次调用 initSecContext 后调用此方法，以确定是否必须将生成的标记发送给同位体或中断的上下文。在接受端上，对此方法的调用可以确定到现在为止，由 acceptSecContext 处理的标记是否已经泄漏了初始端的身份。

返回：
如果上下文初始端仍是匿名，则返回 true，否则返回 false。
另请参见：
requestAnonymity(boolean)

isTransferable

boolean isTransferable()
                       throws GSSException
确定通过使用 export 方法，该上下文是否可以传输给其他进程。此调用仅在完全创建的上下文上有效。

返回：
如果此上下文可以导出，则返回 True；否则返回 false。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

isProtReady

boolean isProtReady()
确定上下文是否已为要在其上使用的 per message 准备就绪。有些机制可能允许在上下文完全创建之前使用 per-message 操作。

返回：
如果诸如 wrap、unwrap、getMIC 和 verifyMIC 之类的方法可在上下文创建的当前阶段用于此上下文，则返回 true，否则，则返回 false。

getConfState

boolean getConfState()
确定数据机密性是否可用于上下文。此方法既可由上下文初始端调用，也可以由上下文接受端调用，但是仅在 isProtReady 或 isEstablished 二者之一返回 true 时调用。如果此方法返回 true，则 getIntegState 也将返回 true

返回：
如果机密性服务可用，则返回 true，否则，则返回 false。
另请参见：
requestConf(boolean)

getIntegState

boolean getIntegState()
确定数据完整性是否可用于上下文。此方法既可由上下文初始端调用，也可以由上下文接受端调用，但是仅在 isProtReady 或 isEstablished 二者之一返回 true 时调用。如果 getConfState 返回 true，则此方法将始终返回 true。

返回：
如果完整性服务可用，则返回 true，否则返回 false。
另请参见：
requestInteg(boolean)

getLifetime

int getLifetime()
确定此上下文剩余的生存期是多长。它既可以由上下文初始端调用，也可以由上下文接受端调用，但是对于确定的答案，仅在 isEstablished 返回 true 后才调用它。

返回：
剩余以秒为单位的生存期
另请参见：
requestLifetime(int)

getSrcName

GSSName getSrcName()
                   throws GSSException
返回上下文初始端的名称。此调用仅在 isProtReady 或 isEstablished 中的二者之一返回 true 时有效。

返回：
一个 GSSName，它是一个包含上下文初始端名称的 MN。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException
另请参见：
GSSName

getTargName

GSSName getTargName()
                    throws GSSException
返回上下文接受端的名称。此调用仅在 isProtReady 或 isEstablished 中的二者之一返回 true 时有效。

返回：
一个 GSSName，它是一个包含上下文接受端名称的 MN。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

getMech

Oid getMech()
            throws GSSException
确定什么机制正用于此上下文。此方法可在上下文完全创建之前调用，但在已协商的机制中，返回的机制可能会更改后续的调用。

返回：
正在使用的机制的 Oid
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

getDelegCred

GSSCredential getDelegCred()
                           throws GSSException
获取上下文初始端委托给上下文接受端的凭据。必须仅在上下文接受端上调用它，并且仅在完全创建上下文时调用一次。调用者可以使用方法 getCredDelegState 来确定是否存在委托的凭据。

返回：
一个包含初始方委托凭据的 GSSCredential，如果没有委托的凭据，则返回 null。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

isInitiator

boolean isInitiator()
                    throws GSSException
确定它是否为上下文初始端。这既可以在上下文初始端上调用，也可以在上下文接受端上调用。

返回：
如果是上下文初始端，则返回 true，如果上下文接受端，则返回 false。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GSSCredential (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.ietf.jgss
接口 GSSCredential

所有超级接口：
Cloneable
public interface GSSCredential
extends Cloneable

此接口将为实体封装 GSS-API 凭据。凭据包含所有必要的加密信息，这些信息使创建的上下文能够代表它所表示的实体。它可以包含多种不同的特定于机制的凭据元素，每种元素又包含有关特定的安全机制的信息，但所有这一切都指的是同一个实体。凭据可用来执行上下文初始化、接受（也可以同时执行二者）。

在 GSSManager 类中可使用其中的一种 createCredential 方法来初始化凭据。GSS-API 凭据的创建并不是为了提供“登录到网络”的功能，因为，此类功能会涉及到创建新的凭据，而不仅仅是获取对现有凭据的处理。package 级别介绍中的 section on credential acquisition 介绍了如何在 Java 平台中获取现有的凭据。GSS-API 实现必须对调用者实施本地访问控制策略，以防止未经授权的调用者获取他们无权获取的凭据。

应用程序将创建一个传输所需参数的凭据对象。然后应用程序可以使用查询方法来获取有关实例化的凭据对象的具体信息。当不需要凭据时，应用程序必须调用 dispose 方法来释该放凭据对象掌握的资源，并且销毁任何经过加密的敏感信息。

下面的示例代码演示了如何为特定的实体创建 GSSCredential 实现、查询其字段，以及不再需要它时如何释放它：

    GSSManager manager = GSSManager.getInstance();

    // start by creating a name object for the entity
    GSSName name = manager.createName("myusername", GSSName.NT_USER_NAME);

    // now acquire credentials for the entity
    GSSCredential cred = manager.createCredential(name,
                    GSSCredential.ACCEPT_ONLY);

    // display credential information - name, remaining lifetime,
    // and the mechanisms it has been acquired over
    System.out.println(cred.getName().toString());
    System.out.println(cred.getRemainingLifetime());

    Oid [] mechs = cred.getMechs();
    if (mechs != null) {
            for (int i = 0; i < mechs.length; i++)
                    System.out.println(mechs[i].toString());
    }

    // release system resources held by the credential
    cred.dispose();

从以下版本开始：
1.4
另请参见：
GSSManager.createCredential(int),
GSSManager.createCredential(GSSName, int, Oid, int),
GSSManager.createCredential(GSSName, int, Oid[], int),
dispose()

字段摘要
static int | ACCEPT_ONLY 凭据使用标志，要求凭据仅可用于上下文接受。
static int | DEFAULT_LIFETIME 一个表示默认的凭据生存期的生存期常量。
static int | INDEFINITE_LIFETIME 一个表示不确定的凭据生存期的生存期常量。
static int | INITIATE_AND_ACCEPT 凭据使用标志，它要求凭据既可用于上下文初始化也可用于接受。
static int | INITIATE_ONLY 凭据使用标志，要求凭据仅可用于上下文初始化。
方法摘要
void | add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage) 将特定于机制的凭据元素添加到现有的凭据中。
void | dispose() 释放 GSSCredential 对象可能包含的任何敏感信息。
boolean | equals(Object another) 进行测试，看此 GSSCredential 是否具有与提供的对象相同的实体。
Oid[] | getMechs() 返回受此凭据支持的机制的列表。
GSSName | getName() 检索凭据所维护的实体的名称。
GSSName | getName(Oid mech) 检索凭据所维护的实体的 Mechanism Name（机制名称）。
int | getRemainingAcceptLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制接受安全上下文。
int | getRemainingInitLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制初始化安全上下文。
int | getRemainingLifetime() 返回凭据所剩余的以秒为单位的生存期。
int | getUsage() 返回凭据使用模式。
int | getUsage(Oid mech) 返回特定机制的凭据使用模式。
int | hashCode() 返回此 GSSCredential 的哈希码值。

字段详细信息

INITIATE_AND_ACCEPT

static final int INITIATE_AND_ACCEPT
凭据使用标志，它要求凭据既可用于上下文初始化也可用于接受。

另请参见：
常量字段值

INITIATE_ONLY

static final int INITIATE_ONLY
凭据使用标志，要求凭据仅可用于上下文初始化。

另请参见：
常量字段值

ACCEPT_ONLY

static final int ACCEPT_ONLY
凭据使用标志，要求凭据仅可用于上下文接受。

另请参见：
常量字段值

DEFAULT_LIFETIME

static final int DEFAULT_LIFETIME
一个表示默认的凭据生存期的生存期常量。此值被设置为 0。

另请参见：
常量字段值

INDEFINITE_LIFETIME

static final int INDEFINITE_LIFETIME
一个表示不确定的凭据生存期的生存期常量。在 Java 中必须将此值设置为最大整数值 -- Integer.MAX_VALUE。

另请参见：
常量字段值
方法详细信息

dispose

void dispose()
             throws GSSException
释放 GSSCredential 对象可能包含的任何敏感信息。一旦不再需要某个凭据，应用程序就要立即调用此方法，以便将维护敏感信息所需的时间降至最低。

抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

getName

GSSName getName()
                throws GSSException
检索凭据所维护的实体的名称。

返回：
一个代表该实体的 GSSName
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

getName

GSSName getName(Oid mech)
                throws GSSException
检索凭据所维护的实体的 Mechanism Name（机制名称）。这相当于对其他形式的 getName 返回的值调用规范化。

参数：
mech - 应该为其返回“Mechanism Name”的机制的 Oid。
返回：
一个表示已针对需要的机制对实体进行规范化的 GSSName
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_MECH GSSException.BAD_MECH}, GSSException.FAILURE
GSSException

getRemainingLifetime

int getRemainingLifetime()
                         throws GSSException
返回凭据所剩余的以秒为单位的生存期。在所有的特定于基础机制的凭据元素中，剩余生存期是最小的生存期。

返回：
此凭据所剩余的以秒为单位的生存期。返回 INDEFINITE_LIFETIME 一值表示凭据尚未到期。返回 0 值表示凭据已经过期。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException
另请参见：
getRemainingInitLifetime(Oid), getRemainingAcceptLifetime(Oid)

getRemainingInitLifetime

int getRemainingInitLifetime(Oid mech)
                             throws GSSException
返回凭据以秒为单位的生存期，以便能够继续使用指定的机制初始化安全上下文。此方法将查询属于指定机制的初始端凭据元素。

参数：
mech - 必须查询其初始端凭据元素的机制的 Oid。
返回：
在此凭据元素可以存留的秒数。返回 INDEFINITE_LIFETIME 值表示凭据元素尚未到期。返回 0 值表示凭据元素已经过期。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_MECH GSSException.BAD_MECH}, GSSException.FAILURE
GSSException

getRemainingAcceptLifetime

int getRemainingAcceptLifetime(Oid mech)
                               throws GSSException
返回凭据以秒为单位的生存期，以便能够继续使用指定的机制接受安全上下文。此方法将查询属于指定机制的接受端凭据元素。

参数：
mech - 必须查询其接受端凭据元素的机制的 Oid。
返回：
此凭据元素存留的秒数。返回 INDEFINITE_LIFETIME 一值表示凭据元素尚未到期。返回 0 值表示凭据元素已经过期。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_MECH GSSException.BAD_MECH}, GSSException.FAILURE
GSSException

getUsage

int getUsage()
             throws GSSException
返回凭据使用模式。换句话说，就是它可以告诉我们，此凭据是否可以用来初始化或接受安全上下文。但它无法告诉我们为了这样做必须使用哪（个）些机制。人们希望应用程序在调用此方法之后允许 GSS-API 挑选出默认的机制。

返回：
返回的值将是以下三者之一：INITIATE_ONLY、ACCEPT_ONLY 和 INITIATE_AND_ACCEPT。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

getUsage

int getUsage(Oid mech)
             throws GSSException
返回特定机制的凭据使用模式。换句话说，就是它可以告诉我们，此凭据是否可以用来初始化或接受具有指定的基础机制的安全上下文。

参数：
mech - 其凭据使用模式需要确定的机制的 Oid。
返回：
返回的值将是以下三者之一：INITIATE_ONLY、ACCEPT_ONLY 和 INITIATE_AND_ACCEPT。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_MECH GSSException.BAD_MECH}, GSSException.FAILURE
GSSException

getMechs

Oid[] getMechs()
               throws GSSException
返回受此凭据支持的机制的列表。但它无法告诉我们，哪些可用来初始化上下文，哪些可用来接受上下文。应用程序必须使用每个返回的 Oid 调用 getUsage 方法，以便确定可以使用的模式。

返回：
一个与受支持的机制一致的 Oid 的数组。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

add

void add(GSSName name,
         int initLifetime,
         int acceptLifetime,
         Oid mech,
         int usage)
         throws GSSException
将特定于机制的凭据元素添加到现有的凭据中。此方法允许构建凭据，每次一个机制。

预计此例程主要由上下文接受端在创建接受端凭据时使用，这些凭据可用于使用不同安全机制的各种客户端。

此例程将添加这一新的凭据元素到合适的地方。为了将该元素添加到新的凭据中，首先要调用 clone 以获取此凭据的一个副本，然后再调用其 add 方法。

与以往一样，GSS-API 实现必须向调用者实施本地访问控制策略，以防止未经授权的调用者获取他们无权获取的凭据。 initLifetime 和 acceptLifetime 的非默认值并不总能得到基础机制的认可，因此，调用者必须准备调用凭据上的 getRemainingInitLifetime 和 getRemainingAcceptLifetime。

参数：
name - 将为其获取此凭据的主体的名称。使用 null 来指定默认的主体。
initLifetime - 为初始化安全上下文，凭据元素应该保持有效的秒数。为此，请使用 GSSCredential.INDEFINITE_LIFETIME，以请求该凭据应具有最大允许生存期。为此，请使用 GSSCredential.DEFAULT_LIFETIME 请求默认的生存期。
acceptLifetime - 为接受安全上下文，凭据元素应该保持有效的秒数。为此，请使用 GSSCredential.INDEFINITE_LIFETIME，以请求该凭据应具有最大允许生存期。为此，请使用 GSSCredential.DEFAULT_LIFETIME 请求默认的生存期。
mech - 通过它获取凭据的机制。
usage - 此凭据元素应该添加到凭据所使用的使用模式。此参数的值必须是下列值之一：INITIATE_AND_ACCEPT、ACCEPT_ONLY 和 INITIATE_ONLY。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DUPLICATE_ELEMENT GSSException.DUPLICATE_ELEMENT}, GSSException.BAD_MECH, GSSException.BAD_NAMETYPE, GSSException.NO_CRED, GSSException.CREDENTIALS_EXPIRED, GSSException.FAILURE
GSSException

equals

boolean equals(Object another)
进行测试，看此 GSSCredential 是否具有与提供的对象相同的实体。这两个凭据必须通过相同的机制获取，并且必须指相同的主体。

覆盖：
类 Object 中的 equals
参数：
another - 与此 GSSCredential 进行比较的另外一个 GSSCredential
返回：
如果两个 GSSCredential 表示相同的实体，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 GSSCredential 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GSSException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.ietf.jgss
类 GSSException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.ietf.jgss.GSSException
所有已实现的接口：
Serializable
public class GSSException
extends Exception

每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。它包括主要和次要的 GSS-API 状态码。主要错误代码是指那些在此类的 GSS-API 级别定义的代码。次要错误代码是指特定于机制的错误代码，他们可以提供附加的信息。基础机制实现负责在抛出此异常时设置适当的次要状态码除向调用者提供数值错误代码外，此类还执行从其数值到文本表示形式的映射。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
static int | BAD_BINDINGS 通道绑定不匹配。
static int | BAD_MECH 请求了不受支持的机制。
static int | BAD_MIC 具有无效的完整性检查的标记。
static int | BAD_NAME 提供了无效名称。
static int | BAD_NAMETYPE 提供了不受支持的类型的名称。
static int | BAD_QOP 不受支持的 QOP 值。
static int | BAD_STATUS 无效的状态码。
static int | CONTEXT_EXPIRED 安全上下文过期。
static int | CREDENTIALS_EXPIRED 过期的凭据。
static int | DEFECTIVE_CREDENTIAL 有缺陷的凭据。
static int | DEFECTIVE_TOKEN 有缺陷的标记。
static int | DUPLICATE_ELEMENT 请求了重复的凭据元素。
static int | DUPLICATE_TOKEN 该标记是前面标记的一个副本。
static int | FAILURE 未在 GSS-API 级别指定的一般故障。
static int | GAP_TOKEN 未收到需要的 per-message 标记。
static int | NAME_NOT_MN 包含多机制元素的名称。
static int | NO_CONTEXT 无效的安全上下文。
static int | NO_CRED 无效的凭据。
static int | OLD_TOKEN 该标记已无效。
static int | UNAUTHORIZED 未授权的操作。
static int | UNAVAILABLE 不可用的操作。
static int | UNSEQ_TOKEN 后面的标记已处理过。
构造方法摘要
GSSException(int majorCode)
使用指定的主要代码创建一个 GSSException 对象。
GSSException(int majorCode, int minorCode, String minorString)
使用指定的主要代码、次要代码和次要代码文本性解释，创建一个 GSSException 对象。
方法摘要
int | getMajor() 返回导致抛出此异常的问题的 GSS-API 级主要错误代码。
String | getMajorString() 返回一个字符串，解释在此异常中 GSS-API 级的主要错误代码。
String | getMessage() 返回主要和次要状态码的文本表示形式。
int | getMinor() 返回导致抛出此异常的问题的机制级错误代码。
String | getMinorString() 返回解释特定于机制的错误代码的字符串。
void | setMinor(int minorCode, String message) 由异常抛出器使用，以设置机制级的次要错误代码及其字符串解释。
String | toString() 返回主要和次要状态码的文本表示形式。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

BAD_BINDINGS

public static final int BAD_BINDINGS
通道绑定不匹配。

另请参见：
常量字段值

BAD_MECH

public static final int BAD_MECH
请求了不受支持的机制。

另请参见：
常量字段值

BAD_NAME

public static final int BAD_NAME
提供了无效名称。

另请参见：
常量字段值

BAD_NAMETYPE

public static final int BAD_NAMETYPE
提供了不受支持的类型的名称。

另请参见：
常量字段值

BAD_STATUS

public static final int BAD_STATUS
无效的状态码。

另请参见：
常量字段值

BAD_MIC

public static final int BAD_MIC
具有无效的完整性检查的标记。

另请参见：
常量字段值

CONTEXT_EXPIRED

public static final int CONTEXT_EXPIRED
安全上下文过期。

另请参见：
常量字段值

CREDENTIALS_EXPIRED

public static final int CREDENTIALS_EXPIRED
过期的凭据。

另请参见：
常量字段值

DEFECTIVE_CREDENTIAL

public static final int DEFECTIVE_CREDENTIAL
有缺陷的凭据。

另请参见：
常量字段值

DEFECTIVE_TOKEN

public static final int DEFECTIVE_TOKEN
有缺陷的标记。

另请参见：
常量字段值

FAILURE

public static final int FAILURE
未在 GSS-API 级别指定的一般故障。

另请参见：
常量字段值

NO_CONTEXT

public static final int NO_CONTEXT
无效的安全上下文。

另请参见：
常量字段值

NO_CRED

public static final int NO_CRED
无效的凭据。

另请参见：
常量字段值

BAD_QOP

public static final int BAD_QOP
不受支持的 QOP 值。

另请参见：
常量字段值

UNAUTHORIZED

public static final int UNAUTHORIZED
未授权的操作。

另请参见：
常量字段值

UNAVAILABLE

public static final int UNAVAILABLE
不可用的操作。

另请参见：
常量字段值

DUPLICATE_ELEMENT

public static final int DUPLICATE_ELEMENT
请求了重复的凭据元素。

另请参见：
常量字段值

NAME_NOT_MN

public static final int NAME_NOT_MN
包含多机制元素的名称。

另请参见：
常量字段值

DUPLICATE_TOKEN

public static final int DUPLICATE_TOKEN
该标记是前面标记的一个副本。这是在上下文创建期间出现的一个致命性错误代码。它并不用于表示增补状态值。而是使用 MessageProp 对象来表示该值。

另请参见：
常量字段值

OLD_TOKEN

public static final int OLD_TOKEN
该标记已无效。这是在上下文创建期间出现的一个致命性错误代码。它并不用于表示增补状态值。而是使用 MessageProp 对象来表示该值。

另请参见：
常量字段值

UNSEQ_TOKEN

public static final int UNSEQ_TOKEN
后面的标记已处理过。这是在上下文创建期间出现的一个致命性错误代码。它并不用于表示增补状态值。而是使用 MessageProp 对象来表示该值。

另请参见：
常量字段值

GAP_TOKEN

public static final int GAP_TOKEN
未收到需要的 per-message 标记。这是在上下文创建期间出现的一个致命性错误代码。它并不用于表示增补状态值。而是使用 MessageProp 对象来表示该值。

另请参见：
常量字段值
构造方法详细信息

GSSException

public GSSException(int majorCode)
使用指定的主要代码创建一个 GSSException 对象。

参数：
majorCode - 导致抛出此异常的问题的 GSS 错误代码。

GSSException

public GSSException(int majorCode,
                    int minorCode,
                    String minorString)
使用指定的主要代码、次要代码和次要代码文本性解释，创建一个 GSSException 对象。此构造方法将在异常产生自基础机制级时使用。它允许设置 GSS 代码和机制代码。

参数：
majorCode - 导致抛出此异常的问题的 GSS 错误代码。
minorCode - 导致抛出此异常的问题的机制级错误代码。
minorString - 机制错误代码的文本解释。
方法详细信息

getMajor

public int getMajor()
返回导致抛出此异常的问题的 GSS-API 级主要错误代码。主要错误代码将在此类中独立于机制的 GSS-API 级定义。可以提供更多信息的特定于机制的错误代码将被设置为次要的错误代码。

返回：
int 导致异常的 GSS-API 级错误代码
另请参见：
getMajorString(),
getMinor(),
getMinorString()

getMinor

public int getMinor()
返回导致抛出此异常的问题的机制级错误代码。次要代码通过基础机制设置。

返回：
int 机制错误代码；0 表示尚未设置该错误代码。
另请参见：
getMinorString(), setMinor(int, java.lang.String)

getMajorString

public String getMajorString()
返回一个字符串，解释在此异常中 GSS-API 级的主要错误代码。

返回：
字符串，主要错误代码的解释字符串
另请参见：
getMajor(), toString()

getMinorString

public String getMinorString()
返回解释特定于机制的错误代码的字符串。如果次要状态码为 0，则不会提供机制级的错误详细信息。

返回：
字符串，机制错误代码的文本解释
另请参见：
getMinor(),
getMajorString(),
toString()

setMinor

public void setMinor(int minorCode,
                     String message)
由异常抛出器使用，以设置机制级的次要错误代码及其字符串解释。机制提供者使用它来表示错误详细信息。

参数：
minorCode - 特定于机制的错误代码
message - 机制错误代码的文本解释
另请参见：
getMinor()

toString

public String toString()
返回主要和次要状态码的文本表示形式。

覆盖：
类 Throwable 中的 toString
返回：
一个带有错误描述的字符串

getMessage

public String getMessage()
返回主要和次要状态码的文本表示形式。

覆盖：
类 Throwable 中的 getMessage
返回：
一个带有错误描述的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GSSManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.ietf.jgss
类 GSSManager

java.lang.Object
    继承者  org.ietf.jgss.GSSManager

public abstract class GSSManager
extends Object

此类作为其他重要 GSS-API 类的工厂，并且还提供有关受支持的机制的信息。它可以创建实现以下三个 GSS-API 接口的类的实例：GSSName、GSSCredential 和 GSSContext。它还具有一些查询可用的机制列表和每个机制支持的名称类型的方法。

默认的 GSSManager 子类的实例可以通过静态方法 getInstance 获取，但应用程序可以随意实例化 GSSManager 的其他字类。除其他机制外，默认的 GSSManager 实例还支持 Kerberos v5 GSS-API 机制。此机制由 Oid "1.2.840.113554.1.2.2" 标识，并在 RFC 1964 中定义。

扩展 GSSManager 抽象类的子类可以实现为基于模块化的提供者层，该层可利用一些人们熟知的服务提供者规范。GSSManager API 允许应用程序设置此类实现的首选的提供者。这些方法还允许实现抛出经过定义明确的异常，以防基于提供者的配置不受支持。那些希望移植的应用程序必须意识到这一点，并能够通过捕获异常进行彻底恢复。

预计将有三种使用提供者的最常见方法：

  1. 应用程序并不关心使用什么提供者（默认情况下）。
  2. 应用程序希望优先使用特定的提供者，或者针对特定的机制，或者始终如此，与机制无关。
  3. 应用程序希望尽可能使用本地配置的提供者，但是，如果失去了对一个或多个机制的支持，则应用程序就会回调它自己的提供者。

GSSManager 类有两种支持这些使用模式的方法：addProviderAtFront 和 addProviderAtEnd。这两种方法可以创建 <provider, oid> 对的有序列表，其中的每个对都指示指定 oid 的一个首选提供者。

需要注意的一点是，在由 GSSManager 创建的不同的 GSS-API 对象之间存在着一定的交互，其中，用于特定机制的提供者可能需要对所有的对象保持一致。例如，如果 GSSCredential 包含来自机制 m 的提供者 p 中的元素，则通常要将它传递给一个将使用机制 m 的提供者 p 的 GSSContext。实现最大可移植性的简单经验就是，不要混合从不同的 GSSManager 中创建的对象，如果应用程序想在已经创建了对象的 GSSManager 上调用 addProviderAtFront 方法，在可能的情况下，则必须创建不同的 GSSManager 实例。

下面是一些示例代码，它显示了如何使用 GSSManager：

     GSSManager manager = GSSManager.getInstance();

     Oid krb5Mechanism = new Oid("1.2.840.113554.1.2.2");
     Oid krb5PrincipalNameType = new Oid("1.2.840.113554.1.2.2.1");

     // Identify who the client wishes to be
     GSSName userName = manager.createName("duke", GSSName.NT_USER_NAME);

     // Identify the name of the server. This uses a Kerberos specific
     // name format.
     GSSName serverName = manager.createName("nfs/foo.sun.com",
                                             krb5PrincipalNameType);

     // Acquire credentials for the user
     GSSCredential userCreds = manager.createCredential(userName,
                                             GSSCredential.DEFAULT_LIFETIME,
                                             krb5Mechanism,
                                             GSSCredential.INITIATE_ONLY);

     // Instantiate and initialize a security context that will be
     // established with the server
     GSSContext context = manager.createContext(serverName,
                                                krb5Mechanism,
                                                userCreds,
                                                GSSContext.DEFAULT_LIFETIME);

服务器端可能会使用此源的以下变量：

     // Acquire credentials for the server
     GSSCredential serverCreds = manager.createCredential(serverName,
                                             GSSCredential.DEFAULT_LIFETIME,
                                             krb5Mechanism,
                                             GSSCredential.ACCEPT_ONLY);

     // Instantiate and initialize a security context that will
     // wait for an establishment request token from the client
     GSSContext context = manager.createContext(serverCreds);

从以下版本开始：
1.4
另请参见：
GSSName, GSSCredential, GSSContext

构造方法摘要
GSSManager()
方法摘要
abstract void | addProviderAtEnd(Provider p, Oid mech) 此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
abstract void | addProviderAtFront(Provider p, Oid mech) 此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。
abstract GSSContext | createContext(byte[] interProcessToken) 创建以前导出的上下文的 Factory 方法。
abstract GSSContext | createContext(GSSCredential myCred) 为接受端一方创建上下文的 Factory 方法。
abstract GSSContext | createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。
abstract GSSCredential | createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
abstract GSSCredential | createCredential(int usage) 获取默认凭据的 Factory 方法。
abstract GSSName | createName(byte[] name, Oid nameType) 将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | createName(byte[] name, Oid nameType, Oid mech) 将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract GSSName | createName(String nameStr, Oid nameType) 将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | createName(String nameStr, Oid nameType, Oid mech) 将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
static GSSManager | getInstance() 返回默认的 GSSManager 实现。
abstract Oid[] | getMechs() 返回一个可通过此 GSSManager 提供给 GSS-API 调用者的机制列表。
abstract Oid[] | getMechsForName(Oid nameType) 返回支持指定的名称类型的机制的列表。
abstract Oid[] | getNamesForMech(Oid mech) 然后返回由指定的机制所支持的名称类型。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GSSManager

public GSSManager()
方法详细信息

getInstance

public static GSSManager getInstance()
返回默认的 GSSManager 实现。

返回：
GSSManager 实现

getMechs

public abstract Oid[] getMechs()
返回一个可通过此 GSSManager 提供给 GSS-API 调用者的机制列表。从 getInstance() 方法中获取的默认 GSSManager 将 Oid "1.2.840.113554.1.2.2" 放在了其列表中。此 Oid 可确定已在 RFC 1964 中定义的 Kerberos v5 GSS-API 机制。

返回：
一些与可用的机制对应的 Oid 对象。当没有机制可用时（例如正在动态配置机制，并且当前未设置任何机制），将返回 null 值

getNamesForMech

public abstract Oid[] getNamesForMech(Oid mech)
                               throws GSSException
然后返回由指定的机制所支持的名称类型。

默认的 GSSManager 实例包括对 Kerberos v5 机制的支持。当指定此机制 ("1.2.840.113554.1.2.2") 时，返回的列表至少将包括以下名称类型：GSSName.NT_HOSTBASED_SERVICE、GSSName.NT_EXPORT_NAME 和特定于 Kerberos v5 的 Oid "1.2.840.113554.1.2.2.1"。Oid "1.2.840.113554.1.2.2.1" 的名称空间在 RFC 1964 中进行了定义。

参数：
mech - 将查询的机制 Oid
返回：
一些与该机制支持的名称类型对应的 Oid 对象。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#UNAVAILABLE GSSException.UNAVAILABLE}、GSSException.FAILURE
GSSException
另请参见：
getMechsForName(Oid)

getMechsForName

public abstract Oid[] getMechsForName(Oid nameType)
返回支持指定的名称类型的机制的列表。

当指定的名称类型是 GSSName.NT_HOSTBASED_SERVICE、GSSName.NT_EXPORT_NAME 或 "1.2.840.113554.1.2.2.1" 这三者之一时，在此列表中将始终返回 Kerberos v5 机制 ("1.2.840.113554.1.2.2")。

参数：
nameType - 要查找的名称类型的 Oid
返回：
一些与支持指定的名称类型的机制对应的 Oid 对象。当没有机制支持指定的名称类型时，将返回 null。
另请参见：
getNamesForMech(Oid)

createName

public abstract GSSName createName(String nameStr,
                                   Oid nameType)
                            throws GSSException
将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。通常，创建的 GSSName 对象包括该名称的多种表示形式，每个受支持的机制都有一种表示形式；此种情况的两个例外示例是：名称空间类型参数指示为 NT_EXPORT_NAME 或 GSS-API 实现不是多机制。建议不要将此方法用于 NT_EXPORT_NAME 类型，因为将以前导出的名称（由任意字节构成）表示为 String 可能会导致字符编码方案问题。在此情形下，建议将字节直接传入 createName 这一方法的重载形式。

参数：
nameStr - 表示要创建的名称的可打印形式的字符串。
nameType - 指定所提供的可打印名称的名称空间的 Oid。null 可以用来指定，特定于机制的默认可打印语法应该根据每个检查 nameStr 的机制进行假定。建议不要将名称类型 NT_EXPORT_NAME 用于此方法。
返回：
一个表示所指定主体的 GSSName
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_NAMETYPE GSSException.BAD_NAMETYPE}、GSSException.BAD_NAME、GSSException.BAD_MECH、GSSException.FAILURE
GSSException
另请参见：
GSSName, GSSName.NT_EXPORT_NAME

createName

public abstract GSSName createName(byte[] name,
                                   Oid nameType)
                            throws GSSException
将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。通常，创建的 GSSName 对象包括该名称的多种表示形式，每个受支持的机制都有一种表示形式；此种情况的两个例外示例是：名称空间类型参数指示为 NT_EXPORT_NAME 或 GSS-API 实现不是多机制。传入的字节将由每种基础机制根据它所选择的编码方案针对指定的命名类型进行解释。

参数：
name - 包含要创建的名称的字节数组
nameType - 指定在字节数组中提供的名称的名称空间的 Oid。null可用来指定，特定于机制的默认可打印语法应该根据每个检查字节数组的机制进行假定。
返回：
一个表示所指定主体的 GSSName
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_NAMETYPE GSSException.BAD_NAMETYPE}、GSSException.BAD_NAME、GSSException.BAD_MECH、GSSException.FAILURE
GSSException
另请参见：
GSSName, GSSName.NT_EXPORT_NAME

createName

public abstract GSSName createName(String nameStr,
                                   Oid nameType,
                                   Oid mech)
                            throws GSSException
将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。换句话说，此方法是一种实用程序，它执行以下两个步骤的等效步骤：首先是 createName，然后是 GSSName.canonicalize。

参数：
nameStr - 表示要创建的名称的可打印形式的字符串。
nameType - 指定所提供的可打印名称的名称空间的 Oid。null 可以用来指定，特定于机制的默认可打印语法应该根据每个检查 nameStr 的机制进行假定。建议不要将名称类型 NT_EXPORT_NAME 用于此方法。
mech - 指定应该为其规范化名称的机制的 Oid
返回：
一个表示指定的主体的 GSSName
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_NAMETYPE GSSException.BAD_NAMETYPE}、GSSException.BAD_NAME、GSSException.BAD_MECH、GSSException.FAILURE
GSSException
另请参见：
GSSName.canonicalize(Oid), GSSName.NT_EXPORT_NAME

createName

public abstract GSSName createName(byte[] name,
                                   Oid nameType,
                                   Oid mech)
                            throws GSSException
将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。换句话说，此方法是一种实用程序，它执行以下两个步骤的等效步骤：首先是 createName，然后是 GSSName.canonicalize。

参数：
name - 包含要创建的名称的字节数组
nameType - 指定在字节数组中提供的名称的名称空间的 Oid。null可用来指定，特定于机制的默认可打印语法应该根据每个检查字节数组的机制进行假定。
mech - 指定应该为其规范化名称的机制的 Oid
返回：
一个表示指定的主体的 GSSName
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_NAMETYPE GSSException.BAD_NAMETYPE}、GSSException.BAD_NAME、GSSException.BAD_MECH、GSSException.FAILURE
GSSException
另请参见：
GSSName.canonicalize(Oid), GSSName.NT_EXPORT_NAME

createCredential

public abstract GSSCredential createCredential(int usage)
                                        throws GSSException
获取默认凭据的 Factory 方法。这会导致 GSS-API 将特定于系统的默认实现用于机制、名称和生存期的 set。

GSS-API 机制提供商必须对调用者实施本地访问控制策略施，以防止未经授权的调用者获取他们无权获取的凭据。不同机制提供商需要的权限种类将以机制为单位记录在文档中。失败的权限检查可能会导致从此方法中抛出 SecurityException。

参数：
usage - 此凭据对象的预期用途。此参数的值必须是下列值之一：GSSCredential.INITIATE_AND_ACCEPT、GSSCredential.ACCEPT_ONLY 和 GSSCredential.INITIATE_ONLY。
返回：
所请求类型的 GSSCredential。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_MECH GSSException.BAD_MECH}、GSSException.BAD_NAMETYPE、GSSException.BAD_NAME、GSSException.CREDENTIALS_EXPIRED、GSSException.NO_CRED、GSSException.FAILURE
GSSException
另请参见：
GSSCredential

createCredential

public abstract GSSCredential createCredential(GSSName name,
                                               int lifetime,
                                               Oid mech,
                                               int usage)
                                        throws GSSException
获取单个机制凭据的 Factory 方法。

GSS-API 机制提供商必须对调用者实施本地访问控制策略施，以防止未经授权的调用者获取他们无权获取的凭据。不同机制提供商需要的权限种类将以机制为单位记录在文档中。失败的权限检查可能会导致从此方法中抛出 SecurityException。

生存期的非默认值并不总能得到基础机制的认可，因此，应用程序必须随时准备根据返回的凭据调用 getRemainingLifetime。

参数：
name - 将为其获取此凭据的主体的名称。使用 null 来指定默认的主体。
lifetime - 凭据应该保持有效的秒数。使用 GSSCredential.INDEFINITE_LIFETIME 请求证书具有最大允许生存期。使用 GSSCredential.DEFAULT_LIFETIME 请求默认的凭据生存期。
mech - 所需机制的 Oid。使用 (Oid) null 来请求默认的机制。
usage - 此凭据对象的预期用途。此参数的值必须是下列值之一：GSSCredential.INITIATE_AND_ACCEPT、GSSCredential.ACCEPT_ONLY 和 GSSCredential.INITIATE_ONLY。
返回：
所请求类型的 GSSCredential。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_MECH GSSException.BAD_MECH}、GSSException.BAD_NAMETYPE、GSSException.BAD_NAME、GSSException.CREDENTIALS_EXPIRED、GSSException.NO_CRED、GSSException.FAILURE
GSSException
另请参见：
GSSCredential

createCredential

public abstract GSSCredential createCredential(GSSName name,
                                               int lifetime,
                                               Oid[] mechs,
                                               int usage)
                                        throws GSSException
通过一套机制获取凭据的 Factory 方法。此方法尝试为在称为 mechs 的数组中指定的每个机制获取凭据。若要确定成功为其获取凭据的机制列表，调用者应该使用 GSSCredential.getMechs 方法。

GSS-API 机制提供商必须对调用者实施本地访问控制策略施，以防止未经授权的调用者获取他们无权获取的凭据。不同机制提供商需要的权限种类将以机制为单位记录在文档中。失败的权限检查可能会导致从此方法中抛出 SecurityException。

生存期的非默认值并不总能得到基础机制的认可，因此，应用程序必须随时准备根据返回的凭据调用 getRemainingLifetime。

参数：
name - 将为其获取此凭据的主体的名称。使用 null 来指定默认的主体。
lifetime - 凭据应该保持有效的秒数。使用 GSSCredential.INDEFINITE_LIFETIME 请求证书具有最大允许生存期。使用 GSSCredential.DEFAULT_LIFETIME 请求默认的凭据生存期。
mechs - Oid 组成的数组，指示获取凭据的机制。使用 (Oid[]) null 请求机制特定于系统的默认 set。
usage - 此凭据对象的预期用途。此参数的值必须是下列值之一：GSSCredential.INITIATE_AND_ACCEPT、GSSCredential.ACCEPT_ONLY 和 GSSCredential.INITIATE_ONLY。
返回：
所请求类型的 GSSCredential。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_MECH GSSException.BAD_MECH}、GSSException.BAD_NAMETYPE、GSSException.BAD_NAME、GSSException.CREDENTIALS_EXPIRED、GSSException.NO_CRED、GSSException.FAILURE
GSSException
另请参见：
GSSCredential

createContext

public abstract GSSContext createContext(GSSName peer,
                                         Oid mech,
                                         GSSCredential myCred,
                                         int lifetime)
                                  throws GSSException
在初始端一方创建上下文的 Factory 方法。 有些机制提供商可能会要求调用者授予初始化安全上下文的权限。失败的权限检查可能会导致从此方法中抛出 SecurityException。

生存期的非默认值并不总能得到基础机制的认可，因此，应用程序必须随时准备根据返回的上下文调用 getLifetime。

参数：
peer - 目标同位体的名称。
mech - 所需机制的 Oid。使用 null 来请求默认的机制。
myCred - 初始端的凭据。将 null 用作默认的初始端主体。
lifetime - 为上下文请求的以秒为单位的生存期。使用 GSSContext.INDEFINITE_LIFETIME 请求上下文具有最大允许的生存期。使用 GSSContext.DEFAULT_LIFETIME 请求上下文的默认生存期。
返回：
未创建的 GSSContext
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DEFECTIVE_TOKEN GSSException.DEFECTIVE_TOKEN}、GSSException.BAD_MIC、GSSException.CONTEXT_EXPIRED、GSSException.FAILURE
GSSException
另请参见：
GSSContext

createContext

public abstract GSSContext createContext(GSSCredential myCred)
                                  throws GSSException
为接受端一方创建上下文的 Factory 方法。上下文的属性将通过提供给 accept 方法的输入标记来确定。 有些机制提供商可能会要求调用者授予接受安全上下文的权限。失败的权限检查可能会导致从此方法中抛出 SecurityException。

参数：
myCred - 接受端的凭据。将 null 用作默认的接受端主体。
返回：
未创建的 GSSContext
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#DEFECTIVE_TOKEN GSSException.DEFECTIVE_TOKEN}、GSSException.BAD_MIC、GSSException.CONTEXT_EXPIRED、GSSException.FAILURE
GSSException
另请参见：
GSSContext

createContext

public abstract GSSContext createContext(byte[] interProcessToken)
                                  throws GSSException
创建以前导出的上下文的 Factory 方法。上下文属性将通过输入标记来确定，并且不能通过 set 方法进行修改。

不要求实现支持安全上下文的进程间的传输。在导出文本前，调用 GSSContext.isTransferable 将表示上下文是否可传输。在不支持它的实现中调用此方法会导致 GSSException，并带有错误代码 GSSException.UNAVAILABLE。 有些机制提供商可能会要求调用者授予初始化或接受安全上下文的权限。失败的权限检查可能会导致从此方法中抛出 SecurityException。

参数：
interProcessToken - 以前从导出方法中发出的标记。
返回：
以前创建的 GSSContext
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#NO_CONTEXT GSSException.NO_CONTEXT}、GSSException.DEFECTIVE_TOKEN、GSSException.UNAVAILABLE、GSSException.UNAUTHORIZED、GSSException.FAILURE
GSSException
另请参见：
GSSContext

addProviderAtFront

public abstract void addProviderAtFront(Provider p,
                                        Oid mech)
                                 throws GSSException
此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。当将 null （而不是 Oid）一值用于机制时，GSSManager 必须优先于其他提供者而使用指示的提供者，而不管机制是什么。仅当指示的提供者不支持所需的机制时，才应将 GSSManager 移动到另外的提供者上。

重复调用此方法可以保存较旧的设置，但这会降低它们的优先级，从而在顶端形成一个提供者和 Oid 对有序列表。

调用带有 null Oid 的 addProviderAtFront 将移除在 GSSManager 实例中为此提供者设置的所有原来的优先级。调用带有非 null Oid 的 addProviderAtFront 将移除使用此机制和此提供者一起设置的任何原来的优先级。

如果 GSSManager 实现不支持带有可插入提供者体系结构的 SPI，则必须抛出 GSSException，并带有状态码 GSSException.UNAVAILABLE，以表示操作不可用。

假设应用程序希望提供者 A 在任何机制需要时都始终第一个接受检查，则它将调用：

         GSSManager mgr = GSSManager.getInstance();
         // mgr may at this point have its own pre-configured list
         // of provider preferences. The following will prepend to
         // any such list:

         mgr.addProviderAtFront(A, null);
现在，如果它还希望在对原来的 set A 进行检查之前始终能从提供者 B 中获取机制 Oid m1，则它将调用：

         mgr.addProviderAtFront(B, m1);
这时，如果需要 m1，GSSManager 将首先检查 B。万一 B 未提供对 m1 的支持，GSSManager 将继续检查 A。如果需要机制 m2（其中 m2 不同于 m1），则 GSSManager 将跳过 B 而直接检查 A。

假设后来对同一 GSSManager 实例又进行了以下调用：

         mgr.addProviderAtFront(B, null)
那么将包含原来具有 (B, m1) 对的设置，该设置应该移除。实际上，优先级列表现在变成了 {(B, null), (A, null), ...//后面是预配置的列表。

不过，请注意下面的调用：

         mgr.addProviderAtFront(A, m3)
并不包括原来的设置 (A, null)，并且列表实际上将变为 {(A, m3), (B, null), (A, null), ...}

参数：
p - 当 mech 需要支持时应该使用的提供者实例。
mech - 将为之设置提供者的机制
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#UNAVAILABLE GSSException.UNAVAILABLE}、GSSException.FAILURE
GSSException

addProviderAtEnd

public abstract void addProviderAtEnd(Provider p,
                                      Oid mech)
                               throws GSSException
此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。当将 null（而不是 Oid）一值用于机制时，GSSManager 必须将指示的提供者用于任何机制。

重复调用此方法可以保存较旧的设置，但这会使它们的优先级高于新的设置，从而在底端形成一个提供者和 Oid 对有序列表。因此，在利用此提供者设置之前将首先利用较旧的提供者设置。

如果存在与现有设置的优先级冲突的原有优先级，则 GSSManager 必须忽略此请求。

如果 GSSManager 实现不支持带有可插入提供者体系结构的 SPI，则必须抛出 GSSException，并带有状态码 GSSException.UNAVAILABLE，以表示操作不可用。

假设应用程序希望，在需要设置 Oid m1 时，始终第一个检查系统默认的提供者，并且仅在它们不支持 m1 时才检查提供者 A。则它将调用：

         GSSManager mgr = GSSManager.getInstance();
         mgr.addProviderAtEnd(A, m1);
现在，如果它还希望在检查完所有配置的提供者之后，针对所有的机制检查提供者 B，则它将调用：

         mgr.addProviderAtEnd(B, null);
实际上，优先级列表现在变成了 {..., (A, m1), (B, null)}。

假设后来对同一 GSSManager 实例又进行了以下调用：

         mgr.addProviderAtEnd(B, m2)
那么将包含原来具有 (B, null) 对的设置，因此应该忽略此请求。如果向已经存在的 (A, m1) 或 (B, null) 对 发出请求，也会出现同样的情况。

不过，请注意下面的调用：

         mgr.addProviderAtEnd(A, null)
并不包括原来的设置 (A, m1)，并且该列表实际上将变为 {..., (A, m1), (B, null), (A, null)}

参数：
p - 当 mech 需要支持时应该使用的提供者实例。
mech - 将为之设置提供者的机制
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#UNAVAILABLE GSSException.UNAVAILABLE}、GSSException.FAILURE
GSSException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GSSName (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.ietf.jgss
接口 GSSName

public interface GSSName

此接口将封装单一的 GSS-API 主体实体。应用程序将通过存在于GSSManager 类中的 createName 方法之一来获取此接口的实现。从概念上讲，GSSName 包含实体，或许多基本名称元素的表示形式，每个受支持的基础机制包含一个这样的表示形式。在 GSS 术语中，仅包含来自一种机制中的元素的 GSSName 称为机制名称 (MN)

由于不同的验证会使用不同的名称空间标识其主体，所以在多机制环境中 GSS-API 的命名支持有必要复杂一些（或者说，即使在某些基础机制要支持多名称空间的单一机制环境中也是如此）。不同的名称格式及其定义将使用 Oid's 来标识，而一些标准类型将在此接口中定义。名称的格式可以基于其名称类型唯一的 Oid 派生出来。

下面的代码中包含一些利用 GSSName 接口的代码示例。以下代码创建了一个 GSSName，然后将其转换为 MN，通过比较，获取该名称的可打印表示形式，将其导出到字节数组，然后再重新导入以获取一个新的 GSSName。

      GSSManager manager = GSSManager.getInstance();

      // create a host based service name
      GSSName name = manager.createName("service@host",
                   GSSName.NT_HOSTBASED_SERVICE);

      Oid krb5 = new Oid("1.2.840.113554.1.2.2");

      GSSName mechName = name.canonicalize(krb5);

      // the above two steps are equivalent to the following
      GSSName mechName = manager.createName("service@host",
                      GSSName.NT_HOSTBASED_SERVICE, krb5);

      // perform name comparison
      if (name.equals(mechName))
              print("Names are equals.");

      // obtain textual representation of name and its printable
      // name type
      print(mechName.toString() +
                      mechName.getStringNameType().toString());

      // export and re-import the name
      byte [] exportName = mechName.export();

      // create a new name object from the exported buffer
      GSSName newName = manager.createName(exportName,
                      GSSName.NT_EXPORT_NAME);

从以下版本开始：
1.4
另请参见：
export(),
equals(GSSName),
GSSManager.createName(String, Oid),
GSSManager.createName(String, Oid, Oid),
GSSManager.createName(byte[], Oid)

字段摘要
static Oid | NT_ANONYMOUS 表示匿名实体的名称类型。
static Oid | NT_EXPORT_NAME 用来表示通过导出方法产生的导出名称的名称类型。
static Oid | NT_HOSTBASED_SERVICE 表示基于主机的服务名称格式的 Oid。
static Oid | NT_MACHINE_UID_NAME 名称类型，表示与本地系统上的用户对应的数值型用户标识符。
static Oid | NT_STRING_UID_NAME 名称类型，指示一个由数字组成的字符串，表示本地系统上用户的数值型用户标识符。
static Oid | NT_USER_NAME 名称类型，表示在本地系统上指定的用户。
方法摘要
GSSName | canonicalize(Oid mech) 创建一个针对某种机制而规范化的名称。
boolean | equals(GSSName another) 比较两个 GSSName 对象，以确定它们是否指的是同一个实体。
boolean | equals(Object another) 将此 GSSName 对象与可能是 GSSName 的另一个对象进行比较。
byte[] | export() 返回机制名称 (MN) 的规范化连续字节表示形式，适合通过授权的功能进行直接的、逐字节比较。
Oid | getStringNameType() 返回此名称的可打印表示形式的名称类型，此名称可从 toString 方法中获取。
int | hashCode() 返回此 GSSName 的哈希码值。
boolean | isAnonymous() 测试此名称对象是否表示匿名的实体。
boolean | isMN() 测试此名称对象是否表示一个机制名称 (MN)。
String | toString() 返回 GSSName 对象的文本表示形式。

字段详细信息

NT_HOSTBASED_SERVICE

static final Oid NT_HOSTBASED_SERVICE
表示基于主机的服务名称格式的 Oid。用来表示与主计算机相关的服务。此名称格式由两种元素构成，即“服务”和“主机名称”，如下所示：service@hostname.

它表示以下 Oid 值：
{ 1(iso), 3(org), 6(dod), 1(internet), 5(security), 6(nametypes), 2(gss-host-based-services) }

NT_USER_NAME

static final Oid NT_USER_NAME
名称类型，表示在本地系统上指定的用户。

它表示以下 Oid 值：
{ iso(1) member-body(2) United States(840) mit(113554) infosys(1) gssapi(2) generic(1) user_name(1) }

NT_MACHINE_UID_NAME

static final Oid NT_MACHINE_UID_NAME
名称类型，表示与本地系统上的用户对应的数值型用户标识符。（例如，Uid）。

它表示以下 Oid 值：
{ iso(1) member-body(2) United States(840) mit(113554) infosys(1) gssapi(2) generic(1) machine_uid_name(2) }

NT_STRING_UID_NAME

static final Oid NT_STRING_UID_NAME
名称类型，指示一个由数字组成的字符串，表示本地系统上用户的数值型用户标识符。

它表示以下 Oid 值：
{ iso(1) member-body(2) United States(840) mit(113554) infosys(1) gssapi(2) generic(1) string_uid_name(3) }

NT_ANONYMOUS

static final Oid NT_ANONYMOUS
表示匿名实体的名称类型。

它表示以下 Oid 值：
{ 1(iso), 3(org), 6(dod), 1(internet), 5(security), 6(nametypes), 3(gss-anonymous-name) }

NT_EXPORT_NAME

static final Oid NT_EXPORT_NAME
用来表示通过导出方法产生的导出名称的名称类型。

它表示以下 Oid 值：
{ 1(iso), 3(org), 6(dod), 1(internet), 5(security), 6(nametypes), 4(gss-api-exported-name) }

方法详细信息

equals

boolean equals(GSSName another)
               throws GSSException
比较两个 GSSName 对象，以确定它们是否指的是同一个实体。

参数：
another - 将此名称与之比较的 GSSName
返回：
如果这两个名称至少包含一个共同的基本元素，则返回 true。如果这两个名称中的任一名称都表示匿名的实体，则该方法将返回 false。
抛出：
GSSException，当两个名称无法进行比较，包含以下主要错误代码时：{@link - GSSException#BAD_NAMETYPE GSSException.BAD_NAMETYPE}, GSSException.FAILURE
GSSException

equals

boolean equals(Object another)
将此 GSSName 对象与可能是 GSSName 的另一个对象进行比较。此行为与 equals 中的行为完全相同,除了没有 GSSException 抛出；而在出现错误时将返回 false。

覆盖：
类 Object 中的 equals
参数：
another - 将此名称与之进行比较的对象
返回：
如果将与之进行比较的对象也是 GSSName 并且两个名称都指的是同一个实体，则返回 true。
另请参见：
equals(GSSName)

hashCode

int hashCode()
返回此 GSSName 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

canonicalize

GSSName canonicalize(Oid mech)
                     throws GSSException
创建一个针对某种机制而规范化的名称。

参数：
mech - 机制的 oid，要为该机制请求名称的规范化格式。
返回：
GSSName，它仅包含一种基本元素，该元素用所需机制的规范化格式表示此名称。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_MECH GSSException.BAD_MECH}、@link GSSException#BAD_NAMETYPE GSSException.BAD_NAMETYPE}、@link GSSException#BAD_NAME GSSException.BAD_NAME}、@link GSSException#FAILURE GSSException.FAILURE}
GSSException

export

byte[] export()
              throws GSSException
返回机制名称 (MN) 的规范化连续字节表示形式，适合通过授权的功能进行直接的、逐字节比较。如果该名称不是 MN，则实现可能会抛出一个带有 NAME_NOT_MN 状态码的 GSSException。如果实现选择不抛出异常，则应该使用某些特定于系统的默认机制，以便规范化该名称，然后导出它。从结构上看，导出的名称对象由头部（它包含标识对名称进行验证的机制的 OID）和尾部（包含名称本身，其中，尾部的语法由每个机制规范定义）组成。输出缓冲的头的格式已在 RFC 2743 中指定。

当在较大的访问控制列表（在此情况下，可以削减在每个名称上创建 GSSName 对象和从 ACL 中调用每个名称上的 equals 方法的开销）中使用时，导出的名称非常有用。

通过使用字节数组 factory 方法 GSSManager.createName 并将 NT_EXPORT_NAME 指定为名称类型对象标识符，可以重新导入导出的名称。得到的 GSSName 名称还将是一个 MN。

返回：
一个包含导出的名称的 byte[]。RFC 2743 为这些字节定义了“Mechanism-Independent Exported Name Object Format”（独立于机制的导出名称对象格式）。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#BAD_NAME GSSException.BAD_NAME}、GSSException.BAD_NAMETYPE、GSSException.FAILURE
GSSException

toString

String toString()
返回 GSSName 对象的文本表示形式。要检索打印的名称格式（它确定了返回的字符串的语法），请使用 getStringNameType 方法。

覆盖：
类 Object 中的 toString
返回：
一个用可打印格式表示此名称的字符串。

getStringNameType

Oid getStringNameType()
                      throws GSSException
返回此名称的可打印表示形式的名称类型，此名称可从 toString 方法中获取。

返回：
一个表示从 toString 方法中返回的名称的名称空间的 Oid。
抛出：
GSSException，包含以下主要错误代码：{@link - GSSException#FAILURE GSSException.FAILURE}
GSSException

isAnonymous

boolean isAnonymous()
测试此名称对象是否表示匿名的实体。

返回：
如果它是一个匿名的名称，则返回 true，否则返回 false。

isMN

boolean isMN()
测试此名称对象是否表示一个机制名称 (MN)。MN 是一个仅包含一种机制的基本名称元素的 GSSName。

返回：
如果是 MN，则返回 true，否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageProp (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.ietf.jgss
类 MessageProp

java.lang.Object
    继承者  org.ietf.jgss.MessageProp

public class MessageProp
extends Object

这是一个在 per-message GSSContext 方法中使用的、用来传送 per-message 属性的实用工具类。

当与 GSSContext 接口的 wrap 和 getMIC 方法一起使用时，此类的一个实例用于指示需要的“Quality-of-Protection”（保护质量，即 QOP），并请求是否将机密性服务应用于调用者提供的数据（仅限于 wrap）。要请求默认的 QOP，应该使用 0 值。

当与 GSSContext 接口的 unwrap 和 verifyMIC 方法一起使用时，此类的一个实例用于指示在提供的消息上所应用的 QOP 和机密性服务。如果使用 verifyMIC，则机密性状态将始终为 false。从这些方法返回后，此对象还将包含可用于处理过的标记的任何增补状态值。增补状态值可以表示旧的标记、无序列标记、间距标记或重复的标记。

从以下版本开始：
1.4
另请参见：
GSSContext.wrap(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.unwrap(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.getMIC(byte[], int, int, org.ietf.jgss.MessageProp),
GSSContext.verifyMIC(byte[], int, int, byte[], int, int, org.ietf.jgss.MessageProp)

构造方法摘要
MessageProp(boolean privState)
设置所需私密状态的构造方法。
MessageProp(int qop, boolean privState)
设置 qop 和私密状态值的构造方法。
方法摘要
int | getMinorStatus() 检索基础验证机制可能已经为此 per-message 操作设置的次要状态码.
String | getMinorString() 检索解释次要状态码的字符串。
boolean | getPrivacy() 检索私密状态。
int | getQOP() 检索 QOP 值。
boolean | isDuplicateToken() 测试此标记是否为先前标记的一个副本。
boolean | isGapToken() 测试是否未接收到需要的标记（即一个或多个原先的标记尚未成功处理）。
boolean | isOldToken() 测试此标记是否还有效（即是否标记已经太陈旧而无法检查其复制情况）。
boolean | isUnseqToken() 测试后面的标记是否已进行处理。
void | setPrivacy(boolean privState) 设置私密状态。
void | setQOP(int qop) 设置 QOP 值。
void | setSupplementaryStates(boolean duplicate, boolean old, boolean unseq, boolean gap, int minorStatus, String minorString) 此方法将设置 MessageProp 中的增补信息标记的状态和次要状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageProp

public MessageProp(boolean privState)
设置所需私密状态的构造方法。所用的 QOP 值为 0。

参数：
privState - 私密（亦即机密性）状态

MessageProp

public MessageProp(int qop,
                   boolean privState)
设置 qop 和私密状态值的构造方法。

参数：
qop - QOP 值
privState - 私密（亦即机密性）状态
方法详细信息

getQOP

public int getQOP()
检索 QOP 值。

返回：
表示 QOP 值的 int
另请参见：
setQOP(int)

getPrivacy

public boolean getPrivacy()
检索私密状态。

返回：
如果私密（即机密性）状态为 true，则返回 true，否则，则返回 false。
另请参见：
setPrivacy(boolean)

setQOP

public void setQOP(int qop)
设置 QOP 值。

参数：
qop - 将 QOP 设置为的 int 值
另请参见：
getQOP()

setPrivacy

public void setPrivacy(boolean privState)
设置私密状态。

另请参见：
getPrivacy()

isDuplicateToken

public boolean isDuplicateToken()
测试此标记是否为先前标记的一个副本。

返回：
如果是副本，则返回 true，否则返回 false。

isOldToken

public boolean isOldToken()
测试此标记是否还有效（即是否标记已经太陈旧而无法检查其复制情况）。

返回：
如果标记的有效期已过，则返回 true，否则返回 false。

isUnseqToken

public boolean isUnseqToken()
测试后面的标记是否已进行处理。

返回：
如果后面的标记已经处理，则返回 true，否则返回 false。

isGapToken

public boolean isGapToken()
测试是否未接收到需要的标记（即一个或多个原先的标记尚未成功处理）。

返回：
如果未接收到需要的 per-message 标记，则返回 true，否则返回 false。

getMinorStatus

public int getMinorStatus()
检索基础验证机制可能已经为此 per-message 操作设置的次要状态码.

返回：
int 次要状态

getMinorString

public String getMinorString()
检索解释次要状态码的字符串。

返回：
一个与次要状态码对应的字符串。当未曾设置次要状态码时，将返回 null。

setSupplementaryStates

public void setSupplementaryStates(boolean duplicate,
                                   boolean old,
                                   boolean unseq,
                                   boolean gap,
                                   int minorStatus,
                                   String minorString)
此方法将设置 MessageProp 中的增补信息标记的状态和次要状态。它不是由应用程序使用，而是由 GSS 实现使用，用来将此信息返回到 per-message context 方法的调用者。

参数：
duplicate - 如果标记是先前标记的一个副本，则返回 true，否则，返回 false
old - 如果标记的有效期已过，则返回 true，否则，返回 false
unseq - 如果后面的标记已处理过，则返回 true，否则，返回 false
gap - 如果一个或多个原先的标记尚未成功处理过，则返回 true，否则，返回 false
minorStatus - per-message 操作的 int 次要状态码
minorString - minorStatus 值的文本表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Oid (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.ietf.jgss
类 Oid

java.lang.Object
    继承者  org.ietf.jgss.Oid

public class Oid
extends Object

此类表示 Universal Object Identifiers（通用对象标识符，即 Oid）及其相关的操作。

Oid 是一些用于 GSS-API 框架内按层次进行全局翻译的标识符，以标识机制和名称格式。

Oid 的结构和编码是在 ISOIEC-8824 和 ISOIEC-8825 中定义的，例如，Kerberos V5 机制的 Oid 表示形式是 "1.2.840.113554.1.2.2"

GSSName 名称类包括公共静态 Oid 对象，它们表示在 GSS-API 中定义的标准名称类型。

从以下版本开始：
1.4

构造方法摘要
Oid(byte[] data)
从其 ASN.1 DER 编码中创建 Oid 对象。
Oid(InputStream derOid)
从其 ASN.1 DER 编码中创建 Oid 对象。
Oid(String strOid)
从其整数组件的字符串表示形式中构建 Oid 对象。
方法摘要
boolean | containedIn(Oid[] oids) 一种实用工具方法，可测试此 Oid 值是否包含在所提供的 Oid 数组中。
boolean | equals(Object other) 测试两个 Oid 对象是否表示相同的 Object 标识符值。
byte[] | getDER() 返回此 oid 对象的全部 ASN.1 DER 编码，其中包括标记和长度。
int | hashCode() 返回此 Oid 的哈希码值。
String | toString() 返回 oid 用句点符号分隔的整数组件的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Oid

public Oid(String strOid)
    throws GSSException
从其整数组件的字符串表示形式中构建 Oid 对象。

参数：
strOid - oid 的句点分隔的字符串表示形式。例如，"1.2.840.113554.1.2.2"。
抛出：
GSSException - 当字符串未进行正确格式化时可能会抛出该异常。

Oid

public Oid(InputStream derOid)
    throws GSSException
从其 ASN.1 DER 编码中创建 Oid 对象。这指的是包括标记和长度在内的全部编码。Oid 的结构和编码是在 ISOIEC-8824 和 ISOIEC-8825 中定义的。此方法在功能方面与其字节数组对应方相同。

参数：
derOid - 包含 DER 编码的 oid 的流
抛出：
当 - DER 编码符合指定的格式时可能会抛出 GSSException。
GSSException

Oid

public Oid(byte[] data)
    throws GSSException
从其 ASN.1 DER 编码中创建 Oid 对象。这将引用包括标记和长度在内的全部编码。Oid 的结构和编码是在 ISOIEC-8824 和 ISOIEC-8825 中定义的。此方法在功能方面与其 InputStream 对应方相同。

参数：
data - 包含 DER 编码的 oid 的字节数组
抛出：
当 - DER 编码不符合指定的格式时可能会抛出 GSSException。
GSSException
方法详细信息

toString

public String toString()
返回 oid 用句点符号分隔的整数组件的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
以下格式的字符串表示形式："1.2.3.4.5"

equals

public boolean equals(Object other)
测试两个 Oid 对象是否表示相同的 Object 标识符值。

覆盖：
类 Object 中的 equals
参数：
other - 必须与此 Oid 对象进行比较的 Oid 对象
返回：
如果这两个 Oid 对象表示相同的值，则返回 true；否则，返回 false。
另请参见：
Object.hashCode(), Hashtable

getDER

public byte[] getDER()
              throws GSSException
返回此 oid 对象的全部 ASN.1 DER 编码，其中包括标记和长度。

返回：
包含此 oid 对象的 DER 编码的字节数组。
抛出：
当 - oid 无法编码时，可能会抛出 GSSException
GSSException

containedIn

public boolean containedIn(Oid[] oids)
一种实用工具方法，可测试此 Oid 值是否包含在所提供的 Oid 数组中。

参数：
oids - 要搜索的 Oid 的数组
返回：
如果该数组包含此 Oid 值，则返回 true，否则，返回 false

hashCode

public int hashCode()
返回此 Oid 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.ietf.jgss (Java Platform SE 6)

 org.ietf.jgss
接口
GSSContext
GSSCredential
GSSName
类
ChannelBinding
GSSManager
MessageProp
Oid
异常
GSSException


org.ietf.jgss (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.ietf.jgss

此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

请参见：
描述

接口摘要
GSSContext | 此接口将封装 GSS-API 安全上下文，并提供可通过上下文提供的安全服务。
GSSCredential | 此接口将为实体封装 GSS-API 凭据。
GSSName | 此接口将封装单一的 GSS-API 主体实体。

类摘要
ChannelBinding | 此类封装关于调用者提供的通道绑定信息的概念。
GSSManager | 此类作为其他重要 GSS-API 类的工厂，并且还提供有关受支持的机制的信息。
MessageProp | 这是一个在 per-message GSSContext 方法中使用的、用来传送 per-message 属性的实用工具类。
Oid | 此类表示 Universal Object Identifiers（通用对象标识符，即 Oid）及其相关的操作。

异常摘要
GSSException 每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

软件包 org.ietf.jgss 的描述

此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。应用程序可以选择使用的安全机制由唯一的对象标识符标识。此类机制的其中一个示例就是 Kerberos v5 GSS-API 机制（对象标识符 1.2.840.113554.1.2.2）。此机制可以通过 GSSManager 类的默认实例获取。

GSS-API 以一种独立于语言的方式在 "RFC 2743" 中定义。Java 语言绑定在 "RFC 2853" 中定义。

应用程序通过实例化 GSSManager 启动，然后 GSSManager 充当安全上下文的工厂。应用程序可以使用那些也可以利用 GSSManager 创建的特定主体名称和凭据；或者还可以使用系统默认值实例化上下文。然后检查上下文创建环路。一旦与同位体一起建立了上下文，也就完成了验证。诸如完整性和机密性的数据保护则可以从此上下文中获取。

GSS-API 与同位体之间不进行任何通信。它只产生应用程序必须以某种方式传输给其他端的标记。

凭据获取

GSS-API 本身并不指示基础机制如何获取验证所必需的凭据。它假定，在调用 GSS-API 之前获取这些凭据，并将其存储在一个机制提供者知道的地方。不过，Java 平台中的默认模型将是这样的：机制提供者必须仅从私有或公共凭据集中获取凭据，这些凭据集与当前访问控制上下文中的 Subject 相关。Kerberos v5 机制将在私有凭据集中搜索需要的 INITIATE 和 ACCEPT 凭据（KerberosTicket 和 KerberosKey），而其他机制可能要在公共集（或两者）中查找。如果需要的凭据未在当前 Subject 的适当集合中，则 GSS-API 调用一定会失败。

此模型具有凭据管理简单、可从应用程序角度预知这一优势。具有适当权限的应用程序可以使用标准的 Java API 清除 Subject 中的凭据或更新它们。如果应用程序清除了这些凭据，就可以确保 JGSS 机制失败，如果它更新了基于时间的凭据，就可以确保 JGSS 机制能够成功。

此模型要求执行 JAAS login，以便对 JGSS 机制稍后可以利用的 Subject 进行验证并登录。不过，应用程序能够通过以下系统属性放宽此限制：javax.security.auth.useSubjectCredsOnly。默认情况下，将假定此系统属性为 true（即便在未设置时也是如此），以指示提供者必须仅使用当前 Subject 中存在的凭据。不过，如果通过应用程序将此属性显式设置为 false，则表示该提供者可以随意使用它所选择的任何凭据缓存。此类凭据缓存可以是磁盘缓存、内存缓存，抑或仅仅是当前 Subject 本身。

相关文档

有关使用 Java GSS-API 的在线教程，请参阅《Introduction to JAAS and Java GSS-API》。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.ietf.jgss 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.ietf.jgss 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.ietf.jgss.ChannelBinding
    • org.ietf.jgss.GSSManager
    • org.ietf.jgss.MessageProp
    • org.ietf.jgss.Oid
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.ietf.jgss.GSSException

接口分层结构

  • java.lang.Cloneable
    • org.ietf.jgss.GSSCredential
  • org.ietf.jgss.GSSContext
  • org.ietf.jgss.GSSName
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.ietf.jgss 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.ietf.jgss
的使用

使用 org.ietf.jgss 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 使用的 org.ietf.jgss 中的类
ChannelBinding
此类封装关于调用者提供的通道绑定信息的概念。
GSSContext
此接口将封装 GSS-API 安全上下文，并提供可通过上下文提供的安全服务。
GSSCredential
此接口将为实体封装 GSS-API 凭据。
GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。
GSSManager
此类作为其他重要 GSS-API 类的工厂，并且还提供有关受支持的机制的信息。
GSSName
此接口将封装单一的 GSS-API 主体实体。
MessageProp
这是一个在 per-message GSSContext 方法中使用的、用来传送 per-message 属性的实用工具类。
Oid
此类表示 Universal Object Identifiers（通用对象标识符，即 Oid）及其相关的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.ietf.jgss.ChannelBinding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.ChannelBinding
的使用

使用 ChannelBinding 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 ChannelBinding 的使用

参数类型为 ChannelBinding 的 org.ietf.jgss 中的方法
 void GSSContext.setChannelBinding(ChannelBinding cb)
设置在上下文创建期间使用的通道绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.ietf.jgss.GSSContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.ietf.jgss.GSSContext
的使用

使用 GSSContext 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSContext 的使用

返回 GSSContext 的 org.ietf.jgss 中的方法
abstract GSSContext | GSSManager.createContext(byte[] interProcessToken) 创建以前导出的上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSCredential myCred) 为接受端一方创建上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.ietf.jgss.GSSCredential 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.ietf.jgss.GSSCredential
的使用

使用 GSSCredential 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSCredential 的使用

返回 GSSCredential 的 org.ietf.jgss 中的方法
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(int usage) 获取默认凭据的 Factory 方法。
GSSCredential | GSSContext.getDelegCred() 获取上下文初始端委托给上下文接受端的凭据。

参数类型为 GSSCredential 的 org.ietf.jgss 中的方法
abstract GSSContext | GSSManager.createContext(GSSCredential myCred) 为接受端一方创建上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.ietf.jgss.GSSException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.GSSException
的使用

使用 GSSException 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSException 的使用

抛出 GSSException 的 org.ietf.jgss 中的方法
byte[] | GSSContext.acceptSecContext(byte[] inToken, int offset, int len) 由上下文接受端在收到同位体的标记后调用。
void | GSSContext.acceptSecContext(InputStream inStream, OutputStream outStream) 由上下文接受端调用，以处理来自使用流的同位体的标记。
void | GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage) 将特定于机制的凭据元素添加到现有的凭据中。
abstract void | GSSManager.addProviderAtEnd(Provider p, Oid mech) 此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
abstract void | GSSManager.addProviderAtFront(Provider p, Oid mech) 此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。
GSSName | GSSName.canonicalize(Oid mech) 创建一个针对某种机制而规范化的名称。
abstract GSSContext | GSSManager.createContext(byte[] interProcessToken) 创建以前导出的上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSCredential myCred) 为接受端一方创建上下文的 Factory 方法。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(int usage) 获取默认凭据的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType) 将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType, Oid mech) 将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType) 将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType, Oid mech) 将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
void | GSSContext.dispose() 释放存储在上下文对象中并且使上下文无效的系统资源和加密信息。
void | GSSCredential.dispose() 释放 GSSCredential 对象可能包含的任何敏感信息。
boolean | GSSName.equals(GSSName another) 比较两个 GSSName 对象，以确定它们是否指的是同一个实体。
byte[] | GSSContext.export() 导出此上下文，以便使其他进程能够导入它。
byte[] | GSSName.export() 返回机制名称 (MN) 的规范化连续字节表示形式，适合通过授权的功能进行直接的、逐字节比较。
GSSCredential | GSSContext.getDelegCred() 获取上下文初始端委托给上下文接受端的凭据。
byte[] | Oid.getDER() 返回此 oid 对象的全部 ASN.1 DER 编码，其中包括标记和长度。
Oid | GSSContext.getMech() 确定什么机制正用于此上下文。
Oid[] | GSSCredential.getMechs() 返回受此凭据支持的机制的列表。
byte[] | GSSContext.getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp) 返回包含所提供消息的加密消息完整性代码 (MIC) 的标记，以便传输到同位体应用程序。
void | GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
GSSName | GSSCredential.getName() 检索凭据所维护的实体的名称。
GSSName | GSSCredential.getName(Oid mech) 检索凭据所维护的实体的 Mechanism Name（机制名称）。
abstract Oid[] | GSSManager.getNamesForMech(Oid mech) 然后返回由指定的机制所支持的名称类型。
int | GSSCredential.getRemainingAcceptLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制接受安全上下文。
int | GSSCredential.getRemainingInitLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制初始化安全上下文。
int | GSSCredential.getRemainingLifetime() 返回凭据所剩余的以秒为单位的生存期。
GSSName | GSSContext.getSrcName() 返回上下文初始端的名称。
Oid | GSSName.getStringNameType() 返回此名称的可打印表示形式的名称类型，此名称可从 toString 方法中获取。
GSSName | GSSContext.getTargName() 返回上下文接受端的名称。
int | GSSCredential.getUsage() 返回凭据使用模式。
int | GSSCredential.getUsage(Oid mech) 返回特定机制的凭据使用模式。
int | GSSContext.getWrapSizeLimit(int qop, boolean confReq, int maxTokenSize) 用来确定可以传输给 wrap 的消息的大小限制。
byte[] | GSSContext.initSecContext(byte[] inputBuf, int offset, int len) 由上下文初始端调用，以启动上下文创建阶段，处理由同位体的 acceptSecContext 方法生成的任何标记。
int | GSSContext.initSecContext(InputStream inStream, OutputStream outStream) 由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
boolean | GSSContext.isInitiator() 确定它是否为上下文初始端。
boolean | GSSContext.isTransferable() 确定通过使用 export 方法，该上下文是否可以传输给其他进程。
void | GSSContext.requestAnonymity(boolean state) 请求不要将初始端的身份泄露给接受端。
void | GSSContext.requestConf(boolean state) 请求针对 wrap 方法启用数据机密性。
void | GSSContext.requestCredDeleg(boolean state) 请求在上下文创建期间将初始端的凭据委托给接受端。
void | GSSContext.requestInteg(boolean state) 请求针对 wrap 和 getMIC 方法启用数据完整性。
void | GSSContext.requestLifetime(int lifetime) 请求上下文以秒为单位的生存期。
void | GSSContext.requestMutualAuth(boolean state) 要求相互验证在上下文创建期间完成。
void | GSSContext.requestReplayDet(boolean state) 请求在上下文创建之后针对 per-message 安全服务启用重放检测。
void | GSSContext.requestSequenceDet(boolean state) 请求在上下文创建之后针对 per-message 安全服务启用序列检查。
void | GSSContext.setChannelBinding(ChannelBinding cb) 设置在上下文创建期间使用的通道绑定。
byte[] | GSSContext.unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 用来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp) 通过提供的消息，检查包含在标记参数中的加密的 MIC。
void | GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp) 通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
byte[] | GSSContext.wrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 将 per-message 安全服务应用于已创建的安全上下文。
void | GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

抛出 GSSException 的 org.ietf.jgss 中的构造方法
Oid(byte[] data)
从其 ASN.1 DER 编码中创建 Oid 对象。
Oid(InputStream derOid)
从其 ASN.1 DER 编码中创建 Oid 对象。
Oid(String strOid)
从其整数组件的字符串表示形式中构建 Oid 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.ietf.jgss.GSSManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.GSSManager
的使用

使用 GSSManager 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSManager 的使用

返回 GSSManager 的 org.ietf.jgss 中的方法
static GSSManager GSSManager.getInstance()
返回默认的 GSSManager 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.ietf.jgss.GSSName 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.ietf.jgss.GSSName
的使用

使用 GSSName 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 GSSName 的使用

返回 GSSName 的 org.ietf.jgss 中的方法
GSSName | GSSName.canonicalize(Oid mech) 创建一个针对某种机制而规范化的名称。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType) 将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType, Oid mech) 将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType) 将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType, Oid mech) 将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
GSSName | GSSCredential.getName() 检索凭据所维护的实体的名称。
GSSName | GSSCredential.getName(Oid mech) 检索凭据所维护的实体的 Mechanism Name（机制名称）。
GSSName | GSSContext.getSrcName() 返回上下文初始端的名称。
GSSName | GSSContext.getTargName() 返回上下文接受端的名称。

参数类型为 GSSName 的 org.ietf.jgss 中的方法
void | GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage) 将特定于机制的凭据元素添加到现有的凭据中。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
boolean | GSSName.equals(GSSName another) 比较两个 GSSName 对象，以确定它们是否指的是同一个实体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.ietf.jgss.MessageProp 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.MessageProp
的使用

使用 MessageProp 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 MessageProp 的使用

参数类型为 MessageProp 的 org.ietf.jgss 中的方法
byte[] | GSSContext.getMIC(byte[] inMsg, int offset, int len, MessageProp msgProp) 返回包含所提供消息的加密消息完整性代码 (MIC) 的标记，以便传输到同位体应用程序。
void | GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
byte[] | GSSContext.unwrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 用来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.verifyMIC(byte[] inToken, int tokOffset, int tokLen, byte[] inMsg, int msgOffset, int msgLen, MessageProp msgProp) 通过提供的消息，检查包含在标记参数中的加密的 MIC。
void | GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp) 通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
byte[] | GSSContext.wrap(byte[] inBuf, int offset, int len, MessageProp msgProp) 将 per-message 安全服务应用于已创建的安全上下文。
void | GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.ietf.jgss.Oid 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.ietf.jgss.Oid
的使用

使用 Oid 的软件包
org.ietf.jgss 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.ietf.jgss 中 Oid 的使用

声明为 Oid 的 org.ietf.jgss 中的字段
static Oid | GSSName.NT_ANONYMOUS 表示匿名实体的名称类型。
static Oid | GSSName.NT_EXPORT_NAME 用来表示通过导出方法产生的导出名称的名称类型。
static Oid | GSSName.NT_HOSTBASED_SERVICE 表示基于主机的服务名称格式的 Oid。
static Oid | GSSName.NT_MACHINE_UID_NAME 名称类型，表示与本地系统上的用户对应的数值型用户标识符。
static Oid | GSSName.NT_STRING_UID_NAME 名称类型，指示一个由数字组成的字符串，表示本地系统上用户的数值型用户标识符。
static Oid | GSSName.NT_USER_NAME 名称类型，表示在本地系统上指定的用户。

返回 Oid 的 org.ietf.jgss 中的方法
Oid | GSSContext.getMech() 确定什么机制正用于此上下文。
Oid[] | GSSCredential.getMechs() 返回受此凭据支持的机制的列表。
abstract Oid[] | GSSManager.getMechs() 返回一个可通过此 GSSManager 提供给 GSS-API 调用者的机制列表。
abstract Oid[] | GSSManager.getMechsForName(Oid nameType) 返回支持指定的名称类型的机制的列表。
abstract Oid[] | GSSManager.getNamesForMech(Oid mech) 然后返回由指定的机制所支持的名称类型。
Oid | GSSName.getStringNameType() 返回此名称的可打印表示形式的名称类型，此名称可从 toString 方法中获取。

参数类型为 Oid 的 org.ietf.jgss 中的方法
void | GSSCredential.add(GSSName name, int initLifetime, int acceptLifetime, Oid mech, int usage) 将特定于机制的凭据元素添加到现有的凭据中。
abstract void | GSSManager.addProviderAtEnd(Provider p, Oid mech) 此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
abstract void | GSSManager.addProviderAtFront(Provider p, Oid mech) 此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。
GSSName | GSSName.canonicalize(Oid mech) 创建一个针对某种机制而规范化的名称。
boolean | Oid.containedIn(Oid[] oids) 一种实用工具方法，可测试此 Oid 值是否包含在所提供的 Oid 数组中。
abstract GSSContext | GSSManager.createContext(GSSName peer, Oid mech, GSSCredential myCred, int lifetime) 在初始端一方创建上下文的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid[] mechs, int usage) 通过一套机制获取凭据的 Factory 方法。
abstract GSSCredential | GSSManager.createCredential(GSSName name, int lifetime, Oid mech, int usage) 获取单个机制凭据的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType) 将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(byte[] name, Oid nameType, Oid mech) 将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType) 将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
abstract GSSName | GSSManager.createName(String nameStr, Oid nameType, Oid mech) 将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
abstract Oid[] | GSSManager.getMechsForName(Oid nameType) 返回支持指定的名称类型的机制的列表。
GSSName | GSSCredential.getName(Oid mech) 检索凭据所维护的实体的 Mechanism Name（机制名称）。
abstract Oid[] | GSSManager.getNamesForMech(Oid mech) 然后返回由指定的机制所支持的名称类型。
int | GSSCredential.getRemainingAcceptLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制接受安全上下文。
int | GSSCredential.getRemainingInitLifetime(Oid mech) 返回凭据以秒为单位的生存期，以便能够继续使用指定的机制初始化安全上下文。
int | GSSCredential.getUsage(Oid mech) 返回特定机制的凭据使用模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


_IDLTypeStub (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 _IDLTypeStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CORBA._IDLTypeStub
所有已实现的接口：
Serializable, IDLType, IDLTypeOperations, IRObject, IRObjectOperations, Object, IDLEntity
public class _IDLTypeStub
extends ObjectImpl
implements IDLType

IDLType 的 Stub。有关 Stub 文件的更多信息，请参阅“生成的文件：Stub”。

org/omg/CORBA/_IDLTypeStub.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:44 (GMT+00:00)

构造方法摘要
_IDLTypeStub()
构造一个默认 _IDLTypeStub 对象。
_IDLTypeStub(Delegate delegate)
构造一个 _IDLTypeStub 对象，并使用给定 Delegate 对象初始化。
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
DefinitionKind | def_kind() 返回对应于此接口存储库对象的 DefinitionKind。
void | destroy() 销毁此对象。
TypeCode | type() type 属性描述源自 IDLType 的对象定义的类型。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

构造方法详细信息

_IDLTypeStub

public _IDLTypeStub()
构造一个默认 _IDLTypeStub 对象。注：如果使用默认构造方法，则该对象在调用 _set_delegate 方法前没有用。

_IDLTypeStub

public _IDLTypeStub(Delegate delegate)
构造一个 _IDLTypeStub 对象，并使用给定 Delegate 对象初始化。

参数：
delegate - Delegate 对象
方法详细信息

type

public TypeCode type()
从接口 IDLTypeOperations 复制的描述
type 属性描述源自 IDLType 的对象定义的类型。

指定者：
接口 IDLTypeOperations 中的 type
返回：
此对象定义的 TypeCode。

def_kind

public DefinitionKind def_kind()
从接口 IRObjectOperations 复制的描述
返回对应于此接口存储库对象的 DefinitionKind。

指定者：
接口 IRObjectOperations 中的 def_kind
返回：
对应于此接口存储库对象的 DefinitionKind。

destroy

public void destroy()
从接口 IRObjectOperations 复制的描述
销毁此对象。如果该对象是一个 Container，则此方法可应用于其所有内容。如果该对象包含一个用于 anonymous 类型的 IDLType 属性，则销毁该 IDLType。如果该对象当前包含在其他对象中，则它将被移除。如果对 Repository 或 PrimitiveDef 调用此方法，则将引发 BAD_INV_ORDER 异常，并带有次要值 (minor value) 2。试图销毁将导致存储库处于不一致状态的对象将引发 BAD_INV_ORDER 异常，并带有次要代码 1。

指定者：
接口 IRObjectOperations 中的 destroy

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


_PolicyStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 _PolicyStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CORBA._PolicyStub
所有已实现的接口：
Serializable, Object, Policy, PolicyOperations, IDLEntity
public class _PolicyStub
extends ObjectImpl
implements Policy

Policy 的 Stub。有关 Stub 文件的更多信息，请参阅“生成的文件：Stub”。

org/omg/CORBA/_PolicyStub.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20

构造方法摘要
_PolicyStub()
构造方法注意事项：如果使用默认构造方法，则该对象在调用 _set_delegate (...) 方法前没有用。
_PolicyStub(Delegate delegate)
构造一个 _PolicyStub 对象，并使用给定 Delegate 对象初始化。
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
Policy | copy() 复制策略对象。
void | destroy() 销毁策略对象。
int | policy_type() 返回对应于策略对象类型的常量值。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

构造方法详细信息

_PolicyStub

public _PolicyStub()
构造方法注意事项：如果使用默认构造方法，则该对象在调用 _set_delegate (...) 方法前没有用。

_PolicyStub

public _PolicyStub(Delegate delegate)
构造一个 _PolicyStub 对象，并使用给定 Delegate 对象初始化。

参数：
delegate - Delegate 对象
方法详细信息

policy_type

public int policy_type()
返回对应于策略对象类型的常量值。策略对象类型的值由 OMG 分配。PolicyType 的新值应该通过向 request@omg.org 发送电子邮件从 OMG 获得。通常，分配的常量值是与相应策略对象一起定义的。

指定者：
接口 PolicyOperations 中的 policy_type
返回：
对应于策略对象类型的常量值。

copy

public Policy copy()
复制策略对象。该副本没有保留任何关于策略与任何域或对象之间的关系。

指定者：
接口 PolicyOperations 中的 copy
返回：
策略对象的副本。

destroy

public void destroy()
销毁策略对象。由策略对象负责确定是否可以销毁其自身。

指定者：
接口 PolicyOperations 中的 destroy

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ACTIVITY_COMPLETED (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ACTIVITY_COMPLETED

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.ACTIVITY_COMPLETED
所有已实现的接口：
Serializable
public final class ACTIVITY_COMPLETED
extends SystemException

ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。它指示调用方法的 Activity 上下文由于 Activity 自身的超时或围绕 Activity 事务的超时而得以完成，或者指示 Activity 以最初所请求方式以外的方式完成。

从以下版本开始：
J2SE 1.5
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
ACTIVITY_COMPLETED()
构造一个 ACTIVITY_COMPLETED 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
ACTIVITY_COMPLETED(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_COMPLETED(String detailMessage)
使用指定消息构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ACTIVITY_COMPLETED

public ACTIVITY_COMPLETED()
构造一个 ACTIVITY_COMPLETED 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。

ACTIVITY_COMPLETED

public ACTIVITY_COMPLETED(String detailMessage)
使用指定消息构造 ACTIVITY_COMPLETED 异常。

参数：
detailMessage - 包含详细消息的字符串。

ACTIVITY_COMPLETED

public ACTIVITY_COMPLETED(int minorCode,
                          CompletionStatus completionStatus)
使用指定次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。

参数：
minorCode - 次要代码。
completionStatus - 完成状态。

ACTIVITY_COMPLETED

public ACTIVITY_COMPLETED(String detailMessage,
                          int minorCode,
                          CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。

参数：
detailMessage - 包含详细消息的字符串。
minorCode - 次要代码。
completionStatus - 完成状态。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ACTIVITY_REQUIRED (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ACTIVITY_REQUIRED

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.ACTIVITY_REQUIRED
所有已实现的接口：
Serializable
public final class ACTIVITY_REQUIRED
extends SystemException

ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。它指示 Activity 上下文是执行已调用操作所必需的，但却不存在与该调用线程关联的 Activity 上下文。

从以下版本开始：
J2SE 1.5
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
ACTIVITY_REQUIRED()
构造一个 ACTIVITY_REQUIRED 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
ACTIVITY_REQUIRED(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
ACTIVITY_REQUIRED(String detailMessage)
使用指定消息构造一个 ACTIVITY_REQUIRED 异常。
ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ACTIVITY_REQUIRED

public ACTIVITY_REQUIRED()
构造一个 ACTIVITY_REQUIRED 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。

ACTIVITY_REQUIRED

public ACTIVITY_REQUIRED(String detailMessage)
使用指定消息构造一个 ACTIVITY_REQUIRED 异常。

参数：
detailMessage - 包含详细消息的字符串。

ACTIVITY_REQUIRED

public ACTIVITY_REQUIRED(int minorCode,
                         CompletionStatus completionStatus)
使用指定次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。

参数：
minorCode - 次要代码。
completionStatus - 完成状态。

ACTIVITY_REQUIRED

public ACTIVITY_REQUIRED(String detailMessage,
                         int minorCode,
                         CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。

参数：
detailMessage - 包含详细消息的字符串。
minorCode - 次要代码。
completionStatus - 完成状态。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Any (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 Any

java.lang.Object
    继承者  org.omg.CORBA.Any
所有已实现的接口：
Serializable, IDLEntity
public abstract class Any
extends Object
implements IDLEntity

充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。Any 对象可用作 NamedValue 对象的组件，NamedValue 对象提供关于请求中的参数或返回值的信息，也用来定义 Context 对象中的名称/值对。

Any 对象由两部分组成：

  1. 数据值
  2. 描述 Any 对象中所包含数据值类型的 TypeCode 对象。例如，用于数组的 TypeCode 对象包含一个用于数组长度的字段和一个用于数组中元素类型的字段。（注意，在这种情况下，TypeCode 对象的第二个字段本身也是一个 TypeCode 对象。）

大部分 Any 类由以下方法对组成：将值插入 Any 对象的方法和从 Any 对象中析取值的方法。

对于某一给定的基本类型 X，这些方法是：

void insert_X(X x)
此方法允许将基本类型 X 的实例 x 插入 Any 对象的 value 字段。注意，如有必要，方法 insert_X 也能重置 Any 对象的 type 字段。
X extract_X()
此方法允许从 Any 对象中析取类型 X 的实例。

此方法在以下两种情况下抛出异常 BAD_OPERATION：

  1. Any 对象中所包含元素的类型不是 X
  2. 在设置 Any 对象的 value 字段之前调用 extract_X 方法

对于每种基本 IDL 数据类型，存在不同的方法对（insert_long 和 extract_long、insert_string 和 extract_string，等等）。

Any 类还拥有用于获取和设置类型代码的方法、用于测试两个 Any 对象是否相等的方法，以及用于从流中读取 Any 对象或将对象写入流中的方法。

从以下版本开始：
JDK1.2

构造方法摘要
Any()
方法摘要
abstract InputStream | create_input_stream() 创建一个输入流，可以从中解组此 Any 对象的值。
abstract OutputStream | create_output_stream() 创建一个输出流，可以将此 Any 对象的值编组到其中。
abstract boolean | equal(Any a) 检查此 Any 对象与给定 Any 对象是否相等。
abstract Any | extract_any() 提取此 Any 对象 value 字段中的 Any 对象。
abstract boolean | extract_boolean() 提取此 Any 对象 value 字段中的 boolean 值。
abstract char | extract_char() 提取此 Any 对象 value 字段中的 char 值。
abstract double | extract_double() 提取此 Any 对象 value 字段中的 double 值。
BigDecimal | extract_fixed() 提取此 Any 对象 value 字段中的 java.math.BigDecimal 对象。
abstract float | extract_float() 提取此 Any 对象 value 字段中的 float 值。
abstract int | extract_long() 提取此 Any 对象 value 字段中的 int 值。
abstract long | extract_longlong() 提取此 Any 对象 value 字段中的 long 值。
abstract Object | extract_Object() 提取此 Any 对象 value 字段中的 org.omg.CORBA.Object。
abstract byte | extract_octet() 提取此 Any 对象 value 字段中的 byte 值。
Principal | extract_Principal() 已过时。 由 CORBA 2.2 取代。
abstract short | extract_short() 提取此 Any 对象 value 字段中的 short 值。
Streamable | extract_Streamable() 从此 Any 对象的 value 字段提取 Streamable。
abstract String | extract_string() 提取此 Any 对象 value 字段中的 String 对象。
abstract TypeCode | extract_TypeCode() 提取此 Any 对象 value 字段中的 TypeCode 对象。
abstract int | extract_ulong() 提取此 Any 对象 value 字段中的 int 值。
abstract long | extract_ulonglong() 提取此 Any 对象 value 字段中的 long 值。
abstract short | extract_ushort() 提取此 Any 对象 value 字段中的 short 值。
abstract Serializable | extract_Value() 提取此 Any 对象 value 字段中的 java.io.Serializable 对象。
abstract char | extract_wchar() 提取此 Any 对象 value 字段中的 char 值。
abstract String | extract_wstring() 提取此 Any 对象 value 字段中的 String 对象。
abstract void | insert_any(Any a) 将给定 Any 对象插入此 Any 对象的 value 字段。
abstract void | insert_boolean(boolean b) 将给定 boolean 值插入此 Any 对象的 value 字段。
abstract void | insert_char(char c) 将给定 char 值插入此 Any 对象的 value 字段。
abstract void | insert_double(double d) 将给定 double 值插入此 Any 对象的 value 字段。
void | insert_fixed(BigDecimal value) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
void | insert_fixed(BigDecimal value, TypeCode type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
abstract void | insert_float(float f) 将给定 float 值插入此 Any 对象的 value 字段。
abstract void | insert_long(int l) 将给定 int 值插入此 Any 对象的 value 字段。
abstract void | insert_longlong(long l) 将给定 long 值插入此 Any 对象的 value 字段。
abstract void | insert_Object(Object o) 将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
abstract void | insert_Object(Object o, TypeCode t) 将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
abstract void | insert_octet(byte b) 将给定 byte 值插入此 Any 对象的 value 字段。
void | insert_Principal(Principal p) 已过时。 由 CORBA 2.2 取代。
abstract void | insert_short(short s) 将给定 short 值插入此 Any 对象的 value 字段。
void | insert_Streamable(Streamable s) 将给定 Streamable 对象插入此 Any 对象的 value 字段。
abstract void | insert_string(String s) 将给定 String 对象插入此 Any 对象的 value 字段。
abstract void | insert_TypeCode(TypeCode t) 将给定 TypeCode 对象插入此 Any 对象的 value 字段。
abstract void | insert_ulong(int l) 将给定 int 值插入此 Any 对象的 value 字段。
abstract void | insert_ulonglong(long l) 将给定 long 值插入此 Any 对象的 value 字段。
abstract void | insert_ushort(short s) 将给定 short 值插入此 Any 对象的 value 字段。
abstract void | insert_Value(Serializable v) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
abstract void | insert_Value(Serializable v, TypeCode t) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
abstract void | insert_wchar(char c) 将给定 char 值插入此 Any 对象的 value 字段。
abstract void | insert_wstring(String s) 将给定 String 对象插入此 Any 对象的 value 字段。
abstract void | read_value(InputStream is, TypeCode t) 使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。
abstract TypeCode | type() 返回此 Any 对象中所包含元素的类型信息。
abstract void | type(TypeCode t) 将此 Any 对象的 type 字段设置为给定的 TypeCode 对象，并清除其值。
abstract void | write_value(OutputStream os) 将此 Any 对象的值写出到给定输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Any

public Any()
方法详细信息

equal

public abstract boolean equal(Any a)
检查此 Any 对象与给定 Any 对象是否相等。如果两个 Any 对象的值和类型代码都相等，则这两个对象相等。

参数：
a - 将测试其是否相等的 Any 对象
返回：
如果两个 Any 对象是相等的，则返回 true；否则返回 false
另请参见：
CORBA 包中有关未实现特性的注释

type

public abstract TypeCode type()
返回此 Any 对象中所包含元素的类型信息。

返回：
TypeCode 对象，它包含关于此 Any 对象中所包含值的类型信息。

type

public abstract void type(TypeCode t)
将此 Any 对象的 type 字段设置为给定的 TypeCode 对象，并清除其值。

注意，使用此方法设置类型代码会清除值（如果有）。提供该方法主要是为了能够为 IDL out 参数正确地设置类型。通常，设置类型由 insert_X 方法完成，如果类型没有被设置为 X，则该方法会将它设置为 X。

参数：
t - 为此 Any 对象中的值提供信息的 TypeCode 对象

read_value

public abstract void read_value(InputStream is,
                                TypeCode t)
                         throws MARSHAL
使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。

参数：
is - org.omg.CORBA.portable.InputStream 对象，从其中读取此 Any 对象中所包含的值
t - 一个 TypeCode 对象，它包含关于要读取的值的类型信息
抛出：
MARSHAL - 当给定 TypeCode 对象与输入流中包含的值不一致时

write_value

public abstract void write_value(OutputStream os)
将此 Any 对象的值写出到给定输出流。如果 typecode 和 value 都需要写入，则先使用 create_output_stream() 创建一个 OutputStream，然后对该 OutputStream 使用 write_any。

如果对 Any 对象调用此方法，而该对象没有将某个值插入其 value 字段，则将抛出异常 java.lang.NullPointerException。

参数：
os - org.omg.CORBA.portable.OutputStream 对象，此 Any 对象的值将被编组到其中

create_output_stream

public abstract OutputStream create_output_stream()
创建一个输出流，可以将此 Any 对象的值编组到其中。

返回：
新创建的 OutputStream

create_input_stream

public abstract InputStream create_input_stream()
创建一个输入流，可以从中解组此 Any 对象的值。

返回：
新创建的 InputStream

extract_short

public abstract short extract_short()
                             throws BAD_OPERATION
提取此 Any 对象 value 字段中的 short 值。

返回：
存储在此 Any 对象中的 short 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 short 以外的值，或者尚未设置 value 字段

insert_short

public abstract void insert_short(short s)
将给定 short 值插入此 Any 对象的 value 字段。

参数：
s - 将插入此 Any 对象中的 short 值

extract_long

public abstract int extract_long()
                          throws BAD_OPERATION
提取此 Any 对象 value 字段中的 int 值。

返回：
存储在此 Any 对象中的 int 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 int 以外的值，或者尚未设置 value 字段

insert_long

public abstract void insert_long(int l)
将给定 int 值插入此 Any 对象的 value 字段。

参数：
l - 将插入此 Any 对象中的 int 值

extract_longlong

public abstract long extract_longlong()
                               throws BAD_OPERATION
提取此 Any 对象 value 字段中的 long 值。

返回：
存储在此 Any 对象中的 long 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 long 以外的值，或者尚未设置 value 字段

insert_longlong

public abstract void insert_longlong(long l)
将给定 long 值插入此 Any 对象的 value 字段。

参数：
l - 将插入此 Any 对象中的 long 值

extract_ushort

public abstract short extract_ushort()
                              throws BAD_OPERATION
提取此 Any 对象 value 字段中的 short 值。

返回：
存储在此 Any 对象中的 short 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 short 以外的值，或者尚未设置 value 字段

insert_ushort

public abstract void insert_ushort(short s)
将给定 short 值插入此 Any 对象的 value 字段。

参数：
s - 将插入此 Any 对象中的 short 值

extract_ulong

public abstract int extract_ulong()
                           throws BAD_OPERATION
提取此 Any 对象 value 字段中的 int 值。

返回：
存储在此 Any 对象中的 int 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 int 以外的值，或者尚未设置 value 字段

insert_ulong

public abstract void insert_ulong(int l)
将给定 int 值插入此 Any 对象的 value 字段。

参数：
l - 将插入此 Any 对象中的 int 值

extract_ulonglong

public abstract long extract_ulonglong()
                                throws BAD_OPERATION
提取此 Any 对象 value 字段中的 long 值。

返回：
存储在此 Any 对象中的 long 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 long 以外的值，或者尚未设置 value 字段

insert_ulonglong

public abstract void insert_ulonglong(long l)
将给定 long 值插入此 Any 对象的 value 字段。

参数：
l - 将插入此 Any 对象中的 long 值

extract_float

public abstract float extract_float()
                             throws BAD_OPERATION
提取此 Any 对象 value 字段中的 float 值。

返回：
存储在此 Any 对象中的 float 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 float 以外的值，或者尚未设置 value 字段

insert_float

public abstract void insert_float(float f)
将给定 float 值插入此 Any 对象的 value 字段。

参数：
f - 将插入此 Any 对象中的 float 值

extract_double

public abstract double extract_double()
                               throws BAD_OPERATION
提取此 Any 对象 value 字段中的 double 值。

返回：
存储在此 Any 对象中的 double 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 double 以外的值，或者尚未设置 value 字段

insert_double

public abstract void insert_double(double d)
将给定 double 值插入此 Any 对象的 value 字段。

参数：
d - 将插入此 Any 对象中的 double 值

extract_boolean

public abstract boolean extract_boolean()
                                 throws BAD_OPERATION
提取此 Any 对象 value 字段中的 boolean 值。

返回：
存储在此 Any 对象中的 boolean 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 boolean 以外的值，或者尚未设置 value 字段

insert_boolean

public abstract void insert_boolean(boolean b)
将给定 boolean 值插入此 Any 对象的 value 字段。

参数：
b - 将插入此 Any 对象中的 boolean 值

extract_char

public abstract char extract_char()
                           throws BAD_OPERATION
提取此 Any 对象 value 字段中的 char 值。

返回：
存储在此 Any 对象中的 char 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 char 以外的值，或者尚未设置 value 字段

insert_char

public abstract void insert_char(char c)
                          throws DATA_CONVERSION
将给定 char 值插入此 Any 对象的 value 字段。

参数：
c - 将插入此 Any 对象中的 char 值
抛出：
DATA_CONVERSION - 如果存在数据转换错误

extract_wchar

public abstract char extract_wchar()
                            throws BAD_OPERATION
提取此 Any 对象 value 字段中的 char 值。

返回：
存储在此 Any 对象中的 char 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 char 以外的值，或者尚未设置 value 字段

insert_wchar

public abstract void insert_wchar(char c)
将给定 char 值插入此 Any 对象的 value 字段。

参数：
c - 将插入此 Any 对象中的 char 值

extract_octet

public abstract byte extract_octet()
                            throws BAD_OPERATION
提取此 Any 对象 value 字段中的 byte 值。

返回：
存储在此 Any 对象中的 byte 值
抛出：
BAD_OPERATION - 如果此 Any 对象包含 byte 以外的值，或者尚未设置 value 字段

insert_octet

public abstract void insert_octet(byte b)
将给定 byte 值插入此 Any 对象的 value 字段。

参数：
b - 将插入此 Any 对象中的 byte 值

extract_any

public abstract Any extract_any()
                         throws BAD_OPERATION
提取此 Any 对象 value 字段中的 Any 对象。

返回：
存储在此 Any 对象中的 Any 对象
抛出：
BAD_OPERATION - 如果此 Any 对象包含 Any 以外的对象，或者尚未设置 value 字段

insert_any

public abstract void insert_any(Any a)
将给定 Any 对象插入此 Any 对象的 value 字段。

参数：
a - 将插入此 Any 对象中的 Any 对象

extract_Object

public abstract Object extract_Object()
                               throws BAD_OPERATION
提取此 Any 对象 value 字段中的 org.omg.CORBA.Object。

返回：
存储在此 Any 对象中的 org.omg.CORBA.Object
抛出：
BAD_OPERATION - 如果此 Any 对象包含 org.omg.CORBA.Object 以外的其他对象，或者尚未设置 value 字段

insert_Object

public abstract void insert_Object(Object o)
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。

参数：
o - 将插入此 Any 对象中的 org.omg.CORBA.Object 对象

extract_Value

public abstract Serializable extract_Value()
                                    throws BAD_OPERATION
提取此 Any 对象 value 字段中的 java.io.Serializable 对象。

返回：
存储在此 Any 对象中的 java.io.Serializable 对象
抛出：
BAD_OPERATION - 如果此 Any 对象包含 java.io.Serializable 以外的对象，或者尚未设置 value 字段

insert_Value

public abstract void insert_Value(Serializable v)
将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。

参数：
v - 将插入此 Any 对象中的 java.io.Serializable 对象

insert_Value

public abstract void insert_Value(Serializable v,
                                  TypeCode t)
                           throws MARSHAL
将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。

参数：
v - 将插入此 Any 对象中的 java.io.Serializable 对象
t - 将插入此 Any 对象 type 字段中的 TypeCode 对象，它描述了将被插入的 java.io.Serializable 对象
抛出：
MARSHAL - 如果 ORB 在编组或解组参数时存在问题

insert_Object

public abstract void insert_Object(Object o,
                                   TypeCode t)
                            throws BAD_PARAM
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。

参数：
o - 将插入此 Any 对象中的 org.omg.CORBA.Object 实例
t - 将插入此 Any 对象中的 TypeCode 对象，它描述了将被插入的 Object
抛出：
BAD_OPERATION - 如果此方法对于此 Any 对象无效
BAD_PARAM

extract_string

public abstract String extract_string()
                               throws BAD_OPERATION
提取此 Any 对象 value 字段中的 String 对象。

返回：
存储在此 Any 对象中的 String 对象
抛出：
BAD_OPERATION - 如果此 Any 对象包含 String 以外的对象，或者尚未设置 value 字段

insert_string

public abstract void insert_string(String s)
                            throws DATA_CONVERSION,
                                   MARSHAL
将给定 String 对象插入此 Any 对象的 value 字段。

参数：
s - 将插入此 Any 对象中的 String 对象
抛出：
DATA_CONVERSION - 如果存在数据转换错误
MARSHAL - 如果 ORB 在编组或解组参数时存在问题

extract_wstring

public abstract String extract_wstring()
                                throws BAD_OPERATION
提取此 Any 对象 value 字段中的 String 对象。

返回：
存储在此 Any 对象中的 String 对象
抛出：
BAD_OPERATION - 如果此 Any 对象包含 String 以外的对象，或者尚未设置 value 字段

insert_wstring

public abstract void insert_wstring(String s)
                             throws MARSHAL
将给定 String 对象插入此 Any 对象的 value 字段。

参数：
s - 将插入此 Any 对象中的 String 对象
抛出：
MARSHAL - 如果 ORB 在编组或解组参数存在问题

extract_TypeCode

public abstract TypeCode extract_TypeCode()
                                   throws BAD_OPERATION
提取此 Any 对象 value 字段中的 TypeCode 对象。

返回：
存储在此 Any 对象中的 TypeCode 对象
抛出：
BAD_OPERATION - 如果此 Any 对象包含 TypeCode 以外的对象，或者尚未设置 value 字段

insert_TypeCode

public abstract void insert_TypeCode(TypeCode t)
将给定 TypeCode 对象插入此 Any 对象的 value 字段。

参数：
t - 将插入此 Any 对象中的 TypeCode 对象

extract_Principal

@Deprecated
public Principal extract_Principal()
                            throws BAD_OPERATION
已过时。 由 CORBA 2.2 取代。

提取此 Any 对象 value 字段中的 Principal 对象。注意，Principal 类已过时。

返回：
存储在此 Any 对象中的 Principal 对象
抛出：
BAD_OPERATION - 如果此 Any 对象包含 Principal 以外的对象，或者尚未设置 value 字段
另请参见：
CORBA 包中有关未实现特性的注释

insert_Principal

@Deprecated
public void insert_Principal(Principal p)
已过时。 由 CORBA 2.2 取代。

将给定 Principal 对象插入此 Any 对象的 value 字段。注意，Principal 类已过时。

参数：
p - 将插入此 Any 对象中的 Principal 对象
另请参见：
CORBA 包中有关未实现特性的注释

extract_Streamable

public Streamable extract_Streamable()
                              throws BAD_INV_ORDER
从此 Any 对象的 value 字段提取 Streamable。此方法允许提取非基本 IDL 类型。

返回：
存储在 Any 对象中的 Streamable。
抛出：
BAD_INV_ORDER - 如果调用者按错误的顺序调用了操作
另请参见：
CORBA 包中有关未实现特性的注释

insert_Streamable

public void insert_Streamable(Streamable s)
将给定 Streamable 对象插入此 Any 对象的 value 字段。此方法允许插入非基本 IDL 类型。

参数：
s - 将插入此 Any 对象的 Streamable 对象，它可以是非基本 IDL 类型
另请参见：
CORBA 包中有关未实现特性的注释

extract_fixed

public BigDecimal extract_fixed()
提取此 Any 对象 value 字段中的 java.math.BigDecimal 对象。

返回：
存储在此 Any 对象中的 java.math.BigDecimal 对象
抛出：
BAD_OPERATION - 如果此 Any 对象包含 java.math.BigDecimal 以外的对象，或者尚未设置 value 字段
另请参见：
CORBA 包中有关未实现特性的注释

insert_fixed

public void insert_fixed(BigDecimal value)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

将给定 java.math.BigDecimal 对象插入此 Any 对象的 value 字段。

参数：
value - 将插入此 Any 对象中的 java.math.BigDecimal 对象
另请参见：
CORBA 包中有关未实现特性的注释

insert_fixed

public void insert_fixed(BigDecimal value,
                         TypeCode type)
                  throws BAD_INV_ORDER
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

将给定 java.math.BigDecimal 对象插入此 Any 对象的 value 字段。

参数：
value - 将插入此 Any 对象中的 java.math.BigDecimal 对象
type - 将插入此 Any 对象 type 字段中的 TypeCode 对象，它描述了将被插入的 java.math.BigDecimal 对象
抛出：
BAD_INV_ORDER - 如果不正确地调用此方法
另请参见：
CORBA 包中有关未实现特性的注释
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AnyHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 AnyHolder

java.lang.Object
    继承者  org.omg.CORBA.AnyHolder
所有已实现的接口：
Streamable
public final class AnyHolder
extends Object
implements Streamable

Any 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

Any 对象的 Holder 类，用于存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将 IDL any 作为 "out" 或 "inout" 参数，则程序员必须传递 AnyHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myAnyHolder 是 AnyHolder 的实例，则可以使用 myAnyHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 Any value
此 AnyHolder 对象保存的 Any 值。
构造方法摘要
AnyHolder()
构造一个新的 AnyHolder 对象，将其 value 字段初始化为 null。
AnyHolder(Any initial)
为给定的 Any 对象构造一个新 AnyHolder 对象。
方法摘要
void | _read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
TypeCode | _type() 返回对应于此 AnyHolder 对象中保存值的 TypeCode 对象。
void | _write(OutputStream output) 将此 AnyHolder 对象中的值编组到 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Any value
此 AnyHolder 对象保存的 Any 值。

构造方法详细信息

AnyHolder

public AnyHolder()
构造一个新的 AnyHolder 对象，将其 value 字段初始化为 null。

AnyHolder

public AnyHolder(Any initial)
为给定的 Any 对象构造一个新 AnyHolder 对象。

参数：
initial - 用来初始化新 AnyHolder 对象 value 字段的 Any 对象
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 AnyHolder 对象中的值编组到 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
返回对应于此 AnyHolder 对象中保存值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
此 AnyHolder 对象中所保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AnySeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 AnySeqHelper

java.lang.Object
    继承者  org.omg.CORBA.AnySeqHelper

public abstract class AnySeqHelper
extends Object

AnySeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/AnySeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
AnySeqHelper()
方法摘要
static Any[] | extract(Any a)
static String | id()
static void | insert(Any a, Any[] that)
static Any[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Any[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AnySeqHelper

public AnySeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          Any[] that)

extract

public static Any[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Any[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Any[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AnySeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 AnySeqHolder

java.lang.Object
    继承者  org.omg.CORBA.AnySeqHolder
所有已实现的接口：
Streamable
public final class AnySeqHolder
extends Object
implements Streamable

AnySeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/AnySeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00)

字段摘要
 Any[] value
构造方法摘要
AnySeqHolder()
AnySeqHolder(Any[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Any[] value
构造方法详细信息

AnySeqHolder

public AnySeqHolder()

AnySeqHolder

public AnySeqHolder(Any[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ARG_IN (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 ARG_IN

public interface ARG_IN

向调用符号化 "input" 参数，表示从客户端将该参数传递到服务器。ARG_IN.value 是用来指示方向的可能值之一，该方向是在使用动态调用接口（Dynamic Invocation Interface，DII）执行调用期间传递参数的方向。

以下代码片段展示了一种典型的用法：

    ORB orb = ORB.init(args, null);
    org.omg.CORBA.NamedValue nv = orb.create_named_value(
         "IDLArgumentIdentifier", myAny, org.omg.CORBA.ARG_IN.value);

从以下版本开始：
JDK1.2
另请参见：
NamedValue

字段摘要
static int value
指示 input 参数的值。

字段详细信息

value

static final int value
指示 input 参数的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ARG_INOUT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 ARG_INOUT

public interface ARG_INOUT

表示用于某一调用的输入和输出的参数，意味着将该参数从客户端传到服务器，然后再从服务器传回客户端。ARG_INOUT.value 是用来指示方向的可能值之一，该方向是在使用动态调用接口（Dynamic Invocation Interface，DII）执行动态调用期间传递参数的方向。

以下代码片段展示了一种典型的用法：

  ORB orb = ORB.init(args, null);
  org.omg.CORBA.NamedValue nv = orb.create_named_value(
        "argumentIdentifier", myAny, org.omg.CORBA.ARG_INOUT.value);

从以下版本开始：
JDK1.2
另请参见：
NamedValue

字段摘要
static int value
指示用于输入和输出的参数的常量值。

字段详细信息

value

static final int value
指示用于输入和输出的参数的常量值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ARG_OUT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 ARG_OUT

public interface ARG_OUT

表示调用的 "input" 参数的常量，意味着从服务器将该参数传递到客户端。ARG_OUT.value 是用来指示方向的可能值之一，该方向是在使用动态调用接口（Dynamic Invocation Interface，DII）执行动态调用期间传递参数的方向。

以下代码片段展示了一种典型的用法：

  ORB orb = ORB.init(args, null);
  org.omg.CORBA.NamedValue nv = orb.create_named_value(
        "argumentIdentifier", myAny, org.omg.CORBA.ARG_OUT.value);

从以下版本开始：
JDK1.2
另请参见：
NamedValue

字段摘要
static int value
指示 output 参数的常量值。

字段详细信息

value

static final int value
指示 output 参数的常量值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_CONTEXT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BAD_CONTEXT

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.BAD_CONTEXT
所有已实现的接口：
Serializable
public final class BAD_CONTEXT
extends SystemException

当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
BAD_CONTEXT()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_CONTEXT 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BAD_CONTEXT

public BAD_CONTEXT()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。

BAD_CONTEXT

public BAD_CONTEXT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。

参数：
s - 包含详细消息的 String 对象

BAD_CONTEXT

public BAD_CONTEXT(int minor,
                   CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_CONTEXT 异常。

参数：
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例

BAD_CONTEXT

public BAD_CONTEXT(String s,
                   int minor,
                   CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_CONTEXT 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_INV_ORDER (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BAD_INV_ORDER

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.BAD_INV_ORDER
所有已实现的接口：
Serializable
public final class BAD_INV_ORDER
extends SystemException

此异常指示调用者按错误顺序调用了操作。例如，如果应用程序在没有事先正确初始化 ORB 的情况下执行与 ORB 有关的调用，则 ORB 将引发该异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
BAD_INV_ORDER()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BAD_INV_ORDER

public BAD_INV_ORDER()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。

BAD_INV_ORDER

public BAD_INV_ORDER(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。

参数：
s - 包含详细消息的字符串

BAD_INV_ORDER

public BAD_INV_ORDER(int minor,
                     CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_INV_ORDER 异常。

参数：
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例

BAD_INV_ORDER

public BAD_INV_ORDER(String s,
                     int minor,
                     CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_INV_ORDER 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_OPERATION (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BAD_OPERATION

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.BAD_OPERATION
所有已实现的接口：
Serializable
public final class BAD_OPERATION
extends SystemException

当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
BAD_OPERATION()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。
BAD_OPERATION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_OPERATION(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。
BAD_OPERATION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_OPERATION 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BAD_OPERATION

public BAD_OPERATION()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。

BAD_OPERATION

public BAD_OPERATION(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。

参数：
s - 包含详细消息的 String

BAD_OPERATION

public BAD_OPERATION(int minor,
                     CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_OPERATION 异常。

参数：
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例

BAD_OPERATION

public BAD_OPERATION(String s,
                     int minor,
                     CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_OPERATION 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_PARAM (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BAD_PARAM

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.BAD_PARAM
所有已实现的接口：
Serializable
public final class BAD_PARAM
extends SystemException

当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。如果将 null 值或 null 指针传递给某一操作（用于应用 null 指针和 null 值概念的语言映射），则 ORB 将引发此异常。如果客户端通过 DII 使用不正确的参数生成请求，则也会引发 BAD_PARAM。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档, 次要代码的含义

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
BAD_PARAM()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。
BAD_PARAM(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_PARAM(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。
BAD_PARAM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_PARAM 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BAD_PARAM

public BAD_PARAM()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。

BAD_PARAM

public BAD_PARAM(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。

参数：
s - 包含描述此异常的详细消息的 String

BAD_PARAM

public BAD_PARAM(int minor,
                 CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_PARAM 异常。

参数：
minor - 次要代码
completed - 完成状态

BAD_PARAM

public BAD_PARAM(String s,
                 int minor,
                 CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_PARAM 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_POLICY (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 BAD_POLICY

public interface BAD_POLICY

将填充在 PolicyError 异常中的 PolicyErrorCode。

字段摘要
static short value
PolicyError 异常中的 Error 代码。

字段详细信息

value

static final short value
PolicyError 异常中的 Error 代码。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_POLICY_TYPE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 BAD_POLICY_TYPE

public interface BAD_POLICY_TYPE

将填充在 PolicyError 异常中的 PolicyErrorCode。

字段摘要
static short value
PolicyError 异常中的 Error 代码。

字段详细信息

value

static final short value
PolicyError 异常中的 Error 代码。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_POLICY_VALUE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 BAD_POLICY_VALUE

public interface BAD_POLICY_VALUE

包含指示某个策略值的值，该策略值对于 create_policy 方法（在 ORB 类中定义）调用中的有效策略类型而言是不正确的。

字段摘要
static short value
该值用于表示 PolicyError 异常中的严重策略值错误。

字段详细信息

value

static final short value
该值用于表示 PolicyError 异常中的严重策略值错误。

另请参见：
PolicyError, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_QOS (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BAD_QOS

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.BAD_QOS
所有已实现的接口：
Serializable
public final class BAD_QOS
extends SystemException

只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。

从以下版本开始：
J2SE 1.5
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
BAD_QOS()
构造一个 BAD_QOS 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
BAD_QOS(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_QOS(String detailMessage)
使用指定消息构造一个 BAD_QOS 异常。
BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 BAD_QOS 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BAD_QOS

public BAD_QOS()
构造一个 BAD_QOS 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。

BAD_QOS

public BAD_QOS(String detailMessage)
使用指定消息构造一个 BAD_QOS 异常。

参数：
detailMessage - 包含详细消息的字符串。

BAD_QOS

public BAD_QOS(int minorCode,
               CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 BAD_QOS 异常。

参数：
minorCode - 次要代码。
completionStatus - 完成状态。

BAD_QOS

public BAD_QOS(String detailMessage,
               int minorCode,
               CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 BAD_QOS 异常。

参数：
detailMessage - 包含详细消息的字符串。
minorCode - 次要代码。
completionStatus - 完成状态。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BAD_TYPECODE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BAD_TYPECODE

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.BAD_TYPECODE
所有已实现的接口：
Serializable
public final class BAD_TYPECODE
extends SystemException

当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
BAD_TYPECODE()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_TYPECODE 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BAD_TYPECODE

public BAD_TYPECODE()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。

BAD_TYPECODE

public BAD_TYPECODE(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。

参数：
s - 包含详细消息的字符串

BAD_TYPECODE

public BAD_TYPECODE(int minor,
                    CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_TYPECODE 异常。

参数：
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例

BAD_TYPECODE

public BAD_TYPECODE(String s,
                    int minor,
                    CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_TYPECODE 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BooleanHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BooleanHolder

java.lang.Object
    继承者  org.omg.CORBA.BooleanHolder
所有已实现的接口：
Streamable
public final class BooleanHolder
extends Object
implements Streamable

Boolean 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

boolean 值的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将 IDL boolean 作为 "out" 或 "inout" 参数，则程序员必须传递 BooleanHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myBooleanHolder 是 BooleanHolder 的实例，则可以使用 myBooleanHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 boolean value
此 BooleanHolder 对象保存的 boolean 值。
构造方法摘要
BooleanHolder()
构造一个新的 BooleanHolder 对象，将其 value 字段初始化为 false。
BooleanHolder(boolean initial)
构造一个新的 BooleanHolder 对象，并使用给定 boolean 初始化其 value 字段。
方法摘要
void | _read(InputStream input) 从 input 中读取已解组的数据，并将它们分配给此 BooleanHolder 对象的 value 字段。
TypeCode | _type() 检索对应于此 BooleanHolder 对象中所保存的值的 TypeCode 对象。
void | _write(OutputStream output) 将此 BooleanHolder 对象 value 字段中的值编组到输出流 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public boolean value
此 BooleanHolder 对象保存的 boolean 值。

构造方法详细信息

BooleanHolder

public BooleanHolder()
构造一个新的 BooleanHolder 对象，将其 value 字段初始化为 false。

BooleanHolder

public BooleanHolder(boolean initial)
构造一个新的 BooleanHolder 对象，并使用给定 boolean 初始化其 value 字段。

参数：
initial - 用来初始化新建 BooleanHolder 对象 value 字段的 boolean 值
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取已解组的数据，并将它们分配给此 BooleanHolder 对象的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream 对象。

_write

public void _write(OutputStream output)
将此 BooleanHolder 对象 value 字段中的值编组到输出流 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
检索对应于此 BooleanHolder 对象中所保存的值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
此 BooleanHolder 对象中所保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BooleanSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BooleanSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.BooleanSeqHelper

public abstract class BooleanSeqHelper
extends Object

BooleanSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/BooleanSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
BooleanSeqHelper()
方法摘要
static boolean[] | extract(Any a)
static String | id()
static void | insert(Any a, boolean[] that)
static boolean[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, boolean[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BooleanSeqHelper

public BooleanSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          boolean[] that)

extract

public static boolean[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static boolean[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         boolean[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BooleanSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 BooleanSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.BooleanSeqHolder
所有已实现的接口：
Streamable
public final class BooleanSeqHolder
extends Object
implements Streamable

BooleanSeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/BooleanSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00)

字段摘要
 boolean[] value
构造方法摘要
BooleanSeqHolder()
BooleanSeqHolder(boolean[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public boolean[] value
构造方法详细信息

BooleanSeqHolder

public BooleanSeqHolder()

BooleanSeqHolder

public BooleanSeqHolder(boolean[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Bounds (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 Bounds

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.Bounds
所有已实现的接口：
Serializable, IDLEntity
public final class Bounds
extends UserException

当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。

另请参见：
关于 Java IDL 异常的文档

构造方法摘要
Bounds()
构造不带指定详细消息的 Bounds。
Bounds(String reason)
构造带指定详细消息的 Bounds。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Bounds

public Bounds()
构造不带指定详细消息的 Bounds。

Bounds

public Bounds(String reason)
构造带指定详细消息的 Bounds。

参数：
reason - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ByteHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ByteHolder

java.lang.Object
    继承者  org.omg.CORBA.ByteHolder
所有已实现的接口：
Streamable
public final class ByteHolder
extends Object
implements Streamable

Byte 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

byte 值的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将一个 IDL octet 作为 "out" 或 "inout" 参数，则程序员必须传递一个 ByteHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myByteHolder 是 ByteHolder 实例，则可以使用 myByteHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 byte value
此 ByteHolder 对象保存的 byte 值。
构造方法摘要
ByteHolder()
构造一个新的 ByteHolder 对象，将其 value 字段初始化为 0。
ByteHolder(byte initial)
为给定 byte 构造一个新的 ByteHolder 对象。
方法摘要
void | _read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ByteHolder 对象中的值。
TypeCode | _type() 返回对应于此 ByteHolder 对象中所保存的值的 TypeCode。
void | _write(OutputStream output) 将此 ByteHolder 对象中的值编组到 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public byte value
此 ByteHolder 对象保存的 byte 值。

构造方法详细信息

ByteHolder

public ByteHolder()
构造一个新的 ByteHolder 对象，将其 value 字段初始化为 0。

ByteHolder

public ByteHolder(byte initial)
为给定 byte 构造一个新的 ByteHolder 对象。

参数：
initial - 用来初始化新 ByteHolder 对象 value 字段的 byte
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取数据，并使用已解组数据初始化此 ByteHolder 对象中的值。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 ByteHolder 对象中的值编组到 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
返回对应于此 ByteHolder 对象中所保存的值的 TypeCode。

指定者：
接口 Streamable 中的 _type
返回：
此 ByteHolder 对象中所保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 CharHolder

java.lang.Object
    继承者  org.omg.CORBA.CharHolder
所有已实现的接口：
Streamable
public final class CharHolder
extends Object
implements Streamable

Char 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

char 值的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将 IDL char 作为 "out" 或 "inout" 参数，则程序员必须传递 CharHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myCharHolder 是 CharHolder 实例，则可以使用 myCharHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 char value
此 CharHolder 对象保存的 char 值。
构造方法摘要
CharHolder()
构造一个新的 CharHolder 对象，将其 value 字段初始化为 0。
CharHolder(char initial)
为给定 char 值构造一个新的 CharHolder 对象。
方法摘要
void | _read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 CharHolder 对象中的值。
TypeCode | _type() 返回对应于此 CharHolder 对象中所保存的值的 TypeCode 对象。
void | _write(OutputStream output) 将此 CharHolder 对象中的值编组到 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public char value
此 CharHolder 对象保存的 char 值。

构造方法详细信息

CharHolder

public CharHolder()
构造一个新的 CharHolder 对象，将其 value 字段初始化为 0。

CharHolder

public CharHolder(char initial)
为给定 char 值构造一个新的 CharHolder 对象。

参数：
initial - 用来初始化新 CharHolder 对象 value 字段的 char 值
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取数据，并使用已解组数据初始化此 CharHolder 对象中的值。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 CharHolder 对象中的值编组到 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
返回对应于此 CharHolder 对象中所保存的值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
此 CharHolder 对象中所保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 CharSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.CharSeqHelper

public abstract class CharSeqHelper
extends Object

CharSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/CharSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
CharSeqHelper()
方法摘要
static char[] | extract(Any a)
static String | id()
static void | insert(Any a, char[] that)
static char[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, char[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CharSeqHelper

public CharSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          char[] that)

extract

public static char[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static char[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         char[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 CharSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.CharSeqHolder
所有已实现的接口：
Streamable
public final class CharSeqHolder
extends Object
implements Streamable

CharSeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/CharSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00)

字段摘要
 char[] value
构造方法摘要
CharSeqHolder()
CharSeqHolder(char[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public char[] value
构造方法详细信息

CharSeqHolder

public CharSeqHolder()

CharSeqHolder

public CharSeqHolder(char[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CODESET_INCOMPATIBLE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 CODESET_INCOMPATIBLE

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.CODESET_INCOMPATIBLE
所有已实现的接口：
Serializable
public final class CODESET_INCOMPATIBLE
extends SystemException

当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。

从以下版本开始：
J2SE 1.5
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
CODESET_INCOMPATIBLE()
构造一个 CODESET_INCOMPATIBLE 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
CODESET_INCOMPATIBLE(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
CODESET_INCOMPATIBLE(String detailMessage)
使用指定消息构造一个 CODESET_INCOMPATIBLE 异常。
CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CODESET_INCOMPATIBLE

public CODESET_INCOMPATIBLE()
构造一个 CODESET_INCOMPATIBLE 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。

CODESET_INCOMPATIBLE

public CODESET_INCOMPATIBLE(String detailMessage)
使用指定消息构造一个 CODESET_INCOMPATIBLE 异常。

参数：
detailMessage - 包含详细消息的字符串。

CODESET_INCOMPATIBLE

public CODESET_INCOMPATIBLE(int minorCode,
                            CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。

参数：
minorCode - 次要代码。
completionStatus - 完成状态。

CODESET_INCOMPATIBLE

public CODESET_INCOMPATIBLE(String detailMessage,
                            int minorCode,
                            CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。

参数：
detailMessage - 包含详细消息的字符串。
minorCode - 次要代码。
completionStatus - 完成状态。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


COMM_FAILURE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 COMM_FAILURE

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.COMM_FAILURE
所有已实现的接口：
Serializable
public final class COMM_FAILURE
extends SystemException

如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

从以下版本开始：
JDK1.2
另请参见：
次要代码的含义

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
COMM_FAILURE()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。
COMM_FAILURE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 COMM_FAILURE 异常。
COMM_FAILURE(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。
COMM_FAILURE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 COMM_FAILURE 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

COMM_FAILURE

public COMM_FAILURE()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。

COMM_FAILURE

public COMM_FAILURE(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。

参数：
s - 包含描述此异常的详细消息的 String

COMM_FAILURE

public COMM_FAILURE(int minor,
                    CompletionStatus completed)
使用指定次要代码和完成状态构造一个 COMM_FAILURE 异常。

参数：
minor - 次要代码
completed - 完成状态，它必须是 COMPLETED_YES、COMPLETED_NO 或 COMPLETED_MAYBE 之一。

COMM_FAILURE

public COMM_FAILURE(String s,
                    int minor,
                    CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 COMM_FAILURE 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 完成状态，它必须是 COMPLETED_YES、COMPLETED_NO 或 COMPLETED_MAYBE 之一。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompletionStatus (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 CompletionStatus

java.lang.Object
    继承者  org.omg.CORBA.CompletionStatus
所有已实现的接口：
Serializable, IDLEntity
public final class CompletionStatus
extends Object
implements IDLEntity

指示某一方法抛出 SystemException 时是否已结束运行的对象。

CompletionStatus 类包含三个 CompletionStatus 实例，它们是表示每种可能完成状态的常量：COMPLETED_MAYBE、COMPLETED_NO 和 COMPLETED_YES。该类还包含三个 int 成员，每个成员都是对应于一个 CompletionStatus 实例的常量。这些 int 成员使该类可以使用 switch 语句。

该类还包含两个方法：

  • public int value()：该方法访问 CompletionStatus 对象的 value 字段
  • public static CompletionStatus from_int(int i)：该方法用于根据 int 成员之一创建实例

从以下版本开始：
JDK1.2
另请参见：
SystemException

字段摘要
static int | _COMPLETED_MAYBE 指示某一方法在抛出 SystemException 之前已结束运行的常量。
static int | _COMPLETED_NO 指示某一方法在抛出 SystemException 之前已结束运行的常量。
static int | _COMPLETED_YES 指示某一方法在抛出 SystemException 之前已结束运行的常量。
static CompletionStatus | COMPLETED_MAYBE 使用常量 _COMPLETED_MAYBE 初始化的 CompletionStatus 实例。
static CompletionStatus | COMPLETED_NO 使用常量 _COMPLETED_NO 初始化的 CompletionStatus 实例。
static CompletionStatus | COMPLETED_YES 使用常量 _COMPLETED_YES 初始化的 CompletionStatus 实例。
方法摘要
static CompletionStatus | from_int(int i) 根据给定的 int 创建一个 CompletionStatus 对象。
int | value() 检索此 CompletionStatus 对象的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_COMPLETED_YES

public static final int _COMPLETED_YES
指示某一方法在抛出 SystemException 之前已结束运行的常量。

另请参见：
常量字段值

_COMPLETED_NO

public static final int _COMPLETED_NO
指示某一方法在抛出 SystemException 之前已结束运行的常量。

另请参见：
常量字段值

_COMPLETED_MAYBE

public static final int _COMPLETED_MAYBE
指示某一方法在抛出 SystemException 之前已结束运行的常量。

另请参见：
常量字段值

COMPLETED_YES

public static final CompletionStatus COMPLETED_YES
使用常量 _COMPLETED_YES 初始化的 CompletionStatus 实例。

COMPLETED_NO

public static final CompletionStatus COMPLETED_NO
使用常量 _COMPLETED_NO 初始化的 CompletionStatus 实例。

COMPLETED_MAYBE

public static final CompletionStatus COMPLETED_MAYBE
使用常量 _COMPLETED_MAYBE 初始化的 CompletionStatus 实例。

方法详细信息

value

public int value()
检索此 CompletionStatus 对象的值。

返回：
可能的 CompletionStatus 值之一：_COMPLETED_YES、_COMPLETED_NO 或 _COMPLETED_MAYBE

from_int

public static CompletionStatus from_int(int i)
根据给定的 int 创建一个 CompletionStatus 对象。

参数：
i - _COMPLETED_YES、_COMPLETED_NO 或 _COMPLETED_MAYBE 之一
返回：
带有以下值的可能 CompletionStatus 对象之一：_COMPLETED_YES、_COMPLETED_NO 或 _COMPLETED_MAYBE
抛出：
BAD_PARAM - 如果提供的参数不是 CompletionStatus 中定义的 int 常量之一
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompletionStatusHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 CompletionStatusHelper

java.lang.Object
    继承者  org.omg.CORBA.CompletionStatusHelper

public abstract class CompletionStatusHelper
extends Object

CompletionStatus 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/CompletionStatusHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）生成，生成时间为 1999 年 6 月 3 日 11:52:03 (GMT+00:00)

构造方法摘要
CompletionStatusHelper()
方法摘要
static CompletionStatus | extract(Any a)
static String | id()
static void | insert(Any a, CompletionStatus that)
static CompletionStatus | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, CompletionStatus value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CompletionStatusHelper

public CompletionStatusHelper()
方法详细信息

insert

public static void insert(Any a,
                          CompletionStatus that)

extract

public static CompletionStatus extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static CompletionStatus read(InputStream istream)

write

public static void write(OutputStream ostream,
                         CompletionStatus value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Context (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 Context

java.lang.Object
    继承者  org.omg.CORBA.Context

public abstract class Context
extends Object

用于在 Request 操作中指定上下文对象的对象，上下文字符串在与请求调用一起被发送之前，必须在该指定的上下文对象中进行解析。Context 对象包含 NamedValue 对象形式的属性列表。这些属性表示关于客户端、环境或请求情形的信息，它们通常是一些可能不方便作为参数传递的属性。

Context 对象是通过先调用 ORB 方法 get_default_context，然后在默认上下文上调用 create_child 来创建的。

Context 对象中的每个属性都由一个 NamedValue 对象表示。属性名称包含在 NamedValue 对象的 name 字段中，与该名称关联的值包含在 Any 对象中，该 Any 已分配给 NamedValue 对象的 value 字段。

Context 属性可以表示要传播到服务器环境（并使其成为其隐含部分）的部分客户端环境或应用程序环境。（示例有窗口标识符或用户首选项信息）。一旦已经调用服务器（即传播属性之后），服务器可以使用 get_values 方法查询其 Context 对象来获得这些属性。

当操作声明中包括上下文子句时，stub 和 skeleton 将有一个为该上下文添加的额外参数。在进行操作调用时，ORB 将在已调用方法的 Context 对象参数中提供使用 IDL 在操作定义中指定的属性以及客户端的 Context 对象中存在的属性。

多个 Context 属性名称（字符串）通常是以 OMG IDL 标识符（或一系列以句点分隔的 OMG IDL 标识符）的形式出现的。单个 Context 属性名称模式可以是属性名称或后跟单个 "*" 的属性名称。没有结尾 "*" 的属性名称模式被认为只与它自己匹配。"<名称>*"形式的属性名称模式与任何以<名称>开头，且后跟零个或多个附加字符的属性名称匹配。

属性名称模式用在操作定义的 Context 子句中，作为 Context.get_values 方法的参数。

Context 对象可能被“链接”在一起，以完成特定默认行为。使用 create_child 方法创建的 Context 对象将与其父对象（创建该对象的 Context 对象）链接在一起，这意味着在搜索属性名称时，搜索子对象之后将搜索父对象。

在特定 Context 对象中定义的属性会在下一个较高级别有效地重写这些属性。通过指定起始范围并在调用 get_values 方法时使用标志 CTX_RESTRICT_SCOPE，可以限定在搜索属性时使用的范围。

可以指定一个 Context 对象来指定起始搜索范围。

从以下版本开始：
JDK1.2

构造方法摘要
Context()
方法摘要
abstract String | context_name() 检索此 Context 对象的名称。
abstract Context | create_child(String child_ctx_name) 创建一个 Context 对象，使用给定字符串作为其名称，并将此 Context 对象设置为其父对象。
abstract void | delete_values(String propname) 从此 Context 对象中删除 name 字段与给定属性名称匹配的 NamedValue 对象。
abstract NVList | get_values(String start_scope, int op_flags, String pattern) 检索 name 字段与给定名称或名称模式匹配的 NamedValue 对象。
abstract Context | parent() 检索此 Context 对象的父对象。
abstract void | set_one_value(String propname, Any propvalue) 创建一个 NamedValue 对象，并将它添加到此 Context 对象中。
abstract void | set_values(NVList values) 在此 Context 对象中设置一个或多个属性值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Context

public Context()
方法详细信息

context_name

public abstract String context_name()
检索此 Context 对象的名称。

返回：
此 Context 对象的名称

parent

public abstract Context parent()
检索此 Context 对象的父对象。

返回：
作为此 Context 父对象的 Context 对象

create_child

public abstract Context create_child(String child_ctx_name)
创建一个 Context 对象，使用给定字符串作为其名称，并将此 Context 对象设置为其父对象。

将新的 Context 对象链接到其父 Context 对象中。这意味着在搜索匹配属性名称时，如果在此上下文中没有发现匹配项，则将继续在父对象中进行搜索。如果该搜索还不成功，则继续在祖父对象（如果有）中进行搜索，依此类推。

参数：
child_ctx_name - 将设置为新 Context 对象名称的 String 对象
返回：
使用指定名称初始化的新建子 Context 对象

set_one_value

public abstract void set_one_value(String propname,
                                   Any propvalue)
创建一个 NamedValue 对象，并将它添加到此 Context 对象中。将新 NamedValue 对象的 name 字段设置为给定字符串；将 value 字段设置为给定 Any 对象；将 flags 字段设置为 0。

参数：
propname - 要设置的属性名称
propvalue - 用来设置属性值的 Any 对象。Any 对象的 value 字段包含将与给定 propname 关联的值；必须将 kind 字段设置为 TCKind.tk_string。

set_values

public abstract void set_values(NVList values)
在此 Context 对象中设置一个或多个属性值。提供给此方法的 NVList 包含一个或多个 NamedValue 对象。在每个 NamedValue 对象中，name 字段用于保存属性名称，同时必须将 flags 字段设置为 0。NamedValue 对象的 value 字段包含一个 Any 对象，而该对象中又包含属性的值。因为该值始终是字符串，所以 Any 对象必须将其 TypeCode 的 kind 字段设置为 TCKind.tk_string。

参数：
values - 包含属性名称和要设置的关联值的 NVList
另请参见：
get_values(java.lang.String, int, java.lang.String), NamedValue, Any

delete_values

public abstract void delete_values(String propname)
从此 Context 对象中删除 name 字段与给定属性名称匹配的 NamedValue 对象。如果为 propname 提供的 String 对象具有结尾通配符 ("*")，则删除所有 name 字段与之匹配的 NamedValue 对象。始终将搜索范围限定为此 Context 对象。

如果未找到匹配属性，则返回异常。

参数：
propname - 要删除的属性名称

get_values

public abstract NVList get_values(String start_scope,
                                  int op_flags,
                                  String pattern)
检索 name 字段与给定名称或名称模式匹配的 NamedValue 对象。此方法允许使用通配符进行搜索，这意味着可能存在多个匹配项，所以可能返回多个值。如果在指示的级别上没有找到该属性，则将继续沿上下文对象树向上搜索，直到找到一个匹配项，或者已经搜索完链接中所有的 Context 对象。

如果没有发现匹配项，则返回错误，不返回任何属性列表。

参数：
start_scope - 指示上下文对象级别的 String 对象，将在该级别上启动对指定属性（例如 "_USER"、"_GROUP" 和 "_SYSTEM"）的搜索。有效范围的名称是特定于实现的。如果忽略范围名称，则从指定上下文对象开始搜索。如果没有找到指定范围名称，则返回异常。
op_flags - 操作标志。可以指定的一个标志是 CTX_RESTRICT_SCOPE。如果指定此标志，则将搜索限定为指定的 start_scope 或此 Context 对象。
pattern - 将检索其值的属性名称。pattern 可以是名称或结尾带通配符 ("*") 的名称。
返回：
一个 NVList，它包含所有关联属性名称与给定名称或名称模式匹配的属性值（以 NamedValue 对象的形式存在）
另请参见：
set_values(org.omg.CORBA.NVList), NamedValue
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContextList (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ContextList

java.lang.Object
    继承者  org.omg.CORBA.ContextList

public abstract class ContextList
extends Object

一个对象，它包含表示属性名称的 String 对象所组成的可修改列表。此类在 Request 操作中使用，用于描述需要解析并与调用一起发送的上下文。（上下文是通过给定属性名称并取回与之关联的值来解析的。）这通过调用 Context 方法 get_values 并提供取自 ContextList 对象的字符串作为第三个参数来实现。get_values 方法返回一个包含 NamedValue 对象的 NVList 对象，NamedValue 保存由给定字符串标识的值。

ContextList 对象由 ORB 创建，如下所示：

   ORB orb = ORB.init(args, null);
   org.omg.CORBA.ContextList ctxList = orb.create_context_list();
变量 ctxList 表示空 ContextList 对象。使用方法 add 将 String 添加到列表中，使用方法 item 访问，使用方法 remove 删除。

从以下版本开始：
JDK1.2
另请参见：
Context

构造方法摘要
ContextList()
方法摘要
abstract void | add(String ctx) 将 String 对象添加到此 ContextList 对象中。
abstract int | count() 返回此 ContextList 对象中的 String 对象数。
abstract String | item(int index) 返回位于给定索引的 String 对象。
abstract void | remove(int index) 移除给定索引处的 String 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContextList

public ContextList()
方法详细信息

count

public abstract int count()
返回此 ContextList 对象中的 String 对象数。

返回：
表示此 ContextList 对象中 String 数量的 int

add

public abstract void add(String ctx)
将 String 对象添加到此 ContextList 对象中。

参数：
ctx - 要添加的 String 对象

item

public abstract String item(int index)
                     throws Bounds
返回位于给定索引的 String 对象。

参数：
index - 所需字符串的索引，其中 0 为第一个字符串的索引
返回：
给定索引处的字符串
抛出：
Bounds - 如果索引大于或等于此 ContextList 对象中的字符串数

remove

public abstract void remove(int index)
                     throws Bounds
移除给定索引处的 String 对象。注意，被移除对象后面的所有字符串的索引都向下移动一位。

参数：
index - 将要移除的 String 对象的索引，0 表示第一个字符串
抛出：
Bounds - 如果该索引大于或等于此 ContextList 对象中的 String 对象数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CTX_RESTRICT_SCOPE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 CTX_RESTRICT_SCOPE

public interface CTX_RESTRICT_SCOPE

可以用作 Context.get_values 方法的第二个参数以限制搜索范围的标志。在使用此标志时，它将上下文值的搜索限定为此特定 Context 对象，或限定为在 Context.get_values 第一个参数所指定的范围。

用法：

     NVList props = myContext.get_values("_USER",
                     CTX_RESTRICT_SCOPE.value, "id*");

从以下版本开始：
JDK1.2
另请参见：
Context.get_values(String, int, String)

字段摘要
static int value
该字段包含 CTX_RESTRICT_SCOPE 标志的 int 值。

字段详细信息

value

static final int value
该字段包含 CTX_RESTRICT_SCOPE 标志的 int 值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Current (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 Current

所有超级接口：
CurrentOperations, IDLEntity, Object, Serializable
所有已知子接口：
Current, Current
public interface Current
extends CurrentOperations, Object, IDLEntity

从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。此信息是使用从在 CORBA 模块中定义的 Current 接口派生的接口以结构化方式访问的。

每个需要自己的上下文的 ORB 或 CORBA 服务都从 CORBA 模块的 Current 中派生一个接口。这些服务的用户可以通过调用 ORB::resolve_initial_references 获取一个适当的 Current 接口实例。

org/omg/CORBA/_PolicyStub.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20。

方法摘要
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 CurrentHelper

java.lang.Object
    继承者  org.omg.CORBA.CurrentHelper

public abstract class CurrentHelper
extends Object

Current 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/CurrentHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20

构造方法摘要
CurrentHelper()
方法摘要
static Current | extract(Any a)
static String | id()
static void | insert(Any a, Current that)
static Current | narrow(Object obj)
static Current | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Current value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CurrentHelper

public CurrentHelper()
方法详细信息

insert

public static void insert(Any a,
                          Current that)

extract

public static Current extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Current read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Current value)

narrow

public static Current narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 CurrentHolder

java.lang.Object
    继承者  org.omg.CORBA.CurrentHolder
所有已实现的接口：
Streamable
public final class CurrentHolder
extends Object
implements Streamable

Current 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/CurrentHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20

字段摘要
 Current value
构造方法摘要
CurrentHolder()
CurrentHolder(Current initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Current value
构造方法详细信息

CurrentHolder

public CurrentHolder()

CurrentHolder

public CurrentHolder(Current initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 CurrentOperations

所有已知子接口：
Current, Current, Current, CurrentOperations, CurrentOperations
public interface CurrentOperations

Current 的接口。有关 Operations 接口的更多信息，请参阅“生成的文件”。 org/omg/CORBA/CurrentOperations.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CustomMarshal (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 CustomMarshal

所有已知子接口：
CustomValue
public interface CustomMarshal

将由 ORB 而不是由用户使用的抽象 value 类型。从语义上说，此类被视为自定义 value 类型的隐式基类，尽管在 IDL 中自定义 value 类型实际上并没有继承它。自定义值类型的实现方应提供 CustomMarshal 操作的实现。实现该操作的方式在 IDL 到 Java 语言映射中指定。每种自定义编组值类型都应该有它自己的实现。

另请参见：
DataInputStream

方法摘要
void | marshal(DataOutputStream os) 必须通过自定义的 Marshal 类实现 marshal 方法。
void | unmarshal(DataInputStream is) 必须通过自定义的 Marshal 类实现 unmarshal 方法。

方法详细信息

marshal

void marshal(DataOutputStream os)
必须通过自定义的 Marshal 类实现 marshal 方法。这是用来编组的方法。

参数：
os - DataOutputStream

unmarshal

void unmarshal(DataInputStream is)
必须通过自定义的 Marshal 类实现 unmarshal 方法。这是用来解组的方法。

参数：
is - DataInputStream
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DATA_CONVERSION (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 DATA_CONVERSION

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.DATA_CONVERSION
所有已实现的接口：
Serializable
public final class DATA_CONVERSION
extends SystemException

如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。例如，如果宽字符代码集转换失败，或者 ORB 无法在不同的表示形式之间转换浮点值，则引发 DATA_CONVERSION。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
DATA_CONVERSION()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(String s)
使用指定详细消息构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 DATA_CONVERSION 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DATA_CONVERSION

public DATA_CONVERSION()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 DATA_CONVERSION 异常。

DATA_CONVERSION

public DATA_CONVERSION(String s)
使用指定详细消息构造一个 DATA_CONVERSION 异常。

参数：
s - 包含详细消息的字符串

DATA_CONVERSION

public DATA_CONVERSION(int minor,
                       CompletionStatus completed)
使用指定次要代码和完成状态构造一个 DATA_CONVERSION 异常。

参数：
minor - 次要代码
completed - 完成状态

DATA_CONVERSION

public DATA_CONVERSION(String s,
                       int minor,
                       CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 DATA_CONVERSION 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataInputStream (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DataInputStream

所有超级接口：
IDLEntity, Serializable, ValueBase
public interface DataInputStream
extends ValueBase

定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。此接口供用户编写的自定义值类型的自定义解组代码使用。

另请参见：
DataOutputStream, CustomMarshal

方法摘要
 Object read_Abstract()
从输入流读取 IDL Abstract 接口。
 void read_any_array(AnySeqHolder seq, int offset, int length)
从输入流读取 IDL Any 数组中从 offset 处开始的 length 个元素。
 Any read_any()
从输入流读取 IDL Any 值。
 void read_boolean_array(BooleanSeqHolder seq, int offset, int length)
从输入流读取 IDL boolean 数组中 offset 处开始的 length 个元素。
 boolean read_boolean()
从输入流读取 IDL boolean 值。
 void read_char_array(CharSeqHolder seq, int offset, int length)
从输入流读取 IDL 字符数组中从 offset 处开始的 length 个元素。
 char read_char()
从输入流读取 IDL 字符值。
 void read_double_array(DoubleSeqHolder seq, int offset, int length)
从输入流读取 IDL double 数组中从 offset 处开始的 length 个元素。
 double read_double()
从输入流读取 IDL double 值。
 void read_float_array(FloatSeqHolder seq, int offset, int length)
从输入流读取 IDL float 数组中从 offset 处开始的 length 个元素。
 float read_float()
从输入流读取 IDL float 值。
 void read_long_array(LongSeqHolder seq, int offset, int length)
从输入流读取 IDL long 数组中从 offset 处开始的 length 个元素。
 int read_long()
从输入流读取 IDL long 值。
 void read_longlong_array(LongLongSeqHolder seq, int offset, int length)
从输入流读取 IDL long long 数组中从 offset 处开始的 length 个元素。
 long read_longlong()
从输入流读取 IDL long long 值。
 Object read_Object()
从输入流读取 IDL CORBA::Object。
 void read_octet_array(OctetSeqHolder seq, int offset, int length)
从输入流读取 IDL octet 数组中从 offset 处开始的 length 个元素。
 byte read_octet()
从输入流读取 IDL octet 值。
 void read_short_array(ShortSeqHolder seq, int offset, int length)
从输入流读取 IDL short 数组中从 offset 处开始的 length 个元素。
 short read_short()
从输入流读取 IDL short 值。
 String read_string()
从输入流读取 IDL 字符串值。
 TypeCode read_TypeCode()
从输入流读取 IDL typecode 值。
 void read_ulong_array(ULongSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL long 数组中从 offset 处开始的 length 个元素。
 int read_ulong()
从输入流读取无符号 IDL long 值。
 void read_ulonglong_array(ULongLongSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL long long 数组中从 offset 处开始的 length 个元素。
 long read_ulonglong()
从输入流读取无符号 IDL long long 值。
 void read_ushort_array(UShortSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL short 数组中从 offset 处开始的 length 个元素。
 short read_ushort()
从输入流读取无符号 IDL short 值。
 Serializable read_Value()
从输入流读取 IDL 值类型。
 void read_wchar_array(WCharSeqHolder seq, int offset, int length)
从输入流读取 IDL 宽字符数组中从 offset 处开始的 length 个元素。
 char read_wchar()
从输入流读取 IDL 宽字符值。
 String read_wstring()
从输入流读取 IDL 宽字符串值。
从接口 org.omg.CORBA.portable.ValueBase 继承的方法
_truncatable_ids

方法详细信息

read_any

Any read_any()
从输入流读取 IDL Any 值。

返回：
读取的 Any 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_boolean

boolean read_boolean()
从输入流读取 IDL boolean 值。

返回：
读取的 boolean 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_char

char read_char()
从输入流读取 IDL 字符值。

返回：
读取的字符。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_wchar

char read_wchar()
从输入流读取 IDL 宽字符值。

返回：
读取的宽字符。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_octet

byte read_octet()
从输入流读取 IDL octet 值。

返回：
读取的 octet 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_short

short read_short()
从输入流读取 IDL short 值。

返回：
读取的 short 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_ushort

short read_ushort()
从输入流读取无符号 IDL short 值。

返回：
读取的无符号 short 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_long

int read_long()
从输入流读取 IDL long 值。

返回：
读取的 long 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_ulong

int read_ulong()
从输入流读取无符号 IDL long 值。

返回：
读取的无符号 long 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_longlong

long read_longlong()
从输入流读取 IDL long long 值。

返回：
读取的 long long 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_ulonglong

long read_ulonglong()
从输入流读取无符号 IDL long long 值。

返回：
读取的无符号 long long 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_float

float read_float()
从输入流读取 IDL float 值。

返回：
读取的 float 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_double

double read_double()
从输入流读取 IDL double 值。

返回：
读取的 double 值。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_string

String read_string()
从输入流读取 IDL 字符串值。

返回：
读取的字符串。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_wstring

String read_wstring()
从输入流读取 IDL 宽字符串值。

返回：
读取的宽字符串。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_Object

Object read_Object()
从输入流读取 IDL CORBA::Object。

返回：
读取的 CORBA::Object。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_Abstract

Object read_Abstract()
从输入流读取 IDL Abstract 接口。

返回：
读取的 Abstract 接口。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_Value

Serializable read_Value()
从输入流读取 IDL 值类型。

返回：
读取的值类型。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_TypeCode

TypeCode read_TypeCode()
从输入流读取 IDL typecode 值。

返回：
读取的 typecode。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_any_array

void read_any_array(AnySeqHolder seq,
                    int offset,
                    int length)
从输入流读取 IDL Any 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_boolean_array

void read_boolean_array(BooleanSeqHolder seq,
                        int offset,
                        int length)
从输入流读取 IDL boolean 数组中 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_char_array

void read_char_array(CharSeqHolder seq,
                     int offset,
                     int length)
从输入流读取 IDL 字符数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_wchar_array

void read_wchar_array(WCharSeqHolder seq,
                      int offset,
                      int length)
从输入流读取 IDL 宽字符数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_octet_array

void read_octet_array(OctetSeqHolder seq,
                      int offset,
                      int length)
从输入流读取 IDL octet 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_short_array

void read_short_array(ShortSeqHolder seq,
                      int offset,
                      int length)
从输入流读取 IDL short 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_ushort_array

void read_ushort_array(UShortSeqHolder seq,
                       int offset,
                       int length)
从输入流读取无符号 IDL short 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_long_array

void read_long_array(LongSeqHolder seq,
                     int offset,
                     int length)
从输入流读取 IDL long 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_ulong_array

void read_ulong_array(ULongSeqHolder seq,
                      int offset,
                      int length)
从输入流读取无符号 IDL long 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_ulonglong_array

void read_ulonglong_array(ULongLongSeqHolder seq,
                          int offset,
                          int length)
从输入流读取无符号 IDL long long 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_longlong_array

void read_longlong_array(LongLongSeqHolder seq,
                         int offset,
                         int length)
从输入流读取 IDL long long 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_float_array

void read_float_array(FloatSeqHolder seq,
                      int offset,
                      int length)
从输入流读取 IDL float 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。

read_double_array

void read_double_array(DoubleSeqHolder seq,
                       int offset,
                       int length)
从输入流读取 IDL double 数组中从 offset 处开始的 length 个元素。

参数：
seq - 将读取的数组的 out 参数 holder。
offset - 将从输入流读取的第一个元素在 seq 中的索引。
length - 从输入流读取的元素个数。
抛出：
org.omg.CORBA.MARSHAL - 如果检测到不一致的地方（包括没有注册流策略），则会引发标准系统异常 MARSHAL。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataOutputStream (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DataOutputStream

所有超级接口：
IDLEntity, Serializable, ValueBase
public interface DataOutputStream
extends ValueBase

定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。此接口供编写用于自定义值类型的自定义编组代码的用户使用。

另请参见：
DataInputStream, CustomMarshal

方法摘要
void | write_Abstract(Object value) 将 IDL Abstract 接口类型写入输出流。
void | write_any_array(Any[] seq, int offset, int length) 将 IDL Any 数组中从 offset 处开始的 length 个元素写入输出流。
void | write_any(Any value) 将 Any 值写入输出流。
void | write_boolean_array(boolean[] seq, int offset, int length) 将 IDL boolean 数组中从 offset 处开始的 length 个元素写入输出流。
void | write_boolean(boolean value) 将 boolean 值写入输出流。
void | write_char_array(char[] seq, int offset, int length) 将 IDL 字符数组中从 offset 处开始的 length 个元素写入输出流。
void | write_char(char value) 将 IDL 字符值写入输出流。
void | write_double_array(double[] seq, int offset, int length) 将 IDL double 数组中从 offset 处开始的 length 个元素写入输出流。
void | write_double(double value) 将 IDL double 值写入输出流。
void | write_float_array(float[] seq, int offset, int length) 将 IDL float 数组中从 offset 处开始的 length 个元素写入输出流。
void | write_float(float value) 将 IDL float 值写入输出流。
void | write_long_array(int[] seq, int offset, int length) 将 IDL long 数组中从 offset 处开始的 length 个元素写入输出流。
void | write_long(int value) 将 IDL long 值（以 Java int 的形式表示）写入输出流。
void | write_longlong_array(long[] seq, int offset, int length) 将 IDL long long 数组中从 offset 处开始的 length 个元素写入输出流。
void | write_longlong(long value) 将 IDL long long 值（以 Java long 的形式表示）写入输出流。
void | write_Object(Object value) 将 IDL CORBA::Object 值写入输出流。
void | write_octet_array(byte[] seq, int offset, int length) 将 IDL octet 数组中从 offset 处开始的 length 个元素写入输出流。
void | write_octet(byte value) 将 IDL octet 值（以一个 Java 字节的形式表示）写入输出流。
void | write_short_array(short[] seq, int offset, int length) 将 IDL short 数组中从 offset 处开始的 length 个元素写入输出流。
void | write_short(short value) 将 IDL short 值写入输出流。
void | write_string(String value) 将 IDL string 值写入输出流。
void | write_TypeCode(TypeCode value) 将 typecode 写入输出流。
void | write_ulong_array(int[] seq, int offset, int length) 将无符号 IDL long 数组中从 offset 处开始的 length 个元素（以 Java int 的形式表示）写入输出流。
void | write_ulong(int value) 将无符号 IDL long 值（以 Java int 的形式表示）写入输出流。
void | write_ulonglong_array(long[] seq, int offset, int length) 将无符号 IDL long long 数组中从 offset 处开始的 length 个元素（以 Java long 的形式表示）写入输出流。
void | write_ulonglong(long value) 将无符号 IDL long long 值（以 Java long 的形式表示）写入输出流。
void | write_ushort_array(short[] seq, int offset, int length) 将无符号 IDL short 数组中从 offset 处开始的 length 个元素（以 Java short 的形式表示）写入输出流。
void | write_ushort(short value) 将无符号 IDL short 值（以 Java short 值的形式表示）写入输出流。
void | write_Value(Serializable value) 将 IDL value 类型值写入输出流。
void | write_wchar_array(char[] seq, int offset, int length) 将 IDL 宽字符数组中从 offset 处开始的 length 个元素写入输出流。
void | write_wchar(char value) 将 IDL 宽字符值写入输出流。
void | write_wstring(String value) 将 IDL 宽字符串值（以 Java String 的形式表示）写入输出流。
从接口 org.omg.CORBA.portable.ValueBase 继承的方法
_truncatable_ids

方法详细信息

write_any

void write_any(Any value)
将 Any 值写入输出流。

参数：
value - 要写入的值。

write_boolean

void write_boolean(boolean value)
将 boolean 值写入输出流。

参数：
value - 要写入的值。

write_char

void write_char(char value)
将 IDL 字符值写入输出流。

参数：
value - 要写入的值。

write_wchar

void write_wchar(char value)
将 IDL 宽字符值写入输出流。

参数：
value - 要写入的值。

write_octet

void write_octet(byte value)
将 IDL octet 值（以一个 Java 字节的形式表示）写入输出流。

参数：
value - 要写入的值。

write_short

void write_short(short value)
将 IDL short 值写入输出流。

参数：
value - 要写入的值。

write_ushort

void write_ushort(short value)
将无符号 IDL short 值（以 Java short 值的形式表示）写入输出流。

参数：
value - 要写入的值。

write_long

void write_long(int value)
将 IDL long 值（以 Java int 的形式表示）写入输出流。

参数：
value - 要写入的值。

write_ulong

void write_ulong(int value)
将无符号 IDL long 值（以 Java int 的形式表示）写入输出流。

参数：
value - 要写入的值。

write_longlong

void write_longlong(long value)
将 IDL long long 值（以 Java long 的形式表示）写入输出流。

参数：
value - 要写入的值。

write_ulonglong

void write_ulonglong(long value)
将无符号 IDL long long 值（以 Java long 的形式表示）写入输出流。

参数：
value - 要写入的值。

write_float

void write_float(float value)
将 IDL float 值写入输出流。

参数：
value - 要写入的值。

write_double

void write_double(double value)
将 IDL double 值写入输出流。

参数：
value - 要写入的值。

write_string

void write_string(String value)
将 IDL string 值写入输出流。

参数：
value - 要写入的值。

write_wstring

void write_wstring(String value)
将 IDL 宽字符串值（以 Java String 的形式表示）写入输出流。

参数：
value - 要写入的值。

write_Object

void write_Object(Object value)
将 IDL CORBA::Object 值写入输出流。

参数：
value - 要写入的值。

write_Abstract

void write_Abstract(Object value)
将 IDL Abstract 接口类型写入输出流。

参数：
value - 要写入的值。

write_Value

void write_Value(Serializable value)
将 IDL value 类型值写入输出流。

参数：
value - 要写入的值。

write_TypeCode

void write_TypeCode(TypeCode value)
将 typecode 写入输出流。

参数：
value - 要写入的值。

write_any_array

void write_any_array(Any[] seq,
                     int offset,
                     int length)
将 IDL Any 数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_boolean_array

void write_boolean_array(boolean[] seq,
                         int offset,
                         int length)
将 IDL boolean 数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_char_array

void write_char_array(char[] seq,
                      int offset,
                      int length)
将 IDL 字符数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_wchar_array

void write_wchar_array(char[] seq,
                       int offset,
                       int length)
将 IDL 宽字符数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_octet_array

void write_octet_array(byte[] seq,
                       int offset,
                       int length)
将 IDL octet 数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_short_array

void write_short_array(short[] seq,
                       int offset,
                       int length)
将 IDL short 数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_ushort_array

void write_ushort_array(short[] seq,
                        int offset,
                        int length)
将无符号 IDL short 数组中从 offset 处开始的 length 个元素（以 Java short 的形式表示）写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_long_array

void write_long_array(int[] seq,
                      int offset,
                      int length)
将 IDL long 数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_ulong_array

void write_ulong_array(int[] seq,
                       int offset,
                       int length)
将无符号 IDL long 数组中从 offset 处开始的 length 个元素（以 Java int 的形式表示）写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_ulonglong_array

void write_ulonglong_array(long[] seq,
                           int offset,
                           int length)
将无符号 IDL long long 数组中从 offset 处开始的 length 个元素（以 Java long 的形式表示）写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_longlong_array

void write_longlong_array(long[] seq,
                          int offset,
                          int length)
将 IDL long long 数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_float_array

void write_float_array(float[] seq,
                       int offset,
                       int length)
将 IDL float 数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。

write_double_array

void write_double_array(double[] seq,
                        int offset,
                        int length)
将 IDL double 数组中从 offset 处开始的 length 个元素写入输出流。

参数：
seq - 将元素写入其中的数组。
offset - 将写入输出流的第一个元素在 seq 中的索引。
length - 写入输出流的元素个数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefinitionKind (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 DefinitionKind

java.lang.Object
    继承者  org.omg.CORBA.DefinitionKind
所有已实现的接口：
Serializable, IDLEntity
public class DefinitionKind
extends Object
implements IDLEntity

该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。此类包含两种常量，一种是 int，另一种是 DefinitionKind 类的实例。此类提供 from_int 方法，只要给出一个 int 常量，该方法就能创建相应的 DefinitionKind 实例。此类还提供了 value 方法，该方法返回用作 DefinitionKind 实例的值的 int 常量。

另请参见：
IRObject

字段摘要
static int | _dk_AbstractInterface 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Alias 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_all 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Array 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Attribute 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Constant 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Enum 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Exception 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Fixed 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Interface 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Module 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Native 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_none 指示 Interface Repository 对象不具有定义种类的常量。
static int | _dk_Operation 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Primitive 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Repository 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Sequence 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_String 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Struct 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Typedef 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Union 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Value 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_ValueBox 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_ValueMember 指示 Interface Repository 对象不具有某一定义种类的常量。
static int | _dk_Wstring 指示 Interface Repository 对象不具有某一定义种类的常量。
static DefinitionKind | dk_AbstractInterface 指示 Interface Repository 对象表示一个抽象接口的静态 DefinitionKind 实例。
static DefinitionKind | dk_Alias 指示 Interface Repository 对象是一个 Alias 的静态 DefinitionKind 实例。
static DefinitionKind | dk_all 通配符 DefinitionKind 常量，可用于 DefinitionKind 适合的所有情况。
static DefinitionKind | dk_Array 指示 Interface Repository 对象是一个 Array 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Attribute 指示 Interface Repository 对象是一个 Attribute 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Constant 指示 Interface Repository 对象是一个常量的静态 DefinitionKind 实例。
static DefinitionKind | dk_Enum 指示 Interface Repository 对象是一个 Enum 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Exception 指示 Interface Repository 对象是一个 Exception 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Fixed 指示 Interface Repository 对象是一个 Fixed value 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Interface 指示 Interface Repository 对象是一个 Interface 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Module 指示 Interface Repository 对象是一个 Module 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Native 指示 Interface Repository 对象是一个 Native value 的静态 DefinitionKind 实例。
static DefinitionKind | dk_none 指示 Interface Repository 对象不具有任何定义种类的静态 DefinitionKind 实例。
static DefinitionKind | dk_Operation 指示 Interface Repository 对象是一个 Operation 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Primitive 指示 Interface Repository 对象是一个 Primitive 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Repository 指示 Interface Repository 对象是一个 Repository 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Sequence 指示 Interface Repository 对象是一个 Sequence 的静态 DefinitionKind 实例。
static DefinitionKind | dk_String 指示 Interface Repository 对象是一个 String 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Struct 指示 Interface Repository 对象是一个 Struct 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Typedef 指示 Interface Repository 对象是一个 Typedef 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Union 指示 Interface Repository 对象是一个 Union 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Value 指示 Interface Repository 对象是一个 Value 的静态 DefinitionKind 实例。
static DefinitionKind | dk_ValueBox 指示 Interface Repository 对象是一个 ValueBox 的静态 DefinitionKind 实例。
static DefinitionKind | dk_ValueMember 指示 Interface Repository 对象是一个 ValueMember 的静态 DefinitionKind 实例。
static DefinitionKind | dk_Wstring 指示 Interface Repository 对象是一个 Wstring 的静态 DefinitionKind 实例。
构造方法摘要
protected DefinitionKind(int _value)
构造一个 DefinitionKind 对象，使用给定值初始化其 _value 字段。
方法摘要
static DefinitionKind | from_int(int i) 创建一个对应于给定代码的 DefinitionKind 实例。
int | value() 返回标识 IR 对象类型的 int 常量。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_dk_none

public static final int _dk_none
指示 Interface Repository 对象不具有定义种类的常量。

另请参见：
常量字段值

_dk_all

public static final int _dk_all
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Attribute

public static final int _dk_Attribute
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Constant

public static final int _dk_Constant
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Exception

public static final int _dk_Exception
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Interface

public static final int _dk_Interface
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Module

public static final int _dk_Module
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Operation

public static final int _dk_Operation
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Typedef

public static final int _dk_Typedef
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Alias

public static final int _dk_Alias
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Struct

public static final int _dk_Struct
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Union

public static final int _dk_Union
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Enum

public static final int _dk_Enum
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Primitive

public static final int _dk_Primitive
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_String

public static final int _dk_String
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Sequence

public static final int _dk_Sequence
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Array

public static final int _dk_Array
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Repository

public static final int _dk_Repository
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Wstring

public static final int _dk_Wstring
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Fixed

public static final int _dk_Fixed
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Value

public static final int _dk_Value
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_ValueBox

public static final int _dk_ValueBox
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_ValueMember

public static final int _dk_ValueMember
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_Native

public static final int _dk_Native
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

_dk_AbstractInterface

public static final int _dk_AbstractInterface
指示 Interface Repository 对象不具有某一定义种类的常量。

另请参见：
常量字段值

dk_none

public static final DefinitionKind dk_none
指示 Interface Repository 对象不具有任何定义种类的静态 DefinitionKind 实例。

dk_all

public static final DefinitionKind dk_all
通配符 DefinitionKind 常量，可用于 DefinitionKind 适合的所有情况。Container 的 contents 方法使用此常量返回所包含的任何种类的定义。

dk_Attribute

public static final DefinitionKind dk_Attribute
指示 Interface Repository 对象是一个 Attribute 的静态 DefinitionKind 实例。

dk_Constant

public static final DefinitionKind dk_Constant
指示 Interface Repository 对象是一个常量的静态 DefinitionKind 实例。

dk_Exception

public static final DefinitionKind dk_Exception
指示 Interface Repository 对象是一个 Exception 的静态 DefinitionKind 实例。

dk_Interface

public static final DefinitionKind dk_Interface
指示 Interface Repository 对象是一个 Interface 的静态 DefinitionKind 实例。

dk_Module

public static final DefinitionKind dk_Module
指示 Interface Repository 对象是一个 Module 的静态 DefinitionKind 实例。

dk_Operation

public static final DefinitionKind dk_Operation
指示 Interface Repository 对象是一个 Operation 的静态 DefinitionKind 实例。

dk_Typedef

public static final DefinitionKind dk_Typedef
指示 Interface Repository 对象是一个 Typedef 的静态 DefinitionKind 实例。

dk_Alias

public static final DefinitionKind dk_Alias
指示 Interface Repository 对象是一个 Alias 的静态 DefinitionKind 实例。

dk_Struct

public static final DefinitionKind dk_Struct
指示 Interface Repository 对象是一个 Struct 的静态 DefinitionKind 实例。

dk_Union

public static final DefinitionKind dk_Union
指示 Interface Repository 对象是一个 Union 的静态 DefinitionKind 实例。

dk_Enum

public static final DefinitionKind dk_Enum
指示 Interface Repository 对象是一个 Enum 的静态 DefinitionKind 实例。

dk_Primitive

public static final DefinitionKind dk_Primitive
指示 Interface Repository 对象是一个 Primitive 的静态 DefinitionKind 实例。

dk_String

public static final DefinitionKind dk_String
指示 Interface Repository 对象是一个 String 的静态 DefinitionKind 实例。

dk_Sequence

public static final DefinitionKind dk_Sequence
指示 Interface Repository 对象是一个 Sequence 的静态 DefinitionKind 实例。

dk_Array

public static final DefinitionKind dk_Array
指示 Interface Repository 对象是一个 Array 的静态 DefinitionKind 实例。

dk_Repository

public static final DefinitionKind dk_Repository
指示 Interface Repository 对象是一个 Repository 的静态 DefinitionKind 实例。

dk_Wstring

public static final DefinitionKind dk_Wstring
指示 Interface Repository 对象是一个 Wstring 的静态 DefinitionKind 实例。

dk_Fixed

public static final DefinitionKind dk_Fixed
指示 Interface Repository 对象是一个 Fixed value 的静态 DefinitionKind 实例。

dk_Value

public static final DefinitionKind dk_Value
指示 Interface Repository 对象是一个 Value 的静态 DefinitionKind 实例。

dk_ValueBox

public static final DefinitionKind dk_ValueBox
指示 Interface Repository 对象是一个 ValueBox 的静态 DefinitionKind 实例。

dk_ValueMember

public static final DefinitionKind dk_ValueMember
指示 Interface Repository 对象是一个 ValueMember 的静态 DefinitionKind 实例。

dk_Native

public static final DefinitionKind dk_Native
指示 Interface Repository 对象是一个 Native value 的静态 DefinitionKind 实例。

dk_AbstractInterface

public static final DefinitionKind dk_AbstractInterface
指示 Interface Repository 对象表示一个抽象接口的静态 DefinitionKind 实例。

构造方法详细信息

DefinitionKind

protected DefinitionKind(int _value)
构造一个 DefinitionKind 对象，使用给定值初始化其 _value 字段。

参数：
_value - DefinitionKind 类中定义的 int 常量之一。
方法详细信息

value

public int value()
返回标识 IR 对象类型的 int 常量。

返回：
DefinitionKind 类中的 int 常量，该常量是此 DefinitionKind 实例的值

from_int

public static DefinitionKind from_int(int i)
创建一个对应于给定代码的 DefinitionKind 实例。

参数：
i - DefinitionKind 类中的 int 常量之一
返回：
对应于给定代码的 DefinitionKind 实例
抛出：
BAD_PARAM - 如果给定参数不是 DefinitionKind 类中的 int 常量之一
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefinitionKindHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 DefinitionKindHelper

java.lang.Object
    继承者  org.omg.CORBA.DefinitionKindHelper

public abstract class DefinitionKindHelper
extends Object

DefinitionKind 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/DefinitionKindHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:43 (GMT+00:00)

构造方法摘要
DefinitionKindHelper()
方法摘要
static DefinitionKind | extract(Any a)
static String | id()
static void | insert(Any a, DefinitionKind that)
static DefinitionKind | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, DefinitionKind value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefinitionKindHelper

public DefinitionKindHelper()
方法详细信息

insert

public static void insert(Any a,
                          DefinitionKind that)

extract

public static DefinitionKind extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DefinitionKind read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DefinitionKind value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DomainManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DomainManager

所有超级接口：
DomainManagerOperations, IDLEntity, Object, Serializable
public interface DomainManager
extends DomainManagerOperations, Object, IDLEntity

提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。DomainManager 已与特定域的策略对象相关联。域管理器还记录域的成员关系，提供添加和移除成员的方法。域管理器本身也是一个域成员，有可能就是它所管理的域的成员。域管理器提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。

方法摘要
从接口 org.omg.CORBA.DomainManagerOperations 继承的方法
get_domain_policy
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DomainManagerOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DomainManagerOperations

所有已知子接口：
DomainManager
public interface DomainManagerOperations

向 DomainManager 提供访问策略的方法。

DomainManager 已与特定域的策略对象相关联。域管理器还记录域的成员关系，提供添加和移除成员的方法。域管理器本身也是一个域成员，有可能就是它所管理的域的成员。域管理器提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。

方法摘要
 Policy get_domain_policy(int policy_type)
此方法为此域中的对象返回指定类型的策略。

方法详细信息

get_domain_policy

Policy get_domain_policy(int policy_type)
此方法为此域中的对象返回指定类型的策略。可用的策略类型与域有关。有关标准 ORB 策略的列表，请参阅 CORBA 规范。

参数：
policy_type - 请求的策略类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DoubleHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 DoubleHolder

java.lang.Object
    继承者  org.omg.CORBA.DoubleHolder
所有已实现的接口：
Streamable
public final class DoubleHolder
extends Object
implements Streamable

Double 的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

用于 double 的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将一个 IDL double 作为 "out" 或 "inout" 参数，则程序员必须传递一个 DoubleHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myDoubleHolder 是 ByteHoDoubleHolderlder 实例，则可以使用 myDoubleHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 double value
此 DoubleHolder 对象保存的 double 值。
构造方法摘要
DoubleHolder()
构造一个新的 DoubleHolder 对象，将其 value 字段初始化为 0.0。
DoubleHolder(double initial)
为给定 double 值构造一个新的 DoubleHolder 对象。
方法摘要
void | _read(InputStream input) 从输入流读取一个 double 值，并将其存储在值成员中。
TypeCode | _type() 返回此 holder 对象的 TypeCode。
void | _write(OutputStream output) 将存储在此 holder 中的 double 值写入 OutputStream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public double value
此 DoubleHolder 对象保存的 double 值。

构造方法详细信息

DoubleHolder

public DoubleHolder()
构造一个新的 DoubleHolder 对象，将其 value 字段初始化为 0.0。

DoubleHolder

public DoubleHolder(double initial)
为给定 double 值构造一个新的 DoubleHolder 对象。

参数：
initial - 用来初始化新 DoubleHolder 对象 value 字段的 double 值
方法详细信息

_read

public void _read(InputStream input)
从输入流读取一个 double 值，并将其存储在值成员中。

指定者：
接口 Streamable 中的 _read
参数：
input - 将从中读取数据的 InputStream。

_write

public void _write(OutputStream output)
将存储在此 holder 中的 double 值写入 OutputStream。

指定者：
接口 Streamable 中的 _write
参数：
output - 将写入值的 OutputStream。

_type

public TypeCode _type()
返回此 holder 对象的 TypeCode。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DoubleSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 DoubleSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.DoubleSeqHelper

public abstract class DoubleSeqHelper
extends Object

DoubleSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/DoubleSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:37 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
DoubleSeqHelper()
方法摘要
static double[] | extract(Any a)
static String | id()
static void | insert(Any a, double[] that)
static double[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, double[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DoubleSeqHelper

public DoubleSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          double[] that)

extract

public static double[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static double[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         double[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DoubleSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 DoubleSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.DoubleSeqHolder
所有已实现的接口：
Streamable
public final class DoubleSeqHolder
extends Object
implements Streamable

DoubleSeq 的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/DoubleSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:37 (GMT+00:00)

字段摘要
 double[] value
构造方法摘要
DoubleSeqHolder()
DoubleSeqHolder(double[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public double[] value
构造方法详细信息

DoubleSeqHolder

public DoubleSeqHolder()

DoubleSeqHolder

public DoubleSeqHolder(double[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynamicImplementation (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 DynamicImplementation

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CORBA.DynamicImplementation
所有已实现的接口：
Object
直接已知子类：
_BindingIteratorImplBase, _NamingContextImplBase
已过时。 org.omg.CORBA.DynamicImplementation

@Deprecated
public class DynamicImplementation
extends ObjectImpl

构造方法摘要
DynamicImplementation()
已过时。
方法摘要
String[] | _ids() 已过时。 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
void | invoke(ServerRequest request) 已过时。 由 Portable Object Adapter 取代
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DynamicImplementation

public DynamicImplementation()
已过时。
方法详细信息

invoke

@Deprecated
public void invoke(ServerRequest request)
已过时。 由 Portable Object Adapter 取代

_ids

public String[] _ids()
已过时。
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynAny (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DynAny

所有超级接口：
Object
所有已知子接口：
DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue
已过时。 使用新的 DynAny 替代

@Deprecated
public interface DynAny
extends Object

支持动态解释（遍历）和构造 org.omg.CORBA.Any 值。DynAny 对象与一个数据值关联，该值对应于插入 Any 的值的副本。DynAny API 允许在运行时遍历与 Any 关联的数据值，并提取数据值的基本成分。

方法摘要
void | assign(DynAny dyn_any) 已过时。 将内容从一个 Dynamic Any 复制到另一个 Dynamic Any 中。
DynAny | copy() 已过时。 克隆此 DynAny 对象。
DynAny | current_component() 已过时。 返回一个 DynAny 对象引用，可用来获取/设置当前所访问组件的值。
void | destroy() 已过时。 销毁此 DynAny 对象，释放用来表示与之关联的数据值的所有资源。
void | from_any(Any value) 已过时。 根据 Any 对象生成一个 DynAny 对象。
Any | get_any() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Any。
boolean | get_boolean() 已过时。 检索此 DynAny 对象中包含的 boolean 值。
char | get_char() 已过时。 检索此 DynAny 对象中包含的 char 值。
double | get_double() 已过时。 检索此 DynAny 对象中包含的 double 值。
float | get_float() 已过时。 检索此 DynAny 对象中包含的 float 值。
int | get_long() 已过时。 检索此 DynAny 对象中包含的 int 值。
long | get_longlong() 已过时。 检索此 DynAny 对象中包含的 long 值。
byte | get_octet() 已过时。 检索此 DynAny 对象中包含的 byte 值。
Object | get_reference() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Other。
short | get_short() 已过时。 检索此 DynAny 对象中包含的 short 值。
String | get_string() 已过时。 检索此 DynAny 对象中包含的 String。
TypeCode | get_typecode() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.TypeCode。
int | get_ulong() 已过时。 检索此 DynAny 对象中包含的 int 值。
long | get_ulonglong() 已过时。 检索此 DynAny 对象中包含的 long 值。
short | get_ushort() 已过时。 检索此 DynAny 对象中包含的 short 值。
Serializable | get_val() 已过时。 检索此 DynAny 对象中包含的 java.io.Serializable 对象。
char | get_wchar() 已过时。 检索此 DynAny 对象中包含的 char 值。
String | get_wstring() 已过时。 检索此 DynAny 对象中包含的 String。
void | insert_any(Any value) 已过时。 插入给定 org.omg.CORBA.Any 对象作为此 DynAny 对象的值。
void | insert_boolean(boolean value) 已过时。 插入给定 boolean 值作为此 DynAny 对象的值。
void | insert_char(char value) 已过时。 插入给定 char 值作为此 DynAny 对象的值。
void | insert_double(double value) 已过时。 插入给定 double 值作为此 DynAny 对象的值。
void | insert_float(float value) 已过时。 插入给定 float 值作为此 DynAny 对象的值。
void | insert_long(int value) 已过时。 插入给定 int 值作为此 DynAny 对象的值。
void | insert_longlong(long value) 已过时。 插入给定 long 值作为此 DynAny 对象的值。
void | insert_octet(byte value) 已过时。 插入给定 byte 值作为此 DynAny 对象的值。
void | insert_reference(Object value) 已过时。 插入给定 org.omg.CORBA.Object 作为此 DynAny 对象的值。
void | insert_short(short value) 已过时。 插入给定 short 值作为此 DynAny 对象的值。
void | insert_string(String value) 已过时。 插入给定 String 对象作为此 DynAny 对象的值。
void | insert_typecode(TypeCode value) 已过时。 插入给定 org.omg.CORBA.TypeCode 值作为此 DynAny 对象的值。
void | insert_ulong(int value) 已过时。 插入给定 int 值作为此 DynAny 对象的值。
void | insert_ulonglong(long value) 已过时。 插入给定 long 值作为此 DynAny 对象的值。
void | insert_ushort(short value) 已过时。 插入给定 short 值作为此 DynAny 对象的值。
void | insert_val(Serializable value) 已过时。 插入给定 java.io.Serializable 对象作为此 DynAny 对象的值。
void | insert_wchar(char value) 已过时。 插入给定 char 值作为此 DynAny 对象的值。
void | insert_wstring(String value) 已过时。 插入给定 String 作为此 DynAny 对象的值。
boolean | next() 已过时。 移动到此 DynAny 对象的下一个组件。
void | rewind() 已过时。 将内部指针移动到第一个组件。
boolean | seek(int index) 已过时。 将内部指针移动到给定索引。
Any | to_any() 已过时。 将 DynAny 对象转换成 Any 对象。
TypeCode | type() 已过时。 返回插入此 DynAny 对象的 TypeCode。
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

方法详细信息

type

TypeCode type()
已过时。
返回插入此 DynAny 对象的 TypeCode。

返回：
TypeCode 对象。

assign

void assign(DynAny dyn_any)
            throws Invalid
已过时。
将内容从一个 Dynamic Any 复制到另一个 Dynamic Any 中。

参数：
dyn_any - 内容被分配给此 DynAny 的 DynAny 对象。
抛出：
Invalid - 如果源 DynAny 无效

from_any

void from_any(Any value)
              throws Invalid
已过时。
根据 Any 对象生成一个 DynAny 对象。

参数：
value - Any 对象。
抛出：
Invalid - 如果源 Any 对象为空或损坏

to_any

Any to_any()
           throws Invalid
已过时。
将 DynAny 对象转换成 Any 对象。

返回：
Any 对象。
抛出：
Invalid - 如果此 DynAny 为空或损坏，或者创建的 DynAny 对象不包含任何有意义的值

destroy

void destroy()
已过时。
销毁此 DynAny 对象，释放用来表示与之关联的数据值的所有资源。此方法还销毁从对象获取的所有 DynAny 对象。

销毁 DynAny 对象应小心处理，需要考虑如何处理与 DynAny 对象关联的数据值的表示形式。如果程序员要销毁 DynAny 对象，但还需要操作与其关联的数据值的某个组件，则应该首先为该组件创建一个 DynAny 对象，然后生成所创建的 DynAny 对象的副本。

copy

DynAny copy()
已过时。
克隆此 DynAny 对象。

返回：
此 DynAny 对象的副本

insert_boolean

void insert_boolean(boolean value)
                    throws InvalidValue
已过时。
插入给定 boolean 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 boolean 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_octet

void insert_octet(byte value)
                  throws InvalidValue
已过时。
插入给定 byte 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 byte 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_char

void insert_char(char value)
                 throws InvalidValue
已过时。
插入给定 char 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 char 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_short

void insert_short(short value)
                  throws InvalidValue
已过时。
插入给定 short 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 short 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_ushort

void insert_ushort(short value)
                   throws InvalidValue
已过时。
插入给定 short 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 short 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_long

void insert_long(int value)
                 throws InvalidValue
已过时。
插入给定 int 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 int 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_ulong

void insert_ulong(int value)
                  throws InvalidValue
已过时。
插入给定 int 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 int 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_float

void insert_float(float value)
                  throws InvalidValue
已过时。
插入给定 float 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 float 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_double

void insert_double(double value)
                   throws InvalidValue
已过时。
插入给定 double 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 double 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_string

void insert_string(String value)
                   throws InvalidValue
已过时。
插入给定 String 对象作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 String 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_reference

void insert_reference(Object value)
                      throws InvalidValue
已过时。
插入给定 org.omg.CORBA.Object 作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 org.omg.CORBA.Object 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_typecode

void insert_typecode(TypeCode value)
                     throws InvalidValue
已过时。
插入给定 org.omg.CORBA.TypeCode 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 org.omg.CORBA.TypeCode 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_longlong

void insert_longlong(long value)
                     throws InvalidValue
已过时。
插入给定 long 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 long 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_ulonglong

void insert_ulonglong(long value)
                      throws InvalidValue
已过时。
插入给定 long 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 long 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_wchar

void insert_wchar(char value)
                  throws InvalidValue
已过时。
插入给定 char 值作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 char 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_wstring

void insert_wstring(String value)
                    throws InvalidValue
已过时。
插入给定 String 作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象的 String 值
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_any

void insert_any(Any value)
                throws InvalidValue
已过时。
插入给定 org.omg.CORBA.Any 对象作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象中的 org.omg.CORBA.Any 对象
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

insert_val

void insert_val(Serializable value)
                throws InvalidValue
已过时。
插入给定 java.io.Serializable 对象作为此 DynAny 对象的值。

如果对已构造 DynAny 对象调用此方法，则该方法将初始化与此 DynAny 对象关联的已构造数据值的下一个组件。

参数：
value - 插入此 DynAny 对象中的 java.io.Serializable 对象
抛出：
InvalidValue - 如果插入值与此 DynAny 对象中被访问组件的类型不一致

get_val

Serializable get_val()
                     throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 java.io.Serializable 对象。

返回：
作为此 DynAny 对象的值的 java.io.Serializable 对象
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与 java.io.Serializable 对象的类型代码不同

get_boolean

boolean get_boolean()
                    throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 boolean 值。

返回：
作为此 DynAny 对象的值的 boolean 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 boolean 值的类型代码不同

get_octet

byte get_octet()
               throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 byte 值。

返回：
作为此 DynAny 对象的值的 byte 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 byte 值的类型代码不同

get_char

char get_char()
              throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 char 值。

返回：
作为此 DynAny 对象的值的 char 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 char 值的类型代码不同

get_short

short get_short()
                throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 short 值。

返回：
作为此 DynAny 对象的值的 short 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 short 值的类型代码不同

get_ushort

short get_ushort()
                 throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 short 值。

返回：
作为此 DynAny 对象的值的 short 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 short 值的类型代码不同

get_long

int get_long()
             throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 int 值。

返回：
作为此 DynAny 对象的值的 int 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 int 值的类型代码不同

get_ulong

int get_ulong()
              throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 int 值。

返回：
作为此 DynAny 对象的值的 int 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 int 值的类型代码不同

get_float

float get_float()
                throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 float 值。

返回：
作为此 DynAny 对象的值的 float 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 float 值的类型代码不同

get_double

double get_double()
                  throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 double 值。

返回：
作为此 DynAny 对象的值的 double 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 double 值的类型代码不同

get_string

String get_string()
                  throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 String。

返回：
作为此 DynAny 对象的值的 String
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 String 的类型代码不同

get_reference

Object get_reference()
                     throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 org.omg.CORBA.Other。

返回：
作为此 DynAny 对象的值的 org.omg.CORBA.Other
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 org.omg.CORBA.Other 的类型代码不同

get_typecode

TypeCode get_typecode()
                      throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 org.omg.CORBA.TypeCode。

返回：
作为此 DynAny 对象的值的 org.omg.CORBA.TypeCode
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 org.omg.CORBA.TypeCode 的类型代码不同

get_longlong

long get_longlong()
                  throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 long 值。

返回：
作为此 DynAny 对象的值的 long 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 long 值的类型代码不同

get_ulonglong

long get_ulonglong()
                   throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 long 值。

返回：
作为此 DynAny 对象的值的 long 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 long 值的类型代码不同

get_wchar

char get_wchar()
               throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 char 值。

返回：
作为此 DynAny 对象的值的 char 值
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 char 值的类型代码不同

get_wstring

String get_wstring()
                   throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 String。

返回：
作为此 DynAny 对象的值的 String
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 String 的类型代码不同

get_any

Any get_any()
            throws TypeMismatch
已过时。
检索此 DynAny 对象中包含的 org.omg.CORBA.Any。

返回：
作为此 DynAny 对象的值的 org.omg.CORBA.Any
抛出：
TypeMismatch - 如果此 DynAny 对象中被访问组件的类型代码与该 org.omg.CORBA.Any 的类型代码不同

current_component

DynAny current_component()
已过时。
返回一个 DynAny 对象引用，可用来获取/设置当前所访问组件的值。可在得到的 DynAny 对象上调用适当的 insert 方法来初始化该组件。可在得到的 DynAny 对象上调用适当的 get 方法来提取该组件的值。

返回：
DynAny 对象引用，可用来检索或设置当前所访问组件的值

next

boolean next()
已过时。
移动到此 DynAny 对象的下一个组件。此方法用于在所构造类型的组件上进行迭代，有效地将指针从一个组件移动到下一个组件。在创建 DynAny 对象时，指针从第一个组件开始移动。

返回：
如果指针指向某一组件，则返回 true；如果不再有组件或者此 DynAny 与基本类型相关而不是与所构造类型相关，则返回 false

seek

boolean seek(int index)
已过时。
将内部指针移动到给定索引。从逻辑上说，此方法为该指针设置了一个新偏移量。

参数：
index - 指示作为指针移动目标位置的 int 值。第一个位置为 0。
返回：
如果指针指向某一组件，则返回 true；如果在指定索引处没有组件，则返回 false。如果此 DynAny 对象与基本类型关联，则此方法对 0 以外的任何索引都返回 false。

rewind

void rewind()
已过时。
将内部指针移动到第一个组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NVList (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NVList

java.lang.Object
    继承者  org.omg.CORBA.NVList

public abstract class NVList
extends Object

包含 NamedValue 对象所组成的可修改列表。

NVList 类的用途如下：

  • 描述动态调用接口 (Dynamic Invocation Interface) 和动态框架接口 (Dynamic Skeleton Interface) 中 Request 对象的参数
  • 描述 Context 对象中的上下文值

每个 NamedValue 对象都由以下部分组成：

  • 一个名称，该名称是一个 String 对象
  • 一个值，该值是一个 Any 对象
  • 一个参数模式标志

可以使用以下 ORB 方法之一创建 NVList 对象：

  1. org.omg.CORBA.ORB.create_list
        org.omg.CORBA.NVList nv = orb.create_list(3);
    变量 nv 表示一个新创建的 NVList 对象。该参数是 orb 的内存管理提示，并不意味着实际的列表长度。例如，如果要在某一请求中使用 NVList 对象，则将被调用的方法将采用三个参数，您可以通过向 create_list 方法提供 3 来优化此操作。注意，新的 NVList 没必要将长度设置为 3；例如，它可以将长度设置为 2 或 4。还要注意的是，您可以将任意数量的 NamedValue 对象添加到此列表中，不管其原始长度如何。

  2. org.omg.CORBA.ORB.create_operation_list
        org.omg.CORBA.NVList nv = orb.create_operation_list(myOperationDef);
    变量 nv 表示新创建的 NVList 对象，该对象包含对给定 OperationDef 对象中所描述方法的参数的描述。

NVList 类中的方法都要处理列表中的 NamedValue 对象。有三个方法可用于添加 NamedValue 对象，一个方法用于获得列表中 NamedValue 对象的计数，另一个方法用于检索给定索引处的 NamedValue 对象，还有一个方法用于移除给定索引处的 NamedValue 对象。

从以下版本开始：
JDK1.2
另请参见：
Request, ServerRequest, NamedValue, Context

构造方法摘要
NVList()
方法摘要
abstract NamedValue | add_item(String item_name, int flags) 创建一个新的 NamedValue 对象，使用给定名称和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract NamedValue | add_value(String item_name, Any val, int flags) 创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract NamedValue | add(int flags) 创建一个新的 NamedValue 对象，使用给定标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract int | count() 返回已添加到此 NVList 对象的 NamedValue 对象数。
abstract NamedValue | item(int index) 检索给定索引处的 NamedValue 对象。
abstract void | remove(int index) 移除位于给定索引处的 NamedValue 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NVList

public NVList()
方法详细信息

count

public abstract int count()
返回已添加到此 NVList 对象的 NamedValue 对象数。

返回：
指示此 NVList 中 NamedValue 对象数的 int 值。

add

public abstract NamedValue add(int flags)
创建一个新的 NamedValue 对象，使用给定标志初始化该对象，并将它添加到此 NVList 对象的末尾。该标志可以是以下参数传递模式之一：ARG_IN.value、ARG_OUT.value 或 ARG_INOUT.value。

参数：
flags - 参数模式标志之一
返回：
新创建的 NamedValue 对象

add_item

public abstract NamedValue add_item(String item_name,
                                    int flags)
创建一个新的 NamedValue 对象，使用给定名称和标志初始化该对象，并将它添加到此 NVList 对象的末尾。该标志可以是以下参数传递模式之一：ARG_IN.value、ARG_OUT.value 或 ARG_INOUT.value。

参数：
item_name - 新 NamedValue 对象的名称
flags - 参数模式标志之一
返回：
新创建的 NamedValue 对象

add_value

public abstract NamedValue add_value(String item_name,
                                     Any val,
                                     int flags)
创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。

参数：
item_name - 新 NamedValue 对象的名称
val - 包含新 NamedValue 对象值的 Any 对象
flags - 以下参数传递模式之一：ARG_IN.value、ARG_OUT.value 或 ARG_INOUT.value
返回：
新创建的 NamedValue 对象

item

public abstract NamedValue item(int index)
                         throws Bounds
检索给定索引处的 NamedValue 对象。

参数：
index - 所需 NamedValue 对象的索引，该索引必须在 0 与列表长度减 1（包括两者）之间。第一个项位于索引 0 处。
返回：
位于给定索引处的 NamedValue 对象
抛出：
Bounds - 如果索引大于或等于此 NamedValue 对象的个数

remove

public abstract void remove(int index)
                     throws Bounds
移除位于给定索引处的 NamedValue 对象。注意，被移除对象之后的所有 NamedValue 对象的索引都将向下移动一位。

参数：
index - 要移除的 NamedValue 对象的索引，该索引必须在 0 与列表长度减 1（包括两者）之间。第一个项位于索引 0 处。
抛出：
Bounds - 如果索引大于或等于列表中 NamedValue 对象的个数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynArray (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DynArray

所有超级接口：
DynAny, Object
已过时。 使用新的 DynArray 替代

@Deprecated
public interface DynArray
extends Object, DynAny

表示与数组关联的 DynAny 对象。

方法摘要
Any[] | get_elements() 已过时。 返回此数组所有元素的值。
void | set_elements(Any[] value) 已过时。 将此 DynArray 对象的值设置为给定数组。
从接口 org.omg.CORBA.DynAny 继承的方法
assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

方法详细信息

get_elements

Any[] get_elements()
已过时。
返回此数组所有元素的值。

返回：
作为此 DynArray 对象值的 Any 对象所组成的数组
另请参见：
set_elements(org.omg.CORBA.Any[])

set_elements

void set_elements(Any[] value)
                  throws InvalidSeq
已过时。
将此 DynArray 对象的值设置为给定数组。

参数：
value - Any 对象数组
抛出：
InvalidSeq - 如果序列出错
另请参见：
get_elements()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynEnum (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DynEnum

所有超级接口：
DynAny, Object
已过时。 使用新的 DynEnum 替代

@Deprecated
public interface DynEnum
extends Object, DynAny

表示与 IDL enum 关联的 DynAny 对象。

方法摘要
String | value_as_string() 已过时。 以字符串形式返回此 DynEnum 中存储的 IDL enum 的值。
void | value_as_string(String arg) 已过时。 设置此 DynEnum 中的特定 enum。
int | value_as_ulong() 已过时。 以 Java int 值形式返回 IDL enum 的值。
void | value_as_ulong(int arg) 已过时。 设置 IDL enum 的值。
从接口 org.omg.CORBA.DynAny 继承的方法
assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

方法详细信息

value_as_string

String value_as_string()
已过时。
以字符串形式返回此 DynEnum 中存储的 IDL enum 的值。

返回：
字符串化的值。

value_as_string

void value_as_string(String arg)
已过时。
设置此 DynEnum 中的特定 enum。

参数：
arg - 对应于该值的字符串。

value_as_ulong

int value_as_ulong()
已过时。
以 Java int 值形式返回 IDL enum 的值。

返回：
整数值。

value_as_ulong

void value_as_ulong(int arg)
已过时。
设置 IDL enum 的值。

参数：
arg - 该枚举的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynFixed (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DynFixed

所有超级接口：
DynAny, Object
已过时。 使用新的 DynFixed 替代

@Deprecated
public interface DynFixed
extends Object, DynAny

表示与 IDL fixed 类型关联的 DynAny 对象。

方法摘要
byte[] | get_value() 已过时。 返回此 DynFixed 对象表示的 fixed 类型的值。
void | set_value(byte[] val) 已过时。 将给定 fixed 类型的实例设置为此 DynFixed 对象的值。
从接口 org.omg.CORBA.DynAny 继承的方法
assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

方法详细信息

get_value

byte[] get_value()
已过时。
返回此 DynFixed 对象表示的 fixed 类型的值。

返回：
字节数组形式的值
另请参见：
set_value(byte[])

set_value

void set_value(byte[] val)
               throws InvalidValue
已过时。
将给定 fixed 类型的实例设置为此 DynFixed 对象的值。

参数：
val - byte 数组形式的 fixed 类型值
抛出：
InvalidValue - 如果给定参数错误
另请参见：
get_value()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynSequence (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DynSequence

所有超级接口：
DynAny, Object
已过时。 使用新的 DynSequence 替代

@Deprecated
public interface DynSequence
extends Object, DynAny

与 IDL sequence 关联的 DynAny 对象的表示形式。

方法摘要
Any[] | get_elements() 已过时。 返回此 sequence 中每个元素的值。
int | length() 已过时。 返回此 DynFixed 对象表示的 sequence 长度。
void | length(int arg) 已过时。 将此 DynFixed 对象所表示的 sequence 长度设置为给定参数。
void | set_elements(Any[] value) 已过时。 使用给定数组设置此 sequence 中所有元素的值。
从接口 org.omg.CORBA.DynAny 继承的方法
assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

方法详细信息

length

int length()
已过时。
返回此 DynFixed 对象表示的 sequence 长度。

返回：
sequence 的长度

length

void length(int arg)
已过时。
将此 DynFixed 对象所表示的 sequence 长度设置为给定参数。

参数：
arg - sequence 的长度

get_elements

Any[] get_elements()
已过时。
返回此 sequence 中每个元素的值。

返回：
包含 sequence 中值的 Any 对象所组成的数组
另请参见：
set_elements(org.omg.CORBA.Any[])

set_elements

void set_elements(Any[] value)
                  throws InvalidSeq
已过时。
使用给定数组设置此 sequence 中所有元素的值。

参数：
value - 要设置的 Any 对象所组成的数组
抛出：
InvalidSeq - 如果这些值所组成的数组出错
另请参见：
get_elements()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynStruct (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DynStruct

所有超级接口：
DynAny, Object
已过时。 使用新的 DynStruct 替代

@Deprecated
public interface DynStruct
extends Object, DynAny

与 IDL struct 关联的 DynAny 对象的表示形式。

方法摘要
TCKind | current_member_kind() 已过时。 返回描述当前成员的种类的 TCKind 对象。
String | current_member_name() 已过时。 在遍历期间返回当前成员的名称。
NameValuePair[] | get_members() 已过时。 返回包含所有已存储 struct 成员的数组。
void | set_members(NameValuePair[] value) 已过时。 设置 struct 的成员。
从接口 org.omg.CORBA.DynAny 继承的方法
assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

方法详细信息

current_member_name

String current_member_name()
已过时。
在遍历期间返回当前成员的名称。

返回：
当前成员的字符串名称

current_member_kind

TCKind current_member_kind()
已过时。
返回描述当前成员的种类的 TCKind 对象。

返回：
描述当前成员的 TCKind 对象

get_members

NameValuePair[] get_members()
已过时。
返回包含所有已存储 struct 成员的数组。

返回：
名称-值对所组成的数组
另请参见：
set_members(org.omg.CORBA.NameValuePair[])

set_members

void set_members(NameValuePair[] value)
                 throws InvalidSeq
已过时。
设置 struct 的成员。

参数：
value - 名称-值对所组成的数组。
抛出：
InvalidSeq - 如果给定参数无效
另请参见：
get_members()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynUnion (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DynUnion

所有超级接口：
DynAny, Object
已过时。 使用新的 DynUnion 替代

@Deprecated
public interface DynUnion
extends Object, DynAny

DynUnion 接口表示与 IDL union 关联的 DynAny 对象。可以使用 DynAny 中定义的操作遍历 union 值。union 中的第一个元素对应于鉴别符 (discriminator)；第二个元素对应于 union 的实际值。调用 next() 方法两次可以访问这两个组件。

方法摘要
TCKind | discriminator_kind() 已过时。 返回与此 union 的鉴别符关联的 TCKind 对象。
DynAny | discriminator() 已过时。 返回一个 DynAny 对象引用，为了插入/获取鉴别符值，必须将该对象收缩为该鉴别符的类型。
TCKind | member_kind() 已过时。 返回与此 union 成员关联的 TCKind。
String | member_name() 已过时。 允许在没有检查鉴别符值的情况下检测此 union 成员的名称。
void | member_name(String arg) 已过时。 允许分配此 union 成员的名称。
DynAny | member() 已过时。 返回为了插入/获取此 union 成员而使用的 DynAny 对象引用。
boolean | set_as_default() 已过时。 确定与此 union 关联的鉴别符是否已经分配了一个有效默认值。
void | set_as_default(boolean arg) 已过时。 确定与此 union 关联的鉴别符是否被分配了一个有效默认值。
从接口 org.omg.CORBA.DynAny 继承的方法
assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

方法详细信息

set_as_default

boolean set_as_default()
已过时。
确定与此 union 关联的鉴别符是否已经分配了一个有效默认值。

返回：
如果鉴别符有一个默认值，则返回 true；否则返回 false。

set_as_default

void set_as_default(boolean arg)
已过时。
确定与此 union 关联的鉴别符是否被分配了一个有效默认值。

参数：
arg - 如果分配给该鉴别符一个默认值，则该参数为 true

discriminator

DynAny discriminator()
已过时。
返回一个 DynAny 对象引用，为了插入/获取鉴别符值，必须将该对象收缩为该鉴别符的类型。

返回：
表示鉴别符值的 DynAny 对象引用

discriminator_kind

TCKind discriminator_kind()
已过时。
返回与此 union 的鉴别符关联的 TCKind 对象。

返回：
与此 union 的鉴别符关联的 TCKind 对象。

member

DynAny member()
已过时。
返回为了插入/获取此 union 成员而使用的 DynAny 对象引用。

返回：
表示此 union 成员的 DynAny 对象。

member_name

String member_name()
已过时。
允许在没有检查鉴别符值的情况下检测此 union 成员的名称。

返回：
此 union 成员的名称

member_name

void member_name(String arg)
已过时。
允许分配此 union 成员的名称。

参数：
arg - 此 union 成员的新名称

member_kind

TCKind member_kind()
已过时。
返回与此 union 成员关联的 TCKind。

返回：
与此 union 成员关联的 TCKind 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 DynValue

所有超级接口：
DynAny, Object
已过时。 使用新的 DynValue 替代

@Deprecated
public interface DynValue
extends Object, DynAny

与 IDL value 类型关联的 DynAny 对象的表示形式。

方法摘要
TCKind | current_member_kind() 已过时。 返回描述当前成员的 TCKind 对象。
String | current_member_name() 已过时。 在遍历表示某个 Value 对象的 DynAny 对象时，返回当前成员的名称。
NameValuePair[] | get_members() 已过时。 返回一个数组，它包含存储在此 DynValue 中 value 对象的所有成员。
void | set_members(NameValuePair[] value) 已过时。 将此 DynValue 对象表示的 value 对象成员设置为给定的 NameValuePair 对象数组。
从接口 org.omg.CORBA.DynAny 继承的方法
assign, copy, current_component, destroy, from_any, get_any, get_boolean, get_char, get_double, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

方法详细信息

current_member_name

String current_member_name()
已过时。
在遍历表示某个 Value 对象的 DynAny 对象时，返回当前成员的名称。

返回：
当前成员的名称

current_member_kind

TCKind current_member_kind()
已过时。
返回描述当前成员的 TCKind 对象。

返回：
对应于当前成员的 TCKind 对象

get_members

NameValuePair[] get_members()
已过时。
返回一个数组，它包含存储在此 DynValue 中 value 对象的所有成员。

返回：
名称-值对所组成的数组。
另请参见：
set_members(org.omg.CORBA.NameValuePair[])

set_members

void set_members(NameValuePair[] value)
                 throws InvalidSeq
已过时。
将此 DynValue 对象表示的 value 对象成员设置为给定的 NameValuePair 对象数组。

参数：
value - 要设置的名称-值对所组成的数组
抛出：
InvalidSeq - 如果部分给定数组值不一致
另请参见：
get_members()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Environment (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 Environment

java.lang.Object
    继承者  org.omg.CORBA.Environment

public abstract class Environment
extends Object

用于 Request 操作的异常的容器 (holder)，使异常可用于客户端。Environment 对象是使用 ORB 的方法 create_environment 创建的。

从以下版本开始：
JDK1.2

构造方法摘要
Environment()
方法摘要
abstract void | clear() 清除此 Environment 对象中的异常。
abstract Exception | exception() 检索此 Environment 对象中的异常。
abstract void | exception(Exception except) 将给定异常插入此 Environment 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Environment

public Environment()
方法详细信息

exception

public abstract Exception exception()
检索此 Environment 对象中的异常。

返回：
此 Environment 对象中的异常

exception

public abstract void exception(Exception except)
将给定异常插入此 Environment 对象。

参数：
except - 要设置的异常

clear

public abstract void clear()
清除此 Environment 对象中的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExceptionList (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ExceptionList

java.lang.Object
    继承者  org.omg.CORBA.ExceptionList

public abstract class ExceptionList
extends Object

Request 操作中使用的对象，用于描述可由某一方法抛出的异常。它维护该异常的 TypeCode 所组成的可修改列表。

以下代码片段展示如何创建 ExceptionList 对象：

    ORB orb = ORB.init(args, null);
    org.omg.CORBA.ExceptionList excList = orb.create_exception_list();
变量 excList 表示不包含 TypeCode 对象的 ExceptionList 对象。

要添加列表项，首先要使用 ORB 方法 create_exception_tc 为要包含的异常创建一个 TypeCode 对象。然后使用 ExceptionList 方法 add 将该对象添加到列表中。ExceptionList 类具有用来获取列表中 TypeCode 对象个数的方法，它还有一些方法可在添加了列表项后访问或删除指定索引处的项。

从以下版本开始：
JDK1.2

构造方法摘要
ExceptionList()
方法摘要
abstract void | add(TypeCode exc) 将描述异常的 TypeCode 对象添加到此 ExceptionList 对象中。
abstract int | count() 检索此 ExceptionList 对象中 TypeCode 对象的个数。
abstract TypeCode | item(int index) 返回给定索引处的 TypeCode 对象。
abstract void | remove(int index) 移除给定索引处的 TypeCode 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExceptionList

public ExceptionList()
方法详细信息

count

public abstract int count()
检索此 ExceptionList 对象中 TypeCode 对象的个数。

返回：
此 ExceptionList 对象中 TypeCode 对象的个数

add

public abstract void add(TypeCode exc)
将描述异常的 TypeCode 对象添加到此 ExceptionList 对象中。

参数：
exc - 要添加的 TypeCode 对象

item

public abstract TypeCode item(int index)
                       throws Bounds
返回给定索引处的 TypeCode 对象。第一个项位于索引 0 处。

参数：
index - 所需的 TypeCode 对象的索引。此索引必须是 0 与 TypeCode 对象个数减 1（包括两者）之间的一个 int 值。
返回：
给定索引处的 TypeCode 对象
抛出：
Bounds - 如果给定索引大于等于此 ExceptionList 对象中 TypeCode 对象的个数

remove

public abstract void remove(int index)
                     throws Bounds
移除给定索引处的 TypeCode 对象。注意，所移除对象之后的所有 TypeCoded 对象的索引都将向下移动一位。

参数：
index - 要移除的 TypeCode 对象的索引。此索引必须是 0 与 TypeCode 对象个数减 1（包括两者）之间的一个 int 值。
抛出：
Bounds - 如果索引大于等于此 ExceptionList 对象中 TypeCode 对象的个数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldNameHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 FieldNameHelper

java.lang.Object
    继承者  org.omg.CORBA.FieldNameHelper

public abstract class FieldNameHelper
extends Object

FieldName 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/FieldNameHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）生成，生成时间为 1999 年 6 月 3 日 11:52:03 (GMT+00:00)

构造方法摘要
FieldNameHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FieldNameHelper

public FieldNameHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FixedHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 FixedHolder

java.lang.Object
    继承者  org.omg.CORBA.FixedHolder
所有已实现的接口：
Streamable
public final class FixedHolder
extends Object
implements Streamable

Fixed 的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

FixedHolder 是 IDL "fixed" 类型值的容器类，它被映射到 Java 类 java.math.BigDecimal。通常用于存储 "out" 和 "inout" IDL 方法参数。如果 IDL 方法签名将 fixed 作为 "out" 或 "inout" 参数，则程序员必须传递 FixedHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的包含值。

字段摘要
 BigDecimal value
FixedHolder 保存的值。
构造方法摘要
FixedHolder()
构造 FixedHolder，不初始化所包含的值。
FixedHolder(BigDecimal initial)
构造 FixedHolder，并使用给定值初始化。
方法摘要
void | _read(InputStream input) 从输入流读取定点值，并将其存储在值成员中。
TypeCode | _type() 返回此 holder 对象的 TypeCode。
void | _write(OutputStream output) 将存储在此 holder 中的定点值写入 OutputStream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public BigDecimal value
FixedHolder 保存的值。

构造方法详细信息

FixedHolder

public FixedHolder()
构造 FixedHolder，不初始化所包含的值。

FixedHolder

public FixedHolder(BigDecimal initial)
构造 FixedHolder，并使用给定值初始化。

参数：
initial - 用来初始化 FixedHolder 的值
方法详细信息

_read

public void _read(InputStream input)
从输入流读取定点值，并将其存储在值成员中。

指定者：
接口 Streamable 中的 _read
参数：
input - 将从中读取数据的 InputStream。

_write

public void _write(OutputStream output)
将存储在此 holder 中的定点值写入 OutputStream。

指定者：
接口 Streamable 中的 _write
参数：
output - 将写入值的 OutputStream。

_type

public TypeCode _type()
返回此 holder 对象的 TypeCode。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FloatHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 FloatHolder

java.lang.Object
    继承者  org.omg.CORBA.FloatHolder
所有已实现的接口：
Streamable
public final class FloatHolder
extends Object
implements Streamable

Float 的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

float 值的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将 IDL float 作为 "out" 或 "inout" 参数，则程序员必须传递 FloatHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myFloatHolder 是 FloatHolder 实例，则可以使用 myFloatHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 float value
此 FloatHolder 对象保存的 float 值。
构造方法摘要
FloatHolder()
构造一个新的 FloatHolder 对象，将其 value 字段初始化为 0.0。
FloatHolder(float initial)
为给定 float 值构造一个新 FloatHolder 对象。
方法摘要
void | _read(InputStream input) 从输入流读取一个 float 值，并使用该 float 值初始化值成员。
TypeCode | _type() 返回此 Streamable 的 TypeCode。
void | _write(OutputStream output) 将 float 值写入输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public float value
此 FloatHolder 对象保存的 float 值。

构造方法详细信息

FloatHolder

public FloatHolder()
构造一个新的 FloatHolder 对象，将其 value 字段初始化为 0.0。

FloatHolder

public FloatHolder(float initial)
为给定 float 值构造一个新 FloatHolder 对象。

参数：
initial - 用来初始化新 FloatHolder 对象 value 字段的 float 值
方法详细信息

_read

public void _read(InputStream input)
从输入流读取一个 float 值，并使用该 float 值初始化值成员。

指定者：
接口 Streamable 中的 _read
参数：
input - 将从中读取数据的 InputStream。

_write

public void _write(OutputStream output)
将 float 值写入输出流。

指定者：
接口 Streamable 中的 _write
参数：
output - 将写入值的 OutputStream。

_type

public TypeCode _type()
返回此 Streamable 的 TypeCode。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FloatSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 FloatSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.FloatSeqHelper

public abstract class FloatSeqHelper
extends Object

FloatSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/FloatSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:37 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
FloatSeqHelper()
方法摘要
static float[] | extract(Any a)
static String | id()
static void | insert(Any a, float[] that)
static float[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, float[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FloatSeqHelper

public FloatSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          float[] that)

extract

public static float[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static float[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         float[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FloatSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 FloatSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.FloatSeqHolder
所有已实现的接口：
Streamable
public final class FloatSeqHolder
extends Object
implements Streamable

FloatSeq 的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/FloatSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:37 (GMT+00:00)

字段摘要
 float[] value
构造方法摘要
FloatSeqHolder()
FloatSeqHolder(float[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public float[] value
构造方法详细信息

FloatSeqHolder

public FloatSeqHolder()

FloatSeqHolder

public FloatSeqHolder(float[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FREE_MEM (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 FREE_MEM

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.FREE_MEM
所有已实现的接口：
Serializable
public final class FREE_MEM
extends SystemException

当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
FREE_MEM()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。
FREE_MEM(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 FREE_MEM 异常。
FREE_MEM(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。
FREE_MEM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 FREE_MEM 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FREE_MEM

public FREE_MEM()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。

FREE_MEM

public FREE_MEM(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。

参数：
s - 包含详细消息的 String

FREE_MEM

public FREE_MEM(int minor,
                CompletionStatus completed)
使用指定次要代码和完成状态构造一个 FREE_MEM 异常。

参数：
minor - 次要代码
completed - 完成状态

FREE_MEM

public FREE_MEM(String s,
                int minor,
                CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 FREE_MEM 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdentifierHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 IdentifierHelper

java.lang.Object
    继承者  org.omg.CORBA.IdentifierHelper

public abstract class IdentifierHelper
extends Object

Identifier 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/IdentifierHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:42 (GMT+00:00)

构造方法摘要
IdentifierHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IdentifierHelper

public IdentifierHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDLType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 IDLType

所有超级接口：
IDLEntity, IDLTypeOperations, IRObject, IRObjectOperations, Object, Serializable
所有已知实现类：
_IDLTypeStub
public interface IDLType
extends IDLTypeOperations, IRObject, IDLEntity

由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。它提供对描述该类型的 TypeCode 对象的访问，并在必须引用 IDLType 定义时用于定义其他接口。

方法摘要
从接口 org.omg.CORBA.IDLTypeOperations 继承的方法
type
从接口 org.omg.CORBA.IRObjectOperations 继承的方法
def_kind, destroy
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDLTypeHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 IDLTypeHelper

java.lang.Object
    继承者  org.omg.CORBA.IDLTypeHelper

public abstract class IDLTypeHelper
extends Object

IDLType 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/IDLTypeHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:44 (GMT+00:00)

构造方法摘要
IDLTypeHelper()
方法摘要
static IDLType | extract(Any a)
static String | id()
static void | insert(Any a, IDLType that)
static IDLType | narrow(Object obj)
static IDLType | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, IDLType value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IDLTypeHelper

public IDLTypeHelper()
方法详细信息

insert

public static void insert(Any a,
                          IDLType that)

extract

public static IDLType extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static IDLType read(InputStream istream)

write

public static void write(OutputStream ostream,
                         IDLType value)

narrow

public static IDLType narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDLTypeOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 IDLTypeOperations

所有超级接口：
IRObjectOperations
所有已知子接口：
IDLType
所有已知实现类：
_IDLTypeStub
public interface IDLTypeOperations
extends IRObjectOperations

此接口必须由所有 IDLType 对象实现。IDLType 由所有表示 IDL 类型（包括 interface、typedef 和 anonymous 类型）的 IR 对象继承。

另请参见：
IDLType, IRObject, IRObjectOperations

方法摘要
 TypeCode type()
type 属性描述源自 IDLType 的对象定义的类型。
从接口 org.omg.CORBA.IRObjectOperations 继承的方法
def_kind, destroy

方法详细信息

type

TypeCode type()
type 属性描述源自 IDLType 的对象定义的类型。

返回：
此对象定义的 TypeCode。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMP_LIMIT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 IMP_LIMIT

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.IMP_LIMIT
所有已实现的接口：
Serializable
public final class IMP_LIMIT
extends SystemException

此异常指示在 OBR 运行时超过了某一项实现限制。例如，ORB 可能达到它可在地址空间同时保存的最大引用数、参数的大小可能已超出所允许的最大大小，或者 ORB 可能强制实行可同时运行的最大客户端数或服务器数。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
IMP_LIMIT()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。
IMP_LIMIT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 IMP_LIMIT 异常。
IMP_LIMIT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。
IMP_LIMIT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 IMP_LIMIT 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IMP_LIMIT

public IMP_LIMIT()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。

IMP_LIMIT

public IMP_LIMIT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。

参数：
s - 包含详细消息的 String

IMP_LIMIT

public IMP_LIMIT(int minor,
                 CompletionStatus completed)
使用指定次要代码和完成状态构造一个 IMP_LIMIT 异常。

参数：
minor - 次要代码
completed - 完成状态

IMP_LIMIT

public IMP_LIMIT(String s,
                 int minor,
                 CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 IMP_LIMIT 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INITIALIZE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INITIALIZE

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INITIALIZE
所有已实现的接口：
Serializable
public final class INITIALIZE
extends SystemException

ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INITIALIZE()
使用默认次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。
INITIALIZE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INITIALIZE 异常。
INITIALIZE(String s)
使用指定详细消息、次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。
INITIALIZE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INITIALIZE 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INITIALIZE

public INITIALIZE()
使用默认次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。

INITIALIZE

public INITIALIZE(String s)
使用指定详细消息、次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。

参数：
s - 包含详细消息的 String

INITIALIZE

public INITIALIZE(int minor,
                  CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INITIALIZE 异常。

参数：
minor - 次要代码
completed - CompletionStatus 实例，指示抛出此异常的方法的完成状态

INITIALIZE

public INITIALIZE(String s,
                  int minor,
                  CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INITIALIZE 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - CompletionStatus 实例，指示抛出此异常的方法的完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INTERNAL (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INTERNAL

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INTERNAL
所有已实现的接口：
Serializable
public final class INTERNAL
extends SystemException

此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INTERNAL()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。
INTERNAL(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INTERNAL 异常。
INTERNAL(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。
INTERNAL(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTERNAL 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INTERNAL

public INTERNAL()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。

INTERNAL

public INTERNAL(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。

参数：
s - 包含详细消息的 String

INTERNAL

public INTERNAL(int minor,
                CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INTERNAL 异常。

参数：
minor - 次要代码
completed - CompletionStatus 实例，指示抛出此异常的方法的完成状态

INTERNAL

public INTERNAL(String s,
                int minor,
                CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTERNAL 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - CompletionStatus 实例，指示抛出此异常的方法的完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INTF_REPOS (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INTF_REPOS

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INTF_REPOS
所有已实现的接口：
Serializable
public final class INTF_REPOS
extends SystemException

当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INTF_REPOS()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTF_REPOS 异常。
INTF_REPOS(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INTF_REPOS 异常。
INTF_REPOS(String s)
使用指定详细消息构造一个 INTF_REPOS 异常。
INTF_REPOS(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTF_REPOS 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INTF_REPOS

public INTF_REPOS()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTF_REPOS 异常。

INTF_REPOS

public INTF_REPOS(String s)
使用指定详细消息构造一个 INTF_REPOS 异常。

参数：
s - 包含详细消息的 String

INTF_REPOS

public INTF_REPOS(int minor,
                  CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INTF_REPOS 异常。

参数：
minor - 次要代码
completed - 完成状态

INTF_REPOS

public INTF_REPOS(String s,
                  int minor,
                  CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTF_REPOS 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IntHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 IntHolder

java.lang.Object
    继承者  org.omg.CORBA.IntHolder
所有已实现的接口：
Streamable
public final class IntHolder
extends Object
implements Streamable

Int 的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

int 值的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将 IDL long 作为 "out" 或 "inout" 参数，则程序员必须传递 IntHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myIntHolder 是 IntHolder 实例，则可以使用 myIntHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 int value
此 IntHolder 对象在其 value 字段中保存的 int 值。
构造方法摘要
IntHolder()
构造一个新的 IntHolder 对象，将其 value 字段初始化为 0。
IntHolder(int initial)
构造一个新的 IntHolder 对象，并使用给定 int 初始化其 value 字段。
方法摘要
void | _read(InputStream input) 从 input 中读取已解组数据，并将其分配给此 IntHolder 对象的 value 字段。
TypeCode | _type() 检索对应于此 IntHolder 对象 value 字段的 TypeCode 对象。
void | _write(OutputStream output) 将此 IntHolder 对象 value 字段中的值编组到输出流 output 中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public int value
此 IntHolder 对象在其 value 字段中保存的 int 值。

构造方法详细信息

IntHolder

public IntHolder()
构造一个新的 IntHolder 对象，将其 value 字段初始化为 0。

IntHolder

public IntHolder(int initial)
构造一个新的 IntHolder 对象，并使用给定 int 初始化其 value 字段。

参数：
initial - 用来初始化新建 IntHolder 对象 value 字段的 int 值
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取已解组数据，并将其分配给此 IntHolder 对象的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream 对象。

_write

public void _write(OutputStream output)
将此 IntHolder 对象 value 字段中的值编组到输出流 output 中。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream 对象

_type

public TypeCode _type()
检索对应于此 IntHolder 对象 value 字段的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
此 IntHolder 对象中保存的值的类型代码。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INV_FLAG (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INV_FLAG

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INV_FLAG
所有已实现的接口：
Serializable
public final class INV_FLAG
extends SystemException

在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INV_FLAG()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。
INV_FLAG(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_FLAG 异常。
INV_FLAG(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。
INV_FLAG(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_FLAG 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INV_FLAG

public INV_FLAG()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。

INV_FLAG

public INV_FLAG(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。

参数：
s - 包含详细消息的 String

INV_FLAG

public INV_FLAG(int minor,
                CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_FLAG 异常。

参数：
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例

INV_FLAG

public INV_FLAG(String s,
                int minor,
                CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_FLAG 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INV_IDENT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INV_IDENT

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INV_IDENT
所有已实现的接口：
Serializable
public final class INV_IDENT
extends SystemException

此异常指示 IDL 标识符在语法上是无效的。例如，如果传递给接口存储库的标识符与 IDL 标识符语法不一致，或者与 DII 一起使用的操作名称不合法，则引发此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INV_IDENT()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。
INV_IDENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_IDENT 异常。
INV_IDENT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。
INV_IDENT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_IDENT 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INV_IDENT

public INV_IDENT()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。

INV_IDENT

public INV_IDENT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。

参数：
s - 包含详细消息的 String

INV_IDENT

public INV_IDENT(int minor,
                 CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_IDENT 异常。

参数：
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 对象

INV_IDENT

public INV_IDENT(String s,
                 int minor,
                 CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_IDENT 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INV_OBJREF (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INV_OBJREF

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INV_OBJREF
所有已实现的接口：
Serializable
public final class INV_OBJREF
extends SystemException

此异常指示对象引用存在内部错误。例如，存储库 ID 的语法可能不正确或者地址信息可能无效。如果没有正确解码传递的字符串，则 ORB::string_to_object 引发此异常。ORB 可以选择通过 nil 引用检测调用（但不强制检测它们）。INV_OBJREF 用于指明这一点。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INV_OBJREF()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。
INV_OBJREF(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_OBJREF(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。
INV_OBJREF(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_OBJREF 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INV_OBJREF

public INV_OBJREF()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。

INV_OBJREF

public INV_OBJREF(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。

参数：
s - 包含详细消息的 String

INV_OBJREF

public INV_OBJREF(int minor,
                  CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_OBJREF 异常。

参数：
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例

INV_OBJREF

public INV_OBJREF(String s,
                  int minor,
                  CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_OBJREF 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 指示完成状态的 CompletionStatus 实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INV_POLICY (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INV_POLICY

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INV_POLICY
所有已实现的接口：
Serializable
public final class INV_POLICY
extends SystemException

当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INV_POLICY()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 INV_POLICY 异常。
INV_POLICY(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_POLICY 异常。
INV_POLICY(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_POLICY 异常。
INV_POLICY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 INV_POLICY 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INV_POLICY

public INV_POLICY()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 INV_POLICY 异常。

INV_POLICY

public INV_POLICY(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_POLICY 异常。

参数：
s - 包含详细消息的 String

INV_POLICY

public INV_POLICY(int minor,
                  CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_POLICY 异常。

参数：
minor - 次要代码
completed - 完成状态

INV_POLICY

public INV_POLICY(String s,
                  int minor,
                  CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 INV_POLICY 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INVALID_ACTIVITY (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INVALID_ACTIVITY

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INVALID_ACTIVITY
所有已实现的接口：
Serializable
public final class INVALID_ACTIVITY
extends SystemException

如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。当试图进行与 Activity 的当前状态不兼容的调用时，也可能引发此异常。

从以下版本开始：
J2SE 1.5
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INVALID_ACTIVITY()
使用次要代码 0 和 CompletionStatus COMPLETED_NO 构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(String detailMessage)
使用指定消息构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INVALID_ACTIVITY

public INVALID_ACTIVITY()
使用次要代码 0 和 CompletionStatus COMPLETED_NO 构造一个 INVALID_ACTIVITY 异常。

INVALID_ACTIVITY

public INVALID_ACTIVITY(String detailMessage)
使用指定消息构造一个 INVALID_ACTIVITY 异常。

参数：
detailMessage - 包含详细消息的字符串。

INVALID_ACTIVITY

public INVALID_ACTIVITY(int minorCode,
                        CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。

参数：
minorCode - 次要代码。
completionStatus - 完成状态。

INVALID_ACTIVITY

public INVALID_ACTIVITY(String detailMessage,
                        int minorCode,
                        CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。

参数：
detailMessage - 包含详细消息的字符串。
minorCode - 次要代码。
completionStatus - 完成状态。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INVALID_TRANSACTION (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 INVALID_TRANSACTION

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.INVALID_TRANSACTION
所有已实现的接口：
Serializable
public final class INVALID_TRANSACTION
extends SystemException

当请求带有无效的事务上下文时，抛出此异常。例如，如果在尝试注册资源时发生错误，则引发此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
INVALID_TRANSACTION()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(String s)
使用指定消息构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

INVALID_TRANSACTION

public INVALID_TRANSACTION()
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INVALID_TRANSACTION 异常。

INVALID_TRANSACTION

public INVALID_TRANSACTION(String s)
使用指定消息构造一个 INVALID_TRANSACTION 异常。

参数：
s - 包含详细消息的 String

INVALID_TRANSACTION

public INVALID_TRANSACTION(int minor,
                           CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。

参数：
minor - 次要代码
completed - 完成状态

INVALID_TRANSACTION

public INVALID_TRANSACTION(String s,
                           int minor,
                           CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。详细消息是描述此特定异常的 String。

参数：
s - 包含详细消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IRObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 IRObject

所有超级接口：
IDLEntity, IRObjectOperations, Object, Serializable
所有已知子接口：
IDLType
所有已知实现类：
_IDLTypeStub
public interface IRObject
extends IRObjectOperations, Object, IDLEntity

IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。

方法摘要
从接口 org.omg.CORBA.IRObjectOperations 继承的方法
def_kind, destroy
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IRObjectOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 IRObjectOperations

所有已知子接口：
IDLType, IDLTypeOperations, IRObject
所有已知实现类：
_IDLTypeStub
public interface IRObjectOperations

这是用于 IRObject 的映射的 Operations 接口。一些接口被用做接口存储库（Interface Repository，IR）中对象的基本接口。这些基本接口是不可实例化的。使用一个共用操作集来定位接口存储库中的对象。其中有些操作在 IRObject 中定义。所有 IR 对象都是从 IRObject 接口继承的，该接口提供了一个用来标识实际对象类型的操作。（IDL 基本接口 IRObject 表示最一般的接口，其他所有接口存储库接口（甚至 Repository 自身）都派生自该接口。）IR 对象的所有 java 实现都必须实现 IRObjectOperations 接口。

另请参见：
IDLTypeOperations, IDLType, IRObject

方法摘要
DefinitionKind | def_kind() 返回对应于此接口存储库对象的 DefinitionKind。
void | destroy() 销毁此对象。

方法详细信息

def_kind

DefinitionKind def_kind()
返回对应于此接口存储库对象的 DefinitionKind。

返回：
对应于此接口存储库对象的 DefinitionKind。

destroy

void destroy()
销毁此对象。如果该对象是一个 Container，则此方法可应用于其所有内容。如果该对象包含一个用于 anonymous 类型的 IDLType 属性，则销毁该 IDLType。如果该对象当前包含在其他对象中，则它将被移除。如果对 Repository 或 PrimitiveDef 调用此方法，则将引发 BAD_INV_ORDER 异常，并带有次要值 (minor value) 2。试图销毁将导致存储库处于不一致状态的对象将引发 BAD_INV_ORDER 异常，并带有次要代码 1。

抛出：
BAD_INV_ORDER - 如果对存储库或 PrimitiveDef 调用此方法，或者试图销毁将导致存储库处于不一致状态的对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LocalObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 LocalObject

java.lang.Object
    继承者  org.omg.CORBA.LocalObject
所有已实现的接口：
Object
public class LocalObject
extends Object
implements Object

用作 Java 语言映射中的本地 IDL 接口实现的基本类。该类实现了 org.omg.CORBA.Object 接口中的所有操作。

本地接口是通过使用 CORBA::LocalObject 实现的，它提供 Object 伪操作的实现以及任何其他适用于这些对象的特定于 ORB 的支持机制。对象实现技术本来就是特定于语言映射的。因此，LocalObject 类型不是在 IDL 中定义的，而是在每个语言映射中指定的。

没有应用于本地对象的方法抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally contrained object"。试图使用 LocalObject 创建 DII 请求将导致 NO_IMPLEMENT 系统异常。试图编组或字符串化 LocalObject 将导致 MARSHAL 系统异常。必须像对常规对象引用那样来缩小或扩大对 LocalObjects 的引用。

LocalObject 被用作本地受约束对象（比如 PortableServer 模块中的那些对象）的基本类。此规范基于 CORBA Components Volume I - orbos/99-07-01。

另请参见：
CORBA 包中有关未实现特性的注释

构造方法摘要
LocalObject()
构造一个默认 LocalObject 实例。
方法摘要
Request | _create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Object | _duplicate() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
DomainManager[] | _get_domain_managers() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Object | _get_interface_def() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Object | _get_interface() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Policy | _get_policy(int policy_type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
int | _hash(int maximum) 返回与对象的生命周期一致的哈希值，使用给定数字作为最大值。
InputStream | _invoke(OutputStream output) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
boolean | _is_a(String repository_id) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
boolean | _is_equivalent(Object that) 在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
boolean | _is_local() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
boolean | _non_existent() 总是返回 false。
ORB | _orb() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
void | _release() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
void | _releaseReply(InputStream input) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | _request(String operation) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
OutputStream | _request(String operation, boolean responseExpected) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
void | _servant_postinvoke(ServantObject servant) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
ServantObject | _servant_preinvoke(String operation, Class expectedType) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Object | _set_policy_override(Policy[] policies, SetOverrideType set_add) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
boolean | validate_connection() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LocalObject

public LocalObject()
构造一个默认 LocalObject 实例。

方法详细信息

_is_equivalent

public boolean _is_equivalent(Object that)

在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。两个等同的对象引用是相等的。两个实际引用相同对象的不同对象引用也是相等的。但是，ORB 不需要尝试确定两个不同的对象引用是否引用了相同的对象，因为这种确定所需的开销可能非常昂贵。

此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _is_equivalent
参数：
that - 用来检查相等性的对象引用
返回：
如果已知此对象引用与给定对象引用相等，则返回 true。注意，false 只指示两个对象引用不同，不一定指示它们所引用的对象不同。

_non_existent

public boolean _non_existent()
总是返回 false。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _non_existent
返回：
false

_hash

public int _hash(int maximum)
返回与对象的生命周期一致的哈希值，使用给定数字作为最大值。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _hash
参数：
maximum - 一个 int 值，它标识哈希码的最大值
返回：
此实例的哈希码

_is_a

public boolean _is_a(String repository_id)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法并不应用于本地对象，所以没有实现。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _is_a
参数：
repository_id - String
返回：
NO_IMPLEMENT，因为此为本地受约束对象，并且此方法并不应用于本地对象
抛出：
NO_IMPLEMENT - 因为此为本地受约束对象，并且此方法并不应用于本地对象
另请参见：
CORBA 包中有关未实现特性的注释

_duplicate

public Object _duplicate()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _duplicate
返回：
此 LocalObject 实例的副本。
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_release

public void _release()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _release
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_request

public Request _request(String operation)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _request
参数：
operation - 一个 String，它提供将由返回的请求所执行的操作的名称
返回：
具有给定操作的 Request 对象
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_create_request

public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _create_request
参数：
ctx - 包含属性列表的 Context 对象
operation - 表示将被调用的方法名称的 String
arg_list - 包含实际调用的方法参数的 NVList
result - 将用作该方法返回值容器的 NamedValue 对象
返回：
使用给定参数初始化的新 Request 对象
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_create_request

public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result,
                               ExceptionList exceptions,
                               ContextList contexts)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _create_request
参数：
ctx - 包含属性列表的 Context 对象
operation - 将被调用的方法的名称
arg_list - 包含实际调用的方法参数的 NVList
result - 将用作该方法返回值容器的 NamedValue 对象
exceptions - 一个 ExceptionList 对象，包含该方法可能抛出的异常所组成的列表
contexts - 一个 ContextList 对象，包含需要解析并随 Request 实例一起发送的上下文字符串所组成的列表
返回：
使用给定参数初始化的新 Request 对象
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_get_interface

public Object _get_interface()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法并不应用于本地对象，所以没有实现。此方法是 org.omg.CORBA.Object 方法的默认实现。

返回：
NO_IMPLEMENT，因为此为本地受约束对象，并且此方法并不应用于本地对象
抛出：
NO_IMPLEMENT - 因为此为本地受约束对象，并且此方法并不应用于本地对象
另请参见：
CORBA 包中有关未实现特性的注释

_get_interface_def

public Object _get_interface_def()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _get_interface_def
返回：
Repository 接口中的 InterfaceDef 对象，它提供了有关此对象引用所引用的对象的类型信息。
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_orb

public ORB _orb()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

返回：
创建此 ObjectImpl 中所包含 Delegate 的 ORB 实例
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_get_policy

public Policy _get_policy(int policy_type)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法并不应用于本地对象，所以没有实现。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _get_policy
参数：
policy_type - int 值
返回：
NO_IMPLEMENT，因为此为本地受约束对象，并且此方法并不应用于本地对象
抛出：
NO_IMPLEMENT - 因为此为本地受约束对象，并且此方法并不应用于本地对象
另请参见：
CORBA 包中有关未实现特性的注释

_get_domain_managers

public DomainManager[] _get_domain_managers()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法并不应用于本地对象，所以没有实现。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _get_domain_managers
返回：
此类直接封装的域管理程序列表。至少有一个域管理程序总是返回在列表中，因为默认情况下，每个类在创建时至少关联一个域管理程序。
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_set_policy_override

public Object _set_policy_override(Policy[] policies,
                                   SetOverrideType set_add)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法并不应用于本地对象，所以没有实现。此方法是 org.omg.CORBA.Object 方法的默认实现。

指定者：
接口 Object 中的 _set_policy_override
参数：
policies - 一个数组
set_add - 一个标志
返回：
NO_IMPLEMENT，因为此为本地受约束对象，并且此方法并不应用于本地对象
抛出：
NO_IMPLEMENT - 因为此为本地受约束对象，并且此方法并不应用于本地对象
另请参见：
CORBA 包中有关未实现特性的注释

_is_local

public boolean _is_local()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

对于此 LocalObject 实例返回 true。

返回：
总是返回 true
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_servant_preinvoke

public ServantObject _servant_preinvoke(String operation,
                                        Class expectedType)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

参数：
operation - 指示将提前调用哪一项操作的 String
expectedType - 上述操作类型的类
返回：
NO_IMPLEMENT，因为此为本地受约束对象，并且此方法并不应用于本地对象
抛出：
NO_IMPLEMENT - 因为此为本地受约束对象，并且此方法并不应用于本地对象
另请参见：
CORBA 包中有关未实现特性的注释

_servant_postinvoke

public void _servant_postinvoke(ServantObject servant)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

参数：
servant - 进行后调用的 servant 对象
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

_request

public OutputStream _request(String operation,
                             boolean responseExpected)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

此方法由 stub 调用，以获得用于编组参数的 OutputStream。stub 必须提供操作名称，并指示是否希望应答（即是否为单向调用）。

参数：
operation - 被请求的操作的名称
responseExpected - 如果期望应答，则该值为 true；如果该调用是单向调用，则该值为 false
返回：
NO_IMPLEMENT 因为此为本地受约束对象，并且此方法并不应用于本地对象
抛出：
NO_IMPLEMENT - 因为此为本地受约束对象，并且此方法并不应用于本地对象
另请参见：
CORBA 包中有关未实现特性的注释

_invoke

public InputStream _invoke(OutputStream output)
                    throws ApplicationException,
                           RemarshalException
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

可调用此方法来调用某项操作。stub 提供以前由 _request() 调用返回的 OutputStream。_invoke 返回一个包含已编组应答的 InputStream。如果发生异常，则 _invoke 抛出 ApplicationException 对象，该对象包含一个 InputStream，从中可解组用户异常状态。

参数：
output - 要调用的 OutputStream
返回：
NO_IMPLEMENT 因为此为本地受约束对象，并且此方法并不应用于本地对象
抛出：
ApplicationException - 如果发生异常，则 _invoke 抛出 ApplicationException 对象，该对象包含一个 InputStream，从中可解组用户异常状态。
RemarshalException - 如果发生异常，则 _invoke 抛出 ApplicationException 对象，该对象包含一个 InputStream，从中可解组用户异常状态。
NO_IMPLEMENT - 因为此为本地受约束对象，并且此方法并不应用于本地对象
另请参见：
CORBA 包中有关未实现特性的注释

_releaseReply

public void _releaseReply(InputStream input)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法是 org.omg.CORBA.Object 方法的默认实现。

stub 可以有选择地调用此方法，以在完成解组时将应答流释放回 ORB。stub 传递由 _invoke() 或 ApplicationException.getInputStream() 返回的 InputStream。还可以将 null 值传递给 _releaseReply，在这种情况下，此方法不执行任何操作。

参数：
input - 释放回 ORB 的应答流或 null
抛出：
NO_IMPLEMENT
另请参见：
CORBA 包中有关未实现特性的注释

validate_connection

public boolean validate_connection()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。此方法并不应用于本地对象，所以没有实现。此方法是 org.omg.CORBA.Object 方法的默认实现。

返回：
NO_IMPLEMENT，因为此为本地受约束对象，并且此方法并不应用于本地对象
抛出：
NO_IMPLEMENT - 因为此为本地受约束对象，并且此方法并不应用于本地对象
另请参见：
CORBA 包中有关未实现特性的注释
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LongHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 LongHolder

java.lang.Object
    继承者  org.omg.CORBA.LongHolder
所有已实现的接口：
Streamable
public final class LongHolder
extends Object
implements Streamable

Long 值的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

long 值的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将 IDL long long 作为 "out" 或 "inout" 参数，则程序员必须传递 LongHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myLongHolder 是 LongHolder 实例，则可以使用 myLongHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 long value
此 LongHolder 对象保存的 long 值。
构造方法摘要
LongHolder()
构造一个新的 LongHolder 对象，将其 value 字段初始化为 0。
LongHolder(long initial)
构造一个新的 LongHolder 对象，并使用给定 long 初始化其 value 字段。
方法摘要
void | _read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
TypeCode | _type() 返回对应于此 Holder 中所保存的值的 TypeCode 对象。
void | _write(OutputStream output) 将此 Holder 中的值编组到 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public long value
此 LongHolder 对象保存的 long 值。

构造方法详细信息

LongHolder

public LongHolder()
构造一个新的 LongHolder 对象，将其 value 字段初始化为 0。

LongHolder

public LongHolder(long initial)
构造一个新的 LongHolder 对象，并使用给定 long 初始化其 value 字段。

参数：
initial - 用来初始化新建 LongHolder 对象 value 字段的 long 值
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 Holder 中的值编组到 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
返回对应于此 Holder 中所保存的值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
此 holder 中保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LongLongSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 LongLongSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.LongLongSeqHelper

public abstract class LongLongSeqHelper
extends Object

LongLongSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/LongLongSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:37 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
LongLongSeqHelper()
方法摘要
static long[] | extract(Any a)
static String | id()
static void | insert(Any a, long[] that)
static long[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, long[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LongLongSeqHelper

public LongLongSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          long[] that)

extract

public static long[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static long[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         long[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LongLongSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 LongLongSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.LongLongSeqHolder
所有已实现的接口：
Streamable
public final class LongLongSeqHolder
extends Object
implements Streamable

LongLongSeq 的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/LongLongSeqHolder.java 由 IDL-to-Java 编译器（可移植）"3.0" 版从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00)

字段摘要
 long[] value
构造方法摘要
LongLongSeqHolder()
LongLongSeqHolder(long[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public long[] value
构造方法详细信息

LongLongSeqHolder

public LongLongSeqHolder()

LongLongSeqHolder

public LongLongSeqHolder(long[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LongSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 LongSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.LongSeqHelper

public abstract class LongSeqHelper
extends Object

LongSeqHelper 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/LongSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
LongSeqHelper()
方法摘要
static int[] | extract(Any a)
static String | id()
static void | insert(Any a, int[] that)
static int[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LongSeqHelper

public LongSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          int[] that)

extract

public static int[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LongSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 LongSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.LongSeqHolder
所有已实现的接口：
Streamable
public final class LongSeqHolder
extends Object
implements Streamable

LongSeq 的 Holder。有关 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/LongSeqHolder.java 由 IDL-to-Java 编译器（可移植）"3.0" 版从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00)

字段摘要
 int[] value
构造方法摘要
LongSeqHolder()
LongSeqHolder(int[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public int[] value
构造方法详细信息

LongSeqHolder

public LongSeqHolder()

LongSeqHolder

public LongSeqHolder(int[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MARSHAL (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 MARSHAL

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.MARSHAL
所有已实现的接口：
Serializable
public final class MARSHAL
extends SystemException

表示网络中传来的请求或应答在结构上无效。此错误通常指示在客户端或服务器端运行时存在错误。例如，如果服务器的应答指示消息包含 1000 个字节，但实际消息却少于或超过 1000 个字节，则 ORB 将引发此异常。不正确地使用 DII 或 DSI 也可能引起的 MARSHAL，例如，发送的实际参数类型与操作的 IDL 签名不一致时。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

从以下版本开始：
JDK1.2

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
MARSHAL()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 MARSHAL 异常。
MARSHAL(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 MARSHAL 异常。
MARSHAL(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 MARSHAL 异常。
MARSHAL(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 MARSHAL 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MARSHAL

public MARSHAL()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 MARSHAL 异常。

MARSHAL

public MARSHAL(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 MARSHAL 异常。

参数：
s - 包含该异常描述的 String

MARSHAL

public MARSHAL(int minor,
               CompletionStatus completed)
使用指定次要代码和完成状态构造一个 MARSHAL 异常。

参数：
minor - 次要代码
completed - 完成状态

MARSHAL

public MARSHAL(String s,
               int minor,
               CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 MARSHAL 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamedValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NamedValue

java.lang.Object
    继承者  org.omg.CORBA.NamedValue

public abstract class NamedValue
extends Object

在 DII 和 DSI 中用来描述参数和返回值的对象。NamedValue 对象还用在 Context 对象例程中传递属性名称和值的列表。

NamedValue 对象包含：

  • 名称：如果 NamedValue 对象用于描述某个请求的参数，则名称将是所描述操作的 OMG IDL 接口定义中指定的参数标识符。
  • 一个值：Any 对象
  • 参数模式标志，以下标志之一：
    • ARG_IN.value
    • ARG_OUT.value
    • ARG_INOUT.value
    • 0：如果此 NamedValue 对象表示 Context 对象中的一个属性，而不是参数或返回值

NamedValue 类具有三个可访问其字段的方法。以下代码段展示了如何创建 NamedValue 对象，然后访问其字段：

    ORB orb = ORB.init(args, null);
    String s = "argument_1";
    org.omg.CORBA.Any myAny = orb.create_any();
    myAny.insert_long(12345);
    int in = org.omg.CORBA.ARG_IN.value;

    org.omg.CORBA.NamedValue nv = orb.create_named_value(
        s, myAny, in);
    System.out.println("This nv name is " + nv.name());
    try {
        System.out.println("This nv value is " + nv.value().extract_long());
        System.out.println("This nv flag is " + nv.flags());
    } catch (org.omg.CORBA.BAD_OPERATION b) {
      System.out.println("extract failed");
    }

如果将此代码片段放入 main 方法中，则输出将如下所示：

    This nv name is argument_1
    This nv value is 12345
    This nv flag is 1

注意，方法 value 返回 Any 对象。若要访问 Any 对象中包含的 long 值，可使用方法 extract_long。

从以下版本开始：
JDK1.2
另请参见：
Any, ARG_IN, ARG_INOUT, ARG_OUT

构造方法摘要
NamedValue()
方法摘要
abstract int | flags() 检索用于此 NamedValue 对象的参数模式标志。
abstract String | name() 检索此 NamedValue 对象的名称。
abstract Any | value() 检索此 NamedValue 对象的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NamedValue

public NamedValue()
方法详细信息

name

public abstract String name()
检索此 NamedValue 对象的名称。

返回：
表示此 NamedValue 对象名称的 String 对象

value

public abstract Any value()
检索此 NamedValue 对象的值。

返回：
包含此 NamedValue 对象值的 Any 对象

flags

public abstract int flags()
检索用于此 NamedValue 对象的参数模式标志。

返回：
表示此 NamedValue 对象参数模式的 int 值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameValuePair (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NameValuePair

java.lang.Object
    继承者  org.omg.CORBA.NameValuePair
所有已实现的接口：
Serializable, IDLEntity
public final class NameValuePair
extends Object
implements IDLEntity

将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。

字段摘要
String | id 将通过此 NameValuePair 对象与某一值关联的名称。
Any | value 将通过此 NameValuePair 对象与某一名称关联的值。
构造方法摘要
NameValuePair()
创建一个空的 NameValuePair 对象。
NameValuePair(String __id, Any __value)
构造一个 NameValuePair 对象，该对象将给定名称与给定 org.omg.CORBA.Any 对象关联。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

id

public String id
将通过此 NameValuePair 对象与某一值关联的名称。

value

public Any value
将通过此 NameValuePair 对象与某一名称关联的值。

构造方法详细信息

NameValuePair

public NameValuePair()
创建一个空的 NameValuePair 对象。要在使用此构造方法后将某一名称与某一值相关联，必须分别访问此对象的字段。

NameValuePair

public NameValuePair(String __id,
                     Any __value)
构造一个 NameValuePair 对象，该对象将给定名称与给定 org.omg.CORBA.Any 对象关联。

参数：
__id - 将与给定 Any 对象关联的名称
__value - 将与给定名称关联的 Any 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameValuePairHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NameValuePairHelper

java.lang.Object
    继承者  org.omg.CORBA.NameValuePairHelper

public abstract class NameValuePairHelper
extends Object

NameValuePair 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/NameValuePairHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）生成，生成时间为 1999 年 6 月 3 日 11:52:03 (GMT+00:00)

构造方法摘要
NameValuePairHelper()
方法摘要
static NameValuePair | extract(Any a)
static String | id()
static void | insert(Any a, NameValuePair that)
static NameValuePair | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameValuePair value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NameValuePairHelper

public NameValuePairHelper()
方法详细信息

insert

public static void insert(Any a,
                          NameValuePair that)

extract

public static NameValuePair extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameValuePair read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameValuePair value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NO_IMPLEMENT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NO_IMPLEMENT

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.NO_IMPLEMENT
所有已实现的接口：
Serializable
public final class NO_IMPLEMENT
extends SystemException

此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。例如，如果客户端请求从接口存储库获得对象的类型定义，但 ORB 没有提供接口存储库，则可由 ORB 引发 NO_IMPLEMENT 异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

从以下版本开始：
JDK1.2

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
NO_IMPLEMENT()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NO_IMPLEMENT

public NO_IMPLEMENT()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_IMPLEMENT 异常。

NO_IMPLEMENT

public NO_IMPLEMENT(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_IMPLEMENT 异常。

参数：
s - 包含该异常描述的 String

NO_IMPLEMENT

public NO_IMPLEMENT(int minor,
                    CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_IMPLEMENT 异常。

参数：
minor - 指定次要代码的 int 值
completed - 指示完成状态的 CompletionStatus 实例

NO_IMPLEMENT

public NO_IMPLEMENT(String s,
                    int minor,
                    CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_IMPLEMENT 异常。

参数：
s - 包含描述消息的 String
minor - 指定次要代码的 int 值
completed - 指示完成状态的 CompletionStatus 实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NO_MEMORY (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NO_MEMORY

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.NO_MEMORY
所有已实现的接口：
Serializable
public final class NO_MEMORY
extends SystemException

如果 ORB 运行时出现内存不足，则抛出此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
NO_MEMORY()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_MEMORY 异常。
NO_MEMORY(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_MEMORY(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_MEMORY 异常。
NO_MEMORY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_MEMORY 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NO_MEMORY

public NO_MEMORY()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_MEMORY 异常。

NO_MEMORY

public NO_MEMORY(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_MEMORY 异常。

参数：
s - 包含描述消息的 String

NO_MEMORY

public NO_MEMORY(int minor,
                 CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_MEMORY 异常。

参数：
minor - 次要代码
completed - 完成状态

NO_MEMORY

public NO_MEMORY(String s,
                 int minor,
                 CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_MEMORY 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NO_PERMISSION (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NO_PERMISSION

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.NO_PERMISSION
所有已实现的接口：
Serializable
public final class NO_PERMISSION
extends SystemException

当因为调用者没有足够的权限而导致调用失败时，抛出此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
NO_PERMISSION()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_PERMISSION 异常。
NO_PERMISSION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_PERMISSION(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_PERMISSION 异常。
NO_PERMISSION(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_PERMISSION 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NO_PERMISSION

public NO_PERMISSION()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_PERMISSION 异常。

NO_PERMISSION

public NO_PERMISSION(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_PERMISSION 异常。

参数：
s - 包含描述消息的 String

NO_PERMISSION

public NO_PERMISSION(int minor,
                     CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_PERMISSION 异常。

参数：
minor - 次要代码
completed - 完成状态

NO_PERMISSION

public NO_PERMISSION(String s,
                     int minor,
                     CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_PERMISSION 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NO_RESOURCES (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NO_RESOURCES

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.NO_RESOURCES
所有已实现的接口：
Serializable
public final class NO_RESOURCES
extends SystemException

当 ORB 遇到一些一般资源限制时，抛出此异常。例如，运行时可能已经达到允许打开的最大连接数。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
NO_RESOURCES()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_RESOURCES 异常。
NO_RESOURCES(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESOURCES(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESOURCES 异常。
NO_RESOURCES(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESOURCES 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NO_RESOURCES

public NO_RESOURCES()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_RESOURCES 异常。

NO_RESOURCES

public NO_RESOURCES(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESOURCES 异常。

参数：
s - 包含描述消息的 String

NO_RESOURCES

public NO_RESOURCES(int minor,
                    CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_RESOURCES 异常。

参数：
minor - 次要代码
completed - 完成状态

NO_RESOURCES

public NO_RESOURCES(String s,
                    int minor,
                    CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESOURCES 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NO_RESPONSE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 NO_RESPONSE

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.NO_RESPONSE
所有已实现的接口：
Serializable
public final class NO_RESPONSE
extends SystemException

如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
NO_RESPONSE()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_RESPONSE 异常。
NO_RESPONSE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_RESPONSE 异常。
NO_RESPONSE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESPONSE 异常。
NO_RESPONSE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESPONSE 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NO_RESPONSE

public NO_RESPONSE()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_RESPONSE 异常。

NO_RESPONSE

public NO_RESPONSE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESPONSE 异常。

参数：
s - 包含描述消息的 String

NO_RESPONSE

public NO_RESPONSE(int minor,
                   CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_RESPONSE 异常。

参数：
minor - 次要代码
completed - 完成状态

NO_RESPONSE

public NO_RESPONSE(String s,
                   int minor,
                   CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESPONSE 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OBJ_ADAPTER (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 OBJ_ADAPTER

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.OBJ_ADAPTER
所有已实现的接口：
Serializable
public final class OBJ_ADAPTER
extends SystemException

此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
OBJ_ADAPTER()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OBJ_ADAPTER

public OBJ_ADAPTER()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 OBJ_ADAPTER 异常。

OBJ_ADAPTER

public OBJ_ADAPTER(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJ_ADAPTER 异常。

参数：
s - 包含描述消息的 String

OBJ_ADAPTER

public OBJ_ADAPTER(int minor,
                   CompletionStatus completed)
使用指定次要代码和完成状态构造一个 OBJ_ADAPTER 异常。

参数：
minor - 次要代码
completed - 完成状态

OBJ_ADAPTER

public OBJ_ADAPTER(String s,
                   int minor,
                   CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJ_ADAPTER 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Object (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 Object

所有已知子接口：
AdapterActivator, BindingIterator, ClientRequestInfo, ClientRequestInterceptor, Codec, CodecFactory, Current, Current, Current, DomainManager, DynAny, DynAny, DynAnyFactory, DynArray, DynArray, DynEnum, DynEnum, DynFixed, DynFixed, DynSequence, DynSequence, DynStruct, DynStruct, DynUnion, DynUnion, DynValue, DynValue, DynValueBox, DynValueCommon, IdAssignmentPolicy, IDLType, IdUniquenessPolicy, ImplicitActivationPolicy, Interceptor, IORInfo, IORInterceptor, IORInterceptor_3_0, IRObject, LifespanPolicy, NamingContext, NamingContextExt, ORBInitializer, ORBInitInfo, POA, POAManager, Policy, PolicyFactory, RequestInfo, RequestProcessingPolicy, RunTime, ServantActivator, ServantLocator, ServantManager, ServantRetentionPolicy, ServerRequestInfo, ServerRequestInterceptor, ThreadPolicy
所有已知实现类：
_BindingIteratorImplBase, _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, _PolicyStub, _Remote_Stub, _ServantActivatorStub, _ServantLocatorStub, DynamicImplementation, LocalObject, ObjectImpl, ObjectImpl, Stub
public interface Object

CORBA 对象引用的定义。

CORBA 对象引用是服务器实现的特定 CORBA 对象的句柄。每次使用 CORBA 对象引用对对象调用方法时，该对象引用都标识同一 CORBA 对象。CORBA 对象可以有多个不同的对象引用。

org.omg.CORBA.Object 接口是 Java 编程语言中所有 CORBA 对象引用继承层次结构的根，类似于用于 RMI 远程对象的 java.rmi.Remote。

CORBA 对象可以是本地的，也可以是远程的。如果该对象是一个本地对象（即与客户端运行在同一 VM 中），则可以直接在该对象实例上进行调用，对象引用可以指向实际的对象实现类实例。如果 CORBA 对象是一个远程对象（即与客户端运行在不同的 VM 中），则对象引用指向某一 stub（代理），该 stub 使用 ORB 机制在对象实现驻留的服务器上进行远程调用。

org.omg.CORBA.portable.ObjectImpl 类中提供接口 org.omg.CORBA.Object 中方法的默认实现，该类是 stub 和对象实现的基类。

另请参见：
ObjectImpl

方法摘要
Request | _create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
Object | _duplicate() 返回此 CORBA 对象引用的副本。
DomainManager[] | _get_domain_managers() 检索此对象的 DomainManager。
Object | _get_interface_def() 获取此对象引用所引用的对象实现的 InterfaceDef。
Policy | _get_policy(int policy_type) 返回应用于此对象的指定类型的 Policy 对象。
int | _hash(int maximum) 返回此对象引用的 ORB 内部标识符。
boolean | _is_a(String repositoryIdentifier) 检查此对象是否是实现给定接口的类的实例。
boolean | _is_equivalent(Object other) 在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
boolean | _non_existent() 确定此对象引用的 server 对象是否已经被销毁。
void | _release() 发出信号，指示此对象引用调用者已经使用完毕，因而可以释放与此对象引用关联的内部 ORB 资源。
Request | _request(String operation) 创建一个在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
Object | _set_policy_override(Policy[] policies, SetOverrideType set_add) 返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。

方法详细信息

_is_a

boolean _is_a(String repositoryIdentifier)
检查此对象是否是实现给定接口的类的实例。

参数：
repositoryIdentifier - 要检查的接口
返回：
如果此对象引用是实现接口的类的实例，则返回 true；否则返回 false

_is_equivalent

boolean _is_equivalent(Object other)
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。两个等同的对象引用是相等的。两个实际引用相同对象的不同对象引用也是相等的。但是，ORB 不需要尝试确定两个不同的对象引用是否引用了相同的对象，因为这种确定所需的开销可能非常昂贵。

参数：
other - 用来检查相等性的另一个对象引用
返回：
如果已知此对象引用与给定对象引用相等，则返回 true。注意，false 仅指示两个对象引用是不同的，它们不一定引用不同的对象。

_non_existent

boolean _non_existent()
确定此对象引用的 server 对象是否已经被销毁。

返回：
如果 ORB 确信 server 对象不存在，则返回 true；否则返回 false

_hash

int _hash(int maximum)
返回此对象引用的 ORB 内部标识符。这是一个哈希标识符，在对象引用的生存期间该标识符不会发生更改，因此该标识符的任何哈希函数也不会发生更改。不保证返回值是唯一的；换句话说，另一个对象引用可以有相同的哈希值。如果两个对象引用的哈希值不同，则它们是不同的对象引用，但是它们仍然可以引用相同的 CORBA 对象。

参数：
maximum - ORB 返回的哈希值的上限
返回：
此对象引用的 ORB 内部哈希标识符

_duplicate

Object _duplicate()
返回此 CORBA 对象引用的副本。server 对象实现不涉及创建副本，并且该实现无法区分请求时使用的是原始对象引用还是副本。

注意，此方法在 Java 平台上不是很有用，因为内存管理由 VM 处理。包含此方法是为了与 CORBA API 保持一致。

_duplicate 方法可能返回此对象引用本身。

返回：
此对象引用的副本或此对象引用本身

_release

void _release()
发出信号，指示此对象引用调用者已经使用完毕，因而可以释放与此对象引用关联的内部 ORB 资源。注意，此操作中不涉及对象实现，并且不影响对同一对象的其他引用。

_get_interface_def

Object _get_interface_def()
获取此对象引用所引用的对象实现的 InterfaceDef。可以使用 InterfaceDef 对象对此对象引用所引用对象的方法、属性和其他类型信息进行内省。

返回：
Repository 接口中的 InterfaceDef 对象，它提供了有关此对象引用所引用的对象的类型信息。

_request

Request _request(String operation)
创建一个在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。

参数：
operation - 使用 Request 实例调用的方法的名称
返回：
新创建的 Request 实例

_create_request

Request _create_request(Context ctx,
                        String operation,
                        NVList arg_list,
                        NamedValue result)
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。

参数：
ctx - 包含属性列表的 Context 对象
operation - 要调用的方法的名称
arg_list - 一个 NVList，包含将调用的方法的实际参数
result - 作为该方法返回值容器的 NamedValue 对象
返回：
新创建的 Request 对象
另请参见：
Request, NVList, NamedValue

_create_request

Request _create_request(Context ctx,
                        String operation,
                        NVList arg_list,
                        NamedValue result,
                        ExceptionList exclist,
                        ContextList ctxlist)
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

参数：
ctx - 包含属性列表的 Context 对象
operation - 要调用的方法的名称
arg_list - 一个 NVList，包含将调用的方法的实际参数
result - 作为该方法返回值容器的 NamedValue 对象
exclist - 一个 ExceptionList 对象，包含该方法可能抛出的异常所组成的列表
ctxlist - 一个 ContextList 对象，包含需要被解析的上下文字符串所组成的列表，这些字符串随 Request 实例一起发送
返回：
新创建的 Request 对象
另请参见：
Request, NVList, NamedValue, ExceptionList, ContextList

_get_policy

Policy _get_policy(int policy_type)
返回应用于此对象的指定类型的 Policy 对象。

参数：
policy_type - 将获取的策略类型
返回：
由 policy_type 参数指定的类型的 Policy 对象
抛出：
BAD_PARAM - 当由于此 ORB 不支持指定类型或者该类型的策略对象没有与此对象关联而导致策略类型值无效时

_get_domain_managers

DomainManager[] _get_domain_managers()
检索此对象的 DomainManager。这允许管理服务（和应用程序）检索域管理程序，从而使得安全性和其他策略能应用于作为该域成员的各个对象。

返回：
此类直接封装的域管理程序列表。至少有一个域管理程序总是返回在列表中，因为默认情况下，每个类在创建时至少关联一个域管理程序。

_set_policy_override

Object _set_policy_override(Policy[] policies,
                            SetOverrideType set_add)
返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。

参数：
policies - 一个 Policy 对象数组，包含将添加或用作替代策略的策略
set_add - 该值可以为 SetOverrideType.SET_OVERRIDE，指示给定策略将替换所有现有策略；也可以为 SetOverrideType.ADD_OVERRIDE，指示应该添加到所有现有策略的给定策略
返回：
一个新 Object，此 Object 中的策略已使用给定策略替换或添加
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OBJECT_NOT_EXIST (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 OBJECT_NOT_EXIST

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.OBJECT_NOT_EXIST
所有已实现的接口：
Serializable
public final class OBJECT_NOT_EXIST
extends SystemException

只要在已删除的对象上执行调用，就会引发此异常。这是一个权威性的“硬性”错误报告。允许（甚至期望）任何此报告的接受者删除此对象引用的所有副本，并执行其他适当的“最终恢复式”过程。将此异常传递给客户端，同时销毁它们可能保存的所有记录（例如，引用转换中使用的代理对象）。客户端可以依次清除其自己的所有数据结构。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

从以下版本开始：
JDK1.2
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
OBJECT_NOT_EXIST()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OBJECT_NOT_EXIST

public OBJECT_NOT_EXIST()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 OBJECT_NOT_EXIST 异常。

OBJECT_NOT_EXIST

public OBJECT_NOT_EXIST(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJECT_NOT_EXIST 异常。

参数：
s - 包含描述消息的 String

OBJECT_NOT_EXIST

public OBJECT_NOT_EXIST(int minor,
                        CompletionStatus completed)
使用指定次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。

参数：
minor - 次要代码
completed - 完成状态

OBJECT_NOT_EXIST

public OBJECT_NOT_EXIST(String s,
                        int minor,
                        CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ObjectHelper

java.lang.Object
    继承者  org.omg.CORBA.ObjectHelper

public abstract class ObjectHelper
extends Object

构造方法摘要
ObjectHelper()
方法摘要
static Object | extract(Any a)
static String | id()
static void | insert(Any a, Object that)
static Object | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Object value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectHelper

public ObjectHelper()
方法详细信息

insert

public static void insert(Any a,
                          Object that)

extract

public static Object extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Object read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Object value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ObjectHolder

java.lang.Object
    继承者  org.omg.CORBA.ObjectHolder
所有已实现的接口：
Streamable
public final class ObjectHolder
extends Object
implements Streamable

Object 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

用于 CORBA 对象引用的 Holder 类（类型 org.omg.CORBA.Object 的值）。它通常用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将 CORBA Object 引用作为 "out" 或 "inout" 参数，则程序员必须传递一个 ObjectHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myObjectHolder 是 ObjectHolder 实例，则可以使用 myObjectHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 Object value
此 ObjectHolder 对象保存的 Object 值。
构造方法摘要
ObjectHolder()
构造一个新的 ObjectHolder 对象，将其 value 字段初始化为 null。
ObjectHolder(Object initial)
构造一个新的 ObjectHolder 对象，并使用给定 Object 初始化其 value 字段。
方法摘要
void | _read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ObjectHolder 对象中的值。
TypeCode | _type() 返回对应于此 ObjectHolder 对象中所保存的值的 TypeCode
void | _write(OutputStream output) 将此 ObjectHolder 对象中的值编组到 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Object value
此 ObjectHolder 对象保存的 Object 值。

构造方法详细信息

ObjectHolder

public ObjectHolder()
构造一个新的 ObjectHolder 对象，将其 value 字段初始化为 null。

ObjectHolder

public ObjectHolder(Object initial)
构造一个新的 ObjectHolder 对象，并使用给定 Object 初始化其 value 字段。

参数：
initial - 用来初始化新建 ObjectHolder 对象 value 字段的 Object
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取数据，并使用已解组数据初始化此 ObjectHolder 对象中的值。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 ObjectHolder 对象中的值编组到 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
返回对应于此 ObjectHolder 对象中所保存的值的 TypeCode

指定者：
接口 Streamable 中的 _type
返回：
此 ObjectHolder 对象中所保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OctetSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 OctetSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.OctetSeqHelper

public abstract class OctetSeqHelper
extends Object

OctetSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/OctetSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日的 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
OctetSeqHelper()
方法摘要
static byte[] | extract(Any a)
static String | id()
static void | insert(Any a, byte[] that)
static byte[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, byte[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OctetSeqHelper

public OctetSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          byte[] that)

extract

public static byte[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static byte[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         byte[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OctetSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 OctetSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.OctetSeqHolder
所有已实现的接口：
Streamable
public final class OctetSeqHolder
extends Object
implements Streamable

OctetSeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/OctetSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日的 22:41:36 (GMT+00:00)

字段摘要
 byte[] value
构造方法摘要
OctetSeqHolder()
OctetSeqHolder(byte[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public byte[] value
构造方法详细信息

OctetSeqHolder

public OctetSeqHolder()

OctetSeqHolder

public OctetSeqHolder(byte[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OMGVMCID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 OMGVMCID

public interface OMGVMCID

为 OMG 保留的供应商次要代码 (minor code) ID。标准异常的次要代码均以分配给 OMG 的 VMCID 开头，这些次要代码被定义为常量 OMGVMCID，它们与所有 VMCID 一样占用前 20 位。

字段摘要
static int value
为 OMG 保留的供应商次要代码 ID。

字段详细信息

value

static final int value
为 OMG 保留的供应商次要代码 ID。此值是使用次要代码的前 20 个位进行按位或运算得到的，可用于生成系统异常中的次要值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ORB (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ORB

java.lang.Object
    继承者  org.omg.CORBA.ORB
直接已知子类：
ORB
public abstract class ORB
extends Object

为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。ORB 类还提供“可插入 ORB 实现”API，该 API 允许使用另一个供应商的 ORB 实现。

通过连接发送请求的对象（客户端）与响应请求的对象（服务器），ORB 使 CORBA 对象彼此之间能够进行通讯。

ORB 类封装了一些一般的 CORBA 功能，它可执行以下操作：（注意第 5 项和第 6 项，它们包含 ORB 类中的大多数方法，通常与动态调用接口（Dynamic Invocation Interface，DII）和动态框架接口（Dynamic Skeleton Interface，DSI）一起使用。开发人员可以直接使用这些接口，但大多数情况下，这些接口常常由 ORB 内部使用，这对于普通程序员是不可见的。）

  1. 通过为预先定义的属性和环境参数提供值来初始化 ORB 实现
  2. 使用方法 resolve_initial_references 获取对某些服务的初始对象引用（如 NameService）
  3. 将对象引用转换为字符串，将字符串转换为对象引用
  4. 将 ORB 连接到 servant（CORBA 对象实现的实例）以及断开 ORB 与 servant 的连接
  5. 创建如下所示对象
    • TypeCode
    • Any
    • NamedValue
    • Context
    • Environment
    • 包含这些对象的列表（如 NVList）
  6. 在 DII 中发送多条消息

可以使用 ORB 类获取对网络上任意位置实现的对象的引用。

应用程序或 applet 通过使用三个 init 方法之一将其自身初始化为 ORB，来访问 CORBA 环境。这三个方法中有两个使用下表中所示的属性（名称与值的关联）。

标准 Java CORBA 属性：
属性名 | 属性值
org.omg.CORBA.ORBClass | ORB 实现的类名称
org.omg.CORBA.ORBSingletonClass | 由 init() 返回的 ORB 的类名称

这些属性允许“插入”不同供应商的 ORB 实现。

在创建 ORB 实例时，使用以下标准搜索顺序来定位 ORB 实现的类名称：

  1. 检查 Applet 参数或应用程序字符串数组（如果有）
  2. 检查属性参数（如果有）
  3. 检查系统属性
  4. 检查位于 user.home 目录中的 orb.properties 文件（如果有）
  5. 检查位于 java.home/lib 目录中的 orb.properties 文件（如果有）
  6. 依靠硬编码 (hardcoded) 的默认行为（使用 Java IDL 实现）

注意，Java IDL 提供全功能 ORB 和单件 (Singleton) ORB 的默认实现。当没有为 init 方法提供任何参数时，返回默认单件 ORB。当为 init 方法提供了参数但没有指定 ORB 类时，返回 Java IDL ORB 实现。

以下代码段创建了一个使用默认 ORB 单件初始化的 ORB 对象。此 ORB 有一个受限制的实现，以防止恶意 applet 执行任何创建 typecode 以外的操作。称它为单件 ORB 是因为整个虚拟机中只有一个实例。

    ORB orb = ORB.init();

以下代码片段创建用于某个应用程序的 ORB 对象。参数 args 表示提供给应用程序的 main 方法的参数。因为该属性指定了 ORB 类为 "SomeORBImplementation"，所以将使用该 ORB 实现初始化新的 ORB。如果 p 为 null，并且参数没有指定 ORB 类，则使用默认 Java IDL 实现初始化新的 ORB。

    Properties p = new Properties();
    p.put("org.omg.CORBA.ORBClass", "SomeORBImplementation");
    ORB orb = ORB.init(args, p);

以下代码片段为作为第一个参数提供的 applet 创建 ORB 对象。如果给定 applet 没有指定 ORB 类，则将使用默认 Java IDL 实现初始化新的 ORB。

    ORB orb = ORB.init(myApplet, null);

可以在一个或多个 ORB 中初始化应用程序或 applet。ORB 初始化是进入 CORBA 环境的引导调用。

从以下版本开始：
JDK1.2

构造方法摘要
ORB()
方法摘要
void | connect(Object obj) 将给定 servant 对象（作为服务器实现类的实例的 Java 对象）连接到 ORB。
TypeCode | create_abstract_interface_tc(String id, String name) 为 IDL 抽象接口创建一个 TypeCode 对象。
abstract TypeCode | create_alias_tc(String id, String name, TypeCode original_type) 创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。
abstract Any | create_any() 创建一个 IDL Any 对象，初始化后该对象包含一个 kind 字段被设置为 TCKind.tc_null 的 Typecode 对象。
abstract TypeCode | create_array_tc(int length, TypeCode element_type) 创建一个表示 IDL array 的 TypeCode 对象。
DynAny | create_basic_dyn_any(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
abstract ContextList | create_context_list() 创建一个空的 ContextList 对象。
DynAny | create_dyn_any(Any value) 已过时。 使用新的 DynAnyFactory API 代替
DynArray | create_dyn_array(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynEnum | create_dyn_enum(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynSequence | create_dyn_sequence(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynStruct | create_dyn_struct(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynUnion | create_dyn_union(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
abstract TypeCode | create_enum_tc(String id, String name, String[] members) 创建一个表示 IDL enum 的 TypeCode 对象。
abstract Environment | create_environment() 创建一个 Environment 对象。
abstract ExceptionList | create_exception_list() 创建一个空的 ExceptionList 对象。
abstract TypeCode | create_exception_tc(String id, String name, StructMember[] members) 创建一个表示 IDL exception 的 TypeCode 对象。
TypeCode | create_fixed_tc(short digits, short scale) 为 IDL fixed 类型创建一个 TypeCode 对象。
abstract TypeCode | create_interface_tc(String id, String name) 创建一个表示 IDL interface 的 TypeCode 对象。
abstract NVList | create_list(int count) 为指定数量的 NamedValue 对象分配具有（可能）足够空间的 NVList。
abstract NamedValue | create_named_value(String s, Any any, int flags) 使用给定名称、值和参数模式标志创建一个 NamedValue 对象。
TypeCode | create_native_tc(String id, String name) 为 IDL native 类型创建一个 TypeCode 对象。
NVList | create_operation_list(Object oper) 创建一个 NVList，并使用给定 OperationDef 对象中所述操作的参数描述进行初始化。
abstract OutputStream | create_output_stream() 创建一个新的 org.omg.CORBA.portable.OutputStream，在执行方法调用期间，可在该输出流中对 IDL 方法参数进行编组。
Policy | create_policy(int type, Any val) 可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。
abstract TypeCode | create_recursive_sequence_tc(int bound, int offset) 已过时。 使用 create_recursive_tc 和 create_sequence_tc 的组合替代它
TypeCode | create_recursive_tc(String id) 创建一个递归 TypeCode 对象，在创建包含递归的 TypeCodes 期间，该对象充当具体 TypeCode 的占位符。
abstract TypeCode | create_sequence_tc(int bound, TypeCode element_type) 创建一个表示 IDL sequence 的 TypeCode 对象。
abstract TypeCode | create_string_tc(int bound) 创建一个表示有界 IDL string 的 TypeCode 对象。
abstract TypeCode | create_struct_tc(String id, String name, StructMember[] members) 创建一个表示 IDL struct 的 TypeCode 对象。
abstract TypeCode | create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members) 创建一个表示 IDL union 的 TypeCode 对象。
TypeCode | create_value_box_tc(String id, String name, TypeCode boxed_type) 为 IDL value box 类型创建一个 TypeCode 对象。
TypeCode | create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members) 为 IDL value 类型创建一个 TypeCode 对象。
abstract TypeCode | create_wstring_tc(int bound) 创建一个表示有界 IDL wstring (wide string) 的 TypeCode 对象。
void | destroy() 销毁 ORB，以便可以回收其资源。
void | disconnect(Object obj) 断开给定 servant 对象与 ORB 的连接。
Current | get_current() 已过时。 使用 resolve_initial_references。
abstract Context | get_default_context() 获取默认 Context 对象。
abstract Request | get_next_response() 获取已接收到响应的下一个 Request 实例。
abstract TypeCode | get_primitive_tc(TCKind tcKind) 检索表示给定基本 IDL 类型的 TypeCode 对象。
boolean | get_service_information(short service_type, ServiceInformationHolder service_info) 用来获取有关受此 ORB 支持的 CORBA 资源和服务的信息。
static ORB | init() 返回对象 ORB 单件。
static ORB | init(Applet app, Properties props) 为 applet 创建一个新的 ORB 实例。
static ORB | init(String[] args, Properties props) 为独立的应用程序创建一个新的 ORB 实例。
abstract String[] | list_initial_services() 返回最初可用 CORBA 对象引用（比如 "NameService" 和 "InterfaceRepository"）的列表。
abstract String | object_to_string(Object obj) 将给定 CORBA 对象引用转换为字符串。
void | perform_work() 如果该操作由主线程调用，则执行与实现有关的单元操作。
abstract boolean | poll_next_response() 找出是否已经响应了延迟的（异步）调用。
abstract Object | resolve_initial_references(String object_name) 根据可用初始服务名称集解析特定对象引用。
void | run() 在 ORB 已完成关闭过程前（该过程始于某些线程调用 shutdown 时），此操作将一直阻塞当前线程。
abstract void | send_multiple_requests_deferred(Request[] req) 异步发送多个动态 (DII) 请求。
abstract void | send_multiple_requests_oneway(Request[] req) 异步发送多个动态 (DII) 请求，并且不期望任何响应。
protected abstract void | set_parameters(Applet app, Properties props) 允许使用给定 applet 和参数初始化 ORB 实现。
protected abstract void | set_parameters(String[] args, Properties props) 允许使用给定的参数和属性初始化 ORB 实现。
void | shutdown(boolean wait_for_completion) 指示关闭 ORB，这将导致关闭所有对象适配器，以准备销毁。
abstract Object | string_to_object(String str) 将方法 object_to_string 生成的字符串转换回 CORBA 对象引用。
boolean | work_pending() 如果 ORB 需要主线程来执行某些操作，则返回 true；如果 ORB 不需要主线程，则返回 false。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ORB

public ORB()
方法详细信息

init

public static ORB init()
返回对象 ORB 单件。此方法总是返回相同的 ORB 实例，该实例是由 org.omg.CORBA.ORBSingletonClass 系统属性所描述的类的实例。

无参数的 init 方法主要用作 TypeCode 对象的工厂，Helper 类使用该对象来实现 type 方法。还可以使用该方法来创建用于描述 union 标签的 Any 对象（作为创建用于 union 的 TypeCode 对象的一部分）。

此方法并不适合由 applet 使用，如果在 applet 环境中调用此方法，则该方法返回的 ORB 是受限制的，即它只能用作 TypeCode 对象的工厂。该方法生成的任何 TypeCode 对象都可以在不受信任的 applet 之间安全地共享。

如果某一 ORB 是使用此方法从 applet 创建的，则将抛出系统异常（如果调用的是用来创建 TypeCode 对象的那些方法以外的方法）。

返回：
单件 ORB

init

public static ORB init(String[] args,
                       Properties props)
为独立的应用程序创建一个新的 ORB 实例。此方法只能从应用程序调用，每次调用该方法都会返回一个新的全功能 ORB 对象。

参数：
args - 应用程序的 main 方法的命令行参数，可以为 null
props - 特定于应用程序的属性，可以为 null
返回：
新创建的 ORB 实例

init

public static ORB init(Applet app,
                       Properties props)
为 applet 创建一个新的 ORB 实例。此方法只能从 applet 调用，每次调用该方法都会返回一个新的全功能 ORB 对象。

参数：
app - applet，可以为 null
props - 特定于 applet 的属性，可以为 null
返回：
新创建的 ORB 实例

set_parameters

protected abstract void set_parameters(String[] args,
                                       Properties props)
允许使用给定的参数和属性初始化 ORB 实现。此方法只能在应用程序中使用，由子类 ORB 实现来实现，并由适当的 init 方法调用，以传入其参数。

参数：
args - 应用程序的 main 方法的命令行参数，可以为 null
props - 特定于应用程序的属性，可以为 null

set_parameters

protected abstract void set_parameters(Applet app,
                                       Properties props)
允许使用给定 applet 和参数初始化 ORB 实现。此方法只能在 applet 中使用，由子类 ORB 实现来实现，并由适当的 init 方法调用，以传入其参数。

参数：
app - applet，可以为 null
props - 特定于 applet 的属性，可以为 null

connect

public void connect(Object obj)
将给定 servant 对象（作为服务器实现类的实例的 Java 对象）连接到 ORB。servant 类必须扩展对应于服务器所支持的接口的 ImplBase 类。因此 servant 必须是一个 CORBA 对象引用，并且必须继承自 org.omg.CORBA.Object。由用户创建的 servant 可在调用 connect 方法之后开始接收远程调用。如果将 servant 作为非本地对象上的 IDL 方法调用中的 IDL 参数传递，也就是说，如果对 servant 对象进行编组并将它发送到进程地址空间以外，则 servant 也可以自动隐式地连接到 ORB。

当 servant 对象已经连接到 ORB 时，调用 connect 方法没有任何效果。

OMG 推荐使用可移植对象适配器 API 取代此方法。

参数：
obj - servant 对象引用

destroy

public void destroy()
销毁 ORB，以便可以回收其资源。对已销毁的 ORB 引用调用任何操作都将抛出 OBJECT_NOT_EXIST 异常。一旦已销毁 ORB，使用相同的 ORBid 再次调用 init 将返回对新建 ORB 的引用。

如果对尚未关闭的 ORB 调用 destroy，则在销毁该 ORB 之前将启动关闭进程，并且该方法将一直阻塞到关闭 ORB 为止。
如果应用程序在当前正服务于某个调用的线程中调用 destroy，则将抛出 BAD_INV_ORDER 系统异常，并带有 OMG 次要代码 (minor code) 3，因为阻塞将导致死锁。

为获取最大的可移植性并避免资源泄漏，应用程序应该总是在退出前对所有 ORB 实例调用 shutdown 和 destroy。

抛出：
BAD_INV_ORDER - 如果当前线程正服务于某一调用

disconnect

public void disconnect(Object obj)
断开给定 servant 对象与 ORB 的连接。在此方法返回之后，ORB 将拒绝对已断开 servant 的传入远程请求，并将异常 org.omg.CORBA.OBJECT_NOT_EXIST 发送回远程客户端。因此，从远程客户端看来，该对象似乎已被销毁。不过要注意的是，使用 servant 直接发布的本地请求不通过 ORB，因此，这些请求将继续由 servant 处理。

如果 servant 没有连接到 ORB，则调用 disconnect 方法没有任何效果。

OMG 推荐使用可移植对象适配器 API 取代此方法。

参数：
obj - 将与 ORB 断开连接的 servant 对象

list_initial_services

public abstract String[] list_initial_services()
返回最初可用 CORBA 对象引用（比如 "NameService" 和 "InterfaceRepository"）的列表。

返回：
String 对象数组，这些对象表示此 ORB 中最初可用 CORBA 服务的对象引用

resolve_initial_references

public abstract Object resolve_initial_references(String object_name)
                                           throws InvalidName
根据可用初始服务名称集解析特定对象引用。

参数：
object_name - 字符串形式的初始服务名称
返回：
与给定名称关联的对象引用
抛出：
InvalidName - 如果给定名称不与已知服务关联

object_to_string

public abstract String object_to_string(Object obj)
将给定 CORBA 对象引用转换为字符串。注意，此字符串的格式由 IIOP 预先定义，允许将不同 ORB 生成的字符串转换回对象引用。

可以使用能够操作 String 对象的任何方式存储所得 String 对象或与它们进行通信。

参数：
obj - 将字符串化的对象引用
返回：
表示对象引用的字符串

string_to_object

public abstract Object string_to_object(String str)
将方法 object_to_string 生成的字符串转换回 CORBA 对象引用。

参数：
str - 将转换回对象引用的字符串。它必须是使用 object_to_string 方法将对象引用转换所得到的字符串。
返回：
对象引用。

create_list

public abstract NVList create_list(int count)
为指定数量的 NamedValue 对象分配具有（可能）足够空间的 NVList。注意，指定的大小只是一个有助于存储分配的提示，并不表示列表的最大大小。

参数：
count - 要分配空间的 NamedValue 对象的建议数量
返回：
新创建的 NVList
另请参见：
NVList

create_operation_list

public NVList create_operation_list(Object oper)
创建一个 NVList，并使用给定 OperationDef 对象中所述操作的参数描述进行初始化。此 OperationDef 对象是从接口存储库 (Interface Repository) 中获得的。所返回 NVList 对象中参数的顺序与原始 IDL 操作定义中的顺序相同，这使得能够在动态调用请求中使用该列表。

参数：
oper - 将用来创建列表的 OperationDef 对象
返回：
新创建的 NVList 对象，它包含对给定 OperationDef 对象中所述方法的参数描述
另请参见：
NVList

create_named_value

public abstract NamedValue create_named_value(String s,
                                              Any any,
                                              int flags)
使用给定名称、值和参数模式标志创建一个 NamedValue 对象。

NamedValue 对象可用作 (1) 参数或返回值，或者 (2) 上下文属性。它可以单独使用，也可以作为 NVList 对象中的一个元素使用。

参数：
s - NamedValue 对象的名称
any - 将插入 NamedValue 对象的 Any 值
flags - NamedValue 的参数模式标志：ARG_IN.value、ARG_OUT.value 或 ARG_INOUT.value 之一。
返回：
新创建的 NamedValue 对象
另请参见：
NamedValue

create_exception_list

public abstract ExceptionList create_exception_list()
创建一个空的 ExceptionList 对象。

返回：
新创建的 ExceptionList 对象

create_context_list

public abstract ContextList create_context_list()
创建一个空的 ContextList 对象。

返回：
新创建的 ContextList 对象
另请参见：
ContextList, Context

get_default_context

public abstract Context get_default_context()
获取默认 Context 对象。

返回：
默认 Context 对象
另请参见：
Context

create_environment

public abstract Environment create_environment()
创建一个 Environment 对象。

返回：
新创建的 Environment 对象
另请参见：
Environment

create_output_stream

public abstract OutputStream create_output_stream()
创建一个新的 org.omg.CORBA.portable.OutputStream，在执行方法调用期间，可在该输出流中对 IDL 方法参数进行编组。

返回：
新创建的 org.omg.CORBA.portable.OutputStream 对象

send_multiple_requests_oneway

public abstract void send_multiple_requests_oneway(Request[] req)
异步发送多个动态 (DII) 请求，并且不期望任何响应。注意，不保证单向调用可到达服务器。

参数：
req - 请求对象数组

send_multiple_requests_deferred

public abstract void send_multiple_requests_deferred(Request[] req)
异步发送多个动态 (DII) 请求。

参数：
req - Request 对象数组

poll_next_response

public abstract boolean poll_next_response()
找出是否已经响应了延迟的（异步）调用。

返回：
如果获得响应，则返回 true；否则返回 false。

get_next_response

public abstract Request get_next_response()
                                   throws WrongTransaction
获取已接收到响应的下一个 Request 实例。

返回：
已获得响应的下一个 Request 对象
抛出：
WrongTransaction - 如果在不同于发送原始请求的事务处理域中调用 get_next_response 方法。有关详细信息，请参阅 OMG 事务服务 (Transaction Service) 规范。

get_primitive_tc

public abstract TypeCode get_primitive_tc(TCKind tcKind)
检索表示给定基本 IDL 类型的 TypeCode 对象。

参数：
tcKind - 对应于所需基本类型的 TCKind 实例
返回：
所请求的 TypeCode 对象

create_struct_tc

public abstract TypeCode create_struct_tc(String id,
                                          String name,
                                          StructMember[] members)
创建一个表示 IDL struct 的 TypeCode 对象。使用给定 id、名称和成员初始化该 TypeCode 对象。

参数：
id - struct 的存储库 id
name - struct 的名称
members - 描述 struct 成员的数组
返回：
描述 IDL struct 的新建 TypeCode 对象

create_union_tc

public abstract TypeCode create_union_tc(String id,
                                         String name,
                                         TypeCode discriminator_type,
                                         UnionMember[] members)
创建一个表示 IDL union 的 TypeCode 对象。使用给定 id、名称、鉴别符类型和成员初始化该 TypeCode 对象。

参数：
id - union 的存储库 id
name - union 的名称
discriminator_type - union 鉴别符的类型
members - 描述 union 成员的数组
返回：
描述 IDL union 的新建 TypeCode 对象

create_enum_tc

public abstract TypeCode create_enum_tc(String id,
                                        String name,
                                        String[] members)
创建一个表示 IDL enum 的 TypeCode 对象。使用给定 id、名称和成员初始化该 TypeCode 对象。

参数：
id - enum 的存储库 id
name - enum 的名称
members - 描述 enum 成员的数组
返回：
描述 IDL enum 的新建 TypeCode 对象

create_alias_tc

public abstract TypeCode create_alias_tc(String id,
                                         String name,
                                         TypeCode original_type)
创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。使用给定 id、名称和原始类型初始化该 TypeCode 对象。

参数：
id - 别名的存储库 id
name - 别名的名称
original_type - 描述原始类型（该值是其别名）的 TypeCode 对象
返回：
描述 IDL alias 的新建 TypeCode 对象

create_exception_tc

public abstract TypeCode create_exception_tc(String id,
                                             String name,
                                             StructMember[] members)
创建一个表示 IDL exception 的 TypeCode 对象。使用给定 id、名称和成员初始化该 TypeCode 对象。

参数：
id - exception 的存储库 id
name - exception 的名称
members - 描述 exception 成员的数组
返回：
描述 IDL exception 的新建 TypeCode 对象

create_interface_tc

public abstract TypeCode create_interface_tc(String id,
                                             String name)
创建一个表示 IDL interface 的 TypeCode 对象。使用给定 id 和名称初始化该 TypeCode 对象。

参数：
id - 接口的存储库 id
name - 接口的名称
返回：
描述 IDL interface 的新建 TypeCode 对象

create_string_tc

public abstract TypeCode create_string_tc(int bound)
创建一个表示有界 IDL string 的 TypeCode 对象。使用给定 bound 初始化该 TypeCode 对象，bound 表示字符串的最大长度。0 指示此类型代码描述的字符串是无界的。

参数：
bound - string 的范围，不能为负
返回：
描述有界 IDL string 的新建 TypeCode 对象
抛出：
BAD_PARAM - 如果 bound 为负值

create_wstring_tc

public abstract TypeCode create_wstring_tc(int bound)
创建一个表示有界 IDL wstring (wide string) 的 TypeCode 对象。使用给定 bound 初始化该 TypeCode 对象，bound 表示宽字符串的最大长度。0 指示此类型代码描述的字符串是无界的。

参数：
bound - wstring 的范围，不能为负
返回：
描述有界 IDL wstring 的新建 TypeCode 对象
抛出：
BAD_PARAM - 如果 bound 为负值

create_sequence_tc

public abstract TypeCode create_sequence_tc(int bound,
                                            TypeCode element_type)
创建一个表示 IDL sequence 的 TypeCode 对象。使用给定 bound 和元素类型初始化该 TypeCode 对象。

参数：
bound - sequence 的范围，如果无界，则该值为 0
element_type - 描述 sequence 中所包含元素的 TypeCode 对象
返回：
描述 IDL sequence 的新建 TypeCode 对象

create_recursive_sequence_tc

@Deprecated
public abstract TypeCode create_recursive_sequence_tc(int bound,
                                                                 int offset)
已过时。 使用 create_recursive_tc 和 create_sequence_tc 的组合替代它

创建一个表示递归 IDL sequence 的 TypeCode 对象。

对于以下代码片段中的 IDL struct Node，用来创建其序列的 offset 参数将是 1：

    Struct Node {
        long value;
        Sequence <Node> subnodes;
    };

参数：
bound - 序列范围，如果无界，则该值为 0
offset - 描述此序列元素的封闭 TypeCode 对象的索引
返回：
描述递归序列的 TypeCode 对象
另请参见：
create_recursive_tc, create_sequence_tc

create_array_tc

public abstract TypeCode create_array_tc(int length,
                                         TypeCode element_type)
创建一个表示 IDL array 的 TypeCode 对象。使用给定长度和元素类型初始化该 TypeCode 对象。

参数：
length - array 的长度
element_type - 描述 array 中所包含元素的类型的 TypeCode 对象
返回：
描述 IDL array 的新建 TypeCode 对象

create_native_tc

public TypeCode create_native_tc(String id,
                                 String name)
为 IDL native 类型创建一个 TypeCode 对象。

参数：
id - native 类型的逻辑 id。
name - native 类型的名称。
返回：
所请求的 TypeCode。

create_abstract_interface_tc

public TypeCode create_abstract_interface_tc(String id,
                                             String name)
为 IDL 抽象接口创建一个 TypeCode 对象。

参数：
id - 抽象接口类型的逻辑 id。
name - 抽象接口类型的名称。
返回：
所请求的 TypeCode。

create_fixed_tc

public TypeCode create_fixed_tc(short digits,
                                short scale)
为 IDL fixed 类型创建一个 TypeCode 对象。

参数：
digits - 指定数字中总的小数位数，必须在从 1 到 31 的闭区间内。
scale - 指定小数点的位置。
返回：
所请求的 TypeCode。

create_value_tc

public TypeCode create_value_tc(String id,
                                String name,
                                short type_modifier,
                                TypeCode concrete_base,
                                ValueMember[] members)
为 IDL value 类型创建一个 TypeCode 对象。concrete_base 参数是用于 valuetype（将为其创建 TypeCode）直接具体 valuetype 基的 TypeCode。如果 valuetype 没有 concrete 基，则该值为 null。

参数：
id - 值类型的逻辑 id。
name - 值类型的名称。
type_modifier - 以下值类型修饰符常量之一：VM_NONE、VM_CUSTOM、VM_ABSTRACT 或 VM_TRUNCATABLE
concrete_base - 描述具体 valuetype 基的 TypeCode 对象
members - 包含 value 类型成员的数组
返回：
所请求的 TypeCode

create_recursive_tc

public TypeCode create_recursive_tc(String id)
创建一个递归 TypeCode 对象，在创建包含递归的 TypeCodes 期间，该对象充当具体 TypeCode 的占位符。id 参数指定类型（递归 TypeCode 将充当该类型的占位符）的存储库 id。一旦将递归 TypeCode 正确地嵌入到对应于指定存储库 id 的封闭 TypeCode，该 TypeCode 的作用将与普通 TypeCode 一样。如果在将递归 TypeCode 嵌入封闭 TypeCode 之前对该 TypeCode 执行调用操作，则将导致 BAD_TYPECODE 异常。

例如，以下 IDL 类型声明中包含递归：

    Struct Node {
        Sequence<Node> subnodes;
    };

要为 struct Node 创建 TypeCode，应调用 TypeCode 创建操作，如下所示：

 String nodeID = "IDL:Node:1.0";
 TypeCode recursiveSeqTC = orb.create_sequence_tc(0, orb.create_recursive_tc(nodeID));
 StructMember[] members = { new StructMember("subnodes", recursiveSeqTC, null) };
 TypeCode structNodeTC = orb.create_struct_tc(nodeID, "Node", members);

还要注意的是，以下是一个非法 IDL 类型声明：

    Struct Node {
        Node next;
    };

递归类型只能出现在可以为空的序列中。当在 Any 数组中传输 struct 数据时，可以通过这种方式避免编码问题。

参数：
id - 所引用类型的逻辑 id
返回：
所请求的 TypeCode

create_value_box_tc

public TypeCode create_value_box_tc(String id,
                                    String name,
                                    TypeCode boxed_type)
为 IDL value box 类型创建一个 TypeCode 对象。

参数：
id - 值类型的逻辑 id
name - 值类型的名称
boxed_type - 该类型的 TypeCode
返回：
所请求的 TypeCode

create_any

public abstract Any create_any()
创建一个 IDL Any 对象，初始化后该对象包含一个 kind 字段被设置为 TCKind.tc_null 的 Typecode 对象。

返回：
新创建的 Any 对象

get_current

@Deprecated
public Current get_current()
已过时。 使用 resolve_initial_references。

检索 Current 对象。Current 接口用于管理由服务使用的特定于线程的信息（比如事务处理和安全）。

返回：
新创建的 Current 对象
另请参见：
CORBA 包中有关未实现特性的注释

run

public void run()
在 ORB 已完成关闭过程前（该过程始于某些线程调用 shutdown 时），此操作将一直阻塞当前线程。此方法可由关闭 ORB 时获取全部通知的多个线程使用。

shutdown

public void shutdown(boolean wait_for_completion)
指示关闭 ORB，这将导致关闭所有对象适配器，以准备销毁。
如果 wait_for_completion 参数为 true，则在所有 ORB 处理（包括当前执行请求、对象释放和其他对象适配器操作的处理）已完成之前，此操作一直受阻塞。如果应用程序在当前正服务于某个调用的线程中执行该操作，则将抛出 BAD_INV_ORDER 系统异常，并带有 OMG 次要代码 3，因为阻塞将导致死锁。
如果 wait_for_completion 参数为 FALSE，则可能在返回时还没完成关闭。

当 ORB 处于关闭过程中时，ORB 操作照常，继续为传入和传出的请求服务，直到所有请求完成为止。一旦 ORB 已关闭，则只能对该 ORB（或从中获得的任何对象引用）调用对象引用管理操作。应用程序还可以对 ORB 本身调用 destroy 操作。调用任何其他操作将导致抛出 BAD_INV_ORDER 系统异常，并带有 OMG 次要代码 4。

ORB.run 方法将在调用 shutdown 之后返回。

参数：
wait_for_completion - 如果调用在完成关闭之前应一直受阻塞，则该参数为 true；如果该调用应立即返回，则该参数为 false
抛出：
BAD_INV_ORDER - 如果当前线程正服务于某一调用。

work_pending

public boolean work_pending()
如果 ORB 需要主线程来执行某些操作，则返回 true；如果 ORB 不需要主线程，则返回 false。

返回：
如果有些操作正处于挂起状态，则返回 true，这意味着 ORB 需要主线程来执行某些操作；如果没有操作处于挂起状态，从而 ORB 不需要主线程，则返回 false

perform_work

public void perform_work()
如果该操作由主线程调用，则执行与实现有关的单元操作。否则不执行任何操作。可以组合使用 work_pending 和 perform_work 方法来实现简单的轮询循环，该循环在 ORB 和其他活动中多路传输主线程。

get_service_information

public boolean get_service_information(short service_type,
                                       ServiceInformationHolder service_info)
用来获取有关受此 ORB 支持的 CORBA 资源和服务的信息。将为其请求信息的服务类型以 in 参数 service_type 的形式传入，该参数值由 CORBA 模块中的常量定义。如果服务信息可用于该类型，则在 out 参数 service_info 中返回它，并且该操作将返回 true 值。如果对于所请求服务类型没有信息可用，则该操作返回 false（即此 ORB 不支持该服务）。

参数：
service_type - 一个 short 值，指示将为其请求信息的服务类型
service_info - 一个 ServiceInformationHolder 对象，该对象将保存此方法生成的 ServiceInformation 对象
返回：
如果服务信息可用于 service_type，则返回 true；如果对于所请求的服务类型没有可用信息，则返回 false
另请参见：
CORBA 包中有关未实现特性的注释

create_dyn_any

@Deprecated
public DynAny create_dyn_any(Any value)
已过时。 使用新的 DynAnyFactory API 代替

根据给定 Any 对象创建一个新的 DynAny 对象。

参数：
value - 据以创建新 DynAny 对象的 Any 对象
返回：
根据给定 Any 对象创建的新 DynAny 对象
另请参见：
CORBA 包中有关未实现特性的注释

create_basic_dyn_any

@Deprecated
public DynAny create_basic_dyn_any(TypeCode type)
                            throws InconsistentTypeCode
已过时。 使用新的 DynAnyFactory API 代替

根据给定 TypeCode 对象创建基本 DynAny 对象。

参数：
type - 据以创建新 DynAny 对象的 TypeCode 对象
返回：
根据给定 TypeCode 对象创建新的 DynAny 对象
抛出：
InconsistentTypeCode - 如果给定 TypeCode 对象与操作不一致。
另请参见：
CORBA 包中有关未实现特性的注释

create_dyn_struct

@Deprecated
public DynStruct create_dyn_struct(TypeCode type)
                            throws InconsistentTypeCode
已过时。 使用新的 DynAnyFactory API 代替

根据给定 TypeCode 对象创建新的 DynStruct 对象。

参数：
type - 据以创建新的 DynStruct 对象的 TypeCode 对象
返回：
根据给定 TypeCode 对象创建新的 DynStruct 对象
抛出：
InconsistentTypeCode - 如果给定 TypeCode 对象与操作不一致。
另请参见：
CORBA 包中有关未实现特性的注释

create_dyn_sequence

@Deprecated
public DynSequence create_dyn_sequence(TypeCode type)
                                throws InconsistentTypeCode
已过时。 使用新的 DynAnyFactory API 代替

根据给定 TypeCode 对象创建新的 DynSequence 对象。

参数：
type - 据以创建新 DynSequence 对象的 TypeCode 对象
返回：
根据给定 TypeCode 对象创建新的 DynSequence 对象
抛出：
InconsistentTypeCode - 如果给定 TypeCode 对象与操作不一致。
另请参见：
CORBA 包中有关未实现特性的注释

create_dyn_array

@Deprecated
public DynArray create_dyn_array(TypeCode type)
                          throws InconsistentTypeCode
已过时。 使用新的 DynAnyFactory API 代替

根据给定 TypeCode 对象创建新的 DynArray 对象。

参数：
type - 据以创建新 DynArray 对象的 TypeCode 对象
返回：
根据给定 TypeCode 对象创建新的 DynArray 对象
抛出：
InconsistentTypeCode - 如果给定 TypeCode 对象与操作不一致。
另请参见：
CORBA 包中有关未实现特性的注释

create_dyn_union

@Deprecated
public DynUnion create_dyn_union(TypeCode type)
                          throws InconsistentTypeCode
已过时。 使用新的 DynAnyFactory API 代替

根据给定 TypeCode 对象创建新的 DynUnion 对象。

参数：
type - 据以创建新 DynUnion 对象的 TypeCode 对象
返回：
根据给定 TypeCode 对象创建新的 DynUnion 对象
抛出：
InconsistentTypeCode - 如果给定 TypeCode 对象与操作不一致。
另请参见：
CORBA 包中有关未实现特性的注释

create_dyn_enum

@Deprecated
public DynEnum create_dyn_enum(TypeCode type)
                        throws InconsistentTypeCode
已过时。 使用新的 DynAnyFactory API 代替

根据给定 TypeCode 对象创建新的 DynEnum 对象。

参数：
type - 据以创建新 DynEnum 对象的 TypeCode 对象
返回：
根据给定 TypeCode 对象创建新的 DynEnum 对象
抛出：
InconsistentTypeCode - 如果给定 TypeCode 对象与操作不一致。
另请参见：
CORBA 包中有关未实现特性的注释

create_policy

public Policy create_policy(int type,
                            Any val)
                     throws PolicyError
可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。如果 create_policy 因为不能解释所请求的类型和策略内容而无法实例化新的 Policy 对象，则它将引发带有恰当原因的 PolicyError 异常。

参数：
type - 要创建的策略对象的 PolicyType
val - 将用来设置被创建的 Policy 对象初始状态的值
返回：
对新建 Policy 对象的引用，该对象的类型由 type 参数指定，并被初始化为 val 参数指定的状态
抛出：
org.omg.CORBA.PolicyError - 当所请求的策略不受支持，或所请求的策略初始状态不受支持时。
PolicyError
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParameterMode (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ParameterMode

java.lang.Object
    继承者  org.omg.CORBA.ParameterMode
所有已实现的接口：
Serializable, IDLEntity
public class ParameterMode
extends Object
implements IDLEntity

Parameter 参数模式的枚举。可能的值：

  • PARAM_IN - 表示一个 "in" 参数。
  • PARAM_OUT - 表示一个 "out" 参数。
  • PARAM_INOUT - 表示一个 "inout" 参数。

字段摘要
static int | _PARAM_IN
static int | _PARAM_INOUT
static int | _PARAM_OUT
static ParameterMode | PARAM_IN
static ParameterMode | PARAM_INOUT
static ParameterMode | PARAM_OUT
构造方法摘要
protected ParameterMode(int value)
方法摘要
static ParameterMode | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_PARAM_IN

public static final int _PARAM_IN
另请参见：
常量字段值

PARAM_IN

public static final ParameterMode PARAM_IN

_PARAM_OUT

public static final int _PARAM_OUT
另请参见：
常量字段值

PARAM_OUT

public static final ParameterMode PARAM_OUT

_PARAM_INOUT

public static final int _PARAM_INOUT
另请参见：
常量字段值

PARAM_INOUT

public static final ParameterMode PARAM_INOUT
构造方法详细信息

ParameterMode

protected ParameterMode(int value)
方法详细信息

value

public int value()

from_int

public static ParameterMode from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParameterModeHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ParameterModeHelper

java.lang.Object
    继承者  org.omg.CORBA.ParameterModeHelper

public abstract class ParameterModeHelper
extends Object

Parameter 参数模式的枚举。可能的值：

  • PARAM_IN - 表示一个 "in" 参数。
  • PARAM_OUT - 表示一个 "out" 参数。
  • PARAM_INOUT - 表示一个 "inout" 参数。

构造方法摘要
ParameterModeHelper()
方法摘要
static ParameterMode | extract(Any a)
static String | id()
static void | insert(Any a, ParameterMode that)
static ParameterMode | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ParameterMode value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ParameterModeHelper

public ParameterModeHelper()
方法详细信息

insert

public static void insert(Any a,
                          ParameterMode that)

extract

public static ParameterMode extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ParameterMode read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ParameterMode value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParameterModeHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ParameterModeHolder

java.lang.Object
    继承者  org.omg.CORBA.ParameterModeHolder
所有已实现的接口：
Streamable
public final class ParameterModeHolder
extends Object
implements Streamable

Parameter 参数模式的枚举。可能的值：

  • PARAM_IN - 表示一个 "in" 参数。
  • PARAM_OUT - 表示一个 "out" 参数。
  • PARAM_INOUT - 表示一个 "inout" 参数。

字段摘要
 ParameterMode value
构造方法摘要
ParameterModeHolder()
ParameterModeHolder(ParameterMode initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public ParameterMode value
构造方法详细信息

ParameterModeHolder

public ParameterModeHolder()

ParameterModeHolder

public ParameterModeHolder(ParameterMode initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PERSIST_STORE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PERSIST_STORE

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.PERSIST_STORE
所有已实现的接口：
Serializable
public final class PERSIST_STORE
extends SystemException

此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
PERSIST_STORE()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 PERSIST_STORE 异常。
PERSIST_STORE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 PERSIST_STORE 异常。
PERSIST_STORE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 PERSIST_STORE 异常。
PERSIST_STORE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 PERSIST_STORE 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PERSIST_STORE

public PERSIST_STORE()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 PERSIST_STORE 异常。

PERSIST_STORE

public PERSIST_STORE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 PERSIST_STORE 异常。

参数：
s - 包含详细消息的 String

PERSIST_STORE

public PERSIST_STORE(int minor,
                     CompletionStatus completed)
使用指定次要代码和完成状态构造一个 PERSIST_STORE 异常。

参数：
minor - 次要代码
completed - 完成状态

PERSIST_STORE

public PERSIST_STORE(String s,
                     int minor,
                     CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 PERSIST_STORE 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Policy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 Policy

所有超级接口：
IDLEntity, Object, PolicyOperations, Serializable
所有已知子接口：
IdAssignmentPolicy, IdUniquenessPolicy, ImplicitActivationPolicy, LifespanPolicy, RequestProcessingPolicy, ServantRetentionPolicy, ThreadPolicy
所有已知实现类：
_PolicyStub
public interface Policy
extends PolicyOperations, Object, IDLEntity

派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。此信息是使用从 CORBA 模块中定义的 Policy 接口派生的接口以结构化方式访问的。CORBA 服务可以有选择地使用此方法的访问操作选项。尤其是安全服务 (Security Service)，它可以使用此技术将安全策略 (Security Policy) 与系统中的对象相关。IDL-to-Java 编译器生成的接口。org/omg/CORBA/Policy.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20

方法摘要
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyError (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.PolicyError
所有已实现的接口：
Serializable, IDLEntity
public final class PolicyError
extends UserException

发生策略错误时抛出的用户异常。PolicyError 异常可能包含在 org.omg.CORBA 包中定义的以下策略错误原因代码之一：BAD_POLICY、BAD_POLICY_TYPE、BAD_POLICY_VALUE、UNSUPPORTED_POLICY 和 UNSUPPORTED_POLICY_VALUE。

字段摘要
 short reason
抛出 PolicyError 异常的原因。
构造方法摘要
PolicyError()
使用空原因代码和空原因详细消息构造一个默认 PolicyError 用户异常。
PolicyError(short __reason)
构造一个 PolicyError 用户异常，并使用给定原因代码和空原因详细消息初始化。
PolicyError(String reason_string, short __reason)
构造一个 PolicyError 用户异常，并使用给定原因详细消息和原因代码初始化。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

reason

public short reason
抛出 PolicyError 异常的原因。

构造方法详细信息

PolicyError

public PolicyError()
使用空原因代码和空原因详细消息构造一个默认 PolicyError 用户异常。

PolicyError

public PolicyError(short __reason)
构造一个 PolicyError 用户异常，并使用给定原因代码和空原因详细消息初始化。

参数：
__reason - 原因代码。

PolicyError

public PolicyError(String reason_string,
                   short __reason)
构造一个 PolicyError 用户异常，并使用给定原因详细消息和原因代码初始化。

参数：
reason_string - 原因详细消息。
__reason - 原因代码。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyErrorCodeHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyErrorCodeHelper

java.lang.Object
    继承者  org.omg.CORBA.PolicyErrorCodeHelper

public abstract class PolicyErrorCodeHelper
extends Object

封装 Policy 无效的原因。

另请参见：
PolicyError

构造方法摘要
PolicyErrorCodeHelper()
方法摘要
static short | extract(Any a)
static String | id()
static void | insert(Any a, short that)
static short | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PolicyErrorCodeHelper

public PolicyErrorCodeHelper()
方法详细信息

insert

public static void insert(Any a,
                          short that)

extract

public static short extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyErrorHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyErrorHelper

java.lang.Object
    继承者  org.omg.CORBA.PolicyErrorHelper

public abstract class PolicyErrorHelper
extends Object

抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。

构造方法摘要
PolicyErrorHelper()
方法摘要
static PolicyError | extract(Any a)
static String | id()
static void | insert(Any a, PolicyError that)
static PolicyError | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, PolicyError value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PolicyErrorHelper

public PolicyErrorHelper()
方法详细信息

insert

public static void insert(Any a,
                          PolicyError that)

extract

public static PolicyError extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static PolicyError read(InputStream istream)

write

public static void write(OutputStream ostream,
                         PolicyError value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyErrorHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyErrorHolder

java.lang.Object
    继承者  org.omg.CORBA.PolicyErrorHolder
所有已实现的接口：
Streamable
public final class PolicyErrorHolder
extends Object
implements Streamable

抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。

字段摘要
 PolicyError value
构造方法摘要
PolicyErrorHolder()
PolicyErrorHolder(PolicyError initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public PolicyError value
构造方法详细信息

PolicyErrorHolder

public PolicyErrorHolder()

PolicyErrorHolder

public PolicyErrorHolder(PolicyError initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyHelper

java.lang.Object
    继承者  org.omg.CORBA.PolicyHelper

public abstract class PolicyHelper
extends Object

Policy 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/PolicyHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20

构造方法摘要
PolicyHelper()
方法摘要
static Policy | extract(Any a)
static String | id()
static void | insert(Any a, Policy that)
static Policy | narrow(Object obj)
static Policy | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Policy value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PolicyHelper

public PolicyHelper()
方法详细信息

insert

public static void insert(Any a,
                          Policy that)

extract

public static Policy extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Policy read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Policy value)

narrow

public static Policy narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyHolder

java.lang.Object
    继承者  org.omg.CORBA.PolicyHolder
所有已实现的接口：
Streamable
public final class PolicyHolder
extends Object
implements Streamable

Policy 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/PolicyHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20

字段摘要
 Policy value
构造方法摘要
PolicyHolder()
PolicyHolder(Policy initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Policy value
构造方法详细信息

PolicyHolder

public PolicyHolder()

PolicyHolder

public PolicyHolder(Policy initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyListHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyListHelper

java.lang.Object
    继承者  org.omg.CORBA.PolicyListHelper

public abstract class PolicyListHelper
extends Object

PolicyList 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/PolicyListHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:21

构造方法摘要
PolicyListHelper()
方法摘要
static Policy[] | extract(Any a)
static String | id()
static void | insert(Any a, Policy[] that)
static Policy[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Policy[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PolicyListHelper

public PolicyListHelper()
方法详细信息

insert

public static void insert(Any a,
                          Policy[] that)

extract

public static Policy[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Policy[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Policy[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyListHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyListHolder

java.lang.Object
    继承者  org.omg.CORBA.PolicyListHolder
所有已实现的接口：
Streamable
public final class PolicyListHolder
extends Object
implements Streamable

PolicyList 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/PolicyListHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:21

字段摘要
 Policy[] value
构造方法摘要
PolicyListHolder()
PolicyListHolder(Policy[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Policy[] value
构造方法详细信息

PolicyListHolder

public PolicyListHolder()

PolicyListHolder

public PolicyListHolder(Policy[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 PolicyOperations

所有已知子接口：
IdAssignmentPolicy, IdAssignmentPolicyOperations, IdUniquenessPolicy, IdUniquenessPolicyOperations, ImplicitActivationPolicy, ImplicitActivationPolicyOperations, LifespanPolicy, LifespanPolicyOperations, Policy, RequestProcessingPolicy, RequestProcessingPolicyOperations, ServantRetentionPolicy, ServantRetentionPolicyOperations, ThreadPolicy, ThreadPolicyOperations
所有已知实现类：
_PolicyStub
public interface PolicyOperations

提供针对某一 Policy 对象的操作。

方法摘要
Policy | copy() 返回 Policy 对象的副本。
void | destroy() 销毁 Policy 对象。
int | policy_type() 返回对应于策略对象类型的常量值。

方法详细信息

policy_type

int policy_type()
返回对应于策略对象类型的常量值。策略对象的值由 OMG 分配。PolicyType 的新值应该通过向 request@omg.org 发送电子邮件从 OMG 获得。通常，分配的常量值是与相应策略对象一起定义的。

返回：
对应于策略对象类型的常量值

copy

Policy copy()
返回 Policy 对象的副本。该副本没有保留任何关于策略与任何域或对象之间的关系。

返回：
Policy 对象的副本

destroy

void destroy()
销毁 Policy 对象。由 Policy 对象负责确定是否可以销毁其自身。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyTypeHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PolicyTypeHelper

java.lang.Object
    继承者  org.omg.CORBA.PolicyTypeHelper

public abstract class PolicyTypeHelper
extends Object

PolicyType 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/PolicyTypeHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 ../../../../../src/share/classes/org/omg/PortableServer/corba.idl 中生成，生成时间为 PDT 时间 1999 年 7 月 17 日（星期六）上午 12:26:20

构造方法摘要
PolicyTypeHelper()
方法摘要
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PolicyTypeHelper

public PolicyTypeHelper()
方法详细信息

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Principal (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 Principal

java.lang.Object
    继承者  org.omg.CORBA.Principal
已过时。 已由 CORBA 2.2 取代。

@Deprecated
public class Principal
extends Object

包含关于客户端身份信息的类，用于访问控制和其他目的。它包含一个被编码为字节序列的属性（Principal 的名称）。

构造方法摘要
Principal()
已过时。
方法摘要
byte[] | name() 已过时。 已由 CORBA 2.2 取代。
void | name(byte[] value) 已过时。 已由 CORBA 2.2 取代。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Principal

public Principal()
已过时。
方法详细信息

name

@Deprecated
public void name(byte[] value)
已过时。 已由 CORBA 2.2 取代。

将此 Principal 对象的名称设置为给定值。

参数：
value - 将在 Principal 中设置的值

name

@Deprecated
public byte[] name()
已过时。 已由 CORBA 2.2 取代。

获取此 Principal 对象的名称。

返回：
此 Principal 对象的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrincipalHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 PrincipalHolder

java.lang.Object
    继承者  org.omg.CORBA.PrincipalHolder
所有已实现的接口：
Streamable
已过时。 Deprecated by CORBA 2.2.

@Deprecated
public final class PrincipalHolder
extends Object
implements Streamable

Principal 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

Principal 类型的值的容器类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将一个 IDL Principal 作为 "out" 或 "inout" 参数，则程序员必须传递一个 PrincipalHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myPrincipalHolder 是 PrincipalHolder 实例，则可以使用 myPrincipalHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 Principal value
已过时。 此 PrincipalHolder 对象保存的 Principal 值。
构造方法摘要
PrincipalHolder()
已过时。 构造一个新的 PrincipalHolder 对象，将其 value 字段初始化为 null。
PrincipalHolder(Principal initial)
已过时。 构造一个新的 PrincipalHolder 对象，并将其 value 字段初始化为给定的 Principal 对象。
方法摘要
void | _read(InputStream input) 已过时。 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 已过时。 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream output) 已过时。 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Principal value
已过时。
此 PrincipalHolder 对象保存的 Principal 值。

构造方法详细信息

PrincipalHolder

public PrincipalHolder()
已过时。
构造一个新的 PrincipalHolder 对象，将其 value 字段初始化为 null。

PrincipalHolder

public PrincipalHolder(Principal initial)
已过时。
构造一个新的 PrincipalHolder 对象，并将其 value 字段初始化为给定的 Principal 对象。

参数：
initial - Principal，用来初始化新建 PrincipalHolder 对象的 value 字段
方法详细信息

_read

public void _read(InputStream input)
已过时。
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
input - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream output)
已过时。
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
output - CDR OutputStream

_type

public TypeCode _type()
已过时。
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


REBIND (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 REBIND

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.REBIND
所有已实现的接口：
Serializable
public final class REBIND
extends SystemException

如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。如果当前有效 RebindPolicy 具有 NO_RECONNECT 值并且必须重新打开连接，也会引发此异常。

从以下版本开始：
J2SE 1.5
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
REBIND()
构造一个 REBIND 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
REBIND(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态 (completion status) 构造一个 REBIND 异常。
REBIND(String detailMessage)
使用指定消息构造一个 REBIND 异常。
REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 REBIND 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

REBIND

public REBIND()
构造一个 REBIND 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。

REBIND

public REBIND(String detailMessage)
使用指定消息构造一个 REBIND 异常。

参数：
detailMessage - 包含详细消息的字符串。

REBIND

public REBIND(int minorCode,
              CompletionStatus completionStatus)
使用指定次要代码和完成状态 (completion status) 构造一个 REBIND 异常。

参数：
minorCode - 次要代码。
completionStatus - 完成状态。

REBIND

public REBIND(String detailMessage,
              int minorCode,
              CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 REBIND 异常。

参数：
detailMessage - 包含详细消息的字符串。
minorCode - 次要代码。
completionStatus - 完成状态。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PRIVATE_MEMBER (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 PRIVATE_MEMBER

public interface PRIVATE_MEMBER

定义 ValueMember 类中私有成员的常量。

PRIVATE_MEMBER 是接口存储库中使用的 typedef Visibility 的两个常量之一，用于标识 ValueMember 类型的可见性。另一个常量是 PUBLIC_MEMBER。

字段摘要
static short value

字段详细信息

value

static final short value
另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PUBLIC_MEMBER (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 PUBLIC_MEMBER

public interface PUBLIC_MEMBER

定义 ValueMember 类中公共成员的常量。

PUBLIC_MEMBER 是接口存储库中使用的 typedef Visibility 的两个常量之一，用于标识 ValueMember 类型的可见性。另一个常量是 PRIVATE_MEMBER。

字段摘要
static short value

字段详细信息

value

static final short value
另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RepositoryIdHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 RepositoryIdHelper

java.lang.Object
    继承者  org.omg.CORBA.RepositoryIdHelper

public abstract class RepositoryIdHelper
extends Object

RepositoryId 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/RepositoryIdHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:43 (GMT+00:00)

构造方法摘要
RepositoryIdHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RepositoryIdHelper

public RepositoryIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Request (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 Request

java.lang.Object
    继承者  org.omg.CORBA.Request

public abstract class Request
extends Object

包含调用某一方法所必需的信息的对象。此类是 ORB 动态调用接口（Dynamic Invocation Interface，DII）的基石，它允许动态创建并调用请求。服务器无法判断使用客户端 stub 的客户端调用与使用 DII 的请求之间的不同。

Request 对象由以下内容组成：

  • 将被调用的操作的名称
  • 包含用于该操作的参数的 NVList。
    该列表中的每一项都是一个 NamedValue 对象，它由三部分组成：
    1. 参数的名称
    2. 参数值（以 Any 对象的形式存在）
    3. 指示该参数是用于输入、输出，还是同时用于这二者的参数模式标志

Request 对象还可以包含附加信息，这取决于原始 IDL 接口定义中对操作的定义。例如，在合适的地方可以包含一个 NamedValue 对象来保存返回值、异常、上下文、可能异常的列表和需要解析的上下文字符串列表。

新的 Request 对象是使用 Object 类中的 create_request 方法之一创建的。换句话说，create_request 方法是在将被调用的对象上执行的。

另请参见：
NamedValue

构造方法摘要
Request()
方法摘要
abstract Any | add_in_arg() 创建一个输入参数，并将它添加到此 Request 对象中。
abstract Any | add_inout_arg() 将一个输入/输出参数添加到此 Request 对象中。
abstract Any | add_named_in_arg(String name) 使用给定名称创建一个输入参数，并将它添加到此 Request 对象中。
abstract Any | add_named_inout_arg(String name) 将具有给定名称的输入/输出参数添加到此 Request 对象中。
abstract Any | add_named_out_arg(String name) 将具有给定名称的输出参数添加到此 Request 对象中。
abstract Any | add_out_arg() 将输出参数添加到此 Request 对象中。
abstract NVList | arguments() 检索包含将被调用方法的参数的 NVList 对象。
abstract ContextList | contexts() 检索用于此请求的 ContextList 对象。
abstract Context | ctx() 检索用于此请求的 Context 对象。
abstract void | ctx(Context c) 将此请求的 Context 对象设置为给定对象。
abstract Environment | env() 检索用于此请求的 Environment 对象。
abstract ExceptionList | exceptions() 检索用于此请求的 ExceptionList 对象。
abstract void | get_response() 允许用户访问之前使用 send_deferred 方法所触发调用的响应。
abstract void | invoke() 使用 Request 对象中的信息进行同步调用。
abstract String | operation() 检索将被调用的方法的名称。
abstract boolean | poll_response() 允许用户确定是否已接收到之前使用 send_deferred 方法所触发调用的响应。
abstract NamedValue | result() 检索包含该方法的返回值的 NamedValue 对象。
abstract Any | return_value() 返回包含方法结果值的 Any 对象。
abstract void | send_deferred() 对请求进行异步调用。
abstract void | send_oneway() 在请求上执行单向调用。
abstract void | set_return_type(TypeCode tc) 设置该方法返回值的 typecode。
abstract Object | target() 检索目标对象引用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Request

public Request()
方法详细信息

target

public abstract Object target()
检索目标对象引用。

返回：
对象引用，指向将被调用的方法的对象实现

operation

public abstract String operation()
检索将被调用的方法的名称。

返回：
将被调用的方法的名称

arguments

public abstract NVList arguments()
检索包含将被调用方法的参数的 NVList 对象。列表中的元素都是 NamedValue 对象，每个元素描述该方法的一个参数。

返回：
包含该方法的参数的 NVList 对象

result

public abstract NamedValue result()
检索包含该方法的返回值的 NamedValue 对象。

返回：
包含该方法的结果的 NamedValue 对象

env

public abstract Environment env()
检索用于此请求的 Environment 对象。它包含被调用的方法所抛出的异常（在调用返回之后）。

返回：
用于此请求的 Environment 对象

exceptions

public abstract ExceptionList exceptions()
检索用于此请求的 ExceptionList 对象。此列表包含 TypeCode 对象，这些对象描述将被调用的方法可能抛出的异常。

返回：
ExceptionList 对象，该对象描述将被调用的方法可能抛出的异常

contexts

public abstract ContextList contexts()
检索用于此请求的 ContextList 对象。此列表包含需要解析并随调用发送的上下文 String。

返回：
其值需要解析并随调用发送的上下文字符串所组成的列表。

ctx

public abstract Context ctx()
检索用于此请求的 Context 对象。这是一个属性列表，提供有关客户端、环境或此请求的情况的信息。

返回：
Context 对象，将使用该对象来解析任何其值需要与调用一起发送的上下文字符串

ctx

public abstract void ctx(Context c)
将此请求的 Context 对象设置为给定对象。

参数：
c - 将用来解析上下文字符串的新 Context 对象

add_in_arg

public abstract Any add_in_arg()
创建一个输入参数，并将它添加到此 Request 对象中。

返回：
一个 Any 对象，它包含所添加输入参数的值和 typecode

add_named_in_arg

public abstract Any add_named_in_arg(String name)
使用给定名称创建一个输入参数，并将它添加到此 Request 对象中。

参数：
name - 将添加的参数的名称
返回：
一个 Any 对象，它包含所添加输入参数的值和 typecode

add_inout_arg

public abstract Any add_inout_arg()
将一个输入/输出参数添加到此 Request 对象中。

返回：
一个 Any 对象，它包含所添加输入/输出参数的值和 typecode

add_named_inout_arg

public abstract Any add_named_inout_arg(String name)
将具有给定名称的输入/输出参数添加到此 Request 对象中。

参数：
name - 将添加的参数的名称
返回：
一个 Any 对象，它包含所添加输入/输出参数的值和 typecode

add_out_arg

public abstract Any add_out_arg()
将输出参数添加到此 Request 对象中。

返回：
一个 Any 对象，它包含所添加输出参数的值和 typecode

add_named_out_arg

public abstract Any add_named_out_arg(String name)
将具有给定名称的输出参数添加到此 Request 对象中。

参数：
name - 将添加的参数的名称
返回：
一个 Any 对象，它包含所添加输出参数的值和 typecode

set_return_type

public abstract void set_return_type(TypeCode tc)
设置该方法返回值的 typecode。

参数：
tc - 包含返回值的类型信息的 TypeCode 对象

return_value

public abstract Any return_value()
返回包含方法结果值的 Any 对象。

返回：
一个 Any 对象，它包含返回值的值和 typecode

invoke

public abstract void invoke()
使用 Request 对象中的信息进行同步调用。异常信息放置在 Request 对象的环境对象中。

send_oneway

public abstract void send_oneway()
在请求上执行单向调用。换句话说，不期望（或等待）应答。注意，该操作即使没有在 IDL 声明中声明也可以使用。不返回任何响应或异常信息。

send_deferred

public abstract void send_deferred()
对请求进行异步调用。换句话说，在向用户返回前不等待响应。用户稍后可以使用 poll_response 和 get_response 方法获取该调用的结果和异常信息。

poll_response

public abstract boolean poll_response()
允许用户确定是否已接收到之前使用 send_deferred 方法所触发调用的响应。

返回：
如果已经接收到方法响应，则返回 true；否则返回 false

get_response

public abstract void get_response()
                           throws WrongTransaction
允许用户访问之前使用 send_deferred 方法所触发调用的响应。

抛出：
WrongTransaction - 如果从不同于最初发送请求的事务处理域中调用 get_response 方法。有关详细信息，请参阅 OMG 事务服务 (Transaction Service) 规范。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerRequest (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ServerRequest

java.lang.Object
    继承者  org.omg.CORBA.ServerRequest

public abstract class ServerRequest
extends Object

捕获对动态框架接口（Dynamic Skeleton Interface，DSI）请求的显式状态的对象。此类是 DSI 的基础，类似于 DII 中的 Request 对象。

ORB 负责创建具体的请求，并将它传递给动态实现例程（Dynamic Implementation Routine，DIR）。动态 servant（一个 DIR）是通过实现 DynamicImplementation 类创建的，该类有一个 invoke 方法。此方法接受 ServerRequest 对象。 抽象类 ServerRequest 定义了一些方法，用来访问请求的方法名称、参数和上下文，以及将该请求的结果设置为返回值或异常。

访问该请求参数的一个微妙之处在于：DIR 需要提供有关所期望参数的类型信息，因为没有关于这些类型的已编译信息。此信息是通过 NVList 提供的，NVList 是 NamedValue 对象列表。每个 NamedValue 对象都包含一个 Any 对象，每个 Any 对象都有一个表示参数类型的 TypeCode 对象。

类似地，还需要为响应、所期望的结果或异常提供类型信息，因此方法 result 和 except 使用 Any 对象作为参数。

另请参见：
DynamicImplementation, NVList, NamedValue

构造方法摘要
ServerRequest()
方法摘要
 void arguments(NVList args)
指定方法参数类型并检索 "in" 和 "inout" 参数值。
abstract  Context ctx()
当操作不是一个属性访问并且该操作的 IDL 定义中包含上下文表达式时，该操作返回用 IDL 指定的上下文信息；否则返回 nil Context 引用。
 void except(Any any)
已过时。 使用 set_exception()
 String op_name()
已过时。 使用 operation()
 String operation()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
 void params(NVList params)
已过时。 使用方法 arguments
 void result(Any any)
已过时。 使用方法 set_result
 void set_exception(Any any)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
 void set_result(Any any)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServerRequest

public ServerRequest()
方法详细信息

op_name

@Deprecated
public String op_name()
已过时。 使用 operation()

检索将被调用的操作的名称。根据 OMG IDL 的规则，这些名称在此对象的“最终派生”接口所支持的所有操作中必须是唯一的。注意，用来获取和设置属性的操作名称分别是 _get_<attribute_name> 和 _set_<attribute_name>。

返回：
要调用的操作的名称

operation

public String operation()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

检索将被调用的操作的名称。根据 OMG IDL 的规则，这些名称在此对象的“最终派生”接口所支持的所有操作中必须是唯一的。注意，用来获取和设置属性的操作名称分别是 _get_<attribute_name> 和 _set_<attribute_name>。

返回：
将被调用的操作的名称
另请参见：
CORBA 包中有关未实现特性的注释

params

@Deprecated
public void params(NVList params)
已过时。 使用方法 arguments

指定方法参数类型并检索 "in" 和 "inout" 参数值。

注意，此方法已过时，使用 arguments 方法替代它。

如果没有调用 set_exception 方法，则 DIR 必须调用此方法一次，即使该方法签名不包含任何参数。一旦已经调用 arguments 或 set_exception 方法，则对同一个 ServerRequest 对象调用 arguments 将导致 BAD_INV_ORDER 系统异常。DIR 必须向方法 arguments 传入使用 TypeCodes 初始化的 NVList 和描述该操作参数类型的 Flag，按照它们在 IDL 规范中出现的顺序（从左到右）传入。使用所提供的 "in" 和 "inout" 参数值，arguments 返回的 NVList 可能不同。如果没有调用 set_exception 方法，则返回前 DIR 必须提供所返回的 NVList，该列表带有用于任何 "out" 参数的返回值，DIR 还可以更改用于任何 "inout" 参数的返回值。

参数：
params - NVList 对象形式的方法参数

arguments

public void arguments(NVList args)
指定方法参数类型并检索 "in" 和 "inout" 参数值。如果没有调用 set_exception 方法，则 DIR 必须调用此方法一次，即使该方法签名不包含任何参数。一旦已经调用 arguments 或 set_exception 方法，则对同一个 ServerRequest 对象调用 arguments 将导致 BAD_INV_ORDER 系统异常。DIR 必须向方法 arguments 传入使用 TypeCodes 初始化的 NVList 和描述该操作参数类型的 Flag，按照它们在 IDL 规范中出现的顺序（从左到右）传入。使用所提供的 "in" 和 "inout" 参数值，arguments 返回的 NVList 可能不同。如果没有调用 set_exception 方法，则返回前 DIR 必须提供所返回的 NVList，该列表带有用于任何 "out" 参数的返回值，DIR 还可以更改用于任何 "inout" 参数的返回值。

参数：
args - NVList 形式的方法参数
另请参见：
CORBA 包中有关未实现特性的注释

result

@Deprecated
public void result(Any any)
已过时。 使用方法 set_result

为调用指定任何返回值。

注意，不推荐使用此方法，建议使用 set_result 方法替代它。

如果没有调用 set_exception 方法，则在调用的方法有一个非 void 结果类型时，必须在 DIR 返回前调用 set_result 方法一次。如果该操作有一个 void 结果类型，则可以有选择地调用 set_result 方法一次，并使用类型为 tk_void 的 Any 对象作为参数。在调用 arguments 方法之前调用 set_result 方法，或者在调用 set_result 或 set_exception 方法之后调用该方法将导致 BAD_INV_ORDER 异常。当 IDL 操作包含一个上下文表达式，或者传递给 arguments 的 NVList 没有描述客户端传递的所有参数时，在调用 set_result 方法之前没有调用 ctx 方法将导致 MARSHAL 系统异常。

参数：
any - 包含将被设置的返回值的 Any 对象

set_result

public void set_result(Any any)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

为调用指定任何返回值。如果没有调用 set_exception 方法，则在调用的方法有一个非 void 结果类型时，必须在 DIR 返回前调用 set_result 方法一次。如果该操作有一个 void 结果类型，则可以有选择地调用 set_result 方法一次，并使用类型为 tk_void 的 Any 对象作为参数。在调用 arguments 方法之前调用 set_result 方法，或者在调用 set_result 或 set_exception 方法之后调用该方法将导致 BAD_INV_ORDER 异常。当 IDL 操作包含一个上下文表达式，或者传递给参数的 NVList 没有描述客户端传递的所有参数时，调用 set_result 方法（没有首先调用 ctx 方法）将导致 MARSHAL 系统异常。

参数：
any - 包含将被设置的返回值的 Any 对象
另请参见：
CORBA 包中有关未实现特性的注释

except

@Deprecated
public void except(Any any)
已过时。 使用 set_exception()

DIR 可以随时调用 set_exception 向客户端返回异常。传递给 set_exception 的 Any 必须包含系统异常，或者所调用操作 IDL 定义的引发表达式中指定的用户异常。传入不包含任何异常的 Any 将导致 BAD_PARAM 系统异常。传入未列出的用户异常将导致 DIR 收到一个 BAD_PARAM 系统异常，或导致客户端收到一个 UNKNOWN_EXCEPTION 系统异常。

参数：
any - 包含异常的 Any 对象

set_exception

public void set_exception(Any any)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

将给定异常返回给客户端。此方法由 DIR 随时调用。传递给此方法的 Any 对象必须包含一个系统异常，或者所调用操作 IDL 定义中指定的用户异常之一。传入不包含任何异常的 Any 对象将导致抛出 BAD_PARAM 系统异常。传入未列出的用户异常将导致 DIR 收到一个 BAD_PARAM 系统异常，或导致客户端收到一个 UNKNOWN_EXCEPTION 系统异常。

参数：
any - 包含异常的 Any 对象
抛出：
BAD_PARAM - 如果给定 Any 对象不包含异常，或者该异常是一个未列出的用户异常
UNKNOWN_EXCEPTION - 如果给定异常是一个未列出的用户异常，并且 DIR 没有收到 BAD_PARAM 异常
另请参见：
CORBA 包中有关未实现特性的注释

ctx

public abstract Context ctx()
当操作不是一个属性访问并且该操作的 IDL 定义中包含上下文表达式时，该操作返回用 IDL 指定的上下文信息；否则返回 nil Context 引用。在调用 arguments 方法之前调用 ctx 方法，或者在调用 ctx、set_result 或 set_exception 方法之后调用该方法都将导致 BAD_INV_ORDER 系统异常。

返回：
Context 对象，将使用该对象来解析任何其值需要与调用一起发送的上下文字符串
抛出：
BAD_INV_ORDER - 如果 (1) 在调用 arguments 方法之前调用 ctx 方法或 (2) 在调用 set_result 或 set_exception 之后调用 ctx 方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceDetail (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ServiceDetail

java.lang.Object
    继承者  org.omg.CORBA.ServiceDetail
所有已实现的接口：
Serializable, IDLEntity
public final class ServiceDetail
extends Object
implements IDLEntity

表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。

字段摘要
byte[] | service_detail 描述此 ServiceDetail 对象所表示的 ORB 服务的数据。
int | service_detail_type 此 ServiceDetail 对象表示的 ORB 服务的类型。
构造方法摘要
ServiceDetail()
使用 0 作为 ORB 服务的类型并使用空描述构造一个 ServiceDetail 对象。
ServiceDetail(int service_detail_type, byte[] service_detail)
使用给定 ORB 服务类型和给定描述构造一个 ServiceDetail 对象。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

service_detail_type

public int service_detail_type
此 ServiceDetail 对象表示的 ORB 服务的类型。

service_detail

public byte[] service_detail
描述此 ServiceDetail 对象所表示的 ORB 服务的数据。

构造方法详细信息

ServiceDetail

public ServiceDetail()
使用 0 作为 ORB 服务的类型并使用空描述构造一个 ServiceDetail 对象。

ServiceDetail

public ServiceDetail(int service_detail_type,
                     byte[] service_detail)
使用给定 ORB 服务类型和给定描述构造一个 ServiceDetail 对象。

参数：
service_detail_type - 指定 ORB 服务类型的 int 值
service_detail - 描述 ORB 服务的 byte 数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceDetailHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ServiceDetailHelper

java.lang.Object
    继承者  org.omg.CORBA.ServiceDetailHelper

public abstract class ServiceDetailHelper
extends Object

构造方法摘要
ServiceDetailHelper()
方法摘要
static ServiceDetail | extract(Any a)
static String | id()
static void | insert(Any a, ServiceDetail that)
static ServiceDetail | read(InputStream in)
static TypeCode | type()
static void | write(OutputStream out, ServiceDetail that)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceDetailHelper

public ServiceDetailHelper()
方法详细信息

write

public static void write(OutputStream out,
                         ServiceDetail that)

read

public static ServiceDetail read(InputStream in)

extract

public static ServiceDetail extract(Any a)

insert

public static void insert(Any a,
                          ServiceDetail that)

type

public static TypeCode type()

id

public static String id()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceInformation (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ServiceInformation

java.lang.Object
    继承者  org.omg.CORBA.ServiceInformation
所有已实现的接口：
Serializable, IDLEntity
public final class ServiceInformation
extends Object
implements IDLEntity

CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。

字段摘要
ServiceDetail[] | service_details 提供有关服务更多详细信息的 ServiceDetail 所组成的数组。
int[] | service_options 表示服务选项的 int 值所组成的数组。
构造方法摘要
ServiceInformation()
使用空 service_options 和 service_details 构造一个 ServiceInformation 对象。
ServiceInformation(int[] __service_options, ServiceDetail[] __service_details)
使用给定 service_options 和 service_details 构造一个 ServiceInformation 对象。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

service_options

public int[] service_options
表示服务选项的 int 值所组成的数组。

service_details

public ServiceDetail[] service_details
提供有关服务更多详细信息的 ServiceDetail 所组成的数组。

构造方法详细信息

ServiceInformation

public ServiceInformation()
使用空 service_options 和 service_details 构造一个 ServiceInformation 对象。

ServiceInformation

public ServiceInformation(int[] __service_options,
                          ServiceDetail[] __service_details)
使用给定 service_options 和 service_details 构造一个 ServiceInformation 对象。

参数：
__service_options - 描述服务选项的 int 值所组成的数组。
__service_details - 描述服务详细信息的 ServiceDetail 所组成的数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceInformationHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ServiceInformationHelper

java.lang.Object
    继承者  org.omg.CORBA.ServiceInformationHelper

public abstract class ServiceInformationHelper
extends Object

构造方法摘要
ServiceInformationHelper()
方法摘要
static ServiceInformation | extract(Any a)
static String | id()
static void | insert(Any a, ServiceInformation that)
static ServiceInformation | read(InputStream in)
static TypeCode | type()
static void | write(OutputStream out, ServiceInformation that)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceInformationHelper

public ServiceInformationHelper()
方法详细信息

write

public static void write(OutputStream out,
                         ServiceInformation that)

read

public static ServiceInformation read(InputStream in)

extract

public static ServiceInformation extract(Any a)

insert

public static void insert(Any a,
                          ServiceInformation that)

type

public static TypeCode type()

id

public static String id()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceInformationHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ServiceInformationHolder

java.lang.Object
    继承者  org.omg.CORBA.ServiceInformationHolder
所有已实现的接口：
Streamable
public final class ServiceInformationHolder
extends Object
implements Streamable

ServiceInformation 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

用于 ServiceInformation 对象的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将一个 IDL xxx 作为 "out" 或 "inout" 参数，则程序员必须传递一个 ServiceInformationHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myServiceInformationHolder 是 ServiceInformationHolder 实例，则可以使用 myServiceInformationHolder.value 访问存储在其 value 字段中的值。

字段摘要
 ServiceInformation value
此 ServiceInformationHolder 对象保存在其 value 字段中的 ServiceInformation 值。
构造方法摘要
ServiceInformationHolder()
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为 null。
ServiceInformationHolder(ServiceInformation arg)
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为给定的 ServiceInformation 对象。
方法摘要
void | _read(InputStream in) 从输入流 in 中读取已解组数据，并将它赋予此 ServiceInformationHolder 对象的 value 字段。
TypeCode | _type() 检索对应于此 ServiceInformationHolder 对象的 value 字段中所保存的值的 TypeCode 对象。
void | _write(OutputStream out) 将此 ServiceInformationHolder 对象的 value 字段中的值编组到输出流 out。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public ServiceInformation value
此 ServiceInformationHolder 对象保存在其 value 字段中的 ServiceInformation 值。

构造方法详细信息

ServiceInformationHolder

public ServiceInformationHolder()
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为 null。

ServiceInformationHolder

public ServiceInformationHolder(ServiceInformation arg)
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为给定的 ServiceInformation 对象。

参数：
arg - ServiceInformation 对象，用来初始化新建 ServiceInformationHolder 对象的 value 字段
方法详细信息

_write

public void _write(OutputStream out)
将此 ServiceInformationHolder 对象的 value 字段中的值编组到输出流 out。

指定者：
接口 Streamable 中的 _write
参数：
out - 将包含 CDR 格式数据的 OutputStream 对象

_read

public void _read(InputStream in)
从输入流 in 中读取已解组数据，并将它赋予此 ServiceInformationHolder 对象的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
in - 包含在线获取的 CDR 格式数据的 InputStream 对象。

_type

public TypeCode _type()
检索对应于此 ServiceInformationHolder 对象的 value 字段中所保存的值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
此 ServiceInformationHolder 对象中所保存值的类型代码
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SetOverrideType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 SetOverrideType

java.lang.Object
    继承者  org.omg.CORBA.SetOverrideType
所有已实现的接口：
Serializable, IDLEntity
public class SetOverrideType
extends Object
implements IDLEntity

标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。

omg.org.CORBA.Object._set_policy_override 方法用 SetOverrideType.SET_OVERRIDE 或 SetOverrideType.ADD_OVERRIDE 作为其第二个参数。方法 _set_policy_override 创建一个新的 Object，并使用作为第一个参数提供的 Policy 对象进行初始化。如果第二个参数是 ADD_OVERRIDE，则将新策略添加到正调用 _set_policy_override 方法的 Object 实例的那些策略中。如果 SET_OVERRIDE 已给定，则使用给定策略替换现有策略。

从以下版本开始：
JDK1.2

字段摘要
static int | _ADD_OVERRIDE 用于枚举值 ADD_OVERRIDE 的 int 常量。
static int | _SET_OVERRIDE 用于枚举值 SET_OVERRIDE 的 int 常量。
static SetOverrideType | ADD_OVERRIDE 用于枚举值 ADD_OVERRIDE 的 SetOverrideType 常量。
static SetOverrideType | SET_OVERRIDE 用于枚举值 SET_OVERRIDE 的 SetOverrideType 常量。
构造方法摘要
protected SetOverrideType(int _value)
根据 int 值构造一个 SetOverrideType 实例。
方法摘要
static SetOverrideType | from_int(int i) 将给定 int 值转换成相应的 SetOverrideType 实例。
int | value() 检索此 SetOverrideType 实例的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_SET_OVERRIDE

public static final int _SET_OVERRIDE
用于枚举值 SET_OVERRIDE 的 int 常量。

另请参见：
常量字段值

_ADD_OVERRIDE

public static final int _ADD_OVERRIDE
用于枚举值 ADD_OVERRIDE 的 int 常量。

另请参见：
常量字段值

SET_OVERRIDE

public static final SetOverrideType SET_OVERRIDE
用于枚举值 SET_OVERRIDE 的 SetOverrideType 常量。

ADD_OVERRIDE

public static final SetOverrideType ADD_OVERRIDE
用于枚举值 ADD_OVERRIDE 的 SetOverrideType 常量。

构造方法详细信息

SetOverrideType

protected SetOverrideType(int _value)
根据 int 值构造一个 SetOverrideType 实例。

参数：
_value - 必须是 SET_OVERRIDE 或 ADD_OVERRIDE
方法详细信息

value

public int value()
检索此 SetOverrideType 实例的值。

返回：
用于此 SetOverrideType 的 int 值

from_int

public static SetOverrideType from_int(int i)
将给定 int 值转换成相应的 SetOverrideType 实例。

参数：
i - 要转换的 int 值，必须是 SetOverrideType._SET_OVERRIDE 或 SetOverrideType._ADD_OVERRIDE
返回：
其值与给定 int 值匹配的 SetOverrideType 实例
抛出：
BAD_PARAM - 如果给定 int 值与任何 SetOverrideType 实例的值都不匹配
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SetOverrideTypeHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 SetOverrideTypeHelper

java.lang.Object
    继承者  org.omg.CORBA.SetOverrideTypeHelper

public abstract class SetOverrideTypeHelper
extends Object

SetOverrideType 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/SetOverrideTypeHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）生成，生成时间为 1999 年 6 月 3 日的 11:52:03 (GMT+00:00)

构造方法摘要
SetOverrideTypeHelper()
方法摘要
static SetOverrideType | extract(Any a)
static String | id()
static void | insert(Any a, SetOverrideType that)
static SetOverrideType | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, SetOverrideType value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SetOverrideTypeHelper

public SetOverrideTypeHelper()
方法详细信息

insert

public static void insert(Any a,
                          SetOverrideType that)

extract

public static SetOverrideType extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static SetOverrideType read(InputStream istream)

write

public static void write(OutputStream ostream,
                         SetOverrideType value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ShortHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ShortHolder

java.lang.Object
    继承者  org.omg.CORBA.ShortHolder
所有已实现的接口：
Streamable
public final class ShortHolder
extends Object
implements Streamable

Short 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

short 值。如果 IDL 操作签名将一个 IDL short 作为 "out" 或 "inout" 参数，则程序员必须传递一个 ShortHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myShortHolder 是 ShortHolder 实例，则可以使用 myShortHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 short value
此 ShortHolder 对象保存的 short 值。
构造方法摘要
ShortHolder()
构造一个新的 ShortHolder 对象，将其 value 字段初始化为 0。
ShortHolder(short initial)
构造一个新的 ShortHolder 对象，并使用给定 short 值初始化其 value 字段。
方法摘要
void | _read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ShortHolder 对象中的值。
TypeCode | _type() 返回对应于此 ShortHolder 对象中所保存的值的 TypeCode。
void | _write(OutputStream output) 将此 ShortHolder 对象中的值编组到 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public short value
此 ShortHolder 对象保存的 short 值。

构造方法详细信息

ShortHolder

public ShortHolder()
构造一个新的 ShortHolder 对象，将其 value 字段初始化为 0。

ShortHolder

public ShortHolder(short initial)
构造一个新的 ShortHolder 对象，并使用给定 short 值初始化其 value 字段。

参数：
initial - short 值，用来初始化新建 ShortHolder 对象的 value 字段
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取数据，并使用已解组数据初始化此 ShortHolder 对象中的值。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 ShortHolder 对象中的值编组到 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
返回对应于此 ShortHolder 对象中所保存的值的 TypeCode。

指定者：
接口 Streamable 中的 _type
返回：
此 ShortHolder 对象中所保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ShortSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ShortSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.ShortSeqHelper

public abstract class ShortSeqHelper
extends Object

ShortSeqHelper 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/ShortSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
ShortSeqHelper()
方法摘要
static short[] | extract(Any a)
static String | id()
static void | insert(Any a, short[] that)
static short[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ShortSeqHelper

public ShortSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          short[] that)

extract

public static short[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ShortSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ShortSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.ShortSeqHolder
所有已实现的接口：
Streamable
public final class ShortSeqHolder
extends Object
implements Streamable

ShortSeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/ShortSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00)

字段摘要
 short[] value
构造方法摘要
ShortSeqHolder()
ShortSeqHolder(short[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public short[] value
构造方法详细信息

ShortSeqHolder

public ShortSeqHolder()

ShortSeqHolder

public ShortSeqHolder(short[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 StringHolder

java.lang.Object
    继承者  org.omg.CORBA.StringHolder
所有已实现的接口：
Streamable
public final class StringHolder
extends Object
implements Streamable

String 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

String 值的 Holder 类，用来存储 IDL 操作中的 "out" 和 "inout" 参数。如果 IDL 操作签名将一个 IDL string 作为 "out" 或 "inout" 参数，则程序员必须传递一个 StringHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myStringHolder 是 StringHolder 实例，则可以使用 myStringHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 String value
此 StringHolder 对象保存的 String 值。
构造方法摘要
StringHolder()
构造一个新的 StringHolder 对象，将其 value 字段初始化为 null。
StringHolder(String initial)
构造一个新的 StringHolder 对象，并使用给定 String 初始化其 value 字段。
方法摘要
void | _read(InputStream input) 从 input 中读取已解组的数据，并将它赋予此 StringHolder 对象的 value 字段。
TypeCode | _type() 检索对应于此 StringHolder 对象中所保存的值的 TypeCode 对象。
void | _write(OutputStream output) 将此 StringHolder 对象所保存的值编组到输出流 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public String value
此 StringHolder 对象保存的 String 值。

构造方法详细信息

StringHolder

public StringHolder()
构造一个新的 StringHolder 对象，将其 value 字段初始化为 null。

StringHolder

public StringHolder(String initial)
构造一个新的 StringHolder 对象，并使用给定 String 初始化其 value 字段。

参数：
initial - String，用来初始化新建 StringHolder 对象的 value 字段
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取已解组的数据，并将它赋予此 StringHolder 对象的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 StringHolder 对象所保存的值编组到输出流 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
检索对应于此 StringHolder 对象中所保存的值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
此 StringHolder 对象中所保存值的类型代码。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 StringSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.StringSeqHelper

public abstract class StringSeqHelper
extends Object

String 数组

构造方法摘要
StringSeqHelper()
方法摘要
static String[] | extract(Any a)
static String | id()
static void | insert(Any a, String[] that)
static String[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringSeqHelper

public StringSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          String[] that)

extract

public static String[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 StringSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.StringSeqHolder
所有已实现的接口：
Streamable
public final class StringSeqHolder
extends Object
implements Streamable

String 数组

字段摘要
 String[] value
构造方法摘要
StringSeqHolder()
StringSeqHolder(String[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public String[] value
构造方法详细信息

StringSeqHolder

public StringSeqHolder()

StringSeqHolder

public StringSeqHolder(String[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringValueHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 StringValueHelper

java.lang.Object
    继承者  org.omg.CORBA.StringValueHelper
所有已实现的接口：
BoxedValueHelper
public class StringValueHelper
extends Object
implements BoxedValueHelper

StringValue 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/StringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日的 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
StringValueHelper()
方法摘要
static String | extract(Any a)
String | get_id()
static String | id()
static void | insert(Any a, String that)
Serializable | read_value(InputStream istream)
static String | read(InputStream istream)
static TypeCode | type()
void | write_value(OutputStream ostream, Serializable value)
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringValueHelper

public StringValueHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

read_value

public Serializable read_value(InputStream istream)
指定者：
接口 BoxedValueHelper 中的 read_value

write

public static void write(OutputStream ostream,
                         String value)

write_value

public void write_value(OutputStream ostream,
                        Serializable value)
指定者：
接口 BoxedValueHelper 中的 write_value

get_id

public String get_id()
指定者：
接口 BoxedValueHelper 中的 get_id
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StructMember (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 StructMember

java.lang.Object
    继承者  org.omg.CORBA.StructMember
所有已实现的接口：
Serializable, IDLEntity
public final class StructMember
extends Object
implements IDLEntity

描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。

字段摘要
String | name 此 StructMember 对象所描述的 struct 成员的名称。
TypeCode | type 此 StructMember 对象所描述的 struct 成员的类型。
IDLType | type_def typedef，它表示此 StructMember 对象所描述的 struct 成员的 IDL 类型。
构造方法摘要
StructMember()
构造一个默认 StructMember 对象。
StructMember(String __name, TypeCode __type, IDLType __type_def)
构造一个 StructMember 对象，并使用给定值进行初始化。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

name

public String name
此 StructMember 对象所描述的 struct 成员的名称。

type

public TypeCode type
此 StructMember 对象所描述的 struct 成员的类型。

type_def

public IDLType type_def
typedef，它表示此 StructMember 对象所描述的 struct 成员的 IDL 类型。

构造方法详细信息

StructMember

public StructMember()
构造一个默认 StructMember 对象。

StructMember

public StructMember(String __name,
                    TypeCode __type,
                    IDLType __type_def)
构造一个 StructMember 对象，并使用给定值进行初始化。

参数：
__name - 具有该 struct 成员名称的 String 对象
__type - 描述 struct 成员类型的 TypeCode 对象
__type_def - 表示 struct 成员 IDL 类型的 IDLType 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StructMemberHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 StructMemberHelper

java.lang.Object
    继承者  org.omg.CORBA.StructMemberHelper

public abstract class StructMemberHelper
extends Object

StructMember 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/StructMemberHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:43 (GMT+00:00)

构造方法摘要
StructMemberHelper()
方法摘要
static StructMember | extract(Any a)
static String | id()
static void | insert(Any a, StructMember that)
static StructMember | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, StructMember value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StructMemberHelper

public StructMemberHelper()
方法详细信息

insert

public static void insert(Any a,
                          StructMember that)

extract

public static StructMember extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static StructMember read(InputStream istream)

write

public static void write(OutputStream ostream,
                         StructMember value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SystemException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 SystemException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
所有已实现的接口：
Serializable
直接已知子类：
ACTIVITY_COMPLETED, ACTIVITY_REQUIRED, BAD_CONTEXT, BAD_INV_ORDER, BAD_OPERATION, BAD_PARAM, BAD_QOS, BAD_TYPECODE, CODESET_INCOMPATIBLE, COMM_FAILURE, DATA_CONVERSION, FREE_MEM, IMP_LIMIT, IndirectionException, INITIALIZE, INTERNAL, INTF_REPOS, INV_FLAG, INV_IDENT, INV_OBJREF, INV_POLICY, INVALID_ACTIVITY, INVALID_TRANSACTION, MARSHAL, NO_IMPLEMENT, NO_MEMORY, NO_PERMISSION, NO_RESOURCES, NO_RESPONSE, OBJ_ADAPTER, OBJECT_NOT_EXIST, PERSIST_STORE, REBIND, TIMEOUT, TRANSACTION_MODE, TRANSACTION_REQUIRED, TRANSACTION_ROLLEDBACK, TRANSACTION_UNAVAILABLE, TRANSIENT, UNKNOWN, UnknownException
public abstract class SystemException
extends RuntimeException

所有 CORBA 标准异常的根类。这些异常可以作为任何 CORBA 操作调用的结果抛出，还可以由许多标准 CORBA API 方法返回。标准异常包含次要代码 (minor code) 以提供更详细的说明，此外还包含完成状态。可以为此类创建子类，以生成标准 ORB 异常集合中的每一个异常。SystemException 扩展了 java.lang.RuntimeException，因此在映射自 IDL 接口的操作的 Java 方法的签名中无需声明任何 SystemException 异常。

另请参见：
关于 Java IDL 异常的文档

字段摘要
CompletionStatus | completed 抛出此异常的操作的状态。
int | minor CORBA Exception 次要代码。
构造方法摘要
protected SystemException(String reason, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 SystemException 异常。
方法摘要
 String toString()
将此异常转换成有代表性的字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

minor

public int minor
CORBA Exception 次要代码。

completed

public CompletionStatus completed
抛出此异常的操作的状态。

构造方法详细信息

SystemException

protected SystemException(String reason,
                          int minor,
                          CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 SystemException 异常。详细消息是描述此特定异常的 String。

参数：
reason - 包含详细消息的 String
minor - 次要代码
completed - 完成状态
方法详细信息

toString

public String toString()
将此异常转换成有代表性的字符串。

覆盖：
类 Throwable 中的 toString
返回：
该 throwable 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TCKind (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TCKind

java.lang.Object
    继承者  org.omg.CORBA.TCKind

public class TCKind
extends Object

IDL enum TCKind 的 Java 映射，TCKind 指定 TypeCode 对象的种类。每个基本和基础 IDL 数据类型都有一个种类。

TCKind 类由以下内容组成：

  • 一组 int 常量，每个常量对应一种 IDL 数据类型。这些 int 常量使该类能够使用 switch 语句。
  • 一组 TCKind 常量，每个常量对应一种 IDL 数据类型。每个 TCKind 实例的 value 字段都是使用对应于该实例所表示的 IDL 数据类型的 int 常量初始化的。
  • 用来将 int 值转换成其相应 TCKind 实例的 from_int 方法

    示例：

          org.omg.CORBA.TCKind k = org.omg.CORBA.TCKind.from_int(
                         org.omg.CORBA.TCKind._tk_string);
    变量 k 表示用于 IDL 类型 string 的 TCKind 实例，该 string 的值为 tk_string。

  • 用来访问 TCKind 常量 _value 字段的 value 方法

    示例：

       int i = org.omg.CORBA.TCKind.tk_char.value();
    变量 i 表示 9，是用于 IDL 数据类型 char 的值。

TCKind 实例的 value 字段是 CDR 编码的，用于 IIOP 消息中的 TypeCode 对象。

字段摘要
static int | _tk_abstract_interface 用于 IDL 数据类型 abstract interface 的 int 常量。
static int | _tk_alias 用于 IDL 数据类型 alias 的 int 常量。
static int | _tk_any 用于 IDL 数据类型 any 的 int 常量。
static int | _tk_array 用于 IDL 数据类型 array 的 int 常量。
static int | _tk_boolean 用于 IDL 数据类型 boolean 的 int 常量。
static int | _tk_char 用于 IDL 数据类型 char 的 int 常量。
static int | _tk_double 用于 IDL 数据类型 double 的 int 常量。
static int | _tk_enum 用于 IDL 数据类型 enum 的 int 常量。
static int | _tk_except 用于 IDL 数据类型 except 的 int 常量。
static int | _tk_fixed 用于 IDL 数据类型 fixed 的 int 常量。
static int | _tk_float 用于 IDL 数据类型 float 的 int 常量。
static int | _tk_long 用于 IDL 数据类型 long 的 int 常量。
static int | _tk_longdouble 用于 IDL 数据类型 longdouble 的 int 常量。
static int | _tk_longlong 用于 IDL 数据类型 longlong 的 int 常量。
static int | _tk_native 用于 IDL 数据类型 native 的 int 常量。
static int | _tk_null 用于 null IDL 数据类型的 int 常量。
static int | _tk_objref 用于 IDL 数据类型 objref 的 int 常量。
static int | _tk_octet 用于 IDL 数据类型 octet 的 int 常量。
static int | _tk_Principal 用于 IDL 数据类型 Principal 的 int 常量。
static int | _tk_sequence 用于 IDL 数据类型 sequence 的 int 常量。
static int | _tk_short 用于 IDL 数据类型 short 的 int 常量。
static int | _tk_string 用于 IDL 数据类型 string 的 int 常量。
static int | _tk_struct 用于 IDL 数据类型 struct 的 int 常量。
static int | _tk_TypeCode 用于 IDL 数据类型 TypeCode 的 int 常量。
static int | _tk_ulong 用于 IDL 数据类型 ulong 的 int 常量。
static int | _tk_ulonglong 用于 IDL 数据类型 ulonglong 的 int 常量。
static int | _tk_union 用于 IDL 数据类型 union 的 int 常量。
static int | _tk_ushort 用于 IDL 数据类型 ushort 的 int 常量。
static int | _tk_value 用于 IDL 数据类型 value 的 int 常量。
static int | _tk_value_box 用于 IDL 数据类型 value_box 的 int 常量。
static int | _tk_void 用于 IDL 数据类型 void 的 int 常量。
static int | _tk_wchar 用于 IDL 数据类型 wchar 的 int 常量。
static int | _tk_wstring 用于 IDL 数据类型 wstring 的 int 常量。
static TCKind | tk_abstract_interface TCKind 常量，使用 TCKind._tk_abstract_interface 初始化其 value 字段。
static TCKind | tk_alias TCKind 常量，使用 TCKind._tk_alias 初始化其 value 字段。
static TCKind | tk_any TCKind 常量，使用 TCKind._tk_any 初始化其 value 字段。
static TCKind | tk_array TCKind 常量，使用 TCKind._tk_array 初始化其 value 字段。
static TCKind | tk_boolean TCKind 常量，使用 TCKind._tk_boolean 初始化其 value 字段。
static TCKind | tk_char TCKind 常量，使用 TCKind._tk_char 初始化其 value 字段。
static TCKind | tk_double TCKind 常量，使用 TCKind._tk_double 初始化其 value 字段。
static TCKind | tk_enum TCKind 常量，使用 TCKind._tk_enum 初始化其 value 字段。
static TCKind | tk_except TCKind 常量，使用 TCKind._tk_except 初始化其 value 字段。
static TCKind | tk_fixed TCKind 常量，使用 TCKind._tk_fixed 初始化其 value 字段。
static TCKind | tk_float TCKind 常量，使用 TCKind._tk_float 初始化其 value 字段。
static TCKind | tk_long TCKind 常量，使用 TCKind._tk_long 初始化其 value 字段。
static TCKind | tk_longdouble TCKind 常量，使用 TCKind._tk_longdouble 初始化其 value 字段。
static TCKind | tk_longlong TCKind 常量，使用 TCKind._tk_longlong 初始化其 value 字段。
static TCKind | tk_native TCKind 常量，使用 TCKind._tk_native 初始化其 value 字段。
static TCKind | tk_null TCKind 常量，使用 TCKind._tk_null 初始化其 value 字段。
static TCKind | tk_objref TCKind 常量，使用 TCKind._tk_objref 初始化其 value 字段。
static TCKind | tk_octet TCKind 常量，使用 TCKind._tk_octet 初始化其 value 字段。
static TCKind | tk_Principal TCKind 常量，使用 TCKind._tk_Principal 初始化其 value 字段。
static TCKind | tk_sequence TCKind 常量，使用 TCKind._tk_sequence 初始化其 value 字段。
static TCKind | tk_short TCKind 常量，使用 TCKind._tk_short 初始化其 value 字段。
static TCKind | tk_string TCKind 常量，使用 TCKind._tk_string 初始化其 value 字段。
static TCKind | tk_struct TCKind 常量，使用 TCKind._tk_struct 初始化其 value 字段。
static TCKind | tk_TypeCode TCKind 常量，使用 TCKind._tk_TypeCode 初始化其 value 字段。
static TCKind | tk_ulong TCKind 常量，使用 TCKind._tk_ulong 初始化其 value 字段。
static TCKind | tk_ulonglong TCKind 常量，使用 TCKind._tk_ulonglong 初始化其 value 字段。
static TCKind | tk_union TCKind 常量，使用 TCKind._tk_union 初始化其 value 字段。
static TCKind | tk_ushort TCKind 常量，使用 TCKind._tk_ushort 初始化其 value 字段。
static TCKind | tk_value TCKind 常量，使用 TCKind._tk_value 初始化其 value 字段。
static TCKind | tk_value_box TCKind 常量，使用 TCKind._tk_value_box 初始化其 value 字段。
static TCKind | tk_void TCKind 常量，使用 TCKind._tk_void 初始化其 value 字段。
static TCKind | tk_wchar TCKind 常量，使用 TCKind._tk_wchar 初始化其 value 字段。
static TCKind | tk_wstring TCKind 常量，使用 TCKind._tk_wstring 初始化其 value 字段。
构造方法摘要
protected TCKind(int _value)
已过时。 不要使用此构造方法，因为根据 OMG 规范，此方法应该是私有的。使用 from_int(int) 代替。
方法摘要
static TCKind | from_int(int i) 将给定 int 值转换成相应的 TCKind 实例。
int | value() 检索此 TCKind 实例的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_tk_null

public static final int _tk_null
用于 null IDL 数据类型的 int 常量。

另请参见：
常量字段值

_tk_void

public static final int _tk_void
用于 IDL 数据类型 void 的 int 常量。

另请参见：
常量字段值

_tk_short

public static final int _tk_short
用于 IDL 数据类型 short 的 int 常量。

另请参见：
常量字段值

_tk_long

public static final int _tk_long
用于 IDL 数据类型 long 的 int 常量。

另请参见：
常量字段值

_tk_ushort

public static final int _tk_ushort
用于 IDL 数据类型 ushort 的 int 常量。

另请参见：
常量字段值

_tk_ulong

public static final int _tk_ulong
用于 IDL 数据类型 ulong 的 int 常量。

另请参见：
常量字段值

_tk_float

public static final int _tk_float
用于 IDL 数据类型 float 的 int 常量。

另请参见：
常量字段值

_tk_double

public static final int _tk_double
用于 IDL 数据类型 double 的 int 常量。

另请参见：
常量字段值

_tk_boolean

public static final int _tk_boolean
用于 IDL 数据类型 boolean 的 int 常量。

另请参见：
常量字段值

_tk_char

public static final int _tk_char
用于 IDL 数据类型 char 的 int 常量。

另请参见：
常量字段值

_tk_octet

public static final int _tk_octet
用于 IDL 数据类型 octet 的 int 常量。

另请参见：
常量字段值

_tk_any

public static final int _tk_any
用于 IDL 数据类型 any 的 int 常量。

另请参见：
常量字段值

_tk_TypeCode

public static final int _tk_TypeCode
用于 IDL 数据类型 TypeCode 的 int 常量。

另请参见：
常量字段值

_tk_Principal

public static final int _tk_Principal
用于 IDL 数据类型 Principal 的 int 常量。

另请参见：
常量字段值

_tk_objref

public static final int _tk_objref
用于 IDL 数据类型 objref 的 int 常量。

另请参见：
常量字段值

_tk_struct

public static final int _tk_struct
用于 IDL 数据类型 struct 的 int 常量。

另请参见：
常量字段值

_tk_union

public static final int _tk_union
用于 IDL 数据类型 union 的 int 常量。

另请参见：
常量字段值

_tk_enum

public static final int _tk_enum
用于 IDL 数据类型 enum 的 int 常量。

另请参见：
常量字段值

_tk_string

public static final int _tk_string
用于 IDL 数据类型 string 的 int 常量。

另请参见：
常量字段值

_tk_sequence

public static final int _tk_sequence
用于 IDL 数据类型 sequence 的 int 常量。

另请参见：
常量字段值

_tk_array

public static final int _tk_array
用于 IDL 数据类型 array 的 int 常量。

另请参见：
常量字段值

_tk_alias

public static final int _tk_alias
用于 IDL 数据类型 alias 的 int 常量。

另请参见：
常量字段值

_tk_except

public static final int _tk_except
用于 IDL 数据类型 except 的 int 常量。

另请参见：
常量字段值

_tk_longlong

public static final int _tk_longlong
用于 IDL 数据类型 longlong 的 int 常量。

另请参见：
常量字段值

_tk_ulonglong

public static final int _tk_ulonglong
用于 IDL 数据类型 ulonglong 的 int 常量。

另请参见：
常量字段值

_tk_longdouble

public static final int _tk_longdouble
用于 IDL 数据类型 longdouble 的 int 常量。

另请参见：
常量字段值

_tk_wchar

public static final int _tk_wchar
用于 IDL 数据类型 wchar 的 int 常量。

另请参见：
常量字段值

_tk_wstring

public static final int _tk_wstring
用于 IDL 数据类型 wstring 的 int 常量。

另请参见：
常量字段值

_tk_fixed

public static final int _tk_fixed
用于 IDL 数据类型 fixed 的 int 常量。

另请参见：
常量字段值

_tk_value

public static final int _tk_value
用于 IDL 数据类型 value 的 int 常量。

另请参见：
常量字段值

_tk_value_box

public static final int _tk_value_box
用于 IDL 数据类型 value_box 的 int 常量。

另请参见：
常量字段值

_tk_native

public static final int _tk_native
用于 IDL 数据类型 native 的 int 常量。

另请参见：
常量字段值

_tk_abstract_interface

public static final int _tk_abstract_interface
用于 IDL 数据类型 abstract interface 的 int 常量。

另请参见：
常量字段值

tk_null

public static final TCKind tk_null
TCKind 常量，使用 TCKind._tk_null 初始化其 value 字段。

tk_void

public static final TCKind tk_void
TCKind 常量，使用 TCKind._tk_void 初始化其 value 字段。

tk_short

public static final TCKind tk_short
TCKind 常量，使用 TCKind._tk_short 初始化其 value 字段。

tk_long

public static final TCKind tk_long
TCKind 常量，使用 TCKind._tk_long 初始化其 value 字段。

tk_ushort

public static final TCKind tk_ushort
TCKind 常量，使用 TCKind._tk_ushort 初始化其 value 字段。

tk_ulong

public static final TCKind tk_ulong
TCKind 常量，使用 TCKind._tk_ulong 初始化其 value 字段。

tk_float

public static final TCKind tk_float
TCKind 常量，使用 TCKind._tk_float 初始化其 value 字段。

tk_double

public static final TCKind tk_double
TCKind 常量，使用 TCKind._tk_double 初始化其 value 字段。

tk_boolean

public static final TCKind tk_boolean
TCKind 常量，使用 TCKind._tk_boolean 初始化其 value 字段。

tk_char

public static final TCKind tk_char
TCKind 常量，使用 TCKind._tk_char 初始化其 value 字段。

tk_octet

public static final TCKind tk_octet
TCKind 常量，使用 TCKind._tk_octet 初始化其 value 字段。

tk_any

public static final TCKind tk_any
TCKind 常量，使用 TCKind._tk_any 初始化其 value 字段。

tk_TypeCode

public static final TCKind tk_TypeCode
TCKind 常量，使用 TCKind._tk_TypeCode 初始化其 value 字段。

tk_Principal

public static final TCKind tk_Principal
TCKind 常量，使用 TCKind._tk_Principal 初始化其 value 字段。

tk_objref

public static final TCKind tk_objref
TCKind 常量，使用 TCKind._tk_objref 初始化其 value 字段。

tk_struct

public static final TCKind tk_struct
TCKind 常量，使用 TCKind._tk_struct 初始化其 value 字段。

tk_union

public static final TCKind tk_union
TCKind 常量，使用 TCKind._tk_union 初始化其 value 字段。

tk_enum

public static final TCKind tk_enum
TCKind 常量，使用 TCKind._tk_enum 初始化其 value 字段。

tk_string

public static final TCKind tk_string
TCKind 常量，使用 TCKind._tk_string 初始化其 value 字段。

tk_sequence

public static final TCKind tk_sequence
TCKind 常量，使用 TCKind._tk_sequence 初始化其 value 字段。

tk_array

public static final TCKind tk_array
TCKind 常量，使用 TCKind._tk_array 初始化其 value 字段。

tk_alias

public static final TCKind tk_alias
TCKind 常量，使用 TCKind._tk_alias 初始化其 value 字段。

tk_except

public static final TCKind tk_except
TCKind 常量，使用 TCKind._tk_except 初始化其 value 字段。

tk_longlong

public static final TCKind tk_longlong
TCKind 常量，使用 TCKind._tk_longlong 初始化其 value 字段。

tk_ulonglong

public static final TCKind tk_ulonglong
TCKind 常量，使用 TCKind._tk_ulonglong 初始化其 value 字段。

tk_longdouble

public static final TCKind tk_longdouble
TCKind 常量，使用 TCKind._tk_longdouble 初始化其 value 字段。

tk_wchar

public static final TCKind tk_wchar
TCKind 常量，使用 TCKind._tk_wchar 初始化其 value 字段。

tk_wstring

public static final TCKind tk_wstring
TCKind 常量，使用 TCKind._tk_wstring 初始化其 value 字段。

tk_fixed

public static final TCKind tk_fixed
TCKind 常量，使用 TCKind._tk_fixed 初始化其 value 字段。

tk_value

public static final TCKind tk_value
TCKind 常量，使用 TCKind._tk_value 初始化其 value 字段。

tk_value_box

public static final TCKind tk_value_box
TCKind 常量，使用 TCKind._tk_value_box 初始化其 value 字段。

tk_native

public static final TCKind tk_native
TCKind 常量，使用 TCKind._tk_native 初始化其 value 字段。

tk_abstract_interface

public static final TCKind tk_abstract_interface
TCKind 常量，使用 TCKind._tk_abstract_interface 初始化其 value 字段。

构造方法详细信息

TCKind

@Deprecated
protected TCKind(int _value)
已过时。 不要使用此构造方法，因为根据 OMG 规范，此方法应该是私有的。使用 from_int(int) 代替。

创建一个新的 TCKind 实例，使用给定 int 值初始化。

参数：
_value - 要转换的 int 值。它必须是 TCKind 类中的 int 常量之一。
方法详细信息

value

public int value()
检索此 TCKind 实例的值。

返回：
一个 int 值，它表示用于此 TCKind 实例的 IDL 数据类型种类

from_int

public static TCKind from_int(int i)
将给定 int 值转换成相应的 TCKind 实例。

参数：
i - 要转换的 int 值。它必须是 TCKind 类中的 int 常量之一。
返回：
value 字段与给定 int 值匹配的 TCKind 实例
抛出：
BAD_PARAM - 如果给定 int 与任何 TCKind 实例的 _value 字段都不匹配
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TIMEOUT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TIMEOUT

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.TIMEOUT
所有已实现的接口：
Serializable
public final class TIMEOUT
extends SystemException

当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。该异常是一个标准系统异常，因为生存时间 QoS 可应用于任何调用。

从以下版本开始：
J2SE 1.5
另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
TIMEOUT()
构造一个 TIMEOUT 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
TIMEOUT(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 TIMEOUT 异常。
TIMEOUT(String detailMessage)
使用指定消息构造一个 TIMEOUT 异常。
TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 TIMEOUT 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TIMEOUT

public TIMEOUT()
构造一个 TIMEOUT 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。

TIMEOUT

public TIMEOUT(String detailMessage)
使用指定消息构造一个 TIMEOUT 异常。

参数：
detailMessage - 包含详细消息的字符串。

TIMEOUT

public TIMEOUT(int minorCode,
               CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 TIMEOUT 异常。

参数：
minorCode - 次要代码。
completionStatus - 完成状态。

TIMEOUT

public TIMEOUT(String detailMessage,
               int minorCode,
               CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 TIMEOUT 异常。

参数：
detailMessage - 包含详细消息的字符串。
minorCode - 次要代码。
completionStatus - 完成状态。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRANSACTION_MODE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TRANSACTION_MODE

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.TRANSACTION_MODE
所有已实现的接口：
Serializable
public final class TRANSACTION_MODE
extends SystemException

如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的信息。它可能还包含描述该异常的字符串。OMG CORBA 核心 2.4 规范中有详细说明。

另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
TRANSACTION_MODE()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TRANSACTION_MODE

public TRANSACTION_MODE()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_MODE 异常。

TRANSACTION_MODE

public TRANSACTION_MODE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_MODE 异常。

参数：
s - 包含详细消息的 String

TRANSACTION_MODE

public TRANSACTION_MODE(int minor,
                        CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_MODE 异常。

参数：
minor - 次要代码
completed - 完成状态

TRANSACTION_MODE

public TRANSACTION_MODE(String s,
                        int minor,
                        CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_MODE 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRANSACTION_REQUIRED (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TRANSACTION_REQUIRED

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.TRANSACTION_REQUIRED
所有已实现的接口：
Serializable
public final class TRANSACTION_REQUIRED
extends SystemException

此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的信息。它可能还包含描述该异常的字符串。OMG 事务服务 (Transaction Service) 规范中有详细说明。

另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
TRANSACTION_REQUIRED()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TRANSACTION_REQUIRED

public TRANSACTION_REQUIRED()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_REQUIRED 异常。

TRANSACTION_REQUIRED

public TRANSACTION_REQUIRED(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_REQUIRED 异常。

参数：
s - 包含详细消息的 String

TRANSACTION_REQUIRED

public TRANSACTION_REQUIRED(int minor,
                            CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。

参数：
minor - 次要代码
completed - 完成状态

TRANSACTION_REQUIRED

public TRANSACTION_REQUIRED(String s,
                            int minor,
                            CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRANSACTION_ROLLEDBACK (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TRANSACTION_ROLLEDBACK

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.TRANSACTION_ROLLEDBACK
所有已实现的接口：
Serializable
public final class TRANSACTION_ROLLEDBACK
extends SystemException

当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。因此，请求操作不能执行或没有执行，因为代表该事务进行下一步计算是无效的。

有关详细信息，请参阅 OMG 事务服务 (Transaction Service) 规范。它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
TRANSACTION_ROLLEDBACK()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TRANSACTION_ROLLEDBACK

public TRANSACTION_ROLLEDBACK()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_ROLLEDBACK 异常。

TRANSACTION_ROLLEDBACK

public TRANSACTION_ROLLEDBACK(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_ROLLEDBACK 异常。

参数：
s - 包含详细消息的 String

TRANSACTION_ROLLEDBACK

public TRANSACTION_ROLLEDBACK(int minor,
                              CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。

参数：
minor - 次要代码
completed - 完成状态

TRANSACTION_ROLLEDBACK

public TRANSACTION_ROLLEDBACK(String s,
                              int minor,
                              CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRANSACTION_UNAVAILABLE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TRANSACTION_UNAVAILABLE

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.TRANSACTION_UNAVAILABLE
所有已实现的接口：
Serializable
public final class TRANSACTION_UNAVAILABLE
extends SystemException

当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。 它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的信息。它可能还包含描述该异常的字符串。OMG CORBA 核心 2.4 规范中有详细说明。

另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
TRANSACTION_UNAVAILABLE()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TRANSACTION_UNAVAILABLE

public TRANSACTION_UNAVAILABLE()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_UNAVAILABLE 异常。

TRANSACTION_UNAVAILABLE

public TRANSACTION_UNAVAILABLE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_UNAVAILABLE 异常。

参数：
s - 包含详细消息的 String

TRANSACTION_UNAVAILABLE

public TRANSACTION_UNAVAILABLE(int minor,
                               CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。

参数：
minor - 次要代码
completed - 完成状态

TRANSACTION_UNAVAILABLE

public TRANSACTION_UNAVAILABLE(String s,
                               int minor,
                               CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRANSIENT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TRANSIENT

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.TRANSIENT
所有已实现的接口：
Serializable
public final class TRANSIENT
extends SystemException

当 ORB 试图到达某一对象但失败时，抛出此异常。该异常并不指示对象不存在。它只意味着由于无法到达对象而不能进一步确定该对象的状态。例如，如果因为服务器或实现存储库关闭而导致尝试建立连接失败，则引发此异常。

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
TRANSIENT()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSIENT 异常。
TRANSIENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSIENT 异常。
TRANSIENT(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSIENT 异常。
TRANSIENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSIENT 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TRANSIENT

public TRANSIENT()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSIENT 异常。

TRANSIENT

public TRANSIENT(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSIENT 异常。

参数：
s - 包含详细消息的 String

TRANSIENT

public TRANSIENT(int minor,
                 CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSIENT 异常。

参数：
minor - 次要代码
completed - 完成状态

TRANSIENT

public TRANSIENT(String s,
                 int minor,
                 CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSIENT 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeCode (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TypeCode

java.lang.Object
    继承者  org.omg.CORBA.TypeCode
所有已实现的接口：
Serializable, IDLEntity
public abstract class TypeCode
extends Object
implements IDLEntity

用于有关特定 CORBA 数据类型的信息的容器。

TypeCode 对象的作用包括：

  • 在动态调用接口 (Dynamic Invocation Interface) 中，用于指示实际参数的类型或返回值的类型。
    NamedValue 对象用于表示参数和返回值。其中有一个组件是 Any 对象，该 Any 对象又有一个 TypeCode 对象作为其组件之一。
  • 由接口存储库 (Interface Repository) 用来表示作为许多 OMG IDL 声明一部分的类型说明。

TypeCode 对象的表示形式是不透明的，从理论上说，TypeCode 对象由以下内容组成：

  • 一个 kind 字段，它被设置为 TCKind 类的一个实例
  • 0 个或多个适用于特定种类的附加字段。例如，描述 OMG IDL 类型 1ong 的 TypeCode 对象所具有的种类为 TCKind.tk_long，没有附加字段。描述 OMG IDL 类型 sequence<boolean, 10> 的 TypeCode 具有一个值为 TCKind.tk_sequence 的 kind 字段，以及值为 boolean 和 10（用于序列元素的类型和序列的长度）的字段。

可以通过以下各种方式获得 TypeCode 对象：
  1. 通过调用 Any.insert_X 方法，其中 X 为基本 IDL 类型。此方法为类型 X 创建 TypeCode 对象，并将其分配给 Any 对象的 type 字段。
  2. 通过调用 ORB 类中的方法

    例如，以下代码为 string（最长为 30 个字符）创建 TypeCode：

       org.omg.CORBA.TypeCode tcString = orb.create_string_tc(30);

    以下代码为由五个 string 组成的 array 创建 TypeCode 对象：

       org.omg.CORBA.TypeCode tcArray = orb.create_array_tc(
                                       5, TCKind.tk_string);

    以下代码为名为 "Account" 的接口创建 TypeCode 对象：

       org.omg.CORBA.TypeCode tcInterface = orb.create_interface_tc(
                                                 "thisId", "Account");
  3. 作为用于用户定义 IDL 类型的 Holder 类中 _type 方法的返回值。这些 Holder 类由 idltojava 编译器生成。
  4. 从 CORBA 接口存储库中获取

TypeCode 类中的大多数方法都是访问方法，包含在 TypeCode 对象中的信息是特定于特定类型的。所以，必须只在所应用类型代码的种类上调用这些方法。如果访问方法试图从不适当类型代码种类中访问信息，则将抛出异常 TypeCodePackage.BadKind。例如，如果在 union 以外的其他种类上调用 discriminator_type 方法，则将抛出 BadKind 异常，因为只有 union 具有鉴别符 (discriminator)。以下列表展示将哪些方法应用到哪些类型代码种类：

以下方法可以在所有 TypeCode 种类上调用：

  • equal
  • kind

以下方法可以在 objref、struct、union、enum、alias、exception、value、value_box、native 和 abstract_interface 上调用：

  • id
  • name

以下方法可以在 struct、union、enum 和 exception 上调用：

  • member_count
  • member_name

以下方法可以在 struct、union 和 exception 上调用：

  • member_type(int index)

以下方法可以在 union 上调用：

  • member_label
  • discriminator_type
  • default_index

以下方法可以在 string、sequence 和 array 上调用：

  • length

以下方法可以在 alias、sequence、array 和 value_box 上调用：

  • content_type

与其他 CORBA 伪对象不同，TypeCode 对象可以作为一般 IDL 参数传递。

不推荐使用 parameter 和 param_count 方法，所以未映射。

Java IDL 扩展了 CORBA 规范，以允许能在 struct TypeCode 上执行的所有操作同样能在 exception TypeCode 上执行。

构造方法摘要
TypeCode()
方法摘要
abstract TypeCode | concrete_base_type() 返回一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型。
abstract TypeCode | content_type() 返回表示此 TypeCode 对象所描述成员 IDL 类型的 TypeCode 对象。
abstract int | default_index() 返回默认成员的索引，如果没有默认成员，则返回 -1。
abstract TypeCode | discriminator_type() 返回描述所有非默认成员标签的 TypeCode 对象。
abstract boolean | equal(TypeCode tc) 将此 TypeCode 对象与给定对象比较，测试它们是否相等。
abstract boolean | equivalent(TypeCode tc) 测试给定 TypeCode 对象是否等于此 TypeCode 对象。
abstract short | fixed_digits() 返回此 TypeCode 对象所描述的 fixed 类型中数字的数量。
abstract short | fixed_scale() 返回此 TypeCode 对象所描述的 fixed 类型的标度。
abstract TypeCode | get_compact_typecode() 剔除所有可选名称和成员名称字段，但使所有别名 typecode 保留原样。
abstract String | id() 检索全局标识此 TypeCode 对象类型的 RepositoryId。
abstract TCKind | kind() 检索此 TypeCode 对象的种类。
abstract int | length() 返回此 TypeCode 对象所描述类型中的成员数。
abstract int | member_count() 检索此 TypeCode 对象所描述类型中的成员数。
abstract Any | member_label(int index) 检索给定索引标识的 union 成员的标签。
abstract String | member_name(int index) 检索给定索引标识的成员的简单名称。
abstract TypeCode | member_type(int index) 检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
abstract short | member_visibility(int index) 返回一个常量，它指示位于给定索引处的成员的可见性。
abstract String | name() 在 TypeCode 对象的封闭作用域内检索标识此对象的简单名称。
abstract short | type_modifier() 返回一个常量，它指示此 TypeCode 对象所描述的 value 类型的修饰符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TypeCode

public TypeCode()
方法详细信息

equal

public abstract boolean equal(TypeCode tc)
将此 TypeCode 对象与给定对象比较，测试它们是否相等。如果两个 TypeCode 对象可以互换并在对它们应用 TypeCode 操作时返回相同的结果，则这两个对象相等。

参数：
tc - 要与之比较的 TypeCode 对象
返回：
如果类型代码相同，则返回 true；否则返回 false

equivalent

public abstract boolean equivalent(TypeCode tc)
测试给定 TypeCode 对象是否等于此 TypeCode 对象。

参数：
tc - 将与此 typecode 比较的 typecode
返回：
如果给定 typecode 等于此 typecode，则返回 true；否则返回 false

get_compact_typecode

public abstract TypeCode get_compact_typecode()
剔除所有可选名称和成员名称字段，但使所有别名 typecode 保留原样。

返回：
一个 TypeCode 对象，已剔除可选名称和成员名称字段，但别名 typecode 保持不变
另请参见：
CORBA 包中有关未实现特性的注释

kind

public abstract TCKind kind()
检索此 TypeCode 对象的种类。代码类型的种类可确定哪些 TypeCode 方法可以合法地在该种类之上进行调用。

kind 方法可以在任何 TypeCode 对象上调用。

返回：
指示此 TypeCode 对象 kind 字段值的 TCKind 实例

id

public abstract String id()
                   throws BadKind
检索全局标识此 TypeCode 对象类型的 RepositoryId。

id 方法可以在 object reference、structure、union、enumeration、alias、exception、valuetype、boxed valuetype、native 和 abstract interface 类型代码上调用。object reference、exception、valuetype、boxed valuetype、native 和 abstract interface TypeCode 对象总是有一个 RepositoryId。从接口存储库 (Interface Repository) 或方法 ORB.create_operation_list 中获得的 structure、union、enumeration 和 alias TypeCode 对象也总是有一个 RepositoryId。如果没有 RepositoryId，则该方法可以返回一个空字符串。

返回：
此 TypeCode 对象的 RepositoryId，如果没有 RepositoryID，则返回一个空字符串
抛出：
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

name

public abstract String name()
                     throws BadKind
在 TypeCode 对象的封闭作用域内检索标识此对象的简单名称。因为这些名称对于 Repository 而言是本地的，所以从 TypeCode 对象返回的名称可能与任何特定 Repository 中的类型名称不匹配，甚至可能是一个空字符串。

name 方法可以在 object reference、structure、union、enumeration、alias、exception、valuetype、boxed valuetype、native 和 abstract interface TypeCode 对象上调用。

返回：
标识此 TypeCode 对象的名称或一个空字符串
抛出：
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

member_count

public abstract int member_count()
                          throws BadKind
检索此 TypeCode 对象所描述类型中的成员数。

member_count 方法可以在 structure、union 和 enumeration TypeCode 对象上调用。Java IDL 扩展了 CORBA 规范，允许此方法在异常上进行操作。

返回：
组成此 TypeCode 对象所描述类型的成员数
抛出：
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

member_name

public abstract String member_name(int index)
                            throws BadKind,
                                   Bounds
检索给定索引标识的成员的简单名称。因为这些名称对于 Repository 而言是本地的，所以从 TypeCode 对象返回的名称可能与任何特定 Repository 中的成员名称不匹配，甚至可能是一个空字符串。

可以在 structure、union 和 enumeration TypeCode 对象上调用 member_name 方法。Java IDL 扩展了 CORBA 规范，允许此方法在异常上进行操作。

参数：
index - 请求名称的成员的索引
返回：
由索引标识的成员的简单名称，或者空字符串
抛出：
Bounds - 如果索引大于等于组成该类型的成员数
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

member_type

public abstract TypeCode member_type(int index)
                              throws BadKind,
                                     Bounds
检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。

member_type 方法可以在 structure 和 union TypeCode 对象上调用。Java IDL 扩展了 CORBA 规范，允许此方法在异常上进行操作。

参数：
index - 开始请求类型信息的成员的索引
返回：
描述给定索引处成员的 TypeCode 对象
抛出：
Bounds - 如果索引大于等于组成该类型的成员数
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

member_label

public abstract Any member_label(int index)
                          throws BadKind,
                                 Bounds
检索给定索引标识的 union 成员的标签。对于默认成员，该标签是 0 八位组 (zero octet)。

member_label 方法可以在 union TypeCode 对象上调用。

参数：
index - 请求标签的 union 成员的索引
返回：
描述所请求 union 成员标签的 Any 对象；对于默认成员，返回 0 八位组
抛出：
Bounds - 如果索引大于等于组成 union 的成员数
BadKind - 如果在非 union TypeCode 对象上调用该方法

discriminator_type

public abstract TypeCode discriminator_type()
                                     throws BadKind
返回描述所有非默认成员标签的 TypeCode 对象。discriminator_type 方法只能在 union TypeCode 对象上调用。

返回：
描述非默认成员标签的 TypeCode 对象
抛出：
BadKind - 如果在非 union TypeCode 对象上调用该方法

default_index

public abstract int default_index()
                           throws BadKind
返回默认成员的索引，如果没有默认成员，则返回 -1。

default_index 方法只能在 union TypeCode 对象上调用。

返回：
默认成员的索引；如果没有默认成员，则返回 -1
抛出：
BadKind - 如果在非 union TypeCode 对象上调用该方法

length

public abstract int length()
                    throws BadKind
返回此 TypeCode 对象所描述类型中的成员数。对于 string 和 sequence，该方法返回一个范围，0 指示无界的 string 或 sequence。对于 array，此方法返回其成员数。

length 方法可以在 string、sequence 和 array TypeCode 对象上调用。

返回：
string 和 sequence 的范围，或者 array 的成员数
抛出：
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

content_type

public abstract TypeCode content_type()
                               throws BadKind
返回表示此 TypeCode 对象所描述成员 IDL 类型的 TypeCode 对象。对于 sequence 和 array，该方法返回元素类型。对于 alias，该方法返回原始类型。注意，多维 array 用嵌套 TypeCode 对象表示，每个维度一个对象。对于 boxed valuetype，该方法返回 boxed 类型。

content_type 方法可以在 sequence、array、alias 和 boxed valuetype TypeCode 对象上调用。

返回：
一个 TypeCode 对象，它对于 sequence 和 array 表示元素类型；对于 alias 表示原始类型；对于 boxed valuetype 表示 boxed 类型。
抛出：
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

fixed_digits

public abstract short fixed_digits()
                            throws BadKind
返回此 TypeCode 对象所描述的 fixed 类型中数字的数量。例如，数字 3000.275d 的 typecode 是 fixed<7,3>，其中 7 是精确度，3 是标度。

返回：
数字的总数
抛出：
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

fixed_scale

public abstract short fixed_scale()
                           throws BadKind
返回此 TypeCode 对象所描述的 fixed 类型的标度。正数指示小数点右边的数字个数。例如，数字 3000d 的 typecode 是 fixed<4,0>，其中第一个数字是精度，第二个数字是标度。出现负数也是有可能的，在小数点的左边添加 0 即可。在这种情况下，fixed<1,-3> 是数字 3000d 的 typecode。

返回：
此 TypeCode 对象所描述 fixed 类型的标度
抛出：
BadKind - 如果在不适当的 TypeCode 对象种类上调用该方法

member_visibility

public abstract short member_visibility(int index)
                                 throws BadKind,
                                        Bounds
返回一个常量，它指示位于给定索引处的成员的可见性。 此操作只能在非 boxed value TypeCode 对象上调用。

参数：
index - 指示 value 中索引的 int 值
返回：
PRIVATE_MEMBER.value 或 PUBLIC_MEMBER.value
抛出：
BadKind - 如果在非 value 类型 TypeCode 对象上调用此方法
Bounds - 如果给定索引超出范围
另请参见：
CORBA 包中有关未实现特性的注释

type_modifier

public abstract short type_modifier()
                             throws BadKind
返回一个常量，它指示此 TypeCode 对象所描述的 value 类型的修饰符。返回的常量必须是以下常量之一：VM_NONE.value、VM_ABSTRACT.value、VM_CUSTOM.value 或 VM_TRUNCATABLE.value。

返回：
描述此 TypeCode 对象所描述 value 类型的常量
抛出：
BadKind - 如果在非 value 类型 TypeCode 对象上调用此方法
另请参见：
CORBA 包中有关未实现特性的注释

concrete_base_type

public abstract TypeCode concrete_base_type()
                                     throws BadKind
返回一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型。如果没有具体基本类型，则返回 null。

返回：
一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型
抛出：
BadKind - 如果在非 boxed value 类型 TypeCode 对象上调用此方法
另请参见：
CORBA 包中有关未实现特性的注释
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeCodeHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 TypeCodeHolder

java.lang.Object
    继承者  org.omg.CORBA.TypeCodeHolder
所有已实现的接口：
Streamable
public final class TypeCodeHolder
extends Object
implements Streamable

TypeCode 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

用于 TypeCode 对象的 Holder 类，用来存储 IDL 操作中的 "out" 和 "inout" 参数。如果 IDL 操作签名将一个 IDL TypeCode 作为 "out" 或 "inout" 参数，则程序员必须传递一个 TypeCodeHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myTypeCodeHolder 是 TypeCodeHolder 实例，则可以使用 myTypeCodeHolder.value 访问存储在其 value 字段中的值。

从以下版本开始：
JDK1.2

字段摘要
 TypeCode value
此 TypeCodeHolder 对象保存的 TypeCode 值。
构造方法摘要
TypeCodeHolder()
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为 null。
TypeCodeHolder(TypeCode initial)
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为给定的 TypeCode 对象。
方法摘要
void | _read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 TypeCodeHolder 对象中的值。
TypeCode | _type() 返回对应于此 TypeCodeHolder 对象中所保存的值的 TypeCode。
void | _write(OutputStream output) 将此 TypeCodeHolder 对象中的值编组到 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public TypeCode value
此 TypeCodeHolder 对象保存的 TypeCode 值。

构造方法详细信息

TypeCodeHolder

public TypeCodeHolder()
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为 null。

TypeCodeHolder

public TypeCodeHolder(TypeCode initial)
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为给定的 TypeCode 对象。

参数：
initial - TypeCode 对象，用来初始化新建 TypeCodeHolder 对象的 value 字段
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取数据，并使用已解组数据初始化此 TypeCodeHolder 对象中的值。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 TypeCodeHolder 对象中的值编组到 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
返回对应于此 TypeCodeHolder 对象中所保存的值的 TypeCode。

指定者：
接口 Streamable 中的 _type
返回：
此 TypeCodeHolder 对象中所保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ULongLongSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ULongLongSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.ULongLongSeqHelper

public abstract class ULongLongSeqHelper
extends Object

ULongLongSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/ULongLongSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:37 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
ULongLongSeqHelper()
方法摘要
static long[] | extract(Any a)
static String | id()
static void | insert(Any a, long[] that)
static long[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, long[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ULongLongSeqHelper

public ULongLongSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          long[] that)

extract

public static long[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static long[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         long[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ULongSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ULongSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.ULongSeqHelper

public abstract class ULongSeqHelper
extends Object

ULongSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/ULongSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
ULongSeqHelper()
方法摘要
static int[] | extract(Any a)
static String | id()
static void | insert(Any a, int[] that)
static int[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ULongSeqHelper

public ULongSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          int[] that)

extract

public static int[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ULongLongSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ULongLongSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.ULongLongSeqHolder
所有已实现的接口：
Streamable
public final class ULongLongSeqHolder
extends Object
implements Streamable

ULongLongSeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/ULongLongSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:37 (GMT+00:00)

字段摘要
 long[] value
构造方法摘要
ULongLongSeqHolder()
ULongLongSeqHolder(long[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public long[] value
构造方法详细信息

ULongLongSeqHolder

public ULongLongSeqHolder()

ULongLongSeqHolder

public ULongLongSeqHolder(long[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ULongSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ULongSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.ULongSeqHolder
所有已实现的接口：
Streamable
public final class ULongSeqHolder
extends Object
implements Streamable

ULongSeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/ULongSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00)

字段摘要
 int[] value
构造方法摘要
ULongSeqHolder()
ULongSeqHolder(int[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public int[] value
构造方法详细信息

ULongSeqHolder

public ULongSeqHolder()

ULongSeqHolder

public ULongSeqHolder(int[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnionMember (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UnionMember

java.lang.Object
    继承者  org.omg.CORBA.UnionMember
所有已实现的接口：
Serializable, IDLEntity
public final class UnionMember
extends Object
implements IDLEntity

接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。

字段摘要
Any | label 此 UnionMember 对象所描述的 union 成员的标签。
String | name 此 UnionMember 对象所描述的 union 成员的名称。
TypeCode | type 此 UnionMember 对象所描述的 union 成员的类型。
IDLType | type_def typedef，它表示此 UnionMember 对象描述的 union 成员的 IDL 类型。
构造方法摘要
UnionMember()
构造一个新的 UnionMember 对象，将其字段初始化为 null。
UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

name

public String name
此 UnionMember 对象所描述的 union 成员的名称。

label

public Any label
此 UnionMember 对象所描述的 union 成员的标签。

type

public TypeCode type
此 UnionMember 对象所描述的 union 成员的类型。

type_def

public IDLType type_def
typedef，它表示此 UnionMember 对象描述的 union 成员的 IDL 类型。

构造方法详细信息

UnionMember

public UnionMember()
构造一个新的 UnionMember 对象，将其字段初始化为 null。

UnionMember

public UnionMember(String __name,
                   Any __label,
                   TypeCode __type,
                   IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。

参数：
__name - 具有此 UnionMember 对象名称的 String 对象
__label - 具有此 UnionMember 对象标签的 Any 对象
__type - 描述此 UnionMember 对象类型的 TypeCode 对象
__type_def - 表示此 UnionMember 对象 IDL 类型的 IDLType 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnionMemberHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UnionMemberHelper

java.lang.Object
    继承者  org.omg.CORBA.UnionMemberHelper

public abstract class UnionMemberHelper
extends Object

UnionMember 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/UnionMemberHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为1999 年 6 月 3 日 11:33:43 (GMT+00:00)

构造方法摘要
UnionMemberHelper()
方法摘要
static UnionMember | extract(Any a)
static String | id()
static void | insert(Any a, UnionMember that)
static UnionMember | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, UnionMember value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UnionMemberHelper

public UnionMemberHelper()
方法详细信息

insert

public static void insert(Any a,
                          UnionMember that)

extract

public static UnionMember extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static UnionMember read(InputStream istream)

write

public static void write(OutputStream ostream,
                         UnionMember value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UNKNOWN (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UNKNOWN

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.UNKNOWN
所有已实现的接口：
Serializable
public final class UNKNOWN
extends SystemException

如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。服务器返回一个客户端未知的系统异常时也会引发 UNKNOWN 异常。（如果服务器使用比客户端新的 CORBA 版本，并且在较新版本中添加了新的系统异常，则可能出现这种情况。）

它包含次要代码 (minor code) 和完成状态 (completion status)，次要代码提供有关造成该异常原因的更详细信息。它可能还包含描述该异常的字符串。

请参阅次要代码的含义一节，查看此异常的次要代码。

另请参见：
关于 Java IDL 异常的文档

字段摘要
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
UNKNOWN()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 UNKNOWN 异常。
UNKNOWN(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 UNKNOWN 异常。
UNKNOWN(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 UNKNOWN 异常。
UNKNOWN(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 UNKNOWN 异常。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UNKNOWN

public UNKNOWN()
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 UNKNOWN 异常。

UNKNOWN

public UNKNOWN(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 UNKNOWN 异常。

参数：
s - 包含详细消息的 String

UNKNOWN

public UNKNOWN(int minor,
               CompletionStatus completed)
使用指定次要代码和完成状态构造一个 UNKNOWN 异常。

参数：
minor - 次要代码
completed - 完成状态

UNKNOWN

public UNKNOWN(String s,
               int minor,
               CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 UNKNOWN 异常。

参数：
s - 包含描述消息的 String
minor - 次要代码
completed - 完成状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownUserException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UnknownUserException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.UnknownUserException
所有已实现的接口：
Serializable, IDLEntity
public final class UnknownUserException
extends UserException

包含由服务器返回的用户异常的类。当客户端使用 DII 执行调用时，从服务器返回的任何异常都被封闭在 UnknownUserException 对象所包含的 Any 对象中。此异常可从 Request.env 方法返回的 Environment 对象中得到。

另请参见：
关于 Java IDL 异常的文档, Request

字段摘要
 Any except
包含由服务器抛出的实际用户异常的 Any 实例。
构造方法摘要
UnknownUserException()
构造一个 UnknownUserException 对象。
UnknownUserException(Any a)
构造一个包含给定 Any 对象的 UnknownUserException 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

except

public Any except
包含由服务器抛出的实际用户异常的 Any 实例。

构造方法详细信息

UnknownUserException

public UnknownUserException()
构造一个 UnknownUserException 对象。

UnknownUserException

public UnknownUserException(Any a)
构造一个包含给定 Any 对象的 UnknownUserException 对象。

参数：
a - 包含服务器返回的用户异常的 Any 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownUserExceptionHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UnknownUserExceptionHelper

java.lang.Object
    继承者  org.omg.CORBA.UnknownUserExceptionHelper

public abstract class UnknownUserExceptionHelper
extends Object

UnknownUserException 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/UnknownUserExceptionHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 CORBA.idl 中生成，生成时间为 PDT 时间 2000 年 8 月 24 日（星期四）下午 5:52:22

构造方法摘要
UnknownUserExceptionHelper()
方法摘要
static UnknownUserException | extract(Any a)
static String | id()
static void | insert(Any a, UnknownUserException that)
static UnknownUserException | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, UnknownUserException value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UnknownUserExceptionHelper

public UnknownUserExceptionHelper()
方法详细信息

insert

public static void insert(Any a,
                          UnknownUserException that)

extract

public static UnknownUserException extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static UnknownUserException read(InputStream istream)

write

public static void write(OutputStream ostream,
                         UnknownUserException value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownUserExceptionHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UnknownUserExceptionHolder

java.lang.Object
    继承者  org.omg.CORBA.UnknownUserExceptionHolder
所有已实现的接口：
Streamable
public final class UnknownUserExceptionHolder
extends Object
implements Streamable

UnknownUserException 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/UnknownUserExceptionHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 CORBA.idl 中生成，生成时间为 PDT 时间 2000 年 8 月 24 日（星期四）下午 5:52:22

字段摘要
 UnknownUserException value
构造方法摘要
UnknownUserExceptionHolder()
UnknownUserExceptionHolder(UnknownUserException initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public UnknownUserException value
构造方法详细信息

UnknownUserExceptionHolder

public UnknownUserExceptionHolder()

UnknownUserExceptionHolder

public UnknownUserExceptionHolder(UnknownUserException initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UNSUPPORTED_POLICY (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 UNSUPPORTED_POLICY

public interface UNSUPPORTED_POLICY

在所请求的 Policy 被 ORB 认为是有效的，但目前不受支持时将被填充的一个 PolicyErrorCode。

字段摘要
static short value
PolicyError 异常的 Error 代码。

字段详细信息

value

static final short value
PolicyError 异常的 Error 代码。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UNSUPPORTED_POLICY_VALUE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 UNSUPPORTED_POLICY_VALUE

public interface UNSUPPORTED_POLICY_VALUE

当所请求的 Policy 值是有效类型并且在该类型的有效范围内，但该有效值目前不受支持时将被填充的 PolicyErrorCode。

字段摘要
static short value
PolicyError 异常的 Error 代码。

字段详细信息

value

static final short value
PolicyError 异常的 Error 代码。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UserException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
所有已实现的接口：
Serializable, IDLEntity
直接已知子类：
AdapterAlreadyExists, AdapterInactive, AdapterNonExistent, AlreadyBound, BadKind, Bounds, Bounds, CannotProceed, DuplicateName, FormatMismatch, ForwardRequest, ForwardRequest, InconsistentTypeCode, InconsistentTypeCode, Invalid, InvalidAddress, InvalidName, InvalidName, InvalidName, InvalidPolicy, InvalidSeq, InvalidSlot, InvalidTypeForEncoding, InvalidValue, InvalidValue, NoContext, NoServant, NotEmpty, NotFound, ObjectAlreadyActive, ObjectNotActive, PolicyError, ServantAlreadyActive, ServantNotActive, TypeMismatch, TypeMismatch, TypeMismatch, UnknownEncoding, UnknownUserException, WrongAdapter, WrongPolicy, WrongTransaction
public abstract class UserException
extends Exception
implements IDLEntity

CORBA IDL 定义的用户异常的根类。所有 CORBA 用户异常都是经过检查的异常，这意味着它们需要在方法签名中被声明。

另请参见：
关于 Java IDL 异常的文档

构造方法摘要
protected | UserException() 构造一个 UserException 对象。
protected | UserException(String reason) 构造带详细消息的 UserException 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UserException

protected UserException()
构造一个 UserException 对象。此方法仅由子类调用。

UserException

protected UserException(String reason)
构造带详细消息的 UserException 对象。此方法仅由子类调用。

参数：
reason - 提供此异常原因的 String 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UShortSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UShortSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.UShortSeqHelper

public abstract class UShortSeqHelper
extends Object

UShortSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/UShortSeqHelper.java 由 IDL-to-Java 编译器（可移植）"3.0" 版从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
UShortSeqHelper()
方法摘要
static short[] | extract(Any a)
static String | id()
static void | insert(Any a, short[] that)
static short[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UShortSeqHelper

public UShortSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          short[] that)

extract

public static short[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UShortSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 UShortSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.UShortSeqHolder
所有已实现的接口：
Streamable
public final class UShortSeqHolder
extends Object
implements Streamable

UShortSeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/UShortSeqHolder.java 由 IDL-to-Java 编译器（可移植）"3.0" 版从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日的 22:41:36 (GMT+00:00)

字段摘要
 short[] value
构造方法摘要
UShortSeqHolder()
UShortSeqHolder(short[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public short[] value
构造方法详细信息

UShortSeqHolder

public UShortSeqHolder()

UShortSeqHolder

public UShortSeqHolder(short[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueBaseHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ValueBaseHelper

java.lang.Object
    继承者  org.omg.CORBA.ValueBaseHelper

public abstract class ValueBaseHelper
extends Object

构造方法摘要
ValueBaseHelper()
方法摘要
static Serializable | extract(Any a)
static String | id()
static void | insert(Any a, Serializable that)
static Serializable | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Serializable value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ValueBaseHelper

public ValueBaseHelper()
方法详细信息

insert

public static void insert(Any a,
                          Serializable that)

extract

public static Serializable extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Serializable read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Serializable value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueBaseHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ValueBaseHolder

java.lang.Object
    继承者  org.omg.CORBA.ValueBaseHolder
所有已实现的接口：
Streamable
public final class ValueBaseHolder
extends Object
implements Streamable

ValueBase 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

用于 java.io.Serializable 的 Holder 类，用来存储 IDL 方法中的 "out" 和 "inout" 参数。如果 IDL 方法签名将一个 IDL ValueBase 作为 "out" 或 "inout" 参数，则程序员必须传递一个 ValueBaseHolder 实例作为方法调用中的相应参数；对于 "inout" 参数，程序员还必须填充将被发送到服务器的 "in" 值。在方法调用返回之前，ORB 将填充与从服务器返回的 "out" 值对应的值。

如果 myValueBaseHolder 是 ValueBaseHolder 实例，则可以使用 myValueBaseHolder.value 访问存储在其 value 字段中的值。

字段摘要
 Serializable value
此 ValueBaseHolder 对象保存的 java.io.Serializable 值。
构造方法摘要
ValueBaseHolder()
构造一个新的 ValueBaseHolder 对象，将其 value 字段初始化为 0。
ValueBaseHolder(Serializable initial)
构造一个新的 ValueBaseHolder 对象，并将其 value 字段初始化为给定的 java.io.Serializable。
方法摘要
void | _read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
TypeCode | _type() 返回对应于此 Holder 中保存的值的 TypeCode 对象。
void | _write(OutputStream output) 将此 Holder 中的值编组到 output。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Serializable value
此 ValueBaseHolder 对象保存的 java.io.Serializable 值。

构造方法详细信息

ValueBaseHolder

public ValueBaseHolder()
构造一个新的 ValueBaseHolder 对象，将其 value 字段初始化为 0。

ValueBaseHolder

public ValueBaseHolder(Serializable initial)
构造一个新的 ValueBaseHolder 对象，并将其 value 字段初始化为给定的 java.io.Serializable。

参数：
initial - java.io.Serializable，用来初始化新建 ValueBaseHolder 对象的 value 字段
方法详细信息

_read

public void _read(InputStream input)
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。

指定者：
接口 Streamable 中的 _read
参数：
input - 包含从导线获取的 CDR 格式数据的 InputStream。

_write

public void _write(OutputStream output)
将此 Holder 中的值编组到 output。

指定者：
接口 Streamable 中的 _write
参数：
output - 将包含 CDR 格式数据的 OutputStream。

_type

public TypeCode _type()
返回对应于此 Holder 中保存的值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
此 holder 中保存值的 TypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VM_CUSTOM (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 VM_CUSTOM

public interface VM_CUSTOM

定义用来表示类型代码中自定义编组值类型的代码。这是 TypeCode 接口上的 type_modifier 方法可能得到的结果之一。

另请参见：
TypeCode

字段摘要
static short value
表示 typecode 中自定义编组值类型的值。

字段详细信息

value

static final short value
表示 typecode 中自定义编组值类型的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueMember (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ValueMember

java.lang.Object
    继承者  org.omg.CORBA.ValueMember
所有已实现的接口：
Serializable, IDLEntity
public final class ValueMember
extends Object
implements IDLEntity

接口存储库 (Interface Repository) 中关于 value 对象成员的描述。

字段摘要
short | access 此 ValueMember 对象所描述的 value 成员的访问类型（公共或私有）。
String | defined_in 用来定义此成员的 value 的存储库 ID。
String | id 此 ValueMember 对象所描述的 value 成员的存储库 ID
String | name 此 ValueMember 对象所描述的 value 成员的名称。
TypeCode | type 此 value 成员的类型。
IDLType | type_def typedef，它表示此 ValueMember 对象描述的 value 成员的 IDL 类型。
String | version 用来定义此成员的 value 的版本。
构造方法摘要
ValueMember()
构造一个默认 ValueMember 对象。
ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
构造一个 ValueMember 对象，使用给定值进行初始化。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

name

public String name
此 ValueMember 对象所描述的 value 成员的名称。

id

public String id
此 ValueMember 对象所描述的 value 成员的存储库 ID

defined_in

public String defined_in
用来定义此成员的 value 的存储库 ID。

version

public String version
用来定义此成员的 value 的版本。

type

public TypeCode type
此 value 成员的类型。

type_def

public IDLType type_def
typedef，它表示此 ValueMember 对象描述的 value 成员的 IDL 类型。

access

public short access
此 ValueMember 对象所描述的 value 成员的访问类型（公共或私有）。

构造方法详细信息

ValueMember

public ValueMember()
构造一个默认 ValueMember 对象。

ValueMember

public ValueMember(String __name,
                   String __id,
                   String __defined_in,
                   String __version,
                   TypeCode __type,
                   IDLType __type_def,
                   short __access)
构造一个 ValueMember 对象，使用给定值进行初始化。

参数：
__name - 此 ValueMember 对象所描述的 value 成员的名称。
__id - 此 ValueMember 对象所描述的 value 成员的存储库 ID；
__defined_in - 用来定义此成员的 value 的存储库 ID。
__version - 用来定义此成员的 value 的版本。
__type - 此 value 成员的类型。
__type_def - typedef，表示此 ValueMember 对象所描述的 value 成员的存储库 ID。
__access - 此 ValueMember 对象所描述的 value 成员的访问类型（公共或私有）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueMemberHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 ValueMemberHelper

java.lang.Object
    继承者  org.omg.CORBA.ValueMemberHelper

public abstract class ValueMemberHelper
extends Object

ValueMember 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/ValueMemberHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:44 (GMT+00:00)

构造方法摘要
ValueMemberHelper()
方法摘要
static ValueMember | extract(Any a)
static String | id()
static void | insert(Any a, ValueMember that)
static ValueMember | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ValueMember value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ValueMemberHelper

public ValueMemberHelper()
方法详细信息

insert

public static void insert(Any a,
                          ValueMember that)

extract

public static ValueMember extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ValueMember read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ValueMember value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VersionSpecHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 VersionSpecHelper

java.lang.Object
    继承者  org.omg.CORBA.VersionSpecHelper

public abstract class VersionSpecHelper
extends Object

VersionSpec 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/VersionSpecHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:43 (GMT+00:00)

构造方法摘要
VersionSpecHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VersionSpecHelper

public VersionSpecHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VisibilityHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 VisibilityHelper

java.lang.Object
    继承者  org.omg.CORBA.VisibilityHelper

public abstract class VisibilityHelper
extends Object

Visibility 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/VisibilityHelper.java 由 "3.0" 版的 DL-to-Java 编译器（可移植）从 ir.idl 中生成，生成时间为 1999 年 6 月 3 日 11:33:44 (GMT+00:00)

构造方法摘要
VisibilityHelper()
方法摘要
static short | extract(Any a)
static String | id()
static void | insert(Any a, short that)
static short | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VisibilityHelper

public VisibilityHelper()
方法详细信息

insert

public static void insert(Any a,
                          short that)

extract

public static short extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VM_ABSTRACT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 VM_ABSTRACT

public interface VM_ABSTRACT

定义用来表示 typecode 中的 Abstract 接口的代码。这是 TypeCode 接口上的 type_modified 方法的一个可能结果。

另请参见：
TypeCode

字段摘要
static short value
表示 typecode 中的抽象接口值类型的值。

字段详细信息

value

static final short value
表示 typecode 中的抽象接口值类型的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VM_NONE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 VM_NONE

public interface VM_NONE

定义代码，用来表示一个 typecode 中值类型的值。

从以下版本开始：
JDK1.2
另请参见：
TypeCode

字段摘要
static short value
根据 CORBA 2.3 规范表示 typecode 中值类型的值。

字段详细信息

value

static final short value
根据 CORBA 2.3 规范表示 typecode 中值类型的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VM_TRUNCATABLE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
接口 VM_TRUNCATABLE

public interface VM_TRUNCATABLE

定义用来表示 typecode 中可截断值类型的代码。如果某一值类型是从另一个值类型“安全”继承的，则该值类型是可截断的，这意味着可以将它强制转换成更一般的继承类型。这是 TypeCode 接口上的 type_modifier 方法可能得到的结果之一。

另请参见：
TypeCode

字段摘要
static short value
表示 typecode 中可截断值类型的值。

字段详细信息

value

static final short value
表示 typecode 中可截断值类型的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCharSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 WCharSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.WCharSeqHelper

public abstract class WCharSeqHelper
extends Object

WCharSeq 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/WCharSeqHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
WCharSeqHelper()
方法摘要
static char[] | extract(Any a)
static String | id()
static void | insert(Any a, char[] that)
static char[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, char[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WCharSeqHelper

public WCharSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          char[] that)

extract

public static char[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static char[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         char[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WCharSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 WCharSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.WCharSeqHolder
所有已实现的接口：
Streamable
public final class WCharSeqHolder
extends Object
implements Streamable

WCharSeq 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/WCharSeqHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 streams.idl 中生成，生成时间为 1999 年 5 月 13 日 22:41:36 (GMT+00:00)

字段摘要
 char[] value
构造方法摘要
WCharSeqHolder()
WCharSeqHolder(char[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public char[] value
构造方法详细信息

WCharSeqHolder

public WCharSeqHolder()

WCharSeqHolder

public WCharSeqHolder(char[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WrongTransaction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 WrongTransaction

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.WrongTransaction
所有已实现的接口：
Serializable, IDLEntity
public final class WrongTransaction
extends UserException

CORBA WrongTransaction 用户定义异常。仅当在与最初发送请求的客户端不同的事务处理域中调用 Request.get_response 和 ORB.get_next_response 方法时抛出此异常。有关详细信息，请参阅 OMG 事务服务 (Transaction Service) 规范。

另请参见：
关于 Java IDL 异常的文档

构造方法摘要
WrongTransaction()
使用空详细消息构造一个 WrongTransaction 对象。
WrongTransaction(String reason)
使用给定详细消息构造一个 WrongTransaction 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

WrongTransaction

public WrongTransaction()
使用空详细消息构造一个 WrongTransaction 对象。

WrongTransaction

public WrongTransaction(String reason)
使用给定详细消息构造一个 WrongTransaction 对象。

参数：
reason - 解释导致此异常抛出原因的详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WrongTransactionHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 WrongTransactionHelper

java.lang.Object
    继承者  org.omg.CORBA.WrongTransactionHelper

public abstract class WrongTransactionHelper
extends Object

WrongTransaction 的 Helper。有关 Helper 文件的更多信息，请参阅“生成的文件：Helper 文件”。

org/omg/CORBA/WrongTransactionHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 CORBA.idl 中生成，生成时间为 PDT 时间 2000 年 8 月 24 日（星期四）下午 5:32:50

构造方法摘要
WrongTransactionHelper()
方法摘要
static WrongTransaction | extract(Any a)
static String | id()
static void | insert(Any a, WrongTransaction that)
static WrongTransaction | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, WrongTransaction value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WrongTransactionHelper

public WrongTransactionHelper()
方法详细信息

insert

public static void insert(Any a,
                          WrongTransaction that)

extract

public static WrongTransaction extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static WrongTransaction read(InputStream istream)

write

public static void write(OutputStream ostream,
                         WrongTransaction value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WrongTransactionHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 WrongTransactionHolder

java.lang.Object
    继承者  org.omg.CORBA.WrongTransactionHolder
所有已实现的接口：
Streamable
public final class WrongTransactionHolder
extends Object
implements Streamable

WrongTransaction 的 Holder。关于 Holder 文件的更多信息，请参阅“生成的文件：Holder 文件”。

org/omg/CORBA/WrongTransactionHolder.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 CORBA.idl 中生成，生成时间为 PDT 时间 2000 年 8 月 24 日（星期四）下午 5:32:50

字段摘要
 WrongTransaction value
构造方法摘要
WrongTransactionHolder()
WrongTransactionHolder(WrongTransaction initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public WrongTransaction value
构造方法详细信息

WrongTransactionHolder

public WrongTransactionHolder()

WrongTransactionHolder

public WrongTransactionHolder(WrongTransaction initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WStringSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 WStringSeqHelper

java.lang.Object
    继承者  org.omg.CORBA.WStringSeqHelper

public abstract class WStringSeqHelper
extends Object

WString 数组

构造方法摘要
WStringSeqHelper()
方法摘要
static String[] | extract(Any a)
static String | id()
static void | insert(Any a, String[] that)
static String[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WStringSeqHelper

public WStringSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          String[] that)

extract

public static String[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WStringSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 WStringSeqHolder

java.lang.Object
    继承者  org.omg.CORBA.WStringSeqHolder
所有已实现的接口：
Streamable
public final class WStringSeqHolder
extends Object
implements Streamable

WString 数组

字段摘要
 String[] value
构造方法摘要
WStringSeqHolder()
WStringSeqHolder(String[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public String[] value
构造方法详细信息

WStringSeqHolder

public WStringSeqHolder()

WStringSeqHolder

public WStringSeqHolder(String[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WStringValueHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA
类 WStringValueHelper

java.lang.Object
    继承者  org.omg.CORBA.WStringValueHelper
所有已实现的接口：
BoxedValueHelper
public class WStringValueHelper
extends Object
implements BoxedValueHelper

org/omg/CORBA/WStringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范：

  • 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07)
  • ptc/00-01-08 中定义的 IDL/Java 语言映射

构造方法摘要
WStringValueHelper()
方法摘要
static String | extract(Any a)
String | get_id()
static String | id()
static void | insert(Any a, String that)
Serializable | read_value(InputStream istream)
static String | read(InputStream istream)
static TypeCode | type()
void | write_value(OutputStream ostream, Serializable value)
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WStringValueHelper

public WStringValueHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

read_value

public Serializable read_value(InputStream istream)
指定者：
接口 BoxedValueHelper 中的 read_value

write

public static void write(OutputStream ostream,
                         String value)

write_value

public void write_value(OutputStream ostream,
                        Serializable value)
指定者：
接口 BoxedValueHelper 中的 write_value

get_id

public String get_id()
指定者：
接口 BoxedValueHelper 中的 get_id
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CORBA (Java Platform SE 6)

 org.omg.CORBA
接口
ARG_IN
ARG_INOUT
ARG_OUT
BAD_POLICY
BAD_POLICY_TYPE
BAD_POLICY_VALUE
CTX_RESTRICT_SCOPE
Current
CurrentOperations
CustomMarshal
DataInputStream
DataOutputStream
DomainManager
DomainManagerOperations
DynAny
DynArray
DynEnum
DynFixed
DynSequence
DynStruct
DynUnion
DynValue
IDLType
IDLTypeOperations
IRObject
IRObjectOperations
Object
OMGVMCID
Policy
PolicyOperations
PRIVATE_MEMBER
PUBLIC_MEMBER
UNSUPPORTED_POLICY
UNSUPPORTED_POLICY_VALUE
VM_ABSTRACT
VM_CUSTOM
VM_NONE
VM_TRUNCATABLE
类
_IDLTypeStub
_PolicyStub
Any
AnyHolder
AnySeqHelper
AnySeqHolder
BooleanHolder
BooleanSeqHelper
BooleanSeqHolder
ByteHolder
CharHolder
CharSeqHelper
CharSeqHolder
CompletionStatus
CompletionStatusHelper
Context
ContextList
CurrentHelper
CurrentHolder
DefinitionKind
DefinitionKindHelper
DoubleHolder
DoubleSeqHelper
DoubleSeqHolder
DynamicImplementation
Environment
ExceptionList
FieldNameHelper
FixedHolder
FloatHolder
FloatSeqHelper
FloatSeqHolder
IdentifierHelper
IDLTypeHelper
IntHolder
LocalObject
LongHolder
LongLongSeqHelper
LongLongSeqHolder
LongSeqHelper
LongSeqHolder
NamedValue
NameValuePair
NameValuePairHelper
NVList
ObjectHelper
ObjectHolder
OctetSeqHelper
OctetSeqHolder
ORB
ParameterMode
ParameterModeHelper
ParameterModeHolder
PolicyErrorCodeHelper
PolicyErrorHelper
PolicyErrorHolder
PolicyHelper
PolicyHolder
PolicyListHelper
PolicyListHolder
PolicyTypeHelper
Principal
PrincipalHolder
RepositoryIdHelper
Request
ServerRequest
ServiceDetail
ServiceDetailHelper
ServiceInformation
ServiceInformationHelper
ServiceInformationHolder
SetOverrideType
SetOverrideTypeHelper
ShortHolder
ShortSeqHelper
ShortSeqHolder
StringHolder
StringSeqHelper
StringSeqHolder
StringValueHelper
StructMember
StructMemberHelper
TCKind
TypeCode
TypeCodeHolder
ULongLongSeqHelper
ULongLongSeqHolder
ULongSeqHelper
ULongSeqHolder
UnionMember
UnionMemberHelper
UnknownUserExceptionHelper
UnknownUserExceptionHolder
UShortSeqHelper
UShortSeqHolder
ValueBaseHelper
ValueBaseHolder
ValueMember
ValueMemberHelper
VersionSpecHelper
VisibilityHelper
WCharSeqHelper
WCharSeqHolder
WrongTransactionHelper
WrongTransactionHolder
WStringSeqHelper
WStringSeqHolder
WStringValueHelper
异常
ACTIVITY_COMPLETED
ACTIVITY_REQUIRED
BAD_CONTEXT
BAD_INV_ORDER
BAD_OPERATION
BAD_PARAM
BAD_QOS
BAD_TYPECODE
Bounds
CODESET_INCOMPATIBLE
COMM_FAILURE
DATA_CONVERSION
FREE_MEM
IMP_LIMIT
INITIALIZE
INTERNAL
INTF_REPOS
INV_FLAG
INV_IDENT
INV_OBJREF
INV_POLICY
INVALID_ACTIVITY
INVALID_TRANSACTION
MARSHAL
NO_IMPLEMENT
NO_MEMORY
NO_PERMISSION
NO_RESOURCES
NO_RESPONSE
OBJ_ADAPTER
OBJECT_NOT_EXIST
PERSIST_STORE
PolicyError
REBIND
SystemException
TIMEOUT
TRANSACTION_MODE
TRANSACTION_REQUIRED
TRANSACTION_ROLLEDBACK
TRANSACTION_UNAVAILABLE
TRANSIENT
UNKNOWN
UnknownUserException
UserException
WrongTransaction


org.omg.CORBA (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CORBA

提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

请参见：
描述

接口摘要
ARG_IN | 向调用符号化 "input" 参数，表示从客户端将该参数传递到服务器。
ARG_INOUT | 表示用于某一调用的输入和输出的参数，意味着将该参数从客户端传到服务器，然后再从服务器传回客户端。
ARG_OUT | 表示调用的 "input" 参数的常量，意味着从服务器将该参数传递到客户端。
BAD_POLICY | 将填充在 PolicyError 异常中的 PolicyErrorCode。
BAD_POLICY_TYPE | 将填充在 PolicyError 异常中的 PolicyErrorCode。
BAD_POLICY_VALUE | 包含指示某个策略值的值，该策略值对于 create_policy 方法（在 ORB 类中定义）调用中的有效策略类型而言是不正确的。
CTX_RESTRICT_SCOPE | 可以用作 Context.get_values 方法的第二个参数以限制搜索范围的标志。
Current | 从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
CurrentOperations | Current 的接口。
CustomMarshal | 将由 ORB 而不是由用户使用的抽象 value 类型。
DataInputStream | 定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
DataOutputStream | 定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。
DomainManager | 提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
DomainManagerOperations | 向 DomainManager 提供访问策略的方法。
DynAny | 已过时。 使用新的 DynAny 替代
DynArray | 已过时。 使用新的 DynArray 替代
DynEnum | 已过时。 使用新的 DynEnum 替代
DynFixed | 已过时。 使用新的 DynFixed 替代
DynSequence | 已过时。 使用新的 DynSequence 替代
DynStruct | 已过时。 使用新的 DynStruct 替代
DynUnion | 已过时。 使用新的 DynUnion 替代
DynValue | 已过时。 使用新的 DynValue 替代
IDLType | 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
IDLTypeOperations | 此接口必须由所有 IDLType 对象实现。
IRObject | IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
IRObjectOperations | 这是用于 IRObject 的映射的 Operations 接口。
Object | CORBA 对象引用的定义。
OMGVMCID | 为 OMG 保留的供应商次要代码 (minor code) ID。
Policy | 派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。
PolicyOperations | 提供针对某一 Policy 对象的操作。
PRIVATE_MEMBER | 定义 ValueMember 类中私有成员的常量。
PUBLIC_MEMBER | 定义 ValueMember 类中公共成员的常量。
UNSUPPORTED_POLICY | 在所请求的 Policy 被 ORB 认为是有效的，但目前不受支持时将被填充的一个 PolicyErrorCode。
UNSUPPORTED_POLICY_VALUE | 当所请求的 Policy 值是有效类型并且在该类型的有效范围内，但该有效值目前不受支持时将被填充的 PolicyErrorCode。
VM_ABSTRACT | 定义用来表示 typecode 中的 Abstract 接口的代码。
VM_CUSTOM | 定义用来表示类型代码中自定义编组值类型的代码。
VM_NONE | 定义代码，用来表示一个 typecode 中值类型的值。
VM_TRUNCATABLE | 定义用来表示 typecode 中可截断值类型的代码。

类摘要
_IDLTypeStub | IDLType 的 Stub。
_PolicyStub | Policy 的 Stub。
Any | 充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
AnyHolder | Any 的 Holder。
AnySeqHelper | AnySeq 的 Helper。
AnySeqHolder | AnySeq 的 Holder。
BooleanHolder | Boolean 的 Holder。
BooleanSeqHelper | BooleanSeq 的 Helper。
BooleanSeqHolder | BooleanSeq 的 Holder。
ByteHolder | Byte 的 Holder。
CharHolder | Char 的 Holder。
CharSeqHelper | CharSeq 的 Helper。
CharSeqHolder | CharSeq 的 Holder。
CompletionStatus | 指示某一方法抛出 SystemException 时是否已结束运行的对象。
CompletionStatusHelper | CompletionStatus 的 Helper。
Context | 用于在 Request 操作中指定上下文对象的对象，上下文字符串在与请求调用一起被发送之前，必须在该指定的上下文对象中进行解析。
ContextList | 一个对象，它包含表示属性名称的 String 对象所组成的可修改列表。
CurrentHelper | Current 的 Helper。
CurrentHolder | Current 的 Holder。
DefinitionKind | 该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。
DefinitionKindHelper | DefinitionKind 的 Helper。
DoubleHolder | Double 的 Holder。
DoubleSeqHelper | DoubleSeq 的 Helper。
DoubleSeqHolder | DoubleSeq 的 Holder。
DynamicImplementation | 已过时。 org.omg.CORBA.DynamicImplementation
Environment | 用于 Request 操作的异常的容器 (holder)，使异常可用于客户端。
ExceptionList | Request 操作中使用的对象，用于描述可由某一方法抛出的异常。
FieldNameHelper | FieldName 的 Helper。
FixedHolder | Fixed 的 Holder。
FloatHolder | Float 的 Holder。
FloatSeqHelper | FloatSeq 的 Helper。
FloatSeqHolder | FloatSeq 的 Holder。
IdentifierHelper | Identifier 的 Helper。
IDLTypeHelper | IDLType 的 Helper。
IntHolder | Int 的 Holder。
LocalObject | 用作 Java 语言映射中的本地 IDL 接口实现的基本类。
LongHolder | Long 值的 Holder。
LongLongSeqHelper | LongLongSeq 的 Helper。
LongLongSeqHolder | LongLongSeq 的 Holder。
LongSeqHelper | LongSeqHelper 的 Helper。
LongSeqHolder | LongSeq 的 Holder。
NamedValue | 在 DII 和 DSI 中用来描述参数和返回值的对象。
NameValuePair | 将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。
NameValuePairHelper | NameValuePair 的 Helper。
NVList | 包含 NamedValue 对象所组成的可修改列表。
ObjectHelper |
ObjectHolder | Object 的 Holder。
OctetSeqHelper | OctetSeq 的 Helper。
OctetSeqHolder | OctetSeq 的 Holder。
ORB | 为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。
ParameterMode | Parameter 参数模式的枚举。
ParameterModeHelper | Parameter 参数模式的枚举。
ParameterModeHolder | Parameter 参数模式的枚举。
PolicyErrorCodeHelper | 封装 Policy 无效的原因。
PolicyErrorHelper | 抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。
PolicyErrorHolder | 抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。
PolicyHelper | Policy 的 Helper。
PolicyHolder | Policy 的 Holder。
PolicyListHelper | PolicyList 的 Helper。
PolicyListHolder | PolicyList 的 Holder。
PolicyTypeHelper | PolicyType 的 Helper。
Principal | 已过时。 已由 CORBA 2.2 取代。
PrincipalHolder | 已过时。 Deprecated by CORBA 2.2.
RepositoryIdHelper | RepositoryId 的 Helper。
Request | 包含调用某一方法所必需的信息的对象。
ServerRequest | 捕获对动态框架接口（Dynamic Skeleton Interface，DSI）请求的显式状态的对象。
ServiceDetail | 表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。
ServiceDetailHelper |
ServiceInformation | CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。
ServiceInformationHelper |
ServiceInformationHolder | ServiceInformation 的 Holder。
SetOverrideType | 标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
SetOverrideTypeHelper | SetOverrideType 的 Helper。
ShortHolder | Short 的 Holder。
ShortSeqHelper | ShortSeqHelper 的 Helper。
ShortSeqHolder | ShortSeq 的 Holder。
StringHolder | String 的 Holder。
StringSeqHelper | String 数组
StringSeqHolder | String 数组
StringValueHelper | StringValue 的 Helper。
StructMember | 描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。
StructMemberHelper | StructMember 的 Helper。
TCKind | IDL enum TCKind 的 Java 映射，TCKind 指定 TypeCode 对象的种类。
TypeCode | 用于有关特定 CORBA 数据类型的信息的容器。
TypeCodeHolder | TypeCode 的 Holder。
ULongLongSeqHelper | ULongLongSeq 的 Helper。
ULongLongSeqHolder | ULongLongSeq 的 Holder。
ULongSeqHelper | ULongSeq 的 Helper。
ULongSeqHolder | ULongSeq 的 Holder。
UnionMember | 接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。
UnionMemberHelper | UnionMember 的 Helper。
UnknownUserExceptionHelper | UnknownUserException 的 Helper。
UnknownUserExceptionHolder | UnknownUserException 的 Holder。
UShortSeqHelper | UShortSeq 的 Helper。
UShortSeqHolder | UShortSeq 的 Holder。
ValueBaseHelper |
ValueBaseHolder | ValueBase 的 Holder。
ValueMember | 接口存储库 (Interface Repository) 中关于 value 对象成员的描述。
ValueMemberHelper | ValueMember 的 Helper。
VersionSpecHelper | VersionSpec 的 Helper。
VisibilityHelper | Visibility 的 Helper。
WCharSeqHelper | WCharSeq 的 Helper。
WCharSeqHolder | WCharSeq 的 Holder。
WrongTransactionHelper | WrongTransaction 的 Helper。
WrongTransactionHolder | WrongTransaction 的 Holder。
WStringSeqHelper | WString 数组
WStringSeqHolder | WString 数组
WStringValueHelper | org/omg/CORBA/WStringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范： 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07) ptc/00-01-08 中定义的 IDL/Java 语言映射

异常摘要
ACTIVITY_COMPLETED | ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
ACTIVITY_REQUIRED | ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
BAD_CONTEXT | 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
BAD_INV_ORDER | 此异常指示调用者按错误顺序调用了操作。
BAD_OPERATION | 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
BAD_PARAM | 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
BAD_QOS | 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
BAD_TYPECODE | 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
Bounds | 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
CODESET_INCOMPATIBLE | 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
COMM_FAILURE | 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
DATA_CONVERSION | 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
FREE_MEM | 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
IMP_LIMIT | 此异常指示在 OBR 运行时超过了某一项实现限制。
INITIALIZE | ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
INTERNAL | 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
INTF_REPOS | 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
INV_FLAG | 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
INV_IDENT | 此异常指示 IDL 标识符在语法上是无效的。
INV_OBJREF | 此异常指示对象引用存在内部错误。
INV_POLICY | 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
INVALID_ACTIVITY | 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
INVALID_TRANSACTION | 当请求带有无效的事务上下文时，抛出此异常。
MARSHAL | 表示网络中传来的请求或应答在结构上无效。
NO_IMPLEMENT | 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
NO_MEMORY | 如果 ORB 运行时出现内存不足，则抛出此异常。
NO_PERMISSION | 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
NO_RESOURCES | 当 ORB 遇到一些一般资源限制时，抛出此异常。
NO_RESPONSE | 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
OBJ_ADAPTER | 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
OBJECT_NOT_EXIST | 只要在已删除的对象上执行调用，就会引发此异常。
PERSIST_STORE | 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
PolicyError | 发生策略错误时抛出的用户异常。
REBIND | 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
SystemException | 所有 CORBA 标准异常的根类。
TIMEOUT | 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
TRANSACTION_MODE | 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
TRANSACTION_REQUIRED | 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
TRANSACTION_ROLLEDBACK | 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
TRANSACTION_UNAVAILABLE | 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
TRANSIENT | 当 ORB 试图到达某一对象但失败时，抛出此异常。
UNKNOWN | 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
UnknownUserException | 包含由服务器返回的用户异常的类。
UserException | CORBA IDL 定义的用户异常的根类。
WrongTransaction | CORBA WrongTransaction 用户定义异常。

软件包 org.omg.CORBA 的描述

提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

有关 Java[TM] Platform，Standard Edition 6 遵守的受支持官方 CORBA 规范部分的明确列表，请参阅 Official Specifications for CORBA support in Java[TM] SE 6。

常规信息

这一节中的信息与编译接口定义语言（Interface Definition Language，IDL）文件以及使用 ORB 编写客户端和服务器的用户有关。

这一节中描述的类和接口可分为四组：ORB 类、异常、Helper 类和 Holder 类。

ORB 类

ORB 处理（或代理）客户端与服务器上的方法实现之间的方法调用。因为客户端和服务器可能位于网络的任何地方，调用和实现可能以不同的编程语言编写，所以 ORB 在后台做了很多工作来实现此通信。

ORB 所做的大部分工作对于用户而言是完全透明的，CORBA 包的主要部分由 ORB 在后台使用的类组成。因此大部分程序员将只直接使用此包的一小部分。实际上，大多数程序员仅使用 ORB 类和一些异常中的少数方法，偶尔也使用 holder 类中的少数方法。

ORB 方法

在应用程序进入 CORBA 环境之前，它必须先执行以下操作：

  • 被初始化为 ORB 环境，也可能是对象适配器 (POA) 环境。
  • 获取对 ORB 对象的引用（在以后的 ORB 操作中使用），也可能获取对其他对象（包括根 POA 或一些 Object Adapter 对象）的引用。

提供以下操作来初始化应用程序及获得适当的对象引用：

  • 这一节中将讨论的可访问 ORB 的操作。
  • 可访问 Object Adapter、Interface Repository、Naming Service 和其他 Object Service 的操作。这些操作将在其他类 中描述。

当应用程序需要 CORBA 环境时，它需要一个机制来获取 ORB 对象引用，也可能是 OA 对象引用（比如根 POA）。此机制有两个用途。第一个用途是将应用程序初始化为 ORB 和 OA 环境。第二个用途是将 ORB 对象引用和 OA 对象引用返回给应用程序，以便在以后的 ORB 和 OA 操作中使用。

若要获取 ORB 对象引用，应用程序应调用 ORB.init 操作。该调用的参数可能由 ORB 的标识符和 arg_list 组成，前者是对象引用所需要的，后者用于允许将特定于环境的数据传递给调用。

以下 ORB 方法可以访问 ORB：

  • init()
  • init(String [] args, Properties props)
  • init(Applet app, Properties props)

使用不带参数的 init() 方法可以实例化一个单件 ORB，它只能为创建 typecode 提供 any，在通过 idlj 在 Helper 类中生成的代码中需要这些 any。

应用程序需要一个用来获得其初始对象引用的可移植方法。根 POA、POA Current、Interface Repository 和各种 Object Service 实例都需要引用。应用程序所需的功能类似于 Naming Service 提供的那些功能。但是，OMG 不应该要求 Naming Service 可用于所有应用程序以便能够以可移植方式初始化。因此，这一节中展示的操作提供了一个简化的本地 Naming Service，应用程序可以使用它来获取其操作所必须的一小组已定义对象引用。因为只期望从此机制中获得一小组定义良好的对象，所以命名上下文可能被简化为单一级别的名称空间。这种简化的结果是只定义两个操作来获得所需的功能。

初始引用是通过 ORB 对象接口中提供的两个操作获得的，该接口中提供了一些设施来列出并解析初始对象引用。这些工具包括：

  • resolve_initial_references(String name)
  • list_initial_services()
  • register_initial_reference(String id, org.omg.CORBA.Object obj)

使用其中一些方法的示例见 Java IDL 入门。

异常

Java IDL 中的异常类似于用 Java 编程语言编写的 any 代码中的那些异常。如果定义某一方法抛出异常，则使用该方法的 any 代码必须有一个 try/catch 块，并在该异常抛出时进行处理。

关于 Java IDL 异常 的文档中有更多信息，这些文档解释了系统异常和用户定义异常之间的不同。

以下是包 org.omg.CORBA 中定义的系统异常的列表（这些异常是通过 org.omg.CORBA.SystemException 从 java.lang.RuntimeException 中继承的未经检查异常）：

        BAD_CONTEXT
        BAD_INV_ORDER
        BAD_OPERATION
        BAD_PARAM
        BAD_TYPECODE
        COMM_FAILURE
        DATA_CONVERSION
        FREE_MEM
        IMP_LIMIT
        INITIALIZE
        INTERNAL
        INTF_REPOS
        INVALID_TRANSACTION
        INV_FLAG
        INV_IDENT
        INV_OBJREF
        INV_POLICY
        MARSHAL
        NO_IMPLEMENT
        NO_MEMORY
        NO_PERMISSION
        NO_RESOURCES
        NO_RESPONSE
        OBJECT_NOT_EXIST
        OBJ_ADAPTER
        PERSIST_STORE
        TRANSACTION_REQUIRED
        TRANSACTION_ROLLEDBACK
        TRANSIENT
        UNKNOWN

以下是包 org.omg.CORBA 中定义的用户定义异常的列表。

        Bounds
        UnknownUserException
        WrongTransaction
        PolicyError

子包

CORBA 包中的一些包用 "Package" 作为其名称的一部分。这些包通常非常小，因为这些包要做的所有事情就是提供异常或类，以便 CORBA 包中的接口和类使用。

例如，包 org.omg.CORBA.TypeCodePackage 包含两个由 TypeCode 类中的方法抛出的异常。这些异常包括：

  • BadKind
  • Bounds
包 org.omg.CORBA.ORBPackage 中包含以下两个异常：
  • InvalidName
  • InconsistentTypeCode

另一个 CORBA 的子包是 portable 包。该包提供了一组 ORB API，这些 API 使得某个供应商的 IDL 编译器所生成的代码能够在另一个供应商的 ORB 上运行。

Holder 类

支持 out 和 inout 参数传递模式需要使用附加 holder 类。因为 Java 编程语言不支持 out 或 inout 参数，holder 类便作为一种可修改的传递参数方式出现。为了支持可移植 stub 和 skeleton，holder 类还实现了 org.omg.CORBA.portable.Streamable 接口。

Holder 类是通过将 "Holder" 追加到类型名称中来命名的。类型名称是指它在 Java 编程语言中的名称。例如，在 Java 编程语言中名为 Account 的接口所对应的 holder 类应该命名为 AccountHolder。

Holder 类可用于 org.omg.CORBA 包中的所有基本 IDL 数据类型。因此，对于 LongHolder、ShortHolder、FloatHolder 等，都已经定义了相应的类。对于所有已命名用户定义的 IDL 类型（typedef 定义的除外），同样会生成一些类。（注意，在这种情况下，用户定义类型包括那些在 OMG 规范中定义的类型（如用于 Interface Repository 的那些类型）和其他 OMG 服务。）

每个 holder 类都包含：

  • 实例中的构造方法
  • 默认构造方法
  • 公共实例成员，类型化值的 value
  • 用来读取输入流并将内容分配给类型的 value 字段的方法
  • 用来将 value 字段的值写入输出流的方法
  • 用来获取类型的 typecode 的方法

对于 Java 语言定义的类型，默认构造方法将 value 字段设置为以下默认值：

  • false，用于 boolean 值
  • 0，用于 numeric 和 char 类型
  • null，用于字符串和对象引用

举例来说，如果用 OMG IDL 定义的 Account 接口被映射到 Java 编程语言，则将生成以下 holder 类：

public final class AccountHolder implements
    org.omg.CORBA.portable.Streamable
{
  // field that holds an Account object
  public Account value = null;

  // default constructor
  public AccountHolder ()
  {
  }

  // creates a new AccountHolder from initialValue
  public AccountHolder (Account initialValue)
  {
    value = initialValue;
  }

  // reads the contents of i and assigns the contents to value
  public void _read (org.omg.CORBA.portable.InputStream i)
  {
    value = AccountHelper.read (i);
  }

  // writes value to o
  public void _write (org.omg.CORBA.portable.OutputStream o)
  {
    AccountHelper.write (o, value);
  }

  // returns the typecode for Account
  public org.omg.CORBA.TypeCode _type ()
  {
    return AccountHelper.type ();
  }

}

关于 Holder 类的更多信息，请参阅 OMG IDL to Java Language Mapping 中的第 1.4 章 Mapping for Basic Types。org.omg.CORBA 包中定义的 Holder 类有：

     AnyHolder
     AnySeqHolder
     BooleanHolder
     BooleanSeqHolder
     ByteHolder
     CharHolder
     CharSeqHolder
     CurrentHolder
     DoubleHolder
     DoubleSeqHolder
     FixedHolder
     FloatHolder
     FloatSeqHolder
     IntHolder
     LongHolder
     LongLongSeqHolder
     LongSeqHolder
     ObjectHolder
     OctetSeqHolder
     ParameterModeHolder
     PolicyErrorHolder
     PolicyListHolder
     PrincipalHolder
     ServiceInformationHolder
     ShortHolder
     ShortSeqHolder
     StringHolder
     StringSeqHolder
     TypeCodeHolder
     ULongLongSeqHolder
     ULongSeqHolder
     UnknownUserExceptionHolder
     UShortSeqHolder
     ValueBaseHolder
     WCharSeqHolder
     WrongTransactionHolder
     WStringSeqHolder

Helper 类

Helper 文件提供了一些操作类型所需的静态方法。这些操作包括：

  • 对类型进行的 Any 插入和析取操作
  • 获取存储库 id
  • 获取 typecode
  • 在流中读取和写入类型
  • 实现 ValueHelper 接口（如果它是用户定义的 value 类型）

用于映射的 IDL 接口或抽象接口的 helper 类还包括收缩操作。静态收缩方法允许将 org.omg.CORBA.Object 收缩成更具体的某种类型的对象引用。如果因为该对象引用不支持所请求的类型而导致收缩失败，则将抛出 IDL 异常 CORBA.BAD_PARAM。引发不同的系统异常则指示存在其他种类的错误。尝试收缩 null 将总是可以成功，并返回 null 值。通常，应用程序编程人员唯一使用的 helper 方法是 narrow 方法。其他方法通常在后台使用，它们对于程序员是透明的。

Helper 类分为两大类，即用于 value 类型的 helper 和用于非 value 类型的 helper。因为一种类别中的所有 helper 类提供的都是相同的方法，所以这里只提供每种 helper 类的一般性解释。

在将 OMG IDL 映射到 Java 编程语言时，为每个用户定义的类型生成一个 "helper" 类。生成的这个类将具有用户定义类型的名称以及追加的 Helper 后缀。例如，如果接口 Account 是用 OMG IDL 定义的，则 idlj 编译器将自动生成一个名为 AccountHelper 的类。AccountHelper 类将包含操作类型实例所需的静态方法，这里的实例指 Account 对象。

narrow 方法

当某一对象是某个方法的返回值时，该对象是以常规对象的形式返回的，它可以是 org.omg.CORBA.Object 对象或者 java.lang.Object 对象。在可以对此对象执行操作之前，必须将该对象强制转换为其更具体的类型。例如，Account 对象将作为一般对象返回，并且必须收缩为 Account 对象，以便可以对该对象调用 Account 方法。

narrow 方法有两种形式，一种形式带有一个 org.omg.CORBA.Object 对象，另一种形式带有一个 java.lang.Object 对象。根据该接口是否是抽象的来确定其 helper 类将提供哪一种 narrow 方法。用于非抽象接口的 helper 类将有一个带 CORBA 对象的 narrow 方法，而用于抽象接口的 narrow 方法将带有 Java 编程语言中的一个对象。对于至少有一个抽象基本接口的非抽象接口，helper 类将同时提供两种形式的 narrow 方法。

Hello World 教程使用的 narrow 方法如下所示：

        // create and initialize the ORB
        ORB orb = ORB.init(args, null);

        // get the root naming context
        org.omg.CORBA.Object objRef =
            orb.resolve_initial_references("NameService");
        // Use NamingContextExt instead of NamingContext.This is
        // part of latest Inter-Operable naming Service.
        NamingContextExt ncRef = NamingContextExtHelper.narrow(objRef);

        // resolve the Object Reference in Naming
String name = "Hello";
        helloImpl = HelloHelper.narrow(ncRef.resolve_str(name));

基本 Helper 类的示例

对于本例，基本 helper 类具有每个 helper 类都会提供的方法，如果用 OMG IDL 定义的类型映射到 Java 编程语言中的接口，则它还包含一个 narrow 方法。非 value 类型的类型将有一个为它们生成的基本 helper 类。

例如，假设接口 Account 不是一个 value 类型的 IDL 类型也不是一个抽象接口，并且没有抽象基本接口，则其 AccountHelper 类将如下所示：

abstract public class AccountHelper
{
  private static String  _id = "IDL:Account:1.0";

  // inserts an Account object into an Any object
  public static void insert (org.omg.CORBA.Any a, Account that)
  {
    org.omg.CORBA.portable.OutputStream out = a.create_output_stream ();
a.type (type ());
    write (out, that);
    a.read_value (out.create_input_stream (), type ());
  }

  // extracts an Account object from an Any object
  public static Account extract (org.omg.CORBA.Any a)
  {
    return read (a.create_input_stream ());
  }

  private static org.omg.CORBA.TypeCode __typeCode = null;
  // gets the typecode for this type
  synchronized public static org.omg.CORBA.TypeCode type ()
  {
    if (__typeCode == null)
    {
      __typeCode = org.omg.CORBA.ORB.init ().create_interface_tc (AccountHelper.id (), "Account");
    }
    return __typeCode;
  }

  // gets the repository id for this type
  public static String id ()
  {
    return _id;
  }

  // reads an Account object from an input stream
  public static Account read (org.omg.CORBA.portable.InputStream istream)
  {
    return narrow (istream.read_Object (_AccountStub.class));
  }

  // writes an Account object to an outputstream
  public static void write (org.omg.CORBA.portable.OutputStream ostream, Account value)
  {
    ostream.write_Object ((org.omg.CORBA.Object) value);
  }

  // converts (narrows) an Object to an Account object
  public static Account narrow (org.omg.CORBA.Object obj)
  {
    if (obj == null)
return null;
    else if (obj instanceof Account)
      return (Account)obj;
    else if (!obj._is_a (id ()))
      throw new org.omg.CORBA.BAD_PARAM ();
    else
    {
      org.omg.CORBA.portable.Delegate delegate = ((org.omg.CORBA.portable.ObjectImpl)obj)._get_delegate ();
      _AccountStub stub = new _AccountStub ();
      stub._set_delegate(delegate);
      return stub;
    }
  }

}

value 类型 Helper 类

用于 value 类型的 helper 类所包含的方法是为非 value 类型方法生成的方法的不同呈现。主要的不同在于 value 类型可以作为某一方法的参数值或返回值传递，这意味着它们必须是可序列化的。

假设 Address 是 value 类型，则 AddressHelper 类将如下所示：

abstract public class AddressHelper
{
  private static String  _id = "IDL:Address:1.0";

  // same as for non-value type
  public static void insert (org.omg.CORBA.Any a, Address that)
  {
    org.omg.CORBA.portable.OutputStream out = a.create_output_stream ();
a.type (type ());
    write (out, that);
    a.read_value (out.create_input_stream (), type ());
  }

  // same as for non-value type
  public static Address extract (org.omg.CORBA.Any a)
  {
    return read (a.create_input_stream ());
  }

  private static org.omg.CORBA.TypeCode __typeCode = null;
  private static boolean __active = false;

  // getting the typecode for the type
  synchronized public static org.omg.CORBA.TypeCode type ()
  {
    if (__typeCode == null)
    {
      synchronized (org.omg.CORBA.TypeCode.class)
      {
        if (__typeCode == null)
        {
          if (__active)
          {
            return org.omg.CORBA.ORB.init().create_recursive_tc ( _id );
          }
__active = true;
          org.omg.CORBA.ValueMember[] _members0 = new org.omg.CORBA.ValueMember[0];
          org.omg.CORBA.TypeCode _tcOf_members0 = null;
          __typeCode = org.omg.CORBA.ORB.init ().create_value_tc (_id, "Address", org.omg.CORBA.VM_NONE.value, null, _members0);
__active = false;
        }
      }
    }
    return __typeCode;
  }

  // same as for non-value type
  public static String id ()
  {
    return _id;
  }

  // reads a serializable instance of Address from the given input stream
  public static Address read (org.omg.CORBA.portable.InputStream istream)
  {
    return (Address)((org.omg.CORBA_2_3.portable.InputStream) istream).read_value (id ());
  }

  // writes a serializable instance of Address to the given output stream
  public static void write (org.omg.CORBA.portable.OutputStream ostream, Address value)
  {
    ((org.omg.CORBA_2_3.portable.OutputStream) ostream).write_value (value, id ());
  }

}

org.omg.CORBA 包中定义的 Helper 类有：

     AnySeqHelper
     BooleanSeqHelper
     CharSeqHelper
     CompletionStatusHelper
     CurrentHelper
     DefinitionKindHelper
     DoubleSeqHelper
     FieldNameHelper
     FloatSeqHelper
     IdentifierHelper
     IDLTypeHelper
     LongLongSeqHelper
     LongSeqHelper
     NameValuePairHelper
     ObjectHelper
     OctetSeqHelper
     ParameterModeHelper
     PolicyErrorCodeHelper
     PolicyErrorHelper
     PolicyHelper
     PolicyListHelper
     PolicyTypeHelper
     RepositoryIdHelper
     ServiceDetailHelper
     ServiceInformationHelper
     SetOverrideTypeHelper
     ShortSeqHelper
     StringSeqHelper
     StringValueHelper
     StructMemberHelper
     ULongLongSeqHelper
     ULongSeqHelper
     UnionMemberHelper
     UnknownUserExceptionHelper
     UShortSeqHelper
     ValueBaseHelper
     ValueMemberHelper
     VersionSpecHelper
     VisibilityHelper
     WCharSeqHelper
     WrongTransactionHelper
     WStringSeqHelper
     WStringValueHelper

其他类

CORBA 包中的其他类和接口都是在后台使用的，它们可分为四组。其中三组都以某种方式用于请求，第四组与 Interface Repository 有关，单独列为一类。

ORB 创建的类

第一组中包含由 ORB 创建的类和请求操作中使用的信息。
  • TCKind -- 指示 TypeCode 对象的种类（数据类型）
  • TypeCode -- 指示数据类型，可能包括其他信息
  • Any -- 包含一个值及其 typecode
  • NamedValue -- 包含一个名称、一个 Any 对象和一个参数模式标志。NamedValue 对象包含关于方法参数、方法返回值或一个上下文的信息。
  • ContextList -- 一个字符串列表，这些字符串描述需要被解析并随调用发送的上下文
  • ExceptionList -- 一个 TypeCode 列表，这些 TypeCode 用于可能由某一方法抛出的异常
  • Environment -- 方法调用期间抛出的异常的容器
  • Context -- 一个 NamedValue 对象列表，这些对象用来将辅助信息从客户端传递到服务器
  • NVList -- 一个 NamedValue 对象列表，这些对象用于传递参数或获取结果

处理请求的类

第二组类用于处理请求：
  • Object -- 所有 CORBA 对象引用的基类
  • Request -- DII 中的主要类，它包含各种方法，有些用来给请求添加参数，有些用来访问有关被调用方法的信息（方法的名称、参数、抛出的异常等等），还有些用来对请求执行调用
  • DynamicImplementation -- 用于使用 DSI 的服务器实现的基类。它包含方法 invoke，此类的一个实现可使用该方法确定 ServerRequest 对象的状态并设置其结果或异常
  • ServerRequest -- 捕获针对动态框架接口 (Dynamic Skeleton Interface) 的请求的显式状态

用作常量的接口

第三组中包括用作常量的接口。IDL 到 Java 的映射强行将 IDL 枚举映射到 Java 类，并将枚举值表示为该类中的公共静态最终字段（如 DefinitionKind）。另一方面，IDL 接口外部定义的 IDL 常量被映射到 Java 接口（每个常量一个接口）。

这就是为什么 org.omg.CORBA 包中的几个接口包含一个 value 字段的原因，该字段是一个 short 值。此字段是一个用于错误代码或值修饰符之类的常量。例如，BAD_POLICY 接口的 value 字段可能是抛出 PolicyError 异常的原因之一。要指定此错误代码，应使用 BAD_POLICY.value。

PolicyError 异常使用以下接口的 value 字段作为其可能的错误代码。

  • BAD_POLICY
  • BAD_POLICY_TYPE
  • BAD_POLICY_VALUE
  • UNSUPPORTED_POLICY
  • UNSUPPORTED_POLICY_VALUE
TypeCode.type_modifier 方法返回以下某一接口的 value 字段。这些接口名称中的 VM 表示“值修饰符”。
  • VM_NONE
  • VM_ABSTRACT
  • VM_CUSTOM
  • VM_TRUNCATABLE
以下常量由 ValueMember 对象的访问方法返回，用于指示 ValueMember 对象的可见性。
  • PRIVATE_MEMBER
  • PUBLIC_MEMBER
以下接口中定义了 NamedValue 对象中使用的标志或用作方法参数的标志：
  • ARG_IN
  • ARG_INOUT
  • ARG_OUT
  • CTX_RESTRICT_SCOPE

Interface Repository 接口和类

第四组中包含 Interface Repository 接口和类，它们由 idlj 编译器从 OMG IDL 接口 ir.idl 中生成。Interface Repository 的用途是标识存储在其中的接口，以便 ORB 可以访问它们。每个模块、类型、接口、属性、操作、参数、异常、常量等都完全由 Interface Repository API 描述。

ORB 不需要接口存储库，Java IDL 也不包含接口存储库。尽管此版本不包括接口存储库的实现，但它包含以下 IR 类和接口，以创建 typecodes（参见 org.omg.CORBA.ORB 接口中的 create_value_tc、create_struct_tc、create_union_tc 和 create_exception_tc 方法）：
&nbs

  • IRObject
  • IDLType
  • DefinitionKind
  • StructMember
  • UnionMember
  • ValueMember

相关文档

有关概述、指南和教程，请参阅：
  • Java IDL 主页

Java IDL 中没有实现的 CORBA 特性

org.omg 子包中包含的一些 API 是为了与当前 OMG CORBA 规范保持一致而提供的，但 Sun 的 JDKTM 版本中没有实现它们。这使得其他 JDK 被许可人可以在标准扩展和产品中提供此 API 的实现。

抛出 NO_IMPLEMENT 的特性

org.omg 子包中包含的一些 API 会因为各种原因抛出 NO_IMPLEMENT 异常。其中一些原因是：

  • 在某些情况下，完成实现根据规范指示这些 API 应抛出 NO_IMPLEMENT，例如 LocalObject。

  • 在多数情况下，抛出 NO_IMPLEMENT 的方法实际上是在 ORB 代码中其他某个地方的子类中实现的，例如 ORB.java 中的方法。

  • 在某些情况下，API 确实尚未实现，例如 _get_interface_def() 和 _get_interface。

此版本中未实现的特性和 API 的总结：

  • Interface Repository。Java IDL 的常规操作不需要 Interface Repository。
  • Java IDL 不支持 long double。
  • 策略 (org.omg.CORBA.Policy) 及获取这些策略的方法未实现。
  • 域管理器 (org.omg.CORBA.DomainManager) 及获取这些域管理器的方法未实现。
  • 服务信息 org.omg.CORBA.ServiceInformation 和 ORB 方法 public boolean get_service_information(short service_type, ServiceInformationHolder service_info) 未实现。
  • 支持单线程的 ORB 方法（perform_work 和 work_pending）未实现。
  • IDL 上下文。

org.omg.CORBA 包中未实现特性的详细列表

org.omg.CORBA 包中未实现的方法：

  • ORB
    • public org.omg.CORBA.Policy create_policy(int type, org.omg.CORBA.Any val)
    • public void perform_work()
    • public boolean work_pending()
    • public org.omg.CORBA.Current get_current()
    • create_operation_list
    • get_default_context
    • get_service_information
    • 废弃 DynAny（推荐使用 DynamicAny 包替代）

从以下版本开始：
JDK1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.CORBA 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.CORBA.Any (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.AnyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.AnySeqHelper
    • org.omg.CORBA.AnySeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanSeqHelper
    • org.omg.CORBA.BooleanSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ByteHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharSeqHelper
    • org.omg.CORBA.CharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CompletionStatus (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.CompletionStatusHelper
    • org.omg.CORBA.Context
    • org.omg.CORBA.ContextList
    • org.omg.CORBA.CurrentHelper
    • org.omg.CORBA.CurrentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DefinitionKind (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DefinitionKindHelper
    • org.omg.CORBA.DoubleHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DoubleSeqHelper
    • org.omg.CORBA.DoubleSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.Environment
    • org.omg.CORBA.ExceptionList
    • org.omg.CORBA.FieldNameHelper
    • org.omg.CORBA.FixedHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatSeqHelper
    • org.omg.CORBA.FloatSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.IdentifierHelper
    • org.omg.CORBA.IDLTypeHelper
    • org.omg.CORBA.IntHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LocalObject (implements org.omg.CORBA.Object)
    • org.omg.CORBA.LongHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongLongSeqHelper
    • org.omg.CORBA.LongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongSeqHelper
    • org.omg.CORBA.LongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.NamedValue
    • org.omg.CORBA.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.NameValuePairHelper
    • org.omg.CORBA.NVList
    • org.omg.CORBA.ObjectHelper
    • org.omg.CORBA.ObjectHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA._IDLTypeStub (implements org.omg.CORBA.IDLType)
      • org.omg.CORBA._PolicyStub (implements org.omg.CORBA.Policy)
      • org.omg.CORBA.DynamicImplementation
    • org.omg.CORBA.OctetSeqHelper
    • org.omg.CORBA.OctetSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ORB
    • org.omg.CORBA.ParameterMode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ParameterModeHelper
    • org.omg.CORBA.ParameterModeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyErrorCodeHelper
    • org.omg.CORBA.PolicyErrorHelper
    • org.omg.CORBA.PolicyErrorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyHelper
    • org.omg.CORBA.PolicyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyListHelper
    • org.omg.CORBA.PolicyListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyTypeHelper
    • org.omg.CORBA.Principal
    • org.omg.CORBA.PrincipalHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.RepositoryIdHelper
    • org.omg.CORBA.Request
    • org.omg.CORBA.ServerRequest
    • org.omg.CORBA.ServiceDetail (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceDetailHelper
    • org.omg.CORBA.ServiceInformation (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceInformationHelper
    • org.omg.CORBA.ServiceInformationHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.SetOverrideType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.SetOverrideTypeHelper
    • org.omg.CORBA.ShortHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ShortSeqHelper
    • org.omg.CORBA.ShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringSeqHelper
    • org.omg.CORBA.StringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.StringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • org.omg.CORBA.StructMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.StructMemberHelper
    • org.omg.CORBA.TCKind
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_COMPLETED
            • org.omg.CORBA.ACTIVITY_REQUIRED
            • org.omg.CORBA.BAD_CONTEXT
            • org.omg.CORBA.BAD_INV_ORDER
            • org.omg.CORBA.BAD_OPERATION
            • org.omg.CORBA.BAD_PARAM
            • org.omg.CORBA.BAD_QOS
            • org.omg.CORBA.BAD_TYPECODE
            • org.omg.CORBA.CODESET_INCOMPATIBLE
            • org.omg.CORBA.COMM_FAILURE
            • org.omg.CORBA.DATA_CONVERSION
            • org.omg.CORBA.FREE_MEM
            • org.omg.CORBA.IMP_LIMIT
            • org.omg.CORBA.INITIALIZE
            • org.omg.CORBA.INTERNAL
            • org.omg.CORBA.INTF_REPOS
            • org.omg.CORBA.INV_FLAG
            • org.omg.CORBA.INV_IDENT
            • org.omg.CORBA.INV_OBJREF
            • org.omg.CORBA.INV_POLICY
            • org.omg.CORBA.INVALID_ACTIVITY
            • org.omg.CORBA.INVALID_TRANSACTION
            • org.omg.CORBA.MARSHAL
            • org.omg.CORBA.NO_IMPLEMENT
            • org.omg.CORBA.NO_MEMORY
            • org.omg.CORBA.NO_PERMISSION
            • org.omg.CORBA.NO_RESOURCES
            • org.omg.CORBA.NO_RESPONSE
            • org.omg.CORBA.OBJ_ADAPTER
            • org.omg.CORBA.OBJECT_NOT_EXIST
            • org.omg.CORBA.PERSIST_STORE
            • org.omg.CORBA.REBIND
            • org.omg.CORBA.TIMEOUT
            • org.omg.CORBA.TRANSACTION_MODE
            • org.omg.CORBA.TRANSACTION_REQUIRED
            • org.omg.CORBA.TRANSACTION_ROLLEDBACK
            • org.omg.CORBA.TRANSACTION_UNAVAILABLE
            • org.omg.CORBA.TRANSIENT
            • org.omg.CORBA.UNKNOWN
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.Bounds
          • org.omg.CORBA.PolicyError
          • org.omg.CORBA.UnknownUserException
          • org.omg.CORBA.WrongTransaction
    • org.omg.CORBA.TypeCode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.TypeCodeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongLongSeqHelper
    • org.omg.CORBA.ULongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongSeqHelper
    • org.omg.CORBA.ULongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.UnionMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.UnionMemberHelper
    • org.omg.CORBA.UnknownUserExceptionHelper
    • org.omg.CORBA.UnknownUserExceptionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.UShortSeqHelper
    • org.omg.CORBA.UShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueBaseHelper
    • org.omg.CORBA.ValueBaseHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ValueMemberHelper
    • org.omg.CORBA.VersionSpecHelper
    • org.omg.CORBA.VisibilityHelper
    • org.omg.CORBA.WCharSeqHelper
    • org.omg.CORBA.WCharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WrongTransactionHelper
    • org.omg.CORBA.WrongTransactionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringSeqHelper
    • org.omg.CORBA.WStringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)

接口分层结构

  • org.omg.CORBA.ARG_IN
  • org.omg.CORBA.ARG_INOUT
  • org.omg.CORBA.ARG_OUT
  • org.omg.CORBA.BAD_POLICY
  • org.omg.CORBA.BAD_POLICY_TYPE
  • org.omg.CORBA.BAD_POLICY_VALUE
  • org.omg.CORBA.CTX_RESTRICT_SCOPE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.CustomMarshal
  • org.omg.CORBA.DomainManagerOperations
    • org.omg.CORBA.DomainManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.IRObjectOperations
    • org.omg.CORBA.IDLTypeOperations
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IRObject (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
  • org.omg.CORBA.Object
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DomainManager (并 extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynAny
      • org.omg.CORBA.DynArray (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynEnum (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynFixed (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynSequence (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynStruct (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynUnion (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynValue (并 extends org.omg.CORBA.Object)
    • org.omg.CORBA.DynArray (并 extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynEnum (并 extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynFixed (并 extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynSequence (并 extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynStruct (并 extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynUnion (并 extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.DynValue (并 extends org.omg.CORBA.DynAny)
    • org.omg.CORBA.IRObject (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations)
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • org.omg.CORBA.Policy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
  • org.omg.CORBA.OMGVMCID
  • org.omg.CORBA.PolicyOperations
    • org.omg.CORBA.Policy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.PRIVATE_MEMBER
  • org.omg.CORBA.PUBLIC_MEMBER
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.DomainManager (并 extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
      • org.omg.CORBA.IRObject (并 extends org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
        • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
      • org.omg.CORBA.Policy (并 extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.DataInputStream
        • org.omg.CORBA.DataOutputStream
  • org.omg.CORBA.UNSUPPORTED_POLICY
  • org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
  • org.omg.CORBA.VM_ABSTRACT
  • org.omg.CORBA.VM_CUSTOM
  • org.omg.CORBA.VM_NONE
  • org.omg.CORBA.VM_TRUNCATABLE
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CORBA 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA
的使用

使用 org.omg.CORBA 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。
org.omg.SendingContext | 为值类型的编组提供支持。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 使用的 org.omg.CORBA 中的类
Object
CORBA 对象引用的定义。
ORB
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。
SystemException
所有 CORBA 标准异常的根类。

org.omg.CORBA 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
AnySeqHolder
AnySeq 的 Holder。
BAD_INV_ORDER
此异常指示调用者按错误顺序调用了操作。
BAD_OPERATION
当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
BAD_PARAM
当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
BooleanSeqHolder
BooleanSeq 的 Holder。
Bounds
当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
CharSeqHolder
CharSeq 的 Holder。
CompletionStatus
指示某一方法抛出 SystemException 时是否已结束运行的对象。
Context
用于在 Request 操作中指定上下文对象的对象，上下文字符串在与请求调用一起被发送之前，必须在该指定的上下文对象中进行解析。
ContextList
一个对象，它包含表示属性名称的 String 对象所组成的可修改列表。
Current
从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
CurrentOperations
Current 的接口。
DATA_CONVERSION
如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
DataInputStream
定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
DataOutputStream
定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。
DefinitionKind
该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。
DomainManager
提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
DomainManagerOperations
向 DomainManager 提供访问策略的方法。
DoubleSeqHolder
DoubleSeq 的 Holder。
DynAny
已过时。 使用新的 DynAny 替代
DynArray
已过时。 使用新的 DynArray 替代
DynEnum
已过时。 使用新的 DynEnum 替代
DynSequence
已过时。 使用新的 DynSequence 替代
DynStruct
已过时。 使用新的 DynStruct 替代
DynUnion
已过时。 使用新的 DynUnion 替代
Environment
用于 Request 操作的异常的容器 (holder)，使异常可用于客户端。
ExceptionList
Request 操作中使用的对象，用于描述可由某一方法抛出的异常。
FloatSeqHolder
FloatSeq 的 Holder。
IDLType
由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
IDLTypeOperations
此接口必须由所有 IDLType 对象实现。
IRObject
IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
IRObjectOperations
这是用于 IRObject 的映射的 Operations 接口。
LongLongSeqHolder
LongLongSeq 的 Holder。
LongSeqHolder
LongSeq 的 Holder。
MARSHAL
表示网络中传来的请求或应答在结构上无效。
NamedValue
在 DII 和 DSI 中用来描述参数和返回值的对象。
NameValuePair
将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。
NVList
包含 NamedValue 对象所组成的可修改列表。
Object
CORBA 对象引用的定义。
OctetSeqHolder
OctetSeq 的 Holder。
ORB
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。
ParameterMode
Parameter 参数模式的枚举。
Policy
派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。
PolicyError
发生策略错误时抛出的用户异常。
PolicyOperations
提供针对某一 Policy 对象的操作。
Principal
已过时。 已由 CORBA 2.2 取代。
Request
包含调用某一方法所必需的信息的对象。
ServerRequest
捕获对动态框架接口（Dynamic Skeleton Interface，DSI）请求的显式状态的对象。
ServiceDetail
表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。
ServiceInformation
CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。
ServiceInformationHolder
ServiceInformation 的 Holder。
SetOverrideType
标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
ShortSeqHolder
ShortSeq 的 Holder。
StructMember
描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。
SystemException
所有 CORBA 标准异常的根类。
TCKind
IDL enum TCKind 的 Java 映射，TCKind 指定 TypeCode 对象的种类。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
ULongLongSeqHolder
ULongLongSeq 的 Holder。
ULongSeqHolder
ULongSeq 的 Holder。
UnionMember
接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。
UnknownUserException
包含由服务器返回的用户异常的类。
UserException
CORBA IDL 定义的用户异常的根类。
UShortSeqHolder
UShortSeq 的 Holder。
ValueMember
接口存储库 (Interface Repository) 中关于 value 对象成员的描述。
WCharSeqHolder
WCharSeq 的 Holder。
WrongTransaction
CORBA WrongTransaction 用户定义异常。

org.omg.CORBA.DynAnyPackage 使用的 org.omg.CORBA 中的类
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.CORBA.ORBPackage 使用的 org.omg.CORBA 中的类
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.CORBA.TypeCodePackage 使用的 org.omg.CORBA 中的类
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.CORBA.portable 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
Context
用于在 Request 操作中指定上下文对象的对象，上下文字符串在与请求调用一起被发送之前，必须在该指定的上下文对象中进行解析。
ContextList
一个对象，它包含表示属性名称的 String 对象所组成的可修改列表。
CustomMarshal
将由 ORB 而不是由用户使用的抽象 value 类型。
DomainManager
提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
ExceptionList
Request 操作中使用的对象，用于描述可由某一方法抛出的异常。
NamedValue
在 DII 和 DSI 中用来描述参数和返回值的对象。
NVList
包含 NamedValue 对象所组成的可修改列表。
Object
CORBA 对象引用的定义。
ORB
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。
Policy
派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。
Principal
已过时。 已由 CORBA 2.2 取代。
Request
包含调用某一方法所必需的信息的对象。
SetOverrideType
标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
SystemException
所有 CORBA 标准异常的根类。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

org.omg.CORBA_2_3 使用的 org.omg.CORBA 中的类
BAD_PARAM
当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
ORB
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。

org.omg.CosNaming 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
DynamicImplementation
已过时。 org.omg.CORBA.DynamicImplementation
Object
CORBA 对象引用的定义。
ORB
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。
ServerRequest
捕获对动态框架接口（Dynamic Skeleton Interface，DSI）请求的显式状态的对象。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

org.omg.CosNaming.NamingContextExtPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.CosNaming.NamingContextPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.Dynamic 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
ParameterMode
Parameter 参数模式的枚举。

org.omg.DynamicAny 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
Object
CORBA 对象引用的定义。
TCKind
IDL enum TCKind 的 Java 映射，TCKind 指定 TypeCode 对象的种类。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

org.omg.DynamicAny.DynAnyFactoryPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

org.omg.DynamicAny.DynAnyPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

org.omg.IOP 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
Object
CORBA 对象引用的定义。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

org.omg.IOP.CodecFactoryPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.IOP.CodecPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.Messaging 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

org.omg.PortableInterceptor 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
Object
CORBA 对象引用的定义。
Policy
派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。
PolicyError
发生策略错误时抛出的用户异常。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.PortableInterceptor.ORBInitInfoPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.PortableServer 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
Current
从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
CurrentOperations
Current 的接口。
Object
CORBA 对象引用的定义。
ORB
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。
Policy
派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。
PolicyOperations
提供针对某一 Policy 对象的操作。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.PortableServer.CurrentPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.PortableServer.POAManagerPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.PortableServer.POAPackage 使用的 org.omg.CORBA 中的类
Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。
UserException
CORBA IDL 定义的用户异常的根类。

org.omg.PortableServer.ServantLocatorPackage 使用的 org.omg.CORBA 中的类
TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

org.omg.SendingContext 使用的 org.omg.CORBA 中的类
Object
CORBA 对象引用的定义。

org.omg.stub.java.rmi 使用的 org.omg.CORBA 中的类
Object
CORBA 对象引用的定义。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Invalid (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.DynAnyPackage
类 Invalid

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.DynAnyPackage.Invalid
所有已实现的接口：
Serializable, IDLEntity
public final class Invalid
extends UserException

动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。

构造方法摘要
Invalid()
构造一个 Invalid 对象。
Invalid(String reason)
构造一个 Invalid 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Invalid

public Invalid()
构造一个 Invalid 对象。

Invalid

public Invalid(String reason)
构造一个 Invalid 对象。

参数：
reason - 一个 String，提供更多有关传递给动态 any 操作的无效参数的信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InvalidSeq (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.DynAnyPackage
类 InvalidSeq

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.DynAnyPackage.InvalidSeq
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidSeq
extends UserException

任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。

构造方法摘要
InvalidSeq()
构造一个 InvalidSeq 对象。
InvalidSeq(String reason)
构造一个 InvalidSeq 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidSeq

public InvalidSeq()
构造一个 InvalidSeq 对象。

InvalidSeq

public InvalidSeq(String reason)
构造一个 InvalidSeq 对象。

参数：
reason - 一个 String，提供关于该异常的更多信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.DynAnyPackage
类 InvalidValue

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.DynAnyPackage.InvalidValue
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidValue
extends UserException

构造方法摘要
InvalidValue()
构造一个 InvalidValue 对象。
InvalidValue(String reason)
构造一个 InvalidValue 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidValue

public InvalidValue()
构造一个 InvalidValue 对象。

InvalidValue

public InvalidValue(String reason)
构造一个 InvalidValue 对象。

参数：
reason - 一个 String，提供关于该异常的更多信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeMismatch (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.DynAnyPackage
类 TypeMismatch

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.DynAnyPackage.TypeMismatch
所有已实现的接口：
Serializable, IDLEntity
public final class TypeMismatch
extends UserException

动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

构造方法摘要
TypeMismatch()
构造一个 TypeMismatch 对象。
TypeMismatch(String reason)
构造一个 TypeMismatch 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TypeMismatch

public TypeMismatch()
构造一个 TypeMismatch 对象。

TypeMismatch

public TypeMismatch(String reason)
构造一个 TypeMismatch 对象。

参数：
reason - 一个 String，提供关于该异常的更多信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CORBA.DynAnyPackage (Java Platform SE 6)

 org.omg.CORBA.DynAnyPackage
异常
Invalid
InvalidSeq
InvalidValue
TypeMismatch


org.omg.CORBA.DynAnyPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CORBA.DynAnyPackage

提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。

请参见：
描述

异常摘要
Invalid | 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
InvalidSeq | 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
InvalidValue |
TypeMismatch | 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

软件包 org.omg.CORBA.DynAnyPackage 的描述

提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。

从以下版本开始：
JDK1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.CORBA.DynAnyPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA.DynAnyPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.DynAnyPackage.Invalid
          • org.omg.CORBA.DynAnyPackage.InvalidSeq
          • org.omg.CORBA.DynAnyPackage.InvalidValue
          • org.omg.CORBA.DynAnyPackage.TypeMismatch
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CORBA.DynAnyPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA.DynAnyPackage
的使用

使用 org.omg.CORBA.DynAnyPackage 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 使用的 org.omg.CORBA.DynAnyPackage 中的类
Invalid
动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
InvalidSeq
任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
InvalidValue
TypeMismatch
动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DynAnyPackage.Invalid 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynAnyPackage.Invalid
的使用

使用 Invalid 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 Invalid 的使用

抛出 Invalid 的 org.omg.CORBA 中的方法
void | DynAny.assign(DynAny dyn_any) 已过时。 将内容从一个 Dynamic Any 复制到另一个 Dynamic Any 中。
void | DynAny.from_any(Any value) 已过时。 根据 Any 对象生成一个 DynAny 对象。
Any | DynAny.to_any() 已过时。 将 DynAny 对象转换成 Any 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DynAnyPackage.InvalidSeq 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynAnyPackage.InvalidSeq
的使用

使用 InvalidSeq 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 InvalidSeq 的使用

抛出 InvalidSeq 的 org.omg.CORBA 中的方法
void | DynArray.set_elements(Any[] value) 已过时。 将此 DynArray 对象的值设置为给定数组。
void | DynSequence.set_elements(Any[] value) 已过时。 使用给定数组设置此 sequence 中所有元素的值。
void | DynStruct.set_members(NameValuePair[] value) 已过时。 设置 struct 的成员。
void | DynValue.set_members(NameValuePair[] value) 已过时。 将此 DynValue 对象表示的 value 对象成员设置为给定的 NameValuePair 对象数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DynAnyPackage.InvalidValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynAnyPackage.InvalidValue
的使用

使用 InvalidValue 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 InvalidValue 的使用

抛出 InvalidValue 的 org.omg.CORBA 中的方法
void | DynAny.insert_any(Any value) 已过时。 插入给定 org.omg.CORBA.Any 对象作为此 DynAny 对象的值。
void | DynAny.insert_boolean(boolean value) 已过时。 插入给定 boolean 值作为此 DynAny 对象的值。
void | DynAny.insert_char(char value) 已过时。 插入给定 char 值作为此 DynAny 对象的值。
void | DynAny.insert_double(double value) 已过时。 插入给定 double 值作为此 DynAny 对象的值。
void | DynAny.insert_float(float value) 已过时。 插入给定 float 值作为此 DynAny 对象的值。
void | DynAny.insert_long(int value) 已过时。 插入给定 int 值作为此 DynAny 对象的值。
void | DynAny.insert_longlong(long value) 已过时。 插入给定 long 值作为此 DynAny 对象的值。
void | DynAny.insert_octet(byte value) 已过时。 插入给定 byte 值作为此 DynAny 对象的值。
void | DynAny.insert_reference(Object value) 已过时。 插入给定 org.omg.CORBA.Object 作为此 DynAny 对象的值。
void | DynAny.insert_short(short value) 已过时。 插入给定 short 值作为此 DynAny 对象的值。
void | DynAny.insert_string(String value) 已过时。 插入给定 String 对象作为此 DynAny 对象的值。
void | DynAny.insert_typecode(TypeCode value) 已过时。 插入给定 org.omg.CORBA.TypeCode 值作为此 DynAny 对象的值。
void | DynAny.insert_ulong(int value) 已过时。 插入给定 int 值作为此 DynAny 对象的值。
void | DynAny.insert_ulonglong(long value) 已过时。 插入给定 long 值作为此 DynAny 对象的值。
void | DynAny.insert_ushort(short value) 已过时。 插入给定 short 值作为此 DynAny 对象的值。
void | DynAny.insert_val(Serializable value) 已过时。 插入给定 java.io.Serializable 对象作为此 DynAny 对象的值。
void | DynAny.insert_wchar(char value) 已过时。 插入给定 char 值作为此 DynAny 对象的值。
void | DynAny.insert_wstring(String value) 已过时。 插入给定 String 作为此 DynAny 对象的值。
void | DynFixed.set_value(byte[] val) 已过时。 将给定 fixed 类型的实例设置为此 DynFixed 对象的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DynAnyPackage.TypeMismatch 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynAnyPackage.TypeMismatch
的使用

使用 TypeMismatch 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 TypeMismatch 的使用

抛出 TypeMismatch 的 org.omg.CORBA 中的方法
Any | DynAny.get_any() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Any。
boolean | DynAny.get_boolean() 已过时。 检索此 DynAny 对象中包含的 boolean 值。
char | DynAny.get_char() 已过时。 检索此 DynAny 对象中包含的 char 值。
double | DynAny.get_double() 已过时。 检索此 DynAny 对象中包含的 double 值。
float | DynAny.get_float() 已过时。 检索此 DynAny 对象中包含的 float 值。
int | DynAny.get_long() 已过时。 检索此 DynAny 对象中包含的 int 值。
long | DynAny.get_longlong() 已过时。 检索此 DynAny 对象中包含的 long 值。
byte | DynAny.get_octet() 已过时。 检索此 DynAny 对象中包含的 byte 值。
Object | DynAny.get_reference() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Other。
short | DynAny.get_short() 已过时。 检索此 DynAny 对象中包含的 short 值。
String | DynAny.get_string() 已过时。 检索此 DynAny 对象中包含的 String。
TypeCode | DynAny.get_typecode() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.TypeCode。
int | DynAny.get_ulong() 已过时。 检索此 DynAny 对象中包含的 int 值。
long | DynAny.get_ulonglong() 已过时。 检索此 DynAny 对象中包含的 long 值。
short | DynAny.get_ushort() 已过时。 检索此 DynAny 对象中包含的 short 值。
Serializable | DynAny.get_val() 已过时。 检索此 DynAny 对象中包含的 java.io.Serializable 对象。
char | DynAny.get_wchar() 已过时。 检索此 DynAny 对象中包含的 char 值。
String | DynAny.get_wstring() 已过时。 检索此 DynAny 对象中包含的 String。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


InconsistentTypeCode (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.ORBPackage
类 InconsistentTypeCode

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.ORBPackage.InconsistentTypeCode
所有已实现的接口：
Serializable, IDLEntity
public final class InconsistentTypeCode
extends UserException

当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。

构造方法摘要
InconsistentTypeCode()
构造一个不带任何原因信息的 InconsistentTypeCode 用户异常。
InconsistentTypeCode(String reason)
构造一个带有指定原因信息的 InconsistentTypeCode 用户异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InconsistentTypeCode

public InconsistentTypeCode()
构造一个不带任何原因信息的 InconsistentTypeCode 用户异常。

InconsistentTypeCode

public InconsistentTypeCode(String reason)
构造一个带有指定原因信息的 InconsistentTypeCode 用户异常。

参数：
reason - 包含原因消息的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InvalidName (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.ORBPackage
类 InvalidName

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.ORBPackage.InvalidName
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidName
extends UserException

当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

从以下版本开始：
JDK1.2
另请参见：
ORB.resolve_initial_references(String)

构造方法摘要
InvalidName()
构造一个不带原因消息的 InvalidName 异常。
InvalidName(String reason)
构造一个带有指定原因消息的 InvalidName 异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidName

public InvalidName()
构造一个不带原因消息的 InvalidName 异常。

InvalidName

public InvalidName(String reason)
构造一个带有指定原因消息的 InvalidName 异常。

参数：
reason - 包含原因消息的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CORBA.ORBPackage (Java Platform SE 6)

 org.omg.CORBA.ORBPackage
异常
InconsistentTypeCode
InvalidName


org.omg.CORBA.ORBPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CORBA.ORBPackage

提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。

请参见：
描述

异常摘要
InconsistentTypeCode | 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
InvalidName | 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

软件包 org.omg.CORBA.ORBPackage 的描述

提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。

相关文档

有关概述，请参阅：
  • 关于 CORBA 包的注释

从以下版本开始：
JDK1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.CORBA.ORBPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA.ORBPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.ORBPackage.InconsistentTypeCode
          • org.omg.CORBA.ORBPackage.InvalidName
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CORBA.ORBPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA.ORBPackage
的使用

使用 org.omg.CORBA.ORBPackage 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 使用的 org.omg.CORBA.ORBPackage 中的类
InconsistentTypeCode
当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
InvalidName
当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ORBPackage.InconsistentTypeCode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ORBPackage.InconsistentTypeCode
的使用

使用 InconsistentTypeCode 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 InconsistentTypeCode 的使用

抛出 InconsistentTypeCode 的 org.omg.CORBA 中的方法
DynAny | ORB.create_basic_dyn_any(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynArray | ORB.create_dyn_array(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynEnum | ORB.create_dyn_enum(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynSequence | ORB.create_dyn_sequence(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynStruct | ORB.create_dyn_struct(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynUnion | ORB.create_dyn_union(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ORBPackage.InvalidName 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ORBPackage.InvalidName
的使用

使用 InvalidName 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 InvalidName 的使用

抛出 InvalidName 的 org.omg.CORBA 中的方法
abstract  Object ORB.resolve_initial_references(String object_name)
根据可用初始服务名称集解析特定对象引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


BadKind (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.TypeCodePackage
类 BadKind

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.TypeCodePackage.BadKind
所有已实现的接口：
Serializable, IDLEntity
public final class BadKind
extends UserException

当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。例如，对不表示 IDL union 的 TypeCode 实例调用 discriminator_type() 方法将导致抛出 BadKind 异常。

从以下版本开始：
JDK1.2
另请参见：
TypeCode

构造方法摘要
BadKind()
构造一个不带任何原因消息的 BadKind 异常。
BadKind(String reason)
构造一个带有指定原因消息的 BadKind 异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BadKind

public BadKind()
构造一个不带任何原因消息的 BadKind 异常。

BadKind

public BadKind(String reason)
构造一个带有指定原因消息的 BadKind 异常。

参数：
reason - 包含原因消息的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Bounds (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.TypeCodePackage
类 Bounds

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CORBA.TypeCodePackage.Bounds
所有已实现的接口：
Serializable, IDLEntity
public final class Bounds
extends UserException

提供 TypeCode 操作 member_name()、member_type() 和 member_label。这些方法在索引参数大于等于构成该类型的成员数时将引发 Bounds。

从以下版本开始：
JDK1.2

构造方法摘要
Bounds()
构造一个不带任何原因信息的 Bounds 异常。
Bounds(String reason)
构造一个带有指定原因信息的 Bounds 异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Bounds

public Bounds()
构造一个不带任何原因信息的 Bounds 异常。

Bounds

public Bounds(String reason)
构造一个带有指定原因信息的 Bounds 异常。

参数：
reason - 包含原因消息的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CORBA.TypeCodePackage (Java Platform SE 6)

 org.omg.CORBA.TypeCodePackage
异常
BadKind
Bounds


org.omg.CORBA.TypeCodePackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CORBA.TypeCodePackage

提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。

请参见：
描述

异常摘要
BadKind | 当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。
Bounds | 提供 TypeCode 操作 member_name()、member_type() 和 member_label。

软件包 org.omg.CORBA.TypeCodePackage 的描述

提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。

相关文档

有关概述，请参阅：
  • 关于 CORBA 包的注释

从以下版本开始：
JDK1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.CORBA.TypeCodePackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA.TypeCodePackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CORBA.TypeCodePackage.BadKind
          • org.omg.CORBA.TypeCodePackage.Bounds
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CORBA.TypeCodePackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA.TypeCodePackage
的使用

使用 org.omg.CORBA.TypeCodePackage 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 使用的 org.omg.CORBA.TypeCodePackage 中的类
BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。
Bounds
提供 TypeCode 操作 member_name()、member_type() 和 member_label。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TypeCodePackage.BadKind 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TypeCodePackage.BadKind
的使用

使用 BadKind 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 BadKind 的使用

抛出 BadKind 的 org.omg.CORBA 中的方法
abstract TypeCode | TypeCode.concrete_base_type() 返回一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型。
abstract TypeCode | TypeCode.content_type() 返回表示此 TypeCode 对象所描述成员 IDL 类型的 TypeCode 对象。
abstract int | TypeCode.default_index() 返回默认成员的索引，如果没有默认成员，则返回 -1。
abstract TypeCode | TypeCode.discriminator_type() 返回描述所有非默认成员标签的 TypeCode 对象。
abstract short | TypeCode.fixed_digits() 返回此 TypeCode 对象所描述的 fixed 类型中数字的数量。
abstract short | TypeCode.fixed_scale() 返回此 TypeCode 对象所描述的 fixed 类型的标度。
abstract String | TypeCode.id() 检索全局标识此 TypeCode 对象类型的 RepositoryId。
abstract int | TypeCode.length() 返回此 TypeCode 对象所描述类型中的成员数。
abstract int | TypeCode.member_count() 检索此 TypeCode 对象所描述类型中的成员数。
abstract Any | TypeCode.member_label(int index) 检索给定索引标识的 union 成员的标签。
abstract String | TypeCode.member_name(int index) 检索给定索引标识的成员的简单名称。
abstract TypeCode | TypeCode.member_type(int index) 检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
abstract short | TypeCode.member_visibility(int index) 返回一个常量，它指示位于给定索引处的成员的可见性。
abstract String | TypeCode.name() 在 TypeCode 对象的封闭作用域内检索标识此对象的简单名称。
abstract short | TypeCode.type_modifier() 返回一个常量，它指示此 TypeCode 对象所描述的 value 类型的修饰符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TypeCodePackage.Bounds 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TypeCodePackage.Bounds
的使用

使用 Bounds 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 Bounds 的使用

抛出 Bounds 的 org.omg.CORBA 中的方法
abstract Any | TypeCode.member_label(int index) 检索给定索引标识的 union 成员的标签。
abstract String | TypeCode.member_name(int index) 检索给定索引标识的成员的简单名称。
abstract TypeCode | TypeCode.member_type(int index) 检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
abstract short | TypeCode.member_visibility(int index) 返回一个常量，它指示位于给定索引处的成员的可见性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


ApplicationException (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 ApplicationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.portable.ApplicationException
所有已实现的接口：
Serializable
public class ApplicationException
extends Exception

此类用来报告 ORB 和 stub 之间的应用程序级异常。

构造方法摘要
ApplicationException(String id, InputStream ins)
根据异常的 CORBA 存储库 ID 和一个输入流（可从中读取异常数据作为其参数）构造 ApplicationException。
方法摘要
String | getId() 返回异常的 CORBA 存储库 ID 而不会将其从异常输入流中移除。
InputStream | getInputStream() 返回可从中读取异常数据作为其参数的输入流。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ApplicationException

public ApplicationException(String id,
                            InputStream ins)
根据异常的 CORBA 存储库 ID 和一个输入流（可从中读取异常数据作为其参数）构造 ApplicationException。

参数：
id - 用户异常的存储库 id
ins - 包含用户异常数据的流
方法详细信息

getId

public String getId()
返回异常的 CORBA 存储库 ID 而不会将其从异常输入流中移除。

返回：
此异常的 CORBA 存储库 ID

getInputStream

public InputStream getInputStream()
返回可从中读取异常数据作为其参数的输入流。

返回：
包含用户异常数据的流
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BoxedValueHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 BoxedValueHelper

所有已知实现类：
StringValueHelper, WStringValueHelper
public interface BoxedValueHelper

方法摘要
String | get_id()
Serializable | read_value(InputStream is)
void | write_value(OutputStream os, Serializable value)

方法详细信息

read_value

Serializable read_value(InputStream is)

write_value

void write_value(OutputStream os,
                 Serializable value)

get_id

String get_id()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CustomValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 CustomValue

所有超级接口：
CustomMarshal, IDLEntity, Serializable, ValueBase
public interface CustomValue
extends ValueBase, CustomMarshal

通过自定义值类型实现的 ValueBase 扩展。

方法摘要
从接口 org.omg.CORBA.portable.ValueBase 继承的方法
_truncatable_ids
从接口 org.omg.CORBA.CustomMarshal 继承的方法
marshal, unmarshal

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Delegate (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 Delegate

java.lang.Object
    继承者  org.omg.CORBA.portable.Delegate
直接已知子类：
Delegate
public abstract class Delegate
extends Object

为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。 每个 stub（代理）包含一个 delegate 对象，所有的 org.omg.CORBA.Object 方法都将转发到该对象。这允许一个供应商的 ORB 所生成的 stub 能与另一个供应商 ORB 中的 delegate 一起工作。

另请参见：
Object

构造方法摘要
Delegate()
方法摘要
abstract  Request create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
创建在动态调用接口中使用的 Request 实例。
abstract  Request create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
创建在动态调用接口中使用的 Request 实例。
abstract  Object duplicate(Object obj)
返回所提供对象引用的复本。
 boolean equals(Object self, Object obj)
提供重写委托 CORBA 对象方法 equals(java.lang.Object obj) 的实现。
 DomainManager[] get_domain_managers(Object self)
检索此对象的 DomainManager。
abstract  Object get_interface_def(Object self)
返回一个所提供对象引用的 InterfaceDef。
 Policy get_policy(Object self, int policy_type)
返回应用于此对象的指定类型的 Policy 对象。
abstract  int hash(Object obj, int max)
返回此对象引用的内部 ORB 标识符（哈希码）。
 int hashCode(Object self)
提供重写委托 CORBA 对象的 hashCode() 方法的实现。
 InputStream invoke(Object self, OutputStream output)
由 stub 调用，以调用一个操作。
abstract  boolean is_a(Object obj, String repository_id)
检查对象引用是否是给定接口的实例。
abstract  boolean is_equivalent(Object obj, Object other)
确定两个对象引用是否相等。
 boolean is_local(Object self)
如果此对象由本地 servant 实现，则返回 true。
abstract  boolean non_existent(Object obj)
确定对象引用的服务器对象是否已经被销毁。
 ORB orb(Object obj)
提供对与其参数关联的 orb 的引用。
abstract  void release(Object obj)
发布与所提供对象引用关联的资源。
 void releaseReply(Object self, InputStream input)
releaseReply 可以由 stub 以可选方式调用，以在解组完成时将应答流释放回 ORB。
abstract  Request request(Object obj, String operation)
创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
 OutputStream request(Object self, String operation, boolean responseExpected)
request 由 stub 调用，以获取用于编组参数的 OutputStream。
 void servant_postinvoke(Object self, ServantObject servant)
servant_postinvoke() 由本地 stub 在已经对本地 servant 调用该操作之后调用。
 ServantObject servant_preinvoke(Object self, String operation, Class expectedType)
返回对应该用作此请求的 servant 的 Java 引用。
 Object set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
将传入的策略与它返回的新创建对象引用关联。
 String toString(Object self)
提供重写委托 CORBA 对象的 toString() 方法的实现。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Delegate

public Delegate()
方法详细信息

get_interface_def

public abstract Object get_interface_def(Object self)
返回一个所提供对象引用的 InterfaceDef。

参数：
self - 需要返回 InterfaceDef 的对象引用。
返回：
InterfaceDef

duplicate

public abstract Object duplicate(Object obj)
返回所提供对象引用的复本。

参数：
obj - 需要返回复本的对象引用
返回：
对象引用的复本

release

public abstract void release(Object obj)
发布与所提供对象引用关联的资源。

参数：
obj - 需要释放资源的对象引用

is_a

public abstract boolean is_a(Object obj,
                             String repository_id)
检查对象引用是否是给定接口的实例。

参数：
obj - 要检查的对象引用。
repository_id - 要检查的接口存储库标识符。
返回：
如果对象引用支持该接口，则返回 true

non_existent

public abstract boolean non_existent(Object obj)
确定对象引用的服务器对象是否已经被销毁。

参数：
obj - 委托给此 delegate 的对象引用。
返回：
如果 ORB 确信 server 对象不存在，则返回 true；否则返回 false

is_equivalent

public abstract boolean is_equivalent(Object obj,
                                      Object other)
确定两个对象引用是否相等。

参数：
obj - 委托给此 delegate 的对象引用。
other - 要检查相等性的对象引用。
返回：
如果两个对象是相等的 CORBA，则返回 true。

hash

public abstract int hash(Object obj,
                         int max)
返回此对象引用的内部 ORB 标识符（哈希码）。

参数：
obj - 委托给此 delegate 的对象引用。
max - 指示 ORB 返回的哈希值的上界。
返回：
对象引用的内部 ORB 哈希标识符

request

public abstract Request request(Object obj,
                                String operation)
创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。

参数：
obj - 委托给此 delegate 的对象引用。
operation - 要使用 Request 实例调用的操作名称。
返回：
创建的 Request 实例

create_request

public abstract Request create_request(Object obj,
                                       Context ctx,
                                       String operation,
                                       NVList arg_list,
                                       NamedValue result)
创建在动态调用接口中使用的 Request 实例。

参数：
obj - 委托给此 delegate 的对象引用。
ctx - 要使用的上下文。
operation - 要调用的操作的名称。
arg_list - NVList 形式的操作参数
result - NamedValue 形式的结果容器。
返回：
创建的 Request 对象。

create_request

public abstract Request create_request(Object obj,
                                       Context ctx,
                                       String operation,
                                       NVList arg_list,
                                       NamedValue result,
                                       ExceptionList exclist,
                                       ContextList ctxlist)
创建在动态调用接口中使用的 Request 实例。

参数：
obj - 委托给此 delegate 的对象引用。
ctx - 要使用的上下文。
operation - 要调用的操作的名称。
arg_list - NVList 形式的操作参数
result - NamedValue 形式的结果容器。
exclist - 操作可以抛出的可能异常列表。
ctxlist - 需要解析并使用 Request 发送的上下文字符串列表。
返回：
创建的 Request 对象。

orb

public ORB orb(Object obj)
提供对与其参数关联的 orb 的引用。

参数：
obj - 委托给此 delegate 的对象引用。
返回：
关联的 ORB。
另请参见：
portable 包中有关未实现特性的注释

get_policy

public Policy get_policy(Object self,
                         int policy_type)
返回应用于此对象的指定类型的 Policy 对象。

参数：
self - 委托给此 delegate 的对象引用。
policy_type - 要获取的策略类型。
返回：
policy_type 参数指定的 Policy 对象类型。
抛出：
BAD_PARAM - 策略类型无效时引发，策略类型无效可能是由于此 ORB 不支持指定的类型，或者该类型的 policy 对象没有与此 Object 关联。
另请参见：
portable 包中有关未实现特性的注释

get_domain_managers

public DomainManager[] get_domain_managers(Object self)
检索此对象的 DomainManager。这允许管理服务（和应用程序）检索域管理程序，从而使得安全性和其他策略能应用于作为该域成员的各个对象。

参数：
self - 委托给此 delegate 的对象引用。
返回：
此类直接封装的域管理程序列表。至少有一个域管理程序总是返回在列表中，因为默认情况下，每个类在创建时至少关联一个域管理程序。
另请参见：
portable 包中有关未实现特性的注释

set_policy_override

public Object set_policy_override(Object self,
                                  Policy[] policies,
                                  SetOverrideType set_add)
将传入的策略与它返回的新创建对象引用关联。只有某些关于在客户终端调用操作的策略才可以使用此操作重写。试图重写任何其他策略将导致引发 CORBA::NO_PERMISSION 异常。

参数：
self - 委托给此 delegate 的对象引用。
policies - Policy 对象的引用序列。
set_add - 指示是否应该这些策略添加到已经存在于该对象引用中的其他所有重写操作上 (ADD_OVERRIDE)，或者是否应该将它们添加到一个空的重写释放对象引用 (clean override free object reference)
返回：
带有关联新策略的新对象引用。
另请参见：
portable 包中有关未实现特性的注释

is_local

public boolean is_local(Object self)
如果此对象由本地 servant 实现，则返回 true。

参数：
self - 委托给此 delegate 的对象引用。
返回：
仅当实现此对象的 servant 位于此 Java VM 时返回 true。如果 servant 不是本地的或 ORB 不支持此特定 servant 的本地 stub，则返回 false。is_local() 的默认行为是返回 false。

servant_preinvoke

public ServantObject servant_preinvoke(Object self,
                                       String operation,
                                       Class expectedType)
返回对应该用作此请求的 servant 的 Java 引用。servant_preinvoke() 由本地 stub 调用。如果返回 ServantObject 对象，则其 servant 字段已经被设置为预期类型的对象（注：该对象可以是也可以不是实际的 servant 实例）。本地 stub 可以将 servant 字段强制转换为所需类型，然后直接调用操作。ServantRequest 对象只对一次调用有效，不能用于多次调用。

参数：
self - 委托给此 delegate 的对象引用。
operation - 包含操作名称的字符串。该操作名称对应于将被编码入 GIOP 请求的操作名称。
expectedType - 表示 servant 所需类型的 Class 对象。所需类型是与 stub 接口的操作类关联的 Class 对象（例如，对应接口 Foo 的 stub 将传递对应于 FooOperation 接口的 Class 对象）。
返回：
一个 ServantObject 对象。如果该方法不希望支持此优化（例如，由于安全性、事务处理等原因），则返回 null 值。如果 servant 不是预期类型，则该方法必须返回 null。

servant_postinvoke

public void servant_postinvoke(Object self,
                               ServantObject servant)
servant_postinvoke() 由本地 stub 在已经对本地 servant 调用该操作之后调用。如果 servant_preinvoke() 返回非 null 值，则必须调用此方法，即使 servant 的方法抛出异常。因此，调用 servant_postinvoke() 应该置于 Java finally 子句中。

参数：
self - 委托给此 delegate 的对象引用。
servant - 从 servant_preinvoke() 方法返回的 ServantObject 实例。

request

public OutputStream request(Object self,
                            String operation,
                            boolean responseExpected)
request 由 stub 调用，以获取用于编组参数的 OutputStream。stub 必须提供操作名称，并指示是否希望响应（即是否为单向调用）。

参数：
self - 委托给此 delegate 的对象引用。
operation - 包含操作名称的字符串。该操作名称对应于将被编码入 GIOP 请求的操作名称。
responseExpected - 如果该操作是单向操作，则该值为 false；否则为 true。
返回：
OutputStream OutputStream，其中可以编组 request 的参数。
另请参见：
portable 包中有关未实现特性的注释

invoke

public InputStream invoke(Object self,
                          OutputStream output)
                   throws ApplicationException,
                          RemarshalException
由 stub 调用，以调用一个操作。stub 提供一个之前通过 request() 调用返回的 OutputStream。invoke 返回包含已编组应答的 InputStream。如果发生异常，则 invoke 可以抛出 ApplicationException 对象，该对象包含可从中解组用户异常状态的 InputStream。

参数：
self - 委托给此 delegate 的对象引用。
output - 包含编组变量的 OutputStream。
返回：
从中可解组应答参数的 InputStream。
抛出：
ApplicationException - 如果实现（对调用）抛出一个异常，而该异常作为其远程方法定义的一部分而定义，则抛出此异常
RemarshalException - 重新编组失败时抛出。
另请参见：
portable 包中有关未实现特性的注释

releaseReply

public void releaseReply(Object self,
                         InputStream input)
releaseReply 可以由 stub 以可选方式调用，以在解组完成时将应答流释放回 ORB。stub 传递 invoke() 或 ApplicationException.getInputStream() 返回的 InputStream。也可以将 null 值传递给 releaseReply，在这种情况下该方法是无操作 (noop)。

参数：
self - 委托给此 delegate 的对象引用。
input - invoke() 返回的 InputStream。
另请参见：
portable 包中有关未实现特性的注释

toString

public String toString(Object self)
提供重写委托 CORBA 对象的 toString() 方法的实现。

参数：
self - 委托给此 delegate 的对象引用
返回：
一个 String 对象，表示委托给此 Delegate 对象的对象引用

hashCode

public int hashCode(Object self)
提供重写委托 CORBA 对象的 hashCode() 方法的实现。

参数：
self - 委托给此 delegate 的对象引用
返回：
一个 int，表示委托给此 Delegate 对象的对象引用哈希码

equals

public boolean equals(Object self,
                      Object obj)
提供重写委托 CORBA 对象方法 equals(java.lang.Object obj) 的实现。

参数：
self - 委托给此 delegate 的对象引用
obj - 要与之比较的 Object
返回：
如果 obj 等于 self，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDLEntity (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 IDLEntity

所有超级接口：
Serializable
所有已知子接口：
AdapterActivator, BindingIterator, ClientRequestInfo, ClientRequestInterceptor, Codec, CodecFactory, Current, Current, Current, CustomValue, DataInputStream, DataOutputStream, DomainManager, DynAny, DynAnyFactory, DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon, IdAssignmentPolicy, IDLType, IdUniquenessPolicy, ImplicitActivationPolicy, Interceptor, IORInfo, IORInterceptor, IORInterceptor_3_0, IRObject, LifespanPolicy, NamingContext, NamingContextExt, ObjectReferenceFactory, ObjectReferenceTemplate, ORBInitializer, ORBInitInfo, POA, POAManager, Policy, PolicyFactory, RequestInfo, RequestProcessingPolicy, RunTime, ServantActivator, ServantLocator, ServantManager, ServantRetentionPolicy, ServerRequestInfo, ServerRequestInterceptor, StreamableValue, ThreadPolicy, ValueBase
所有已知实现类：
_BindingIteratorImplBase, _BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, _PolicyStub, _ServantActivatorStub, _ServantLocatorStub, AdapterAlreadyExists, AdapterInactive, AdapterNonExistent, AlreadyBound, Any, BadKind, Binding, BindingType, Bounds, Bounds, CannotProceed, CompletionStatus, DefinitionKind, DuplicateName, Encoding, FormatMismatch, ForwardRequest, ForwardRequest, IdAssignmentPolicyValue, IdUniquenessPolicyValue, ImplicitActivationPolicyValue, InconsistentTypeCode, InconsistentTypeCode, Invalid, InvalidAddress, InvalidName, InvalidName, InvalidName, InvalidPolicy, InvalidSeq, InvalidSlot, InvalidTypeForEncoding, InvalidValue, InvalidValue, IOR, LifespanPolicyValue, NameComponent, NameDynAnyPair, NameValuePair, NameValuePair, NoContext, NoServant, NotEmpty, NotFound, NotFoundReason, ObjectAlreadyActive, ObjectNotActive, Parameter, ParameterMode, PolicyError, RequestProcessingPolicyValue, ServantAlreadyActive, ServantNotActive, ServantRetentionPolicyValue, ServiceContext, ServiceDetail, ServiceInformation, SetOverrideType, State, StructMember, TaggedComponent, TaggedProfile, ThreadPolicyValue, TypeCode, TypeMismatch, TypeMismatch, TypeMismatch, UnionMember, UnknownEncoding, UnknownUserException, UserException, ValueMember, WrongAdapter, WrongPolicy, WrongTransaction
public interface IDLEntity
extends Serializable

一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。RMI IIOP 寻找这种标记来执行编组/解组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndirectionException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 IndirectionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.portable.IndirectionException
所有已实现的接口：
Serializable
public class IndirectionException
extends SystemException

Indirection 异常是一个特定于 Java 的系统异常。在调用 ORB 输入流解组一个以间接运算 (indirection) 形式编码的值，且该值正处于解组过程中时，将抛出该异常。这可能发生在 ORB 输入流调用 ValueHandler 来解组一个 RMI 值，而该值的状态包含在对其自身的递归引用中时。因为调用 ValueHandler.read_value() 目前不返回值，所以 ORB 输入流的间接运算列表不包含用于间接运算标记所指定的流偏移量的条目。流偏移量返回到异常的 offset 字段中。

另请参见：
InputStream, OutputStream

字段摘要
 int offset
指向流偏移量。
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
IndirectionException(int offset)
使用正确的偏移量值创建一个 IndirectionException。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

offset

public int offset
指向流偏移量。

构造方法详细信息

IndirectionException

public IndirectionException(int offset)
使用正确的偏移量值创建一个 IndirectionException。流偏移量返回到异常的 offset 字段中。在从流中递归读出定义的值时构造并抛出此异常。

参数：
offset - 流偏移量，该处检测到递归
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputStream (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 InputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  org.omg.CORBA.portable.InputStream
所有已实现的接口：
Closeable
直接已知子类：
InputStream
public abstract class InputStream
extends InputStream

InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。这些方法供 ORB 用来解组 IDL 类型以及从 Any 中析取 IDL。_array 形式的方法可以直接用来读取 IDL 类型的序列和数组。

从以下版本开始：
JDK1.2

构造方法摘要
InputStream()
方法摘要
ORB | orb() 返回创建此 InputStream 的 ORB。
abstract Any | read_any() 从此输入流中读取一个 Any。
abstract void | read_boolean_array(boolean[] value, int offset, int length) 从此输入流中读取一个 boolean 数组。
abstract boolean | read_boolean() 从此输入流中读取一个 boolean 值。
abstract void | read_char_array(char[] value, int offset, int length) 从此输入流中读取一个 char 数组。
abstract char | read_char() 从此输入流中读取一个 char 值。
Context | read_Context() 从流中读取一个 CORBA 上下文。
abstract void | read_double_array(double[] value, int offset, int length) 从此输入流中读取一个 double 数组。
abstract double | read_double() 从此输入流中读取一个 double 值。
BigDecimal | read_fixed() 读取一个 BigDecimal 数。
abstract void | read_float_array(float[] value, int offset, int length) 从此输入流中读取一个 float 数组。
abstract float | read_float() 从此输入流中读取一个 float 值。
abstract void | read_long_array(int[] value, int offset, int length) 从此输入流中读取一个 CORBA long（即 Java int）数组。
abstract int | read_long() 从此输入流中读取一个 CORBA long（即 Java int）值。
abstract void | read_longlong_array(long[] value, int offset, int length) 从此输入流中读取一个 CORBA longlong（即 Java long）数组。
abstract long | read_longlong() 从此输入流中读取一个 CORBA longlong（即 Java long）值。
abstract Object | read_Object() 从此输入流中读取一个 CORBA 对象。
Object | read_Object(Class clz) 取消对象的编组并返回一个 CORBA Object，该对象是作为参数传递的类的实例。
abstract void | read_octet_array(byte[] value, int offset, int length) 从此输入流中读取一个八位组（即 bytes）数组。
abstract byte | read_octet() 从此输入流中读取一个八位组（即 byte）值。
Principal | read_Principal() 已过时。 已由 CORBA 2.2 取代。
abstract void | read_short_array(short[] value, int offset, int length) 从此输入流中读取一个 short 数组。
abstract short | read_short() 从此输入流中读取一个 short 值。
abstract String | read_string() 从此输入流中读取一个 string 值。
abstract TypeCode | read_TypeCode() 从此输入流中读取一个 TypeCode。
abstract void | read_ulong_array(int[] value, int offset, int length) 从此输入流中读取一个无符号 CORBA long（即 Java int）数组。
abstract int | read_ulong() 从此输入流中读取一个无符号 CORBA long（即 Java int）值。
abstract void | read_ulonglong_array(long[] value, int offset, int length) 从此输入流中读取一个无符号 CORBA longlong（即 Java long）数组。
abstract long | read_ulonglong() 从此输入流中读取一个 CORBA 无符号 longlong（即 Java long）值。
abstract void | read_ushort_array(short[] value, int offset, int length) 从此输入流中读取一个无符号 short 数组。
abstract short | read_ushort() 从此输入流中读取一个无符号 short 值。
abstract void | read_wchar_array(char[] value, int offset, int length) 从此输入流中读取一个 wide char 数组。
abstract char | read_wchar() 从此输入流中读取一个 wide char 值。
abstract String | read_wstring() 从此输入流中读取一个 wide string 值。
int | read() 从输入流中读取数据的下一个字节。
从类 java.io.InputStream 继承的方法
available, close, mark, markSupported, read, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputStream

public InputStream()
方法详细信息

read_boolean

public abstract boolean read_boolean()
从此输入流中读取一个 boolean 值。

返回：
从此输入流中读取的 boolean 值。

read_char

public abstract char read_char()
从此输入流中读取一个 char 值。

返回：
从此输入流中读取的 char 值。

read_wchar

public abstract char read_wchar()
从此输入流中读取一个 wide char 值。

返回：
从此输入流中读取的 char 值。

read_octet

public abstract byte read_octet()
从此输入流中读取一个八位组（即 byte）值。

返回：
从此输入流中读取的 byte 值。

read_short

public abstract short read_short()
从此输入流中读取一个 short 值。

返回：
从此输入流中读取的 short 值。

read_ushort

public abstract short read_ushort()
从此输入流中读取一个无符号 short 值。

返回：
从此输入流中读取的 short 值。

read_long

public abstract int read_long()
从此输入流中读取一个 CORBA long（即 Java int）值。

返回：
从此输入流中读取的 int 值。

read_ulong

public abstract int read_ulong()
从此输入流中读取一个无符号 CORBA long（即 Java int）值。

返回：
从此输入流中读取的 int 值。

read_longlong

public abstract long read_longlong()
从此输入流中读取一个 CORBA longlong（即 Java long）值。

返回：
从此输入流中读取的 long 值。

read_ulonglong

public abstract long read_ulonglong()
从此输入流中读取一个 CORBA 无符号 longlong（即 Java long）值。

返回：
从此输入流中读取的 long 值。

read_float

public abstract float read_float()
从此输入流中读取一个 float 值。

返回：
从此输入流中读取的 float 值。

read_double

public abstract double read_double()
从此输入流中读取一个 double 值。

返回：
从此输入流中读取的 double 值。

read_string

public abstract String read_string()
从此输入流中读取一个 string 值。

返回：
从此输入流中读取的 String 值。

read_wstring

public abstract String read_wstring()
从此输入流中读取一个 wide string 值。

返回：
从此输入流中读取的 String 值。

read_boolean_array

public abstract void read_boolean_array(boolean[] value,
                                        int offset,
                                        int length)
从此输入流中读取一个 boolean 数组。

参数：
value - 返回的 boolean 数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_char_array

public abstract void read_char_array(char[] value,
                                     int offset,
                                     int length)
从此输入流中读取一个 char 数组。

参数：
value - 返回的 char 数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_wchar_array

public abstract void read_wchar_array(char[] value,
                                      int offset,
                                      int length)
从此输入流中读取一个 wide char 数组。

参数：
value - 返回的 wide char 数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_octet_array

public abstract void read_octet_array(byte[] value,
                                      int offset,
                                      int length)
从此输入流中读取一个八位组（即 bytes）数组。

参数：
value - 返回的八位组（即 byte）数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_short_array

public abstract void read_short_array(short[] value,
                                      int offset,
                                      int length)
从此输入流中读取一个 short 数组。

参数：
value - 返回的 short 数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_ushort_array

public abstract void read_ushort_array(short[] value,
                                       int offset,
                                       int length)
从此输入流中读取一个无符号 short 数组。

参数：
value - 返回的 short 数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_long_array

public abstract void read_long_array(int[] value,
                                     int offset,
                                     int length)
从此输入流中读取一个 CORBA long（即 Java int）数组。

参数：
value - 返回的 CORBA long（即 Java int）数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_ulong_array

public abstract void read_ulong_array(int[] value,
                                      int offset,
                                      int length)
从此输入流中读取一个无符号 CORBA long（即 Java int）数组。

参数：
value - 返回的 CORBA long（即 Java int）数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_longlong_array

public abstract void read_longlong_array(long[] value,
                                         int offset,
                                         int length)
从此输入流中读取一个 CORBA longlong（即 Java long）数组。

参数：
value - 返回的 CORBA long（即 Java long）数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_ulonglong_array

public abstract void read_ulonglong_array(long[] value,
                                          int offset,
                                          int length)
从此输入流中读取一个无符号 CORBA longlong（即 Java long）数组。

参数：
value - 返回的 CORBA long（即 Java long）数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_float_array

public abstract void read_float_array(float[] value,
                                      int offset,
                                      int length)
从此输入流中读取一个 float 数组。

参数：
value - 返回的 float 数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_double_array

public abstract void read_double_array(double[] value,
                                       int offset,
                                       int length)
从此输入流中读取一个 double 数组。

参数：
value - 返回的 double 数组。
offset - 流中的偏移量。
length - 要读取的缓冲区长度。

read_Object

public abstract Object read_Object()
从此输入流中读取一个 CORBA 对象。

返回：
从此输入流中读取的 Object 实例。

read_TypeCode

public abstract TypeCode read_TypeCode()
从此输入流中读取一个 TypeCode。

返回：
从此输入流中读取的 TypeCode 实例。

read_any

public abstract Any read_any()
从此输入流中读取一个 Any。

返回：
从此输入流中读取的 Any 实例。

read_Principal

@Deprecated
public Principal read_Principal()
已过时。 已由 CORBA 2.2 取代。

返回调用的 principal。

返回：
调用主体。

read

public int read()
         throws IOException
从类 InputStream 复制的描述
从输入流中读取数据的下一个字节。返回 0 到 255 范围内的 int 字节值。如果因为已经到达流末尾而没有可用的字节，则返回值 -1。在输入数据可用、检测到流末尾或者抛出异常前，此方法一直阻塞。

子类必须提供此方法的一个实现。

指定者：
类 InputStream 中的 read
返回：
下一个数据字节；如果到达流的末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
portable 包中有关未实现特性的注释

read_fixed

public BigDecimal read_fixed()
读取一个 BigDecimal 数。

返回：
一个 java.math.BigDecimal 数

read_Context

public Context read_Context()
从流中读取一个 CORBA 上下文。

返回：
CORBA 上下文
另请参见：
portable 包中有关未实现特性的注释

read_Object

public Object read_Object(Class clz)
取消对象的编组并返回一个 CORBA Object，该对象是作为参数传递的类的实例。此类是预期类型的 stub 类。

参数：
clz - 与能肯定预期类型相对应的 stub 类的 Class 对象，或能肯定预期的 RMI/IDL 接口类型的 Class 对象。
返回：
从此流中读取的 clz 的 Object 实例
另请参见：
portable 包中有关未实现特性的注释

orb

public ORB orb()
返回创建此 InputStream 的 ORB。

返回：
创建此流的 ORB 对象
另请参见：
portable 包中有关未实现特性的注释
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvokeHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 InvokeHandler

所有已知子接口：
Tie
所有已知实现类：
BindingIteratorPOA, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA
public interface InvokeHandler

此接口为入呼叫 (incoming call) 提供调度机制。ORB 调用它来调度对 servant 的请求。

方法摘要
 OutputStream _invoke(String method, InputStream input, ResponseHandler handler)
由 ORB 调用来调度对 servant 的请求。

方法详细信息

_invoke

OutputStream _invoke(String method,
                     InputStream input,
                     ResponseHandler handler)
                     throws SystemException
由 ORB 调用来调度对 servant 的请求。 ORB 传递方法名称、包含编组参数的 InputStream，以及 servant 用来构造恰当应答的 ResponseHandler。 此方法只可能抛出 CORBA SystemException。 该方法必须返回包含已编组应答的 ResponseHandler 所创建的 OutputStream。 在方法调用的生存期外，servant 必须仍然保留一个对 ResponseHandler 的引用。 Servant 的行为定义如下：

1. 确定正确的方法和 InputStream 中的已解组参数。

2. 调用方法实现。

3. 如果没有任何用户异常，则使用 ResponseHandler 创建一个正常应答。

4. 如果发生用户异常，则使用 ResponseHandler 创建异常。

5. ResponseHandler 将编组应答返回到 OutputStream。

6. 将 OutputStream 返回到 ORB。

参数：
method - 方法名称。
input - 包含已编组参数的 InputStream。
handler - servant 用来构造正确应答的 ResponseHandler。
返回：
包含已编组应答的 ResponseHandler 所创建的 OutputStream。
抛出：
SystemException - 当因为 CORBA 系统异常而导致调用失败时，抛出此异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 ObjectImpl

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
所有已实现的接口：
Object
直接已知子类：
_BindingIteratorStub, _DynAnyFactoryStub, _DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub, _IDLTypeStub, _NamingContextExtStub, _NamingContextStub, _PolicyStub, _ServantActivatorStub, _ServantLocatorStub, DynamicImplementation, ObjectImpl
public abstract class ObjectImpl
extends Object
implements Object

所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。所有方法实现都被委托到 ObjectImpl 实例中存储的 Delegate 对象。ObjectImpl 允许可移植的 stub，因为 Delegate 可以由特定于不同供应商的 ORB 实现。

构造方法摘要
ObjectImpl()
方法摘要
Request | _create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | _create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
Object | _duplicate() 返回此 ObjectImpl 对象的一个副本。
Delegate | _get_delegate() 获得对特定于供应商的 Delegate 对象的引用，此 ObjectImpl 对象将对其调用的所有方法委托给该对象。
DomainManager[] | _get_domain_managers() 获得此 ObjectImpl 对象的域管理程序所组成的列表。
Object | _get_interface_def() 获得此 ObjectImpl 对象的接口定义。
Policy | _get_policy(int policy_type) 获得此 ObjectImpl 对象具有给定策略类型的 Policy 对象。
int | _hash(int maximum) 获得充当此 ObjectImpl 对象内部 ORB 标识符的哈希码。
abstract String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
InputStream | _invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
boolean | _is_a(String repository_id) 检查给定存储库标识符标识的对象是否是 ObjectImpl 对象。
boolean | _is_equivalent(Object that) 检查给定的 ObjectImpl 对象是否等于此 ObjectImpl 对象。
boolean | _is_local() 检查此 ObjectImpl 对象是否是由本地 servant 实现的。
boolean | _non_existent() 检查此 ObjectImpl 对象的 server 对象是否已经被销毁。
ORB | _orb() 返回对与此对象及其委托相关的 ORB 的引用。
void | _release() 释放与此 ObjectImpl 对象关联的资源。
void | _releaseReply(InputStream input) 调用 _invoke 方法并且解组完成后，将给定的应答流释放回 ORB。
Request | _request(String operation) 创建一个 Request 对象，使其包含可用于动态调用接口 (Dynamic Invocation Interface) 的给定方法。
OutputStream | _request(String operation, boolean responseExpected) 返回一个 OutputStream 对象，该对象用于编组给定方法的参数。
void | _servant_postinvoke(ServantObject servant) 本地 stub 在发起了对本地 servant（通过对 _servant_preinvoke 方法的调用得到）的一次操作后，再调用此方法。
ServantObject | _servant_preinvoke(String operation, Class expectedType) 返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。
void | _set_delegate(Delegate delegate) 将此 ObjectImpl 实例的 Delegate 设置为给定的 Delegate 对象。
Object | _set_policy_override(Policy[] policies, SetOverrideType set_add) 将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
boolean | equals(Object obj) 比较此 ObjectImpl 对象与给定对象是否相等。
int | hashCode() 返回此 ObjectImpl 对象的哈希码。
String | toString() 返回表示此 ObjectImpl 对象的 String 对象。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ObjectImpl

public ObjectImpl()
方法详细信息

_get_delegate

public Delegate _get_delegate()
获得对特定于供应商的 Delegate 对象的引用，此 ObjectImpl 对象将对其调用的所有方法委托给该对象。

返回：
包含在此 ObjectImpl 实例中的 Delegate
抛出：
BAD_OPERATION - 如果尚未设置委托
另请参见：
_set_delegate(org.omg.CORBA.portable.Delegate)

_set_delegate

public void _set_delegate(Delegate delegate)
将此 ObjectImpl 实例的 Delegate 设置为给定的 Delegate 对象。对此 ObjectImpl 对象调用的所有方法将被委托到此 Delegate。

参数：
delegate - Delegate 实例，对此 ObjectImpl 对象调用的所有方法都将被委托到该实例；可以由第三方 ORB 实现
另请参见：
_get_delegate()

_ids

public abstract String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组

_duplicate

public Object _duplicate()
返回此 ObjectImpl 对象的一个副本。

指定者：
接口 Object 中的 _duplicate
返回：
作为此对象副本的 orb.omg.CORBA.Object 对象。

_release

public void _release()
释放与此 ObjectImpl 对象关联的资源。

指定者：
接口 Object 中的 _release

_is_a

public boolean _is_a(String repository_id)
检查给定存储库标识符标识的对象是否是 ObjectImpl 对象。

指定者：
接口 Object 中的 _is_a
参数：
repository_id - 带有要检查的存储库标识符的 String 对象
返回：
如果给定存储库 id 标识的对象是 ObjectImpl 的实例，则返回 true；否则返回 false

_is_equivalent

public boolean _is_equivalent(Object that)
检查给定的 ObjectImpl 对象是否等于此 ObjectImpl 对象。

指定者：
接口 Object 中的 _is_equivalent
参数：
that - 要与此 ObjectImpl 对象比较的 ObjectImpl 实例
返回：
如果给定对象等于此 ObjectImpl 对象，则返回 true；否则返回 false

_non_existent

public boolean _non_existent()
检查此 ObjectImpl 对象的 server 对象是否已经被销毁。

指定者：
接口 Object 中的 _non_existent
返回：
如果 ORB 确信 server 对象不存在，则返回 true；否则返回 false

_hash

public int _hash(int maximum)
获得充当此 ObjectImpl 对象内部 ORB 标识符的哈希码。

指定者：
接口 Object 中的 _hash
参数：
maximum - 一个 int，指示 ORB 返回的哈希码值上限
返回：
表示此 ObjectImpl 对象哈希码的 int

_request

public Request _request(String operation)
创建一个 Request 对象，使其包含可用于动态调用接口 (Dynamic Invocation Interface) 的给定方法。

指定者：
接口 Object 中的 _request
参数：
operation - 将由新 Request 对象调用的方法
返回：
使用给定方法初始化的新 Request 对象

_create_request

public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result)
创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。

指定者：
接口 Object 中的 _create_request
参数：
ctx - 请求的 Context
operation - 新 Request 对象将调用的方法
arg_list - 方法的参数；一个 NVList，其中每个参数都是 NamedValue 对象
result - 一个 NamedValue 对象，用于返回执行请求的方法后所得的结果
返回：
一个新的 Request 对象，使用给定的上下文、方法、参数列表，以及返回值的容器初始化。
另请参见：
Request, NVList, NamedValue

_create_request

public Request _create_request(Context ctx,
                               String operation,
                               NVList arg_list,
                               NamedValue result,
                               ExceptionList exceptions,
                               ContextList contexts)
创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。此 Request 对象用于动态调用接口。

指定者：
接口 Object 中的 _create_request
参数：
ctx - 含有上下文字符串的 Context 对象，所包含的字符串必须在随同请求一起被发送前进行解析
operation - 新 Request 对象将调用的方法
arg_list - 方法的参数；一个 NVList，其中每个参数都是 NamedValue 对象
result - 一个 NamedValue 对象，用来返回执行请求的方法所得的结果
exceptions - 给定方法抛出的异常所组成的列表
contexts - 在解析 ctx 中上下文时所需要的属性列表；contexts 中的字符串被用作 Context.get_values 方法的参数，该方法返回与给定属性关联的值
返回：
一个新的 Request 对象，使用给定的要解析上下文字符串、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表进行初始化
另请参见：
Request, NVList, NamedValue, ExceptionList, ContextList

_get_interface_def

public Object _get_interface_def()
获得此 ObjectImpl 对象的接口定义。

指定者：
接口 Object 中的 _get_interface_def
返回：
org.omg.CORBA.Object 实例，它是此 ObjectImpl 对象的接口定义

_orb

public ORB _orb()
返回对与此对象及其委托相关的 ORB 的引用。返回值是创建委托的 ORB 对象。

返回：
ORB 实例，它创建了包含在此 ObjectImpl 对象中的 Delegate 对象

_get_policy

public Policy _get_policy(int policy_type)
获得此 ObjectImpl 对象具有给定策略类型的 Policy 对象。

指定者：
接口 Object 中的 _get_policy
参数：
policy_type - 指示策略类型的 int
返回：
应用于此 ObjectImpl 对象并具有指定策略类型的 Policy 对象
另请参见：
PolicyOperations.policy_type()

_get_domain_managers

public DomainManager[] _get_domain_managers()
获得此 ObjectImpl 对象的域管理程序所组成的列表。

指定者：
接口 Object 中的 _get_domain_managers
返回：
一个数组，包含此 ObjectImpl 实例的 DomainManager 对象

_set_policy_override

public Object _set_policy_override(Policy[] policies,
                                   SetOverrideType set_add)
将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。

指定者：
接口 Object 中的 _set_policy_override
参数：
policies - 一个 Policy 对象数组，具有取代当前策略或被添加到当前策略的策略
set_add - 可能为 SetOverrideType.SET_OVERRIDE，指示给定策略将取代任何现存策略；也可能为 SetOverrideType.ADD_OVERRIDE，指示给定策略将被添加到任何现有策略
返回：
一个 Object，给定策略取代或被添加到该对象以前的策略

_is_local

public boolean _is_local()
检查此 ObjectImpl 对象是否是由本地 servant 实现的。如果是，则可以使用本地调用 API 的 ObjectImpl 对象。

返回：
如果此对象由本地 servant 实现，则返回 true；否则返回 false。

_servant_preinvoke

public ServantObject _servant_preinvoke(String operation,
                                        Class expectedType)
返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。如果此 ObjectImpl 对象是本地 stub，则在发送请求前它将调用 _servant_preinvoke 方法，以获取要使用的 ServantObject 实例。

如果返回 ServantObject 对象，则其 servant 字段已经被设置为所期望类型的对象（注意：该对象可以是也可以不是实际的 servant 实例）。本地 stub 可以将 servant 字段强制转换为所需类型，然后直接调用操作。ServantRequest 对象只对一次调用有效，不能用于多次调用。

参数：
operation - 一个包含要调用的方法名称的 String。此名称应该对应于将被编码入 GIOP 请求的方法名称。
expectedType - 一个 Class 对象，表示返回的 servant 的预期类型。此预期类型是与 stub 接口的操作类有关的 Class 对象。例如，接口 Foo 的 stub 将传递用于 FooOperations 接口的 Class 对象。
返回：
(1) 一个 ServantObject 对象，可能是也可能不是实际 servant 实例，或者返回 (2) null，如果 (a) servant 不是本地的或 (b)由于 POA ServantManager 发出 ForwardRequest 使 servant 不再是本地的
抛出：
BAD_PARAM - 如果 servant 不是预期类型

_servant_postinvoke

public void _servant_postinvoke(ServantObject servant)
本地 stub 在发起了对本地 servant（通过对 _servant_preinvoke 方法的调用得到）的一次操作后，再调用此方法。如果 _servant_preinvoke 方法返回非 null 值，则必须调用 _servant_postinvoke 方法，即使 servant 调用的方法抛出异常。因此，对 _servant_postinvoke 方法的调用应该置于 Java finally 子句中。

参数：
servant - _servant_preinvoke 方法返回的 ServantObject 实例

_request

public OutputStream _request(String operation,
                             boolean responseExpected)
返回一个 OutputStream 对象，该对象用于编组给定方法的参数。此方法由 stub 调用，必须指示是否希望响应，即调用是否是单向的。

参数：
operation - 给出方法名称的 String。
responseExpected - 一个 boolean 值，如果请求不是单向的（即希望获得响应），则该参数为 true
返回：
用来分派请求的 OutputStream 对象

_invoke

public InputStream _invoke(OutputStream output)
                    throws ApplicationException,
                           RemarshalException
调用某个操作并返回用来读取响应的 InputStream 对象。stub 提供以前调用 _request 方法所返回的 OutputStream 对象。以前调用时被指定为 _request 参数的方法就是此方法要调用的方法。

如果发生异常，则 _invoke 方法将抛出 ApplicationException 对象，该对象包含一个 InputStream，可从中解组用户异常状态。

参数：
output - 用来分派请求的 OutputStream 对象
返回：
一个 InputStream 对象，包含已调用方法的编组响应
抛出：
ApplicationException - 如果该调用遇到应用程序定义的异常
RemarshalException - 如果该调用导致重新编组错误
另请参见：
_request(java.lang.String)

_releaseReply

public void _releaseReply(InputStream input)
调用 _invoke 方法并且解组完成后，将给定的应答流释放回 ORB。对于 stub，调用此方法是可选的。

参数：
input - _invoke 方法或 ApplicationException.getInputStream 方法返回的 InputStream 对象；可以为 null，在这种情况下此方法不执行任何操作
另请参见：
_invoke(org.omg.CORBA.portable.OutputStream)

toString

public String toString()
返回表示此 ObjectImpl 对象的 String 对象。

覆盖：
类 Object 中的 toString
返回：
此对象的 String 表示形式

hashCode

public int hashCode()
返回此 ObjectImpl 对象的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希代码。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
比较此 ObjectImpl 对象与给定对象是否相等。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象进行比较的对象
返回：
如果两个对象相等，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OutputStream (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 OutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  org.omg.CORBA.portable.OutputStream
所有已实现的接口：
Closeable, Flushable
直接已知子类：
OutputStream
public abstract class OutputStream
extends OutputStream

OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。这些方法供 ORB 用来编组 IDL 类型以及将 IDL 插入 Any。这些 _array 形式的方法可以直接用于写入 IDL 类型的序列和数组。

从以下版本开始：
JDK1.2

构造方法摘要
OutputStream()
方法摘要
abstract InputStream | create_input_stream() 返回一个具有相同缓冲区的输入流。
ORB | orb() 返回创建此 OutputStream 的 ORB。
abstract void | write_any(Any value) 在此输出流上写入一个 Any。
abstract void | write_boolean_array(boolean[] value, int offset, int length) 在此输出流上写入一个 boolean 数组。
abstract void | write_boolean(boolean value) 将一个 boolean 值写入此流。
abstract void | write_char_array(char[] value, int offset, int length) 在此输出流上写入一个 char 数组。
abstract void | write_char(char value) 将一个 char 值写入此流。
void | write_Context(Context ctx, ContextList contexts) 在此流上写入一个 CORBA 上下文。
abstract void | write_double_array(double[] value, int offset, int length) 在此输入流上写入一个 double 数组。
abstract void | write_double(double value) 将一个 double 值写入此流。
void | write_fixed(BigDecimal value) 写入一个 BigDecimal 数。
abstract void | write_float_array(float[] value, int offset, int length) 在此输入流上写入一个 float 数组。
abstract void | write_float(float value) 将一个 float 值写入此流。
abstract void | write_long_array(int[] value, int offset, int length) 在此输出流上写入一个 CORBA long（即 Java int）数组。
abstract void | write_long(int value) 将一个 CORBA long（即 Java int）值写入此流。
abstract void | write_longlong_array(long[] value, int offset, int length) 在此输出流上写入一个 CORBA longlong（即 Java int）数组。
abstract void | write_longlong(long value) 将一个 CORBA longlong（即 Java long）值写入此流。
abstract void | write_Object(Object value) 在此输入流上写入一个 CORBA Object。
abstract void | write_octet_array(byte[] value, int offset, int length) 在此输出流上写入一个 CORBA 八位组 (byte) 数组。
abstract void | write_octet(byte value) 将一个 CORBA 八位组（即字节）写入此流。
void | write_Principal(Principal value) 已过时。 已由 CORBA 2.2 取代。
abstract void | write_short_array(short[] value, int offset, int length) 在此输出流上写入一个 short 数组。
abstract void | write_short(short value) 将一个 short 值写入此流。
abstract void | write_string(String value) 将一个 string 值写入此流。
abstract void | write_TypeCode(TypeCode value) 在此输出流上写入一个 TypeCode。
abstract void | write_ulong_array(int[] value, int offset, int length) 在此输出流上写入一个无符号 CORBA long（即 Java int）数组。
abstract void | write_ulong(int value) 将一个无符号 CORBA long（即 Java int）值写入此流。
abstract void | write_ulonglong_array(long[] value, int offset, int length) 在此输出流上写入一个无符号 CORBA longlong（即 Java int）数组。
abstract void | write_ulonglong(long value) 将一个无符号 CORBA longlong（即 Java long）值写入此流。
abstract void | write_ushort_array(short[] value, int offset, int length) 在此输出流上写入一个无符号 short 数组。
abstract void | write_ushort(short value) 将一个无符号 short 值写入此流。
abstract void | write_wchar_array(char[] value, int offset, int length) 在此输出流上写入一个 wide char 数组。
abstract void | write_wchar(char value) 将一个 wide char 值写入此流。
abstract void | write_wstring(String value) 将一个 wide string 值写入此流。
void | write(int b) 将一个 integer（数组长度）写入此流。
从类 java.io.OutputStream 继承的方法
close, flush, write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OutputStream

public OutputStream()
方法详细信息

create_input_stream

public abstract InputStream create_input_stream()
返回一个具有相同缓冲区的输入流。

返回：
具有相同缓冲区的输入流。

write_boolean

public abstract void write_boolean(boolean value)
将一个 boolean 值写入此流。

参数：
value - 要写入的值。

write_char

public abstract void write_char(char value)
将一个 char 值写入此流。

参数：
value - 要写入的值。

write_wchar

public abstract void write_wchar(char value)
将一个 wide char 值写入此流。

参数：
value - 要写入的值。

write_octet

public abstract void write_octet(byte value)
将一个 CORBA 八位组（即字节）写入此流。

参数：
value - 要写入的值。

write_short

public abstract void write_short(short value)
将一个 short 值写入此流。

参数：
value - 要写入的值。

write_ushort

public abstract void write_ushort(short value)
将一个无符号 short 值写入此流。

参数：
value - 要写入的值。

write_long

public abstract void write_long(int value)
将一个 CORBA long（即 Java int）值写入此流。

参数：
value - 要写入的值。

write_ulong

public abstract void write_ulong(int value)
将一个无符号 CORBA long（即 Java int）值写入此流。

参数：
value - 要写入的值。

write_longlong

public abstract void write_longlong(long value)
将一个 CORBA longlong（即 Java long）值写入此流。

参数：
value - 要写入的值。

write_ulonglong

public abstract void write_ulonglong(long value)
将一个无符号 CORBA longlong（即 Java long）值写入此流。

参数：
value - 要写入的值。

write_float

public abstract void write_float(float value)
将一个 float 值写入此流。

参数：
value - 要写入的值。

write_double

public abstract void write_double(double value)
将一个 double 值写入此流。

参数：
value - 要写入的值。

write_string

public abstract void write_string(String value)
将一个 string 值写入此流。

参数：
value - 要写入的值。

write_wstring

public abstract void write_wstring(String value)
将一个 wide string 值写入此流。

参数：
value - 要写入的值。

write_boolean_array

public abstract void write_boolean_array(boolean[] value,
                                         int offset,
                                         int length)
在此输出流上写入一个 boolean 数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_char_array

public abstract void write_char_array(char[] value,
                                      int offset,
                                      int length)
在此输出流上写入一个 char 数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_wchar_array

public abstract void write_wchar_array(char[] value,
                                       int offset,
                                       int length)
在此输出流上写入一个 wide char 数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_octet_array

public abstract void write_octet_array(byte[] value,
                                       int offset,
                                       int length)
在此输出流上写入一个 CORBA 八位组 (byte) 数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_short_array

public abstract void write_short_array(short[] value,
                                       int offset,
                                       int length)
在此输出流上写入一个 short 数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_ushort_array

public abstract void write_ushort_array(short[] value,
                                        int offset,
                                        int length)
在此输出流上写入一个无符号 short 数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_long_array

public abstract void write_long_array(int[] value,
                                      int offset,
                                      int length)
在此输出流上写入一个 CORBA long（即 Java int）数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_ulong_array

public abstract void write_ulong_array(int[] value,
                                       int offset,
                                       int length)
在此输出流上写入一个无符号 CORBA long（即 Java int）数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_longlong_array

public abstract void write_longlong_array(long[] value,
                                          int offset,
                                          int length)
在此输出流上写入一个 CORBA longlong（即 Java int）数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_ulonglong_array

public abstract void write_ulonglong_array(long[] value,
                                           int offset,
                                           int length)
在此输出流上写入一个无符号 CORBA longlong（即 Java int）数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_float_array

public abstract void write_float_array(float[] value,
                                       int offset,
                                       int length)
在此输入流上写入一个 float 数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_double_array

public abstract void write_double_array(double[] value,
                                        int offset,
                                        int length)
在此输入流上写入一个 double 数组。

参数：
value - 要写入的数组。
offset - 流中的偏移量。
length - 要写入的缓冲区长度。

write_Object

public abstract void write_Object(Object value)
在此输入流上写入一个 CORBA Object。

参数：
value - 要写入的值。

write_TypeCode

public abstract void write_TypeCode(TypeCode value)
在此输出流上写入一个 TypeCode。

参数：
value - 要写入的值。

write_any

public abstract void write_any(Any value)
在此输出流上写入一个 Any。

参数：
value - 要写入的值。

write_Principal

@Deprecated
public void write_Principal(Principal value)
已过时。 已由 CORBA 2.2 取代。

在此输出流上写入一个 Principle。

参数：
value - 要写入的值。

write

public void write(int b)
           throws IOException
将一个 integer（数组长度）写入此流。

指定者：
类 OutputStream 中的 write
参数：
b - 要写入的值。
抛出：
IOException - 如果存在输入/输出错误
另请参见：
portable 包中有关未实现特性的注释

write_fixed

public void write_fixed(BigDecimal value)
写入一个 BigDecimal 数。

参数：
value - 要写入的值 BidDecimal。

write_Context

public void write_Context(Context ctx,
                          ContextList contexts)
在此流上写入一个 CORBA 上下文。该上下文被编组为一个 string 序列。实际上只写入那些在 contexts 参数中指定的 Context 值。

参数：
ctx - CORBA 上下文
contexts - ContextList 对象，包含要写入的 context 列表
另请参见：
portable 包中有关未实现特性的注释

orb

public ORB orb()
返回创建此 OutputStream 的 ORB。

返回：
返回创建此 OutputStream 的 ORB
另请参见：
portable 包中有关未实现特性的注释
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemarshalException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 RemarshalException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.portable.RemarshalException
所有已实现的接口：
Serializable
public final class RemarshalException
extends Exception

此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。在这种情况下，重试前 ORB 必须重新编组请求。使用基于流模式的 Stub 应该捕获 RemarshalException，该异常可能从 ObjectImpl 的 _invoke() 方法抛出。一旦捕获到该异常，stub 应立即重新编组请求：调用 _request()，编组参数（如果有），然后调用 _invoke()。在 _invoke() 正常返回或引发 RemarshalException 以外的异常前，stub 应重复此过程。

构造方法摘要
RemarshalException()
构造一个 RemarshalException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RemarshalException

public RemarshalException()
构造一个 RemarshalException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResponseHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 ResponseHandler

public interface ResponseHandler

此接口由 ORB 在调用期间提供给 servant，允许 servant 稍后检索用来返回调用结果的 OutputStream。

方法摘要
OutputStream | createExceptionReply() 在方法调用期间由 servant 调用。
OutputStream | createReply() 在方法调用期间由 servant 调用。

方法详细信息

createReply

OutputStream createReply()
在方法调用期间由 servant 调用。如果没有发生任何异常，则 servant 应该调用此方法来创建应答编组缓冲区。

返回：
适于编组应答的 OutputStream。
另请参见：
portable 包中有关未实现特性的注释

createExceptionReply

OutputStream createExceptionReply()
在方法调用期间由 servant 调用。如果发生用户异常，则 servant 应该调用此方法来创建应答编组缓冲区。

返回：
适于编组异常 ID 和用户异常主体的 OutputStream。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantObject (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 ServantObject

java.lang.Object
    继承者  org.omg.CORBA.portable.ServantObject

public class ServantObject
extends Object

此类是本地 stub API 的一部分，其目的是为配置的客户端和服务器（即驻留在同一 Java VM 上的客户端和服务器）提供高性能的调用。ObjectImpl 和 Delegate 上的三个附加方法支持本地 stub API。ORB 可以为此类创建子类以返回其实现可能需要的附加请求状态。

另请参见：
ObjectImpl, Delegate

字段摘要
 Object servant
实际的 servant。
构造方法摘要
ServantObject()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

servant

public Object servant
实际的 servant。本地 stub 可以将此字段强制转换为所需类型，然后直接调用操作。注意，该对象可以是也可以不是实际的 servant 实例。

构造方法详细信息

ServantObject

public ServantObject()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Streamable (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 Streamable

所有已知子接口：
StreamableValue
所有已知实现类：
AlreadyBoundHolder, AnyHolder, AnySeqHolder, BindingHolder, BindingIteratorHolder, BindingListHolder, BindingTypeHolder, BooleanHolder, BooleanSeqHolder, ByteHolder, CannotProceedHolder, CharHolder, CharSeqHolder, CookieHolder, CurrentHolder, DoubleHolder, DoubleSeqHolder, FixedHolder, FloatHolder, FloatSeqHolder, IntHolder, InvalidAddressHolder, InvalidNameHolder, IORHolder, IORInterceptor_3_0Holder, LongHolder, LongLongSeqHolder, LongSeqHolder, MultipleComponentProfileHolder, NameComponentHolder, NameHolder, NamingContextExtHolder, NamingContextHolder, NotEmptyHolder, NotFoundHolder, NotFoundReasonHolder, ObjectHolder, ObjectReferenceFactoryHolder, ObjectReferenceTemplateHolder, ObjectReferenceTemplateSeqHolder, OctetSeqHolder, ParameterModeHolder, PolicyErrorHolder, PolicyHolder, PolicyListHolder, PrincipalHolder, ServiceContextHolder, ServiceContextListHolder, ServiceInformationHolder, ShortHolder, ShortSeqHolder, StringHolder, StringSeqHolder, TaggedComponentHolder, TaggedProfileHolder, TypeCodeHolder, ULongLongSeqHolder, ULongSeqHolder, UnknownUserExceptionHolder, UShortSeqHolder, ValueBaseHolder, WCharSeqHolder, WrongTransactionHolder, WStringSeqHolder
public interface Streamable

所有复杂 IDL 类型的 Holder 类的基类。ORB 将所有生成的 Holder 视为 Streamable 来调用编组和解组的各种方法。

从以下版本开始：
JDK1.2

方法摘要
void | _read(InputStream istream) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream ostream) 将 Holder 中 value 字段的值编组到 ostream。

方法详细信息

_read

void _read(InputStream istream)
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

参数：
istream - 表示导线中 CDR 数据的 InputStream。

_write

void _write(OutputStream ostream)
将 Holder 中 value 字段的值编组到 ostream。

参数：
ostream - CDR OutputStream

_type

TypeCode _type()
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StreamableValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 StreamableValue

所有超级接口：
IDLEntity, Serializable, Streamable, ValueBase
public interface StreamableValue
extends Streamable, ValueBase

为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。 所有的值类型通过实现 StreamableValue 或 CustomValue 接口直接或间接实现 ValueBase。

方法摘要
从接口 org.omg.CORBA.portable.Streamable 继承的方法
_read, _type, _write
从接口 org.omg.CORBA.portable.ValueBase 继承的方法
_truncatable_ids

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
类 UnknownException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.omg.CORBA.SystemException
                    继承者  org.omg.CORBA.portable.UnknownException
所有已实现的接口：
Serializable
public class UnknownException
extends SystemException

org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。它为具有 UnknownExceptionInfo 服务上下文的 UNKNOWN 系统异常提供其 Java 表示形式。如果抛出 CORBA 系统异常 org.omg.CORBA.portable.UnknownException，则 stub 将执行以下操作之一：(1) 将它转换为 org.omg.CORBA.UNKNOWN。(2) 将它转换为 UnknownException 包含的嵌套异常。(3) 将它直接传递给用户。

字段摘要
 Throwable originalEx
一个 throwable 对象，包装在 CORBA UnknownException 中的原始异常。
从类 org.omg.CORBA.SystemException 继承的字段
completed, minor
构造方法摘要
UnknownException(Throwable ex)
构造一个 UnknownException 对象。
方法摘要
从类 org.omg.CORBA.SystemException 继承的方法
toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

originalEx

public Throwable originalEx
一个 throwable 对象，包装在 CORBA UnknownException 中的原始异常。

构造方法详细信息

UnknownException

public UnknownException(Throwable ex)
构造一个 UnknownException 对象。

参数：
ex - 包装在此异常中的 Throwable 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueBase (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 ValueBase

所有超级接口：
IDLEntity, Serializable
所有已知子接口：
CustomValue, DataInputStream, DataOutputStream, ObjectReferenceFactory, ObjectReferenceTemplate, StreamableValue
public interface ValueBase
extends IDLEntity

所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。换句话说，valuetype 对象的 Java 映射实现 ValueBase 接口。为 valuetype 生成的 Java 类应为相应的值类型提供一个 ValueBase 接口的实现。对于可以作为流的值类型（即非自定义的），生成的 Java 类也应该提供 org.omg.CORBA.portable.Streamable 接口的实现。（CORBA::ValueBase 映射到 java.io.Serializable。）

方法摘要
 String[] _truncatable_ids()
提供可截断的存储库 id。

方法详细信息

_truncatable_ids

String[] _truncatable_ids()
提供可截断的存储库 id。

返回：
一个 String 数组，即可截断存储库 id 列表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 ValueFactory

public interface ValueFactory

ValueFactory 接口是 IDL 类型 CORBA::ValueFactory 的本地映射。read_value() 方法由 ORB 运行时在解组值类型的过程中调用。用户应该实现此方法，作为实现特定于类型的值工厂的一部分。在该实现中，用户应该调用 is.read_value(java.io.Serializable)，并使用一个未初始化的 valuetype 来解组。流返回传入的值，其中所有的数据均未解组。

另请参见：
ORB

方法摘要
 Serializable read_value(InputStream is)
ORB 运行时在解组值类型的过程中调用此方法。

方法详细信息

read_value

Serializable read_value(InputStream is)
ORB 运行时在解组值类型的过程中调用此方法。用户应该实现此方法，作为实现特定于类型的值工厂的一部分。

参数：
is - 一个 InputStream 对象，从中读取值。
返回：
一个 Serializable 对象，从 "is" 输入流中读取的值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueInputStream (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 ValueInputStream

public interface ValueInputStream

Java 到 IDL ptc 02-01-12 1.5.1.4 ValueInputStream 用来实现第 2 版的 RMI-IIOP 流格式。

方法摘要
void | end_value() end_value 方法读取嵌套自定义 valuetype 的结束标记（在跳过结束标记之前的所有数据后）并将 valuetype 嵌套层次加 1。
void | start_value() start_value 方法读取嵌套自定义 valuetype 的 valuetype 头并将该 valuetype 的嵌套层次加 1。

方法详细信息

start_value

void start_value()
start_value 方法读取嵌套自定义 valuetype 的 valuetype 头并将该 valuetype 的嵌套层次加 1。

end_value

void end_value()
end_value 方法读取嵌套自定义 valuetype 的结束标记（在跳过结束标记之前的所有数据后）并将 valuetype 嵌套层次加 1。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueOutputStream (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA.portable
接口 ValueOutputStream

public interface ValueOutputStream

Java 到 IDL ptc 02-01-12 1.5.1.3 ValueOutputStream 用来实现第 2 版的 RMI-IIOP 流格式。

方法摘要
void | end_value() end_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的结束标记，并将 valuetype 嵌套层次减 1。
void | start_value(String rep_id) start_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的 valuetype 头（使用 null 代码基和指定的存储库 ID），并将 valuetype 嵌套层次加 1。

方法详细信息

start_value

void start_value(String rep_id)
start_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的 valuetype 头（使用 null 代码基和指定的存储库 ID），并将 valuetype 嵌套层次加 1。

end_value

void end_value()
end_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的结束标记，并将 valuetype 嵌套层次减 1。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CORBA.portable (Java Platform SE 6)

 org.omg.CORBA.portable
接口
BoxedValueHelper
CustomValue
IDLEntity
InvokeHandler
ResponseHandler
Streamable
StreamableValue
ValueBase
ValueFactory
ValueInputStream
ValueOutputStream
类
Delegate
InputStream
ObjectImpl
OutputStream
ServantObject
异常
ApplicationException
IndirectionException
RemarshalException
UnknownException


org.omg.CORBA.portable (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CORBA.portable

提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

请参见：
描述

接口摘要
BoxedValueHelper |
CustomValue | 通过自定义值类型实现的 ValueBase 扩展。
IDLEntity | 一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InvokeHandler | 此接口为入呼叫 (incoming call) 提供调度机制。
ResponseHandler | 此接口由 ORB 在调用期间提供给 servant，允许 servant 稍后检索用来返回调用结果的 OutputStream。
Streamable | 所有复杂 IDL 类型的 Holder 类的基类。
StreamableValue | 为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。
ValueBase | 所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。
ValueFactory | ValueFactory 接口是 IDL 类型 CORBA::ValueFactory 的本地映射。
ValueInputStream | Java 到 IDL ptc 02-01-12 1.5.1.4 ValueInputStream 用来实现第 2 版的 RMI-IIOP 流格式。
ValueOutputStream | Java 到 IDL ptc 02-01-12 1.5.1.3 ValueOutputStream 用来实现第 2 版的 RMI-IIOP 流格式。

类摘要
Delegate | 为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。
InputStream | InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
ObjectImpl | 所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
OutputStream | OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
ServantObject | 此类是本地 stub API 的一部分，其目的是为配置的客户端和服务器（即驻留在同一 Java VM 上的客户端和服务器）提供高性能的调用。

异常摘要
ApplicationException | 此类用来报告 ORB 和 stub 之间的应用程序级异常。
IndirectionException | Indirection 异常是一个特定于 Java 的系统异常。
RemarshalException | 此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
UnknownException | org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

软件包 org.omg.CORBA.portable 的描述

提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。Stub 和其他代码（通过 IDL 或用 Java 编程语言编写的接口生成）可以调入这些 ORB API。

CORBA Features Throwing NO_IMPLEMENT() 异常

一些方法在默认情况下抛出 NO_IMPLEMENT() 异常，但是 ORB 供应商可以重写这些方法以提供实在的实现。包含在 Java[tm] Platform，Standard Edition 6 这一版本中的 ORB 包括以下方法的实现。

org.omg.CORBA.portable 包中未实现特性的列表

org.omg.CORBA.portable 包中未实现的接口

  • InvokeHandler
  • ResponseHandler

org.omg.CORBA.portable 包中未实现的方法

  • InputStream
    • public int read()
    • public.math.BigDecimal read_fixed()
    • public org.omg.CORBA.Context read_Context()
    • public org.omg.CORBA.Object read_Object(java.lang.Class clz)
    • public org.omg.CORBA.ORB orb()
  • OutputStream
    • public org.omg.CORBA.ORB orb()
    • public void write_Context(org.omg.CORBA.Context ctx, org.omg.CORBA.ContextList contexts)
    • public void write_fixed(java.math.BigDecimal value)
    • public void write(int b)
  • Delegate
    • public void releaseReply(org.omg.CORBA.Object self, InputStream input)
    • public InputStream invoke(org.omg.CORBA.Object self, OutputStream output)
    • public OutputStream request(org.omg.CORBA.Object self, String operation, boolean responseExpected)
    • public org.omg.CORBA.Object set_policy_override(org.omg.CORBA.Object self, org.omg.CORBA.Policy[] policies, org.omg.CORBA.SetOverrideType set_add)
    • public org.omg.CORBA.DomainManager[] get_domain_managers( org.omg.CORBA.Object self)
    • public org.omg.CORBA.Policy get_policy(org.omg.CORBA.Object self, int policy_type)

从以下版本开始：
JDK1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.CORBA.portable 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA.portable 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
    • java.io.InputStream (implements java.io.Closeable)
      • org.omg.CORBA.portable.InputStream
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.omg.CORBA.portable.OutputStream
    • org.omg.CORBA.portable.ServantObject
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.portable.ApplicationException
        • org.omg.CORBA.portable.RemarshalException
        • java.lang.RuntimeException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.portable.IndirectionException
            • org.omg.CORBA.portable.UnknownException

接口分层结构

  • org.omg.CORBA.portable.BoxedValueHelper
  • org.omg.CORBA.CustomMarshal
    • org.omg.CORBA.portable.CustomValue (并 extends org.omg.CORBA.portable.ValueBase)
  • org.omg.CORBA.portable.InvokeHandler
  • org.omg.CORBA.portable.ResponseHandler
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.portable.CustomValue (并 extends org.omg.CORBA.CustomMarshal)
        • org.omg.CORBA.portable.StreamableValue (并 extends org.omg.CORBA.portable.Streamable)
  • org.omg.CORBA.portable.Streamable
    • org.omg.CORBA.portable.StreamableValue (并 extends org.omg.CORBA.portable.ValueBase)
  • org.omg.CORBA.portable.ValueFactory
  • org.omg.CORBA.portable.ValueInputStream
  • org.omg.CORBA.portable.ValueOutputStream
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CORBA.portable 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA.portable
的使用

使用 org.omg.CORBA.portable 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。
org.omg.SendingContext | 为值类型的编组提供支持。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 使用的 org.omg.CORBA.portable 中的类
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
InvokeHandler
此接口为入呼叫 (incoming call) 提供调度机制。
ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.CORBA 使用的 org.omg.CORBA.portable 中的类
ApplicationException
此类用来报告 ORB 和 stub 之间的应用程序级异常。
BoxedValueHelper
Delegate
为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
RemarshalException
此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
ServantObject
此类是本地 stub API 的一部分，其目的是为配置的客户端和服务器（即驻留在同一 Java VM 上的客户端和服务器）提供高性能的调用。
Streamable
所有复杂 IDL 类型的 Holder 类的基类。
ValueBase
所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。

org.omg.CORBA.DynAnyPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。

org.omg.CORBA.ORBPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。

org.omg.CORBA.TypeCodePackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。

org.omg.CORBA.portable 使用的 org.omg.CORBA.portable 中的类
ApplicationException
此类用来报告 ORB 和 stub 之间的应用程序级异常。
Delegate
为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
RemarshalException
此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
ResponseHandler
此接口由 ORB 在调用期间提供给 servant，允许 servant 稍后检索用来返回调用结果的 OutputStream。
ServantObject
此类是本地 stub API 的一部分，其目的是为配置的客户端和服务器（即驻留在同一 Java VM 上的客户端和服务器）提供高性能的调用。
Streamable
所有复杂 IDL 类型的 Holder 类的基类。
ValueBase
所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。

org.omg.CORBA_2_3 使用的 org.omg.CORBA.portable 中的类
ValueFactory
ValueFactory 接口是 IDL 类型 CORBA::ValueFactory 的本地映射。

org.omg.CORBA_2_3.portable 使用的 org.omg.CORBA.portable 中的类
BoxedValueHelper
Delegate
为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.CosNaming 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
InvokeHandler
此接口为入呼叫 (incoming call) 提供调度机制。
ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
ResponseHandler
此接口由 ORB 在调用期间提供给 servant，允许 servant 稍后检索用来返回调用结果的 OutputStream。
Streamable
所有复杂 IDL 类型的 Holder 类的基类。

org.omg.CosNaming.NamingContextExtPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
Streamable
所有复杂 IDL 类型的 Holder 类的基类。

org.omg.CosNaming.NamingContextPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
Streamable
所有复杂 IDL 类型的 Holder 类的基类。

org.omg.Dynamic 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。

org.omg.DynamicAny 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.DynamicAny.DynAnyFactoryPackage 使用的 org.omg.CORBA.portable 中的类
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.DynamicAny.DynAnyPackage 使用的 org.omg.CORBA.portable 中的类
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.IOP 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
Streamable
所有复杂 IDL 类型的 Holder 类的基类。

org.omg.IOP.CodecFactoryPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.IOP.CodecPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.Messaging 使用的 org.omg.CORBA.portable 中的类
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.PortableInterceptor 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
Streamable
所有复杂 IDL 类型的 Holder 类的基类。
ValueBase
所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。

org.omg.PortableInterceptor.ORBInitInfoPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.PortableServer 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
InvokeHandler
此接口为入呼叫 (incoming call) 提供调度机制。
ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
ResponseHandler
此接口由 ORB 在调用期间提供给 servant，允许 servant 稍后检索用来返回调用结果的 OutputStream。

org.omg.PortableServer.CurrentPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.PortableServer.POAManagerPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.PortableServer.POAPackage 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.omg.PortableServer.ServantLocatorPackage 使用的 org.omg.CORBA.portable 中的类
InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
Streamable
所有复杂 IDL 类型的 Holder 类的基类。

org.omg.SendingContext 使用的 org.omg.CORBA.portable 中的类
IDLEntity
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。

org.omg.stub.java.rmi 使用的 org.omg.CORBA.portable 中的类
ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.ApplicationException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.ApplicationException
的使用

使用 ApplicationException 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 ApplicationException 的使用

抛出 ApplicationException 的 org.omg.CORBA 中的方法
 InputStream LocalObject._invoke(OutputStream output)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

org.omg.CORBA.portable 中 ApplicationException 的使用

抛出 ApplicationException 的 org.omg.CORBA.portable 中的方法
InputStream | ObjectImpl._invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
InputStream | Delegate.invoke(Object self, OutputStream output) 由 stub 调用，以调用一个操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.BoxedValueHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.BoxedValueHelper
的使用

使用 BoxedValueHelper 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。

org.omg.CORBA 中 BoxedValueHelper 的使用

实现 BoxedValueHelper 的 org.omg.CORBA 中的类
class | StringValueHelper StringValue 的 Helper。
class | WStringValueHelper org/omg/CORBA/WStringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范： 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07) ptc/00-01-08 中定义的 IDL/Java 语言映射

org.omg.CORBA_2_3.portable 中 BoxedValueHelper 的使用

参数类型为 BoxedValueHelper 的 org.omg.CORBA_2_3.portable 中的方法
Serializable | InputStream.read_value(BoxedValueHelper factory) 从输入流解组值类型。
void | OutputStream.write_value(Serializable value, BoxedValueHelper factory) 将值类型编组到输出流中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.CustomValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.CustomValue
的使用

没有 org.omg.CORBA.portable.CustomValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.Delegate 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.Delegate
的使用

使用 Delegate 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 Delegate 的使用

参数类型为 Delegate 的 org.omg.CORBA 中的构造方法
_IDLTypeStub(Delegate delegate)
构造一个 _IDLTypeStub 对象，并使用给定 Delegate 对象初始化。
_PolicyStub(Delegate delegate)
构造一个 _PolicyStub 对象，并使用给定 Delegate 对象初始化。

org.omg.CORBA_2_3.portable 中 Delegate 的使用

org.omg.CORBA_2_3.portable 中 Delegate 的子类
 class Delegate
Delegate 类提供 CORBA 对象特定于 ORB 供应商的实现。

org.omg.CORBA.portable 中 Delegate 的使用

返回 Delegate 的 org.omg.CORBA.portable 中的方法
 Delegate ObjectImpl._get_delegate()
获得对特定于供应商的 Delegate 对象的引用，此 ObjectImpl 对象将对其调用的所有方法委托给该对象。

参数类型为 Delegate 的 org.omg.CORBA.portable 中的方法
 void ObjectImpl._set_delegate(Delegate delegate)
将此 ObjectImpl 实例的 Delegate 设置为给定的 Delegate 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.IDLEntity 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.IDLEntity
的使用

使用 IDLEntity 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.SendingContext | 为值类型的编组提供支持。

org.omg.CORBA 中 IDLEntity 的使用

org.omg.CORBA 中 IDLEntity 的子接口
interface | Current 从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
interface | DataInputStream 定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
interface | DataOutputStream 定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。
interface | DomainManager 提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
interface | IDLType 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
interface | IRObject IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
interface | Policy 派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。

实现 IDLEntity 的 org.omg.CORBA 中的类
class | _IDLTypeStub IDLType 的 Stub。
class | _PolicyStub Policy 的 Stub。
class | Any 充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | CompletionStatus 指示某一方法抛出 SystemException 时是否已结束运行的对象。
class | DefinitionKind 该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。
class | NameValuePair 将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。
class | ParameterMode Parameter 参数模式的枚举。
class | PolicyError 发生策略错误时抛出的用户异常。
class | ServiceDetail 表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。
class | ServiceInformation CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。
class | SetOverrideType 标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
class | StructMember 描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。
class | TypeCode 用于有关特定 CORBA 数据类型的信息的容器。
class | UnionMember 接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | UserException CORBA IDL 定义的用户异常的根类。
class | ValueMember 接口存储库 (Interface Repository) 中关于 value 对象成员的描述。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

org.omg.CORBA.DynAnyPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CORBA.DynAnyPackage 中的类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CORBA.ORBPackage 中的类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 IDLEntity 的使用

org.omg.CORBA.portable 中 IDLEntity 的子接口
interface | CustomValue 通过自定义值类型实现的 ValueBase 扩展。
interface | StreamableValue 为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。
interface | ValueBase 所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。

org.omg.CORBA.TypeCodePackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CORBA.TypeCodePackage 中的类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming 中 IDLEntity 的使用

org.omg.CosNaming 中 IDLEntity 的子接口
interface | BindingIterator BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
interface | NamingContext 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
interface | NamingContextExt NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 IDLEntity 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
class | Binding org/omg/CosNaming/Binding.java。
class | BindingType 指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
class | NameComponent org/omg/CosNaming/NameComponent.java。

org.omg.CosNaming.NamingContextExtPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CosNaming.NamingContextExtPackage 中的类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.CosNaming.NamingContextPackage 中的类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。
class | NotFoundReason 指示未能解析的原因。

org.omg.Dynamic 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.Dynamic 中的类
 class Parameter
org/omg/Dynamic/Parameter.java。

org.omg.DynamicAny 中 IDLEntity 的使用

org.omg.DynamicAny 中 IDLEntity 的子接口
interface | DynAny 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
interface | DynAnyFactory DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
interface | DynArray DynArray 对象支持对 IDL 数组的操作。
interface | DynEnum DynEnum 对象支持对 IDL 枚举值的操作。
interface | DynFixed DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
interface | DynSequence DynSequence 对象支持对 IDL 序列的操作。
interface | DynStruct DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
interface | DynUnion DynUnion 对象支持对 IDL 联合 (union) 的操作。
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

实现 IDLEntity 的 org.omg.DynamicAny 中的类
class | _DynAnyFactoryStub DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。
class | NameDynAnyPair org/omg/DynamicAny/NameDynAnyPair.java。

org.omg.IOP 中 IDLEntity 的使用

org.omg.IOP 中 IDLEntity 的子接口
interface | Codec IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
interface | CodecFactory Codec 可从 CodecFactory 中获得。

实现 IDLEntity 的 org.omg.IOP 中的类
class | Encoding org/omg/IOP/Encoding.java。
class | IOR org/omg/IOP/IOR.java。
class | ServiceContext org/omg/IOP/ServiceContext.java。
class | TaggedComponent org/omg/IOP/TaggedComponent.java。
class | TaggedProfile org/omg/IOP/TaggedProfile.java。

org.omg.IOP.CodecFactoryPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.IOP.CodecFactoryPackage 中的类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.IOP.CodecPackage 中的类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 IDLEntity 的使用

org.omg.PortableInterceptor 中 IDLEntity 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ClientRequestInterceptor 客户端 interceptor。
interface | Interceptor 所有 Portable Interceptor 实现 Interceptor。
interface | IORInfo 提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | ObjectReferenceFactory 对象引用工厂。
interface | ObjectReferenceTemplate 对象引用模板。
interface | ORBInitializer 便于注册 interceptor 和初始化 ORB。
interface | ORBInitInfo 传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
interface | PolicyFactory 使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
interface | RequestInfo Interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。

实现 IDLEntity 的 org.omg.PortableInterceptor 中的类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 IDLEntity 的使用

org.omg.PortableServer 中 IDLEntity 的子接口
interface | AdapterActivator 一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | POA POA 对象管理对象集合的实现。
interface | POAManager 每个 POA 对象都有一个关联的 POAManager 对象。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantManager servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

实现 IDLEntity 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
class | ForwardRequest org/omg/PortableServer/ForwardRequest.java。
class | IdAssignmentPolicyValue IdAssignmentPolicyValue 可以具有以下值。
class | IdUniquenessPolicyValue IdUniquenessPolicyValue 可以具有以下值。
class | ImplicitActivationPolicyValue ImplicitActivationPolicyValue 具有以下语义。
class | LifespanPolicyValue LifespanPolicyValue 可以具有以下值。
class | RequestProcessingPolicyValue RequestProcessingPolicyValue 可以具有以下值。
class | ServantRetentionPolicyValue ServantRetentionPolicyValue 可以具有以下值。
class | ThreadPolicyValue ThreadPolicyValue 可以具有以下值。

org.omg.PortableServer.CurrentPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.PortableServer.CurrentPackage 中的类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.PortableServer.POAManagerPackage 中的类
class | AdapterInactive org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。
class | State 指定 POAManager 的状态。

org.omg.PortableServer.POAPackage 中 IDLEntity 的使用

实现 IDLEntity 的 org.omg.PortableServer.POAPackage 中的类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.omg.SendingContext 中 IDLEntity 的使用

org.omg.SendingContext 中 IDLEntity 的子接口
 interface RunTime
定义表示请求的发送上下文的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.IndirectionException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.IndirectionException
的使用

没有 org.omg.CORBA.portable.IndirectionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.InputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.InputStream
的使用

使用 InputStream 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。

javax.rmi.CORBA 中 InputStream 的使用

参数类型为 InputStream 的 javax.rmi.CORBA 中的方法
static Object Util.readAny(InputStream in)
将 java.lang.Object 作为 CORBA any 读取。
 Object UtilDelegate.readAny(InputStream in)
Util.readAny(org.omg.CORBA.portable.InputStream) 的委托调用。
 Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
使用 Java 语义从流中读取一个值。

org.omg.CORBA 中 InputStream 的使用

返回 InputStream 的 org.omg.CORBA 中的方法
InputStream | LocalObject._invoke(OutputStream output) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
abstract InputStream | Any.create_input_stream() 创建一个输入流，可以从中解组此 Any 对象的值。

参数类型为 InputStream 的 org.omg.CORBA 中的方法
void | AnyHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
void | AnySeqHolder._read(InputStream i)
void | BooleanHolder._read(InputStream input) 从 input 中读取已解组的数据，并将它们分配给此 BooleanHolder 对象的 value 字段。
void | BooleanSeqHolder._read(InputStream i)
void | ByteHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ByteHolder 对象中的值。
void | CharHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 CharHolder 对象中的值。
void | CharSeqHolder._read(InputStream i)
void | CurrentHolder._read(InputStream i)
void | DoubleHolder._read(InputStream input) 从输入流读取一个 double 值，并将其存储在值成员中。
void | DoubleSeqHolder._read(InputStream i)
void | FixedHolder._read(InputStream input) 从输入流读取定点值，并将其存储在值成员中。
void | FloatHolder._read(InputStream input) 从输入流读取一个 float 值，并使用该 float 值初始化值成员。
void | FloatSeqHolder._read(InputStream i)
void | IntHolder._read(InputStream input) 从 input 中读取已解组数据，并将其分配给此 IntHolder 对象的 value 字段。
void | LongHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
void | LongLongSeqHolder._read(InputStream i)
void | LongSeqHolder._read(InputStream i)
void | ObjectHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ObjectHolder 对象中的值。
void | OctetSeqHolder._read(InputStream i)
void | ParameterModeHolder._read(InputStream i)
void | PolicyErrorHolder._read(InputStream i)
void | PolicyHolder._read(InputStream i)
void | PolicyListHolder._read(InputStream i)
void | PrincipalHolder._read(InputStream input) 已过时。
void | ServiceInformationHolder._read(InputStream in) 从输入流 in 中读取已解组数据，并将它赋予此 ServiceInformationHolder 对象的 value 字段。
void | ShortHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 ShortHolder 对象中的值。
void | ShortSeqHolder._read(InputStream i)
void | StringHolder._read(InputStream input) 从 input 中读取已解组的数据，并将它赋予此 StringHolder 对象的 value 字段。
void | StringSeqHolder._read(InputStream i)
void | TypeCodeHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化此 TypeCodeHolder 对象中的值。
void | ULongLongSeqHolder._read(InputStream i)
void | ULongSeqHolder._read(InputStream i)
void | UShortSeqHolder._read(InputStream i)
void | UnknownUserExceptionHolder._read(InputStream i)
void | ValueBaseHolder._read(InputStream input) 从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
void | WCharSeqHolder._read(InputStream i)
void | WStringSeqHolder._read(InputStream i)
void | WrongTransactionHolder._read(InputStream i)
void | LocalObject._releaseReply(InputStream input) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Serializable | StringValueHelper.read_value(InputStream istream)
Serializable | WStringValueHelper.read_value(InputStream istream)
abstract void | Any.read_value(InputStream is, TypeCode t) 使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。
static Any[] | AnySeqHelper.read(InputStream istream)
static boolean[] | BooleanSeqHelper.read(InputStream istream)
static char[] | CharSeqHelper.read(InputStream istream)
static CompletionStatus | CompletionStatusHelper.read(InputStream istream)
static Current | CurrentHelper.read(InputStream istream)
static DefinitionKind | DefinitionKindHelper.read(InputStream istream)
static double[] | DoubleSeqHelper.read(InputStream istream)
static String | FieldNameHelper.read(InputStream istream)
static float[] | FloatSeqHelper.read(InputStream istream)
static IDLType | IDLTypeHelper.read(InputStream istream)
static String | IdentifierHelper.read(InputStream istream)
static long[] | LongLongSeqHelper.read(InputStream istream)
static int[] | LongSeqHelper.read(InputStream istream)
static NameValuePair | NameValuePairHelper.read(InputStream istream)
static Object | ObjectHelper.read(InputStream istream)
static byte[] | OctetSeqHelper.read(InputStream istream)
static ParameterMode | ParameterModeHelper.read(InputStream istream)
static short | PolicyErrorCodeHelper.read(InputStream istream)
static PolicyError | PolicyErrorHelper.read(InputStream istream)
static Policy | PolicyHelper.read(InputStream istream)
static Policy[] | PolicyListHelper.read(InputStream istream)
static int | PolicyTypeHelper.read(InputStream istream)
static String | RepositoryIdHelper.read(InputStream istream)
static ServiceDetail | ServiceDetailHelper.read(InputStream in)
static ServiceInformation | ServiceInformationHelper.read(InputStream in)
static SetOverrideType | SetOverrideTypeHelper.read(InputStream istream)
static short[] | ShortSeqHelper.read(InputStream istream)
static String[] | StringSeqHelper.read(InputStream istream)
static String | StringValueHelper.read(InputStream istream)
static StructMember | StructMemberHelper.read(InputStream istream)
static long[] | ULongLongSeqHelper.read(InputStream istream)
static int[] | ULongSeqHelper.read(InputStream istream)
static short[] | UShortSeqHelper.read(InputStream istream)
static UnionMember | UnionMemberHelper.read(InputStream istream)
static UnknownUserException | UnknownUserExceptionHelper.read(InputStream istream)
static Serializable | ValueBaseHelper.read(InputStream istream)
static ValueMember | ValueMemberHelper.read(InputStream istream)
static String | VersionSpecHelper.read(InputStream istream)
static short | VisibilityHelper.read(InputStream istream)
static char[] | WCharSeqHelper.read(InputStream istream)
static String[] | WStringSeqHelper.read(InputStream istream)
static String | WStringValueHelper.read(InputStream istream)
static WrongTransaction | WrongTransactionHelper.read(InputStream istream)

org.omg.CORBA_2_3.portable 中 InputStream 的使用

org.omg.CORBA_2_3.portable 中 InputStream 的子类
 class InputStream
InputStream 提供从流读取所有映射的 IDL 类型的接口。

org.omg.CORBA.portable 中 InputStream 的使用

返回 InputStream 的 org.omg.CORBA.portable 中的方法
InputStream | ObjectImpl._invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
abstract InputStream | OutputStream.create_input_stream() 返回一个具有相同缓冲区的输入流。
InputStream | ApplicationException.getInputStream() 返回可从中读取异常数据作为其参数的输入流。
InputStream | Delegate.invoke(Object self, OutputStream output) 由 stub 调用，以调用一个操作。

参数类型为 InputStream 的 org.omg.CORBA.portable 中的方法
OutputStream | InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler) 由 ORB 调用来调度对 servant 的请求。
void | Streamable._read(InputStream istream) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
void | ObjectImpl._releaseReply(InputStream input) 调用 _invoke 方法并且解组完成后，将给定的应答流释放回 ORB。
Serializable | BoxedValueHelper.read_value(InputStream is)
void | Delegate.releaseReply(Object self, InputStream input) releaseReply 可以由 stub 以可选方式调用，以在解组完成时将应答流释放回 ORB。

参数类型为 InputStream 的 org.omg.CORBA.portable 中的构造方法
ApplicationException(String id, InputStream ins)
根据异常的 CORBA 存储库 ID 和一个输入流（可从中读取异常数据作为其参数）构造 ApplicationException。

org.omg.CosNaming 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.CosNaming 中的方法
OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
void | BindingHolder._read(InputStream i)
void | BindingIteratorHolder._read(InputStream i)
void | BindingListHolder._read(InputStream i)
void | BindingTypeHolder._read(InputStream i)
void | NameComponentHolder._read(InputStream i)
void | NameHolder._read(InputStream i)
void | NamingContextExtHolder._read(InputStream i)
void | NamingContextHolder._read(InputStream i)
static Binding | BindingHelper.read(InputStream istream)
static BindingIterator | BindingIteratorHelper.read(InputStream istream)
static Binding[] | BindingListHelper.read(InputStream istream)
static BindingType | BindingTypeHelper.read(InputStream istream)
static String | IstringHelper.read(InputStream istream)
static NameComponent | NameComponentHelper.read(InputStream istream)
static NameComponent[] | NameHelper.read(InputStream istream)
static NamingContextExt | NamingContextExtHelper.read(InputStream istream)
static NamingContext | NamingContextHelper.read(InputStream istream)

org.omg.CosNaming.NamingContextExtPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
void | InvalidAddressHolder._read(InputStream i)
static String | AddressHelper.read(InputStream istream)
static InvalidAddress | InvalidAddressHelper.read(InputStream istream)
static String | StringNameHelper.read(InputStream istream)
static String | URLStringHelper.read(InputStream istream)

org.omg.CosNaming.NamingContextPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.CosNaming.NamingContextPackage 中的方法
void | AlreadyBoundHolder._read(InputStream i)
void | CannotProceedHolder._read(InputStream i)
void | InvalidNameHolder._read(InputStream i)
void | NotEmptyHolder._read(InputStream i)
void | NotFoundHolder._read(InputStream i)
void | NotFoundReasonHolder._read(InputStream i)
static AlreadyBound | AlreadyBoundHelper.read(InputStream istream)
static CannotProceed | CannotProceedHelper.read(InputStream istream)
static InvalidName | InvalidNameHelper.read(InputStream istream)
static NotEmpty | NotEmptyHelper.read(InputStream istream)
static NotFound | NotFoundHelper.read(InputStream istream)
static NotFoundReason | NotFoundReasonHelper.read(InputStream istream)

org.omg.DynamicAny 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.DynamicAny 中的方法
static Any[] | AnySeqHelper.read(InputStream istream)
static DynAnyFactory | DynAnyFactoryHelper.read(InputStream istream)
static DynAny | DynAnyHelper.read(InputStream istream)
static DynAny[] | DynAnySeqHelper.read(InputStream istream)
static DynArray | DynArrayHelper.read(InputStream istream)
static DynEnum | DynEnumHelper.read(InputStream istream)
static DynFixed | DynFixedHelper.read(InputStream istream)
static DynSequence | DynSequenceHelper.read(InputStream istream)
static DynStruct | DynStructHelper.read(InputStream istream)
static DynUnion | DynUnionHelper.read(InputStream istream)
static DynValue | DynValueHelper.read(InputStream istream)
static String | FieldNameHelper.read(InputStream istream)
static NameDynAnyPair | NameDynAnyPairHelper.read(InputStream istream)
static NameDynAnyPair[] | NameDynAnyPairSeqHelper.read(InputStream istream)
static NameValuePair | NameValuePairHelper.read(InputStream istream)
static NameValuePair[] | NameValuePairSeqHelper.read(InputStream istream)

org.omg.DynamicAny.DynAnyFactoryPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static InconsistentTypeCode InconsistentTypeCodeHelper.read(InputStream istream)

org.omg.DynamicAny.DynAnyPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static InvalidValue | InvalidValueHelper.read(InputStream istream)
static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

org.omg.IOP 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.IOP 中的方法
void | IORHolder._read(InputStream i)
void | MultipleComponentProfileHolder._read(InputStream i)
void | ServiceContextHolder._read(InputStream i)
void | ServiceContextListHolder._read(InputStream i)
void | TaggedComponentHolder._read(InputStream i)
void | TaggedProfileHolder._read(InputStream i)
static CodecFactory | CodecFactoryHelper.read(InputStream istream)
static int | ComponentIdHelper.read(InputStream istream)
static IOR | IORHelper.read(InputStream istream)
static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
static int | ProfileIdHelper.read(InputStream istream)
static ServiceContext | ServiceContextHelper.read(InputStream istream)
static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)
static int | ServiceIdHelper.read(InputStream istream)
static TaggedComponent | TaggedComponentHelper.read(InputStream istream)
static TaggedProfile | TaggedProfileHelper.read(InputStream istream)

org.omg.IOP.CodecFactoryPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.IOP.CodecFactoryPackage 中的方法
static UnknownEncoding UnknownEncodingHelper.read(InputStream istream)

org.omg.IOP.CodecPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.IOP.CodecPackage 中的方法
static FormatMismatch | FormatMismatchHelper.read(InputStream istream)
static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)
static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

org.omg.Messaging 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.Messaging 中的方法
static short SyncScopeHelper.read(InputStream istream)

org.omg.PortableInterceptor 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableInterceptor 中的方法
void | IORInterceptor_3_0Holder._read(InputStream i)
void | ObjectReferenceFactoryHolder._read(InputStream i)
void | ObjectReferenceTemplateHolder._read(InputStream i)
void | ObjectReferenceTemplateSeqHolder._read(InputStream i)
static int | AdapterManagerIdHelper.read(InputStream istream)
static String[] | AdapterNameHelper.read(InputStream istream)
static short | AdapterStateHelper.read(InputStream istream)
static Current | CurrentHelper.read(InputStream istream)
static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
static InvalidSlot | InvalidSlotHelper.read(InputStream istream)
static String | ORBIdHelper.read(InputStream istream)
static byte[] | ObjectIdHelper.read(InputStream istream)
static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)
static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)
static String | ServerIdHelper.read(InputStream istream)

org.omg.PortableInterceptor.ORBInitInfoPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static DuplicateName | DuplicateNameHelper.read(InputStream istream)
static InvalidName | InvalidNameHelper.read(InputStream istream)
static String | ObjectIdHelper.read(InputStream istream)

org.omg.PortableServer 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer 中的方法
OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
static Current | CurrentHelper.read(InputStream istream)
static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
static POA | POAHelper.read(InputStream istream)
static ServantActivator | ServantActivatorHelper.read(InputStream istream)
static ServantLocator | ServantLocatorHelper.read(InputStream istream)

org.omg.PortableServer.CurrentPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer.CurrentPackage 中的方法
static NoContext NoContextHelper.read(InputStream istream)

org.omg.PortableServer.POAManagerPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer.POAManagerPackage 中的方法
static AdapterInactive AdapterInactiveHelper.read(InputStream istream)

org.omg.PortableServer.POAPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer.POAPackage 中的方法
static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)
static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)
static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)
static NoServant | NoServantHelper.read(InputStream istream)
static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)
static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)
static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)
static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)
static WrongAdapter | WrongAdapterHelper.read(InputStream istream)
static WrongPolicy | WrongPolicyHelper.read(InputStream istream)

org.omg.PortableServer.ServantLocatorPackage 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.PortableServer.ServantLocatorPackage 中的方法
 void CookieHolder._read(InputStream is)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.InvokeHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.InvokeHandler
的使用

使用 InvokeHandler 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

javax.rmi.CORBA 中 InvokeHandler 的使用

javax.rmi.CORBA 中 InvokeHandler 的子接口
 interface Tie
定义所有 RMI-IIOP 服务器端 tie 必须实现的方法。

org.omg.CosNaming 中 InvokeHandler 的使用

实现 InvokeHandler 的 org.omg.CosNaming 中的类
class | BindingIteratorPOA BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
class | NamingContextExtPOA NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextPOA 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.PortableServer 中 InvokeHandler 的使用

实现 InvokeHandler 的 org.omg.PortableServer 中的类
class | ServantActivatorPOA POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
class | ServantLocatorPOA POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.ObjectImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.ObjectImpl
的使用

使用 ObjectImpl 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 中 ObjectImpl 的使用

javax.rmi.CORBA 中 ObjectImpl 的子类
 class Stub
必须从其继承所有 RMI-IIOP stub 的基类。

org.omg.CORBA 中 ObjectImpl 的使用

org.omg.CORBA 中 ObjectImpl 的子类
class | _IDLTypeStub IDLType 的 Stub。
class | _PolicyStub Policy 的 Stub。
class | DynamicImplementation 已过时。 org.omg.CORBA.DynamicImplementation

org.omg.CORBA_2_3.portable 中 ObjectImpl 的使用

org.omg.CORBA_2_3.portable 中 ObjectImpl 的子类
 class ObjectImpl
ObjectImpl 类是所有 stub 的基类。

org.omg.CosNaming 中 ObjectImpl 的使用

org.omg.CosNaming 中 ObjectImpl 的子类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.DynamicAny 中 ObjectImpl 的使用

org.omg.DynamicAny 中 ObjectImpl 的子类
class | _DynAnyFactoryStub DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。

org.omg.PortableServer 中 ObjectImpl 的使用

org.omg.PortableServer 中 ObjectImpl 的子类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

org.omg.stub.java.rmi 中 ObjectImpl 的使用

org.omg.stub.java.rmi 中 ObjectImpl 的子类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.OutputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.OutputStream
的使用

使用 OutputStream 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。

javax.rmi.CORBA 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.rmi.CORBA 中的方法
static void Util.writeAbstractObject(OutputStream out, Object obj)
将 java.lang.Object 作为一个值或 CORBA Object 写入。
 void UtilDelegate.writeAbstractObject(OutputStream out, Object obj)
Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
static void Util.writeAny(OutputStream out, Object obj)
将 any java.lang.Object 作为 CORBA any 写入。
 void UtilDelegate.writeAny(OutputStream out, Object obj)
Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
static void Util.writeRemoteObject(OutputStream out, Object obj)
将 java.lang.Object 作为 CORBA Object 写入。
 void UtilDelegate.writeRemoteObject(OutputStream out, Object obj)
Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
 void ValueHandler.writeValue(OutputStream out, Serializable value)
使用 Java 语义将一个值写入流。
 void ValueHandlerMultiFormat.writeValue(OutputStream out, Serializable value, byte streamFormatVersion)
允许 ORB 为 RMI/IDL 自定义值类型传递流格式版本。

org.omg.CORBA 中 OutputStream 的使用

返回 OutputStream 的 org.omg.CORBA 中的方法
OutputStream | LocalObject._request(String operation, boolean responseExpected) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
abstract OutputStream | Any.create_output_stream() 创建一个输出流，可以将此 Any 对象的值编组到其中。
abstract OutputStream | ORB.create_output_stream() 创建一个新的 org.omg.CORBA.portable.OutputStream，在执行方法调用期间，可在该输出流中对 IDL 方法参数进行编组。

参数类型为 OutputStream 的 org.omg.CORBA 中的方法
InputStream | LocalObject._invoke(OutputStream output) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
void | AnyHolder._write(OutputStream output) 将此 AnyHolder 对象中的值编组到 output。
void | AnySeqHolder._write(OutputStream o)
void | BooleanHolder._write(OutputStream output) 将此 BooleanHolder 对象 value 字段中的值编组到输出流 output。
void | BooleanSeqHolder._write(OutputStream o)
void | ByteHolder._write(OutputStream output) 将此 ByteHolder 对象中的值编组到 output。
void | CharHolder._write(OutputStream output) 将此 CharHolder 对象中的值编组到 output。
void | CharSeqHolder._write(OutputStream o)
void | CurrentHolder._write(OutputStream o)
void | DoubleHolder._write(OutputStream output) 将存储在此 holder 中的 double 值写入 OutputStream。
void | DoubleSeqHolder._write(OutputStream o)
void | FixedHolder._write(OutputStream output) 将存储在此 holder 中的定点值写入 OutputStream。
void | FloatHolder._write(OutputStream output) 将 float 值写入输出流。
void | FloatSeqHolder._write(OutputStream o)
void | IntHolder._write(OutputStream output) 将此 IntHolder 对象 value 字段中的值编组到输出流 output 中。
void | LongHolder._write(OutputStream output) 将此 Holder 中的值编组到 output。
void | LongLongSeqHolder._write(OutputStream o)
void | LongSeqHolder._write(OutputStream o)
void | ObjectHolder._write(OutputStream output) 将此 ObjectHolder 对象中的值编组到 output。
void | OctetSeqHolder._write(OutputStream o)
void | ParameterModeHolder._write(OutputStream o)
void | PolicyErrorHolder._write(OutputStream o)
void | PolicyHolder._write(OutputStream o)
void | PolicyListHolder._write(OutputStream o)
void | PrincipalHolder._write(OutputStream output) 已过时。
void | ServiceInformationHolder._write(OutputStream out) 将此 ServiceInformationHolder 对象的 value 字段中的值编组到输出流 out。
void | ShortHolder._write(OutputStream output) 将此 ShortHolder 对象中的值编组到 output。
void | ShortSeqHolder._write(OutputStream o)
void | StringHolder._write(OutputStream output) 将此 StringHolder 对象所保存的值编组到输出流 output。
void | StringSeqHolder._write(OutputStream o)
void | TypeCodeHolder._write(OutputStream output) 将此 TypeCodeHolder 对象中的值编组到 output。
void | ULongLongSeqHolder._write(OutputStream o)
void | ULongSeqHolder._write(OutputStream o)
void | UShortSeqHolder._write(OutputStream o)
void | UnknownUserExceptionHolder._write(OutputStream o)
void | ValueBaseHolder._write(OutputStream output) 将此 Holder 中的值编组到 output。
void | WCharSeqHolder._write(OutputStream o)
void | WStringSeqHolder._write(OutputStream o)
void | WrongTransactionHolder._write(OutputStream o)
abstract void | Any.write_value(OutputStream os) 将此 Any 对象的值写出到给定输出流。
void | StringValueHelper.write_value(OutputStream ostream, Serializable value)
void | WStringValueHelper.write_value(OutputStream ostream, Serializable value)
static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
static void | BooleanSeqHelper.write(OutputStream ostream, boolean[] value)
static void | OctetSeqHelper.write(OutputStream ostream, byte[] value)
static void | CharSeqHelper.write(OutputStream ostream, char[] value)
static void | WCharSeqHelper.write(OutputStream ostream, char[] value)
static void | CompletionStatusHelper.write(OutputStream ostream, CompletionStatus value)
static void | CurrentHelper.write(OutputStream ostream, Current value)
static void | DefinitionKindHelper.write(OutputStream ostream, DefinitionKind value)
static void | DoubleSeqHelper.write(OutputStream ostream, double[] value)
static void | FloatSeqHelper.write(OutputStream ostream, float[] value)
static void | IDLTypeHelper.write(OutputStream ostream, IDLType value)
static void | PolicyTypeHelper.write(OutputStream ostream, int value)
static void | LongSeqHelper.write(OutputStream ostream, int[] value)
static void | ULongSeqHelper.write(OutputStream ostream, int[] value)
static void | LongLongSeqHelper.write(OutputStream ostream, long[] value)
static void | ULongLongSeqHelper.write(OutputStream ostream, long[] value)
static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
static void | ObjectHelper.write(OutputStream ostream, Object value)
static void | ParameterModeHelper.write(OutputStream ostream, ParameterMode value)
static void | PolicyHelper.write(OutputStream ostream, Policy value)
static void | PolicyListHelper.write(OutputStream ostream, Policy[] value)
static void | PolicyErrorHelper.write(OutputStream ostream, PolicyError value)
static void | ValueBaseHelper.write(OutputStream ostream, Serializable value)
static void | ServiceDetailHelper.write(OutputStream out, ServiceDetail that)
static void | ServiceInformationHelper.write(OutputStream out, ServiceInformation that)
static void | SetOverrideTypeHelper.write(OutputStream ostream, SetOverrideType value)
static void | PolicyErrorCodeHelper.write(OutputStream ostream, short value)
static void | VisibilityHelper.write(OutputStream ostream, short value)
static void | ShortSeqHelper.write(OutputStream ostream, short[] value)
static void | UShortSeqHelper.write(OutputStream ostream, short[] value)
static void | FieldNameHelper.write(OutputStream ostream, String value)
static void | IdentifierHelper.write(OutputStream ostream, String value)
static void | RepositoryIdHelper.write(OutputStream ostream, String value)
static void | StringValueHelper.write(OutputStream ostream, String value)
static void | VersionSpecHelper.write(OutputStream ostream, String value)
static void | WStringValueHelper.write(OutputStream ostream, String value)
static void | StringSeqHelper.write(OutputStream ostream, String[] value)
static void | WStringSeqHelper.write(OutputStream ostream, String[] value)
static void | StructMemberHelper.write(OutputStream ostream, StructMember value)
static void | UnionMemberHelper.write(OutputStream ostream, UnionMember value)
static void | UnknownUserExceptionHelper.write(OutputStream ostream, UnknownUserException value)
static void | ValueMemberHelper.write(OutputStream ostream, ValueMember value)
static void | WrongTransactionHelper.write(OutputStream ostream, WrongTransaction value)

org.omg.CORBA_2_3.portable 中 OutputStream 的使用

org.omg.CORBA_2_3.portable 中 OutputStream 的子类
 class OutputStream
OutputStream 提供将所有映射的 IDL 类型写入流的接口。

org.omg.CORBA.portable 中 OutputStream 的使用

返回 OutputStream 的 org.omg.CORBA.portable 中的方法
OutputStream | InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler) 由 ORB 调用来调度对 servant 的请求。
OutputStream | ObjectImpl._request(String operation, boolean responseExpected) 返回一个 OutputStream 对象，该对象用于编组给定方法的参数。
OutputStream | ResponseHandler.createExceptionReply() 在方法调用期间由 servant 调用。
OutputStream | ResponseHandler.createReply() 在方法调用期间由 servant 调用。
OutputStream | Delegate.request(Object self, String operation, boolean responseExpected) request 由 stub 调用，以获取用于编组参数的 OutputStream。

参数类型为 OutputStream 的 org.omg.CORBA.portable 中的方法
InputStream | ObjectImpl._invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
void | Streamable._write(OutputStream ostream) 将 Holder 中 value 字段的值编组到 ostream。
InputStream | Delegate.invoke(Object self, OutputStream output) 由 stub 调用，以调用一个操作。
void | BoxedValueHelper.write_value(OutputStream os, Serializable value)

org.omg.CosNaming 中 OutputStream 的使用

返回 OutputStream 的 org.omg.CosNaming 中的方法
OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

参数类型为 OutputStream 的 org.omg.CosNaming 中的方法
void | BindingHolder._write(OutputStream o)
void | BindingIteratorHolder._write(OutputStream o)
void | BindingListHolder._write(OutputStream o)
void | BindingTypeHolder._write(OutputStream o)
void | NameComponentHolder._write(OutputStream o)
void | NameHolder._write(OutputStream o)
void | NamingContextExtHolder._write(OutputStream o)
void | NamingContextHolder._write(OutputStream o)
static void | BindingHelper.write(OutputStream ostream, Binding value)
static void | BindingListHelper.write(OutputStream ostream, Binding[] value)
static void | BindingIteratorHelper.write(OutputStream ostream, BindingIterator value)
static void | BindingTypeHelper.write(OutputStream ostream, BindingType value)
static void | NameComponentHelper.write(OutputStream ostream, NameComponent value)
static void | NameHelper.write(OutputStream ostream, NameComponent[] value)
static void | NamingContextHelper.write(OutputStream ostream, NamingContext value)
static void | NamingContextExtHelper.write(OutputStream ostream, NamingContextExt value)
static void | IstringHelper.write(OutputStream ostream, String value)

org.omg.CosNaming.NamingContextExtPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
void | InvalidAddressHolder._write(OutputStream o)
static void | InvalidAddressHelper.write(OutputStream ostream, InvalidAddress value)
static void | AddressHelper.write(OutputStream ostream, String value)
static void | StringNameHelper.write(OutputStream ostream, String value)
static void | URLStringHelper.write(OutputStream ostream, String value)

org.omg.CosNaming.NamingContextPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.CosNaming.NamingContextPackage 中的方法
void | AlreadyBoundHolder._write(OutputStream o)
void | CannotProceedHolder._write(OutputStream o)
void | InvalidNameHolder._write(OutputStream o)
void | NotEmptyHolder._write(OutputStream o)
void | NotFoundHolder._write(OutputStream o)
void | NotFoundReasonHolder._write(OutputStream o)
static void | AlreadyBoundHelper.write(OutputStream ostream, AlreadyBound value)
static void | CannotProceedHelper.write(OutputStream ostream, CannotProceed value)
static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
static void | NotEmptyHelper.write(OutputStream ostream, NotEmpty value)
static void | NotFoundHelper.write(OutputStream ostream, NotFound value)
static void | NotFoundReasonHelper.write(OutputStream ostream, NotFoundReason value)

org.omg.DynamicAny 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.DynamicAny 中的方法
static void | AnySeqHelper.write(OutputStream ostream, Any[] value)
static void | DynAnyHelper.write(OutputStream ostream, DynAny value)
static void | DynAnySeqHelper.write(OutputStream ostream, DynAny[] value)
static void | DynAnyFactoryHelper.write(OutputStream ostream, DynAnyFactory value)
static void | DynArrayHelper.write(OutputStream ostream, DynArray value)
static void | DynEnumHelper.write(OutputStream ostream, DynEnum value)
static void | DynFixedHelper.write(OutputStream ostream, DynFixed value)
static void | DynSequenceHelper.write(OutputStream ostream, DynSequence value)
static void | DynStructHelper.write(OutputStream ostream, DynStruct value)
static void | DynUnionHelper.write(OutputStream ostream, DynUnion value)
static void | DynValueHelper.write(OutputStream ostream, DynValue value)
static void | NameDynAnyPairHelper.write(OutputStream ostream, NameDynAnyPair value)
static void | NameDynAnyPairSeqHelper.write(OutputStream ostream, NameDynAnyPair[] value)
static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
static void | NameValuePairSeqHelper.write(OutputStream ostream, NameValuePair[] value)
static void | FieldNameHelper.write(OutputStream ostream, String value)

org.omg.DynamicAny.DynAnyFactoryPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static void InconsistentTypeCodeHelper.write(OutputStream ostream, InconsistentTypeCode value)

org.omg.DynamicAny.DynAnyPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static void | InvalidValueHelper.write(OutputStream ostream, InvalidValue value)
static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

org.omg.IOP 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.IOP 中的方法
void | IORHolder._write(OutputStream o)
void | MultipleComponentProfileHolder._write(OutputStream o)
void | ServiceContextHolder._write(OutputStream o)
void | ServiceContextListHolder._write(OutputStream o)
void | TaggedComponentHolder._write(OutputStream o)
void | TaggedProfileHolder._write(OutputStream o)
static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)
static void | ComponentIdHelper.write(OutputStream ostream, int value)
static void | ProfileIdHelper.write(OutputStream ostream, int value)
static void | ServiceIdHelper.write(OutputStream ostream, int value)
static void | IORHelper.write(OutputStream ostream, IOR value)
static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)
static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)
static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)

org.omg.IOP.CodecFactoryPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.IOP.CodecFactoryPackage 中的方法
static void UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)

org.omg.IOP.CodecPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.IOP.CodecPackage 中的方法
static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)
static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)
static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

org.omg.Messaging 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.Messaging 中的方法
static void SyncScopeHelper.write(OutputStream ostream, short value)

org.omg.PortableInterceptor 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableInterceptor 中的方法
void | IORInterceptor_3_0Holder._write(OutputStream o)
void | ObjectReferenceFactoryHolder._write(OutputStream o)
void | ObjectReferenceTemplateHolder._write(OutputStream o)
void | ObjectReferenceTemplateSeqHolder._write(OutputStream o)
static void | ObjectIdHelper.write(OutputStream ostream, byte[] value)
static void | CurrentHelper.write(OutputStream ostream, Current value)
static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
static void | AdapterManagerIdHelper.write(OutputStream ostream, int value)
static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)
static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)
static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)
static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)
static void | AdapterStateHelper.write(OutputStream ostream, short value)
static void | ORBIdHelper.write(OutputStream ostream, String value)
static void | ServerIdHelper.write(OutputStream ostream, String value)
static void | AdapterNameHelper.write(OutputStream ostream, String[] value)

org.omg.PortableInterceptor.ORBInitInfoPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)
static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
static void | ObjectIdHelper.write(OutputStream ostream, String value)

org.omg.PortableServer 中 OutputStream 的使用

返回 OutputStream 的 org.omg.PortableServer 中的方法
OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

参数类型为 OutputStream 的 org.omg.PortableServer 中的方法
static void | CurrentHelper.write(OutputStream ostream, Current value)
static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
static void | POAHelper.write(OutputStream ostream, POA value)
static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)
static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)

org.omg.PortableServer.CurrentPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableServer.CurrentPackage 中的方法
static void NoContextHelper.write(OutputStream ostream, NoContext value)

org.omg.PortableServer.POAManagerPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableServer.POAManagerPackage 中的方法
static void AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)

org.omg.PortableServer.POAPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableServer.POAPackage 中的方法
static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)
static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)
static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)
static void | NoServantHelper.write(OutputStream ostream, NoServant value)
static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)
static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)
static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)
static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)
static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)
static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)

org.omg.PortableServer.ServantLocatorPackage 中 OutputStream 的使用

参数类型为 OutputStream 的 org.omg.PortableServer.ServantLocatorPackage 中的方法
 void CookieHolder._write(OutputStream os)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.RemarshalException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.RemarshalException
的使用

使用 RemarshalException 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 RemarshalException 的使用

抛出 RemarshalException 的 org.omg.CORBA 中的方法
 InputStream LocalObject._invoke(OutputStream output)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

org.omg.CORBA.portable 中 RemarshalException 的使用

抛出 RemarshalException 的 org.omg.CORBA.portable 中的方法
InputStream | ObjectImpl._invoke(OutputStream output) 调用某个操作并返回用来读取响应的 InputStream 对象。
InputStream | Delegate.invoke(Object self, OutputStream output) 由 stub 调用，以调用一个操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ResponseHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ResponseHandler
的使用

使用 ResponseHandler 的软件包
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA.portable 中 ResponseHandler 的使用

参数类型为 ResponseHandler 的 org.omg.CORBA.portable 中的方法
 OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
由 ORB 调用来调度对 servant 的请求。

org.omg.CosNaming 中 ResponseHandler 的使用

参数类型为 ResponseHandler 的 org.omg.CosNaming 中的方法
OutputStream | BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

org.omg.PortableServer 中 ResponseHandler 的使用

参数类型为 ResponseHandler 的 org.omg.PortableServer 中的方法
OutputStream | ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)
OutputStream | ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.ServantObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.ServantObject
的使用

使用 ServantObject 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 ServantObject 的使用

返回 ServantObject 的 org.omg.CORBA 中的方法
 ServantObject LocalObject._servant_preinvoke(String operation, Class expectedType)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

参数类型为 ServantObject 的 org.omg.CORBA 中的方法
 void LocalObject._servant_postinvoke(ServantObject servant)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

org.omg.CORBA.portable 中 ServantObject 的使用

返回 ServantObject 的 org.omg.CORBA.portable 中的方法
ServantObject | ObjectImpl._servant_preinvoke(String operation, Class expectedType) 返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。
ServantObject | Delegate.servant_preinvoke(Object self, String operation, Class expectedType) 返回对应该用作此请求的 servant 的 Java 引用。

参数类型为 ServantObject 的 org.omg.CORBA.portable 中的方法
 void ObjectImpl._servant_postinvoke(ServantObject servant)
本地 stub 在发起了对本地 servant（通过对 _servant_preinvoke 方法的调用得到）的一次操作后，再调用此方法。
 void Delegate.servant_postinvoke(Object self, ServantObject servant)
servant_postinvoke() 由本地 stub 在已经对本地 servant 调用该操作之后调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.Streamable 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.Streamable
的使用

使用 Streamable 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。

org.omg.CORBA 中 Streamable 的使用

实现 Streamable 的 org.omg.CORBA 中的类
class | AnyHolder Any 的 Holder。
class | AnySeqHolder AnySeq 的 Holder。
class | BooleanHolder Boolean 的 Holder。
class | BooleanSeqHolder BooleanSeq 的 Holder。
class | ByteHolder Byte 的 Holder。
class | CharHolder Char 的 Holder。
class | CharSeqHolder CharSeq 的 Holder。
class | CurrentHolder Current 的 Holder。
class | DoubleHolder Double 的 Holder。
class | DoubleSeqHolder DoubleSeq 的 Holder。
class | FixedHolder Fixed 的 Holder。
class | FloatHolder Float 的 Holder。
class | FloatSeqHolder FloatSeq 的 Holder。
class | IntHolder Int 的 Holder。
class | LongHolder Long 值的 Holder。
class | LongLongSeqHolder LongLongSeq 的 Holder。
class | LongSeqHolder LongSeq 的 Holder。
class | ObjectHolder Object 的 Holder。
class | OctetSeqHolder OctetSeq 的 Holder。
class | ParameterModeHolder Parameter 参数模式的枚举。
class | PolicyErrorHolder 抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。
class | PolicyHolder Policy 的 Holder。
class | PolicyListHolder PolicyList 的 Holder。
class | PrincipalHolder 已过时。 Deprecated by CORBA 2.2.
class | ServiceInformationHolder ServiceInformation 的 Holder。
class | ShortHolder Short 的 Holder。
class | ShortSeqHolder ShortSeq 的 Holder。
class | StringHolder String 的 Holder。
class | StringSeqHolder String 数组
class | TypeCodeHolder TypeCode 的 Holder。
class | ULongLongSeqHolder ULongLongSeq 的 Holder。
class | ULongSeqHolder ULongSeq 的 Holder。
class | UnknownUserExceptionHolder UnknownUserException 的 Holder。
class | UShortSeqHolder UShortSeq 的 Holder。
class | ValueBaseHolder ValueBase 的 Holder。
class | WCharSeqHolder WCharSeq 的 Holder。
class | WrongTransactionHolder WrongTransaction 的 Holder。
class | WStringSeqHolder WString 数组

返回 Streamable 的 org.omg.CORBA 中的方法
 Streamable Any.extract_Streamable()
从此 Any 对象的 value 字段提取 Streamable。

参数类型为 Streamable 的 org.omg.CORBA 中的方法
 void Any.insert_Streamable(Streamable s)
将给定 Streamable 对象插入此 Any 对象的 value 字段。

org.omg.CORBA.portable 中 Streamable 的使用

org.omg.CORBA.portable 中 Streamable 的子接口
 interface StreamableValue
为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。

org.omg.CosNaming 中 Streamable 的使用

实现 Streamable 的 org.omg.CosNaming 中的类
class | BindingHolder org/omg/CosNaming/BindingHolder.java。
class | BindingIteratorHolder BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
class | BindingListHolder 绑定列表。
class | BindingTypeHolder 指定给定的绑定是对象（非命名上下文的对象）的还是命名上下文的。
class | NameComponentHolder org/omg/CosNaming/NameComponentHolder.java。
class | NameHolder 名称是名称组件的序列。
class | NamingContextExtHolder NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextHolder 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.CosNaming.NamingContextExtPackage 中 Streamable 的使用

实现 Streamable 的 org.omg.CosNaming.NamingContextExtPackage 中的类
 class InvalidAddressHolder
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java。

org.omg.CosNaming.NamingContextPackage 中 Streamable 的使用

实现 Streamable 的 org.omg.CosNaming.NamingContextPackage 中的类
class | AlreadyBoundHolder org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java。
class | CannotProceedHolder org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java。
class | InvalidNameHolder org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java。
class | NotEmptyHolder org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java。
class | NotFoundHolder org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java。
class | NotFoundReasonHolder 指示未能解析的原因。

org.omg.IOP 中 Streamable 的使用

实现 Streamable 的 org.omg.IOP 中的类
class | IORHolder org/omg/IOP/IORHolder.java。
class | MultipleComponentProfileHolder 形成多组件配置文件的一组加标记的组件。
class | ServiceContextHolder org/omg/IOP/ServiceContextHolder.java。
class | ServiceContextListHolder 形成服务上下文列表的一组服务上下文。
class | TaggedComponentHolder org/omg/IOP/TaggedComponentHolder.java。
class | TaggedProfileHolder org/omg/IOP/TaggedProfileHolder.java。

org.omg.PortableInterceptor 中 Streamable 的使用

实现 Streamable 的 org.omg.PortableInterceptor 中的类
class | IORInterceptor_3_0Holder org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java。
class | ObjectReferenceFactoryHolder 对象引用工厂。
class | ObjectReferenceTemplateHolder 对象引用模板。
class | ObjectReferenceTemplateSeqHolder 对象引用模板序列用来报告不发生在适配器管理器的状态更改。

org.omg.PortableServer.ServantLocatorPackage 中 Streamable 的使用

实现 Streamable 的 org.omg.PortableServer.ServantLocatorPackage 中的类
 class CookieHolder
native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.StreamableValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.StreamableValue
的使用

没有 org.omg.CORBA.portable.StreamableValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.portable.UnknownException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.portable.UnknownException
的使用

没有 org.omg.CORBA.portable.UnknownException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ValueBase 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ValueBase
的使用

使用 ValueBase 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.CORBA 中 ValueBase 的使用

org.omg.CORBA 中 ValueBase 的子接口
interface | DataInputStream 定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
interface | DataOutputStream 定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。

org.omg.CORBA.portable 中 ValueBase 的使用

org.omg.CORBA.portable 中 ValueBase 的子接口
interface | CustomValue 通过自定义值类型实现的 ValueBase 扩展。
interface | StreamableValue 为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。

org.omg.PortableInterceptor 中 ValueBase 的使用

org.omg.PortableInterceptor 中 ValueBase 的子接口
interface | ObjectReferenceFactory 对象引用工厂。
interface | ObjectReferenceTemplate 对象引用模板。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ValueFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ValueFactory
的使用

使用 ValueFactory 的软件包
org.omg.CORBA_2_3 CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

org.omg.CORBA_2_3 中 ValueFactory 的使用

返回 ValueFactory 的 org.omg.CORBA_2_3 中的方法
ValueFactory | ORB.lookup_value_factory(String id)
ValueFactory | ORB.register_value_factory(String id, ValueFactory factory)

参数类型为 ValueFactory 的 org.omg.CORBA_2_3 中的方法
 ValueFactory ORB.register_value_factory(String id, ValueFactory factory)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ValueInputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ValueInputStream
的使用

没有 org.omg.CORBA.portable.ValueInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.portable.ValueOutputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.portable.ValueOutputStream
的使用

没有 org.omg.CORBA.portable.ValueOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Official Specifications for CORBA support in Java[tm] SE 6

Specification References

The specifications with which the Java[tm] Platform, Standard Edition (Java SE) v.1.6.0 ORB complies are as follows. If these links do not take you to the referenced specification, the OMG may have changed the URL, and you can link to www.omg.org to search for the correct specification.
  • CORBA 2.3.1 (formal/99-10-07)
  • IDL to Java language mapping (ptc/00-01-08)
  • Revised IDL to Java language mapping (ptc/00-11-03)
  • Java to IDL language mapping (ptc/00-01-06)
  • Interoperable Naming Service (ptc/00-08-07)
  • Portable Interceptors (ptc/2001-03-04)
These are the only specifications referenced by this document.

Supported Specification Details

Not all of the above specifications are currently implemented in the ORB in Java[tm] SE 6. The precise list of supported sections is as follows:
  • CORBA 2.3.1 chapters 1-3 and 6-9
  • Revised IDL to Java language mapping, section 1.21.8.2, the orb.properties file.
  • CORBA 2.3.1 chapter 4 with the following replacements from the Portable Interceptors specification:
    • section 4.2.3.5 destroy
    • section 4.5.2 CodeFactory and PICurrent are required
    • Section 4.5.3.4 as updated for register_initial_reference
  • CORBA 2.3.1 chapter 5 with the following update from the Portable Interceptors specification:
    • 5.5.2 StringSeq and WStringSeq are required. This adds the following classes to org.omg.CORBA:
      • StringSeqHolder
      • StringSeqHelper
      • WStringSeqHolder
      • WStringSeqHelper
  • CORBA 2.3.1 sections 10.6.1 and 10.6.2 are supported for repository IDs.
  • CORBA 2.3.1 section 10.7 for TypeCode APIs.
  • CORBA 2.3.1 chapter 11, Portable Object Adapter (POA), with the following updates from the Portable Interceptors specification:
    • Section 11.3.7 POAs must preserve all policies
    • Section 11.3.8.2 again states that POAs must preserve all policies
    • Section 11.3.8.26 POA::id is required.
  • CORBA 2.3.1 chapters 13 and 15 define GIOP 1.0, 1.1, and 1.2. The Java SE 6 ORB fully supports all versions of GIOP, with the exception that the bi-directional GIOP feature defined in sections 15.8 and 15.9 is not supported.
  • All of the Interoperable Naming Service is supported.
  • Portable Interceptors section 13.8 (the new Coder/Decoder interfaces) and all of chapter 21 (the interceptor specification).
  • Section 1.21.8 of the Revised IDL to Java Language Mapping Specification (ptc/00-11-03) has been changed from the version in the IDL to Java Language Mapping Specification (ptc/00-01-08).

Tools

  • The IDL to Java compiler (idlj) complies with:
    • CORBA 2.3.1 chapter 3 (IDL definition)
    • CORBA 2.3.1 chapters 5 and 6 (semantics of Value types)
    • CORBA 2.3.1 section 10.6.5 (pragmas)
    • The IDL to Java mapping specification
    • The Revised IDL to Java language mapping specification section 1.12.1 "local interfaces"
  • The Java to IDL compiler (the IIOP backend for rmic) complies with:
    • CORBA 2.3.1 chapters 5 and 6 (value types)
    • The Java to IDL language mapping. Note that this implicitly references section 1.21 of the IDL to Java language mapping
    • IDL generated by the -idl flag complies with CORBA 2.3.1 chapter 3.


IDL-to-Java Generated Files

The files that are generated by the IDL-to-Java compiler, in accordance with the IDL-to-Java Language Mapping Specification, which is implemented in JavaTM SE 6 according the compliance document.

In general IDL names and identifiers are mapped to Java names and identifiers with no change. Because of the nature of the Java language, a single IDL construct may be mapped to several (differently named) Java constructs. The additional names are constructed by appending a descriptive suffix. For example, the IDL interface foo is mapped to the Java interfaces foo and fooOperations, and additional Java classes fooHelper, fooHolder, fooPOA, and optionally fooPOATie.

The mapping in effect reserves the use of several names for its own purposes. These are:

  • The Java class <type>Helper, where <type> is the name of an IDL defined type.
  • The Java class <type>Holder, where <type> is the name of an IDL defined type (with certain exceptions such as typedef aliases).
  • The Java classes <basicJavaType>Holder, where <basicJavaType> is one of the Java primitive datatypes that is used by one of the IDL basic datatypes.
  • The Java classes <interface>Operations, <interface>POA, and <interface>POATie, where <interface> is the name of an IDL interface type.
  • The nested scope Java package name <interface>Package, where <interface> is the name of an IDL interface.

    Helper Files

    Helper files supply several static methods needed to manipulate the type. These include Any insert and extract operations for the type, getting the repository id, getting the typecode, and reading and writing the type from and to a stream.

    The helper class for a mapped IDL interface or abstract interface also include narrow operation(s). The static narrow method allows an org.omg.CORBA.Object to be narrowed to the object reference of a more specific type. The IDL exception CORBA::BAD_PARAM is thrown if the narrow fails because the object reference does not support the requested type. A different system exception is raised to indicate other kinds of errors. Trying to narrow a null will always succeed with a return value of null.

    Holder Files

    Support for out and inout parameter passing modes requires the use of additional holder classes. These classes are available for all of the basic IDL datatypes in the org.omg.CORBA package and are generated for all named user defined IDL types except those defined by typedefs. (Note that in this context user defined includes types that are defined in OMG specifications such as those for the Interface Repository, and other OMG services.)

    Each holder class has a constructor from an instance, a default constructor, and has a public instance member, value which is the typed value. The default constructor sets the value field to the default value for the type as defined by the Java language: false for boolean, 0 for numeric and char types, null for strings, null for object references.

    To support portable stubs and skeletons, holder classes also implement the org.omg.CORBA.portable.Streamable interface.

    Operations Files

    A non abstract IDL interface is mapped to two public Java interfaces: a signature interface and an operations interface. The signature interface, which extends IDLEntity, has the same name as the IDL interface name and is used as the signature type in method declarations when interfaces of the specified type are used in other interfaces. The operations interface has the same name as the IDL interface with the suffix Operations appended to the end and is used in the server-side mapping and as a mechanism for providing optimized calls for collocated client and servers.

    The Java operations interface contains the mapped operation signatures. The Java signature interface extends the operations interface, the (mapped) base org.omg.CORBA.Object, as well as org.omg.portable.IDLEntity. Methods can be invoked on the signature interface. Interface inheritance expressed in IDL is reflected in both the Java signature interface and operations interface hierarchies.

    Stubs

    For the mapping of a non-object-oriented language, there will be a programming interface to the stubs for each interface type. Generally, the stubs will present access to the OMG IDL-defined operations on an object in a way that is easy for programmers to predict once they are familiar with OMG IDL and the language mapping for the particular programming language. The stubs make calls on the rest of the ORB using interfaces that are private to, and presumably optimized for, the particular ORB Core. If more than one ORB is available, there may be different stubs corresponding to the different ORBs. In this case, it is necessary for the ORB and language mapping to cooperate to associate the correct stubs with the particular object reference.

    Object-oriented programming languages, such as Java, C++, and Smalltalk, do not require stub interfaces.


类 org.omg.CORBA.ACTIVITY_COMPLETED 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ACTIVITY_COMPLETED
的使用

没有 org.omg.CORBA.ACTIVITY_COMPLETED 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ACTIVITY_REQUIRED 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ACTIVITY_REQUIRED
的使用

没有 org.omg.CORBA.ACTIVITY_REQUIRED 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.ARG_IN 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.ARG_IN
的使用

没有 org.omg.CORBA.ARG_IN 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.ARG_INOUT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.ARG_INOUT
的使用

没有 org.omg.CORBA.ARG_INOUT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.ARG_OUT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.ARG_OUT
的使用

没有 org.omg.CORBA.ARG_OUT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.Any 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Any
的使用

使用 Any 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.CORBA 中 Any 的使用

声明为 Any 的 org.omg.CORBA 中的字段
Any | UnknownUserException.except 包含由服务器抛出的实际用户异常的 Any 实例。
Any | UnionMember.label 此 UnionMember 对象所描述的 union 成员的标签。
Any | AnyHolder.value 此 AnyHolder 对象保存的 Any 值。
Any[] | AnySeqHolder.value
Any | NameValuePair.value 将通过此 NameValuePair 对象与某一名称关联的值。

返回 Any 的 org.omg.CORBA 中的方法
abstract Any | Request.add_in_arg() 创建一个输入参数，并将它添加到此 Request 对象中。
abstract Any | Request.add_inout_arg() 将一个输入/输出参数添加到此 Request 对象中。
abstract Any | Request.add_named_in_arg(String name) 使用给定名称创建一个输入参数，并将它添加到此 Request 对象中。
abstract Any | Request.add_named_inout_arg(String name) 将具有给定名称的输入/输出参数添加到此 Request 对象中。
abstract Any | Request.add_named_out_arg(String name) 将具有给定名称的输出参数添加到此 Request 对象中。
abstract Any | Request.add_out_arg() 将输出参数添加到此 Request 对象中。
abstract Any | ORB.create_any() 创建一个 IDL Any 对象，初始化后该对象包含一个 kind 字段被设置为 TCKind.tc_null 的 Typecode 对象。
abstract Any | Any.extract_any() 提取此 Any 对象 value 字段中的 Any 对象。
static Any[] | AnySeqHelper.extract(Any a)
Any | DynAny.get_any() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Any。
Any[] | DynArray.get_elements() 已过时。 返回此数组所有元素的值。
Any[] | DynSequence.get_elements() 已过时。 返回此 sequence 中每个元素的值。
abstract Any | TypeCode.member_label(int index) 检索给定索引标识的 union 成员的标签。
Any | DataInputStream.read_any() 从输入流读取 IDL Any 值。
static Any[] | AnySeqHelper.read(InputStream istream)
abstract Any | Request.return_value() 返回包含方法结果值的 Any 对象。
Any | DynAny.to_any() 已过时。 将 DynAny 对象转换成 Any 对象。
abstract Any | NamedValue.value() 检索此 NamedValue 对象的值。

参数类型为 Any 的 org.omg.CORBA 中的方法
abstract  NamedValue NVList.add_value(String item_name, Any val, int flags)
创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
 DynAny ORB.create_dyn_any(Any value)
已过时。 使用新的 DynAnyFactory API 代替
abstract  NamedValue ORB.create_named_value(String s, Any any, int flags)
使用给定名称、值和参数模式标志创建一个 NamedValue 对象。
 Policy ORB.create_policy(int type, Any val)
可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。
abstract  boolean Any.equal(Any a)
检查此 Any 对象与给定 Any 对象是否相等。
 void ServerRequest.except(Any any)
已过时。 使用 set_exception()
static Any[] AnySeqHelper.extract(Any a)
static boolean[] BooleanSeqHelper.extract(Any a)
static char[] CharSeqHelper.extract(Any a)
static CompletionStatus CompletionStatusHelper.extract(Any a)
static Current CurrentHelper.extract(Any a)
static DefinitionKind DefinitionKindHelper.extract(Any a)
static double[] DoubleSeqHelper.extract(Any a)
static String FieldNameHelper.extract(Any a)
static float[] FloatSeqHelper.extract(Any a)
static IDLType IDLTypeHelper.extract(Any a)
static String IdentifierHelper.extract(Any a)
static long[] LongLongSeqHelper.extract(Any a)
static int[] LongSeqHelper.extract(Any a)
static NameValuePair NameValuePairHelper.extract(Any a)
static Object ObjectHelper.extract(Any a)
static byte[] OctetSeqHelper.extract(Any a)
static ParameterMode ParameterModeHelper.extract(Any a)
static short PolicyErrorCodeHelper.extract(Any a)
static PolicyError PolicyErrorHelper.extract(Any a)
static Policy PolicyHelper.extract(Any a)
static Policy[] PolicyListHelper.extract(Any a)
static int PolicyTypeHelper.extract(Any a)
static String RepositoryIdHelper.extract(Any a)
static ServiceDetail ServiceDetailHelper.extract(Any a)
static ServiceInformation ServiceInformationHelper.extract(Any a)
static SetOverrideType SetOverrideTypeHelper.extract(Any a)
static short[] ShortSeqHelper.extract(Any a)
static String[] StringSeqHelper.extract(Any a)
static String StringValueHelper.extract(Any a)
static StructMember StructMemberHelper.extract(Any a)
static long[] ULongLongSeqHelper.extract(Any a)
static int[] ULongSeqHelper.extract(Any a)
static short[] UShortSeqHelper.extract(Any a)
static UnionMember UnionMemberHelper.extract(Any a)
static UnknownUserException UnknownUserExceptionHelper.extract(Any a)
static Serializable ValueBaseHelper.extract(Any a)
static ValueMember ValueMemberHelper.extract(Any a)
static String VersionSpecHelper.extract(Any a)
static short VisibilityHelper.extract(Any a)
static char[] WCharSeqHelper.extract(Any a)
static String[] WStringSeqHelper.extract(Any a)
static String WStringValueHelper.extract(Any a)
static WrongTransaction WrongTransactionHelper.extract(Any a)
 void DynAny.from_any(Any value)
已过时。 根据 Any 对象生成一个 DynAny 对象。
abstract  void Any.insert_any(Any a)
将给定 Any 对象插入此 Any 对象的 value 字段。
 void DynAny.insert_any(Any value)
已过时。 插入给定 org.omg.CORBA.Any 对象作为此 DynAny 对象的值。
static void AnySeqHelper.insert(Any a, Any[] that)
static void AnySeqHelper.insert(Any a, Any[] that)
static void BooleanSeqHelper.insert(Any a, boolean[] that)
static void OctetSeqHelper.insert(Any a, byte[] that)
static void CharSeqHelper.insert(Any a, char[] that)
static void WCharSeqHelper.insert(Any a, char[] that)
static void CompletionStatusHelper.insert(Any a, CompletionStatus that)
static void CurrentHelper.insert(Any a, Current that)
static void DefinitionKindHelper.insert(Any a, DefinitionKind that)
static void DoubleSeqHelper.insert(Any a, double[] that)
static void FloatSeqHelper.insert(Any a, float[] that)
static void IDLTypeHelper.insert(Any a, IDLType that)
static void PolicyTypeHelper.insert(Any a, int that)
static void LongSeqHelper.insert(Any a, int[] that)
static void ULongSeqHelper.insert(Any a, int[] that)
static void LongLongSeqHelper.insert(Any a, long[] that)
static void ULongLongSeqHelper.insert(Any a, long[] that)
static void NameValuePairHelper.insert(Any a, NameValuePair that)
static void ObjectHelper.insert(Any a, Object that)
static void ParameterModeHelper.insert(Any a, ParameterMode that)
static void PolicyHelper.insert(Any a, Policy that)
static void PolicyListHelper.insert(Any a, Policy[] that)
static void PolicyErrorHelper.insert(Any a, PolicyError that)
static void ValueBaseHelper.insert(Any a, Serializable that)
static void ServiceDetailHelper.insert(Any a, ServiceDetail that)
static void ServiceInformationHelper.insert(Any a, ServiceInformation that)
static void SetOverrideTypeHelper.insert(Any a, SetOverrideType that)
static void PolicyErrorCodeHelper.insert(Any a, short that)
static void VisibilityHelper.insert(Any a, short that)
static void ShortSeqHelper.insert(Any a, short[] that)
static void UShortSeqHelper.insert(Any a, short[] that)
static void FieldNameHelper.insert(Any a, String that)
static void IdentifierHelper.insert(Any a, String that)
static void RepositoryIdHelper.insert(Any a, String that)
static void StringValueHelper.insert(Any a, String that)
static void VersionSpecHelper.insert(Any a, String that)
static void WStringValueHelper.insert(Any a, String that)
static void StringSeqHelper.insert(Any a, String[] that)
static void WStringSeqHelper.insert(Any a, String[] that)
static void StructMemberHelper.insert(Any a, StructMember that)
static void UnionMemberHelper.insert(Any a, UnionMember that)
static void UnknownUserExceptionHelper.insert(Any a, UnknownUserException that)
static void ValueMemberHelper.insert(Any a, ValueMember that)
static void WrongTransactionHelper.insert(Any a, WrongTransaction that)
 void ServerRequest.result(Any any)
已过时。 使用方法 set_result
 void DynArray.set_elements(Any[] value)
已过时。 将此 DynArray 对象的值设置为给定数组。
 void DynSequence.set_elements(Any[] value)
已过时。 使用给定数组设置此 sequence 中所有元素的值。
 void ServerRequest.set_exception(Any any)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
abstract  void Context.set_one_value(String propname, Any propvalue)
创建一个 NamedValue 对象，并将它添加到此 Context 对象中。
 void ServerRequest.set_result(Any any)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
 void DataOutputStream.write_any_array(Any[] seq, int offset, int length)
将 IDL Any 数组中从 offset 处开始的 length 个元素写入输出流。
 void DataOutputStream.write_any(Any value)
将 Any 值写入输出流。
static void AnySeqHelper.write(OutputStream ostream, Any[] value)

参数类型为 Any 的 org.omg.CORBA 中的构造方法
AnyHolder(Any initial)
为给定的 Any 对象构造一个新 AnyHolder 对象。
AnySeqHolder(Any[] initialValue)
NameValuePair(String __id, Any __value)
构造一个 NameValuePair 对象，该对象将给定名称与给定 org.omg.CORBA.Any 对象关联。
UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
UnknownUserException(Any a)
构造一个包含给定 Any 对象的 UnknownUserException 对象。

org.omg.CORBA.portable 中 Any 的使用

返回 Any 的 org.omg.CORBA.portable 中的方法
abstract  Any InputStream.read_any()
从此输入流中读取一个 Any。

参数类型为 Any 的 org.omg.CORBA.portable 中的方法
abstract  void OutputStream.write_any(Any value)
在此输出流上写入一个 Any。

org.omg.CosNaming 中 Any 的使用

参数类型为 Any 的 org.omg.CosNaming 中的方法
static Binding | BindingHelper.extract(Any a)
static BindingIterator | BindingIteratorHelper.extract(Any a)
static Binding[] | BindingListHelper.extract(Any a)
static BindingType | BindingTypeHelper.extract(Any a)
static String | IstringHelper.extract(Any a)
static NameComponent | NameComponentHelper.extract(Any a)
static NameComponent[] | NameHelper.extract(Any a)
static NamingContextExt | NamingContextExtHelper.extract(Any a)
static NamingContext | NamingContextHelper.extract(Any a)
static void | BindingHelper.insert(Any a, Binding that)
static void | BindingListHelper.insert(Any a, Binding[] that)
static void | BindingIteratorHelper.insert(Any a, BindingIterator that)
static void | BindingTypeHelper.insert(Any a, BindingType that)
static void | NameComponentHelper.insert(Any a, NameComponent that)
static void | NameHelper.insert(Any a, NameComponent[] that)
static void | NamingContextHelper.insert(Any a, NamingContext that)
static void | NamingContextExtHelper.insert(Any a, NamingContextExt that)
static void | IstringHelper.insert(Any a, String that)

org.omg.CosNaming.NamingContextExtPackage 中 Any 的使用

参数类型为 Any 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
static String | AddressHelper.extract(Any a)
static InvalidAddress | InvalidAddressHelper.extract(Any a)
static String | StringNameHelper.extract(Any a)
static String | URLStringHelper.extract(Any a)
static void | InvalidAddressHelper.insert(Any a, InvalidAddress that)
static void | AddressHelper.insert(Any a, String that)
static void | StringNameHelper.insert(Any a, String that)
static void | URLStringHelper.insert(Any a, String that)

org.omg.CosNaming.NamingContextPackage 中 Any 的使用

参数类型为 Any 的 org.omg.CosNaming.NamingContextPackage 中的方法
static AlreadyBound | AlreadyBoundHelper.extract(Any a)
static CannotProceed | CannotProceedHelper.extract(Any a)
static InvalidName | InvalidNameHelper.extract(Any a)
static NotEmpty | NotEmptyHelper.extract(Any a)
static NotFound | NotFoundHelper.extract(Any a)
static NotFoundReason | NotFoundReasonHelper.extract(Any a)
static void | AlreadyBoundHelper.insert(Any a, AlreadyBound that)
static void | CannotProceedHelper.insert(Any a, CannotProceed that)
static void | InvalidNameHelper.insert(Any a, InvalidName that)
static void | NotEmptyHelper.insert(Any a, NotEmpty that)
static void | NotFoundHelper.insert(Any a, NotFound that)
static void | NotFoundReasonHelper.insert(Any a, NotFoundReason that)

org.omg.Dynamic 中 Any 的使用

声明为 Any 的 org.omg.Dynamic 中的字段
 Any Parameter.argument

参数类型为 Any 的 org.omg.Dynamic 中的构造方法
Parameter(Any _argument, ParameterMode _mode)

org.omg.DynamicAny 中 Any 的使用

声明为 Any 的 org.omg.DynamicAny 中的字段
 Any NameValuePair.value
与名称关联的 Any 值。

返回 Any 的 org.omg.DynamicAny 中的方法
static Any[] | AnySeqHelper.extract(Any a)
Any | DynAnyOperations.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynAnyStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynArrayStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynEnumStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynFixedStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
Any | _DynSequenceStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynStructStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynUnionStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynValueStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
Any | DynValueBoxOperations.get_boxed_value() 以 Any 的形式返回装箱值。
Any[] | DynArrayOperations.get_elements() 返回 DynArray 的元素。
Any[] | DynSequenceOperations.get_elements() 返回序列的元素。
Any[] | _DynArrayStub.get_elements() 返回 DynArray 的元素。
Any[] | _DynSequenceStub.get_elements() 返回序列的元素。
static Any[] | AnySeqHelper.read(InputStream istream)
Any | DynAnyOperations.to_any() 从 DynAny 对象创建 any 值。
Any | _DynAnyStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynArrayStub.to_any() 从 DynAny 对象中创建 any 值。
Any | _DynEnumStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynFixedStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynSequenceStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynStructStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynUnionStub.to_any() 从 DynAny 对象创建 any 值。
Any | _DynValueStub.to_any() 从 DynAny 对象创建 any 值。

参数类型为 Any 的 org.omg.DynamicAny 中的方法
DynAny | DynAnyFactoryOperations.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
DynAny | _DynAnyFactoryStub.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
static Any[] | AnySeqHelper.extract(Any a)
static DynAnyFactory | DynAnyFactoryHelper.extract(Any a)
static DynAny | DynAnyHelper.extract(Any a)
static DynAny[] | DynAnySeqHelper.extract(Any a)
static DynArray | DynArrayHelper.extract(Any a)
static DynEnum | DynEnumHelper.extract(Any a)
static DynFixed | DynFixedHelper.extract(Any a)
static DynSequence | DynSequenceHelper.extract(Any a)
static DynStruct | DynStructHelper.extract(Any a)
static DynUnion | DynUnionHelper.extract(Any a)
static DynValue | DynValueHelper.extract(Any a)
static String | FieldNameHelper.extract(Any a)
static NameDynAnyPair | NameDynAnyPairHelper.extract(Any a)
static NameDynAnyPair[] | NameDynAnyPairSeqHelper.extract(Any a)
static NameValuePair | NameValuePairHelper.extract(Any a)
static NameValuePair[] | NameValuePairSeqHelper.extract(Any a)
void | DynAnyOperations.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynUnionStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | DynAnyOperations.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynFixedStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_any(Any value) 将 Any 值插入由此 DynAny 表示的 Any 中。
void | _DynStructStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
static void | AnySeqHelper.insert(Any a, Any[] that)
static void | AnySeqHelper.insert(Any a, Any[] that)
static void | DynAnyHelper.insert(Any a, DynAny that)
static void | DynAnySeqHelper.insert(Any a, DynAny[] that)
static void | DynAnyFactoryHelper.insert(Any a, DynAnyFactory that)
static void | DynArrayHelper.insert(Any a, DynArray that)
static void | DynEnumHelper.insert(Any a, DynEnum that)
static void | DynFixedHelper.insert(Any a, DynFixed that)
static void | DynSequenceHelper.insert(Any a, DynSequence that)
static void | DynStructHelper.insert(Any a, DynStruct that)
static void | DynUnionHelper.insert(Any a, DynUnion that)
static void | DynValueHelper.insert(Any a, DynValue that)
static void | NameDynAnyPairHelper.insert(Any a, NameDynAnyPair that)
static void | NameDynAnyPairSeqHelper.insert(Any a, NameDynAnyPair[] that)
static void | NameValuePairHelper.insert(Any a, NameValuePair that)
static void | NameValuePairSeqHelper.insert(Any a, NameValuePair[] that)
static void | FieldNameHelper.insert(Any a, String that)
void | DynValueBoxOperations.set_boxed_value(Any boxed) 使用指定值取代已装箱值。
void | DynArrayOperations.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements(Any[] value) 设置序列的元素。
void | _DynArrayStub.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements(Any[] value) 设置序列的元素。
static void | AnySeqHelper.write(OutputStream ostream, Any[] value)

参数类型为 Any 的 org.omg.DynamicAny 中的构造方法
NameValuePair(String _id, Any _value)

org.omg.DynamicAny.DynAnyFactoryPackage 中 Any 的使用

参数类型为 Any 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static InconsistentTypeCode | InconsistentTypeCodeHelper.extract(Any a)
static void | InconsistentTypeCodeHelper.insert(Any a, InconsistentTypeCode that)

org.omg.DynamicAny.DynAnyPackage 中 Any 的使用

参数类型为 Any 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static InvalidValue | InvalidValueHelper.extract(Any a)
static TypeMismatch | TypeMismatchHelper.extract(Any a)
static void | InvalidValueHelper.insert(Any a, InvalidValue that)
static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)

org.omg.IOP 中 Any 的使用

返回 Any 的 org.omg.IOP 中的方法
Any | CodecOperations.decode_value(byte[] data, TypeCode tc) 基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
Any | CodecOperations.decode(byte[] data) 基于对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

参数类型为 Any 的 org.omg.IOP 中的方法
byte[] | CodecOperations.encode_value(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
byte[] | CodecOperations.encode(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
static CodecFactory | CodecFactoryHelper.extract(Any a)
static int | ComponentIdHelper.extract(Any a)
static IOR | IORHelper.extract(Any a)
static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
static int | ProfileIdHelper.extract(Any a)
static ServiceContext | ServiceContextHelper.extract(Any a)
static ServiceContext[] | ServiceContextListHelper.extract(Any a)
static int | ServiceIdHelper.extract(Any a)
static TaggedComponent | TaggedComponentHelper.extract(Any a)
static TaggedProfile | TaggedProfileHelper.extract(Any a)
static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
static void | ComponentIdHelper.insert(Any a, int that)
static void | ProfileIdHelper.insert(Any a, int that)
static void | ServiceIdHelper.insert(Any a, int that)
static void | IORHelper.insert(Any a, IOR that)
static void | ServiceContextHelper.insert(Any a, ServiceContext that)
static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)

org.omg.IOP.CodecFactoryPackage 中 Any 的使用

参数类型为 Any 的 org.omg.IOP.CodecFactoryPackage 中的方法
static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)

org.omg.IOP.CodecPackage 中 Any 的使用

参数类型为 Any 的 org.omg.IOP.CodecPackage 中的方法
static FormatMismatch | FormatMismatchHelper.extract(Any a)
static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
static TypeMismatch | TypeMismatchHelper.extract(Any a)
static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)

org.omg.Messaging 中 Any 的使用

参数类型为 Any 的 org.omg.Messaging 中的方法
static short | SyncScopeHelper.extract(Any a)
static void | SyncScopeHelper.insert(Any a, short that)

org.omg.PortableInterceptor 中 Any 的使用

返回 Any 的 org.omg.PortableInterceptor 中的方法
Any | CurrentOperations.get_slot(int id) 检索应用程序通过 get_slot 在 PICurrent 中设置的槽数据。
Any | RequestInfoOperations.get_slot(int id) 返回请求域内 PortableInterceptor.Current 给定槽 (slot) 中的数据。
Any | ClientRequestInfoOperations.received_exception() 返回一个 any，它包含要向客户端返回的异常。
Any | RequestInfoOperations.result() 返回一个 any，它包含该操作调用的结果。
Any | ServerRequestInfoOperations.sending_exception() 返回一个 any，它包含将向客户端返回的异常。

参数类型为 Any 的 org.omg.PortableInterceptor 中的方法
Policy | PolicyFactoryOperations.create_policy(int type, Any value) 返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。
static int | AdapterManagerIdHelper.extract(Any a)
static String[] | AdapterNameHelper.extract(Any a)
static short | AdapterStateHelper.extract(Any a)
static Current | CurrentHelper.extract(Any a)
static ForwardRequest | ForwardRequestHelper.extract(Any a)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
static InvalidSlot | InvalidSlotHelper.extract(Any a)
static String | ORBIdHelper.extract(Any a)
static byte[] | ObjectIdHelper.extract(Any a)
static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
static String | ServerIdHelper.extract(Any a)
static void | ObjectIdHelper.insert(Any a, byte[] that)
static void | CurrentHelper.insert(Any a, Current that)
static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
static void | AdapterManagerIdHelper.insert(Any a, int that)
static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
static void | AdapterStateHelper.insert(Any a, short that)
static void | ORBIdHelper.insert(Any a, String that)
static void | ServerIdHelper.insert(Any a, String that)
static void | AdapterNameHelper.insert(Any a, String[] that)
void | CurrentOperations.set_slot(int id, Any data) 在槽中设置数据。
void | ServerRequestInfoOperations.set_slot(int id, Any data) 允许 Interceptor 在请求域中的 PortableInterceptor.Current 内设置槽 (slot)。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Any 的使用

参数类型为 Any 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static DuplicateName | DuplicateNameHelper.extract(Any a)
static InvalidName | InvalidNameHelper.extract(Any a)
static String | ObjectIdHelper.extract(Any a)
static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
static void | InvalidNameHelper.insert(Any a, InvalidName that)
static void | ObjectIdHelper.insert(Any a, String that)

org.omg.PortableServer 中 Any 的使用

参数类型为 Any 的 org.omg.PortableServer 中的方法
static Current | CurrentHelper.extract(Any a)
static ForwardRequest | ForwardRequestHelper.extract(Any a)
static POA | POAHelper.extract(Any a)
static ServantActivator | ServantActivatorHelper.extract(Any a)
static ServantLocator | ServantLocatorHelper.extract(Any a)
static void | CurrentHelper.insert(Any a, Current that)
static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
static void | POAHelper.insert(Any a, POA that)
static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
static void | ServantLocatorHelper.insert(Any a, ServantLocator that)

org.omg.PortableServer.CurrentPackage 中 Any 的使用

参数类型为 Any 的 org.omg.PortableServer.CurrentPackage 中的方法
static NoContext | NoContextHelper.extract(Any a)
static void | NoContextHelper.insert(Any a, NoContext that)

org.omg.PortableServer.POAManagerPackage 中 Any 的使用

参数类型为 Any 的 org.omg.PortableServer.POAManagerPackage 中的方法
static AdapterInactive | AdapterInactiveHelper.extract(Any a)
static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)

org.omg.PortableServer.POAPackage 中 Any 的使用

参数类型为 Any 的 org.omg.PortableServer.POAPackage 中的方法
static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
static NoServant | NoServantHelper.extract(Any a)
static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
static ServantNotActive | ServantNotActiveHelper.extract(Any a)
static WrongAdapter | WrongAdapterHelper.extract(Any a)
static WrongPolicy | WrongPolicyHelper.extract(Any a)
static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
static void | NoServantHelper.insert(Any a, NoServant that)
static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.AnyHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.AnyHolder
的使用

没有 org.omg.CORBA.AnyHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.AnySeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.AnySeqHelper
的使用

没有 org.omg.CORBA.AnySeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.AnySeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.AnySeqHolder
的使用

使用 AnySeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 AnySeqHolder 的使用

参数类型为 AnySeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_any_array(AnySeqHolder seq, int offset, int length)
从输入流读取 IDL Any 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_CONTEXT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_CONTEXT
的使用

没有 org.omg.CORBA.BAD_CONTEXT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_INV_ORDER 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_INV_ORDER
的使用

使用 BAD_INV_ORDER 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 BAD_INV_ORDER 的使用

抛出 BAD_INV_ORDER 的 org.omg.CORBA 中的方法
Streamable | Any.extract_Streamable() 从此 Any 对象的 value 字段提取 Streamable。
void | Any.insert_fixed(BigDecimal value, TypeCode type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_OPERATION 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_OPERATION
的使用

使用 BAD_OPERATION 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 BAD_OPERATION 的使用

抛出 BAD_OPERATION 的 org.omg.CORBA 中的方法
abstract Any | Any.extract_any() 提取此 Any 对象 value 字段中的 Any 对象。
abstract boolean | Any.extract_boolean() 提取此 Any 对象 value 字段中的 boolean 值。
abstract char | Any.extract_char() 提取此 Any 对象 value 字段中的 char 值。
abstract double | Any.extract_double() 提取此 Any 对象 value 字段中的 double 值。
abstract float | Any.extract_float() 提取此 Any 对象 value 字段中的 float 值。
abstract int | Any.extract_long() 提取此 Any 对象 value 字段中的 int 值。
abstract long | Any.extract_longlong() 提取此 Any 对象 value 字段中的 long 值。
abstract Object | Any.extract_Object() 提取此 Any 对象 value 字段中的 org.omg.CORBA.Object。
abstract byte | Any.extract_octet() 提取此 Any 对象 value 字段中的 byte 值。
Principal | Any.extract_Principal() 已过时。 由 CORBA 2.2 取代。
abstract short | Any.extract_short() 提取此 Any 对象 value 字段中的 short 值。
abstract String | Any.extract_string() 提取此 Any 对象 value 字段中的 String 对象。
abstract TypeCode | Any.extract_TypeCode() 提取此 Any 对象 value 字段中的 TypeCode 对象。
abstract int | Any.extract_ulong() 提取此 Any 对象 value 字段中的 int 值。
abstract long | Any.extract_ulonglong() 提取此 Any 对象 value 字段中的 long 值。
abstract short | Any.extract_ushort() 提取此 Any 对象 value 字段中的 short 值。
abstract Serializable | Any.extract_Value() 提取此 Any 对象 value 字段中的 java.io.Serializable 对象。
abstract char | Any.extract_wchar() 提取此 Any 对象 value 字段中的 char 值。
abstract String | Any.extract_wstring() 提取此 Any 对象 value 字段中的 String 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_PARAM 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_PARAM
的使用

使用 BAD_PARAM 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

org.omg.CORBA 中 BAD_PARAM 的使用

抛出 BAD_PARAM 的 org.omg.CORBA 中的方法
abstract  void Any.insert_Object(Object o, TypeCode t)
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。

org.omg.CORBA_2_3 中 BAD_PARAM 的使用

抛出 BAD_PARAM 的 org.omg.CORBA_2_3 中的方法
 Object ORB.get_value_def(String repid)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.BAD_POLICY 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.BAD_POLICY
的使用

没有 org.omg.CORBA.BAD_POLICY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.BAD_POLICY_TYPE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.BAD_POLICY_TYPE
的使用

没有 org.omg.CORBA.BAD_POLICY_TYPE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.BAD_POLICY_VALUE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.BAD_POLICY_VALUE
的使用

没有 org.omg.CORBA.BAD_POLICY_VALUE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_QOS 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_QOS
的使用

没有 org.omg.CORBA.BAD_QOS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BAD_TYPECODE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BAD_TYPECODE
的使用

没有 org.omg.CORBA.BAD_TYPECODE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BooleanHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BooleanHolder
的使用

没有 org.omg.CORBA.BooleanHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BooleanSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BooleanSeqHelper
的使用

没有 org.omg.CORBA.BooleanSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.BooleanSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.BooleanSeqHolder
的使用

使用 BooleanSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 BooleanSeqHolder 的使用

参数类型为 BooleanSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_boolean_array(BooleanSeqHolder seq, int offset, int length)
从输入流读取 IDL boolean 数组中 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.Bounds 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Bounds
的使用

使用 Bounds 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 Bounds 的使用

抛出 Bounds 的 org.omg.CORBA 中的方法
abstract String | ContextList.item(int index) 返回位于给定索引的 String 对象。
abstract TypeCode | ExceptionList.item(int index) 返回给定索引处的 TypeCode 对象。
abstract NamedValue | NVList.item(int index) 检索给定索引处的 NamedValue 对象。
abstract void | ContextList.remove(int index) 移除给定索引处的 String 对象。
abstract void | ExceptionList.remove(int index) 移除给定索引处的 TypeCode 对象。
abstract void | NVList.remove(int index) 移除位于给定索引处的 NamedValue 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ByteHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ByteHolder
的使用

没有 org.omg.CORBA.ByteHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.CODESET_INCOMPATIBLE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CODESET_INCOMPATIBLE
的使用

没有 org.omg.CORBA.CODESET_INCOMPATIBLE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.COMM_FAILURE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.COMM_FAILURE
的使用

没有 org.omg.CORBA.COMM_FAILURE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.CTX_RESTRICT_SCOPE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.CTX_RESTRICT_SCOPE
的使用

没有 org.omg.CORBA.CTX_RESTRICT_SCOPE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.CharHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CharHolder
的使用

没有 org.omg.CORBA.CharHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.CharSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CharSeqHelper
的使用

没有 org.omg.CORBA.CharSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.CharSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CharSeqHolder
的使用

使用 CharSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 CharSeqHolder 的使用

参数类型为 CharSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_char_array(CharSeqHolder seq, int offset, int length)
从输入流读取 IDL 字符数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.CompletionStatus 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CompletionStatus
的使用

使用 CompletionStatus 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 CompletionStatus 的使用

声明为 CompletionStatus 的 org.omg.CORBA 中的字段
CompletionStatus | SystemException.completed 抛出此异常的操作的状态。
static CompletionStatus | CompletionStatus.COMPLETED_MAYBE 使用常量 _COMPLETED_MAYBE 初始化的 CompletionStatus 实例。
static CompletionStatus | CompletionStatus.COMPLETED_NO 使用常量 _COMPLETED_NO 初始化的 CompletionStatus 实例。
static CompletionStatus | CompletionStatus.COMPLETED_YES 使用常量 _COMPLETED_YES 初始化的 CompletionStatus 实例。

返回 CompletionStatus 的 org.omg.CORBA 中的方法
static CompletionStatus | CompletionStatusHelper.extract(Any a)
static CompletionStatus | CompletionStatus.from_int(int i) 根据给定的 int 创建一个 CompletionStatus 对象。
static CompletionStatus | CompletionStatusHelper.read(InputStream istream)

参数类型为 CompletionStatus 的 org.omg.CORBA 中的方法
static void | CompletionStatusHelper.insert(Any a, CompletionStatus that)
static void | CompletionStatusHelper.write(OutputStream ostream, CompletionStatus value)

参数类型为 CompletionStatus 的 org.omg.CORBA 中的构造方法
ACTIVITY_COMPLETED(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_REQUIRED(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
BAD_CONTEXT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_INV_ORDER(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_OPERATION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_OPERATION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_PARAM(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_PARAM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_QOS(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_TYPECODE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_TYPECODE 异常。
CODESET_INCOMPATIBLE(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
COMM_FAILURE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 COMM_FAILURE 异常。
COMM_FAILURE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 COMM_FAILURE 异常。
DATA_CONVERSION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 DATA_CONVERSION 异常。
FREE_MEM(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 FREE_MEM 异常。
FREE_MEM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 FREE_MEM 异常。
IMP_LIMIT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 IMP_LIMIT 异常。
IMP_LIMIT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 IMP_LIMIT 异常。
INITIALIZE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INITIALIZE 异常。
INITIALIZE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INITIALIZE 异常。
INTERNAL(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INTERNAL 异常。
INTERNAL(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTERNAL 异常。
INTF_REPOS(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INTF_REPOS 异常。
INTF_REPOS(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTF_REPOS 异常。
INV_FLAG(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_FLAG 异常。
INV_FLAG(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_FLAG 异常。
INV_IDENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_IDENT 异常。
INV_IDENT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_IDENT 异常。
INV_OBJREF(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_OBJREF(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_POLICY(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INV_POLICY 异常。
INV_POLICY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 INV_POLICY 异常。
INVALID_ACTIVITY(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_TRANSACTION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
MARSHAL(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 MARSHAL 异常。
MARSHAL(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 MARSHAL 异常。
NO_IMPLEMENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_MEMORY(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_MEMORY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_PERMISSION(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_PERMISSION(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_RESOURCES(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESOURCES(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESPONSE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 NO_RESPONSE 异常。
NO_RESPONSE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESPONSE 异常。
OBJ_ADAPTER(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
OBJECT_NOT_EXIST(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
PERSIST_STORE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 PERSIST_STORE 异常。
PERSIST_STORE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 PERSIST_STORE 异常。
REBIND(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态 (completion status) 构造一个 REBIND 异常。
REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 REBIND 异常。
SystemException(String reason, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 SystemException 异常。
TIMEOUT(int minorCode, CompletionStatus completionStatus)
使用指定次要代码和完成状态构造一个 TIMEOUT 异常。
TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 TIMEOUT 异常。
TRANSACTION_MODE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_REQUIRED(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_ROLLEDBACK(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_UNAVAILABLE(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSIENT(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 TRANSIENT 异常。
TRANSIENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSIENT 异常。
UNKNOWN(int minor, CompletionStatus completed)
使用指定次要代码和完成状态构造一个 UNKNOWN 异常。
UNKNOWN(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 UNKNOWN 异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.CompletionStatusHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CompletionStatusHelper
的使用

没有 org.omg.CORBA.CompletionStatusHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.Context 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Context
的使用

使用 Context 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 Context 的使用

返回 Context 的 org.omg.CORBA 中的方法
abstract Context | Context.create_child(String child_ctx_name) 创建一个 Context 对象，使用给定字符串作为其名称，并将此 Context 对象设置为其父对象。
abstract Context | Request.ctx() 检索用于此请求的 Context 对象。
abstract Context | ServerRequest.ctx() 当操作不是一个属性访问并且该操作的 IDL 定义中包含上下文表达式时，该操作返回用 IDL 指定的上下文信息；否则返回 nil Context 引用。
abstract Context | ORB.get_default_context() 获取默认 Context 对象。
abstract Context | Context.parent() 检索此 Context 对象的父对象。

参数类型为 Context 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
abstract void | Request.ctx(Context c) 将此请求的 Context 对象设置为给定对象。

org.omg.CORBA.portable 中 Context 的使用

返回 Context 的 org.omg.CORBA.portable 中的方法
 Context InputStream.read_Context()
从流中读取一个 CORBA 上下文。

参数类型为 Context 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。
void | OutputStream.write_Context(Context ctx, ContextList contexts) 在此流上写入一个 CORBA 上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ContextList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ContextList
的使用

使用 ContextList 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 ContextList 的使用

返回 ContextList 的 org.omg.CORBA 中的方法
abstract ContextList | Request.contexts() 检索用于此请求的 ContextList 对象。
abstract ContextList | ORB.create_context_list() 创建一个空的 ContextList 对象。

参数类型为 ContextList 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

org.omg.CORBA.portable 中 ContextList 的使用

参数类型为 ContextList 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。
void | OutputStream.write_Context(Context ctx, ContextList contexts) 在此流上写入一个 CORBA 上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.Current 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.Current
的使用

使用 Current 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 Current 的使用

声明为 Current 的 org.omg.CORBA 中的字段
 Current CurrentHolder.value

返回 Current 的 org.omg.CORBA 中的方法
static Current | CurrentHelper.extract(Any a)
Current | ORB.get_current() 已过时。 使用 resolve_initial_references。
static Current | CurrentHelper.narrow(Object obj)
static Current | CurrentHelper.read(InputStream istream)

参数类型为 Current 的 org.omg.CORBA 中的方法
static void | CurrentHelper.insert(Any a, Current that)
static void | CurrentHelper.write(OutputStream ostream, Current value)

参数类型为 Current 的 org.omg.CORBA 中的构造方法
CurrentHolder(Current initialValue)

org.omg.PortableServer 中 Current 的使用

org.omg.PortableServer 中 Current 的子接口
 interface Current
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.CurrentHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CurrentHelper
的使用

没有 org.omg.CORBA.CurrentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.CurrentHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.CurrentHolder
的使用

没有 org.omg.CORBA.CurrentHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.CurrentOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.CurrentOperations
的使用

使用 CurrentOperations 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 CurrentOperations 的使用

org.omg.CORBA 中 CurrentOperations 的子接口
 interface Current
从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。

org.omg.PortableServer 中 CurrentOperations 的使用

org.omg.PortableServer 中 CurrentOperations 的子接口
 interface CurrentOperations
从 CORBA::Current 中派生的 PortableServer::Current 接口，它提供一些能够访问调用方法的对象身份的方法实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.CustomMarshal 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.CustomMarshal
的使用

使用 CustomMarshal 的软件包
org.omg.CORBA.portable 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA.portable 中 CustomMarshal 的使用

org.omg.CORBA.portable 中 CustomMarshal 的子接口
 interface CustomValue
通过自定义值类型实现的 ValueBase 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DATA_CONVERSION 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DATA_CONVERSION
的使用

使用 DATA_CONVERSION 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DATA_CONVERSION 的使用

抛出 DATA_CONVERSION 的 org.omg.CORBA 中的方法
abstract void | Any.insert_char(char c) 将给定 char 值插入此 Any 对象的 value 字段。
abstract void | Any.insert_string(String s) 将给定 String 对象插入此 Any 对象的 value 字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DataInputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DataInputStream
的使用

使用 DataInputStream 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DataInputStream 的使用

参数类型为 DataInputStream 的 org.omg.CORBA 中的方法
 void CustomMarshal.unmarshal(DataInputStream is)
必须通过自定义的 Marshal 类实现 unmarshal 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DataOutputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DataOutputStream
的使用

使用 DataOutputStream 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DataOutputStream 的使用

参数类型为 DataOutputStream 的 org.omg.CORBA 中的方法
 void CustomMarshal.marshal(DataOutputStream os)
必须通过自定义的 Marshal 类实现 marshal 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DefinitionKind 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DefinitionKind
的使用

使用 DefinitionKind 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DefinitionKind 的使用

声明为 DefinitionKind 的 org.omg.CORBA 中的字段
static DefinitionKind | DefinitionKind.dk_AbstractInterface 指示 Interface Repository 对象表示一个抽象接口的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Alias 指示 Interface Repository 对象是一个 Alias 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_all 通配符 DefinitionKind 常量，可用于 DefinitionKind 适合的所有情况。
static DefinitionKind | DefinitionKind.dk_Array 指示 Interface Repository 对象是一个 Array 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Attribute 指示 Interface Repository 对象是一个 Attribute 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Constant 指示 Interface Repository 对象是一个常量的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Enum 指示 Interface Repository 对象是一个 Enum 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Exception 指示 Interface Repository 对象是一个 Exception 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Fixed 指示 Interface Repository 对象是一个 Fixed value 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Interface 指示 Interface Repository 对象是一个 Interface 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Module 指示 Interface Repository 对象是一个 Module 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Native 指示 Interface Repository 对象是一个 Native value 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_none 指示 Interface Repository 对象不具有任何定义种类的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Operation 指示 Interface Repository 对象是一个 Operation 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Primitive 指示 Interface Repository 对象是一个 Primitive 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Repository 指示 Interface Repository 对象是一个 Repository 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Sequence 指示 Interface Repository 对象是一个 Sequence 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_String 指示 Interface Repository 对象是一个 String 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Struct 指示 Interface Repository 对象是一个 Struct 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Typedef 指示 Interface Repository 对象是一个 Typedef 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Union 指示 Interface Repository 对象是一个 Union 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Value 指示 Interface Repository 对象是一个 Value 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_ValueBox 指示 Interface Repository 对象是一个 ValueBox 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_ValueMember 指示 Interface Repository 对象是一个 ValueMember 的静态 DefinitionKind 实例。
static DefinitionKind | DefinitionKind.dk_Wstring 指示 Interface Repository 对象是一个 Wstring 的静态 DefinitionKind 实例。

返回 DefinitionKind 的 org.omg.CORBA 中的方法
DefinitionKind | IRObjectOperations.def_kind() 返回对应于此接口存储库对象的 DefinitionKind。
DefinitionKind | _IDLTypeStub.def_kind()
static DefinitionKind | DefinitionKindHelper.extract(Any a)
static DefinitionKind | DefinitionKind.from_int(int i) 创建一个对应于给定代码的 DefinitionKind 实例。
static DefinitionKind | DefinitionKindHelper.read(InputStream istream)

参数类型为 DefinitionKind 的 org.omg.CORBA 中的方法
static void | DefinitionKindHelper.insert(Any a, DefinitionKind that)
static void | DefinitionKindHelper.write(OutputStream ostream, DefinitionKind value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DefinitionKindHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DefinitionKindHelper
的使用

没有 org.omg.CORBA.DefinitionKindHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DomainManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DomainManager
的使用

使用 DomainManager 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 DomainManager 的使用

返回 DomainManager 的 org.omg.CORBA 中的方法
DomainManager[] | LocalObject._get_domain_managers() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
DomainManager[] | Object._get_domain_managers() 检索此对象的 DomainManager。

org.omg.CORBA.portable 中 DomainManager 的使用

返回 DomainManager 的 org.omg.CORBA.portable 中的方法
DomainManager[] | ObjectImpl._get_domain_managers() 获得此 ObjectImpl 对象的域管理程序所组成的列表。
DomainManager[] | Delegate.get_domain_managers(Object self) 检索此对象的 DomainManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DomainManagerOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DomainManagerOperations
的使用

使用 DomainManagerOperations 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DomainManagerOperations 的使用

org.omg.CORBA 中 DomainManagerOperations 的子接口
 interface DomainManager
提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DoubleHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DoubleHolder
的使用

没有 org.omg.CORBA.DoubleHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DoubleSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DoubleSeqHelper
的使用

没有 org.omg.CORBA.DoubleSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DoubleSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DoubleSeqHolder
的使用

使用 DoubleSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DoubleSeqHolder 的使用

参数类型为 DoubleSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_double_array(DoubleSeqHolder seq, int offset, int length)
从输入流读取 IDL double 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DynAny 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynAny
的使用

使用 DynAny 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynAny 的使用

org.omg.CORBA 中 DynAny 的子接口
interface | DynArray 已过时。 使用新的 DynArray 替代
interface | DynEnum 已过时。 使用新的 DynEnum 替代
interface | DynFixed 已过时。 使用新的 DynFixed 替代
interface | DynSequence 已过时。 使用新的 DynSequence 替代
interface | DynStruct 已过时。 使用新的 DynStruct 替代
interface | DynUnion 已过时。 使用新的 DynUnion 替代
interface | DynValue 已过时。 使用新的 DynValue 替代

返回 DynAny 的 org.omg.CORBA 中的方法
DynAny | DynAny.copy() 已过时。 克隆此 DynAny 对象。
DynAny | ORB.create_basic_dyn_any(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynAny | ORB.create_dyn_any(Any value) 已过时。 使用新的 DynAnyFactory API 代替
DynAny | DynAny.current_component() 已过时。 返回一个 DynAny 对象引用，可用来获取/设置当前所访问组件的值。
DynAny | DynUnion.discriminator() 已过时。 返回一个 DynAny 对象引用，为了插入/获取鉴别符值，必须将该对象收缩为该鉴别符的类型。
DynAny | DynUnion.member() 已过时。 返回为了插入/获取此 union 成员而使用的 DynAny 对象引用。

参数类型为 DynAny 的 org.omg.CORBA 中的方法
 void DynAny.assign(DynAny dyn_any)
已过时。 将内容从一个 Dynamic Any 复制到另一个 Dynamic Any 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DynArray 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynArray
的使用

使用 DynArray 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynArray 的使用

返回 DynArray 的 org.omg.CORBA 中的方法
 DynArray ORB.create_dyn_array(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DynEnum 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynEnum
的使用

使用 DynEnum 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynEnum 的使用

返回 DynEnum 的 org.omg.CORBA 中的方法
 DynEnum ORB.create_dyn_enum(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DynFixed 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynFixed
的使用

没有 org.omg.CORBA.DynFixed 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DynSequence 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynSequence
的使用

使用 DynSequence 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynSequence 的使用

返回 DynSequence 的 org.omg.CORBA 中的方法
 DynSequence ORB.create_dyn_sequence(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DynStruct 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynStruct
的使用

使用 DynStruct 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynStruct 的使用

返回 DynStruct 的 org.omg.CORBA 中的方法
 DynStruct ORB.create_dyn_struct(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DynUnion 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynUnion
的使用

使用 DynUnion 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 DynUnion 的使用

返回 DynUnion 的 org.omg.CORBA 中的方法
 DynUnion ORB.create_dyn_union(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.DynValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.DynValue
的使用

没有 org.omg.CORBA.DynValue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.DynamicImplementation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.DynamicImplementation
的使用

使用 DynamicImplementation 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 DynamicImplementation 的使用

org.omg.CosNaming 中 DynamicImplementation 的子类
class | _BindingIteratorImplBase
class | _NamingContextImplBase

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.Environment 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Environment
的使用

使用 Environment 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 Environment 的使用

返回 Environment 的 org.omg.CORBA 中的方法
abstract Environment | ORB.create_environment() 创建一个 Environment 对象。
abstract Environment | Request.env() 检索用于此请求的 Environment 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ExceptionList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ExceptionList
的使用

使用 ExceptionList 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 ExceptionList 的使用

返回 ExceptionList 的 org.omg.CORBA 中的方法
abstract ExceptionList | ORB.create_exception_list() 创建一个空的 ExceptionList 对象。
abstract ExceptionList | Request.exceptions() 检索用于此请求的 ExceptionList 对象。

参数类型为 ExceptionList 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

org.omg.CORBA.portable 中 ExceptionList 的使用

参数类型为 ExceptionList 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.FREE_MEM 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FREE_MEM
的使用

没有 org.omg.CORBA.FREE_MEM 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.FieldNameHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FieldNameHelper
的使用

没有 org.omg.CORBA.FieldNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.FixedHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FixedHolder
的使用

没有 org.omg.CORBA.FixedHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.FloatHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FloatHolder
的使用

没有 org.omg.CORBA.FloatHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.FloatSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FloatSeqHelper
的使用

没有 org.omg.CORBA.FloatSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.FloatSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.FloatSeqHolder
的使用

使用 FloatSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 FloatSeqHolder 的使用

参数类型为 FloatSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_float_array(FloatSeqHolder seq, int offset, int length)
从输入流读取 IDL float 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.IDLType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.IDLType
的使用

使用 IDLType 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 IDLType 的使用

实现 IDLType 的 org.omg.CORBA 中的类
 class _IDLTypeStub
IDLType 的 Stub。

声明为 IDLType 的 org.omg.CORBA 中的字段
IDLType | StructMember.type_def typedef，它表示此 StructMember 对象所描述的 struct 成员的 IDL 类型。
IDLType | UnionMember.type_def typedef，它表示此 UnionMember 对象描述的 union 成员的 IDL 类型。
IDLType | ValueMember.type_def typedef，它表示此 ValueMember 对象描述的 value 成员的 IDL 类型。

返回 IDLType 的 org.omg.CORBA 中的方法
static IDLType | IDLTypeHelper.extract(Any a)
static IDLType | IDLTypeHelper.narrow(Object obj)
static IDLType | IDLTypeHelper.read(InputStream istream)

参数类型为 IDLType 的 org.omg.CORBA 中的方法
static void | IDLTypeHelper.insert(Any a, IDLType that)
static void | IDLTypeHelper.write(OutputStream ostream, IDLType value)

参数类型为 IDLType 的 org.omg.CORBA 中的构造方法
StructMember(String __name, TypeCode __type, IDLType __type_def)
构造一个 StructMember 对象，并使用给定值进行初始化。
UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
构造一个 ValueMember 对象，使用给定值进行初始化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.IDLTypeHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.IDLTypeHelper
的使用

没有 org.omg.CORBA.IDLTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.IDLTypeOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.IDLTypeOperations
的使用

使用 IDLTypeOperations 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 IDLTypeOperations 的使用

org.omg.CORBA 中 IDLTypeOperations 的子接口
 interface IDLType
由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。

实现 IDLTypeOperations 的 org.omg.CORBA 中的类
 class _IDLTypeStub
IDLType 的 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.IMP_LIMIT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.IMP_LIMIT
的使用

没有 org.omg.CORBA.IMP_LIMIT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INITIALIZE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INITIALIZE
的使用

没有 org.omg.CORBA.INITIALIZE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INTERNAL 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INTERNAL
的使用

没有 org.omg.CORBA.INTERNAL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INTF_REPOS 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INTF_REPOS
的使用

没有 org.omg.CORBA.INTF_REPOS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INVALID_ACTIVITY 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INVALID_ACTIVITY
的使用

没有 org.omg.CORBA.INVALID_ACTIVITY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INVALID_TRANSACTION 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INVALID_TRANSACTION
的使用

没有 org.omg.CORBA.INVALID_TRANSACTION 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INV_FLAG 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INV_FLAG
的使用

没有 org.omg.CORBA.INV_FLAG 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INV_IDENT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INV_IDENT
的使用

没有 org.omg.CORBA.INV_IDENT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INV_OBJREF 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INV_OBJREF
的使用

没有 org.omg.CORBA.INV_OBJREF 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.INV_POLICY 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.INV_POLICY
的使用

没有 org.omg.CORBA.INV_POLICY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.IRObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.IRObject
的使用

使用 IRObject 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 IRObject 的使用

org.omg.CORBA 中 IRObject 的子接口
 interface IDLType
由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。

实现 IRObject 的 org.omg.CORBA 中的类
 class _IDLTypeStub
IDLType 的 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.IRObjectOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.IRObjectOperations
的使用

使用 IRObjectOperations 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 IRObjectOperations 的使用

org.omg.CORBA 中 IRObjectOperations 的子接口
interface | IDLType 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
interface | IDLTypeOperations 此接口必须由所有 IDLType 对象实现。
interface | IRObject IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。

实现 IRObjectOperations 的 org.omg.CORBA 中的类
 class _IDLTypeStub
IDLType 的 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.IdentifierHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.IdentifierHelper
的使用

没有 org.omg.CORBA.IdentifierHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.IntHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.IntHolder
的使用

没有 org.omg.CORBA.IntHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.LocalObject 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LocalObject
的使用

没有 org.omg.CORBA.LocalObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.LongHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongHolder
的使用

没有 org.omg.CORBA.LongHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.LongLongSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongLongSeqHelper
的使用

没有 org.omg.CORBA.LongLongSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.LongLongSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongLongSeqHolder
的使用

使用 LongLongSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 LongLongSeqHolder 的使用

参数类型为 LongLongSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_longlong_array(LongLongSeqHolder seq, int offset, int length)
从输入流读取 IDL long long 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.LongSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongSeqHelper
的使用

没有 org.omg.CORBA.LongSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.LongSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.LongSeqHolder
的使用

使用 LongSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 LongSeqHolder 的使用

参数类型为 LongSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_long_array(LongSeqHolder seq, int offset, int length)
从输入流读取 IDL long 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.MARSHAL 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.MARSHAL
的使用

使用 MARSHAL 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 MARSHAL 的使用

抛出 MARSHAL 的 org.omg.CORBA 中的方法
abstract void | Any.insert_string(String s) 将给定 String 对象插入此 Any 对象的 value 字段。
abstract void | Any.insert_Value(Serializable v, TypeCode t) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
abstract void | Any.insert_wstring(String s) 将给定 String 对象插入此 Any 对象的 value 字段。
abstract void | Any.read_value(InputStream is, TypeCode t) 使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NO_IMPLEMENT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_IMPLEMENT
的使用

没有 org.omg.CORBA.NO_IMPLEMENT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NO_MEMORY 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_MEMORY
的使用

没有 org.omg.CORBA.NO_MEMORY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NO_PERMISSION 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_PERMISSION
的使用

没有 org.omg.CORBA.NO_PERMISSION 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NO_RESOURCES 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_RESOURCES
的使用

没有 org.omg.CORBA.NO_RESOURCES 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NO_RESPONSE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NO_RESPONSE
的使用

没有 org.omg.CORBA.NO_RESPONSE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NVList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NVList
的使用

使用 NVList 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 NVList 的使用

返回 NVList 的 org.omg.CORBA 中的方法
abstract NVList | Request.arguments() 检索包含将被调用方法的参数的 NVList 对象。
abstract NVList | ORB.create_list(int count) 为指定数量的 NamedValue 对象分配具有（可能）足够空间的 NVList。
NVList | ORB.create_operation_list(Object oper) 创建一个 NVList，并使用给定 OperationDef 对象中所述操作的参数描述进行初始化。
abstract NVList | Context.get_values(String start_scope, int op_flags, String pattern) 检索 name 字段与给定名称或名称模式匹配的 NamedValue 对象。

参数类型为 NVList 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
void | ServerRequest.arguments(NVList args) 指定方法参数类型并检索 "in" 和 "inout" 参数值。
void | ServerRequest.params(NVList params) 已过时。 使用方法 arguments
abstract void | Context.set_values(NVList values) 在此 Context 对象中设置一个或多个属性值。

org.omg.CORBA.portable 中 NVList 的使用

参数类型为 NVList 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NameValuePair 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NameValuePair
的使用

使用 NameValuePair 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 NameValuePair 的使用

返回 NameValuePair 的 org.omg.CORBA 中的方法
static NameValuePair | NameValuePairHelper.extract(Any a)
NameValuePair[] | DynStruct.get_members() 已过时。 返回包含所有已存储 struct 成员的数组。
NameValuePair[] | DynValue.get_members() 已过时。 返回一个数组，它包含存储在此 DynValue 中 value 对象的所有成员。
static NameValuePair | NameValuePairHelper.read(InputStream istream)

参数类型为 NameValuePair 的 org.omg.CORBA 中的方法
static void | NameValuePairHelper.insert(Any a, NameValuePair that)
void | DynStruct.set_members(NameValuePair[] value) 已过时。 设置 struct 的成员。
void | DynValue.set_members(NameValuePair[] value) 已过时。 将此 DynValue 对象表示的 value 对象成员设置为给定的 NameValuePair 对象数组。
static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NameValuePairHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NameValuePairHelper
的使用

没有 org.omg.CORBA.NameValuePairHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.NamedValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.NamedValue
的使用

使用 NamedValue 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 NamedValue 的使用

返回 NamedValue 的 org.omg.CORBA 中的方法
abstract NamedValue | NVList.add_item(String item_name, int flags) 创建一个新的 NamedValue 对象，使用给定名称和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract NamedValue | NVList.add_value(String item_name, Any val, int flags) 创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract NamedValue | NVList.add(int flags) 创建一个新的 NamedValue 对象，使用给定标志初始化该对象，并将它添加到此 NVList 对象的末尾。
abstract NamedValue | ORB.create_named_value(String s, Any any, int flags) 使用给定名称、值和参数模式标志创建一个 NamedValue 对象。
abstract NamedValue | NVList.item(int index) 检索给定索引处的 NamedValue 对象。
abstract NamedValue | Request.result() 检索包含该方法的返回值的 NamedValue 对象。

参数类型为 NamedValue 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

org.omg.CORBA.portable 中 NamedValue 的使用

参数类型为 NamedValue 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.OBJECT_NOT_EXIST 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.OBJECT_NOT_EXIST
的使用

没有 org.omg.CORBA.OBJECT_NOT_EXIST 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.OBJ_ADAPTER 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.OBJ_ADAPTER
的使用

没有 org.omg.CORBA.OBJ_ADAPTER 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.OMGVMCID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.OMGVMCID
的使用

没有 org.omg.CORBA.OMGVMCID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ORB 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ORB
的使用

使用 ORB 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

javax.rmi.CORBA 中 ORB 的使用

返回 ORB 的 javax.rmi.CORBA 中的方法
 ORB Tie.orb()
返回此 tie 的 ORB。

参数类型为 ORB 的 javax.rmi.CORBA 中的方法
 void Stub.connect(ORB orb)
将此 stub 连接到 ORB。
 void StubDelegate.connect(Stub self, ORB orb)
Stub.connect(org.omg.CORBA.ORB) 的委托调用。
static Object Util.copyObject(Object obj, ORB orb)
复制或连接一个对象。
 Object UtilDelegate.copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。
static Object[] Util.copyObjects(Object[] obj, ORB orb)
复制或连接一个对象数组。
 Object[] UtilDelegate.copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。
 void Tie.orb(ORB orb)
设置此 tie 的 ORB。

org.omg.CORBA 中 ORB 的使用

返回 ORB 的 org.omg.CORBA 中的方法
ORB | LocalObject._orb() 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
static ORB | ORB.init() 返回对象 ORB 单件。
static ORB | ORB.init(Applet app, Properties props) 为 applet 创建一个新的 ORB 实例。
static ORB | ORB.init(String[] args, Properties props) 为独立的应用程序创建一个新的 ORB 实例。

org.omg.CORBA_2_3 中 ORB 的使用

org.omg.CORBA_2_3 中 ORB 的子类
 class ORB
扩展了 org.omg.CORBA.ORB 的类，使 ORB 在 OMG CORBA 规范 2.3 版下可移植。

org.omg.CORBA.portable 中 ORB 的使用

返回 ORB 的 org.omg.CORBA.portable 中的方法
ORB | ObjectImpl._orb() 返回对与此对象及其委托相关的 ORB 的引用。
ORB | InputStream.orb() 返回创建此 InputStream 的 ORB。
ORB | OutputStream.orb() 返回创建此 OutputStream 的 ORB。
ORB | Delegate.orb(Object obj) 提供对与其参数关联的 orb 的引用。

org.omg.CosNaming 中 ORB 的使用

参数类型为 ORB 的 org.omg.CosNaming 中的方法
BindingIterator | BindingIteratorPOA._this(ORB orb)
NamingContextExt | NamingContextExtPOA._this(ORB orb)
NamingContext | NamingContextPOA._this(ORB orb)

org.omg.PortableServer 中 ORB 的使用

返回 ORB 的 org.omg.PortableServer 中的方法
 ORB Servant._orb()
返回当前与 Servant 关联的 ORB 实例（便捷方法）。

参数类型为 ORB 的 org.omg.PortableServer 中的方法
Object | Servant._this_object(ORB orb) 允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
ServantActivator | ServantActivatorPOA._this(ORB orb)
ServantLocator | ServantLocatorPOA._this(ORB orb)

org.omg.PortableServer.portable 中 ORB 的使用

返回 ORB 的 org.omg.PortableServer.portable 中的方法
 ORB Delegate.orb(Servant Self)
返回当前关联 Servant 的 ORB 实例的便捷方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.Object 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.Object
的使用

使用 Object 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.SendingContext | 为值类型的编组提供支持。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 中 Object 的使用

实现 Object 的 javax.rmi.CORBA 中的类
 class Stub
必须从其继承所有 RMI-IIOP stub 的基类。

返回 Object 的 javax.rmi.CORBA 中的方法
 Object Tie.thisObject()
返回此 tie 表示的目标对象的对象引用。

org.omg.CORBA 中 Object 的使用

org.omg.CORBA 中 Object 的子接口
interface | Current 从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
interface | DomainManager 提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
interface | DynAny 已过时。 使用新的 DynAny 替代
interface | DynArray 已过时。 使用新的 DynArray 替代
interface | DynEnum 已过时。 使用新的 DynEnum 替代
interface | DynFixed 已过时。 使用新的 DynFixed 替代
interface | DynSequence 已过时。 使用新的 DynSequence 替代
interface | DynStruct 已过时。 使用新的 DynStruct 替代
interface | DynUnion 已过时。 使用新的 DynUnion 替代
interface | DynValue 已过时。 使用新的 DynValue 替代
interface | IDLType 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
interface | IRObject IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
interface | Policy 派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。

实现 Object 的 org.omg.CORBA 中的类
class | _IDLTypeStub IDLType 的 Stub。
class | _PolicyStub Policy 的 Stub。
class | DynamicImplementation 已过时。 org.omg.CORBA.DynamicImplementation
class | LocalObject 用作 Java 语言映射中的本地 IDL 接口实现的基本类。

声明为 Object 的 org.omg.CORBA 中的字段
 Object ObjectHolder.value
此 ObjectHolder 对象保存的 Object 值。

返回 Object 的 org.omg.CORBA 中的方法
 Object LocalObject._duplicate()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
 Object Object._duplicate()
返回此 CORBA 对象引用的副本。
 Object LocalObject._get_interface_def()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
 Object Object._get_interface_def()
获取此对象引用所引用的对象实现的 InterfaceDef。
 Object LocalObject._get_interface()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
 Object LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
 Object Object._set_policy_override(Policy[] policies, SetOverrideType set_add)
返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。
abstract  Object Any.extract_Object()
提取此 Any 对象 value 字段中的 org.omg.CORBA.Object。
static Object ObjectHelper.extract(Any a)
 Object DynAny.get_reference()
已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Other。
 Object DataInputStream.read_Object()
从输入流读取 IDL CORBA::Object。
static Object ObjectHelper.read(InputStream istream)
abstract  Object ORB.resolve_initial_references(String object_name)
根据可用初始服务名称集解析特定对象引用。
abstract  Object ORB.string_to_object(String str)
将方法 object_to_string 生成的字符串转换回 CORBA 对象引用。
abstract  Object Request.target()
检索目标对象引用。

参数类型为 Object 的 org.omg.CORBA 中的方法
 boolean LocalObject._is_equivalent(Object that)
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
 boolean Object._is_equivalent(Object other)
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
 void ORB.connect(Object obj)
将给定 servant 对象（作为服务器实现类的实例的 Java 对象）连接到 ORB。
 NVList ORB.create_operation_list(Object oper)
创建一个 NVList，并使用给定 OperationDef 对象中所述操作的参数描述进行初始化。
 void ORB.disconnect(Object obj)
断开给定 servant 对象与 ORB 的连接。
abstract  void Any.insert_Object(Object o)
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
abstract  void Any.insert_Object(Object o, TypeCode t)
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
 void DynAny.insert_reference(Object value)
已过时。 插入给定 org.omg.CORBA.Object 作为此 DynAny 对象的值。
static void ObjectHelper.insert(Any a, Object that)
static Current CurrentHelper.narrow(Object obj)
static IDLType IDLTypeHelper.narrow(Object obj)
static Policy PolicyHelper.narrow(Object obj)
abstract  String ORB.object_to_string(Object obj)
将给定 CORBA 对象引用转换为字符串。
 void DataOutputStream.write_Object(Object value)
将 IDL CORBA::Object 值写入输出流。
static void ObjectHelper.write(OutputStream ostream, Object value)

参数类型为 Object 的 org.omg.CORBA 中的构造方法
ObjectHolder(Object initial)
构造一个新的 ObjectHolder 对象，并使用给定 Object 初始化其 value 字段。

org.omg.CORBA_2_3 中 Object 的使用

返回 Object 的 org.omg.CORBA_2_3 中的方法
 Object ORB.get_value_def(String repid)

org.omg.CORBA_2_3.portable 中 Object 的使用

参数类型为 Object 的 org.omg.CORBA_2_3.portable 中的方法
 String Delegate.get_codebase(Object self)
返回提供的对象引用的代码基。

org.omg.CORBA.portable 中 Object 的使用

实现 Object 的 org.omg.CORBA.portable 中的类
 class ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。

返回 Object 的 org.omg.CORBA.portable 中的方法
Object | ObjectImpl._duplicate() 返回此 ObjectImpl 对象的一个副本。
Object | ObjectImpl._get_interface_def() 获得此 ObjectImpl 对象的接口定义。
Object | ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add) 将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
abstract Object | Delegate.duplicate(Object obj) 返回所提供对象引用的复本。
abstract Object | Delegate.get_interface_def(Object self) 返回一个所提供对象引用的 InterfaceDef。
abstract Object | InputStream.read_Object() 从此输入流中读取一个 CORBA 对象。
Object | InputStream.read_Object(Class clz) 取消对象的编组并返回一个 CORBA Object，该对象是作为参数传递的类的实例。
Object | Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add) 将传入的策略与它返回的新创建对象引用关联。

参数类型为 Object 的 org.omg.CORBA.portable 中的方法
 boolean ObjectImpl._is_equivalent(Object that)
检查给定的 ObjectImpl 对象是否等于此 ObjectImpl 对象。
abstract  Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
创建在动态调用接口中使用的 Request 实例。
abstract  Request Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
创建在动态调用接口中使用的 Request 实例。
abstract  Object Delegate.duplicate(Object obj)
返回所提供对象引用的复本。
 boolean Delegate.equals(Object self, Object obj)
提供重写委托 CORBA 对象方法 equals(java.lang.Object obj) 的实现。
 DomainManager[] Delegate.get_domain_managers(Object self)
检索此对象的 DomainManager。
abstract  Object Delegate.get_interface_def(Object self)
返回一个所提供对象引用的 InterfaceDef。
 Policy Delegate.get_policy(Object self, int policy_type)
返回应用于此对象的指定类型的 Policy 对象。
abstract  int Delegate.hash(Object obj, int max)
返回此对象引用的内部 ORB 标识符（哈希码）。
 int Delegate.hashCode(Object self)
提供重写委托 CORBA 对象的 hashCode() 方法的实现。
 InputStream Delegate.invoke(Object self, OutputStream output)
由 stub 调用，以调用一个操作。
abstract  boolean Delegate.is_a(Object obj, String repository_id)
检查对象引用是否是给定接口的实例。
abstract  boolean Delegate.is_equivalent(Object obj, Object other)
确定两个对象引用是否相等。
 boolean Delegate.is_local(Object self)
如果此对象由本地 servant 实现，则返回 true。
abstract  boolean Delegate.non_existent(Object obj)
确定对象引用的服务器对象是否已经被销毁。
 ORB Delegate.orb(Object obj)
提供对与其参数关联的 orb 的引用。
abstract  void Delegate.release(Object obj)
发布与所提供对象引用关联的资源。
 void Delegate.releaseReply(Object self, InputStream input)
releaseReply 可以由 stub 以可选方式调用，以在解组完成时将应答流释放回 ORB。
abstract  Request Delegate.request(Object obj, String operation)
创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
 OutputStream Delegate.request(Object self, String operation, boolean responseExpected)
request 由 stub 调用，以获取用于编组参数的 OutputStream。
 void Delegate.servant_postinvoke(Object self, ServantObject servant)
servant_postinvoke() 由本地 stub 在已经对本地 servant 调用该操作之后调用。
 ServantObject Delegate.servant_preinvoke(Object self, String operation, Class expectedType)
返回对应该用作此请求的 servant 的 Java 引用。
 Object Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add)
将传入的策略与它返回的新创建对象引用关联。
 String Delegate.toString(Object self)
提供重写委托 CORBA 对象的 toString() 方法的实现。
abstract  void OutputStream.write_Object(Object value)
在此输入流上写入一个 CORBA Object。

org.omg.CosNaming 中 Object 的使用

org.omg.CosNaming 中 Object 的子接口
interface | BindingIterator BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
interface | NamingContext 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
interface | NamingContextExt NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 Object 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

返回 Object 的 org.omg.CosNaming 中的方法
Object | NamingContextExtOperations.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | _NamingContextExtStub.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。

参数类型为 Object 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
static BindingIterator | BindingIteratorHelper.narrow(Object obj)
static NamingContextExt | NamingContextExtHelper.narrow(Object obj)
static NamingContext | NamingContextHelper.narrow(Object obj)
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
static BindingIterator | BindingIteratorHelper.unchecked_narrow(Object obj)
static NamingContextExt | NamingContextExtHelper.unchecked_narrow(Object obj)
static NamingContext | NamingContextHelper.unchecked_narrow(Object obj)

org.omg.DynamicAny 中 Object 的使用

org.omg.DynamicAny 中 Object 的子接口
interface | DynAnyFactory DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

实现 Object 的 org.omg.DynamicAny 中的类
class | _DynAnyFactoryStub DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。

返回 Object 的 org.omg.DynamicAny 中的方法
Object | DynAnyOperations.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynAnyStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynArrayStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynEnumStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynFixedStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynSequenceStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynStructStub.get_reference() 从此 DynAny 析取对 CORBA 对象的引用。
Object | _DynUnionStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynValueStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。

参数类型为 Object 的 org.omg.DynamicAny 中的方法
void | DynAnyOperations.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynAnyStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynArrayStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynEnumStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynFixedStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynSequenceStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynStructStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynUnionStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynValueStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
static DynAnyFactory | DynAnyFactoryHelper.narrow(Object obj)
static DynAny | DynAnyHelper.narrow(Object obj)
static DynArray | DynArrayHelper.narrow(Object obj)
static DynEnum | DynEnumHelper.narrow(Object obj)
static DynFixed | DynFixedHelper.narrow(Object obj)
static DynSequence | DynSequenceHelper.narrow(Object obj)
static DynStruct | DynStructHelper.narrow(Object obj)
static DynUnion | DynUnionHelper.narrow(Object obj)
static DynValue | DynValueHelper.narrow(Object obj)
static DynAnyFactory | DynAnyFactoryHelper.unchecked_narrow(Object obj)
static DynAny | DynAnyHelper.unchecked_narrow(Object obj)
static DynArray | DynArrayHelper.unchecked_narrow(Object obj)
static DynEnum | DynEnumHelper.unchecked_narrow(Object obj)
static DynFixed | DynFixedHelper.unchecked_narrow(Object obj)
static DynSequence | DynSequenceHelper.unchecked_narrow(Object obj)
static DynStruct | DynStructHelper.unchecked_narrow(Object obj)
static DynUnion | DynUnionHelper.unchecked_narrow(Object obj)
static DynValue | DynValueHelper.unchecked_narrow(Object obj)

org.omg.IOP 中 Object 的使用

org.omg.IOP 中 Object 的子接口
interface | Codec IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
interface | CodecFactory Codec 可从 CodecFactory 中获得。

参数类型为 Object 的 org.omg.IOP 中的方法
static CodecFactory | CodecFactoryHelper.narrow(Object obj)
static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)

org.omg.PortableInterceptor 中 Object 的使用

org.omg.PortableInterceptor 中 Object 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ClientRequestInterceptor 客户端 interceptor。
interface | Interceptor 所有 Portable Interceptor 实现 Interceptor。
interface | IORInfo 提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | ORBInitializer 便于注册 interceptor 和初始化 ORB。
interface | ORBInitInfo 传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
interface | PolicyFactory 使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
interface | RequestInfo Interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。

声明为 Object 的 org.omg.PortableInterceptor 中的字段
 Object ForwardRequest.forward
将请求转发到的新对象。

返回 Object 的 org.omg.PortableInterceptor 中的方法
Object | ClientRequestInfoOperations.effective_target() 返回实际调用操作的对象。
Object | RequestInfoOperations.forward_reference() 如果 reply_status 属性为 LOCATION_FORWARD，则包含要将请求转发到的对象。
Object | ObjectReferenceFactory.make_object(String repositoryId, byte[] object_id) make_object 根据此模板中的数据，使用给定的存储库 ID 和对象 ID 创建 CORBA 对象引用。
Object | ORBInitInfoOperations.resolve_initial_references(String id) 等同于 ORB.resolve_initial_references。
Object | ClientRequestInfoOperations.target() 返回客户端调用以执行操作的对象。

参数类型为 Object 的 org.omg.PortableInterceptor 中的方法
static Current | CurrentHelper.narrow(Object obj)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
void | ORBInitInfoOperations.register_initial_reference(String id, Object obj) 等同于 ORB.register_initial_reference。
static Current | CurrentHelper.unchecked_narrow(Object obj)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)

参数类型为 Object 的 org.omg.PortableInterceptor 中的构造方法
ForwardRequest(Object _forward)
ForwardRequest(String $reason, Object _forward)

org.omg.PortableServer 中 Object 的使用

org.omg.PortableServer 中 Object 的子接口
interface | AdapterActivator 一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | POA POA 对象管理对象集合的实现。
interface | POAManager 每个 POA 对象都有一个关联的 POAManager 对象。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantManager servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

实现 Object 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

声明为 Object 的 org.omg.PortableServer 中的字段
 Object ForwardRequest.forward_reference

返回 Object 的 org.omg.PortableServer 中的方法
 Object Servant._get_interface_def()
以 CORBA::Object 的形式返回 InterfaceDef 对象，该对象定义由 Servant 实现的 CORBA::Object 的运行时类型。
 Object Servant._this_object()
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
 Object Servant._this_object(ORB orb)
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
 Object POAOperations.create_reference_with_id(byte[] oid, String intf)
此操作创建一个对象引用，该引用封装指定的 Object Id 和接口存储库 Id 值。
 Object POAOperations.create_reference(String intf)
此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。
 Object POAOperations.id_to_reference(byte[] oid)
如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
 Object POAOperations.servant_to_reference(Servant p_servant)
如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。

参数类型为 Object 的 org.omg.PortableServer 中的方法
static Current | CurrentHelper.narrow(Object obj)
static POA | POAHelper.narrow(Object obj)
static ServantActivator | ServantActivatorHelper.narrow(Object obj)
static ServantLocator | ServantLocatorHelper.narrow(Object obj)
byte[] | POAOperations.reference_to_id(Object reference) 此操作返回指定引用封装的 Object Id 值。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)
static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)

参数类型为 Object 的 org.omg.PortableServer 中的构造方法
ForwardRequest(Object _forward_reference)
ForwardRequest(String $reason, Object _forward_reference)

org.omg.PortableServer.portable 中 Object 的使用

返回 Object 的 org.omg.PortableServer.portable 中的方法
Object | Delegate.get_interface_def(Servant self) 此操作返回接口 Repository 中的一个对象，该对象提供可能对编程有用的类型信息。
Object | Delegate.this_object(Servant Self) 此方法允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。

org.omg.SendingContext 中 Object 的使用

org.omg.SendingContext 中 Object 的子接口
 interface RunTime
定义表示请求的发送上下文的基类。

org.omg.stub.java.rmi 中 Object 的使用

实现 Object 的 org.omg.stub.java.rmi 中的类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ObjectHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ObjectHelper
的使用

没有 org.omg.CORBA.ObjectHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ObjectHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ObjectHolder
的使用

没有 org.omg.CORBA.ObjectHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.OctetSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.OctetSeqHelper
的使用

没有 org.omg.CORBA.OctetSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.OctetSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.OctetSeqHolder
的使用

使用 OctetSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 OctetSeqHolder 的使用

参数类型为 OctetSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_octet_array(OctetSeqHolder seq, int offset, int length)
从输入流读取 IDL octet 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PERSIST_STORE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PERSIST_STORE
的使用

没有 org.omg.CORBA.PERSIST_STORE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.PRIVATE_MEMBER 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.PRIVATE_MEMBER
的使用

没有 org.omg.CORBA.PRIVATE_MEMBER 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.PUBLIC_MEMBER 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.PUBLIC_MEMBER
的使用

没有 org.omg.CORBA.PUBLIC_MEMBER 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ParameterMode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ParameterMode
的使用

使用 ParameterMode 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。

org.omg.CORBA 中 ParameterMode 的使用

声明为 ParameterMode 的 org.omg.CORBA 中的字段
static ParameterMode | ParameterMode.PARAM_IN
static ParameterMode | ParameterMode.PARAM_INOUT
static ParameterMode | ParameterMode.PARAM_OUT
ParameterMode | ParameterModeHolder.value

返回 ParameterMode 的 org.omg.CORBA 中的方法
static ParameterMode | ParameterModeHelper.extract(Any a)
static ParameterMode | ParameterMode.from_int(int value)
static ParameterMode | ParameterModeHelper.read(InputStream istream)

参数类型为 ParameterMode 的 org.omg.CORBA 中的方法
static void | ParameterModeHelper.insert(Any a, ParameterMode that)
static void | ParameterModeHelper.write(OutputStream ostream, ParameterMode value)

参数类型为 ParameterMode 的 org.omg.CORBA 中的构造方法
ParameterModeHolder(ParameterMode initialValue)

org.omg.Dynamic 中 ParameterMode 的使用

声明为 ParameterMode 的 org.omg.Dynamic 中的字段
 ParameterMode Parameter.mode

参数类型为 ParameterMode 的 org.omg.Dynamic 中的构造方法
Parameter(Any _argument, ParameterMode _mode)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ParameterModeHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ParameterModeHelper
的使用

没有 org.omg.CORBA.ParameterModeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ParameterModeHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ParameterModeHolder
的使用

没有 org.omg.CORBA.ParameterModeHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.Policy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.Policy
的使用

使用 Policy 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 Policy 的使用

实现 Policy 的 org.omg.CORBA 中的类
 class _PolicyStub
Policy 的 Stub。

声明为 Policy 的 org.omg.CORBA 中的字段
Policy | PolicyHolder.value
Policy[] | PolicyListHolder.value

返回 Policy 的 org.omg.CORBA 中的方法
Policy | LocalObject._get_policy(int policy_type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Policy | Object._get_policy(int policy_type) 返回应用于此对象的指定类型的 Policy 对象。
Policy | PolicyOperations.copy() 返回 Policy 对象的副本。
Policy | _PolicyStub.copy() 复制策略对象。
Policy | ORB.create_policy(int type, Any val) 可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。
static Policy | PolicyHelper.extract(Any a)
static Policy[] | PolicyListHelper.extract(Any a)
Policy | DomainManagerOperations.get_domain_policy(int policy_type) 此方法为此域中的对象返回指定类型的策略。
static Policy | PolicyHelper.narrow(Object obj)
static Policy | PolicyHelper.read(InputStream istream)
static Policy[] | PolicyListHelper.read(InputStream istream)

参数类型为 Policy 的 org.omg.CORBA 中的方法
Object | LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Object | Object._set_policy_override(Policy[] policies, SetOverrideType set_add) 返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。
static void | PolicyHelper.insert(Any a, Policy that)
static void | PolicyListHelper.insert(Any a, Policy[] that)
static void | PolicyHelper.write(OutputStream ostream, Policy value)
static void | PolicyListHelper.write(OutputStream ostream, Policy[] value)

参数类型为 Policy 的 org.omg.CORBA 中的构造方法
PolicyHolder(Policy initialValue)
PolicyListHolder(Policy[] initialValue)

org.omg.CORBA.portable 中 Policy 的使用

返回 Policy 的 org.omg.CORBA.portable 中的方法
Policy | ObjectImpl._get_policy(int policy_type) 获得此 ObjectImpl 对象具有给定策略类型的 Policy 对象。
Policy | Delegate.get_policy(Object self, int policy_type) 返回应用于此对象的指定类型的 Policy 对象。

参数类型为 Policy 的 org.omg.CORBA.portable 中的方法
Object | ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add) 将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
Object | Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add) 将传入的策略与它返回的新创建对象引用关联。

org.omg.PortableInterceptor 中 Policy 的使用

返回 Policy 的 org.omg.PortableInterceptor 中的方法
Policy | PolicyFactoryOperations.create_policy(int type, Any value) 返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。
Policy | IORInfoOperations.get_effective_policy(int type) 允许 ORB 服务实现确定对将构造的 IOR 有效的特定类型服务器端策略。
Policy | ClientRequestInfoOperations.get_request_policy(int type) 返回此操作实行的给定策略。
Policy | ServerRequestInfoOperations.get_server_policy(int type) 返回此操作实行的具有给定策略类型的策略。

org.omg.PortableServer 中 Policy 的使用

org.omg.PortableServer 中 Policy 的子接口
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

参数类型为 Policy 的 org.omg.PortableServer 中的方法
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyError 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyError
的使用

使用 PolicyError 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.CORBA 中 PolicyError 的使用

声明为 PolicyError 的 org.omg.CORBA 中的字段
 PolicyError PolicyErrorHolder.value

返回 PolicyError 的 org.omg.CORBA 中的方法
static PolicyError | PolicyErrorHelper.extract(Any a)
static PolicyError | PolicyErrorHelper.read(InputStream istream)

参数类型为 PolicyError 的 org.omg.CORBA 中的方法
static void | PolicyErrorHelper.insert(Any a, PolicyError that)
static void | PolicyErrorHelper.write(OutputStream ostream, PolicyError value)

抛出 PolicyError 的 org.omg.CORBA 中的方法
 Policy ORB.create_policy(int type, Any val)
可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。

参数类型为 PolicyError 的 org.omg.CORBA 中的构造方法
PolicyErrorHolder(PolicyError initialValue)

org.omg.PortableInterceptor 中 PolicyError 的使用

抛出 PolicyError 的 org.omg.PortableInterceptor 中的方法
 Policy PolicyFactoryOperations.create_policy(int type, Any value)
返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyErrorCodeHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyErrorCodeHelper
的使用

没有 org.omg.CORBA.PolicyErrorCodeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyErrorHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyErrorHelper
的使用

没有 org.omg.CORBA.PolicyErrorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyErrorHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyErrorHolder
的使用

没有 org.omg.CORBA.PolicyErrorHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyHelper
的使用

没有 org.omg.CORBA.PolicyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyHolder
的使用

没有 org.omg.CORBA.PolicyHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyListHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyListHelper
的使用

没有 org.omg.CORBA.PolicyListHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyListHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyListHolder
的使用

没有 org.omg.CORBA.PolicyListHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.PolicyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.PolicyOperations
的使用

使用 PolicyOperations 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 PolicyOperations 的使用

org.omg.CORBA 中 PolicyOperations 的子接口
 interface Policy
派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。

实现 PolicyOperations 的 org.omg.CORBA 中的类
 class _PolicyStub
Policy 的 Stub。

org.omg.PortableServer 中 PolicyOperations 的使用

org.omg.PortableServer 中 PolicyOperations 的子接口
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdAssignmentPolicyOperations IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | IdUniquenessPolicyOperations IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | ImplicitActivationPolicyOperations 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | LifespanPolicyOperations LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | RequestProcessingPolicyOperations 此策略指定已创建的 POA 处理请求的方式。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ServantRetentionPolicyOperations 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。
interface | ThreadPolicyOperations ThreadPolicy 指定与已创建的 POA 一起使用的线程模型 (threading model)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PolicyTypeHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PolicyTypeHelper
的使用

没有 org.omg.CORBA.PolicyTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.Principal 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Principal
的使用

使用 Principal 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 Principal 的使用

声明为 Principal 的 org.omg.CORBA 中的字段
 Principal PrincipalHolder.value
已过时。 此 PrincipalHolder 对象保存的 Principal 值。

返回 Principal 的 org.omg.CORBA 中的方法
 Principal Any.extract_Principal()
已过时。 由 CORBA 2.2 取代。

参数类型为 Principal 的 org.omg.CORBA 中的方法
 void Any.insert_Principal(Principal p)
已过时。 由 CORBA 2.2 取代。

参数类型为 Principal 的 org.omg.CORBA 中的构造方法
PrincipalHolder(Principal initial)
已过时。 构造一个新的 PrincipalHolder 对象，并将其 value 字段初始化为给定的 Principal 对象。

org.omg.CORBA.portable 中 Principal 的使用

返回 Principal 的 org.omg.CORBA.portable 中的方法
 Principal InputStream.read_Principal()
已过时。 已由 CORBA 2.2 取代。

参数类型为 Principal 的 org.omg.CORBA.portable 中的方法
 void OutputStream.write_Principal(Principal value)
已过时。 已由 CORBA 2.2 取代。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.REBIND 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.REBIND
的使用

没有 org.omg.CORBA.REBIND 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.PrincipalHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.PrincipalHolder
的使用

没有 org.omg.CORBA.PrincipalHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.RepositoryIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.RepositoryIdHelper
的使用

没有 org.omg.CORBA.RepositoryIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.Request 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.Request
的使用

使用 Request 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 Request 的使用

返回 Request 的 org.omg.CORBA 中的方法
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
Request | LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
Request | LocalObject._request(String operation) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Request | Object._request(String operation) 创建一个在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
abstract Request | ORB.get_next_response() 获取已接收到响应的下一个 Request 实例。

参数类型为 Request 的 org.omg.CORBA 中的方法
abstract void | ORB.send_multiple_requests_deferred(Request[] req) 异步发送多个动态 (DII) 请求。
abstract void | ORB.send_multiple_requests_oneway(Request[] req) 异步发送多个动态 (DII) 请求，并且不期望任何响应。

org.omg.CORBA.portable 中 Request 的使用

返回 Request 的 org.omg.CORBA.portable 中的方法
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result) 创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
Request | ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts) 创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
Request | ObjectImpl._request(String operation) 创建一个 Request 对象，使其包含可用于动态调用接口 (Dynamic Invocation Interface) 的给定方法。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist) 创建在动态调用接口中使用的 Request 实例。
abstract Request | Delegate.request(Object obj, String operation) 创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ServerRequest 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServerRequest
的使用

使用 ServerRequest 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CORBA 中 ServerRequest 的使用

参数类型为 ServerRequest 的 org.omg.CORBA 中的方法
 void DynamicImplementation.invoke(ServerRequest request)
已过时。 由 Portable Object Adapter 取代

org.omg.CosNaming 中 ServerRequest 的使用

参数类型为 ServerRequest 的 org.omg.CosNaming 中的方法
void | _BindingIteratorImplBase.invoke(ServerRequest r)
void | _NamingContextImplBase.invoke(ServerRequest r)

org.omg.PortableServer 中 ServerRequest 的使用

参数类型为 ServerRequest 的 org.omg.PortableServer 中的方法
abstract  void DynamicImplementation.invoke(ServerRequest request)
接收发布到任何由 DSI servant 实现的 CORBA 对象的请求，并进行执行该请求所需的处理。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceDetail 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceDetail
的使用

使用 ServiceDetail 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ServiceDetail 的使用

声明为 ServiceDetail 的 org.omg.CORBA 中的字段
 ServiceDetail[] ServiceInformation.service_details
提供有关服务更多详细信息的 ServiceDetail 所组成的数组。

返回 ServiceDetail 的 org.omg.CORBA 中的方法
static ServiceDetail | ServiceDetailHelper.extract(Any a)
static ServiceDetail | ServiceDetailHelper.read(InputStream in)

参数类型为 ServiceDetail 的 org.omg.CORBA 中的方法
static void | ServiceDetailHelper.insert(Any a, ServiceDetail that)
static void | ServiceDetailHelper.write(OutputStream out, ServiceDetail that)

参数类型为 ServiceDetail 的 org.omg.CORBA 中的构造方法
ServiceInformation(int[] __service_options, ServiceDetail[] __service_details)
使用给定 service_options 和 service_details 构造一个 ServiceInformation 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceDetailHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceDetailHelper
的使用

没有 org.omg.CORBA.ServiceDetailHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceInformation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceInformation
的使用

使用 ServiceInformation 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ServiceInformation 的使用

声明为 ServiceInformation 的 org.omg.CORBA 中的字段
 ServiceInformation ServiceInformationHolder.value
此 ServiceInformationHolder 对象保存在其 value 字段中的 ServiceInformation 值。

返回 ServiceInformation 的 org.omg.CORBA 中的方法
static ServiceInformation | ServiceInformationHelper.extract(Any a)
static ServiceInformation | ServiceInformationHelper.read(InputStream in)

参数类型为 ServiceInformation 的 org.omg.CORBA 中的方法
static void | ServiceInformationHelper.insert(Any a, ServiceInformation that)
static void | ServiceInformationHelper.write(OutputStream out, ServiceInformation that)

参数类型为 ServiceInformation 的 org.omg.CORBA 中的构造方法
ServiceInformationHolder(ServiceInformation arg)
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为给定的 ServiceInformation 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceInformationHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceInformationHelper
的使用

没有 org.omg.CORBA.ServiceInformationHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ServiceInformationHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ServiceInformationHolder
的使用

使用 ServiceInformationHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ServiceInformationHolder 的使用

参数类型为 ServiceInformationHolder 的 org.omg.CORBA 中的方法
 boolean ORB.get_service_information(short service_type, ServiceInformationHolder service_info)
用来获取有关受此 ORB 支持的 CORBA 资源和服务的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.SetOverrideType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.SetOverrideType
的使用

使用 SetOverrideType 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA 中 SetOverrideType 的使用

声明为 SetOverrideType 的 org.omg.CORBA 中的字段
static SetOverrideType | SetOverrideType.ADD_OVERRIDE 用于枚举值 ADD_OVERRIDE 的 SetOverrideType 常量。
static SetOverrideType | SetOverrideType.SET_OVERRIDE 用于枚举值 SET_OVERRIDE 的 SetOverrideType 常量。

返回 SetOverrideType 的 org.omg.CORBA 中的方法
static SetOverrideType | SetOverrideTypeHelper.extract(Any a)
static SetOverrideType | SetOverrideType.from_int(int i) 将给定 int 值转换成相应的 SetOverrideType 实例。
static SetOverrideType | SetOverrideTypeHelper.read(InputStream istream)

参数类型为 SetOverrideType 的 org.omg.CORBA 中的方法
Object | LocalObject._set_policy_override(Policy[] policies, SetOverrideType set_add) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
Object | Object._set_policy_override(Policy[] policies, SetOverrideType set_add) 返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。
static void | SetOverrideTypeHelper.insert(Any a, SetOverrideType that)
static void | SetOverrideTypeHelper.write(OutputStream ostream, SetOverrideType value)

org.omg.CORBA.portable 中 SetOverrideType 的使用

参数类型为 SetOverrideType 的 org.omg.CORBA.portable 中的方法
Object | ObjectImpl._set_policy_override(Policy[] policies, SetOverrideType set_add) 将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
Object | Delegate.set_policy_override(Object self, Policy[] policies, SetOverrideType set_add) 将传入的策略与它返回的新创建对象引用关联。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.SetOverrideTypeHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.SetOverrideTypeHelper
的使用

没有 org.omg.CORBA.SetOverrideTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ShortHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ShortHolder
的使用

没有 org.omg.CORBA.ShortHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ShortSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ShortSeqHelper
的使用

没有 org.omg.CORBA.ShortSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ShortSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ShortSeqHolder
的使用

使用 ShortSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ShortSeqHolder 的使用

参数类型为 ShortSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_short_array(ShortSeqHolder seq, int offset, int length)
从输入流读取 IDL short 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.StringHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StringHolder
的使用

没有 org.omg.CORBA.StringHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.StringSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StringSeqHelper
的使用

没有 org.omg.CORBA.StringSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.StringSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StringSeqHolder
的使用

没有 org.omg.CORBA.StringSeqHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.StringValueHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StringValueHelper
的使用

没有 org.omg.CORBA.StringValueHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.StructMember 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StructMember
的使用

使用 StructMember 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 StructMember 的使用

返回 StructMember 的 org.omg.CORBA 中的方法
static StructMember | StructMemberHelper.extract(Any a)
static StructMember | StructMemberHelper.read(InputStream istream)

参数类型为 StructMember 的 org.omg.CORBA 中的方法
abstract TypeCode | ORB.create_exception_tc(String id, String name, StructMember[] members) 创建一个表示 IDL exception 的 TypeCode 对象。
abstract TypeCode | ORB.create_struct_tc(String id, String name, StructMember[] members) 创建一个表示 IDL struct 的 TypeCode 对象。
static void | StructMemberHelper.insert(Any a, StructMember that)
static void | StructMemberHelper.write(OutputStream ostream, StructMember value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.StructMemberHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.StructMemberHelper
的使用

没有 org.omg.CORBA.StructMemberHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.SystemException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.SystemException
的使用

使用 SystemException 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

javax.rmi.CORBA 中 SystemException 的使用

参数类型为 SystemException 的 javax.rmi.CORBA 中的方法
static RemoteException Util.mapSystemException(SystemException ex)
将 SystemException 映射到 RemoteException。
 RemoteException UtilDelegate.mapSystemException(SystemException ex)
Util.mapSystemException(org.omg.CORBA.SystemException) 的委托调用。

org.omg.CORBA 中 SystemException 的使用

org.omg.CORBA 中 SystemException 的子类
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。

org.omg.CORBA.portable 中 SystemException 的使用

org.omg.CORBA.portable 中 SystemException 的子类
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

抛出 SystemException 的 org.omg.CORBA.portable 中的方法
 OutputStream InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
由 ORB 调用来调度对 servant 的请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TCKind 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TCKind
的使用

使用 TCKind 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.CORBA 中 TCKind 的使用

声明为 TCKind 的 org.omg.CORBA 中的字段
static TCKind | TCKind.tk_abstract_interface TCKind 常量，使用 TCKind._tk_abstract_interface 初始化其 value 字段。
static TCKind | TCKind.tk_alias TCKind 常量，使用 TCKind._tk_alias 初始化其 value 字段。
static TCKind | TCKind.tk_any TCKind 常量，使用 TCKind._tk_any 初始化其 value 字段。
static TCKind | TCKind.tk_array TCKind 常量，使用 TCKind._tk_array 初始化其 value 字段。
static TCKind | TCKind.tk_boolean TCKind 常量，使用 TCKind._tk_boolean 初始化其 value 字段。
static TCKind | TCKind.tk_char TCKind 常量，使用 TCKind._tk_char 初始化其 value 字段。
static TCKind | TCKind.tk_double TCKind 常量，使用 TCKind._tk_double 初始化其 value 字段。
static TCKind | TCKind.tk_enum TCKind 常量，使用 TCKind._tk_enum 初始化其 value 字段。
static TCKind | TCKind.tk_except TCKind 常量，使用 TCKind._tk_except 初始化其 value 字段。
static TCKind | TCKind.tk_fixed TCKind 常量，使用 TCKind._tk_fixed 初始化其 value 字段。
static TCKind | TCKind.tk_float TCKind 常量，使用 TCKind._tk_float 初始化其 value 字段。
static TCKind | TCKind.tk_long TCKind 常量，使用 TCKind._tk_long 初始化其 value 字段。
static TCKind | TCKind.tk_longdouble TCKind 常量，使用 TCKind._tk_longdouble 初始化其 value 字段。
static TCKind | TCKind.tk_longlong TCKind 常量，使用 TCKind._tk_longlong 初始化其 value 字段。
static TCKind | TCKind.tk_native TCKind 常量，使用 TCKind._tk_native 初始化其 value 字段。
static TCKind | TCKind.tk_null TCKind 常量，使用 TCKind._tk_null 初始化其 value 字段。
static TCKind | TCKind.tk_objref TCKind 常量，使用 TCKind._tk_objref 初始化其 value 字段。
static TCKind | TCKind.tk_octet TCKind 常量，使用 TCKind._tk_octet 初始化其 value 字段。
static TCKind | TCKind.tk_Principal TCKind 常量，使用 TCKind._tk_Principal 初始化其 value 字段。
static TCKind | TCKind.tk_sequence TCKind 常量，使用 TCKind._tk_sequence 初始化其 value 字段。
static TCKind | TCKind.tk_short TCKind 常量，使用 TCKind._tk_short 初始化其 value 字段。
static TCKind | TCKind.tk_string TCKind 常量，使用 TCKind._tk_string 初始化其 value 字段。
static TCKind | TCKind.tk_struct TCKind 常量，使用 TCKind._tk_struct 初始化其 value 字段。
static TCKind | TCKind.tk_TypeCode TCKind 常量，使用 TCKind._tk_TypeCode 初始化其 value 字段。
static TCKind | TCKind.tk_ulong TCKind 常量，使用 TCKind._tk_ulong 初始化其 value 字段。
static TCKind | TCKind.tk_ulonglong TCKind 常量，使用 TCKind._tk_ulonglong 初始化其 value 字段。
static TCKind | TCKind.tk_union TCKind 常量，使用 TCKind._tk_union 初始化其 value 字段。
static TCKind | TCKind.tk_ushort TCKind 常量，使用 TCKind._tk_ushort 初始化其 value 字段。
static TCKind | TCKind.tk_value TCKind 常量，使用 TCKind._tk_value 初始化其 value 字段。
static TCKind | TCKind.tk_value_box TCKind 常量，使用 TCKind._tk_value_box 初始化其 value 字段。
static TCKind | TCKind.tk_void TCKind 常量，使用 TCKind._tk_void 初始化其 value 字段。
static TCKind | TCKind.tk_wchar TCKind 常量，使用 TCKind._tk_wchar 初始化其 value 字段。
static TCKind | TCKind.tk_wstring TCKind 常量，使用 TCKind._tk_wstring 初始化其 value 字段。

返回 TCKind 的 org.omg.CORBA 中的方法
TCKind | DynStruct.current_member_kind() 已过时。 返回描述当前成员的种类的 TCKind 对象。
TCKind | DynValue.current_member_kind() 已过时。 返回描述当前成员的 TCKind 对象。
TCKind | DynUnion.discriminator_kind() 已过时。 返回与此 union 的鉴别符关联的 TCKind 对象。
static TCKind | TCKind.from_int(int i) 将给定 int 值转换成相应的 TCKind 实例。
abstract TCKind | TypeCode.kind() 检索此 TypeCode 对象的种类。
TCKind | DynUnion.member_kind() 已过时。 返回与此 union 成员关联的 TCKind。

参数类型为 TCKind 的 org.omg.CORBA 中的方法
abstract  TypeCode ORB.get_primitive_tc(TCKind tcKind)
检索表示给定基本 IDL 类型的 TypeCode 对象。

org.omg.DynamicAny 中 TCKind 的使用

返回 TCKind 的 org.omg.DynamicAny 中的方法
TCKind | DynStructOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | DynValueOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynStructStub.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynValueStub.current_member_kind() 返回与当前位置的成员有关联的 TCKind。
TCKind | DynUnionOperations.discriminator_kind() 返回鉴别符 TypeCode 的 TCKind 值。
TCKind | _DynUnionStub.discriminator_kind() 返回鉴别符 TypeCode 的 TCKind 值。
TCKind | DynUnionOperations.member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。
TCKind | _DynUnionStub.member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TIMEOUT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TIMEOUT
的使用

没有 org.omg.CORBA.TIMEOUT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSACTION_MODE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSACTION_MODE
的使用

没有 org.omg.CORBA.TRANSACTION_MODE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSACTION_REQUIRED 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSACTION_REQUIRED
的使用

没有 org.omg.CORBA.TRANSACTION_REQUIRED 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSACTION_ROLLEDBACK
的使用

没有 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSACTION_UNAVAILABLE
的使用

没有 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TRANSIENT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TRANSIENT
的使用

没有 org.omg.CORBA.TRANSIENT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TypeCode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TypeCode
的使用

使用 TypeCode 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。

org.omg.CORBA 中 TypeCode 的使用

声明为 TypeCode 的 org.omg.CORBA 中的字段
TypeCode | StructMember.type 此 StructMember 对象所描述的 struct 成员的类型。
TypeCode | UnionMember.type 此 UnionMember 对象所描述的 union 成员的类型。
TypeCode | ValueMember.type 此 value 成员的类型。
TypeCode | TypeCodeHolder.value 此 TypeCodeHolder 对象保存的 TypeCode 值。

返回 TypeCode 的 org.omg.CORBA 中的方法
TypeCode | AnyHolder._type() 返回对应于此 AnyHolder 对象中保存值的 TypeCode 对象。
TypeCode | AnySeqHolder._type()
TypeCode | BooleanHolder._type() 检索对应于此 BooleanHolder 对象中所保存的值的 TypeCode 对象。
TypeCode | BooleanSeqHolder._type()
TypeCode | ByteHolder._type() 返回对应于此 ByteHolder 对象中所保存的值的 TypeCode。
TypeCode | CharHolder._type() 返回对应于此 CharHolder 对象中所保存的值的 TypeCode 对象。
TypeCode | CharSeqHolder._type()
TypeCode | CurrentHolder._type()
TypeCode | DoubleHolder._type() 返回此 holder 对象的 TypeCode。
TypeCode | DoubleSeqHolder._type()
TypeCode | FixedHolder._type() 返回此 holder 对象的 TypeCode。
TypeCode | FloatHolder._type() 返回此 Streamable 的 TypeCode。
TypeCode | FloatSeqHolder._type()
TypeCode | IntHolder._type() 检索对应于此 IntHolder 对象 value 字段的 TypeCode 对象。
TypeCode | LongHolder._type() 返回对应于此 Holder 中所保存的值的 TypeCode 对象。
TypeCode | LongLongSeqHolder._type()
TypeCode | LongSeqHolder._type()
TypeCode | ObjectHolder._type() 返回对应于此 ObjectHolder 对象中所保存的值的 TypeCode
TypeCode | OctetSeqHolder._type()
TypeCode | ParameterModeHolder._type()
TypeCode | PolicyErrorHolder._type()
TypeCode | PolicyHolder._type()
TypeCode | PolicyListHolder._type()
TypeCode | PrincipalHolder._type() 已过时。
TypeCode | ServiceInformationHolder._type() 检索对应于此 ServiceInformationHolder 对象的 value 字段中所保存的值的 TypeCode 对象。
TypeCode | ShortHolder._type() 返回对应于此 ShortHolder 对象中所保存的值的 TypeCode。
TypeCode | ShortSeqHolder._type()
TypeCode | StringHolder._type() 检索对应于此 StringHolder 对象中所保存的值的 TypeCode 对象。
TypeCode | StringSeqHolder._type()
TypeCode | TypeCodeHolder._type() 返回对应于此 TypeCodeHolder 对象中所保存的值的 TypeCode。
TypeCode | ULongLongSeqHolder._type()
TypeCode | ULongSeqHolder._type()
TypeCode | UShortSeqHolder._type()
TypeCode | UnknownUserExceptionHolder._type()
TypeCode | ValueBaseHolder._type() 返回对应于此 Holder 中保存的值的 TypeCode 对象。
TypeCode | WCharSeqHolder._type()
TypeCode | WStringSeqHolder._type()
TypeCode | WrongTransactionHolder._type()
abstract TypeCode | TypeCode.concrete_base_type() 返回一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型。
abstract TypeCode | TypeCode.content_type() 返回表示此 TypeCode 对象所描述成员 IDL 类型的 TypeCode 对象。
TypeCode | ORB.create_abstract_interface_tc(String id, String name) 为 IDL 抽象接口创建一个 TypeCode 对象。
abstract TypeCode | ORB.create_alias_tc(String id, String name, TypeCode original_type) 创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。
abstract TypeCode | ORB.create_array_tc(int length, TypeCode element_type) 创建一个表示 IDL array 的 TypeCode 对象。
abstract TypeCode | ORB.create_enum_tc(String id, String name, String[] members) 创建一个表示 IDL enum 的 TypeCode 对象。
abstract TypeCode | ORB.create_exception_tc(String id, String name, StructMember[] members) 创建一个表示 IDL exception 的 TypeCode 对象。
TypeCode | ORB.create_fixed_tc(short digits, short scale) 为 IDL fixed 类型创建一个 TypeCode 对象。
abstract TypeCode | ORB.create_interface_tc(String id, String name) 创建一个表示 IDL interface 的 TypeCode 对象。
TypeCode | ORB.create_native_tc(String id, String name) 为 IDL native 类型创建一个 TypeCode 对象。
abstract TypeCode | ORB.create_recursive_sequence_tc(int bound, int offset) 已过时。 使用 create_recursive_tc 和 create_sequence_tc 的组合替代它
TypeCode | ORB.create_recursive_tc(String id) 创建一个递归 TypeCode 对象，在创建包含递归的 TypeCodes 期间，该对象充当具体 TypeCode 的占位符。
abstract TypeCode | ORB.create_sequence_tc(int bound, TypeCode element_type) 创建一个表示 IDL sequence 的 TypeCode 对象。
abstract TypeCode | ORB.create_string_tc(int bound) 创建一个表示有界 IDL string 的 TypeCode 对象。
abstract TypeCode | ORB.create_struct_tc(String id, String name, StructMember[] members) 创建一个表示 IDL struct 的 TypeCode 对象。
abstract TypeCode | ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members) 创建一个表示 IDL union 的 TypeCode 对象。
TypeCode | ORB.create_value_box_tc(String id, String name, TypeCode boxed_type) 为 IDL value box 类型创建一个 TypeCode 对象。
TypeCode | ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members) 为 IDL value 类型创建一个 TypeCode 对象。
abstract TypeCode | ORB.create_wstring_tc(int bound) 创建一个表示有界 IDL wstring (wide string) 的 TypeCode 对象。
abstract TypeCode | TypeCode.discriminator_type() 返回描述所有非默认成员标签的 TypeCode 对象。
abstract TypeCode | Any.extract_TypeCode() 提取此 Any 对象 value 字段中的 TypeCode 对象。
abstract TypeCode | TypeCode.get_compact_typecode() 剔除所有可选名称和成员名称字段，但使所有别名 typecode 保留原样。
abstract TypeCode | ORB.get_primitive_tc(TCKind tcKind) 检索表示给定基本 IDL 类型的 TypeCode 对象。
TypeCode | DynAny.get_typecode() 已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.TypeCode。
abstract TypeCode | ExceptionList.item(int index) 返回给定索引处的 TypeCode 对象。
abstract TypeCode | TypeCode.member_type(int index) 检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
TypeCode | DataInputStream.read_TypeCode() 从输入流读取 IDL typecode 值。
abstract TypeCode | Any.type() 返回此 Any 对象中所包含元素的类型信息。
static TypeCode | AnySeqHelper.type()
static TypeCode | BooleanSeqHelper.type()
static TypeCode | CharSeqHelper.type()
static TypeCode | CompletionStatusHelper.type()
static TypeCode | CurrentHelper.type()
static TypeCode | DefinitionKindHelper.type()
static TypeCode | DoubleSeqHelper.type()
TypeCode | DynAny.type() 已过时。 返回插入此 DynAny 对象的 TypeCode。
static TypeCode | FieldNameHelper.type()
static TypeCode | FloatSeqHelper.type()
static TypeCode | IDLTypeHelper.type()
TypeCode | IDLTypeOperations.type() type 属性描述源自 IDLType 的对象定义的类型。
static TypeCode | IdentifierHelper.type()
static TypeCode | LongLongSeqHelper.type()
static TypeCode | LongSeqHelper.type()
static TypeCode | NameValuePairHelper.type()
static TypeCode | ObjectHelper.type()
static TypeCode | OctetSeqHelper.type()
static TypeCode | ParameterModeHelper.type()
static TypeCode | PolicyErrorCodeHelper.type()
static TypeCode | PolicyErrorHelper.type()
static TypeCode | PolicyHelper.type()
static TypeCode | PolicyListHelper.type()
static TypeCode | PolicyTypeHelper.type()
static TypeCode | RepositoryIdHelper.type()
static TypeCode | ServiceDetailHelper.type()
static TypeCode | ServiceInformationHelper.type()
static TypeCode | SetOverrideTypeHelper.type()
static TypeCode | ShortSeqHelper.type()
static TypeCode | StringSeqHelper.type()
static TypeCode | StringValueHelper.type()
static TypeCode | StructMemberHelper.type()
static TypeCode | ULongLongSeqHelper.type()
static TypeCode | ULongSeqHelper.type()
static TypeCode | UShortSeqHelper.type()
static TypeCode | UnionMemberHelper.type()
static TypeCode | UnknownUserExceptionHelper.type()
static TypeCode | ValueBaseHelper.type()
static TypeCode | ValueMemberHelper.type()
static TypeCode | VersionSpecHelper.type()
static TypeCode | VisibilityHelper.type()
static TypeCode | WCharSeqHelper.type()
static TypeCode | WStringSeqHelper.type()
static TypeCode | WStringValueHelper.type()
static TypeCode | WrongTransactionHelper.type()
TypeCode | _IDLTypeStub.type()

参数类型为 TypeCode 的 org.omg.CORBA 中的方法
abstract void | ExceptionList.add(TypeCode exc) 将描述异常的 TypeCode 对象添加到此 ExceptionList 对象中。
abstract TypeCode | ORB.create_alias_tc(String id, String name, TypeCode original_type) 创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。
abstract TypeCode | ORB.create_array_tc(int length, TypeCode element_type) 创建一个表示 IDL array 的 TypeCode 对象。
DynAny | ORB.create_basic_dyn_any(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynArray | ORB.create_dyn_array(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynEnum | ORB.create_dyn_enum(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynSequence | ORB.create_dyn_sequence(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynStruct | ORB.create_dyn_struct(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
DynUnion | ORB.create_dyn_union(TypeCode type) 已过时。 使用新的 DynAnyFactory API 代替
abstract TypeCode | ORB.create_sequence_tc(int bound, TypeCode element_type) 创建一个表示 IDL sequence 的 TypeCode 对象。
abstract TypeCode | ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members) 创建一个表示 IDL union 的 TypeCode 对象。
TypeCode | ORB.create_value_box_tc(String id, String name, TypeCode boxed_type) 为 IDL value box 类型创建一个 TypeCode 对象。
TypeCode | ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members) 为 IDL value 类型创建一个 TypeCode 对象。
abstract boolean | TypeCode.equal(TypeCode tc) 将此 TypeCode 对象与给定对象比较，测试它们是否相等。
abstract boolean | TypeCode.equivalent(TypeCode tc) 测试给定 TypeCode 对象是否等于此 TypeCode 对象。
void | Any.insert_fixed(BigDecimal value, TypeCode type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
abstract void | Any.insert_Object(Object o, TypeCode t) 将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
void | DynAny.insert_typecode(TypeCode value) 已过时。 插入给定 org.omg.CORBA.TypeCode 值作为此 DynAny 对象的值。
abstract void | Any.insert_TypeCode(TypeCode t) 将给定 TypeCode 对象插入此 Any 对象的 value 字段。
abstract void | Any.insert_Value(Serializable v, TypeCode t) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
abstract void | Any.read_value(InputStream is, TypeCode t) 使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。
abstract void | Request.set_return_type(TypeCode tc) 设置该方法返回值的 typecode。
abstract void | Any.type(TypeCode t) 将此 Any 对象的 type 字段设置为给定的 TypeCode 对象，并清除其值。
void | DataOutputStream.write_TypeCode(TypeCode value) 将 typecode 写入输出流。

参数类型为 TypeCode 的 org.omg.CORBA 中的构造方法
StructMember(String __name, TypeCode __type, IDLType __type_def)
构造一个 StructMember 对象，并使用给定值进行初始化。
TypeCodeHolder(TypeCode initial)
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为给定的 TypeCode 对象。
UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
构造一个 ValueMember 对象，使用给定值进行初始化。

org.omg.CORBA.portable 中 TypeCode 的使用

返回 TypeCode 的 org.omg.CORBA.portable 中的方法
TypeCode | Streamable._type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
abstract TypeCode | InputStream.read_TypeCode() 从此输入流中读取一个 TypeCode。

参数类型为 TypeCode 的 org.omg.CORBA.portable 中的方法
abstract  void OutputStream.write_TypeCode(TypeCode value)
在此输出流上写入一个 TypeCode。

org.omg.CosNaming 中 TypeCode 的使用

返回 TypeCode 的 org.omg.CosNaming 中的方法
TypeCode | BindingHolder._type()
TypeCode | BindingIteratorHolder._type()
TypeCode | BindingListHolder._type()
TypeCode | BindingTypeHolder._type()
TypeCode | NameComponentHolder._type()
TypeCode | NameHolder._type()
TypeCode | NamingContextExtHolder._type()
TypeCode | NamingContextHolder._type()
static TypeCode | BindingHelper.type()
static TypeCode | BindingIteratorHelper.type()
static TypeCode | BindingListHelper.type()
static TypeCode | BindingTypeHelper.type()
static TypeCode | IstringHelper.type()
static TypeCode | NameComponentHelper.type()
static TypeCode | NameHelper.type()
static TypeCode | NamingContextExtHelper.type()
static TypeCode | NamingContextHelper.type()

org.omg.CosNaming.NamingContextExtPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
TypeCode | InvalidAddressHolder._type()
static TypeCode | AddressHelper.type()
static TypeCode | InvalidAddressHelper.type()
static TypeCode | StringNameHelper.type()
static TypeCode | URLStringHelper.type()

org.omg.CosNaming.NamingContextPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.CosNaming.NamingContextPackage 中的方法
TypeCode | AlreadyBoundHolder._type()
TypeCode | CannotProceedHolder._type()
TypeCode | InvalidNameHolder._type()
TypeCode | NotEmptyHolder._type()
TypeCode | NotFoundHolder._type()
TypeCode | NotFoundReasonHolder._type()
static TypeCode | AlreadyBoundHelper.type()
static TypeCode | CannotProceedHelper.type()
static TypeCode | InvalidNameHelper.type()
static TypeCode | NotEmptyHelper.type()
static TypeCode | NotFoundHelper.type()
static TypeCode | NotFoundReasonHelper.type()

org.omg.DynamicAny 中 TypeCode 的使用

返回 TypeCode 的 org.omg.DynamicAny 中的方法
TypeCode | DynAnyOperations.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynAnyStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynArrayStub.get_typecode() 从此 DynAny 析取 TypeCode 对象。
TypeCode | _DynEnumStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynFixedStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynSequenceStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynStructStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynUnionStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynValueStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
static TypeCode | AnySeqHelper.type()
static TypeCode | DynAnyFactoryHelper.type()
static TypeCode | DynAnyHelper.type()
TypeCode | DynAnyOperations.type() 返回与此 DynAny 对象有关联的 TypeCode。
static TypeCode | DynAnySeqHelper.type()
static TypeCode | DynArrayHelper.type()
static TypeCode | DynEnumHelper.type()
static TypeCode | DynFixedHelper.type()
static TypeCode | DynSequenceHelper.type()
static TypeCode | DynStructHelper.type()
static TypeCode | DynUnionHelper.type()
static TypeCode | DynValueHelper.type()
static TypeCode | FieldNameHelper.type()
static TypeCode | NameDynAnyPairHelper.type()
static TypeCode | NameDynAnyPairSeqHelper.type()
static TypeCode | NameValuePairHelper.type()
static TypeCode | NameValuePairSeqHelper.type()
TypeCode | _DynAnyStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynArrayStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynEnumStub.type() 返回与此 DynAny 对象关联的 TypeCode。
TypeCode | _DynFixedStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynSequenceStub.type() 返回与此 DynAny 对象关联的 TypeCode。
TypeCode | _DynStructStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynUnionStub.type() 返回与此 DynAny 对象有关联的 TypeCode。
TypeCode | _DynValueStub.type() 返回与此 DynAny 对象有关联的 TypeCode。

参数类型为 TypeCode 的 org.omg.DynamicAny 中的方法
DynAny | DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
void | DynAnyOperations.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynAnyStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynArrayStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynEnumStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynFixedStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynSequenceStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynStructStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynUnionStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynValueStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。

org.omg.DynamicAny.DynAnyFactoryPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static TypeCode InconsistentTypeCodeHelper.type()

org.omg.DynamicAny.DynAnyPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static TypeCode | InvalidValueHelper.type()
static TypeCode | TypeMismatchHelper.type()

org.omg.IOP 中 TypeCode 的使用

返回 TypeCode 的 org.omg.IOP 中的方法
TypeCode | IORHolder._type()
TypeCode | MultipleComponentProfileHolder._type()
TypeCode | ServiceContextHolder._type()
TypeCode | ServiceContextListHolder._type()
TypeCode | TaggedComponentHolder._type()
TypeCode | TaggedProfileHolder._type()
static TypeCode | CodecFactoryHelper.type()
static TypeCode | ComponentIdHelper.type()
static TypeCode | IORHelper.type()
static TypeCode | MultipleComponentProfileHelper.type()
static TypeCode | ProfileIdHelper.type()
static TypeCode | ServiceContextHelper.type()
static TypeCode | ServiceContextListHelper.type()
static TypeCode | ServiceIdHelper.type()
static TypeCode | TaggedComponentHelper.type()
static TypeCode | TaggedProfileHelper.type()

参数类型为 TypeCode 的 org.omg.IOP 中的方法
 Any CodecOperations.decode_value(byte[] data, TypeCode tc)
基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

org.omg.IOP.CodecFactoryPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.IOP.CodecFactoryPackage 中的方法
static TypeCode UnknownEncodingHelper.type()

org.omg.IOP.CodecPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.IOP.CodecPackage 中的方法
static TypeCode | FormatMismatchHelper.type()
static TypeCode | InvalidTypeForEncodingHelper.type()
static TypeCode | TypeMismatchHelper.type()

org.omg.Messaging 中 TypeCode 的使用

返回 TypeCode 的 org.omg.Messaging 中的方法
static TypeCode SyncScopeHelper.type()

org.omg.PortableInterceptor 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableInterceptor 中的方法
TypeCode | IORInterceptor_3_0Holder._type()
TypeCode | ObjectReferenceFactoryHolder._type()
TypeCode | ObjectReferenceTemplateHolder._type()
TypeCode | ObjectReferenceTemplateSeqHolder._type()
TypeCode[] | RequestInfoOperations.exceptions() 返回一个 TypeCode 对象数组，这些对象描述此操作调用可能抛出的用户异常的 TypeCode。
static TypeCode | AdapterManagerIdHelper.type()
static TypeCode | AdapterNameHelper.type()
static TypeCode | AdapterStateHelper.type()
static TypeCode | CurrentHelper.type()
static TypeCode | ForwardRequestHelper.type()
static TypeCode | IORInterceptor_3_0Helper.type()
static TypeCode | InvalidSlotHelper.type()
static TypeCode | ORBIdHelper.type()
static TypeCode | ObjectIdHelper.type()
static TypeCode | ObjectReferenceFactoryHelper.type()
static TypeCode | ObjectReferenceTemplateHelper.type()
static TypeCode | ObjectReferenceTemplateSeqHelper.type()
static TypeCode | ServerIdHelper.type()

org.omg.PortableInterceptor.ORBInitInfoPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static TypeCode | DuplicateNameHelper.type()
static TypeCode | InvalidNameHelper.type()
static TypeCode | ObjectIdHelper.type()

org.omg.PortableServer 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer 中的方法
static TypeCode | CurrentHelper.type()
static TypeCode | ForwardRequestHelper.type()
static TypeCode | POAHelper.type()
static TypeCode | ServantActivatorHelper.type()
static TypeCode | ServantLocatorHelper.type()

org.omg.PortableServer.CurrentPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer.CurrentPackage 中的方法
static TypeCode NoContextHelper.type()

org.omg.PortableServer.POAManagerPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer.POAManagerPackage 中的方法
static TypeCode AdapterInactiveHelper.type()

org.omg.PortableServer.POAPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer.POAPackage 中的方法
static TypeCode | AdapterAlreadyExistsHelper.type()
static TypeCode | AdapterNonExistentHelper.type()
static TypeCode | InvalidPolicyHelper.type()
static TypeCode | NoServantHelper.type()
static TypeCode | ObjectAlreadyActiveHelper.type()
static TypeCode | ObjectNotActiveHelper.type()
static TypeCode | ServantAlreadyActiveHelper.type()
static TypeCode | ServantNotActiveHelper.type()
static TypeCode | WrongAdapterHelper.type()
static TypeCode | WrongPolicyHelper.type()

org.omg.PortableServer.ServantLocatorPackage 中 TypeCode 的使用

返回 TypeCode 的 org.omg.PortableServer.ServantLocatorPackage 中的方法
 TypeCode CookieHolder._type()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.TypeCodeHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.TypeCodeHolder
的使用

没有 org.omg.CORBA.TypeCodeHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ULongLongSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ULongLongSeqHelper
的使用

没有 org.omg.CORBA.ULongLongSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ULongLongSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ULongLongSeqHolder
的使用

使用 ULongLongSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ULongLongSeqHolder 的使用

参数类型为 ULongLongSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_ulonglong_array(ULongLongSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL long long 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ULongSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ULongSeqHelper
的使用

没有 org.omg.CORBA.ULongSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ULongSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ULongSeqHolder
的使用

使用 ULongSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ULongSeqHolder 的使用

参数类型为 ULongSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_ulong_array(ULongSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL long 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UNKNOWN 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UNKNOWN
的使用

没有 org.omg.CORBA.UNKNOWN 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.UNSUPPORTED_POLICY 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.UNSUPPORTED_POLICY
的使用

没有 org.omg.CORBA.UNSUPPORTED_POLICY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.UNSUPPORTED_POLICY_VALUE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
的使用

没有 org.omg.CORBA.UNSUPPORTED_POLICY_VALUE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UShortSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UShortSeqHelper
的使用

没有 org.omg.CORBA.UShortSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UShortSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UShortSeqHolder
的使用

使用 UShortSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 UShortSeqHolder 的使用

参数类型为 UShortSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_ushort_array(UShortSeqHolder seq, int offset, int length)
从输入流读取无符号 IDL short 数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UnionMember 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnionMember
的使用

使用 UnionMember 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 UnionMember 的使用

返回 UnionMember 的 org.omg.CORBA 中的方法
static UnionMember | UnionMemberHelper.extract(Any a)
static UnionMember | UnionMemberHelper.read(InputStream istream)

参数类型为 UnionMember 的 org.omg.CORBA 中的方法
abstract TypeCode | ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members) 创建一个表示 IDL union 的 TypeCode 对象。
static void | UnionMemberHelper.insert(Any a, UnionMember that)
static void | UnionMemberHelper.write(OutputStream ostream, UnionMember value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UnionMemberHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnionMemberHelper
的使用

没有 org.omg.CORBA.UnionMemberHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UnknownUserException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnknownUserException
的使用

使用 UnknownUserException 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 UnknownUserException 的使用

声明为 UnknownUserException 的 org.omg.CORBA 中的字段
 UnknownUserException UnknownUserExceptionHolder.value

返回 UnknownUserException 的 org.omg.CORBA 中的方法
static UnknownUserException | UnknownUserExceptionHelper.extract(Any a)
static UnknownUserException | UnknownUserExceptionHelper.read(InputStream istream)

参数类型为 UnknownUserException 的 org.omg.CORBA 中的方法
static void | UnknownUserExceptionHelper.insert(Any a, UnknownUserException that)
static void | UnknownUserExceptionHelper.write(OutputStream ostream, UnknownUserException value)

参数类型为 UnknownUserException 的 org.omg.CORBA 中的构造方法
UnknownUserExceptionHolder(UnknownUserException initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UnknownUserExceptionHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnknownUserExceptionHelper
的使用

没有 org.omg.CORBA.UnknownUserExceptionHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UnknownUserExceptionHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UnknownUserExceptionHolder
的使用

没有 org.omg.CORBA.UnknownUserExceptionHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.UserException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.UserException
的使用

使用 UserException 的软件包
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.CORBA 中 UserException 的使用

org.omg.CORBA 中 UserException 的子类
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | PolicyError 发生策略错误时抛出的用户异常。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

org.omg.CORBA.DynAnyPackage 中 UserException 的使用

org.omg.CORBA.DynAnyPackage 中 UserException 的子类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 UserException 的使用

org.omg.CORBA.ORBPackage 中 UserException 的子类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.TypeCodePackage 中 UserException 的使用

org.omg.CORBA.TypeCodePackage 中 UserException 的子类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming.NamingContextExtPackage 中 UserException 的使用

org.omg.CosNaming.NamingContextExtPackage 中 UserException 的子类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 UserException 的使用

org.omg.CosNaming.NamingContextPackage 中 UserException 的子类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。

org.omg.IOP.CodecFactoryPackage 中 UserException 的使用

org.omg.IOP.CodecFactoryPackage 中 UserException 的子类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 UserException 的使用

org.omg.IOP.CodecPackage 中 UserException 的子类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 UserException 的使用

org.omg.PortableInterceptor 中 UserException 的子类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 UserException 的使用

org.omg.PortableInterceptor.ORBInitInfoPackage 中 UserException 的子类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 UserException 的使用

org.omg.PortableServer 中 UserException 的子类
 class ForwardRequest
org/omg/PortableServer/ForwardRequest.java。

org.omg.PortableServer.CurrentPackage 中 UserException 的使用

org.omg.PortableServer.CurrentPackage 中 UserException 的子类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 UserException 的使用

org.omg.PortableServer.POAManagerPackage 中 UserException 的子类
 class AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

org.omg.PortableServer.POAPackage 中 UserException 的使用

org.omg.PortableServer.POAPackage 中 UserException 的子类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.VM_ABSTRACT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.VM_ABSTRACT
的使用

没有 org.omg.CORBA.VM_ABSTRACT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.VM_CUSTOM 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.VM_CUSTOM
的使用

没有 org.omg.CORBA.VM_CUSTOM 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.VM_NONE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.VM_NONE
的使用

没有 org.omg.CORBA.VM_NONE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CORBA.VM_TRUNCATABLE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CORBA.VM_TRUNCATABLE
的使用

没有 org.omg.CORBA.VM_TRUNCATABLE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ValueBaseHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ValueBaseHelper
的使用

没有 org.omg.CORBA.ValueBaseHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ValueBaseHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ValueBaseHolder
的使用

没有 org.omg.CORBA.ValueBaseHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ValueMember 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ValueMember
的使用

使用 ValueMember 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 ValueMember 的使用

返回 ValueMember 的 org.omg.CORBA 中的方法
static ValueMember | ValueMemberHelper.extract(Any a)
static ValueMember | ValueMemberHelper.read(InputStream istream)

参数类型为 ValueMember 的 org.omg.CORBA 中的方法
TypeCode | ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members) 为 IDL value 类型创建一个 TypeCode 对象。
static void | ValueMemberHelper.insert(Any a, ValueMember that)
static void | ValueMemberHelper.write(OutputStream ostream, ValueMember value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.ValueMemberHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.ValueMemberHelper
的使用

没有 org.omg.CORBA.ValueMemberHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.VersionSpecHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.VersionSpecHelper
的使用

没有 org.omg.CORBA.VersionSpecHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.VisibilityHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.VisibilityHelper
的使用

没有 org.omg.CORBA.VisibilityHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.WCharSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WCharSeqHelper
的使用

没有 org.omg.CORBA.WCharSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.WCharSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WCharSeqHolder
的使用

使用 WCharSeqHolder 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 WCharSeqHolder 的使用

参数类型为 WCharSeqHolder 的 org.omg.CORBA 中的方法
 void DataInputStream.read_wchar_array(WCharSeqHolder seq, int offset, int length)
从输入流读取 IDL 宽字符数组中从 offset 处开始的 length 个元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.WStringSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WStringSeqHelper
的使用

没有 org.omg.CORBA.WStringSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.WStringSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WStringSeqHolder
的使用

没有 org.omg.CORBA.WStringSeqHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.WStringValueHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WStringValueHelper
的使用

没有 org.omg.CORBA.WStringValueHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.WrongTransaction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WrongTransaction
的使用

使用 WrongTransaction 的软件包
org.omg.CORBA 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA 中 WrongTransaction 的使用

声明为 WrongTransaction 的 org.omg.CORBA 中的字段
 WrongTransaction WrongTransactionHolder.value

返回 WrongTransaction 的 org.omg.CORBA 中的方法
static WrongTransaction | WrongTransactionHelper.extract(Any a)
static WrongTransaction | WrongTransactionHelper.read(InputStream istream)

参数类型为 WrongTransaction 的 org.omg.CORBA 中的方法
static void | WrongTransactionHelper.insert(Any a, WrongTransaction that)
static void | WrongTransactionHelper.write(OutputStream ostream, WrongTransaction value)

抛出 WrongTransaction 的 org.omg.CORBA 中的方法
abstract Request | ORB.get_next_response() 获取已接收到响应的下一个 Request 实例。
abstract void | Request.get_response() 允许用户访问之前使用 send_deferred 方法所触发调用的响应。

参数类型为 WrongTransaction 的 org.omg.CORBA 中的构造方法
WrongTransactionHolder(WrongTransaction initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.WrongTransactionHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WrongTransactionHelper
的使用

没有 org.omg.CORBA.WrongTransactionHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA.WrongTransactionHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA.WrongTransactionHolder
的使用

没有 org.omg.CORBA.WrongTransactionHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA._IDLTypeStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA._IDLTypeStub
的使用

没有 org.omg.CORBA._IDLTypeStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA._PolicyStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA._PolicyStub
的使用

没有 org.omg.CORBA._PolicyStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


_Remote_Stub (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.stub.java.rmi
类 _Remote_Stub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CORBA_2_3.portable.ObjectImpl
            继承者  javax.rmi.CORBA.Stub
                继承者  org.omg.stub.java.rmi._Remote_Stub
所有已实现的接口：
Serializable, Remote, Object
public final class _Remote_Stub
extends Stub
implements Remote

此类为 Remote 类型提供 Stub。该类由 rmic 编译器生成，仍然在 OMG 的平台下工作。其内容随规范的反展而更改，对此不做任何通知。

构造方法摘要
_Remote_Stub()
方法摘要
 String[] _ids()
返回对象实现的存储库 id 数组。
从类 javax.rmi.CORBA.Stub 继承的方法
connect, equals, hashCode, toString
从类 org.omg.CORBA_2_3.portable.ObjectImpl 继承的方法
_get_codebase
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

_Remote_Stub

public _Remote_Stub()
方法详细信息

_ids

public String[] _ids()
返回对象实现的存储库 id 数组。索引 0 处的字符串表示最终派生 (most derived) 的接口。对于通用 CORBA 对象（即 IDL:omg.org/CORBA/Object:1.0）来说，最后一个 id 是隐含的，不会出现在数组中。

指定者：
类 ObjectImpl 中的 _ids
返回：
对象实现的存储库 id 数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.stub.java.rmi (Java Platform SE 6)

 org.omg.stub.java.rmi
类
_Remote_Stub


org.omg.stub.java.rmi (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.stub.java.rmi

包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

请参见：
描述

类摘要
_Remote_Stub 此类为 Remote 类型提供 Stub。

软件包 org.omg.stub.java.rmi 的描述

包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.stub.java.rmi 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.stub.java.rmi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
          • org.omg.stub.java.rmi._Remote_Stub (implements java.rmi.Remote)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.stub.java.rmi 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.stub.java.rmi
的使用

没有 org.omg.stub.java.rmi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.stub.java.rmi._Remote_Stub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.stub.java.rmi._Remote_Stub
的使用

没有 org.omg.stub.java.rmi._Remote_Stub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


ORB (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA_2_3
类 ORB

java.lang.Object
    继承者  org.omg.CORBA.ORB
        继承者  org.omg.CORBA_2_3.ORB

public abstract class ORB
extends ORB

扩展了 org.omg.CORBA.ORB 的类，使 ORB 在 OMG CORBA 规范 2.3 版下可移植。

构造方法摘要
ORB()
方法摘要
Object | get_value_def(String repid)
ValueFactory | lookup_value_factory(String id)
ValueFactory | register_value_factory(String id, ValueFactory factory)
void | set_delegate(Object wrapper)
void | unregister_value_factory(String id)
从类 org.omg.CORBA.ORB 继承的方法
connect, create_abstract_interface_tc, create_alias_tc, create_any, create_array_tc, create_basic_dyn_any, create_context_list, create_dyn_any, create_dyn_array, create_dyn_enum, create_dyn_sequence, create_dyn_struct, create_dyn_union, create_enum_tc, create_environment, create_exception_list, create_exception_tc, create_fixed_tc, create_interface_tc, create_list, create_named_value, create_native_tc, create_operation_list, create_output_stream, create_policy, create_recursive_sequence_tc, create_recursive_tc, create_sequence_tc, create_string_tc, create_struct_tc, create_union_tc, create_value_box_tc, create_value_tc, create_wstring_tc, destroy, disconnect, get_current, get_default_context, get_next_response, get_primitive_tc, get_service_information, init, init, init, list_initial_services, object_to_string, perform_work, poll_next_response, resolve_initial_references, run, send_multiple_requests_deferred, send_multiple_requests_oneway, set_parameters, set_parameters, shutdown, string_to_object, work_pending
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ORB

public ORB()
方法详细信息

register_value_factory

public ValueFactory register_value_factory(String id,
                                           ValueFactory factory)

unregister_value_factory

public void unregister_value_factory(String id)

lookup_value_factory

public ValueFactory lookup_value_factory(String id)

get_value_def

public Object get_value_def(String repid)
                     throws BAD_PARAM
抛出：
BAD_PARAM
另请参见：
CORBA_2_3 包有关未实现特性的注释

set_delegate

public void set_delegate(Object wrapper)
另请参见：
CORBA_2_3 包有关未实现特性的注释
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CORBA_2_3 (Java Platform SE 6)

 org.omg.CORBA_2_3
类
ORB


org.omg.CORBA_2_3 (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CORBA_2_3

CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

请参见：
描述

类摘要
ORB 扩展了 org.omg.CORBA.ORB 的类，使 ORB 在 OMG CORBA 规范 2.3 版下可移植。

软件包 org.omg.CORBA_2_3 的描述

CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。这些更改出现在 OMG 定义的 CORBA API 的最新修订本中。在从 CORBA 包中相应接口所派生的接口中添加了一些新方法，这可提供向后兼容性和避免中断 JCK 测试。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

抽象类 org.omg.CORBA_2_3.ORB 中的以下方法尚未实现：

  • public org.omg.CORBA.portable.ValueFactory register_value_factory(String id, org.omg.CORBA.portable.ValueFactory factory)
  • public void unregister_value_factory(String id)
  • public org.omg.CORBA.portable.ValueFactory lookup_value_factory(String id)
  • public org.omg.CORBA.Object get_value_def(String repid)
  • public void set_delegate(java.lang.Object wrapper)

从以下版本开始：
JDK 1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.CORBA_2_3 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA_2_3 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.CORBA.ORB
      • org.omg.CORBA_2_3.ORB
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CORBA_2_3 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA_2_3
的使用

没有 org.omg.CORBA_2_3 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Delegate (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA_2_3.portable
类 Delegate

java.lang.Object
    继承者  org.omg.CORBA.portable.Delegate
        继承者  org.omg.CORBA_2_3.portable.Delegate

public abstract class Delegate
extends Delegate

Delegate 类提供 CORBA 对象特定于 ORB 供应商的实现。它扩展 org.omg.CORBA.portable.Delegate 并提供 CORBA 2.3 定义的新方法。

从以下版本开始：
JDK1.2
另请参见：
Delegate

构造方法摘要
Delegate()
方法摘要
 String get_codebase(Object self)
返回提供的对象引用的代码基。
从类 org.omg.CORBA.portable.Delegate 继承的方法
create_request, create_request, duplicate, equals, get_domain_managers, get_interface_def, get_policy, hash, hashCode, invoke, is_a, is_equivalent, is_local, non_existent, orb, release, releaseReply, request, request, servant_postinvoke, servant_preinvoke, set_policy_override, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Delegate

public Delegate()
方法详细信息

get_codebase

public String get_codebase(Object self)
返回提供的对象引用的代码基。

参数：
self - 需要返回代码基的对象引用。
返回：
以 url 字符串列表（以空格分隔）的形式返回代码基；如果不存在，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InputStream (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA_2_3.portable
类 InputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  org.omg.CORBA.portable.InputStream
            继承者  org.omg.CORBA_2_3.portable.InputStream
所有已实现的接口：
Closeable
public abstract class InputStream
extends InputStream

InputStream 提供从流读取所有映射的 IDL 类型的接口。它扩展 org.omg.CORBA.portable.InputStream。此类定义 CORBA 2.3 添加的新方法。

从以下版本开始：
JDK1.2
另请参见：
InputStream

构造方法摘要
InputStream()
方法摘要
Object | read_abstract_interface() 解组值对象或适当的 stub 对象。
Object | read_abstract_interface(Class clz) 解组与传递类型相对应的类对象或 stub 类。
Serializable | read_value() 从输入流解组值类型。
Serializable | read_value(BoxedValueHelper factory) 从输入流解组值类型。
Serializable | read_value(Class clz) 从输入流解组值类型。
Serializable | read_value(Serializable value) 从输入流解组值类型。
Serializable | read_value(String rep_id) 从输入流解组值类型。
从类 org.omg.CORBA.portable.InputStream 继承的方法
orb, read_any, read_boolean_array, read_boolean, read_char_array, read_char, read_Context, read_double_array, read_double, read_fixed, read_float_array, read_float, read_long_array, read_long, read_longlong_array, read_longlong, read_Object, read_Object, read_octet_array, read_octet, read_Principal, read_short_array, read_short, read_string, read_TypeCode, read_ulong_array, read_ulong, read_ulonglong_array, read_ulonglong, read_ushort_array, read_ushort, read_wchar_array, read_wchar, read_wstring, read
从类 java.io.InputStream 继承的方法
available, close, mark, markSupported, read, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputStream

public InputStream()
方法详细信息

read_value

public Serializable read_value()
从输入流解组值类型。

返回：
从输入流解组的值类型

read_value

public Serializable read_value(Class clz)
从输入流解组值类型。

参数：
clz - 要解组的值的声明类型
返回：
从输入流解组的值

read_value

public Serializable read_value(BoxedValueHelper factory)
从输入流解组值类型。

参数：
factory - 用于解组值类型的帮助器的实例
返回：
从输入流解组的值

read_value

public Serializable read_value(String rep_id)
从输入流解组值类型。

参数：
rep_id - 标识要解组的值的类型
返回：
从输入流解组的值类型

read_value

public Serializable read_value(Serializable value)
从输入流解组值类型。

参数：
value - 在调用 Streamable._read() 或 CustomMarshal.unmarshal() 解组值前添加到 orb 的间接寻址表的未初始化的值。
返回：
从输入流解组的值类型

read_abstract_interface

public Object read_abstract_interface()
解组值对象或适当的 stub 对象。

返回：
返回值对象或适当的 stub 对象的 ORB 运行时。

read_abstract_interface

public Object read_abstract_interface(Class clz)
解组与传递类型相对应的类对象或 stub 类。

参数：
clz - 与能肯定预期的类型相对应的 stub 类的 Class 对象。
返回：
返回值对象或适当 stub 对象的 ORB 运行时。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA_2_3.portable
类 ObjectImpl

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CORBA_2_3.portable.ObjectImpl
所有已实现的接口：
Object
直接已知子类：
Stub
public abstract class ObjectImpl
extends ObjectImpl

ObjectImpl 类是所有 stub 的基类。它提供基本的代理机制。它扩展 org.omg.CORBA.portable.ObjectImpl 并提供 CORBA 2.3 定义的新方法。

从以下版本开始：
JDK1.2
另请参见：
ObjectImpl

构造方法摘要
ObjectImpl()
方法摘要
 String _get_codebase()
返回此对象引用的代码基。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _ids, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ObjectImpl

public ObjectImpl()
方法详细信息

_get_codebase

public String _get_codebase()
返回此对象引用的代码基。

返回：
以 url 字符串列表（以空格分隔）的形式返回代码基；如果不存在，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OutputStream (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CORBA_2_3.portable
类 OutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  org.omg.CORBA.portable.OutputStream
            继承者  org.omg.CORBA_2_3.portable.OutputStream
所有已实现的接口：
Closeable, Flushable
public abstract class OutputStream
extends OutputStream

OutputStream 提供将所有映射的 IDL 类型写入流的接口。它扩展 org.omg.CORBA.portable.OutputStream 并定义 CORBA 2.3 定义的新方法。

从以下版本开始：
JDK1.2
另请参见：
OutputStream

构造方法摘要
OutputStream()
方法摘要
void | write_abstract_interface(Object obj) 编组值对象或 stub 对象。
void | write_value(Serializable value) 将值类型编组到输出流中。
void | write_value(Serializable value, BoxedValueHelper factory) 将值类型编组到输出流中。
void | write_value(Serializable value, Class clz) 将值类型编组到输出流中。
void | write_value(Serializable value, String repository_id) 将值类型编组到输出流中。
从类 org.omg.CORBA.portable.OutputStream 继承的方法
create_input_stream, orb, write_any, write_boolean_array, write_boolean, write_char_array, write_char, write_Context, write_double_array, write_double, write_fixed, write_float_array, write_float, write_long_array, write_long, write_longlong_array, write_longlong, write_Object, write_octet_array, write_octet, write_Principal, write_short_array, write_short, write_string, write_TypeCode, write_ulong_array, write_ulong, write_ulonglong_array, write_ulonglong, write_ushort_array, write_ushort, write_wchar_array, write_wchar, write_wstring, write
从类 java.io.OutputStream 继承的方法
close, flush, write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OutputStream

public OutputStream()
方法详细信息

write_value

public void write_value(Serializable value)
将值类型编组到输出流中。

参数：
value - 要写入的实际值

write_value

public void write_value(Serializable value,
                        Class clz)
将值类型编组到输出流中。

参数：
value - 要写入的实际值
clz - 要编组的值的声明类型

write_value

public void write_value(Serializable value,
                        String repository_id)
将值类型编组到输出流中。

参数：
value - 要写入的实际值
repository_id - 标识要编组的值类型的类型

write_value

public void write_value(Serializable value,
                        BoxedValueHelper factory)
将值类型编组到输出流中。

参数：
value - 要写入的实际值
factory - 用于编组框值 (boxed value) 的帮助器的实例

write_abstract_interface

public void write_abstract_interface(Object obj)
编组值对象或 stub 对象。

参数：
obj - 要编组的实际值对象或要被编组的 stub
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CORBA_2_3.portable (Java Platform SE 6)

 org.omg.CORBA_2_3.portable
类
Delegate
InputStream
ObjectImpl
OutputStream


org.omg.CORBA_2_3.portable (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CORBA_2_3.portable

提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。

请参见：
描述

类摘要
Delegate | Delegate 类提供 CORBA 对象特定于 ORB 供应商的实现。
InputStream | InputStream 提供从流读取所有映射的 IDL 类型的接口。
ObjectImpl | ObjectImpl 类是所有 stub 的基类。
OutputStream | OutputStream 提供将所有映射的 IDL 类型写入流的接口。

软件包 org.omg.CORBA_2_3.portable 的描述

提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.CORBA_2_3.portable 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA_2_3.portable 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.CORBA.portable.Delegate
      • org.omg.CORBA_2_3.portable.Delegate
    • java.io.InputStream (implements java.io.Closeable)
      • org.omg.CORBA.portable.InputStream
        • org.omg.CORBA_2_3.portable.InputStream
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.omg.CORBA.portable.OutputStream
        • org.omg.CORBA_2_3.portable.OutputStream
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CORBA_2_3.portable 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CORBA_2_3.portable
的使用

使用 org.omg.CORBA_2_3.portable 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 使用的 org.omg.CORBA_2_3.portable 中的类
ObjectImpl
ObjectImpl 类是所有 stub 的基类。

org.omg.CORBA.portable 使用的 org.omg.CORBA_2_3.portable 中的类
InputStream
InputStream 提供从流读取所有映射的 IDL 类型的接口。

org.omg.stub.java.rmi 使用的 org.omg.CORBA_2_3.portable 中的类
ObjectImpl
ObjectImpl 类是所有 stub 的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA_2_3.portable.Delegate 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.portable.Delegate
的使用

没有 org.omg.CORBA_2_3.portable.Delegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA_2_3.portable.InputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.portable.InputStream
的使用

使用 InputStream 的软件包
org.omg.CORBA.portable 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA.portable 中 InputStream 的使用

参数类型为 InputStream 的 org.omg.CORBA.portable 中的方法
 Serializable ValueFactory.read_value(InputStream is)
ORB 运行时在解组值类型的过程中调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA_2_3.portable.ObjectImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.portable.ObjectImpl
的使用

使用 ObjectImpl 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 中 ObjectImpl 的使用

javax.rmi.CORBA 中 ObjectImpl 的子类
 class Stub
必须从其继承所有 RMI-IIOP stub 的基类。

org.omg.stub.java.rmi 中 ObjectImpl 的使用

org.omg.stub.java.rmi 中 ObjectImpl 的子类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA_2_3.portable.OutputStream 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.portable.OutputStream
的使用

没有 org.omg.CORBA_2_3.portable.OutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CORBA_2_3.ORB 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CORBA_2_3.ORB
的使用

没有 org.omg.CORBA_2_3.ORB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


_BindingIteratorImplBase (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 _BindingIteratorImplBase

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CORBA.DynamicImplementation
            继承者  org.omg.CosNaming._BindingIteratorImplBase
所有已实现的接口：
Serializable, Object, IDLEntity, BindingIterator, BindingIteratorOperations
public abstract class _BindingIteratorImplBase
extends DynamicImplementation
implements BindingIterator

另请参见：
序列化表格

构造方法摘要
_BindingIteratorImplBase()
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
void | invoke(ServerRequest r)
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CosNaming.BindingIteratorOperations 继承的方法
destroy, next_n, next_one
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

构造方法详细信息

_BindingIteratorImplBase

public _BindingIteratorImplBase()
方法详细信息

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

覆盖：
类 DynamicImplementation 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组

invoke

public void invoke(ServerRequest r)
覆盖：
类 DynamicImplementation 中的 invoke
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


_BindingIteratorStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 _BindingIteratorStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CosNaming._BindingIteratorStub
所有已实现的接口：
Serializable, Object, IDLEntity, BindingIterator, BindingIteratorOperations
public class _BindingIteratorStub
extends ObjectImpl
implements BindingIterator

BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。 通过使用 NamingContext 上的 list 方法可以获取绑定迭代器。

另请参见：
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder), 序列化表格

构造方法摘要
_BindingIteratorStub()
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
void | destroy() 此操作销毁迭代器。
boolean | next_n(int how_many, BindingListHolder bl) 此操作返回最多可以达到的请求绑定数。
boolean | next_one(BindingHolder b) 此操作返回下一个绑定。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

构造方法详细信息

_BindingIteratorStub

public _BindingIteratorStub()
方法详细信息

next_one

public boolean next_one(BindingHolder b)
此操作返回下一个绑定。如果不存在更多绑定，则返回 false。

指定者：
接口 BindingIteratorOperations 中的 next_one
参数：
b - 返回的绑定

next_n

public boolean next_n(int how_many,
                      BindingListHolder bl)
此操作返回最多可以达到的请求绑定数。

指定者：
接口 BindingIteratorOperations 中的 next_n
参数：
how_many - 要返回的最大绑定数

bl - 返回的绑定

destroy

public void destroy()
此操作销毁迭代器。

指定者：
接口 BindingIteratorOperations 中的 destroy

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_NamingContextExtStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 _NamingContextExtStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CosNaming._NamingContextExtStub
所有已实现的接口：
Serializable, Object, IDLEntity, NamingContext, NamingContextExt, NamingContextExtOperations, NamingContextOperations
public class _NamingContextExtStub
extends ObjectImpl
implements NamingContextExt

NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。可以同时将不同名称绑定到相同或不同上下文中的对象。通过 NamingContextExt，可以使用基于 URL 的名称进行绑定和解析。

请参阅 CORBA COS 命名规范。

另请参见：
序列化表格

构造方法摘要
_NamingContextExtStub()
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
void | bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
void | bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | destroy() destroy 操作删除命名上下文。
void | list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。
NamingContext | new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
void | rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
NameComponent[] | to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。
String | to_string(NameComponent[] n) 此操作从 Name 组件数组创建字符串化的名称。
String | to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
void | unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

构造方法详细信息

_NamingContextExtStub

public _NamingContextExtStub()
方法详细信息

to_string

public String to_string(NameComponent[] n)
                 throws InvalidName
此操作从 Name 组件数组创建字符串化的名称。

指定者：
接口 NamingContextExtOperations 中的 to_string
参数：
n - 对象名

抛出：
org.omg.CosNaming.NamingContextExtPackage.InvalidName - 指示名称不标识绑定。

InvalidName

to_name

public NameComponent[] to_name(String sn)
                        throws InvalidName
此操作将“字符串化的名称”转换为等效的“名称组件”数组。

指定者：
接口 NamingContextExtOperations 中的 to_name
参数：
sn - 对象的“字符串化的名称”

抛出：
org.omg.CosNaming.NamingContextExtPackage.InvalidName - 指示名称不标识绑定。

InvalidName

to_url

public String to_url(String addr,
                     String sn)
              throws InvalidAddress,
                     InvalidName
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

指定者：
接口 NamingContextExtOperations 中的 to_url
参数：
addr - 运行“命名服务”的主机基于 Internet 的地址

sn - 对象的“字符串化的名称”

抛出：
org.omg.CosNaming.NamingContextExtPackage.InvalidName - 指示名称不标识绑定。

org.omg.CosNaming.NamingContextPackage.InvalidAddress - 指示主机基于 Internet 的地址不正确

InvalidAddress
InvalidName

resolve_str

public Object resolve_str(String sn)
                   throws NotFound,
                          CannotProceed,
                          InvalidName
此操作将“字符串化的”名称解析为对象引用。

指定者：
接口 NamingContextExtOperations 中的 resolve_str
参数：
sn - 对象的“字符串化的名称”

抛出：
NotFound - 指示不存在给定名称的对象引用。

CannotProceed - 指示给定的组合名称不正确

org.omg.CosNaming.NamingContextExtPackage.InvalidName - 指示名称不标识绑定。

InvalidName

bind

public void bind(NameComponent[] n,
                 Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
在命名上下文中创建名称和对象的绑定。在传递组合名称以进行解析时，使用 bind 绑定的命名上下文不参与名称解析。

指定者：
接口 NamingContextOperations 中的 bind
参数：
n - 对象名

obj - 要与给定名称绑定在一起的对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

AlreadyBound - 指示已将对象绑定到指定名称。

bind_context

public void bind_context(NameComponent[] n,
                         NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
命名作为命名上下文的对象。在传递组合名称以进行解析时，使用 bind_context() 绑定的命名上下文参与名称解析。

指定者：
接口 NamingContextOperations 中的 bind_context
参数：
n - 对象名

nc - 要与给定名称绑定在一起的 NamingContect 对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

AlreadyBound - 指示已将对象绑定到指定名称。

rebind

public void rebind(NameComponent[] n,
                   Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。在传递组合名称以进行解析时，使用 rebind 绑定的命名上下文不参与名称解析。

指定者：
接口 NamingContextOperations 中的 rebind
参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

rebind_context

public void rebind_context(NameComponent[] n,
                           NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。在传递组合名称以进行解析时，使用 rebind_context() 绑定的命名上下文参与名称解析。

指定者：
接口 NamingContextOperations 中的 rebind_context
参数：
n - 对象名

nc - 要与给定名称重新绑定在一起的 NamingContect 对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

resolve

public Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
解析操作是指检索绑定到给定上下文中名称的对象的过程。给定名称必须与绑定名称完全匹配。命名服务不返回对象的类型。客户端负责将对象“收缩”为适当的类型。即客户端通常将返回对象由 Object 强制转换为更专用的接口。

指定者：
接口 NamingContextOperations 中的 resolve
参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

unbind

public void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
unbind 操作从上下文移除名称绑定。

指定者：
接口 NamingContextOperations 中的 unbind
参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

list

public void list(int how_many,
                 BindingListHolder bl,
                 BindingIteratorHolder bi)
列表操作允许客户端迭代命名上下文中的一组绑定。

list 操作在 BindingList bl 中返回最多可以达到的请求绑定数。

  • 如果命名上下文包含附加绑定，则 list 操作将返回带有附加绑定的 BindingIterator。
  • 如果命名上下文不包含附加绑定，则绑定迭代器为 nil 对象引用。

指定者：
接口 NamingContextOperations 中的 list
参数：
how_many - 要返回的最大绑定数

bl - 返回的绑定列表

bi - 返回的绑定迭代器

new_context

public NamingContext new_context()
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。没有将新上下文绑定到任何名称。

指定者：
接口 NamingContextOperations 中的 new_context

bind_new_context

public NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
此操作创建新上下文并将其绑定到作为参数提供的名称。新创建的上下文由将其绑定到的上下文的命名服务器（即实现名称参数（最后一个组件除外）表示的上下文的命名服务器）实现。

指定者：
接口 NamingContextOperations 中的 bind_new_context
参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

AlreadyBound - 指示已将对象绑定到指定名称。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

destroy

public void destroy()
             throws NotEmpty
destroy 操作删除命名上下文。如果命名上下文包含绑定，则引发 NotEmpty 异常。

指定者：
接口 NamingContextOperations 中的 destroy
抛出：
NotEmpty - 指示命名上下文包含绑定。

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_NamingContextImplBase (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 _NamingContextImplBase

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CORBA.DynamicImplementation
            继承者  org.omg.CosNaming._NamingContextImplBase
所有已实现的接口：
Serializable, Object, IDLEntity, NamingContext, NamingContextOperations
public abstract class _NamingContextImplBase
extends DynamicImplementation
implements NamingContext

另请参见：
序列化表格

构造方法摘要
_NamingContextImplBase()
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
void | invoke(ServerRequest r)
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CosNaming.NamingContextOperations 继承的方法
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

构造方法详细信息

_NamingContextImplBase

public _NamingContextImplBase()
方法详细信息

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

覆盖：
类 DynamicImplementation 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组

invoke

public void invoke(ServerRequest r)
覆盖：
类 DynamicImplementation 中的 invoke
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_NamingContextStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 _NamingContextStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CosNaming._NamingContextStub
所有已实现的接口：
Serializable, Object, IDLEntity, NamingContext, NamingContextOperations
public class _NamingContextStub
extends ObjectImpl
implements NamingContext

命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。可以同时将不同名称绑定到相同或不同上下文中的对象。

请参阅 CORBA COS 命名规范。

另请参见：
序列化表格

构造方法摘要
_NamingContextStub()
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
void | bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | destroy() destroy 操作删除命名上下文。
void | list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。
NamingContext | new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
void | rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
void | unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

构造方法详细信息

_NamingContextStub

public _NamingContextStub()
方法详细信息

bind

public void bind(NameComponent[] n,
                 Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
在命名上下文中创建名称和对象的绑定。在传递组合名称以进行解析时，使用 bind 绑定的命名上下文不参与名称解析。

指定者：
接口 NamingContextOperations 中的 bind
参数：
n - 对象名

obj - 要与给定名称绑定在一起的对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

AlreadyBound - 指示已将对象绑定到指定名称。

bind_context

public void bind_context(NameComponent[] n,
                         NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
命名作为命名上下文的对象。在传递组合名称以进行解析时，使用 bind_context() 绑定的命名上下文参与名称解析。

指定者：
接口 NamingContextOperations 中的 bind_context
参数：
n - 对象名

nc - 要与给定名称绑定在一起的 NamingContect 对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

AlreadyBound - 指示已将对象绑定到指定名称。

rebind

public void rebind(NameComponent[] n,
                   Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。在传递组合名称以进行解析时，使用 rebind 绑定的命名上下文不参与名称解析。

指定者：
接口 NamingContextOperations 中的 rebind
参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

rebind_context

public void rebind_context(NameComponent[] n,
                           NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。在传递组合名称以进行解析时，使用 rebind_context() 绑定的命名上下文参与名称解析。

指定者：
接口 NamingContextOperations 中的 rebind_context
参数：
n - 对象名

nc - 要与给定名称重新绑定在一起的 NamingContect 对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

resolve

public Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
解析操作是指检索绑定到给定上下文中名称的对象的过程。给定名称必须与绑定名称完全匹配。命名服务不返回对象的类型。客户端负责将对象“收缩”为适当的类型。即客户端通常将返回对象由 Object 强制转换为更专用的接口。

指定者：
接口 NamingContextOperations 中的 resolve
参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

unbind

public void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
unbind 操作从上下文移除名称绑定。

指定者：
接口 NamingContextOperations 中的 unbind
参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

list

public void list(int how_many,
                 BindingListHolder bl,
                 BindingIteratorHolder bi)
列表操作允许客户端迭代命名上下文中的一组绑定。

list 操作在 BindingList bl 中返回最多可以达到的请求绑定数。

  • 如果命名上下文包含附加绑定，则 list 操作将返回带有附加绑定的 BindingIterator。
  • 如果命名上下文不包含附加绑定，则绑定迭代器为 nil 对象引用。

指定者：
接口 NamingContextOperations 中的 list
参数：
how_many - 要返回的最大绑定数

bl - 返回的绑定列表

bi - 返回的绑定迭代器

new_context

public NamingContext new_context()
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。没有将新上下文绑定到任何名称。

指定者：
接口 NamingContextOperations 中的 new_context

bind_new_context

public NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
此操作创建一个新上下文并将其绑定到作为参数提供的名称。新创建的上下文由将其绑定到的上下文的命名服务器（即实现名称参数（最后一个组件除外）表示的上下文的命名服务器）实现。

指定者：
接口 NamingContextOperations 中的 bind_new_context
参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

AlreadyBound - 指示已将对象绑定到指定名称。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

destroy

public void destroy()
             throws NotEmpty
destroy 操作删除命名上下文。如果命名上下文包含绑定，则引发 NotEmpty 异常。

指定者：
接口 NamingContextOperations 中的 destroy
抛出：
NotEmpty - 指示命名上下文包含绑定。

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Binding (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 Binding

java.lang.Object
    继承者  org.omg.CosNaming.Binding
所有已实现的接口：
Serializable, IDLEntity
public final class Binding
extends Object
implements IDLEntity

org/omg/CosNaming/Binding.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

另请参见：
序列化表格

字段摘要
NameComponent[] | binding_name
BindingType | binding_type
构造方法摘要
Binding()
Binding(NameComponent[] _binding_name, BindingType _binding_type)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

binding_name

public NameComponent[] binding_name

binding_type

public BindingType binding_type
构造方法详细信息

Binding

public Binding()

Binding

public Binding(NameComponent[] _binding_name,
               BindingType _binding_type)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingHelper

java.lang.Object
    继承者  org.omg.CosNaming.BindingHelper

public abstract class BindingHelper
extends Object

org/omg/CosNaming/BindingHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
BindingHelper()
方法摘要
static Binding | extract(Any a)
static String | id()
static void | insert(Any a, Binding that)
static Binding | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Binding value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BindingHelper

public BindingHelper()
方法详细信息

insert

public static void insert(Any a,
                          Binding that)

extract

public static Binding extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Binding read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Binding value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingHolder

java.lang.Object
    继承者  org.omg.CosNaming.BindingHolder
所有已实现的接口：
Streamable
public final class BindingHolder
extends Object
implements Streamable

org/omg/CosNaming/BindingHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
 Binding value
构造方法摘要
BindingHolder()
BindingHolder(Binding initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Binding value
构造方法详细信息

BindingHolder

public BindingHolder()

BindingHolder

public BindingHolder(Binding initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingIterator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
接口 BindingIterator

所有超级接口：
BindingIteratorOperations, IDLEntity, Object, Serializable
所有已知实现类：
_BindingIteratorImplBase, _BindingIteratorStub
public interface BindingIterator
extends BindingIteratorOperations, Object, IDLEntity

BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。 通过使用 NamingContext 上的 list 方法可以获取绑定迭代器。

另请参见：
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

方法摘要
从接口 org.omg.CosNaming.BindingIteratorOperations 继承的方法
destroy, next_n, next_one
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingIteratorHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingIteratorHelper

java.lang.Object
    继承者  org.omg.CosNaming.BindingIteratorHelper

public abstract class BindingIteratorHelper
extends Object

BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。 通过使用 NamingContext 上的 list 方法可以获取绑定迭代器。

另请参见：
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

构造方法摘要
BindingIteratorHelper()
方法摘要
static BindingIterator | extract(Any a)
static String | id()
static void | insert(Any a, BindingIterator that)
static BindingIterator | narrow(Object obj)
static BindingIterator | read(InputStream istream)
static TypeCode | type()
static BindingIterator | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, BindingIterator value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BindingIteratorHelper

public BindingIteratorHelper()
方法详细信息

insert

public static void insert(Any a,
                          BindingIterator that)

extract

public static BindingIterator extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static BindingIterator read(InputStream istream)

write

public static void write(OutputStream ostream,
                         BindingIterator value)

narrow

public static BindingIterator narrow(Object obj)

unchecked_narrow

public static BindingIterator unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingIteratorHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingIteratorHolder

java.lang.Object
    继承者  org.omg.CosNaming.BindingIteratorHolder
所有已实现的接口：
Streamable
public final class BindingIteratorHolder
extends Object
implements Streamable

BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。 通过使用 NamingContext 上的 list 方法可以获取绑定迭代器。

另请参见：
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

字段摘要
 BindingIterator value
构造方法摘要
BindingIteratorHolder()
BindingIteratorHolder(BindingIterator initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public BindingIterator value
构造方法详细信息

BindingIteratorHolder

public BindingIteratorHolder()

BindingIteratorHolder

public BindingIteratorHolder(BindingIterator initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingIteratorOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
接口 BindingIteratorOperations

所有已知子接口：
BindingIterator
所有已知实现类：
_BindingIteratorImplBase, _BindingIteratorStub, BindingIteratorPOA
public interface BindingIteratorOperations

BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。 通过使用 NamingContext 上的 list 方法可以获取绑定迭代器。

另请参见：
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

方法摘要
void | destroy() 此操作销毁迭代器。
boolean | next_n(int how_many, BindingListHolder bl) 此操作返回最多可以达到的请求绑定数。
boolean | next_one(BindingHolder b) 此操作返回下一个绑定。

方法详细信息

next_one

boolean next_one(BindingHolder b)
此操作返回下一个绑定。如果不存在更多绑定，则返回 false。

参数：
b - 返回的绑定

next_n

boolean next_n(int how_many,
               BindingListHolder bl)
此操作返回最多可以达到的请求绑定数。

参数：
how_many - 要返回的最大绑定数

bl - 返回的绑定

destroy

void destroy()
此操作销毁迭代器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingIteratorPOA (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingIteratorPOA

java.lang.Object
    继承者  org.omg.PortableServer.Servant
        继承者  org.omg.CosNaming.BindingIteratorPOA
所有已实现的接口：
InvokeHandler, BindingIteratorOperations
public abstract class BindingIteratorPOA
extends Servant
implements BindingIteratorOperations, InvokeHandler

BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。 通过使用 NamingContext 上的 list 方法可以获取绑定迭代器。

另请参见：
NamingContextOperations.list(int, org.omg.CosNaming.BindingListHolder, org.omg.CosNaming.BindingIteratorHolder)

构造方法摘要
BindingIteratorPOA()
方法摘要
String[] | _all_interfaces(POA poa, byte[] objectId) ORB 使用此操作从 servant 获取完整的类型信息。
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) 由 ORB 调用来调度对 servant 的请求。
BindingIterator | _this()
BindingIterator | _this(ORB orb)
从类 org.omg.PortableServer.Servant 继承的方法
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.omg.CosNaming.BindingIteratorOperations 继承的方法
destroy, next_n, next_one

构造方法详细信息

BindingIteratorPOA

public BindingIteratorPOA()
方法详细信息

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
从接口 InvokeHandler 复制的描述
由 ORB 调用来调度对 servant 的请求。 ORB 传递方法名称、包含编组参数的 InputStream，以及 servant 用来构造恰当应答的 ResponseHandler。 此方法只可能抛出 CORBA SystemException。 该方法必须返回包含已编组应答的 ResponseHandler 所创建的 OutputStream。 在方法调用的生存期外，servant 必须仍然保留一个对 ResponseHandler 的引用。 Servant 的行为定义如下：

1. 确定正确的方法和 InputStream 中的已解组参数。

2. 调用方法实现。

3. 如果没有任何用户异常，则使用 ResponseHandler 创建一个正常应答。

4. 如果发生用户异常，则使用 ResponseHandler 创建异常。

5. ResponseHandler 将编组应答返回到 OutputStream。

6. 将 OutputStream 返回到 ORB。

指定者：
接口 InvokeHandler 中的 _invoke
参数：
$method - 方法名称。
in - 包含已编组参数的 InputStream。
$rh - servant 用来构造正确应答的 ResponseHandler。
返回：
包含已编组应答的 ResponseHandler 所创建的 OutputStream。

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
从类 Servant 复制的描述
ORB 使用此操作从 servant 获取完整的类型信息。

指定者：
类 Servant 中的 _all_interfaces
参数：
poa - 与 servant 关联的 POA。
objectId - 对应于与此 servant 关联的对象的 id。
返回：
对象类型信息列表。

_this

public BindingIterator _this()

_this

public BindingIterator _this(ORB orb)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingListHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingListHelper

java.lang.Object
    继承者  org.omg.CosNaming.BindingListHelper

public abstract class BindingListHelper
extends Object

绑定列表。

构造方法摘要
BindingListHelper()
方法摘要
static Binding[] | extract(Any a)
static String | id()
static void | insert(Any a, Binding[] that)
static Binding[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Binding[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BindingListHelper

public BindingListHelper()
方法详细信息

insert

public static void insert(Any a,
                          Binding[] that)

extract

public static Binding[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Binding[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Binding[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingListHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingListHolder

java.lang.Object
    继承者  org.omg.CosNaming.BindingListHolder
所有已实现的接口：
Streamable
public final class BindingListHolder
extends Object
implements Streamable

绑定列表。

字段摘要
 Binding[] value
构造方法摘要
BindingListHolder()
BindingListHolder(Binding[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Binding[] value
构造方法详细信息

BindingListHolder

public BindingListHolder()

BindingListHolder

public BindingListHolder(Binding[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingType

java.lang.Object
    继承者  org.omg.CosNaming.BindingType
所有已实现的接口：
Serializable, IDLEntity
public class BindingType
extends Object
implements IDLEntity

指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。

另请参见：
序列化表格

字段摘要
static int | _ncontext
static int | _nobject
static BindingType | ncontext
static BindingType | nobject
构造方法摘要
protected BindingType(int value)
方法摘要
static BindingType | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_nobject

public static final int _nobject
另请参见：
常量字段值

nobject

public static final BindingType nobject

_ncontext

public static final int _ncontext
另请参见：
常量字段值

ncontext

public static final BindingType ncontext
构造方法详细信息

BindingType

protected BindingType(int value)
方法详细信息

value

public int value()

from_int

public static BindingType from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingTypeHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingTypeHelper

java.lang.Object
    继承者  org.omg.CosNaming.BindingTypeHelper

public abstract class BindingTypeHelper
extends Object

指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。

构造方法摘要
BindingTypeHelper()
方法摘要
static BindingType | extract(Any a)
static String | id()
static void | insert(Any a, BindingType that)
static BindingType | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, BindingType value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BindingTypeHelper

public BindingTypeHelper()
方法详细信息

insert

public static void insert(Any a,
                          BindingType that)

extract

public static BindingType extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static BindingType read(InputStream istream)

write

public static void write(OutputStream ostream,
                         BindingType value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BindingTypeHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 BindingTypeHolder

java.lang.Object
    继承者  org.omg.CosNaming.BindingTypeHolder
所有已实现的接口：
Streamable
public final class BindingTypeHolder
extends Object
implements Streamable

指定给定的绑定是对象（非命名上下文的对象）的还是命名上下文的。

字段摘要
 BindingType value
构造方法摘要
BindingTypeHolder()
BindingTypeHolder(BindingType initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public BindingType value
构造方法详细信息

BindingTypeHolder

public BindingTypeHolder()

BindingTypeHolder

public BindingTypeHolder(BindingType initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IstringHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 IstringHelper

java.lang.Object
    继承者  org.omg.CosNaming.IstringHelper

public abstract class IstringHelper
extends Object

org/omg/CosNaming/IstringHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
IstringHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IstringHelper

public IstringHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameComponent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NameComponent

java.lang.Object
    继承者  org.omg.CosNaming.NameComponent
所有已实现的接口：
Serializable, IDLEntity
public final class NameComponent
extends Object
implements IDLEntity

org/omg/CosNaming/NameComponent.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

另请参见：
序列化表格

字段摘要
String | id
String | kind
构造方法摘要
NameComponent()
NameComponent(String _id, String _kind)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

id

public String id

kind

public String kind
构造方法详细信息

NameComponent

public NameComponent()

NameComponent

public NameComponent(String _id,
                     String _kind)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameComponentHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NameComponentHelper

java.lang.Object
    继承者  org.omg.CosNaming.NameComponentHelper

public abstract class NameComponentHelper
extends Object

org/omg/CosNaming/NameComponentHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
NameComponentHelper()
方法摘要
static NameComponent | extract(Any a)
static String | id()
static void | insert(Any a, NameComponent that)
static NameComponent | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameComponent value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NameComponentHelper

public NameComponentHelper()
方法详细信息

insert

public static void insert(Any a,
                          NameComponent that)

extract

public static NameComponent extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameComponent read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameComponent value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameComponentHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NameComponentHolder

java.lang.Object
    继承者  org.omg.CosNaming.NameComponentHolder
所有已实现的接口：
Streamable
public final class NameComponentHolder
extends Object
implements Streamable

org/omg/CosNaming/NameComponentHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
 NameComponent value
构造方法摘要
NameComponentHolder()
NameComponentHolder(NameComponent initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public NameComponent value
构造方法详细信息

NameComponentHolder

public NameComponentHolder()

NameComponentHolder

public NameComponentHolder(NameComponent initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NameHelper

java.lang.Object
    继承者  org.omg.CosNaming.NameHelper

public abstract class NameHelper
extends Object

名称是名称组件的序列。

构造方法摘要
NameHelper()
方法摘要
static NameComponent[] | extract(Any a)
static String | id()
static void | insert(Any a, NameComponent[] that)
static NameComponent[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameComponent[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NameHelper

public NameHelper()
方法详细信息

insert

public static void insert(Any a,
                          NameComponent[] that)

extract

public static NameComponent[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameComponent[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameComponent[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NameHolder

java.lang.Object
    继承者  org.omg.CosNaming.NameHolder
所有已实现的接口：
Streamable
public final class NameHolder
extends Object
implements Streamable

名称是名称组件的序列。

字段摘要
 NameComponent[] value
构造方法摘要
NameHolder()
NameHolder(NameComponent[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public NameComponent[] value
构造方法详细信息

NameHolder

public NameHolder()

NameHolder

public NameHolder(NameComponent[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
接口 NamingContext

所有超级接口：
IDLEntity, NamingContextOperations, Object, Serializable
所有已知子接口：
NamingContextExt
所有已知实现类：
_NamingContextExtStub, _NamingContextImplBase, _NamingContextStub
public interface NamingContext
extends NamingContextOperations, Object, IDLEntity

命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。可以同时将不同名称绑定到相同或不同上下文中的对象。

请参阅 CORBA COS 命名规范。

方法摘要
从接口 org.omg.CosNaming.NamingContextOperations 继承的方法
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextExt (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
接口 NamingContextExt

所有超级接口：
IDLEntity, NamingContext, NamingContextExtOperations, NamingContextOperations, Object, Serializable
所有已知实现类：
_NamingContextExtStub
public interface NamingContextExt
extends NamingContextExtOperations, NamingContext, IDLEntity

NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。可以同时将不同名称绑定到相同或不同上下文中的对象。通过 NamingContextExt，可以使用基于 URL 的名称进行绑定和解析。

请参阅 CORBA COS 命名规范。

方法摘要
从接口 org.omg.CosNaming.NamingContextExtOperations 继承的方法
resolve_str, to_name, to_string, to_url
从接口 org.omg.CosNaming.NamingContextOperations 继承的方法
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextExtHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NamingContextExtHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextExtHelper

public abstract class NamingContextExtHelper
extends Object

NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。可以同时将不同名称绑定到相同或不同上下文中的对象。通过 NamingContextExt，可以使用基于 URL 的名称进行绑定和解析。

请参阅 CORBA COS 命名规范。

构造方法摘要
NamingContextExtHelper()
方法摘要
static NamingContextExt | extract(Any a)
static String | id()
static void | insert(Any a, NamingContextExt that)
static NamingContextExt | narrow(Object obj)
static NamingContextExt | read(InputStream istream)
static TypeCode | type()
static NamingContextExt | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, NamingContextExt value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NamingContextExtHelper

public NamingContextExtHelper()
方法详细信息

insert

public static void insert(Any a,
                          NamingContextExt that)

extract

public static NamingContextExt extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NamingContextExt read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NamingContextExt value)

narrow

public static NamingContextExt narrow(Object obj)

unchecked_narrow

public static NamingContextExt unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextExtHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NamingContextExtHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextExtHolder
所有已实现的接口：
Streamable
public final class NamingContextExtHolder
extends Object
implements Streamable

NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。可以同时将不同名称绑定到相同或不同上下文中的对象。通过 NamingContextExt，可以使用基于 URL 的名称进行绑定和解析。

请参阅 CORBA COS 命名规范。

字段摘要
 NamingContextExt value
构造方法摘要
NamingContextExtHolder()
NamingContextExtHolder(NamingContextExt initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public NamingContextExt value
构造方法详细信息

NamingContextExtHolder

public NamingContextExtHolder()

NamingContextExtHolder

public NamingContextExtHolder(NamingContextExt initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextExtOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
接口 NamingContextExtOperations

所有超级接口：
NamingContextOperations
所有已知子接口：
NamingContextExt
所有已知实现类：
_NamingContextExtStub, NamingContextExtPOA
public interface NamingContextExtOperations
extends NamingContextOperations

NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。可以同时将不同名称绑定到相同或不同上下文中的对象。通过 NamingContextExt，可以使用基于 URL 的名称进行绑定和解析。

请参阅 CORBA COS 命名规范。

方法摘要
Object | resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
NameComponent[] | to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。
String | to_string(NameComponent[] n) 此操作根据 Name 组件数组创建字符串化的名称。
String | to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
从接口 org.omg.CosNaming.NamingContextOperations 继承的方法
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

方法详细信息

to_string

String to_string(NameComponent[] n)
                 throws InvalidName
此操作根据 Name 组件数组创建字符串化的名称。

参数：
n - 对象名

抛出：
org.omg.CosNaming.NamingContextExtPackage.InvalidName - 指示名称不标识绑定。

InvalidName

to_name

NameComponent[] to_name(String sn)
                        throws InvalidName
此操作将“字符串化的名称”转换为等效的“名称组件”数组。

参数：
sn - 对象的“字符串化的名称”

抛出：
org.omg.CosNaming.NamingContextExtPackage.InvalidName - 指示名称不标识绑定。

InvalidName

to_url

String to_url(String addr,
              String sn)
              throws InvalidAddress,
                     InvalidName
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

参数：
addr - 运行“命名服务”的主机基于 Internet 的地址

sn - 对象的“字符串化的名称”

抛出：
org.omg.CosNaming.NamingContextExtPackage.InvalidName - 指示名称不标识绑定。

org.omg.CosNaming.NamingContextPackage.InvalidAddress - 指示主机基于 Internet 的地址不正确

InvalidAddress
InvalidName

resolve_str

Object resolve_str(String sn)
                   throws NotFound,
                          CannotProceed,
                          InvalidName
此操作将“字符串化的”名称解析为对象引用。

参数：
sn - 对象的“字符串化的名称”

抛出：
NotFound - 指示不存在给定名称的对象引用。

CannotProceed - 指示给定的组合名称不正确

org.omg.CosNaming.NamingContextExtPackage.InvalidName - 指示名称不标识绑定。

InvalidName
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextExtPOA (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NamingContextExtPOA

java.lang.Object
    继承者  org.omg.PortableServer.Servant
        继承者  org.omg.CosNaming.NamingContextExtPOA
所有已实现的接口：
InvokeHandler, NamingContextExtOperations, NamingContextOperations
public abstract class NamingContextExtPOA
extends Servant
implements NamingContextExtOperations, InvokeHandler

NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。可以同时将不同名称绑定到相同或不同上下文中的对象。通过 NamingContextExt，可以使用基于 URL 的名称进行绑定和解析。

请参阅 CORBA COS 命名规范。

构造方法摘要
NamingContextExtPOA()
方法摘要
String[] | _all_interfaces(POA poa, byte[] objectId) ORB 使用此操作从 servant 获取完整的类型信息。
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) 由 ORB 调用来调度对 servant 的请求。
NamingContextExt | _this()
NamingContextExt | _this(ORB orb)
从类 org.omg.PortableServer.Servant 继承的方法
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.omg.CosNaming.NamingContextExtOperations 继承的方法
resolve_str, to_name, to_string, to_url
从接口 org.omg.CosNaming.NamingContextOperations 继承的方法
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

构造方法详细信息

NamingContextExtPOA

public NamingContextExtPOA()
方法详细信息

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
从接口 InvokeHandler 复制的描述
由 ORB 调用来调度对 servant 的请求。 ORB 传递方法名称、包含编组参数的 InputStream，以及 servant 用来构造恰当应答的 ResponseHandler。 此方法只可能抛出 CORBA SystemException。 该方法必须返回包含已编组应答的 ResponseHandler 所创建的 OutputStream。 在方法调用的生存期外，servant 必须仍然保留一个对 ResponseHandler 的引用。 Servant 的行为定义如下：

1. 确定正确的方法和 InputStream 中的已解组参数。

2. 调用方法实现。

3. 如果没有任何用户异常，则使用 ResponseHandler 创建一个正常应答。

4. 如果发生用户异常，则使用 ResponseHandler 创建异常。

5. ResponseHandler 将编组应答返回到 OutputStream。

6. 将 OutputStream 返回到 ORB。

指定者：
接口 InvokeHandler 中的 _invoke
参数：
$method - 方法名称。
in - 包含已编组参数的 InputStream。
$rh - servant 用来构造正确应答的 ResponseHandler。
返回：
包含已编组应答的 ResponseHandler 所创建的 OutputStream。

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
从类 Servant 复制的描述
ORB 使用此操作从 servant 获取完整的类型信息。

指定者：
类 Servant 中的 _all_interfaces
参数：
poa - 与 servant 关联的 POA。
objectId - 对应于与此 servant 关联的对象的 id。
返回：
对象类型信息列表。

_this

public NamingContextExt _this()

_this

public NamingContextExt _this(ORB orb)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NamingContextHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextHelper

public abstract class NamingContextHelper
extends Object

命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。可以同时将不同名称绑定到相同或不同上下文中的对象。

请参阅 CORBA COS 命名规范。

构造方法摘要
NamingContextHelper()
方法摘要
static NamingContext | extract(Any a)
static String | id()
static void | insert(Any a, NamingContext that)
static NamingContext | narrow(Object obj)
static NamingContext | read(InputStream istream)
static TypeCode | type()
static NamingContext | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, NamingContext value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NamingContextHelper

public NamingContextHelper()
方法详细信息

insert

public static void insert(Any a,
                          NamingContext that)

extract

public static NamingContext extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NamingContext read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NamingContext value)

narrow

public static NamingContext narrow(Object obj)

unchecked_narrow

public static NamingContext unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NamingContextHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextHolder
所有已实现的接口：
Streamable
public final class NamingContextHolder
extends Object
implements Streamable

命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。可以同时将不同名称绑定到相同或不同上下文中的对象。

请参阅 CORBA COS 命名规范。

字段摘要
 NamingContext value
构造方法摘要
NamingContextHolder()
NamingContextHolder(NamingContext initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public NamingContext value
构造方法详细信息

NamingContextHolder

public NamingContextHolder()

NamingContextHolder

public NamingContextHolder(NamingContext initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
接口 NamingContextOperations

所有已知子接口：
NamingContext, NamingContextExt, NamingContextExtOperations
所有已知实现类：
_NamingContextExtStub, _NamingContextImplBase, _NamingContextStub, NamingContextExtPOA, NamingContextPOA
public interface NamingContextOperations

命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。可以同时将不同名称绑定到相同或不同上下文中的对象。

请参阅 CORBA COS 命名规范。

方法摘要
void | bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
void | bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | destroy() destroy 操作删除命名上下文。
void | list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) list 操作允许客户端迭代命名上下文中的一组绑定。
NamingContext | new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
void | rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
void | unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。

方法详细信息

bind

void bind(NameComponent[] n,
          Object obj)
          throws NotFound,
                 CannotProceed,
                 InvalidName,
                 AlreadyBound
在命名上下文中创建名称和对象的绑定。在传递组合名称以进行解析时，使用 bind 绑定的命名上下文不参与名称解析。

参数：
n - 对象名

obj - 要与给定名称绑定在一起的对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

AlreadyBound - 指示已将对象绑定到指定名称。

bind_context

void bind_context(NameComponent[] n,
                  NamingContext nc)
                  throws NotFound,
                         CannotProceed,
                         InvalidName,
                         AlreadyBound
命名作为命名上下文的对象。在传递组合名称以进行解析时，使用 bind_context() 绑定的命名上下文参与名称解析。

参数：
n - 对象名

nc - 要与给定名称绑定在一起的 NamingContect 对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

AlreadyBound - 指示已将对象绑定到指定名称。

rebind

void rebind(NameComponent[] n,
            Object obj)
            throws NotFound,
                   CannotProceed,
                   InvalidName
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。在传递组合名称以进行解析时，使用 rebind 绑定的命名上下文不参与名称解析。

参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

rebind_context

void rebind_context(NameComponent[] n,
                    NamingContext nc)
                    throws NotFound,
                           CannotProceed,
                           InvalidName
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。在传递组合名称以进行解析时，使用 rebind_context() 绑定的命名上下文参与名称解析。

参数：
n - 对象名

nc - 要与给定名称重新绑定在一起的 NamingContect 对象

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

resolve

Object resolve(NameComponent[] n)
               throws NotFound,
                      CannotProceed,
                      InvalidName
解析操作是指检索绑定到给定上下文中名称的对象的过程。给定名称必须与绑定名称完全匹配。命名服务不返回对象的类型。客户端负责将对象“收缩”为适当的类型。即客户端通常将返回对象由 Object 强制转换为更专用的接口。

参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

unbind

void unbind(NameComponent[] n)
            throws NotFound,
                   CannotProceed,
                   InvalidName
unbind 操作从上下文移除名称绑定。

参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

list

void list(int how_many,
          BindingListHolder bl,
          BindingIteratorHolder bi)
list 操作允许客户端迭代命名上下文中的一组绑定。

list 操作在 BindingList bl 中返回最多可以达到的请求绑定数。

  • 如果命名上下文包含附加绑定，则 list 操作将返回带有附加绑定的 BindingIterator。
  • 如果命名上下文不包含附加绑定，则绑定迭代器为 nil 对象引用。

参数：
how_many - 要返回的最大绑定数

bl - 返回的绑定列表

bi - 返回的绑定迭代器

new_context

NamingContext new_context()
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。没有将新上下文绑定到任何名称。

bind_new_context

NamingContext bind_new_context(NameComponent[] n)
                               throws NotFound,
                                      AlreadyBound,
                                      CannotProceed,
                                      InvalidName
此操作创建新上下文并将其绑定到作为参数提供的名称。新创建的上下文由将其绑定到的上下文的命名服务器（即实现名称参数（最后一个组件除外）表示的上下文的命名服务器）实现。

参数：
n - 对象名

抛出：
NotFound - 指示名称不标识绑定。

AlreadyBound - 指示已将对象绑定到指定名称。

CannotProceed - 指示由于某种原因放弃了实现。不过，客户端也可能在返回的命名上下文中继续该操作。

InvalidName - 指示名称无效。

destroy

void destroy()
             throws NotEmpty
destroy 操作删除命名上下文。如果命名上下文包含绑定，则引发 NotEmpty 异常。

抛出：
NotEmpty - 指示命名上下文包含绑定。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingContextPOA (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming
类 NamingContextPOA

java.lang.Object
    继承者  org.omg.PortableServer.Servant
        继承者  org.omg.CosNaming.NamingContextPOA
所有已实现的接口：
InvokeHandler, NamingContextOperations
public abstract class NamingContextPOA
extends Servant
implements NamingContextOperations, InvokeHandler

命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。可以同时将不同名称绑定到相同或不同上下文中的对象。

请参阅 CORBA COS 命名规范。

构造方法摘要
NamingContextPOA()
方法摘要
String[] | _all_interfaces(POA poa, byte[] objectId) ORB 使用此操作从 servant 获取完整的类型信息。
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) 由 ORB 调用来调度对 servant 的请求。
NamingContext | _this()
NamingContext | _this(ORB orb)
从类 org.omg.PortableServer.Servant 继承的方法
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.omg.CosNaming.NamingContextOperations 继承的方法
bind_context, bind_new_context, bind, destroy, list, new_context, rebind_context, rebind, resolve, unbind

构造方法详细信息

NamingContextPOA

public NamingContextPOA()
方法详细信息

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
从接口 InvokeHandler 复制的描述
由 ORB 调用来调度对 servant 的请求。 ORB 传递方法名称、包含编组参数的 InputStream，以及 servant 用来构造恰当应答的 ResponseHandler。 此方法只可能抛出 CORBA SystemException。 该方法必须返回包含已编组应答的 ResponseHandler 所创建的 OutputStream。 在方法调用的生存期外，servant 必须仍然保留一个对 ResponseHandler 的引用。 Servant 的行为定义如下：

1. 确定正确的方法和 InputStream 中的已解组参数。

2. 调用方法实现。

3. 如果没有任何用户异常，则使用 ResponseHandler 创建一个正常应答。

4. 如果发生用户异常，则使用 ResponseHandler 创建异常。

5. ResponseHandler 将编组应答返回到 OutputStream。

6. 将 OutputStream 返回到 ORB。

指定者：
接口 InvokeHandler 中的 _invoke
参数：
$method - 方法名称。
in - 包含已编组参数的 InputStream。
$rh - servant 用来构造正确应答的 ResponseHandler。
返回：
包含已编组应答的 ResponseHandler 所创建的 OutputStream。

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
从类 Servant 复制的描述
ORB 使用此操作从 servant 获取完整的类型信息。

指定者：
类 Servant 中的 _all_interfaces
参数：
poa - 与 servant 关联的 POA。
objectId - 对应于与此 servant 关联的对象的 id。
返回：
对象类型信息列表。

_this

public NamingContext _this()

_this

public NamingContext _this(ORB orb)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CosNaming (Java Platform SE 6)

 org.omg.CosNaming
接口
BindingIterator
BindingIteratorOperations
NamingContext
NamingContextExt
NamingContextExtOperations
NamingContextOperations
类
_BindingIteratorImplBase
_BindingIteratorStub
_NamingContextExtStub
_NamingContextImplBase
_NamingContextStub
Binding
BindingHelper
BindingHolder
BindingIteratorHelper
BindingIteratorHolder
BindingIteratorPOA
BindingListHelper
BindingListHolder
BindingType
BindingTypeHelper
BindingTypeHolder
IstringHelper
NameComponent
NameComponentHelper
NameComponentHolder
NameHelper
NameHolder
NamingContextExtHelper
NamingContextExtHolder
NamingContextExtPOA
NamingContextHelper
NamingContextHolder
NamingContextPOA


org.omg.CosNaming (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CosNaming

为 Java IDL 提供命名服务。

请参见：
描述

接口摘要
BindingIterator | BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
BindingIteratorOperations | BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
NamingContext | 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextExt | NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtOperations | NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextOperations | 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

类摘要
_BindingIteratorImplBase |
_BindingIteratorStub | BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
_NamingContextExtStub | NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
_NamingContextImplBase |
_NamingContextStub | 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
Binding | org/omg/CosNaming/Binding.java。
BindingHelper | org/omg/CosNaming/BindingHelper.java。
BindingHolder | org/omg/CosNaming/BindingHolder.java。
BindingIteratorHelper | BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorHolder | BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorPOA | BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingListHelper | 绑定列表。
BindingListHolder | 绑定列表。
BindingType | 指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
BindingTypeHelper | 指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
BindingTypeHolder | 指定给定的绑定是对象（非命名上下文的对象）的还是命名上下文的。
IstringHelper | org/omg/CosNaming/IstringHelper.java。
NameComponent | org/omg/CosNaming/NameComponent.java。
NameComponentHelper | org/omg/CosNaming/NameComponentHelper.java。
NameComponentHolder | org/omg/CosNaming/NameComponentHolder.java。
NameHelper | 名称是名称组件的序列。
NameHolder | 名称是名称组件的序列。
NamingContextExtHelper | NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtHolder | NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtPOA | NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextHelper | 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextHolder | 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextPOA | 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

软件包 org.omg.CosNaming 的描述

为 Java IDL 提供命名服务。对象请求代理守护程序（Object Request Broker Daemon，ORBD）还包括瞬态和持久命名服务。

该包及其所有类和接口都是通过在 nameservice.idl 文件上运行 idlj 工具生成的，该文件是用 OMG IDL 编写的模块。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

接口

org.omg.CosNaming 包包含两个公共接口和若干辅助类。

这两个接口是：

  • NamingContext
  • BindingIterator

这两个接口提供了一些方法，有些用来绑定/取消绑定名称和对象引用，有些用来检索绑定的对象引用，还有些用来迭代绑定列表。NamingContext 接口提供命名服务的主要功能，BindingIterator 提供迭代名称/对象引用绑定列表的各种方法。

辅助类

为了将 OMG IDL 接口映射到 Java 编程语言，idlj 编译器创建了一些 Java 类，这些类可视为辅助类。在这里提供有关接口 NamingContext 和 BindingIterator 所使用的已生成辅助类的注释。

NamingContext 和 BindingIterator 所使用的类

以下是命名服务所使用的类。（以下讨论为此处列出的每个类所生成的 helper 和 holder 类。）
  • public final class NameComponent - 名称的构建块 (building block)。（名称被绑定到命名上下文中的对象引用。）

    名称是一个或多个 NameComponent 对象所组成的数组。带有单个 NameComponent 的名称称为简单名称；带有多个 NameComponent 对象的名称称为组合名称。

    NameComponent 对象由两个字段组成：

    1. id - 用作标识符的 String
    2. kind - 可用于任何描述性内容的 String。其重要性在于，可以使用它来描述对象，但不会影响到语法。例如，C 编程语言使用这样的语法约定：将扩展名 ".c" 附加到文件名上指示其为源代码文件。在 NameComponent 对象中，kind 字段可用于描述对象类型，而不是文件扩展名或其他语法约定。kind 字段值的示例如下：字符串 "c_source"、"object_code"、"executable"、"postscript" 和 ""。kind 字段为空字符串也很常见。

    在名称中，每个 NameComponent 对象（除了最后一个）都表示一个 NamingContext 对象；最后一个 NameComponent 对象表示绑定的对象引用。这类似于路径名，路径名中最后一个名称是文件名，而前面的所有名称都是目录名。

  • public final class Binding - 将名称与对象引用或命名上下文关联的对象。Binding 对象具有两个字段：
    1. binding_name - 表示绑定名称的一个或多个 NameComponent 对象所组成的数组
    2. binding_type - BindingType 对象，该对象指示绑定发生在名称和对象引用之间，还是发生在名称和命名上下文之间

    NamingContext 接口具有一些方法，其中有些用来绑定/取消绑定名称与对象引用或命名上下文，有些用来列举绑定，还有些用来解析绑定（给定名称时，resolve 方法返回绑定到它的对象引用）。

  • public final class BindingType - 一个对象，指定给定的 Binding 对象是名称与对象引用（即非命名上下文）之间的绑定还是名称与命名上下文之间的绑定。

    BindingType 类由两个方法和四个常量组成。这些常量中有两个是 BindingType 对象，另外两个是 int。

    BindingType 对象可以传递到 Binding 类的构造方法，也可以用作参数或返回值。这些 BindingType 对象是：

    • public static final BindingType nobject - 指示是与对象引用之间的绑定
    • public static final BindingType ncontext - 指示是与命名上下文之间的绑定

    int 常量可以提供给 from_int 方法以创建 BindingType 对象，也可以作为 value 方法的返回值。这些常量是：

    • public static final int _nobject
    • public static final int _ncontext
    如果提供的 from_int 方法带有的参数是 _nobject 或 _ncontext 之外的任何内容，则它将抛出异常 org.omg.CORBA.BAD_PARAM。

    用法如下：

           BindingType btObject = from_int(_nobject);
       BindingType btContext = from_int(_ncontext);
    btObject 变量引用 BindingType 对象，该对象初始化后表示一个与对象引用的绑定。btContext 变量引用 BindingType 对象，该对象初始化后表示一个与 NamingContex 对象的绑定。

    value 方法返回 _nobject 或 _ncontext，因此在以下代码行中，变量 bt 将包含 _nobject 或 _ncontext：

           int bt = BindingType.value();

Holder 类

OMG IDL 使用 OUT 和 INOUT 参数从操作返回值。到 Java 编程语言的映射（不具有 OUT 和 INOUT 参数）为每个类型创建一个特殊类，称为 holder 类。可以将 holder 类的实例作为参数传递给 Java 方法，并可以为该实例的 value 字段分配值。这允许它执行 OUT 和 INOUT 参数的功能。

以下是为 org.omg.CosNaming 包生成的 holder 类：

  • NamingContextHolder
  • BindingIteratorHolder
  • BindingHolder
  • BindingListHolder
  • BindingTypeHolder
  • NameComponentHolder
  • NameHolder

注意，在 org.omg.CORBA 包中，每个基本 Java 类型都有一个 holder 类：IntHolder、ShortHolder、StringHolder，等等。

另请注意，即使不存在 Name 类，也会存在一个 NameHolder 类；类似地，即使不存在 BindingList 类，也会存在一个 BindingListHolder 类。出现这种现象是因为在 OMG IDL 接口中，Name 和 BindingList 都是 typedef。不存在从 IDL typedef 到 Java 结构的映射，但是如果 typedef 用于序列或数组，则会生成 holder 类。与映射到 Java 编程语言一样，Name 是 NameComponent 对象数组，BindingList 是 Binding 对象数组。 所有 holder 类都具有至少两个构造方法和一个字段：

  • value 字段 - 用作 OUT 或 INOUT 参数的类型的实例。例如，NamingContextHolder 的 value 字段将是一个 NamingContext 对象。
  • 默认构造方法 - 创建新 holder 对象并使用该类型的默认值初始化的构造方法。例如，用默认构造方法创建的新 BindingHolder 对象的 value 字段将被设置为 null，因为此为对象的默认值。其他默认值有用于 boolean 的 false、用于数值和 char 类型的 0 和用于对象引用的 null。
  • 实例中的构造方法 - 创建新 holder 对象并使用提供的实例初始化其 value 字段的构造方法

为用户定义类型（Java 类）创建的 holder 类另外还有三种方法，但是应用程序开发人员不直接使用它们。

Helper 类

Helper 类是为 OMG IDL 接口中所有用户定义类型生成的，提供操作这些类型所需的静态方法。

Helper 类中只有一种供应用程序员使用的方法。narrow 方法。只有从 IDL 接口映射的 Java 接口才具有包含 narrow 方法的 helper 类，因此在 CosNaming 包中，只有类 NamingContextHelper 和 BindingIteratorHelper 才具有 narrow 方法。

  • public static NamingContext narrow(org.omg.CORBA.Object obj) - 将给定的 CORBA 对象转换为 NamingContext 对象
  • public static BindingIterator narrow(org.omg.CORBA.Object obj) - 将给定的 CORBA 对象转换为 BindingIterator 对象

org.omg.CosNaming.NamingContextPackage 包

此包为 org.omg.CosNaming 包中使用的异常以及 NotFoundReason 类（为 NotFound 异常提供原因）提供 Helper 和 Holder 类。

为以下异常提供 Helper 和 Holder 类：

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound

命名服务兼容性

Sun CosNaming 包的实现遵守 OMG COSNaming 规范。换句话说，Sun 命名服务中的 API 根据 OMG 提供的命名服务指南实现。因此，如果第三方供应商已实现与 OMG 兼容的命名服务，则可以在 Sun 的 CosNaming 实现和第三方供应商的实现之间切换。然而，不同供应商实现命名服务的方式可能稍有不同（如异常字符串不同），理解这一点很重要。

第三方命名服务用法说明

尽管我们鼓励使用出自同一个供应商的 ORB 和 ORB 服务，但使用 Sun 的 RMI-IIOP ORB 插入第三方的 COSNaming 实现也是可能的。以下是要执行的步骤：
  1. 为 Bootstrap 服务器创建属性文件，并在该文件中给出两个条目。例如，可以将此属性文件称为 /tmp/services，并将以下内容置于其中：NameService, <Stringified IOR of the Root Naming Context>。

    此操作将 NameService 与要使用的 CosNaming 实现的根命名上下文 (Root Naming Context) 相关联。

  2. 使用以下命令启动独立的 Bootstrap 服务器：

      java -classpath $(CLASSPATH)
      com.sun.corba.ee.internal.CosNaming.BootstrapServer -InitialServicesFile
      "/tmp/services" [-ORBInitialPort port]

    注意，位于命令末尾的方括号指示指定一个可选的端口号。

这时，如果应用程序调用 org.omg.CORBA.ORB.resolve_initial_references 方法，则 CORBA 进程将联系 Bootstrap 服务器来获取根命名上下文。

包规范

  • Interoperable Naming Service (ptc/00-08-07)

相关文档

有关如何使用 CosNaming API 的概述和示例，请参阅：
  • Naming Service

有关 Java IDL 概述，请参阅：

  • Java IDL 主页

从以下版本开始：
JDK1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.CosNaming 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CosNaming 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.CosNaming.Binding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingHelper
    • org.omg.CosNaming.BindingHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingIteratorHelper
    • org.omg.CosNaming.BindingIteratorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingListHelper
    • org.omg.CosNaming.BindingListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingTypeHelper
    • org.omg.CosNaming.BindingTypeHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.IstringHelper
    • org.omg.CosNaming.NameComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NameComponentHelper
    • org.omg.CosNaming.NameComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NameHelper
    • org.omg.CosNaming.NameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextExtHelper
    • org.omg.CosNaming.NamingContextExtHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextHelper
    • org.omg.CosNaming.NamingContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CosNaming._BindingIteratorStub (implements org.omg.CosNaming.BindingIterator)
      • org.omg.CosNaming._NamingContextExtStub (implements org.omg.CosNaming.NamingContextExt)
      • org.omg.CosNaming._NamingContextStub (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._BindingIteratorImplBase (implements org.omg.CosNaming.BindingIterator)
        • org.omg.CosNaming._NamingContextImplBase (implements org.omg.CosNaming.NamingContext)
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.BindingIteratorPOA (implements org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.InvokeHandler)
      • org.omg.CosNaming.NamingContextExtPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextOperations)

接口分层结构

  • org.omg.CosNaming.BindingIteratorOperations
    • org.omg.CosNaming.BindingIterator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CosNaming.NamingContextOperations
    • org.omg.CosNaming.NamingContext (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExtOperations
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext)
  • org.omg.CORBA.Object
    • org.omg.CosNaming.BindingIterator (并 extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContext (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations)
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.CosNaming.BindingIterator (并 extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContext (并 extends org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
        • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CosNaming 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CosNaming
的使用

使用 org.omg.CosNaming 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 使用的 org.omg.CosNaming 中的类
Binding
org/omg/CosNaming/Binding.java。
BindingHolder
org/omg/CosNaming/BindingHolder.java。
BindingIterator
BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
BindingIteratorHolder
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorOperations
BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
BindingListHolder
绑定列表。
BindingType
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
NameComponent
org/omg/CosNaming/NameComponent.java。
NamingContext
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextExt
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtOperations
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextOperations
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.CosNaming.NamingContextPackage 使用的 org.omg.CosNaming 中的类
NameComponent
org/omg/CosNaming/NameComponent.java。
NamingContext
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.Binding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.Binding
的使用

使用 Binding 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 Binding 的使用

声明为 Binding 的 org.omg.CosNaming 中的字段
Binding | BindingHolder.value
Binding[] | BindingListHolder.value

返回 Binding 的 org.omg.CosNaming 中的方法
static Binding | BindingHelper.extract(Any a)
static Binding[] | BindingListHelper.extract(Any a)
static Binding | BindingHelper.read(InputStream istream)
static Binding[] | BindingListHelper.read(InputStream istream)

参数类型为 Binding 的 org.omg.CosNaming 中的方法
static void | BindingHelper.insert(Any a, Binding that)
static void | BindingListHelper.insert(Any a, Binding[] that)
static void | BindingHelper.write(OutputStream ostream, Binding value)
static void | BindingListHelper.write(OutputStream ostream, Binding[] value)

参数类型为 Binding 的 org.omg.CosNaming 中的构造方法
BindingHolder(Binding initialValue)
BindingListHolder(Binding[] initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingHelper
的使用

没有 org.omg.CosNaming.BindingHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingHolder
的使用

使用 BindingHolder 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingHolder 的使用

参数类型为 BindingHolder 的 org.omg.CosNaming 中的方法
boolean | BindingIteratorOperations.next_one(BindingHolder b) 此操作返回下一个绑定。
boolean | _BindingIteratorStub.next_one(BindingHolder b) 此操作返回下一个绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CosNaming.BindingIterator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.BindingIterator
的使用

使用 BindingIterator 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingIterator 的使用

实现 BindingIterator 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。

声明为 BindingIterator 的 org.omg.CosNaming 中的字段
 BindingIterator BindingIteratorHolder.value

返回 BindingIterator 的 org.omg.CosNaming 中的方法
BindingIterator | BindingIteratorPOA._this()
BindingIterator | BindingIteratorPOA._this(ORB orb)
static BindingIterator | BindingIteratorHelper.extract(Any a)
static BindingIterator | BindingIteratorHelper.narrow(Object obj)
static BindingIterator | BindingIteratorHelper.read(InputStream istream)
static BindingIterator | BindingIteratorHelper.unchecked_narrow(Object obj)

参数类型为 BindingIterator 的 org.omg.CosNaming 中的方法
static void | BindingIteratorHelper.insert(Any a, BindingIterator that)
static void | BindingIteratorHelper.write(OutputStream ostream, BindingIterator value)

参数类型为 BindingIterator 的 org.omg.CosNaming 中的构造方法
BindingIteratorHolder(BindingIterator initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingIteratorHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingIteratorHelper
的使用

没有 org.omg.CosNaming.BindingIteratorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingIteratorHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingIteratorHolder
的使用

使用 BindingIteratorHolder 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingIteratorHolder 的使用

参数类型为 BindingIteratorHolder 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) list 操作允许客户端迭代命名上下文中的一组绑定。
void | _NamingContextExtStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。
void | _NamingContextStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CosNaming.BindingIteratorOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.BindingIteratorOperations
的使用

使用 BindingIteratorOperations 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingIteratorOperations 的使用

org.omg.CosNaming 中 BindingIteratorOperations 的子接口
 interface BindingIterator
BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。

实现 BindingIteratorOperations 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | BindingIteratorPOA BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingIteratorPOA 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingIteratorPOA
的使用

没有 org.omg.CosNaming.BindingIteratorPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingListHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingListHelper
的使用

没有 org.omg.CosNaming.BindingListHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingListHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingListHolder
的使用

使用 BindingListHolder 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingListHolder 的使用

参数类型为 BindingListHolder 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) list 操作允许客户端迭代命名上下文中的一组绑定。
void | _NamingContextExtStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。
void | _NamingContextStub.list(int how_many, BindingListHolder bl, BindingIteratorHolder bi) 列表操作允许客户端迭代命名上下文中的一组绑定。
boolean | BindingIteratorOperations.next_n(int how_many, BindingListHolder bl) 此操作返回最多可以达到的请求绑定数。
boolean | _BindingIteratorStub.next_n(int how_many, BindingListHolder bl) 此操作返回最多可以达到的请求绑定数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingType
的使用

使用 BindingType 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 BindingType 的使用

声明为 BindingType 的 org.omg.CosNaming 中的字段
BindingType | Binding.binding_type
static BindingType | BindingType.ncontext
static BindingType | BindingType.nobject
BindingType | BindingTypeHolder.value

返回 BindingType 的 org.omg.CosNaming 中的方法
static BindingType | BindingTypeHelper.extract(Any a)
static BindingType | BindingType.from_int(int value)
static BindingType | BindingTypeHelper.read(InputStream istream)

参数类型为 BindingType 的 org.omg.CosNaming 中的方法
static void | BindingTypeHelper.insert(Any a, BindingType that)
static void | BindingTypeHelper.write(OutputStream ostream, BindingType value)

参数类型为 BindingType 的 org.omg.CosNaming 中的构造方法
Binding(NameComponent[] _binding_name, BindingType _binding_type)
BindingTypeHolder(BindingType initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingTypeHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingTypeHelper
的使用

没有 org.omg.CosNaming.BindingTypeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.BindingTypeHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.BindingTypeHolder
的使用

没有 org.omg.CosNaming.BindingTypeHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.IstringHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.IstringHelper
的使用

没有 org.omg.CosNaming.IstringHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NameComponent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameComponent
的使用

使用 NameComponent 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 NameComponent 的使用

声明为 NameComponent 的 org.omg.CosNaming 中的字段
NameComponent[] | Binding.binding_name
NameComponent | NameComponentHolder.value
NameComponent[] | NameHolder.value

返回 NameComponent 的 org.omg.CosNaming 中的方法
static NameComponent | NameComponentHelper.extract(Any a)
static NameComponent[] | NameHelper.extract(Any a)
static NameComponent | NameComponentHelper.read(InputStream istream)
static NameComponent[] | NameHelper.read(InputStream istream)
NameComponent[] | NamingContextExtOperations.to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。
NameComponent[] | _NamingContextExtStub.to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。

参数类型为 NameComponent 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
static void | NameComponentHelper.insert(Any a, NameComponent that)
static void | NameHelper.insert(Any a, NameComponent[] that)
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
String | NamingContextExtOperations.to_string(NameComponent[] n) 此操作根据 Name 组件数组创建字符串化的名称。
String | _NamingContextExtStub.to_string(NameComponent[] n) 此操作从 Name 组件数组创建字符串化的名称。
void | NamingContextOperations.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextExtStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
static void | NameComponentHelper.write(OutputStream ostream, NameComponent value)
static void | NameHelper.write(OutputStream ostream, NameComponent[] value)

参数类型为 NameComponent 的 org.omg.CosNaming 中的构造方法
Binding(NameComponent[] _binding_name, BindingType _binding_type)
NameComponentHolder(NameComponent initialValue)
NameHolder(NameComponent[] initialValue)

org.omg.CosNaming.NamingContextPackage 中 NameComponent 的使用

声明为 NameComponent 的 org.omg.CosNaming.NamingContextPackage 中的字段
NameComponent[] | CannotProceed.rest_of_name
NameComponent[] | NotFound.rest_of_name

参数类型为 NameComponent 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)
NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NameComponentHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameComponentHelper
的使用

没有 org.omg.CosNaming.NameComponentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NameComponentHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameComponentHolder
的使用

没有 org.omg.CosNaming.NameComponentHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NameHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameHelper
的使用

没有 org.omg.CosNaming.NameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NameHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NameHolder
的使用

没有 org.omg.CosNaming.NameHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CosNaming.NamingContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.NamingContext
的使用

使用 NamingContext 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 NamingContext 的使用

org.omg.CosNaming 中 NamingContext 的子接口
 interface NamingContextExt
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 NamingContext 的 org.omg.CosNaming 中的类
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

声明为 NamingContext 的 org.omg.CosNaming 中的字段
 NamingContext NamingContextHolder.value

返回 NamingContext 的 org.omg.CosNaming 中的方法
NamingContext | NamingContextPOA._this()
NamingContext | NamingContextPOA._this(ORB orb)
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
static NamingContext | NamingContextHelper.extract(Any a)
static NamingContext | NamingContextHelper.narrow(Object obj)
NamingContext | NamingContextOperations.new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
NamingContext | _NamingContextExtStub.new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
NamingContext | _NamingContextStub.new_context() 此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
static NamingContext | NamingContextHelper.read(InputStream istream)
static NamingContext | NamingContextHelper.unchecked_narrow(Object obj)

参数类型为 NamingContext 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
static void | NamingContextHelper.insert(Any a, NamingContext that)
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
static void | NamingContextHelper.write(OutputStream ostream, NamingContext value)

参数类型为 NamingContext 的 org.omg.CosNaming 中的构造方法
NamingContextHolder(NamingContext initialValue)

org.omg.CosNaming.NamingContextPackage 中 NamingContext 的使用

声明为 NamingContext 的 org.omg.CosNaming.NamingContextPackage 中的字段
 NamingContext CannotProceed.cxt

参数类型为 NamingContext 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CosNaming.NamingContextExt 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.NamingContextExt
的使用

使用 NamingContextExt 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 NamingContextExt 的使用

实现 NamingContextExt 的 org.omg.CosNaming 中的类
 class _NamingContextExtStub
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

声明为 NamingContextExt 的 org.omg.CosNaming 中的字段
 NamingContextExt NamingContextExtHolder.value

返回 NamingContextExt 的 org.omg.CosNaming 中的方法
NamingContextExt | NamingContextExtPOA._this()
NamingContextExt | NamingContextExtPOA._this(ORB orb)
static NamingContextExt | NamingContextExtHelper.extract(Any a)
static NamingContextExt | NamingContextExtHelper.narrow(Object obj)
static NamingContextExt | NamingContextExtHelper.read(InputStream istream)
static NamingContextExt | NamingContextExtHelper.unchecked_narrow(Object obj)

参数类型为 NamingContextExt 的 org.omg.CosNaming 中的方法
static void | NamingContextExtHelper.insert(Any a, NamingContextExt that)
static void | NamingContextExtHelper.write(OutputStream ostream, NamingContextExt value)

参数类型为 NamingContextExt 的 org.omg.CosNaming 中的构造方法
NamingContextExtHolder(NamingContextExt initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtHelper
的使用

没有 org.omg.CosNaming.NamingContextExtHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtHolder
的使用

没有 org.omg.CosNaming.NamingContextExtHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CosNaming.NamingContextExtOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.NamingContextExtOperations
的使用

使用 NamingContextExtOperations 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 NamingContextExtOperations 的使用

org.omg.CosNaming 中 NamingContextExtOperations 的子接口
 interface NamingContextExt
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 NamingContextExtOperations 的 org.omg.CosNaming 中的类
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextExtPOA NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPOA 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPOA
的使用

没有 org.omg.CosNaming.NamingContextExtPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextHelper
的使用

没有 org.omg.CosNaming.NamingContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextHolder
的使用

没有 org.omg.CosNaming.NamingContextHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.CosNaming.NamingContextOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.CosNaming.NamingContextOperations
的使用

使用 NamingContextOperations 的软件包
org.omg.CosNaming 为 Java IDL 提供命名服务。

org.omg.CosNaming 中 NamingContextOperations 的使用

org.omg.CosNaming 中 NamingContextOperations 的子接口
interface | NamingContext 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
interface | NamingContextExt NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
interface | NamingContextExtOperations NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 NamingContextOperations 的 org.omg.CosNaming 中的类
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
class | NamingContextExtPOA NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextPOA 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPOA 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPOA
的使用

没有 org.omg.CosNaming.NamingContextPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming._BindingIteratorImplBase 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._BindingIteratorImplBase
的使用

没有 org.omg.CosNaming._BindingIteratorImplBase 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming._BindingIteratorStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._BindingIteratorStub
的使用

没有 org.omg.CosNaming._BindingIteratorStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming._NamingContextExtStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._NamingContextExtStub
的使用

没有 org.omg.CosNaming._NamingContextExtStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming._NamingContextImplBase 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._NamingContextImplBase
的使用

没有 org.omg.CosNaming._NamingContextImplBase 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming._NamingContextStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming._NamingContextStub
的使用

没有 org.omg.CosNaming._NamingContextStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AddressHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextExtPackage
类 AddressHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextExtPackage.AddressHelper

public abstract class AddressHelper
extends Object

地址是以 String 形式表示的主机和端口信息。

构造方法摘要
AddressHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AddressHelper

public AddressHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InvalidAddress (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextExtPackage
类 InvalidAddress

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidAddress
extends UserException

org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
InvalidAddress()
InvalidAddress(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidAddress

public InvalidAddress()

InvalidAddress

public InvalidAddress(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidAddressHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextExtPackage
类 InvalidAddressHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper

public abstract class InvalidAddressHelper
extends Object

org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
InvalidAddressHelper()
方法摘要
static InvalidAddress | extract(Any a)
static String | id()
static void | insert(Any a, InvalidAddress that)
static InvalidAddress | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidAddress value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InvalidAddressHelper

public InvalidAddressHelper()
方法详细信息

insert

public static void insert(Any a,
                          InvalidAddress that)

extract

public static InvalidAddress extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidAddress read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidAddress value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidAddressHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextExtPackage
类 InvalidAddressHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
所有已实现的接口：
Streamable
public final class InvalidAddressHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
 InvalidAddress value
构造方法摘要
InvalidAddressHolder()
InvalidAddressHolder(InvalidAddress initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public InvalidAddress value
构造方法详细信息

InvalidAddressHolder

public InvalidAddressHolder()

InvalidAddressHolder

public InvalidAddressHolder(InvalidAddress initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringNameHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextExtPackage
类 StringNameHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextExtPackage.StringNameHelper

public abstract class StringNameHelper
extends Object

StringName 是以 String 形式表示的“字符串化的名称”和“名称组件数组”。

构造方法摘要
StringNameHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringNameHelper

public StringNameHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLStringHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextExtPackage
类 URLStringHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextExtPackage.URLStringHelper

public abstract class URLStringHelper
extends Object

URLString 是以 String 形式表示的 URL 地址（corbaloc: 或 corbaname:）。

构造方法摘要
URLStringHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

URLStringHelper

public URLStringHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CosNaming.NamingContextExtPackage (Java Platform SE 6)

 org.omg.CosNaming.NamingContextExtPackage
类
AddressHelper
InvalidAddressHelper
InvalidAddressHolder
StringNameHelper
URLStringHelper
异常
InvalidAddress


org.omg.CosNaming.NamingContextExtPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CosNaming.NamingContextExtPackage

此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

请参见：
描述

类摘要
AddressHelper | 地址是以 String 形式表示的主机和端口信息。
InvalidAddressHelper | org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java。
InvalidAddressHolder | org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java。
StringNameHelper | StringName 是以 String 形式表示的“字符串化的名称”和“名称组件数组”。
URLStringHelper | URLString 是以 String 形式表示的 URL 地址（corbaloc: 或 corbaname:）。

异常摘要
InvalidAddress org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

软件包 org.omg.CosNaming.NamingContextExtPackage 的描述

此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类：

  • AddressHelper
  • StringNameHelper
  • URLStringHelper
  • InvalidAddress

    包规范

    有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

    从以下版本开始：
    1.4
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM Platform
    Standard Ed. 6
    上一个软件包 下一个软件包 框架 无框架


org.omg.CosNaming.NamingContextExtPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CosNaming.NamingContextExtPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.CosNaming.NamingContextExtPackage.AddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
    • org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CosNaming.NamingContextExtPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CosNaming.NamingContextExtPackage
的使用

使用 org.omg.CosNaming.NamingContextExtPackage 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

org.omg.CosNaming 使用的 org.omg.CosNaming.NamingContextExtPackage 中的类
InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextExtPackage 使用的 org.omg.CosNaming.NamingContextExtPackage 中的类
InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddress 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
的使用

使用 InvalidAddress 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

org.omg.CosNaming 中 InvalidAddress 的使用

抛出 InvalidAddress 的 org.omg.CosNaming 中的方法
String | NamingContextExtOperations.to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
String | _NamingContextExtStub.to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

org.omg.CosNaming.NamingContextExtPackage 中 InvalidAddress 的使用

声明为 InvalidAddress 的 org.omg.CosNaming.NamingContextExtPackage 中的字段
 InvalidAddress InvalidAddressHolder.value

返回 InvalidAddress 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
static InvalidAddress | InvalidAddressHelper.extract(Any a)
static InvalidAddress | InvalidAddressHelper.read(InputStream istream)

参数类型为 InvalidAddress 的 org.omg.CosNaming.NamingContextExtPackage 中的方法
static void | InvalidAddressHelper.insert(Any a, InvalidAddress that)
static void | InvalidAddressHelper.write(OutputStream ostream, InvalidAddress value)

参数类型为 InvalidAddress 的 org.omg.CosNaming.NamingContextExtPackage 中的构造方法
InvalidAddressHolder(InvalidAddress initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
的使用

没有 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AlreadyBound (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 AlreadyBound

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CosNaming.NamingContextPackage.AlreadyBound
所有已实现的接口：
Serializable, IDLEntity
public final class AlreadyBound
extends UserException

org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
AlreadyBound()
AlreadyBound(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AlreadyBound

public AlreadyBound()

AlreadyBound

public AlreadyBound(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AlreadyBoundHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 AlreadyBoundHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper

public abstract class AlreadyBoundHelper
extends Object

org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
AlreadyBoundHelper()
方法摘要
static AlreadyBound | extract(Any a)
static String | id()
static void | insert(Any a, AlreadyBound that)
static AlreadyBound | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, AlreadyBound value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AlreadyBoundHelper

public AlreadyBoundHelper()
方法详细信息

insert

public static void insert(Any a,
                          AlreadyBound that)

extract

public static AlreadyBound extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static AlreadyBound read(InputStream istream)

write

public static void write(OutputStream ostream,
                         AlreadyBound value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AlreadyBoundHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 AlreadyBoundHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
所有已实现的接口：
Streamable
public final class AlreadyBoundHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
 AlreadyBound value
构造方法摘要
AlreadyBoundHolder()
AlreadyBoundHolder(AlreadyBound initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public AlreadyBound value
构造方法详细信息

AlreadyBoundHolder

public AlreadyBoundHolder()

AlreadyBoundHolder

public AlreadyBoundHolder(AlreadyBound initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CannotProceed (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 CannotProceed

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CosNaming.NamingContextPackage.CannotProceed
所有已实现的接口：
Serializable, IDLEntity
public final class CannotProceed
extends UserException

org/omg/CosNaming/NamingContextPackage/CannotProceed.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
NamingContext | cxt
NameComponent[] | rest_of_name
构造方法摘要
CannotProceed()
CannotProceed(NamingContext _cxt, NameComponent[] _rest_of_name)
CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

cxt

public NamingContext cxt

rest_of_name

public NameComponent[] rest_of_name
构造方法详细信息

CannotProceed

public CannotProceed()

CannotProceed

public CannotProceed(NamingContext _cxt,
                     NameComponent[] _rest_of_name)

CannotProceed

public CannotProceed(String $reason,
                     NamingContext _cxt,
                     NameComponent[] _rest_of_name)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CannotProceedHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 CannotProceedHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.CannotProceedHelper

public abstract class CannotProceedHelper
extends Object

org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
CannotProceedHelper()
方法摘要
static CannotProceed | extract(Any a)
static String | id()
static void | insert(Any a, CannotProceed that)
static CannotProceed | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, CannotProceed value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CannotProceedHelper

public CannotProceedHelper()
方法详细信息

insert

public static void insert(Any a,
                          CannotProceed that)

extract

public static CannotProceed extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static CannotProceed read(InputStream istream)

write

public static void write(OutputStream ostream,
                         CannotProceed value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CannotProceedHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 CannotProceedHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
所有已实现的接口：
Streamable
public final class CannotProceedHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
 CannotProceed value
构造方法摘要
CannotProceedHolder()
CannotProceedHolder(CannotProceed initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public CannotProceed value
构造方法详细信息

CannotProceedHolder

public CannotProceedHolder()

CannotProceedHolder

public CannotProceedHolder(CannotProceed initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidName (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 InvalidName

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CosNaming.NamingContextPackage.InvalidName
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidName
extends UserException

org/omg/CosNaming/NamingContextPackage/InvalidName.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
InvalidName()
InvalidName(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidName

public InvalidName()

InvalidName

public InvalidName(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidNameHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 InvalidNameHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.InvalidNameHelper

public abstract class InvalidNameHelper
extends Object

org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
InvalidNameHelper()
方法摘要
static InvalidName | extract(Any a)
static String | id()
static void | insert(Any a, InvalidName that)
static InvalidName | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidName value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InvalidNameHelper

public InvalidNameHelper()
方法详细信息

insert

public static void insert(Any a,
                          InvalidName that)

extract

public static InvalidName extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidName read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidName value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidNameHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 InvalidNameHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
所有已实现的接口：
Streamable
public final class InvalidNameHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
 InvalidName value
构造方法摘要
InvalidNameHolder()
InvalidNameHolder(InvalidName initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public InvalidName value
构造方法详细信息

InvalidNameHolder

public InvalidNameHolder()

InvalidNameHolder

public InvalidNameHolder(InvalidName initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotEmpty (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotEmpty

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CosNaming.NamingContextPackage.NotEmpty
所有已实现的接口：
Serializable, IDLEntity
public final class NotEmpty
extends UserException

org/omg/CosNaming/NamingContextPackage/NotEmpty.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
NotEmpty()
NotEmpty(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotEmpty

public NotEmpty()

NotEmpty

public NotEmpty(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotEmptyHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotEmptyHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.NotEmptyHelper

public abstract class NotEmptyHelper
extends Object

org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
NotEmptyHelper()
方法摘要
static NotEmpty | extract(Any a)
static String | id()
static void | insert(Any a, NotEmpty that)
static NotEmpty | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NotEmpty value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NotEmptyHelper

public NotEmptyHelper()
方法详细信息

insert

public static void insert(Any a,
                          NotEmpty that)

extract

public static NotEmpty extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NotEmpty read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NotEmpty value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotEmptyHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotEmptyHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
所有已实现的接口：
Streamable
public final class NotEmptyHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
 NotEmpty value
构造方法摘要
NotEmptyHolder()
NotEmptyHolder(NotEmpty initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public NotEmpty value
构造方法详细信息

NotEmptyHolder

public NotEmptyHolder()

NotEmptyHolder

public NotEmptyHolder(NotEmpty initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotFound (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotFound

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.CosNaming.NamingContextPackage.NotFound
所有已实现的接口：
Serializable, IDLEntity
public final class NotFound
extends UserException

org/omg/CosNaming/NamingContextPackage/NotFound.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
NameComponent[] | rest_of_name
NotFoundReason | why
构造方法摘要
NotFound()
NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

why

public NotFoundReason why

rest_of_name

public NameComponent[] rest_of_name
构造方法详细信息

NotFound

public NotFound()

NotFound

public NotFound(NotFoundReason _why,
                NameComponent[] _rest_of_name)

NotFound

public NotFound(String $reason,
                NotFoundReason _why,
                NameComponent[] _rest_of_name)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotFoundHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotFoundHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.NotFoundHelper

public abstract class NotFoundHelper
extends Object

org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

构造方法摘要
NotFoundHelper()
方法摘要
static NotFound | extract(Any a)
static String | id()
static void | insert(Any a, NotFound that)
static NotFound | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NotFound value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NotFoundHelper

public NotFoundHelper()
方法详细信息

insert

public static void insert(Any a,
                          NotFound that)

extract

public static NotFound extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NotFound read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NotFound value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotFoundHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotFoundHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.NotFoundHolder
所有已实现的接口：
Streamable
public final class NotFoundHolder
extends Object
implements Streamable

org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/CosNaming/nameservice.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:11 (GMT-08:00)。

字段摘要
 NotFound value
构造方法摘要
NotFoundHolder()
NotFoundHolder(NotFound initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public NotFound value
构造方法详细信息

NotFoundHolder

public NotFoundHolder()

NotFoundHolder

public NotFoundHolder(NotFound initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotFoundReason (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotFoundReason

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.NotFoundReason
所有已实现的接口：
Serializable, IDLEntity
public class NotFoundReason
extends Object
implements IDLEntity

指示未能解析的原因。

字段摘要
static int | _missing_node
static int | _not_context
static int | _not_object
static NotFoundReason | missing_node
static NotFoundReason | not_context
static NotFoundReason | not_object
构造方法摘要
protected NotFoundReason(int value)
方法摘要
static NotFoundReason | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_missing_node

public static final int _missing_node
另请参见：
常量字段值

missing_node

public static final NotFoundReason missing_node

_not_context

public static final int _not_context
另请参见：
常量字段值

not_context

public static final NotFoundReason not_context

_not_object

public static final int _not_object
另请参见：
常量字段值

not_object

public static final NotFoundReason not_object
构造方法详细信息

NotFoundReason

protected NotFoundReason(int value)
方法详细信息

value

public int value()

from_int

public static NotFoundReason from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotFoundReasonHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotFoundReasonHelper

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper

public abstract class NotFoundReasonHelper
extends Object

指示未能解析的原因。

构造方法摘要
NotFoundReasonHelper()
方法摘要
static NotFoundReason | extract(Any a)
static String | id()
static void | insert(Any a, NotFoundReason that)
static NotFoundReason | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NotFoundReason value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NotFoundReasonHelper

public NotFoundReasonHelper()
方法详细信息

insert

public static void insert(Any a,
                          NotFoundReason that)

extract

public static NotFoundReason extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NotFoundReason read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NotFoundReason value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotFoundReasonHolder (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.CosNaming.NamingContextPackage
类 NotFoundReasonHolder

java.lang.Object
    继承者  org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
所有已实现的接口：
Streamable
public final class NotFoundReasonHolder
extends Object
implements Streamable

指示未能解析的原因。

字段摘要
 NotFoundReason value
构造方法摘要
NotFoundReasonHolder()
NotFoundReasonHolder(NotFoundReason initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public NotFoundReason value
构造方法详细信息

NotFoundReasonHolder

public NotFoundReasonHolder()

NotFoundReasonHolder

public NotFoundReasonHolder(NotFoundReason initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.CosNaming.NamingContextPackage (Java Platform SE 6)

 org.omg.CosNaming.NamingContextPackage
类
AlreadyBoundHelper
AlreadyBoundHolder
CannotProceedHelper
CannotProceedHolder
InvalidNameHelper
InvalidNameHolder
NotEmptyHelper
NotEmptyHolder
NotFoundHelper
NotFoundHolder
NotFoundReason
NotFoundReasonHelper
NotFoundReasonHolder
异常
AlreadyBound
CannotProceed
InvalidName
NotEmpty
NotFound


org.omg.CosNaming.NamingContextPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.CosNaming.NamingContextPackage

此包包含 org.omg.CosNaming 包的 Exception 类。

请参见：
描述

类摘要
AlreadyBoundHelper | org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java。
AlreadyBoundHolder | org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java。
CannotProceedHelper | org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java。
CannotProceedHolder | org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java。
InvalidNameHelper | org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java。
InvalidNameHolder | org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java。
NotEmptyHelper | org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java。
NotEmptyHolder | org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java。
NotFoundHelper | org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java。
NotFoundHolder | org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java。
NotFoundReason | 指示未能解析的原因。
NotFoundReasonHelper | 指示未能解析的原因。
NotFoundReasonHolder | 指示未能解析的原因。

异常摘要
AlreadyBound | org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
CannotProceed | org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
InvalidName | org/omg/CosNaming/NamingContextPackage/InvalidName.java。
NotEmpty | org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
NotFound | org/omg/CosNaming/NamingContextPackage/NotFound.java。

软件包 org.omg.CosNaming.NamingContextPackage 的描述

此包包含 org.omg.CosNaming 包的 Exception 类。异常类的列表为：

  • AlreadyBound
  • CannotProceed
  • InvalidName
  • NotEmpty
  • NotFound
  • NotFoundReason

    包规范

    有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java SE 6。

    从以下版本开始：
    1.4
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM Platform
    Standard Ed. 6
    上一个软件包 下一个软件包 框架 无框架


org.omg.CosNaming.NamingContextPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CosNaming.NamingContextPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReason (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder (implements org.omg.CORBA.portable.Streamable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.CosNaming.NamingContextPackage.AlreadyBound
          • org.omg.CosNaming.NamingContextPackage.CannotProceed
          • org.omg.CosNaming.NamingContextPackage.InvalidName
          • org.omg.CosNaming.NamingContextPackage.NotEmpty
          • org.omg.CosNaming.NamingContextPackage.NotFound
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.CosNaming.NamingContextPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.CosNaming.NamingContextPackage
的使用

使用 org.omg.CosNaming.NamingContextPackage 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 使用的 org.omg.CosNaming.NamingContextPackage 中的类
AlreadyBound
org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
CannotProceed
org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
InvalidName
org/omg/CosNaming/NamingContextPackage/InvalidName.java。
NotEmpty
org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
NotFound
org/omg/CosNaming/NamingContextPackage/NotFound.java。

org.omg.CosNaming.NamingContextPackage 使用的 org.omg.CosNaming.NamingContextPackage 中的类
AlreadyBound
org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
CannotProceed
org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
InvalidName
org/omg/CosNaming/NamingContextPackage/InvalidName.java。
NotEmpty
org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
NotFound
org/omg/CosNaming/NamingContextPackage/NotFound.java。
NotFoundReason
指示未能解析的原因。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.AlreadyBound 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.AlreadyBound
的使用

使用 AlreadyBound 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 AlreadyBound 的使用

抛出 AlreadyBound 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。

org.omg.CosNaming.NamingContextPackage 中 AlreadyBound 的使用

声明为 AlreadyBound 的 org.omg.CosNaming.NamingContextPackage 中的字段
 AlreadyBound AlreadyBoundHolder.value

返回 AlreadyBound 的 org.omg.CosNaming.NamingContextPackage 中的方法
static AlreadyBound | AlreadyBoundHelper.extract(Any a)
static AlreadyBound | AlreadyBoundHelper.read(InputStream istream)

参数类型为 AlreadyBound 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | AlreadyBoundHelper.insert(Any a, AlreadyBound that)
static void | AlreadyBoundHelper.write(OutputStream ostream, AlreadyBound value)

参数类型为 AlreadyBound 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
AlreadyBoundHolder(AlreadyBound initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.CannotProceed 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.CannotProceed
的使用

使用 CannotProceed 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 CannotProceed 的使用

抛出 CannotProceed 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | NamingContextExtOperations.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | _NamingContextExtStub.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
void | NamingContextOperations.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextExtStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。

org.omg.CosNaming.NamingContextPackage 中 CannotProceed 的使用

声明为 CannotProceed 的 org.omg.CosNaming.NamingContextPackage 中的字段
 CannotProceed CannotProceedHolder.value

返回 CannotProceed 的 org.omg.CosNaming.NamingContextPackage 中的方法
static CannotProceed | CannotProceedHelper.extract(Any a)
static CannotProceed | CannotProceedHelper.read(InputStream istream)

参数类型为 CannotProceed 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | CannotProceedHelper.insert(Any a, CannotProceed that)
static void | CannotProceedHelper.write(OutputStream ostream, CannotProceed value)

参数类型为 CannotProceed 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
CannotProceedHolder(CannotProceed initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.InvalidName 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.InvalidName
的使用

使用 InvalidName 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 InvalidName 的使用

抛出 InvalidName 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | NamingContextExtOperations.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | _NamingContextExtStub.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
NameComponent[] | NamingContextExtOperations.to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。
NameComponent[] | _NamingContextExtStub.to_name(String sn) 此操作将“字符串化的名称”转换为等效的“名称组件”数组。
String | NamingContextExtOperations.to_string(NameComponent[] n) 此操作根据 Name 组件数组创建字符串化的名称。
String | _NamingContextExtStub.to_string(NameComponent[] n) 此操作从 Name 组件数组创建字符串化的名称。
String | NamingContextExtOperations.to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
String | _NamingContextExtStub.to_url(String addr, String sn) 此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
void | NamingContextOperations.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextExtStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。

org.omg.CosNaming.NamingContextPackage 中 InvalidName 的使用

声明为 InvalidName 的 org.omg.CosNaming.NamingContextPackage 中的字段
 InvalidName InvalidNameHolder.value

返回 InvalidName 的 org.omg.CosNaming.NamingContextPackage 中的方法
static InvalidName | InvalidNameHelper.extract(Any a)
static InvalidName | InvalidNameHelper.read(InputStream istream)

参数类型为 InvalidName 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | InvalidNameHelper.insert(Any a, InvalidName that)
static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)

参数类型为 InvalidName 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
InvalidNameHolder(InvalidName initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotEmpty 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotEmpty
的使用

使用 NotEmpty 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 NotEmpty 的使用

抛出 NotEmpty 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.destroy() destroy 操作删除命名上下文。
void | _NamingContextExtStub.destroy() destroy 操作删除命名上下文。
void | _NamingContextStub.destroy() destroy 操作删除命名上下文。

org.omg.CosNaming.NamingContextPackage 中 NotEmpty 的使用

声明为 NotEmpty 的 org.omg.CosNaming.NamingContextPackage 中的字段
 NotEmpty NotEmptyHolder.value

返回 NotEmpty 的 org.omg.CosNaming.NamingContextPackage 中的方法
static NotEmpty | NotEmptyHelper.extract(Any a)
static NotEmpty | NotEmptyHelper.read(InputStream istream)

参数类型为 NotEmpty 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | NotEmptyHelper.insert(Any a, NotEmpty that)
static void | NotEmptyHelper.write(OutputStream ostream, NotEmpty value)

参数类型为 NotEmpty 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
NotEmptyHolder(NotEmpty initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFound 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFound
的使用

使用 NotFound 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming 中 NotFound 的使用

抛出 NotFound 的 org.omg.CosNaming 中的方法
void | NamingContextOperations.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextExtStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
void | _NamingContextStub.bind_context(NameComponent[] n, NamingContext nc) 命名作为命名上下文的对象。
NamingContext | NamingContextOperations.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextExtStub.bind_new_context(NameComponent[] n) 此操作创建新上下文并将其绑定到作为参数提供的名称。
NamingContext | _NamingContextStub.bind_new_context(NameComponent[] n) 此操作创建一个新上下文并将其绑定到作为参数提供的名称。
void | NamingContextOperations.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextExtStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | _NamingContextStub.bind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定。
void | NamingContextOperations.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind_context(NameComponent[] n, NamingContext nc) 在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
void | NamingContextOperations.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextExtStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
void | _NamingContextStub.rebind(NameComponent[] n, Object obj) 在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
Object | NamingContextExtOperations.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | _NamingContextExtStub.resolve_str(String sn) 此操作将“字符串化的”名称解析为对象引用。
Object | NamingContextOperations.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextExtStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
Object | _NamingContextStub.resolve(NameComponent[] n) 解析操作是指检索绑定到给定上下文中名称的对象的过程。
void | NamingContextOperations.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextExtStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。
void | _NamingContextStub.unbind(NameComponent[] n) unbind 操作从上下文移除名称绑定。

org.omg.CosNaming.NamingContextPackage 中 NotFound 的使用

声明为 NotFound 的 org.omg.CosNaming.NamingContextPackage 中的字段
 NotFound NotFoundHolder.value

返回 NotFound 的 org.omg.CosNaming.NamingContextPackage 中的方法
static NotFound | NotFoundHelper.extract(Any a)
static NotFound | NotFoundHelper.read(InputStream istream)

参数类型为 NotFound 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | NotFoundHelper.insert(Any a, NotFound that)
static void | NotFoundHelper.write(OutputStream ostream, NotFound value)

参数类型为 NotFound 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
NotFoundHolder(NotFound initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundReason
的使用

使用 NotFoundReason 的软件包
org.omg.CosNaming.NamingContextPackage 此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.CosNaming.NamingContextPackage 中 NotFoundReason 的使用

声明为 NotFoundReason 的 org.omg.CosNaming.NamingContextPackage 中的字段
static NotFoundReason | NotFoundReason.missing_node
static NotFoundReason | NotFoundReason.not_context
static NotFoundReason | NotFoundReason.not_object
NotFoundReason | NotFoundReasonHolder.value
NotFoundReason | NotFound.why

返回 NotFoundReason 的 org.omg.CosNaming.NamingContextPackage 中的方法
static NotFoundReason | NotFoundReasonHelper.extract(Any a)
static NotFoundReason | NotFoundReason.from_int(int value)
static NotFoundReason | NotFoundReasonHelper.read(InputStream istream)

参数类型为 NotFoundReason 的 org.omg.CosNaming.NamingContextPackage 中的方法
static void | NotFoundReasonHelper.insert(Any a, NotFoundReason that)
static void | NotFoundReasonHelper.write(OutputStream ostream, NotFoundReason value)

参数类型为 NotFoundReason 的 org.omg.CosNaming.NamingContextPackage 中的构造方法
NotFound(NotFoundReason _why, NameComponent[] _rest_of_name)
NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)
NotFoundReasonHolder(NotFoundReason initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
的使用

没有 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


RunTime (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.SendingContext
接口 RunTime

所有超级接口：
IDLEntity, Object, RunTimeOperations, Serializable
public interface RunTime
extends RunTimeOperations, Object, IDLEntity

定义表示请求的发送上下文的基类。发送上下文允许访问关于 GIOP 消息始发方运行时环境的信息。例如，当值类型在 GIOP 请求消息上编组时，该值类型的接受方可能需要询问发送方有关值类型实现的 CodeBase。

方法摘要
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


RunTimeOperations (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.SendingContext
接口 RunTimeOperations

所有已知子接口：
RunTime
public interface RunTimeOperations

定义在表示请求的发送上下文的基类上使用的操作。发送上下文允许访问关于 GIOP 消息始发方运行时环境的信息。例如，当值类型在 GIOP 请求消息上编组时，该值类型的接受方可能需要询问发送方有关值类型实现的 CodeBase。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.SendingContext (Java Platform SE 6)

 org.omg.SendingContext
接口
RunTime
RunTimeOperations


org.omg.SendingContext (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.SendingContext

为值类型的编组提供支持。

请参见：
描述

接口摘要
RunTime | 定义表示请求的发送上下文的基类。
RunTimeOperations | 定义在表示请求的发送上下文的基类上使用的操作。

软件包 org.omg.SendingContext 的描述

为值类型的编组提供支持。值类型编组可能需要访问值类型的实现或关于值类型的元信息。使用特定的服务上下文（包含 SendingContext.RunTime 接口的实例）在发送上下文和接受上下文之间传递此信息。

发送上下文可以是调用的客户端方，也可以是服务器方，具体取决于哪一方包含值类型。如果请求包含值类型，则发送上下文是调用的客户端方。如果应答包含值类型，则它是服务器方。通信的另一方是接受上下文。

为 SendingContext 编组的服务上下文由 SendingContext.RunTime 接口的封装 IOR 组成。RunTime 只是一个为以后扩展而定义的标记接口。目前只定义了一个 RunTime 的子接口：SendingContext.CodeBase 接口。接口 CodeBase 定义了一些操作来获取代码 URL 以及关于从发送上下文接收的 value 类型的元信息。

注意，这些类目前在 com.sun.org.omg.SendingContext 包中定义而不是 org.omg.SendingContext 包中。这样做是为了避免包括大部分 JDK 核心中的接口存储库，因为接口存储库为了满足 CORBA 组件运行的需要仍然在不断发展。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.SendingContext 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.SendingContext 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • org.omg.CORBA.Object
    • org.omg.SendingContext.RunTime (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.SendingContext.RunTimeOperations)
  • org.omg.SendingContext.RunTimeOperations
    • org.omg.SendingContext.RunTime (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.SendingContext.RunTime (并 extends org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.SendingContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.SendingContext
的使用

使用 org.omg.SendingContext 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.SendingContext | 为值类型的编组提供支持。

javax.rmi.CORBA 使用的 org.omg.SendingContext 中的类
RunTime
定义表示请求的发送上下文的基类。

org.omg.SendingContext 使用的 org.omg.SendingContext 中的类
RunTimeOperations
定义在表示请求的发送上下文的基类上使用的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.SendingContext.RunTime 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.SendingContext.RunTime
的使用

使用 RunTime 的软件包
javax.rmi.CORBA 包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.CORBA 中 RunTime 的使用

返回 RunTime 的 javax.rmi.CORBA 中的方法
 RunTime ValueHandler.getRunTimeCodeBase()
返回此 ValueHandler 的 CodeBase。

参数类型为 RunTime 的 javax.rmi.CORBA 中的方法
 Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
使用 Java 语义从流中读取一个值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.SendingContext.RunTimeOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.SendingContext.RunTimeOperations
的使用

使用 RunTimeOperations 的软件包
org.omg.SendingContext 为值类型的编组提供支持。

org.omg.SendingContext 中 RunTimeOperations 的使用

org.omg.SendingContext 中 RunTimeOperations 的子接口
 interface RunTime
定义表示请求的发送上下文的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


_ServantActivatorStub (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 _ServantActivatorStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.PortableServer._ServantActivatorStub
所有已实现的接口：
Serializable, Object, IDLEntity, ServantActivator, ServantActivatorOperations, ServantManager, ServantManagerOperations
public class _ServantActivatorStub
extends ObjectImpl
implements ServantActivator

当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。

字段摘要
static Class _opsClass
构造方法摘要
_ServantActivatorStub()
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
void | etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要停用对象的 servant 就会调用此操作。
Servant | incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_ServantActivatorStub

public _ServantActivatorStub()
方法详细信息

incarnate

public Servant incarnate(byte[] oid,
                         POA adapter)
                  throws ForwardRequest
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。

指定者：
接口 ServantActivatorOperations 中的 incarnate
参数：
oid - 关联所请求对象的对象 Id。
adapter - 将激活对象的 POA 的对象引用。
返回：
创建的对应于 oid 的 Servant，或者提供 servant 管理器的用户所定位的 Servant。
抛出：
ForwardRequest - 指示 ORB 负责将当前请求和后续请求传递给异常的向前引用 (forward_reference) 成员所表示的对象。

etherealize

public void etherealize(byte[] oid,
                        POA adapter,
                        Servant serv,
                        boolean cleanup_in_progress,
                        boolean remaining_activations)
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要停用对象的 servant 就会调用此操作。

指定者：
接口 ServantActivatorOperations 中的 etherealize
参数：
oid - 关联将被停用的对象的对象 Id。
adapter - 已激活对象的 POA 的对象引用。
serv - 包含对关联将停用的 servant 的引用。
cleanup_in_progress - 为 TRUE 指示在 etherealize_objects 参数为 TRUE 的情况下调用该销毁或停用操作。FALSE 指示由于其他原因调用 etherealize。
remaining_activations - 指示 Servant 管理器是否可以销毁 servant。如果设置为 TRUE，则 Servant 管理器应该等待所有进行中的调用全部完成。

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


_ServantLocatorStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 _ServantLocatorStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.PortableServer._ServantLocatorStub
所有已实现的接口：
Serializable, Object, IDLEntity, ServantLocator, ServantLocatorOperations, ServantManager, ServantManagerOperations
public class _ServantLocatorStub
extends ObjectImpl
implements ServantLocator

POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。因为 POA 了解此 servant 管理器返回的 servant 只用于单个请求，所以它可以向 servant 管理器的操作提供额外的信息，从而一对该 servant 管理器的操作也许能共同执行某些不同于 ServantActivator 的操作。POA 使用 ServantLocator 接口时，对 preinvoke 返回的 servant 调用该操作后，POA 将立即对 servant 管理器调用 postinvoke，同时将 ObjectId 值和 Servant 值（及其他值）作为参数传递。servant 管理器可以使用这一功能来强制调停每个对关联 POA 的对象的请求。

字段摘要
static Class _opsClass
构造方法摘要
_ServantLocatorStub()
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
void | postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
Servant | preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_ServantLocatorStub

public _ServantLocatorStub()
方法详细信息

preinvoke

public Servant preinvoke(byte[] oid,
                         POA adapter,
                         String operation,
                         CookieHolder the_cookie)
                  throws ForwardRequest
此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。

指定者：
接口 ServantLocatorOperations 中的 preinvoke
参数：
oid - 关联所请求对象的对象 Id。
adapter - 将激活对象的 POA 的引用。
operation - 操作名称。
the_cookie - 一个不透明值，可由调用 postinvoke 期间使用的 servant 管理器设置。
返回：
用来处理传入请求的 Servant。
抛出：
ForwardRequest - 指示 ORB 负责将当前请求和后续请求传递给异常的向前引用 (forward_reference) 成员所表示的对象。

postinvoke

public void postinvoke(byte[] oid,
                       POA adapter,
                       String operation,
                       Object the_cookie,
                       Servant the_servant)
servant 完成请求时都将调用此操作。

指定者：
接口 ServantLocatorOperations 中的 postinvoke
参数：
oid - 关联所请求对象的对象 Id。
adapter - 已激活对象的 POA 的引用。
the_cookie - 一个包含 preinvoke 设置的数据的透明值。
the_servant - 对关联对象的 servant 的引用。

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AdapterActivator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 AdapterActivator

所有超级接口：
AdapterActivatorOperations, IDLEntity, Object, Serializable
public interface AdapterActivator
extends AdapterActivatorOperations, Object, IDLEntity

一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。产生这一需求可能是接受指定子 POA（或其中一个子 POA）的请求所带来的副作用，调用 activate 参数值为 TRUE 的 find_POA 时也需要创建子 POA。

方法摘要
从接口 org.omg.PortableServer.AdapterActivatorOperations 继承的方法
unknown_adapter
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AdapterActivatorOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 AdapterActivatorOperations

所有已知子接口：
AdapterActivator
public interface AdapterActivatorOperations

一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。产生这一需求可能是接受指定子 POA（或其中一个子 POA）的请求所带来的副作用，调用 activate 参数值为 TRUE 的 find_POA 时也需要创建子 POA。

方法摘要
 boolean unknown_adapter(POA parent, String name)
在 ORB 接收对象引用的请求时，如果该对象引用定义不存在的目标 POA，则将调用此操作。

方法详细信息

unknown_adapter

boolean unknown_adapter(POA parent,
                        String name)
在 ORB 接收对象引用的请求时，如果该对象引用定义不存在的目标 POA，则将调用此操作。对于每个必须按存在的目标 POA 顺序创建的 POA，ORB 调用此操作一次。

参数：
parent - 指示需要创建的 POA 的父 POA。
name - 指示相对于父 POA 的 POA 名称。
返回：
如果创建了 POA，则返回 TRUE；否则返回 FALSE。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Current (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 Current

所有超级接口：
Current, CurrentOperations, IDLEntity, Object, Serializable
public interface Current
extends CurrentOperations, Current, IDLEntity

从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。提供 Current 接口是为了支持实现多个对象，但可以在任一 servant 上 POA 调度的方法调用的上下文中使用的 servant。如果要提供位置透明性，则 ORB 必须支持在本地和远程调用操作的上下文中都使用 Current。通过进行 CORBA::ORB::resolve_initial_references("POACurrent") 操作，应用程序可获得 Current 的实例。此后，它便可以在 POA 指派的方法的上下文中使用，以获取标识调用操作的对象的 POA 和 ObjectId。

方法摘要
从接口 org.omg.PortableServer.CurrentOperations 继承的方法
get_object_id, get_POA
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 CurrentHelper

java.lang.Object
    继承者  org.omg.PortableServer.CurrentHelper

public abstract class CurrentHelper
extends Object

从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。提供 Current 接口是为了支持实现多个对象，但可以在任一 servant 上 POA 调度的方法调用的上下文中使用的 servant。如果要提供位置透明性，则 ORB 必须支持在本地和远程调用操作的上下文中都使用 Current。通过进行 CORBA::ORB::resolve_initial_references("POACurrent") 操作，应用程序可获得 Current 的实例。此后，它便可以在 POA 指派的方法的上下文中使用，以获取标识调用操作的对象的 POA 和 ObjectId。

构造方法摘要
CurrentHelper()
方法摘要
static Current | extract(Any a)
static String | id()
static void | insert(Any a, Current that)
static Current | narrow(Object obj)
static Current | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Current value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CurrentHelper

public CurrentHelper()
方法详细信息

insert

public static void insert(Any a,
                          Current that)

extract

public static Current extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Current read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Current value)

narrow

public static Current narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 CurrentOperations

所有超级接口：
CurrentOperations
所有已知子接口：
Current
public interface CurrentOperations
extends CurrentOperations

从 CORBA::Current 中派生的 PortableServer::Current 接口，它提供一些能够访问调用方法的对象身份的方法实现。提供 Current 接口是为了支持实现多个对象，但可以在任一 servant 上 POA 调度的方法调用的上下文中使用的 servant。如果要提供位置透明性，则 ORB 必须支持在本地和远程调用操作的上下文中都使用 Current。通过进行 CORBA::ORB::resolve_initial_references("POACurrent") 操作，应用程序可获得 Current 的实例。此后，它便可以在 POA 指派的方法的上下文中使用，以获取标识调用操作的对象的 POA 和 ObjectId。

方法摘要
byte[] | get_object_id() 返回一个 ObjectId，标识此方法在其上下文中调用的对象。
POA | get_POA() 返回对 POA 的引用，该 POA 实现此方法在其上下文中调用的对象。

方法详细信息

get_POA

POA get_POA()
            throws NoContext
返回对 POA 的引用，该 POA 实现此方法在其上下文中调用的对象。

返回：
实现对象的 POA。
抛出：
NoContext - 在操作超出 POA 调度的操作范围时引发。

get_object_id

byte[] get_object_id()
                     throws NoContext
返回一个 ObjectId，标识此方法在其上下文中调用的对象。

返回：
对象的 ObjectId
抛出：
NoContext - 在超出 POA 调度的操作范围调用该操作时引发。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynamicImplementation (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 DynamicImplementation

java.lang.Object
    继承者  org.omg.PortableServer.Servant
        继承者  org.omg.PortableServer.DynamicImplementation

public abstract class DynamicImplementation
extends Servant

允许动态处理对象调用。基于 POA 的 DSI servant 继承自标准 DynamicImplementation 类，此类继承自 Servant 类。基于 IDL to Java 规范。CORBA V 2.3.1 ptc/00-01-08.pdf。

构造方法摘要
DynamicImplementation()
方法摘要
abstract  void invoke(ServerRequest request)
接收发布到任何由 DSI servant 实现的 CORBA 对象的请求，并进行执行该请求所需的处理。
从类 org.omg.PortableServer.Servant 继承的方法
_all_interfaces, _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynamicImplementation

public DynamicImplementation()
方法详细信息

invoke

public abstract void invoke(ServerRequest request)
接收发布到任何由 DSI servant 实现的 CORBA 对象的请求，并进行执行该请求所需的处理。

参数：
request - 发布到 CORBA 对象的请求。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ForwardRequest (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ForwardRequest

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.ForwardRequest
所有已实现的接口：
Serializable, IDLEntity
public final class ForwardRequest
extends UserException

org/omg/PortableServer/ForwardRequest.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植））从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
 Object forward_reference
构造方法摘要
ForwardRequest()
ForwardRequest(Object _forward_reference)
ForwardRequest(String $reason, Object _forward_reference)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

forward_reference

public Object forward_reference
构造方法详细信息

ForwardRequest

public ForwardRequest()

ForwardRequest

public ForwardRequest(Object _forward_reference)

ForwardRequest

public ForwardRequest(String $reason,
                      Object _forward_reference)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ForwardRequestHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ForwardRequestHelper

java.lang.Object
    继承者  org.omg.PortableServer.ForwardRequestHelper

public abstract class ForwardRequestHelper
extends Object

org/omg/PortableServer/ForwardRequestHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ForwardRequestHelper()
方法摘要
static ForwardRequest | extract(Any a)
static String | id()
static void | insert(Any a, ForwardRequest that)
static ForwardRequest | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ForwardRequest value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ForwardRequestHelper

public ForwardRequestHelper()
方法详细信息

insert

public static void insert(Any a,
                          ForwardRequest that)

extract

public static ForwardRequest extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ForwardRequest read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ForwardRequest value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ID_ASSIGNMENT_POLICY_ID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ID_ASSIGNMENT_POLICY_ID

public interface ID_ASSIGNMENT_POLICY_ID

org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
static int value
表示 ID_ASSIGNMENT_POLICY_ID 的值。

字段详细信息

value

static final int value
表示 ID_ASSIGNMENT_POLICY_ID 的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ID_UNIQUENESS_POLICY_ID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ID_UNIQUENESS_POLICY_ID

public interface ID_UNIQUENESS_POLICY_ID

org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
static int value
表示 ID_UNIQUENESS_POLICY_ID 的值。

字段详细信息

value

static final int value
表示 ID_UNIQUENESS_POLICY_ID 的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdAssignmentPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 IdAssignmentPolicy

所有超级接口：
IdAssignmentPolicyOperations, IDLEntity, Object, Policy, PolicyOperations, Serializable
public interface IdAssignmentPolicy
extends IdAssignmentPolicyOperations, Policy, IDLEntity

IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。默认值是 SYSTEM_ID。

方法摘要
从接口 org.omg.PortableServer.IdAssignmentPolicyOperations 继承的方法
value
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdAssignmentPolicyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 IdAssignmentPolicyOperations

所有超级接口：
PolicyOperations
所有已知子接口：
IdAssignmentPolicy
public interface IdAssignmentPolicyOperations
extends PolicyOperations

IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。默认值是 SYSTEM_ID。

方法摘要
 IdAssignmentPolicyValue value()
指定策略值。
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type

方法详细信息

value

IdAssignmentPolicyValue value()
指定策略值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdAssignmentPolicyValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 IdAssignmentPolicyValue

java.lang.Object
    继承者  org.omg.PortableServer.IdAssignmentPolicyValue
所有已实现的接口：
Serializable, IDLEntity
public class IdAssignmentPolicyValue
extends Object
implements IDLEntity

IdAssignmentPolicyValue 可以具有以下值。USER_ID - 只能由应用程序为 POA 中创建的对象分配 Object Id。SYSTEM_ID - 只能由 POA 为 POA 中创建的对象分配 Object Id。如果 POA 同时具有 PERSISTENT 策略，则分配的 Object Id 在同一 POA 的所有实例中必须唯一。

字段摘要
static int | _SYSTEM_ID
static int | _USER_ID
static IdAssignmentPolicyValue | SYSTEM_ID
static IdAssignmentPolicyValue | USER_ID
构造方法摘要
protected IdAssignmentPolicyValue(int value)
方法摘要
static IdAssignmentPolicyValue | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_USER_ID

public static final int _USER_ID
另请参见：
常量字段值

USER_ID

public static final IdAssignmentPolicyValue USER_ID

_SYSTEM_ID

public static final int _SYSTEM_ID
另请参见：
常量字段值

SYSTEM_ID

public static final IdAssignmentPolicyValue SYSTEM_ID
构造方法详细信息

IdAssignmentPolicyValue

protected IdAssignmentPolicyValue(int value)
方法详细信息

value

public int value()

from_int

public static IdAssignmentPolicyValue from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdUniquenessPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 IdUniquenessPolicy

所有超级接口：
IDLEntity, IdUniquenessPolicyOperations, Object, Policy, PolicyOperations, Serializable
public interface IdUniquenessPolicy
extends IdUniquenessPolicyOperations, Policy, IDLEntity

IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。默认值为 UNIQUE_ID。

方法摘要
从接口 org.omg.PortableServer.IdUniquenessPolicyOperations 继承的方法
value
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdUniquenessPolicyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 IdUniquenessPolicyOperations

所有超级接口：
PolicyOperations
所有已知子接口：
IdUniquenessPolicy
public interface IdUniquenessPolicyOperations
extends PolicyOperations

IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。默认值为 UNIQUE_ID。

方法摘要
 IdUniquenessPolicyValue value()
指定策略值
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type

方法详细信息

value

IdUniquenessPolicyValue value()
指定策略值

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdUniquenessPolicyValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 IdUniquenessPolicyValue

java.lang.Object
    继承者  org.omg.PortableServer.IdUniquenessPolicyValue
所有已实现的接口：
Serializable, IDLEntity
public class IdUniquenessPolicyValue
extends Object
implements IDLEntity

IdUniquenessPolicyValue 可以具有以下值。UNIQUE_ID - 使用 POA 激活的 Servant 只支持一个 Object Id。MULTIPLE_ID - 使用 POA 激活的 servant 可以支持一个或多个 Object Id。

字段摘要
static int | _MULTIPLE_ID
static int | _UNIQUE_ID
static IdUniquenessPolicyValue | MULTIPLE_ID
static IdUniquenessPolicyValue | UNIQUE_ID
构造方法摘要
protected IdUniquenessPolicyValue(int value)
方法摘要
static IdUniquenessPolicyValue | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_UNIQUE_ID

public static final int _UNIQUE_ID
另请参见：
常量字段值

UNIQUE_ID

public static final IdUniquenessPolicyValue UNIQUE_ID

_MULTIPLE_ID

public static final int _MULTIPLE_ID
另请参见：
常量字段值

MULTIPLE_ID

public static final IdUniquenessPolicyValue MULTIPLE_ID
构造方法详细信息

IdUniquenessPolicyValue

protected IdUniquenessPolicyValue(int value)
方法详细信息

value

public int value()

from_int

public static IdUniquenessPolicyValue from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IMPLICIT_ACTIVATION_POLICY_ID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 IMPLICIT_ACTIVATION_POLICY_ID

public interface IMPLICIT_ACTIVATION_POLICY_ID

org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
static int value
表示 IMPLICIT_ACTIVATION_POLICY_ID 的值。

字段详细信息

value

static final int value
表示 IMPLICIT_ACTIVATION_POLICY_ID 的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImplicitActivationPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ImplicitActivationPolicy

所有超级接口：
IDLEntity, ImplicitActivationPolicyOperations, Object, Policy, PolicyOperations, Serializable
public interface ImplicitActivationPolicy
extends ImplicitActivationPolicyOperations, Policy, IDLEntity

此策略指定已创建的 POA 中是否支持隐式激活 servant。

方法摘要
从接口 org.omg.PortableServer.ImplicitActivationPolicyOperations 继承的方法
value
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImplicitActivationPolicyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ImplicitActivationPolicyOperations

所有超级接口：
PolicyOperations
所有已知子接口：
ImplicitActivationPolicy
public interface ImplicitActivationPolicyOperations
extends PolicyOperations

此策略指定已创建的 POA 中是否支持隐式激活 servant。

方法摘要
 ImplicitActivationPolicyValue value()
指定策略值
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type

方法详细信息

value

ImplicitActivationPolicyValue value()
指定策略值

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImplicitActivationPolicyValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ImplicitActivationPolicyValue

java.lang.Object
    继承者  org.omg.PortableServer.ImplicitActivationPolicyValue
所有已实现的接口：
Serializable, IDLEntity
public class ImplicitActivationPolicyValue
extends Object
implements IDLEntity

ImplicitActivationPolicyValue 具有以下语义。IMPLICIT_ACTIVATION 指示隐式激活 servant。这需要设置 SYSTEM_ID 和 RETAIN 策略。NO_IMPLICIT_ACTIVATION 指示不支持隐式激活 servant。

字段摘要
static int | _IMPLICIT_ACTIVATION
static int | _NO_IMPLICIT_ACTIVATION
static ImplicitActivationPolicyValue | IMPLICIT_ACTIVATION
static ImplicitActivationPolicyValue | NO_IMPLICIT_ACTIVATION
构造方法摘要
protected ImplicitActivationPolicyValue(int value)
方法摘要
static ImplicitActivationPolicyValue | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_IMPLICIT_ACTIVATION

public static final int _IMPLICIT_ACTIVATION
另请参见：
常量字段值

IMPLICIT_ACTIVATION

public static final ImplicitActivationPolicyValue IMPLICIT_ACTIVATION

_NO_IMPLICIT_ACTIVATION

public static final int _NO_IMPLICIT_ACTIVATION
另请参见：
常量字段值

NO_IMPLICIT_ACTIVATION

public static final ImplicitActivationPolicyValue NO_IMPLICIT_ACTIVATION
构造方法详细信息

ImplicitActivationPolicyValue

protected ImplicitActivationPolicyValue(int value)
方法详细信息

value

public int value()

from_int

public static ImplicitActivationPolicyValue from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LIFESPAN_POLICY_ID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 LIFESPAN_POLICY_ID

public interface LIFESPAN_POLICY_ID

org/omg/PortableServer/LIFESPAN_POLICY_ID.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
static int value
表示 LIFESPAN_POLICY_ID 的值。

字段详细信息

value

static final int value
表示 LIFESPAN_POLICY_ID 的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LifespanPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 LifespanPolicy

所有超级接口：
IDLEntity, LifespanPolicyOperations, Object, Policy, PolicyOperations, Serializable
public interface LifespanPolicy
extends LifespanPolicyOperations, Policy, IDLEntity

LifespanPolicy 指定已创建 POA 中实现的对象的生存期。默认值为 TRANSIENT。

方法摘要
从接口 org.omg.PortableServer.LifespanPolicyOperations 继承的方法
value
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LifespanPolicyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 LifespanPolicyOperations

所有超级接口：
PolicyOperations
所有已知子接口：
LifespanPolicy
public interface LifespanPolicyOperations
extends PolicyOperations

LifespanPolicy 指定已创建 POA 中实现的对象的生存期。默认值为 TRANSIENT。

方法摘要
 LifespanPolicyValue value()
指定策略值
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type

方法详细信息

value

LifespanPolicyValue value()
指定策略值

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LifespanPolicyValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 LifespanPolicyValue

java.lang.Object
    继承者  org.omg.PortableServer.LifespanPolicyValue
所有已实现的接口：
Serializable, IDLEntity
public class LifespanPolicyValue
extends Object
implements IDLEntity

LifespanPolicyValue 可以具有以下值。TRANSIENT - POA 中实现对象的存活期不能超过其第一次创建时所在的 POA 实例。PERSISTENT - POA 中实现对象的存活期可以超过其第一次创建的过程。

字段摘要
static int | _PERSISTENT
static int | _TRANSIENT
static LifespanPolicyValue | PERSISTENT
static LifespanPolicyValue | TRANSIENT
构造方法摘要
protected LifespanPolicyValue(int value)
方法摘要
static LifespanPolicyValue | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_TRANSIENT

public static final int _TRANSIENT
另请参见：
常量字段值

TRANSIENT

public static final LifespanPolicyValue TRANSIENT

_PERSISTENT

public static final int _PERSISTENT
另请参见：
常量字段值

PERSISTENT

public static final LifespanPolicyValue PERSISTENT
构造方法详细信息

LifespanPolicyValue

protected LifespanPolicyValue(int value)
方法详细信息

value

public int value()

from_int

public static LifespanPolicyValue from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


POA (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 POA

所有超级接口：
IDLEntity, Object, POAOperations, Serializable
public interface POA
extends POAOperations, Object, IDLEntity

POA 对象管理对象集合的实现。POA 支持由 Object Id 标识的对象的名称空间。POA 也支持 POA 的名称空间。POA 都是作为现有 POA 的子 POA 创建的，这形成了始于根 POA 的分层结构。POA 对象不得输出到其他进程，也不得使用 ORB::object_to_string 具体化。

方法摘要
从接口 org.omg.PortableServer.POAOperations 继承的方法
activate_object_with_id, activate_object, create_id_assignment_policy, create_id_uniqueness_policy, create_implicit_activation_policy, create_lifespan_policy, create_POA, create_reference_with_id, create_reference, create_request_processing_policy, create_servant_retention_policy, create_thread_policy, deactivate_object, destroy, find_POA, get_servant_manager, get_servant, id_to_reference, id_to_servant, id, reference_to_id, reference_to_servant, servant_to_id, servant_to_reference, set_servant_manager, set_servant, the_activator, the_activator, the_children, the_name, the_parent, the_POAManager
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


POAHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 POAHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAHelper

public abstract class POAHelper
extends Object

POA 对象管理对象集合的实现。POA 支持由 Object Id 标识的对象的名称空间。POA 也支持 POA 的名称空间。POA 都是作为现有 POA 的子 POA 创建的，这形成了始于根 POA 的分层结构。POA 对象不得输出到其他进程，也不得使用 ORB::object_to_string 具体化。

构造方法摘要
POAHelper()
方法摘要
static POA | extract(Any a)
static String | id()
static void | insert(Any a, POA that)
static POA | narrow(Object obj)
static POA | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, POA value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

POAHelper

public POAHelper()
方法详细信息

insert

public static void insert(Any a,
                          POA that)

extract

public static POA extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static POA read(InputStream istream)

write

public static void write(OutputStream ostream,
                         POA value)

narrow

public static POA narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


POAManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 POAManager

所有超级接口：
IDLEntity, Object, POAManagerOperations, Serializable
public interface POAManager
extends POAManagerOperations, Object, IDLEntity

每个 POA 对象都有一个关联的 POAManager 对象。POA 管理器可以与一个或多个 POA 对象关联。POA 管理器封装 POA 关联的处理状态。

方法摘要
从接口 org.omg.PortableServer.POAManagerOperations 继承的方法
activate, deactivate, discard_requests, get_state, hold_requests
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


POAManagerOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 POAManagerOperations

所有已知子接口：
POAManager
public interface POAManagerOperations

每个 POA 对象具有一个关联的 POAManager 对象。POA 管理器可以与一个或多个 POA 对象关联。POA 管理器封装 POA 关联的处理状态。

方法摘要
void | activate() 此操作将 POA 管理器更改为激活状态，促使关联的 POA 开始处理请求。
void | deactivate(boolean etherealize_objects, boolean wait_for_completion) 此操作将 POA 管理器的状态更改为非激活 (inactive)，促使关联的 POA 拒绝尚未开始执行的请求以及任何新的请求。
void | discard_requests(boolean wait_for_completion) 此操作将 POA 管理器的状态更改为丢弃 (discarding)。
State | get_state() 此操作返回 POA 管理器的状态。
void | hold_requests(boolean wait_for_completion) 此操作将 POA 管理器更改为保持 (holding) 状态，促使关联的 POA 将传入请求排队。

方法详细信息

activate

void activate()
              throws AdapterInactive
此操作将 POA 管理器更改为激活状态，促使关联的 POA 开始处理请求。

抛出：
AdapterInactive - 对非激活状态的 POAManager 调用该操作时引发。

hold_requests

void hold_requests(boolean wait_for_completion)
                   throws AdapterInactive
此操作将 POA 管理器更改为保持 (holding) 状态，促使关联的 POA 将传入请求排队。

参数：
wait_for_completion - 如果为 FALSE，则操作在更改状态后立即返回。如果为 TRUE，则操作将等待所有激活的请求完成。
抛出：
AdapterInactive - 对非激活状态的 POAManager 调用该操作时引发。

discard_requests

void discard_requests(boolean wait_for_completion)
                      throws AdapterInactive
此操作将 POA 管理器的状态更改为丢弃 (discarding)。这促使关联的 POA 丢弃传入请求。

参数：
wait_for_completion - 如果为 FALSE，则操作在更改状态后立即返回。如果为 TRUE，则操作将等待所有激活的请求完成。
抛出：
AdapterInactive - 对非激活状态的 POAManager 调用该操作时引发。

deactivate

void deactivate(boolean etherealize_objects,
                boolean wait_for_completion)
                throws AdapterInactive
此操作将 POA 管理器的状态更改为非激活 (inactive)，促使关联的 POA 拒绝尚未开始执行的请求以及任何新的请求。

参数：
etherealize_objects - 一个标记，指示是否对所有激活的对象调用关联 servant 管理器的 etherealize 操作。
wait_for_completion - 如果为 FALSE，则操作在更改状态后立即返回。如果为 TRUE，则操作将等待所有激活的请求完成。
抛出：
AdapterInactive - 对非激活状态的 POAManager 调用该操作时引发。

get_state

State get_state()
此操作返回 POA 管理器的状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


POAOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 POAOperations

所有已知子接口：
POA
public interface POAOperations

POA 对象管理对象集合的实现。POA 支持由 Object Id 标识的对象的名称空间。POA 也支持 POA 的名称空间。POA 都是作为现有 POA 的子 POA 创建的，这形成了始于根 POA 的分层结构。POA 对象不得输出到其他进程，也不得使用 ORB::object_to_string 具体化。

方法摘要
void | activate_object_with_id(byte[] id, Servant p_servant) 此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
byte[] | activate_object(Servant p_servant) 此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。
IdAssignmentPolicy | create_id_assignment_policy(IdAssignmentPolicyValue value) 每个这类操作都返回一个对具有指定值的策略对象的引用。
IdUniquenessPolicy | create_id_uniqueness_policy(IdUniquenessPolicyValue value) 每个这类操作都返回一个对具有指定值的策略对象的引用。
ImplicitActivationPolicy | create_implicit_activation_policy(ImplicitActivationPolicyValue value) 每个这类操作都返回一个对具有指定值的策略对象的引用。
LifespanPolicy | create_lifespan_policy(LifespanPolicyValue value) 每个这类操作都返回一个对具有指定值的策略对象的引用。
POA | create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies) 此操作创建一个新的 POA 作为目标 POA 的子 POA。
Object | create_reference_with_id(byte[] oid, String intf) 此操作创建一个对象引用，该引用封装指定的 Object Id 和接口存储库 Id 值。
Object | create_reference(String intf) 此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。
RequestProcessingPolicy | create_request_processing_policy(RequestProcessingPolicyValue value) 每个这类操作都返回一个对具有指定值的策略对象的引用。
ServantRetentionPolicy | create_servant_retention_policy(ServantRetentionPolicyValue value) 每个这类操作都返回一个对具有指定值的策略对象的引用。
ThreadPolicy | create_thread_policy(ThreadPolicyValue value) 每个这种操作都返回一个对具有指定值的策略对象的引用。
void | deactivate_object(byte[] oid) 此操作促使在 oid 参数中指定的 ObjectId 被取消激活。
void | destroy(boolean etherealize_objects, boolean wait_for_completion) 此操作销毁 POA 及所有子代 POA。
POA | find_POA(String adapter_name, boolean activate_it) 如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。
ServantManager | get_servant_manager() 如果 POA 的 ServantRetentionPolicy 为 RETAIN，则 ServantManager 参数 (imgr) 应该支持 ServantActivator 接口。
Servant | get_servant() 此操作返回与 POA 关联的默认 servant。
Object | id_to_reference(byte[] oid) 如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
Servant | id_to_servant(byte[] oid) 如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
byte[] | id() 此操作在 POA 的创建过程中返回该 POA 的唯一 id。
byte[] | reference_to_id(Object reference) 此操作返回指定引用封装的 Object Id 值。
Servant | reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
byte[] | servant_to_id(Servant p_servant) 此操作有四种可能的行为。
Object | servant_to_reference(Servant p_servant) 如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。
void | set_servant_manager(ServantManager imgr) 此操作设置与 POA 关联的默认 servant 管理器。
void | set_servant(Servant p_servant) 此操作在 POA 中将指定的 servant 注册为默认 servant。
AdapterActivator | the_activator() 此属性标识与 POA 关联的适配器激活器。
void | the_activator(AdapterActivator newThe_activator) 此属性标识与 POA 关联的适配器激活器。
POA[] | the_children() 此属性标识 POA 的所有子 POA 的当前设置。
String | the_name() 此属性标识相对于其父 POA 的 POA。
POA | the_parent() 此属性标识 POA 的父 POA。
POAManager | the_POAManager() 此属性标识与 POA 关联的 POA 管理器。

方法详细信息

create_POA

POA create_POA(String adapter_name,
               POAManager a_POAManager,
               Policy[] policies)
               throws AdapterAlreadyExists,
                      InvalidPolicy
此操作创建一个新的 POA 作为目标 POA 的子 POA。

参数：
adapter_name - 标识新的 POA（就其他具有相同父 POA 的 POA 而言）。
a_POAManager - 指示与新 POA 关联的 POA 管理器。
policies - 指示与将与 POA 关联以控制其行为的策略对象。
抛出：
AdapterAlreadyExists - 指示目标 POA 已经有一个具有指定名称的子 POA。
InvalidPolicy - 策略对象中存在对 ORB 无效的策略、存在冲突，或要求未执行的管理动作时引发。

find_POA

POA find_POA(String adapter_name,
             boolean activate_it)
             throws AdapterNonExistent
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。

参数：
adapter_name - 要查找的 POA 名称。
activate_it - 如果不存在具有指定名称的 POA，且 activate_it 参数的值为 TRUE，则将调用目标 POA 的 AdapterActivator（如果有）。
返回：
POA，如果有或由 AdapterActivator 激活。
抛出：
AdapterNonExistent

destroy

void destroy(boolean etherealize_objects,
             boolean wait_for_completion)
此操作销毁 POA 及所有子代 POA。在销毁包含子代的 POA 前销毁（以递归形式）所有子代 POA。以此方式销毁的 POA（即具有其名称的 POA）以后可通过相同的过程重新创建。

参数：
etherealize_objects - 指示是否需要对 servant 管理器调用 etherealize 操作的标记。
wait_for_completion - 一个标记，指示 POA 及其子 POA 是否需要等待激活的请求和 etherealization 操作完成。

create_thread_policy

ThreadPolicy create_thread_policy(ThreadPolicyValue value)
每个这种操作都返回一个对具有指定值的策略对象的引用。

参数：
value - 策略类型
返回：
ThreadPolcy 对象

create_lifespan_policy

LifespanPolicy create_lifespan_policy(LifespanPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

参数：
value - 策略类型
返回：
LifespanPolicy 对象

create_id_uniqueness_policy

IdUniquenessPolicy create_id_uniqueness_policy(IdUniquenessPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

参数：
value - 策略类型
返回：
IdUniquenessPolicy 对象

create_id_assignment_policy

IdAssignmentPolicy create_id_assignment_policy(IdAssignmentPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

参数：
value - 策略类型
返回：
IdAssignmentPolicy 对象

create_implicit_activation_policy

ImplicitActivationPolicy create_implicit_activation_policy(ImplicitActivationPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

参数：
value - 策略类型
返回：
ImplicitActivationPolicy 对象

create_servant_retention_policy

ServantRetentionPolicy create_servant_retention_policy(ServantRetentionPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

参数：
value - 策略类型
返回：
ServantRetentionPolicy 对象

create_request_processing_policy

RequestProcessingPolicy create_request_processing_policy(RequestProcessingPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

参数：
value - 策略类型
返回：
RequestProcessingPolicy 对象

the_name

String the_name()
此属性标识相对于其父 POA 的 POA。此名称在创建 POA 时分配。

the_parent

POA the_parent()
此属性标识 POA 的父 POA。根 POA 的父 POA 为 null。

the_children

POA[] the_children()
此属性标识 POA 的所有子 POA 的当前设置。子 POA 的设置只包括 POA 的直接子 POA，不包括其直接子 POA 的子代。

the_POAManager

POAManager the_POAManager()
此属性标识与 POA 关联的 POA 管理器。

the_activator

AdapterActivator the_activator()
此属性标识与 POA 关联的适配器激活器。

the_activator

void the_activator(AdapterActivator newThe_activator)
此属性标识与 POA 关联的适配器激活器。

get_servant_manager

ServantManager get_servant_manager()
                                   throws WrongPolicy
如果 POA 的 ServantRetentionPolicy 为 RETAIN，则 ServantManager 参数 (imgr) 应该支持 ServantActivator 接口。对于 NON_RETAIN 策略，ServantManager 应该支持 ServantLocator 接口。如果参数为 nil 或不支持所需接口，则引发 OBJ_ADAPTER 异常。

返回：
与 POA 关联的 ServantManager；如果不存在，则返回 null。
抛出：
WrongPolicy - 未指定 USE_SERVANT_MANAGER 策略时引发。

set_servant_manager

void set_servant_manager(ServantManager imgr)
                         throws WrongPolicy
此操作设置与 POA 关联的默认 servant 管理器。此操作只能在创建了 POA 后调用一次。试图在已经设置了 servant 管理器后再次设置将导致引发 BAD_INV_ORDER 异常。

参数：
imgr - 默认情况下使用的 servant 管理器。
抛出：
WrongPolicy - 未指定 USE_SERVANT_MANAGER 策略时引发。

get_servant

Servant get_servant()
                    throws NoServant,
                           WrongPolicy
此操作返回与 POA 关联的默认 servant。

返回：
p_servant 与 POA 关联的默认 servant。
抛出：
NoServant - 没有与 POA 关联的默认 servant 时引发。
WrongPolicy - 未指定 USE_DEFAULT_SERVANT 策略时引发。

set_servant

void set_servant(Servant p_servant)
                 throws WrongPolicy
此操作在 POA 中将指定的 servant 注册为默认 servant。此 servant 将用于所有在 Active Object Map 中没有对应 servant 的请求。

参数：
p_servant - 默认情况下使用的 servant。
抛出：
WrongPolicy - 未指定 USE_DEFAULT_SERVANT 策略时引发。

activate_object

byte[] activate_object(Servant p_servant)
                       throws ServantAlreadyActive,
                              WrongPolicy
此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。

参数：
p_servant - 要与将被激活的对象关联的 servant。
返回：
生成对象 id 的 POA。
抛出：
ServantAlreadyActive - 在 POA 具有 UNIQUE_ID 策略且 servant 已经存在于 Active Object Map 时引发。
WrongPolicy - 未指定 SYSTEM_ID 和 RETAIN 策略时引发。

activate_object_with_id

void activate_object_with_id(byte[] id,
                             Servant p_servant)
                             throws ServantAlreadyActive,
                                    ObjectAlreadyActive,
                                    WrongPolicy
此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。

参数：
id - 将被激活的对象的对象 id。
p_servant - 将关联对象的 servant。
抛出：
ServantAlreadyActive - 在 POA 具有 UNIQUE_ID 策略且 servant 已经存在于 Active Object Map 时引发。
ObjectAlreadyActive - 对象已经在 POA 中激活时引发。
WrongPolicy - 未指定 RETAIN 策略时引发。

deactivate_object

void deactivate_object(byte[] oid)
                       throws ObjectNotActive,
                              WrongPolicy
此操作促使在 oid 参数中指定的 ObjectId 被取消激活。只要已取消激活的 ObjectId 中还存在激活的请求，该 ObjectId 将继续处理请求。当为停用的 ObjectId 执行的所有请求全部完成后，将从 Active Object Map 中移除该 ObjectId。

参数：
oid - 将被停用的对象的 Object Id。
抛出：
ObjectNotActive - 如果具有指定 oid 的对象不在 Active Object Map 中。
WrongPolicy - 未指定 RETAIN 策略时引发。

create_reference

Object create_reference(String intf)
                        throws WrongPolicy
此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。

参数：
intf - 用来创建对象引用的 rep id。
返回：
使用 intf 创建的对象引用。
抛出：
WrongPolicy - 如果未指定 SYSTEM_ID 策略。

create_reference_with_id

Object create_reference_with_id(byte[] oid,
                                String intf)
此操作创建一个对象引用，该引用封装指定的 Object Id 和接口存储库 Id 值。该操作不会导致发生激活。所得引用可以传递给客户端，从而后续对这些引用的请求将导致在必要时可激活对象，或者使用默认的 servant，具体取决于适用的策略。

参数：
oid - 用来创建 objref 的对象 id
intf - 用来创建 objref 的 rep id
返回：
使用 oid 和 intf 创建的对象引用
抛出：
BAD_PARAM - 如果 POA 具有 SYSTEM_ID 策略且它检测到系统或 POA 没有生成 Object Id 值。

servant_to_id

byte[] servant_to_id(Servant p_servant)
                     throws ServantNotActive,
                            WrongPolicy
此操作有四种可能的行为。1. 如果 POA 具有 UNIQUE_ID 策略且指定的 servant 已激活，则返回与该 servant 关联的 Object Id。2. 如果 POA 具有 IMPLICIT_ACTIVATION 策略，并且 POA 具有 MULTIPLE_ID 策略或者指定的 servant 未激活，则使用 POA 生成的 Object Id 和与该 servant 关联的 Interface Id 激活 servant，并返回该 Object Id。3. 如果 POA 具有 USE_DEFAULT_SERVANT 策略，指定的 servant 为默认 servant，并将在执行请求的上下文中对默认 servant 调用该操作，则将返回关联当前调用的 ObjectId。4. 其他情况下引发 ServantNotActive 异常。

参数：
p_servant - 为其返回对象 disi 的 servant。
返回：
与 servant 关联的对象 id。
抛出：
ServantNotActive - 如果不满足上述规则和策略组合。
WrongPolicy - 如果 USE_DEFAULT_SERVANT 策略或 RETAIN 策略的组合以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略不存在。

servant_to_reference

Object servant_to_reference(Servant p_servant)
                            throws ServantNotActive,
                                   WrongPolicy
如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。它具有四种可能的行为。1. 如果 POA 同时具有 RETAIN 和 UNIQUE_ID 策略，且指定的 servant 是激活的，则返回一个封装激活 servant 时所用信息的对象引用。2. 如果 POA 同时具有 RETAIN 和 IMPLICIT_ACTIVATION 策略，并且 POA 具有 MULTIPLE_ID 策略或者指定的 servant 未激活，则使用 POA 生成的 Object Id 和与该 servant 关联的 Interface Id 激活 servant，并返回响应的对象引用。3. 如果该操作在执行请求的上下文中对指定的 servant 调用，则返回关联当前调用的引用。4. 其他情况下引发 ServantNotActive 异常。

参数：
p_servant - 需要为其获取对象引用的 servant。
返回：
与 servant 关联的对象引用。
抛出：
WrongPolicy - 如果操作不是在对指定 servant 执行请求的上下文中调用的，且所需的策略不存在。
ServantNotActive - 如果不满足上述指定策略和规则。

reference_to_servant

Servant reference_to_servant(Object reference)
                             throws ObjectNotActive,
                                    WrongPolicy,
                                    WrongAdapter
如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。如果 POA 具有 USE_DEFAULT_SERVANT 策略并且已经向 POA 注册了默认 servant，则此操作返回该默认 servant。如果此 POA 没有创建对象引用，则引发 WrongAdapter 异常。（与 POA.IDL 不一致的 OMG 问题。）

参数：
reference - 为其返回 servant 的对象引用。
返回：
与引用关联的 servant。
抛出：
WrongPolicy - 如果 RETAIN 策略或 USE_DEFAULT_SERVANT 策略都不存在。
ObjectNotActive - 如果 servant 不存在于 Active Object Map 中（对于 RETAIN）或者没有注册默认 servant（对于 USE_DEFAULT_POLICY）。
WrongAdapter - 如果此 POA 实例没有创建引用。

reference_to_id

byte[] reference_to_id(Object reference)
                       throws WrongAdapter,
                              WrongPolicy
此操作返回指定引用封装的 Object Id 值。仅在引用是由将执行此操作的 POA 所创建的情况下，此操作才有效。引用表示的对象不是激活状态时此操作也能成功。

参数：
reference - 对象引用，需要根据该引用返回对象 id。
返回：
引用中封装的对象 id。
抛出：
WrongAdapter - 如果引用不是由引用中指定的 POA 创建的。
WrongPolicy - 先声明，以用于以后扩展。

id_to_servant

Servant id_to_servant(byte[] oid)
                      throws ObjectNotActive,
                             WrongPolicy
如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。如果 POA 具有 USE_DEFAULT_SERVANT 策略并且已经向 POA 注册了默认 servant，则此操作返回该默认 servant。

参数：
oid - 为其返回 servant 的对象 id。
返回：
与 oid 关联的 servant。
抛出：
ObjectNotActive - 如果 ObjectId 不存在于 Active Object Map 中（对于 RETAIN 策略），或者没有注册默认 servant（对于 USE_DEFAULT_SERVANT 策略）。
WrongPolicy - 如果 RETAIN 策略或 USE_DEFAULT_SERVANT 策略不存在，则引发该异常。

id_to_reference

Object id_to_reference(byte[] oid)
                       throws ObjectNotActive,
                              WrongPolicy
如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。

参数：
oid - 为其返回引用的对象 id。
返回：
对象引用。
抛出：
ObjectNotActive - 如果 POA 中的 Object Id 值未激活。
WrongPolicy - 如果不存在 RETAIN 策略。

id

byte[] id()
此操作在 POA 的创建过程中返回该 POA 的唯一 id。该值由可移植的 interceptor 使用。

此 id 在 POA 处理过程中的生命周期内保证是唯一的。对于持久 POA，这意味着如果在同一路径使用与另一个 POA 相同的名称创建一个 POA，则这两个 POA 是等同的，也因此具有相同的 id。对于瞬态 POA，每个 POA 均唯一。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


REQUEST_PROCESSING_POLICY_ID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 REQUEST_PROCESSING_POLICY_ID

public interface REQUEST_PROCESSING_POLICY_ID

org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
static int value
表示 REQUEST_PROCESSING_POLICY_ID 的值。

字段详细信息

value

static final int value
表示 REQUEST_PROCESSING_POLICY_ID 的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestProcessingPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 RequestProcessingPolicy

所有超级接口：
IDLEntity, Object, Policy, PolicyOperations, RequestProcessingPolicyOperations, Serializable
public interface RequestProcessingPolicy
extends RequestProcessingPolicyOperations, Policy, IDLEntity

此策略指定已创建的 POA 处理请求的方式。默认值为 USE_ACTIVE_OBJECT_MAP_ONLY。

方法摘要
从接口 org.omg.PortableServer.RequestProcessingPolicyOperations 继承的方法
value
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestProcessingPolicyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 RequestProcessingPolicyOperations

所有超级接口：
PolicyOperations
所有已知子接口：
RequestProcessingPolicy
public interface RequestProcessingPolicyOperations
extends PolicyOperations

此策略指定已创建的 POA 处理请求的方式。默认值为 USE_ACTIVE_OBJECT_MAP_ONLY。

方法摘要
 RequestProcessingPolicyValue value()
指定策略值
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type

方法详细信息

value

RequestProcessingPolicyValue value()
指定策略值

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestProcessingPolicyValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 RequestProcessingPolicyValue

java.lang.Object
    继承者  org.omg.PortableServer.RequestProcessingPolicyValue
所有已实现的接口：
Serializable, IDLEntity
public class RequestProcessingPolicyValue
extends Object
implements IDLEntity

RequestProcessingPolicyValue 可以具有以下值。USE_ACTIVE_OBJECT_MAP_ONLY - 如果 Active Object Map 中不存在 Object Id，则向客户端返回 OBJECT_NOT_EXIST 异常。同时还需要 RETAIN 策略。USE_DEFAULT_SERVANT - 如果 Active Object Map 中不存在 Object Id 或者存在 NON_RETAIN 策略，并且已经使用 set_servant 操作向 POA 注册了默认 servant，则将请求指派给默认 servant。USE_SERVANT_MANAGER - 如果 Active Object Map 中不存在 Object Id 或者存在 NON_RETAIN 策略，并且已经使用 set_servant_manager 操作向 POA 注册了 servant 管理器，则可以使用该 servant 管理器定位 servant 或引发异常。。

字段摘要
static int | _USE_ACTIVE_OBJECT_MAP_ONLY
static int | _USE_DEFAULT_SERVANT
static int | _USE_SERVANT_MANAGER
static RequestProcessingPolicyValue | USE_ACTIVE_OBJECT_MAP_ONLY
static RequestProcessingPolicyValue | USE_DEFAULT_SERVANT
static RequestProcessingPolicyValue | USE_SERVANT_MANAGER
构造方法摘要
protected RequestProcessingPolicyValue(int value)
方法摘要
static RequestProcessingPolicyValue | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_USE_ACTIVE_OBJECT_MAP_ONLY

public static final int _USE_ACTIVE_OBJECT_MAP_ONLY
另请参见：
常量字段值

USE_ACTIVE_OBJECT_MAP_ONLY

public static final RequestProcessingPolicyValue USE_ACTIVE_OBJECT_MAP_ONLY

_USE_DEFAULT_SERVANT

public static final int _USE_DEFAULT_SERVANT
另请参见：
常量字段值

USE_DEFAULT_SERVANT

public static final RequestProcessingPolicyValue USE_DEFAULT_SERVANT

_USE_SERVANT_MANAGER

public static final int _USE_SERVANT_MANAGER
另请参见：
常量字段值

USE_SERVANT_MANAGER

public static final RequestProcessingPolicyValue USE_SERVANT_MANAGER
构造方法详细信息

RequestProcessingPolicyValue

protected RequestProcessingPolicyValue(int value)
方法详细信息

value

public int value()

from_int

public static RequestProcessingPolicyValue from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Servant (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 Servant

java.lang.Object
    继承者  org.omg.PortableServer.Servant
直接已知子类：
BindingIteratorPOA, DynamicImplementation, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA
public abstract class Servant
extends Object

定义本机 Servant 类型。在 Java 中，Servant 类型被映射到 Java org.omg.PortableServer.Servant 类。它充当所有 POA servant 实现的基类，提供许多可由应用程序员调用的方法，以及可由 POA 本身调用（也可由用户重写）以控制 servant 行为各方面的方法。基于 IDL to Java 规范。(CORBA V2.3.1) ptc/00-01-08.pdf。

构造方法摘要
Servant()
方法摘要
abstract  String[] _all_interfaces(POA poa, byte[] objectId)
ORB 使用此操作从 servant 获取完整的类型信息。
 POA _default_POA()
从与 servant 关联的 ORB 实例返回根 POA。
 Delegate _get_delegate()
获取 PortableServer::Servant 特定于供应商的 ORB 实现。
 Object _get_interface_def()
以 CORBA::Object 的形式返回 InterfaceDef 对象，该对象定义由 Servant 实现的 CORBA::Object 的运行时类型。
 boolean _is_a(String repository_id)
查看指定的 repository_id 是否存在于 _all_interfaces() 返回的列表，或者其是否是一般 CORBA 对象的 repository_id。
 boolean _non_existent()
检查 Object 是否存在。
 byte[] _object_id()
允许便捷地执行公共方法，等效于调用 PortableServer::Current::get_object_id。
 ORB _orb()
返回当前与 Servant 关联的 ORB 实例（便捷方法）。
 POA _poa()
允许便捷地执行共用方法，等效于 PortableServer::Current:get_POA。
 void _set_delegate(Delegate delegate)
此操作支持 Java ORB 可移植性接口，它向通过代理支持 ORB 可移植性的类提供一个设置其委托的方法。
 Object _this_object()
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
 Object _this_object(ORB orb)
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Servant

public Servant()
方法详细信息

_get_delegate

public final Delegate _get_delegate()
获取 PortableServer::Servant 特定于供应商的 ORB 实现。

返回：
_delegate，PortableServer::Servant 特定于供应商的 ORB 实现

_set_delegate

public final void _set_delegate(Delegate delegate)
此操作支持 Java ORB 可移植性接口，它向通过代理支持 ORB 可移植性的类提供一个设置其委托的方法。

参数：
delegate - PortableServer::Servant 特定于供应商的 ORB 实现。

_this_object

public final Object _this_object()
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。

返回：
关联请求的 this_object Object 引用。

_this_object

public final Object _this_object(ORB orb)
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。

参数：
orb - 与 servant 关联的 ORB。
返回：
与请求关联的 _this_object 引用。

_orb

public final ORB _orb()
返回当前与 Servant 关联的 ORB 实例（便捷方法）。

返回：
当前与 Servant 关联的 ORB 实例 orb。

_poa

public final POA _poa()
允许便捷地执行共用方法，等效于 PortableServer::Current:get_POA。

返回：
与 servant 关联的 POA poa。

_object_id

public final byte[] _object_id()
允许便捷地执行公共方法，等效于调用 PortableServer::Current::get_object_id。

返回：
与此 servant 关联的 Object ID object_id。

_default_POA

public POA _default_POA()
从与 servant 关联的 ORB 实例返回根 POA。子类可重写此方法来返回不同的 POA。

返回：
与 Servant 关联的 POA default_POA。

_is_a

public boolean _is_a(String repository_id)
查看指定的 repository_id 是否存在于 _all_interfaces() 返回的列表，或者其是否是一般 CORBA 对象的 repository_id。

参数：
repository_id - 要在存储库列表中检查（或根据通用 CORBA 对象的 id 检查）的 repository_id。
返回：
is_a boolean 值，指示指定的 repository_id 是否在存储列表中或者其是否与 CORBA 对象的相同。

_non_existent

public boolean _non_existent()
检查 Object 是否存在。Servant 提供 _non_existent() 的默认实现，该实现可通过派生的 servant 重写。

返回：
如果该对象不存在，则返回 true；否则返回 false。

_get_interface_def

public Object _get_interface_def()
以 CORBA::Object 的形式返回 InterfaceDef 对象，该对象定义由 Servant 实现的 CORBA::Object 的运行时类型。_get_interface_def 的调用者必须缩小 InterfaceDef 的结果以便使用。

如果默认行为无法满足要求，则可以通过派生的 servant 重写此 _get_interface_def() 默认实现。根据 CORBA 2.3.1 规范第 11.3.1 小节中的定义，_get_interface_def() 的默认行为是使用静态 servant 的最终派生接口或者从动态 servant 中得到的最终派生接口来获取 InterfaceDef。实现 Servant 的 Delegate 必须支持此行为。

返回：
get_interface_def（CORBA::Object 形式的 InterfaceDef 对象），它定义由 Servant 实现的 CORBA::Object 的运行时类型。

_all_interfaces

public abstract String[] _all_interfaces(POA poa,
                                         byte[] objectId)
ORB 使用此操作从 servant 获取完整的类型信息。

参数：
poa - 与 servant 关联的 POA。
objectId - 对应于与此 servant 关联的对象的 id。
返回：
对象类型信息列表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SERVANT_RETENTION_POLICY_ID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 SERVANT_RETENTION_POLICY_ID

public interface SERVANT_RETENTION_POLICY_ID

org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
static int value
表示 SERVANT_RETENTION_POLICY_ID 的值。

字段详细信息

value

static final int value
表示 SERVANT_RETENTION_POLICY_ID 的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantActivator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ServantActivator

所有超级接口：
IDLEntity, Object, Serializable, ServantActivatorOperations, ServantManager, ServantManagerOperations
所有已知实现类：
_ServantActivatorStub
public interface ServantActivator
extends ServantActivatorOperations, ServantManager, IDLEntity

POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

方法摘要
从接口 org.omg.PortableServer.ServantActivatorOperations 继承的方法
etherealize, incarnate
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantActivatorHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ServantActivatorHelper

java.lang.Object
    继承者  org.omg.PortableServer.ServantActivatorHelper

public abstract class ServantActivatorHelper
extends Object

POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

构造方法摘要
ServantActivatorHelper()
方法摘要
static ServantActivator | extract(Any a)
static String | id()
static void | insert(Any a, ServantActivator that)
static ServantActivator | narrow(Object obj)
static ServantActivator | read(InputStream istream)
static TypeCode | type()
static ServantActivator | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, ServantActivator value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServantActivatorHelper

public ServantActivatorHelper()
方法详细信息

insert

public static void insert(Any a,
                          ServantActivator that)

extract

public static ServantActivator extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServantActivator read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServantActivator value)

narrow

public static ServantActivator narrow(Object obj)

unchecked_narrow

public static ServantActivator unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantActivatorOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ServantActivatorOperations

所有超级接口：
ServantManagerOperations
所有已知子接口：
ServantActivator
所有已知实现类：
_ServantActivatorStub, ServantActivatorPOA
public interface ServantActivatorOperations
extends ServantManagerOperations

POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

方法摘要
void | etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要取消激活对象的 servant 就会调用此操作。
Servant | incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。

方法详细信息

incarnate

Servant incarnate(byte[] oid,
                  POA adapter)
                  throws ForwardRequest
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。

参数：
oid - 关联所请求对象的对象 Id。
adapter - 将激活对象的 POA 的对象引用。
返回：
创建的对应于 oid 的 Servant，或者提供 servant 管理器的用户所定位的 Servant。
抛出：
ForwardRequest - 指示 ORB 负责将当前请求和后续请求传递给异常的向前引用 (forward_reference) 成员所表示的对象。

etherealize

void etherealize(byte[] oid,
                 POA adapter,
                 Servant serv,
                 boolean cleanup_in_progress,
                 boolean remaining_activations)
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要取消激活对象的 servant 就会调用此操作。

参数：
oid - 关联将被停用的对象的对象 Id。
adapter - 已激活对象的 POA 的对象引用。
serv - 包含对关联将停用的 servant 的引用。
cleanup_in_progress - 为 TRUE 指示在 etherealize_objects 参数为 TRUE 的情况下调用该销毁或停用操作。FALSE 指示由于其他原因调用 etherealize。
remaining_activations - 指示 Servant 管理器是否可以销毁 servant。如果设置为 TRUE，则 Servant 管理器应该等待所有进行中的调用全部完成。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantActivatorPOA (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ServantActivatorPOA

java.lang.Object
    继承者  org.omg.PortableServer.Servant
        继承者  org.omg.PortableServer.ServantActivatorPOA
所有已实现的接口：
InvokeHandler, ServantActivatorOperations, ServantManagerOperations
public abstract class ServantActivatorPOA
extends Servant
implements ServantActivatorOperations, InvokeHandler

POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

构造方法摘要
ServantActivatorPOA()
方法摘要
String[] | _all_interfaces(POA poa, byte[] objectId) ORB 使用此操作从 servant 获取完整的类型信息。
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) 由 ORB 调用来调度对 servant 的请求。
ServantActivator | _this()
ServantActivator | _this(ORB orb)
从类 org.omg.PortableServer.Servant 继承的方法
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.omg.PortableServer.ServantActivatorOperations 继承的方法
etherealize, incarnate

构造方法详细信息

ServantActivatorPOA

public ServantActivatorPOA()
方法详细信息

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
从接口 InvokeHandler 复制的描述
由 ORB 调用来调度对 servant 的请求。 ORB 传递方法名称、包含编组参数的 InputStream，以及 servant 用来构造恰当应答的 ResponseHandler。 此方法只可能抛出 CORBA SystemException。 该方法必须返回包含已编组应答的 ResponseHandler 所创建的 OutputStream。 在方法调用的生存期外，servant 必须仍然保留一个对 ResponseHandler 的引用。 Servant 的行为定义如下：

1. 确定正确的方法和 InputStream 中的已解组参数。

2. 调用方法实现。

3. 如果没有任何用户异常，则使用 ResponseHandler 创建一个正常应答。

4. 如果发生用户异常，则使用 ResponseHandler 创建异常。

5. ResponseHandler 将编组应答返回到 OutputStream。

6. 将 OutputStream 返回到 ORB。

指定者：
接口 InvokeHandler 中的 _invoke
参数：
$method - 方法名称。
in - 包含已编组参数的 InputStream。
$rh - servant 用来构造正确应答的 ResponseHandler。
返回：
包含已编组应答的 ResponseHandler 所创建的 OutputStream。

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
从类 Servant 复制的描述
ORB 使用此操作从 servant 获取完整的类型信息。

指定者：
类 Servant 中的 _all_interfaces
参数：
poa - 与 servant 关联的 POA。
objectId - 对应于与此 servant 关联的对象的 id。
返回：
对象类型信息列表。

_this

public ServantActivator _this()

_this

public ServantActivator _this(ORB orb)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantLocator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ServantLocator

所有超级接口：
IDLEntity, Object, Serializable, ServantLocatorOperations, ServantManager, ServantManagerOperations
所有已知实现类：
_ServantLocatorStub
public interface ServantLocator
extends ServantLocatorOperations, ServantManager, IDLEntity

当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。因为 POA 了解此 servant 管理器返回的 servant 只用于单个请求，所以它可以向 servant 管理器的操作提供额外的信息，从而一对该 servant 管理器的操作也许能共同执行某些不同于 ServantActivator 的操作。POA 使用 ServantLocator 接口时，对 preinvoke 返回的 servant 调用该操作后，POA 将立即对 servant 管理器调用 postinvoke，同时将 ObjectId 值和 Servant 值（及其他值）作为参数传递。servant 管理器可以使用这一功能来强制调停每个对关联 POA 的对象的请求。

方法摘要
从接口 org.omg.PortableServer.ServantLocatorOperations 继承的方法
postinvoke, preinvoke
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantLocatorHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ServantLocatorHelper

java.lang.Object
    继承者  org.omg.PortableServer.ServantLocatorHelper

public abstract class ServantLocatorHelper
extends Object

POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。因为 POA 了解此 servant 管理器返回的 servant 只用于单个请求，所以它可以向 servant 管理器的操作提供额外的信息，从而一对该 servant 管理器的操作也许能共同执行某些不同于 ServantActivator 的操作。POA 使用 ServantLocator 接口时，对 preinvoke 返回的 servant 调用该操作后，POA 将立即对 servant 管理器调用 postinvoke，同时将 ObjectId 值和 Servant 值（及其他值）作为参数传递。servant 管理器可以使用这一功能来强制调停每个对关联 POA 的对象的请求。

构造方法摘要
ServantLocatorHelper()
方法摘要
static ServantLocator | extract(Any a)
static String | id()
static void | insert(Any a, ServantLocator that)
static ServantLocator | narrow(Object obj)
static ServantLocator | read(InputStream istream)
static TypeCode | type()
static ServantLocator | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, ServantLocator value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServantLocatorHelper

public ServantLocatorHelper()
方法详细信息

insert

public static void insert(Any a,
                          ServantLocator that)

extract

public static ServantLocator extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServantLocator read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServantLocator value)

narrow

public static ServantLocator narrow(Object obj)

unchecked_narrow

public static ServantLocator unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantLocatorOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ServantLocatorOperations

所有超级接口：
ServantManagerOperations
所有已知子接口：
ServantLocator
所有已知实现类：
_ServantLocatorStub, ServantLocatorPOA
public interface ServantLocatorOperations
extends ServantManagerOperations

当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。因为 POA 了解此 servant 管理器返回的 servant 只用于单个请求，所以它可以向 servant 管理器的操作提供额外的信息，从而一对该 servant 管理器的操作也许能共同执行某些不同于 ServantActivator 的操作。POA 使用 ServantLocator 接口时，对 preinvoke 返回的 servant 调用该操作后，POA 将立即对 servant 管理器调用 postinvoke，同时将 ObjectId 值和 Servant 值（及其他值）作为参数传递。servant 管理器可以使用这一功能来强制调停每个对关联 POA 的对象的请求。

方法摘要
void | postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
Servant | preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。

方法详细信息

preinvoke

Servant preinvoke(byte[] oid,
                  POA adapter,
                  String operation,
                  CookieHolder the_cookie)
                  throws ForwardRequest
此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。

参数：
oid - 关联所请求对象的对象 Id。
adapter - 将激活对象的 POA 的引用。
operation - 操作名称。
the_cookie - 一个不透明值，可由调用 postinvoke 期间使用的 servant 管理器设置。
返回：
用来处理传入请求的 Servant。
抛出：
ForwardRequest - 指示 ORB 负责将当前请求和后续请求传递给异常的向前引用 (forward_reference) 成员所表示的对象。

postinvoke

void postinvoke(byte[] oid,
                POA adapter,
                String operation,
                Object the_cookie,
                Servant the_servant)
servant 完成请求时都将调用此操作。

参数：
oid - 关联所请求对象的对象 Id。
adapter - 已激活对象的 POA 的引用。
the_cookie - 一个包含 preinvoke 设置的数据的透明值。
the_servant - 对关联对象的 servant 的引用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantLocatorPOA (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ServantLocatorPOA

java.lang.Object
    继承者  org.omg.PortableServer.Servant
        继承者  org.omg.PortableServer.ServantLocatorPOA
所有已实现的接口：
InvokeHandler, ServantLocatorOperations, ServantManagerOperations
public abstract class ServantLocatorPOA
extends Servant
implements ServantLocatorOperations, InvokeHandler

POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。因为 POA 了解此 servant 管理器返回的 servant 只用于单个请求，所以它可以向 servant 管理器的操作提供额外的信息，从而一对该 servant 管理器的操作也许能共同执行某些不同于 ServantActivator 的操作。POA 使用 ServantLocator 接口时，对 preinvoke 返回的 servant 调用该操作后，POA 将立即对 servant 管理器调用 postinvoke，同时将 ObjectId 值和 Servant 值（及其他值）作为参数传递。servant 管理器可以使用这一功能来强制调停每个对关联 POA 的对象的请求。

构造方法摘要
ServantLocatorPOA()
方法摘要
String[] | _all_interfaces(POA poa, byte[] objectId) ORB 使用此操作从 servant 获取完整的类型信息。
OutputStream | _invoke(String $method, InputStream in, ResponseHandler $rh) 由 ORB 调用来调度对 servant 的请求。
ServantLocator | _this()
ServantLocator | _this(ORB orb)
从类 org.omg.PortableServer.Servant 继承的方法
_default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.omg.PortableServer.ServantLocatorOperations 继承的方法
postinvoke, preinvoke

构造方法详细信息

ServantLocatorPOA

public ServantLocatorPOA()
方法详细信息

_invoke

public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
从接口 InvokeHandler 复制的描述
由 ORB 调用来调度对 servant 的请求。 ORB 传递方法名称、包含编组参数的 InputStream，以及 servant 用来构造恰当应答的 ResponseHandler。 此方法只可能抛出 CORBA SystemException。 该方法必须返回包含已编组应答的 ResponseHandler 所创建的 OutputStream。 在方法调用的生存期外，servant 必须仍然保留一个对 ResponseHandler 的引用。 Servant 的行为定义如下：

1. 确定正确的方法和 InputStream 中的已解组参数。

2. 调用方法实现。

3. 如果没有任何用户异常，则使用 ResponseHandler 创建一个正常应答。

4. 如果发生用户异常，则使用 ResponseHandler 创建异常。

5. ResponseHandler 将编组应答返回到 OutputStream。

6. 将 OutputStream 返回到 ORB。

指定者：
接口 InvokeHandler 中的 _invoke
参数：
$method - 方法名称。
in - 包含已编组参数的 InputStream。
$rh - servant 用来构造正确应答的 ResponseHandler。
返回：
包含已编组应答的 ResponseHandler 所创建的 OutputStream。

_all_interfaces

public String[] _all_interfaces(POA poa,
                                byte[] objectId)
从类 Servant 复制的描述
ORB 使用此操作从 servant 获取完整的类型信息。

指定者：
类 Servant 中的 _all_interfaces
参数：
poa - 与 servant 关联的 POA。
objectId - 对应于与此 servant 关联的对象的 id。
返回：
对象类型信息列表。

_this

public ServantLocator _this()

_this

public ServantLocator _this(ORB orb)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantManager (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ServantManager

所有超级接口：
IDLEntity, Object, Serializable, ServantManagerOperations
所有已知子接口：
ServantActivator, ServantLocator
所有已知实现类：
_ServantActivatorStub, _ServantLocatorStub
public interface ServantManager
extends ServantManagerOperations, Object, IDLEntity

servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。servant 管理器在 POA 中注册为一个回调对象，以供 POA 在需要时调用。ServantManager 可以是 ServantActivator，也可以是 ServantLocator。对于它所注册的 POA 对象，ServantManager 对象必须是本地的。

方法摘要
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantManagerOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ServantManagerOperations

所有已知子接口：
ServantActivator, ServantActivatorOperations, ServantLocator, ServantLocatorOperations, ServantManager
所有已知实现类：
_ServantActivatorStub, _ServantLocatorStub, ServantActivatorPOA, ServantLocatorPOA
public interface ServantManagerOperations

servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。servant 管理器在 POA 中注册为一个回调对象，以供 POA 在需要时调用。ServantManager 可以是 ServantActivator，也可以是 ServantLocator。对于它所注册的 POA 对象，ServantManager 对象必须是本地的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantRetentionPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ServantRetentionPolicy

所有超级接口：
IDLEntity, Object, Policy, PolicyOperations, Serializable, ServantRetentionPolicyOperations
public interface ServantRetentionPolicy
extends ServantRetentionPolicyOperations, Policy, IDLEntity

此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。

方法摘要
从接口 org.omg.PortableServer.ServantRetentionPolicyOperations 继承的方法
value
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantRetentionPolicyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ServantRetentionPolicyOperations

所有超级接口：
PolicyOperations
所有已知子接口：
ServantRetentionPolicy
public interface ServantRetentionPolicyOperations
extends PolicyOperations

此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。

方法摘要
 ServantRetentionPolicyValue value()
指示策略值
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type

方法详细信息

value

ServantRetentionPolicyValue value()
指示策略值

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantRetentionPolicyValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ServantRetentionPolicyValue

java.lang.Object
    继承者  org.omg.PortableServer.ServantRetentionPolicyValue
所有已实现的接口：
Serializable, IDLEntity
public class ServantRetentionPolicyValue
extends Object
implements IDLEntity

ServantRetentionPolicyValue 可以具有以下值。RETAIN - 指示 POA 将在其 Active Object Map 中保留激活的 servant。NON_RETAIN - 指示 POA 不保留 Servant。如果创建 POA 时没有指定 ServantRetentionPolicy，则默认为 RETAIN。

字段摘要
static int | _NON_RETAIN
static int | _RETAIN
static ServantRetentionPolicyValue | NON_RETAIN
static ServantRetentionPolicyValue | RETAIN
构造方法摘要
protected ServantRetentionPolicyValue(int value)
方法摘要
static ServantRetentionPolicyValue | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_RETAIN

public static final int _RETAIN
另请参见：
常量字段值

RETAIN

public static final ServantRetentionPolicyValue RETAIN

_NON_RETAIN

public static final int _NON_RETAIN
另请参见：
常量字段值

NON_RETAIN

public static final ServantRetentionPolicyValue NON_RETAIN
构造方法详细信息

ServantRetentionPolicyValue

protected ServantRetentionPolicyValue(int value)
方法详细信息

value

public int value()

from_int

public static ServantRetentionPolicyValue from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


THREAD_POLICY_ID (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 THREAD_POLICY_ID

public interface THREAD_POLICY_ID

org/omg/PortableServer/THREAD_POLICY_ID.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
static int value
表示 THREAD_POLICY_ID 的值。

字段详细信息

value

static final int value
表示 THREAD_POLICY_ID 的值。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ThreadPolicy

所有超级接口：
IDLEntity, Object, Policy, PolicyOperations, Serializable, ThreadPolicyOperations
public interface ThreadPolicy
extends ThreadPolicyOperations, Policy, IDLEntity

ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。默认值为 ORB_CTRL_MODEL。

方法摘要
从接口 org.omg.PortableServer.ThreadPolicyOperations 继承的方法
value
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPolicyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
接口 ThreadPolicyOperations

所有超级接口：
PolicyOperations
所有已知子接口：
ThreadPolicy
public interface ThreadPolicyOperations
extends PolicyOperations

ThreadPolicy 指定与已创建的 POA 一起使用的线程模型 (threading model)。默认值为 ORB_CTRL_MODEL。

方法摘要
 ThreadPolicyValue value()
指定策略值
从接口 org.omg.CORBA.PolicyOperations 继承的方法
copy, destroy, policy_type

方法详细信息

value

ThreadPolicyValue value()
指定策略值

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPolicyValue (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer
类 ThreadPolicyValue

java.lang.Object
    继承者  org.omg.PortableServer.ThreadPolicyValue
所有已实现的接口：
Serializable, IDLEntity
public class ThreadPolicyValue
extends Object
implements IDLEntity

ThreadPolicyValue 可以具有以下值。ORB_CTRL_MODEL - ORB 负责向线程分配对 ORB 控制的 POA 的请求。SINGLE_THREAD_MODEL - 按顺序处理对单线程 POA 的请求。

字段摘要
static int | _ORB_CTRL_MODEL
static int | _SINGLE_THREAD_MODEL
static ThreadPolicyValue | ORB_CTRL_MODEL
static ThreadPolicyValue | SINGLE_THREAD_MODEL
构造方法摘要
protected ThreadPolicyValue(int value)
方法摘要
static ThreadPolicyValue | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_ORB_CTRL_MODEL

public static final int _ORB_CTRL_MODEL
另请参见：
常量字段值

ORB_CTRL_MODEL

public static final ThreadPolicyValue ORB_CTRL_MODEL

_SINGLE_THREAD_MODEL

public static final int _SINGLE_THREAD_MODEL
另请参见：
常量字段值

SINGLE_THREAD_MODEL

public static final ThreadPolicyValue SINGLE_THREAD_MODEL
构造方法详细信息

ThreadPolicyValue

protected ThreadPolicyValue(int value)
方法详细信息

value

public int value()

from_int

public static ThreadPolicyValue from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.PortableServer (Java Platform SE 6)

 org.omg.PortableServer
接口
AdapterActivator
AdapterActivatorOperations
Current
CurrentOperations
ID_ASSIGNMENT_POLICY_ID
ID_UNIQUENESS_POLICY_ID
IdAssignmentPolicy
IdAssignmentPolicyOperations
IdUniquenessPolicy
IdUniquenessPolicyOperations
IMPLICIT_ACTIVATION_POLICY_ID
ImplicitActivationPolicy
ImplicitActivationPolicyOperations
LIFESPAN_POLICY_ID
LifespanPolicy
LifespanPolicyOperations
POA
POAManager
POAManagerOperations
POAOperations
REQUEST_PROCESSING_POLICY_ID
RequestProcessingPolicy
RequestProcessingPolicyOperations
SERVANT_RETENTION_POLICY_ID
ServantActivator
ServantActivatorOperations
ServantLocator
ServantLocatorOperations
ServantManager
ServantManagerOperations
ServantRetentionPolicy
ServantRetentionPolicyOperations
THREAD_POLICY_ID
ThreadPolicy
ThreadPolicyOperations
类
_ServantActivatorStub
_ServantLocatorStub
CurrentHelper
DynamicImplementation
ForwardRequestHelper
IdAssignmentPolicyValue
IdUniquenessPolicyValue
ImplicitActivationPolicyValue
LifespanPolicyValue
POAHelper
RequestProcessingPolicyValue
Servant
ServantActivatorHelper
ServantActivatorPOA
ServantLocatorHelper
ServantLocatorPOA
ServantRetentionPolicyValue
ThreadPolicyValue
异常
ForwardRequest


org.omg.PortableServer (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.PortableServer

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

请参见：
描述

接口摘要
AdapterActivator | 一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
AdapterActivatorOperations | 一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
Current | 从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。
CurrentOperations | 从 CORBA::Current 中派生的 PortableServer::Current 接口，它提供一些能够访问调用方法的对象身份的方法实现。
ID_ASSIGNMENT_POLICY_ID | org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java。
ID_UNIQUENESS_POLICY_ID | org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java。
IdAssignmentPolicy | IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
IdAssignmentPolicyOperations | IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
IdUniquenessPolicy | IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
IdUniquenessPolicyOperations | IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
IMPLICIT_ACTIVATION_POLICY_ID | org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java。
ImplicitActivationPolicy | 此策略指定已创建的 POA 中是否支持隐式激活 servant。
ImplicitActivationPolicyOperations | 此策略指定已创建的 POA 中是否支持隐式激活 servant。
LIFESPAN_POLICY_ID | org/omg/PortableServer/LIFESPAN_POLICY_ID.java。
LifespanPolicy | LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
LifespanPolicyOperations | LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
POA | POA 对象管理对象集合的实现。
POAManager | 每个 POA 对象都有一个关联的 POAManager 对象。
POAManagerOperations | 每个 POA 对象具有一个关联的 POAManager 对象。
POAOperations | POA 对象管理对象集合的实现。
REQUEST_PROCESSING_POLICY_ID | org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java。
RequestProcessingPolicy | 此策略指定已创建的 POA 处理请求的方式。
RequestProcessingPolicyOperations | 此策略指定已创建的 POA 处理请求的方式。
SERVANT_RETENTION_POLICY_ID | org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java。
ServantActivator | POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorOperations | POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantLocator | 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
ServantLocatorOperations | 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
ServantManager | servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
ServantManagerOperations | servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
ServantRetentionPolicy | 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
ServantRetentionPolicyOperations | 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
THREAD_POLICY_ID | org/omg/PortableServer/THREAD_POLICY_ID.java。
ThreadPolicy | ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。
ThreadPolicyOperations | ThreadPolicy 指定与已创建的 POA 一起使用的线程模型 (threading model)。

类摘要
_ServantActivatorStub | 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
_ServantLocatorStub | POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
CurrentHelper | 从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。
DynamicImplementation | 允许动态处理对象调用。
ForwardRequestHelper | org/omg/PortableServer/ForwardRequestHelper.java。
IdAssignmentPolicyValue | IdAssignmentPolicyValue 可以具有以下值。
IdUniquenessPolicyValue | IdUniquenessPolicyValue 可以具有以下值。
ImplicitActivationPolicyValue | ImplicitActivationPolicyValue 具有以下语义。
LifespanPolicyValue | LifespanPolicyValue 可以具有以下值。
POAHelper | POA 对象管理对象集合的实现。
RequestProcessingPolicyValue | RequestProcessingPolicyValue 可以具有以下值。
Servant | 定义本机 Servant 类型。
ServantActivatorHelper | POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorPOA | POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantLocatorHelper | POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。
ServantLocatorPOA | POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。
ServantRetentionPolicyValue | ServantRetentionPolicyValue 可以具有以下值。
ThreadPolicyValue | ThreadPolicyValue 可以具有以下值。

异常摘要
ForwardRequest org/omg/PortableServer/ForwardRequest.java。

软件包 org.omg.PortableServer 的描述

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

在 Java 中，基于可移植对象适配器（Portable Object Adaptor，POA）的动态框架接口（Dynamic Skeleton Interface，DSI）servant 继承自标准 DynamicImplementation 类，而该类继承自 Servant 类。本机 Servant 类型由 POA 的 PortableServer 模块定义。在 Java 中，Servant 类型被映射到 Java org.omg.PortableServer.Servant 类。它充当所有 POA servant 实现的基类，提供许多可由应用程序员调用的方法，以及可由 POA 本身调用（也可由用户重写）以控制 servant 行为各方面的方法。

包规范

有关 Java[tm] Platform, Standard Edition 6 遵守的官方 OMG 规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

与 POA 相关的接口

PortableServer 模块定义以下与 POA 相关的接口：

  • POA
  • POAManager
  • ServantManager
  • ServantActivator
  • ServantLocator
  • AdapterActivator
  • ThreadPolicy
  • LifespanPolicy
  • IdUniquenessPolicy
  • IdAssignmentPolicy
  • ImplicitActivationPolicy
  • ServantRetentionPolicy
  • RequestProcessingPolicy
  • Current

此外，POA 还定义 Servant 本机类型。

操作类

上文列出的每个接口都有一个关联的 Operations 接口。Operations 接口由 idlj 编译器生成，其中包含一些方法签名，用于在与其关联的接口中定义的方法。Operations 接口可以通过客户端和服务器访问，而其关联的接口只能通过客户端调用。

值类

以后缀 PolicyValue 结尾的类提供了 create_POA 调用所使用的值，该调用可设置 POA 的策略。参见以下用来示范的样本代码。PolicyValue 文件包括以下内容：

  • IdAssignmentPolicyValue
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • LifespanPolicyValue
  • RequestProcessingPolicyValue
  • ServantRetentionPolicyValue
  • ThreadPolicyValue

Helper 类

Helper 类是为 OMG IDL 接口中所有用户定义类型生成的，提供操作这些类型所需的静态方法。Helper 类中只有一种供应用程序员使用的方法。narrow 方法。只有 IDL 接口所映射的 Java 接口才有包含 narrow 方法的 helper 类，因此在 PortableServer 包中，只有以下类才具有 narrow 方法：

  • ForwardRequestHelper
  • ServantActivatorHelper
  • ServantLocatorHelper

POA 类

POA 类用于实现 ServantActivator 或 ServantLocator。

异常

ForwardRequest 异常指示 ORB 负责将当前请求和后续 ForwardRequest 请求传递给异常的 forward_reference 成员所表示的对象。

应用程序员所实现的接口

PortableServer 执行的大部分操作对用户是透明的。因此程序员将只能使用一小部分上述接口。剩余的接口将由 ORB 实现提供。应用程序员所需的接口如下：

  • AdapterActivator

    适配器激活器与 POA 关联。适配器激活器提供具有随需创建子 POA 功能的 POA。产生这一需求可能是接受指定子 POA（或其中一个子 POA）的请求所带来的副作用，调用 find_POA 时将 activate 参数值设置为 TRUE 也需要创建子 POA。创建所有所需 POA 的应用服务器在刚开始执行时不需要使用或提供适配器激活器；只有在请求处理期间需要创建 POA 时才有必要这样做。

  • ServantLocator

    当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。

  • ServantActivator

    当 POA 具有 RETAIN 策略时，使用 ServantActivator 这种 servant 管理器。

org.omg.PortableServer.ServantLocatorPackage 包

此包提供一个 CookieHolder 类，将 Cookie 类型作为 out 参数传递。CookieHolder 类与其他基本类型的 holder 类完全一样。

相关文档

有关 Java IDL 概述，请参见：

  • Java IDL 主页。

    代码示例

    实例服务器代码

    import javax.naming.InitialContext;
import javax.naming.Context;
import javax.rmi.PortableRemoteObject ;
import com.sun.corba.se.impl.poa.POAORB;
import org.omg.PortableServer.*;
import java.util.*;
import org.omg.CORBA.*;
import javax.rmi.CORBA.Stub;
import javax.rmi.CORBA.Util;

public class HelloServer {
    public HelloServer(String[] args) {
        try {
            Properties p = System.getProperties();
         //   p.put("org.omg.CORBA.ORBClass", "com.sun.corba.ee.internal.POA.POAORB");
            ORB orb = ORB.init( args, p );

            POA rootPOA = (POA)orb.resolve_initial_references("RootPOA");

Policy[] tpolicy = new Policy[3];
            tpolicy[0] = rootPOA.create_lifespan_policy(
                LifespanPolicyValue.TRANSIENT );
            tpolicy[1] = rootPOA.create_request_processing_policy(
                RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY );
            tpolicy[2] = rootPOA.create_servant_retention_policy(
                ServantRetentionPolicyValue.RETAIN);
            POA tpoa = rootPOA.create_POA("MyTransientPOA", null, tpolicy);

            String  ObjectId = "MyObjectId";
            byte[] oid = ObjectId.getBytes();

            org.omg.CORBA.Object obj = tpoa.create_reference_with_id(oid,
                new _HelloImpl_Tie()._all_interfaces(tpoa, oid)[0]);
            HelloInterface helloRef = (HelloInterface)PortableRemoteObject.narrow(
                obj, HelloInterface.class );

            Context initialNamingContext = new InitialContext();
            initialNamingContext.rebind("HelloService", helloRef);
            System.out.println("Hello Server: Ready...");
            orb.run();
         } catch (Exception e) {
            System.out.println("Trouble:" + e);
            e.printStackTrace();
         }
     }

     public static void main(String args[]) {
         new HelloServer( args );
     }
}

    从以下版本开始：
    1.4
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM Platform
    Standard Ed. 6
    上一个软件包 下一个软件包 框架 无框架


org.omg.PortableServer 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.PortableServer.CurrentHelper
    • org.omg.PortableServer.ForwardRequestHelper
    • org.omg.PortableServer.IdAssignmentPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.IdUniquenessPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.ImplicitActivationPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.LifespanPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.PortableServer._ServantActivatorStub (implements org.omg.PortableServer.ServantActivator)
      • org.omg.PortableServer._ServantLocatorStub (implements org.omg.PortableServer.ServantLocator)
    • org.omg.PortableServer.POAHelper
    • org.omg.PortableServer.RequestProcessingPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.DynamicImplementation
      • org.omg.PortableServer.ServantActivatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantActivatorHelper
    • org.omg.PortableServer.ServantLocatorHelper
    • org.omg.PortableServer.ServantRetentionPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.ThreadPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.ForwardRequest

接口分层结构

  • org.omg.PortableServer.AdapterActivatorOperations
    • org.omg.PortableServer.AdapterActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (并 extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.CurrentOperations
      • org.omg.PortableServer.Current (并 extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
  • org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
  • org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
  • org.omg.PortableServer.LIFESPAN_POLICY_ID
  • org.omg.CORBA.Object
    • org.omg.PortableServer.AdapterActivator (并 extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (并 extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.POA (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.ServantManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • org.omg.PortableServer.POAManagerOperations
    • org.omg.PortableServer.POAManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableServer.POAOperations
    • org.omg.PortableServer.POA (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.PolicyOperations
    • org.omg.PortableServer.IdAssignmentPolicyOperations
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicyOperations
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicyOperations
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicyOperations
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.Policy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicyOperations
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ServantRetentionPolicyOperations
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ThreadPolicyOperations
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
  • org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableServer.AdapterActivator (并 extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableServer.Current (并 extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (并 extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.POA (并 extends org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
      • org.omg.PortableServer.POAManager (并 extends org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
      • org.omg.CORBA.Policy (并 extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
        • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
        • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
        • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
        • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
        • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
        • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantManager (并 extends org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
        • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
        • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
  • org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
  • org.omg.PortableServer.ServantManagerOperations
    • org.omg.PortableServer.ServantActivatorOperations
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocatorOperations
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • org.omg.PortableServer.THREAD_POLICY_ID
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.PortableServer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer
的使用

使用 org.omg.PortableServer 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CosNaming 使用的 org.omg.PortableServer 中的类
POA
POA 对象管理对象集合的实现。
Servant
定义本机 Servant 类型。

org.omg.PortableServer 使用的 org.omg.PortableServer 中的类
AdapterActivator
一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
AdapterActivatorOperations
一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
Current
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。
CurrentOperations
从 CORBA::Current 中派生的 PortableServer::Current 接口，它提供一些能够访问调用方法的对象身份的方法实现。
ForwardRequest
org/omg/PortableServer/ForwardRequest.java。
IdAssignmentPolicy
IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
IdAssignmentPolicyOperations
IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
IdAssignmentPolicyValue
IdAssignmentPolicyValue 可以具有以下值。
IdUniquenessPolicy
IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
IdUniquenessPolicyOperations
IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
IdUniquenessPolicyValue
IdUniquenessPolicyValue 可以具有以下值。
ImplicitActivationPolicy
此策略指定已创建的 POA 中是否支持隐式激活 servant。
ImplicitActivationPolicyOperations
此策略指定已创建的 POA 中是否支持隐式激活 servant。
ImplicitActivationPolicyValue
ImplicitActivationPolicyValue 具有以下语义。
LifespanPolicy
LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
LifespanPolicyOperations
LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
LifespanPolicyValue
LifespanPolicyValue 可以具有以下值。
POA
POA 对象管理对象集合的实现。
POAManager
每个 POA 对象都有一个关联的 POAManager 对象。
POAManagerOperations
每个 POA 对象具有一个关联的 POAManager 对象。
POAOperations
POA 对象管理对象集合的实现。
RequestProcessingPolicy
此策略指定已创建的 POA 处理请求的方式。
RequestProcessingPolicyOperations
此策略指定已创建的 POA 处理请求的方式。
RequestProcessingPolicyValue
RequestProcessingPolicyValue 可以具有以下值。
Servant
定义本机 Servant 类型。
ServantActivator
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorOperations
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantLocator
当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
ServantLocatorOperations
当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
ServantManager
servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
ServantManagerOperations
servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
ServantRetentionPolicy
此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
ServantRetentionPolicyOperations
此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
ServantRetentionPolicyValue
ServantRetentionPolicyValue 可以具有以下值。
ThreadPolicy
ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。
ThreadPolicyOperations
ThreadPolicy 指定与已创建的 POA 一起使用的线程模型 (threading model)。
ThreadPolicyValue
ThreadPolicyValue 可以具有以下值。

org.omg.PortableServer.portable 使用的 org.omg.PortableServer 中的类
POA
POA 对象管理对象集合的实现。
Servant
定义本机 Servant 类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


NoContext (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.CurrentPackage
类 NoContext

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.CurrentPackage.NoContext
所有已实现的接口：
Serializable, IDLEntity
public final class NoContext
extends UserException

org/omg/PortableServer/CurrentPackage/NoContext.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植））从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
NoContext()
NoContext(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoContext

public NoContext()

NoContext

public NoContext(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


NoContextHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.CurrentPackage
类 NoContextHelper

java.lang.Object
    继承者  org.omg.PortableServer.CurrentPackage.NoContextHelper

public abstract class NoContextHelper
extends Object

org/omg/PortableServer/CurrentPackage/NoContextHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
NoContextHelper()
方法摘要
static NoContext | extract(Any a)
static String | id()
static void | insert(Any a, NoContext that)
static NoContext | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NoContext value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NoContextHelper

public NoContextHelper()
方法详细信息

insert

public static void insert(Any a,
                          NoContext that)

extract

public static NoContext extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NoContext read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NoContext value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.PortableServer.CurrentPackage (Java Platform SE 6)

 org.omg.PortableServer.CurrentPackage
类
NoContextHelper
异常
NoContext


org.omg.PortableServer.CurrentPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.PortableServer.CurrentPackage

提供各种方法实现，这些实现能够访问调用方法的对象的身份。

请参见：
描述

类摘要
NoContextHelper org/omg/PortableServer/CurrentPackage/NoContextHelper.java。

异常摘要
NoContext org/omg/PortableServer/CurrentPackage/NoContext.java。

软件包 org.omg.PortableServer.CurrentPackage 的描述

提供各种方法实现，这些实现能够访问调用方法的对象的身份。Current 包支持 servant 实现多个对象，但可以在任意 servant 上 POA 指派的方法调用的上下文中使用。如果要提供位置透明性，则 ORB 必须支持在本地和远程调用操作的上下文中都使用 Current。通过进行 CORBA::ORB::resolve_initial_references("POACurrent") 操作，应用程序可获取 Current 的实例。此后，它便可以在 POA 指派的方法的上下文中使用，以获取标识调用操作的对象的 POA 和 ObjectId。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.PortableServer.CurrentPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.CurrentPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.PortableServer.CurrentPackage.NoContextHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.CurrentPackage.NoContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.PortableServer.CurrentPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.CurrentPackage
的使用

使用 org.omg.PortableServer.CurrentPackage 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。

org.omg.PortableServer 使用的 org.omg.PortableServer.CurrentPackage 中的类
NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.CurrentPackage 使用的 org.omg.PortableServer.CurrentPackage 中的类
NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.CurrentPackage.NoContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.CurrentPackage.NoContext
的使用

使用 NoContext 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。

org.omg.PortableServer 中 NoContext 的使用

抛出 NoContext 的 org.omg.PortableServer 中的方法
byte[] | CurrentOperations.get_object_id() 返回一个 ObjectId，标识此方法在其上下文中调用的对象。
POA | CurrentOperations.get_POA() 返回对 POA 的引用，该 POA 实现此方法在其上下文中调用的对象。

org.omg.PortableServer.CurrentPackage 中 NoContext 的使用

返回 NoContext 的 org.omg.PortableServer.CurrentPackage 中的方法
static NoContext | NoContextHelper.extract(Any a)
static NoContext | NoContextHelper.read(InputStream istream)

参数类型为 NoContext 的 org.omg.PortableServer.CurrentPackage 中的方法
static void | NoContextHelper.insert(Any a, NoContext that)
static void | NoContextHelper.write(OutputStream ostream, NoContext value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.CurrentPackage.NoContextHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.CurrentPackage.NoContextHelper
的使用

没有 org.omg.PortableServer.CurrentPackage.NoContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AdapterAlreadyExists (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 AdapterAlreadyExists

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.AdapterAlreadyExists
所有已实现的接口：
Serializable, IDLEntity
public final class AdapterAlreadyExists
extends UserException

org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
AdapterAlreadyExists()
AdapterAlreadyExists(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AdapterAlreadyExists

public AdapterAlreadyExists()

AdapterAlreadyExists

public AdapterAlreadyExists(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AdapterAlreadyExistsHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 AdapterAlreadyExistsHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

public abstract class AdapterAlreadyExistsHelper
extends Object

org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植））从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
AdapterAlreadyExistsHelper()
方法摘要
static AdapterAlreadyExists | extract(Any a)
static String | id()
static void | insert(Any a, AdapterAlreadyExists that)
static AdapterAlreadyExists | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, AdapterAlreadyExists value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdapterAlreadyExistsHelper

public AdapterAlreadyExistsHelper()
方法详细信息

insert

public static void insert(Any a,
                          AdapterAlreadyExists that)

extract

public static AdapterAlreadyExists extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static AdapterAlreadyExists read(InputStream istream)

write

public static void write(OutputStream ostream,
                         AdapterAlreadyExists value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AdapterNonExistent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 AdapterNonExistent

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.AdapterNonExistent
所有已实现的接口：
Serializable, IDLEntity
public final class AdapterNonExistent
extends UserException

org/omg/PortableServer/POAPackage/AdapterNonExistent.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
AdapterNonExistent()
AdapterNonExistent(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AdapterNonExistent

public AdapterNonExistent()

AdapterNonExistent

public AdapterNonExistent(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AdapterNonExistentHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 AdapterNonExistentHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

public abstract class AdapterNonExistentHelper
extends Object

org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
AdapterNonExistentHelper()
方法摘要
static AdapterNonExistent | extract(Any a)
static String | id()
static void | insert(Any a, AdapterNonExistent that)
static AdapterNonExistent | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, AdapterNonExistent value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdapterNonExistentHelper

public AdapterNonExistentHelper()
方法详细信息

insert

public static void insert(Any a,
                          AdapterNonExistent that)

extract

public static AdapterNonExistent extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static AdapterNonExistent read(InputStream istream)

write

public static void write(OutputStream ostream,
                         AdapterNonExistent value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 InvalidPolicy

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.InvalidPolicy
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidPolicy
extends UserException

org/omg/PortableServer/POAPackage/InvalidPolicy.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

字段摘要
 short index
构造方法摘要
InvalidPolicy()
InvalidPolicy(short _index)
InvalidPolicy(String $reason, short _index)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

index

public short index
构造方法详细信息

InvalidPolicy

public InvalidPolicy()

InvalidPolicy

public InvalidPolicy(short _index)

InvalidPolicy

public InvalidPolicy(String $reason,
                     short _index)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidPolicyHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 InvalidPolicyHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.InvalidPolicyHelper

public abstract class InvalidPolicyHelper
extends Object

org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
InvalidPolicyHelper()
方法摘要
static InvalidPolicy | extract(Any a)
static String | id()
static void | insert(Any a, InvalidPolicy that)
static InvalidPolicy | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidPolicy value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InvalidPolicyHelper

public InvalidPolicyHelper()
方法详细信息

insert

public static void insert(Any a,
                          InvalidPolicy that)

extract

public static InvalidPolicy extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidPolicy read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidPolicy value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoServant (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 NoServant

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.NoServant
所有已实现的接口：
Serializable, IDLEntity
public final class NoServant
extends UserException

org/omg/PortableServer/POAPackage/NoServant.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
NoServant()
NoServant(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoServant

public NoServant()

NoServant

public NoServant(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoServantHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 NoServantHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.NoServantHelper

public abstract class NoServantHelper
extends Object

org/omg/PortableServer/POAPackage/NoServantHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
NoServantHelper()
方法摘要
static NoServant | extract(Any a)
static String | id()
static void | insert(Any a, NoServant that)
static NoServant | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NoServant value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NoServantHelper

public NoServantHelper()
方法详细信息

insert

public static void insert(Any a,
                          NoServant that)

extract

public static NoServant extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NoServant read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NoServant value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectAlreadyActive (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 ObjectAlreadyActive

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.ObjectAlreadyActive
所有已实现的接口：
Serializable, IDLEntity
public final class ObjectAlreadyActive
extends UserException

org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ObjectAlreadyActive()
ObjectAlreadyActive(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ObjectAlreadyActive

public ObjectAlreadyActive()

ObjectAlreadyActive

public ObjectAlreadyActive(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectAlreadyActiveHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 ObjectAlreadyActiveHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

public abstract class ObjectAlreadyActiveHelper
extends Object

org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ObjectAlreadyActiveHelper()
方法摘要
static ObjectAlreadyActive | extract(Any a)
static String | id()
static void | insert(Any a, ObjectAlreadyActive that)
static ObjectAlreadyActive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectAlreadyActive value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectAlreadyActiveHelper

public ObjectAlreadyActiveHelper()
方法详细信息

insert

public static void insert(Any a,
                          ObjectAlreadyActive that)

extract

public static ObjectAlreadyActive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectAlreadyActive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectAlreadyActive value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectNotActive (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 ObjectNotActive

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.ObjectNotActive
所有已实现的接口：
Serializable, IDLEntity
public final class ObjectNotActive
extends UserException

org/omg/PortableServer/POAPackage/ObjectNotActive.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ObjectNotActive()
ObjectNotActive(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ObjectNotActive

public ObjectNotActive()

ObjectNotActive

public ObjectNotActive(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectNotActiveHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 ObjectNotActiveHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

public abstract class ObjectNotActiveHelper
extends Object

org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ObjectNotActiveHelper()
方法摘要
static ObjectNotActive | extract(Any a)
static String | id()
static void | insert(Any a, ObjectNotActive that)
static ObjectNotActive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectNotActive value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectNotActiveHelper

public ObjectNotActiveHelper()
方法详细信息

insert

public static void insert(Any a,
                          ObjectNotActive that)

extract

public static ObjectNotActive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectNotActive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectNotActive value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantAlreadyActive (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 ServantAlreadyActive

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.ServantAlreadyActive
所有已实现的接口：
Serializable, IDLEntity
public final class ServantAlreadyActive
extends UserException

org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ServantAlreadyActive()
ServantAlreadyActive(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServantAlreadyActive

public ServantAlreadyActive()

ServantAlreadyActive

public ServantAlreadyActive(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantAlreadyActiveHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 ServantAlreadyActiveHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

public abstract class ServantAlreadyActiveHelper
extends Object

org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ServantAlreadyActiveHelper()
方法摘要
static ServantAlreadyActive | extract(Any a)
static String | id()
static void | insert(Any a, ServantAlreadyActive that)
static ServantAlreadyActive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ServantAlreadyActive value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServantAlreadyActiveHelper

public ServantAlreadyActiveHelper()
方法详细信息

insert

public static void insert(Any a,
                          ServantAlreadyActive that)

extract

public static ServantAlreadyActive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServantAlreadyActive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServantAlreadyActive value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantNotActive (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 ServantNotActive

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.ServantNotActive
所有已实现的接口：
Serializable, IDLEntity
public final class ServantNotActive
extends UserException

org/omg/PortableServer/POAPackage/ServantNotActive.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ServantNotActive()
ServantNotActive(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServantNotActive

public ServantNotActive()

ServantNotActive

public ServantNotActive(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServantNotActiveHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 ServantNotActiveHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.ServantNotActiveHelper

public abstract class ServantNotActiveHelper
extends Object

org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
ServantNotActiveHelper()
方法摘要
static ServantNotActive | extract(Any a)
static String | id()
static void | insert(Any a, ServantNotActive that)
static ServantNotActive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ServantNotActive value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServantNotActiveHelper

public ServantNotActiveHelper()
方法详细信息

insert

public static void insert(Any a,
                          ServantNotActive that)

extract

public static ServantNotActive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServantNotActive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServantNotActive value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WrongAdapter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 WrongAdapter

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.WrongAdapter
所有已实现的接口：
Serializable, IDLEntity
public final class WrongAdapter
extends UserException

org/omg/PortableServer/POAPackage/WrongAdapter.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
WrongAdapter()
WrongAdapter(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

WrongAdapter

public WrongAdapter()

WrongAdapter

public WrongAdapter(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WrongAdapterHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 WrongAdapterHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.WrongAdapterHelper

public abstract class WrongAdapterHelper
extends Object

org/omg/PortableServer/POAPackage/WrongAdapterHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
WrongAdapterHelper()
方法摘要
static WrongAdapter | extract(Any a)
static String | id()
static void | insert(Any a, WrongAdapter that)
static WrongAdapter | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, WrongAdapter value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WrongAdapterHelper

public WrongAdapterHelper()
方法详细信息

insert

public static void insert(Any a,
                          WrongAdapter that)

extract

public static WrongAdapter extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static WrongAdapter read(InputStream istream)

write

public static void write(OutputStream ostream,
                         WrongAdapter value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WrongPolicy (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 WrongPolicy

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAPackage.WrongPolicy
所有已实现的接口：
Serializable, IDLEntity
public final class WrongPolicy
extends UserException

org/omg/PortableServer/POAPackage/WrongPolicy.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
WrongPolicy()
WrongPolicy(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

WrongPolicy

public WrongPolicy()

WrongPolicy

public WrongPolicy(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WrongPolicyHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAPackage
类 WrongPolicyHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAPackage.WrongPolicyHelper

public abstract class WrongPolicyHelper
extends Object

org/omg/PortableServer/POAPackage/WrongPolicyHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
WrongPolicyHelper()
方法摘要
static WrongPolicy | extract(Any a)
static String | id()
static void | insert(Any a, WrongPolicy that)
static WrongPolicy | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, WrongPolicy value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WrongPolicyHelper

public WrongPolicyHelper()
方法详细信息

insert

public static void insert(Any a,
                          WrongPolicy that)

extract

public static WrongPolicy extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static WrongPolicy read(InputStream istream)

write

public static void write(OutputStream ostream,
                         WrongPolicy value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.PortableServer.POAPackage (Java Platform SE 6)

 org.omg.PortableServer.POAPackage
类
AdapterAlreadyExistsHelper
AdapterNonExistentHelper
InvalidPolicyHelper
NoServantHelper
ObjectAlreadyActiveHelper
ObjectNotActiveHelper
ServantAlreadyActiveHelper
ServantNotActiveHelper
WrongAdapterHelper
WrongPolicyHelper
异常
AdapterAlreadyExists
AdapterNonExistent
InvalidPolicy
NoServant
ObjectAlreadyActive
ObjectNotActive
ServantAlreadyActive
ServantNotActive
WrongAdapter
WrongPolicy


org.omg.PortableServer.POAPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.PortableServer.POAPackage

允许程序员构造可在不同 ORB 产品间移植的对象实现。

请参见：
描述

类摘要
AdapterAlreadyExistsHelper | org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java。
AdapterNonExistentHelper | org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java。
InvalidPolicyHelper | org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java。
NoServantHelper | org/omg/PortableServer/POAPackage/NoServantHelper.java。
ObjectAlreadyActiveHelper | org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java。
ObjectNotActiveHelper | org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java。
ServantAlreadyActiveHelper | org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java。
ServantNotActiveHelper | org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java。
WrongAdapterHelper | org/omg/PortableServer/POAPackage/WrongAdapterHelper.java。
WrongPolicyHelper | org/omg/PortableServer/POAPackage/WrongPolicyHelper.java。

异常摘要
AdapterAlreadyExists | org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
AdapterNonExistent | org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
InvalidPolicy | org/omg/PortableServer/POAPackage/InvalidPolicy.java。
NoServant | org/omg/PortableServer/POAPackage/NoServant.java。
ObjectAlreadyActive | org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
ObjectNotActive | org/omg/PortableServer/POAPackage/ObjectNotActive.java。
ServantAlreadyActive | org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
ServantNotActive | org/omg/PortableServer/POAPackage/ServantNotActive.java。
WrongAdapter | org/omg/PortableServer/POAPackage/WrongAdapter.java。
WrongPolicy | org/omg/PortableServer/POAPackage/WrongPolicy.java。

软件包 org.omg.PortableServer.POAPackage 的描述

允许程序员构造可在不同 ORB 产品间移植的对象实现。

可移植对象适配器（Portable Object Adaptor，POA）是为达到以下目的而设计的：

  • 允许程序员构造可在不同 ORB 产品间移植的对象实现。
  • 为具有持久身份的对象提供支持。
  • 为对象的透明活动提供支持。
  • 允许单个 servant 同时支持多个对象身份。

如果给定 My.idl 中定义的接口 My，则 idlj 编译器将生成文件 MyPOA.java。必须提供 My 的实现，并且该实现必须继承 MyPOA。

MyPOA.java 是一个基于流的框架，它扩展了 org.omg.PortableServer.Servant，实现了 InvokeHandler 接口以及与该框架实现的 IDL 接口关联的操作接口。

可移植对象适配器 (POA) 的 PortableServer 模块定义本机 Servant 类型。在 Java 编程语言中，Servant 类型被映射为 Java org.omg.PortableServer.Servant 类。它充当所有 POA servant 实现的基类，提供许多可由应用程序员调用的方法，以及可由 POA 本身调用（也可由用户重写）以控制 servant 行为各方面的方法。

所有的映射对应于 OMG 文档 formal/99-10-07.pdf 指定的 CORBA V2.3.1 第 11 章。唯一例外的是 id 属性，它被添加到 ptc/00-08-06 的第 11.3.8.26 小节中。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.PortableServer.POAPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.POAPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper
    • org.omg.PortableServer.POAPackage.NoServantHelper
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
          • org.omg.PortableServer.POAPackage.InvalidPolicy
          • org.omg.PortableServer.POAPackage.NoServant
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
          • org.omg.PortableServer.POAPackage.ObjectNotActive
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
          • org.omg.PortableServer.POAPackage.ServantNotActive
          • org.omg.PortableServer.POAPackage.WrongAdapter
          • org.omg.PortableServer.POAPackage.WrongPolicy
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.PortableServer.POAPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.POAPackage
的使用

使用 org.omg.PortableServer.POAPackage 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 使用的 org.omg.PortableServer.POAPackage 中的类
AdapterAlreadyExists
org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
AdapterNonExistent
org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
InvalidPolicy
org/omg/PortableServer/POAPackage/InvalidPolicy.java。
NoServant
org/omg/PortableServer/POAPackage/NoServant.java。
ObjectAlreadyActive
org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
ObjectNotActive
org/omg/PortableServer/POAPackage/ObjectNotActive.java。
ServantAlreadyActive
org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
ServantNotActive
org/omg/PortableServer/POAPackage/ServantNotActive.java。
WrongAdapter
org/omg/PortableServer/POAPackage/WrongAdapter.java。
WrongPolicy
org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.omg.PortableServer.POAPackage 使用的 org.omg.PortableServer.POAPackage 中的类
AdapterAlreadyExists
org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
AdapterNonExistent
org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
InvalidPolicy
org/omg/PortableServer/POAPackage/InvalidPolicy.java。
NoServant
org/omg/PortableServer/POAPackage/NoServant.java。
ObjectAlreadyActive
org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
ObjectNotActive
org/omg/PortableServer/POAPackage/ObjectNotActive.java。
ServantAlreadyActive
org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
ServantNotActive
org/omg/PortableServer/POAPackage/ServantNotActive.java。
WrongAdapter
org/omg/PortableServer/POAPackage/WrongAdapter.java。
WrongPolicy
org/omg/PortableServer/POAPackage/WrongPolicy.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.AdapterAlreadyExists 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.AdapterAlreadyExists
的使用

使用 AdapterAlreadyExists 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 AdapterAlreadyExists 的使用

抛出 AdapterAlreadyExists 的 org.omg.PortableServer 中的方法
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

org.omg.PortableServer.POAPackage 中 AdapterAlreadyExists 的使用

返回 AdapterAlreadyExists 的 org.omg.PortableServer.POAPackage 中的方法
static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)

参数类型为 AdapterAlreadyExists 的 org.omg.PortableServer.POAPackage 中的方法
static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
的使用

没有 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.AdapterNonExistent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.AdapterNonExistent
的使用

使用 AdapterNonExistent 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 AdapterNonExistent 的使用

抛出 AdapterNonExistent 的 org.omg.PortableServer 中的方法
 POA POAOperations.find_POA(String adapter_name, boolean activate_it)
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。

org.omg.PortableServer.POAPackage 中 AdapterNonExistent 的使用

返回 AdapterNonExistent 的 org.omg.PortableServer.POAPackage 中的方法
static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)

参数类型为 AdapterNonExistent 的 org.omg.PortableServer.POAPackage 中的方法
static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
的使用

没有 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.InvalidPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.InvalidPolicy
的使用

使用 InvalidPolicy 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 InvalidPolicy 的使用

抛出 InvalidPolicy 的 org.omg.PortableServer 中的方法
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

org.omg.PortableServer.POAPackage 中 InvalidPolicy 的使用

返回 InvalidPolicy 的 org.omg.PortableServer.POAPackage 中的方法
static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)

参数类型为 InvalidPolicy 的 org.omg.PortableServer.POAPackage 中的方法
static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper
的使用

没有 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.NoServant 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.NoServant
的使用

使用 NoServant 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 NoServant 的使用

抛出 NoServant 的 org.omg.PortableServer 中的方法
 Servant POAOperations.get_servant()
此操作返回与 POA 关联的默认 servant。

org.omg.PortableServer.POAPackage 中 NoServant 的使用

返回 NoServant 的 org.omg.PortableServer.POAPackage 中的方法
static NoServant | NoServantHelper.extract(Any a)
static NoServant | NoServantHelper.read(InputStream istream)

参数类型为 NoServant 的 org.omg.PortableServer.POAPackage 中的方法
static void | NoServantHelper.insert(Any a, NoServant that)
static void | NoServantHelper.write(OutputStream ostream, NoServant value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.NoServantHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.NoServantHelper
的使用

没有 org.omg.PortableServer.POAPackage.NoServantHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ObjectAlreadyActive 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ObjectAlreadyActive
的使用

使用 ObjectAlreadyActive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 ObjectAlreadyActive 的使用

抛出 ObjectAlreadyActive 的 org.omg.PortableServer 中的方法
 void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。

org.omg.PortableServer.POAPackage 中 ObjectAlreadyActive 的使用

返回 ObjectAlreadyActive 的 org.omg.PortableServer.POAPackage 中的方法
static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)

参数类型为 ObjectAlreadyActive 的 org.omg.PortableServer.POAPackage 中的方法
static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
的使用

没有 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ObjectNotActive 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ObjectNotActive
的使用

使用 ObjectNotActive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 ObjectNotActive 的使用

抛出 ObjectNotActive 的 org.omg.PortableServer 中的方法
void | POAOperations.deactivate_object(byte[] oid) 此操作促使在 oid 参数中指定的 ObjectId 被取消激活。
Object | POAOperations.id_to_reference(byte[] oid) 如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
Servant | POAOperations.id_to_servant(byte[] oid) 如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。

org.omg.PortableServer.POAPackage 中 ObjectNotActive 的使用

返回 ObjectNotActive 的 org.omg.PortableServer.POAPackage 中的方法
static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)

参数类型为 ObjectNotActive 的 org.omg.PortableServer.POAPackage 中的方法
static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
的使用

没有 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ServantAlreadyActive 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ServantAlreadyActive
的使用

使用 ServantAlreadyActive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 ServantAlreadyActive 的使用

抛出 ServantAlreadyActive 的 org.omg.PortableServer 中的方法
void | POAOperations.activate_object_with_id(byte[] id, Servant p_servant) 此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
byte[] | POAOperations.activate_object(Servant p_servant) 此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。

org.omg.PortableServer.POAPackage 中 ServantAlreadyActive 的使用

返回 ServantAlreadyActive 的 org.omg.PortableServer.POAPackage 中的方法
static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)

参数类型为 ServantAlreadyActive 的 org.omg.PortableServer.POAPackage 中的方法
static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
的使用

没有 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ServantNotActive 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ServantNotActive
的使用

使用 ServantNotActive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 ServantNotActive 的使用

抛出 ServantNotActive 的 org.omg.PortableServer 中的方法
byte[] | POAOperations.servant_to_id(Servant p_servant) 此操作有四种可能的行为。
Object | POAOperations.servant_to_reference(Servant p_servant) 如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。

org.omg.PortableServer.POAPackage 中 ServantNotActive 的使用

返回 ServantNotActive 的 org.omg.PortableServer.POAPackage 中的方法
static ServantNotActive | ServantNotActiveHelper.extract(Any a)
static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)

参数类型为 ServantNotActive 的 org.omg.PortableServer.POAPackage 中的方法
static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper
的使用

没有 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.WrongAdapter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.WrongAdapter
的使用

使用 WrongAdapter 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 WrongAdapter 的使用

抛出 WrongAdapter 的 org.omg.PortableServer 中的方法
byte[] | POAOperations.reference_to_id(Object reference) 此操作返回指定引用封装的 Object Id 值。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。

org.omg.PortableServer.POAPackage 中 WrongAdapter 的使用

返回 WrongAdapter 的 org.omg.PortableServer.POAPackage 中的方法
static WrongAdapter | WrongAdapterHelper.extract(Any a)
static WrongAdapter | WrongAdapterHelper.read(InputStream istream)

参数类型为 WrongAdapter 的 org.omg.PortableServer.POAPackage 中的方法
static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.WrongAdapterHelper
的使用

没有 org.omg.PortableServer.POAPackage.WrongAdapterHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.WrongPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.WrongPolicy
的使用

使用 WrongPolicy 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer 中 WrongPolicy 的使用

抛出 WrongPolicy 的 org.omg.PortableServer 中的方法
void | POAOperations.activate_object_with_id(byte[] id, Servant p_servant) 此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
byte[] | POAOperations.activate_object(Servant p_servant) 此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。
Object | POAOperations.create_reference(String intf) 此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。
void | POAOperations.deactivate_object(byte[] oid) 此操作促使在 oid 参数中指定的 ObjectId 被取消激活。
ServantManager | POAOperations.get_servant_manager() 如果 POA 的 ServantRetentionPolicy 为 RETAIN，则 ServantManager 参数 (imgr) 应该支持 ServantActivator 接口。
Servant | POAOperations.get_servant() 此操作返回与 POA 关联的默认 servant。
Object | POAOperations.id_to_reference(byte[] oid) 如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
Servant | POAOperations.id_to_servant(byte[] oid) 如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
byte[] | POAOperations.reference_to_id(Object reference) 此操作返回指定引用封装的 Object Id 值。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
byte[] | POAOperations.servant_to_id(Servant p_servant) 此操作有四种可能的行为。
Object | POAOperations.servant_to_reference(Servant p_servant) 如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。
void | POAOperations.set_servant_manager(ServantManager imgr) 此操作设置与 POA 关联的默认 servant 管理器。
void | POAOperations.set_servant(Servant p_servant) 此操作在 POA 中将指定的 servant 注册为默认 servant。

org.omg.PortableServer.POAPackage 中 WrongPolicy 的使用

返回 WrongPolicy 的 org.omg.PortableServer.POAPackage 中的方法
static WrongPolicy | WrongPolicyHelper.extract(Any a)
static WrongPolicy | WrongPolicyHelper.read(InputStream istream)

参数类型为 WrongPolicy 的 org.omg.PortableServer.POAPackage 中的方法
static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)
static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAPackage.WrongPolicyHelper
的使用

没有 org.omg.PortableServer.POAPackage.WrongPolicyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AdapterInactive (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAManagerPackage
类 AdapterInactive

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableServer.POAManagerPackage.AdapterInactive
所有已实现的接口：
Serializable, IDLEntity
public final class AdapterInactive
extends UserException

org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植））从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
AdapterInactive()
AdapterInactive(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AdapterInactive

public AdapterInactive()

AdapterInactive

public AdapterInactive(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AdapterInactiveHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAManagerPackage
类 AdapterInactiveHelper

java.lang.Object
    继承者  org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

public abstract class AdapterInactiveHelper
extends Object

org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植））从 ../../../../src/share/classes/org/omg/PortableServer/poa.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:05 (GMT-08:00)。

构造方法摘要
AdapterInactiveHelper()
方法摘要
static AdapterInactive | extract(Any a)
static String | id()
static void | insert(Any a, AdapterInactive that)
static AdapterInactive | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, AdapterInactive value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdapterInactiveHelper

public AdapterInactiveHelper()
方法详细信息

insert

public static void insert(Any a,
                          AdapterInactive that)

extract

public static AdapterInactive extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static AdapterInactive read(InputStream istream)

write

public static void write(OutputStream ostream,
                         AdapterInactive value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


State (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.POAManagerPackage
类 State

java.lang.Object
    继承者  org.omg.PortableServer.POAManagerPackage.State
所有已实现的接口：
Serializable, IDLEntity
public class State
extends Object
implements IDLEntity

指定 POAManager 的状态。

字段摘要
static int | _ACTIVE
static int | _DISCARDING
static int | _HOLDING
static int | _INACTIVE
static State | ACTIVE
static State | DISCARDING
static State | HOLDING
static State | INACTIVE
构造方法摘要
protected State(int value)
方法摘要
static State | from_int(int value)
int | value()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

_HOLDING

public static final int _HOLDING
另请参见：
常量字段值

HOLDING

public static final State HOLDING

_ACTIVE

public static final int _ACTIVE
另请参见：
常量字段值

ACTIVE

public static final State ACTIVE

_DISCARDING

public static final int _DISCARDING
另请参见：
常量字段值

DISCARDING

public static final State DISCARDING

_INACTIVE

public static final int _INACTIVE
另请参见：
常量字段值

INACTIVE

public static final State INACTIVE
构造方法详细信息

State

protected State(int value)
方法详细信息

value

public int value()

from_int

public static State from_int(int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.PortableServer.POAManagerPackage (Java Platform SE 6)

 org.omg.PortableServer.POAManagerPackage
类
AdapterInactiveHelper
State
异常
AdapterInactive


org.omg.PortableServer.POAManagerPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.PortableServer.POAManagerPackage

封装 POA 关联的处理状态。

请参见：
描述

类摘要
AdapterInactiveHelper | org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java。
State | 指定 POAManager 的状态。

异常摘要
AdapterInactive org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

软件包 org.omg.PortableServer.POAManagerPackage 的描述

封装 POA 关联的处理状态。每个 POA 对象都有关联的 POAManager 对象。POA 管理器可以与一个或多个 POA 对象关联。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.PortableServer.POAManagerPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.POAManagerPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
    • org.omg.PortableServer.POAManagerPackage.State (implements org.omg.CORBA.portable.IDLEntity)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.PortableServer.POAManagerPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.POAManagerPackage
的使用

使用 org.omg.PortableServer.POAManagerPackage 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。

org.omg.PortableServer 使用的 org.omg.PortableServer.POAManagerPackage 中的类
AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。
State
指定 POAManager 的状态。

org.omg.PortableServer.POAManagerPackage 使用的 org.omg.PortableServer.POAManagerPackage 中的类
AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。
State
指定 POAManager 的状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAManagerPackage.AdapterInactive 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAManagerPackage.AdapterInactive
的使用

使用 AdapterInactive 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。

org.omg.PortableServer 中 AdapterInactive 的使用

抛出 AdapterInactive 的 org.omg.PortableServer 中的方法
void | POAManagerOperations.activate() 此操作将 POA 管理器更改为激活状态，促使关联的 POA 开始处理请求。
void | POAManagerOperations.deactivate(boolean etherealize_objects, boolean wait_for_completion) 此操作将 POA 管理器的状态更改为非激活 (inactive)，促使关联的 POA 拒绝尚未开始执行的请求以及任何新的请求。
void | POAManagerOperations.discard_requests(boolean wait_for_completion) 此操作将 POA 管理器的状态更改为丢弃 (discarding)。
void | POAManagerOperations.hold_requests(boolean wait_for_completion) 此操作将 POA 管理器更改为保持 (holding) 状态，促使关联的 POA 将传入请求排队。

org.omg.PortableServer.POAManagerPackage 中 AdapterInactive 的使用

返回 AdapterInactive 的 org.omg.PortableServer.POAManagerPackage 中的方法
static AdapterInactive | AdapterInactiveHelper.extract(Any a)
static AdapterInactive | AdapterInactiveHelper.read(InputStream istream)

参数类型为 AdapterInactive 的 org.omg.PortableServer.POAManagerPackage 中的方法
static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)
static void | AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
的使用

没有 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAManagerPackage.State 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAManagerPackage.State
的使用

使用 State 的软件包
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。

org.omg.PortableServer 中 State 的使用

返回 State 的 org.omg.PortableServer 中的方法
 State POAManagerOperations.get_state()
此操作返回 POA 管理器的状态。

org.omg.PortableServer.POAManagerPackage 中 State 的使用

声明为 State 的 org.omg.PortableServer.POAManagerPackage 中的字段
static State | State.ACTIVE
static State | State.DISCARDING
static State | State.HOLDING
static State | State.INACTIVE

返回 State 的 org.omg.PortableServer.POAManagerPackage 中的方法
static State State.from_int(int value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


CookieHolder (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.ServantLocatorPackage
类 CookieHolder

java.lang.Object
    继承者  org.omg.PortableServer.ServantLocatorPackage.CookieHolder
所有已实现的接口：
Streamable
public final class CookieHolder
extends Object
implements Streamable

native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。提供 CookieHolder 是为了将 Cookie 类型作为输出参数传递。CookieHolder 类与其他基本类型的 holder 类完全一样。

字段摘要
 Object value
构造方法摘要
CookieHolder()
CookieHolder(Object initial)
方法摘要
void | _read(InputStream is) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream os) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public Object value
构造方法详细信息

CookieHolder

public CookieHolder()

CookieHolder

public CookieHolder(Object initial)
方法详细信息

_read

public void _read(InputStream is)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
is - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream os)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
os - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 6)

 org.omg.PortableServer.ServantLocatorPackage
类
CookieHolder


org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.PortableServer.ServantLocatorPackage

提供定位 servant 的类和接口。

请参见：
描述

类摘要
CookieHolder native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。

软件包 org.omg.PortableServer.ServantLocatorPackage 的描述

提供定位 servant 的类和接口。

此包提供一个 CookieHolder 类，将 Cookie 类型作为 out 参数传递。CookieHolder 类与其他基本类型的 holder 类完全一样。

包规范

有关 Java[tm] Platform, Standard Edition 6 遵守的官方 OMG 规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.PortableServer.ServantLocatorPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.ServantLocatorPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder (implements org.omg.CORBA.portable.Streamable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.PortableServer.ServantLocatorPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.ServantLocatorPackage
的使用

使用 org.omg.PortableServer.ServantLocatorPackage 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 使用的 org.omg.PortableServer.ServantLocatorPackage 中的类
CookieHolder
native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder
的使用

使用 CookieHolder 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 CookieHolder 的使用

参数类型为 CookieHolder 的 org.omg.PortableServer 中的方法
Servant | ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
Servant | _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Delegate (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableServer.portable
接口 Delegate

public interface Delegate

可移植性包包含供 ORB 实现者使用的接口和类。它提供了公共定义的 API，可用来连接 stub 和 ORB 框架。Delegate 接口提供特定于 ORB 供应商的 PortableServer::Servant 实现。遵守规范 CORBA V2.3.1 ptc/00-01-08.pdf

方法摘要
 POA default_POA(Servant Self)
此方法的默认行为是从关联 servant 的 ORB 实例返回根 POA。
 Object get_interface_def(Servant self)
此操作返回接口 Repository 中的一个对象，该对象提供可能对编程有用的类型信息。
 boolean is_a(Servant Self, String Repository_Id)
此方法查看指定的 repid 是否存在于 _all_interfaces() 返回的列表上，或者该 repid 是否是通用 CORBA 对象的存储库 id。
 boolean non_existent(Servant Self)
此操作用来检查 Object 是否存在。
 byte[] object_id(Servant Self)
方法 _object_id() 等效于调用 PortableServer::Current::get_object_id。
 ORB orb(Servant Self)
返回当前关联 Servant 的 ORB 实例的便捷方法。
 POA poa(Servant Self)
method _poa() 等效于调用 PortableServer::Current:get_POA。
 Object this_object(Servant Self)
此方法允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。

方法详细信息

orb

ORB orb(Servant Self)
返回当前关联 Servant 的 ORB 实例的便捷方法。

参数：
Self - servant。
返回：
关联 Servant 的 ORB。

this_object

Object this_object(Servant Self)
此方法允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。

参数：
Self - servant。
返回：
关联请求的对象引用。

poa

POA poa(Servant Self)
method _poa() 等效于调用 PortableServer::Current:get_POA。

参数：
Self - servant。
返回：
关联 servant 的 POA。

object_id

byte[] object_id(Servant Self)
方法 _object_id() 等效于调用 PortableServer::Current::get_object_id。

参数：
Self - servant。
返回：
与此 servant 关联的 ObjectId。

default_POA

POA default_POA(Servant Self)
此方法的默认行为是从关联 servant 的 ORB 实例返回根 POA。

参数：
Self - servant。
返回：
关联 servant 类的 POA。

is_a

boolean is_a(Servant Self,
             String Repository_Id)
此方法查看指定的 repid 是否存在于 _all_interfaces() 返回的列表上，或者该 repid 是否是通用 CORBA 对象的存储库 id。

参数：
Self - servant。
Repository_Id - 要在存储库列表中检查（或根据通用 CORBA 对象检查）的 repository_id。
返回：
一个 boolean 值，指示指定的 repid 是否存在于列表中，或者该 id 是否与获取 CORBA 对象的 id 相同。

non_existent

boolean non_existent(Servant Self)
此操作用来检查 Object 是否存在。

参数：
Self - servant。
返回：
一个 boolean 值，true 指示对象不存在；false 则相反。

get_interface_def

Object get_interface_def(Servant self)
此操作返回接口 Repository 中的一个对象，该对象提供可能对编程有用的类型信息。

参数：
self - servant。
返回：
对应于对象的类型信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.PortableServer.portable (Java Platform SE 6)

 org.omg.PortableServer.portable
接口
Delegate


org.omg.PortableServer.portable (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.PortableServer.portable

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

请参见：
描述

接口摘要
Delegate 可移植性包包含供 ORB 实现者使用的接口和类。

软件包 org.omg.PortableServer.portable 的描述

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

portable 包包含供 ORB 实现者使用的接口和类。它提供了公共定义的 API，可用来连接 stub 和 ORB 框架。Delegate 接口提供特定于 ORB 供应商的 PortableServer::Servant 实现。此包遵守 CORBA 规范 V2.3.1 ptc/00-01-08。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.PortableServer.portable 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.portable 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • org.omg.PortableServer.portable.Delegate
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.PortableServer.portable 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableServer.portable
的使用

使用 org.omg.PortableServer.portable 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 使用的 org.omg.PortableServer.portable 中的类
Delegate
可移植性包包含供 ORB 实现者使用的接口和类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.portable.Delegate 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.portable.Delegate
的使用

使用 Delegate 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 Delegate 的使用

返回 Delegate 的 org.omg.PortableServer 中的方法
 Delegate Servant._get_delegate()
获取 PortableServer::Servant 特定于供应商的 ORB 实现。

参数类型为 Delegate 的 org.omg.PortableServer 中的方法
 void Servant._set_delegate(Delegate delegate)
此操作支持 Java ORB 可移植性接口，它向通过代理支持 ORB 可移植性的类提供一个设置其委托的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.AdapterActivator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.AdapterActivator
的使用

使用 AdapterActivator 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 AdapterActivator 的使用

返回 AdapterActivator 的 org.omg.PortableServer 中的方法
 AdapterActivator POAOperations.the_activator()
此属性标识与 POA 关联的适配器激活器。

参数类型为 AdapterActivator 的 org.omg.PortableServer 中的方法
 void POAOperations.the_activator(AdapterActivator newThe_activator)
此属性标识与 POA 关联的适配器激活器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.AdapterActivatorOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.AdapterActivatorOperations
的使用

使用 AdapterActivatorOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 AdapterActivatorOperations 的使用

org.omg.PortableServer 中 AdapterActivatorOperations 的子接口
 interface AdapterActivator
一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.Current 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.Current
的使用

使用 Current 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 Current 的使用

返回 Current 的 org.omg.PortableServer 中的方法
static Current | CurrentHelper.extract(Any a)
static Current | CurrentHelper.narrow(Object obj)
static Current | CurrentHelper.read(InputStream istream)

参数类型为 Current 的 org.omg.PortableServer 中的方法
static void | CurrentHelper.insert(Any a, Current that)
static void | CurrentHelper.write(OutputStream ostream, Current value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.CurrentHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.CurrentHelper
的使用

没有 org.omg.PortableServer.CurrentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.CurrentOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.CurrentOperations
的使用

使用 CurrentOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 CurrentOperations 的使用

org.omg.PortableServer 中 CurrentOperations 的子接口
 interface Current
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.DynamicImplementation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.DynamicImplementation
的使用

没有 org.omg.PortableServer.DynamicImplementation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ForwardRequest 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ForwardRequest
的使用

使用 ForwardRequest 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ForwardRequest 的使用

返回 ForwardRequest 的 org.omg.PortableServer 中的方法
static ForwardRequest | ForwardRequestHelper.extract(Any a)
static ForwardRequest | ForwardRequestHelper.read(InputStream istream)

参数类型为 ForwardRequest 的 org.omg.PortableServer 中的方法
static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)

抛出 ForwardRequest 的 org.omg.PortableServer 中的方法
Servant | ServantActivatorOperations.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。
Servant | _ServantActivatorStub.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
Servant | ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
Servant | _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ForwardRequestHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ForwardRequestHelper
的使用

没有 org.omg.PortableServer.ForwardRequestHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
的使用

没有 org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
的使用

没有 org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
的使用

没有 org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.IdAssignmentPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IdAssignmentPolicy
的使用

使用 IdAssignmentPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdAssignmentPolicy 的使用

返回 IdAssignmentPolicy 的 org.omg.PortableServer 中的方法
 IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.IdAssignmentPolicyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IdAssignmentPolicyOperations
的使用

使用 IdAssignmentPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdAssignmentPolicyOperations 的使用

org.omg.PortableServer 中 IdAssignmentPolicyOperations 的子接口
 interface IdAssignmentPolicy
IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.IdUniquenessPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IdUniquenessPolicy
的使用

使用 IdUniquenessPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdUniquenessPolicy 的使用

返回 IdUniquenessPolicy 的 org.omg.PortableServer 中的方法
 IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.IdAssignmentPolicyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.IdAssignmentPolicyValue
的使用

使用 IdAssignmentPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdAssignmentPolicyValue 的使用

声明为 IdAssignmentPolicyValue 的 org.omg.PortableServer 中的字段
static IdAssignmentPolicyValue | IdAssignmentPolicyValue.SYSTEM_ID
static IdAssignmentPolicyValue | IdAssignmentPolicyValue.USER_ID

返回 IdAssignmentPolicyValue 的 org.omg.PortableServer 中的方法
static IdAssignmentPolicyValue | IdAssignmentPolicyValue.from_int(int value)
IdAssignmentPolicyValue | IdAssignmentPolicyOperations.value() 指定策略值。

参数类型为 IdAssignmentPolicyValue 的 org.omg.PortableServer 中的方法
 IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.IdUniquenessPolicyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.IdUniquenessPolicyOperations
的使用

使用 IdUniquenessPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdUniquenessPolicyOperations 的使用

org.omg.PortableServer 中 IdUniquenessPolicyOperations 的子接口
 interface IdUniquenessPolicy
IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.IdUniquenessPolicyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.IdUniquenessPolicyValue
的使用

使用 IdUniquenessPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 IdUniquenessPolicyValue 的使用

声明为 IdUniquenessPolicyValue 的 org.omg.PortableServer 中的字段
static IdUniquenessPolicyValue | IdUniquenessPolicyValue.MULTIPLE_ID
static IdUniquenessPolicyValue | IdUniquenessPolicyValue.UNIQUE_ID

返回 IdUniquenessPolicyValue 的 org.omg.PortableServer 中的方法
static IdUniquenessPolicyValue | IdUniquenessPolicyValue.from_int(int value)
IdUniquenessPolicyValue | IdUniquenessPolicyOperations.value() 指定策略值

参数类型为 IdUniquenessPolicyValue 的 org.omg.PortableServer 中的方法
 IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ImplicitActivationPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ImplicitActivationPolicy
的使用

使用 ImplicitActivationPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ImplicitActivationPolicy 的使用

返回 ImplicitActivationPolicy 的 org.omg.PortableServer 中的方法
 ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ImplicitActivationPolicyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ImplicitActivationPolicyOperations
的使用

使用 ImplicitActivationPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ImplicitActivationPolicyOperations 的使用

org.omg.PortableServer 中 ImplicitActivationPolicyOperations 的子接口
 interface ImplicitActivationPolicy
此策略指定已创建的 POA 中是否支持隐式激活 servant。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ImplicitActivationPolicyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ImplicitActivationPolicyValue
的使用

使用 ImplicitActivationPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ImplicitActivationPolicyValue 的使用

声明为 ImplicitActivationPolicyValue 的 org.omg.PortableServer 中的字段
static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.IMPLICIT_ACTIVATION
static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.NO_IMPLICIT_ACTIVATION

返回 ImplicitActivationPolicyValue 的 org.omg.PortableServer 中的方法
static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.from_int(int value)
ImplicitActivationPolicyValue | ImplicitActivationPolicyOperations.value() 指定策略值

参数类型为 ImplicitActivationPolicyValue 的 org.omg.PortableServer 中的方法
 ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.LIFESPAN_POLICY_ID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.LIFESPAN_POLICY_ID
的使用

没有 org.omg.PortableServer.LIFESPAN_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.LifespanPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.LifespanPolicy
的使用

使用 LifespanPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 LifespanPolicy 的使用

返回 LifespanPolicy 的 org.omg.PortableServer 中的方法
 LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.LifespanPolicyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.LifespanPolicyOperations
的使用

使用 LifespanPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 LifespanPolicyOperations 的使用

org.omg.PortableServer 中 LifespanPolicyOperations 的子接口
 interface LifespanPolicy
LifespanPolicy 指定已创建 POA 中实现的对象的生存期。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.LifespanPolicyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.LifespanPolicyValue
的使用

使用 LifespanPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 LifespanPolicyValue 的使用

声明为 LifespanPolicyValue 的 org.omg.PortableServer 中的字段
static LifespanPolicyValue | LifespanPolicyValue.PERSISTENT
static LifespanPolicyValue | LifespanPolicyValue.TRANSIENT

返回 LifespanPolicyValue 的 org.omg.PortableServer 中的方法
static LifespanPolicyValue | LifespanPolicyValue.from_int(int value)
LifespanPolicyValue | LifespanPolicyOperations.value() 指定策略值

参数类型为 LifespanPolicyValue 的 org.omg.PortableServer 中的方法
 LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.POA 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.POA
的使用

使用 POA 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CosNaming 中 POA 的使用

参数类型为 POA 的 org.omg.CosNaming 中的方法
String[] | BindingIteratorPOA._all_interfaces(POA poa, byte[] objectId)
String[] | NamingContextExtPOA._all_interfaces(POA poa, byte[] objectId)
String[] | NamingContextPOA._all_interfaces(POA poa, byte[] objectId)

org.omg.PortableServer 中 POA 的使用

返回 POA 的 org.omg.PortableServer 中的方法
 POA Servant._default_POA()
从与 servant 关联的 ORB 实例返回根 POA。
 POA Servant._poa()
允许便捷地执行共用方法，等效于 PortableServer::Current:get_POA。
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。
static POA POAHelper.extract(Any a)
 POA POAOperations.find_POA(String adapter_name, boolean activate_it)
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。
 POA CurrentOperations.get_POA()
返回对 POA 的引用，该 POA 实现此方法在其上下文中调用的对象。
static POA POAHelper.narrow(Object obj)
static POA POAHelper.read(InputStream istream)
 POA[] POAOperations.the_children()
此属性标识 POA 的所有子 POA 的当前设置。
 POA POAOperations.the_parent()
此属性标识 POA 的父 POA。

参数类型为 POA 的 org.omg.PortableServer 中的方法
abstract String[] | Servant._all_interfaces(POA poa, byte[] objectId) ORB 使用此操作从 servant 获取完整的类型信息。
String[] | ServantActivatorPOA._all_interfaces(POA poa, byte[] objectId)
String[] | ServantLocatorPOA._all_interfaces(POA poa, byte[] objectId)
void | ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要取消激活对象的 servant 就会调用此操作。
void | _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要停用对象的 servant 就会调用此操作。
Servant | ServantActivatorOperations.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。
Servant | _ServantActivatorStub.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
static void | POAHelper.insert(Any a, POA that)
void | ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
void | _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
Servant | ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
Servant | _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。
boolean | AdapterActivatorOperations.unknown_adapter(POA parent, String name) 在 ORB 接收对象引用的请求时，如果该对象引用定义不存在的目标 POA，则将调用此操作。
static void | POAHelper.write(OutputStream ostream, POA value)

org.omg.PortableServer.portable 中 POA 的使用

返回 POA 的 org.omg.PortableServer.portable 中的方法
 POA Delegate.default_POA(Servant Self)
此方法的默认行为是从关联 servant 的 ORB 实例返回根 POA。
 POA Delegate.poa(Servant Self)
method _poa() 等效于调用 PortableServer::Current:get_POA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.POAHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.POAHelper
的使用

没有 org.omg.PortableServer.POAHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.POAManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.POAManager
的使用

使用 POAManager 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 POAManager 的使用

返回 POAManager 的 org.omg.PortableServer 中的方法
 POAManager POAOperations.the_POAManager()
此属性标识与 POA 关联的 POA 管理器。

参数类型为 POAManager 的 org.omg.PortableServer 中的方法
 POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.POAManagerOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.POAManagerOperations
的使用

使用 POAManagerOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 POAManagerOperations 的使用

org.omg.PortableServer 中 POAManagerOperations 的子接口
 interface POAManager
每个 POA 对象都有一个关联的 POAManager 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.POAOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.POAOperations
的使用

使用 POAOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 POAOperations 的使用

org.omg.PortableServer 中 POAOperations 的子接口
 interface POA
POA 对象管理对象集合的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
的使用

没有 org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.RequestProcessingPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.RequestProcessingPolicy
的使用

使用 RequestProcessingPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 RequestProcessingPolicy 的使用

返回 RequestProcessingPolicy 的 org.omg.PortableServer 中的方法
 RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.RequestProcessingPolicyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.RequestProcessingPolicyOperations
的使用

使用 RequestProcessingPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 RequestProcessingPolicyOperations 的使用

org.omg.PortableServer 中 RequestProcessingPolicyOperations 的子接口
 interface RequestProcessingPolicy
此策略指定已创建的 POA 处理请求的方式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.RequestProcessingPolicyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.RequestProcessingPolicyValue
的使用

使用 RequestProcessingPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 RequestProcessingPolicyValue 的使用

声明为 RequestProcessingPolicyValue 的 org.omg.PortableServer 中的字段
static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY
static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_DEFAULT_SERVANT
static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_SERVANT_MANAGER

返回 RequestProcessingPolicyValue 的 org.omg.PortableServer 中的方法
static RequestProcessingPolicyValue | RequestProcessingPolicyValue.from_int(int value)
RequestProcessingPolicyValue | RequestProcessingPolicyOperations.value() 指定策略值

参数类型为 RequestProcessingPolicyValue 的 org.omg.PortableServer 中的方法
 RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
的使用

没有 org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.Servant 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.Servant
的使用

使用 Servant 的软件包
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.CosNaming 中 Servant 的使用

org.omg.CosNaming 中 Servant 的子类
class | BindingIteratorPOA BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
class | NamingContextExtPOA NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | NamingContextPOA 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.PortableServer 中 Servant 的使用

org.omg.PortableServer 中 Servant 的子类
class | DynamicImplementation 允许动态处理对象调用。
class | ServantActivatorPOA POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
class | ServantLocatorPOA POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

返回 Servant 的 org.omg.PortableServer 中的方法
Servant | POAOperations.get_servant() 此操作返回与 POA 关联的默认 servant。
Servant | POAOperations.id_to_servant(byte[] oid) 如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
Servant | ServantActivatorOperations.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。
Servant | _ServantActivatorStub.incarnate(byte[] oid, POA adapter) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
Servant | ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
Servant | _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie) 此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。
Servant | POAOperations.reference_to_servant(Object reference) 如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。

参数类型为 Servant 的 org.omg.PortableServer 中的方法
void | POAOperations.activate_object_with_id(byte[] id, Servant p_servant) 此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
byte[] | POAOperations.activate_object(Servant p_servant) 此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。
void | ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要取消激活对象的 servant 就会调用此操作。
void | _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations) 假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要停用对象的 servant 就会调用此操作。
void | ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
void | _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant) servant 完成请求时都将调用此操作。
byte[] | POAOperations.servant_to_id(Servant p_servant) 此操作有四种可能的行为。
Object | POAOperations.servant_to_reference(Servant p_servant) 如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。
void | POAOperations.set_servant(Servant p_servant) 此操作在 POA 中将指定的 servant 注册为默认 servant。

org.omg.PortableServer.portable 中 Servant 的使用

参数类型为 Servant 的 org.omg.PortableServer.portable 中的方法
 POA Delegate.default_POA(Servant Self)
此方法的默认行为是从关联 servant 的 ORB 实例返回根 POA。
 Object Delegate.get_interface_def(Servant self)
此操作返回接口 Repository 中的一个对象，该对象提供可能对编程有用的类型信息。
 boolean Delegate.is_a(Servant Self, String Repository_Id)
此方法查看指定的 repid 是否存在于 _all_interfaces() 返回的列表上，或者该 repid 是否是通用 CORBA 对象的存储库 id。
 boolean Delegate.non_existent(Servant Self)
此操作用来检查 Object 是否存在。
 byte[] Delegate.object_id(Servant Self)
方法 _object_id() 等效于调用 PortableServer::Current::get_object_id。
 ORB Delegate.orb(Servant Self)
返回当前关联 Servant 的 ORB 实例的便捷方法。
 POA Delegate.poa(Servant Self)
method _poa() 等效于调用 PortableServer::Current:get_POA。
 Object Delegate.this_object(Servant Self)
此方法允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantActivator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantActivator
的使用

使用 ServantActivator 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantActivator 的使用

实现 ServantActivator 的 org.omg.PortableServer 中的类
 class _ServantActivatorStub
当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。

返回 ServantActivator 的 org.omg.PortableServer 中的方法
ServantActivator | ServantActivatorPOA._this()
ServantActivator | ServantActivatorPOA._this(ORB orb)
static ServantActivator | ServantActivatorHelper.extract(Any a)
static ServantActivator | ServantActivatorHelper.narrow(Object obj)
static ServantActivator | ServantActivatorHelper.read(InputStream istream)
static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)

参数类型为 ServantActivator 的 org.omg.PortableServer 中的方法
static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantActivatorHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantActivatorHelper
的使用

没有 org.omg.PortableServer.ServantActivatorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantActivatorOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantActivatorOperations
的使用

使用 ServantActivatorOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantActivatorOperations 的使用

org.omg.PortableServer 中 ServantActivatorOperations 的子接口
 interface ServantActivator
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

实现 ServantActivatorOperations 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | ServantActivatorPOA POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantActivatorPOA 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantActivatorPOA
的使用

没有 org.omg.PortableServer.ServantActivatorPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantLocator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantLocator
的使用

使用 ServantLocator 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantLocator 的使用

实现 ServantLocator 的 org.omg.PortableServer 中的类
 class _ServantLocatorStub
POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

返回 ServantLocator 的 org.omg.PortableServer 中的方法
ServantLocator | ServantLocatorPOA._this()
ServantLocator | ServantLocatorPOA._this(ORB orb)
static ServantLocator | ServantLocatorHelper.extract(Any a)
static ServantLocator | ServantLocatorHelper.narrow(Object obj)
static ServantLocator | ServantLocatorHelper.read(InputStream istream)
static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)

参数类型为 ServantLocator 的 org.omg.PortableServer 中的方法
static void | ServantLocatorHelper.insert(Any a, ServantLocator that)
static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantLocatorHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantLocatorHelper
的使用

没有 org.omg.PortableServer.ServantLocatorHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantLocatorPOA 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantLocatorPOA
的使用

没有 org.omg.PortableServer.ServantLocatorPOA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantLocatorOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantLocatorOperations
的使用

使用 ServantLocatorOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantLocatorOperations 的使用

org.omg.PortableServer 中 ServantLocatorOperations 的子接口
 interface ServantLocator
当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。

实现 ServantLocatorOperations 的 org.omg.PortableServer 中的类
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
class | ServantLocatorPOA POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantManager 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantManager
的使用

使用 ServantManager 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantManager 的使用

org.omg.PortableServer 中 ServantManager 的子接口
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。

实现 ServantManager 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

返回 ServantManager 的 org.omg.PortableServer 中的方法
 ServantManager POAOperations.get_servant_manager()
如果 POA 的 ServantRetentionPolicy 为 RETAIN，则 ServantManager 参数 (imgr) 应该支持 ServantActivator 接口。

参数类型为 ServantManager 的 org.omg.PortableServer 中的方法
 void POAOperations.set_servant_manager(ServantManager imgr)
此操作设置与 POA 关联的默认 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantManagerOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantManagerOperations
的使用

使用 ServantManagerOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantManagerOperations 的使用

org.omg.PortableServer 中 ServantManagerOperations 的子接口
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantActivatorOperations POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantLocatorOperations 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantManager servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。

实现 ServantManagerOperations 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
class | ServantActivatorPOA POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
class | ServantLocatorPOA POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantRetentionPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantRetentionPolicy
的使用

使用 ServantRetentionPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantRetentionPolicy 的使用

返回 ServantRetentionPolicy 的 org.omg.PortableServer 中的方法
 ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ServantRetentionPolicyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ServantRetentionPolicyOperations
的使用

使用 ServantRetentionPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantRetentionPolicyOperations 的使用

org.omg.PortableServer 中 ServantRetentionPolicyOperations 的子接口
 interface ServantRetentionPolicy
此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ServantRetentionPolicyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ServantRetentionPolicyValue
的使用

使用 ServantRetentionPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ServantRetentionPolicyValue 的使用

声明为 ServantRetentionPolicyValue 的 org.omg.PortableServer 中的字段
static ServantRetentionPolicyValue | ServantRetentionPolicyValue.NON_RETAIN
static ServantRetentionPolicyValue | ServantRetentionPolicyValue.RETAIN

返回 ServantRetentionPolicyValue 的 org.omg.PortableServer 中的方法
static ServantRetentionPolicyValue | ServantRetentionPolicyValue.from_int(int value)
ServantRetentionPolicyValue | ServantRetentionPolicyOperations.value() 指示策略值

参数类型为 ServantRetentionPolicyValue 的 org.omg.PortableServer 中的方法
 ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
每个这类操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.THREAD_POLICY_ID 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.THREAD_POLICY_ID
的使用

没有 org.omg.PortableServer.THREAD_POLICY_ID 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ThreadPolicy 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ThreadPolicy
的使用

使用 ThreadPolicy 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ThreadPolicy 的使用

返回 ThreadPolicy 的 org.omg.PortableServer 中的方法
 ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
每个这种操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableServer.ThreadPolicyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableServer.ThreadPolicyOperations
的使用

使用 ThreadPolicyOperations 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ThreadPolicyOperations 的使用

org.omg.PortableServer 中 ThreadPolicyOperations 的子接口
 interface ThreadPolicy
ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer.ThreadPolicyValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer.ThreadPolicyValue
的使用

使用 ThreadPolicyValue 的软件包
org.omg.PortableServer 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer 中 ThreadPolicyValue 的使用

声明为 ThreadPolicyValue 的 org.omg.PortableServer 中的字段
static ThreadPolicyValue | ThreadPolicyValue.ORB_CTRL_MODEL
static ThreadPolicyValue | ThreadPolicyValue.SINGLE_THREAD_MODEL

返回 ThreadPolicyValue 的 org.omg.PortableServer 中的方法
static ThreadPolicyValue | ThreadPolicyValue.from_int(int value)
ThreadPolicyValue | ThreadPolicyOperations.value() 指定策略值

参数类型为 ThreadPolicyValue 的 org.omg.PortableServer 中的方法
 ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
每个这种操作都返回一个对具有指定值的策略对象的引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer._ServantActivatorStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer._ServantActivatorStub
的使用

没有 org.omg.PortableServer._ServantActivatorStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableServer._ServantLocatorStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableServer._ServantLocatorStub
的使用

没有 org.omg.PortableServer._ServantLocatorStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


ACTIVE (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ACTIVE

public interface ACTIVE

org/omg/PortableInterceptor/ACTIVE.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
指示正常请求处理的对象适配器状态。

字段详细信息

value

static final short value
指示正常请求处理的对象适配器状态。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AdapterManagerIdHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 AdapterManagerIdHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.AdapterManagerIdHelper

public abstract class AdapterManagerIdHelper
extends Object

适配器管理器标识符。每个对象适配器有一个适配器管理器，该管理器只能在此 API 中通过 ID 来指示。一组对象适配器实例可以共享同一个适配器管理器，在这种情况下，所有具有相同适配器管理器 ID 的对象适配器都监视为该适配器管理器报告的状态转换。

构造方法摘要
AdapterManagerIdHelper()
方法摘要
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdapterManagerIdHelper

public AdapterManagerIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AdapterNameHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 AdapterNameHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.AdapterNameHelper

public abstract class AdapterNameHelper
extends Object

对象适配器的名称。此名称只在创建对象适配器的 ORB 范围内才是唯一的。

构造方法摘要
AdapterNameHelper()
方法摘要
static String[] | extract(Any a)
static String | id()
static void | insert(Any a, String[] that)
static String[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdapterNameHelper

public AdapterNameHelper()
方法详细信息

insert

public static void insert(Any a,
                          String[] that)

extract

public static String[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AdapterStateHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 AdapterStateHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.AdapterStateHelper

public abstract class AdapterStateHelper
extends Object

对象适配器状态的类型。状态更改将报告给对象适配器或适配器管理器。

构造方法摘要
AdapterStateHelper()
方法摘要
static short | extract(Any a)
static String | id()
static void | insert(Any a, short that)
static short | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AdapterStateHelper

public AdapterStateHelper()
方法详细信息

insert

public static void insert(Any a,
                          short that)

extract

public static short extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClientRequestInfo (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ClientRequestInfo

所有超级接口：
ClientRequestInfoOperations, IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable
public interface ClientRequestInfo
extends ClientRequestInfoOperations, RequestInfo, IDLEntity

客户端请求 interceptor 可访问的请求信息。

ClientRequestInfo 上的某些属性和操作并不是对所有的截取点都有效。下表展示了每个属性或操作的有效性。如果无效，则试图访问它们将导致抛出 BAD_INV_ORDER，并带有标准次要代码 14。

 | send_request | send_poll | receive_reply | receive_exception | receive_other
继承自 RequestInfo：
request_id | 是 | 是 | 是 | 是 | 是
operation | 是 | 是 | 是 | 是 | 是
arguments | 是1 | 否 | 是 | 否 | 否
exceptions | 是 | 否 | 是 | 是 | 是
contexts | 是 | 否 | 是 | 是 | 是
operation_context | 是 | 否 | 是 | 是 | 是
result | 否 | 否 | 是 | 否 | 否
response_expected | 是 | 是 | 是 | 是 | 是
sync_scope | 是 | 否 | 是 | 是 | 是
reply_status | 否 | 否 | 是 | 是 | 是
forward_reference | 否 | 否 | 否 | 否 | 是2
get_slot | 是 | 是 | 是 | 是 | 是
get_request_service_context | 是 | 否 | 是 | 是 | 是
get_reply_service_context | 否 | 否 | 是 | 是 | 是
特定于 ClientRequestInfo：
target | 是 | 是 | 是 | 是 | 是
effective_target | 是 | 是 | 是 | 是 | 是
effective_profile | 是 | 是 | 是 | 是 | 是
received_exception | 否 | 否 | 否 | 是 | 否
received_exception_id | 否 | 否 | 否 | 是 | 否
get_effective_component | 是 | 否 | 是 | 是 | 是
get_effective_components | 是 | 否 | 是 | 是 | 是
get_request_policy | 是 | 否 | 是 | 是 | 是
add_request_service_context | 是 | 否 | 否 | 否 | 否
  1. 将 ClientRequestInfo 传递给 send_request 时，对于每个参数（无论它是 in、inout 还是 out），列表中都有一个对应的条目。但只有 in 和 inout 参数可用。
  2. 如果 reply_status 属性不是 LOCATION_FORWARD，则访问此属性将抛出 BAD_INV_ORDER，并带有标准次要代码 14。

另请参见：
ClientRequestInterceptor

方法摘要
从接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 继承的方法
add_request_service_context, effective_profile, effective_target, get_effective_component, get_effective_components, get_request_policy, received_exception_id, received_exception, target
从接口 org.omg.PortableInterceptor.RequestInfoOperations 继承的方法
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClientRequestInfoOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ClientRequestInfoOperations

所有超级接口：
RequestInfoOperations
所有已知子接口：
ClientRequestInfo
public interface ClientRequestInfoOperations
extends RequestInfoOperations

客户端请求 interceptor 可访问的请求信息。

ClientRequestInfo 上的某些属性和操作并不是对所有的截取点都有效。下表展示了每个属性或操作的有效性。如果无效，则试图访问它将导致抛出 BAD_INV_ORDER，并带有标准次要代码 14。

 | send_request | send_poll | receive_reply | receive_exception | receive_other
继承自 RequestInfo：
request_id | 是 | 是 | 是 | 是 | 是
operation | 是 | 是 | 是 | 是 | 是
arguments | 是1 | 否 | 是 | 否 | 否
exceptions | 是 | 否 | 是 | 是 | 是
contexts | 是 | 否 | 是 | 是 | 是
operation_context | 是 | 否 | 是 | 是 | 是
result | 否 | 否 | 是 | 否 | 否
response_expected | 是 | 是 | 是 | 是 | 是
sync_scope | 是 | 否 | 是 | 是 | 是
reply_status | 否 | 否 | 是 | 是 | 是
forward_reference | 否 | 否 | 否 | 否 | 是2
get_slot | 是 | 是 | 是 | 是 | 是
get_request_service_context | 是 | 否 | 是 | 是 | 是
get_reply_service_context | 否 | 否 | 是 | 是 | 是
特定于 ClientRequestInfo：
target | 是 | 是 | 是 | 是 | 是
effective_target | 是 | 是 | 是 | 是 | 是
effective_profile | 是 | 是 | 是 | 是 | 是
received_exception | 否 | 否 | 否 | 是 | 否
received_exception_id | 否 | 否 | 否 | 是 | 否
get_effective_component | 是 | 否 | 是 | 是 | 是
get_effective_components | 是 | 否 | 是 | 是 | 是
get_request_policy | 是 | 否 | 是 | 是 | 是
add_request_service_context | 是 | 否 | 否 | 否 | 否
  1. 将 ClientRequestInfo 传递给 send_request 时，对于每个参数（无论它是 in、inout 还是 out），列表中都有一个对应的条目。但只有 in 和 inout 参数可用。
  2. 如果 reply_status 属性不是 LOCATION_FORWARD，则访问此属性将抛出 BAD_INV_ORDER，并带有标准次要代码 14。

另请参见：
ClientRequestInterceptor

方法摘要
void | add_request_service_context(ServiceContext service_context, boolean replace) 允许 Interceptor 将服务上下文添加到请求。
TaggedProfile | effective_profile() 返回将用来发送请求的配置文件。
Object | effective_target() 返回实际调用操作的对象。
TaggedComponent | get_effective_component(int id) 返回为此请求选择的配置文件中带有给定 ID 的 IOP.TaggedComponent。
TaggedComponent[] | get_effective_components(int id) 返回为此请求选择的配置文件中具有给定 ID 的带标记组件所组成的数组。
Policy | get_request_policy(int type) 返回此操作实行的给定策略。
String | received_exception_id() 返回将向客户端返回的异常的存储库 id。
Any | received_exception() 返回一个 any，它包含要向客户端返回的异常。
Object | target() 返回客户端调用以执行操作的对象。
从接口 org.omg.PortableInterceptor.RequestInfoOperations 继承的方法
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

方法详细信息

target

Object target()
返回客户端调用以执行操作的对象。

另请参见：
effective_target()

effective_target

Object effective_target()
返回实际调用操作的对象。如果 reply_status 为 LOCATION_FORWARD，则后续请求中 effective_target 将包含转发的 IOR，而目标保持不变。

另请参见：
target()

effective_profile

TaggedProfile effective_profile()
返回将用来发送请求的配置文件。如果此操作的对象发生了位置转发，并且该对象的配置文件因此而发生了更改，则此配置文件即为用来定位的配置文件。

received_exception

Any received_exception()
返回一个 any，它包含要向客户端返回的异常。

如果异常是不能插入 any 的用户异常（例如，该异常是未知的或绑定不提供 TypeCode），则此属性将是一个包含系统异常 UNKNOWN 并带有标准次要代码 (minor code) 1 的 any。但是，异常的存储库 id 在 received_exception_id 属性中可用。

另请参见：
received_exception_id()

received_exception_id

String received_exception_id()
返回将向客户端返回的异常的存储库 id。

另请参见：
received_exception(), PortableInterceptor 包中关于限制/未实现特性的注释

get_effective_component

TaggedComponent get_effective_component(int id)
返回为此请求选择的配置文件中带有给定 ID 的 IOP.TaggedComponent。

如果给定的组件 ID 对应多个组件，则此操作返回哪个组件是不确定的。如果给定的组件 ID 对应于多个组件，则应调用 get_effective_components。

参数：
id - 将返回的组件的组件 id。
返回：
通过给定标识符获取的 IOP.TaggedComponent。
抛出：
BAD_PARAM - 如果不存在对应于给定组件 ID 的组件，则抛出此异常，并带有标准次代码 28。
另请参见：
get_effective_components(int)

get_effective_components

TaggedComponent[] get_effective_components(int id)
返回为此请求选择的配置文件中具有给定 ID 的带标记组件所组成的数组。

参数：
id - 将返回的组件的组件 id。
返回：
TaggedComponent 对象的数组，每个对象都包含给定标识符。
抛出：
BAD_PARAM - 如果不存在对应于给定组件 ID 的组件，则抛出此异常，并带有标准次代码 28。
另请参见：
get_effective_component(int)

get_request_policy

Policy get_request_policy(int type)
返回此操作实行的给定策略。

参数：
type - 指定将返回策略的策略类型。
返回：
通过给定类型获取的 CORBA.Policy。
抛出：
INV_POLICY - 如果策略类型因为此 ORB 不支持指定类型或该类型的策略对象不与此 Object 关联而无效，则抛出此异常，并带有标准次代码 1。
另请参见：
PortableInterceptor 包中关于限制/未实现特性的注释

add_request_service_context

void add_request_service_context(ServiceContext service_context,
                                 boolean replace)
允许 Interceptor 将服务上下文添加到请求。

没有对服务上下文的顺序做出任何声明。它们可能按添加的顺序出现，也可能不是如此。

参数：
service_context - 将添加到请求的 IOP.ServiceContext。
replace - 在已经存在具有给定 ID 的服务上下文时指示此操作的行为。如果为 false，则抛出 BAD_INV_ORDER，并带有标准次要代码 15。如果为 true，则用新服务上下文取代现有的服务上下文。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClientRequestInterceptor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ClientRequestInterceptor

所有超级接口：
ClientRequestInterceptorOperations, IDLEntity, Interceptor, InterceptorOperations, Object, Serializable
public interface ClientRequestInterceptor
extends ClientRequestInterceptorOperations, Interceptor, IDLEntity

客户端 interceptor。

请求 Interceptor 用于通过 ORB 在指定点截取请求/应答序列流，以便服务能够查询请求信息并操作在客户端和服务器之间传播的服务上下文。请求 Interceptor 主要用途是使 ORB 服务能够在客户端和服务器之间传输上下文信息。请求 Interceptor 有两种类型：客户端和服务器端。

编写客户端 Interceptor 需要实现 ClientRequestInterceptor 接口。

另请参见：
ClientRequestInfo

方法摘要
从接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 继承的方法
receive_exception, receive_other, receive_reply, send_poll, send_request
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClientRequestInterceptorOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ClientRequestInterceptorOperations

所有超级接口：
InterceptorOperations
所有已知子接口：
ClientRequestInterceptor
public interface ClientRequestInterceptorOperations
extends InterceptorOperations

客户端的请求 interceptor。

请求 Interceptor 用于通过 ORB 在指定点截取请求/应答序列流，以便服务能够查询请求信息并操作在客户端和服务器之间传播的服务上下文。请求 Interceptor 主要用途是使 ORB 服务能够在客户端和服务器之间传输上下文信息。请求 Interceptor 有两种类型：客户端和服务器端。

编写客户端 Interceptor 需要实现 ClientRequestInterceptor 接口。

另请参见：
ClientRequestInfo

方法摘要
void | receive_exception(ClientRequestInfo ri) 指示 interceptor 发生异常。
void | receive_other(ClientRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | receive_reply(ClientRequestInfo ri) 允许 Interceptor 在从服务器返回后但在向客户端返回控件前查询信息。
void | send_poll(ClientRequestInfo ri) 允许 Interceptor 在轮询获取应答序列的与时间无关的调用（Time-Independent Invocation，TII）时查询信息。
void | send_request(ClientRequestInfo ri) 允许 Interceptor 在请求被发送到服务器前查询请求信息并修改服务上下文。
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name

方法详细信息

send_request

void send_request(ClientRequestInfo ri)
                  throws ForwardRequest
允许 Interceptor 在请求被发送到服务器前查询请求信息并修改服务上下文。

此截取点可能抛出系统异常。如果抛出异常，则不调用其他任何 Interceptor 的 send_request 操作。移除那些 Flow Stack 上的 Interceptor 并调用其 receive_exception 截取点。此截取点也可能抛出 ForwardRequest 异常。如果 Interceptor 抛出此异常，则不调用其他任何 Interceptor 的 send_request 操作。移除那些 Flow Stack 上的 Interceptor 并调用其 receive_other 截取点。

符合的 Interceptor 如果从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。completion_status 应为 COMPLETED_NO。

参数：
ri - 关于将被截取的当前请求的信息。
抛出：
ForwardRequest - 抛出此异常指示 ORB 重试请求应该与异常中给定的新对象一起发生。

send_poll

void send_poll(ClientRequestInfo ri)
允许 Interceptor 在轮询获取应答序列的与时间无关的调用（Time-Independent Invocation，TII）时查询信息。

利用 TII，应用程序可以轮询对之前由轮询客户端或其他客户端发送的请求所做出的响应。此轮询将通过 send_poll 截取点报告给 Interceptor，响应将通过 receive_reply 或 receive_exception 截取点返回。如果在超过轮询超时期前没有获得响应，则抛出系统异常 TIMEOUT，并使用该异常调用 receive_exception。

此截取点可能抛出系统异常。如果抛出异常，则不调用其他任何 Interceptor 的 send_poll 操作。移除那些 Flow Stack 上的 Interceptor 并调用其 receive_exception 截取点。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。completion_status 应为 COMPLETED_NO。

参数：
ri - 关于将被截取的当前请求的信息。
抛出：
TIMEOUT - 如果在超过轮询超时期前没有获得响应。

receive_reply

void receive_reply(ClientRequestInfo ri)
允许 Interceptor 在从服务器返回后但在向客户端返回控件前查询信息。

此截取点可能抛出系统异常。如果抛出异常，则不调用其他任何 Interceptor 的 receive_reply 操作。将调用 Flow Stack 中剩余 Interceptor 的 receive_exception 截取点。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。completion_status 应为 COMPLETED_YES。

参数：
ri - 关于将被截取的当前请求的信息。

receive_exception

void receive_exception(ClientRequestInfo ri)
                       throws ForwardRequest
指示 interceptor 发生异常。允许 Interceptor 在向客户端抛出异常前查询异常信息。

此截取点可能抛出系统异常。这等效于更改连续 Interceptor（从 Flow Stack 中移除的）调用 receive_exception 接收到的异常。对客户端抛出的异常将是 Interceptor 抛出的最终异常或者原始异常（如果没有 Interceptor 更改了异常）。

此截取点同样可能抛出 ForwardRequest 异常。如果 Interceptor 抛出此异常，则不调用其他任何 Interceptor 的 receive_exception 操作。移除 Flow Stack 中剩余的 Interceptor 并调用其 receive_other 截取点。

如果异常的 completion_status 不是 COMPLETED_NO，则此截取点抛出 ForwardRequest 异常是不恰当的。将失去请求的最多一次 (at-most-once) 语义。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。如果原始异常为系统异常，则新异常的 completion_status 将与原始异常相同。如果原始异常为用户异常，则新异常的 completion_status 应为 COMPLETED_YES。

在某些情况下，异常（如 COMM_FAILURE）可能导致重试请求，具体取决于实行的策略。虽然这种重试对于 Interceptor 而言是一个新的请求，但是在原始请求和重试请求之间仍然存在一种相关性：因为没有向客户端返回控制信息，所以原始请求和重试请求的 PortableInterceptor.Current 是相同的。

参数：
ri - 关于将被截取的当前请求的信息。
抛出：
ForwardRequest - 抛出此异常指示 ORB 重试请求应该与异常中给定的新对象一起发生。

receive_other

void receive_other(ClientRequestInfo ri)
                   throws ForwardRequest
允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。例如，请求可以引起重试（例如，收到带有 LOCATION_FORWARD 状态的 GIOP 应答）；又如异步调用时，请求后不会立即应答，但是将向客户端返回控制信息并调用终端截取点。

对于重试而言，当已经指示重试后可能执行一个新的请求，也可能不执行，具体取决于实行的策略。如果执行新的请求，则虽然这种重试对于 Interceptor 而言是一个新的请求，但是在原始请求和重试请求之间仍然存在一种相关性：因为没有向客户端返回控制信息，所以原始请求和重试请求的请求域 PortableInterceptor.Current 是相同的。

此截取点可能抛出系统异常。如果抛出异常，则不调用其他任何 Interceptor 的 receive_other 操作。移除 Flow Stack 中剩余的 Interceptor 并调用其 receive_exception 截取点。

此截取点同样可能抛出 ForwardRequest 异常。如果 Interceptor 抛出此异常，则使用 ForwardRequest 异常提供的新信息调用连续 Interceptor 的 receive_other 操作。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。completion_status 应该是 COMPLETED_NO。如果已经完成了目标调用，则将调用此截取点。

参数：
ri - 关于将被截取的当前请求的信息。
抛出：
ForwardRequest - 抛出此异常指示 ORB 重试请求应该与异常中给定的新对象一起发生。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Current (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 Current

所有超级接口：
Current, CurrentOperations, IDLEntity, Object, Serializable
public interface Current
extends CurrentOperations, Current, IDLEntity

Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。每个需要使用 PICurrent 的服务都在初始化期间预定了一个或多个槽，然后在处理请求和应答期间使用这些槽。

在进行调用之前，通过调用 ORB.resolve_initial_references( "PICurrent" ) 获取 PICurrent。通过对 RequestInfo 对象进行 get_slot 操作，可从截取点内获取从线程域传送到请求域的 PICurrent 数据。PICurrent 也可以通过 resolve_initial_references 获取，但这样获取的是 Interceptor 的线程域 PICurrent。

方法摘要
从接口 org.omg.PortableInterceptor.CurrentOperations 继承的方法
get_slot, set_slot
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 CurrentHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.CurrentHelper

public abstract class CurrentHelper
extends Object

Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文和请求方或应答的服务上下文之间传输其上下文数据。每个需要使用 PICurrent 的服务都在初始化期间预定了一个或多个槽，然后在处理请求和应答期间使用这些槽。

在进行调用之前，通过调用 ORB.resolve_initial_references( "PICurrent" ) 获取 PICurrent。通过对 RequestInfo 对象进行 get_slot 操作，可从截取点内获取从线程域传送到请求域的 PICurrent 数据。PICurrent 也可以通过 resolve_initial_references 获取，但这样获取的是 Interceptor 的线程域 PICurrent。

构造方法摘要
CurrentHelper()
方法摘要
static Current | extract(Any a)
static String | id()
static void | insert(Any a, Current that)
static Current | narrow(Object obj)
static Current | read(InputStream istream)
static TypeCode | type()
static Current | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, Current value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CurrentHelper

public CurrentHelper()
方法详细信息

insert

public static void insert(Any a,
                          Current that)

extract

public static Current extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Current read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Current value)

narrow

public static Current narrow(Object obj)

unchecked_narrow

public static Current unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CurrentOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 CurrentOperations

所有超级接口：
CurrentOperations
所有已知子接口：
Current
public interface CurrentOperations
extends CurrentOperations

Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。每个需要使用 PICurrent 的服务都在初始化期间预定了一个或多个槽，然后在处理请求和应答期间使用这些槽。

在进行调用之前，通过调用 ORB.resolve_initial_references( "PICurrent" ) 获取 PICurrent。通过对 RequestInfo 对象进行 get_slot 操作，可从截取点内获取从线程域传送到请求域的 PICurrent 数据。PICurrent 也可以通过 resolve_initial_references 获取，但这样获取的是 Interceptor 的线程域 PICurrent。

方法摘要
Any | get_slot(int id) 检索应用程序通过 get_slot 在 PICurrent 中设置的槽数据。
void | set_slot(int id, Any data) 在槽中设置数据。

方法详细信息

get_slot

Any get_slot(int id)
             throws InvalidSlot
检索应用程序通过 get_slot 在 PICurrent 中设置的槽数据。该数据以 Any 的形式存在。

如果尚未设置给定槽，则返回包含带有 TCKind 值为 tk_null 的类型代码的 Any，并且该 Any 中不包含任何值。

参数：
id - 将返回数据的槽的 SlotId。
返回：
给定槽标识符的数据，以 Any 的形式存在。
抛出：
InvalidSlot - 如果对尚未分配的槽调用 get_slot，则抛出此异常。
BAD_INV_ORDER - 如果在 ORB 初始化程序内调用 get_slot，则抛出此异常。

set_slot

void set_slot(int id,
              Any data)
              throws InvalidSlot
在槽中设置数据。该数据以 Any 的形式存在。如果该槽中已存在数据，则将其重写。

参数：
id - 将设置数据的槽的 SlotId。
data - 将对所标识的槽设置的数据，以 Any 的形式存在。
抛出：
InvalidSlot - 如果对尚未分配的槽调用 set_slot，则抛出此异常。
BAD_INV_ORDER - 如果在 ORB 初始化程序内调用 set_slot，则抛出此异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DISCARDING (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 DISCARDING

public interface DISCARDING

org/omg/PortableInterceptor/DISCARDING.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
导致丢弃所有请求的对象适配器状态。

字段详细信息

value

static final short value
导致丢弃所有请求的对象适配器状态。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ForwardRequest (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ForwardRequest

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableInterceptor.ForwardRequest
所有已实现的接口：
Serializable, IDLEntity
public final class ForwardRequest
extends UserException

org/omg/PortableInterceptor/ForwardRequest.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
 Object forward
将请求转发到的新对象。
构造方法摘要
ForwardRequest()
ForwardRequest(Object _forward)
ForwardRequest(String $reason, Object _forward)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

forward

public Object forward
将请求转发到的新对象。

构造方法详细信息

ForwardRequest

public ForwardRequest()

ForwardRequest

public ForwardRequest(Object _forward)

ForwardRequest

public ForwardRequest(String $reason,
                      Object _forward)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ForwardRequestHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ForwardRequestHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ForwardRequestHelper

public abstract class ForwardRequestHelper
extends Object

org/omg/PortableInterceptor/ForwardRequestHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

构造方法摘要
ForwardRequestHelper()
方法摘要
static ForwardRequest | extract(Any a)
static String | id()
static void | insert(Any a, ForwardRequest that)
static ForwardRequest | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ForwardRequest value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ForwardRequestHelper

public ForwardRequestHelper()
方法详细信息

insert

public static void insert(Any a,
                          ForwardRequest that)

extract

public static ForwardRequest extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ForwardRequest read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ForwardRequest value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HOLDING (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 HOLDING

public interface HOLDING

org/omg/PortableInterceptor/HOLDING.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
在状态更改前暂时保持请求的对象适配器状态。

字段详细信息

value

static final short value
在状态更改前暂时保持请求的对象适配器状态。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


INACTIVE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 INACTIVE

public interface INACTIVE

org/omg/PortableInterceptor/INACTIVE.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
导致丢弃所有请求的对象适配器状态。

字段详细信息

value

static final short value
导致丢弃所有请求的对象适配器状态。此状态指示适配器将被关闭。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Interceptor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 Interceptor

所有超级接口：
IDLEntity, InterceptorOperations, Object, Serializable
所有已知子接口：
ClientRequestInterceptor, IORInterceptor, IORInterceptor_3_0, ServerRequestInterceptor
public interface Interceptor
extends InterceptorOperations, Object, IDLEntity

所有 Portable Interceptor 实现 Interceptor。

方法摘要
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InterceptorOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 InterceptorOperations

所有已知子接口：
ClientRequestInterceptor, ClientRequestInterceptorOperations, Interceptor, IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations, IORInterceptorOperations, ServerRequestInterceptor, ServerRequestInterceptorOperations
public interface InterceptorOperations

所有 Portable Interceptor 实现 Interceptor。

方法摘要
void | destroy() 提供销毁此 interceptor 的机会。
String | name() 返回 interceptor 的名称。

方法详细信息

name

String name()
返回 interceptor 的名称。

每个 Interceptor 都具有一个用来管理 Interceptor 列表的名称。每种 Interceptor 类型只能向 ORB 注册一个给定名称的 Interceptor。Interceptor 可以是匿名的，即将空字符串作为名称属性。可向 ORB 注册任何数量的匿名 Interceptor。

返回：
interceptor 的名称。

destroy

void destroy()
提供销毁此 interceptor 的机会。在调用 ORB.destroy 期间调用该 destroy 方法。当应用程序调用 ORB.destroy 时，ORB 将执行以下操作：
  1. 等待所有进行中的请求完成
  2. 为每个 interceptor 调用 Interceptor.destroy 操作
  3. 完成 ORB 的销毁
如果 Interceptor.destroy 中的方法调用发生在已销毁 ORB 上实现的对象的对象引用上，则将导致不明确的行为。但是，对未销毁 ORB 上实现的对象进行方法调用是允许的。（这意味着销毁的 ORB 仍然可作为客户端，但不能作为服务器。）

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidSlot (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 InvalidSlot

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableInterceptor.InvalidSlot
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidSlot
extends UserException

org/omg/PortableInterceptor/InvalidSlot.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

构造方法摘要
InvalidSlot()
InvalidSlot(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidSlot

public InvalidSlot()

InvalidSlot

public InvalidSlot(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidSlotHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 InvalidSlotHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.InvalidSlotHelper

public abstract class InvalidSlotHelper
extends Object

org/omg/PortableInterceptor/InvalidSlotHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

构造方法摘要
InvalidSlotHelper()
方法摘要
static InvalidSlot | extract(Any a)
static String | id()
static void | insert(Any a, InvalidSlot that)
static InvalidSlot | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidSlot value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InvalidSlotHelper

public InvalidSlotHelper()
方法详细信息

insert

public static void insert(Any a,
                          InvalidSlot that)

extract

public static InvalidSlot extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidSlot read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidSlot value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORInfo (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 IORInfo

所有超级接口：
IDLEntity, IORInfoOperations, Object, Serializable
public interface IORInfo
extends IORInfoOperations, Object, IDLEntity

提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。ORB 将此接口实现的实例作为参数传递给 IORInterceptor.establish_components。

另请参见：
IORInterceptor

方法摘要
从接口 org.omg.PortableInterceptor.IORInfoOperations 继承的方法
adapter_template, add_ior_component_to_profile, add_ior_component, current_factory, current_factory, get_effective_policy, manager_id, state
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORInfoOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 IORInfoOperations

所有已知子接口：
IORInfo
public interface IORInfoOperations

提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。ORB 将此接口实现的实例作为参数传递给 IORInterceptor.establish_components。

另请参见：
IORInterceptor

方法摘要
ObjectReferenceTemplate | adapter_template() 返回刚创建并在 IOR interceptor 上运行的对象适配器的对象引用模板。
void | add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id) 可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component_to_profile，以便向构造 IOR 时要包括的设置添加带标记的组件。
void | add_ior_component(TaggedComponent tagged_component) 可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component，以便向构造 IOR 时要包括的设置添加带标记的组件。
ObjectReferenceFactory | current_factory() 读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
void | current_factory(ObjectReferenceFactory newCurrent_factory) 读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
Policy | get_effective_policy(int type) 允许 ORB 服务实现确定对将构造的 IOR 有效的特定类型服务器端策略。
int | manager_id() 返回刚创建并在 IOR interceptor 上运行的对象适配器的对象适配器管理器 id。
short | state() 返回刚创建并在 IOR interceptor 上运行的对象适配器的对象适配器状态。

方法详细信息

get_effective_policy

Policy get_effective_policy(int type)
允许 ORB 服务实现确定对将构造的 IOR 有效的特定类型服务器端策略。当将构造的 IOR 对应于使用 POA 实现的对象时，所有传递给创建该 POA 的 PortableServer.POA.create_POA 调用的 Policy 对象都可以通过 get_effective_policy 访问。

如果 ORB 已知给定类型的策略，则此操作将抛出 INV_POLICY，并带有标准次要代码 2。

参数：
type - 一个 int，指定要返回的策略的类型。
返回：
所请求类型的有效 CORBA.Policy 对象。如果已知给定策略类型，但不存在有效的该类型策略，则此操作将返回 nil 对象引用。

add_ior_component

void add_ior_component(TaggedComponent tagged_component)
可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component，以便向构造 IOR 时要包括的设置添加带标记的组件。此设置中的组件将包括在所有的配置文件中。

可以存在任何数量具有相同 ID 的组件。

参数：
a_component - 要添加的 IOP.TaggedComponent。

add_ior_component_to_profile

void add_ior_component_to_profile(TaggedComponent tagged_component,
                                  int profile_id)
可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component_to_profile，以便向构造 IOR 时要包括的设置添加带标记的组件。此设置中的组件将包括在指定的配置文件中。

可以存在任何数量具有相同 ID 的组件。

参数：
a_component - 要添加的 IOP.TaggedComponent。
profile_id - 将添加此组件的配置文件的配置文件 id。
抛出：
BAD_PARAM - 如果给定配置文件 ID 没有定义已知配置文件或不能向该配置文件添加组件，则将抛出此异常，并带有标准次代码 29。

manager_id

int manager_id()
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象适配器管理器 id。

state

short state()
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象适配器状态。

adapter_template

ObjectReferenceTemplate adapter_template()
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象引用模板。

current_factory

ObjectReferenceFactory current_factory()
读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。默认情况下，此工厂与 adapter_template 属性的值相同。current_factory 也可以设置为 IORInterceptor_3_0 中的另一个对象引用模板。

current_factory

void current_factory(ObjectReferenceFactory newCurrent_factory)
读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。默认情况下，此工厂与 adapter_template 属性的值相同。current_factory 也可以设置为 IORInterceptor_3_0 中的另一个对象引用模板。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORInterceptor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 IORInterceptor

所有超级接口：
IDLEntity, Interceptor, InterceptorOperations, IORInterceptorOperations, Object, Serializable
所有已知子接口：
IORInterceptor_3_0
public interface IORInterceptor
extends IORInterceptorOperations, Interceptor, IDLEntity

Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。

在某些情况下，可移植 ORB 服务实现可能需要向对象引用添加描述服务器或对象 ORB 服务相关功能的信息，以便使客户端中的 ORB 服务实现运转正常。

IORInterceptor 和 IORInfo 接口支持这一功能。

另请参见：
IORInfo

方法摘要
从接口 org.omg.PortableInterceptor.IORInterceptorOperations 继承的方法
establish_components
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORInterceptor_3_0 (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 IORInterceptor_3_0

所有超级接口：
IDLEntity, Interceptor, InterceptorOperations, IORInterceptor, IORInterceptor_3_0Operations, IORInterceptorOperations, Object, Serializable
public interface IORInterceptor_3_0
extends IORInterceptor_3_0Operations, IORInterceptor, IDLEntity

org/omg/PortableInterceptor/IORInterceptor_3_0.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

方法摘要
从接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 继承的方法
adapter_manager_state_changed, adapter_state_changed, components_established
从接口 org.omg.PortableInterceptor.IORInterceptorOperations 继承的方法
establish_components
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORInterceptor_3_0Helper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 IORInterceptor_3_0Helper

java.lang.Object
    继承者  org.omg.PortableInterceptor.IORInterceptor_3_0Helper

public abstract class IORInterceptor_3_0Helper
extends Object

org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

构造方法摘要
IORInterceptor_3_0Helper()
方法摘要
static IORInterceptor_3_0 | extract(Any a)
static String | id()
static void | insert(Any a, IORInterceptor_3_0 that)
static IORInterceptor_3_0 | narrow(Object obj)
static IORInterceptor_3_0 | read(InputStream istream)
static TypeCode | type()
static IORInterceptor_3_0 | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, IORInterceptor_3_0 value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IORInterceptor_3_0Helper

public IORInterceptor_3_0Helper()
方法详细信息

insert

public static void insert(Any a,
                          IORInterceptor_3_0 that)

extract

public static IORInterceptor_3_0 extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static IORInterceptor_3_0 read(InputStream istream)

write

public static void write(OutputStream ostream,
                         IORInterceptor_3_0 value)

narrow

public static IORInterceptor_3_0 narrow(Object obj)

unchecked_narrow

public static IORInterceptor_3_0 unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORInterceptor_3_0Holder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 IORInterceptor_3_0Holder

java.lang.Object
    继承者  org.omg.PortableInterceptor.IORInterceptor_3_0Holder
所有已实现的接口：
Streamable
public final class IORInterceptor_3_0Holder
extends Object
implements Streamable

org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
 IORInterceptor_3_0 value
构造方法摘要
IORInterceptor_3_0Holder()
IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public IORInterceptor_3_0 value
构造方法详细信息

IORInterceptor_3_0Holder

public IORInterceptor_3_0Holder()

IORInterceptor_3_0Holder

public IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORInterceptor_3_0Operations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 IORInterceptor_3_0Operations

所有超级接口：
InterceptorOperations, IORInterceptorOperations
所有已知子接口：
IORInterceptor_3_0
public interface IORInterceptor_3_0Operations
extends IORInterceptorOperations

org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:10 (GMT-08:00)。

方法摘要
void | adapter_manager_state_changed(int id, short state) 只要适配器管理器的状态更改时便调用此方法。
void | adapter_state_changed(ObjectReferenceTemplate[] templates, short state) 只要对象适配器的状态发生更改，并且该状态更改不是由适配器管理器引起的，便调用此方法。
void | components_established(IORInfo info) 在已经对所有已注册 IORInterceptor 实例调用 establish_components 方法后，对所有已注册 IORInterceptor_3_0 实例调用 components_established 方法。
从接口 org.omg.PortableInterceptor.IORInterceptorOperations 继承的方法
establish_components
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name

方法详细信息

components_established

void components_established(IORInfo info)
在已经对所有已注册 IORInterceptor 实例调用 establish_components 方法后，对所有已注册 IORInterceptor_3_0 实例调用 components_established 方法。此调用中可将 adapter_template 用于 info。此调用中可使用 info 获取或设置 current_factory。

此方法抛出的任何异常可由调用此 interceptor 的对象适配器处理。就 POA 而言，一个异常将导致带有 OMG 标准次代码 (minor code) 6 的 OBJ_ADAPTER 异常。

参数：
info - 将创建的对象适配器的 IORInfo。

adapter_manager_state_changed

void adapter_manager_state_changed(int id,
                                   short state)
只要适配器管理器的状态更改时便调用此方法。对于 POA，指的是 POAManager。通过 adapter_manager_state_changed 报告的状态更改不会再通过 adapter_state_changed 报告。

参数：
id - 更改状态的适配器管理器的适配器管理器 id
state - 适配器管理器的新状态

adapter_state_changed

void adapter_state_changed(ObjectReferenceTemplate[] templates,
                           short state)
只要对象适配器的状态发生更改，并且该状态更改不是由适配器管理器引起的，便调用此方法。向所有已注册 IORInterceptor_3_0 实例报告此类更改。

参数：
templates - 发生此状态更改的 ObjectReferenceTemplate 实例序列。
state - 由所有模板共享的新 AdapterState。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORInterceptorOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 IORInterceptorOperations

所有超级接口：
InterceptorOperations
所有已知子接口：
IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations
public interface IORInterceptorOperations
extends InterceptorOperations

Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。

在某些情况下，可移植 ORB 服务实现可能需要向对象引用添加描述服务器或对象 ORB 服务相关功能的信息，以便使客户端中的 ORB 服务实现运转正常。

IORInterceptor 和 IORInfo 接口支持这一功能。

另请参见：
IORInfo

方法摘要
 void establish_components(IORInfo info)
在汇编将包括在对象引用配置文件中的组件列表时，服务器端 ORB 对所有已注册 IORInterceptor 实例调用 establish_components 操作。
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name

方法详细信息

establish_components

void establish_components(IORInfo info)
在汇编将包括在对象引用配置文件中的组件列表时，服务器端 ORB 对所有已注册 IORInterceptor 实例调用 establish_components 操作。没有必要对每个对象引用调用此操作。就 POA 而言，在每次调用 POA::create_POA 时将调用此操作。无论如何，要保证在单独设置服务器策略时至少调用 establish_components 一次。

establish_components 的实现不得抛出异常。如果抛出异常，则 ORB 应忽略该异常并继续调用下一个 IOR Interceptor 的 establish_components 操作。

参数：
info - IORInfo 实例，供 ORB 服务用来查询适用的策略并添加将包括在已生成 IOR 中的组件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LOCATION_FORWARD (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 LOCATION_FORWARD

public interface LOCATION_FORWARD

org/omg/PortableInterceptor/LOCATION_FORWARD.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
指示 LocationForward 应答状态。

字段详细信息

value

static final short value
指示 LocationForward 应答状态。RequestInfo.reply_status 的可能值之一。

另请参见：
RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, TRANSPORT_RETRY, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NON_EXISTENT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 NON_EXISTENT

public interface NON_EXISTENT

org/omg/PortableInterceptor/NON_EXISTENT.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
指示适配器已经被销毁的对象适配器状态。

字段详细信息

value

static final short value
指示适配器已经被销毁的对象适配器状态。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SUCCESSFUL (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 SUCCESSFUL

public interface SUCCESSFUL

org/omg/PortableInterceptor/SUCCESSFUL.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
指示一个成功的应答状态。

字段详细信息

value

static final short value
指示一个成功的应答状态。RequestInfo.reply_status 的可能值之一。

另请参见：
RequestInfoOperations.reply_status(), SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectIdHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ObjectIdHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ObjectIdHelper

public abstract class ObjectIdHelper
extends Object

对象 id 类型。此类提供对象适配器创建的特定对象的身份。

构造方法摘要
ObjectIdHelper()
方法摘要
static byte[] | extract(Any a)
static String | id()
static void | insert(Any a, byte[] that)
static byte[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, byte[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectIdHelper

public ObjectIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          byte[] that)

extract

public static byte[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static byte[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         byte[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectReferenceFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ObjectReferenceFactory

所有超级接口：
IDLEntity, Serializable, ValueBase
所有已知子接口：
ObjectReferenceTemplate
public interface ObjectReferenceFactory
extends ValueBase

对象引用工厂。此接口提供创建对象引用的能力。

方法摘要
 Object make_object(String repositoryId, byte[] object_id)
make_object 根据此模板中的数据，使用给定的存储库 ID 和对象 ID 创建 CORBA 对象引用。
从接口 org.omg.CORBA.portable.ValueBase 继承的方法
_truncatable_ids

方法详细信息

make_object

Object make_object(String repositoryId,
                   byte[] object_id)
make_object 根据此模板中的数据，使用给定的存储库 ID 和对象 ID 创建 CORBA 对象引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectReferenceFactoryHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ObjectReferenceFactoryHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

public abstract class ObjectReferenceFactoryHelper
extends Object

对象引用工厂。此接口提供创建对象引用的能力。

构造方法摘要
ObjectReferenceFactoryHelper()
方法摘要
static ObjectReferenceFactory | extract(Any a)
static String | id()
static void | insert(Any a, ObjectReferenceFactory that)
static ObjectReferenceFactory | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectReferenceFactory value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectReferenceFactoryHelper

public ObjectReferenceFactoryHelper()
方法详细信息

insert

public static void insert(Any a,
                          ObjectReferenceFactory that)

extract

public static ObjectReferenceFactory extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectReferenceFactory read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectReferenceFactory value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectReferenceFactoryHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ObjectReferenceFactoryHolder

java.lang.Object
    继承者  org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
所有已实现的接口：
Streamable
public final class ObjectReferenceFactoryHolder
extends Object
implements Streamable

对象引用工厂。此接口提供创建对象引用的能力。

字段摘要
 ObjectReferenceFactory value
构造方法摘要
ObjectReferenceFactoryHolder()
ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public ObjectReferenceFactory value
构造方法详细信息

ObjectReferenceFactoryHolder

public ObjectReferenceFactoryHolder()

ObjectReferenceFactoryHolder

public ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectReferenceTemplate (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ObjectReferenceTemplate

所有超级接口：
IDLEntity, ObjectReferenceFactory, Serializable, ValueBase
public interface ObjectReferenceTemplate
extends ObjectReferenceFactory

对象引用模板。每个在 ORB 中创建的对象适配器都必须存在一个此类的实例。server_id、orb_id 和 adapter_name 属性唯一地标识 IMR 范围内的这种模块。注意，在相同范围内 adapter_id 同样也是唯一的，但它是透明的，在很多情况下并不适用。

方法摘要
String[] | adapter_name()
String | orb_id()
String | server_id()
从接口 org.omg.PortableInterceptor.ObjectReferenceFactory 继承的方法
make_object
从接口 org.omg.CORBA.portable.ValueBase 继承的方法
_truncatable_ids

方法详细信息

server_id

String server_id()

orb_id

String orb_id()

adapter_name

String[] adapter_name()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectReferenceTemplateHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ObjectReferenceTemplateHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

public abstract class ObjectReferenceTemplateHelper
extends Object

对象引用模板。每个在 ORB 中创建的对象适配器都必须存在一个此类的实例。server_id、orb_id 和 adapter_name 属性唯一地标识 IMR 范围内的这种模块。注意，在相同范围内 adapter_id 同样也是唯一的，但它是透明的，在很多情况下并不适用。

构造方法摘要
ObjectReferenceTemplateHelper()
方法摘要
static ObjectReferenceTemplate | extract(Any a)
static String | id()
static void | insert(Any a, ObjectReferenceTemplate that)
static ObjectReferenceTemplate | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectReferenceTemplate value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectReferenceTemplateHelper

public ObjectReferenceTemplateHelper()
方法详细信息

insert

public static void insert(Any a,
                          ObjectReferenceTemplate that)

extract

public static ObjectReferenceTemplate extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectReferenceTemplate read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectReferenceTemplate value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectReferenceTemplateHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ObjectReferenceTemplateHolder

java.lang.Object
    继承者  org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
所有已实现的接口：
Streamable
public final class ObjectReferenceTemplateHolder
extends Object
implements Streamable

对象引用模板。每个在 ORB 中创建的对象适配器都必须存在一个此类的实例。server_id、orb_id 和 adapter_name 属性唯一地标识 IMR 范围内的这种模块。注意，在相同范围内 adapter_id 同样也是唯一的，但它是透明的，在很多情况下并不适用。

字段摘要
 ObjectReferenceTemplate value
构造方法摘要
ObjectReferenceTemplateHolder()
ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public ObjectReferenceTemplate value
构造方法详细信息

ObjectReferenceTemplateHolder

public ObjectReferenceTemplateHolder()

ObjectReferenceTemplateHolder

public ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectReferenceTemplateSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ObjectReferenceTemplateSeqHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

public abstract class ObjectReferenceTemplateSeqHelper
extends Object

对象引用模板序列用来报告不发生在适配器管理器的状态更改。

构造方法摘要
ObjectReferenceTemplateSeqHelper()
方法摘要
static ObjectReferenceTemplate[] | extract(Any a)
static String | id()
static void | insert(Any a, ObjectReferenceTemplate[] that)
static ObjectReferenceTemplate[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ObjectReferenceTemplate[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectReferenceTemplateSeqHelper

public ObjectReferenceTemplateSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          ObjectReferenceTemplate[] that)

extract

public static ObjectReferenceTemplate[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ObjectReferenceTemplate[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ObjectReferenceTemplate[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectReferenceTemplateSeqHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ObjectReferenceTemplateSeqHolder

java.lang.Object
    继承者  org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
所有已实现的接口：
Streamable
public final class ObjectReferenceTemplateSeqHolder
extends Object
implements Streamable

对象引用模板序列用来报告不发生在适配器管理器的状态更改。

字段摘要
 ObjectReferenceTemplate[] value
构造方法摘要
ObjectReferenceTemplateSeqHolder()
ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public ObjectReferenceTemplate[] value
构造方法详细信息

ObjectReferenceTemplateSeqHolder

public ObjectReferenceTemplateSeqHolder()

ObjectReferenceTemplateSeqHolder

public ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ORBIdHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ORBIdHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ORBIdHelper

public abstract class ORBIdHelper
extends Object

org/omg/PortableInterceptor/ORBIdHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

构造方法摘要
ORBIdHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ORBIdHelper

public ORBIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ORBInitializer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ORBInitializer

所有超级接口：
IDLEntity, Object, ORBInitializerOperations, Serializable
public interface ORBInitializer
extends ORBInitializerOperations, Object, IDLEntity

便于注册 interceptor 和初始化 ORB。

ORB 服务凭借 Interceptor 这一方法获得进行 ORB 处理的权力，Interceptor 实际上已成为 ORB 的一部分。因为 Interceptor 是 ORB 的一部分，所以当 ORB.init 返回 ORB 时，应该已经注册了 Interceptor。在已经调用 ORB.init 返回 Interceptor 后，不能在 ORB 上注册 Interceptor。

通过注册实现 ORBInitializer 接口的关联的 ORBInitializer 对象才能注册 Interceptor。ORB 在初始化时，应该调用每个已注册 ORBInitializer，并将用来注册其 Interceptor 的 ORBInitInfo 对象传递给该 ORB。

用 Java 注册 ORB Initializer

ORBInitializer 通过 Java ORB 属性注册。

属性名称的形式如下：

org.omg.PortableInterceptor.ORBInitializerClass.<Service>
其中 <Service> 是实现以下类的字符串名称：
org.omg.PortableInterceptor.ORBInitializer
要避免名称冲突，应使用与 DNS 名称约定相反的约定。例如，如果 X 公司有三个 initializer，则它能够定义以下属性：
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
在 ORB.init 期间，应该收集那些以 org.omg.PortableInterceptor.ORBInitializerClass 开头的属性，提取每个属性的 <Service> 部分，然后将该 <Service> 字符串作为类名来实例化某个对象，并对该对象调用 pre_init 和 post_init 方法。如果存在异常，ORB 应忽略这些异常并继续进行。

示例

例如，X 公司编写的客户端登陆可能具有以下 ORBInitializer 实现：

 package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
要运行使用此日志记录服务的名为 MyApp 的程序，用户可以键入：
java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

注册 Interceptor 的有关注意事项：

每个 ORB 都要注册请求 Interceptor。

要获得虚拟的针对对象的 Interceptor，应在截取点内的目标上查询策略以确定它们是否应该执行某些操作。

要获得虚拟的针对 POA 的 Interceptor，应使用不同的 ORB 实例化每个 POA。虽然在管理上 Interceptor 是有序的，但注册 Interceptor 时并不需要按顺序进行。请求 Interceptor 参与服务上下文。服务上下文没有顺序，因此请求 Interceptor 也没有必要有顺序。IOR Interceptor 参与带标记的组件。带标记的组件没有顺序，因此 IOR Interceptor 也没有必要有顺序。

注册代码应该避免使用 ORB（即使用提供的 orb_id 调用 ORB.init）。因为注册发生在初始化 ORB 期间，对出于此状态的 ORB 进行调用的结果是不确定的。

另请参见：
ORBInitInfo

方法摘要
从接口 org.omg.PortableInterceptor.ORBInitializerOperations 继承的方法
post_init, pre_init
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ORBInitializerOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ORBInitializerOperations

所有已知子接口：
ORBInitializer
public interface ORBInitializerOperations

便于注册 interceptor 和初始化 ORB。

ORB 服务凭借 Interceptor 这一方法获得进行 ORB 处理的权力，Interceptor 实际上已成为 ORB 的一部分。因为 Interceptor 是 ORB 的一部分，所以当 ORB.init 返回 ORB 时，应该已经注册了 Interceptor。在已经调用 ORB.init 返回 Interceptor 后，不能在 ORB 上注册 Interceptor。

通过注册实现 ORBInitializer 接口的关联的 ORBInitializer 对象才能注册 Interceptor。ORB 在初始化时，应该调用每个已注册 ORBInitializer，并将用来注册其 Interceptor 的 ORBInitInfo 对象传递给该 ORB。

用 Java 注册 ORB Initializer

ORBInitializer 通过 Java ORB 属性注册。

属性名称的形式如下：

org.omg.PortableInterceptor.ORBInitializerClass.<Service>
其中 <Service> 是实现以下类的字符串名称：
org.omg.PortableInterceptor.ORBInitializer
要避免名称冲突，应使用与 DNS 名称约定相反的约定。例如，如果 X 公司有三个 initializer，则它能够定义以下属性：
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
  • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
在 ORB.init 期间，应该收集那些以 org.omg.PortableInterceptor.ORBInitializerClass 开头的属性，提取每个属性的 <Service> 部分，然后将该 <Service> 字符串作为类名来实例化某个对象，并对该对象调用 pre_init 和 post_init 方法。如果存在异常，ORB 应忽略这些异常并继续进行。

示例

例如，X 公司编写的客户端登陆可能具有以下 ORBInitializer 实现：

 package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
要运行使用此日志记录服务的名为 MyApp 的程序，用户可以键入：
java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

注册 Interceptor 的有关注意事项：

每个 ORB 都要注册请求 Interceptor。

要获得虚拟的针对对象的 Interceptor，应在截取点内的目标上查询策略以确定它们是否应该执行某些操作。

要获得虚拟的针对 POA 的 Interceptor，应使用不同的 ORB 实例化每个 POA。虽然在管理上 Interceptor 是有序的，但注册 Interceptor 时并不需要按顺序进行。请求 Interceptor 参与服务上下文。服务上下文没有顺序，因此请求 Interceptor 也没有必要有顺序。IOR Interceptor 参与带标记的组件。带标记的组件没有顺序，因此 IOR Interceptor 也没有必要有顺序。

注册代码应该避免使用 ORB（即使用提供的 orb_id 调用 ORB.init）。因为注册发生在初始化 ORB 期间，对出于此状态的 ORB 进行调用的结果是不确定的。

另请参见：
ORBInitInfo

方法摘要
void | post_init(ORBInitInfo info) 初始化 ORB 期间调用此方法。
void | pre_init(ORBInitInfo info) 初始化 ORB 期间调用此方法。

方法详细信息

pre_init

void pre_init(ORBInitInfo info)
初始化 ORB 期间调用此方法。如果希望 interceptor 注册的初始服务可以供其他 interceptor 使用，则应该在此时通过调用 ORBInitInfo.register_initial_reference 注册那些初始服务。

参数：
info - 提供 Interceptor 据以注册的初始化属性和操作。

post_init

void post_init(ORBInitInfo info)
初始化 ORB 期间调用此方法。如果服务必须作为其初始化的一部分解析初始引用，则它应该假定此时所有的初始引用均可用。

调用 post_init 操作并不是初始化 ORB 的最后一项工作。调用 post_init 之后的最后一项工作是将已注册 interceptor 列表附加到 ORB。因此，在调用 post_init 期间，ORB 不包含 interceptor。如果从 post_init 内部进行间接 ORB 调用，则在该调用上不会调用任何请求 interceptor。类似的，如果执行了导致创建 IOR 的操作，也不会调用任何 IOR interceptor。

参数：
info - 提供 Interceptor 据以注册的初始化属性和操作。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ORBInitInfo (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ORBInitInfo

所有超级接口：
IDLEntity, Object, ORBInitInfoOperations, Serializable
public interface ORBInitInfo
extends ORBInitInfoOperations, Object, IDLEntity

传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。

ORBInitInfo 对象只在 ORB.init 期间有效。如果服务保持对其 ORBInitInfo 对象的引用，并试图在 ORB.init 返回后使用该对象，则该对象将不再存在，并抛出 OBJECT_NOT_EXIST 异常。

另请参见：
ORBInitializer

方法摘要
从接口 org.omg.PortableInterceptor.ORBInitInfoOperations 继承的方法
add_client_request_interceptor, add_ior_interceptor, add_server_request_interceptor, allocate_slot_id, arguments, codec_factory, orb_id, register_initial_reference, register_policy_factory, resolve_initial_references
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ORBInitInfoOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ORBInitInfoOperations

所有已知子接口：
ORBInitInfo
public interface ORBInitInfoOperations

传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。

ORBInitInfo 对象只在 ORB.init 期间有效。如果服务保持对其 ORBInitInfo 对象的引用，并试图在 ORB.init 返回后使用该对象，则该对象将不再存在，并抛出 OBJECT_NOT_EXIST 异常。

另请参见：
ORBInitializer

方法摘要
void | add_client_request_interceptor(ClientRequestInterceptor interceptor) 此方法用来将客户端的请求 Interceptor 添加到客户端请求 Interceptor 列表。
void | add_ior_interceptor(IORInterceptor interceptor) 此方法用来将 IOR Interceptor 添加到 IOR Interceptor 列表。
void | add_server_request_interceptor(ServerRequestInterceptor interceptor) 此方法用来将服务器端的请求 Interceptor 添加到服务器端请求 Interceptor 列表。
int | allocate_slot_id() 调用此方法来在 PortableInterceptor.Current 上分配槽 (slot)。
String[] | arguments() 返回传递给 ORB.init 的参数。
CodecFactory | codec_factory() 返回 IOP.CodecFactory。
String | orb_id() 返回将被初始化的 ORB 的 ID。
void | register_initial_reference(String id, Object obj) 等同于 ORB.register_initial_reference。
void | register_policy_factory(int type, PolicyFactory policy_factory) 注册给定 PolicyType 的 PolicyFactory。
Object | resolve_initial_references(String id) 等同于 ORB.resolve_initial_references。

方法详细信息

arguments

String[] arguments()
返回传递给 ORB.init 的参数。它们可能包含 ORB 的参数，也可能不包含。

orb_id

String orb_id()
返回将被初始化的 ORB 的 ID。

codec_factory

CodecFactory codec_factory()
返回 IOP.CodecFactory。通常通过调用 ORB.resolve_initial_references( "CodecFactory" ) 获取 CodecFactory，但是因为 ORB 当前不可用，而且 Interceptor（尤其是在处理服务上下文时）将请求 Codec，所以必须在初始化 ORB 时获取 Codec 的方法。

register_initial_reference

void register_initial_reference(String id,
                                Object obj)
                                throws InvalidName
等同于 ORB.register_initial_reference。这里提供一个具有相同功能的方法是因为：未完全初始化的 ORB 当前不可用，但是初始引用可能需要作为 Interceptor 注册的一部分被注册。唯一的不同之处在于，ORB 中的这一操作使用 PIDL (CORBA.ORB.ObjectId) 和 (CORBA.ORB.InvalidName)，而此接口中的这一操作使用此接口中定义的 IDL；语义是等同的。

抛出：
InvalidName

resolve_initial_references

Object resolve_initial_references(String id)
                                  throws InvalidName
等同于 ORB.resolve_initial_references。这里提供一个具有相同功能的方法是因为：未完全初始化的 ORB 当前不可用，但是 ORB 中的初始引用可能需要作为 Interceptor 注册的一部分。唯一的不同之处在于，ORB 中的这一操作使用 PIDL (CORBA::ORB::ObjectId) 和 (CORBA::ORB::InvalidName)，而此接口中的这一操作使用此接口中定义的 IDL；语义是等同的。

此操作仅在 post_init 期间有效。

抛出：
InvalidName

add_client_request_interceptor

void add_client_request_interceptor(ClientRequestInterceptor interceptor)
                                    throws DuplicateName
此方法用来将客户端的请求 Interceptor 添加到客户端请求 Interceptor 列表。

参数：
interceptor - 要添加的 ClientRequestInterceptor。
抛出：
DuplicateName - 如果客户端的请求 Interceptor 已经使用此 Interceptor 的名称注册。

add_server_request_interceptor

void add_server_request_interceptor(ServerRequestInterceptor interceptor)
                                    throws DuplicateName
此方法用来将服务器端的请求 Interceptor 添加到服务器端请求 Interceptor 列表。

参数：
interceptor - 要添加的 ServerRequestInterceptor。
抛出：
DuplicateName - 如果服务器端的请求 Interceptor 已经使用此 Interceptor 的名称注册。

add_ior_interceptor

void add_ior_interceptor(IORInterceptor interceptor)
                         throws DuplicateName
此方法用来将 IOR Interceptor 添加到 IOR Interceptor 列表。

参数：
interceptor - 要添加的 IORInterceptor。
抛出：
DuplicateName - 如果 IOR Interceptor 已经使用此 Interceptor 名称注册。

allocate_slot_id

int allocate_slot_id()
调用此方法来在 PortableInterceptor.Current 上分配槽 (slot)。

注意，可以在 ORB 初始化程序中分配槽的 id，但不能初始化槽本身。

返回：
已经分配的槽的索引。
抛出：
BAD_INV_ORDER - 如果在 ORB 初始化程序内对 PICurrent 调用 set_slot 或 get_slot，则抛出此异常并带有标准次要代码 14。
另请参见：
Current

register_policy_factory

void register_policy_factory(int type,
                             PolicyFactory policy_factory)
注册给定 PolicyType 的 PolicyFactory。

参数：
type - 给定 PolicyFactory 服务的策略类型。
policy_factory - 给定策略类型的工厂。
抛出：
BAD_INV_ORDER - 如果已经存在给定 PolicyType 的 PolicyFactory，则抛出此异常并带有标准次要代码 16。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 PolicyFactory

所有超级接口：
IDLEntity, Object, PolicyFactoryOperations, Serializable
public interface PolicyFactory
extends PolicyFactoryOperations, Object, IDLEntity

使得策略类型能够使用 CORBA.ORB.create_policy 来构建。

可移植 ORB 服务实现在初始化 ORB 期间注册了 PolicyFactory 接口的实例，以便允许使用 CORBA.ORB.create_policy 构建其策略类型。要求 POA 保存任何以此方式向 ORBInitInfo 注册的策略。

另请参见：
ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

方法摘要
从接口 org.omg.PortableInterceptor.PolicyFactoryOperations 继承的方法
create_policy
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyFactoryOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 PolicyFactoryOperations

所有已知子接口：
PolicyFactory
public interface PolicyFactoryOperations

使得策略类型能够通过 CORBA.ORB.create_policy 构建。

可移植 ORB 服务实现在初始化 ORB 期间注册了 PolicyFactory 接口的实例，以便允许使用 CORBA.ORB.create_policy 构建其策略类型。要求 POA 保存任何以此方式向 ORBInitInfo 注册的策略。

另请参见：
ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

方法摘要
 Policy create_policy(int type, Any value)
返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。

方法详细信息

create_policy

Policy create_policy(int type,
                     Any value)
                     throws PolicyError
返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。

当为已注册 PolicyFactory 的 PolicyType 调用 CORBA.ORB.create_policy 时，ORB 对已注册 PolicyFactory 实例调用 create_policy。然后，create_policy 将返回一个派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。如果它无法返回，则根据对 CORBA.ORB.create_policy 的相关描述抛出异常。

参数：
type - 一个 int，指定将创建的策略的类型。
value - any，包含用来构造 CORBA.Policy 的数据。
返回：
具有指定类型和值的 CORBA.Policy 对象。
抛出：
PolicyError
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestInfo (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 RequestInfo

所有超级接口：
IDLEntity, Object, RequestInfoOperations, Serializable
所有已知子接口：
ClientRequestInfo, ServerRequestInfo
public interface RequestInfo
extends RequestInfoOperations, Object, IDLEntity

Interceptor 可访问的请求信息。

每个截取点都给定了一个对象，Interceptor 可以通过该对象访问请求信息。客户端和服务器端的截取点关注不同的信息，因此有两种信息对象：ClientRequestInfo 传递给客户端的截取点，ServerRequestInfo 传递给服务器端的截取点。但也有两者都需要的信息，所以这两个接口继承自同一个接口：RequestInfo。

另请参见：
ClientRequestInfo, ServerRequestInfo

方法摘要
从接口 org.omg.PortableInterceptor.RequestInfoOperations 继承的方法
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestInfoOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 RequestInfoOperations

所有已知子接口：
ClientRequestInfo, ClientRequestInfoOperations, RequestInfo, ServerRequestInfo, ServerRequestInfoOperations
public interface RequestInfoOperations

Interceptor 可访问的请求信息。

每个截取点都给定了一个对象，Interceptor 可以通过该对象访问请求信息。客户端和服务器端的截取点关注不同的信息，因此有两种信息对象：ClientRequestInfo 传递给客户端的截取点，ServerRequestInfo 传递给服务器端的截取点。但也有两者都需要的信息，所以这两个接口继承自同一个接口：RequestInfo。

另请参见：
ClientRequestInfo, ServerRequestInfo

方法摘要
Parameter[] | arguments() 返回一个 Parameter 对象数组，包含将调用的操作上的参数。
String[] | contexts() 返回一个 String 对象数组，这些对象描述可以在此操作调用上传递的上下文。
TypeCode[] | exceptions() 返回一个 TypeCode 对象数组，这些对象描述此操作调用可能抛出的用户异常的 TypeCode。
Object | forward_reference() 如果 reply_status 属性为 LOCATION_FORWARD，则包含要将请求转发到的对象。
ServiceContext | get_reply_service_context(int id) 返回具有给定 ID 的与应答关联的服务上下文复本。
ServiceContext | get_request_service_context(int id) 返回具有给定 ID 的与请求关联的服务上下文复本。
Any | get_slot(int id) 返回请求域内 PortableInterceptor.Current 给定槽 (slot) 中的数据。
String[] | operation_context() 返回一个 String 对象数组，这些对象包含将在请求上发送上下文。
String | operation() 返回将被调用的操作的名称。
short | reply_status() 描述操作调用结果的状态。
int | request_id() 返回唯一地标识激活的请求/应答序列的 id。
boolean | response_expected() 指示是否希望响应。
Any | result() 返回一个 any，它包含该操作调用的结果。
short | sync_scope() 定义在控制信息返回到客户端前请求应前进的距离。

方法详细信息

request_id

int request_id()
返回唯一地标识激活的请求/应答序列的 id。请求/应答序列一结束此 ID 即可重用。注意，此 id 不同于 GIOP request_id。如果使用的传送机制是 GIOP，则这些 ID 很可能是相同的，但是不保证也不要求如此。

operation

String operation()
返回将被调用的操作的名称。

arguments

Parameter[] arguments()
返回一个 Parameter 对象数组，包含将调用的操作上的参数。如果没有参数，则此属性将是一个 0 长度数组。

并非所有环境都提供对参数的访问。例如，使用 Java 可移植绑定时参数将不可用。在这些环境中访问此属性时，将抛出 NO_RESOURCES，并带有标准次要代码 1。

注：对于 DSI/DII 调用参数是可用的。

抛出：
NO_RESOURCES - 如果参数不可用。
另请参见：
PortableInterceptor 包中关于限制/未实现特性的注释

exceptions

TypeCode[] exceptions()
返回一个 TypeCode 对象数组，这些对象描述此操作调用可能抛出的用户异常的 TypeCode。如果没有用户异常，则此方法返回一个长度为 0 的数组。

并非所有环境都提供对异常列表的访问。例如，使用 Java 可移植绑定时异常列表将不可用。在这些环境中访问此属性时，将抛出 NO_RESOURCES，并带有标准次要代码 1。

注：异常对于 DSI/DII 调用是可用的。

抛出：
NO_RESOURCES - 如果异常不可用。
另请参见：
PortableInterceptor 包中关于限制/未实现特性的注释

contexts

String[] contexts()
返回一个 String 对象数组，这些对象描述可以在此操作调用上传递的上下文。如果没有上下文，则此方法返回一个长度为 0 的数组。

并非所有环境都提供对上下文列表的访问。例如，使用 Java 可移植绑定时上下文列表将不可用。在这些环境中访问此属性时，将抛出 NO_RESOURCES，并带有标准次要代码 1。

注：上下文对于 DSI/DII 调用是可用的。

抛出：
NO_RESOURCES - 如果上下文不可用。
另请参见：
PortableInterceptor 包中关于限制/未实现特性的注释

operation_context

String[] operation_context()
返回一个 String 对象数组，这些对象包含将在请求上发送上下文。

并非所有环境都提供对上下文的访问。例如，使用 Java 可移植绑定时上下文将不可用。在这些环境中访问此属性时，将抛出 NO_RESOURCES，并带有标准次代码 1。

注：operation_context 对于 DSI/DII 调用是可用的。

抛出：
NO_RESOURCES - 如果操作上下文不可用。
另请参见：
PortableInterceptor 包中关于限制/未实现特性的注释

result

Any result()
返回一个 any，它包含该操作调用的结果。如果操作返回类型为空，则此属性将是包含 TCKind 值为 tk_void 的类型代码的 any，并且该 any 不包含任何值。

并非所有环境都提供对结果的访问。例如，使用 Java 可移植绑定时结果将不可用。在这些环境中访问此属性时，将抛出 NO_RESOURCES，并带有标准次要代码 1。

注：结果对于 DSI/DII 调用是可用的。

抛出：
NO_RESOURCES - 如果结果不可用。
另请参见：
PortableInterceptor 包中关于限制/未实现特性的注释

response_expected

boolean response_expected()
指示是否希望响应。

对于客户端，当 response_expected 为 false 时不返回应答，因此不能调用 receive_reply。不发生异常时调用 receive_other，发生异常时调用 receive_exception。

此属性在客户端 send_poll 内部为 true。

sync_scope

short sync_scope()
定义在控制信息返回到客户端前请求应前进的距离。这已在 Messaging 规范中定义，仅当 response_expected 为 false 时才相关。如果 response_expected 为 true，则 sync_scope 的值是不确定的。此属性可以是以下值之一：
  • Messaging.SYNC_NONE
  • Messaging.SYNC_WITH_TRANSPORT
  • Messaging.SYNC_WITH_SERVER
  • Messaging.SYNC_WITH_TARGET
对于服务器所有的域而言，将从目标操作调用的返回中创建应答，但不会将该应答返回给客户端。尽管它不会返回给客户端，但确实发生了应答，因此将执行正常服务器端截取点（即 receive_request_service_contexts、receive_request、send_reply 或 send_exception）。

对于 SYNC_WITH_SERVER 和 SYNC_WITH_TARGET，在调用目标前，服务器将一个空应答发送回客户端。此应答将不会被服务器端的 Interceptor 截取。

另请参见：
PortableInterceptor 包中关于限制/未实现特性的注释

reply_status

short reply_status()
描述操作调用结果的状态。返回值可以是以下值之一：
  • PortableInterceptor.SUCCESSFUL
  • PortableInterceptor.SYSTEM_EXCEPTION
  • PortableInterceptor.USER_EXCEPTION
  • PortableInterceptor.LOCATION_FORWARD
  • PortableInterceptor.TRANSPORT_RETRY
对于客户端：
  • 在 receive_reply 截取点内，此方法仅返回 SUCCESSFUL
    • .
  • 在 receive_exception 截取点内，此方法将返回 SYSTEM_EXCEPTION 或 USER_EXCEPTION。
  • 在 receive_other 截取点内，此方法将返回以下任意值：SUCCESSFUL、LOCATION_FORWARD 或 TRANSPORT_RETRY。SUCCESSFUL 表示成功返回了异步请求。LOCATION_FORWARD 表示返回了应答，并以 LOCATION_FORWARD 作为其状态。TRANSPORT_RETRY 表示传送机制指示重试 - 例如，带有 NEEDS_ADDRESSING_MODE 状态的 GIOP 应答。
对于服务器：
  • 在 send_reply 截取点内，此方法仅返回 SUCCESSFUL
  • 在 send_exception 截取点内，此方法将返回 SYSTEM_EXCEPTION 或 USER_EXCEPTION。
  • 在 send_other 截取点内，此属性将是以下任意值：SUCCESSFUL 或 LOCATION_FORWARD。SUCCESSFUL 表示成功返回了异步请求。LOCATION_FORWARD 表示返回了应答，并以 LOCATION_FORWARD 作为其状态。

另请参见：
SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY

forward_reference

Object forward_reference()
如果 reply_status 属性为 LOCATION_FORWARD，则包含要将请求转发到的对象。转发的请求是否将实际发生是不确定的。

get_slot

Any get_slot(int id)
             throws InvalidSlot
返回请求域内 PortableInterceptor.Current 给定槽 (slot) 中的数据。

如果尚未设置给定槽，则返回一个包含 TCKind 值为 tk_null 的类型代码的 any。

参数：
id - 将返回的槽的 SlotId。
返回：
使用给定标识符获取的槽数据，以 any 的形式存在。
抛出：
InvalidSlot - 如果 ID 定义的不是已分配的槽，则抛出此异常。
另请参见：
Current

get_request_service_context

ServiceContext get_request_service_context(int id)
返回具有给定 ID 的与请求关联的服务上下文复本。

参数：
id - 将返回的服务上下文的 IOP.ServiceId。
返回：
通过给定标识符获取的 IOP.ServiceContext。
抛出：
BAD_PARAM - 如果请求的服务上下文不包含对应于该 ID 的条目，则抛出此异常，并带有标准次代码 26。

get_reply_service_context

ServiceContext get_reply_service_context(int id)
返回具有给定 ID 的与应答关联的服务上下文复本。

参数：
id - 将返回的服务上下文的 IOP.ServiceId。
返回：
具有给定标识符的 IOP.ServiceContext。
抛出：
BAD_PARAM - 如果请求的服务上下文不包含对应于该 ID 的条目，则抛出此异常，并带有标准次要代码 26。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerIdHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
类 ServerIdHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ServerIdHelper

public abstract class ServerIdHelper
extends Object

org/omg/PortableInterceptor/ServerIdHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

构造方法摘要
ServerIdHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServerIdHelper

public ServerIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerRequestInfo (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ServerRequestInfo

所有超级接口：
IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable, ServerRequestInfoOperations
public interface ServerRequestInfo
extends ServerRequestInfoOperations, RequestInfo, IDLEntity

服务器端请求 interceptor 可访问的请求信息。

某些 ServerRequestInfo 上的属性和操作并不是对所有的截取点都有效。下表展示了每个属性或操作的有效性。如果无效，则试图访问它将导致抛出 BAD_INV_ORDER，并带有标准次要代码 14。

 | receive_request_ service_contexts | receive_request | send_reply | send_exception | send_other
继承自 RequestInfo：
request_id | 是 | 是 | 是 | 是 | 是
operation | 是 | 是 | 是 | 是 | 是
arguments | 否 | 是1 | 是 | 否2 | 否2
exceptions | 否 | 是 | 是 | 是 | 是
contexts | 否 | 是 | 是 | 是 | 是
operation_context | 否 | 是 | 是 | 否 | 否
result | 否 | 否 | 是 | 否 | 否
response_expected | 是 | 是 | 是 | 是 | 是
sync_scope | 是 | 是 | 是 | 是 | 是
request_id | 是 | 是 | 是 | 是 | 是
operation | 是 | 是 | 是 | 是 | 是
arguments | 否 | 是1 | 是 | 否2 | 否2
exceptions | 否 | 是 | 是 | 是 | 是
contexts | 否 | 是 | 是 | 是 | 是
operation_context | 否 | 是 | 是 | 否 | 否
result | 否 | 否 | 是 | 否 | 否
response_expected | 是 | 是 | 是 | 是 | 是
sync_scope | 是 | 是 | 是 | 是 | 是
reply_status | 否 | 否 | 是 | 是 | 是
forward_reference | 否 | 否 | 否 | 否 | 是2
get_slot | 是 | 是 | 是 | 是 | 是
get_request_service_context | 是 | 否 | 是 | 是 | 是
get_reply_service_context | 否 | 否 | 是 | 是 | 是
特定于 ServerRequestInfo：
sending_exception | 否 | 否 | 否 | 是 | 否
object_id | 否 | 是 | 是 | 是3 | 是3
adapter_id | 否 | 是 | 是 | 是3 | 是3
server_id | 否 | 是 | 是 | 是 | 是
orb_id | 否 | 是 | 是 | 是 | 是
adapter_name | 否 | 是 | 是 | 是 | 是
target_most_derived_interface | 否 | 是 | 否4 | 否4 | 否4
get_server_policy | 是 | 是 | 是 | 是 | 是
set_slot | 是 | 是 | 是 | 是 | 是
target_is_a | 否 | 是 | 否4 | 否4 | 否4
add_reply_service_context | 是 | 是 | 是 | 是 | 是
  1. 将 ServerRequestInfo 传递给 receive_request 时，对于每个参数（无论它是 in、inout 还是 out），列表中都有一个对应的条目。但只有 in 和 inout 参数可用。
  2. 如果 reply_status 属性不是 LOCATION_FORWARD，则访问此属性将抛出 BAD_INV_ORDER，并带有标准次要代码 14。
  3. 如果 servant 定位器导致位置转发或抛出异常，则此属性/操作在此截取点不可用。如果不可用，则抛出 NO_RESOURCES，并带有标准次要代码 1。
  4. 该操作在此截取点不可用，因为必要信息要求访问目标对象的 servant，而该 servant 对于 ORB 已经不可用。例如，如果对象适配器为使用 ServantLocator 的 POA，则 ORB 将在调用 ServantLocator.postinvoke() 后调用该截取点。

另请参见：
ServerRequestInterceptor

方法摘要
从接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 继承的方法
adapter_id, adapter_name, add_reply_service_context, get_server_policy, object_id, orb_id, sending_exception, server_id, set_slot, target_is_a, target_most_derived_interface
从接口 org.omg.PortableInterceptor.RequestInfoOperations 继承的方法
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerRequestInfoOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ServerRequestInfoOperations

所有超级接口：
RequestInfoOperations
所有已知子接口：
ServerRequestInfo
public interface ServerRequestInfoOperations
extends RequestInfoOperations

服务器端请求 interceptor 可访问的请求信息。

某些 ServerRequestInfo 上的属性和操作并不是对所有的截取点都有效。下表展示了每个属性或操作的有效性。如果无效，则试图访问它将导致抛出 BAD_INV_ORDER，并带有标准次要代码 14。

 | receive_request_ service_contexts | receive_request | send_reply | send_exception | send_other
继承自 RequestInfo：
request_id | 是 | 是 | 是 | 是 | 是
operation | 是 | 是 | 是 | 是 | 是
arguments | 否 | 是1 | 是 | 否2 | 否2
exceptions | 否 | 是 | 是 | 是 | 是
contexts | 否 | 是 | 是 | 是 | 是
operation_context | 否 | 是 | 是 | 否 | 否
result | 否 | 否 | 是 | 否 | 否
response_expected | 是 | 是 | 是 | 是 | 是
sync_scope | 是 | 是 | 是 | 是 | 是
request_id | 是 | 是 | 是 | 是 | 是
operation | 是 | 是 | 是 | 是 | 是
arguments | 否 | 是1 | 是 | 否2 | 否2
exceptions | 否 | 是 | 是 | 是 | 是
contexts | 否 | 是 | 是 | 是 | 是
operation_context | 否 | 是 | 是 | 否 | 否
result | 否 | 否 | 是 | 否 | 否
response_expected | 是 | 是 | 是 | 是 | 是
sync_scope | 是 | 是 | 是 | 是 | 是
reply_status | 否 | 否 | 是 | 是 | 是
forward_reference | 否 | 否 | 否 | 否 | 是2
get_slot | 是 | 是 | 是 | 是 | 是
get_request_service_context | 是 | 否 | 是 | 是 | 是
get_reply_service_context | 否 | 否 | 是 | 是 | 是
特定于 ServerRequestInfo：
sending_exception | 否 | 否 | 否 | 是 | 否
object_id | 否 | 是 | 是 | 是3 | 是3
adapter_id | 否 | 是 | 是 | 是3 | 是3
server_id | 否 | 是 | 是 | 是 | 是
orb_id | 否 | 是 | 是 | 是 | 是
adapter_name | 否 | 是 | 是 | 是 | 是
target_most_derived_interface | 否 | 是 | 否4 | 否4 | 否4
get_server_policy | 是 | 是 | 是 | 是 | 是
set_slot | 是 | 是 | 是 | 是 | 是
target_is_a | 否 | 是 | 否4 | 否4 | 否4
add_reply_service_context | 是 | 是 | 是 | 是 | 是
  1. 将 ServerRequestInfo 传递给 receive_request 时，对于每个参数（无论它是 in、inout 还是 out），列表中都有一个对应的条目。但只有 in 和 inout 参数可用。
  2. 如果 reply_status 属性不是 LOCATION_FORWARD，则访问此属性将抛出 BAD_INV_ORDER，并带有标准次要代码 14。
  3. 如果 servant 定位器导致位置转发或抛出异常，则此属性/操作在此截取点不可用。如果不可用，则抛出 NO_RESOURCES，并带有标准次要代码 1。
  4. 该操作在此截取点不可用，因为必要信息要求访问目标对象的 servant，而该 servant 对于 ORB 已经不可用。例如，如果对象适配器为使用 ServantLocator 的 POA，则 ORB 将在调用 ServantLocator.postinvoke() 后调用该截取点。

另请参见：
ServerRequestInterceptor

方法摘要
 byte[] adapter_id()
返回对象适配器的不透明标识符。
 String[] adapter_name()
返回字符串序列，这些字符串标识正处理此请求的对象适配器实例。
 void add_reply_service_context(ServiceContext service_context, boolean replace)
允许 Interceptor 将服务上下文添加到请求。
 Policy get_server_policy(int type)
返回此操作实行的具有给定策略类型的策略。
 byte[] object_id()
返回描述该操作调用目标的不透明 object_id。
 String orb_id()
返回用于创建 ORB 的 ID。
 Any sending_exception()
返回一个 any，它包含将向客户端返回的异常。
 String server_id()
返回使用 -ORBServerId 参数的 ORB::init 上指定的服务器 ID。
 void set_slot(int id, Any data)
允许 Interceptor 在请求域中的 PortableInterceptor.Current 内设置槽 (slot)。
 boolean target_is_a(String id)
如果 servant 是给定的存储库 id，则返回 true；若不是则返回 false。
 String target_most_derived_interface()
返回 servant 最终派生接口的存储库 id。
从接口 org.omg.PortableInterceptor.RequestInfoOperations 继承的方法
arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

方法详细信息

sending_exception

Any sending_exception()
返回一个 any，它包含将向客户端返回的异常。

如果异常是不能插入 any 的用户异常（例如，该异常是未知的或绑定不提供 TypeCode），则此属性将是一个包含系统异常 UNKNOWN 并带有标准次要代码 1 的 any。

另请参见：
PortableInterceptor 包中关于限制/未实现特性的注释

object_id

byte[] object_id()
返回描述该操作调用目标的不透明 object_id。

adapter_id

byte[] adapter_id()
返回对象适配器的不透明标识符。

server_id

String server_id()
返回使用 -ORBServerId 参数的 ORB::init 上指定的服务器 ID。

orb_id

String orb_id()
返回用于创建 ORB 的 ID。

adapter_name

String[] adapter_name()
返回字符串序列，这些字符串标识正处理此请求的对象适配器实例。

target_most_derived_interface

String target_most_derived_interface()
返回 servant 最终派生接口的存储库 id。

get_server_policy

Policy get_server_policy(int type)
返回此操作实行的具有给定策略类型的策略。返回的 CORBA.Policy 对象只应该是通过 register_policy_factory 注册了其类型的策略。

参数：
type - 指定将返回的策略的 CORBA.PolicyType。
返回：
通过给定策略类型获取的 CORBA.Policy。
抛出：
INV_POLICY - 如果没有通过 register_policy_factory 注册给定类型的策略，则抛出此异常，并带有标准次要代码 2。
另请参见：
ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

set_slot

void set_slot(int id,
              Any data)
              throws InvalidSlot
允许 Interceptor 在请求域中的 PortableInterceptor.Current 内设置槽 (slot)。如果该槽中已存在数据，则将其重写。

参数：
id - 槽的 id。
data - 存储在槽中的数据，以 any 的形式存在。
抛出：
InvalidSlot - 如果 ID 定义的不是已分配的槽，则抛出此异常。
另请参见：
Current

target_is_a

boolean target_is_a(String id)
如果 servant 是给定的存储库 id，则返回 true；若不是则返回 false。

参数：
id - 调用者将检验 servant 是否是此存储库 id。
返回：
servant 是否是给定的 RepositoryId。

add_reply_service_context

void add_reply_service_context(ServiceContext service_context,
                               boolean replace)
允许 Interceptor 将服务上下文添加到请求。

没有对服务上下文的顺序做出任何声明。它们可能按添加的顺序出现，也可能不是如此。

参数：
service_context - 将添加到应答的 IOP.ServiceContext。
replace - 在已经存在具有给定 ID 的服务上下文时指示此操作的行为。如果为 false，则抛出 BAD_INV_ORDER，并带有标准次要代码 15。如果为 true，则用新服务上下文取代现有的服务上下文。
抛出：
BAD_INV_ORDER - 如果 replace 为 false 且已经存在具有给定 ID 的服务上下文，则抛出此异常，并带有标准次代码 15。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerRequestInterceptor (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ServerRequestInterceptor

所有超级接口：
IDLEntity, Interceptor, InterceptorOperations, Object, Serializable, ServerRequestInterceptorOperations
public interface ServerRequestInterceptor
extends ServerRequestInterceptorOperations, Interceptor, IDLEntity

服务器端的请求 interceptor。

请求 Interceptor 用于通过 ORB 在指定点截取请求/应答序列流，以便服务能够查询请求信息并操作在客户端和服务器之间传播的服务上下文。请求 Interceptor 主要用途是使 ORB 服务能够在客户端和服务器之间传输上下文信息。请求 Interceptor 有两种类型：客户端和服务器端。

编写服务器端 Interceptor 需要实现 ServerRequestInterceptor 接口。

另请参见：
ServerRequestInfo

方法摘要
从接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 继承的方法
receive_request_service_contexts, receive_request, send_exception, send_other, send_reply
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerRequestInterceptorOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 ServerRequestInterceptorOperations

所有超级接口：
InterceptorOperations
所有已知子接口：
ServerRequestInterceptor
public interface ServerRequestInterceptorOperations
extends InterceptorOperations

服务器端的请求 interceptor。

请求 Interceptor 用于通过 ORB 在指定点截取请求/应答序列流，以便服务能够查询请求信息并操作在客户端和服务器之间传播的服务上下文。请求 Interceptor 主要用途是使 ORB 服务能够在客户端和服务器之间传输上下文信息。请求 Interceptor 有两种类型：客户端和服务器端。

编写服务器端 Interceptor 需要实现 ServerRequestInterceptor 接口。

另请参见：
ServerRequestInfo

方法摘要
void | receive_request_service_contexts(ServerRequestInfo ri) 允许 interceptor 处理服务上下文信息。
void | receive_request(ServerRequestInfo ri) 允许 Interceptor 在所有信息（包括操作参数）可用后查询信息。
void | send_exception(ServerRequestInfo ri) 允许 Interceptor 在向客户端抛出异常前查询异常信息并修改应答服务上下文。
void | send_other(ServerRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | send_reply(ServerRequestInfo ri) 允许 Interceptor 在已调用目标操作后、向客户端返回应答前查询应答信息并修改应答服务上下文。
从接口 org.omg.PortableInterceptor.InterceptorOperations 继承的方法
destroy, name

方法详细信息

receive_request_service_contexts

void receive_request_service_contexts(ServerRequestInfo ri)
                                      throws ForwardRequest
允许 interceptor 处理服务上下文信息。

在此截取点，Interceptor 必须从传入请求获取其服务上下文信息，并将其传输到 PortableInterceptor.Current 的槽 (slot)。

在调用 servant 管理器之前调用此截取点。此时操作参数尚未可用。此截取点可能执行与目标调用相同的线程，也可能不执行。

此截取点可能抛出系统异常。如果抛出异常，则不调用任何其他 Interceptor 的 receive_request_service_contexts 操作。移除那些 Flow Stack 上的 Interceptor 并调用其 send_exception 截取点。

此截取点同样可能抛出 ForwardRequest 异常。如果 Interceptor 抛出此异常，则不调用任何其他 Interceptor 的 receive_request_service_contexts 操作。移除那些 Flow Stack 上的 Interceptor 并调用其 send_other 截取点。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。completion_status 应为 COMPLETED_NO。

参数：
ri - 关于将被截取的当前请求的信息。
抛出：
ForwardRequest - 抛出此异常指示 ORB 重试请求应该与异常中给定的新对象一起发生。

receive_request

void receive_request(ServerRequestInfo ri)
                     throws ForwardRequest
允许 Interceptor 在所有信息（包括操作参数）可用后查询信息。此截取点应该执行与目标调用相同的线程。

在 DSI 模型中，因为在用户代码调用 arguments 时参数首次可用，所以将从 arguments 内部调用 receive_request。有可能不是在 DSI 模型中调用 arguments。目标可以在调用 arguments 之前调用 set_exception。ORB 应保证通过 arguments 或 set_exception 调用 receive_request 一次。如果通过 set_exception 调用，则请求参数将导致抛出 NO_RESOURCES，并带有标准次要代码 1。

此截取点可能抛出系统异常。如果抛出异常，则不调用任何其他 Interceptor 的 receive_request 操作。移除那些 Flow Stack 上的 Interceptor 并调用其 send_exception 截取点。

此截取点同样可能抛出 ForwardRequest 异常。如果 Interceptor 抛出此异常，则不调用任何其他 Interceptor 的 receive_request 操作。移除那些 Flow Stack 上的 Interceptor 并调用其 send_other 截取点。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。completion_status 应为 COMPLETED_NO。

参数：
ri - 关于将被截取的当前请求的信息。
抛出：
ForwardRequest - 抛出此异常指示 ORB 重试请求应该与异常中给定的新对象一起发生。

send_reply

void send_reply(ServerRequestInfo ri)
允许 Interceptor 在已调用目标操作后、向客户端返回应答前查询应答信息并修改应答服务上下文。此截取点应该执行与目标调用相同的线程。

此截取点可能抛出系统异常。如果抛出异常，则不调用任何其他 Interceptor 的 send_reply 操作。Flow Stack 中剩余的 Interceptor 将使其 send_exception 截取点被调用。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。completion_status 应为 COMPLETED_YES。

参数：
ri - 关于将被截取的当前请求的信息。

send_exception

void send_exception(ServerRequestInfo ri)
                    throws ForwardRequest
允许 Interceptor 在向客户端抛出异常前查询异常信息并修改应答服务上下文。当发生异常时，将调用此截取点。此截取点应该执行与目标调用相同的线程。

此截取点可能抛出系统异常。这可以更改连续 Interceptor（从 Flow Stack 中移除的）调用 send_exception 收到的异常。对客户端抛出的异常将是 Interceptor 抛出的最终异常或者原始异常（如果没有 Interceptor 更改了异常）。

此截取点同样可能抛出 ForwardRequest 异常。如果 Interceptor 抛出此异常，则不调用任何其他 Interceptor 的 send_exception 操作。将调用 Flow Stack 中剩余 Interceptor 的 send_other 截取点。

如果异常的 completion_status 不是 COMPLETED_NO，则此截取点抛出 ForwardRequest 异常是不恰当的。将失去请求的最多一次 (at-most-once) 语义。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。如果原始异常为系统异常，则新异常的 completion_status 将与原始异常相同。如果原始异常为用户异常，则新异常的 completion_status 应为 COMPLETED_YES。

参数：
ri - 关于将被截取的当前请求的信息。
抛出：
ForwardRequest - 抛出此异常指示 ORB 重试请求应该与异常中给定的新对象一起发生。

send_other

void send_other(ServerRequestInfo ri)
                throws ForwardRequest
允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。例如，请求可以引起重试（例如，收到带有 LOCATION_FORWARD 状态的 GIOP 应答）。此截取点应该执行与目标调用相同的线程。

此截取点可能抛出系统异常。如果抛出异常，则不调用任何其他 Interceptor 的 send_other 操作。将调用 Flow Stack 中剩余 Interceptor 的 send_exception 截取点。

此截取点同样可能抛出 ForwardRequest 异常。如果 Interceptor 抛出此异常，则使用 ForwardRequest 异常提供的新信息调用连续 Interceptor 的 send_other 操作。

如果符合的 Interceptor 从此截取点抛出系统异常，则它们应该完全遵守 completion_status 语义。completion_status 应为 COMPLETED_NO。

参数：
ri - 关于将被截取的当前请求的信息。
抛出：
ForwardRequest - 抛出此异常指示 ORB 重试请求应该与异常中给定的新对象一起发生。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SYSTEM_EXCEPTION (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 SYSTEM_EXCEPTION

public interface SYSTEM_EXCEPTION

org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
指示 SystemException 应答状态。

字段详细信息

value

static final short value
指示 SystemException 应答状态。RequestInfo.reply_status 的可能值之一。

另请参见：
RequestInfoOperations.reply_status(), SUCCESSFUL, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TRANSPORT_RETRY (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 TRANSPORT_RETRY

public interface TRANSPORT_RETRY

org/omg/PortableInterceptor/TRANSPORT_RETRY.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
指示 Transport Retry 应答状态。

字段详细信息

value

static final short value
指示 Transport Retry 应答状态。RequestInfo.reply_status 的可能值之一。

另请参见：
RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UNKNOWN (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 UNKNOWN

public interface UNKNOWN

org/omg/PortableInterceptor/UNKNOWN.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
XXX

字段详细信息

value

static final short value
XXX

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


USER_EXCEPTION (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor
接口 USER_EXCEPTION

public interface USER_EXCEPTION

org/omg/PortableInterceptor/USER_EXCEPTION.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
static short value
指示 UserException 应答状态。

字段详细信息

value

static final short value
指示 UserException 应答状态。RequestInfo.reply_status 的可能值之一。

另请参见：
RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.PortableInterceptor (Java Platform SE 6)

 org.omg.PortableInterceptor
接口
ACTIVE
ClientRequestInfo
ClientRequestInfoOperations
ClientRequestInterceptor
ClientRequestInterceptorOperations
Current
CurrentOperations
DISCARDING
HOLDING
INACTIVE
Interceptor
InterceptorOperations
IORInfo
IORInfoOperations
IORInterceptor
IORInterceptor_3_0
IORInterceptor_3_0Operations
IORInterceptorOperations
LOCATION_FORWARD
NON_EXISTENT
ObjectReferenceFactory
ObjectReferenceTemplate
ORBInitializer
ORBInitializerOperations
ORBInitInfo
ORBInitInfoOperations
PolicyFactory
PolicyFactoryOperations
RequestInfo
RequestInfoOperations
ServerRequestInfo
ServerRequestInfoOperations
ServerRequestInterceptor
ServerRequestInterceptorOperations
SUCCESSFUL
SYSTEM_EXCEPTION
TRANSPORT_RETRY
UNKNOWN
USER_EXCEPTION
类
AdapterManagerIdHelper
AdapterNameHelper
AdapterStateHelper
CurrentHelper
ForwardRequestHelper
InvalidSlotHelper
IORInterceptor_3_0Helper
IORInterceptor_3_0Holder
ObjectIdHelper
ObjectReferenceFactoryHelper
ObjectReferenceFactoryHolder
ObjectReferenceTemplateHelper
ObjectReferenceTemplateHolder
ObjectReferenceTemplateSeqHelper
ObjectReferenceTemplateSeqHolder
ORBIdHelper
ServerIdHelper
异常
ForwardRequest
InvalidSlot


org.omg.PortableInterceptor (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.PortableInterceptor

提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

请参见：
描述

接口摘要
ACTIVE | org/omg/PortableInterceptor/ACTIVE.java。
ClientRequestInfo | 客户端请求 interceptor 可访问的请求信息。
ClientRequestInfoOperations | 客户端请求 interceptor 可访问的请求信息。
ClientRequestInterceptor | 客户端 interceptor。
ClientRequestInterceptorOperations | 客户端的请求 interceptor。
Current | Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。
CurrentOperations | Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。
DISCARDING | org/omg/PortableInterceptor/DISCARDING.java。
HOLDING | org/omg/PortableInterceptor/HOLDING.java。
INACTIVE | org/omg/PortableInterceptor/INACTIVE.java。
Interceptor | 所有 Portable Interceptor 实现 Interceptor。
InterceptorOperations | 所有 Portable Interceptor 实现 Interceptor。
IORInfo | 提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
IORInfoOperations | 提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
IORInterceptor | Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
IORInterceptor_3_0 | org/omg/PortableInterceptor/IORInterceptor_3_0.java。
IORInterceptor_3_0Operations | org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。
IORInterceptorOperations | Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
LOCATION_FORWARD | org/omg/PortableInterceptor/LOCATION_FORWARD.java。
NON_EXISTENT | org/omg/PortableInterceptor/NON_EXISTENT.java。
ObjectReferenceFactory | 对象引用工厂。
ObjectReferenceTemplate | 对象引用模板。
ORBInitializer | 便于注册 interceptor 和初始化 ORB。
ORBInitializerOperations | 便于注册 interceptor 和初始化 ORB。
ORBInitInfo | 传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
ORBInitInfoOperations | 传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
PolicyFactory | 使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
PolicyFactoryOperations | 使得策略类型能够通过 CORBA.ORB.create_policy 构建。
RequestInfo | Interceptor 可访问的请求信息。
RequestInfoOperations | Interceptor 可访问的请求信息。
ServerRequestInfo | 服务器端请求 interceptor 可访问的请求信息。
ServerRequestInfoOperations | 服务器端请求 interceptor 可访问的请求信息。
ServerRequestInterceptor | 服务器端的请求 interceptor。
ServerRequestInterceptorOperations | 服务器端的请求 interceptor。
SUCCESSFUL | org/omg/PortableInterceptor/SUCCESSFUL.java。
SYSTEM_EXCEPTION | org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java。
TRANSPORT_RETRY | org/omg/PortableInterceptor/TRANSPORT_RETRY.java。
UNKNOWN | org/omg/PortableInterceptor/UNKNOWN.java。
USER_EXCEPTION | org/omg/PortableInterceptor/USER_EXCEPTION.java。

类摘要
AdapterManagerIdHelper | 适配器管理器标识符。
AdapterNameHelper | 对象适配器的名称。
AdapterStateHelper | 对象适配器状态的类型。
CurrentHelper | Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文和请求方或应答的服务上下文之间传输其上下文数据。
ForwardRequestHelper | org/omg/PortableInterceptor/ForwardRequestHelper.java。
InvalidSlotHelper | org/omg/PortableInterceptor/InvalidSlotHelper.java。
IORInterceptor_3_0Helper | org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java。
IORInterceptor_3_0Holder | org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java。
ObjectIdHelper | 对象 id 类型。
ObjectReferenceFactoryHelper | 对象引用工厂。
ObjectReferenceFactoryHolder | 对象引用工厂。
ObjectReferenceTemplateHelper | 对象引用模板。
ObjectReferenceTemplateHolder | 对象引用模板。
ObjectReferenceTemplateSeqHelper | 对象引用模板序列用来报告不发生在适配器管理器的状态更改。
ObjectReferenceTemplateSeqHolder | 对象引用模板序列用来报告不发生在适配器管理器的状态更改。
ORBIdHelper | org/omg/PortableInterceptor/ORBIdHelper.java。
ServerIdHelper | org/omg/PortableInterceptor/ServerIdHelper.java。

异常摘要
ForwardRequest | org/omg/PortableInterceptor/ForwardRequest.java。
InvalidSlot | org/omg/PortableInterceptor/InvalidSlot.java。

软件包 org.omg.PortableInterceptor 的描述

提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

Interceptor 类型

目前可以注册三种 interceptor 类型：
  • IORInterceptor - 用于在 IOR 内部的配置文件中建立带标记的组件。
  • ClientRequestInterceptor - 通过 ORB 在客户端 端截取请求/应答序列流。
  • ServerRequestInterceptor - 通过 ORB 在服务器 端截取请求/应答序列流。
有关如何注册 interceptor，请参阅 ORBInitializer 的 Java 文档。

org.omg.PortableInterceptor 包中已知的限制/未实现方法

  • RequestInfo
    • sync_scope(): 总是返回 SYNC_WITH_TRANSPORT
    • arguments(): 只支持 DII/DSI 调用
    • exceptions(): 只支持客户端的 DII 调用。不支持服务器端的调用。
    • contexts(): 只支持客户端的 DII 调用。不支持服务器端的调用，因为用户的 ORB 不发送上下文。
    • operation_context(): 只支持客户端的 DII 调用。不支持服务器端的调用，因为 ORB 不发送上下文。
    • result():只支持 DII/DSI 调用
  • ClientRequestInfo
    • received_exception_id(): 就 DII 而言总是返回 null
    • get_request_policy(int type): 未实现。
  • ServerRequestInfo
    • sending_exception(): 不支持非 DSI 情况下服务器端的用户异常。

包规范

有关 Java[tm] Platform, Standard Edition 6 遵守的官方 OMG 规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.PortableInterceptor 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableInterceptor 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterManagerIdHelper
    • org.omg.PortableInterceptor.AdapterNameHelper
    • org.omg.PortableInterceptor.AdapterStateHelper
    • org.omg.PortableInterceptor.CurrentHelper
    • org.omg.PortableInterceptor.ForwardRequestHelper
    • org.omg.PortableInterceptor.InvalidSlotHelper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectIdHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ORBIdHelper
    • org.omg.PortableInterceptor.ServerIdHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableInterceptor.ForwardRequest
          • org.omg.PortableInterceptor.InvalidSlot

接口分层结构

  • org.omg.PortableInterceptor.ACTIVE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.Current (并 extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.CurrentOperations
      • org.omg.PortableInterceptor.Current (并 extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • org.omg.PortableInterceptor.DISCARDING
  • org.omg.PortableInterceptor.HOLDING
  • org.omg.PortableInterceptor.INACTIVE
  • org.omg.PortableInterceptor.InterceptorOperations
    • org.omg.PortableInterceptor.ClientRequestInterceptorOperations
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.Interceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInterceptorOperations
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.ServerRequestInterceptorOperations
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
  • org.omg.PortableInterceptor.IORInfoOperations
    • org.omg.PortableInterceptor.IORInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.LOCATION_FORWARD
  • org.omg.PortableInterceptor.NON_EXISTENT
  • org.omg.CORBA.Object
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (并 extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Interceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations)
    • org.omg.PortableInterceptor.ORBInitializer (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • org.omg.PortableInterceptor.PolicyFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • org.omg.PortableInterceptor.RequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
  • org.omg.PortableInterceptor.ORBInitializerOperations
    • org.omg.PortableInterceptor.ORBInitializer (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.ORBInitInfoOperations
    • org.omg.PortableInterceptor.ORBInitInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.PolicyFactoryOperations
    • org.omg.PortableInterceptor.PolicyFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.RequestInfoOperations
    • org.omg.PortableInterceptor.ClientRequestInfoOperations
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.RequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfoOperations
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.PortableInterceptor.RequestInfo)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.PortableInterceptor.Interceptor)
      • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.Current (并 extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (并 extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations)
      • org.omg.PortableInterceptor.Interceptor (并 extends org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
          • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.PortableInterceptor.IORInfo (并 extends org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ORBInitializer (并 extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
      • org.omg.PortableInterceptor.ORBInitInfo (并 extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
      • org.omg.PortableInterceptor.PolicyFactory (并 extends org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
      • org.omg.PortableInterceptor.RequestInfo (并 extends org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
        • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.PortableInterceptor.ObjectReferenceFactory
          • org.omg.PortableInterceptor.ObjectReferenceTemplate
  • org.omg.PortableInterceptor.SUCCESSFUL
  • org.omg.PortableInterceptor.SYSTEM_EXCEPTION
  • org.omg.PortableInterceptor.TRANSPORT_RETRY
  • org.omg.PortableInterceptor.UNKNOWN
  • org.omg.PortableInterceptor.USER_EXCEPTION
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.PortableInterceptor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableInterceptor
的使用

使用 org.omg.PortableInterceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 使用的 org.omg.PortableInterceptor 中的类
ClientRequestInfo
客户端请求 interceptor 可访问的请求信息。
ClientRequestInfoOperations
客户端请求 interceptor 可访问的请求信息。
ClientRequestInterceptor
客户端 interceptor。
ClientRequestInterceptorOperations
客户端的请求 interceptor。
Current
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。
CurrentOperations
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。
ForwardRequest
org/omg/PortableInterceptor/ForwardRequest.java。
Interceptor
所有 Portable Interceptor 实现 Interceptor。
InterceptorOperations
所有 Portable Interceptor 实现 Interceptor。
InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。
IORInfo
提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
IORInfoOperations
提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
IORInterceptor
Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
IORInterceptor_3_0
org/omg/PortableInterceptor/IORInterceptor_3_0.java。
IORInterceptor_3_0Operations
org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。
IORInterceptorOperations
Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
ObjectReferenceFactory
对象引用工厂。
ObjectReferenceTemplate
对象引用模板。
ORBInitializerOperations
便于注册 interceptor 和初始化 ORB。
ORBInitInfo
传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
ORBInitInfoOperations
传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
PolicyFactory
使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
PolicyFactoryOperations
使得策略类型能够通过 CORBA.ORB.create_policy 构建。
RequestInfo
Interceptor 可访问的请求信息。
RequestInfoOperations
Interceptor 可访问的请求信息。
ServerRequestInfo
服务器端请求 interceptor 可访问的请求信息。
ServerRequestInfoOperations
服务器端请求 interceptor 可访问的请求信息。
ServerRequestInterceptor
服务器端的请求 interceptor。
ServerRequestInterceptorOperations
服务器端的请求 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DuplicateName (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor.ORBInitInfoPackage
类 DuplicateName

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
所有已实现的接口：
Serializable, IDLEntity
public final class DuplicateName
extends UserException

org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:10 (GMT-08:00)。

字段摘要
 String name
已为其注册了 interceptor 的名称。
构造方法摘要
DuplicateName()
DuplicateName(String _name)
DuplicateName(String $reason, String _name)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

name

public String name
已为其注册了 interceptor 的名称。

构造方法详细信息

DuplicateName

public DuplicateName()

DuplicateName

public DuplicateName(String _name)

DuplicateName

public DuplicateName(String $reason,
                     String _name)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DuplicateNameHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor.ORBInitInfoPackage
类 DuplicateNameHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

public abstract class DuplicateNameHelper
extends Object

org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:10 (GMT-08:00)。

构造方法摘要
DuplicateNameHelper()
方法摘要
static DuplicateName | extract(Any a)
static String | id()
static void | insert(Any a, DuplicateName that)
static DuplicateName | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, DuplicateName value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DuplicateNameHelper

public DuplicateNameHelper()
方法详细信息

insert

public static void insert(Any a,
                          DuplicateName that)

extract

public static DuplicateName extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DuplicateName read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DuplicateName value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidName (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor.ORBInitInfoPackage
类 InvalidName

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidName
extends UserException

org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:10 (GMT-08:00)。

构造方法摘要
InvalidName()
InvalidName(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidName

public InvalidName()

InvalidName

public InvalidName(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidNameHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor.ORBInitInfoPackage
类 InvalidNameHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

public abstract class InvalidNameHelper
extends Object

org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:10 (GMT-08:00)。

构造方法摘要
InvalidNameHelper()
方法摘要
static InvalidName | extract(Any a)
static String | id()
static void | insert(Any a, InvalidName that)
static InvalidName | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidName value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InvalidNameHelper

public InvalidNameHelper()
方法详细信息

insert

public static void insert(Any a,
                          InvalidName that)

extract

public static InvalidName extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidName read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidName value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectIdHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.PortableInterceptor.ORBInitInfoPackage
类 ObjectIdHelper

java.lang.Object
    继承者  org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

public abstract class ObjectIdHelper
extends Object

表示为一个 String 的 Object id

构造方法摘要
ObjectIdHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectIdHelper

public ObjectIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 6)

 org.omg.PortableInterceptor.ORBInitInfoPackage
类
DuplicateNameHelper
InvalidNameHelper
ObjectIdHelper
异常
DuplicateName
InvalidName


org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.PortableInterceptor.ORBInitInfoPackage

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

请参见：
描述

类摘要
DuplicateNameHelper | org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java。
InvalidNameHelper | org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java。
ObjectIdHelper | 表示为一个 String 的 Object id

异常摘要
DuplicateName | org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。
InvalidName | org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java。

软件包 org.omg.PortableInterceptor.ORBInitInfoPackage 的描述

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。有关的更多信息，请参考 OMG 规范。

包规范

有关Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.PortableInterceptor.ORBInitInfoPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableInterceptor.ORBInitInfoPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.PortableInterceptor.ORBInitInfoPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.PortableInterceptor.ORBInitInfoPackage
的使用

使用 org.omg.PortableInterceptor.ORBInitInfoPackage 的软件包
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableInterceptor 使用的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的类
DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。
InvalidName
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 使用的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的类
DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。
InvalidName
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
的使用

使用 DuplicateName 的软件包
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableInterceptor 中 DuplicateName 的使用

抛出 DuplicateName 的 org.omg.PortableInterceptor 中的方法
void | ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor) 此方法用来将客户端的请求 Interceptor 添加到客户端请求 Interceptor 列表。
void | ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor) 此方法用来将 IOR Interceptor 添加到 IOR Interceptor 列表。
void | ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor) 此方法用来将服务器端的请求 Interceptor 添加到服务器端请求 Interceptor 列表。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 DuplicateName 的使用

返回 DuplicateName 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static DuplicateName | DuplicateNameHelper.extract(Any a)
static DuplicateName | DuplicateNameHelper.read(InputStream istream)

参数类型为 DuplicateName 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
的使用

没有 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
的使用

使用 InvalidName 的软件包
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableInterceptor 中 InvalidName 的使用

抛出 InvalidName 的 org.omg.PortableInterceptor 中的方法
void | ORBInitInfoOperations.register_initial_reference(String id, Object obj) 等同于 ORB.register_initial_reference。
Object | ORBInitInfoOperations.resolve_initial_references(String id) 等同于 ORB.resolve_initial_references。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 InvalidName 的使用

返回 InvalidName 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static InvalidName | InvalidNameHelper.extract(Any a)
static InvalidName | InvalidNameHelper.read(InputStream istream)

参数类型为 InvalidName 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法
static void | InvalidNameHelper.insert(Any a, InvalidName that)
static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
的使用

没有 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
的使用

没有 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.UNKNOWN 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.UNKNOWN
的使用

没有 org.omg.PortableInterceptor.UNKNOWN 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ACTIVE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ACTIVE
的使用

没有 org.omg.PortableInterceptor.ACTIVE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.AdapterManagerIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.AdapterManagerIdHelper
的使用

没有 org.omg.PortableInterceptor.AdapterManagerIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.AdapterNameHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.AdapterNameHelper
的使用

没有 org.omg.PortableInterceptor.AdapterNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.AdapterStateHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.AdapterStateHelper
的使用

没有 org.omg.PortableInterceptor.AdapterStateHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ClientRequestInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ClientRequestInfo
的使用

使用 ClientRequestInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ClientRequestInfo 的使用

参数类型为 ClientRequestInfo 的 org.omg.PortableInterceptor 中的方法
void | ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri) 指示 interceptor 发生异常。
void | ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | ClientRequestInterceptorOperations.receive_reply(ClientRequestInfo ri) 允许 Interceptor 在从服务器返回后但在向客户端返回控件前查询信息。
void | ClientRequestInterceptorOperations.send_poll(ClientRequestInfo ri) 允许 Interceptor 在轮询获取应答序列的与时间无关的调用（Time-Independent Invocation，TII）时查询信息。
void | ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri) 允许 Interceptor 在请求被发送到服务器前查询请求信息并修改服务上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ClientRequestInfoOperations
的使用

使用 ClientRequestInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ClientRequestInfoOperations 的使用

org.omg.PortableInterceptor 中 ClientRequestInfoOperations 的子接口
 interface ClientRequestInfo
客户端请求 interceptor 可访问的请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ClientRequestInterceptor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ClientRequestInterceptor
的使用

使用 ClientRequestInterceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ClientRequestInterceptor 的使用

参数类型为 ClientRequestInterceptor 的 org.omg.PortableInterceptor 中的方法
 void ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor)
此方法用来将客户端的请求 Interceptor 添加到客户端请求 Interceptor 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations
的使用

使用 ClientRequestInterceptorOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ClientRequestInterceptorOperations 的使用

org.omg.PortableInterceptor 中 ClientRequestInterceptorOperations 的子接口
 interface ClientRequestInterceptor
客户端 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.Current 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.Current
的使用

使用 Current 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 Current 的使用

返回 Current 的 org.omg.PortableInterceptor 中的方法
static Current | CurrentHelper.extract(Any a)
static Current | CurrentHelper.narrow(Object obj)
static Current | CurrentHelper.read(InputStream istream)
static Current | CurrentHelper.unchecked_narrow(Object obj)

参数类型为 Current 的 org.omg.PortableInterceptor 中的方法
static void | CurrentHelper.insert(Any a, Current that)
static void | CurrentHelper.write(OutputStream ostream, Current value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.CurrentHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.CurrentHelper
的使用

没有 org.omg.PortableInterceptor.CurrentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.CurrentOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.CurrentOperations
的使用

使用 CurrentOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 CurrentOperations 的使用

org.omg.PortableInterceptor 中 CurrentOperations 的子接口
 interface Current
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.DISCARDING 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.DISCARDING
的使用

没有 org.omg.PortableInterceptor.DISCARDING 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ForwardRequest 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ForwardRequest
的使用

使用 ForwardRequest 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ForwardRequest 的使用

返回 ForwardRequest 的 org.omg.PortableInterceptor 中的方法
static ForwardRequest | ForwardRequestHelper.extract(Any a)
static ForwardRequest | ForwardRequestHelper.read(InputStream istream)

参数类型为 ForwardRequest 的 org.omg.PortableInterceptor 中的方法
static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)

抛出 ForwardRequest 的 org.omg.PortableInterceptor 中的方法
void | ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri) 指示 interceptor 发生异常。
void | ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri) 允许 interceptor 处理服务上下文信息。
void | ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri) 允许 Interceptor 在所有信息（包括操作参数）可用后查询信息。
void | ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri) 允许 Interceptor 在向客户端抛出异常前查询异常信息并修改应答服务上下文。
void | ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri) 允许 Interceptor 在请求被发送到服务器前查询请求信息并修改服务上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ForwardRequestHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ForwardRequestHelper
的使用

没有 org.omg.PortableInterceptor.ForwardRequestHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.HOLDING 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.HOLDING
的使用

没有 org.omg.PortableInterceptor.HOLDING 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.INACTIVE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.INACTIVE
的使用

没有 org.omg.PortableInterceptor.INACTIVE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInfo
的使用

使用 IORInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInfo 的使用

参数类型为 IORInfo 的 org.omg.PortableInterceptor 中的方法
void | IORInterceptor_3_0Operations.components_established(IORInfo info) 在已经对所有已注册 IORInterceptor 实例调用 establish_components 方法后，对所有已注册 IORInterceptor_3_0 实例调用 components_established 方法。
void | IORInterceptorOperations.establish_components(IORInfo info) 在汇编将包括在对象引用配置文件中的组件列表时，服务器端 ORB 对所有已注册 IORInterceptor 实例调用 establish_components 操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInfoOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInfoOperations
的使用

使用 IORInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInfoOperations 的使用

org.omg.PortableInterceptor 中 IORInfoOperations 的子接口
 interface IORInfo
提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInterceptor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInterceptor
的使用

使用 IORInterceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInterceptor 的使用

org.omg.PortableInterceptor 中 IORInterceptor 的子接口
 interface IORInterceptor_3_0
org/omg/PortableInterceptor/IORInterceptor_3_0.java。

参数类型为 IORInterceptor 的 org.omg.PortableInterceptor 中的方法
 void ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor)
此方法用来将 IOR Interceptor 添加到 IOR Interceptor 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInterceptorOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInterceptorOperations
的使用

使用 IORInterceptorOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInterceptorOperations 的使用

org.omg.PortableInterceptor 中 IORInterceptorOperations 的子接口
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | IORInterceptor_3_0Operations org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInterceptor_3_0 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInterceptor_3_0
的使用

使用 IORInterceptor_3_0 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInterceptor_3_0 的使用

声明为 IORInterceptor_3_0 的 org.omg.PortableInterceptor 中的字段
 IORInterceptor_3_0 IORInterceptor_3_0Holder.value

返回 IORInterceptor_3_0 的 org.omg.PortableInterceptor 中的方法
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)

参数类型为 IORInterceptor_3_0 的 org.omg.PortableInterceptor 中的方法
static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)

参数类型为 IORInterceptor_3_0 的 org.omg.PortableInterceptor 中的构造方法
IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper
的使用

没有 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder
的使用

没有 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations
的使用

使用 IORInterceptor_3_0Operations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 IORInterceptor_3_0Operations 的使用

org.omg.PortableInterceptor 中 IORInterceptor_3_0Operations 的子接口
 interface IORInterceptor_3_0
org/omg/PortableInterceptor/IORInterceptor_3_0.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.Interceptor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.Interceptor
的使用

使用 Interceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 Interceptor 的使用

org.omg.PortableInterceptor 中 Interceptor 的子接口
interface | ClientRequestInterceptor 客户端 interceptor。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.InterceptorOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.InterceptorOperations
的使用

使用 InterceptorOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 InterceptorOperations 的使用

org.omg.PortableInterceptor 中 InterceptorOperations 的子接口
interface | ClientRequestInterceptor 客户端 interceptor。
interface | ClientRequestInterceptorOperations 客户端的请求 interceptor。
interface | Interceptor 所有 Portable Interceptor 实现 Interceptor。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | IORInterceptor_3_0Operations org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。
interface | IORInterceptorOperations Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。
interface | ServerRequestInterceptorOperations 服务器端的请求 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.InvalidSlot 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.InvalidSlot
的使用

使用 InvalidSlot 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 InvalidSlot 的使用

返回 InvalidSlot 的 org.omg.PortableInterceptor 中的方法
static InvalidSlot | InvalidSlotHelper.extract(Any a)
static InvalidSlot | InvalidSlotHelper.read(InputStream istream)

参数类型为 InvalidSlot 的 org.omg.PortableInterceptor 中的方法
static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)

抛出 InvalidSlot 的 org.omg.PortableInterceptor 中的方法
Any | CurrentOperations.get_slot(int id) 检索应用程序通过 get_slot 在 PICurrent 中设置的槽数据。
Any | RequestInfoOperations.get_slot(int id) 返回请求域内 PortableInterceptor.Current 给定槽 (slot) 中的数据。
void | CurrentOperations.set_slot(int id, Any data) 在槽中设置数据。
void | ServerRequestInfoOperations.set_slot(int id, Any data) 允许 Interceptor 在请求域中的 PortableInterceptor.Current 内设置槽 (slot)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.InvalidSlotHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.InvalidSlotHelper
的使用

没有 org.omg.PortableInterceptor.InvalidSlotHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.LOCATION_FORWARD 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.LOCATION_FORWARD
的使用

没有 org.omg.PortableInterceptor.LOCATION_FORWARD 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.NON_EXISTENT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.NON_EXISTENT
的使用

没有 org.omg.PortableInterceptor.NON_EXISTENT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ORBIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ORBIdHelper
的使用

没有 org.omg.PortableInterceptor.ORBIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ORBInitInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ORBInitInfo
的使用

使用 ORBInitInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ORBInitInfo 的使用

参数类型为 ORBInitInfo 的 org.omg.PortableInterceptor 中的方法
void | ORBInitializerOperations.post_init(ORBInitInfo info) 初始化 ORB 期间调用此方法。
void | ORBInitializerOperations.pre_init(ORBInitInfo info) 初始化 ORB 期间调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ORBInitInfoOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ORBInitInfoOperations
的使用

使用 ORBInitInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ORBInitInfoOperations 的使用

org.omg.PortableInterceptor 中 ORBInitInfoOperations 的子接口
 interface ORBInitInfo
传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ORBInitializer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ORBInitializer
的使用

没有 org.omg.PortableInterceptor.ORBInitializer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ORBInitializerOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ORBInitializerOperations
的使用

使用 ORBInitializerOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ORBInitializerOperations 的使用

org.omg.PortableInterceptor 中 ORBInitializerOperations 的子接口
 interface ORBInitializer
便于注册 interceptor 和初始化 ORB。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectIdHelper
的使用

没有 org.omg.PortableInterceptor.ObjectIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ObjectReferenceFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ObjectReferenceFactory
的使用

使用 ObjectReferenceFactory 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ObjectReferenceFactory 的使用

org.omg.PortableInterceptor 中 ObjectReferenceFactory 的子接口
 interface ObjectReferenceTemplate
对象引用模板。

声明为 ObjectReferenceFactory 的 org.omg.PortableInterceptor 中的字段
 ObjectReferenceFactory ObjectReferenceFactoryHolder.value

返回 ObjectReferenceFactory 的 org.omg.PortableInterceptor 中的方法
ObjectReferenceFactory | IORInfoOperations.current_factory() 读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)

参数类型为 ObjectReferenceFactory 的 org.omg.PortableInterceptor 中的方法
void | IORInfoOperations.current_factory(ObjectReferenceFactory newCurrent_factory) 读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)

参数类型为 ObjectReferenceFactory 的 org.omg.PortableInterceptor 中的构造方法
ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ObjectReferenceTemplate 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ObjectReferenceTemplate
的使用

使用 ObjectReferenceTemplate 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ObjectReferenceTemplate 的使用

声明为 ObjectReferenceTemplate 的 org.omg.PortableInterceptor 中的字段
ObjectReferenceTemplate | ObjectReferenceTemplateHolder.value
ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHolder.value

返回 ObjectReferenceTemplate 的 org.omg.PortableInterceptor 中的方法
ObjectReferenceTemplate | IORInfoOperations.adapter_template() 返回刚创建并在 IOR interceptor 上运行的对象适配器的对象引用模板。
static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)

参数类型为 ObjectReferenceTemplate 的 org.omg.PortableInterceptor 中的方法
void | IORInterceptor_3_0Operations.adapter_state_changed(ObjectReferenceTemplate[] templates, short state) 只要对象适配器的状态发生更改，并且该状态更改不是由适配器管理器引起的，便调用此方法。
static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)

参数类型为 ObjectReferenceTemplate 的 org.omg.PortableInterceptor 中的构造方法
ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.SUCCESSFUL 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.SUCCESSFUL
的使用

没有 org.omg.PortableInterceptor.SUCCESSFUL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
的使用

没有 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.PolicyFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.PolicyFactory
的使用

使用 PolicyFactory 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 PolicyFactory 的使用

参数类型为 PolicyFactory 的 org.omg.PortableInterceptor 中的方法
 void ORBInitInfoOperations.register_policy_factory(int type, PolicyFactory policy_factory)
注册给定 PolicyType 的 PolicyFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.PolicyFactoryOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.PolicyFactoryOperations
的使用

使用 PolicyFactoryOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 PolicyFactoryOperations 的使用

org.omg.PortableInterceptor 中 PolicyFactoryOperations 的子接口
 interface PolicyFactory
使得策略类型能够使用 CORBA.ORB.create_policy 来构建。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.RequestInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.RequestInfo
的使用

使用 RequestInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 RequestInfo 的使用

org.omg.PortableInterceptor 中 RequestInfo 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.RequestInfoOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.RequestInfoOperations
的使用

使用 RequestInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 RequestInfoOperations 的使用

org.omg.PortableInterceptor 中 RequestInfoOperations 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ClientRequestInfoOperations 客户端请求 interceptor 可访问的请求信息。
interface | RequestInfo Interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。
interface | ServerRequestInfoOperations 服务器端请求 interceptor 可访问的请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.SYSTEM_EXCEPTION 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.SYSTEM_EXCEPTION
的使用

没有 org.omg.PortableInterceptor.SYSTEM_EXCEPTION 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.PortableInterceptor.ServerIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.PortableInterceptor.ServerIdHelper
的使用

没有 org.omg.PortableInterceptor.ServerIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ServerRequestInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ServerRequestInfo
的使用

使用 ServerRequestInfo 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ServerRequestInfo 的使用

参数类型为 ServerRequestInfo 的 org.omg.PortableInterceptor 中的方法
void | ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri) 允许 interceptor 处理服务上下文信息。
void | ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri) 允许 Interceptor 在所有信息（包括操作参数）可用后查询信息。
void | ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri) 允许 Interceptor 在向客户端抛出异常前查询异常信息并修改应答服务上下文。
void | ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri) 允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
void | ServerRequestInterceptorOperations.send_reply(ServerRequestInfo ri) 允许 Interceptor 在已调用目标操作后、向客户端返回应答前查询应答信息并修改应答服务上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ServerRequestInfoOperations
的使用

使用 ServerRequestInfoOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ServerRequestInfoOperations 的使用

org.omg.PortableInterceptor 中 ServerRequestInfoOperations 的子接口
 interface ServerRequestInfo
服务器端请求 interceptor 可访问的请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ServerRequestInterceptor 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ServerRequestInterceptor
的使用

使用 ServerRequestInterceptor 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ServerRequestInterceptor 的使用

参数类型为 ServerRequestInterceptor 的 org.omg.PortableInterceptor 中的方法
 void ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor)
此方法用来将服务器端的请求 Interceptor 添加到服务器端请求 Interceptor 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations
的使用

使用 ServerRequestInterceptorOperations 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 ServerRequestInterceptorOperations 的使用

org.omg.PortableInterceptor 中 ServerRequestInterceptorOperations 的子接口
 interface ServerRequestInterceptor
服务器端的请求 interceptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.TRANSPORT_RETRY 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.TRANSPORT_RETRY
的使用

没有 org.omg.PortableInterceptor.TRANSPORT_RETRY 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.PortableInterceptor.USER_EXCEPTION 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.PortableInterceptor.USER_EXCEPTION
的使用

没有 org.omg.PortableInterceptor.USER_EXCEPTION 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


SYNC_WITH_TRANSPORT (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.Messaging
接口 SYNC_WITH_TRANSPORT

public interface SYNC_WITH_TRANSPORT

org/omg/Messaging/SYNC_WITH_TRANSPORT.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:08 (GMT-08:00)。

字段摘要
static short value
Messaging 规范中定义的常量，定义请求在控件返回客户端前应传输的距离。

字段详细信息

value

static final short value
Messaging 规范中定义的常量，定义请求在控件返回客户端前应传输的距离。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SyncScopeHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.Messaging
类 SyncScopeHelper

java.lang.Object
    继承者  org.omg.Messaging.SyncScopeHelper

public abstract class SyncScopeHelper
extends Object

Synchronization 作用域

构造方法摘要
SyncScopeHelper()
方法摘要
static short | extract(Any a)
static String | id()
static void | insert(Any a, short that)
static short | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, short value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SyncScopeHelper

public SyncScopeHelper()
方法详细信息

insert

public static void insert(Any a,
                          short that)

extract

public static short extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static short read(InputStream istream)

write

public static void write(OutputStream ostream,
                         short value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.Messaging (Java Platform SE 6)

 org.omg.Messaging
接口
SYNC_WITH_TRANSPORT
类
SyncScopeHelper


org.omg.Messaging (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.Messaging

此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。

请参见：
描述

接口摘要
SYNC_WITH_TRANSPORT org/omg/Messaging/SYNC_WITH_TRANSPORT.java。

类摘要
SyncScopeHelper Synchronization 作用域

软件包 org.omg.Messaging 的描述

此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。有关更多细节，请参阅该 OMG 规范。

请注意，我们并没有提该规范中 Messaging 模块的所有部分。只提供那些在公共 API（尤其是 Portable Interceptor）中作为返回值和参数类型引用的部分。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.Messaging 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.Messaging 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.Messaging.SyncScopeHelper

接口分层结构

  • org.omg.Messaging.SYNC_WITH_TRANSPORT
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.Messaging 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.Messaging
的使用

没有 org.omg.Messaging 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.Messaging.SYNC_WITH_TRANSPORT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.Messaging.SYNC_WITH_TRANSPORT
的使用

没有 org.omg.Messaging.SYNC_WITH_TRANSPORT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.Messaging.SyncScopeHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.Messaging.SyncScopeHelper
的使用

没有 org.omg.Messaging.SyncScopeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Codec (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 Codec

所有超级接口：
CodecOperations, IDLEntity, Object, Serializable
public interface Codec
extends CodecOperations, Object, IDLEntity

IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。Codec 提供一个机制，在其 IDL 数据类型和 CDR 封装表示形式之间传输这些组件。

Codec 可从 CodecFactory 中获得。CodecFactory 可通过调用 ORB.resolve_initial_references( "CodecFactory" ) 获得。

方法摘要
从接口 org.omg.IOP.CodecOperations 继承的方法
decode_value, decode, encode_value, encode
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CodecFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 CodecFactory

所有超级接口：
CodecFactoryOperations, IDLEntity, Object, Serializable
public interface CodecFactory
extends CodecFactoryOperations, Object, IDLEntity

Codec 可从 CodecFactory 中获得。CodecFactory 可通过调用 ORB.resolve_initial_references( "CodecFactory" ) 获得。

方法摘要
从接口 org.omg.IOP.CodecFactoryOperations 继承的方法
create_codec
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CodecFactoryHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 CodecFactoryHelper

java.lang.Object
    继承者  org.omg.IOP.CodecFactoryHelper

public abstract class CodecFactoryHelper
extends Object

Codec 可从 CodecFactory 中获得。CodecFactory 可通过调用 ORB.resolve_initial_references( "CodecFactory" ) 获得。

构造方法摘要
CodecFactoryHelper()
方法摘要
static CodecFactory | extract(Any a)
static String | id()
static void | insert(Any a, CodecFactory that)
static CodecFactory | narrow(Object obj)
static CodecFactory | read(InputStream istream)
static TypeCode | type()
static CodecFactory | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, CodecFactory value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CodecFactoryHelper

public CodecFactoryHelper()
方法详细信息

insert

public static void insert(Any a,
                          CodecFactory that)

extract

public static CodecFactory extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static CodecFactory read(InputStream istream)

write

public static void write(OutputStream ostream,
                         CodecFactory value)

narrow

public static CodecFactory narrow(Object obj)

unchecked_narrow

public static CodecFactory unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CodecFactoryOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 CodecFactoryOperations

所有已知子接口：
CodecFactory
public interface CodecFactoryOperations

Codec 可从 CodecFactory 中获得。CodecFactory 可通过调用 ORB.resolve_initial_references( "CodecFactory" ) 获得。

方法摘要
 Codec create_codec(Encoding enc)
创建一个给定编码的 Codec。

方法详细信息

create_codec

Codec create_codec(Encoding enc)
                   throws UnknownEncoding
创建一个给定编码的 Codec。

参数：
enc - 用来创建 Codec 的编码。
返回：
使用给定编码获取的 Codec。
抛出：
UnknownEncoding - 此工厂无法创建给定编码的 Codec 时抛出该异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CodecOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 CodecOperations

所有已知子接口：
Codec
public interface CodecOperations

IOR 组件格式和 ORB 服务使用的服务上下文数据通常被定义为 IDL 定义数据类型的 CDR 封装编码实例。Codec 提供一个机制，在其 IDL 数据类型和 CDR 封装表示形式之间传输这些组件。

Codec 可从 CodecFactory 中获得。CodecFactory 可通过调用 ORB.resolve_initial_references( "CodecFactory" ) 获得。

方法摘要
Any | decode_value(byte[] data, TypeCode tc) 基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
Any | decode(byte[] data) 基于对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
byte[] | encode_value(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
byte[] | encode(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。

方法详细信息

encode

byte[] encode(Any data)
              throws InvalidTypeForEncoding
基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。

参数：
data - 将被编码为一个 byte 数组的数据（any 形式）。
返回：
包含已编码 Any 的 byte 数组。此 byte 数组包含 TypeCode 和类型数据。
抛出：
InvalidTypeForEncoding - 如果该类型对于对此 Codec 有效的编码格式无效，则抛出此异常。

decode

Any decode(byte[] data)
           throws FormatMismatch
基于对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

参数：
data - 将被解码为 Any 的数据（byte 数组的形式）。
返回：
包含已解码 byte 数组数据的 Any。
抛出：
FormatMismatch - 在 byte 数组不能被解码为 Any 时抛出。

encode_value

byte[] encode_value(Any data)
                    throws InvalidTypeForEncoding
基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。只解码 Any 中的数据，不对 TypeCode 中的数据进行解码。

参数：
data - 将被编码为一个 byte 数组的数据（Any 形式）。
返回：
包含已编码 Any 中数据的 byte 数组。
抛出：
InvalidTypeForEncoding - 如果该类型对于对此 Codec 有效的编码格式无效，则抛出此异常。

decode_value

Any decode_value(byte[] data,
                 TypeCode tc)
                 throws FormatMismatch,
                        TypeMismatch
基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

参数：
data - 将被解码为 Any 的数据（byte 数组的形式）。
tc - 用来解码数据的 TypeCode。
返回：
包含已解码 byte 数组数据的 Any。
抛出：
FormatMismatch - 在 byte 数组不能被解码为 Any 时抛出。
TypeMismatch
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CodeSets (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 CodeSets

public interface CodeSets

org/omg/IOP/CodeSets.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
标识在 "GIOP Code Set Service Context" 13-43 页，13.10.2.5 这一部分定义的 CONV_FRAME.CodeSetContext CDR 封装。

字段详细信息

value

static final int value
标识在 "GIOP Code Set Service Context" 13-43 页，13.10.2.5 这一部分定义的 CONV_FRAME.CodeSetContext CDR 封装。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentIdHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 ComponentIdHelper

java.lang.Object
    继承者  org.omg.IOP.ComponentIdHelper

public abstract class ComponentIdHelper
extends Object

表示多组件配置文件的标准方式。可以将此类封装在 TaggedProfile 中。

构造方法摘要
ComponentIdHelper()
方法摘要
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComponentIdHelper

public ComponentIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Encoding (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 Encoding

java.lang.Object
    继承者  org.omg.IOP.Encoding
所有已实现的接口：
Serializable, IDLEntity
public final class Encoding
extends Object
implements IDLEntity

org/omg/IOP/Encoding.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

字段摘要
short | format 编码格式。
byte | major_version 此 Encoding 格式的主要形式。
byte | minor_version 此 Encoding 格式的次要形式。
构造方法摘要
Encoding()
Encoding(short _format, byte _major_version, byte _minor_version)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

format

public short format
编码格式。

major_version

public byte major_version
此 Encoding 格式的主要形式。

minor_version

public byte minor_version
此 Encoding 格式的次要形式。

构造方法详细信息

Encoding

public Encoding()

Encoding

public Encoding(short _format,
                byte _major_version,
                byte _minor_version)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ENCODING_CDR_ENCAPS (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 ENCODING_CDR_ENCAPS

public interface ENCODING_CDR_ENCAPS

org/omg/IOP/ENCODING_CDR_ENCAPS.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

字段摘要
static short value
CDR Encapsulation 编码。

字段详细信息

value

static final short value
CDR Encapsulation 编码。

另请参见：
CodecFactory, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExceptionDetailMessage (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 ExceptionDetailMessage

public interface ExceptionDetailMessage

org/omg/IOP/ExceptionDetailMessage.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

字段摘要
static int value
CORBA formal/02-06-01:13.7.1: ExceptionDetailMessage，它标识 wstring 的 CDR 封装，使用 GIOP 1.2 与 UTF-16 的 TCS-W 编码。

字段详细信息

value

static final int value
CORBA formal/02-06-01:13.7.1: ExceptionDetailMessage，它标识 wstring 的 CDR 封装，使用 GIOP 1.2 与 UTF-16 的 TCS-W 编码。此服务上下文可以被发送到 reply_status 为 SYSTEM_EXCEPTION 或 USER_EXCEPTION 的 Reply 消息上。此服务上下文的用法通过语言映射定义。

IDL/Java: ptc/02-01-22:1.15.2: 在编组 System Exception 时，其 GIOP Reply 消息应包括关联的 ExceptionDetailMessage 服务上下文。被调用者的栈追踪通常是非常有价值的调试信息，但它可能包含敏感信息或不需要的信息。因此，服务上下文中的 wstring 将包含与异常相关的附加信息，例如，对异常调用 printStackTrace(PrintWriter) 或 getMessage() 的结果。当在客户端解码 System Exception 时，任何 ExceptionDetailMessage 服务上下文的 wstring 将变成已解码的异常对象中的 Java 错误信息。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IOR (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 IOR

java.lang.Object
    继承者  org.omg.IOP.IOR
所有已实现的接口：
Serializable, IDLEntity
public final class IOR
extends Object
implements IDLEntity

org/omg/IOP/IOR.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
TaggedProfile[] | profiles 与此对象引用关联的一组有标记的配置文件。
String | type_id 以 String 形式表示的类型 id。
构造方法摘要
IOR()
IOR(String _type_id, TaggedProfile[] _profiles)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

type_id

public String type_id
以 String 形式表示的类型 id。

profiles

public TaggedProfile[] profiles
与此对象引用关联的一组有标记的配置文件。

构造方法详细信息

IOR

public IOR()

IOR

public IOR(String _type_id,
           TaggedProfile[] _profiles)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 IORHelper

java.lang.Object
    继承者  org.omg.IOP.IORHelper

public abstract class IORHelper
extends Object

org/omg/IOP/IORHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

构造方法摘要
IORHelper()
方法摘要
static IOR | extract(Any a)
static String | id()
static void | insert(Any a, IOR that)
static IOR | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, IOR value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IORHelper

public IORHelper()
方法详细信息

insert

public static void insert(Any a,
                          IOR that)

extract

public static IOR extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static IOR read(InputStream istream)

write

public static void write(OutputStream ostream,
                         IOR value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IORHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 IORHolder

java.lang.Object
    继承者  org.omg.IOP.IORHolder
所有已实现的接口：
Streamable
public final class IORHolder
extends Object
implements Streamable

org/omg/IOP/IORHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

字段摘要
 IOR value
构造方法摘要
IORHolder()
IORHolder(IOR initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public IOR value
构造方法详细信息

IORHolder

public IORHolder()

IORHolder

public IORHolder(IOR initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultipleComponentProfileHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 MultipleComponentProfileHelper

java.lang.Object
    继承者  org.omg.IOP.MultipleComponentProfileHelper

public abstract class MultipleComponentProfileHelper
extends Object

形成多组件配置文件的一组加标记的组件。

构造方法摘要
MultipleComponentProfileHelper()
方法摘要
static TaggedComponent[] | extract(Any a)
static String | id()
static void | insert(Any a, TaggedComponent[] that)
static TaggedComponent[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TaggedComponent[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MultipleComponentProfileHelper

public MultipleComponentProfileHelper()
方法详细信息

insert

public static void insert(Any a,
                          TaggedComponent[] that)

extract

public static TaggedComponent[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TaggedComponent[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TaggedComponent[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultipleComponentProfileHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 MultipleComponentProfileHolder

java.lang.Object
    继承者  org.omg.IOP.MultipleComponentProfileHolder
所有已实现的接口：
Streamable
public final class MultipleComponentProfileHolder
extends Object
implements Streamable

形成多组件配置文件的一组加标记的组件。

字段摘要
 TaggedComponent[] value
构造方法摘要
MultipleComponentProfileHolder()
MultipleComponentProfileHolder(TaggedComponent[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public TaggedComponent[] value
构造方法详细信息

MultipleComponentProfileHolder

public MultipleComponentProfileHolder()

MultipleComponentProfileHolder

public MultipleComponentProfileHolder(TaggedComponent[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProfileIdHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 ProfileIdHelper

java.lang.Object
    继承者  org.omg.IOP.ProfileIdHelper

public abstract class ProfileIdHelper
extends Object

配置文件 ID

构造方法摘要
ProfileIdHelper()
方法摘要
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ProfileIdHelper

public ProfileIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMICustomMaxStreamFormat (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 RMICustomMaxStreamFormat

public interface RMICustomMaxStreamFormat

org/omg/IOP/RMICustomMaxStreamFormat.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
标识 RMICustomMaxStreamFormat 服务上下文的 CDR 封装，该封装中包含指示客户端最大 RMI-IIOP 流格式形式的单个字节。

字段详细信息

value

static final int value
标识 RMICustomMaxStreamFormat 服务上下文的 CDR 封装，该封装中包含指示客户端最大 RMI-IIOP 流格式形式的单个字节。 参见 Java to IDL ptc/02-01-12 1.4.12。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceContext (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 ServiceContext

java.lang.Object
    继承者  org.omg.IOP.ServiceContext
所有已实现的接口：
Serializable, IDLEntity
public final class ServiceContext
extends Object
implements IDLEntity

org/omg/IOP/ServiceContext.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2004 年 8 月 11 日（星期三）上午 5:04:04 (GMT-08:00)。

字段摘要
byte[] | context_data 与此服务上下文关联的数据
int | context_id 服务上下文 id
构造方法摘要
ServiceContext()
ServiceContext(int _context_id, byte[] _context_data)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

context_id

public int context_id
服务上下文 id

context_data

public byte[] context_data
与此服务上下文关联的数据

构造方法详细信息

ServiceContext

public ServiceContext()

ServiceContext

public ServiceContext(int _context_id,
                      byte[] _context_data)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceContextHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 ServiceContextHelper

java.lang.Object
    继承者  org.omg.IOP.ServiceContextHelper

public abstract class ServiceContextHelper
extends Object

org/omg/IOP/ServiceContextHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

构造方法摘要
ServiceContextHelper()
方法摘要
static ServiceContext | extract(Any a)
static String | id()
static void | insert(Any a, ServiceContext that)
static ServiceContext | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ServiceContext value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceContextHelper

public ServiceContextHelper()
方法详细信息

insert

public static void insert(Any a,
                          ServiceContext that)

extract

public static ServiceContext extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServiceContext read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServiceContext value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceContextHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 ServiceContextHolder

java.lang.Object
    继承者  org.omg.IOP.ServiceContextHolder
所有已实现的接口：
Streamable
public final class ServiceContextHolder
extends Object
implements Streamable

org/omg/IOP/ServiceContextHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
 ServiceContext value
构造方法摘要
ServiceContextHolder()
ServiceContextHolder(ServiceContext initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public ServiceContext value
构造方法详细信息

ServiceContextHolder

public ServiceContextHolder()

ServiceContextHolder

public ServiceContextHolder(ServiceContext initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceContextListHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 ServiceContextListHelper

java.lang.Object
    继承者  org.omg.IOP.ServiceContextListHelper

public abstract class ServiceContextListHelper
extends Object

形成服务上下文列表的一组服务上下文。

构造方法摘要
ServiceContextListHelper()
方法摘要
static ServiceContext[] | extract(Any a)
static String | id()
static void | insert(Any a, ServiceContext[] that)
static ServiceContext[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, ServiceContext[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceContextListHelper

public ServiceContextListHelper()
方法详细信息

insert

public static void insert(Any a,
                          ServiceContext[] that)

extract

public static ServiceContext[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static ServiceContext[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         ServiceContext[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceContextListHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 ServiceContextListHolder

java.lang.Object
    继承者  org.omg.IOP.ServiceContextListHolder
所有已实现的接口：
Streamable
public final class ServiceContextListHolder
extends Object
implements Streamable

形成服务上下文列表的一组服务上下文。

字段摘要
 ServiceContext[] value
构造方法摘要
ServiceContextListHolder()
ServiceContextListHolder(ServiceContext[] initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public ServiceContext[] value
构造方法详细信息

ServiceContextListHolder

public ServiceContextListHolder()

ServiceContextListHolder

public ServiceContextListHolder(ServiceContext[] initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceIdHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 ServiceIdHelper

java.lang.Object
    继承者  org.omg.IOP.ServiceIdHelper

public abstract class ServiceIdHelper
extends Object

以 int 形式表示的服务 id

构造方法摘要
ServiceIdHelper()
方法摘要
static int | extract(Any a)
static String | id()
static void | insert(Any a, int that)
static int | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, int value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceIdHelper

public ServiceIdHelper()
方法详细信息

insert

public static void insert(Any a,
                          int that)

extract

public static int extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static int read(InputStream istream)

write

public static void write(OutputStream ostream,
                         int value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TAG_ALTERNATE_IIOP_ADDRESS (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TAG_ALTERNATE_IIOP_ADDRESS

public interface TAG_ALTERNATE_IIOP_ADDRESS

org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
在将同一个对象键 (object key) 用于多个互联网位置的情况下，定义了以下标准 IOR Component 来支持 IIOP 1.2 版。

字段详细信息

value

static final int value
在将同一个对象键 (object key) 用于多个互联网位置的情况下，定义了以下标准 IOR Component 来支持 IIOP 1.2 版。

TAG_ALTERNATE_IIOP_ADDRESS 组件具有关联的类型值：

     struct {
         string HostID,
         short Port
     };
编码为 CDR 封装。

TAG_INTERNET_IOP Profile 1.2 中可能包含零个或多个 TAG_ALTERNATE_IIOP_ADDRESS 组件类型实例。除了 Profile 正文中表示的主机和端口地址外，每个可选地址都可以用于客户端 orb。在 TAG_INTERNET_IOP Profile 中存在一个或多个 TAG_ALTERNATE_IIOP_ADDRESS 组件的情况下，IIOP 1.2 没有指定这些组件的使用顺序。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TAG_CODE_SETS (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TAG_CODE_SETS

public interface TAG_CODE_SETS

org/omg/IOP/TAG_CODE_SETS.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
IOR 多组件配置文件结构的代码集组件包括： 服务器的本机 char 代码集和变换码集，和 服务器的本机 wchar 代码集和变换码集。

字段详细信息

value

static final int value
IOR 多组件配置文件结构的代码集组件包括：
  • 服务器的本机 char 代码集和变换码集，和
  • 服务器的本机 wchar 代码集和变换码集。
char 和 wchar 变换码集都按照优先级 (preference) 顺序排列。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TAG_INTERNET_IOP (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TAG_INTERNET_IOP

public interface TAG_INTERNET_IOP

org/omg/IOP/TAG_INTERNET_IOP.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
标识支持网络 ORB 交换协议 (Internet Inter-ORB Protocol) 的配置文件。

字段详细信息

value

static final int value
标识支持网络 ORB 交换协议 (Internet Inter-ORB Protocol) 的配置文件。此配置文件的 ProfileBody 包含一个结构的 CDR 封装，该结构包含 IIOP 使用的寻址和对象识别信息。TAG_INTERNET_IOP 配置文件的 1.1 版也包括一个 TaggedComponent 对象数组，该数组可以包含支持可选 IIOP 功能、ORB 服务（如安全性），以及未来协议扩展的附加信息。

通过将附加配置文件信息编码为 TAG_INTERNET_IOP 配置文件中的组件，IIOP 以外的协议（如 ESIOP 和其他 GIOP）可以与 IIOP 共享配置文件信息（如对象标识或安全性信息）。所有 TAG_INTERNET_IOP 配置协议都支持 IIOP，无论它们是否还同时支持附加协议。可互操作的 ORB 不需要创建或理解任何其他配置文件，也不需要创建或理解任何为其他协议（可能与 IIOP 共享 TAG_INTERNET_IOP 配置文件）定义的组件。

TAG_INTERNET_IOP 配置文件的 profile_data 是 IIOP.ProfileBody_1_1 类型的 CDR 封装。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TAG_JAVA_CODEBASE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TAG_JAVA_CODEBASE

public interface TAG_JAVA_CODEBASE

org/omg/IOP/TAG_JAVA_CODEBASE.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
支持 stub、tie、value 和 value helper 的类下载。

字段详细信息

value

static final int value
支持 stub、tie、value 和 value helper 的类下载。该规范允许 stub 和 tie 的代码基信息在导线上传输，并可在相关时使用已存在的 ClassLoader。

对于 value 和 value helper，代码基在 value 标记后发送。对于 stub 和 tie，代码基是作为 IOR 配置文件中的 TaggedComponent TAG_JAVA_CODEBASE 来传输的，其中 component_data 是编写为 IDL 字符串的代码基的 CDR 封装。代码基是以空格分隔的一个或多个 URL 列表。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TAG_MULTIPLE_COMPONENTS (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TAG_MULTIPLE_COMPONENTS

public interface TAG_MULTIPLE_COMPONENTS

org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
指示封装的值类型为 MultipleComponentProfile。

字段详细信息

value

static final int value
指示封装的值类型为 MultipleComponentProfile。在这种情况下，配置文件由一列协议组件组成，它的使用必须通过使用此配置文件的协议指定。此配置文件可以用来携带 IOR 组件。

TAG_MULTIPLE_COMPONENTS 配置文件的 profile_data 是一个上文所示的 MultipleComponentProfile 类型的 CDR 封装。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TAG_ORB_TYPE (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TAG_ORB_TYPE

public interface TAG_ORB_TYPE

org/omg/IOP/TAG_ORB_TYPE.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
它在实际应用中通常很有用，能够标识生成对象引用的特定 ORB 种类、解决该特定 ORB 的问题，或者充分利用共享效率。

字段详细信息

value

static final int value
它在实际应用中通常很有用，能够标识生成对象引用的特定 ORB 种类、解决该特定 ORB 的问题，或者充分利用共享效率。

TAG_ORB_TYPE 组件有一个类型为无符号 long (Java long) 的关联值，该值被编码为 CDR 封装，指定由 OMG 为初始 ORB 的 ORB 类型分配的 ORB 类型 ID。通过向 OMG 提交一个对 ORB 类型的简短（一段）描述，任何人都可以注册任何 ORB 类型并接受一个返回的新 ORB 类型。ORB 类型描述和值所组成的列表将可用于 OMG 网服务器。

在任何 IOR 配置文件中，TAG_ORB_TYPE 组件最多可以出现一次。对于支持 IIOP 1.1 或更高版本的配置文件，则可以随意出现。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TAG_POLICIES (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TAG_POLICIES

public interface TAG_POLICIES

org/omg/IOP/TAG_POLICIES.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
一个包含 QoS 策略序列的配置文件组件，这些策略通过对象适配器与对象引用一起输出。

字段详细信息

value

static final int value
一个包含 QoS 策略序列的配置文件组件，这些策略通过对象适配器与对象引用一起输出。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TaggedComponent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 TaggedComponent

java.lang.Object
    继承者  org.omg.IOP.TaggedComponent
所有已实现的接口：
Serializable, IDLEntity
public final class TaggedComponent
extends Object
implements IDLEntity

org/omg/IOP/TaggedComponent.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
byte[] | component_data 与组件 id 关联的组件数据。
int | tag 以组件 id 形式表示的标记。
构造方法摘要
TaggedComponent()
TaggedComponent(int _tag, byte[] _component_data)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

tag

public int tag
以组件 id 形式表示的标记。

component_data

public byte[] component_data
与组件 id 关联的组件数据。

构造方法详细信息

TaggedComponent

public TaggedComponent()

TaggedComponent

public TaggedComponent(int _tag,
                       byte[] _component_data)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TAG_RMI_CUSTOM_MAX_STREAM_FORMAT (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

public interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
RMI-IIOP 具有多个流格式形式。

字段详细信息

value

static final int value
RMI-IIOP 具有多个流格式形式。服务器可以指定其最大形式，这可通过包括加上 TAG_RMI_CUSTOM_MAX_STREAM_FORMAT 标记的组件实现，也可以通过默认值实现，对于 GIOP 1.2 及较低版本，默认使用格式 1，对于 GIOP 1.3 及较高版本，默认使用格式 2。 参见 Java to IDL ptc/02-01-12 1.4.11。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TaggedComponentHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 TaggedComponentHelper

java.lang.Object
    继承者  org.omg.IOP.TaggedComponentHelper

public abstract class TaggedComponentHelper
extends Object

org/omg/IOP/TaggedComponentHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

构造方法摘要
TaggedComponentHelper()
方法摘要
static TaggedComponent | extract(Any a)
static String | id()
static void | insert(Any a, TaggedComponent that)
static TaggedComponent | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TaggedComponent value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TaggedComponentHelper

public TaggedComponentHelper()
方法详细信息

insert

public static void insert(Any a,
                          TaggedComponent that)

extract

public static TaggedComponent extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TaggedComponent read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TaggedComponent value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TaggedComponentHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 TaggedComponentHolder

java.lang.Object
    继承者  org.omg.IOP.TaggedComponentHolder
所有已实现的接口：
Streamable
public final class TaggedComponentHolder
extends Object
implements Streamable

org/omg/IOP/TaggedComponentHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
 TaggedComponent value
构造方法摘要
TaggedComponentHolder()
TaggedComponentHolder(TaggedComponent initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public TaggedComponent value
构造方法详细信息

TaggedComponentHolder

public TaggedComponentHolder()

TaggedComponentHolder

public TaggedComponentHolder(TaggedComponent initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TaggedProfile (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 TaggedProfile

java.lang.Object
    继承者  org.omg.IOP.TaggedProfile
所有已实现的接口：
Serializable, IDLEntity
public final class TaggedProfile
extends Object
implements IDLEntity

org/omg/IOP/TaggedProfile.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
byte[] | profile_data 关联的配置文件数据。
int | tag 以配置文件 id 形式表示的标记。
构造方法摘要
TaggedProfile()
TaggedProfile(int _tag, byte[] _profile_data)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

tag

public int tag
以配置文件 id 形式表示的标记。

profile_data

public byte[] profile_data
关联的配置文件数据。

构造方法详细信息

TaggedProfile

public TaggedProfile()

TaggedProfile

public TaggedProfile(int _tag,
                     byte[] _profile_data)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TaggedProfileHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 TaggedProfileHelper

java.lang.Object
    继承者  org.omg.IOP.TaggedProfileHelper

public abstract class TaggedProfileHelper
extends Object

org/omg/IOP/TaggedProfileHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

构造方法摘要
TaggedProfileHelper()
方法摘要
static TaggedProfile | extract(Any a)
static String | id()
static void | insert(Any a, TaggedProfile that)
static TaggedProfile | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TaggedProfile value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TaggedProfileHelper

public TaggedProfileHelper()
方法详细信息

insert

public static void insert(Any a,
                          TaggedProfile that)

extract

public static TaggedProfile extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TaggedProfile read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TaggedProfile value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TaggedProfileHolder (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
类 TaggedProfileHolder

java.lang.Object
    继承者  org.omg.IOP.TaggedProfileHolder
所有已实现的接口：
Streamable
public final class TaggedProfileHolder
extends Object
implements Streamable

org/omg/IOP/TaggedProfileHolder.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
 TaggedProfile value
构造方法摘要
TaggedProfileHolder()
TaggedProfileHolder(TaggedProfile initialValue)
方法摘要
void | _read(InputStream i) 从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
TypeCode | _type() 检索对应于 Holder 中 value 字段值的 TypeCode 对象。
void | _write(OutputStream o) 将 Holder 中 value 字段的值编组到 ostream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

public TaggedProfile value
构造方法详细信息

TaggedProfileHolder

public TaggedProfileHolder()

TaggedProfileHolder

public TaggedProfileHolder(TaggedProfile initialValue)
方法详细信息

_read

public void _read(InputStream i)
从接口 Streamable 复制的描述
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。

指定者：
接口 Streamable 中的 _read
参数：
i - 表示导线中 CDR 数据的 InputStream。

_write

public void _write(OutputStream o)
从接口 Streamable 复制的描述
将 Holder 中 value 字段的值编组到 ostream。

指定者：
接口 Streamable 中的 _write
参数：
o - CDR OutputStream

_type

public TypeCode _type()
从接口 Streamable 复制的描述
检索对应于 Holder 中 value 字段值的 TypeCode 对象。

指定者：
接口 Streamable 中的 _type
返回：
TypeCode 对象，对应于 holder 中保存的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransactionService (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP
接口 TransactionService

public interface TransactionService

org/omg/IOP/TransactionService.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:06 (GMT-08:00)。

字段摘要
static int value
标识一个定义在 CORBAservices: Common Object Services Specifications 中的 CosTSInteroperation.PropogationContext 的 CDR 封装。

字段详细信息

value

static final int value
标识一个定义在 CORBAservices: Common Object Services Specifications 中的 CosTSInteroperation.PropogationContext 的 CDR 封装。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.IOP (Java Platform SE 6)

 org.omg.IOP
接口
Codec
CodecFactory
CodecFactoryOperations
CodecOperations
CodeSets
ENCODING_CDR_ENCAPS
ExceptionDetailMessage
RMICustomMaxStreamFormat
TAG_ALTERNATE_IIOP_ADDRESS
TAG_CODE_SETS
TAG_INTERNET_IOP
TAG_JAVA_CODEBASE
TAG_MULTIPLE_COMPONENTS
TAG_ORB_TYPE
TAG_POLICIES
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
TransactionService
类
CodecFactoryHelper
ComponentIdHelper
Encoding
IOR
IORHelper
IORHolder
MultipleComponentProfileHelper
MultipleComponentProfileHolder
ProfileIdHelper
ServiceContext
ServiceContextHelper
ServiceContextHolder
ServiceContextListHelper
ServiceContextListHolder
ServiceIdHelper
TaggedComponent
TaggedComponentHelper
TaggedComponentHolder
TaggedProfile
TaggedProfileHelper
TaggedProfileHolder


org.omg.IOP (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.IOP

此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

请参见：
描述

接口摘要
Codec | IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
CodecFactory | Codec 可从 CodecFactory 中获得。
CodecFactoryOperations | Codec 可从 CodecFactory 中获得。
CodecOperations | IOR 组件格式和 ORB 服务使用的服务上下文数据通常被定义为 IDL 定义数据类型的 CDR 封装编码实例。
CodeSets | org/omg/IOP/CodeSets.java。
ENCODING_CDR_ENCAPS | org/omg/IOP/ENCODING_CDR_ENCAPS.java。
ExceptionDetailMessage | org/omg/IOP/ExceptionDetailMessage.java。
RMICustomMaxStreamFormat | org/omg/IOP/RMICustomMaxStreamFormat.java。
TAG_ALTERNATE_IIOP_ADDRESS | org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java。
TAG_CODE_SETS | org/omg/IOP/TAG_CODE_SETS.java。
TAG_INTERNET_IOP | org/omg/IOP/TAG_INTERNET_IOP.java。
TAG_JAVA_CODEBASE | org/omg/IOP/TAG_JAVA_CODEBASE.java。
TAG_MULTIPLE_COMPONENTS | org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java。
TAG_ORB_TYPE | org/omg/IOP/TAG_ORB_TYPE.java。
TAG_POLICIES | org/omg/IOP/TAG_POLICIES.java。
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT | org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java。
TransactionService | org/omg/IOP/TransactionService.java。

类摘要
CodecFactoryHelper | Codec 可从 CodecFactory 中获得。
ComponentIdHelper | 表示多组件配置文件的标准方式。
Encoding | org/omg/IOP/Encoding.java。
IOR | org/omg/IOP/IOR.java。
IORHelper | org/omg/IOP/IORHelper.java。
IORHolder | org/omg/IOP/IORHolder.java。
MultipleComponentProfileHelper | 形成多组件配置文件的一组加标记的组件。
MultipleComponentProfileHolder | 形成多组件配置文件的一组加标记的组件。
ProfileIdHelper | 配置文件 ID
ServiceContext | org/omg/IOP/ServiceContext.java。
ServiceContextHelper | org/omg/IOP/ServiceContextHelper.java。
ServiceContextHolder | org/omg/IOP/ServiceContextHolder.java。
ServiceContextListHelper | 形成服务上下文列表的一组服务上下文。
ServiceContextListHolder | 形成服务上下文列表的一组服务上下文。
ServiceIdHelper | 以 int 形式表示的服务 id
TaggedComponent | org/omg/IOP/TaggedComponent.java。
TaggedComponentHelper | org/omg/IOP/TaggedComponentHelper.java。
TaggedComponentHolder | org/omg/IOP/TaggedComponentHolder.java。
TaggedProfile | org/omg/IOP/TaggedProfile.java。
TaggedProfileHelper | org/omg/IOP/TaggedProfileHelper.java。
TaggedProfileHolder | org/omg/IOP/TaggedProfileHolder.java。

软件包 org.omg.IOP 的描述

此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。有关更多细节，请参阅该 OMG 规范。

请注意，我们并没有提供该规范中 IOP 模块的所有部分。只提供那些在公共 API（尤其是 Portable Interceptor）中作为返回值和参数类型引用的部分。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.IOP 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.IOP 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.IOP.CodecFactoryHelper
    • org.omg.IOP.ComponentIdHelper
    • org.omg.IOP.Encoding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IOR (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IORHelper
    • org.omg.IOP.IORHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.MultipleComponentProfileHelper
    • org.omg.IOP.MultipleComponentProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ProfileIdHelper
    • org.omg.IOP.ServiceContext (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.ServiceContextHelper
    • org.omg.IOP.ServiceContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceContextListHelper
    • org.omg.IOP.ServiceContextListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceIdHelper
    • org.omg.IOP.TaggedComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedComponentHelper
    • org.omg.IOP.TaggedComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.TaggedProfile (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedProfileHelper
    • org.omg.IOP.TaggedProfileHolder (implements org.omg.CORBA.portable.Streamable)

接口分层结构

  • org.omg.IOP.CodecFactoryOperations
    • org.omg.IOP.CodecFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodecOperations
    • org.omg.IOP.Codec (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodeSets
  • org.omg.IOP.ENCODING_CDR_ENCAPS
  • org.omg.IOP.ExceptionDetailMessage
  • org.omg.CORBA.Object
    • org.omg.IOP.Codec (并 extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.CodecFactory (并 extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity)
  • org.omg.IOP.RMICustomMaxStreamFormat
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.IOP.Codec (并 extends org.omg.IOP.CodecOperations, org.omg.CORBA.Object)
      • org.omg.IOP.CodecFactory (并 extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.Object)
  • org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
  • org.omg.IOP.TAG_CODE_SETS
  • org.omg.IOP.TAG_INTERNET_IOP
  • org.omg.IOP.TAG_JAVA_CODEBASE
  • org.omg.IOP.TAG_MULTIPLE_COMPONENTS
  • org.omg.IOP.TAG_ORB_TYPE
  • org.omg.IOP.TAG_POLICIES
  • org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • org.omg.IOP.TransactionService
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.IOP 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.IOP
的使用

使用 org.omg.IOP 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 使用的 org.omg.IOP 中的类
Codec
IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
CodecFactory
Codec 可从 CodecFactory 中获得。
CodecFactoryOperations
Codec 可从 CodecFactory 中获得。
CodecOperations
IOR 组件格式和 ORB 服务使用的服务上下文数据通常被定义为 IDL 定义数据类型的 CDR 封装编码实例。
Encoding
org/omg/IOP/Encoding.java。
IOR
org/omg/IOP/IOR.java。
ServiceContext
org/omg/IOP/ServiceContext.java。
TaggedComponent
org/omg/IOP/TaggedComponent.java。
TaggedProfile
org/omg/IOP/TaggedProfile.java。

org.omg.PortableInterceptor 使用的 org.omg.IOP 中的类
CodecFactory
Codec 可从 CodecFactory 中获得。
ServiceContext
org/omg/IOP/ServiceContext.java。
TaggedComponent
org/omg/IOP/TaggedComponent.java。
TaggedProfile
org/omg/IOP/TaggedProfile.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


UnknownEncoding (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP.CodecFactoryPackage
类 UnknownEncoding

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.IOP.CodecFactoryPackage.UnknownEncoding
所有已实现的接口：
Serializable, IDLEntity
public final class UnknownEncoding
extends UserException

org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

构造方法摘要
UnknownEncoding()
UnknownEncoding(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownEncoding

public UnknownEncoding()

UnknownEncoding

public UnknownEncoding(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


UnknownEncodingHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP.CodecFactoryPackage
类 UnknownEncodingHelper

java.lang.Object
    继承者  org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

public abstract class UnknownEncodingHelper
extends Object

org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

构造方法摘要
UnknownEncodingHelper()
方法摘要
static UnknownEncoding | extract(Any a)
static String | id()
static void | insert(Any a, UnknownEncoding that)
static UnknownEncoding | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, UnknownEncoding value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UnknownEncodingHelper

public UnknownEncodingHelper()
方法详细信息

insert

public static void insert(Any a,
                          UnknownEncoding that)

extract

public static UnknownEncoding extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static UnknownEncoding read(InputStream istream)

write

public static void write(OutputStream ostream,
                         UnknownEncoding value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.IOP.CodecFactoryPackage (Java Platform SE 6)

 org.omg.IOP.CodecFactoryPackage
类
UnknownEncodingHelper
异常
UnknownEncoding


org.omg.IOP.CodecFactoryPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.IOP.CodecFactoryPackage

此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

请参见：
描述

类摘要
UnknownEncodingHelper org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java。

异常摘要
UnknownEncoding org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

软件包 org.omg.IOP.CodecFactoryPackage 的描述

此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.IOP.CodecFactoryPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.IOP.CodecFactoryPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.IOP.CodecFactoryPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.IOP.CodecFactoryPackage
的使用

使用 org.omg.IOP.CodecFactoryPackage 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

org.omg.IOP 使用的 org.omg.IOP.CodecFactoryPackage 中的类
UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecFactoryPackage 使用的 org.omg.IOP.CodecFactoryPackage 中的类
UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecFactoryPackage.UnknownEncoding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecFactoryPackage.UnknownEncoding
的使用

使用 UnknownEncoding 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

org.omg.IOP 中 UnknownEncoding 的使用

抛出 UnknownEncoding 的 org.omg.IOP 中的方法
 Codec CodecFactoryOperations.create_codec(Encoding enc)
创建一个给定编码的 Codec。

org.omg.IOP.CodecFactoryPackage 中 UnknownEncoding 的使用

返回 UnknownEncoding 的 org.omg.IOP.CodecFactoryPackage 中的方法
static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
static UnknownEncoding | UnknownEncodingHelper.read(InputStream istream)

参数类型为 UnknownEncoding 的 org.omg.IOP.CodecFactoryPackage 中的方法
static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)
static void | UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
的使用

没有 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


FormatMismatch (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP.CodecPackage
类 FormatMismatch

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.IOP.CodecPackage.FormatMismatch
所有已实现的接口：
Serializable, IDLEntity
public final class FormatMismatch
extends UserException

org/omg/IOP/CodecPackage/FormatMismatch.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

构造方法摘要
FormatMismatch()
FormatMismatch(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FormatMismatch

public FormatMismatch()

FormatMismatch

public FormatMismatch(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FormatMismatchHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP.CodecPackage
类 FormatMismatchHelper

java.lang.Object
    继承者  org.omg.IOP.CodecPackage.FormatMismatchHelper

public abstract class FormatMismatchHelper
extends Object

org/omg/IOP/CodecPackage/FormatMismatchHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

构造方法摘要
FormatMismatchHelper()
方法摘要
static FormatMismatch | extract(Any a)
static String | id()
static void | insert(Any a, FormatMismatch that)
static FormatMismatch | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, FormatMismatch value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FormatMismatchHelper

public FormatMismatchHelper()
方法详细信息

insert

public static void insert(Any a,
                          FormatMismatch that)

extract

public static FormatMismatch extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static FormatMismatch read(InputStream istream)

write

public static void write(OutputStream ostream,
                         FormatMismatch value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidTypeForEncoding (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP.CodecPackage
类 InvalidTypeForEncoding

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.IOP.CodecPackage.InvalidTypeForEncoding
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidTypeForEncoding
extends UserException

org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

构造方法摘要
InvalidTypeForEncoding()
InvalidTypeForEncoding(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidTypeForEncoding

public InvalidTypeForEncoding()

InvalidTypeForEncoding

public InvalidTypeForEncoding(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidTypeForEncodingHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP.CodecPackage
类 InvalidTypeForEncodingHelper

java.lang.Object
    继承者  org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

public abstract class InvalidTypeForEncodingHelper
extends Object

org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

构造方法摘要
InvalidTypeForEncodingHelper()
方法摘要
static InvalidTypeForEncoding | extract(Any a)
static String | id()
static void | insert(Any a, InvalidTypeForEncoding that)
static InvalidTypeForEncoding | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidTypeForEncoding value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InvalidTypeForEncodingHelper

public InvalidTypeForEncodingHelper()
方法详细信息

insert

public static void insert(Any a,
                          InvalidTypeForEncoding that)

extract

public static InvalidTypeForEncoding extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidTypeForEncoding read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidTypeForEncoding value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeMismatch (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP.CodecPackage
类 TypeMismatch

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.IOP.CodecPackage.TypeMismatch
所有已实现的接口：
Serializable, IDLEntity
public final class TypeMismatch
extends UserException

org/omg/IOP/CodecPackage/TypeMismatch.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

构造方法摘要
TypeMismatch()
TypeMismatch(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TypeMismatch

public TypeMismatch()

TypeMismatch

public TypeMismatch(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeMismatchHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.IOP.CodecPackage
类 TypeMismatchHelper

java.lang.Object
    继承者  org.omg.IOP.CodecPackage.TypeMismatchHelper

public abstract class TypeMismatchHelper
extends Object

org/omg/IOP/CodecPackage/TypeMismatchHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/IOP.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:07 (GMT-08:00)。

构造方法摘要
TypeMismatchHelper()
方法摘要
static TypeMismatch | extract(Any a)
static String | id()
static void | insert(Any a, TypeMismatch that)
static TypeMismatch | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TypeMismatch value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TypeMismatchHelper

public TypeMismatchHelper()
方法详细信息

insert

public static void insert(Any a,
                          TypeMismatch that)

extract

public static TypeMismatch extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TypeMismatch read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TypeMismatch value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.IOP.CodecPackage (Java Platform SE 6)

 org.omg.IOP.CodecPackage
类
FormatMismatchHelper
InvalidTypeForEncodingHelper
TypeMismatchHelper
异常
FormatMismatch
InvalidTypeForEncoding
TypeMismatch


org.omg.IOP.CodecPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.IOP.CodecPackage

此包根据 IOP::Codec IDL 接口定义生成。

请参见：
描述

类摘要
FormatMismatchHelper | org/omg/IOP/CodecPackage/FormatMismatchHelper.java。
InvalidTypeForEncodingHelper | org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java。
TypeMismatchHelper | org/omg/IOP/CodecPackage/TypeMismatchHelper.java。

异常摘要
FormatMismatch | org/omg/IOP/CodecPackage/FormatMismatch.java。
InvalidTypeForEncoding | org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。
TypeMismatch | org/omg/IOP/CodecPackage/TypeMismatch.java。

软件包 org.omg.IOP.CodecPackage 的描述

此包根据 IOP::Codec IDL 接口定义生成。它包含 IOP::Codec（作为 Portable Interceptor 规范的一部分）中指定的 IDL 异常的 Java 表示形式。有关更多细节，请参阅该 OMG 规范。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.IOP.CodecPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.IOP.CodecPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.IOP.CodecPackage.FormatMismatchHelper
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.IOP.CodecPackage.FormatMismatch
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
          • org.omg.IOP.CodecPackage.TypeMismatch
    • org.omg.IOP.CodecPackage.TypeMismatchHelper
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.IOP.CodecPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.IOP.CodecPackage
的使用

使用 org.omg.IOP.CodecPackage 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。

org.omg.IOP 使用的 org.omg.IOP.CodecPackage 中的类
FormatMismatch
org/omg/IOP/CodecPackage/FormatMismatch.java。
InvalidTypeForEncoding
org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。
TypeMismatch
org/omg/IOP/CodecPackage/TypeMismatch.java。

org.omg.IOP.CodecPackage 使用的 org.omg.IOP.CodecPackage 中的类
FormatMismatch
org/omg/IOP/CodecPackage/FormatMismatch.java。
InvalidTypeForEncoding
org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。
TypeMismatch
org/omg/IOP/CodecPackage/TypeMismatch.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.FormatMismatch 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.FormatMismatch
的使用

使用 FormatMismatch 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。

org.omg.IOP 中 FormatMismatch 的使用

抛出 FormatMismatch 的 org.omg.IOP 中的方法
Any | CodecOperations.decode_value(byte[] data, TypeCode tc) 基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
Any | CodecOperations.decode(byte[] data) 基于对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

org.omg.IOP.CodecPackage 中 FormatMismatch 的使用

返回 FormatMismatch 的 org.omg.IOP.CodecPackage 中的方法
static FormatMismatch | FormatMismatchHelper.extract(Any a)
static FormatMismatch | FormatMismatchHelper.read(InputStream istream)

参数类型为 FormatMismatch 的 org.omg.IOP.CodecPackage 中的方法
static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.FormatMismatchHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.FormatMismatchHelper
的使用

没有 org.omg.IOP.CodecPackage.FormatMismatchHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.InvalidTypeForEncoding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.InvalidTypeForEncoding
的使用

使用 InvalidTypeForEncoding 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。

org.omg.IOP 中 InvalidTypeForEncoding 的使用

抛出 InvalidTypeForEncoding 的 org.omg.IOP 中的方法
byte[] | CodecOperations.encode_value(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
byte[] | CodecOperations.encode(Any data) 基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。

org.omg.IOP.CodecPackage 中 InvalidTypeForEncoding 的使用

返回 InvalidTypeForEncoding 的 org.omg.IOP.CodecPackage 中的方法
static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)

参数类型为 InvalidTypeForEncoding 的 org.omg.IOP.CodecPackage 中的方法
static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
的使用

没有 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.TypeMismatch 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.TypeMismatch
的使用

使用 TypeMismatch 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。

org.omg.IOP 中 TypeMismatch 的使用

抛出 TypeMismatch 的 org.omg.IOP 中的方法
 Any CodecOperations.decode_value(byte[] data, TypeCode tc)
基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。

org.omg.IOP.CodecPackage 中 TypeMismatch 的使用

返回 TypeMismatch 的 org.omg.IOP.CodecPackage 中的方法
static TypeMismatch | TypeMismatchHelper.extract(Any a)
static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

参数类型为 TypeMismatch 的 org.omg.IOP.CodecPackage 中的方法
static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecPackage.TypeMismatchHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecPackage.TypeMismatchHelper
的使用

没有 org.omg.IOP.CodecPackage.TypeMismatchHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.CodeSets 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.CodeSets
的使用

没有 org.omg.IOP.CodeSets 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.Codec 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.Codec
的使用

使用 Codec 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 Codec 的使用

返回 Codec 的 org.omg.IOP 中的方法
 Codec CodecFactoryOperations.create_codec(Encoding enc)
创建一个给定编码的 Codec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.CodecFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.CodecFactory
的使用

使用 CodecFactory 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 中 CodecFactory 的使用

返回 CodecFactory 的 org.omg.IOP 中的方法
static CodecFactory | CodecFactoryHelper.extract(Any a)
static CodecFactory | CodecFactoryHelper.narrow(Object obj)
static CodecFactory | CodecFactoryHelper.read(InputStream istream)
static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)

参数类型为 CodecFactory 的 org.omg.IOP 中的方法
static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)

org.omg.PortableInterceptor 中 CodecFactory 的使用

返回 CodecFactory 的 org.omg.PortableInterceptor 中的方法
 CodecFactory ORBInitInfoOperations.codec_factory()
返回 IOP.CodecFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.CodecFactoryHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.CodecFactoryHelper
的使用

没有 org.omg.IOP.CodecFactoryHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.CodecFactoryOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.CodecFactoryOperations
的使用

使用 CodecFactoryOperations 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 CodecFactoryOperations 的使用

org.omg.IOP 中 CodecFactoryOperations 的子接口
 interface CodecFactory
Codec 可从 CodecFactory 中获得。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.CodecOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.CodecOperations
的使用

使用 CodecOperations 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 CodecOperations 的使用

org.omg.IOP 中 CodecOperations 的子接口
 interface Codec
IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.ComponentIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ComponentIdHelper
的使用

没有 org.omg.IOP.ComponentIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.ENCODING_CDR_ENCAPS 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.ENCODING_CDR_ENCAPS
的使用

没有 org.omg.IOP.ENCODING_CDR_ENCAPS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.Encoding 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.Encoding
的使用

使用 Encoding 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 Encoding 的使用

参数类型为 Encoding 的 org.omg.IOP 中的方法
 Codec CodecFactoryOperations.create_codec(Encoding enc)
创建一个给定编码的 Codec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.ExceptionDetailMessage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.ExceptionDetailMessage
的使用

没有 org.omg.IOP.ExceptionDetailMessage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.IOR 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.IOR
的使用

使用 IOR 的软件包
org.omg.IOP 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP 中 IOR 的使用

声明为 IOR 的 org.omg.IOP 中的字段
 IOR IORHolder.value

返回 IOR 的 org.omg.IOP 中的方法
static IOR | IORHelper.extract(Any a)
static IOR | IORHelper.read(InputStream istream)

参数类型为 IOR 的 org.omg.IOP 中的方法
static void | IORHelper.insert(Any a, IOR that)
static void | IORHelper.write(OutputStream ostream, IOR value)

参数类型为 IOR 的 org.omg.IOP 中的构造方法
IORHolder(IOR initialValue)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.IORHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.IORHelper
的使用

没有 org.omg.IOP.IORHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.IORHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.IORHolder
的使用

没有 org.omg.IOP.IORHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.MultipleComponentProfileHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.MultipleComponentProfileHelper
的使用

没有 org.omg.IOP.MultipleComponentProfileHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.MultipleComponentProfileHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.MultipleComponentProfileHolder
的使用

没有 org.omg.IOP.MultipleComponentProfileHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.ProfileIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ProfileIdHelper
的使用

没有 org.omg.IOP.ProfileIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.RMICustomMaxStreamFormat 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.RMICustomMaxStreamFormat
的使用

没有 org.omg.IOP.RMICustomMaxStreamFormat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContext
的使用

使用 ServiceContext 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 中 ServiceContext 的使用

声明为 ServiceContext 的 org.omg.IOP 中的字段
ServiceContext | ServiceContextHolder.value
ServiceContext[] | ServiceContextListHolder.value

返回 ServiceContext 的 org.omg.IOP 中的方法
static ServiceContext | ServiceContextHelper.extract(Any a)
static ServiceContext[] | ServiceContextListHelper.extract(Any a)
static ServiceContext | ServiceContextHelper.read(InputStream istream)
static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)

参数类型为 ServiceContext 的 org.omg.IOP 中的方法
static void | ServiceContextHelper.insert(Any a, ServiceContext that)
static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)

参数类型为 ServiceContext 的 org.omg.IOP 中的构造方法
ServiceContextHolder(ServiceContext initialValue)
ServiceContextListHolder(ServiceContext[] initialValue)

org.omg.PortableInterceptor 中 ServiceContext 的使用

返回 ServiceContext 的 org.omg.PortableInterceptor 中的方法
ServiceContext | RequestInfoOperations.get_reply_service_context(int id) 返回具有给定 ID 的与应答关联的服务上下文复本。
ServiceContext | RequestInfoOperations.get_request_service_context(int id) 返回具有给定 ID 的与请求关联的服务上下文复本。

参数类型为 ServiceContext 的 org.omg.PortableInterceptor 中的方法
void | ServerRequestInfoOperations.add_reply_service_context(ServiceContext service_context, boolean replace) 允许 Interceptor 将服务上下文添加到请求。
void | ClientRequestInfoOperations.add_request_service_context(ServiceContext service_context, boolean replace) 允许 Interceptor 将服务上下文添加到请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContextHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContextHelper
的使用

没有 org.omg.IOP.ServiceContextHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContextHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContextHolder
的使用

没有 org.omg.IOP.ServiceContextHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContextListHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContextListHelper
的使用

没有 org.omg.IOP.ServiceContextListHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.ServiceContextListHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceContextListHolder
的使用

没有 org.omg.IOP.ServiceContextListHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.ServiceIdHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.ServiceIdHelper
的使用

没有 org.omg.IOP.ServiceIdHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
的使用

没有 org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_CODE_SETS 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_CODE_SETS
的使用

没有 org.omg.IOP.TAG_CODE_SETS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_INTERNET_IOP 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_INTERNET_IOP
的使用

没有 org.omg.IOP.TAG_INTERNET_IOP 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_JAVA_CODEBASE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_JAVA_CODEBASE
的使用

没有 org.omg.IOP.TAG_JAVA_CODEBASE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_MULTIPLE_COMPONENTS 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_MULTIPLE_COMPONENTS
的使用

没有 org.omg.IOP.TAG_MULTIPLE_COMPONENTS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_ORB_TYPE 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_ORB_TYPE
的使用

没有 org.omg.IOP.TAG_ORB_TYPE 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_POLICIES 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_POLICIES
的使用

没有 org.omg.IOP.TAG_POLICIES 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.TaggedComponent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedComponent
的使用

使用 TaggedComponent 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 中 TaggedComponent 的使用

声明为 TaggedComponent 的 org.omg.IOP 中的字段
TaggedComponent[] | MultipleComponentProfileHolder.value
TaggedComponent | TaggedComponentHolder.value

返回 TaggedComponent 的 org.omg.IOP 中的方法
static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
static TaggedComponent | TaggedComponentHelper.extract(Any a)
static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
static TaggedComponent | TaggedComponentHelper.read(InputStream istream)

参数类型为 TaggedComponent 的 org.omg.IOP 中的方法
static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)

参数类型为 TaggedComponent 的 org.omg.IOP 中的构造方法
MultipleComponentProfileHolder(TaggedComponent[] initialValue)
TaggedComponentHolder(TaggedComponent initialValue)

org.omg.PortableInterceptor 中 TaggedComponent 的使用

返回 TaggedComponent 的 org.omg.PortableInterceptor 中的方法
TaggedComponent | ClientRequestInfoOperations.get_effective_component(int id) 返回为此请求选择的配置文件中带有给定 ID 的 IOP.TaggedComponent。
TaggedComponent[] | ClientRequestInfoOperations.get_effective_components(int id) 返回为此请求选择的配置文件中具有给定 ID 的带标记组件所组成的数组。

参数类型为 TaggedComponent 的 org.omg.PortableInterceptor 中的方法
void | IORInfoOperations.add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id) 可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component_to_profile，以便向构造 IOR 时要包括的设置添加带标记的组件。
void | IORInfoOperations.add_ior_component(TaggedComponent tagged_component) 可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component，以便向构造 IOR 时要包括的设置添加带标记的组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
的使用

没有 org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.TaggedComponentHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedComponentHelper
的使用

没有 org.omg.IOP.TaggedComponentHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.TaggedComponentHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedComponentHolder
的使用

没有 org.omg.IOP.TaggedComponentHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.TaggedProfile 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedProfile
的使用

使用 TaggedProfile 的软件包
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.IOP 中 TaggedProfile 的使用

声明为 TaggedProfile 的 org.omg.IOP 中的字段
TaggedProfile[] | IOR.profiles 与此对象引用关联的一组有标记的配置文件。
TaggedProfile | TaggedProfileHolder.value

返回 TaggedProfile 的 org.omg.IOP 中的方法
static TaggedProfile | TaggedProfileHelper.extract(Any a)
static TaggedProfile | TaggedProfileHelper.read(InputStream istream)

参数类型为 TaggedProfile 的 org.omg.IOP 中的方法
static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)
static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)

参数类型为 TaggedProfile 的 org.omg.IOP 中的构造方法
IOR(String _type_id, TaggedProfile[] _profiles)
TaggedProfileHolder(TaggedProfile initialValue)

org.omg.PortableInterceptor 中 TaggedProfile 的使用

返回 TaggedProfile 的 org.omg.PortableInterceptor 中的方法
 TaggedProfile ClientRequestInfoOperations.effective_profile()
返回将用来发送请求的配置文件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.TaggedProfileHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedProfileHelper
的使用

没有 org.omg.IOP.TaggedProfileHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.IOP.TaggedProfileHolder 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.IOP.TaggedProfileHolder
的使用

没有 org.omg.IOP.TaggedProfileHolder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.IOP.TransactionService 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.IOP.TransactionService
的使用

没有 org.omg.IOP.TransactionService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Parameter (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.Dynamic
类 Parameter

java.lang.Object
    继承者  org.omg.Dynamic.Parameter
所有已实现的接口：
Serializable, IDLEntity
public final class Parameter
extends Object
implements IDLEntity

org/omg/Dynamic/Parameter.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/PortableInterceptor/Interceptors.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:09 (GMT-08:00)。

字段摘要
Any | argument
ParameterMode | mode
构造方法摘要
Parameter()
Parameter(Any _argument, ParameterMode _mode)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

argument

public Any argument

mode

public ParameterMode mode
构造方法详细信息

Parameter

public Parameter()

Parameter

public Parameter(Any _argument,
                 ParameterMode _mode)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.Dynamic (Java Platform SE 6)

 org.omg.Dynamic
类
Parameter


org.omg.Dynamic (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.Dynamic

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。

请参见：
描述

类摘要
Parameter org/omg/Dynamic/Parameter.java。

软件包 org.omg.Dynamic 的描述

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。有关更多细节，请参阅该 OMG 规范。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.Dynamic 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.Dynamic 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.Dynamic.Parameter (implements org.omg.CORBA.portable.IDLEntity)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.Dynamic 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.Dynamic
的使用

使用 org.omg.Dynamic 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 使用的 org.omg.Dynamic 中的类
Parameter
org/omg/Dynamic/Parameter.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.Dynamic.Parameter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.Dynamic.Parameter
的使用

使用 Parameter 的软件包
org.omg.PortableInterceptor 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor 中 Parameter 的使用

返回 Parameter 的 org.omg.PortableInterceptor 中的方法
 Parameter[] RequestInfoOperations.arguments()
返回一个 Parameter 对象数组，包含将调用的操作上的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


_DynAnyFactoryStub (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynAnyFactoryStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynAnyFactoryStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAnyFactory, DynAnyFactoryOperations
public class _DynAnyFactoryStub
extends ObjectImpl
implements DynAnyFactory

DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。一般来说，只有两种创建 DynAny 对象的方式：

  • 调用现有 DynAny 对象上的操作
  • 调用 DynAnyFactory 对象上的操作
已构造的 DynAny 对象支持允许创建新 DynAny 对象的操作，可在这些对象中封装对某个成分值的访问权限。DynAny 对象还支持用于创建新 DynAny 对象的复制操作。通过调用 ORB.resolve_initial_references() 并将标识符参数设置为字符串常量 "DynAnyFactory"，可以获取 DynAnyFactory 对象的引用。

动态解释 any 的第一步通常是使用 create_dyn_any() 创建 DynAny 对象。所得 DynAny 对象引用集中于 DynFixed、DynStruct、DynSequence、DynArray、DynUnion、DynEnum 或 DynValue 这几种对象引用，因 any 的类型而异。

动态创建 any 需要使用 create_dyn_any_from_type_code() 创建 DynAny 对象，并传递与要创建的值关联的 TypeCode。返回的引用将集中为复合类型之一，如 DynStruct（如果合适）。然后，通过在所得对象上调用操作来初始化值。最后，可调用 to_any 操作根据已构造的 DynAny 创建 any 值。

字段摘要
static Class _opsClass
构造方法摘要
_DynAnyFactoryStub()
方法摘要
String[] | _ids() 获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
DynAny | create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynAnyFactoryStub

public _DynAnyFactoryStub()
方法详细信息

create_dyn_any

public DynAny create_dyn_any(Any value)
                      throws InconsistentTypeCode
根据 any 值创建新 DynAny 对象。将与 any 值关联的 TypeCode 的副本分配给所得 DynAny 对象。与 DynAny 对象关联的值是原始 any 中值的副本。如果传递的值具有组件，则将已创建的 DynAny 的当前位置设置为 0；否则设置为 -1。

指定者：
接口 DynAnyFactoryOperations 中的 create_dyn_any
抛出：
InconsistentTypeCode - 如果值具有 TCKind 为 tk_Principal、tk_native 或 tk_abstract_interface 的 TypeCode

create_dyn_any_from_type_code

public DynAny create_dyn_any_from_type_code(TypeCode type)
                                     throws InconsistentTypeCode
根据 TypeCode 创建 DynAny。根据 TypeCode 的不同，创建的对象可能为 DynAny 类型，也可能为其派生类型之一（如 DynStruct）。返回的引用可以集中为派生类型。无论是哪种情况，根据 TypeCode 构造的 DynAny 都具有初始默认值。基本类型的默认值如下：
  • false，用于 boolean
  • 0，用于 numeric 类型
  • 0，用于类型 octet、char 和 wchar
  • 空字符串，用于 string 和 wstring
  • null，用于对象引用
  • 带有 TCKind 值为 tk_null 的类型代码，用于类型代码
  • 包含带有 TCKind 值为 tk_null 的类型代码但不包含任何值的 any，用于 any 值
对于复合类型，创建相应 DynAny 时默认值的分配如下：
  • 对于 DynSequence，它将当前位置设置为 -1 并创建空序列。
  • 对于 DynEnum，它将当前位置设置为 -1，并将计数器 (enumerator) 的值设置为 TypeCode 指示的第一个计数器值。
  • 对于 DynFixed，它将当前位置设置为 -1 并将值设置为 0。
  • 对于 DynStruct，它将空异常的当前位置设置为 -1，所有其他 TypeCode 的当前位置都设置为 0。成员（如果有）将被初始化（递归式）为其默认值。
  • 对于 DynArray，它将当前位置设置为 0 并将元素（递归式）初始化为其默认值。
  • 对于 DynUnion，它将当前位置设置为 0。将鉴别符值设置为与第一个指定的联合成员一致的值。激活该成员并将其（递归式）初始化为默认值。
  • 对于 DynValue 和 DynValueBox，它将初始化为 null 值。

指定者：
接口 DynAnyFactoryOperations 中的 create_dyn_any_from_type_code
抛出：
InconsistentTypeCode

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


_DynAnyStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynAnyStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynAnyStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAny, DynAnyOperations
public class _DynAnyStub
extends ObjectImpl
implements DynAny

通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。DynAny 对象与对应于插入 any 的值的副本的数据值相关联。

DynAny 对象可视为一个有序的 DynAny 组件集合。对于表示基本类型（如 long）或没有组件的类型（如空异常）的 DynAny，有序的组件集合为空。每个 DynAny 对象在其组件 DynAny 集合中都有一个当前位置。当前位置由 0 到 n-1 的索引值标识，其中 n 为组件数。特殊索引值 -1 指示不指向任何位置的当前位置。对于不能有当前位置的值（如空异常），索引值始终为 -1。如果使用具有组件的值初始化 DynAny，则索引被初始化为 0。在创建未初始化的 DynAny（即不具有值但具有允许组件的 TypeCode 的 DynAny）之后，当前位置取决于由 DynAny 表示的值的类型。（将当前位置设置为 0 还是 -1 取决于新 DynAny 是否获取了其组件的默认值。）

迭代操作 rewind、seek 和 next 可用于更改当前位置，current_component 操作返回当前位置的组件。component_count 操作返回 DynAny 的组件数。总体上说，这些操作都能在 DynAny 的组件上进行迭代，从而能够（例如）检查其内容（递归式）。

已构造的 DynAny 对象是与构造类型关联的 DynAny 对象。还有一种从 DynAny 接口继承而来的接口，它与 IDL 中的每种构造类型（fixed、enum、struct、sequence、union、array、exception 和 value 类型）相关联。

已构造的 DynAny 对象导出支持创建新 DynAny 对象的操作，每个对象都与已构造数据值的组件相关联。例如，DynStruct 与 struct 值关联。这意味着 DynStruct 可视为拥有一个有序的组件集合，每个结构成员一个。DynStruct 对象导出支持创建新 DynAny 对象的操作，其中每个对象都与 struct 的成员关联。

如果 DynAny 对象是从另一个（已构造）DynAny 对象获取的（如表示从 DynStruct 创建的结构成员的 DynAny），则成员 DynAny 在逻辑上包含在 DynStruct 中。调用 insert 或 get 操作不更改当前位置。销毁顶级 DynAny 对象（不是作为另一个 DynAny 的组件获取的）将同时销毁从其获取的所有 DynAny 对象组件。销毁非顶级 DynAny 对象的操作没有任何效果。在已销毁的顶级 DynAny 或其任何子代上调用操作将引发 OBJECT_NOT_EXIST。如果程序员要销毁 DynAny 对象，但还需要操作与其关联的数据值的某个组件，则应该首先为该组件创建一个 DynAny，然后生成所创建的 DynAny 对象的副本。

为了支持高效实现，根据分配的内存空间和存取速度定义 DynAny 对象的行为。DynAny 对象旨在用于遍历从 any 析取的值，或用于在运行时构造 any 的值。不建议将其用于其他目的。

Insert 和 get 操作是处理基本 DynAny 对象所必需的，但是也可以使用它们来处理已构造的 DynAny 对象。将基本数据类型值插入已构造的 DynAny 对象意味着初始化与 DynAny 对象关联的已构造数据值的当前组件。例如，对 DynStruct 调用 insert_boolean 意味着在关联的 struct 数据值的当前位置插入 boolean 数据值。如果某个类型的 TypeCode 等效于 DynAny 中包含的 TypeCode，或者等效于处于当前位置的 DynAny 的 TypeCode（如果 DynAny 具有组件），则该类型与插入值或析取值一致。

DynAny 和 DynAnyFactory 对象对于创建和使用它们的进程而言是本地的。这意味着不能将对 DynAny 和 DynAnyFactory 对象的引用导出到其他进程，也不能通过 ORB.object_to_string() 使其具体化。如果进行这样的尝试，则该违反规则的操作将引发 MARSHAL 系统异常。由于它们的接口是在 IDL 中指定的，所以 DynAny 对象导出在标准 org.omg.CORBA.Object 接口中定义的操作。但是，任何尝试调用通过 Object 接口导出的操作都会引发标准 NO_IMPLEMENT 异常。尝试使用带有 DII 的 DynAny 对象将引发 NO_IMPLEMENT 异常。

字段摘要
static Class _opsClass
构造方法摘要
_DynAnyStub()
方法摘要
 String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 void destroy()
销毁 DynAny 对象。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象关联的值。
 Any get_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
 boolean get_boolean()
从此 DynAny 析取 boolean 值。
 char get_char()
从此 DynAny 析取 char 值。
 double get_double()
从此 DynAny 析取 double 值。
 DynAny get_dyn_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
 float get_float()
从此 DynAny 中提取 float 值。
 int get_long()
从此 DynAny 析取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 byte get_octet()
从此 DynAny 中提取 byte 值。
 Object get_reference()
从此 DynAny 中提取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 中提取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 中提取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 void insert_any(Any value)
将 Any 值插入此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入到 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 Any to_any()
从 DynAny 对象创建 any 值。
 TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynAnyStub

public _DynAnyStub()
方法详细信息

type

public TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

指定者：
接口 DynAnyOperations 中的 type
返回：
与 DynAny 对象关联的 TypeCode

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 assign
参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 from_any
抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

public Any to_any()
从 DynAny 对象创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

指定者：
接口 DynAnyOperations 中的 to_any
返回：
具有相同值和 TypeCode 的新 Any 对象

equal

public boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

指定者：
接口 DynAnyOperations 中的 equal
返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

public void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

指定者：
接口 DynAnyOperations 中的 destroy

copy

public DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

指定者：
接口 DynAnyOperations 中的 copy
返回：
DynAny 对象的深层复制

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_boolean
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_octet
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_char
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_short
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ushort
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_long
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_float
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_double
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_string
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入到 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_reference
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_typecode
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_longlong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulonglong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_wchar
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_wstring
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_dyn_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 insert_val
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 析取 boolean 值。

指定者：
接口 DynAnyOperations 中的 get_boolean
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 get_octet
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 析取 char 值。

指定者：
接口 DynAnyOperations 中的 get_char
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 short 值。

指定者：
接口 DynAnyOperations 中的 get_short
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ushort
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 析取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_long
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 float 值。

指定者：
接口 DynAnyOperations 中的 get_float
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 析取 double 值。

指定者：
接口 DynAnyOperations 中的 get_double
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_string
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取对 CORBA 对象的引用。

指定者：
接口 DynAnyOperations 中的 get_reference
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 中提取 TypeCode 对象。

指定者：
接口 DynAnyOperations 中的 get_typecode
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_longlong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulonglong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 get_wchar
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_wstring
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值。

指定者：
接口 DynAnyOperations 中的 get_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。

指定者：
接口 DynAnyOperations 中的 get_dyn_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 get_val
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

public boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 seek

rewind

public void rewind()
等效于 seek(0)。

指定者：
接口 DynAnyOperations 中的 rewind

next

public boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 next

component_count

public int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

指定者：
接口 DynAnyOperations 中的 component_count

current_component

public DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

指定者：
接口 DynAnyOperations 中的 current_component
抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_DynArrayStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynArrayStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynArrayStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynArray, DynArrayOperations
public class _DynArrayStub
extends ObjectImpl
implements DynArray

DynArray 对象支持对 IDL 数组 (array) 的操作。注意，数组的维数包含在可通过类型属性访问的 TypeCode 中。也可以通过调用 component_count 操作得到。

字段摘要
static Class _opsClass
构造方法摘要
_DynArrayStub()
方法摘要
 String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 void destroy()
销毁 DynAny 对象。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象关联的值。
 Any get_any()
析取由此 DynAny 表示的 Any 中所包含的 Any 值。
 boolean get_boolean()
从此 DynAny 中提取 boolean 值。
 char get_char()
从此 DynAny 中提取 char 值。
 double get_double()
从此 DynAny 中提取 double 值。
 DynAny get_dyn_any()
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
 DynAny[] get_elements_as_dyn_any()
以 DynAny 的形式返回 DynArray 的元素。
 Any[] get_elements()
返回 DynArray 的元素。
 float get_float()
从此 DynAny 中提取 float 值。
 int get_long()
从此 DynAny 中提取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 byte get_octet()
从此 DynAny 中提取 byte 值。
 Object get_reference()
从此 DynAny 中提取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 中提取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 析取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 void insert_any(Any value)
将 Any 值插入此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入到 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 void set_elements_as_dyn_any(DynAny[] value)
设置 DynArray 以包含传递的元素。
 void set_elements(Any[] value)
设置 DynArray 以包含传递的元素。
 Any to_any()
从 DynAny 对象中创建 any 值。
 TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynArrayStub

public _DynArrayStub()
方法详细信息

get_elements

public Any[] get_elements()
返回 DynArray 的元素。

指定者：
接口 DynArrayOperations 中的 get_elements

set_elements

public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
设置 DynArray 以包含传递的元素。

指定者：
接口 DynArrayOperations 中的 set_elements
抛出：
TypeMismatch - 如果一个或多个元素具有与 DynArrays TypeCode 不一致的类型
InvalidValue - 如果序列包含的元素数与数组维数不同

get_elements_as_dyn_any

public DynAny[] get_elements_as_dyn_any()
以 DynAny 的形式返回 DynArray 的元素。

指定者：
接口 DynArrayOperations 中的 get_elements_as_dyn_any

set_elements_as_dyn_any

public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
设置 DynArray 以包含传递的元素。

指定者：
接口 DynArrayOperations 中的 set_elements_as_dyn_any
抛出：
TypeMismatch - 如果一个或多个元素具有与 DynArrays TypeCode 不一致的类型
InvalidValue - 如果序列包含的元素数与数组维数不同

type

public TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

指定者：
接口 DynAnyOperations 中的 type
返回：
与 DynAny 对象关联的 TypeCode

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 assign
参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 from_any
抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

public Any to_any()
从 DynAny 对象中创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

指定者：
接口 DynAnyOperations 中的 to_any
返回：
具有相同值和 TypeCode 的新 Any 对象

equal

public boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

指定者：
接口 DynAnyOperations 中的 equal
返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

public void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

指定者：
接口 DynAnyOperations 中的 destroy

copy

public DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

指定者：
接口 DynAnyOperations 中的 copy
返回：
DynAny 对象的深层复制

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_boolean
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_octet
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_char
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_short
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ushort
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_long
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_float
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_double
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_string
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入到 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_reference
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_typecode
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_longlong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulonglong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_wchar
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_wstring
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_dyn_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 insert_val
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 中提取 boolean 值。

指定者：
接口 DynAnyOperations 中的 get_boolean
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 get_octet
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 char 值。

指定者：
接口 DynAnyOperations 中的 get_char
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 short 值。

指定者：
接口 DynAnyOperations 中的 get_short
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ushort
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 中提取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_long
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 float 值。

指定者：
接口 DynAnyOperations 中的 get_float
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 double 值。

指定者：
接口 DynAnyOperations 中的 get_double
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_string
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取对 CORBA 对象的引用。

指定者：
接口 DynAnyOperations 中的 get_reference
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 析取 TypeCode 对象。

指定者：
接口 DynAnyOperations 中的 get_typecode
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_longlong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulonglong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 get_wchar
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_wstring
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
析取由此 DynAny 表示的 Any 中所包含的 Any 值。

指定者：
接口 DynAnyOperations 中的 get_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。

指定者：
接口 DynAnyOperations 中的 get_dyn_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 get_val
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

public boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 seek

rewind

public void rewind()
等效于 seek(0)。

指定者：
接口 DynAnyOperations 中的 rewind

next

public boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 next

component_count

public int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

指定者：
接口 DynAnyOperations 中的 component_count

current_component

public DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

指定者：
接口 DynAnyOperations 中的 current_component
抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_DynEnumStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynEnumStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynEnumStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynEnum, DynEnumOperations
public class _DynEnumStub
extends ObjectImpl
implements DynEnum

DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。DynEnum 的当前位置始终为 -1。

字段摘要
static Class _opsClass
构造方法摘要
_DynEnumStub()
方法摘要
 String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 void destroy()
销毁 DynAny 对象。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象关联的值。
 Any get_any()
析取由此 DynAny 表示的 Any 中所包含的 Any 值。
 String get_as_string()
以 IDL 标识符的形式返回 DynEnum 的值。
 int get_as_ulong()
以枚举值的序数值 (ordinal value) 的形式返回 DynEnum 的值。
 boolean get_boolean()
从此 DynAny 中提取 boolean 值。
 char get_char()
从此 DynAny 析取 char 值。
 double get_double()
从此 DynAny 中提取 double 值。
 DynAny get_dyn_any()
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
 float get_float()
从此 DynAny 中提取 float 值。
 int get_long()
从此 DynAny 中提取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 byte get_octet()
从此 DynAny 析取 byte 值。
 Object get_reference()
从此 DynAny 中提取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 中提取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 中提取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 void insert_any(Any value)
将 Any 值插入此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 void set_as_string(String value)
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
 void set_as_ulong(int value)
将 DynEnum 的值设置为枚举值的序号。
 Any to_any()
从 DynAny 对象创建 any 值。
 TypeCode type()
返回与此 DynAny 对象关联的 TypeCode。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynEnumStub

public _DynEnumStub()
方法详细信息

get_as_string

public String get_as_string()
以 IDL 标识符的形式返回 DynEnum 的值。

指定者：
接口 DynEnumOperations 中的 get_as_string

set_as_string

public void set_as_string(String value)
                   throws InvalidValue
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。

指定者：
接口 DynEnumOperations 中的 set_as_string
抛出：
InvalidValue - 如果值包含的字符串不是相应枚举类型的有效 IDL 标识符

get_as_ulong

public int get_as_ulong()
以枚举值的序数值 (ordinal value) 的形式返回 DynEnum 的值。枚举器 (enumerator) 的序号从 0 到 n-1，正如它们在相应的 IDL 定义中从左到右显示的那样。

指定者：
接口 DynEnumOperations 中的 get_as_ulong

set_as_ulong

public void set_as_ulong(int value)
                  throws InvalidValue
将 DynEnum 的值设置为枚举值的序号。

指定者：
接口 DynEnumOperations 中的 set_as_ulong
抛出：
InvalidValue - 如果值包含相应枚举类型的序号范围之外的值

type

public TypeCode type()
返回与此 DynAny 对象关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

指定者：
接口 DynAnyOperations 中的 type
返回：
与 DynAny 对象关联的 TypeCode

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 assign
参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 from_any
抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

public Any to_any()
从 DynAny 对象创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

指定者：
接口 DynAnyOperations 中的 to_any
返回：
具有相同值和 TypeCode 的新 Any 对象

equal

public boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

指定者：
接口 DynAnyOperations 中的 equal
返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

public void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

指定者：
接口 DynAnyOperations 中的 destroy

copy

public DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

指定者：
接口 DynAnyOperations 中的 copy
返回：
DynAny 对象的深层复制

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_boolean
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_octet
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_char
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_short
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ushort
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_long
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_float
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_double
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_string
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_reference
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_typecode
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_longlong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulonglong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_wchar
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_wstring
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。

指定者：
接口 DynAnyOperations 中的 insert_dyn_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 insert_val
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 中提取 boolean 值。

指定者：
接口 DynAnyOperations 中的 get_boolean
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 析取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 get_octet
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 析取 char 值。

指定者：
接口 DynAnyOperations 中的 get_char
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 short 值。

指定者：
接口 DynAnyOperations 中的 get_short
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ushort
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 中提取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_long
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 float 值。

指定者：
接口 DynAnyOperations 中的 get_float
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 double 值。

指定者：
接口 DynAnyOperations 中的 get_double
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_string
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取对 CORBA 对象的引用。

指定者：
接口 DynAnyOperations 中的 get_reference
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 中提取 TypeCode 对象。

指定者：
接口 DynAnyOperations 中的 get_typecode
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_longlong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulonglong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 get_wchar
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_wstring
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
析取由此 DynAny 表示的 Any 中所包含的 Any 值。

指定者：
接口 DynAnyOperations 中的 get_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。

指定者：
接口 DynAnyOperations 中的 get_dyn_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 get_val
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

public boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 seek

rewind

public void rewind()
等效于 seek(0)。

指定者：
接口 DynAnyOperations 中的 rewind

next

public boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 next

component_count

public int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

指定者：
接口 DynAnyOperations 中的 component_count

current_component

public DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

指定者：
接口 DynAnyOperations 中的 current_component
抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_DynFixedStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynFixedStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynFixedStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynFixed, DynFixedOperations
public class _DynFixedStub
extends ObjectImpl
implements DynFixed

DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。因为 IDL 没有可以表示固定类型（其具有任意位数和标度）的常规类型，所以操作将使用 IDL 字符串类型。

字段摘要
static Class _opsClass
构造方法摘要
_DynFixedStub()
方法摘要
 String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 void destroy()
销毁 DynAny 对象。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象关联的值。
 Any get_any()
提取由此 DynAny 表示的 Any 中包含的 Any 值。
 boolean get_boolean()
从此 DynAny 提取 boolean 值。
 char get_char()
从此 DynAny 中提取 char 值。
 double get_double()
从此 DynAny 中提取 double 值。
 DynAny get_dyn_any()
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
 float get_float()
从此 DynAny 中提取 float 值。
 int get_long()
从此 DynAny 中提取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 byte get_octet()
从此 DynAny 析取 byte 值。
 Object get_reference()
从此 DynAny 中提取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 析取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 中提取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 String get_value()
返回 DynFixed 的值。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 void insert_any(Any value)
将 Any 值插入此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入到 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 boolean set_value(String val)
设置 DynFixed 的值。
 Any to_any()
从 DynAny 对象创建 any 值。
 TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynFixedStub

public _DynFixedStub()
方法详细信息

get_value

public String get_value()
返回 DynFixed 的值。

指定者：
接口 DynFixedOperations 中的 get_value

set_value

public boolean set_value(String val)
                  throws TypeMismatch,
                         InvalidValue
设置 DynFixed 的值。val 字符串包含的固定字符串常量必须与用于 IDL 固定点字面值的常量具有相同的格式。不过，尾部的 d 或 D 是可选的。如果可以将 val 表示为 DynFixed 而不损失精度，则返回值为 true。如果 val 的小数位数多于 DynFixed 可以表示的位数，则小数位数将被截短，返回值为 false。

指定者：
接口 DynFixedOperations 中的 set_value
抛出：
TypeMismatch - 如果 val 不包含有效固定点字面值，或者包含除前导或尾部空白外的无关字符
InvalidValue - 如果 val 包含值的标度超出 DynFixed 的标度，或者 val 没有被初始化

type

public TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

指定者：
接口 DynAnyOperations 中的 type
返回：
与 DynAny 对象关联的 TypeCode

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 assign
参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 from_any
抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

public Any to_any()
从 DynAny 对象创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

指定者：
接口 DynAnyOperations 中的 to_any
返回：
具有相同值和 TypeCode 的新 Any 对象

equal

public boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

指定者：
接口 DynAnyOperations 中的 equal
返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

public void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

指定者：
接口 DynAnyOperations 中的 destroy

copy

public DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

指定者：
接口 DynAnyOperations 中的 copy
返回：
DynAny 对象的深层复制

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_boolean
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_octet
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_char
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_short
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ushort
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_long
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_float
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_double
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_string
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入到 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_reference
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_typecode
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_longlong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulonglong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_wchar
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_wstring
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_dyn_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 insert_val
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 提取 boolean 值。

指定者：
接口 DynAnyOperations 中的 get_boolean
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 析取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 get_octet
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 char 值。

指定者：
接口 DynAnyOperations 中的 get_char
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 析取 short 值。

指定者：
接口 DynAnyOperations 中的 get_short
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ushort
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 中提取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_long
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 float 值。

指定者：
接口 DynAnyOperations 中的 get_float
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 double 值。

指定者：
接口 DynAnyOperations 中的 get_double
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_string
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取对 CORBA 对象的引用。

指定者：
接口 DynAnyOperations 中的 get_reference
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 中提取 TypeCode 对象。

指定者：
接口 DynAnyOperations 中的 get_typecode
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_longlong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulonglong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 get_wchar
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_wstring
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
提取由此 DynAny 表示的 Any 中包含的 Any 值。

指定者：
接口 DynAnyOperations 中的 get_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。

指定者：
接口 DynAnyOperations 中的 get_dyn_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 get_val
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

public boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 seek

rewind

public void rewind()
等效于 seek(0)。

指定者：
接口 DynAnyOperations 中的 rewind

next

public boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 next

component_count

public int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

指定者：
接口 DynAnyOperations 中的 component_count

current_component

public DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

指定者：
接口 DynAnyOperations 中的 current_component
抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_DynSequenceStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynSequenceStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynSequenceStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynSequence, DynSequenceOperations
public class _DynSequenceStub
extends ObjectImpl
implements DynSequence

DynSequence 对象支持对 IDL 序列 (sequence) 的操作。

字段摘要
static Class _opsClass
构造方法摘要
_DynSequenceStub()
方法摘要
 String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 void destroy()
销毁 DynAny 对象。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象关联的值。
 Any get_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
 boolean get_boolean()
从此 DynAny 中提取 boolean 值。
 char get_char()
从此 DynAny 中提取 char 值。
 double get_double()
从此 DynAny 中提取 double 值。
 DynAny get_dyn_any()
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
 DynAny[] get_elements_as_dyn_any()
返回表示序列的元素的 DynAny。
 Any[] get_elements()
返回序列的元素。
 float get_float()
从此 DynAny 提取 float 值。
 int get_length()
返回当前序列的长度。
 int get_long()
从此 DynAny 中提取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 byte get_octet()
从此 DynAny 中提取 byte 值。
 Object get_reference()
从此 DynAny 中提取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 中提取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 中提取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 void insert_any(Any value)
将 Any 值插入由此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 void set_elements_as_dyn_any(DynAny[] value)
使用 DynAny 设置序列的元素。
 void set_elements(Any[] value)
设置序列的元素。
 void set_length(int len)
设置序列的长度。
 Any to_any()
从 DynAny 对象创建 any 值。
 TypeCode type()
返回与此 DynAny 对象关联的 TypeCode。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynSequenceStub

public _DynSequenceStub()
方法详细信息

get_length

public int get_length()
返回当前序列的长度。

指定者：
接口 DynSequenceOperations 中的 get_length

set_length

public void set_length(int len)
                throws InvalidValue
设置序列的长度。增加序列的长度将在尾部添加新元素，同时不影响现有元素的值。新添加的元素按默认方式初始化。如果上一个当前位置是 -1，则增加序列的长度会将当前位置设置为第一个新添加的元素。如果上一个当前位置不是 -1，则该操作对当前位置没有影响。减少序列的长度将从尾部移除元素，同时不影响剩余元素的值。减少序列长度后，新的当前位置用以下方式确定：
  • 如果将序列长度设置为 0，则当前位置被设置为 -1。
  • 如果减少长度前当前位置为 -1，则其仍然为 -1。
  • 如果当前位置指示一个有效元素，而该元素在减少长度后没有被移除，则当前位置保持不变。
  • 如果当前位置指示一个有效元素，但该元素在减少长度后被移除，则将当前位置设置为 -1。

指定者：
接口 DynSequenceOperations 中的 set_length
抛出：
InvalidValue - 如果此为有界序列且 len 大于其界限

get_elements

public Any[] get_elements()
返回序列的元素。

指定者：
接口 DynSequenceOperations 中的 get_elements

set_elements

public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
设置序列的元素。将 DynSequence 的长度设置为 value 的长度。如果 value 的长度不为 0，则将当前位置设置为 0；如果 value 是长度为 0 的序列，则将当前位置设置为 -1。

指定者：
接口 DynSequenceOperations 中的 set_elements
抛出：
TypeMismatch - 如果 value 包含一个或多个元素，而这些元素的 TypeCode 不等于 DynSequence 的 TypeCode 元素
InvalidValue - 如果 value 的长度超出有界序列的界限

get_elements_as_dyn_any

public DynAny[] get_elements_as_dyn_any()
返回表示序列的元素的 DynAny。

指定者：
接口 DynSequenceOperations 中的 get_elements_as_dyn_any

set_elements_as_dyn_any

public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
使用 DynAny 设置序列的元素。将 DynSequence 的长度设置为 value 的长度。如果 value 的长度不为 0，则将当前位置设置为 0；如果 value 是长度为 0 的序列，则将当前位置设置为 -1。

指定者：
接口 DynSequenceOperations 中的 set_elements_as_dyn_any
抛出：
TypeMismatch - 如果 value 包含一个或多个元素，而这些元素的 TypeCode 不等于 DynSequence 的 TypeCode 元素
InvalidValue - 如果 value 的长度超出有界序列的界限

type

public TypeCode type()
返回与此 DynAny 对象关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

指定者：
接口 DynAnyOperations 中的 type
返回：
与 DynAny 对象关联的 TypeCode

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 assign
参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 from_any
抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

public Any to_any()
从 DynAny 对象创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

指定者：
接口 DynAnyOperations 中的 to_any
返回：
具有相同值和 TypeCode 的新 Any 对象

equal

public boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

指定者：
接口 DynAnyOperations 中的 equal
返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

public void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

指定者：
接口 DynAnyOperations 中的 destroy

copy

public DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

指定者：
接口 DynAnyOperations 中的 copy
返回：
DynAny 对象的深层复制

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_boolean
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_octet
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_char
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_short
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ushort
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_long
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_float
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_double
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_string
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_reference
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_typecode
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_longlong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulonglong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_wchar
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_wstring
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入由此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。

指定者：
接口 DynAnyOperations 中的 insert_dyn_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 insert_val
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 中提取 boolean 值。

指定者：
接口 DynAnyOperations 中的 get_boolean
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 get_octet
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 char 值。

指定者：
接口 DynAnyOperations 中的 get_char
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 short 值。

指定者：
接口 DynAnyOperations 中的 get_short
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ushort
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 中提取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_long
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 提取 float 值。

指定者：
接口 DynAnyOperations 中的 get_float
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 double 值。

指定者：
接口 DynAnyOperations 中的 get_double
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_string
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取对 CORBA 对象的引用。

指定者：
接口 DynAnyOperations 中的 get_reference
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 中提取 TypeCode 对象。

指定者：
接口 DynAnyOperations 中的 get_typecode
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_longlong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulonglong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 get_wchar
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_wstring
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值。

指定者：
接口 DynAnyOperations 中的 get_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。

指定者：
接口 DynAnyOperations 中的 get_dyn_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 get_val
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

public boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 seek

rewind

public void rewind()
等效于 seek(0)。

指定者：
接口 DynAnyOperations 中的 rewind

next

public boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 next

component_count

public int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

指定者：
接口 DynAnyOperations 中的 component_count

current_component

public DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

指定者：
接口 DynAnyOperations 中的 current_component
抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_DynStructStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynStructStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynStructStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynStruct, DynStructOperations
public class _DynStructStub
extends ObjectImpl
implements DynStruct

DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。对异常成员的处理方式与对结构数据成员一样。

字段摘要
static Class _opsClass
构造方法摘要
_DynStructStub()
方法摘要
 String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 TCKind current_member_kind()
返回与当前位置的成员关联的 TCKind。
 String current_member_name()
返回当前位置上的成员的名称。
 void destroy()
销毁 DynAny 对象。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
 Any get_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
 boolean get_boolean()
从此 DynAny 中提取 boolean 值。
 char get_char()
从此 DynAny 中提取 char 值。
 double get_double()
从此 DynAny 中提取 double 值。
 DynAny get_dyn_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
 float get_float()
从此 DynAny 中提取 float 值。
 int get_long()
从此 DynAny 中提取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 NameDynAnyPair[] get_members_as_dyn_any()
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
 NameValuePair[] get_members()
返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
 byte get_octet()
从此 DynAny 中提取 byte 值。
 Object get_reference()
从此 DynAny 析取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 中提取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 中提取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 void insert_any(Any value)
将 Any 值插入此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 void set_members_as_dyn_any(NameDynAnyPair[] value)
初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
 void set_members(NameValuePair[] value)
初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
 Any to_any()
从 DynAny 对象创建 any 值。
 TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynStructStub

public _DynStructStub()
方法详细信息

current_member_name

public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
返回当前位置上的成员的名称。此操作可能返回空字符串，因为所操作的值的 TypeCode 可能不包含成员名称。

指定者：
接口 DynStructOperations 中的 current_member_name
抛出：
TypeMismatch - 如果 DynStruct 表示空异常。
InvalidValue - 如果当前位置不指示成员

current_member_kind

public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
返回与当前位置的成员关联的 TCKind。

指定者：
接口 DynStructOperations 中的 current_member_kind
抛出：
TypeMismatch - 如果 DynStruct 表示空异常。
InvalidValue - 如果当前位置不指示成员

get_members

public NameValuePair[] get_members()
返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。该序列所含成员的顺序与成员的声明顺序（由 DynStruct 的 TypeCode 指示）相同。当前位置不受影响。如果 DynStruct 的 TypeCode 不包含成员名称，则返回序列中的成员名称将为空字符串。

指定者：
接口 DynStructOperations 中的 get_members

set_members

public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。如果传递的序列长度不为 0，则操作将当前位置设置为 0。如果传递的是空序列，则将当前位置设置为 -1。

根据 DynStruct 的 TypeCode 的指示，成员在 NameValuePair 中必须按它们在结构数据的 IDL 规范中的显示顺序显示，除非它们为空字符串。该操作不尝试根据成员名称分配成员值。

指定者：
接口 DynStructOperations 中的 set_members
抛出：
TypeMismatch - 如果所传递序列中提供的成员名称与 DynStruct 的 TypeCode 中相应成员名称不匹配，并且它们都不是空字符串
InvalidValue - 如果所传递序列的元素数与 DynStruct 的 TypeCode 指示的成员数不一致

get_members_as_dyn_any

public NameDynAnyPair[] get_members_as_dyn_any()
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。该序列所含成员的顺序与成员的声明顺序（由 DynStruct 的 TypeCode 指示）相同。当前位置不受影响。如果 DynStruct 的 TypeCode 不包含成员名称，则返回序列中的成员名称将为空字符串。

指定者：
接口 DynStructOperations 中的 get_members_as_dyn_any

set_members_as_dyn_any

public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。如果传递的序列长度不为 0，则操作将当前位置设置为 0。如果传递的是空序列，则将当前位置设置为 -1。

根据 DynStruct 的 TypeCode 的指示，成员在 NameDynAnyPair 中必须按它们在结构数据的 IDL 规范中的显示顺序显示，除非它们为空字符串。该操作不尝试根据成员名称分配成员值。

指定者：
接口 DynStructOperations 中的 set_members_as_dyn_any
抛出：
TypeMismatch - 如果所传递序列中提供的成员名称与 DynStruct 的 TypeCode 中相应成员名称不匹配，并且它们都不是空字符串
InvalidValue - 如果所传递序列的元素数与 DynStruct 的 TypeCode 指示的成员数不一致

type

public TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

指定者：
接口 DynAnyOperations 中的 type
返回：
与 DynAny 对象关联的 TypeCode

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 assign
参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象有关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 from_any
抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

public Any to_any()
从 DynAny 对象创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

指定者：
接口 DynAnyOperations 中的 to_any
返回：
具有相同值和 TypeCode 的新 Any 对象

equal

public boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

指定者：
接口 DynAnyOperations 中的 equal
返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

public void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

指定者：
接口 DynAnyOperations 中的 destroy

copy

public DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

指定者：
接口 DynAnyOperations 中的 copy
返回：
DynAny 对象的深层复制

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_boolean
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_octet
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_char
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_short
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ushort
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_long
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_float
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_double
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_string
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_reference
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_typecode
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_longlong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulonglong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_wchar
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_wstring
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_dyn_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 insert_val
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 中提取 boolean 值。

指定者：
接口 DynAnyOperations 中的 get_boolean
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 get_octet
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 char 值。

指定者：
接口 DynAnyOperations 中的 get_char
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 short 值。

指定者：
接口 DynAnyOperations 中的 get_short
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ushort
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 中提取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_long
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 float 值。

指定者：
接口 DynAnyOperations 中的 get_float
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 double 值。

指定者：
接口 DynAnyOperations 中的 get_double
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_string
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 析取对 CORBA 对象的引用。

指定者：
接口 DynAnyOperations 中的 get_reference
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 中提取 TypeCode 对象。

指定者：
接口 DynAnyOperations 中的 get_typecode
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_longlong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulonglong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 get_wchar
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_wstring
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值。

指定者：
接口 DynAnyOperations 中的 get_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。

指定者：
接口 DynAnyOperations 中的 get_dyn_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 get_val
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

public boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 seek

rewind

public void rewind()
等效于 seek(0)。

指定者：
接口 DynAnyOperations 中的 rewind

next

public boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 next

component_count

public int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

指定者：
接口 DynAnyOperations 中的 component_count

current_component

public DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

指定者：
接口 DynAnyOperations 中的 current_component
抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_DynUnionStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynUnionStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynUnionStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynUnion, DynUnionOperations
public class _DynUnionStub
extends ObjectImpl
implements DynUnion

DynUnion 对象支持对 IDL 联合数据 (union) 的操作。联合数据只能有两个有效的当前位置：

  • 0，表示鉴别符 (discriminator)
  • 1，表示活动成员
联合数据的 component_count 值依赖于当前鉴别符：其鉴别符指示一个指定成员的联合数据的 component_count 值为 2，其他情况为 1。

字段摘要
static Class _opsClass
构造方法摘要
_DynUnionStub()
方法摘要
 String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 void destroy()
销毁 DynAny 对象。
 TCKind discriminator_kind()
返回鉴别符 TypeCode 的 TCKind 值。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
 Any get_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
 boolean get_boolean()
从此 DynAny 中提取 boolean 值。
 char get_char()
从此 DynAny 中提取 char 值。
 DynAny get_discriminator()
返回当前鉴别符值。
 double get_double()
从此 DynAny 中提取 double 值。
 DynAny get_dyn_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
 float get_float()
从此 DynAny 中提取 float 值。
 int get_long()
从此 DynAny 中提取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 byte get_octet()
从此 DynAny 中提取 byte 值。
 Object get_reference()
从此 DynAny 中提取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 中提取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 中提取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 boolean has_no_active_member()
如果联合数据没有活动成员，即这些联合数据值仅由其鉴别符组成（因为鉴别符的值不作为显式 case 标签列出），则返回 true。
 void insert_any(Any value)
将 Any 值插入此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入到 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 TCKind member_kind()
返回当前活动成员 TypeCode 的 TCKind 值。
 String member_name()
返回当前活动成员的名称。
 DynAny member()
返回当前活动成员。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 void set_discriminator(DynAny d)
将 DynUnion 的鉴别符值设置为指定值。
 void set_to_default_member()
将鉴别符设置为联合数据的默认 case 的值。
 void set_to_no_active_member()
将鉴别符设置为与任何联合数据 case 标签都不相应的值。
 Any to_any()
从 DynAny 对象创建 any 值。
 TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynUnionStub

public _DynUnionStub()
方法详细信息

get_discriminator

public DynAny get_discriminator()
返回当前鉴别符值。

指定者：
接口 DynUnionOperations 中的 get_discriminator

set_discriminator

public void set_discriminator(DynAny d)
                       throws TypeMismatch
将 DynUnion 的鉴别符值设置为指定值。将鉴别符设置为与当前活动联合数据成员一致的值对当前活动成员没有影响。将鉴别符设置为与当前活动成员不一致的值将停用该成员，并将与新鉴别符值一致的成员（如果存在与该值对应的成员）初始化为其默认值，从而激活该成员。如果鉴别符值指示一个不存在的联合数据成员，则设置联合数据鉴别符会将当前位置设置为 0（在此情况下，has_no_active_member 返回 true）。否则，如果鉴别符值指示指定的联合数据成员，则将当前位置设置为 1（在此情况下，has_no_active_member 返回 false，component_count 返回 2）。

指定者：
接口 DynUnionOperations 中的 set_discriminator
抛出：
TypeMismatch - 如果参数的 TypeCode 不等于联合数据鉴别符的 TypeCode

set_to_default_member

public void set_to_default_member()
                           throws TypeMismatch
将鉴别符设置为联合数据的默认 case 的值。它将当前位置设置为 0，并导致 component_count 返回 2。

指定者：
接口 DynUnionOperations 中的 set_to_default_member
抛出：
TypeMismatch - 如果联合数据没有显式的默认 case

set_to_no_active_member

public void set_to_no_active_member()
                             throws TypeMismatch
将鉴别符设置为与任何联合数据 case 标签都不相应的值。它将当前位置设置为 0，并导致 component_count 返回 1。

指定者：
接口 DynUnionOperations 中的 set_to_no_active_member
抛出：
TypeMismatch - 如果联合数据具有显式的默认 case，或者其显式 case 标签使用了整个鉴别符值范围

has_no_active_member

public boolean has_no_active_member()
如果联合数据没有活动成员，即这些联合数据值仅由其鉴别符组成（因为鉴别符的值不作为显式 case 标签列出），则返回 true。对具有默认 case 的联合数据调用此操作将返回 false。对显式 case 标签使用了整个鉴别符值范围的联合数据调用此操作将返回 false。

指定者：
接口 DynUnionOperations 中的 has_no_active_member

discriminator_kind

public TCKind discriminator_kind()
返回鉴别符 TypeCode 的 TCKind 值。

指定者：
接口 DynUnionOperations 中的 discriminator_kind

member_kind

public TCKind member_kind()
                   throws InvalidValue
返回当前活动成员 TypeCode 的 TCKind 值。

指定者：
接口 DynUnionOperations 中的 member_kind
抛出：
InvalidValue - 如果联合数据不具有当前活动成员

member

public DynAny member()
              throws InvalidValue
返回当前活动成员。注意，当且仅当当前活动成员没有更改时返回的引用才仍然有效。使用超出当前活动成员生存时间的返回引用将引发 OBJECT_NOT_EXIST。

指定者：
接口 DynUnionOperations 中的 member
抛出：
InvalidValue - 如果联合数据没有活动成员

member_name

public String member_name()
                   throws InvalidValue
返回当前活动成员的名称。如果联合数据 TypeCode 不包含当前活动成员的成员名称，则操作将返回空字符串。

指定者：
接口 DynUnionOperations 中的 member_name
抛出：
InvalidValue - 如果联合数据没有活动成员

type

public TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

指定者：
接口 DynAnyOperations 中的 type
返回：
与 DynAny 对象关联的 TypeCode

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 assign
参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象有关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 from_any
抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

public Any to_any()
从 DynAny 对象创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

指定者：
接口 DynAnyOperations 中的 to_any
返回：
具有相同值和 TypeCode 的新 Any 对象

equal

public boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

指定者：
接口 DynAnyOperations 中的 equal
返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

public void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

指定者：
接口 DynAnyOperations 中的 destroy

copy

public DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

指定者：
接口 DynAnyOperations 中的 copy
返回：
DynAny 对象的深层复制

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_boolean
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_octet
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_char
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_short
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ushort
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_long
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_float
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_double
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_string
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入到 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_reference
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_typecode
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_longlong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulonglong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_wchar
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_wstring
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_dyn_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 insert_val
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 中提取 boolean 值。

指定者：
接口 DynAnyOperations 中的 get_boolean
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 get_octet
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 char 值。

指定者：
接口 DynAnyOperations 中的 get_char
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 short 值。

指定者：
接口 DynAnyOperations 中的 get_short
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ushort
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 中提取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_long
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 float 值。

指定者：
接口 DynAnyOperations 中的 get_float
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 double 值。

指定者：
接口 DynAnyOperations 中的 get_double
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_string
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取对 CORBA 对象的引用。

指定者：
接口 DynAnyOperations 中的 get_reference
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 中提取 TypeCode 对象。

指定者：
接口 DynAnyOperations 中的 get_typecode
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_longlong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulonglong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 get_wchar
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_wstring
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值。

指定者：
接口 DynAnyOperations 中的 get_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。

指定者：
接口 DynAnyOperations 中的 get_dyn_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 get_val
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

public boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 seek

rewind

public void rewind()
等效于 seek(0)。

指定者：
接口 DynAnyOperations 中的 rewind

next

public boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 next

component_count

public int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

指定者：
接口 DynAnyOperations 中的 component_count

current_component

public DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

指定者：
接口 DynAnyOperations 中的 current_component
抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


_DynValueStub (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 _DynValueStub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.DynamicAny._DynValueStub
所有已实现的接口：
Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynValue, DynValueCommon, DynValueCommonOperations, DynValueOperations
public class _DynValueStub
extends ObjectImpl
implements DynValue

DynValue 对象支持 IDL non-boxed value 类型的操作。DynValue 接口可表示 null 和非 null 两种值类型。对于表示非 null 值类型的 DynValue，DynValue 的组件由该值类型的公共和专有成员组成，包括那些按照定义的顺序从具体基本值类型继承的成员。表示 null 值类型的 DynValue 没有组件，其当前位置为 -1。

警告：不加区别地更改专有值类型成员的内容将导致值类型实现因违反内部约束而破坏。提供对专有成员的访问是为了支持 ORB 桥接和调试之类的活动，不应使用该权限任意违反值类型的封装。

字段摘要
static Class _opsClass
构造方法摘要
_DynValueStub()
方法摘要
 String[] _ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 TCKind current_member_kind()
返回与当前位置的成员有关联的 TCKind。
 String current_member_name()
返回当前位置上成员的名称。
 void destroy()
销毁 DynAny 对象。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
 Any get_any()
提取由此 DynAny 表示的 Any 中包含的 Any 值。
 boolean get_boolean()
从此 DynAny 中提取 boolean 值。
 char get_char()
从此 DynAny 中提取 char 值。
 double get_double()
从此 DynAny 中提取 double 值。
 DynAny get_dyn_any()
提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
 float get_float()
从此 DynAny 中提取 float 值。
 int get_long()
从此 DynAny 中提取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 NameDynAnyPair[] get_members_as_dyn_any()
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
 NameValuePair[] get_members()
返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
 byte get_octet()
从此 DynAny 中提取 byte 值。
 Object get_reference()
从此 DynAny 中提取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 中提取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 中提取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 void insert_any(Any value)
将 Any 值插入此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入到 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 boolean is_null()
如果 DynValueCommon 表示 null 值类型，则返回 true。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 void set_members_as_dyn_any(NameDynAnyPair[] value)
根据 NameDynAnyPair 序列初始化该值类型的成员。
 void set_members(NameValuePair[] value)
根据 NameValuePair 序列初始化该值类型的成员。
 void set_to_null()
将 DynValueCommon 的表示形式更改为 null 值类型。
 void set_to_value()
使用新构造的值取代 null 值类型。
 Any to_any()
从 DynAny 对象创建 any 值。
 TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

字段详细信息

_opsClass

public static final Class _opsClass
构造方法详细信息

_DynValueStub

public _DynValueStub()
方法详细信息

current_member_name

public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
返回当前位置上成员的名称。此操作可能返回空字符串，因为所操作的值的 TypeCode 可能不包含成员名称。

指定者：
接口 DynValueOperations 中的 current_member_name
抛出：
TypeMismatch - 如果 DynValue 表示 null 值类型。
InvalidValue - 如果当前位置不指示成员

current_member_kind

public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
返回与当前位置的成员有关联的 TCKind。

指定者：
接口 DynValueOperations 中的 current_member_kind
抛出：
TypeMismatch - 如果 DynValue 表示 null 值类型。
InvalidValue - 如果当前位置不指示成员

get_members

public NameValuePair[] get_members()
                            throws InvalidValue
返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。该序列所含成员的顺序与成员的声明顺序（由 DynValue 的 TypeCode 指示）相同。当前位置不受影响。如果 DynValue 的 TypeCode 不包含成员名称，则返回序列中的成员名称将为空字符串。

指定者：
接口 DynValueOperations 中的 get_members
抛出：
InvalidValue - 如果此对象表示 null 值类型

set_members

public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
根据 NameValuePair 序列初始化该值类型的成员。如果传递的序列长度不为 0，则操作将当前位置设置为 0。如果传递空序列，则将当前位置设置为 -1。使用此方法可以将 null 值类型初始化为非 null 值类型。

根据 DynValue 的 TypeCode 的指示，成员在 NameValuePair 中必须按它们在值类型的 IDL 规范中的显示顺序显示，除非它们为空字符串。该操作不尝试根据成员名称分配成员值。

指定者：
接口 DynValueOperations 中的 set_members
抛出：
TypeMismatch - 如果所传递序列中提供的成员名称与 DynValue 的 TypeCode 中相应成员名称不匹配，并且它们都不是空字符串
InvalidValue - 如果所传递序列的元素数与 DynValue 的 TypeCode 指示的成员数不一致

get_members_as_dyn_any

public NameDynAnyPair[] get_members_as_dyn_any()
                                        throws InvalidValue
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。该序列所含成员的顺序与成员的声明顺序（由 DynValue 的 TypeCode 指示）相同。当前位置不受影响。如果 DynValue 的 TypeCode 不包含成员名称，则返回序列中的成员名称将为空字符串。

指定者：
接口 DynValueOperations 中的 get_members_as_dyn_any
抛出：
InvalidValue - 如果此对象表示 null 值类型

set_members_as_dyn_any

public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
根据 NameDynAnyPair 序列初始化该值类型的成员。如果传递的序列长度不为 0，则操作将当前位置设置为 0。如果传递空序列，则将当前位置设置为 -1。使用此方法可以将 null 值类型初始化为非 null 值类型。

根据 DynValue 的 TypeCode 的指示，成员在 NameDynAnyPair 中必须按它们在值类型的 IDL 规范中的显示顺序显示，除非它们为空字符串。该操作不尝试根据成员名称分配成员值。

指定者：
接口 DynValueOperations 中的 set_members_as_dyn_any
抛出：
TypeMismatch - 如果所传递序列中提供的成员名称与 DynValue 的 TypeCode 中相应成员名称不匹配，并且它们都不是空字符串
InvalidValue - 如果所传递序列的元素数与 DynValue 的 TypeCode 指示的成员数不一致

is_null

public boolean is_null()
如果 DynValueCommon 表示 null 值类型，则返回 true。

指定者：
接口 DynValueCommonOperations 中的 is_null

set_to_null

public void set_to_null()
将 DynValueCommon 的表示形式更改为 null 值类型。

指定者：
接口 DynValueCommonOperations 中的 set_to_null

set_to_value

public void set_to_value()
使用新构造的值取代 null 值类型。将其组件初始化为默认值，该值与使用 DynAnyFactory.create_dyn_any_from_type_code 所得结果相同。如果 DynValueCommon 表示非 null 值类型，则此操作无效。

指定者：
接口 DynValueCommonOperations 中的 set_to_value

type

public TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

指定者：
接口 DynAnyOperations 中的 type
返回：
与 DynAny 对象关联的 TypeCode

assign

public void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 assign
参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象有关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

指定者：
接口 DynAnyOperations 中的 from_any
抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

public Any to_any()
从 DynAny 对象创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

指定者：
接口 DynAnyOperations 中的 to_any
返回：
具有相同值和 TypeCode 的新 Any 对象

equal

public boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

指定者：
接口 DynAnyOperations 中的 equal
返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

public void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

指定者：
接口 DynAnyOperations 中的 destroy

copy

public DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

指定者：
接口 DynAnyOperations 中的 copy
返回：
DynAny 对象的深层复制

insert_boolean

public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_boolean
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_octet
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_char
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_short
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ushort
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_long
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_float
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_double
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_string
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入到 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_reference
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

指定者：
接口 DynAnyOperations 中的 insert_typecode
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_longlong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_ulonglong
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 insert_wchar
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

指定者：
接口 DynAnyOperations 中的 insert_wstring
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。

指定者：
接口 DynAnyOperations 中的 insert_dyn_any
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 insert_val
抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 中提取 boolean 值。

指定者：
接口 DynAnyOperations 中的 get_boolean
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

指定者：
接口 DynAnyOperations 中的 get_octet
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

public char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 char 值。

指定者：
接口 DynAnyOperations 中的 get_char
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

public short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 short 值。

指定者：
接口 DynAnyOperations 中的 get_short
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ushort
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

public int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 中提取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_long
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

public float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 float 值。

指定者：
接口 DynAnyOperations 中的 get_float
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

public double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 double 值。

指定者：
接口 DynAnyOperations 中的 get_double
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

public String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_string
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取对 CORBA 对象的引用。

指定者：
接口 DynAnyOperations 中的 get_reference
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 中提取 TypeCode 对象。

指定者：
接口 DynAnyOperations 中的 get_typecode
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_longlong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

指定者：
接口 DynAnyOperations 中的 get_ulonglong
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

指定者：
接口 DynAnyOperations 中的 get_wchar
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

指定者：
接口 DynAnyOperations 中的 get_wstring
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

public Any get_any()
            throws TypeMismatch,
                   InvalidValue
提取由此 DynAny 表示的 Any 中包含的 Any 值。

指定者：
接口 DynAnyOperations 中的 get_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。

指定者：
接口 DynAnyOperations 中的 get_dyn_any
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

指定者：
接口 DynAnyOperations 中的 get_val
抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

public boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 seek

rewind

public void rewind()
等效于 seek(0)。

指定者：
接口 DynAnyOperations 中的 rewind

next

public boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

指定者：
接口 DynAnyOperations 中的 next

component_count

public int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

指定者：
接口 DynAnyOperations 中的 component_count

current_component

public DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

指定者：
接口 DynAnyOperations 中的 current_component
抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法

_ids

public String[] _ids()
从类 ObjectImpl 复制的描述
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。例如，对于 sub，此方法返回所有关于该 stub 所支持的接口的信息。

指定者：
类 ObjectImpl 中的 _ids
返回：
此 ObjectImpl 实例支持的所有存储库标识符所组成的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AnySeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 AnySeqHelper

java.lang.Object
    继承者  org.omg.DynamicAny.AnySeqHelper

public abstract class AnySeqHelper
extends Object

org/omg/DynamicAny/AnySeqHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:17 (GMT-08:00)。

构造方法摘要
AnySeqHelper()
方法摘要
static Any[] | extract(Any a)
static String | id()
static void | insert(Any a, Any[] that)
static Any[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, Any[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AnySeqHelper

public AnySeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          Any[] that)

extract

public static Any[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static Any[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         Any[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynAny (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynAny

所有超级接口：
DynAnyOperations, IDLEntity, Object, Serializable
所有已知子接口：
DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon
所有已知实现类：
_DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub
public interface DynAny
extends DynAnyOperations, Object, IDLEntity

通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。DynAny 对象与对应于插入 any 的值的副本的数据值相关联。

DynAny 对象可视为一个有序的 DynAny 组件集合。对于表示基本类型（如 long）或没有组件的类型（如空异常）的 DynAny，有序的组件集合为空。每个 DynAny 对象在其组件 DynAny 集合中都有一个当前位置。当前位置由 0 到 n-1 的索引值标识，其中 n 为组件数。特殊索引值 -1 指示不指向任何位置的当前位置。对于不能有当前位置的值（如空异常），索引值始终为 -1。如果使用具有组件的值初始化 DynAny，则索引被初始化为 0。在创建未初始化的 DynAny（即不具有值但具有允许组件的 TypeCode 的 DynAny）之后，当前位置取决于由 DynAny 表示的值的类型。（将当前位置设置为 0 还是 -1 取决于新 DynAny 是否获取了其组件的默认值。）

迭代操作 rewind、seek 和 next 可用于更改当前位置，current_component 操作返回当前位置的组件。component_count 操作返回 DynAny 的组件数。总体上说，这些操作都能在 DynAny 的组件上进行迭代，从而能够（例如）检查其内容（递归式）。

已构造的 DynAny 对象是与构造类型关联的 DynAny 对象。还有一种从 DynAny 接口继承而来的接口，它与 IDL 中的每种构造类型（fixed、enum、struct、sequence、union、array、exception 和 value 类型）相关联。

已构造的 DynAny 对象导出支持创建新 DynAny 对象的操作，每个对象都与已构造数据值的组件相关联。例如，DynStruct 与 struct 值关联。这意味着 DynStruct 可视为拥有一个有序的组件集合，每个结构成员一个。DynStruct 对象导出支持创建新 DynAny 对象的操作，其中每个对象都与 struct 的成员关联。

如果 DynAny 对象是从另一个（已构造）DynAny 对象获取的（如表示从 DynStruct 创建的结构成员的 DynAny），则成员 DynAny 在逻辑上包含在 DynStruct 中。调用 insert 或 get 操作不更改当前位置。销毁顶级 DynAny 对象（不是作为另一个 DynAny 的组件获取的）将同时销毁从其获取的所有 DynAny 对象组件。销毁非顶级 DynAny 对象的操作没有任何效果。在已销毁的顶级 DynAny 或其任何子代上调用操作将引发 OBJECT_NOT_EXIST。如果程序员要销毁 DynAny 对象，但还需要操作与其关联的数据值的某个组件，则应该首先为该组件创建一个 DynAny，然后生成所创建的 DynAny 对象的副本。

为了支持高效实现，根据分配的内存空间和存取速度定义 DynAny 对象的行为。DynAny 对象旨在用于遍历从 any 析取的值，或用于在运行时构造 any 的值。不建议将其用于其他目的。

Insert 和 get 操作是处理基本 DynAny 对象所必需的，但是也可以使用它们来处理已构造的 DynAny 对象。将基本数据类型值插入已构造的 DynAny 对象意味着初始化与 DynAny 对象关联的已构造数据值的当前组件。例如，对 DynStruct 调用 insert_boolean 意味着在关联的 struct 数据值的当前位置插入 boolean 数据值。如果某个类型的 TypeCode 等效于 DynAny 中包含的 TypeCode，或者等效于处于当前位置的 DynAny 的 TypeCode（如果 DynAny 具有组件），则该类型与插入值或析取值一致。

DynAny 和 DynAnyFactory 对象对于创建和使用它们的进程而言是本地的。这意味着不能将对 DynAny 和 DynAnyFactory 对象的引用导出到其他进程，也不能通过 ORB.object_to_string() 使其具体化。如果进行这样的尝试，则该违反规则的操作将引发 MARSHAL 系统异常。由于它们的接口是在 IDL 中指定的，所以 DynAny 对象导出在标准 org.omg.CORBA.Object 接口中定义的操作。但是，任何尝试调用通过 Object 接口导出的操作都会引发标准 NO_IMPLEMENT 异常。尝试使用带有 DII 的 DynAny 对象将引发 NO_IMPLEMENT 异常。

方法摘要
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynAnyFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynAnyFactory

所有超级接口：
DynAnyFactoryOperations, IDLEntity, Object, Serializable
所有已知实现类：
_DynAnyFactoryStub
public interface DynAnyFactory
extends DynAnyFactoryOperations, Object, IDLEntity

DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。一般来说，只有两种创建 DynAny 对象的方式：

  • 调用现有 DynAny 对象上的操作
  • 调用 DynAnyFactory 对象上的操作
已构造的 DynAny 对象支持允许创建新 DynAny 对象的操作，可在这些对象中封装对某个成分值的访问权限。DynAny 对象还支持用于创建新 DynAny 对象的复制操作。通过调用 ORB.resolve_initial_references() 并将标识符参数设置为字符串常量 "DynAnyFactory"，可以获取 DynAnyFactory 对象的引用。

动态解释 any 的第一步通常是使用 create_dyn_any() 创建 DynAny 对象。所得 DynAny 对象引用集中于 DynFixed、DynStruct、DynSequence、DynArray、DynUnion、DynEnum 或 DynValue 这几种对象引用，因 any 的类型而异。

动态创建 any 需要使用 create_dyn_any_from_type_code() 创建 DynAny 对象，并传递与要创建的值关联的 TypeCode。返回的引用将集中为复合类型之一，如 DynStruct（如果合适）。然后，通过在所得对象上调用操作来初始化值。最后，可调用 to_any 操作根据已构造的 DynAny 创建 any 值。

方法摘要
从接口 org.omg.DynamicAny.DynAnyFactoryOperations 继承的方法
create_dyn_any_from_type_code, create_dyn_any
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynAnyFactoryHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynAnyFactoryHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynAnyFactoryHelper

public abstract class DynAnyFactoryHelper
extends Object

DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。一般来说，只有两种创建 DynAny 对象的方式：

  • 调用现有 DynAny 对象上的操作
  • 调用 DynAnyFactory 对象上的操作
已构造的 DynAny 对象支持允许创建新 DynAny 对象的操作，可在这些对象中封装对某个成分值的访问权限。DynAny 对象还支持用于创建新 DynAny 对象的复制操作。通过调用 ORB.resolve_initial_references() 并将标识符参数设置为字符串常量 "DynAnyFactory"，可以获取 DynAnyFactory 对象的引用。

动态解释 any 的第一步通常是使用 create_dyn_any() 创建 DynAny 对象。所得 DynAny 对象引用集中于 DynFixed、DynStruct、DynSequence、DynArray、DynUnion、DynEnum 或 DynValue 这几种对象引用，因 any 的类型而异。

动态创建 any 需要使用 create_dyn_any_from_type_code() 创建 DynAny 对象，并传递与要创建的值关联的 TypeCode。返回的引用将集中为复合类型之一，如 DynStruct（如果合适）。然后，通过在所得对象上调用操作来初始化值。最后，可调用 to_any 操作根据已构造的 DynAny 创建 any 值。

构造方法摘要
DynAnyFactoryHelper()
方法摘要
static DynAnyFactory | extract(Any a)
static String | id()
static void | insert(Any a, DynAnyFactory that)
static DynAnyFactory | narrow(Object obj)
static DynAnyFactory | read(InputStream istream)
static TypeCode | type()
static DynAnyFactory | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynAnyFactory value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynAnyFactoryHelper

public DynAnyFactoryHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynAnyFactory that)

extract

public static DynAnyFactory extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynAnyFactory read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynAnyFactory value)

narrow

public static DynAnyFactory narrow(Object obj)

unchecked_narrow

public static DynAnyFactory unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynAnyFactoryOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynAnyFactoryOperations

所有已知子接口：
DynAnyFactory
所有已知实现类：
_DynAnyFactoryStub
public interface DynAnyFactoryOperations

DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。一般来说，只有两种创建 DynAny 对象的方式：

  • 调用现有 DynAny 对象上的操作
  • 调用 DynAnyFactory 对象上的操作
已构造的 DynAny 对象支持允许创建新 DynAny 对象的操作，可在这些对象中封装对某个成分值的访问权限。DynAny 对象还支持用于创建新 DynAny 对象的复制操作。通过调用 ORB.resolve_initial_references() 并将标识符参数设置为字符串常量 "DynAnyFactory"，可以获取 DynAnyFactory 对象的引用。

动态解释 any 的第一步通常是使用 create_dyn_any() 创建 DynAny 对象。所得 DynAny 对象引用集中于 DynFixed、DynStruct、DynSequence、DynArray、DynUnion、DynEnum 或 DynValue 这几种对象引用，因 any 的类型而异。

动态创建 any 需要使用 create_dyn_any_from_type_code() 创建 DynAny 对象，并传递与要创建的值关联的 TypeCode。返回的引用将集中为复合类型之一，如 DynStruct（如果合适）。然后，通过在所得对象上调用操作来初始化值。最后，可调用 to_any 操作根据已构造的 DynAny 创建 any 值。

方法摘要
DynAny | create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。

方法详细信息

create_dyn_any

DynAny create_dyn_any(Any value)
                      throws InconsistentTypeCode
根据 any 值创建新 DynAny 对象。将与 any 值关联的 TypeCode 的副本分配给所得 DynAny 对象。与 DynAny 对象关联的值是原始 any 中值的副本。如果传递的值具有组件，则将已创建的 DynAny 的当前位置设置为 0；否则设置为 -1。

抛出：
InconsistentTypeCode - 如果值具有 TCKind 为 tk_Principal、tk_native 或 tk_abstract_interface 的 TypeCode

create_dyn_any_from_type_code

DynAny create_dyn_any_from_type_code(TypeCode type)
                                     throws InconsistentTypeCode
根据 TypeCode 创建 DynAny。根据 TypeCode 的不同，创建的对象可能为 DynAny 类型，也可能为其派生类型之一（如 DynStruct）。返回的引用可以集中为派生类型。无论是哪种情况，根据 TypeCode 构造的 DynAny 都具有初始默认值。基本类型的默认值如下：
  • false，用于 boolean
  • 0，用于 numeric 类型
  • 0，用于类型 octet、char 和 wchar
  • 空字符串，用于 string 和 wstring
  • null，用于对象引用
  • 带有 TCKind 值为 tk_null 的类型代码，用于类型代码
  • 包含带有 TCKind 值为 tk_null 的类型代码但不包含任何值的 any，用于 any 值
对于复合类型，创建相应 DynAny 时默认值的分配如下：
  • 对于 DynSequence，它将当前位置设置为 -1 并创建空序列。
  • 对于 DynEnum，它将当前位置设置为 -1，并将计数器 (enumerator) 的值设置为 TypeCode 指示的第一个计数器值。
  • 对于 DynFixed，它将当前位置设置为 -1 并将值设置为 0。
  • 对于 DynStruct，它将空异常的当前位置设置为 -1，所有其他 TypeCode 的当前位置都设置为 0。成员（如果有）将被初始化（递归式）为其默认值。
  • 对于 DynArray，它将当前位置设置为 0 并将元素（递归式）初始化为其默认值。
  • 对于 DynUnion，它将当前位置设置为 0。将鉴别符值设置为与第一个指定的联合成员一致的值。激活该成员并将其（递归式）初始化为默认值。
  • 对于 DynValue 和 DynValueBox，它将初始化为 null 值。

抛出：
InconsistentTypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynAnyHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynAnyHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynAnyHelper

public abstract class DynAnyHelper
extends Object

通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。DynAny 对象与对应于插入 any 的值的副本的数据值相关联。

DynAny 对象可视为一个有序的 DynAny 组件集合。对于表示基本类型（如 long）或没有组件的类型（如空异常）的 DynAny，有序的组件集合为空。每个 DynAny 对象在其组件 DynAny 集合中都有一个当前位置。当前位置由 0 到 n-1 的索引值标识，其中 n 为组件数。特殊索引值 -1 指示不指向任何位置的当前位置。对于不能有当前位置的值（如空异常），索引值始终为 -1。如果使用具有组件的值初始化 DynAny，则索引被初始化为 0。在创建未初始化的 DynAny（即不具有值但具有允许组件的 TypeCode 的 DynAny）之后，当前位置取决于由 DynAny 表示的值的类型。（将当前位置设置为 0 还是 -1 取决于新 DynAny 是否获取了其组件的默认值。）

迭代操作 rewind、seek 和 next 可用于更改当前位置，current_component 操作返回当前位置的组件。component_count 操作返回 DynAny 的组件数。总体上说，这些操作都能在 DynAny 的组件上进行迭代，从而能够（例如）检查其内容（递归式）。

已构造的 DynAny 对象是与构造类型关联的 DynAny 对象。还有一种从 DynAny 接口继承而来的接口，它与 IDL 中的每种构造类型（fixed、enum、struct、sequence、union、array、exception 和 value 类型）相关联。

已构造的 DynAny 对象导出支持创建新 DynAny 对象的操作，每个对象都与已构造数据值的组件相关联。例如，DynStruct 与 struct 值关联。这意味着 DynStruct 可视为拥有一个有序的组件集合，每个结构成员一个。DynStruct 对象导出支持创建新 DynAny 对象的操作，其中每个对象都与 struct 的成员关联。

如果 DynAny 对象是从另一个（已构造）DynAny 对象获取的（如表示从 DynStruct 创建的结构成员的 DynAny），则成员 DynAny 在逻辑上包含在 DynStruct 中。调用 insert 或 get 操作不更改当前位置。销毁顶级 DynAny 对象（不是作为另一个 DynAny 的组件获取的）将同时销毁从其获取的所有 DynAny 对象组件。销毁非顶级 DynAny 对象的操作没有任何效果。在已销毁的顶级 DynAny 或其任何子代上调用操作将引发 OBJECT_NOT_EXIST。如果程序员要销毁 DynAny 对象，但还需要操作与其关联的数据值的某个组件，则应该首先为该组件创建一个 DynAny，然后生成所创建的 DynAny 对象的副本。

为了支持高效实现，根据分配的内存空间和存取速度定义 DynAny 对象的行为。DynAny 对象旨在用于遍历从 any 析取的值，或用于在运行时构造 any 的值。不建议将其用于其他目的。

Insert 和 get 操作是处理基本 DynAny 对象所必需的，但是也可以使用它们来处理已构造的 DynAny 对象。将基本数据类型值插入已构造的 DynAny 对象意味着初始化与 DynAny 对象关联的已构造数据值的当前组件。例如，对 DynStruct 调用 insert_boolean 意味着在关联的 struct 数据值的当前位置插入 boolean 数据值。如果某个类型的 TypeCode 等效于 DynAny 中包含的 TypeCode，或者等效于处于当前位置的 DynAny 的 TypeCode（如果 DynAny 具有组件），则该类型与插入值或析取值一致。

DynAny 和 DynAnyFactory 对象对于创建和使用它们的进程而言是本地的。这意味着不能将对 DynAny 和 DynAnyFactory 对象的引用导出到其他进程，也不能通过 ORB.object_to_string() 使其具体化。如果进行这样的尝试，则该违反规则的操作将引发 MARSHAL 系统异常。由于它们的接口是在 IDL 中指定的，所以 DynAny 对象导出在标准 org.omg.CORBA.Object 接口中定义的操作。但是，任何尝试调用通过 Object 接口导出的操作都会引发标准 NO_IMPLEMENT 异常。尝试使用带有 DII 的 DynAny 对象将引发 NO_IMPLEMENT 异常。

构造方法摘要
DynAnyHelper()
方法摘要
static DynAny | extract(Any a)
static String | id()
static void | insert(Any a, DynAny that)
static DynAny | narrow(Object obj)
static DynAny | read(InputStream istream)
static TypeCode | type()
static DynAny | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynAny value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynAnyHelper

public DynAnyHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynAny that)

extract

public static DynAny extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynAny read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynAny value)

narrow

public static DynAny narrow(Object obj)

unchecked_narrow

public static DynAny unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynAnyOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynAnyOperations

所有已知子接口：
DynAny, DynArray, DynArrayOperations, DynEnum, DynEnumOperations, DynFixed, DynFixedOperations, DynSequence, DynSequenceOperations, DynStruct, DynStructOperations, DynUnion, DynUnionOperations, DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations
所有已知实现类：
_DynAnyStub, _DynArrayStub, _DynEnumStub, _DynFixedStub, _DynSequenceStub, _DynStructStub, _DynUnionStub, _DynValueStub
public interface DynAnyOperations

通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。DynAny 对象与对应于插入 any 的值的副本的数据值相关联。

DynAny 对象可视为一个有序的 DynAny 组件集合。对于表示基本类型（如 long）或没有组件的类型（如空异常）的 DynAny，有序的组件集合为空。每个 DynAny 对象在其组件 DynAny 集合中都有一个当前位置。当前位置由 0 到 n-1 的索引值标识，其中 n 为组件数。特殊索引值 -1 指示不指向任何位置的当前位置。对于不能有当前位置的值（如空异常），索引值始终为 -1。如果使用具有组件的值初始化 DynAny，则索引被初始化为 0。在创建未初始化的 DynAny（即不具有值但具有允许组件的 TypeCode 的 DynAny）之后，当前位置取决于由 DynAny 表示的值的类型。（将当前位置设置为 0 还是 -1 取决于新 DynAny 是否获取了其组件的默认值。）

迭代操作 rewind、seek 和 next 可用于更改当前位置，current_component 操作返回当前位置的组件。component_count 操作返回 DynAny 的组件数。总体上说，这些操作都能在 DynAny 的组件上进行迭代，从而能够（例如）检查其内容（递归式）。

已构造的 DynAny 对象是与构造类型关联的 DynAny 对象。还有一种从 DynAny 接口继承而来的接口，它与 IDL 中的每种构造类型（fixed、enum、struct、sequence、union、array、exception 和 value 类型）相关联。

已构造的 DynAny 对象导出支持创建新 DynAny 对象的操作，每个对象都与已构造数据值的组件相关联。例如，DynStruct 与 struct 值关联。这意味着 DynStruct 可视为拥有一个有序的组件集合，每个结构成员一个。DynStruct 对象导出支持创建新 DynAny 对象的操作，其中每个对象都与 struct 的成员关联。

如果 DynAny 对象是从另一个（已构造）DynAny 对象获取的（如表示从 DynStruct 创建的结构成员的 DynAny），则成员 DynAny 在逻辑上包含在 DynStruct 中。调用 insert 或 get 操作不更改当前位置。销毁顶级 DynAny 对象（不是作为另一个 DynAny 的组件获取的）将同时销毁从其获取的所有 DynAny 对象组件。销毁非顶级 DynAny 对象的操作没有任何效果。在已销毁的顶级 DynAny 或其任何子代上调用操作将引发 OBJECT_NOT_EXIST。如果程序员要销毁 DynAny 对象，但还需要操作与其关联的数据值的某个组件，则应该首先为该组件创建一个 DynAny，然后生成所创建的 DynAny 对象的副本。

为了支持高效实现，根据分配的内存空间和存取速度定义 DynAny 对象的行为。DynAny 对象旨在用于遍历从 any 析取的值，或用于在运行时构造 any 的值。不建议将其用于其他目的。

Insert 和 get 操作是处理基本 DynAny 对象所必需的，但是也可以使用它们来处理已构造的 DynAny 对象。将基本数据类型值插入已构造的 DynAny 对象意味着初始化与 DynAny 对象关联的已构造数据值的当前组件。例如，对 DynStruct 调用 insert_boolean 意味着在关联的 struct 数据值的当前位置插入 boolean 数据值。如果某个类型的 TypeCode 等效于 DynAny 中包含的 TypeCode，或者等效于处于当前位置的 DynAny 的 TypeCode（如果 DynAny 具有组件），则该类型与插入值或析取值一致。

DynAny 和 DynAnyFactory 对象对于创建和使用它们的进程而言是本地的。这意味着不能将对 DynAny 和 DynAnyFactory 对象的引用导出到其他进程，也不能通过 ORB.object_to_string() 使其具体化。如果进行这样的尝试，则该违反规则的操作将引发 MARSHAL 系统异常。由于它们的接口是在 IDL 中指定的，所以 DynAny 对象导出在标准 org.omg.CORBA.Object 接口中定义的操作。但是，任何尝试调用通过 Object 接口导出的操作都会引发标准 NO_IMPLEMENT 异常。尝试使用带有 DII 的 DynAny 对象将引发 NO_IMPLEMENT 异常。

方法摘要
 void assign(DynAny dyn_any)
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
 int component_count()
返回 DynAny 的组件数。
 DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
 DynAny current_component()
返回当前位置上的组件的 DynAny。
 void destroy()
销毁 DynAny 对象。
 boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。
 void from_any(Any value)
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
 Any get_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
 boolean get_boolean()
从此 DynAny 中提取 boolean 值。
 char get_char()
从此 DynAny 中提取 char 值。
 double get_double()
从此 DynAny 中提取 double 值。
 DynAny get_dyn_any()
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
 float get_float()
从此 DynAny 中提取 float 值。
 int get_long()
从此 DynAny 中提取 integer 值。
 long get_longlong()
从此 DynAny 中提取 long 值。
 byte get_octet()
从此 DynAny 中提取 byte 值。
 Object get_reference()
从此 DynAny 中提取对 CORBA 对象的引用。
 short get_short()
从此 DynAny 中提取 short 值。
 String get_string()
从此 DynAny 中提取 string 值。
 TypeCode get_typecode()
从此 DynAny 中提取 TypeCode 对象。
 int get_ulong()
从此 DynAny 中提取 integer 值。
 long get_ulonglong()
从此 DynAny 中提取 long 值。
 short get_ushort()
从此 DynAny 中提取 short 值。
 Serializable get_val()
从此 DynAny 中提取 Serializable 对象。
 char get_wchar()
从此 DynAny 中提取 long 值。
 String get_wstring()
从此 DynAny 中提取 string 值。
 void insert_any(Any value)
将 Any 值插入此 DynAny 表示的 Any 中。
 void insert_boolean(boolean value)
将 boolean 值插入 DynAny 中。
 void insert_char(char value)
将 char 值插入 DynAny 中。
 void insert_double(double value)
将 double 值插入 DynAny 中。
 void insert_dyn_any(DynAny value)
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
 void insert_float(float value)
将 float 值插入 DynAny 中。
 void insert_long(int value)
将 integer 值插入 DynAny 中。
 void insert_longlong(long value)
将 long 值插入 DynAny 中。
 void insert_octet(byte value)
将 byte 值插入 DynAny 中。
 void insert_reference(Object value)
将对 CORBA 对象的引用插入到 DynAny 中。
 void insert_short(short value)
将 short 值插入 DynAny 中。
 void insert_string(String value)
将 string 值插入 DynAny 中。
 void insert_typecode(TypeCode value)
将 TypeCode 对象插入 DynAny 中。
 void insert_ulong(int value)
将 integer 值插入 DynAny 中。
 void insert_ulonglong(long value)
将 long 值插入 DynAny 中。
 void insert_ushort(short value)
将 short 值插入 DynAny 中。
 void insert_val(Serializable value)
将对 Serializable 对象的引用插入此 DynAny 中。
 void insert_wchar(char value)
将 char 值插入 DynAny 中。
 void insert_wstring(String value)
将 string 值插入 DynAny 中。
 boolean next()
将当前位置推进到下一个组件。
 void rewind()
等效于 seek(0)。
 boolean seek(int index)
将当前位置设置为索引。
 Any to_any()
从 DynAny 对象创建 any 值。
 TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。

方法详细信息

type

TypeCode type()
返回与此 DynAny 对象有关联的 TypeCode。DynAny 对象是通过分配给它的 TypeCode 值创建的。此 TypeCode 值确定通过 DynAny 对象处理的值的类型。注意，与 DynAny 对象关联的 TypeCode 在创建 DynAny 时初始化，在 DynAny 对象的生存期间不能更改。

返回：
与 DynAny 对象关联的 TypeCode

assign

void assign(DynAny dyn_any)
            throws TypeMismatch
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

参数：
dyn_any -
抛出：
TypeMismatch - 如果传递的 DynAny 的类型不等于目标 DynAny 的类型

from_any

void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
使用 any 中包含的值初始化与 DynAny 对象有关联的值。对具有组件的值，将目标 DynAny 的当前位置设置为 0，对不具有组件的值，将该位置设置为 -1。

抛出：
TypeMismatch - 如果所传递 Any 的类型不等于目标 DynAny 的类型
InvalidValue - 如果所传递的 Any 不包含合法值（如 null 字符串）

to_any

Any to_any()
从 DynAny 对象创建 any 值。将与 DynAny 对象关联的 TypeCode 的副本分配给所得 any。将与 DynAny 对象关联的值复制到 any 中。

返回：
具有相同值和 TypeCode 的新 Any 对象

equal

boolean equal(DynAny dyn_any)
比较两个 DynAny 值是否相等。如果两个 DynAny 值的 TypeCode 相等，则它们的值相等；以此类推，所有组件 DynAny 都具有相等的值。将比较的两个 DynAny 的当前位置不影响比较结果。

返回：
如果 DynAny 相等，则返回 true；否则返回 false

destroy

void destroy()
销毁 DynAny 对象。此操作释放所有用来表示与 DynAny 对象关联的数据值的资源。为了避免资源泄漏，此操作必须在从 ORB 接口的创建操作之一获取的引用或者 DynAny.copy() 返回的引用上调用。在组件 DynAny 对象（例如，current_component 操作返回的对象）上调用 destroy 没有任何效果。销毁 DynAny 对象意味着销毁从其获取的所有 DynAny 对象。即对已销毁 DynAny 组件的引用将变得无效。调用这种引用将引发 OBJECT_NOT_EXIST。如果在销毁可从中获取组件的 DynAny 前使用 copy 操作生成了组件的复本，则可以在该 DynAny 的生存期后操作其组件。

copy

DynAny copy()
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。该操作是多态的，即对派生自 DynAny 的类型之一（如 DynStruct）调用该操作时，将创建派生的类型，但以 DynAny 基本类型的形式返回其引用。

返回：
DynAny 对象的深层复制

insert_boolean

void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
将 boolean 值插入 DynAny 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_octet

void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
将 byte 值插入 DynAny 中。将 IDL octet 数据类型映射为 Java byte 数据类型。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_char

void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
将 char 值插入 DynAny 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_short

void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
将 short 值插入 DynAny 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ushort

void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
将 short 值插入 DynAny 中。将 IDL ushort 数据类型映射为 Java short 数据类型。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_long

void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
将 integer 值插入 DynAny 中。将 IDL long 数据类型映射为 Java int 数据类型。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulong

void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
将 integer 值插入 DynAny 中。将 IDL ulong 数据类型映射为 Java int 数据类型。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_float

void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
将 float 值插入 DynAny 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_double

void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
将 double 值插入 DynAny 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_string

void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_reference

void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
将对 CORBA 对象的引用插入到 DynAny 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_typecode

void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
将 TypeCode 对象插入 DynAny 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_longlong

void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
将 long 值插入 DynAny 中。将 IDL long 数据类型映射为 Java long 数据类型。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_ulonglong

void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
将 long 值插入 DynAny 中。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wchar

void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
将 char 值插入 DynAny 中。将 IDL wchar 数据类型映射为 Java char 数据类型。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_wstring

void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
将 string 值插入 DynAny 中。有界的和无界的字符串都使用此方法插入。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
InvalidValue - 如果插入的字符串的长度超出有界字符串的界限
TypeMismatch

insert_any

void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
将 Any 值插入此 DynAny 表示的 Any 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_dyn_any

void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

insert_val

void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
将对 Serializable 对象的引用插入此 DynAny 中。将 IDL ValueBase 类型映射为 Java Serializable 类型。

抛出：
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法

get_boolean

boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
从此 DynAny 中提取 boolean 值。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_octet

byte get_octet()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 byte 值。将 IDL octet 数据类型映射为 Java byte 数据类型。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_char

char get_char()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 char 值。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_short

short get_short()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 short 值。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ushort

short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
从此 DynAny 中提取 short 值。将 IDL ushort 数据类型映射为 Java short 数据类型。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_long

int get_long()
             throws TypeMismatch,
                    InvalidValue
从此 DynAny 中提取 integer 值。将 IDL long 数据类型映射为 Java int 数据类型。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulong

int get_ulong()
              throws TypeMismatch,
                     InvalidValue
从此 DynAny 中提取 integer 值。将 IDL ulong 数据类型映射为 Java int 数据类型。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_float

float get_float()
                throws TypeMismatch,
                       InvalidValue
从此 DynAny 中提取 float 值。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_double

double get_double()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 double 值。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_string

String get_string()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_reference

Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取对 CORBA 对象的引用。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_typecode

TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
从此 DynAny 中提取 TypeCode 对象。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_longlong

long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
从此 DynAny 中提取 long 值。将 IDL long 数据类型映射为 Java long 数据类型。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_ulonglong

long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 long 值。将 IDL 无符号 long 数据类型映射为 Java long 数据类型。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wchar

char get_wchar()
               throws TypeMismatch,
                      InvalidValue
从此 DynAny 中提取 long 值。将 IDL wchar 数据类型映射为 Java char 数据类型。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_wstring

String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
从此 DynAny 中提取 string 值。有界的和无界的字符串都使用此方法析取。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue

get_any

Any get_any()
            throws TypeMismatch,
                   InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_dyn_any

DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

get_val

Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
从此 DynAny 中提取 Serializable 对象。将 IDL ValueBase 类型映射为 Java Serializable 类型。

抛出：
TypeMismatch - 如果在 DynAny 中访问的组件类型不等于所请求的类型。
TypeMismatch - 如果在其当前组件本身也有组件的 DynAny 上调用此方法
InvalidValue - 如果此 DynAny 具有组件，但当前位置为 -1

seek

boolean seek(int index)
将当前位置设置为索引。当前位置为索引 0 到 n-1，即索引 0 对应于第一个组件。如果所得当前位置指示 DynAny 的组件，则操作返回 true；如果索引指示的位置不与组件对应，则返回 false。使用负索引调用 seek 是合法的。它将当前位置设置为 -1，指示不存在组件，并返回 false。如果传递相应位置上没有组件的 DynAny 的非负索引值，则会将当前位置设置为 -1 并返回 false。

rewind

void rewind()
等效于 seek(0)。

next

boolean next()
将当前位置推进到下一个组件。如果所得当前位置指示一个组件，则该操作返回 true；否则返回 false。返回值为 false 时当前位置仍为 -1。如果在没有组件的 DynAny 上调用 next，则当前位置仍为 -1 并返回 false。

component_count

int component_count()
返回 DynAny 的组件数。对于没有组件的 DynAny，它返回 0。该操作仅计算位于顶层的组件。例如，如果在具有单个成员的 DynStruct 上调用 component_count，则返回值为 1，与成员的类型无关。
  • 对于序列 (sequence)，该操作返回当前的元素数。
  • 对于结构 (structure)、异常 (exception) 和值 (value) 类型，该操作返回成员数。
  • 对于数组 (array)，该操作返回元素数。
  • 对于联合数据 (union)，如果鉴别符指示指定的成员为活动状态，则返回 2；否则，它返回 1。
  • 对于 DynFixed 和 DynEnum，该操作返回 0。

current_component

DynAny current_component()
                         throws TypeMismatch
返回当前位置上的组件的 DynAny。它不推进当前位置，所以反复调用 current_component 且不插入对 rewind、next 或 seek 的调用将返回相同的组件。返回的 DynAny 对象引用可用于获取/设置当前组件的值。如果当前组件表示复合类型，则可基于 TypeCode 缩小返回引用的范围以获取对应于复合类型的接口。在不能有组件的 DynAny（如 DynEnum 或空异常）上调用 current_component 将引发 TypeMismatch。在其当前位置为 -1 的 DynAny 上调用 current_component 将返回 nil 引用。迭代操作和 current_component 都可用于动态组成 any 值。创建动态 any（如 DynStruct）后，current_component 和 next 可用于初始化值的所有组件。一旦完成初始化动态值，to_any 将创建相应的 any 值。

抛出：
TypeMismatch - 如果在不能有组件的 DynAny（如 DynEnum 或空异常）上调用此方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynAnySeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynAnySeqHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynAnySeqHelper

public abstract class DynAnySeqHelper
extends Object

org/omg/DynamicAny/DynAnySeqHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:17 (GMT-08:00)。

构造方法摘要
DynAnySeqHelper()
方法摘要
static DynAny[] | extract(Any a)
static String | id()
static void | insert(Any a, DynAny[] that)
static DynAny[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, DynAny[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynAnySeqHelper

public DynAnySeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynAny[] that)

extract

public static DynAny[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynAny[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynAny[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynArray (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynArray

所有超级接口：
DynAny, DynAnyOperations, DynArrayOperations, IDLEntity, Object, Serializable
所有已知实现类：
_DynArrayStub
public interface DynArray
extends DynArrayOperations, DynAny, IDLEntity

DynArray 对象支持对 IDL 数组的操作。注意，数组的维数包含在可通过类型属性访问的 TypeCode 中。也可以通过调用 component_count 操作得到。

方法摘要
从接口 org.omg.DynamicAny.DynArrayOperations 继承的方法
get_elements_as_dyn_any, get_elements, set_elements_as_dyn_any, set_elements
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynArrayHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynArrayHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynArrayHelper

public abstract class DynArrayHelper
extends Object

DynArray 对象支持对 IDL 数组的操作。注意，数组的维数包含在可通过类型属性访问的 TypeCode 中。也可以通过调用 component_count 操作得到。

构造方法摘要
DynArrayHelper()
方法摘要
static DynArray | extract(Any a)
static String | id()
static void | insert(Any a, DynArray that)
static DynArray | narrow(Object obj)
static DynArray | read(InputStream istream)
static TypeCode | type()
static DynArray | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynArray value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynArrayHelper

public DynArrayHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynArray that)

extract

public static DynArray extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynArray read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynArray value)

narrow

public static DynArray narrow(Object obj)

unchecked_narrow

public static DynArray unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynArrayOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynArrayOperations

所有超级接口：
DynAnyOperations
所有已知子接口：
DynArray
所有已知实现类：
_DynArrayStub
public interface DynArrayOperations
extends DynAnyOperations

DynArray 对象支持对 IDL 数组的操作。注意，数组的维数包含在可通过类型属性访问的 TypeCode 中。也可以通过调用 component_count 操作得到。

方法摘要
DynAny[] | get_elements_as_dyn_any() 以 DynAny 的形式返回 DynArray 的元素。
Any[] | get_elements() 返回 DynArray 的元素。
void | set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

get_elements

Any[] get_elements()
返回 DynArray 的元素。

set_elements

void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
设置 DynArray 以包含传递的元素。

抛出：
TypeMismatch - 如果一个或多个元素具有与 DynArrays TypeCode 不一致的类型
InvalidValue - 如果序列包含的元素数与数组维数不同

get_elements_as_dyn_any

DynAny[] get_elements_as_dyn_any()
以 DynAny 的形式返回 DynArray 的元素。

set_elements_as_dyn_any

void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
设置 DynArray 以包含传递的元素。

抛出：
TypeMismatch - 如果一个或多个元素具有与 DynArrays TypeCode 不一致的类型
InvalidValue - 如果序列包含的元素数与数组维数不同
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynEnum (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynEnum

所有超级接口：
DynAny, DynAnyOperations, DynEnumOperations, IDLEntity, Object, Serializable
所有已知实现类：
_DynEnumStub
public interface DynEnum
extends DynEnumOperations, DynAny, IDLEntity

DynEnum 对象支持对 IDL 枚举值的操作。DynEnum 的当前位置始终为 -1。

方法摘要
从接口 org.omg.DynamicAny.DynEnumOperations 继承的方法
get_as_string, get_as_ulong, set_as_string, set_as_ulong
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynEnumHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynEnumHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynEnumHelper

public abstract class DynEnumHelper
extends Object

DynEnum 对象支持对 IDL 枚举值的操作。DynEnum 的当前位置始终为 -1。

构造方法摘要
DynEnumHelper()
方法摘要
static DynEnum | extract(Any a)
static String | id()
static void | insert(Any a, DynEnum that)
static DynEnum | narrow(Object obj)
static DynEnum | read(InputStream istream)
static TypeCode | type()
static DynEnum | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynEnum value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynEnumHelper

public DynEnumHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynEnum that)

extract

public static DynEnum extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynEnum read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynEnum value)

narrow

public static DynEnum narrow(Object obj)

unchecked_narrow

public static DynEnum unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynEnumOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynEnumOperations

所有超级接口：
DynAnyOperations
所有已知子接口：
DynEnum
所有已知实现类：
_DynEnumStub
public interface DynEnumOperations
extends DynAnyOperations

DynEnum 对象支持对 IDL enumerated value 的操作。DynEnum 的当前位置始终为 -1。

方法摘要
String | get_as_string() 以 IDL 标识符的形式返回 DynEnum 的值。
int | get_as_ulong() 以枚举值序号的形式返回 DynEnum 的值。
void | set_as_string(String value) 将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
void | set_as_ulong(int value) 将 DynEnum 的值设置为枚举值的序号。
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

get_as_string

String get_as_string()
以 IDL 标识符的形式返回 DynEnum 的值。

set_as_string

void set_as_string(String value)
                   throws InvalidValue
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。

抛出：
InvalidValue - 如果值包含的字符串不是相应枚举类型的有效 IDL 标识符

get_as_ulong

int get_as_ulong()
以枚举值序号的形式返回 DynEnum 的值。枚举器 (enumerator) 的序号从 0 到 n-1，正如它们在相应的 IDL 定义中从左到右显示的那样。

set_as_ulong

void set_as_ulong(int value)
                  throws InvalidValue
将 DynEnum 的值设置为枚举值的序号。

抛出：
InvalidValue - 如果值包含相应枚举类型的序号范围之外的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynFixed (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynFixed

所有超级接口：
DynAny, DynAnyOperations, DynFixedOperations, IDLEntity, Object, Serializable
所有已知实现类：
_DynFixedStub
public interface DynFixed
extends DynFixedOperations, DynAny, IDLEntity

DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。因为 IDL 没有可以表示固定类型（其具有任意位数和标度）的常规类型，所以操作将使用 IDL 字符串类型。

方法摘要
从接口 org.omg.DynamicAny.DynFixedOperations 继承的方法
get_value, set_value
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynFixedHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynFixedHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynFixedHelper

public abstract class DynFixedHelper
extends Object

DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。因为 IDL 没有可以表示固定类型（其具有任意位数和标度）的常规类型，所以操作将使用 IDL 字符串类型。

构造方法摘要
DynFixedHelper()
方法摘要
static DynFixed | extract(Any a)
static String | id()
static void | insert(Any a, DynFixed that)
static DynFixed | narrow(Object obj)
static DynFixed | read(InputStream istream)
static TypeCode | type()
static DynFixed | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynFixed value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynFixedHelper

public DynFixedHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynFixed that)

extract

public static DynFixed extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynFixed read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynFixed value)

narrow

public static DynFixed narrow(Object obj)

unchecked_narrow

public static DynFixed unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynFixedOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynFixedOperations

所有超级接口：
DynAnyOperations
所有已知子接口：
DynFixed
所有已知实现类：
_DynFixedStub
public interface DynFixedOperations
extends DynAnyOperations

DynFixed 对象支持对 IDL 定值的操作。因为 IDL 没有可以表示固定类型（其具有任意位数和标度）的常规类型，所以操作将使用 IDL 字符串类型。

方法摘要
String | get_value() 返回 DynFixed 的值。
boolean | set_value(String val) 设置 DynFixed 的值。
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

get_value

String get_value()
返回 DynFixed 的值。

set_value

boolean set_value(String val)
                  throws TypeMismatch,
                         InvalidValue
设置 DynFixed 的值。val 字符串包含的固定字符串常量必须与用于 IDL 固定点字面值的常量具有相同的格式。不过，尾部的 d 或 D 是可选的。如果可以将 val 表示为 DynFixed 而不损失精度，则返回值为 true。如果 val 的小数位数多于 DynFixed 可以表示的位数，则小数位数将被截短，返回值为 false。

抛出：
TypeMismatch - 如果 val 不包含有效固定点字面值，或者包含除前导或尾部空白外的无关字符
InvalidValue - 如果 val 包含值的标度超出 DynFixed 的标度，或者 val 没有被初始化
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynSequence (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynSequence

所有超级接口：
DynAny, DynAnyOperations, DynSequenceOperations, IDLEntity, Object, Serializable
所有已知实现类：
_DynSequenceStub
public interface DynSequence
extends DynSequenceOperations, DynAny, IDLEntity

DynSequence 对象支持对 IDL 序列的操作。

方法摘要
从接口 org.omg.DynamicAny.DynSequenceOperations 继承的方法
get_elements_as_dyn_any, get_elements, get_length, set_elements_as_dyn_any, set_elements, set_length
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynSequenceHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynSequenceHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynSequenceHelper

public abstract class DynSequenceHelper
extends Object

DynSequence 对象支持对 IDL 序列的操作。

构造方法摘要
DynSequenceHelper()
方法摘要
static DynSequence | extract(Any a)
static String | id()
static void | insert(Any a, DynSequence that)
static DynSequence | narrow(Object obj)
static DynSequence | read(InputStream istream)
static TypeCode | type()
static DynSequence | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynSequence value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynSequenceHelper

public DynSequenceHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynSequence that)

extract

public static DynSequence extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynSequence read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynSequence value)

narrow

public static DynSequence narrow(Object obj)

unchecked_narrow

public static DynSequence unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynSequenceOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynSequenceOperations

所有超级接口：
DynAnyOperations
所有已知子接口：
DynSequence
所有已知实现类：
_DynSequenceStub
public interface DynSequenceOperations
extends DynAnyOperations

DynSequence 对象支持对 IDL 序列的操作。

方法摘要
DynAny[] | get_elements_as_dyn_any() 返回表示序列元素的 DynAny。
Any[] | get_elements() 返回序列的元素。
int | get_length() 返回序列的当前长度。
void | set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | set_elements(Any[] value) 设置序列的元素。
void | set_length(int len) 设置序列的长度。
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

get_length

int get_length()
返回序列的当前长度。

set_length

void set_length(int len)
                throws InvalidValue
设置序列的长度。增加序列的长度将在尾部添加新元素，同时不影响现有元素的值。新添加的元素按默认方式初始化。如果上一个当前位置是 -1，则增加序列的长度会将当前位置设置为第一个新添加的元素。如果上一个当前位置不是 -1，则该操作对当前位置没有影响。减少序列的长度将从尾部移除元素，同时不影响剩余元素的值。减少序列长度后，新的当前位置用以下方式确定：
  • 如果将序列长度设置为 0，则当前位置被设置为 -1。
  • 如果减少长度前当前位置为 -1，则其仍然为 -1。
  • 如果当前位置指示一个有效元素，而该元素在减少长度后没有被移除，则当前位置保持不变。
  • 如果当前位置指示一个有效元素，但该元素在减少长度后被移除，则将当前位置设置为 -1。

抛出：
InvalidValue - 如果此为有界序列且 len 大于其界限

get_elements

Any[] get_elements()
返回序列的元素。

set_elements

void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
设置序列的元素。将 DynSequence 的长度设置为 value 的长度。如果 value 的长度不为 0，则将当前位置设置为 0；如果 value 是长度为 0 的序列，则将当前位置设置为 -1。

抛出：
TypeMismatch - 如果 value 包含一个或多个元素，而这些元素的 TypeCode 不等于 DynSequence 的 TypeCode 元素
InvalidValue - 如果 value 的长度超出有界序列的界限

get_elements_as_dyn_any

DynAny[] get_elements_as_dyn_any()
返回表示序列元素的 DynAny。

set_elements_as_dyn_any

void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
使用 DynAny 设置序列的元素。将 DynSequence 的长度设置为 value 的长度。如果 value 的长度不为 0，则将当前位置设置为 0；如果 value 是长度为 0 的序列，则将当前位置设置为 -1。

抛出：
TypeMismatch - 如果 value 包含一个或多个元素，而这些元素的 TypeCode 不等于 DynSequence 的 TypeCode 元素
InvalidValue - 如果 value 的长度超出有界序列的界限
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynStruct (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynStruct

所有超级接口：
DynAny, DynAnyOperations, DynStructOperations, IDLEntity, Object, Serializable
所有已知实现类：
_DynStructStub
public interface DynStruct
extends DynStructOperations, DynAny, IDLEntity

DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。对异常成员的处理方式与对结构数据成员一样。

方法摘要
从接口 org.omg.DynamicAny.DynStructOperations 继承的方法
current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynStructHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynStructHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynStructHelper

public abstract class DynStructHelper
extends Object

DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。对异常成员的处理方式与对结构数据成员一样。

构造方法摘要
DynStructHelper()
方法摘要
static DynStruct | extract(Any a)
static String | id()
static void | insert(Any a, DynStruct that)
static DynStruct | narrow(Object obj)
static DynStruct | read(InputStream istream)
static TypeCode | type()
static DynStruct | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynStruct value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynStructHelper

public DynStructHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynStruct that)

extract

public static DynStruct extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynStruct read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynStruct value)

narrow

public static DynStruct narrow(Object obj)

unchecked_narrow

public static DynStruct unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynStructOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynStructOperations

所有超级接口：
DynAnyOperations
所有已知子接口：
DynStruct
所有已知实现类：
_DynStructStub
public interface DynStructOperations
extends DynAnyOperations

DynStruct 对象支持对 IDL 结构数据 (struct) 和异常 (exception) 值的操作。对异常成员的处理方式与对结构数据成员一样。

方法摘要
TCKind | current_member_kind() 返回与当前位置的成员关联的 TCKind。
String | current_member_name() 返回当前位置的成员的名称。
NameDynAnyPair[] | get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameValuePair[] | get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
void | set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

current_member_name

String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
返回当前位置的成员的名称。此操作可能返回空字符串，因为所操作的值的 TypeCode 可能不包含成员名称。

抛出：
TypeMismatch - 如果 DynStruct 表示空异常。
InvalidValue - 如果当前位置不指示成员

current_member_kind

TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
返回与当前位置的成员关联的 TCKind。

抛出：
TypeMismatch - 如果 DynStruct 表示空异常。
InvalidValue - 如果当前位置不指示成员

get_members

NameValuePair[] get_members()
返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。该序列所含成员的顺序与成员的声明顺序（由 DynStruct 的 TypeCode 指示）相同。当前位置不受影响。如果 DynStruct 的 TypeCode 不包含成员名称，则返回序列中的成员名称将为空字符串。

set_members

void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。如果传递的序列长度不为 0，则操作将当前位置设置为 0。如果传递的是空序列，则将当前位置设置为 -1。

根据 DynStruct 的 TypeCode 的指示，成员在 NameValuePair 中必须按它们在结构数据的 IDL 规范中的显示顺序显示，除非它们为空字符串。该操作不尝试根据成员名称分配成员值。

抛出：
TypeMismatch - 如果所传递序列中提供的成员名称与 DynStruct 的 TypeCode 中相应成员名称不匹配，并且它们都不是空字符串
InvalidValue - 如果所传递序列的元素数与 DynStruct 的 TypeCode 指示的成员数不一致

get_members_as_dyn_any

NameDynAnyPair[] get_members_as_dyn_any()
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。该序列所含成员的顺序与成员的声明顺序（由 DynStruct 的 TypeCode 指示）相同。当前位置不受影响。如果 DynStruct 的 TypeCode 不包含成员名称，则返回序列中的成员名称将为空字符串。

set_members_as_dyn_any

void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。如果传递的序列长度不为 0，则操作将当前位置设置为 0。如果传递的是空序列，则将当前位置设置为 -1。

根据 DynStruct 的 TypeCode 的指示，成员在 NameDynAnyPair 中必须按它们在结构数据的 IDL 规范中的显示顺序显示，除非它们为空字符串。该操作不尝试根据成员名称分配成员值。

抛出：
TypeMismatch - 如果所传递序列中提供的成员名称与 DynStruct 的 TypeCode 中相应成员名称不匹配，并且它们都不是空字符串
InvalidValue - 如果所传递序列的元素数与 DynStruct 的 TypeCode 指示的成员数不一致
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynUnion (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynUnion

所有超级接口：
DynAny, DynAnyOperations, DynUnionOperations, IDLEntity, Object, Serializable
所有已知实现类：
_DynUnionStub
public interface DynUnion
extends DynUnionOperations, DynAny, IDLEntity

DynUnion 对象支持对 IDL 联合 (union) 的操作。联合数据只能有两个有效的当前位置：

  • 0，表示鉴别符 (discriminator)
  • 1，表示活动成员
联合数据的 component_count 值依赖于当前鉴别符：其鉴别符指示一个指定成员的联合数据的 component_count 值为 2，其他情况为 1。

方法摘要
从接口 org.omg.DynamicAny.DynUnionOperations 继承的方法
discriminator_kind, get_discriminator, has_no_active_member, member_kind, member_name, member, set_discriminator, set_to_default_member, set_to_no_active_member
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynUnionHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynUnionHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynUnionHelper

public abstract class DynUnionHelper
extends Object

DynUnion 对象支持对 IDL 联合数据 (union) 的操作。联合数据只能有两个有效的当前位置：

  • 0，表示鉴别符 (discriminator)
  • 1，表示活动成员
联合数据的 component_count 值依赖于当前鉴别符：其鉴别符指示一个指定成员的联合数据的 component_count 值为 2，其他情况为 1。

构造方法摘要
DynUnionHelper()
方法摘要
static DynUnion | extract(Any a)
static String | id()
static void | insert(Any a, DynUnion that)
static DynUnion | narrow(Object obj)
static DynUnion | read(InputStream istream)
static TypeCode | type()
static DynUnion | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynUnion value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynUnionHelper

public DynUnionHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynUnion that)

extract

public static DynUnion extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynUnion read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynUnion value)

narrow

public static DynUnion narrow(Object obj)

unchecked_narrow

public static DynUnion unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynUnionOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynUnionOperations

所有超级接口：
DynAnyOperations
所有已知子接口：
DynUnion
所有已知实现类：
_DynUnionStub
public interface DynUnionOperations
extends DynAnyOperations

DynUnion 对象支持对 IDL 联合数据 (union) 的操作。联合数据只能有两个有效的当前位置：

  • 0，表示鉴别符 (discriminator)
  • 1，表示活动成员
联合数据的 component_count 值依赖于当前鉴别符：其鉴别符指示一个指定成员的联合数据的 component_count 值为 2，其他情况为 1。

方法摘要
TCKind | discriminator_kind() 返回鉴别符 TypeCode 的 TCKind 值。
DynAny | get_discriminator() 返回当前鉴别符值。
boolean | has_no_active_member() 如果联合数据没有活动成员，即这些联合数据值仅由其鉴别符组成（因为鉴别符的值不作为显式 case 标签列出），则返回 true。
TCKind | member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。
String | member_name() 返回当前活动成员的名称。
DynAny | member() 返回当前活动成员。
void | set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | set_to_default_member() 将鉴别符设置为联合数据的默认 case 的值。
void | set_to_no_active_member() 将鉴别符设置为与任何联合数据 case 标签都不相应的值。
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

get_discriminator

DynAny get_discriminator()
返回当前鉴别符值。

set_discriminator

void set_discriminator(DynAny d)
                       throws TypeMismatch
将 DynUnion 的鉴别符值设置为指定值。将鉴别符设置为与当前活动联合数据成员一致的值对当前活动成员没有影响。将鉴别符设置为与当前活动成员不一致的值将停用该成员，并将与新鉴别符值一致的成员（如果存在与该值对应的成员）初始化为其默认值，从而激活该成员。如果鉴别符值指示一个不存在的联合数据成员，则设置联合数据鉴别符会将当前位置设置为 0（在此情况下，has_no_active_member 返回 true）。否则，如果鉴别符值指示指定的联合数据成员，则将当前位置设置为 1（在此情况下，has_no_active_member 返回 false，component_count 返回 2）。

抛出：
TypeMismatch - 如果参数的 TypeCode 不等于联合数据鉴别符的 TypeCode

set_to_default_member

void set_to_default_member()
                           throws TypeMismatch
将鉴别符设置为联合数据的默认 case 的值。它将当前位置设置为 0，并导致 component_count 返回 2。

抛出：
TypeMismatch - 如果联合数据没有显式的默认 case

set_to_no_active_member

void set_to_no_active_member()
                             throws TypeMismatch
将鉴别符设置为与任何联合数据 case 标签都不相应的值。它将当前位置设置为 0，并导致 component_count 返回 1。

抛出：
TypeMismatch - 如果联合数据具有显式的默认 case，或者其显式 case 标签使用了整个鉴别符值范围

has_no_active_member

boolean has_no_active_member()
如果联合数据没有活动成员，即这些联合数据值仅由其鉴别符组成（因为鉴别符的值不作为显式 case 标签列出），则返回 true。对具有默认 case 的联合数据调用此操作将返回 false。对显式 case 标签使用了整个鉴别符值范围的联合数据调用此操作将返回 false。

discriminator_kind

TCKind discriminator_kind()
返回鉴别符 TypeCode 的 TCKind 值。

member_kind

TCKind member_kind()
                   throws InvalidValue
返回当前活动成员 TypeCode 的 TCKind 值。

抛出：
InvalidValue - 如果联合数据不具有当前活动成员

member

DynAny member()
              throws InvalidValue
返回当前活动成员。注意，当且仅当当前活动成员没有更改时返回的引用才仍然有效。使用超出当前活动成员生存时间的返回引用将引发 OBJECT_NOT_EXIST。

抛出：
InvalidValue - 如果联合数据没有活动成员

member_name

String member_name()
                   throws InvalidValue
返回当前活动成员的名称。如果联合数据 TypeCode 不包含当前活动成员的成员名称，则操作将返回空字符串。

抛出：
InvalidValue - 如果联合数据没有活动成员
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynValue (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynValue

所有超级接口：
DynAny, DynAnyOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations, IDLEntity, Object, Serializable
所有已知实现类：
_DynValueStub
public interface DynValue
extends DynValueOperations, DynValueCommon, IDLEntity

DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。DynValue 接口可表示 null 和非 null 两种值类型。对于表示非 null 值类型的 DynValue，DynValue 的组件由该值类型的公共和专有成员组成，包括那些按照定义的顺序从具体基本值类型继承的成员。表示 null 值类型的 DynValue 没有组件，其当前位置为 -1。

警告：不加区别地更改专有值类型成员的内容将导致值类型实现因违反内部约束而破坏。提供对专有成员的访问是为了支持 ORB 桥接和调试之类的活动，不应使用该权限任意违反值类型的封装。

方法摘要
从接口 org.omg.DynamicAny.DynValueOperations 继承的方法
current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members
从接口 org.omg.DynamicAny.DynValueCommonOperations 继承的方法
is_null, set_to_null, set_to_value
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynValueBox (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynValueBox

所有超级接口：
DynAny, DynAnyOperations, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, IDLEntity, Object, Serializable
public interface DynValueBox
extends DynValueBoxOperations, DynValueCommon, IDLEntity

DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。DynValueBox 接口可表示 null 和非 null 两种值类型。对于表示非 null 值类型的 DynValueBox，DynValueBox 具有单个装箱类型的组件。表示 null 值类型的 DynValueBox 没有组件，其当前位置为 -1。

方法摘要
从接口 org.omg.DynamicAny.DynValueBoxOperations 继承的方法
get_boxed_value_as_dyn_any, get_boxed_value, set_boxed_value_as_dyn_any, set_boxed_value
从接口 org.omg.DynamicAny.DynValueCommonOperations 继承的方法
is_null, set_to_null, set_to_value
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynValueBoxOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynValueBoxOperations

所有超级接口：
DynAnyOperations, DynValueCommonOperations
所有已知子接口：
DynValueBox
public interface DynValueBoxOperations
extends DynValueCommonOperations

DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。DynValueBox 接口可表示 null 和非 null 两种值类型。对于表示非 null 值类型的 DynValueBox，DynValueBox 具有单个装箱类型的组件。表示 null 值类型的 DynValueBox 没有组件，其当前位置为 -1。

方法摘要
DynAny | get_boxed_value_as_dyn_any() 以 DynAny 的形式返回已装箱值。
Any | get_boxed_value() 以 Any 的形式返回装箱值。
void | set_boxed_value_as_dyn_any(DynAny boxed) 使用参数中包含的值取代已装箱值。
void | set_boxed_value(Any boxed) 使用指定值取代已装箱值。
从接口 org.omg.DynamicAny.DynValueCommonOperations 继承的方法
is_null, set_to_null, set_to_value
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

get_boxed_value

Any get_boxed_value()
                    throws InvalidValue
以 Any 的形式返回装箱值。

抛出：
InvalidValue - 如果此对象表示 null 值装箱类型

set_boxed_value

void set_boxed_value(Any boxed)
                     throws TypeMismatch
使用指定值取代已装箱值。如果 DynBoxedValue 表示 null 值类型，则将其转换为非 null 值。

抛出：
TypeMismatch - 如果此对象表示非 null 值装箱类型，并且参数的类型与当前已装箱值类型不匹配。

get_boxed_value_as_dyn_any

DynAny get_boxed_value_as_dyn_any()
                                  throws InvalidValue
以 DynAny 的形式返回已装箱值。

抛出：
InvalidValue - 如果此对象表示 null 值装箱类型

set_boxed_value_as_dyn_any

void set_boxed_value_as_dyn_any(DynAny boxed)
                                throws TypeMismatch
使用参数中包含的值取代已装箱值。如果 DynBoxedValue 表示 null 值类型，则将其转换为非 null 值。

抛出：
TypeMismatch - 如果此对象表示非 null 值装箱类型，并且参数的类型与当前已装箱值类型不匹配。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynValueCommon (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynValueCommon

所有超级接口：
DynAny, DynAnyOperations, DynValueCommonOperations, IDLEntity, Object, Serializable
所有已知子接口：
DynValue, DynValueBox
所有已知实现类：
_DynValueStub
public interface DynValueCommon
extends DynValueCommonOperations, DynAny, IDLEntity

DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

方法摘要
从接口 org.omg.DynamicAny.DynValueCommonOperations 继承的方法
is_null, set_to_null, set_to_value
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type
从接口 org.omg.CORBA.Object 继承的方法
_create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynValueCommonOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynValueCommonOperations

所有超级接口：
DynAnyOperations
所有已知子接口：
DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueOperations
所有已知实现类：
_DynValueStub
public interface DynValueCommonOperations
extends DynAnyOperations

DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

方法摘要
boolean | is_null() 如果 DynValueCommon 表示 null 值类型，则返回 true。
void | set_to_null() 将 DynValueCommon 的表示形式更改为 null 值类型。
void | set_to_value() 使用新构造的值取代 null 值类型。
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

is_null

boolean is_null()
如果 DynValueCommon 表示 null 值类型，则返回 true。

set_to_null

void set_to_null()
将 DynValueCommon 的表示形式更改为 null 值类型。

set_to_value

void set_to_value()
使用新构造的值取代 null 值类型。将其组件初始化为默认值，该值与使用 DynAnyFactory.create_dyn_any_from_type_code 所得结果相同。如果 DynValueCommon 表示非 null 值类型，则此操作无效。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynValueHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 DynValueHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynValueHelper

public abstract class DynValueHelper
extends Object

DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。DynValue 接口可表示 null 和非 null 两种值类型。对于表示非 null 值类型的 DynValue，DynValue 的组件由该值类型的公共和专有成员组成，包括那些按照定义的顺序从具体基本值类型继承的成员。表示 null 值类型的 DynValue 没有组件，其当前位置为 -1。

警告：不加区别地更改专有值类型成员的内容将导致值类型实现因违反内部约束而破坏。提供对专有成员的访问是为了支持 ORB 桥接和调试之类的活动，不应使用该权限任意违反值类型的封装。

构造方法摘要
DynValueHelper()
方法摘要
static DynValue | extract(Any a)
static String | id()
static void | insert(Any a, DynValue that)
static DynValue | narrow(Object obj)
static DynValue | read(InputStream istream)
static TypeCode | type()
static DynValue | unchecked_narrow(Object obj)
static void | write(OutputStream ostream, DynValue value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DynValueHelper

public DynValueHelper()
方法详细信息

insert

public static void insert(Any a,
                          DynValue that)

extract

public static DynValue extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static DynValue read(InputStream istream)

write

public static void write(OutputStream ostream,
                         DynValue value)

narrow

public static DynValue narrow(Object obj)

unchecked_narrow

public static DynValue unchecked_narrow(Object obj)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynValueOperations (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
接口 DynValueOperations

所有超级接口：
DynAnyOperations, DynValueCommonOperations
所有已知子接口：
DynValue
所有已知实现类：
_DynValueStub
public interface DynValueOperations
extends DynValueCommonOperations

DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。DynValue 接口可表示 null 和非 null 两种值类型。对于表示非 null 值类型的 DynValue，DynValue 的组件由该值类型的公共和专有成员组成，包括那些按照定义的顺序从具体基本值类型继承的成员。表示 null 值类型的 DynValue 没有组件，其当前位置为 -1。

警告：不加区别地更改专有值类型成员的内容将导致值类型实现因违反内部约束而破坏。提供对专有成员的访问是为了支持 ORB 桥接和调试之类的活动，不应使用该权限任意违反值类型的封装。

方法摘要
TCKind | current_member_kind() 返回与当前位置的成员关联的 TCKind。
String | current_member_name() 返回当前位置上的成员的名称。
NameDynAnyPair[] | get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
NameValuePair[] | get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
void | set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
从接口 org.omg.DynamicAny.DynValueCommonOperations 继承的方法
is_null, set_to_null, set_to_value
从接口 org.omg.DynamicAny.DynAnyOperations 继承的方法
assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

方法详细信息

current_member_name

String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
返回当前位置上的成员的名称。此操作可能返回空字符串，因为所操作的值的 TypeCode 可能不包含成员名称。

抛出：
TypeMismatch - 如果 DynValue 表示 null 值类型。
InvalidValue - 如果当前位置不指示成员

current_member_kind

TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
返回与当前位置的成员关联的 TCKind。

抛出：
TypeMismatch - 如果 DynValue 表示 null 值类型。
InvalidValue - 如果当前位置不指示成员

get_members

NameValuePair[] get_members()
                            throws InvalidValue
返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。该序列所含成员的顺序与成员的声明顺序（由 DynValue 的 TypeCode 指示）相同。当前位置不受影响。如果 DynValue 的 TypeCode 不包含成员名称，则返回序列中的成员名称将为空字符串。

抛出：
InvalidValue - 如果此对象表示 null 值类型

set_members

void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
根据 NameValuePair 序列初始化该值类型的成员。如果传递的序列长度不为 0，则操作将当前位置设置为 0。如果传递空序列，则将当前位置设置为 -1。使用此方法可以将 null 值类型初始化为非 null 值类型。

根据 DynValue 的 TypeCode 的指示，成员在 NameValuePair 中必须按它们在值类型的 IDL 规范中的显示顺序显示，除非它们为空字符串。该操作不尝试根据成员名称分配成员值。

抛出：
TypeMismatch - 如果所传递序列中提供的成员名称与 DynValue 的 TypeCode 中相应成员名称不匹配，并且它们都不是空字符串
InvalidValue - 如果所传递序列的元素数与 DynValue 的 TypeCode 指示的成员数不一致

get_members_as_dyn_any

NameDynAnyPair[] get_members_as_dyn_any()
                                        throws InvalidValue
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。该序列所含成员的顺序与成员的声明顺序（由 DynValue 的 TypeCode 指示）相同。当前位置不受影响。如果 DynValue 的 TypeCode 不包含成员名称，则返回序列中的成员名称将为空字符串。

抛出：
InvalidValue - 如果此对象表示 null 值类型

set_members_as_dyn_any

void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
根据 NameDynAnyPair 序列初始化该值类型的成员。如果传递的序列长度不为 0，则操作将当前位置设置为 0。如果传递空序列，则将当前位置设置为 -1。使用此方法可以将 null 值类型初始化为非 null 值类型。

根据 DynValue 的 TypeCode 的指示，成员在 NameDynAnyPair 中必须按它们在值类型的 IDL 规范中的显示顺序显示，除非它们为空字符串。该操作不尝试根据成员名称分配成员值。

抛出：
TypeMismatch - 如果所传递序列中提供的成员名称与 DynValue 的 TypeCode 中相应成员名称不匹配，并且它们都不是空字符串
InvalidValue - 如果所传递序列的元素数与 DynValue 的 TypeCode 指示的成员数不一致
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldNameHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 FieldNameHelper

java.lang.Object
    继承者  org.omg.DynamicAny.FieldNameHelper

public abstract class FieldNameHelper
extends Object

org/omg/DynamicAny/FieldNameHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:16 (GMT-08:00)。

构造方法摘要
FieldNameHelper()
方法摘要
static String | extract(Any a)
static String | id()
static void | insert(Any a, String that)
static String | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, String value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FieldNameHelper

public FieldNameHelper()
方法详细信息

insert

public static void insert(Any a,
                          String that)

extract

public static String extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static String read(InputStream istream)

write

public static void write(OutputStream ostream,
                         String value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameDynAnyPair (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 NameDynAnyPair

java.lang.Object
    继承者  org.omg.DynamicAny.NameDynAnyPair
所有已实现的接口：
Serializable, IDLEntity
public final class NameDynAnyPair
extends Object
implements IDLEntity

org/omg/DynamicAny/NameDynAnyPair.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:16 (GMT-08:00)。

字段摘要
String | id 与 DynAny 关联的名称。
DynAny | value 与名称关联的 DynAny 值。
构造方法摘要
NameDynAnyPair()
NameDynAnyPair(String _id, DynAny _value)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

id

public String id
与 DynAny 关联的名称。

value

public DynAny value
与名称关联的 DynAny 值。

构造方法详细信息

NameDynAnyPair

public NameDynAnyPair()

NameDynAnyPair

public NameDynAnyPair(String _id,
                      DynAny _value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameDynAnyPairHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 NameDynAnyPairHelper

java.lang.Object
    继承者  org.omg.DynamicAny.NameDynAnyPairHelper

public abstract class NameDynAnyPairHelper
extends Object

org/omg/DynamicAny/NameDynAnyPairHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:16 (GMT-08:00)。

构造方法摘要
NameDynAnyPairHelper()
方法摘要
static NameDynAnyPair | extract(Any a)
static String | id()
static void | insert(Any a, NameDynAnyPair that)
static NameDynAnyPair | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameDynAnyPair value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NameDynAnyPairHelper

public NameDynAnyPairHelper()
方法详细信息

insert

public static void insert(Any a,
                          NameDynAnyPair that)

extract

public static NameDynAnyPair extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameDynAnyPair read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameDynAnyPair value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameDynAnyPairSeqHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 NameDynAnyPairSeqHelper

java.lang.Object
    继承者  org.omg.DynamicAny.NameDynAnyPairSeqHelper

public abstract class NameDynAnyPairSeqHelper
extends Object

org/omg/DynamicAny/NameDynAnyPairSeqHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:17 (GMT-08:00)。

构造方法摘要
NameDynAnyPairSeqHelper()
方法摘要
static NameDynAnyPair[] | extract(Any a)
static String | id()
static void | insert(Any a, NameDynAnyPair[] that)
static NameDynAnyPair[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameDynAnyPair[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NameDynAnyPairSeqHelper

public NameDynAnyPairSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          NameDynAnyPair[] that)

extract

public static NameDynAnyPair[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameDynAnyPair[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameDynAnyPair[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameValuePair (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 NameValuePair

java.lang.Object
    继承者  org.omg.DynamicAny.NameValuePair
所有已实现的接口：
Serializable, IDLEntity
public final class NameValuePair
extends Object
implements IDLEntity

org/omg/DynamicAny/NameValuePair.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:16 (GMT-08:00)。

字段摘要
String | id 与 Any 有关联的名称。
Any | value 与名称关联的 Any 值。
构造方法摘要
NameValuePair()
NameValuePair(String _id, Any _value)
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

id

public String id
与 Any 有关联的名称。

value

public Any value
与名称关联的 Any 值。

构造方法详细信息

NameValuePair

public NameValuePair()

NameValuePair

public NameValuePair(String _id,
                     Any _value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameValuePairHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 NameValuePairHelper

java.lang.Object
    继承者  org.omg.DynamicAny.NameValuePairHelper

public abstract class NameValuePairHelper
extends Object

org/omg/DynamicAny/NameValuePairHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:16 (GMT-08:00)。

构造方法摘要
NameValuePairHelper()
方法摘要
static NameValuePair | extract(Any a)
static String | id()
static void | insert(Any a, NameValuePair that)
static NameValuePair | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameValuePair value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NameValuePairHelper

public NameValuePairHelper()
方法详细信息

insert

public static void insert(Any a,
                          NameValuePair that)

extract

public static NameValuePair extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameValuePair read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameValuePair value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameValuePairSeqHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny
类 NameValuePairSeqHelper

java.lang.Object
    继承者  org.omg.DynamicAny.NameValuePairSeqHelper

public abstract class NameValuePairSeqHelper
extends Object

org/omg/DynamicAny/NameValuePairSeqHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2004 年 8 月 11 日，星期三上午 5:04:16 (GMT-08:00)。

构造方法摘要
NameValuePairSeqHelper()
方法摘要
static NameValuePair[] | extract(Any a)
static String | id()
static void | insert(Any a, NameValuePair[] that)
static NameValuePair[] | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, NameValuePair[] value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NameValuePairSeqHelper

public NameValuePairSeqHelper()
方法详细信息

insert

public static void insert(Any a,
                          NameValuePair[] that)

extract

public static NameValuePair[] extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static NameValuePair[] read(InputStream istream)

write

public static void write(OutputStream ostream,
                         NameValuePair[] value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.DynamicAny (Java Platform SE 6)

 org.omg.DynamicAny
接口
DynAny
DynAnyFactory
DynAnyFactoryOperations
DynAnyOperations
DynArray
DynArrayOperations
DynEnum
DynEnumOperations
DynFixed
DynFixedOperations
DynSequence
DynSequenceOperations
DynStruct
DynStructOperations
DynUnion
DynUnionOperations
DynValue
DynValueBox
DynValueBoxOperations
DynValueCommon
DynValueCommonOperations
DynValueOperations
类
_DynAnyFactoryStub
_DynAnyStub
_DynArrayStub
_DynEnumStub
_DynFixedStub
_DynSequenceStub
_DynStructStub
_DynUnionStub
_DynValueStub
AnySeqHelper
DynAnyFactoryHelper
DynAnyHelper
DynAnySeqHelper
DynArrayHelper
DynEnumHelper
DynFixedHelper
DynSequenceHelper
DynStructHelper
DynUnionHelper
DynValueHelper
FieldNameHelper
NameDynAnyPair
NameDynAnyPairHelper
NameDynAnyPairSeqHelper
NameValuePair
NameValuePairHelper
NameValuePairSeqHelper


org.omg.DynamicAny (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.DynamicAny

提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

请参见：
描述

接口摘要
DynAny | 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnyFactory | DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyFactoryOperations | DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyOperations | 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynArray | DynArray 对象支持对 IDL 数组的操作。
DynArrayOperations | DynArray 对象支持对 IDL 数组的操作。
DynEnum | DynEnum 对象支持对 IDL 枚举值的操作。
DynEnumOperations | DynEnum 对象支持对 IDL enumerated value 的操作。
DynFixed | DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
DynFixedOperations | DynFixed 对象支持对 IDL 定值的操作。
DynSequence | DynSequence 对象支持对 IDL 序列的操作。
DynSequenceOperations | DynSequence 对象支持对 IDL 序列的操作。
DynStruct | DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
DynStructOperations | DynStruct 对象支持对 IDL 结构数据 (struct) 和异常 (exception) 值的操作。
DynUnion | DynUnion 对象支持对 IDL 联合 (union) 的操作。
DynUnionOperations | DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
DynValue | DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
DynValueBox | DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
DynValueBoxOperations | DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
DynValueCommon | DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
DynValueCommonOperations | DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
DynValueOperations | DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。

类摘要
_DynAnyFactoryStub | DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
_DynAnyStub | 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
_DynArrayStub | DynArray 对象支持对 IDL 数组 (array) 的操作。
_DynEnumStub | DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
_DynFixedStub | DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
_DynSequenceStub | DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
_DynStructStub | DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
_DynUnionStub | DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
_DynValueStub | DynValue 对象支持 IDL non-boxed value 类型的操作。
AnySeqHelper | org/omg/DynamicAny/AnySeqHelper.java。
DynAnyFactoryHelper | DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyHelper | 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnySeqHelper | org/omg/DynamicAny/DynAnySeqHelper.java。
DynArrayHelper | DynArray 对象支持对 IDL 数组的操作。
DynEnumHelper | DynEnum 对象支持对 IDL 枚举值的操作。
DynFixedHelper | DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
DynSequenceHelper | DynSequence 对象支持对 IDL 序列的操作。
DynStructHelper | DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
DynUnionHelper | DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
DynValueHelper | DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
FieldNameHelper | org/omg/DynamicAny/FieldNameHelper.java。
NameDynAnyPair | org/omg/DynamicAny/NameDynAnyPair.java。
NameDynAnyPairHelper | org/omg/DynamicAny/NameDynAnyPairHelper.java。
NameDynAnyPairSeqHelper | org/omg/DynamicAny/NameDynAnyPairSeqHelper.java。
NameValuePair | org/omg/DynamicAny/NameValuePair.java。
NameValuePairHelper | org/omg/DynamicAny/NameValuePairHelper.java。
NameValuePairSeqHelper | org/omg/DynamicAny/NameValuePairSeqHelper.java。

软件包 org.omg.DynamicAny 的描述

提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

可以将 any 传递给不具有任何有关 any 类型的静态信息的程序（由 IDL 编译器生成的该类型代码没有经过对象实现的编译）。结果，接收 any 的对象不具有使用它的可移植方法。

DynAny 允许在运行时遍历与 any 有关联的数据值，并提取数据值的基本成分。它在编写功能强大的常规服务器程序（支持过滤的桥梁、事件通道）时非常有用。类似地，此设施允许在运行时构造 any，无需具备其类型的静态知识。它在编写常规客户端程序（桥梁、浏览器、用户界面工具）时非常有用。

Any 值可以通过 DynAny 对象进行动态解释（遍历）和构造。DynAny 对象与对应于插入 Any 的值的副本的数据值相关联。DynAny 对象可视为 DynAny 组件的有序集合。对于表示基本类型（如 long）或不具有组件的类型（如空异常）的 DynAny，组件的有序集合为空。

每个 DynAny 对象在其 DynAny 组件集合中都有一个当前位置。当前位置由 0 到 n-1（其中 n 为组件数）的索引值标识。特殊索引值 -1 指示不指向任何位置的当前位置。对于不能有当前位置的值（如空异常），索引值始终为 -1。如果使用具有组件的值初始化 DynAny，则索引被初始化为 0。在创建未初始化的 DynAny（即不具有值但具有允许组件的 TypeCode 的 DynAny）之后，当前位置取决于由 DynAny 表示的值的类型。（将当前位置设置为 0 还是 -1 取决于新 DynAny 是否获取了其组件的默认值。）

迭代操作 rewind、seek 和 next 可用于更改当前位置，current_component 操作返回当前位置的组件。component_count 操作返回 DynAny 的组件数。总体上说，这些操作都能在 DynAny 的组件上进行迭代，从而能够（例如）检查其内容（递归式）。

已构造的 DynAny 对象是与构造类型关联的 DynAny 对象。还有一种从 DynAny 接口继承而来的接口，它与 IDL 中的每种构造类型（fixed、enum、struct、sequence、union、array、exception 和 value 类型）相关联。已构造的 DynAny 对象导出支持创建新 DynAny 对象的操作，每个对象都与已构造数据值的组件相关联。例如，DynStruct 与 struct 值相关联。这意味着 DynStruct 可视为拥有一个有序的组件集合，每个结构成员一个。DynStruct 对象导出支持创建新 DynAny 对象的操作，其中每个对象都与 struct 的成员有关联。

如果 DynAny 对象是从另一个（已构造）DynAny 对象获取的（如表示从 DynStruct 创建的结构成员的 DynAny），则成员 DynAny 在逻辑上包含在 DynStruct 中。调用 insert 或 get 操作不更改当前位置。销毁顶级 DynAny 对象（不是作为另一个 DynAny 的组件获取的）将同时销毁从其获取的所有 DynAny 对象组件。销毁非顶级 DynAny 对象的操作没有任何效果。在已销毁的顶级 DynAny 或其任何子代上调用操作将引发 OBJECT_NOT_EXIST。如果程序员要销毁 DynAny 对象，但还需要操作与其关联的数据值的某个组件，则应该首先为该组件创建一个 DynAny，然后生成所创建的 DynAny 对象的副本。

为了支持高效实现，根据分配的内存空间和存取速度定义 DynAny 对象的行为。DynAny 对象旨在用于遍历从 any 提取的值，或用于在运行时构造 any 的值。不建议将其用于其他目的。

处理 DynAny 对象

Insert 和 get 操作是处理基本 DynAny 对象所必需的，但是也可以使用它们来处理已构造的 DynAny 对象。将基本数据类型值插入已构造的 DynAny 对象意味着初始化与 DynAny 对象关联的已构造数据值的当前组件。例如，对 DynStruct 调用 insert_boolean 意味着在关联的 struct 数据值的当前位置插入 boolean 数据值。如果某个类型的 TypeCode 等效于 DynAny 中包含的 TypeCode，或者等效于处于当前位置的 DynAny 的 TypeCode（如果 DynAny 有组件），则该类型与插入值或提取值一致。

基本操作包括：

  • insert_boolean, get_boolean
  • insert_char, get_char
  • insert_short, get_short
  • insert_ushort, get_ushort
  • insert_long, get_long
  • insert_ulong, get_ulong
  • insert_double, get_double
  • insert_string, get_string
  • insert_reference, get_reference
  • insert_typecode, get_typecode
  • insert_longlong, get_longlong
  • insert_ulonglong, get_ulonglong
  • insert_longdouble, get_longdouble
  • insert_wchar, get_wchar
  • insert_wstring, get_wstring
  • insert_any, get_any
  • insert_dyn_any, get_dyn_any
  • insert_val, get_val
  • insert_octet, get_octet
  • insert_float, get_float
  • get_value
  • get_as_string
  • get_as_ulong
  • get_members
  • get_members_as_dyn_any
  • get_discriminator
  • get_length
  • get_elements
  • get_elements_as_dyn_any
  • get_boxed_value
  • get_boxed_value_as_dyn_any

DynAny 和 DynAnyFactory 对象对于创建和使用它们的进程而言是本地的。这意味着，不能将对 DynAny 和 DynAnyFactory 对象的引用导出到其他进程，也不能通过 ORB.object_to_string() 使其具体化。如果进行这样的尝试，则该违反规则的操作将引发 MARSHAL 系统异常。由于它们的接口是在 IDL 中指定的，所以 DynAny 对象导出在标准 org.omg.CORBA.Object 接口中定义的操作。但是，任何尝试调用通过 Object 接口导出的操作都会引发标准 NO_IMPLEMENT 异常。尝试使用带有 DII 的 DynAny 对象将引发 NO_IMPLEMENT 异常。

包规范

有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.DynamicAny 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.DynamicAny 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.DynamicAny.AnySeqHelper
    • org.omg.DynamicAny.DynAnyFactoryHelper
    • org.omg.DynamicAny.DynAnyHelper
    • org.omg.DynamicAny.DynAnySeqHelper
    • org.omg.DynamicAny.DynArrayHelper
    • org.omg.DynamicAny.DynEnumHelper
    • org.omg.DynamicAny.DynFixedHelper
    • org.omg.DynamicAny.DynSequenceHelper
    • org.omg.DynamicAny.DynStructHelper
    • org.omg.DynamicAny.DynUnionHelper
    • org.omg.DynamicAny.DynValueHelper
    • org.omg.DynamicAny.FieldNameHelper
    • org.omg.DynamicAny.NameDynAnyPair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameDynAnyPairHelper
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper
    • org.omg.DynamicAny.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairSeqHelper
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.DynamicAny._DynAnyFactoryStub (implements org.omg.DynamicAny.DynAnyFactory)
      • org.omg.DynamicAny._DynAnyStub (implements org.omg.DynamicAny.DynAny)
      • org.omg.DynamicAny._DynArrayStub (implements org.omg.DynamicAny.DynArray)
      • org.omg.DynamicAny._DynEnumStub (implements org.omg.DynamicAny.DynEnum)
      • org.omg.DynamicAny._DynFixedStub (implements org.omg.DynamicAny.DynFixed)
      • org.omg.DynamicAny._DynSequenceStub (implements org.omg.DynamicAny.DynSequence)
      • org.omg.DynamicAny._DynStructStub (implements org.omg.DynamicAny.DynStruct)
      • org.omg.DynamicAny._DynUnionStub (implements org.omg.DynamicAny.DynUnion)
      • org.omg.DynamicAny._DynValueStub (implements org.omg.DynamicAny.DynValue)

接口分层结构

  • org.omg.DynamicAny.DynAnyFactoryOperations
    • org.omg.DynamicAny.DynAnyFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.DynamicAny.DynAnyOperations
    • org.omg.DynamicAny.DynAny (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArrayOperations
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnumOperations
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixedOperations
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequenceOperations
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStructOperations
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnionOperations
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommonOperations
      • org.omg.DynamicAny.DynValueBoxOperations
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueOperations
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
  • org.omg.CORBA.Object
    • org.omg.DynamicAny.DynAny (并 extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (并 extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.DynamicAny.DynAny (并 extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.Object)
        • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynAnyFactory (并 extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations)
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations)
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations)
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations)
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations)
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations)
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.DynamicAny 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.DynamicAny
的使用

使用 org.omg.DynamicAny 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 使用的 org.omg.DynamicAny 中的类
DynAny
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnyFactory
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyFactoryOperations
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyOperations
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynArray
DynArray 对象支持对 IDL 数组的操作。
DynArrayOperations
DynArray 对象支持对 IDL 数组的操作。
DynEnum
DynEnum 对象支持对 IDL 枚举值的操作。
DynEnumOperations
DynEnum 对象支持对 IDL enumerated value 的操作。
DynFixed
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
DynFixedOperations
DynFixed 对象支持对 IDL 定值的操作。
DynSequence
DynSequence 对象支持对 IDL 序列的操作。
DynSequenceOperations
DynSequence 对象支持对 IDL 序列的操作。
DynStruct
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
DynStructOperations
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常 (exception) 值的操作。
DynUnion
DynUnion 对象支持对 IDL 联合 (union) 的操作。
DynUnionOperations
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
DynValue
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
DynValueBoxOperations
DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
DynValueCommon
DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
DynValueCommonOperations
DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
DynValueOperations
DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。
NameDynAnyPair
org/omg/DynamicAny/NameDynAnyPair.java。
NameValuePair
org/omg/DynamicAny/NameValuePair.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


InvalidValue (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny.DynAnyPackage
类 InvalidValue

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.DynamicAny.DynAnyPackage.InvalidValue
所有已实现的接口：
Serializable, IDLEntity
public final class InvalidValue
extends UserException

org/omg/DynamicAny/DynAnyPackage/InvalidValue.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:12 (GMT-08:00)。

构造方法摘要
InvalidValue()
InvalidValue(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidValue

public InvalidValue()

InvalidValue

public InvalidValue(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InvalidValueHelper (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny.DynAnyPackage
类 InvalidValueHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper

public abstract class InvalidValueHelper
extends Object

org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:12 (GMT-08:00)。

构造方法摘要
InvalidValueHelper()
方法摘要
static InvalidValue | extract(Any a)
static String | id()
static void | insert(Any a, InvalidValue that)
static InvalidValue | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InvalidValue value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InvalidValueHelper

public InvalidValueHelper()
方法详细信息

insert

public static void insert(Any a,
                          InvalidValue that)

extract

public static InvalidValue extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InvalidValue read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InvalidValue value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeMismatch (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny.DynAnyPackage
类 TypeMismatch

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.DynamicAny.DynAnyPackage.TypeMismatch
所有已实现的接口：
Serializable, IDLEntity
public final class TypeMismatch
extends UserException

org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:12 (GMT-08:00)。

构造方法摘要
TypeMismatch()
TypeMismatch(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TypeMismatch

public TypeMismatch()

TypeMismatch

public TypeMismatch(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeMismatchHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny.DynAnyPackage
类 TypeMismatchHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper

public abstract class TypeMismatchHelper
extends Object

org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:12 (GMT-08:00)。

构造方法摘要
TypeMismatchHelper()
方法摘要
static TypeMismatch | extract(Any a)
static String | id()
static void | insert(Any a, TypeMismatch that)
static TypeMismatch | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, TypeMismatch value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TypeMismatchHelper

public TypeMismatchHelper()
方法详细信息

insert

public static void insert(Any a,
                          TypeMismatch that)

extract

public static TypeMismatch extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static TypeMismatch read(InputStream istream)

write

public static void write(OutputStream ostream,
                         TypeMismatch value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.DynamicAny.DynAnyPackage (Java Platform SE 6)

 org.omg.DynamicAny.DynAnyPackage
类
InvalidValueHelper
TypeMismatchHelper
异常
InvalidValue
TypeMismatch


org.omg.DynamicAny.DynAnyPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.DynamicAny.DynAnyPackage

此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

请参见：
描述

类摘要
InvalidValueHelper | org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java。
TypeMismatchHelper | org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java。

异常摘要
InvalidValue | org/omg/DynamicAny/DynAnyPackage/InvalidValue.java。
TypeMismatch | org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java。

软件包 org.omg.DynamicAny.DynAnyPackage 的描述

此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。有关更多细节，请参阅该 OMG 规范。

包规范

有关 Java[tm] Platform, Standard Edition 6 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.DynamicAny.DynAnyPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.DynamicAny.DynAnyPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynAnyPackage.InvalidValue
          • org.omg.DynamicAny.DynAnyPackage.TypeMismatch
    • org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.DynamicAny.DynAnyPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.DynamicAny.DynAnyPackage
的使用

使用 org.omg.DynamicAny.DynAnyPackage 的软件包
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.DynamicAny 使用的 org.omg.DynamicAny.DynAnyPackage 中的类
InvalidValue
org/omg/DynamicAny/DynAnyPackage/InvalidValue.java。
TypeMismatch
org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java。

org.omg.DynamicAny.DynAnyPackage 使用的 org.omg.DynamicAny.DynAnyPackage 中的类
InvalidValue
org/omg/DynamicAny/DynAnyPackage/InvalidValue.java。
TypeMismatch
org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyPackage.InvalidValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyPackage.InvalidValue
的使用

使用 InvalidValue 的软件包
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.DynamicAny 中 InvalidValue 的使用

抛出 InvalidValue 的 org.omg.DynamicAny 中的方法
TCKind | DynStructOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | DynValueOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynStructStub.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynValueStub.current_member_kind() 返回与当前位置的成员有关联的 TCKind。
String | DynStructOperations.current_member_name() 返回当前位置的成员的名称。
String | DynValueOperations.current_member_name() 返回当前位置上的成员的名称。
String | _DynStructStub.current_member_name() 返回当前位置上的成员的名称。
String | _DynValueStub.current_member_name() 返回当前位置上成员的名称。
void | DynAnyOperations.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynUnionStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
Any | DynAnyOperations.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynAnyStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynArrayStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynEnumStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynFixedStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
Any | _DynSequenceStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynStructStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynUnionStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynValueStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
boolean | DynAnyOperations.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynAnyStub.get_boolean() 从此 DynAny 析取 boolean 值。
boolean | _DynArrayStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynEnumStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynFixedStub.get_boolean() 从此 DynAny 提取 boolean 值。
boolean | _DynSequenceStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynStructStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynUnionStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynValueStub.get_boolean() 从此 DynAny 中提取 boolean 值。
DynAny | DynValueBoxOperations.get_boxed_value_as_dyn_any() 以 DynAny 的形式返回已装箱值。
Any | DynValueBoxOperations.get_boxed_value() 以 Any 的形式返回装箱值。
char | DynAnyOperations.get_char() 从此 DynAny 中提取 char 值。
char | _DynAnyStub.get_char() 从此 DynAny 析取 char 值。
char | _DynArrayStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynEnumStub.get_char() 从此 DynAny 析取 char 值。
char | _DynFixedStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynSequenceStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynStructStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynUnionStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynValueStub.get_char() 从此 DynAny 中提取 char 值。
double | DynAnyOperations.get_double() 从此 DynAny 中提取 double 值。
double | _DynAnyStub.get_double() 从此 DynAny 析取 double 值。
double | _DynArrayStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynEnumStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynFixedStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynSequenceStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynStructStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynUnionStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynValueStub.get_double() 从此 DynAny 中提取 double 值。
DynAny | DynAnyOperations.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynAnyStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynArrayStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynEnumStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynFixedStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynSequenceStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynStructStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynUnionStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynValueStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
float | DynAnyOperations.get_float() 从此 DynAny 中提取 float 值。
float | _DynAnyStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynArrayStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynEnumStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynFixedStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynSequenceStub.get_float() 从此 DynAny 提取 float 值。
float | _DynStructStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynUnionStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynValueStub.get_float() 从此 DynAny 中提取 float 值。
int | DynAnyOperations.get_long() 从此 DynAny 中提取 integer 值。
int | _DynAnyStub.get_long() 从此 DynAny 析取 integer 值。
int | _DynArrayStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynEnumStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynFixedStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynSequenceStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynStructStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynUnionStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynValueStub.get_long() 从此 DynAny 中提取 integer 值。
long | DynAnyOperations.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynAnyStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynArrayStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynEnumStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynFixedStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynSequenceStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynStructStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynUnionStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynValueStub.get_longlong() 从此 DynAny 中提取 long 值。
NameDynAnyPair[] | DynValueOperations.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
NameDynAnyPair[] | _DynValueStub.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
NameValuePair[] | DynValueOperations.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
NameValuePair[] | _DynValueStub.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
byte | DynAnyOperations.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynAnyStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynArrayStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynEnumStub.get_octet() 从此 DynAny 析取 byte 值。
byte | _DynFixedStub.get_octet() 从此 DynAny 析取 byte 值。
byte | _DynSequenceStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynStructStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynUnionStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynValueStub.get_octet() 从此 DynAny 中提取 byte 值。
Object | DynAnyOperations.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynAnyStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynArrayStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynEnumStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynFixedStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynSequenceStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynStructStub.get_reference() 从此 DynAny 析取对 CORBA 对象的引用。
Object | _DynUnionStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynValueStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
short | DynAnyOperations.get_short() 从此 DynAny 中提取 short 值。
short | _DynAnyStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynArrayStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynEnumStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynFixedStub.get_short() 从此 DynAny 析取 short 值。
short | _DynSequenceStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynStructStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynUnionStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynValueStub.get_short() 从此 DynAny 中提取 short 值。
String | DynAnyOperations.get_string() 从此 DynAny 中提取 string 值。
String | _DynAnyStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynArrayStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynEnumStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynFixedStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynSequenceStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynStructStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynUnionStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynValueStub.get_string() 从此 DynAny 中提取 string 值。
TypeCode | DynAnyOperations.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynAnyStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynArrayStub.get_typecode() 从此 DynAny 析取 TypeCode 对象。
TypeCode | _DynEnumStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynFixedStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynSequenceStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynStructStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynUnionStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynValueStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
int | DynAnyOperations.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynAnyStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynArrayStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynEnumStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynFixedStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynSequenceStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynStructStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynUnionStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynValueStub.get_ulong() 从此 DynAny 中提取 integer 值。
long | DynAnyOperations.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynAnyStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynArrayStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynEnumStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynFixedStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynSequenceStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynStructStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynUnionStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynValueStub.get_ulonglong() 从此 DynAny 中提取 long 值。
short | DynAnyOperations.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynAnyStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynArrayStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynEnumStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynFixedStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynSequenceStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynStructStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynUnionStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynValueStub.get_ushort() 从此 DynAny 中提取 short 值。
Serializable | DynAnyOperations.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynAnyStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynArrayStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynEnumStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynFixedStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynSequenceStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynStructStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynUnionStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynValueStub.get_val() 从此 DynAny 中提取 Serializable 对象。
char | DynAnyOperations.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynAnyStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynArrayStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynEnumStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynFixedStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynSequenceStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynStructStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynUnionStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynValueStub.get_wchar() 从此 DynAny 中提取 long 值。
String | DynAnyOperations.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynAnyStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynArrayStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynEnumStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynFixedStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynSequenceStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynStructStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynUnionStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynValueStub.get_wstring() 从此 DynAny 中提取 string 值。
void | DynAnyOperations.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynFixedStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_any(Any value) 将 Any 值插入由此 DynAny 表示的 Any 中。
void | _DynStructStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | DynAnyOperations.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynAnyStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynArrayStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynEnumStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynFixedStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynSequenceStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynStructStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynUnionStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynValueStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | DynAnyOperations.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynAnyStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynArrayStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynEnumStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynFixedStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynSequenceStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynStructStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynUnionStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynValueStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | DynAnyOperations.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynAnyStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynArrayStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynEnumStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynFixedStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynSequenceStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynStructStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynUnionStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynValueStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | DynAnyOperations.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynFixedStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynStructStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | DynAnyOperations.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynAnyStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynArrayStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynEnumStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynFixedStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynSequenceStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynStructStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynUnionStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynValueStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | DynAnyOperations.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynAnyStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynArrayStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynEnumStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynFixedStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynSequenceStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynStructStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynUnionStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynValueStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | DynAnyOperations.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynAnyStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynArrayStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynEnumStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynFixedStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynSequenceStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynStructStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynUnionStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynValueStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | DynAnyOperations.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynAnyStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynArrayStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynEnumStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynFixedStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynSequenceStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynStructStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynUnionStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynValueStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | DynAnyOperations.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynAnyStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynArrayStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynEnumStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynFixedStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynSequenceStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynStructStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynUnionStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynValueStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | DynAnyOperations.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynAnyStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynArrayStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynEnumStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynFixedStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynSequenceStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynStructStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynUnionStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynValueStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | DynAnyOperations.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynAnyStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynArrayStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynEnumStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynFixedStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynSequenceStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynStructStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynUnionStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynValueStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | DynAnyOperations.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynAnyStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynArrayStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynEnumStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynFixedStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynSequenceStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynStructStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynUnionStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynValueStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | DynAnyOperations.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynAnyStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynArrayStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynEnumStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynFixedStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynSequenceStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynStructStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynUnionStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynValueStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | DynAnyOperations.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynAnyStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynArrayStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynEnumStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynFixedStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynSequenceStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynStructStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynUnionStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynValueStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | DynAnyOperations.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynAnyStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynArrayStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynEnumStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynFixedStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynSequenceStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynStructStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynUnionStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynValueStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | DynAnyOperations.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynAnyStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynArrayStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynEnumStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynFixedStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynSequenceStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynStructStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynUnionStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynValueStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | DynAnyOperations.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynAnyStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynArrayStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynEnumStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynFixedStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynSequenceStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynStructStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynUnionStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynValueStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | DynAnyOperations.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynAnyStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynArrayStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynEnumStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynFixedStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynSequenceStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynStructStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynUnionStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynValueStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
TCKind | DynUnionOperations.member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。
TCKind | _DynUnionStub.member_kind() 返回当前活动成员 TypeCode 的 TCKind 值。
String | DynUnionOperations.member_name() 返回当前活动成员的名称。
String | _DynUnionStub.member_name() 返回当前活动成员的名称。
DynAny | DynUnionOperations.member() 返回当前活动成员。
DynAny | _DynUnionStub.member() 返回当前活动成员。
void | DynEnumOperations.set_as_string(String value) 将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
void | _DynEnumStub.set_as_string(String value) 将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
void | DynEnumOperations.set_as_ulong(int value) 将 DynEnum 的值设置为枚举值的序号。
void | _DynEnumStub.set_as_ulong(int value) 将 DynEnum 的值设置为枚举值的序号。
void | DynArrayOperations.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | _DynArrayStub.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | DynArrayOperations.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements(Any[] value) 设置序列的元素。
void | _DynArrayStub.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements(Any[] value) 设置序列的元素。
void | DynSequenceOperations.set_length(int len) 设置序列的长度。
void | _DynSequenceStub.set_length(int len) 设置序列的长度。
void | DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | DynStructOperations.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
void | _DynStructStub.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
boolean | DynFixedOperations.set_value(String val) 设置 DynFixed 的值。
boolean | _DynFixedStub.set_value(String val) 设置 DynFixed 的值。

org.omg.DynamicAny.DynAnyPackage 中 InvalidValue 的使用

返回 InvalidValue 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static InvalidValue | InvalidValueHelper.extract(Any a)
static InvalidValue | InvalidValueHelper.read(InputStream istream)

参数类型为 InvalidValue 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static void | InvalidValueHelper.insert(Any a, InvalidValue that)
static void | InvalidValueHelper.write(OutputStream ostream, InvalidValue value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
的使用

没有 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyPackage.TypeMismatch 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyPackage.TypeMismatch
的使用

使用 TypeMismatch 的软件包
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.DynamicAny 中 TypeMismatch 的使用

抛出 TypeMismatch 的 org.omg.DynamicAny 中的方法
void | DynAnyOperations.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynUnionStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
DynAny | DynAnyOperations.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynAnyStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynArrayStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynEnumStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynFixedStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynSequenceStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynStructStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynUnionStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynValueStub.current_component() 返回当前位置上的组件的 DynAny。
TCKind | DynStructOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | DynValueOperations.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynStructStub.current_member_kind() 返回与当前位置的成员关联的 TCKind。
TCKind | _DynValueStub.current_member_kind() 返回与当前位置的成员有关联的 TCKind。
String | DynStructOperations.current_member_name() 返回当前位置的成员的名称。
String | DynValueOperations.current_member_name() 返回当前位置上的成员的名称。
String | _DynStructStub.current_member_name() 返回当前位置上的成员的名称。
String | _DynValueStub.current_member_name() 返回当前位置上成员的名称。
void | DynAnyOperations.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynUnionStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.from_any(Any value) 使用 any 中包含的值初始化与 DynAny 对象有关联的值。
Any | DynAnyOperations.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynAnyStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynArrayStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynEnumStub.get_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynFixedStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
Any | _DynSequenceStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynStructStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynUnionStub.get_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值。
Any | _DynValueStub.get_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值。
boolean | DynAnyOperations.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynAnyStub.get_boolean() 从此 DynAny 析取 boolean 值。
boolean | _DynArrayStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynEnumStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynFixedStub.get_boolean() 从此 DynAny 提取 boolean 值。
boolean | _DynSequenceStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynStructStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynUnionStub.get_boolean() 从此 DynAny 中提取 boolean 值。
boolean | _DynValueStub.get_boolean() 从此 DynAny 中提取 boolean 值。
char | DynAnyOperations.get_char() 从此 DynAny 中提取 char 值。
char | _DynAnyStub.get_char() 从此 DynAny 析取 char 值。
char | _DynArrayStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynEnumStub.get_char() 从此 DynAny 析取 char 值。
char | _DynFixedStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynSequenceStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynStructStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynUnionStub.get_char() 从此 DynAny 中提取 char 值。
char | _DynValueStub.get_char() 从此 DynAny 中提取 char 值。
double | DynAnyOperations.get_double() 从此 DynAny 中提取 double 值。
double | _DynAnyStub.get_double() 从此 DynAny 析取 double 值。
double | _DynArrayStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynEnumStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynFixedStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynSequenceStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynStructStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynUnionStub.get_double() 从此 DynAny 中提取 double 值。
double | _DynValueStub.get_double() 从此 DynAny 中提取 double 值。
DynAny | DynAnyOperations.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynAnyStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynArrayStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynEnumStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynFixedStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynSequenceStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynStructStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynUnionStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynValueStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
float | DynAnyOperations.get_float() 从此 DynAny 中提取 float 值。
float | _DynAnyStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynArrayStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynEnumStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynFixedStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynSequenceStub.get_float() 从此 DynAny 提取 float 值。
float | _DynStructStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynUnionStub.get_float() 从此 DynAny 中提取 float 值。
float | _DynValueStub.get_float() 从此 DynAny 中提取 float 值。
int | DynAnyOperations.get_long() 从此 DynAny 中提取 integer 值。
int | _DynAnyStub.get_long() 从此 DynAny 析取 integer 值。
int | _DynArrayStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynEnumStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynFixedStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynSequenceStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynStructStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynUnionStub.get_long() 从此 DynAny 中提取 integer 值。
int | _DynValueStub.get_long() 从此 DynAny 中提取 integer 值。
long | DynAnyOperations.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynAnyStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynArrayStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynEnumStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynFixedStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynSequenceStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynStructStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynUnionStub.get_longlong() 从此 DynAny 中提取 long 值。
long | _DynValueStub.get_longlong() 从此 DynAny 中提取 long 值。
byte | DynAnyOperations.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynAnyStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynArrayStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynEnumStub.get_octet() 从此 DynAny 析取 byte 值。
byte | _DynFixedStub.get_octet() 从此 DynAny 析取 byte 值。
byte | _DynSequenceStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynStructStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynUnionStub.get_octet() 从此 DynAny 中提取 byte 值。
byte | _DynValueStub.get_octet() 从此 DynAny 中提取 byte 值。
Object | DynAnyOperations.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynAnyStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynArrayStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynEnumStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynFixedStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynSequenceStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynStructStub.get_reference() 从此 DynAny 析取对 CORBA 对象的引用。
Object | _DynUnionStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
Object | _DynValueStub.get_reference() 从此 DynAny 中提取对 CORBA 对象的引用。
short | DynAnyOperations.get_short() 从此 DynAny 中提取 short 值。
short | _DynAnyStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynArrayStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynEnumStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynFixedStub.get_short() 从此 DynAny 析取 short 值。
short | _DynSequenceStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynStructStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynUnionStub.get_short() 从此 DynAny 中提取 short 值。
short | _DynValueStub.get_short() 从此 DynAny 中提取 short 值。
String | DynAnyOperations.get_string() 从此 DynAny 中提取 string 值。
String | _DynAnyStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynArrayStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynEnumStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynFixedStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynSequenceStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynStructStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynUnionStub.get_string() 从此 DynAny 中提取 string 值。
String | _DynValueStub.get_string() 从此 DynAny 中提取 string 值。
TypeCode | DynAnyOperations.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynAnyStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynArrayStub.get_typecode() 从此 DynAny 析取 TypeCode 对象。
TypeCode | _DynEnumStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynFixedStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynSequenceStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynStructStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynUnionStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
TypeCode | _DynValueStub.get_typecode() 从此 DynAny 中提取 TypeCode 对象。
int | DynAnyOperations.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynAnyStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynArrayStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynEnumStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynFixedStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynSequenceStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynStructStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynUnionStub.get_ulong() 从此 DynAny 中提取 integer 值。
int | _DynValueStub.get_ulong() 从此 DynAny 中提取 integer 值。
long | DynAnyOperations.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynAnyStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynArrayStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynEnumStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynFixedStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynSequenceStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynStructStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynUnionStub.get_ulonglong() 从此 DynAny 中提取 long 值。
long | _DynValueStub.get_ulonglong() 从此 DynAny 中提取 long 值。
short | DynAnyOperations.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynAnyStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynArrayStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynEnumStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynFixedStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynSequenceStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynStructStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynUnionStub.get_ushort() 从此 DynAny 中提取 short 值。
short | _DynValueStub.get_ushort() 从此 DynAny 中提取 short 值。
Serializable | DynAnyOperations.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynAnyStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynArrayStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynEnumStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynFixedStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynSequenceStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynStructStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynUnionStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynValueStub.get_val() 从此 DynAny 中提取 Serializable 对象。
char | DynAnyOperations.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynAnyStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynArrayStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynEnumStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynFixedStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynSequenceStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynStructStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynUnionStub.get_wchar() 从此 DynAny 中提取 long 值。
char | _DynValueStub.get_wchar() 从此 DynAny 中提取 long 值。
String | DynAnyOperations.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynAnyStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynArrayStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynEnumStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynFixedStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynSequenceStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynStructStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynUnionStub.get_wstring() 从此 DynAny 中提取 string 值。
String | _DynValueStub.get_wstring() 从此 DynAny 中提取 string 值。
void | DynAnyOperations.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynFixedStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_any(Any value) 将 Any 值插入由此 DynAny 表示的 Any 中。
void | _DynStructStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_any(Any value) 将 Any 值插入此 DynAny 表示的 Any 中。
void | DynAnyOperations.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynAnyStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynArrayStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynEnumStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynFixedStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynSequenceStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynStructStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynUnionStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | _DynValueStub.insert_boolean(boolean value) 将 boolean 值插入 DynAny 中。
void | DynAnyOperations.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynAnyStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynArrayStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynEnumStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynFixedStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynSequenceStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynStructStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynUnionStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | _DynValueStub.insert_char(char value) 将 char 值插入 DynAny 中。
void | DynAnyOperations.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynAnyStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynArrayStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynEnumStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynFixedStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynSequenceStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynStructStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynUnionStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | _DynValueStub.insert_double(double value) 将 double 值插入 DynAny 中。
void | DynAnyOperations.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynFixedStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynStructStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | DynAnyOperations.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynAnyStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynArrayStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynEnumStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynFixedStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynSequenceStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynStructStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynUnionStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | _DynValueStub.insert_float(float value) 将 float 值插入 DynAny 中。
void | DynAnyOperations.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynAnyStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynArrayStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynEnumStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynFixedStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynSequenceStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynStructStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynUnionStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | _DynValueStub.insert_long(int value) 将 integer 值插入 DynAny 中。
void | DynAnyOperations.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynAnyStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynArrayStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynEnumStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynFixedStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynSequenceStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynStructStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynUnionStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | _DynValueStub.insert_longlong(long value) 将 long 值插入 DynAny 中。
void | DynAnyOperations.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynAnyStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynArrayStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynEnumStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynFixedStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynSequenceStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynStructStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynUnionStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | _DynValueStub.insert_octet(byte value) 将 byte 值插入 DynAny 中。
void | DynAnyOperations.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynAnyStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynArrayStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynEnumStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynFixedStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynSequenceStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynStructStub.insert_reference(Object value) 将对 CORBA 对象的引用插入 DynAny 中。
void | _DynUnionStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | _DynValueStub.insert_reference(Object value) 将对 CORBA 对象的引用插入到 DynAny 中。
void | DynAnyOperations.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynAnyStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynArrayStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynEnumStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynFixedStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynSequenceStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynStructStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynUnionStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | _DynValueStub.insert_short(short value) 将 short 值插入 DynAny 中。
void | DynAnyOperations.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynAnyStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynArrayStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynEnumStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynFixedStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynSequenceStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynStructStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynUnionStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | _DynValueStub.insert_string(String value) 将 string 值插入 DynAny 中。
void | DynAnyOperations.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynAnyStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynArrayStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynEnumStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynFixedStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynSequenceStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynStructStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynUnionStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | _DynValueStub.insert_typecode(TypeCode value) 将 TypeCode 对象插入 DynAny 中。
void | DynAnyOperations.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynAnyStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynArrayStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynEnumStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynFixedStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynSequenceStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynStructStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynUnionStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | _DynValueStub.insert_ulong(int value) 将 integer 值插入 DynAny 中。
void | DynAnyOperations.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynAnyStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynArrayStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynEnumStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynFixedStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynSequenceStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynStructStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynUnionStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | _DynValueStub.insert_ulonglong(long value) 将 long 值插入 DynAny 中。
void | DynAnyOperations.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynAnyStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynArrayStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynEnumStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynFixedStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynSequenceStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynStructStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynUnionStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | _DynValueStub.insert_ushort(short value) 将 short 值插入 DynAny 中。
void | DynAnyOperations.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynAnyStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynArrayStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynEnumStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynFixedStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynSequenceStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynStructStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynUnionStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynValueStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | DynAnyOperations.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynAnyStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynArrayStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynEnumStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynFixedStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynSequenceStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynStructStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynUnionStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | _DynValueStub.insert_wchar(char value) 将 char 值插入 DynAny 中。
void | DynAnyOperations.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynAnyStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynArrayStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynEnumStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynFixedStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynSequenceStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynStructStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynUnionStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | _DynValueStub.insert_wstring(String value) 将 string 值插入 DynAny 中。
void | DynValueBoxOperations.set_boxed_value_as_dyn_any(DynAny boxed) 使用参数中包含的值取代已装箱值。
void | DynValueBoxOperations.set_boxed_value(Any boxed) 使用指定值取代已装箱值。
void | DynUnionOperations.set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | _DynUnionStub.set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | DynArrayOperations.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | _DynArrayStub.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | DynArrayOperations.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements(Any[] value) 设置序列的元素。
void | _DynArrayStub.set_elements(Any[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements(Any[] value) 设置序列的元素。
void | DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | DynStructOperations.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
void | _DynStructStub.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
void | DynUnionOperations.set_to_default_member() 将鉴别符设置为联合数据的默认 case 的值。
void | _DynUnionStub.set_to_default_member() 将鉴别符设置为联合数据的默认 case 的值。
void | DynUnionOperations.set_to_no_active_member() 将鉴别符设置为与任何联合数据 case 标签都不相应的值。
void | _DynUnionStub.set_to_no_active_member() 将鉴别符设置为与任何联合数据 case 标签都不相应的值。
boolean | DynFixedOperations.set_value(String val) 设置 DynFixed 的值。
boolean | _DynFixedStub.set_value(String val) 设置 DynFixed 的值。

org.omg.DynamicAny.DynAnyPackage 中 TypeMismatch 的使用

返回 TypeMismatch 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static TypeMismatch | TypeMismatchHelper.extract(Any a)
static TypeMismatch | TypeMismatchHelper.read(InputStream istream)

参数类型为 TypeMismatch 的 org.omg.DynamicAny.DynAnyPackage 中的方法
static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
的使用

没有 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


InconsistentTypeCode (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny.DynAnyFactoryPackage
类 InconsistentTypeCode

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.omg.CORBA.UserException
                继承者  org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
所有已实现的接口：
Serializable, IDLEntity
public final class InconsistentTypeCode
extends UserException

org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，生成时间为 2006 年 6 月 30 日，星期五上午 12:40:13 (GMT-08:00)。

构造方法摘要
InconsistentTypeCode()
InconsistentTypeCode(String $reason)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InconsistentTypeCode

public InconsistentTypeCode()

InconsistentTypeCode

public InconsistentTypeCode(String $reason)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InconsistentTypeCodeHelper (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.omg.DynamicAny.DynAnyFactoryPackage
类 InconsistentTypeCodeHelper

java.lang.Object
    继承者  org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper

public abstract class InconsistentTypeCodeHelper
extends Object

org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java。由 "3.2" 版的 IDL-to-Java 编译器（可移植）从 ../../../../src/share/classes/org/omg/DynamicAny/DynamicAny.idl 生成，2006 年 6 月 30 日，星期五上午 12:40:13 (GMT-08:00)。

构造方法摘要
InconsistentTypeCodeHelper()
方法摘要
static InconsistentTypeCode | extract(Any a)
static String | id()
static void | insert(Any a, InconsistentTypeCode that)
static InconsistentTypeCode | read(InputStream istream)
static TypeCode | type()
static void | write(OutputStream ostream, InconsistentTypeCode value)
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InconsistentTypeCodeHelper

public InconsistentTypeCodeHelper()
方法详细信息

insert

public static void insert(Any a,
                          InconsistentTypeCode that)

extract

public static InconsistentTypeCode extract(Any a)

type

public static TypeCode type()

id

public static String id()

read

public static InconsistentTypeCode read(InputStream istream)

write

public static void write(OutputStream ostream,
                         InconsistentTypeCode value)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.omg.DynamicAny.DynAnyFactoryPackage (Java Platform SE 6)

 org.omg.DynamicAny.DynAnyFactoryPackage
类
InconsistentTypeCodeHelper
异常
InconsistentTypeCode


org.omg.DynamicAny.DynAnyFactoryPackage (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.omg.DynamicAny.DynAnyFactoryPackage

此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。

请参见：
描述

类摘要
InconsistentTypeCodeHelper org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java。

异常摘要
InconsistentTypeCode org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java。

软件包 org.omg.DynamicAny.DynAnyFactoryPackage 的描述

此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。有关更多细节，请参阅该 OMG 规范。

包规范

有关 Java 2 平台、标准版 v.1.4 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in J2SE 1.4。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.omg.DynamicAny.DynAnyFactoryPackage 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.DynamicAny.DynAnyFactoryPackage 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.omg.DynamicAny.DynAnyFactoryPackage 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.omg.DynamicAny.DynAnyFactoryPackage
的使用

使用 org.omg.DynamicAny.DynAnyFactoryPackage 的软件包
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。

org.omg.DynamicAny 使用的 org.omg.DynamicAny.DynAnyFactoryPackage 中的类
InconsistentTypeCode
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java。

org.omg.DynamicAny.DynAnyFactoryPackage 使用的 org.omg.DynamicAny.DynAnyFactoryPackage 中的类
InconsistentTypeCode
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
的使用

使用 InconsistentTypeCode 的软件包
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。

org.omg.DynamicAny 中 InconsistentTypeCode 的使用

抛出 InconsistentTypeCode 的 org.omg.DynamicAny 中的方法
DynAny | DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | DynAnyFactoryOperations.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
DynAny | _DynAnyFactoryStub.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。

org.omg.DynamicAny.DynAnyFactoryPackage 中 InconsistentTypeCode 的使用

返回 InconsistentTypeCode 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static InconsistentTypeCode | InconsistentTypeCodeHelper.extract(Any a)
static InconsistentTypeCode | InconsistentTypeCodeHelper.read(InputStream istream)

参数类型为 InconsistentTypeCode 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法
static void | InconsistentTypeCodeHelper.insert(Any a, InconsistentTypeCode that)
static void | InconsistentTypeCodeHelper.write(OutputStream ostream, InconsistentTypeCode value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
的使用

没有 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.AnySeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.AnySeqHelper
的使用

没有 org.omg.DynamicAny.AnySeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynAny 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynAny
的使用

使用 DynAny 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynAny 的使用

org.omg.DynamicAny 中 DynAny 的子接口
interface | DynArray DynArray 对象支持对 IDL 数组的操作。
interface | DynEnum DynEnum 对象支持对 IDL 枚举值的操作。
interface | DynFixed DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
interface | DynSequence DynSequence 对象支持对 IDL 序列的操作。
interface | DynStruct DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
interface | DynUnion DynUnion 对象支持对 IDL 联合 (union) 的操作。
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

实现 DynAny 的 org.omg.DynamicAny 中的类
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。

声明为 DynAny 的 org.omg.DynamicAny 中的字段
 DynAny NameDynAnyPair.value
与名称关联的 DynAny 值。

返回 DynAny 的 org.omg.DynamicAny 中的方法
DynAny | DynAnyOperations.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynAnyStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynArrayStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynEnumStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynFixedStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynSequenceStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynStructStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynUnionStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | _DynValueStub.copy() 创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
DynAny | DynAnyFactoryOperations.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | _DynAnyFactoryStub.create_dyn_any_from_type_code(TypeCode type) 根据 TypeCode 创建 DynAny。
DynAny | DynAnyFactoryOperations.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
DynAny | _DynAnyFactoryStub.create_dyn_any(Any value) 根据 any 值创建新 DynAny 对象。
DynAny | DynAnyOperations.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynAnyStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynArrayStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynEnumStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynFixedStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynSequenceStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynStructStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynUnionStub.current_component() 返回当前位置上的组件的 DynAny。
DynAny | _DynValueStub.current_component() 返回当前位置上的组件的 DynAny。
static DynAny | DynAnyHelper.extract(Any a)
static DynAny[] | DynAnySeqHelper.extract(Any a)
DynAny | DynValueBoxOperations.get_boxed_value_as_dyn_any() 以 DynAny 的形式返回已装箱值。
DynAny | DynUnionOperations.get_discriminator() 返回当前鉴别符值。
DynAny | _DynUnionStub.get_discriminator() 返回当前鉴别符值。
DynAny | DynAnyOperations.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynAnyStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynArrayStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynEnumStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynFixedStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynSequenceStub.get_dyn_any() 析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynStructStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynUnionStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny | _DynValueStub.get_dyn_any() 提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
DynAny[] | DynArrayOperations.get_elements_as_dyn_any() 以 DynAny 的形式返回 DynArray 的元素。
DynAny[] | DynSequenceOperations.get_elements_as_dyn_any() 返回表示序列元素的 DynAny。
DynAny[] | _DynArrayStub.get_elements_as_dyn_any() 以 DynAny 的形式返回 DynArray 的元素。
DynAny[] | _DynSequenceStub.get_elements_as_dyn_any() 返回表示序列的元素的 DynAny。
DynAny | DynUnionOperations.member() 返回当前活动成员。
DynAny | _DynUnionStub.member() 返回当前活动成员。
static DynAny | DynAnyHelper.narrow(Object obj)
static DynAny | DynAnyHelper.read(InputStream istream)
static DynAny[] | DynAnySeqHelper.read(InputStream istream)
static DynAny | DynAnyHelper.unchecked_narrow(Object obj)

参数类型为 DynAny 的 org.omg.DynamicAny 中的方法
void | DynAnyOperations.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
void | _DynAnyStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynArrayStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynEnumStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynFixedStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynSequenceStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynStructStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
void | _DynUnionStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
void | _DynValueStub.assign(DynAny dyn_any) 使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
boolean | DynAnyOperations.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynAnyStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynArrayStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynEnumStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynFixedStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynSequenceStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynStructStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynUnionStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
boolean | _DynValueStub.equal(DynAny dyn_any) 比较两个 DynAny 值是否相等。
void | DynAnyOperations.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynAnyStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynArrayStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynEnumStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynFixedStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynSequenceStub.insert_dyn_any(DynAny value) 将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
void | _DynStructStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynUnionStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
void | _DynValueStub.insert_dyn_any(DynAny value) 将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
static void | DynAnyHelper.insert(Any a, DynAny that)
static void | DynAnySeqHelper.insert(Any a, DynAny[] that)
void | DynValueBoxOperations.set_boxed_value_as_dyn_any(DynAny boxed) 使用参数中包含的值取代已装箱值。
void | DynUnionOperations.set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | _DynUnionStub.set_discriminator(DynAny d) 将 DynUnion 的鉴别符值设置为指定值。
void | DynArrayOperations.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | DynSequenceOperations.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
void | _DynArrayStub.set_elements_as_dyn_any(DynAny[] value) 设置 DynArray 以包含传递的元素。
void | _DynSequenceStub.set_elements_as_dyn_any(DynAny[] value) 使用 DynAny 设置序列的元素。
static void | DynAnyHelper.write(OutputStream ostream, DynAny value)
static void | DynAnySeqHelper.write(OutputStream ostream, DynAny[] value)

参数类型为 DynAny 的 org.omg.DynamicAny 中的构造方法
NameDynAnyPair(String _id, DynAny _value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynAnyFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynAnyFactory
的使用

使用 DynAnyFactory 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynAnyFactory 的使用

实现 DynAnyFactory 的 org.omg.DynamicAny 中的类
 class _DynAnyFactoryStub
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

返回 DynAnyFactory 的 org.omg.DynamicAny 中的方法
static DynAnyFactory | DynAnyFactoryHelper.extract(Any a)
static DynAnyFactory | DynAnyFactoryHelper.narrow(Object obj)
static DynAnyFactory | DynAnyFactoryHelper.read(InputStream istream)
static DynAnyFactory | DynAnyFactoryHelper.unchecked_narrow(Object obj)

参数类型为 DynAnyFactory 的 org.omg.DynamicAny 中的方法
static void | DynAnyFactoryHelper.insert(Any a, DynAnyFactory that)
static void | DynAnyFactoryHelper.write(OutputStream ostream, DynAnyFactory value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyFactoryHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyFactoryHelper
的使用

没有 org.omg.DynamicAny.DynAnyFactoryHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynAnyFactoryOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynAnyFactoryOperations
的使用

使用 DynAnyFactoryOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynAnyFactoryOperations 的使用

org.omg.DynamicAny 中 DynAnyFactoryOperations 的子接口
 interface DynAnyFactory
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

实现 DynAnyFactoryOperations 的 org.omg.DynamicAny 中的类
 class _DynAnyFactoryStub
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnyHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnyHelper
的使用

没有 org.omg.DynamicAny.DynAnyHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynAnyOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynAnyOperations
的使用

使用 DynAnyOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynAnyOperations 的使用

org.omg.DynamicAny 中 DynAnyOperations 的子接口
interface | DynAny 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
interface | DynArray DynArray 对象支持对 IDL 数组的操作。
interface | DynArrayOperations DynArray 对象支持对 IDL 数组的操作。
interface | DynEnum DynEnum 对象支持对 IDL 枚举值的操作。
interface | DynEnumOperations DynEnum 对象支持对 IDL enumerated value 的操作。
interface | DynFixed DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
interface | DynFixedOperations DynFixed 对象支持对 IDL 定值的操作。
interface | DynSequence DynSequence 对象支持对 IDL 序列的操作。
interface | DynSequenceOperations DynSequence 对象支持对 IDL 序列的操作。
interface | DynStruct DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
interface | DynStructOperations DynStruct 对象支持对 IDL 结构数据 (struct) 和异常 (exception) 值的操作。
interface | DynUnion DynUnion 对象支持对 IDL 联合 (union) 的操作。
interface | DynUnionOperations DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueBoxOperations DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
interface | DynValueCommonOperations DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
interface | DynValueOperations DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。

实现 DynAnyOperations 的 org.omg.DynamicAny 中的类
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynAnySeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynAnySeqHelper
的使用

没有 org.omg.DynamicAny.DynAnySeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynArray 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynArray
的使用

使用 DynArray 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynArray 的使用

实现 DynArray 的 org.omg.DynamicAny 中的类
 class _DynArrayStub
DynArray 对象支持对 IDL 数组 (array) 的操作。

返回 DynArray 的 org.omg.DynamicAny 中的方法
static DynArray | DynArrayHelper.extract(Any a)
static DynArray | DynArrayHelper.narrow(Object obj)
static DynArray | DynArrayHelper.read(InputStream istream)
static DynArray | DynArrayHelper.unchecked_narrow(Object obj)

参数类型为 DynArray 的 org.omg.DynamicAny 中的方法
static void | DynArrayHelper.insert(Any a, DynArray that)
static void | DynArrayHelper.write(OutputStream ostream, DynArray value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynArrayHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynArrayHelper
的使用

没有 org.omg.DynamicAny.DynArrayHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynArrayOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynArrayOperations
的使用

使用 DynArrayOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynArrayOperations 的使用

org.omg.DynamicAny 中 DynArrayOperations 的子接口
 interface DynArray
DynArray 对象支持对 IDL 数组的操作。

实现 DynArrayOperations 的 org.omg.DynamicAny 中的类
 class _DynArrayStub
DynArray 对象支持对 IDL 数组 (array) 的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynEnum 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynEnum
的使用

使用 DynEnum 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynEnum 的使用

实现 DynEnum 的 org.omg.DynamicAny 中的类
 class _DynEnumStub
DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。

返回 DynEnum 的 org.omg.DynamicAny 中的方法
static DynEnum | DynEnumHelper.extract(Any a)
static DynEnum | DynEnumHelper.narrow(Object obj)
static DynEnum | DynEnumHelper.read(InputStream istream)
static DynEnum | DynEnumHelper.unchecked_narrow(Object obj)

参数类型为 DynEnum 的 org.omg.DynamicAny 中的方法
static void | DynEnumHelper.insert(Any a, DynEnum that)
static void | DynEnumHelper.write(OutputStream ostream, DynEnum value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynEnumHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynEnumHelper
的使用

没有 org.omg.DynamicAny.DynEnumHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynEnumOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynEnumOperations
的使用

使用 DynEnumOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynEnumOperations 的使用

org.omg.DynamicAny 中 DynEnumOperations 的子接口
 interface DynEnum
DynEnum 对象支持对 IDL 枚举值的操作。

实现 DynEnumOperations 的 org.omg.DynamicAny 中的类
 class _DynEnumStub
DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynFixed 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynFixed
的使用

使用 DynFixed 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynFixed 的使用

实现 DynFixed 的 org.omg.DynamicAny 中的类
 class _DynFixedStub
DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。

返回 DynFixed 的 org.omg.DynamicAny 中的方法
static DynFixed | DynFixedHelper.extract(Any a)
static DynFixed | DynFixedHelper.narrow(Object obj)
static DynFixed | DynFixedHelper.read(InputStream istream)
static DynFixed | DynFixedHelper.unchecked_narrow(Object obj)

参数类型为 DynFixed 的 org.omg.DynamicAny 中的方法
static void | DynFixedHelper.insert(Any a, DynFixed that)
static void | DynFixedHelper.write(OutputStream ostream, DynFixed value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynFixedHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynFixedHelper
的使用

没有 org.omg.DynamicAny.DynFixedHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynStruct 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynStruct
的使用

使用 DynStruct 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynStruct 的使用

实现 DynStruct 的 org.omg.DynamicAny 中的类
 class _DynStructStub
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

返回 DynStruct 的 org.omg.DynamicAny 中的方法
static DynStruct | DynStructHelper.extract(Any a)
static DynStruct | DynStructHelper.narrow(Object obj)
static DynStruct | DynStructHelper.read(InputStream istream)
static DynStruct | DynStructHelper.unchecked_narrow(Object obj)

参数类型为 DynStruct 的 org.omg.DynamicAny 中的方法
static void | DynStructHelper.insert(Any a, DynStruct that)
static void | DynStructHelper.write(OutputStream ostream, DynStruct value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynFixedOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynFixedOperations
的使用

使用 DynFixedOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynFixedOperations 的使用

org.omg.DynamicAny 中 DynFixedOperations 的子接口
 interface DynFixed
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。

实现 DynFixedOperations 的 org.omg.DynamicAny 中的类
 class _DynFixedStub
DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynSequence 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynSequence
的使用

使用 DynSequence 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynSequence 的使用

实现 DynSequence 的 org.omg.DynamicAny 中的类
 class _DynSequenceStub
DynSequence 对象支持对 IDL 序列 (sequence) 的操作。

返回 DynSequence 的 org.omg.DynamicAny 中的方法
static DynSequence | DynSequenceHelper.extract(Any a)
static DynSequence | DynSequenceHelper.narrow(Object obj)
static DynSequence | DynSequenceHelper.read(InputStream istream)
static DynSequence | DynSequenceHelper.unchecked_narrow(Object obj)

参数类型为 DynSequence 的 org.omg.DynamicAny 中的方法
static void | DynSequenceHelper.insert(Any a, DynSequence that)
static void | DynSequenceHelper.write(OutputStream ostream, DynSequence value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynSequenceHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynSequenceHelper
的使用

没有 org.omg.DynamicAny.DynSequenceHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynSequenceOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynSequenceOperations
的使用

使用 DynSequenceOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynSequenceOperations 的使用

org.omg.DynamicAny 中 DynSequenceOperations 的子接口
 interface DynSequence
DynSequence 对象支持对 IDL 序列的操作。

实现 DynSequenceOperations 的 org.omg.DynamicAny 中的类
 class _DynSequenceStub
DynSequence 对象支持对 IDL 序列 (sequence) 的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynStructHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynStructHelper
的使用

没有 org.omg.DynamicAny.DynStructHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynStructOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynStructOperations
的使用

使用 DynStructOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynStructOperations 的使用

org.omg.DynamicAny 中 DynStructOperations 的子接口
 interface DynStruct
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

实现 DynStructOperations 的 org.omg.DynamicAny 中的类
 class _DynStructStub
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynUnion 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynUnion
的使用

使用 DynUnion 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynUnion 的使用

实现 DynUnion 的 org.omg.DynamicAny 中的类
 class _DynUnionStub
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。

返回 DynUnion 的 org.omg.DynamicAny 中的方法
static DynUnion | DynUnionHelper.extract(Any a)
static DynUnion | DynUnionHelper.narrow(Object obj)
static DynUnion | DynUnionHelper.read(InputStream istream)
static DynUnion | DynUnionHelper.unchecked_narrow(Object obj)

参数类型为 DynUnion 的 org.omg.DynamicAny 中的方法
static void | DynUnionHelper.insert(Any a, DynUnion that)
static void | DynUnionHelper.write(OutputStream ostream, DynUnion value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynUnionHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynUnionHelper
的使用

没有 org.omg.DynamicAny.DynUnionHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynUnionOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynUnionOperations
的使用

使用 DynUnionOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynUnionOperations 的使用

org.omg.DynamicAny 中 DynUnionOperations 的子接口
 interface DynUnion
DynUnion 对象支持对 IDL 联合 (union) 的操作。

实现 DynUnionOperations 的 org.omg.DynamicAny 中的类
 class _DynUnionStub
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValue 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValue
的使用

使用 DynValue 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValue 的使用

实现 DynValue 的 org.omg.DynamicAny 中的类
 class _DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

返回 DynValue 的 org.omg.DynamicAny 中的方法
static DynValue | DynValueHelper.extract(Any a)
static DynValue | DynValueHelper.narrow(Object obj)
static DynValue | DynValueHelper.read(InputStream istream)
static DynValue | DynValueHelper.unchecked_narrow(Object obj)

参数类型为 DynValue 的 org.omg.DynamicAny 中的方法
static void | DynValueHelper.insert(Any a, DynValue that)
static void | DynValueHelper.write(OutputStream ostream, DynValue value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueBox 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueBox
的使用

没有 org.omg.DynamicAny.DynValueBox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueBoxOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueBoxOperations
的使用

使用 DynValueBoxOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValueBoxOperations 的使用

org.omg.DynamicAny 中 DynValueBoxOperations 的子接口
 interface DynValueBox
DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueCommon 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueCommon
的使用

使用 DynValueCommon 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValueCommon 的使用

org.omg.DynamicAny 中 DynValueCommon 的子接口
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。

实现 DynValueCommon 的 org.omg.DynamicAny 中的类
 class _DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueCommonOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueCommonOperations
的使用

使用 DynValueCommonOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValueCommonOperations 的使用

org.omg.DynamicAny 中 DynValueCommonOperations 的子接口
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueBoxOperations DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
interface | DynValueOperations DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。

实现 DynValueCommonOperations 的 org.omg.DynamicAny 中的类
 class _DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.DynValueHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.DynValueHelper
的使用

没有 org.omg.DynamicAny.DynValueHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.omg.DynamicAny.DynValueOperations 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.omg.DynamicAny.DynValueOperations
的使用

使用 DynValueOperations 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 DynValueOperations 的使用

org.omg.DynamicAny 中 DynValueOperations 的子接口
 interface DynValue
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。

实现 DynValueOperations 的 org.omg.DynamicAny 中的类
 class _DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.FieldNameHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.FieldNameHelper
的使用

没有 org.omg.DynamicAny.FieldNameHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameDynAnyPair 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameDynAnyPair
的使用

使用 NameDynAnyPair 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 NameDynAnyPair 的使用

返回 NameDynAnyPair 的 org.omg.DynamicAny 中的方法
static NameDynAnyPair | NameDynAnyPairHelper.extract(Any a)
static NameDynAnyPair[] | NameDynAnyPairSeqHelper.extract(Any a)
NameDynAnyPair[] | DynStructOperations.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameDynAnyPair[] | DynValueOperations.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
NameDynAnyPair[] | _DynStructStub.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameDynAnyPair[] | _DynValueStub.get_members_as_dyn_any() 返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
static NameDynAnyPair | NameDynAnyPairHelper.read(InputStream istream)
static NameDynAnyPair[] | NameDynAnyPairSeqHelper.read(InputStream istream)

参数类型为 NameDynAnyPair 的 org.omg.DynamicAny 中的方法
static void | NameDynAnyPairHelper.insert(Any a, NameDynAnyPair that)
static void | NameDynAnyPairSeqHelper.insert(Any a, NameDynAnyPair[] that)
void | DynStructOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
void | _DynStructStub.set_members_as_dyn_any(NameDynAnyPair[] value) 初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members_as_dyn_any(NameDynAnyPair[] value) 根据 NameDynAnyPair 序列初始化该值类型的成员。
static void | NameDynAnyPairHelper.write(OutputStream ostream, NameDynAnyPair value)
static void | NameDynAnyPairSeqHelper.write(OutputStream ostream, NameDynAnyPair[] value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameDynAnyPairHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameDynAnyPairHelper
的使用

没有 org.omg.DynamicAny.NameDynAnyPairHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameDynAnyPairSeqHelper
的使用

没有 org.omg.DynamicAny.NameDynAnyPairSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameValuePair 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameValuePair
的使用

使用 NameValuePair 的软件包
org.omg.DynamicAny 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny 中 NameValuePair 的使用

返回 NameValuePair 的 org.omg.DynamicAny 中的方法
static NameValuePair | NameValuePairHelper.extract(Any a)
static NameValuePair[] | NameValuePairSeqHelper.extract(Any a)
NameValuePair[] | DynStructOperations.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameValuePair[] | DynValueOperations.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
NameValuePair[] | _DynStructStub.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
NameValuePair[] | _DynValueStub.get_members() 返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
static NameValuePair | NameValuePairHelper.read(InputStream istream)
static NameValuePair[] | NameValuePairSeqHelper.read(InputStream istream)

参数类型为 NameValuePair 的 org.omg.DynamicAny 中的方法
static void | NameValuePairHelper.insert(Any a, NameValuePair that)
static void | NameValuePairSeqHelper.insert(Any a, NameValuePair[] that)
void | DynStructOperations.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | DynValueOperations.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
void | _DynStructStub.set_members(NameValuePair[] value) 初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
void | _DynValueStub.set_members(NameValuePair[] value) 根据 NameValuePair 序列初始化该值类型的成员。
static void | NameValuePairHelper.write(OutputStream ostream, NameValuePair value)
static void | NameValuePairSeqHelper.write(OutputStream ostream, NameValuePair[] value)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameValuePairHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameValuePairHelper
的使用

没有 org.omg.DynamicAny.NameValuePairHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny.NameValuePairSeqHelper 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny.NameValuePairSeqHelper
的使用

没有 org.omg.DynamicAny.NameValuePairSeqHelper 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynAnyFactoryStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynAnyFactoryStub
的使用

没有 org.omg.DynamicAny._DynAnyFactoryStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynAnyStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynAnyStub
的使用

没有 org.omg.DynamicAny._DynAnyStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynArrayStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynArrayStub
的使用

没有 org.omg.DynamicAny._DynArrayStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynEnumStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynEnumStub
的使用

没有 org.omg.DynamicAny._DynEnumStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynFixedStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynFixedStub
的使用

没有 org.omg.DynamicAny._DynFixedStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynSequenceStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynSequenceStub
的使用

没有 org.omg.DynamicAny._DynSequenceStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynStructStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynStructStub
的使用

没有 org.omg.DynamicAny._DynStructStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynUnionStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynUnionStub
的使用

没有 org.omg.DynamicAny._DynUnionStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.omg.DynamicAny._DynValueStub 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.omg.DynamicAny._DynValueStub
的使用

没有 org.omg.DynamicAny._DynValueStub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Attr (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 Attr

所有超级接口：
Node
public interface Attr
extends Node

Attr 接口表示 Element 对象中的属性。通常该属性所允许的值定义在与文档相关的模式中。

Attr 对象继承 Node 接口，但由于它们实际上不是它们描述的元素的子节点，DOM 不会将它们看作文档树的一部分。因此，Node 的属性 parentNode、previousSibling 和 nextSibling 具有用于 Attr 对象的 null 值。DOM 认为元素的属性是其特性，而不是一个来自于它们所关联的元素的独立的身份；这应该使实现把这种特征作为与所有给定类型的元素相关联的默认属性更为有效。此外，Attr 节点不可以是 DocumentFragment 的直接子节点。不过，它们可以与包含在 DocumentFragment 内的 Element 节点相关联。简而言之，DOM 的用户和实现者需要知道 Attr 节点与从 Node 接口继承的其他对象有些共同之处，但它们还是截然不同的。

该属性的有效值按如下方式确定：如果为此属性明确分配了任何值，则此值为该属性的有效值；否则，如果声明了此属性，且该声明包括默认值，则该默认值为属性的有效值；否则，直到明确添加了属性，该属性才会存在于结构模型中的这一元素上。注意，Attr 实例上的 Node.nodeValue 属性还可以用于检索该属性值的字符串版本。

如果该属性未在实例文档中明确给定值，但有与文档相关的模式提供的一个默认值，则创建属性节点时把 specified 设置为 false。移除在模式中为其定义了默认值的属性节点将生成一个具有默认值和 specified 设置为 false 的新属性节点。如果调用 Document.normalizeDocument() 时出现确认，则按照由模式提供的默认属性值重新计算 specified 等于 false 的属性节点。如果没有默认值与模式中的这一属性相关联，则该属性节点被丢弃。

在 XML 中，属性值可以包含实体引用，Attr 节点的子节点可以是 Text 或 EntityReference 节点（当使用这些节点时；有关讨论，请参阅 EntityReference 的描述）。

DOM Core 表示作为简单字符串的所有属性值，即使与文档相关联的 DTD 或模式声明它们是某个特定类型（如 tokenized）。

由 DOM 实现执行的属性值规范化的方式取决于该实现对使用的模式的了解程度。通常，Attr 节点的 value 和 nodeValue 属性最初返回由解析器给定的标准化值。调用 Document.normalizeDocument() 之后的情况也是这样（假定设置了正确的选项）。但变化后可能不是这样，与是通过直接设置字符串值还是通过更改 Attr 子节点执行变化无关。特别是，当涉及 character references 时、给出那些不在 DOM 中表示的和影响属性值标准化的时是这种情况，另一方面，如果该实现知道更改属性值时使用的模式，且它与 CDATA 属于不同的类型，则它可以在该时再一次对其执行标准化。对于特殊的 DOM 实现（如 SVG DOM 实现）而言尤其如此，这些实现都会以不同于字符串的内部形式存储属性值。

下表给出了一些示例，表示初始文档中的属性（已解析的属性）值、在 DOM 中公开的值和序列化的值之间的关系：

以下是例子 已解析的属性值 初始 Attr.value 已序列化的属性值
字符引用
"x²=5"

"x?=5"

"x²=5"
内置的字符实体
"y<6"

"y<6"

"y<6"
以下值之间的字面值新行
 "x=5
y=6"

"x=5 y=6"

"x=5
y=6"
以下值之间的已标准化新行
"x=5
 y=6"

"x=5 y=6"

"x=5 y=6"
具有字面值新行的实体 e
 <!ENTITY e '...
...'> [...]> "x=5&e;y=6"
 对实现和加载选项的依赖性 对实现和加载/保存选项的依赖性

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
String | getName() 返回此属性的名称。
Element | getOwnerElement() 此属性连接到的 Element 节点；如果未使用此属性，则为 null。
TypeInfo | getSchemaTypeInfo() 与此属性相关联的类型信息。
boolean | getSpecified() 如果在实例文档中显式给此属性一个值，则为 True；否则为 false。
String | getValue() 检索时，该属性值以字符串形式返回。
boolean | isId() 返回是否此属性属于类型 ID（即包含其所有者元素的标识符）。
void | setValue(String value) 检索时，该属性值以字符串形式返回。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getName

String getName()
返回此属性的名称。如果 Node.localName 与 null 不同，则此属性是一个限定名称。

getSpecified

boolean getSpecified()
如果在实例文档中显式给此属性一个值，则为 True；否则为 false。如果应用程序更改了此属性节点的值（即使它在结尾时有与默认值相同的值），则将它设置为 true。类似地，该实现可以根据其他模式处理具有默认值的属性，但应用程序应该使用 Document.normalizeDocument() 来保证此信息最新。

getValue

String getValue()
检索时，该属性值以字符串形式返回。字符和常规实体引用将使用其值替换。另请参见 Element 接口上的方法 getAttribute。
设置时，此方法使用该字符串的未解析的内容创建 Text 节点，即将 XML 处理器识别为标记的所有字符视为字面值文本。另请参见方法 Element.setAttribute()。
有些特殊的实现（如一些 [SVG 1.1] 实现）可以自动执行标准化，即使变化后也一样；在此情况下，检索的值可以与设置的值不同。

setValue

void setValue(String value)
              throws DOMException
检索时，该属性值以字符串形式返回。字符和常规实体引用将使用其值替换。另请参见 Element 接口上的方法 getAttribute。
设置时，此方法使用该字符串的未解析的内容创建 Text 节点，即将 XML 处理器识别为标记的所有字符视为字面值文本。另请参见方法 Element.setAttribute()。
有些特殊的实现（如一些 [SVG 1.1] 实现）可以自动执行标准化，即使变化后也一样；在此情况下，检索的值可以与设置的值不同。

抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR:当节点为只读的时引发此异常。

getOwnerElement

Element getOwnerElement()
此属性连接到的 Element 节点；如果未使用此属性，则为 null。

从以下版本开始：
DOM Level 2

getSchemaTypeInfo

TypeInfo getSchemaTypeInfo()
与此属性相关联的类型信息。在加载文档或调用 Document.normalizeDocument() 之后保证此属性中包含的类型信息正确时，如果节点被移动，则 schemaTypeInfo 不能不可靠。

从以下版本开始：
DOM Level 3

isId

boolean isId()
返回是否此属性属于类型 ID（即包含其所有者元素的标识符）。如果是且其值是唯一的，则可以使用方法 Document.getElementById 检索此属性的 ownerElement。实现可以使用几种方法确定是否知道属性节点包含标识符：
  • 如果在加载文档或调用 Document.normalizeDocument() 时出现使用 XML Schema [XML Schema Part 1] 的验证，则使用后模式验证信息集贡献（PSVI 贡献）值确定此属性是否是使用 [XPointer] 中的 schema-determined ID 定义的模式确定的 ID 属性。
  • 如果在加载文档或在调用 Document.normalizeDocument() 时使用 DTD 进行验证，则使用信息集 [type definition] 值确定此属性是否是使用 [XPointer] 中的 DTD-determined ID 定义的 DTD 确定的 ID 属性。
  • 使用方法 Element.setIdAttribute()、Element.setIdAttributeNS() 或 Element.setIdAttributeNode() 的属性，即它是用户确定的 ID 属性；

    注： XPointer 框架（参阅 [XPointer] 中的 3.2 节）将 DOM 用户确定的 ID 属性视为 XPointer 外部确定的 ID 定义的一部分。

  • 使用此规范范围之外的机制，则它是外部确定的 ID 属性。这包括使用与 XML 模式和 DTD 不同的模式语言。

如果在调用 Document.normalizeDocument() 时出现确认，则重置所有用户确定的 ID 属性，然后重新评诂所有属性节点 ID 信息与使用的模式是否一致。因此，如果 Attr.schemaTypeInfo 属性包含 ID 类型，则 isId 将始终返回 true。

从以下版本开始：
DOM Level 3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CDATASection (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 CDATASection

所有超级接口：
CharacterData, Node, Text
public interface CDATASection
extends Text

CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。在 CDATA 节中识别的唯一分隔符是结束 CDATA 节的 "]]>" 字符串。CDATA 节不能嵌套。它们的主要目的是包含诸如 XML 片段之类的材料而无需转义所有分隔符。

CharacterData.data 属性保存由 CDATA 节包含的文本。注意，这可以 包含需要在 CDATA 节之外转义的字符，而且根据为序列化选择的字符编码 ("charset")，它不能作为 CDATA 节的一部分写出某些字符。

CDATASection 接口通过 Text 接口继承自 CharacterData 接口。相邻的 CDATASection 节点不能使用 Node 接口的 normalize 方法合并。

不对 CDATA 节的内容进行任何词汇检查，因此在该内容中可能有字符序列 "]]>"，根据 [XML 1.0] 2.7 节该序列在 CDATA 节中是非法的。出现此字符序列一定会在序列化期间生成严重错误，或一定在序列化之前拆分 cdata 节（另请参见 DOMConfiguration 接口中的参数 "split-cdata-sections"）。

注： 因为在 CDATASection 内不识别任何标记，所以序列化时不能将字符数字引用用作转义机制。因此，在序列化具有字符编码（其中包含一些字符无法表示）的 CDATASection 时需要采取措施。如果这样做失败了将不会生成格式良好的 XML。

注： 序列化过程中一个可能的解决方法是在该字符使用字符引用或实体引用输出字符之前结束 CDATA 节，并为文本节点中的所有更多字符打开一个新 CDATA 节。不过要注意的是，在写入时有些代码转换库在编码中丢失字符时不返回错误或异常，加大了确保序列化时不破坏数据的难度。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
从接口 org.w3c.dom.Text 继承的方法
getWholeText, isElementContentWhitespace, replaceWholeText, splitText
从接口 org.w3c.dom.CharacterData 继承的方法
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharacterData (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 CharacterData

所有超级接口：
Node
所有已知子接口：
CDATASection, Comment, Text, Text
public interface CharacterData
extends Node

CharacterData 接口使用属性集合和用于访问 DOM 中字符数据的方法扩展节点。为了清楚起见，在这里定义此集合，而不是在使用这些属性和方法的每个对象上定义。任何 DOM 对象都不会直接对应于 CharacterData，尽管 Text 和其他的对象是从它继承该接口的。此接口中的所有 offset 都从 0 开始。

如 DOMString 接口中所述，DOM 中的文本字符串以 UTF-16（即 16 位单元序列）表示。在下述情况下，每当需要指示以 16 位单元在 CharacterData 上进行索引时就使用术语 16 位单元。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
void | appendData(String arg) 将字符串追加到节点的字符数据的结尾。
void | deleteData(int offset, int count) 从该节点移除某个范围的 16 位单元。
String | getData() 实现此接口的节点的字符数据。
int | getLength() 通过下面的 data 和 substringData 方法可使用的 16 位单元数。
void | insertData(int offset, String arg) 在指定的 16 位单元偏移量位置插入一个字符串。
void | replaceData(int offset, int count, String arg) 用指定的字符串替换从指定 16 位单元偏移量起始的字符。
void | setData(String data) 实现此接口的节点的字符数据。
String | substringData(int offset, int count) 从该节点提取某个范围的数据。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getData

String getData()
               throws DOMException
实现此接口的节点的字符数据。DOM 实现不可以任意限制可以存储在 CharacterData 节点中的数据量。不过，实现限制可能意味着全部的节点数据不可以适合单个 DOMString。在这种情况下，用户可以调用 substringData 以适当大小的片段来检索数据。

抛出：
DOMException - DOMSTRING_SIZE_ERR:当它返回的字符多于实现平台上的 DOMString 变量中的字符时引发此异常。

setData

void setData(String data)
             throws DOMException
实现此接口的节点的字符数据。DOM 实现不可以任意限制可以存储在 CharacterData 节点中的数据量。不过，实现限制可能意味着全部的节点数据不可以适合单个 DOMString。在这种情况下，用户可以调用 substringData 以适当大小的片段来检索数据。。

抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR:节点为只读的时引发此异常。

getLength

int getLength()
通过下面的 data 和 substringData 方法可使用的 16 位单元数。此数可能是值 0，即 CharacterData 节点可以为空。

substringData

String substringData(int offset,
                     int count)
                     throws DOMException
从该节点提取某个范围的数据。

参数：
offset - 要提取的子字符串的起始偏移量。
count - 要提取的 16 位单元数。
返回：
指定的子字符串。如果 offset 和 count 的和超过 length，则返回到数据结尾处的所有 16 位单元。
抛出：
DOMException - INDEX_SIZE_ERR:如果指定 offset 为负或大于 data 中的 16 位单元数，或者如果指定 count 为负，则引发此异常。
DOMSTRING_SIZE_ERR:指定范围的文本不适合 DOMString 时引发此异常。

appendData

void appendData(String arg)
                throws DOMException
将字符串追加到节点的字符数据的结尾。如果成功，则 data 可访问 data 和指定 DOMString 的串联形式。

参数：
arg - 要追加的 DOMString。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR:此节点为只读的引发此异常。

insertData

void insertData(int offset,
                String arg)
                throws DOMException
在指定的 16 位单元偏移量位置插入一个字符串。

参数：
offset - 字符串偏移量，在该处插入字符串。
arg - 要插入的 DOMString。
抛出：
DOMException - INDEX_SIZE_ERR:指定 offset 为负或大于 data 中的 16 位单元数时引发此异常。
NO_MODIFICATION_ALLOWED_ERR:此节点为只读的引发此异常。

deleteData

void deleteData(int offset,
                int count)
                throws DOMException
从该节点移除某个范围的 16 位单元。如果成功，则 data 和 length 反映此更改。

参数：
offset - 偏移量，从此位置开始移除。
count - 要删除的 16 位单元数。如果 offset 和 count 的和超过 length，则删除从 offset 开始到数据结尾的所有 16 位单元。
抛出：
DOMException - INDEX_SIZE_ERR:如果指定 offset 为负或大于 data 中的 16 位单元数，或者如果指定 count 为负，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的引发此异常。

replaceData

void replaceData(int offset,
                 int count,
                 String arg)
                 throws DOMException
用指定的字符串替换从指定 16 位单元偏移量起始的字符。

参数：
offset - 偏移量，从此位置开始替换。
count - 要替换的 16 位单元数。如果 offset 和 count 的和超过 length，则替换到数据结尾的所有 16 位单元；（即其效果与具有同样范围的 remove 方法调用相同，后跟 append 方法调用）。
arg - 必须用来替换该范围的字符的 DOMString。
抛出：
DOMException - INDEX_SIZE_ERR:如果指定 offset 为负或大于 data 中的 16 位单元数，或者如果指定 count 为负，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的引发此异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Comment (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 Comment

所有超级接口：
CharacterData, Node
public interface Comment
extends CharacterData

此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。注意，这是在 XML（实际上是 HTML）中的注释的定义，尽管有些 HTML 工具可以实现完整 SGML 注释结构。

不对注释的内容进行词汇检查，因此在该内容中可以有字符序列 "--"（双连字符），按照 [XML 1.0] 2.5 节该序列在注释中是非法的。出现此字符序列一定会在序列化期间产生严重错误。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
从接口 org.w3c.dom.CharacterData 继承的方法
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Document (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 Document

所有超级接口：
Node
所有已知实现类：
SOAPPart
public interface Document
extends Node

Document 接口表示整个 HTML 或 XML 文档。从概念上讲，它是文档树的根，并提供对文档数据的基本访问。

因为元素、文本节点、注释、处理指令等不能存在于 Document 的上下文之外，所以 Document 接口还包含所需的创建这些对象的工厂方法。所创建的 Node 对象具有 ownerDocument 属性，该属性将 Node 对象与创建这些对象时的上下文所属的 Document 关联起来。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
 Node adoptNode(Node source)
试图把另一文档中的节点采用到此文档。
 Attr createAttribute(String name)
创建给定名称的 Attr。
 Attr createAttributeNS(String namespaceURI, String qualifiedName)
创建给定的限定名称和名称空间 URI 的属性。
 CDATASection createCDATASection(String data)
创建其值为指定字符串的 CDATASection 节点。
 Comment createComment(String data)
创建给定指定字符串的 Comment 节点。
 DocumentFragment createDocumentFragment()
创建空 DocumentFragment 对象。
 Element createElement(String tagName)
创建指定类型的元素。
 Element createElementNS(String namespaceURI, String qualifiedName)
创建给定的限定名称和名称空间 URI 的元素。
 EntityReference createEntityReference(String name)
创建 EntityReference 对象。
 ProcessingInstruction createProcessingInstruction(String target, String data)
创建给定指定名称和数据字符串的 ProcessingInstruction 节点。
 Text createTextNode(String data)
创建给定指定字符串的 Text 节点。
 DocumentType getDoctype()
与此文档相关的文档类型声明（参见 DocumentType）。
 Element getDocumentElement()
这是一种便捷属性，该属性允许直接访问文档的文档元素的子节点。
 String getDocumentURI()
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。
 DOMConfiguration getDomConfig()
调用 Document.normalizeDocument() 时使用的配置。
 Element getElementById(String elementId)
返回具有带给定值的 ID 属性的 Element。
 NodeList getElementsByTagName(String tagname)
按文档顺序返回包含在文档中且具有给定标记名称的所有 Element 的 NodeList。
 NodeList getElementsByTagNameNS(String namespaceURI, String localName)
以文档顺序返回具有给定本地名称和名称空间 URI 的所有 Elements 的 NodeList。
 DOMImplementation getImplementation()
处理此文档的 DOMImplementation 对象。
 String getInputEncoding()
指定解析时此文档使用的编码的属性。
 boolean getStrictErrorChecking()
指定是否强制执行错误检查的属性。
 String getXmlEncoding()
作为 XML 声明的一部分，指定此文档编码的属性。
 boolean getXmlStandalone()
作为 XML 声明的一部分，指定此文档是否为独立文档的属性。
 String getXmlVersion()
作为 XML 声明 的一部分指定此文档版本号的属性。
 Node importNode(Node importedNode, boolean deep)
从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
 void normalizeDocument()
此方法的行为如同使文档通过一个保存和加载的过程，而将其置为 "normal（标准）" 形式。
 Node renameNode(Node n, String namespaceURI, String qualifiedName)
重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
 void setDocumentURI(String documentURI)
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。
 void setStrictErrorChecking(boolean strictErrorChecking)
指定是否强制执行错误检查的属性。
 void setXmlStandalone(boolean xmlStandalone)
作为 XML 声明 的一部分指定此文档是否是单独的的属性。
 void setXmlVersion(String xmlVersion)
作为 XML 声明 的一部分指定此文档版本号的属性。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getDoctype

DocumentType getDoctype()
与此文档相关的文档类型声明（参见 DocumentType）。对于没有文档类型声明的 XML 文档，此方法返回 null。对于 HTML 文档，可以返回 DocumentType 对象，与 HTML 文档中是否有文档类型声明无关。
这提供对 Document 的子节点 DocumentType 节点的直接访问。此节点可以在文档创建时设置，以后可以通过使用子节点操作方法（如 Node.insertBefore 或 Node.replaceChild）进行更改。不过要注意的是，根据创建时指定的 DocumentType，在有些实现可以实例化不同类型的 Document 对象（支持 "Core" 之外的其他功能，如 "HTML" [DOM Level 2 HTML]）时，以后对它的更改很可能会导致所支持功能的不可更改。

从以下版本开始：
DOM Level 3

getImplementation

DOMImplementation getImplementation()
处理此文档的 DOMImplementation 对象。DOM 应用程序可以使用多个实现中的对象。

getDocumentElement

Element getDocumentElement()
这是一种便捷属性，该属性允许直接访问文档的文档元素的子节点。

createElement

Element createElement(String tagName)
                      throws DOMException
创建指定类型的元素。注意，返回的实例实现 Element 接口，所以可以直接在返回的对象上指定属性。
此外，如果存在具有默认值的已知属性，则自动创建表示它们的 Attr 节点，并将其连接到该元素。
要创建具有限定名称和名称空间 URI 的元素，使用 createElementNS 方法。

参数：
tagName - 要实例化的元素类型名称。对于 XML，tagName 参数是区分大小写的；而对于其他文档，则取决于所使用标记语言的大小写敏感性。在该情况下，可通过 DOM 实现将该名称映射到该标记的规范形式。
返回：
新的 Element 对象，该对象具有设置为 tagName 的 nodeName 属性以及设置为 null 的 localName、prefix 和 namespaceURI。
抛出：
DOMException - INVALID_CHARACTER_ERR：如果指定的名称是不遵循所使用的 XML 版本（在 Document.xmlVersion 属性中指定）的 XML 名称，则引发此异常。

createDocumentFragment

DocumentFragment createDocumentFragment()
创建空 DocumentFragment 对象。

返回：
新的 DocumentFragment。

createTextNode

Text createTextNode(String data)
创建给定指定字符串的 Text 节点。

参数：
data - 该节点的数据。
返回：
新 Text 对象。

createComment

Comment createComment(String data)
创建给定指定字符串的 Comment 节点。

参数：
data - 该节点的数据。
返回：
新 Comment 对象。

createCDATASection

CDATASection createCDATASection(String data)
                                throws DOMException
创建其值为指定字符串的 CDATASection 节点。

参数：
data - CDATASection 内容的数据。
返回：
新 CDATASection 对象。
抛出：
DOMException - NOT_SUPPORTED_ERR:如果此文档为 HTML 文档，则引发该异常。

createProcessingInstruction

ProcessingInstruction createProcessingInstruction(String target,
                                                  String data)
                                                  throws DOMException
创建给定指定名称和数据字符串的 ProcessingInstruction 节点。

参数：
target - 处理指令的目标部分。与 Document.createElementNS 或 Document.createAttributeNS 不同，此方法不检查目标名称是否为格式良好的名称空间。为了确保目标名称是格式良好的名称空间，应用程序应该使用设置为 true 的参数 "namespaces" 调用 Document.normalizeDocument()。
data - 该节点的数据。
返回：
新 ProcessingInstruction 对象。
抛出：
DOMException - INVALID_CHARACTER_ERR:如果指定的目标是不遵循在 Document.xmlVersion 属性中指定的使用中的 XML 版本的 XML 名称，则引发此异常。
NOT_SUPPORTED_ERR:如果此文档为 HTML 文档，则引发此异常。

createAttribute

Attr createAttribute(String name)
                     throws DOMException
创建给定名称的 Attr。注意，然后可以使用 setAttributeNode 方法在 Element 上设置 Attr。
要创建具有限定名称和名称空间 URI 的属性，使用 createAttributeNS 方法。

参数：
name - 属性名称。
返回：
新的 Attr 对象，该对象具有设置为 name 的 nodeName 属性以及设置为 null 的 localName、prefix 和 namespaceURI。该属性的值为空字符串。
抛出：
DOMException - INVALID_CHARACTER_ERR:如果指定的名称是不遵循在 Document.xmlVersion 属性中指定的使用中的 XML 版本的 XML 名称，则引发此异常。

createEntityReference

EntityReference createEntityReference(String name)
                                      throws DOMException
创建 EntityReference 对象。此外，如果引用的实体是已知的，则使 EntityReference 节点的子列表与相应 Entity 节点的子列表相同。

注： 如果任何 Entity 节点的后代具有未绑定的名称空间前缀，则相应的所创建的 EntityReference 节点的后代也未绑定；（其 namespaceURI 为 null）。DOM Level 2 和 3 不支持在此情况下解析名称空间前缀的任何机制。

参数：
name - 要引用的实体的名称。与 Document.createElementNS 或 Document.createAttributeNS 不同，不在实体名称上检查名称空间是否为格式良好的。为了确保实体名称是格式良好的名称空间，应用程序应该使用设置为 true 的参数 "namespaces" 调用 Document.normalizeDocument()。
返回：
新的 EntityReference 对象。
抛出：
DOMException - INVALID_CHARACTER_ERR:如果指定的名称是不遵循在 Document.xmlVersion 属性中指定的使用中的 XML 版本的 XML 名称，则引发此异常。
NOT_SUPPORTED_ERR:如果此文档为 HTML 文档，则引发该异常。

getElementsByTagName

NodeList getElementsByTagName(String tagname)
按文档顺序返回包含在文档中且具有给定标记名称的所有 Element 的 NodeList。

参数：
tagname - 要匹配的标记的名称。特殊值 "*" 匹配所有标记。对于 XML ，tagname 参数是区分大小写的，否则它将依靠正在使用的标记语言的大小写敏感性。
返回：
包含所有匹配的 Elements 的新 NodeList 对象。

importNode

Node importNode(Node importedNode,
                boolean deep)
                throws DOMException
从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。返回的节点没有父节点；（parentNode 为 null）。
对于所有节点而言，导入节点创建由导入文档所有的节点对象，属性值等同于源节点的 nodeName 和 nodeType，加上与名称空间相关的属性（prefix、localName 和 namespaceURI）。与在 cloneNode 操作中一样，源节点没有改变。与导入的节点相关的用户数据不可继续使用。不过，如果随相关数据一起指定了任何 UserDataHandlers，则将在此方法返回之前用适当的参数调用这些处理程序。
其他信息按相应的 nodeType 复制，在从一个文档向另一文档复制 XML 或 HTML 源的分段时试图镜像所需的行为，并认识到两个方法可以在 XML 实例中具有不同的 DTD。下表描述了每种类型节点的细节。
ATTRIBUTE_NODE
在生成的 Attr 上，将 ownerElement 属性设置为 null 并将 specified 标志设置为 true。递归地导入源 Attr 的后代，并且重新集合得到的节点来构造相应的子树。注意，deep 参数对 Attr 节点无效；它们总是在导入时带着子节点。
DOCUMENT_FRAGMENT_NODE
如果将 deep 选项设置为 true，则递归地导入源 DocumentFragment 的后代，并在导入的 DocumentFragment 下重新集合得到的节点以构造相应的子树。否则，此操作仅生成一个空 DocumentFragment。
DOCUMENT_NODE
不能导入 Document 节点。
DOCUMENT_TYPE_NODE
不能导入 DocumentType 节点。
ELEMENT_NODE
导入源元素的指定的 属性节点，并将生成的 Attr 节点连接到生成的 Element。默认属性是不 被复制的，不过，如果被导入的文档定义了此元素名称的默认属性，则分配这些属性。如果将 importNode deep 参数设置为 true，则递归地导入源元素的后代并集合得到的节点，以构造相应的子树。
ENTITY_NODE
可以导入 Entity 节点，但在当前版本的 DOM 中，DocumentType 是只读的。将考虑在以后版本的 DOM 中包含将这些导入的节点添加到 DocumentType 中这一功能。导入时，将复制 publicId、systemId 和 notationName 属性。如果请求 deep 导入，则递归地导入源 Entity 的后代，并重新集合得到的节点以构造相应的子树。
ENTITY_REFERENCE_NODE
即使请求 deep 导入，也只复制 EntityReference 本身，因为源和目标文档可能以不同方式定义实体。如果正在导入的文档提供对此实体名称的定义，则它的值得以分配。
NOTATION_NODE
可以导入 Notation 节点，但在当前版本的 DOM 中，DocumentType 是只读的。能够将这些导入的节点添加到 DocumentType 将被认为是以后版本的 DOM 的附加功能。导入时，复制 publicId 和 systemId 属性。注意，deep 参数对此类型的节点无效，因为它们不能有任何子节点。
PROCESSING_INSTRUCTION_NODE
导入的节点从源节点中复制其 target 和 data 值。注意，该 deep 参数对此类型的节点无效，因为它们不能有任何子节点。
TEXT_NODE、CDATA_SECTION_NODE、COMMENT_NODE
继承自 CharacterData 的这三种类型的节点从源节点复制其 data 和 length 属性。注意，deep 参数对这三种类型的节点无效，因为它们不能有任何子节点。

参数：
importedNode - 要导入的节点。
deep - 如果为 true，则递归地导入在指定节点下的子树；如果为 false，则仅导入节点本身，如上面的解释。这对不能有任何子节点的节点、对 Attr 和 EntityReference 节点都无效。
返回：
导入的、属于此 Document 的节点。
抛出：
DOMException - NOT_SUPPORTED_ERR:如果不支持正在导入的该类型的节点，则引发此异常。
INVALID_CHARACTER_ERR:如果导入的一个名称是不遵循在 Document.xmlVersion 属性中指定的使用中的 XML 版本的 XML 名称，则引发此异常。例如，将 XML 1.1 [XML 1.1] 元素导入 XML 1.0 文档时可能引发此异常。
从以下版本开始：
DOM Level 2

createElementNS

Element createElementNS(String namespaceURI,
                        String qualifiedName)
                        throws DOMException
创建给定的限定名称和名称空间 URI 的元素。
依据 [XML Namespaces]，如果应用程序不希望使用名称空间，则必须将 null 作为方法的 namespaceURI 参数的值。

参数：
namespaceURI - 要创建的元素的名称空间 URI。
qualifiedName - 要实例化的元素类型的限定名称。
返回：
具有以下属性的新 Element 对象：
属性 | 值
Node.nodeName | qualifiedName
Node.namespaceURI | namespaceURI
Node.prefix | 前缀，从 qualifiedName 中提取的；如果没有前缀，则为 null
Node.localName | 本地名称，从 qualifiedName 提取的
Element.tagName | qualifiedName
抛出：
DOMException - INVALID_CHARACTER_ERR:如果指定的 qualifiedName 是不遵循在 Document.xmlVersion 属性中指定的使用中的 XML 版本的 XML 名称，则引发此异常。
NAMESPACE_ERR:下列情况引发此异常：如果 qualifiedName 是错误格式的限制名称；如果 qualifiedName 具有前缀且 namespaceURI 为 null；或者如果 qualifiedName 具有前缀 "xml" 且该 namespaceURI 不同于 "http://www.w3.org/XML/1998/namespace" [XML Namespaces]；或者如果 qualifiedName 或其前缀为 "xmlns" 且该 namespaceURI 不同于 "http://www.w3.org/2000/xmlns/"；或者如果 namespaceURI 为 "http://www.w3.org/2000/xmlns/" 且 qualifiedName 及其前缀都不是 "xmlns"。
NOT_SUPPORTED_ERR:由于 XML 定义了名称空间，如果当前文档不支持 "XML" 特性，则总是抛出此异常。
从以下版本开始：
DOM Level 2

createAttributeNS

Attr createAttributeNS(String namespaceURI,
                       String qualifiedName)
                       throws DOMException
创建给定的限定名称和名称空间 URI 的属性。
对于每个 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将 null 作为方法的 namespaceURI 参数的值。

参数：
namespaceURI - 要创建的属性的名称空间 URI。
qualifiedName - 要实例化的属性的限定名称。
返回：
具有以下属性的新 Attr 对象：
属性 | 值
Node.nodeName | qualifiedName
Node.namespaceURI | namespaceURI
Node.prefix | 前缀，从 qualifiedName 中提取的；如果没有前缀，则为 null
Node.localName | 本地名称，从 qualifiedName 提取的
Attr.name | qualifiedName
Node.nodeValue | 空字符串
抛出：
DOMException - INVALID_CHARACTER_ERR:如果指定的 qualifiedName 是不遵循在 Document.xmlVersion 属性中指定的使用中的 XML 版本的 XML 名称，则引发此异常。
NAMESPACE_ERR:在以下情况下引发此异常：如果 qualifiedName 为错误格式的限定名称；如果 qualifiedName 有前缀且 namespaceURI 为 null；如果 qualifiedName 有前缀 "xml" 且 namespaceURI 不同于 "http://www.w3.org/XML/1998/namespace"；如果 qualifiedName 或其前缀为 "xmlns" 且 namespaceURI 不同于 "http://www.w3.org/2000/xmlns/"；或者 namespaceURI 为 "http://www.w3.org/2000/xmlns/" 且 qualifiedName 及其前缀都不是 "xmlns"。
NOT_SUPPORTED_ERR:由于 XML 定义了名称空间，如果当前文档不支持 "XML" 特性，则总是抛出此异常。
从以下版本开始：
DOM Level 2

getElementsByTagNameNS

NodeList getElementsByTagNameNS(String namespaceURI,
                                String localName)
以文档顺序返回具有给定本地名称和名称空间 URI 的所有 Elements 的 NodeList。

参数：
namespaceURI - 要匹配的元素的名称空间 URI。特殊值 "*" 匹配所有名称空间。
localName - 要匹配的元素的本地名称。特殊值 "*" 匹配所有本地名称。
返回：
包含所有匹配的 Elements 的新 NodeList 对象。
从以下版本开始：
DOM Level 2

getElementById

Element getElementById(String elementId)
返回具有带给定值的 ID 属性的 Element。如果不存在此类元素，则此方法返回 null。如果一个以上的元素具有带该值的 ID 属性，返回哪一个元素是不确定的。
期望 DOM 实现使用属性 Attr.isId 来确定属性是否属于类型 ID。

注： 具有名称 "ID" 或 "id" 的属性不属于类型 ID，除非这样定义。

参数：
elementId - 元素的唯一 id 值。
返回：
匹配的元素；如果不存在任何匹配元素，则返回 null。
从以下版本开始：
DOM Level 2

getInputEncoding

String getInputEncoding()
指定解析时此文档使用的编码的属性。如果此属性未知（如在内存中创建 Document 时），则为 null。

从以下版本开始：
DOM Level 3

getXmlEncoding

String getXmlEncoding()
作为 XML 声明的一部分，指定此文档编码的属性。在未指定或未知时，如在内存中创建 Document 时，此属性为 null。

从以下版本开始：
DOM Level 3

getXmlStandalone

boolean getXmlStandalone()
作为 XML 声明的一部分，指定此文档是否为独立文档的属性。未指定时，此属性为 false。

注： 设置此属性时不对此值进行任何验证。应用程序应该使用带有 "validate" 参数的 Document.normalizeDocument() 验证该值是否匹配在 [XML 1.0] 中定义的有关独立文档声明的有效性约束（）。

从以下版本开始：
DOM Level 3

setXmlStandalone

void setXmlStandalone(boolean xmlStandalone)
                      throws DOMException
作为 XML 声明 的一部分指定此文档是否是单独的的属性。未指定时，此属性为 false。

注： 设置此属性时不对此值进行任何验证。应用程序应该使用带有 "validate" 参数的 Document.normalizeDocument() 验证该值是否匹配 validity constraint for standalone document declaration（在 [XML 1.0] 中定义）。

抛出：
DOMException - NOT_SUPPORTED_ERR:如果此文档不支持 "XML" 特性，则引发此异常。
从以下版本开始：
DOM Level 3

getXmlVersion

String getXmlVersion()
作为 XML 声明 的一部分指定此文档版本号的属性。如果没有声明，或如果此文档支持 "XML" 特性，则该值为 "1.0"。如果此文档不支持 "XML" 特性，则该值始终为 null。更改此属性将影响在 XML 名称中检查无效字符的方法。应用程序应该调用 Document.normalizeDocument() 来检查在已经是此 Document 一部分的 Node 中的无效字符。
DOM 应用程序可以使用参数值分别为 "XMLVersion" 和 "1.0"的 DOMImplementation.hasFeature(feature, version) 方法来确定实现是否支持 [XML 1.0]。DOM 应用程序还可以使用参数值分别为 "XMLVersion" 和 "1.1"的同一方法来确定实现是否支持 [XML 1.1]。在这两种情况下，为了支持 XML，实现还必须支持在此规范中定义的 "XML" 特性。支持某版本的 "XMLVersion" 特性的 Document 对象不能在使用 Document.xmlVersion 时对相同版本号引发 NOT_SUPPORTED_ERR 异常。

从以下版本开始：
DOM Level 3

setXmlVersion

void setXmlVersion(String xmlVersion)
                   throws DOMException
作为 XML 声明 的一部分指定此文档版本号的属性。如果没有声明，或如果此文档支持 "XML" 特性，则该值为 "1.0"。如果此文档不支持 "XML" 特性，则该值始终为 null。更改此属性将影响在 XML 名称中检查无效字符的方法。应用程序应该调用 Document.normalizeDocument() 来检查在已经是此 Document 一部分的 Node 中的无效字符。
DOM 应用程序可以使用参数值分别为 "XMLVersion" 和 "1.0"的 DOMImplementation.hasFeature(feature, version) 方法来确定实现是否支持 [XML 1.0]。DOM 应用程序还可以使用参数值分别为 "XMLVersion" 和 "1.1"的同一方法来确定实现是否支持 [XML 1.1]。在这两种情况下，为了支持 XML，实现还必须支持在此规范中定义的 "XML" 特性。支持某版本的 "XMLVersion" 特性的 Document 对象不能在使用 Document.xmlVersion 时对相同版本号引发 NOT_SUPPORTED_ERR 异常。

抛出：
DOMException - NOT_SUPPORTED_ERR:如果将该版本设置为此 Document 不支持的值，或此文档不支持 "XML" 特性，则引发此异常。
从以下版本开始：
DOM Level 3

getStrictErrorChecking

boolean getStrictErrorChecking()
指定是否强制执行错误检查的属性。设置为 false 时，该实现可以不测试通常在 DOM 操作上定义的每个可能的错误情形，可以不在 DOM 操作上引发任何 DOMException，也可以不在使用 Document.normalizeDocument() 时报告错误。如果发生错误，则该行为将会不确定。此属性默认为 true。

从以下版本开始：
DOM Level 3

setStrictErrorChecking

void setStrictErrorChecking(boolean strictErrorChecking)
指定是否强制执行错误检查的属性。设置为 false 时，该实现不会随意测试通常在 DOM 操作上定义的每个可能的错误情形，不会在 DOM 操作上引发任何 DOMException，也不会在使用 Document.normalizeDocument() 时报告错误。如果发生错误，则该行为不确定。此属性默认为 true。

从以下版本开始：
DOM Level 3

getDocumentURI

String getDocumentURI()
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。设置此属性时不执行任何词汇检查；这可能导致在使用 Node.baseURI 时返回 null 值。
请注意，如果 Document 支持 "HTML" [DOM Level 2 HTML] 特性，则计算 Node.baseURI 时 HTML BASE 元素的 href 属性优先于此属性。

从以下版本开始：
DOM Level 3

setDocumentURI

void setDocumentURI(String documentURI)
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。设置此属性时不执行任何词汇检查；这可能导致在使用 Node.baseURI 时返回 null 值。
请注意，如果 Document 支持 "HTML" [DOM Level 2 HTML] 特性，则计算 Node.baseURI 时 HTML BASE 元素的 href 属性优先于此属性。

从以下版本开始：
DOM Level 3

adoptNode

Node adoptNode(Node source)
               throws DOMException
试图把另一文档中的节点采用到此文档。如果受支持，则它将更改源节点的 ownerDocument、它的子节点以及连接的属性节点（如果有）。如果源节点有父节点，则首先从其父节点的子节点列表中移除它。此方法允许将子树从一个文档移动到另一个文档（与 importNode() 不同，后者创建源节点副本，而不是移动子树）。失败时，应用程序应该改为使用 Document.importNode()。注意，如果采用的节点已经是此文档的一部分（即源文档和目标文档相同），此方法仍可有效地从其父节点（如果有）的子列表移除源节点。下表描述了每种类型节点的细节。
ATTRIBUTE_NODE
在采用的 Attr 上，将 ownerElement 属性设置为 null 并将 specified 标志设置为 true。递归地采用源 Attr 的后代。
DOCUMENT_FRAGMENT_NODE
递归地采用源节点的后代。
DOCUMENT_NODE
不能采用 Document 节点。
DOCUMENT_TYPE_NODE
不能采用 DocumentType 节点。
ELEMENT_NODE
采用源元素的 Specified 属性节点。丢弃默认属性，不过，如果被采用的文档定义了此元素名称的默认属性，则分配这些属性。递归地采用源元素的后代。
ENTITY_NODE
不能采用 Entity 节点。
ENTITY_REFERENCE_NODE
只采用 EntityReference 节点本身并丢弃其后代，因为源文档和目标文档可能以不同方式定义实体。如果要导入的文档提供了对此实体名称的定义，则分配其值。
NOTATION_NODE
不能采用 Notation 节点。
PROCESSING_INSTRUCTION_NODE, TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
这些节点均可以采用。无特殊说明。

注： 由于它与 Document.importNode() 方法不同，不创建新的节点，因此此方法不引发 INVALID_CHARACTER_ERR 异常，并且应用程序应该使用 Document.normalizeDocument() 方法来检查导入的名称是否是遵循正在使用的 XML 版本的 XML 名称。

参数：
source - 要移入此文档的节点。
返回：
采用的节点，如果此操作失败（例如源节点来自不同实现时），则返回 null。
抛出：
DOMException - NOT_SUPPORTED_ERR:如果源节点属于 DOCUMENT、DOCUMENT_TYPE 类型，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR:源节点为只读的时引发此异常。
从以下版本开始：
DOM Level 3

getDomConfig

DOMConfiguration getDomConfig()
调用 Document.normalizeDocument() 时使用的配置。

从以下版本开始：
DOM Level 3

normalizeDocument

void normalizeDocument()
此方法的行为如同使文档通过一个保存和加载的过程，而将其置为 "normal（标准）" 形式。因此，此方法更新 EntityReference 节点的替换树并规范化 Text 节点，如在方法 Node.normalize() 中定义的那样。
否则，实际结果取决于在 Document.domConfig 对象上设置的、控制哪个操作实际发生的特性。值得注意的是，此方法还可以按照其中描述的算法使文档名称空间格式良好、检查字符规范化、移除 CDATASection 节点，等等。有关详细信息请参见 DOMConfiguration。
// Keep in the document
 the information defined // in the XML Information Set (Java example)
 DOMConfiguration docConfig = myDocument.getDomConfig();
 docConfig.setParameter("infoset", Boolean.TRUE);
 myDocument.normalizeDocument();

生成改变事件（当被支持时）来反映在该文档上发生的更改。
如果在调用此方法期间发生错误（如试图更新只读节点）或按照正在使用的 XML 版本 Node.nodeName 包含无效字符，则将使用与 "error-handler" 参数相关联的 DOMErrorHandler 对象报告错误或警告（DOMError.SEVERITY_ERROR 或 DOMError.SEVERITY_WARNING）。注意，如果实现无法从错误中恢复，则此方法还可能报告严重错误（DOMError.SEVERITY_FATAL_ERROR）。

从以下版本开始：
DOM Level 3

renameNode

Node renameNode(Node n,
                String namespaceURI,
                String qualifiedName)
                throws DOMException
重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
如有可能，此方法只更改给定节点的名称；否则此方法将创建一个具有指定名称的新节点，并将现有节点替换为新节点，如下所述。
如果只更改给定节点的名称是不可能的，则执行以下操作：创建新节点；在新节点上注册任何已注册的事件侦听器；从旧节点移除连接到该节点的任何用户数据；从旧节点的父节点（如果有）将其移除；将子节点移到新节点；如果重命名的节点为 Element，则其属性移动到新节点；将新节点插入旧节点原来在其父（如果有）的子节点列表中的位置；将连接到旧节点的用户数据连接到新节点。
当正被重命名的节点为 Element 时，只移动指定的属性，源于 DTD 的默认属性按照新的元素名称更新。此外，实现还可以更新源自其他模式的默认属性。应用程序应该使用 Document.normalizeDocument() 来保证这些属性是最新的。
当正被重命名的节点是连接到 Element 的 Attr 时，则首先从 Element 属性映射中移除该节点。然后，一旦通过修改现有节点或创建新节点（如上所述）重命名，则将它放回原处。
此外，
  • 可触发用户数据事件 NODE_RENAMED,
  • 当实现支持 "MutationNameEvents" 特性时，此方法中包含的每个改变操作都将触发相应的事件，最后将触发事件 { http://www.w3.org/2001/xml-events DOMElementNameChanged} 或 { http://www.w3.org/2001/xml-events DOMAttributeNameChanged}。

参数：
n - 要重命名的节点。
namespaceURI - 新的名称空间 URI。
qualifiedName - 新的限定名称。
返回：
重命名的节点。这可以是指定的节点，也可以是用来替换指定节点而创建的新节点。
抛出：
DOMException - NOT_SUPPORTED_ERR:当指定节点的类型不是 ELEMENT_NODE，也不是 ATTRIBUTE_NODE 时，或者如果实现不支持重命名文档元素，则引发此异常。
INVALID_CHARACTER_ERR:如果新的限定名称不是遵循正在使用的在 Document.xmlVersion 属性中指定的 XML 版本的 XML 名称，则引发此异常。
WRONG_DOCUMENT_ERR:当从与此文档不同的另一个文档创建指定节点时，引发此异常。
NAMESPACE_ERR:在以下情况下引发此异常：如果 qualifiedName 为错误格式的限定名称；如果 qualifiedName 有前缀且 namespaceURI 为 null；或者如果 qualifiedName 有前缀 "xml" 且 namespaceURI 不同于 "http://www.w3.org/XML/1998/namespace" [XML Namespaces]。当正被重命名的节点为一属性时，如果 qualifiedName 或其前缀为 "xmlns" 且 namespaceURI 不同于 "http://www.w3.org/2000/xmlns/"，也引发此异常。
从以下版本开始：
DOM Level 3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentFragment (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DocumentFragment

所有超级接口：
Node
public interface DocumentFragment
extends Node

DocumentFragment 是“轻量级”或“最小”Document 对象。希望能够提取文档树的一部分或创建文档的新片段是很常见的。设想实现像剪切这样的用户命令或通过来回移动片段重新安排文档。需要有一个可以保存此类片段的对象，很自然出于此目要使用一个 Node。当 Document 对象真正可以完成此职责时，Document 对象可能为重量级对象，具体取决于基础实现。此操作真正需要的是非常轻量级的对象。DocumentFragment 就是这样的对象。

此外，多种操作（如作为另一个 Node 的子节点插入节点）可能将 DocumentFragment 对象作为参数；这样会导致将 DocumentFragment 的所有子节点移动到此节点的子列表。

DocumentFragment 节点的子节点为 0 或表示定义文档结构的所有子树顶部的多个节点。DocumentFragment 节点不需要是格式良好的 XML 文档（尽管它们需要遵循强加给格式良好的 XML 已解析实体的规则，这些实体可以有多个顶部节点）。例如，DocumentFragment 可能只有一个子节点，并且该子节点可以是 Text。这样的结构模型表示的既不是 HTML 文档，也不是格式良好的 XML 文档。

将 DocumentFragment 插入 Document（确切地说是可以接受子节点的任何其他 Node）时，将 DocumentFragment 的子节点而不是将 DocumentFragment 本身插入 Node。这使得 DocumentFragment 在用户希望创建兄弟节点时非常有用；该 DocumentFragment 充当这些节点的父节点，所以用户可以使用 Node 接口中的标准方法，如 Node.insertBefore 和 Node.appendChild。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentType (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DocumentType

所有超级接口：
Node
public interface DocumentType
extends Node

每个 Document 都有 doctype 属性，该属性的值可以为 null，也可以为 DocumentType 对象。因为在写入时不能明确了解名称空间和各种 XML 模式在 DTD 表示形式上的成果的影响，DOM Core 中的 DocumentType 接口为针对文档和其他因素定义的实体列表提供了一个接口。

DOM Level 3 不支持编辑 DocumentType 节点。DocumentType 节点为只读的。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
NamedNodeMap | getEntities() 包含在 DTD 中声明的内部和外部常规实体的 NamedNodeMap。
String | getInternalSubset() 以字符串表示的内部子集，如果没有内部子集，则为 null。
String | getName() DTD 的名称；即紧跟在 DOCTYPE 关键字后面的名称。
NamedNodeMap | getNotations() 包含在 DTD 中声明的表示法的 NamedNodeMap。
String | getPublicId() 外部子集的公共标识符。
String | getSystemId() 外部子集的系统标识符。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getName

String getName()
DTD 的名称；即紧跟在 DOCTYPE 关键字后面的名称。

getEntities

NamedNodeMap getEntities()
包含在 DTD 中声明的内部和外部常规实体的 NamedNodeMap。不包含参数实体。丢弃重复实体。例如以下示例中：
<!DOCTYPE
 ex SYSTEM "ex.dtd" [ <!ENTITY foo "foo"> <!ENTITY bar
 "bar"> <!ENTITY bar "bar2"> <!ENTITY % baz "baz">
 ]> <ex/>
该接口提供对 foo 的访问，并且提供 bar 的第一个声明而不是 bar 或者 baz的第二个声明。此映射中的每个节点也实现 Entity 接口。
DOM Level 2 不支持编辑实体，因此不能以任何方式改变 entities。

getNotations

NamedNodeMap getNotations()
包含在 DTD 中声明的表示法的 NamedNodeMap。丢弃重复实体。此映射中的每个节点也实现 Notation 接口。
DOM Level 2 不支持编辑表示法，因此不能以任何方式改变 notations。

getPublicId

String getPublicId()
外部子集的公共标识符。

从以下版本开始：
DOM Level 2

getSystemId

String getSystemId()
外部子集的系统标识符。这可以是绝对 URI，也可以不是。

从以下版本开始：
DOM Level 2

getInternalSubset

String getInternalSubset()
以字符串表示的内部子集，如果没有内部子集，则为 null。这不包含分隔方括号。

注：返回的实际内容取决于可用于该实现的信息量。取决于各种参数（包括用于构建文档的 XML 处理器）这可以不同。

从以下版本开始：
DOM Level 2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMConfiguration (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DOMConfiguration

public interface DOMConfiguration

该 DOMConfiguration 接口表示文档的配置，并维护一个可识别的参数表。使用该配置，能够更改 Document.normalizeDocument() 行为，如将 CDATASection 节点替换为 Text 节点或指定在请求验证 Document 时必须使用的模式类型。DOMConfiguration 对象也可用于 DOMParser 和 DOMSerializer 接口中的 [DOM Level 3 Load and Save]。

由 DOMConfiguration 对象使用的参数名称可在整个 DOM Level 3 规范中定义。名称不区分大小写。要避免可能的冲突，根据惯例，应该使指向在 DOM 规范之外定义的参数的名称唯一。因为参数要作为属性公开，所以建议名称遵循 5.16 节带有字符 '-'（连字符号）的“[Unicode] 标识符”，但它不是由 DOM 实现强制执行的。要求 DOM Level 3 核心实现来识别在此规范中定义的所有参数。也可能要求某些参数值接受该实现的支持。若要知道一个值是否必须被支持，请参阅参数的定义。

注：参数类似于在 SAX2 [SAX] 中使用的功能和属性。

下面是在 DOM 中定义的参数列表：

"canonical-form"
true
[optional] 根据在 [Canonical XML] 指定的规则规范化文档，如从树中移除 DocumentType 节点（如果有），或从每个元素移除多余的名称空间声明。注意，这限于可以在 DOM 中表示的内容；需要特别指出的是，无法指定 DOM 中的属性的顺序。此外，将此参数设置为 true 还要设置下面列出的参数的状态。以后对这些参数中某个的状态的更改都会将“规范形式”转换回 false。设置为 false 的参数："entities"、" normalize-characters"、"cdata-sections"。设置为 true 的参数："namespaces"、"namespace-declarations"、"well-formed"、"element-content-whitespace"。其他参数只有在参数描述中显式地指定时才更改。
false
[需要]（默认）不规范化文档。
"cdata-sections"
true
[需要]（默认）保留文档中的 CDATASection 节点。
false
[需要]将文档中的 CDATASection 节点转换为 Text 节点。然后将新的 Text 节点与任何相邻 Text 节点合并起来。
"check-character-normalization"
true
[可选] 检查文档中的字符是否是 完全规范化，如在 [XML 1.1] 的附录 B 中定义的那样。当遇到规范化检查失败的字符序列时，将发生带有 DOMError.type（等于 "check-character-normalization-failure"）的错误。
false
[需要]（默认）不检查字符是否规范化。
"comments"
true
[需要]（默认）保留文档中的 Comment 节点。
false
[需要]丢弃文档中的 Comment 节点。
"datatype-normalization"
true
[optional] 公开树中的模式标准化值，如 XML 模式中的 XML 模式标准化值。由于此参数要求有模式信息，所以还要将 "validate" 参数设置为 true。"validate" 为 false 时激活此参数无效，且不发生模式规范化。

注：由于文档包含 XML 1.0 处理的结果，所以此参数不会像在 [XML 1.0] 的 3.3.3 节中定义的那样应用于属性值规范化，而只用于除文档类型定义 (DTD) 之外的模式语言。

false
[需要]（默认）不执行对树的模式规范化。
"element-content-whitespace"
true
[需要]（默认）保留文档中的所有空格。
false
[可选] 丢弃在元素内容中包含空格的所有 Text 节点，如在 [element content whitespace] 中描述的那样。期望该实现使用属性 Text.isElementContentWhitespace 来确定是否应该丢弃 Text 节点。
"entities"
true
[需要]（默认）保留文档中的 EntityReference 节点。
false
[需要] 从文档中移除所有 EntityReference 节点，并直接将实体扩展放入适当位置。按 Node.normalize 中定义的那样，标准化 Text 节点。文档中只保留 未扩展的实体引用。

注：此参数不影响 Entity 节点。

"error-handler"
[需要] 包含 DOMErrorHandler 对象。如果在文档中遇到错误，则该实现将回调使用此参数注册的 DOMErrorHandler。该实现可以提供默认的 DOMErrorHandler 对象。调用时，DOMError.relatedData 将包含离发生错误的位置最近的节点。如果该实现不能确定发生错误的节点，则 DOMError.relatedData 将包含 Document 节点。从错误处理程序内部对文档的修改将导致与实现有关的行为。
"infoset"
true
[需要] 在文档中保留在 XML 信息集合 [XML Information Set] 中定义的信息。这样做强迫以下参数为 false："validate-if-schema"、"entities"、"datatype-normalization"、"cdata-sections"。这迫使以下参数为 true："namespace-declarations"、"well-formed"、"element-content-whitespace"、" comments"、"namespaces"。其他参数只有在参数的描述中显式指定时才能更改。注意，只有在适当设置以上指定的单个参数时，使用 getParameter 查询此参数才能返回 true。
false
将 infoset 设置为 false 无效。
"namespaces"
true
[需要]（默认）按以下定义方式执行名称空间处理。
false
[可选] 不执行名称空间处理。
"namespace-declarations"
如果将参数 "namespaces" 设置为 false，则此参数无效。
true
[需要]（默认）包括在文档中模式指定或默认的名称空间声明属性。另请参见 [XML Namespaces] 和 [XML Namespaces 1.1] 中的“声明名称空间”各节。
false
[需要] 丢弃所有名称空间声明属性。保留名称空间前缀 (Node.prefix)，即使此参数设置为 false。
"normalize-characters"
true
[可选] 完全标准化文档中的字符，如 [XML 1.1] 的附录 B 中定义的那样。
false
[需要]（默认）不执行字符规范化。
"schema-location"
[可选] 表示包含 URI 列表的 DOMString 对象，由空格分隔（与在 [XML 1.0] 第 2.3 节定义的 nonterminal production S 匹配的字符），它表示对其进行验证的模式，即当前模式。此列表中引用的模式类型必须匹配用 schema-type 指定的类型，否则实现的行为不确定。使用此属性指定的模式优先于在文档本身中指定的模式信息。对于名称空间感知的模式而言，如果使用此属性指定的模式和模式文档（例如使用 schemaLocation 属性）中在文档实例中（例如使用模式 import 机制）指定的模式共享同一 targetNamespace，则将使用由用户使用此属性指定的模式。如果使用此属性指定的两个模式共享同一 targetNamespace，或不存在名称空间，则该行为与实现有关。如果未提供任何位置，则此参数为 null。

注：忽略 "schema-location" 参数，除非设置了 "schema-type" 参数值。强烈建议设置 Document.documentURI，以便实现可以成功解析所引用的所有外部实体。

"schema-type"
[可选] 表示一个 DOMString 对象，该对象包含绝对 URI 且表示用于对其验证文档的模式语言类型。注意，不对绝对 URI 进行词汇检查。如果未设置此参数，则该实现可以根据支持的模式语言和加载时使用的模式语言提供默认值。如果未提供任何值，则此参数为 null。

注：对于 XML 模式 [XML Schema Part 1]，应用程序必须使用值 "http://www.w3.org/2001/XMLSchema"。对于 XML DTD [XML 1.0]，应用程序必须使用值 "http://www.w3.org/TR/REC-xml"。其他模式语言在 W3C 的作用域之外，因此为了使用此方法应该建议绝对 URI。

"split-cdata-sections"
true
[需要]（默认）拆分包含 CDATA 节终止标志 ']]>' 的 CDATA 节。拆分 CDATA 节时，将发出警告，DOMError.type 等于 "cdata-sections-splitted"，DOMError.relatedData 等于从该拆分得到的文档顺序的第一个 CDATASection 节点。
false
[需要]如果 CDATASection 包含不可表示的字符时发出错误通知。
"validate"
true
[可选] 当它按 [XML 1.0] 定义的方式进行标准化时，要求验证文档的模式（例如 XML 模式、DTD、任何其他类型或表示形式的模式）。如果发现验证错误，或未发现任何模式，则通知错误处理程序。按照使用的模式，将不公开模式标准化值，除非参数 "datatype-normalization" 为 true。此参数将重新评诂：
  • 具有 Attr.specified 等于 false 的属性节点，如在 Attr 接口的描述中指定的那样；
  • 所有 Text 节点的属性 Text.isElementContentWhitespace 的值；
  • 所有 Attr 节点的属性 Attr.isId 的值；
  • 属性 Element.schemaTypeInfo 和 Attr.schemaTypeInfo。

注："validate-if-schema" 和 "validate" 互斥，将其中一个设置为 true 就要将另一个设置为 false。应用程序还应该考虑将参数 "well-formed" 设置为 true，这是验证该文档时该选项的默认值。

false
[需要]（默认）不实现模式处理，包括内部子集处理。保留默认属性值信息。注意，如果 "validate-if-schema" 为 true，则仍可能进行验证。
"validate-if-schema"
true
[可选]仅当可以在模式（与找到的位置无关，即 XML 模式、DTD 或模式的任何其他类型或表示形式）中找到文档元素的声明时启用验证。如果启用验证，则此参数的行为与设置为 true 的参数 "validate" 的行为相同。

注："validate-if-schema" 和 "validate" 互斥，将其中一个设置为 true 就要将另一个设置为 false。

false
[需要]（默认）如果文档有模式，则不应该执行任何模式处理，包括内部子集处理。保留默认属性值信息。注意，如果 "validate" 为 true，则仍必须进行验证。
"well-formed"
true
[需要]（默认）按照在 Document.xmlVersion 中使用的 XML 版本检查所有节点是否是良好格式的 XML：
  • 按照其节点类型检查属性 Node.nodeName 是否包含无效字符；是否生成类型 "wf-invalid-character-in-node-name" 的 DOMError（必要时带有 DOMError.SEVERITY_ERROR severity）；
  • 检查 Attr、Element、Comment、Text、CDATASection 节点内的文本内容是否包含无效字符，是否生成类型 "wf-invalid-character" 的 DOMError（必要时带有 DOMError.SEVERITY_ERROR severity）；
  • 检查 ProcessingInstruction 节点内的数据是否包含无效字符，是否生成类型 "wf-invalid-character" 的 DOMError（必要时带有 DOMError.SEVERITY_ERROR severity）；
false
[可选] 不检查 XML 的格式良好性。

使用 Document.documentURI 解析与实体相关的系统标识符。但是，当 DOM 实现支持在 [DOM Level 3 Load and Save] 中定义的功能 "LS" 时，参数 "resource-resolver" 还可以在连接到 Document 节点的 DOMConfiguration 上使用。如果已设置了此参数，则 Document.normalizeDocument() 将调用资源解析程序，而不是使用 Document.documentURI。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

方法摘要
boolean | canSetParameter(String name, Object value) 检查是否支持将参数设置为特定值。
Object | getParameter(String name) 如果已知，则返回参数的值。
DOMStringList | getParameterNames() 此 DOMConfiguration 对象支持的参数列表，并且应用程序至少可以为其设置一个值。
void | setParameter(String name, Object value) 设置参数的值。

方法详细信息

setParameter

void setParameter(String name,
                  Object value)
                  throws DOMException
设置参数的值。

参数：
name - 要设置的参数的名称。
value - 新的值，如果用户希望取消设置该参数则为 null。当将值参数的类型定义为 DOMUserData 时，对象类型必须匹配由参数的定义所定义的类型。例如，如果参数为 "error-handler"，则该值必须是 DOMErrorHandler 类型。
抛出：
DOMException - NOT_FOUND_ERR: 参数名称不可识别时，引发此异常。
NOT_SUPPORTED_ERR: 当参数名称可以识别但不能设置请求的值时，引发此异常。
TYPE_MISMATCH_ERR:如果此参数名称的值类型与期望的值类型不兼容，则引发此异常。

getParameter

Object getParameter(String name)
                    throws DOMException
如果已知，则返回参数的值。

参数：
name - 参数的名称。
返回：
返回与指定参数相关的当前对象；如果没有任何相关的对象，或如果参数不被支持，则返回 null。
抛出：
DOMException - NOT_FOUND_ERR:参数名称不可识别时，引发此异常。

canSetParameter

boolean canSetParameter(String name,
                        Object value)
检查是否支持将参数设置为特定值。

参数：
name - 要检查的参数的名称。
value - 一个对象。如果为 null，则返回的值为 true。
返回：
如果可以成功地将参数设置为特定的值，则返回 true；如果参数不可识别或请求的值不受支持，则返回 false。这样不会更改参数本身的当前值。

getParameterNames

DOMStringList getParameterNames()
此 DOMConfiguration 对象支持的参数列表，并且应用程序至少可以为其设置一个值。注意，此列表还可以包含在此规范之外定义的参数名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMError (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DOMError

public interface DOMError

DOMError 是一个描述错误的接口。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

字段摘要
static short | SEVERITY_ERROR DOMError 描述的错误的严重性为错误。
static short | SEVERITY_FATAL_ERROR DOMError 描述的错误的严重性为严重错误。
static short | SEVERITY_WARNING DOMError 描述的错误的严重性为警告。
方法摘要
DOMLocator | getLocation() 错误的位置。
String | getMessage() 描述所发生错误的特定于实现的字符串。
Object | getRelatedData() 相关的与 DOMError.type 有关的数据（如果有）。
Object | getRelatedException() 相关的与相关平台有关的异常（如果有）。
short | getSeverity() 错误的严重性，SEVERITY_WARNING、SEVERITY_ERROR 或 SEVERITY_FATAL_ERROR。
String | getType() DOMString，指示在 relatedData 中哪个相关数据是所期望的。

字段详细信息

SEVERITY_WARNING

static final short SEVERITY_WARNING
DOMError 描述的错误的严重性为警告。SEVERITY_WARNING 将不会使处理停止，除非 DOMErrorHandler.handleError() 返回 false。

另请参见：
常量字段值

SEVERITY_ERROR

static final short SEVERITY_ERROR
DOMError 描述的错误的严重性为错误。如果错误可以恢复，则 SEVERITY_ERROR 可能不会使处理停止，除非 DOMErrorHandler.handleError() 返回 false。

另请参见：
常量字段值

SEVERITY_FATAL_ERROR

static final short SEVERITY_FATAL_ERROR
DOMError 描述的错误的严重性为严重错误。SEVERITY_FATAL_ERROR 将导致正常的处理停止。忽略 DOMErrorHandler.handleError() 的返回值，除非实现选择继续（在此情况下，行为变得不确定）。

另请参见：
常量字段值
方法详细信息

getSeverity

short getSeverity()
错误的严重性，SEVERITY_WARNING、SEVERITY_ERROR 或 SEVERITY_FATAL_ERROR。

getMessage

String getMessage()
描述所发生错误的特定于实现的字符串。

getType

String getType()
DOMString，指示在 relatedData 中哪个相关数据是所期望的。用户应该参阅错误的规范，以找到其 DOMString 类型和 relatedData 定义（如果有）。

注：例如，Document.normalizeDocument() 在使用 "split-cdata-sections" 参数时生成警告。因此，该方法生成具有 类型 "cdata-sections-splitted" 的 SEVERITY_WARNING，并由 relatedData 属性返回第一个从该拆分中得到的文档顺序的 CDATASection 节点。

getRelatedException

Object getRelatedException()
相关的与相关平台有关的异常（如果有）。

getRelatedData

Object getRelatedData()
相关的与 DOMError.type 有关的数据（如果有）。

getLocation

DOMLocator getLocation()
错误的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMErrorHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DOMErrorHandler

public interface DOMErrorHandler

DOMErrorHandler 是在报告处理 XML 数据时发生的错误或在进行某些其他处理（如验证文档）时 DOM 实现可以调用的回调接口。可以使用 DOMConfiguration 接口上的 "error-handler" 将 DOMErrorHandler 对象 连接到 Document。如果在操作期间需要报告一个以上的错误，则传递到错误处理程序的错误序列和数量与实现有关。

期望正在使用 DOM 实现的应用程序实现此接口。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

方法摘要
 boolean handleError(DOMError error)
发生错误时在错误处理程序上调用此方法。

方法详细信息

handleError

boolean handleError(DOMError error)
发生错误时在错误处理程序上调用此方法。
如果从此方法抛出异常，则认为与返回 true 等效。

参数：
error - 描述错误的错误对象。DOM 实现可以在对 handleError 方法的多次调用时重新使用此对象。
返回：
如果 handleError 方法返回 false，则 DOM 实现应该在可能时停止当前处理。如果该方法返回 true，则该处理可以根据 DOMError.severity 继续进行。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
类 DOMException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.w3c.dom.DOMException
所有已实现的接口：
Serializable
public class DOMException
extends RuntimeException

DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。通常，DOM 方法在普通处理情况下返回特定的错误值，如使用 NodeList 时的超出边界错误。

实现应该在其他情况下引发其他异常。例如，如果不期望是 null 时传递 null 参数，则实现应该引发一个与实现有关的异常。

有些语言和对象系统不支持异常的概念。对于这样的系统，可以使用本机错误报告机制指示错误情况。例如，对于一些绑定，方法可以返回错误代码，它们类似于在相应方法描述中列出的错误代码。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

另请参见：
序列化表格

字段摘要
short | code
static short | DOMSTRING_SIZE_ERR 如果文本的指定范围不适合 DOMString。
static short | HIERARCHY_REQUEST_ERR 如果在不属于 Node 的位置将任何 Node 插入。
static short | INDEX_SIZE_ERR 如果索引或大小为负，或大于允许的值。
static short | INUSE_ATTRIBUTE_ERR 如果试图添加已经在其他位置使用的属性。
static short | INVALID_ACCESS_ERR 如果基础对象不支持某个参数或操作。
static short | INVALID_CHARACTER_ERR 如果指定无效或非法字符，如在 XML 名称中。
static short | INVALID_MODIFICATION_ERR 如果试图修改基础对象的类型。
static short | INVALID_STATE_ERR 如果试图使用不可用或不再可用的对象。
static short | NAMESPACE_ERR 如果试图以一种与名称空间有关的错误的方式创建或更改一个对象。
static short | NO_DATA_ALLOWED_ERR 如果为不支持数据的 Node 指定数据。
static short | NO_MODIFICATION_ALLOWED_ERR 如果试图在不允许修改的位置修改对象。
static short | NOT_FOUND_ERR 如果试图在它不存在的上下文中引用 Node。
static short | NOT_SUPPORTED_ERR 如果实现不支持请求类型的对象或操作。
static short | SYNTAX_ERR 如果指定无效或非法字符串。
static short | TYPE_MISMATCH_ERR 如果对象的类型和与此对象相关联的参数的期望类型不兼容。
static short | VALIDATION_ERR 如果调用诸如 insertBefore 或 removeChild 之类的方法使 Node 无效(和 "partial validity" 有关的），则引发此异常并且将不进行操作。
static short | WRONG_DOCUMENT_ERR 如果 Node 用于不同的文档而不是创建它的文档（该文档不支持它）。
构造方法摘要
DOMException(short code, String message)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

code

public short code

INDEX_SIZE_ERR

public static final short INDEX_SIZE_ERR
如果索引或大小为负，或大于允许的值。

另请参见：
常量字段值

DOMSTRING_SIZE_ERR

public static final short DOMSTRING_SIZE_ERR
如果文本的指定范围不适合 DOMString。

另请参见：
常量字段值

HIERARCHY_REQUEST_ERR

public static final short HIERARCHY_REQUEST_ERR
如果在不属于 Node 的位置将任何 Node 插入。

另请参见：
常量字段值

WRONG_DOCUMENT_ERR

public static final short WRONG_DOCUMENT_ERR
如果 Node 用于不同的文档而不是创建它的文档（该文档不支持它）。

另请参见：
常量字段值

INVALID_CHARACTER_ERR

public static final short INVALID_CHARACTER_ERR
如果指定无效或非法字符，如在 XML 名称中。

另请参见：
常量字段值

NO_DATA_ALLOWED_ERR

public static final short NO_DATA_ALLOWED_ERR
如果为不支持数据的 Node 指定数据。

另请参见：
常量字段值

NO_MODIFICATION_ALLOWED_ERR

public static final short NO_MODIFICATION_ALLOWED_ERR
如果试图在不允许修改的位置修改对象。

另请参见：
常量字段值

NOT_FOUND_ERR

public static final short NOT_FOUND_ERR
如果试图在它不存在的上下文中引用 Node。

另请参见：
常量字段值

NOT_SUPPORTED_ERR

public static final short NOT_SUPPORTED_ERR
如果实现不支持请求类型的对象或操作。

另请参见：
常量字段值

INUSE_ATTRIBUTE_ERR

public static final short INUSE_ATTRIBUTE_ERR
如果试图添加已经在其他位置使用的属性。

另请参见：
常量字段值

INVALID_STATE_ERR

public static final short INVALID_STATE_ERR
如果试图使用不可用或不再可用的对象。

从以下版本开始：
DOM Level 2
另请参见：
常量字段值

SYNTAX_ERR

public static final short SYNTAX_ERR
如果指定无效或非法字符串。

从以下版本开始：
DOM Level 2
另请参见：
常量字段值

INVALID_MODIFICATION_ERR

public static final short INVALID_MODIFICATION_ERR
如果试图修改基础对象的类型。

从以下版本开始：
DOM Level 2
另请参见：
常量字段值

NAMESPACE_ERR

public static final short NAMESPACE_ERR
如果试图以一种与名称空间有关的错误的方式创建或更改一个对象。

从以下版本开始：
DOM Level 2
另请参见：
常量字段值

INVALID_ACCESS_ERR

public static final short INVALID_ACCESS_ERR
如果基础对象不支持某个参数或操作。

从以下版本开始：
DOM Level 2
另请参见：
常量字段值

VALIDATION_ERR

public static final short VALIDATION_ERR
如果调用诸如 insertBefore 或 removeChild 之类的方法使 Node 无效(和 "partial validity" 有关的），则引发此异常并且将不进行操作。此代码用于 [DOM Level 3 Validation]。更多的信息，请参见此规范。

从以下版本开始：
DOM Level 3
另请参见：
常量字段值

TYPE_MISMATCH_ERR

public static final short TYPE_MISMATCH_ERR
如果对象的类型和与此对象相关联的参数的期望类型不兼容。

从以下版本开始：
DOM Level 3
另请参见：
常量字段值
构造方法详细信息

DOMException

public DOMException(short code,
                    String message)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMImplementation (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DOMImplementation

public interface DOMImplementation

DOMImplementation 接口为执行独立于文档对象模型的任何特定实例的操作提供了许多方法。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

方法摘要
Document | createDocument(String namespaceURI, String qualifiedName, DocumentType doctype) 创建具有文档元素的指定类型的 DOM Document 对象。
DocumentType | createDocumentType(String qualifiedName, String publicId, String systemId) 创建空 DocumentType 节点。
Object | getFeature(String feature, String version) 此方法返回一个特定的对象，该对象实现了 DOM Features 中所指定的特定特性或版本的特殊 API。
boolean | hasFeature(String feature, String version) 测试 DOM 实现是否实现在 DOM Features 中指定的特定特性和版本。

方法详细信息

hasFeature

boolean hasFeature(String feature,
                   String version)
测试 DOM 实现是否实现在 DOM Features 中指定的特定特性和版本。

参数：
feature - 要测试的特性的名称。
version - 这是要测试的特性的版本号。
返回：
如果在指定的版本中实现该特性，则返回 true；否则返回 false。

createDocumentType

DocumentType createDocumentType(String qualifiedName,
                                String publicId,
                                String systemId)
                                throws DOMException
创建空 DocumentType 节点。无法使实体声明和表示法可用。不发生实体引用扩展和默认属性添加。

参数：
qualifiedName - 要创建的文档类型的限定名称。
publicId - 外部子集的公共标识符。
systemId - 外部子集的系统标识符。
返回：
具有设置为 null 的 Node.ownerDocument 的新 DocumentType 节点。
抛出：
DOMException - INVALID_CHARACTER_ERR:如果指定的限定名称不是遵循 [XML 1.0] 的 XML 名称，则引发此异常。
NAMESPACE_ERR: 如果 qualifiedName 是错误格式的，则引发此异常。
NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档公开的语言不支持 XML 名称空间（如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

createDocument

Document createDocument(String namespaceURI,
                        String qualifiedName,
                        DocumentType doctype)
                        throws DOMException
创建具有文档元素的指定类型的 DOM Document 对象。
注意，基于给定的 DocumentType 创建文档，该实现可以实例化特定的 Document 对象，这些对象可支持 "Core" 之外的其他特性，如 "HTML" [DOM Level 2 HTML]。而在创建文档之后再设置 DocumentType，可能使得此操作很难实现。此外，特定的 Document 创建方法（例如 createHTMLDocument [DOM Level 2 HTML]）可用于获取特定类型的 Document 对象。

参数：
namespaceURI - 要创建的文档元素的名称空间 URI 或 null。
qualifiedName - 要创建的文档元素的限定名称或 null。
doctype - 要创建的文档的类型或 null。当 doctype 不是 null 时，其 Node.ownerDocument 属性将被设置为正在创建的文档。
返回：
具有文档元素的新 Document 对象。如果 NamespaceURI、qualifiedName 和 doctype 为 null，则返回的 Document 为空的，不带有文档元素。
抛出：
DOMException - INVALID_CHARACTER_ERR:如果指定的限定名称不是遵循 [XML 1.0] 的 XML 名称，则引发此异常。
NAMESPACE_ERR: 在以下情况下引发此异常：如果 qualifiedName 是错误格式的；如果 qualifiedName 有前缀且 namespaceURI 为 null；或者如果 qualifiedName 为 null 且 namespaceURI 不同于 null；或者如果 qualifiedName 有名为 "xml" 的前缀且 namespaceURI 不同于 "http://www.w3.org/XML/1998/namespace" [XML Namespaces]；或者如果 DOM 实现不支持 "XML" 功能但提供非 null 名称空间 URI，因为名称空间由 XML 定义。
WRONG_DOCUMENT_ERR: 如果 doctype 已经用于不同文档或者从不同的实现创建，则引发此异常。
NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档公开的语言不支持 XML 名称空间（如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

getFeature

Object getFeature(String feature,
                  String version)
此方法返回一个特定的对象，该对象实现了 DOM Features 中所指定的特定特性或版本的特殊 API。该特殊对象也可以通过使用特定于绑定的强制转换方法获得，但不是必须期望这样做，正如文中讨论的那样。此方法还允许实现提供不支持 DOMImplementation 接口的特殊对象。

参数：
feature - 所请求的功能的名称。注意，追加到功能的名称的任何加号 "+" 将被忽略，因为它在此方法的上下文中无关紧要。
version - 这是要测试的功能的版本号。
返回：
返回实现指定的特性和版本的特殊 API 的对象（如果有）；如果不存在实现与此特性相关的接口的对象，则返回 null。如果此方法返回的 DOMObject 实现 DOMImplementation 接口，则它必须委托给主要核心实现 DOMImplementation 且不返回与该主要核心 DOMImplementation 不一致的结果，如 hasFeature、getFeature、等等。
从以下版本开始：
DOM Level 3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMImplementationList (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DOMImplementationList

public interface DOMImplementationList

DOMImplementationList 接口提供对 DOM 实现的有序集合的抽象，没有定义或约束如何实现此集合。DOMImplementationList 中的项可以通过从 0 开始的整数索引访问。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

方法摘要
int | getLength() 列表中 DOMImplementation 的数目。
DOMImplementation | item(int index) 返回集合中的第 index 个项。

方法详细信息

item

DOMImplementation item(int index)
返回集合中的第 index 个项。如果 index 大于或等于列表中的 DOMImplementation 的数目，则此方法返回 null。

参数：
index - 集合中的索引。
返回：
DOMImplementationList 中第 index 个位置处的 DOMImplementation；如果索引不是有效索引，则返回 null。

getLength

int getLength()
列表中 DOMImplementation 的数目。有效子节点索引的范围是 0 到 length-1(包含此值）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMImplementationSource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DOMImplementationSource

public interface DOMImplementationSource

此接口允许 DOM 实现程序根据请求的功能和版本提供一个或多个实现，如下所述。每个实现的 DOMImplementationSource 对象都在可用源的特定于绑定的列表中列出，所以可使其 DOMImplementation 对象可用。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

方法摘要
DOMImplementation | getDOMImplementation(String features) 请求支持指定的功能的第一个 DOM 实现的方法。
DOMImplementationList | getDOMImplementationList(String features) 请求支持指定功能和版本的 DOM 实现的列表的方法，如下所述。

方法详细信息

getDOMImplementation

DOMImplementation getDOMImplementation(String features)
请求支持指定的功能的第一个 DOM 实现的方法。

参数：
features - 指定所需功能和版本的字符串。这是一个空格分隔的列表，其中每个功能都由其名称指定，后面可以选择跟一个空格或版本号。此方法返回由 getDOMImplementationList 返回的列表中的第一个项。例如，字符串 "XML 3.0 Traversal +Events 2.0" 将请求支持其 3.0 版本 "XML" 模块的 DOM 实现，该模块支持任何版本的 "Traversal" 模块，以及其 2.0 版的 "Events" 模块。模块 "Events" 必须能够使用方法 Node.getFeature() 和 DOMImplementation.getFeature() 访问。
返回：
支持所需功能的第一个 DOM 实现；如果此源没有 DOM 实现，则返回 null。

getDOMImplementationList

DOMImplementationList getDOMImplementationList(String features)
请求支持指定功能和版本的 DOM 实现的列表的方法，如下所述。

参数：
features - 指定所需功能和版本的字符串。这是一个空格分隔的列表，其中每个功能都由其名称指定，后面可以选择跟一个空格或版本号。此列表的形式如下："XML 3.0 Traversal +Events 2.0"
返回：
支持所需功能的 DOM 实现的列表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMLocator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DOMLocator

public interface DOMLocator

DOMLocator 是一个描述位置（如发生错误的位置）的接口。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

方法摘要
int | getByteOffset() 此定位器指向的输入源中的字节偏移量；如果没有可用的字节偏移量，则为 -1。
int | getColumnNumber() 此定位器指向的列号；如果没有可用的列号，则为 -1。
int | getLineNumber() 此定位器指向的行号；如果没有可用的行号，则为 -1。
Node | getRelatedNode() 此定位器指向的节点；如果没有可用的节点，则为 null。
String | getUri() 此定位器指向的 URI；如果没有可用的 URI，则为 null。
int | getUtf16Offset() 此定位器指向的输入源中的 UTF-16 偏移量（如在 [Unicode] 和 [ISO/IEC 10646] 的 Amendment 1 中定义的那样）；如果不存在可用的 UTF-16 偏移量，则为 -1。

方法详细信息

getLineNumber

int getLineNumber()
此定位器指向的行号；如果没有可用的行号，则为 -1。

getColumnNumber

int getColumnNumber()
此定位器指向的列号；如果没有可用的列号，则为 -1。

getByteOffset

int getByteOffset()
此定位器指向的输入源中的字节偏移量；如果没有可用的字节偏移量，则为 -1。

getUtf16Offset

int getUtf16Offset()
此定位器指向的输入源中的 UTF-16 偏移量（如在 [Unicode] 和 [ISO/IEC 10646] 的 Amendment 1 中定义的那样）；如果不存在可用的 UTF-16 偏移量，则为 -1。

getRelatedNode

Node getRelatedNode()
此定位器指向的节点；如果没有可用的节点，则为 null。

getUri

String getUri()
此定位器指向的 URI；如果没有可用的 URI，则为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DOMStringList (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 DOMStringList

public interface DOMStringList

DOMStringList 接口提供对 DOMString 值的有序集合的抽象，没有定义或约束此集合是如何实现的。DOMStringList 中的项可以通过从 0 开始的整数索引访问。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

方法摘要
boolean | contains(String str) 测试一个字符串是否是此 DOMStringList 的一部分。
int | getLength() 列表中 DOMString 的数目。
String | item(int index) 返回集合中的第 index 个项。

方法详细信息

item

String item(int index)
返回集合中的第 index 个项。如果 index 大于或等于列表中的 DOMString 的数目，则此方法返回 null。

参数：
index - 集合中的索引。
返回：
DOMStringList 中第 index 个位置处的 DOMString；如果索引不是有效索引，则返回 null。

getLength

int getLength()
列表中 DOMString 的数目。有效子节点索引的范围是 0 到 length-1（包含此值）。

contains

boolean contains(String str)
测试一个字符串是否是此 DOMStringList 的一部分。

参数：
str - 要查找的字符串。
返回：
如果已经找到字符串，则返回 true；否则，返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Element (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 Element

所有超级接口：
Node
所有已知子接口：
Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement
所有已知实现类：
IIOMetadataNode
public interface Element
extends Node

Element 接口表示 HTML 或 XML 文档中的一个元素。元素可能有与它们相关的属性；由于 Element 接口继承自 Node，所以可以使用一般 Node 接口属性 attributes 来获得元素所有属性的集合。Element 接口上有通过名称获得 Attr 对象或通过名称获得属性值的方法。在 XML 中（其中的属性值可能包含实体引用），应该获得 Attr 对象来检查表示属性值的可能相当复杂的子树。另一方面，在 HTML 中（其中的所有属性都有简单的字符串值），可以使用直接访问属性值的方法，这既安全又便捷。

注：在 DOM Level 2 中，方法 normalize 是从转移到的 Node 接口继承的。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
String | getAttribute(String name) 通过名称获得属性值。
Attr | getAttributeNode(String name) 通过名称获得属性节点。
Attr | getAttributeNodeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 获得 Attr 节点。
String | getAttributeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 获得属性值。
NodeList | getElementsByTagName(String name) 以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。
NodeList | getElementsByTagNameNS(String namespaceURI, String localName) 以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。
TypeInfo | getSchemaTypeInfo() 与此元素相关的类型信息。
String | getTagName() 元素的名称。
boolean | hasAttribute(String name) 当具有给定名称的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
boolean | hasAttributeNS(String namespaceURI, String localName) 当具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
void | removeAttribute(String name) 通过名称移除一个属性。
Attr | removeAttributeNode(Attr oldAttr) 移除指定的属性节点。
void | removeAttributeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 移除属性值。
void | setAttribute(String name, String value) 添加一个新属性。
Attr | setAttributeNode(Attr newAttr) 添加新的属性节点。
Attr | setAttributeNodeNS(Attr newAttr) 添加新属性。
void | setAttributeNS(String namespaceURI, String qualifiedName, String value) 添加新属性。
void | setIdAttribute(String name, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。
void | setIdAttributeNode(Attr idAttr, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
void | setIdAttributeNS(String namespaceURI, String localName, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getTagName

String getTagName()
元素的名称。如果 Node.localName 与 null 不同，则此属性为一个限定名称。例如，在以下示例中：
 <elementExample id="demo"> ...
 </elementExample> ,
tagName 具有值 "elementExample"。注意，这在 XML 中是保留大小写的，DOM 中的所有操作也是这样。HTML DOM 以规范的大写形式返回 HTML 元素的 tagName，而不考虑源 HTML 文档中的大小写形式。

getAttribute

String getAttribute(String name)
通过名称获得属性值。

参数：
name - 要获得的属性名称。
返回：
字符串形式的 Attr 值；如果该属性没有指定值或默认值，则返回空字符串。

setAttribute

void setAttribute(String name,
                  String value)
                  throws DOMException
添加一个新属性。如果具有该名称的属性已经出现在元素中，则将其值更改为值参数的值。此值为简单的字符串；在设置它时没有对它进行解析。因此，将任何标记（如作为实体引用而被识别的语法）视为字面值文本，并且需要在写出时由实现适当转义。为了分配包含实体引用的属性值，用户必须创建一个 Attr 节点，加上所有 Text 和 EntityReference 节点，构建适当的子树，并将它作为属性值，通过 setAttributeNode 方法来分配。
要设置具有限定名称和名称空间 URI 的属性，使用 setAttributeNS 方法。

参数：
name - 要创建或更改的属性名称。
value - 以字符串形式设置的值。
抛出：
DOMException - INVALID_CHARACTER_ERR: 根据在 Document.xmlVersion 属性中指定的正在使用的 XML 版本，如果指定名称不是 XML 名称，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。

removeAttribute

void removeAttribute(String name)
                     throws DOMException
通过名称移除一个属性。如果被移除属性的默认值在 DTD 中定义，则新的属性值将在可用时随该默认值以及相应名称空间 URI、本地名称和前缀立即出现。类似地，实现可以处理其他模式的默认值，但应用程序应该使用 Document.normalizeDocument() 来保证此信息最新。
如果找不到具有此名称的属性，则此方法无效。
要通过本地名称和名称空间 URI 移除属性，使用 removeAttributeNS 方法。

参数：
name - 要移除的属性的名称。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。

getAttributeNode

Attr getAttributeNode(String name)
通过名称获得属性节点。
要通过限定名称和名称空间 URI 获得属性节点，使用 getAttributeNodeNS 方法。

参数：
name - 要获得的属性名称 (nodeName)。
返回：
返回具有指定名称 (nodeName) 的 Attr 节点；如果没有这样的属性，则返回 null。

setAttributeNode

Attr setAttributeNode(Attr newAttr)
                      throws DOMException
添加新的属性节点。如果具有该名称 (nodeName) 的属性已经出现在元素中，则用新属性替换它。用自身替换属性节点无效。
要添加具有限定名称和名称空间 URI 的新属性节点，使用 setAttributeNodeNS 方法。

参数：
newAttr - 要添加到属性列表的 Attr 节点。
返回：
如果用 newAttr 属性替换现有属性，则返回被替换的 Attr 节点；否则返回 null。
抛出：
DOMException - WRONG_DOCUMENT_ERR: 如果 newAttr 是从不同的文档创建的，不是从创建该元素的文档创建的，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。
INUSE_ATTRIBUTE_ERR: 如果 newAttr 已经是另一个 Element 对象的属性，则引发此异常。DOM 用户必须显式地克隆 Attr 节点，以便在其他元素中重新使用它们。

removeAttributeNode

Attr removeAttributeNode(Attr oldAttr)
                         throws DOMException
移除指定的属性节点。如果在 DTD 中定义了被移除 Attr 节点的默认值，则新的节点将在可用时随该默认值以及相应名称空间 URI、本地名称和前缀一起立即出现。类似地，实现可以处理其他模式的默认值，但应用程序应该使用 Document.normalizeDocument() 来保证此信息最新。

参数：
oldAttr - 从属性列表中移除的 Attr 节点。
返回：
被移除的 Attr 节点。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。
NOT_FOUND_ERR: 如果 oldAttr 不是该元素的属性，则引发此异常。

getElementsByTagName

NodeList getElementsByTagName(String name)
以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。

参数：
name - 要匹配的标记的名称。特殊值 "*" 匹配所有标记。
返回：
匹配的 Element 节点列表。

getAttributeNS

String getAttributeNS(String namespaceURI,
                      String localName)
                      throws DOMException
通过本地名称和名称空间 URI 获得属性值。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
namespaceURI - 要获得的属性的名称空间 URI。
localName - 要获得的属性的本地名称。
返回：
字符串形式的 Attr 值；如果该属性没有指定值或默认值，则返回空字符串。
抛出：
DOMException - NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档中公开的语言不支持 XML 名称空间（例如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

setAttributeNS

void setAttributeNS(String namespaceURI,
                    String qualifiedName,
                    String value)
                    throws DOMException
添加新属性。如果具有相同本地名称和名称空间 URI 的属性已经出现在元素上，则将其前缀更改为 qualifiedName 的前缀部分，并将其值更改为 value 参数。此值为简单的字符串；在设置它时没有对它进行解析。因此，将任何标记（如作为实体引用识别的语法）视为字面值文本，并且需要在写出时由实现适当转义。为了分配包含实体引用的属性值，用户必须创建一个 Attr 节点，加上所有 Text 和 EntityReference 节点，构建适当的子树，并使用 setAttributeNodeNS 或 setAttributeNode 作为属性的值分配它。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
namespaceURI - 要创建或更改的属性的名称空间 URI。
qualifiedName - 要创建或更改的属性的限定名称。
value - 以字符串形式设置的值。
抛出：
DOMException - INVALID_CHARACTER_ERR: 根据在 Document.xmlVersion 属性中指定的正在使用的 XML 版本,如果指定名称不是 XML 名称，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的，则引发此异常。
NAMESPACE_ERR: 在以下情况下引发此异常：如果根据 XML 规范中的名称空间，qualifiedName 是错误格式的；如果 qualifiedName 有前缀且 namespaceURI 为 null；如果 qualifiedName 有名为 "xml" 的前缀且 namespaceURI 不同于 "http://www.w3.org/XML/1998/namespace"；如果 qualifiedName 或其前缀为 "xmlns" 且 namespaceURI 不同于 "http://www.w3.org/2000/xmlns/"；或者如果 namespaceURI 为 "http://www.w3.org/2000/xmlns/" 且 qualifiedName 及其前缀都不是 "xmlns"。
NOT_SUPPORTED_ERR:如果实现不支持功能 "XML" 且文档中公开的语言不支持 XML 名称空间（例如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

removeAttributeNS

void removeAttributeNS(String namespaceURI,
                       String localName)
                       throws DOMException
通过本地名称和名称空间 URI 移除属性值。如果被移除属性的默认值在 DTD 中定义，则新的属性值将在可用时随该默认值以及相应名称空间 URI、本地名称和前缀立即出现。类似地，实现可以处理其他模式的默认值，但应用程序应该使用 Document.normalizeDocument() 来保证此信息最新。
如果找不到具有此本地名称和名称空间 URI 的属性，则此方法无效。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
namespaceURI - 要移除的属性的名称空间 URI。
localName - 要移除的属性的本地名称。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。
NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档中公开的语言不支持 XML 名称空间（例如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

getAttributeNodeNS

Attr getAttributeNodeNS(String namespaceURI,
                        String localName)
                        throws DOMException
通过本地名称和名称空间 URI 获得 Attr 节点。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
namespaceURI - 要获得的属性的名称空间 URI。
localName - 要获得的属性的本地名称。
返回：
具有特定属性名称和名称空间 URI 的 Attr 节点；如果没有这样的属性，则返回 null。
抛出：
DOMException - NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档中公开的语言不支持 XML 名称空间（例如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

setAttributeNodeNS

Attr setAttributeNodeNS(Attr newAttr)
                        throws DOMException
添加新属性。如果具有该本地名称和该名称空间 URI 的属性已经出现在元素中，则用新的属性替换它。用自身替换属性节点无效。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
newAttr - 要添加到属性列表的 Attr 节点。
返回：
如果用 newAttr 属性替换具有相同本地名称和名称空间 URI 的现有属性，则返回被替换的 Attr 节点；否则返回 null。
抛出：
DOMException - WRONG_DOCUMENT_ERR: 如果 newAttr 是从不同的文档创建的，不是从创建该元素的文档创建的，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的，则引发此异常。
INUSE_ATTRIBUTE_ERR: 如果 newAttr 已经是另一个 Element 对象的属性，则引发此异常。DOM 用户必须显式地克隆 Attr 节点，以便在其他元素中重新使用它们。
NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档中公开的语言不支持 XML 名称空间（例如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

getElementsByTagNameNS

NodeList getElementsByTagNameNS(String namespaceURI,
                                String localName)
                                throws DOMException
以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。

参数：
namespaceURI - 要匹配的元素的名称空间 URI。特殊值 "*" 匹配所有名称空间。
localName - 要匹配的元素的本地名称。特殊值 "*" 匹配所有本地名称。
返回：
包含所有匹配的 Elements 的新 NodeList 对象。
抛出：
DOMException - NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档中公开的语言不支持 XML 名称空间（例如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

hasAttribute

boolean hasAttribute(String name)
当具有给定名称的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。

参数：
name - 要查找的属性名称。
返回：
如果具有给定名称的属性在此元素上被指定一个值或具有默认值，则返回 true；否则返回 false。
从以下版本开始：
DOM Level 2

hasAttributeNS

boolean hasAttributeNS(String namespaceURI,
                       String localName)
                       throws DOMException
当具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
namespaceURI - 要查找的属性的名称空间 URI。
localName - 要查找的属性的本地名称。
返回：
如果具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值，则返回 true；否则返回 false。
抛出：
DOMException - NOT_SUPPORTED_ERR:如果实现不支持功能 "XML" 且文档中公开的语言不支持 XML 名称空间（例如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

getSchemaTypeInfo

TypeInfo getSchemaTypeInfo()
与此元素相关的类型信息。

从以下版本开始：
DOM Level 3

setIdAttribute

void setIdAttribute(String name,
                    boolean isId)
                    throws DOMException
如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。此方法影响 Attr.isId 的值和 Document.getElementById 的行为，但不更改可能正在使用的任何模式；需要特别指出的是，此方法不影响指定 Attr 节点的 Attr.schemaTypeInfo。使用参数 isId 的值 false 来取消将属性声明为用户确定的 ID 属性。
要通过本地名称和名称空间 URI 指定属性，使用 setIdAttributeNS 方法。

参数：
name - 属性名称。
isId - 属性是否是 ID 类型。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的，则引发此异常。
NOT_FOUND_ERR:如果指定的节点不是此元素的属性，则引发此异常。
从以下版本开始：
DOM Level 3

setIdAttributeNS

void setIdAttributeNS(String namespaceURI,
                      String localName,
                      boolean isId)
                      throws DOMException
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。此方法影响 Attr.isId 的值和 Document.getElementById 的行为，但不更改可能正在使用的任何模式；需要特别指出的是，此方法不影响指定 Attr 节点的 Attr.schemaTypeInfo。使用参数 isId 的值 false 来取消将属性声明为用户确定的 ID 属性。

参数：
namespaceURI - 属性的名称空间 URI。
name - 属性的本地名称。
isId - 属性是否是 ID 类型。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的，则引发此异常。
NOT_FOUND_ERR: 如果指定的节点不是此元素的属性，则引发此异常。
从以下版本开始：
DOM Level 3

setIdAttributeNode

void setIdAttributeNode(Attr idAttr,
                        boolean isId)
                        throws DOMException
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。此方法影响 Attr.isId 的值和 Document.getElementById 的行为，但不更改可能正在使用的任何模式；需要特别指出的是，此方法不影响指定 Attr 节点的 Attr.schemaTypeInfo。使用参数 isId 的值 false 来取消将属性声明为用户确定的 ID 属性。

参数：
idAttr - 属性节点。
isId - 属性是否是 ID 类型。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。
NOT_FOUND_ERR: 如果指定的节点不是此元素的属性，则引发此异常。
从以下版本开始：
DOM Level 3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Entity (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 Entity

所有超级接口：
Node
public interface Entity
extends Node

此接口表示在 XML 文档中解析和未解析的已知实体。注意，这模仿该实体本身而不是 实体声明。

从 Node 继承的 nodeName 属性包含实体的名称。

XML 处理器可能选择在结构模型传入 DOM 之前完全扩展实体；在此情况下，文档树中将不会有 EntityReference 节点。

XML 不要求非验证 XML 处理器读取和处理在外部子集中所做的或在参数实体中声明的实体声明。这意味着在外部子集中声明的解析实体不需要通过应用程序的某些类进行扩展，而且意味着该实体的替换文本可能不可用。当 替换文本 可用时，相应 Entity 节点的子列表表示该替换值的结构。否则，子列表为空。

DOM Level 3 不支持编辑 Entity 节点；如果用户希望更改 Entity 的内容，则必须通过克隆 Entity 的内容在结构模型中替换每个相关 EntityReference 节点，然后再对这些克隆中的每一个进行必要的更改。Entity 节点及其所有后代都为只读的。

Entity 节点没有任何父节点。

注：如果该实体包含未绑定的名称空间前缀，则 Entity 节点子树中相应节点的 namespaceURI 为 null。对于指向此实体的 EntityReference 节点的同一名称空间 URI 同样是这样，这时使用 Document 接口的 createEntityReference 方法创建这些节点。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
String | getInputEncoding() 当实体为外部解析实体时，它是在解析时用于此实体的指定编码的属性。
String | getNotationName() 对于未解析实体，则为该实体的表示法名称。
String | getPublicId() 如果已指定，则为与实体相关的公共标识符；否则为 null。
String | getSystemId() 如果已指定，则为与实体相关的系统标识符；否则为 null。
String | getXmlEncoding() 当实体为外部解析实体时，它是作为文本声明的一部分指定此实体的编码的属性。
String | getXmlVersion() 当实体为外部解析实体时，它是作为文本声明的一部分指定此实体版本号的属性。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getPublicId

String getPublicId()
如果已指定，则为与实体相关的公共标识符；否则为 null。

getSystemId

String getSystemId()
如果已指定，则为与实体相关的系统标识符；否则为 null。这可以是绝对 URI，也可以不是。

getNotationName

String getNotationName()
对于未解析实体，则为该实体的表示法名称。对于解析实体，此值为 null。

getInputEncoding

String getInputEncoding()
当实体为外部解析实体时，它是在解析时用于此实体的指定编码的属性。如果实体是内部子集中的实体，或如果未知，则此属性为 null。

从以下版本开始：
DOM Level 3

getXmlEncoding

String getXmlEncoding()
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体的编码的属性。否则，此属性为 null。

从以下版本开始：
DOM Level 3

getXmlVersion

String getXmlVersion()
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体版本号的属性。否则，此属性为 null。

从以下版本开始：
DOM Level 3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EntityReference (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 EntityReference

所有超级接口：
Node
public interface EntityReference
extends Node

EntityReference 节点可以用来在树中表示实体引用。注意，对字符引用和对预定义实体的引用都被视为通过 HTML 或 XML 处理器扩展，以便字符用 Unicode 等效形式表示，而不是通过实体引用表示。此外，XML 处理器可以在构建 Document 时完全扩展对实体的引用，而不是提供 EntityReference 节点。如果它确实提供这样的节点，则对于表示已知实体的引用的 EntityReference 节点而言，存在 Entity，且 EntityReference 节点的子树为 Entity 节点子树的副本。但是，在实体包含未绑定名称空间前缀时，后者不可以为 true。在此情况下，因为名称空间前缀的解析取决于实体引用的位置，可能要将 EntityReference 节点的后代绑定到不同的名称空间 URI。当 EntityReference 节点表示对未知实体的引用时，该节点没有子节点且替换值（例如由 Attr.value 使用时）为空。

对于 Entity 节点而言，EntityReference 节点及其所有后代都是只读的。

注：在扩展实体引用之后执行规范化（例如在 XML 1.0 和 XML Schema 中）时，EntityReference 节点可能导致元素内容和属性值规范化问题。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamedNodeMap (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 NamedNodeMap

public interface NamedNodeMap

实现 NamedNodeMap 接口的对象用于表示可以通过名称访问的节点的集合。注意，NamedNodeMap 不从 NodeList 继承；不以任何特定的顺序维护 NamedNodeMaps。在实现 NamedNodeMap 的对象中包含的对象还可以通过顺序索引进行访问，但只允许方便地枚举 NamedNodeMap 的内容，并不意味着 DOM 指定这些节点的顺序。

DOM 中的 NamedNodeMap 对象是活动的。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

方法摘要
int | getLength() 此映射中的节点数。
Node | getNamedItem(String name) 检索通过名称指定的节点。
Node | getNamedItemNS(String namespaceURI, String localName) 检索通过本地名称和名称空间 URI 指定的节点。
Node | item(int index) 返回映射中第 index 个项。
Node | removeNamedItem(String name) 移除通过名称指定的节点。
Node | removeNamedItemNS(String namespaceURI, String localName) 移除通过本地名称和名称空间 URI 指定的节点。
Node | setNamedItem(Node arg) 使用 nodeName 属性添加节点。
Node | setNamedItemNS(Node arg) 使用其 namespaceURI 和 localName 添加节点。

方法详细信息

getNamedItem

Node getNamedItem(String name)
检索通过名称指定的节点。

参数：
name - 要检索的节点的 nodeName。
返回：
具有指定 nodeName 的 Node（类型不限）；如果它不标识此映射中的任何节点，则返回 null。

setNamedItem

Node setNamedItem(Node arg)
                  throws DOMException
使用 nodeName 属性添加节点。如果具有此名称的节点已经出现在此映射中，则用新的节点替换它。用自身替换节点无效。
由于 nodeName 属性用于派生必须在其下存储节点的名称，因为名称可能冲突无法存储多个某种类型的节点（具有“特殊的”字符串值的那些节点）。这被视为优于允许为节点起别名。

参数：
arg - 在此映射中存储的节点。以后该节点可使用其 nodeName 属性的值来访问。
返回：
如果新 Node 替换现有节点，则返回被替换的 Node；否则返回 null。
抛出：
DOMException - WRONG_DOCUMENT_ERR: 如果 arg 是从不同的文档创建的，不是从创建此映射的文档创建的，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此映射为只读的，则引发此异常。
INUSE_ATTRIBUTE_ERR: 如果 arg 为已经是另一 Element 对象的属性的 Attr，则引发此异常。DOM 用户必须显式地克隆 Attr 节点，以便在其他元素中重新使用它们。
HIERARCHY_REQUEST_ERR: 如果试图添加不属于此 NamedNodeMap 的节点，则引发此异常。这样的例子包括试图将某些内容而不是 Attr 节点添加到属性的元素映射，或者将非实体节点添加到实体的 DocumentType 映射。

removeNamedItem

Node removeNamedItem(String name)
                     throws DOMException
移除通过名称指定的节点。当此映射包含连接到元素的属性时，如果知道移除的属性具有默认值，则在可用时立即出现包括默认值以及相应名称空间 URI、本地名称和前缀的属性。

参数：
name - 要移除的节点的 nodeName。
返回：
如果存在具有这样的名称的节点，则返回从此映射移除的节点。
抛出：
DOMException - NOT_FOUND_ERR: 如果此映射中不存在命名为 name 的节点，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此映射为只读的，则引发此异常。

item

Node item(int index)
返回映射中第 index 个项。如果 index 大于或等于此映射中的节点数，则这将返回 null。

参数：
index - 此映射中的索引。
返回：
该映射中第 index 个位置处的节点；如果是无效索引，则返回 null。

getLength

int getLength()
此映射中的节点数。有效子节点索引的范围为 0 到 length-1。

getNamedItemNS

Node getNamedItemNS(String namespaceURI,
                    String localName)
                    throws DOMException
检索通过本地名称和名称空间 URI 指定的节点。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
namespaceURI - 要检索的节点的名称空间 URI。
localName - 要检索的节点的本地名称。
返回：
具有指定本地名称和名称空间 URI 的 Node（类型不限）；如果它们不标识此映射中的任何节点，则返回 null。
抛出：
DOMException - NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档中公开的语言不支持 XML 名称空间（如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

setNamedItemNS

Node setNamedItemNS(Node arg)
                    throws DOMException
使用其 namespaceURI 和 localName 添加节点。如果具有该名称空间 URI 和该本地名称的节点已经出现在此映射中，则用新节点替换它。用自身替换节点无效。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
arg - 存储在此映射中的节点。以后该节点可使用其 namespaceURI 和 localName 属性的值进行访问。
返回：
如果新 Node 替换现有节点，则返回被替换的 Node；否则返回 null。
抛出：
DOMException - WRONG_DOCUMENT_ERR: 如果 arg 是从不同的文档创建的，不是从创建此映射的文档创建的，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此映射为只读的，则引发此异常。
INUSE_ATTRIBUTE_ERR: 如果 arg 为已经是另一 Element 对象的属性的 Attr，则引发此异常。DOM 用户必须显式地克隆 Attr 节点，以便在其他元素中重新使用它们。
HIERARCHY_REQUEST_ERR: 如果试图添加不属于此 NamedNodeMap 的节点，则引发此异常。这样的例子包括试图将某些内容而不是 Attr 节点添加到属性的元素映射，或者将非实体节点添加到实体的 DocumentType 映射。
NOT_SUPPORTED_ERR:如果实现不支持功能 "XML" 且文档公开的语言不支持 XML 名称空间（如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2

removeNamedItemNS

Node removeNamedItemNS(String namespaceURI,
                       String localName)
                       throws DOMException
移除通过本地名称和名称空间 URI 指定的节点。此映射中包含连接到一个元素的属性时，可能知道移除的属性具有默认值，由 Node 接口的属性返回。如果是这样，当适当时包含默认值以及相应名称空间 URI、本地名称和前缀的属性立即出现。
按照 [XML Namespaces]，如果应用程序希望没有名称空间，则它们必须将值 null 用作方法的 namespaceURI 参数。

参数：
namespaceURI - 要移除的节点的名称空间 URI。
localName - 要移除的节点的本地名称。
返回：
如果存在具有这样的本地名称和名称空间 URI 的节点，则返回从此映射移除的节点。
抛出：
DOMException - NOT_FOUND_ERR:如果此映射中存在具有指定 namespaceURI 和 localName 的节点，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此映射为只读的，则引发此异常。
NOT_SUPPORTED_ERR: 如果实现不支持功能 "XML" 且文档公开的语言不支持 XML 名称空间（如 [HTML 4.01]），则可能引发此异常。
从以下版本开始：
DOM Level 2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameList (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 NameList

public interface NameList

NameList 接口提供对并行的名称和名称空间值对（可以为 null 值）的有序集合的抽象，无需定义或约束如何实现此集合。NameList 中的项可以通过从 0 开始的整数索引进行访问。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

方法摘要
boolean | contains(String str) 测试名称是否是此 NameList 中的一部分。
boolean | containsNS(String namespaceURI, String name) 测试 namespaceURI/name 对是否是此 NameList 中的一部分。
int | getLength() 列表中的对（名称和名称空间 URI）数。
String | getName(int index) 返回集合中的第 index 个名称项。
String | getNamespaceURI(int index) 返回集合中的第 index 个 namespaceURI 项。

方法详细信息

getName

String getName(int index)
返回集合中的第 index 个名称项。

参数：
index - 集合中的索引。
返回：
NameList 中的第 index 个位置处的名称；如果不存在指定索引的名称，或如果索引超出范围，则返回 null。

getNamespaceURI

String getNamespaceURI(int index)
返回集合中的第 index 个 namespaceURI 项。

参数：
index - 集合中的索引。
返回：
NameList 中的第 index 个位置处的名称空间 URI；如果不存在指定索引的名称，或如果索引超出范围，则返回 null。

getLength

int getLength()
列表中的对（名称和名称空间 URI）数。有效子节点索引的范围是 0 到 length-1（包含此值）。

contains

boolean contains(String str)
测试名称是否是此 NameList 中的一部分。

参数：
str - 要查找的名称。
返回：
如果已经找到名称，则返回 true；否则，返回 false。

containsNS

boolean containsNS(String namespaceURI,
                   String name)
测试 namespaceURI/name 对是否是此 NameList 中的一部分。

参数：
namespaceURI - 要查找的名称空间 URI。
name - 要查找的名称。
返回：
如果已经找到 namespaceURI/name 对，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Node (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 Node

所有已知子接口：
Attr, CDATASection, CharacterData, Comment, Detail, DetailEntry, Document, DocumentFragment, DocumentType, Element, Entity, EntityReference, Node, Notation, ProcessingInstruction, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text, Text
所有已知实现类：
IIOMetadataNode, SOAPPart
public interface Node

该 Node 接口是整个文档对象模型的主要数据类型。它表示该文档树中的单个节点。当实现 Node 接口的所有对象公开处理子节点的方法时，不是实现 Node 接口的所有对象都有子节点。例如，Text 节点可能没有子节点，且将子节点添加到这样的节点将导致引发 DOMException。

包括属性 nodeName、nodeValue 和 attributes 作为一种获取节点信息的机制，无需向下强制转换为特定的派生接口。在没有对特定的 nodeType（如 Element 的 nodeValue 或 Comment 的 attributes）的属性的明显映射的情况下，这将返回 null。注意，特定的接口可能包含其他更方便的机制来获取和设置相关信息。

nodeName、nodeValue 和 attributes 的值将根据以下节点类型的不同而不同。

Interface | nodeName | nodeValue | attributes
Attr | 与 Attr.name 相同 | 与 Attr.value 相同 | null
CDATASection | "#cdata-section" | 与 CharacterData.data 相同，CDATA 节的内容 | null
Comment | "#comment" | 与 CharacterData.data 相同，该注释的内容 | null
Document | "#document" | null | null
DocumentFragment | "#document-fragment" | null | null
DocumentType | 与 DocumentType.name 相同 | null | null
Element | 与 Element.tagName 相同 | null | NamedNodeMap
Entity | entity name | null | null
EntityReference | 引用的实体名称 | null | null
Notation | notation name | null | null
ProcessingInstruction | 与 ProcessingInstruction.target 相同 | 与 ProcessingInstruction.data 相同 | null
Text | "#text" | 与 CharacterData.data 相同，该文本节点的内容 | null

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
static short | ATTRIBUTE_NODE 该节点为 Attr。
static short | CDATA_SECTION_NODE 该节点为 CDATASection。
static short | COMMENT_NODE 该节点为 Comment。
static short | DOCUMENT_FRAGMENT_NODE 该节点为 DocumentFragment。
static short | DOCUMENT_NODE 该节点为 Document。
static short | DOCUMENT_POSITION_CONTAINED_BY 引用节点包含该节点。
static short | DOCUMENT_POSITION_CONTAINS 该节点包含引用节点。
static short | DOCUMENT_POSITION_DISCONNECTED 两个节点断开连接。
static short | DOCUMENT_POSITION_FOLLOWING 该节点在引用节点之后。
static short | DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC 对前后位置的确定是特定于实现的。
static short | DOCUMENT_POSITION_PRECEDING 第二个节点在引用节点之前。
static short | DOCUMENT_TYPE_NODE 该节点为 DocumentType。
static short | ELEMENT_NODE 该节点为 Element。
static short | ENTITY_NODE 该节点为 Entity。
static short | ENTITY_REFERENCE_NODE 该节点为 EntityReference。
static short | NOTATION_NODE 该节点为 Notation。
static short | PROCESSING_INSTRUCTION_NODE 该节点为 ProcessingInstruction。
static short | TEXT_NODE 该节点为 Text 节点。
方法摘要
Node | appendChild(Node newChild) 将节点 newChild 添加到此节点的子节点列表的末尾。
Node | cloneNode(boolean deep) 返回此节点的副本，即允当节点的一般复制构造方法。
short | compareDocumentPosition(Node other) 就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。
NamedNodeMap | getAttributes() 包含此节点的属性的 NamedNodeMap（如果它是 Element）；否则为 null。
String | getBaseURI() 此节点的绝对基 URI；如果实现不能获得绝对 URI，则为 null。
NodeList | getChildNodes() 包含此节点的所有子节点的 NodeList。
Object | getFeature(String feature, String version) 此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。
Node | getFirstChild() 此节点的第一个子节点。
Node | getLastChild() 此节点的最后一个节点。
String | getLocalName() 返回此节点限定名称的本地部分。
String | getNamespaceURI() 此节点的名称空间 URI；如果它未被指定，则返回 null（参见）。
Node | getNextSibling() 直接在此节点之后的节点。
String | getNodeName() 此节点的名称，取决于其类型；参见上表。
short | getNodeType() 表示基础对象的类型的节点，如上所述。
String | getNodeValue() 此节点的值，取决于其类型；参见上表。
Document | getOwnerDocument() 与此节点相关的 Document 对象。
Node | getParentNode() 此节点的父节点。
String | getPrefix() 此节点的名称空间前缀；如果它未被指定，则为 null。
Node | getPreviousSibling() 直接在此节点之前的节点。
String | getTextContent() 此属性返回此节点及其后代的文本内容。
Object | getUserData(String key) 检索与此节点上的某个键相关联的对象。
boolean | hasAttributes() 返回此节点（如果它是一个元素）是否具有任何属性。
boolean | hasChildNodes() 返回此节点是否具有任何子节点。
Node | insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
boolean | isDefaultNamespace(String namespaceURI) 此方法检查指定的 namespaceURI 是否是默认名称空间。
boolean | isEqualNode(Node arg) 测试两个节点是否相等。
boolean | isSameNode(Node other) 返回此节点是否是与给定节点相同的节点。
boolean | isSupported(String feature, String version) 测试 DOM 实现是否实现特定功能，且该功能是否受此节点支持，如下所述。
String | lookupNamespaceURI(String prefix) 从此节点开始，查找与给定前缀相关的名称空间 URI。
String | lookupPrefix(String namespaceURI) 从此节点开始，查找与给定名称空间 URI 相关的前缀。
void | normalize() 将此 Node 之下完整的深层子树中所有 Text 节点（包括属性节点）放入只有结构（如元素、注释、处理指令、CDATA 节和实体引用）分隔 Text 节点的“常规”形式，也就是说，既没有相邻的 Text 节点，也没有空 Text 节点。
Node | removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | replaceChild(Node newChild, Node oldChild) 将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
void | setNodeValue(String nodeValue) 此节点的值，取决于其类型；参见上表。
void | setPrefix(String prefix) 此节点的名称空间前缀；如果未指定，则为 null。
void | setTextContent(String textContent) 此属性返回此节点及其后代的文本内容。
Object | setUserData(String key, Object data, UserDataHandler handler) 将对象与此节点上的键相关联。

字段详细信息

ELEMENT_NODE

static final short ELEMENT_NODE
该节点为 Element。

另请参见：
常量字段值

ATTRIBUTE_NODE

static final short ATTRIBUTE_NODE
该节点为 Attr。

另请参见：
常量字段值

TEXT_NODE

static final short TEXT_NODE
该节点为 Text 节点。

另请参见：
常量字段值

CDATA_SECTION_NODE

static final short CDATA_SECTION_NODE
该节点为 CDATASection。

另请参见：
常量字段值

ENTITY_REFERENCE_NODE

static final short ENTITY_REFERENCE_NODE
该节点为 EntityReference。

另请参见：
常量字段值

ENTITY_NODE

static final short ENTITY_NODE
该节点为 Entity。

另请参见：
常量字段值

PROCESSING_INSTRUCTION_NODE

static final short PROCESSING_INSTRUCTION_NODE
该节点为 ProcessingInstruction。

另请参见：
常量字段值

COMMENT_NODE

static final short COMMENT_NODE
该节点为 Comment。

另请参见：
常量字段值

DOCUMENT_NODE

static final short DOCUMENT_NODE
该节点为 Document。

另请参见：
常量字段值

DOCUMENT_TYPE_NODE

static final short DOCUMENT_TYPE_NODE
该节点为 DocumentType。

另请参见：
常量字段值

DOCUMENT_FRAGMENT_NODE

static final short DOCUMENT_FRAGMENT_NODE
该节点为 DocumentFragment。

另请参见：
常量字段值

NOTATION_NODE

static final short NOTATION_NODE
该节点为 Notation。

另请参见：
常量字段值

DOCUMENT_POSITION_DISCONNECTED

static final short DOCUMENT_POSITION_DISCONNECTED
两个节点断开连接。断开连接的节点之间的顺序始终特定于实现。

另请参见：
常量字段值

DOCUMENT_POSITION_PRECEDING

static final short DOCUMENT_POSITION_PRECEDING
第二个节点在引用节点之前。

另请参见：
常量字段值

DOCUMENT_POSITION_FOLLOWING

static final short DOCUMENT_POSITION_FOLLOWING
该节点在引用节点之后。

另请参见：
常量字段值

DOCUMENT_POSITION_CONTAINS

static final short DOCUMENT_POSITION_CONTAINS
该节点包含引用节点。包含的节点也总是在前面。

另请参见：
常量字段值

DOCUMENT_POSITION_CONTAINED_BY

static final short DOCUMENT_POSITION_CONTAINED_BY
引用节点包含该节点。包含的节点也总是在后面。

另请参见：
常量字段值

DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC

static final short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC
对前后位置的确定是特定于实现的。

另请参见：
常量字段值
方法详细信息

getNodeName

String getNodeName()
此节点的名称，取决于其类型；参见上表。

getNodeValue

String getNodeValue()
                    throws DOMException
此节点的值，取决于其类型；参见上表。当将它定义为 null 时，设置它无效，包括节点为只读的情况。

抛出：
DOMException - DOMSTRING_SIZE_ERR: 在它返回的字符多于实现平台上 DOMString 变量中适合的字符时引发此异常。

setNodeValue

void setNodeValue(String nodeValue)
                  throws DOMException
此节点的值，取决于其类型；参见上表。当将它定义为 null 时，设置它无效，包括节点为只读的情况。

抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 当节点为只读且未将它定义为 null 时引发此异常。

getNodeType

short getNodeType()
表示基础对象的类型的节点，如上所述。

getParentNode

Node getParentNode()
此节点的父节点。所有节点（除 Attr、Document、DocumentFragment、Entity 和 Notation）都可以有父节点。但是，如果刚创建节点且尚未添加到树，或如果已经从树中移除了它，此值为 null。

getChildNodes

NodeList getChildNodes()
包含此节点的所有子节点的 NodeList。如果不存在子节点，则这是不包含节点的 NodeList。

getFirstChild

Node getFirstChild()
此节点的第一个子节点。如果没有这样的节点，则返回 null。

getLastChild

Node getLastChild()
此节点的最后一个节点。如果没有这样的节点，则返回 null。

getPreviousSibling

Node getPreviousSibling()
直接在此节点之前的节点。如果没有这样的节点，则返回 null。

getNextSibling

Node getNextSibling()
直接在此节点之后的节点。如果没有这样的节点，则返回 null。

getAttributes

NamedNodeMap getAttributes()
包含此节点的属性的 NamedNodeMap（如果它是 Element）；否则为 null。

getOwnerDocument

Document getOwnerDocument()
与此节点相关的 Document 对象。这也是用于创建新节点的 Document 对象。当此节点为 Document 或未与任何 Document 一起使用的 DocumentType 时，返回 null。

从以下版本开始：
DOM Level 2

insertBefore

Node insertBefore(Node newChild,
                  Node refChild)
                  throws DOMException
在现有子节点 refChild 之前插入节点 newChild。如果 refChild 为 null，则将 newChild 插入到子节点列表的末尾。
如果 newChild 为 DocumentFragment 对象，则以同样的顺序将其所有节点插入 refChild 之前。如果 newChild 已经存在于树中，则首先移除它。

注：将一个节点插入本身之前与实现有关。

参数：
newChild - 要插入的节点。
refChild - 引用节点，即必须在其前插入新节点的节点。
返回：
要插入的节点。
抛出：
DOMException - HIERARCHY_REQUEST_ERR:在以下情况下引发此异常：如果此节点为不允许 newChild 节点类型的子节点的类型；或者如果要插入的节点为此节点的一个祖先或此节点本身；或者如果此节点为 Document 类型且 DOM 应用程序试图插入第二个 DocumentType 或 Element 节点。
WRONG_DOCUMENT_ERR:如果 newChild 是从不同的文档创建的，不是从创建此节点的文档创建的，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的，或者如果要插入的节点的父节点为只读的，则引发此异常。
NOT_FOUND_ERR: 如果 refChild 不是此节点的子节点。
NOT_SUPPORTED_ERR: 如果此节点为 Document 类型，如果 DOM 实现不支持插入 DocumentType 或 Element 节点，则可能引发此异常。
从以下版本开始：
DOM Level 3

replaceChild

Node replaceChild(Node newChild,
                  Node oldChild)
                  throws DOMException
将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
如果 newChild 为 DocumentFragment 对象，则将 oldChild 替换为所有 DocumentFragment 子节点，它们都以相同的顺序插入。如果 newChild 已经存在于树中，则首先移除它。

注：将节点替换为它本身与实现有关。

参数：
newChild - 要在子节点列表中放入的新节点。
oldChild - 列表中被替换的节点。
返回：
替换的节点。
抛出：
DOMException - HIERARCHY_REQUEST_ERR: 在以下情况下引发此异常：如果此节点为不允许 newChild 节点类型的子节点的类型；或者如果要放入的节点为此节点的一个祖先或此节点本身；或者如果此节点为 Document 类型且替换操作的结果将第二个 DocumentType 或 Element 添加到 Document 上。
WRONG_DOCUMENT_ERR: 如果 newChild 是从不同的文档创建的，不是从创建此节点的文档创建的，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此节点或新节点的父节点为只读的，则引发此异常。
NOT_FOUND_ERR: 如果 oldChild 不是此节点的子节点，则引发此异常。
NOT_SUPPORTED_ERR: 如果此节点为 Document 类型，则如果 DOM 实现不支持替换 DocumentType 子节点或 Element 子节点，则可能引发此异常。
从以下版本开始：
DOM Level 3

removeChild

Node removeChild(Node oldChild)
                 throws DOMException
从子节点列表中移除 oldChild 所指示的子节点，并将其返回。

参数：
oldChild - 移除的节点。
返回：
移除的节点。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。
NOT_FOUND_ERR: 如果 oldChild 不是此节点的子节点。
NOT_SUPPORTED_ERR: 如果此节点为 Document 类型，则如果 DOM 实现不支持移除 DocumentType 子节点或 Element 子节点，则可能引发此异常。
从以下版本开始：
DOM Level 3

appendChild

Node appendChild(Node newChild)
                 throws DOMException
将节点 newChild 添加到此节点的子节点列表的末尾。如果 newChild 已经存在于树中，则首先移除它。

参数：
newChild - 要添加的节点。如果它是 DocumentFragment 对象，则将文档片段的整个内容移动到此节点的子列表中
返回：
添加的节点。
抛出：
DOMException - HIERARCHY_REQUEST_ERR: 在以下情况下引发此异常：如果此节点为不允许 newChild 节点类型的子节点的类型；或者如果要追加的节点为此节点的一个祖先或此节点本身；或者如果此节点为 Document 类型且 DOM 应用程序试图追加第二个 DocumentType 或 Element 节点。
WRONG_DOCUMENT_ERR: 如果 newChild 是从不同的文档创建的，不是从创建此节点的文档创建的，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的，或者如果要插入的节点以前的父节点为只读的，则引发此异常。
NOT_SUPPORTED_ERR: 如果 newChild 节点为 Document 节点的子节点，则如果 DOM 实现不支持移除 DocumentType 子节点或 Element 子节点，则可能引发此异常。
从以下版本开始：
DOM Level 3

hasChildNodes

boolean hasChildNodes()
返回此节点是否具有任何子节点。

返回：
如果此节点没有任何子节点，则返回 true；否则返回 false。

cloneNode

Node cloneNode(boolean deep)
返回此节点的副本，即允当节点的一般复制构造方法。副本节点没有父节点（parentNode 为 null），且没有用户数据。与导入的节点相关的用户数据不携带过来。但是，如果随相关数据一起指定了任何 UserDataHandlers，则将在此方法返回之前用适当的参数调用这些处理程序。
克隆一个 Element 将复制所有属性及其值，包括由 XML 处理器生成的用来表示默认属性的那些属性和值，但此方法不复制它包含的任何子节点，除非它是一个深层克隆。这包括此 Element 所包含的文本，因为该文本包含在子 Text 节点中。直接克隆 Attr（相对于作为 Element 克隆操作的一部分进行的克隆）将返回指定的属性（specified 为 true）。克隆一个 Attr 总是要克隆其子节点，因为它们表示其值，不管这是否是深层克隆。如果相应的 Entity 可用，则克隆 EntityReference 将自动构造其子树，不管这是否是深层克隆。克隆任何其他类型的节点只返回此节点的副本。
注意，克隆一个不可变子树会导致可变副本，但 EntityReference 克隆的子节点应为只读的。此外，还要指定未指定的 Attr 节点的克隆。并且，克隆 Document、DocumentType、Entity 和 Notation 节点与实现有关。

参数：
deep - 如果为 true，则在指定节点下递归式克隆子树；如果为 false，则仅克隆节点本身（及其属性，如果它是 Element）。
返回：
副本节点。

normalize

void normalize()
将此 Node 之下完整的深层子树中所有 Text 节点（包括属性节点）放入只有结构（如元素、注释、处理指令、CDATA 节和实体引用）分隔 Text 节点的“常规”形式，也就是说，既没有相邻的 Text 节点，也没有空 Text 节点。这可以用于确保一个文档的 DOM 视图相同，好像它是保存和重新加载的一样，并且在使用依赖特定文档树结构的操作（如 XPointer [XPointer] 查询）时此方法非常有用。如果连接到 Node.ownerDocument 的 DOMConfiguration 对象的参数 "normalize-characters" 为 true，则此方法还将完全标准化 Text 节点的字符。

注：在文档包含 CDATASections 的情况下，单独的标准化操作可能不充分，因为 XPointer 不区分 Text 节点和 CDATASection 节点。

从以下版本开始：
DOM Level 3

isSupported

boolean isSupported(String feature,
                    String version)
测试 DOM 实现是否实现特定功能，且该功能是否受此节点支持，如下所述。

参数：
feature - 要测试的功能的名称。
version - 这是要测试的功能的版本号。
返回：
如果在此节点上支持指定的功能，则返回 true；否则，返回 false。
从以下版本开始：
DOM Level 2

getNamespaceURI

String getNamespaceURI()
此节点的名称空间 URI；如果它未被指定，则返回 null（参见）。
这不是计算的值，计算的值是基于检查范围内名称空间声明的名称空间查询的结果。它只是创建时给定的名称空间 URI。
对于除 ELEMENT_NODE 和 ATTRIBUTE_NODE 之外的任何类型的节点以及使用 DOM Level 1 方法创建的节点，如 Document.createElement()，这始终为 null。

注：根据 Namespaces in XML 规范 [XML Namespaces]，属性不从它连接到的元素继承其名称空间。如果未显式给定一个属性名称空间，则它只是没有名称空间。

从以下版本开始：
DOM Level 2

getPrefix

String getPrefix()
此节点的名称空间前缀；如果它未被指定，则为 null。当将它定义为 null 时，设置它无效，包括节点为只读的情况。
注意，在允许时设置此属性将更改 nodeName 属性，它将在可用时保存限定名称，以及 Element 和 Attr 接口的 tagName 和 name 属性。
将前缀设置为 null 会使它不被指定，将它设置为空字符串与实现有关。
还要注意，更改已知具有默认值的属性的前缀不会使具有默认值和初始前缀的新属性出现，因为 namespaceURI 和 localName 没有发生变化。
对于除 ELEMENT_NODE 和 ATTRIBUTE_NODE 之外的任何类型的节点以及使用 DOM Level 1 方法创建的节点，如 Document 接口中的 createElement，这始终为 null。

从以下版本开始：
DOM Level 2

setPrefix

void setPrefix(String prefix)
               throws DOMException
此节点的名称空间前缀；如果未指定，则为 null。当将它定义为 null 时，设置它无效，包括节点为只读的情况。
注意，在允许时设置此属性将更改 nodeName 属性，它将在可用时保存限定名称，以及 Element 和 Attr 接口的 tagName 和 name 属性。
将前缀设置为 null 会使它不被指定，将它设置为空字符串与实现有关。
还要注意，更改已知具有默认值的属性的前缀不会使具有默认值和初始前缀的新属性出现，因为 namespaceURI 和 localName 不发生变化。
对于除 ELEMENT_NODE 和 ATTRIBUTE_NODE 之外的任何类型的节点以及使用 DOM Level 1 方法创建的节点，如 Document 接口中的 createElement，这始终为 null。

抛出：
DOMException - INVALID_CHARACTER_ERR: 根据在 Document.xmlVersion 属性中指定的正在使用的 XML 版本，如果指定的前缀包含非法字符，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读，则引发此异常。
NAMESPACE_ERR:在以下情况下引发此异常：如果按照 XML 规范中的名称空间，指定的 prefix 格式错误；如果此节点的 namespaceURI 为 null；如果指定的前缀为 "xml" 且此节点的 namespaceURI 不同于 "http://www.w3.org/XML/1998/namespace"；如果此节点为属性，指定前缀为 "xmlns" 且此节点的 namespaceURI 不同于 "http://www.w3.org/2000/xmlns/"；或者如果此节点为属性且此节点的 qualifiedName 为 "xmlns" [XML Namespaces]。
从以下版本开始：
DOM Level 2

getLocalName

String getLocalName()
返回此节点限定名称的本地部分。
对于除 ELEMENT_NODE 和 ATTRIBUTE_NODE 之外的任何类型的节点以及使用 DOM Level 1 方法创建的节点，如 Document.createElement()，这始终为 null。

从以下版本开始：
DOM Level 2

hasAttributes

boolean hasAttributes()
返回此节点（如果它是一个元素）是否具有任何属性。

返回：
如果此节点具有任何属性，则返回 true；否则返回 false。
从以下版本开始：
DOM Level 2

getBaseURI

String getBaseURI()
此节点的绝对基 URI；如果实现不能获得绝对 URI，则为 null。此值如描述的那样计算。但是，当 Document 支持功能 "HTML" [DOM Level 2 HTML] 时，首先使用 HTML BASE 元素（如果有）的 href 属性的值计算基 URI；否则，使用 Document 接口中的 documentURI 属性的值计算。

从以下版本开始：
DOM Level 3

compareDocumentPosition

short compareDocumentPosition(Node other)
                              throws DOMException
就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。

参数：
other - 与引用节点比较的节点。
返回：
返回相对于引用节点如何定位节点。
抛出：
DOMException - NOT_SUPPORTED_ERR: 当被比较的节点来自不同的 DOM 实现，未调整该 DOM 实现以返回一致的特定于实现的结果时。
从以下版本开始：
DOM Level 3

getTextContent

String getTextContent()
                      throws DOMException
此属性返回此节点及其后代的文本内容。将它定义为 null 时，设置它无效。设置后，移除此节点可能有的任何可能的子节点，并且如果新字符串不为空或 null，则用包含此属性设置的字符串的单个 Text 节点替换。
获取后，不执行序列化，且返回的字符串不包含任何标记。不执行空白规范化且在元素内容中返回的字符串不包含空白（参见属性 Text.isElementContentWhitespace）。类似地，设置后，也不执行解析，且以纯文本内容形式采用输入字符串。
根据下面定义的节点类型，返回的字符串由此节点的文本内容生成：
节点类型 | 内容
ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | 串接每个子节点的 textContent 属性值，不包括 COMMENT_NODE 和 PROCESSING_INSTRUCTION_NODE 节点。如果该节点没有子节点，则这是空字符串。
TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null

抛出：
DOMException - DOMSTRING_SIZE_ERR:在它返回的字符多于实现平台上 DOMString 变量中适合的字符时引发此异常。
从以下版本开始：
DOM Level 3

setTextContent

void setTextContent(String textContent)
                    throws DOMException
此属性返回此节点及其后代的文本内容。将它定义为 null 时，设置它无效。设置后，移除此节点可能有的任何可能的子节点，并且，如果新字符串不为空或 null，则用包含此属性设置的字符串的单个 Text 节点替换。
获取后，不执行序列化，且返回的字符串不包含任何标记。不执行空白规范化，且返回的字符串在元素内容中不包含空白（参见属性 Text.isElementContentWhitespace）。类似地，设置后，也不执行解析，且以纯文本内容形式采用输入字符串。
根据下面定义的节点类型，返回的字符串由此节点的文本内容生成：
节点类型 | 内容
ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | 串接每个子节点的 textContent 属性值，不包括 COMMENT_NODE 和 PROCESSING_INSTRUCTION_NODE 节点。如果该节点没有子节点，则这是空字符串。
TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null

抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 节点为只读的时引发此异常。
从以下版本开始：
DOM Level 3

isSameNode

boolean isSameNode(Node other)
返回此节点是否是与给定节点相同的节点。
此方法提供一种方法来确定由实现返回的两个 Node 引用是否引用同一个对象。当两个 Node 引用引用同一个对象时，即使是通过代理，也可能完全可交换地使用这些引用，例如所有属性都有相同的值且在任何引用上调用同一个 DOM 方法总是起完全相同的作用。

参数：
other - 要测试的节点。
返回：
如果节点相同，则返回 true；否则，返回 false。
从以下版本开始：
DOM Level 3

lookupPrefix

String lookupPrefix(String namespaceURI)
从此节点开始，查找与给定名称空间 URI 相关的前缀。此方法忽略默认名称空间声明。
参见此方法使用的算法的详细信息。

参数：
namespaceURI - 要查找的名称空间 URI。
返回：
如果已找到，则返回相关的名称空间前缀；如果未找到任何前缀，则返回 null。如果一个以上的前缀与名称空间前缀相关，则返回的名称空间前缀与实现有关。
从以下版本开始：
DOM Level 3

isDefaultNamespace

boolean isDefaultNamespace(String namespaceURI)
此方法检查指定的 namespaceURI 是否是默认名称空间。

参数：
namespaceURI - 要查找的名称空间 URI。
返回：
如果指定的 namespaceURI 为默认名称空间，则返回 true；否则，返回 false。
从以下版本开始：
DOM Level 3

lookupNamespaceURI

String lookupNamespaceURI(String prefix)
从此节点开始，查找与给定前缀相关的名称空间 URI。
有关此方法使用的算法的详细信息，请参见。

参数：
prefix - 要查找的前缀。如果此参数为 null，则此方法将返回默认的名称空间 URI（如果有）。
返回：
返回相关的名称空间 URI；如果未找到，则返回 null。
从以下版本开始：
DOM Level 3

isEqualNode

boolean isEqualNode(Node arg)
测试两个节点是否相等。
此方法测试节点的相等性，不是测试是否相同（即两个节点是否为对同一对象的引用），相同性可以使用 Node.isSameNode() 测试。所有相同的节点也将相等，尽管反之则不然。
当且仅当满足以下条件时，两个节点才相等：
  • 这两个节点属于同一类型。
  • 以下字符串属性相等：nodeName、localName、namespaceURI、prefix、nodeValue。也就是说：它们都为 null，或者它们具有相同的长度且是字符相等的字符。
  • attributes NamedNodeMaps 相等。也就是说：它们都为 null，或者它们具有相同的长度，且对于一个映射中存在的每个节点来说，相应在另一个映射中有一个节点并且相等，尽管不是必须在同一个索引处。
  • childNodes NodeLists 相等。也就是说：它们都为 null，或者它们具有相同的长度且在同一索引处包含相等的节点。注意，规范化可以影响相等性；要避免这种情况，应该在比较之前标准化这些节点。

两个 DocumentType 节点要是相等，还必须满足以下条件：
  • 以下字符串属性相等：publicId、systemId、internalSubset。
  • entities NamedNodeMaps 相等。
  • notations NamedNodeMaps 相等。

另一方面，以下内容不影响相等性：ownerDocument、baseURI 和 parentNode 属性；Attr 节点的 specified 属性；Attr 和 Element 节点的 schemaTypeInfo 属性；Text 节点的 Text.isElementContentWhitespace 属性；以及在节点上注册的任何用户数据和事件侦听器。

注：通常，在相等性检查的考虑中，上面描述中未提到的任何情况都是无关紧要的。注意，此规范的未来版本可能考虑更多属性，并且期望遵守此规范的实现进行相应的更新。

参数：
arg - 与其比较相等性的节点。
返回：
如果节点相等，则返回 true；否则，返回 false。
从以下版本开始：
DOM Level 3

getFeature

Object getFeature(String feature,
                  String version)
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。该特殊对象也可以通过使用特定于绑定的强制转换方法获得，但不是必须期望这样，如文中讨论的那样。此方法还允许实现提供不支持 Node 接口的特殊对象。

参数：
feature - 所请求的功能的名称。注意，追加到功能名称的任何加号 "+" 将被忽略，因为它在此方法的上下文中无关紧要。
version - 这是要测试的功能版本号。
返回：
返回实现指定功能和版本的特定 API 的对象（如果有）；如果不存在实现与该功能相关的接口的对象，则返回 null。如果此方法返回的 DOMObject 实现 Node 接口，则它必须委托给主要核心 Node 且不返回与主要核心 Node 不一致的结果，如属性、子节点，等等。
从以下版本开始：
DOM Level 3

setUserData

Object setUserData(String key,
                   Object data,
                   UserDataHandler handler)
将对象与此节点上的键相关联。该对象以后可以通过使用相同键的调用 getUserData 从此节点检索到。

参数：
key - 将该对象与其关联的键。
data - 与给定键相关联的对象；为 null 时表示移除与任何现有的与该键的关联。
handler - 与该键关联的处理程序，或 null。
返回：
返回以前与此节点上的给定键关联的 DOMUserData；如果没有，则返回 null。
从以下版本开始：
DOM Level 3

getUserData

Object getUserData(String key)
检索与此节点上的某个键相关联的对象。必须首先通过使用相同键的调用 setUserData 将该对象设置到此节点。

参数：
key - 该对象所关联的键。
返回：
返回与此节点上的给定键关联的 DOMUserData；如果没有，则返回 null。
从以下版本开始：
DOM Level 3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NodeList (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 NodeList

所有已知实现类：
IIOMetadataNode
public interface NodeList

NodeList 接口提供对节点的有序集合的抽象，没有定义或约束如何实现此集合。DOM 中的 NodeList 对象是活动的。

NodeList 中的项可以通过从 0 开始的整数索引进行访问。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

方法摘要
int | getLength() 列表中的节点数。
Node | item(int index) 返回集合中的第 index 个项。

方法详细信息

item

Node item(int index)
返回集合中的第 index 个项。如果 index 大于或等于此列表中的节点数，则返回 null。

参数：
index - 集合中的索引。
返回：
返回该 NodeList 中 index 位置处的节点；如果索引是无效索引，则返回 null。

getLength

int getLength()
列表中的节点数。有效子节点索引的范围是 0 到 length-1（包含此值）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Notation (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 Notation

所有超级接口：
Node
public interface Notation
extends Node

此接口表示在 DTD 中声明的表示法。表示法可以通过名称声明未解析实体的格式（请参见 XML 1.0 规范 [XML 1.0] 的 4.7 节），或用于处理指令目标的格式声明（请参见 XML 1.0 规范 [XML 1.0] 的 2.6 节）。将从 Node 继承的 nodeName 属性设置为该表示法的声明名称。

DOM Core 不支持编辑 Notation 节点；因此这些节点为只读的。

Notation 节点没有父节点。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
String | getPublicId() 此表示法的公共标识符。
String | getSystemId() 此表示法的系统标识符。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getPublicId

String getPublicId()
此表示法的公共标识符。如果未指定公共标识符，则返回值为 null。

getSystemId

String getSystemId()
此表示法的系统标识符。如果未指定系统标识符，则返回值为 null。这可以是绝对 URI，也可以不是。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProcessingInstruction (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 ProcessingInstruction

所有超级接口：
Node
public interface ProcessingInstruction
extends Node

ProcessingInstruction 接口表示“处理指令”，该指令作为一种在文档的文本中保持特定于处理器的信息的方法在 XML 中使用。

不对处理指令的内容进行任何词汇检查，因此在该内容中可能有字符序列 "?>"，按照 [XML 1.0] 的 2.6 节，该序列是非法的。出现此字符序列一定会在序列化期间生成严重错误。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
String | getData() 此处理指令的内容。
String | getTarget() 此处理指令的目标。
void | setData(String data) 此处理指令的内容。
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

getTarget

String getTarget()
此处理指令的目标。XML 会将此目标定义为第一个标记，该标记紧跟在开始处理指令的标记后面。

getData

String getData()
此处理指令的内容。此内容的范围从目标之后的第一个非空白字符到紧接在 ?> 之前的字符。

setData

void setData(String data)
             throws DOMException
此处理指令的内容。此内容的范围从目标之后的第一个非空白字符到紧接在 ?> 之前的字符。

抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 节点为只读的时引发此异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Text (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 Text

所有超级接口：
CharacterData, Node
所有已知子接口：
CDATASection, Text
public interface Text
extends CharacterData

该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。如果元素的内容中没有标记，则文本包含在实现 Text 接口的单个对象中，此接口是该元素的唯一子元素。如果有标记，则将它解析为信息项（元素、注释，等等）和组成该元素的子元素列表的 Text 节点。

首先通过 DOM 使文档可用时，文本的每个块只有一个 Text 节点。用户可以创建表示给定元素的内容的相邻的 Text 节点，没有任何插入标记，但应该知道无法在 XML 或 HTML 中表示这些节点之间的分隔，因此它们（通常）不会保持在 DOM 编辑会话之间。Node.normalize() 方法为每个文本块将所有这样的相邻 Text 对象合并为单个的节点。

不对 Text 节点的内容进行任何词汇检查，并且根据节点在文档中的位置，有些字符必须在使用字符引用进行序列化期间转义；例如，在文本内容是元素或属性的一部分的字符 "<&"；文本内容是元素一部分的字符序列 "]]>"；当文本内容是属性一部分的引号字符 " 或省略符号字符 '。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
方法摘要
String | getWholeText() 返回 Text 节点（逻辑上与此节点相邻的节点）的以文档顺序串接的所有文本。
boolean | isElementContentWhitespace() 返回此文本节点是否包含 元素内容空白符，即经常所称的“可忽略的空白符”。
Text | replaceWholeText(String content) 将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。
Text | splitText(int offset) 在指定的 offset 处将此节点拆分为两个节点，并将二者作为兄弟节点保持在树中。
从接口 org.w3c.dom.CharacterData 继承的方法
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData
从接口 org.w3c.dom.Node 继承的方法
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

方法详细信息

splitText

Text splitText(int offset)
               throws DOMException
在指定的 offset 处将此节点拆分为两个节点，并将二者作为兄弟节点保持在树中。拆分之后，此节点将包含 offset 点之前的所有内容。返回相同类型的新节点，该节点包含 offset 点及其后面的所有内容。如果初始节点有父节点，则作为初始节点下一个兄弟节点插入新节点。当 offset 等于此节点的长度时，则新节点没有任何数据。

参数：
offset - 从 0 开始的16 位单元偏移量，在该位置拆分。
返回：
与此节点类型相同的新节点。
抛出：
DOMException - INDEX_SIZE_ERR: 如果指定偏移量为负或大于 data 中的 16 位单元数，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。

isElementContentWhitespace

boolean isElementContentWhitespace()
返回此文本节点是否包含 元素内容空白符，即经常所称的“可忽略的空白符”。在加载文档期间确定文本节点在元素内容中是否包含空白符，或者在使用 Document.normalizeDocument() 时是否进行验证。

从以下版本开始：
DOM Level 3

getWholeText

String getWholeText()
返回 Text 节点（逻辑上与此节点相邻的节点）的以文档顺序串接的所有文本。
例如，下面的示例中，wholeText 在包含 "bar" 的 Text 节点上时返回 "barfoo"，而在包含 "foo" 的 Text 节点上时则返回 "barfoo"。
                     +-----+
                     | <p> |
                     +-----+
                       /\
                      /  \
               /-----\    +-------+
               | bar |    | &ent; |
               \-----/    +-------+
                              |
                              |
                           /-----\
                           | foo |
                           \-----/
图：barTextNode.wholeText 的值为 "barfoo"

从以下版本开始：
DOM Level 3

replaceWholeText

Text replaceWholeText(String content)
                      throws DOMException
将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。移除包括当前节点在内的所有逻辑上相邻的文本节点，除非它是替换文本的接收方。

此方法返回接收替换文本的节点。返回的节点为：

  • null，此时替换文本为空字符串；
  • 当前节点，当前节点为只读的时除外；
  • 与在替换位置插入的当前节点类型相同（Text 或 CDATASection）的新 Text 节点。

例如，在上面的示例中，在参数中有 "yo" 的包含 "bar" 的 Text 上调用 replaceWholeText 将导致以下情况：

                     +-----+
                     | <p> |
                     +-----+
                        |
                        |
                     /-----\
                     | yo  |
                     \-----/
图：barTextNode.replaceWholeText("yo") 使用 "yo" 修改 barTextNode 的文本内容

在要移除的节点为 EntityReference 的只读的后代时，必须移除 EntityReference，而不是移除只读节点。如果要移除的任何 EntityReference 都有不是 EntityReference、Text 或 CDATASection 的后代，则在对文档进行任何修改之前，replaceWholeText 方法一定失败，并引发具有代码 NO_MODIFICATION_ALLOWED_ERR 的 DOMException。

例如，在下面的示例中，在包含 "bar" 的 Text 节点上调用 replaceWholeText 会失败，因为 EntityReference 节点 "ent" 包含无法移除的 Element 节点。

参数：
content - 替换 Text 节点的内容。
返回：
使用指定内容创建的 Text 节点。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 如果正在替换的某个 Text 节点为只读的，则引发此异常。
从以下版本开始：
DOM Level 3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeInfo (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 TypeInfo

public interface TypeInfo

TypeInfo 接口表示从 Element 或 Attr 节点引用的类型，用与文档相关的模式指定。该类型是一对名称空间 URI 和名称属性，且取决于文档的模式。

如果文档的模式为 XML DTD [XML 1.0]，则按以下方式计算值：

  • 如果此类型是从 Attr 节点引用的，则 typeNamespace 为 "http://www.w3.org/TR/REC-xml" 且 typeName 表示 [XML Information Set] 中的 [attribute type] 属性。如果没有属性声明，则 typeNamespace 和 typeName 为 null。
  • 如果此类型是从 Element 节点引用的，则 typeNamespace 和 typeName 为 null。

如果文档的模式为 XML Schema [XML Schema Part 1]，则使用后模式验证信息集贡献（也称为 PSVI 贡献）按以下方式计算值：

  • 如果 [validity] 属性存在且是“无效的” 或“未知的”，则：为声明类型的 {target namespace} 和 {name} 属性（如果可用）；否则为 null。

    注：在写入时，XML Schema 规范不要求公开声明的类型。因此，如果有效性是无效的，则 DOM 实现可能选择不提供类型信息。

  • 如果 [validity] 属性存在且是“无效的”，则：
    1. 如果 [member type definition] 存在，则：
      1. 如果 {name} 不存在，则公开 [member type definition] 属性的 {name} 和 {target namespace} 属性；
      2. 否则，公开相应匿名类型名称的名称空间和本地名称。
    2. 如果 [type definition] 属性存在：
      1. 如果 {name} 不存在，则公开 [type definition] 属性的 {name} 和 {target namespace} 属性；
      2. 否则，公开相应匿名类型名称的名称空间和本地名称。
    3. 如果 [member type definition anonymous] 存在：
      1. 如果它为 false，则公开 [member type definition name] 和 [member type definition namespace] 属性；
      2. 否则，公开相应匿名类型名称的名称空间和本地名称。
    4. 如果 [type definition anonymous] 存在：
      1. 如果它为 false，则公开 [type definition name] 和 [type definition namespace] 属性；
      2. 否则，公开相应匿名类型名称的名称空间和本地名称。

注：其他模式语言不在 W3C 的范围内，因此应该使用 TypeInfo 定义如何表示它们的类型系统。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

字段摘要
static int | DERIVATION_EXTENSION 如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示由 extension 派生出的。
static int | DERIVATION_LIST 如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示 列表。
static int | DERIVATION_RESTRICTION 如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示通过 restriction 进行的派生（如果涉及复杂的类型）或 restriction（如果涉及简单的类型）。
static int | DERIVATION_UNION 如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示 union（如果涉及简单类型）。
方法摘要
String | getTypeName() 为相关元素或属性声明的类型的名称；如果未知，则为 null。
String | getTypeNamespace() 为相关元素或属性声明的类型的名称空间；如果该元素没有声明或如果没有名称空间信息可用，则为 null。
boolean | isDerivedFrom(String typeNamespaceArg, String typeNameArg, int derivationMethod) 此方法返回引用类型定义（即在其上调用该方法的 TypeInfo）和其他类型定义（即作为参数传递的类型定义）之间是否存在派生。

字段详细信息

DERIVATION_RESTRICTION

static final int DERIVATION_RESTRICTION
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示通过 restriction 进行的派生（如果涉及复杂的类型）或 restriction（如果涉及简单的类型）。
如果其他类型定义与引用类型定义相同，或者如果遵循引用类型定义中的 {base type definition} 属性可以递归式到达其他类型定义，并且涉及的所有 derivation methods 都是限制，则引用类型定义由限制从其他类型定义中派生。

另请参见：
常量字段值

DERIVATION_EXTENSION

static final int DERIVATION_EXTENSION
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示由 extension 派生出的。
如果遵循引用类型定义中的 {base type definition} 属性可以递归式到达其他类型定义，且至少一个涉及到的 derivation methods 是扩展，则引用类型定义由扩展从其他类型定义中派生。

另请参见：
常量字段值

DERIVATION_UNION

static final int DERIVATION_UNION
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示 union（如果涉及简单类型）。
如果存在两种类型定义 T1 和 T2，T1 具有 {各种} union，而其中一个 {成员类型定义} 为 T2，则引用类型定义由 union 从其他类型定义派生，例如，引用类型定义是通过 DERIVATION_RESTRICTION 或 DERIVATION_EXTENSION 从 T1 派生的，T2 是通过 DERIVATION_RESTRICTION 从其他类型定义派生。注意，T1 可以与引用类型定义相同，T2 可以与其他类型定义相同。

另请参见：
常量字段值

DERIVATION_LIST

static final int DERIVATION_LIST
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示 列表。
如果存在两种类型定义 T1 和 T2，例如，引用类型定义由 DERIVATION_RESTRICTION 或 DERIVATION_EXTENSION 从 T1 派生，T2 由 DERIVATION_RESTRICTION 从其他类型定义派生，则引用类型定义由列表从其他类型派生，T1 具有 {各种} 列表，T2 为 {项类型定义}。注意，T1 可以与引用类型定义相同，T2 可以与其他类型定义相同。

另请参见：
常量字段值
方法详细信息

getTypeName

String getTypeName()
为相关元素或属性声明的类型的名称；如果未知，则为 null。

getTypeNamespace

String getTypeNamespace()
为相关元素或属性声明的类型的名称空间；如果该元素没有声明或如果没有名称空间信息可用，则为 null。

isDerivedFrom

boolean isDerivedFrom(String typeNamespaceArg,
                      String typeNameArg,
                      int derivationMethod)
此方法返回引用类型定义（即在其上调用该方法的 TypeInfo）和其他类型定义（即作为参数传递的类型定义）之间是否存在派生。

参数：
typeNamespaceArg - 其他类型定义的名称空间。
typeNameArg - 其他类型定义的名称。
derivationMethod - 在两种类型之间应用的派生类型和条件，如在此接口中提供的常量列表中描述的。
返回：
如果文档的模式为 DTD 或者没有与此文档相关的模式，则此方法将总是返回 false。如果文档的模式为 XML Schema，则该方法将为 true（如果按照派生参数从其他类型定义派生引用类型定义）。如果参数的值为 0（没有将 derivationMethod 参数的任何一位设置为 1），则该方法将返回 true（如果可以通过从引用类型定义递归{基本类型定义}、{项类型定义}或{成员类型定义} 组合到达其他类型定义）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UserDataHandler (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom
接口 UserDataHandler

public interface UserDataHandler

当使用 Node.setUserData() 将一个对象与节点上的键相关联时，当克隆、导入或重命名该对象关联的节点时应用程序可以提供调用的处理程序。应用程序可以使用此方法实现与它与 DOM 节点相关联的数据有关的各种行为。此接口定义该处理程序。

另请参见 Document Object Model (DOM) Level 3 Core Specification。

从以下版本开始：
DOM Level 3

字段摘要
static short | NODE_ADOPTED 使用 Document.adoptNode() 采用节点。
static short | NODE_CLONED 使用 Node.cloneNode() 克隆节点。
static short | NODE_DELETED 删除节点。
static short | NODE_IMPORTED 使用 Document.importNode() 导入节点。
static short | NODE_RENAMED 使用 Document.renameNode() 重命名节点。
方法摘要
 void handle(short operation, String key, Object data, Node src, Node dst)
每当导入或克隆为其注册此处理程序的节点时，调用此方法。

字段详细信息

NODE_CLONED

static final short NODE_CLONED
使用 Node.cloneNode() 克隆节点。

另请参见：
常量字段值

NODE_IMPORTED

static final short NODE_IMPORTED
使用 Document.importNode() 导入节点。

另请参见：
常量字段值

NODE_DELETED

static final short NODE_DELETED
删除节点。

注：在某些环境（如 Java）中，此方法可能不被支持或可能不可靠，在此情况下，实现不具备真正控制何时实际删除对象。

另请参见：
常量字段值

NODE_RENAMED

static final short NODE_RENAMED
使用 Document.renameNode() 重命名节点。

另请参见：
常量字段值

NODE_ADOPTED

static final short NODE_ADOPTED
使用 Document.adoptNode() 采用节点。

另请参见：
常量字段值
方法详细信息

handle

void handle(short operation,
            String key,
            Object data,
            Node src,
            Node dst)
每当导入或克隆为其注册此处理程序的节点时，调用此方法。
DOM 应用程序不能在 UserDataHandler 中引发异常。从处理程序抛出异常所产生的影响与 DOM 实现有关。

参数：
operation - 指定在节点上正在执行的操作的类型。
key - 指定正在为其调用此处理程序的键。
data - 指定正在为其调用此处理程序的数据。
src - 指定正在被克隆、采用、导入或重命名的节点。正在删除节点时，这为 null。
dst - 指定新创建的节点（如果有），或 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.w3c.dom (Java Platform SE 6)

 org.w3c.dom
接口
Attr
CDATASection
CharacterData
Comment
Document
DocumentFragment
DocumentType
DOMConfiguration
DOMError
DOMErrorHandler
DOMImplementation
DOMImplementationList
DOMImplementationSource
DOMLocator
DOMStringList
Element
Entity
EntityReference
NamedNodeMap
NameList
Node
NodeList
Notation
ProcessingInstruction
Text
TypeInfo
UserDataHandler
异常
DOMException


org.w3c.dom (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.w3c.dom

为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

请参见：
描述

接口摘要
Attr | Attr 接口表示 Element 对象中的属性。
CDATASection | CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。
CharacterData | CharacterData 接口使用属性集合和用于访问 DOM 中字符数据的方法扩展节点。
Comment | 此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。
Document | Document 接口表示整个 HTML 或 XML 文档。
DocumentFragment | DocumentFragment 是“轻量级”或“最小”Document 对象。
DocumentType | 每个 Document 都有 doctype 属性，该属性的值可以为 null，也可以为 DocumentType 对象。
DOMConfiguration | 该 DOMConfiguration 接口表示文档的配置，并维护一个可识别的参数表。
DOMError | DOMError 是一个描述错误的接口。
DOMErrorHandler | DOMErrorHandler 是在报告处理 XML 数据时发生的错误或在进行某些其他处理（如验证文档）时 DOM 实现可以调用的回调接口。
DOMImplementation | DOMImplementation 接口为执行独立于文档对象模型的任何特定实例的操作提供了许多方法。
DOMImplementationList | DOMImplementationList 接口提供对 DOM 实现的有序集合的抽象，没有定义或约束如何实现此集合。
DOMImplementationSource | 此接口允许 DOM 实现程序根据请求的功能和版本提供一个或多个实现，如下所述。
DOMLocator | DOMLocator 是一个描述位置（如发生错误的位置）的接口。
DOMStringList | DOMStringList 接口提供对 DOMString 值的有序集合的抽象，没有定义或约束此集合是如何实现的。
Element | Element 接口表示 HTML 或 XML 文档中的一个元素。
Entity | 此接口表示在 XML 文档中解析和未解析的已知实体。
EntityReference | EntityReference 节点可以用来在树中表示实体引用。
NamedNodeMap | 实现 NamedNodeMap 接口的对象用于表示可以通过名称访问的节点的集合。
NameList | NameList 接口提供对并行的名称和名称空间值对（可以为 null 值）的有序集合的抽象，无需定义或约束如何实现此集合。
Node | 该 Node 接口是整个文档对象模型的主要数据类型。
NodeList | NodeList 接口提供对节点的有序集合的抽象，没有定义或约束如何实现此集合。
Notation | 此接口表示在 DTD 中声明的表示法。
ProcessingInstruction | ProcessingInstruction 接口表示“处理指令”，该指令作为一种在文档的文本中保持特定于处理器的信息的方法在 XML 中使用。
Text | 该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。
TypeInfo | TypeInfo 接口表示从 Element 或 Attr 节点引用的类型，用与文档相关的模式指定。
UserDataHandler | 当使用 Node.setUserData() 将一个对象与节点上的键相关联时，当克隆、导入或重命名该对象关联的节点时应用程序可以提供调用的处理程序。

异常摘要
DOMException DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

软件包 org.w3c.dom 的描述

为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。该 Document Object Model Level 2 Core API 允许程序动态访问和更新文档的内容和结构。有关更多信息，请参阅 规范。

从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.w3c.dom 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.w3c.dom 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.DOMException

接口分层结构

  • org.w3c.dom.DOMConfiguration
  • org.w3c.dom.DOMError
  • org.w3c.dom.DOMErrorHandler
  • org.w3c.dom.DOMImplementation
  • org.w3c.dom.DOMImplementationList
  • org.w3c.dom.DOMImplementationSource
  • org.w3c.dom.DOMLocator
  • org.w3c.dom.DOMStringList
  • org.w3c.dom.NamedNodeMap
  • org.w3c.dom.NameList
  • org.w3c.dom.Node
    • org.w3c.dom.Attr
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Comment
      • org.w3c.dom.Text
        • org.w3c.dom.CDATASection
    • org.w3c.dom.Document
    • org.w3c.dom.DocumentFragment
    • org.w3c.dom.DocumentType
    • org.w3c.dom.Element
    • org.w3c.dom.Entity
    • org.w3c.dom.EntityReference
    • org.w3c.dom.Notation
    • org.w3c.dom.ProcessingInstruction
  • org.w3c.dom.NodeList
  • org.w3c.dom.TypeInfo
  • org.w3c.dom.UserDataHandler
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.w3c.dom 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.w3c.dom
的使用

使用 org.w3c.dom 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap |
org.w3c.dom.events |
org.w3c.dom.ls |

javax.imageio.metadata 使用的 org.w3c.dom 中的类
Attr
Attr 接口表示 Element 对象中的属性。
Document
Document 接口表示整个 HTML 或 XML 文档。
DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。
Element
Element 接口表示 HTML 或 XML 文档中的一个元素。
NamedNodeMap
实现 NamedNodeMap 接口的对象用于表示可以通过名称访问的节点的集合。
Node
该 Node 接口是整个文档对象模型的主要数据类型。
NodeList
NodeList 接口提供对节点的有序集合的抽象，没有定义或约束如何实现此集合。
TypeInfo
TypeInfo 接口表示从 Element 或 Attr 节点引用的类型，用与文档相关的模式指定。
UserDataHandler
当使用 Node.setUserData() 将一个对象与节点上的键相关联时，当克隆、导入或重命名该对象关联的节点时应用程序可以提供调用的处理程序。

javax.xml.bind 使用的 org.w3c.dom 中的类
Node
该 Node 接口是整个文档对象模型的主要数据类型。

javax.xml.bind.annotation 使用的 org.w3c.dom 中的类
Element
Element 接口表示 HTML 或 XML 文档中的一个元素。

javax.xml.bind.helpers 使用的 org.w3c.dom 中的类
Node
该 Node 接口是整个文档对象模型的主要数据类型。

javax.xml.crypto.dom 使用的 org.w3c.dom 中的类
Element
Element 接口表示 HTML 或 XML 文档中的一个元素。
Node
该 Node 接口是整个文档对象模型的主要数据类型。

javax.xml.crypto.dsig.dom 使用的 org.w3c.dom 中的类
Node
该 Node 接口是整个文档对象模型的主要数据类型。

javax.xml.parsers 使用的 org.w3c.dom 中的类
Document
Document 接口表示整个 HTML 或 XML 文档。
DOMImplementation
DOMImplementation 接口为执行独立于文档对象模型的任何特定实例的操作提供了许多方法。

javax.xml.soap 使用的 org.w3c.dom 中的类
Document
Document 接口表示整个 HTML 或 XML 文档。
Element
Element 接口表示 HTML 或 XML 文档中的一个元素。
Node
该 Node 接口是整个文档对象模型的主要数据类型。
Text
该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。

javax.xml.transform.dom 使用的 org.w3c.dom 中的类
Node
该 Node 接口是整个文档对象模型的主要数据类型。

javax.xml.validation 使用的 org.w3c.dom 中的类
TypeInfo
TypeInfo 接口表示从 Element 或 Attr 节点引用的类型，用与文档相关的模式指定。

org.w3c.dom 使用的 org.w3c.dom 中的类
Attr
Attr 接口表示 Element 对象中的属性。
CDATASection
CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。
CharacterData
CharacterData 接口使用属性集合和用于访问 DOM 中字符数据的方法扩展节点。
Comment
此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。
Document
Document 接口表示整个 HTML 或 XML 文档。
DocumentFragment
DocumentFragment 是“轻量级”或“最小”Document 对象。
DocumentType
每个 Document 都有 doctype 属性，该属性的值可以为 null，也可以为 DocumentType 对象。
DOMConfiguration
该 DOMConfiguration 接口表示文档的配置，并维护一个可识别的参数表。
DOMError
DOMError 是一个描述错误的接口。
DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。
DOMImplementation
DOMImplementation 接口为执行独立于文档对象模型的任何特定实例的操作提供了许多方法。
DOMImplementationList
DOMImplementationList 接口提供对 DOM 实现的有序集合的抽象，没有定义或约束如何实现此集合。
DOMLocator
DOMLocator 是一个描述位置（如发生错误的位置）的接口。
DOMStringList
DOMStringList 接口提供对 DOMString 值的有序集合的抽象，没有定义或约束此集合是如何实现的。
Element
Element 接口表示 HTML 或 XML 文档中的一个元素。
EntityReference
EntityReference 节点可以用来在树中表示实体引用。
NamedNodeMap
实现 NamedNodeMap 接口的对象用于表示可以通过名称访问的节点的集合。
Node
该 Node 接口是整个文档对象模型的主要数据类型。
NodeList
NodeList 接口提供对节点的有序集合的抽象，没有定义或约束如何实现此集合。
ProcessingInstruction
ProcessingInstruction 接口表示“处理指令”，该指令作为一种在文档的文本中保持特定于处理器的信息的方法在 XML 中使用。
Text
该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。
TypeInfo
TypeInfo 接口表示从 Element 或 Attr 节点引用的类型，用与文档相关的模式指定。
UserDataHandler
当使用 Node.setUserData() 将一个对象与节点上的键相关联时，当克隆、导入或重命名该对象关联的节点时应用程序可以提供调用的处理程序。

org.w3c.dom.bootstrap 使用的 org.w3c.dom 中的类
DOMImplementation
DOMImplementation 接口为执行独立于文档对象模型的任何特定实例的操作提供了许多方法。
DOMImplementationList
DOMImplementationList 接口提供对 DOM 实现的有序集合的抽象，没有定义或约束如何实现此集合。
DOMImplementationSource
此接口允许 DOM 实现程序根据请求的功能和版本提供一个或多个实现，如下所述。

org.w3c.dom.events 使用的 org.w3c.dom 中的类
DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。
Node
该 Node 接口是整个文档对象模型的主要数据类型。

org.w3c.dom.ls 使用的 org.w3c.dom 中的类
Document
Document 接口表示整个 HTML 或 XML 文档。
DOMConfiguration
该 DOMConfiguration 接口表示文档的配置，并维护一个可识别的参数表。
DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。
Element
Element 接口表示 HTML 或 XML 文档中的一个元素。
Node
该 Node 接口是整个文档对象模型的主要数据类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DocumentEvent (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.events
接口 DocumentEvent

public interface DocumentEvent

DocumentEvent 接口提供一种机制，通过该机制用户可以创建实现支持的 Event 类型。期望将在支持 Event 模型的实现中实现 Document 接口的同一个对象上实现 DocumentEvent 接口。

另请参见《Document Object Model (DOM) Level 2 Events Specification》。

从以下版本开始：
DOM Level 2

方法摘要
 Event createEvent(String eventType)

方法详细信息

createEvent

Event createEvent(String eventType)
                  throws DOMException
参数：
eventType - eventType 参数指定要创建的 Event 接口的类型。如果实现支持指定的 Event 接口，则此方法将返回请求的接口类型的新 Event。如果通过 dispatchEvent 方法指派 Event，则必须在事件创建之后调用适当事件的 init 方法以初始化 Event 的值。例如，希望综合某种 UIEvent 事件的用户应使用参数 "UIEvents" 调用 createEvent。然后可以在新创建的 UIEvent 上调用 initUIEvent 方法来设置要指派的特定类型的 UIEvent 并设置其上下文信息。在用户自己不方便或不必创建 Event 时，createEvent 方法用于创建 Event。在实现提供的 Event 不够的情况下，用户可以提供自己的 Event 实现用来和 dispatchEvent 方法一起使用。
返回：
新创建的 Event
抛出：
DOMException - NOT_SUPPORTED_ERR: 如果实现不支持请求的 Event 接口类型，则引发该异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Event (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.events
接口 Event

所有已知子接口：
LSLoadEvent, LSProgressEvent, MouseEvent, MutationEvent, UIEvent
public interface Event

Event 接口用于为处理事件的处理程序提供关于事件的上下文信息。实现 Event 接口的对象通常作为第一个参数传递给事件处理程序。从 Event(包含与它们附带的事件类型直接相关的信息)派生其他接口，可以将更多特定的上下文信息传递给事件处理程序。这些派生的接口也由传递给事件侦听器的对象实现。

另请参见 Document Object Model (DOM) Level 2 Events Specification。

从以下版本开始：
DOM Level 2

字段摘要
static short | AT_TARGET 目前事件正在目标 EventTarget 接受评诂。
static short | BUBBLING_PHASE 当前的事件阶段为 bubbling 阶段。
static short | CAPTURING_PHASE 当前的事件阶段是捕获阶段。
方法摘要
boolean | getBubbles() 用于指示事件是否是 bubbling 事件。
boolean | getCancelable() 用于指示事件是否可以阻止其默认操作。
EventTarget | getCurrentTarget() 用于指示当前正在处理其 EventListeners 的 EventTarget。
short | getEventPhase() 用于指示当前正在评诂哪个阶段的事件流。
EventTarget | getTarget() 用于指示 EventTarget，最初将事件指派给它。
long | getTimeStamp() 用于指定创建事件的时间（与历元相关，以毫秒为单位）。
String | getType() 事件的名称（不区分大小写）。
void | initEvent(String eventTypeArg, boolean canBubbleArg, boolean cancelableArg) initEvent 方法用于初始化通过 DocumentEvent 接口创建的 Event 的值。
void | preventDefault() 如果事件可取消，则 preventDefault 方法用于表示要取消该事件，意味着作为事件结果的、通常由该实现采取的任何默认操作将不出现。
void | stopPropagation() stopPropagation 方法用于阻止在事件流期间事件的进一步传播。

字段详细信息

CAPTURING_PHASE

static final short CAPTURING_PHASE
当前的事件阶段是捕获阶段。

另请参见：
常量字段值

AT_TARGET

static final short AT_TARGET
目前事件正在目标 EventTarget 接受评诂。

另请参见：
常量字段值

BUBBLING_PHASE

static final short BUBBLING_PHASE
当前的事件阶段为 bubbling 阶段。

另请参见：
常量字段值
方法详细信息

getType

String getType()
事件的名称（不区分大小写）。该名称必须是 XML 名称。

getTarget

EventTarget getTarget()
用于指示 EventTarget，最初将事件指派给它。

getCurrentTarget

EventTarget getCurrentTarget()
用于指示当前正在处理其 EventListeners 的 EventTarget。这在捕获和 bubbling 期间特别有用。

getEventPhase

short getEventPhase()
用于指示当前正在评诂哪个阶段的事件流。

getBubbles

boolean getBubbles()
用于指示事件是否是 bubbling 事件。如果事件可以 bubble，则值为 true；否则值为 false。

getCancelable

boolean getCancelable()
用于指示事件是否可以阻止其默认操作。如果可以阻止默认操作，则值为 true；否则值为 false。

getTimeStamp

long getTimeStamp()
用于指定创建事件的时间（与历元相关，以毫秒为单位）。由于有些系统不能提供此信息，timeStamp 的值可能不是对所有事件都可用。当不可用时，将返回值 0。历元时间的示例是系统启动时间，或者 UTC 时间 1970 年 1 月 1 日 0:0:0。

stopPropagation

void stopPropagation()
stopPropagation 方法用于阻止在事件流期间事件的进一步传播。如果任何 EventListener 调用此方法，则该事件将终止沿着树传播。事件流停止之前，该事件将完成向当前 EventTarget 上的所有侦听器的指派。在事件流的任何阶段都可以使用此方法。

preventDefault

void preventDefault()
如果事件可取消，则 preventDefault 方法用于表示要取消该事件，意味着作为事件结果的、通常由该实现采取的任何默认操作将不出现。在事件流的任何阶段，如果调用 preventDefault 方法，则取消该事件。与该事件相关联的任何默认操作都不会发生。对非可取消的事件调用此方法无效。一旦调用 preventDefault，在事件传播的剩余时间内它仍有效。在事件流的任何阶段都可以使用此方法。

initEvent

void initEvent(String eventTypeArg,
               boolean canBubbleArg,
               boolean cancelableArg)
initEvent 方法用于初始化通过 DocumentEvent 接口创建的 Event 的值。此方法只能在通过 dispatchEvent 方法指派 Event 之前调用，尽管在该阶段可以多次调用它（如有必要）。如果被多次调用，则最后一次调用优先。如果从 Event 接口的子类调用，则只修改在 initEvent 方法中指定的值，所有其他属性保持不变。

参数：
eventTypeArg - 指定事件类型。此类型可以是当前在此规范中定义的任何事件类型，或是一个新的事件类型。该字符串必须是 XML 名称。任何新的事件类型一定不能以字符串 "DOM" 的大写、小写或混合大小写版本开头。此前缀是为以后的 DOM 事件集保留的。还强烈推荐添加自己的事件的第三方使用自己的前缀以避免混淆，降低与其他新的事件发生冲突的可能性。
canBubbleArg - 指定该事件是否可以 bubble。
cancelableArg - 指定是否可以阻止事件的默认操作。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.events
类 EventException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.w3c.dom.events.EventException
所有已实现的接口：
Serializable
public class EventException
extends RuntimeException

事件操作可以像在其方法描述中指定的那样抛出 EventException。

另请参见《Document Object Model (DOM) Level 2 Events Specification》。

从以下版本开始：
DOM Level 2
另请参见：
序列化表格

字段摘要
short | code
static short | UNSPECIFIED_EVENT_TYPE_ERR 如果 Event 的类型不是在调用该方法之前通过初始化该事件指定的。
构造方法摘要
EventException(short code, String message)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

code

public short code

UNSPECIFIED_EVENT_TYPE_ERR

public static final short UNSPECIFIED_EVENT_TYPE_ERR
如果 Event 的类型不是在调用该方法之前通过初始化该事件指定的。把 Event 的类型指定为 null 或空字符串也会触发此异常。

另请参见：
常量字段值
构造方法详细信息

EventException

public EventException(short code,
                      String message)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventListener (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.events
接口 EventListener

public interface EventListener

EventListener 接口是处理事件的主要方法。用户实现 EventListener 接口，并使用 AddEventListener 方法在 EventTarget 上注册其侦听器。用户还应该在使用完侦听器后从其 EventTarget 移除 EventListener。

使用 cloneNode 方法复制 Node 时，连接到源 Node 的 EventListener 不连接复制的 Node。如果用户希望将相同的 EventListener 添加到新创建的副本，则用户必须手工添加它们。

另请参见《Document Object Model (DOM) Level 2 Events Specification》。

从以下版本开始：
DOM Level 2

方法摘要
 void handleEvent(Event evt)
每当发生 EventListener 接口为其注册的类型的事件时，即可调用此方法。

方法详细信息

handleEvent

void handleEvent(Event evt)
每当发生 EventListener 接口为其注册的类型的事件时，即可调用此方法。

参数：
evt - 包含关于事件的上下文信息的 Event。它还包含用于确定事件的流和默认操作的 stopPropagation 和 preventDefault 方法。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventTarget (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.events
接口 EventTarget

public interface EventTarget

EventTarget 接口由支持 DOM Event Model 的实现中的所有 Nodes 实现。因此，此接口可以通过在 Node 接口的实例上使用特定于绑定的强制转换方法获得。该接口允许在 EventTarget 上注册和移除 EventListeners，并将事件指派给 EventTarget。

另请参见《Document Object Model (DOM) Level 2 Events Specification》。

从以下版本开始：
DOM Level 2

方法摘要
void | addEventListener(String type, EventListener listener, boolean useCapture) 此方法允许在事件目标上注册事件侦听器。
boolean | dispatchEvent(Event evt) 此方法允许将事件指派到实现事件模型。
void | removeEventListener(String type, EventListener listener, boolean useCapture) 此方法允许从事件目标移除事件侦听器。

方法详细信息

addEventListener

void addEventListener(String type,
                      EventListener listener,
                      boolean useCapture)
此方法允许在事件目标上注册事件侦听器。如果在处理事件时将 EventListener 添加到 EventTarget，则该事件将不会通过当前操作触发，但可以在事件流后面的阶段（如 bubbling 阶段）触发。
如果使用同样的参数在同一个 EventTarget 上注册多个相同的 EventListener，则丢弃重复的实例。它们不会引起两次调用 EventListener，并且由于被丢弃，它们不需要使用 removeEventListener 方法移除。

参数：
type - 用户正在注册的事件类型
listener - listener 参数采用由用户实现的接口，该接口包含事件发生时要调用的方法。
useCapture - 如果为 true，则 useCapture 指示用户希望启动捕获。启动捕获后，所有指定类型的事件将在被指派到树中其下面的任何 EventTargets 之前指派给已注册的 EventListener。正在通过树向上 bubbling 的事件将不触发指定的使用捕获的 EventListener。

removeEventListener

void removeEventListener(String type,
                         EventListener listener,
                         boolean useCapture)
此方法允许从事件目标移除事件侦听器。如果 EventListener 在处理事件时从 EventTarget 移除，则它不会由当前操作触发。EventListener 永远不能在移除后被调用。
用不标识在 EventTarget 上的任何当前已注册的 EventListener 的参数调用 removeEventListener 时无效。

参数：
type - 指定正在被移除的 EventListener 的事件类型。
listener - 该 EventListener 参数指示要被移除的 EventListener 。
useCapture - 指定正被移除的 EventListener 是否是作为捕获侦听器注册的。如果一个侦听器注册了两次，一次带有捕获，一次不带捕获，每次都必须单独移除。移除捕获侦听器不影响同一侦听器的非捕获版本，反之亦然。

dispatchEvent

boolean dispatchEvent(Event evt)
                      throws EventException
此方法允许将事件指派到实现事件模型。以此方式指派的事件将与直接由实现指派的事件有相同的捕获和 bubbling 行为。事件的目标是在其上调用 dispatchEvent 的 EventTarget。

参数：
evt - 指定用于处理事件的事件类型、行为或上下文信息。
返回：
dispatchEvent 的返回值指示处理事件的任何一个侦听器是否调用了 preventDefault。如果调用了 preventDefault，则值为 false；否则该值为 true。
抛出：
EventException - UNSPECIFIED_EVENT_TYPE_ERR: 如果 Event 的类型不是在调用 dispatchEvent 之前通过初始化该事件指定的，则引发该异常。把 Event 的类型指定为 null 或空字符串也会触发此异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.events
接口 MouseEvent

所有超级接口：
Event, UIEvent
public interface MouseEvent
extends UIEvent

MouseEvent 接口提供与鼠标事件相关联的特定上下文信息。

从 UIEvent 继承的 detail 属性指示在用户操作期间同一屏幕位置上鼠标按键被按下和释放的次数。用户开始此操作时属性值为 1，对每个完整的按下和释放序列增加 1。如果用户在 mousedown 和 mouseup 之间移动鼠标，则将值设置为 0，指示没有进行单击操作。

就嵌套元素来说，鼠标事件的目标始终是最里层的嵌套元素。目标元素的祖先可以使用 bubbling 来获得在其后代元素内发生的鼠标事件的通知。

另请参见 Document Object Model (DOM) Level 2 Events Specification。

从以下版本开始：
DOM Level 2

字段摘要
从接口 org.w3c.dom.events.Event 继承的字段
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
方法摘要
boolean | getAltKey() 用于指示在触发事件期间是否按下 'alt' 键。
short | getButton() 在由按下或释放鼠标的按键引起的鼠标事件期间，button 用于指示哪一个鼠标按键改变了状态。
int | getClientX() 相对于 DOM 实现的客户区域的水平坐标(事件发生在此处)。
int | getClientY() 相对于 DOM 实现的客户区域的垂直坐标(事件发生在此处)。
boolean | getCtrlKey() 用于指示在触发事件事件期间是否按下 'ctrl' 键。
boolean | getMetaKey() 用于指示在触发事件期间是否按下 'meta' 键。
EventTarget | getRelatedTarget() 用于识别与 UI 事件相关的辅助 EventTarget。
int | getScreenX() 相对于屏幕坐标系统原点的水平坐标(事件发生在此处)。
int | getScreenY() 相对于屏幕坐标系统原点的垂直坐标(事件发生在此处)。
boolean | getShiftKey() 用于指示在触发事件期间是否按下 'shift' 键。
void | initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg) initMouseEvent 方法用于初始化通过 DocumentEvent 接口创建的 MouseEvent 的值。
从接口 org.w3c.dom.events.UIEvent 继承的方法
getDetail, getView, initUIEvent
从接口 org.w3c.dom.events.Event 继承的方法
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

方法详细信息

getScreenX

int getScreenX()
相对于屏幕坐标系统原点的水平坐标(事件发生在此处)。

getScreenY

int getScreenY()
相对于屏幕坐标系统原点的垂直坐标(事件发生在此处)。

getClientX

int getClientX()
相对于 DOM 实现的客户区域的水平坐标(事件发生在此处)。

getClientY

int getClientY()
相对于 DOM 实现的客户区域的垂直坐标(事件发生在此处)。

getCtrlKey

boolean getCtrlKey()
用于指示在触发事件事件期间是否按下 'ctrl' 键。

getShiftKey

boolean getShiftKey()
用于指示在触发事件期间是否按下 'shift' 键。

getAltKey

boolean getAltKey()
用于指示在触发事件期间是否按下 'alt' 键。在有些平台上，此键可能映射为一个替代键名。

getMetaKey

boolean getMetaKey()
用于指示在触发事件期间是否按下 'meta' 键。在有些平台上，此键可能映射为一个替代键名。

getButton

short getButton()
在由按下或释放鼠标的按键引起的鼠标事件期间，button 用于指示哪一个鼠标按键改变了状态。button 值的范围为 0 （指示鼠标的左键）、1（指示中间键（如果有））和 2（指示右键）。对于为左手使用而配置的鼠标，鼠标按键操作正好相反，值改为从右向左读取。

getRelatedTarget

EventTarget getRelatedTarget()
用于识别与 UI 事件相关的辅助 EventTarget。目前此属性和 mouseover 事件一起使用来指示指点设备退出的 EventTarget，和 mouseout 事件一起使用指示指点设备进入的 EventTarget。

initMouseEvent

void initMouseEvent(String typeArg,
                    boolean canBubbleArg,
                    boolean cancelableArg,
                    org.w3c.dom.views.AbstractView viewArg,
                    int detailArg,
                    int screenXArg,
                    int screenYArg,
                    int clientXArg,
                    int clientYArg,
                    boolean ctrlKeyArg,
                    boolean altKeyArg,
                    boolean shiftKeyArg,
                    boolean metaKeyArg,
                    short buttonArg,
                    EventTarget relatedTargetArg)
initMouseEvent 方法用于初始化通过 DocumentEvent 接口创建的 MouseEvent 的值。此方法只能在通过 dispatchEvent 方法指派 MouseEvent 之前调用，尽管在该阶段可以多次调用它（如有必要）。如果被多次调用，则最后一次调用优先。

参数：
typeArg - 指定事件类型。
canBubbleArg - 指定该事件是否可以 bubble。
cancelableArg - 指定是否可以阻止事件的默认操作。
viewArg - 指定 Event 的 AbstractView。
detailArg - 指定 Event 的鼠标单击量。
screenXArg - 指定 Event 的屏幕 x 坐标
screenYArg - 指定 Event 的屏幕 y 坐标
clientXArg - 指定 Event 的客户机 x 坐标
clientYArg - 指定 Event 的客户机 y 坐标
ctrlKeyArg - 指定是否在 Event 期间按下 control 键。
altKeyArg - 指定是否在 Event 期间按下 alt 键。
shiftKeyArg - 指定是否在 Event 期间按下 shift 键。
metaKeyArg - 指定是否在 Event 期间按下 meta 键。
buttonArg - 指定 Event 的鼠标按键。
relatedTargetArg - 指定 Event 的相关 EventTarget。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MutationEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.events
接口 MutationEvent

所有超级接口：
Event
public interface MutationEvent
extends Event

MutationEvent 接口提供与 Mutation 事件相关的特定上下文信息。

另请参见《Document Object Model (DOM) Level 2 Events Specification》。

从以下版本开始：
DOM Level 2

字段摘要
static short | ADDITION 只添加 Attr。
static short | MODIFICATION 适当修改 Attr。
static short | REMOVAL 只移除 Attr。
从接口 org.w3c.dom.events.Event 继承的字段
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
方法摘要
short | getAttrChange() attrChange 指示触发 DOMAttrModified 事件的更改类型。
String | getAttrName() attrName 指示 DOMAttrModified 事件中已更改的 Attr 节点的名称。
String | getNewValue() newValue 指示 DOMAttrModified 事件中 Attr 节点的新值，以及 DOMCharacterDataModified 中 CharacterData 节点的新值。
String | getPrevValue() prevValue 指示 DOMAttrModified 事件中 Attr 节点以前的值，以及 DOMCharacterDataModified 事件中 CharacterData 节点以前的值。
Node | getRelatedNode() relatedNode 用于识别与 mutation 事件相关联的辅助节点。
void | initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg) 该 initMutationEvent 方法用于初始化通过 DocumentEvent 接口创建的 MutationEvent 的值。
从接口 org.w3c.dom.events.Event 继承的方法
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

字段详细信息

MODIFICATION

static final short MODIFICATION
适当修改 Attr。

另请参见：
常量字段值

ADDITION

static final short ADDITION
只添加 Attr。

另请参见：
常量字段值

REMOVAL

static final short REMOVAL
只移除 Attr。

另请参见：
常量字段值
方法详细信息

getRelatedNode

Node getRelatedNode()
relatedNode 用于识别与 mutation 事件相关联的辅助节点。例如，如果将 mutation 事件指派给一个节点用来指示该节点的父节点已更改，则 relatedNode 为已更改的父节点。如果改为将事件指派给一个子树用来指示其中的节点已更改，则 relatedNode 为已更改的节点。就 DOMAttrModified 事件来说，它指示被修改、添加或移除的 Attr 节点。

getPrevValue

String getPrevValue()
prevValue 指示 DOMAttrModified 事件中 Attr 节点以前的值，以及 DOMCharacterDataModified 事件中 CharacterData 节点以前的值。

getNewValue

String getNewValue()
newValue 指示 DOMAttrModified 事件中 Attr 节点的新值，以及 DOMCharacterDataModified 中 CharacterData 节点的新值。

getAttrName

String getAttrName()
attrName 指示 DOMAttrModified 事件中已更改的 Attr 节点的名称。

getAttrChange

short getAttrChange()
attrChange 指示触发 DOMAttrModified 事件的更改类型。该值可能是 MODIFICATION、ADDITION 或 REMOVAL。

initMutationEvent

void initMutationEvent(String typeArg,
                       boolean canBubbleArg,
                       boolean cancelableArg,
                       Node relatedNodeArg,
                       String prevValueArg,
                       String newValueArg,
                       String attrNameArg,
                       short attrChangeArg)
该 initMutationEvent 方法用于初始化通过 DocumentEvent 接口创建的 MutationEvent 的值。此方法只能在通过 dispatchEvent 方法指派了 MutationEvent 之前调用，尽管在该阶段可以多次调用它（如有必要）。如果被多次调用，则最后一次调用优先。

参数：
typeArg - 指定事件类型。
canBubbleArg - 指定该事件是否可以 bubble。
cancelableArg - 指定是否可以阻止事件的默认操作。
relatedNodeArg - 指定 Event 的相关节点。
prevValueArg - 指定 Event 的 prevValue 属性。此值可以为 null。
newValueArg - 指定 Event 的 newValue 属性。此值可以为 null。
attrNameArg - 指定 Event 的 attrName 属性。此值可以为 null。
attrChangeArg - 指定 Event 的 attrChange 属性
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIEvent (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.events
接口 UIEvent

所有超级接口：
Event
所有已知子接口：
MouseEvent
public interface UIEvent
extends Event

UIEvent 接口提供与用户界面事件相关联的特定上下文信息。

另请参见《Document Object Model (DOM) Level 2 Events Specification》。

从以下版本开始：
DOM Level 2

字段摘要
从接口 org.w3c.dom.events.Event 继承的字段
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
方法摘要
int | getDetail() 指定关于 Event 的一些详细信息，具体取决于事件的类型。
org.w3c.dom.views.AbstractView | getView() view 属性标识生成事件的 AbstractView。
void | initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg) initUIEvent 方法用于初始化通过 DocumentEvent 接口创建的 UIEvent 的值。
从接口 org.w3c.dom.events.Event 继承的方法
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

方法详细信息

getView

org.w3c.dom.views.AbstractView getView()
view 属性标识生成事件的 AbstractView。

getDetail

int getDetail()
指定关于 Event 的一些详细信息，具体取决于事件的类型。

initUIEvent

void initUIEvent(String typeArg,
                 boolean canBubbleArg,
                 boolean cancelableArg,
                 org.w3c.dom.views.AbstractView viewArg,
                 int detailArg)
initUIEvent 方法用于初始化通过 DocumentEvent 接口创建的 UIEvent 的值。此方法只能在通过 dispatchEvent 方法指派了 UIEvent 方法之前调用，尽管在该阶段可以多次调用它（如有必要）。如果被多次调用，则最后一次调用优先。

参数：
typeArg - 指定事件类型。
canBubbleArg - 指定该事件是否可以 bubble。
cancelableArg - 指定是否可以阻止事件的默认操作。
viewArg - 指定 Event 的 AbstractView。
detailArg - 指定 Event 的详细信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.w3c.dom.events (Java Platform SE 6)

 org.w3c.dom.events
接口
DocumentEvent
Event
EventListener
EventTarget
MouseEvent
MutationEvent
UIEvent
异常
EventException


org.w3c.dom.events (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.w3c.dom.events

接口摘要
DocumentEvent | DocumentEvent 接口提供一种机制，通过该机制用户可以创建实现支持的 Event 类型。
Event | Event 接口用于为处理事件的处理程序提供关于事件的上下文信息。
EventListener | EventListener 接口是处理事件的主要方法。
EventTarget | EventTarget 接口由支持 DOM Event Model 的实现中的所有 Nodes 实现。
MouseEvent | MouseEvent 接口提供与鼠标事件相关联的特定上下文信息。
MutationEvent | MutationEvent 接口提供与 Mutation 事件相关的特定上下文信息。
UIEvent | UIEvent 接口提供与用户界面事件相关联的特定上下文信息。

异常摘要
EventException 事件操作可以像在其方法描述中指定的那样抛出 EventException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.w3c.dom.events 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.w3c.dom.events 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.events.EventException

接口分层结构

  • org.w3c.dom.events.DocumentEvent
  • org.w3c.dom.events.Event
    • org.w3c.dom.events.MutationEvent
    • org.w3c.dom.events.UIEvent
      • org.w3c.dom.events.MouseEvent
  • org.w3c.dom.events.EventListener
  • org.w3c.dom.events.EventTarget
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.w3c.dom.events 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.w3c.dom.events
的使用

使用 org.w3c.dom.events 的软件包
org.w3c.dom.events
org.w3c.dom.ls

org.w3c.dom.events 使用的 org.w3c.dom.events 中的类
Event
Event 接口用于为处理事件的处理程序提供关于事件的上下文信息。
EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。
EventListener
EventListener 接口是处理事件的主要方法。
EventTarget
EventTarget 接口由支持 DOM Event Model 的实现中的所有 Nodes 实现。
UIEvent
UIEvent 接口提供与用户界面事件相关联的特定上下文信息。

org.w3c.dom.ls 使用的 org.w3c.dom.events 中的类
Event
Event 接口用于为处理事件的处理程序提供关于事件的上下文信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.events.EventListener 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.EventListener
的使用

使用 EventListener 的软件包
org.w3c.dom.events

org.w3c.dom.events 中 EventListener 的使用

参数类型为 EventListener 的 org.w3c.dom.events 中的方法
void | EventTarget.addEventListener(String type, EventListener listener, boolean useCapture) 此方法允许在事件目标上注册事件侦听器。
void | EventTarget.removeEventListener(String type, EventListener listener, boolean useCapture) 此方法允许从事件目标移除事件侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.events.MouseEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.MouseEvent
的使用

没有 org.w3c.dom.events.MouseEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.events.UIEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.UIEvent
的使用

使用 UIEvent 的软件包
org.w3c.dom.events

org.w3c.dom.events 中 UIEvent 的使用

org.w3c.dom.events 中 UIEvent 的子接口
 interface MouseEvent
MouseEvent 接口提供与鼠标事件相关联的特定上下文信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.w3c.dom.events.EventException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.w3c.dom.events.EventException
的使用

使用 EventException 的软件包
org.w3c.dom.events

org.w3c.dom.events 中 EventException 的使用

抛出 EventException 的 org.w3c.dom.events 中的方法
 boolean EventTarget.dispatchEvent(Event evt)
此方法允许将事件指派到实现事件模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.events.MutationEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.MutationEvent
的使用

没有 org.w3c.dom.events.MutationEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.events.Event 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.Event
的使用

使用 Event 的软件包
org.w3c.dom.events
org.w3c.dom.ls

org.w3c.dom.events 中 Event 的使用

org.w3c.dom.events 中 Event 的子接口
interface | MouseEvent MouseEvent 接口提供与鼠标事件相关联的特定上下文信息。
interface | MutationEvent MutationEvent 接口提供与 Mutation 事件相关的特定上下文信息。
interface | UIEvent UIEvent 接口提供与用户界面事件相关联的特定上下文信息。

返回 Event 的 org.w3c.dom.events 中的方法
 Event DocumentEvent.createEvent(String eventType)

参数类型为 Event 的 org.w3c.dom.events 中的方法
boolean | EventTarget.dispatchEvent(Event evt) 此方法允许将事件指派到实现事件模型。
void | EventListener.handleEvent(Event evt) 每当发生 EventListener 接口为其注册的类型的事件时，即可调用此方法。

org.w3c.dom.ls 中 Event 的使用

org.w3c.dom.ls 中 Event 的子接口
interface | LSLoadEvent 此接口表示通知文档加载完成的加载事件对象。
interface | LSProgressEvent 此接口表示进度事件对象，该对象在解析文档时通知应用程序有关进度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.events.EventTarget 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.EventTarget
的使用

使用 EventTarget 的软件包
org.w3c.dom.events

org.w3c.dom.events 中 EventTarget 的使用

返回 EventTarget 的 org.w3c.dom.events 中的方法
EventTarget | Event.getCurrentTarget() 用于指示当前正在处理其 EventListeners 的 EventTarget。
EventTarget | MouseEvent.getRelatedTarget() 用于识别与 UI 事件相关的辅助 EventTarget。
EventTarget | Event.getTarget() 用于指示 EventTarget，最初将事件指派给它。

参数类型为 EventTarget 的 org.w3c.dom.events 中的方法
 void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
initMouseEvent 方法用于初始化通过 DocumentEvent 接口创建的 MouseEvent 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.events.DocumentEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.events.DocumentEvent
的使用

没有 org.w3c.dom.events.DocumentEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DOMImplementationRegistry (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.bootstrap
类 DOMImplementationRegistry

java.lang.Object
    继承者  org.w3c.dom.bootstrap.DOMImplementationRegistry

public final class DOMImplementationRegistry
extends Object

启用应用程序来获得 DOMImplementation 实例的工厂。

示例：

  // get an instance of the DOMImplementation registry
  DOMImplementationRegistry registry =
       DOMImplementationRegistry.newInstance();
  // get a DOM implementation the Level 3 XML module
  DOMImplementation domImpl =
       registry.getDOMImplementation("XML 3.0");

这提供了一个带有与实现无关的开始点的应用程序。DOM 实现可以修改此类以满足新的安全标准，或为 DOMImplementationSource 列表提供 *附加的* 回退。

从以下版本开始：
DOM Level 3
另请参见：
DOMImplementation, DOMImplementationSource

字段摘要
static String PROPERTY
指定 DOMImplementationSource 类名称的系统属性。
方法摘要
void | addSource(DOMImplementationSource s) 注册实现。
DOMImplementation | getDOMImplementation(String features) 返回第一个具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。
DOMImplementationList | getDOMImplementationList(String features) 返回支持所需功能的实现列表。
static DOMImplementationRegistry | newInstance() 获得 DOMImplementationRegistry 的新实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PROPERTY

public static final String PROPERTY
指定 DOMImplementationSource 类名称的系统属性。

另请参见：
常量字段值
方法详细信息

newInstance

public static DOMImplementationRegistry newInstance()
                                             throws ClassNotFoundException,
                                                    InstantiationException,
                                                    IllegalAccessException,
                                                    ClassCastException
获得 DOMImplementationRegistry 的新实例。 DOMImplementationRegistry 是由应用程序还是实现进行初始化，这取决于上下文，首先检查 Java 系统属性 org.w3c.dom.DOMImplementationSourceList 的值和服务提供者(其内容位于 "META_INF/services/org.w3c.dom.DOMImplementationSourceList" )。此属性的值是一个由空格分隔的实现 DOMImplementationSource 接口的可供使用的类名称列表。列表在类名称列表中的每个类都实例化，并将遇到的所有异常抛给应用程序。

返回：
已初始化的 DOMImplementationRegistry 实例
抛出：
ClassNotFoundException - 如果无法找到任何指定的类
InstantiationException - 如果任何指定的类是接口或抽象类
IllegalAccessException - 如果指定类的默认构造方法不可访问
ClassCastException - 如果任何指定的类没有实现 DOMImplementationSource

getDOMImplementation

public DOMImplementation getDOMImplementation(String features)
返回第一个具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。

参数：
features - 指定所需功能的字符串。这是一个空格分隔的列表，列表中每个功能都由其名称指定，可以选择后面跟随一个空格和版本号。此列表的形式类似如下："XML 1.0 Traversal +Events 2.0"
返回：
具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。

getDOMImplementationList

public DOMImplementationList getDOMImplementationList(String features)
返回支持所需功能的实现列表。

参数：
features - 指定所需功能的字符串。这是一个空格分隔的列表，列表中每个功能都由其名称指定，可以选择后面跟随一个空格和版本号。此列表的形式类似如下："XML 1.0 Traversal +Events 2.0"
返回：
支持所需功能的 DOMImplementation 列表。

addSource

public void addSource(DOMImplementationSource s)
注册实现。

参数：
s - 要注册的源，不可以为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.w3c.dom.bootstrap (Java Platform SE 6)

 org.w3c.dom.bootstrap
类
DOMImplementationRegistry


org.w3c.dom.bootstrap (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.w3c.dom.bootstrap

类摘要
DOMImplementationRegistry 启用应用程序来获得 DOMImplementation 实例的工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.w3c.dom.bootstrap 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.w3c.dom.bootstrap 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.w3c.dom.bootstrap.DOMImplementationRegistry
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.w3c.dom.bootstrap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.w3c.dom.bootstrap
的使用

使用 org.w3c.dom.bootstrap 的软件包
org.w3c.dom.bootstrap

org.w3c.dom.bootstrap 使用的 org.w3c.dom.bootstrap 中的类
DOMImplementationRegistry
启用应用程序来获得 DOMImplementation 实例的工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.w3c.dom.bootstrap.DOMImplementationRegistry 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.w3c.dom.bootstrap.DOMImplementationRegistry
的使用

使用 DOMImplementationRegistry 的软件包
org.w3c.dom.bootstrap

org.w3c.dom.bootstrap 中 DOMImplementationRegistry 的使用

返回 DOMImplementationRegistry 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


DOMImplementationLS (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 DOMImplementationLS

public interface DOMImplementationLS

DOMImplementationLS 包括创建 Load 和 Save 对象的工厂方法。

期望在 DOMImplementation 接口的实例上使用特定于绑定的 casting 方法获取 DOMImplementationLS 接口的实例，或者如果 Document 支持在 [DOM Level 3 Core] 中定义的功能 "Core" 版本 "3.0" ，通过分别使用带有参数值 "LS"（或 "LS-Async"）和 "3.0" 的 DOMImplementation.getFeature 方法来获取。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

字段摘要
static short | MODE_ASYNCHRONOUS 创建一个异步 LSParser。
static short | MODE_SYNCHRONOUS 创建一个同步 LSParser。
方法摘要
LSInput | createLSInput() 创建一个新的空输入源对象，其中，LSInput.characterStream、LSInput.byteStream、LSInput.stringData LSInput.systemId、LSInput.publicId、LSInput.baseURI 和 LSInput.encoding 为 null，LSInput.certifiedText 为 false。
LSOutput | createLSOutput() 创建新的空输出目标对象，其中，LSOutput.characterStream、LSOutput.byteStream、LSOutput.systemId 和 LSOutput.encoding 为 null。
LSParser | createLSParser(short mode, String schemaType) 创建一个新的 LSParser。
LSSerializer | createLSSerializer() 创建新的 LSSerializer 对象。

字段详细信息

MODE_SYNCHRONOUS

static final short MODE_SYNCHRONOUS
创建一个同步 LSParser。

另请参见：
常量字段值

MODE_ASYNCHRONOUS

static final short MODE_ASYNCHRONOUS
创建一个异步 LSParser。

另请参见：
常量字段值
方法详细信息

createLSParser

LSParser createLSParser(short mode,
                        String schemaType)
                        throws DOMException
创建一个新的 LSParser。然后新构建的解析器可以通过其 DOMConfiguration 对象得以配置，并通过其 parse 方法用来解析文档。

参数：
mode - mode 参数是 MODE_SYNCHRONOUS 或 MODE_ASYNCHRONOUS，如果 mode 是 MODE_SYNCHRONOUS，则所创建的 LSParser 将以同步模式操作，如果它是 MODE_ASYNCHRONOUS，则所创建的 LSParser 将以异步模式操作。
schemaType - 绝对 URI，表示在使用新创建的 LSParser 加载 Document 期间所使用的模式语言的类型。注意，不对绝对 URI 执行词法检查。为任何种类的模式类型创建 LSParser（即 LSParser 将自由使用找到的模式），使用 null 值。

注：对于 W3C XML Schema [XML Schema Part 1]，应用程序必须使用值 "http://www.w3.org/2001/XMLSchema"。对于 XML DTD [XML 1.0]，应用程序必须使用值 "http://www.w3.org/TR/REC-xml"。其他的模式语言在 W3C 范围之外，因此为了使用此方法，应当推荐绝对 URI。

返回：
新创建的 LSParser 对象。此 LSParser 或者是同步的或者是异步的，具体取决于 mode 参数的值。

注：默认情况下，新创建的 LSParser 不包含 DOMErrorHandler，即 "error-handler" 配置参数的值为 null。但是，创建时实现可以提供默认的错误处理程序。在这种情况下，在新的 LSParser 对象上的 "error-handler" 配置参数的初始值包含对默认错误处理程序的引用。

抛出：
DOMException - NOT_SUPPORTED_ERR: 如果请求的模式类型不受支持，将引发此异常。

createLSSerializer

LSSerializer createLSSerializer()
创建新的 LSSerializer 对象。

返回：
新创建的 LSSerializer 对象。

注：默认情况下，新创建的 LSSerializer 没有 DOMErrorHandler，即 "error-handler" 配置参数的值为 null。但是，创建时实现可以提供默认的错误处理程序。在这种情况下，在新的 LSSerializer 对象上的 "error-handler" 配置参数的初始值包括对默认的错误处理程序的引用。

createLSInput

LSInput createLSInput()
创建一个新的空输入源对象，其中，LSInput.characterStream、LSInput.byteStream、LSInput.stringData LSInput.systemId、LSInput.publicId、LSInput.baseURI 和 LSInput.encoding 为 null，LSInput.certifiedText 为 false。

返回：
新创建的输入对象。

createLSOutput

LSOutput createLSOutput()
创建新的空输出目标对象，其中，LSOutput.characterStream、LSOutput.byteStream、LSOutput.systemId 和 LSOutput.encoding 为 null。

返回：
新创建的输出对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


LSException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
类 LSException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  org.w3c.dom.ls.LSException
所有已实现的接口：
Serializable
public class LSException
extends RuntimeException

如果处理停止，解析或写操作可以抛出 LSException。处理可能因带有严重的 DOMError.SEVERITY_FATAL_ERROR 或不可恢复的 DOMError.SEVERITY_ERROR 的 DOMError，或者如果 DOMErrorHandler.handleError() 返回 false 而停止。

注：如在 DOMError 接口中对常量的定义建议的那样，DOM 实现可以选择在发生严重错误后继续，但是得到的 DOM 树则具有实现依赖性。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

另请参见：
序列化表格

字段摘要
short | code
static short | PARSE_ERR 如果尝试使用 LSParser 加载文档或 XML 片段并且处理已经停止。
static short | SERIALIZE_ERR 如果尝试使用 LSSerializer 序列化 Node 并且处理已经停止。
构造方法摘要
LSException(short code, String message)
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

code

public short code

PARSE_ERR

public static final short PARSE_ERR
如果尝试使用 LSParser 加载文档或 XML 片段并且处理已经停止。

另请参见：
常量字段值

SERIALIZE_ERR

public static final short SERIALIZE_ERR
如果尝试使用 LSSerializer 序列化 Node 并且处理已经停止。

另请参见：
常量字段值
构造方法详细信息

LSException

public LSException(short code,
                   String message)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSInput (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSInput

public interface LSInput

此接口表示数据的输入源。

此接口允许应用程序封装有关单个对象中的输入源的信息，它可包括公共标识符、系统标识符、字节流（可能带有指定的编码）、基本 URI 和/ 或字符流。

对字节流和字符流的精确定义具有绑定依赖性。

当需要这种对象时，期望应用程序提供实现此接口的对象。应用程序既可以提供自己的实现此接口的对象，也可以使用一般的工厂方法 DOMImplementationLS.createLSInput() 来创建实现此接口的对象。

LSParser 将使用 LSInput 对象来确定如何读取数据。LSParser 将按照下面的顺序查看在 LSInput 中指定的不同输入，以便知道将从哪个输入中读取数据，将使用不为 null 并且不是空字符串的第一个输入：

  1. LSInput.characterStream
  2. LSInput.byteStream
  3. LSInput.stringData
  4. LSInput.systemId
  5. LSInput.publicId

如果所有的输入都为 null，LSParser 将报告有 DOMError，其 DOMError.type 被设置为 "no-input-specified"，其 DOMError.severity 被设置为 DOMError.SEVERITY_FATAL_ERROR。

LSInput 对象属于应用程序。DOM 实现永远不会修改这些对象（尽管可在必要时制作副本和修改副本）。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

方法摘要
String | getBaseURI() 基 URI（请参阅 [IETF RFC 2396]中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。
InputStream | getByteStream() 依赖于语言和绑定类型的属性，表示字节的流。
boolean | getCertifiedText() 如果设置为 true，则假定解析 [XML 1.1] 时对输入进行认证（请参阅 [XML 1.1] 中的 2.13 节）。
Reader | getCharacterStream() 依赖于语言和绑定类型的属性，表示 16 位单元流。
String | getEncoding() 字符编码（如果已知）。
String | getPublicId() 此输入源的公共标识符。
String | getStringData() 要解析的字符串数据。
String | getSystemId() 系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。
void | setBaseURI(String baseURI) 基 URI（请参阅 [IETF RFC 2396])中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。
void | setByteStream(InputStream byteStream) 依赖于语言和绑定类型的属性，表示字节流。
void | setCertifiedText(boolean certifiedText) 如果设置为 true，则假定解析 [XML 1.1] 时对输入进行验证（请参阅 [XML 1.1] 中的 2.13 节）。
void | setCharacterStream(Reader characterStream) 依赖于语言和绑定类型的属性，表示 16 位单元的流。
void | setEncoding(String encoding) 字符串编码（如果已知）。
void | setPublicId(String publicId) 此输入源的公共标识符。
void | setStringData(String stringData) 要解析的字符串数据。
void | setSystemId(String systemId) 系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。

方法详细信息

getCharacterStream

Reader getCharacterStream()
依赖于语言和绑定类型的属性，表示 16 位单元流。应用程序必须使用 UTF-16（在 [Unicode] 和 [ISO/IEC 10646] 中定义）编码流。当使用字符流时，不必具有 XML 声明。如果有 XML 声明，将忽略编码属性的值。

setCharacterStream

void setCharacterStream(Reader characterStream)
依赖于语言和绑定类型的属性，表示 16 位单元的流。应用程序必须使用 UTF-16（在 [Unicode] 和 [ISO/IEC 10646] 中定义）编码流。当使用字符流时，不必具有 XML 声明。如果有 XML 声明，将忽略编码属性的值。

getByteStream

InputStream getByteStream()
依赖于语言和绑定类型的属性，表示字节的流。
如果应用程序知道字节流的字符编码，则必须设置编码属性。用此方法设置编码将重写在数据的 XML 声明中指定的任何编码。

setByteStream

void setByteStream(InputStream byteStream)
依赖于语言和绑定类型的属性，表示字节流。
如果应用程序知道字节流的字符编码，则必须设置编码属性。用此方法设置编码将重写在数据的 XML 声明中指定的任何编码。

getStringData

String getStringData()
要解析的字符串数据。如果提供了字符串数据，将始终将此视为 16 位单元序列（UTF-16 编码字符）。当使用 stringData 时，不必具有 XML 声明。如果有 XML 声明，将忽略编码属性的值。

setStringData

void setStringData(String stringData)
要解析的字符串数据。如果提供了字符串数据，将始终将此视为 16 位单元序列（UTF-16 编码的字符）。当使用 stringData 时，不必具有 XML 声明。如果有 XML 声明，将忽略编码属性的值。

getSystemId

String getSystemId()
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。如果有字节流、字符流或字符串数据，则系统标识符将为可选项。提供一项非常有用，因为应用程序将使用它来解析任何相对 URI，并可将它包含到错误消息和警告中。（如果在输入源中没有其他的输入可供使用，则 LSParser 将只尝试获取由 URI 引用标识的资源。）
如果应用程序知道系统标识符所指向的对象的字符编码，则可以使用 encoding 属性来设置编码。
如果指定的系统 ID 是相对 URI 引用（请参阅 [IETF RFC 2396] 中的 5 节），则 DOM 实现将尝试以 baseURI 为基解析相对 URI，如果尝试失败，则表示该行为具有实现依赖性。

setSystemId

void setSystemId(String systemId)
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。如果有字节流、字符流或字符串数据，则系统标识符将为可选项。提供一项仍非常有用，因为应用程序将使用它来解析任何相对 URI，并可将它包含到错误消息和警告中。（如果在输入源中没有其他的输入可供使用，则 LSParser 将只尝试获取由 URI 引用标识的资源。）
如果应用程序知道系统标识符所指向的对象的字符编码，则可以使用 encoding 属性来设置编码。
如果指定的系统 ID 是相对 URI 引用（请参阅 [IETF RFC 2396] 中的 5 节），则 DOM 实现将尝试以 baseURI 为基解析相对 URI，如果尝试失败，则表示该行为与实现有关。

getPublicId

String getPublicId()
此输入源的公共标识符。可以使用依赖于实现的机制（如目录或其他映射）将它映射到一个输入源。当报告错误时，也可以将公共标识符（如果已指定）作为位置信息的一部分来报告。

setPublicId

void setPublicId(String publicId)
此输入源的公共标识符。可以使用具有实现依赖性的机制（如目录或其他映射）将它映射到一个输入源。当报告错误时，还可以将公共标识符（如果已指定）作为位置信息的一部分来报告。

getBaseURI

String getBaseURI()
基 URI（请参阅 [IETF RFC 2396]中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。
如果使用时基 URI 本身是相对 URI、空字符串或 null，则表示该行为具有实现依赖性。

setBaseURI

void setBaseURI(String baseURI)
基 URI（请参阅 [IETF RFC 2396])中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。
如果使用时基 URI 本身是相对 URI、空字符串或 null，则该行为具有实现依赖性。

getEncoding

String getEncoding()
字符编码（如果已知）。编码必须是 XML 编码声明（[XML 1.0] 的 4.3.3 节 "Character Encoding in Entities"）可接受的字符串。
当应用程序提供字符流或字符串数据时，此属性无效。对于其他的输入源，通过此属性指定的编码将重写在 XML 声明或 Text 声明中指定的任何编码，或者从高层协议中获取的编码，如 HTTP [IETF RFC 2616]。

setEncoding

void setEncoding(String encoding)
字符串编码（如果已知）。编码必须是 XML 编码声明（[XML 1.0] 的 4.3.3 节 "Character Encoding in Entities"）可接受的字符串。
当应用程序提供字符流或字符串数据时，此属性无效。对于其他的输入源，通过此属性指定的编码将重写在 XML 声明或 Text 声明中指定的任何编码，或者从高层协议中获取的编码，如 HTTP [IETF RFC 2616]。

getCertifiedText

boolean getCertifiedText()
如果设置为 true，则假定解析 [XML 1.1] 时对输入进行认证（请参阅 [XML 1.1] 中的 2.13 节）。

setCertifiedText

void setCertifiedText(boolean certifiedText)
如果设置为 true，则假定解析 [XML 1.1] 时对输入进行验证（请参阅 [XML 1.1] 中的 2.13 节）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSLoadEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSLoadEvent

所有超级接口：
Event
public interface LSLoadEvent
extends Event

此接口表示通知文档加载完成的加载事件对象。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

字段摘要
从接口 org.w3c.dom.events.Event 继承的字段
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
方法摘要
LSInput | getInput() 被解析的输入源。
Document | getNewDocument() 完成加载的文档。
从接口 org.w3c.dom.events.Event 继承的方法
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

方法详细信息

getNewDocument

Document getNewDocument()
完成加载的文档。

getInput

LSInput getInput()
被解析的输入源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSOutput (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSOutput

public interface LSOutput

此接口表示数据的输出目标。

此接口允许应用程序封装有关单个对象中的输出目标的信息，它可包括 URI、字节流（可能带有指定的编码）、基 URI 和/或字符流。

对字节流和字符流的精确定义具有绑定依赖性。

当需要这种对象时，期望应用程序提供实现此接口的对象。应用程序既可以提供自己的实现此接口的对象，也可以使用一般的工厂方法 DOMImplementationLS.createLSOutput() 来创建实现此接口的对象。

LSSerializer 将使用 LSOutput 对象来确定将输出序列化到何处。LSSerializer 将按照下面的顺序查看在 LSOutput 中指定的不同输出，以了解输出到哪个当中，将使用不为 null 并且不是空字符串的第一个输出：

  1. LSOutput.characterStream
  2. LSOutput.byteStream
  3. LSOutput.systemId

LSOutput 对象属于该应用程序。DOM 实现永远不会修改这些对象（尽管可在必要时制做副本和修改副本）。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

方法摘要
OutputStream | getByteStream() 具有语言和绑定依赖性类型的属性，表示字节的可写流。
Writer | getCharacterStream() 具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。
String | getEncoding() 用于输出的字符编码。
String | getSystemId() 系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。
void | setByteStream(OutputStream byteStream) 具有语言和绑定依赖性类型的属性，表示字节的可写流。
void | setCharacterStream(Writer characterStream) 具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。
void | setEncoding(String encoding) 用于输出的字符编码。
void | setSystemId(String systemId) 系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。

方法详细信息

getCharacterStream

Writer getCharacterStream()
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。

setCharacterStream

void setCharacterStream(Writer characterStream)
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。

getByteStream

OutputStream getByteStream()
具有语言和绑定依赖性类型的属性，表示字节的可写流。

setByteStream

void setByteStream(OutputStream byteStream)
具有语言和绑定依赖性类型的属性，表示字节的可写流。

getSystemId

String getSystemId()
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。
如果系统 ID 是相对 URI 引用（参见 [IETF RFC 2396] 中的 5 节），则该行为具有实现依赖性。

setSystemId

void setSystemId(String systemId)
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。
如果系统 ID 是相对 URI 引用（参见 [IETF RFC 2396] 中的 5 节），则该行为具有实现依赖性。

getEncoding

String getEncoding()
用于输出的字符编码。编码必须是 XML 编码声明（[XML 1.0] 的 4.3.3 节 "Character Encoding in Entities"）可接受的字符串，建议在“国际因特网地址分配委员会”[IANA-CHARSETS] 注册的字符编码应该使用它们的注册名称来引用。

setEncoding

void setEncoding(String encoding)
用于输出的字符编码。编码必须是 XML 编码声明（[XML 1.0] 的 4.3.3 节 "Character Encoding in Entities"）可接受的字符串，建议在“国际因特网地址分配委员会”[IANA-CHARSETS] 中注册的字符编码使用它们的注册名称来引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSParser (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSParser

public interface LSParser

可以构建的对象接口，或者参数、来自各种输入源的 DOM 树。

LSParser 提供了用于解析 XML 和构建相应的 DOM 文档结构的 API。LSParser 实例可以通过调用 DOMImplementationLS.createLSParser() 方法获取。

如 [DOM Level 3 Core] 中指定的那样，当通过 LSParser 第一次使文档可供使用时：

  • 从不会有两个 NODE_TEXT 类型的相邻节点，并且从不会有空的文本节点。
  • 期望 Attr 节点的 value 和 nodeValue 属性最初返回《XML 1.0 normalized value》。但是，如果参数《validate-if-schema》和《datatype-normalization》被设置为 true，由于属性值依赖于所使用的属性标准化，所以该值会不同于通过 XML 1.0 属性标准化而获得的值。如果把参数《datatype-normalization》设置为 false，则可以保证进行 XML 1.0 属性标准化，如果属性列表不包括名称空间声明，则 Element 字节上的 attributes 属性表示在 [XML Information Set] 中定义的属性 [attributes]。

期望异步 LSParser 对象也实现 events::EventTarget 接口，以便事件侦听器能够在异步 LSParser 对象上注册。

异步 LSParser 对象所支持的事件包括：

load
LSParser 完成对文档的加载。另请参见 LSLoadEvent 接口的定义。
progress
在解析数据时 LSParser 通知进度情况。此规范并不尝试精确定义应该何时调度进度事件。而是有意让其具有实现依赖性。下面是一个应用程序如何调度进度事件的示例：一旦解析器开始接收数据，则将调度进度事件，以表示解析已开始。从这时起，为接收和处理的每 4096 个字节数据调度进度事件。但这只是一个示例，实现可以在解析期间的任何时间选择调度进度事件，或者根本不调度这些事件。另请参见 LSProgressEvent 接口的定义。

注：此规范中定义的所有事件都使用名称空间 URI "http://www.w3.org/2002/DOMLS"。

在解析输入源时，通过错误处理程序（LSParser.domConfig 的 "error-handler" 参数）将错误报告给应用程序。此规范决不尝试定义解析 XML 或者其他任何标记时所有可能发生的错误，但对一些常见的错误情形做了定义。此规范定义的错误和警告类型 (DOMError.type) 包括：

"check-character-normalization-failure" [error]
如果参数 "check-character-normalization" 设置为 true 并且碰到标准化检查失败的字符串，则将引发此错误。
"doctype-not-allowed" [fatal]
如果配置参数 "disallow-doctype" 设置为 true 并且遇到了 doctype，则将引发此错误。
"no-input-specified" [fatal]
当加载文档并且未在 LSInput 对象中指定输入时引发此错误。
"pi-base-uri-not-preserved" [warning]
如果在不能保留处理指令的基 URI 位置遇到处理指令，则引发此警告。将引发此警告的一种情况示例是：配置参数 "entities" 被设置为 false 并且将解析下面的 XML 文件：
 <!DOCTYPE root [ <!ENTITY e SYSTEM 'subdir/myentity.ent' ]>
 <root> &e; </root>
subdir/myentity.ent 包括：
<one> <two/> </one> <?pi 3.14159?>
 <more/>
"unbound-prefix-in-entity" [warning]
这是一个独立于实现的警告，如果配置参数 "namespaces" 设置为 true 并且在实体的替换文本中碰到了未绑定的名称空间前缀时,可以引发此警告。并非强制引发此警告，因为有些现有的解析器不能在实体的替换文本中识别未绑定的名称空间前缀。
"unknown-character-denormalization" [fatal]
如果配置参数 "ignore-unknown-character-denormalizations" 设置为 false 并且遇到了处理器无法为其确定标准化属性的字符，则引发此错误。
"unsupported-encoding" [fatal]
如果遇到了不支持的编码，则引发此错误。
"unsupported-media-type" [fatal]
如果配置参数 "supported-media-types-only" 设置为 true 并且遇到了不支持的媒体类型，则引发此错误。

除了引发定义的错误和警告之外，期望实现应该对其他任何错误和警告情况，例如 IO 错误（未找到文件，权限被拒绝）、XML 格式良好性错误等引发特定于实现的错误和警告。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

字段摘要
static short | ACTION_APPEND_AS_CHILDREN 将解析操作的结果追加为上下文节点的子节点。
static short | ACTION_INSERT_AFTER 把解析操作的结果作为上下文节点的直接后续兄弟节点插入。
static short | ACTION_INSERT_BEFORE 把解析操作的结果作为上下文节点的直接前置兄弟节点插入。
static short | ACTION_REPLACE 用解析操作的结果替换上下文节点。
static short | ACTION_REPLACE_CHILDREN 用解析操作的结果替换上下文节点的所有子节点。
方法摘要
void | abort() 中断对当前由 LSParser 加载的文档的加载。
boolean | getAsync() 如果 LSParser 是异步的，为 true，如果它是同步的，则为 false。
boolean | getBusy() 如果 LSParser 当前正忙于加载文档，则为 true，否则为 false。
DOMConfiguration | getDomConfig() 解析输入源时使用的 DOMConfiguration 对象。
LSParserFilter | getFilter() 当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。
Document | parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Document | parseURI(String uri) 从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。
Node | parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
void | setFilter(LSParserFilter filter) 当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。

字段详细信息

ACTION_APPEND_AS_CHILDREN

static final short ACTION_APPEND_AS_CHILDREN
将解析操作的结果追加为上下文节点的子节点。为了使此动作起作用，上下文节点必须是 Element 或 DocumentFragment。

另请参见：
常量字段值

ACTION_REPLACE_CHILDREN

static final short ACTION_REPLACE_CHILDREN
用解析操作的结果替换上下文节点的所有子节点。为了使此动作有效，上下文节点必须是 Element、Document 或 DocumentFragment。

另请参见：
常量字段值

ACTION_INSERT_BEFORE

static final short ACTION_INSERT_BEFORE
把解析操作的结果作为上下文节点的直接前置兄弟节点插入。为了使此操作有效，上下文节点的父节点必须是 Element 或 DocumentFragment。

另请参见：
常量字段值

ACTION_INSERT_AFTER

static final short ACTION_INSERT_AFTER
把解析操作的结果作为上下文节点的直接后续兄弟节点插入。为了使此操作有效，上下文节点的父节点必须是 Element 或 DocumentFragment。

另请参见：
常量字段值

ACTION_REPLACE

static final short ACTION_REPLACE
用解析操作的结果替换上下文节点。为了使此操作有效，上下文节点必须具有父节点，并且父节点必须是 Element 或 DocumentFragment。

另请参见：
常量字段值
方法详细信息

getDomConfig

DOMConfiguration getDomConfig()
解析输入源时使用的 DOMConfiguration 对象。此 DOMConfiguration 特定于解析操作。在由解析操作创建或使用的 Document 上，没有参数值从此 DOMConfiguration 对象被自动传递到 DOMConfiguration 对象。DOM 应用程序负责将任何所需的参数值从此 DOMConfiguration 对象传递到由 Document 对象引用的 DOMConfiguration 对象。
除在 "DOMConfiguration" 接口（在 [DOM Level 3 Core] 中定义）上识别的参数之外，针对 LSParser 的 DOMConfiguration 对象还可以添加或修改以下参数：
"charset-overrides-xml-encoding"
true
[可选]（默认）如果高层协议（如 HTTP）[IETF RFC 2616] 提供了对正被处理的输入流的字符编码的指示，则将重写在 XML 声明或 Text 声明中指定的任何编码（另请参见 [XML 1.0] 中的 4.3.3 节 "Character Encoding in Entities"）。显式在 LSInput 中设置编码将重写协议中的任何编码。
false
[必需] 解析器将忽略高层协议的任何字符集编码信息。
"disallow-doctype"
true
[可选] 如果在解析文档时出现了 doctype 节点，则将抛出严重的 "doctype-not-allowed" 错误。这在处理诸如 SOAP 信封之类的不允许有 doctype 节点的文档时非常有用。
false
[必需]（默认）允许文档中的 doctype 节点。
"ignore-unknown-character-denormalizations"
true
[必需]（默认）如果在检验完全标准化时 [XML 1.1] 受支持，处理器遇到不能为其确定标准化属性的字符时，则处理器将忽略由这些字符导致的任何反向标准化。[XML 1.0]将忽略此参数。
false
[可选] 如果遇到了处理器不能确定其标准化属性的字符，则报告严重的 "unknown-character-denormalization" 错误。
"infoset"
关于此参数的描述请参见 DOMConfiguration 的定义。与在 [DOM Level 3 Core] 中不同，对于 LSParser，此参数将默认为 true。
"namespaces"
true
[必需]（默认）执行在 [XML Namespaces] 和 [XML Namespaces 1.1] 中定义的名称空间处理。
false
[可选] 不执行名称空间处理。
"resource-resolver"
[必需] 对 LSResourceResolver 对象的引用，或为 null。如果遇到外部资源（如外部 XML 实体或 XML 模式位置）时此参数的值不为 null，则实现将请求在此参数中引用的 LSResourceResolver 解析该资源。
"supported-media-types-only"
true
[可选] 检查被解析资源的媒体类型是否为被支持的媒体类型。如果遇到了不支持的媒体类型，则将引发类型 "unsupported-media-type" 的严重错误。必须总是接受在 [IETF RFC 3023] 中定义的媒体类型。
false
[必需]（默认）接受任何媒体类型。
"validate"
关于此参数的描述请参见 DOMConfiguration 的定义。与在 [DOM Level 3 Core] 中不同，总是要完成对内部子集的处理，即使此参数设置为 false。
"validate-if-schema"
关于此参数的描述请参见 DOMConfiguration 的定义。与在 [DOM Level 3 Core] 中不同，总是要完成对内部子集的处理，即使此参数设置为 false。
"well-formed"
关于此参数的描述请参见 DOMConfiguration 的定义。与在 [DOM Level 3 Core] 中不同，不能将此参数设置为 false。

getFilter

LSParserFilter getFilter()
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。过滤器可以选择从正在构建的文档中删除一些元素，或提前终止解析。
过滤器将在应用了 DOMConfiguration 参数请求的操作后调用。例如，如果 "validate" 设置为 true，则在调用过滤器前进行验证。

setFilter

void setFilter(LSParserFilter filter)
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。过滤器可以选择从构建的文档中删除一些元素，或提前终止解析。
过滤器将在使用了 DOMConfiguration 参数请求的操作后调用。例如，如果 "validate" 设置为 true，则在调用过滤器前进行验证。

getAsync

boolean getAsync()
如果 LSParser 是异步的，为 true，如果它是同步的，则为 false。

getBusy

boolean getBusy()
如果 LSParser 当前正忙于加载文档，则为 true，否则为 false。

parse

Document parse(LSInput input)
               throws DOMException,
                      LSException
从通过 LSInput 标识的资源中解析 XML 文档。

参数：
input - 从其中读取文档的源的 LSInput。
返回：
如果 LSParser 是同步 LSParser，则将返回新创建并填充的 Document。如果 LSParser 是异步的，则返回 null，因为当此方法返回时，还不能构建该文档对象。
抛出：
DOMException - INVALID_STATE_ERR:如果 LSParser 的 LSParser.busy 属性为 true，则引发此异常。
LSException - PARSE_ERR:如果 LSParser 无法加载 XML 文档，则引发此异常。如果 DOM 应用程序想获得关于错误的详细信息，则它必须附加一个使用参数 "error-handler" 的 DOMErrorHandler。

parseURI

Document parseURI(String uri)
                  throws DOMException,
                         LSException
从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。如果 URI 包括片段标识符（参见 [IETF RFC 2396] 中的 4.1 节），则该行为不是由此规范定义的，此规范的未来版本可能会定义该行为。

参数：
uri - 将读取的 XML 文档的位置。
返回：
如果 LSParser 是同步 LSParser，则将返回新创建并已填充的 Document，如果发生错误，则返回 null。如果 LSParser 是异步的，则返回 null，因为当此方法返回时，还不可以构建该文档对象。
抛出：
DOMException - INVALID_STATE_ERR:如果 LSParser.busy 属性为 true，则将引发此异常。
LSException - PARSE_ERR:如果 LSParser 无法加载 XML 文档，则将引发此异常。如果 DOM 应用程序想获得关于错误的详细信息，则它必须附加一个使用参数 "error-handler" 的 DOMErrorHandler。

parseWithContext

Node parseWithContext(LSInput input,
                      Node contextArg,
                      short action)
                      throws DOMException,
                             LSException
从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。当解析输入流时，上下文节点（或其父节点，取决于在哪里将结果插入）用于解析未绑定的名称空间前缀。上下文节点的 ownerDocument 节点（如果是类型 DOCUMENT_NODE 的节点，则为节点本身）用来解析默认属性和实体引用。
因为新的数据插入到文档，所以通过上下文节点的直接子节点或兄弟节点将触发至少一个 mutation 事件。
如果上下文节点是 Document 节点并且动作是 ACTION_REPLACE_CHILDREN，则作为上下文节点传递的文档将被更改，以便将其 xmlEncoding、documentURI、xmlVersion、inputEncoding、xmlStandalone 以及所有其他的此类属性都设置为它们将被设置的值（如果使用 LSParser.parse() 解析输入源时）。
此方法始终是同步方法，即使 LSParser 是异步时（LSParser.async 为 true）也是如此。
如果在解析过程中出现错误，则将通过与 DOMConfiguration 的 "error-handler" 参数相关联的 ErrorHandler 实例通知调用者。
当调用 parseWithContext 时，将忽略以下配置参数的值，而是始终使用其默认值：""validate"、"validate-if-schema" 和 "element-content-whitespace"。将正常对待其他参数，期望解析器调用 LSParserFilter就像整个文档被解析一样。

参数：
input - 从中读取源文档的 LSInput。源文档必须是 XML 片段，即除完整的 XML 文档之外的任何文档片段（除了上下文节点的类型为 DOCUMENT_NODE、操作为 ACTION_REPLACE_CHILDREN 的情况）、DOCTYPE（内部子集）、实体声明、符号声明、XML 或文本声明。
contextArg - 用作正被解析的数据的上下文的节点。此节点必须是 Document 节点、DocumentFragment 节点或允许作为 Element 节点的子节点的类型的节点，例如它不能是 Attribute 节点。
action - 此参数描述了在新插入节点的集合与现有的上下文节点的子节点之间应该采取什么动作。可能的动作集在上面的 ACTION_TYPES 中进行定义。
返回：
返回作为解析操作结果的节点。如果结果超过一个顶级节点，则返回第一个节点。
抛出：
DOMException - HIERARCHY_REQUEST_ERR:如果内容不能替换、插入到上下文节点的前面、后面或作为它的子节点（另请参见 [DOM Level 3 Core] 中的 Node.insertBefore 或 Node.replaceChild），则引发此异常。
NOT_SUPPORTED_ERR:如果 LSParser 不支持此方法，或者上下文节点是类型 Document，并且 DOM 实现不支持替换 DocumentType 子节点或 Element 子节点，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR:如果上下文节点是只读节点，并且将内容追加到了其子列表中，或者上下文节点的父节点是只读节点并且将内容插入到了其子列表中，则将引发此异常。
INVALID_STATE_ERR:如果 LSParser.busy 属性为 true，则将引发此异常。
LSException - PARSE_ERR:如果 LSParser 无法加载 XML 片段，则将引发此异常。如果 DOM 应用程序想获得关于错误的详细信息，则它必须附加一个使用参数 "error-handler" 的 DOMErrorHandler。

abort

void abort()
中断对当前由 LSParser 加载的文档的加载。如果当前 LSParser 不忙，则调用此方法无效。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSParserFilter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSParserFilter

public interface LSParserFilter

LSParserFilter 为应用程序提供了在解析期间构建节点时检查这些节点的能力。由于要检查每个节点，所以可能会修改或删除这些节点，或者会提前终止整个解析。

此时解析器会调用任何过滤器器方法，所有者 Document 和 DOMImplementation 对象存在并可访问。从不会将文档元素传递给 LSParserFilter 方法，即不可能过滤出文档元素。Document、DocumentType、Notation、Entity 和 Attr 节点从不会被传递给过滤器上的 acceptNode 方法。如果参数 "entities" 设置为 false，则把 EntityReference 节点的子节点传递给过滤器。注意，如参数 "entities" 所描述的那样，从不会丢弃未展开的实体引用节点，并且始终将它传递给过滤器。

解析文档期间，所有的有效性检查都像它出现在输入流上那样出现在源文档上，而不像在内存中构建它那样出现在 DOM 文档上。使用过滤器，内存中的文档可以是流上文档的子集，并且其有效性可能已受到了过滤的影响。

当将元素传递给过滤器方法时，所有的默认属性必须出现在这些元素上。所有其他默认内容也必须传递给过滤器方法。

DOM 应用程序不能引发过滤器中的异常。从过滤器中抛出异常产生的效果具有 DOM 实现依赖性。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

字段摘要
static short | FILTER_ACCEPT 接受节点。
static short | FILTER_INTERRUPT 中断对文档的常规处理。
static short | FILTER_REJECT 拒绝节点及其子节点。
static short | FILTER_SKIP 跳过此单个节点。
方法摘要
short | acceptNode(Node nodeArg) 此方法将由解析器在完成对每个节点的解析后调用。
int | getWhatToShow() 告知 LSParser 将向方法 LSParserFilter.acceptNode 显示什么类型的节点。
short | startElement(Element elementArg) 解析器将在扫描完每个 Element 启动标记后，处理其余的 Element 之前调用此方法。

字段详细信息

FILTER_ACCEPT

static final short FILTER_ACCEPT
接受节点。

另请参见：
常量字段值

FILTER_REJECT

static final short FILTER_REJECT
拒绝节点及其子节点。

另请参见：
常量字段值

FILTER_SKIP

static final short FILTER_SKIP
跳过此单个节点。仍需考虑此节点的子节点。

另请参见：
常量字段值

FILTER_INTERRUPT

static final short FILTER_INTERRUPT
中断对文档的常规处理。

另请参见：
常量字段值
方法详细信息

startElement

short startElement(Element elementArg)
解析器将在扫描完每个 Element 启动标记后，处理其余的 Element 之前调用此方法。其目的是允许有效跳过包括任何子元素在内的元素。注意，仅将元素节点传递给 startElement 函数。
传递给 startElement 以便过滤的元素节点包括所有的 Element 属性，但不包括任何子节点。Element 还不能放构建的文档中适当的位置（它不能有父节点）。
startElement 过滤器函数可以访问或更改 Element 的属性。更改 Namespace 声明不会对解析器的名称空间解析产生任何影响。
为了提高效率，如果节点被接受，传递给过滤器的 Element 节点不能与实际放置于树中的节点是同一个节点。并且在文档中读取和过滤文档过程中，可以重新使用实际的节点（节点对象标识）。

参数：
elementArg - 新遇到的元素。此时将调用此方法，元素不完整 - 它将有其自己的属性，但没有子项。
返回：
  • FILTER_ACCEPT 如果 Element 必须包括在要构建的 DOM 文档中。
  • FILTER_REJECT 如果 Element 及其所有的子项必须拒绝。
  • FILTER_SKIP 如果 Element 必须跳过。将把它所有的子项插入到跳过的 Element 节点位置。
  • FILTER_INTERRUPT 如果过滤器想停止对文档的处理。中断对文档的处理将不再保证得到的 DOM 树是格式良好的 XML。拒绝 Element。
返回任何其他值都会导致未指定的行为。

acceptNode

short acceptNode(Node nodeArg)
此方法将由解析器在完成对每个节点的解析后调用。节点及其所有后代将存在并且是完整的。父节点也将存在，尽管它可能不是完整的，即它可能有尚未解析的附加子节点。从不将属性节点传递给此函数。
在此方法中，新节点可以随意修改 - 可以添加或移除子节点，修改文本节点等。此节点外面文档的其余部分的状态是没有定义的，并且尝试导航到或修改文档的其他任何部分产生的影响是未定义的。
为了验证解析器，将在过滤器进行任何修改之前检查原始文档。在过滤器执行的任何文档修改上都不进行有效性检查。
如果此新节点被拒绝，则解析器可能会重用该新节点及其所有的后代。

参数：
nodeArg - 新构建的元素。此时调用此方法，该元素是完整的 - 它具有其所有的子节点（和它们的字节点，以此类推）和属性，并且作为子节点连接到它的父节点。
返回：
  • FILTER_ACCEPT 如果此 Node 必须包括在要构建的 DOM 文档中。
  • FILTER_REJECT 如果 Node 及其所有的子节点必须被拒绝。
  • FILTER_SKIP 如果 Node 必须跳过并且 Node 必须由 Node 的所有子节点代替。
  • FILTER_INTERRUPT 如果过滤器想停止对文档的处理。中止对文档的处理将不再保证得到的 DOM 树是格式良好的 XML。Node 被接受，并且将成为最后一个得到完整解析的节点。

getWhatToShow

int getWhatToShow()
告知 LSParser 将向方法 LSParserFilter.acceptNode 显示什么类型的节点。如果没有将某个节点显示给使用此属性的过滤器，则该节点将自动包含在要构建的 DOM 文档中。有关对常量的定义请参见 NodeFilter。常量 SHOW_ATTRIBUTE、SHOW_DOCUMENT、SHOW_DOCUMENT_TYPE、SHOW_NOTATION、SHOW_ENTITY 和 SHOW_DOCUMENT_FRAGMENT 在此无意义。从不会将这些节点传递给 LSParserFilter.acceptNode。
此处使用的常量在 [DOM Level 2 Traversal and Range] 中定义。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSProgressEvent (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSProgressEvent

所有超级接口：
Event
public interface LSProgressEvent
extends Event

此接口表示进度事件对象，该对象在解析文档时通知应用程序有关进度。它扩展在 [DOM Level 3 Events] 中定义的 Event 接口。

用于属性 position 和 totalSize 的单元未指定，并且具有实现和输入依赖性。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

字段摘要
从接口 org.w3c.dom.events.Event 继承的字段
AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE
方法摘要
LSInput | getInput() 被解析的输入源。
int | getPosition() 输入源中的当前位置，包括所有的外部实体和已经读取的其他资源。
int | getTotalSize() 包括所有外部资源的文档的总大小，如果能看到对更多的外部资源的引用，则此数量可能在解析文档时而改变。
从接口 org.w3c.dom.events.Event 继承的方法
getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

方法详细信息

getInput

LSInput getInput()
被解析的输入源。

getPosition

int getPosition()
输入源中的当前位置，包括所有的外部实体和已经读取的其他资源。

getTotalSize

int getTotalSize()
包括所有外部资源的文档的总大小，如果能看到对更多的外部资源的引用，则此数量可能在解析文档时而改变。如果总体大小无法确定或估计，则将返回 0 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSResourceResolver (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSResourceResolver

public interface LSResourceResolver

LSResourceResolver 为应用程序提供了将引用重定向到外部资源的方法。

需要对外部资源实现自定义处理的应用程序可以实现此接口并通过设置连接到 LSParser 和 LSSerializer 的 DOMConfiguration 对象的 "resource-resolver" 参数注册其实现。如果受 "LS" 功能受，该应用程序还可以在连接到 Document 的 DOMConfiguration 对象上注册。

然后 LSParser 将允许应用程序在包含它们以前截取任何外部实体，其中包括外部 DTD 子集和外部参数实体。从不会将顶级文档实体传输给 resolveResource 方法。

许多 DOM 应用程序将不需要实现此接口，但对于从数据库或其他特定的输入源中构建 XML 文档的应用程序，或者使用 URN 的应用程序来说，这特别有用。

注：LSResourceResolver 基于 SAX2 [SAX] EntityResolver 接口。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

方法摘要
 LSInput resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
允许应用程序解析外部资源。

方法详细信息

resolveResource

LSInput resolveResource(String type,
                        String namespaceURI,
                        String publicId,
                        String systemId,
                        String baseURI)
允许应用程序解析外部资源。
LSParser 将在打开任何外部资源前调用此方法，外部资源包括外部 DTD 子集、在 DTD 中引用的外部实体、在文档元素中引用的外部实体（但是不将顶级文档实体传递给此方法）。应用程序然后可以请求 LSParser 解析使用替换的 URI或者使用完全不同的输入源的外部资源本身。
应用程序编写者可以使用此方法将外部系统标识符重定向到安全和/或本地 URI，在目录中查找公共标识符，或从数据库或其他输入源（例如包括对话框）中读取实体。

参数：
type - 被解析的资源的类型。对于 XML [XML 1.0] 资源（即实体），应用程序必须使用值 "http://www.w3.org/TR/REC-xml"。对于 XML 模式 [XML Schema Part 1]，应用程序必须使用值 "http://www.w3.org/2001/XMLSchema"。其他类型的资源在此规范的范围之外，因此为了使用此方法应当推荐绝对 URI。
namespaceURI - 被解析资源的名称空间，例如，解析 XML Schema 资源时 XML Schema [XML Schema Part 1] 的目标名称空间。
publicId - 被引用的外部实体的公共标识符，如果没有提供公共标识符或者资源不是实体，则为 null。
systemId - 公共标识符，它是被引用的外部资源的 URI 引用 [IETF RFC 2396]，如果没有提供系统标识符，则为 null。
baseURI - 被解析资源的绝对基 URI，如果没有基 URI，则为 null。
返回：
一个描述新的输入源的 LSInput 对象，或者返回 null 以请求解析器打开到该资源的规则 URI 连接。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSSerializer (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSSerializer

public interface LSSerializer

LSSerializer 提供了将 DOM 文档序列化（编写）为 XML 的 API。XML 数据被写入字符串或输入流。在序列化期间所做的任何更改或修复仅影响序列化的数据。Document 对象及其子对象永远不会被序列化操作所改变。

在序列化 XML 数据期间，将像在 [DOM Level 3 Core] 的附录 B 中所定义的那样，执行名称空间修复。[DOM Level 2 Core] 允许空字符串作为实际名称空间 URI。如果一个 Node 的 namespaceURI 是空字符串，则序列化将把它们视为 null，从而忽略前缀（如果有）。

LSSerializer 接受任何用于序列化的节点类型。对于 Document 或 Entity 类型的节点，将在可能的情况下创建格式良好的 XML（如果文档或实体来自解析操作并且自创建以来没有改变，则可保证格式良好性）。这些节点类型的序列化输出分别作为 XML 文档或外部 XML 实体，并且是 XML 解析器可接受的输入。对于所有其他类型的节点，序列化格式是依赖于实现的。

在被序列化的 Document、DocumentFragment 或 Entity 内，将按如下方式处理 Nodes

  • 编写 Document 节点，包括 XML 声明（除非参数 "xml-declaration" 设置为 false）和 DTD 子集（如果 DOM 中存在一个）。编写 Document 节点序列化整个文档。
  • 当 Entity 节点直接由 LSSerializer.write 编写时将输出实体扩展，但不执行名称空间修复。得到的输出将作为有效的外部实体。
  • 如果参数 "entities" 设置为 true，则把 EntityReference 节点序列化为输出中形式 " &entityName;" 的实体引用。将忽略实体引用的子节点（扩展）。如果参数 "entities" 设置为 false，则仅序列化实体引用的子项。将始终序列化不带有子项的 EntityReference 节点（没有相应的 Entity 节点，或者相应的 Entity 节点没有子节点）。
  • CDATAsections 包括不能用指定的输出编码表示的内容字符，将根据 "split-cdata-sections" 参数对其进行处理。如果将该参数设置为 true，则将拆分 CDATAsections，将不可表示的字符序列化为普通内容中的数字字符引用。不指定拆分的精确位置和数量。如果参数设置为 false，则参数 "well-formed" 设置为 true 时，CDATAsection 中不可表示的字符将报告为 "wf-invalid-character" 错误。该错误不可恢复 - 没有提供替换字符和继续进行序列化的机制。
  • DocumentFragment 节点可通过按照文档片段的子片段在文档片段中出现的顺序序列化这些子片段得以序列化。
  • 所有其他节点类型（Element、Text 等）都将序列化为其相应的 XML 源格式。

注：序列化 Node 并不总能生成格式良好的 XML 文档，即解析得到的序列化时 LSParser 可能会抛出严重错误。

在文档的字符数据中（在标记之外），任何无法直接表示的字符都将替换为字符引用。'<' 和 '&' 将由预定义实体 < 和 & 替换。除非必需（例如在 ']]>' 这一情况下使用 >），否则不能使用其他预定义实体（>、' 和 "）。无法用输入字符编码直接表示的任何字符都将序列化为数值字符引用（由于字符编码标准一般使用字符的十六进制表示形式，所以在序列化字符引用时鼓励使用十六进制表示形式）。

若要允许属性值同时包括单引号和双引号，可以将省略号或单引号字符 (') 表示为 "'"，双引号字符 (") 表示为 """。无法直接用输出字符编码表示的新行字符和其他字符将被序列化为数值字符引用。

在标记内（但在属性外），无法用输出字符编码表示的任何字符都将被报告为 DOMError 严重错误。其中的一个示例就是使用 encoding="us-ascii" 序列化元素 <LaCa?ada/>。这将导致生成 DOMError "wf-invalid-character-in-node-name"（在 "well-formed" 中建议的）。

当通过将 LSSerializer 上的参数 "normalize-characters" 设置为 true 请求字符标准化时，对所有被序列化的数据（包括标识和字符数据），将根据对 "fully normalized" 字符（包括在 [XML 1.1] 的附录 E 中）的定义实施字符标准化。字符标准化过程只影响正在编写的数据；在序列化完成之后不会改变 DOM 的文档视图。

需要实现支持编码 "UTF-8"、"UTF-16"、"UTF-16BE" 和 "UTF-16LE"，以保证数据在需要得到所有 XML 解析器支持的所有编码中能够序列化。当编码是 UTF-8 时，无论字节顺序标记是否得到了序列化，无论输出是大尾端还是 小尾端，都具有实现依赖性。当编码是 UTF-16 时，无论输出是大尾端还是小尾端，都具有实现依赖性，但必须为非字符输出（如 LSOutput.byteStream 或 LSOutput.systemId）生成字节顺序标记。如果未生成字节顺序标记，则报告一个 "byte-order-mark-needed" 警告。当编码是 UTF-16LE 或 UTF-16BE 时，输出是大尾端 (UTF-16BE) 或小尾端 (UTF-16LE)，将不生成字节顺序标记。在所有这些情况下，编码声明（如果已生成）将与序列化期间使用的编码一致（例如，如果请求 UTF-16，则 encoding="UTF-16" 将出现）。

名称空间将在序列化期间进行修复，序列化过程将检验名称空间声明、名称空间前缀以及与元素和属性相关的名称空间 URI 是否一致。如果发现有不一致，则将改变文档的序列化形式以删除它们。序列化文档时修复名称空间所使用的方法是在 [DOM Level 3 Core] 的附录 B.1 "Namespace normalization" 中定义的算法。

在序列化文档期间，参数 "discard-default-content" 控制是否序列化非指定数据。

在序列化期间，将通过错误处理程序（LSSerializer.domConfig 的 "error-handler" 参数）将错误和警告报告给应用程序。此规范从不尝试定义序列化 DOM 节点期间可能发生的所有错误和警告，但却对一些常见的错误和警告情形做了定义。此规范定义的错误和警告类型 (DOMError.type) 包括：

"no-output-specified" [fatal]
当未在 LSOutput 中指定输出的情况下向 LSOutput 写入时，将引发此错误。
"unbound-prefix-in-entity-reference" [fatal]
引发此错误的情况是：配置参数 "namespaces" 设置为 true，并且在没有名称空间前缀绑定的位置引用了其替换文本包含未绑定的名称空间前缀的实体。
"unsupported-encoding" [fatal]
如果遇到了不受支持的编码，则引发此错误。

除引发定义的错误和警告之外，这些实现还应该针对其他任何错误和警告情况，例如 IO 错误（未找到文件，权限被拒绝）等引发特定于实现的错误和警告。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

方法摘要
DOMConfiguration | getDomConfig() 在序列化 DOM 节点时由 LSSerializer 使用的 DOMConfiguration 对象。
LSSerializerFilter | getFilter() 当应用程序提供过滤器时，在序列化每个节点前串行器先调出过滤器。
String | getNewLine() 在所写出的 XML 中使用的字符的行尾序列。
void | setFilter(LSSerializerFilter filter) 当应用程序提供过滤器时，在序列化每个节点前串行器将先调出过滤器。
void | setNewLine(String newLine) 在所写出的 XML 中使用的字符的行尾序列。
boolean | write(Node nodeArg, LSOutput destination) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
String | writeToString(Node nodeArg) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
boolean | writeToURI(Node nodeArg, String uri) 这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。

方法详细信息

getDomConfig

DOMConfiguration getDomConfig()
在序列化 DOM 节点时由 LSSerializer 使用的 DOMConfiguration 对象。
除由 "DOMConfiguration" 接口（在 [DOM Level 3 Core] 中定义）识别的参数之外，LSSerializer 的 DOMConfiguration 对象还将添加或修改以下参数：
"canonical-form"
true
[可选] 根据在 [Canonical XML] 中指定的规则编写文档。除 "canonical-form》、[DOM Level 3 Core] 中描述的行为外，将此参数设置为 true 将把参数 "format-pretty-print"、"discard-default-content" 和 "xml-declaration " 设置为 false。将其中的一个参数设置为 true 将把此参数设置为 false。当 "canonical-form" 为 true 时序列化 XML 1.1 文档将生成严重错误。
false。
[必需]（默认）不规范化输出。
"discard-default-content"
true
[必需]（默认）使用 Attr.specified 属性来决定必须丢弃哪些属性。注意，有些实现可能使用任何可供实现使用的信息（即 XML 模式、DTD、Attr.specified 属性等）来决定在此参数设置为 true 时应丢弃哪些属性和内容。
false。
[必需] 保留所有属性和所有内容。
"format-pretty-print"
true
[可选] 通过添加空白格式化输出，以产生打印美观的、缩排的、可为人读的格式。转换的准确形式不是由此规范指定的。打印美观性可改变文档的内容，并且会影响文档的有效性，验证实现必须保留有效性。
false。
[必需]（默认）不打印美观化结果。
"ignore-unknown-character-denormalizations"
true
[必需]（默认），如果在 [XML 1.1] 受支持的情况下检查完全标准化时遇到了不能为其确定标准化属性的字符，则将引发一个 "unknown-character-denormalization" 警告（而不是像未设置此参数那样引发错误），并将忽略由这些字符引起的任何可能的反向标准化。
false。
[可选] 如果遇到了处理器不能为其确定标准化属性的字符，则将引发严重错误。
"normalize-characters"
此参数与 [DOM Level 3 Core] 中的 DOMConfiguration 定义的参数等效。与在 Core 中不同，此参数的默认值是 true。尽管根据 [XML 1.1] 中的附录 E 的规定，不需要 DOM 实现支持完全标准化文档中的字符，但如果支持，则默认情况下必须激活此参数。
"xml-declaration"
true
[必需]（默认）如果 Document、Element 或 Entity 节点被序列化，则必须包括 XML 声明或文本声明。版本（如果文档是 Level 3 文档并且版本为非 null，则使用 Document.xmlVersion，否则使用值 "1.0"）和输出编码（关于如何查找输出编码的详细信息请参见 LSSerializer.write ）在已序列化的 XML 声明中指定。
false。
[必需] 不序列化 XML 和文本声明。如果这会引起问题（即已序列化的数据是 XML 版本，而不是 [XML 1.0]，或者必须有编码才能重新解析序列化的数据），则将发出一个 "xml-declaration-needed" 警告。

getNewLine

String getNewLine()
在所写出的 XML 中使用的字符的行尾序列。任何字符都受支持，但 XML 仅将某些字符集序列视为行尾（如果序列化的内容是 XML 1.0，则请参见 [XML 1.0] 中的 2.11 节 "End-of-Line Handling"，如果序列化的内容是 XML 1.1，则请参见 [XML 1.1] 中的 2.11 节 "End-of-Line Handling"）。使用其他字符序列而不是推荐的字符序列会导致文档要么不能序列化，要么不是格式良好的文档。）
检索时，此属性的默认值特定于实现的默认行尾序列。DOM 实现应该选择默认值，以符合所用环境中文本文件的常规约定。实现必须选择与 XML 1.0 或 XML 1.1 所允许的序列匹配的默认序列，具体情况取决于序列化的内容。将此属性设置为 null 将把其值重置为默认值。

setNewLine

void setNewLine(String newLine)
在所写出的 XML 中使用的字符的行尾序列。任何字符都受支持，但 XML 仅将某些字符集序列视为行尾（如果序列化的内容是 XML 1.0，则请参见 [XML 1.0] 中的 2.11 节 "End-of-Line Handling"，如果序列化的内容是 XML 1.1，则请参见 [XML 1.1] 中的 2.11 节 "End-of-Line Handling"）。使用其他字符序列而不是推荐的字符序列会导致文档要么不能序列化，要么不是格式良好的文档。）
检索时，此属性的默认值是特定于实现的默认行尾序列。DOM 实现必须选择默认值，以符合所用环境中文本文件的常规约定。实现必须选择与 XML 1.0 或 XML 1.1 所允许的序列匹配的默认序列，具体情况取决于序列化的内容。将此属性设置为 null 将把其值重置为默认值。

getFilter

LSSerializerFilter getFilter()
当应用程序提供过滤器时，在序列化每个节点前串行器先调出过滤器。过滤器实现可以选择从流中删除节点，或者提前终止序列化。
过滤器将在使用了 DOMConfiguration 参数请求的操作后调用。例如，如果把 "cdata-sections" 设置为 false，则不会将 CDATA 节传递给过滤器。

setFilter

void setFilter(LSSerializerFilter filter)
当应用程序提供过滤器时，在序列化每个节点前串行器将先调出过滤器。过滤器实现可以选择从流中删除节点，或者提前终止序列化。
过滤器将在使用了 DOMConfiguration 参数请求的操作后调用。例如，如果把 "cdata-sections" 设置为 false，则不会将 CDATA 节传递给过滤器。

write

boolean write(Node nodeArg,
              LSOutput destination)
              throws LSException
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。将输出写入所提供的 LSOutput。
当向 LSOutput 写入时，编码可以通过查找可通过 LSOutput 获得的编码信息和按如下顺序编写的条目（或者其所有者文档）来发现：
  1. LSOutput.encoding,
  2. Document.inputEncoding,
  3. Document.xmlEncoding.

如果没有编码可通过上述属性获得，则将使用 "UTF-8" 的默认编码。如果指定的编码不受支持，则将引发 "unsupported-encoding" 严重错误。
如果在 LSOutput 中未指定输出，则将引发 "no-output-specified" 严重错误。
实现负责将适当的媒体类型与已序列化的数据相关联。
当向 HTTP URI 写入时，将执行 HTTP PUT。当向其他类型的 URI 写入时，向 URI 写入数据的机制具有实现依赖性。

参数：
nodeArg - 将序列化的节点。
destination - 已序列化 DOM 的目标。
返回：
如果 node 被成功序列化，则返回 true。如果常规处理停止，但实现仍在序列化文档，则返回 false；序列化的结果是具有实现依赖性。
抛出：
LSException - SERIALIZE_ERR:如果 LSSerializer 不能序列化节点，则引发此异常。如果 DOM 应用程序想获得有关错误的详细信息，则它必须附加上使用参数 "error-handler" 的 DOMErrorHandler。

writeToURI

boolean writeToURI(Node nodeArg,
                   String uri)
                   throws LSException
这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。

参数：
nodeArg - 要序列化的节点。
uri - 要写入到的 URI。
返回：
如果 node 被成功序列化，则返回 true。如果常规处理停止，但实现仍在序列化文档，则返回 false；序列化的结果是具有实现依赖性。
抛出：
LSException - SERIALIZE_ERR:如果 LSSerializer 无法序列化节点，则引发此异常。如果 DOM 应用程序想获得有关错误的详细信息，则它必须附加上使用参数 "error-handler" 的 DOMErrorHandler。

writeToString

String writeToString(Node nodeArg)
                     throws DOMException,
                            LSException
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。将输出写入到返回给调用者的 DOMString。所使用的编码是 DOMString 类型的编码，即 UTF-16。注意，在 DOMString 对象中未生成字节顺序标记。

参数：
nodeArg - 将序列化的节点。
返回：
返回序列化的数据。
抛出：
DOMException - DOMSTRING_SIZE_ERR: 如果得到的字符串太长，不能放在 DOMString 中，则将引发此异常。
LSException - SERIALIZE_ERR: 如果 LSSerializer 不能序列化节点，则引发此异常。如果 DOM 应用程序想获得有关错误的详细信息，则它必须附加上使用参数 "error-handler" 的 DOMErrorHandler。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LSSerializerFilter (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.w3c.dom.ls
接口 LSSerializerFilter

所有超级接口：
org.w3c.dom.traversal.NodeFilter
public interface LSSerializerFilter
extends org.w3c.dom.traversal.NodeFilter

LSSerializerFilter 为应用程序提供了在序列化节点时检查节点以及决定哪些节点应该或不应该序列化的能力。LSSerializerFilter 接口基于 [DOM Level 2 Traversal and Range] 中定义的 NodeFilter 接口。

Document、DocumentType、DocumentFragment、Notation、Entity 和 Attr 节点的子节点不传递给过滤器。如果通过方法 LSParserFilter.acceptNode() 跳过 EntityReference 节点，则仅将 EntityReference 节点的子节点传递给过滤器。

当序列化 Element 时，在将它的所有属性传递给过滤器前将该元素传递给过滤器。从不将名称空间声明属性和默认属性（除了在 " discard-default-content" 设置为 false 时）传递给过滤器。

任何尝试修改传递给 LSSerializerFilter 的节点的结果都将具有实现依赖性。

DOM 应用程序不能引发过滤器中的异常。从过滤器中抛出异常的效果具有 DOM 实现依赖性。

为了提高效率，传递给过滤器的节点不能与实际在树中的节点相同。并且实际的节点（节点对象标识）可以在文档过滤和序列化期间重新使用。

另请参见《Document Object Model (DOM) Level 3 Load and Save Specification》。

字段摘要
从接口 org.w3c.dom.traversal.NodeFilter 继承的字段
FILTER_ACCEPT, FILTER_REJECT, FILTER_SKIP, SHOW_ALL, SHOW_ATTRIBUTE, SHOW_CDATA_SECTION, SHOW_COMMENT, SHOW_DOCUMENT, SHOW_DOCUMENT_FRAGMENT, SHOW_DOCUMENT_TYPE, SHOW_ELEMENT, SHOW_ENTITY, SHOW_ENTITY_REFERENCE, SHOW_NOTATION, SHOW_PROCESSING_INSTRUCTION, SHOW_TEXT
方法摘要
 int getWhatToShow()
告诉 LSSerializer 向过滤器显示什么类型的节点。
从接口 org.w3c.dom.traversal.NodeFilter 继承的方法
acceptNode

方法详细信息

getWhatToShow

int getWhatToShow()
告诉 LSSerializer 向过滤器显示什么类型的节点。如果未将节点显示给使用此属性的过滤器，则将自动序列化。有关对常量的定义请参见 NodeFilter。常量 SHOW_DOCUMENT、SHOW_DOCUMENT_TYPE、SHOW_DOCUMENT_FRAGMENT、SHOW_NOTATION 和 SHOW_ENTITY 在此无意义，从不会将此类节点传递给 LSSerializerFilter。
与 [DOM Level 2 Traversal and Range] 不同，SHOW_ATTRIBUTE 常量表示显示 Attr 节点并将它传递给过滤器。
此处使用的常量在 [DOM Level 2 Traversal and Range] 中定义。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.w3c.dom.ls (Java Platform SE 6)

 org.w3c.dom.ls
接口
DOMImplementationLS
LSInput
LSLoadEvent
LSOutput
LSParser
LSParserFilter
LSProgressEvent
LSResourceResolver
LSSerializer
LSSerializerFilter
异常
LSException


org.w3c.dom.ls (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.w3c.dom.ls

接口摘要
DOMImplementationLS | DOMImplementationLS 包括创建 Load 和 Save 对象的工厂方法。
LSInput | 此接口表示数据的输入源。
LSLoadEvent | 此接口表示通知文档加载完成的加载事件对象。
LSOutput | 此接口表示数据的输出目标。
LSParser | 可以构建的对象接口，或者参数、来自各种输入源的 DOM 树。
LSParserFilter | LSParserFilter 为应用程序提供了在解析期间构建节点时检查这些节点的能力。
LSProgressEvent | 此接口表示进度事件对象，该对象在解析文档时通知应用程序有关进度。
LSResourceResolver | LSResourceResolver 为应用程序提供了将引用重定向到外部资源的方法。
LSSerializer | LSSerializer 提供了将 DOM 文档序列化（编写）为 XML 的 API。
LSSerializerFilter | LSSerializerFilter 为应用程序提供了在序列化节点时检查节点以及决定哪些节点应该或不应该序列化的能力。

异常摘要
LSException 如果处理停止，解析或写操作可以抛出 LSException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.w3c.dom.ls 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.w3c.dom.ls 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.ls.LSException

接口分层结构

  • org.w3c.dom.ls.DOMImplementationLS
  • org.w3c.dom.events.Event
    • org.w3c.dom.ls.LSLoadEvent
    • org.w3c.dom.ls.LSProgressEvent
  • org.w3c.dom.ls.LSInput
  • org.w3c.dom.ls.LSOutput
  • org.w3c.dom.ls.LSParser
  • org.w3c.dom.ls.LSParserFilter
  • org.w3c.dom.ls.LSResourceResolver
  • org.w3c.dom.ls.LSSerializer
  • org.w3c.dom.traversal.NodeFilter
    • org.w3c.dom.ls.LSSerializerFilter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.w3c.dom.ls 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.w3c.dom.ls
的使用

使用 org.w3c.dom.ls 的软件包
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.w3c.dom.ls |

javax.xml.validation 使用的 org.w3c.dom.ls 中的类
LSResourceResolver
LSResourceResolver 为应用程序提供了将引用重定向到外部资源的方法。

org.w3c.dom.ls 使用的 org.w3c.dom.ls 中的类
LSException
如果处理停止，解析或写操作可以抛出 LSException。
LSInput
此接口表示数据的输入源。
LSOutput
此接口表示数据的输出目标。
LSParser
可以构建的对象接口，或者参数、来自各种输入源的 DOM 树。
LSParserFilter
LSParserFilter 为应用程序提供了在解析期间构建节点时检查这些节点的能力。
LSSerializer
LSSerializer 提供了将 DOM 文档序列化（编写）为 XML 的 API。
LSSerializerFilter
LSSerializerFilter 为应用程序提供了在序列化节点时检查节点以及决定哪些节点应该或不应该序列化的能力。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.DOMImplementationLS 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.DOMImplementationLS
的使用

没有 org.w3c.dom.ls.DOMImplementationLS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.w3c.dom.ls.LSException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.w3c.dom.ls.LSException
的使用

使用 LSException 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSException 的使用

抛出 LSException 的 org.w3c.dom.ls 中的方法
Document | LSParser.parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Document | LSParser.parseURI(String uri) 从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。
Node | LSParser.parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
boolean | LSSerializer.write(Node nodeArg, LSOutput destination) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
String | LSSerializer.writeToString(Node nodeArg) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
boolean | LSSerializer.writeToURI(Node nodeArg, String uri) 这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSInput 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSInput
的使用

使用 LSInput 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSInput 的使用

返回 LSInput 的 org.w3c.dom.ls 中的方法
LSInput | DOMImplementationLS.createLSInput() 创建一个新的空输入源对象，其中，LSInput.characterStream、LSInput.byteStream、LSInput.stringData LSInput.systemId、LSInput.publicId、LSInput.baseURI 和 LSInput.encoding 为 null，LSInput.certifiedText 为 false。
LSInput | LSLoadEvent.getInput() 被解析的输入源。
LSInput | LSProgressEvent.getInput() 被解析的输入源。
LSInput | LSResourceResolver.resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI) 允许应用程序解析外部资源。

参数类型为 LSInput 的 org.w3c.dom.ls 中的方法
Document | LSParser.parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Node | LSParser.parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSLoadEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSLoadEvent
的使用

没有 org.w3c.dom.ls.LSLoadEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSOutput 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSOutput
的使用

使用 LSOutput 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSOutput 的使用

返回 LSOutput 的 org.w3c.dom.ls 中的方法
 LSOutput DOMImplementationLS.createLSOutput()
创建新的空输出目标对象，其中，LSOutput.characterStream、LSOutput.byteStream、LSOutput.systemId 和 LSOutput.encoding 为 null。

参数类型为 LSOutput 的 org.w3c.dom.ls 中的方法
 boolean LSSerializer.write(Node nodeArg, LSOutput destination)
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSParser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSParser
的使用

使用 LSParser 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSParser 的使用

返回 LSParser 的 org.w3c.dom.ls 中的方法
 LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
创建一个新的 LSParser。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSParserFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSParserFilter
的使用

使用 LSParserFilter 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSParserFilter 的使用

返回 LSParserFilter 的 org.w3c.dom.ls 中的方法
 LSParserFilter LSParser.getFilter()
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。

参数类型为 LSParserFilter 的 org.w3c.dom.ls 中的方法
 void LSParser.setFilter(LSParserFilter filter)
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSProgressEvent 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSProgressEvent
的使用

没有 org.w3c.dom.ls.LSProgressEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSResourceResolver 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSResourceResolver
的使用

使用 LSResourceResolver 的软件包
javax.xml.validation 此包提供了用于 XML 文档验证的 API。

javax.xml.validation 中 LSResourceResolver 的使用

返回 LSResourceResolver 的 javax.xml.validation 中的方法
abstract LSResourceResolver | SchemaFactory.getResourceResolver() 获取设置为此 SchemaFactory 的当前 LSResourceResolver。
abstract LSResourceResolver | Validator.getResourceResolver() 获取设置为此 Validator 的当前 LSResourceResolver。
abstract LSResourceResolver | ValidatorHandler.getResourceResolver() 获取设置到此 ValidatorHandler 的当前 LSResourceResolver。

参数类型为 LSResourceResolver 的 javax.xml.validation 中的方法
abstract void | SchemaFactory.setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义解析模式时的资源解析。
abstract void | Validator.setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义验证期间的资源解析。
abstract void | ValidatorHandler.setResourceResolver(LSResourceResolver resourceResolver) 设置 LSResourceResolver 以自定义验证期间的资源解析。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSSerializer 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSSerializer
的使用

使用 LSSerializer 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSSerializer 的使用

返回 LSSerializer 的 org.w3c.dom.ls 中的方法
 LSSerializer DOMImplementationLS.createLSSerializer()
创建新的 LSSerializer 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ls.LSSerializerFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ls.LSSerializerFilter
的使用

使用 LSSerializerFilter 的软件包
org.w3c.dom.ls

org.w3c.dom.ls 中 LSSerializerFilter 的使用

返回 LSSerializerFilter 的 org.w3c.dom.ls 中的方法
 LSSerializerFilter LSSerializer.getFilter()
当应用程序提供过滤器时，在序列化每个节点前串行器先调出过滤器。

参数类型为 LSSerializerFilter 的 org.w3c.dom.ls 中的方法
 void LSSerializer.setFilter(LSSerializerFilter filter)
当应用程序提供过滤器时，在序列化每个节点前串行器将先调出过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DOMConfiguration 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMConfiguration
的使用

使用 DOMConfiguration 的软件包
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.ls |

org.w3c.dom 中 DOMConfiguration 的使用

返回 DOMConfiguration 的 org.w3c.dom 中的方法
 DOMConfiguration Document.getDomConfig()
调用 Document.normalizeDocument() 时使用的配置。

org.w3c.dom.ls 中 DOMConfiguration 的使用

返回 DOMConfiguration 的 org.w3c.dom.ls 中的方法
DOMConfiguration | LSParser.getDomConfig() 解析输入源时使用的 DOMConfiguration 对象。
DOMConfiguration | LSSerializer.getDomConfig() 在序列化 DOM 节点时由 LSSerializer 使用的 DOMConfiguration 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DOMError 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMError
的使用

使用 DOMError 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DOMError 的使用

参数类型为 DOMError 的 org.w3c.dom 中的方法
 boolean DOMErrorHandler.handleError(DOMError error)
发生错误时在错误处理程序上调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DOMErrorHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMErrorHandler
的使用

没有 org.w3c.dom.DOMErrorHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DOMImplementation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMImplementation
的使用

使用 DOMImplementation 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap |

javax.xml.parsers 中 DOMImplementation 的使用

返回 DOMImplementation 的 javax.xml.parsers 中的方法
abstract  DOMImplementation DocumentBuilder.getDOMImplementation()
获取 DOMImplementation 对象的一个实例。

org.w3c.dom 中 DOMImplementation 的使用

返回 DOMImplementation 的 org.w3c.dom 中的方法
DOMImplementation | DOMImplementationSource.getDOMImplementation(String features) 请求支持指定的功能的第一个 DOM 实现的方法。
DOMImplementation | Document.getImplementation() 处理此文档的 DOMImplementation 对象。
DOMImplementation | DOMImplementationList.item(int index) 返回集合中的第 index 个项。

org.w3c.dom.bootstrap 中 DOMImplementation 的使用

返回 DOMImplementation 的 org.w3c.dom.bootstrap 中的方法
 DOMImplementation DOMImplementationRegistry.getDOMImplementation(String features)
返回第一个具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DOMImplementationList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMImplementationList
的使用

使用 DOMImplementationList 的软件包
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap |

org.w3c.dom 中 DOMImplementationList 的使用

返回 DOMImplementationList 的 org.w3c.dom 中的方法
 DOMImplementationList DOMImplementationSource.getDOMImplementationList(String features)
请求支持指定功能和版本的 DOM 实现的列表的方法，如下所述。

org.w3c.dom.bootstrap 中 DOMImplementationList 的使用

返回 DOMImplementationList 的 org.w3c.dom.bootstrap 中的方法
 DOMImplementationList DOMImplementationRegistry.getDOMImplementationList(String features)
返回支持所需功能的实现列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DOMImplementationSource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMImplementationSource
的使用

使用 DOMImplementationSource 的软件包
org.w3c.dom.bootstrap

org.w3c.dom.bootstrap 中 DOMImplementationSource 的使用

参数类型为 DOMImplementationSource 的 org.w3c.dom.bootstrap 中的方法
 void DOMImplementationRegistry.addSource(DOMImplementationSource s)
注册实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DOMLocator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMLocator
的使用

使用 DOMLocator 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DOMLocator 的使用

返回 DOMLocator 的 org.w3c.dom 中的方法
 DOMLocator DOMError.getLocation()
错误的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DOMStringList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DOMStringList
的使用

使用 DOMStringList 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DOMStringList 的使用

返回 DOMStringList 的 org.w3c.dom 中的方法
 DOMStringList DOMConfiguration.getParameterNames()
此 DOMConfiguration 对象支持的参数列表，并且应用程序至少可以为其设置一个值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.NameList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.NameList
的使用

没有 org.w3c.dom.NameList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.UserDataHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.UserDataHandler
的使用

使用 UserDataHandler 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 UserDataHandler 的使用

参数类型为 UserDataHandler 的 javax.imageio.metadata 中的方法
 Object IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)

org.w3c.dom 中 UserDataHandler 的使用

参数类型为 UserDataHandler 的 org.w3c.dom 中的方法
 Object Node.setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.Notation 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Notation
的使用

没有 org.w3c.dom.Notation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.ProcessingInstruction 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.ProcessingInstruction
的使用

使用 ProcessingInstruction 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 ProcessingInstruction 的使用

返回 ProcessingInstruction 的 org.w3c.dom 中的方法
 ProcessingInstruction Document.createProcessingInstruction(String target, String data)
创建给定指定名称和数据字符串的 ProcessingInstruction 节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DocumentFragment 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DocumentFragment
的使用

使用 DocumentFragment 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DocumentFragment 的使用

返回 DocumentFragment 的 org.w3c.dom 中的方法
 DocumentFragment Document.createDocumentFragment()
创建空 DocumentFragment 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.DocumentType 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.DocumentType
的使用

使用 DocumentType 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 DocumentType 的使用

返回 DocumentType 的 org.w3c.dom 中的方法
DocumentType | DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId) 创建空 DocumentType 节点。
DocumentType | Document.getDoctype() 与此文档相关的文档类型声明（参见 DocumentType）。

参数类型为 DocumentType 的 org.w3c.dom 中的方法
 Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
创建具有文档元素的指定类型的 DOM Document 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.EntityReference 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.EntityReference
的使用

使用 EntityReference 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 EntityReference 的使用

返回 EntityReference 的 org.w3c.dom 中的方法
 EntityReference Document.createEntityReference(String name)
创建 EntityReference 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.w3c.dom.DOMException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.w3c.dom.DOMException
的使用

使用 DOMException 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |

javax.imageio.metadata 中 DOMException 的使用

抛出 DOMException 的 javax.imageio.metadata 中的方法
short | IIOMetadataNode.compareDocumentPosition(Node other)
String | IIOMetadataNode.getNamespaceURI() 返回 null，因为不支持名称空间。
String | IIOMetadataNode.getNodeValue()
String | IIOMetadataNode.getTextContent()
Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
void | IIOMetadataNode.setIdAttribute(String name, boolean isId)
void | IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)
void | IIOMetadataNode.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
void | IIOMetadataNode.setNodeValue(String nodeValue)
void | IIOMetadataNode.setTextContent(String textContent)

org.w3c.dom 中 DOMException 的使用

抛出 DOMException 的 org.w3c.dom 中的方法
Node | Document.adoptNode(Node source) 试图把另一文档中的节点采用到此文档。
Node | Node.appendChild(Node newChild) 将节点 newChild 添加到此节点的子节点列表的末尾。
void | CharacterData.appendData(String arg) 将字符串追加到节点的字符数据的结尾。
short | Node.compareDocumentPosition(Node other) 就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。
Attr | Document.createAttribute(String name) 创建给定名称的 Attr。
Attr | Document.createAttributeNS(String namespaceURI, String qualifiedName) 创建给定的限定名称和名称空间 URI 的属性。
CDATASection | Document.createCDATASection(String data) 创建其值为指定字符串的 CDATASection 节点。
Document | DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype) 创建具有文档元素的指定类型的 DOM Document 对象。
DocumentType | DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId) 创建空 DocumentType 节点。
Element | Document.createElement(String tagName) 创建指定类型的元素。
Element | Document.createElementNS(String namespaceURI, String qualifiedName) 创建给定的限定名称和名称空间 URI 的元素。
EntityReference | Document.createEntityReference(String name) 创建 EntityReference 对象。
ProcessingInstruction | Document.createProcessingInstruction(String target, String data) 创建给定指定名称和数据字符串的 ProcessingInstruction 节点。
void | CharacterData.deleteData(int offset, int count) 从该节点移除某个范围的 16 位单元。
Attr | Element.getAttributeNodeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 获得 Attr 节点。
String | Element.getAttributeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 获得属性值。
String | CharacterData.getData() 实现此接口的节点的字符数据。
NodeList | Element.getElementsByTagNameNS(String namespaceURI, String localName) 以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。
Node | NamedNodeMap.getNamedItemNS(String namespaceURI, String localName) 检索通过本地名称和名称空间 URI 指定的节点。
String | Node.getNodeValue() 此节点的值，取决于其类型；参见上表。
Object | DOMConfiguration.getParameter(String name) 如果已知，则返回参数的值。
String | Node.getTextContent() 此属性返回此节点及其后代的文本内容。
boolean | Element.hasAttributeNS(String namespaceURI, String localName) 当具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
Node | Document.importNode(Node importedNode, boolean deep) 从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
Node | Node.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
void | CharacterData.insertData(int offset, String arg) 在指定的 16 位单元偏移量位置插入一个字符串。
void | Element.removeAttribute(String name) 通过名称移除一个属性。
Attr | Element.removeAttributeNode(Attr oldAttr) 移除指定的属性节点。
void | Element.removeAttributeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 移除属性值。
Node | Node.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | NamedNodeMap.removeNamedItem(String name) 移除通过名称指定的节点。
Node | NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName) 移除通过本地名称和名称空间 URI 指定的节点。
Node | Document.renameNode(Node n, String namespaceURI, String qualifiedName) 重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
Node | Node.replaceChild(Node newChild, Node oldChild) 将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
void | CharacterData.replaceData(int offset, int count, String arg) 用指定的字符串替换从指定 16 位单元偏移量起始的字符。
Text | Text.replaceWholeText(String content) 将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。
void | Element.setAttribute(String name, String value) 添加一个新属性。
Attr | Element.setAttributeNode(Attr newAttr) 添加新的属性节点。
Attr | Element.setAttributeNodeNS(Attr newAttr) 添加新属性。
void | Element.setAttributeNS(String namespaceURI, String qualifiedName, String value) 添加新属性。
void | ProcessingInstruction.setData(String data) 此处理指令的内容。
void | CharacterData.setData(String data) 实现此接口的节点的字符数据。
void | Element.setIdAttribute(String name, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。
void | Element.setIdAttributeNode(Attr idAttr, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
void | Element.setIdAttributeNS(String namespaceURI, String localName, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
Node | NamedNodeMap.setNamedItem(Node arg) 使用 nodeName 属性添加节点。
Node | NamedNodeMap.setNamedItemNS(Node arg) 使用其 namespaceURI 和 localName 添加节点。
void | Node.setNodeValue(String nodeValue) 此节点的值，取决于其类型；参见上表。
void | DOMConfiguration.setParameter(String name, Object value) 设置参数的值。
void | Node.setPrefix(String prefix) 此节点的名称空间前缀；如果未指定，则为 null。
void | Node.setTextContent(String textContent) 此属性返回此节点及其后代的文本内容。
void | Attr.setValue(String value) 检索时，该属性值以字符串形式返回。
void | Document.setXmlStandalone(boolean xmlStandalone) 作为 XML 声明 的一部分指定此文档是否是单独的的属性。
void | Document.setXmlVersion(String xmlVersion) 作为 XML 声明 的一部分指定此文档版本号的属性。
Text | Text.splitText(int offset) 在指定的 offset 处将此节点拆分为两个节点，并将二者作为兄弟节点保持在树中。
String | CharacterData.substringData(int offset, int count) 从该节点提取某个范围的数据。

org.w3c.dom.events 中 DOMException 的使用

抛出 DOMException 的 org.w3c.dom.events 中的方法
 Event DocumentEvent.createEvent(String eventType)

org.w3c.dom.ls 中 DOMException 的使用

抛出 DOMException 的 org.w3c.dom.ls 中的方法
LSParser | DOMImplementationLS.createLSParser(short mode, String schemaType) 创建一个新的 LSParser。
Document | LSParser.parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Document | LSParser.parseURI(String uri) 从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。
Node | LSParser.parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
String | LSSerializer.writeToString(Node nodeArg) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.CDATASection 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.CDATASection
的使用

使用 CDATASection 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 CDATASection 的使用

返回 CDATASection 的 org.w3c.dom 中的方法
 CDATASection Document.createCDATASection(String data)
创建其值为指定字符串的 CDATASection 节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.Entity 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Entity
的使用

没有 org.w3c.dom.Entity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.Comment 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Comment
的使用

使用 Comment 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 Comment 的使用

返回 Comment 的 org.w3c.dom 中的方法
 Comment Document.createComment(String data)
创建给定指定字符串的 Comment 节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.Text 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Text
的使用

使用 Text 的软件包
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.xml.soap 中 Text 的使用

javax.xml.soap 中 Text 的子接口
 interface Text
值为文本的节点的表示形式。

org.w3c.dom 中 Text 的使用

org.w3c.dom 中 Text 的子接口
 interface CDATASection
CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。

返回 Text 的 org.w3c.dom 中的方法
Text | Document.createTextNode(String data) 创建给定指定字符串的 Text 节点。
Text | Text.replaceWholeText(String content) 将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。
Text | Text.splitText(int offset) 在指定的 offset 处将此节点拆分为两个节点，并将二者作为兄弟节点保持在树中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.CharacterData 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.CharacterData
的使用

使用 CharacterData 的软件包
org.w3c.dom 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom 中 CharacterData 的使用

org.w3c.dom 中 CharacterData 的子接口
interface | CDATASection CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。
interface | Comment 此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。
interface | Text 该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.Attr 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Attr
的使用

使用 Attr 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 Attr 的使用

返回 Attr 的 javax.imageio.metadata 中的方法
Attr | IIOMetadataNode.getAttributeNode(String name)
Attr | IIOMetadataNode.getAttributeNodeNS(String namespaceURI, String localName) 等效于 getAttributeNode(localName)。
Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
Attr | IIOMetadataNode.setAttributeNodeNS(Attr newAttr) 等效于 setAttributeNode(newAttr)。

参数类型为 Attr 的 javax.imageio.metadata 中的方法
Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
Attr | IIOMetadataNode.setAttributeNodeNS(Attr newAttr) 等效于 setAttributeNode(newAttr)。
void | IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)

org.w3c.dom 中 Attr 的使用

返回 Attr 的 org.w3c.dom 中的方法
Attr | Document.createAttribute(String name) 创建给定名称的 Attr。
Attr | Document.createAttributeNS(String namespaceURI, String qualifiedName) 创建给定的限定名称和名称空间 URI 的属性。
Attr | Element.getAttributeNode(String name) 通过名称获得属性节点。
Attr | Element.getAttributeNodeNS(String namespaceURI, String localName) 通过本地名称和名称空间 URI 获得 Attr 节点。
Attr | Element.removeAttributeNode(Attr oldAttr) 移除指定的属性节点。
Attr | Element.setAttributeNode(Attr newAttr) 添加新的属性节点。
Attr | Element.setAttributeNodeNS(Attr newAttr) 添加新属性。

参数类型为 Attr 的 org.w3c.dom 中的方法
Attr | Element.removeAttributeNode(Attr oldAttr) 移除指定的属性节点。
Attr | Element.setAttributeNode(Attr newAttr) 添加新的属性节点。
Attr | Element.setAttributeNodeNS(Attr newAttr) 添加新属性。
void | Element.setIdAttributeNode(Attr idAttr, boolean isId) 如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.NamedNodeMap 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.NamedNodeMap
的使用

使用 NamedNodeMap 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 NamedNodeMap 的使用

返回 NamedNodeMap 的 javax.imageio.metadata 中的方法
 NamedNodeMap IIOMetadataNode.getAttributes()

org.w3c.dom 中 NamedNodeMap 的使用

返回 NamedNodeMap 的 org.w3c.dom 中的方法
NamedNodeMap | Node.getAttributes() 包含此节点的属性的 NamedNodeMap（如果它是 Element）；否则为 null。
NamedNodeMap | DocumentType.getEntities() 包含在 DTD 中声明的内部和外部常规实体的 NamedNodeMap。
NamedNodeMap | DocumentType.getNotations() 包含在 DTD 中声明的表示法的 NamedNodeMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.TypeInfo 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.TypeInfo
的使用

使用 TypeInfo 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 TypeInfo 的使用

返回 TypeInfo 的 javax.imageio.metadata 中的方法
 TypeInfo IIOMetadataNode.getSchemaTypeInfo()

javax.xml.validation 中 TypeInfo 的使用

返回 TypeInfo 的 javax.xml.validation 中的方法
abstract TypeInfo | TypeInfoProvider.getAttributeTypeInfo(int index) 返回指定的当前元素属性的不可变的 TypeInfo 对象。
abstract TypeInfo | TypeInfoProvider.getElementTypeInfo() 返回当前元素的不可变的 TypeInfo 对象。

org.w3c.dom 中 TypeInfo 的使用

返回 TypeInfo 的 org.w3c.dom 中的方法
TypeInfo | Attr.getSchemaTypeInfo() 与此属性相关联的类型信息。
TypeInfo | Element.getSchemaTypeInfo() 与此元素相关的类型信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.Element 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Element
的使用

使用 Element 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.ls |

javax.imageio.metadata 中 Element 的使用

实现 Element 的 javax.imageio.metadata 中的类
 class IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

javax.xml.bind.annotation 中 Element 的使用

返回 Element 的 javax.xml.bind.annotation 中的方法
 Element W3CDomHandler.getElement(DOMResult r)

参数类型为 Element 的 javax.xml.bind.annotation 中的方法
 Source W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

javax.xml.crypto.dom 中 Element 的使用

返回 Element 的 javax.xml.crypto.dom 中的方法
 Element DOMCryptoContext.getElementById(String idValue)
返回具有指定 ID 属性值的 Element。

参数类型为 Element 的 javax.xml.crypto.dom 中的方法
 void DOMCryptoContext.setIdAttributeNS(Element element, String namespaceURI, String localName)
将名称空间 URI 和本地名称指定的元素属性注册为类型 ID。

javax.xml.soap 中 Element 的使用

javax.xml.soap 中 Element 的子接口
interface | Detail DetailEntry 对象的容器。
interface | DetailEntry Detail 对象的内容，给出 SOAPFault 对象的详细信息。
interface | SOAPBody 表示 SOAP 消息中 SOAP 正文元素内容的对象。
interface | SOAPBodyElement 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
interface | SOAPElement 表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
interface | SOAPEnvelope SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
interface | SOAPFault SOAPBody 对象中的元素，包含错误和/或状态信息。
interface | SOAPFaultElement SOAPFault 对象内容的表示形式。
interface | SOAPHeader SOAP 头元素的表示形式。
interface | SOAPHeaderElement 表示 SOAP 信封 SOAP 头部分的内容的对象。

参数类型为 Element 的 javax.xml.soap 中的方法
 SOAPElement SOAPFactory.createElement(Element domElement)
根据现有的 DOM Element 创建 SOAPElement 对象。

org.w3c.dom 中 Element 的使用

返回 Element 的 org.w3c.dom 中的方法
Element | Document.createElement(String tagName) 创建指定类型的元素。
Element | Document.createElementNS(String namespaceURI, String qualifiedName) 创建给定的限定名称和名称空间 URI 的元素。
Element | Document.getDocumentElement() 这是一种便捷属性，该属性允许直接访问文档的文档元素的子节点。
Element | Document.getElementById(String elementId) 返回具有带给定值的 ID 属性的 Element。
Element | Attr.getOwnerElement() 此属性连接到的 Element 节点；如果未使用此属性，则为 null。

org.w3c.dom.ls 中 Element 的使用

参数类型为 Element 的 org.w3c.dom.ls 中的方法
 short LSParserFilter.startElement(Element elementArg)
解析器将在扫描完每个 Element 启动标记后，处理其余的 Element 之前调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.NodeList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.NodeList
的使用

使用 NodeList 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

javax.imageio.metadata 中 NodeList 的使用

实现 NodeList 的 javax.imageio.metadata 中的类
 class IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

返回 NodeList 的 javax.imageio.metadata 中的方法
NodeList | IIOMetadataNode.getChildNodes()
NodeList | IIOMetadataNode.getElementsByTagName(String name)
NodeList | IIOMetadataNode.getElementsByTagNameNS(String namespaceURI, String localName) 等效于 getElementsByTagName(localName)。

org.w3c.dom 中 NodeList 的使用

返回 NodeList 的 org.w3c.dom 中的方法
NodeList | Node.getChildNodes() 包含此节点的所有子节点的 NodeList。
NodeList | Element.getElementsByTagName(String name) 以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。
NodeList | Document.getElementsByTagName(String tagname) 按文档顺序返回包含在文档中且具有给定标记名称的所有 Element 的 NodeList。
NodeList | Element.getElementsByTagNameNS(String namespaceURI, String localName) 以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。
NodeList | Document.getElementsByTagNameNS(String namespaceURI, String localName) 以文档顺序返回具有给定本地名称和名称空间 URI 的所有 Elements 的 NodeList。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.Document 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Document
的使用

使用 Document 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.ls |

javax.imageio.metadata 中 Document 的使用

返回 Document 的 javax.imageio.metadata 中的方法
 Document IIOMetadataNode.getOwnerDocument()
返回 null，因为 IIOMetadataNode 不属于任何 Document。

javax.xml.parsers 中 Document 的使用

返回 Document 的 javax.xml.parsers 中的方法
abstract Document | DocumentBuilder.newDocument() 获取 DOM Document 对象的一个新实例来生成一个 DOM 树。
Document | DocumentBuilder.parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
abstract Document | DocumentBuilder.parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(String uri) 将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。

javax.xml.soap 中 Document 的使用

实现 Document 的 javax.xml.soap 中的类
 class SOAPPart
SOAPMessage 对象中特定于 SOAP 部分的容器。

返回 Document 的 javax.xml.soap 中的方法
 Document SOAPBody.extractContentAsDocument()
创建新的 DOM Document，并将此 SOAPBody 的第一个子元素设置为它的文档元素。

参数类型为 Document 的 javax.xml.soap 中的方法
 SOAPBodyElement SOAPBody.addDocument(Document document)
将 DOM Document 的根节点添加到此 SOAPBody 对象。

org.w3c.dom 中 Document 的使用

返回 Document 的 org.w3c.dom 中的方法
Document | DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype) 创建具有文档元素的指定类型的 DOM Document 对象。
Document | Node.getOwnerDocument() 与此节点相关的 Document 对象。

org.w3c.dom.ls 中 Document 的使用

返回 Document 的 org.w3c.dom.ls 中的方法
Document | LSLoadEvent.getNewDocument() 完成加载的文档。
Document | LSParser.parse(LSInput input) 从通过 LSInput 标识的资源中解析 XML 文档。
Document | LSParser.parseURI(String uri) 从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.w3c.dom.Node 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.w3c.dom.Node
的使用

使用 Node 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |

javax.imageio.metadata 中 Node 的使用

实现 Node 的 javax.imageio.metadata 中的类
 class IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

声明为 Node 的 javax.imageio.metadata 中的字段
protected  Node IIOInvalidTreeException.offendingNode
导致解析错误的 Node，或 null。

返回 Node 的 javax.imageio.metadata 中的方法
Node | IIOMetadataNode.appendChild(Node newChild) 将节点 newChild 添加到此节点子节点列表的末尾。
Node | IIOMetadataNode.cloneNode(boolean deep) 返回此节点的副本。
abstract Node | IIOMetadata.getAsTree(String formatName) 返回 XML DOM Node 对象，该对象表示此对象所包含的元数据树的根（根据给定元数据格式定义的约定）。
Node | IIOMetadataNode.getFirstChild() 此节点的第一个子节点；如果该节点没有子节点，则返回 null。
Node | IIOMetadataNode.getLastChild() 返回此节点的最后一个子节点；如果该节点没有子节点，则返回 null。
Node | IIOMetadataNode.getNextSibling() 返回此节点的下一个兄弟节点；如果该节点没有下一个兄弟节点，则返回 null。
Node | IIOInvalidTreeException.getOffendingNode() 返回导致解析错误的 Node。
Node | IIOMetadataNode.getParentNode() 返回此节点的父节点。
Node | IIOMetadataNode.getPreviousSibling() 返回此节点的上一个兄弟节点；如果该节点没有上一个兄弟节点，则返回 null。
Node | IIOMetadataNode.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
Node | IIOMetadataNode.item(int index)
Node | IIOMetadataNode.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | IIOMetadataNode.replaceChild(Node newChild, Node oldChild) 将子节点 oldChild 替换为子节点列表中的 newChild，并返回 oldChild 节点。

参数类型为 Node 的 javax.imageio.metadata 中的方法
Node | IIOMetadataNode.appendChild(Node newChild) 将节点 newChild 添加到此节点子节点列表的末尾。
short | IIOMetadataNode.compareDocumentPosition(Node other)
Node | IIOMetadataNode.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
boolean | IIOMetadataNode.isEqualNode(Node node)
boolean | IIOMetadataNode.isSameNode(Node node)
abstract void | IIOMetadata.mergeTree(String formatName, Node root) 根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。
Node | IIOMetadataNode.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | IIOMetadataNode.replaceChild(Node newChild, Node oldChild) 将子节点 oldChild 替换为子节点列表中的 newChild，并返回 oldChild 节点。
void | IIOMetadata.setFromTree(String formatName, Node root) 根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。

参数类型为 Node 的 javax.imageio.metadata 中的构造方法
IIOInvalidTreeException(String message, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串和对导致解析错误的 Node 的引用。
IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。

javax.xml.bind 中 Node 的使用

返回 Node 的 javax.xml.bind 中的方法
Node | ValidationEventLocator.getNode() 返回对 DOM Node 的引用（如果可用）。
Node | Marshaller.getNode(Object contentTree) 获取内容树的 DOM 树视图（可选）。

返回变量类型为 Node 的类型的 javax.xml.bind 中的方法
 Binder<Node> JAXBContext.createBinder()
为 W3C DOM 创建一个 Binder。

参数类型为 Node 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, Node node)
将以 jaxbElement 为根的内容树编组到 DOM 树中。
 Object Unmarshaller.unmarshal(Node node)
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 Node 的使用

返回 Node 的 javax.xml.bind.helpers 中的方法
Node | ValidationEventLocatorImpl.getNode()
Node | AbstractMarshallerImpl.getNode(Object obj) 默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。

参数类型为 Node 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, Node node)
 void ValidationEventLocatorImpl.setNode(Node _node)
在此事件定位符上设置 Node 字段。
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)

参数类型为 Node 的 javax.xml.bind.helpers 中的构造方法
ValidationEventLocatorImpl(Node _node)
构造一个指向 DOM Node 的对象。

javax.xml.crypto.dom 中 Node 的使用

返回 Node 的 javax.xml.crypto.dom 中的方法
Node | DOMURIReference.getHere() 返回当前位置的节点。
Node | DOMStructure.getNode() 返回包含在此 DOMStructure 中的节点。

参数类型为 Node 的 javax.xml.crypto.dom 中的构造方法
DOMStructure(Node node)
创建包含指定节点的 DOMStructure。

javax.xml.crypto.dsig.dom 中 Node 的使用

返回 Node 的 javax.xml.crypto.dsig.dom 中的方法
Node | DOMSignContext.getNextSibling() 返回 nextSibling 节点。
Node | DOMValidateContext.getNode() 返回节点。
Node | DOMSignContext.getParent() 返回父节点。

参数类型为 Node 的 javax.xml.crypto.dsig.dom 中的方法
void | DOMSignContext.setNextSibling(Node nextSibling) 设置下一个兄弟节点。
void | DOMValidateContext.setNode(Node node) 设置节点。
void | DOMSignContext.setParent(Node parent) 设置父节点。

参数类型为 Node 的 javax.xml.crypto.dsig.dom 中的构造方法
DOMSignContext(Key signingKey, Node parent)
创建带有指定签名密钥和父节点的 DOMSignContext。
DOMSignContext(Key signingKey, Node parent, Node nextSibling)
创建带有指定的签名密钥、父节点和下一个兄弟节点的 DOMSignContext。
DOMSignContext(KeySelector ks, Node parent)
创建带有指定密钥选择器和父节点的 DOMSignContext。
DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
创建带有指定密钥选择器、父节点和下一个兄弟节点的 DOMSignContext。
DOMValidateContext(Key validatingKey, Node node)
创建包含指定密钥和节点的 DOMValidateContext。
DOMValidateContext(KeySelector ks, Node node)
创建包含指定密钥选择器和节点的 DOMValidateContext。

javax.xml.soap 中 Node 的使用

javax.xml.soap 中 Node 的子接口
interface | Detail DetailEntry 对象的容器。
interface | DetailEntry Detail 对象的内容，给出 SOAPFault 对象的详细信息。
interface | Node XML 文档中节点（元素）的表示形式。
interface | SOAPBody 表示 SOAP 消息中 SOAP 正文元素内容的对象。
interface | SOAPBodyElement 表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
interface | SOAPElement 表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
interface | SOAPEnvelope SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
interface | SOAPFault SOAPBody 对象中的元素，包含错误和/或状态信息。
interface | SOAPFaultElement SOAPFault 对象内容的表示形式。
interface | SOAPHeader SOAP 头元素的表示形式。
interface | SOAPHeaderElement 表示 SOAP 信封 SOAP 头部分的内容的对象。

实现 Node 的 javax.xml.soap 中的类
 class SOAPPart
SOAPMessage 对象中特定于 SOAP 部分的容器。

javax.xml.transform.dom 中 Node 的使用

返回 Node 的 javax.xml.transform.dom 中的方法
Node | DOMResult.getNextSibling() 获取将要插入的结果节点之后的子节点。
Node | DOMResult.getNode() 获取将包含结果 DOM 树的节点。
Node | DOMSource.getNode() 获取表示 Source DOM 树的节点。
Node | DOMLocator.getOriginatingNode() 返回事件发生的节点位置。

参数类型为 Node 的 javax.xml.transform.dom 中的方法
void | DOMResult.setNextSibling(Node nextSibling) 设置将要插入的结果节点之后的子节点。
void | DOMResult.setNode(Node node) 设置将包含结果 DOM 树的节点。
void | DOMSource.setNode(Node node) 设置将表示 Source DOM 树的节点。

参数类型为 Node 的 javax.xml.transform.dom 中的构造方法
DOMResult(Node node)
使用 DOM 节点创建新输出目标。
DOMResult(Node node, Node nextSibling)
使用 DOM 节点创建新输出目标，此目标指定了应该插入的结果节点之后的子节点。
DOMResult(Node node, Node nextSibling, String systemId)
使用 DOM 节点创建新输出目标，此目标指定了子节点，其中结果节点为指定 System ID 且应该插入到该子节点之前。
DOMResult(Node node, String systemId)
使用 DOM 节点创建带有指定 System ID 的新输出目标。
DOMSource(Node n)
创建带有 DOM 节点的新输入源。
DOMSource(Node node, String systemID)
创建带有 DOM 节点的新输入源，系统 ID 也作为基本 URI 被传入。

org.w3c.dom 中 Node 的使用

org.w3c.dom 中 Node 的子接口
interface | Attr Attr 接口表示 Element 对象中的属性。
interface | CDATASection CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。
interface | CharacterData CharacterData 接口使用属性集合和用于访问 DOM 中字符数据的方法扩展节点。
interface | Comment 此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。
interface | Document Document 接口表示整个 HTML 或 XML 文档。
interface | DocumentFragment DocumentFragment 是“轻量级”或“最小”Document 对象。
interface | DocumentType 每个 Document 都有 doctype 属性，该属性的值可以为 null，也可以为 DocumentType 对象。
interface | Element Element 接口表示 HTML 或 XML 文档中的一个元素。
interface | Entity 此接口表示在 XML 文档中解析和未解析的已知实体。
interface | EntityReference EntityReference 节点可以用来在树中表示实体引用。
interface | Notation 此接口表示在 DTD 中声明的表示法。
interface | ProcessingInstruction ProcessingInstruction 接口表示“处理指令”，该指令作为一种在文档的文本中保持特定于处理器的信息的方法在 XML 中使用。
interface | Text 该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。

返回 Node 的 org.w3c.dom 中的方法
Node | Document.adoptNode(Node source) 试图把另一文档中的节点采用到此文档。
Node | Node.appendChild(Node newChild) 将节点 newChild 添加到此节点的子节点列表的末尾。
Node | Node.cloneNode(boolean deep) 返回此节点的副本，即允当节点的一般复制构造方法。
Node | Node.getFirstChild() 此节点的第一个子节点。
Node | Node.getLastChild() 此节点的最后一个节点。
Node | NamedNodeMap.getNamedItem(String name) 检索通过名称指定的节点。
Node | NamedNodeMap.getNamedItemNS(String namespaceURI, String localName) 检索通过本地名称和名称空间 URI 指定的节点。
Node | Node.getNextSibling() 直接在此节点之后的节点。
Node | Node.getParentNode() 此节点的父节点。
Node | Node.getPreviousSibling() 直接在此节点之前的节点。
Node | DOMLocator.getRelatedNode() 此定位器指向的节点；如果没有可用的节点，则为 null。
Node | Document.importNode(Node importedNode, boolean deep) 从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
Node | Node.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
Node | NamedNodeMap.item(int index) 返回映射中第 index 个项。
Node | NodeList.item(int index) 返回集合中的第 index 个项。
Node | Node.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | NamedNodeMap.removeNamedItem(String name) 移除通过名称指定的节点。
Node | NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName) 移除通过本地名称和名称空间 URI 指定的节点。
Node | Document.renameNode(Node n, String namespaceURI, String qualifiedName) 重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
Node | Node.replaceChild(Node newChild, Node oldChild) 将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
Node | NamedNodeMap.setNamedItem(Node arg) 使用 nodeName 属性添加节点。
Node | NamedNodeMap.setNamedItemNS(Node arg) 使用其 namespaceURI 和 localName 添加节点。

参数类型为 Node 的 org.w3c.dom 中的方法
Node | Document.adoptNode(Node source) 试图把另一文档中的节点采用到此文档。
Node | Node.appendChild(Node newChild) 将节点 newChild 添加到此节点的子节点列表的末尾。
short | Node.compareDocumentPosition(Node other) 就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。
void | UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst) 每当导入或克隆为其注册此处理程序的节点时，调用此方法。
Node | Document.importNode(Node importedNode, boolean deep) 从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
Node | Node.insertBefore(Node newChild, Node refChild) 在现有子节点 refChild 之前插入节点 newChild。
boolean | Node.isEqualNode(Node arg) 测试两个节点是否相等。
boolean | Node.isSameNode(Node other) 返回此节点是否是与给定节点相同的节点。
Node | Node.removeChild(Node oldChild) 从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
Node | Document.renameNode(Node n, String namespaceURI, String qualifiedName) 重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
Node | Node.replaceChild(Node newChild, Node oldChild) 将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
Node | NamedNodeMap.setNamedItem(Node arg) 使用 nodeName 属性添加节点。
Node | NamedNodeMap.setNamedItemNS(Node arg) 使用其 namespaceURI 和 localName 添加节点。

org.w3c.dom.events 中 Node 的使用

返回 Node 的 org.w3c.dom.events 中的方法
 Node MutationEvent.getRelatedNode()
relatedNode 用于识别与 mutation 事件相关联的辅助节点。

参数类型为 Node 的 org.w3c.dom.events 中的方法
 void MutationEvent.initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
该 initMutationEvent 方法用于初始化通过 DocumentEvent 接口创建的 MutationEvent 的值。

org.w3c.dom.ls 中 Node 的使用

返回 Node 的 org.w3c.dom.ls 中的方法
 Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。

参数类型为 Node 的 org.w3c.dom.ls 中的方法
short | LSParserFilter.acceptNode(Node nodeArg) 此方法将由解析器在完成对每个节点的解析后调用。
Node | LSParser.parseWithContext(LSInput input, Node contextArg, short action) 从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
boolean | LSSerializer.write(Node nodeArg, LSOutput destination) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
String | LSSerializer.writeToString(Node nodeArg) 像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
boolean | LSSerializer.writeToURI(Node nodeArg, String uri) 这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AttributeList (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 AttributeList

所有已知实现类：
AttributeListImpl
已过时。 此接口已经被 SAX2 Attributes 接口取代，后者包括名称空间支持。

public interface AttributeList

用于元素的属性规范的接口。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

这是用于报告元素的属性的原始 SAX1 接口。与新的 Attributes 接口不同，它不支持与名称空间相关的信息。

当把属性列表作为 startElement 事件的一部分提供时，该列表将返回仅在该事件范围内的有效结果；一旦事件处理程序将控制返回给解析器，则该属性列表无效。若要保存属性列表的永久性副本，请使用 SAX1 AttributeListImpl helper 类。

属性列表只包括已经指定的或默认的属性：#IMPLIED 属性将不包括在内。

对于 SAX 应用程序，有两种方法来获取来自 AttributeList 的信息。第一，它可以迭代整个列表：

 public void startElement (String name, AttributeList atts) {
   for (int i = 0; i < atts.getLength(); i++) {
     String name = atts.getName(i);
     String type = atts.getType(i);
     String value = atts.getValue(i);
     [...]
   }
 }

（注意，如果没有属性，则 getLength() 的结果将是零。）

作为选择，该应用程序可以请求特定属性的值或类型：

 public void startElement (String name, AttributeList atts) {
   String identifier = atts.getValue("id");
   String label = atts.getValue("label");
   [...]
 }

从以下版本开始：
SAX 1.0
另请参见：
startElement, AttributeListImpl

方法摘要
int | getLength() 已过时。 返回此列表中属性的个数。
String | getName(int i) 已过时。 返回此列表中属性的名称（根据位置）。
String | getType(int i) 已过时。 返回列表中属性的类型（根据位置）。
String | getType(String name) 已过时。 返回列表中属性的类型（根据名称）。
String | getValue(int i) 已过时。 返回列表中属性的值（根据位置）。
String | getValue(String name) 已过时。 返回列表中属性的值（根据名称）。

方法详细信息

getLength

int getLength()
已过时。
返回此列表中属性的个数。

SAX 解析器能够以任意顺序提供属性，而与其声明或指定的顺序无关。属性的个数可以为零。

返回：
此列表中属性的个数。

getName

String getName(int i)
已过时。
返回此列表中属性的名称（根据位置）。

名称必须是唯一的：SAX 解析器不能两次包括同一属性。将从列表中忽略不带有值的属性（那些在启动标记中不带指定值的声明的 #IMPLIED）。

如果属性名称具有名称空间前缀，则仍将带上该前缀。

参数：
i - 列表中属性的索引（从 0 开始）。
返回：
被索引的属性的名称，如果索引超出范围，则返回 null。
另请参见：
getLength()

getType

String getType(int i)
已过时。
返回列表中属性的类型（根据位置）。

属性类型是下列字符串之一："CDATA"、"ID"、"IDREF"、"IDREFS"、"NMTOKEN"、"NMTOKENS"、"ENTITY"、"ENTITIES" 或 "NOTATION"（始终用大写字母）。

如果解析器尚未读取属性的声明，或者解析器没有报告属性类型，则必须返回值 "CDATA"，这一点在“XML 1.0 建议书”（第 3.3.3 条款，“属性值标准化”）中规定。

对于不是注释的可枚举的属性，解析器将把类型报告为 "NMTOKEN"。

参数：
i - 列表中属性的索引（从 0 开始）。
返回：
字符串形式的属性类型，如果索引超出范围，则返回 null。
另请参见：
getLength(), getType(java.lang.String)

getValue

String getValue(int i)
已过时。
返回列表中属性的值（根据位置）。

如果属性值是标记（IDREFS、ENTITIES 或 NMTOKENS）列表，则将把这些标记串接成用空白分开的单个字符串。

参数：
i - 列表中属性的索引（从 0 开始）。
返回：
字符串形式的属性值，如果索引超出范围，则返回 null。
另请参见：
getLength(), getValue(java.lang.String)

getType

String getType(String name)
已过时。
返回列表中属性的类型（根据名称）。

返回值与 getType(int) 的返回值相同。

如果属性名称在文档中具有名称空间前缀，则应用程序必须在此处包括前缀。

参数：
name - 属性的名称。
返回：
字符串形式的属性类型，如果不存在此类属性，则返回 null。
另请参见：
getType(int)

getValue

String getValue(String name)
已过时。
返回列表中属性的值（根据名称）。

返回值与 getValue(int) 的返回值相同。

如果属性名称在文档中具有名称空间前缀，则应用程序必须在此处包括前缀。

参数：
name - 要返回的属性的名称
返回：
字符串形式的属性值，如果不存在此类属性，则返回 null。
另请参见：
getValue(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Attributes (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 Attributes

所有已知子接口：
Attributes2
所有已知实现类：
Attributes2Impl, AttributesImpl
public interface Attributes

关于 XML 属性列表的接口。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

此接口允许用以下三种不同方式访问属性列表：

  1. 通过属性索引；
  2. 通过名称空间限定的名称；或者
  3. 通过限定（前缀）名。

该列表将不包括被声明为 #IMPLIED、但未在启动标记中指定的那些属性。还不包括用作名称空间声明 (xmlns*) 的属性，除非 http://xml.org/sax/features/namespace-prefixes 功能设置为 true（默认情况下是 false）。由于 SAX2 与原始的 "Namespaces in XML" 建议一致，所以它一般不为名称空间声明属性提供名称空间 URI。

有些 SAX2 解析器可能支持使用可选的功能标记 (http://xml.org/sax/features/xmlns-uris) 请求为这些属性提供 URI，以便与该建议书以后的向后兼容的版本一致。（属性的“本地名称”将成为前缀，而在定义默认的元素名称空间时 "xmlns" 将成为前缀。）为了具有可移植性，处理程序代码应该始终解析该冲突，而不是要求解析器能够改变该功能标记的设置。

如果名称空间前缀功能（参见上述内容）为 false，则可能无法通过限定名访问；如果 http://xml.org/sax/features/namespaces 功能为 false，则也无法通过名称空间限定名访问。

此接口取代现在不推荐使用的 SAX1 AttributeList 接口，后者不包括名称空间支持。除名称空间支持外，它还增加了 getIndex 方法（见下面）。

列表中属性的顺序没有指定，并且实现与实现之间也各不相同。

从以下版本开始：
SAX 2.0
另请参见：
AttributesImpl, DeclHandler.attributeDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

方法摘要
int | getIndex(String qName) 通过 XML 限定（前缀）名查找属性的索引。
int | getIndex(String uri, String localName) 通过名称空间的名称查找属性的索引。
int | getLength() 返回此列表中的属性个数。
String | getLocalName(int index) 通过索引查找属性的本地名称。
String | getQName(int index) 通过索引查找属性的 XML 限定（前缀）名。
String | getType(int index) 通过索引查找属性的类型。
String | getType(String qName) 通过 XML 限定（前缀）名查找属性的类型。
String | getType(String uri, String localName) 根据名称空间的名称查找属性的类型。
String | getURI(int index) 通过索引查找属性的名称空间 URI。
String | getValue(int index) 通过索引查找属性的值。
String | getValue(String qName) 通过 XML 限定（前缀）名查找属性的值。
String | getValue(String uri, String localName) 根据名称空间的名称查找属性的值。

方法详细信息

getLength

int getLength()
返回此列表中的属性个数。

一旦知道了属性个数，就可以迭代列表。

返回：
此列表中属性的个数。
另请参见：
getURI(int), getLocalName(int), getQName(int), getType(int), getValue(int)

getURI

String getURI(int index)
通过索引查找属性的名称空间 URI。

参数：
index - 属性索引（从零开始）。
返回：
名称空间 URI，如果没有可用的，则返回空字符串；如果该索引超出范围，则返回 null。
另请参见：
getLength()

getLocalName

String getLocalName(int index)
通过索引查找属性的本地名称。

参数：
index - 属性索引（从零开始）。
返回：
本地名称，如果未执行名称空间处理，则返回空字符串，如果该索引超出范围，则返回 null。
另请参见：
getLength()

getQName

String getQName(int index)
通过索引查找属性的 XML 限定（前缀）名。

参数：
index - 属性索引（从零开始）。
返回：
XML 限定名，如果没有可用的，则返回空字符串，如果该索引超出范围，则返回 null。
另请参见：
getLength()

getType

String getType(int index)
通过索引查找属性的类型。

属性类型是下列字符串之一："CDATA"、"ID"、"IDREF"、"IDREFS"、"NMTOKEN"、"NMTOKENS"、"ENTITY"、"ENTITIES" 或 "NOTATION"（始终用大写字母）。

如果解析器尚未读取属性的声明，或者解析器没有报告属性类型，则必须返回值 "CDATA"，如在“XML 1.0 Recommendation”（第 3.3.3 节 "Attribute-Value Normalization"）中规定的。

对于不是注释的可枚举的属性，解析器将把类型报告为 "NMTOKEN"。

参数：
index - 属性索引（从零开始）。
返回：
字符串形式的属性类型，如果该索引超出范围，则返回 null。
另请参见：
getLength()

getValue

String getValue(int index)
通过索引查找属性的值。

如果属性值是标记（IDREFS、ENTITIES 或 NMTOKENS）列表，则将把这些标记串接成一个字符串,每个标记用单个空格分隔。

参数：
index - 属性索引（从零开始）。
返回：
字符串形式的属性值，如果该索引超出范围，则返回 null。
另请参见：
getLength()

getIndex

int getIndex(String uri,
             String localName)
通过名称空间的名称查找属性的索引。

参数：
uri - 名称空间 URI，如果该名称没有名称空间 URI，则返回空字符串。
localName - 属性的本地名称。
返回：
属性的索引，如果未出现在该列表中，则返回 -1。

getIndex

int getIndex(String qName)
通过 XML 限定（前缀）名查找属性的索引。

参数：
qName - 限定（前缀）名。
返回：
属性的索引，如果未出现在列表中，则返回 -1。

getType

String getType(String uri,
               String localName)
根据名称空间的名称查找属性的类型。

关于可能的类型的描述请参阅 getType(int)。

参数：
uri - 名称空间 URI，如果该名称没有名称空间 URI，则返回空字符串。
localName - 属性的本地名称。
返回：
字符串形式的属性类型，如果该属性不在列表中，或者未执行名称空间处理，则返回 null。

getType

String getType(String qName)
通过 XML 限定（前缀）名查找属性的类型。

关于可能的类型的描述请参阅 getType(int)。

参数：
qName - XML 限定名。
返回：
字符串形式的属性类型，如果该属性不在列表中，或者限定名不可用，则返回 null。

getValue

String getValue(String uri,
                String localName)
根据名称空间的名称查找属性的值。

关于可能的值的描述请参阅 getValue(int)。

参数：
uri - 名称空间 URI，如果名称没有名称空间 URI，则返回空字符串。
localName - 属性的本地名称。
返回：
字符串形式的属性值，如果该属性未在列表中，则返回 null。

getValue

String getValue(String qName)
通过 XML 限定（前缀）名查找属性的值。

关于可能的值的描述，请参阅 getValue(int)。

参数：
qName - XML 限定名。
返回：
字符串形式的属性值，如果属性不在列表中，或者限定名不可用，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 ContentHandler

所有已知子接口：
TemplatesHandler, TransformerHandler, UnmarshallerHandler
所有已知实现类：
DefaultHandler, DefaultHandler2, ValidatorHandler, XMLFilterImpl, XMLReaderAdapter
public interface ContentHandler

接收文档逻辑内容的通知。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

这是一个大多数 SAX 应用程序实施的主要接口：如果需要通知应用程序基本解析事件，则它将实现此接口并且使用 setContentHandler 方法，向 SAX 解析器注册一个实例。解析器将使用该实例报告与基本文档相关的事件，如启动和终止元素与字符数据。

在此接口中的事件顺序非常重要，它本身可镜像文档中信息的顺序。例如，在 startElement 事件与相应的 endElement 事件之间，元素的所有内容（字符数据、处理指令和/ 或子元素）都将以一定顺序出现。

此接口与现在不推荐使用的 SAX 1.0 DocumentHandler 接口相似，但它增加了对名称空间和报告跳过的实体（在非验证的 XML 处理器中）的支持。

实现者应该注意，在 java.net 包中还有一个 ContentHandler 类；这意味着以下实现方法可能并非明智之举

import java.net.*;
 import org.xml.sax.*;

实际上，不管怎样 "import ...*" 通常标志不简洁的编程，因此，用户应该将此作为一种功能而不是错误。

从以下版本开始：
SAX 2.0
另请参见：
XMLReader, DTDHandler, ErrorHandler

方法摘要
void | characters(char[] ch, int start, int length) 接收字符数据的通知。
void | endDocument() 接收文档的结尾的通知。
void | endElement(String uri, String localName, String qName) 接收元素结束的通知。
void | endPrefixMapping(String prefix) 结束前缀 URI 范围的映射。
void | ignorableWhitespace(char[] ch, int start, int length) 接收元素内容中可忽略的空白的通知。
void | processingInstruction(String target, String data) 接收处理指令的通知。
void | setDocumentLocator(Locator locator) 接收用来查找 SAX 文档事件起源的对象。
void | skippedEntity(String name) 接收跳过的实体的通知。
void | startDocument() 接收文档的开始的通知。
void | startElement(String uri, String localName, String qName, Attributes atts) 接收元素开始的通知。
void | startPrefixMapping(String prefix, String uri) 开始前缀 URI 名称空间范围映射。

方法详细信息

setDocumentLocator

void setDocumentLocator(Locator locator)
接收用来查找 SAX 文档事件起源的对象。

强烈建议（但不是绝对需要）使用 SAX 解析器来提供定位器：如果是这样，则必须在调用 ContentHandler 接口中的任何其他方法之前调用此方法为应用程序提供定位器。

定位器允许应用程序确定任何与文档相关的事件的终止位置，即便是解析器不报告错误也是如此。通常情况下，应用程序将使用此信息报告它自己的错误（例如与应用程序的业务规则不匹配的字符内容）。由定位器返回的信息可能不足以供搜索引擎使用。

注意，该定位器仅在调用 SAX 事件回调期间,在 startDocument 返回之后，调用 endDocument 之前，返回正确的信息。应用程序不应该尝试在任何时间都使用它。

参数：
locator - 可以返回任何 SAX 文档事件位置的对象
另请参见：
Locator

startDocument

void startDocument()
                   throws SAXException
接收文档的开始的通知。

在其他任何事件回调（不包括 setDocumentLocator）之前，SAX 解析器仅调用此方法一次。

抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常
另请参见：
endDocument()

endDocument

void endDocument()
                 throws SAXException
接收文档的结尾的通知。

在此方法的说明和 ErrorHandler.fatalError(org.xml.sax.SAXParseException) 的说明之间存在着明显的冲突。在未来的主版本中解决这一不明确问题之后，关于解析器报告 fatalError() 或抛出异常后是否调用 endDocument() 这一点，客户将会十分明确。

SAX 解析器仅调用此方法一次，并且它将是解析期间最后调用的方法。直到解析器放弃解析（由于不可恢复的错误）或到达输入的结尾时，它才可以调用此方法。

抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常
另请参见：
startDocument()

startPrefixMapping

void startPrefixMapping(String prefix,
                        String uri)
                        throws SAXException
开始前缀 URI 名称空间范围映射。

此事件的信息对于常规的名称空间处理并非必需：当 http://xml.org/sax/features/namespaces 功能为 true（默认）时，SAX XML 读取器将自动替换元素和属性名称的前缀。

但是，有这样几种情况，应用程序需要在字符数据或属性值中使用前缀，但在这里，前缀不能自动地安全扩展；必要时，start/endPrefixMapping 事件将为应用程序提供所需信息，以便应用程序本身可在这些上下文中扩展前缀。

注意，不能保证 start/endPrefixMapping 事件相互之间能够正确地嵌套：所有的 startPrefixMapping 事件将在相应的 startElement 事件之前立即发生，所有的 endPrefixMapping 事件将在相应的 endElement 事件之后立即发生，但在其他情况下不能保证其顺序。

对于 "xml" 前缀，永远不应有 start/endPrefixMapping 事件，因为它是预声明的和不可改变。

参数：
prefix - 声明的名称空间前缀。对于没有前缀的默认元素名称空间，使用空字符串。
uri - 将前缀映射到的名称空间 URI
抛出：
SAXException - 客户端可能会在处理期间抛出一个异常
另请参见：
endPrefixMapping(java.lang.String), startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

endPrefixMapping

void endPrefixMapping(String prefix)
                      throws SAXException
结束前缀 URI 范围的映射。

详细信息请参阅 startPrefixMapping。这些事件将始终在相应的 endElement 事件之后立即发生，但在其他情况下 endPrefixMapping 事件的顺序不能保证。

参数：
prefix - 被映射的前缀。当默认的映射范围结束时，这是一个空字符串。
抛出：
SAXException - 客户端可能会在处理期间抛出一个异常
另请参见：
startPrefixMapping(java.lang.String, java.lang.String), endElement(java.lang.String, java.lang.String, java.lang.String)

startElement

void startElement(String uri,
                  String localName,
                  String qName,
                  Attributes atts)
                  throws SAXException
接收元素开始的通知。

解析器在 XML 文档中的每个元素的开始调用此方法；对于每个 startElement 事件都将有相应的 endElement 事件（即使该元素为空时）。所有元素的内容都将在相应的 endElement 事件之前顺序地报告。

此事件允许每个元素最多有以下三个名称组件：

  1. 名称空间 URI；
  2. 本地名称；和
  3. 限定（前缀）名。

可以提供它们中的部分或全部，具体如何取决于 http://xml.org/sax/features/namespaces 和 http://xml.org/sax/features/namespace-prefixes 属性的值：

  • 当名称空间属性为 true（默认）时，名称空间 URI 和本地名称是必需项，当名称空间属性为 false 时，则为可选项（如果指定一个值，两个都必须指定）；
  • 当名称空间前缀属性为 true 时，限定名是必需项，当名称空间前缀属性为 false(默认值）时，则为可选项。

注意，所提供的属性列表仅包括具有显式值（指定的或默认的）的属性：将忽略 #IMPLIED 属性。仅在 http://xml.org/sax/features/namespace-prefixes 属性为 true （默认情况下为 false，并且对 true 值的支持是可选项）时属性列表才包括用于名称空间声明（xmlns* 属性）的属性。

与 characters() 一样，属性值可以具有需要不止一个 char 值的字符。

参数：
uri - 名称空间 URI，如果元素没有名称空间 URI，或者未执行名称空间处理，则为空字符串
localName - 本地名称（不带前缀），如果未执行名称空间处理，则为空字符串
qName - 限定名（带有前缀），如果限定名不可用，则为空字符串
atts - 连接到元素上的属性。如果没有属性，则它将是空 Attributes 对象。在 startElement 返回后，此对象的值是未定义的
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常
另请参见：
endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

endElement

void endElement(String uri,
                String localName,
                String qName)
                throws SAXException
接收元素结束的通知。

SAX 解析器会在 XML 文档中每个元素的末尾调用此方法；对于每个 endElement 事件都将有相应的 startElement 事件（即使该元素为空时）。

有关名称的信息，请参见 startElement。

参数：
uri - 名称空间 URI，如果元素没有名称空间 URI，或者未执行名称空间处理，则为空字符串
localName - 本地名称（不带前缀），如果未执行名称空间处理，则为空字符串
qName - 限定的 XML 名称（带前缀），如果限定名不可用，则为空字符串
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常

characters

void characters(char[] ch,
                int start,
                int length)
                throws SAXException
接收字符数据的通知。

解析器将调用此方法来报告字符数据的每个存储块。SAX 解析器能够用单个存储块返回所有的连续字符数据，或者可以将该数据拆分成几个存储块；但是，任何单个事件中的全部字符都必须来自同一个外部实体，以便定位器能够提供有用的信息。

应用程序不能尝试在指定的范围外从数组中读取数据。

单独的字符可以由不止一个 Java char 值组成。由于不能仅用十六位来表示字符，所以发生此情况的重要情形有两种。一种情形是，字符用代理项对 表示，使用两个特殊的 Unicode 值。此类字符在所谓的 "Astral Planes" 中，代码点在 U+FFFF 之上。另一种情形涉及到复合字符，如由一个或多个重音字符构成的基本字符。

编写代码时不能假定一次读入一个 char 的算法将适用于字符单元；在某些情况下这些算法将拆分一些字符。这与在什么情况下 XML 允许有任意字符（如属性值、处理指令数据、注解以及从此方法中报告的数据）相关。通常还与 Java 代码控制国际化的文本时相关；该问题不是 XML 独有的。

注意，有些解析器将使用 ignorableWhitespace 方法而不是此方法报告元素内容中的空白（验证解析器必须 这么做）。

参数：
ch - 来自 XML 文档的字符
start - 数组中的开始位置
length - 从数组中读取的字符的个数
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常
另请参见：
ignorableWhitespace(char[], int, int), Locator

ignorableWhitespace

void ignorableWhitespace(char[] ch,
                         int start,
                         int length)
                         throws SAXException
接收元素内容中可忽略的空白的通知。

验证解析器必须使用此方法来报告元素内容中的每块空白（请参阅“W3C XML 1.0 Recommendation”中的 2.10 节）：如果非验证解析器能够解析和使用内容模块，则这些非验证解析器也可以使用此方法。

SAX 解析器能够用单个存储块返回所有的连续空白，或者可以将该数据拆分成几个存储块；但是，任何单个事件中的全部字符都必须来自同一个外部实体，以便定位器能够提供有用的信息。

应用程序不能尝试在指定的范围外从数组中读取数据。

参数：
ch - 来自 XML 文档的字符
start - 数组中的开始位置
length - 从数组中读取的字符的个数
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常
另请参见：
characters(char[], int, int)

processingInstruction

void processingInstruction(String target,
                           String data)
                           throws SAXException
接收处理指令的通知。

解析器将为找到的每个处理指令调用一次此方法：注意，处理指令可以出现在主要文档元素的前面或后面。

SAX 解析器必须从不使用此方法报告 XML 声明（XML 1.0 的 2.8 节）或文本声明（XML 1.0 的 4.3.1 节）。

与 characters() 一样，处理指令数据可以具有需要不止一个 char 值的字符。

参数：
target - 处理指令目标
data - 处理指令数据，如果未提供，则为 null。该数据不包括将其与目标分开的任何空白
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。

skippedEntity

void skippedEntity(String name)
                   throws SAXException
接收跳过的实体的通知。将不为标记结构（如元素开始标记或标记声明）内的实体引用调用此方法。（XML 建议书要求报告所跳过的外部实体。SAX 还报告内部实体扩展 / 非扩展，但不包括在标记结构内部。）

解析器将在每次跳过实体时调用此方法。如果非验证处理器尚未看到声明，则可以跳过实体（例如，因为该实体在外部 DTD 子集中声明）。所有的处理器都可以跳过外部实体，但具体情况取决于 http://xml.org/sax/features/external-general-entities 和 http://xml.org/sax/features/external-parameter-entities 属性的值。

参数：
name - 所跳过的实体的名称。如果它是参数实体，则名称将以 '%' 开头，如果它是外部 DTD 子集，则将是字符串 "[dtd]"
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 DocumentHandler

所有已知实现类：
HandlerBase, ParserAdapter
已过时。 此接口已经被 SAX2 ContentHandler 接口取代，后者包括名称空间支持。

public interface DocumentHandler

接收常规文档事件的通知。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

这是一个 SAX1 的主事件处理接口；在 SAX2 中，它已经被 ContentHandler 所取代，后者提供了名称空间支持和对跳过的实体的报告。此接口包括在 SAX2 中，仅支持以前的 SAX1 应用程序。

在此接口中的事件顺序非常重要，它本身可镜像文档中信息的顺序。例如，在 startElement 事件与相应的 endElement 事件之间，元素的所有内容（字符数据、处理指令和/ 或子元素）都将以一定顺序出现。

不想实施完整接口的应用程序编写者可以从 HandlerBase 派生出一个类， HandlerBase 实现默认的功能；解析器编写者可以通过实例化 HandlerBase 来获取默认的处理程序。应用程序可以使用由解析器通过 setDocumentLocator 方法提供的 Locator 接口查找任何文档事件的位置。

从以下版本开始：
SAX 1.0
另请参见：
Parser.setDocumentHandler(org.xml.sax.DocumentHandler), Locator, HandlerBase

方法摘要
void | characters(char[] ch, int start, int length) 已过时。 接收字符数据的通知。
void | endDocument() 已过时。 接收文档结束的通知。
void | endElement(String name) 已过时。 接收元素结束的通知。
void | ignorableWhitespace(char[] ch, int start, int length) 已过时。 接收元素内容中可忽略的空白的通知。
void | processingInstruction(String target, String data) 已过时。 接收处理指令的通知。
void | setDocumentLocator(Locator locator) 已过时。 接收用来查找 SAX 文档事件起源的对象。
void | startDocument() 已过时。 接收文档的开始的通知。
void | startElement(String name, AttributeList atts) 已过时。 接收元素开始的通知。

方法详细信息

setDocumentLocator

void setDocumentLocator(Locator locator)
已过时。
接收用来查找 SAX 文档事件起源的对象。

强烈建议（但并非必须）使用 SAX 解析器来提供定位器：如果使用 SAX 解析器，则必须在调用 DocumentHandler 接口中的任何其他方法之前调用此方法来为应用程序提供定位器。

定位器允许应用程序确定任何与文档相关的事件的终止位置，即便是解析器不报告错误也是如此。通常情况下，应用程序将使用此信息报告它自己的错误（例如与应用程序的业务规则不匹配的字符内容）。由定位器返回的信息可能不足以供搜索引擎使用。

注意，定位器仅在调用此接口中的事件时返回正确的信息。应用程序不应尝试在任何其他时间使用定位器。

参数：
locator - 可以返回任何 SAX 文档事件位置的对象。
另请参见：
Locator

startDocument

void startDocument()
                   throws SAXException
已过时。
接收文档的开始的通知。

在调用此接口或 DTDHandler 中的其他任何方法（setDocumentLocator 方法除外）之前，SAX 解析器仅调用此方法一次。

抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。

endDocument

void endDocument()
                 throws SAXException
已过时。
接收文档结束的通知。

SAX 解析器仅调用此方法一次，并且它将是解析期间最后调用的方法。直到解析器放弃解析（由于不可恢复的错误）或到达输入的结尾时，它才可以调用此方法。

抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。

startElement

void startElement(String name,
                  AttributeList atts)
                  throws SAXException
已过时。
接收元素开始的通知。

解析器在 XML 文档中的每个元素的开始调用此方法；对于每个 startElement() 事件都将有相应的 endElement() 事件（即使该元素为空时）。所有元素内容都将在相应的 endElement() 事件之前顺序地报告。

如果元素名称具有名称空间前缀，则仍带上前缀。注意，所提供的属性列表仅包括具有显式值（指定的或默认的）的属性：将忽略 #IMPLIED 属性。

参数：
name - 元素类型名称。
atts - 附加到元素的属性（如果有）。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
endElement(java.lang.String), AttributeList

endElement

void endElement(String name)
                throws SAXException
已过时。
接收元素结束的通知。

解析器会在 XML 文档中的每个元素结束时调用此方法；对于每个 endElement() 事件都将有相应的 startElement() 事件（即便是该元素为空时也是如此）。

如果元素名称具有名称空间前缀，则仍会将该前缀附加到该名称。

参数：
name - 元素类型名称
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。

characters

void characters(char[] ch,
                int start,
                int length)
                throws SAXException
已过时。
接收字符数据的通知。

解析器将调用此方法来报告字符数据的每个存储块。SAX 解析器能够用单个存储块返回所有的连续字符数据，或者可以将该数据拆分成几个存储块；但是，任何单个事件中的全部字符都必须来自同一个外部实体，以便定位器能够提供有用的信息。

应用程序不能尝试在指定的范围外从数组中读取数据。

注意，有些解析器使用 ignorableWhitespace() 方法报告空白，而不是此方法（验证解析器必须这样做）。

参数：
ch - XML 文档的字符。
start - 在数组中的开始位置。
length - 从数组中读取的字符个数。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ignorableWhitespace(char[], int, int), Locator

ignorableWhitespace

void ignorableWhitespace(char[] ch,
                         int start,
                         int length)
                         throws SAXException
已过时。
接收元素内容中可忽略的空白的通知。

验证解析器必须使用此方法来报告每块可忽略的空白（请参阅“W3C XML 1.0 建议书”中的 2.10 节）：如果非验证解析器能够解析和使用内容模型，则这些非验证解析器也可以使用此方法。

SAX 解析器能够用单个存储块返回所有的连续空白，或者可以将该数据拆分成几个存储块；但是，任何单个事件中的全部字符都必须来自同一个外部实体，以便定位器能够提供有用的信息。

应用程序不能尝试在指定的范围外从数组中读取数据。

参数：
ch - XML 文档的字符。
start - 在数组中的开始位置。
length - 从数组中读取的字符个数。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
characters(char[], int, int)

processingInstruction

void processingInstruction(String target,
                           String data)
                           throws SAXException
已过时。
接收处理指令的通知。

解析器将为找到的每个处理指令调用一次此方法：注意，处理指令可以出现在主要文档元素的前面或后面。

SAX 解析器始终不得使用此方法报告 XML 声明（XML 1.0 的 2.8 节）或文本声明（XML 1.0 的 4.3.1 节）。

参数：
target - 处理指令目标。
data - 处理指令数据，如果未提供，则为 null。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DTDHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 DTDHandler

所有已知子接口：
TransformerHandler
所有已知实现类：
DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl
public interface DTDHandler

接收基本的 DTD 相关的事件的通知。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

如果 SAX 应用程序需要关于注释和未解析的实体的信息，则该应用程序实现此接口并使用 SAX 解析器的 setDTDHandler 方法向该解析器注册一个实例。解析器使用该实例向应用程序报告注释和未解析的实体声明。

注意，此接口仅包括 XML 推荐标准需要 处理器报告的 DTD 事件：注释和未解析的实体声明。

SAX 解析器可按任何顺序报告这些事件，而不管声明注释和未解析的实体时所采用的顺序；但是，必须在文档处理程序的 startDocument 事件之后，在第一个 startElement 事件之前报告所有的 DTD 事件。（如果使用 LexicalHandler，则这些事件也必须在 endDTD 事件之前报告。）

需要依靠应用程序来存储信息以备将来之用（可能用哈希表或对象树）。如果应用程序遇到了 "NOTATION"、"ENTITY" 或 "ENTITIES" 类型的属性，则可以使用它通过此接口获取的信息来查找与该属性值对应的实体和/ 或注释。

从以下版本开始：
SAX 1.0
另请参见：
XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

方法摘要
void | notationDecl(String name, String publicId, String systemId) 接收注释声明事件的通知。
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 接收未解析的实体声明事件的通知。

方法详细信息

notationDecl

void notationDecl(String name,
                  String publicId,
                  String systemId)
                  throws SAXException
接收注释声明事件的通知。

必要时需要应用程序来记录注释以便供以后参考；注释可以作为属性值和在未解析实体声明中出现，并且有时和处理指令目标名称一起使用。

至少 publicId 和 systemId 中的一个必须为非 null。如果有系统标识符，并且是 URL，则 SAX 解析器必须在通过此事件将它传递给应用程序之前完整解析它。

不能保证任何未解析实体在使用注释声明之前都报告它。

参数：
name - 注释名称。
publicId - 注释的公共标识符，如果未提供，则为 null。
systemId - 注释的系统标识符，如果未提供，则为 null。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

unparsedEntityDecl

void unparsedEntityDecl(String name,
                        String publicId,
                        String systemId,
                        String notationName)
                        throws SAXException
接收未解析的实体声明事件的通知。

注意，注释名称对应于由 notationDecl 事件报告的注释。必要时需要应用程序记录实体以备以后参考；未解析的实体可以显示为属性值。

如果系统标识符是 URL，则解析器必须在将它传递给应用程序之前完整解析它。

参数：
name - 未解析的实体的名称。
publicId - 实体的公共标识符，如果未提供，则为 null。
systemId - 实体的系统标识符。
notationName - 相关注释的名称。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EntityResolver (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 EntityResolver

所有已知子接口：
EntityResolver2
所有已知实现类：
DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl
public interface EntityResolver

用于解析实体的基本接口。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

如果 SAX 应用程序需要实现自定义处理外部实体，则必须实现此接口并使用 setEntityResolver 方法向 SAX 驱动器注册一个实例。

然后 XML 阅读器将允许应用程序在包含外部实体之前截取任何外部实体（包括外部 DTD 子集和外部参数实体，如果有）。

许多 SAX 应用程序不需要实现此接口，但对于从数据库或其他特定的输入源中构建 XML 文档的应用程序，或者对于使用 URI 类型（而不是 URL ）的应用程序，这特别有用。

下面的解析器将使用系统标识符 "http://www.myhost.com/today" 为应用程序提供用于实体的特定字符流：

 import org.xml.sax.EntityResolver;
 import org.xml.sax.InputSource;

 public class MyResolver implements EntityResolver {
   public InputSource resolveEntity (String publicId, String systemId)
   {
     if (systemId.equals("http://www.myhost.com/today")) {
              // return a special input source
       MyReader reader = new MyReader();
       return new InputSource(reader);
     } else {
              // use the default behaviour
return null;
     }
   }
 }

应用程序还可以使用此接口将系统标识符重定向到本地 URI，或者在目录中查找替换（可能使用公共标识符）。

从以下版本开始：
SAX 1.0
另请参见：
XMLReader.setEntityResolver(org.xml.sax.EntityResolver), InputSource

方法摘要
 InputSource resolveEntity(String publicId, String systemId)
允许应用程序解析外部实体。

方法详细信息

resolveEntity

InputSource resolveEntity(String publicId,
                          String systemId)
                          throws SAXException,
                                 IOException
允许应用程序解析外部实体。

解析器将在打开任何外部实体（顶级文档实体除外）前调用此方法。此类实体包括在 DTD 内引用的外部 DTD 子集和外部参数实体（无论哪种情形，仅在在解析器都读取外部参数实体时）和在文档元素内引用的外部通用实体（如果解析器读取外部通用实体）。应用程序可以请求解析器本身定位实体、使用另外的 URI或者使用应用程序提供的数据（作为字符或字节输入流）。

应用程序编写者可以使用此方法将外部系统标识符重定向到安全的和/或本地的 URI，以便在目录中查找公共标识符或从数据库或其他输入源（其中包括对话框）中读取实体。XML 和 SAX 都不为使用公共或系统 ID 解析资源指定首选策略。但是，SAX 指定了如何解释通过此方法返回的任何 InputSource，并指定如果未返回，则系统 ID 将被重新引用为 URL。

如果系统标识符是 URL，则 SAX 解析器必须在将它报告给应用程序之前完整解析它。

参数：
publicId - 被引用的外部实体的公共标识符，如果未提供，则为 null。
systemId - 被引用的外部实体的系统标识符。
返回：
一个描述新输入源的 InputSource 对象，或者返回 null，以请求解析器打开到系统标识符的常规 URI 连接。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 特定于 Java 的 IO 异常，可能是由于为 InputSource 创建新的 InputStream 或 Reader 所导致的。
另请参见：
InputSource
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ErrorHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 ErrorHandler

所有已知实现类：
DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl
public interface ErrorHandler

SAX 错误处理程序的基本接口。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

如果 SAX 应用程序需要实现自定义的错误处理，则它必须实现此接口，然后使用 setErrorHandler 方法向 XML 阅读器注册一个实例。然后解析器将通过此接口报告所有的错误和警告。

警告：如果应用程序不 注册 ErrorHandler，则将不报告 XML 解析错误，除了对严重的错误将抛出 SAXParseException 外。为了检测有效性错误，必须注册用 error() 调用处理某些事情的 ErrorHandler。

对于 XML 处理错误，SAX 驱动器必须优先于抛出异常使用此接口：需要应用程序来决定是否对不同类型的错误和警告抛出异常。但是要注意，不要求解析器在调用 fatalError 之后继续报告另外的错误。换句话说，SAX 驱动器类可以在报告任何 fatalError 之后抛出异常。另外，解析器可以对非 XML 错误抛出适当的异常。例如，XMLReader.parse() 将对访问实体或文档的错误抛出 IOException。

从以下版本开始：
SAX 1.0
另请参见：
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler), SAXParseException

方法摘要
void | error(SAXParseException exception) 接收可恢复的错误的通知。
void | fatalError(SAXParseException exception) 接收不可恢复的错误的通知。
void | warning(SAXParseException exception) 接收警告的通知。

方法详细信息

warning

void warning(SAXParseException exception)
             throws SAXException
接收警告的通知。

SAX 解析器将使用此方法报告不属于 XML 推荐标准定义的错误或严重的错误的情形。默认行为是不采取任何措施。

SAX 解析器必须在调用此方法后继续提供正常的解析事件：应用程序应该仍能够处理文档直到结尾。

过滤器也可以使用此方法报告其他的非 XML 警告。

参数：
exception - 封装在 SAX 解析异常中的警告信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
SAXParseException

error

void error(SAXParseException exception)
           throws SAXException
接收可恢复的错误的通知。

这符合 "W3C XML 1.0 Recommendation" 的 1.2 节中对“错误”的定义。例如，验证解析器将使用此回调来报告违反有效性约束。默认行为是不采取任何措施。

SAX 解析器必须在调用此方法后继续提供正常的解析事件应用程序应该仍能够处理文档直到结尾如果应用程序不能这样做，则解析器必须报告一个严重的错误，即使 XML 推荐标准未要求这样做。

过滤器也可以使用此方法报告其他的非 XML 错误。

参数：
exception - 封装在 SAX 解析异常中的错误信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
SAXParseException

fatalError

void fatalError(SAXParseException exception)
                throws SAXException
接收不可恢复的错误的通知。

在此方法的文档和 ContentHandler.endDocument() 的文档之间存在着明显的矛盾。直到在未来的主版本中解决了这一不明确问题后，客户才不必假定在解析器报告 fatalError() 或抛出异常后是否将调用 endDocument()。

这符合 "W3C XML 1.0 Recommendation" 的 1.2 节对“严重的错误”的定义。例如，解析器将使用此回调来报告违背了格式良好性的约束。

应用程序必须假定在解析器调用此方法之后该文档不可用，并且应该仅为收集更多的错误消息而继续进行：事实上，一旦调用了此方法，SAX 解析器就可以随意停止对其他任何事件的报告。

参数：
exception - 封装在 SAX 解析异常中的错误信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
SAXParseException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HandlerBase (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
类 HandlerBase

java.lang.Object
    继承者  org.xml.sax.HandlerBase
所有已实现的接口：
DocumentHandler, DTDHandler, EntityResolver, ErrorHandler
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

public class HandlerBase
extends Object
implements EntityResolver, DTDHandler, DocumentHandler, ErrorHandler

处理程序的默认基类。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

此类可实现以下四个 SAX1 接口的默认行为：EntityResolver、DTDHandler、DocumentHandler 和 ErrorHandler。此类现已过时，但它包括在 SAX2 中用来支持遗留的 SAX1 应用程序。而 SAX2 应用程序应该使用 DefaultHandler 类。

应用程序编写者可以在他们仅需实现部分接口时扩展此类；当应用程序尚未提供其自己的处理程序时解析器编写者可通过实例化此类来提供默认的处理程序。

注意，使用此类是可选的。

从以下版本开始：
SAX 1.0
另请参见：
EntityResolver, DTDHandler, DocumentHandler, ErrorHandler

构造方法摘要
HandlerBase()
已过时。
方法摘要
void | characters(char[] ch, int start, int length) 已过时。 接收元素内字符数据的通知。
void | endDocument() 已过时。 接收文档结束的通知。
void | endElement(String name) 已过时。 接收元素结束的通知。
void | error(SAXParseException e) 已过时。 接收可恢复的解析器错误的通知。
void | fatalError(SAXParseException e) 已过时。 报告严重的 XML 解析错误。
void | ignorableWhitespace(char[] ch, int start, int length) 已过时。 接收元素内容中可忽略的空白的通知。
void | notationDecl(String name, String publicId, String systemId) 已过时。 接收注释声明的通知。
void | processingInstruction(String target, String data) 已过时。 接收处理指令的通知。
InputSource | resolveEntity(String publicId, String systemId) 已过时。 解析外部实体。
void | setDocumentLocator(Locator locator) 已过时。 接收文档事件的 Locator 对象。
void | startDocument() 已过时。 接收文档开始的通知。
void | startElement(String name, AttributeList attributes) 已过时。 接收元素开始的通知。
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 已过时。 接收未解析的实体声明的通知。
void | warning(SAXParseException e) 已过时。 接收解析器警告的通知。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HandlerBase

public HandlerBase()
已过时。
方法详细信息

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException
已过时。
解析外部实体。

将始终返回 null，因此解析器将使用 XML 文档中提供的系统标识符。此方法实现 SAX 默认的行为：应用程序编写者可以在子类中重写它以便进行诸如目录查找或 URI 重定向之类的特定转换。

指定者：
接口 EntityResolver 中的 resolveEntity
参数：
publicId - 公共标识符，如果没有可用的则为 null。
systemId - XML 文档中提供的系统标识符。
返回：
新的输入源，或返回 null以要求默认的行为。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
EntityResolver.resolveEntity(java.lang.String, java.lang.String)

notationDecl

public void notationDecl(String name,
                         String publicId,
                         String systemId)
已过时。
接收注释声明的通知。

默认为不执行任何操作。如果应用程序编写者希望跟踪在文档中声明的注释，则可以在子类中重写此方法。

指定者：
接口 DTDHandler 中的 notationDecl
参数：
name - 注释名称。
publicId - 注释公共标识符，如果没有可使用的则为 null。
systemId - 注释系统标识符。
另请参见：
DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

unparsedEntityDecl

public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
已过时。
接收未解析的实体声明的通知。

默认为不执行任何操作。应用程序编写者可以在子类中重写此方法，以便跟踪在文档中声明的未解析实体。

指定者：
接口 DTDHandler 中的 unparsedEntityDecl
参数：
name - 实体名称。
publicId - 实体公共标识符，如果不可用则为 null。
systemId - 实体系统标识符。
notationName - 相关注释的名称。
另请参见：
DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

setDocumentLocator

public void setDocumentLocator(Locator locator)
已过时。
接收文档事件的 Locator 对象。

默认为不执行任何操作。如果应用程序编写者希望存储定位器以用于其他的文档事件，则可以在子类中重写此方法。

指定者：
接口 DocumentHandler 中的 setDocumentLocator
参数：
locator - 用于所有 SAX 文档事件的定位器。
另请参见：
DocumentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

startDocument

public void startDocument()
                   throws SAXException
已过时。
接收文档开始的通知。

默认为不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在文档的开始采取特定的措施（如分配树的根节点或创建输出文件）。

指定者：
接口 DocumentHandler 中的 startDocument
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DocumentHandler.startDocument()

endDocument

public void endDocument()
                 throws SAXException
已过时。
接收文档结束的通知。

默认为不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在文档结束时采取特定的措施（如结束树或关闭输出文件）。

指定者：
接口 DocumentHandler 中的 endDocument
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DocumentHandler.endDocument()

startElement

public void startElement(String name,
                         AttributeList attributes)
                  throws SAXException
已过时。
接收元素开始的通知。

默认为不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在每个元素开始时采取特定的措施（如向文件分配新的树节点或把输出写入到文件）。

指定者：
接口 DocumentHandler 中的 startElement
参数：
name - 元素类型名称。
attributes - 指定的或默认的属性。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

endElement

public void endElement(String name)
                throws SAXException
已过时。
接收元素结束的通知。

默认为不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在每个元素结束时采取特定的措施（如结束树节点或将输出写入到文件中）。

指定者：
接口 DocumentHandler 中的 endElement
参数：
name - 元素名称
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DocumentHandler.endElement(java.lang.String)

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
已过时。
接收元素内字符数据的通知。

默认为不执行任何操作。应用程序编写者可以重写此方法，以便对每块字符数据采取特定的措施（如将该数据添加到节点或缓冲区，或者将该数据打印到文件）。

指定者：
接口 DocumentHandler 中的 characters
参数：
ch - 字符。
start - 在字符数组中的起始位置。
length - 从字符数组使用的字符个数。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DocumentHandler.characters(char[], int, int)

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
已过时。
接收元素内容中可忽略的空白的通知。

默认为不执行任何操作。应用程序编写者可以重写此方法，以便对每块可忽略的空白采取特定的措施（如将数据添加到节点或缓冲区，或者将数据打印到文件）。

指定者：
接口 DocumentHandler 中的 ignorableWhitespace
参数：
ch - 空白字符。
start - 在字符数组中的起始位置。
length - 从字符数组使用的字符个数。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DocumentHandler.ignorableWhitespace(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
已过时。
接收处理指令的通知。

默认为不执行任何操作。应用程序编写者可以在子类中重写此方法，以便对每个处理指令采取特定的措施，如设置状态变量或调用其他的方法。

指定者：
接口 DocumentHandler 中的 processingInstruction
参数：
target - 处理指令目标。
data - 处理指令数据，如果未提供则为 null。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DocumentHandler.processingInstruction(java.lang.String, java.lang.String)

warning

public void warning(SAXParseException e)
             throws SAXException
已过时。
接收解析器警告的通知。

默认实现不执行任何操作。应用程序编写者可以在子类中重写此方法，以便对每个警告采取特定的措施，如在日志文件中插入消息，或者将它打印到控制台。

指定者：
接口 ErrorHandler 中的 warning
参数：
e - 编码为异常的警告信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

error

public void error(SAXParseException e)
           throws SAXException
已过时。
接收可恢复的解析器错误的通知。

默认实现不执行任何操作。应用程序编写者可以在子类中重写此方法，以便对每个错误采取特定的措施，如在日志文件中插入消息，或者将它打印到控制台。

指定者：
接口 ErrorHandler 中的 error
参数：
e - 编码为异常的警告信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

fatalError

public void fatalError(SAXParseException e)
                throws SAXException
已过时。
报告严重的 XML 解析错误。

默认的实现抛出 SAXParseException。如果应用程序编写者需要对每个严重的错误采取特定的措施（如将所有的错误收集到一个报告中），则可以在子类中重写此方法：当调用此方法时，无论哪种情况，应用程序都必须停止所有的常规处理，这是因为文档已不再可靠，并且解析器再也不能报告解析事件。

指定者：
接口 ErrorHandler 中的 fatalError
参数：
e - 编码为异常的错误信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputSource (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
类 InputSource

java.lang.Object
    继承者  org.xml.sax.InputSource

public class InputSource
extends Object

XML 实体的单一输入源。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

此类允许 SAX 应用程序封装有关单个对象中的输入源的信息，它可包括公共标识符、系统标识符、字节流（可能带有指定的编码）、基本 URI 和/ 或字符流。

在以下两种情况下应用程序可以将输入源提供给解析器：作为 Parser.parse 方法的参数，或者作为 EntityResolver.resolveEntity 方法的返回值。

SAX 解析器将使用 InputSource 对象来确定如何读取 XML 输入。如果有字符流可用，则解析器将直接读取该流，而忽略该流中找到的任何文本编码声明。如果没有字符流，但却有字节流，则解析器将使用该字节流，从而使用在 InputSource 中指定的编码，或者另外（如果未指定编码）通过使用某种诸如 XML 规范 中的算法算法自动探测字符编码。如果既没有字符流，又没有字节流可用，则解析器将尝试打开到由系统标识符标识的资源的 URI 连接。

InputSource 对象属于该应用程序：SAX 解析器将不会以任何方式修改它（它可以在必要时修改副本）。但是，作为解析终止清除的一部分，对字节流和字符流的标准处理就是关闭这二者，因此在将此类流传递给解析器后应用程序不应尝试重新使用它们。

从以下版本开始：
SAX 1.0
另请参见：
XMLReader.parse(org.xml.sax.InputSource), EntityResolver.resolveEntity(java.lang.String, java.lang.String), InputStream, Reader

构造方法摘要
InputSource()
零参数默认构造方法。
InputSource(InputStream byteStream)
使用字节流创建新的输入源。
InputSource(Reader characterStream)
使用字符流创建新的输入源。
InputSource(String systemId)
使用系统标识符创建新的输入源。
方法摘要
InputStream | getByteStream() 获取此输入源的字节流。
Reader | getCharacterStream() 获取此输入源的字符流。
String | getEncoding() 获取字节流或 URI 的字符编码。
String | getPublicId() 获取此输入源的公共标识符。
String | getSystemId() 获取此输入源的系统标识符。
void | setByteStream(InputStream byteStream) 设置此输入源的字节流。
void | setCharacterStream(Reader characterStream) 设置此输入源的字符流。
void | setEncoding(String encoding) 设置字符编码（如果已知）。
void | setPublicId(String publicId) 设置此输入源的公共标识符。
void | setSystemId(String systemId) 设置此输入源的系统标识符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputSource

public InputSource()
零参数默认构造方法。

另请参见：
setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader),
setEncoding(java.lang.String)

InputSource

public InputSource(String systemId)
使用系统标识符创建新的输入源。

应用程序可以使用 setPublicId 将公共标识符包括在内，也可以使用 setEncoding 来指定字符编码（如果已知）。

如果系统标识符是 URL，则必须完整解析它（它不可以是相对 URL）。

参数：
systemId - 系统标识符 (URI)。
另请参见：
setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setEncoding(java.lang.String),
setCharacterStream(java.io.Reader)

InputSource

public InputSource(InputStream byteStream)
使用字节流创建新的输入源。

应用程序编写者必须使用 setSystemId() 为解析相对 URI 提供基，还可以使用 setPublicId 将公共标识符包括在内，并且可以使用 setEncoding 来指定对象的字符编码。

参数：
byteStream - 包含文档的原始字节流。
另请参见：
setPublicId(java.lang.String),
setSystemId(java.lang.String),
setEncoding(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)

InputSource

public InputSource(Reader characterStream)
使用字符流创建新的输入源。

应用程序编写者必须使用 setSystemId() 为解析相对 URI 提供基，并且可以使用 setPublicId 将公共标识符包括在内。

字符流不能包括字节顺序标记。

另请参见：
setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)
方法详细信息

setPublicId

public void setPublicId(String publicId)
设置此输入源的公共标识符。

公共标识符始终为可选的：如果应用程序编写者包括一个公共标识符，则将把它作为位置信息的一部分提供。

参数：
publicId - 字符串形式的公共标识符。
另请参见：
getPublicId(),
Locator.getPublicId(),
SAXParseException.getPublicId()

getPublicId

public String getPublicId()
获取此输入源的公共标识符。

返回：
公共标识符，如果未提供，则返回 null。
另请参见：
setPublicId(java.lang.String)

setSystemId

public void setSystemId(String systemId)
设置此输入源的系统标识符。

如果有字节流或字符流，则系统标识符是可选的，但提供系统标识符非常有用，这是因为应用程序可以使用它解析相对 URI，并且可以将它包含在错误消息和警告中（解析器仅在未指定字节流或字符流时尝试打开到 URI 的连接）。

如果应用程序知道系统标识符所指向的对象的字符编码，则可以使用 setEncoding 方法来注册编码。

如果系统标识符是 URL，则必须完整解析它（它不可以是相对 URL）。

参数：
systemId - 字符串形式的系统标识符。
另请参见：
setEncoding(java.lang.String),
getSystemId(),
Locator.getSystemId(),
SAXParseException.getSystemId()

getSystemId

public String getSystemId()
获取此输入源的系统标识符。

getEncoding 方法将返回所指向对象的字符编码，如果未知，则返回 null。

如果系统 ID 是 URL，则将完整解析它。

返回：
系统标识符，如果未提供，则返回 null。
另请参见：
setSystemId(java.lang.String), getEncoding()

setByteStream

public void setByteStream(InputStream byteStream)
设置此输入源的字节流。

如果还有指定的字符流，则 SAX 解析器将忽略此操作，它将优先于打开自己 URI 连接而使用字节流。

如果应用程序知道字节流的字符编码，则必须使用 setEncoding 方法设置它。

参数：
byteStream - 包含 XML 文档或其他实体的字节流。
另请参见：
setEncoding(java.lang.String),
getByteStream(),
getEncoding(),
InputStream

getByteStream

public InputStream getByteStream()
获取此输入源的字节流。

getEncoding 方法将返回此字节流的字符编码，如果未知，则返回 null。

返回：
字节流，如果未提供，则返回 null。
另请参见：
getEncoding(), setByteStream(java.io.InputStream)

setEncoding

public void setEncoding(String encoding)
设置字符编码（如果已知）。

编码必须是 XML 编码声明可接受的字符串（参见 "XML 1.0 recommendation" 的 4.3.3 节）。

当应用程序提供字符流时，此方法无效。

参数：
encoding - 描述字符编码的字符串。
另请参见：
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
getEncoding()

getEncoding

public String getEncoding()
获取字节流或 URI 的字符编码。当应用程序提供字符流时，将忽略此值。

返回：
编码，如果未提供，则返回 null。
另请参见：
setByteStream(java.io.InputStream),
getSystemId(),
getByteStream()

setCharacterStream

public void setCharacterStream(Reader characterStream)
设置此输入源的字符流。

如果有指定的字符流，则 SAX 解析器将忽略任何字节流，并且不尝试打开到系统标识符的 URI 连接。

参数：
characterStream - 包含 XML 文档或其他实体的字符流。
另请参见：
getCharacterStream(), Reader

getCharacterStream

public Reader getCharacterStream()
获取此输入源的字符流。

返回：
字符流，如果未提供，则返回 null。
另请参见：
setCharacterStream(java.io.Reader)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Locator (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 Locator

所有已知子接口：
Locator2
所有已知实现类：
Locator2Impl, LocatorImpl
public interface Locator

用来将 SAX 事件与文档位置关联的接口。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

如果 SAX 解析器为 SAX 应用程序提供位置信息，要实现这一点，则需要先实现此接口，然后使用内容处理程序的 setDocumentLocator 方法将一个实例传递给应用程序。应用程序可以使用此对象获取 XML 源文档中其他任何 SAX 事件的位置。

注意，由该对象返回的结果仅在每个回调方法内有效：如果应用程序尝试在其他任何时间，或在完成解析后使用定位器，则将接收到不可预知的结果。

不要求 SAX 解析器提供定位器，但强烈建议它提供定位器。如果解析器提供定位器，则必须在报告任何其他文档事件之前提供它。如果在应用程序接收 startDocument 事件之前尚未设置定位器，则应用程序必须假定定位器不可用。

从以下版本开始：
SAX 1.0
另请参见：
ContentHandler.setDocumentLocator(org.xml.sax.Locator)

方法摘要
int | getColumnNumber() 返回当前文档事件结束处的列号。
int | getLineNumber() 返回当前文档事件结束处的行号。
String | getPublicId() 返回当前文档事件的公共标识符。
String | getSystemId() 返回当前文档事件的系统标识符。

方法详细信息

getPublicId

String getPublicId()
返回当前文档事件的公共标识符。

返回值是文档实体的公共标识符，或在其中出现触发事件标记的外部解析实体的公共标识符。

返回：
包含公共标识符的字符串，如果没有可用的，则返回 null。
另请参见：
getSystemId()

getSystemId

String getSystemId()
返回当前文档事件的系统标识符。

返回值是文档实体的系统标识符，或在其中出现触发事件的标记的外部解析实体的系统标识符。

如果系统标识符是 URL，则解析器必须在将它传递给应用程序之前完整解析它。例如，必须始终以 file:... 的形式提供文件。URL 和其他类型的相对 URI 也将根据它们的基来解析。

返回：
包含系统标识符的字符串，如果没有可用的，则返回 null。
另请参见：
getPublicId()

getLineNumber

int getLineNumber()
返回当前文档事件结束处的行号。行由行尾分隔，这在 XML 规范中定义。

警告：从该方法返回的值只是供诊断用的近似值；并不提供编辑源 XML 文档的字符内容所需的充足信息。在某些情况下，这些“行”号与将显示为列的号匹配，而在其他一些情况下，因内部实体扩展它们可以与源文本不匹配。

在文档实体或在其中出现触发事件标记的外部解析实体中，返回值是行号的近似值。

如有可能，SAX 驱动器应该提供与文档事件相关的文本之后的第一个字符的行位置。第一行就是 "line 1"。

返回：
行号，如果没有可用的，则返回 -1。
另请参见：
getColumnNumber()

getColumnNumber

int getColumnNumber()
返回当前文档事件结束处的列号。这是自最后一行结束后，从一开始的 Java char 值号。

警告：从该方法返回的值只是供诊断用的近似值；并不提供编辑源 XML 文档的字符内容所需的充足信息。例如，当行包括组合字符序列、宽字符、代理项对或双向文本组合时，该值可能与文本编辑器中所显示的列不一致。

在文档实体或在其中出现触发事件标记的外部解析实体中，返回值是列号的近似值。

如有可能，SAX 驱动器应该提供与文档事件相关的文本之后的第一个字符的行位置。每行中的第一列就是 "column 1"。

返回：
列号，如果没有可用的，则返回 -1。
另请参见：
getLineNumber()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Parser (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 Parser

所有已知实现类：
XMLReaderAdapter
已过时。 此接口已经被 SAX2 XMLReader 接口取代，后者包括名称空间支持。

public interface Parser

用于 SAX （XML 的简单 API） 解析器的基本接口。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

这是一个 SAX1 的主要事件提供者接口；在 SAX2 中它已经被 XMLReader 所取代，后者包括名称空间支持、复杂的可配置性及可扩展性。

所有的 SAX1 解析器都必须实现这一基本接口：它允许应用程序为不同类型的事件注册处理程序并且从 URI 或字符流开始解析。

所有的 SAX1 解析器还必须实现零参数的构造方法（尽管也允许实现其他的构造方法）。

SAX1 解析器可以重新使用，但不可重入：一旦成功完成了第一次解析，应用程序就可以重新使用一个解析器对象（可能具有不同的输入源），但它不可以在解析中以递归的方式调用 parse() 方法，

从以下版本开始：
SAX 1.0
另请参见：
EntityResolver, DTDHandler, DocumentHandler, ErrorHandler, HandlerBase, InputSource

方法摘要
void | parse(InputSource source) 已过时。 解析 XML 文档。
void | parse(String systemId) 已过时。 从系统标识符 (URI) 解析 XML 文档。
void | setDocumentHandler(DocumentHandler handler) 已过时。 允许应用程序注册文档事件处理程序。
void | setDTDHandler(DTDHandler handler) 已过时。 允许应用程序注册 DTD 事件处理程序。
void | setEntityResolver(EntityResolver resolver) 已过时。 允许应用程序注册自定义的实体解析器。
void | setErrorHandler(ErrorHandler handler) 已过时。 允许应用程序注册错误事件处理程序。
void | setLocale(Locale locale) 已过时。 允许应用程序请求错误和警告的环境。

方法详细信息

setLocale

void setLocale(Locale locale)
               throws SAXException
已过时。
允许应用程序请求错误和警告的环境。

不需要 SAX 解析器提供对错误和警告的本地化；但是，如果它们无法支持所请求的环境，则必须抛出 SAX 异常。在解析过程中应用程序不能请求环境改变。

参数：
locale - Java Locale 对象。
抛出：
SAXException - 如果不支持请求的环境，则抛出异常（使用原来的或默认的环境）。
另请参见：
SAXException, SAXParseException

setEntityResolver

void setEntityResolver(EntityResolver resolver)
已过时。
允许应用程序注册自定义的实体解析器。

如果应用程序不注册实体解析器，则 SAX 解析器自身将解析系统标识符并打开到实体的连接（这是在 HandlerBase 中实现的默认行为）。

应用程序还可以在解析期间注册新的或不同的实体解析器，并且 SAX 解析器必须立即开始使用新的解析器。

参数：
resolver - 用来解析实体的对象。
另请参见：
EntityResolver, HandlerBase

setDTDHandler

void setDTDHandler(DTDHandler handler)
已过时。
允许应用程序注册 DTD 事件处理程序。

如果应用程序不注册 DTD 处理程序，则将忽略由 SAX 解析器报告的所有 DTD 事件（这是由 HandlerBase 实现的默认行为）。

应用程序还可以在解析期间注册新的或不同的处理程序，并且 SAX 解析器必须立即开始使用新的处理程序。

参数：
handler - DTD 处理程序。
另请参见：
DTDHandler, HandlerBase

setDocumentHandler

void setDocumentHandler(DocumentHandler handler)
已过时。
允许应用程序注册文档事件处理程序。

如果应用程序不注册文档处理程序，则将忽略由 SAX 解析器报告的所有文档事件（这是由 HandlerBase 实现的默认行为）。

应用程序还可以在解析过程中注册新的或不同的处理程序，并且 SAX 解析器必须立即开始使用新的处理程序。

参数：
handler - 文档处理程序。
另请参见：
DocumentHandler, HandlerBase

setErrorHandler

void setErrorHandler(ErrorHandler handler)
已过时。
允许应用程序注册错误事件处理程序。

如果应用程序不注册错误事件处理程序，则将忽略由 SAX 解析器报告的所有错误事件，但不包括 fatalError，它将抛出 SAXException（这是由 HandlerBase 实现的默认行为）。

应用程序还可以在解析过程中注册新的或不同的处理程序，并且 SAX 解析器必须立即开始使用新的处理程序。

参数：
handler - 错误处理程序。
另请参见：
ErrorHandler, SAXException, HandlerBase

parse

void parse(InputSource source)
           throws SAXException,
                  IOException
已过时。
解析 XML 文档。

应用程序可以使用此方法指导 SAX 解析器开始解析来自任何有效输入源（字符流、字节流或 URI）的 XML 文档。

在解析正在进行时，应用程序可能不能调用此方法（它们必须为每个另外的 XML 文档创建新的 Parser）。一旦完成了解析，应用程序就可以重新使用可能具有另外一个输入源的同一个 Parser 对象。

参数：
source - XML 文档的顶层的输入源。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 解析器发出的 IO 异常，可能来自应用程序提供的字节流或字符流。
另请参见：
InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setDocumentHandler(org.xml.sax.DocumentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

parse

void parse(String systemId)
           throws SAXException,
                  IOException
已过时。
从系统标识符 (URI) 解析 XML 文档。

此方法是从系统标识符读取文档这一常见情形的捷径。它完全等效于以下方法：

 parse(new InputSource(systemId));

如果系统标识符是一个 URL，则在将它传递到解析器之前必须由应用程序对它进行完整的解析。

参数：
systemId - 系统标识符 (URI)。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 解析器发出的 IO 异常，可能来自应用程序提供的字节流或字符流。
另请参见：
parse(org.xml.sax.InputSource)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAXException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
类 SAXException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.xml.sax.SAXException
所有已实现的接口：
Serializable
直接已知子类：
SAXNotRecognizedException, SAXNotSupportedException, SAXParseException
public class SAXException
extends Exception

封装一般的 SAX 错误或警告。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

此类可以包含来自 XML 解析器或应用程序的基本错误和警告信息。解析器编写者或应用程序编写者可以子类化它以提供附加的功能。SAX 处理程序可以抛出此异常或任何从它子类化而来的异常。

如果应用程序需要传递其他类型的异常，则它必须把这些异常包装在 SAXException 中或从 SAXException 派生出的异常中。

如果解析器或应用程序需要包含关于 XML 文档中特定位置的信息，则必须使用 SAXParseException 子类。

从以下版本开始：
SAX 1.0
另请参见：
SAXParseException, 序列化表格

构造方法摘要
SAXException()
创建一个新的 SAXException。
SAXException(Exception e)
创建一个包装现有异常的新的 SAXException。
SAXException(String message)
创建一个新的 SAXException。
SAXException(String message, Exception e)
从现有的异常创建新的 SAXException。
方法摘要
Exception | getException() 返回嵌入的异常（如果有）。
String | getMessage() 返回此异常的详细消息。
String | toString() 重写 toString 以获取任何嵌入的异常。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SAXException

public SAXException()
创建一个新的 SAXException。

SAXException

public SAXException(String message)
创建一个新的 SAXException。

参数：
message - 错误或警告消息。

SAXException

public SAXException(Exception e)
创建一个包装现有异常的新的 SAXException。

现有异常将嵌入到新的异常中，其消息将成为 SAXException 的默认消息。

参数：
e - 包装在 SAXException 中的异常。

SAXException

public SAXException(String message,
                    Exception e)
从现有的异常创建新的 SAXException。

现有的异常将嵌入到新的异常中，但新的异常将有其自己的消息。

参数：
message - 详细消息。
e - 包装在 SAXException 中的异常。
方法详细信息

getMessage

public String getMessage()
返回此异常的详细消息。

如果有嵌入的异常，并且 SAXException 没有其自己的详细消息，则此方法将返回嵌入的异常的详细消息。

覆盖：
类 Throwable 中的 getMessage
返回：
错误或警告消息。

getException

public Exception getException()
返回嵌入的异常（如果有）。

返回：
嵌入的异常，如果没有，则返回 null。

toString

public String toString()
重写 toString 以获取任何嵌入的异常。

覆盖：
类 Throwable 中的 toString
返回：
此异常的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAXNotRecognizedException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
类 SAXNotRecognizedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.xml.sax.SAXException
                继承者  org.xml.sax.SAXNotRecognizedException
所有已实现的接口：
Serializable
public class SAXNotRecognizedException
extends SAXException

用于未识别的标识符的 Exception 类。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

XMLReader 将在它发现未识别功能或属性标识符时抛出此异常；SAX 应用程序和扩展可以基于其他相似的目的使用此类。

从以下版本开始：
SAX 2.0
另请参见：
SAXNotSupportedException, 序列化表格

构造方法摘要
SAXNotRecognizedException()
默认的构造方法。
SAXNotRecognizedException(String message)
构造带指定的消息的新的异常。
方法摘要
从类 org.xml.sax.SAXException 继承的方法
getException, getMessage, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SAXNotRecognizedException

public SAXNotRecognizedException()
默认的构造方法。

SAXNotRecognizedException

public SAXNotRecognizedException(String message)
构造带指定的消息的新的异常。

参数：
message - 异常的文本消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAXNotSupportedException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
类 SAXNotSupportedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.xml.sax.SAXException
                继承者  org.xml.sax.SAXNotSupportedException
所有已实现的接口：
Serializable
public class SAXNotSupportedException
extends SAXException

用于不被支持的操作的 Exception 类。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

XMLReader 将在它能够识别功能或属性标识符，但却无法执行请求的操作（设置状态或值）时抛出此异常。其他 SAX2 应用程序和扩展可以基于相似的目的使用此类。

从以下版本开始：
SAX 2.0
另请参见：
SAXNotRecognizedException, 序列化表格

构造方法摘要
SAXNotSupportedException()
构造不带任何消息的新异常。
SAXNotSupportedException(String message)
构造带指定消息的新的异常。
方法摘要
从类 org.xml.sax.SAXException 继承的方法
getException, getMessage, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SAXNotSupportedException

public SAXNotSupportedException()
构造不带任何消息的新异常。

SAXNotSupportedException

public SAXNotSupportedException(String message)
构造带指定消息的新的异常。

参数：
message - 异常的文本消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SAXParseException (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
类 SAXParseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  org.xml.sax.SAXException
                继承者  org.xml.sax.SAXParseException
所有已实现的接口：
Serializable
public class SAXParseException
extends SAXException

封装 XML 解析错误或警告。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

此异常好像来源于 Locator 对象那样可以包括用来在原始 XML 文档中查找错误的信息。注意，尽管应用程序将接收 SAXParseException 作为 ErrorHandler 接口中处理程序的参数，但实际上应用程序不需要抛出异常；它可以只是读取其中的信息，并采取不同的操作。

因为此异常是 SAXException 的子类，所以它继承了包装其他异常的能力。

从以下版本开始：
SAX 1.0
另请参见：
SAXException, Locator, ErrorHandler, 序列化表格

构造方法摘要
SAXParseException(String message, Locator locator)
从消息和 Locator 创建新的 SAXParseException。
SAXParseException(String message, Locator locator, Exception e)
将现有的异常包装在 SAXParseException 中。
SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber)
创建新的 SAXParseException。
SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
创建带有嵌入异常的新 SAXParseException。
方法摘要
int | getColumnNumber() 发生异常的文本结尾的列号。
int | getLineNumber() 发生异常的文本结尾的行号。
String | getPublicId() 获取发生异常的实体的公共标识符。
String | getSystemId() 获取发生异常的实体的系统标识符。
从类 org.xml.sax.SAXException 继承的方法
getException, getMessage, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SAXParseException

public SAXParseException(String message,
                         Locator locator)
从消息和 Locator 创建新的 SAXParseException。

当应用程序从 ContentHandler 回调内创建其自己的异常时，此构造方法尤其有用。

参数：
message - 错误或警告消息。
locator - 错误或警告的 locator 对象（可以为 null）。
另请参见：
Locator

SAXParseException

public SAXParseException(String message,
                         Locator locator,
                         Exception e)
将现有的异常包装在 SAXParseException 中。

当应用程序从 ContentHandler 回调内创建其自己的异常，并且需要包装不是 SAXException 的子类的现有异常时，此构造方法尤其有用。

参数：
message - 错误或警告消息；或者为 null，以便使用来自于嵌入异常的消息。
locator - 错误或警告的 locator 对象（可以为 null）。
e - 任何异常。
另请参见：
Locator

SAXParseException

public SAXParseException(String message,
                         String publicId,
                         String systemId,
                         int lineNumber,
                         int columnNumber)
创建新的 SAXParseException。

此构造方法对解析器编写者最为有用。

除消息之外的所有参数好像都是由 Locator 提供的。例如，如果系统标识符是一个 URL（包括相对文件名），则调用者必须在创建异常之前完全解析它。

参数：
message - 错误或警告消息。
publicId - 生成错误或警告的实体的公共标识符。
systemId - 生成错误或警告的实体的系统标识符。
lineNumber - 引起错误或警告的文本结尾的行号。
columnNumber - 引起错误或警告的文本结尾的列号。

SAXParseException

public SAXParseException(String message,
                         String publicId,
                         String systemId,
                         int lineNumber,
                         int columnNumber,
                         Exception e)
创建带有嵌入异常的新 SAXParseException。

对于需要包装不是 SAXException 的子类的异常的解析器编写者，此构造方法最有用。

除消息和异常之外的所有参数好像都是由 Locator 提供的。例如，如果系统标识符是 URL（包括相对文件名），则调用者必须在创建该异常之前完全解析它。

参数：
message - 错误或警告消息，或者 null，以便使用来自于嵌入的异常的消息。
publicId - 生成错误或警告的实体的公共标识符。
systemId - 生成错误或警告的实体的系统标识符。
lineNumber - 引起错误或警告的文本结尾的行号。
columnNumber - 引起错误或警告的文本结尾的列号。
e - 嵌入到此异常中的其他异常。
方法详细信息

getPublicId

public String getPublicId()
获取发生异常的实体的公共标识符。

返回：
包含公共标识符的字符串，如果没有可用的，则返回 null。
另请参见：
Locator.getPublicId()

getSystemId

public String getSystemId()
获取发生异常的实体的系统标识符。

如果系统标识符是 URL，则已得到了完全解析。

返回：
包含系统标识符的字符串，如果没有可用的，则返回 null。
另请参见：
Locator.getSystemId()

getLineNumber

public int getLineNumber()
发生异常的文本结尾的行号。

第一行就是行 1。

返回：
代表行号的整数，如果没有可用的，则返回 -1。
另请参见：
Locator.getLineNumber()

getColumnNumber

public int getColumnNumber()
发生异常的文本结尾的列号。

行中的第一列就是位置 1。

返回：
代表列号的整数，如果没有可用的，则返回 -1。
另请参见：
Locator.getColumnNumber()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLFilter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 XMLFilter

所有超级接口：
XMLReader
所有已知实现类：
XMLFilterImpl
public interface XMLFilter
extends XMLReader

用于 XML 过滤器的接口。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

除了 XML 过滤器是从另外的 XML 阅读器中获取其事件，而不是从诸如 XML 文档或数据库之类的基本源获取事件，XML 过滤器就像一个 XML 阅读器。过滤器可以在它们将事件传递给最终应用程序时修改这些事件的流。

通过自动传递所有的 EntityResolver、DTDHandler、ContentHandler 和 ErrorHandler 事件，XMLFilterImpl helper 类为创建 SAX2 过滤器提供了便捷的基类。

从以下版本开始：
SAX 2.0
另请参见：
XMLFilterImpl

方法摘要
XMLReader | getParent() 获取父阅读器。
void | setParent(XMLReader parent) 设置父阅读器。
从接口 org.xml.sax.XMLReader 继承的方法
getContentHandler, getDTDHandler, getEntityResolver, getErrorHandler, getFeature, getProperty, parse, parse, setContentHandler, setDTDHandler, setEntityResolver, setErrorHandler, setFeature, setProperty

方法详细信息

setParent

void setParent(XMLReader parent)
设置父阅读器。

此方法允许应用程序将过滤器链接到父阅读器（可以是另外的过滤器）。参数不能为 null。

参数：
parent - 父阅读器。

getParent

XMLReader getParent()
获取父阅读器。

此方法允许应用程序查询父阅读器（可以是另外的过滤器）。一般说来，最好不要在父阅读器上直接执行所有的操作：它们都必须通过此过滤器。

返回：
父过滤器，如果未设置，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLReader (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.xml.sax
接口 XMLReader

所有已知子接口：
XMLFilter
所有已知实现类：
ParserAdapter, XMLFilterImpl
public interface XMLReader

用于使用回调读取 XML 文档的接口。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅 http://www.saxproject.org。

注：不管其名称如何，此接口不 扩展标准的 Java Reader 接口，因为读取 XML 是一个与读取字符数据完全不同的活动。

XMLReader 是 XML 解析器的 SAX2 驱动程序必须实现的接口。此接口允许应用程序设置和查询解析器中的功能和属性，注册文档处理的事件处理程序，以及开始文档解析。

所有的 SAX 接口都假定为是同步的：必须在完成分解后返回 parse 方法，并且阅读器必须等待事件处理程序回调返回后才能报告下一个事件。

此接口取代了（现在不推荐） SAX 1.0 Parser 接口。与旧的解析器接口（和某些监控器接口）相比，XMLReader 接口具有两大重要增强：

  1. 它增加了查询和设置功能和属性的标准方法；并且
  2. 增加了对名称空间的支持，这是许多高层的 XML 标准所必需的。

存在将 SAX1 解析器转换为 SAX2 XMLReader 的适配器并且反之亦然。

从以下版本开始：
SAX 2.0
另请参见：
XMLFilter, ParserAdapter, XMLReaderAdapter

方法摘要
ContentHandler | getContentHandler() 返回当前的内容处理程序。
DTDHandler | getDTDHandler() 返回当前的 DTD 处理程序。
EntityResolver | getEntityResolver() 返回当前的实体解析器。
ErrorHandler | getErrorHandler() 返回当前的错误处理程序。
boolean | getFeature(String name) 查找功能标志的值。
Object | getProperty(String name) 查找属性的值。
void | parse(InputSource input) 解析 XML 文档。
void | parse(String systemId) 从系统标识符 (URI) 解析 XML 文档。
void | setContentHandler(ContentHandler handler) 允许应用程序注册内容事件处理程序。
void | setDTDHandler(DTDHandler handler) 允许应用程序注册 DTD 事件处理程序。
void | setEntityResolver(EntityResolver resolver) 允许应用程序注册实体解析器。
void | setErrorHandler(ErrorHandler handler) 允许应用程序注册错误事件处理程序。
void | setFeature(String name, boolean value) 设置功能标志的值。
void | setProperty(String name, Object value) 设置属性的值。

方法详细信息

getFeature

boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找功能标志的值。

功能名称是任何完全限定 URI。XMLReader 识别功能名称是可能的，但暂时不能返回它的值。有些功能值仅在特定的上下文中可用，例如在解析之前、期间或之后。另外，有些功能值不能以编程方式访问。（如果是用于 SAX1 Parser 的适配器，则将没有独立于实现的方法来公开基础解析器是否在执行验证，是否展开外部实体等。）

要求所有的 XMLReaders 都能识别 http://xml.org/sax/features/namespaces 和 http://xml.org/sax/features/namespace-prefixes 功能名称。

典型用途如下：

 XMLReader r = new MySAXDriver();

                         // try to activate validation
 try {
   r.setFeature("http://xml.org/sax/features/validation", true);
 } catch (SAXException e) {
   System.err.println("Cannot activate validation.");
 }

                         // register event handlers
 r.setContentHandler(new MyContentHandler());
 r.setErrorHandler(new MyErrorHandler());

                         // parse the first document
 try {
   r.parse("http://www.foo.com/mydoc.xml");
 } catch (IOException e) {
   System.err.println("I/O exception reading XML document");
 } catch (SAXException e) {
   System.err.println("XML exception reading document.");
 }

通过使用在其自己的 URI 上构建的名称，实现可以随意（建议）设计其自己的功能。

参数：
name - 功能名称，它是一个完全限定 URI。
返回：
该功能的当前值（true 或 false）。
抛出：
SAXNotRecognizedException - 如果功能值不能分配或检索。
SAXNotSupportedException - 当 XMLReader 能够识别功能名称但此时却无法确定其值时。
另请参见：
setFeature(java.lang.String, boolean)

setFeature

void setFeature(String name,
                boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
设置功能标志的值。

功能名称是任何完全限定 URI。XMLReader 可以公开功能值，但却无法改变当前值。有些功能值仅在特定的上下文中不可改变或可以改变，例如在解析之前、期间或之后。

要求所有的 XMLReaders 支持把 http://xml.org/sax/features/namespaces 设置为 true，把 http://xml.org/sax/features/namespace-prefixes 设置为 false。

参数：
name - 功能名称，它是一个完全限定 URI。
value - 请求的功能值（true 或 false）。
抛出：
SAXNotRecognizedException - 如果功能值不能分配或检索。
SAXNotSupportedException - 当 XMLReader 能够识别功能名称但不能设置请求的值时。
另请参见：
getFeature(java.lang.String)

getProperty

Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找属性的值。

属性名称是任何完全限定 URI。XMLReader 可以识别属性名称，但暂时不能返回其值。有些属性值仅在特定的上下文中可用，例如在解析之前、期间或之后。

不要求 XMLReaders 能够识别任何特定的属性名称，但要记录 SAX2 的初始核心集。

使用在其自己的 URI 上构建的名称，实现可以随意（并且推荐）设计其自己的属性。

参数：
name - 属性名称，它是一个完全限定 URI。
返回：
属性的当前值。
抛出：
SAXNotRecognizedException - 如果属性值不能分配或检索。
SAXNotSupportedException - 当 XMLReader 能够识别属性名称但此时却不能确定其值时。
另请参见：
setProperty(java.lang.String, java.lang.Object)

setProperty

void setProperty(String name,
                 Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
设置属性的值。

属性名称是任何完全限定 URI。XMLReader 可以识别属性名称，但却不能改变当前值。有些属性值仅在特定的上下文中不可改变或可以改变，例如在解析之前、期间或之后。

不要求 XMLReaders 知道设置任何特定的属性名称，尽管 SAX2 定义了核心集。

此方法还是用于设置扩展的处理程序的标准机制。

参数：
name - 属性名称，它是一个完全限定 URI。
value - 请求的属性值。
抛出：
SAXNotRecognizedException - 如果属性值不能分配或检索。
SAXNotSupportedException - 当 XMLReader 能够识别属性名称但却不能设置请求的值时。

setEntityResolver

void setEntityResolver(EntityResolver resolver)
允许应用程序注册实体解析器。

如果应用程序不注册实体解析器，则 XMLReader 将执行其自己默认的解析。

应用程序还可以在解析期间注册新的或不同的解析器，并且 SAX 解析器必须立即开始使用新的解析器。

参数：
resolver - 实体解析器。
另请参见：
getEntityResolver()

getEntityResolver

EntityResolver getEntityResolver()
返回当前的实体解析器。

返回：
当前的实体解析器，如果尚未注册，则返回 null。
另请参见：
setEntityResolver(org.xml.sax.EntityResolver)

setDTDHandler

void setDTDHandler(DTDHandler handler)
允许应用程序注册 DTD 事件处理程序。

如果应用程序不注册 DTD 处理程序，则将默默地忽略由 SAX 解析器报告的所有 DTD 事件。

应用程序还可以在解析期间注册新的或不同的处理程序，并且 SAX 解析器必须立即开始使用新的处理程序。

参数：
handler - DTD 处理程序。
另请参见：
getDTDHandler()

getDTDHandler

DTDHandler getDTDHandler()
返回当前的 DTD 处理程序。

返回：
当前的 DTD 处理程序，如果尚未注册，则返回 null。
另请参见：
setDTDHandler(org.xml.sax.DTDHandler)

setContentHandler

void setContentHandler(ContentHandler handler)
允许应用程序注册内容事件处理程序。

如果应用程序不注册内容处理程序，则将默默地忽略由 SAX 解析器报告的所有内容事件。

应用程序还可以在解析期间注册新的或不同的处理程序，并且 SAX 解析器必须立即开始使用新的处理程序。

参数：
handler - 内容处理程序。
另请参见：
getContentHandler()

getContentHandler

ContentHandler getContentHandler()
返回当前的内容处理程序。

返回：
当前的内容处理程序，如果尚未注册，则返回 null。
另请参见：
setContentHandler(org.xml.sax.ContentHandler)

setErrorHandler

void setErrorHandler(ErrorHandler handler)
允许应用程序注册错误事件处理程序。

如果应用程序不注册错误处理程序，则将默默地忽略由 SAX 解析器报告的所有错误事件；但是不能继续进行常规处理。强烈建议所有的 SAX 应用程序实现错误处理程序，以避免出现不可预料的故障。

应用程序还可以在解析期间注册新的或不同的处理程序，并且 SAX 解析器必须立即开始使用新的处理程序。

参数：
handler - 错误处理程序。
另请参见：
getErrorHandler()

getErrorHandler

ErrorHandler getErrorHandler()
返回当前的错误处理程序。

返回：
当前的错误处理程序，如果尚未注册，则返回 null。
另请参见：
setErrorHandler(org.xml.sax.ErrorHandler)

parse

void parse(InputSource input)
           throws IOException,
                  SAXException
解析 XML 文档。

应用程序可以使用此方法指导 XML reader 开始解析来自任何有效输入源（字符流、字节流或 URI）的 XML 文档。

在解析正在进行时，应用程序不能调用此方法（它们必须为每个嵌套的 XML 文档创建新的 XMLReader）。一旦完成了解析，应用程序就可以重新使用同一个 XMLReader 对象（可能带有不同的输入源）。在完成解析之前对 XMLReader 对象的配置（例如为功能标记和属性建立的处理程序绑定和值）是不可改变的，除非配置在此方面的定义显式指定了其他行为。（例如，公开被解析的文档的特征的功能标记或属性。）

在解析期间，XMLReader 通过已注册的事件处理程序提供关于 XML 文档的信息。

此方法是同步的：它直到解析结束后才返回。如果客户端应用程序希望提前终止解析，则它应该抛出一个异常。

参数：
input - XML 文档的顶层的输入源。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 解析器发出的 IO 异常，可能来自应用程序提供的字节流或字符流。
另请参见：
InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setContentHandler(org.xml.sax.ContentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

parse

void parse(String systemId)
           throws IOException,
                  SAXException
从系统标识符 (URI) 解析 XML 文档。

此方法是从系统标识符读取文档这一常见情形的捷径。它完全等效于以下方法：

 parse(new InputSource(systemId));

如果系统标识符是 URL，则在将它传递到解析器之前必须由应用程序对它进行完整的解析。

参数：
systemId - 系统标识符 (URI)。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 解析器发出的 IO 异常，可能来自应用程序提供的字节流或字符流。
另请参见：
parse(org.xml.sax.InputSource)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.xml.sax (Java Platform SE 6)

 org.xml.sax
接口
AttributeList
Attributes
ContentHandler
DocumentHandler
DTDHandler
EntityResolver
ErrorHandler
Locator
Parser
XMLFilter
XMLReader
类
HandlerBase
InputSource
异常
SAXException
SAXNotRecognizedException
SAXNotSupportedException
SAXParseException


org.xml.sax (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.xml.sax

此包提供了核心 SAX API。

请参见：
描述

接口摘要
AttributeList | 已过时。 此接口已经被 SAX2 Attributes 接口取代，后者包括名称空间支持。
Attributes | 关于 XML 属性列表的接口。
ContentHandler | 接收文档逻辑内容的通知。
DocumentHandler | 已过时。 此接口已经被 SAX2 ContentHandler 接口取代，后者包括名称空间支持。
DTDHandler | 接收基本的 DTD 相关的事件的通知。
EntityResolver | 用于解析实体的基本接口。
ErrorHandler | SAX 错误处理程序的基本接口。
Locator | 用来将 SAX 事件与文档位置关联的接口。
Parser | 已过时。 此接口已经被 SAX2 XMLReader 接口取代，后者包括名称空间支持。
XMLFilter | 用于 XML 过滤器的接口。
XMLReader | 用于使用回调读取 XML 文档的接口。

类摘要
HandlerBase | 已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。
InputSource | XML 实体的单一输入源。

异常摘要
SAXException | 封装一般的 SAX 错误或警告。
SAXNotRecognizedException | 用于未识别的标识符的 Exception 类。
SAXNotSupportedException | 用于不被支持的操作的 Exception 类。
SAXParseException | 封装 XML 解析错误或警告。

软件包 org.xml.sax 的描述

此包提供了核心 SAX API。不推荐某些 SAX1 API 支持将名称空间感知性集成到新的应用程序设计当中和对现有的基础结构的维护当中。

有关 SAX 的更多信息，请参阅 http://www.saxproject.org。

SAX2 标准功能标志

SAX2 的基本特征之一就是增加了可用来检查和在可能的情况下修改解析器模式（特别是验证之类的模式）的功能标志。由于这些功能用（绝对）URI 标识，所以任何人都可以定义此类功能。当前定义的标准功能 URI 在标识符（如 validation）之前有前缀 http://xml.org/sax/features/。可使用 setFeature 打开或关闭这些功能。这些标准标识符包括：

功能 ID | 访问 | 默认值 | 描述
外部一般实体 | 读/写 | 未指定 | 报告此解析器是否处理外部一般实体；如果验证，则始终为 true。
外部参数实体 | 读/写 | 未指定 | 报告此解析器是否处理外部参数实体；如果验证，则始终为 true。
独立 | （解析）只读，（不解析）无 | 不适用 | 只可以在解析期间，完成 startDocument() 回调后进行检查；只读。如果文档在其 XML 声明中指定 standalone="yes"，则该值为 true，否则为 false。
词法处理程序/参数实体 | 读/写 | 未指定 | 值 "true" 表示 LexicalHandler 将报告参数实体的开始和结束。
名称空间 | 读/写 | true | 值 "true" 表示名称空间 URI 和元素的无前缀本地名称以及属性名称可用。
名称空间前缀 | 读/写 | false | 值 "true" 表示 XML 限定名（带有前缀）和属性（包括 xmlns* 属性）可用。
resolve-dtd-uris 读/写 true 值 "true" 表示在报告之前将绝对化（与其基 URI 有关）声明中的系统 ID。（这是所有 SAX2 XML 解析器的默认行为。）值 "false" 表示不会绝对化这些 ID；解析器将从 Locator.getSystemId() 中提供基 URI。这适用于传入的系统 ID
  • DTDHandler.notationDecl()、
  • DTDHandler.unparsedEntityDecl() 和
  • DeclHandler.externalEntityDecl()。
不适用于不用来报告声明的 EntityResolver.resolveEntity()，也不适用于 LexicalHandler.startDTD()，后者已经提供了非绝对化的 URI。
字符串驻留 | 读/写 | 未指定 | 如果所有的 XML 名称（针对元素、前缀、属性、实体、表示法和本地名称）以及名称空间 URI 都通过使用 java.lang.String.intern 被驻留下来，则将具有值 "true"。这支持快速测试字符串常量是否相等/不等，而不是强制减慢对 String.equals() 的调用。
unicode 标准化检查 | 读/写 | false | 控制解析器是否报告 Unicode 标准化错误，“XML 1.1 Recommendation”的 2.13 节和附录 B 中描述了这一点。如果为 true，则使用 ErrorHandler.error() 回调报告 Unicode 标准化错误。此类错误本身并不是严重的（尽管显然其他与 Unicode 相关的错误可能是严重的错误）。
use-attributes2 | 只读 | 不可用 | 如果 ContentHandler.startElement() 中的由此解析器传递的 Attributes 对象实现了 org.xml.sax.ext.Attributes2 接口，则返回 "true"。该接口公开其他的与 DTD 相关的信息，例如属性是否在源文本中指定而不是是默认的。
use-locator2 | 只读 | 不可用 | 如果在 ContentHandler.setDocumentLocator() 中由此解析器传递的 Locator 对象实现了 org.xml.sax.ext.Locator2 接口，则返回 "true"。该接口公开其他的实体信息，例如所用的字符编码和 XML 版本。
use-entity-resolver2 | 读/写 | true | 如果为 setEntityResolver 提供实现 org.xml.sax.ext.EntityResolver2 接口的对象时，将使用这些这些新的方法，则返回 "true"。如果返回 "false" 则表示将不使用这些方法。
验证 | 读/写 | 未指定 | 控制解析器是否报告所有的有效性错误；如果为 true，则将读取所有的外部实体。
xmlns-uris | 读/写 | false | 当设置 namespace-prefixes 功能时，控制解析器是否将名称空间声明属性视为在 http://www.w3.org/2000/xmlns/ 名称空间中。默认情况下，SAX2 遵守原始的 "Namespaces in XML" 推荐标准，该推荐标准明确规定此类属性不在任何名称空间中。将此可选标记设置为 "true" 能使 SAX2 事件遵守该推荐标准以后的向后兼容的版本，从而将这些属性置于名称空间中。
xml-1.1 | 只读 | 不适用 | 如果解析器既支持 XML 1.1 又支持 XML 1.0，则返回 "true"。如果解析器仅支持 XML 1.0，则返回 "false"。

要求支持 名称空间 和 名称空间前缀 属性的默认值。对其他任何功能标志的支持是完全可选的。

对于不是由 SAX2 指定的默认值，每个 XMLReader 推荐标准都指定了其默认值，或可以选择不公开功能标志。否则除非在此指定，推荐标准可以支持改变这些标准功能标志的当前值（但在解析期间不可以）。

SAX2 标准处理程序和属性 ID

对于被描述为对象的解析器接口特征，将定义独立名称空间。此名称空间中的对象仍是由 URI 标识的，并且在诸如 lexical-handler 或 dom-node 之类的标识符之前，标准属性 URI 具有前缀 http://xml.org/sax/properties/。可使用 setProperty() 管理这些属性。这些标识符包括：

属性 ID | 描述
declaration-handler | 用来查看大多数 DTD 声明，但那些被视为词法（“document element name is ...”）或者对所有 SAX 解析器 (DTDHandler) 是强制性的声明除外。该对象必须实现 org.xml.sax.ext.DeclHandler。
document-xml-version | 只可以在解析期间、完成 startDocument() 回调后进行检查；只读。此属性是一个字符串常量，它描述了文档的实际 XML 版本，如 "1.0" 或 "1.1"。
dom-node | 对于忽略其 parser.parse() 参数的 "DOM Walker" 样式解析器，这可以用来指定通过该解析器遍历的 DOM (子）树。该对象必须实现 org.w3c.dom.Node 接口。
lexical-handler | 用来查看某些应用程序基本的语法事件：注释、CDATA 分隔符、选定的一般实体收录和 DTD（以及文档元素名称的声明）的开始与结尾。该对象必须实现 org.xml.sax.ext.LexicalHandler。
xml-string | 仅在解析器回调期间可读，这公开负责当前事件的字符的 TBS 存储块。

所有这些标准属性都是可选的；XMLReader 实现不必支持它们。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.xml.sax 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.xml.sax 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.xml.sax.HandlerBase (implements org.xml.sax.DocumentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • org.xml.sax.InputSource
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
          • org.xml.sax.SAXNotSupportedException
          • org.xml.sax.SAXParseException

接口分层结构

  • org.xml.sax.AttributeList
  • org.xml.sax.Attributes
  • org.xml.sax.ContentHandler
  • org.xml.sax.DocumentHandler
  • org.xml.sax.DTDHandler
  • org.xml.sax.EntityResolver
  • org.xml.sax.ErrorHandler
  • org.xml.sax.Locator
  • org.xml.sax.Parser
  • org.xml.sax.XMLReader
    • org.xml.sax.XMLFilter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.xml.sax 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.xml.sax
的使用

使用 org.xml.sax 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind 使用的 org.xml.sax 中的类
ContentHandler
接收文档逻辑内容的通知。
InputSource
XML 实体的单一输入源。

javax.xml.bind.helpers 使用的 org.xml.sax 中的类
ContentHandler
接收文档逻辑内容的通知。
InputSource
XML 实体的单一输入源。
Locator
用来将 SAX 事件与文档位置关联的接口。
SAXException
封装一般的 SAX 错误或警告。
SAXParseException
封装 XML 解析错误或警告。
XMLReader
用于使用回调读取 XML 文档的接口。

javax.xml.parsers 使用的 org.xml.sax 中的类
EntityResolver
用于解析实体的基本接口。
ErrorHandler
SAX 错误处理程序的基本接口。
HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。
InputSource
XML 实体的单一输入源。
Parser
已过时。 此接口已经被 SAX2 XMLReader 接口取代，后者包括名称空间支持。
SAXException
封装一般的 SAX 错误或警告。
SAXNotRecognizedException
用于未识别的标识符的 Exception 类。
SAXNotSupportedException
用于不被支持的操作的 Exception 类。
XMLReader
用于使用回调读取 XML 文档的接口。

javax.xml.transform.sax 使用的 org.xml.sax 中的类
ContentHandler
接收文档逻辑内容的通知。
DTDHandler
接收基本的 DTD 相关的事件的通知。
InputSource
XML 实体的单一输入源。
XMLFilter
用于 XML 过滤器的接口。
XMLReader
用于使用回调读取 XML 文档的接口。

javax.xml.validation 使用的 org.xml.sax 中的类
ContentHandler
接收文档逻辑内容的通知。
ErrorHandler
SAX 错误处理程序的基本接口。
SAXException
封装一般的 SAX 错误或警告。
SAXNotRecognizedException
用于未识别的标识符的 Exception 类。
SAXNotSupportedException
用于不被支持的操作的 Exception 类。

javax.xml.xpath 使用的 org.xml.sax 中的类
InputSource
XML 实体的单一输入源。

org.xml.sax 使用的 org.xml.sax 中的类
AttributeList
已过时。 此接口已经被 SAX2 Attributes 接口取代，后者包括名称空间支持。
Attributes
关于 XML 属性列表的接口。
ContentHandler
接收文档逻辑内容的通知。
DocumentHandler
已过时。 此接口已经被 SAX2 ContentHandler 接口取代，后者包括名称空间支持。
DTDHandler
接收基本的 DTD 相关的事件的通知。
EntityResolver
用于解析实体的基本接口。
ErrorHandler
SAX 错误处理程序的基本接口。
InputSource
XML 实体的单一输入源。
Locator
用来将 SAX 事件与文档位置关联的接口。
SAXException
封装一般的 SAX 错误或警告。
SAXNotRecognizedException
用于未识别的标识符的 Exception 类。
SAXNotSupportedException
用于不被支持的操作的 Exception 类。
SAXParseException
封装 XML 解析错误或警告。
XMLReader
用于使用回调读取 XML 文档的接口。

org.xml.sax.ext 使用的 org.xml.sax 中的类
Attributes
关于 XML 属性列表的接口。
ContentHandler
接收文档逻辑内容的通知。
DTDHandler
接收基本的 DTD 相关的事件的通知。
EntityResolver
用于解析实体的基本接口。
ErrorHandler
SAX 错误处理程序的基本接口。
InputSource
XML 实体的单一输入源。
Locator
用来将 SAX 事件与文档位置关联的接口。
SAXException
封装一般的 SAX 错误或警告。

org.xml.sax.helpers 使用的 org.xml.sax 中的类
AttributeList
已过时。 此接口已经被 SAX2 Attributes 接口取代，后者包括名称空间支持。
Attributes
关于 XML 属性列表的接口。
ContentHandler
接收文档逻辑内容的通知。
DocumentHandler
已过时。 此接口已经被 SAX2 ContentHandler 接口取代，后者包括名称空间支持。
DTDHandler
接收基本的 DTD 相关的事件的通知。
EntityResolver
用于解析实体的基本接口。
ErrorHandler
SAX 错误处理程序的基本接口。
InputSource
XML 实体的单一输入源。
Locator
用来将 SAX 事件与文档位置关联的接口。
Parser
已过时。 此接口已经被 SAX2 XMLReader 接口取代，后者包括名称空间支持。
SAXException
封装一般的 SAX 错误或警告。
SAXNotRecognizedException
用于未识别的标识符的 Exception 类。
SAXNotSupportedException
用于不被支持的操作的 Exception 类。
SAXParseException
封装 XML 解析错误或警告。
XMLFilter
用于 XML 过滤器的接口。
XMLReader
用于使用回调读取 XML 文档的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


Attributes2 (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.ext
接口 Attributes2

所有超级接口：
Attributes
所有已知实现类：
Attributes2Impl
public interface Attributes2
extends Attributes

SAX2 扩展，用于扩充通过 Attributes 提供的每个属性信息。如果实现支持此扩展，则 ContentHandler.startElement() 中提供的属性将实现此接口，并且 http://xml.org/sax/features/use-attributes2 功能标志将具有值 true。

此模块（包括源代码和文档）在公共域中，同时 没有担保。

XMLReader 实现无需支持此信息，并且它不是仅核心 SAX2 分发的一部分。

注意，如果属性是默认的 (!isSpecified())，则它还必须在 DTD 中声明 (isDeclared())。类似地，如果属性的类型是除 CDATA 之外的任何类型，则它必须已声明。

从以下版本开始：
SAX 2.0 (extensions 1.1 alpha)

方法摘要
boolean | isDeclared(int index) 返回 false，除非在 DTD 中声明了该属性。
boolean | isDeclared(String qName) 返回 false，除非在 DTD 中声明该属性。
boolean | isDeclared(String uri, String localName) 返回 false，除非在 DTD 中声明属性。
boolean | isSpecified(int index) 返回 true，除非 DTD 默认提供属性值。
boolean | isSpecified(String qName) 返回 true，除非由 DTD 默认提供属性值。
boolean | isSpecified(String uri, String localName) 返回 true，除非由 DTD 默认提供属性值。
从接口 org.xml.sax.Attributes 继承的方法
getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

方法详细信息

isDeclared

boolean isDeclared(int index)
返回 false，除非在 DTD 中声明了该属性。这有助于区别 SAX 报告为 CDATA 的两种属性：声明的属性（因此，通常是有效的）和未声明的属性（永远是无效的）。

参数：
index - 属性索引（从零开始）。
返回：
如果在 DTD 中声明属性，则返回 true，否则返回 false。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不标识属性时。

isDeclared

boolean isDeclared(String qName)
返回 false，除非在 DTD 中声明该属性。这有助于区别 SAX 报告为 CDATA 的两种属性：声明的属性（因此，通常是有效的）和未声明的属性（永远是无效的）。

参数：
qName - XML 限定（加前缀的)名称。
返回：
如果在 DTD 中声明属性，则返回 true，否则返回 false。
抛出：
IllegalArgumentException - 当提供的名称不标识属性时。

isDeclared

boolean isDeclared(String uri,
                   String localName)
返回 false，除非在 DTD 中声明属性。这有助于区别 SAX 报告为 CDATA 的两种属性：声明的属性（因此，通常是有效的）和未声明的属性（永远是无效的）。

请记住，由于 DTD 不能“理解”名称空间，所以与属性关联的名称空间 URI 不可以来自 DTD。该声明将会应用于属性的 qName。

参数：
uri - 名称空间 URI，如果该名称没有名称空间 URI，则为空字符串。
localName - 属性的本地名称。
返回：
如果在 DTD 中声明属性，则返回 true，否则返回 false。
抛出：
IllegalArgumentException - 当提供的名称不标识属性时。

isSpecified

boolean isSpecified(int index)
返回 true，除非 DTD 默认提供属性值。

参数：
index - 属性索引（从零开始）。
返回：
如果在 XML 文本中找到该值，则返回 true，如果由 DTD 默认提供值，则返回 false。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不标识属性时。

isSpecified

boolean isSpecified(String uri,
                    String localName)
返回 true，除非由 DTD 默认提供属性值。

请记住，由于 DTD 不能“理解”名称空间，所以与属性关联的名称空间 URI 不可以来自 DTD。该声明将会应用于属性的 qName。

参数：
uri - 名称空间 URI，如果该名称没有名称空间 URI，则为空字符串。
localName - 属性的本地名称。
返回：
如果在 XML 文本中找到该值，则返回 true，如果由 DTD 默认提供值，则返回 false。
抛出：
IllegalArgumentException - 当提供的名称不标识属性时。

isSpecified

boolean isSpecified(String qName)
返回 true，除非由 DTD 默认提供属性值。

参数：
qName - XML 限定（加前缀的)名称。
返回：
如果在 XML 文本中找到该值，则返回 true，如果由 DTD 默认提供值，则返回 false。
抛出：
IllegalArgumentException - 当提供的名称不标识属性时。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Attributes2Impl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.ext
类 Attributes2Impl

java.lang.Object
    继承者  org.xml.sax.helpers.AttributesImpl
        继承者  org.xml.sax.ext.Attributes2Impl
所有已实现的接口：
Attributes, Attributes2
public class Attributes2Impl
extends AttributesImpl
implements Attributes2

用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

此模块（包括源代码和文档）在公共域中，同时 没有担保。

这不是仅核心 SAX2 分发的一部分。

每个属性的指定的 标志将总为 true，除非使用副本构造方法或 setSpecified(int, boolean) 将它设置为 false。类似地，每个属性的声明的 标志将总为 false，默认的属性（指定为 false)、非 CDATA 属性或使用 setDeclared(int, boolean) 将其设置为 true 时除外。如果手工更改属性的类型，则为了相符可能需要修改其声明的 标志。

从以下版本开始：
SAX 2.0 (extensions 1.1 alpha)

构造方法摘要
Attributes2Impl()
构造一个新的空 Attributes2Impl 对象。
Attributes2Impl(Attributes atts)
复制现有属性或 Attributes2 对象。
方法摘要
void | addAttribute(String uri, String localName, String qName, String type, String value) 将属性添回到列表的末尾，将其“指定的”标志设置为 true。
boolean | isDeclared(int index) 返回属性的“声明的”标志的当前值。
boolean | isDeclared(String qName) 返回属性的“声明的”标志的当前值。
boolean | isDeclared(String uri, String localName) 返回属性的“声明的”标志的当前值。
boolean | isSpecified(int index) 返回属性的“指定的”标志的当前值。
boolean | isSpecified(String qName) 返回属性的“指定的”标志的当前值。
boolean | isSpecified(String uri, String localName) 返回属性的“指定的”标志的当前值。
void | removeAttribute(int index) 从列表移除属性。
void | setAttributes(Attributes atts) 复制整个属性对象。
void | setDeclared(int index, boolean value) 将值分配给特定属性的“声明的”标志。
void | setSpecified(int index, boolean value) 将值分配给特定属性的“指定的”标志。
从类 org.xml.sax.helpers.AttributesImpl 继承的方法
clear, getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue, setAttribute, setLocalName, setQName, setType, setURI, setValue
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.xml.sax.Attributes 继承的方法
getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

构造方法详细信息

Attributes2Impl

public Attributes2Impl()
构造一个新的空 Attributes2Impl 对象。

Attributes2Impl

public Attributes2Impl(Attributes atts)
复制现有属性或 Attributes2 对象。如果对象实现 Attributes2，则复制每个属性的指定的 和声明的 标志的值。否则，标志值默认假定没有使用任何 DTD，除非有相反证据(例如，属性具有除 CDATA 之外的类型，但它们必须已经声明）。

在 startElement 事件中，此构造方法特别有用。

参数：
atts - 现有 Attributes 对象。
方法详细信息

isDeclared

public boolean isDeclared(int index)
返回属性的“声明的”标志的当前值。

指定者：
接口 Attributes2 中的 isDeclared
参数：
index - 属性索引（从零开始）。
返回：
如果在 DTD 中声明属性，则返回 true，否则返回 false。

isDeclared

public boolean isDeclared(String uri,
                          String localName)
返回属性的“声明的”标志的当前值。

指定者：
接口 Attributes2 中的 isDeclared
参数：
uri - 名称空间 URI，如果该名称没有名称空间 URI，则为空字符串。
localName - 属性的本地名称。
返回：
如果在 DTD 中声明属性，则返回 true，否则返回 false。

isDeclared

public boolean isDeclared(String qName)
返回属性的“声明的”标志的当前值。

指定者：
接口 Attributes2 中的 isDeclared
参数：
qName - XML 限定（加前缀的)名称。
返回：
如果在 DTD 中声明属性，则返回 true，否则返回 false。

isSpecified

public boolean isSpecified(int index)
返回属性的“指定的”标志的当前值。

指定者：
接口 Attributes2 中的 isSpecified
参数：
index - 属性索引（从零开始）。
返回：
当前的标志值
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不标识属性时。

isSpecified

public boolean isSpecified(String uri,
                           String localName)
返回属性的“指定的”标志的当前值。

指定者：
接口 Attributes2 中的 isSpecified
参数：
uri - 名称空间 URI，如果该名称没有名称空间 URI，则为空字符串。
localName - 属性的本地名称。
返回：
当前标志值
抛出：
IllegalArgumentException - 当提供的名称不标识属性时。

isSpecified

public boolean isSpecified(String qName)
返回属性的“指定的”标志的当前值。

指定者：
接口 Attributes2 中的 isSpecified
参数：
qName - XML 限定（加前缀的）名称。
返回：
当前标志值
抛出：
IllegalArgumentException - 当提供的名称不标识属性时。

setAttributes

public void setAttributes(Attributes atts)
复制整个属性对象。将 true 分配给“指定的”标志，将 false 分配给“声明的”标志（属性的类型不是 CDATA 时除外），除非对象是 Attributes2 对象。在此情况下，完全复制这些标志值。

覆盖：
类 AttributesImpl 中的 setAttributes
参数：
atts - 要复制的属性。
另请参见：
AttributesImpl.setAttributes(org.xml.sax.Attributes)

addAttribute

public void addAttribute(String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
将属性添回到列表的末尾，将其“指定的”标志设置为 true。要将标志的值设置为 false，使用 setSpecified(int, boolean)。

除非属性类型 是 CDATA，才按照 DTD 中声明的那样标记此属性。要将该标志值设置为 true，使用 setDeclared(int, boolean)。

覆盖：
类 AttributesImpl 中的 addAttribute
参数：
uri - 名称空间 URI，如果没有可用的，或不是正在执行名称空间处理，则为空字符串。
localName - 本地名称，如果不是正在执行名称空间处理，则为空字符串。
qName - 限定（加前缀的）名称，如果限定名称不可用，则为空字符串。
type - 字符串形式的属性类型。
value - 属性值。
另请参见：
AttributesImpl.addAttribute(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

removeAttribute

public void removeAttribute(int index)
从类 AttributesImpl 复制的描述
从列表移除属性。

覆盖：
类 AttributesImpl 中的 removeAttribute
参数：
index - 属性的索引（从零开始）。

setDeclared

public void setDeclared(int index,
                        boolean value)
将值分配给特定属性的“声明的”标志。通常，仅有类型 CDATA 的属性需要此操作，包括其类型更改为 CDATA 或从 CDATA 更改来的属性。

参数：
index - 属性的索引（从零开始）。
value - 需要的标志值。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不标识属性时。
另请参见：
AttributesImpl.setType(int, java.lang.String)

setSpecified

public void setSpecified(int index,
                         boolean value)
将值分配给特定属性的“指定的”标志。这是能够清除此标志的唯一方法，使用复制构造方法通过初始化进行的清除除外。

参数：
index - 属性的索引（从零开始）。
value - 需要的标志值。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不标识属性时。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DeclHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.ext
接口 DeclHandler

所有已知实现类：
DefaultHandler2
public interface DeclHandler

用于 DTD 声明事件的 SAX2 扩展处理程序。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

这是 SAX2 的一个可选扩展处理程序，以提供有关 XML 文档中 DTD 声明的更完整信息。不需要 XML 阅读器识别此处理程序，它不是仅核心 SAX2 分发的一部分。

注意，已经通过 DTDHandler 接口报告与数据相关的 DTD 声明（未解析的实体和注释）。

如果将声明处理程序与词法处理程序一起使用，则在 startDTD 和 endDTD 事件之间将发生所有事件。

要为 XML 阅读器设置 DeclHandler，使用带有属性名称 http://xml.org/sax/properties/declaration-handler 的 setProperty 方法以及将此接口（或 null）实现为该值的对象。如果阅读器不报告声明事件，则尝试注册处理程序时，它将抛出 SAXNotRecognizedException。

从以下版本开始：
SAX 2.0 (extensions 1.0)

方法摘要
void | attributeDecl(String eName, String aName, String type, String mode, String value) 报告属性类型声明。
void | elementDecl(String name, String model) 报告元素类型声明。
void | externalEntityDecl(String name, String publicId, String systemId) 报告解析的外部实体声明。
void | internalEntityDecl(String name, String value) 报告内部实体声明。

方法详细信息

elementDecl

void elementDecl(String name,
                 String model)
                 throws SAXException
报告元素类型声明。

内容模型将由字符串 "EMPTY"、字符串 "ANY" 或用括号括起来的组组成，可以选择后面跟随一个出现指示符。将使模型标准化，以便完全解析所有的参数实体，并移除所有的空白，并将包括括号。其他标准化（例如，移除多余的括号或简化出现指示符）是由解析器决定的。

参数：
name - 元素类型名称。
model - 作为标准化字符串的内容模型。
抛出：
SAXException - 应用程序可能引发一个异常。

attributeDecl

void attributeDecl(String eName,
                   String aName,
                   String type,
                   String mode,
                   String value)
                   throws SAXException
报告属性类型声明。

将仅报告属性的有效（第一个）声明。类型将是以下字符串之一："CDATA"、"ID"、"IDREF"、"IDREFS"、"NMTOKEN"、"NMTOKENS"、"ENTITY"、"ENTITIES"、移除所有空格的带有分隔符 "|" 的加上括号的标记组，或后跟一个空格再跟随移除所有空白的加上括号的标记组的单词 "NOTATION"。

值将是报告给应用程序、被适当标准化的值，它带有实体和扩展的字符引用。

参数：
eName - 关联元素的名称。
aName - 属性的名称。
type - 表示属性类型的字符串。
mode - 表示属性默认模式（"#IMPLIED"、"#REQUIRED" 或 "#FIXED"）的字符串，如果不应用上述模式，则为 null。
value - 表示属性的默认值的字符串，如果不存在，则为 null。
抛出：
SAXException - 应用程序可能引发一个异常。

internalEntityDecl

void internalEntityDecl(String name,
                        String value)
                        throws SAXException
报告内部实体声明。

将仅报告每个实体的有效（第一个）声明。将扩展值中的所有参数实体，但不扩展常规实体。

参数：
name - 实体的名称。如果是参数实体，则名称以 "%" 开头。
value - 实体的替换文本。
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

externalEntityDecl

void externalEntityDecl(String name,
                        String publicId,
                        String systemId)
                        throws SAXException
报告解析的外部实体声明。

将仅报告每个实体的有效（第一个）声明。

如果系统标识符是 URL，则解析器必须在将它传递给应用程序之前完全解析它。

参数：
name - 实体的名称。如果是参数实体，则名称以 "%" 开头。
publicId - 实体的公共标识符，如果没有给定，则为 null。
systemId - 实体的系统标识符。
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultHandler2 (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.ext
类 DefaultHandler2

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
        继承者  org.xml.sax.ext.DefaultHandler2
所有已实现的接口：
ContentHandler, DTDHandler, EntityResolver, ErrorHandler, DeclHandler, EntityResolver2, LexicalHandler
public class DefaultHandler2
extends DefaultHandler
implements LexicalHandler, DeclHandler, EntityResolver2

此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。除了重写原始 SAX1 resolveEntity() 方法之外，仅返回添加的处理程序方法。子类可能在逐个方法的基础上重写每个事情。

此模块（包括源代码和文档）在公共域中，同时 没有担保。

注：此类可能仍知道 ContentHandler.setDocumentLocator() 调用可能被传递一个 Locator2 对象，并且 ContentHandler.startElement() 调用被传递一个 Attributes2 对象。

从以下版本开始：
SAX 2.0 (extensions 1.1 alpha)

构造方法摘要
DefaultHandler2()
构造忽略所有解析事件的处理程序。
方法摘要
 void attributeDecl(String eName, String aName, String type, String mode, String value)
报告属性类型声明。
 void comment(char[] ch, int start, int length)
报告文档的任何位置的 XML 注释。
 void elementDecl(String name, String model)
报告元素类型声明。
 void endCDATA()
报告 CDATA 节的结束。
 void endDTD()
报告 DTD 声明的结束。
 void endEntity(String name)
报告实体的结束。
 void externalEntityDecl(String name, String publicId, String systemId)
报告解析的外部实体声明。
 InputSource getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
 void internalEntityDecl(String name, String value)
报告内部实体声明。
 InputSource resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
 InputSource resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
 void startCDATA()
报告 CDATA 节的开始。
 void startDTD(String name, String publicId, String systemId)
报告 DTD 声明的开始（如果存在）。
 void startEntity(String name)
报告一些内部和外部 XML 实体的开始。
从类 org.xml.sax.helpers.DefaultHandler 继承的方法
characters, endDocument, endElement, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping, unparsedEntityDecl, warning
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultHandler2

public DefaultHandler2()
构造忽略所有解析事件的处理程序。

方法详细信息

startCDATA

public void startCDATA()
                throws SAXException
从接口 LexicalHandler 复制的描述
报告 CDATA 节的开始。

通过常规 characters 事件报告 CDATA 节的内容；此事件仅用于报告边界。

指定者：
接口 LexicalHandler 中的 startCDATA
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
LexicalHandler.endCDATA()

endCDATA

public void endCDATA()
              throws SAXException
从接口 LexicalHandler 复制的描述
报告 CDATA 节的结束。

指定者：
接口 LexicalHandler 中的 endCDATA
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
LexicalHandler.startCDATA()

startDTD

public void startDTD(String name,
                     String publicId,
                     String systemId)
              throws SAXException
从接口 LexicalHandler 复制的描述
报告 DTD 声明的开始（如果存在）。

此方法主要用于报告 DOCTYPE 声明的开始；如果文档没有任何 DOCTYPE 声明，则不调用此方法。

通过 DTDHandler 或 DeclHandler 事件报告的所有声明必须在 startDTD 和 endDTD 事件之间出现。可以假设声明属于内部 DTD 子集，除非它们在 startEntity 和 endEntity 事件之间出现。也应该在 startDTD 和 endDTD 事件之间，以事件出现的原始顺序（逻辑）报告 DTD 的注释和处理指令；但是，它们不需要出现在相对于 DTDHandler 或 DeclHandler 事件的正确位置。

注意，start/endDTD 事件将出现在 ContentHandler 的 start/endDocument 事件中，并在第一个 startElement 事件之前。

指定者：
接口 LexicalHandler 中的 startDTD
参数：
name - 文档类型名称。
publicId - 用于外部 DTD 子集的已声明的公共标识符，如果没有声明，则为 null。
systemId - 用于外部 DTD 子集的已声明的系统公共标识符，如果没有声明，则为 null。（注意，这不能根据文档基 URI 解析）
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
LexicalHandler.endDTD(), LexicalHandler.startEntity(java.lang.String)

endDTD

public void endDTD()
            throws SAXException
从接口 LexicalHandler 复制的描述
报告 DTD 声明的结束。

此方法主要用于报告 DOCTYPE 声明的结束；如果文档没有任何 DOCTYPE 声明，则不调用此方法。

指定者：
接口 LexicalHandler 中的 endDTD
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
LexicalHandler.startDTD(java.lang.String, java.lang.String, java.lang.String)

startEntity

public void startEntity(String name)
                 throws SAXException
从接口 LexicalHandler 复制的描述
报告一些内部和外部 XML 实体的开始。

参数实体（包括外部 DTD 子集）的报告是可选的，报告 LexicalHandler 事件的 SAX2 驱动程序不能实现它；可以使用 http://xml.org/sax/features/lexical-handler/parameter-entities 功能查询或控制参数实体的报告。

使用其正规名称报告常规实体，参数实体具有置于其名称前的 "%"，并且外部 DTD 子集具有伪实体名 "[dtd]"。

在 SAX2 驱动程序提供这些事件时，所有其他事件必须在开始/结束实体事件中正确嵌套。不存在对来自 DeclHandler 或 DTDHandler 的事件进行正确排序的 附加要求。

注意，跳过的实体将通过 skippedEntity 事件（是 ContentHandler 接口的一部分）报告。

由于 SAX 使用的流事件模型，不能在任何环境下报告某些实体边界：

  • 属性值中的常规实体
  • 声明中的参数实体

将默认扩展上述实体，而不指示原始实体边界的位置。

还要注意，不报告字符引用（实际上它不是实体）的边界。

必须正确嵌套所有 start/endEntity 事件。

指定者：
接口 LexicalHandler 中的 startEntity
参数：
name - 实体的名称。如果是参数实体，则名称将以 "%" 开头，如果是外部 DTD 子集，则将是 "[dtd]"。
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
LexicalHandler.endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

endEntity

public void endEntity(String name)
               throws SAXException
从接口 LexicalHandler 复制的描述
报告实体的结束。

指定者：
接口 LexicalHandler 中的 endEntity
参数：
name - 正在结束的实体名称。
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
LexicalHandler.startEntity(java.lang.String)

comment

public void comment(char[] ch,
                    int start,
                    int length)
             throws SAXException
从接口 LexicalHandler 复制的描述
报告文档的任何位置的 XML 注释。

此回调将用于文档元素内外的注释，包括外部 DTD 子集中的注释（如果读取）。必须在 start/endDTD 和 start/endEntity 事件内部正确嵌套 DTD 中的注释（如果已使用）。

指定者：
接口 LexicalHandler 中的 comment
参数：
ch - 保存注释中的字符的数组。
start - 数组中的开始位置。
length - 使用的数组中的字符数。
抛出：
SAXException - 应用程序可能引发一个异常。

attributeDecl

public void attributeDecl(String eName,
                          String aName,
                          String type,
                          String mode,
                          String value)
                   throws SAXException
从接口 DeclHandler 复制的描述
报告属性类型声明。

将仅报告属性的有效（第一个）声明。类型将是以下字符串之一："CDATA"、"ID"、"IDREF"、"IDREFS"、"NMTOKEN"、"NMTOKENS"、"ENTITY"、"ENTITIES"、移除所有空格的带有分隔符 "|" 的加上括号的标记组，或后跟一个空格再跟随移除所有空白的加上括号的标记组的单词 "NOTATION"。

值将是报告给应用程序、被适当标准化的值，它带有实体和扩展的字符引用。

指定者：
接口 DeclHandler 中的 attributeDecl
参数：
eName - 关联元素的名称。
aName - 属性的名称。
type - 表示属性类型的字符串。
mode - 表示属性默认模式（"#IMPLIED"、"#REQUIRED" 或 "#FIXED"）的字符串，如果不应用上述模式，则为 null。
value - 表示属性的默认值的字符串，如果不存在，则为 null。
抛出：
SAXException - 应用程序可能引发一个异常。

elementDecl

public void elementDecl(String name,
                        String model)
                 throws SAXException
从接口 DeclHandler 复制的描述
报告元素类型声明。

内容模型将由字符串 "EMPTY"、字符串 "ANY" 或用括号括起来的组组成，可以选择后面跟随一个出现指示符。将使模型标准化，以便完全解析所有的参数实体，并移除所有的空白，并将包括括号。其他标准化（例如，移除多余的括号或简化出现指示符）是由解析器决定的。

指定者：
接口 DeclHandler 中的 elementDecl
参数：
name - 元素类型名称。
model - 作为标准化字符串的内容模型。
抛出：
SAXException - 应用程序可能引发一个异常。

externalEntityDecl

public void externalEntityDecl(String name,
                               String publicId,
                               String systemId)
                        throws SAXException
从接口 DeclHandler 复制的描述
报告解析的外部实体声明。

将仅报告每个实体的有效（第一个）声明。

如果系统标识符是 URL，则解析器必须在将它传递给应用程序之前完全解析它。

指定者：
接口 DeclHandler 中的 externalEntityDecl
参数：
name - 实体的名称。如果是参数实体，则名称以 "%" 开头。
publicId - 实体的公共标识符，如果没有给定，则为 null。
systemId - 实体的系统标识符。
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

internalEntityDecl

public void internalEntityDecl(String name,
                               String value)
                        throws SAXException
从接口 DeclHandler 复制的描述
报告内部实体声明。

将仅报告每个实体的有效（第一个）声明。将扩展值中的所有参数实体，但不扩展常规实体。

指定者：
接口 DeclHandler 中的 internalEntityDecl
参数：
name - 实体的名称。如果是参数实体，则名称以 "%" 开头。
value - 实体的替换文本。
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

getExternalSubset

public InputSource getExternalSubset(String name,
                                     String baseURI)
                              throws SAXException,
                                     IOException
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。

指定者：
接口 EntityResolver2 中的 getExternalSubset
参数：
name - 标识文档根元素。此名称来自 DOCTYPE 声明（如果可用），或来自实际的根元素。
baseURI - 文档的基 URI，充当选择外部子集的附加提示。这总是一个绝对 URI，除非由于向 XMLReader 提供了一个不带 URI 的 InputSource 而使它为 null 时。
返回：
描述解析器使用的新外部子集的 InputSource 对象，或指示不提供任何外部子集的 null。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 可能指示创建新的 InputStream 或 Reader 失败，或非法 URL。

resolveEntity

public InputSource resolveEntity(String name,
                                 String publicId,
                                 String baseURI,
                                 String systemId)
                          throws SAXException,
                                 IOException
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。注意，因为是重写旧的 DefaultHandler.resolveEntity() 方法以调用此方法，所以有时可以使用 null 名称 和 baseURI 以及已经绝对化的 systemId 调用此方法。

指定者：
接口 EntityResolver2 中的 resolveEntity
参数：
name - 标识正被解析的外部实体。外部子集的 "[dtd]"，或者以 "%" 开头用来指示参数实体的名称，或者常规实体的名称。在由 SAX2 解析器调用时，它永不能为 null。
publicId - 被引用的外部实体的公共标识符（按照 XML 规范的要求标准化），如果不提供任何内容，则为 null。
baseURI - 关于解释哪个相对 systemID 的 URI。这总是一个绝对 URI，除非它为 null（可能因为向 XMLReader 提供了一个不带 URI 的 InputSource）。XML 规范定义了此 URI，它是与开始相关声明的 "<" 相关联的 URI。
systemId - 引用的外部实体的系统标识符；相对 URI 或绝对 URI。由 SAX2 解析器调用时，它从不能为 null；此类解析器仅解析声明的实体和任何外部子集。
返回：
描述解析器使用的新输入源的 InputSource 对象。返回 null 指示解析器基于基 URI 解析系统 ID，并打开到产生的 URI 的连接。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 可能指示创建新的 InputStream 或 Reader 失败，或非法 URL。

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException,
                                 IOException
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。为使用此类，只需重写该方法。

指定者：
接口 EntityResolver 中的 resolveEntity
覆盖：
类 DefaultHandler 中的 resolveEntity
参数：
publicId - 公共标识符，如果没有可用的，则为 null。
systemId - 在 XML 文档中提供的系统标识符。
返回：
新的输入源，或返回 null，以要求默认的行为。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 特定于 Java 的 IO 异常，可能是由于为 InputSource 创建新的 InputStream 或 Reader 所导致的。
另请参见：
EntityResolver.resolveEntity(java.lang.String, java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EntityResolver2 (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.ext
接口 EntityResolver2

所有超级接口：
EntityResolver
所有已知实现类：
DefaultHandler2
public interface EntityResolver2
extends EntityResolver

扩展的接口，用于将外部实体引用映射到输入源，或用于提供缺少的外部子集。使用 XMLReader.setEntityResolver() 方法将此接口的实现提供给解析器。当解析器使用此接口中的方法时，将使用 EntityResolver2.resolveEntity() 方法（在此接口中）而不是 旧的 (SAX 1.0) EntityResolver.resolveEntity() 方法。

此模块（包括源代码和文档）在公共域中，同时 没有担保。

如果 SAX 应用程序需要此接口为外部实体定义的自定义处理，则必须确保使用 XMLReader，并将 http://xml.org/sax/features/use-entity-resolver2）功能标志设置为 true（识别该功能时，是其默认值）。如果该标志不可识别，或其值为 false，或解析器不能实现此接口，那么仅使用 EntityResolver 方法。

它支持修改实体解析的三种类别的应用程序。此接口对于旧式 应用程序是未知的；它们将提供 EntityResolver。由于多态性，转换模式 提供了 EntityResolver2，并自动获取在任何支持它的系统（解析器或其他工具）中方法的优点。旧式 和转换模式 应用程序将与任何 SAX2 解析器一起工作。新式 应用程序将运行失败，在支持此特定功能的 SAX2 解析器上运行除外。它们强调功能标志应有值 "true"，如果调用原始 SAX 1.0 式实体解析方法，则它们提供的 EntityResolver2 实现可能会抛出异常。

从以下版本开始：
SAX 2.0 (extensions 1.1 alpha)
另请参见：
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

方法摘要
InputSource | getExternalSubset(String name, String baseURI) 允许应用程序为不能显式定义外部子集的文档提供外部子集。
InputSource | resolveEntity(String name, String publicId, String baseURI, String systemId) 允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。
从接口 org.xml.sax.EntityResolver 继承的方法
resolveEntity

方法详细信息

getExternalSubset

InputSource getExternalSubset(String name,
                              String baseURI)
                              throws SAXException,
                                     IOException
允许应用程序为不能显式定义外部子集的文档提供外部子集。这样，具有 DOCTYPE 声明的忽略外部子集的文档可以增加可供验证、实体处理和属性处理（标准化、默认和报告包括 ID 的类型）使用的声明。通过 startDTD() 方法报告此增加，就像文档文本最初就包括外部子集一样；在报告任何内部子集数据或错误之前进行此回调。

此方法也可以与没有 DOCTYPE 声明的文档一起使用。当遇到根元素，但没有看到任何 DOCTYPE 声明时，调用此方法。如果返回该外部子集的一个值，则声明该根元素为根元素，条件是以其他方式在文档序言结尾衔接 DOCTYPE 声明无效。在该情况下，解析器回调序列逻辑上类似以下内容：

 ... comments and PIs from the prolog (as usual)
 startDTD ("rootName", source.getPublicId (), source.getSystemId ());
 startEntity ("[dtd]");
 ... declarations, comments, and PIs from the external subset
 endEntity ("[dtd]");
 endDTD ();
 ... then the rest of the document (as usual)
 startElement (..., "rootName", ...);

注意，InputSource 不能获得进一步的解析。此方法的实现可能要调用 resolveEntity() 以获得一些优点，如使用 DTD 实体的本地缓存。另外，不包括外部参数实体的（非验证）处理器永不使用此方法。

与 XML 处理器进行互操作时，此方法的使用包括简化数据验证，该处理器总是需要对外部实体的不合需要的网络访问，或者由于其他原因采用“非 DTD”策略。非验证目的包括强制文档去包括 DTD，以便能一致地处理属性。例如，XPath 处理器在它能够处理广泛使用的引用类型之前需要知道哪一个属性具有类型 "ID"。

警告：返回外部子集能修改输入文档。通过为常规实体提供定义，能使格式错误的文档看起来格式良好。

参数：
name - 标识文档根元素。此名称来自 DOCTYPE 声明（如果可用），或来自实际的根元素。
baseURI - 文档的基 URI，充当选择外部子集的附加提示。这总是一个绝对 URI，除非由于向 XMLReader 提供了一个不带 URI 的 InputSource 而使它为 null 时。
返回：
描述解析器使用的新外部子集的 InputSource 对象，或指示不提供任何外部子集的 null。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 可能指示创建新的 InputStream 或 Reader 失败，或非法 URL。

resolveEntity

InputSource resolveEntity(String name,
                          String publicId,
                          String baseURI,
                          String systemId)
                          throws SAXException,
                                 IOException
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。仅对已正确声明的外部实体调用此方法。此方法提供比 EntityResolver 接口更多的灵活性，支持更复杂的目录方案（例如 OASIS XML Catalogs 规范定义的目录方案）的实现。

配置为使用此解析器方法的解析器将调用它，以确定用于由于 XML 文本中的引用而包括在内的任何外部实体的输入源。它排除文档实体和 getExternalSubset() 返回的任何外部实体。当通过使用功能标志将（非验证的）处理器配置为不包括实体（参数或常规）的类时，不为此类实体调用此方法。

注意，这里使用的实体命名方案与 LexicalHandler 中或 ContentHandler.skippedEntity() 方法中使用的相同。

参数：
name - 标识正被解析的外部实体。外部子集的 "[dtd]"，或者以 "%" 开头用来指示参数实体的名称，或者常规实体的名称。在由 SAX2 解析器调用时，它永不能为 null。
publicId - 被引用的外部实体的公共标识符（按照 XML 规范的要求标准化），如果不提供任何内容，则为 null。
baseURI - 关于解释哪个相对 systemID 的 URI。这总是一个绝对 URI，除非它为 null（可能因为向 XMLReader 提供了一个不带 URI 的 InputSource）。XML 规范定义了此 URI，它是与开始相关声明的 "<" 相关联的 URI。
systemId - 引用的外部实体的系统标识符；相对 URI 或绝对 URI。由 SAX2 解析器调用时，它从不能为 null；此类解析器仅解析声明的实体和任何外部子集。
返回：
描述解析器使用的新输入源的 InputSource 对象。返回 null 指示解析器基于基 URI 解析系统 ID，并打开到产生的 URI 的连接。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 可能指示创建新的 InputStream 或 Reader 失败，或非法 URL。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LexicalHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.ext
接口 LexicalHandler

所有已知子接口：
TransformerHandler
所有已知实现类：
DefaultHandler2
public interface LexicalHandler

用于词法事件的 SAX2 扩展处理程序。

此模块（包括源代码和文档）在公共域中，同时 没有担保。有关更多信息，请参阅http://www.saxproject.org。

这是 SAX2 的可选扩展处理程序，以提供关于 XML 文档的词汇信息，例如，注释和 CDATA 节边界。不需要 XML 阅读器识别此处理程序，它不是仅核心 SAX2 分发的一部分。

词汇处理程序中的事件应用于整个文档，不是仅应用于文档元素，并且所有词汇处理程序事件必须在内容处理程序的 startDocument 和 endDocument 事件之间出现。

要为 XML 阅读器设置 LexicalHandler，使用带有属性名称 http://xml.org/sax/properties/lexical-handler 的 setProperty 方法以及将此接口（或 null）实现为该值的对象。如果阅读器不报告词汇事件，则尝试注册处理程序时，它将抛出 SAXNotRecognizedException。

从以下版本开始：
SAX 2.0 (extensions 1.0)

方法摘要
void | comment(char[] ch, int start, int length) 报告文档的任何位置的 XML 注释。
void | endCDATA() 报告 CDATA 节的结束。
void | endDTD() 报告 DTD 声明的结束。
void | endEntity(String name) 报告实体的结束。
void | startCDATA() 报告 CDATA 节的开始。
void | startDTD(String name, String publicId, String systemId) 报告 DTD 声明的开始（如果存在）。
void | startEntity(String name) 报告一些内部和外部 XML 实体的开始。

方法详细信息

startDTD

void startDTD(String name,
              String publicId,
              String systemId)
              throws SAXException
报告 DTD 声明的开始（如果存在）。

此方法主要用于报告 DOCTYPE 声明的开始；如果文档没有任何 DOCTYPE 声明，则不调用此方法。

通过 DTDHandler 或 DeclHandler 事件报告的所有声明必须在 startDTD 和 endDTD 事件之间出现。可以假设声明属于内部 DTD 子集，除非它们在 startEntity 和 endEntity 事件之间出现。也应该在 startDTD 和 endDTD 事件之间，以事件出现的原始顺序（逻辑）报告 DTD 的注释和处理指令；但是，它们不需要出现在相对于 DTDHandler 或 DeclHandler 事件的正确位置。

注意，start/endDTD 事件将出现在 ContentHandler 的 start/endDocument 事件中，并在第一个 startElement 事件之前。

参数：
name - 文档类型名称。
publicId - 用于外部 DTD 子集的已声明的公共标识符，如果没有声明，则为 null。
systemId - 用于外部 DTD 子集的已声明的系统公共标识符，如果没有声明，则为 null。（注意，这不能根据文档基 URI 解析）
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
endDTD(), startEntity(java.lang.String)

endDTD

void endDTD()
            throws SAXException
报告 DTD 声明的结束。

此方法主要用于报告 DOCTYPE 声明的结束；如果文档没有任何 DOCTYPE 声明，则不调用此方法。

抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
startDTD(java.lang.String, java.lang.String, java.lang.String)

startEntity

void startEntity(String name)
                 throws SAXException
报告一些内部和外部 XML 实体的开始。

参数实体（包括外部 DTD 子集）的报告是可选的，报告 LexicalHandler 事件的 SAX2 驱动程序不能实现它；可以使用 http://xml.org/sax/features/lexical-handler/parameter-entities 功能查询或控制参数实体的报告。

使用其正规名称报告常规实体，参数实体具有置于其名称前的 "%"，并且外部 DTD 子集具有伪实体名 "[dtd]"。

在 SAX2 驱动程序提供这些事件时，所有其他事件必须在开始/结束实体事件中正确嵌套。不存在对来自 DeclHandler 或 DTDHandler 的事件进行正确排序的 附加要求。

注意，跳过的实体将通过 skippedEntity 事件（是 ContentHandler 接口的一部分）报告。

由于 SAX 使用的流事件模型，不能在任何环境下报告某些实体边界：

  • 属性值中的常规实体
  • 声明中的参数实体

将默认扩展上述实体，而不指示原始实体边界的位置。

还要注意，不报告字符引用（实际上它不是实体）的边界。

必须正确嵌套所有 start/endEntity 事件。

参数：
name - 实体的名称。如果是参数实体，则名称将以 "%" 开头，如果是外部 DTD 子集，则将是 "[dtd]"。
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

endEntity

void endEntity(String name)
               throws SAXException
报告实体的结束。

参数：
name - 正在结束的实体名称。
抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
startEntity(java.lang.String)

startCDATA

void startCDATA()
                throws SAXException
报告 CDATA 节的开始。

通过常规 characters 事件报告 CDATA 节的内容；此事件仅用于报告边界。

抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
endCDATA()

endCDATA

void endCDATA()
              throws SAXException
报告 CDATA 节的结束。

抛出：
SAXException - 应用程序可能引发一个异常。
另请参见：
startCDATA()

comment

void comment(char[] ch,
             int start,
             int length)
             throws SAXException
报告文档的任何位置的 XML 注释。

此回调将用于文档元素内外的注释，包括外部 DTD 子集中的注释（如果读取）。必须在 start/endDTD 和 start/endEntity 事件内部正确嵌套 DTD 中的注释（如果已使用）。

参数：
ch - 保存注释中的字符的数组。
start - 数组中的开始位置。
length - 使用的数组中的字符数。
抛出：
SAXException - 应用程序可能引发一个异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Locator2 (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.ext
接口 Locator2

所有超级接口：
Locator
所有已知实现类：
Locator2Impl
public interface Locator2
extends Locator

SAX2 扩展，用于扩充通过 Locator 提供的实体信息。如果实现支持此扩展，则在 ContentHandler.setDocumentLocator() 中提供的定位器将实现此接口，并且 http://xml.org/sax/features/use-locator2 功能标志将具有值 true。

此模块（包括源代码和文档）在公共域中，同时 没有担保。

XMLReader 实现无需支持此信息，并且它不是仅核心 SAX2 分发的一部分。

从以下版本开始：
SAX 2.0 (extensions 1.1 alpha)

方法摘要
String | getEncoding() 返回实体的字符编码的名称。
String | getXMLVersion() 返回用于该实体的 XML 的版本。
从接口 org.xml.sax.Locator 继承的方法
getColumnNumber, getLineNumber, getPublicId, getSystemId

方法详细信息

getXMLVersion

String getXMLVersion()
返回用于该实体的 XML 的版本。这将正式成为当前实体的 <?xml version='...' ...?> 声明的标识符，或由解析器默认指定。

返回：
用于解释实体的文本的 XML 版本的标识符，如果该信息在当前解析状态中仍不可用，则返回 null。

getEncoding

String getEncoding()
返回实体的字符编码的名称。如果在外部声明该编码（例如，在 MIME Content-Type 的标题中），它将是返回的名称。否则，如果在文档的开始处存在 <?xml ...encoding='...'?> 声明，则将返回该编码名称。否则，将推断编码（通常为 UTF-8，或某些 UTF-16 变体），并且返回推断的名称。

当使用 InputSource 提供实体的字符流时，此方法返回在该输入流中提供的编码。

注意，某些当前 W3C 规范要求在处理之前使用 Unicode Normalization Form C 标准化一些编码中的文本。应用程序必须执行此类标准化，并且通常基于此方法返回的值触发它。

编码名称可以是基础 JVM 使用的编码名称，并且比较时应区分大小写。

返回：
用于解释 * 实体的文本的字符编码的名称，如果不向通过 InputSource 传递的 * 字符流提供该名称，或者在当前解析状态中不可用，则为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Locator2Impl (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.ext
类 Locator2Impl

java.lang.Object
    继承者  org.xml.sax.helpers.LocatorImpl
        继承者  org.xml.sax.ext.Locator2Impl
所有已实现的接口：
Locator2, Locator
public class Locator2Impl
extends LocatorImpl
implements Locator2

用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

此模块（包括源代码和文档）在公共域中，同时 没有担保。

这不是仅内核 SAX2 分发的一部分。

从以下版本开始：
SAX 2.0.2

构造方法摘要
Locator2Impl()
构造一个新的空 Locator2Impl 对象。
Locator2Impl(Locator locator)
复制现有 Locator 或 Locator2 对象。
方法摘要
String | getEncoding() 返回编码属性的当前值。
String | getXMLVersion() 返回版本属性的当前值。
void | setEncoding(String encoding) 分配编码属性的当前值。
void | setXMLVersion(String version) 分配版本属性的当前值。
从类 org.xml.sax.helpers.LocatorImpl 继承的方法
getColumnNumber, getLineNumber, getPublicId, getSystemId, setColumnNumber, setLineNumber, setPublicId, setSystemId
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 org.xml.sax.Locator 继承的方法
getColumnNumber, getLineNumber, getPublicId, getSystemId

构造方法详细信息

Locator2Impl

public Locator2Impl()
构造一个新的空 Locator2Impl 对象。这通常没有用，因为此类的主要用途是做一个现有 Locator 的快照。

Locator2Impl

public Locator2Impl(Locator locator)
复制现有 Locator 或 Locator2 对象。如果对象实现 Locator2，则复制编码 和版本 字符串的值，否则将它们设置为 null。

参数：
locator - 现有 Locator 对象。
方法详细信息

getXMLVersion

public String getXMLVersion()
返回版本属性的当前值。

指定者：
接口 Locator2 中的 getXMLVersion
返回：
用于解释实体的文本的 XML 版本的标识符，如果该信息在当前解析状态中仍不可用，则返回 null。
另请参见：
setXMLVersion(java.lang.String)

getEncoding

public String getEncoding()
返回编码属性的当前值。

指定者：
接口 Locator2 中的 getEncoding
返回：
用于解释 * 实体的文本的字符编码的名称，如果不向通过 InputSource 传递的 * 字符流提供该名称，或者在当前解析状态中不可用，则为 null。
另请参见：
setEncoding(java.lang.String)

setXMLVersion

public void setXMLVersion(String version)
分配版本属性的当前值。

参数：
version - 新的“版本”值
另请参见：
getXMLVersion()

setEncoding

public void setEncoding(String encoding)
分配编码属性的当前值。

参数：
encoding - 新的“编码”值
另请参见：
getEncoding()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.xml.sax.ext (Java Platform SE 6)

 org.xml.sax.ext
接口
Attributes2
DeclHandler
EntityResolver2
LexicalHandler
Locator2
类
Attributes2Impl
DefaultHandler2
Locator2Impl


org.xml.sax.ext (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.xml.sax.ext

此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

请参见：
描述

接口摘要
Attributes2 | SAX2 扩展，用于扩充通过 Attributes 提供的每个属性信息。
DeclHandler | 用于 DTD 声明事件的 SAX2 扩展处理程序。
EntityResolver2 | 扩展的接口，用于将外部实体引用映射到输入源，或用于提供缺少的外部子集。
LexicalHandler | 用于词法事件的 SAX2 扩展处理程序。
Locator2 | SAX2 扩展，用于扩充通过 Locator 提供的实体信息。

类摘要
Attributes2Impl | 用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。
DefaultHandler2 | 此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。
Locator2Impl | 用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

软件包 org.xml.sax.ext 的描述

此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

有关 SAX 的更多信息，请参阅 http://www.saxproject.org。

虽然通常需要在解析器内核中实现公开的功能，但是此包与 SAX2 内核无关。该独立性具有多个结果：

  • 不 需要 SAX2 驱动程序识别这些处理程序。
  • 不能假设类文件存在于每个 SAX2 安装中。
  • 可以独立于 SAX2 更新此包（即在不更新 SAX2 本身的情况下，添加新的处理程序和类）。
  • 新的处理程序不是由 SAX2 org.xml.sax.helpers.DefaultHandler 或 org.xml.sax.helpers.XMLFilterImpl 实现的。如果需要此类行为，则可以子类化它们，或使用在这里找到的帮助程序类。
  • 需要以不同于核心 SAX2 处理程序的方式注册处理程序。

此包 SAX2-ext 是 SAX2 的标准化扩展。其目的是允许 SAX 解析器将某些类型的信息传递到应用程序，同时充当其他 SAX2 解析器扩展包的简单模型。但是，并不是所有的此类扩展包都应由解析器直接识别。例如，可以完全将多数验证系统置于支持标准化 SAX2 接口的解析器顶层。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.xml.sax.ext 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.xml.sax.ext 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
      • org.xml.sax.ext.Attributes2Impl (implements org.xml.sax.ext.Attributes2)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.xml.sax.ext.DefaultHandler2 (implements org.xml.sax.ext.DeclHandler, org.xml.sax.ext.EntityResolver2, org.xml.sax.ext.LexicalHandler)
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
      • org.xml.sax.ext.Locator2Impl (implements org.xml.sax.ext.Locator2)

接口分层结构

  • org.xml.sax.Attributes
    • org.xml.sax.ext.Attributes2
  • org.xml.sax.ext.DeclHandler
  • org.xml.sax.EntityResolver
    • org.xml.sax.ext.EntityResolver2
  • org.xml.sax.ext.LexicalHandler
  • org.xml.sax.Locator
    • org.xml.sax.ext.Locator2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.xml.sax.ext 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.xml.sax.ext
的使用

使用 org.xml.sax.ext 的软件包
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

javax.xml.transform.sax 使用的 org.xml.sax.ext 中的类
LexicalHandler
用于词法事件的 SAX2 扩展处理程序。

org.xml.sax.ext 使用的 org.xml.sax.ext 中的类
Attributes2
SAX2 扩展，用于扩充通过 Attributes 提供的每个属性信息。
DeclHandler
用于 DTD 声明事件的 SAX2 扩展处理程序。
EntityResolver2
扩展的接口，用于将外部实体引用映射到输入源，或用于提供缺少的外部子集。
LexicalHandler
用于词法事件的 SAX2 扩展处理程序。
Locator2
SAX2 扩展，用于扩充通过 Locator 提供的实体信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.ext.Attributes2 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.Attributes2
的使用

使用 Attributes2 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 Attributes2 的使用

实现 Attributes2 的 org.xml.sax.ext 中的类
 class Attributes2Impl
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.ext.Attributes2Impl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.ext.Attributes2Impl
的使用

没有 org.xml.sax.ext.Attributes2Impl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.ext.DeclHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.DeclHandler
的使用

使用 DeclHandler 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 DeclHandler 的使用

实现 DeclHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.ext.DefaultHandler2 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.ext.DefaultHandler2
的使用

没有 org.xml.sax.ext.DefaultHandler2 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.ext.LexicalHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.LexicalHandler
的使用

使用 LexicalHandler 的软件包
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

javax.xml.transform.sax 中 LexicalHandler 的使用

javax.xml.transform.sax 中 LexicalHandler 的子接口
 interface TransformerHandler
侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

返回 LexicalHandler 的 javax.xml.transform.sax 中的方法
 LexicalHandler SAXResult.getLexicalHandler()
获取输出的 SAX2 LexicalHandler。

参数类型为 LexicalHandler 的 javax.xml.transform.sax 中的方法
 void SAXResult.setLexicalHandler(LexicalHandler handler)
设置输出的 SAX2 LexicalHandler。

org.xml.sax.ext 中 LexicalHandler 的使用

实现 LexicalHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.ext.Locator2 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.Locator2
的使用

使用 Locator2 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 Locator2 的使用

实现 Locator2 的 org.xml.sax.ext 中的类
 class Locator2Impl
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.ext.Locator2Impl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.ext.Locator2Impl
的使用

没有 org.xml.sax.ext.Locator2Impl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.ext.EntityResolver2 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ext.EntityResolver2
的使用

使用 EntityResolver2 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 EntityResolver2 的使用

实现 EntityResolver2 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


AttributeListImpl (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 AttributeListImpl

java.lang.Object
    继承者  org.xml.sax.helpers.AttributeListImpl
所有已实现的接口：
AttributeList
已过时。 此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。

public class AttributeListImpl
extends Object
implements AttributeList

AttributeList 的默认实现。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

AttributeList 实现不推荐使用的 SAX1 AttributeList 接口，它已被新的 SAX2 AttributesImpl 接口取代。

此类提供 SAX AttributeList 接口的有用实现。此实现对于 SAX 解析器编写者（使用该实现向应用程序提供属性）和 SAX 应用程序编写者（使用该实现创建元素属性规范的持久副本）都有用：

 private AttributeList myatts;

 public void startElement (String name, AttributeList atts)
 {
              // create a persistent copy of the attribute list
              // for use outside this method
   myatts = new AttributeListImpl(atts);
   [...]
 }

请注意，不要求 SAX 解析器使用此类来提供 AttributeList 的实现；仅作为可选的便捷方法提供它。尤其是，鼓励解析器编写者发明更有效的实现。

从以下版本开始：
SAX 1.0
另请参见：
AttributeList, DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

构造方法摘要
AttributeListImpl()
已过时。 创建空的属性列表。
AttributeListImpl(AttributeList atts)
已过时。 构造现有属性列表的持久副本。
方法摘要
void | addAttribute(String name, String type, String value) 已过时。 向属性列表添加属性。
void | clear() 已过时。 清除属性列表。
int | getLength() 已过时。 返回列表中的属性个数。
String | getName(int i) 已过时。 获取属性名称（按位置）。
String | getType(int i) 已过时。 获取属性的类型（按位置）。
String | getType(String name) 已过时。 获取属性的类型（按名称）。
String | getValue(int i) 已过时。 获取属性的值（按位置）。
String | getValue(String name) 已过时。 获取属性的值（按名称）。
void | removeAttribute(String name) 已过时。 从列表移除属性。
void | setAttributeList(AttributeList atts) 已过时。 设置属性列表，丢弃以前的内容。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AttributeListImpl

public AttributeListImpl()
已过时。
创建空的属性列表。

此构造方法对解析器编写者非常有用，解析器编写者将使用它创建单个的、可重用的属性列表，使用元素之间的 clear 方法可以重设该列表。

另请参见：
addAttribute(java.lang.String, java.lang.String, java.lang.String), clear()

AttributeListImpl

public AttributeListImpl(AttributeList atts)
已过时。
构造现有属性列表的持久副本。

此构造方法对应用程序编写者非常有用，应用程序编写者将使用它创建现有属性列表的持久副本。

参数：
atts - 要复制的属性列表
另请参见：
DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)
方法详细信息

setAttributeList

public void setAttributeList(AttributeList atts)
已过时。
设置属性列表，丢弃以前的内容。

此方法允许应用程序编写者容易地重用属性列表。

参数：
atts - 要复制的属性列表。

addAttribute

public void addAttribute(String name,
                         String type,
                         String value)
已过时。
向属性列表添加属性。

为 SAX 解析器编写者提供此方法，以允许他们在将属性列表传递给应用程序之前以增量方式构建它。

参数：
name - 属性名称。
type - 属性类型（对于枚举为 "NMTOKEN")。
value - 属性值（不得为 null）。
另请参见：
removeAttribute(java.lang.String), DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

removeAttribute

public void removeAttribute(String name)
已过时。
从列表移除属性。

SAX 应用程序编写者可以使用此方法从 AttributeList 中过滤属性。注意，调用此方法会更改属性列表的长度和一些属性的索引。

如果请求的属性不在列表中，则这是无操作。

参数：
name - 属性名称。
另请参见：
addAttribute(java.lang.String, java.lang.String, java.lang.String)

clear

public void clear()
已过时。
清除属性列表。

SAX 解析器编写者可以使用此方法重设 DocumentHandler.startElement 事件之间的属性列表。通常，重用同一 AttributeListImpl 对象，而不每次分配一个新对象是有意义的。

另请参见：
DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

getLength

public int getLength()
已过时。
返回列表中的属性个数。

指定者：
接口 AttributeList 中的 getLength
返回：
此列表中的属性个数。
另请参见：
AttributeList.getLength()

getName

public String getName(int i)
已过时。
获取属性名称（按位置）。

指定者：
接口 AttributeList 中的 getName
参数：
i - 列表中属性的位置。
返回：
字符串形式的属性名称，如果在该位置没有属性，则返回 null。
另请参见：
AttributeList.getName(int)

getType

public String getType(int i)
已过时。
获取属性的类型（按位置）。

指定者：
接口 AttributeList 中的 getType
参数：
i - 列表中属性的位置。
返回：
字符串形式的属性类型（对于枚举为“NMTOKEN”，如果没有读取声明，则为“CDATA”），如果在该位置没有属性，则返回 null。
另请参见：
AttributeList.getType(int)

getValue

public String getValue(int i)
已过时。
获取属性的值（按位置）。

指定者：
接口 AttributeList 中的 getValue
参数：
i - 列表中属性的位置。
返回：
字符串形式的属性值，如果在该位置没有属性，则返回 null。
另请参见：
AttributeList.getValue(int)

getType

public String getType(String name)
已过时。
获取属性的类型（按名称）。

指定者：
接口 AttributeList 中的 getType
参数：
name - 属性名称。
返回：
字符串形式的属性类型（对于枚举为“NMTOKEN”，如果没有读取声明，则为“CDATA”）。
另请参见：
AttributeList.getType(java.lang.String)

getValue

public String getValue(String name)
已过时。
获取属性的值（按名称）。

指定者：
接口 AttributeList 中的 getValue
参数：
name - 属性名称。
返回：
字符串形式的属性值，如果不存在此类属性，则返回 null。
另请参见：
AttributeList.getValue(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AttributesImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 AttributesImpl

java.lang.Object
    继承者  org.xml.sax.helpers.AttributesImpl
所有已实现的接口：
Attributes
直接已知子类：
Attributes2Impl
public class AttributesImpl
extends Object
implements Attributes

Attributes 接口的默认实现。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

此类提供 SAX2 Attributes 接口的默认实现，并附带操纵器，以便可以修改或重用列表。

此类有两种典型的用途：

  1. 在 startElement 事件中捕获 Attributes 对象的持久快照；或
  2. 在 SAX2 驱动程序或过滤器中构造或修改 Attributes 对象。

此类可以替换现已不推荐使用的 SAX1 AttributeListImpl 类；除了支持更新的 Attributes 接口（而不是不推荐使用的 AttributeList 接口）外，它还包括使用单个数组（而不是向量集）更加有效的实现。

从以下版本开始：
SAX 2.0

构造方法摘要
AttributesImpl()
构造一个新的空 AttributesImpl 对象。
AttributesImpl(Attributes atts)
复制现有 Attributes 对象。
方法摘要
void | addAttribute(String uri, String localName, String qName, String type, String value) 将属性添加到列表的末尾。
void | clear() 为了重用而清除属性列表。
int | getIndex(String qName) 通过限定（加前缀的）名称查找属性的索引。
int | getIndex(String uri, String localName) 通过名称空间名称查找属性的索引。
int | getLength() 返回列表中的属性个数。
String | getLocalName(int index) 返回属性的本地名称。
String | getQName(int index) 返回属性的限定（加前缀的）名称。
String | getType(int index) 通过索引返回属性的类型。
String | getType(String qName) 通过限定（加前缀的）名称查找属性的类型。
String | getType(String uri, String localName) 通过限定名称空间的名称查找属性的类型。
String | getURI(int index) 返回属性的名称空间 URI。
String | getValue(int index) 通过索引返回属性的值。
String | getValue(String qName) 通过限定（加前缀的）名称查找属性的值。
String | getValue(String uri, String localName) 通过限定名称空间的名称查找属性的值。
void | removeAttribute(int index) 从列表移除属性。
void | setAttribute(int index, String uri, String localName, String qName, String type, String value) 在列表中设置属性。
void | setAttributes(Attributes atts) 复制整个 Attributes 对象。
void | setLocalName(int index, String localName) 设置特定属性的本地名称。
void | setQName(int index, String qName) 设置特定属性的限定名称。
void | setType(int index, String type) 设置特定属性的类型。
void | setURI(int index, String uri) 设置特定属性的名称空间 URI。
void | setValue(int index, String value) 设置特定属性的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AttributesImpl

public AttributesImpl()
构造一个新的空 AttributesImpl 对象。

AttributesImpl

public AttributesImpl(Attributes atts)
复制现有 Attributes 对象。

在 startElement 事件中，此构造方法特别有用。

参数：
atts - 现有 Attributes 对象。
方法详细信息

getLength

public int getLength()
返回列表中的属性个数。

指定者：
接口 Attributes 中的 getLength
返回：
此列表中的属性个数。
另请参见：
Attributes.getLength()

getURI

public String getURI(int index)
返回属性的名称空间 URI。

指定者：
接口 Attributes 中的 getURI
参数：
index - 属性的索引（从零开始）。
返回：
名称空间 URI，如果没有可用的，则返回空字符串；如果索引超出范围，则返回 null。
另请参见：
Attributes.getURI(int)

getLocalName

public String getLocalName(int index)
返回属性的本地名称。

指定者：
接口 Attributes 中的 getLocalName
参数：
index - 属性的索引（从零开始）。
返回：
属性的本地名称，如果没有，则返回空字符串；如果索引超出范围，则返回 null。
另请参见：
Attributes.getLocalName(int)

getQName

public String getQName(int index)
返回属性的限定（加前缀的）名称。

指定者：
接口 Attributes 中的 getQName
参数：
index - 属性的索引（从零开始）。
返回：
属性的限定名称，如果没有可用的，则返回空字符串；如果索引超出范围，则返回 null。
另请参见：
Attributes.getQName(int)

getType

public String getType(int index)
通过索引返回属性的类型。

指定者：
接口 Attributes 中的 getType
参数：
index - 属性的索引（从零开始）。
返回：
属性的类型，如果类型是未知的，则返回 "CDATA"；如果索引超出范围，则返回 null。
另请参见：
Attributes.getType(int)

getValue

public String getValue(int index)
通过索引返回属性的值。

指定者：
接口 Attributes 中的 getValue
参数：
index - 属性的索引（从零开始）。
返回：
属性的值，如果索引超出范围，则返回 null。
另请参见：
Attributes.getValue(int)

getIndex

public int getIndex(String uri,
                    String localName)
通过名称空间名称查找属性的索引。

在许多情况下，查找一次名称并使用索引查询方法而不重复使用名称查询方法是非常有效的。

指定者：
接口 Attributes 中的 getIndex
参数：
uri - 属性的名称空间 URI，如果没有可用的，则为空字符串。
localName - 属性的本地名称。
返回：
属性的索引，如果没有任何内容相匹配，则返回 -1。
另请参见：
Attributes.getIndex(java.lang.String,java.lang.String)

getIndex

public int getIndex(String qName)
通过限定（加前缀的）名称查找属性的索引。

指定者：
接口 Attributes 中的 getIndex
参数：
qName - 限定的名称。
返回：
属性的索引，如果没有任何内容相匹配，则返回 -1。
另请参见：
Attributes.getIndex(java.lang.String)

getType

public String getType(String uri,
                      String localName)
通过限定名称空间的名称查找属性的类型。

指定者：
接口 Attributes 中的 getType
参数：
uri - 名称空间 URI，对于不带显式的名称空间 URI 的名称，则为空字符串。
localName - 本地名称。
返回：
属性的类型，如果没有任何匹配的属性，则为 null。
另请参见：
Attributes.getType(java.lang.String,java.lang.String)

getType

public String getType(String qName)
通过限定（加前缀的）名称查找属性的类型。

指定者：
接口 Attributes 中的 getType
参数：
qName - 限定的名称。
返回：
属性的类型，如果没有任何匹配的属性，则为 null。
另请参见：
Attributes.getType(java.lang.String)

getValue

public String getValue(String uri,
                       String localName)
通过限定名称空间的名称查找属性的值。

指定者：
接口 Attributes 中的 getValue
参数：
uri - 名称空间 URI，对于不带显式名称空间 URI 的名称，则为空字符串。
localName - 本地名称。
返回：
属性的值，如果没有任何匹配的属性，则为 null。
另请参见：
Attributes.getValue(java.lang.String,java.lang.String)

getValue

public String getValue(String qName)
通过限定（加前缀的）名称查找属性的值。

指定者：
接口 Attributes 中的 getValue
参数：
qName - 限定的名称。
返回：
属性的值，如果没有任何匹配的属性，则为 null。
另请参见：
Attributes.getValue(java.lang.String)

clear

public void clear()
为了重用而清除属性列表。

注意，此调用几乎不释放内存：保存当前数组，以便重用。

setAttributes

public void setAttributes(Attributes atts)
复制整个 Attributes 对象。

重用现有对象比不断分配新对象更高效。

参数：
atts - 要复制的属性。

addAttribute

public void addAttribute(String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
将属性添加到列表的末尾。

由于速度的原因，此方法将不进行检查以查看属性是否已在列表中：这由应用程序负责。

参数：
uri - 名称空间 URI，如果没有可用的，或不是正在执行名称空间处理，则为空字符串。
localName - 本地名称，如果不是正在执行名称空间处理，则为空字符串。
qName - 限定（加前缀的）名称，如果限定名称不可用，则为空字符串。
type - 字符串形式的属性类型。
value - 属性值。

setAttribute

public void setAttribute(int index,
                         String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
在列表中设置属性。

由于速度的原因，此方法不检查名称是否冲突或格式是否良好：此类检查由应用程序负责。

参数：
index - 属性的索引（从零开始）。
uri - 名称空间 URI，如果没有，或不是正在执行名称空间处理，则为空字符串。
localName - 本地名称，如果不是正在执行名称空间处理，则为空字符串。
qName - 限定的名称，如果限定的名称不可用，则为空字符串。
type - 字符串形式的属性类型。
value - 属性值。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不指向列表中的属性时。

removeAttribute

public void removeAttribute(int index)
从列表移除属性。

参数：
index - 属性的索引（从零开始）。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不指向列表中的属性时。

setURI

public void setURI(int index,
                   String uri)
设置特定属性的名称空间 URI。

参数：
index - 属性的索引（从零开始）。
uri - 属性的名称空间 URI，如果没有，则为空字符串。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不指向列表中的属性时。

setLocalName

public void setLocalName(int index,
                         String localName)
设置特定属性的本地名称。

参数：
index - 属性的索引（从零开始）。
localName - 属性的本地名称，如果没有，则为空字符串。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不指向列表中的属性时。

setQName

public void setQName(int index,
                     String qName)
设置特定属性的限定名称。

参数：
index - 属性的索引（从零开始）。
qName - 属性的限定名称，如果没有，则为空字符串。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不指向列表中的属性时。

setType

public void setType(int index,
                    String type)
设置特定属性的类型。

参数：
index - 属性的索引（从零开始）。
type - 属性的类型。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不指向列表中的属性时。

setValue

public void setValue(int index,
                     String value)
设置特定属性的值。

参数：
index - 属性的索引（从零开始）。
value - 属性的值。
抛出：
ArrayIndexOutOfBoundsException - 当提供的索引不指向列表中的属性时。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultHandler (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 DefaultHandler

java.lang.Object
    继承者  org.xml.sax.helpers.DefaultHandler
所有已实现的接口：
ContentHandler, DTDHandler, EntityResolver, ErrorHandler
直接已知子类：
DefaultHandler2
public class DefaultHandler
extends Object
implements EntityResolver, DTDHandler, ContentHandler, ErrorHandler

SAX2 事件处理程序的默认基类。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

此类可用作 SAX2 应用程序的有用基类：它提供四个核心 SAX2 处理程序类中的所有回调的默认实现：

  • EntityResolver
  • DTDHandler
  • ContentHandler
  • ErrorHandler

应用程序编写者可以在他们仅需实现部分接口时扩展此类；当应用程序尚未提供其自己的处理程序时解析器编写者可通过实例化此类来提供默认的处理程序。

此类替换不推荐使用的 SAX1 HandlerBase 类。

从以下版本开始：
SAX 2.0
另请参见：
EntityResolver, DTDHandler, ContentHandler, ErrorHandler

构造方法摘要
DefaultHandler()
方法摘要
void | characters(char[] ch, int start, int length) 接收元素中字符数据的通知。
void | endDocument() 接收文档结束的通知。
void | endElement(String uri, String localName, String qName) 接收元素结束的通知。
void | endPrefixMapping(String prefix) 接收名称空间映射结束的通知。
void | error(SAXParseException e) 接收可恢复的解析器错误的通知。
void | fatalError(SAXParseException e) 报告严重的 XML 解析错误。
void | ignorableWhitespace(char[] ch, int start, int length) 接收元素内容中可忽略空白的通知。
void | notationDecl(String name, String publicId, String systemId) 接收注释声明的通知。
void | processingInstruction(String target, String data) 接收处理指令的通知。
InputSource | resolveEntity(String publicId, String systemId) 解析外部实体。
void | setDocumentLocator(Locator locator) 接收文档事件的 Locator 对象。
void | skippedEntity(String name) 接收跳过的实体的通知。
void | startDocument() 接收文档开始的通知。
void | startElement(String uri, String localName, String qName, Attributes attributes) 接收元素开始的通知。
void | startPrefixMapping(String prefix, String uri) 接收名称空间映射开始的通知。
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 接收未解析实体声明的通知。
void | warning(SAXParseException e) 接收解析器警告的通知。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultHandler

public DefaultHandler()
方法详细信息

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws IOException,
                                 SAXException
解析外部实体。

将始终返回 null，因此解析器将使用 XML 文档中提供的系统标识符。此方法实现 SAX 默认的行为：应用程序编写者可以在子类中重写它以便进行诸如目录查找或 URI 重定向之类的特定转换。

指定者：
接口 EntityResolver 中的 resolveEntity
参数：
publicId - 公共标识符，如果没有可用的，则为 null。
systemId - 在 XML 文档中提供的系统标识符。
返回：
新的输入源，或返回 null，以要求默认的行为。
抛出：
IOException - 如果在设置新的输入源时发生错误。
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
EntityResolver.resolveEntity(java.lang.String, java.lang.String)

notationDecl

public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
接收注释声明的通知。

默认情况下，不执行任何操作。如果应用程序编写者希望跟踪在文档中声明的注释，则可以在子类中重写此方法。

指定者：
接口 DTDHandler 中的 notationDecl
参数：
name - 注释名称。
publicId - 注释公共标识符，如果没有可使用的则为 null。
systemId - 注释系统标识符。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

unparsedEntityDecl

public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
接收未解析实体声明的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便跟踪在文档中声明的未解析实体。

指定者：
接口 DTDHandler 中的 unparsedEntityDecl
参数：
name - 实体名称。
publicId - 实体公共标识符，如果不可用，则为 null。
systemId - 实体系统标识符。
notationName - 相关联的注释的名称。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

setDocumentLocator

public void setDocumentLocator(Locator locator)
接收文档事件的 Locator 对象。

默认情况下，不执行任何操作。如果应用程序编写者希望存储定位器以用于其他的文档事件，则可以在子类中重写此方法。

指定者：
接口 ContentHandler 中的 setDocumentLocator
参数：
locator - 用于所有 SAX 文档事件的定位器。
另请参见：
ContentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

startDocument

public void startDocument()
                   throws SAXException
接收文档开始的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在文档的开始采取特定的措施（如分配树的根节点或创建输出文件）。

指定者：
接口 ContentHandler 中的 startDocument
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.startDocument()

endDocument

public void endDocument()
                 throws SAXException
接收文档结束的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在文档的结束处采取特定的操作（如，结束树或关闭输出文件）。

指定者：
接口 ContentHandler 中的 endDocument
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.endDocument()

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
接收名称空间映射开始的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在每个名称空间前缀范围的开始处采取特定的操作（如存储前缀映射）。

指定者：
接口 ContentHandler 中的 startPrefixMapping
参数：
prefix - 正在声明的名称空间前缀。
uri - 映射到前缀的名称空间 URI。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

endPrefixMapping

public void endPrefixMapping(String prefix)
                      throws SAXException
接收名称空间映射结束的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在每个前缀映射的结束处采取特定的操作。

指定者：
接口 ContentHandler 中的 endPrefixMapping
参数：
prefix - 正在声明的名称空间前缀。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.endPrefixMapping(java.lang.String)

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes attributes)
                  throws SAXException
接收元素开始的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在每个元素的开始处采取特定的操作（如，分配新的树节点或将输出写入文件）。

指定者：
接口 ContentHandler 中的 startElement
参数：
uri - 名称空间 URI，如果元素没有任何名称空间 URI，或者没有正在执行名称空间处理，则为空字符串。
localName - 本地名称（不带前缀），如果没有正在执行名称空间处理，则为空字符串。
qName - 限定的名称（带有前缀），如果限定的名称不可用，则为空字符串。
attributes - 附加到元素的属性。如果没有属性，则它将是空的 Attributes 对象。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
接收元素结束的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便在每个元素的结束处采取特定的操作（如，结束树节点或将输出写入文件）。

指定者：
接口 ContentHandler 中的 endElement
参数：
uri - 名称空间 URI，如果元素没有任何名称空间 URI，或者没有正在执行名称空间处理，则为空字符串。
localName - 本地名称（不带前缀），如果没有正在执行名称空间处理，则为空字符串。
qName - 限定的名称（带有前缀），如果限定的名称不可用，则为空字符串。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
接收元素中字符数据的通知。

默认情况下，不执行任何操作。应用程序编写者可以重写此方法，以便对每块字符数据采取特定的措施（如将该数据添加到节点或缓冲区，或者将该数据打印到文件）。

指定者：
接口 ContentHandler 中的 characters
参数：
ch - 字符。
start - 字符数组中的开始位置。
length - 从字符数组中使用的字符数。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.characters(char[], int, int)

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
接收元素内容中可忽略空白的通知。

默认情况下，不执行任何操作。应用程序编写者可以重写此方法，以便对每块可忽略的空白采取特定的措施（如将数据添加到节点或缓冲区，或者将数据打印到文件）。

指定者：
接口 ContentHandler 中的 ignorableWhitespace
参数：
ch - 空白字符。
start - 字符数组中的开始位置。
length - 从字符数组中使用的字符数。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.ignorableWhitespace(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
接收处理指令的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便对每个处理指令采取特定的措施，如设置状态变量或调用其他的方法。

指定者：
接口 ContentHandler 中的 processingInstruction
参数：
target - 处理指令目标。
data - 处理指令数据，如果未提供，则为 null。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.processingInstruction(java.lang.String, java.lang.String)

skippedEntity

public void skippedEntity(String name)
                   throws SAXException
接收跳过的实体的通知。

默认情况下，不执行任何操作。应用程序编写者可以在子类中重写此方法，以便对每个处理指令采取特定的措施，如设置状态变量或调用其他的方法。

指定者：
接口 ContentHandler 中的 skippedEntity
参数：
name - 跳过的实体的名称。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ContentHandler.processingInstruction(java.lang.String, java.lang.String)

warning

public void warning(SAXParseException e)
             throws SAXException
接收解析器警告的通知。

默认实现不执行任何操作。应用程序编写者可以在子类中重写此方法，以便对每个警告采取特定的措施，如在日志文件中插入消息，或者将它打印到控制台。

指定者：
接口 ErrorHandler 中的 warning
参数：
e - 被编码为异常的警告信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

error

public void error(SAXParseException e)
           throws SAXException
接收可恢复的解析器错误的通知。

默认实现不执行任何操作。应用程序编写者可以在子类中重写此方法，以便对每个错误采取特定的措施，如在日志文件中插入消息，或者将它打印到控制台。

指定者：
接口 ErrorHandler 中的 error
参数：
e - 被编码为异常的错误信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

fatalError

public void fatalError(SAXParseException e)
                throws SAXException
报告严重的 XML 解析错误。

默认的实现抛出 SAXParseException。如果应用程序编写者需要对每个严重的错误采取特定的措施（如将所有的错误收集到一个报告中），则可以在子类中重写此方法：当调用此方法时，无论哪种情况，应用程序都必须停止所有的常规处理，这是因为文档已不再可靠，并且解析器再也不能报告解析事件。

指定者：
接口 ErrorHandler 中的 fatalError
参数：
e - 被编码为异常的错误信息。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
另请参见：
ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LocatorImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 LocatorImpl

java.lang.Object
    继承者  org.xml.sax.helpers.LocatorImpl
所有已实现的接口：
Locator
直接已知子类：
Locator2Impl
public class LocatorImpl
extends Object
implements Locator

提供 Locator 的可选的有用实现。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

此类主要对应用程序编写者有用，他们可以在文档解析过程中使用该类对任意点的定位器进行持久快照：

 Locator locator;
 Locator startloc;

 public void setLocator (Locator locator)
 {
         // note the locator
   this.locator = locator;
 }

 public void startDocument ()
 {
         // save the location of the start of the document
         // for future use.
   Locator startloc = new LocatorImpl(locator);
 }

通常，解析器编写者将不使用此类，因为仅当请求时提供位置信息才能更有效，而不持续地更新 Locator 对象。

从以下版本开始：
SAX 1.0
另请参见：
Locator

构造方法摘要
LocatorImpl()
零参数的构造方法。
LocatorImpl(Locator locator)
复制构造方法。
方法摘要
int | getColumnNumber() 返回保存的列数（从 1 开始）。
int | getLineNumber() 返回保存的行数（从 1 开始）。
String | getPublicId() 返回保存的公开标识符。
String | getSystemId() 返回保存的系统标识符。
void | setColumnNumber(int columnNumber) 设置此定位器的列数（从 1 开始）。
void | setLineNumber(int lineNumber) 设置此定位器的行数（从 1 开始）。
void | setPublicId(String publicId) 设置此定位器的公开标识符。
void | setSystemId(String systemId) 设置此定位器的系统标识符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LocatorImpl

public LocatorImpl()
零参数的构造方法。

这通常没有用，因为此类的主要用途是获取现有 Locator 的快照。

LocatorImpl

public LocatorImpl(Locator locator)
复制构造方法。

创建定位器的当前状态的持久副本。当初始定位器更改时，此副本将仍保持初始值（并且可以在 DocumentHandler 方法的作用域之外使用它）。

参数：
locator - 要复制的定位器。
方法详细信息

getPublicId

public String getPublicId()
返回保存的公开标识符。

指定者：
接口 Locator 中的 getPublicId
返回：
字符串形式的公开标识符，如果没有可用的，则为 null。
另请参见：
Locator.getPublicId(), setPublicId(java.lang.String)

getSystemId

public String getSystemId()
返回保存的系统标识符。

指定者：
接口 Locator 中的 getSystemId
返回：
字符串形式的系统标识符，如果没有可用的，则为 null。
另请参见：
Locator.getSystemId(), setSystemId(java.lang.String)

getLineNumber

public int getLineNumber()
返回保存的行数（从 1 开始）。

指定者：
接口 Locator 中的 getLineNumber
返回：
整数形式的行数，如果没有可用的，则返回 -1。
另请参见：
Locator.getLineNumber(), setLineNumber(int)

getColumnNumber

public int getColumnNumber()
返回保存的列数（从 1 开始）。

指定者：
接口 Locator 中的 getColumnNumber
返回：
整数形式的列数，如果没有可用的，则返回 -1。
另请参见：
Locator.getColumnNumber(), setColumnNumber(int)

setPublicId

public void setPublicId(String publicId)
设置此定位器的公开标识符。

参数：
publicId - 新的公开标识符，如果没有可用的，则为 null。
另请参见：
getPublicId()

setSystemId

public void setSystemId(String systemId)
设置此定位器的系统标识符。

参数：
systemId - 新的系统标识符，如果没有可用的，则为 null。
另请参见：
getSystemId()

setLineNumber

public void setLineNumber(int lineNumber)
设置此定位器的行数（从 1 开始）。

参数：
lineNumber - 行数，如果没有可用的，则为 -1。
另请参见：
getLineNumber()

setColumnNumber

public void setColumnNumber(int columnNumber)
设置此定位器的列数（从 1 开始）。

参数：
columnNumber - 列数，如果没有可用的，则为 -1。
另请参见：
getColumnNumber()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamespaceSupport (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 NamespaceSupport

java.lang.Object
    继承者  org.xml.sax.helpers.NamespaceSupport

public class NamespaceSupport
extends Object

封装名称空间逻辑，以便由使用 SAX 的应用程序使用，或由 SAX 驱动程序内部使用。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

此类封装名称空间处理的逻辑：它可以跟踪当前对每个上下文强制使用的声明，并自动将限定的 XML 名称处理为其名称空间的一部分；它还可以反过来用于从名称空间生成 XML qname。

名称空间支持对象是可重用的，但是在每个会话之间必须调用 reset 方法。

下面是一个简单的会话：

String parts[] = new String[3];
 NamespaceSupport support = new NamespaceSupport();

 support.pushContext();
 support.declarePrefix("", "http://www.w3.org/1999/xhtml");
 support.declarePrefix("dc", "http://www.purl.org/dc#");

 parts = support.processName("p", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 parts = support.processName("dc:title", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 support.popContext();

注意，对于多数元素不包含名称空间声明的使用情况，必须优化此类：例如，如果对每个上下文都重复相同的前缀/URI 映射，则此类将会产生某种程度的低效率。

虽然 SAX 驱动程序（解析器）可以选择使用此类来实现名称空间处理，但是不要求它们这样做。如果应用程序要使用名称空间信息，则它们必须跟踪名称空间信息本身。

从以下版本开始：
SAX 2.0

字段摘要
static String | NSDECL 作为常量的名称空间声明 URI。
static String | XMLNS 作为常量的 XML 名称空间 URI。
构造方法摘要
NamespaceSupport()
创建新的名称空间支持对象。
方法摘要
 boolean declarePrefix(String prefix, String uri)
声明名称空间前缀。
 Enumeration getDeclaredPrefixes()
返回此上下文中声明的所有前缀的枚举。
 String getPrefix(String uri)
返回映射到名称空间 URI 的前缀之一。
 Enumeration getPrefixes()
返回所有前缀的枚举，其声明在当前上下文中是活动的。
 Enumeration getPrefixes(String uri)
返回给定 URI 的 所有前缀的枚举，给定 URI 的声明在当前上下文中是活动的。
 String getURI(String prefix)
查找前缀，并获取当前映射的名称空间 URI。
 boolean isNamespaceDeclUris()
如果将名称空间声明属性放置到名称空间中，则返回 true。
 void popContext()
恢复到以前的名称空间上下文。
 String[] processName(String qName, String[] parts, boolean isAttribute)
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。
 void pushContext()
开始新的名称空间上下文。
 void reset()
重设此名称空间支持对象，以便重新使用。
 void setNamespaceDeclUris(boolean value)
控制是否通过 processName() 将名称空间声明属性放置到 NSDECL 名称空间中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

XMLNS

public static final String XMLNS
作为常量的 XML 名称空间 URI。值是 http://www.w3.org/XML/1998/namespace，在 "Namespaces in XML" * 推荐标准中定义。

这是自动映射到 "xml" 前缀的名称空间 URI。

另请参见：
常量字段值

NSDECL

public static final String NSDECL
作为常量的名称空间声明 URI。值是 http://www.w3.org/xmlns/2000/，在 "Namespaces in XML" 推荐标准的向后兼容勘误表中定义。因为勘误表晚于 SAX2，SAX2 默认为原始的推荐标准，并且通常不使用此 URI。

这是可以选择应用到 xmlns 和 xmlns:* 属性的名称空间 URI，使用它声明名称空间。

从以下版本开始：
SAX 2.1alpha
另请参见：
setNamespaceDeclUris(boolean), isNamespaceDeclUris(), 常量字段值
构造方法详细信息

NamespaceSupport

public NamespaceSupport()
创建新的名称空间支持对象。

方法详细信息

reset

public void reset()
重设此名称空间支持对象，以便重新使用。

在为新的会话重用名称空间支持对象之前，有必要调用此方法。如果要支持名称空间声明 URI，则还必须将标志设置为非默认值。

另请参见：
setNamespaceDeclUris(boolean)

pushContext

public void pushContext()
开始新的名称空间上下文。新的上下文将自动继承其父上下文的声明，但是它还将跟踪在此上下文中所做的声明。

事件回调代码应对每个元素启动一次新的上下文。这意味着已准备好在两个位置中的任何一个位置调用它。对于不包括名称空间声明的元素，ContentHandler.startElement() 回调是正确的位置。对于具有此类声明的元素，它在第一个 ContentHandler.startPrefixMapping() 回调中完成。可以使用布尔标志跟踪是否已启动上下文。当调用这些方法中的任何一个方法时，它会检查该标志以查看是否需要启动新的上下文。如果是，它会启动上下文，并设置标志。在 ContentHandler.startElement() 设置标志后，它总是清除该标志。

通常，SAX 驱动程序会在每个 XML 元素的开始处推送新的上下文。然后，它们执行属性上的第一个传递，以处理所有的名称空间声明，进行 ContentHandler.startPrefixMapping() 回调。然后，进行第二个传递，以便为所有属性和元素名称确定限定名称空间的名称。最后，ContentHandler.startElement() 回调的所有信息都是可用的，这样就可以完成。

名称空间支持对象总是以已经有效的基本上下文开始：在此上下文中，仅声明 "xml" 前缀。

另请参见：
ContentHandler, popContext()

popContext

public void popContext()
恢复到以前的名称空间上下文。

通常，应在每个 XML 元素的结束处弹出上下文。弹出上下文后，恢复以前有效的所有名称空间前缀映射。

弹出上下文后，不得尝试声明其他名称空间前缀，除非首先推送另一个上下文。

另请参见：
pushContext()

declarePrefix

public boolean declarePrefix(String prefix,
                             String uri)
声明名称空间前缀。在引用前缀之前，必须对它们进行声明。例如，SAX 驱动程序（解析器）将在下面两个过程中扫描元素的属性：第一个是名称空间声明，然后是第二个过程，它使用 processName() 根据（潜在预定义的）前缀解释前缀。

此方法在当前名称空间上下文中声明前缀；在弹出此上下文之前，前缀仍保持有效，除非它在后代上下文中映像。

要声明默认元素名称空间，请使用空字符串作为前缀。

注意，在此库中存在不对称：即使声明了默认元素名称空间，getPrefix 也不会返回 "" 前缀。要检查默认名称空间，必须使用 getURI 显式查找它。存在此不对称使查找属性名称的前缀更容易，其中不允许默认的前缀。

参数：
prefix - 要声明的前缀，或指示默认元素名称空间的空字符串。这不能有值“xml”或“xmlns”。
uri - 与前缀关联的名称空间 URI。
返回：
如果前缀是合法的，则返回 true；否则，返回 false
另请参见：
processName(java.lang.String, java.lang.String[], boolean),
getURI(java.lang.String),
getPrefix(java.lang.String)

processName

public String[] processName(String qName,
                            String[] parts,
                            boolean isAttribute)
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。

此方法通过移除前缀，并在当前声明的前缀之中查找它来处理当前上下文中的原始 XML 限定名称。返回值将是调用者提供的数组，按以下方式填写：

parts[0]
名称空间 URI，如果没有正在使用的，则为空字符串。
parts[1]
本地名称（不带前缀）。
parts[2]
最初的原始名称。

将内部化数组中的所有字符串。如果原始名称具有没有声明的前缀，那么返回值将为 null。

注意，处理属性名称与处理元素名称不同：未加前缀的元素名称将接收默认名称空间（如果有），而未加前缀的属性名称将不接收。

参数：
qName - 要处理的 XML 限定名称。
parts - 调用者提供的数组，至少能够保存三个成员。
isAttribute - 指示这是属性名称 (true) 或元素名称 (false) 的标志。
返回：
提供的数组，它持有三个内部化字符串，表示名称空间 URI（或空字符串）、本地名称和 XML 限定名称；如果存在未声明的前缀，则返回 null。
另请参见：
declarePrefix(java.lang.String, java.lang.String), String.intern()

getURI

public String getURI(String prefix)
查找前缀，并获取当前映射的名称空间 URI。

此方法查找当前上下文中的前缀。对于默认名称空间，使用空字符串 ("")。

参数：
prefix - 要查找的前缀。
返回：
关联的名称空间 URI，如果此上下文中未声明前缀，则返回 null。
另请参见：
getPrefix(java.lang.String), getPrefixes()

getPrefixes

public Enumeration getPrefixes()
返回所有前缀的枚举，其声明在当前上下文中是活动的。这包括来自没有被重写的父上下文的声明。

注：如果存在默认前缀，则在此枚举中将不返回它；使用带有参数 "" 的 getURI 检查默认前缀。

返回：
前缀的枚举（永远不为空）。
另请参见：
getDeclaredPrefixes(), getURI(java.lang.String)

getPrefix

public String getPrefix(String uri)
返回映射到名称空间 URI 的前缀之一。

如果当前有多个前缀映射到同一 URI，则此方法将进行任意选择；如果需要所有前缀，则改用 getPrefixes() 方法。

注：这将永不返回空（默认）前缀；要检查默认前缀，请使用带有参数 "" 的 getURI 方法。

参数：
uri - 名称空间 URI
返回：
当前映射到所提供的 URI 的前缀之一，如果没有映射内容，或者将 URI 分配到默认名称空间，则返回 null
另请参见：
getPrefixes(java.lang.String), getURI(java.lang.String)

getPrefixes

public Enumeration getPrefixes(String uri)
返回给定 URI 的 所有前缀的枚举，给定 URI 的声明在当前上下文中是活动的。这包括来自没有被重写的父上下文的声明。

此方法返回映射到特定名称空间 URI 的前缀。将包括前缀：xml。如果仅需要映射到名称空间 URI 的一个前缀，并且不关心获取哪一个前缀，请改用 getPrefix 方法。

注：此枚举中永不 包括空的（默认）前缀；要检查是否存在默认名称空间，请使用带有参数 "" 的 getURI 方法。

参数：
uri - 名称空间 URI。
返回：
前缀的枚举（永不为空）。
另请参见：
getPrefix(java.lang.String),
getDeclaredPrefixes(),
getURI(java.lang.String)

getDeclaredPrefixes

public Enumeration getDeclaredPrefixes()
返回此上下文中声明的所有前缀的枚举。

此枚举中将包括空的（默认）前缀；注意，此行为与 getPrefix(java.lang.String) 和 getPrefixes() 的行为不同。

返回：
此上下文中声明的所有前缀的枚举。
另请参见：
getPrefixes(), getURI(java.lang.String)

setNamespaceDeclUris

public void setNamespaceDeclUris(boolean value)
控制是否通过 processName() 将名称空间声明属性放置到 NSDECL 名称空间中。在推送任何上下文之前，这是唯一可更改的。

抛出：
IllegalStateException - 当推送任何上下文之后尝试设置它时。
从以下版本开始：
SAX 2.1alpha

isNamespaceDeclUris

public boolean isNamespaceDeclUris()
如果将名称空间声明属性放置到名称空间中，则返回 true。此行为不是默认的行为。

从以下版本开始：
SAX 2.1alpha
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParserAdapter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 ParserAdapter

java.lang.Object
    继承者  org.xml.sax.helpers.ParserAdapter
所有已实现的接口：
DocumentHandler, XMLReader
public class ParserAdapter
extends Object
implements XMLReader, DocumentHandler

将 SAX1 Parser 适配为 SAX2 XMLReader。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

此类包装 SAX1 Parser，并使其充当带有功能、属性和名称空间支持的 SAX2 XMLReader。注意，不可能报告 skippedEntity 事件，因为 SAX1 不提供该信息。

此适配器不对重复的名称空间限定的属性进行测试。

从以下版本开始：
SAX 2.0
另请参见：
XMLReaderAdapter, XMLReader, Parser

构造方法摘要
ParserAdapter()
构造一个新解析器适配器。
ParserAdapter(Parser parser)
构造一个新的解析器适配器。
方法摘要
void | characters(char[] ch, int start, int length) 适配器实现方法；不调用。
void | endDocument() 适配器实现方法；不调用。
void | endElement(String qName) 适配器实现方法；不调用。
ContentHandler | getContentHandler() 返回当前内容处理程序。
DTDHandler | getDTDHandler() 返回当前 DTD 处理程序。
EntityResolver | getEntityResolver() 返回当前实体解析器。
ErrorHandler | getErrorHandler() 返回当前错误处理程序。
boolean | getFeature(String name) 检查解析器功能标志。
Object | getProperty(String name) 获取解析器属性。
void | ignorableWhitespace(char[] ch, int start, int length) 适配器实现方法；不调用。
void | parse(InputSource input) 解析 XML 文档。
void | parse(String systemId) 解析 XML 文档。
void | processingInstruction(String target, String data) 适配器实现方法；不调用。
void | setContentHandler(ContentHandler handler) 设置内容处理程序。
void | setDocumentLocator(Locator locator) 适配器实现方法；不调用。
void | setDTDHandler(DTDHandler handler) 设置 DTD 处理程序。
void | setEntityResolver(EntityResolver resolver) 设置实体解析器。
void | setErrorHandler(ErrorHandler handler) 设置错误处理程序。
void | setFeature(String name, boolean value) 为解析器设置功能标志。
void | setProperty(String name, Object value) 设置解析器属性。
void | startDocument() 适配器实现方法；不调用。
void | startElement(String qName, AttributeList qAtts) 适配器实现方法；不调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ParserAdapter

public ParserAdapter()
              throws SAXException
构造一个新解析器适配器。

使用 "org.xml.sax.parser" 属性查找嵌入的 SAX1 驱动程序。

抛出：
SAXException - 如果不能实例化嵌入的驱动程序，或者未指定 org.xml.sax.parser 属性。

ParserAdapter

public ParserAdapter(Parser parser)
构造一个新的解析器适配器。

注意，一旦创建适配器，将不能更改嵌入的解析器；要嵌入不同的解析器，应分配一个新的 ParserAdapter。

参数：
parser - 要嵌入的 SAX1 解析器。
抛出：
NullPointerException - 如果解析器参数为 null。
方法详细信息

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
为解析器设置功能标志。

能识别的功能仅为名称空间和名称前缀。

指定者：
接口 XMLReader 中的 setFeature
参数：
name - 功能名称，作为一个完整的 URI。
value - 请求的功能值。
抛出：
SAXNotRecognizedException - 如果无法分配或检索该功能。
SAXNotSupportedException - 如果不能把该值分配给功能。
另请参见：
XMLReader.setFeature(java.lang.String, boolean)

getFeature

public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
检查解析器功能标志。

能识别的功能仅为名称空间和名称前缀。

指定者：
接口 XMLReader 中的 getFeature
参数：
name - 功能名称，作为一个完整的 URI。
返回：
当前功能值。
抛出：
SAXNotRecognizedException - 如果无法分配或检索功能值。
SAXNotSupportedException - 如果该功能当前不可读。
另请参见：
XMLReader.setFeature(java.lang.String, boolean)

setProperty

public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
设置解析器属性。

当前未识别任何属性。

指定者：
接口 XMLReader 中的 setProperty
参数：
name - 属性名。
value - 属性值。
抛出：
SAXNotRecognizedException - 如果无法分配或检索属性值。
SAXNotSupportedException - 如果不能把该值分配给属性。
另请参见：
XMLReader.setProperty(java.lang.String, java.lang.Object)

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
获取解析器属性。

当前未识别任何属性。

指定者：
接口 XMLReader 中的 getProperty
参数：
name - 属性名。
返回：
属性值。
抛出：
SAXNotRecognizedException - 如果无法分配或检索属性值。
SAXNotSupportedException - 如果属性值当前不可读。
另请参见：
XMLReader.getProperty(java.lang.String)

setEntityResolver

public void setEntityResolver(EntityResolver resolver)
设置实体解析器。

指定者：
接口 XMLReader 中的 setEntityResolver
参数：
resolver - 新实体解析器。
另请参见：
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

getEntityResolver

public EntityResolver getEntityResolver()
返回当前实体解析器。

指定者：
接口 XMLReader 中的 getEntityResolver
返回：
当前实体解析器，如果未提供，则返回 null。
另请参见：
XMLReader.getEntityResolver()

setDTDHandler

public void setDTDHandler(DTDHandler handler)
设置 DTD 处理程序。

指定者：
接口 XMLReader 中的 setDTDHandler
参数：
handler - the new DTD handler
另请参见：
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

getDTDHandler

public DTDHandler getDTDHandler()
返回当前 DTD 处理程序。

指定者：
接口 XMLReader 中的 getDTDHandler
返回：
当前 DTD 处理程序，如果未提供，则返回 null
另请参见：
XMLReader.getEntityResolver()

setContentHandler

public void setContentHandler(ContentHandler handler)
设置内容处理程序。

指定者：
接口 XMLReader 中的 setContentHandler
参数：
handler - the new content handler
另请参见：
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

getContentHandler

public ContentHandler getContentHandler()
返回当前内容处理程序。

指定者：
接口 XMLReader 中的 getContentHandler
返回：
当前内容处理程序，如果未提供，则返回 null。
另请参见：
XMLReader.getEntityResolver()

setErrorHandler

public void setErrorHandler(ErrorHandler handler)
设置错误处理程序。

指定者：
接口 XMLReader 中的 setErrorHandler
参数：
handler - 新的错误处理程序。
另请参见：
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

getErrorHandler

public ErrorHandler getErrorHandler()
返回当前错误处理程序。

指定者：
接口 XMLReader 中的 getErrorHandler
返回：
当前错误处理程序，如果未提供，则返回 null。
另请参见：
XMLReader.getEntityResolver()

parse

public void parse(String systemId)
           throws IOException,
                  SAXException
解析 XML 文档。

指定者：
接口 XMLReader 中的 parse
参数：
systemId - 文档的绝对 URL。
抛出：
IOException - 如果在读取文档的原始内容时存在问题。
SAXException - 如果在处理文档时存在问题。
另请参见：
parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

parse

public void parse(InputSource input)
           throws IOException,
                  SAXException
解析 XML 文档。

指定者：
接口 XMLReader 中的 parse
参数：
input - 文档的输入源。
抛出：
IOException - 如果在读取文档的原始内容时存在问题。
SAXException - 如果在处理文档时存在问题。
另请参见：
parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

setDocumentLocator

public void setDocumentLocator(Locator locator)
适配器实现方法；不调用。适配 SAX1 文档定位器事件。

指定者：
接口 DocumentHandler 中的 setDocumentLocator
参数：
locator - 文档定位器。
另请参见：
ContentHandler.setDocumentLocator(org.xml.sax.Locator)

startDocument

public void startDocument()
                   throws SAXException
适配器实现方法；不调用。适配 SAX1 开始文档事件。

指定者：
接口 DocumentHandler 中的 startDocument
抛出：
SAXException - 客户端可能引发处理异常。
另请参见：
DocumentHandler.startDocument()

endDocument

public void endDocument()
                 throws SAXException
适配器实现方法；不调用。适配 SAX1 结束文档事件。

指定者：
接口 DocumentHandler 中的 endDocument
抛出：
SAXException - 客户端可能引发处理异常。
另请参见：
DocumentHandler.endDocument()

startElement

public void startElement(String qName,
                         AttributeList qAtts)
                  throws SAXException
适配器实现方法；不调用。适配 SAX1 startElement 事件。

如果必要，则执行 Namespace 处理。

指定者：
接口 DocumentHandler 中的 startElement
参数：
qName - 限定的（前缀）名称。
qAtts - XML 属性列表（带 qnames）。
抛出：
SAXException - 客户端可能引发处理异常。
另请参见：
DocumentHandler.endElement(java.lang.String), AttributeList

endElement

public void endElement(String qName)
                throws SAXException
适配器实现方法；不调用。适配 SAX1 结束元素事件。

指定者：
接口 DocumentHandler 中的 endElement
参数：
qName - 限定的（前缀）名称。
抛出：
SAXException - 客户端可能引发处理异常。
另请参见：
DocumentHandler.endElement(java.lang.String)

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
适配器实现方法；不调用。适配 SAX1 字符事件。

指定者：
接口 DocumentHandler 中的 characters
参数：
ch - 一个字符数组。
start - 数组中的开始位置。
length - 要使用的字符数。
抛出：
SAXException - 客户端可能引发处理异常。
另请参见：
DocumentHandler.characters(char[], int, int)

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
适配器实现方法；不调用。适配 SAX1 可忽略空白事件。

指定者：
接口 DocumentHandler 中的 ignorableWhitespace
参数：
ch - 字符数组。
start - 数组中的开始位置。
length - 要使用的字符数。
抛出：
SAXException - 客户端可能引发处理异常。
另请参见：
DocumentHandler.ignorableWhitespace(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
适配器实现方法；不调用。适配 SAX1 处理指令事件。

指定者：
接口 DocumentHandler 中的 processingInstruction
参数：
target - 处理指令目标。
data - 处理指令的剩余部分
抛出：
SAXException - 客户端可能引发处理异常。
另请参见：
DocumentHandler.processingInstruction(java.lang.String, java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParserFactory (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 ParserFactory

java.lang.Object
    继承者  org.xml.sax.helpers.ParserFactory
已过时。 此类与不推荐使用的 Parser 接口一起使用。

public class ParserFactory
extends Object

用于动态加载 SAX 解析器的特定于 Java 的类。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

注：此类用于与现在已不推荐使用的 SAX1 Parser 类一起使用。SAX2 应用程序应改为使用 XMLReaderFactory。

ParserFactory 不是 SAX 的独立于平台定义的一部分；它是专门为 Java XML 应用程序编写者设计的附加便利类。SAX 应用程序可以使用此类中的静态方法基于 "org.xml.sax.parser" 系统属性的值或包含类名的字符串在运行时动态分配 SAX 解析器。

注意，应用程序仍然需要实现 SAX1 的 XML 解析器。

从以下版本开始：
SAX 1.0

方法摘要
static Parser | makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

makeParser

public static Parser makeParser()
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                NullPointerException,
                                ClassCastException
已过时。
使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。

命名类必须存在，并且必须实现 Parser 接口。

抛出：
NullPointerException - 不存在 "org.xml.sax.parser" 系统属性的值。
ClassNotFoundException - 未找到 SAX 解析器类（检查您的 CLASSPATH）。
IllegalAccessException - 已找到 SAX 解析器类，但您没有权限加载它。
InstantiationException - 已找到 SAX 解析器类，但不能实例化它。
ClassCastException - 已找到并实例化 SAX 解析器类，但没有实现 org.xml.sax.Parser。
另请参见：
makeParser(java.lang.String), Parser

makeParser

public static Parser makeParser(String className)
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                ClassCastException
已过时。
使用提供的类名创建一个新的 SAX 解析器对象。

命名类必须存在，并且必须实现 Parser 接口。

参数：
className - 包含 SAX 解析器类名的字符串。
抛出：
ClassNotFoundException - 未找到 SAX 解析器类（检查您的 CLASSPATH）。
IllegalAccessException - 已找到 SAX 解析器类，但您没有权限加载它。
InstantiationException - 已找到 SAX 解析器类，但不能实例化它。
ClassCastException - 已找到并实例化 SAX 解析器类，但没有实现 org.xml.sax.Parser。
另请参见：
makeParser(), Parser
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLFilterImpl (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 XMLFilterImpl

java.lang.Object
    继承者  org.xml.sax.helpers.XMLFilterImpl
所有已实现的接口：
ContentHandler, DTDHandler, EntityResolver, ErrorHandler, XMLFilter, XMLReader
public class XMLFilterImpl
extends Object
implements XMLFilter, EntityResolver, DTDHandler, ContentHandler, ErrorHandler

派生 XML 过滤器的基类。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。。

此类设计为位于 XMLReader 和客户端应用程序的事件处理程序之间。默认情况下，除了将请求传递给阅读器和将事件传递给未修改的处理程序外，不执行其他操作。但是，子类可以重写特定方法在它们传递时修改事件流或配置请求。

从以下版本开始：
SAX 2.0
另请参见：
XMLFilter, XMLReader, EntityResolver, DTDHandler, ContentHandler, ErrorHandler

构造方法摘要
XMLFilterImpl()
构造一个不带父过滤器的空 XML 过滤器。
XMLFilterImpl(XMLReader parent)
构造一个带有特定父过滤器的 XML 过滤器。
方法摘要
void | characters(char[] ch, int start, int length) 过滤一个字符数据事件。
void | endDocument() 过滤一个结束文档事件。
void | endElement(String uri, String localName, String qName) 过滤一个结束元素事件。
void | endPrefixMapping(String prefix) 过滤一个结束名称空间前缀映射事件。
void | error(SAXParseException e) 过滤一个错误事件。
void | fatalError(SAXParseException e) 过滤一个严重的错误事件。
ContentHandler | getContentHandler() 获取内容事件处理程序。
DTDHandler | getDTDHandler() 获取当前 DTD 事件处理程序。
EntityResolver | getEntityResolver() 获取当前实体解析器。
ErrorHandler | getErrorHandler() 获取当前错误事件处理程序。
boolean | getFeature(String name) 查找功能值。
XMLReader | getParent() 获取父读取器。
Object | getProperty(String name) 查找属性值。
void | ignorableWhitespace(char[] ch, int start, int length) 过滤一个可忽略空格的事件。
void | notationDecl(String name, String publicId, String systemId) 过滤一个注释声明事件。
void | parse(InputSource input) 解析一个文档。
void | parse(String systemId) 解析一个文档。
void | processingInstruction(String target, String data) 过滤一个处理指令事件。
InputSource | resolveEntity(String publicId, String systemId) 过滤一个外部实体解析。
void | setContentHandler(ContentHandler handler) 设置内容事件处理程序。
void | setDocumentLocator(Locator locator) 过滤一个新的文档定位器事件。
void | setDTDHandler(DTDHandler handler) 设置 DTD 事件处理程序。
void | setEntityResolver(EntityResolver resolver) 设置实体解析器。
void | setErrorHandler(ErrorHandler handler) 设置错误事件处理程序。
void | setFeature(String name, boolean value) 设置功能的值。
void | setParent(XMLReader parent) 设置父读取器。
void | setProperty(String name, Object value) 设置属性值。
void | skippedEntity(String name) 过滤一个跳过的实体事件。
void | startDocument() 过滤一个开始文档事件。
void | startElement(String uri, String localName, String qName, Attributes atts) 过滤一个开始元素事件。
void | startPrefixMapping(String prefix, String uri) 过滤一个开始名称空间前缀映射事件。
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 过滤一个未解析实体声明事件。
void | warning(SAXParseException e) 过滤一个警告事件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLFilterImpl

public XMLFilterImpl()
构造一个不带父过滤器的空 XML 过滤器。

此过滤器将没有父过滤器：在使用 setFeature 或 setProperty 开始解析或执行任何操作之前您必须分配一个父过滤器，除非将其用作纯事件使用者而非 XMLReader。

另请参见：
XMLReader.setFeature(java.lang.String, boolean),
XMLReader.setProperty(java.lang.String, java.lang.Object),
setParent(org.xml.sax.XMLReader)

XMLFilterImpl

public XMLFilterImpl(XMLReader parent)
构造一个带有特定父过滤器的 XML 过滤器。

另请参见：
setParent(org.xml.sax.XMLReader), getParent()
方法详细信息

setParent

public void setParent(XMLReader parent)
设置父读取器。

这是 XMLReader，此过滤器将从其中获取它的事件并向其传递配置请求。父过滤器本身还有可能是其他过滤器。

如果没有设置父读取器，则解析、设置或获得功能或属性的任何尝试都不会成功。

指定者：
接口 XMLFilter 中的 setParent
参数：
parent - 父 XML 读取器。
另请参见：
getParent()

getParent

public XMLReader getParent()
获取父读取器。

指定者：
接口 XMLFilter 中的 getParent
返回：
父 XML 读取器，如果未设置，则返回 null。
另请参见：
setParent(org.xml.sax.XMLReader)

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
设置功能的值。

如果父功能为 null，则始终会失败。

指定者：
接口 XMLReader 中的 setFeature
参数：
name - 功能名称。
value - 请求的功能值。
抛出：
SAXNotRecognizedException - 如果功能值不能从父功能分配或检索。
SAXNotSupportedException - 当父功能识别功名称，但不能设置请求的值时。
另请参见：
XMLReader.getFeature(java.lang.String)

getFeature

public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找功能值。

如果父功能为 null，则始终会失败。

指定者：
接口 XMLReader 中的 getFeature
参数：
name - 功能名称。
返回：
此功能的当前值。
抛出：
SAXNotRecognizedException - 如果功能值不能从父功能分配或检索。
SAXNotSupportedException - 当父功能识别功能名称，但此时不能确定其值时。
另请参见：
XMLReader.setFeature(java.lang.String, boolean)

setProperty

public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
设置属性值。

如果父属性为 null，则始终会失败。

指定者：
接口 XMLReader 中的 setProperty
参数：
name - 属性名。
value - 请求的属性值。
抛出：
SAXNotRecognizedException - 如果属性值不能从父属性分配或检索。
SAXNotSupportedException - 当父属性识别属性名称，但不能设置请求的值时。

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
查找属性值。

指定者：
接口 XMLReader 中的 getProperty
参数：
name - 属性名。
返回：
属性的当前值。
抛出：
SAXNotRecognizedException - 如果属性值不能从父属性分配或检索。
SAXNotSupportedException - 当父属性识别属性名称，但此时不能确定其值时。
另请参见：
XMLReader.setProperty(java.lang.String, java.lang.Object)

setEntityResolver

public void setEntityResolver(EntityResolver resolver)
设置实体解析器。

指定者：
接口 XMLReader 中的 setEntityResolver
参数：
resolver - 新实体解析器。
另请参见：
XMLReader.getEntityResolver()

getEntityResolver

public EntityResolver getEntityResolver()
获取当前实体解析器。

指定者：
接口 XMLReader 中的 getEntityResolver
返回：
当前实体解析器，如果未设置，则返回 null。
另请参见：
XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

setDTDHandler

public void setDTDHandler(DTDHandler handler)
设置 DTD 事件处理程序。

指定者：
接口 XMLReader 中的 setDTDHandler
参数：
handler - 新的 DTD 处理程序。
另请参见：
XMLReader.getDTDHandler()

getDTDHandler

public DTDHandler getDTDHandler()
获取当前 DTD 事件处理程序。

指定者：
接口 XMLReader 中的 getDTDHandler
返回：
当前 DTD 处理程序，如果未设置，则返回 null。
另请参见：
XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

setContentHandler

public void setContentHandler(ContentHandler handler)
设置内容事件处理程序。

指定者：
接口 XMLReader 中的 setContentHandler
参数：
handler - 新的内容处理程序
另请参见：
XMLReader.getContentHandler()

getContentHandler

public ContentHandler getContentHandler()
获取内容事件处理程序。

指定者：
接口 XMLReader 中的 getContentHandler
返回：
当前内容处理程序，如果未设置，则返回 null。
另请参见：
XMLReader.setContentHandler(org.xml.sax.ContentHandler)

setErrorHandler

public void setErrorHandler(ErrorHandler handler)
设置错误事件处理程序。

指定者：
接口 XMLReader 中的 setErrorHandler
参数：
handler - 新的错误处理程序
另请参见：
XMLReader.getErrorHandler()

getErrorHandler

public ErrorHandler getErrorHandler()
获取当前错误事件处理程序。

指定者：
接口 XMLReader 中的 getErrorHandler
返回：
当前错误处理程序，如果未设置，则返回 null。
另请参见：
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

parse

public void parse(InputSource input)
           throws SAXException,
                  IOException
解析一个文档。

指定者：
接口 XMLReader 中的 parse
参数：
input - 文档实体的输入源。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 来自解析器的 IO 异常，可能来自应用程序提供的字节流或字符流。
另请参见：
InputSource,
XMLReader.parse(java.lang.String),
XMLReader.setEntityResolver(org.xml.sax.EntityResolver),
XMLReader.setDTDHandler(org.xml.sax.DTDHandler),
XMLReader.setContentHandler(org.xml.sax.ContentHandler),
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

parse

public void parse(String systemId)
           throws SAXException,
                  IOException
解析一个文档。

指定者：
接口 XMLReader 中的 parse
参数：
systemId - 作为完全限定 URI 的系统标识符。
抛出：
SAXException - 任何 SAX 异常，可能包装另外的异常。
IOException - 来自解析器的 IO 异常，可能来自应用程序提供的字节流或字符流。
另请参见：
XMLReader.parse(org.xml.sax.InputSource)

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException,
                                 IOException
过滤一个外部实体解析。

指定者：
接口 EntityResolver 中的 resolveEntity
参数：
publicId - 实体的公开标识符，或者为 null。
systemId - 实体的系统标识符。
返回：
新的 InputSource，默认返回 null。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
IOException - 客户端可以在获取新 InputSource 的同时抛出一个与 I/O 相关的异常。
另请参见：
InputSource

notationDecl

public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
过滤一个注释声明事件。

指定者：
接口 DTDHandler 中的 notationDecl
参数：
name - 注释名称。
publicId - 注释的公开标识符，或者为 null。
systemId - 注释的系统标识符，或者 null。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

unparsedEntityDecl

public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
过滤一个未解析实体声明事件。

指定者：
接口 DTDHandler 中的 unparsedEntityDecl
参数：
name - 实体名称。
publicId - 实体的公开标识符，或者为 null。
systemId - 实体的系统标识符，或者 null。
notationName - 相关联的注释的名称。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes

setDocumentLocator

public void setDocumentLocator(Locator locator)
过滤一个新的文档定位器事件。

指定者：
接口 ContentHandler 中的 setDocumentLocator
参数：
locator - 文档定位器。
另请参见：
Locator

startDocument

public void startDocument()
                   throws SAXException
过滤一个开始文档事件。

指定者：
接口 ContentHandler 中的 startDocument
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
ContentHandler.endDocument()

endDocument

public void endDocument()
                 throws SAXException
过滤一个结束文档事件。

指定者：
接口 ContentHandler 中的 endDocument
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
ContentHandler.startDocument()

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
过滤一个开始名称空间前缀映射事件。

指定者：
接口 ContentHandler 中的 startPrefixMapping
参数：
prefix - 名称空间前缀。
uri - 名称空间 URI。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
ContentHandler.endPrefixMapping(java.lang.String), ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

endPrefixMapping

public void endPrefixMapping(String prefix)
                      throws SAXException
过滤一个结束名称空间前缀映射事件。

指定者：
接口 ContentHandler 中的 endPrefixMapping
参数：
prefix - 名称空间前缀。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
ContentHandler.startPrefixMapping(java.lang.String, java.lang.String), ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
过滤一个开始元素事件。

指定者：
接口 ContentHandler 中的 startElement
参数：
uri - 元素的名称空间 URI，或者空字符串。
localName - 元素的本地名称，或者空字符串。
qName - 元素的限定（带前缀的）名称，或者空字符串。
atts - 元素的属性。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
过滤一个结束元素事件。

指定者：
接口 ContentHandler 中的 endElement
参数：
uri - 元素的名称空间 URI，或者空字符串。
localName - 元素的本地名称，或者空字符串。
qName - 元素的限定（带前缀的）名称，或者空字符串。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
过滤一个字符数据事件。

指定者：
接口 ContentHandler 中的 characters
参数：
ch - 字符数组。
start - 数组中的开始位置。
length - 从数组中使用的字符数。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
ContentHandler.ignorableWhitespace(char[], int, int), Locator

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
过滤一个可忽略空格的事件。

指定者：
接口 ContentHandler 中的 ignorableWhitespace
参数：
ch - 字符数组。
start - 数组中的开始位置。
length - 从数组中使用的字符数。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
ContentHandler.characters(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
过滤一个处理指令事件。

指定者：
接口 ContentHandler 中的 processingInstruction
参数：
target - 处理指令目标。
data - 目标后跟随的文本。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。

skippedEntity

public void skippedEntity(String name)
                   throws SAXException
过滤一个跳过的实体事件。

指定者：
接口 ContentHandler 中的 skippedEntity
参数：
name - 跳过的实体的名称。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。

warning

public void warning(SAXParseException e)
             throws SAXException
过滤一个警告事件。

指定者：
接口 ErrorHandler 中的 warning
参数：
e - 作为异常的警告。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
SAXParseException

error

public void error(SAXParseException e)
           throws SAXException
过滤一个错误事件。

指定者：
接口 ErrorHandler 中的 error
参数：
e - 作为异常的错误。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
SAXParseException

fatalError

public void fatalError(SAXParseException e)
                throws SAXException
过滤一个严重的错误事件。

指定者：
接口 ErrorHandler 中的 fatalError
参数：
e - 作为异常的错误。
抛出：
SAXException - 客户端可以在处理过程中抛出一个异常。
另请参见：
SAXParseException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLReaderAdapter (Java Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 XMLReaderAdapter

java.lang.Object
    继承者  org.xml.sax.helpers.XMLReaderAdapter
所有已实现的接口：
ContentHandler, Parser
public class XMLReaderAdapter
extends Object
implements Parser, ContentHandler

将 SAX2 XMLReader 适配为 SAX1 解析器。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

此类包装 SAX2 XMLReader 并且使之充当 SAX1 Parser。XMLReader 必须支持 http://xml.org/sax/features/namespace-prefixes 属性的 true 值，否则解析将会失败，并抛出 SAXException；如果 XMLReader 支持 http://xml.org/sax/features/namespaces 属性的 false 值，这也将会被用于提高效率。

从以下版本开始：
SAX 2.0
另请参见：
Parser, XMLReader

构造方法摘要
XMLReaderAdapter()
创建一个新的适配器。
XMLReaderAdapter(XMLReader xmlReader)
创建一个新的适配器。
方法摘要
void | characters(char[] ch, int start, int length) 适配 SAX2 字符事件。
void | endDocument() 结束文档事件。
void | endElement(String uri, String localName, String qName) 适配 SAX2 结束元素事件。
void | endPrefixMapping(String prefix) 适配 SAX2 结束前缀映射事件。
void | ignorableWhitespace(char[] ch, int start, int length) 适配 SAX2 忽略空白事件。
void | parse(InputSource input) 解析文档。
void | parse(String systemId) 解析文档。
void | processingInstruction(String target, String data) 适配 SAX2 处理指令事件。
void | setDocumentHandler(DocumentHandler handler) 注册 SAX1 文档事件处理程序。
void | setDocumentLocator(Locator locator) 设置文档定位器。
void | setDTDHandler(DTDHandler handler) 注册 DTD 事件处理程序。
void | setEntityResolver(EntityResolver resolver) 注册实体解析器。
void | setErrorHandler(ErrorHandler handler) 注册错误事件处理程序。
void | setLocale(Locale locale) 设置错误报告的语言环境。
void | skippedEntity(String name) 适配 SAX2 跳过的实体事件。
void | startDocument() 开始文档事件。
void | startElement(String uri, String localName, String qName, Attributes atts) 适配 SAX2 开始元素事件。
void | startPrefixMapping(String prefix, String uri) 适配 SAX2 开始前缀映射事件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLReaderAdapter

public XMLReaderAdapter()
                 throws SAXException
创建一个新的适配器。

使用 "org.xml.sax.driver" 属性来查找要嵌入的 SAX2 驱动程序。

抛出：
SAXException - 如果无法实例化嵌入的驱动程序，或者未指定 org.xml.sax.driver 属性。

XMLReaderAdapter

public XMLReaderAdapter(XMLReader xmlReader)
创建一个新的适配器。

创建一个新的适配器，包装 SAX2 XMLReader。适配器将使 XMLReader 的作用与 SAX1 解析器类似。

参数：
xmlReader - 要包装的 SAX2 XMLReader。
抛出：
NullPointerException - 如果参数为 null。
方法详细信息

setLocale

public void setLocale(Locale locale)
               throws SAXException
设置错误报告的语言环境。

SAX2 中不支持这么做，并且总是抛出异常。

指定者：
接口 Parser 中的 setLocale
参数：
locale - 错误报告的语言环境。
抛出：
SAXException - 如果不重写则抛出该异常。
另请参见：
Parser.setLocale(java.util.Locale)

setEntityResolver

public void setEntityResolver(EntityResolver resolver)
注册实体解析器。

指定者：
接口 Parser 中的 setEntityResolver
参数：
resolver - 新的解析器。
另请参见：
Parser.setEntityResolver(org.xml.sax.EntityResolver)

setDTDHandler

public void setDTDHandler(DTDHandler handler)
注册 DTD 事件处理程序。

指定者：
接口 Parser 中的 setDTDHandler
参数：
handler - 新的 DTD 事件处理程序。
另请参见：
Parser.setDTDHandler(org.xml.sax.DTDHandler)

setDocumentHandler

public void setDocumentHandler(DocumentHandler handler)
注册 SAX1 文档事件处理程序。

注意，SAX1 文档处理程序不支持名称空间。

指定者：
接口 Parser 中的 setDocumentHandler
参数：
handler - 新的 SAX1 文档事件处理程序。
另请参见：
Parser.setDocumentHandler(org.xml.sax.DocumentHandler)

setErrorHandler

public void setErrorHandler(ErrorHandler handler)
注册错误事件处理程序。

指定者：
接口 Parser 中的 setErrorHandler
参数：
handler - 新的错误事件处理程序。
另请参见：
Parser.setErrorHandler(org.xml.sax.ErrorHandler)

parse

public void parse(String systemId)
           throws IOException,
                  SAXException
解析文档。

如果嵌入的 XMLReader 不支持 http://xml.org/sax/features/namespace-prefixes 属性，此方法将抛出异常。

指定者：
接口 Parser 中的 parse
参数：
systemId - 文档的绝对 URL。
抛出：
IOException - 如果在读取文档的原始内容时存在问题。
SAXException - 如果在处理文档时存在问题。
另请参见：
parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

parse

public void parse(InputSource input)
           throws IOException,
                  SAXException
解析文档。

如果嵌入的 XMLReader 不支持 http://xml.org/sax/features/namespace-prefixes 属性，此方法将抛出异常。

指定者：
接口 Parser 中的 parse
参数：
input - 文档的输入源。
抛出：
IOException - 如果在读取文档的原始内容时存在问题。
SAXException - 如果在处理文档时存在问题。
另请参见：
parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

setDocumentLocator

public void setDocumentLocator(Locator locator)
设置文档定位器。

指定者：
接口 ContentHandler 中的 setDocumentLocator
参数：
locator - 文档定位器。
另请参见：
ContentHandler.setDocumentLocator(org.xml.sax.Locator)

startDocument

public void startDocument()
                   throws SAXException
开始文档事件。

指定者：
接口 ContentHandler 中的 startDocument
抛出：
SAXException - 客户端可能引发一个处理异常。
另请参见：
ContentHandler.startDocument()

endDocument

public void endDocument()
                 throws SAXException
结束文档事件。

指定者：
接口 ContentHandler 中的 endDocument
抛出：
SAXException - 客户端可能引发一个处理异常。
另请参见：
ContentHandler.endDocument()

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
适配 SAX2 开始前缀映射事件。

指定者：
接口 ContentHandler 中的 startPrefixMapping
参数：
prefix - 映射的前缀。
uri - 要映射到的名称空间 URI。
另请参见：
ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

endPrefixMapping

public void endPrefixMapping(String prefix)
适配 SAX2 结束前缀映射事件。

指定者：
接口 ContentHandler 中的 endPrefixMapping
参数：
prefix - 映射的前缀。
另请参见：
ContentHandler.endPrefixMapping(java.lang.String)

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
适配 SAX2 开始元素事件。

指定者：
接口 ContentHandler 中的 startElement
参数：
uri - 名称空间 URI。
localName - 名称空间本地名称。
qName - 限定的（前缀）名称。
atts - SAX2 属性。
抛出：
SAXException - 客户端可能引发一个处理异常。
另请参见：
ContentHandler.endDocument()

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
适配 SAX2 结束元素事件。

指定者：
接口 ContentHandler 中的 endElement
参数：
uri - 名称空间 URI。
localName - 名称空间本地名称。
qName - 限定的（前缀）名称。
抛出：
SAXException - 客户端可能引发一个处理异常。
另请参见：
ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
适配 SAX2 字符事件。

指定者：
接口 ContentHandler 中的 characters
参数：
ch - 字符数组。
start - 数组中的开始位置。
length - 要使用的字符数。
抛出：
SAXException - 客户端可能引发一个处理异常。
另请参见：
ContentHandler.characters(char[], int, int)

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
适配 SAX2 忽略空白事件。

指定者：
接口 ContentHandler 中的 ignorableWhitespace
参数：
ch - 字符数组。
start - 数组中的开始位置。
length - 要使用的字符数。
抛出：
SAXException - 客户端可能引发一个处理异常。
另请参见：
ContentHandler.ignorableWhitespace(char[], int, int)

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
适配 SAX2 处理指令事件。

指定者：
接口 ContentHandler 中的 processingInstruction
参数：
target - 处理指令目标。
data - 处理指令的剩余部分
抛出：
SAXException - 客户端可能引发处理异常。
另请参见：
ContentHandler.processingInstruction(java.lang.String, java.lang.String)

skippedEntity

public void skippedEntity(String name)
                   throws SAXException
适配 SAX2 跳过的实体事件。

指定者：
接口 ContentHandler 中的 skippedEntity
参数：
name - 跳过的实体的名称。
抛出：
SAXException - 可由子类抛出。
另请参见：
ContentHandler.skippedEntity(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLReaderFactory (Java Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

org.xml.sax.helpers
类 XMLReaderFactory

java.lang.Object
    继承者  org.xml.sax.helpers.XMLReaderFactory

public final class XMLReaderFactory
extends Object

创建 XML 阅读器的工厂。

此模块（包括源代码和文档）位于公共域中，对该模块不提供担保。有关更多信息，请参阅http://www.saxproject.org。

此类包含用于从显式类名称或基于运行时默认值创建 XML 阅读器的静态方法：

 try {
   XMLReader myReader = XMLReaderFactory.createXMLReader();
 } catch (SAXException e) {
   System.err.println(e.getMessage());
 }

注意，分发与解析程序绑定在一起：应该修改无参数 createXMLReader 的实现，来处理外部配置机制未设置的情况。当位于类路径时，该方法应该尽力返回解析器，甚至没有一个将其类名绑定到 org.xml.sax.driver，使这些配置机制能够看到它。

从以下版本开始：
SAX 2.0

方法摘要
static XMLReader | createXMLReader() 尝试从系统默认值创建一个 XMLReader。
static XMLReader | createXMLReader(String className) 尝试从类名称创建一个 XML 阅读器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

createXMLReader

public static XMLReader createXMLReader()
                                 throws SAXException
尝试从系统默认值创建一个 XMLReader。在可以支持它的环境下，XMLReader 类的名称通过顺序尝试这些选项中的每一个来确定，并且使用第一个成功的：

  • 如果系统属性 org.xml.sax.driver 有一个值，该值将被用做 XMLReader 类名称。
  • JAR "Services API" 被用于在 META-INF/services/org.xml.sax.driver 文件中查找类名称，该文件在运行时可用的 jarfiles 中。
  • 强烈建议使用 SAX 解析器分发提供默认的 XMLReader 类名称，该类名称只在以前的选项（在此列表上）不成功时才生效。
  • 最后，如果 ParserFactory.makeParser() 可以返回系统默认 SAX1 解析器，该解析器将包装在 ParserAdapter 中。(这是一个用于 SAX1 环境的迁移帮助，其中 org.xml.sax.parser 系统属性经常是可用的。)

在诸如小型嵌套系统的环境中，这样的环境不能支持灵活性，使用确定默认值的其他机制。

注意，许多 Java 环境允许系统属性在命令行初始化。这意味着，在多数情况下为该属性设置一个较好的值可确保对此方法的调用能够成功，除了安全策略干扰时。具有低健壮性的此方法的实现 能够使应用程序向旧的 SAX 环境的可移值性最大化。

返回：
新的 XMLReader。
抛出：
SAXException - 如果不能识别或实例化默认 XMLReader 类。
另请参见：
createXMLReader(java.lang.String)

createXMLReader

public static XMLReader createXMLReader(String className)
                                 throws SAXException
尝试从类名称创建一个 XML 阅读器。

给定一个类名称，此方法尝试加载该类或将其实例化为 XML 阅读器。

注意，此方法在以下环境中不可用：即不允许调用者（也可能是 applet）动态加载类。

返回：
新的 XML 阅读器。
抛出：
SAXException - 如果此类不能被加载、实例化、或强制转化成 XMLReader。
另请参见：
createXMLReader()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


org.xml.sax.helpers (Java Platform SE 6)

 org.xml.sax.helpers
类
AttributeListImpl
AttributesImpl
DefaultHandler
LocatorImpl
NamespaceSupport
ParserAdapter
ParserFactory
XMLFilterImpl
XMLReaderAdapter
XMLReaderFactory


org.xml.sax.helpers (Java Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 org.xml.sax.helpers

此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

请参见：
描述

类摘要
AttributeListImpl | 已过时。 此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。
AttributesImpl | Attributes 接口的默认实现。
DefaultHandler | SAX2 事件处理程序的默认基类。
LocatorImpl | 提供 Locator 的可选的有用实现。
NamespaceSupport | 封装名称空间逻辑，以便由使用 SAX 的应用程序使用，或由 SAX 驱动程序内部使用。
ParserAdapter | 将 SAX1 Parser 适配为 SAX2 XMLReader。
ParserFactory | 已过时。 此类与不推荐使用的 Parser 接口一起使用。
XMLFilterImpl | 派生 XML 过滤器的基类。
XMLReaderAdapter | 将 SAX2 XMLReader 适配为 SAX1 解析器。
XMLReaderFactory | 创建 XML 阅读器的工厂。

软件包 org.xml.sax.helpers 的描述

此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

有关 SAX 的更多信息，请参阅 http://www.saxproject.org。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


org.xml.sax.helpers 类分层结构 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.xml.sax.helpers 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • org.xml.sax.helpers.AttributeListImpl (implements org.xml.sax.AttributeList)
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
    • org.xml.sax.helpers.NamespaceSupport
    • org.xml.sax.helpers.ParserAdapter (implements org.xml.sax.DocumentHandler, org.xml.sax.XMLReader)
    • org.xml.sax.helpers.ParserFactory
    • org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
    • org.xml.sax.helpers.XMLReaderAdapter (implements org.xml.sax.ContentHandler, org.xml.sax.Parser)
    • org.xml.sax.helpers.XMLReaderFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


软件包 org.xml.sax.helpers 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

软件包 org.xml.sax.helpers
的使用

使用 org.xml.sax.helpers 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

javax.xml.parsers 使用的 org.xml.sax.helpers 中的类
DefaultHandler
SAX2 事件处理程序的默认基类。

org.xml.sax.ext 使用的 org.xml.sax.helpers 中的类
AttributesImpl
Attributes 接口的默认实现。
DefaultHandler
SAX2 事件处理程序的默认基类。
LocatorImpl
提供 Locator 的可选的有用实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.AttributeListImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.AttributeListImpl
的使用

没有 org.xml.sax.helpers.AttributeListImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.AttributesImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.AttributesImpl
的使用

使用 AttributesImpl 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 AttributesImpl 的使用

org.xml.sax.ext 中 AttributesImpl 的子类
 class Attributes2Impl
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.DefaultHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.DefaultHandler
的使用

使用 DefaultHandler 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

javax.xml.parsers 中 DefaultHandler 的使用

参数类型为 DefaultHandler 的 javax.xml.parsers 中的方法
void | SAXParser.parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | SAXParser.parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(String uri, DefaultHandler dh) 使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

org.xml.sax.ext 中 DefaultHandler 的使用

org.xml.sax.ext 中 DefaultHandler 的子类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.LocatorImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.LocatorImpl
的使用

使用 LocatorImpl 的软件包
org.xml.sax.ext 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.ext 中 LocatorImpl 的使用

org.xml.sax.ext 中 LocatorImpl 的子类
 class Locator2Impl
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.NamespaceSupport 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.NamespaceSupport
的使用

没有 org.xml.sax.helpers.NamespaceSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.ParserAdapter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.ParserAdapter
的使用

没有 org.xml.sax.helpers.ParserAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.ParserFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.ParserFactory
的使用

没有 org.xml.sax.helpers.ParserFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.XMLFilterImpl 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.XMLFilterImpl
的使用

没有 org.xml.sax.helpers.XMLFilterImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.XMLReaderAdapter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.XMLReaderAdapter
的使用

没有 org.xml.sax.helpers.XMLReaderAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.helpers.XMLReaderFactory 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.helpers.XMLReaderFactory
的使用

没有 org.xml.sax.helpers.XMLReaderFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.Attributes 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.Attributes
的使用

使用 Attributes 的软件包
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

org.xml.sax 中 Attributes 的使用

参数类型为 Attributes 的 org.xml.sax 中的方法
 void ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
接收元素开始的通知。

org.xml.sax.ext 中 Attributes 的使用

org.xml.sax.ext 中 Attributes 的子接口
 interface Attributes2
SAX2 扩展，用于扩充通过 Attributes 提供的每个属性信息。

实现 Attributes 的 org.xml.sax.ext 中的类
 class Attributes2Impl
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

参数类型为 Attributes 的 org.xml.sax.ext 中的方法
 void Attributes2Impl.setAttributes(Attributes atts)
复制整个属性对象。

参数类型为 Attributes 的 org.xml.sax.ext 中的构造方法
Attributes2Impl(Attributes atts)
复制现有属性或 Attributes2 对象。

org.xml.sax.helpers 中 Attributes 的使用

实现 Attributes 的 org.xml.sax.helpers 中的类
 class AttributesImpl
Attributes 接口的默认实现。

参数类型为 Attributes 的 org.xml.sax.helpers 中的方法
void | AttributesImpl.setAttributes(Attributes atts) 复制整个 Attributes 对象。
void | DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes) 接收元素开始的通知。
void | XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts) 过滤一个开始元素事件。
void | XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts) 适配 SAX2 开始元素事件。

参数类型为 Attributes 的 org.xml.sax.helpers 中的构造方法
AttributesImpl(Attributes atts)
复制现有 Attributes 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.ContentHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ContentHandler
的使用

使用 ContentHandler 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind 中 ContentHandler 的使用

javax.xml.bind 中 ContentHandler 的子接口
 interface UnmarshallerHandler
作为 SAX ContentHandler 实现的 Unmarshaller。

参数类型为 ContentHandler 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。

javax.xml.bind.helpers 中 ContentHandler 的使用

参数类型为 ContentHandler 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)

javax.xml.transform.sax 中 ContentHandler 的使用

javax.xml.transform.sax 中 ContentHandler 的子接口
interface | TemplatesHandler 可用于将 SAX 解析事件（解析转换指令）处理为 Templates 对象的 SAX ContentHandler。
interface | TransformerHandler 侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

返回 ContentHandler 的 javax.xml.transform.sax 中的方法
 ContentHandler SAXResult.getHandler()
获取作为 Result 的 ContentHandler。

参数类型为 ContentHandler 的 javax.xml.transform.sax 中的方法
 void SAXResult.setHandler(ContentHandler handler)
设置要作为 SAX2 ContentHandler 的目标。

参数类型为 ContentHandler 的 javax.xml.transform.sax 中的构造方法
SAXResult(ContentHandler handler)
创建以 SAX2 ContentHandler 为目标的 SAXResult。

javax.xml.validation 中 ContentHandler 的使用

实现 ContentHandler 的 javax.xml.validation 中的类
 class ValidatorHandler
处理 SAX 流的流验证器。

返回 ContentHandler 的 javax.xml.validation 中的方法
abstract  ContentHandler ValidatorHandler.getContentHandler()
获取接收扩充的验证结果的 ContentHandler。

参数类型为 ContentHandler 的 javax.xml.validation 中的方法
abstract  void ValidatorHandler.setContentHandler(ContentHandler receiver)
设置 ContentHandler，它接收扩充的验证结果。

org.xml.sax 中 ContentHandler 的使用

返回 ContentHandler 的 org.xml.sax 中的方法
 ContentHandler XMLReader.getContentHandler()
返回当前的内容处理程序。

参数类型为 ContentHandler 的 org.xml.sax 中的方法
 void XMLReader.setContentHandler(ContentHandler handler)
允许应用程序注册内容事件处理程序。

org.xml.sax.ext 中 ContentHandler 的使用

实现 ContentHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

org.xml.sax.helpers 中 ContentHandler 的使用

实现 ContentHandler 的 org.xml.sax.helpers 中的类
class | DefaultHandler SAX2 事件处理程序的默认基类。
class | XMLFilterImpl 派生 XML 过滤器的基类。
class | XMLReaderAdapter 将 SAX2 XMLReader 适配为 SAX1 解析器。

返回 ContentHandler 的 org.xml.sax.helpers 中的方法
ContentHandler | ParserAdapter.getContentHandler() 返回当前内容处理程序。
ContentHandler | XMLFilterImpl.getContentHandler() 获取内容事件处理程序。

参数类型为 ContentHandler 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.setContentHandler(ContentHandler handler) 设置内容处理程序。
void | XMLFilterImpl.setContentHandler(ContentHandler handler) 设置内容事件处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.DTDHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.DTDHandler
的使用

使用 DTDHandler 的软件包
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.transform.sax 中 DTDHandler 的使用

javax.xml.transform.sax 中 DTDHandler 的子接口
 interface TransformerHandler
侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。

org.xml.sax 中 DTDHandler 的使用

实现 DTDHandler 的 org.xml.sax 中的类
 class HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

返回 DTDHandler 的 org.xml.sax 中的方法
 DTDHandler XMLReader.getDTDHandler()
返回当前的 DTD 处理程序。

参数类型为 DTDHandler 的 org.xml.sax 中的方法
void | Parser.setDTDHandler(DTDHandler handler) 已过时。 允许应用程序注册 DTD 事件处理程序。
void | XMLReader.setDTDHandler(DTDHandler handler) 允许应用程序注册 DTD 事件处理程序。

org.xml.sax.ext 中 DTDHandler 的使用

实现 DTDHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

org.xml.sax.helpers 中 DTDHandler 的使用

实现 DTDHandler 的 org.xml.sax.helpers 中的类
class | DefaultHandler SAX2 事件处理程序的默认基类。
class | XMLFilterImpl 派生 XML 过滤器的基类。

返回 DTDHandler 的 org.xml.sax.helpers 中的方法
DTDHandler | ParserAdapter.getDTDHandler() 返回当前 DTD 处理程序。
DTDHandler | XMLFilterImpl.getDTDHandler() 获取当前 DTD 事件处理程序。

参数类型为 DTDHandler 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.setDTDHandler(DTDHandler handler) 设置 DTD 处理程序。
void | XMLFilterImpl.setDTDHandler(DTDHandler handler) 设置 DTD 事件处理程序。
void | XMLReaderAdapter.setDTDHandler(DTDHandler handler) 注册 DTD 事件处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.DocumentHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.DocumentHandler
的使用

使用 DocumentHandler 的软件包
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

org.xml.sax 中 DocumentHandler 的使用

实现 DocumentHandler 的 org.xml.sax 中的类
 class HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

参数类型为 DocumentHandler 的 org.xml.sax 中的方法
 void Parser.setDocumentHandler(DocumentHandler handler)
已过时。 允许应用程序注册文档事件处理程序。

org.xml.sax.helpers 中 DocumentHandler 的使用

实现 DocumentHandler 的 org.xml.sax.helpers 中的类
 class ParserAdapter
将 SAX1 Parser 适配为 SAX2 XMLReader。

参数类型为 DocumentHandler 的 org.xml.sax.helpers 中的方法
 void XMLReaderAdapter.setDocumentHandler(DocumentHandler handler)
注册 SAX1 文档事件处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.HandlerBase 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.HandlerBase
的使用

使用 HandlerBase 的软件包
javax.xml.parsers 提供允许处理 XML 文档的类。

javax.xml.parsers 中 HandlerBase 的使用

参数类型为 HandlerBase 的 javax.xml.parsers 中的方法
void | SAXParser.parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。
void | SAXParser.parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(String uri, HandlerBase hb) 使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.Parser 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.Parser
的使用

使用 Parser 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 Parser 的使用

返回 Parser 的 javax.xml.parsers 中的方法
abstract  Parser SAXParser.getParser()
返回由此类的实现封装的 SAX 解析器。

org.xml.sax.helpers 中 Parser 的使用

实现 Parser 的 org.xml.sax.helpers 中的类
 class XMLReaderAdapter
将 SAX2 XMLReader 适配为 SAX1 解析器。

返回 Parser 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

参数类型为 Parser 的 org.xml.sax.helpers 中的构造方法
ParserAdapter(Parser parser)
构造一个新的解析器适配器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.XMLFilter 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.XMLFilter
的使用

使用 XMLFilter 的软件包
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.transform.sax 中 XMLFilter 的使用

返回 XMLFilter 的 javax.xml.transform.sax 中的方法
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Source src) 创建使用给定 Source 作为转换指令的 XMLFilter。
abstract XMLFilter | SAXTransformerFactory.newXMLFilter(Templates templates) 基于 Templates 参数，创建 XMLFilter。

org.xml.sax.helpers 中 XMLFilter 的使用

实现 XMLFilter 的 org.xml.sax.helpers 中的类
 class XMLFilterImpl
派生 XML 过滤器的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.XMLReader 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.XMLReader
的使用

使用 XMLReader 的软件包
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind.helpers 中 XMLReader 的使用

返回 XMLReader 的 javax.xml.bind.helpers 中的方法
protected  XMLReader AbstractUnmarshallerImpl.getXMLReader()
获取配置好的 XMLReader。

参数类型为 XMLReader 的 javax.xml.bind.helpers 中的方法
protected abstract  Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
使用指定的 XMLReader 和 InputSource 解组对象。

javax.xml.parsers 中 XMLReader 的使用

返回 XMLReader 的 javax.xml.parsers 中的方法
abstract  XMLReader SAXParser.getXMLReader()
返回由此类的实现封装的 XMLReader。

javax.xml.transform.sax 中 XMLReader 的使用

返回 XMLReader 的 javax.xml.transform.sax 中的方法
 XMLReader SAXSource.getXMLReader()
获取要用于 Source 的 XMLReader。

参数类型为 XMLReader 的 javax.xml.transform.sax 中的方法
 void SAXSource.setXMLReader(XMLReader reader)
设置要用于 Source 的 XMLReader。

参数类型为 XMLReader 的 javax.xml.transform.sax 中的构造方法
SAXSource(XMLReader reader, InputSource inputSource)
使用 XMLReader 和 SAX InputSource 创建 SAXSource。

org.xml.sax 中 XMLReader 的使用

org.xml.sax 中 XMLReader 的子接口
 interface XMLFilter
用于 XML 过滤器的接口。

返回 XMLReader 的 org.xml.sax 中的方法
 XMLReader XMLFilter.getParent()
获取父阅读器。

参数类型为 XMLReader 的 org.xml.sax 中的方法
 void XMLFilter.setParent(XMLReader parent)
设置父阅读器。

org.xml.sax.helpers 中 XMLReader 的使用

实现 XMLReader 的 org.xml.sax.helpers 中的类
class | ParserAdapter 将 SAX1 Parser 适配为 SAX2 XMLReader。
class | XMLFilterImpl 派生 XML 过滤器的基类。

返回 XMLReader 的 org.xml.sax.helpers 中的方法
static XMLReader | XMLReaderFactory.createXMLReader() 尝试从系统默认值创建一个 XMLReader。
static XMLReader | XMLReaderFactory.createXMLReader(String className) 尝试从类名称创建一个 XML 阅读器。
XMLReader | XMLFilterImpl.getParent() 获取父读取器。

参数类型为 XMLReader 的 org.xml.sax.helpers 中的方法
 void XMLFilterImpl.setParent(XMLReader parent)
设置父读取器。

参数类型为 XMLReader 的 org.xml.sax.helpers 中的构造方法
XMLFilterImpl(XMLReader parent)
构造一个带有特定父过滤器的 XML 过滤器。
XMLReaderAdapter(XMLReader xmlReader)
创建一个新的适配器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.ErrorHandler 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.ErrorHandler
的使用

使用 ErrorHandler 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 ErrorHandler 的使用

参数类型为 ErrorHandler 的 javax.xml.parsers 中的方法
abstract  void DocumentBuilder.setErrorHandler(ErrorHandler eh)
指定解析器要使用的 ErrorHandler。

javax.xml.validation 中 ErrorHandler 的使用

返回 ErrorHandler 的 javax.xml.validation 中的方法
abstract ErrorHandler | SchemaFactory.getErrorHandler() 获取设置为此 SchemaFactory 的当前 ErrorHandler。
abstract ErrorHandler | Validator.getErrorHandler() 获取设置为此 Validator 的当前 ErrorHandler。
abstract ErrorHandler | ValidatorHandler.getErrorHandler() 获取设置为此 ValidatorHandler 的当前 ErrorHandler。

参数类型为 ErrorHandler 的 javax.xml.validation 中的方法
abstract void | SchemaFactory.setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收在 newSchema 方法调用期间遇到的错误。
abstract void | Validator.setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收在 validate 方法调用期间遇到的错误。
abstract void | ValidatorHandler.setErrorHandler(ErrorHandler errorHandler) 设置 ErrorHandler 以接收验证期间遇到的错误。

org.xml.sax 中 ErrorHandler 的使用

实现 ErrorHandler 的 org.xml.sax 中的类
 class HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

返回 ErrorHandler 的 org.xml.sax 中的方法
 ErrorHandler XMLReader.getErrorHandler()
返回当前的错误处理程序。

参数类型为 ErrorHandler 的 org.xml.sax 中的方法
void | Parser.setErrorHandler(ErrorHandler handler) 已过时。 允许应用程序注册错误事件处理程序。
void | XMLReader.setErrorHandler(ErrorHandler handler) 允许应用程序注册错误事件处理程序。

org.xml.sax.ext 中 ErrorHandler 的使用

实现 ErrorHandler 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

org.xml.sax.helpers 中 ErrorHandler 的使用

实现 ErrorHandler 的 org.xml.sax.helpers 中的类
class | DefaultHandler SAX2 事件处理程序的默认基类。
class | XMLFilterImpl 派生 XML 过滤器的基类。

返回 ErrorHandler 的 org.xml.sax.helpers 中的方法
ErrorHandler | ParserAdapter.getErrorHandler() 返回当前错误处理程序。
ErrorHandler | XMLFilterImpl.getErrorHandler() 获取当前错误事件处理程序。

参数类型为 ErrorHandler 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.setErrorHandler(ErrorHandler handler) 设置错误处理程序。
void | XMLFilterImpl.setErrorHandler(ErrorHandler handler) 设置错误事件处理程序。
void | XMLReaderAdapter.setErrorHandler(ErrorHandler handler) 注册错误事件处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.AttributeList 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.AttributeList
的使用

使用 AttributeList 的软件包
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

org.xml.sax 中 AttributeList 的使用

参数类型为 AttributeList 的 org.xml.sax 中的方法
void | DocumentHandler.startElement(String name, AttributeList atts) 已过时。 接收元素开始的通知。
void | HandlerBase.startElement(String name, AttributeList attributes) 已过时。 接收元素开始的通知。

org.xml.sax.helpers 中 AttributeList 的使用

实现 AttributeList 的 org.xml.sax.helpers 中的类
 class AttributeListImpl
已过时。 此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。

参数类型为 AttributeList 的 org.xml.sax.helpers 中的方法
void | AttributeListImpl.setAttributeList(AttributeList atts) 已过时。 设置属性列表，丢弃以前的内容。
void | ParserAdapter.startElement(String qName, AttributeList qAtts) 适配器实现方法；不调用。

参数类型为 AttributeList 的 org.xml.sax.helpers 中的构造方法
AttributeListImpl(AttributeList atts)
已过时。 构造现有属性列表的持久副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.SAXParseException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.SAXParseException
的使用

使用 SAXParseException 的软件包
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind.helpers 中 SAXParseException 的使用

参数类型为 SAXParseException 的 javax.xml.bind.helpers 中的构造方法
ValidationEventLocatorImpl(SAXParseException e)
根据 SAXParseException 的位置信息构造一个对象。

org.xml.sax 中 SAXParseException 的使用

参数类型为 SAXParseException 的 org.xml.sax 中的方法
void | HandlerBase.error(SAXParseException e) 已过时。 接收可恢复的解析器错误的通知。
void | ErrorHandler.error(SAXParseException exception) 接收可恢复的错误的通知。
void | HandlerBase.fatalError(SAXParseException e) 已过时。 报告严重的 XML 解析错误。
void | ErrorHandler.fatalError(SAXParseException exception) 接收不可恢复的错误的通知。
void | HandlerBase.warning(SAXParseException e) 已过时。 接收解析器警告的通知。
void | ErrorHandler.warning(SAXParseException exception) 接收警告的通知。

org.xml.sax.helpers 中 SAXParseException 的使用

参数类型为 SAXParseException 的 org.xml.sax.helpers 中的方法
void | DefaultHandler.error(SAXParseException e) 接收可恢复的解析器错误的通知。
void | XMLFilterImpl.error(SAXParseException e) 过滤一个错误事件。
void | DefaultHandler.fatalError(SAXParseException e) 报告严重的 XML 解析错误。
void | XMLFilterImpl.fatalError(SAXParseException e) 过滤一个严重的错误事件。
void | DefaultHandler.warning(SAXParseException e) 接收解析器警告的通知。
void | XMLFilterImpl.warning(SAXParseException e) 过滤一个警告事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.SAXNotRecognizedException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.SAXNotRecognizedException
的使用

使用 SAXNotRecognizedException 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 SAXNotRecognizedException 的使用

抛出 SAXNotRecognizedException 的 javax.xml.parsers 中的方法
abstract boolean | SAXParserFactory.getFeature(String name) 返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
abstract Object | SAXParser.getProperty(String name) 返回 XMLReader 的底层实现中请求的特定属性。
abstract void | SAXParserFactory.setFeature(String name, boolean value) 在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
abstract void | SAXParser.setProperty(String name, Object value) 设置 XMLReader 的底层实现中的特定属性。

javax.xml.validation 中 SAXNotRecognizedException 的使用

抛出 SAXNotRecognizedException 的 javax.xml.validation 中的方法
boolean | SchemaFactory.getFeature(String name) 查找功能标志的值。
boolean | Validator.getFeature(String name) 查找功能标志的值。
boolean | ValidatorHandler.getFeature(String name) 查找特性标志的值。
Object | SchemaFactory.getProperty(String name) 查找属性值。
Object | Validator.getProperty(String name) 查找属性值。
Object | ValidatorHandler.getProperty(String name) 查找属性值。
void | SchemaFactory.setFeature(String name, boolean value) 设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。
void | Validator.setFeature(String name, boolean value) 设置功能标志的值。
void | ValidatorHandler.setFeature(String name, boolean value) 设置此 ValidatorHandler 的特性。
void | SchemaFactory.setProperty(String name, Object object) 设置属性值。
void | Validator.setProperty(String name, Object object) 设置属性值。
void | ValidatorHandler.setProperty(String name, Object object) 设置属性值。

org.xml.sax 中 SAXNotRecognizedException 的使用

抛出 SAXNotRecognizedException 的 org.xml.sax 中的方法
boolean | XMLReader.getFeature(String name) 查找功能标志的值。
Object | XMLReader.getProperty(String name) 查找属性的值。
void | XMLReader.setFeature(String name, boolean value) 设置功能标志的值。
void | XMLReader.setProperty(String name, Object value) 设置属性的值。

org.xml.sax.helpers 中 SAXNotRecognizedException 的使用

抛出 SAXNotRecognizedException 的 org.xml.sax.helpers 中的方法
boolean | ParserAdapter.getFeature(String name) 检查解析器功能标志。
boolean | XMLFilterImpl.getFeature(String name) 查找功能值。
Object | ParserAdapter.getProperty(String name) 获取解析器属性。
Object | XMLFilterImpl.getProperty(String name) 查找属性值。
void | ParserAdapter.setFeature(String name, boolean value) 为解析器设置功能标志。
void | XMLFilterImpl.setFeature(String name, boolean value) 设置功能的值。
void | ParserAdapter.setProperty(String name, Object value) 设置解析器属性。
void | XMLFilterImpl.setProperty(String name, Object value) 设置属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.Locator 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.Locator
的使用

使用 Locator 的软件包
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind.helpers 中 Locator 的使用

参数类型为 Locator 的 javax.xml.bind.helpers 中的构造方法
ValidationEventLocatorImpl(Locator loc)
根据 org.xml.sax.Locator 构造一个对象。

org.xml.sax 中 Locator 的使用

参数类型为 Locator 的 org.xml.sax 中的方法
void | ContentHandler.setDocumentLocator(Locator locator) 接收用来查找 SAX 文档事件起源的对象。
void | DocumentHandler.setDocumentLocator(Locator locator) 已过时。 接收用来查找 SAX 文档事件起源的对象。
void | HandlerBase.setDocumentLocator(Locator locator) 已过时。 接收文档事件的 Locator 对象。

参数类型为 Locator 的 org.xml.sax 中的构造方法
SAXParseException(String message, Locator locator)
从消息和 Locator 创建新的 SAXParseException。
SAXParseException(String message, Locator locator, Exception e)
将现有的异常包装在 SAXParseException 中。

org.xml.sax.ext 中 Locator 的使用

org.xml.sax.ext 中 Locator 的子接口
 interface Locator2
SAX2 扩展，用于扩充通过 Locator 提供的实体信息。

实现 Locator 的 org.xml.sax.ext 中的类
 class Locator2Impl
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

参数类型为 Locator 的 org.xml.sax.ext 中的构造方法
Locator2Impl(Locator locator)
复制现有 Locator 或 Locator2 对象。

org.xml.sax.helpers 中 Locator 的使用

实现 Locator 的 org.xml.sax.helpers 中的类
 class LocatorImpl
提供 Locator 的可选的有用实现。

参数类型为 Locator 的 org.xml.sax.helpers 中的方法
void | DefaultHandler.setDocumentLocator(Locator locator) 接收文档事件的 Locator 对象。
void | ParserAdapter.setDocumentLocator(Locator locator) 适配器实现方法；不调用。
void | XMLFilterImpl.setDocumentLocator(Locator locator) 过滤一个新的文档定位器事件。
void | XMLReaderAdapter.setDocumentLocator(Locator locator) 设置文档定位器。

参数类型为 Locator 的 org.xml.sax.helpers 中的构造方法
LocatorImpl(Locator locator)
复制构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.SAXNotSupportedException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.SAXNotSupportedException
的使用

使用 SAXNotSupportedException 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 SAXNotSupportedException 的使用

抛出 SAXNotSupportedException 的 javax.xml.parsers 中的方法
abstract boolean | SAXParserFactory.getFeature(String name) 返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
abstract Object | SAXParser.getProperty(String name) 返回 XMLReader 的底层实现中请求的特定属性。
abstract void | SAXParserFactory.setFeature(String name, boolean value) 在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
abstract void | SAXParser.setProperty(String name, Object value) 设置 XMLReader 的底层实现中的特定属性。

javax.xml.validation 中 SAXNotSupportedException 的使用

抛出 SAXNotSupportedException 的 javax.xml.validation 中的方法
boolean | SchemaFactory.getFeature(String name) 查找功能标志的值。
boolean | Validator.getFeature(String name) 查找功能标志的值。
boolean | ValidatorHandler.getFeature(String name) 查找特性标志的值。
Object | SchemaFactory.getProperty(String name) 查找属性值。
Object | Validator.getProperty(String name) 查找属性值。
Object | ValidatorHandler.getProperty(String name) 查找属性值。
void | SchemaFactory.setFeature(String name, boolean value) 设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。
void | Validator.setFeature(String name, boolean value) 设置功能标志的值。
void | ValidatorHandler.setFeature(String name, boolean value) 设置此 ValidatorHandler 的特性。
void | SchemaFactory.setProperty(String name, Object object) 设置属性值。
void | Validator.setProperty(String name, Object object) 设置属性值。
void | ValidatorHandler.setProperty(String name, Object object) 设置属性值。

org.xml.sax 中 SAXNotSupportedException 的使用

抛出 SAXNotSupportedException 的 org.xml.sax 中的方法
boolean | XMLReader.getFeature(String name) 查找功能标志的值。
Object | XMLReader.getProperty(String name) 查找属性的值。
void | XMLReader.setFeature(String name, boolean value) 设置功能标志的值。
void | XMLReader.setProperty(String name, Object value) 设置属性的值。

org.xml.sax.helpers 中 SAXNotSupportedException 的使用

抛出 SAXNotSupportedException 的 org.xml.sax.helpers 中的方法
boolean | ParserAdapter.getFeature(String name) 检查解析器功能标志。
boolean | XMLFilterImpl.getFeature(String name) 查找功能值。
Object | ParserAdapter.getProperty(String name) 获取解析器属性。
Object | XMLFilterImpl.getProperty(String name) 查找属性值。
void | ParserAdapter.setFeature(String name, boolean value) 为解析器设置功能标志。
void | XMLFilterImpl.setFeature(String name, boolean value) 设置功能的值。
void | ParserAdapter.setProperty(String name, Object value) 设置解析器属性。
void | XMLFilterImpl.setProperty(String name, Object value) 设置属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.InputSource 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.InputSource
的使用

使用 InputSource 的软件包
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind 中 InputSource 的使用

参数类型为 InputSource 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(InputSource source)
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 InputSource 的使用

参数类型为 InputSource 的 javax.xml.bind.helpers 中的方法
Object | AbstractUnmarshallerImpl.unmarshal(InputSource source)
protected abstract Object | AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source) 使用指定的 XMLReader 和 InputSource 解组对象。

javax.xml.parsers 中 InputSource 的使用

参数类型为 InputSource 的 javax.xml.parsers 中的方法
abstract Document | DocumentBuilder.parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。

javax.xml.transform.sax 中 InputSource 的使用

返回 InputSource 的 javax.xml.transform.sax 中的方法
InputSource | SAXSource.getInputSource() 获取要用于 Source 的 SAX InputSource。
static InputSource | SAXSource.sourceToInputSource(Source source) 尝试从 Source 对象获取 SAX InputSource 对象。

参数类型为 InputSource 的 javax.xml.transform.sax 中的方法
 void SAXSource.setInputSource(InputSource inputSource)
设置要用于 Source 的 SAX InputSource。

参数类型为 InputSource 的 javax.xml.transform.sax 中的构造方法
SAXSource(InputSource inputSource)
使用 SAX InputSource，创建 SAXSource。
SAXSource(XMLReader reader, InputSource inputSource)
使用 XMLReader 和 SAX InputSource 创建 SAXSource。

javax.xml.xpath 中 InputSource 的使用

参数类型为 InputSource 的 javax.xml.xpath 中的方法
String | XPathExpression.evaluate(InputSource source) 计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。
Object | XPathExpression.evaluate(InputSource source, QName returnType) 计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
String | XPath.evaluate(String expression, InputSource source) 计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。
Object | XPath.evaluate(String expression, InputSource source, QName returnType) 计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。

org.xml.sax 中 InputSource 的使用

返回 InputSource 的 org.xml.sax 中的方法
InputSource | HandlerBase.resolveEntity(String publicId, String systemId) 已过时。 解析外部实体。
InputSource | EntityResolver.resolveEntity(String publicId, String systemId) 允许应用程序解析外部实体。

参数类型为 InputSource 的 org.xml.sax 中的方法
void | Parser.parse(InputSource source) 已过时。 解析 XML 文档。
void | XMLReader.parse(InputSource input) 解析 XML 文档。

org.xml.sax.ext 中 InputSource 的使用

返回 InputSource 的 org.xml.sax.ext 中的方法
 InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
 InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
允许应用程序为不能显式定义外部子集的文档提供外部子集。
 InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
 InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
 InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。

org.xml.sax.helpers 中 InputSource 的使用

返回 InputSource 的 org.xml.sax.helpers 中的方法
InputSource | DefaultHandler.resolveEntity(String publicId, String systemId) 解析外部实体。
InputSource | XMLFilterImpl.resolveEntity(String publicId, String systemId) 过滤一个外部实体解析。

参数类型为 InputSource 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.parse(InputSource input) 解析 XML 文档。
void | XMLFilterImpl.parse(InputSource input) 解析一个文档。
void | XMLReaderAdapter.parse(InputSource input) 解析文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


接口 org.xml.sax.EntityResolver 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

接口 org.xml.sax.EntityResolver
的使用

使用 EntityResolver 的软件包
javax.xml.parsers | 提供允许处理 XML 文档的类。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.parsers 中 EntityResolver 的使用

参数类型为 EntityResolver 的 javax.xml.parsers 中的方法
abstract  void DocumentBuilder.setEntityResolver(EntityResolver er)
指定使用 EntityResolver 解析要解析的 XML 文档中存在的实体。

org.xml.sax 中 EntityResolver 的使用

实现 EntityResolver 的 org.xml.sax 中的类
 class HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

返回 EntityResolver 的 org.xml.sax 中的方法
 EntityResolver XMLReader.getEntityResolver()
返回当前的实体解析器。

参数类型为 EntityResolver 的 org.xml.sax 中的方法
void | Parser.setEntityResolver(EntityResolver resolver) 已过时。 允许应用程序注册自定义的实体解析器。
void | XMLReader.setEntityResolver(EntityResolver resolver) 允许应用程序注册实体解析器。

org.xml.sax.ext 中 EntityResolver 的使用

org.xml.sax.ext 中 EntityResolver 的子接口
 interface EntityResolver2
扩展的接口，用于将外部实体引用映射到输入源，或用于提供缺少的外部子集。

实现 EntityResolver 的 org.xml.sax.ext 中的类
 class DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

org.xml.sax.helpers 中 EntityResolver 的使用

实现 EntityResolver 的 org.xml.sax.helpers 中的类
class | DefaultHandler SAX2 事件处理程序的默认基类。
class | XMLFilterImpl 派生 XML 过滤器的基类。

返回 EntityResolver 的 org.xml.sax.helpers 中的方法
EntityResolver | ParserAdapter.getEntityResolver() 返回当前实体解析器。
EntityResolver | XMLFilterImpl.getEntityResolver() 获取当前实体解析器。

参数类型为 EntityResolver 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.setEntityResolver(EntityResolver resolver) 设置实体解析器。
void | XMLFilterImpl.setEntityResolver(EntityResolver resolver) 设置实体解析器。
void | XMLReaderAdapter.setEntityResolver(EntityResolver resolver) 注册实体解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


类 org.xml.sax.SAXException 的使用 (Java Platform SE 6)

上一个 下一个 框架 无框架

类 org.xml.sax.SAXException
的使用

使用 SAXException 的软件包
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.xml.bind.helpers 中 SAXException 的使用

参数类型为 SAXException 的 javax.xml.bind.helpers 中的方法
protected  UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
从 SAXException 创建 UnmarshalException。

javax.xml.parsers 中 SAXException 的使用

抛出 SAXException 的 javax.xml.parsers 中的方法
abstract Parser | SAXParser.getParser() 返回由此类的实现封装的 SAX 解析器。
abstract XMLReader | SAXParser.getXMLReader() 返回由此类的实现封装的 XMLReader。
abstract SAXParser | SAXParserFactory.newSAXParser() 使用当前配置的工厂参数创建 SAXParser 的一个新实例。
Document | DocumentBuilder.parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | SAXParser.parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。
abstract Document | DocumentBuilder.parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(String uri) 将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(String uri, DefaultHandler dh) 使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
void | SAXParser.parse(String uri, HandlerBase hb) 使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

javax.xml.validation 中 SAXException 的使用

抛出 SAXException 的 javax.xml.validation 中的方法
abstract Schema | SchemaFactory.newSchema() 创建特殊的 Schema 对象。
Schema | SchemaFactory.newSchema(File schema) 解析作为模式的指定 File 并以 Schema 的形式返回它。
Schema | SchemaFactory.newSchema(Source schema) 解析作为模式的指定源并以模式形式返回它。
abstract Schema | SchemaFactory.newSchema(Source[] schemas) 解析作为模式的指定源（或多个源），并以模式形式返回它。
Schema | SchemaFactory.newSchema(URL schema) 解析作为模式的指定 URL 并以 Schema 形式返回它。
void | Validator.validate(Source source) 验证指定的输入。
abstract void | Validator.validate(Source source, Result result) 验证指定输入并将扩充的验证结果发送到指定输出。

org.xml.sax 中 SAXException 的使用

org.xml.sax 中 SAXException 的子类
class | SAXNotRecognizedException 用于未识别的标识符的 Exception 类。
class | SAXNotSupportedException 用于不被支持的操作的 Exception 类。
class | SAXParseException 封装 XML 解析错误或警告。

抛出 SAXException 的 org.xml.sax 中的方法
void | ContentHandler.characters(char[] ch, int start, int length) 接收字符数据的通知。
void | DocumentHandler.characters(char[] ch, int start, int length) 已过时。 接收字符数据的通知。
void | HandlerBase.characters(char[] ch, int start, int length) 已过时。 接收元素内字符数据的通知。
void | ContentHandler.endDocument() 接收文档的结尾的通知。
void | DocumentHandler.endDocument() 已过时。 接收文档结束的通知。
void | HandlerBase.endDocument() 已过时。 接收文档结束的通知。
void | DocumentHandler.endElement(String name) 已过时。 接收元素结束的通知。
void | HandlerBase.endElement(String name) 已过时。 接收元素结束的通知。
void | ContentHandler.endElement(String uri, String localName, String qName) 接收元素结束的通知。
void | ContentHandler.endPrefixMapping(String prefix) 结束前缀 URI 范围的映射。
void | HandlerBase.error(SAXParseException e) 已过时。 接收可恢复的解析器错误的通知。
void | ErrorHandler.error(SAXParseException exception) 接收可恢复的错误的通知。
void | HandlerBase.fatalError(SAXParseException e) 已过时。 报告严重的 XML 解析错误。
void | ErrorHandler.fatalError(SAXParseException exception) 接收不可恢复的错误的通知。
void | ContentHandler.ignorableWhitespace(char[] ch, int start, int length) 接收元素内容中可忽略的空白的通知。
void | DocumentHandler.ignorableWhitespace(char[] ch, int start, int length) 已过时。 接收元素内容中可忽略的空白的通知。
void | HandlerBase.ignorableWhitespace(char[] ch, int start, int length) 已过时。 接收元素内容中可忽略的空白的通知。
void | DTDHandler.notationDecl(String name, String publicId, String systemId) 接收注释声明事件的通知。
void | Parser.parse(InputSource source) 已过时。 解析 XML 文档。
void | XMLReader.parse(InputSource input) 解析 XML 文档。
void | Parser.parse(String systemId) 已过时。 从系统标识符 (URI) 解析 XML 文档。
void | XMLReader.parse(String systemId) 从系统标识符 (URI) 解析 XML 文档。
void | ContentHandler.processingInstruction(String target, String data) 接收处理指令的通知。
void | DocumentHandler.processingInstruction(String target, String data) 已过时。 接收处理指令的通知。
void | HandlerBase.processingInstruction(String target, String data) 已过时。 接收处理指令的通知。
InputSource | HandlerBase.resolveEntity(String publicId, String systemId) 已过时。 解析外部实体。
InputSource | EntityResolver.resolveEntity(String publicId, String systemId) 允许应用程序解析外部实体。
void | Parser.setLocale(Locale locale) 已过时。 允许应用程序请求错误和警告的环境。
void | ContentHandler.skippedEntity(String name) 接收跳过的实体的通知。
void | ContentHandler.startDocument() 接收文档的开始的通知。
void | DocumentHandler.startDocument() 已过时。 接收文档的开始的通知。
void | HandlerBase.startDocument() 已过时。 接收文档开始的通知。
void | DocumentHandler.startElement(String name, AttributeList atts) 已过时。 接收元素开始的通知。
void | HandlerBase.startElement(String name, AttributeList attributes) 已过时。 接收元素开始的通知。
void | ContentHandler.startElement(String uri, String localName, String qName, Attributes atts) 接收元素开始的通知。
void | ContentHandler.startPrefixMapping(String prefix, String uri) 开始前缀 URI 名称空间范围映射。
void | DTDHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 接收未解析的实体声明事件的通知。
void | HandlerBase.warning(SAXParseException e) 已过时。 接收解析器警告的通知。
void | ErrorHandler.warning(SAXParseException exception) 接收警告的通知。

org.xml.sax.ext 中 SAXException 的使用

抛出 SAXException 的 org.xml.sax.ext 中的方法
 void DeclHandler.attributeDecl(String eName, String aName, String type, String mode, String value)
报告属性类型声明。
 void DefaultHandler2.attributeDecl(String eName, String aName, String type, String mode, String value)
 void DefaultHandler2.comment(char[] ch, int start, int length)
 void LexicalHandler.comment(char[] ch, int start, int length)
报告文档的任何位置的 XML 注释。
 void DeclHandler.elementDecl(String name, String model)
报告元素类型声明。
 void DefaultHandler2.elementDecl(String name, String model)
 void DefaultHandler2.endCDATA()
 void LexicalHandler.endCDATA()
报告 CDATA 节的结束。
 void DefaultHandler2.endDTD()
 void LexicalHandler.endDTD()
报告 DTD 声明的结束。
 void DefaultHandler2.endEntity(String name)
 void LexicalHandler.endEntity(String name)
报告实体的结束。
 void DeclHandler.externalEntityDecl(String name, String publicId, String systemId)
报告解析的外部实体声明。
 void DefaultHandler2.externalEntityDecl(String name, String publicId, String systemId)
 InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
 InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
允许应用程序为不能显式定义外部子集的文档提供外部子集。
 void DeclHandler.internalEntityDecl(String name, String value)
报告内部实体声明。
 void DefaultHandler2.internalEntityDecl(String name, String value)
 InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
 InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
 InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。
 void DefaultHandler2.startCDATA()
 void LexicalHandler.startCDATA()
报告 CDATA 节的开始。
 void DefaultHandler2.startDTD(String name, String publicId, String systemId)
 void LexicalHandler.startDTD(String name, String publicId, String systemId)
报告 DTD 声明的开始（如果存在）。
 void DefaultHandler2.startEntity(String name)
 void LexicalHandler.startEntity(String name)
报告一些内部和外部 XML 实体的开始。

org.xml.sax.helpers 中 SAXException 的使用

抛出 SAXException 的 org.xml.sax.helpers 中的方法
void | DefaultHandler.characters(char[] ch, int start, int length) 接收元素中字符数据的通知。
void | ParserAdapter.characters(char[] ch, int start, int length) 适配器实现方法；不调用。
void | XMLFilterImpl.characters(char[] ch, int start, int length) 过滤一个字符数据事件。
void | XMLReaderAdapter.characters(char[] ch, int start, int length) 适配 SAX2 字符事件。
static XMLReader | XMLReaderFactory.createXMLReader() 尝试从系统默认值创建一个 XMLReader。
static XMLReader | XMLReaderFactory.createXMLReader(String className) 尝试从类名称创建一个 XML 阅读器。
void | DefaultHandler.endDocument() 接收文档结束的通知。
void | ParserAdapter.endDocument() 适配器实现方法；不调用。
void | XMLFilterImpl.endDocument() 过滤一个结束文档事件。
void | XMLReaderAdapter.endDocument() 结束文档事件。
void | ParserAdapter.endElement(String qName) 适配器实现方法；不调用。
void | DefaultHandler.endElement(String uri, String localName, String qName) 接收元素结束的通知。
void | XMLFilterImpl.endElement(String uri, String localName, String qName) 过滤一个结束元素事件。
void | XMLReaderAdapter.endElement(String uri, String localName, String qName) 适配 SAX2 结束元素事件。
void | DefaultHandler.endPrefixMapping(String prefix) 接收名称空间映射结束的通知。
void | XMLFilterImpl.endPrefixMapping(String prefix) 过滤一个结束名称空间前缀映射事件。
void | DefaultHandler.error(SAXParseException e) 接收可恢复的解析器错误的通知。
void | XMLFilterImpl.error(SAXParseException e) 过滤一个错误事件。
void | DefaultHandler.fatalError(SAXParseException e) 报告严重的 XML 解析错误。
void | XMLFilterImpl.fatalError(SAXParseException e) 过滤一个严重的错误事件。
void | DefaultHandler.ignorableWhitespace(char[] ch, int start, int length) 接收元素内容中可忽略空白的通知。
void | ParserAdapter.ignorableWhitespace(char[] ch, int start, int length) 适配器实现方法；不调用。
void | XMLFilterImpl.ignorableWhitespace(char[] ch, int start, int length) 过滤一个可忽略空格的事件。
void | XMLReaderAdapter.ignorableWhitespace(char[] ch, int start, int length) 适配 SAX2 忽略空白事件。
void | DefaultHandler.notationDecl(String name, String publicId, String systemId) 接收注释声明的通知。
void | XMLFilterImpl.notationDecl(String name, String publicId, String systemId) 过滤一个注释声明事件。
void | ParserAdapter.parse(InputSource input) 解析 XML 文档。
void | XMLFilterImpl.parse(InputSource input) 解析一个文档。
void | XMLReaderAdapter.parse(InputSource input) 解析文档。
void | ParserAdapter.parse(String systemId) 解析 XML 文档。
void | XMLFilterImpl.parse(String systemId) 解析一个文档。
void | XMLReaderAdapter.parse(String systemId) 解析文档。
void | DefaultHandler.processingInstruction(String target, String data) 接收处理指令的通知。
void | ParserAdapter.processingInstruction(String target, String data) 适配器实现方法；不调用。
void | XMLFilterImpl.processingInstruction(String target, String data) 过滤一个处理指令事件。
void | XMLReaderAdapter.processingInstruction(String target, String data) 适配 SAX2 处理指令事件。
InputSource | DefaultHandler.resolveEntity(String publicId, String systemId) 解析外部实体。
InputSource | XMLFilterImpl.resolveEntity(String publicId, String systemId) 过滤一个外部实体解析。
void | XMLReaderAdapter.setLocale(Locale locale) 设置错误报告的语言环境。
void | DefaultHandler.skippedEntity(String name) 接收跳过的实体的通知。
void | XMLFilterImpl.skippedEntity(String name) 过滤一个跳过的实体事件。
void | XMLReaderAdapter.skippedEntity(String name) 适配 SAX2 跳过的实体事件。
void | DefaultHandler.startDocument() 接收文档开始的通知。
void | ParserAdapter.startDocument() 适配器实现方法；不调用。
void | XMLFilterImpl.startDocument() 过滤一个开始文档事件。
void | XMLReaderAdapter.startDocument() 开始文档事件。
void | ParserAdapter.startElement(String qName, AttributeList qAtts) 适配器实现方法；不调用。
void | DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes) 接收元素开始的通知。
void | XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts) 过滤一个开始元素事件。
void | XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts) 适配 SAX2 开始元素事件。
void | DefaultHandler.startPrefixMapping(String prefix, String uri) 接收名称空间映射开始的通知。
void | XMLFilterImpl.startPrefixMapping(String prefix, String uri) 过滤一个开始名称空间前缀映射事件。
void | DefaultHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 接收未解析实体声明的通知。
void | XMLFilterImpl.unparsedEntityDecl(String name, String publicId, String systemId, String notationName) 过滤一个未解析实体声明事件。
void | DefaultHandler.warning(SAXParseException e) 接收解析器警告的通知。
void | XMLFilterImpl.warning(SAXParseException e) 过滤一个警告事件。

抛出 SAXException 的 org.xml.sax.helpers 中的构造方法
ParserAdapter()
构造一个新解析器适配器。
XMLReaderAdapter()
创建一个新的适配器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6


A - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

A

a - 类 java.awt.AWTEventMulticaster 中的变量
A - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering A (8 1/2 x 11 in) 的 MediaType 实例。
A - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering A 尺寸，8.5 inch × 11 inch。
A - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A 尺寸。
A - 类 javax.swing.text.html.HTML.Tag 中的静态变量
A0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A0 的别名。
A0 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A0 尺寸，841 mm × 1189 mm。
A1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A1 的别名。
A1 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A1 尺寸，594 mm × 841 mm。
A10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A10 的别名。
A10 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A10 尺寸，26 mm × 37 mm。
A2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A2 的别名。
A2 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A2 尺寸，420 mm × 594 mm。
A3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A3 的别名。
A3 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A3 尺寸，297 mm × 420 mm。
A4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A4 的别名。
A4 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A4 尺寸，210 × by 297 mm。
A5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A5 的别名。
A5 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A5 尺寸，148 mm × 210 mm。
A6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A6 的别名。
A6 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A6 尺寸，105 mm × 148 mm。
A7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A7 的别名。
A7 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A7 尺寸，74 mm × 105 mm。
A8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A8 的别名。
A8 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A8 尺寸，52 mm × 74 mm。
A9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_A9 的别名。
A9 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO A9 尺寸，37 mm × 52 mm。
ABORT - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示被异步跟踪的图像在生成完成前即已中止。
abort() - 类 java.net.CacheRequest 中的方法
中止缓存响应的尝试。
abort() - 类 javax.imageio.ImageReader 中的方法
请求中止当前所有读取操作。
abort() - 类 javax.imageio.ImageWriter 中的方法
请求中止任何当前写入操作。
abort() - 接口 javax.security.auth.spi.LoginModule 中的方法
中止验证过程的方法（阶段 2）。
abort() - 接口 org.w3c.dom.ls.LSParser 中的方法
中断对当前由 LSParser 加载的文档的加载。
ABORTED - 类 java.awt.MediaTracker 中的静态变量
指示媒体下载已中止的标志。
ABORTED - 类 javax.print.attribute.standard.JobState 中的静态变量
作业已被系统中止（通常当作业处于 PROCESSING 或 PROCESSING_STOPPED 状态时），打印机已完成正在中止的作业，且所有作业状态属性已达到作业的最终值。
ABORTED_BY_SYSTEM - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统中止了作业。
abortGrabbing() - 类 java.awt.image.PixelGrabber 中的方法
请求 PixelGrabber 中止获取图像。
abortRequested() - 类 javax.imageio.ImageReader 中的方法
如果从实例化 reader 或调用 clearAbortRequest 时起，已经请求了中止当前读取操作，则返回 true。
abortRequested() - 类 javax.imageio.ImageWriter 中的方法
如果自从 writer 被实例化或 clearAbortRequest 被调用开始，已经发出中止当前写入操作的请求，则返回 true。
ABOUT_UIROLE - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个充当提供 "About" 信息角色的 UI。
ABOVE_BASELINE - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
ABOVE_BASELINE_LEADING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
ABOVE_BASELINE_TRAILING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
ABOVE_BOTTOM - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框底端线的顶部。
ABOVE_TOP - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框顶端线的上部。
abs(int) - 类 java.lang.Math 中的静态方法
返回 int 值的绝对值。
abs(long) - 类 java.lang.Math 中的静态方法
返回 long 值的绝对值。
abs(float) - 类 java.lang.Math 中的静态方法
返回 float 值的绝对值。
abs(double) - 类 java.lang.Math 中的静态方法
返回 double 值的绝对值。
abs(int) - 类 java.lang.StrictMath 中的静态方法
返回 int 值的绝对值。
abs(long) - 类 java.lang.StrictMath 中的静态方法
返回 long 值的绝对值。
abs(float) - 类 java.lang.StrictMath 中的静态方法
返回 float 值的绝对值。
abs(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的绝对值。
abs() - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为此 BigDecimal 的绝对值，其标度为 this.scale()。
abs(MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为此 BigDecimal 绝对值的 BigDecimal（根据上下文设置进行舍入）。
abs() - 类 java.math.BigInteger 中的方法
返回其值是此 BigInteger 的绝对值的 BigInteger。
absolute(int) - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的给定行编号。
absolutePath() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.absolutePath() 中的规范实现 absolutePath 方法。
absolutePath() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点的绝对路径名。
ABSTRACT - 类 java.lang.reflect.Modifier 中的静态变量
表示 abstract 修饰符的 int 的值。
AbstractAction - javax.swing 中的 类
此类提供 JFC Action 接口的默认实现。
AbstractAction() - 类 javax.swing.AbstractAction 的构造方法
用默认描述字符串和默认图标定义一个 Action 对象。
AbstractAction(String) - 类 javax.swing.AbstractAction 的构造方法
用指定描述字符串和默认图标定义一个 Action 对象。
AbstractAction(String, Icon) - 类 javax.swing.AbstractAction 的构造方法
用指定描述字符串和指定图标定义一个 Action 对象。
AbstractAnnotationValueVisitor6<R,P> - javax.lang.model.util 中的 类
注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
AbstractAnnotationValueVisitor6() - 类 javax.lang.model.util.AbstractAnnotationValueVisitor6 的构造方法
要调用的具体子类的构造方法。
AbstractBorder - javax.swing.border 中的 类
实现无大小限制的空边框类。
AbstractBorder() - 类 javax.swing.border.AbstractBorder 的构造方法
AbstractButton - javax.swing 中的 类
定义按钮和菜单项的一般行为。
AbstractButton() - 类 javax.swing.AbstractButton 的构造方法
AbstractButton.AccessibleAbstractButton - javax.swing 中的 类
此类实现对 AbstractButton 类的可访问性支持。
AbstractButton.AccessibleAbstractButton() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 的构造方法
AbstractButton.ButtonChangeListener - javax.swing 中的 类
将 ChangeListener 扩展为可序列化的。
AbstractCellEditor - javax.swing 中的 类
AbstractCellEditor() - 类 javax.swing.AbstractCellEditor 的构造方法
AbstractCollection<E> - java.util 中的 类
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
AbstractCollection() - 类 java.util.AbstractCollection 的构造方法
唯一的构造方法。
AbstractColorChooserPanel - javax.swing.colorchooser 中的 类
这是用于颜色选取器的抽象超类。
AbstractColorChooserPanel() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 的构造方法
AbstractDocument - javax.swing.text 中的 类
文档接口的实现，可作为实现各种文档的基础。
AbstractDocument(AbstractDocument.Content) - 类 javax.swing.text.AbstractDocument 的构造方法
构造具有某种指定内容存储机制的新 AbstractDocument。
AbstractDocument(AbstractDocument.Content, AbstractDocument.AttributeContext) - 类 javax.swing.text.AbstractDocument 的构造方法
构造具有某种指定内容存储机制的新 AbstractDocument。
AbstractDocument.AbstractElement - javax.swing.text 中的 类
实现元素的抽象部分。
AbstractDocument.AbstractElement(Element, AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 的构造方法
创建新的 AbstractElement。
AbstractDocument.AttributeContext - javax.swing.text 中的 接口
一个接口，它用于允许 MutableAttributeSet 的实现使用可插入属性压缩技术。
AbstractDocument.BranchElement - javax.swing.text 中的 类
实现一个包含其他元素的复合元素。
AbstractDocument.BranchElement(Element, AttributeSet) - 类 javax.swing.text.AbstractDocument.BranchElement 的构造方法
构造最初不包含任何子元素的复合元素。
AbstractDocument.Content - javax.swing.text 中的 接口
描述可编辑的字符序列内容的接口。
AbstractDocument.DefaultDocumentEvent - javax.swing.text 中的 类
存储修改文档时发生的文档更改。
AbstractDocument.DefaultDocumentEvent(int, int, DocumentEvent.EventType) - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 的构造方法
构造更改记录。
AbstractDocument.ElementEdit - javax.swing.text 中的 类
一个 ElementChange 实现，可将其添加到文档事件中。
AbstractDocument.ElementEdit(Element, int, Element[], Element[]) - 类 javax.swing.text.AbstractDocument.ElementEdit 的构造方法
构造一个编辑记录。
AbstractDocument.LeafElement - javax.swing.text 中的 类
实现可直接表示某类内容的元素。
AbstractDocument.LeafElement(Element, AttributeSet, int, int) - 类 javax.swing.text.AbstractDocument.LeafElement 的构造方法
构造一个表示文档中内容的元素（没有子元素）。
AbstractElementVisitor6<R,P> - javax.lang.model.util 中的 类
程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
AbstractElementVisitor6() - 类 javax.lang.model.util.AbstractElementVisitor6 的构造方法
要调用的具体子类的构造方法。
AbstractExecutorService - java.util.concurrent 中的 类
提供 ExecutorService 执行方法的默认实现。
AbstractExecutorService() - 类 java.util.concurrent.AbstractExecutorService 的构造方法
AbstractInterruptibleChannel - java.nio.channels.spi 中的 类
可中断通道的基本实现类。
AbstractInterruptibleChannel() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 的构造方法
初始化此类的一个新实例。
AbstractLayoutCache - javax.swing.tree 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
AbstractLayoutCache() - 类 javax.swing.tree.AbstractLayoutCache 的构造方法
AbstractLayoutCache.NodeDimensions - javax.swing.tree 中的 类
由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。
AbstractLayoutCache.NodeDimensions() - 类 javax.swing.tree.AbstractLayoutCache.NodeDimensions 的构造方法
AbstractList<E> - java.util 中的 类
此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
AbstractList() - 类 java.util.AbstractList 的构造方法
唯一的构造方法。
AbstractListModel - javax.swing 中的 类
该数据模型的抽象定义提供一个带内容的 List。
AbstractListModel() - 类 javax.swing.AbstractListModel 的构造方法
AbstractMap<K,V> - java.util 中的 类
此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。
AbstractMap() - 类 java.util.AbstractMap 的构造方法
唯一的构造方法。
AbstractMap.SimpleEntry<K,V> - java.util 中的 类
维护键和值的 Entry。
AbstractMap.SimpleEntry(K, V) - 类 java.util.AbstractMap.SimpleEntry 的构造方法
创建一个项，它表示从指定键到指定值的映射关系。
AbstractMap.SimpleEntry(Map.Entry<? extends K, ? extends V>) - 类 java.util.AbstractMap.SimpleEntry 的构造方法
创建一个项，它表示的映射关系与指定的项相同。
AbstractMap.SimpleImmutableEntry<K,V> - java.util 中的 类
维护不可变的键和值的 Entry。
AbstractMap.SimpleImmutableEntry(K, V) - 类 java.util.AbstractMap.SimpleImmutableEntry 的构造方法
创建一个项，它表示从指定键到指定值的映射关系。
AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K, ? extends V>) - 类 java.util.AbstractMap.SimpleImmutableEntry 的构造方法
创建一个项，它表示的映射关系与指定项相同。
AbstractMarshallerImpl - javax.xml.bind.helpers 中的 类
部分默认 Marshaller 实现。
AbstractMarshallerImpl() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 的构造方法
AbstractMethodError - java.lang 中的 错误
当应用程序试图调用一个抽象方法时，抛出此错误。
AbstractMethodError() - 错误 java.lang.AbstractMethodError 的构造方法
构造不带详细消息的 AbstractMethodError。
AbstractMethodError(String) - 错误 java.lang.AbstractMethodError 的构造方法
构造带指定详细消息的 AbstractMethodError。
AbstractOwnableSynchronizer - java.util.concurrent.locks 中的 类
可以由线程以独占方式拥有的同步器。
AbstractOwnableSynchronizer() - 类 java.util.concurrent.locks.AbstractOwnableSynchronizer 的构造方法
供子类使用的空构造方法。
AbstractPreferences - java.util.prefs 中的 类
此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。
AbstractPreferences(AbstractPreferences, String) - 类 java.util.prefs.AbstractPreferences 的构造方法
用指定的父节点和与其父节点相关的指定名称创建首选项节点。
AbstractProcessor - javax.annotation.processing 中的 类
旨在用作最具体注释 processor 的便捷超类的抽象注释 processor。
AbstractProcessor() - 类 javax.annotation.processing.AbstractProcessor 的构造方法
子类要调用的构造方法。
AbstractQueue<E> - java.util 中的 类
此类提供某些 Queue 操作的骨干实现。
AbstractQueue() - 类 java.util.AbstractQueue 的构造方法
子类使用的构造方法。
AbstractQueuedLongSynchronizer - java.util.concurrent.locks 中的 类
以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。
AbstractQueuedLongSynchronizer() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 的构造方法
创建一个初始同步状态为 0 的新 AbstractQueuedLongSynchronizer 实例。
AbstractQueuedLongSynchronizer.ConditionObject - java.util.concurrent.locks 中的 类
作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。
AbstractQueuedLongSynchronizer.ConditionObject() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 的构造方法
创建一个新的 ConditionObject 实例。
AbstractQueuedSynchronizer - java.util.concurrent.locks 中的 类
为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。
AbstractQueuedSynchronizer() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 的构造方法
创建具有初始同步状态 0 的新 AbstractQueuedSynchronizer 实例。
AbstractQueuedSynchronizer.ConditionObject - java.util.concurrent.locks 中的 类
AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。
AbstractQueuedSynchronizer.ConditionObject() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 的构造方法
创建一个新的 ConditionObject 实例。
AbstractScriptEngine - javax.script 中的 类
为几个 eval 方法的变体提供标准实现。
AbstractScriptEngine() - 类 javax.script.AbstractScriptEngine 的构造方法
创建一个新的 AbstractScriptEngine 实例，使用 SimpleScriptContext 作为其默认 ScriptContext。
AbstractScriptEngine(Bindings) - 类 javax.script.AbstractScriptEngine 的构造方法
创建一个新实例，使用指定 Bindings 作为受保护 context 字段中的 ENGINE_SCOPE Bindings。
AbstractSelectableChannel - java.nio.channels.spi 中的 类
可选择通道的基本实现类。
AbstractSelectableChannel(SelectorProvider) - 类 java.nio.channels.spi.AbstractSelectableChannel 的构造方法
初始化此类的一个新实例。
AbstractSelectionKey - java.nio.channels.spi 中的 类
选择键的基本实现类。
AbstractSelectionKey() - 类 java.nio.channels.spi.AbstractSelectionKey 的构造方法
初始化此类的一个新实例。
AbstractSelector - java.nio.channels.spi 中的 类
选择器的基本实现类。
AbstractSelector(SelectorProvider) - 类 java.nio.channels.spi.AbstractSelector 的构造方法
初始化此类的一个新实例。
AbstractSequentialList<E> - java.util 中的 类
此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
AbstractSequentialList() - 类 java.util.AbstractSequentialList 的构造方法
单独的构造方法。
AbstractSet<E> - java.util 中的 类
此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
AbstractSet() - 类 java.util.AbstractSet 的构造方法
单独的构造方法。
AbstractSpinnerModel - javax.swing 中的 类
此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。
AbstractSpinnerModel() - 类 javax.swing.AbstractSpinnerModel 的构造方法
AbstractTableModel - javax.swing.table 中的 类
此抽象类为 TableModel 接口中的大多数方法提供默认实现。
AbstractTableModel() - 类 javax.swing.table.AbstractTableModel 的构造方法
AbstractTypeVisitor6<R,P> - javax.lang.model.util 中的 类
类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。
AbstractTypeVisitor6() - 类 javax.lang.model.util.AbstractTypeVisitor6 的构造方法
要调用的具体子类的构造方法。
AbstractUndoableEdit - javax.swing.undo 中的 类
UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
AbstractUndoableEdit() - 类 javax.swing.undo.AbstractUndoableEdit 的构造方法
创建一个 AbstractUndoableEdit，其将 hasBeenDone 和 alive 默认为 true。
AbstractUnmarshallerImpl - javax.xml.bind.helpers 中的 类
部分默认 Unmarshaller 实现。
AbstractUnmarshallerImpl() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 的构造方法
AbstractWriter - javax.swing.text 中的 类
AbstractWriter 是一个抽象类，它实际执行元素树（包括属性）的写出工作。
AbstractWriter(Writer, Document) - 类 javax.swing.text.AbstractWriter 的构造方法
创建新的 AbstractWriter。
AbstractWriter(Writer, Document, int, int) - 类 javax.swing.text.AbstractWriter 的构造方法
创建新的 AbstractWriter。
AbstractWriter(Writer, Element) - 类 javax.swing.text.AbstractWriter 的构造方法
创建新的 AbstractWriter。
AbstractWriter(Writer, Element, int, int) - 类 javax.swing.text.AbstractWriter 的构造方法
创建新的 AbstractWriter。
accelerationPriority - 类 java.awt.Image 中的变量
用于加速此图像的优先级。
ACCELERATOR_KEY - 接口 javax.swing.Action 中的静态变量
用来存储将用作动作加速器的 KeyStroke 的键。
acceleratorFont - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
acceleratorForeground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
acceleratorSelectionForeground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
accept(Component) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
确定是否可以接受选择某个 Component 作为新的焦点拥有者。
accept(Component) - 类 java.awt.DefaultFocusTraversalPolicy 中的方法
确定是否可以接受选择某个 Component 作为新的焦点所有者。
accept(File) - 接口 java.io.FileFilter 中的方法
测试指定抽象路径名是否应该包含在某个路径名列表中。
accept(File, String) - 接口 java.io.FilenameFilter 中的方法
测试指定文件是否应该包含在某一文件列表中。
accept() - 类 java.net.ServerSocket 中的方法
侦听并接受到此套接字的连接。
accept(SocketImpl) - 类 java.net.SocketImpl 中的方法
接受连接。
accept() - 类 java.nio.channels.ServerSocketChannel 中的方法
接受到此通道套接字的连接。
accept(AnnotationValueVisitor<R, P>, P) - 接口 javax.lang.model.element.AnnotationValue 中的方法
将一个 visitor 应用到此值。
accept(ElementVisitor<R, P>, P) - 接口 javax.lang.model.element.Element 中的方法
将一个 visitor 应用到此元素。
accept(TypeVisitor<R, P>, P) - 接口 javax.lang.model.type.TypeMirror 中的方法
将一个 visitor 应用于此类型。
accept(File) - 类 javax.swing.filechooser.FileFilter 中的方法
此过滤器是否接受给定的文件。
accept(File) - 类 javax.swing.filechooser.FileNameExtensionFilter 中的方法
测试指定的文件，如果该文件被接受，则返回 true，否则返回 false。
accept(File) - 类 javax.swing.JFileChooser 中的方法
如果应该显示该文件，则返回 true。
accept(Component) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
确定是否可以接受选择指定的 Component 作为新的焦点所有者。
accept(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 中的方法
accept(Component) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
确定是否可以接受选择某个 Component 作为新的焦点拥有者。
accept(XMLEvent) - 接口 javax.xml.stream.EventFilter 中的方法
测试此事件是否为此流的一部分。
accept(XMLStreamReader) - 接口 javax.xml.stream.StreamFilter 中的方法
测试当前状态是否为此流的一部分。
ACCEPT_ALL - 接口 java.net.CookiePolicy 中的静态变量
一种预定义策略，表示接受所有 cookie。
ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识是否使用 AcceptAllFileFilter。
ACCEPT_NONE - 接口 java.net.CookiePolicy 中的静态变量
一种预定义策略，表示不接受任何 cookie。
ACCEPT_ONLY - 接口 org.ietf.jgss.GSSCredential 中的静态变量
凭据使用标志，要求凭据仅可用于上下文接受。
ACCEPT_ORIGINAL_SERVER - 接口 java.net.CookiePolicy 中的静态变量
一种预定义策略，表示只接受来自原始服务器的 cookie。
acceptChanges() - 接口 javax.sql.rowset.CachedRowSet 中的方法
将对此 CachedRowSet 对象所做的行更新、插入以及删除更改传播到底层数据源。
acceptChanges(Connection) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将所有行更新、插入以及删除更改传播到支持此 CachedRowSet 对象的数据源，使用指定的 Connection 对象建立到数据源的连接。
acceptDrag(int) - 类 java.awt.dnd.DropTargetContext 中的方法
接受该 Drag。
acceptDrag(int) - 类 java.awt.dnd.DropTargetDragEvent 中的方法
接受 drag。
acceptDrop(int) - 类 java.awt.dnd.DropTargetContext 中的方法
调用以指示放置操作是可接受的（使用指定的操作）。
acceptDrop(int) - 类 java.awt.dnd.DropTargetDropEvent 中的方法
使用指定的操作接受 drop。
ACCEPTING_JOBS - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的静态变量
打印机当前接受作业。
acceptNode(Node) - 接口 org.w3c.dom.ls.LSParserFilter 中的方法
此方法将由解析器在完成对每个节点的解析后调用。
acceptSecContext(byte[], int, int) - 接口 org.ietf.jgss.GSSContext 中的方法
由上下文接受端在收到同位体的标记后调用。
acceptSecContext(InputStream, OutputStream) - 接口 org.ietf.jgss.GSSContext 中的方法
由上下文接受端调用，以处理来自使用流的同位体的标记。
acceptsURL(String) - 接口 java.sql.Driver 中的方法
查询驱动程序是否认为它可以打开到给定 URL 的连接。
access - 类 org.omg.CORBA.ValueMember 中的变量
此 ValueMember 对象所描述的 value 成员的访问类型（公共或私有）。
AccessControlContext - java.security 中的 类
AccessControlContext 用于基于它所封装的上下文作出系统资源访问决定。
AccessControlContext(ProtectionDomain[]) - 类 java.security.AccessControlContext 的构造方法
创建带有给定 ProtectionDomain 集合的 AccessControlContext。
AccessControlContext(AccessControlContext, DomainCombiner) - 类 java.security.AccessControlContext 的构造方法
创建具有给定 AccessControlContext 和 DomainCombiner 的新 AccessControlContext。
AccessControlException - java.security 中的 异常
此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
AccessControlException(String) - 异常 java.security.AccessControlException 的构造方法
构造带指定详细消息的 AccessControlException。
AccessControlException(String, Permission) - 异常 java.security.AccessControlException 的构造方法
构造带指定详细消息和导致异常的请求权限的 AccessControlException。
AccessController - java.security 中的 类
AccessController 类用于与访问控制相关的操作和决定。
AccessException - java.rmi 中的 异常
AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
AccessException(String) - 异常 java.rmi.AccessException 的构造方法
构造带指定详细消息的 AccessException。
AccessException(String, Exception) - 异常 java.rmi.AccessException 的构造方法
构造带指定详细消息和嵌入异常的 AccessException。
Accessible - javax.accessibility 中的 接口
Accessible 接口是可访问性包的主接口。
ACCESSIBLE_ACTION_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示支持的动作集已更改的常量。
ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定组件的活动子级已更改的常量。
ACCESSIBLE_CARET_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleText 插入符已更改的常量。
ACCESSIBLE_CHILD_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定何时向对象添加或从对象移除 Accessible 子级的常量。
ACCESSIBLE_COMPONENT_BOUNDS_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
指示组件边界已更改的 PropertyChangeEvent。
ACCESSIBLE_DESCRIPTION_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleDescription 属性已更改的常量。
ACCESSIBLE_HYPERTEXT_OFFSET - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示超文本元素已收到焦点的常量。
ACCESSIBLE_INVALIDATE_CHILDREN - 类 javax.accessibility.AccessibleContext 中的静态变量
指示某个组件（例如树或文本）的子级已发生重要更改的 PropertyChangeEvent。
ACCESSIBLE_NAME_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleName 属性已更改的常量。
ACCESSIBLE_SELECTION_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleSelection 已更改的常量。
ACCESSIBLE_STATE_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleStateSet 属性已更改的常量。
ACCESSIBLE_TABLE_CAPTION_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示表标题已更改的常量。
ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示列描述已更改的常量。
ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示列标题已更改的常量。
ACCESSIBLE_TABLE_MODEL_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示表数据已更改的常量。
ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示行描述已更改的常量。
ACCESSIBLE_TABLE_ROW_HEADER_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示行标题已更改的常量。
ACCESSIBLE_TABLE_SUMMARY_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
用于指示表摘要已更改的常量。
ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED - 类 javax.accessibility.AccessibleContext 中的静态变量
指示文本属性已更改的 PropertyChangeEvent。
ACCESSIBLE_TEXT_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
指示文本已更改的 PropertyChangeEvent。
ACCESSIBLE_VALUE_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定 accessibleValue 属性已更改的常量。
ACCESSIBLE_VISIBLE_DATA_PROPERTY - 类 javax.accessibility.AccessibleContext 中的静态变量
用于确定对象的可见外观已更改的常量。
AccessibleAction - javax.accessibility 中的 接口
任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。
AccessibleAttributeSequence - javax.accessibility 中的 类
此类汇集共享相同连续属性集的文本的跨度，以及该属性集。
AccessibleAttributeSequence(int, int, AttributeSet) - 类 javax.accessibility.AccessibleAttributeSequence 的构造方法
构造带有给定参数的 AccessibleAttributeSequence。
accessibleAWTComponentHandler - 类 java.awt.Component.AccessibleAWTComponent 中的变量
accessibleAWTFocusHandler - 类 java.awt.Component.AccessibleAWTComponent 中的变量
AccessibleBundle - javax.accessibility 中的 类
用于维护强类型枚举的基类。
AccessibleBundle() - 类 javax.accessibility.AccessibleBundle 的构造方法
AccessibleComponent - javax.accessibility 中的 接口
屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
accessibleContainerHandler - 类 java.awt.Container.AccessibleAWTContainer 中的变量
accessibleContainerHandler - 类 javax.swing.JComponent.AccessibleJComponent 中的变量
AccessibleContext - javax.accessibility 中的 类
AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleContext() - 类 javax.accessibility.AccessibleContext 的构造方法
accessibleContext - 类 javax.swing.CellRendererPane 中的变量
accessibleContext - 类 javax.swing.JApplet 中的变量
accessibleContext - 类 javax.swing.JColorChooser 中的变量
accessibleContext - 类 javax.swing.JComponent 中的变量
与此 JComponent 关联的 AccessibleContext。
accessibleContext - 类 javax.swing.JDialog 中的变量
accessibleContext - 类 javax.swing.JFileChooser 中的变量
accessibleContext - 类 javax.swing.JFrame 中的变量
可访问的上下文属性。
accessibleContext - 类 javax.swing.JWindow 中的变量
可访问的上下文属性。
accessibleContext - 类 javax.swing.ProgressMonitor 中的变量
ProgressMonitor 的 AccessibleContext
accessibleDescription - 类 javax.accessibility.AccessibleContext 中的变量
包含对象描述的本地化 String。
AccessibleEditableText - javax.accessibility 中的 接口
在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。
AccessibleExtendedComponent - javax.accessibility 中的 接口
屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。
AccessibleExtendedTable - javax.accessibility 中的 接口
AccessibleExtendedTable 类提供了有关以二维表的格式呈现数据的用户界面组件的扩展信息。
AccessibleExtendedText - javax.accessibility 中的 接口
AccessibleExtendedText 接口包含 AccessibleText 接口所未提供的其他方法 应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleExtendedText 接口。
accessibleFocusHandler - 类 javax.swing.JComponent.AccessibleJComponent 中的变量
AccessibleHyperlink - javax.accessibility 中的 类
Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。
AccessibleHyperlink() - 类 javax.accessibility.AccessibleHyperlink 的构造方法
AccessibleHypertext - javax.accessibility 中的 接口
AccessibleHypertext 类是在显示器上显示超文本信息的所有类的基类。
AccessibleIcon - javax.accessibility 中的 接口
任何具有关联图标（例如按钮）的对象都应支持 AccessibleIcon 接口。
AccessibleKeyBinding - javax.accessibility 中的 接口
任何具有键盘绑定（例如可用于选择对象的键盘助记符和/或键盘快捷键）功能的对象都应支持 AccessibleKeyBinding 接口。
accessibleName - 类 javax.accessibility.AccessibleContext 中的变量
包含对象名称的本地化 String。
AccessibleObject - java.lang.reflect 中的 类
AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。
AccessibleObject() - 类 java.lang.reflect.AccessibleObject 的构造方法
构造方法：仅供 Java 虚拟机使用。
accessibleParent - 类 javax.accessibility.AccessibleContext 中的变量
此对象的可访问父级。
AccessibleRelation - javax.accessibility 中的 类
AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。
AccessibleRelation(String) - 类 javax.accessibility.AccessibleRelation 的构造方法
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
AccessibleRelation(String, Object) - 类 javax.accessibility.AccessibleRelation 的构造方法
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
AccessibleRelation(String, Object[]) - 类 javax.accessibility.AccessibleRelation 的构造方法
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
AccessibleRelationSet - javax.accessibility 中的 类
AccessibleRelationSet 类确定了组件的关系集。
AccessibleRelationSet() - 类 javax.accessibility.AccessibleRelationSet 的构造方法
创建新的空关系集。
AccessibleRelationSet(AccessibleRelation[]) - 类 javax.accessibility.AccessibleRelationSet 的构造方法
创建具有传入的关系数组中所包含的初始关系集的新关系。
AccessibleResourceBundle - javax.accessibility 中的 类
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。
AccessibleResourceBundle() - 类 javax.accessibility.AccessibleResourceBundle 的构造方法
已过时。
AccessibleRole - javax.accessibility 中的 类
AccessibleRole 类确定组件的职责。
AccessibleRole(String) - 类 javax.accessibility.AccessibleRole 的构造方法
使用与语言环境无关的给定键创建新的 AccessibleRole。
AccessibleSelection - javax.accessibility 中的 接口
此 AccessibleSelection 接口提供了辅助技术的标准机制，以确定当前选定了哪些子级，以及修改选项集合。
AccessibleState - javax.accessibility 中的 类
AccessibleState 类描述了组件的特殊状态。
AccessibleState(String) - 类 javax.accessibility.AccessibleState 的构造方法
使用给定的与语言环境无关的键创建新的 AccessibleState。
AccessibleStateSet - javax.accessibility 中的 类
AccessibleStateSet 类确定组件的状态集。
AccessibleStateSet() - 类 javax.accessibility.AccessibleStateSet 的构造方法
创建新的空状态集。
AccessibleStateSet(AccessibleState[]) - 类 javax.accessibility.AccessibleStateSet 的构造方法
创建一个新状态，其初始状态集包含在传入的状态数组中。
AccessibleStreamable - javax.accessibility 中的 接口
任何表示显示屏组件背后原始流的组件的 AccessibleContext 都必须实现 AccessibleStreamable 接口。
AccessibleTable - javax.accessibility 中的 接口
AccessibleTable 类描述了以二维表格式呈现数据的用户界面组件。
AccessibleTableModelChange - javax.accessibility 中的 接口
AccessibleTableModelChange 接口描述了表模型的更改。
AccessibleText - javax.accessibility 中的 接口
所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。
AccessibleTextSequence - javax.accessibility 中的 类
此类汇集文本区域的关键细节。
AccessibleTextSequence(int, int, String) - 类 javax.accessibility.AccessibleTextSequence 的构造方法
构造带有给定参数的 AccessibleTextSequence。
AccessibleValue - javax.accessibility 中的 接口
任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。
ACCESSORY_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
声明正在使用不同的 accessory 组件（例如预览文件）。
AccountException - javax.security.auth.login 中的 异常
一般的帐户异常。
AccountException() - 异常 javax.security.auth.login.AccountException 的构造方法
构造不带详细消息的 AccountException。
AccountException(String) - 异常 javax.security.auth.login.AccountException 的构造方法
构造带指定详细消息的 AccountException。
AccountExpiredException - javax.security.auth.login 中的 异常
当用户帐户到期时抛出此异常。
AccountExpiredException() - 异常 javax.security.auth.login.AccountExpiredException 的构造方法
构造不带详细消息的 AccountExpiredException。
AccountExpiredException(String) - 异常 javax.security.auth.login.AccountExpiredException 的构造方法
构造带指定详细消息的 AccountExpiredException。
AccountLockedException - javax.security.auth.login 中的 异常
帐户被锁定时抛出此异常。
AccountLockedException() - 异常 javax.security.auth.login.AccountLockedException 的构造方法
构造不带详细消息的 AccountLockedException。
AccountLockedException(String) - 异常 javax.security.auth.login.AccountLockedException 的构造方法
构造带指定详细消息的 AccountLockedException。
AccountNotFoundException - javax.security.auth.login 中的 异常
未找到帐户时抛出此异常。
AccountNotFoundException() - 异常 javax.security.auth.login.AccountNotFoundException 的构造方法
构造不带详细消息的 AccountNotFoundException。
AccountNotFoundException(String) - 异常 javax.security.auth.login.AccountNotFoundException 的构造方法
构造带指定详细消息的 AccountNotFoundException。
Acl - java.security.acl 中的 接口
表示访问控制列表 (ACL) 的接口。
AclEntry - java.security.acl 中的 接口
这是用于表示访问控制列表 (ACL) 中某个项的接口。
AclNotFoundException - java.security.acl 中的 异常
如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
AclNotFoundException() - 异常 java.security.acl.AclNotFoundException 的构造方法
构造一个 AclNotFoundException。
acos(double) - 类 java.lang.Math 中的静态方法
返回一个值的反余弦；返回的角度范围在 0.0 到 pi 之间。
acos(double) - 类 java.lang.StrictMath 中的静态方法
返回值的反余弦；返回角的范围在 0.0 到 pi 之间。
acquire(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以独占模式获取，忽略中断。
acquire(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以独占模式获取对象，忽略中断。
acquire() - 类 java.util.concurrent.Semaphore 中的方法
从此信号量获取一个许可，在提供一个许可前一直将线程阻塞，否则线程被中断。
acquire(int) - 类 java.util.concurrent.Semaphore 中的方法
从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞，或者线程已被中断。
acquireInterruptibly(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以独占模式获取，如果被中断则中止。
acquireInterruptibly(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以独占模式获取对象，如果被中断则中止。
acquireShared(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以共享模式获取，忽略中断。
acquireShared(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以共享模式获取对象，忽略中断。
acquireSharedInterruptibly(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以共享模式获取，如果被中断则中止。
acquireSharedInterruptibly(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以共享模式获取对象，如果被中断则中止。
acquireUninterruptibly() - 类 java.util.concurrent.Semaphore 中的方法
从此信号量中获取许可，在有可用的许可前将其阻塞。
acquireUninterruptibly(int) - 类 java.util.concurrent.Semaphore 中的方法
从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞。
action(Event, Object) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。
ACTION - 类 javax.management.MBeanOperationInfo 中的静态变量
指示该操作与写入操作类似，并将以某种方式修改 MBean，通常是写入某个值或更改某个配置。
Action - javax.swing 中的 接口
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。
ACTION - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ACTION_APPEND_AS_CHILDREN - 接口 org.w3c.dom.ls.LSParser 中的静态变量
将解析操作的结果追加为上下文节点的子节点。
ACTION_COMMAND_KEY - 接口 javax.swing.Action 中的静态变量
用来确定 ActionEvent 的命令 String 的键，ActionEvent 是在 Action 因驻留在与 JComponent 关联的 Keymap 中而被通知时所创建的。
ACTION_COPY - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“复制”操作的 int 值。
ACTION_COPY_OR_MOVE - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“复制”或“移动”操作的 int 值。
ACTION_EVENT - 类 java.awt.Event 中的静态变量
此事件指示用户想要某个事件发生。
ACTION_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择操作事件的事件掩码。
ACTION_FIRST - 类 java.awt.event.ActionEvent 中的静态变量
用于标识动作事件的 ID 序列的起始编号。
ACTION_INFO - 类 javax.management.MBeanOperationInfo 中的静态变量
指示该操作与读取和写入操作类似。
ACTION_INSERT_AFTER - 接口 org.w3c.dom.ls.LSParser 中的静态变量
把解析操作的结果作为上下文节点的直接后续兄弟节点插入。
ACTION_INSERT_BEFORE - 接口 org.w3c.dom.ls.LSParser 中的静态变量
把解析操作的结果作为上下文节点的直接前置兄弟节点插入。
ACTION_LAST - 类 java.awt.event.ActionEvent 中的静态变量
用于标识动作事件的 ID 序列的结束编号。
ACTION_LINK - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“链接”操作的 int 值。
ACTION_MOVE - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“移动”操作的 int 值。
ACTION_NONE - 类 java.awt.dnd.DnDConstants 中的静态变量
表示无操作的 int 值。
ACTION_PERFORMED - 类 java.awt.event.ActionEvent 中的静态变量
此事件 id 指示发生了有意义的动作。
ACTION_REFERENCE - 类 java.awt.dnd.DnDConstants 中的静态变量
表示“引用”操作的 int 值（等同于 ACTION_LINK）。
ACTION_REPLACE - 接口 org.w3c.dom.ls.LSParser 中的静态变量
用解析操作的结果替换上下文节点。
ACTION_REPLACE_CHILDREN - 接口 org.w3c.dom.ls.LSParser 中的静态变量
用解析操作的结果替换上下文节点的所有子节点。
actionCommand - 类 javax.swing.DefaultButtonModel 中的变量
按钮所触发的动作命令字符串。
actionCommand - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
ActionEvent - java.awt.event 中的 类
指示发生了组件定义的动作的语义事件。
ActionEvent(Object, int, String) - 类 java.awt.event.ActionEvent 的构造方法
构造一个 ActionEvent 对象。
ActionEvent(Object, int, String, int) - 类 java.awt.event.ActionEvent 的构造方法
使用修改键构造一个 ActionEvent 对象。
ActionEvent(Object, int, String, long, int) - 类 java.awt.event.ActionEvent 的构造方法
使用指定修改键和时间戳构造一个 ActionEvent 对象。
ActionListener - java.awt.event 中的 接口
用于接收操作事件的侦听器接口。
actionListener - 类 javax.swing.AbstractButton 中的变量
按钮模型的 ActionListener。
ActionMap - javax.swing 中的 类
ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
ActionMap() - 类 javax.swing.ActionMap 的构造方法
创建一个没有父级和映射关系的 ActionMap。
ActionMapUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 javax.swing.ActionMap 的子类。
ActionMapUIResource() - 类 javax.swing.plaf.ActionMapUIResource 的构造方法
actionName - 类 javax.swing.text.JTextComponent.KeyBinding 中的变量
键的操作名称。
actionPerformed(ActionEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 actionPerformed 方法处理 actionPerformed 事件。
actionPerformed(ActionEvent) - 类 java.awt.dnd.DropTarget.DropTargetAutoScroller 中的方法
导致发生自动滚动
actionPerformed(ActionEvent) - 接口 java.awt.event.ActionListener 中的方法
发生操作时调用。
actionPerformed(ActionEvent) - 类 java.awt.List.AccessibleAWTList 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
在执行操作时，编辑被终止。
actionPerformed(ActionEvent) - 类 javax.swing.JComboBox 中的方法
此方法由于实现的副作用而存在的公共方法。
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的方法
因 Timer 而将此方法作为公共方法。
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.BeepAction 中的方法
触发此动作时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.CopyAction 中的方法
触发此动作时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.CutAction 中的方法
触发此动作时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction 中的方法
动作触发时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.InsertBreakAction 中的方法
触发此动作时执行该操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.InsertContentAction 中的方法
此动作触发时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.InsertTabAction 中的方法
此动作触发时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.DefaultEditorKit.PasteAction 中的方法
触发此动作时执行的操作。
actionPerformed(ActionEvent) - 类 javax.swing.text.html.FormView 中的方法
负责处理 ActionEvent。
actionPerformed(ActionEvent) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的方法
将 HTML 插入文档。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.AlignmentAction 中的方法
设置对齐方式。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.BoldAction 中的方法
切换粗体属性。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.FontFamilyAction 中的方法
设置字体系列。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.FontSizeAction 中的方法
设置字体大小。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.ForegroundAction 中的方法
设置前景色。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.ItalicAction 中的方法
切换斜体属性。
actionPerformed(ActionEvent) - 类 javax.swing.text.StyledEditorKit.UnderlineAction 中的方法
切换下划线属性。
actionPerformed(ActionEvent) - 类 javax.swing.ToolTipManager.insideTimerAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.ToolTipManager.outsideTimerAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.ToolTipManager.stillInsideTimerAction 中的方法
actionPerformed(ActionEvent) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
计时器被激发时传递消息，这将启动编辑会话。
actionPropertyChanged(Action, String) - 类 javax.swing.AbstractButton 中的方法
更新按钮的状态以响应相关的操作中的属性更改。
actionPropertyChanged(Action, String) - 类 javax.swing.JComboBox 中的方法
更新组合框的状态以响应关联动作中的属性更改。
actionPropertyChanged(Action, String) - 类 javax.swing.JMenuItem 中的方法
更新按钮的状态以响应相关的操作中的属性更改。
actionPropertyChanged(Action, String) - 类 javax.swing.JTextField 中的方法
更新文本字段的状态以响应关联动作中的属性更改。
Activatable - java.rmi.activation 中的 类
Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
Activatable(String, MarshalledObject<?>, boolean, int) - 类 java.rmi.activation.Activatable 的构造方法
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
Activatable(String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.activation.Activatable 的构造方法
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
Activatable(ActivationID, int) - 类 java.rmi.activation.Activatable 的构造方法
构造方法用于在指定端口上激活/导出对象。
Activatable(ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.activation.Activatable 的构造方法
构造方法用于在指定端口上激活/导出对象。
activate() - 接口 java.awt.im.spi.InputMethod 中的方法
激活输入方法，以便立即进行输入处理。
activate(Applet) - 接口 java.beans.AppletInitializer 中的方法
激活和/或将 Applet 标记为激活。
activate(boolean) - 类 java.rmi.activation.ActivationID 中的方法
激活此 id 的对象。
activate(ActivationID, boolean) - 接口 java.rmi.activation.Activator 中的方法
激活与激活标识符 id 关联的对象。
activate(IIOParam) - 接口 javax.imageio.IIOParamController 中的方法
激活控制器。
activate(IIOMetadata) - 接口 javax.imageio.metadata.IIOMetadataController 中的方法
激活控制器。
activate() - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作将 POA 管理器更改为激活状态，促使关联的 POA 开始处理请求。
activate_object(Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作生成一个 Object Id，并将该 Object Id 和指定的 servant 输入 Active Object Map。
activate_object_with_id(byte[], Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作将指定 Object Id 与指定 servant 之间的关联输入 Active Object Map。
activateController() - 类 javax.imageio.IIOParam 中的方法
激活为此 IIOParam 对象安装的 IIOParamController，并返回得到的值。
activateController() - 类 javax.imageio.metadata.IIOMetadata 中的方法
激活为此 IIOMetadata 对象安装的 IIOMetadataController，并返回所得到的值。
ACTIVATED - 类 javax.swing.event.HyperlinkEvent.EventType 中的静态变量
激活类型。
ActivateFailedException - java.rmi.activation 中的 异常
在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
ActivateFailedException(String) - 异常 java.rmi.activation.ActivateFailedException 的构造方法
构造带指定详细消息的 ActivateFailedException。
ActivateFailedException(String, Exception) - 异常 java.rmi.activation.ActivateFailedException 的构造方法
构造带指定详细消息和嵌套异常的 ActivateFailedException。
activateFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
此方法将激活 f，将它移动到前台。
activateFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常指示此窗体拥有焦点。
activateFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
窗体变为被选择状态时调用此方法。
activateLink(int, JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit.LinkController 中的方法
如果给定位置表示一个链接，则调用关联 JEditorPane 上的 linkActivated。
ActivationDataFlavor - javax.activation 中的 类
ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。
ActivationDataFlavor(Class, String, String) - 类 javax.activation.ActivationDataFlavor 的构造方法
构造一个表示任意 Java 对象的 DataFlavor。
ActivationDataFlavor(Class, String) - 类 javax.activation.ActivationDataFlavor 的构造方法
构造一个表示 MimeType 的 DataFlavor。
ActivationDataFlavor(String, String) - 类 javax.activation.ActivationDataFlavor 的构造方法
构造一个表示 MimeType 的 DataFlavor。
ActivationDesc - java.rmi.activation 中的 类
激活描述符包含激活对象所必需的信息： 对象的组标识符， 对象的完全限定的类名， 对象的代码基（类中的位置），一个代码基 URL 路径， 对象的重启“模式”，以及 一个可包含特定于对象的初始化数据的“编组”对象。
ActivationDesc(String, String, MarshalledObject<?>) - 类 java.rmi.activation.ActivationDesc 的构造方法
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(String, String, MarshalledObject<?>, boolean) - 类 java.rmi.activation.ActivationDesc 的构造方法
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>) - 类 java.rmi.activation.ActivationDesc 的构造方法
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>, boolean) - 类 java.rmi.activation.ActivationDesc 的构造方法
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。
ActivationException - java.rmi.activation 中的 异常
激活接口所使用的一般异常。
ActivationException() - 异常 java.rmi.activation.ActivationException 的构造方法
构造一个 ActivationException。
ActivationException(String) - 异常 java.rmi.activation.ActivationException 的构造方法
构造带指定详细消息的 ActivationException。
ActivationException(String, Throwable) - 异常 java.rmi.activation.ActivationException 的构造方法
构造带指定详细消息和原因的 ActivationException。
ActivationGroup - java.rmi.activation 中的 类
ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
ActivationGroup(ActivationGroupID) - 类 java.rmi.activation.ActivationGroup 的构造方法
用给定的激活组标识符创建一个激活组。
ActivationGroup_Stub - java.rmi.activation 中的 类
ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。
ActivationGroup_Stub(RemoteRef) - 类 java.rmi.activation.ActivationGroup_Stub 的构造方法
为 ActivationGroup 类构造一个 stub。
ActivationGroupDesc - java.rmi.activation 中的 类
激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。
ActivationGroupDesc(Properties, ActivationGroupDesc.CommandEnvironment) - 类 java.rmi.activation.ActivationGroupDesc 的构造方法
使用组实现的系统默认值和代码基来构造一个组描述符。
ActivationGroupDesc(String, String, MarshalledObject<?>, Properties, ActivationGroupDesc.CommandEnvironment) - 类 java.rmi.activation.ActivationGroupDesc 的构造方法
指定一个用于该组的替代组实现和执行环境。
ActivationGroupDesc.CommandEnvironment - java.rmi.activation 中的 类
ActivationGroup 实现的启动选项。
ActivationGroupDesc.CommandEnvironment(String, String[]) - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 的构造方法
用所有必要的信息创建一个 CommandEnvironment。
ActivationGroupID - java.rmi.activation 中的 类
针对一个注册激活组的标识符，它完成几个目标： 在激活系统中唯一地标识该组，以及 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。
ActivationGroupID(ActivationSystem) - 类 java.rmi.activation.ActivationGroupID 的构造方法
构造一个唯一的组 id。
ActivationID - java.rmi.activation 中的 类
激活利用特定的标识符来表示远程对象，对象能随着时间被激活。
ActivationID(Activator) - 类 java.rmi.activation.ActivationID 的构造方法
ActivationID 的构造方法带有单个参数 activator，这指定了一个对激活器（负责激活与此标识符相关联的对象）的远程引用。
ActivationInstantiator - java.rmi.activation 中的 接口
ActivationInstantiator 负责创建“可激活”对象的实例。
ActivationMonitor - java.rmi.activation 中的 接口
一个 ActivationMonitor 特定于一个 ActivationGroup，当一个组通过对 ActivationSystem.activeGroup 的调用（这是内部完成的）被报告为活动时，获得一个 ActivationMonitor。
ActivationSystem - java.rmi.activation 中的 接口
ActivationSystem 为注册组和在那些组中要被激活的“可激活”对象提供一种方式。
Activator - java.rmi.activation 中的 接口
Activator 方便了远程对象激活。
ACTIVATOR_ID - 类 java.rmi.server.ObjID 中的静态变量
激活程序的已知 ObjID 的对象数。
ACTIVE - 类 javax.accessibility.AccessibleState 中的静态变量
指示某个窗口当前是活动窗口。
active - 类 javax.sound.midi.VoiceStatus 中的变量
指示声音当前是否正在处理 MIDI 音符。
ACTIVE - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/ACTIVE.java。
ACTIVE - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
ACTIVE_CAPTION - 类 java.awt.SystemColor 中的静态变量
SystemColor.activeCaption 系统颜色的数组索引。
ACTIVE_CAPTION_BORDER - 类 java.awt.SystemColor 中的静态变量
SystemColor.activeCaptionBorder 系统颜色的数组索引。
ACTIVE_CAPTION_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.activeCaptionText 系统颜色的数组索引。
ACTIVE_SENSING - 类 javax.sound.midi.ShortMessage 中的静态变量
ACTIVE_SENSING 消息的状态字节（0xFE 或 254）。
activeCaption - 类 java.awt.SystemColor 中的静态变量
为当前活动窗口的窗口标题提供的背景色。
activeCaptionBorder - 类 java.awt.SystemColor 中的静态变量
为当前活动窗口的边框提供的颜色。
activeCaptionText - 类 java.awt.SystemColor 中的静态变量
为当前活动窗口的窗口标题文本提供的颜色。
activeCount() - 类 java.lang.Thread 中的静态方法
返回当前线程的线程组中活动线程的数目。
activeCount() - 类 java.lang.ThreadGroup 中的方法
返回此线程组中活动线程的估计数。
ActiveEvent - java.awt 中的 接口
知道如何对自身进行指派的事件的接口。
activeGroup(ActivationGroupID, ActivationInstantiator, long) - 接口 java.rmi.activation.ActivationSystem 中的方法
通过回调来通知激活系统该组现在是活动的。
activeGroupCount() - 类 java.lang.ThreadGroup 中的方法
返回此线程组中活动线程组的估计数。
activeObject(ActivationID, Remote) - 类 java.rmi.activation.ActivationGroup 中的方法
当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
activeObject(ActivationID, MarshalledObject<? extends Remote>) - 类 java.rmi.activation.ActivationGroup 中的方法
如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
activeObject(ActivationID, MarshalledObject<? extends Remote>) - 接口 java.rmi.activation.ActivationMonitor 中的方法
通知某个对象现在是活动的。
ACTIVITY_COMPLETED - org.omg.CORBA 中的 异常
ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
ACTIVITY_COMPLETED() - 异常 org.omg.CORBA.ACTIVITY_COMPLETED 的构造方法
构造一个 ACTIVITY_COMPLETED 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
ACTIVITY_COMPLETED(String) - 异常 org.omg.CORBA.ACTIVITY_COMPLETED 的构造方法
使用指定消息构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_COMPLETED(int, CompletionStatus) - 异常 org.omg.CORBA.ACTIVITY_COMPLETED 的构造方法
使用指定次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_COMPLETED(String, int, CompletionStatus) - 异常 org.omg.CORBA.ACTIVITY_COMPLETED 的构造方法
使用指定消息、次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。
ACTIVITY_REQUIRED - org.omg.CORBA 中的 异常
ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
ACTIVITY_REQUIRED() - 异常 org.omg.CORBA.ACTIVITY_REQUIRED 的构造方法
构造一个 ACTIVITY_REQUIRED 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
ACTIVITY_REQUIRED(String) - 异常 org.omg.CORBA.ACTIVITY_REQUIRED 的构造方法
使用指定消息构造一个 ACTIVITY_REQUIRED 异常。
ACTIVITY_REQUIRED(int, CompletionStatus) - 异常 org.omg.CORBA.ACTIVITY_REQUIRED 的构造方法
使用指定次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
ACTIVITY_REQUIRED(String, int, CompletionStatus) - 异常 org.omg.CORBA.ACTIVITY_REQUIRED 的构造方法
使用指定消息、次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。
ActivityCompletedException - javax.activity 中的 异常
任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
ActivityCompletedException() - 异常 javax.activity.ActivityCompletedException 的构造方法
构造一个新实例，其详细消息为 null。
ActivityCompletedException(String) - 异常 javax.activity.ActivityCompletedException 的构造方法
构造带有指定详细消息的新实例。
ActivityCompletedException(Throwable) - 异常 javax.activity.ActivityCompletedException 的构造方法
构造带有指定 cause 的新 throwable。
ActivityCompletedException(String, Throwable) - 异常 javax.activity.ActivityCompletedException 的构造方法
构造带有指定详细消息和 cause 的新 throwable。
ActivityRequiredException - javax.activity 中的 异常
如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
ActivityRequiredException() - 异常 javax.activity.ActivityRequiredException 的构造方法
构造一个新实例，其详细消息为 null。
ActivityRequiredException(String) - 异常 javax.activity.ActivityRequiredException 的构造方法
构造带有指定详细消息的新实例。
ActivityRequiredException(Throwable) - 异常 javax.activity.ActivityRequiredException 的构造方法
构造带有指定 cause 的新 throwable。
ActivityRequiredException(String, Throwable) - 异常 javax.activity.ActivityRequiredException 的构造方法
构造带有指定详细消息和 cause 的新 throwable。
AD - 类 java.util.GregorianCalendar 中的静态变量
ERA 字段的值指示公元后（耶稣纪元后）的时期（也称为 CE）。
adapter_id() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回对象适配器的不透明标识符。
adapter_manager_state_changed(int, short) - 接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 中的方法
只要适配器管理器的状态更改时便调用此方法。
adapter_name() - 接口 org.omg.PortableInterceptor.ObjectReferenceTemplate 中的方法
adapter_name() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回字符串序列，这些字符串标识正处理此请求的对象适配器实例。
adapter_state_changed(ObjectReferenceTemplate[], short) - 接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 中的方法
只要对象适配器的状态发生更改，并且该状态更改不是由适配器管理器引起的，便调用此方法。
adapter_template() - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象引用模板。
AdapterActivator - org.omg.PortableServer 中的 接口
一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
AdapterActivatorOperations - org.omg.PortableServer 中的 接口
一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
AdapterAlreadyExists - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
AdapterAlreadyExists() - 异常 org.omg.PortableServer.POAPackage.AdapterAlreadyExists 的构造方法
AdapterAlreadyExists(String) - 异常 org.omg.PortableServer.POAPackage.AdapterAlreadyExists 的构造方法
AdapterAlreadyExistsHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java。
AdapterAlreadyExistsHelper() - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 的构造方法
AdapterInactive - org.omg.PortableServer.POAManagerPackage 中的 异常
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。
AdapterInactive() - 异常 org.omg.PortableServer.POAManagerPackage.AdapterInactive 的构造方法
AdapterInactive(String) - 异常 org.omg.PortableServer.POAManagerPackage.AdapterInactive 的构造方法
AdapterInactiveHelper - org.omg.PortableServer.POAManagerPackage 中的 类
org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java。
AdapterInactiveHelper() - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 的构造方法
AdapterManagerIdHelper - org.omg.PortableInterceptor 中的 类
适配器管理器标识符。
AdapterManagerIdHelper() - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 的构造方法
AdapterNameHelper - org.omg.PortableInterceptor 中的 类
对象适配器的名称。
AdapterNameHelper() - 类 org.omg.PortableInterceptor.AdapterNameHelper 的构造方法
AdapterNonExistent - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
AdapterNonExistent() - 异常 org.omg.PortableServer.POAPackage.AdapterNonExistent 的构造方法
AdapterNonExistent(String) - 异常 org.omg.PortableServer.POAPackage.AdapterNonExistent 的构造方法
AdapterNonExistentHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java。
AdapterNonExistentHelper() - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 的构造方法
AdapterStateHelper - org.omg.PortableInterceptor 中的 类
对象适配器状态的类型。
AdapterStateHelper() - 类 org.omg.PortableInterceptor.AdapterStateHelper 的构造方法
add(ComponentListener, ComponentListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加组件侦听器 a 和组件侦听器 b，并返回得到的多路广播侦听器。
add(ContainerListener, ContainerListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加容器侦听器 a 和容器侦听器 b，并返回得到的多路广播侦听器。
add(FocusListener, FocusListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加焦点侦听器 a 和焦点侦听器 b，并返回得到的多路广播侦听器。
add(KeyListener, KeyListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加键侦听器 a 和键侦听器 b，并返回得到的多路广播侦听器。
add(MouseListener, MouseListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加鼠标侦听器 a 和鼠标侦听器 b，并返回得到的多路广播侦听器。
add(MouseMotionListener, MouseMotionListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加鼠标移动侦听器 a 和鼠标移动侦听器 b，并返回得到的多路广播侦听器。
add(WindowListener, WindowListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加窗口侦听器 a 和窗口侦听器 b，并返回得到的多路广播侦听器。
add(WindowStateListener, WindowStateListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加窗口状态侦听器 a 和窗口状态侦听器 b，并返回得到的多路广播侦听器。
add(WindowFocusListener, WindowFocusListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加窗口焦点侦听器 a 和窗口焦点侦听器 b，并返回得到的多路广播侦听器。
add(ActionListener, ActionListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加操作侦听器 a 和操作侦听器 b，并返回得到的多路广播侦听器。
add(ItemListener, ItemListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加项侦听器 a 和项侦听器 b，并返回得到的多路广播侦听器。
add(AdjustmentListener, AdjustmentListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加调整侦听器 a 和调整侦听器 b，并返回得到的多路广播侦听器。
add(TextListener, TextListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
add(InputMethodListener, InputMethodListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加输入方法侦听器 a 和输入方法侦听器 b，并返回得到的多路广播侦听器。
add(HierarchyListener, HierarchyListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加层次结构侦听器 a 和层次结构侦听器 b，并返回得到的多路广播侦听器。
add(HierarchyBoundsListener, HierarchyBoundsListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加层次结构边界侦听器 a 和层次结构边界侦听器 b，并返回得到的多路广播侦听器。
add(MouseWheelListener, MouseWheelListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
添加鼠标滚轮侦听器 a 和鼠标滚轮侦听器 b，并返回得到的多路广播侦听器。
add(String) - 类 java.awt.Choice 中的方法
将一个项添加到此 Choice 菜单中。
add(PopupMenu) - 类 java.awt.Component 中的方法
向组件添加指定的弹出菜单。
add(Component) - 类 java.awt.Container 中的方法
将指定组件追加到此容器的尾部。
add(String, Component) - 类 java.awt.Container 中的方法
将指定组件添加到此容器中。
add(Component, int) - 类 java.awt.Container 中的方法
将指定组件添加到此容器的给定位置上。
add(Component, Object) - 类 java.awt.Container 中的方法
将指定的组件添加到此容器的尾部。
add(Component, Object, int) - 类 java.awt.Container 中的方法
使用指定约束，将指定组件添加到此容器的指定索引所在的位置上。
add(Area) - 类 java.awt.geom.Area 中的方法
将指定 Area 的形状添加到此 Area 的形状中。
add(double, double) - 类 java.awt.geom.Rectangle2D 中的方法
将由 double 精度参数 newx 和 newy 指定的点添加到此 Rectangle2D 中。
add(Point2D) - 类 java.awt.geom.Rectangle2D 中的方法
将 Point2D 对象 pt 添加到此 Rectangle2D 中。
add(Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的方法
将 Rectangle2D 对象添加到此 Rectangle2D 中。
add(Object) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Object 添加到此参数列表。
add(byte) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Byte 添加到此参数列表。
add(char) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Character 添加到此参数列表。
add(short) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Short 添加到此参数列表。
add(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Integer 添加到此参数列表。
add(long) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Long 添加到此参数列表。
add(float) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Float 添加到此参数列表。
add(double) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个 Double 添加到此参数列表。
add(String) - 类 java.awt.List 中的方法
向滚动列表的末尾添加指定的项。
add(String, int) - 类 java.awt.List 中的方法
向滚动列表中索引指示的位置添加指定的项。
add(MenuItem) - 类 java.awt.Menu 中的方法
将指定的菜单项添加到此菜单。
add(String) - 类 java.awt.Menu 中的方法
将带有指定标签的项添加到此菜单。
add(Menu) - 类 java.awt.MenuBar 中的方法
将指定的菜单添加到菜单栏。
add(int, int) - 类 java.awt.Rectangle 中的方法
将一个由整数参数 newx,newy 指定的点添加到此 Rectangle 的边界。
add(Point) - 类 java.awt.Rectangle 中的方法
将指定的 Point 添加到此 Rectangle 的边界。
add(Rectangle) - 类 java.awt.Rectangle 中的方法
将一个 Rectangle 添加到此 Rectangle 中。
add(RenderingHints) - 类 java.awt.RenderingHints 中的方法
将指定 RenderingHints 对象中的所有键和相应的值添加到此 RenderingHints 对象中。
add(TrayIcon) - 类 java.awt.SystemTray 中的方法
将 TrayIcon 添加到 SystemTray。
add(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在此 BeanContext 中添加/嵌套一个子级。
add(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this + augend)，其标度为 max(this.scale(), augend.scale())。
add(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
add(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this + val) 的 BigInteger。
add(URI, HttpCookie) - 接口 java.net.CookieStore 中的方法
将一个 HTTP cookie 添加到存储区中。
add(Permission) - 类 java.security.PermissionCollection 中的方法
将一个权限对象添加到当前权限对象的集合。
add(Permission) - 类 java.security.Permissions 中的方法
将一个 permission 对象添加到该权限所属的类的 PermissionCollection 中。
add(E) - 类 java.util.AbstractCollection 中的方法
确保此 collection 包含指定的元素（可选操作）。
add(E) - 类 java.util.AbstractList 中的方法
将指定的元素添加到此列表的尾部（可选操作）。
add(int, E) - 类 java.util.AbstractList 中的方法
在列表的指定位置插入指定元素（可选操作）。
add(E) - 类 java.util.AbstractQueue 中的方法
将指定的元素插入到此队列中（如果立即可行且不会违反容量限制），在成功时返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
add(int, E) - 类 java.util.AbstractSequentialList 中的方法
在此列表中的指定位置上插入指定的元素（可选操作）。
add(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的末尾。
add(E) - 类 java.util.ArrayList 中的方法
将指定的元素添加到此列表的尾部。
add(int, E) - 类 java.util.ArrayList 中的方法
将指定的元素插入此列表中的指定位置。
add(int, int) - 类 java.util.Calendar 中的方法
根据日历的规则，为给定的日历字段添加或减去指定的时间量。
add(E) - 接口 java.util.Collection 中的方法
确保此 collection 包含指定的元素（可选操作）。
add(E) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
将指定的元素插入到此队列的尾部（如果立即可行且不会超过该队列的容量），在成功时返回 true，如果此队列已满，则抛出 IllegalStateException。
add(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
Inserts the 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则抛出 IllegalStateException。
add(E) - 接口 java.util.concurrent.BlockingQueue 中的方法
将指定元素插入此队列中（如果立即可行且不会违反容量限制），成功时返回 true，如果当前没有可用的空间，则抛出 IllegalStateException。
add(E) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
将指定元素插入此队列的尾部。
add(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
如果此 set 中不包含指定元素，则添加指定元素。
add(E) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
将指定元素添加到此列表的尾部。
add(int, E) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
在此列表的指定位置上插入指定元素。
add(E) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果指定元素并不存在于此 set 中，则添加它。
add(E) - 类 java.util.concurrent.DelayQueue 中的方法
将指定元素插入此延迟队列中。
add(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
在不违反容量限制的情况下，将指定的元素插入此双端队列的末尾。
add(E) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
将指定元素插入此优先级队列。
add(E) - 接口 java.util.Deque 中的方法
将指定元素插入此双端队列所表示的队列（换句话说，此双端队列的尾部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
add(int, int) - 类 java.util.GregorianCalendar 中的方法
根据日历规则，将指定的（有符号的）时间量添加到给定的日历字段中。
add(E) - 类 java.util.HashSet 中的方法
如果此 set 中尚未包含指定元素，则添加指定元素。
add(E) - 类 java.util.LinkedList 中的方法
将指定元素添加到此列表的结尾。
add(int, E) - 类 java.util.LinkedList 中的方法
在此列表中指定的位置插入指定的元素。
add(E) - 接口 java.util.List 中的方法
向列表的尾部添加指定的元素（可选操作）。
add(int, E) - 接口 java.util.List 中的方法
在列表的指定位置插入指定元素（可选操作）。
add(E) - 接口 java.util.ListIterator 中的方法
将指定的元素插入列表（可选操作）。
add(E) - 类 java.util.PriorityQueue 中的方法
将指定的元素插入此优先级队列。
add(E) - 接口 java.util.Queue 中的方法
将指定的元素插入此队列（如果立即可行且不会违反容量限制），在成功时返回 true，如果当前没有可用的空间，则抛出 IllegalStateException。
add(E) - 接口 java.util.Set 中的方法
如果 set 中尚未存在指定的元素，则添加此元素（可选操作）。
add(E) - 类 java.util.TreeSet 中的方法
将指定的元素添加到此 set（如果该元素尚未存在于 set 中）。
add(E) - 类 java.util.Vector 中的方法
将指定元素添加到此向量的末尾。
add(int, E) - 类 java.util.Vector 中的方法
在此向量的指定位置插入指定的元素。
add(AccessibleRelation) - 类 javax.accessibility.AccessibleRelationSet 中的方法
将新关系添加到当前关系集中。
add(AccessibleState) - 类 javax.accessibility.AccessibleStateSet 中的方法
如果某个新状态不在当前状态集中，则将它添加到当前状态集中。
add(Attribute) - 类 javax.management.AttributeList 中的方法
添加指定的 Attribute 作为列表的最后一个元素。
add(int, Attribute) - 类 javax.management.AttributeList 中的方法
插入指定的属性作为指定位置处的元素。
add(Object) - 类 javax.management.AttributeList 中的方法
add(int, Object) - 类 javax.management.AttributeList 中的方法
add(Role) - 类 javax.management.relation.RoleList 中的方法
添加指定为列表中最后一个元素的 Role。
add(int, Role) - 类 javax.management.relation.RoleList 中的方法
插入指定为指定位置处的元素的角色。
add(Object) - 类 javax.management.relation.RoleList 中的方法
add(int, Object) - 类 javax.management.relation.RoleList 中的方法
add(RoleUnresolved) - 类 javax.management.relation.RoleUnresolvedList 中的方法
添加指定为列表中最后一个元素的 RoleUnresolved。
add(int, RoleUnresolved) - 类 javax.management.relation.RoleUnresolvedList 中的方法
在指定位置处插入指定为元素的未解析角色。
add(Object) - 类 javax.management.relation.RoleUnresolvedList 中的方法
add(int, Object) - 类 javax.management.relation.RoleUnresolvedList 中的方法
add(String) - 类 javax.naming.CompositeName 中的方法
将单个组件添加到此复合名称的末尾。
add(int, String) - 类 javax.naming.CompositeName 中的方法
在此复合名称中的指定位置添加单个组件。
add(String) - 类 javax.naming.CompoundName 中的方法
将单个组件添加到此组合名称的末尾。
add(int, String) - 类 javax.naming.CompoundName 中的方法
在此组合名称中的指定位置添加单个组件。
add(Object) - 接口 javax.naming.directory.Attribute 中的方法
向属性添加新值。
add(int, Object) - 接口 javax.naming.directory.Attribute 中的方法
将属性值添加到属性值的有序列表中。
add(Object) - 类 javax.naming.directory.BasicAttribute 中的方法
向此属性添加新值。
add(int, Object) - 类 javax.naming.directory.BasicAttribute 中的方法
add(String) - 类 javax.naming.ldap.LdapName 中的方法
将单个组件添加到此 LDAP 名称的末尾。
add(Rdn) - 类 javax.naming.ldap.LdapName 中的方法
将单个 RDN 添加到此 LDAP 名称的末尾。
add(int, String) - 类 javax.naming.ldap.LdapName 中的方法
将单个组件添加到此 LDAP 名称中的指定位置。
add(int, Rdn) - 类 javax.naming.ldap.LdapName 中的方法
将单个 RDN 添加到此 LDAP 名称中的指定位置。
add(String) - 接口 javax.naming.Name 中的方法
将单个组件添加到此名称的末尾。
add(int, String) - 接口 javax.naming.Name 中的方法
在此名称中的指定位置添加单个组件。
add(RefAddr) - 类 javax.naming.Reference 中的方法
将地址添加到地址列表的末尾。
add(int, RefAddr) - 类 javax.naming.Reference 中的方法
将地址添加到地址列表中的索引 posn 处。
add(Attribute) - 接口 javax.print.attribute.AttributeSet 中的方法
如果指定的属性尚不存在，则将它添加到此属性集中，首先要移除与指定属性值相同的属性类别中的任何现有值。
add(Attribute) - 接口 javax.print.attribute.DocAttributeSet 中的方法
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - 类 javax.print.attribute.HashAttributeSet 中的方法
如果指定的属性不存在，则将它添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有属性。
add(Attribute) - 接口 javax.print.attribute.PrintJobAttributeSet 中的方法
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - 接口 javax.print.attribute.PrintRequestAttributeSet 中的方法
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
add(Attribute) - 接口 javax.print.attribute.PrintServiceAttributeSet 中的方法
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
add(JobStateReason) - 类 javax.print.attribute.standard.JobStateReasons 中的方法
将指定的元素添加到此作业状态原因属性（如果它尚未存在）。
add(MidiEvent) - 类 javax.sound.midi.Track 中的方法
将新事件添加至音轨。
add(AbstractButton) - 类 javax.swing.ButtonGroup 中的方法
将按钮添加到组中。
add(int, Object) - 类 javax.swing.DefaultListModel 中的方法
在此列表的指定位置处插入指定元素。
add(Class<T>, T) - 类 javax.swing.event.EventListenerList 中的方法
将侦听器作为指定类型的侦听器进行添加。
add(JMenuItem) - 类 javax.swing.JMenu 中的方法
将某个菜单项追加到此菜单的末尾。
add(Component) - 类 javax.swing.JMenu 中的方法
将某个组件追加到此菜单的末尾。
add(Component, int) - 类 javax.swing.JMenu 中的方法
将指定组件添加到此容器的给定位置上。
add(String) - 类 javax.swing.JMenu 中的方法
创建具有指定文本的新菜单项，并将其追加到此菜单的末尾。
add(Action) - 类 javax.swing.JMenu 中的方法
创建连接到指定 Action 对象的新菜单项，并将其追加到此菜单的末尾。
add(JMenu) - 类 javax.swing.JMenuBar 中的方法
将指定的菜单追加到菜单栏的末尾。
add(JMenuItem) - 类 javax.swing.JPopupMenu 中的方法
将指定菜单项添加到此菜单的末尾。
add(String) - 类 javax.swing.JPopupMenu 中的方法
创建具有指定文本的菜单项，并将其添加到此菜单的末尾。
add(Action) - 类 javax.swing.JPopupMenu 中的方法
将指派指定 Action 对象的新菜单项添加到菜单的末尾。
add(Component) - 类 javax.swing.JTabbedPane 中的方法
添加一个 component，其选项卡的默认值为调用 component.getName 返回的组件的名称。
add(String, Component) - 类 javax.swing.JTabbedPane 中的方法
添加具有指定选项卡标题的 component。
add(Component, int) - 类 javax.swing.JTabbedPane 中的方法
在指定的选项卡索引位置添加一个 component，默认的选项卡标题为组件名称。
add(Component, Object) - 类 javax.swing.JTabbedPane 中的方法
将一个 component 添加到选项卡窗格中。
add(Component, Object, int) - 类 javax.swing.JTabbedPane 中的方法
在指定的选项卡索引位置添加一个 component。
add(Action) - 类 javax.swing.JToolBar 中的方法
添加一个指派动作的新的 JButton。
add(MutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
从其父节点移除 newChild，并通过将其添加到此节点的子数组的结尾，使其成为此节点的子节点。
add(Duration) - 类 javax.xml.datatype.Duration 中的方法
计算值为 this+rhs 的新持续时间。
add(Duration) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将 duration 添加到此实例。
add(XMLEvent) - 接口 javax.xml.stream.util.XMLEventConsumer 中的方法
此方法为使用者添加一个事件。
add(XMLEvent) - 接口 javax.xml.stream.XMLEventWriter 中的方法
向输出流添加事件。
add(XMLEventReader) - 接口 javax.xml.stream.XMLEventWriter 中的方法
将整个流添加到输出流，在 hasNext() 返回 false 前对 inputStream 参数调用 next()。
add(GSSName, int, int, Oid, int) - 接口 org.ietf.jgss.GSSCredential 中的方法
将特定于机制的凭据元素添加到现有的凭据中。
add(String) - 类 org.omg.CORBA.ContextList 中的方法
将 String 对象添加到此 ContextList 对象中。
add(TypeCode) - 类 org.omg.CORBA.ExceptionList 中的方法
将描述异常的 TypeCode 对象添加到此 ExceptionList 对象中。
add(int) - 类 org.omg.CORBA.NVList 中的方法
创建一个新的 NamedValue 对象，使用给定标志初始化该对象，并将它添加到此 NVList 对象的末尾。
ADD_ATTRIBUTE - 接口 javax.naming.directory.DirContext 中的静态变量
此常量指定使用指定值添加属性。
add_client_request_interceptor(ClientRequestInterceptor) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
此方法用来将客户端的请求 Interceptor 添加到客户端请求 Interceptor 列表。
add_in_arg() - 类 org.omg.CORBA.Request 中的方法
创建一个输入参数，并将它添加到此 Request 对象中。
add_inout_arg() - 类 org.omg.CORBA.Request 中的方法
将一个输入/输出参数添加到此 Request 对象中。
add_ior_component(TaggedComponent) - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component，以便向构造 IOR 时要包括的设置添加带标记的组件。
add_ior_component_to_profile(TaggedComponent, int) - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
可移植 ORB 服务实现从其 establish_components 实现调用 add_ior_component_to_profile，以便向构造 IOR 时要包括的设置添加带标记的组件。
add_ior_interceptor(IORInterceptor) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
此方法用来将 IOR Interceptor 添加到 IOR Interceptor 列表。
add_item(String, int) - 类 org.omg.CORBA.NVList 中的方法
创建一个新的 NamedValue 对象，使用给定名称和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
add_named_in_arg(String) - 类 org.omg.CORBA.Request 中的方法
使用给定名称创建一个输入参数，并将它添加到此 Request 对象中。
add_named_inout_arg(String) - 类 org.omg.CORBA.Request 中的方法
将具有给定名称的输入/输出参数添加到此 Request 对象中。
add_named_out_arg(String) - 类 org.omg.CORBA.Request 中的方法
将具有给定名称的输出参数添加到此 Request 对象中。
add_out_arg() - 类 org.omg.CORBA.Request 中的方法
将输出参数添加到此 Request 对象中。
ADD_OVERRIDE - 类 org.omg.CORBA.SetOverrideType 中的静态变量
用于枚举值 ADD_OVERRIDE 的 SetOverrideType 常量。
add_reply_service_context(ServiceContext, boolean) - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
允许 Interceptor 将服务上下文添加到请求。
add_request_service_context(ServiceContext, boolean) - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
允许 Interceptor 将服务上下文添加到请求。
add_server_request_interceptor(ServerRequestInterceptor) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
此方法用来将服务器端的请求 Interceptor 添加到服务器端请求 Interceptor 列表。
add_value(String, Any, int) - 类 org.omg.CORBA.NVList 中的方法
创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。
addAccessibleSelection(int) - 类 java.awt.List.AccessibleAWTList 中的方法
将对象中的指定选项添加到对象选择中。
addAccessibleSelection(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
将该对象的指定 Accessible 子对象添加到该对象的选择中。
addAccessibleSelection(int) - 接口 javax.accessibility.AccessibleSelection 中的方法
将对象的指定 Accessible 子级添加到该对象的选项中。
addAccessibleSelection(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
将该对象的指定 Accessible 子对象添加到该对象的选择中。
addAccessibleSelection(int) - 类 javax.swing.JList.AccessibleJList 中的方法
将对象中的指定选项添加到对象选择中。
addAccessibleSelection(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
选择菜单中的第 i 个菜单。
addAccessibleSelection(int) - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
在菜单栏中选择第 n 个菜单，并强制其弹出。
addAccessibleSelection(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
addAccessibleSelection(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
将该对象的指定 Accessible 子对象添加到该对象的选择中。
addAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
将对象中指定选择的项添加到对象的选择中。
addAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
将对象中指定选择的项添加到对象的选择中。
addActionForKeyStroke(KeyStroke, Action) - 接口 javax.swing.text.Keymap 中的方法
向 keymap 添加绑定。
addActionListener(ActionListener) - 类 java.awt.Button 中的方法
添加指定的动作侦听器，以接收发自此按钮的动作事件。
addActionListener(ActionListener) - 类 java.awt.List 中的方法
添加指定的动作侦听器以从此列表接收动作事件。
addActionListener(ActionListener) - 类 java.awt.MenuItem 中的方法
添加指定的动作侦听器，以从此菜单项接收动作事件。
addActionListener(ActionListener) - 类 java.awt.TextField 中的方法
添加指定的操作侦听器，以从此文本字段接收操作事件。
addActionListener(ActionListener) - 类 java.awt.TrayIcon 中的方法
添加指定的动作侦听器，以接收发自此 TrayIcon 的 ActionEvent。
addActionListener(ActionListener) - 类 javax.swing.AbstractButton 中的方法
将一个 ActionListener 添加到按钮中。
addActionListener(ActionListener) - 接口 javax.swing.ButtonModel 中的方法
向模型添加一个 ActionListener。
addActionListener(ActionListener) - 接口 javax.swing.ComboBoxEditor 中的方法
添加一个 ActionListener。
addActionListener(ActionListener) - 类 javax.swing.DefaultButtonModel 中的方法
向模型添加一个 ActionListener。
addActionListener(ActionListener) - 类 javax.swing.JComboBox 中的方法
添加 ActionListener。
addActionListener(ActionListener) - 类 javax.swing.JFileChooser 中的方法
向文件选择器添加一个 ActionListener。
addActionListener(ActionListener) - 类 javax.swing.JTextField 中的方法
添加指定的操作侦听器以从此文本字段接收操作事件。
addActionListener(ActionListener) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
addActionListener(ActionListener) - 类 javax.swing.Timer 中的方法
将一个动作侦听器添加到 Timer。
addAdjustmentListener(AdjustmentListener) - 接口 java.awt.Adjustable 中的方法
添加侦听器，以便在可调整对象的值更改时接收调整事件。
addAdjustmentListener(AdjustmentListener) - 类 java.awt.Scrollbar 中的方法
添加指定的调整侦听器，以接收发自此滚动条的 AdjustmentEvent 实例。
addAdjustmentListener(AdjustmentListener) - 类 java.awt.ScrollPaneAdjustable 中的方法
添加指定的调整侦听器，以接收发自此 ScrollPaneAdjustable 的调整事件。
addAdjustmentListener(AdjustmentListener) - 类 javax.swing.JScrollBar 中的方法
添加一个 AdjustmentListener。
addAll(Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
将 Collection 添加到 Children（不受支持的）实现的集合，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
addAll(Collection<? extends E>) - 类 java.util.AbstractCollection 中的方法
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
addAll(int, Collection<? extends E>) - 类 java.util.AbstractList 中的方法
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
addAll(Collection<? extends E>) - 类 java.util.AbstractQueue 中的方法
将指定 collection 中的所有元素都添加到此队列中。
addAll(int, Collection<? extends E>) - 类 java.util.AbstractSequentialList 中的方法
在此列表中指定的位置上插入指定 collection 中的所有元素（可选操作）。
addAll(Collection<? extends E>) - 类 java.util.ArrayList 中的方法
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。
addAll(int, Collection<? extends E>) - 类 java.util.ArrayList 中的方法
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。
addAll(Collection<? extends E>) - 接口 java.util.Collection 中的方法
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
addAll(Collection<? super T>, T...) - 类 java.util.Collections 中的静态方法
将所有指定元素添加到指定 collection 中。
addAll(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中的所有元素添加此列表的尾部。
addAll(int, Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
从指定位置开始，将指定 collection 的所有元素插入此列表。
addAll(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果此 set 中没有指定 collection 中的所有元素，则将它们都添加到此 set 中。
addAll(Collection<? extends E>) - 类 java.util.LinkedList 中的方法
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序。
addAll(int, Collection<? extends E>) - 类 java.util.LinkedList 中的方法
将指定 collection 中的所有元素从指定位置开始插入此列表。
addAll(Collection<? extends E>) - 接口 java.util.List 中的方法
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序（可选操作）。
addAll(int, Collection<? extends E>) - 接口 java.util.List 中的方法
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
addAll(Collection<? extends E>) - 接口 java.util.Set 中的方法
如果 set 中没有指定 collection 中的所有元素，则将其添加到此 set 中（可选操作）。
addAll(Collection<? extends E>) - 类 java.util.TreeSet 中的方法
将指定 collection 中的所有元素添加到此 set 中。
addAll(Collection<? extends E>) - 类 java.util.Vector 中的方法
将指定 Collection 中的所有元素添加到此向量的末尾，按照指定 collection 的迭代器所返回的顺序添加这些元素。
addAll(int, Collection<? extends E>) - 类 java.util.Vector 中的方法
在指定位置将指定 Collection 中的所有元素插入到此向量中。
addAll(AccessibleRelation[]) - 类 javax.accessibility.AccessibleRelationSet 中的方法
将所有关系添加到现有关系集中。
addAll(AccessibleState[]) - 类 javax.accessibility.AccessibleStateSet 中的方法
将所有状态添加到现有状态集中。
addAll(AttributeList) - 类 javax.management.AttributeList 中的方法
将指定 AttributeList 中的所有元素追加到列表的末尾，元素的顺序是指定 AttributeList 的 Iterator 所返回的顺序。
addAll(int, AttributeList) - 类 javax.management.AttributeList 中的方法
将指定 AttributeList 中的所有元素插入此列表，从指定的位置开始插入，元素的顺序是指定 Attribute 的 Iterator 所返回的顺序。
addAll(Collection<?>) - 类 javax.management.AttributeList 中的方法
addAll(int, Collection<?>) - 类 javax.management.AttributeList 中的方法
addAll(RoleList) - 类 javax.management.relation.RoleList 中的方法
将指定 RoleList 中的所有元素追加到列表末尾，这些元素按指定 RoleList 的迭代器返回的顺序排列。
addAll(int, RoleList) - 类 javax.management.relation.RoleList 中的方法
从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
addAll(Collection<?>) - 类 javax.management.relation.RoleList 中的方法
addAll(int, Collection<?>) - 类 javax.management.relation.RoleList 中的方法
addAll(RoleUnresolvedList) - 类 javax.management.relation.RoleUnresolvedList 中的方法
将指定 RoleUnresolvedList 中的所有元素追加到列表末尾，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
addAll(int, RoleUnresolvedList) - 类 javax.management.relation.RoleUnresolvedList 中的方法
从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
addAll(Collection<?>) - 类 javax.management.relation.RoleUnresolvedList 中的方法
addAll(int, Collection<?>) - 类 javax.management.relation.RoleUnresolvedList 中的方法
addAll(Name) - 类 javax.naming.CompositeName 中的方法
按顺序将复合名称的组件添加到此复合名称的末尾。
addAll(int, Name) - 类 javax.naming.CompositeName 中的方法
按顺序将复合名称的组件添加到此复合名称中的指定位置。
addAll(Name) - 类 javax.naming.CompoundName 中的方法
按顺序将组合名称的组件添加到此组合名称的末尾。
addAll(int, Name) - 类 javax.naming.CompoundName 中的方法
按顺序将组合名称的组件添加到此组合名称中的指定位置。
addAll(Name) - 类 javax.naming.ldap.LdapName 中的方法
按顺序将名称的组件添加到此名称的末尾。
addAll(List<Rdn>) - 类 javax.naming.ldap.LdapName 中的方法
按顺序将名称的 RDN 添加到此名称的末尾。
addAll(int, Name) - 类 javax.naming.ldap.LdapName 中的方法
按顺序将名称的组件添加到此名称中的指定位置。
addAll(int, List<Rdn>) - 类 javax.naming.ldap.LdapName 中的方法
按顺序将名称的 RDN 添加到此名称中的指定位置。
addAll(Name) - 接口 javax.naming.Name 中的方法
按顺序将名称的组件添加到此名称的末尾。
addAll(int, Name) - 接口 javax.naming.Name 中的方法
按顺序将名称的组件添加到此名称中的指定位置。
addAll(AttributeSet) - 接口 javax.print.attribute.AttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 接口 javax.print.attribute.DocAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 类 javax.print.attribute.HashAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 接口 javax.print.attribute.PrintJobAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 接口 javax.print.attribute.PrintRequestAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAll(AttributeSet) - 接口 javax.print.attribute.PrintServiceAttributeSet 中的方法
将指定集合中的所有元素添加到此属性中。
addAllAbsent(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中尚未包含在此列表中的所有元素添加列表的尾部。
addAncestorListener(AncestorListener) - 类 javax.swing.JComponent 中的方法
注册 listener，从而当组件或其任意祖先移动，或者变得可见或不可见时该侦听器将收到 AncestorEvent。
addAndGet(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将给定值与当前值相加。
addAndGet(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将给定值与索引 i 的元素相加。
addAndGet(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将给定值添加到此更新器管理的给定对象的字段当前值。
addAndGet(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将给定值添加到当前值。
addAndGet(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将给定值添加到索引 i 的元素。
addAndGet(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将给定值添加到此更新器管理的给定对象的字段的当前值。
addAttachmentPart(AttachmentPart) - 类 javax.xml.soap.SOAPMessage 中的方法
将给定的 AttachmentPart 对象添加到此 SOAPMessage 对象。
addAttribute(AttributedCharacterIterator.Attribute, Object) - 类 java.text.AttributedString 中的方法
将一个属性添加到整个字符串中。
addAttribute(AttributedCharacterIterator.Attribute, Object, int, int) - 类 java.text.AttributedString 中的方法
将一个属性添加到字符串的子范围。
addAttribute(String, String, int, boolean, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的可以被设置为任意值的元素中。
addAttribute(String, String, int, boolean, String, List<String>) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。
addAttribute(String, String, int, boolean, String, String, String, boolean, boolean) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的元素中，该元素将由一系列值定义。
addAttribute(String, String, int, boolean, int, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的元素中，该元素将由值的列表定义。
addAttribute(Object, Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
向该元素添加一个属性。
addAttribute(AttributeSet, Object, Object) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
向给定属性集中添加一个属性，并返回新的有代表性的属性集。
addAttribute(AttributeSet, Object, Object) - 类 javax.swing.text.html.StyleSheet 中的方法
向给定集合添加属性，并返回新的表示方式的集合。
addAttribute(Object, Object) - 接口 javax.swing.text.MutableAttributeSet 中的方法
创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。
addAttribute(Object, Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
向列表添加属性。
addAttribute(AttributeSet, Object, Object) - 类 javax.swing.text.StyleContext 中的方法
向给定的集合中添加属性，并返回新的有代表性的集合。
addAttribute(Object, Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
添加属性。
addAttribute(Name, String) - 接口 javax.xml.soap.SOAPElement 中的方法
将带有指定名称和值的属性添加到此 SOAPElement 对象。
addAttribute(QName, String) - 接口 javax.xml.soap.SOAPElement 中的方法
将带有指定名称和值的属性添加到此 SOAPElement 对象。
addAttribute(String, String, String, String, String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
将属性添回到列表的末尾，将其“指定的”标志设置为 true。
addAttribute(String, String, String) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 向属性列表添加属性。
addAttribute(String, String, String, String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
将属性添加到列表的末尾。
addAttributeChangeNotificationListener(NotificationListener, String, Object) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
注册一个将 NotificationListener 接口实现为侦听器的对象。
addAttributeChangeNotificationListener(NotificationListener, String, Object) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
addAttributes(Map<? extends AttributedCharacterIterator.Attribute, ?>, int, int) - 类 java.text.AttributedString 中的方法
将属性集添加到字符串的子范围。
addAttributes(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
向该元素添加一个属性集合。
addAttributes(AttributeSet, AttributeSet) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
向元素添加一组属性。
addAttributes(AttributeSet, AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
向元素添加属性集。
addAttributes(AttributeSet) - 接口 javax.swing.text.MutableAttributeSet 中的方法
创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。
addAttributes(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
向列表添加属性集。
addAttributes(AttributeSet, AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
向元素添加属性集。
addAttributes(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
将属性集添加到元素。
addAuxiliaryLookAndFeel(LookAndFeel) - 类 javax.swing.UIManager 中的静态方法
将 LookAndFeel 添加到辅助外观的列表中。
addAWTEventListener(AWTEventListener, long) - 类 java.awt.Toolkit 中的方法
添加一个 AWTEventListener，以接收与给定 eventMask 一致的系统范围内指派的所有 AWTEvent。
addBatch() - 接口 java.sql.PreparedStatement 中的方法
将一组参数添加到此 PreparedStatement 对象的批处理命令中。
addBatch(String) - 接口 java.sql.Statement 中的方法
将给定的 SQL 命令添加到此 Statement 对象的当前命令列表中。
addBeanContextMembershipListener(BeanContextMembershipListener) - 接口 java.beans.beancontext.BeanContext 中的方法
添加指定的 BeanContextMembershipListener，以便无论何时添加或移除一个子 Component，都可以接收来自此 BeanContext 的 BeanContextMembershipEvents。
addBeanContextMembershipListener(BeanContextMembershipListener) - 类 java.beans.beancontext.BeanContextSupport 中的方法
添加一个 BeanContextMembershipListener。
addBeanContextServicesListener(BeanContextServicesListener) - 接口 java.beans.beancontext.BeanContextServices 中的方法
将一个 BeanContextServicesListener 添加到此 BeanContext
addBeanContextServicesListener(BeanContextServicesListener) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
添加一个 BeanContextServicesListener。
addBody() - 接口 javax.xml.soap.SOAPEnvelope 中的方法
创建一个 SOAPBody 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPBody 对象。
addBodyElement(Name) - 接口 javax.xml.soap.SOAPBody 中的方法
使用指定名称创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
addBodyElement(QName) - 接口 javax.xml.soap.SOAPBody 中的方法
使用指定 QName 创建新的 SOAPBodyElement 对象，并将其添加到此 SOAPBody 对象。
addBooleanAttribute(String, String, boolean, boolean) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将新属性添加到以前定义的元素中，该元素将由枚举值 TRUE 和 FALSE 定义，数据类型为 DATATYPE_BOOLEAN。
addButtonComponents(Container, Object[], int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
创建表示 buttons 中每个对象的适当对象并将其添加到 container。
addCaretListener(CaretListener) - 类 javax.swing.text.JTextComponent 中的方法
添加插入符侦听器，以便侦听任何插入符的更改通知。
addCellEditorListener(CellEditorListener) - 类 javax.swing.AbstractCellEditor 中的方法
将一个 CellEditorListener 添加到侦听器列表中。
addCellEditorListener(CellEditorListener) - 接口 javax.swing.CellEditor 中的方法
当编辑器停止运作或取消编辑时，向被通知的列表添加一个侦听器。
addCellEditorListener(CellEditorListener) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
添加 CellEditorListener。
addCertificate(Certificate) - 类 java.security.Identity 中的方法
已过时。 为此 Identity 添加一个证书。
addCertPathChecker(PKIXCertPathChecker) - 类 java.security.cert.PKIXParameters 中的方法
向证书路径检查器列表中添加一个 PKIXCertPathChecker。
addCertStore(CertStore) - 类 java.security.cert.PKIXParameters 中的方法
将 CertStore 添加到查找证书和 CRL 所使用的 CertStore 列表末尾。
addChangeListener(ChangeListener) - 类 javax.swing.AbstractButton 中的方法
向按钮添加一个 ChangeListener。
addChangeListener(ChangeListener) - 类 javax.swing.AbstractSpinnerModel 中的方法
将一个 ChangeListener 添加到模型的侦听器列表中。
addChangeListener(ChangeListener) - 接口 javax.swing.BoundedRangeModel 中的方法
将一个 ChangeListener 添加到模型的侦听器列表中。
addChangeListener(ChangeListener) - 接口 javax.swing.ButtonModel 中的方法
向模型添加一个 ChangeListener。
addChangeListener(ChangeListener) - 接口 javax.swing.colorchooser.ColorSelectionModel 中的方法
在模型中添加作为更改侦听器的 listener。
addChangeListener(ChangeListener) - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
将一个 ChangeListener 添加到模型中。
addChangeListener(ChangeListener) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
添加一个 ChangeListener。
addChangeListener(ChangeListener) - 类 javax.swing.DefaultButtonModel 中的方法
向模型添加一个 ChangeListener。
addChangeListener(ChangeListener) - 类 javax.swing.DefaultSingleSelectionModel 中的方法
向按钮添加一个 ChangeListener。
addChangeListener(ChangeListener) - 类 javax.swing.JProgressBar 中的方法
将指定的 ChangeListener 添加到进度条。
addChangeListener(ChangeListener) - 类 javax.swing.JSlider 中的方法
将一个 ChangeListener 添加到滑块。
addChangeListener(ChangeListener) - 类 javax.swing.JSpinner 中的方法
为每次发生模型更改时要通知的列表添加侦听器。
addChangeListener(ChangeListener) - 类 javax.swing.JTabbedPane 中的方法
将一个 ChangeListener 添加到此选项卡窗格中。
addChangeListener(ChangeListener) - 类 javax.swing.JViewport 中的方法
将一个 ChangeListener 添加到每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表。
addChangeListener(ChangeListener) - 类 javax.swing.MenuSelectionManager 中的方法
向按钮添加 ChangeListener。
addChangeListener(ChangeListener) - 接口 javax.swing.SingleSelectionModel 中的方法
在模型中添加作为更改侦听侦听器的 listener。
addChangeListener(ChangeListener) - 接口 javax.swing.SpinnerModel 中的方法
向该模型的侦听器列表添加一个 ChangeListener。
addChangeListener(ChangeListener) - 接口 javax.swing.text.Caret 中的方法
添加作为跟踪任何插入符位置更改的侦听器。
addChangeListener(ChangeListener) - 类 javax.swing.text.DefaultCaret 中的方法
添加一个侦听器，以便对插入符位置改变进行跟踪。
addChangeListener(ChangeListener) - 接口 javax.swing.text.Style 中的方法
添加一个侦听器，以便随时跟踪属性的更改。
addChangeListener(ChangeListener) - 类 javax.swing.text.StyleContext 中的方法
添加一个侦听器，以跟踪何时添加或删除样式。
addChangeListener(ChangeListener) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
添加更改侦听器。
addChildElement(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
将现有元素添加到给定父节点类型的合法子节点的列表中。
addChildElement(Name) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用给定 Name 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用给定 QName 对象初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(String, String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(String, String, String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。
addChildElement(SOAPElement) - 接口 javax.xml.soap.SOAPElement 中的方法
将 SOAPElement 作为此 SOAPElement 实例的子级添加。
addChoosableFileFilter(FileFilter) - 类 javax.swing.JFileChooser 中的方法
向用户可选择的文件过滤器列表添加一个过滤器。
addChooserPanel(AbstractColorChooserPanel) - 类 javax.swing.JColorChooser 中的方法
将颜色选取器面板添加到颜色选取器。
addColumn(TableColumn) - 类 javax.swing.JTable 中的方法
将 aColumn 追加到此 JTable 的列模型所保持的列数组的尾部。
addColumn(TableColumn) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
将 aColumn 追加到 tableColumns 数组的结尾。
addColumn(Object) - 类 javax.swing.table.DefaultTableModel 中的方法
将一列添加到模型中。
addColumn(Object, Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
将一列添加到模型中。
addColumn(Object, Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
将一列添加到模型中。
addColumn(TableColumn) - 接口 javax.swing.table.TableColumnModel 中的方法
将 aColumn 追加到 tableColumns 数组的结尾。
addColumnModelListener(TableColumnModelListener) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
添加表列模型事件的侦听器。
addColumnModelListener(TableColumnModelListener) - 接口 javax.swing.table.TableColumnModel 中的方法
为表列模型事件添加侦听器。
addColumnSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
将从 index0 到 index1 之间（包含两端）的列添加到当前选择中。
addComponent(Component) - 类 javax.swing.GroupLayout.Group 中的方法
将 Component 添加到此 Group。
addComponent(Component, int, int, int) - 类 javax.swing.GroupLayout.Group 中的方法
使用指定大小将 Component 添加到此 Group。
addComponent(Component) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
将 Component 添加到此 Group。
addComponent(Component, int, int, int) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
使用指定大小将 Component 添加到此 Group。
addComponent(Component, GroupLayout.Alignment) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
使用指定的对齐方式将 Component 添加到此 ParallelGroup。
addComponent(Component, GroupLayout.Alignment, int, int, int) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
addComponent(Component) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将 Component 添加到此 Group。
addComponent(boolean, Component) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将 Component 添加到此 Group。
addComponent(Component, int, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
使用指定大小将 Component 添加到此 Group。
addComponent(boolean, Component, int, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
使用指定大小将 Component 添加到此 Group。
addComponentListener(ComponentListener) - 类 java.awt.Component 中的方法
添加指定的组件侦听器，以接收发自此组件的组件事件。
addConnectionEventListener(ConnectionEventListener) - 接口 javax.sql.PooledConnection 中的方法
注册给定的事件侦听器，以便在此 PooledConnection 对象上发生事件时它将得到通知。
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - 接口 javax.management.remote.JMXConnector 中的方法
添加一个接收连接状态改变的侦听器。
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.remote.rmi.RMIConnector 中的方法
addConsumer(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
将指定的 ImageConsumer 添加到对过滤图像的数据感兴趣的使用者列表。
addConsumer(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
为了在稍后的 Image 重构期间访问图像数据，向 ImageProducer 注册一个 ImageConsumer。
addConsumer(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表。
addConsumer(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表。
addContainerGap() - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示容器边缘和触到容器边框的组件之间首选间隙的元素。
addContainerGap(int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
使用指定大小添加一个元素，它表示容器的一个边缘和下一个或前一个 Component 之间的首选间隙。
addContainerListener(ContainerListener) - 类 java.awt.Container 中的方法
添加指定容器的侦听器，以接收来自此容器的容器事件。
addContent(char[], int, int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
添加某个具有当前字符属性的文本。
addContent(char[], int, int, boolean) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
添加某个具有当前字符属性的文本。
addControlButtons() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
addControllerEventListener(ControllerEventListener, int[]) - 接口 javax.sound.midi.Sequencer 中的方法
注册一个控件事件侦听器，以便在 sequencer 处理所请求的一种或多种类型的控制更改事件时接收通知。
addCSSAttribute(MutableAttributeSet, CSS.Attribute, String) - 类 javax.swing.text.html.StyleSheet 中的方法
将 CSS 属性添加到给定的集合。
addCSSAttributeFromHTML(MutableAttributeSet, CSS.Attribute, String) - 类 javax.swing.text.html.StyleSheet 中的方法
将 CSS 属性添加到给定的集合。
addCustomEntriesToTable(UIDefaults) - 类 javax.swing.plaf.metal.MetalTheme 中的方法
将特定于此主题的值添加到默认表。
addCustomEntriesToTable(UIDefaults) - 类 javax.swing.plaf.metal.OceanTheme 中的方法
将此主题的自定义条目添加到默认表中。
addDetail() - 接口 javax.xml.soap.SOAPFault 中的方法
创建可选的 Detail 对象，并将其设置为此 SOAPFault 对象的 Detail 对象。
addDetailEntry(Name) - 接口 javax.xml.soap.Detail 中的方法
使用给定名称创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
addDetailEntry(QName) - 接口 javax.xml.soap.Detail 中的方法
使用给定 QName 创建新的 DetailEntry 对象，并将其添加到此 Detail 对象。
addDirtyRegion(JComponent, int, int, int, int) - 类 javax.swing.RepaintManager 中的方法
在应刷新的组件列表中添加组件。
addDirtyRegion(Window, int, int, int, int) - 类 javax.swing.RepaintManager 中的方法
将 window 添加到需要重绘的 Component 列表。
addDirtyRegion(Applet, int, int, int, int) - 类 javax.swing.RepaintManager 中的方法
将 applet 添加到需要重绘的 Component 列表。
addDocument(Document) - 接口 javax.xml.soap.SOAPBody 中的方法
将 DOM Document 的根节点添加到此 SOAPBody 对象。
addDocumentListener(DocumentListener) - 类 javax.swing.text.AbstractDocument 中的方法
添加负责通知任何更改的文档侦听器。
addDocumentListener(DocumentListener) - 类 javax.swing.text.DefaultStyledDocument 中的方法
添加负责通知任何更改的文档侦听器。
addDocumentListener(DocumentListener) - 接口 javax.swing.text.Document 中的方法
注册给定的观察者以便开始接收文档发生更改的通知。
addDragGestureListener(DragGestureListener) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
注册一个新的 DragGestureListener。
addDragSourceListener(DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
将指定的 DragSourceListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动源事件。
addDragSourceListener(DragSourceListener) - 类 java.awt.dnd.DragSourceContext 中的方法
如果尚未将 DragSourceListener 添加到此 DragSourceContext，则添加一个。
addDragSourceMotionListener(DragSourceMotionListener) - 类 java.awt.dnd.DragSource 中的方法
将指定的 DragSourceMotionListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动移动事件。
addDropTargetListener(DropTargetListener) - 类 java.awt.dnd.DropTarget 中的方法
添加一个新的 DropTargetListener (UNICAST SOURCE)。
addEdit(UndoableEdit) - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
添加文档编辑。
addEdit(UndoableEdit) - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
此默认实现返回 false。
addEdit(UndoableEdit) - 类 javax.swing.undo.CompoundEdit 中的方法
如果此编辑为 inProgress，则接受 anEdit 并返回 true。
addEdit(UndoableEdit) - 接口 javax.swing.undo.UndoableEdit 中的方法
将 UndoableEdit 添加到此 UndoableEdit。
addEdit(UndoableEdit) - 类 javax.swing.undo.UndoManager 中的方法
如果可能，将一个 UndoableEdit 添加到此 UndoManager。
addEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此公共方法是特定于实现的，应该为私有，不要调用或重写。
addElement(E) - 类 java.util.Vector 中的方法
将指定的组件添加到此向量的末尾，将其大小增加 1。
addElement(String, String, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
使用某个子策略（CHILD_POLICY_REPEAT 除外）将新元素类型添加到此元数据文档格式中。
addElement(String, String, int, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
使用子策略 CHILD_POLICY_REPEAT 将新元素类型添加到此元数据文档格式中。
addElement(Object) - 类 javax.swing.DefaultComboBoxModel 中的方法
addElement(Object) - 类 javax.swing.DefaultListModel 中的方法
将指定组件添加到此类表的末尾。
addElement(Object) - 接口 javax.swing.MutableComboBoxModel 中的方法
在模型的末尾添加项。
addEntry(Principal, AclEntry) - 接口 java.security.acl.Acl 中的方法
向此 ACL 中添加 ACL 项。
addEventListener(String, EventListener, boolean) - 接口 org.w3c.dom.events.EventTarget 中的方法
此方法允许在事件目标上注册事件侦听器。
addFault() - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFault(Name, String, Locale) - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFault(QName, String, Locale) - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFault(Name, String) - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFault(QName, String) - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
addFaultReasonText(String, Locale) - 接口 javax.xml.soap.SOAPFault 中的方法
追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。
addFirst(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的开头。
addFirst(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头；如果当前没有空间可用，则抛出 IllegalStateException。
addFirst(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
addFirst(E) - 接口 java.util.Deque 中的方法
将指定元素插入此双端队列的开头（如果可以直接这样做而不违反容量限制）。
addFirst(E) - 类 java.util.LinkedList 中的方法
将指定元素插入此列表的开头。
addFlavorForUnencodedNative(String, DataFlavor) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
添加从单个 String native 到单个 DataFlavor 的映射。
addFlavorListener(FlavorListener) - 类 java.awt.datatransfer.Clipboard 中的方法
注册指定的 FlavorListener，以从此剪贴板接收 FlavorEvent。
addFocusListener(FocusListener) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
添加指定的焦点侦听器，以接收发自此组件的焦点事件。
addFocusListener(FocusListener) - 类 java.awt.Component 中的方法
添加指定的焦点侦听器，以便当此组件获得输入焦点时能够接收发自此组件的焦点事件。
addFocusListener(FocusListener) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
添加指定的焦点侦听器，以从此组件接收焦点事件。
addFocusListener(FocusListener) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
添加指定的焦点侦听器，以从此组件接收焦点事件。
addFocusListener(FocusListener) - 接口 javax.accessibility.AccessibleComponent 中的方法
添加指定的焦点侦听器，以接收来自此组件的焦点事件。
addFocusListener(FocusListener) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
addFocusListener(FocusListener) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
addFocusListener(FocusListener) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
addFocusListener(FocusListener) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
addGap(int) - 类 javax.swing.GroupLayout.Group 中的方法
将固定间隙添加到此 Group。
addGap(int, int, int) - 类 javax.swing.GroupLayout.Group 中的方法
将指定大小的间隙添加到此 Group。
addGap(int) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
将固定间隙添加到此 Group。
addGap(int, int, int) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
将指定大小的间隙添加到此 Group。
addGap(int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将固定间隙添加到此 Group。
addGap(int, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将指定大小的间隙添加到此 Group。
addGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout.Group 中的方法
将 Group 添加到此 Group。
addGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
将 Group 添加到此 Group。
addGroup(GroupLayout.Alignment, GroupLayout.Group) - 类 javax.swing.GroupLayout.ParallelGroup 中的方法
使用指定的对齐方式将 Group 添加到此 ParallelGroup。
addGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将 Group 添加到此 Group。
addGroup(boolean, GroupLayout.Group) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
将 Group 添加到此 Group。
addHandler(Handler) - 类 java.util.logging.Logger 中的方法
添加一个日志 Handler 以接收日志记录消息。
addHandshakeCompletedListener(HandshakeCompletedListener) - 类 javax.net.ssl.SSLSocket 中的方法
注册一个事件侦听器来接收此连接上的 SSL 握手已经完成的通知。
addHeader(String, String) - 类 javax.xml.soap.MimeHeaders 中的方法
将带有指定名称和值的 MimeHeader 对象添加到此 MimeHeaders 对象的头列表。
addHeader() - 接口 javax.xml.soap.SOAPEnvelope 中的方法
创建一个 SOAPHeader 对象，并将其设置为此 SOAPEnvelope 对象的 SOAPHeader 对象。
addHeaderElement(Name) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定名称初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addHeaderElement(QName) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定 qname 初始化的新的 SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addHierarchyBoundsListener(HierarchyBoundsListener) - 类 java.awt.Component 中的方法
添加指定的层次结构边界侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构边界事件。
addHierarchyListener(HierarchyListener) - 类 java.awt.Component 中的方法
添加指定的层次结构侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构变化事件。
addHighlight(int, int, Highlighter.HighlightPainter) - 类 javax.swing.text.DefaultHighlighter 中的方法
向视图添加高亮显示。
addHighlight(int, int, Highlighter.HighlightPainter) - 接口 javax.swing.text.Highlighter 中的方法
向视图添加高亮显示。
addHyperlinkListener(HyperlinkListener) - 类 javax.swing.JEditorPane 中的方法
为了通知所有的更改（例如选中和进入某个链接）而添加一个超链接侦听器。
addIcon(Container) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
创建并添加 JLabel，它表示对 top 调用 getIcon 所返回的图标。
addIdentity(Identity) - 类 java.security.IdentityScope 中的方法
已过时。 向此身份作用域添加一个身份。
addIfAbsent(E) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
添加元素（如果不存在）。
addIIOReadProgressListener(IIOReadProgressListener) - 类 javax.imageio.ImageReader 中的方法
将 IIOReadProgressListener 添加到已注册的进度侦听器列表中。
addIIOReadUpdateListener(IIOReadUpdateListener) - 类 javax.imageio.ImageReader 中的方法
将 IIOReadUpdateListener 添加到已注册的更新侦听器列表中。
addIIOReadWarningListener(IIOReadWarningListener) - 类 javax.imageio.ImageReader 中的方法
将 IIOReadWarningListener 添加到已注册的警告侦听器的列表中。
addIIOWriteProgressListener(IIOWriteProgressListener) - 类 javax.imageio.ImageWriter 中的方法
将 IIOWriteProgressListener 添加到已注册的进度侦听器列表中。
addIIOWriteWarningListener(IIOWriteWarningListener) - 类 javax.imageio.ImageWriter 中的方法
将 IIOWriteWarningListener 添加到已注册的警告侦听器的列表中。
addImage(Image, int) - 类 java.awt.MediaTracker 中的方法
向此媒体跟踪器正在跟踪的图像列表添加一个图像。
addImage(Image, int, int, int) - 类 java.awt.MediaTracker 中的方法
向此媒体跟踪器正在跟踪的图像列表添加一个经过缩放的图像。
addImpl(Component, Object, int) - 类 java.awt.Container 中的方法
将指定组件添加到此容器的指定索引所在的位置上。
addImpl(Component, Object, int) - 类 java.awt.ScrollPane 中的方法
将指定的组件添加到此滚动窗格容器。
addImpl(Component, Object, int) - 类 javax.swing.AbstractButton 中的方法
将指定组件添加到此容器的指定索引所在的位置上，有关此方法的完整描述，请参阅 Container.addImpl(Component, Object, int)。
addImpl(Component, Object, int) - 类 javax.swing.CellRendererPane 中的方法
如果指定组件已经是此组件的子组件，则不必再操心去做任何事，堆栈顺序对于单元格渲染器组件而言无关紧要（CellRendererPane 不管怎样都不进行绘制）。
addImpl(Component, Object, int) - 类 javax.swing.JApplet 中的方法
添加指定的子 Component。
addImpl(Component, Object, int) - 类 javax.swing.JDesktopPane 中的方法
将指定组件添加到此容器的指定索引所在的位置上。
addImpl(Component, Object, int) - 类 javax.swing.JDialog 中的方法
添加指定的子 Component。
addImpl(Component, Object, int) - 类 javax.swing.JFrame 中的方法
添加指定的子 Component。
addImpl(Component, Object, int) - 类 javax.swing.JInternalFrame 中的方法
添加指定的子 Component。
addImpl(Component, Object, int) - 类 javax.swing.JLayeredPane 中的方法
addImpl(Component, Object, int) - 类 javax.swing.JRootPane 中的方法
重写以便将玻璃组件的位置强行设置成零位子级。
addImpl(Component, Object, int) - 类 javax.swing.JSplitPane 中的方法
将指定组件添加到此分隔窗格。
addImpl(Component, Object, int) - 类 javax.swing.JToolBar 中的方法
在添加 JButton 时，它最初被设置为 disabled。
addImpl(Component, Object, int) - 类 javax.swing.JViewport 中的方法
设置 JViewport 的轻量子对象，可以为 null。
addImpl(Component, Object, int) - 类 javax.swing.JWindow 中的方法
添加指定的子 Component。
addInputMethodListener(InputMethodListener) - 类 java.awt.Component 中的方法
添加指定的输入方法侦听器，以接收发自此组件的输入方法事件。
addInputMethodListener(InputMethodListener) - 类 javax.swing.text.JTextComponent 中的方法
addInternal(EventListener, EventListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从正添加的侦听器 a 和侦听器 b 中一起返回得到的多路广播侦听器。
addInternalFrameListener(InternalFrameListener) - 类 javax.swing.JInternalFrame 中的方法
添加指定的侦听器，以从此内部窗体接收内部窗体事件。
addInvalidComponent(JComponent) - 类 javax.swing.RepaintManager 中的方法
按照布局需要标记组件，并将事件指派线程的 runnable 排入队列，该线程将验证组件的第一个 isValidateRoot() 祖先。
addIssuer(X500Principal) - 类 java.security.cert.X509CRLSelector 中的方法
向 issuerNames 标准中添加名称。
addIssuerName(String) - 类 java.security.cert.X509CRLSelector 中的方法
已过时，使用 X509CRLSelector.addIssuer(X500Principal) 或 X509CRLSelector.addIssuerName(byte[]) 替代。
addIssuerName(byte[]) - 类 java.security.cert.X509CRLSelector 中的方法
向 issuerNames 标准中添加名称。
addItem(String) - 类 java.awt.Choice 中的方法
如果对于 Java 2 platform v1.1 已过时，请使用 add 方法替换。
addItem(String) - 类 java.awt.List 中的方法
已过时。 由 add(String) 取代。
addItem(String, int) - 类 java.awt.List 中的方法
已过时。 由 add(String, int) 取代。
addItem(Object) - 类 javax.swing.JComboBox 中的方法
为项列表添加项。
addItemListener(ItemListener) - 类 java.awt.Checkbox 中的方法
添加指定的项侦听器，以接收来自此复选框的项事件。
addItemListener(ItemListener) - 类 java.awt.CheckboxMenuItem 中的方法
添加指定的项侦听器，以接收发自此复选框菜单项的项事件。
addItemListener(ItemListener) - 类 java.awt.Choice 中的方法
添加指定的项侦听器，以接收发自此 Choice 菜单的项事件。
addItemListener(ItemListener) - 接口 java.awt.ItemSelectable 中的方法
添加侦听器，以接收用户更改项状态时的项事件。
addItemListener(ItemListener) - 类 java.awt.List 中的方法
添加指定的项侦听器以接收此列表的项事件。
addItemListener(ItemListener) - 类 javax.swing.AbstractButton 中的方法
将一个 ItemListener 添加到 checkbox 中。
addItemListener(ItemListener) - 接口 javax.swing.ButtonModel 中的方法
向模型添加一个 ItemListener。
addItemListener(ItemListener) - 类 javax.swing.DefaultButtonModel 中的方法
向模型添加一个 ItemListener。
addItemListener(ItemListener) - 类 javax.swing.JComboBox 中的方法
添加 ItemListener。
ADDITION - 接口 org.w3c.dom.events.MutationEvent 中的静态变量
只添加 Attr。
AdditionalComments - 类 javax.swing.text.html.HTMLDocument 中的静态变量
文档属性键值。
addKeyEventDispatcher(KeyEventDispatcher) - 类 java.awt.KeyboardFocusManager 中的方法
将 KeyEventDispatcher 添加到此 KeyboardFocusManager 的调度程序链中。
addKeyEventPostProcessor(KeyEventPostProcessor) - 类 java.awt.KeyboardFocusManager 中的方法
将 KeyEventPostProcessor 添加到此 KeyboardFocusManager 的后处理器链中。
addKeyListener(KeyListener) - 类 java.awt.Component 中的方法
添加指定的按键侦听器，以接收发自此组件的按键事件。
addKeymap(String, Keymap) - 类 javax.swing.text.JTextComponent 中的静态方法
将一个新 keymap 添加到 keymap 层次结构。
addLast(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的末尾。
addLast(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾；如果当前没有空间可用，则抛出 IllegalStateException。
addLast(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
addLast(E) - 接口 java.util.Deque 中的方法
将指定元素插入此双端队列的末尾（如果可以直接这样做而不违反容量限制）。
addLast(E) - 类 java.util.LinkedList 中的方法
将指定元素添加到此列表的结尾。
addLayoutComponent(Component, Object) - 类 java.awt.BorderLayout 中的方法
使用指定的约束对象将指定组件添加到布局中。
addLayoutComponent(String, Component) - 类 java.awt.BorderLayout 中的方法
已过时。 由 addLayoutComponent(Component, Object) 取代。
addLayoutComponent(Component, Object) - 类 java.awt.CardLayout 中的方法
将指定的组件添加到此卡片布局的内部名称表。
addLayoutComponent(String, Component) - 类 java.awt.CardLayout 中的方法
已过时。 由 addLayoutComponent(Component, Object) 取代。
addLayoutComponent(String, Component) - 类 java.awt.FlowLayout 中的方法
将指定的组件添加到布局中。
addLayoutComponent(String, Component) - 类 java.awt.GridBagLayout 中的方法
无效，因为此布局管理器不使用每组件字符串。
addLayoutComponent(Component, Object) - 类 java.awt.GridBagLayout 中的方法
使用指定 constraints 对象将指定组件添加到布局中。
addLayoutComponent(String, Component) - 类 java.awt.GridLayout 中的方法
将具有指定名称的指定组件添加到布局。
addLayoutComponent(String, Component) - 接口 java.awt.LayoutManager 中的方法
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
addLayoutComponent(Component, Object) - 接口 java.awt.LayoutManager2 中的方法
使用指定约束对象，将指定组件添加到布局。
addLayoutComponent(String, Component) - 类 javax.swing.BoxLayout 中的方法
此类不使用。
addLayoutComponent(Component, Object) - 类 javax.swing.BoxLayout 中的方法
此类不使用。
addLayoutComponent(String, Component) - 类 javax.swing.GroupLayout 中的方法
已将 Component 添加到父容器的通知。
addLayoutComponent(Component, Object) - 类 javax.swing.GroupLayout 中的方法
已将 Component 添加到父容器的通知。
addLayoutComponent(String, Component) - 类 javax.swing.JRootPane.RootLayout 中的方法
addLayoutComponent(Component, Object) - 类 javax.swing.JRootPane.RootLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
此 LayoutManager 方法不执行任何操作。
addLayoutComponent(String, Component) - 类 javax.swing.OverlayLayout 中的方法
将指定的组件添加到布局中。
addLayoutComponent(Component, Object) - 类 javax.swing.OverlayLayout 中的方法
使用指定的约束对象将指定组件添加到布局中。
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
在 place 位置添加组件。
addLayoutComponent(Component, Object) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
使用指定的约束对象将指定组件添加到布局中。
addLayoutComponent(String, Component) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
addLayoutComponent(String, Component) - 类 javax.swing.ScrollPaneLayout 中的方法
将指定的组件添加到布局中。
addLayoutComponent(String, Component) - 类 javax.swing.SpringLayout 中的方法
无效，因为此布局管理器不使用每组件字符串。
addLayoutComponent(Component, Object) - 类 javax.swing.SpringLayout 中的方法
如果 constraints 是 SpringLayout.Constraints 的一个实例，则将该约束与指定组件相关联。
addLayoutComponent(String, Component) - 类 javax.swing.ViewportLayout 中的方法
将指定的组件添加到布局中。
addLineListener(LineListener) - 接口 javax.sound.sampled.Line 中的方法
将侦听器添加到此行。
addListDataListener(ListDataListener) - 类 javax.swing.AbstractListModel 中的方法
将某个侦听器添加到每次更改数据模型都要通知的列表。
addListDataListener(ListDataListener) - 接口 javax.swing.ListModel 中的方法
将一个侦听器添加到每次在数据模型发生更改时都得到通知的列表。
addListSelectionListener(ListSelectionListener) - 类 javax.swing.DefaultListSelectionModel 中的方法
将侦听器添加到每次在选择发生更改时都得到通知的列表。
addListSelectionListener(ListSelectionListener) - 类 javax.swing.JList 中的方法
将侦听器添加到列表，每次选择发生更改时将获得通知；这是侦听选择状态更改的首选方式。
addListSelectionListener(ListSelectionListener) - 接口 javax.swing.ListSelectionModel 中的方法
将侦听器添加到每次在选择发生更改时都得到通知的列表。
addLogger(Logger) - 类 java.util.logging.LogManager 中的方法
添加指定的 logger。
addMailcap(String) - 类 javax.activation.MailcapCommandMap 中的方法
将条目添加到注册表。
addMember(Principal) - 接口 java.security.acl.Group 中的方法
向组中添加指定的成员。
addMenuDragMouseListener(MenuDragMouseListener) - 类 javax.swing.JMenuItem 中的方法
将 MenuDragMouseListener 添加到菜单项。
addMenuKeyListener(MenuKeyListener) - 类 javax.swing.JMenuItem 中的方法
将 MenuKeyListener 添加到菜单项。
addMenuKeyListener(MenuKeyListener) - 类 javax.swing.JPopupMenu 中的方法
将 MenuKeyListener 添加到弹出菜单。
addMenuListener(MenuListener) - 类 javax.swing.JMenu 中的方法
添加菜单事件的侦听器。
addMessageComponents(Container, GridBagConstraints, Object, int, boolean) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
创建表示 msg 的适当对象并将其置于 container 中。
addMetaEventListener(MetaEventListener) - 接口 javax.sound.midi.Sequencer 中的方法
注册一个元事件侦听器，以便在 sequence 中遇到元事件并由此 sequencer 处理时接收通知。
addMimeHeader(String, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将带有指定名称和值的 MIME 头添加到此 AttachmentPart 对象。
addMimeHeader(String, String) - 类 javax.xml.soap.SOAPPart 中的方法
使用指定名称和值创建 MimeHeader 对象，并将其添加到此 SOAPPart 对象。
addMimeTypes(String) - 类 javax.activation.MimetypesFileTypeMap 中的方法
将 MIME 类型值预先添加到注册表。
addMouseListener(MouseListener) - 类 java.awt.Component 中的方法
添加指定的鼠标侦听器，以接收发自此组件的鼠标事件。
addMouseListener(MouseListener) - 类 java.awt.TrayIcon 中的方法
添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标事件。
addMouseMotionListener(MouseMotionListener) - 类 java.awt.Component 中的方法
添加指定的鼠标移动侦听器，以接收发自此组件的鼠标移动事件。
addMouseMotionListener(MouseMotionListener) - 类 java.awt.TrayIcon 中的方法
添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标移动事件。
addMouseWheelListener(MouseWheelListener) - 类 java.awt.Component 中的方法
添加指定的鼠标滚轮侦听器，以接收发自此组件的鼠标滚轮事件。
addMtomAttachment(DataHandler, String, String) - 类 javax.xml.bind.attachment.AttachmentMarshaller 中的方法
将用于优化二进制存储的 MIME 内容 data 作为附件。
addMtomAttachment(byte[], int, int, String, String, String) - 类 javax.xml.bind.attachment.AttachmentMarshaller 中的方法
将用于优化二进制存储的二进制 data 作为附件。
addNamespaceDeclaration(String, String) - 接口 javax.xml.soap.SOAPElement 中的方法
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。
addNamingListener(Name, int, NamingListener) - 接口 javax.naming.event.EventContext 中的方法
添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
addNamingListener(String, int, NamingListener) - 接口 javax.naming.event.EventContext 中的方法
添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。
addNamingListener(Name, String, SearchControls, NamingListener) - 接口 javax.naming.event.EventDirContext 中的方法
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
addNamingListener(String, String, SearchControls, NamingListener) - 接口 javax.naming.event.EventDirContext 中的方法
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。
addNamingListener(Name, String, Object[], SearchControls, NamingListener) - 接口 javax.naming.event.EventDirContext 中的方法
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
addNamingListener(String, String, Object[], SearchControls, NamingListener) - 接口 javax.naming.event.EventDirContext 中的方法
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
addNodeChangeListener(NodeChangeListener) - 类 java.util.prefs.AbstractPreferences 中的方法
addNodeChangeListener(NodeChangeListener) - 类 java.util.prefs.Preferences 中的方法
注册指定侦听器以接收此节点的节点更改事件。
addNotification(String, String, Object, Date, long, long, boolean) - 类 javax.management.timer.Timer 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long, long) - 类 javax.management.timer.Timer 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long) - 类 javax.management.timer.Timer 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
addNotification(String, String, Object, Date) - 类 javax.management.timer.Timer 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long, long, boolean) - 接口 javax.management.timer.TimerMBean 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long, long) - 接口 javax.management.timer.TimerMBean 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
addNotification(String, String, Object, Date, long) - 接口 javax.management.timer.TimerMBean 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
addNotification(String, String, Object, Date) - 接口 javax.management.timer.TimerMBean 中的方法
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - 接口 javax.management.MBeanServer 中的方法
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - 接口 javax.management.MBeanServer 中的方法
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - 接口 javax.management.MBeanServerConnection 中的方法
向已注册的 MBean 添加一个侦听器。
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - 接口 javax.management.MBeanServerConnection 中的方法
向已注册的 MBean 添加一个侦听器。
addNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.MBeanServerDelegate 中的方法
addNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
注册一个将 NotificationListener 接口实现为侦听器的对象。
addNotificationListener(NotificationListener, NotificationFilter, Object) - 接口 javax.management.NotificationBroadcaster 中的方法
在此 MBean 中添加一个侦听器。
addNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.NotificationBroadcasterSupport 中的方法
添加一个侦听器。
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
addNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.StandardEmitterMBean 中的方法
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
addNotify() - 类 java.awt.Button 中的方法
创建按钮的同位体。
addNotify() - 类 java.awt.Canvas 中的方法
创建 canvas 的同位体。
addNotify() - 类 java.awt.Checkbox 中的方法
创建 Checkbox 的同位体。
addNotify() - 类 java.awt.CheckboxMenuItem 中的方法
创建复选框项的同位体。
addNotify() - 类 java.awt.Choice 中的方法
创建 Choice 的同位体。
addNotify() - 类 java.awt.Component 中的方法
通过将此 Component 连接到一个本机屏幕资源使其成为可显示的。
addNotify() - 类 java.awt.Container 中的方法
通过将这个 Container 连接到本机屏幕资源，使其可以显示。
addNotify() - 类 java.awt.Dialog 中的方法
通过将此 Dialog 连接到本机屏幕资源，从而使其成为可显示的。
addNotify(ComponentPeer) - 类 java.awt.dnd.DropTarget 中的方法
通知 DropTarget 它已经与某个 Component 关联。
addNotify(DropTargetContextPeer) - 类 java.awt.dnd.DropTargetContext 中的方法
与 DropTargetContextPeer 关联时调用。
addNotify() - 类 java.awt.FileDialog 中的方法
创建文件对话框的同位体。
addNotify() - 类 java.awt.Frame 中的方法
通过将此窗体连接到本机屏幕资源，使其成为可显示的。
addNotify() - 类 java.awt.Label 中的方法
创建此标签的同位体。
addNotify() - 类 java.awt.List 中的方法
创建列表的同位体。
addNotify() - 类 java.awt.Menu 中的方法
创建该菜单的同位体。
addNotify() - 类 java.awt.MenuBar 中的方法
创建该菜单栏的同位体。
addNotify() - 类 java.awt.MenuItem 中的方法
创建该菜单项的同位体。
addNotify() - 类 java.awt.Panel 中的方法
创建 Panel 的同位体。
addNotify() - 类 java.awt.PopupMenu 中的方法
创建弹出式菜单的同位体。
addNotify() - 类 java.awt.Scrollbar 中的方法
创建 Scrollbar 的同位体。
addNotify() - 类 java.awt.ScrollPane 中的方法
创建滚动窗格的同位体。
addNotify() - 类 java.awt.TextArea 中的方法
创建 TextArea 的同位体。
addNotify() - 类 java.awt.TextComponent 中的方法
通过将此 Component 连接到一个本机屏幕资源，使其成为可显示的。
addNotify() - 类 java.awt.TextField 中的方法
创建 TextField 的同位体。
addNotify() - 类 java.awt.Window 中的方法
通过创建到本机屏幕资源的连接，使此窗口变得可显示。
addNotify() - 类 javax.swing.JComponent 中的方法
通知此组件它现在已有了一个父组件。
addNotify() - 类 javax.swing.JMenuBar 中的方法
重写 JComponent.addNotify 以向当前键盘管理器注册此菜单栏。
addNotify() - 类 javax.swing.JRootPane 中的方法
将本身注册为 SystemEventQueueUtils 的新的根窗格。
addNotify() - 类 javax.swing.JTable 中的方法
调用 configureEnclosingScrollPane 方法。
addNotify() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
addNotUnderstoodHeaderElement(QName) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定名称初始化的新的 NotUnderstood SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addObjectValue(String, Class<T>, boolean, T) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
addObjectValue(String, Class<T>, boolean, T, List<? extends T>) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
addObjectValue(String, Class<T>, T, Comparable<? super T>, Comparable<? super T>, boolean, boolean) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
addObjectValue(String, Class<?>, int, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
addObservedObject(ObjectName) - 类 javax.management.monitor.Monitor 中的方法
如果尚未显示此对象，则在观察到的 MBean 集中添加指定的对象。
addObservedObject(ObjectName) - 接口 javax.management.monitor.MonitorMBean 中的方法
将指定的对象添加到所观察的 MBean 集中。
addObserver(Observer) - 类 java.util.Observable 中的方法
如果观察者与集合中已有的观察者不同，则向对象的观察者集中添加此观察者。
addOwner(Principal, Principal) - 接口 java.security.acl.Owner 中的方法
添加一个所有者。
addPathToName(int, String) - 类 java.security.cert.X509CertSelector 中的方法
向 pathToNames 标准中添加一个名称。
addPathToName(int, byte[]) - 类 java.security.cert.X509CertSelector 中的方法
向 pathToNames 标准中添加一个名称。
addPermission(Permission) - 接口 java.security.acl.AclEntry 中的方法
向此 ACL 项添加指定的权限。
addPoint(int, int) - 类 java.awt.Polygon 中的方法
将指定的坐标追加到此 Polygon。
addPopupMenuListener(PopupMenuListener) - 类 javax.swing.JComboBox 中的方法
添加 PopupMenu 侦听器，该侦听器将侦听取自组合框弹出部分的通知消息。
addPopupMenuListener(PopupMenuListener) - 类 javax.swing.JPopupMenu 中的方法
添加 PopupMenu 侦听器。
addPort(QName, String, String) - 类 javax.xml.ws.Service 中的方法
为服务创建新的端口。
addPort(QName, String, String) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
为服务创建新的端口。
addPreferenceChangeListener(PreferenceChangeListener) - 类 java.util.prefs.AbstractPreferences 中的方法
addPreferenceChangeListener(PreferenceChangeListener) - 类 java.util.prefs.Preferences 中的方法
注册指定侦听器以接收此首选项节点的首选项更改事件。
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示两个组件之间首选间隙的元素。
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示两个组件之间首选间隙的元素。
addPreferredGap(LayoutStyle.ComponentPlacement) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示两个距离最近的组件之间首选间隙的元素。
addPreferredGap(LayoutStyle.ComponentPlacement, int, int) - 类 javax.swing.GroupLayout.SequentialGroup 中的方法
添加一个表示两个距离最近的组件之间首选间隙的元素。
addPrintJobAttributeListener(PrintJobAttributeListener, PrintJobAttributeSet) - 接口 javax.print.DocPrintJob 中的方法
为指定属性中的更改注册一个侦听器。
addPrintJobListener(PrintJobListener) - 接口 javax.print.DocPrintJob 中的方法
为此 PrintJob 执行期间所出现的事件注册一个侦听器。
addPrintServiceAttributeListener(PrintServiceAttributeListener) - 接口 javax.print.PrintService 中的方法
为此 PrintService 上的事件注册一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
将 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Component 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Component 中的方法
向指定属性的侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Container.AccessibleAWTContainer 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Container 中的方法
将一个 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Container 中的方法
将一个 PropertyChangeListener 添加到某个指定属性的侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
将 PropertyChangeListener 添加到特定属性的侦听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.SystemTray 中的方法
将 PropertyChangeListener 添加到特定属性的侦听器列表中。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Toolkit 中的方法
为指定的桌面属性添加指定的属性更改侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.awt.Window 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Window 中的方法
将 PropertyChangeListener 添加到某个特定属性的侦听器列表。
addPropertyChangeListener(String, PropertyChangeListener) - 接口 java.beans.beancontext.BeanContextChild 中的方法
将一个 PropertyChangeListener 添加到此 BeanContextChild 中，以便无论指定属性何时发生更改都可以接收一个 PropertyChangeEvent。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
为特定属性添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 接口 java.beans.Customizer 中的方法
注册一个用于 PropertyChange 事件的侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.beans.PropertyChangeSupport 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(String, PropertyChangeListener) - 类 java.beans.PropertyChangeSupport 中的方法
为指定的属性向侦听器列表中添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 接口 java.beans.PropertyEditor 中的方法
注册一个用于 PropertyChange 事件的侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.beans.PropertyEditorSupport 中的方法
注册一个用于 PropertyChange 事件的侦听器。
addPropertyChangeListener(PropertyChangeListener) - 接口 java.util.jar.Pack200.Packer 中的方法
为属性映射上的 PropertyChange 事件注册一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - 接口 java.util.jar.Pack200.Unpacker 中的方法
为属性映射上的 PropertyChange 事件注册一个侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 java.util.logging.LogManager 中的方法
添加重读日志属性时调用的事件侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.accessibility.AccessibleContext 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.AbstractAction 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 接口 javax.swing.Action 中的方法
添加一个 PropertyChange 侦听器。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
将一个 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
将一个 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
将一个 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.SwingWorker 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.table.TableColumn 中的方法
向侦听器列表中添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
将 PropertyChangeListener 添加到侦听器列表。
addPropertyChangeListener(PropertyChangeListener) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
将一个 PropertyChangeListener 添加到侦听器列表中。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.UIDefaults 中的方法
向侦听器列表添加一个 PropertyChangeListener。
addPropertyChangeListener(PropertyChangeListener) - 类 javax.swing.UIManager 中的静态方法
将一个 PropertyChangeListener 添加到侦听器列表。
addProvider(Provider) - 类 java.security.Security 中的静态方法
将提供者添加到下一个可用位置。
addProviderAtEnd(Provider, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
addProviderAtFront(Provider, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。
addRelation(ObjectName) - 类 javax.management.relation.RelationService 中的方法
作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
addRelation(ObjectName) - 接口 javax.management.relation.RelationServiceMBean 中的方法
作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
addRelationType(RelationType) - 类 javax.management.relation.RelationService 中的方法
作为关系类型添加给定的对象。
addRelationType(RelationType) - 接口 javax.management.relation.RelationServiceMBean 中的方法
作为关系类型添加给定的对象。
addRenderingHints(Map<?, ?>) - 类 java.awt.Graphics2D 中的方法
为呈现算法设置任意数量的首选项值。
addRequestProperty(String, String) - 类 java.net.URLConnection 中的方法
添加由键值对指定的一般请求属性。
addResourceBundle(String) - 类 javax.swing.UIDefaults 中的方法
将一个资源包添加到从中搜索本地化值的资源包的列表中。
address() - 类 java.net.Proxy 中的方法
返回代理的套接字地址，如果其为直接连接，则返回 null。
address - 类 java.net.SocketImpl 中的变量
此套接字的远程端点的 IP 地址。
ADDRESS - 类 javax.swing.text.html.HTML.Tag 中的静态变量
AddressHelper - org.omg.CosNaming.NamingContextExtPackage 中的 类
地址是以 String 形式表示的主机和端口信息。
AddressHelper() - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 的构造方法
addRoleInfo(RoleInfo) - 类 javax.management.relation.RelationTypeSupport 中的方法
添加角色信息。
addRow(Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
添加一行到模型的结尾。
addRow(Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
添加一行到模型的结尾。
addRowSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
将从 index0 到 index1 之间（包含两端）的行添加到当前选择中。
addRowSet(Joinable) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将给定的 RowSet 对象添加到此 JoinRowSet 对象。
addRowSet(RowSet, int) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将给定的 RowSet 对象添加到此 JoinRowSet 对象，并将指定的列设置为 RowSet 对象的匹配列。
addRowSet(RowSet, String) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。
addRowSet(RowSet[], int[]) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列索引数组中的匹配列。
addRowSet(RowSet[], String[]) - 接口 javax.sql.rowset.JoinRowSet 中的方法
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。
addRowSetListener(RowSetListener) - 接口 javax.sql.RowSet 中的方法
注册给定侦听器，以便此 RowSet 对象上发生事件时将得到通知。
addRowSetListener(RowSetListener) - 类 javax.sql.rowset.BaseRowSet 中的方法
只要在此 RowSet 对象上发生事件，就将通知该侦听器。
addRowSorterListener(RowSorterListener) - 类 javax.swing.RowSorter 中的方法
添加一个 RowSorterListener 来接收有关此 RowSorter 的通知。
addrs - 类 javax.naming.Reference 中的变量
包含此 Reference 中所包含的地址。
addrType - 类 javax.naming.RefAddr 中的变量
包含此地址的类型。
addRule(String) - 类 javax.swing.text.html.StyleSheet 中的方法
向 sheet 添加规则集合。
addSelectionInterval(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
将选择更改为当前选择与 index0 和 index1（包括）之间索引的并集。
addSelectionInterval(int, int) - 类 javax.swing.JList 中的方法
将选择设置为指定间隔与当前选择的并集。
addSelectionInterval(int, int) - 类 javax.swing.JTree 中的方法
将 index0 和 index1（包含）之间的路径添加到该选择。
addSelectionInterval(int, int) - 接口 javax.swing.ListSelectionModel 中的方法
将选择更改为当前选择与 index0 和 index1 之间（包括两者）索引的并集。
addSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
将由指定的 TreePath 标识的节点添加到当前选择。
addSelectionPath(TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
将路径添加到当前的 selection 中。
addSelectionPath(TreePath) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
将路径添加到当前的选择中。
addSelectionPaths(TreePath[]) - 类 javax.swing.JTree 中的方法
将路径数组中的每个路径添加到当前选择。
addSelectionPaths(TreePath[]) - 类 javax.swing.JTree.EmptySelectionModel 中的方法
一个未添加任何内容的 null 实现。
addSelectionPaths(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
向当前的 selection 中添加路径。
addSelectionPaths(TreePath[]) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
向当前的选择中添加路径。
addSelectionRow(int) - 类 javax.swing.JTree 中的方法
将指定行处的路径添加到当前选择。
addSelectionRows(int[]) - 类 javax.swing.JTree 中的方法
将每个指定行处的路径添加到当前选择。
addSeparator() - 类 java.awt.Menu 中的方法
将一个分隔线或连字符添加到菜单的当前位置。
addSeparator() - 类 javax.swing.JMenu 中的方法
将新分隔符追加到菜单的末尾。
addSeparator() - 类 javax.swing.JPopupMenu 中的方法
将新分隔符添加到菜单的末尾。
addSeparator() - 类 javax.swing.JToolBar 中的方法
将默认大小的分隔符添加到工具栏的末尾。
addSeparator(Dimension) - 类 javax.swing.JToolBar 中的方法
将指定大小的分隔符添加到工具栏的末尾。
addService(Class, BeanContextServiceProvider) - 接口 java.beans.beancontext.BeanContextServices 中的方法
向此 BeanContext 添加服务。
addService(Class, BeanContextServiceProvider) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
添加服务。
addService(Class, BeanContextServiceProvider, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
添加服务。
addShutdownHook(Thread) - 类 java.lang.Runtime 中的方法
注册新的虚拟机来关闭钩子。
addSingletonComponent(Component, Component) - 类 javax.swing.ScrollPaneLayout 中的方法
移除现有组件。
addSource(Object) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将一个图像添加到源列表的末尾。
addSource(DOMImplementationSource) - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的方法
注册实现。
addSpecialElement(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
添加基本上完全是在属性集中指定的内容。
addStatementEventListener(StatementEventListener) - 接口 javax.sql.PooledConnection 中的方法
向此 PooledConnection 对象注册一个 StatementEventListener。
addStyle(String, Style) - 类 javax.swing.JTextPane 中的方法
将一个新样式添加到逻辑样式层次结构中。
addStyle(String, Style) - 类 javax.swing.text.DefaultStyledDocument 中的方法
向逻辑样式层次结构中添加新样式。
addStyle(String, Style) - 类 javax.swing.text.StyleContext 中的方法
将新的样式添加到样式层次中。
addStyle(String, Style) - 接口 javax.swing.text.StyledDocument 中的方法
向逻辑样式层次中添加新样式。
addStyleSheet(StyleSheet) - 类 javax.swing.text.html.StyleSheet 中的方法
将 StyleSheet ss 中的规则添加到接收者的规则中。
addSubComponents() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
addSubComponents() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
重写父级的方法，避免创建一个菜单栏。
addSubjectAlternativeName(int, String) - 类 java.security.cert.X509CertSelector 中的方法
向 subjectAlternativeNames 标准中添加一个名称。
addSubjectAlternativeName(int, byte[]) - 类 java.security.cert.X509CertSelector 中的方法
向 subjectAlternativeNames 标准中添加一个名称。
addSwaRefAttachment(DataHandler) - 类 javax.xml.bind.attachment.AttachmentMarshaller 中的方法
将 MIME data 作为附件添加，并返回附件的内容 id（即 cid）。
addSystemMenuItems(JMenu) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
addSystemMenuItems(JMenu) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
重写父级的方法，使其不执行任何操作。
addTab(String, Icon, Component, String) - 类 javax.swing.JTabbedPane 中的方法
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。
addTab(String, Icon, Component) - 类 javax.swing.JTabbedPane 中的方法
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。
addTab(String, Component) - 类 javax.swing.JTabbedPane 中的方法
添加一个由 title 表示，且没有图标的 component。
addTableModelListener(TableModelListener) - 类 javax.swing.table.AbstractTableModel 中的方法
每次数据模型发生更改时，就向被通知的列表添加一个侦听器。
addTableModelListener(TableModelListener) - 接口 javax.swing.table.TableModel 中的方法
每当数据模型发生更改时，就将一个侦听器添加到被通知的列表中。
addTag - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
HTML 中的 Tag（从此 Tag 开始添加标记）。
addTask(Runnable) - 类 javax.swing.text.LayoutQueue 中的方法
添加一个任务，该任务不必立即执行，原因是其结果可能是不可见的。
addTextListener(TextListener) - 类 java.awt.TextComponent 中的方法
添加指定的文本事件侦听器，以接收此文本组件发出的文本事件。
addTextNode(String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。
addTileObserver(TileObserver) - 类 java.awt.image.BufferedImage 中的方法
添加一个 tile observer。
addTileObserver(TileObserver) - 接口 java.awt.image.WritableRenderedImage 中的方法
添加一个观察器。
addTo(Calendar) - 类 javax.xml.datatype.Duration 中的方法
将此持续时间添加到 Calendar 对象。
addTo(Date) - 类 javax.xml.datatype.Duration 中的方法
将此持续时间添加到 Date 对象。
addToEnvironment(String, Object) - 接口 javax.naming.Context 中的方法
将一个新环境属性添加到此上下文的环境中。
addToEnvironment(String, Object) - 类 javax.naming.InitialContext 中的方法
addTransformer(ClassFileTransformer, boolean) - 接口 java.lang.instrument.Instrumentation 中的方法
注册提供的转换器。
addTransformer(ClassFileTransformer) - 接口 java.lang.instrument.Instrumentation 中的方法
注册提供的转换器。
addTreeExpansionListener(TreeExpansionListener) - 类 javax.swing.JTree 中的方法
为 TreeExpansion 事件添加侦听器。
addTreeModelListener(TreeModelListener) - 类 javax.swing.tree.DefaultTreeModel 中的方法
为树更改后发布的 TreeModelEvent 添加侦听器。
addTreeModelListener(TreeModelListener) - 接口 javax.swing.tree.TreeModel 中的方法
为树更改后发布的 TreeModelEvent 添加侦听器。
addTreeSelectionListener(TreeSelectionListener) - 类 javax.swing.JTree 中的方法
为 TreeSelection 事件添加侦听器。
addTreeSelectionListener(TreeSelectionListener) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
向每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表添加 x。
addTreeSelectionListener(TreeSelectionListener) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
向侦听器列表添加 x，每次选定的 TreePath 集合发生更改时，这些侦听器都会得到通知。
addTreeWillExpandListener(TreeWillExpandListener) - 类 javax.swing.JTree 中的方法
为 TreeWillExpand 事件添加侦听器。
addUndoableEditListener(UndoableEditListener) - 类 javax.swing.text.AbstractDocument 中的方法
添加负责通知任何更改的撤消侦听器。
addUndoableEditListener(UndoableEditListener) - 接口 javax.swing.text.Document 中的方法
注册给定的观察者以便开始接收文档发生不可撤消的编辑的通知。
addUndoableEditListener(UndoableEditListener) - 类 javax.swing.undo.UndoableEditSupport 中的方法
注册一个 UndoableEditListener。
addUnencodedNativeForFlavor(DataFlavor, String) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
添加从指定的 DataFlavor（和等于指定 DataFlavor 的所有 DataFlavor）到指定 String native 的映射。
addUpgradeHeaderElement(Iterator) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addUpgradeHeaderElement(String[]) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addUpgradeHeaderElement(String) - 接口 javax.xml.soap.SOAPHeader 中的方法
创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。
addURL(URL) - 类 java.net.URLClassLoader 中的方法
将指定的 URL 添加到 URL 列表中，以便搜索类和资源。
addURL(URL) - 类 javax.management.loading.MLet 中的方法
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
addURL(String) - 类 javax.management.loading.MLet 中的方法
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
addURL(URL) - 接口 javax.management.loading.MLetMBean 中的方法
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
addURL(String) - 接口 javax.management.loading.MLetMBean 中的方法
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
addVetoableChangeListener(VetoableChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
将 VetoableChangeListener 添加到侦听器列表。
addVetoableChangeListener(String, VetoableChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
将 VetoableChangeListener 添加到特定属性的侦听器列表。
addVetoableChangeListener(String, VetoableChangeListener) - 接口 java.beans.beancontext.BeanContextChild 中的方法
将一个 VetoableChangeListener 添加到此 BeanContextChild，以便无论指定属性何时发生更改都可以接收事件。
addVetoableChangeListener(String, VetoableChangeListener) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
为特定属性添加一个 VetoableChangeListener。
addVetoableChangeListener(VetoableChangeListener) - 类 java.beans.VetoableChangeSupport 中的方法
向侦听器列表添加一个 VetoableListener。
addVetoableChangeListener(String, VetoableChangeListener) - 类 java.beans.VetoableChangeSupport 中的方法
为特定属性添加一个 VetoableChangeListener。
addVetoableChangeListener(VetoableChangeListener) - 类 javax.swing.JComponent 中的方法
向侦听器列表添加一个 VetoableChangeListener。
addWindowFocusListener(WindowFocusListener) - 类 java.awt.Window 中的方法
添加指定的窗口焦点侦听器，以从此窗口接收窗口事件。
addWindowListener(WindowListener) - 类 java.awt.Window 中的方法
添加指定的窗口侦听器，以从此窗口接收窗口事件。
addWindowStateListener(WindowStateListener) - 类 java.awt.Window 中的方法
添加指定的窗口状态侦听器，以从此窗口接收窗口事件。
Adjustable - java.awt 中的 接口
此接口用于那些具有可调整数值的对象，数值应包含在有限范围的值之内。
adjustAllocation(Shape) - 类 javax.swing.text.FieldView 中的方法
调整给定视图的分配区域，使其适合文本字段的分配区域。
adjustForGravity(GridBagConstraints, Rectangle) - 类 java.awt.GridBagLayout 中的方法
根据约束几何结构和填充将 x、y、宽度和高度四个字段调整为正确值。
AdjustForGravity(GridBagConstraints, Rectangle) - 类 java.awt.GridBagLayout 中的方法
此方法已过时，仅为提供向后兼容性；新代码应该调用 adjustForGravity 来代替。
ADJUSTMENT_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择调整事件的事件掩码。
ADJUSTMENT_FIRST - 类 java.awt.event.AdjustmentEvent 中的静态变量
标记调整事件 id 范围的第一个整数 id。
ADJUSTMENT_LAST - 类 java.awt.event.AdjustmentEvent 中的静态变量
标记调整事件 id 范围的最后一个整数 id。
ADJUSTMENT_VALUE_CHANGED - 类 java.awt.event.AdjustmentEvent 中的静态变量
调整值更改事件。
AdjustmentEvent - java.awt.event 中的 类
由 Adjustable 对象所发出的调整事件。
AdjustmentEvent(Adjustable, int, int, int) - 类 java.awt.event.AdjustmentEvent 的构造方法
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。
AdjustmentEvent(Adjustable, int, int, int, boolean) - 类 java.awt.event.AdjustmentEvent 的构造方法
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。
AdjustmentListener - java.awt.event 中的 接口
用于接收调整事件的侦听器接口。
adjustmentValueChanged(AdjustmentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 adjustmentValueChanged 方法处理 adjustmentValueChanged 事件。
adjustmentValueChanged(AdjustmentEvent) - 接口 java.awt.event.AdjustmentListener 中的方法
在可调整的值发生更改时调用该方法。
adjustRow(FlowView, int, int, int) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
如有可能，调整给定行以使其适合布局区域。
adjustRow(ParagraphView.Row, int, int) - 类 javax.swing.text.ParagraphView 中的方法
如有可能，调整给定行以使其处于布局区域内。
adjustSizes(int, SizeRequirements[]) - 类 javax.swing.SizeRequirements 中的静态方法
按给定总量调整指定的大小数组。
adjustVisibility(Rectangle) - 类 javax.swing.text.DefaultCaret 中的方法
滚动关联的视图（如果有）以使插入符可见。
Adler32 - java.util.zip 中的 类
可用于计算数据流的 Adler-32 校验和的类。
Adler32() - 类 java.util.zip.Adler32 的构造方法
创建新的 Adler32 对象。
ADMIN_UIROLE - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个充当管理角色的 UI。
adoptNode(Node) - 接口 org.w3c.dom.Document 中的方法
试图把另一文档中的节点采用到此文档。
AEGEAN_NUMBERS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Aegean Numbers”Unicode 字符块的常量。
AffineTransform - java.awt.geom 中的 类
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
AffineTransform() - 类 java.awt.geom.AffineTransform 的构造方法
构造一个表示恒等变换的新 AffineTransform。
AffineTransform(AffineTransform) - 类 java.awt.geom.AffineTransform 的构造方法
构造一个新 AffineTransform，让它作为指定 AffineTransform 对象的副本。
AffineTransform(float, float, float, float, float, float) - 类 java.awt.geom.AffineTransform 的构造方法
根据表示 3x3 变换矩阵 6 个可指定条目的 6 个浮点值构造一个新 AffineTransform。
AffineTransform(float[]) - 类 java.awt.geom.AffineTransform 的构造方法
根据一个浮点值数组构造一个新 AffineTransform，该数组要么表示 3x3 变换矩阵的 4 个非平移条目，要么表示 3x3 变换矩阵的 6 个可指定条目。
AffineTransform(double, double, double, double, double, double) - 类 java.awt.geom.AffineTransform 的构造方法
根据表示 3x3 变换矩阵 6 个可指定条目的 6 个双精度值构造一个新 AffineTransform。
AffineTransform(double[]) - 类 java.awt.geom.AffineTransform 的构造方法
根据双精度值数组构造一个新 AffineTransform，该数组要么表示 3x3 变换矩阵的 4 个非平移条目，要么表示它的 6 个可指定条目。
AffineTransformOp - java.awt.image 中的 类
此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。
AffineTransformOp(AffineTransform, RenderingHints) - 类 java.awt.image.AffineTransformOp 的构造方法
根据仿射转换构造 AffineTransformOp。
AffineTransformOp(AffineTransform, int) - 类 java.awt.image.AffineTransformOp 的构造方法
根据仿射转换和插值类型构造一个 AffineTransformOp。
after(Timestamp) - 类 java.sql.Timestamp 中的方法
指示此 Timestamp 对象是否晚于给定的 Timestamp 对象。
after(Object) - 类 java.util.Calendar 中的方法
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之后，返回判断结果。
after(Date) - 类 java.util.Date 中的方法
测试此日期是否在指定日期之后。
AFTER_LAST_LINE - 类 java.awt.BorderLayout 中的静态变量
与 PAGE_END 同义。
AFTER_LINE_ENDS - 类 java.awt.BorderLayout 中的静态变量
与 LINE_END 同义。
afterExecute(Runnable, Throwable) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
基于完成执行给定 Runnable 所调用的方法。
afterLast() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的末尾，正好位于最后一行之后。
afterMarshal(Object) - 类 javax.xml.bind.Marshaller.Listener 中的方法

将 source 编组到 XML 之后调用的回调方法。

afterOffset(int) - 类 java.awt.font.TextHitInfo 中的静态方法
在指定偏移量处创建一个与偏移量之后的字符关联的 TextHitInfo。
afterUnmarshal(Object, Object) - 类 javax.xml.bind.Unmarshaller.Listener 中的方法

将 XML 数据解组到 target 之后调用的回调方法。

AIFC - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 AIFF-C 文件。
AIFF - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 AIFF 文件。
ALAW - 类 javax.sound.sampled.AudioFormat.Encoding 中的静态变量
指定 a-law 编码数据。
ALERT - 类 javax.accessibility.AccessibleRole 中的静态变量
可用于就某事向用户报警的对象。
AlgorithmMethod - javax.xml.crypto 中的 接口
XML Security 规范中定义的算法的抽象表示。
AlgorithmParameterGenerator - java.security 中的 类
AlgorithmParameterGenerator 类用于生成将在某个特定算法中使用的参数集合。
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi, Provider, String) - 类 java.security.AlgorithmParameterGenerator 的构造方法
创建一个 AlgorithmParameterGenerator 对象。
AlgorithmParameterGeneratorSpi - java.security 中的 类
此类为 AlgorithmParameterGenerator 类定义服务提供者接口 (SPI)，AlgorithmParameterGenerator 类用于生成在某个特定算法中使用的参数集合。
AlgorithmParameterGeneratorSpi() - 类 java.security.AlgorithmParameterGeneratorSpi 的构造方法
AlgorithmParameters - java.security 中的 类
此类用作密码参数的不透明表示形式。
AlgorithmParameters(AlgorithmParametersSpi, Provider, String) - 类 java.security.AlgorithmParameters 的构造方法
创建一个 AlgorithmParameters 对象。
AlgorithmParameterSpec - java.security.spec 中的 接口
加密参数的（透明）规范。
AlgorithmParametersSpi - java.security 中的 类
此类为 AlgorithmParameters 类定义服务提供者接口 (SPI)，AlgorithmParameters 类用于管理算法参数。
AlgorithmParametersSpi() - 类 java.security.AlgorithmParametersSpi 的构造方法
aliases() - 类 java.nio.charset.Charset 中的方法
返回包含此 charset 各个别名的集合。
aliases() - 类 java.security.KeyStore 中的方法
列出此 keystore 的所有别名。
ALIGN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ALIGN_BAR - 类 javax.swing.text.TabStop 中的静态变量
ALIGN_CENTER - 类 javax.swing.text.StyleConstants 中的静态变量
段落对齐的可能值。
ALIGN_CENTER - 类 javax.swing.text.TabStop 中的静态变量
制表符后的字符所放置的位置：直到下一个制表符/新行的所有字符都以制表符位置为中心放置。
ALIGN_DECIMAL - 类 javax.swing.text.TabStop 中的静态变量
制表符后的字符对齐的方式：下一个数字/制表符/新行位于制表符位置，与 RIGHT_TAB 非常类似，仅包括了数字作为要查找的附加字符。
ALIGN_JUSTIFIED - 类 javax.swing.text.StyleConstants 中的静态变量
段落对齐的可能值。
ALIGN_LEFT - 类 javax.swing.text.StyleConstants 中的静态变量
段落对齐方式的可能值。
ALIGN_LEFT - 类 javax.swing.text.TabStop 中的静态变量
制表符后的字符所放置的位置。
ALIGN_RIGHT - 类 javax.swing.text.StyleConstants 中的静态变量
段落对齐的可能值。
ALIGN_RIGHT - 类 javax.swing.text.TabStop 中的静态变量
制表符后的字符所放置的位置：直到下一个制表符/新行的所有字符都以此位置结束。
alignment - 类 javax.swing.SizeRequirements 中的变量
对齐方式，指定为介于 0.0 和 1.0 之间的值，包含这两个边界值。
Alignment - 类 javax.swing.text.StyleConstants 中的静态变量
段落的对齐方式。
ALINK - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ALL - 类 java.awt.JobAttributes.DefaultSelectionType 中的静态变量
用于指定应该打印全部作业页面的 DefaultSelectionType 实例。
ALL - 类 java.util.logging.Level 中的静态变量
ALL 指示应该记录所有消息。
ALL_COLUMNS - 类 javax.swing.event.TableModelEvent 中的静态变量
指定一行或一些行中的所有列。
ALL_RANGES - 类 java.awt.font.NumericShaper 中的静态变量
标识所有的范围，用于完整的上下文成形。
ALL_STYLES - 类 java.util.Calendar 中的静态变量
指示所有风格名称的 getDisplayNames 的风格说明符，比如 "January" 和 "Jan"。
ALLBITS - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示现在已完成了一幅以前绘制的静态图像，并且可以其最终形式再次绘制它。
allKeys() - 类 javax.swing.ActionMap 中的方法
返回在此 ActionMap 及其父级中定义的键所组成的数组。
allKeys() - 类 javax.swing.InputMap 中的方法
返回在此 InputMap 及其父级中定义的 KeyStroke 组成的数组。
allNotesOff() - 接口 javax.sound.midi.MidiChannel 中的方法
关闭此通道上当前发声的所有音符。
allocate(int) - 类 java.nio.ByteBuffer 中的静态方法
分配一个新的字节缓冲区。
allocate(int) - 类 java.nio.CharBuffer 中的静态方法
分配新的字符缓冲区。
allocate(int) - 类 java.nio.DoubleBuffer 中的静态方法
分配新的 double 缓冲区。
allocate(int) - 类 java.nio.FloatBuffer 中的静态方法
分配新的 float 缓冲区。
allocate(int) - 类 java.nio.IntBuffer 中的静态方法
分配新的 int 缓冲区。
allocate(int) - 类 java.nio.LongBuffer 中的静态方法
分配新的 long 缓冲区。
allocate(int) - 类 java.nio.ShortBuffer 中的静态方法
分配新的 short 缓冲区。
allocate(XMLStreamReader) - 接口 javax.xml.stream.util.XMLEventAllocator 中的方法
此方法在给定 XMLStreamReader 当前状态的情况下分配事件。
allocate(XMLStreamReader, XMLEventConsumer) - 接口 javax.xml.stream.util.XMLEventAllocator 中的方法
此方法在给定 XMLStreamReader 当前状态的情况下分配一个事件或一个事件组，并将该事件或事件组添加给传入的使用者。
allocate_slot_id() - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
调用此方法来在 PortableInterceptor.Current 上分配槽 (slot)。
allocateArray(int) - 类 javax.swing.text.GapContent 中的方法
分配一个存储适当类型项的数组（由子类确定）。
allocateDirect(int) - 类 java.nio.ByteBuffer 中的静态方法
分配新的直接字节缓冲区。
ALLOCATOR - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于设置/获取分配器实现的属性。
allOf(Class<E>) - 类 java.util.EnumSet 中的静态方法
创建一个包含指定元素类型的所有元素的枚举 set。
ALLOW_UNASSIGNED - 类 java.net.IDN 中的静态变量
允许处理未分配代码点的标志。
allowCoreThreadTimeOut(boolean) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
如果在保持活动时间内没有任务到达，新任务到达时正在替换（如果需要），则设置控制核心线程是超时还是终止的策略。
ALLOWED_CLASSNAMES - 类 javax.management.openmbean.OpenType 中的静态变量
已过时。 使用 ALLOWED_CLASSNAMES_LIST 取代。
ALLOWED_CLASSNAMES_LIST - 类 javax.management.openmbean.OpenType 中的静态变量
开放数据值允许的 Java 类的完全限定名称的列表。
allowMultipleSelections() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取布尔值，该布尔值确定是否允许从该 choices 列表进行多重选择。
allowsChildren - 类 javax.swing.tree.DefaultMutableTreeNode 中的变量
如果该节点可以有子节点，则为 true
allowsCoreThreadTimeOut() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
如果此池允许核心线程超时和终止，如果在 keepAlive 时间内没有任务到达，新任务到达时正在替换（如果需要），则返回 true。
allowsMultipleSelections() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 isMultipleMode() 取代。
allowThreadSuspension(boolean) - 类 java.lang.ThreadGroup 中的方法
已过时。 此调用的定义取决于 ThreadGroup.suspend()，它被废弃了。更进一步地说，此调用的行为从不被指定。
allowUserInteraction - 类 java.net.URLConnection 中的变量
如果为 true，则在允许用户交互（例如弹出一个验证对话框）的上下文中对此 URL 进行检查。
AllPermission - java.security 中的 类
AllPermission 是暗含所有其他权限的权限。
AllPermission() - 类 java.security.AllPermission 的构造方法
创建新的 AllPermission 对象。
AllPermission(String, String) - 类 java.security.AllPermission 的构造方法
创建新的 AllPermission 对象。
allProceduresAreCallable() - 接口 java.sql.DatabaseMetaData 中的方法
获取当前用户是否可以调用 getProcedures 方法返回的所有过程。
allRowsChanged() - 类 javax.swing.DefaultRowSorter 中的方法
当底层模型的内容完全更改时，调用此方法。
allRowsChanged() - 类 javax.swing.RowSorter 中的方法
当底层模型的内容完全更改时，调用此方法。
allSoundOff() - 接口 javax.sound.midi.MidiChannel 中的方法
立即关闭通道上所有发声的音符，同时忽略当前 Instrument 的 Hold Pedal 状态和内部衰减率。
allTablesAreSelectable() - 接口 java.sql.DatabaseMetaData 中的方法
获取当前用户是否可以使用 SELECT 语句中的 getTables 方法返回的所有表。
ALPHABETIC_PRESENTATION_FORMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Alphabetic Presentation Forms”Unicode 字符块的常量。
AlphaComposite - java.awt 中的 类
AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。
AlreadyBound - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
AlreadyBound() - 异常 org.omg.CosNaming.NamingContextPackage.AlreadyBound 的构造方法
AlreadyBound(String) - 异常 org.omg.CosNaming.NamingContextPackage.AlreadyBound 的构造方法
AlreadyBoundException - java.rmi 中的 异常
如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
AlreadyBoundException() - 异常 java.rmi.AlreadyBoundException 的构造方法
构造不带指定详细消息的 AlreadyBoundException。
AlreadyBoundException(String) - 异常 java.rmi.AlreadyBoundException 的构造方法
构造带指定详细消息的 AlreadyBoundException。
AlreadyBoundHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java。
AlreadyBoundHelper() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 的构造方法
AlreadyBoundHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java。
AlreadyBoundHolder() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 的构造方法
AlreadyBoundHolder(AlreadyBound) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 的构造方法
AlreadyConnectedException - java.nio.channels 中的 异常
试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
AlreadyConnectedException() - 异常 java.nio.channels.AlreadyConnectedException 的构造方法
构造此类的一个实例。
alreadyNotified - 类 javax.management.monitor.Monitor 中的变量
已过时。 等效于 Monitor.alreadyNotifieds[0]。
alreadyNotifieds - 类 javax.management.monitor.Monitor 中的变量
已经通知的选定监视器错误。
ALT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ALT_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Alt 键的扩展修饰符常量。
ALT_GRAPH_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
AltGraph 键的扩展修饰符常量。
ALT_GRAPH_MASK - 类 java.awt.event.InputEvent 中的静态变量
AltGraph 键修饰符常量。
ALT_MASK - 类 java.awt.event.ActionEvent 中的静态变量
alt 修饰符。
ALT_MASK - 类 java.awt.Event 中的静态变量
此标志指示当事件发生时按下 Alt 键。
ALT_MASK - 类 java.awt.event.InputEvent 中的静态变量
Alt 键修饰符常量。
ALTERNATE - 类 java.util.FormattableFlags 中的静态变量
要求输出使用替换形式。
alternateAddTag - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
HTML 中的替换 Tag，如果未找到 parentTag 但找到了 alternateParentTag，则从此替换 Tag 开始添加标记。
alternateParentTag - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
如果未找到 parentTag，则要在文档中检查的替换 Tag。
altName - 异常 javax.naming.CannotProceedException 中的变量
包含已解析对象的名称，该名称相对于上下文 altNameCtx。
altNameCtx - 异常 javax.naming.CannotProceedException 中的变量
包含上下文，altName 是相对于该上下文指定的。
ALWAYS_UPDATE - 类 javax.swing.text.DefaultCaret 中的静态变量
指示无论文档更新是否是在事件调度线程中执行，始终根据文档更改更新插入符位置。
AM - 类 java.util.Calendar 中的静态变量
指示从午夜到中午之前这段时间的 Calendar.AM_PM 字段值。
AM_PM - 类 java.text.DateFormat.Field 中的静态变量
标识每日时间指示符（例如 "a.m." 或 "p.m."）的常量。
AM_PM - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示 HOUR 是在中午之前还是在中午之后。
AM_PM_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 AM_PM 字段的有用常量。
ANCESTOR_ADDED - 类 javax.swing.event.AncestorEvent 中的静态变量
某个祖先组件被添加到可见对象的层次结构中（使其可见），并且目前正显示该组件。
ANCESTOR_MOVED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示祖先 Container 被移动的事件 id。
ANCESTOR_MOVED - 类 javax.swing.event.AncestorEvent 中的静态变量
某个祖先组件更改了其屏幕位置。
ANCESTOR_REMOVED - 类 javax.swing.event.AncestorEvent 中的静态变量
某个祖先组件从可见对象的层次结构中被移除（隐藏它），并且不再显示该组件。
ANCESTOR_RESIZED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示祖先 Container 大小被调整的事件 id。
ancestorAdded(AncestorEvent) - 接口 javax.swing.event.AncestorListener 中的方法
当通过调用 setVisible(true) 或将其添加到组件层次结构中而使源组件或其祖先之一变得可见时调用。
AncestorEvent - javax.swing.event 中的 类
报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
AncestorEvent(JComponent, int, Container, Container) - 类 javax.swing.event.AncestorEvent 的构造方法
构造一个 AncestorEvent 对象，以标识祖先组件显示状态的更改。
AncestorListener - javax.swing.event 中的 接口
AncestorListener 接口支持 JComponent 或其祖先之一发生更改时进行通知。
ancestorMoved(HierarchyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 ancestorMoved 方法处理 ancestorMoved 事件。
ancestorMoved(HierarchyEvent) - 类 java.awt.event.HierarchyBoundsAdapter 中的方法
移动源的祖先时调用。
ancestorMoved(HierarchyEvent) - 接口 java.awt.event.HierarchyBoundsListener 中的方法
移动源的祖先时调用。
ancestorMoved(AncestorEvent) - 接口 javax.swing.event.AncestorListener 中的方法
在源组件或其祖先之一被移动时调用。
ancestorRemoved(AncestorEvent) - 接口 javax.swing.event.AncestorListener 中的方法
当通过调用 setVisible(false) 或将其从组件层次结构中移除而使源组件或其祖先之一变得不可见时调用。
ancestorResized(HierarchyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 ancestorResized 方法处理 ancestorResized 事件。
ancestorResized(HierarchyEvent) - 类 java.awt.event.HierarchyBoundsAdapter 中的方法
调整源的祖先的大小时调用。
ancestorResized(HierarchyEvent) - 接口 java.awt.event.HierarchyBoundsListener 中的方法
调整源的祖先的大小时调用。
anchor - 类 java.awt.GridBagConstraints 中的变量
当组件小于其显示区域时使用此字段。
ANCHOR_SELECTION_PATH_PROPERTY - 类 javax.swing.JTree 中的静态变量
定位选择路径的绑定属性名称。
and(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this & val) 的 BigInteger。
and(BitSet) - 类 java.util.BitSet 中的方法
对此目标位 set 和参数位 set 执行逻辑与操作。
and(QueryExp, QueryExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，它是其他两个查询表达式的“与”。
andFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
andNot(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this & ~val) 的 BigInteger。
andNot(BitSet) - 类 java.util.BitSet 中的方法
清除此 BitSet 中所有的位，其相应的位在指定的 BitSet 中已设置。
annotateClass(Class<?>) - 类 java.io.ObjectOutputStream 中的方法
子类可以实现此方法，从而允许在流中存储类数据。
AnnotatedElement - java.lang.reflect 中的 接口
表示目前正在此 VM 中运行的程序的一个已注释元素。
annotateProxyClass(Class<?>) - 类 java.io.ObjectOutputStream 中的方法
子类可以实现此方法，从而在流中存储定制数据和动态代理类的描述符。
Annotation - java.lang.annotation 中的 接口
所有 annotation 类型都要扩展的公共接口。
Annotation - java.text 中的 类
如果文本属性具有 annotation 特征，则 Annotation 对象用作文本属性值的包装器。
Annotation(Object) - 类 java.text.Annotation 的构造方法
构造一条具有给定值（可能为 null）的 annotation 记录。
AnnotationFormatError - java.lang.annotation 中的 错误
当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。
AnnotationFormatError(String) - 错误 java.lang.annotation.AnnotationFormatError 的构造方法
构造具有指定详细消息的新 AnnotationFormatError。
AnnotationFormatError(String, Throwable) - 错误 java.lang.annotation.AnnotationFormatError 的构造方法
构造带指定详细消息和原因的新 AnnotationFormatError。
AnnotationFormatError(Throwable) - 错误 java.lang.annotation.AnnotationFormatError 的构造方法
构造带指定原因和详细消息的新 AnnotationFormatError，该消息为 (cause == null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
AnnotationMirror - javax.lang.model.element 中的 接口
表示一个注释。
annotationType() - 接口 java.lang.annotation.Annotation 中的方法
返回此 annotation 的注释类型。
annotationType() - 异常 java.lang.annotation.IncompleteAnnotationException 中的方法
返回带有缺少元素的注释类型的 Class 对象。
AnnotationTypeMismatchException - java.lang.annotation 中的 异常
若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
AnnotationTypeMismatchException(Method, String) - 异常 java.lang.annotation.AnnotationTypeMismatchException 的构造方法
构造针对指定的注释类型元素和找到的数据类型的 AnnotationTypeMismatchException。
AnnotationValue - javax.lang.model.element 中的 接口
表示注释类型元素的值。
AnnotationValueVisitor<R,P> - javax.lang.model.element 中的 接口
注释类型元素值的 visitor，使用 visitor 设计模式的变体。
ANY - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Any - org.omg.CORBA 中的 类
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
Any() - 类 org.omg.CORBA.Any 的构造方法
AnyHolder - org.omg.CORBA 中的 类
Any 的 Holder。
AnyHolder() - 类 org.omg.CORBA.AnyHolder 的构造方法
构造一个新的 AnyHolder 对象，将其 value 字段初始化为 null。
AnyHolder(Any) - 类 org.omg.CORBA.AnyHolder 的构造方法
为给定的 Any 对象构造一个新 AnyHolder 对象。
AnySeqHelper - org.omg.CORBA 中的 类
AnySeq 的 Helper。
AnySeqHelper() - 类 org.omg.CORBA.AnySeqHelper 的构造方法
AnySeqHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/AnySeqHelper.java。
AnySeqHelper() - 类 org.omg.DynamicAny.AnySeqHelper 的构造方法
AnySeqHolder - org.omg.CORBA 中的 类
AnySeq 的 Holder。
AnySeqHolder() - 类 org.omg.CORBA.AnySeqHolder 的构造方法
AnySeqHolder(Any[]) - 类 org.omg.CORBA.AnySeqHolder 的构造方法
anySubString(AttributeValueExp, StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于字符串参数的约束条件。
AppConfigurationEntry - javax.security.auth.login 中的 类
此类表示为在 Configuration 类中的 getAppConfigurationEntry(String appName) 方法中指定的应用程序配置的单个 LoginModule 条目。
AppConfigurationEntry(String, AppConfigurationEntry.LoginModuleControlFlag, Map<String, ?>) - 类 javax.security.auth.login.AppConfigurationEntry 的构造方法
此类的默认构造方法。
AppConfigurationEntry.LoginModuleControlFlag - javax.security.auth.login 中的 类
此类表示 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。
append(Shape, boolean) - 类 java.awt.geom.Path2D 中的方法
将指定 Shape 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
append(PathIterator, boolean) - 类 java.awt.geom.Path2D 中的方法
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
append(PathIterator, boolean) - 类 java.awt.geom.Path2D.Double 中的方法
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
append(PathIterator, boolean) - 类 java.awt.geom.Path2D.Float 中的方法
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
append(Printable, PageFormat) - 类 java.awt.print.Book 中的方法
将单个页面追加到此 Book 的尾部。
append(Printable, PageFormat, int) - 类 java.awt.print.Book 中的方法
将 numPages 个页面追加到此 Book 的尾部。
append(String) - 类 java.awt.TextArea 中的方法
将给定文本追加到文本区的当前文本。
append(CharSequence) - 类 java.io.CharArrayWriter 中的方法
将指定的字符序列添加到此 writer。
append(CharSequence, int, int) - 类 java.io.CharArrayWriter 中的方法
将指定字符序列的子序列添加到此 writer。
append(char) - 类 java.io.CharArrayWriter 中的方法
将指定字符添加到此 writer。
append(CharSequence) - 类 java.io.PrintStream 中的方法
将指定字符序列添加到此输出流。
append(CharSequence, int, int) - 类 java.io.PrintStream 中的方法
将指定字符序列的子序列添加到此输出流。
append(char) - 类 java.io.PrintStream 中的方法
将指定字符添加到此输出流。
append(CharSequence) - 类 java.io.PrintWriter 中的方法
将指定的字符序列添加到此 writer。
append(CharSequence, int, int) - 类 java.io.PrintWriter 中的方法
将指定字符序列的子序列添加到此 writer。
append(char) - 类 java.io.PrintWriter 中的方法
将指定字符添加到此 writer。
append(CharSequence) - 类 java.io.StringWriter 中的方法
将指定的字符序列添加到此 writer。
append(CharSequence, int, int) - 类 java.io.StringWriter 中的方法
将指定字符序列的子序列添加到此 writer。
append(char) - 类 java.io.StringWriter 中的方法
将指定字符添加到此 writer。
append(CharSequence) - 类 java.io.Writer 中的方法
将指定字符序列添加到此 writer。
append(CharSequence, int, int) - 类 java.io.Writer 中的方法
将指定字符序列的子序列添加到此 writer.Appendable。
append(char) - 类 java.io.Writer 中的方法
将指定字符添加到此 writer。
append(CharSequence) - 接口 java.lang.Appendable 中的方法
向此 Appendable 添加指定的字符序列。
append(CharSequence, int, int) - 接口 java.lang.Appendable 中的方法
向此 Appendable 添加指定字符序列的子序列。
append(char) - 接口 java.lang.Appendable 中的方法
向此 Appendable 添加指定字符。
append(Object) - 类 java.lang.StringBuffer 中的方法
append(String) - 类 java.lang.StringBuffer 中的方法
append(StringBuffer) - 类 java.lang.StringBuffer 中的方法
将指定的 StringBuffer 添加到此序列中。
append(CharSequence) - 类 java.lang.StringBuffer 中的方法
将指定的 CharSequence 添加到该序列。
append(CharSequence, int, int) - 类 java.lang.StringBuffer 中的方法
append(char[]) - 类 java.lang.StringBuffer 中的方法
append(char[], int, int) - 类 java.lang.StringBuffer 中的方法
append(boolean) - 类 java.lang.StringBuffer 中的方法
append(char) - 类 java.lang.StringBuffer 中的方法
append(int) - 类 java.lang.StringBuffer 中的方法
append(long) - 类 java.lang.StringBuffer 中的方法
append(float) - 类 java.lang.StringBuffer 中的方法
append(double) - 类 java.lang.StringBuffer 中的方法
append(Object) - 类 java.lang.StringBuilder 中的方法
append(String) - 类 java.lang.StringBuilder 中的方法
append(StringBuffer) - 类 java.lang.StringBuilder 中的方法
将指定的 StringBuffer 添加到此序列。
append(CharSequence) - 类 java.lang.StringBuilder 中的方法
append(CharSequence, int, int) - 类 java.lang.StringBuilder 中的方法
append(char[]) - 类 java.lang.StringBuilder 中的方法
append(char[], int, int) - 类 java.lang.StringBuilder 中的方法
append(boolean) - 类 java.lang.StringBuilder 中的方法
append(char) - 类 java.lang.StringBuilder 中的方法
append(int) - 类 java.lang.StringBuilder 中的方法
append(long) - 类 java.lang.StringBuilder 中的方法
append(float) - 类 java.lang.StringBuilder 中的方法
append(double) - 类 java.lang.StringBuilder 中的方法
append(CharSequence) - 类 java.nio.CharBuffer 中的方法
将指定的字符序列添加到此缓冲区（可选操作）。
append(CharSequence, int, int) - 类 java.nio.CharBuffer 中的方法
将指定字符序列的子序列添加到此缓冲区（可选操作）。
append(char) - 类 java.nio.CharBuffer 中的方法
将指定字符添加到此缓冲区（可选操作）。
append(String) - 类 javax.swing.JTextArea 中的方法
将给定文本追加到文档结尾。
append(View) - 类 javax.swing.text.View 中的方法
追加单个子视图。
Appendable - java.lang 中的 接口
能够被添加 char 序列和值的对象。
appendChild(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
将节点 newChild 添加到此节点子节点列表的末尾。
appendChild(Node) - 接口 org.w3c.dom.Node 中的方法
将节点 newChild 添加到此节点的子节点列表的末尾。
appendCodePoint(int) - 类 java.lang.StringBuffer 中的方法
appendCodePoint(int) - 类 java.lang.StringBuilder 中的方法
appendData(String) - 接口 org.w3c.dom.CharacterData 中的方法
将字符串追加到节点的字符数据的结尾。
appendEvent(InputEvent) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
Recognizer 在 Component 上注册的侦听器将通过此 API 记录所有识别的 Event，识别的 Event 是组成 Drag 和 Drop 开始动作的系列 Event 的一部分。
appendFaultSubcode(QName) - 接口 javax.xml.soap.SOAPFault 中的方法
将 Subcode 添加到此 SOAPFault 包含的 Subcode 序列的末尾。
appendRemainingComponent(String) - 异常 javax.naming.NamingException 中的方法
将 name 作为剩余名称中最后的组件添加。
appendRemainingComponent(String) - 类 javax.naming.spi.ResolveResult 中的方法
将单个组件添加到剩余名称末尾。
appendRemainingName(Name) - 异常 javax.naming.NamingException 中的方法
将 'name' 中的组件作为剩余名称中最后的组件添加。
appendRemainingName(Name) - 类 javax.naming.spi.ResolveResult 中的方法
将组件添加到剩余名称的末尾。
appendReplacement(StringBuffer, String) - 类 java.util.regex.Matcher 中的方法
实现非终端添加和替换步骤。
appendTail(StringBuffer) - 类 java.util.regex.Matcher 中的方法
实现终端添加和替换步骤。
appendText(String) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 append(String) 取代。
appendToBootstrapClassLoaderSearch(JarFile) - 接口 java.lang.instrument.Instrumentation 中的方法
指定 JAR 文件，检测类由引导类加载器定义。
appendToSystemClassLoaderSearch(JarFile) - 接口 java.lang.instrument.Instrumentation 中的方法
指定 JAR 文件，检测类由系统类加载器定义。
Applet - java.applet 中的 类
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。
Applet() - 类 java.applet.Applet 的构造方法
构造一个新 Applet。
APPLET - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定搜索其他属性时将使用的初始上下文构造方法的 applet 的环境属性名称。
APPLET - 类 javax.swing.text.html.HTML.Tag 中的静态变量
applet - 类 javax.swing.text.html.parser.DTD 中的变量
Applet.AccessibleApplet - java.applet 中的 类
此类实现对 Applet 类的可访问性支持。
Applet.AccessibleApplet() - 类 java.applet.Applet.AccessibleApplet 的构造方法
AppletContext - java.applet 中的 接口
此接口对应于 applet 的环境：包含 applet 的文档以及同一文档中的其他 applet。
AppletInitializer - java.beans 中的 接口
此接口设计用于与 java.beans.Beans.instantiate 联合使用。
appletResize(int, int) - 接口 java.applet.AppletStub 中的方法
当 applet 想要重新调整大小时调用。
AppletStub - java.applet 中的 接口
当 applet 第一次被创建时，使用 applet 的 setStub 方法把 applet stub 连接到它。
ApplicationException - org.omg.CORBA.portable 中的 异常
此类用来报告 ORB 和 stub 之间的应用程序级异常。
ApplicationException(String, InputStream) - 异常 org.omg.CORBA.portable.ApplicationException 的构造方法
根据异常的 CORBA 存储库 ID 和一个输入流（可从中读取异常数据作为其参数）构造 ApplicationException。
apply(ObjectName) - 类 javax.management.AttributeValueExp 中的方法
在 MBean 上应用 AttributeValueExp。
apply(ObjectName) - 类 javax.management.ObjectName 中的方法
测试此 ObjectName（可以是一个模式）是否与另一个 ObjectName 匹配。
apply(ObjectName) - 接口 javax.management.QueryExp 中的方法
在 MBean 上应用 QueryExp。
apply(ObjectName) - 类 javax.management.StringValueExp 中的方法
在 MBean 上应用 ValueExp。
apply(ObjectName) - 接口 javax.management.ValueExp 中的方法
在 MBean 上应用 ValueExp。
APPLY_REVERB - 类 javax.sound.sampled.BooleanControl.Type 中的静态变量
表示是否将回响应用于行的控件。
applyComponentOrientation(ComponentOrientation) - 类 java.awt.Component 中的方法
设置此组件及其包含的所有组件的 ComponentOrientation 属性。
applyComponentOrientation(ComponentOrientation) - 类 java.awt.Container 中的方法
设置此容器和其中包含的所有组件的 ComponentOrientation 属性。
applyComponentOrientation(ComponentOrientation) - 类 javax.swing.JMenu 中的方法
设置此菜单及其中包含的所有组件的 ComponentOrientation 属性。
applyLocalizedPattern(String) - 类 java.text.DecimalFormat 中的方法
将给定的模式应用于此 Format 对象。
applyLocalizedPattern(String) - 类 java.text.SimpleDateFormat 中的方法
将给定的本地化模式字符串应用于此日期格式。
applyPattern(String) - 类 java.text.ChoiceFormat 中的方法
设置模式。
applyPattern(String) - 类 java.text.DecimalFormat 中的方法
将给定的模式应用于此 Format 对象。
applyPattern(String) - 类 java.text.MessageFormat 中的方法
设置此消息格式所使用的模式。
applyPattern(String) - 类 java.text.SimpleDateFormat 中的方法
将给定模式字符串应用于此日期格式。
applyResourceBundle(ResourceBundle) - 类 java.awt.Window 中的方法
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
applyResourceBundle(String) - 类 java.awt.Window 中的方法
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
appRandom - 类 java.security.SignatureSpi 中的变量
应用程序指定的随机源。
APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用于确认（yes、ok）按钮的助记符的更改。
APPROVE_BUTTON_TEXT_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识确认（yes、ok）按钮上的文本更改。
APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用于确认（yes、ok）按钮的工具提示文本的更改。
APPROVE_OPTION - 类 javax.swing.JFileChooser 中的静态变量
选择确认（yes、ok）后返回该值。
APPROVE_SELECTION - 类 javax.swing.JFileChooser 中的静态变量
指示确认当前的选择（与按下 yes 或 ok 相同）。
approveSelection() - 类 javax.swing.JFileChooser 中的方法
用户单击 Approve 按钮（默认情况下标有 "Open" 或 "Save"）时由 UI 调用此方法。
APRIL - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第四个月的 Calendar.MONTH 字段值。
APRIL - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第四个月的值。
ARABIC - 类 java.awt.font.NumericShaper 中的静态变量
标识 ARABIC 范围和十进制基数。
ARABIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Arabic”Unicode 字符块的常量。
ARABIC_PRESENTATION_FORMS_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Arabic Presentation Forms-A”Unicode 字符块的常量。
ARABIC_PRESENTATION_FORMS_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Arabic Presentation Forms-B”Unicode 字符块的常量。
Arc2D - java.awt.geom 中的 类
Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
Arc2D(int) - 类 java.awt.geom.Arc2D 的构造方法
这是一个不能直接实例化的抽象类。
Arc2D.Double - java.awt.geom 中的 类
此类定义以 double 精度指定的弧。
Arc2D.Double() - 类 java.awt.geom.Arc2D.Double 的构造方法
构造一个新 OPEN 弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)。
Arc2D.Double(int) - 类 java.awt.geom.Arc2D.Double 的构造方法
构造一个新弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)、指定的闭合类型。
Arc2D.Double(double, double, double, double, double, double, int) - 类 java.awt.geom.Arc2D.Double 的构造方法
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Double(Rectangle2D, double, double, int) - 类 java.awt.geom.Arc2D.Double 的构造方法
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Float - java.awt.geom 中的 类
此类定义以 float 精度指定的弧。
Arc2D.Float() - 类 java.awt.geom.Arc2D.Float 的构造方法
构造一个新 OPEN 弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)。
Arc2D.Float(int) - 类 java.awt.geom.Arc2D.Float 的构造方法
构造一个新弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)，角跨越 (start = 0, extent = 0)、指定的闭合类型。
Arc2D.Float(float, float, float, float, float, float, int) - 类 java.awt.geom.Arc2D.Float 的构造方法
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Float(Rectangle2D, float, float, int) - 类 java.awt.geom.Arc2D.Float 的构造方法
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
archeight - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
圆角弧的高度。
archeight - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
圆角弧的高度。
ARCHIVE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
arcwidth - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
圆角弧的宽度。
arcwidth - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
圆角弧的宽度。
Area - java.awt.geom 中的 类
Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。
Area() - 类 java.awt.geom.Area 的构造方法
创建空区域的默认构造方法。
Area(Shape) - 类 java.awt.geom.Area 的构造方法
Area 类可以根据指定的 Shape 对象创建区域几何形状。
AREA - 类 javax.swing.text.html.HTML.Tag 中的静态变量
AreaAveragingScaleFilter - java.awt.image 中的 类
这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
AreaAveragingScaleFilter(int, int) - 类 java.awt.image.AreaAveragingScaleFilter 的构造方法
构造一个 AreaAveragingScaleFilter，它对由 width 和 height 参数所指定的源图像的像素进行缩放。
areFieldsSet - 类 java.util.Calendar 中的变量
如果 fields[] 与当前的设置时间同步，则返回 true。
areFocusTraversalKeysSet(int) - 类 java.awt.Component 中的方法
返回是否为此 Component 显式定义了给定焦点遍历操作的焦点遍历键 Set。
areFocusTraversalKeysSet(int) - 类 java.awt.Container 中的方法
返回是否已经为此 Container 明确定义了用于给定焦点遍历操作的焦点遍历键的 Set。
areNew - 类 javax.swing.event.TreeSelectionEvent 中的变量
对于每条路径，标识该路径实际上是否为一条新路径。
arePathsContiguous(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果路径是连续的，或者此对象没有 RowMapper，则返回 true。
areTablesSet() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
如果表是当前设置的，则返回 true。
areTablesSet() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
如果表是当前设置的，则返回 true。
arg - 类 java.awt.Event 中的变量
事件的任意参数。
ARG_IN - org.omg.CORBA 中的 接口
向调用符号化 "input" 参数，表示从客户端将该参数传递到服务器。
ARG_INOUT - org.omg.CORBA 中的 接口
表示用于某一调用的输入和输出的参数，意味着将该参数从客户端传到服务器，然后再从服务器传回客户端。
ARG_OUT - org.omg.CORBA 中的 接口
表示调用的 "input" 参数的常量，意味着从服务器将该参数传递到客户端。
ARGUMENT - 类 java.text.MessageFormat.Field 中的静态变量
标识消息某一部分的常量，其中此消息是从传入 formatToCharacterIterator 的参数生成的。
argument - 类 org.omg.Dynamic.Parameter 中的变量
arguments() - 类 org.omg.CORBA.Request 中的方法
检索包含将被调用方法的参数的 NVList 对象。
arguments(NVList) - 类 org.omg.CORBA.ServerRequest 中的方法
指定方法参数类型并检索 "in" 和 "inout" 参数值。
arguments() - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
返回传递给 ORB.init 的参数。
arguments() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 Parameter 对象数组，包含将调用的操作上的参数。
ARGV - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它将一个位置参数数组传递给某一脚本。
ArithmeticException - java.lang 中的 异常
当出现异常的运算条件时，抛出此异常。
ArithmeticException() - 异常 java.lang.ArithmeticException 的构造方法
构造不带详细消息的 ArithmeticException。
ArithmeticException(String) - 异常 java.lang.ArithmeticException 的构造方法
构造具有指定详细消息的 ArithmeticException。
ARMED - 类 javax.accessibility.AccessibleState 中的静态变量
指示选中了此对象。
ARMED - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“选中的”位，该位指示选择/触发按钮操作的部分委托事项。
ARMENIAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Armenian”Unicode 字符块的常量。
arrangeGrid(Container) - 类 java.awt.GridBagLayout 中的方法
布置网格。
ArrangeGrid(Container) - 类 java.awt.GridBagLayout 中的方法
此方法已过时，仅为提供向后兼容性；新代码应该调用 arrangeGrid 来代替。
Array - java.lang.reflect 中的 类
Array 类提供了动态创建和访问 Java 数组的方法。
array() - 类 java.nio.Buffer 中的方法
返回此缓冲区的底层实现数组（可选操作）。
array() - 类 java.nio.ByteBuffer 中的方法
返回实现此缓冲区的 byte 数组（可选操作）。
array() - 类 java.nio.CharBuffer 中的方法
返回实现此缓冲区的字符数组（可选操作）。
array() - 类 java.nio.DoubleBuffer 中的方法
返回实现此缓冲区的 double 数组（可选操作）。
array() - 类 java.nio.FloatBuffer 中的方法
返回实现此缓冲区的 float 数组（可选操作）。
array() - 类 java.nio.IntBuffer 中的方法
返回实现此缓冲区的 int 数组（可选操作）。
array() - 类 java.nio.LongBuffer 中的方法
返回实现此缓冲区的 long 数组（可选操作）。
array() - 类 java.nio.ShortBuffer 中的方法
返回实现此缓冲区的 short 数组（可选操作）。
Array - java.sql 中的 接口
SQL 类型 ARRAY 在 Java 编程语言中的映射关系。
ARRAY - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 ARRAY 的 Java 编程语言中的常量（有时称为类型代码）。
array - 类 javax.swing.text.Segment 中的变量
这是包含了所需文本的数组。
ArrayBlockingQueue<E> - java.util.concurrent 中的 类
一个由数组支持的有界阻塞队列。
ArrayBlockingQueue(int) - 类 java.util.concurrent.ArrayBlockingQueue 的构造方法
创建一个带有给定的（固定）容量和默认访问策略的 ArrayBlockingQueue。
ArrayBlockingQueue(int, boolean) - 类 java.util.concurrent.ArrayBlockingQueue 的构造方法
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue。
ArrayBlockingQueue(int, boolean, Collection<? extends E>) - 类 java.util.concurrent.ArrayBlockingQueue 的构造方法
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue，它最初包含给定 collection 的元素，并以 collection 迭代器的遍历顺序添加元素。
arraycopy(Object, int, Object, int, int) - 类 java.lang.System 中的静态方法
从指定源数组中复制一个数组，复制从指定的位置开始，到目标数组的指定位置结束。
ArrayDeque<E> - java.util 中的 类
Deque 接口的大小可变数组的实现。
ArrayDeque() - 类 java.util.ArrayDeque 的构造方法
构造一个初始容量能够容纳 16 个元素的空数组双端队列。
ArrayDeque(int) - 类 java.util.ArrayDeque 的构造方法
构造一个初始容量能够容纳指定数量的元素的空数组双端队列。
ArrayDeque(Collection<? extends E>) - 类 java.util.ArrayDeque 的构造方法
构造一个包含指定 collection 的元素的双端队列，这些元素按 collection 的迭代器返回的顺序排列。
ArrayIndexOutOfBoundsException - java.lang 中的 异常
用非法索引访问数组时抛出的异常。
ArrayIndexOutOfBoundsException() - 异常 java.lang.ArrayIndexOutOfBoundsException 的构造方法
构造不带详细消息的 ArrayIndexOutOfBoundsException。
ArrayIndexOutOfBoundsException(int) - 异常 java.lang.ArrayIndexOutOfBoundsException 的构造方法
构造具有指示非法索引的参数的新 ArrayIndexOutOfBoundsException 类。
ArrayIndexOutOfBoundsException(String) - 异常 java.lang.ArrayIndexOutOfBoundsException 的构造方法
构造具有指定详细消息的 ArrayIndexOutOfBoundsException 类。
ArrayList<E> - java.util 中的 类
List 接口的大小可变数组的实现。
ArrayList(int) - 类 java.util.ArrayList 的构造方法
构造一个具有指定初始容量的空列表。
ArrayList() - 类 java.util.ArrayList 的构造方法
构造一个初始容量为 10 的空列表。
ArrayList(Collection<? extends E>) - 类 java.util.ArrayList 的构造方法
构造一个包含指定 collection 的元素的列表，这些元素是按照该 collection 的迭代器返回它们的顺序排列的。
arrayOffset() - 类 java.nio.Buffer 中的方法
返回此缓冲区的底层实现数组中第一个缓冲区元素的偏移量（可选操作）。
arrayOffset() - 类 java.nio.ByteBuffer 中的方法
返回此缓冲区中的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.CharBuffer 中的方法
返回此缓冲区中的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.DoubleBuffer 中的方法
返回此缓冲区中的第一个 double 元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.FloatBuffer 中的方法
返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.IntBuffer 中的方法
返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.LongBuffer 中的方法
返回此缓冲区中第一个元素在缓冲区的支持数组中的偏移量（可选操作）。
arrayOffset() - 类 java.nio.ShortBuffer 中的方法
返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
Arrays - java.util 中的 类
此类包含用来操作数组（比如排序和搜索）的各种方法。
ArrayStoreException - java.lang 中的 异常
试图将错误类型的对象存储到一个对象数组时抛出的异常。
ArrayStoreException() - 异常 java.lang.ArrayStoreException 的构造方法
构造不带详细消息的 ArrayStoreException。
ArrayStoreException(String) - 异常 java.lang.ArrayStoreException 的构造方法
构造具有指定详细消息的 ArrayStoreException。
ArrayType - javax.lang.model.type 中的 接口
表示一个数组类型。
ArrayType<T> - javax.management.openmbean 中的 类
ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。
ArrayType(int, OpenType<?>) - 类 javax.management.openmbean.ArrayType 的构造方法
构造一个描述开放数据 值的 ArrayType 实例，该值是其元素的开放类型 为 elementType、元素的维度为 dimension 的数组。
ArrayType(SimpleType<?>, boolean) - 类 javax.management.openmbean.ArrayType 的构造方法
为提供的 SimpleType 构造一个一维 ArrayType 实例。
ARROW_BUTTON - 类 javax.swing.plaf.synth.Region 中的静态变量
ArrowButton 是特殊类型的按钮，也呈现了一个方向指示器（通常是一个箭头）。
arrowButton - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
arrowIcon - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
ARROWS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Arrows”Unicode 字符块的常量。
asCharacters() - 接口 javax.xml.stream.events.XMLEvent 中的方法
将此事件作为 Characters 返回，如果此事件不是字符，则可能导致类强制转化异常。
asCharBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 char 缓冲区。
ASCII_STREAM_PARAM - 类 javax.sql.rowset.BaseRowSet 中的静态变量
该常量向 RowSetReaderImpl 对象指示给定的参数是一个 ASCII 流。
asciiStream - 类 javax.sql.rowset.BaseRowSet 中的变量
将由方法 getAsciiStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
asDoubleBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 double 缓冲区。
asElement() - 接口 javax.lang.model.type.DeclaredType 中的方法
返回对应于此类型的元素。
asElement() - 接口 javax.lang.model.type.TypeVariable 中的方法
返回对应于此类型变量的元素。
asElement(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回对应于类型的元素。
asEndElement() - 接口 javax.xml.stream.events.XMLEvent 中的方法
将此事件作为结束元素事件返回，如果此事件不是结束元素，则可能导致类强制转换异常。
asFloatBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 float 缓冲区。
asin(double) - 类 java.lang.Math 中的静态方法
返回一个值的反正弦；返回的角度范围在 -pi/2 到 pi/2 之间。
asin(double) - 类 java.lang.StrictMath 中的静态方法
返回值的反正弦；返回角的范围在 -pi/2 到 pi/2 之间。
asIntBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 int 缓冲区。
asksAllowsChildren - 类 javax.swing.tree.DefaultTreeModel 中的变量
确定 isLeaf 方法如何判断一个节点是否为叶节点。
asksAllowsChildren() - 类 javax.swing.tree.DefaultTreeModel 中的方法
告知如何确定叶节点。
asLifoQueue(Deque<T>) - 类 java.util.Collections 中的静态方法
以后进先出 (Lifo) Queue 的形式返回某个 Deque 的视图。
asList(T...) - 类 java.util.Arrays 中的静态方法
返回一个受指定数组支持的固定大小的列表。
asList() - 类 javax.management.AttributeList 中的方法
以 List<Attribute> 的形式返回此列表的视图。
asList() - 类 javax.management.relation.RoleList 中的方法
以 List<Role> 的形式返回此列表的示图。
asList() - 类 javax.management.relation.RoleUnresolvedList 中的方法
以 List<RoleUnresolved> 的形式返回此列表的视图。
asLongBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 long 缓冲区。
asMemberOf(DeclaredType, Element) - 接口 javax.lang.model.util.Types 中的方法
当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
asReadOnlyBuffer() - 类 java.nio.ByteBuffer 中的方法
创建共享此缓冲区内容的新的只读字节缓冲区。
asReadOnlyBuffer() - 类 java.nio.CharBuffer 中的方法
创建共享此缓冲区内容的新的只读字符缓冲区。
asReadOnlyBuffer() - 类 java.nio.DoubleBuffer 中的方法
创建共享此缓冲区内容的新的只读 double 缓冲区。
asReadOnlyBuffer() - 类 java.nio.FloatBuffer 中的方法
创建共享此缓冲区内容的新的只读 float 缓冲区。
asReadOnlyBuffer() - 类 java.nio.IntBuffer 中的方法
创建共享此缓冲区内容的新的只读 int 缓冲区。
asReadOnlyBuffer() - 类 java.nio.LongBuffer 中的方法
创建共享此缓冲区内容的新的只读 long 缓冲区。
asReadOnlyBuffer() - 类 java.nio.ShortBuffer 中的方法
创建共享此缓冲区内容的新的只读 short 缓冲区。
assembleSystemMenu() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
assembleSystemMenu() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
重写父级的方法，使其不执行任何操作。
AssertionError - java.lang 中的 错误
抛出该异常指示某个断言失败。
AssertionError() - 错误 java.lang.AssertionError 的构造方法
构造一个不带详细消息的 AssertionError。
AssertionError(Object) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的对象，该对象将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(boolean) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 boolean，该 boolean 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(char) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 char，该 char 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(int) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 int，该 int 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(long) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 long，该 long 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(float) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 float，该 float 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(double) - 错误 java.lang.AssertionError 的构造方法
构造一个 AssertionError，其详细消息派生于指定的 double，该 double 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
asShortBuffer() - 类 java.nio.ByteBuffer 中的方法
创建此字节缓冲区的视图，作为 short 缓冲区。
assign(DynAny) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 将内容从一个 Dynamic Any 复制到另一个 Dynamic Any 中。
assign(DynAny) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynStructStub 中的方法
使用与另一个 DynAny 对象关联的值初始化与 DynAny 对象关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
assign(DynAny) - 类 org.omg.DynamicAny._DynValueStub 中的方法
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
assign(DynAny) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
使用与另一个 DynAny 对象有关联的值初始化与 DynAny 对象有关联的值。
asStartElement() - 接口 javax.xml.stream.events.XMLEvent 中的方法
将此事件作为开始元素事件返回，如果此事件不是开始元素，则可能导致类强制转换异常。
asSubclass(Class<U>) - 类 java.lang.Class 中的方法
强制转换该 Class 对象，以表示指定的 class 对象所表示的类的一个子类。
assureRectsCreated(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
asType() - 接口 javax.lang.model.element.Element 中的方法
返回此元素定义的类型。
AsyncBoxView - javax.swing.text 中的 类
异步执行布局处理的框。
AsyncBoxView(Element, int) - 类 javax.swing.text.AsyncBoxView 的构造方法
构造执行异步布局处理的 BoxView。
AsyncBoxView.ChildLocator - javax.swing.text 中的 类
该类在本地化区域发生更改时，管理该本地化区域中子视图的有效位置。
AsyncBoxView.ChildLocator() - 类 javax.swing.text.AsyncBoxView.ChildLocator 的构造方法
构造 ChildLocator。
AsyncBoxView.ChildState - javax.swing.text 中的 类
表示子视图布局状态的记录。
AsyncBoxView.ChildState(View) - 类 javax.swing.text.AsyncBoxView.ChildState 的构造方法
构造子视图状态。
AsyncHandler<T> - javax.xml.ws 中的 接口
AsyncHandler 接口由希望接收关于完成了异步调用服务端点操作的回调通知的客户端实现。
AsynchronousCloseException - java.nio.channels 中的 异常
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
AsynchronousCloseException() - 异常 java.nio.channels.AsynchronousCloseException 的构造方法
构造此类的一个实例。
AT_TARGET - 接口 org.w3c.dom.events.Event 中的静态变量
目前事件正在目标 EventTarget 接受评诂。
atan(double) - 类 java.lang.Math 中的静态方法
返回一个值的反正切；返回的角度范围在 -pi/2 到 pi/2 之间。
atan(double) - 类 java.lang.StrictMath 中的静态方法
返回值的反正切；返回角的范围在 -pi/2 到 pi/2 之间。
atan2(double, double) - 类 java.lang.Math 中的静态方法
将矩形坐标 (x, y) 转换成极坐标 (r, theta)，返回所得角 theta。
atan2(double, double) - 类 java.lang.StrictMath 中的静态方法
将矩形坐标 (x, y) 转换成极坐标 (r, theta)，并返回角 theta。
AtomicBoolean - java.util.concurrent.atomic 中的 类
可以用原子方式更新的 boolean 值。
AtomicBoolean(boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 的构造方法
使用给定的初始值创建新的 AtomicBoolean。
AtomicBoolean() - 类 java.util.concurrent.atomic.AtomicBoolean 的构造方法
使用初始值 false 创建新的 AtomicBoolean。
AtomicInteger - java.util.concurrent.atomic 中的 类
可以用原子方式更新的 int 值。
AtomicInteger(int) - 类 java.util.concurrent.atomic.AtomicInteger 的构造方法
创建具有给定初始值的新 AtomicInteger。
AtomicInteger() - 类 java.util.concurrent.atomic.AtomicInteger 的构造方法
创建具有初始值 0 的新 AtomicInteger。
AtomicIntegerArray - java.util.concurrent.atomic 中的 类
可以用原子方式更新其元素的 int 数组。
AtomicIntegerArray(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 的构造方法
创建给定长度的新 AtomicIntegerArray。
AtomicIntegerArray(int[]) - 类 java.util.concurrent.atomic.AtomicIntegerArray 的构造方法
创建与给定数组具有相同长度的新 AtomicIntegerArray，并从给定数组复制其所有元素。
AtomicIntegerFieldUpdater<T> - java.util.concurrent.atomic 中的 类
基于反射的实用工具，可以对指定类的指定 volatile int 字段进行原子更新。
AtomicIntegerFieldUpdater() - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 的构造方法
受保护的无操作构造方法，供子类使用。
AtomicLong - java.util.concurrent.atomic 中的 类
可以用原子方式更新的 long 值。
AtomicLong(long) - 类 java.util.concurrent.atomic.AtomicLong 的构造方法
创建具有给定初始值的新 AtomicLong。
AtomicLong() - 类 java.util.concurrent.atomic.AtomicLong 的构造方法
创建具有初始值 0 的新 AtomicLong。
AtomicLongArray - java.util.concurrent.atomic 中的 类
可以用原子方式更新其元素的 long 数组。
AtomicLongArray(int) - 类 java.util.concurrent.atomic.AtomicLongArray 的构造方法
创建给定长度的新 AtomicLongArray。
AtomicLongArray(long[]) - 类 java.util.concurrent.atomic.AtomicLongArray 的构造方法
创建与给定数组具有相同长度的新 AtomicLongArray，并从给定数组复制其所有元素。
AtomicLongFieldUpdater<T> - java.util.concurrent.atomic 中的 类
基于反射的实用工具，可以对指定类的指定 volatile long 字段进行原子更新。
AtomicLongFieldUpdater() - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 的构造方法
受保护的无操作构造方法，供子类使用。
AtomicMarkableReference<V> - java.util.concurrent.atomic 中的 类
AtomicMarkableReference 维护带有标记位的对象引用，可以原子方式对其进行更新。
AtomicMarkableReference(V, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 的构造方法
创建具有给定初始值的新 AtomicMarkableReference。
AtomicReference<V> - java.util.concurrent.atomic 中的 类
可以用原子方式更新的对象引用。
AtomicReference(V) - 类 java.util.concurrent.atomic.AtomicReference 的构造方法
使用给定的初始值创建新的 AtomicReference。
AtomicReference() - 类 java.util.concurrent.atomic.AtomicReference 的构造方法
使用 null 初始值创建新的 AtomicReference。
AtomicReferenceArray<E> - java.util.concurrent.atomic 中的 类
可以用原子方式更新其元素的对象引用数组。
AtomicReferenceArray(int) - 类 java.util.concurrent.atomic.AtomicReferenceArray 的构造方法
创建给定长度的新 AtomicReferenceArray。
AtomicReferenceArray(E[]) - 类 java.util.concurrent.atomic.AtomicReferenceArray 的构造方法
创建与给定数组具有相同长度的新 AtomicReferenceArray，并从给定数组复制其所有元素。
AtomicReferenceFieldUpdater<T,V> - java.util.concurrent.atomic 中的 类
基于反射的实用工具，可以对指定类的指定 volatile 字段进行原子更新。
AtomicReferenceFieldUpdater() - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 的构造方法
受保护的无操作构造方法，供子类使用。
AtomicStampedReference<V> - java.util.concurrent.atomic 中的 类
AtomicStampedReference 维护带有整数“标志”的对象引用，可以用原子方式对其进行更新。
AtomicStampedReference(V, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 的构造方法
创建具有给定初始值的新 AtomicStampedReference。
attach(Object) - 类 java.nio.channels.SelectionKey 中的方法
将给定的对象附加到此键。
attachment() - 类 java.nio.channels.SelectionKey 中的方法
获取当前的附加对象。
AttachmentMarshaller - javax.xml.bind.attachment 中的 类
启用 JAXB 编组来优化二进制数据存储。
AttachmentMarshaller() - 类 javax.xml.bind.attachment.AttachmentMarshaller 的构造方法
AttachmentPart - javax.xml.soap 中的 类
SOAPMessage 对象的一个附件。
AttachmentPart() - 类 javax.xml.soap.AttachmentPart 的构造方法
AttachmentUnmarshaller - javax.xml.bind.attachment 中的 类
启用包含优化的二进制数据格式的根文档的 JAXB 解组。
AttachmentUnmarshaller() - 类 javax.xml.bind.attachment.AttachmentUnmarshaller 的构造方法
ATTEMPTED - 类 javax.print.attribute.standard.PDLOverrideSupported 中的静态变量
打印机会尝试让外部作业属性值优先于嵌入到文档打印数据中的指令，但是不保证确实会如此。
attemptMark(V, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
如果当前引用 == 预期引用，则以原子方式将该标记的值设置为给定的更新值。
attemptStamp(V, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
如果当前引用 == 预期引用，则以原子方式将该标志的值设置为给定的更新值。
attr(String) - 类 javax.management.Query 中的静态方法
返回新的属性表达式。
attr(String, String) - 类 javax.management.Query 中的静态方法
返回新的限定属性表达式。
Attr - org.w3c.dom 中的 接口
Attr 接口表示 Element 对象中的属性。
Attribute - javax.management 中的 类
通过将 MBean 属性名与其值相关联来表示 MBean 属性。
Attribute(String, Object) - 类 javax.management.Attribute 的构造方法
构造将给定的属性名与给定值相关联的 Attribute 对象。
Attribute - javax.naming.directory 中的 接口
此接口表示与命名对象关联的属性。
Attribute - javax.print.attribute 中的 接口
接口 Attribute 是由任何一个打印属性类实现的基本接口，用于指示该类表示某一打印属性。
Attribute - javax.xml.stream.events 中的 接口
包含关于属性信息的接口。
ATTRIBUTE - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个属性
ATTRIBUTE_CHANGE - 类 javax.management.AttributeChangeNotification 中的静态变量
通知类型，指示所观察的 MBean 属性值已更改。
ATTRIBUTE_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Attr。
ATTRIBUTE_RUN - 接口 javax.accessibility.AccessibleExtendedText 中的静态变量
用于指示应被检索的文本部分是具有相同文本属性的连续文本的常量。
AttributeChangeNotification - javax.management 中的 类
提供 MBean 所发送的属性更改通知的定义。
AttributeChangeNotification(Object, long, long, String, String, String, Object, Object) - 类 javax.management.AttributeChangeNotification 的构造方法
构造一个 AttributeChangeNotification 对象。
AttributeChangeNotificationFilter - javax.management 中的 类
此类实现 attribute change notification 的 NotificationFilter 接口。
AttributeChangeNotificationFilter() - 类 javax.management.AttributeChangeNotificationFilter 的构造方法
AttributedCharacterIterator - java.text 中的 接口
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
AttributedCharacterIterator.Attribute - java.text 中的 类
定义用于标识文本属性的属性键。
AttributedCharacterIterator.Attribute(String) - 类 java.text.AttributedCharacterIterator.Attribute 的构造方法
构造具有给定名称的 Attribute。
attributeDecl(String, String, String, String, String) - 接口 org.xml.sax.ext.DeclHandler 中的方法
报告属性类型声明。
attributeDecl(String, String, String, String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
AttributedString - java.text 中的 类
AttributedString 保存文本及相关属性信息。
AttributedString(String) - 类 java.text.AttributedString 的构造方法
构造带给定文本的 AttributedString 实例。
AttributedString(String, Map<? extends AttributedCharacterIterator.Attribute, ?>) - 类 java.text.AttributedString 的构造方法
构造带给定文本和属性的 AttributedString。
AttributedString(AttributedCharacterIterator) - 类 java.text.AttributedString 的构造方法
构造带有 AttributedCharacterIterator 表示的给定属性文本的 AttributedString。
AttributedString(AttributedCharacterIterator, int, int) - 类 java.text.AttributedString 的构造方法
构造带有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
AttributedString(AttributedCharacterIterator, int, int, AttributedCharacterIterator.Attribute[]) - 类 java.text.AttributedString 的构造方法
构造具有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
AttributeException - javax.print 中的 接口
接口 AttributeException 是一个混合接口，PrintException 的子类可实现该接口以报告涉及一个或多个打印属性的错误条件，特定的 Print Service 实例不支持该条件。
AttributeInUseException - javax.naming.directory 中的 异常
当操作试图添加已经存在的属性时抛出此异常。
AttributeInUseException(String) - 异常 javax.naming.directory.AttributeInUseException 的构造方法
使用解释构造一个新的 AttributeInUseException 实例。
AttributeInUseException() - 异常 javax.naming.directory.AttributeInUseException 的构造方法
构造一个新的 AttributeInUseException 实例。
AttributeList - javax.management 中的 类
表示 MBean 属性值的列表。
AttributeList() - 类 javax.management.AttributeList 的构造方法
构造一个空 AttributeList。
AttributeList(int) - 类 javax.management.AttributeList 的构造方法
构造一个具有指定初始容量的空 AttributeList。
AttributeList(AttributeList) - 类 javax.management.AttributeList 的构造方法
构造一个包含指定 AttributeList 元素的 AttributeList，元素的顺序是该 AttributeList 的迭代器所返回的顺序。
AttributeList(List<Attribute>) - 类 javax.management.AttributeList 的构造方法
构造一个包含指定 List 的元素的 AttributeList，这些元素按 List 的迭代器返回的顺序排列。
AttributeList - javax.swing.text.html.parser 中的 类
此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。
AttributeList(String) - 类 javax.swing.text.html.parser.AttributeList 的构造方法
创建一个属性列表元素。
AttributeList(String, int, int, String, Vector<?>, AttributeList) - 类 javax.swing.text.html.parser.AttributeList 的构造方法
创建一个属性列表元素。
AttributeList - org.xml.sax 中的 接口
已过时。 此接口已经被 SAX2 Attributes 接口取代，后者包括名称空间支持。
AttributeListImpl - org.xml.sax.helpers 中的 类
已过时。 此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。
AttributeListImpl() - 类 org.xml.sax.helpers.AttributeListImpl 的构造方法
已过时。 创建空的属性列表。
AttributeListImpl(AttributeList) - 类 org.xml.sax.helpers.AttributeListImpl 的构造方法
已过时。 构造现有属性列表的持久副本。
AttributeModificationException - javax.naming.directory 中的 异常
当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
AttributeModificationException(String) - 异常 javax.naming.directory.AttributeModificationException 的构造方法
使用解释构造一个新的 AttributeModificationException 实例。
AttributeModificationException() - 异常 javax.naming.directory.AttributeModificationException 的构造方法
构造一个新的 AttributeModificationException 实例。
attributeNames() - 类 java.beans.FeatureDescriptor 中的方法
获得与语言环境无关的此特性名称的枚举。
attributeNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示可能不允许使用 NULL 值。
AttributeNotFoundException - javax.management 中的 异常
指定的属性不存在或无法检索。
AttributeNotFoundException() - 异常 javax.management.AttributeNotFoundException 的构造方法
默认的构造方法。
AttributeNotFoundException(String) - 异常 javax.management.AttributeNotFoundException 的构造方法
允许指定具体错误消息的构造方法。
attributeNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示明确允许使用 NULL 值。
attributeNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道是否允许使用 NULL 值。
Attributes - java.util.jar 中的 类
Attributes 类将 Manifest 属性名称映射到关联的字符串值。
Attributes() - 类 java.util.jar.Attributes 的构造方法
构造具有默认大小的新的空 Attributes 对象。
Attributes(int) - 类 java.util.jar.Attributes 的构造方法
构造具有指定初始大小的新的空 Attributes 对象。
Attributes(Attributes) - 类 java.util.jar.Attributes 的构造方法
构造新的 Attributes 对象，该对象与指定的 Attributes 具有相同的属性名称-值映射关系。
attributes - 类 javax.accessibility.AccessibleAttributeSequence 中的变量
文本属性
Attributes - javax.naming.directory 中的 接口
此接口表示属性的集合。
Attributes - org.xml.sax 中的 接口
关于 XML 属性列表的接口。
Attributes.Name - java.util.jar 中的 类
Attributes.Name 类表示存储在此 Map 中的一个属性名称。
Attributes.Name(String) - 类 java.util.jar.Attributes.Name 的构造方法
用给定字符串名称构造一个新的属性名称。
Attributes2 - org.xml.sax.ext 中的 接口
SAX2 扩展，用于扩充通过 Attributes 提供的每个属性信息。
Attributes2Impl - org.xml.sax.ext 中的 类
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。
Attributes2Impl() - 类 org.xml.sax.ext.Attributes2Impl 的构造方法
构造一个新的空 Attributes2Impl 对象。
Attributes2Impl(Attributes) - 类 org.xml.sax.ext.Attributes2Impl 的构造方法
复制现有属性或 Attributes2 对象。
AttributeSet - javax.print.attribute 中的 接口
接口 AttributeSet 为打印属性集指定接口。
AttributeSet - javax.swing.text 中的 接口
唯一属性的集合。
AttributeSet.CharacterAttribute - javax.swing.text 中的 接口
此接口是类型签名，可出现在任意属性键上以帮助实现字符级的表示。
AttributeSet.ColorAttribute - javax.swing.text 中的 接口
此接口是类型签名，可出现在任意属性键上以帮助实现颜色的表示。
AttributeSet.FontAttribute - javax.swing.text 中的 接口
此接口是类型签名，可出现在任意属性键上以帮助确定使用何种字体来呈现某类文本。
AttributeSet.ParagraphAttribute - javax.swing.text 中的 接口
此接口是类型签名，可出现在任意属性键上以帮助实现段落级的表示。
AttributeSetUtilities - javax.print.attribute 中的 类
类 AttributeSetUtilities 为操作 AttributeSets 提供静态方法。
AttributesImpl - org.xml.sax.helpers 中的 类
Attributes 接口的默认实现。
AttributesImpl() - 类 org.xml.sax.helpers.AttributesImpl 的构造方法
构造一个新的空 AttributesImpl 对象。
AttributesImpl(Attributes) - 类 org.xml.sax.helpers.AttributesImpl 的构造方法
复制现有 Attributes 对象。
attributeUpdate(PrintJobAttributeEvent) - 接口 javax.print.event.PrintJobAttributeListener 中的方法
通知侦听器某些打印作业属性已更改。
attributeUpdate(PrintServiceAttributeEvent) - 接口 javax.print.event.PrintServiceAttributeListener 中的方法
调用此方法来通知侦听器关于打印服务中的事件。
AttributeValueExp - javax.management 中的 类
表示用作关系约束参数的属性。
AttributeValueExp() - 类 javax.management.AttributeValueExp 的构造方法
已过时。 在查询中不能使用此构造方法所创建的实例。
AttributeValueExp(String) - 类 javax.management.AttributeValueExp 的构造方法
创建一个表示指定对象属性 attr 的新 AttributeValueExp。
attrID - 类 javax.naming.directory.BasicAttribute 中的变量
保存属性的 id。
atts - 类 javax.swing.text.html.parser.Element 中的变量
AU - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 AU 文件。
AudioClip - java.applet 中的 接口
AudioClip 接口是用于播放音频剪辑的简单抽象。
AudioFileFormat - javax.sound.sampled 中的 类
AudioFileFormat 类的实例描述音频文件，包括文件类型、文件长度（以字节为单位）、文件中包含的音频数据的长度（以示例帧为单位），以及音频数据的格式。
AudioFileFormat(AudioFileFormat.Type, int, AudioFormat, int) - 类 javax.sound.sampled.AudioFileFormat 的构造方法
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int) - 类 javax.sound.sampled.AudioFileFormat 的构造方法
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int, Map<String, Object>) - 类 javax.sound.sampled.AudioFileFormat 的构造方法
构造具有定义的属性集合的音频文件格式对象。
AudioFileFormat.Type - javax.sound.sampled 中的 类
Type 类的实例表示音频文件的标准类型之一。
AudioFileFormat.Type(String, String) - 类 javax.sound.sampled.AudioFileFormat.Type 的构造方法
构造文件类型。
AudioFileReader - javax.sound.sampled.spi 中的 类
音频文件读取服务的提供者。
AudioFileReader() - 类 javax.sound.sampled.spi.AudioFileReader 的构造方法
AudioFileWriter - javax.sound.sampled.spi 中的 类
音频文件写入服务的提供者。
AudioFileWriter() - 类 javax.sound.sampled.spi.AudioFileWriter 的构造方法
AudioFormat - javax.sound.sampled 中的 类
AudioFormat 是在声音流中指定特定数据安排的类。
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean) - 类 javax.sound.sampled.AudioFormat 的构造方法
构造具有给定参数的 AudioFormat。
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean, Map<String, Object>) - 类 javax.sound.sampled.AudioFormat 的构造方法
构造具有给定参数的 AudioFormat。
AudioFormat(float, int, int, boolean, boolean) - 类 javax.sound.sampled.AudioFormat 的构造方法
构造具有线性 PCM 编码和给定参数的 AudioFormat。
AudioFormat.Encoding - javax.sound.sampled 中的 类
Encoding 类命名用于音频流的数据表示形式的特定类型。
AudioFormat.Encoding(String) - 类 javax.sound.sampled.AudioFormat.Encoding 的构造方法
构造一个新编码。
AudioInputStream - javax.sound.sampled 中的 类
音频输入流是具有指定音频格式和长度的输入流。
AudioInputStream(InputStream, AudioFormat, long) - 类 javax.sound.sampled.AudioInputStream 的构造方法
使用指定输入流中的音频数据构造具有请求的格式和长度（以示例帧为单位）的音频输入流。
AudioInputStream(TargetDataLine) - 类 javax.sound.sampled.AudioInputStream 的构造方法
构造从指示的目标数据行读取数据的音频输入流。
AudioPermission - javax.sound.sampled 中的 类
AudioPermission 类表示对音频系统资源的访问权限。
AudioPermission(String) - 类 javax.sound.sampled.AudioPermission 的构造方法
创建具有指定符号名（如 "play" 或 "record"）的 AudioPermission 对象。
AudioPermission(String, String) - 类 javax.sound.sampled.AudioPermission 的构造方法
创建具有指定符号名（"play" 或 "record"）的 AudioPermission 对象。
AudioSystem - javax.sound.sampled 中的 类
AudioSystem 类充当取样音频系统资源的入口点。
augmentList(Action[], Action[]) - 类 javax.swing.text.TextAction 中的静态方法
取一个命令列表并用另一个命令列表去扩充。
AUGUST - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第八个月的 Calendar.MONTH 字段值。
AUGUST - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第八个月的值。
authenticate(Object) - 接口 javax.management.remote.JMXAuthenticator 中的方法
用给定的客户端凭据验证 MBeanServerConnection 客户端。
AuthenticationException - javax.naming 中的 异常
当访问命名或目录服务发生验证错误时，抛出此异常。
AuthenticationException(String) - 异常 javax.naming.AuthenticationException 的构造方法
使用所提供的解释构造一个新的 AuthenticationException 实例。
AuthenticationException() - 异常 javax.naming.AuthenticationException 的构造方法
构造一个新的 AuthenticationException 实例。
AuthenticationException - javax.security.sasl 中的 异常
此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
AuthenticationException() - 异常 javax.security.sasl.AuthenticationException 的构造方法
构造一个新的 AuthenticationException 实例。
AuthenticationException(String) - 异常 javax.security.sasl.AuthenticationException 的构造方法
构造带详细消息的新 AuthenticationException 实例。
AuthenticationException(String, Throwable) - 异常 javax.security.sasl.AuthenticationException 的构造方法
构造带详细消息和根异常的新 AuthenticationException 实例。
AuthenticationNotSupportedException - javax.naming 中的 异常
当所请求验证的特定 flavor 不受支持时，抛出此异常。
AuthenticationNotSupportedException(String) - 异常 javax.naming.AuthenticationNotSupportedException 的构造方法
使用解释构造一个新的 AuthenticationNotSupportedException 实例。
AuthenticationNotSupportedException() - 异常 javax.naming.AuthenticationNotSupportedException 的构造方法
构造一个新的 AuthenticationNotSupportedException 实例，将解释和所有名称解析字段初始化为 null。
Authenticator - java.net 中的 类
Authenticator 类表示懂得如何获得网络连接验证的对象。
Authenticator() - 类 java.net.Authenticator 的构造方法
AUTHENTICATOR - 类 javax.management.remote.JMXConnectorServer 中的静态变量
为连接器服务器指定经验证的属性名称。
Authenticator.RequestorType - java.net 中的 枚举
请求验证的实体的类型。
AUTHORITATIVE - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定所请求服务的权威性的环境属性名称。
AuthorizeCallback - javax.security.sasl 中的 类
此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。
AuthorizeCallback(String, String) - 类 javax.security.sasl.AuthorizeCallback 的构造方法
构造 AuthorizeCallback 的实例。
AuthPermission - javax.security.auth 中的 类
此类用于验证权限。
AuthPermission(String) - 类 javax.security.auth.AuthPermission 的构造方法
创建具有指定名称的新 AuthPermission。
AuthPermission(String, String) - 类 javax.security.auth.AuthPermission 的构造方法
创建具有指定名称的新 AuthPermission 对象。
AuthProvider - java.security 中的 类
此类定义 provider 的登录和注销方法。
AuthProvider(String, double, String) - 类 java.security.AuthProvider 的构造方法
构造具有指定名称、版本号和信息的 provider。
AUTO_RESIZE_ALL_COLUMNS - 类 javax.swing.JTable 中的静态变量
在所有的调整大小操作中，按比例调整所有的列。
AUTO_RESIZE_LAST_COLUMN - 类 javax.swing.JTable 中的静态变量
在所有的调整大小操作中，只对最后一列进行调整。
AUTO_RESIZE_NEXT_COLUMN - 类 javax.swing.JTable 中的静态变量
在 UI 中调整了一个列时，对其下一列进行相反方向的调整。
AUTO_RESIZE_OFF - 类 javax.swing.JTable 中的静态变量
不自动调整列的宽度；使用滚动条。
AUTO_RESIZE_SUBSEQUENT_COLUMNS - 类 javax.swing.JTable 中的静态变量
在 UI 调整中，更改后续列以保持总宽度不变；此为默认行为。
autoCommitFailureClosesAllResultSets() - 接口 java.sql.DatabaseMetaData 中的方法
当 autoCommit 为 true 时，获取 SQLException 是否指示所有打开的 ResultSets 已关闭（包括那些可保持的）。
autoCreateColumnsFromModel - 类 javax.swing.JTable 中的变量
如果为 true，则表对 TableModel 进行查询以构建默认列集。
autoResizeMode - 类 javax.swing.JTable 中的变量
确定表是否自动调整列的宽度以占用表的整个宽度，以及如何进行调整。
Autoscroll - java.awt.dnd 中的 接口
在 DnD 操作期间，用户有可能希望将操作目标放入一个可滚动的 GUI 控件区域中，而该区域当前对用户是不可见的。
autoscroll(Point) - 接口 java.awt.dnd.Autoscroll 中的方法
通知 Component 自动滚动
autoScrollDown() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
autoscrollTimer - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
autoScrollUp() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
AUTOSENSE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
AUTOSENSE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
AUTOSENSE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
AUX_RETURN - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上辅助返回音量的控件。
AUX_SEND - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上辅助发送音量的控件。
available() - 类 java.io.BufferedInputStream 中的方法
返回可以从此输入流读取（或跳过）、且不受此输入流接下来的方法调用阻塞的估计字节数。
available() - 类 java.io.ByteArrayInputStream 中的方法
返回可从此输入流读取（或跳过）的剩余字节数。
available() - 类 java.io.FileInputStream 中的方法
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
available() - 类 java.io.FilterInputStream 中的方法
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
available() - 类 java.io.InputStream 中的方法
返回此输入流下一个方法调用可以不受阻塞地从此输入流读取（或跳过）的估计字节数。
available() - 类 java.io.LineNumberInputStream 中的方法
已过时。 无阻塞情况下返回可以从此输入流中读取的字节数。
available() - 接口 java.io.ObjectInput 中的方法
返回可以无阻塞地读取的字节数。
available() - 类 java.io.ObjectInputStream 中的方法
返回可以不受阻塞地读取的字节数。
available() - 类 java.io.PipedInputStream 中的方法
返回可以不受阻塞地从此输入流中读取的字节数。
available() - 类 java.io.PushbackInputStream 中的方法
返回可以不受下一次调用此输入流的方法阻塞地从此输入流读取（或跳过）的估计字节数。
available() - 类 java.io.SequenceInputStream 中的方法
返回不受阻塞地从当前底层输入流读取（或跳过）的字节数的估计值，方法是通过下一次调用当前底层输入流的方法。
available() - 类 java.io.StringBufferInputStream 中的方法
已过时。 返回无阻塞情况下可以从此输入流读取的字节数。
available() - 类 java.net.SocketImpl 中的方法
返回可以不受阻塞地从此套接字中读取的字节数。
available() - 类 java.util.zip.DeflaterInputStream 中的方法
在到达 EOF 后返回 0；否则始终返回 1。
available() - 类 java.util.zip.InflaterInputStream 中的方法
在到达 EOF 后返回 0；否则始终返回 1。
available() - 类 java.util.zip.ZipInputStream 中的方法
在 EOF 到达当前条目数据后，返回 0；否则，始终返回 1。
available() - 类 javax.crypto.CipherInputStream 中的方法
返回不发生阻塞地从此输入流读取的字节数。
available() - 类 javax.sound.sampled.AudioInputStream 中的方法
返回可不受阻塞地从此音频输入流中读取（或跳过）的最大字节数。
available() - 接口 javax.sound.sampled.DataLine 中的方法
获得当前可用于数据行内部缓冲区中处理的应用程序的数据字节数。
availableCharsets() - 类 java.nio.charset.Charset 中的静态方法
构造从规范 charset 名称到 charset 对象的有序映射。
availableLocales - 类 javax.imageio.ImageReader 中的变量
可以用来本地化警告消息的 Locale 组成的数组，如果不支持本地化，则为 null。
availableLocales - 类 javax.imageio.ImageWriter 中的变量
可以用来本地化警告消息和压缩设置值的 Locale 组成的数组，如果本地化不受支持，则将它们初始化为 null。
availablePermits() - 类 java.util.concurrent.Semaphore 中的方法
返回此信号量中当前可用的许可数。
availableProcessors() - 类 java.lang.Runtime 中的方法
向 Java 虚拟机返回可用处理器的数目。
averageBytesPerChar() - 类 java.nio.charset.CharsetEncoder 中的方法
返回为每个输入字符生成的平均字节数。
averageCharsPerByte() - 类 java.nio.charset.CharsetDecoder 中的方法
返回为每个输入字节生成的平均字符数。
avoidingGui() - 类 java.beans.beancontext.BeanContextSupport 中的方法
用于确定 BeanContext 子级是否避免使用其 GUI。
avoidingGui() - 接口 java.beans.Visibility 中的方法
确定此 bean 是否避免使用 GUI。
await() - 类 java.util.concurrent.CountDownLatch 中的方法
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断。
await(long, TimeUnit) - 类 java.util.concurrent.CountDownLatch 中的方法
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断或超出了指定的等待时间。
await() - 类 java.util.concurrent.CyclicBarrier 中的方法
在所有参与者都已经在此 barrier 上调用 await 方法之前，将一直等待。
await(long, TimeUnit) - 类 java.util.concurrent.CyclicBarrier 中的方法
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
await() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现可中断的条件等待。
await(long, TimeUnit) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现定时条件等待。
await() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现不可中断的条件等待。
await(long, TimeUnit) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现定时的条件等待。
await() - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号或被中断之前一直处于等待状态。
await(long, TimeUnit) - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
awaitNanos(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现定时条件等待。
awaitNanos(long) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现定时的条件等待。
awaitNanos(long) - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
awaitTermination(long, TimeUnit) - 接口 java.util.concurrent.ExecutorService 中的方法
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。
awaitTermination(long, TimeUnit) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
awaitUninterruptibly() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现不可中断的条件等待。
awaitUninterruptibly() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现不可中断的条件等待。
awaitUninterruptibly() - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号之前一直处于等待状态。
awaitUntil(Date) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
实现绝对定时条件等待。
awaitUntil(Date) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
实现绝对定时条件等待。
awaitUntil(Date) - 接口 java.util.concurrent.locks.Condition 中的方法
造成当前线程在接到信号、被中断或到达指定最后期限之前一直处于等待状态。
AWT_COMPONENT - 类 javax.accessibility.AccessibleRole 中的静态变量
一个 AWT 组件，但关于它的其他信息都是未知的。
AWTError - java.awt 中的 错误
当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。
AWTError(String) - 错误 java.awt.AWTError 的构造方法
构造带指定详细消息的 AWTError 的实例。
AWTEvent - java.awt 中的 类
所有 AWT 事件的根事件类。
AWTEvent(Event) - 类 java.awt.AWTEvent 的构造方法
从 1.0 样式的事件参数构造一个 AWTEvent 对象。
AWTEvent(Object, int) - 类 java.awt.AWTEvent 的构造方法
使用指定的源对象和类型构造一个 AWTEvent 对象。
AWTEventListener - java.awt.event 中的 接口
该侦听器接口用于接收指派给对象的事件的通知，这些对象是 Component、MenuComponent 或其子类的实例。
AWTEventListenerProxy - java.awt.event 中的 类
扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。
AWTEventListenerProxy(long, AWTEventListener) - 类 java.awt.event.AWTEventListenerProxy 的构造方法
将 AWTEventListener 绑定到特定事件掩码的构造方法。
AWTEventMulticaster - java.awt 中的 类
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
AWTEventMulticaster(EventListener, EventListener) - 类 java.awt.AWTEventMulticaster 的构造方法
创建一个将侦听器 a 和侦听器 b 链接起来的事件多路广播器实例。
AWTException - java.awt 中的 异常
表示发生了 Absract Window Toolkit 异常。
AWTException(String) - 异常 java.awt.AWTException 的构造方法
构造带指定详细消息的 AWTException 实例。
AWTKeyStroke - java.awt 中的 类
AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。
AWTKeyStroke() - 类 java.awt.AWTKeyStroke 的构造方法
使用默认值构造 AWTKeyStroke。
AWTKeyStroke(char, int, int, boolean) - 类 java.awt.AWTKeyStroke 的构造方法
使用指定值构造 AWTKeyStroke。
AWTPermission - java.awt 中的 类
此类用于 AWT 权限。
AWTPermission(String) - 类 java.awt.AWTPermission 的构造方法
创建具有指定名称的新 AWTPermission。
AWTPermission(String, String) - 类 java.awt.AWTPermission 的构造方法
创建具有指定名称的新 AWTPermission 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


B - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

B

b - 类 java.awt.AWTEventMulticaster 中的变量
B - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering B (11 x 17 in) 的 MediaType 实例。
B - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering B 尺寸，11 inch × 17 inch。
B - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
B 尺寸。
B - 类 javax.swing.text.html.HTML.Tag 中的静态变量
B0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B0 的别名。
B0 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B0 尺寸，1000 mm × 1414 mm。
B0 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B0 尺寸，1030 mm × 1456 mm。
B1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B1 的别名。
B1 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B1 尺寸，707 mm × 1000 mm。
B1 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B1 尺寸，728 mm × 1030 mm。
B10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B10 的别名。
B10 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B10 尺寸，31 mm × 44 mm。
B10 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B10 尺寸，32 mm × 45 mm。
B2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B2 的别名。
B2 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B2 尺寸，500 mm × 707 mm。
B2 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B2 尺寸，515 mm × 728 mm。
B3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B3 的别名。
B3 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B3 尺寸，353 mm × 500 mm。
B3 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B3 尺寸，364 mm × 515 mm。
B4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B4 的别名。
B4 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B4 尺寸，250 mm × 353 mm。
B4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B4 尺寸，257 mm × 364 mm。
B5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B5 的别名。
B5 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B5 尺寸，176 mm × 250 mm。
B5 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B5 尺寸，182 mm × 257 mm。
B6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B6 的别名。
B6 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B6 尺寸，125 mm × 176 mm。
B6 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B6 尺寸，128 mm × 182 mm。
B7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B7 的别名。
B7 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B7 尺寸，88 mm × 125 mm。
B7 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B7 尺寸，91 mm × 128 mm。
B8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B8 的别名。
B8 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B8 尺寸，62 mm × 88 mm。
B8 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B8 尺寸，64 mm × 91 mm。
B9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B9 的别名。
B9 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO B9 尺寸，44 mm × 62 mm。
B9 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS B9 尺寸，45 mm × 64 mm。
BACK_SPACE - 类 java.awt.Event 中的静态变量
BackSpace 键。
backBuffers - 类 java.awt.Component.BltBufferStrategy 中的变量
后台缓冲区
BACKGROUND - 类 java.awt.BufferCapabilities.FlipContents 中的静态变量
当翻转内容为 BACKGROUND 时，后台缓冲区的内容在翻转后使用背景颜色清除。
BACKGROUND - 类 java.awt.font.TextAttribute 中的静态变量
用于呈现文本背景的 paint 的属性键。
BACKGROUND - 类 javax.swing.plaf.synth.ColorType 中的静态变量
某一 region 背景的 ColorType。
BACKGROUND - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Background - 类 javax.swing.text.StyleConstants 中的静态变量
背景色属性的名称。
BACKGROUND_ATTACHMENT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND_COLOR - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND_IMAGE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND_POSITION - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BACKGROUND_REPEAT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
backgroundNonSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
不选定节点时用于背景的颜色。
backgroundSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
选定节点时用于背景的颜色。
backingStore - 类 javax.swing.JViewport 中的变量
已过时。 从 Java 2 平台 v1.3 开始
BACKINGSTORE_SCROLL_MODE - 类 javax.swing.JViewport 中的静态变量
将视口内容拉入屏幕外图像。
BackingStoreException - java.util.prefs 中的 异常
抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
BackingStoreException(String) - 异常 java.util.prefs.BackingStoreException 的构造方法
构造带指定详细消息的 BackingStoreException。
BackingStoreException(Throwable) - 异常 java.util.prefs.BackingStoreException 的构造方法
构造带指定原因的 BackingStoreException。
backingStoreImage - 类 javax.swing.JViewport 中的变量
用于后备存储的视图图像。
Backward - 类 javax.swing.text.Position.Bias 中的静态变量
指示到模型中上一字符的偏差。
BACKWARD_TRAVERSAL_KEYS - 类 java.awt.KeyboardFocusManager 中的静态变量
Backward 焦点遍历键的标识符。
backwardAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向后移动一个位置的动作名称。
BAD_BINDINGS - 异常 org.ietf.jgss.GSSException 中的静态变量
通道绑定不匹配。
BAD_CONTEXT - org.omg.CORBA 中的 异常
当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
BAD_CONTEXT() - 异常 org.omg.CORBA.BAD_CONTEXT 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(String) - 异常 org.omg.CORBA.BAD_CONTEXT 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_CONTEXT 的构造方法
使用指定次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_CONTEXT(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_CONTEXT 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_CONTEXT 异常。
BAD_INV_ORDER - org.omg.CORBA 中的 异常
此异常指示调用者按错误顺序调用了操作。
BAD_INV_ORDER() - 异常 org.omg.CORBA.BAD_INV_ORDER 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(String) - 异常 org.omg.CORBA.BAD_INV_ORDER 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_INV_ORDER 的构造方法
使用指定次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_INV_ORDER(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_INV_ORDER 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_INV_ORDER 异常。
BAD_LOCATION - 类 javax.swing.text.AbstractDocument 中的静态变量
指示位置错误的错误消息。
BAD_MECH - 异常 org.ietf.jgss.GSSException 中的静态变量
请求了不受支持的机制。
BAD_MIC - 异常 org.ietf.jgss.GSSException 中的静态变量
具有无效的完整性检查的标记。
BAD_NAME - 异常 org.ietf.jgss.GSSException 中的静态变量
提供了无效名称。
BAD_NAMETYPE - 异常 org.ietf.jgss.GSSException 中的静态变量
提供了不受支持的类型的名称。
BAD_OPERATION - org.omg.CORBA 中的 异常
当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
BAD_OPERATION() - 异常 org.omg.CORBA.BAD_OPERATION 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。
BAD_OPERATION(String) - 异常 org.omg.CORBA.BAD_OPERATION 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。
BAD_OPERATION(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_OPERATION 的构造方法
使用指定次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_OPERATION(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_OPERATION 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_OPERATION 异常。
BAD_PARAM - org.omg.CORBA 中的 异常
当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
BAD_PARAM() - 异常 org.omg.CORBA.BAD_PARAM 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。
BAD_PARAM(String) - 异常 org.omg.CORBA.BAD_PARAM 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。
BAD_PARAM(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_PARAM 的构造方法
使用指定次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_PARAM(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_PARAM 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_PARAM 异常。
BAD_POLICY - org.omg.CORBA 中的 接口
将填充在 PolicyError 异常中的 PolicyErrorCode。
BAD_POLICY_TYPE - org.omg.CORBA 中的 接口
将填充在 PolicyError 异常中的 PolicyErrorCode。
BAD_POLICY_VALUE - org.omg.CORBA 中的 接口
包含指示某个策略值的值，该策略值对于 create_policy 方法（在 ORB 类中定义）调用中的有效策略类型而言是不正确的。
BAD_QOP - 异常 org.ietf.jgss.GSSException 中的静态变量
不受支持的 QOP 值。
BAD_QOS - org.omg.CORBA 中的 异常
只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
BAD_QOS() - 异常 org.omg.CORBA.BAD_QOS 的构造方法
构造一个 BAD_QOS 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
BAD_QOS(String) - 异常 org.omg.CORBA.BAD_QOS 的构造方法
使用指定消息构造一个 BAD_QOS 异常。
BAD_QOS(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_QOS 的构造方法
使用指定次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_QOS(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_QOS 的构造方法
使用指定消息、次要代码和完成状态构造一个 BAD_QOS 异常。
BAD_STATUS - 异常 org.ietf.jgss.GSSException 中的静态变量
无效的状态码。
BAD_TYPECODE - org.omg.CORBA 中的 异常
当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
BAD_TYPECODE() - 异常 org.omg.CORBA.BAD_TYPECODE 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(String) - 异常 org.omg.CORBA.BAD_TYPECODE 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(int, CompletionStatus) - 异常 org.omg.CORBA.BAD_TYPECODE 的构造方法
使用指定次要代码和完成状态构造一个 BAD_TYPECODE 异常。
BAD_TYPECODE(String, int, CompletionStatus) - 异常 org.omg.CORBA.BAD_TYPECODE 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 BAD_TYPECODE 异常。
BadAttributeValueExpException - javax.management 中的 异常
向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
BadAttributeValueExpException(Object) - 异常 javax.management.BadAttributeValueExpException 的构造方法
构造带指定 Object 的 BadAttributeValueExpException。
BadBinaryOpValueExpException - javax.management 中的 异常
向构造查询的方法传递无效的表达式时，抛出此异常。
BadBinaryOpValueExpException(ValueExp) - 异常 javax.management.BadBinaryOpValueExpException 的构造方法
构造带指定 ValueExp 的 BadBinaryOpValueExpException。
BadBreakWeight - 类 javax.swing.text.View 中的静态变量
该权重指示对于格式化来说视图未处于拆分的好时机。
BadKind - org.omg.CORBA.TypeCodePackage 中的 异常
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。
BadKind() - 异常 org.omg.CORBA.TypeCodePackage.BadKind 的构造方法
构造一个不带任何原因消息的 BadKind 异常。
BadKind(String) - 异常 org.omg.CORBA.TypeCodePackage.BadKind 的构造方法
构造一个带有指定原因消息的 BadKind 异常。
BadLocationException - javax.swing.text 中的 异常
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
BadLocationException(String, int) - 异常 javax.swing.text.BadLocationException 的构造方法
创建新的 BadLocationException 对象。
BadPaddingException - javax.crypto 中的 异常
当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
BadPaddingException() - 异常 javax.crypto.BadPaddingException 的构造方法
构造不带详细消息的 BadPaddingException。
BadPaddingException(String) - 异常 javax.crypto.BadPaddingException 的构造方法
构造带指定详细消息的 BadPaddingException。
BadStringOperationException - javax.management 中的 异常
向构造查询的方法传递无效的字符串操作时，抛出此异常。
BadStringOperationException(String) - 异常 javax.management.BadStringOperationException 的构造方法
构造带指定详细消息的 BadStringOperationException。
BALANCE - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示两个立体声扬声器之间立体声信号相对平衡的控件。
BandCombineOp - java.awt.image 中的 类
此类使用一个指定矩阵对 Raster 中的 band 进行任意线性组合。
BandCombineOp(float[][], RenderingHints) - 类 java.awt.image.BandCombineOp 的构造方法
构造一个具有指定矩阵的 BandCombineOp。
BandedSampleModel - java.awt.image 中的 类
此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。
BandedSampleModel(int, int, int, int) - 类 java.awt.image.BandedSampleModel 的构造方法
构造一个具有指定参数的 BandedSampleModel。
BandedSampleModel(int, int, int, int, int[], int[]) - 类 java.awt.image.BandedSampleModel 的构造方法
构造一个具有指定参数的 BandedSampleModel。
bandOffsets - 类 java.awt.image.ComponentSampleModel 中的变量
数据数组元素中所有 band 的偏移量。
bank - 类 javax.sound.midi.VoiceStatus 中的变量
此声音当前正在使用的乐器的库号。
bankIndices - 类 java.awt.image.ComponentSampleModel 中的变量
各个存储图像数据 band 的存储单元的索引。
banks - 类 java.awt.image.DataBuffer 中的变量
此 DataBuffer 中存储单元的数量。
BASE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
base - 类 javax.swing.text.html.parser.DTD 中的变量
BASE64 - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
Base64 转换算法 URI。
BASEFONT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
baseIsLeftToRight() - 类 java.text.Bidi 中的方法
如果基本方向是从左到右，则返回 true。
BASELINE - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BASELINE - 类 javax.swing.SpringLayout 中的静态变量
指定组件的基线。
BASELINE_LEADING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BASELINE_TRAILING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
baselineLayout(int, int, int[], int[]) - 类 javax.swing.text.BoxView 中的方法
在给定的 targetSpan 区域，即我们将使用的区域的宽度（或高度），计算每个子视图在此 BoxView 中的位置和扩展。
baselineRequirements(int, SizeRequirements) - 类 javax.swing.text.BoxView 中的方法
通过检查每个子视图的大小计算此 BoxView 的大小要求。
BaseRowSet - javax.sql.rowset 中的 类
提供一个具有基本功能的 RowSet 对象的抽象类。
BaseRowSet() - 类 javax.sql.rowset.BaseRowSet 的构造方法
构造一个新的 BaseRowSet 对象，使用默认的 Vector 对象初始化其 listeners 字段。
baseWireHandle - 接口 java.io.ObjectStreamConstants 中的静态变量
分配的第一个句柄。
BASIC_LATIN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Basic Latin”Unicode 字符块的常量。
BasicArrowButton - javax.swing.plaf.basic 中的 类
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
BasicArrowButton(int, Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicArrowButton 的构造方法
创建一个在指定方向上绘制其箭头并具有指定颜色的 BasicArrowButton。
BasicArrowButton(int) - 类 javax.swing.plaf.basic.BasicArrowButton 的构造方法
创建一个在指定方向上绘制其箭头的 BasicArrowButton。
BasicAttribute - javax.naming.directory 中的 类
此类提供 Attribute 接口的基本实现。
BasicAttribute(String) - 类 javax.naming.directory.BasicAttribute 的构造方法
构造一个不带值无序属性的新实例。
BasicAttribute(String, Object) - 类 javax.naming.directory.BasicAttribute 的构造方法
构造一个带有单个值的无序属性的新实例。
BasicAttribute(String, boolean) - 类 javax.naming.directory.BasicAttribute 的构造方法
构造一个不带值的可能为有序属性的新实例。
BasicAttribute(String, Object, boolean) - 类 javax.naming.directory.BasicAttribute 的构造方法
构造一个带有单个值的可能为有序属性的新实例。
BasicAttributes - javax.naming.directory 中的 类
此类提供 Attributes 接口的基本实现。
BasicAttributes() - 类 javax.naming.directory.BasicAttributes 的构造方法
构造一个新的 Attributes 实例。
BasicAttributes(boolean) - 类 javax.naming.directory.BasicAttributes 的构造方法
构造一个新的 Attributes 实例。
BasicAttributes(String, Object) - 类 javax.naming.directory.BasicAttributes 的构造方法
构造带有一个属性的新 Attributes 实例。
BasicAttributes(String, Object, boolean) - 类 javax.naming.directory.BasicAttributes 的构造方法
构造带有一个属性的新 Attributes 实例。
BasicBorders - javax.swing.plaf.basic 中的 类
可以提供适合基本 L&F 的 Border 的工厂对象。
BasicBorders() - 类 javax.swing.plaf.basic.BasicBorders 的构造方法
BasicBorders.ButtonBorder - javax.swing.plaf.basic 中的 类
BasicBorders.ButtonBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 的构造方法
BasicBorders.FieldBorder - javax.swing.plaf.basic 中的 类
BasicBorders.FieldBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 的构造方法
BasicBorders.MarginBorder - javax.swing.plaf.basic 中的 类
BasicBorders.MarginBorder() - 类 javax.swing.plaf.basic.BasicBorders.MarginBorder 的构造方法
BasicBorders.MenuBarBorder - javax.swing.plaf.basic 中的 类
BasicBorders.MenuBarBorder(Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 的构造方法
BasicBorders.RadioButtonBorder - javax.swing.plaf.basic 中的 类
BasicBorders.RadioButtonBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 的构造方法
BasicBorders.RolloverButtonBorder - javax.swing.plaf.basic 中的 类
用于翻转工具栏按钮的特殊细边框。
BasicBorders.RolloverButtonBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder 的构造方法
BasicBorders.SplitPaneBorder - javax.swing.plaf.basic 中的 类
绘制围绕拆分窗格的边框。
BasicBorders.SplitPaneBorder(Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 的构造方法
BasicBorders.ToggleButtonBorder - javax.swing.plaf.basic 中的 类
BasicBorders.ToggleButtonBorder(Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 的构造方法
BasicButtonListener - javax.swing.plaf.basic 中的 类
按钮侦听器。
BasicButtonListener(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonListener 的构造方法
BasicButtonUI - javax.swing.plaf.basic 中的 类
BasicButton 实现
BasicButtonUI() - 类 javax.swing.plaf.basic.BasicButtonUI 的构造方法
BasicCheckBoxMenuItemUI - javax.swing.plaf.basic 中的 类
BasicCheckboxMenuItem 实现
BasicCheckBoxMenuItemUI() - 类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 的构造方法
BasicCheckBoxUI - javax.swing.plaf.basic 中的 类
BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicCheckBoxUI() - 类 javax.swing.plaf.basic.BasicCheckBoxUI 的构造方法
BasicColorChooserUI - javax.swing.plaf.basic 中的 类
为 JColorChooser 提供基本外观。
BasicColorChooserUI() - 类 javax.swing.plaf.basic.BasicColorChooserUI 的构造方法
BasicColorChooserUI.PropertyHandler - javax.swing.plaf.basic 中的 类
因编译器故障而被标记为 "public" 的内部类。
BasicColorChooserUI.PropertyHandler() - 类 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler 的构造方法
BasicComboBoxEditor - javax.swing.plaf.basic 中的 类
用于可编辑组合框的默认编辑器。
BasicComboBoxEditor() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 的构造方法
BasicComboBoxEditor.UIResource - javax.swing.plaf.basic 中的 类
实现 UIResource 的 BasicComboBoxEditor 的子类。
BasicComboBoxEditor.UIResource() - 类 javax.swing.plaf.basic.BasicComboBoxEditor.UIResource 的构造方法
BasicComboBoxRenderer - javax.swing.plaf.basic 中的 类
ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicComboBoxRenderer() - 类 javax.swing.plaf.basic.BasicComboBoxRenderer 的构造方法
BasicComboBoxRenderer.UIResource - javax.swing.plaf.basic 中的 类
实现 UIResource 的 BasicComboBoxRenderer 的子类。
BasicComboBoxRenderer.UIResource() - 类 javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource 的构造方法
BasicComboBoxUI - javax.swing.plaf.basic 中的 类
JComboBox 的基本 UI 实现。
BasicComboBoxUI() - 类 javax.swing.plaf.basic.BasicComboBoxUI 的构造方法
BasicComboBoxUI.ComboBoxLayoutManager - javax.swing.plaf.basic 中的 类
此布局管理器处理组合框的“标准”布局。
BasicComboBoxUI.ComboBoxLayoutManager() - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 的构造方法
BasicComboBoxUI.FocusHandler - javax.swing.plaf.basic 中的 类
失去焦点时，此侦听器将隐藏弹出部分。
BasicComboBoxUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 的构造方法
BasicComboBoxUI.ItemHandler - javax.swing.plaf.basic 中的 类
此侦听器观察组合框中选择的更改。
BasicComboBoxUI.ItemHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler 的构造方法
BasicComboBoxUI.KeyHandler - javax.swing.plaf.basic 中的 类
此侦听器检查键事件是否不是导航键。
BasicComboBoxUI.KeyHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler 的构造方法
BasicComboBoxUI.ListDataHandler - javax.swing.plaf.basic 中的 类
此侦听器观察 ComboBoxModel 中的更改。
BasicComboBoxUI.ListDataHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 的构造方法
BasicComboBoxUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此侦听器观察在组合框中发生更改的绑定 (bound) 属性。
BasicComboBoxUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler 的构造方法
BasicComboPopup - javax.swing.plaf.basic 中的 类
此为 ComboPopup 接口的基本实现。
BasicComboPopup(JComboBox) - 类 javax.swing.plaf.basic.BasicComboPopup 的构造方法
BasicComboPopup.InvocationKeyHandler - javax.swing.plaf.basic 中的 类
从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
BasicComboPopup.InvocationKeyHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler 的构造方法
BasicComboPopup.InvocationMouseHandler - javax.swing.plaf.basic 中的 类
要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
BasicComboPopup.InvocationMouseHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 的构造方法
BasicComboPopup.InvocationMouseMotionHandler - javax.swing.plaf.basic 中的 类
此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
BasicComboPopup.InvocationMouseMotionHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler 的构造方法
BasicComboPopup.ItemHandler - javax.swing.plaf.basic 中的 类
此侦听器观察组合框中选择的更改。
BasicComboPopup.ItemHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ItemHandler 的构造方法
BasicComboPopup.ListDataHandler - javax.swing.plaf.basic 中的 类
从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
BasicComboPopup.ListDataHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 的构造方法
BasicComboPopup.ListMouseHandler - javax.swing.plaf.basic 中的 类
在列表中释放鼠标时，此侦听器隐藏弹出部分。
BasicComboPopup.ListMouseHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 的构造方法
BasicComboPopup.ListMouseMotionHandler - javax.swing.plaf.basic 中的 类
在列表上移动鼠标时，此侦听器更改所选项。
BasicComboPopup.ListMouseMotionHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler 的构造方法
BasicComboPopup.ListSelectionHandler - javax.swing.plaf.basic 中的 类
从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
BasicComboPopup.ListSelectionHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler 的构造方法
BasicComboPopup.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。
BasicComboPopup.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler 的构造方法
BasicControl - javax.naming.ldap 中的 类
此类提供 Control 接口的基本实现。
BasicControl(String) - 类 javax.naming.ldap.BasicControl 的构造方法
构造一个非关键控件。
BasicControl(String, boolean, byte[]) - 类 javax.naming.ldap.BasicControl 的构造方法
使用提供的参数构造控件。
BasicDesktopIconUI - javax.swing.plaf.basic 中的 类
用于桌面最小化窗口的 L&F。
BasicDesktopIconUI() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 的构造方法
BasicDesktopIconUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
侦听鼠标移动及对其操作。
BasicDesktopIconUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 的构造方法
BasicDesktopPaneUI - javax.swing.plaf.basic 中的 类
桌面的基本 L&F。
BasicDesktopPaneUI() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 的构造方法
BasicDesktopPaneUI.CloseAction - javax.swing.plaf.basic 中的 类
处理关闭一个内部窗体。
BasicDesktopPaneUI.CloseAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 的构造方法
BasicDesktopPaneUI.MaximizeAction - javax.swing.plaf.basic 中的 类
处理最大化一个内部窗体。
BasicDesktopPaneUI.MaximizeAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 的构造方法
BasicDesktopPaneUI.MinimizeAction - javax.swing.plaf.basic 中的 类
处理最小化一个内部窗体。
BasicDesktopPaneUI.MinimizeAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 的构造方法
BasicDesktopPaneUI.NavigateAction - javax.swing.plaf.basic 中的 类
处理导航到下一个内部窗体。
BasicDesktopPaneUI.NavigateAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 的构造方法
BasicDesktopPaneUI.OpenAction - javax.swing.plaf.basic 中的 类
处理恢复一个最小化或最大化的内部窗体。
BasicDesktopPaneUI.OpenAction() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 的构造方法
BasicDirectoryModel - javax.swing.plaf.basic 中的 类
文件列表的基本实现。
BasicDirectoryModel(JFileChooser) - 类 javax.swing.plaf.basic.BasicDirectoryModel 的构造方法
BasicEditorPaneUI - javax.swing.plaf.basic 中的 类
为 JEditorPane 提供外观。
BasicEditorPaneUI() - 类 javax.swing.plaf.basic.BasicEditorPaneUI 的构造方法
创建新的 BasicEditorPaneUI。
BasicFileChooserUI - javax.swing.plaf.basic 中的 类
FileChooser 的基本 L&F 实现。
BasicFileChooserUI(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 的构造方法
BasicFileChooserUI.AcceptAllFileFilter - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.AcceptAllFileFilter() - 类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 的构造方法
BasicFileChooserUI.ApproveSelectionAction - javax.swing.plaf.basic 中的 类
响应 Open 或 Save 请求
BasicFileChooserUI.ApproveSelectionAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction 的构造方法
BasicFileChooserUI.BasicFileView - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.BasicFileView() - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 的构造方法
BasicFileChooserUI.CancelSelectionAction - javax.swing.plaf.basic 中的 类
响应取消请求。
BasicFileChooserUI.CancelSelectionAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction 的构造方法
BasicFileChooserUI.ChangeToParentDirectoryAction - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.ChangeToParentDirectoryAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction 的构造方法
BasicFileChooserUI.DoubleClickListener - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.DoubleClickListener(JList) - 类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 的构造方法
BasicFileChooserUI.GoHomeAction - javax.swing.plaf.basic 中的 类
基于“Home”键事件或等效事件的动作。
BasicFileChooserUI.GoHomeAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction 的构造方法
BasicFileChooserUI.NewFolderAction - javax.swing.plaf.basic 中的 类
创建新文件夹。
BasicFileChooserUI.NewFolderAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction 的构造方法
BasicFileChooserUI.SelectionListener - javax.swing.plaf.basic 中的 类
BasicFileChooserUI.SelectionListener() - 类 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener 的构造方法
BasicFileChooserUI.UpdateAction - javax.swing.plaf.basic 中的 类
重新扫描当前目录中的文件。
BasicFileChooserUI.UpdateAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction 的构造方法
BasicFormattedTextFieldUI - javax.swing.plaf.basic 中的 类
提供 JFormattedTextField 的外观实现。
BasicFormattedTextFieldUI() - 类 javax.swing.plaf.basic.BasicFormattedTextFieldUI 的构造方法
BasicGraphicsUtils - javax.swing.plaf.basic 中的 类
BasicGraphicsUtils() - 类 javax.swing.plaf.basic.BasicGraphicsUtils 的构造方法
BasicHTML - javax.swing.plaf.basic 中的 类
支持为 swing 组件提供 html 视图。
BasicHTML() - 类 javax.swing.plaf.basic.BasicHTML 的构造方法
BasicIconFactory - javax.swing.plaf.basic 中的 类
提供适于基本 L & F 使用的 Icon 的工厂对象。
BasicIconFactory() - 类 javax.swing.plaf.basic.BasicIconFactory 的构造方法
BasicInternalFrameTitlePane - javax.swing.plaf.basic 中的 类
管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
BasicInternalFrameTitlePane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 的构造方法
BasicInternalFrameTitlePane.CloseAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.CloseAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction 的构造方法
BasicInternalFrameTitlePane.IconifyAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.IconifyAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction 的构造方法
BasicInternalFrameTitlePane.MaximizeAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.MaximizeAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction 的构造方法
BasicInternalFrameTitlePane.MoveAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.MoveAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction 的构造方法
BasicInternalFrameTitlePane.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler 的构造方法
BasicInternalFrameTitlePane.RestoreAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.RestoreAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction 的构造方法
BasicInternalFrameTitlePane.SizeAction - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.SizeAction() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction 的构造方法
BasicInternalFrameTitlePane.SystemMenuBar - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.SystemMenuBar() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 的构造方法
BasicInternalFrameTitlePane.TitlePaneLayout - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicInternalFrameTitlePane.TitlePaneLayout() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 的构造方法
BasicInternalFrameUI - javax.swing.plaf.basic 中的 类
JInternalFrame 的基本 L&F 实现。
BasicInternalFrameUI(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 的构造方法
BasicInternalFrameUI.BasicInternalFrameListener - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.BasicInternalFrameListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 的构造方法
BasicInternalFrameUI.BorderListener - javax.swing.plaf.basic 中的 类
侦听边框调整。
BasicInternalFrameUI.BorderListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 的构造方法
BasicInternalFrameUI.ComponentHandler - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.ComponentHandler() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 的构造方法
BasicInternalFrameUI.GlassPaneDispatcher - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.GlassPaneDispatcher() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 的构造方法
BasicInternalFrameUI.InternalFrameLayout - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.InternalFrameLayout() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 的构造方法
BasicInternalFrameUI.InternalFramePropertyChangeListener - javax.swing.plaf.basic 中的 类
BasicInternalFrameUI.InternalFramePropertyChangeListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener 的构造方法
BasicLabelUI - javax.swing.plaf.basic 中的 类
LabelUI 的 Windows L&F 实现。
BasicLabelUI() - 类 javax.swing.plaf.basic.BasicLabelUI 的构造方法
BasicListUI - javax.swing.plaf.basic 中的 类
ListUI 的可扩展实现。
BasicListUI() - 类 javax.swing.plaf.basic.BasicListUI 的构造方法
BasicListUI.FocusHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicListUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicListUI.FocusHandler 的构造方法
BasicListUI.ListDataHandler - javax.swing.plaf.basic 中的 类
在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。
BasicListUI.ListDataHandler() - 类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 的构造方法
BasicListUI.ListSelectionHandler - javax.swing.plaf.basic 中的 类
在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。
BasicListUI.ListSelectionHandler() - 类 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler 的构造方法
BasicListUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
鼠标输入和 JList 的焦点处理。
BasicListUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 的构造方法
BasicListUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
在 installUI 时添加到 JList 的 PropertyChangeListener。
BasicListUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler 的构造方法
BasicLookAndFeel - javax.swing.plaf.basic 中的 类
为 Swing 创建外观时要使用的基类。
BasicLookAndFeel() - 类 javax.swing.plaf.basic.BasicLookAndFeel 的构造方法
BasicMenuBarUI - javax.swing.plaf.basic 中的 类
MenuBarUI 的默认 L&F 实现。
BasicMenuBarUI() - 类 javax.swing.plaf.basic.BasicMenuBarUI 的构造方法
BasicMenuItemUI - javax.swing.plaf.basic 中的 类
BasicMenuItem 实现
BasicMenuItemUI() - 类 javax.swing.plaf.basic.BasicMenuItemUI 的构造方法
BasicMenuItemUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
BasicMenuItemUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 的构造方法
BasicMenuUI - javax.swing.plaf.basic 中的 类
MenuUI 的默认 L&F 实现。
BasicMenuUI() - 类 javax.swing.plaf.basic.BasicMenuUI 的构造方法
BasicMenuUI.ChangeHandler - javax.swing.plaf.basic 中的 类
从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。
BasicMenuUI.ChangeHandler(JMenu, BasicMenuUI) - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 的构造方法
BasicMenuUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
BasicMenuUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 的构造方法
BasicOptionPaneUI - javax.swing.plaf.basic 中的 类
为 JOptionPane 提供基本外观。
BasicOptionPaneUI() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 的构造方法
BasicOptionPaneUI.ButtonActionListener - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicOptionPaneUI.ButtonActionListener(int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 的构造方法
BasicOptionPaneUI.ButtonAreaLayout - javax.swing.plaf.basic 中的 类
ButtonAreaLayout 的行为方式类似于 FlowLayout。
BasicOptionPaneUI.ButtonAreaLayout(boolean, int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 的构造方法
BasicOptionPaneUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicOptionPaneUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler 的构造方法
BasicPanelUI - javax.swing.plaf.basic 中的 类
BasicPanel 实现
BasicPanelUI() - 类 javax.swing.plaf.basic.BasicPanelUI 的构造方法
BasicPasswordFieldUI - javax.swing.plaf.basic 中的 类
为密码字段提供 Windows 外观。
BasicPasswordFieldUI() - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 的构造方法
BasicPermission - java.security 中的 类
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
BasicPermission(String) - 类 java.security.BasicPermission 的构造方法
创建具有指定名称的新 BasicPermission。
BasicPermission(String, String) - 类 java.security.BasicPermission 的构造方法
创建具有指定名称的新 BasicPermission 对象。
BasicPopupMenuSeparatorUI - javax.swing.plaf.basic 中的 类
PopupMenuSeparatorUI 的基本 L&F 实现。
BasicPopupMenuSeparatorUI() - 类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 的构造方法
BasicPopupMenuUI - javax.swing.plaf.basic 中的 类
PopupMenuUI 的 Windows L&F 实现。
BasicPopupMenuUI() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 的构造方法
BasicProgressBarUI - javax.swing.plaf.basic 中的 类
ProgressBarUI 的基本 L&F 实现。
BasicProgressBarUI() - 类 javax.swing.plaf.basic.BasicProgressBarUI 的构造方法
BasicProgressBarUI.ChangeHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicProgressBarUI.ChangeHandler() - 类 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler 的构造方法
BasicRadioButtonMenuItemUI - javax.swing.plaf.basic 中的 类
BasicRadioButtonMenuItem 实现
BasicRadioButtonMenuItemUI() - 类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 的构造方法
BasicRadioButtonUI - javax.swing.plaf.basic 中的 类
BasicRadioButtonUI 的 RadioButtonUI 实现
BasicRadioButtonUI() - 类 javax.swing.plaf.basic.BasicRadioButtonUI 的构造方法
BasicRootPaneUI - javax.swing.plaf.basic 中的 类
RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
BasicRootPaneUI() - 类 javax.swing.plaf.basic.BasicRootPaneUI 的构造方法
BasicScrollBarUI - javax.swing.plaf.basic 中的 类
基本外观的 ScrollBarUI 的实现
BasicScrollBarUI() - 类 javax.swing.plaf.basic.BasicScrollBarUI 的构造方法
BasicScrollBarUI.ArrowButtonListener - javax.swing.plaf.basic 中的 类
光标键的侦听器。
BasicScrollBarUI.ArrowButtonListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener 的构造方法
BasicScrollBarUI.ModelListener - javax.swing.plaf.basic 中的 类
侦听模型更改的侦听器。
BasicScrollBarUI.ModelListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI.ModelListener 的构造方法
BasicScrollBarUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
BasicScrollBarUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler 的构造方法
BasicScrollBarUI.ScrollListener - javax.swing.plaf.basic 中的 类
在 ScrollPane 中发起的滚动事件的侦听器。
BasicScrollBarUI.ScrollListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 的构造方法
BasicScrollBarUI.ScrollListener(int, boolean) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 的构造方法
BasicScrollBarUI.TrackListener - javax.swing.plaf.basic 中的 类
跟踪鼠标拖动。
BasicScrollBarUI.TrackListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 的构造方法
BasicScrollPaneUI - javax.swing.plaf.basic 中的 类
ScrollPaneUI 的默认 L&F 实现。
BasicScrollPaneUI() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 的构造方法
BasicScrollPaneUI.HSBChangeListener - javax.swing.plaf.basic 中的 类
水平滚动条侦听器。
BasicScrollPaneUI.HSBChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener 的构造方法
BasicScrollPaneUI.MouseWheelHandler - javax.swing.plaf.basic 中的 类
MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。
BasicScrollPaneUI.MouseWheelHandler() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler 的构造方法
BasicScrollPaneUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
BasicScrollPaneUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler 的构造方法
BasicScrollPaneUI.ViewportChangeHandler - javax.swing.plaf.basic 中的 类
视口事件的侦听器。
BasicScrollPaneUI.ViewportChangeHandler() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler 的构造方法
BasicScrollPaneUI.VSBChangeListener - javax.swing.plaf.basic 中的 类
垂直滚动条侦听器。
BasicScrollPaneUI.VSBChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener 的构造方法
BasicSeparatorUI - javax.swing.plaf.basic 中的 类
SeparatorUI 的基本 L&F 实现。
BasicSeparatorUI() - 类 javax.swing.plaf.basic.BasicSeparatorUI 的构造方法
BasicSliderUI - javax.swing.plaf.basic 中的 类
SliderUI 的基本 L&F 实现。
BasicSliderUI(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 的构造方法
BasicSliderUI.ActionScroller - javax.swing.plaf.basic 中的 类
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
BasicSliderUI.ActionScroller(JSlider, int, boolean) - 类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 的构造方法
BasicSliderUI.ChangeHandler - javax.swing.plaf.basic 中的 类
数据模型侦听器。
BasicSliderUI.ChangeHandler() - 类 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler 的构造方法
BasicSliderUI.ComponentHandler - javax.swing.plaf.basic 中的 类
调整事件大小的侦听器。
BasicSliderUI.ComponentHandler() - 类 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler 的构造方法
BasicSliderUI.FocusHandler - javax.swing.plaf.basic 中的 类
焦点更改侦听器。
BasicSliderUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 的构造方法
BasicSliderUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
BasicSliderUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler 的构造方法
BasicSliderUI.ScrollListener - javax.swing.plaf.basic 中的 类
滚动事件侦听器。
BasicSliderUI.ScrollListener() - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 的构造方法
BasicSliderUI.ScrollListener(int, boolean) - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 的构造方法
BasicSliderUI.TrackListener - javax.swing.plaf.basic 中的 类
跟踪鼠标移动。
BasicSliderUI.TrackListener() - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 的构造方法
BasicSpinnerUI - javax.swing.plaf.basic 中的 类
默认 Spinner UI 委托。
BasicSpinnerUI() - 类 javax.swing.plaf.basic.BasicSpinnerUI 的构造方法
BasicSplitPaneDivider - javax.swing.plaf.basic 中的 类
BasicSplitPaneUI 使用的分隔符。
BasicSplitPaneDivider(BasicSplitPaneUI) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 的构造方法
创建 BasicSplitPaneDivider 的实例。
BasicSplitPaneDivider.DividerLayout - javax.swing.plaf.basic 中的 类
用于布置 BasicSplitPaneDivider。
BasicSplitPaneDivider.DividerLayout() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 的构造方法
BasicSplitPaneDivider.DragController - javax.swing.plaf.basic 中的 类
在面向 HORIZONTAL_SPLIT 的拆分窗格的拖动会话期间处理事件。
BasicSplitPaneDivider.DragController(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 的构造方法
BasicSplitPaneDivider.MouseHandler - javax.swing.plaf.basic 中的 类
MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
BasicSplitPaneDivider.MouseHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 的构造方法
BasicSplitPaneDivider.VerticalDragController - javax.swing.plaf.basic 中的 类
在面向 VERTICAL_SPLIT 的拆分窗格的拖动会话期间处理事件。
BasicSplitPaneDivider.VerticalDragController(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 的构造方法
BasicSplitPaneUI - javax.swing.plaf.basic 中的 类
SplitPaneUI 的基本 L&F 实现。
BasicSplitPaneUI() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 的构造方法
BasicSplitPaneUI.BasicHorizontalLayoutManager - javax.swing.plaf.basic 中的 类
具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。
BasicSplitPaneUI.BasicVerticalLayoutManager - javax.swing.plaf.basic 中的 类
用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。
BasicSplitPaneUI.BasicVerticalLayoutManager() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager 的构造方法
BasicSplitPaneUI.FocusHandler - javax.swing.plaf.basic 中的 类
JSplitPane UI 使用的 FocusListener 的实现。
BasicSplitPaneUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 的构造方法
BasicSplitPaneUI.KeyboardDownRightHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardDownRightHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler 的构造方法
BasicSplitPaneUI.KeyboardEndHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardEndHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler 的构造方法
BasicSplitPaneUI.KeyboardHomeHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardHomeHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler 的构造方法
BasicSplitPaneUI.KeyboardResizeToggleHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardResizeToggleHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler 的构造方法
BasicSplitPaneUI.KeyboardUpLeftHandler - javax.swing.plaf.basic 中的 类
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
BasicSplitPaneUI.KeyboardUpLeftHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler 的构造方法
BasicSplitPaneUI.PropertyHandler - javax.swing.plaf.basic 中的 类
JSplitPane UI 使用的 PropertyChangeListener 的实现。
BasicSplitPaneUI.PropertyHandler() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler 的构造方法
BasicStroke - java.awt 中的 类
BasicStroke 类定义针对图形图元轮廓呈现属性的一个基本集合，这些图元使用 Graphics2D 对象呈现，而该对象的 Stroke 属性设置为此 BasicStroke。
BasicStroke(float, int, int, float, float[], float) - 类 java.awt.BasicStroke 的构造方法
构造一个具有指定属性的新 BasicStroke。
BasicStroke(float, int, int, float) - 类 java.awt.BasicStroke 的构造方法
构造一个具有指定属性的实心的 BasicStroke。
BasicStroke(float, int, int) - 类 java.awt.BasicStroke 的构造方法
构造一个具有指定属性的实心的 BasicStroke。
BasicStroke(float) - 类 java.awt.BasicStroke 的构造方法
构造一个具有指定线条宽度以及 cap 和 join 风格的默认值的实心 BasicStroke。
BasicStroke() - 类 java.awt.BasicStroke 的构造方法
构造一个具有所有属性的默认值的新 BasicStroke。
BasicTabbedPaneUI - javax.swing.plaf.basic 中的 类
TabbedPaneUI 的基本 L&F 实现。
BasicTabbedPaneUI() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 的构造方法
BasicTabbedPaneUI.FocusHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 的构造方法
BasicTabbedPaneUI.MouseHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.MouseHandler() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler 的构造方法
BasicTabbedPaneUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler 的构造方法
BasicTabbedPaneUI.TabbedPaneLayout - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.TabbedPaneLayout() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 的构造方法
BasicTabbedPaneUI.TabSelectionHandler - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicTabbedPaneUI.TabSelectionHandler() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler 的构造方法
BasicTableHeaderUI - javax.swing.plaf.basic 中的 类
BasicTableHeaderUI 实现
BasicTableHeaderUI() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 的构造方法
BasicTableHeaderUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicTableHeaderUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 的构造方法
BasicTableUI - javax.swing.plaf.basic 中的 类
BasicTableUI 实现
BasicTableUI() - 类 javax.swing.plaf.basic.BasicTableUI 的构造方法
BasicTableUI.FocusHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicTableUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicTableUI.FocusHandler 的构造方法
BasicTableUI.KeyHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicTableUI.KeyHandler() - 类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 的构造方法
BasicTableUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
此内部类因编译器故障而被标记为“公开”。
BasicTableUI.MouseInputHandler() - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 的构造方法
BasicTextAreaUI - javax.swing.plaf.basic 中的 类
为纯文本编辑器提供外观。
BasicTextAreaUI() - 类 javax.swing.plaf.basic.BasicTextAreaUI 的构造方法
构造新的 BasicTextAreaUI 对象。
BasicTextFieldUI - javax.swing.plaf.basic 中的 类
JTextField 的外观的基础。
BasicTextFieldUI() - 类 javax.swing.plaf.basic.BasicTextFieldUI 的构造方法
创建新的 BasicTextFieldUI。
BasicTextPaneUI - javax.swing.plaf.basic 中的 类
为样式化文本编辑器提供外观。
BasicTextPaneUI() - 类 javax.swing.plaf.basic.BasicTextPaneUI 的构造方法
创建新的 BasicTextPaneUI。
BasicTextUI - javax.swing.plaf.basic 中的 类
此类是文本组件外观的基础。
BasicTextUI() - 类 javax.swing.plaf.basic.BasicTextUI 的构造方法
创建新的 UI。
BasicTextUI.BasicCaret - javax.swing.plaf.basic 中的 类
BasicTextUI.BasicCaret() - 类 javax.swing.plaf.basic.BasicTextUI.BasicCaret 的构造方法
BasicTextUI.BasicHighlighter - javax.swing.plaf.basic 中的 类
BasicTextUI.BasicHighlighter() - 类 javax.swing.plaf.basic.BasicTextUI.BasicHighlighter 的构造方法
BasicToggleButtonUI - javax.swing.plaf.basic 中的 类
BasicToggleButton 实现
BasicToggleButtonUI() - 类 javax.swing.plaf.basic.BasicToggleButtonUI 的构造方法
BasicToolBarSeparatorUI - javax.swing.plaf.basic 中的 类
ToolBarSeparatorUI 的基本 L&F 实现。
BasicToolBarSeparatorUI() - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 的构造方法
BasicToolBarUI - javax.swing.plaf.basic 中的 类
ToolBarUI 的基本 L&F 实现。
BasicToolBarUI() - 类 javax.swing.plaf.basic.BasicToolBarUI 的构造方法
BasicToolBarUI.DockingListener - javax.swing.plaf.basic 中的 类
此类应视为“受保护”内部类。
BasicToolBarUI.DockingListener(JToolBar) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 的构造方法
BasicToolBarUI.DragWindow - javax.swing.plaf.basic 中的 类
BasicToolBarUI.FrameListener - javax.swing.plaf.basic 中的 类
BasicToolBarUI.FrameListener() - 类 javax.swing.plaf.basic.BasicToolBarUI.FrameListener 的构造方法
BasicToolBarUI.PropertyListener - javax.swing.plaf.basic 中的 类
BasicToolBarUI.PropertyListener() - 类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener 的构造方法
BasicToolBarUI.ToolBarContListener - javax.swing.plaf.basic 中的 类
BasicToolBarUI.ToolBarContListener() - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 的构造方法
BasicToolBarUI.ToolBarFocusListener - javax.swing.plaf.basic 中的 类
BasicToolBarUI.ToolBarFocusListener() - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 的构造方法
BasicToolTipUI - javax.swing.plaf.basic 中的 类
标准工具提示 L&F。
BasicToolTipUI() - 类 javax.swing.plaf.basic.BasicToolTipUI 的构造方法
BasicTreeUI - javax.swing.plaf.basic 中的 类
层次数据结构的基本 L&F。
BasicTreeUI() - 类 javax.swing.plaf.basic.BasicTreeUI 的构造方法
BasicTreeUI.CellEditorHandler - javax.swing.plaf.basic 中的 类
侦听器负责获取单元格编辑事件并相应地更新树。
BasicTreeUI.CellEditorHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 的构造方法
BasicTreeUI.ComponentHandler - javax.swing.plaf.basic 中的 类
滚动时更新首选大小（如果需要）。
BasicTreeUI.ComponentHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 的构造方法
BasicTreeUI.FocusHandler - javax.swing.plaf.basic 中的 类
失去/获得焦点时重绘前导选择行。
BasicTreeUI.FocusHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 的构造方法
BasicTreeUI.KeyHandler - javax.swing.plaf.basic 中的 类
用于获取多个按键事件以适当生成事件。
BasicTreeUI.KeyHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 的构造方法
BasicTreeUI.MouseHandler - javax.swing.plaf.basic 中的 类
TreeMouseListener 负责基于鼠标事件更新选择。
BasicTreeUI.MouseHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 的构造方法
BasicTreeUI.MouseInputHandler - javax.swing.plaf.basic 中的 类
在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。
BasicTreeUI.MouseInputHandler(Component, Component, MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 的构造方法
BasicTreeUI.NodeDimensionsHandler - javax.swing.plaf.basic 中的 类
负责获取节点大小的类，其方法被转发到 BasicTreeUI 方法。
BasicTreeUI.NodeDimensionsHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 的构造方法
BasicTreeUI.PropertyChangeHandler - javax.swing.plaf.basic 中的 类
树的 PropertyChangeListener。
BasicTreeUI.PropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler 的构造方法
BasicTreeUI.SelectionModelPropertyChangeHandler - javax.swing.plaf.basic 中的 类
TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。
BasicTreeUI.SelectionModelPropertyChangeHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler 的构造方法
BasicTreeUI.TreeCancelEditingAction - javax.swing.plaf.basic 中的 类
执行操作时调用 cancelEditing 的 ActionListener。
BasicTreeUI.TreeCancelEditingAction(String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 的构造方法
BasicTreeUI.TreeExpansionHandler - javax.swing.plaf.basic 中的 类
更新 TreeState 以响应节点的展开/折叠。
BasicTreeUI.TreeExpansionHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 的构造方法
BasicTreeUI.TreeHomeAction - javax.swing.plaf.basic 中的 类
TreeHomeAction 用于处理 end/home 动作。
BasicTreeUI.TreeHomeAction(int, String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 的构造方法
BasicTreeUI.TreeIncrementAction - javax.swing.plaf.basic 中的 类
TreeIncrementAction 用于处理向上/向下操作。
BasicTreeUI.TreeIncrementAction(int, String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 的构造方法
BasicTreeUI.TreeModelHandler - javax.swing.plaf.basic 中的 类
将所有 TreeModel 事件转发到 TreeState。
BasicTreeUI.TreeModelHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 的构造方法
BasicTreeUI.TreePageAction - javax.swing.plaf.basic 中的 类
TreePageAction 处理向上翻页和向下翻页事件。
BasicTreeUI.TreePageAction(int, String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 的构造方法
BasicTreeUI.TreeSelectionHandler - javax.swing.plaf.basic 中的 类
侦听选择模型中的更改并相应地更新显示。
BasicTreeUI.TreeSelectionHandler() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler 的构造方法
BasicTreeUI.TreeToggleAction - javax.swing.plaf.basic 中的 类
对于第一个选定行展开将被切换。
BasicTreeUI.TreeToggleAction(String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 的构造方法
BasicTreeUI.TreeTraverseAction - javax.swing.plaf.basic 中的 类
TreeTraverseAction 是用于向左/向右方向键的动作。
BasicTreeUI.TreeTraverseAction(int, String) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 的构造方法
BasicViewportUI - javax.swing.plaf.basic 中的 类
BasicViewport 实现
BasicViewportUI() - 类 javax.swing.plaf.basic.BasicViewportUI 的构造方法
BATCHSIZE - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定通过服务协议返回数据时要使用的批处理量 (batch size) 的环境属性名称。
BatchUpdateException - java.sql 中的 异常
进行批量更新操作期间发生错误时抛出的 SQLException 子类。
BatchUpdateException(String, String, int, int[]) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、SQLState、vendorCode 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String, String, int[]) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、SQLState 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String, int[]) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(int[]) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException() - 异常 java.sql.BatchUpdateException 的构造方法
构造一个 BatchUpdateException 对象。
BatchUpdateException(Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 cause 初始化的 BatchUpdateException 对象。
BatchUpdateException(int[], Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String, int[], Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、cause 和 updateCounts 构造的 BatchUpdateException 对象。
BatchUpdateException(String, String, int[], Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、SQLState、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String, String, int, int[], Throwable) - 异常 java.sql.BatchUpdateException 的构造方法
构造一个使用给定 reason、SQLState、vendorCode、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BC - 类 java.util.GregorianCalendar 中的静态变量
ERA 字段的值指示公元前（Christ 前）的时期（也称为 BCE）。
bcmListeners - 类 java.beans.beancontext.BeanContextSupport 中的变量
protected ArrayList bcmListeners 字段的所有访问在该对象上都将是同步的。
bcsChildren() - 类 java.beans.beancontext.BeanContextSupport 中的方法
返回此 BeanContext 所有子级的迭代器。
bcsListeners - 类 java.beans.beancontext.BeanContextServicesSupport 中的变量
BeanContextServicesListener 对象的列表。
bcsPreDeserializationHook(ObjectInputStream) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
bcsPreDeserializationHook(ObjectInputStream) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
bcsPreSerializationHook(ObjectOutputStream) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
在序列化子级之前，从 BeanContextSupport writeObject 中调用。
bcsPreSerializationHook(ObjectOutputStream) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在调用 defaultWriteObject() 之后，但在序列化当前可序列化子级之前，由 writeObject 调用。
BeanContext - java.beans.beancontext 中的 接口
BeanContext 是 JavaBean 的逻辑层次容器。
beanContext - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
BeanContextChild - java.beans.beancontext 中的 接口
正如 BeanContext 子接口所定义的，希望在其中进行嵌套并获得对其执行环境（或文本）的引用的 JavaBeans 应该实现此接口。
BeanContextChildComponentProxy - java.beans.beancontext 中的 接口
此接口由具有与之相关的 AWT Component 的 BeanContextChildren 实现。
beanContextChildPeer - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
在其中嵌套此 BeanContextChild 的 BeanContext。
BeanContextChildSupport - java.beans.beancontext 中的 类
这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
BeanContextChildSupport() - 类 java.beans.beancontext.BeanContextChildSupport 的构造方法
构造一个 BeanContextChildSupport，其中已经为此类创建了子类以便实现 JavaBean 组件自身。
BeanContextChildSupport(BeanContextChild) - 类 java.beans.beancontext.BeanContextChildSupport 的构造方法
构造一个 BeanContextChildSupport，其中 JavaBean 组件自身实现 BeanContextChild 并封装它，并将该接口委托给此实现
BeanContextContainerProxy - java.beans.beancontext 中的 接口
此接口由具有与之关联的 AWT Container 的 BeanContext 实现。
BeanContextEvent - java.beans.beancontext 中的 类
BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。
BeanContextEvent(BeanContext) - 类 java.beans.beancontext.BeanContextEvent 的构造方法
构造一个 BeanContextEvent
BeanContextMembershipEvent - java.beans.beancontext 中的 类
BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
BeanContextMembershipEvent(BeanContext, Collection) - 类 java.beans.beancontext.BeanContextMembershipEvent 的构造方法
构造一个 BeanContextMembershipEvent
BeanContextMembershipEvent(BeanContext, Object[]) - 类 java.beans.beancontext.BeanContextMembershipEvent 的构造方法
构造一个 BeanContextMembershipEvent
BeanContextMembershipListener - java.beans.beancontext 中的 接口
当 BeanContext 的成员关系状态发生更改时，兼容的 BeanContext 在此接口上触发事件。
BeanContextProxy - java.beans.beancontext 中的 接口
此接口由并不直接拥有（通过实现该接口或一个子接口拥有）与之关联的 BeanContext(Child)，但是拥有它代理的一个公共 BeanContext(Child) 的 JavaBean 实现。
BeanContextServiceAvailableEvent - java.beans.beancontext 中的 类
BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
BeanContextServiceAvailableEvent(BeanContextServices, Class) - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 的构造方法
构造一个 BeanContextAvailableServiceEvent。
BeanContextServiceProvider - java.beans.beancontext 中的 接口
BeanContext 的主要功能之一是充当 JavaBeans 与 BeanContextServiceProviders 之间的集合点。
BeanContextServiceProviderBeanInfo - java.beans.beancontext 中的 接口
希望提供关于其 bean 可能提供服务的显式消息的 BeanContextServiceProvider 实现者应实现某个 BeanInfo 类，该类实现此 BeanInfo 的子接口并提供有关其服务的方法、属性、事件等显式信息。
BeanContextServiceRevokedEvent - java.beans.beancontext 中的 类
BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。
BeanContextServiceRevokedEvent(BeanContextServices, Class, boolean) - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 的构造方法
构造一个 BeanContextServiceEvent。
BeanContextServiceRevokedListener - java.beans.beancontext 中的 接口
用于接收 BeanContextServiceRevokedEvent 对象的侦听器接口。
BeanContextServices - java.beans.beancontext 中的 接口
BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。
BeanContextServicesListener - java.beans.beancontext 中的 接口
用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。
BeanContextServicesSupport - java.beans.beancontext 中的 类
此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
BeanContextServicesSupport(BeanContextServices, Locale, boolean, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
构造一个 BeanContextServicesSupport 实例
BeanContextServicesSupport(BeanContextServices, Locale, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
使用指定 Locale 和设计模式创建一个实例。
BeanContextServicesSupport(BeanContextServices, Locale) - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
使用指定语言环境创建一个实例。
BeanContextServicesSupport(BeanContextServices) - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
创建一个具有同位体的实例
BeanContextServicesSupport() - 类 java.beans.beancontext.BeanContextServicesSupport 的构造方法
创建不是另一个对象代理的实例。
BeanContextServicesSupport.BCSSChild - java.beans.beancontext 中的 类
BeanContextServicesSupport.BCSSProxyServiceProvider - java.beans.beancontext 中的 类
BeanContextServicesSupport.BCSSServiceProvider - java.beans.beancontext 中的 类
子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。
BeanContextSupport - java.beans.beancontext 中的 类
此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。
BeanContextSupport(BeanContext, Locale, boolean, boolean) - 类 java.beans.beancontext.BeanContextSupport 的构造方法
构造一个 BeanContextSupport 实例。
BeanContextSupport(BeanContext, Locale, boolean) - 类 java.beans.beancontext.BeanContextSupport 的构造方法
使用指定 Locale 和设计模式创建一个实例。
BeanContextSupport(BeanContext, Locale) - 类 java.beans.beancontext.BeanContextSupport 的构造方法
使用指定语言环境创建一个实例。
BeanContextSupport(BeanContext) - 类 java.beans.beancontext.BeanContextSupport 的构造方法
使用默认语言环境创建一个实例
BeanContextSupport() - 类 java.beans.beancontext.BeanContextSupport 的构造方法
创建不是另一个对象代理的实例。
BeanContextSupport.BCSChild - java.beans.beancontext 中的 类
BeanContextSupport.BCSIterator - java.beans.beancontext 中的 类
受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。
BeanDescriptor - java.beans 中的 类
BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。
BeanDescriptor(Class<?>) - 类 java.beans.BeanDescriptor 的构造方法
为没有 customizer 的 bean 创建一个 BeanDescriptor。
BeanDescriptor(Class<?>, Class<?>) - 类 java.beans.BeanDescriptor 的构造方法
为有 customizer 的 bean 创建一个 BeanDescriptor。
BeanInfo - java.beans 中的 接口
希望提供有关其 bean 的显式信息的 bean 实现者可以提供某个 BeanInfo 类，该类实现此 BeanInfo 接口并提供有关其 bean 的方法、属性、事件等显式信息。
Beans - java.beans 中的 类
此类提供一些通用的 bean 控制方法。
Beans() - 类 java.beans.Beans 的构造方法
beep() - 类 java.awt.Toolkit 中的方法
发出一个音频嘟嘟声。
beepAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于创建蜂鸣声的动作名称。
before(Timestamp) - 类 java.sql.Timestamp 中的方法
指示此 Timestamp 对象是否早于给定的 Timestamp 对象。
before(Object) - 类 java.util.Calendar 中的方法
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之前，返回判断结果。
before(Date) - 类 java.util.Date 中的方法
测试此日期是否在指定日期之前。
BEFORE_FIRST_LINE - 类 java.awt.BorderLayout 中的静态变量
与 PAGE_START 同义。
BEFORE_LINE_BEGINS - 类 java.awt.BorderLayout 中的静态变量
与 LINE_START 同义。
beforeExecute(Thread, Runnable) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
在执行给定线程中的给定 Runnable 之前调用的方法。
beforeFirst() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的开头，正好位于第一行之前。
beforeMarshal(Object) - 类 javax.xml.bind.Marshaller.Listener 中的方法

从 source 编组到 XML 之前调用的回调方法。

beforeOffset(int) - 类 java.awt.font.TextHitInfo 中的静态方法
在指定偏移量处创建一个与偏移量之前的字符关联的 TextHitInfo。
beforeUnmarshal(Object, Object) - 类 javax.xml.bind.Unmarshaller.Listener 中的方法

在解组到 target 之前调用的回调方法。

begin() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
标记可能无限期阻塞的 I/O 操作的开始。
begin() - 类 java.nio.channels.spi.AbstractSelector 中的方法
标记可能无限期阻塞的 I/O 操作的开始。
beginAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到文档开头的 Action 名称。
beginDragDividerLocation - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
拖动会话开始时分隔符的位置。
beginDraggingFrame(JComponent) - 类 javax.swing.DefaultDesktopManager 中的方法
beginDraggingFrame(JComponent) - 接口 javax.swing.DesktopManager 中的方法
通常在用户已经指示他们将开始拖动某个组件时调用此方法。
beginHandshake() - 类 javax.net.ssl.SSLEngine 中的方法
在此 SSLEngine 上发起握手（初始的或重新协商）。
beginLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到行首的 Action 名称。
beginParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到段落开头的 Action 名称。
beginResizingFrame(JComponent, int) - 类 javax.swing.DefaultDesktopManager 中的方法
beginResizingFrame(JComponent, int) - 接口 javax.swing.DesktopManager 中的方法
通常在用户已经指示他们将开始重新调整窗体的大小时调用此方法。
beginUpdate() - 类 javax.swing.undo.UndoableEditSupport 中的方法
beginWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到字首的 Action 名称。
BELOW_BASELINE - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BELOW_BASELINE_LEADING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BELOW_BASELINE_TRAILING - 类 java.awt.GridBagConstraints 中的静态变量
anchor 字段的可能值。
BELOW_BOTTOM - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框底端线的底部。
BELOW_TOP - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框顶端线的底部。
BENGALI - 类 java.awt.font.NumericShaper 中的静态变量
标识 BENGALI 范围和十进制基数。
BENGALI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Bengali”Unicode 字符块的常量。
BEST_COMPRESSION - 类 java.util.zip.Deflater 中的静态变量
最佳压缩的压缩级别。
BEST_SPEED - 类 java.util.zip.Deflater 中的静态变量
最快压缩的压缩级别。
bestRowNotPseudo - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符“不”是伪列。
bestRowPseudo - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符是伪列。
bestRowSession - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符的作用域是当前会话的剩余部分。
bestRowTemporary - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符的作用域是临时的，仅在使用该行时可用。
bestRowTransaction - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符的作用域是当前事务的剩余部分。
bestRowUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示最佳行标识符可能是伪列 (pseudo column)，也可能不是。
between(ValueExp, ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示一个值在其他两个值之间的约束条件。
BevelBorder - javax.swing.border 中的 类
该类实现简单的双线斜面边框。
BevelBorder(int) - 类 javax.swing.border.BevelBorder 的构造方法
创建具有指定类型的斜面边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生。
BevelBorder(int, Color, Color) - 类 javax.swing.border.BevelBorder 的构造方法
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
BevelBorder(int, Color, Color, Color, Color) - 类 javax.swing.border.BevelBorder 的构造方法
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
bevelType - 类 javax.swing.border.BevelBorder 中的变量
BGCOLOR - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Bidi - java.text 中的 类
此类实现了 Unicode 双向算法 (Unicode Bidirectional Algorithm)。
Bidi(String, int) - 类 java.text.Bidi 的构造方法
由给定的文本段和基本方向构造 Bidi。
Bidi(AttributedCharacterIterator) - 类 java.text.Bidi 的构造方法
由给定的文本段构造 Bidi。
Bidi(char[], int, byte[], int, int, int) - 类 java.text.Bidi 的构造方法
由给定的文本、嵌入和方向信息构造 Bidi。
BIDI_EMBEDDING - 类 java.awt.font.TextAttribute 中的静态变量
文本嵌入级别的属性键。
BidiElementName - 类 javax.swing.text.AbstractDocument 中的静态变量
用于保存单向操作的元素名。
BidiLevel - 类 javax.swing.text.StyleConstants 中的静态变量
由 Unicode bidi 算法指派的字符双向级别。
BIG - 类 javax.swing.text.html.HTML.Tag 中的静态变量
BIG_ENDIAN - 类 java.nio.ByteOrder 中的静态变量
表示 big-endian 字节顺序的常量。
BigDecimal - java.math 中的 类
不可变的、任意精度的有符号十进制数。
BigDecimal(char[], int, int) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组。
BigDecimal(char[], int, int, MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组，并根据上下文设置进行舍入。
BigDecimal(char[]) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列。
BigDecimal(char[], MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列（根据上下文设置进行舍入）。
BigDecimal(String) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符串表示形式转换为 BigDecimal。
BigDecimal(String, MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigDecimal 的字符串表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符串（按照上下文设置进行舍入）。
BigDecimal(double) - 类 java.math.BigDecimal 的构造方法
将 double 转换为 BigDecimal，后者是 double 的二进制浮点值准确的十进制表示形式。
BigDecimal(double, MathContext) - 类 java.math.BigDecimal 的构造方法
将 double 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger) - 类 java.math.BigDecimal 的构造方法
将 BigInteger 转换为 BigDecimal。
BigDecimal(BigInteger, MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigInteger 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger, int) - 类 java.math.BigDecimal 的构造方法
将 BigInteger 非标度值和 int 标度转换为 BigDecimal。
BigDecimal(BigInteger, int, MathContext) - 类 java.math.BigDecimal 的构造方法
将 BigInteger 非标度值和 int 标度转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(int) - 类 java.math.BigDecimal 的构造方法
将 int 转换为 BigDecimal。
BigDecimal(int, MathContext) - 类 java.math.BigDecimal 的构造方法
将 int 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(long) - 类 java.math.BigDecimal 的构造方法
将 long 转换为 BigDecimal。
BigDecimal(long, MathContext) - 类 java.math.BigDecimal 的构造方法
将 long 转换为 BigDecimal（根据上下文设置进行舍入）。
BIGDECIMAL - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigDecimal 的值。
bigEndian - 类 javax.sound.sampled.AudioFormat 中的变量
指示是以 big-endian 顺序还是 little-endian 顺序存储音频数据。
BIGINT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BIGINT 的 Java 编程语言中的常量（有时称为类型代码）。
BigInteger - java.math 中的 类
不可变的任意精度的整数。
BigInteger(byte[]) - 类 java.math.BigInteger 的构造方法
将包含 BigInteger 的二进制补码表示形式的 byte 数组转换为 BigInteger。
BigInteger(int, byte[]) - 类 java.math.BigInteger 的构造方法
将 BigInteger 的符号-数量表示形式转换为 BigInteger。
BigInteger(String, int) - 类 java.math.BigInteger 的构造方法
将指定基数的 BigInteger 的字符串表示形式转换为 BigInteger。
BigInteger(String) - 类 java.math.BigInteger 的构造方法
将 BigInteger 的十进制字符串表示形式转换为 BigInteger。
BigInteger(int, Random) - 类 java.math.BigInteger 的构造方法
构造一个随机生成的 BigInteger，它是在 0 到 (2numBits - 1)（包括）范围内均匀分布的值。
BigInteger(int, int, Random) - 类 java.math.BigInteger 的构造方法
构造一个随机生成的正 BigInteger，它可能是一个具有指定 bitLength 的素数。
BIGINTEGER - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigInteger 的值。
BINARY - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BINARY 的 Java 编程语言中的常量（有时称为类型代码）。
BINARY_STREAM_PARAM - 类 javax.sql.rowset.BaseRowSet 中的静态变量
该常量向 RowSetReaderImpl 对象指示给定的参数是一个二进制流。
BinaryRefAddr - javax.naming 中的 类
此类表示通信终端地址的二进制形式。
BinaryRefAddr(String, byte[]) - 类 javax.naming.BinaryRefAddr 的构造方法
使用地址类型和用于内容的字节数组构造一个新的 BinaryRefAddr 实例。
BinaryRefAddr(String, byte[], int, int) - 类 javax.naming.BinaryRefAddr 的构造方法
使用地址类型和用于内容的字节数组区域构造一个新的 BinaryRefAddr 实例。
binarySearch(long[], long) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 long 型数组，以获得指定的值。
binarySearch(long[], int, int, long) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 long 型数组的范围，以获得指定的值。
binarySearch(int[], int) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 int 型数组，以获得指定的值。
binarySearch(int[], int, int, int) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 int 型数组的范围，以获得指定的值。
binarySearch(short[], short) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 short 型数组，以获得指定的值。
binarySearch(short[], int, int, short) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 short 型数组的范围，以获得指定的值。
binarySearch(char[], char) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 char 型数组，以获得指定的值。
binarySearch(char[], int, int, char) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 char 型数组的范围，以获得指定的值。
binarySearch(byte[], byte) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 byte 型数组，以获得指定的值。
binarySearch(byte[], int, int, byte) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 byte 型数组的范围，以获得指定的值。
binarySearch(double[], double) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 double 型数组，以获得指定的值。
binarySearch(double[], int, int, double) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 double 型数组的范围，以获得指定的值。
binarySearch(float[], float) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 float 型数组，以获得指定的值。
binarySearch(float[], int, int, float) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定的 float 型数组的范围，以获得指定的值。
binarySearch(Object[], Object) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定数组，以获得指定对象。
binarySearch(Object[], int, int, Object) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定数组的范围，以获得指定对象。
binarySearch(T[], T, Comparator<? super T>) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定数组，以获得指定对象。
binarySearch(T[], int, int, T, Comparator<? super T>) - 类 java.util.Arrays 中的静态方法
使用二分搜索法来搜索指定数组的范围，以获得指定对象。
binarySearch(List<? extends Comparable<? super T>>, T) - 类 java.util.Collections 中的静态方法
使用二分搜索法搜索指定列表，以获得指定对象。
binarySearch(List<? extends T>, T, Comparator<? super T>) - 类 java.util.Collections 中的静态方法
使用二分搜索法搜索指定列表，以获得指定对象。
binaryStream - 类 javax.sql.rowset.BaseRowSet 中的变量
将由方法 getBinaryStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
bind(SocketAddress) - 类 java.net.DatagramSocket 中的方法
将此 DatagramSocket 绑定到特定的地址和端口。
bind(int, InetAddress) - 类 java.net.DatagramSocketImpl 中的方法
将数据报套接字绑定到本地端口和地址。
bind(SocketAddress) - 类 java.net.ServerSocket 中的方法
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
bind(SocketAddress, int) - 类 java.net.ServerSocket 中的方法
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
bind(SocketAddress) - 类 java.net.Socket 中的方法
将套接字绑定到本地地址。
bind(InetAddress, int) - 类 java.net.SocketImpl 中的方法
将此套接字绑定到指定的本地 IP 地址和端口号。
bind(String, Remote) - 类 java.rmi.Naming 中的静态方法
将指定 name 绑定到远程对象。
bind(String, Remote) - 接口 java.rmi.registry.Registry 中的方法
绑定对此注册表中指定 name 的远程引用。
bind(Name, Object) - 接口 javax.naming.Context 中的方法
将名称绑定到对象。
bind(String, Object) - 接口 javax.naming.Context 中的方法
将名称绑定到对象。
bind(Name, Object, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
将名称与关联的属性一起绑定到一个对象。
bind(String, Object, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
将名称与关联的属性一起绑定到一个对象。
bind(String, Object, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
bind(Name, Object, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
bind(String, Object) - 类 javax.naming.InitialContext 中的方法
bind(Name, Object) - 类 javax.naming.InitialContext 中的方法
BIND - 类 javax.print.attribute.standard.Finishings 中的静态变量
此值指示要将某个绑定应用于文档；绑定的类型和布局是由位置定义的。
bind(NameComponent[], Object) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
在命名上下文中创建名称和对象的绑定。
bind(NameComponent[], Object) - 类 org.omg.CosNaming._NamingContextStub 中的方法
在命名上下文中创建名称和对象的绑定。
bind(NameComponent[], Object) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
在命名上下文中创建名称和对象的绑定。
bind_context(NameComponent[], NamingContext) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
命名作为命名上下文的对象。
bind_context(NameComponent[], NamingContext) - 类 org.omg.CosNaming._NamingContextStub 中的方法
命名作为命名上下文的对象。
bind_context(NameComponent[], NamingContext) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
命名作为命名上下文的对象。
bind_new_context(NameComponent[]) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作创建新上下文并将其绑定到作为参数提供的名称。
bind_new_context(NameComponent[]) - 类 org.omg.CosNaming._NamingContextStub 中的方法
此操作创建一个新上下文并将其绑定到作为参数提供的名称。
bind_new_context(NameComponent[]) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
此操作创建新上下文并将其绑定到作为参数提供的名称。
Binder<XmlNode> - javax.xml.bind 中的 类
在 XML 信息集节点和表示相同 XML 文档的 JAXB 对象之间启用同步。
Binder() - 类 javax.xml.bind.Binder 的构造方法
BindException - java.net 中的 异常
试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
BindException(String) - 异常 java.net.BindException 的构造方法
构造一个新的 BindException，使其具有关于绑定错误产生原因的指定详细消息。
BindException() - 异常 java.net.BindException 的构造方法
构造不带详细消息的新 BindException。
Binding - javax.naming 中的 类
此类表示上下文中一个名称到对象的绑定。
Binding(String, Object) - 类 javax.naming.Binding 的构造方法
在给定其名称和对象的情况下构造一个 Binding 实例。
Binding(String, Object, boolean) - 类 javax.naming.Binding 的构造方法
在给定其名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。
Binding(String, String, Object) - 类 javax.naming.Binding 的构造方法
在给定其名称、类名称和对象的情况下构造一个 Binding 实例。
Binding(String, String, Object, boolean) - 类 javax.naming.Binding 的构造方法
在给定其名称、类名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。
Binding - javax.xml.ws 中的 接口
Binding 接口是 JAX-WS 协议绑定的基本接口。
Binding - org.omg.CosNaming 中的 类
org/omg/CosNaming/Binding.java。
Binding() - 类 org.omg.CosNaming.Binding 的构造方法
Binding(NameComponent[], BindingType) - 类 org.omg.CosNaming.Binding 的构造方法
binding_name - 类 org.omg.CosNaming.Binding 中的变量
binding_type - 类 org.omg.CosNaming.Binding 中的变量
BindingHelper - org.omg.CosNaming 中的 类
org/omg/CosNaming/BindingHelper.java。
BindingHelper() - 类 org.omg.CosNaming.BindingHelper 的构造方法
BindingHolder - org.omg.CosNaming 中的 类
org/omg/CosNaming/BindingHolder.java。
BindingHolder() - 类 org.omg.CosNaming.BindingHolder 的构造方法
BindingHolder(Binding) - 类 org.omg.CosNaming.BindingHolder 的构造方法
BindingIterator - org.omg.CosNaming 中的 接口
BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
BindingIteratorHelper - org.omg.CosNaming 中的 类
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorHelper() - 类 org.omg.CosNaming.BindingIteratorHelper 的构造方法
BindingIteratorHolder - org.omg.CosNaming 中的 类
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorHolder() - 类 org.omg.CosNaming.BindingIteratorHolder 的构造方法
BindingIteratorHolder(BindingIterator) - 类 org.omg.CosNaming.BindingIteratorHolder 的构造方法
BindingIteratorOperations - org.omg.CosNaming 中的 接口
BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
BindingIteratorPOA - org.omg.CosNaming 中的 类
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。
BindingIteratorPOA() - 类 org.omg.CosNaming.BindingIteratorPOA 的构造方法
BindingListHelper - org.omg.CosNaming 中的 类
绑定列表。
BindingListHelper() - 类 org.omg.CosNaming.BindingListHelper 的构造方法
BindingListHolder - org.omg.CosNaming 中的 类
绑定列表。
BindingListHolder() - 类 org.omg.CosNaming.BindingListHolder 的构造方法
BindingListHolder(Binding[]) - 类 org.omg.CosNaming.BindingListHolder 的构造方法
BindingProvider - javax.xml.ws 中的 接口
BindingProvider 接口提供对用于请求和响应消息处理的协议绑定及关联上下文对象的访问。
Bindings - javax.script 中的 接口
所有键均为 String 的键/值对映射关系。
BindingType - javax.xml.ws 中的 注释类型
BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
BindingType - org.omg.CosNaming 中的 类
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
BindingType(int) - 类 org.omg.CosNaming.BindingType 的构造方法
BindingTypeHelper - org.omg.CosNaming 中的 类
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
BindingTypeHelper() - 类 org.omg.CosNaming.BindingTypeHelper 的构造方法
BindingTypeHolder - org.omg.CosNaming 中的 类
指定给定的绑定是对象（非命名上下文的对象）的还是命名上下文的。
BindingTypeHolder() - 类 org.omg.CosNaming.BindingTypeHolder 的构造方法
BindingTypeHolder(BindingType) - 类 org.omg.CosNaming.BindingTypeHolder 的构造方法
BIT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BIT 的 Java 编程语言中的常量（有时称为类型代码）。
BIT_DEPTH_MULTI - 类 java.awt.DisplayMode 中的静态变量
位深的值（如果此显示模式支持多个位深）。
bitCount(int) - 类 java.lang.Integer 中的静态方法
返回指定 int 值的二进制补码表示形式的 1 位的数量。
bitCount(long) - 类 java.lang.Long 中的静态方法
返回指定 long 值的二进制补码表示形式中的 1 位的数量。
bitCount() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的二进制补码表示形式中与符号不同的位的数量。
bitLength() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的最小的二进制补码表示形式的位数，不包括 符号位。
BITMASK - 接口 java.awt.Transparency 中的静态变量
表示保证完全不透明的图像数据（alpha 值为 1.0）或完全透明的图像数据（alpha 值为 0.0）。
bitOffset - 类 javax.imageio.stream.ImageInputStreamImpl 中的变量
流中的当前位偏移量。
BitSet - java.util 中的 类
此类实现了一个按需增长的位向量。
BitSet() - 类 java.util.BitSet 的构造方法
创建一个新的位 set。
BitSet(int) - 类 java.util.BitSet 的构造方法
创建一个位 set，它的初始大小足以显式表示索引范围在 0 到 nbits-1 的位。
black - 类 java.awt.Color 中的静态变量
黑色。
BLACK - 类 java.awt.Color 中的静态变量
黑色。
BLIT_SCROLL_MODE - 类 javax.swing.JViewport 中的静态变量
使用 graphics.copyArea 来实现滚动。
Blob - java.sql 中的 接口
SQL BLOB 值在 JavaTM 编程语言中的表示形式（映射关系）。
BLOB - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BLOB 的 Java 编程语言中的常量（有时称为类型代码）。
BLOCK_DECREMENT - 类 java.awt.event.AdjustmentEvent 中的静态变量
块减量调整类型。
BLOCK_ELEMENTS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Block Elements”Unicode 字符块的常量。
BLOCK_INCREMENT - 类 java.awt.event.AdjustmentEvent 中的静态变量
块增量调整类型。
blockClose(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
向解析器缓冲区添加一条指令，以关闭给定类型的块元素。
blockIncrement - 类 javax.swing.JScrollBar 中的变量
BlockingDeque<E> - java.util.concurrent 中的 接口
支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
blockingLock() - 类 java.nio.channels.SelectableChannel 中的方法
获取其 configureBlocking 和 register 方法实现同步的对象。
blockingLock() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
BlockingQueue<E> - java.util.concurrent 中的 接口
支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。
blockOpen(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
向解析器缓冲区添加一条指令，以创建具有给定属性的块元素。
BLOCKQUOTE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
BlockView - javax.swing.text.html 中的 类
用来显示具有 CSS 规范的块（作为一个框）的视图实现。
BlockView(Element, int) - 类 javax.swing.text.html.BlockView 的构造方法
创建表示 html 框的新视图。
blue - 类 java.awt.Color 中的静态变量
蓝色。
BLUE - 类 java.awt.Color 中的静态变量
蓝色。
BLUECOMPONENT - 类 java.awt.color.ICC_ProfileRGB 中的静态变量
用于获取蓝色分量的 gamma 值或 TRC。
BMPImageWriteParam - javax.imageio.plugins.bmp 中的 类
用于以 BMP 格式编码图像的 ImageWriteParam 的子类。
BMPImageWriteParam(Locale) - 类 javax.imageio.plugins.bmp.BMPImageWriteParam 的构造方法
构造一个设置为使用给定 Locale 并且所有参数都采用默认值的 BMPImageWriteParam。
BMPImageWriteParam() - 类 javax.imageio.plugins.bmp.BMPImageWriteParam 的构造方法
构造一个所有参数均为默认值并具有为 null 的 Locale 的 BMPImageWriteParam 对象。
BODY - 类 javax.swing.text.html.HTML.Tag 中的静态变量
body - 类 javax.swing.text.html.parser.DTD 中的变量
BOLD - 类 java.awt.Font 中的静态变量
粗体样式常量。
Bold - 类 javax.swing.text.StyleConstants 中的静态变量
粗体属性的名称。
BOLD_ACTION - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
粗体动作标识符
Book - java.awt.print 中的 类
Book 类提供文档的表示形式，该文档的页面可以使用不同的页面格式和页面 painter。
Book() - 类 java.awt.print.Book 的构造方法
创建新的空 Book。
Boolean - java.lang 中的 类
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Boolean(boolean) - 类 java.lang.Boolean 的构造方法
分配一个表示 value 参数的 Boolean 对象。
Boolean(String) - 类 java.lang.Boolean 的构造方法
如果 String 参数不为 null 且在忽略大小写时等于 "true"，则分配一个表示 true 值的 Boolean 对象。
BOOLEAN - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 BOOLEAN 的 Java 编程语言中的常量（有时称为类型代码）。
BOOLEAN - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Boolean 的值。
BOOLEAN - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 布尔值数据类型。
BooleanControl - javax.sound.sampled 中的 类
BooleanControl 能够在影响行音频的两个可能的设置之间切换。
BooleanControl(BooleanControl.Type, boolean, String, String) - 类 javax.sound.sampled.BooleanControl 的构造方法
构造一个具有给定参数的新 boolean 控件对象。
BooleanControl(BooleanControl.Type, boolean) - 类 javax.sound.sampled.BooleanControl 的构造方法
构造一个具有给定参数的新 boolean 控件对象。
BooleanControl.Type - javax.sound.sampled 中的 类
BooleanControl.Type 类的实例标识一种 boolean 控件。
BooleanControl.Type(String) - 类 javax.sound.sampled.BooleanControl.Type 的构造方法
构造新的 boolean 控件类型。
BooleanHolder - org.omg.CORBA 中的 类
Boolean 的 Holder。
BooleanHolder() - 类 org.omg.CORBA.BooleanHolder 的构造方法
构造一个新的 BooleanHolder 对象，将其 value 字段初始化为 false。
BooleanHolder(boolean) - 类 org.omg.CORBA.BooleanHolder 的构造方法
构造一个新的 BooleanHolder 对象，并使用给定 boolean 初始化其 value 字段。
BooleanSeqHelper - org.omg.CORBA 中的 类
BooleanSeq 的 Helper。
BooleanSeqHelper() - 类 org.omg.CORBA.BooleanSeqHelper 的构造方法
BooleanSeqHolder - org.omg.CORBA 中的 类
BooleanSeq 的 Holder。
BooleanSeqHolder() - 类 org.omg.CORBA.BooleanSeqHolder 的构造方法
BooleanSeqHolder(boolean[]) - 类 org.omg.CORBA.BooleanSeqHolder 的构造方法
booleanValue() - 类 java.lang.Boolean 中的方法
将此 Boolean 对象的值作为基本布尔值返回。
BOPOMOFO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Bopomofo”Unicode 字符块的常量。
BOPOMOFO_EXTENDED - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Bopomofo Extended”Unicode 字符块的常量。
Border - javax.swing.border 中的 接口
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。
border - 类 javax.swing.border.TitledBorder 中的变量
BORDER - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
border - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的变量
要使用的边框。
BORDER_BOTTOM - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_BOTTOM_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_COLOR - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_LEFT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_LEFT_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_PAINTED_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识是否绘制边框的更改。
BORDER_PAINTED_FLAT_CHANGED_PROPERTY - 类 javax.swing.JCheckBox 中的静态变量
标识 flat 属性的更改。
BORDER_RIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_RIGHT_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_STYLE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_TOP - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_TOP_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BORDER_WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
BorderFactory - javax.swing 中的 类
提供标准 Border 对象的工厂类。
borderInsets - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 中的静态变量
borderInsets - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 中的静态变量
borderInsets - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 中的静态变量
borderInsets - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 中的静态变量
BorderLayout - java.awt 中的 类
这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
BorderLayout() - 类 java.awt.BorderLayout 的构造方法
构造一个组件之间没有间距的新边框布局。
BorderLayout(int, int) - 类 java.awt.BorderLayout 的构造方法
构造一个具有指定组件间距的边框布局。
borderListener - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
borderSelectionColor - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
如果应绘制边框选择色，则为 true。
borderSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
节点具有焦点时，用于焦点指示符的颜色。
BorderUIResource - javax.swing.plaf 中的 类
BorderUIResource(Border) - 类 javax.swing.plaf.BorderUIResource 的构造方法
创建一个 UIResource 边框对象，该对象包装了一个现有 Border 实例。
BorderUIResource.BevelBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.BevelBorderUIResource(int) - 类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的构造方法
BorderUIResource.BevelBorderUIResource(int, Color, Color) - 类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的构造方法
BorderUIResource.BevelBorderUIResource(int, Color, Color, Color, Color) - 类 javax.swing.plaf.BorderUIResource.BevelBorderUIResource 的构造方法
BorderUIResource.CompoundBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.CompoundBorderUIResource(Border, Border) - 类 javax.swing.plaf.BorderUIResource.CompoundBorderUIResource 的构造方法
BorderUIResource.EmptyBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.EmptyBorderUIResource(int, int, int, int) - 类 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource 的构造方法
BorderUIResource.EmptyBorderUIResource(Insets) - 类 javax.swing.plaf.BorderUIResource.EmptyBorderUIResource 的构造方法
BorderUIResource.EtchedBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.EtchedBorderUIResource() - 类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的构造方法
BorderUIResource.EtchedBorderUIResource(int) - 类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的构造方法
BorderUIResource.EtchedBorderUIResource(Color, Color) - 类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的构造方法
BorderUIResource.EtchedBorderUIResource(int, Color, Color) - 类 javax.swing.plaf.BorderUIResource.EtchedBorderUIResource 的构造方法
BorderUIResource.LineBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.LineBorderUIResource(Color) - 类 javax.swing.plaf.BorderUIResource.LineBorderUIResource 的构造方法
BorderUIResource.LineBorderUIResource(Color, int) - 类 javax.swing.plaf.BorderUIResource.LineBorderUIResource 的构造方法
BorderUIResource.MatteBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.MatteBorderUIResource(int, int, int, int, Color) - 类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的构造方法
BorderUIResource.MatteBorderUIResource(int, int, int, int, Icon) - 类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的构造方法
BorderUIResource.MatteBorderUIResource(Icon) - 类 javax.swing.plaf.BorderUIResource.MatteBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource - javax.swing.plaf 中的 类
BorderUIResource.TitledBorderUIResource(String) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border, String) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border, String, int, int) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border, String, int, int, Font) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BorderUIResource.TitledBorderUIResource(Border, String, int, int, Font, Color) - 类 javax.swing.plaf.BorderUIResource.TitledBorderUIResource 的构造方法
BOTH - 类 java.awt.GridBagConstraints 中的静态变量
在水平方向和垂直方向上同时调整组件大小。
bottom - 类 java.awt.Insets 中的变量
底部的 inset。
BOTTOM - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的底层进纸托盘。
bottom - 类 javax.swing.border.EmptyBorder 中的变量
BOTTOM - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框底端线的中部。
BOTTOM - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个 Component 到另一个 Component 的下面。
BOTTOM - 接口 javax.swing.SwingConstants 中的静态变量
用于指定框底部位置的框方向常量。
BOTTOM_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentY 的易于使用的常量。
BOTTOM_ALIGNMENT - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形底部与行的底部对齐。
BoundedRangeModel - javax.swing 中的 接口
定义由 Slider 和 ProgressBar 这类组件使用的数据模型。
bounds() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
bounds - 类 java.awt.Polygon 中的变量
此 Polygon 的边界。
Bounds - org.omg.CORBA 中的 异常
当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
Bounds() - 异常 org.omg.CORBA.Bounds 的构造方法
构造不带指定详细消息的 Bounds。
Bounds(String) - 异常 org.omg.CORBA.Bounds 的构造方法
构造带指定详细消息的 Bounds。
Bounds - org.omg.CORBA.TypeCodePackage 中的 异常
提供 TypeCode 操作 member_name()、member_type() 和 member_label。
Bounds() - 异常 org.omg.CORBA.TypeCodePackage.Bounds 的构造方法
构造一个不带任何原因信息的 Bounds 异常。
Bounds(String) - 异常 org.omg.CORBA.TypeCodePackage.Bounds 的构造方法
构造一个带有指定原因信息的 Bounds 异常。
Box - javax.swing 中的 类
使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
Box(int) - 类 javax.swing.Box 的构造方法
创建一个沿指定坐标轴显示其组件的 Box。
Box.AccessibleBox - javax.swing 中的 类
此类实现 Box 类的可访问性支持。
Box.AccessibleBox() - 类 javax.swing.Box.AccessibleBox 的构造方法
Box.Filler - javax.swing 中的 类
参与布局但没有视图的轻量级组件的实现。
Box.Filler(Dimension, Dimension, Dimension) - 类 javax.swing.Box.Filler 的构造方法
使用给定的大小范围创建形状的构造方法。
Box.Filler.AccessibleBoxFiller - javax.swing 中的 类
此类实现 Box.Filler 类的可访问性支持。
Box.Filler.AccessibleBoxFiller() - 类 javax.swing.Box.Filler.AccessibleBoxFiller 的构造方法
BOX_DRAWING - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Box Drawing”Unicode 字符块的常量。
boxedClass(PrimitiveType) - 接口 javax.lang.model.util.Types 中的方法
返回给定基本类型的装箱 (boxed) 值类型的类。
BoxedValueHelper - org.omg.CORBA.portable 中的 接口
BoxLayout - javax.swing 中的 类
允许垂直或水平布置多个组件的布局管理器。
BoxLayout(Container, int) - 类 javax.swing.BoxLayout 的构造方法
创建一个将沿给定轴放置组件的布局管理器。
boxRect - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的变量
用于保存要绘制的跳动框（由 getBox 返回）的位置和大小。
BoxView - javax.swing.text 中的 类
一个视图，它通过沿某轴平铺将其子级排列到框形状中。
BoxView(Element, int) - 类 javax.swing.text.BoxView 的构造方法
构造一个 BoxView。
BR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
BRAILLE_PATTERNS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Braille Patterns”Unicode 字符块的常量。
breadthFirstEnumeration() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回一个枚举，该枚举按广度优先的顺序遍历以此节点为根的子树。
BreakIterator - java.text 中的 类
BreakIterator 类实现用于查找文本中边界位置的方法。
BreakIterator() - 类 java.text.BreakIterator 的构造方法
构造方法。
BreakIteratorProvider - java.text.spi 中的 类
提供 BreakIterator 类具体实现的服务提供者的抽象类。
BreakIteratorProvider() - 类 java.text.spi.BreakIteratorProvider 的构造方法
唯一的构造方法。
breaksFlow() - 类 javax.swing.text.html.HTML.Tag 中的方法
如果此标记导致数据流换行，则返回 true；否则返回 false。
breaksFlow() - 类 javax.swing.text.html.parser.TagElement 中的方法
breakView(int, int, float, float) - 类 javax.swing.text.GlyphView 中的方法
在给定的轴上以给定的长度拆分此视图。
breakView(int, int, float, float) - 类 javax.swing.text.html.InlineView 中的方法
尝试在给定轴上拆分此视图。
breakView(int, float, Shape) - 类 javax.swing.text.ParagraphView 中的方法
以给定的长度在给定的轴上拆分此视图。
breakView(int, int, float, float) - 类 javax.swing.text.View 中的方法
试图在给定的轴上拆分视图。
BRIEF - 类 java.rmi.server.LogStream 中的静态变量
已过时。 日志级别常量（简明日志记录）。
brighter() - 类 java.awt.Color 中的方法
创建一个新 Color，它具有比此 Color 更亮的颜色。
BrokenBarrierException - java.util.concurrent 中的 异常
当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
BrokenBarrierException() - 异常 java.util.concurrent.BrokenBarrierException 的构造方法
构造不带指定详细消息的 BrokenBarrierException。
BrokenBarrierException(String) - 异常 java.util.concurrent.BrokenBarrierException 的构造方法
构造带指定详细消息的 BrokenBarrierException。
browse(URI) - 类 java.awt.Desktop 中的方法
启动默认浏览器来显示 URI。
BUBBLING_PHASE - 接口 org.w3c.dom.events.Event 中的静态变量
当前的事件阶段为 bubbling 阶段。
buf - 类 java.io.BufferedInputStream 中的变量
存储数据的内部缓冲区数组。
buf - 类 java.io.BufferedOutputStream 中的变量
存储数据的内部缓冲区。
buf - 类 java.io.ByteArrayInputStream 中的变量
由该流的创建者提供的 byte 数组。
buf - 类 java.io.ByteArrayOutputStream 中的变量
存储数据的缓冲区。
buf - 类 java.io.CharArrayReader 中的变量
字符缓冲区。
buf - 类 java.io.CharArrayWriter 中的变量
存储数据的缓冲区。
buf - 类 java.io.PushbackInputStream 中的变量
推回缓冲区。
buf - 类 java.util.zip.DeflaterInputStream 中的变量
读取压缩数据的输入缓冲区。
buf - 类 java.util.zip.DeflaterOutputStream 中的变量
写入压缩数据的输出缓冲区。
buf - 类 java.util.zip.InflaterInputStream 中的变量
用于解压缩的输入缓冲区。
buf - 类 java.util.zip.InflaterOutputStream 中的变量
写入未压缩数据的输出缓冲区。
buffer - 类 java.io.PipedInputStream 中的变量
放置传入数据的循环缓冲区。
buffer - 类 java.io.StringBufferInputStream 中的变量
已过时。 从中读取字节的字符串。
Buffer - java.nio 中的 类
一个用于特定基本类型数据的容器。
buffer - 类 javax.swing.text.DefaultStyledDocument 中的变量
BUFFER_SIZE_DEFAULT - 类 javax.swing.text.DefaultStyledDocument 中的静态变量
初始内容缓冲区的默认大小。
BufferCapabilities - java.awt 中的 类
缓冲区的能力和属性。
BufferCapabilities(ImageCapabilities, ImageCapabilities, BufferCapabilities.FlipContents) - 类 java.awt.BufferCapabilities 的构造方法
创建一个指定缓冲区能力的新对象
BufferCapabilities.FlipContents - java.awt 中的 类
页面翻转后可能的后台缓冲区内容的一个类型安全的枚举
BUFFERED_OPTION - 类 javax.swing.DebugGraphics 中的静态变量
在一个单独的 Frame 中显示已缓冲的操作。
BufferedImage - java.awt.image 中的 类
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
BufferedImage(int, int, int) - 类 java.awt.image.BufferedImage 的构造方法
构造一个类型为预定义图像类型之一的 BufferedImage。
BufferedImage(int, int, int, IndexColorModel) - 类 java.awt.image.BufferedImage 的构造方法
构造一个类型为预定义图像类型之一的 BufferedImage：TYPE_BYTE_BINARY 或 TYPE_BYTE_INDEXED。
BufferedImage(ColorModel, WritableRaster, boolean, Hashtable<?, ?>) - 类 java.awt.image.BufferedImage 的构造方法
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
BufferedImageFilter - java.awt.image 中的 类
BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
BufferedImageFilter(BufferedImageOp) - 类 java.awt.image.BufferedImageFilter 的构造方法
构造具有指定单一源图像/单一目标图像操作符的 BufferedImageFilter。
BufferedImageOp - java.awt.image 中的 接口
此接口描述对 BufferedImage 对象所执行的单输入/单输出操作。
BufferedInputStream - java.io 中的 类
BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
BufferedInputStream(InputStream) - 类 java.io.BufferedInputStream 的构造方法
创建一个 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
BufferedInputStream(InputStream, int) - 类 java.io.BufferedInputStream 的构造方法
创建具有指定缓冲区大小的 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
BufferedOutputStream - java.io 中的 类
该类实现缓冲的输出流。
BufferedOutputStream(OutputStream) - 类 java.io.BufferedOutputStream 的构造方法
创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
BufferedOutputStream(OutputStream, int) - 类 java.io.BufferedOutputStream 的构造方法
创建一个新的缓冲输出流，以将具有指定缓冲区大小的数据写入指定的底层输出流。
BufferedReader - java.io 中的 类
从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
BufferedReader(Reader, int) - 类 java.io.BufferedReader 的构造方法
创建一个使用指定大小输入缓冲区的缓冲字符输入流。
BufferedReader(Reader) - 类 java.io.BufferedReader 的构造方法
创建一个使用默认大小输入缓冲区的缓冲字符输入流。
BufferedWriter - java.io 中的 类
将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
BufferedWriter(Writer) - 类 java.io.BufferedWriter 的构造方法
创建一个使用默认大小输出缓冲区的缓冲字符输出流。
BufferedWriter(Writer, int) - 类 java.io.BufferedWriter 的构造方法
创建一个使用给定大小输出缓冲区的新缓冲字符输出流。
BufferOverflowException - java.nio 中的 异常
当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
BufferOverflowException() - 异常 java.nio.BufferOverflowException 的构造方法
构造此类的一个实例。
BufferStrategy - java.awt.image 中的 类
BufferStrategy 类表示用来在特定的 Canvas 或 Window 上组织复杂内存的机制。
BufferStrategy() - 类 java.awt.image.BufferStrategy 的构造方法
BufferUnderflowException - java.nio 中的 异常
当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
BufferUnderflowException() - 异常 java.nio.BufferUnderflowException 的构造方法
构造此类的一个实例。
BUHID - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Buhid”Unicode 字符块的常量。
build(CertPathParameters) - 类 java.security.cert.CertPathBuilder 中的方法
尝试使用指定的算法参数集构建一个证书路径。
buildChooser() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
建立一个新的选取器面板。
bumps - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 中的变量
bumps - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
burstStringInto(Container, String, int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
递归式创建表示 d 的新 JLabel 实例每个 JLabel 实例都将被添加到 c。
BUSY - 类 javax.accessibility.AccessibleState 中的静态变量
指示当前对象忙。
Button - java.awt 中的 类
此类创建一个标签按钮。
Button() - 类 java.awt.Button 的构造方法
构造一个标签字符串为空的按钮。
Button(String) - 类 java.awt.Button 的构造方法
构造一个带指定标签的按钮。
BUTTON - 类 javax.swing.plaf.synth.Region 中的静态变量
Button 的 region。
Button.AccessibleAWTButton - java.awt 中的 类
此类实现对 Button 类的可访问性支持。
Button.AccessibleAWTButton() - 类 java.awt.Button.AccessibleAWTButton 的构造方法
BUTTON1 - 类 java.awt.event.MouseEvent 中的静态变量
指示鼠标按键 #1；由 MouseEvent.getButton() 使用。
BUTTON1_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button1 的扩展修饰符常量。
BUTTON1_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button1 修饰符常量。
BUTTON2 - 类 java.awt.event.MouseEvent 中的静态变量
指示鼠标按键 #2；由 MouseEvent.getButton() 使用。
BUTTON2_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button2 的扩展修饰符常量。
BUTTON2_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button2 修饰符常量。
BUTTON3 - 类 java.awt.event.MouseEvent 中的静态变量
指示鼠标按键 #3；由 MouseEvent.getButton() 使用。
BUTTON3_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button3 的扩展修饰符常量。
BUTTON3_MASK - 类 java.awt.event.InputEvent 中的静态变量
Mouse Button3 修饰符常量。
ButtonGroup - javax.swing 中的 类
此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。
ButtonGroup() - 类 javax.swing.ButtonGroup 的构造方法
创建一个新的 ButtonGroup。
buttonIndex - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener 中的变量
buttonListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
ButtonModel - javax.swing 中的 接口
按钮的状态模型。
buttons - 类 javax.swing.ButtonGroup 中的变量
ButtonUI - javax.swing.plaf 中的 类
JButton 的可插入外观界面。
ButtonUI() - 类 javax.swing.plaf.ButtonUI 的构造方法
Byte - java.lang 中的 类
Byte 类将基本类型 byte 的值包装在一个对象中。
Byte(byte) - 类 java.lang.Byte 的构造方法
构造一个新分配的 Byte 对象，以表示指定的 byte 值。
Byte(String) - 类 java.lang.Byte 的构造方法
构造一个新分配的 Byte 对象，以表示 String 参数所指示的 byte 值。
BYTE - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Byte 的值。
ByteArrayInputStream - java.io 中的 类
ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。
ByteArrayInputStream(byte[]) - 类 java.io.ByteArrayInputStream 的构造方法
创建一个 ByteArrayInputStream，使用 buf 作为其缓冲区数组。
ByteArrayInputStream(byte[], int, int) - 类 java.io.ByteArrayInputStream 的构造方法
创建 ByteArrayInputStream，使用 buf 作为其缓冲区数组。
ByteArrayOutputStream - java.io 中的 类
此类实现了一个输出流，其中的数据被写入一个 byte 数组。
ByteArrayOutputStream() - 类 java.io.ByteArrayOutputStream 的构造方法
创建一个新的 byte 数组输出流。
ByteArrayOutputStream(int) - 类 java.io.ByteArrayOutputStream 的构造方法
创建一个新的 byte 数组输出流，它具有指定大小的缓冲区容量（以字节为单位）。
ByteBuffer - java.nio 中的 类
字节缓冲区。
ByteChannel - java.nio.channels 中的 接口
可读取和写入字节的信道。
ByteHolder - org.omg.CORBA 中的 类
Byte 的 Holder。
ByteHolder() - 类 org.omg.CORBA.ByteHolder 的构造方法
构造一个新的 ByteHolder 对象，将其 value 字段初始化为 0。
ByteHolder(byte) - 类 org.omg.CORBA.ByteHolder 的构造方法
为给定 byte 构造一个新的 ByteHolder 对象。
byteLength - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的长度，以字节为单位。
ByteLookupTable - java.awt.image 中的 类
此类定义一个 lookup table 对象。
ByteLookupTable(int, byte[][]) - 类 java.awt.image.ByteLookupTable 的构造方法
根据字节数组的数组（表示每个 band 的 lookup table）构造一个 ByteLookupTable 对象。
ByteLookupTable(int, byte[]) - 类 java.awt.image.ByteLookupTable 的构造方法
根据字节数组（表示应用于所有 band 的 lookup table）构造一个 ByteLookupTable 对象。
ByteOrder - java.nio 中的 类
字节顺序的类型安全枚举。
byteOrder - 类 javax.imageio.stream.ImageInputStreamImpl 中的变量
流的字节顺序，其为枚举类 java.nio.ByteOrder 的实例，其中 ByteOrder.BIG_ENDIAN 指示网络字节顺序，ByteOrder.LITTLE_ENDIAN 指示反向顺序。
bytesConsumed() - 类 javax.net.ssl.SSLEngineResult 中的方法
返回使用的输入缓冲区中的字节数。
bytesProduced() - 类 javax.net.ssl.SSLEngineResult 中的方法
返回写入到输出缓冲区中的字节数。
bytesTransferred - 异常 java.io.InterruptedIOException 中的变量
报告 I/O 操作中断之前传输了其中多少字节。
bytesWidth(byte[], int, int) - 类 java.awt.FontMetrics 中的方法
返回显示此 Font 中指定字节数组的总 advance width。
byteValue() - 类 java.lang.Byte 中的方法
作为一个 byte 返回此 Byte 的值。
byteValue() - 类 java.lang.Double 中的方法
以 byte 形式返回此 Double 的值（通过强制转换为 byte）。
byteValue() - 类 java.lang.Float 中的方法
将此 Float 值以 byte 形式返回（强制转换为 byte）。
byteValue() - 类 java.lang.Integer 中的方法
以 byte 类型返回该 Integer 的值。
byteValue() - 类 java.lang.Long 中的方法
以 byte 形式返回此 Long 的值。
byteValue() - 类 java.lang.Number 中的方法
以 byte 形式返回指定的数值。
byteValue() - 类 java.lang.Short 中的方法
以 byte 形式返回此 Short 的值。
byteValueExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 byte，以检查丢失的信息。
BYZANTINE_MUSICAL_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Byzantine Musical Symbols”Unicode 字符块的常量。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


C - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

C

C - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering C (17 x 22 in) 的 MediaType 实例。
C - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering C 尺寸，17 inch × 22 inch。
C - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
C 尺寸。
C0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C0 的别名。
C1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C1 的别名。
C10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C10 的别名。
C14NMethodParameterSpec - javax.xml.crypto.dsig.spec 中的 接口
CanonicalizationMethod 算法的算法参数规范。
C2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C2 的别名。
C3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C3 的别名。
C3 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO C3 尺寸，324 mm × 458 mm。
C4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C4 的别名。
C4 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO C4 尺寸，229 mm × 324 mm。
C5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C5 的别名。
C5 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO C5 尺寸，162 mm × 229 mm。
C6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C6 的别名。
C6 - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO C6 尺寸，114 mm × 162 mm。
C7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C7 的别名。
C8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C8 的别名。
C9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C9 的别名。
cachedChildren() - 类 java.util.prefs.AbstractPreferences 中的方法
返回此节点的所有已知未移除子节点。
cachedMinimumSize - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
CachedRowSet - javax.sql.rowset 中的 接口
所有标准 CachedRowSet 实现都必须实现的接口。
cacheIcon(File, Icon) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法
cacheMBeanInfo(MBeanInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：缓存为此对象构建的 MBeanInfo。
CacheRequest - java.net 中的 类
表示在 ResponseCache 中存储资源的通道。
CacheRequest() - 类 java.net.CacheRequest 的构造方法
CacheResponse - java.net 中的 类
表示从 ResponseCache 获取资源的通道。
CacheResponse() - 类 java.net.CacheResponse 的构造方法
calcRect - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
用于通用布局计算以避免运行中构造多个新 Rectangle 的矩形。
calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - 类 javax.swing.SizeRequirements 中的静态方法
创建一组偏移量/区域对，指定如何按照指定对齐方式对一组组件进行布局。
calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - 类 javax.swing.SizeRequirements 中的静态方法
创建一组偏移量/区域对，指定如何按指定对齐方式对一组组件进行布局。
calculateBreakPosition(int, int) - 类 javax.swing.text.WrappedPlainView 中的方法
此方法由嵌套换行视图调用，以确定拆分位置。
calculateContentRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateFocusRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateGeometry() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateIndex(CompositeData) - 接口 javax.management.openmbean.TabularData 中的方法
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例中后引用该参数。
calculateIndex(CompositeData) - 类 javax.management.openmbean.TabularDataSupport 中的方法
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例后引用该参数。
calculateInnerArea(JComponent, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
calculateLabelRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateLayoutInfo() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
calculateMajorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.BoxView 中的方法
计算主轴 axis 的大小要求。
calculateMajorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.html.BlockView 中的方法
计算块沿主轴的要求（即沿其平铺的轴）。
calculateMaxTabHeight(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateMaxTabHeight(int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
calculateMaxTabWidth(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.BoxView 中的方法
计算辅轴 axis 的大小要求。
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.FlowView 中的方法
计算沿辅轴的要求。
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.html.BlockView 中的方法
计算块沿辅轴的要求（即垂直沿其平铺的轴的轴）。
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.html.ParagraphView 中的方法
计算段落沿辅轴的要求。
calculateMinorAxisRequirements(int, SizeRequirements) - 类 javax.swing.text.TableView 中的方法
计算辅轴的所需大小。
calculateSize(boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
calculateTabAreaHeight(int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateTabAreaWidth(int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateTabHeight(int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateTabRects(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
calculateTabWidth(int, int, FontMetrics) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
calculateThumbLocation() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateThumbSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateTickRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - 类 javax.swing.SizeRequirements 中的静态方法
创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - 类 javax.swing.SizeRequirements 中的静态方法
创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
calculateTrackBuffer() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calculateTrackRect() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
calendar - 类 java.text.DateFormat 中的变量
DateFormat 使用 calendar 来生成实现日期和时间格式化所需的时间字段值。
Calendar - java.util 中的 类
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Calendar() - 类 java.util.Calendar 的构造方法
构造一个带有默认时区和语言环境的 Calendar。
Calendar(TimeZone, Locale) - 类 java.util.Calendar 的构造方法
构造一个带有指定时区和语言环境的 Calendar。
call() - 接口 java.util.concurrent.Callable 中的方法
计算结果，如果无法计算结果，则抛出一个异常。
call() - 接口 javax.tools.JavaCompiler.CompilationTask 中的方法
执行此编译任务。
call(SOAPMessage, Object) - 类 javax.xml.soap.SOAPConnection 中的方法
将给定消息发送到指定端点，在返回应答前将一直阻塞。
Callable<V> - java.util.concurrent 中的 接口
返回结果并且可能抛出异常的任务。
callable(Runnable, T) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可运行给定的任务并返回给定的结果。
callable(Runnable) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可运行给定的任务并返回 null。
callable(PrivilegedAction<?>) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。
callable(PrivilegedExceptionAction<?>) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。
CallableStatement - java.sql 中的 接口
用于执行 SQL 存储过程的接口。
Callback - javax.security.auth.callback 中的 接口
将此接口的实现传递给 CallbackHandler，允许底层安全服务与调用的应用程序交互，从而获取特定的验证数据（如用户名和密码），或者显示特定的信息（如错误和警告消息）。
CallbackHandler - javax.security.auth.callback 中的 接口
应用程序实现 CallbackHandler，并将其传递到底层安全服务，以便它们能与应用程序交互，从而获得特定的验证数据（如用户名和密码），或显示特定的信息（如错误和警告消息）。
CANADA - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
CANADA_FRENCH - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
cancel() - 类 java.awt.print.PrinterJob 中的方法
取消正在进行的打印作业。
cancel() - 类 java.nio.channels.SelectionKey 中的方法
请求取消此键的通道到其选择器的注册。
cancel() - 类 java.nio.channels.spi.AbstractSelectionKey 中的方法
取消此键。
cancel() - 接口 java.sql.Statement 中的方法
如果 DBMS 和驱动程序都支持中止 SQL 语句，则取消此 Statement 对象。
cancel(boolean) - 接口 java.util.concurrent.Future 中的方法
试图取消对此任务的执行。
cancel(boolean) - 类 java.util.concurrent.FutureTask 中的方法
cancel() - 类 java.util.Timer 中的方法
终止此计时器，丢弃所有当前已安排的任务。
cancel() - 类 java.util.TimerTask 中的方法
取消此计时器任务。
cancel() - 接口 javax.print.CancelablePrintJob 中的方法
停止对打印作业的进一步处理。
CANCEL - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
CANCEL 选项。
cancel(boolean) - 类 javax.swing.SwingWorker 中的方法
试图取消对此任务的执行。
CANCEL_OPTION - 类 javax.swing.JFileChooser 中的静态变量
选择 cancel 后的返回该值。
CANCEL_OPTION - 类 javax.swing.JOptionPane 中的静态变量
选择 CANCEL 时从类方法返回的值。
CANCEL_SELECTION - 类 javax.swing.JFileChooser 中的静态变量
指示取消当前的选择。
CancelablePrintJob - javax.print 中的 接口
打印应用程序使用此接口来取消打印作业。
cancelButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
cancelButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
cancelButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
cancelCellEditing() - 类 javax.swing.AbstractCellEditor 中的方法
调用 fireEditingCanceled。
cancelCellEditing() - 接口 javax.swing.CellEditor 中的方法
告知编辑器取消编辑并且不接受任何已部分编辑的值。
cancelCellEditing() - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
cancelCellEditing() - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
取消编辑。
cancelCellEditing() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
将 cancelCellEditing 发送到 realEditor，并从此实例移除它。
CANCELED - 类 javax.print.attribute.standard.JobState 中的静态变量
作业已被人为操作取消，打印机已完成了正取消的作业，且所有作业状态属性已达到作业的最终值。
cancelEditing() - 类 javax.swing.JTree 中的方法
取消当前编辑会话。
cancelEditing(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
取消当前编辑会话。
cancelEditing(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 cancelEditing 方法。
cancelEditing(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
取消当前编辑会话。
cancelLatestCommittedText(AttributedCharacterIterator.Attribute[]) - 接口 java.awt.im.InputMethodRequests 中的方法
从文本编辑组件中获取最新的提交文本，并将其从该组件的文本正文中移除。
CancellationException - java.util.concurrent 中的 异常
如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
CancellationException() - 异常 java.util.concurrent.CancellationException 的构造方法
构造不带详细消息的 CancellationException。
CancellationException(String) - 异常 java.util.concurrent.CancellationException 的构造方法
构造带指定详细消息的 CancellationException。
CancelledKeyException - java.nio.channels 中的 异常
当试图使用不再有效的选择键时，抛出此未经检查的异常。
CancelledKeyException() - 异常 java.nio.channels.CancelledKeyException 的构造方法
构造此类的一个实例。
cancelledKeys() - 类 java.nio.channels.spi.AbstractSelector 中的方法
获取此选择器的已取消键集。
cancelRowUpdates() - 接口 java.sql.ResultSet 中的方法
取消对 ResultSet 对象中的当前行所作的更新。
cancelSelection() - 类 javax.swing.JFileChooser 中的方法
用户选择 Cancel 按钮时由 UI 调用此方法。
canDecodeInput(Object) - 类 javax.imageio.spi.ImageReaderSpi 中的方法
如果给定的源对象看起来是此 reader 支持的格式，则返回 true。
canDisplay(char) - 类 java.awt.Font 中的方法
检查此 Font 是否具有指定字符的字形。
canDisplay(int) - 类 java.awt.Font 中的方法
检查此 Font 是否具有指定字符的字形。
canDisplayUpTo(String) - 类 java.awt.Font 中的方法
指示此 Font 是否可以显示指定的 String。
canDisplayUpTo(char[], int, int) - 类 java.awt.Font 中的方法
指示此 Font 是否可以显示指定 text 中从 start 开始至 limit 结束的所有字符。
canDisplayUpTo(CharacterIterator, int, int) - 类 java.awt.Font 中的方法
指示此 Font 是否可以显示由 iter 指定的文本（从 start 开始至 limit 结束）。
canDock(Component, Point) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
canEdit - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
从 Java 2 平台 v1.4 开始，不应再使用此字段。
canEditImmediately(EventObject) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果 event 为 null，或者它是一个单击计数 > 2 的 MouseEvent，并且 inHitRegion 返回 true，则此方法返回 true。
canEncode() - 类 java.nio.charset.Charset 中的方法
通知此 charset 是否支持编码。
canEncode(char) - 类 java.nio.charset.CharsetEncoder 中的方法
通知此编码器是否能够编码给定的字符。
canEncode(CharSequence) - 类 java.nio.charset.CharsetEncoder 中的方法
通过此编码器是否能够编码给定的字符序列。
canEncodeImage(ImageTypeSpecifier) - 类 javax.imageio.spi.ImageWriterSpi 中的方法
如果与此服务提供者关联的 ImageWriter 实现能够使用给定的布局编码图像，则返回 true。
canEncodeImage(RenderedImage) - 类 javax.imageio.spi.ImageWriterSpi 中的方法
如果与此服务提供者关联的 ImageWriter 实现能够编码给定的 RenderedImage 实例，则返回 true。
canExecute() - 类 java.io.File 中的方法
测试应用程序是否可以执行此抽象路径名表示的文件。
canFilterIndexColorModel - 类 java.awt.image.RGBImageFilter 中的变量
此布尔值指示是否可以接受用 filterRGB 方法的颜色过滤替代逐像素过滤，并应用于 IndexColorModel 对象的颜色表项。
canImport(TransferHandler.TransferSupport) - 类 javax.swing.TransferHandler 中的方法
在拖放操作期间重复调用此方法，以允许开发人员配置传输的可接受性属性，并返回传输的可接受性；返回 true 值指示给定 TransferSupport（它包含该传输的所有细节）所表示的传输在当前是可以接受的，false 值指示拒绝该传输。
canImport(JComponent, DataFlavor[]) - 类 javax.swing.TransferHandler 中的方法
指示一个组件在实际尝试导入给定数据 flavor 的集合之前是否接受其导入。
canInsertEmpty(int) - 类 javax.imageio.ImageWriter 中的方法
如果 writer 支持在给定索引处插入新的空图像，则返回 true。
canInsertImage(int) - 类 javax.imageio.ImageWriter 中的方法
如果 writer 支持在给定索引处插入新图像，则返回 true。
canNodeAppear(String, ImageTypeSpecifier) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。
canNodeAppear(String, ImageTypeSpecifier) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
CannotProceed - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
CannotProceed() - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 的构造方法
CannotProceed(NamingContext, NameComponent[]) - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 的构造方法
CannotProceed(String, NamingContext, NameComponent[]) - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 的构造方法
CannotProceedException - javax.naming 中的 异常
抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
CannotProceedException(String) - 异常 javax.naming.CannotProceedException 的构造方法
使用解释构造一个新的 CannotProceedException 实例。
CannotProceedException() - 异常 javax.naming.CannotProceedException 的构造方法
构造一个新的 CannotProceedException 实例。
CannotProceedHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java。
CannotProceedHelper() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 的构造方法
CannotProceedHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java。
CannotProceedHolder() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 的构造方法
CannotProceedHolder(CannotProceed) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 的构造方法
CannotRedoException - javax.swing.undo 中的 异常
当 UndoableEdit 被通知 redo() 但无法执行时抛出。
CannotRedoException() - 异常 javax.swing.undo.CannotRedoException 的构造方法
CannotUndoException - javax.swing.undo 中的 异常
当 UndoableEdit 被通知 undo() 但无法执行时抛出。
CannotUndoException() - 异常 javax.swing.undo.CannotUndoException 的构造方法
canOffsetTiles - 类 javax.imageio.ImageWriteParam 中的变量
如果此 ImageWriteParam 允许使用 tiling 网格偏移量参数，则返回为 true 的 boolean 值。
canOffsetTiles() - 类 javax.imageio.ImageWriteParam 中的方法
如果 writer 在执行写入操作的同时可以使用非零网格偏移量进行平铺，则返回 true。
CANON_EQ - 类 java.util.regex.Pattern 中的静态变量
启用规范等价。
CANONICAL - 类 javax.security.auth.x500.X500Principal 中的静态变量
标识名的规范化字符串格式。
CANONICAL_DECOMPOSITION - 类 java.text.Collator 中的静态变量
Decomposition 模式值。
CanonicalizationMethod - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML CanonicalizationMethod 元素的表示形式。
canonicalize(Oid) - 接口 org.ietf.jgss.GSSName 中的方法
创建一个针对某种机制而规范化的名称。
canPathsBeAdded(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
用于测试是否可以添加特定的 TreePath 集合。
canPathsBeRemoved(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果可以移除该路径而不中断该模型的连续性，则返回 true。
canRead() - 类 java.io.File 中的方法
测试应用程序是否可以读取此抽象路径名表示的文件。
canReadRaster() - 类 javax.imageio.ImageReader 中的方法
如果此插件支持只读取像素数据的 Raster，则返回 true。
canRedo() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
如果此编辑为 alive 并且 hasBeenDone 为 false，则返回 true。
canRedo() - 类 javax.swing.undo.CompoundEdit 中的方法
如果 isInProgress 或者超类返回 false，则此方法返回 false。
canRedo() - 接口 javax.swing.undo.UndoableEdit 中的方法
如果可以恢复此编辑，则返回 true。
canRedo() - 类 javax.swing.undo.UndoManager 中的方法
如果可以恢复编辑，则返回 true。
canRemoveImage(int) - 类 javax.imageio.ImageWriter 中的方法
如果 writer 支持在给定索引处移除现有图像，则返回 true。
canReplaceImageMetadata(int) - 类 javax.imageio.ImageWriter 中的方法
如果有可能使用索引 imageIndex 替换与现有图像有关的图像元数据，则返回 true。
canReplacePixels(int) - 类 javax.imageio.ImageWriter 中的方法
如果 writer 允许使用 replacePixels 方法替换给定图像的索引，则返回 true。
canReplaceStreamMetadata() - 类 javax.imageio.ImageWriter 中的方法
如果有可能替换已存在于输出中的流元数据，则返回 true。
canSetParameter(String, Object) - 接口 org.w3c.dom.DOMConfiguration 中的方法
检查是否支持将参数设置为特定值。
canSetSourceRenderSize - 类 javax.imageio.ImageReadParam 中的变量
如果此 ImageReadParam 允许设置源呈现维数，则为 true。
canSetSourceRenderSize() - 类 javax.imageio.ImageReadParam 中的方法
如果此 reader 允许通过使用 setSourceRenderSize 方法以任意大小将源图像呈现为解码过程的一部分，则返回 true。
canUndo() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
如果此编辑为 alive 并且 hasBeenDone 为 true，则返回 true。
canUndo() - 类 javax.swing.undo.CompoundEdit 中的方法
如果 isInProgress 或者超类返回 false，则此方法返回 false。
canUndo() - 接口 javax.swing.undo.UndoableEdit 中的方法
如果可以撤消此编辑，则返回 true。
canUndo() - 类 javax.swing.undo.UndoManager 中的方法
如果可以撤消编辑，则返回 true。
canUndoOrRedo() - 类 javax.swing.undo.UndoManager 中的方法
如果可以调用 undo 或 redo，则返回 true。
canUseCacheFile() - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
如果与此服务提供者关联的 ImageInputStream 实现可选择利用缓存文件改善性能和/或内存占用，则返回 true。
canUseCacheFile() - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
如果与此服务提供者关联的 ImageOutputStream 实现可选择利用缓存 File 改善性能和/或内存占用，则返回 true。
Canvas - java.awt 中的 类
Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
Canvas() - 类 java.awt.Canvas 的构造方法
构造一个新的 Canvas。
Canvas(GraphicsConfiguration) - 类 java.awt.Canvas 的构造方法
根据给定 GraphicsConfiguration 对象构造一个新的 Canvas。
CANVAS - 类 javax.accessibility.AccessibleRole 中的静态变量
可用于绘制和捕获事件的对象。
Canvas.AccessibleAWTCanvas - java.awt 中的 类
此类实现对 Canvas 类的可访问性支持。
Canvas.AccessibleAWTCanvas() - 类 java.awt.Canvas.AccessibleAWTCanvas 的构造方法
canWrite() - 类 java.io.File 中的方法
测试应用程序是否可以修改此抽象路径名表示的文件。
canWriteCompressed - 类 javax.imageio.ImageWriteParam 中的变量
如果此 writer 可以使用压缩写入图像，则返回为 true 的 boolean 值。
canWriteCompressed() - 类 javax.imageio.ImageWriteParam 中的方法
如果此 writer 支持压缩，则返回 true。
canWriteEmpty() - 类 javax.imageio.ImageWriter 中的方法
如果 writer 支持写入由单个图像组成的完整图像流，则返回 true，这些对象带有要输出的不确定像素值、有关元数据和缩略图。
canWriteProgressive - 类 javax.imageio.ImageWriteParam 中的变量
如果此 ImageWriteParam 允许以一个质量递增传递的逐步序列的方式写入图像，则返回为 true 的 boolean 值。
canWriteProgressive() - 类 javax.imageio.ImageWriteParam 中的方法
如果 writer 能够以一系列质量逐渐递增的传递的方式将图像写出，则返回 true。
canWriteRasters() - 类 javax.imageio.ImageWriter 中的方法
如果采用 IIOImage 参数的方法能够处理 Raster（相对于 RenderedImage）源图像，则返回 true。
canWriteSequence() - 类 javax.imageio.ImageWriter 中的方法
如果 writer 能够将图像添加到已经包含头信息和可能的以前图像的图像流中，则返回 true。
canWriteTiles - 类 javax.imageio.ImageWriteParam 中的变量
如果此 ImageWriteParam 允许设置 tile 的宽度和高度参数，则返回为 true 的 boolean 值。
canWriteTiles() - 类 javax.imageio.ImageWriteParam 中的方法
如果 writer 在执行写入操作的同时可以进行平铺，则返回 true。
CAP_BUTT - 类 java.awt.BasicStroke 中的静态变量
无装饰地结束未封闭的子路径和虚线线段。
CAP_ROUND - 类 java.awt.BasicStroke 中的静态变量
使用半径等于画笔宽度一半的圆形装饰结束未封闭的子路径和虚线线段。
CAP_SQUARE - 类 java.awt.BasicStroke 中的静态变量
使用正方形结束未封闭的子路径和虚线线段，正方形越过线段端点，并延长等于线条宽度一半的距离。
capacity() - 类 java.lang.StringBuffer 中的方法
capacity() - 类 java.nio.Buffer 中的方法
返回此缓冲区的容量。
capacity() - 类 java.util.Vector 中的方法
返回此向量的当前容量。
capacity() - 类 javax.swing.DefaultListModel 中的方法
返回此列表的当前容量。
capacityIncrement - 类 java.util.Vector 中的变量
向量的大小大于其容量时，容量自动增加的量。
capacityIncrement - 类 javax.management.monitor.Monitor 中的静态变量
监视器数组的大小大于其容量时，容量自动递增的量。
caps - 类 java.awt.Component.BltBufferStrategy 中的变量
缓冲区能力
caps - 类 java.awt.Component.FlipBufferStrategy 中的变量
缓冲能力。
CAPS_LOCK - 类 java.awt.Event 中的静态变量
Caps Lock 键，一个非 ASCII 操作键。
CAPTION - 类 javax.swing.text.html.HTML.Tag 中的静态变量
capture(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
对类型应用 capture 转换。
CAPTURING_PHASE - 接口 org.w3c.dom.events.Event 中的静态变量
当前的事件阶段是捕获阶段。
cardinality() - 类 java.util.BitSet 中的方法
返回此 BitSet 中设置为 true 的位数。
CardLayout - java.awt 中的 类
CardLayout 对象是容器的布局管理器。
CardLayout() - 类 java.awt.CardLayout 的构造方法
创建一个间距大小为 0 的新卡片布局。
CardLayout(int, int) - 类 java.awt.CardLayout 的构造方法
创建一个具有指定水平间距和垂直间距的新卡片布局。
Caret - javax.swing.text 中的 接口
文档视图中的一个位置，它表示文档模型中能插入其他内容的位置。
CARET_POSITION_CHANGED - 类 java.awt.event.InputMethodEvent 中的静态变量
事件类型，它指示输入方法文本中修改的插入点。
CaretEvent - javax.swing.event 中的 类
CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
CaretEvent(Object) - 类 javax.swing.event.CaretEvent 的构造方法
创建一个新的 CaretEvent 对象。
CaretListener - javax.swing.event 中的 接口
用于侦听文本组件插入符的位置更改的侦听器。
caretPositionChanged(InputMethodEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 caretPositionChanged 方法处理 caretPositionChanged 事件。
caretPositionChanged(InputMethodEvent) - 接口 java.awt.event.InputMethodListener 中的方法
当撰写文本中的 caret 发生变化时调用。
caretUpdate(CaretEvent) - 接口 javax.swing.event.CaretListener 中的方法
当插入符的位置被更新时调用。
caretUpdate(CaretEvent) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
处理插入符更新（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_CARET_PROPERTY 和 AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY）。
CASE_INSENSITIVE - 类 java.util.regex.Pattern 中的静态变量
启用不区分大小写的匹配。
CASE_INSENSITIVE_ORDER - 类 java.lang.String 中的静态变量
一个对 String 对象进行排序的 Comparator，作用与 compareToIgnoreCase 相同。
cast(Object) - 类 java.lang.Class 中的方法
将一个对象强制转换成此 Class 对象所表示的类或接口。
catchExceptions - 类 java.awt.event.InvocationEvent 中的变量
如果 dispatch() 捕获了 Throwable 并将其存储在异常实例变量中，则设置为 true。
cbrt(double) - 类 java.lang.Math 中的静态方法
返回 double 值的立方根。
cbrt(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的立方根。
CDATA - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
CDATA - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个 CDATA 节
CDATA_SECTION_ELEMENTS - 类 javax.xml.transform.OutputKeys 中的静态变量
cdata-section-elements = expanded names. cdata-section-elements 指定了由空白分隔的元素名称列表，其中的文本节点子级应使用 CDATA 部分来输出。
CDATA_SECTION_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 CDATASection。
CDATASection - org.w3c.dom 中的 接口
CDATA 节用于转义文本块，该文本块包含的字符如果不转义则会被视为标记。
ceil(double) - 类 java.lang.Math 中的静态方法
返回最小的（最接近负无穷大）double 值，该值大于等于参数，并等于某个整数。
ceil(double) - 类 java.lang.StrictMath 中的静态方法
返回最小的（最接近负无穷大）double 值，该值大于等于参数，并且等于某个整数。
ceiling(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
ceiling(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 中大于等于给定元素的最小元素；如果不存在这样的元素，则返回 null。
ceiling(E) - 类 java.util.TreeSet 中的方法
ceilingEntry(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与大于等于给定键的最小键关联的键-值映射关系；如果不存在这样的条目，则返回 null。
ceilingEntry(K) - 接口 java.util.NavigableMap 中的方法
返回一个键-值映射关系，它与大于等于给定键的最小键关联；如果不存在这样的键，则返回 null。
ceilingEntry(K) - 类 java.util.TreeMap 中的方法
ceilingKey(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
ceilingKey(K) - 接口 java.util.NavigableMap 中的方法
返回大于等于给定键的最小键；如果不存在这样的键，则返回 null。
ceilingKey(K) - 类 java.util.TreeMap 中的方法
CELL_EDITOR_PROPERTY - 类 javax.swing.JTree 中的静态变量
cellEditor 的绑定属性名称。
CELL_RENDERER_PROPERTY - 类 javax.swing.JTree 中的静态变量
cellRenderer 的绑定属性名称。
CELL_RENDERER_PROPERTY - 类 javax.swing.table.TableColumn 中的静态变量
从 Java 2 platform v1.3 开始已过时。
CellEditor - javax.swing 中的 接口
此接口定义任何通用编辑器应该能够实现的方法。
cellEditor - 类 javax.swing.JTable 中的变量
活动单元格编辑器对象，它重写当前单元格占用的屏幕空间，并允许用户更改其内容。
cellEditor - 类 javax.swing.JTree 中的变量
条目编辑器。
cellEditor - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
树的编辑器。
cellEditor - 类 javax.swing.table.TableColumn 中的变量
用于编辑列的数据单元格的编辑器。
CellEditorListener - javax.swing.event 中的 接口
CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口
cellHeight - 类 javax.swing.plaf.basic.BasicListUI 中的变量
cellHeights - 类 javax.swing.plaf.basic.BasicListUI 中的变量
CELLPADDING - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
cellRenderer - 类 javax.swing.JTree 中的变量
用于绘制节点的单元格。
cellRenderer - 类 javax.swing.table.TableColumn 中的变量
用于绘制列的数据单元格的渲染器。
cellRendererChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
CellRendererPane - javax.swing 中的 类
此类被插入在单元格渲染器与使用它们的组件之间。
CellRendererPane() - 类 javax.swing.CellRendererPane 的构造方法
构造一个 CellRendererPane 对象。
CellRendererPane.AccessibleCellRendererPane - javax.swing 中的 类
此类实现 Panel 类的可访问性支持。
CellRendererPane.AccessibleCellRendererPane() - 类 javax.swing.CellRendererPane.AccessibleCellRendererPane 的构造方法
cellSelectionEnabled - 类 javax.swing.JTable 中的变量
从 Java 2 平台 v1.3 开始已过时。
CELLSPACING - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
cellWidth - 类 javax.swing.plaf.basic.BasicListUI 中的变量
CENTER - 类 java.awt.BorderLayout 中的静态变量
中间区域的布局约束（容器中央）。
CENTER - 类 java.awt.FlowLayout 中的静态变量
此值指示每一行组件都应该是居中的。
CENTER - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的中心。
CENTER - 类 java.awt.Label 中的静态变量
指示标签文本应居中。
CENTER - 类 javax.swing.border.TitledBorder 中的静态变量
将标题文本置于边框线的中心。
CENTER - 接口 javax.swing.SwingConstants 中的静态变量
某区域的中心位置。
CENTER - 类 javax.swing.text.html.HTML.Tag 中的静态变量
CENTER_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentY 和 getAlignmentX 的易于使用的常量。
CENTER_BASELINE - 类 java.awt.Font 中的静态变量
布置文本时，在表意文字的脚本（如中文、日文和韩文）中使用的基线。
CENTER_BASELINE - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形的原点与行的中心基线对齐。
centersChildren - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的变量
如果为 true，则子级将在父级中汇总在一起。
Certificate - java.security.cert 中的 类
管理各种身份证书的抽象类。
Certificate(String) - 类 java.security.cert.Certificate 的构造方法
创建指定类型的证书。
Certificate - java.security 中的 接口
已过时。 在 Java 平台中创建了新的证书处理包。此 Certificate 接口已完全废弃，其仍存在是为了能平稳地过渡到新包。
Certificate - javax.security.cert 中的 类
管理各种身份证书的抽象类。
Certificate() - 类 javax.security.cert.Certificate 的构造方法
Certificate.CertificateRep - java.security.cert 中的 类
用于序列化的替换 Certificate 类。
Certificate.CertificateRep(String, byte[]) - 类 java.security.cert.Certificate.CertificateRep 的构造方法
构造带有 Certificate 类型和 Certificate 编码字节的替代 Certificate 类。
CertificateEncodingException - java.security.cert 中的 异常
证书编码异常。
CertificateEncodingException() - 异常 java.security.cert.CertificateEncodingException 的构造方法
构造不带详细消息的 CertificateEncodingException。
CertificateEncodingException(String) - 异常 java.security.cert.CertificateEncodingException 的构造方法
构造带指定详细消息的 CertificateEncodingException。
CertificateEncodingException(String, Throwable) - 异常 java.security.cert.CertificateEncodingException 的构造方法
创建带指定详细消息和原因的 CertificateEncodingException。
CertificateEncodingException(Throwable) - 异常 java.security.cert.CertificateEncodingException 的构造方法
创建带指定原因和详细消息的 CertificateEncodingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateEncodingException - javax.security.cert 中的 异常
证书编码异常。
CertificateEncodingException() - 异常 javax.security.cert.CertificateEncodingException 的构造方法
构造不带详细消息的 CertificateEncodingException。
CertificateEncodingException(String) - 异常 javax.security.cert.CertificateEncodingException 的构造方法
构造带指定详细信息的 CertificateEncodingException。
CertificateException - java.security.cert 中的 异常
此异常指示各种证书问题中的一种。
CertificateException() - 异常 java.security.cert.CertificateException 的构造方法
构造不带详细消息的 Certificate 异常。
CertificateException(String) - 异常 java.security.cert.CertificateException 的构造方法
构造带给定详细消息的 Certificate 异常。
CertificateException(String, Throwable) - 异常 java.security.cert.CertificateException 的构造方法
创建带指定详细消息和原因的 CertificateException。
CertificateException(Throwable) - 异常 java.security.cert.CertificateException 的构造方法
创建带指定原因和详细消息的 CertificateException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateException - javax.security.cert 中的 异常
此异常指示各种证书问题之一。
CertificateException() - 异常 javax.security.cert.CertificateException 的构造方法
构造不带详细消息的 CertificateException。
CertificateException(String) - 异常 javax.security.cert.CertificateException 的构造方法
构造带给定详细消息的 CertificateException。
CertificateExpiredException - java.security.cert 中的 异常
证书过期异常。
CertificateExpiredException() - 异常 java.security.cert.CertificateExpiredException 的构造方法
构造不带详细消息的 CertificateExpiredException。
CertificateExpiredException(String) - 异常 java.security.cert.CertificateExpiredException 的构造方法
构造带指定详细消息的 CertificateExpiredException。
CertificateExpiredException - javax.security.cert 中的 异常
证书过期异常。
CertificateExpiredException() - 异常 javax.security.cert.CertificateExpiredException 的构造方法
构造不带详细消息的 CertificateExpiredException。
CertificateExpiredException(String) - 异常 javax.security.cert.CertificateExpiredException 的构造方法
构造带指定详细信息的 CertificateExpiredException。
CertificateFactory - java.security.cert 中的 类
此类定义了用于从相关的编码中生成证书、证书路径 (CertPath) 和证书撤消列表 (CRL) 对象的 CertificateFactory 功能。
CertificateFactory(CertificateFactorySpi, Provider, String) - 类 java.security.cert.CertificateFactory 的构造方法
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertificateFactorySpi - java.security.cert 中的 类
此类定义了 CertificateFactory 类的服务提供者接口 (SPI)。
CertificateFactorySpi() - 类 java.security.cert.CertificateFactorySpi 的构造方法
CertificateNotYetValidException - java.security.cert 中的 异常
证书尚无效异常。
CertificateNotYetValidException() - 异常 java.security.cert.CertificateNotYetValidException 的构造方法
构造不带详细消息的 CertificateNotYetValidException。
CertificateNotYetValidException(String) - 异常 java.security.cert.CertificateNotYetValidException 的构造方法
构造带指定详细消息的 CertificateNotYetValidException。
CertificateNotYetValidException - javax.security.cert 中的 异常
证书不再有效异常。
CertificateNotYetValidException() - 异常 javax.security.cert.CertificateNotYetValidException 的构造方法
构造不带详细消息的 CertificateNotYetValidException。
CertificateNotYetValidException(String) - 异常 javax.security.cert.CertificateNotYetValidException 的构造方法
构造带指定详细消息的 CertificateNotYetValidException。
CertificateParsingException - java.security.cert 中的 异常
证书解析异常。
CertificateParsingException() - 异常 java.security.cert.CertificateParsingException 的构造方法
构造不带详细消息的 CertificateParsingException。
CertificateParsingException(String) - 异常 java.security.cert.CertificateParsingException 的构造方法
构造带指定详细消息的 CertificateParsingException。
CertificateParsingException(String, Throwable) - 异常 java.security.cert.CertificateParsingException 的构造方法
创建带指定详细消息和原因的 CertificateParsingException。
CertificateParsingException(Throwable) - 异常 java.security.cert.CertificateParsingException 的构造方法
创建带指定原因和详细消息的 CertificateParsingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateParsingException - javax.security.cert 中的 异常
证书解析异常。
CertificateParsingException() - 异常 javax.security.cert.CertificateParsingException 的构造方法
构造不带详细消息的 CertificateParsingException。
CertificateParsingException(String) - 异常 javax.security.cert.CertificateParsingException 的构造方法
构造带指定详细信息的 CertificateParsingException。
certificates() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 所有证书的一个副本。
CertPath - java.security.cert 中的 类
不可变的证书序列（证书路径）。
CertPath(String) - 类 java.security.cert.CertPath 的构造方法
创建指定类型的 CertPath。
CertPath.CertPathRep - java.security.cert 中的 类
用于序列化的替换 CertPath 类。
CertPath.CertPathRep(String, byte[]) - 类 java.security.cert.CertPath.CertPathRep 的构造方法
创建具有指定证书路径类型和编码形式的 CertPathRep。
CertPathBuilder - java.security.cert 中的 类
构建证书路径（也称为证书链）的类。
CertPathBuilder(CertPathBuilderSpi, Provider, String) - 类 java.security.cert.CertPathBuilder 的构造方法
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertPathBuilderException - java.security.cert 中的 异常
指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
CertPathBuilderException() - 异常 java.security.cert.CertPathBuilderException 的构造方法
创建详细消息为 null 的 CertPathBuilderException。
CertPathBuilderException(String) - 异常 java.security.cert.CertPathBuilderException 的构造方法
创建带给定详细消息的 CertPathBuilderException。
CertPathBuilderException(Throwable) - 异常 java.security.cert.CertPathBuilderException 的构造方法
创建包装指定 throwable 的 CertPathBuilderException。
CertPathBuilderException(String, Throwable) - 异常 java.security.cert.CertPathBuilderException 的构造方法
创建带指定详细消息和原因的 CertPathBuilderException。
CertPathBuilderResult - java.security.cert 中的 接口
证书路径生成器算法的结果的规范。
CertPathBuilderSpi - java.security.cert 中的 类
CertPathBuilder 类的服务提供者接口 (SPI)。
CertPathBuilderSpi() - 类 java.security.cert.CertPathBuilderSpi 的构造方法
默认的构造方法。
CertPathParameters - java.security.cert 中的 接口
证书路径算法参数的规范。
CertPathTrustManagerParameters - javax.net.ssl 中的 类
CertPathParameters 的包装器。
CertPathTrustManagerParameters(CertPathParameters) - 类 javax.net.ssl.CertPathTrustManagerParameters 的构造方法
根据指定的 parameters 构造新的 CertPathTrustManagerParameters。
CertPathValidator - java.security.cert 中的 类
验证证书路径（也称为证书链）的类。
CertPathValidator(CertPathValidatorSpi, Provider, String) - 类 java.security.cert.CertPathValidator 的构造方法
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertPathValidatorException - java.security.cert 中的 异常
指示在验证一个证书路径时遇到了某种问题的异常。
CertPathValidatorException() - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建不带详细消息的 CertPathValidatorException。
CertPathValidatorException(String) - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建带给定详细消息的 CertPathValidatorException。
CertPathValidatorException(Throwable) - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建包装指定 throwable 的 CertPathValidatorException。
CertPathValidatorException(String, Throwable) - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建带指定详细消息和 cause 的 CertPathValidatorException。
CertPathValidatorException(String, Throwable, CertPath, int) - 异常 java.security.cert.CertPathValidatorException 的构造方法
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。
CertPathValidatorResult - java.security.cert 中的 接口
证书路径验证器算法的结果的规范。
CertPathValidatorSpi - java.security.cert 中的 类
CertPathValidator 类的服务提供者接口 (SPI)。
CertPathValidatorSpi() - 类 java.security.cert.CertPathValidatorSpi 的构造方法
默认的构造方法。
CertSelector - java.security.cert 中的 接口
一个定义了一套选择 Certificate 的标准的选择器。
CertStore - java.security.cert 中的 类
用于从存储库中获取 Certificate 和 CRL 的类。
CertStore(CertStoreSpi, Provider, String, CertStoreParameters) - 类 java.security.cert.CertStore 的构造方法
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。
CertStoreException - java.security.cert 中的 异常
指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
CertStoreException() - 异常 java.security.cert.CertStoreException 的构造方法
创建详细消息为 null 的 CertStoreException。
CertStoreException(String) - 异常 java.security.cert.CertStoreException 的构造方法
创建带指定详细消息的 CertStoreException。
CertStoreException(Throwable) - 异常 java.security.cert.CertStoreException 的构造方法
创建包装指定 throwable 的 CertStoreException。
CertStoreException(String, Throwable) - 异常 java.security.cert.CertStoreException 的构造方法
创建带指定详细消息和 cause 的 CertStoreException。
CertStoreParameters - java.security.cert 中的 接口
CertStore 参数的规范。
CertStoreSpi - java.security.cert 中的 类
CertStore 类的服务提供者接口 (SPI)。
CertStoreSpi(CertStoreParameters) - 类 java.security.cert.CertStoreSpi 的构造方法
唯一的构造方法。
CHANGE - 类 javax.swing.event.DocumentEvent.EventType 中的静态变量
更改类型。
change(int, int, AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
更改内容。
CHANGED - 类 java.awt.dnd.DragSourceContext 中的静态变量
updateCurrentCursor() 使用的 int 值，指示用户操作已改变。
ChangedCharSetException - javax.swing.text 中的 异常
顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。
ChangedCharSetException(String, boolean) - 异常 javax.swing.text.ChangedCharSetException 的构造方法
changedUpdate(DocumentEvent) - 接口 javax.swing.event.DocumentListener 中的方法
给出属性或属性集发生了更改的通知。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FlowView 中的方法
发出通知，通知文档中此视图负责的某个位置的属性已更改。
changedUpdate(FlowView, DocumentEvent, Rectangle) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
发出通知，通知文档中此视图负责的某个位置的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.GlyphView 中的方法
发出通知，通知文档此视图负责的位置处的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.BlockView 中的方法
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.ImageView 中的方法
当 Elements 属性已更改时调用。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.InlineView 中的方法
发出通知，通知文档此视图负责的位置处的属性已更改。
changedUpdate(DocumentEvent) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.LabelView 中的方法
发出通知，通知文档此视图负责的位置处的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.ParagraphView 中的方法
发出通知，通知文档中此视图负责的某个位置的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.PlainView 中的方法
发出通知，通知文档中此视图负责的某个位置的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
发出通知，通知文档此视图负责的位置处的属性已更改。
changedUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.WrappedPlainView 中的方法
发出文档中此视图负责的位置上的属性已发生更改的通知。
changeEvent - 类 javax.swing.AbstractButton 中的变量
每个按钮实例都只需要一个 ChangeEvent，因为事件的唯一状态是源属性。
changeEvent - 类 javax.swing.AbstractCellEditor 中的变量
changeEvent - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的变量
由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。
changeEvent - 类 javax.swing.DefaultBoundedRangeModel 中的变量
由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。
changeEvent - 类 javax.swing.DefaultButtonModel 中的变量
每个按钮模型实例只需要一个 ChangeEvent，因为事件的唯一状态是源属性。
changeEvent - 类 javax.swing.DefaultSingleSelectionModel 中的变量
ChangeEvent - javax.swing.event 中的 类
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
ChangeEvent(Object) - 类 javax.swing.event.ChangeEvent 的构造方法
构造一个 ChangeEvent 对象。
changeEvent - 类 javax.swing.JProgressBar 中的变量
每个实例只需要一个 ChangeEvent，因为事件的唯一感兴趣属性是不可变源，即进度条。
changeEvent - 类 javax.swing.JSlider 中的变量
一个滑块实例仅需要一个 ChangeEvent，因为该事件唯一（只读）的状态是源属性。
changeEvent - 类 javax.swing.JTabbedPane 中的变量
由于事件仅有的（只读）状态是源属性，因此每个 TabPane 实例只需要一个 ChangeEvent。
changeEvent - 类 javax.swing.MenuSelectionManager 中的变量
每个按钮模型实例只需要一个 ChangeEvent，因为事件的惟一状态是 source 属性。
changeEvent - 类 javax.swing.table.DefaultTableColumnModel 中的变量
更改事件（只需要一个）
changeEvent - 类 javax.swing.text.DefaultCaret 中的变量
此模型的更改事件。
changeEvent - 类 javax.swing.text.StyleContext.NamedStyle 中的变量
由于事件的惟一状态（只读）为源属性，因此每个模型实例只需要一个 ChangeEvent。
changeHighlight(Object, int, int) - 类 javax.swing.text.DefaultHighlighter 中的方法
更改高亮显示。
changeHighlight(Object, int, int) - 接口 javax.swing.text.Highlighter 中的方法
更改给定的高亮显示，以使其横跨文档的不同部分。
changeInfo - 类 javax.naming.event.NamingEvent 中的变量
包含关于生成此事件的更改的信息。
changeListener - 类 javax.swing.AbstractButton 中的变量
按钮模型的 changeListener。
ChangeListener - javax.swing.event 中的 接口
定义一个侦听 ChangeEvent 的对象。
changeListener - 类 javax.swing.JProgressBar 中的变量
侦听由进度条的模型发送的更改事件，并将其再次指派到在此进度条上注册的更改事件侦听器。
changeListener - 类 javax.swing.JSlider 中的变量
changeListener（无前缀）是添加到滑块模型的侦听器。
changeListener - 类 javax.swing.JTabbedPane 中的变量
changeListener 是添加到模型中的侦听器。
changeListener - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的变量
changeListener - 类 javax.swing.plaf.basic.BasicMenuUI 中的变量
changeListener - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的变量
changeListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
changeSelection(int, int, boolean, boolean) - 类 javax.swing.JTable 中的方法
根据 toggle 和 extend 这两个标志的状态，更新表的选择模型。
changeShape(Dimension, Dimension, Dimension) - 类 javax.swing.Box.Filler 中的方法
更改此形状的大小请求。
changeSupport - 类 javax.swing.AbstractAction 中的变量
如果已经注册了任意 PropertyChangeListener，则 changeSupport 字段负责描述它们。
changeSupport - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
用于接收通知的注册侦听器。
changeToParentDirectory() - 类 javax.swing.JFileChooser 中的方法
将要设置的目录更改为当前目录的父级。
changeUpdate() - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
更新元素结构，以响应文档中的更改。
Channel - java.nio.channels 中的 接口
用于 I/O 操作的连接。
channel() - 类 java.nio.channels.FileLock 中的方法
返回文件通道，此锁定保持在该通道的文件上。
channel() - 类 java.nio.channels.SelectionKey 中的方法
返回为之创建此键的通道。
channel - 类 javax.sound.midi.VoiceStatus 中的变量
在其上演奏此声音的 MIDI 通道。
CHANNEL_PRESSURE - 类 javax.sound.midi.ShortMessage 中的静态变量
CHANNEL_PRESSURE (Aftertouch) 消息的命令值（0xD0 或 208）
ChannelBinding - org.ietf.jgss 中的 类
此类封装关于调用者提供的通道绑定信息的概念。
ChannelBinding(InetAddress, InetAddress, byte[]) - 类 org.ietf.jgss.ChannelBinding 的构造方法
使用用户提供的地址信息和数据创建 ChannelBinding 对象。
ChannelBinding(byte[]) - 类 org.ietf.jgss.ChannelBinding 的构造方法
创建不带任何说明性信息的 ChannelBinding 对象。
Channels - java.nio.channels 中的 类
针对信道和流的实用工具方法。
channels - 类 javax.sound.sampled.AudioFormat 中的变量
使用此格式的音频信道数（单声道为 1，立体声为 2）。
CHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 CHAR 的 Java 编程语言中的常量（有时称为类型代码）。
CHAR_REPLACEMENT - 类 java.awt.font.TextAttribute 中的静态变量
用于取代字符的字体标准字型显示的用户定义字形的属性键。
CHAR_UNDEFINED - 类 java.awt.event.KeyEvent 中的静态变量
KEY_PRESSED 和 KEY_RELEASED 事件没有映射到一个有效的 Unicode 字符时使用此值作为 keyChar 值。
Character - java.lang 中的 类
Character 类在对象中包装一个基本类型 char 的值。
Character(char) - 类 java.lang.Character 的构造方法
构造一个新分配的 Character 对象，用以表示指定的 char 值。
CHARACTER - 接口 javax.accessibility.AccessibleText 中的静态变量
用于指示应获取的文本部分是一个字符的常量。
CHARACTER - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Character 的值。
Character.Subset - java.lang 中的 类
此类的实例表示 Unicode 字符集的特定子集。
Character.Subset(String) - 类 java.lang.Character.Subset 的构造方法
构造一个新的 Subset 实例。
Character.UnicodeBlock - java.lang 中的 类
表示 Unicode 规范中字符块的一系列字符子集。
CHARACTER_SET_ENCODING - 类 javax.xml.soap.SOAPMessage 中的静态变量
指定 SOAP Message 的字符类型编码。
CharacterCodingException - java.nio.charset 中的 异常
出现字符编码或解码错误时，抛出此经过检查的异常。
CharacterCodingException() - 异常 java.nio.charset.CharacterCodingException 的构造方法
构造此类的一个实例。
CharacterData - org.w3c.dom 中的 接口
CharacterData 接口使用属性集合和用于访问 DOM 中字符数据的方法扩展节点。
CharacterIterator - java.text 中的 接口
此接口定义了对文本进行双向迭代的协议。
Characters - javax.xml.stream.events 中的 接口
此方法将描述 Characters 事件的接口。
CHARACTERS - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一些字符
characters(char[], int, int) - 接口 org.xml.sax.ContentHandler 中的方法
接收字符数据的通知。
characters(char[], int, int) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收字符数据的通知。
characters(char[], int, int) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收元素内字符数据的通知。
characters(char[], int, int) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收元素中字符数据的通知。
characters(char[], int, int) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
characters(char[], int, int) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个字符数据事件。
characters(char[], int, int) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 字符事件。
CharArrayReader - java.io 中的 类
此类实现一个可用作字符输入流的字符缓冲区。
CharArrayReader(char[]) - 类 java.io.CharArrayReader 的构造方法
根据指定的 char 数组创建一个 CharArrayReader。
CharArrayReader(char[], int, int) - 类 java.io.CharArrayReader 的构造方法
根据指定的 char 数组创建一个 CharArrayReader。
CharArrayWriter - java.io 中的 类
此类实现一个可用作 Writer 的字符缓冲区。
CharArrayWriter() - 类 java.io.CharArrayWriter 的构造方法
创建一个新的 CharArrayWriter。
CharArrayWriter(int) - 类 java.io.CharArrayWriter 的构造方法
创建一个具有指定初始大小的新 CharArrayWriter。
charAt(int) - 接口 java.lang.CharSequence 中的方法
返回指定索引的 char 值。
charAt(int) - 类 java.lang.String 中的方法
返回指定索引处的 char 值。
charAt(int) - 类 java.lang.StringBuffer 中的方法
charAt(int) - 类 java.nio.CharBuffer 中的方法
读取相对于当前位置的给定索引处的字符。
charAt(int) - 类 javax.swing.text.Segment 中的方法
返回指定索引的 char 值。
charAttr - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的变量
CharBuffer - java.nio 中的 类
字符缓冲区。
CharConversionException - java.io 中的 异常
用于字符转换异常的基类。
CharConversionException() - 异常 java.io.CharConversionException 的构造方法
此异常不提供详细消息。
CharConversionException(String) - 异常 java.io.CharConversionException 的构造方法
此异常提供详细消息。
charCount(int) - 类 java.lang.Character 中的静态方法
确定表示指定字符（Unicode 代码点）所需的 char 值的数量。
CharHolder - org.omg.CORBA 中的 类
Char 的 Holder。
CharHolder() - 类 org.omg.CORBA.CharHolder 的构造方法
构造一个新的 CharHolder 对象，将其 value 字段初始化为 0。
CharHolder(char) - 类 org.omg.CORBA.CharHolder 的构造方法
为给定 char 值构造一个新的 CharHolder 对象。
CharSeqHelper - org.omg.CORBA 中的 类
CharSeq 的 Helper。
CharSeqHelper() - 类 org.omg.CORBA.CharSeqHelper 的构造方法
CharSeqHolder - org.omg.CORBA 中的 类
CharSeq 的 Holder。
CharSeqHolder() - 类 org.omg.CORBA.CharSeqHolder 的构造方法
CharSeqHolder(char[]) - 类 org.omg.CORBA.CharSeqHolder 的构造方法
CharSequence - java.lang 中的 接口
CharSequence 是 char 值的一个可读序列。
Charset - java.nio.charset 中的 类
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。
Charset(String, String[]) - 类 java.nio.charset.Charset 的构造方法
使用给定的规范名称和别名集合初始化新 charset。
charset() - 类 java.nio.charset.CharsetDecoder 中的方法
返回创建此解码器的 charset。
charset() - 类 java.nio.charset.CharsetEncoder 中的方法
返回创建此编码器的 charset。
CharsetDecoder - java.nio.charset 中的 类
能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。
CharsetDecoder(Charset, float, float) - 类 java.nio.charset.CharsetDecoder 的构造方法
初始化新的解码器。
CharsetEncoder - java.nio.charset 中的 类
能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。
CharsetEncoder(Charset, float, float, byte[]) - 类 java.nio.charset.CharsetEncoder 的构造方法
初始化新的编码器。
CharsetEncoder(Charset, float, float) - 类 java.nio.charset.CharsetEncoder 的构造方法
初始化新的编码器。
charsetForName(String) - 类 java.nio.charset.spi.CharsetProvider 中的方法
用给定的 charset 名称获取 charset。
CharsetProvider - java.nio.charset.spi 中的 类
Charset 服务提供者类。
CharsetProvider() - 类 java.nio.charset.spi.CharsetProvider 的构造方法
初始化新的 charset 提供者。
charsets() - 类 java.nio.charset.spi.CharsetProvider 中的方法
创建在此提供者所支持的 charset 上进行迭代的迭代器。
charStream - 类 javax.sql.rowset.BaseRowSet 中的变量
将由方法 getCharacterStream 返回的 Reader 对象，该方法在 ResultSet 接口中指定。
charsWidth(char[], int, int) - 类 java.awt.FontMetrics 中的方法
返回显示此 Font 中指定字符数组的总 advance width。
charValue() - 类 java.lang.Character 中的方法
返回此 Character 对象的值。
charWidth(int) - 类 java.awt.FontMetrics 中的方法
返回此 Font 中指定字符的 advance width。
charWidth(char) - 类 java.awt.FontMetrics 中的方法
返回此 Font 中指定字符的 advance width。
check(Certificate, Collection<String>) - 类 java.security.cert.PKIXCertPathChecker 中的方法
使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
check(String, URL, String, MLetContent) - 类 javax.management.loading.MLet 中的方法
当扩展此服务来支持缓存和版本控制时，要重写此方法。
CHECK_BOX - 类 javax.accessibility.AccessibleRole 中的静态变量
可以被选中或不被选中的选项，它针对当前状态提供了单独的指示符。
CHECK_BOX - 类 javax.swing.plaf.synth.Region 中的静态变量
CheckBox 的 region。
CHECK_BOX_MENU_ITEM - 类 javax.swing.plaf.synth.Region 中的静态变量
CheckBoxMenuItem 的 region。
checkAccept(String, int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程从指定的主机和端口号接受套接字连接，则抛出 SecurityException。
checkAccess(Thread) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程修改 thread 参数，则抛出 SecurityException。
checkAccess(ThreadGroup) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程修改线程组参数，则抛出 SecurityException。
checkAccess() - 类 java.lang.Thread 中的方法
判定当前运行的线程是否有权修改该线程。
checkAccess() - 类 java.lang.ThreadGroup 中的方法
确定当前运行的线程是否有权修改此线程组。
checkAccess() - 类 java.util.logging.LogManager 中的方法
检查使用当前上下文来修改日志配置是否受信任。
checkAll() - 类 java.awt.MediaTracker 中的方法
查看此媒体跟踪器正在跟踪的所有图像是否已完成加载。
checkAll(boolean) - 类 java.awt.MediaTracker 中的方法
检查此媒体跟踪器正在跟踪的所有图像是否都已完成加载。
checkAwtEventQueueAccess() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问 AWT 事件队列，则抛出 SecurityException。
Checkbox - java.awt 中的 类
复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
Checkbox() - 类 java.awt.Checkbox 的构造方法
使用空字符串标签创建一个复选框。
Checkbox(String) - 类 java.awt.Checkbox 的构造方法
使用指定标签创建一个复选框。
Checkbox(String, boolean) - 类 java.awt.Checkbox 的构造方法
使用指定标签创建一个复选框，并将它设置为指定状态。
Checkbox(String, boolean, CheckboxGroup) - 类 java.awt.Checkbox 的构造方法
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。
Checkbox(String, CheckboxGroup, boolean) - 类 java.awt.Checkbox 的构造方法
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。
Checkbox.AccessibleAWTCheckbox - java.awt 中的 类
此类实现对 Checkbox 类的可访问性支持。
Checkbox.AccessibleAWTCheckbox() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 的构造方法
CheckboxGroup - java.awt 中的 类
CheckboxGroup 类用于集合 Checkbox 按钮集。
CheckboxGroup() - 类 java.awt.CheckboxGroup 的构造方法
创建 CheckboxGroup 的一个新实例。
CheckboxMenuItem - java.awt 中的 类
此类表示一个可包括在菜单中的复选框。
CheckboxMenuItem() - 类 java.awt.CheckboxMenuItem 的构造方法
创建具有空标签的复选框菜单项。
CheckboxMenuItem(String) - 类 java.awt.CheckboxMenuItem 的构造方法
创建具有指定标签的复选框菜单项。
CheckboxMenuItem(String, boolean) - 类 java.awt.CheckboxMenuItem 的构造方法
创建 具有指定标签和状态的复选框菜单项。
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem - java.awt 中的 类
用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 的构造方法
checkClientTrusted(X509Certificate[], String) - 接口 javax.net.ssl.X509TrustManager 中的方法
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。
checkClosed() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
如果已经关闭流，则抛出 IOException。
checkConnect(String, int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程打开到指定主机和端口号的套接字连接，则抛出 SecurityException。
checkConnect(String, int, Object) - 类 java.lang.SecurityManager 中的方法
如果不允许指定的安全上下文打开与指定主机和端口号的套接字连接，则抛出 SecurityException。
checkCreateClassLoader() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程创建新的类加载器，则抛出 SecurityException。
checkDelete(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程删除指定的文件，则抛出 SecurityException。
CHECKED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象当前被选中。
CHECKED - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
checkedCollection(Collection<E>, Class<E>) - 类 java.util.Collections 中的静态方法
返回指定 collection 的一个动态类型安全视图。
CheckedInputStream - java.util.zip 中的 类
需要维护所读取数据校验和的输入流。
CheckedInputStream(InputStream, Checksum) - 类 java.util.zip.CheckedInputStream 的构造方法
使用指定校验和创建输入流。
checkedList(List<E>, Class<E>) - 类 java.util.Collections 中的静态方法
返回指定列表的一个动态类型安全视图。
checkedMap(Map<K, V>, Class<K>, Class<V>) - 类 java.util.Collections 中的静态方法
返回指定映射的一个动态类型安全视图。
CheckedOutputStream - java.util.zip 中的 类
需要维护写入数据校验和的输出流。
CheckedOutputStream(OutputStream, Checksum) - 类 java.util.zip.CheckedOutputStream 的构造方法
使用指定校验和创建输出流。
checkedSet(Set<E>, Class<E>) - 类 java.util.Collections 中的静态方法
返回指定 set 的一个动态类型安全视图。
checkedSortedMap(SortedMap<K, V>, Class<K>, Class<V>) - 类 java.util.Collections 中的静态方法
返回指定有序映射的一个动态类型安全视图。
checkedSortedSet(SortedSet<E>, Class<E>) - 类 java.util.Collections 中的静态方法
返回指定有序 set 的一个动态类型安全视图。
checkError() - 类 java.io.PrintStream 中的方法
刷新流并检查其错误状态。
checkError() - 类 java.io.PrintWriter 中的方法
如果流没有关闭，则刷新流且检查其错误状态。
checkExec(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程创建一个子进程，则抛出 SecurityException。
checkExit(int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程使用特定的状态码暂停 Java 虚拟机，则抛出 SecurityException。
checkForClickInExpandControl(TreePath, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果 mouseX 和 mouseY 位于 row 的展开/折叠区域内，则此方法将切换行。
checkGuard(Object) - 接口 java.security.Guard 中的方法
确定是否允许访问受保护的 object 对象。
checkGuard(Object) - 类 java.security.Permission 中的方法
为某权限实现 guard 接口。
checkHorizontalKey(int, String) - 类 javax.swing.AbstractButton 中的方法
验证 key 参数是否为 horizontalAlignment 和 horizontalTextPosition 属性的合法值。
checkHorizontalKey(int, String) - 类 javax.swing.JLabel 中的方法
验证该键是否为 horizontalAlignment 属性的合法值。
checkIcon - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
checkID(int) - 类 java.awt.MediaTracker 中的方法
检查由此媒体跟踪器跟踪且使用指定标识符标记的所有图像是否已完成加载。
checkID(int, boolean) - 类 java.awt.MediaTracker 中的方法
检查由此媒体跟踪器跟踪且使用指定标识符标记的所有图像是否已完成加载。
checkImage(Image, ImageObserver) - 类 java.awt.Component 中的方法
返回指定图像屏幕表示的构造状态。
checkImage(Image, int, int, ImageObserver) - 类 java.awt.Component 中的方法
返回指定图像屏幕表示的构造状态。
checkImage(Image, int, int, ImageObserver) - 类 java.awt.Toolkit 中的方法
指示正准备显示的指定图像的构造状态。
checkLink(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程动态链接由字符串参数文件指定的库代码，则抛出 SecurityException。
checkListen(int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程等待与指定本地端口号进行连接的请求，则抛出 SecurityException。
checkMaxDegree(int) - 类 javax.management.relation.RoleInfo 中的方法
如果 value 参数小于或等于期望的最大程度，则返回 true；否则返回 false。
checkMemberAccess(Class<?>, int) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问程序，则抛出 SecurityException。
checkMinDegree(int) - 类 javax.management.relation.RoleInfo 中的方法
如果 value 参数大于或等于期望的最小程度，则返回 true；否则返回 false。
checkMulticast(InetAddress) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播，则抛出 SecurityException。
checkMulticast(InetAddress, byte) - 类 java.lang.SecurityManager 中的方法
已过时。 由 #checkPermission(java.security.Permission) 取代
checkOpacity(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
checkPackageAccess(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问由参数指定的包，则抛出 SecurityException。
checkPackageDefinition(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程在参数指定的包中定义类，则抛出 SecurityException。
checkPainter() - 类 javax.swing.text.GlyphView 中的方法
检查是否存在字形 painter。
checkPermission(Permission) - 类 java.lang.SecurityManager 中的方法
如果基于当前有效的安全策略，不允许执行根据给定权限所指定的请求访问，则抛出 SecurityException。
checkPermission(Permission, Object) - 类 java.lang.SecurityManager 中的方法
如果拒绝指定的安全上下文访问由给定权限所指定的资源，则抛出 SecurityException。
checkPermission(Permission) - 类 java.security.AccessControlContext 中的方法
基于当前生效的安全策略和此对象中的上下文确定是否允许指定权限指示的访问请求。
checkPermission(Permission) - 类 java.security.AccessController 中的静态方法
基于当前 AccessControlContext 和安全策略确定是否允许指定权限所指示的访问请求。
checkPermission(Principal, Permission) - 接口 java.security.acl.Acl 中的方法
检查指定的主体是否具有指定的权限。
checkPermission(Permission) - 接口 java.security.acl.AclEntry 中的方法
检查指定的权限是否为此项中权限集合的一部分。
checkPrintJobAccess() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程发起一个打印作业请求，则抛出 SecurityException。
checkPropertiesAccess() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问或修改系统属性，则抛出 SecurityException。
checkPropertyAccess(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问具有指定的 key 名的系统属性，则抛出 SecurityException。
checkRead(FileDescriptor) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程从指定的文件描述符进行读取，则抛出 SecurityException。
checkRead(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程读取由字符串参数指定的文件，则抛出 SecurityException。
checkRead(String, Object) - 类 java.lang.SecurityManager 中的方法
如果不允许指定的安全上下文读取由字符串参数所指定的文件，则抛出 SecurityException。
checkReadParamBandSettings(ImageReadParam, int, int) - 类 javax.imageio.ImageReader 中的静态方法
reader 可用来测试 ImageReadParam 的源和目标 band 设置的有效性的实用方法。
checkRoleReading(String, String) - 类 javax.management.relation.RelationService 中的方法
检查给定 Role 能否以给定类型的关系进行读取。
checkRoleReading(String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检查给定 Role 能否在给定类型的关系中读取。
checkRoleWriting(Role, String, Boolean) - 类 javax.management.relation.RelationService 中的方法
检查给定 Role 能否以给定类型的关系进行设置。
checkRoleWriting(Role, String, Boolean) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检查给定 Role 能否在给定类型的关系中设置。
checkSecurityAccess(String) - 类 java.lang.SecurityManager 中的方法
确定是应该允许还是拒绝具有指定权限目标名的权限。
checkServerTrusted(X509Certificate[], String) - 接口 javax.net.ssl.X509TrustManager 中的方法
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。
checkSetFactory() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程设置由 ServerSocket 或 Socket 使用的套接字工厂，或者由 URL 使用的流处理程序工厂，则抛出 SecurityException。
Checksum - java.util.zip 中的 接口
表示数据校验和的接口。
checkSystemClipboardAccess() - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程访问系统剪贴板，则抛出 SecurityException。
checkTopLevelWindow(Object) - 类 java.lang.SecurityManager 中的方法
如果不受信任的调用线程调出由 window 参数指出的顶层窗口，则返回 false。
checkValidity() - 类 java.security.cert.X509Certificate 中的方法
检查证书目前是否有效。
checkValidity(Date) - 类 java.security.cert.X509Certificate 中的方法
检查给定的日期是否处于证书的有效期内。
checkValidity() - 类 javax.security.cert.X509Certificate 中的方法
检查证书目前是否有效。
checkValidity(Date) - 类 javax.security.cert.X509Certificate 中的方法
检查指定的日期是否处于证书的有效期内。
checkVerticalKey(int, String) - 类 javax.swing.AbstractButton 中的方法
验证 key 参数是否为垂直属性的合法值。
checkVerticalKey(int, String) - 类 javax.swing.JLabel 中的方法
验证该键是否为 verticalAlignment 或 verticalTextPosition 属性的合法值。
checkWrite(FileDescriptor) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程写入指定的文件描述符，则抛出 SecurityException。
checkWrite(String) - 类 java.lang.SecurityManager 中的方法
如果不允许调用线程写由字符串参数指定的文件，则抛出 SecurityException。
CHEROKEE - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Cherokee”Unicode 字符块的常量。
CHILD_NODE_OF - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个对象的子节点。
CHILD_NODE_OF_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 CHILD_NODE_OF 关系已更改。
CHILD_POLICY_ALL - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示某个元素必须具有按顺序排列的其每个合法子元素的单个实例。
CHILD_POLICY_CHOICE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示元素必须具有从其合法子元素中选择的零个或一个子元素。
CHILD_POLICY_EMPTY - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示某个元素不具有任何子元素。
CHILD_POLICY_MAX - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
最大有效 CHILD_POLICY_* 常量，将用于范围检查。
CHILD_POLICY_REPEAT - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示元素必须具有其唯一合法子元素的零个或多个实例。
CHILD_POLICY_SEQUENCE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示元素必须具有其所有合法子元素的实例序列。
CHILD_POLICY_SOME - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getChildPolicy 返回的常量，指示元素必须具有按顺序排列的其每个合法子元素的零个或一个实例。
childAdded(NodeChangeEvent) - 接口 java.util.prefs.NodeChangeListener 中的方法
添加子节点时调用此方法。
childAlloc - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的变量
用于子级分配区域以避免创建大量垃圾的形状。
childAllocation(int, Rectangle) - 类 javax.swing.text.BoxView 中的方法
为子视图分配一个区域。
childAllocation(int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
返回给定子级的分配区域。
childChanged(AsyncBoxView.ChildState) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
子级已更改的通知。
childDeserializedHook(Object, BeanContextSupport.BCSChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法
由 readObject 利用新近反序列化的子级和 BCSChild 调用。
childIndices - 类 javax.swing.event.TreeModelEvent 中的变量
标识子节点所在位置的索引。
childJustAddedHook(Object, BeanContextSupport.BCSChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以重写此方法，以便在已经添加子对象之后，且在发生事件通知之前，只扩展 add() 语义。
childJustRemovedHook(Object, BeanContextSupport.BCSChild) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
在已成功移除子级之后，从超类的子级移除操作中调用。
childJustRemovedHook(Object, BeanContextSupport.BCSChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以重写此方法，以便在已经移除子对象之后，且在发生事件通知之前，只扩展 remove() 语义。
childRemoved(NodeChangeEvent) - 接口 java.util.prefs.NodeChangeListener 中的方法
移除子节点时调用此方法。
children - 类 java.beans.beancontext.BeanContextMembershipEvent 中的变量
受此事件通知影响的子级的列表。
children - 类 java.beans.beancontext.BeanContextSupport 中的变量
protected HashMap children 字段的所有访问在该对象上都将是同步的。
children - 类 javax.swing.event.TreeModelEvent 中的变量
已被移除的子节点。
children() - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
必要时创建子类以加载此子节点。
children() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
以 Enumeration 形式返回接收方的子级。
children() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
以 Enumeration 的形式返回接收者的子级。
children() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
以 Enumeration 的形式返回接收者的子级。
children - 类 javax.swing.tree.DefaultMutableTreeNode 中的变量
子节点的数组，如果此节点没有子节点，则可以为 null
children() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回此节点的子节点的正向枚举。
children() - 接口 javax.swing.tree.TreeNode 中的方法
以 Enumeration 的形式返回接收者的子节点。
childrenAdded(BeanContextMembershipEvent) - 接口 java.beans.beancontext.BeanContextMembershipListener 中的方法
在将一个子级或子级列表添加到此侦听器在其中注册的 BeanContext 中时调用。
childrenNames() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.childrenNames() 中的规范实现 children 方法。
childrenNames() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点相对于此节点的子节点名称。
childrenNamesSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
返回此首选项节点的子节点名称。
childrenRemoved(BeanContextMembershipEvent) - 接口 java.beans.beancontext.BeanContextMembershipListener 中的方法
在将一个子级或子级列表从此侦听器在其中注册的 BeanContext 中移除时调用。
childSpi(String) - 类 java.util.prefs.AbstractPreferences 中的方法
返回此首选项节点的指定子节点；如果该子节点尚未存在，则创建它。
childValue(T) - 类 java.lang.InheritableThreadLocal 中的方法
在创建子线程时，计算这个可继承线程局部变量的子线程的初始值，将该值作为父线程值的一个函数。
childValue - 类 javax.swing.JTree.DynamicUtilTreeNode 中的变量
用于创建子节点的值。
CHINA - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
CHINESE - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
Choice - java.awt 中的 类
Choice 类表示一个弹出式选择菜单。
Choice() - 类 java.awt.Choice 的构造方法
创建一个新的选择菜单。
Choice.AccessibleAWTChoice - java.awt 中的 类
此类实现对 Choice 类的可访问性支持。
Choice.AccessibleAWTChoice() - 类 java.awt.Choice.AccessibleAWTChoice 的构造方法
ChoiceCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。
ChoiceCallback(String, String[], int, boolean) - 类 javax.security.auth.callback.ChoiceCallback 的构造方法
构造一个 ChoiceCallback，带有提示、选项列表、默认选项和指定选项列表是否允许进行多重选择的布尔值。
ChoiceFormat - java.text 中的 类
ChoiceFormat 允许将格式应用到某个范围的数。
ChoiceFormat(String) - 类 java.text.ChoiceFormat 的构造方法
根据 limit 和相应的 format（基于模式）构造。
ChoiceFormat(double[], String[]) - 类 java.text.ChoiceFormat 的构造方法
根据 limit 和相应的 format 构造。
choices - 类 java.sql.DriverPropertyInfo 中的变量
如果可以从特定一组值中选择 DriverPropertyInfo.value 字段的值，则返回可能值组成的数组；否则返回 null。
CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识预定义文件过滤器列表的更改，用户可从该列表中进行选择。
chooseClientAlias(String[], Principal[], Socket) - 接口 javax.net.ssl.X509KeyManager 中的方法
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。
chooseEngineClientAlias(String[], Principal[], SSLEngine) - 类 javax.net.ssl.X509ExtendedKeyManager 中的方法
选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。
chooseEngineServerAlias(String, Principal[], SSLEngine) - 类 javax.net.ssl.X509ExtendedKeyManager 中的方法
选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。
chooser - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的变量
在其上安装此 BasicColorChooserUI 的 JColorChooser。
CHOOSER_PANELS_PROPERTY - 类 javax.swing.JColorChooser 中的静态变量
chooserPanel 数组属性名。
chooseServerAlias(String, Principal[], Socket) - 接口 javax.net.ssl.X509KeyManager 中的方法
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。
CHORD - 类 java.awt.geom.Arc2D 中的静态变量
闭合类型，用于通过从弧段的起始点到弧段的结束点画一条直线来闭合的弧。
CHOU_1 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #1 信封尺寸，142 mm × 332 mm。
CHOU_2 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #2 信封尺寸，119 mm × 277 mm。
CHOU_3 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #3 信封尺寸，120 mm by 235 mm。
CHOU_30 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #30 信封尺寸，92 mm by 235 mm。
CHOU_4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #4 信封尺寸，90 mm × 205 mm。
CHOU_40 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Chou ("long") #40 信封尺寸，90 mm × 225 mm。
Chromaticity - javax.print.attribute.standard 中的 类
Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
Chromaticity(int) - 类 javax.print.attribute.standard.Chromaticity 的构造方法
构造具有给定整数值的新色度枚举值。
chunkLength - 类 java.net.HttpURLConnection 中的变量
使用存储块编码流模式进行输出时的存储块长度。
Cipher - javax.crypto 中的 类
此类为加密和解密提供密码功能。
Cipher(CipherSpi, Provider, String) - 类 javax.crypto.Cipher 的构造方法
创建 Cipher 对象。
CipherInputStream - javax.crypto 中的 类
CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。
CipherInputStream(InputStream, Cipher) - 类 javax.crypto.CipherInputStream 的构造方法
根据 InputStream 和 Cipher 构造 CipherInputStream。
CipherInputStream(InputStream) - 类 javax.crypto.CipherInputStream 的构造方法
根据 InputStream 构造 CipherInputStream，不指定 Cipher。
CipherOutputStream - javax.crypto 中的 类
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。
CipherOutputStream(OutputStream, Cipher) - 类 javax.crypto.CipherOutputStream 的构造方法
从 OutputStream 和 Cipher 构造 CipherOutputStream。
CipherOutputStream(OutputStream) - 类 javax.crypto.CipherOutputStream 的构造方法
从 OutputStream 构造 CipherOutputStream，不指定 Cipher。
CipherSpi - javax.crypto 中的 类
此类为 Cipher 类定义了服务提供者接口 (SPI)。
CipherSpi() - 类 javax.crypto.CipherSpi 的构造方法
CITE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
CJK_COMPATIBILITY - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Compatibility”Unicode 字符块的常量。
CJK_COMPATIBILITY_FORMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Compatibility Forms”Unicode 字符块的常量。
CJK_COMPATIBILITY_IDEOGRAPHS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Compatibility Ideographs”Unicode 字符块的常量。
CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Compatibility Ideographs Supplement”Unicode 字符块的常量。
CJK_RADICALS_SUPPLEMENT - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Radicals Supplement”Unicode 字符块的常量。
CJK_SYMBOLS_AND_PUNCTUATION - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Symbols and Punctuation”Unicode 字符块的常量。
CJK_UNIFIED_IDEOGRAPHS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Unified Ideographs”Unicode 字符块的常量。
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Unified Ideographs Extension A”Unicode 字符块的常量。
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“CJK Unified Ideographs Extension B”Unicode 字符块的常量。
Class<T> - java.lang 中的 类
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
CLASS - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
CLASS_ABSTRACT - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是抽象。
CLASS_ATTRIBUTE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
当与类属性名称连在一起时，使用 JSR 200 规范中指定的布局语言指出该属性的格式。
CLASS_COLORSPACECONVERSION - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是颜色空间变换。
CLASS_DEVICELINK - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是设备链接。
CLASS_DISPLAY - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是显示。
CLASS_INPUT - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是输入。
CLASS_LOADING_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
ClassLoadingMXBean 的 ObjectName 的字符串表示形式。
CLASS_NAMEDCOLOR - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是指定的颜色。
CLASS_OUTPUT - 类 java.awt.color.ICC_Profile 中的静态变量
Profile 类是输出。
CLASS_PATH - 类 java.util.jar.Attributes.Name 中的静态变量
Class-Path 的 Name 对象具有的属性。
classattr() - 类 javax.management.Query 中的静态方法
返回一个新的类属性表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
ClassCastException - java.lang 中的 异常
当试图将对象强制转换为不是实例的子类时，抛出该异常。
ClassCastException() - 异常 java.lang.ClassCastException 的构造方法
构造不带详细消息的 ClassCastException。
ClassCastException(String) - 异常 java.lang.ClassCastException 的构造方法
构造带指定详细消息的 ClassCastException。
ClassCircularityError - java.lang 中的 错误
当初始化类时检测到类的循环调用的时候，抛出该错误。
ClassCircularityError() - 错误 java.lang.ClassCircularityError 的构造方法
构造不带详细消息的 ClassCircularityError。
ClassCircularityError(String) - 错误 java.lang.ClassCircularityError 的构造方法
构造带指定详细消息的 ClassCircularityError。
ClassDefinition - java.lang.instrument 中的 类
此类用作 Instrumentation.redefineClasses 方法的参数锁定。
ClassDefinition(Class<?>, byte[]) - 类 java.lang.instrument.ClassDefinition 的构造方法
使用提供的类和类文件字节创建一个新的 ClassDefinition 绑定。
classDepth(String) - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
ClassDesc - javax.rmi.CORBA 中的 类
此类用于对 IIOP 上的 java.lang.Class 对象进行编组。
ClassDesc() - 类 javax.rmi.CORBA.ClassDesc 的构造方法
classEquals(Class, Class) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
测试以查看两个类对象或其名称是否相等。
classFactory - 类 javax.naming.Reference 中的变量
包含用来创建此 Reference 所引用的对象实例的工厂类名称。
classFactoryLocation - 类 javax.naming.Reference 中的变量
包含工厂类的位置。
ClassFileTransformer - java.lang.instrument 中的 接口
一个提供此接口的实现以转换类文件的代理。
ClassFormatError - java.lang 中的 错误
当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
ClassFormatError() - 错误 java.lang.ClassFormatError 的构造方法
构造不带详细消息的 ClassFormatError。
ClassFormatError(String) - 错误 java.lang.ClassFormatError 的构造方法
构造带指定详细消息的 ClassFormatError。
CLASSID - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ClassLoader - java.lang 中的 类
类加载器是负责加载类的对象。
ClassLoader(ClassLoader) - 类 java.lang.ClassLoader 的构造方法
使用指定的、用于委托操作的父类加载器创建新的类加载器。
ClassLoader() - 类 java.lang.ClassLoader 的构造方法
使用方法 getSystemClassLoader() 返回的 ClassLoader 创建一个新的类加载器，将该加载器作为父类加载器。
classLoaderDepth() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
ClassLoaderRepository - javax.management.loading 中的 接口
此接口的实例用于保持在 MBean Server 中注册的 ClassLoader 的列表。
ClassLoadingMXBean - java.lang.management 中的 接口
用于 Java 虚拟机的类加载系统的管理接口。
classname - 异常 java.io.InvalidClassException 中的变量
无效类的名称。
className - 类 javax.naming.Reference 中的变量
包含此 Reference 所引用的对象类的完全限定名称。
ClassNotFoundException - java.lang 中的 异常
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
ClassNotFoundException() - 异常 java.lang.ClassNotFoundException 的构造方法
构造不带详细消息的 ClassNotFoundException。
ClassNotFoundException(String) - 异常 java.lang.ClassNotFoundException 的构造方法
构造带指定详细消息的 ClassNotFoundException。
ClassNotFoundException(String, Throwable) - 异常 java.lang.ClassNotFoundException 的构造方法
构造一个 ClassNotFoundException，它带有指定详细消息和加载类时引发的可选异常。
clean(ObjID[], long, VMID, boolean) - 接口 java.rmi.dgc.DGC 中的方法
洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。
CLEAR - 类 java.awt.AlphaComposite 中的静态变量
目标色和目标 alpha 值都被清除（Porter-Duff Clear 规则）。
Clear - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 CLEAR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
clear() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 removeAll() 取代。
clear() - 类 java.awt.RenderingHints 中的方法
清除所有键/值对的 RenderingHints 对象。
clear() - 类 java.beans.beancontext.BeanContextSupport 中的方法
清除子对象（不受支持的）实现，这些实现在分层结构锁定和 "children" 受保护字段上必须是同步的
clear() - 类 java.lang.ref.Reference 中的方法
清除此引用对象。
clear() - 类 java.nio.Buffer 中的方法
清除此缓冲区。
clear() - 类 java.security.Provider 中的方法
清除此 provider，使其不再包含用来查找由该 provider 实现的设施的属性。
clear() - 类 java.util.AbstractCollection 中的方法
移除此 collection 中的所有元素（可选操作）。
clear() - 类 java.util.AbstractList 中的方法
从此列表中移除所有元素（可选操作）。
clear() - 类 java.util.AbstractMap 中的方法
从此映射中移除所有映射关系（可选操作）。
clear() - 类 java.util.AbstractQueue 中的方法
移除此队列中的所有元素。
clear() - 类 java.util.ArrayDeque 中的方法
从此双端队列中移除所有元素。
clear() - 类 java.util.ArrayList 中的方法
移除此列表中的所有元素。
clear(int) - 类 java.util.BitSet 中的方法
将索引指定处的位设置为 false。
clear(int, int) - 类 java.util.BitSet 中的方法
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为 false。
clear() - 类 java.util.BitSet 中的方法
将此 BitSet 中的所有位设置为 false。
clear() - 类 java.util.Calendar 中的方法
将此 Calendar 的所日历字段值和时间值（从历元至现在的毫秒偏移量）设置成未定义。
clear(int) - 类 java.util.Calendar 中的方法
将此 Calendar 的给定日历字段值和时间值（从历元至现在的毫秒偏移量）设置成未定义。
clear() - 接口 java.util.Collection 中的方法
移除此 collection 中的所有元素（可选操作）。
clear() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
自动移除此队列中的所有元素。
clear() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
从该映射中移除所有映射关系
clear() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
从此 set 中移除所有元素。
clear() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
从此列表移除所有元素。
clear() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
移除此 set 中的所有元素。
clear() - 类 java.util.concurrent.DelayQueue 中的方法
自动移除此延迟队列的所有元素。
clear() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
以原子方式 (atomically) 从此双端队列移除所有元素。
clear() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
从队列彻底移除所有元素。
clear() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
完全移除此队列中的所有元素。
clear() - 类 java.util.concurrent.SynchronousQueue 中的方法
不执行任何操作。
clear() - 类 java.util.EnumMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 java.util.HashMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 java.util.HashSet 中的方法
从此 set 中移除所有元素。
clear() - 类 java.util.Hashtable 中的方法
将此哈希表清空，使其不包含任何键。
clear() - 类 java.util.IdentityHashMap 中的方法
从映射中移除所有映射关系。
clear() - 类 java.util.jar.Attributes 中的方法
从此 Map 中移除所有属性。
clear() - 类 java.util.jar.Manifest 中的方法
清除此 Manifest 中的主 Attributes 和条目。
clear() - 类 java.util.LinkedHashMap 中的方法
从该映射中移除所有映射关系。
clear() - 类 java.util.LinkedList 中的方法
从此列表中移除所有元素。
clear() - 接口 java.util.List 中的方法
从列表中移除所有元素（可选操作）。
clear() - 接口 java.util.Map 中的方法
从此映射中移除所有映射关系（可选操作）。
clear() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.clear() 中的规范实现 clear 方法。
clear() - 类 java.util.prefs.Preferences 中的方法
移除此首选项节点中的所有首选项（键-值关联）。
clear() - 类 java.util.PriorityQueue 中的方法
从此优先级队列中移除所有元素。
clear() - 接口 java.util.Set 中的方法
移除此 set 中的所有元素（可选操作）。
clear() - 类 java.util.TreeMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 java.util.TreeSet 中的方法
移除此 set 中的所有元素。
clear() - 类 java.util.Vector 中的方法
从此向量中移除所有元素。
clear() - 类 java.util.WeakHashMap 中的方法
从此映射中移除所有映射关系。
clear() - 类 javax.accessibility.AccessibleRelationSet 中的方法
从当前关系集中移除所有关系。
clear() - 类 javax.accessibility.AccessibleStateSet 中的方法
从当前状态集中移除所有状态。
clear() - 接口 javax.management.openmbean.TabularData 中的方法
从此 TabularData 实例中移除所有 CompositeData 值（即各行）。
clear() - 类 javax.management.openmbean.TabularDataSupport 中的方法
从此 TabularDataSupport 实例中移除所有行。
clear() - 接口 javax.naming.directory.Attribute 中的方法
从此属性移除所有值。
clear() - 类 javax.naming.directory.BasicAttribute 中的方法
clear() - 类 javax.naming.Reference 中的方法
从此引用中删除所有地址。
clear() - 接口 javax.print.attribute.AttributeSet 中的方法
从此属性集中移除所有属性。
clear() - 类 javax.print.attribute.HashAttributeSet 中的方法
从此属性集中移除所有属性。
clear() - 类 javax.script.SimpleBindings 中的方法
从此映射中移除所有映射关系（可选操作）。
clear() - 类 javax.swing.ActionMap 中的方法
从此 ActionMap 中移除所有映射关系。
clear() - 类 javax.swing.ComponentInputMap 中的方法
从此对象中移除所有映射关系。
clear() - 类 javax.swing.DefaultListModel 中的方法
从此列表中移除所有元素。
clear() - 类 javax.swing.InputMap 中的方法
从此 InputMap 中移除所有映射关系。
CLEAR - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
CLEAR - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
clear() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
取消设置所有未定义的字段。
clear() - 类 org.omg.CORBA.Environment 中的方法
清除此 Environment 对象中的异常。
clear() - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 清除属性列表。
clear() - 类 org.xml.sax.helpers.AttributesImpl 中的方法
为了重用而清除属性列表。
clearAbortRequest() - 类 javax.imageio.ImageReader 中的方法
清除任何以前的中止请求。
clearAbortRequest() - 类 javax.imageio.ImageWriter 中的方法
清除任何以前的中止请求。
clearAccessibleSelection() - 类 java.awt.List.AccessibleAWTList 中的方法
清除对象中的选择，从而对象中没有选择任何项。
clearAccessibleSelection() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
清除该对象中的选择，使该对象中没有子对象被选择。
clearAccessibleSelection() - 接口 javax.accessibility.AccessibleSelection 中的方法
清除对象中的选项，使该对象中没有选中的子对象。
clearAccessibleSelection() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
清除对象中的选择，使对象中任何子对象都未被选中。
clearAccessibleSelection() - 类 javax.swing.JList.AccessibleJList 中的方法
清除对象中的选择，从而对象中没有选择任何项。
clearAccessibleSelection() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
清除对象中的选择，从而对象中没有选择任何项。
clearAccessibleSelection() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
清除对象中的选择，从而对象中没有选择任何项。
clearAccessibleSelection() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
clearAccessibleSelection() - 类 javax.swing.JTable.AccessibleJTable 中的方法
清除该对象中的选择，使该对象中不存在选择的子对象。
clearAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
清除对象中的选择，这样此对象中什么也没有选择。
clearAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree 中的方法
清除对象中的选择，这样此对象中什么也没有选择。
clearAssertionStatus() - 类 java.lang.ClassLoader 中的方法
将此类加载器的默认断言状态设置为 false，并放弃与此类加载器关联的所有默认包或类断言状态设置。
clearAutoscroll() - 类 java.awt.dnd.DropTarget 中的方法
清除自动滚动
clearBatch() - 接口 java.sql.Statement 中的方法
清空此 Statement 对象的当前 SQL 命令列表。
clearBit(int) - 类 java.math.BigInteger 中的方法
返回其值与清除了指定位的此 BigInteger 等效的 BigInteger。
clearCache() - 类 java.util.ResourceBundle 中的静态方法
从已经使用调用者的类加载器加载的缓存中移除所有资源包。
clearCache(ClassLoader) - 类 java.util.ResourceBundle 中的静态方法
从已经使用给定类加载器加载的缓存中移除所有资源包。
clearChanged() - 类 java.util.Observable 中的方法
指示对象不再改变，或者它已对其所有的观察者通知了最近的改变，所以 hasChanged 方法将返回 false。
clearContent() - 类 javax.xml.soap.AttachmentPart 中的方法
清除此 AttachmentPart 对象的内容。
clearError() - 类 java.io.PrintStream 中的方法
清除此流的内部错误状态。
clearError() - 类 java.io.PrintWriter 中的方法
清除此流的错误状态。
clearGlobalFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
在 Java 和本机级别清除全局焦点所有者。
clearIconCache() - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法
clearIconCache() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
clearParameters() - 接口 java.sql.PreparedStatement 中的方法
立即清除当前参数值。
clearParameters() - 类 javax.sql.rowset.BaseRowSet 中的方法
清除所有此 RowSet 对象的内部参数表示形式的当前参数值，这些参数值将在执行此 RowSet 对象的命令时在其中设置这些参数。
clearParameters() - 接口 javax.sql.RowSet 中的方法
清除为此 RowSet 对象命令设置的参数。
clearParameters() - 类 javax.xml.transform.Transformer 中的方法
清除所有通过 setParameter 设置的参数。
clearPassword() - 类 javax.crypto.spec.PBEKeySpec 中的方法
清空密码的内部副本。
clearPassword() - 类 javax.security.auth.callback.PasswordCallback 中的方法
清除获取到的密码。
clearProperty(String) - 类 java.lang.System 中的静态方法
移除指定键指示的系统属性。
clearRect(int, int, int, int) - 类 java.awt.Graphics 中的方法
通过使用当前绘图表面的背景色进行填充来清除指定的矩形。
clearRect(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.clearRect。
clearSelectedPath() - 类 javax.swing.MenuSelectionManager 中的方法
告知菜单选项，以关闭和取消选择所有菜单组件。
clearSelection() - 类 javax.swing.ButtonGroup 中的方法
清除选中内容，从而没有选择 ButtonGroup 中的任何按钮。
clearSelection() - 类 javax.swing.DefaultListSelectionModel 中的方法
将该选择更改为空集。
clearSelection() - 类 javax.swing.DefaultSingleSelectionModel 中的方法
clearSelection() - 类 javax.swing.JList 中的方法
清除选择；调用此方法后，isSelectionEmpty 将返回 true。
clearSelection() - 类 javax.swing.JTable 中的方法
取消选中所有已选定的行和列。
clearSelection() - 类 javax.swing.JTree 中的方法
清除该选择。
clearSelection() - 接口 javax.swing.ListSelectionModel 中的方法
将该选择更改为空集。
clearSelection() - 接口 javax.swing.SingleSelectionModel 中的方法
清除选项（返回 -1）。
clearSelection() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
清空当前的 selection。
clearSelection() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
清空当前的选择。
clearTextShiftOffset() - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
clearToggledPaths() - 类 javax.swing.JTree 中的方法
清除切换的树路径的缓存。
clearWarnings() - 接口 java.sql.Connection 中的方法
清除为此 Connection 对象报告的所有警告。
clearWarnings() - 接口 java.sql.ResultSet 中的方法
清除在此 ResultSet 对象上报告的所有警告。
clearWarnings() - 接口 java.sql.Statement 中的方法
清除在此 Statement 对象上报告的所有警告。
CLICK - 接口 javax.accessibility.AccessibleAction 中的静态变量
导致某个组件执行其默认动作的动作。
clickCount - 类 java.awt.Event 中的变量
对于 MOUSE_DOWN 事件来说，此字段指示连续点击的次数。
clickCountToStart - 类 javax.swing.DefaultCellEditor 中的变量
指定开始编辑所需单击次数的整数。
clientClosed(RMIConnection) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
关闭由 makeClient 创建的客户端连接时调用的方法。
ClientInfoStatus - java.sql 中的 枚举
无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。
ClientRequestInfo - org.omg.PortableInterceptor 中的 接口
客户端请求 interceptor 可访问的请求信息。
ClientRequestInfoOperations - org.omg.PortableInterceptor 中的 接口
客户端请求 interceptor 可访问的请求信息。
ClientRequestInterceptor - org.omg.PortableInterceptor 中的 接口
客户端 interceptor。
ClientRequestInterceptorOperations - org.omg.PortableInterceptor 中的 接口
客户端的请求 interceptor。
clip(Shape) - 类 java.awt.Graphics2D 中的方法
将当前 Clip 与指定 Shape 的内部区域相交，并将 Clip 设置为所得的交集。
Clip - javax.sound.sampled 中的 接口
Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。
Clipboard - java.awt.datatransfer 中的 类
此类实现一种使用剪切/复制/粘贴操作传输数据的机制。
Clipboard(String) - 类 java.awt.datatransfer.Clipboard 的构造方法
创建剪贴板对象。
ClipboardOwner - java.awt.datatransfer 中的 接口
为提供数据到剪贴板的类所定义的接口。
clipRect(int, int, int, int) - 类 java.awt.Graphics 中的方法
将当前剪贴区与指定的矩形相交。
clipRect(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.clipRect。
Clob - java.sql 中的 接口
SQL 类型 CLOB 在 JavaTM 编程语言中的映射关系。
CLOB - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 CLOB 的 Java 编程语言中的常量（有时称为类型代码）。
clockSequence() - 类 java.util.UUID 中的方法
与此 UUID 相关联的时钟序列值。
clone() - 类 java.awt.BufferCapabilities 中的方法
clone() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的副本。
clone() - 类 java.awt.font.TextLayout 中的方法
创建此 TextLayout 的副本。
clone() - 类 java.awt.font.TextMeasurer 中的方法
clone() - 类 java.awt.geom.AffineTransform 中的方法
返回此 AffineTransform 对象的副本。
clone() - 类 java.awt.geom.Area 中的方法
返回此 Area 对象的精确副本。
clone() - 类 java.awt.geom.CubicCurve2D 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Dimension2D 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Line2D 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Path2D 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Path2D.Double 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Path2D.Float 中的方法
创建一个与此对象具有相同类的新对象。
clone() - 类 java.awt.geom.Point2D 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 java.awt.geom.QuadCurve2D 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 java.awt.geom.RectangularShape 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 java.awt.GridBagConstraints 中的方法
创建此网格包约束（grid bag constraint）的副本。
clone() - 类 java.awt.image.ImageFilter 中的方法
复制此对象。
clone() - 类 java.awt.image.Kernel 中的方法
复制此对象。
clone() - 类 java.awt.image.renderable.ParameterBlock 中的方法
创建 ParameterBlock 的一个副本。
clone() - 类 java.awt.image.renderable.RenderContext 中的方法
对 RenderContext 进行复制。
clone() - 类 java.awt.ImageCapabilities 中的方法
clone() - 类 java.awt.Insets 中的方法
创建此对象的副本。
clone() - 类 java.awt.JobAttributes 中的方法
创建并返回此 JobAttributes 的一个副本。
clone() - 类 java.awt.PageAttributes 中的方法
创建并返回此 PageAttributes 的一个副本。
clone() - 类 java.awt.print.PageFormat 中的方法
制作此 PageFormat 的副本，使它与此 PageFormat 具有相同的内容。
clone() - 类 java.awt.print.Paper 中的方法
创建此 Paper 的一个副本，内容与此 Paper 相同。
clone() - 类 java.awt.RenderingHints 中的方法
创建此 RenderingHints 对象的一个副本，它与此 RenderingHints 对象具有相同的内容。
clone() - 类 java.lang.Enum 中的方法
抛出 CloneNotSupportedException。
clone() - 类 java.lang.Object 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.net.HttpCookie 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.rmi.server.UnicastRemoteObject 中的方法
返回与初始对象不同的远程对象的副本。
clone() - 接口 java.security.acl.AclEntry 中的方法
复制此 ACL 项。
clone() - 接口 java.security.cert.CertPathBuilderResult 中的方法
对此 CertPathBuilderResult 进行复制。
clone() - 接口 java.security.cert.CertPathParameters 中的方法
对此 CertPathParameters 进行复制。
clone() - 接口 java.security.cert.CertPathValidatorResult 中的方法
对此 CertPathValidatorResult 进行复制。
clone() - 接口 java.security.cert.CertSelector 中的方法
对此 CertSelector 进行复制。
clone() - 接口 java.security.cert.CertStoreParameters 中的方法
对此 CertStoreParameters 进行复制。
clone() - 类 java.security.cert.CollectionCertStoreParameters 中的方法
返回此对象的副本。
clone() - 接口 java.security.cert.CRLSelector 中的方法
对此 CRLSelector 进行复制。
clone() - 类 java.security.cert.LDAPCertStoreParameters 中的方法
返回此对象的副本。
clone() - 类 java.security.cert.PKIXCertPathChecker 中的方法
返回此对象的副本。
clone() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回此对象的副本。
clone() - 类 java.security.cert.PKIXParameters 中的方法
对此 PKIXParameters 对象进行复制。
clone() - 类 java.security.cert.X509CertSelector 中的方法
返回此对象的副本。
clone() - 类 java.security.cert.X509CRLSelector 中的方法
返回此对象的副本。
clone() - 类 java.security.MessageDigest 中的方法
如果实现是可复制的，则返回一个副本。
clone() - 类 java.security.MessageDigestSpi 中的方法
如果实现是可复制的，则返回一个副本。
clone() - 类 java.security.Signature 中的方法
如果此实现可以复制，则返回副本。
clone() - 类 java.security.SignatureSpi 中的方法
如果此实现可以复制，则返回一个副本。
clone() - 类 java.text.BreakIterator 中的方法
创建此迭代器的副本。
clone() - 接口 java.text.CharacterIterator 中的方法
创建此迭代器的一个副本
clone() - 类 java.text.ChoiceFormat 中的方法
重写 Cloneable
clone() - 类 java.text.Collator 中的方法
重写 Cloneable
clone() - 类 java.text.DateFormat 中的方法
重写 Cloneable
clone() - 类 java.text.DateFormatSymbols 中的方法
重写 Cloneable。
clone() - 类 java.text.DecimalFormat 中的方法
标准重写；没有语义上的变化。
clone() - 类 java.text.DecimalFormatSymbols 中的方法
标准重写。
clone() - 类 java.text.Format 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.text.MessageFormat 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.text.NumberFormat 中的方法
重写 Cloneable
clone() - 类 java.text.RuleBasedCollator 中的方法
标准重写，无语义变化。
clone() - 类 java.text.SimpleDateFormat 中的方法
创建此 SimpleDateFormat 的一个副本。
clone() - 类 java.text.StringCharacterIterator 中的方法
创建此迭代器的副本。
clone() - 类 java.util.AbstractMap 中的方法
返回此 AbstractMap 实例的浅表副本：不复制键和值本身。
clone() - 类 java.util.ArrayDeque 中的方法
返回此双端队列的副本。
clone() - 类 java.util.ArrayList 中的方法
返回此 ArrayList 实例的浅表副本。
clone() - 类 java.util.BitSet 中的方法
复制此 BitSet，生成一个与之相等的新 BitSet。
clone() - 类 java.util.Calendar 中的方法
创建并返回此对象的一个副本。
clone() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此 ConcurrentSkipListMap 实例的浅表副本。
clone() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回此 ConcurrentSkipListSet 实例的浅表副本。
clone() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表的浅表副本。
clone() - 类 java.util.Date 中的方法
返回此对象的副本。
clone() - 类 java.util.EnumMap 中的方法
返回此枚举映射的浅表副本。
clone() - 类 java.util.EnumSet 中的方法
返回 set 的副本。
clone() - 类 java.util.GregorianCalendar 中的方法
clone() - 类 java.util.HashMap 中的方法
返回此 HashMap 实例的浅表副本：并不复制键和值本身。
clone() - 类 java.util.HashSet 中的方法
返回此 HashSet 实例的浅表副本：并没有复制这些元素本身。
clone() - 类 java.util.Hashtable 中的方法
创建此哈希表的浅表副本。
clone() - 类 java.util.IdentityHashMap 中的方法
返回此标识哈希映射的浅表副本：不复制键和值本身。
clone() - 类 java.util.jar.Attributes 中的方法
返回 Attributes 的副本，实现方法如下: public Object clone() { return new Attributes(this); } 由于属性名称和值本身不可变，因此可以安全地修改返回的 Attributes，而不会影响原始值。
clone() - 类 java.util.jar.Manifest 中的方法
返回 Manifest 的浅表副本。
clone() - 类 java.util.LinkedList 中的方法
返回此 LinkedList 的浅表副本。
clone() - 类 java.util.Locale 中的方法
重写 Cloneable。
clone() - 类 java.util.SimpleTimeZone 中的方法
返回此 SimpleTimeZone 实例的一个副本。
clone() - 类 java.util.TimeZone 中的方法
创建此 TimeZone 的一个副本。
clone() - 类 java.util.TreeMap 中的方法
返回此 TreeMap 实例的浅表副本。
clone() - 类 java.util.TreeSet 中的方法
返回 TreeSet 实例的浅表副本。
clone() - 类 java.util.Vector 中的方法
返回向量的一个副本。
clone() - 类 java.util.zip.ZipEntry 中的方法
返回此条目的副本。
clone() - 类 javax.crypto.Mac 中的方法
如果提供者实现可以复制，则返回一个副本。
clone() - 类 javax.crypto.MacSpi 中的方法
如果此实现可以复制，则返回一个副本。
clone() - 接口 javax.management.Descriptor 中的方法
返回一个与此描述符相等的描述符。
clone() - 类 javax.management.ImmutableDescriptor 中的方法
返回一个与此描述符相等的描述符。
clone() - 类 javax.management.MBeanAttributeInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanConstructorInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanNotificationInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanOperationInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.MBeanParameterInfo 中的方法
返回此实例的浅表副本。
clone() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
返回作为 Descriptor 副本的新 Descriptor。
clone() - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 中的方法
创建并返回新的 ModelMBeanAttributeInfo，它是此 ModelMBeanAttributeInfo 的副本。
clone() - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 中的方法
创建并返回新 ModelMBeanConstructorInfo，它是此 ModelMBeanConstructorInfo 的副本。
clone() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
创建并返回此对象的一个副本。
clone() - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
返回此实例的浅表复制。
clone() - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 中的方法
创建并返回新 ModelMBeanNotificationInfo，它是此 ModelMBeanNotificationInfo 的副本。
clone() - 类 javax.management.modelmbean.ModelMBeanOperationInfo 中的方法
创建并返回新的 ModelMBeanOperationInfo，它是此 ModelMBeanOperationInfo 的副本。
clone() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例的一个副本：通过调用 super.clone()，然后副本此基础映射，即可得到该副本。
clone() - 类 javax.management.relation.Role 中的方法
复制角色对象。
clone() - 类 javax.management.relation.RoleUnresolved 中的方法
复制此对象。
clone() - 类 javax.naming.CompositeName 中的方法
生成此复合名称的副本。
clone() - 类 javax.naming.CompoundName 中的方法
创建此组合名称的副本。
clone() - 接口 javax.naming.directory.Attribute 中的方法
对属性进行复制。
clone() - 接口 javax.naming.directory.Attributes 中的方法
对属性集进行复制。
clone() - 类 javax.naming.directory.BasicAttribute 中的方法
clone() - 类 javax.naming.directory.BasicAttributes 中的方法
clone() - 类 javax.naming.ldap.LdapName 中的方法
生成此名称的新副本。
clone() - 接口 javax.naming.Name 中的方法
生成此名称的新副本。
clone() - 类 javax.naming.Reference 中的方法
使用地址的类名称列表、类工厂名称和类工厂位置创建此引用的副本。
clone() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的一个副本，该副本保留了枚举值的语义，它是与此枚举值相同的对象。
clone() - 类 javax.sound.midi.MetaMessage 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 javax.sound.midi.MidiMessage 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 javax.sound.midi.ShortMessage 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 javax.sound.midi.SysexMessage 中的方法
创建一个与此对象具有相同类和相同内容的新对象。
clone() - 类 javax.swing.AbstractAction 中的方法
复制抽象操作。
clone() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回此选择模型的具有相同选择的副本。
clone() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
复制 AbstractFormatter。
clone() - 类 javax.swing.text.DefaultFormatter 中的方法
创建此 DefaultFormatter 的副本。
clone(Element, Element) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
创建此元素的一个副本，使其具有不同的父级。
clone() - 类 javax.swing.text.EditorKit 中的方法
创建此编辑器工具包的副本。
clone() - 类 javax.swing.text.ElementIterator 中的方法
复制 ElementIterator。
clone() - 类 javax.swing.text.GlyphView 中的方法
创建一个浅表复制。
clone() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
创建编辑器工具包的一个副本。
clone() - 类 javax.swing.text.InternationalFormatter 中的方法
创建该 DefaultFormatter 的一个副本。
clone() - 类 javax.swing.text.Segment 中的方法
创建一个浅表副本。
clone() - 类 javax.swing.text.SimpleAttributeSet 中的方法
复制属性集。
clone() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
复制属性集。
clone() - 类 javax.swing.text.StyledEditorKit 中的方法
创建此编辑器工具包的一个副本。
clone() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
重写以复制 public。
clone() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回具有相同 selection 的此对象的副本。
clone() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
创建并返回此对象的一个副本。
Cloneable - java.lang 中的 接口
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
cloneNode(boolean) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的副本。
cloneNode(boolean) - 接口 org.w3c.dom.Node 中的方法
返回此节点的副本，即允当节点的一般复制构造方法。
CloneNotSupportedException - java.lang 中的 异常
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
CloneNotSupportedException() - 异常 java.lang.CloneNotSupportedException 的构造方法
构造不带详细消息的 CloneNotSupportedException。
CloneNotSupportedException(String) - 异常 java.lang.CloneNotSupportedException 的构造方法
构造带指定详细消息的 CloneNotSupportedException。
cloneWithSource(Object) - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回接收方的副本，但带有将成为 newSource 的源。
closable - 类 javax.swing.JInternalFrame 中的变量
窗体可关闭。
close() - 类 java.awt.SplashScreen 中的方法
隐藏闪现屏幕、关闭窗口并释放所有相关资源。
close() - 类 java.beans.XMLDecoder 中的方法
此方法关闭与此流相关联的输入流。
close() - 类 java.beans.XMLEncoder 中的方法
此方法调用 flush，写入结束后文，然后关闭与此流有关的输出流。
close() - 类 java.io.BufferedInputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.io.BufferedReader 中的方法
close() - 类 java.io.BufferedWriter 中的方法
close() - 类 java.io.ByteArrayInputStream 中的方法
关闭 ByteArrayInputStream 无效。
close() - 类 java.io.ByteArrayOutputStream 中的方法
关闭 ByteArrayOutputStream 无效。
close() - 类 java.io.CharArrayReader 中的方法
关闭该流并释放与之关联的所有系统资源。
close() - 类 java.io.CharArrayWriter 中的方法
关闭该流。
close() - 接口 java.io.Closeable 中的方法
关闭此流并释放与此流关联的所有系统资源。
close() - 类 java.io.FileInputStream 中的方法
关闭此文件输入流并释放与此流有关的所有系统资源。
close() - 类 java.io.FileOutputStream 中的方法
关闭此文件输出流并释放与此流有关的所有系统资源。
close() - 类 java.io.FilterInputStream 中的方法
关闭此输入流并释放与此流关联的所有系统资源。
close() - 类 java.io.FilterOutputStream 中的方法
关闭此输出流并释放与此流有关的所有系统资源。
close() - 类 java.io.FilterReader 中的方法
close() - 类 java.io.FilterWriter 中的方法
close() - 类 java.io.InputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.io.InputStreamReader 中的方法
close() - 接口 java.io.ObjectInput 中的方法
关闭输入流。
close() - 类 java.io.ObjectInputStream 中的方法
关闭输入流。
close() - 接口 java.io.ObjectOutput 中的方法
关闭该流。
close() - 类 java.io.ObjectOutputStream 中的方法
关闭流。
close() - 类 java.io.OutputStream 中的方法
关闭此输出流并释放与此流有关的所有系统资源。
close() - 类 java.io.OutputStreamWriter 中的方法
close() - 类 java.io.PipedInputStream 中的方法
关闭此管道输入流并释放与该流相关的所有系统资源。
close() - 类 java.io.PipedOutputStream 中的方法
关闭此管道输出流并释放与此流有关的所有系统资源。
close() - 类 java.io.PipedReader 中的方法
关闭此传送流并释放与该流相关的所有系统资源。
close() - 类 java.io.PipedWriter 中的方法
关闭此管道输出流并释放与此流相关的所有系统资源。
close() - 类 java.io.PrintStream 中的方法
关闭流。
close() - 类 java.io.PrintWriter 中的方法
关闭该流并释放与之关联的所有系统资源。
close() - 类 java.io.PushbackInputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.io.PushbackReader 中的方法
关闭该流并释放与之关联的所有系统资源。
close() - 类 java.io.RandomAccessFile 中的方法
关闭此随机访问文件流并释放与该流关联的所有系统资源。
close() - 类 java.io.Reader 中的方法
关闭该流并释放与之关联的所有资源。
close() - 类 java.io.SequenceInputStream 中的方法
关闭此输入流并释放与此流关联的所有系统资源。
close() - 类 java.io.StringReader 中的方法
关闭该流并释放与之关联的所有系统资源。
close() - 类 java.io.StringWriter 中的方法
关闭 StringWriter 无效。
close() - 类 java.io.Writer 中的方法
关闭此流，但要先刷新它。
close() - 类 java.net.DatagramSocket 中的方法
关闭此数据报套接字。
close() - 类 java.net.DatagramSocketImpl 中的方法
关闭套接字。
close() - 类 java.net.ServerSocket 中的方法
关闭此套接字。
close() - 类 java.net.Socket 中的方法
关闭此套接字。
close() - 类 java.net.SocketImpl 中的方法
关闭此套接字。
close() - 接口 java.nio.channels.Channel 中的方法
关闭此通道。
close() - 接口 java.nio.channels.InterruptibleChannel 中的方法
关闭此通道。
close() - 类 java.nio.channels.Selector 中的方法
关闭此选择器。
close() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
关闭此通道。
close() - 类 java.nio.channels.spi.AbstractSelector 中的方法
关闭此选择器。
close() - 接口 java.sql.Connection 中的方法
立即释放此 Connection 对象的数据库和 JDBC 资源，而不是等待它们被自动释放。
close() - 接口 java.sql.ResultSet 中的方法
立即释放此 ResultSet 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
close() - 接口 java.sql.Statement 中的方法
立即释放此 Statement 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
close() - 类 java.util.Formatter 中的方法
关闭此 formatter。
close() - 类 java.util.logging.ConsoleHandler 中的方法
重写 StreamHandler.close 以进行刷新，但是不关闭输出流。
close() - 类 java.util.logging.FileHandler 中的方法
关闭所有文件。
close() - 类 java.util.logging.Handler 中的方法
关闭 Handler，并释放所有相关的资源。
close() - 类 java.util.logging.MemoryHandler 中的方法
关闭 Handler，并释放所有相关的资源。
close() - 类 java.util.logging.SocketHandler 中的方法
关闭此输出流。
close() - 类 java.util.logging.StreamHandler 中的方法
关闭当前输出流。
close() - 类 java.util.Scanner 中的方法
关闭此扫描器。
close() - 类 java.util.zip.DeflaterInputStream 中的方法
关闭此输入流和它的底层输入流，丢弃挂起的未压缩数据。
close() - 类 java.util.zip.DeflaterOutputStream 中的方法
将剩余压缩数据写入输出流并关闭底层流。
close() - 类 java.util.zip.GZIPInputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.util.zip.InflaterInputStream 中的方法
关闭此输入流并释放与该流关联的所有系统资源。
close() - 类 java.util.zip.InflaterOutputStream 中的方法
将剩余未压缩数据写入输出流并关闭底层输出流。
close() - 类 java.util.zip.ZipFile 中的方法
关闭 ZIP 文件。
close() - 类 java.util.zip.ZipInputStream 中的方法
关闭此输入流并释放与此流关联的所有系统资源。
close() - 类 java.util.zip.ZipOutputStream 中的方法
关闭 ZIP 输出流和正在过滤的流。
close() - 类 javax.crypto.CipherInputStream 中的方法
关闭该输入流并释放任何与该流关联的系统资源。
close() - 类 javax.crypto.CipherOutputStream 中的方法
关闭此输出流并释放任何与此流关联的系统资源。
close() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
关闭此 FileCacheImageInputStream，关闭并移除缓存文件。
close() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
关闭此 FileCacheImageOututStream。
close() - 类 javax.imageio.stream.FileImageInputStream 中的方法
close() - 类 javax.imageio.stream.FileImageOutputStream 中的方法
close() - 接口 javax.imageio.stream.ImageInputStream 中的方法
关闭流。
close() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
close() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
关闭此 MemoryCacheImageInputStream，释放缓存。
close() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
关闭此 MemoryCacheImageOutputStream。
close() - 接口 javax.management.remote.JMXConnector 中的方法
关闭客户端到其服务器的连接。
close() - 接口 javax.management.remote.rmi.RMIConnection 中的方法
关闭此连接。
close() - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
close() - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
close() - 类 javax.management.remote.rmi.RMIConnector 中的方法
close() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
关闭此连接服务器。
close() - 接口 javax.naming.Context 中的方法
关闭此上下文。
close() - 类 javax.naming.InitialContext 中的方法
close() - 类 javax.naming.ldap.StartTlsResponse 中的方法
妥善地关闭 TLS 连接并转换回底层连接。
close() - 接口 javax.naming.NamingEnumeration 中的方法
关闭此枚举。
close() - 接口 javax.sound.midi.MidiDevice 中的方法
关闭设备，指示设备现在应释放任何正在使用的系统资源。
close() - 接口 javax.sound.midi.Receiver 中的方法
指示应用程序已结束使用接收器，以及其请求的受限制资源可能已被释放或已可用。
close() - 接口 javax.sound.midi.Transmitter 中的方法
指示应用程序已结束使用传输器，以及其请求的受限制资源可能已被释放或已可用。
close() - 类 javax.sound.sampled.AudioInputStream 中的方法
关闭此音频输入流并释放与该流关联的所有系统资源。
close() - 接口 javax.sound.sampled.Line 中的方法
关闭行，指示可以释放的该行使用的所有系统资源。
CLOSE - 类 javax.sound.sampled.LineEvent.Type 中的静态变量
行关闭（释放该行在打开时获得的系统资源）时发送的事件类型。
close() - 接口 javax.sql.PooledConnection 中的方法
关闭此 PooledConnection 对象表示的物理连接。
close() - 类 javax.swing.ProgressMonitor 中的方法
指示操作已完成。
close() - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.close，以便关闭进度监视器以及流。
close() - 类 javax.tools.ForwardingJavaFileManager 中的方法
close() - 接口 javax.tools.JavaFileManager 中的方法
释放此文件管理器直接或间接打开的所有资源。
close() - 类 javax.xml.soap.SOAPConnection 中的方法
关闭此 SOAPConnection 对象。
close() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
close() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
close() - 接口 javax.xml.stream.XMLEventReader 中的方法
释放所有与此 Reader 关联的资源。
close() - 接口 javax.xml.stream.XMLEventWriter 中的方法
释放所有与此流关联的资源。
close() - 接口 javax.xml.stream.XMLStreamReader 中的方法
释放与此 Reader 关联的所有资源。
close() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
关闭此 writer 并释放与 writer 关联的所有资源。
close(MessageContext) - 接口 javax.xml.ws.handler.Handler 中的方法
消息交换模式结束时调用，正好发生在 JAX-WS 运行时指派消息、错误或异常之前。
CLOSE_ALL_RESULTS - 接口 java.sql.Statement 中的静态变量
该常量指示调用 getMoreResults 时应该关闭以前一直打开的所有 ResultSet 对象。
CLOSE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
CLOSE_CURRENT_RESULT - 接口 java.sql.Statement 中的静态变量
该常量指示调用 getMoreResults 时应该关闭当前 ResultSet 对象。
CLOSE_CURSORS_AT_COMMIT - 接口 java.sql.ResultSet 中的静态变量
该常量指示提交当前事务时，具有此可保存性的打开的 ResultSet 对象将被关闭。
CLOSE_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
CLOSE_FAILURE 用于对输出流的关闭失败时。
Closeable - java.io 中的 接口
Closeable 是可以关闭的数据源或目标。
closeAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
closeButton - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
closeClient(RMIConnection) - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
closeClient(RMIConnection) - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
closeClient(RMIConnection) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
关闭由 makeClient 建立的客户端连接。
CLOSED - 类 javax.management.remote.JMXConnectionNotification 中的静态变量
关闭连接通知的通知类型字符串。
CLOSED_OPTION - 类 javax.swing.JOptionPane 中的静态变量
用户没有做出任何选择而关闭了窗口时从类方法返回的值，很可能将此值视为 CANCEL_OPTION 或 NO_OPTION。
ClosedByInterruptException - java.nio.channels 中的 异常
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
ClosedByInterruptException() - 异常 java.nio.channels.ClosedByInterruptException 的构造方法
构造此类的一个实例。
ClosedChannelException - java.nio.channels 中的 异常
当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
ClosedChannelException() - 异常 java.nio.channels.ClosedChannelException 的构造方法
构造此类的一个实例。
closedIcon - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于显示无扩展的非叶节点的图标。
ClosedSelectorException - java.nio.channels 中的 异常
试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
ClosedSelectorException() - 异常 java.nio.channels.ClosedSelectorException 的构造方法
构造此类的一个实例。
closeEntry() - 类 java.util.zip.ZipInputStream 中的方法
关闭当前 ZIP 条目并定位流以读取下一个条目。
closeEntry() - 类 java.util.zip.ZipOutputStream 中的方法
关闭当前 ZIP 条目并定位流以写入下一个条目。
closeFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
从父窗体中移除窗体，如有必要，还要移除 desktopIcon。
closeFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常，此调用应该从其父窗体中移除窗体。
closeFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要关闭窗体时调用此方法。
closeIcon - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
closeInbound() - 类 javax.net.ssl.SSLEngine 中的方法
通知没有更多的入站网络数据将发送到此 SSLEngine。
closeKey - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
closeOutbound() - 类 javax.net.ssl.SSLEngine 中的方法
通知没有更多的出站应用程序数据将在此 SSLEngine 上发送。
closeOutUnwantedEmbeddedTags(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
搜索属性集和存储在标记向量中的每个标记。
closePath() - 类 java.awt.geom.Path2D 中的方法
通过绘制一条向后延伸到最后一个 moveTo 的坐标的直线，封闭当前子路径。
closeServer() - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
closeServer() - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
closeServer() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
由 RMIServerImpl.close() 调用以关闭连接器服务器。
CMMException - java.awt.color 中的 异常
如果本机 CMM 返回一个错误，则抛出此异常。
CMMException(String) - 异常 java.awt.color.CMMException 的构造方法
构造带指定详细消息的 CMMException。
coalesceEvents(AWTEvent, AWTEvent) - 类 java.awt.Component 中的方法
将正发送的事件与现有事件组合在一起。
CODE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
CODE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
code - 异常 org.w3c.dom.DOMException 中的变量
code - 异常 org.w3c.dom.events.EventException 中的变量
code - 异常 org.w3c.dom.ls.LSException 中的变量
CODE_ATTRIBUTE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
当与代码属性名称连在一起时，指出该属性的格式。
CODEBASE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Codec - org.omg.IOP 中的 接口
IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
codec_factory() - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
返回 IOP.CodecFactory。
CodecFactory - org.omg.IOP 中的 接口
Codec 可从 CodecFactory 中获得。
CodecFactoryHelper - org.omg.IOP 中的 类
Codec 可从 CodecFactory 中获得。
CodecFactoryHelper() - 类 org.omg.IOP.CodecFactoryHelper 的构造方法
CodecFactoryOperations - org.omg.IOP 中的 接口
Codec 可从 CodecFactory 中获得。
CodecOperations - org.omg.IOP 中的 接口
IOR 组件格式和 ORB 服务使用的服务上下文数据通常被定义为 IDL 定义数据类型的 CDR 封装编码实例。
codePointAt(CharSequence, int) - 类 java.lang.Character 中的静态方法
返回 CharSequence 的给定索引上的代码点。
codePointAt(char[], int) - 类 java.lang.Character 中的静态方法
返回 char 数组的给定索引上的代码点。
codePointAt(char[], int, int) - 类 java.lang.Character 中的静态方法
返回 char 数组的给定索引上的代码点，该数组中只有那些具有小于 limit 的 index 值的数组元素可以使用。
codePointAt(int) - 类 java.lang.String 中的方法
返回指定索引处的字符（Unicode 代码点）。
codePointAt(int) - 类 java.lang.StringBuffer 中的方法
codePointBefore(CharSequence, int) - 类 java.lang.Character 中的静态方法
返回 CharSequence 的给定索引前面的代码点。
codePointBefore(char[], int) - 类 java.lang.Character 中的静态方法
返回 char 数组的给定索引前面的代码点。
codePointBefore(char[], int, int) - 类 java.lang.Character 中的静态方法
返回 char 数组的给定索引前面的代码点，该数组中只有那些具有大于等于 start 的 index 值的数组元素可以使用。
codePointBefore(int) - 类 java.lang.String 中的方法
返回指定索引之前的字符（Unicode 代码点）。
codePointBefore(int) - 类 java.lang.StringBuffer 中的方法
codePointCount(CharSequence, int, int) - 类 java.lang.Character 中的静态方法
返回指定字符序列的文本范围内的 Unicode 代码点数量。
codePointCount(char[], int, int) - 类 java.lang.Character 中的静态方法
返回 char 数组参数的子数组中 Unicode 代码点的数量。
codePointCount(int, int) - 类 java.lang.String 中的方法
返回此 String 的指定文本范围中的 Unicode 代码点数。
codePointCount(int, int) - 类 java.lang.StringBuffer 中的方法
CoderMalfunctionError - java.nio.charset 中的 错误
当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。
CoderMalfunctionError(Exception) - 错误 java.nio.charset.CoderMalfunctionError 的构造方法
初始化此类的一个实例。
CoderResult - java.nio.charset 中的 类
coder 结果状态的描述。
CODESET_INCOMPATIBLE - org.omg.CORBA 中的 异常
当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
CODESET_INCOMPATIBLE() - 异常 org.omg.CORBA.CODESET_INCOMPATIBLE 的构造方法
构造一个 CODESET_INCOMPATIBLE 异常，使次要代码 (minor code) 设置为 0，COMPLETED_NO 设置为 CompletionStatus。
CODESET_INCOMPATIBLE(String) - 异常 org.omg.CORBA.CODESET_INCOMPATIBLE 的构造方法
使用指定消息构造一个 CODESET_INCOMPATIBLE 异常。
CODESET_INCOMPATIBLE(int, CompletionStatus) - 异常 org.omg.CORBA.CODESET_INCOMPATIBLE 的构造方法
使用指定次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
CODESET_INCOMPATIBLE(String, int, CompletionStatus) - 异常 org.omg.CORBA.CODESET_INCOMPATIBLE 的构造方法
使用指定消息、次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。
CodeSets - org.omg.IOP 中的 接口
org/omg/IOP/CodeSets.java。
CodeSigner - java.security 中的 类
此类封装关于代码签名者的信息。
CodeSigner(CertPath, Timestamp) - 类 java.security.CodeSigner 的构造方法
构造 CodeSigner 对象。
CodeSource - java.security 中的 类
此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。
CodeSource(URL, Certificate[]) - 类 java.security.CodeSource 的构造方法
构造一个 CodeSource 并将其与指定位置和证书集合相关联。
CodeSource(URL, CodeSigner[]) - 类 java.security.CodeSource 的构造方法
构造一个 CodeSource 并将其与指定位置和代码签名者集合相关联。
CODETYPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
CodingErrorAction - java.nio.charset 中的 类
编码错误操作的类型安全的枚举。
coerceData(boolean) - 类 java.awt.image.BufferedImage 中的方法
强制该数据与 isAlphaPremultiplied 变量中指定的状态相匹配。
coerceData(WritableRaster, boolean) - 类 java.awt.image.ColorModel 中的方法
强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
coerceData(WritableRaster, boolean) - 类 java.awt.image.ComponentColorModel 中的方法
强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
coerceData(WritableRaster, boolean) - 类 java.awt.image.DirectColorModel 中的方法
强制光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定此 ColorModel 现在已对该数据进行正确描述。
colHead - 类 javax.swing.ScrollPaneLayout 中的变量
子级列标题。
COLLAPSED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是折叠的。
collapsedIcon - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
CollapsedStringAdapter - javax.xml.bind.annotation.adapters 中的 类
用来处理 xs:token 及其派生类型的内置 XmlAdapter。
CollapsedStringAdapter() - 类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 的构造方法
collapsePath(TreePath) - 类 javax.swing.JTree 中的方法
确保指定路径标识的节点是折叠的，并且可查看。
collapseRow(int) - 类 javax.swing.JTree 中的方法
确保指定行中的节点是折叠的。
COLLATED - 类 javax.print.attribute.standard.SheetCollate 中的静态变量
当打印多个副本时，文档中的纸张以整理后的顺序出现。
CollationElementIterator - java.text 中的 类
CollationElementIterator 类用作一个迭代器，以遍历国际化字符串的每个字符。
CollationKey - java.text 中的 类
CollationKey 表示遵守特定 Collator 对象规则的 String。
CollationKey(String) - 类 java.text.CollationKey 的构造方法
CollationKey 构造方法。
Collator - java.text 中的 类
Collator 类执行区分语言环境的 String 比较。
Collator() - 类 java.text.Collator 的构造方法
默认的构造方法。
CollatorProvider - java.text.spi 中的 类
提供 Collator 类具体实现的服务提供者的抽象类。
CollatorProvider() - 类 java.text.spi.CollatorProvider 的构造方法
唯一的构造方法（由子类构造方法调用，通常是隐式的）。
Collection<E> - java.util 中的 接口
Collection 层次结构 中的根接口。
CollectionCertStoreParameters - java.security.cert 中的 类
用作 Collection CertStore 算法输入的参数。
CollectionCertStoreParameters(Collection<?>) - 类 java.security.cert.CollectionCertStoreParameters 的构造方法
创建 CollectionCertStoreParameters 的一个实例，它允许从指定的 Collection 中获取证书和 CRL。
CollectionCertStoreParameters() - 类 java.security.cert.CollectionCertStoreParameters 的构造方法
创建具有默认参数值（一个空的并且不可变的 Collection）的 CollectionCertStoreParameters 的实例
Collections - java.util 中的 类
此类完全由在 collection 上进行操作或返回 collection 的静态方法组成。
Color - java.awt 中的 类
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Color(int, int, int) - 类 java.awt.Color 的构造方法
创建具有指定红色、绿色和蓝色值的不透明的 sRGB 颜色，这些值都在 (0 - 255) 的范围内。
Color(int, int, int, int) - 类 java.awt.Color 的构造方法
创建具有指定红色、绿色、蓝色和 alpha 值的 sRGB 颜色，这些值都在 (0 - 255) 的范围内。
Color(int) - 类 java.awt.Color 的构造方法
创建具有指定组合的 RGB 值的不透明的 sRGB 颜色，此 sRGB 值的 16-23 位表示红色分量，8-15 位表示绿色分量，0-7 位表示蓝色分量。
Color(int, boolean) - 类 java.awt.Color 的构造方法
创建具有指定组合的 RGBA 值的 sRGB 颜色，此 RGBA 值的 24-31 位表示 alpha 分量，16-23 位表示红色分量，8-15 位表示绿色分量，0-7 位表示蓝色分量。
Color(float, float, float) - 类 java.awt.Color 的构造方法
创建具有指定红色、绿色和蓝色值的不透明的 sRGB 颜色，这三个颜色值都在 (0.0 - 1.0) 的范围内。
Color(float, float, float, float) - 类 java.awt.Color 的构造方法
创建具有指定红色、绿色、蓝色和 alpha 值的 sRGB 颜色，这些值都在 (0.0 - 1.0) 的范围内。
Color(ColorSpace, float[], float) - 类 java.awt.Color 的构造方法
创建具有 float 数组中指定的颜色分量和指定的 alpha 值的指定 ColorSpace 中的颜色。
COLOR - 类 java.awt.PageAttributes.ColorType 中的静态变量
用来指定颜色打印的 ColorType 实例。
COLOR - 类 javax.print.attribute.standard.Chromaticity 中的静态变量
彩色打印。
color - 类 javax.swing.border.MatteBorder 中的变量
COLOR - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
COLOR - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COLOR_ACTION - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
Color 选择动作标识符（颜色作为参数传递）
COLOR_CHOOSER - 类 javax.accessibility.AccessibleRole 中的静态变量
允许用户选择颜色的专用窗格。
COLOR_CHOOSER - 类 javax.swing.plaf.synth.Region 中的静态变量
ColorChooser 的 region。
COLOR_CHOOSER_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
ColorChooserComponentFactory - javax.swing.colorchooser 中的 类
旨在生成要插入到颜色选取器中的预先配置的“访问器”对象的类。
ColorChooserUI - javax.swing.plaf 中的 类
JColorChooser 的可插入外观界面。
ColorChooserUI() - 类 javax.swing.plaf.ColorChooserUI 的构造方法
ColorConvertOp - java.awt.image 中的 类
此类对源图像中的数据执行逐像素的颜色转换。
ColorConvertOp(RenderingHints) - 类 java.awt.image.ColorConvertOp 的构造方法
构造从源颜色空间到目标颜色空间转换的新 ColorConvertOp。
ColorConvertOp(ColorSpace, RenderingHints) - 类 java.awt.image.ColorConvertOp 的构造方法
根据 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ColorSpace, ColorSpace, RenderingHints) - 类 java.awt.image.ColorConvertOp 的构造方法
根据两个 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ICC_Profile[], RenderingHints) - 类 java.awt.image.ColorConvertOp 的构造方法
根据 ICC_Profiles 的数组构造新的 ColorConvertOp。
ColorModel - java.awt.image 中的 类
此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。
ColorModel(int) - 类 java.awt.image.ColorModel 的构造方法
构造 ColorModel，将指定位数的像素转换为颜色/alpha 分量。
ColorModel(int, int[], ColorSpace, boolean, boolean, int, int) - 类 java.awt.image.ColorModel 的构造方法
构造将像素值转换为颜色/alpha 分量的 ColorModel。
colorModel - 类 javax.imageio.ImageTypeSpecifier 中的变量
将用作原型的 ColorModel。
ColorSelectionModel - javax.swing.colorchooser 中的 接口
支持选取 Color 的模型。
ColorSpace - java.awt.color 中的 类
此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。
ColorSpace(int, int) - 类 java.awt.color.ColorSpace 的构造方法
构造一个给定颜色空间类型和分量数的 ColorSpace。
ColorSupported - javax.print.attribute.standard 中的 类
ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
ColorSupported(int) - 类 javax.print.attribute.standard.ColorSupported 的构造方法
构造具有给定整数值的支持新颜色的枚举值。
ColorType - javax.swing.plaf.synth 中的 类
可从某种风格中获取的一些颜色的类型安全枚举。
ColorType(String) - 类 javax.swing.plaf.synth.ColorType 的构造方法
创建一个具有指定描述的 ColorType。
ColorUIResource - javax.swing.plaf 中的 类
ColorUIResource(int, int, int) - 类 javax.swing.plaf.ColorUIResource 的构造方法
ColorUIResource(int) - 类 javax.swing.plaf.ColorUIResource 的构造方法
ColorUIResource(float, float, float) - 类 javax.swing.plaf.ColorUIResource 的构造方法
ColorUIResource(Color) - 类 javax.swing.plaf.ColorUIResource 的构造方法
COLS - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COLSPAN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
column - 类 javax.swing.event.TableModelEvent 中的变量
COLUMN_HEADER - 类 javax.accessibility.AccessibleRole 中的静态变量
数据列的头。
COLUMN_HEADER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口顶部左上角和右上角之间的区域。
COLUMN_WIDTH_PROPERTY - 类 javax.swing.table.TableColumn 中的静态变量
从 Java 2 platform v1.3 开始已过时。
columnAdded(TableColumnModelEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器有一列被添加到模型中。
columnAdded(TableColumnModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更（列插入）
columnAdded(TableColumnModelEvent) - 类 javax.swing.JTable 中的方法
将列添加到表的列模型时调用。
columnAdded(TableColumnModelEvent) - 类 javax.swing.table.JTableHeader 中的方法
将列添加到表列模型时调用。
columnAtPoint(Point) - 类 javax.swing.JTable 中的方法
返回 point 所在的列索引；如果结果不在 [0, getColumnCount()-1] 范围内，则返回 -1。
columnAtPoint(Point) - 类 javax.swing.table.JTableHeader 中的方法
返回该 point 所处列的索引，如果列位于边界外，则返回 -1。
columnHeader - 类 javax.swing.JScrollPane 中的变量
列标题子级。
columnIdentifiers - 类 javax.swing.table.DefaultTableModel 中的变量
Vector，由多个列标识符组成。
columnMargin - 类 javax.swing.table.DefaultTableColumnModel 中的变量
每列之间的空白宽度
columnMarginChanged(ChangeEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器因为页边空白更改，有一列被移除。
columnMarginChanged(ChangeEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪由于空白变更而引起的列移动的变更。
columnMarginChanged(ChangeEvent) - 类 javax.swing.JTable 中的方法
当列由于间距的更改而被移动时调用。
columnMarginChanged(ChangeEvent) - 类 javax.swing.table.JTableHeader 中的方法
当列由于间距改变而被移动时调用。
columnModel - 类 javax.swing.JTable 中的变量
表的 TableColumnModel。
columnModel - 类 javax.swing.table.JTableHeader 中的变量
表头的 TableColumnModel。
columnMoved(TableColumnModelEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器有一列被重新调整位置。
columnMoved(TableColumnModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪列重新定位的变更。
columnMoved(TableColumnModelEvent) - 类 javax.swing.JTable 中的方法
重新定位列时调用。
columnMoved(TableColumnModelEvent) - 类 javax.swing.table.JTableHeader 中的方法
重新定位列时调用。
columnNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中可能不允许使用 NULL 值。
columnNoNulls - 接口 java.sql.ResultSetMetaData 中的静态变量
指示列不允许使用 NULL 值的常量。
columnNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中明确允许使用 NULL 值。
columnNullable - 接口 java.sql.ResultSetMetaData 中的静态变量
指示列允许使用 NULL 值的常量。
columnNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道列是否可为 null。
columnNullableUnknown - 接口 java.sql.ResultSetMetaData 中的静态变量
指示不知道列的值是否可为 null 的常量。
columnRemoved(TableColumnModelEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器有一列从模型中移除。
columnRemoved(TableColumnModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更（列删除）
columnRemoved(TableColumnModelEvent) - 类 javax.swing.JTable 中的方法
从表的列模型中移除列时调用。
columnRemoved(TableColumnModelEvent) - 类 javax.swing.table.JTableHeader 中的方法
从表列模型中移除列时调用。
columnSelectionAllowed - 类 javax.swing.table.DefaultTableColumnModel 中的变量
此列模型中允许的列选择
columnSelectionChanged(ListSelectionEvent) - 接口 javax.swing.event.TableColumnModelListener 中的方法
告知侦听器 TableColumnModel 的选择模型发生更改。
columnSelectionChanged(ListSelectionEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
对变更的 TableColumnModel 的选择模型进行跟踪。
columnSelectionChanged(ListSelectionEvent) - 类 javax.swing.JTable 中的方法
TableColumnModel 的选择模型更改时调用。
columnSelectionChanged(ListSelectionEvent) - 类 javax.swing.table.JTableHeader 中的方法
当 TableColumnModel 的选择模型更改时调用。
columnUpdated(int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
指示此 CachedRowSet 对象当前行中的指定列是否已更新。
columnUpdated(String) - 接口 javax.sql.rowset.CachedRowSet 中的方法
指示此 CachedRowSet 对象当前行中的指定列是否已更新。
columnWeights - 类 java.awt.GridBagLayout 中的变量
此字段保持对列权重的重写。
columnWidths - 类 java.awt.GridBagLayout 中的变量
此字段保持对列最小宽度的重写。
combine(ProtectionDomain[], ProtectionDomain[]) - 接口 java.security.DomainCombiner 中的方法
修改或更新提供的 ProtectionDomain。
combine(ProtectionDomain[], ProtectionDomain[]) - 类 javax.security.auth.SubjectDomainCombiner 中的方法
使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。
COMBINING - 类 java.awt.font.GlyphMetrics 中的静态变量
指示表示组合字符的字形，例如元音变音。
COMBINING_DIACRITICAL_MARKS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Combining Diacritical Marks”Unicode 字符块的常量。
COMBINING_HALF_MARKS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Combining Half Marks”Unicode 字符块的常量。
COMBINING_MARKS_FOR_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Combining Diacritical Marks for Symbols”Unicode 字符块的常量。
COMBINING_SPACING_MARK - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Mc”。
COMBO_BOX - 类 javax.accessibility.AccessibleRole 中的静态变量
用户可以从中进行选择的选项列表。
COMBO_BOX - 类 javax.swing.plaf.synth.Region 中的静态变量
ComboBox 的 region。
comboBox - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
comboBox - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
comboBox - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
ComboBoxEditor - javax.swing 中的 接口
用于 JComboBox 组件的编辑器组件。
ComboBoxModel - javax.swing 中的 接口
用于组合框的数据模型。
ComboBoxUI - javax.swing.plaf 中的 类
JComboBox 的可插入外观界面。
ComboBoxUI() - 类 javax.swing.plaf.ComboBoxUI 的构造方法
comboIcon - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
ComboPopup - javax.swing.plaf.basic 中的 接口
定义实现组合框弹出部分所需方法的接口。
COMM_FAILURE - org.omg.CORBA 中的 异常
如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
COMM_FAILURE() - 异常 org.omg.CORBA.COMM_FAILURE 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。
COMM_FAILURE(String) - 异常 org.omg.CORBA.COMM_FAILURE 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。
COMM_FAILURE(int, CompletionStatus) - 异常 org.omg.CORBA.COMM_FAILURE 的构造方法
使用指定次要代码和完成状态构造一个 COMM_FAILURE 异常。
COMM_FAILURE(String, int, CompletionStatus) - 异常 org.omg.CORBA.COMM_FAILURE 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 COMM_FAILURE 异常。
command(Object) - 类 java.lang.Compiler 中的静态方法
检查参数类型及其字段，并执行一些文档操作。
command(List<String>) - 类 java.lang.ProcessBuilder 中的方法
设置此进程生成器的操作系统程序和参数。
command(String...) - 类 java.lang.ProcessBuilder 中的方法
设置此进程生成器的操作系统程序和参数。
command() - 类 java.lang.ProcessBuilder 中的方法
返回此进程生成器的操作系统程序和参数。
CommandInfo - javax.activation 中的 类
CommandMap 实现使用 CommandInfo 类描述命令请求的结果。
CommandInfo(String, String) - 类 javax.activation.CommandInfo 的构造方法
CommandInfo 的构造方法。
CommandMap - javax.activation 中的 类
CommandMap 类为系统中可用的命令对象注册表提供接口。
CommandMap() - 类 javax.activation.CommandMap 的构造方法
CommandObject - javax.activation 中的 接口
Activation Framework 所知的 JavaBean 组件实现此接口，以找出请求这些组件执行的命令动词，并获取表示这些组件要操作的数据的 DataHandler。
COMMENT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COMMENT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
所有注释以此标记作为标签。
comment(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出注释。
Comment - javax.xml.stream.events 中的 接口
注释事件的接口。
COMMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个注释
Comment - org.w3c.dom 中的 接口
此接口继承自 CharacterData 表示注释的内容，即起始 '<!--' 和结束 '-->' 之间的所有字符。
comment(char[], int, int) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
comment(char[], int, int) - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告文档的任何位置的 XML 注释。
COMMENT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Comment。
commentChar(int) - 类 java.io.StreamTokenizer 中的方法
指定该字符参数启动一个单行注释。
COMMENTS - 类 java.util.regex.Pattern 中的静态变量
模式中允许空白和注释。
commit() - 接口 java.sql.Connection 中的方法
使所有上一次提交/回滚后进行的更改成为持久更改，并释放此 Connection 对象当前持有的所有数据库锁。
commit() - 接口 javax.security.auth.spi.LoginModule 中的方法
提交验证过程的方法（阶段 2）。
commit() - 接口 javax.sql.rowset.CachedRowSet 中的方法
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
commit() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
commit() - 接口 javax.sql.rowset.spi.TransactionalWriter 中的方法
使最后一次调用 commit 或 rollback 方法以来 acceptChanges 执行的所有更改永久化。
COMMIT - 类 javax.swing.JFormattedTextField 中的静态变量
标识丢失焦点时，应该调用 commitEdit 的常量。
commit(Xid, boolean) - 接口 javax.transaction.xa.XAResource 中的方法
提交 xid 指定的全局事务。
COMMIT_ON_ACCEPT_CHANGES - 接口 javax.sql.rowset.CachedRowSet 中的静态变量
导致在调用 acceptChanges() 时，CachedRowSet 对象的 SyncProvider 提交更改。
COMMIT_OR_REVERT - 类 javax.swing.JFormattedTextField 中的静态变量
标识丢失焦点时，应该调用 commitEdit 的常量。
commitEdit() - 类 javax.swing.JFormattedTextField 中的方法
强制从 AbstractFormatter 获得当前值并将其设置为当前值。
commitEdit() - 类 javax.swing.JSpinner 中的方法
将当前编辑的值提交给 SpinnerModel。
commitEdit() - 类 javax.swing.JSpinner.DefaultEditor 中的方法
将当前编辑值赋给 SpinnerModel。
COMMON - 类 java.awt.JobAttributes.DialogType 中的静态变量
用于指定跨平台的纯 Java 打印对话框的 DialogType 实例。
CommonDataSource - javax.sql 中的 接口
此接口定义在 DataSource、XADataSource 和 ConnectionPoolDataSource 之间公用的方法。
CommunicationException - javax.naming 中的 异常
当客户端无法与目录或命名服务通信时，抛出此异常。
CommunicationException(String) - 异常 javax.naming.CommunicationException 的构造方法
使用所提供的参数构造一个新的 CommunicationException 实例。
CommunicationException() - 异常 javax.naming.CommunicationException 的构造方法
构造一个新的 CommunicationException 实例。
compact() - 类 java.nio.ByteBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.CharBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.DoubleBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.FloatBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.IntBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.LongBuffer 中的方法
压缩此缓冲区（可选操作）。
compact() - 类 java.nio.ShortBuffer 中的方法
压缩此缓冲区（可选操作）。
COMPACT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COMPACT_DISC - 类 javax.sound.sampled.Port.Info 中的静态变量
从 CD-ROM 驱动器获得音频端口类型。
Comparable<T> - java.lang 中的 接口
此接口强行对实现它的每个类的对象进行整体排序。
Comparator<T> - java.util 中的 接口
强行对某个对象 collection 进行整体排序 的比较函数。
comparator() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
comparator() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
comparator() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
返回用于对此队列元素进行排序的比较器；如果此队列使用其元素的自然顺序，则返回 null。
comparator() - 类 java.util.PriorityQueue 中的方法
返回用来对此队列中的元素进行排序的比较器；如果此队列根据其元素的自然顺序进行排序，则返回 null。
comparator() - 接口 java.util.SortedMap 中的方法
返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。
comparator() - 接口 java.util.SortedSet 中的方法
返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。
comparator() - 类 java.util.TreeMap 中的方法
comparator() - 类 java.util.TreeSet 中的方法
compare(double, double) - 类 java.lang.Double 中的静态方法
比较两个指定的 double 值。
compare(float, float) - 类 java.lang.Float 中的静态方法
比较两个指定的 float 值。
compare(String, String) - 类 java.text.Collator 中的方法
根据此 Collator 的整理规则来比较源字符串和目标字符串。
compare(Object, Object) - 类 java.text.Collator 中的方法
比较此方法两个参数的顺序。
compare(String, String) - 类 java.text.RuleBasedCollator 中的方法
根据表规则比较存储在两个不同字符串中的字符数据。
compare(T, T) - 接口 java.util.Comparator 中的方法
比较用来排序的两个参数。
compare(Duration) - 类 javax.xml.datatype.Duration 中的方法
与此 Duration 实例的部分顺序关系比较。
compare(XMLGregorianCalendar) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
根据 W3C XML 模式 1.0 第二部分 3.2.7.3 小节 Order relation on dateTime 中定义的部分顺序关系，比较 W3C XML 模式 1.0 日期/时间数据类型的两个实例。
compareAndSet(boolean, boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(int, int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(int, int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
compareAndSet(T, int, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段值设置为给定的更新值。
compareAndSet(long, long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(int, long, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(T, long, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段设置为给定的更新值。
compareAndSet(V, V, boolean, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
如果当前引用 == 预期引用，并且当前标记等于预期标记，那么以原子方式将引用和标记的值设置为给定的更新值。
compareAndSet(V, V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
compareAndSet(int, E, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
compareAndSet(T, V, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器管理的给定对象的字段设置为给定的更新值。
compareAndSet(V, V, int, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
如果当前引用 == 预期引用，并且当前标志等于预期标志，则以原子方式将该引用和该标志的值设置为给定的更新值。
compareAndSetState(long, long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
如果当前状态值等于预期值，则以原子方式将同步状态设置为给定的更新值。
compareAndSetState(int, int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
如果当前状态值等于预期值，则以原子方式将同步状态设置为给定的更新值。
compareDocumentPosition(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
compareDocumentPosition(Node) - 接口 org.w3c.dom.Node 中的方法
就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。
compareTabOrder(Component, Component) - 类 javax.swing.DefaultFocusManager 中的方法
compareTo(File) - 类 java.io.File 中的方法
按字母顺序比较两个抽象路径名。
compareTo(Object) - 类 java.io.ObjectStreamField 中的方法
将此字段与另一个 ObjectStreamField 进行比较。
compareTo(Boolean) - 类 java.lang.Boolean 中的方法
将此 Boolean 实例与其他实例进行比较。
compareTo(Byte) - 类 java.lang.Byte 中的方法
在数字上比较两个 Byte 对象。
compareTo(Character) - 类 java.lang.Character 中的方法
根据数字比较两个 Character 对象。
compareTo(T) - 接口 java.lang.Comparable 中的方法
比较此对象与指定对象的顺序。
compareTo(Double) - 类 java.lang.Double 中的方法
对两个 Double 对象所表示的数值进行比较。
compareTo(E) - 类 java.lang.Enum 中的方法
比较此枚举与指定对象的顺序。
compareTo(Float) - 类 java.lang.Float 中的方法
比较两个 Float 对象所表示的数值。
compareTo(Integer) - 类 java.lang.Integer 中的方法
在数字上比较两个 Integer 对象。
compareTo(Long) - 类 java.lang.Long 中的方法
在数字上比较两个 Long 对象。
compareTo(Short) - 类 java.lang.Short 中的方法
比较两个 Short 对象所表示的数值。
compareTo(String) - 类 java.lang.String 中的方法
按字典顺序比较两个字符串。
compareTo(BigDecimal) - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 与指定的 BigDecimal 比较。
compareTo(BigInteger) - 类 java.math.BigInteger 中的方法
将此 BigInteger 与指定的 BigInteger 进行比较。
compareTo(URI) - 类 java.net.URI 中的方法
将此 URI 与另一个对象（也必须是 URI）进行比较。
compareTo(ByteBuffer) - 类 java.nio.ByteBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(CharBuffer) - 类 java.nio.CharBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(Charset) - 类 java.nio.charset.Charset 中的方法
比较此 charset 与其他 charset。
compareTo(DoubleBuffer) - 类 java.nio.DoubleBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(FloatBuffer) - 类 java.nio.FloatBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(IntBuffer) - 类 java.nio.IntBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(LongBuffer) - 类 java.nio.LongBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(ShortBuffer) - 类 java.nio.ShortBuffer 中的方法
将此缓冲区与另一个缓冲区进行比较。
compareTo(Timestamp) - 类 java.sql.Timestamp 中的方法
将此 Timestamp 对象与给定 Timestamp 对象相比较。
compareTo(Date) - 类 java.sql.Timestamp 中的方法
将此 Timestamp 对象与给定的 Date（必须为 Timestamp 对象）相比较。
compareTo(CollationKey) - 类 java.text.CollationKey 中的方法
比较此 CollationKey 与目标 CollationKey。
compareTo(Calendar) - 类 java.util.Calendar 中的方法
比较两个 Calendar 对象表示的时间值（从历元至现在的毫秒偏移量）。
compareTo(Date) - 类 java.util.Date 中的方法
比较两个日期的顺序。
compareTo(UUID) - 类 java.util.UUID 中的方法
将此 UUID 与指定的 UUID 比较。
compareTo(ObjectName) - 类 javax.management.ObjectName 中的方法
比较两个 ObjectName 实例。
compareTo(Object) - 类 javax.naming.CompositeName 中的方法
比较此 CompositeName 与指定 Object 的顺序。
compareTo(Object) - 类 javax.naming.CompoundName 中的方法
比较此 CompoundName 与指定 Object 的顺序。
compareTo(Object) - 类 javax.naming.ldap.LdapName 中的方法
比较此 LdapName 与指定 Object 的顺序。
compareTo(Object) - 类 javax.naming.ldap.Rdn 中的方法
比较此 Rdn 与指定 Object 的顺序。
compareTo(Object) - 接口 javax.naming.Name 中的方法
比较此名称与另一个名称的顺序。
compareToIgnoreCase(String) - 类 java.lang.String 中的方法
按字典顺序比较两个字符串，不考虑大小写。
Compilable - javax.script 中的 接口
由 ScriptEngines 实现的可选接口，该 ScriptEngines 的方法将脚本编译成无需重新编译就能反复执行的某种形式。
COMPILATION_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
CompilationMXBean 的 ObjectName 的字符串表示形式。
CompilationMXBean - java.lang.management 中的 接口
用于 Java 虚拟机的编译系统的管理接口。
compile(String) - 类 java.util.regex.Pattern 中的静态方法
将给定的正则表达式编译到模式中。
compile(String, int) - 类 java.util.regex.Pattern 中的静态方法
将给定的正则表达式编译到具有给定标志的模式中。
compile(String) - 接口 javax.script.Compilable 中的方法
编译脚本（以 String 形式表示的源），以便以后执行。
compile(Reader) - 接口 javax.script.Compilable 中的方法
编译脚本（从 Reader 读取的源），以便以后执行。
compile(String) - 接口 javax.xml.xpath.XPath 中的方法
编译 XPath 表达式供以后计算使用。
compileClass(Class<?>) - 类 java.lang.Compiler 中的静态方法
编译指定的类。
compileClasses(String) - 类 java.lang.Compiler 中的静态方法
编译那些名称与指定字符串相匹配的所有类。
CompiledScript - javax.script 中的 类
存储编译结果的类扩展自此类。
CompiledScript() - 类 javax.script.CompiledScript 的构造方法
Compiler - java.lang 中的 类
Compiler 类主要支持 Java 到本机代码的编译器及相关服务。
complementOf(EnumSet<E>) - 类 java.util.EnumSet 中的静态方法
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
COMPLETE - 类 java.awt.MediaTracker 中的静态变量
指示媒体下载已成功完成的标志。
complete() - 类 java.util.Calendar 中的方法
填充日历字段中所有未设置的字段。
COMPLETED - 类 javax.print.attribute.standard.JobState 中的静态变量
作业已成功完成，或以警告或错误结束，所有作业介质纸张已成功堆栈到适当的输出纸盒（或多个纸盒）中，且所有作业状态已达到作业的最终值。
completed - 异常 org.omg.CORBA.SystemException 中的变量
抛出此异常的操作的状态。
COMPLETED_MAYBE - 类 org.omg.CORBA.CompletionStatus 中的静态变量
使用常量 _COMPLETED_MAYBE 初始化的 CompletionStatus 实例。
COMPLETED_NO - 类 org.omg.CORBA.CompletionStatus 中的静态变量
使用常量 _COMPLETED_NO 初始化的 CompletionStatus 实例。
COMPLETED_YES - 类 org.omg.CORBA.CompletionStatus 中的静态变量
使用常量 _COMPLETED_YES 初始化的 CompletionStatus 实例。
completeDrag(int, int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
completeDrag(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
用鼠标事件的新位置传递 finishDraggingTo 的消息。
completeEditing() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
传递消息以停止编辑会话。
completeEditing(boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
停止编辑会话。
COMPLETESCANLINES - 接口 java.awt.image.ImageConsumer 中的静态变量
按照一次（多个）完整扫描行的方式传递像素。
completeUIInstall() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
在安装所有默认值/侦听器之后根据 installUI 调用。
completeUIUninstall() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
Completion - javax.annotation.processing 中的 接口
某一注释的建议 completion。
Completions - javax.annotation.processing 中的 类
用来组合 Completion 对象的实用工具类。
CompletionService<V> - java.util.concurrent 中的 接口
将生产新的异步任务与使用已完成任务的结果分离开来的服务。
CompletionStatus - org.omg.CORBA 中的 类
指示某一方法抛出 SystemException 时是否已结束运行的对象。
CompletionStatusHelper - org.omg.CORBA 中的 类
CompletionStatus 的 Helper。
CompletionStatusHelper() - 类 org.omg.CORBA.CompletionStatusHelper 的构造方法
Component - java.awt 中的 类
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component() - 类 java.awt.Component 的构造方法
构造一个新组件。
component - 类 java.awt.dnd.DragGestureRecognizer 中的变量
与此 DragGestureRecognizer 关联的 Component。
COMPONENT - 类 java.awt.font.GlyphMetrics 中的静态变量
指示在内部存储中没有相应字符的字形。
component - 类 javax.swing.ImageIcon 中的静态变量
Component.AccessibleAWTComponent - java.awt 中的 类
用来为可访问性提供默认支持的 Component 的内部类。
Component.AccessibleAWTComponent() - 类 java.awt.Component.AccessibleAWTComponent 的构造方法
虽然该类是抽象的，但其所有子类都应该能够调用此方法。
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler - java.awt 中的 类
当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler() - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 的构造方法
Component.AccessibleAWTComponent.AccessibleAWTFocusHandler - java.awt 中的 类
当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）
Component.AccessibleAWTComponent.AccessibleAWTFocusHandler() - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 的构造方法
Component.BaselineResizeBehavior - java.awt 中的 枚举
常见方式的枚举，指示组件的基线可以随大小的更改而更改。
Component.BltBufferStrategy - java.awt 中的 类
用于将屏幕外的画面以位图传输方式传输到一个组件的内部类。
Component.BltBufferStrategy(int, BufferCapabilities) - 类 java.awt.Component.BltBufferStrategy 的构造方法
围绕组件创建一个新的 blt 缓冲区策略
Component.FlipBufferStrategy - java.awt 中的 类
在组件上翻转缓冲区的内部类。
Component.FlipBufferStrategy(int, BufferCapabilities) - 类 java.awt.Component.FlipBufferStrategy 的构造方法
为此组件创建新的翻转缓冲区策略。
COMPONENT_ADDED - 类 java.awt.event.ContainerEvent 中的静态变量
此事件指示组件已被添加到容器中。
component_count() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回 DynAny 的组件数。
component_count() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回 DynAny 的组件数。
component_count() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
返回 DynAny 的组件数。
component_data - 类 org.omg.IOP.TaggedComponent 中的变量
与组件 id 关联的组件数据。
COMPONENT_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择组件事件的事件掩码。
COMPONENT_FIRST - 类 java.awt.event.ComponentEvent 中的静态变量
用于组件事件的 id 范围的起始编号。
COMPONENT_HIDDEN - 类 java.awt.event.ComponentEvent 中的静态变量
此事件指示组件呈现为不可见。
COMPONENT_LAST - 类 java.awt.event.ComponentEvent 中的静态变量
用于组件事件的 id 范围的结束编号。
COMPONENT_MOVED - 类 java.awt.event.ComponentEvent 中的静态变量
此事件指示组件位置已更改。
COMPONENT_REMOVED - 类 java.awt.event.ContainerEvent 中的静态变量
此事件指示已从容器中移除组件。
COMPONENT_RESIZED - 类 java.awt.event.ComponentEvent 中的静态变量
此事件指示组件大小已更改。
COMPONENT_SHOWN - 类 java.awt.event.ComponentEvent 中的静态变量
此事件指示组件已变得可见。
ComponentAdapter - java.awt.event 中的 类
用于接收组件事件的抽象适配器类。
ComponentAdapter() - 类 java.awt.event.ComponentAdapter 的构造方法
componentAdded(ContainerEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentAdded 方法处理 componentAdded 容器事件。
componentAdded(ContainerEvent) - 类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 中的方法
componentAdded(ContainerEvent) - 类 java.awt.event.ContainerAdapter 中的方法
已将组件添加到容器中时调用。
componentAdded(ContainerEvent) - 接口 java.awt.event.ContainerListener 中的方法
已将组件添加到容器中时调用。
componentAdded(ContainerEvent) - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 中的方法
componentAdded(ContainerEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 中的方法
ComponentAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
组件属性的名称。
ComponentColorModel - java.awt.image 中的 类
使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。
ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int) - 类 java.awt.image.ComponentColorModel 的构造方法
根据指定参数构造 ComponentColorModel。
ComponentColorModel(ColorSpace, boolean, boolean, int, int) - 类 java.awt.image.ComponentColorModel 的构造方法
根据指定参数构造 ComponentColorModel。
ComponentElementName - 类 javax.swing.text.StyleConstants 中的静态变量
用于表示组件的元素名称。
ComponentEvent - java.awt.event 中的 类
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
ComponentEvent(Component, int) - 类 java.awt.event.ComponentEvent 的构造方法
构造一个 ComponentEvent 对象。
componentForPoint(Component, Point) - 类 javax.swing.MenuSelectionManager 中的方法
返回包含 sourcePoint 的当前选择路径的组件。
componentHidden(ComponentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentHidden 方法处理 componentHidden 事件。
componentHidden(ComponentEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 中的方法
componentHidden(ComponentEvent) - 类 java.awt.event.ComponentAdapter 中的方法
组件变得不可见时调用。
componentHidden(ComponentEvent) - 接口 java.awt.event.ComponentListener 中的方法
组件变得不可见时调用。
componentHidden(ComponentEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 中的方法
ComponentIdHelper - org.omg.IOP 中的 类
表示多组件配置文件的标准方式。
ComponentIdHelper() - 类 org.omg.IOP.ComponentIdHelper 的构造方法
ComponentInputMap - javax.swing 中的 类
ComponentInputMap 是与特定 JComponent 相关联的 InputMap。
ComponentInputMap(JComponent) - 类 javax.swing.ComponentInputMap 的构造方法
创建一个与给定组件相关联的 ComponentInputMap。
ComponentInputMapUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
ComponentInputMapUIResource(JComponent) - 类 javax.swing.plaf.ComponentInputMapUIResource 的构造方法
ComponentListener - java.awt.event 中的 接口
用于接收组件事件的侦听器接口。
componentListener - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
componentListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
componentMoved(ComponentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentMoved 方法处理 componentMoved 事件。
componentMoved(ComponentEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 中的方法
componentMoved(ComponentEvent) - 类 java.awt.event.ComponentAdapter 中的方法
组件位置更改时调用。
componentMoved(ComponentEvent) - 接口 java.awt.event.ComponentListener 中的方法
组件位置更改时调用。
componentMoved(ComponentEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 中的方法
componentMoved(ComponentEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的方法
ComponentOrientation - java.awt 中的 类
ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。
componentRemoved(ContainerEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentRemoved 方法处理 componentRemoved 容器事件。
componentRemoved(ContainerEvent) - 类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 中的方法
componentRemoved(ContainerEvent) - 类 java.awt.event.ContainerAdapter 中的方法
已从容器中移除组件时调用。
componentRemoved(ContainerEvent) - 接口 java.awt.event.ContainerListener 中的方法
已从容器中移除组件时调用。
componentRemoved(ContainerEvent) - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 中的方法
componentRemoved(ContainerEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener 中的方法
componentResized(ComponentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentResized 方法处理 componentResized 事件。
componentResized(ComponentEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 中的方法
componentResized(ComponentEvent) - 类 java.awt.event.ComponentAdapter 中的方法
组件大小更改时调用。
componentResized(ComponentEvent) - 接口 java.awt.event.ComponentListener 中的方法
组件大小更改时调用。
componentResized(ComponentEvent) - 类 javax.swing.JViewport.ViewListener 中的方法
componentResized(ComponentEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 中的方法
当 JInternalFrame 的父级大小更改时调用。
componentResized(ComponentEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.ComponentHandler 中的方法
components - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的变量
components_established(IORInfo) - 接口 org.omg.PortableInterceptor.IORInterceptor_3_0Operations 中的方法
在已经对所有已注册 IORInterceptor 实例调用 establish_components 方法后，对所有已注册 IORInterceptor_3_0 实例调用 components_established 方法。
ComponentSampleModel - java.awt.image 中的 类
此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。
ComponentSampleModel(int, int, int, int, int, int[]) - 类 java.awt.image.ComponentSampleModel 的构造方法
构造具有指定参数的 ComponentSampleModel。
ComponentSampleModel(int, int, int, int, int, int[], int[]) - 类 java.awt.image.ComponentSampleModel 的构造方法
构造具有指定参数的 ComponentSampleModel。
componentShown(ComponentEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 componentShown 方法处理 componentShown 事件。
componentShown(ComponentEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 中的方法
componentShown(ComponentEvent) - 类 java.awt.event.ComponentAdapter 中的方法
组件变得可见时调用。
componentShown(ComponentEvent) - 接口 java.awt.event.ComponentListener 中的方法
组件变得可见时调用。
componentShown(ComponentEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler 中的方法
ComponentUI - javax.swing.plaf 中的 类
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。
ComponentUI() - 类 javax.swing.plaf.ComponentUI 的构造方法
单独的构造方法。
ComponentView - javax.swing.text 中的 类
实现视图接口的组件装饰器。
ComponentView(Element) - 类 javax.swing.text.ComponentView 的构造方法
创建新的 ComponentView 对象。
compose(Raster, Raster, WritableRaster) - 接口 java.awt.CompositeContext 中的方法
组合两个源 Raster 对象并将结果置于目标 WritableRaster 中。
ComposedTextAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
撰写文本的输入法属性的名称。
composeName(Name, Name) - 接口 javax.naming.Context 中的方法
将此上下文的名称与相对于此上下文的名称组合。
composeName(String, String) - 接口 javax.naming.Context 中的方法
将此上下文的名称与相对于此上下文的名称组合。
composeName(String, String) - 类 javax.naming.InitialContext 中的方法
将此上下文的名称与相对于此上下文的名称组合。
composeName(Name, Name) - 类 javax.naming.InitialContext 中的方法
将此上下文的名称与相对于此上下文的名称组合。
Composite - java.awt 中的 接口
Composite 接口和 CompositeContext 一起定义了用基础图形区域组合绘图基本元素的方法。
CompositeContext - java.awt 中的 接口
CompositeContext 接口为复合操作定义了已封装和已优化的环境。
CompositeData - javax.management.openmbean 中的 接口
CompositeData 接口指定表示复合数据 结构的复杂开放数据 对象的特定类型的行为。
CompositeDataInvocationHandler - javax.management.openmbean 中的 类
将获取方法转发给 CompositeData 的 InvocationHandler。
CompositeDataInvocationHandler(CompositeData) - 类 javax.management.openmbean.CompositeDataInvocationHandler 的构造方法
构造一个受给定 CompositeData 支持的处理程序。
CompositeDataSupport - javax.management.openmbean 中的 类
CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。
CompositeDataSupport(CompositeType, String[], Object[]) - 类 javax.management.openmbean.CompositeDataSupport 的构造方法
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。
CompositeDataSupport(CompositeType, Map<String, ?>) - 类 javax.management.openmbean.CompositeDataSupport 的构造方法
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。
CompositeDataView - javax.management.openmbean 中的 接口
Java 类可以实现此接口，以指示如何通过 MXBean 框架将其转换为 CompositeData。
CompositeName - javax.naming 中的 类
此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
CompositeName(Enumeration<String>) - 类 javax.naming.CompositeName 的构造方法
使用由 'comps' 指定的组件构造一个新的复合名称实例。
CompositeName(String) - 类 javax.naming.CompositeName 的构造方法
通过使用复合名称语法（从左到右，用斜杠分隔）解析字符串 n 来构造一个新的复合名称实例。
CompositeName() - 类 javax.naming.CompositeName 的构造方法
构造一个新的空复合名称。
CompositeType - javax.management.openmbean 中的 类
CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。
CompositeType(String, String, String[], String[], OpenType<?>[]) - 类 javax.management.openmbean.CompositeType 的构造方法
构造一个 CompositeType 实例，检查给定参数的有效性。
CompositeView - javax.swing.text 中的 类
CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。
CompositeView(Element) - 类 javax.swing.text.CompositeView 的构造方法
为给定元素构造一个 CompositeView。
CompoundBorder - javax.swing.border 中的 类
一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
CompoundBorder() - 类 javax.swing.border.CompoundBorder 的构造方法
创建一个组合边框，其内部边框和外部边框均为 null。
CompoundBorder(Border, Border) - 类 javax.swing.border.CompoundBorder 的构造方法
按照指定的内部边框和外部边框创建组合边框。
CompoundControl - javax.sound.sampled 中的 类
CompoundControl（如图形均衡器）控制两个或多个相关属性，每个属性本身都表示为 Control。
CompoundControl(CompoundControl.Type, Control[]) - 类 javax.sound.sampled.CompoundControl 的构造方法
构造一个具有给定参数的新组合控件对象。
CompoundControl.Type - javax.sound.sampled 中的 类
CompoundControl.Type 内部类的实例标识一种组合控件。
CompoundControl.Type(String) - 类 javax.sound.sampled.CompoundControl.Type 的构造方法
构造一个新的组合控件类型。
CompoundEdit - javax.swing.undo 中的 类
AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
CompoundEdit() - 类 javax.swing.undo.CompoundEdit 的构造方法
compoundEdit - 类 javax.swing.undo.UndoableEditSupport 中的变量
CompoundName - javax.naming 中的 类
此类表示一个组合名称，即一个取自层次名称空间的名称。
CompoundName(Enumeration<String>, Properties) - 类 javax.naming.CompoundName 的构造方法
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。
CompoundName(String, Properties) - 类 javax.naming.CompoundName 的构造方法
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。
COMPRESS - 类 javax.print.attribute.standard.Compression 中的静态变量
UNIX 压缩技术。
Compression - javax.print.attribute.standard 中的 类
Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
Compression(int) - 类 javax.print.attribute.standard.Compression 的构造方法
构造具有给定整数值的新压缩枚举值。
COMPRESSION_ERROR - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统中止了作业，因为打印机在解压缩文档数据中遇到错误。
compressionMode - 类 javax.imageio.ImageWriteParam 中的变量
控制压缩设置的模式，必须将它设置为四个 MODE_* 值之一。
compressionQuality - 类 javax.imageio.ImageWriteParam 中的变量
包含当前压缩质量设置的 float 值。
compressionType - 类 javax.imageio.ImageWriteParam 中的变量
包含当前压缩类型名称的 String，如果没有设置压缩类型，则返回 null。
compressionTypes - 类 javax.imageio.ImageWriteParam 中的变量
包含可用压缩类型名称的 String 数组。
comptable - 类 java.awt.GridBagLayout 中的变量
此哈希表维持组件与其网格包约束之间的关联。
computeBlit(int, int, Point, Point, Dimension, Rectangle) - 类 javax.swing.JViewport 中的方法
计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
computeDifference(Rectangle, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
返回矩形数组的便捷方法，该矩形表示不与 rectB 重叠的 rectA 内的区域。
computeFields() - 类 java.util.Calendar 中的方法
将当前毫秒时间值 Calendar.time 转换为 fields[] 中的日历字段值。
computeFields() - 类 java.util.GregorianCalendar 中的方法
将时间值（从 Epoch 至现在的毫秒偏移量）转换为日历字段值。
computeIntersection(int, int, int, int, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
在未分配新矩形的情况下计算两个矩形的交集的便捷方法。
computePopupBounds(int, int, int, int) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
基于组合框的位置和封闭的屏幕界限计算组合框的弹出部分的位置和大小。
computeRegions(ImageReadParam, int, int, BufferedImage, Rectangle, Rectangle) - 类 javax.imageio.ImageReader 中的静态方法
计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
computerIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
computeStringWidth(SynthContext, Font, FontMetrics, String) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
返回传入字符串的大小。
computeStringWidth(FontMetrics, String) - 类 javax.swing.SwingUtilities 中的静态方法
使用具有指定“规格”（大小）的字体计算字符串的宽度。
computeTime() - 类 java.util.Calendar 中的方法
将 fields[] 中的当前日历字段值转换为毫秒时间值 Calendar.time。
computeTime() - 类 java.util.GregorianCalendar 中的方法
将日历字段值转换为时间值（从 Epoch 至现在的毫秒偏移量）。
computeUnion(int, int, int, int, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
在未分配新矩形的情况下计算两个矩形的并集的便捷方法。
computeVisibleRect(Rectangle) - 类 javax.swing.JComponent 中的方法
返回该 Component 的“可见 rect 矩形”，即此组件及其所有祖先的可见矩形的交集。
concat(String) - 类 java.lang.String 中的方法
将指定字符串连接到此字符串的结尾。
concatenate(AffineTransform) - 类 java.awt.geom.AffineTransform 中的方法
以最常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，以提供由 Tx 映射到以前用户空间的新用户空间。
concatenateTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
通过追加另一变换修改当前的“用户到设备”变换。
concetenateTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
已过时。 由 concatenateTransform(AffineTransform) 所替代。
concrete_base_type() - 类 org.omg.CORBA.TypeCode 中的方法
返回一个 TypeCode 对象，它描述此 TypeCode 对象所描述 value 类型的具体基本类型。
CONCUR_READ_ONLY - 接口 java.sql.ResultSet 中的静态变量
该常量指示不可以更新的 ResultSet 对象的并发模式。
CONCUR_UPDATABLE - 接口 java.sql.ResultSet 中的静态变量
该常量指示可以更新的 ResultSet 对象的并发模式。
ConcurrentHashMap<K,V> - java.util.concurrent 中的 类
支持获取的完全并发和更新的所期望可调整并发的哈希表。
ConcurrentHashMap(int, float, int) - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
创建一个带有指定初始容量、加载因子和并发级别的新的空映射。
ConcurrentHashMap(int, float) - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
创建一个带有指定初始容量、加载因子和默认 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap(int) - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
创建一个带有指定初始容量、默认加载因子 (0.75) 和 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap() - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
创建一个带有默认初始容量 (16)、加载因子 (0.75) 和 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap(Map<? extends K, ? extends V>) - 类 java.util.concurrent.ConcurrentHashMap 的构造方法
构造一个与给定映射具有相同映射关系的新映射。
ConcurrentLinkedQueue<E> - java.util.concurrent 中的 类
一个基于链接节点的无界线程安全队列。
ConcurrentLinkedQueue() - 类 java.util.concurrent.ConcurrentLinkedQueue 的构造方法
创建一个最初为空的 ConcurrentLinkedQueue。
ConcurrentLinkedQueue(Collection<? extends E>) - 类 java.util.concurrent.ConcurrentLinkedQueue 的构造方法
创建一个最初包含给定 collection 元素的 ConcurrentLinkedQueue，按照此 collection 迭代器的遍历顺序来添加元素。
ConcurrentMap<K,V> - java.util.concurrent 中的 接口
提供其他原子 putIfAbsent、remove、replace 方法的 Map。
ConcurrentModificationException - java.util 中的 异常
当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
ConcurrentModificationException() - 异常 java.util.ConcurrentModificationException 的构造方法
构造不带详细消息的 ConcurrentModificationException。
ConcurrentModificationException(String) - 异常 java.util.ConcurrentModificationException 的构造方法
构造带指定详细消息的 ConcurrentModificationException。
ConcurrentNavigableMap<K,V> - java.util.concurrent 中的 接口
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。
ConcurrentSkipListMap<K,V> - java.util.concurrent 中的 类
可缩放的并发 ConcurrentNavigableMap 实现。
ConcurrentSkipListMap() - 类 java.util.concurrent.ConcurrentSkipListMap 的构造方法
构造一个新的空映射，该映射按照键的自然顺序进行排序。
ConcurrentSkipListMap(Comparator<? super K>) - 类 java.util.concurrent.ConcurrentSkipListMap 的构造方法
构造一个新的空映射，该映射按照指定的比较器进行排序。
ConcurrentSkipListMap(Map<? extends K, ? extends V>) - 类 java.util.concurrent.ConcurrentSkipListMap 的构造方法
构造一个新映射，该映射所包含的映射关系与给定映射包含的映射关系相同，并按照键的自然顺序进行排序。
ConcurrentSkipListMap(SortedMap<K, ? extends V>) - 类 java.util.concurrent.ConcurrentSkipListMap 的构造方法
构造一个新映射，该映射所包含的映射关系与指定的有序映射包含的映射关系相同，使用的顺序也相同。
ConcurrentSkipListSet<E> - java.util.concurrent 中的 类
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
ConcurrentSkipListSet() - 类 java.util.concurrent.ConcurrentSkipListSet 的构造方法
构造一个新的空 set，该 set 按照元素的自然顺序对其进行排序。
ConcurrentSkipListSet(Comparator<? super E>) - 类 java.util.concurrent.ConcurrentSkipListSet 的构造方法
构造一个新的空 set，该 set 按照指定的比较器对其元素进行排序。
ConcurrentSkipListSet(Collection<? extends E>) - 类 java.util.concurrent.ConcurrentSkipListSet 的构造方法
构造一个包含指定 collection 中元素的新 set，这个新 set 按照元素的自然顺序对其进行排序。
ConcurrentSkipListSet(SortedSet<E>) - 类 java.util.concurrent.ConcurrentSkipListSet 的构造方法
构造一个新 set，该 set 所包含的元素与指定的有序 set 包含的元素相同，使用的顺序也相同。
Condition - java.util.concurrent.locks 中的 接口
Condition 将 Object 监视器方法（wait、notify 和 notifyAll）分解成截然不同的对象，以便通过将这些对象与任意 Lock 实现组合使用，为每个对象提供多个等待 set（wait-set）。
CONFIG - 类 java.util.logging.Level 中的静态变量
CONFIG 是用于静态配置消息的消息级别。
config(String) - 类 java.util.logging.Logger 中的方法
记录一条 CONFIG 消息。
Configuration - javax.security.auth.login 中的 类
Configuration 对象负责指定应该将哪一个 LoginModule 用于某一特定应用程序，以及应该以什么样的顺序调用 LoginModule。
Configuration() - 类 javax.security.auth.login.Configuration 的构造方法
唯一的构造方法。
Configuration.Parameters - javax.security.auth.login 中的 接口
此类表示 Configuration 参数的标记接口。
ConfigurationException - javax.naming 中的 异常
当存在配置问题时，抛出此异常。
ConfigurationException(String) - 异常 javax.naming.ConfigurationException 的构造方法
使用解释构造一个新的 ConfigurationException 实例。
ConfigurationException() - 异常 javax.naming.ConfigurationException 的构造方法
构造一个新的 ConfigurationException 实例，将解释和所有名称解析字段初始化为 null。
ConfigurationSpi - javax.security.auth.login 中的 类
此类为 Configuration 类定义服务提供者接口（SPI）。
ConfigurationSpi() - 类 javax.security.auth.login.ConfigurationSpi 的构造方法
configureArrowButton() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此公共方法是特定于实现的，应该为私有。
configureBlocking(boolean) - 类 java.nio.channels.SelectableChannel 中的方法
调整此通道的阻塞模式。
configureBlocking(boolean) - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
调整此通道的阻塞模式。
configureEditor(ComboBoxEditor, Object) - 类 javax.swing.JComboBox 中的方法
利用指定项初始化编辑器。
configureEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
configureEditor() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
configureEnclosingScrollPane() - 类 javax.swing.JTable 中的方法
如果此 JTable 是一个封闭 JScrollPane 的 viewportView（通常情况如此），那么可通过安装表的 tableHeader 作为滚动窗格的 columnHeaderView 来配置此 ScrollPane。
configureLayoutCache() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
基于为其提供外观的树重置 TreeState 实例。
configureList() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
配置用于保存弹出部分中的组合框项的列表。
configurePopup() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
配置组合框的弹出部分。
configurePropertiesFromAction(Action) - 类 javax.swing.AbstractButton 中的方法
在此按钮上设置属性以匹配指定 Action 中的属性。
configurePropertiesFromAction(Action) - 类 javax.swing.JComboBox 中的方法
在此组合框上设置属性以匹配指定 Action 中的属性。
configurePropertiesFromAction(Action) - 类 javax.swing.JMenuItem 中的方法
在此按钮上设置属性以匹配指定 Action 中的属性。
configurePropertiesFromAction(Action) - 类 javax.swing.JTextField 中的方法
在此文本字段上设置属性，以匹配指定 Action 中的值。
configureScrollBarColors() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
configureScrollBarColors() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
configureScroller() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
配置在组合框弹出控件中保存列表的可滚动部分。
ConfirmationCallback - javax.security.auth.callback 中的 类
底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。
ConfirmationCallback(int, int, int) - 类 javax.security.auth.callback.ConfirmationCallback 的构造方法
构造一个带有消息类型、选项类型和默认选项的 ConfirmationCallback。
ConfirmationCallback(int, String[], int) - 类 javax.security.auth.callback.ConfirmationCallback 的构造方法
构造一个带有消息类型、选项列表和默认选项的 ConfirmationCallback。
ConfirmationCallback(String, int, int, int) - 类 javax.security.auth.callback.ConfirmationCallback 的构造方法
构造一个带有提示、消息类型、选项类型和默认选项的 ConfirmationCallback。
ConfirmationCallback(String, int, String[], int) - 类 javax.security.auth.callback.ConfirmationCallback 的构造方法
构造一个带有提示、消息类型、选项列表和默认选项的 ConfirmationCallback。
connect(PipedOutputStream) - 类 java.io.PipedInputStream 中的方法
使此管道输入流连接到管道输出流 src。
connect(PipedInputStream) - 类 java.io.PipedOutputStream 中的方法
将此管道输出流连接到接收者。
connect(PipedWriter) - 类 java.io.PipedReader 中的方法
使此传送 reader 连接到传送 writer src。
connect(PipedReader) - 类 java.io.PipedWriter 中的方法
将此传送 writer 连接到接收方。
connect(InetAddress, int) - 类 java.net.DatagramSocket 中的方法
将套接字连接到此套接字的远程地址。
connect(SocketAddress) - 类 java.net.DatagramSocket 中的方法
将此套接字连接到远程套接字地址（IP 地址 + 端口号）。
connect(InetAddress, int) - 类 java.net.DatagramSocketImpl 中的方法
将数据报套接字连接到远程目标。
connect(SocketAddress) - 类 java.net.Socket 中的方法
将此套接字连接到服务器。
connect(SocketAddress, int) - 类 java.net.Socket 中的方法
将此套接字连接到服务器，并指定一个超时值。
connect(String, int) - 类 java.net.SocketImpl 中的方法
将此套接字连接到指定主机上的指定端口。
connect(InetAddress, int) - 类 java.net.SocketImpl 中的方法
将此套接字连接到指定主机上的指定端口号。
connect(SocketAddress, int) - 类 java.net.SocketImpl 中的方法
将此套接字连接到指定主机上的指定端口号。
connect() - 类 java.net.URLConnection 中的方法
打开到此 URL 引用的资源的通信链接（如果尚未建立这样的连接）。
connect(SocketAddress) - 类 java.nio.channels.DatagramChannel 中的方法
连接此通道的套接字。
connect(SocketAddress) - 类 java.nio.channels.SocketChannel 中的方法
连接此通道的套接字。
connect(String, Properties) - 接口 java.sql.Driver 中的方法
试图创建一个到给定 URL 的数据库连接。
connect() - 接口 javax.management.remote.JMXConnector 中的方法
建立到连接器服务器的连接。
connect(Map<String, ?>) - 接口 javax.management.remote.JMXConnector 中的方法
建立到连接器服务器的连接。
connect(JMXServiceURL) - 类 javax.management.remote.JMXConnectorFactory 中的静态方法
创建到位于给定地址的连接器服务器的连接。
connect(JMXServiceURL, Map<String, ?>) - 类 javax.management.remote.JMXConnectorFactory 中的静态方法
创建到位于给定地址的连接器服务器的连接。
connect() - 类 javax.management.remote.rmi.RMIConnector 中的方法
connect(Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnector 中的方法
connect(Remote, Remote) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 的委托调用。
connect(ORB) - 类 javax.rmi.CORBA.Stub 中的方法
将此 stub 连接到 ORB。
connect(Stub, ORB) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.connect(org.omg.CORBA.ORB) 的委托调用。
connect(Remote, Remote) - 类 javax.rmi.PortableRemoteObject 中的静态方法
使 Remote 对象准备好进行远程通信。
connect(Object) - 类 org.omg.CORBA.ORB 中的方法
将给定 servant 对象（作为服务器实现类的实例的 Java 对象）连接到 ORB。
connected - 类 java.net.URLConnection 中的变量
如果为 false，则此连接对象尚未创建到指定 URL 的通信链接。
ConnectException - java.net 中的 异常
试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
ConnectException(String) - 异常 java.net.ConnectException 的构造方法
构造一个新的 ConnectException，使其具有关于连接错误产生原因的指定详细消息。
ConnectException() - 异常 java.net.ConnectException 的构造方法
构造不带详细信息的新 ConnectException。
ConnectException - java.rmi 中的 异常
如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
ConnectException(String) - 异常 java.rmi.ConnectException 的构造方法
构造带指定详细消息的 ConnectException。
ConnectException(String, Exception) - 异常 java.rmi.ConnectException 的构造方法
构造带指定详细消息和嵌入异常的 ConnectException。
connectFailed(URI, SocketAddress, IOException) - 类 java.net.ProxySelector 中的方法
调用此方法来指示无法建立到代理/socks 服务器的连接。
CONNECTING_TO_DEVICE - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
打印机已经在输出设备中安排了作业，并且正在与共享的网络输出设备进行连接（并且可能在相当长的时间内无法实际开始打印作业，因为这取决于网络上其他服务器对该输出设备的使用情况）。
ConnectIOException - java.rmi 中的 异常
如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
ConnectIOException(String) - 异常 java.rmi.ConnectIOException 的构造方法
构造带指定详细消息的 ConnectIOException。
ConnectIOException(String, Exception) - 异常 java.rmi.ConnectIOException 的构造方法
构造带指定详细消息和嵌入异常的 ConnectIOException。
Connection - java.sql 中的 接口
与特定数据库的连接（会话）。
connectionClosed(String, String, Object) - 类 javax.management.remote.JMXConnectorServer 中的方法
正常关闭客户端连接时由子类调用。
connectionClosed(String, String, Object) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
connectionClosed(ConnectionEvent) - 接口 javax.sql.ConnectionEventListener 中的方法
通知此 ConnectionEventListener 应用程序已对其入池连接的表示形式调用 close 方法。
connectionErrorOccurred(ConnectionEvent) - 接口 javax.sql.ConnectionEventListener 中的方法
通知此 ConnectionEventListener 发生了严重错误，入池连接不再可用。
ConnectionEvent - javax.sql 中的 类
提供关于连接相关事件的源信息的 Event 对象。
ConnectionEvent(PooledConnection) - 类 javax.sql.ConnectionEvent 的构造方法
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象进行初始化。
ConnectionEvent(PooledConnection, SQLException) - 类 javax.sql.ConnectionEvent 的构造方法
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象和 SQLException 对象进行初始化。
ConnectionEventListener - javax.sql 中的 接口
注册该对象便可获得由 PooledConnection 对象生成的事件的通知。
connectionFailed(String, String, Object) - 类 javax.management.remote.JMXConnectorServer 中的方法
客户端连接失败时由子类调用。
connectionFailed(String, String, Object) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
connectionOpened(String, String, Object) - 类 javax.management.remote.JMXConnectorServer 中的方法
打开新的客户端连接时由子类调用。
connectionOpened(String, String, Object) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
ConnectionPendingException - java.nio.channels 中的 异常
试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
ConnectionPendingException() - 异常 java.nio.channels.ConnectionPendingException 的构造方法
构造此类的一个实例。
ConnectionPoolDataSource - javax.sql 中的 接口
PooledConnection 对象的工厂。
CONNECTOR_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pc”。
CONREF - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Console - java.io 中的 类
此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。
console() - 类 java.lang.System 中的静态方法
返回与当前 Java 虚拟机关联的唯一 Console 对象（如果有）。
ConsoleHandler - java.util.logging 中的 类
此 Handler 向 System.err 发布日志记录。
ConsoleHandler() - 类 java.util.logging.ConsoleHandler 的构造方法
为 System.err 创建一个 ConsoleHandler。
constant(int) - 类 javax.swing.Spring 中的静态方法
返回一个 strut -- 一个其 minimum、preferred 和 maximum 值每个都有值 pref 的 spring。
constant(int, int, int) - 类 javax.swing.Spring 中的静态方法
返回一个其 minimum、preferred 和 maximum 值具有以下值的 spring：分别是 min、pref 和 max。
constantName() - 异常 java.lang.EnumConstantNotPresentException 中的方法
返回缺少的枚举常量的名称。
constraintBeforeFloating - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
Constructor<T> - java.lang.reflect 中的 类
Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
ConstructorProperties - java.beans 中的 注释类型
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。
constructorsIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
elements 中构造方法的列表。
constructorsIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中构造方法的集合。
consume() - 类 java.awt.AWTEvent 中的方法
如果能够使用此事件，则使用此事件。
consume() - 类 java.awt.event.InputEvent 中的方法
使用此事件，以便不会按照默认的方式由产生此事件的源代码来处理此事件。
consume() - 类 java.awt.event.InputMethodEvent 中的方法
使用此事件，以便不会按默认方式由产生此事件的源代码来处理此事件。
consumed - 类 java.awt.AWTEvent 中的变量
在源处理了事件之后，控制是否将事件发送回同位体，false 表示将事件发送给同位体；true 则不发送。
consumer - 类 java.awt.image.ImageFilter 中的变量
特定图像数据流的使用者，而此 ImageFilter 实例也是为这个使用者来过滤数据的。
containedIn(Oid[]) - 类 org.ietf.jgss.Oid 中的方法
一种实用工具方法，可测试此 Oid 值是否包含在所提供的 Oid 数组中。
Container - java.awt 中的 类
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Container() - 类 java.awt.Container 的构造方法
构造一个新的 Container。
Container.AccessibleAWTContainer - java.awt 中的 类
用于对可访问性提供默认支持的 Container 内部类。
Container.AccessibleAWTContainer() - 类 java.awt.Container.AccessibleAWTContainer 的构造方法
Container.AccessibleAWTContainer.AccessibleContainerHandler - java.awt 中的 类
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
Container.AccessibleAWTContainer.AccessibleContainerHandler() - 类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 的构造方法
CONTAINER_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择容器事件的事件掩码。
CONTAINER_FIRST - 类 java.awt.event.ContainerEvent 中的静态变量
用于容器事件的 id 范围的起始编号。
CONTAINER_LAST - 类 java.awt.event.ContainerEvent 中的静态变量
用于容器事件的 id 范围的结束编号。
ContainerAdapter - java.awt.event 中的 类
用于接收容器事件的抽象适配器类。
ContainerAdapter() - 类 java.awt.event.ContainerAdapter 的构造方法
ContainerEvent - java.awt.event 中的 类
指示容器内容因为添加或移除组件而更改的低级别事件。
ContainerEvent(Component, int, Component) - 类 java.awt.event.ContainerEvent 的构造方法
构造一个 ContainerEvent 对象。
ContainerListener - java.awt.event 中的 接口
用于接收容器事件的侦听器接口。
containerListener - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的变量
ContainerOrderFocusTraversalPolicy - java.awt 中的 类
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
ContainerOrderFocusTraversalPolicy() - 类 java.awt.ContainerOrderFocusTraversalPolicy 的构造方法
contains(Point) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
检查指定的点是否在此对象的边界内，该点的 x 坐标和 y 坐标是相对于该对象的坐标系来定义的。
contains(int, int) - 类 java.awt.Component 中的方法
检查组件是否“包含”指定的点，其中 x 和 y 是相对于此组件的坐标系定义的。
contains(Point) - 类 java.awt.Component 中的方法
检查组件是否“包含”指定的点，其中该点的 x 和 y 坐标是相对于此组件的坐标系定义的。
contains(double, double) - 类 java.awt.geom.Arc2D 中的方法
确定指定的点是否位于弧的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
确定弧的内部是否完全包含指定的矩形。
contains(Rectangle2D) - 类 java.awt.geom.Arc2D 中的方法
确定弧的内部是否完全包含指定的矩形。
contains(double, double) - 类 java.awt.geom.Area 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.geom.Area 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Area 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.geom.Area 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.CubicCurve2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.geom.CubicCurve2D 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.geom.CubicCurve2D 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.Ellipse2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Ellipse2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(double, double) - 类 java.awt.geom.Line2D 中的方法
测试指定坐标是否在此 Line2D 对象的边界内。
contains(Point2D) - 类 java.awt.geom.Line2D 中的方法
测试给定 Point2D 是否在此 Line2D 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Line2D 中的方法
测试此 Line2D 的内部是否完全包含指定矩形坐标集。
contains(Rectangle2D) - 类 java.awt.geom.Line2D 中的方法
测试此 Line2D 内部是否完全包含指定的 Rectangle2D。
contains(PathIterator, double, double) - 类 java.awt.geom.Path2D 中的静态方法
测试指定的坐标是否在指定 PathIterator 的封闭边界内。
contains(PathIterator, Point2D) - 类 java.awt.geom.Path2D 中的静态方法
测试指定的 Point2D 是否在指定 PathIterator 的封闭边界内。
contains(double, double) - 类 java.awt.geom.Path2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.geom.Path2D 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(PathIterator, double, double, double, double) - 类 java.awt.geom.Path2D 中的静态方法
测试指定矩形区域是否完全在指定 PathIterator 的封闭边界内。
contains(PathIterator, Rectangle2D) - 类 java.awt.geom.Path2D 中的静态方法
测试指定的 Rectangle2D 是否完全在指定 PathIterator 的封闭区域内。
contains(double, double, double, double) - 类 java.awt.geom.Path2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.geom.Path2D 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.QuadCurve2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.geom.QuadCurve2D 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.geom.QuadCurve2D 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.Rectangle2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Point2D) - 类 java.awt.geom.RectangularShape 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(Rectangle2D) - 类 java.awt.geom.RectangularShape 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Point) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
检查指定点是否位于此对象的界限中，其中该点的 X 坐标和 Y 坐标是相对于对象的定义的。
contains(Point) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系相关。
contains(Point) - 类 java.awt.Polygon 中的方法
确定指定的 Point 是否位于此 Polygon 的内部。
contains(int, int) - 类 java.awt.Polygon 中的方法
确定指定的坐标是否位于此 Polygon 的内部。
contains(double, double) - 类 java.awt.Polygon 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 类 java.awt.Polygon 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 类 java.awt.Polygon 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 类 java.awt.Polygon 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(Point) - 类 java.awt.Rectangle 中的方法
检查此 Rectangle 是否包含指定的 Point。
contains(int, int) - 类 java.awt.Rectangle 中的方法
检查此 Rectangle 是否包含位于指定位置 (x,y) 的点。
contains(Rectangle) - 类 java.awt.Rectangle 中的方法
检查此 Rectangle 是否完全包含指定的 Rectangle。
contains(int, int, int, int) - 类 java.awt.Rectangle 中的方法
检查此 Rectangle 是否完全包含位于指定位置 (X,Y) 且具有指定维数 (W,H) 的 Rectangle。
contains(double, double) - 接口 java.awt.Shape 中的方法
测试指定坐标是否在 Shape 的边界内。
contains(Point2D) - 接口 java.awt.Shape 中的方法
测试指定的 Point2D 是否在 Shape 的边界内。
contains(double, double, double, double) - 接口 java.awt.Shape 中的方法
测试 Shape 内部是否完全包含指定矩形区域。
contains(Rectangle2D) - 接口 java.awt.Shape 中的方法
测试 Shape 内部是否完全包含指定的 Rectangle2D。
contains(Object) - 类 java.beans.beancontext.BeanContextMembershipEvent 中的方法
指定子级受事件影响吗？
contains(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
确定指定对象当前是否是此 BeanContext 的子级。
contains(CharSequence) - 类 java.lang.String 中的方法
当且仅当此字符串包含指定的 char 值序列时，返回 true。
contains(Charset) - 类 java.nio.charset.Charset 中的方法
通知此 charset 是否包含给定的 charset。
contains(Object) - 类 java.util.AbstractCollection 中的方法
如果此 collection 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.ArrayDeque 中的方法
如果此双端队列包含指定元素，则返回 true。
contains(Object) - 类 java.util.ArrayList 中的方法
如果此列表中包含指定的元素，则返回 true。
contains(Object) - 接口 java.util.Collection 中的方法
如果此 collection 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
如果此队列包含指定的元素，则返回 true。
contains(Object) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果此双端队列包含指定的元素，则返回 true。
contains(Object) - 接口 java.util.concurrent.BlockingQueue 中的方法
如果此队列包含指定元素，则返回 true。
contains(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
一种遗留方法，测试此表中是否有一些与指定值存在映射关系的键。
contains(Object) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
如果此队列包含指定元素，则返回 true。
contains(Object) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
如果此 set 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
如果此列表包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果此 set 包含指定元素，则返回 true。
contains(Object) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
如果此双端队列包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
如果队列包含指定的元素，则返回 true。
contains(Object) - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 false。
contains(Object) - 接口 java.util.Deque 中的方法
如果此双端队列包含指定元素，则返回 true。
contains(Object) - 类 java.util.HashSet 中的方法
如果此 set 包含指定元素，则返回 true。
contains(Object) - 类 java.util.Hashtable 中的方法
测试此映射表中是否存在与指定值关联的键。
contains(Object) - 类 java.util.LinkedList 中的方法
如果此列表包含指定元素，则返回 true。
contains(Object) - 接口 java.util.List 中的方法
如果列表包含指定的元素，则返回 true。
contains(Object) - 类 java.util.PriorityQueue 中的方法
如果此队列包含指定的元素，则返回 true。
contains(Object) - 接口 java.util.Set 中的方法
如果 set 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.TreeSet 中的方法
如果此 set 包含指定的元素，则返回 true。
contains(Object) - 类 java.util.Vector 中的方法
如果此向量包含指定的元素，则返回 true。
contains(Point) - 接口 javax.accessibility.AccessibleComponent 中的方法
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
contains(String) - 类 javax.accessibility.AccessibleRelationSet 中的方法
返回关系集是否包含与指定键匹配的关系。
contains(AccessibleState) - 类 javax.accessibility.AccessibleStateSet 中的方法
检查当前状态是否在状态集中。
contains(Object) - 类 javax.imageio.spi.ServiceRegistry 中的方法
如果当前注册了 provider，则返回 true。
contains(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
测试一个类型参数是否包含 另一个类型参数。
contains(Object) - 接口 javax.naming.directory.Attribute 中的方法
确定某个值是否在属性中。
contains(Object) - 类 javax.naming.directory.BasicAttribute 中的方法
确定值是否在此属性中。
contains(int) - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
确定此整数集属性是否包含给定的值。
contains(IntegerSyntax) - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
确定此整数集属性是否包含给定的整数属性的值。
contains(Object) - 类 javax.swing.DefaultListModel 中的方法
测试指定对象是否为此类表中的组件。
contains(int, int) - 类 javax.swing.JComponent 中的方法
为了进行鼠标处理，让 UI 委托来定义此组件的精确形状。
contains(Point) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
contains(Point) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系统相关。
contains(Point) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
contains(Object) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
contains(JComponent, int, int) - 类 javax.swing.plaf.ComponentUI 中的方法
如果指定 x,y 位置包含在指定组件外观的已定义形状中，则返回 true。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(JComponent, int, int) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 contains 方法。
contains(Point) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
contains(String) - 接口 org.w3c.dom.DOMStringList 中的方法
测试一个字符串是否是此 DOMStringList 的一部分。
contains(String) - 接口 org.w3c.dom.NameList 中的方法
测试名称是否是此 NameList 中的一部分。
containsAlias(String) - 类 java.security.KeyStore 中的方法
检查给定别名是否存在于此 keystore 中。
containsAll(Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
测试以查看指定 Collection 中的所有对象是否是此 BeanContext 的子对象。
containsAll(Collection<?>) - 类 java.util.AbstractCollection 中的方法
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
containsAll(Collection<?>) - 接口 java.util.Collection 中的方法
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
containsAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
如果此列表包含指定 collection 的所有元素，则返回 true。
containsAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果此 set 包含指定 collection 的所有元素，则返回 true。
containsAll(Collection<?>) - 类 java.util.concurrent.SynchronousQueue 中的方法
除非给定 collection 为空，否则返回 false。
containsAll(Collection<?>) - 接口 java.util.List 中的方法
如果列表包含指定 collection 的所有元素，则返回 true。
containsAll(Collection<?>) - 接口 java.util.Set 中的方法
如果此 set 包含指定 collection 的所有元素，则返回 true。
containsAll(Collection<?>) - 类 java.util.Vector 中的方法
如果此向量包含指定 Collection 中的所有元素，则返回 true。
containsAngle(double) - 类 java.awt.geom.Arc2D 中的方法
确定指定的角度是否位于弧的角跨越内。
containsAttribute(Object, Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查是否定义了给定的属性名称/值。
containsAttribute(Object, Object) - 接口 javax.swing.text.AttributeSet 中的方法
如果此集合用相同的名称和相等值定义一个属性，则返回 true 。
containsAttribute(Object, Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
检查属性列表中是否包含了指定的属性名称/值对。
containsAttribute(Object, Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
确定给定的属性名称/值是否已定义。
containsAttribute(Object, Object) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
检查给定的属性名称/值是否已定义。
containsAttributes(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查该元素是否包含所有的属性。
containsAttributes(AttributeSet) - 接口 javax.swing.text.AttributeSet 中的方法
如果此集合用相等值定义给定集合中的所有属性，则返回 true。
containsAttributes(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
确定属性列表中是否包含所有指定的名称/值对。
containsAttributes(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
检查元素是否包含了所有属性。
containsAttributes(AttributeSet) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
检查属性集是否包含了所有给定的属性。
containsCustomComponents(JOptionPane) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
如果在上一次对 validateComponent 的调用中消息或按钮包含 Component 的子类，则返回 true。
containsCustomComponents(JOptionPane) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 containsCustomComponents 方法。
containsCustomComponents(JOptionPane) - 类 javax.swing.plaf.OptionPaneUI 中的方法
如果用户已经为选项或消息提供 Component 实例，则返回 true。
containsKey(Object) - 类 java.awt.RenderingHints 中的方法
如果此 RenderingHints 包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
确定指定对象当前是否是此 BeanContext 的子级。
containsKey(Object) - 类 java.util.AbstractMap 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
测试指定对象是否为此表中的键。
containsKey(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.EnumMap 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.HashMap 中的方法
如果此映射包含对于指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.Hashtable 中的方法
测试指定对象是否为此哈希表中的键。
containsKey(Object) - 类 java.util.IdentityHashMap 中的方法
测试指定的对象引用是否为此标识哈希映射中的键。
containsKey(Object) - 类 java.util.jar.Attributes 中的方法
如果此 Map 包含指定的属性名称（键），则返回 true。
containsKey(Object) - 接口 java.util.Map 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(String) - 类 java.util.ResourceBundle 中的方法
确定给定 key 是否包含在此 ResourceBundle 及其父包中。
containsKey(Object) - 类 java.util.TreeMap 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 java.util.WeakHashMap 中的方法
如果此映射对于指定的键包含映射关系，则返回 true。
containsKey(String) - 接口 javax.management.openmbean.CompositeData 中的方法
当且仅当此 CompositeData 实例包含名称为 key 的项时，返回 true。
containsKey(String) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
当且仅当此 CompositeData 实例包含名称是 key 的项时，才返回 true。
containsKey(String) - 类 javax.management.openmbean.CompositeType 中的方法
如果此 CompositeType 实例定义了名称为 itemName 的项，则返回 true。
containsKey(Object[]) - 接口 javax.management.openmbean.TabularData 中的方法
当且仅当此 TabularData 实例包含其索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
containsKey(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
containsKey(Object[]) - 类 javax.management.openmbean.TabularDataSupport 中的方法
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
containsKey(Class<?>) - 接口 javax.print.attribute.AttributeSet 中的方法
如果此属性集包含指定类别的一个属性，则返回 true。
containsKey(Class<?>) - 类 javax.print.attribute.HashAttributeSet 中的方法
如果此属性集包含指定类别的属性，则返回 true。
containsKey(Object) - 接口 javax.script.Bindings 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsKey(Object) - 类 javax.script.SimpleBindings 中的方法
如果此映射包含指定键的映射关系，则返回 true。
containsNS(String, String) - 接口 org.w3c.dom.NameList 中的方法
测试 namespaceURI/name 对是否是此 NameList 中的一部分。
containsObservedObject(ObjectName) - 类 javax.management.monitor.Monitor 中的方法
测试指定的对象是否在所观察的 MBean 集中。
containsObservedObject(ObjectName) - 接口 javax.management.monitor.MonitorMBean 中的方法
测试指定的对象是否在所观察的 MBean 集中。
containsValue(Object) - 类 java.awt.RenderingHints 中的方法
如果此 RenderingHints 将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.AbstractMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
如果此映射为指定值映射一个或多个键，则返回 true。
containsValue(Object) - 类 java.util.EnumMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.HashMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.Hashtable 中的方法
如果此 Hashtable 将一个或多个键映射到此值，则返回 true。
containsValue(Object) - 类 java.util.IdentityHashMap 中的方法
测试指定的对象引用是否为此标识哈希映射中的值。
containsValue(Object) - 类 java.util.jar.Attributes 中的方法
如果此 Map 将一个或多个属性名称（键）映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.LinkedHashMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 接口 java.util.Map 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 类 java.util.TreeMap 中的方法
如果此映射为指定值映射一个或多个键，则返回 true。
containsValue(Object) - 类 java.util.WeakHashMap 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
containsValue(Object) - 接口 javax.management.openmbean.CompositeData 中的方法
当且仅当此 CompositeData 实例包含值为 value 的项时，返回 true。
containsValue(Object) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
当且仅当此 CompositeData 实例包含其值是 value 的项时，返回 true。
containsValue(CompositeData) - 接口 javax.management.openmbean.TabularData 中的方法
当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
containsValue(CompositeData) - 类 javax.management.openmbean.TabularDataSupport 中的方法
当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
containsValue(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
当且仅当此 TabularData 实例包含指定的值时，才返回 true。
containsValue(Attribute) - 接口 javax.print.attribute.AttributeSet 中的方法
如果此属性集包含给定的属性值，则返回 true。
containsValue(Attribute) - 类 javax.print.attribute.HashAttributeSet 中的方法
如果此属性集包含给定的属性，则返回 true。
containsValue(Object) - 类 javax.script.SimpleBindings 中的方法
如果此映射将一个或多个键映射到指定值，则返回 true。
CONTENT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
CONTENT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
所有文本内容以此标记作为标签。
content - 类 javax.swing.text.html.parser.ContentModel 中的变量
内容。
content - 类 javax.swing.text.html.parser.Element 中的变量
CONTENT_AREA_FILLED_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对按钮绘制的内容区域的更改。
CONTENT_PANE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
CONTENT_TYPE - 类 java.util.jar.Attributes.Name 中的静态变量
Content-Type 的 Name 对象具有的属性。
content_type() - 类 org.omg.CORBA.TypeCode 中的方法
返回表示此 TypeCode 对象所描述成员 IDL 类型的 TypeCode 对象。
contentBorderInsets - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
ContentElementName - 类 javax.swing.text.AbstractDocument 中的静态变量
用于表示内容的元素名
contentEquals(StringBuffer) - 类 java.lang.String 中的方法
将此字符串与指定的 StringBuffer 比较。
contentEquals(CharSequence) - 类 java.lang.String 中的方法
将此字符串与指定的 CharSequence 比较。
contentEquals(CharSequence) - 接口 javax.lang.model.element.Name 中的方法
将此名称与指定的 CharSequence 进行比较。
ContentHandler - java.net 中的 类
抽象类 ContentHandler 是从 URLConnection 读取 Object 的所有类的超类。
ContentHandler() - 类 java.net.ContentHandler 的构造方法
ContentHandler - org.xml.sax 中的 接口
接收文档逻辑内容的通知。
ContentHandlerFactory - java.net 中的 接口
此接口定义内容处理程序的工厂。
ContentModel - javax.swing.text.html.parser 中的 类
内容模式的表示形式。
ContentModel() - 类 javax.swing.text.html.parser.ContentModel 的构造方法
ContentModel(Element) - 类 javax.swing.text.html.parser.ContentModel 的构造方法
为元素创建一个内容模式。
ContentModel(int, ContentModel) - 类 javax.swing.text.html.parser.ContentModel 的构造方法
创建一个特定类型的内容模式。
ContentModel(int, Object, ContentModel) - 类 javax.swing.text.html.parser.ContentModel 的构造方法
创建一个特定类型的内容模式。
contentPane - 类 javax.swing.JRootPane 中的变量
内容窗格。
contentRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
contents - 类 java.awt.datatransfer.Clipboard 中的变量
CONTENTS_CHANGED - 类 javax.swing.event.ListDataEvent 中的静态变量
标识列表内容中的一处或多处更改。
contentsChanged(ListDataEvent) - 接口 javax.swing.event.ListDataListener 中的方法
在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。
contentsChanged(ListDataEvent) - 类 javax.swing.JComboBox 中的方法
此方法作为实现的副作用存在的公共方法。
contentsChanged(ListDataEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
List Data Listener 内容更改方法。
contentsChanged(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 中的方法
contentsChanged(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 中的方法
contentsChanged(ListDataEvent) - 类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 中的方法
contentsLost() - 类 java.awt.Component.BltBufferStrategy 中的方法
contentsLost() - 类 java.awt.Component.FlipBufferStrategy 中的方法
contentsLost() - 类 java.awt.image.BufferStrategy 中的方法
返回上次调用 getDrawGraphics 后绘制缓冲区是否丢失。
contentsLost() - 类 java.awt.image.VolatileImage 中的方法
如果上次调用 validate 后呈现数据丢失，则返回 true。
contentsRestored() - 类 java.awt.Component.BltBufferStrategy 中的方法
contentsRestored() - 类 java.awt.Component.FlipBufferStrategy 中的方法
contentsRestored() - 类 java.awt.image.BufferStrategy 中的方法
返回绘制缓冲区最近是否从丢失状态恢复，并重新初始化为默认背景色（白色）。
ContentType - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getType 的可能值。
context - 类 java.awt.dnd.DropTargetEvent 中的变量
与此 DropTargetEvent 相关的 DropTargetContext。
Context - javax.naming 中的 接口
此接口表示一个命名上下文，它由一组名称到对象的绑定组成。
context - 类 javax.script.AbstractScriptEngine 中的变量
此 AbstractScriptEngine 的默认 ScriptContext。
Context - org.omg.CORBA 中的 类
用于在 Request 操作中指定上下文对象的对象，上下文字符串在与请求调用一起被发送之前，必须在该指定的上下文对象中进行解析。
Context() - 类 org.omg.CORBA.Context 的构造方法
context_data - 类 org.omg.IOP.ServiceContext 中的变量
与此服务上下文关联的数据
CONTEXT_EXPIRED - 异常 org.ietf.jgss.GSSException 中的静态变量
安全上下文过期。
context_id - 类 org.omg.IOP.ServiceContext 中的变量
服务上下文 id
context_name() - 类 org.omg.CORBA.Context 中的方法
检索此 Context 对象的名称。
ContextList - org.omg.CORBA 中的 类
一个对象，它包含表示属性名称的 String 对象所组成的可修改列表。
ContextList() - 类 org.omg.CORBA.ContextList 的构造方法
ContextNotEmptyException - javax.naming 中的 异常
当试图销毁一个不为空的上下文时，抛出此异常。
ContextNotEmptyException(String) - 异常 javax.naming.ContextNotEmptyException 的构造方法
使用解释构造一个新的 ContextNotEmptyException 实例。
ContextNotEmptyException() - 异常 javax.naming.ContextNotEmptyException 的构造方法
构造一个新的 ContextNotEmptyException 实例，将解释和所有名称解析字段初始化为 null。
contexts() - 类 org.omg.CORBA.Request 中的方法
检索用于此请求的 ContextList 对象。
contexts() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 String 对象数组，这些对象描述可以在此操作调用上传递的上下文。
ContextualRenderedImageFactory - java.awt.image.renderable 中的 接口
ContextualRenderedImageFactory 为在 RenderableImageOp 实例之间可能不同的功能提供接口。
CONTIGUOUS_TREE_SELECTION - 接口 javax.swing.tree.TreeSelectionModel 中的静态变量
选择只能是连续的。
CONTINUE - 类 javax.sound.midi.ShortMessage 中的静态变量
CONTINUE 消息的状态字节（0xFB 或 251）。
continueDrag(int, int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
continueDrag(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
用鼠标事件的新位置传递 dragDividerTo 的消息。
CONTINUOUS_LAYOUT_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 continuousLayout 属性名称。
continuousLayout - 类 javax.swing.JSplitPane 中的变量
当调整大小时视图是否连续重新显示。
contListener - 类 javax.swing.plaf.metal.MetalToolBarUI 中的变量
此受保护的字段是特定于实现的。
CONTROL - 类 java.awt.SystemColor 中的静态变量
SystemColor.control 系统颜色的数组索引。
control - 类 java.awt.SystemColor 中的静态变量
为控制面板和控制对象（比如按钮）提供的颜色。
CONTROL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Cc”。
Control - javax.naming.ldap 中的 接口
此接口表示在 RFC 2251 中定义的 LDAPv3 控件。
Control - javax.sound.sampled 中的 类
Line 常常具有一个控件（如 gain 和 pan）集合，这些控件都会影响通过行传递的音频信号。
Control(Control.Type) - 类 javax.sound.sampled.Control 的构造方法
构造具有指定类型的控件。
Control.Type - javax.sound.sampled 中的 类
Type 类的实例表示控件的类型。
Control.Type(String) - 类 javax.sound.sampled.Control.Type 的构造方法
构造具有指定名称的新控件类型。
CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
指示显示控制按钮。
CONTROL_CHANGE - 类 javax.sound.midi.ShortMessage 中的静态变量
CONTROL_CHANGE 消息的命令值（0xB0 或 176）
CONTROL_DK_SHADOW - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlDkShadow 系统颜色的数组索引。
CONTROL_FACTORIES - 接口 javax.naming.ldap.LdapContext 中的静态变量
该常量保存用来指定要使用的控件工厂列表的环境属性名称。
CONTROL_HIGHLIGHT - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlHighlight 系统颜色的数组索引。
CONTROL_LT_HIGHLIGHT - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlLtHighlight 系统颜色的数组索引。
CONTROL_PICTURES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Control Pictures”Unicode 字符块的常量。
CONTROL_SHADOW - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlShadow 系统颜色的数组索引。
CONTROL_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.controlText 系统颜色的数组索引。
controlChange(ShortMessage) - 接口 javax.sound.midi.ControllerEventListener 中的方法
当 Sequencer 遇到并处理了一个此侦听器需要的控制更改事件时调用。
controlChange(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
对指定控件的值的更改作出反应。
controlDkShadow - 类 java.awt.SystemColor 中的静态变量
为 3D 控制对象（比如按钮）的加黑阴影区域提供的颜色。
controlDown() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
ControlFactory - javax.naming.ldap 中的 类
此抽象类表示用于创建 LDAPv3 控件的工厂。
ControlFactory() - 类 javax.naming.ldap.ControlFactory 的构造方法
controlHighlight - 类 java.awt.SystemColor 中的静态变量
为 3D 控制对象（比如按钮）的亮区提供的颜色。
CONTROLLED_BY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象由一个或多个目标对象控制。
CONTROLLED_BY_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识正在进行控制操作的目标对象已更改
controller - 类 javax.imageio.IIOParam 中的变量
调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的 IIOParamController。
controller - 类 javax.imageio.metadata.IIOMetadata 中的变量
调用 activateController 方法时，将用来为此 IIOMetadataController 对象提供设置值的 IIOParamController。
CONTROLLER_FOR - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个目标对象的控制器。
CONTROLLER_FOR_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识目标对象的控制器已更改
ControllerEventListener - javax.sound.midi 中的 接口
ControllerEventListener 接口应由一个其实例需要在 Sequencer 处理了请求的 MIDI 控制更改事件类型时接收通知的类实现。
controlLtHighlight - 类 java.awt.SystemColor 中的静态变量
为 3D 控制对象（比如按钮）的高亮区域提供的颜色。
controlShadow - 类 java.awt.SystemColor 中的静态变量
为 3D 控制对象（比如按钮）的阴影区域提供的颜色。
controlText - 类 java.awt.SystemColor 中的静态变量
为控制面板和控制对象（比如按钮）的文本提供的颜色。
convert(long, TimeUnit) - 枚举 java.util.concurrent.TimeUnit 中的方法
将给定单元的时间段转换到此单元。
convertColumnIndexToModel(int) - 类 javax.swing.JTable 中的方法
将视图中位于 viewColumnIndex 的列索引映射到表模型中的列索引。
convertColumnIndexToView(int) - 类 javax.swing.JTable 中的方法
将表模型中位于 modelColumnIndex 的列索引映射到视图中的列索引。
CONVERTED_TEXT - 类 java.awt.im.InputMethodHighlight 中的静态变量
已转换文本状态的常量。
convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - 接口 javax.imageio.ImageTranscoder 中的方法
返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
convertMouseEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
convertMouseEvent(Component, MouseEvent, Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。
convertPoint(Component, Point, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
convertPoint(Component, int, int, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将 source 坐标系统中的点 (x,y) 转换到 destination 坐标系统。
convertPointFromScreen(Point, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将一个点从屏幕坐标转换到组件的坐标系统
convertPointToScreen(Point, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将一个点从组件的坐标系统转换到屏幕坐标。
convertPreviousRowIndexToModel(int) - 类 javax.swing.event.RowSorterEvent 中的方法
返回基于模型排序之前的 index 的位置。
convertRectangle(Component, Rectangle, Component) - 类 javax.swing.SwingUtilities 中的静态方法
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
convertRowIndexToModel(int) - 类 javax.swing.DefaultRowSorter 中的方法
返回基于底层模型的 index 的位置。
convertRowIndexToModel(int) - 类 javax.swing.JTable 中的方法
将基于视图的行索引映射到底层 TableModel。
convertRowIndexToModel(int) - 类 javax.swing.RowSorter 中的方法
返回基于底层模型的 index 的位置。
convertRowIndexToView(int) - 类 javax.swing.DefaultRowSorter 中的方法
返回基于视图 index 的位置。
convertRowIndexToView(int) - 类 javax.swing.JTable 中的方法
将基于 TableModel 的行索引映射到该视图。
convertRowIndexToView(int) - 类 javax.swing.RowSorter 中的方法
返回基于视图 index 的位置。
convertRowToY(int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回指定行的原点的 JList 相对 Y 坐标，如果 row 无效，则返回 -1。
convertStreamMetadata(IIOMetadata, ImageWriteParam) - 接口 javax.imageio.ImageTranscoder 中的方法
返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
convertStreamMetadata(IIOMetadata, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
convertToIntDiscrete(Raster, boolean) - 类 java.awt.image.IndexColorModel 中的方法
返回一个 TYPE_INT_ARGB 或 TYPE_INT_RGB 的新 BufferedImage，其 Raster 的像素数据是通过使用此 ColorModel 的颜色/alpha 分量数组扩展源 Raster 中的各索引来计算的。
convertToVector(Object[]) - 类 javax.swing.table.DefaultTableModel 中的静态方法
返回一个包含与该数组相同的对象的向量。
convertToVector(Object[][]) - 类 javax.swing.table.DefaultTableModel 中的静态方法
返回一个 vector，该 vector 由包含与该数组相同的对象的多个 vector 组成。
convertValueToText(Object, boolean, boolean, boolean, int, boolean) - 类 javax.swing.JTree 中的方法
通过渲染器调用以将指定值转换为文本。
convertYToRow(int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
基于当前布局，将 JList 相对坐标转换为包含它的行。
ConvolveOp - java.awt.image 中的 类
此类实现从源到目标的卷积。
ConvolveOp(Kernel, int, RenderingHints) - 类 java.awt.image.ConvolveOp 的构造方法
构造给定 Kernel、边缘条件和 RenderingHint 对象（可以为 null）的 ConvolveOp。
ConvolveOp(Kernel) - 类 java.awt.image.ConvolveOp 的构造方法
构造给定了 Kernel 的 ConvolveOp。
CookieHandler - java.net 中的 类
CookieHandler 对象提供一种回调机制以将 HTTP 状态管理策略实现挂钩到 HTTP 协议处理程序。
CookieHandler() - 类 java.net.CookieHandler 的构造方法
CookieHolder - org.omg.PortableServer.ServantLocatorPackage 中的 类
native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。
CookieHolder() - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 的构造方法
CookieHolder(Object) - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 的构造方法
CookieManager - java.net 中的 类
CookieManager 提供 CookieHandler 的具体实现，它将 cookie 的存储区与围绕接受和拒绝 cookie 的策略分离开来。
CookieManager() - 类 java.net.CookieManager 的构造方法
创建一个新 cookie 管理器。
CookieManager(CookieStore, CookiePolicy) - 类 java.net.CookieManager 的构造方法
使用指定 cookie 存储区和 cookie 策略创建一个新 cookie 管理器。
CookiePolicy - java.net 中的 接口
CookiePolicy 实现决定应该接受哪个 cookie 以及应该拒绝哪个 cookie。
CookieStore - java.net 中的 接口
表示 cookie 存储区的 CookieStore 对象。
COORDS - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
COPIED - 类 java.awt.BufferCapabilities.FlipContents 中的静态变量
当翻转内容为 COPIED 时，翻转时将后台缓冲区的内容复制到前台缓冲区。
Copies - javax.print.attribute.standard 中的 类
Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
Copies(int) - 类 javax.print.attribute.standard.Copies 的构造方法
构造具有给定整数值的新副本属性。
CopiesSupported - javax.print.attribute.standard 中的 类
CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
CopiesSupported(int) - 类 javax.print.attribute.standard.CopiesSupported 的构造方法
构造一个新的支持副本的属性，它包含单个整数。
CopiesSupported(int, int) - 类 javax.print.attribute.standard.CopiesSupported 的构造方法
构造一个新的支持副本的属性，它包含一个整数范围。
copy(List<? super T>, List<? extends T>) - 类 java.util.Collections 中的静态方法
将所有元素从一个列表复制到另一个列表。
copy() - 类 javax.swing.JPasswordField 中的方法
对当前外观调用 provideErrorFeedback，这通常启动错误蜂鸣。
copy - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的变量
copy() - 类 javax.swing.text.JTextComponent 中的方法
将关联文本模型中当前选定的范围传输到系统剪贴板，并在文本模型中保留内容。
COPY - 类 javax.swing.TransferHandler 中的静态变量
表示“复制”传输动作的 int 值。
copy() - 类 org.omg.CORBA._PolicyStub 中的方法
复制策略对象。
copy() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 克隆此 DynAny 对象。
copy() - 接口 org.omg.CORBA.PolicyOperations 中的方法
返回 Policy 对象的副本。
copy() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynStructStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 类 org.omg.DynamicAny._DynValueStub 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
copy() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
创建一个新 DynAny 对象，其值为调用此方法的 DynAny 的深层复制。
COPY_OR_MOVE - 类 javax.swing.TransferHandler 中的静态变量
表示“复制”或“移动”的源操作功能的 int 值。
copyAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
复制选定区域并将其内容置于剪贴板中的动作名称。
copyArea(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
将组件的区域复制到由 dx 和 dy 指定的距离处。
copyArea(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.copyArea。
copyAttributes() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
复制属性集合。
copyAttributes() - 接口 javax.swing.text.AttributeSet 中的方法
返回保证固定不变的属性集。
copyAttributes() - 类 javax.swing.text.SimpleAttributeSet 中的方法
创建属性的副本。
copyAttributes() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
复制属性集。
copyAttributes() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
复制属性集。
copyChildren() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得此 BeanContext 子级的副本。
copyData(WritableRaster) - 类 java.awt.image.BufferedImage 中的方法
计算 BufferedImage 的一个任意矩形区域，并将其复制到指定的 WritableRaster。
copyData(WritableRaster) - 接口 java.awt.image.RenderedImage 中的方法
计算 RenderedImage 的任意矩形区域，并将其复制到调用者提供的 WritableRaster 中。
copyInto(Object[]) - 类 java.util.Vector 中的方法
将此向量的组件复制到指定的数组中。
copyInto(Object[]) - 类 javax.swing.DefaultListModel 中的方法
将此列表的组件复制到指定数组中。
copyObject(Object, ORB) - 类 javax.rmi.CORBA.Util 中的静态方法
复制或连接一个对象。
copyObject(Object, ORB) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。
copyObjects(Object[], ORB) - 类 javax.rmi.CORBA.Util 中的静态方法
复制或连接一个对象数组。
copyObjects(Object[], ORB) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。
copyOf(T[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。
copyOf(U[], int, Class<? extends T[]>) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。
copyOf(byte[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(short[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(int[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(long[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(char[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 null 字符填充（如有必要），以使副本具有指定的长度。
copyOf(float[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(double[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
copyOf(boolean[], int) - 类 java.util.Arrays 中的静态方法
复制指定的数组，截取或用 false 填充（如有必要），以使副本具有指定的长度。
copyOf(EnumSet<E>) - 类 java.util.EnumSet 中的静态方法
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。
copyOf(Collection<E>) - 类 java.util.EnumSet 中的静态方法
创建一个从指定 collection 初始化的枚举 set。
copyOfRange(T[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(U[], int, int, Class<? extends T[]>) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(byte[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(short[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(int[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(long[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(char[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(float[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(double[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
copyOfRange(boolean[], int, int) - 类 java.util.Arrays 中的静态方法
将指定数组的指定范围复制到一个新数组。
CopyOnWriteArrayList<E> - java.util.concurrent 中的 类
ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
CopyOnWriteArrayList() - 类 java.util.concurrent.CopyOnWriteArrayList 的构造方法
创建一个空列表。
CopyOnWriteArrayList(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArrayList 的构造方法
创建一个按 collection 的迭代器返回元素的顺序包含指定 collection 元素的列表。
CopyOnWriteArrayList(E[]) - 类 java.util.concurrent.CopyOnWriteArrayList 的构造方法
创建一个保存给定数组的副本的列表。
CopyOnWriteArraySet<E> - java.util.concurrent 中的 类
对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
CopyOnWriteArraySet() - 类 java.util.concurrent.CopyOnWriteArraySet 的构造方法
创建一个空 set。
CopyOnWriteArraySet(Collection<? extends E>) - 类 java.util.concurrent.CopyOnWriteArraySet 的构造方法
创建一个包含指定 collection 所有元素的 set。
copySign(double, double) - 类 java.lang.Math 中的静态方法
返回带有第二个浮点参数符号的第一个浮点参数。
copySign(float, float) - 类 java.lang.Math 中的静态方法
返回带有第二个浮点参数符号的第一个浮点参数。
copySign(double, double) - 类 java.lang.StrictMath 中的静态方法
返回带有第二个浮点参数符号的第一个浮点参数。
copySign(float, float) - 类 java.lang.StrictMath 中的静态方法
返回带有第二个浮点参数符号的第一个浮点参数。
copyValueOf(char[], int, int) - 类 java.lang.String 中的静态方法
返回指定数组中表示该字符序列的 String。
copyValueOf(char[]) - 类 java.lang.String 中的静态方法
返回指定数组中表示该字符序列的 String。
cos(double) - 类 java.lang.Math 中的静态方法
返回角的三角余弦。
cos(double) - 类 java.lang.StrictMath 中的静态方法
返回角的三角余弦。
cosh(double) - 类 java.lang.Math 中的静态方法
返回 double 值的双曲线余弦。
cosh(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的双曲线余弦。
count - 类 java.io.BufferedInputStream 中的变量
比缓冲区中最后一个有效字节的索引大 1 的索引。
count - 类 java.io.BufferedOutputStream 中的变量
缓冲区中的有效字节数。
count - 类 java.io.ByteArrayInputStream 中的变量
比输入流缓冲区中最后一个有效字符的索引大一的索引。
count - 类 java.io.ByteArrayOutputStream 中的变量
缓冲区中的有效字节数。
count - 类 java.io.CharArrayReader 中的变量
此缓冲区结尾处的索引。
count - 类 java.io.CharArrayWriter 中的变量
缓冲区中的 char 数目。
count - 类 java.io.StringBufferInputStream 中的变量
已过时。 输入流缓冲区中有效字符数。
count - 类 javax.swing.text.Segment 中的变量
这是构成所需文本的数组元素的数目。
count() - 类 org.omg.CORBA.ContextList 中的方法
返回此 ContextList 对象中的 String 对象数。
count() - 类 org.omg.CORBA.ExceptionList 中的方法
检索此 ExceptionList 对象中 TypeCode 对象的个数。
count() - 类 org.omg.CORBA.NVList 中的方法
返回已添加到此 NVList 对象的 NamedValue 对象数。
countAttachments() - 类 javax.xml.soap.SOAPMessage 中的方法
获取此消息中附件数量的计数。
countComponents() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 etComponentCount() 取代。
countDown() - 类 java.util.concurrent.CountDownLatch 中的方法
递减锁存器的计数，如果计数到达零，则释放所有等待的线程。
CountDownLatch - java.util.concurrent 中的 类
一个同步辅助类，在完成一组正在其他线程中执行的操作之前，它允许一个或多个线程一直等待。
CountDownLatch(int) - 类 java.util.concurrent.CountDownLatch 的构造方法
构造一个用给定计数初始化的 CountDownLatch。
CounterMonitor - javax.management.monitor 中的 类
定义专门用来观察计数器属性值的监视器 MBean。
CounterMonitor() - 类 javax.management.monitor.CounterMonitor 的构造方法
默认的构造方法。
CounterMonitorMBean - javax.management.monitor 中的 接口
公开计数器监视器 MBean 的远程管理接口。
countItems() - 类 java.awt.Choice 中的方法
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
countItems() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
countItems() - 类 java.awt.Menu 中的方法
已过时。 从 JDK version 1.1 开始，已由 getItemCount() 取代。
countMenus() - 类 java.awt.MenuBar 中的方法
已过时。 从 JDK version 1.1 开始，由 getMenuCount() 取代。
countObservers() - 类 java.util.Observable 中的方法
返回 Observable 对象的观察者数目。
countStackFrames() - 类 java.lang.Thread 中的方法
已过时。 该调用的定义依赖于 Thread.suspend()，但它遭到了反对。此外，该调用的结果从来都不是意义明确的。
countTokens() - 类 java.util.StringTokenizer 中的方法
计算在生成异常之前可以调用此 tokenizer 的 nextToken 方法的次数。
COVER - 类 javax.print.attribute.standard.Finishings 中的静态变量
当需要为文档选择非打印（或预打印）封面时指定此值。
COVER_OPEN - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备上的一个或多个机盖处于打开状态。
CPE - 类 javax.naming.spi.NamingManager 中的静态变量
保存环境属性名称的常量，getContinuationContext() 将其 CannotProceedException 参数的值保存在该环境属性中。
crc - 类 java.util.zip.GZIPInputStream 中的变量
未压缩数据的 CRC-32。
crc - 类 java.util.zip.GZIPOutputStream 中的变量
未压缩数据的 CRC-32 。
CRC32 - java.util.zip 中的 类
可用于计算数据流的 CRC-32 的类。
CRC32() - 类 java.util.zip.CRC32 的构造方法
创建新的 CRC32 对象。
create() - 类 java.awt.Graphics 中的方法
创建一个新的 Graphics 对象，它是此 Graphics 对象的副本。
create(int, int, int, int) - 类 java.awt.Graphics 中的方法
基于此 Graphics 对象创建一个新的 Graphics 对象，但是使用新的转换和剪贴区域。
create(RenderContext, ParameterBlock) - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
create(ParameterBlock, RenderingHints) - 接口 java.awt.image.renderable.RenderedImageFactory 中的方法
针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。
create(Class<T>, Object, String) - 类 java.beans.EventHandler 中的静态方法
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。
create(Class<T>, Object, String, String) - 类 java.beans.EventHandler 中的静态方法
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
create(Class<T>, Object, String, String, String) - 类 java.beans.EventHandler 中的静态方法
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
create() - 类 java.net.DatagramSocketImpl 中的方法
创建数据报套接字。
create(boolean) - 类 java.net.SocketImpl 中的方法
创建一个流或数据报套接字。
create(String) - 类 java.net.URI 中的静态方法
通过解析给定的字符串创建 URI。
create() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.create 来返回一个 DebugGraphics 对象。
create(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.create 来返回一个 DebugGraphics 对象。
create(Element) - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 中的方法
创建元素的视图 (PasswordView)。
create(Element) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
创建元素的视图。
create(Element) - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的方法
基于元素创建视图 (FieldView)。
create(Element) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建元素的视图。
create(Element, int, int) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建元素的视图。
create(DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.DefaultStyledDocument 中的方法
初始化文档，以反映给定元素结构（即由 getDefaultRootElement 方法报告的结构）。
create(DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.html.HTMLDocument 中的方法
替换具有给定元素规范的文档内容。
create(Element) - 类 javax.swing.text.html.HTMLEditorKit.HTMLFactory 中的方法
根据元素创建视图。
create(Element) - 接口 javax.swing.text.ViewFactory 中的方法
根据给定的文档的结构化元素创建一个视图。
create(Name) - 类 javax.xml.soap.SOAPElementFactory 中的方法
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
create(String) - 类 javax.xml.soap.SOAPElementFactory 中的方法
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换
create(String, String, String) - 类 javax.xml.soap.SOAPElementFactory 中的方法
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换
create(Object) - 类 javax.xml.ws.Endpoint 中的静态方法
创建具有指定实现者对象的端点。
create(String, Object) - 类 javax.xml.ws.Endpoint 中的静态方法
创建具有指定绑定类型和实现者对象的端点。
create(URL, QName) - 类 javax.xml.ws.Service 中的静态方法
创建 Service 实例。
create(QName) - 类 javax.xml.ws.Service 中的静态方法
创建 Service 实例。
create_abstract_interface_tc(String, String) - 类 org.omg.CORBA.ORB 中的方法
为 IDL 抽象接口创建一个 TypeCode 对象。
create_alias_tc(String, String, TypeCode) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。
create_any() - 类 org.omg.CORBA.ORB 中的方法
创建一个 IDL Any 对象，初始化后该对象包含一个 kind 字段被设置为 TCKind.tc_null 的 Typecode 对象。
create_array_tc(int, TypeCode) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL array 的 TypeCode 对象。
create_basic_dyn_any(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_child(String) - 类 org.omg.CORBA.Context 中的方法
创建一个 Context 对象，使用给定字符串作为其名称，并将此 Context 对象设置为其父对象。
create_codec(Encoding) - 接口 org.omg.IOP.CodecFactoryOperations 中的方法
创建一个给定编码的 Codec。
create_context_list() - 类 org.omg.CORBA.ORB 中的方法
创建一个空的 ContextList 对象。
create_dyn_any(Any) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_any(Any) - 类 org.omg.DynamicAny._DynAnyFactoryStub 中的方法
根据 any 值创建新 DynAny 对象。
create_dyn_any(Any) - 接口 org.omg.DynamicAny.DynAnyFactoryOperations 中的方法
根据 any 值创建新 DynAny 对象。
create_dyn_any_from_type_code(TypeCode) - 类 org.omg.DynamicAny._DynAnyFactoryStub 中的方法
根据 TypeCode 创建 DynAny。
create_dyn_any_from_type_code(TypeCode) - 接口 org.omg.DynamicAny.DynAnyFactoryOperations 中的方法
根据 TypeCode 创建 DynAny。
create_dyn_array(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_enum(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_sequence(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_struct(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_dyn_union(TypeCode) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用新的 DynAnyFactory API 代替
create_enum_tc(String, String, String[]) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL enum 的 TypeCode 对象。
create_environment() - 类 org.omg.CORBA.ORB 中的方法
创建一个 Environment 对象。
create_exception_list() - 类 org.omg.CORBA.ORB 中的方法
创建一个空的 ExceptionList 对象。
create_exception_tc(String, String, StructMember[]) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL exception 的 TypeCode 对象。
create_fixed_tc(short, short) - 类 org.omg.CORBA.ORB 中的方法
为 IDL fixed 类型创建一个 TypeCode 对象。
create_id_assignment_policy(IdAssignmentPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_id_uniqueness_policy(IdUniquenessPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_implicit_activation_policy(ImplicitActivationPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_input_stream() - 类 org.omg.CORBA.Any 中的方法
创建一个输入流，可以从中解组此 Any 对象的值。
create_input_stream() - 类 org.omg.CORBA.portable.OutputStream 中的方法
返回一个具有相同缓冲区的输入流。
create_interface_tc(String, String) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL interface 的 TypeCode 对象。
create_lifespan_policy(LifespanPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_list(int) - 类 org.omg.CORBA.ORB 中的方法
为指定数量的 NamedValue 对象分配具有（可能）足够空间的 NVList。
create_named_value(String, Any, int) - 类 org.omg.CORBA.ORB 中的方法
使用给定名称、值和参数模式标志创建一个 NamedValue 对象。
create_native_tc(String, String) - 类 org.omg.CORBA.ORB 中的方法
为 IDL native 类型创建一个 TypeCode 对象。
create_operation_list(Object) - 类 org.omg.CORBA.ORB 中的方法
创建一个 NVList，并使用给定 OperationDef 对象中所述操作的参数描述进行初始化。
create_output_stream() - 类 org.omg.CORBA.Any 中的方法
创建一个输出流，可以将此 Any 对象的值编组到其中。
create_output_stream() - 类 org.omg.CORBA.ORB 中的方法
创建一个新的 org.omg.CORBA.portable.OutputStream，在执行方法调用期间，可在该输出流中对 IDL 方法参数进行编组。
create_POA(String, POAManager, Policy[]) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作创建一个新的 POA 作为目标 POA 的子 POA。
create_policy(int, Any) - 类 org.omg.CORBA.ORB 中的方法
可以调用此方法创建特定类型的新策略对象实例，并且其类型具有指定的初始状态。
create_policy(int, Any) - 接口 org.omg.PortableInterceptor.PolicyFactoryOperations 中的方法
返回派生自 CORBA.Policy（其值对应于指定的 any）的恰当接口的实例。
create_recursive_sequence_tc(int, int) - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用 create_recursive_tc 和 create_sequence_tc 的组合替代它
create_recursive_tc(String) - 类 org.omg.CORBA.ORB 中的方法
创建一个递归 TypeCode 对象，在创建包含递归的 TypeCodes 期间，该对象充当具体 TypeCode 的占位符。
create_reference(String) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。
create_reference_with_id(byte[], String) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作创建一个对象引用，该引用封装指定的 Object Id 和接口存储库 Id 值。
create_request(Object, Context, String, NVList, NamedValue) - 类 org.omg.CORBA.portable.Delegate 中的方法
创建在动态调用接口中使用的 Request 实例。
create_request(Object, Context, String, NVList, NamedValue, ExceptionList, ContextList) - 类 org.omg.CORBA.portable.Delegate 中的方法
创建在动态调用接口中使用的 Request 实例。
create_request_processing_policy(RequestProcessingPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_sequence_tc(int, TypeCode) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL sequence 的 TypeCode 对象。
create_servant_retention_policy(ServantRetentionPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这类操作都返回一个对具有指定值的策略对象的引用。
create_string_tc(int) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示有界 IDL string 的 TypeCode 对象。
create_struct_tc(String, String, StructMember[]) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL struct 的 TypeCode 对象。
create_thread_policy(ThreadPolicyValue) - 接口 org.omg.PortableServer.POAOperations 中的方法
每个这种操作都返回一个对具有指定值的策略对象的引用。
create_union_tc(String, String, TypeCode, UnionMember[]) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示 IDL union 的 TypeCode 对象。
create_value_box_tc(String, String, TypeCode) - 类 org.omg.CORBA.ORB 中的方法
为 IDL value box 类型创建一个 TypeCode 对象。
create_value_tc(String, String, short, TypeCode, ValueMember[]) - 类 org.omg.CORBA.ORB 中的方法
为 IDL value 类型创建一个 TypeCode 对象。
create_wstring_tc(int) - 类 org.omg.CORBA.ORB 中的方法
创建一个表示有界 IDL wstring (wide string) 的 TypeCode 对象。
createActionChangeListener(JMenuItem) - 类 javax.swing.JMenu 中的方法
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
createActionChangeListener(JMenuItem) - 类 javax.swing.JPopupMenu 中的方法
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
createActionChangeListener(JButton) - 类 javax.swing.JToolBar 中的方法
返回正确配置的 PropertyChangeListener，它根据 Action 的更改对控件进行更新，如果需要使用默认的属性更改侦听器，则为 null。
createActionComponent(Action) - 类 javax.swing.JMenu 中的方法
该工厂方法创建添加到 JMenu 的 Action 的 JMenuItem。
createActionComponent(Action) - 类 javax.swing.JPopupMenu 中的方法
该工厂方法为添加到 JPopupMenu 的 Action 创建对应的 JMenuItem。
createActionComponent(Action) - 类 javax.swing.JToolBar 中的方法
将为 Action 创建 JButton 的工厂方法添加到 JToolBar 中。
createActionListener() - 类 javax.swing.AbstractButton 中的方法
createActionMap() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createActionPropertyChangeListener(Action) - 类 javax.swing.AbstractButton 中的方法
创建并返回 PropertyChangeListener，它负责侦听指定 Action 的更改以及更新适当的属性。
createActionPropertyChangeListener(Action) - 类 javax.swing.JComboBox 中的方法
创建并返回一个 PropertyChangeListener，它负责侦听指定 Action 的更改并更新适当属性。
createActionPropertyChangeListener(Action) - 类 javax.swing.JTextField 中的方法
创建并返回一个负责侦听指定 Action 的更改以及更新适当属性的 PropertyChangeListener。
createActions() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createAndPublishEndpoint(String, Object) - 类 javax.xml.ws.spi.Provider 中的方法
创建和发布具有指定地址和实现对象的端点对象。
createArrayOf(String, Object[]) - 接口 java.sql.Connection 中的方法
创建 Array 对象的工厂方法。
createArrowButton() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建一个按钮，将使用它来控制显示或隐藏组合框的弹出部分。
createArrowButton() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createArrowButtonListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createAttachmentPart() - 类 javax.xml.soap.SOAPMessage 中的方法
创建一个新的空 AttachmentPart 对象。
createAttachmentPart(DataHandler) - 类 javax.xml.soap.SOAPMessage 中的方法
创建 AttachmentPart 对象并使用给定的 DataHandler 对象填充。
createAttachmentPart(Object, String) - 类 javax.xml.soap.SOAPMessage 中的方法
创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。
createAttribute(String, String, String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 Attribute。
createAttribute(String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 Attribute。
createAttribute(QName, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 Attribute。
createAttribute(String) - 接口 org.w3c.dom.Document 中的方法
创建给定名称的 Attr。
createAttributeNS(String, String) - 接口 org.w3c.dom.Document 中的方法
创建给定的限定名称和名称空间 URI 的属性。
createAudioAction(Object) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
创建并返回用于播放音频的 Action。
createBackBuffers(int) - 类 java.awt.Component.BltBufferStrategy 中的方法
创建后台缓冲区
createBanded(ColorSpace, int[], int[], int, boolean, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回带状图像格式的说明符，它将使用 ComponentColorModel 和 BandedSampleModel 来存储单独数组中的每个通道。
createBandedRaster(int, int, int, int, Point) - 类 java.awt.image.Raster 中的静态方法
根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
createBandedRaster(int, int, int, int, int[], int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
createBandedRaster(DataBuffer, int, int, int, int[], int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
createBaselineGroup(boolean, boolean) - 类 javax.swing.GroupLayout 中的方法
创建并返回一个沿基线对齐其元素的 ParallelGroup。
createBCSChild(Object, Object) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。
createBCSChild(Object, Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。
createBCSSServiceProvider(Class, BeanContextServiceProvider) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。
createBevelBorder(int) - 类 javax.swing.BorderFactory 中的静态方法
创建一个指定类型的斜面边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
createBevelBorder(int, Color, Color) - 类 javax.swing.BorderFactory 中的静态方法
使用指定高亮显示和阴影显示方式来创建一个指定类型的斜面边框。
createBevelBorder(int, Color, Color, Color, Color) - 类 javax.swing.BorderFactory 中的静态方法
创建一个指定类型的斜面边框，使用内部和外部高亮显示区域及阴影区域的指定颜色。
createBinder(Class<T>) - 类 javax.xml.bind.JAXBContext 中的方法
创建一个可用于关联/原地解组/编组操作的 Binder 对象。
createBinder() - 类 javax.xml.bind.JAXBContext 中的方法
为 W3C DOM 创建一个 Binder。
createBindings() - 接口 javax.script.ScriptEngine 中的方法
返回一个未初始化的 Bindings。
createBlackLineBorder() - 类 javax.swing.border.LineBorder 中的静态方法
获取一个颜色为黑色、厚度为 1 的线边框的便捷方法。
createBlob() - 接口 java.sql.Connection 中的方法
构造实现 Blob 接口的对象。
createBorderListener(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createBorderListener(JInternalFrame) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
返回将在 TitlePane 上安装的 MouseInputAdapter。
createBranchElement(Element, AttributeSet) - 类 javax.swing.text.AbstractDocument 中的方法
创建文档分支元素，它可包含其他元素。
createBranchElement(Element, AttributeSet) - 类 javax.swing.text.html.HTMLDocument 中的方法
创建文档分支元素，它可以包含其他元素。
createBufferedImage(int, int) - 类 javax.imageio.ImageTypeSpecifier 中的方法
根据此对象中包含的规范创建一个具有给定宽度和高度的 BufferedImage。
createBuffers(int, BufferCapabilities) - 类 java.awt.Component.FlipBufferStrategy 中的方法
创建一个或多个具有给定能力的、复杂的翻转缓冲区。
createBufferStrategy(int) - 类 java.awt.Canvas 中的方法
创建一个新的策略，用于对此组件的多次缓冲。
createBufferStrategy(int, BufferCapabilities) - 类 java.awt.Canvas 中的方法
创建一个新的策略，使用所需的缓冲区能力对此组件进行多次缓冲。
createBufferStrategy(int) - 类 java.awt.Window 中的方法
为此组件上的多缓冲创建一个新策略。
createBufferStrategy(int, BufferCapabilities) - 类 java.awt.Window 中的方法
根据所需缓冲区能力为此组件上的多缓冲创建新策略。
createButton(Button) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Button 实现。
createButtonActionListener(int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
createButtonArea() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
创建并返回包含按钮的 Container。
createButtonListener(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
createButtonListener(AbstractButton) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
createButtons() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createButtons() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
createCanvas(Canvas) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Canvas 实现。
createCaret() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建用于插入符的对象。
createCaret() - 类 javax.swing.text.DefaultEditorKit 中的方法
获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
createCaret() - 类 javax.swing.text.EditorKit 中的方法
获取能在由关联的 ViewFactory 生成的视图中导航的插入符。
createCData(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 CData 标记设置为 true 的 Character 事件。
createCDATASection(String) - 接口 org.w3c.dom.Document 中的方法
创建其值为指定字符串的 CDATASection 节点。
createCellEditorListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建在当前编辑器中处理事件的侦听器。
createCellRendererPane() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回用于放置渲染器组件的渲染器窗格。
createChangeListener() - 类 javax.swing.AbstractButton 中的方法
想以不同的方式处理 ChangeEvent 的子类可以重写此方法，以返回另一个 ChangeListener 实现。
createChangeListener() - 类 javax.swing.JProgressBar 中的方法
要以不同方式处理来自模型的更改事件的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
createChangeListener() - 类 javax.swing.JSlider 中的方法
想要以不同方式处理模型的 ChangeEvent 的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
createChangeListener() - 类 javax.swing.JTabbedPane 中的方法
要对 ChangeEvents 进行不同处理的子类可以重写它，从而返回 ModelListener 的一个子类，或者返回另一个 ChangeListener 实现。
createChangeListener() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
createChangeListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createChangeListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createChangeListener() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
createCharacters(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 Character 事件，此方法不检查内容是否全部为空白。
createCheckbox(Checkbox) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Checkbox 实现。
createCheckboxMenuItem(CheckboxMenuItem) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 CheckboxMenuItem 实现。
createChild(int, int, int, int, int, int, int[]) - 类 java.awt.image.Raster 中的方法
返回共享此 Raster 全部或部分 DataBuffer 的新 Raster。
createChildren(DefaultMutableTreeNode, Object) - 类 javax.swing.JTree.DynamicUtilTreeNode 中的静态方法
将 children 中的所有子节点添加到父节点。
createChildState(View) - 类 javax.swing.text.AsyncBoxView 中的方法
通过此方法创建新的 ChildState 记录，以允许扩展 ChildState 记录的子类执行/保存更多状态。
createChoice(Choice) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Choice 实现。
createClassFile(CharSequence, Element...) - 接口 javax.annotation.processing.Filer 中的方法
创建一个新的类文件，并返回一个对象以允许写入它。
createClob() - 接口 java.sql.Connection 中的方法
构造实现 Clob 接口的对象。
createComment(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个注释。
createComment(String) - 接口 org.w3c.dom.Document 中的方法
创建给定指定字符串的 Comment 节点。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.AffineTransformOp 中的方法
创建一个具有正确大小和 band 数的经过检查的目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 接口 java.awt.image.BufferedImageOp 中的方法
创建一个具有正确大小和 band 数的经过检查的目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.ColorConvertOp 中的方法
创建给定源的具有正确大小和 band 数量的归零目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.ConvolveOp 中的方法
创建具有正确 band 大小和数量的归零目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.LookupOp 中的方法
创建一幅具有正确大小和 band 数的、经过检查的目标图像。
createCompatibleDestImage(BufferedImage, ColorModel) - 类 java.awt.image.RescaleOp 中的方法
创建一个具有正确大小和 band 数的经检查的目标图像。
createCompatibleDestRaster(Raster) - 类 java.awt.image.AffineTransformOp 中的方法
创建一个具有正确大小和 band 数的经过检查的目标 Raster。
createCompatibleDestRaster(Raster) - 类 java.awt.image.BandCombineOp 中的方法
创建一个经过检查的目标 Raster，它具有正确大小和 band 数。
createCompatibleDestRaster(Raster) - 类 java.awt.image.ColorConvertOp 中的方法
创建给定源且具有正确 band 大小和数量的归零目标 Raster。
createCompatibleDestRaster(Raster) - 类 java.awt.image.ConvolveOp 中的方法
创建给定源且具有正确 band 大小和数量的归零目标 Raster。
createCompatibleDestRaster(Raster) - 类 java.awt.image.LookupOp 中的方法
在给定源 Raster 的情况下，创建一幅具有正确大小和 band 数的、经过检查的目标 Raster。
createCompatibleDestRaster(Raster) - 接口 java.awt.image.RasterOp 中的方法
创建一个具有正确大小和 band 数的归零目标 Raster。
createCompatibleDestRaster(Raster) - 类 java.awt.image.RescaleOp 中的方法
在给出源的情况下，创建一个具有正确大小和 band 数的经检查的目标 Raster。
createCompatibleImage(int, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
createCompatibleImage(int, int, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个支持指定透明度，并且数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
createCompatibleSampleModel(int, int) - 类 java.awt.image.BandedSampleModel 中的方法
创建一个具有指定宽度和高度的新的 BandedSampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.ColorModel 中的方法
用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
createCompatibleSampleModel(int, int) - 类 java.awt.image.ComponentColorModel 中的方法
用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
createCompatibleSampleModel(int, int) - 类 java.awt.image.ComponentSampleModel 中的方法
创建具有指定宽度和高度的 ComponentSampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.IndexColorModel 中的方法
创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
构造一个具有指定宽度和高度的新 MultiPixelPackedSampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.PackedColorModel 中的方法
创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.PixelInterleavedSampleModel 中的方法
创建一个具有指定宽度和高度的 PixelInterleavedSampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.SampleModel 中的方法
创建一个用此 SampleModel 的格式描述数据，但宽度和高度不同的 SampleModel。
createCompatibleSampleModel(int, int) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
创建一个具有指定宽度和高度的新 SinglePixelPackedSampleModel。
createCompatibleVolatileImage(int, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
createCompatibleVolatileImage(int, int, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
createCompatibleVolatileImage(int, int, ImageCapabilities) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
createCompatibleVolatileImage(int, int, ImageCapabilities, int) - 类 java.awt.GraphicsConfiguration 中的方法
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.ColorModel 中的方法
用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.ComponentColorModel 中的方法
用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.DirectColorModel 中的方法
创建具有指定宽度和高度、拥有与此 ColorModel 兼容的数据布局 (SampleModel) 的 WritableRaster。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.IndexColorModel 中的方法
创建一个具有指定宽度和高度、数据布局 (SampleModel) 与此 ColorModel 兼容的 WritableRaster。
createCompatibleWritableRaster() - 类 java.awt.image.Raster 中的方法
创建一个兼容的 WritableRaster，使其具有与此 Raster 相同的大小、SampleModel，以及一个新初始化的 DataBuffer。
createCompatibleWritableRaster(int, int) - 类 java.awt.image.Raster 中的方法
创建一个兼容的 WritableRaster，使其具有指定大小、新 SampleModel 和新初始化的 DataBuffer。
createCompatibleWritableRaster(Rectangle) - 类 java.awt.image.Raster 中的方法
创建一个兼容的 WritableRaster，使其具有由 rect 指定的位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
createCompatibleWritableRaster(int, int, int, int) - 类 java.awt.image.Raster 中的方法
创建一个兼容的 WritableRaster，使其具有指定位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
createComponent(Component) - 类 java.awt.Toolkit 中的方法
创建组件或容器的同位体。
createComponent() - 类 javax.swing.text.ComponentView 中的方法
创建与此视图关联的组件。
createComponent() - 类 javax.swing.text.html.FormView 中的方法
创建组件。
createComponent() - 类 javax.swing.text.html.ObjectView 中的方法
创建组件。
createComponentListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createComponentListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createComponentListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建并返回新的 ComponentHandler。
createCompoundBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有 null 内部边缘和 null 外部边缘的合成边框。
createCompoundBorder(Border, Border) - 类 javax.swing.BorderFactory 中的静态方法
创建一个合成边框，指定了用于外部和内部边缘的 border 对象。
createCompoundEdit() - 类 javax.swing.undo.UndoableEditSupport 中的方法
仅从 beginUpdate 调用。
createConnection() - 类 javax.xml.soap.SOAPConnectionFactory 中的方法
创建新的 SOAPConnection。
createContainer() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
创建管理 editingComponent 放置的容器。
createContainerListener() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
createContainerListener() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
创建一个将添加到 JToolBar 中的容器侦听器。
createContentHandler(String) - 接口 java.net.ContentHandlerFactory 中的方法
创建从 URLStreamHandler 读取对象的新 ContentHandler。
createContentPane() - 类 javax.swing.JRootPane 中的方法
由构造方法调用以便创建默认的 contentPane。
createContext(ColorModel, ColorModel, RenderingHints) - 类 java.awt.AlphaComposite 中的方法
为合成操作创建一个上下文。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.Color 中的方法
创建并返回用来生成固定颜色模式的 PaintContext。
createContext(ColorModel, ColorModel, RenderingHints) - 接口 java.awt.Composite 中的方法
创建一个上下文，其中包含用于执行复合操作的状态。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.GradientPaint 中的方法
创建并返回用来生成颜色模式的上下文。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.LinearGradientPaint 中的方法
创建并返回用来生成颜色模式的 PaintContext。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 接口 java.awt.Paint 中的方法
创建并返回用来生成颜色模式的 PaintContext。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.RadialGradientPaint 中的方法
创建并返回用来生成颜色模式的 PaintContext。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.SystemColor 中的方法
创建并返回用来生成纯色模式的 PaintContext。
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - 类 java.awt.TexturePaint 中的方法
创建并返回用于生成颜色模式的上下文。
createContext(GSSName, Oid, GSSCredential, int) - 类 org.ietf.jgss.GSSManager 中的方法
在初始端一方创建上下文的 Factory 方法。
createContext(GSSCredential) - 类 org.ietf.jgss.GSSManager 中的方法
为接受端一方创建上下文的 Factory 方法。
createContext(byte[]) - 类 org.ietf.jgss.GSSManager 中的方法
创建以前导出的上下文的 Factory 方法。
createCopy() - 接口 javax.sql.rowset.CachedRowSet 中的方法
创建一个 RowSet 对象，它是此 CachedRowSet 对象中数据的深层副本。
createCopyNoConstraints() - 接口 javax.sql.rowset.CachedRowSet 中的方法
创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象数据的深层副本，但是独立于此 CachedRowSet 对象。
createCopySchema() - 接口 javax.sql.rowset.CachedRowSet 中的方法
创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象的空副本。
createCredential(int) - 类 org.ietf.jgss.GSSManager 中的方法
获取默认凭据的 Factory 方法。
createCredential(GSSName, int, Oid, int) - 类 org.ietf.jgss.GSSManager 中的方法
获取单个机制凭据的 Factory 方法。
createCredential(GSSName, int, Oid[], int) - 类 org.ietf.jgss.GSSManager 中的方法
通过一套机制获取凭据的 Factory 方法。
createCustomCursor(Image, Point, String) - 类 java.awt.Toolkit 中的方法
创建一个新的自定义光标对象。
createDataBuffer() - 类 java.awt.image.BandedSampleModel 中的方法
创建一个与此 BandedSampleModel 对应的 DataBuffer，该 DataBuffer 的数据类型、存储单元数和大小都将与此 BandedSampleModel 一致。
createDataBuffer() - 类 java.awt.image.ComponentSampleModel 中的方法
创建对应于此 ComponentSampleModel 的 DataBuffer。
createDataBuffer() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
创建一个与此 MultiPixelPackedSampleModel 对应的 DataBuffer。
createDataBuffer() - 类 java.awt.image.SampleModel 中的方法
创建一个对应于此 SampleModel 的 DataBuffer。
createDataBuffer() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
创建一个对应于此 SinglePixelPackedSampleModel 的 DataBuffer。
createDataContentHandler(String) - 类 javax.activation.CommandMap 中的方法
查找与 MIME 类型对应的 DataContentHandler。
createDataContentHandler(String, DataSource) - 类 javax.activation.CommandMap 中的方法
查找与 MIME 类型对应的 DataContentHandler。
createDataContentHandler(String) - 接口 javax.activation.DataContentHandlerFactory 中的方法
针对 MIME 类型创建一个新的 DataContentHandler 对象。
createDataContentHandler(String) - 类 javax.activation.MailcapCommandMap 中的方法
返回指定 MIME 类型的 DataContentHandler。
createDatagramSocketImpl() - 接口 java.net.DatagramSocketImplFactory 中的方法
创建新的 DatagramSocketImpl 实例。
createdCellEditor - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
如果当前位于树中的编辑器由此实例创建，则设置为 true。
createDecreaseButton(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createDecreaseButton(int) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
返回表示减少量视图的视图。
createDefaultCellEditor() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建默认单元格编辑器。
createDefaultCellRenderer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回用于为每个节点添加标志的默认单元格渲染器。
createDefaultChoosers() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
createDefaultColumnModel() - 类 javax.swing.JTable 中的方法
返回默认的列模型对象，它是一个 DefaultTableColumnModel。
createDefaultColumnModel() - 类 javax.swing.table.JTableHeader 中的方法
返回默认的列模型对象，它是 DefaultTableColumnModel。
createDefaultColumnsFromModel() - 类 javax.swing.JTable 中的方法
使用 TableModel 接口中定义的 getColumnCount 方法根据数据模型创建默认的表列。
createDefaultDataModel() - 类 javax.swing.JTable 中的方法
返回默认的表模型对象，它是一个 DefaultTableModel。
createDefaultDivider() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
创建默认的分隔符。
createDefaultDivider() - 类 javax.swing.plaf.metal.MetalSplitPaneUI 中的方法
创建默认分隔符。
createDefaultDocument() - 类 javax.swing.text.DefaultEditorKit 中的方法
创建一个适合此编辑器类型的未初始化文本存储模型 (PlainDocument)。
createDefaultDocument() - 类 javax.swing.text.EditorKit 中的方法
创建一个适合此编辑器类型的未初始化的文本存储模型。
createDefaultDocument() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
创建一个适合此编辑器类型的未初始化文本存储模型。
createDefaultDocument() - 类 javax.swing.text.StyledEditorKit 中的方法
创建一个适合此编辑器类型的未初始化文本存储模型。
createDefaultDragGestureRecognizer(Component, int, DragGestureListener) - 类 java.awt.dnd.DragSource 中的方法
创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
createDefaultEditorKit() - 类 javax.swing.JEditorPane 中的方法
首次创建组件时，创建默认的编辑器工具包 (PlainEditorKit)。
createDefaultEditorKit() - 类 javax.swing.JTextPane 中的方法
创建默认使用的 EditorKit。
createDefaultEditors() - 类 javax.swing.JTable 中的方法
为 object、number 和 boolean 值创建默认的单元格编辑器。
createDefaultHeaderRenderer() - 类 javax.swing.table.TableColumn 中的方法
从 Java 2 platform v1.3 开始，TableColumn 构造方法不再调用此方法。
createDefaultKeySelectionManager() - 类 javax.swing.JComboBox 中的方法
返回默认键选择管理器的实例。
createDefaultModel() - 类 javax.swing.JTextArea 中的方法
如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。
createDefaultModel() - 类 javax.swing.JTextField 中的方法
如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。
createDefaultNonContinuousLayoutDivider() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回默认的非连续布局分隔符，该分隔符是使用深灰色填充背景的 Canvas 的实例。
createDefaultRenderer() - 类 javax.swing.table.JTableHeader 中的方法
返回 TableColumn 未定义头渲染器时所使用的默认渲染器。
createDefaultRenderers() - 类 javax.swing.JTable 中的方法
为 object、number、double、date、boolean 和 icon 创建默认的单元格渲染器。
createDefaultRendering() - 接口 java.awt.image.renderable.RenderableImage 中的方法
返回此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
createDefaultRendering() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
createDefaultRoot() - 类 javax.swing.text.DefaultStyledDocument 中的方法
创建用于代表默认文档结构的根元素。
createDefaultRoot() - 类 javax.swing.text.html.HTMLDocument 中的方法
创建用于表示默认文档结构的根元素。
createDefaultRoot() - 类 javax.swing.text.PlainDocument 中的方法
创建用于表示默认文档结构的根元素。
createDefaultSelectionModel() - 类 javax.swing.JTable 中的方法
返回默认的选择模型对象，它是一个 DefaultListSelectionModel。
createDefaultTableHeader() - 类 javax.swing.JTable 中的方法
返回默认的表标题对象，它是一个 JTableHeader。
createDefaultTheme() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
确保当前 MetalTheme 为非 null。
createDesktopManager() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createDesktopPeer(Desktop) - 类 java.awt.Toolkit 中的方法
使用指定的同位体接口创建此工具包的 Desktop 实现。
createDetail() - 类 javax.xml.soap.SOAPFactory 中的方法
创建充当 DetailEntry 对象容器的新 Detail 对象。
createDetailsView(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createDialog(Dialog) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Dialog 实现。
createDialog(Component, String, boolean, JColorChooser, ActionListener, ActionListener) - 类 javax.swing.JColorChooser 中的静态方法
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
createDialog(Component) - 类 javax.swing.JFileChooser 中的方法
创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
createDialog(Component, String) - 类 javax.swing.JOptionPane 中的方法
创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
createDialog(String) - 类 javax.swing.JOptionPane 中的方法
创建并返回一个新的带有指定标题的无父 JDialog。
createDirectoryComboBoxModel(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createDirectoryComboBoxRenderer(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createDisabledImage(Image) - 类 javax.swing.GrayFilter 中的静态方法
创建一个禁用图像
createDispatch(QName, Class<T>, Service.Mode) - 类 javax.xml.ws.Service 中的方法
创建与用户选择的对象一起使用的 Dispatch 实例。
createDispatch(QName, JAXBContext, Service.Mode) - 类 javax.xml.ws.Service 中的方法
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。
createDispatch(QName, Class<T>, Service.Mode) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
创建与用户选择的对象一起使用的 Dispatch 实例。
createDispatch(QName, JAXBContext, Service.Mode) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。
createDockingListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createDockingListener() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
createDocument(String, String, DocumentType) - 接口 org.w3c.dom.DOMImplementation 中的方法
创建具有文档元素的指定类型的 DOM Document 对象。
createDocumentFragment() - 接口 org.w3c.dom.Document 中的方法
创建空 DocumentFragment 对象。
createDocumentType(String, String, String) - 接口 org.w3c.dom.DOMImplementation 中的方法
创建空 DocumentType 节点。
createDoubleClickListener(JFileChooser, JList) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
createDragGestureRecognizer(Class<T>, Component, int, DragGestureListener) - 类 java.awt.dnd.DragSource 中的方法
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
createDragGestureRecognizer(Class<T>, DragSource, Component, int, DragGestureListener) - 类 java.awt.Toolkit 中的方法
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。
createDragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
创建处理此拖动的 DragSourceContext。
createDragSourceContextPeer(DragGestureEvent) - 类 java.awt.Toolkit 中的方法
创建 DragSourceContext 的同位体。
createDragWindow(JToolBar) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createdRenderer - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
如果当前在树中使用的渲染器由此实例创建，则设置为 true。
createDropTargetAutoScroller(Component, Point) - 类 java.awt.dnd.DropTarget 中的方法
创建一个嵌入式自动滚动条
createDropTargetContext() - 类 java.awt.dnd.DropTarget 中的方法
创建与此 DropTarget 关联的 DropTargetContext。
createDTD(DTD, String) - 类 javax.swing.text.html.parser.ParserDelegator 中的静态方法
createDTD(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个文档类型定义事件。
createEastPane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createEditor(SpinnerModel) - 类 javax.swing.JSpinner 中的方法
此方法由构造方法调用，以创建显示序列当前值的 JComponent。
createEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将在可编辑的组合框中使用的默认编辑器。
createEditor() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
installUI 通过调用此方法获取 JSpinner 的编辑器组件。
createEditor() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createEditorComponent() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
创建内部编辑器组件。
createEditorKitForContentType(String) - 类 javax.swing.JEditorPane 中的静态方法
根据默认的编辑器工具包注册表为给定的类型创建处理程序。
createElement(Element) - 类 javax.xml.soap.SOAPFactory 中的方法
根据现有的 DOM Element 创建 SOAPElement 对象。
createElement(Name) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定 Name 对象初始化的 SOAPElement 对象。
createElement(QName) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定 QName 对象初始化的 SOAPElement 对象。
createElement(String) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定本地名称初始化的 SOAPElement 对象。
createElement(String, String, String) - 类 javax.xml.soap.SOAPFactory 中的方法
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。
createElement(String) - 接口 org.w3c.dom.Document 中的方法
创建指定类型的元素。
createElementNS(String, String) - 接口 org.w3c.dom.Document 中的方法
创建给定的限定名称和名称空间 URI 的元素。
createEmptyBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个不占用空间的空边框。
createEmptyBorder(int, int, int, int) - 类 javax.swing.BorderFactory 中的静态方法
创建一个占用空间但没有绘制的空边框，指定了顶线、底线、左边框线和右边框线的宽度。
createEmptyFrameIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法
createEndDocument() - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 EndDocument 事件的新实例。
createEndElement(QName, Iterator) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 EndElement。
createEndElement(String, String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 EndElement。
createEndElement(String, String, String, Iterator) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 EndElement。
createEndpoint(String, Object) - 类 javax.xml.ws.spi.Provider 中的方法
创建具有提供的绑定和实现对象的端点对象。
createEntityReference(String, EntityDeclaration) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 EntityReference 事件的新实例。
createEntityReference(String) - 接口 org.w3c.dom.Document 中的方法
创建 EntityReference 对象。
createEtchedBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
createEtchedBorder(Color, Color) - 类 javax.swing.BorderFactory 中的静态方法
使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
createEtchedBorder(int) - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
createEtchedBorder(int, Color, Color) - 类 javax.swing.BorderFactory 中的静态方法
使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
createEvent(String) - 接口 org.w3c.dom.events.DocumentEvent 中的方法
createExceptionReply() - 接口 org.omg.CORBA.portable.ResponseHandler 中的方法
在方法调用期间由 servant 调用。
createExtendedResponse(String, byte[], int, int) - 接口 javax.naming.ldap.ExtendedRequest 中的方法
创建与此请求对应的响应对象。
createExtendedResponse(String, byte[], int, int) - 类 javax.naming.ldap.StartTlsRequest 中的方法
创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。
createFault(String, QName) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象
createFault() - 类 javax.xml.soap.SOAPFactory 中的方法
创建一个新的默认 SOAPFault 对象
createFileDialog(FileDialog) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 FileDialog 实现。
createFileObject(File, String) - 类 javax.swing.filechooser.FileSystemView 中的方法
返回根据给定的 filename 在 dir 中构造的 File 对象。
createFileObject(String) - 类 javax.swing.filechooser.FileSystemView 中的方法
返回根据给定路径字符串构造的 File 对象。
createFileSystemRoot(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
创建针对 f 的新 File 对象，使其对于文件系统根目录而言具有正确的行为。
createFilterComboBoxModel() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createFilterComboBoxRenderer() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createFilteredReader(XMLStreamReader, StreamFilter) - 类 javax.xml.stream.XMLInputFactory 中的方法
创建过滤的 reader，它用过滤器包装 reader。
createFilteredReader(XMLEventReader, EventFilter) - 类 javax.xml.stream.XMLInputFactory 中的方法
创建过滤的事件 reader，它用过滤器包装事件 reader。
createFloatingFrame(JToolBar) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
不再使用，使用 BasicToolBarUI.createFloatingWindow(JToolBar)
createFloatingWindow(JToolBar) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
创建将工具栏拖出其容器后包含该工具栏的窗口
createFocusListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到组合框的 FocusListener。
createFocusListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
createFocusListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createFocusListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
创建 JSplitPane UI 的 FocusListener。
createFocusListener() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
createFocusListener() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
创建在 JTable 中处理键盘导航的焦点侦听器。
createFocusListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建失去/获取焦点时负责更新显示的侦听器。
createFont(int, InputStream) - 类 java.awt.Font 中的静态方法
返回一个使用指定字体类型和输入数据的新 Font。
createFont(int, File) - 类 java.awt.Font 中的静态方法
返回一个使用指定字体类型和指定字体文件的新 Font。
createFragment(int, int) - 类 javax.swing.text.GlyphView 中的方法
创建表示元素某部分的视图。
createFragment(int, int) - 类 javax.swing.text.View 中的方法
创建一个表示元素某部分的视图。
createFrame(Frame) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Frame 实现。
createFrameListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createFromBufferedImageType(int) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回一个 ImageTypeSpecifier，它将对某一标准 BufferedImage 类型（而不是 TYPE_CUSTOM）进行编码。
createFromRenderedImage(RenderedImage) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回一个 ImageTypeSpecifier，它将对 RenderedImage（可能是 BufferedImage）的布局进行编码。
createGlassPane() - 类 javax.swing.JRootPane 中的方法
由构造方法调用以便创建默认的 glassPane。
createGlassPaneDispatcher() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createGlue() - 类 javax.swing.Box 中的静态方法
创建一个不可见的 "glue" 组件，其可见组件有一个最大宽度（对于横向 box）或高度（对于纵向 box）的 Box，该组件可能很有用。
createGlyphVector(FontRenderContext, String) - 类 java.awt.Font 中的方法
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
createGlyphVector(FontRenderContext, char[]) - 类 java.awt.Font 中的方法
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
createGlyphVector(FontRenderContext, CharacterIterator) - 类 java.awt.Font 中的方法
根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
createGlyphVector(FontRenderContext, int[]) - 类 java.awt.Font 中的方法
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
createGraphics(BufferedImage) - 类 java.awt.GraphicsEnvironment 中的方法
返回一个呈现指定 BufferedImage 的 Graphics2D 对象。
createGraphics() - 类 java.awt.image.BufferedImage 中的方法
创建一个 Graphics2D，可以将它绘制到此 BufferedImage 中。
createGraphics() - 类 java.awt.image.VolatileImage 中的方法
创建一个 Graphics2D，可以将它绘制到此 VolatileImage 中。
createGraphics() - 类 java.awt.SplashScreen 中的方法
创建闪现屏幕叠加图像的图形上下文（Graphics2D 形式），它允许在闪现屏幕上进行绘制。
createGrayLineBorder() - 类 javax.swing.border.LineBorder 中的静态方法
获取一个颜色为灰色、厚度为 1 的线条边框的便捷方法。
createGrayscale(int, int, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回灰度级图像格式的说明符，它会将给定位深 (bit depth) 的像素压缩成指定数据类型的数组元素。
createGrayscale(int, int, boolean, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回灰度级图像格式和 alpha 图像格式的说明符，它会将给定位深的像素压缩成指定数据类型的数组元素。
createGroup(ActivationGroupID, ActivationGroupDesc, long) - 类 java.rmi.activation.ActivationGroup 中的静态方法
为当前 VM 创建并设置激活组。
createHighlighter() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建用于添加高亮显示的对象。
createHorizontalBox() - 类 javax.swing.Box 中的静态方法
创建一个从左到右显示其组件的 Box。
createHorizontalGlue() - 类 javax.swing.Box 中的静态方法
创建一个横向 glue 组件。
createHorizontalScrollBar() - 类 javax.swing.JScrollPane 中的方法
默认返回 JScrollPane.ScrollBar。
createHorizontalStrut(int) - 类 javax.swing.Box 中的静态方法
创建一个不可见的、固定宽度的组件。
createHSBChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
createHTMLView(JComponent, String) - 类 javax.swing.plaf.basic.BasicHTML 中的静态方法
创建给定组件和 html 字符串的 html 渲染器。
createIgnorableSpace(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个可忽略的空间。
createImage(ImageProducer) - 类 java.awt.Component 中的方法
根据指定的图像生成器创建一幅图像。
createImage(int, int) - 类 java.awt.Component 中的方法
创建一幅用于双缓冲的、可在屏幕外绘制的图像。
createImage(String) - 类 java.awt.Toolkit 中的方法
返回从指定文件获取像素数据的图像。
createImage(URL) - 类 java.awt.Toolkit 中的方法
返回一幅图像，该图像从指定 URL 获取像素数据。
createImage(ImageProducer) - 类 java.awt.Toolkit 中的方法
使用指定的图像生成器创建一幅图像。
createImage(byte[]) - 类 java.awt.Toolkit 中的方法
创建一幅图像，该图像对存储在指定字节数组中的图像进行解码。
createImage(byte[], int, int) - 类 java.awt.Toolkit 中的方法
创建一幅图像，该图像对存储在指定字节数组中指定偏移量和长度处的图像进行解码。
createImageInputStream(Object) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 ImageInputStream，它将从给定 Object 中获取输入。
createImageOutputStream(Object) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 ImageOutputStream，它将其输出发送到给定 Object。
createIncreaseButton(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createIncreaseButton(int) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
返回表示增加量视图的视图。
createIndexed(byte[], byte[], byte[], byte[], int, int) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回索引颜色图像格式的说明符，它将给定位深的索引值压缩成指定数据类型的数组元素。
createInitialContextFactory(Hashtable<?, ?>) - 接口 javax.naming.spi.InitialContextFactoryBuilder 中的方法
使用指定环境创建一个初始上下文工厂。
createInputAttributes(Element, MutableAttributeSet) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
将 element 的 AttributeSet 键/值复制到 set 中。
createInputAttributes(Element, MutableAttributeSet) - 类 javax.swing.text.StyledEditorKit 中的方法
将 element 的 AttributeSet 键/值复制到 set 中。
createInputMethod() - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
创建相应输入方法的新实例。
createInputMethodJFrame(String, boolean) - 接口 java.awt.im.spi.InputMethodContext 中的方法
创建输入方法使用的顶层 Swing JFrame。
createInputMethodWindow(String, boolean) - 接口 java.awt.im.spi.InputMethodContext 中的方法
创建输入方法使用的顶层窗口。
createInputStreamInstance(Object, boolean, File) - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
返回与此服务提供者关联的 ImageInputStream 实现的实例。
createInputStreamInstance(Object) - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
返回与此服务提供者关联的 ImageInputStream 实现的实例。
createInterleaved(ColorSpace, int[], int, boolean, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回交错图像格式的说明符，它将使用 ComponentColorModel 和 PixelInterleavedSampleModel 来存储单个 byte、short 或 int 值形式的每个像素组件。
createInterleavedRaster(int, int, int, int, Point) - 类 java.awt.image.Raster 中的静态方法
根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
createInterleavedRaster(int, int, int, int, int, int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
createInterleavedRaster(DataBuffer, int, int, int, int, int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
createInternalFrame(Component, String) - 类 javax.swing.JOptionPane 中的方法
创建并返回 JInternalFrame 的实例。
createInternalFrameListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createIntersection(Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
createIntersection(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Double 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
createIntersection(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Float 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
createIntersection(Rectangle2D) - 类 java.awt.Rectangle 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
createInverse() - 类 java.awt.geom.AffineTransform 中的方法
返回表示逆向变换的 AffineTransform 对象。
createItemListener() - 类 javax.swing.AbstractButton 中的方法
createItemListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到组合框的 ItemListener。
createItemListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到组合框的 ItemListener。
createJAXBIntrospector() - 类 javax.xml.bind.JAXBContext 中的方法
创建一个可以用于内省 JAXB 对象的 JAXBIntrospector 对象。
createKeyboardDownRightListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyboardEndListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyboardHomeListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyboardResizeToggleListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyboardUpLeftListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 platform v1.3 开始。
createKeyListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到组合框的 KeyListener。
createKeyListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到组合框的键侦听器。
createKeyListener() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
创建在 JTable 中处理键盘导航的键侦听器。
createKeyListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责从树获取键事件的侦听器。
createKeymap() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
创建用于文本组件的 keymap，并在其中安装必需的绑定。
createLabel(Label) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Label 实现。
createLargeAttributeSet(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
创建一个以空间来换取时间的大属性集合。
createLargeAttributeSet(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
创建一个以空间来换取时间的大属性集合。
createLayeredPane() - 类 javax.swing.JRootPane 中的方法
由构造方法调用以便创建默认的 layeredPane。
createLayout() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createLayout() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
创建管理 JSpinner 的 editor、nextButton 和 previousButton 子级的 LayoutManager。
createLayout() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
createLayoutCache() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责管理展开内容及节点大小的对象。
createLayoutManager() - 类 javax.swing.JViewport 中的方法
子类可以重写此方法以在该构造方法中安装一个不同布局的管理器（或者为 null）。
createLayoutManager() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建用于管理构成组合框的组件的布局管理器。
createLayoutManager() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createLayoutManager() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
createLayoutManager() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
由 installUI 调用，用于创建布局管理器对象以管理 JTabbedPane。
createLayoutManager() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createLayoutManager() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
createLeafElement(Element, AttributeSet, int, int) - 类 javax.swing.text.AbstractDocument 中的方法
创建文档叶元素。
createLeafElement(Element, AttributeSet, int, int) - 类 javax.swing.text.html.HTMLDocument 中的方法
创建直接表示文本的文档叶元素（没有任何子级）。
createLeftOneTouchButton() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的左边组件。
createLineBidi(int, int) - 类 java.text.Bidi 中的方法
构造一个 Bidi 对象，表示当前 Bidi 所代表的段落中的一行文本上的双向信息。
createLineBorder(Color) - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有指定颜色的线边框。
createLineBorder(Color, int) - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有指定颜色和宽度的线边框。
createList(List) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 List 实现。
createList() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建在显示组合框模型项的弹出控件中使用的 JList。
createList(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createListDataListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到 ComboBoxModel 的列表数据侦听器。
createListDataListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到 ComboBoxModel 的列表数据侦听器。
createListDataListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
创建在需要时由模型添加到 JList 的 ListDataListener 的实例。
createListMouseListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建观察弹出列表中的鼠标事件的鼠标侦听器。
createListMouseMotionListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建观察弹出列表中的鼠标移动事件的鼠标移动侦听器。
createListSelectionListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建观察弹出列表中的选择更改的列表选择侦听器。
createListSelectionListener(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
createListSelectionListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
创建在需要时由 selectionModel 添加到 JList 的 ListSelectionHandler 的实例。
createListSelectionListener(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
创建一个用于文件和目录列表的选择侦听器。
createLoweredBevelBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有凹入斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
createLSInput() - 接口 org.w3c.dom.ls.DOMImplementationLS 中的方法
创建一个新的空输入源对象，其中，LSInput.characterStream、LSInput.byteStream、LSInput.stringData LSInput.systemId、LSInput.publicId、LSInput.baseURI 和 LSInput.encoding 为 null，LSInput.certifiedText 为 false。
createLSOutput() - 接口 org.w3c.dom.ls.DOMImplementationLS 中的方法
创建新的空输出目标对象，其中，LSOutput.characterStream、LSOutput.byteStream、LSOutput.systemId 和 LSOutput.encoding 为 null。
createLSParser(short, String) - 接口 org.w3c.dom.ls.DOMImplementationLS 中的方法
创建一个新的 LSParser。
createLSSerializer() - 接口 org.w3c.dom.ls.DOMImplementationLS 中的方法
创建新的 LSSerializer 对象。
createMarshaller() - 类 javax.xml.bind.JAXBContext 中的方法
创建一个可以用来将 java 内容树转换为 XML 数据的 Marshaller 对象。
createMatteBorder(int, int, int, int, Color) - 类 javax.swing.BorderFactory 中的静态方法
使用纯色创建一个类似衬边的边框。
createMatteBorder(int, int, int, int, Icon) - 类 javax.swing.BorderFactory 中的静态方法
创建一个由多层指定图标组成的、类似衬边的边框。
createMBean(String, ObjectName) - 接口 javax.management.MBeanServer 中的方法
createMBean(String, ObjectName, ObjectName) - 接口 javax.management.MBeanServer 中的方法
createMBean(String, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
createMBean(String, ObjectName, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
createMBean(String, ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 服务器中实例化并注册一个 MBean。
createMBean(String, ObjectName, ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 服务器中实例化并注册一个 MBean。
createMBean(String, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 服务器中实例化并注册一个 MBean。
createMBean(String, ObjectName, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 服务器中实例化并注册一个 MBean。
createMBean(String, ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
createMBean(String, ObjectName, ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
createMBean(String, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
createMBean(String, ObjectName, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
createMBean(String, ObjectName, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
createMBean(String, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
createMBeanServer() - 类 javax.management.MBeanServerFactory 中的静态方法
返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口。
createMBeanServer(String) - 类 javax.management.MBeanServerFactory 中的静态方法
返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口。
createMenu(Menu) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Menu 实现。
createMenuBar(MenuBar) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 MenuBar 实现。
createMenuDragMouseListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
createMenuDragMouseListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createMenuItem(MenuItem) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 MenuItem 实现。
createMenuKeyListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
createMenuKeyListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createMenuListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createMessage() - 类 javax.xml.soap.MessageFactory 中的方法
使用默认的 SOAPPart、SOAPEnvelope、SOAPBody 和 SOAPHeader 对象创建新的 SOAPMessage 对象。
createMessage(MimeHeaders, InputStream) - 类 javax.xml.soap.MessageFactory 中的方法
将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
createMessageArea() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
从 installComponents 获取消息以创建包含消息正文的 Container。
createModel() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
createModelListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createMouseInputListener() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
createMouseInputListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
创建实现 MouseInputListener 的委托。
createMouseInputListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
createMouseInputListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createMouseInputListener() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
创建 JTableHeader 的鼠标侦听器。
createMouseInputListener() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
创建 JTable 的鼠标侦听器。
createMouseListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将观察组合框上的鼠标按下和释放事件的侦听器。
createMouseListener() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
createMouseListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责基于鼠标事件更新选择的侦听器。
createMouseMotionListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到组合框的鼠标移动侦听器。
createMouseWheelListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
创建一个 MouseWheelListener 的实例，该实例由 installUI() 添加到 JScrollPane。
createMultiDocPrintJob() - 接口 javax.print.MultiDocPrintService 中的方法
创建一个可打印 multiDoc 的作业。
createName(String, String, String) - 接口 javax.xml.soap.SOAPEnvelope 中的方法
创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。
createName(String) - 接口 javax.xml.soap.SOAPEnvelope 中的方法
创建使用给定本地名称初始化的新 Name 对象。
createName(String, String, String) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。
createName(String) - 类 javax.xml.soap.SOAPFactory 中的方法
创建使用给定本地名称初始化的新 Name 对象。
createName(String, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。
createName(byte[], Oid) - 类 org.ietf.jgss.GSSManager 中的方法
将包含名称的字节数组从指定的名称空间转换到 GSSName 对象的 Factory 方法。
createName(String, Oid, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
createName(byte[], Oid, Oid) - 类 org.ietf.jgss.GSSManager 中的方法
将包含名称的字符串数组从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。
createNamespace(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新的默认 Namespace。
createNamespace(String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新的 Namespace。
createNClob() - 接口 java.sql.Connection 中的方法
构造实现 NClob 接口的对象。
createNewFile() - 类 java.io.File 中的方法
当且仅当不存在具有此抽象路径名指定名称的文件时，不可分地创建一个新的空文件。
createNewFolder(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
创建具有默认文件夹名称的新文件夹。
createNextButton() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
创建将用 spinner.getNextValue 返回的对象取代 spinner 模型值的组件。
createNodeDimensions() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建能够确定树中给定节点大小的 NodeDimensions 的实例。
createNonRolloverBorder() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
创建工具栏组件的非翻转边框。
createNonRolloverBorder() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
createNorthPane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createNorthPane(JInternalFrame) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
createObjectFactory(Object, Hashtable<?, ?>) - 接口 javax.naming.spi.ObjectFactoryBuilder 中的方法
使用所提供的环境创建一个新对象工厂。
createOutput(String, String) - 类 javax.xml.bind.SchemaOutputResolver 中的方法
确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。
createOutputStreamInstance(Object, boolean, File) - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
返回与此服务提供者关联的 ImageOutputStream 实现的实例。
createOutputStreamInstance(Object) - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
返回与此服务提供者关联的 ImageOutputStream 实现的实例。
createPacked(ColorSpace, int, int, int, int, int, boolean) - 类 javax.imageio.ImageTypeSpecifier 中的静态方法
返回压缩图像格式的说明符，它将使用 DirectColorModel 和一个压缩的 SampleModel 来存储压缩成单个 byte、short 或 int 值的像素。
createPackedRaster(int, int, int, int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 SinglePixelPackedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 掩码的 Raster。
createPackedRaster(int, int, int, int, int, Point) - 类 java.awt.image.Raster 中的静态方法
根据打包的 SampleModel 创建一个具有指定数据类型、宽度、高度、band 数和每 band 位数的 Raster。
createPackedRaster(DataBuffer, int, int, int, int[], Point) - 类 java.awt.image.Raster 中的静态方法
根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
createPackedRaster(DataBuffer, int, int, int, Point) - 类 java.awt.image.Raster 中的静态方法
根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
createPanel(Panel) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Panel 实现。
createParallelGroup() - 类 javax.swing.GroupLayout 中的方法
使用 Alignment.LEADING 的对齐方式创建并返回一个 ParallelGroup。
createParallelGroup(GroupLayout.Alignment) - 类 javax.swing.GroupLayout 中的方法
使用指定的对齐方式创建并返回一个 ParallelGroup。
createParallelGroup(GroupLayout.Alignment, boolean) - 类 javax.swing.GroupLayout 中的方法
使用指定的对齐方式和调整大小行为创建并返回一个 ParallelGroup。
createPopup() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建组合框的弹出部分。
createPopup() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createPopupMenu(PopupMenu) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 PopupMenu 实现。
createPosition(int) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
在内容中创建一个位置，该位置将在内容改变时跟踪更改。
createPosition(int) - 类 javax.swing.text.AbstractDocument 中的方法
返回更改文档时，将跟踪更改的位置。
createPosition(int) - 接口 javax.swing.text.Document 中的方法
此方法允许应用程序在字符内容序列中标记位置。
createPosition(int) - 类 javax.swing.text.GapContent 中的方法
在内容中创建一个位置，使其在内容发生变化时能跟踪内容的更改。
createPosition(int) - 类 javax.swing.text.StringContent 中的方法
在内容中创建一个位置，让其跟踪随内容的变化而进行的更改。
createPreviousButton() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
创建将用 spinner.getPreviousValue 返回的对象取代 spinner 模型值的组件。
createPrintJob() - 接口 javax.print.PrintService 中的方法
创建并返回一个 PrintJob，它应能够处理取自任意受支持的 docflavor 的数据。
createProcessingInstruction(String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个处理指令。
createProcessingInstruction(String, String) - 接口 org.w3c.dom.Document 中的方法
创建给定指定名称和数据字符串的 ProcessingInstruction 节点。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将添加到组合框的 PropertyChangeListener。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建将添加到组合框的 PropertyChangeListener。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
返回要安装到 JDesktopPane 上的 PropertyChangeListener。
createPropertyChangeListener(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
创建由 installUI() 添加到 JList 的 PropertyChangeHandler 的实例。
createPropertyChangeListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
创建一个将被添加到菜单项的 PropertyChangeListener。
createPropertyChangeListener(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
创建由 installUI() 添加到 JScrollPane 的 PropertyChangeListener 的实例。
createPropertyChangeListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
创建一个可以添加到 JSpinner 本身的 PropertyChangeListener。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
创建 JSplitPane UI 的 PropertyChangeListener。
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责基于树的更改方式更新 UI 的侦听器。
createPropertyChangeListener() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
createPropertyChangeListener(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
createPropertyChangeListener() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
createPropertyChangeListener(JSlider) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
createPropertyEditor(Object) - 类 java.beans.PropertyDescriptor 中的方法
使用当前属性编辑器类构造一个属性编辑器实例。
createPropertyListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createQName(String, String) - 接口 javax.xml.soap.SOAPElement 中的方法
创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。
createRaisedBevelBorder() - 类 javax.swing.BorderFactory 中的静态方法
创建一个具有凸出斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
createRaster(SampleModel, DataBuffer, Point) - 类 java.awt.image.Raster 中的静态方法
创建具有指定 SampleModel 和 DataBuffer 的 Raster。
createReaderInstance() - 类 javax.imageio.spi.ImageReaderSpi 中的方法
返回与此服务提供者关联的 ImageReader 实现的实例。
createReaderInstance(Object) - 类 javax.imageio.spi.ImageReaderSpi 中的方法
返回与此服务提供者关联的 ImageReader 实现的实例。
createRegistry(int) - 类 java.rmi.registry.LocateRegistry 中的静态方法
创建并导出接受指定 port 请求的本地主机上的 Registry 实例。
createRegistry(int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.registry.LocateRegistry 中的静态方法
在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
createRelation(String, String, RoleList) - 类 javax.management.relation.RelationService 中的方法
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
createRelation(String, String, RoleList) - 接口 javax.management.relation.RelationServiceMBean 中的方法
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
createRelationType(String, RoleInfo[]) - 类 javax.management.relation.RelationService 中的方法
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
createRelationType(String, RoleInfo[]) - 接口 javax.management.relation.RelationServiceMBean 中的方法
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
createRenderer() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建将在不可编辑的组合框中使用的默认渲染器。
createRendering(RenderContext) - 接口 java.awt.image.renderable.RenderableImage 中的方法
使用给定的 RenderContext 创建表示此图像一个呈现的 RenderedImage。
createRendering(RenderContext) - 类 java.awt.image.renderable.RenderableImageOp 中的方法
创建一个表示根据给定 RenderContext 呈现的 RenderableImageOp（包括其 Renderable 源）的 RenderedImage。
createReply() - 接口 org.omg.CORBA.portable.ResponseHandler 中的方法
在方法调用期间由 servant 调用。
createResource(JavaFileManager.Location, CharSequence, CharSequence, Element...) - 接口 javax.annotation.processing.Filer 中的方法
创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
createRightOneTouchButton() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
创建并返回 JButton 的实例，该实例可用于折叠拆分窗格中的右边组件。
createRigidArea(Dimension) - 类 javax.swing.Box 中的静态方法
创建一个总是具有指定大小的不可见组件。
createRolloverBorder() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
创建工具栏组件的翻转边框。
createRolloverBorder() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
createRolloverListener() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
创建一个将添加到 JToolBar 中的属性更改侦听器。
createRootLayout() - 类 javax.swing.JRootPane 中的方法
由构造方法调用以便创建默认的 layoutManager。
createRootPane() - 类 javax.swing.JApplet 中的方法
构造方法调用此方法创建默认 rootPane。
createRootPane() - 类 javax.swing.JDialog 中的方法
构造方法调用此方法来创建默认的 rootPane。
createRootPane() - 类 javax.swing.JFrame 中的方法
由构造方法调用，以创建默认的 rootPane。
createRootPane() - 类 javax.swing.JInternalFrame 中的方法
构造方法调用此方法来设置 JRootPane。
createRootPane() - 类 javax.swing.JWindow 中的方法
由该构造方法调用以创建默认的 rootPane。
createRow() - 类 javax.swing.text.FlowView 中的方法
创建应在保持流中子级行值时使用的视图。
createRow() - 类 javax.swing.text.ParagraphView 中的方法
创建用于在流中存储子级行值的 View。
createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - 类 javax.security.sasl.Sasl 中的静态方法
使用提供的参数创建 SaslClient。
createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - 接口 javax.security.sasl.SaslClientFactory 中的方法
使用提供的参数创建 SaslClient。
createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - 类 javax.security.sasl.Sasl 中的静态方法
为指定机制创建一个 SaslServer。
createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - 接口 javax.security.sasl.SaslServerFactory 中的方法
使用提供的参数创建 SaslServer。
createScaledRendering(int, int, RenderingHints) - 接口 java.awt.image.renderable.RenderableImage 中的方法
创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
createScaledRendering(int, int, RenderingHints) - 类 java.awt.image.renderable.RenderableImageOp 中的方法
创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
createScreenCapture(Rectangle) - 类 java.awt.Robot 中的方法
创建包含从屏幕中读取的像素的图像。
createScrollbar(Scrollbar) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Scrollbar 实现。
createScrollBarSwapListener() - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
createScrollButton(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
创建并返回一个 JButton，它将为用户提供朝某一特定方向滚动选项卡的方式。
createScroller() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
创建容纳可滚动列表的滚动窗格。
createScrollListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createScrollListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createScrollPane(ScrollPane) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 ScrollPane 实现。
createScrollPaneForTable(JTable) - 类 javax.swing.JTable 中的静态方法
已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。
createSelectionModel() - 类 javax.swing.JList 中的方法
返回一个 DefaultListSelectionModel 实例；在构造期间调用此方法初始化列表的选择模型属性。
createSelectionModel() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
创建新的默认列表选择模型。
createSelectionModelPropertyChangeListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建负责从选择模型获取属性更改事件的侦听器。
createSeparator() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
createSequentialGroup() - 类 javax.swing.GroupLayout 中的方法
创建并返回一个 SequentialGroup。
createServerSocket(int) - 接口 java.rmi.server.RMIServerSocketFactory 中的方法
在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
createServerSocket(int) - 类 java.rmi.server.RMISocketFactory 中的方法
在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
createServerSocket() - 类 javax.net.ServerSocketFactory 中的方法
返回未绑定的服务器套接字。
createServerSocket(int) - 类 javax.net.ServerSocketFactory 中的方法
返回绑定到指定端口的服务器套接字。
createServerSocket(int, int) - 类 javax.net.ServerSocketFactory 中的方法
返回绑定到指定端口的服务器套接字，并且使用指定的连接 backlog。
createServerSocket(int, int, InetAddress) - 类 javax.net.ServerSocketFactory 中的方法
返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。
createServerSocket(int) - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
创建一个服务器套接字，该套接字接受根据此工厂的 SSL 套接字配置参数配置的 SSL 连接。
createServiceDelegate(URL, QName, Class) - 类 javax.xml.ws.spi.Provider 中的方法
创建一个服务委托对象。
createShared() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回一个新的 RowSet 对象，支持该对象的数据与此 CachedRowSet 对象的相同。
createSmallAttributeSet(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
创建可以共享的属性压缩集。
createSmallAttributeSet(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
创建一个可能用于共享的压缩属性集。
createSocket(String, int) - 接口 java.rmi.server.RMIClientSocketFactory 中的方法
创建连接到指定主机和端口的客户机套接字。
createSocket(String, int) - 类 java.rmi.server.RMISocketFactory 中的方法
创建连接到指定主机和端口的客户机套接字。
createSocket() - 类 javax.net.SocketFactory 中的方法
创建一个未连接的套接字。
createSocket(String, int) - 类 javax.net.SocketFactory 中的方法
创建一个套接字并把它连接到指定远程主机上的指定远程端口。
createSocket(String, int, InetAddress, int) - 类 javax.net.SocketFactory 中的方法
创建一个套接字并把它连接到指定远程主机上的指定远程端口。
createSocket(InetAddress, int) - 类 javax.net.SocketFactory 中的方法
创建一个套接字并把它连接到指定地址上的指定端口号。
createSocket(InetAddress, int, InetAddress, int) - 类 javax.net.SocketFactory 中的方法
创建一个套接字并把它连接到指定远程端口上的指定远程地址。
createSocket(Socket, String, int, boolean) - 类 javax.net.ssl.SSLSocketFactory 中的方法
返回在连接到指定主机的给定端口的现有套接字上分层的套接字。
createSocket(String, int) - 类 javax.rmi.ssl.SslRMIClientSocketFactory 中的方法
创建一个 SSL 套接字。
createSocketImpl() - 接口 java.net.SocketImplFactory 中的方法
创建新的 SocketImpl 实例。
createSourceFile(CharSequence, Element...) - 接口 javax.annotation.processing.Filer 中的方法
创建一个新的源文件，并返回一个对象以允许写入它。
createSouthPane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createSpace(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 isSpace 标记设置为 true 的 Character 事件。
createSQLXML() - 接口 java.sql.Connection 中的方法
构造实现 SQLXML 接口的对象。
createSSLEngine() - 类 javax.net.ssl.SSLContext 中的方法
使用此上下文创建新的 SSLEngine。
createSSLEngine(String, int) - 类 javax.net.ssl.SSLContext 中的方法
使用此上下文创建新的 SSLEngine，该上下文使用劝告同位体信息。
createStandardLabels(int) - 类 javax.swing.JSlider 中的方法
创建一个数字文本标签的 Hashtable，从滑块最小值处开始并使用指定的增量。
createStandardLabels(int, int) - 类 javax.swing.JSlider 中的方法
创建一个数字文本标签的 Hashtable，从指定起始点处开始并使用指定的增量。
createStartDocument() - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 StartDocument 事件的新实例。
createStartDocument(String, String, boolean) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 StartDocument 事件的新实例。
createStartDocument(String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 StartDocument 事件的新实例。
createStartDocument(String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个 StartDocument 事件的新实例。
createStartElement(QName, Iterator, Iterator) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 StartElement。
createStartElement(String, String, String) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 StartElement。
createStartElement(String, String, String, Iterator, Iterator) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 StartElement。
createStartElement(String, String, String, Iterator, Iterator, NamespaceContext) - 类 javax.xml.stream.XMLEventFactory 中的方法
创建一个新 StartElement。
createStatement() - 接口 java.sql.Connection 中的方法
创建一个 Statement 对象来将 SQL 语句发送到数据库。
createStatement(int, int) - 接口 java.sql.Connection 中的方法
创建一个 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
createStatement(int, int, int) - 接口 java.sql.Connection 中的方法
创建一个 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
createStrokedShape(Shape) - 类 java.awt.BasicStroke 中的方法
返回一个 Shape，它在内部定义了指定 Shape 的笔划轮廓。
createStrokedShape(Shape) - 接口 java.awt.Stroke 中的方法
返回一个轮廓 Shape，它封闭了应该在根据规则描绘 Shape 时绘制的区域，这些规则是由实现 Stroke 接口的对象定义的。
createStruct(String, Object[]) - 接口 java.sql.Connection 中的方法
创建 Struct 对象的工厂方法。
createSubcontext(Name) - 接口 javax.naming.Context 中的方法
创建并绑定一个新上下文。
createSubcontext(String) - 接口 javax.naming.Context 中的方法
创建并绑定一个新上下文。
createSubcontext(Name, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
创建并绑定新的上下文及关联的属性。
createSubcontext(String, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
创建并绑定新的上下文及关联的属性。
createSubcontext(String, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
createSubcontext(Name, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
createSubcontext(String) - 类 javax.naming.InitialContext 中的方法
createSubcontext(Name) - 类 javax.naming.InitialContext 中的方法
createSubsetSampleModel(int[]) - 类 java.awt.image.BandedSampleModel 中的方法
创建一个具有此 BandedSampleModel 的 band 子集的新 BandedSampleModel。
createSubsetSampleModel(int[]) - 类 java.awt.image.ComponentSampleModel 中的方法
创建具有此 ComponentSampleModel 的 band 子集的新 ComponentSampleModel。
createSubsetSampleModel(int[]) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
创建一个具有此 MultiPixelPackedSampleModel band 子集的新 MultiPixelPackedSampleModel。
createSubsetSampleModel(int[]) - 类 java.awt.image.PixelInterleavedSampleModel 中的方法
创建一个具有此 PixelInterleavedSampleModel 的 band 子集的 PixelInterleavedSampleModel。
createSubsetSampleModel(int[]) - 类 java.awt.image.SampleModel 中的方法
创建一个新 SampleModel，它具有此 SampleModel 的 band 子集。
createSubsetSampleModel(int[]) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
创建一个新 SinglePixelPackedSampleModel，使其具有此 SinglePixelPackedSampleModel 的 band 子集。
createSystemMenu() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createSystemMenuBar() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
createTableCell(Element) - 类 javax.swing.text.TableView 中的方法
已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。
createTableRow(Element) - 类 javax.swing.text.TableView 中的方法
创建新的表格行。
createTempFile(String, String, File) - 类 java.io.File 中的静态方法
在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
createTempFile(String, String) - 类 java.io.File 中的静态方法
在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。
createTextArea(TextArea) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 TextArea 实现。
createTextField(TextField) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 TextField 实现。
createTextNode(String) - 接口 org.w3c.dom.Document 中的方法
创建给定指定字符串的 Text 节点。
createTitledBorder(String) - 类 javax.swing.BorderFactory 中的静态方法
创建一个新标题边框，使其具有指定的标题、默认的边框类型（由当前外观确定）、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
createTitledBorder(Border) - 类 javax.swing.BorderFactory 中的静态方法
创建一个空标题的新标题边框，使其具有指定的边框对象、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
createTitledBorder(Border, String) - 类 javax.swing.BorderFactory 中的静态方法
向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
createTitledBorder(Border, String, int, int) - 类 javax.swing.BorderFactory 中的静态方法
向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。
createTitledBorder(Border, String, int, int, Font) - 类 javax.swing.BorderFactory 中的静态方法
向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
createTitledBorder(Border, String, int, int, Font, Color) - 类 javax.swing.BorderFactory 中的静态方法
向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
createToolBarContListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createToolBarFocusListener() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
createToolTip() - 类 javax.swing.JComponent 中的方法
返回用于显示工具提示的 JToolTip 实例。
createTrack() - 类 javax.sound.midi.Sequence 中的方法
创建一个新的、初始为空的轨道作为此 Sequence 的一部分。
createTrackListener() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
createTrackListener(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
createTranscoderInstance() - 类 javax.imageio.spi.ImageTranscoderSpi 中的方法
返回与此服务提供者关联的 ImageTranscoder 实现的实例。
createTransferable(JComponent) - 类 javax.swing.TransferHandler 中的方法
创建一个要用作数据传输源的 Transferable。
createTransferableProxy(Transferable, boolean) - 类 java.awt.dnd.DropTargetContext 中的方法
创建一个代理指定 Transferable 的 TransferableProxy。
createTransformedArea(AffineTransform) - 类 java.awt.geom.Area 中的方法
创建一个新 Area 对象，使它与由指定 AffineTransform 变换的 Area 包含相同的几何形状。
createTransformedShape(Shape) - 类 java.awt.geom.AffineTransform 中的方法
返回新的 Shape 对象，它在通过此变换之后，由指定 Shape 的几何形状定义。
createTransformedShape(AffineTransform) - 类 java.awt.geom.Path2D 中的方法
返回一个表示此 Path2D 变换形式的新 Shape。
createTranslatedChild(int, int) - 类 java.awt.image.Raster 中的方法
创建一个 Raster，使其大小、SampleModel 和 DataBuffer 与此 Raster 相同，但是位置不同。
createTreeCellEditor() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果构造方法中没有提供 TreeCellEditor，则调用此方法。
createTreeExpansionListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建并返回在节点展开状态更改时负责更新 treestate 的对象。
createTreeModel(Object) - 类 javax.swing.JTree 中的静态方法
返回一个 TreeModel，它包装指定的对象。
createTreeModelListener() - 类 javax.swing.JTree 中的方法
创建并返回 TreeModelHandler 的一个实例。
createTreeModelListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回可以在模型更改时更新树的侦听器。
createTreeSelectionListener() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
创建基于选择更改方法更新显示的侦听器。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicCheckBoxUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的静态方法
创建 JTextPane 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicFormattedTextFieldUI 中的静态方法
创建 JFormattedTextField 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的静态方法
返回 BasicListUI 的新实例。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的静态方法
创建一个新的 BasicOptionPaneUI 实例。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicPanelUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 中的静态方法
创建 JPasswordField 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的静态方法
返回 BasicSpinnerUI 的新实例。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的静态方法
创建新的 BasicSplitPaneUI 实例
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的静态方法
创建 JTextArea 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的静态方法
创建 JTextField 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextPaneUI 中的静态方法
创建 JTextPane 的 UI。
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.ComponentUI 中的静态方法
返回指定组件的一个 UI 委托实例。
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalCheckBoxUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalLabelUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalMenuBarUI 中的静态方法
为传入的组件创建 ComponentUI 实现。
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalProgressBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalRootPaneUI 中的静态方法
为 JRootPane 创建一个 UI。
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalSeparatorUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalSplitPaneUI 中的静态方法
创建一个新的 MetalSplitPaneUI 实例
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalTextFieldUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的静态方法
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的静态方法
如果任意辅助 LookAndFeel 都支持此 UI，则返回一个多路 UI 实例。
createUI(JComponent) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
为传入的 JComponent 创建 Synth 外观 ComponentUI。
createUIs(ComponentUI, Vector, JComponent) - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的静态方法
创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
createUnion(Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
createUnion(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Double 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
createUnion(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Float 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
createUnion(Rectangle2D) - 类 java.awt.Rectangle 中的方法
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
createUnmarshalException(SAXException) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
从 SAXException 创建 UnmarshalException。
createUnmarshaller(ValidationEventHandler) - 接口 javax.xml.bind.annotation.DomHandler 中的方法
当 JAXB 提供者需要将文档的一部分解组为信息集表示形式时，首先要调用此方法创建一个 Result 对象。
createUnmarshaller(ValidationEventHandler) - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法
createUnmarshaller() - 类 javax.xml.bind.JAXBContext 中的方法
创建一个可以用来将 XML 数据转换为 java 内容树的 Unmarshaller 对象。
createUnresolved(String, int) - 类 java.net.InetSocketAddress 中的静态方法
根据主机名和端口号创建未解析的套接字地址。
createURLStreamHandler(String) - 接口 java.net.URLStreamHandlerFactory 中的方法
创建具有指定协议的新 URLStreamHandler 实例。
createValidator() - 类 javax.xml.bind.JAXBContext 中的方法
已过时。 从 JAXB 2.0 开始
createValue(UIDefaults) - 接口 javax.swing.UIDefaults.ActiveValue 中的方法
创建从 UIDefaults 表中检索的值。
createValue(UIDefaults) - 类 javax.swing.UIDefaults.LazyInputMap 中的方法
使用传入的绑定创建一个 InputMap。
createValue(UIDefaults) - 接口 javax.swing.UIDefaults.LazyValue 中的方法
创建从 UIDefaults 表中检索的实际值。
createValue(UIDefaults) - 类 javax.swing.UIDefaults.ProxyLazyValue 中的方法
创建从 UIDefaults 表中检索的值。
createValueHandler() - 类 javax.rmi.CORBA.Util 中的静态方法
返回实现 ValueHandler 接口的类的单一实例。
createValueHandler() - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.createValueHandler() 的委托调用。
createVerticalBox() - 类 javax.swing.Box 中的静态方法
创建一个从上到下显示其组件的 Box。
createVerticalGlue() - 类 javax.swing.Box 中的静态方法
创建一个纵向 glue 组件。
createVerticalScrollBar() - 类 javax.swing.JScrollPane 中的方法
默认返回 JScrollPane.ScrollBar。
createVerticalStrut(int) - 类 javax.swing.Box 中的静态方法
创建一个不可见的、固定高度的组件。
createView(FlowView, int, int, int) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
创建一个可用于表示流的当前片段的视图。
createViewListener() - 类 javax.swing.JViewport 中的方法
为该视图创建侦听器。
createViewport() - 类 javax.swing.JScrollPane 中的方法
默认返回新的 JViewport。
createViewportChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
createVolatileImage(int, int) - 类 java.awt.Component 中的方法
创建一幅用于双缓冲的、可变的、可在屏幕外绘制的图像。
createVolatileImage(int, int, ImageCapabilities) - 类 java.awt.Component 中的方法
创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。
createVSBChangeListener() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
createWestPane(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
createWindow(Window) - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 Window 实现。
createWinListener(JPopupMenu) - 类 javax.swing.JMenu 中的方法
创建弹出菜单的窗口关闭侦听器。
createWritableChild(int, int, int, int, int, int, int[]) - 类 java.awt.image.WritableRaster 中的方法
返回新的 WritableRaster，它共享此 WritableRaster 的全部或部分 DataBuffer。
createWritableRaster(SampleModel, Point) - 类 java.awt.image.Raster 中的静态方法
创建一个具有指定 SampleModel 的 WritableRaster。
createWritableRaster(SampleModel, DataBuffer, Point) - 类 java.awt.image.Raster 中的静态方法
创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
createWritableTranslatedChild(int, int) - 类 java.awt.image.WritableRaster 中的方法
在不同的位置上创建一个与此 WritableRaster 具有相同大小、SampleModel 和 DataBuffer 的 WritableRaster。
createWriterInstance() - 类 javax.imageio.spi.ImageWriterSpi 中的方法
返回与此服务提供者关联的 ImageWriter 实现的实例。
createWriterInstance(Object) - 类 javax.imageio.spi.ImageWriterSpi 中的方法
返回与此服务提供者关联的 ImageWriter 实现的实例。
createXMLEventReader(Reader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 reader 创建一个新 XMLEventReader。
createXMLEventReader(String, Reader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 reader 创建一个新 XMLEventReader。
createXMLEventReader(XMLStreamReader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 XMLStreamReader 创建一个新 XMLEventReader。
createXMLEventReader(Source) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 JAXP 源创建一个新 XMLEventReader。
createXMLEventReader(InputStream) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLEventReader。
createXMLEventReader(InputStream, String) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLEventReader。
createXMLEventReader(String, InputStream) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLEventReader。
createXMLEventWriter(Result) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到 JAXP 结果的新 XMLEventWriter。
createXMLEventWriter(OutputStream) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到流的新 XMLEventWriter。
createXMLEventWriter(OutputStream, String) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到流的新 XMLEventWriter。
createXMLEventWriter(Writer) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到 writer 的新 XMLEventWriter。
createXMLReader() - 类 org.xml.sax.helpers.XMLReaderFactory 中的静态方法
尝试从系统默认值创建一个 XMLReader。
createXMLReader(String) - 类 org.xml.sax.helpers.XMLReaderFactory 中的静态方法
尝试从类名称创建一个 XML 阅读器。
createXMLStreamReader(Reader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 reader 创建一个新 XMLStreamReader。
createXMLStreamReader(Source) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 JAXP 源创建一个新 XMLStreamReader。
createXMLStreamReader(InputStream) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLStreamReader。
createXMLStreamReader(InputStream, String) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLStreamReader。
createXMLStreamReader(String, InputStream) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLStreamReader。
createXMLStreamReader(String, Reader) - 类 javax.xml.stream.XMLInputFactory 中的方法
根据 java.io.InputStream 创建一个新 XMLStreamReader。
createXMLStreamWriter(Writer) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到 writer 的新 XMLStreamWriter。
createXMLStreamWriter(OutputStream) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到流的新 XMLStreamWriter。
createXMLStreamWriter(OutputStream, String) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到流的新 XMLStreamWriter。
createXMLStreamWriter(Result) - 类 javax.xml.stream.XMLOutputFactory 中的方法
创建一个写入到 JAXP 结果的新 XMLStreamWriter。
createZipEntry(String) - 类 java.util.jar.JarInputStream 中的方法
为指定的 JAR 文件条目名称创建新的 JarEntry (ZipEntry)。
createZipEntry(String) - 类 java.util.zip.ZipInputStream 中的方法
为指定条目名称创建一个新的 ZipEntry 对象。
createZone(int, int) - 类 javax.swing.text.ZoneView 中的方法
针对模型中的给定范围（应该在此对象的职责范围内），创建一个视图来表示分区。
CredentialException - javax.security.auth.login 中的 异常
一般证书异常。
CredentialException() - 异常 javax.security.auth.login.CredentialException 的构造方法
构造不带详细消息的 CredentialException。
CredentialException(String) - 异常 javax.security.auth.login.CredentialException 的构造方法
构造带指定详细消息的 CredentialException。
CredentialExpiredException - javax.security.auth.login 中的 异常
当 Credential 到期时抛出此异常。
CredentialExpiredException() - 异常 javax.security.auth.login.CredentialExpiredException 的构造方法
构造不带详细消息的 CredentialExpiredException。
CredentialExpiredException(String) - 异常 javax.security.auth.login.CredentialExpiredException 的构造方法
构造带指定详细消息的 CredentialExpiredException。
CredentialNotFoundException - javax.security.auth.login 中的 异常
找不到证书时抛出此异常。
CredentialNotFoundException() - 异常 javax.security.auth.login.CredentialNotFoundException 的构造方法
构造不带详细消息的 CredentialNotFoundException。
CredentialNotFoundException(String) - 异常 javax.security.auth.login.CredentialNotFoundException 的构造方法
构造带指定详细消息的 CredentialNotFoundException。
CREDENTIALS - 接口 javax.management.remote.JMXConnector 中的静态变量
属性的名称，它指定了连接过程中发送给连接器服务器的凭据。
CREDENTIALS - 类 javax.security.sasl.Sasl 中的静态变量
属性的名称，它指定要使用的证书。
CREDENTIALS_EXPIRED - 异常 org.ietf.jgss.GSSException 中的静态变量
过期的凭据。
CRITICAL - 接口 javax.naming.ldap.Control 中的静态变量
指示关键控件。
criticality - 类 javax.naming.ldap.BasicControl 中的变量
控件的关键性。
CRL - java.security.cert 中的 类
此类是具有不同格式但很常用的证书撤消列表 (CRL) 的抽象。
CRL(String) - 类 java.security.cert.CRL 的构造方法
创建指定类型的 CRL。
CRLException - java.security.cert 中的 异常
CRL（证书撤消列表）异常。
CRLException() - 异常 java.security.cert.CRLException 的构造方法
构造不带详细消息的 CRLException。
CRLException(String) - 异常 java.security.cert.CRLException 的构造方法
构造带指定详细消息的 CRLException。
CRLException(String, Throwable) - 异常 java.security.cert.CRLException 的构造方法
创建带指定详细消息和 cause 的 CRLException。
CRLException(Throwable) - 异常 java.security.cert.CRLException 的构造方法
创建带指定 cause 和详细消息的 CRLException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CRLSelector - java.security.cert 中的 接口
一个定义了一套选择 CRL 的标准的选择器。
CropImageFilter - java.awt.image 中的 类
用于裁剪图像的 ImageFilter 类。
CropImageFilter(int, int, int, int) - 类 java.awt.image.CropImageFilter 的构造方法
按指定 x、y、w 和 h 参数从源 Image 提取绝对矩形区域来构造 CropImageFilter。
CROSS_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供两个表的交叉乘积。
CROSSHAIR_CURSOR - 类 java.awt.Cursor 中的静态变量
十字光标类型。
CROSSHAIR_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.CROSSHAIR_CURSOR 取代。
CS_CIEXYZ - 类 java.awt.color.ColorSpace 中的静态变量
上面定义的 CIEXYZ 变换颜色空间。
CS_GRAY - 类 java.awt.color.ColorSpace 中的静态变量
内置的线性灰度颜色空间。
CS_LINEAR_RGB - 类 java.awt.color.ColorSpace 中的静态变量
内置的线性 RGB 颜色空间。
CS_PYCC - 类 java.awt.color.ColorSpace 中的静态变量
Photo YCC 变换颜色空间。
CS_sRGB - 类 java.awt.color.ColorSpace 中的静态变量
sRGB 颜色空间的定义位于 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html。
CSS - javax.swing.text.html 中的 类
将 CSS attributes 集定义为类型安全的枚举。
CSS() - 类 javax.swing.text.html.CSS 的构造方法
CSS.Attribute - javax.swing.text.html 中的 类
用作 AttributeSet 的键的定义，此属性集可存储 CSS 属性。
CTRL_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Control 键的扩展修饰符常量。
CTRL_MASK - 类 java.awt.event.ActionEvent 中的静态变量
Ctrl 修饰符。
CTRL_MASK - 类 java.awt.Event 中的静态变量
此标志指示当事件发生时按下 Control 键。
CTRL_MASK - 类 java.awt.event.InputEvent 中的静态变量
Ctrl 键修饰符常量。
ctrlx - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段控制点的 X 坐标。
ctrlx - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段控制点的 X 坐标。
ctrlx1 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段第一个控制点的 X 坐标。
ctrlx1 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段第一个控制点的 X 坐标。
ctrlx2 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段第二个控制点的 X 坐标。
ctrlx2 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段第二个控制点的 X 坐标。
ctrly - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段控制点的 Y 坐标。
ctrly - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段控制点的 Y 坐标。
ctrly1 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段第一个控制点的 Y 坐标。
ctrly1 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段第一个控制点的 Y 坐标。
ctrly2 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段第二个控制点的 Y 坐标。
ctrly2 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段第二个控制点的 Y 坐标。
ctx() - 类 org.omg.CORBA.Request 中的方法
检索用于此请求的 Context 对象。
ctx(Context) - 类 org.omg.CORBA.Request 中的方法
将此请求的 Context 对象设置为给定对象。
ctx() - 类 org.omg.CORBA.ServerRequest 中的方法
当操作不是一个属性访问并且该操作的 IDL 定义中包含上下文表达式时，该操作返回用 IDL 指定的上下文信息；否则返回 nil Context 引用。
CTX_RESTRICT_SCOPE - org.omg.CORBA 中的 接口
可以用作 Context.get_values 方法的第二个参数以限制搜索范围的标志。
CubicCurve2D - java.awt.geom 中的 类
CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。
CubicCurve2D() - 类 java.awt.geom.CubicCurve2D 的构造方法
这是一个不可直接实例化的抽象类。
CubicCurve2D.Double - java.awt.geom 中的 类
使用 double 坐标指定的三次参数曲线段。
CubicCurve2D.Double() - 类 java.awt.geom.CubicCurve2D.Double 的构造方法
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 CubicCurve。
CubicCurve2D.Double(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D.Double 的构造方法
根据指定的 double 坐标构造并初始化一个 CubicCurve2D。
CubicCurve2D.Float - java.awt.geom 中的 类
使用 float 坐标指定的三次参数曲线段。
CubicCurve2D.Float() - 类 java.awt.geom.CubicCurve2D.Float 的构造方法
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 CubicCurve。
CubicCurve2D.Float(float, float, float, float, float, float, float, float) - 类 java.awt.geom.CubicCurve2D.Float 的构造方法
根据指定的 float 坐标构造并初始化一个 CubicCurve2D。
CURRENCY - 类 java.text.NumberFormat.Field 中的静态变量
标识货币字段的常量。
Currency - java.util 中的 类
表示货币。
CURRENCY_SYMBOL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Sc”。
CURRENCY_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Currency Symbols”Unicode 字符块的常量。
CurrencyNameProvider - java.util.spi 中的 类
为 Currency 类提供本地化货币符号的服务提供者的抽象类。
CurrencyNameProvider() - 类 java.util.spi.CurrencyNameProvider 的构造方法
唯一的构造方法。
current() - 类 java.text.BreakIterator 中的方法
返回最近由 next()、next(int)、previous()、first()、last()、following(int) 或 preceding(int) 返回的文本边界的字符索引。
current() - 接口 java.text.CharacterIterator 中的方法
获取当前位置（由 getIndex() 返回）的字符。
current() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.current()。
current() - 类 javax.swing.text.ElementIterator 中的方法
获取当前 Element。
CURRENT - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
current() - 类 javax.swing.text.Segment 中的方法
获取当前位置（由 getIndex() 返回）的字符。
Current - org.omg.CORBA 中的 接口
从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
Current - org.omg.PortableInterceptor 中的 接口
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。
Current - org.omg.PortableServer 中的 接口
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。
current_component() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 返回一个 DynAny 对象引用，可用来获取/设置当前所访问组件的值。
current_component() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回当前位置上的组件的 DynAny。
current_component() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
返回当前位置上的组件的 DynAny。
current_factory() - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
current_factory(ObjectReferenceFactory) - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
读取时返回当前工厂，该工厂将用于创建对应于刚创建并在 IOR interceptor 上运行的对象适配器的对象引用。
current_member_kind() - 接口 org.omg.CORBA.DynStruct 中的方法
已过时。 返回描述当前成员的种类的 TCKind 对象。
current_member_kind() - 接口 org.omg.CORBA.DynValue 中的方法
已过时。 返回描述当前成员的 TCKind 对象。
current_member_kind() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回与当前位置的成员关联的 TCKind。
current_member_kind() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回与当前位置的成员有关联的 TCKind。
current_member_kind() - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
返回与当前位置的成员关联的 TCKind。
current_member_kind() - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
返回与当前位置的成员关联的 TCKind。
current_member_name() - 接口 org.omg.CORBA.DynStruct 中的方法
已过时。 在遍历期间返回当前成员的名称。
current_member_name() - 接口 org.omg.CORBA.DynValue 中的方法
已过时。 在遍历表示某个 Value 对象的 DynAny 对象时，返回当前成员的名称。
current_member_name() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回当前位置上的成员的名称。
current_member_name() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回当前位置上成员的名称。
current_member_name() - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
返回当前位置的成员的名称。
current_member_name() - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
返回当前位置上的成员的名称。
currentCellRenderer - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要用于进行实际单元格绘制的渲染器。
currentClassLoader() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
currentGroupID() - 类 java.rmi.activation.ActivationGroup 中的静态方法
返回当前激活组的标识符。
CurrentHelper - org.omg.CORBA 中的 类
Current 的 Helper。
CurrentHelper() - 类 org.omg.CORBA.CurrentHelper 的构造方法
CurrentHelper - org.omg.PortableInterceptor 中的 类
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文和请求方或应答的服务上下文之间传输其上下文数据。
CurrentHelper() - 类 org.omg.PortableInterceptor.CurrentHelper 的构造方法
CurrentHelper - org.omg.PortableServer 中的 类
从 CORBA::Current 派生的 PortableServer::Current 接口，它提供一些方法实现，这些实现能够访问调用方法的对象的身份。
CurrentHelper() - 类 org.omg.PortableServer.CurrentHelper 的构造方法
CurrentHolder - org.omg.CORBA 中的 类
Current 的 Holder。
CurrentHolder() - 类 org.omg.CORBA.CurrentHolder 的构造方法
CurrentHolder(Current) - 类 org.omg.CORBA.CurrentHolder 的构造方法
currentLoadedClass() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
currentManager(Component) - 类 javax.swing.RepaintManager 中的静态方法
在给定 Component 的情况下，返回调用线程的 RepaintManager。
currentManager(JComponent) - 类 javax.swing.RepaintManager 中的静态方法
在给定 JComponent 的情况下，返回调用线程的 RepaintManager。
currentMouseX - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的变量
currentMouseX - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的变量
currentMouseY - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的变量
currentMouseY - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的变量
CurrentOperations - org.omg.CORBA 中的 接口
Current 的接口。
CurrentOperations - org.omg.PortableInterceptor 中的 接口
Portable Interceptor Current（也称为 PICurrent）就是一个槽表 (slot table)，每个服务都使用该表中的槽在其上下文与请求或应答服务上下文之间传输其上下文数据。
CurrentOperations - org.omg.PortableServer 中的 接口
从 CORBA::Current 中派生的 PortableServer::Current 接口，它提供一些能够访问调用方法的对象身份的方法实现。
currentSegment(float[]) - 类 java.awt.geom.FlatteningPathIterator 中的方法
使用迭代返回当前路径段的坐标和类型。
currentSegment(double[]) - 类 java.awt.geom.FlatteningPathIterator 中的方法
使用迭代返回当前路径段的坐标和类型。
currentSegment(float[]) - 接口 java.awt.geom.PathIterator 中的方法
使用迭代返回当前路径段的坐标和类型。
currentSegment(double[]) - 接口 java.awt.geom.PathIterator 中的方法
使用迭代返回当前路径段的坐标和类型。
currentThread() - 类 java.lang.Thread 中的静态方法
返回对当前正在执行的线程对象的引用。
currentTimeMillis() - 类 java.lang.System 中的静态方法
返回以毫秒为单位的当前时间。
currentValuePane - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
Cursor - java.awt 中的 类
封装鼠标光标的位图表示形式的类。
Cursor(int) - 类 java.awt.Cursor 的构造方法
用指定类型创建一个新的光标对象。
Cursor(String) - 类 java.awt.Cursor 的构造方法
用指定名称创建一个新的定制光标对象。
cursorMoved(RowSetEvent) - 接口 javax.sql.RowSetListener 中的方法
通知已注册侦听器 RowSet 对象的指针已移动。
curveTo(double, double, double, double, double, double) - 类 java.awt.geom.Path2D 中的方法
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
curveTo(double, double, double, double, double, double) - 类 java.awt.geom.Path2D.Double 中的方法
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
curveTo(double, double, double, double, double, double) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
curveTo(float, float, float, float, float, float) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
CUSTOM_CURSOR - 类 java.awt.Cursor 中的静态变量
与所有定制光标有关的类型。
CUSTOM_DIALOG - 类 javax.swing.JFileChooser 中的静态变量
指示 JFileChooser 支持特定于开发人员文件操作的类型值。
Customizer - java.beans 中的 接口
customizer 类提供一个用来自定义目标 Java Bean 的完全自定义 GUI。
CustomMarshal - org.omg.CORBA 中的 接口
将由 ORB 而不是由用户使用的抽象 value 类型。
CustomValue - org.omg.CORBA.portable 中的 接口
通过自定义值类型实现的 ValueBase 扩展。
cut(int, int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
将两个索引之间的文本剪切到系统剪贴板中。
cut() - 类 javax.swing.JPasswordField 中的方法
对当前外观调用 provideErrorFeedback，这通常启动错误蜂鸣。
cut(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
将两个索引之间的文本剪切到系统剪贴板中。
cut(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
将两个索引之间的文本剪切到系统剪贴板中。
cut() - 类 javax.swing.text.JTextComponent 中的方法
将关联文本模型中当前选定的范围传输到系统剪贴板，并从模型中移除内容。
cutAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
剪切选定区域并将其内容置于剪贴板中的动作名称。
cxt - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 中的变量
cyan - 类 java.awt.Color 中的静态变量
青色。
CYAN - 类 java.awt.Color 中的静态变量
青色。
CyclicBarrier - java.util.concurrent 中的 类
一个同步辅助类，它允许一组线程互相等待，直到到达某个公共屏障点 (common barrier point)。
CyclicBarrier(int, Runnable) - 类 java.util.concurrent.CyclicBarrier 的构造方法
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，并在启动 barrier 时执行给定的屏障操作，该操作由最后一个进入 barrier 的线程执行。
CyclicBarrier(int) - 类 java.util.concurrent.CyclicBarrier 的构造方法
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，但它不会在启动 barrier 时执行预定义的操作。
CYPRIOT_SYLLABARY - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Cypriot Syllabary”Unicode 字符块的常量。
CYRILLIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Cyrillic”Unicode 字符块的常量。
CYRILLIC_SUPPLEMENTARY - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Cyrillic Supplementary”Unicode 字符块的常量。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


D - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

D

D - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering D (22 x 34 in) 的 MediaType 实例。
D - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering D 尺寸，22 inch × 34 inch。
D - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
D 尺寸。
damage(Rectangle) - 类 javax.swing.text.DefaultCaret 中的方法
毁坏围绕插入符的区域以使该区域在新的位置重绘。
damageLineRange(int, int, Shape, Component) - 类 javax.swing.text.PlainView 中的方法
重新绘制给定的行范围。
damageRange(JTextComponent, int, int) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
促使重新绘制负责模型给定部分的那部分视图。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
促使重新绘制负责模型给定部分的那部分视图。
damageRange(JTextComponent, int, int) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 damageRange 方法。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 damageRange 方法。
damageRange(JTextComponent, int, int) - 类 javax.swing.plaf.TextUI 中的方法
促使重新绘制负责模型给定部分的那部分视图。
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - 类 javax.swing.plaf.TextUI 中的方法
促使重新绘制负责模型给定部分的那部分视图。
DARK - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态变量
DARK_GRAY - 类 java.awt.Color 中的静态变量
深灰色。
darker() - 类 java.awt.Color 中的方法
创建一个新 Color，它具有比此 Color 更暗的颜色。
darkGray - 类 java.awt.Color 中的静态变量
深灰色。
darkShadow - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的变量
darkShadow - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的变量
darkShadow - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
darkShadowColor - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
DASH_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pd”。
data - 类 javax.sound.midi.MidiMessage 中的变量
MIDI 消息数据。
DATA - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
data - 类 javax.swing.text.html.parser.Element 中的变量
存储用户数据的字段。
data - 类 javax.swing.text.html.parser.Entity 中的变量
Data - javax.xml.crypto 中的 接口
取消引用 URIReference 或后续 Transform 的输入/输出所得结果的抽象表示。
DATA_CONVERSION - org.omg.CORBA 中的 异常
如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
DATA_CONVERSION() - 异常 org.omg.CORBA.DATA_CONVERSION 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(String) - 异常 org.omg.CORBA.DATA_CONVERSION 的构造方法
使用指定详细消息构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(int, CompletionStatus) - 异常 org.omg.CORBA.DATA_CONVERSION 的构造方法
使用指定次要代码和完成状态构造一个 DATA_CONVERSION 异常。
DATA_CONVERSION(String, int, CompletionStatus) - 异常 org.omg.CORBA.DATA_CONVERSION 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 DATA_CONVERSION 异常。
DATA_TRANSFER_COMPLETE - 类 javax.print.event.PrintJobEvent 中的静态变量
不必打印该作业，但数据已经成功地从客户端传输到了打印服务。
DatabaseMetaData - java.sql 中的 接口
关于数据库的整体综合信息。
DataBuffer - java.awt.image 中的 类
此类用于包装一个或多个数据数组。
DataBuffer(int, int) - 类 java.awt.image.DataBuffer 的构造方法
构造包含一个指定数据类型和大小的存储单元的 DataBuffer。
DataBuffer(int, int, int) - 类 java.awt.image.DataBuffer 的构造方法
构造包含了指定数量的存储单元的 DataBuffer。
DataBuffer(int, int, int, int) - 类 java.awt.image.DataBuffer 的构造方法
构造包含指定存储单元数量的 DataBuffer。
DataBuffer(int, int, int, int[]) - 类 java.awt.image.DataBuffer 的构造方法
构造包含指定存储单元数量的 DataBuffer。
dataBuffer - 类 java.awt.image.Raster 中的变量
存储图像数据的 DataBuffer。
DataBufferByte - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部按字节存储数据。
DataBufferByte(int) - 类 java.awt.image.DataBufferByte 的构造方法
构造具有单个存储单元和指定大小且基于字节的 DataBuffer。
DataBufferByte(int, int) - 类 java.awt.image.DataBufferByte 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于字节的 DataBuffer。
DataBufferByte(byte[], int) - 类 java.awt.image.DataBufferByte 的构造方法
使用指定数组构造具有单个存储单元且基于字节的 DataBuffer。
DataBufferByte(byte[], int, int) - 类 java.awt.image.DataBufferByte 的构造方法
使用指定数组、大小和偏移量构造具有单个存储单元且基于字节的 DataBuffer。
DataBufferByte(byte[][], int) - 类 java.awt.image.DataBufferByte 的构造方法
构造具有指定数组且基于字节的 DataBuffer。
DataBufferByte(byte[][], int, int[]) - 类 java.awt.image.DataBufferByte 的构造方法
构造具有指定数组、大小和偏移量且基于字节的 DataBuffer。
DataBufferDouble - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以 double 形式存储数据。
DataBufferDouble(int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定大小且基于 double 的 DataBuffer。
DataBufferDouble(int, int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 double 的 DataBuffer。
DataBufferDouble(double[], int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(double[], int, int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(double[][], int) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(double[][], int, int[]) - 类 java.awt.image.DataBufferDouble 的构造方法
构造具有指定数据数组、大小和每存储单元偏移量且基于 double 的 DataBuffer。
DataBufferFloat - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以 float 形式存储数据。
DataBufferFloat(int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定大小的且基于 float 的 DataBuffer。
DataBufferFloat(int, int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 float 的 DataBuffer。
DataBufferFloat(float[], int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(float[], int, int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(float[][], int) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(float[][], int, int[]) - 类 java.awt.image.DataBufferFloat 的构造方法
构造具有指定数据数组、大小和每存储单元偏移量且基于 float 的 DataBuffer。
DataBufferInt - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以整数形式存储数据。
DataBufferInt(int) - 类 java.awt.image.DataBufferInt 的构造方法
构造具有单个存储单元和指定大小且基于整数的 DataBuffer。
DataBufferInt(int, int) - 类 java.awt.image.DataBufferInt 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于整数的 DataBuffer。
DataBufferInt(int[], int) - 类 java.awt.image.DataBufferInt 的构造方法
使用指定数组构造具有单个存储单元且基于整数的 DataBuffer。
DataBufferInt(int[], int, int) - 类 java.awt.image.DataBufferInt 的构造方法
使用指定数组、大小和偏移量构造具有单个存储单元且基于整数的 DataBuffer。
DataBufferInt(int[][], int) - 类 java.awt.image.DataBufferInt 的构造方法
构造具有指定数组且基于整数的 DataBuffer。
DataBufferInt(int[][], int, int[]) - 类 java.awt.image.DataBufferInt 的构造方法
构造具有指定数组、大小和偏移量且基于整数的 DataBuffer。
DataBufferShort - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以 short 类型存储数据。
DataBufferShort(int) - 类 java.awt.image.DataBufferShort 的构造方法
构造具有单个存储单元和指定大小且基于 short 的 DataBuffer。
DataBufferShort(int, int) - 类 java.awt.image.DataBufferShort 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 short 的 DataBuffer。
DataBufferShort(short[], int) - 类 java.awt.image.DataBufferShort 的构造方法
使用指定数组构造具有单个存储单元且基于 short 的 DataBuffer。
DataBufferShort(short[], int, int) - 类 java.awt.image.DataBufferShort 的构造方法
使用指定数组、大小和偏移量构造具有单个存储单元且基于 short 的 DataBuffer。
DataBufferShort(short[][], int) - 类 java.awt.image.DataBufferShort 的构造方法
构造具有指定数组且基于 short 的 DataBuffer。
DataBufferShort(short[][], int, int[]) - 类 java.awt.image.DataBufferShort 的构造方法
构造具有指定数组、大小和偏移量且基于 short 的 DataBuffer。
DataBufferUShort - java.awt.image 中的 类
此类扩展了 DataBuffer，并在内部以 short 类型存储数据。
DataBufferUShort(int) - 类 java.awt.image.DataBufferUShort 的构造方法
构造具有单个存储单元和指定大小且基于无符号 short 的 DataBuffer。
DataBufferUShort(int, int) - 类 java.awt.image.DataBufferUShort 的构造方法
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[], int) - 类 java.awt.image.DataBufferUShort 的构造方法
使用指定数组构造具有单个存储单元且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[], int, int) - 类 java.awt.image.DataBufferUShort 的构造方法
使用指定数组、大小和偏移量构造具有单个存储单元且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[][], int) - 类 java.awt.image.DataBufferUShort 的构造方法
构造具有指定数组且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[][], int, int[]) - 类 java.awt.image.DataBufferUShort 的构造方法
构造具有指定数组、大小和偏移量且基于无符号 short 的 DataBuffer。
DataContentHandler - javax.activation 中的 接口
DataContentHandler 接口由可用于扩展 Transferable 接口的 DataHandler 实现性能的对象来实现。
DataContentHandlerFactory - javax.activation 中的 接口
此接口定义了 DataContentHandler 的工厂。
dataDefinitionCausesTransactionCommit() - 接口 java.sql.DatabaseMetaData 中的方法
获取事务中的数据定义语句是否强迫该事务进行提交。
dataDefinitionIgnoredInTransactions() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否忽略事务中的数据定义语句。
DataFlavor - java.awt.datatransfer 中的 类
DataFlavor 提供有关数据的元信息。
DataFlavor() - 类 java.awt.datatransfer.DataFlavor 的构造方法
构造一个新的 DataFlavor。
DataFlavor(Class<?>, String) - 类 java.awt.datatransfer.DataFlavor 的构造方法
构造一个表示 Java 类的 DataFlavor。
DataFlavor(String, String) - 类 java.awt.datatransfer.DataFlavor 的构造方法
构造一个表示 MimeType 的 DataFlavor。
DataFlavor(String, String, ClassLoader) - 类 java.awt.datatransfer.DataFlavor 的构造方法
构造一个表示 MimeType 的 DataFlavor。
DataFlavor(String) - 类 java.awt.datatransfer.DataFlavor 的构造方法
根据 mimeType 字符串构造 DataFlavor。
DataFormatException - java.util.zip 中的 异常
当数据格式发生错误时，抛出此异常。
DataFormatException() - 异常 java.util.zip.DataFormatException 的构造方法
构造不带详细消息的 DataFormatException。
DataFormatException(String) - 异常 java.util.zip.DataFormatException 的构造方法
构造带指定详细消息的 DataFormatException。
DatagramChannel - java.nio.channels 中的 类
针对面向数据报套接字的可选择通道。
DatagramChannel(SelectorProvider) - 类 java.nio.channels.DatagramChannel 的构造方法
初始化此类的一个新实例。
DatagramPacket - java.net 中的 类
此类表示数据报包。
DatagramPacket(byte[], int, int) - 类 java.net.DatagramPacket 的构造方法
构造 DatagramPacket，用来接收长度为 length 的包，在缓冲区中指定了偏移量。
DatagramPacket(byte[], int) - 类 java.net.DatagramPacket 的构造方法
构造 DatagramPacket，用来接收长度为 length 的数据包。
DatagramPacket(byte[], int, int, InetAddress, int) - 类 java.net.DatagramPacket 的构造方法
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[], int, int, SocketAddress) - 类 java.net.DatagramPacket 的构造方法
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[], int, InetAddress, int) - 类 java.net.DatagramPacket 的构造方法
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[], int, SocketAddress) - 类 java.net.DatagramPacket 的构造方法
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramSocket - java.net 中的 类
此类表示用来发送和接收数据报包的套接字。
DatagramSocket() - 类 java.net.DatagramSocket 的构造方法
构造数据报套接字并将其绑定到本地主机上任何可用的端口。
DatagramSocket(DatagramSocketImpl) - 类 java.net.DatagramSocket 的构造方法
创建带有指定 DatagramSocketImpl 的未绑定数据报套接字。
DatagramSocket(SocketAddress) - 类 java.net.DatagramSocket 的构造方法
创建数据报套接字，将其绑定到指定的本地套接字地址。
DatagramSocket(int) - 类 java.net.DatagramSocket 的构造方法
创建数据报套接字并将其绑定到本地主机上的指定端口。
DatagramSocket(int, InetAddress) - 类 java.net.DatagramSocket 的构造方法
创建数据报套接字，将其绑定到指定的本地地址。
DatagramSocketImpl - java.net 中的 类
数据报和多播套接字实现的抽象基类。
DatagramSocketImpl() - 类 java.net.DatagramSocketImpl 的构造方法
DatagramSocketImplFactory - java.net 中的 接口
此接口定义用于数据报套接字实现的工厂。
DataHandler - javax.activation 中的 类
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。
DataHandler(DataSource) - 类 javax.activation.DataHandler 的构造方法
创建引用指定 DataSource 的 DataHandler 实例。
DataHandler(Object, String) - 类 javax.activation.DataHandler 的构造方法
创建表示此 MIME 类型对象的 DataHandler 实例。
DataHandler(URL) - 类 javax.activation.DataHandler 的构造方法
创建引用 URL 的 DataHandler 实例。
DataInput - java.io 中的 接口
DataInput 接口用于从二进制流中读取字节，并根据所有 Java 基本类型数据进行重构。
DataInputStream - java.io 中的 类
数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
DataInputStream(InputStream) - 类 java.io.DataInputStream 的构造方法
使用指定的底层 InputStream 创建一个 DataInputStream。
DataInputStream - org.omg.CORBA 中的 接口
定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
DataLine - javax.sound.sampled 中的 接口
DataLine 将与介质相关的功能添加到其超接口 Line。
DataLine.Info - javax.sound.sampled 中的 类
除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。
DataLine.Info(Class<?>, AudioFormat[], int, int) - 类 javax.sound.sampled.DataLine.Info 的构造方法
根据指定信息构造数据行的信息对象，这些包括受支持音频格式的集合和缓冲区大小的范围。
DataLine.Info(Class<?>, AudioFormat, int) - 类 javax.sound.sampled.DataLine.Info 的构造方法
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式和所需的缓冲区大小。
DataLine.Info(Class<?>, AudioFormat) - 类 javax.sound.sampled.DataLine.Info 的构造方法
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式。
DATALINK - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DATALINK 的 Java 编程语言中的常量（有时称为类型代码）。
dataModel - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
dataModel - 类 javax.swing.JTable 中的变量
表的 TableModel。
DataOutput - java.io 中的 接口
DataOutput 接口用于将数据从任意 Java 基本类型转换为一系列字节，并将这些字节写入二进制流。
DataOutputStream - java.io 中的 类
数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
DataOutputStream(OutputStream) - 类 java.io.DataOutputStream 的构造方法
创建一个新的数据输出流，将数据写入指定基础输出流。
DataOutputStream - org.omg.CORBA 中的 接口
定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。
DataSource - javax.activation 中的 接口
DataSource 接口为 JavaBeans Activation Framework 提供任意数据集合的抽象。
DataSource - javax.sql 中的 接口
该工厂用于提供到此 DataSource 对象所表示的物理数据源的连接。
DATASOURCE_DB_LOCK - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示锁定整个数据源，该数据源是正在使用此 SyncProvider 对象的 RowSet 对象的数据源。
DATASOURCE_NO_LOCK - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示在原始数据源上不保持任何锁定。
DATASOURCE_ROW_LOCK - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示锁定原始 SQL 语句涉及的行，该语句用于填充正在使用此 SyncProvider 对象的 RowSet 对象。
DATASOURCE_TABLE_LOCK - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示锁定原始 SQL 语句涉及的所有表，该语句用于填充正在使用此 SyncProvider 对象的 RowSet 对象。
DataTruncation - java.sql 中的 异常
以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
DataTruncation(int, boolean, boolean, int, int) - 异常 java.sql.DataTruncation 的构造方法
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。
DataTruncation(int, boolean, boolean, int, int, Throwable) - 异常 java.sql.DataTruncation 的构造方法
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。
dataType - 类 java.awt.image.DataBuffer 中的变量
此 DataBuffer 的数据类型。
dataType - 类 java.awt.image.SampleModel 中的变量
存储像素数据的 DataBuffer 的数据类型。
DATATYPE_BOOLEAN - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeDataType 返回的常量，指示属性的值为 'true' 或 'false'。
DATATYPE_DOUBLE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
由 getAttributeDataType 返回的常量，指示属性的值为双精度十进制浮点数的字符串表示形式。
DATATYPE_FLOAT - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
由 getAttributeDataType 返回的常量，指示属性的值为十进制浮点数的字符串表示形式。
DATATYPE_INTEGER - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeDataType 返回的常量，指示属性的值为整数的字符串表示形式。
DATATYPE_STRING - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeDataType 返回的常量，指示属性的值为通用的 Unicode 字符串。
DatatypeConfigurationException - javax.xml.datatype 中的 异常
指示严重的配置错误。
DatatypeConfigurationException() - 异常 javax.xml.datatype.DatatypeConfigurationException 的构造方法
创建不带任何指定详细消息和原因的新 DatatypeConfigurationException。
DatatypeConfigurationException(String) - 异常 javax.xml.datatype.DatatypeConfigurationException 的构造方法
创建带指定详细消息的新 DatatypeConfigurationException。
DatatypeConfigurationException(String, Throwable) - 异常 javax.xml.datatype.DatatypeConfigurationException 的构造方法
创建带有指定详细消息和原因的新 DatatypeConfigurationException。
DatatypeConfigurationException(Throwable) - 异常 javax.xml.datatype.DatatypeConfigurationException 的构造方法
使用指定的原因创建一个新的 DatatypeConfigurationException。
DatatypeConstants - javax.xml.datatype 中的 类
包含基本 Datatype 值作为常量的实用工具类。
DatatypeConstants.Field - javax.xml.datatype 中的 类
类型安全的枚举类，它表示 Duration 类的六个字段。
DatatypeConverter - javax.xml.bind 中的 类
可以使用 javaType 绑定声明来自定义 XML 模式数据类型到 Java 数据类型的绑定。
DatatypeConverterInterface - javax.xml.bind 中的 接口
该 DatatypeConverterInterface 仅适用于 JAXB 提供者。
DatatypeFactory - javax.xml.datatype 中的 类
创建新 javax.xml.datatype Object 的工厂，创建的对象可提供 XML 和 Java Object 之间的映射。
DatatypeFactory() - 类 javax.xml.datatype.DatatypeFactory 的构造方法
受保护的构造方法，包外无法实例化。
DATATYPEFACTORY_IMPLEMENTATION_CLASS - 类 javax.xml.datatype.DatatypeFactory 中的静态变量
JSR 206: Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。
DATATYPEFACTORY_PROPERTY - 类 javax.xml.datatype.DatatypeFactory 中的静态变量
JSR 206:Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。
dataVector - 类 javax.swing.table.DefaultTableModel 中的变量
Vector，由包含多个 Object 值的 Vector 组成。
Date - java.sql 中的 类
一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
Date(int, int, int) - 类 java.sql.Date 的构造方法
已过时。 使用构造方法 Date(long date) 替代
Date(long) - 类 java.sql.Date 的构造方法
使用给定毫秒时间值构造一个 Date 对象。
DATE - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DATE 的 Java 编程语言中的常量（有时称为类型代码）。
DATE - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一个月中的某天。
Date - java.util 中的 类
类 Date 表示特定的瞬间，精确到毫秒。
Date() - 类 java.util.Date 的构造方法
分配 Date 对象并初始化此对象，以表示分配它的时间（精确到毫秒）。
Date(long) - 类 java.util.Date 的构造方法
分配 Date 对象并初始化此对象，以表示自从标准基准时间（称为“历元（epoch）”，即 1970 年 1 月 1 日 00:00:00 GMT）以来的指定毫秒数。
Date(int, int, int) - 类 java.util.Date 的构造方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date) 或 GregorianCalendar(year + 1900, month, date) 取代。
Date(int, int, int, int, int) - 类 java.util.Date 的构造方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min) 或 GregorianCalendar(year + 1900, month, date, hrs, min) 取代。
Date(int, int, int, int, int, int) - 类 java.util.Date 的构造方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代。
Date(String) - 类 java.util.Date 的构造方法
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
DATE - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.util.Date 的值。
DATE - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 date 的完全限定名称。
DATE_EDITOR - 类 javax.accessibility.AccessibleRole 中的静态变量
DATE_EDITOR 是允许用户编辑 java.util.Date 和 java.util.Time 对象的组件。
DATE_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 DATE 字段的有用常量。
dateFilter(RowFilter.ComparisonType, Date, int...) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。
DateFormat - java.text 中的 类
DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
DateFormat() - 类 java.text.DateFormat 的构造方法
创建一个新的 DateFormat。
DateFormat.Field - java.text 中的 类
定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
DateFormat.Field(String, int) - 类 java.text.DateFormat.Field 的构造方法
创建一个 Field。
DateFormatProvider - java.text.spi 中的 类
提供 DateFormat 类具体实现的服务提供者的抽象类。
DateFormatProvider() - 类 java.text.spi.DateFormatProvider 的构造方法
唯一的构造方法。
DateFormatSymbols - java.text 中的 类
DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
DateFormatSymbols() - 类 java.text.DateFormatSymbols 的构造方法
通过从默认语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。
DateFormatSymbols(Locale) - 类 java.text.DateFormatSymbols 的构造方法
通过从给定语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。
DateFormatSymbolsProvider - java.text.spi 中的 类
提供 DateFormatSymbols 类实例的服务提供者的抽象类。
DateFormatSymbolsProvider() - 类 java.text.spi.DateFormatSymbolsProvider 的构造方法
唯一的构造方法。
DateFormatter - javax.swing.text 中的 类
DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
DateFormatter() - 类 javax.swing.text.DateFormatter 的构造方法
这是 new DateFormatter(DateFormat.getDateInstance()) 的简写。
DateFormatter(DateFormat) - 类 javax.swing.text.DateFormatter 的构造方法
返回用指定的 Format 实例配置的 DateFormatter。
DATETIME - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 dateTime 的完全限定名称。
DateTimeAtCompleted - javax.print.attribute.standard 中的 类
DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
DateTimeAtCompleted(Date) - 类 javax.print.attribute.standard.DateTimeAtCompleted 的构造方法
构造具有给定 Date 值的新 date-time at completed 属性。
DateTimeAtCreation - javax.print.attribute.standard 中的 类
DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
DateTimeAtCreation(Date) - 类 javax.print.attribute.standard.DateTimeAtCreation 的构造方法
构造具有给定 Date 值的新的 DateTimeAtCreation 属性。
DateTimeAtProcessing - javax.print.attribute.standard 中的 类
DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
DateTimeAtProcessing(Date) - 类 javax.print.attribute.standard.DateTimeAtProcessing 的构造方法
构造具有给定 Date 值的新的 DateTimeAtProcessing 属性。
DateTimeSyntax - javax.print.attribute 中的 类
类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。
DateTimeSyntax(Date) - 类 javax.print.attribute.DateTimeSyntax 的构造方法
构造具有给定 java.util.Date 值的新的日期-时间属性。
DAY_OF_MONTH - 类 java.text.DateFormat.Field 中的静态变量
标识 DAY_OF_MONTH 字段的常量。
DAY_OF_MONTH - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一个月中的某天。
DAY_OF_WEEK - 类 java.text.DateFormat.Field 中的静态变量
标识 DAY_OF_WEEK 字段的常量。
DAY_OF_WEEK - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一个星期中的某天。
DAY_OF_WEEK_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 DAY_OF_WEEK 字段的有用常量。
DAY_OF_WEEK_IN_MONTH - 类 java.text.DateFormat.Field 中的静态变量
标识 DAY_OF_WEEK_IN_MONTH 字段的常量。
DAY_OF_WEEK_IN_MONTH - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示当前月中的第几个星期。
DAY_OF_WEEK_IN_MONTH_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 DAY_OF_WEEK_IN_MONTH 字段的有用常量。
DAY_OF_YEAR - 类 java.text.DateFormat.Field 中的静态变量
标识 DAY_OF_YEAR 字段的常量。
DAY_OF_YEAR - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示当前年中的天数。
DAY_OF_YEAR_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 DAY_OF_YEAR 字段的有用常量。
DAYS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示日字段的常量。
dbgTag - 类 javax.management.monitor.Monitor 中的变量
已过时。 无替代版本。
DD - 类 javax.swing.text.html.HTML.Tag 中的静态变量
deactivate(boolean) - 接口 java.awt.im.spi.InputMethod 中的方法
让输入方法处于非活动状态。
deactivate() - 接口 javax.rmi.CORBA.Tie 中的方法
取消激活此 tie 表示的目标对象。
deactivate(boolean, boolean) - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作将 POA 管理器的状态更改为非激活 (inactive)，促使关联的 POA 拒绝尚未开始执行的请求以及任何新的请求。
deactivate_object(byte[]) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作促使在 oid 参数中指定的 ObjectId 被取消激活。
deactivateFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
deactivateFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常指示此窗体失去焦点。
deactivateFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
窗体不再是被选择状态时调用此方法。
DebugGraphics - javax.swing 中的 类
支持图形调试的图形子类。
DebugGraphics() - 类 javax.swing.DebugGraphics 的构造方法
构造一个支持减速绘制的新调试图形上下文。
DebugGraphics(Graphics, JComponent) - 类 javax.swing.DebugGraphics 的构造方法
根据现有图形上下文构造一个调试图形上下文，该上下文可以减慢指定组件的绘制。
DebugGraphics(Graphics) - 类 javax.swing.DebugGraphics 的构造方法
根据现有图形上下文构造一个调试图形上下文，该上下文支持减慢绘制。
decapitalize(String) - 类 java.beans.Introspector 中的静态方法
获得一个字符串并将它转换成普通 Java 变量名称大写形式的实用工具方法。
DECEMBER - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第十二个月的 Calendar.MONTH 字段值。
DECEMBER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第十二个月的值。
DECIMAL - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DECIMAL 的 Java 编程语言中的常量（有时称为类型代码）。
DECIMAL128 - 类 java.math.MathContext 中的静态变量
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal128 格式（即 34 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
DECIMAL32 - 类 java.math.MathContext 中的静态变量
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal32 格式（即 7 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
DECIMAL64 - 类 java.math.MathContext 中的静态变量
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal64 格式（即 16 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
DECIMAL_DIGIT_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Nd”。
DECIMAL_SEPARATOR - 类 java.text.NumberFormat.Field 中的静态变量
标识小数点字段的常量。
DecimalFormat - java.text 中的 类
DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
DecimalFormat() - 类 java.text.DecimalFormat 的构造方法
使用默认模式和默认语言环境的符号创建一个 DecimalFormat。
DecimalFormat(String) - 类 java.text.DecimalFormat 的构造方法
使用给定的模式和默认语言环境的符号创建一个 DecimalFormat。
DecimalFormat(String, DecimalFormatSymbols) - 类 java.text.DecimalFormat 的构造方法
使用给定的模式和符号创建一个 DecimalFormat。
DecimalFormatSymbols - java.text 中的 类
此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
DecimalFormatSymbols() - 类 java.text.DecimalFormatSymbols 的构造方法
为默认的语言环境创建一个 DecimalFormatSymbols 对象。
DecimalFormatSymbols(Locale) - 类 java.text.DecimalFormatSymbols 的构造方法
为给定的语言环境创建一个 DecimalFormatSymbols 对象。
DecimalFormatSymbolsProvider - java.text.spi 中的 类
提供 DecimalFormatSymbols 类实例的服务提供者的抽象类。
DecimalFormatSymbolsProvider() - 类 java.text.spi.DecimalFormatSymbolsProvider 的构造方法
唯一的构造方法。
DECLARE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
DECLARED - 接口 java.lang.reflect.Member 中的静态变量
标识类或接口的所有已声明成员的集合。
DeclaredType - javax.lang.model.type 中的 接口
表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
declaredType - 类 javax.xml.bind.JAXBElement 中的变量
xml 元素声明类型的 Java 数据类型绑定。
declarePrefix(String, String) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
声明名称空间前缀。
DeclHandler - org.xml.sax.ext 中的 接口
用于 DTD 声明事件的 SAX2 扩展处理程序。
decode(String) - 类 java.awt.Color 中的静态方法
将 String 转换成整数，并返回指定的不透明 Color。
decode(String) - 类 java.awt.Font 中的静态方法
返回 str 参数所描述的 Font。
decode(String) - 类 java.lang.Byte 中的静态方法
将 String 解码为 Byte。
decode(String) - 类 java.lang.Integer 中的静态方法
将 String 解码为 Integer。
decode(String) - 类 java.lang.Long 中的静态方法
将 String 解码成 Long。
decode(String) - 类 java.lang.Short 中的静态方法
将 String 解码为 Short。
decode(String) - 类 java.net.URLDecoder 中的静态方法
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。
decode(String, String) - 类 java.net.URLDecoder 中的静态方法
使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。
decode(ByteBuffer) - 类 java.nio.charset.Charset 中的方法
将此 charset 中的字节解码成 Unicode 字符的便捷方法。
decode(ByteBuffer, CharBuffer, boolean) - 类 java.nio.charset.CharsetDecoder 中的方法
从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
decode(ByteBuffer) - 类 java.nio.charset.CharsetDecoder 中的方法
把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
decode(InputStream) - 接口 java.security.Certificate 中的方法
已过时。 从输入流解码证书。
decode(byte[]) - 接口 org.omg.IOP.CodecOperations 中的方法
基于对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
decode_value(byte[], TypeCode) - 接口 org.omg.IOP.CodecOperations 中的方法
基于给定的 TypeCode 和对此 Codec 有效的编码格式，将给定的 byte 数组解码为 Any。
decodeDataFlavor(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
解码 String native 以用作 DataFlavor。
decodeJavaMIMEType(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
解码 String native 以用作 Java MIME 类型。
decodeLineStyle(Object) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
此方法进行传入客户端属性中的字符串和内部表示形式（当前的并且用 int 值表示）之间的转换
decodeLoop(ByteBuffer, CharBuffer) - 类 java.nio.charset.CharsetDecoder 中的方法
将一个或多个字节解码为一个或多个字符。
decorateTask(Runnable, RunnableScheduledFuture<V>) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
修改或替换用于执行 runnable 的任务。
decorateTask(Callable<V>, RunnableScheduledFuture<V>) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
修改或替换用于执行 callable 的任务。
decrButton - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
DECREASE_HIGHLIGHT - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的静态变量
decreaseButton - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
DECREMENT - 接口 javax.accessibility.AccessibleAction 中的静态变量
减少某个值的动作。
decrementAndGet() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将当前值减 1。
decrementAndGet(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将索引 i 的元素减 1。
decrementAndGet(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的字段的当前值减 1。
decrementAndGet() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将当前值减 1。
decrementAndGet(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将索引 i 的元素减1。
decrementAndGet(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象字段当前值减 1。
decrIndent() - 类 javax.swing.text.AbstractWriter 中的方法
降低缩进级别。
DECRYPT - 类 javax.xml.crypto.KeySelector.Purpose 中的静态变量
用于解密的密钥。
DECRYPT_MODE - 类 javax.crypto.Cipher 中的静态变量
用于将 Cipher 初始化为解密模式的常量。
deepEquals(Object[], Object[]) - 类 java.util.Arrays 中的静态方法
如果两个指定数组彼此是深层相等 的，则返回 true。
deepHashCode(Object[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的“深层内容”返回哈希码。
deepToString(Object[]) - 类 java.util.Arrays 中的静态方法
返回指定数组“深层内容”的字符串表示形式。
def - 类 java.util.zip.DeflaterInputStream 中的变量
此流的压缩器。
def - 类 java.util.zip.DeflaterOutputStream 中的变量
此流的压缩器。
def_kind() - 类 org.omg.CORBA._IDLTypeStub 中的方法
def_kind() - 接口 org.omg.CORBA.IRObjectOperations 中的方法
返回对应于此接口存储库对象的 DefinitionKind。
defAttributeList(String, int, int, String, String, AttributeList) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个 AttributeList。
DEFAULT - 类 java.awt.dnd.DragSourceContext 中的静态变量
updateCurrentCursor() 使用的 int 值，指示应该将 Cursor 改为默认（未放置）的 Cursor。
DEFAULT - 类 java.security.spec.PSSParameterSpec 中的静态变量
带所有默认值的 PSS 参数集合。
DEFAULT - 类 java.text.DateFormat 中的静态变量
用于默认模式的常量。
DEFAULT - 类 javax.crypto.spec.OAEPParameterSpec 中的静态变量
使用所有默认值的 OAEP 参数设置。
DEFAULT - 类 javax.crypto.spec.PSource.PSpecified 中的静态变量
其值与 byte[0] 相等的编码输入 P。
DEFAULT - 接口 javax.swing.Action 中的静态变量
当前未使用。
DEFAULT - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 是默认区域。
DEFAULT - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
DEFAULT - 类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 中的静态变量
指示默认名称空间（“#default”）。
DEFAULT_CARET_POLICY - 类 java.awt.font.TextLayout 中的静态变量
客户端未指定策略时使用此 CaretPolicy。
DEFAULT_CLASS_LOADER - 类 javax.management.remote.JMXConnectorFactory 中的静态变量
指定默认的类加载器的属性名称。
DEFAULT_CLASS_LOADER - 类 javax.management.remote.JMXConnectorServerFactory 中的静态变量
指定默认的类加载器的属性名称。
DEFAULT_CLASS_LOADER_NAME - 类 javax.management.remote.JMXConnectorServerFactory 中的静态变量
指定默认的类加载器 MBean 名称的属性名称。
DEFAULT_COMPRESSION - 类 java.util.zip.Deflater 中的静态变量
默认压缩级别。
DEFAULT_CSS - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
用于设置标记视图的默认级联样式表 (Cascading Style Sheet) 文件。
DEFAULT_CURSOR - 类 java.awt.Cursor 中的静态变量
默认光标类型（如果没有定义光标，则获取该设置）。
DEFAULT_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.DEFAULT_CURSOR 取代。
default_index() - 类 org.omg.CORBA.TypeCode 中的方法
返回默认成员的索引，如果没有默认成员，则返回 -1。
DEFAULT_JUSTIFICATION - 类 javax.swing.border.TitledBorder 中的静态变量
标题文本使用默认的对齐方式。
DEFAULT_KEYMAP - 类 javax.swing.text.JTextComponent 中的静态变量
将由所有 JTextComponent 实例共享的默认 keymap，除非这些实例已有另一个 keymap 集合。
DEFAULT_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Default 层的便捷对象。
DEFAULT_LIFETIME - 接口 org.ietf.jgss.GSSContext 中的静态变量
一个表示默认的上下文生存期的生存期常量。
DEFAULT_LIFETIME - 接口 org.ietf.jgss.GSSCredential 中的静态变量
一个表示默认的凭据生存期的生存期常量。
DEFAULT_MODALITY_TYPE - 类 java.awt.Dialog 中的静态变量
有模式 dialog 的默认模式类型。
DEFAULT_NS_PREFIX - 类 javax.xml.XMLConstants 中的静态变量
用于表示默认 XML 名称空间的前缀。
DEFAULT_OBJECT_MODEL_URI - 类 javax.xml.xpath.XPathFactory 中的静态变量
默认 Object Model URI。
DEFAULT_OPTION - 类 javax.swing.JOptionPane 中的静态变量
意味着外观不应该提供任何选项的类型，即仅使用取自 JOptionPane 的选项。
default_POA(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此方法的默认行为是从关联 servant 的 ORB 实例返回根 POA。
DEFAULT_POSITION - 类 javax.swing.border.TitledBorder 中的静态变量
标题文本使用默认的垂直方向。
DEFAULT_PROPERTY_NAME - 类 javax.xml.xpath.XPathFactory 中的静态变量
遵守 JAXP 规范的默认属性名称。
DEFAULT_SIZE - 类 javax.swing.GroupLayout 中的静态变量
指示组件或间隙的大小应该用于特定的范围值。
DEFAULT_SOAP_PROTOCOL - 接口 javax.xml.soap.SOAPConstants 中的静态变量
默认协议：向后兼容的 SOAP 1.1。
DEFAULT_STRATEGY - 类 java.util.zip.Deflater 中的静态变量
默认压缩策略。
DEFAULT_STYLE - 类 javax.swing.text.StyleContext 中的静态变量
赋予与段落相关的默认逻辑样式的名称。
DEFAULT_VALUE - 类 javax.lang.model.util.ElementScanner6 中的变量
指定的默认值。
DEFAULT_VALUE - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的变量
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
DEFAULT_VALUE - 类 javax.lang.model.util.SimpleElementVisitor6 中的变量
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
DEFAULT_VALUE - 类 javax.lang.model.util.SimpleTypeVisitor6 中的变量
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
DEFAULT_VALUE_FIELD - 类 javax.management.JMX 中的静态变量
defaultValue 字段的名称。
defaultAction(Object, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
visit 方法的默认动作。
defaultAction(Element, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
visit 方法的默认动作。
defaultAction(TypeMirror, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
visit 方法的默认动作。
DefaultBoundedRangeModel - javax.swing 中的 类
BoundedRangeModel 的一般实现。
DefaultBoundedRangeModel() - 类 javax.swing.DefaultBoundedRangeModel 的构造方法
使用默认值初始化所有属性。
DefaultBoundedRangeModel(int, int, int, int) - 类 javax.swing.DefaultBoundedRangeModel 的构造方法
初始化 value、extent、minimum 和 maximum。
defaultButton - 类 javax.swing.JRootPane 中的变量
当窗格成为焦点并有类似按下 Enter 键的特定于 UI 的操作发生时被激活的按钮。
DefaultButtonModel - javax.swing 中的 类
Button 组件的数据模型的默认实现。
DefaultButtonModel() - 类 javax.swing.DefaultButtonModel 的构造方法
构造一个 DefaultButtonModel。
DefaultCaret - javax.swing.text 中的 类
插入符的默认实现。
DefaultCaret() - 类 javax.swing.text.DefaultCaret 的构造方法
构造默认的插入符。
DefaultCellEditor - javax.swing 中的 类
表单元格和树单元格的默认编辑器。
DefaultCellEditor(JTextField) - 类 javax.swing.DefaultCellEditor 的构造方法
构造一个使用文本字段的 DefaultCellEditor。
DefaultCellEditor(JCheckBox) - 类 javax.swing.DefaultCellEditor 的构造方法
构造一个使用复选框的 DefaultCellEditor 对象。
DefaultCellEditor(JComboBox) - 类 javax.swing.DefaultCellEditor 的构造方法
构造一个使用组合框的 DefaultCellEditor 对象。
DefaultCellEditor.EditorDelegate - javax.swing 中的 类
受保护的 (protected) EditorDelegate 类。
DefaultCellEditor.EditorDelegate() - 类 javax.swing.DefaultCellEditor.EditorDelegate 的构造方法
defaultCharset() - 类 java.nio.charset.Charset 中的静态方法
返回此 Java 虚拟机的默认 charset。
defaultChoosers - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的变量
DefaultColorSelectionModel - javax.swing.colorchooser 中的 类
ColorSelectionModel 的一般实现。
DefaultColorSelectionModel() - 类 javax.swing.colorchooser.DefaultColorSelectionModel 的构造方法
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 Color.white。
DefaultColorSelectionModel(Color) - 类 javax.swing.colorchooser.DefaultColorSelectionModel 的构造方法
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 color，该颜色不应为 null。
DefaultComboBoxModel - javax.swing 中的 类
组合框的默认模型。
DefaultComboBoxModel() - 类 javax.swing.DefaultComboBoxModel 的构造方法
构造一个空的 DefaultComboBoxModel 对象。
DefaultComboBoxModel(Object[]) - 类 javax.swing.DefaultComboBoxModel 的构造方法
构造一个用对象数组初始化的 DefaultComboBoxModel 对象。
DefaultComboBoxModel(Vector<?>) - 类 javax.swing.DefaultComboBoxModel 的构造方法
构造一个用向量初始化的 DefaultComboBoxModel 对象。
defaultConstraints - 类 java.awt.GridBagLayout 中的变量
此字段保持包含默认值的网格包约束实例，因此如果某个组件没有与其相关联的网格包约束，则会分配给该组件一个 defaultConstraints 的副本。
defaultController - 类 javax.imageio.IIOParam 中的变量
调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的默认 IIOParamController。
defaultController - 类 javax.imageio.metadata.IIOMetadata 中的变量
建议用作此 IIOMetadata 对象的控制器的 IIOMetadataController。
DefaultCopyDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于复制操作的默认 Cursor，指示当前允许放置。
DefaultCopyNoDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于复制操作的默认 Cursor，指示当前不允许放置。
DefaultDesktopManager - javax.swing 中的 类
此类是 DesktopManager 的实现。
DefaultDesktopManager() - 类 javax.swing.DefaultDesktopManager 的构造方法
defaulted(String) - 类 java.io.ObjectInputStream.GetField 中的方法
如果指定的字段是默认字段并且在此流中不存在任何值，则返回 true。
DefaultEditorKit - javax.swing.text 中的 类
这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
DefaultEditorKit() - 类 javax.swing.text.DefaultEditorKit 的构造方法
DefaultEditorKit 的默认构造方法
DefaultEditorKit.BeepAction - javax.swing.text 中的 类
创建蜂鸣声。
DefaultEditorKit.BeepAction() - 类 javax.swing.text.DefaultEditorKit.BeepAction 的构造方法
使用适当的标识符创建此对象。
DefaultEditorKit.CopyAction - javax.swing.text 中的 类
复制选定的区域并将其内容放入系统剪贴板中。
DefaultEditorKit.CopyAction() - 类 javax.swing.text.DefaultEditorKit.CopyAction 的构造方法
使用适当的标识符创建此对象。
DefaultEditorKit.CutAction - javax.swing.text 中的 类
剪切选定的区域并将其内容放入系统剪贴板中。
DefaultEditorKit.CutAction() - 类 javax.swing.text.DefaultEditorKit.CutAction 的构造方法
使用适当的标识符创建此对象。
DefaultEditorKit.DefaultKeyTypedAction - javax.swing.text 中的 类
如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
DefaultEditorKit.DefaultKeyTypedAction() - 类 javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction 的构造方法
用适当的标识符创建此对象。
DefaultEditorKit.InsertBreakAction - javax.swing.text 中的 类
在文档中放置行/段落中断。
DefaultEditorKit.InsertBreakAction() - 类 javax.swing.text.DefaultEditorKit.InsertBreakAction 的构造方法
创建此对象，使其具有相应的标识符。
DefaultEditorKit.InsertContentAction - javax.swing.text 中的 类
将内容置于关联的文档中。
DefaultEditorKit.InsertContentAction() - 类 javax.swing.text.DefaultEditorKit.InsertContentAction 的构造方法
创建此对象，使其具有相应的标识符。
DefaultEditorKit.InsertTabAction - javax.swing.text 中的 类
将一个制表符置于文档中。
DefaultEditorKit.InsertTabAction() - 类 javax.swing.text.DefaultEditorKit.InsertTabAction 的构造方法
创建此对象，使其具有相应的标识符。
DefaultEditorKit.PasteAction - javax.swing.text 中的 类
将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
DefaultEditorKit.PasteAction() - 类 javax.swing.text.DefaultEditorKit.PasteAction 的构造方法
创建此对象，使其具有相应的标识符。
defaultEditorsByColumnClass - 类 javax.swing.JTable 中的变量
一个由对象组成的表，它显示并编辑单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。
DefaultFocusManager - javax.swing 中的 类
此类已被废弃，用 1.4 focus API 取代。
DefaultFocusManager() - 类 javax.swing.DefaultFocusManager 的构造方法
DefaultFocusTraversalPolicy - java.awt 中的 类
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
DefaultFocusTraversalPolicy() - 类 java.awt.DefaultFocusTraversalPolicy 的构造方法
DefaultFormatter - javax.swing.text 中的 类
DefaultFormatter 格式化任意对象。
DefaultFormatter() - 类 javax.swing.text.DefaultFormatter 的构造方法
创建 DefaultFormatter。
DefaultFormatterFactory - javax.swing.text 中的 类
JFormattedTextField.AbstractFormatterFactory 的一个实现。
DefaultFormatterFactory() - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 的构造方法
创建具有指定 JFormattedTextField.AbstractFormatter 的 DefaultFormatterFactory。
DefaultHandler - org.xml.sax.helpers 中的 类
SAX2 事件处理程序的默认基类。
DefaultHandler() - 类 org.xml.sax.helpers.DefaultHandler 的构造方法
DefaultHandler2 - org.xml.sax.ext 中的 类
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。
DefaultHandler2() - 类 org.xml.sax.ext.DefaultHandler2 的构造方法
构造忽略所有解析事件的处理程序。
DefaultHighlighter - javax.swing.text 中的 类
实现 Highlighter 接口。
DefaultHighlighter() - 类 javax.swing.text.DefaultHighlighter 的构造方法
创建新 DefaultHighlighther 对象。
DefaultHighlighter.DefaultHighlightPainter - javax.swing.text 中的 类
只高亮显示用纯色填充高亮显示区域的 painter。
DefaultHighlighter.DefaultHighlightPainter(Color) - 类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 的构造方法
构造新的高亮显示 painter。
defaultInitCtx - 类 javax.naming.InitialContext 中的变量
该字段保存调用 NamingManager.getInitialContext() 的结果。
DefaultKeyboardFocusManager - java.awt 中的 类
AWT 应用程序的默认 KeyboardFocusManager。
DefaultKeyboardFocusManager() - 类 java.awt.DefaultKeyboardFocusManager 的构造方法
defaultKeyTypedAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
在接收到键输入事件 并且无 keymap 输入时默认执行的动作名称。
DefaultLinkDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于链接操作的默认 Cursor，指示当前允许放置。
DefaultLinkNoDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于链接操作的默认 Cursor，指示当前不允许放置。
DefaultListCellRenderer - javax.swing 中的 类
呈现列表中的一个项。
DefaultListCellRenderer() - 类 javax.swing.DefaultListCellRenderer 的构造方法
为列表中的项构造默认渲染器对象。
DefaultListCellRenderer.UIResource - javax.swing 中的 类
实现 UIResource 的 DefaultListCellRenderer 的子类。
DefaultListCellRenderer.UIResource() - 类 javax.swing.DefaultListCellRenderer.UIResource 的构造方法
DefaultListModel - javax.swing 中的 类
此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。
DefaultListModel() - 类 javax.swing.DefaultListModel 的构造方法
DefaultListSelectionModel - javax.swing 中的 类
列表选择的默认数据模型。
DefaultListSelectionModel() - 类 javax.swing.DefaultListSelectionModel 的构造方法
DefaultLoaderRepository - javax.management 中的 类
已过时。 使用 MBeanServer.getClassLoaderRepository() 取代。
DefaultLoaderRepository() - 类 javax.management.DefaultLoaderRepository 的构造方法
已过时。
DefaultLoaderRepository - javax.management.loading 中的 类
已过时。 使用 MBeanServer.getClassLoaderRepository()} 替代。
DefaultLoaderRepository() - 类 javax.management.loading.DefaultLoaderRepository 的构造方法
已过时。
defaultManager() - 类 javax.swing.MenuSelectionManager 中的静态方法
返回默认菜单选项管理器。
DefaultMenuLayout - javax.swing.plaf.basic 中的 类
Popup 菜单和菜单栏的默认布局管理器。
DefaultMenuLayout(Container, int) - 类 javax.swing.plaf.basic.DefaultMenuLayout 的构造方法
DefaultMetalTheme - javax.swing.plaf.metal 中的 类
提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。
DefaultMetalTheme() - 类 javax.swing.plaf.metal.DefaultMetalTheme 的构造方法
创建并返回 DefaultMetalTheme 的一个实例。
DefaultMoveDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于移动操作的默认 Cursor，指示当前允许放置。
DefaultMoveNoDrop - 类 java.awt.dnd.DragSource 中的静态变量
用于移动操作的默认 Cursor，指示当前不允许放置。
DefaultMutableTreeNode - javax.swing.tree 中的 类
DefaultMutableTreeNode 是树数据结构中的通用节点。
DefaultMutableTreeNode() - 类 javax.swing.tree.DefaultMutableTreeNode 的构造方法
创建没有父节点和子节点的树节点，该树节点允许有子节点。
DefaultMutableTreeNode(Object) - 类 javax.swing.tree.DefaultMutableTreeNode 的构造方法
创建没有父节点和子节点、但允许有子节点的树节点，并使用指定的用户对象对它进行初始化。
DefaultMutableTreeNode(Object, boolean) - 类 javax.swing.tree.DefaultMutableTreeNode 的构造方法
创建没有父节点和子节点的树节点，使用指定的用户对象对它进行初始化，仅在指定时才允许有子节点。
defaultPage(PageFormat) - 类 java.awt.print.PrinterJob 中的方法
复制 PageFormat 参数，并更改该副本，以描述默认页面的大小和方向。
defaultPage() - 类 java.awt.print.PrinterJob 中的方法
创建新的 PageFormat 实例，并将它设置为默认大小和方向。
DefaultPainter - 类 javax.swing.text.DefaultHighlighter 中的静态变量
LayeredHighlighter.LayerPainter 的默认实现，可用于绘制高亮显示区域。
DefaultPersistenceDelegate - java.beans 中的 类
DefaultPersistenceDelegate 是 PersistenceDelegate 抽象类的具体实现，是没有关于其可用信息的类在默认情况下使用的委托。
DefaultPersistenceDelegate() - 类 java.beans.DefaultPersistenceDelegate 的构造方法
为具有 null 构造方法的类创建持久委托。
DefaultPersistenceDelegate(String[]) - 类 java.beans.DefaultPersistenceDelegate 的构造方法
为其构造方法的参数是属性名称值（由 constructorPropertyNames 指定）的类创建默认持久委托。
defaultPressAction - 类 javax.swing.JRootPane 中的变量
已过时。 从 Java 2 platform v1.3 开始
defaultReadObject() - 类 java.io.ObjectInputStream 中的方法
从此流读取当前类的非静态和非瞬态字段。
defaultReleaseAction - 类 javax.swing.JRootPane 中的变量
已过时。 从 Java 2 platform v1.3 开始
defaultRenderersByColumnClass - 类 javax.swing.JTable 中的变量
一个由对象组成的表，它显示单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。
DefaultRowSorter<M,I> - javax.swing 中的 类
RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。
DefaultRowSorter() - 类 javax.swing.DefaultRowSorter 的构造方法
创建一个空 DefaultRowSorter。
DefaultRowSorter.ModelWrapper<M,I> - javax.swing 中的 类
DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。
DefaultRowSorter.ModelWrapper() - 类 javax.swing.DefaultRowSorter.ModelWrapper 的构造方法
创建一个新的 ModelWrapper。
defaults - 类 java.util.Properties 中的变量
一个属性列表，包含属性列表中所有未找到值的键的默认值。
DefaultSingleSelectionModel - javax.swing 中的 类
SingleSelectionModel 的一般实现。
DefaultSingleSelectionModel() - 类 javax.swing.DefaultSingleSelectionModel 的构造方法
DefaultStyledDocument - javax.swing.text 中的 类
能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
DefaultStyledDocument(AbstractDocument.Content, StyleContext) - 类 javax.swing.text.DefaultStyledDocument 的构造方法
构造样式化文档。
DefaultStyledDocument(StyleContext) - 类 javax.swing.text.DefaultStyledDocument 的构造方法
构造具有默认的内容存储实现和一组共享样式的样式化文档。
DefaultStyledDocument() - 类 javax.swing.text.DefaultStyledDocument 的构造方法
构造默认的样式化文档。
DefaultStyledDocument.AttributeUndoableEdit - javax.swing.text 中的 类
用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。
DefaultStyledDocument.AttributeUndoableEdit(Element, AttributeSet, boolean) - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 的构造方法
DefaultStyledDocument.ElementBuffer - javax.swing.text 中的 类
管理对元素层次结构更改的类。
DefaultStyledDocument.ElementBuffer(Element) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 的构造方法
创建新的 ElementBuffer。
DefaultStyledDocument.ElementSpec - javax.swing.text 中的 类
构建元素的规范。
DefaultStyledDocument.ElementSpec(AttributeSet, short) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 的构造方法
当标记不在文档中存储时供标记使用的构造方法。
DefaultStyledDocument.ElementSpec(AttributeSet, short, int) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 的构造方法
供文档内部解析使用的构造方法，在数据已添加但还需要 len 信息时使用。
DefaultStyledDocument.ElementSpec(AttributeSet, short, char[], int, int) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 的构造方法
用于外部创建规范的构造方法，供批量输入内容和标记到文档中。
DefaultStyledDocument.SectionElement - javax.swing.text 中的 类
文档的默认根元素... 与所包含的段落/行对应。
DefaultStyledDocument.SectionElement() - 类 javax.swing.text.DefaultStyledDocument.SectionElement 的构造方法
创建新 SectionElement。
DefaultTableCellRenderer - javax.swing.table 中的 类
呈现（显示） JTable 中每个单元格的标准类。
DefaultTableCellRenderer() - 类 javax.swing.table.DefaultTableCellRenderer 的构造方法
创建一个默认的表单元格渲染器。
DefaultTableCellRenderer.UIResource - javax.swing.table 中的 类
DefaultTableCellRenderer 的一个子类，它实现 UIResource。
DefaultTableCellRenderer.UIResource() - 类 javax.swing.table.DefaultTableCellRenderer.UIResource 的构造方法
DefaultTableColumnModel - javax.swing.table 中的 类
JTable 的标准列处理程序。
DefaultTableColumnModel() - 类 javax.swing.table.DefaultTableColumnModel 的构造方法
创建默认的表列模型。
DefaultTableModel - javax.swing.table 中的 类
这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。
DefaultTableModel() - 类 javax.swing.table.DefaultTableModel 的构造方法
构造默认的 DefaultTableModel，它是一个零列零行的表。
DefaultTableModel(int, int) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个具有 rowCount 行和 columnCount 列的 null 对象值的 DefaultTableModel。
DefaultTableModel(Vector, int) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。
DefaultTableModel(Object[], int) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。
DefaultTableModel(Vector, Vector) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。
DefaultTableModel(Object[][], Object[]) - 类 javax.swing.table.DefaultTableModel 的构造方法
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。
defaultTextIconGap - 类 javax.swing.plaf.basic.BasicButtonUI 中的变量
defaultTextIconGap - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
defaultTextShiftOffset - 类 javax.swing.plaf.basic.BasicButtonUI 中的变量
DefaultTextUI - javax.swing.text 中的 类
已过时。
DefaultTextUI() - 类 javax.swing.text.DefaultTextUI 的构造方法
已过时。
defaultThreadFactory() - 类 java.util.concurrent.Executors 中的静态方法
返回用于创建新线程的默认线程工厂。
DefaultTreeCellEditor - javax.swing.tree 中的 类
TreeCellEditor。
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer) - 类 javax.swing.tree.DefaultTreeCellEditor 的构造方法
使用指定呈现器和默认编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer, TreeCellEditor) - 类 javax.swing.tree.DefaultTreeCellEditor 的构造方法
使用指定的呈现器和指定的编辑器，为 JTree 构造一个 DefaultTreeCellEditor 对象。
DefaultTreeCellEditor.DefaultTextField - javax.swing.tree 中的 类
不提供任何编辑器时所使用的 TextField。
DefaultTreeCellEditor.DefaultTextField(Border) - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 的构造方法
构造一个 DefaultTreeCellEditor.DefaultTextField 对象。
DefaultTreeCellEditor.EditorContainer - javax.swing.tree 中的 类
负责存放 editingComponent 的容器。
DefaultTreeCellEditor.EditorContainer() - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 的构造方法
构造一个 EditorContainer 对象。
DefaultTreeCellRenderer - javax.swing.tree 中的 类
显示树中的条目。
DefaultTreeCellRenderer() - 类 javax.swing.tree.DefaultTreeCellRenderer 的构造方法
返回 DefaultTreeCellRenderer 的新实例。
DefaultTreeModel - javax.swing.tree 中的 类
使用 TreeNodes 的简单树数据模型。
DefaultTreeModel(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 的构造方法
创建其中任何节点都可以有子节点的树。
DefaultTreeModel(TreeNode, boolean) - 类 javax.swing.tree.DefaultTreeModel 的构造方法
创建一棵树，指定某个节点是否可以有子节点，或者是否仅某些节点可以有子节点。
DefaultTreeSelectionModel - javax.swing.tree 中的 类
TreeSelectionModel 的默认实现。
DefaultTreeSelectionModel() - 类 javax.swing.tree.DefaultTreeSelectionModel 的构造方法
使用 DISCONTIGUOUS_TREE_SELECTION 的选择模式创建空的 DefaultTreeSelectionModel 新实例。
DefaultValidationEventHandler - javax.xml.bind.helpers 中的 类
唯一的 JAXB 1.0 默认验证事件处理程序。
DefaultValidationEventHandler() - 类 javax.xml.bind.helpers.DefaultValidationEventHandler 的构造方法
defaultWriteObject() - 类 java.io.ObjectOutputStream 中的方法
将当前类的非静态和非瞬态字段写入此流。
defContentModel(int, Object, ContentModel) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个新的内容模式。
DEFECTIVE_CREDENTIAL - 异常 org.ietf.jgss.GSSException 中的静态变量
有缺陷的凭据。
DEFECTIVE_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
有缺陷的标记。
defElement(String, int, boolean, boolean, ContentModel, String[], String[], AttributeList) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个 Element。
defEntity(String, int, int) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个字符 Entity。
defEntity(String, int, String) - 类 javax.swing.text.html.parser.DTD 中的方法
创建并返回一个 Entity。
defineAttributes(String, AttributeList) - 类 javax.swing.text.html.parser.DTD 中的方法
定义 Element 的属性。
defineClass(byte[], int, int) - 类 java.lang.ClassLoader 中的方法
已过时。 由 defineClass(String, byte[], int, int) 取代
defineClass(String, byte[], int, int) - 类 java.lang.ClassLoader 中的方法
将一个 byte 数组转换为 Class 类的实例。
defineClass(String, byte[], int, int, ProtectionDomain) - 类 java.lang.ClassLoader 中的方法
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
defineClass(String, ByteBuffer, ProtectionDomain) - 类 java.lang.ClassLoader 中的方法
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。
defineClass(String, byte[], int, int, CodeSource) - 类 java.security.SecureClassLoader 中的方法
使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。
defineClass(String, ByteBuffer, CodeSource) - 类 java.security.SecureClassLoader 中的方法
使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。
defined_in - 类 org.omg.CORBA.ValueMember 中的变量
用来定义此成员的 value 的存储库 ID。
defineElement(String, int, boolean, boolean, ContentModel, BitSet, BitSet, AttributeList) - 类 javax.swing.text.html.parser.DTD 中的方法
返回与指定参数匹配的 Element。
defineEntity(String, int, char[]) - 类 javax.swing.text.html.parser.DTD 中的方法
定义一个实体。
definePackage(String, String, String, String, String, String, String, URL) - 类 java.lang.ClassLoader 中的方法
根据 name 在此 ClassLoader 中定义包。
definePackage(String, Manifest, URL) - 类 java.net.URLClassLoader 中的方法
用该 ClassLoader 中的名称定义一个新包。
DefinitionKind - org.omg.CORBA 中的 类
该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。
DefinitionKind(int) - 类 org.omg.CORBA.DefinitionKind 的构造方法
构造一个 DefinitionKind 对象，使用给定值初始化其 _value 字段。
DefinitionKindHelper - org.omg.CORBA 中的 类
DefinitionKind 的 Helper。
DefinitionKindHelper() - 类 org.omg.CORBA.DefinitionKindHelper 的构造方法
deflate(byte[], int, int) - 类 java.util.zip.Deflater 中的方法
使用压缩数据填充指定缓冲区。
deflate(byte[]) - 类 java.util.zip.Deflater 中的方法
使用压缩数据填充指定缓冲区。
deflate() - 类 java.util.zip.DeflaterOutputStream 中的方法
将下一个压缩数据块写入输出流。
DEFLATE - 类 javax.print.attribute.standard.Compression 中的静态变量
ZIP 公共域 inflate/deflate 压缩技术。
DEFLATE_HINT - 接口 java.util.jar.Pack200.Packer 中的静态变量
如果将此属性设置为 Pack200.Packer.TRUE 或 Pack200.Packer.FALSE，则打包器将在输出存档中设置相应的压缩提示，并且不传输存档元素的单个压缩提示。
DEFLATE_HINT - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
此属性指示解包器应该忽略 DEFLATE_HINT 的所有已传输的值，并用给定值 Pack200.Unpacker.TRUE 或 Pack200.Unpacker.FALSE 替换它们。
DEFLATED - 类 java.util.zip.Deflater 中的静态变量
deflate 算法（当前支持的唯一算法）的压缩方法。
DEFLATED - 类 java.util.zip.ZipEntry 中的静态变量
用于已压缩 (deflated) 条目的压缩方法。
DEFLATED - 类 java.util.zip.ZipOutputStream 中的静态变量
用于已压缩 (DEFLATED) 条目的压缩方法。
Deflater - java.util.zip 中的 类
此类使用流行的 ZLIB 压缩程序库为通用压缩提供支持。
Deflater(int, boolean) - 类 java.util.zip.Deflater 的构造方法
使用指定压缩级别创建新的压缩器。
Deflater(int) - 类 java.util.zip.Deflater 的构造方法
使用指定压缩级别创建新的压缩器。
Deflater() - 类 java.util.zip.Deflater 的构造方法
使用默认压缩级别创建新的压缩器。
DeflaterInputStream - java.util.zip 中的 类
为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
DeflaterInputStream(InputStream) - 类 java.util.zip.DeflaterInputStream 的构造方法
创建一个带有默认压缩器和缓冲区大小的新输入流。
DeflaterInputStream(InputStream, Deflater) - 类 java.util.zip.DeflaterInputStream 的构造方法
创建一个带有指定压缩器和默认缓冲区大小的新输入流。
DeflaterInputStream(InputStream, Deflater, int) - 类 java.util.zip.DeflaterInputStream 的构造方法
创建一个带有指定压缩器和缓冲区大小的新输入流。
DeflaterOutputStream - java.util.zip 中的 类
此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
DeflaterOutputStream(OutputStream, Deflater, int) - 类 java.util.zip.DeflaterOutputStream 的构造方法
使用指定压缩器和缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream, Deflater) - 类 java.util.zip.DeflaterOutputStream 的构造方法
使用指定压缩器和默认缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream) - 类 java.util.zip.DeflaterOutputStream 的构造方法
使用默认压缩器和缓冲区大小创建一个新输出流。
deiconifyFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
从父窗体中移除 desktopIcon，并将其窗体添加到父窗体中。
deiconifyFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常移除现有的任何图标表示形式，并将窗体恢复到其原始大小和位置。
deiconifyFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要取消图标化窗体时调用此方法。
deiconize() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
deinstall(JTextComponent) - 接口 javax.swing.text.Caret 中的方法
在将 UI 从 JTextComponent 的接口中移除时调用。
deinstall(JTextComponent) - 类 javax.swing.text.DefaultCaret 中的方法
当 UI 从一个 JTextComponent 的接口移除时调用。
deinstall(JTextComponent) - 类 javax.swing.text.DefaultHighlighter 中的方法
从 JTextComponent 的接口移除 UI 时调用。
deinstall(JEditorPane) - 类 javax.swing.text.EditorKit 中的方法
从 JEditorPane 中移除工具包时调用。
deinstall(JTextComponent) - 接口 javax.swing.text.Highlighter 中的方法
将 UI 从 JTextComponent 的接口移除时调用。
deinstall(JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
工具包从 JEditorPane 移除时调用。
deinstall(JEditorPane) - 类 javax.swing.text.StyledEditorKit 中的方法
工具包从 JEditorPane 移除时调用。
deinstallMouseHandlers(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
delay(int) - 类 java.awt.Robot 中的方法
睡眠指定的时间。
Delayed - java.util.concurrent 中的 接口
一种混合风格的接口，用来标记那些应该在给定延迟时间之后执行的对象。
DelayQueue<E extends Delayed> - java.util.concurrent 中的 类
Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
DelayQueue() - 类 java.util.concurrent.DelayQueue 的构造方法
创建一个最初为空的新 DelayQueue。
DelayQueue(Collection<? extends E>) - 类 java.util.concurrent.DelayQueue 的构造方法
创建一个最初包含 Delayed 实例的给定 collection 元素的 DelayQueue。
delegate - 类 javax.swing.DefaultCellEditor 中的变量
处理从 CellEditor 发送的所有方法的委托类。
Delegate - org.omg.CORBA.portable 中的 类
为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。
Delegate() - 类 org.omg.CORBA.portable.Delegate 的构造方法
Delegate - org.omg.CORBA_2_3.portable 中的 类
Delegate 类提供 CORBA 对象特定于 ORB 供应商的实现。
Delegate() - 类 org.omg.CORBA_2_3.portable.Delegate 的构造方法
Delegate - org.omg.PortableServer.portable 中的 接口
可移植性包包含供 ORB 实现者使用的接口和类。
DELEGATE_NAME - 类 javax.management.MBeanServerDelegate 中的静态变量
定义 MBeanServerDelegate 的默认 ObjectName。
delegateFocus(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此为一种实用程序方法，用于帮助事件处理程序计算出在调出弹出控件时将焦点发送到的位置。
delegateFocus(MouseEvent) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup 中的方法
已过时。
DelegationPermission - javax.security.auth.kerberos 中的 类
此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
DelegationPermission(String) - 类 javax.security.auth.kerberos.DelegationPermission 的构造方法
创建带有指定从属主体和目标主体的新 DelegationPermission。
DelegationPermission(String, String) - 类 javax.security.auth.kerberos.DelegationPermission 的构造方法
创建带有指定从属主体和目标主体的新 DelegationPermission。
DELETE - 类 java.awt.Event 中的静态变量
Delete 键。
delete() - 类 java.io.File 中的方法
删除此抽象路径名表示的文件或目录。
delete(int, int) - 类 java.lang.StringBuffer 中的方法
delete(int, int) - 类 java.lang.StringBuilder 中的方法
delete(int, int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
删除两个索引之间的文本
DELETE - 接口 javax.accessibility.AccessibleTableModelChange 中的静态变量
标识行和/或列的删除。
DELETE - 类 javax.swing.event.TableModelEvent 中的静态变量
标识行或列的移除。
delete(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
删除两个索引之间的文本
delete(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
删除两个索引之间的文本
delete() - 接口 javax.tools.FileObject 中的方法
删除此文件对象。
delete() - 类 javax.tools.ForwardingFileObject 中的方法
delete() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现不执行任何操作。
DELETE_ROW_CONFLICT - 接口 javax.sql.rowset.spi.SyncResolver 中的静态变量
指示在 RowSet 对象试图删除数据源中的行时发生冲突。
delete_values(String) - 类 org.omg.CORBA.Context 中的方法
从此 Context 对象中删除 name 字段与给定属性名称匹配的 NamedValue 对象。
deleteChar(AttributedCharacterIterator, int) - 类 java.awt.font.LineBreakMeasurer 中的方法
从文本删除单个字符之后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
deleteChar(AttributedCharacterIterator, int) - 类 java.awt.font.TextMeasurer 中的方法
从当前由此 TextMeasurer 表示的段落中删除一个字符后，更新 TextMeasurer。
deleteCharAt(int) - 类 java.lang.StringBuffer 中的方法
deleteCharAt(int) - 类 java.lang.StringBuilder 中的方法
deleteData(int, int) - 接口 org.w3c.dom.CharacterData 中的方法
从该节点移除某个范围的 16 位单元。
deleteEntry(String) - 类 java.security.KeyStore 中的方法
删除此 keystore 中给定别名标识的条目。
deleteNextCharAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
删除当前插入符位置之后字符内容的动作名称。
deleteNextWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
删除选择开始位置之后单词的动作名称。
deleteObserver(Observer) - 类 java.util.Observable 中的方法
从对象的观察者集合中删除某个观察者。
deleteObservers() - 类 java.util.Observable 中的方法
清除观察者列表，使此对象不再有任何观察者。
deleteOnExit() - 类 java.io.File 中的方法
在虚拟机终止时，请求删除此抽象路径名表示的文件或目录。
deleteOwner(Principal, Principal) - 接口 java.security.acl.Owner 中的方法
删除一个所有者。
deletePrevCharAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
删除当前插入符位置之前字符内容的动作名称。
deletePrevWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
删除选择开始位置之前单词的动作名称。
deleteRow() - 接口 java.sql.ResultSet 中的方法
从此 ResultSet 对象和底层数据库中删除当前行。
deletesAreDetected(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以通过调用 ResultSet.rowDeleted 方法检测可见行的删除。
deleteShortcut(MenuShortcut) - 类 java.awt.MenuBar 中的方法
删除指定的菜单快捷方式。
deleteShortcut() - 类 java.awt.MenuItem 中的方法
删除与此菜单项关联的任何 MenuShortcut 对象。
deleteTrack(Track) - 类 javax.sound.midi.Sequence 中的方法
从 Sequence 中移除指定的轨道。
delimiter() - 类 java.util.Scanner 中的方法
返回此 Scanner 当前正在用于匹配分隔符的 Pattern。
delItem(int) - 类 java.awt.List 中的方法
已过时。 由 remove(String) 和 remove(int) 取代。
delItems(int, int) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，后来不再公开使用。只希望作为包私有方法时保留此方法。
deliverEvent(Event) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。
deliverEvent(Event) - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代
deltaTransform(Point2D, Point2D) - 类 java.awt.geom.AffineTransform 中的方法
变换由 ptSrc 指定的相对距离向量，并将结果存储在 ptDst 中。
deltaTransform(double[], int, double[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换相对距离向量数组。
Deprecated - java.lang 中的 注释类型
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
depth() - 类 javax.swing.text.ElementIterator 中的方法
获取元素树的当前深度。
depthFirstEnumeration() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回一个枚举，该枚举按深度优先的顺序遍历以此节点为根的子树。
depthOffset - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要正确计算 x 位置应该偏移的深度。
Deque<E> - java.util 中的 接口
一个线性 collection，支持在两端插入和移除元素。
dequeueKeyEvents(long, Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
释放正常指派到当前焦点所有者的所有 KeyEvent，这些 KeyEvent 因为调用了具有相同时间戳和 Component 的 enqueueKeyEvents 而被加入队列。
dequeueKeyEvents(long, Component) - 类 java.awt.KeyboardFocusManager 中的方法
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
dereference(XMLCryptoContext) - 接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod 中的方法
取消引用此 RetrievalMethod 引用的 KeyInfo 信息，并应用指定的 Transform。
dereference(URIReference, XMLCryptoContext) - 接口 javax.xml.crypto.URIDereferencer 中的方法
取消引用指定 URIReference 并返回已取消引用的数据。
deregister(AbstractSelectionKey) - 类 java.nio.channels.spi.AbstractSelector 中的方法
从其通道的键集中移除给定的键。
deregisterAll(Class<?>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
注销给定类别下当前注册的所有服务提供者对象。
deregisterAll() - 类 javax.imageio.spi.ServiceRegistry 中的方法
从所有类别注销所有当前注册的服务提供者。
deregisterDriver(Driver) - 类 java.sql.DriverManager 中的静态方法
从 DriverManager 的列表中删除一个驱动程序。
deregisterServiceProvider(T, Class<T>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
从给定的类别中移除服务提供者对象。
deregisterServiceProvider(Object) - 类 javax.imageio.spi.ServiceRegistry 中的方法
从包含它的所有类别中移除服务提供者对象。
DERIVATION_EXTENSION - 接口 org.w3c.dom.TypeInfo 中的静态变量
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示由 extension 派生出的。
DERIVATION_LIST - 接口 org.w3c.dom.TypeInfo 中的静态变量
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示 列表。
DERIVATION_RESTRICTION - 接口 org.w3c.dom.TypeInfo 中的静态变量
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示通过 restriction 进行的派生（如果涉及复杂的类型）或 restriction（如果涉及简单的类型）。
DERIVATION_UNION - 接口 org.w3c.dom.TypeInfo 中的静态变量
如果文档的模式为 XML Schema [XML Schema Part 1]，则此常量表示 union（如果涉及简单类型）。
derive(int) - 类 java.awt.AlphaComposite 中的方法
返回一个类似的 AlphaComposite 对象，该对象使用指定的复合规则。
derive(float) - 类 java.awt.AlphaComposite 中的方法
返回一个类似的 AlphaComposite 对象，该对象使用指定的 alpha 值。
deriveFont(int, float) - 类 java.awt.Font 中的方法
通过复制此 Font 对象并应用新样式和大小，创建一个新 Font 对象。
deriveFont(int, AffineTransform) - 类 java.awt.Font 中的方法
通过复制此 Font 对象并应用新样式和变换，创建一个新 Font 对象。
deriveFont(float) - 类 java.awt.Font 中的方法
通过复制当前 Font 对象并应用新的大小，创建一个新 Font 对象。
deriveFont(AffineTransform) - 类 java.awt.Font 中的方法
通过复制当前 Font 对象并应用新的变换，创建一个新 Font 对象。
deriveFont(int) - 类 java.awt.Font 中的方法
通过复制当前的 Font 对象，并应用新的样式，创建一个新 Font 对象。
deriveFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - 类 java.awt.Font 中的方法
通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
deriveMMFont(float[]) - 接口 java.awt.font.MultipleMaster 中的方法
根据指定数组中包含的设计轴值，创建 multiple master 字体的新实例。
deriveMMFont(float[], float, float, float, float) - 接口 java.awt.font.MultipleMaster 中的方法
根据详细的规格信息，创建 multiple master 字体的新实例。
DES_EDE_KEY_LEN - 类 javax.crypto.spec.DESedeKeySpec 中的静态变量
定义以 byte 为单位的 DESede 密钥长度的常量。
DES_KEY_LEN - 类 javax.crypto.spec.DESKeySpec 中的静态变量
定义以字节为单位的 DES 密钥长度的常量。
descendingIterator() - 类 java.util.ArrayDeque 中的方法
descendingIterator() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回在此 set 的元素上以降序进行迭代的迭代器。
descendingIterator() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回在此双端队列的元素上以逆向连续顺序进行迭代的迭代器。
descendingIterator() - 接口 java.util.Deque 中的方法
返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。
descendingIterator() - 类 java.util.LinkedList 中的方法
descendingIterator() - 接口 java.util.NavigableSet 中的方法
以降序返回在此 set 的元素上进行迭代的迭代器。
descendingIterator() - 类 java.util.TreeSet 中的方法
返回在此 set 元素上按降序进行迭代的迭代器。
descendingKeySet() - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
返回此映射中所包含键的逆序 NavigableSet 视图。
descendingKeySet() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
descendingKeySet() - 接口 java.util.NavigableMap 中的方法
返回此映射中所包含键的逆序 NavigableSet 视图。
descendingKeySet() - 类 java.util.TreeMap 中的方法
descendingMap() - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
返回此映射中所包含映射关系的逆序视图。
descendingMap() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
descendingMap() - 接口 java.util.NavigableMap 中的方法
返回此映射中所包含映射关系的逆序视图。
descendingMap() - 类 java.util.TreeMap 中的方法
descendingSet() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回此 set 中所包含元素的逆序视图。
descendingSet() - 接口 java.util.NavigableSet 中的方法
返回此 set 中所包含元素的逆序视图。
descendingSet() - 类 java.util.TreeSet 中的方法
description - 类 java.sql.DriverPropertyInfo 中的变量
属性的简要描述，可能为 null。
description - 类 javax.management.MBeanFeatureInfo 中的变量
该功能的可读描述。
Descriptor - javax.management 中的 接口
JMX 元素的附加元数据。
DescriptorAccess - javax.management 中的 接口
此接口用于获得对 Descriptor 类的描述符的访问，这些 Descriptor 类与某个 JMX 组件相关联，比如 MBean、MBeanInfo、MBeanAttributeInfo、MBeanNotificationInfo、MBeanOperationInfo 和 MBeanParameterInfo。
DescriptorKey - javax.management 中的 注释类型
描述注释元素与 Descriptor 中字段之间关联方式的元注释。
DescriptorRead - javax.management 中的 接口
读取管理接口元素（如 MBeanInfo）的 Descriptor 的接口。
DescriptorSupport - javax.management.modelmbean 中的 类
此类表示 ModelMBean 元素的元数据集。
DescriptorSupport() - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
描述符默认的构造方法。
DescriptorSupport(int) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
描述符构造方法。
DescriptorSupport(DescriptorSupport) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
采用 Descriptor 作为参数的描述符构造方法。
DescriptorSupport(String) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
Descriptor 构造方法带有一个 XML String。
DescriptorSupport(String[], Object[]) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
带有字段名称和字段值的构造方法。
DescriptorSupport(String...) - 类 javax.management.modelmbean.DescriptorSupport 的构造方法
带有 fieldName=fieldValue 格式的字段的构造方法。
DESedeKeySpec - javax.crypto.spec 中的 类
此类指定一个 DES-EDE ("triple-DES") 密钥。
DESedeKeySpec(byte[]) - 类 javax.crypto.spec.DESedeKeySpec 的构造方法
创建一个 DESedeKeySpec 对象，使用 key 中的前 24 个字节作为 DES-EDE 密钥的密钥内容。
DESedeKeySpec(byte[], int) - 类 javax.crypto.spec.DESedeKeySpec 的构造方法
创建一个 DESedeKeySpec 对象，使用 key 中始于且包含 offset 的前 24 个字节作为 DES-EDE 密钥的密钥内容。
deselect(int) - 类 java.awt.List 中的方法
取消选择指定索引处的项。
DESELECTED - 类 java.awt.event.ItemEvent 中的静态变量
此状态更改值指示已选定的项被取消选定。
DESERET - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Deseret”Unicode 字符块的常量。
deserialize(ObjectInputStream, Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
readObject 使用此方法来反序列化一个 collection。
deserialize(ObjectName, byte[]) - 接口 javax.management.MBeanServer 中的方法
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
deserialize(String, byte[]) - 接口 javax.management.MBeanServer 中的方法
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
deserialize(String, ObjectName, byte[]) - 接口 javax.management.MBeanServer 中的方法
已过时。 使用 getClassLoader 为反序列化获得类加载器。
DESIGNATED_LONG - 类 javax.print.attribute.standard.MediaSize.ISO 中的静态变量
指定 ISO Designated Long 尺寸，110 mm × 220 mm。
DesignMode - java.beans 中的 接口
此接口由 java.beans.beancontext.BeanContext 的实例实现或委托，以便将当前的 "designTime" 属性传播到 java.beans.beancontext.BeanContextChild 实例的嵌套层次结构。
designTime - 类 java.beans.beancontext.BeanContextSupport 中的变量
指示此对象目前是否处于设计时间模式下的 boolean 值。
desiredAssertionStatus() - 类 java.lang.Class 中的方法
如果要在调用此方法时将要初始化该类，则返回将分配给该类的断言状态。
DESKeySpec - javax.crypto.spec 中的 类
此类指定一个 DES 密钥。
DESKeySpec(byte[]) - 类 javax.crypto.spec.DESKeySpec 的构造方法
创建一个 DESKeySpec 对象，使用 key 中的前 8 个字节作为 DES 密钥的密钥内容。
DESKeySpec(byte[], int) - 类 javax.crypto.spec.DESKeySpec 的构造方法
创建一个 DESKeySpec 对象，使用 key 中始于且包含 offset 的前 8 个字节作为 DES-EDE 密钥的密钥内容。
Desktop - java.awt 中的 类
Desktop 类允许 Java 应用程序启动已在本机桌面上注册的关联应用程序，以处理 URI 或文件。
DESKTOP - 类 java.awt.SystemColor 中的静态变量
SystemColor.desktop 系统颜色的数组索引。
desktop - 类 java.awt.SystemColor 中的静态变量
为桌面背景提供的颜色。
desktop - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
Desktop.Action - java.awt 中的 枚举
表示动作类型。
DESKTOP_ICON - 类 javax.accessibility.AccessibleRole 中的静态变量
DESKTOP_PANE 中的图标化的内部 frame。
DESKTOP_ICON - 类 javax.swing.plaf.synth.Region 中的静态变量
DesktopIcon 的 region。
DESKTOP_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
支持内部窗体和这些内部窗体的图标化形式的窗格。
DESKTOP_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
DesktopPane 的 region。
desktopIcon - 类 javax.swing.JInternalFrame 中的变量
此内部窗体图标化时所显示的图标。
desktopIcon - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的变量
DesktopIconUI - javax.swing.plaf 中的 类
JDesktopIcon 的可插入外观界面。
DesktopIconUI() - 类 javax.swing.plaf.DesktopIconUI 的构造方法
DesktopManager - javax.swing 中的 接口
DesktopManager 对象由 DesktopPane 对象所拥有。
desktopManager - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
DesktopPaneUI - javax.swing.plaf 中的 类
JDesktopPane 的可插入外观界面。
DesktopPaneUI() - 类 javax.swing.plaf.DesktopPaneUI 的构造方法
desktopProperties - 类 java.awt.Toolkit 中的变量
desktopPropsSupport - 类 java.awt.Toolkit 中的变量
destHeight - 类 java.awt.image.ReplicateScaleFilter 中的变量
缩放图像的目标高度。
destination - 类 javax.imageio.ImageReadParam 中的变量
当前目标 BufferedImage；如果没有设置目标图像，则为 null。
Destination - javax.print.attribute.standard 中的 类
Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
Destination(URI) - 类 javax.print.attribute.standard.Destination 的构造方法
构造具有给定 URI 的新目标属性。
destination - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的变量
接收所有事件的目的地。
destinationBands - 类 javax.imageio.ImageReadParam 中的变量
要使用的目标 band 集合（int 数组的形式）。
destinationOffset - 类 javax.imageio.IIOParam 中的变量
目标区域中的偏移量，应将左上部解码像素置于此处。
destinationType - 类 javax.imageio.IIOParam 中的变量
一个 ImageTypeSpecifier，用来在进行读取操作时生成目标图像，或者在进行写入操作时设置输出颜色类型。
destroy() - 类 java.applet.Applet 中的方法
由浏览器或 applet viewer 调用，通知此 applet 它正在被回收，它应该销毁分配给它的任何资源。
destroy() - 类 java.lang.Process 中的方法
杀掉子进程。
destroy() - 类 java.lang.Thread 中的方法
已过时。 该方法最初用于破坏该线程，但不作任何清除。它所保持的任何监视器都会保持锁定状态。不过，该方法决不会被实现。即使要实现，它也极有可能以 Thread.suspend() 方式被死锁。如果目标线程被破坏时保持一个保护关键系统资源的锁，则任何线程在任何时候都无法再次访问该资源。如果另一个线程曾试图锁定该资源，则会出现死锁。这类死锁通常会证明它们自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
destroy() - 类 java.lang.ThreadGroup 中的方法
销毁此线程组及其所有子组。
destroy() - 类 java.security.KeyStore.PasswordProtection 中的方法
清除密码。
destroy() - 接口 javax.security.auth.Destroyable 中的方法
销毁此 Object。
destroy() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
销毁此密钥。
destroy() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
销毁票据和存储在其中的敏感信息。
destroy() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
清除对此对象中的 X.509 证书、私钥和 KeyStore 别名的引用。
destroy() - 类 org.omg.CORBA._IDLTypeStub 中的方法
destroy() - 类 org.omg.CORBA._PolicyStub 中的方法
销毁策略对象。
destroy() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 销毁此 DynAny 对象，释放用来表示与之关联的数据值的所有资源。
destroy() - 接口 org.omg.CORBA.IRObjectOperations 中的方法
销毁此对象。
destroy() - 类 org.omg.CORBA.ORB 中的方法
销毁 ORB，以便可以回收其资源。
destroy() - 接口 org.omg.CORBA.PolicyOperations 中的方法
销毁 Policy 对象。
destroy() - 类 org.omg.CosNaming._BindingIteratorStub 中的方法
此操作销毁迭代器。
destroy() - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
destroy 操作删除命名上下文。
destroy() - 类 org.omg.CosNaming._NamingContextStub 中的方法
destroy 操作删除命名上下文。
destroy() - 接口 org.omg.CosNaming.BindingIteratorOperations 中的方法
此操作销毁迭代器。
destroy() - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
destroy 操作删除命名上下文。
destroy() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynStructStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
销毁 DynAny 对象。
destroy() - 类 org.omg.DynamicAny._DynValueStub 中的方法
销毁 DynAny 对象。
destroy() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
销毁 DynAny 对象。
destroy() - 接口 org.omg.PortableInterceptor.InterceptorOperations 中的方法
提供销毁此 interceptor 的机会。
destroy(boolean, boolean) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作销毁 POA 及所有子代 POA。
Destroyable - javax.security.auth 中的 接口
诸如 credentials 之类的对象可以选择实现此接口以便提供销毁它的内容的功能。
destroyBuffers() - 类 java.awt.Component.FlipBufferStrategy 中的方法
销毁通过此对象所创建的缓冲区。
DestroyFailedException - javax.security.auth 中的 异常
当 destroy 操作失败时，抛出此异常。
DestroyFailedException() - 异常 javax.security.auth.DestroyFailedException 的构造方法
构造不带详细消息的 DestroyFailedException。
DestroyFailedException(String) - 异常 javax.security.auth.DestroyFailedException 的构造方法
构造带指定详细消息的 DestroyFailedException。
destroySubcontext(Name) - 接口 javax.naming.Context 中的方法
销毁指定上下文，并将它从名称空间中移除。
destroySubcontext(String) - 接口 javax.naming.Context 中的方法
销毁指定上下文，并将它从名称空间中移除。
destroySubcontext(String) - 类 javax.naming.InitialContext 中的方法
destroySubcontext(Name) - 类 javax.naming.InitialContext 中的方法
destWidth - 类 java.awt.image.ReplicateScaleFilter 中的变量
缩放图像的目标宽度。
detachNode() - 接口 javax.xml.soap.Node 中的方法
从树中移除此 Node 对象。
detail - 异常 java.io.WriteAbortedException 中的变量
在写入 ObjectStream 时捕获的异常。
detail - 异常 java.rmi.activation.ActivationException 中的变量
激活异常的原因。
detail - 异常 java.rmi.RemoteException 中的变量
远程异常的原因。
detail - 异常 java.rmi.server.ServerCloneException 中的变量
异常原因。
Detail - javax.xml.soap 中的 接口
DetailEntry 对象的容器。
DetailEntry - javax.xml.soap 中的 接口
Detail 对象的内容，给出 SOAPFault 对象的详细信息。
detailsViewIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
detectedCharset() - 类 java.nio.charset.CharsetDecoder 中的方法
获取此解码器检测到的 charset（可选操作）。
determineOffset(JTree, Object, boolean, boolean, boolean, int) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
DEVANAGARI - 类 java.awt.font.NumericShaper 中的静态变量
标识 DEVANAGARI 范围和十进制基数。
DEVANAGARI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Devanagari”Unicode 字符块的常量。
DEVELOPER_EMPTY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备显影剂已用完。
DEVELOPER_LOW - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备显影剂不足。
DFN - 类 javax.swing.text.html.HTML.Tag 中的静态变量
DGC - java.rmi.dgc 中的 接口
DGC 抽象用于分布式垃圾回收算法的服务器端。
DGC_ID - 类 java.rmi.server.ObjID 中的静态变量
分布式垃圾回收器的已知 ObjID 的对象数。
DHGenParameterSpec - javax.crypto.spec 中的 类
此类指定用于生成在 Diffie-Hellman 密钥协议中使用的 Diffie-Hellman（系统）参数的参数集合。
DHGenParameterSpec(int, int) - 类 javax.crypto.spec.DHGenParameterSpec 的构造方法
为生成 Diffie-Hellman（系统）参数构造一个参数集。
DHKey - javax.crypto.interfaces 中的 接口
Diffie-Hellman 密钥的接口。
DHParameterSpec - javax.crypto.spec 中的 类
此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。
DHParameterSpec(BigInteger, BigInteger) - 类 javax.crypto.spec.DHParameterSpec 的构造方法
使用质数模数 p 和基生成器 g 为 Diffie-Hellman 构造一个参数集。
DHParameterSpec(BigInteger, BigInteger, int) - 类 javax.crypto.spec.DHParameterSpec 的构造方法
使用质数模数 p、基生成器 g 以及以位为单位的随机指数大小 l（私有值）为 Diffie-Hellman 构造一个参数集。
DHPrivateKey - javax.crypto.interfaces 中的 接口
Diffie-Hellman 私钥接口。
DHPrivateKeySpec - javax.crypto.spec 中的 类
此类使用其关联的参数指定一个 Diffie-Hellman 私钥。
DHPrivateKeySpec(BigInteger, BigInteger, BigInteger) - 类 javax.crypto.spec.DHPrivateKeySpec 的构造方法
带有一个私有值 x、一个质数模数 p 以及一个基生成器 g 的构造方法。
DHPublicKey - javax.crypto.interfaces 中的 接口
Diffie-Hellman 公钥接口。
DHPublicKeySpec - javax.crypto.spec 中的 类
此类使用关联的参数指定一个 Diffie-Hellman 公钥。
DHPublicKeySpec(BigInteger, BigInteger, BigInteger) - 类 javax.crypto.spec.DHPublicKeySpec 的构造方法
带有一个公有值 y、一个质数模数 p 以及一个基生成器 g 的构造方法。
Diagnostic<S> - javax.tools 中的 接口
用于来自工具的诊断的接口。
Diagnostic.Kind - javax.tools 中的 枚举
诊断的种类，例如，错误或者警告。
DiagnosticCollector<S> - javax.tools 中的 类
提供将诊断收集到一个列表中的简单方法。
DiagnosticCollector() - 类 javax.tools.DiagnosticCollector 的构造方法
DiagnosticListener<S> - javax.tools 中的 接口
用于接收来自工具的诊断的接口。
Dialog - java.awt 中的 类
Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
Dialog(Frame) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Frame 和一个空标题。
Dialog(Frame, boolean) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定所有者 Frame、模式和一个空标题。
Dialog(Frame, String) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Frame 和标题。
Dialog(Frame, String, boolean) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题和模式。
Dialog(Frame, String, boolean, GraphicsConfiguration) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。
Dialog(Dialog) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Dialog 和一个空标题。
Dialog(Dialog, String) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Dialog 和标题。
Dialog(Dialog, String, boolean) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题和模式。
Dialog(Dialog, String, boolean, GraphicsConfiguration) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。
Dialog(Window) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Window 和一个空标题。
Dialog(Window, String) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Window 和标题。
Dialog(Window, Dialog.ModalityType) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定所有者 Window、模式和一个空标题。
Dialog(Window, String, Dialog.ModalityType) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。
Dialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - 类 java.awt.Dialog 的构造方法
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。
DIALOG - 类 java.awt.Font 中的静态变量
逻辑字体 "Dialog" 的规范系列名称的 String 常量。
DIALOG - 类 javax.accessibility.AccessibleRole 中的静态变量
带有标题栏和边框的顶层窗口。
Dialog.AccessibleAWTDialog - java.awt 中的 类
此类实现对 Dialog 类的可访问性支持。
Dialog.AccessibleAWTDialog() - 类 java.awt.Dialog.AccessibleAWTDialog 的构造方法
Dialog.ModalExclusionType - java.awt 中的 枚举
任何顶层窗口都可以标记为不受模式对话框阻塞。
Dialog.ModalityType - java.awt 中的 枚举
模式对话框阻塞对某些顶层窗口的所有输入。
DIALOG_INPUT - 类 java.awt.Font 中的静态变量
逻辑字体 "DialogInput" 的规范系列名称的 String 常量。
DIALOG_TITLE_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识对话框标题的更改。
DIALOG_TYPE_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识显示文件类型的更改（仅显示文件、仅显示目录或显示文件和目录）。
DIALOG_UI - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个作为 AWT 对话框实现的 UI。
dialogInit() - 类 javax.swing.JDialog 中的方法
构造方法调用此方法来正确初始化 JDialog。
Dictionary<K,V> - java.util 中的 类
Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。
Dictionary() - 类 java.util.Dictionary 的构造方法
单独的构造方法。
die() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
将 alive 设置为 false。
die() - 类 javax.swing.undo.CompoundEdit 中的方法
按添加时相反的顺序将 die 发送到每个子编辑。
die() - 接口 javax.swing.undo.UndoableEdit 中的方法
通知某个编辑不应再使用它。
digest - 类 java.security.DigestInputStream 中的变量
与此流关联的消息摘要。
digest - 类 java.security.DigestOutputStream 中的变量
与此流关联的消息摘要。
digest() - 类 java.security.MessageDigest 中的方法
通过执行诸如填充之类的最终操作完成哈希计算。
digest(byte[], int, int) - 类 java.security.MessageDigest 中的方法
通过执行诸如填充之类的最终操作完成哈希计算。
digest(byte[]) - 类 java.security.MessageDigest 中的方法
使用指定的 byte 数组对摘要进行最后更新，然后完成摘要计算。
DigestException - java.security 中的 异常
此为一般 Message Digest 异常。
DigestException() - 异常 java.security.DigestException 的构造方法
构造不带详细消息的 DigestException。
DigestException(String) - 异常 java.security.DigestException 的构造方法
构造带指定详细消息的 DigestException。
DigestException(String, Throwable) - 异常 java.security.DigestException 的构造方法
创建带指定详细消息和 cause 的 DigestException。
DigestException(Throwable) - 异常 java.security.DigestException 的构造方法
创建带指定 cause 和详细消息 DigestException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
DigestInputStream - java.security 中的 类
使用通过流的位更新关联消息摘要的透明流。
DigestInputStream(InputStream, MessageDigest) - 类 java.security.DigestInputStream 的构造方法
使用指定的输入流和消息摘要创建一个摘要输入流。
DigestMethod - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML DigestMethod 元素的表示形式。
DigestMethodParameterSpec - javax.xml.crypto.dsig.spec 中的 接口
用于 DigestMethod 算法的算法参数的规范。
DigestOutputStream - java.security 中的 类
使用通过流的位更新关联消息摘要的透明流。
DigestOutputStream(OutputStream, MessageDigest) - 类 java.security.DigestOutputStream 的构造方法
使用指定的输出流和消息摘要创建一个摘要输出流。
digit(char, int) - 类 java.lang.Character 中的静态方法
返回使用指定基数的字符 ch 的数值。
digit(int, int) - 类 java.lang.Character 中的静态方法
返回使用指定基数的指定字符（Unicode 代码点）的数值。
Dimension - java.awt 中的 类
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Dimension() - 类 java.awt.Dimension 的构造方法
创建 Dimension 的一个实例（宽度为零，高度为零）。
Dimension(Dimension) - 类 java.awt.Dimension 的构造方法
创建 Dimension 的一个实例（宽度和高度与指定的 dimension 相同）。
Dimension(int, int) - 类 java.awt.Dimension 的构造方法
构造一个 Dimension，并将其初始化为指定宽度和高度。
Dimension2D - java.awt.geom 中的 类
Dimension2D 类用于封装宽度和高度尺寸。
Dimension2D() - 类 java.awt.geom.Dimension2D 的构造方法
这是一个不可直接实例化的抽象类。
DimensionUIResource - javax.swing.plaf 中的 类
DimensionUIResource(int, int) - 类 javax.swing.plaf.DimensionUIResource 的构造方法
DINGBATS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Dingbats”Unicode 字符块的常量。
DIR - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
DIR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
DirContext - javax.naming.directory 中的 接口
目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。
DirectColorModel - java.awt.image 中的 类
DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。
DirectColorModel(int, int, int, int) - 类 java.awt.image.DirectColorModel 的构造方法
根据指定的指示 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本的掩码构造 DirectColorModel。
DirectColorModel(int, int, int, int, int) - 类 java.awt.image.DirectColorModel 的构造方法
根据指定的指示在 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本与 alpha 样本（如果存在）的掩码构造 DirectColorModel。
DirectColorModel(ColorSpace, int, int, int, int, int, boolean, int) - 类 java.awt.image.DirectColorModel 的构造方法
根据指定参数构造 DirectColorModel。
direction - 类 javax.swing.plaf.basic.BasicArrowButton 中的变量
箭头的方向。
direction - 类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 中的变量
direction - 类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 中的变量
指定用于调整选择的方向。
direction - 类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 中的变量
指定用于调整选择的方向。
direction - 类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 中的变量
确定要遍历的方向，1 意味着展开，-1 意味着折叠。
DIRECTION_DEFAULT_LEFT_TO_RIGHT - 类 java.text.Bidi 中的静态变量
表示基本方向依赖于根据 Unicode 双向算法得到的文本中第一个强方向字符的常量。
DIRECTION_DEFAULT_RIGHT_TO_LEFT - 类 java.text.Bidi 中的静态变量
表示基本方向依赖于根据 Unicode 双向算法得到的文本中第一个强方向字符的常量。
DIRECTION_LEFT_TO_RIGHT - 类 java.text.Bidi 中的静态变量
表示基本方向是从左到右的常量。
DIRECTION_RIGHT_TO_LEFT - 类 java.text.Bidi 中的静态变量
表示基本方向是从右到左的常量。
DIRECTIONALITY_ARABIC_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“AN”。
DIRECTIONALITY_BOUNDARY_NEUTRAL - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“BN”。
DIRECTIONALITY_COMMON_NUMBER_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“CS”。
DIRECTIONALITY_EUROPEAN_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“EN”。
DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“ES”。
DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“ET”。
DIRECTIONALITY_LEFT_TO_RIGHT - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“L”。
DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“LRE”。
DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“LRO”。
DIRECTIONALITY_NONSPACING_MARK - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“NSM”。
DIRECTIONALITY_OTHER_NEUTRALS - 类 java.lang.Character 中的静态变量
Unicode 规范中的非特定双向字符类型“ON”。
DIRECTIONALITY_PARAGRAPH_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的非特定双向字符类型“B”。
DIRECTIONALITY_POP_DIRECTIONAL_FORMAT - 类 java.lang.Character 中的静态变量
Unicode 规范中的弱双向字符类型“PDF”。
DIRECTIONALITY_RIGHT_TO_LEFT - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“R”。
DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“AL”。
DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“RLE”。
DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE - 类 java.lang.Character 中的静态变量
Unicode 规范中的强双向字符类型“RLO”。
DIRECTIONALITY_SEGMENT_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的非特定双向字符类型“S”。
DIRECTIONALITY_UNDEFINED - 类 java.lang.Character 中的静态变量
未定义的双向字符类型。
DIRECTIONALITY_WHITESPACE - 类 java.lang.Character 中的静态变量
Unicode 规范中的非特定双向字符类型“WS”。
DIRECTORIES_ONLY - 类 javax.swing.JFileChooser 中的静态变量
指示仅显示目录。
directory() - 类 java.lang.ProcessBuilder 中的方法
返回此进程生成器的工作目录。
directory(File) - 类 java.lang.ProcessBuilder 中的方法
设置此进程生成器的工作目录。
DIRECTORY_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用户的目录更改。
DIRECTORY_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
允许用户在目录内容中导航并进行选择的窗格。
directoryIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
DirectoryManager - javax.naming.spi 中的 类
此类包含支持 DirContext 实现的方法。
directoryOpenButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
选择了目录且当前选择模式是 FILES_ONLY 时用于确认按钮的助记符键代码。
directoryOpenButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的标签文本。
directoryOpenButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的工具提示文本。
directSupertypes(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回类型的直接超类型。
DirObjectFactory - javax.naming.spi 中的 接口
此接口表示一个工厂，该工厂用来在给定某一对象以及有关该对象的属性的情况下创建该对象。
DirStateFactory - javax.naming.spi 中的 接口
此接口表示一个工厂，该工厂用来获得对象的状态和用于绑定的相应属性。
DirStateFactory.Result - javax.naming.spi 中的 类
用于返回 DirStateFactory.getStateToBind() 的结果的对象/属性对。
DirStateFactory.Result(Object, Attributes) - 类 javax.naming.spi.DirStateFactory.Result 的构造方法
构造一个 Result 实例。
dirty(ObjID[], long, Lease) - 接口 java.rmi.dgc.DGC 中的方法
脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。
disable() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
disable() - 类 java.awt.MenuItem 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
disable() - 类 java.lang.Compiler 中的静态方法
使编译器停止操作。
disable() - 类 javax.swing.JComponent 中的方法
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
disableAllAttributes() - 类 javax.management.AttributeChangeNotificationFilter 中的方法
禁用所有属性名称。
disableAllObjectNames() - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
禁用任何 MBeanServerNotification（取消选中所有的 ObjectName）。
disableAllTypes() - 类 javax.management.NotificationFilterSupport 中的方法
禁止所有通知类型。
disableAttribute(String) - 类 javax.management.AttributeChangeNotificationFilter 中的方法
禁用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定属性名称。
DISABLED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 未被启用的基本状态。
DISABLED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识禁用按钮时使用的图标的更改。
DISABLED_SELECTED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识禁用并选定按钮时使用的图标的更改。
disabledForeground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
disabledTextColor - 类 javax.swing.plaf.metal.MetalButtonUI 中的变量
disabledTextColor - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的变量
disabledTextColor - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的变量
disableEvents(long) - 类 java.awt.Component 中的方法
禁用由传递给此组件的指定事件掩码参数所定义的事件。
disableEvents(long) - 类 java.awt.MenuItem 中的方法
禁止将事件提交到将由指定事件掩码参数定义的事件的菜单项。
disableObjectName(ObjectName) - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
禁用与给定 ObjectName 有关的 MBeanServerNotification。
disableResizedPosting() - 类 javax.swing.table.TableColumn 中的方法
已过时。 从 Java 2 platform v1.3 开始
disableSwingFocusManager() - 类 javax.swing.FocusManager 中的静态方法
已过时。 从 1.4 开始，由 KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy) 取代
disableType(String) - 类 javax.management.NotificationFilterSupport 中的方法
从前缀列表中移除给定的前缀。
discard_requests(boolean) - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作将 POA 管理器的状态更改为丢弃 (discarding)。
discardAllEdits() - 类 javax.swing.undo.UndoManager 中的方法
清空撤消管理器，向进程中的每个编辑发送一个 die 消息。
DISCARDING - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/DISCARDING.java。
DISCARDING - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
discardKeyEvents(Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
放弃因为一次或多次调用具有指定 Component 或其子代之一的 enqueueKeyEvents 而加入队列的所有 KeyEvent。
discardKeyEvents(Component) - 类 java.awt.KeyboardFocusManager 中的方法
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
disconnect() - 类 java.net.DatagramSocket 中的方法
断开套接字的连接。
disconnect() - 类 java.net.DatagramSocketImpl 中的方法
断开数据报套接字和远程目标的连接。
disconnect() - 类 java.net.HttpURLConnection 中的方法
指示近期服务器不太可能有其他请求。
disconnect() - 类 java.nio.channels.DatagramChannel 中的方法
断开此通道套接字的连接。
disconnect(Object) - 类 org.omg.CORBA.ORB 中的方法
断开给定 servant 对象与 ORB 的连接。
DISCONTIGUOUS_TREE_SELECTION - 接口 javax.swing.tree.TreeSelectionModel 中的静态变量
选择可以包含任何数量的项，这些项不必是连续的。
discriminator() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 返回一个 DynAny 对象引用，为了插入/获取鉴别符值，必须将该对象收缩为该鉴别符的类型。
discriminator_kind() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 返回与此 union 的鉴别符关联的 TCKind 对象。
discriminator_kind() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回鉴别符 TypeCode 的 TCKind 值。
discriminator_kind() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回鉴别符 TypeCode 的 TCKind 值。
discriminator_type() - 类 org.omg.CORBA.TypeCode 中的方法
返回描述所有非默认成员标签的 TypeCode 对象。
disjoint(Collection<?>, Collection<?>) - 类 java.util.Collections 中的静态方法
如果两个指定 collection 中没有相同的元素，则返回 true。
dismiss(JSpinner) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
将此编辑器从指定的 JSpinner 断开连接。
dispatch() - 接口 java.awt.ActiveEvent 中的方法
将事件指派给目标、事件源侦听器，或者做任何希望此事件去做的事情。
dispatch() - 类 java.awt.event.InvocationEvent 中的方法
执行 Runnable 的 run() 方法并在 run() 返回时通知 notifier（如果有）。
dispatch(Remote, RemoteCall, int, long) - 接口 java.rmi.server.Skeleton 中的方法
已过时。 无替代版本
dispatch(NamingListener) - 类 javax.naming.event.NamingEvent 中的方法
对此事件调用适当的侦听器方法。
dispatch(NamingListener) - 类 javax.naming.event.NamingExceptionEvent 中的方法
使用此事件对侦听器调用 namingExceptionThrown() 方法。
dispatch(UnsolicitedNotificationListener) - 类 javax.naming.ldap.UnsolicitedNotificationEvent 中的方法
使用此事件对侦听器调用 notificationReceived() 方法。
Dispatch<T> - javax.xml.ws 中的 接口
Dispatch 接口提供对动态调用服务端点操作的支持。
dispatchEvent(AWTEvent) - 类 java.awt.Component 中的方法
为组件或其子组件之一指派事件。
dispatchEvent(AWTEvent) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
此方法由 AWT 事件调度程序调用，该调度程序请求当前的 KeyboardFocusManager 以它的名义指派指定的事件。
dispatchEvent(AWTEvent) - 类 java.awt.EventQueue 中的方法
指派一个事件。
dispatchEvent(AWTEvent) - 类 java.awt.im.InputContext 中的方法
将事件指派到处于活动状态的输入方法。
dispatchEvent(AWTEvent) - 接口 java.awt.im.spi.InputMethod 中的方法
将事件指派到输入方法。
dispatchEvent(AWTEvent) - 类 java.awt.KeyboardFocusManager 中的方法
AWT 事件调度程序可以调用此方法，请求当前的 KeyboardFocusManager 为其指派指定的事件。
dispatchEvent(AWTEvent) - 类 java.awt.MenuComponent 中的方法
将事件传递给此组件或其子组件之一。
dispatchEvent(Event) - 接口 org.w3c.dom.events.EventTarget 中的方法
此方法允许将事件指派到实现事件模型。
dispatchInputMethodEvent(int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - 接口 java.awt.im.spi.InputMethodContext 中的方法
根据给定的参数创建输入方法事件并将其指派到客户端组件。
dispatchKeyEvent(KeyEvent) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
如果调度程序链中其他 KeyEventDispatcher 都没有调度 KeyEvent，或者没有注册其他 KeyEventDispatcher，则由 dispatchEvent 调用此方法。
dispatchKeyEvent(KeyEvent) - 类 java.awt.KeyboardFocusManager 中的方法
通常情况下，如果该指派程序链中的其他 KeyEventDispatcher 没有指派 KeyEvent 或者没有注册其他 KeyEventDispatcher，则 dispatchEvent 将调用此方法。
dispatchKeyEvent(KeyEvent) - 接口 java.awt.KeyEventDispatcher 中的方法
当前 KeyboardFocusManager 调用此方法，请求此 KeyEventDispatcher 为其指派指定的事件。
DISPLAY - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
DISPLAYABILITY_CHANGED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示 HIERARCHY_CHANGED 事件是因为层次结构的可显示性发生更改而生成的。
DISPLAYED_MNEMONIC_INDEX_KEY - 接口 javax.swing.Action 中的静态变量
用来存储对应于文本（由 NAME 属性标识）索引的 Integer 值的键，助记符的装饰应在该文本中呈现。
displayMessage(String, String, TrayIcon.MessageType) - 类 java.awt.TrayIcon 中的方法
在托盘图标附近显示弹出消息。
DisplayMode - java.awt 中的 类
DisplayMode 类封装 GraphicsDevice 的位深、高度、宽度和刷新率。
DisplayMode(int, int, int, int) - 类 java.awt.DisplayMode 的构造方法
使用提供的参数创建一个新的显示模式对象。
displayName() - 类 java.nio.charset.Charset 中的方法
返回此 charset 用于默认语言环境的可读名称。
displayName(Locale) - 类 java.nio.charset.Charset 中的方法
返回此 charset 用于给定语言环境的可读名称。
dispose() - 类 java.awt.Component.BltBufferStrategy 中的方法
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
dispose() - 类 java.awt.Component.FlipBufferStrategy 中的方法
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
dispose() - 接口 java.awt.CompositeContext 中的方法
释放分配给上下文的资源。
dispose() - 类 java.awt.Graphics 中的方法
释放此图形的上下文以及它使用的所有系统资源。
dispose() - 类 java.awt.im.InputContext 中的方法
释放由此输入上下文使用过的资源。
dispose() - 接口 java.awt.im.spi.InputMethod 中的方法
释放由此输入方法使用的资源。
dispose() - 类 java.awt.image.BufferStrategy 中的方法
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
dispose() - 接口 java.awt.PaintContext 中的方法
释放为操作分配的资源。
dispose() - 类 java.awt.Window 中的方法
释放由此 Window、其子组件及其拥有的所有子组件所使用的所有本机屏幕资源。
dispose() - 类 javax.imageio.ImageReader 中的方法
允许释放此对象占用的所有资源。
dispose() - 类 javax.imageio.ImageWriter 中的方法
允许释放此对象保存的所有资源。
dispose() - 类 javax.print.StreamPrintService 中的方法
处置此 StreamPrintService。
dispose() - 接口 javax.security.sasl.SaslClient 中的方法
处置 SaslClient 可能使用的所有系统资源或安全敏感信息。
dispose() - 接口 javax.security.sasl.SaslServer 中的方法
处置 SaslServer 可能使用的所有系统资源或安全敏感信息。
dispose() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.dispose。
dispose() - 类 javax.swing.JInternalFrame 中的方法
使此内部窗体不可见、取消选定并关闭它。
dispose() - 接口 org.ietf.jgss.GSSContext 中的方法
释放存储在上下文对象中并且使上下文无效的系统资源和加密信息。
dispose() - 接口 org.ietf.jgss.GSSCredential 中的方法
释放 GSSCredential 对象可能包含的任何敏感信息。
DISPOSE_ON_CLOSE - 接口 javax.swing.WindowConstants 中的静态变量
移除窗口的默认窗口关闭操作。
distance(double, double, double, double) - 类 java.awt.geom.Point2D 中的静态方法
返回两个点之间距离。
distance(double, double) - 类 java.awt.geom.Point2D 中的方法
返回从此 Point2D 到指定点的距离。
distance(Point2D) - 类 java.awt.geom.Point2D 中的方法
返回从此 Point2D 到指定 Point2D 的距离。
distanceSq(double, double, double, double) - 类 java.awt.geom.Point2D 中的静态方法
返回两个点之间距离的平方。
distanceSq(double, double) - 类 java.awt.geom.Point2D 中的方法
返回从此 Point2D 到指定点的距离的平方。
distanceSq(Point2D) - 类 java.awt.geom.Point2D 中的方法
返回从此 Point2D 到指定 Point2D 的距离的平方。
DISTINCT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DISTINCT 的 Java 编程语言中的常量（有时称为类型代码）。
DIV - 类 javax.management.Query 中的静态变量
表示 Query.div(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
div(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个二进制表达式，表示两个数值的商。
DIV - 类 javax.swing.text.html.HTML.Tag 中的静态变量
divide(BigDecimal, int, int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
divide(BigDecimal, int, RoundingMode) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
divide(BigDecimal, int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
divide(BigDecimal, RoundingMode) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
divide(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this / divisor)，其首选标度为 (this.scale() - divisor.scale())；如果无法表示准确的商值（因为它有无穷的十进制扩展），则抛出 ArithmeticException。
divide(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
divide(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this / val) 的 BigInteger。
divideAndRemainder(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟对两个操作数计算所得到的 remainder。
divideAndRemainder(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
divideAndRemainder(BigInteger) - 类 java.math.BigInteger 中的方法
返回包含 (this / val) 后跟 (this % val) 的两个 BigInteger 的数组。
DIVIDER - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个表示分隔条的 Component。
divider - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
此 JSplitPane 的分隔符的实例。
DIVIDER_LOCATION_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 dividerLocation 属性。
DIVIDER_SIZE_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 border 属性名称。
dividerResizeToggleKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
dividerSize - 类 javax.swing.JSplitPane 中的变量
分隔条大小。
dividerSize - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
分隔符的大小。
dividerSize - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
拖动会话有效时分隔符的大小。
divideToIntegralValue(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为向下舍入所得商值 (this / divisor) 的整数部分。
divideToIntegralValue(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为 (this / divisor) 的整数部分。
divisionType - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的 division 类型。
divisionType - 类 javax.sound.midi.Sequence 中的变量
sequence 的定时 division 类型。
dk_AbstractInterface - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象表示一个抽象接口的静态 DefinitionKind 实例。
dk_Alias - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Alias 的静态 DefinitionKind 实例。
dk_all - 类 org.omg.CORBA.DefinitionKind 中的静态变量
通配符 DefinitionKind 常量，可用于 DefinitionKind 适合的所有情况。
dk_Array - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Array 的静态 DefinitionKind 实例。
dk_Attribute - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Attribute 的静态 DefinitionKind 实例。
dk_Constant - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个常量的静态 DefinitionKind 实例。
dk_Enum - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Enum 的静态 DefinitionKind 实例。
dk_Exception - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Exception 的静态 DefinitionKind 实例。
dk_Fixed - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Fixed value 的静态 DefinitionKind 实例。
dk_Interface - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Interface 的静态 DefinitionKind 实例。
dk_Module - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Module 的静态 DefinitionKind 实例。
dk_Native - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Native value 的静态 DefinitionKind 实例。
dk_none - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有任何定义种类的静态 DefinitionKind 实例。
dk_Operation - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Operation 的静态 DefinitionKind 实例。
dk_Primitive - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Primitive 的静态 DefinitionKind 实例。
dk_Repository - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Repository 的静态 DefinitionKind 实例。
dk_Sequence - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Sequence 的静态 DefinitionKind 实例。
dk_String - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 String 的静态 DefinitionKind 实例。
dk_Struct - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Struct 的静态 DefinitionKind 实例。
dk_Typedef - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Typedef 的静态 DefinitionKind 实例。
dk_Union - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Union 的静态 DefinitionKind 实例。
dk_Value - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Value 的静态 DefinitionKind 实例。
dk_ValueBox - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 ValueBox 的静态 DefinitionKind 实例。
dk_ValueMember - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 ValueMember 的静态 DefinitionKind 实例。
dk_Wstring - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象是一个 Wstring 的静态 DefinitionKind 实例。
DL - 类 javax.swing.text.html.HTML.Tag 中的静态变量
DnDConstants - java.awt.dnd 中的 类
此类包含了表示 Drag 和 Drop 操作所执行的操作类型的常量值。
DNS_URL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定用于 JNDI URL 上下文的 DNS 主机名和域名（例如 "dns://somehost/wiz.com"）的环境属性名称。
DO_NOTHING_ON_CLOSE - 接口 javax.swing.WindowConstants 中的静态变量
无操作默认窗口关闭操作。
doAccessibleAction(int) - 类 java.awt.Button.AccessibleAWTButton 中的方法
在对象上执行指定的操作
doAccessibleAction(int) - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
在对象上执行指定的操作
doAccessibleAction(int) - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
在对象上执行指定的操作
doAccessibleAction(int) - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
在对象上执行指定的操作
doAccessibleAction(int) - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
对该对象执行指定的操作
doAccessibleAction(int) - 接口 javax.accessibility.AccessibleAction 中的方法
对对象执行指定的 Action
doAccessibleAction(int) - 类 javax.accessibility.AccessibleHyperlink 中的方法
对该对象执行指定的 Action
doAccessibleAction(int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
对该对象执行指定的 Action
doAccessibleAction(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
对该对象执行指定的 Action
doAccessibleAction(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
对该对象执行指定的 Action
doAccessibleAction(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
对该对象执行指定的操作
doAccessibleAction(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
执行树节点上的指定操作。
doAccessibleAction(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
对该对象执行指定的 Action
doAs(Subject, PrivilegedAction<T>) - 类 javax.security.auth.Subject 中的静态方法
作为特定的 Subject 的功能。
doAs(Subject, PrivilegedExceptionAction<T>) - 类 javax.security.auth.Subject 中的静态方法
作为特定的 Subject 的功能。
doAsPrivileged(Subject, PrivilegedAction<T>, AccessControlContext) - 类 javax.security.auth.Subject 中的静态方法
作为特定的 Subject 的特权功能。
doAsPrivileged(Subject, PrivilegedExceptionAction<T>, AccessControlContext) - 类 javax.security.auth.Subject 中的静态方法
作为特定的 Subject 的特权功能。
Doc - javax.print 中的 接口
接口 Doc 指定某个对象的接口，该接口为 PrintJob 提供部分打印数据。
DocAttribute - javax.print.attribute 中的 接口
接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
DocAttributeSet - javax.print.attribute 中的 接口
接口 DocAttributeSet 指定文档属性（即：实现接口 DocAttribute 的打印属性）集的接口。
DocFlavor - javax.print 中的 类
类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。
DocFlavor(String, String) - 类 javax.print.DocFlavor 的构造方法
根据给定的 MIME 类型和表示形式类名构造新的 DocFlavor 对象。
DocFlavor.BYTE_ARRAY - javax.print 中的 类
类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.BYTE_ARRAY(String) - 类 javax.print.DocFlavor.BYTE_ARRAY 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "[B"（byte 数组）的新 DocFlavor。
DocFlavor.CHAR_ARRAY - javax.print 中的 类
类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.CHAR_ARRAY(String) - 类 javax.print.DocFlavor.CHAR_ARRAY 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "[C"（字符数组）的新 DocFlavor。
DocFlavor.INPUT_STREAM - javax.print 中的 类
类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.INPUT_STREAM(String) - 类 javax.print.DocFlavor.INPUT_STREAM 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.InputStream"（byte 流）的新 DocFlavor。
DocFlavor.READER - javax.print 中的 类
类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.READER(String) - 类 javax.print.DocFlavor.READER 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.Reader"（字符流）的新 DocFlavor。
DocFlavor.SERVICE_FORMATTED - javax.print 中的 类
类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
DocFlavor.SERVICE_FORMATTED(String) - 类 javax.print.DocFlavor.SERVICE_FORMATTED 的构造方法
构造具有 "application/x-java-jvm-local-objectref" MIME 类型（指示服务格式化打印数据）和给定打印数据表示形式类名的新 DocFlavor。
DocFlavor.STRING - javax.print 中的 类
类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.STRING(String) - 类 javax.print.DocFlavor.STRING 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "java.lang.String" 的新 DocFlavor。
DocFlavor.URL - javax.print 中的 类
类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。
DocFlavor.URL(String) - 类 javax.print.DocFlavor.URL 的构造方法
构造具有给定 MIME 类型和打印数据表示形式类名 "java.net.URL" 的新 DocFlavor。
dockingBorderColor - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
dockingColor - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
dockingListener - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
doClick() - 类 javax.swing.AbstractButton 中的方法
以编程方式执行“单击”。
doClick(int) - 类 javax.swing.AbstractButton 中的方法
以编程方式执行“单击”。
doClick(int) - 类 javax.swing.JMenu 中的方法
以编程方式执行“单击”。
doClick(MenuSelectionManager) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
要激活菜单项时调用此方法。
DocPrintJob - javax.print 中的 接口
此接口表示了一个可使用作业属性集打印指定文档的打印作业。
DOCTYPE_PUBLIC - 类 javax.xml.transform.OutputKeys 中的静态变量
doctype-public = string. 有关关键值应为何值的描述，请参阅 OutputKeys.DOCTYPE_SYSTEM 属性文档。
DOCTYPE_SYSTEM - 类 javax.xml.transform.OutputKeys 中的静态变量
doctype-system = string. doctype-system 指定了要在文档类型声明中使用的系统标识符。
Document - javax.swing.text 中的 接口
Document 是一个作为 swing 文本组件模型的文本容器。
Document - org.w3c.dom 中的 接口
Document 接口表示整个 HTML 或 XML 文档。
DOCUMENT_ACCESS_ERROR - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机不能访问由引用传递的一个或多个文档（即打印数据表示形式对象为 URL）。
DOCUMENT_FORMAT_ERROR - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统中止了作业，因为打印机在处理文档数据时遇到错误。
DOCUMENT_FRAGMENT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 DocumentFragment。
DOCUMENT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Document。
DOCUMENT_POSITION_CONTAINED_BY - 接口 org.w3c.dom.Node 中的静态变量
引用节点包含该节点。
DOCUMENT_POSITION_CONTAINS - 接口 org.w3c.dom.Node 中的静态变量
该节点包含引用节点。
DOCUMENT_POSITION_DISCONNECTED - 接口 org.w3c.dom.Node 中的静态变量
两个节点断开连接。
DOCUMENT_POSITION_FOLLOWING - 接口 org.w3c.dom.Node 中的静态变量
该节点在引用节点之后。
DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC - 接口 org.w3c.dom.Node 中的静态变量
对前后位置的确定是特定于实现的。
DOCUMENT_POSITION_PRECEDING - 接口 org.w3c.dom.Node 中的静态变量
第二个节点在引用节点之前。
DOCUMENT_TYPE_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 DocumentType。
documentBaseKey - 类 javax.swing.plaf.basic.BasicHTML 中的静态变量
存储为客户端属性以指示用作解析相关引用的基址的键。
DocumentBuilder - javax.xml.parsers 中的 类
定义 API， 使其从 XML 文档获取 DOM 文档实例。
DocumentBuilder() - 类 javax.xml.parsers.DocumentBuilder 的构造方法
受保护的构造方法
DocumentBuilderFactory - javax.xml.parsers 中的 类
定义工厂 API，使应用程序能够从 XML 文档获取生成 DOM 对象树的解析器。
DocumentBuilderFactory() - 类 javax.xml.parsers.DocumentBuilderFactory 的构造方法
用于阻止实例化的受保护构造方法。
Documented - java.lang.annotation 中的 注释类型
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
DocumentEvent - javax.swing.event 中的 接口
用于文档更改通知的接口。
DocumentEvent - org.w3c.dom.events 中的 接口
DocumentEvent 接口提供一种机制，通过该机制用户可以创建实现支持的 Event 类型。
DocumentEvent.ElementChange - javax.swing.event 中的 接口
描述对特定元素所做的更改。
DocumentEvent.EventType - javax.swing.event 中的 类
文档事件类型的枚举
DocumentFilter - javax.swing.text 中的 类
DocumentFilter，顾名思义，它是 Document 改变方法的一个过滤器。
DocumentFilter() - 类 javax.swing.text.DocumentFilter 的构造方法
DocumentFilter.FilterBypass - javax.swing.text 中的 类
充当避开回调 Document 进行更改的方法。
DocumentFilter.FilterBypass() - 类 javax.swing.text.DocumentFilter.FilterBypass 的构造方法
DocumentFragment - org.w3c.dom 中的 接口
DocumentFragment 是“轻量级”或“最小”Document 对象。
DocumentHandler - org.xml.sax 中的 接口
已过时。 此接口已经被 SAX2 ContentHandler 接口取代，后者包括名称空间支持。
DocumentListener - javax.swing.event 中的 接口
观察者使用该接口注册以接收文本文档的更改通知。
DocumentName - javax.print.attribute.standard 中的 类
DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
DocumentName(String, Locale) - 类 javax.print.attribute.standard.DocumentName 的构造方法
构造具有给定文档名称和语言环境的新文档名称属性。
DocumentParser - javax.swing.text.html.parser 中的 类
HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。
DocumentParser(DTD) - 类 javax.swing.text.html.parser.DocumentParser 的构造方法
DocumentType - org.w3c.dom 中的 接口
每个 Document 都有 doctype 属性，该属性的值可以为 null，也可以为 DocumentType 对象。
doDefaultCloseAction() - 类 javax.swing.JInternalFrame 中的方法
激发 INTERNAL_FRAME_CLOSING 事件，然后执行内部窗体的默认 close 操作所指定的操作。
doesMaxRowSizeIncludeBlobs() - 接口 java.sql.DatabaseMetaData 中的方法
获取 getMaxRowSize 方法的返回值是否包括 SQL 数据类型 LONGVARCHAR 和 LONGVARBINARY。
doFinal() - 类 javax.crypto.Cipher 中的方法
结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
doFinal(byte[], int) - 类 javax.crypto.Cipher 中的方法
结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
doFinal(byte[]) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal(byte[], int, int) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal(byte[], int, int, byte[]) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal(byte[], int, int, byte[], int) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal(ByteBuffer, ByteBuffer) - 类 javax.crypto.Cipher 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
doFinal() - 类 javax.crypto.Mac 中的方法
完成 MAC 操作。
doFinal(byte[], int) - 类 javax.crypto.Mac 中的方法
完成 MAC 操作。
doFinal(byte[]) - 类 javax.crypto.Mac 中的方法
处理给定的 byte 数组并完成 MAC 操作。
doInBackground() - 类 javax.swing.SwingWorker 中的方法
计算结果；如果无法计算结果，则抛出异常。
doInput - 类 java.net.URLConnection 中的变量
此变量由 setDoInput 方法设置。
doLayout() - 类 java.awt.Component 中的方法
提示布局管理器布局此组件。
doLayout() - 类 java.awt.Container 中的方法
使此容器布置其组件。
doLayout() - 类 java.awt.ScrollPane 中的方法
通过将子组件的大小调整为其首选大小来布置此容器。
doLayout() - 类 javax.swing.JTable 中的方法
使此表布局其行和列。
doLayout() - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 中的方法
对此 Container 进行布局。
doLookup(Name) - 类 javax.naming.InitialContext 中的静态方法
获取指定对象的静态方法。
doLookup(String) - 类 javax.naming.InitialContext 中的静态方法
获取指定对象的静态方法。
DOM_OBJECT_MODEL - 类 javax.xml.xpath.XPathConstants 中的静态变量
DOM 对象模型的 URI，"http://java.sun.com/jaxp/xpath/dom"。
DomainCombiner - java.security 中的 接口
DomainCombiner 提供一个动态更新与当前 AccessControlContext 关联的 ProtectionDomain 的方法。
DomainManager - org.omg.CORBA 中的 接口
提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
DomainManagerOperations - org.omg.CORBA 中的 接口
向 DomainManager 提供访问策略的方法。
domainMatches(String, String) - 类 java.net.HttpCookie 中的静态方法
检查主机名是否在域中的实用方法。
DOMConfiguration - org.w3c.dom 中的 接口
该 DOMConfiguration 接口表示文档的配置，并维护一个可识别的参数表。
DOMCryptoContext - javax.xml.crypto.dom 中的 类
此类提供 XMLCryptoContext 接口特定于 DOM 的实现。
DOMCryptoContext() - 类 javax.xml.crypto.dom.DOMCryptoContext 的构造方法
默认的构造方法。
DOMError - org.w3c.dom 中的 接口
DOMError 是一个描述错误的接口。
DOMErrorHandler - org.w3c.dom 中的 接口
DOMErrorHandler 是在报告处理 XML 数据时发生的错误或在进行某些其他处理（如验证文档）时 DOM 实现可以调用的回调接口。
DOMException - org.w3c.dom 中的 异常
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。
DOMException(short, String) - 异常 org.w3c.dom.DOMException 的构造方法
DomHandler<ElementT,ResultT extends Result> - javax.xml.bind.annotation 中的 接口
在元素（及其子代）与 DOM（或类似对象）表示形式之间相互转换。
DOMImplementation - org.w3c.dom 中的 接口
DOMImplementation 接口为执行独立于文档对象模型的任何特定实例的操作提供了许多方法。
DOMImplementationList - org.w3c.dom 中的 接口
DOMImplementationList 接口提供对 DOM 实现的有序集合的抽象，没有定义或约束如何实现此集合。
DOMImplementationLS - org.w3c.dom.ls 中的 接口
DOMImplementationLS 包括创建 Load 和 Save 对象的工厂方法。
DOMImplementationRegistry - org.w3c.dom.bootstrap 中的 类
启用应用程序来获得 DOMImplementation 实例的工厂。
DOMImplementationSource - org.w3c.dom 中的 接口
此接口允许 DOM 实现程序根据请求的功能和版本提供一个或多个实现，如下所述。
DOMLocator - javax.xml.transform.dom 中的 接口
指示源 DOM 中节点的位置，主要用于错误报告。
DOMLocator - org.w3c.dom 中的 接口
DOMLocator 是一个描述位置（如发生错误的位置）的接口。
DOMResult - javax.xml.transform.dom 中的 类
以 Document Object Model（DOM）树的形式充当转换结果树的持有者。
DOMResult() - 类 javax.xml.transform.dom.DOMResult 的构造方法
零参数的默认构造方法。
DOMResult(Node) - 类 javax.xml.transform.dom.DOMResult 的构造方法
使用 DOM 节点创建新输出目标。
DOMResult(Node, String) - 类 javax.xml.transform.dom.DOMResult 的构造方法
使用 DOM 节点创建带有指定 System ID 的新输出目标。
DOMResult(Node, Node) - 类 javax.xml.transform.dom.DOMResult 的构造方法
使用 DOM 节点创建新输出目标，此目标指定了应该插入的结果节点之后的子节点。
DOMResult(Node, Node, String) - 类 javax.xml.transform.dom.DOMResult 的构造方法
使用 DOM 节点创建新输出目标，此目标指定了子节点，其中结果节点为指定 System ID 且应该插入到该子节点之前。
DOMSignContext - javax.xml.crypto.dsig.dom 中的 类
特定于 DOM 的 XMLSignContext。
DOMSignContext(Key, Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 的构造方法
创建带有指定签名密钥和父节点的 DOMSignContext。
DOMSignContext(Key, Node, Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 的构造方法
创建带有指定的签名密钥、父节点和下一个兄弟节点的 DOMSignContext。
DOMSignContext(KeySelector, Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 的构造方法
创建带有指定密钥选择器和父节点的 DOMSignContext。
DOMSignContext(KeySelector, Node, Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 的构造方法
创建带有指定密钥选择器、父节点和下一个兄弟节点的 DOMSignContext。
DOMSource - javax.xml.transform.dom 中的 类
以 Document Object Model（DOM）树的形式充当转换 Source 树的持有者。
DOMSource() - 类 javax.xml.transform.dom.DOMSource 的构造方法
零参数的默认构造方法。
DOMSource(Node) - 类 javax.xml.transform.dom.DOMSource 的构造方法
创建带有 DOM 节点的新输入源。
DOMSource(Node, String) - 类 javax.xml.transform.dom.DOMSource 的构造方法
创建带有 DOM 节点的新输入源，系统 ID 也作为基本 URI 被传入。
DOMSTRING_SIZE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果文本的指定范围不适合 DOMString。
DOMStringList - org.w3c.dom 中的 接口
DOMStringList 接口提供对 DOMString 值的有序集合的抽象，没有定义或约束此集合是如何实现的。
DOMStructure - javax.xml.crypto.dom 中的 类
特定于 DOM 的 XMLStructure。
DOMStructure(Node) - 类 javax.xml.crypto.dom.DOMStructure 的构造方法
创建包含指定节点的 DOMStructure。
DOMURIReference - javax.xml.crypto.dom 中的 接口
特定于 DOM 的 URIReference。
DOMValidateContext - javax.xml.crypto.dsig.dom 中的 类
特定于 DOM 的 XMLValidateContext。
DOMValidateContext(KeySelector, Node) - 类 javax.xml.crypto.dsig.dom.DOMValidateContext 的构造方法
创建包含指定密钥选择器和节点的 DOMValidateContext。
DOMValidateContext(Key, Node) - 类 javax.xml.crypto.dsig.dom.DOMValidateContext 的构造方法
创建包含指定密钥和节点的 DOMValidateContext。
done() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
done(RemoteCall) - 接口 java.rmi.server.RemoteRef 中的方法
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
DONE - 类 java.text.BreakIterator 中的静态变量
在已经到达第一个或最后一个文本边界时，previous()、next()、next(int)、preceding(int) 和 following(int) 将返回 DONE。
DONE - 接口 java.text.CharacterIterator 中的静态变量
当迭代器已到达文本末尾或开始处时返回的常量。
done() - 类 java.util.concurrent.FutureTask 中的方法
当此任务转换到状态 isDone（不管是正常地还是通过取消）时，调用受保护的方法。
done() - 类 javax.swing.SwingWorker 中的方法
doInBackground 方法完成后，在事件指派线程 上执行此方法。
dontUseGui() - 类 java.beans.beancontext.BeanContextSupport 中的方法
通知此实例它可以不再呈现一个 GUI。
dontUseGui() - 接口 java.beans.Visibility 中的方法
此方法指示不应该使用 Gui 的 bean。
DOOR_OPEN - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备上的一个或多个门处于打开状态。
doOutput - 类 java.net.URLConnection 中的变量
此变量由 setDoOutput 方法设置。
doPhase(Key, boolean) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
doPrivileged(PrivilegedAction<T>) - 类 java.security.AccessController 中的静态方法
启用特权，执行指定的 PrivilegedAction。
doPrivileged(PrivilegedAction<T>, AccessControlContext) - 类 java.security.AccessController 中的静态方法
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedAction。
doPrivileged(PrivilegedExceptionAction<T>) - 类 java.security.AccessController 中的静态方法
启用特权，执行指定的 PrivilegedExceptionAction。
doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext) - 类 java.security.AccessController 中的静态方法
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。
doPrivilegedWithCombiner(PrivilegedAction<T>) - 类 java.security.AccessController 中的静态方法
启用特权，执行指定的 PrivilegedAction。
doPrivilegedWithCombiner(PrivilegedExceptionAction<T>) - 类 java.security.AccessController 中的静态方法
启用特权，执行指定的 PrivilegedExceptionAction。
DOTALL - 类 java.util.regex.Pattern 中的静态变量
启用 dotall 模式。
Double - java.lang 中的 类
Double 类在对象中包装一个基本类型 double 的值。
Double(double) - 类 java.lang.Double 的构造方法
构造一个新分配的 Double 对象，它表示基本的 double 参数。
Double(String) - 类 java.lang.Double 的构造方法
构造一个新分配的 Double 对象，表示用字符串表示的 double 类型的浮点值。
DOUBLE - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 DOUBLE 的 Java 编程语言中的常量（有时称为类型代码）。
DOUBLE - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Double 的值。
DoubleBuffer - java.nio 中的 类
double 缓冲区。
DoubleHolder - org.omg.CORBA 中的 类
Double 的 Holder。
DoubleHolder() - 类 org.omg.CORBA.DoubleHolder 的构造方法
构造一个新的 DoubleHolder 对象，将其 value 字段初始化为 0.0。
DoubleHolder(double) - 类 org.omg.CORBA.DoubleHolder 的构造方法
为给定 double 值构造一个新的 DoubleHolder 对象。
DoubleSeqHelper - org.omg.CORBA 中的 类
DoubleSeq 的 Helper。
DoubleSeqHelper() - 类 org.omg.CORBA.DoubleSeqHelper 的构造方法
DoubleSeqHolder - org.omg.CORBA 中的 类
DoubleSeq 的 Holder。
DoubleSeqHolder() - 类 org.omg.CORBA.DoubleSeqHolder 的构造方法
DoubleSeqHolder(double[]) - 类 org.omg.CORBA.DoubleSeqHolder 的构造方法
doubleToLongBits(double) - 类 java.lang.Double 中的静态方法
根据 IEEE 754 浮点双精度格式 ("double format") 位布局，返回指定浮点值的表示形式。
doubleToRawLongBits(double) - 类 java.lang.Double 中的静态方法
根据 IEEE 754 浮点“双精度格式”位布局，返回指定浮点值的表示形式，并保留 NaN 值。
doubleValue() - 类 java.lang.Byte 中的方法
作为一个 double 返回此 Byte 的值。
doubleValue() - 类 java.lang.Double 中的方法
返回此 Double 对象的 double 值。
doubleValue() - 类 java.lang.Float 中的方法
返回此 Float 对象的 double 值。
doubleValue() - 类 java.lang.Integer 中的方法
以 double 类型返回该 Integer 的值。
doubleValue() - 类 java.lang.Long 中的方法
以 double 形式返回此 Long 的值。
doubleValue() - 类 java.lang.Number 中的方法
以 double 形式返回指定的数值。
doubleValue() - 类 java.lang.Short 中的方法
以 double 形式返回此 Short 的值。
doubleValue() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 double。
doubleValue() - 类 java.math.BigInteger 中的方法
将此 BigInteger 转换为 double。
doubleValue() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
doubleValue() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
DOWN - 类 java.awt.Event 中的静态变量
Down Arrow 键，一个非 ASCII 操作键。
DOWN_CYCLE_TRAVERSAL_KEYS - 类 java.awt.KeyboardFocusManager 中的静态变量
Down Cycle 焦点遍历键的标识符。
downAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向下移动一个位置的动作名称。
downFocusCycle(Container) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
将焦点下移一个焦点遍历循环。
downFocusCycle(Container) - 类 java.awt.KeyboardFocusManager 中的方法
将焦点下移一个焦点遍历循环。
downFocusCycle() - 类 java.awt.KeyboardFocusManager 中的方法
当且仅当当前焦点所有者是一个作为焦点循环根的 Container 时，从当前焦点所有者将焦点下移一个焦点遍历循环。
downKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
downKey - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
downKey - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
已过时。 从 Java 2 平台 v1.3 开始。
DPCM - 类 javax.print.attribute.ResolutionSyntax 中的静态变量
指示每厘米点数为单位 (dpcm) 的值。
DPI - 类 javax.print.attribute.ResolutionSyntax 中的静态变量
指示每英寸点数为单位 (dpi) 的值。
DRAFT - 类 java.awt.PageAttributes.PrintQualityType 中的静态变量
用于指定草稿打印质量的 PrintQualityType 实例。
DRAFT - 类 javax.print.attribute.standard.PrintQuality 中的静态变量
打印机可提供的最低打印质量。
DRAG_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Drag 层的便捷对象。
dragDividerTo(int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
利用包含此实例的 dragDividerTo 传递 BasicSplitPaneUI 的消息。
dragDividerTo(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
拖动会话期间传递消息以便将分隔符移动到传入位置。
dragDropEnd(DragSourceDropEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
调用此方法来通知 Drag 和 Drop 操作已完成。
dragDropEnd(DragSourceDropEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragDropEnd，并将指定的 DragSourceDropEvent 传递给它们。
dragDropEnd(DragSourceDropEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
调用此方法来通知 Drag 和 Drop 操作已完成。
dragEnter(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
光标的热点进入放置点（与平台相关）时调用该方法。
dragEnter(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragEnter，并将指定的 DragSourceDragEvent 传递给它们。
dragEnter(DragSourceDragEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
光标的热点进入放置点（与平台相关）时调用该方法。
dragEnter(DropTargetDragEvent) - 类 java.awt.dnd.DropTarget 中的方法
在已注册的 DropTargetListener 上调用 dragEnter，并将其传递给指定的 DropTargetDragEvent。
dragEnter(DropTargetDragEvent) - 类 java.awt.dnd.DropTargetAdapter 中的方法
当鼠标指针进入向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行的同时调用该方法。
dragEnter(DropTargetDragEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
正在进行 drag 操作时调用，此时鼠标指针进入 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
dragExit(DragSourceEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
光标的热点离开放置点（与平台相关）时调用该方法。
dragExit(DragSourceEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragExit，并将指定的 DragSourceEvent 传递给它们。
dragExit(DragSourceEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
光标的热点离开放置点（与平台相关）时调用该方法。
dragExit(DropTargetEvent) - 类 java.awt.dnd.DropTarget 中的方法
在已注册的 DropTargetListener 上调用 dragExit，并将其传递给指定的 DropTargetEvent。
dragExit(DropTargetEvent) - 类 java.awt.dnd.DropTargetAdapter 中的方法
当鼠标指针已经离开向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行时调用该方法。
dragExit(DropTargetEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
正在进行 drag 操作时调用，此时鼠标指针已退出 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
dragFrame(JComponent, int, int) - 类 javax.swing.DefaultDesktopManager 中的方法
将正被拖动窗体的可见位置移动到指定位置。
dragFrame(JComponent, int, int) - 接口 javax.swing.DesktopManager 中的方法
用户已经移动窗体。
draggedColumn - 类 javax.swing.table.JTableHeader 中的变量
被拖动列的索引。
draggedDistance - 类 javax.swing.table.JTableHeader 中的变量
列被拖离其初始位置的距离。
dragger - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
处理要进行实际拖动操作的鼠标拖动消息。
DragGestureEvent - java.awt.dnd 中的 类
当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
DragGestureEvent(DragGestureRecognizer, int, Point, List<? extends InputEvent>) - 类 java.awt.dnd.DragGestureEvent 的构造方法
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。
DragGestureListener - java.awt.dnd 中的 接口
此接口源于 DragGestureRecognizer，当该（子）类的对象检测到拖动启动动作时，调用此接口。
dragGestureListener - 类 java.awt.dnd.DragGestureRecognizer 中的变量
与此 DragGestureRecognizer 关联的 DragGestureListener。
dragGestureRecognized(DragGestureEvent) - 接口 java.awt.dnd.DragGestureListener 中的方法
DragGestureRecognizer 已经检测到与平台有关的拖动启动动作，并且正通知此侦听器，以便启动用户操作。
DragGestureRecognizer - java.awt.dnd 中的 类
DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。
DragGestureRecognizer(DragSource, Component, int, DragGestureListener) - 类 java.awt.dnd.DragGestureRecognizer 的构造方法
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
DragGestureRecognizer(DragSource, Component, int) - 类 java.awt.dnd.DragGestureRecognizer 的构造方法
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component 和此 Drag 和 Drop 操作所支持的动作。
DragGestureRecognizer(DragSource, Component) - 类 java.awt.dnd.DragGestureRecognizer 的构造方法
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource 和此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component。
DragGestureRecognizer(DragSource) - 类 java.awt.dnd.DragGestureRecognizer 的构造方法
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource。
draggingHW - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
如果任何一个子级（不包括 nonContinuousLayoutDivider）是重量级的，则在 startDragging 中设置 true。
dragMouseMoved(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
在拖动操作期间，只要移动了鼠标就调用该方法。
dragMouseMoved(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向与此 DragSourceContext 关联的 DragSource 注册的 DragSourceMotionListener 调用 dragMouseMoved，并将指定的 DragSourceDragEvent 传递给它们。
dragMouseMoved(DragSourceDragEvent) - 接口 java.awt.dnd.DragSourceMotionListener 中的方法
只要在拖动操作期间鼠标移动了，就调用该方法。
dragOver(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
光标的热点在放置点（与平台相关）上移动时调用该方法。
dragOver(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceContext 调用 dragOver，并将指定的 DragSourceDragEvent 传递给它们。
dragOver(DragSourceDragEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
光标的热点在放置点（与平台相关）上移动时调用该方法。
dragOver(DropTargetDragEvent) - 类 java.awt.dnd.DropTarget 中的方法
在已注册的 DropTargetListener 上调用 dragOver，并将其传递给指定的 DropTargetDragEvent。
dragOver(DropTargetDragEvent) - 类 java.awt.dnd.DropTargetAdapter 中的方法
当鼠标指针仍旧处于向此侦听器注册的 DropTarget 放置点可操作部分上时，则在拖动操作正在进行时调用该方法。
dragOver(DropTargetDragEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
正在进行 drag 操作时调用，此时鼠标指针仍然处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
dragSource - 类 java.awt.dnd.DragGestureRecognizer 中的变量
与此 DragGestureRecognizer 关联的 DragSource。
DragSource - java.awt.dnd 中的 类
DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。
DragSource() - 类 java.awt.dnd.DragSource 的构造方法
创建一个新的 DragSource。
DragSourceAdapter - java.awt.dnd 中的 类
用于接收拖动源事件的抽象适配器类。
DragSourceAdapter() - 类 java.awt.dnd.DragSourceAdapter 的构造方法
DragSourceContext - java.awt.dnd 中的 类
DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。
DragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - 类 java.awt.dnd.DragSourceContext 的构造方法
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。
DragSourceDragEvent - java.awt.dnd 中的 类
通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
DragSourceDragEvent(DragSourceContext, int, int, int) - 类 java.awt.dnd.DragSourceDragEvent 的构造方法
构造一个 DragSourceDragEvent。
DragSourceDragEvent(DragSourceContext, int, int, int, int, int) - 类 java.awt.dnd.DragSourceDragEvent 的构造方法
构造一个具有指定 DragSourceContext、用户放置动作、目标放置动作、修改键和坐标的 DragSourceDragEvent。
DragSourceDropEvent - java.awt.dnd 中的 类
通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。
DragSourceDropEvent(DragSourceContext, int, boolean) - 类 java.awt.dnd.DragSourceDropEvent 的构造方法
放置构造一个具有给定 DragSourceContext、放置操作和指示放置是否成功的 boolean 值的 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext, int, boolean, int, int) - 类 java.awt.dnd.DragSourceDropEvent 的构造方法
针对放置构造一个具有给定 DragSourceContext、放置操作、表示放置是否成功的 boolean 值和坐标的 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext) - 类 java.awt.dnd.DragSourceDropEvent 的构造方法
针对没有引起放置的拖动构造一个 DragSourceDropEvent。
DragSourceEvent - java.awt.dnd 中的 类
此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。
DragSourceEvent(DragSourceContext) - 类 java.awt.dnd.DragSourceEvent 的构造方法
根据一个指定的 DragSourceContext 来构造一个 DragSourceEvent。
DragSourceEvent(DragSourceContext, int, int) - 类 java.awt.dnd.DragSourceEvent 的构造方法
根据指定的 DragSourceContext 和光标位置坐标构造一个 DragSourceEvent。
DragSourceListener - java.awt.dnd 中的 接口
DragSourceListener 定义了事件接口，Drag 和 Drop 操作的始发端使用它来跟踪用户操作的状态，并通过 Drag 和 Drop 操作为用户提供合适的“拖动结束”反馈。
DragSourceMotionListener - java.awt.dnd 中的 接口
用于接收拖动操作期间鼠标移动事件的侦听器接口。
dragTo(Point, Point) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
dragWindow - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
drain() - 类 java.io.ObjectOutputStream 中的方法
排空 ObjectOutputStream 中的所有已缓冲数据。
drain() - 接口 javax.sound.sampled.DataLine 中的方法
通过在清空数据行的内部缓冲区之前继续数据 I/O，排空数据行中的列队数据。
drainPermits() - 类 java.util.concurrent.Semaphore 中的方法
获取并返回立即可用的所有许可。
drainTo(Collection<? super E>) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
drainTo(Collection<? super E>) - 接口 java.util.concurrent.BlockingQueue 中的方法
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
drainTo(Collection<? super E>, int) - 接口 java.util.concurrent.BlockingQueue 中的方法
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
drainTo(Collection<? super E>) - 类 java.util.concurrent.DelayQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.DelayQueue 中的方法
drainTo(Collection<? super E>) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
drainTo(Collection<? super E>) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
drainTo(Collection<? super E>) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
drainTo(Collection<? super E>) - 类 java.util.concurrent.SynchronousQueue 中的方法
drainTo(Collection<? super E>, int) - 类 java.util.concurrent.SynchronousQueue 中的方法
draw(Graphics2D, float, float) - 类 java.awt.font.GraphicAttribute 中的方法
在指定的位置呈现此 GraphicAttribute。
draw(Graphics2D, float, float) - 类 java.awt.font.ImageGraphicAttribute 中的方法
在指定的位置呈现此 GraphicAttribute。
draw(Graphics2D, float, float) - 类 java.awt.font.ShapeGraphicAttribute 中的方法
在指定的位置呈现此 GraphicAttribute。
draw(Graphics2D, float, float) - 类 java.awt.font.TextLayout 中的方法
在指定的 Graphics2D 上下文中的指定位置上呈现此 TextLayout。
draw(Shape) - 类 java.awt.Graphics2D 中的方法
使用当前 Graphics2D 上下文的设置勾画 Shape 的轮廓。
draw3DRect(int, int, int, int, boolean) - 类 java.awt.Graphics 中的方法
绘制指定矩形的 3-D 高亮显示边框。
draw3DRect(int, int, int, int, boolean) - 类 java.awt.Graphics2D 中的方法
绘制指定矩形的 3-D 高亮显示边框。
draw3DRect(int, int, int, int, boolean) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.draw3DRect。
drawArc(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
绘制一个覆盖指定矩形的圆弧或椭圆弧边框。
drawArc(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawArc。
drawBezel(Graphics, int, int, int, int, boolean, boolean, Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawBuffer - 类 java.awt.Component.FlipBufferStrategy 中的变量
绘制缓冲区。
drawBytes(byte[], int, int, int, int) - 类 java.awt.Graphics 中的方法
使用此图形上下文的当前字体和颜色绘制由指定 byte 数组给定的文本。
drawBytes(byte[], int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawBytes。
drawCentered(Component, Graphics, Icon, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
drawChars(char[], int, int, int, int) - 类 java.awt.Graphics 中的方法
使用此图形上下文的当前字体和颜色绘制由指定字符数组给定的文本。
drawChars(char[], int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawChars。
drawCheck(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法
drawDashedHorizontalLine(Graphics, int, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
drawDashedRect(Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawDashedVerticalLine(Graphics, int, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
drawEchoCharacter(Graphics, int, int, char) - 类 javax.swing.text.PasswordView 中的方法
呈现回显字符，或呈现用来显示密码字符的图形。
drawEtchedRect(Graphics, int, int, int, int, Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawGlyphVector(GlyphVector, float, float) - 类 java.awt.Graphics2D 中的方法
使用 Graphics2D 上下文的呈现属性，呈现指定 GlyphVector 的文本。
drawGroove(Graphics, int, int, int, int, Color, Color) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawImage(Image, int, int, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制指定图像中当前可用的图像。
drawImage(Image, int, int, int, int, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制指定图像中已缩放到适合指定矩形内部的图像。
drawImage(Image, int, int, Color, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制指定图像中当前可用的图像。
drawImage(Image, int, int, int, int, Color, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制指定图像中已缩放到适合指定矩形内部的图像。
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - 类 java.awt.Graphics 中的方法
绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
drawImage(Image, AffineTransform, ImageObserver) - 类 java.awt.Graphics2D 中的方法
呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
drawImage(BufferedImage, BufferedImageOp, int, int) - 类 java.awt.Graphics2D 中的方法
呈现使用 BufferedImageOp 过滤的 BufferedImage。
drawImage(Image, int, int, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, int, int, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, Color, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, int, int, Color, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawImage。
drawingCache - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
用于最小化垂直线的绘制。
drawInverted() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
drawLine(int, int, int, int) - 类 java.awt.Graphics 中的方法
在此图形上下文的坐标系中，使用当前颜色在点 (x1, y1) 和 (x2, y2) 之间画一条线。
drawLine(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawLine。
drawLine(SynthContext, Object, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
在两个端点之间绘制一条线。
drawLine(SynthContext, Object, Graphics, int, int, int, int, Object) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
在两个端点之间绘制一条线。
drawLine(int, Graphics, int, int) - 类 javax.swing.text.PlainView 中的方法
呈现文本的某一行，取消末尾的空白并扩展所有的制表符。
drawLine(int, int, Graphics, int, int) - 类 javax.swing.text.WrappedPlainView 中的方法
取消结尾空格并扩展所有制表符，从而呈现一行文本。
drawLoweredBezel(Graphics, int, int, int, int, Color, Color, Color, Color) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
drawOval(int, int, int, int) - 类 java.awt.Graphics 中的方法
绘制椭圆的边框。
drawOval(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawOval。
drawPolygon(int[], int[], int) - 类 java.awt.Graphics 中的方法
绘制一个由 x 和 y 坐标数组定义的闭合多边形。
drawPolygon(Polygon) - 类 java.awt.Graphics 中的方法
绘制由指定的 Polygon 对象定义的多边形边框。
drawPolygon(int[], int[], int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawPolygon。
drawPolyline(int[], int[], int) - 类 java.awt.Graphics 中的方法
绘制由 x 和 y 坐标数组定义的一系列连接线。
drawPolyline(int[], int[], int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawPolyline。
drawRect(int, int, int, int) - 类 java.awt.Graphics 中的方法
绘制指定矩形的边框。
drawRect(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawRect。
drawRenderableImage(RenderableImage, AffineTransform) - 类 java.awt.Graphics2D 中的方法
呈现 RenderableImage，在绘制前进行从图像空间到用户空间的转换。
drawRenderedImage(RenderedImage, AffineTransform) - 类 java.awt.Graphics2D 中的方法
呈现 RenderedImage，在绘制前进行从图像空间到用户空间的转换。
drawRoundRect(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
用此图形上下文的当前颜色绘制圆角矩形的边框。
drawRoundRect(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawRoundRect。
drawSelectedText(Graphics, int, int, int, int) - 类 javax.swing.text.PasswordView 中的方法
将模型中给定的范围呈现为选定文本。
drawSelectedText(Graphics, int, int, int, int) - 类 javax.swing.text.PlainView 中的方法
将模型中给定的范围呈现为选定文本。
drawSelectedText(Graphics, int, int, int, int) - 类 javax.swing.text.WrappedPlainView 中的方法
将模型中给定的范围呈现为所选文本。
drawString(String, int, int) - 类 java.awt.Graphics 中的方法
使用此图形上下文的当前字体和颜色绘制由指定 string 给定的文本。
drawString(AttributedCharacterIterator, int, int) - 类 java.awt.Graphics 中的方法
依据 TextAttribute 类的规范应用指定迭代器的属性，呈现迭代器的文本。
drawString(String, int, int) - 类 java.awt.Graphics2D 中的方法
使用 Graphics2D 上下文中的当前文本属性状态呈现指定的 String 的文本。
drawString(String, float, float) - 类 java.awt.Graphics2D 中的方法
使用 Graphics2D 上下文中当前文本属性状态呈现由指定 String 指定的文本。
drawString(AttributedCharacterIterator, int, int) - 类 java.awt.Graphics2D 中的方法
依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
drawString(AttributedCharacterIterator, float, float) - 类 java.awt.Graphics2D 中的方法
依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
drawString(String, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawString。
drawString(AttributedCharacterIterator, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.drawString。
drawString(Graphics, String, int, int, int) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
像 g.drawString 那样利用图形 g 在位置 (x,y) 绘制字符串。
drawStringUnderlineCharAt(Graphics, String, int, int, int) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
像 g.drawString 那样利用图形 g 在位置 (x, y) 绘制字符串。
drawTabbedText(Segment, int, int, Graphics, TabExpander, int) - 类 javax.swing.text.Utilities 中的静态方法
使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
drawUnselectedText(Graphics, int, int, int, int) - 类 javax.swing.text.PasswordView 中的方法
将模型中给定的范围呈现为正常的未选定文本。
drawUnselectedText(Graphics, int, int, int, int) - 类 javax.swing.text.PlainView 中的方法
将模型中给定的范围呈现为正常的未选定文本。
drawUnselectedText(Graphics, int, int, int, int) - 类 javax.swing.text.WrappedPlainView 中的方法
将模型中的给定范围呈现为普通未选择的文本。
drawVBuffer - 类 java.awt.Component.FlipBufferStrategy 中的变量
作为可变图像的绘制缓冲区。
Driver - java.sql 中的 接口
每个驱动程序类必须实现的接口。
DriverManager - java.sql 中的 类
管理一组 JDBC 驱动程序的基本服务。
DriverPropertyInfo - java.sql 中的 类
用于建立连接的驱动程序属性。
DriverPropertyInfo(String, String) - 类 java.sql.DriverPropertyInfo 的构造方法
构造一个带有给定名称和值的 DriverPropertyInfo 对象。
drop(DropTargetDropEvent) - 类 java.awt.dnd.DropTarget 中的方法
如果此 DropTarget 处于激活状态，则在已注册的 DropTargetListener 上调用 drop，并将其传递给指定的 DropTargetDropEvent。
drop(DropTargetDropEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
在 drag 操作已终止时调用，此时 drop 处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
dropActionChanged(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceAdapter 中的方法
当用户修改放置操作时调用该方法。
dropActionChanged(DragSourceDragEvent) - 类 java.awt.dnd.DragSourceContext 中的方法
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dropActionChanged，并将指定的 DragSourceDragEvent 传递给它们。
dropActionChanged(DragSourceDragEvent) - 接口 java.awt.dnd.DragSourceListener 中的方法
当用户修改放置操作时调用该方法。
dropActionChanged(DropTargetDragEvent) - 类 java.awt.dnd.DropTarget 中的方法
在已注册的 DropTargetListener 上调用 dropActionChanged，并将其传递给指定的 DropTargetDragEvent。
dropActionChanged(DropTargetDragEvent) - 类 java.awt.dnd.DropTargetAdapter 中的方法
如果用户已经修改了当前的放置操作，则调用该方法。
dropActionChanged(DropTargetDragEvent) - 接口 java.awt.dnd.DropTargetListener 中的方法
在用户已经修改了当前 drop 操作后调用。
dropComplete(boolean) - 类 java.awt.dnd.DropTargetContext 中的方法
此方法指示放置操作完成以及成功与否。
dropComplete(boolean) - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法通知 DragSource drop 传输已完成。
DropMode - javax.swing 中的 枚举
放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
DropTarget - java.awt.dnd 中的 类
在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
DropTarget(Component, int, DropTargetListener, boolean, FlavorMap) - 类 java.awt.dnd.DropTarget 的构造方法
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。
DropTarget(Component, int, DropTargetListener, boolean) - 类 java.awt.dnd.DropTarget 的构造方法
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget() - 类 java.awt.dnd.DropTarget 的构造方法
创建一个 DropTarget
DropTarget(Component, DropTargetListener) - 类 java.awt.dnd.DropTarget 的构造方法
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component, int, DropTargetListener) - 类 java.awt.dnd.DropTarget 的构造方法
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget.DropTargetAutoScroller - java.awt.dnd 中的 类
此受保护的嵌套类实现自动滚动
DropTarget.DropTargetAutoScroller(Component, Point) - 类 java.awt.dnd.DropTarget.DropTargetAutoScroller 的构造方法
构造一个 DropTargetAutoScroller
DropTargetAdapter - java.awt.dnd 中的 类
接收放置目标事件的抽象适配器类。
DropTargetAdapter() - 类 java.awt.dnd.DropTargetAdapter 的构造方法
DropTargetContext - java.awt.dnd 中的 类
每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。
DropTargetContext.TransferableProxy - java.awt.dnd 中的 类
TransferableProxy 是一个帮助器内部类，它实现 Transferable 接口，并用作另一个表示特定 drag-n-drop（拖放）操作数据转换的 Transferable 对象的代理。
DropTargetDragEvent - java.awt.dnd 中的 类
通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
DropTargetDragEvent(DropTargetContext, Point, int, int) - 类 java.awt.dnd.DropTargetDragEvent 的构造方法
在给出此操作的 DropTargetContext、Component 坐标中 "Drag" Cursor 热点的位置、用户 drop 操作和源 drop 操作的情况下，构造一个 DropTargetDragEvent。
DropTargetDropEvent - java.awt.dnd 中的 类
通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext, Point, int, int) - 类 java.awt.dnd.DropTargetDropEvent 的构造方法
在给出此操作的 DropTargetContext、Component 坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作和当前受源对象支持的操作集合的情况下，构造一个 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext, Point, int, int, boolean) - 类 java.awt.dnd.DropTargetDropEvent 的构造方法
在给出此操作的 DropTargetContext、Component 的坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作、当前受源对象支持的操作集合，以及一个指示源对象与目标对象是否在同一 JVM 中的 boolean 值的情况下，构造一个 DropTargetEvent。
DropTargetEvent - java.awt.dnd 中的 类
DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。
DropTargetEvent(DropTargetContext) - 类 java.awt.dnd.DropTargetEvent 的构造方法
构造一个具有指定 DropTargetContext 的 DropTargetEvent。
DropTargetListener - java.awt.dnd 中的 接口
DropTargetListener 接口是 DropTarget 类所使用的回调接口，用于提供所涉及的 DropTarget 的 DnD 操作的通知。
DSA_SHA1 - 接口 javax.xml.crypto.dsig.SignatureMethod 中的静态变量
DSAwithSHA1 (DSS) 签名方法的算法 URI。
DSA_TYPE - 接口 javax.xml.crypto.dsig.keyinfo.KeyValue 中的静态变量
标识 DSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#DSAKeyValue。
DSAKey - java.security.interfaces 中的 接口
DSA 公用或专用密钥的接口。
DSAKeyPairGenerator - java.security.interfaces 中的 接口
能够生成 DSA 密钥对的对象的接口。
DSAParameterSpec - java.security.spec 中的 类
此类指定用于 DSA 算法的参数的集合。
DSAParameterSpec(BigInteger, BigInteger, BigInteger) - 类 java.security.spec.DSAParameterSpec 的构造方法
创建一个具有指定参数值的新的 DSAParameterSpec。
DSAParams - java.security.interfaces 中的 接口
特定于 DSA 的密钥参数集的接口，它定义 DSA 密钥系列。
DSAPrivateKey - java.security.interfaces 中的 接口
DSA 专用密钥的标准接口。
DSAPrivateKeySpec - java.security.spec 中的 类
此类指定带关联参数的 DSA 专用密钥。
DSAPrivateKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - 类 java.security.spec.DSAPrivateKeySpec 的构造方法
创建一个具有指定参数值的新 DSAPrivateKeySpec。
DSAPublicKey - java.security.interfaces 中的 接口
DSA 公用密钥的接口。
DSAPublicKeySpec - java.security.spec 中的 类
此类指定带关联参数的 DSA 公用密钥。
DSAPublicKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - 类 java.security.spec.DSAPublicKeySpec 的构造方法
创建一个具有指定参数值的新 DSAPublicKeySpec。
DST - 类 java.awt.AlphaComposite 中的静态变量
目标色不变（Porter-Duff Destination 规则）。
Dst - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DST_ATOP - 类 java.awt.AlphaComposite 中的静态变量
在源色之上合成源色中的目标色部分，并将替换目标色（Porter-Duff Destination Atop Source 规则）。
DST_IN - 类 java.awt.AlphaComposite 中的静态变量
源色中的目标色部分将替换目标色（Porter-Duff Destination In Source 规则）。
DST_OFFSET - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，以毫秒为单位指示夏令时的偏移量。
DST_OUT - 类 java.awt.AlphaComposite 中的静态变量
源色以外的目标色部分将替换目标色（Porter-Duff Destination Held Out By Source 规则）。
DST_OVER - 类 java.awt.AlphaComposite 中的静态变量
在源色之上合成目标色，产生的结果将替代目标色（Porter-Duff Destination Over Source 规则）。
DstAtop - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DstIn - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DstOut - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DstOver - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 DST_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
DT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
DTD - javax.swing.text.html.parser 中的 类
SGML DTD 的表示形式。
DTD(String) - 类 javax.swing.text.html.parser.DTD 的构造方法
创建具有指定名称的新 DTD。
dtd - 类 javax.swing.text.html.parser.Parser 中的变量
DTD - javax.xml.stream.events 中的 接口
它是处理 DTD 的事件的顶层接口。
DTD - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个 DTD
DTDConstants - javax.swing.text.html.parser 中的 接口
DTD 中使用的 SGML 常量。
DTDHandler - org.xml.sax 中的 接口
接收基本的 DTD 相关的事件的通知。
DUMMY - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
dump(PrintStream, int) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
转储该元素层次结构的调试表示形式。
dump(PrintStream) - 类 javax.swing.text.AbstractDocument 中的方法
提供诊断转储 (dump)。
dumpAllThreads(boolean, boolean) - 接口 java.lang.management.ThreadMXBean 中的方法
返回所有活动线程的线程信息，并带有堆栈跟踪和同步信息。
dumpStack() - 类 java.lang.Thread 中的静态方法
将当前线程的堆栈跟踪打印至标准错误流。
DUPLEX - 类 javax.print.attribute.standard.Sides 中的静态变量
“双面长边”的别名（请参阅 TWO_SIDED_LONG_EDGE）。
duplicate() - 类 java.nio.ByteBuffer 中的方法
创建共享此缓冲区内容的新的字节缓冲区。
duplicate() - 类 java.nio.CharBuffer 中的方法
创建共享此缓冲区内容的新的字符缓冲区。
duplicate() - 类 java.nio.DoubleBuffer 中的方法
创建共享此缓冲区内容的新的 double 缓冲区。
duplicate() - 类 java.nio.FloatBuffer 中的方法
创建共享此缓冲区内容的新的 float 缓冲区。
duplicate() - 类 java.nio.IntBuffer 中的方法
创建共享此缓冲区内容的新的 int 缓冲区。
duplicate() - 类 java.nio.LongBuffer 中的方法
创建共享此缓冲区内容的新的 long 缓冲区。
duplicate() - 类 java.nio.ShortBuffer 中的方法
创建共享此缓冲区内容的新的 short 缓冲区。
duplicate(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回所提供对象引用的复本。
DUPLICATE_ELEMENT - 异常 org.ietf.jgss.GSSException 中的静态变量
请求了重复的凭据元素。
DUPLICATE_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
该标记是前面标记的一个副本。
DuplicateFormatFlagsException - java.util 中的 异常
格式说明符中提供重复标志时抛出的未经检查的异常。
DuplicateFormatFlagsException(String) - 异常 java.util.DuplicateFormatFlagsException 的构造方法
构造带指定标志的此类的一个实例。
DuplicateName - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 异常
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。
DuplicateName() - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 的构造方法
DuplicateName(String) - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 的构造方法
DuplicateName(String, String) - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 的构造方法
DuplicateNameHelper - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 类
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java。
DuplicateNameHelper() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 的构造方法
DURATION - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式数据类型 duration 的完全限定名称。
Duration - javax.xml.datatype 中的 类
W3C XML 模式 1.0 规范中定义的时间范围的不可变表示形式。
Duration() - 类 javax.xml.datatype.Duration 的构造方法
默认的无参数构造方法。
DURATION_DAYTIME - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
XQuery 1.0 和 Path 2.0 数据类型 dayTimeDuration 的完全限定名称。
DURATION_YEARMONTH - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
XQuery 1.0 和 XPath 2.0 数据类型 yearMonthDuration 的完全限定名称。
DYNAMIC_SOAP_PROTOCOL - 接口 javax.xml.soap.SOAPConstants 中的静态变量
用于创建 MessageFactory 实例，该实例可创建 SOAPMessages，SOAPMessages 的具体类型取决于传递给 createMessage 方法的 Content-Type MIME 头。
DynamicImplementation - org.omg.CORBA 中的 类
已过时。 org.omg.CORBA.DynamicImplementation
DynamicImplementation() - 类 org.omg.CORBA.DynamicImplementation 的构造方法
已过时。
DynamicImplementation - org.omg.PortableServer 中的 类
允许动态处理对象调用。
DynamicImplementation() - 类 org.omg.PortableServer.DynamicImplementation 的构造方法
DynamicMBean - javax.management 中的 接口
定义了 Dynamic MBean（公开了动态管理接口的 MBean）应该实现的各个方法。
DynAny - org.omg.CORBA 中的 接口
已过时。 使用新的 DynAny 替代
DynAny - org.omg.DynamicAny 中的 接口
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnyFactory - org.omg.DynamicAny 中的 接口
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyFactoryHelper - org.omg.DynamicAny 中的 类
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyFactoryHelper() - 类 org.omg.DynamicAny.DynAnyFactoryHelper 的构造方法
DynAnyFactoryOperations - org.omg.DynamicAny 中的 接口
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
DynAnyHelper - org.omg.DynamicAny 中的 类
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnyHelper() - 类 org.omg.DynamicAny.DynAnyHelper 的构造方法
DynAnyOperations - org.omg.DynamicAny 中的 接口
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
DynAnySeqHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/DynAnySeqHelper.java。
DynAnySeqHelper() - 类 org.omg.DynamicAny.DynAnySeqHelper 的构造方法
DynArray - org.omg.CORBA 中的 接口
已过时。 使用新的 DynArray 替代
DynArray - org.omg.DynamicAny 中的 接口
DynArray 对象支持对 IDL 数组的操作。
DynArrayHelper - org.omg.DynamicAny 中的 类
DynArray 对象支持对 IDL 数组的操作。
DynArrayHelper() - 类 org.omg.DynamicAny.DynArrayHelper 的构造方法
DynArrayOperations - org.omg.DynamicAny 中的 接口
DynArray 对象支持对 IDL 数组的操作。
DynEnum - org.omg.CORBA 中的 接口
已过时。 使用新的 DynEnum 替代
DynEnum - org.omg.DynamicAny 中的 接口
DynEnum 对象支持对 IDL 枚举值的操作。
DynEnumHelper - org.omg.DynamicAny 中的 类
DynEnum 对象支持对 IDL 枚举值的操作。
DynEnumHelper() - 类 org.omg.DynamicAny.DynEnumHelper 的构造方法
DynEnumOperations - org.omg.DynamicAny 中的 接口
DynEnum 对象支持对 IDL enumerated value 的操作。
DynFixed - org.omg.CORBA 中的 接口
已过时。 使用新的 DynFixed 替代
DynFixed - org.omg.DynamicAny 中的 接口
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
DynFixedHelper - org.omg.DynamicAny 中的 类
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
DynFixedHelper() - 类 org.omg.DynamicAny.DynFixedHelper 的构造方法
DynFixedOperations - org.omg.DynamicAny 中的 接口
DynFixed 对象支持对 IDL 定值的操作。
DynSequence - org.omg.CORBA 中的 接口
已过时。 使用新的 DynSequence 替代
DynSequence - org.omg.DynamicAny 中的 接口
DynSequence 对象支持对 IDL 序列的操作。
DynSequenceHelper - org.omg.DynamicAny 中的 类
DynSequence 对象支持对 IDL 序列的操作。
DynSequenceHelper() - 类 org.omg.DynamicAny.DynSequenceHelper 的构造方法
DynSequenceOperations - org.omg.DynamicAny 中的 接口
DynSequence 对象支持对 IDL 序列的操作。
DynStruct - org.omg.CORBA 中的 接口
已过时。 使用新的 DynStruct 替代
DynStruct - org.omg.DynamicAny 中的 接口
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
DynStructHelper - org.omg.DynamicAny 中的 类
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
DynStructHelper() - 类 org.omg.DynamicAny.DynStructHelper 的构造方法
DynStructOperations - org.omg.DynamicAny 中的 接口
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常 (exception) 值的操作。
DynUnion - org.omg.CORBA 中的 接口
已过时。 使用新的 DynUnion 替代
DynUnion - org.omg.DynamicAny 中的 接口
DynUnion 对象支持对 IDL 联合 (union) 的操作。
DynUnionHelper - org.omg.DynamicAny 中的 类
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
DynUnionHelper() - 类 org.omg.DynamicAny.DynUnionHelper 的构造方法
DynUnionOperations - org.omg.DynamicAny 中的 接口
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
DynValue - org.omg.CORBA 中的 接口
已过时。 使用新的 DynValue 替代
DynValue - org.omg.DynamicAny 中的 接口
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
DynValueBox - org.omg.DynamicAny 中的 接口
DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
DynValueBoxOperations - org.omg.DynamicAny 中的 接口
DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
DynValueCommon - org.omg.DynamicAny 中的 接口
DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
DynValueCommonOperations - org.omg.DynamicAny 中的 接口
DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。
DynValueHelper - org.omg.DynamicAny 中的 类
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
DynValueHelper() - 类 org.omg.DynamicAny.DynValueHelper 的构造方法
DynValueOperations - org.omg.DynamicAny 中的 接口
DynValue 对象支持对 IDL 非装箱 (boxed) 值类型的支持。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


E - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

E

E - 类 java.awt.PageAttributes.MediaType 中的静态变量
Engineering E (34 x 44 in) 的 MediaType 实例。
E - 类 java.lang.Math 中的静态变量
比任何其他值都更接近 e（即自然对数的底数）的 double 值。
E - 类 java.lang.StrictMath 中的静态变量
比任何其他值都更接近 e（即自然对数的底数）的 double 值。
E - 类 javax.print.attribute.standard.MediaSize.Engineering 中的静态变量
指定 engineering E 尺寸，34 inch × 44 inch。
E - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
E 尺寸。
E_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口右边框大小的光标类型。
E_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.E_RESIZE_CURSOR 取代。
EAST - 类 java.awt.BorderLayout 中的静态变量
东区域的布局约束（容器右边）。
EAST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的右部，并在垂直方向上居中。
EAST - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的右边。
EAST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向东（右）。
EASTERN_ARABIC - 类 java.awt.font.NumericShaper 中的静态变量
标识 ARABIC 范围和 ARABIC_EXTENDED 十进制基数。
eastPane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
ECField - java.security.spec 中的 接口
此接口表示椭圆曲线 (EC) 有限字段。
ECFieldF2m - java.security.spec 中的 类
此不可变类定义椭圆曲线 (EC) 首数为 2 的有限字段。
ECFieldF2m(int) - 类 java.security.spec.ECFieldF2m 的构造方法
使用常规方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldF2m(int, BigInteger) - 类 java.security.spec.ECFieldF2m 的构造方法
使用多项式方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldF2m(int, int[]) - 类 java.security.spec.ECFieldF2m 的构造方法
使用多项式方法创建椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldFp - java.security.spec 中的 类
此不可变类定义椭圆曲线 (EC) 素数的有限字段。
ECFieldFp(BigInteger) - 类 java.security.spec.ECFieldFp 的构造方法
根据指定的素数 p 创建一个椭圆曲线素数的有限字段。
ECGenParameterSpec - java.security.spec 中的 类
此不可变类指定用于生成椭圆曲线 (EC) 域参数的参数集。
ECGenParameterSpec(String) - 类 java.security.spec.ECGenParameterSpec 的构造方法
使用标准的（或预定义的）名称 stdName 创建用于 EC 参数生成的参数规范，以便生成相应的（预计算的）椭圆曲线域参数。
echoCharIsSet() - 类 java.awt.TextField 中的方法
指示此文本字段是否有一个回显字符集。
echoCharIsSet() - 类 javax.swing.JPasswordField 中的方法
如果此 JPasswordField 具有为回显设置的字符，则返回 true。
ECKey - java.security.interfaces 中的 接口
椭圆曲线 (EC) 密钥的接口。
ECParameterSpec - java.security.spec 中的 类
此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。
ECParameterSpec(EllipticCurve, ECPoint, BigInteger, int) - 类 java.security.spec.ECParameterSpec 的构造方法
创建基于指定值的椭圆曲线域参数。
ECPoint - java.security.spec 中的 类
此不可变类在仿射坐标中表示椭圆曲线 (EC) 上的点。
ECPoint(BigInteger, BigInteger) - 类 java.security.spec.ECPoint 的构造方法
根据指定的仿射 x 坐标 x 和仿射 y 坐标 y 创建 ECPoint。
ECPrivateKey - java.security.interfaces 中的 接口
椭圆曲线 (EC) 专用密钥的接口。
ECPrivateKeySpec - java.security.spec 中的 类
此不可变类指定带关联参数的椭圆曲线专用密钥。
ECPrivateKeySpec(BigInteger, ECParameterSpec) - 类 java.security.spec.ECPrivateKeySpec 的构造方法
使用指定的参数值创建一个新的 ECPrivateKeySpec。
ECPublicKey - java.security.interfaces 中的 接口
椭圆曲线 (EC) 公用密钥的接口。
ECPublicKeySpec - java.security.spec 中的 类
此不可变类指定带关联参数的椭圆曲线公用密钥。
ECPublicKeySpec(ECPoint, ECParameterSpec) - 类 java.security.spec.ECPublicKeySpec 的构造方法
根据指定参数值，创建一个新的 ECPublicKeySpec。
EDGE_NO_OP - 类 java.awt.image.ConvolveOp 中的静态变量
将位于源图像边缘的像素复制为目标中相应的像素，不加修改。
EDGE_SPACING - 类 javax.swing.border.TitledBorder 中的静态变量
EDGE_STITCH - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿某个边的一个或多个装订点（金属针脚）绑定。
EDGE_STITCH_BOTTOM - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿底边的一个或多个装订点（金属针脚）绑定。
EDGE_STITCH_LEFT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿左边的一个或多个装订点（金属针脚）绑定。
EDGE_STITCH_RIGHT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿右边的一个或多个装订点（金属针脚）绑定。
EDGE_STITCH_TOP - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿顶边的一个或多个装订点（金属针脚）绑定。
EDGE_ZERO_FILL - 类 java.awt.image.ConvolveOp 中的静态变量
位于目标图像边缘的像素被设置为 0。
edit(File) - 类 java.awt.Desktop 中的方法
启动关联编辑器应用程序并打开用于编辑的文件。
EDITABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示用户可以更改此对象的内容。
editable - 类 javax.swing.JTree 中的变量
树是否可以编辑？默认值为 false。
EDITABLE_PROPERTY - 类 javax.swing.JTree 中的静态变量
editable 的绑定属性名称。
editablePropertyChanged(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
已过时。 从 Java 2 platform v1.4 开始。
EDITBAR - 类 javax.accessibility.AccessibleRole 中的静态变量
该职责表示充当一个求值公式的对象。
editCellAt(int, int) - 类 javax.swing.JTable 中的方法
如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。
editCellAt(int, int, EventObject) - 类 javax.swing.JTable 中的方法
如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。
editingCanceled(ChangeEvent) - 接口 javax.swing.event.CellEditorListener 中的方法
此方法告知侦听器编辑器已经取消编辑
editingCanceled(ChangeEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
编辑取消时调用。
editingCanceled(ChangeEvent) - 类 javax.swing.JTable 中的方法
编辑取消时调用。
editingCanceled(ChangeEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 中的方法
在树中取消编辑时传递消息。
editingColumn - 类 javax.swing.JTable 中的变量
标识所编辑的单元格的列。
editingComponent - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
编辑时，它将是进行实际编辑的 Component。
editingComponent - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
用于编辑的组件，从 editingContainer 获取。
editingContainer - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
将包含 editorComponent 的编辑容器。
editingIcon - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
编辑时要使用的图标。
editingPath - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要编辑的路径。
editingRow - 类 javax.swing.JTable 中的变量
标识所编辑的单元格的行。
editingRow - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要编辑的行。
editingStopped(ChangeEvent) - 接口 javax.swing.event.CellEditorListener 中的方法
此方法告知侦听器编辑器已经结束编辑
editingStopped(ChangeEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪单元格内容的变更。
editingStopped(ChangeEvent) - 类 javax.swing.JTable 中的方法
编辑结束时调用。
editingStopped(ChangeEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler 中的方法
在树中停止编辑时传递消息。
editor - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
editor - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的变量
editor - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
EDITOR_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
EditorPane 的 region。
editorBorderInsets - 类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 中的变量
editorBorderInsets - 类 javax.swing.plaf.metal.MetalComboBoxEditor 中的静态变量
默认编辑器边框 Insets。
editorComp - 类 javax.swing.JTable 中的变量
在编辑时处理编辑的 Component。
editorComponent - 类 javax.swing.DefaultCellEditor 中的变量
正被编辑的 Swing 组件。
EditorContainer() - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 中的方法
editorHasDifferentSize - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
如果编辑器的大小不同于渲染器，则设置为 true。
EditorKit - javax.swing.text 中的 类
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
EditorKit() - 类 javax.swing.text.EditorKit 的构造方法
构造一个 EditorKit。
edits - 类 javax.swing.undo.CompoundEdit 中的变量
由此 CompoundEdit 全部撤消/恢复的 UndoableEdit 的集合。
editToBeRedone() - 类 javax.swing.undo.UndoManager 中的方法
如果调用 redo，则返回下一个要恢复的有效编辑。
editToBeUndone() - 类 javax.swing.undo.UndoManager 中的方法
如果调用 undo，则返回下一个要撤消的有效编辑。
effective_profile() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回将用来发送请求的配置文件。
effective_target() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回实际调用操作的对象。
EFFORT - 接口 java.util.jar.Pack200.Packer 中的静态变量
如果将此属性设置为单个十进制数字，则打包器将在压缩存档时使用指定压缩级别。
element() - 异常 java.lang.annotation.AnnotationTypeMismatchException 中的方法
返回类型不正确的元素的 Method 对象。
element() - 类 java.util.AbstractQueue 中的方法
获取但不移除此队列的头。
element() - 类 java.util.ArrayDeque 中的方法
获取，但不移除此双端队列所表示的队列的头。
element() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）。
element() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
获取但不移除此双端队列表示的队列的头部。
element() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）。
element() - 类 java.util.LinkedList 中的方法
获取但不移除此列表的头（第一个元素）。
element() - 接口 java.util.Queue 中的方法
获取，但是不移除此队列的头。
Element - javax.lang.model.element 中的 接口
表示一个程序元素，比如包、类或者方法。
element - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的变量
Element - javax.swing.text 中的 接口
描述文档的结构元素的接口。
Element - javax.swing.text.html.parser 中的 类
使用 ELEMENT 构造在 DTD 中描述的一个元素。
Element - javax.xml.bind 中的 接口
这是一个元素标记接口。
Element - org.w3c.dom 中的 接口
Element 接口表示 HTML 或 XML 文档中的一个元素。
ELEMENT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Element。
elementAt(int) - 类 java.util.Vector 中的方法
返回指定索引处的组件。
elementAt(int) - 类 javax.swing.DefaultListModel 中的方法
返回指定索引处的组件。
elementCount - 类 java.util.Vector 中的变量
Vector 对象中的有效组件数。
elementCount - 类 javax.management.monitor.Monitor 中的变量
被观察对象的向量中的有效组件数。
elementCountToTag(HTMLDocument, int, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法
返回要获得表示 tag 的元素时，从最深的叶元素开始所需的元素数。
elementData - 类 java.util.Vector 中的变量
存储向量组件的数组缓冲区。
elementDecl(String, String) - 接口 org.xml.sax.ext.DeclHandler 中的方法
报告元素类型声明。
elementDecl(String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
ElementFilter - javax.lang.model.util 中的 类
用来从元素集合中只选择所需元素的过滤器。
elementHash - 类 javax.swing.text.html.parser.DTD 中的变量
ElementIterator - javax.swing.text 中的 类
ElementIterator，顾名思义，沿 Element 树进行迭代。
ElementIterator(Document) - 类 javax.swing.text.ElementIterator 的构造方法
创建新的 ElementIterator。
ElementIterator(Element) - 类 javax.swing.text.ElementIterator 的构造方法
创建新的 ElementIterator。
ElementKind - javax.lang.model.element 中的 枚举
元素的 kind。
ElementKindVisitor6<R,P> - javax.lang.model.util 中的 类
基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
ElementKindVisitor6() - 类 javax.lang.model.util.ElementKindVisitor6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
ElementKindVisitor6(R) - 类 javax.lang.model.util.ElementKindVisitor6 的构造方法
具体子类的构造方法；使用参数作为默认值。
elementName() - 异常 java.lang.annotation.IncompleteAnnotationException 中的方法
返回缺少元素的名称。
ElementNameAttribute - 类 javax.swing.text.AbstractDocument 中的静态变量
用于指定元素名的属性名。
elements() - 类 java.security.PermissionCollection 中的方法
返回集合中所有 Permission 对象的枚举。
elements() - 类 java.security.Permissions 中的方法
返回此 Permissions 对象中所有 PermissionCollection 中的所有 Permission 对象的枚举。
elements() - 类 java.security.Provider 中的方法
elements() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此表中值的枚举。
elements() - 类 java.util.Dictionary 中的方法
返回此 dictionary 中值的枚举。
elements() - 类 java.util.Hashtable 中的方法
返回此哈希表中的值的枚举。
elements() - 类 java.util.Vector 中的方法
返回此向量的组件的枚举。
Elements - javax.lang.model.util 中的 接口
用来对程序元素进行操作的实用工具方法。
elements() - 类 javax.swing.DefaultListModel 中的方法
返回此列表的组件枚举。
elements - 类 javax.swing.text.html.parser.DTD 中的变量
ElementScanner6<R,P> - javax.lang.model.util 中的 类
程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
ElementScanner6() - 类 javax.lang.model.util.ElementScanner6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
ElementScanner6(R) - 类 javax.lang.model.util.ElementScanner6 的构造方法
具体子类的构造方法；使用参数作为默认值。
ElementType - java.lang.annotation 中的 枚举
程序元素类型。
ElementVisitor<R,P> - javax.lang.model.element 中的 接口
程序元素的 visitor，使用 visitor 设计模式的样式。
Ellipse2D - java.awt.geom 中的 类
Ellipse2D 类描述窗体矩形定义的椭圆。
Ellipse2D() - 类 java.awt.geom.Ellipse2D 的构造方法
这是一个无法直接实例化的抽象类。
Ellipse2D.Double - java.awt.geom 中的 类
Double 类以 double 精度定义椭圆。
Ellipse2D.Double() - 类 java.awt.geom.Ellipse2D.Double 的构造方法
构造一个新 Ellipse2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Ellipse2D.Double(double, double, double, double) - 类 java.awt.geom.Ellipse2D.Double 的构造方法
根据指定坐标构造和初始化 Ellipse2D。
Ellipse2D.Float - java.awt.geom 中的 类
Float 类以 float 精度定义椭圆。
Ellipse2D.Float() - 类 java.awt.geom.Ellipse2D.Float 的构造方法
构造一个新 Ellipse2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Ellipse2D.Float(float, float, float, float) - 类 java.awt.geom.Ellipse2D.Float 的构造方法
根据指定坐标构造和初始化 Ellipse2D。
EllipticCurve - java.security.spec 中的 类
此不可变类持有表示椭圆曲线所必需的值。
EllipticCurve(ECField, BigInteger, BigInteger) - 类 java.security.spec.EllipticCurve 的构造方法
使用指定的椭圆字段 field 以及系数 a 和 b 创建椭圆曲线。
EllipticCurve(ECField, BigInteger, BigInteger, byte[]) - 类 java.security.spec.EllipticCurve 的构造方法
使用指定的椭圆字段 field、系数 a 和 b，以及用于生成曲线的 seed 创建椭圆曲线。
EM - 类 javax.swing.text.html.HTML.Tag 中的静态变量
EMBEDDED_BY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象嵌入一个或多个对象。
EMBEDDED_BY_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 EMBEDDED_BY 关系已更改。
EMBEDS - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象具有一个或多个嵌入它的对象。
EMBEDS_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 EMBEDS 关系已更改。
empty() - 类 java.util.Stack 中的方法
测试堆栈是否为空。
empty() - 类 javax.swing.text.html.parser.ContentModel 中的方法
如果内容模式可以匹配一个空输入流，则返回 true。
EMPTY - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
EMPTY - 类 javax.swing.text.SimpleAttributeSet 中的静态变量
空的属性集。
EMPTY_DESCRIPTOR - 类 javax.management.ImmutableDescriptor 中的静态变量
空描述符。
EMPTY_ENUMERATION - 类 javax.swing.tree.DefaultMutableTreeNode 中的静态变量
始终为空的枚举。
EMPTY_LIST - 类 java.util.Collections 中的静态变量
空的列表（不可变的）。
EMPTY_MAP - 类 java.util.Collections 中的静态变量
空的映射（不可变的）。
EMPTY_SET - 类 java.util.Collections 中的静态变量
空的 set（不可变的）。
EmptyBorder - javax.swing.border 中的 类
该类提供了一个占用空间但不执行绘制的空透明边框。
EmptyBorder(int, int, int, int) - 类 javax.swing.border.EmptyBorder 的构造方法
创建具有指定 insets 的空边框
EmptyBorder(Insets) - 类 javax.swing.border.EmptyBorder 的构造方法
创建具有指定 insets 的空边框
emptyList() - 类 java.util.Collections 中的静态方法
返回空的列表（不可变的）。
emptyMap() - 类 java.util.Collections 中的静态方法
返回空的映射（不可变的）。
emptySet() - 类 java.util.Collections 中的静态方法
返回空的 set（不可变的）。
EmptyStackException - java.util 中的 异常
该异常由 Stack 类中的方法抛出，以表明堆栈为空。
EmptyStackException() - 异常 java.util.EmptyStackException 的构造方法
构造一个将 null 作为其错误消息字符串的新 EmptyStackException。
emptyTag(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出所有空元素（没有对应结束标记的所有标记）。
enable() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
enable(boolean) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
enable() - 类 java.awt.MenuItem 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
enable(boolean) - 类 java.awt.MenuItem 中的方法
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
enable() - 类 java.lang.Compiler 中的静态方法
使编译器恢复操作。
enable() - 类 javax.swing.JComponent 中的方法
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
enableActions() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
enableAllObjectNames() - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
启用所有 MBeanServerNotification（选中所有 ObjectName）。
enableAttribute(String) - 类 javax.management.AttributeChangeNotificationFilter 中的方法
启用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定名称。
enableClientWindowNotification(InputMethod, boolean) - 接口 java.awt.im.spi.InputMethodContext 中的方法
启用或禁用指定输入方法的当前客户端窗口位置或状态的通知。
ENABLED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是启用的。
enabled - 类 javax.swing.AbstractAction 中的变量
指定是否启用操作；默认值为 true。
ENABLED - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“启用的”位，该位指示可以通过输入设备（如鼠标指针）选择按钮。
ENABLED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示组件被启用的基本状态。
enableEvents(long) - 类 java.awt.Component 中的方法
启用由传递给此组件的指定事件掩码参数所定义的事件。
enableEvents(long) - 类 java.awt.MenuItem 中的方法
允许将事件提交到将由指定事件掩码参数定义的事件的菜单项。
enableInputMethods(boolean) - 类 java.awt.Component 中的方法
启用或禁用此组件的输入方法支持。
enableInputMethods(boolean) - 类 java.awt.TextComponent 中的方法
启用或禁用此文本组件的输入法支持。
enableObjectName(ObjectName) - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
启用与给定 ObjectName 有关的 MBeanServerNotification。
enableReplaceObject(boolean) - 类 java.io.ObjectOutputStream 中的方法
允许流对流中的对象进行替换。
enableResizedPosting() - 类 javax.swing.table.TableColumn 中的方法
已过时。 从 Java 2 platform v1.3 开始
enableResolveObject(boolean) - 类 java.io.ObjectInputStream 中的方法
使流允许从该流读取的对象被替代。
enableType(String) - 类 javax.management.NotificationFilterSupport 中的方法
允许将其类型以指定前缀开始的所有通知发送到该侦听器。
ENCLOSED_ALPHANUMERICS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Enclosed Alphanumerics”Unicode 字符块的常量。
ENCLOSED_CJK_LETTERS_AND_MONTHS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Enclosed CJK Letters and Months”Unicode 字符块的常量。
ENCLOSING_MARK - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Me”。
encode(String) - 类 java.net.URLEncoder 中的静态方法
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。
encode(String, String) - 类 java.net.URLEncoder 中的静态方法
使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。
encode(CharBuffer) - 类 java.nio.charset.Charset 中的方法
将此 charset 中的 Unicode 字符编码成字节的便捷方法。
encode(String) - 类 java.nio.charset.Charset 中的方法
将此 charset 中的字符串编码成字节的便捷方法。
encode(CharBuffer, ByteBuffer, boolean) - 类 java.nio.charset.CharsetEncoder 中的方法
从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
encode(CharBuffer) - 类 java.nio.charset.CharsetEncoder 中的方法
把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
encode(OutputStream) - 接口 java.security.Certificate 中的方法
已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
encode(Any) - 接口 org.omg.IOP.CodecOperations 中的方法
基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
encode_value(Any) - 接口 org.omg.IOP.CodecOperations 中的方法
基于对此 Codec 有效的编码格式，将给定的 any 转换为一个 byte 数组。
encodeDataFlavor(DataFlavor) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
编码 DataFlavor 以用作 String native。
EncodedKeySpec - java.security.spec 中的 类
此类用编码格式表示公用密钥或专用密钥。
EncodedKeySpec(byte[]) - 类 java.security.spec.EncodedKeySpec 的构造方法
根据给定的编码密钥创建一个新的 EncodedKeySpec。
encodedParams - 类 javax.crypto.SealedObject 中的变量
由密封 Cipher 使用的加密参数，以默认格式进行编码。
encodeJavaMIMEType(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
编码 MIME 类型以用作 String native。
encodeLoop(CharBuffer, ByteBuffer) - 类 java.nio.charset.CharsetEncoder 中的方法
将一个或多个字符编码为一个或多个字节。
Encoder - java.beans 中的 类
Encoder 是这样的类，它可用于创建根据其公共 API 对 JavaBeans 集合状态进行编码的文件或流。
Encoder() - 类 java.beans.Encoder 的构造方法
encoding - 类 javax.sound.sampled.AudioFormat 中的变量
此格式使用的音频编码技术。
ENCODING - 类 javax.xml.transform.OutputKeys 中的静态变量
encoding = string. encoding 指定了首选的字符编码，Transformer 应使用此编码将字符序列编码作为字节序列进行编码。
Encoding - org.omg.IOP 中的 类
org/omg/IOP/Encoding.java。
Encoding() - 类 org.omg.IOP.Encoding 的构造方法
Encoding(short, byte, byte) - 类 org.omg.IOP.Encoding 的构造方法
ENCODING_CDR_ENCAPS - org.omg.IOP 中的 接口
org/omg/IOP/ENCODING_CDR_ENCAPS.java。
encodingSet() - 接口 javax.xml.stream.events.StartDocument 中的方法
如果在文档的编码声明中设置了 CharacterEncodingScheme，则返回 true。
ENCRYPT - 类 javax.xml.crypto.KeySelector.Purpose 中的静态变量
用于加密的密钥。
ENCRYPT_MODE - 类 javax.crypto.Cipher 中的静态变量
用于将 Cipher 初始化为加密模式的常量。
EncryptedPrivateKeyInfo - javax.crypto 中的 类
此类实现 EncryptedPrivateKeyInfo 类型，如在 PKCS #8 中定义的那样。
EncryptedPrivateKeyInfo(byte[]) - 类 javax.crypto.EncryptedPrivateKeyInfo 的构造方法
根据其 ASN.1 编码构造（即解析）EncryptedPrivateKeyInfo。
EncryptedPrivateKeyInfo(String, byte[]) - 类 javax.crypto.EncryptedPrivateKeyInfo 的构造方法
根据加密算法名称和加密数据构造 EncryptedPrivateKeyInfo。
EncryptedPrivateKeyInfo(AlgorithmParameters, byte[]) - 类 javax.crypto.EncryptedPrivateKeyInfo 的构造方法
根据加密算法参数和加密数据构造 EncryptedPrivateKeyInfo。
ENCTYPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
END - 类 java.awt.Event 中的静态变量
End 键，一个非 ASCII 操作键。
end() - 类 java.awt.PrintJob 中的方法
终止打印作业并进行必要的清除操作。
end(boolean) - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
标记可能无限期阻塞的 I/O 操作的结尾。
end() - 类 java.nio.channels.spi.AbstractSelector 中的方法
标记可能无限期阻塞的 I/O 操作的结束。
end() - 类 java.util.regex.Matcher 中的方法
返回最后匹配字符之后的偏移量。
end(int) - 类 java.util.regex.Matcher 中的方法
返回在以前的匹配操作期间，由给定组所捕获子序列的最后字符之后的偏移量。
end() - 接口 java.util.regex.MatchResult 中的方法
返回最后匹配字符之后的偏移量。
end(int) - 接口 java.util.regex.MatchResult 中的方法
返回在匹配期间由给定组所捕获子序列的最后字符之后的偏移量。
end() - 类 java.util.zip.Deflater 中的方法
关闭解压缩器并放弃所有未处理的输入。
end() - 类 java.util.zip.Inflater 中的方法
关闭解压缩器并放弃所有未处理的输入。
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 中的方法
end(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 中的方法
当发现此动作所注册的标记类型的结束标记时调用。
end() - 类 javax.swing.undo.CompoundEdit 中的方法
将 inProgress 设置为 false。
end() - 类 javax.swing.undo.StateEdit 中的方法
获取 StateEditable 对象的后编辑状态，并结束编辑。
end() - 类 javax.swing.undo.UndoManager 中的方法
将此 UndoManager 转换为标准 CompoundEdit。
end(Xid, int) - 接口 javax.transaction.xa.XAResource 中的方法
终止代表事务分支所执行的工作。
END_DOCUMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个结束文档
END_ELEMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个结束元素
END_OF_EXCLUSIVE - 类 javax.sound.midi.ShortMessage 中的静态变量
End of System Exclusive 消息的状态字节（0xF7 或 247）。
END_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pe”。
end_value() - 接口 org.omg.CORBA.portable.ValueInputStream 中的方法
end_value 方法读取嵌套自定义 valuetype 的结束标记（在跳过结束标记之前的所有数据后）并将 valuetype 嵌套层次加 1。
end_value() - 接口 org.omg.CORBA.portable.ValueOutputStream 中的方法
end_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的结束标记，并将 valuetype 嵌套层次减 1。
endAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到文档末尾的 Action 名称。
endCDATA() - 类 org.xml.sax.ext.DefaultHandler2 中的方法
endCDATA() - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告 CDATA 节的结束。
endComposition() - 类 java.awt.im.InputContext 中的方法
结束当前可能在此上下文进行的任何输入撰写。
endComposition() - 接口 java.awt.im.spi.InputMethod 中的方法
结束当前可能在此上下文中正进行的任何输入撰写。
EndDocument - javax.xml.stream.events 中的 接口
文档结尾的标记接口。
endDocument() - 接口 org.xml.sax.ContentHandler 中的方法
接收文档的结尾的通知。
endDocument() - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收文档结束的通知。
endDocument() - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收文档结束的通知。
endDocument() - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收文档结束的通知。
endDocument() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
endDocument() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个结束文档事件。
endDocument() - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
结束文档事件。
endDraggingFrame(JComponent) - 类 javax.swing.DefaultDesktopManager 中的方法
endDraggingFrame(JComponent) - 接口 javax.swing.DesktopManager 中的方法
此方法在拖动会话结束时发出信号。
endDTD() - 类 org.xml.sax.ext.DefaultHandler2 中的方法
endDTD() - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告 DTD 声明的结束。
EndElement - javax.xml.stream.events 中的 接口
结束元素事件的接口。
endElement(String, String, String) - 接口 org.xml.sax.ContentHandler 中的方法
接收元素结束的通知。
endElement(String) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收元素结束的通知。
endElement(String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收元素结束的通知。
endElement(String, String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收元素结束的通知。
endElement(String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
endElement(String, String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个结束元素事件。
endElement(String, String, String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 结束元素事件。
endEntity(String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
endEntity(String) - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告实体的结束。
endFontTag() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
此方法已不再使用，而用写出 <span> 来替换。
endIndex - 类 javax.accessibility.AccessibleAttributeSequence 中的变量
文本序列的结束索引
endIndex - 类 javax.accessibility.AccessibleTextSequence 中的变量
文本序列的结束索引
endInsertEmpty() - 类 javax.imageio.ImageWriter 中的方法
完成对新图像的插入，该操作是从以前调用 prepareInsertEmpty 开始的。
endKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
endLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到行尾的 Action 名称。
EndOfLineStringProperty - 类 javax.swing.text.DefaultEditorKit 中的静态变量
在读取文档时，如果遇到 CRLF，将添加具有此名称的一个属性，属性值为 "\r\n"。
endParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到段落末尾的 Action 名称。
Endpoint - javax.xml.ws 中的 类
Web 服务端点。
Endpoint() - 类 javax.xml.ws.Endpoint 的构造方法
ENDPOINT_ADDRESS_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
标准属性：目标服务端点地址。
endPrefixMapping(String) - 接口 org.xml.sax.ContentHandler 中的方法
结束前缀 URI 范围的映射。
endPrefixMapping(String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收名称空间映射结束的通知。
endPrefixMapping(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个结束名称空间前缀映射事件。
endPrefixMapping(String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 结束前缀映射事件。
endReplacePixels() - 类 javax.imageio.ImageWriter 中的方法
终止调用 replacePixels 的序列。
endResizingFrame(JComponent) - 类 javax.swing.DefaultDesktopManager 中的方法
endResizingFrame(JComponent) - 接口 javax.swing.DesktopManager 中的方法
此方法在重新调整大小会话结束时发出信号。
endsWith(String) - 类 java.lang.String 中的方法
测试此字符串是否以指定的后缀结束。
endsWith(Name) - 类 javax.naming.CompositeName 中的方法
确定某一复合名称是否是此复合名称的后缀。
endsWith(Name) - 类 javax.naming.CompoundName 中的方法
确定某一组合名称是否是此组合名称的后缀。
endsWith(Name) - 类 javax.naming.ldap.LdapName 中的方法
确定此 LDAP 名称是否以某一指定 LDAP 名称后缀结尾。
endsWith(List<Rdn>) - 类 javax.naming.ldap.LdapName 中的方法
确定指定的 RDN 序列是否形成此 LDAP 名称的后缀。
endsWith(Name) - 接口 javax.naming.Name 中的方法
确定此名称是否以某一指定后缀结束。
ENDTAG - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
endTag(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出元素的结束标记。
ENDTAG - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
endTag(boolean) - 类 javax.swing.text.html.parser.Parser 中的方法
处理结束标记。
EndTagType - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getType 的可能值。
endUpdate() - 类 javax.swing.undo.UndoableEditSupport 中的方法
死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。
endWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到字尾的动作名称。
endWriteEmpty() - 类 javax.imageio.ImageWriter 中的方法
完成对新图像的写入，该操作是从优先调用 prepareWriteEmpty 开始的。
endWriteSequence() - 类 javax.imageio.ImageWriter 中的方法
完成以 prepareWriteSequence 开头的一系列图像的写入。
ENGINE - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它是 ScriptEngine 实现的名称。
ENGINE_SCOPE - 接口 javax.script.ScriptContext 中的静态变量
EngineScope 属性在单个 ScriptEngine 的生存期是可见的，并为每个引擎维护一个属性集。
ENGINE_VERSION - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它标识 ScriptEngine 实现的版本。
engineAliases() - 类 java.security.KeyStoreSpi 中的方法
列出此 keystore 的所有别名。
engineBuild(CertPathParameters) - 类 java.security.cert.CertPathBuilderSpi 中的方法
尝试使用指定的算法参数集构建一个证书路径。
engineContainsAlias(String) - 类 java.security.KeyStoreSpi 中的方法
检查给定别名是否存在于此 keystore 中。
engineCreateSSLEngine() - 类 javax.net.ssl.SSLContextSpi 中的方法
使用此上下文创建新的 SSLEngine。
engineCreateSSLEngine(String, int) - 类 javax.net.ssl.SSLContextSpi 中的方法
使用此上下文创建 SSLEngine。
engineDeleteEntry(String) - 类 java.security.KeyStoreSpi 中的方法
删除由此 keystore 中给定的别名标识的项。
engineDigest() - 类 java.security.MessageDigestSpi 中的方法
通过执行诸如填充等之类的最终操作完成哈希计算。
engineDigest(byte[], int, int) - 类 java.security.MessageDigestSpi 中的方法
通过执行诸如填充等之类的最终操作完成哈希计算。
engineDoFinal(byte[], int, int) - 类 javax.crypto.CipherSpi 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
engineDoFinal(byte[], int, int, byte[], int) - 类 javax.crypto.CipherSpi 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
engineDoFinal(ByteBuffer, ByteBuffer) - 类 javax.crypto.CipherSpi 中的方法
按单部分操作加密或解密数据，或者结束一个多部分操作。
engineDoFinal() - 类 javax.crypto.MacSpi 中的方法
完成 MAC 计算并且重新设置 MAC 以便进一步使用，维护 MAC 初始化所用的秘密密钥。
engineDoPhase(Key, boolean) - 类 javax.crypto.KeyAgreementSpi 中的方法
用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
engineEntryInstanceOf(String, Class<? extends KeyStore.Entry>) - 类 java.security.KeyStoreSpi 中的方法
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
engineGenerateCertificate(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
engineGenerateCertificates(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
engineGenerateCertPath(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
engineGenerateCertPath(InputStream, String) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
engineGenerateCertPath(List<? extends Certificate>) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
engineGenerateCRL(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
engineGenerateCRLs(InputStream) - 类 java.security.cert.CertificateFactorySpi 中的方法
返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
engineGenerateKey() - 类 javax.crypto.KeyGeneratorSpi 中的方法
生成一个秘密密钥。
engineGenerateParameters() - 类 java.security.AlgorithmParameterGeneratorSpi 中的方法
生成参数。
engineGeneratePrivate(KeySpec) - 类 java.security.KeyFactorySpi 中的方法
根据所提供的密钥规范（密钥材料）生成私钥对象。
engineGeneratePublic(KeySpec) - 类 java.security.KeyFactorySpi 中的方法
根据所提供的密钥规范（密钥材料）生成公钥对象。
engineGenerateSecret() - 类 javax.crypto.KeyAgreementSpi 中的方法
生成共享秘密密钥并在新的缓冲区中返回它。
engineGenerateSecret(byte[], int) - 类 javax.crypto.KeyAgreementSpi 中的方法
生成共享秘密密钥，并将从 offset 开始（包括）的部分放入缓冲区 sharedSecret。
engineGenerateSecret(String) - 类 javax.crypto.KeyAgreementSpi 中的方法
创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
engineGenerateSecret(KeySpec) - 类 javax.crypto.SecretKeyFactorySpi 中的方法
根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
engineGenerateSeed(int) - 类 java.security.SecureRandomSpi 中的方法
返回给定的种子字节数。
engineGenExemptionBlob() - 类 javax.crypto.ExemptionMechanismSpi 中的方法
生成豁免机制密钥 blob。
engineGenExemptionBlob(byte[], int) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
生成豁免机制密钥 blob 并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
engineGetAppConfigurationEntry(String) - 类 javax.security.auth.login.ConfigurationSpi 中的方法
获取指定 name 的 AppConfigurationEntry。
engineGetBlockSize() - 类 javax.crypto.CipherSpi 中的方法
返回块的大小（以字节为单位）。
engineGetCertificate(String) - 类 java.security.KeyStoreSpi 中的方法
返回与给定别名关联的证书。
engineGetCertificateAlias(Certificate) - 类 java.security.KeyStoreSpi 中的方法
返回其证书和给定证书匹配的第一个 keystore 项的名称（别名）。
engineGetCertificateChain(String) - 类 java.security.KeyStoreSpi 中的方法
返回与给定别名关联的证书链。
engineGetCertificates(CertSelector) - 类 java.security.cert.CertStoreSpi 中的方法
返回与指定选择器匹配的 Certificate 的 Collection。
engineGetCertPathEncodings() - 类 java.security.cert.CertificateFactorySpi 中的方法
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
engineGetClientSessionContext() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回此上下文的客户端 SSLSessionContext 对象。
engineGetCreationDate(String) - 类 java.security.KeyStoreSpi 中的方法
返回该别名标识的项的创建日期。
engineGetCRLs(CRLSelector) - 类 java.security.cert.CertStoreSpi 中的方法
返回与指定选择器匹配的 CRL 的 Collection。
engineGetDefaultSSLParameters() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
engineGetDigestLength() - 类 java.security.MessageDigestSpi 中的方法
返回以字节为单位的摘要长度。
engineGetEncoded() - 类 java.security.AlgorithmParametersSpi 中的方法
返回基本编码格式的参数。
engineGetEncoded(String) - 类 java.security.AlgorithmParametersSpi 中的方法
返回以指定格式编码的参数。
engineGetEntry(String, KeyStore.ProtectionParameter) - 类 java.security.KeyStoreSpi 中的方法
使用指定保护参数获取指定别名的 KeyStore.Entry。
engineGetIV() - 类 javax.crypto.CipherSpi 中的方法
返回新缓冲区中的初始化向量 (IV)。
engineGetKey(String, char[]) - 类 java.security.KeyStoreSpi 中的方法
返回与给定别名关联的密钥，使用给定密码恢复它。
engineGetKeyManagers() - 类 javax.net.ssl.KeyManagerFactorySpi 中的方法
为每类密钥内容返回一个密钥管理器。
engineGetKeySize(Key) - 类 javax.crypto.CipherSpi 中的方法
返回给定密钥对象的密钥大小，以位为单位。
engineGetKeySpec(Key, Class<T>) - 类 java.security.KeyFactorySpi 中的方法
返回给定密钥对象的规范（密钥材料）。
engineGetKeySpec(SecretKey, Class) - 类 javax.crypto.SecretKeyFactorySpi 中的方法
以所需格式返回给定密钥对象的规范（密钥材料）。
engineGetMacLength() - 类 javax.crypto.MacSpi 中的方法
返回以字节为单位的 MAC 的长度。
engineGetOutputSize(int) - 类 javax.crypto.CipherSpi 中的方法
在给定了输入长度 inputLen（以字节为单位）的情况下，返回用于保存下一个 update 或 doFinal 操作结果所需的输出缓冲区长度的字节数。
engineGetOutputSize(int) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
给定了输入长度 inputLen （以字节为单位）的情况下，返回用于保存下一个 engineGenExemptionBlob 操作结果所需的输出缓冲区长度的字节长度。
engineGetParameter(String) - 类 java.security.SignatureSpi 中的方法
已过时。
engineGetParameters() - 类 java.security.SignatureSpi 中的方法
此方法将由提供者重写，以返回与此签名引擎配合使用的参数，如果此签名引擎未使用任何参数，则返回 null。
engineGetParameters() - 类 javax.crypto.CipherSpi 中的方法
返回此 cipher 使用的参数。
engineGetParameterSpec(Class<T>) - 类 java.security.AlgorithmParametersSpi 中的方法
返回此参数对象的（透明）规范。
engineGetPermissions(CodeSource) - 类 java.security.PolicySpi 中的方法
返回包含授予指定 CodeSource 的权限集的 PermissionCollection 对象。
engineGetPermissions(ProtectionDomain) - 类 java.security.PolicySpi 中的方法
返回包含授予指定 ProtectionDomain 的权限集的 PermissionCollection 对象。
engineGetServerSessionContext() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回此上下文的服务器 SSLSessionContext 对象。
engineGetServerSocketFactory() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回此上下文的 ServerSocketFactory 对象。
engineGetSocketFactory() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回此上下文的 SocketFactory 对象。
engineGetSupportedSSLParameters() - 类 javax.net.ssl.SSLContextSpi 中的方法
返回表示此 SSL 上下文最大受支持设置的 SSLParameters 的副本。
engineGetTrustManagers() - 类 javax.net.ssl.TrustManagerFactorySpi 中的方法
为每种信任材料返回一个信任管理器。
engineImplies(ProtectionDomain, Permission) - 类 java.security.PolicySpi 中的方法
检查该策略是否已将 Permission 授予 ProtectionDomain。
engineInit(int, SecureRandom) - 类 java.security.AlgorithmParameterGeneratorSpi 中的方法
针对某个特定大小和随机源初始化此参数生成器。
engineInit(AlgorithmParameterSpec, SecureRandom) - 类 java.security.AlgorithmParameterGeneratorSpi 中的方法
利用特定于算法的参数生成值的集合初始化此参数生成器。
engineInit(AlgorithmParameterSpec) - 类 java.security.AlgorithmParametersSpi 中的方法
使用在 paramSpec 中指定的参数初始化此参数对象。
engineInit(byte[]) - 类 java.security.AlgorithmParametersSpi 中的方法
根据参数的基本解码格式导入指定的参数并对其解码。
engineInit(byte[], String) - 类 java.security.AlgorithmParametersSpi 中的方法
根据指定的解码格式从 params 导入参数并对其解码。
engineInit(int, Key, SecureRandom) - 类 javax.crypto.CipherSpi 中的方法
用密钥和随机源初始化此 cipher。
engineInit(int, Key, AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.CipherSpi 中的方法
用一个密钥、一组算法参数和一个随机源初始化此 cipher。
engineInit(int, Key, AlgorithmParameters, SecureRandom) - 类 javax.crypto.CipherSpi 中的方法
用一个密钥、一组算法参数和一个随机源初始化此 cipher。
engineInit(Key) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
用密钥初始化此豁免机制。
engineInit(Key, AlgorithmParameterSpec) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
用一个密钥和一组算法参数初始化此豁免机制。
engineInit(Key, AlgorithmParameters) - 类 javax.crypto.ExemptionMechanismSpi 中的方法
用一个密钥和一组算法参数初始化此豁免机制。
engineInit(Key, SecureRandom) - 类 javax.crypto.KeyAgreementSpi 中的方法
用给定密钥和随机源初始化此密钥协定。
engineInit(Key, AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.KeyAgreementSpi 中的方法
用给定密钥、算法参数集和随机源初始化此密钥协定。
engineInit(SecureRandom) - 类 javax.crypto.KeyGeneratorSpi 中的方法
初始化该密钥生成器。
engineInit(AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.KeyGeneratorSpi 中的方法
用指定参数集和用户提供的随机源初始化密钥生成器。
engineInit(int, SecureRandom) - 类 javax.crypto.KeyGeneratorSpi 中的方法
使用给定随机源初始化此密钥生成器，以获取确定的密钥长度。
engineInit(Key, AlgorithmParameterSpec) - 类 javax.crypto.MacSpi 中的方法
用给定的（秘密）密钥和算法参数初始化 MAC。
engineInit(KeyStore, char[]) - 类 javax.net.ssl.KeyManagerFactorySpi 中的方法
使用密钥内容源初始化此工厂。
engineInit(ManagerFactoryParameters) - 类 javax.net.ssl.KeyManagerFactorySpi 中的方法
使用密钥内容源初始化此工厂。
engineInit(KeyManager[], TrustManager[], SecureRandom) - 类 javax.net.ssl.SSLContextSpi 中的方法
初始化此上下文。
engineInit(KeyStore) - 类 javax.net.ssl.TrustManagerFactorySpi 中的方法
用证书授权源和相关的信任材料初始化此工厂。
engineInit(ManagerFactoryParameters) - 类 javax.net.ssl.TrustManagerFactorySpi 中的方法
使用特定于提供者的密钥材料源初始化此工厂。
engineInitSign(PrivateKey) - 类 java.security.SignatureSpi 中的方法
通过用于签名操作的指定私钥初始化此签名对象。
engineInitSign(PrivateKey, SecureRandom) - 类 java.security.SignatureSpi 中的方法
通过用于签名操作的指定私钥和随机源初始化此签名对象。
engineInitVerify(PublicKey) - 类 java.security.SignatureSpi 中的方法
通过用于验证操作的指定公钥初始化此签名对象。
engineIsCertificateEntry(String) - 类 java.security.KeyStoreSpi 中的方法
如果给定别名标识的项是通过调用 setCertificateEntry 或者调用使用 TrustedCertificateEntry 作为参数的 setEntry 来创建的，则返回 true。
engineIsKeyEntry(String) - 类 java.security.KeyStoreSpi 中的方法
如果给定别名标识的项是通过调用 setKeyEntry 或者调用使用 PrivateKeyEntry 或 SecretKeyEntry 作为参数的 setEntry 创建的，则返回 true。
engineLoad(InputStream, char[]) - 类 java.security.KeyStoreSpi 中的方法
从给定的输入流中加载此 KeyStore。
engineLoad(KeyStore.LoadStoreParameter) - 类 java.security.KeyStoreSpi 中的方法
使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
engineNextBytes(byte[]) - 类 java.security.SecureRandomSpi 中的方法
生成用户指定的随机字节数。
engineRefresh() - 类 java.security.PolicySpi 中的方法
刷新/重载策略配置。
engineRefresh() - 类 javax.security.auth.login.ConfigurationSpi 中的方法
刷新并重新加载 Configuration。
engineReset() - 类 java.security.MessageDigestSpi 中的方法
为进一步使用重置摘要。
engineReset() - 类 javax.crypto.MacSpi 中的方法
为了进一步使用而重新设置 MAC，维护 MAC 初始化所用的秘密密钥。
engineScope - 类 javax.script.SimpleScriptContext 中的变量
此字段是引擎范围 bindings。
engineSetCertificateEntry(String, Certificate) - 类 java.security.KeyStoreSpi 中的方法
将给定证书分配给给定别名。
engineSetEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - 类 java.security.KeyStoreSpi 中的方法
用指定别名保存 KeyStore.Entry。
engineSetKeyEntry(String, Key, char[], Certificate[]) - 类 java.security.KeyStoreSpi 中的方法
将给定的密钥分配给给定的别名，用给定的密码保护它。
engineSetKeyEntry(String, byte[], Certificate[]) - 类 java.security.KeyStoreSpi 中的方法
将给定密钥（已经被保护）分配给给定别名。
engineSetMode(String) - 类 javax.crypto.CipherSpi 中的方法
设置此 cipher 的模式。
engineSetPadding(String) - 类 javax.crypto.CipherSpi 中的方法
设置此 cipher 的填充机制。
engineSetParameter(String, Object) - 类 java.security.SignatureSpi 中的方法
已过时。 由 engineSetParameter 取代。
engineSetParameter(AlgorithmParameterSpec) - 类 java.security.SignatureSpi 中的方法
此方法将由提供者重写，以便使用指定的参数设置初始化此签名引擎。
engineSetSeed(byte[]) - 类 java.security.SecureRandomSpi 中的方法
重新提供此随机对象的种子。
engineSign() - 类 java.security.SignatureSpi 中的方法
返回迄今为止所有更新的数据的签名字节。
engineSign(byte[], int, int) - 类 java.security.SignatureSpi 中的方法
完成此签名操作，并从 offset 开始将得到的签名字节保存在提供的缓冲区 outbuf 中。
engineSize() - 类 java.security.KeyStoreSpi 中的方法
获取此 keystore 中项的数目。
engineStore(OutputStream, char[]) - 类 java.security.KeyStoreSpi 中的方法
将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
engineStore(KeyStore.LoadStoreParameter) - 类 java.security.KeyStoreSpi 中的方法
使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
engineToString() - 类 java.security.AlgorithmParametersSpi 中的方法
返回描述参数的格式化字符串。
engineTranslateKey(Key) - 类 java.security.KeyFactorySpi 中的方法
将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
engineTranslateKey(SecretKey) - 类 javax.crypto.SecretKeyFactorySpi 中的方法
将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
engineUnwrap(byte[], String, int) - 类 javax.crypto.CipherSpi 中的方法
打开一个以前包装的密钥。
engineUpdate(byte) - 类 java.security.MessageDigestSpi 中的方法
使用指定的字节更新摘要。
engineUpdate(byte[], int, int) - 类 java.security.MessageDigestSpi 中的方法
使用指定的 byte 数组，在指定的偏移量处开始更新摘要。
engineUpdate(ByteBuffer) - 类 java.security.MessageDigestSpi 中的方法
使用指定的 ByteBuffer 更新摘要。
engineUpdate(byte) - 类 java.security.SignatureSpi 中的方法
使用指定的字节更新要签名或验证的数据。
engineUpdate(byte[], int, int) - 类 java.security.SignatureSpi 中的方法
使用指定的 byte 数组，从指定的偏移量开始更新要签名或验证的数据。
engineUpdate(ByteBuffer) - 类 java.security.SignatureSpi 中的方法
使用指定的 ByteBuffer 更新要签名或验证的数据。
engineUpdate(byte[], int, int) - 类 javax.crypto.CipherSpi 中的方法
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
engineUpdate(byte[], int, int, byte[], int) - 类 javax.crypto.CipherSpi 中的方法
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
engineUpdate(ByteBuffer, ByteBuffer) - 类 javax.crypto.CipherSpi 中的方法
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
engineUpdate(byte) - 类 javax.crypto.MacSpi 中的方法
处理给定的字节。
engineUpdate(byte[], int, int) - 类 javax.crypto.MacSpi 中的方法
从 offset 开始处（包含），处理 input 中的前len 个字节。
engineUpdate(ByteBuffer) - 类 javax.crypto.MacSpi 中的方法
从 input.position() 开始处，处理 ByteBuffer input 中的 input.remaining() 字节。
engineValidate(CertPath, CertPathParameters) - 类 java.security.cert.CertPathValidatorSpi 中的方法
使用指定的算法参数集验证指定的证书路径。
engineVerify(byte[]) - 类 java.security.SignatureSpi 中的方法
验证传入的签名。
engineVerify(byte[], int, int) - 类 java.security.SignatureSpi 中的方法
在指定的 byte 数组中，从指定的偏移量处开始，验证传入的签名。
engineWrap(Key) - 类 javax.crypto.CipherSpi 中的方法
将密钥包装。
ENGLISH - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
enqueue() - 类 java.lang.ref.Reference 中的方法
将此引用对象添加到引用对象已向其注册的队列（如果有）。
enqueueKeyEvents(long, Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
延迟对 KeyEvent 的指派，直到指定的 Component 成为焦点所有者。
enqueueKeyEvents(long, Component) - 类 java.awt.KeyboardFocusManager 中的方法
在指定的 Component 成为焦点所有者以前由 AWT 调用，以通知 KeyboardFocusManager 延迟指派 KeyEvent。
ensureCapacity(int) - 类 java.lang.StringBuffer 中的方法
ensureCapacity(int) - 类 java.util.ArrayList 中的方法
如有必要，增加此 ArrayList 实例的容量，以确保它至少能够容纳最小容量参数所指定的元素数。
ensureCapacity(int) - 类 java.util.Vector 中的方法
增加此向量的容量（如有必要），以确保其至少能够保存最小容量参数指定的组件数。
ensureCapacity(int) - 类 javax.swing.DefaultListModel 中的方法
增加此列表的容量（如有必要），以确保其至少能够保存最小容量参数指定的组件数。
ensureFileIsVisible(File) - 类 javax.swing.JFileChooser 中的方法
确保指定的文件是可见的，不是隐藏的。
ensureFileIsVisible(JFileChooser, File) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
ensureFileIsVisible(JFileChooser, File) - 类 javax.swing.plaf.FileChooserUI 中的方法
ensureFileIsVisible(JFileChooser, File) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
ensureFileIsVisible(JFileChooser, File) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 ensureFileIsVisible 方法。
ensureIndexIsVisible(int) - 类 javax.swing.JList 中的方法
滚动封闭视口中的列表，使指定单元完全可见。
ensureRowsAreVisible(int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
确保 beginRow 通过 endRow 标识的行是可见的。
ENTER - 类 java.awt.dnd.DragSourceContext 中的静态变量
updateCurrentCursor() 使用的 int 值，指示 Cursor 已进入 DropTarget。
ENTER - 类 java.awt.Event 中的静态变量
Enter 键。
ENTERED - 类 javax.swing.event.HyperlinkEvent.EventType 中的静态变量
进入类型。
entering(String, String) - 类 java.util.logging.Logger 中的方法
记录一个方法条目。
entering(String, String, Object) - 类 java.util.logging.Logger 中的方法
记录一个方法条目，带有一个参数。
entering(String, String, Object[]) - 类 java.util.logging.Logger 中的方法
记录一个方法条目，带有一组参数。
ENTITIES - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
ENTITY - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Entity - javax.swing.text.html.parser 中的 类
使用 ENTITY 构造在 DTD 中描述了一个实体。
Entity(String, int, char[]) - 类 javax.swing.text.html.parser.Entity 的构造方法
创建一个实体。
Entity - org.w3c.dom 中的 接口
此接口表示在 XML 文档中解析和未解析的已知实体。
ENTITY_DECLARATION - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示一个 Entity Declaration
ENTITY_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Entity。
ENTITY_REFERENCE - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个实体引用
ENTITY_REFERENCE_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 EntityReference。
EntityDeclaration - javax.xml.stream.events 中的 接口
处理实体声明的接口。
entityHash - 类 javax.swing.text.html.parser.DTD 中的变量
EntityReference - javax.xml.stream.events 中的 接口
处理实体事件的接口。
EntityReference - org.w3c.dom 中的 接口
EntityReference 节点可以用来在树中表示实体引用。
EntityResolver - org.xml.sax 中的 接口
用于解析实体的基本接口。
EntityResolver2 - org.xml.sax.ext 中的 接口
扩展的接口，用于将外部实体引用映射到输入源，或用于提供缺少的外部子集。
entries() - 接口 java.security.acl.Acl 中的方法
返回此 ACL 中各项的枚举。
entries() - 类 java.util.jar.JarFile 中的方法
返回 zip 文件条目的枚举。
entries() - 类 java.util.zip.ZipFile 中的方法
返回 ZIP 文件条目的枚举。
entryInstanceOf(String, Class<? extends KeyStore.Entry>) - 类 java.security.KeyStore 中的方法
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
entrySet() - 类 java.awt.RenderingHints 中的方法
返回此 RenderingHints 中所包含映射关系的 Set 视图。
entrySet() - 类 java.security.Provider 中的方法
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。
entrySet() - 类 java.util.AbstractMap 中的方法
entrySet() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此映射所包含的映射关系的 Set 视图。
entrySet() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此映射中所包含的映射关系的 Set 视图。
entrySet() - 类 java.util.EnumMap 中的方法
返回此映射中所包含映射关系的 Set 视图。
entrySet() - 类 java.util.HashMap 中的方法
返回此映射所包含的映射关系的 Set 视图。
entrySet() - 类 java.util.Hashtable 中的方法
返回此映射中包含的键的 Set 视图。
entrySet() - 类 java.util.IdentityHashMap 中的方法
返回此映射所包含映射关系的 Set 视图。
entrySet() - 类 java.util.jar.Attributes 中的方法
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。
entrySet() - 接口 java.util.Map 中的方法
返回此映射中包含的映射关系的 Set 视图。
entrySet() - 接口 java.util.SortedMap 中的方法
返回在此映射中包含的映射关系的 Set 视图。
entrySet() - 类 java.util.TreeMap 中的方法
返回此映射中包含的映射关系的 Set 视图。
entrySet() - 类 java.util.WeakHashMap 中的方法
返回此映射所包含的映射关系的 Set 视图。
entrySet() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。
entrySet() - 类 javax.script.SimpleBindings 中的方法
返回此映射中包含的映射关系的 Set 视图。
Enum<E extends Enum<E>> - java.lang 中的 类
这是所有 Java 语言枚举类型的公共基本类。
Enum(String, int) - 类 java.lang.Enum 的构造方法
单独的构造方法。
EnumConstantNotPresentException - java.lang 中的 异常
当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
EnumConstantNotPresentException(Class<? extends Enum>, String) - 异常 java.lang.EnumConstantNotPresentException 的构造方法
为指定常量构造一个 EnumConstantNotPresentException。
EnumControl - javax.sound.sampled 中的 类
EnumControl 提供对一组截然不同的可能值的控制，每个值都由一个对象表示。
EnumControl(EnumControl.Type, Object[], Object) - 类 javax.sound.sampled.EnumControl 的构造方法
构造一个具有给定参数的新枚举控件对象。
EnumControl.Type - javax.sound.sampled 中的 类
EnumControl.Type 内部类的实例标识了某种枚举控件。
EnumControl.Type(String) - 类 javax.sound.sampled.EnumControl.Type 的构造方法
构造一个新的枚举控件类型。
enumerate(Thread[]) - 类 java.lang.Thread 中的静态方法
将当前线程的线程组及其子组中的每一个活动线程复制到指定的数组中。
enumerate(Thread[]) - 类 java.lang.ThreadGroup 中的方法
把此线程组及其子组中的所有活动线程复制到指定数组中。
enumerate(Thread[], boolean) - 类 java.lang.ThreadGroup 中的方法
把此线程组中的所有活动线程复制到指定数组中。
enumerate(ThreadGroup[]) - 类 java.lang.ThreadGroup 中的方法
把对此线程组中的所有活动子组的引用复制到指定数组中。
enumerate(ThreadGroup[], boolean) - 类 java.lang.ThreadGroup 中的方法
把对此线程组中的所有活动子组的引用复制到指定数组中。
enumeration(Collection<T>) - 类 java.util.Collections 中的静态方法
返回一个指定 collection 上的枚举。
Enumeration<E> - java.util 中的 接口
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EnumMap<K extends Enum<K>,V> - java.util 中的 类
与枚举类型键一起使用的专用 Map 实现。
EnumMap(Class<K>) - 类 java.util.EnumMap 的构造方法
创建一个具有指定键类型的空枚举映射。
EnumMap(EnumMap<K, ? extends V>) - 类 java.util.EnumMap 的构造方法
创建一个其键类型与指定枚举映射相同的枚举映射，最初包含相同的映射关系（如果有的话）。
EnumMap(Map<K, ? extends V>) - 类 java.util.EnumMap 的构造方法
创建一个枚举映射，从指定映射对其初始化。
EnumSet<E extends Enum<E>> - java.util 中的 类
与枚举类型一起使用的专用 Set 实现。
EnumSyntax - javax.print.attribute 中的 类
类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
EnumSyntax(int) - 类 javax.print.attribute.EnumSyntax 的构造方法
使用给定的整数值构造一个新枚举值。
enumType() - 异常 java.lang.EnumConstantNotPresentException 中的方法
返回缺少的枚举常量的类型。
env() - 类 org.omg.CORBA.Request 中的方法
检索用于此请求的 Environment 对象。
ENV_10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_10_ENVELOPE 的别名。
ENV_10X13 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_10X13_ENVELOPE 的别名。
ENV_10X14 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_10X14_ENVELOPE 的别名。
ENV_10X15 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_10X15_ENVELOPE 的别名。
ENV_11 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_11_ENVELOPE 的别名。
ENV_12 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_12_ENVELOPE 的别名。
ENV_14 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_14_ENVELOPE 的别名。
ENV_6X9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_6X9_ENVELOPE 的别名。
ENV_7X9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_7X9_ENVELOPE 的别名。
ENV_9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_NUMBER_9_ENVELOPE 的别名。
ENV_9X11 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_9X11_ENVELOPE 的别名。
ENV_9X12 - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_9X12_ENVELOPE 的别名。
ENV_INVITE - 类 java.awt.PageAttributes.MediaType 中的静态变量
INVITE_ENVELOPE 的别名。
ENV_ITALY - 类 java.awt.PageAttributes.MediaType 中的静态变量
ITALY_ENVELOPE 的别名。
ENV_MONARCH - 类 java.awt.PageAttributes.MediaType 中的静态变量
MONARCH_ENVELOPE 的别名。
ENV_PERSONAL - 类 java.awt.PageAttributes.MediaType 中的静态变量
PERSONAL_ENVELOPE 的别名。
ENVELOPE - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的信封进纸托盘。
ENVELOPED - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
Enveloped Signature 转换算法 URI。
environment() - 类 java.lang.ProcessBuilder 中的方法
返回此进程生成器环境的字符串映射视图。
environment - 异常 javax.naming.CannotProceedException 中的变量
包含与无法继续进行的 Context 或 DirContext 方法有关的环境。
Environment - org.omg.CORBA 中的 类
用于 Request 操作的异常的容器 (holder)，使异常可用于客户端。
Environment() - 类 org.omg.CORBA.Environment 的构造方法
eof - 异常 java.io.OptionalDataException 中的变量
如果流的缓冲部分不再有数据，则为 True。
EOFException - java.io 中的 异常
当输入过程中意外到达文件或流的末尾时，抛出此异常。
EOFException() - 异常 java.io.EOFException 的构造方法
构造 EOFException，使用 null 作为其错误详细消息。
EOFException(String) - 异常 java.io.EOFException 的构造方法
构造带有指定详细消息的 EOFException。
eolIsSignificant(boolean) - 类 java.io.StreamTokenizer 中的方法
确定是否将行末尾视为标记。
eos - 类 java.util.zip.GZIPInputStream 中的变量
指示输入流的结尾。
EQ - 类 javax.management.Query 中的静态变量
表示 Query.eq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
eq(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于两个值的等于约束条件。
EQUAL - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
比较结果。
equal(Any) - 类 org.omg.CORBA.Any 中的方法
检查此 Any 对象与给定 Any 对象是否相等。
equal(TypeCode) - 类 org.omg.CORBA.TypeCode 中的方法
将此 TypeCode 对象与给定对象比较，测试它们是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynStructStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 类 org.omg.DynamicAny._DynValueStub 中的方法
比较两个 DynAny 值是否相等。
equal(DynAny) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
比较两个 DynAny 值是否相等。
equals(Object) - 类 java.awt.AlphaComposite 中的方法
确定指定的对象是否等于此 AlphaComposite。
equals(Object) - 类 java.awt.AWTKeyStroke 中的方法
如果此对象与指定对象相同，则返回 true。
equals(Object) - 类 java.awt.BasicStroke 中的方法
测试指定对象与此 BasicStroke 是否相等，首先测试指定对象是否是一个 BasicStroke，然后将其宽度、连接、cap、斜接限制、虚线和虚线相位属性与 BasicStroke 的那些属性进行比较。
equals(Object) - 类 java.awt.Color 中的方法
确定另一个对象是否与此 Color 相同。
equals(Object) - 类 java.awt.datatransfer.DataFlavor 中的方法
测试任意 Object 与此 DataFlavor 的相等性。
equals(DataFlavor) - 类 java.awt.datatransfer.DataFlavor 中的方法
测试 DataFlavor 与此 DataFlavor 的相等性。
equals(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
已过时。 与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。
equals(Object) - 类 java.awt.Dimension 中的方法
检查两个 dimension 对象是否具有相同的值。
equals(DisplayMode) - 类 java.awt.DisplayMode 中的方法
返回对两个显示模式是否相同的判断。
equals(Object) - 类 java.awt.DisplayMode 中的方法
指示其他某个对象是否与此对象“相等”。
equals(Object) - 类 java.awt.Font 中的方法
将此 Font 对象与指定 Object 进行比较。
equals(Object) - 类 java.awt.font.FontRenderContext 中的方法
如果 obj 是 FontRenderContext 的一个实例，并且具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。
equals(FontRenderContext) - 类 java.awt.font.FontRenderContext 中的方法
如果 rhs 具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。
equals(GlyphVector) - 类 java.awt.font.GlyphVector 中的方法
测试指定的 GlyphVector 是否恰好等于此 GlyphVector。
equals(Object) - 类 java.awt.font.ImageGraphicAttribute 中的方法
比较此 ImageGraphicAttribute 与指定的 Object。
equals(ImageGraphicAttribute) - 类 java.awt.font.ImageGraphicAttribute 中的方法
比较此 ImageGraphicAttribute 与指定的 ImageGraphicAttribute。
equals(Object) - 类 java.awt.font.NumericShaper 中的方法
如果指定的对象是 NumericShaper 的一个实例，并且完全一致地成形到此实例，则返回 true。
equals(Object) - 类 java.awt.font.ShapeGraphicAttribute 中的方法
将此 ShapeGraphicAttribute 与指定的 Object 进行比较。
equals(ShapeGraphicAttribute) - 类 java.awt.font.ShapeGraphicAttribute 中的方法
将此 ShapeGraphicAttribute 与指定的 ShapeGraphicAttribute 进行比较。
equals(Object) - 类 java.awt.font.TextHitInfo 中的方法
如果指定的 Object 是一个 TextHitInfo 并且等于此 TextHitInfo，则返回 true。
equals(TextHitInfo) - 类 java.awt.font.TextHitInfo 中的方法
如果指定的 TextHitInfo 具有与此 TextHitInfo 相同的 charIndex 和 isLeadingEdge，则返回 true。
equals(Object) - 类 java.awt.font.TextLayout 中的方法
如果指定 Object 是一个 TextLayout 对象，且指定的 Object 等于此 TextLayout，则返回 true。
equals(TextLayout) - 类 java.awt.font.TextLayout 中的方法
如果两个布局相等，则返回 true。
equals(Object) - 类 java.awt.font.TransformAttribute 中的方法
如果 rhs 是一个变换等效于此 TransformAttribute 变换的 TransformAttribute，则返回 true。
equals(Object) - 类 java.awt.geom.AffineTransform 中的方法
如果此 AffineTransform 表示与指定参数相同的仿射坐标变换，则返回 true。
equals(Object) - 类 java.awt.geom.Arc2D 中的方法
确定指定的 Object 是否与此 Arc2D 相等。
equals(Area) - 类 java.awt.geom.Area 中的方法
测试两个 Area 对象的几何形状是否相等。
equals(Object) - 类 java.awt.geom.Ellipse2D 中的方法
确定指定的 Object 是否与此 Ellipse2D 相等。
equals(Object) - 类 java.awt.geom.Point2D 中的方法
确定两个点是否相等。
equals(Object) - 类 java.awt.geom.Rectangle2D 中的方法
确定指定的 Object 是否与此 Rectangle2D 相等。
equals(Object) - 类 java.awt.geom.RoundRectangle2D 中的方法
确定指定的 Object 是否与此 RoundRectangle2D 相等。
equals(Object) - 类 java.awt.image.ColorModel 中的方法
测试指定的 Object 是否是 ColorModel 的实例，以及它是否等于此 ColorModel。
equals(Object) - 类 java.awt.image.ComponentColorModel 中的方法
将此颜色模型与其他模型进行相等性比较。
equals(Object) - 类 java.awt.image.ComponentSampleModel 中的方法
equals(Object) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
equals(Object) - 类 java.awt.image.PackedColorModel 中的方法
测试指定的 Object 是否为 PackedColorModel 的一个实例并且等于此 PackedColorModel。
equals(Object) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
equals(Object) - 类 java.awt.Insets 中的方法
检查两个 insets 对象是否等价。
equals(Object) - 类 java.awt.JobAttributes 中的方法
确定两个 JobAttributes 是否相等。
equals(MenuShortcut) - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。
equals(Object) - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。
equals(Object) - 类 java.awt.PageAttributes 中的方法
确定两个 PageAttributes 是否相等。
equals(Object) - 类 java.awt.Point 中的方法
确定两个点是否相等。
equals(Object) - 类 java.awt.Rectangle 中的方法
检查两个矩形是否相等。
equals(Object) - 类 java.awt.RenderingHints 中的方法
对指定的 Object 与此 RenderingHints 进行相等性比较。
equals(Object) - 类 java.awt.RenderingHints.Key 中的方法
用于所有 Key 对象的 equals 方法将返回与等号运算符 '==' 相同的结果。
equals(Object) - 类 java.beans.IndexedPropertyDescriptor 中的方法
将此 PropertyDescriptor 与指定对象比较。
equals(Object) - 类 java.beans.PropertyDescriptor 中的方法
将此 PropertyDescriptor 与指定对象进行比较。
equals(Object) - 类 java.io.File 中的方法
测试此抽象路径名与给定对象是否相等。
equals(Object) - 类 java.io.FilePermission 中的方法
检查两个 FilePermission 对象是否相等。
equals(Object) - 接口 java.lang.annotation.Annotation 中的方法
如果指定的对象表示在逻辑上等效于此接口的注释，则返回 true。
equals(Object) - 类 java.lang.Boolean 中的方法
当且仅当参数不是 null，而是一个与此对象一样，都表示同一个 Boolean 值的 boolean 对象时，才返回 true。
equals(Object) - 类 java.lang.Byte 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.lang.Character 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.lang.Character.Subset 中的方法
比较两个 Subset 对象的相等性。
equals(Object) - 类 java.lang.Double 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.lang.Enum 中的方法
当指定对象等于此枚举常量时，返回 true。
equals(Object) - 类 java.lang.Float 中的方法
将此对象与指定对象进行比较。
equals(Object) - 类 java.lang.Integer 中的方法
比较此对象与指定对象。
equals(Object) - 类 java.lang.Long 中的方法
将此对象与指定对象进行比较。
equals(Object) - 类 java.lang.Object 中的方法
指示其他某个对象是否与此对象“相等”。
equals(Object) - 类 java.lang.reflect.Constructor 中的方法
将此 Constructor 对象与指定的对象进行比较。
equals(Object) - 类 java.lang.reflect.Field 中的方法
将此 Field 与指定对象比较。
equals(Object) - 类 java.lang.reflect.Method 中的方法
将此 Method 与指定对象进行比较。
equals(Object) - 类 java.lang.Short 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.lang.StackTraceElement 中的方法
如果指定的对象是另一个 StackTraceElement 实例，并且该对象表示的执行点与该实例的相同，则返回 ture。
equals(Object) - 类 java.lang.String 中的方法
将此字符串与指定的对象比较。
equals(Object) - 类 java.math.BigDecimal 中的方法
比较此 BigDecimal 与指定的 Object 的相等性。
equals(Object) - 类 java.math.BigInteger 中的方法
比较此 BigInteger 与指定的 Object 的相等性。
equals(Object) - 类 java.math.MathContext 中的方法
将此 MathContext 与指定的 Object 进行相等性比较。
equals(Object) - 类 java.net.HttpCookie 中的方法
测试两个 http cookie 的相等性。
equals(Object) - 类 java.net.Inet4Address 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.Inet6Address 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.InetAddress 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.InetSocketAddress 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.InterfaceAddress 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.NetworkInterface 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.Proxy 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.net.SocketPermission 中的方法
检查两个 SocketPermission 对象的相等性。
equals(Object) - 类 java.net.URI 中的方法
测试此 URI 与另一对象的相等性。
equals(Object) - 类 java.net.URL 中的方法
比较此 URL 是否等于另一个对象。
equals(URL, URL) - 类 java.net.URLStreamHandler 中的方法
提供默认的 equals 计算。
equals(Object) - 类 java.nio.ByteBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.CharBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.charset.Charset 中的方法
通知此对象是否和其他对象相等。
equals(Object) - 类 java.nio.DoubleBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.FloatBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.IntBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.LongBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.nio.ShortBuffer 中的方法
判断此缓冲区是否与另一个对象相同。
equals(Object) - 类 java.rmi.activation.ActivationDesc 中的方法
比较两个激活描述符的内容相等性。
equals(Object) - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 中的方法
比较两个命令环境的内容相等性。
equals(Object) - 类 java.rmi.activation.ActivationGroupDesc 中的方法
比较两个激活组描述符的内容相等性。
equals(Object) - 类 java.rmi.activation.ActivationGroupID 中的方法
比较两个组标识符的内容相等性。
equals(Object) - 类 java.rmi.activation.ActivationID 中的方法
比较两个激活 id 的内容相等性。
equals(Object) - 类 java.rmi.dgc.VMID 中的方法
将此 VMID 与另一个进行比较，如果它们是同一标识符，则返回 true。
equals(Object) - 类 java.rmi.MarshalledObject 中的方法
将此 MarshalledObject 与另一对象进行比较。
equals(Object) - 类 java.rmi.server.ObjID 中的方法
比较指定对象与此 ObjID 是否相等。
equals(Object) - 类 java.rmi.server.RemoteObject 中的方法
比较两个远程对象是否相等。
equals(Object) - 类 java.rmi.server.UID 中的方法
比较给定对象与此 UID 的相等性。
equals(Object) - 类 java.security.AccessControlContext 中的方法
检查两个 AccessControlContext 对象是否相等。
equals(Object) - 接口 java.security.acl.Permission 中的方法
如果传递的对象与此接口中所表示的权限相匹配，则返回 true。
equals(Object) - 类 java.security.AllPermission 中的方法
检查两个 AllPermission 对象是否相等。
equals(Object) - 类 java.security.BasicPermission 中的方法
检查两个 BasicPermission 对象是否相等。
equals(Object) - 类 java.security.cert.Certificate 中的方法
比较此证书与指定对象的相等性。
equals(Object) - 类 java.security.cert.CertPath 中的方法
比较此证书路径与指定对象的相等性。
equals(Object) - 类 java.security.cert.X509CRL 中的方法
比较此 CRL 与给定对象的相等性。
equals(Object) - 类 java.security.cert.X509CRLEntry 中的方法
比较此 CRL 项与给定对象的相等性。
equals(Object) - 类 java.security.CodeSigner 中的方法
测试指定对象与此代码签名者之间是否相等。
equals(Object) - 类 java.security.CodeSource 中的方法
测试指定对象与此对象之间的相等性。
equals(Object) - 类 java.security.Identity 中的方法
已过时。 测试指定对象与此 Identity 的相等性。
equals(Object) - 类 java.security.Permission 中的方法
检查两个 Permission 对象是否相等。
equals(Object) - 接口 java.security.Principal 中的方法
将此主体与指定对象比较。
equals(Object) - 类 java.security.spec.ECFieldF2m 中的方法
比较此有限字段与指定对象的相等性。
equals(Object) - 类 java.security.spec.ECFieldFp 中的方法
比较此素数有限字段与指定对象的相等性。
equals(Object) - 类 java.security.spec.ECPoint 中的方法
比较此椭圆曲线点与指定对象的相等性。
equals(Object) - 类 java.security.spec.EllipticCurve 中的方法
比较此椭圆曲线与指定对象的相等性。
equals(Object) - 类 java.security.Timestamp 中的方法
比较指定的对象和此时间戳之间的相同性。
equals(Object) - 类 java.security.UnresolvedPermission 中的方法
检查两个 UnresolvedPermission 对象的相等性。
equals(Object) - 接口 java.sql.RowId 中的方法
将此 RowId 与指定对象比较。
equals(Timestamp) - 类 java.sql.Timestamp 中的方法
测试此 Timestamp 对象是否等于给定的 Timestamp 对象。
equals(Object) - 类 java.sql.Timestamp 中的方法
测试此对象是否等于给定的 Timestamp 对象。
equals(Object) - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
比较两个对象的相等性。
equals(Object) - 类 java.text.ChoiceFormat 中的方法
两个对象之间的相等性比较。
equals(String, String) - 类 java.text.Collator 中的方法
根据此 Collator 的整理规则比较两个字符串是否相等的便捷方法。
equals(Object) - 类 java.text.Collator 中的方法
比较两个 Collator 的相等性。
equals(Object) - 类 java.text.DateFormat 中的方法
重写 equals
equals(Object) - 类 java.text.DateFormatSymbols 中的方法
重写 equals。
equals(Object) - 类 java.text.DecimalFormat 中的方法
重写 equals
equals(Object) - 类 java.text.DecimalFormatSymbols 中的方法
重写 equals。
equals(Object) - 类 java.text.FieldPosition 中的方法
重写 equals
equals(Object) - 类 java.text.MessageFormat 中的方法
两个消息格式对象之间的相等性比较
equals(Object) - 类 java.text.NumberFormat 中的方法
重写 equals
equals(Object) - 类 java.text.ParsePosition 中的方法
重写 equals
equals(Object) - 类 java.text.RuleBasedCollator 中的方法
比较两个 collation 对象的相等性。
equals(Object) - 类 java.text.SimpleDateFormat 中的方法
比较给定对象与此 SimpleDateFormat 的相等性。
equals(Object) - 类 java.text.StringCharacterIterator 中的方法
比较两个 StringCharacterIterator 对象的相等性。
equals(Object) - 类 java.util.AbstractList 中的方法
将指定的对象与此列表进行相等性比较。
equals(Object) - 类 java.util.AbstractMap 中的方法
比较指定对象与此映射的相等性。
equals(Object) - 类 java.util.AbstractMap.SimpleEntry 中的方法
比较指定对象与此项的相等性。
equals(Object) - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
比较指定对象与此项的相等性。
equals(Object) - 类 java.util.AbstractSet 中的方法
比较指定对象与此 set 的相等性。
equals(long[], long[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 long 型数组彼此相等，则返回 true。
equals(int[], int[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 int 型数组彼此相等，则返回 true。
equals(short[], short[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 short 型数组彼此相等，则返回 true。
equals(char[], char[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 char 型数组彼此相等，则返回 true。
equals(byte[], byte[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 byte 型数组彼此相等，则返回 true。
equals(boolean[], boolean[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 boolean 型数组彼此相等，则返回 true。
equals(double[], double[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 double 型数组彼此相等，则返回 true。
equals(float[], float[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 float 型数组彼此相等，则返回 true。
equals(Object[], Object[]) - 类 java.util.Arrays 中的静态方法
如果两个指定的 Objects 数组彼此相等，则返回 true。
equals(Object) - 类 java.util.BitSet 中的方法
将此对象与指定的对象进行比较。
equals(Object) - 类 java.util.Calendar 中的方法
将此 Calendar 与指定 Object 比较。
equals(Object) - 接口 java.util.Collection 中的方法
比较此 collection 与指定对象是否相等。
equals(Object) - 接口 java.util.Comparator 中的方法
指示某个其他对象是否“等于”此 Comparator。
equals(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
比较指定对象与此映射的相等性。
equals(Object) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
比较指定对象与此 set 的相等性。
equals(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
比较指定对象与此列表的相等性。
equals(Object) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
比较指定对象与此 set 的相等性。
equals(Object) - 类 java.util.Date 中的方法
比较两个日期的相等性。
equals(Object) - 类 java.util.EnumMap 中的方法
比较指定对象与此映射的相等性。
equals(Object) - 类 java.util.GregorianCalendar 中的方法
比较此 GregorianCalendar 与指定的 Object。
equals(Object) - 类 java.util.Hashtable 中的方法
按照 Map 接口的定义，比较指定 Object 与此 Map 是否相等。
equals(Object) - 类 java.util.IdentityHashMap 中的方法
比较指定对象与此映射的相等性。
equals(Object) - 类 java.util.jar.Attributes 中的方法
将指定的 Attributes 对象与此 Map 进行相等性比较。
equals(Object) - 类 java.util.jar.Attributes.Name 中的方法
将此属性名称与另一个属性名称进行相等性比较。
equals(Object) - 类 java.util.jar.Manifest 中的方法
如果指定的 Object 也是一个 Manifest，并且具有相同的主 Attributes 和条目，则返回 true。
equals(Object) - 接口 java.util.List 中的方法
比较指定的对象与列表是否相等。
equals(Object) - 类 java.util.Locale 中的方法
如果该 Locale 等于另一个对象，则返回 true。
equals(Object) - 类 java.util.logging.Level 中的方法
比较两个对象值的相等性。
equals(Object) - 接口 java.util.Map.Entry 中的方法
比较指定对象与此项的相等性。
equals(Object) - 接口 java.util.Map 中的方法
比较指定的对象与此映射是否相等。
equals(Object) - 类 java.util.PropertyPermission 中的方法
检查两个 PropertyPermission 对象是否相等。
equals(Object) - 接口 java.util.Set 中的方法
比较指定对象与此 set 的相等性。
equals(Object) - 类 java.util.SimpleTimeZone 中的方法
比较两个 SimpleTimeZone 对象的相等性。
equals(Object) - 类 java.util.UUID 中的方法
将此对象与指定对象比较。
equals(Object) - 类 java.util.Vector 中的方法
比较指定对象与此向量的相等性。
equals(DataFlavor) - 类 javax.activation.ActivationDataFlavor 中的方法
将传入的 DataFlavor 与此 DataFlavor 进行比较；调用 isMimeTypeEqual 方法。
equals(Object) - 类 javax.crypto.spec.RC2ParameterSpec 中的方法
测试给定对象与此对象的相等性。
equals(Object) - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
测试给定对象与此对象的相等性。
equals(Object) - 类 javax.crypto.spec.SecretKeySpec 中的方法
测试给定对象与此对象的相等性。
equals(Object) - 类 javax.imageio.ImageTypeSpecifier 中的方法
如果给定 Object 是一个 ImageTypeSpecifier 并且具有与此对象相同的 SampleModel 和 ColorModel，则返回 true。
equals(Object) - 接口 javax.lang.model.element.Element 中的方法
如果参数表示与此元素相同的元素，则返回 true；否则返回 false。
equals(Object) - 接口 javax.lang.model.element.Name 中的方法
如果参数表示与 this 相同的名称，则返回 true，否则返回 false。
equals(Object) - 接口 javax.lang.model.type.TypeMirror 中的方法
遵守 Object.equals 的常规协定。
equals(Object) - 类 javax.management.Attribute 中的方法
比较当前的 Attribute Object 与另一个 Attribute Object。
equals(Object) - 接口 javax.management.Descriptor 中的方法
将此描述符与给定对象比较。
equals(Object) - 类 javax.management.ImmutableDescriptor 中的方法
将此描述符与给定对象进行比较。
equals(Object) - 类 javax.management.MBeanAttributeInfo 中的方法
比较此 MBeanAttributeInfo 与另一个 MBeanAttributeInfo。
equals(Object) - 类 javax.management.MBeanConstructorInfo 中的方法
比较此 MBeanConstructorInfo 与另一个 MBeanConstructorInfo。
equals(Object) - 类 javax.management.MBeanFeatureInfo 中的方法
比较此 MBeanFeatureInfo 与另一个 MBeanFeatureInfo。
equals(Object) - 类 javax.management.MBeanInfo 中的方法
比较此 MBeanInfo 与另一个 MBeanInfo。
equals(Object) - 类 javax.management.MBeanNotificationInfo 中的方法
把此 MBeanNotificationInfo 与另一个 MBeanNotificationInfo 进行比较。
equals(Object) - 类 javax.management.MBeanOperationInfo 中的方法
比较此 MBeanOperationInfo 与另一个 MBeanOperationInfo。
equals(Object) - 类 javax.management.MBeanParameterInfo 中的方法
比较此 MBeanParameterInfo 与另一个 MBeanParameterInfo。
equals(Object) - 类 javax.management.MBeanPermission 中的方法
检查两个 MBeanPermission 对象的相等性。
equals(Object) - 类 javax.management.MBeanServerPermission 中的方法
检查两个 MBeanServerPermission 对象的相等性。
equals(Object) - 类 javax.management.modelmbean.DescriptorSupport 中的方法
将此描述符与给定对象比较。
equals(Object) - 类 javax.management.ObjectInstance 中的方法
比较当前的 ObjectInstance 与另一个 ObjectInstance 是否相等。
equals(Object) - 类 javax.management.ObjectName 中的方法
比较当前的对象名与另一个对象名是否相等。
equals(Object) - 类 javax.management.openmbean.ArrayType 中的方法
比较指定的 obj 参数与此 ArrayType 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.CompositeData 中的方法
比较指定 obj 参数与此 CompositeData 实例的相等性。
equals(Object) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
比较指定的 obj 参数与此 CompositeDataSupport 实例的相等性。
equals(Object) - 类 javax.management.openmbean.CompositeType 中的方法
比较指定的 obj 参数与此 CompositeType 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
比较指定的 obj 参数与此 OpenMBeanAttributeInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
比较指定 obj 参数与此 OpenMBeanAttributeInfoSupport 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
比较指定的 obj 参数与此 OpenMBeanConstructorInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 中的方法
比较指定 obj 参数与此 OpenMBeanConstructorInfoSupport 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
比较指定 obj 参数与此 OpenMBeanInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanInfoSupport 中的方法
比较指定 obj 参数与此 OpenMBeanInfoSupport 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
比较指定 obj 参数与此 OpenMBeanOperationInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 中的方法
比较指定的 obj 参数与此 OpenMBeanOperationInfoSupport 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
比较指定的 obj 参数与此 OpenMBeanParameterInfo 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
比较指定的 obj 参数与此 OpenMBeanParameterInfoSupport 实例的相等性。
equals(Object) - 类 javax.management.openmbean.OpenType 中的方法
比较指定的 obj 参数与此开放类型实例的相等性。
equals(Object) - 类 javax.management.openmbean.SimpleType 中的方法
比较指定 obj 参数与此 SimpleType 实例的相等性。
equals(Object) - 接口 javax.management.openmbean.TabularData 中的方法
比较指定的 obj 参数与此 TabularData 实例的相等性。
equals(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
比较指定的 obj 参数与此 TabularDataSupport 实例的相等性。
equals(Object) - 类 javax.management.openmbean.TabularType 中的方法
比较指定的 obj 参数与此 TabularType 实例的相等性。
equals(Object) - 类 javax.management.remote.JMXPrincipal 中的方法
比较指定的 Object 与此 JMXPrincipal 是否相等。
equals(Object) - 类 javax.management.remote.JMXServiceURL 中的方法
指示是否有其他的对象等于此对象。
equals(Object) - 类 javax.naming.BinaryRefAddr 中的方法
确定 obj 是否等于此地址。
equals(Object) - 类 javax.naming.CompositeName 中的方法
确定两个复合名称是否相等。
equals(Object) - 类 javax.naming.CompoundName 中的方法
确定 obj 在语法上是否等同于此组合名称。
equals(Object) - 类 javax.naming.directory.BasicAttribute 中的方法
确定 obj 是否等于此属性。
equals(Object) - 类 javax.naming.directory.BasicAttributes 中的方法
确定此 BasicAttributes 是否等于另一个 Attributes。
equals(Object) - 类 javax.naming.ldap.LdapName 中的方法
确定两个 LDAP 名称是否相等。
equals(Object) - 类 javax.naming.ldap.Rdn 中的方法
比较指定 Object 与此 Rdn 的相等性。
equals(Object) - 类 javax.naming.RefAddr 中的方法
确定 obj 是否等于此 RefAddr。
equals(Object) - 类 javax.naming.Reference 中的方法
确定 obj 是否是一个与此引用具有相同地址（按相同顺序）的引用。
equals(Object) - 接口 javax.print.attribute.AttributeSet 中的方法
比较指定的对象与此属性集的相等性。
equals(Object) - 类 javax.print.attribute.DateTimeSyntax 中的方法
返回此日期-时间属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.HashAttributeSet 中的方法
比较指定的对象与此属性集的相等性。
equals(Object) - 类 javax.print.attribute.IntegerSyntax 中的方法
返回此整数属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回此分辨率属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
返回此整数集属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.Copies 中的方法
返回此副本属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.CopiesSupported 中的方法
返回支持副本的此属性是否等于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.DateTimeAtCompleted 中的方法
返回此 DateTimeAtCompleted 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.DateTimeAtCreation 中的方法
返回此 DateTimeAtCreation 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.DateTimeAtProcessing 中的方法
返回此 DateTimeAtProcessing 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.Destination 中的方法
返回此目标属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.DocumentName 中的方法
返回此文档名称属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobHoldUntil 中的方法
返回此 JobHoldUntil 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobImpressions 中的方法
返回此作业印张属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobImpressionsCompleted 中的方法
返回此 JobImpressionsCompleted 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobImpressionsSupported 中的方法
返回此 JobImpressionsSupported 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobKOctets 中的方法
返回此 JobKOctets 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobKOctetsProcessed 中的方法
返回此 JobKOctetsProcessed 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobKOctetsSupported 中的方法
返回此 JobKOctetsSupported 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobMediaSheets 中的方法
返回此 JobMediaSheets 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobMediaSheetsCompleted 中的方法
返回此 JobMediaSheetsCompleted 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobMediaSheetsSupported 中的方法
返回支持的此 JobMediaSheetsSupported 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobMessageFromOperator 中的方法
返回 Operator 属性传来的此作业消息是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobName 中的方法
返回此作业名称属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobOriginatingUserName 中的方法
返回此 JobOriginatingUserName 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobPriority 中的方法
返回此作业优先级属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.JobPrioritySupported 中的方法
返回支持的此作业优先级属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.Media 中的方法
返回此介质属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
返回此介质页边距属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.MediaSize 中的方法
返回此介质尺寸属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.NumberOfDocuments 中的方法
返回此文档数属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.NumberOfInterveningJobs 中的方法
返回此 NumberOfInterveningJobs 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.NumberUp 中的方法
返回此计数属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.NumberUpSupported 中的方法
返回此 NumberUpSupported 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.OutputDeviceAssigned 中的方法
返回此 OutputDeviceAssigned 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PageRanges 中的方法
返回此 PageRanges 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PagesPerMinute 中的方法
返回此 PagesPerMinute 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PagesPerMinuteColor 中的方法
返回此 PagesPerMinuteColor 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterInfo 中的方法
返回此 PrinterInfo 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterLocation 中的方法
返回此 PrinterLocation 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterMakeAndModel 中的方法
返回此 PrinterMakeAndModel 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterMessageFromOperator 中的方法
返回此 PrinterMessageFromOperator 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterMoreInfo 中的方法
返回此 PrinterMoreInfo 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 中的方法
返回此 PrinterMoreInfoManufacturer 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterName 中的方法
返回此 PrinterName 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterResolution 中的方法
返回此 PrinterResolution 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.PrinterURI 中的方法
返回此打印机名称属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.QueuedJobCount 中的方法
返回此 QueuedJobCount 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.standard.RequestingUserName 中的方法
返回此 RequestingUserName 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.TextSyntax 中的方法
返回此文本属性是否等效于传入的对象。
equals(Object) - 类 javax.print.attribute.URISyntax 中的方法
返回此 URI 属性是否等效于传入的对象。
equals(Object) - 类 javax.print.DocFlavor 中的方法
确定此 DocFlavor 对象是否等于给定的对象。
equals(Object) - 接口 javax.print.PrintService 中的方法
确定两个服务是否引用相同的底层服务。
equals(Object) - 类 javax.rmi.CORBA.Stub 中的方法
比较两个 stub 的相等性。
equals(Stub, Object) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.equals(java.lang.Object) 的委托调用。
equals(Object) - 类 javax.rmi.ssl.SslRMIClientSocketFactory 中的方法
指示某个其他对象是否“等于”此对象。
equals(Object) - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
指示某个其他对象是否“等于”此对象。
equals(Object) - 类 javax.security.auth.kerberos.DelegationPermission 中的方法
检查两个 DelegationPermission 对象是否相等。
equals(Object) - 类 javax.security.auth.kerberos.KerberosKey 中的方法
比较指定 Object 与此 KerberosKey 的相等性。
equals(Object) - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
比较指定的对象与此 Principal 是否相等。
equals(Object) - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
比较给定 Object 与此 KerberosTicket 的相等性。
equals(Object) - 类 javax.security.auth.kerberos.ServicePermission 中的方法
检查两个 ServicePermission 对象是否相等。
equals(Object) - 类 javax.security.auth.PrivateCredentialPermission 中的方法
检查两个 PrivateCredentialPermission 对象是否相等。
equals(Object) - 类 javax.security.auth.Subject 中的方法
比较指定对象与此 Subject 的相等性。
equals(Object) - 类 javax.security.auth.x500.X500Principal 中的方法
比较指定的 Object 与此 X500Principal 的相等性。
equals(Object) - 类 javax.security.cert.Certificate 中的方法
比较此证书是否与指定对象相等。
equals(Object) - 类 javax.sound.midi.MidiDevice.Info 中的方法
报告两个对象是否相等。
equals(Object) - 类 javax.sound.midi.Sequencer.SyncMode 中的方法
确定两个对象是否等价。
equals(Object) - 类 javax.sound.sampled.AudioFileFormat.Type 中的方法
终止 equals 方法
equals(Object) - 类 javax.sound.sampled.AudioFormat.Encoding 中的方法
终止 equals 方法
equals(Object) - 类 javax.sound.sampled.Control.Type 中的方法
终止 equals 方法
equals(Object) - 类 javax.sound.sampled.LineEvent.Type 中的方法
指示指定对象是否等于此事件类型，如果对象是相同的，则返回 true。
equals(Object) - 类 javax.sound.sampled.Mixer.Info 中的方法
指示两个 info 对象是否相等；如果相等，则返回 true。
equals(Object) - 类 javax.sound.sampled.Port.Info 中的方法
终止 equals 方法
equals(Object) - 类 javax.sound.sampled.ReverbType 中的方法
指示指定对象是否等于此回响类型，如果对象相同，则返回 true。
equals(Object) - 类 javax.swing.RowSorter.SortKey 中的方法
如果此对象与指定对象相等，则返回 true。
equals(Object) - 类 javax.swing.text.DefaultCaret 中的方法
将此对象与指定的对象进行比较。
equals(Object) - 类 javax.swing.text.html.HTML.UnknownTag 中的方法
将此对象与指定对象进行比较。
equals(Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
将该对象与指定对象比较。
equals(Object) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
将此对象与指定对象比较。
equals(Object) - 类 javax.swing.text.TabSet 中的方法
指示此 TabSet 是否与另一个相等。
equals(Object) - 类 javax.swing.text.TabStop 中的方法
如果制表符相等，则返回 true。
equals(Object) - 类 javax.swing.tree.TreePath 中的方法
通过检查路径中每个元素的相等性，测试两个 TreePaths 的相等性。
equals(Object) - 类 javax.xml.datatype.Duration 中的方法
检查此持续时间对象是否与另一个 Duration 对象具有相同的持续时间。
equals(Object) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此日历与指定的对象进行比较。
equals(Object) - 类 javax.xml.namespace.QName 中的方法
测试此 QName 与另一个 Object 的相等性。
equals(Object) - 类 org.ietf.jgss.ChannelBinding 中的方法
比较 ChannelBinding 的两个实例。
equals(Object) - 接口 org.ietf.jgss.GSSCredential 中的方法
进行测试，看此 GSSCredential 是否具有与提供的对象相同的实体。
equals(GSSName) - 接口 org.ietf.jgss.GSSName 中的方法
比较两个 GSSName 对象，以确定它们是否指的是同一个实体。
equals(Object) - 接口 org.ietf.jgss.GSSName 中的方法
将此 GSSName 对象与可能是 GSSName 的另一个对象进行比较。
equals(Object) - 类 org.ietf.jgss.Oid 中的方法
测试两个 Oid 对象是否表示相同的 Object 标识符值。
equals(Object, Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
提供重写委托 CORBA 对象方法 equals(java.lang.Object obj) 的实现。
equals(Object) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
比较此 ObjectImpl 对象与给定对象是否相等。
equalsIgnoreCase(String) - 类 java.lang.String 中的方法
将此 String 与另一个 String 比较，不考虑大小写。
equivalent(TypeCode) - 类 org.omg.CORBA.TypeCode 中的方法
测试给定 TypeCode 对象是否等于此 TypeCode 对象。
ERA - 类 java.text.DateFormat.Field 中的静态变量
标识 ERA 字段的常量。
ERA - 类 java.util.Calendar 中的静态变量
指示年代的 get 和 set 的字段数字，比如罗马儒略历中的 AD 或 BC。
ERA_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 ERA 字段的有用常量。
erasure(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回删除状态的类型。
err - 类 java.io.FileDescriptor 中的静态变量
标准错误流的句柄。
err - 类 java.lang.System 中的静态变量
“标准”错误输出流。
ERROR - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示被异步跟踪的图像遇到了错误。
Error - java.lang 中的 错误
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Error() - 错误 java.lang.Error 的构造方法
构造详细消息为 null 的新错误。
Error(String) - 错误 java.lang.Error 的构造方法
构造带指定详细消息的新错误。
Error(String, Throwable) - 错误 java.lang.Error 的构造方法
构造带指定详细消息和原因的新错误。
Error(Throwable) - 错误 java.lang.Error 的构造方法
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息来构造新的错误（通常包含 cause 的类和详细消息）。
ERROR - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "error"，某些属性的可能值。
error(String, Exception, int) - 类 java.util.logging.ErrorManager 中的方法
在发生 Handler 失败时调用 error 方法。
ERROR - 类 javax.print.attribute.standard.Severity 中的静态变量
指示 PrinterStateReason 是 "error"（最严重）。
ERROR - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
ERROR 消息类型。
ERROR - 类 javax.security.auth.callback.TextOutputCallback 中的静态变量
错误消息。
error(String, String, String, String) - 类 javax.swing.text.html.parser.Parser 中的方法
调用错误处理程序。
error(String, String, String) - 类 javax.swing.text.html.parser.Parser 中的方法
error(String, String) - 类 javax.swing.text.html.parser.Parser 中的方法
error(String) - 类 javax.swing.text.html.parser.Parser 中的方法
ERROR - 接口 javax.xml.bind.ValidationEvent 中的静态变量
对应于 W3C XML 1.0 Recommendation 第 1.2 节中的“错误”的定义的条件。
error(TransformerException) - 接口 javax.xml.transform.ErrorListener 中的方法
接收可恢复错误的通知。
error(SAXParseException) - 接口 org.xml.sax.ErrorHandler 中的方法
接收可恢复的错误的通知。
error(SAXParseException) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收可恢复的解析器错误的通知。
error(SAXParseException) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收可恢复的解析器错误的通知。
error(SAXParseException) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个错误事件。
ERROR_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
ERROR_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
用于错误消息。
ERROR_OPTION - 类 javax.swing.JFileChooser 中的静态变量
发生错误后返回该值。
errorCode - 异常 javax.transaction.xa.XAException 中的变量
用其创建 SystemException 的错误代码。
ERRORED - 类 java.awt.MediaTracker 中的静态变量
指示媒体下载出错的标志。
ErrorHandler - org.xml.sax 中的 接口
SAX 错误处理程序的基本接口。
ErrorListener - javax.xml.transform 中的 接口
要提供自定义错误处理，则需实现此接口并使用 setErrorListener 方法注册一个带有 Transformer 的实现的实例。
ErrorManager - java.util.logging 中的 类
可将 ErrorManager 对象附加到 Handler，以便处理日志记录过程中 Handler 上所发生的错误。
ErrorManager() - 类 java.util.logging.ErrorManager 的构造方法
errorRaised() - 接口 javax.annotation.processing.RoundEnvironment 中的方法
如果在以前的处理 round 中发生错误，则返回 true；否则返回 false。
ErrorType - javax.lang.model.type 中的 接口
表示无法正常建模的类或接口类型。
errorWriter - 类 javax.script.SimpleScriptContext 中的变量
此字段是用于脚本输出错误的 writer。
ESCAPE - 类 java.awt.Event 中的静态变量
Escape 键。
escapeValue(Object) - 类 javax.naming.ldap.Rdn 中的静态方法
在给定属性值的情况下返回根据 RFC 2253 中指定的规则转义的字符串。
establish_components(IORInfo) - 接口 org.omg.PortableInterceptor.IORInterceptorOperations 中的方法
在汇编将包括在对象引用配置文件中的组件列表时，服务器端 ORB 对所有已注册 IORInterceptor 实例调用 establish_components 操作。
EtchedBorder - javax.swing.border 中的 类
该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
EtchedBorder() - 类 javax.swing.border.EtchedBorder 的构造方法
创建一个阴刻浮雕化类型的边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生。
EtchedBorder(int) - 类 javax.swing.border.EtchedBorder 的构造方法
创建具有指定蚀刻类型的浮雕化边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生
EtchedBorder(Color, Color) - 类 javax.swing.border.EtchedBorder 的构造方法
创建具有指定高亮显示和阴影颜色的阴刻浮雕化边框
EtchedBorder(int, Color, Color) - 类 javax.swing.border.EtchedBorder 的构造方法
创建具有指定蚀刻类型、高亮显示和阴影颜色的浮雕化边框
etchType - 类 javax.swing.border.EtchedBorder 中的变量
etherealize(byte[], POA, Servant, boolean, boolean) - 类 org.omg.PortableServer._ServantActivatorStub 中的方法
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要停用对象的 servant 就会调用此操作。
etherealize(byte[], POA, Servant, boolean, boolean) - 接口 org.omg.PortableServer.ServantActivatorOperations 中的方法
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要取消激活对象的 servant 就会调用此操作。
ETHIOPIC - 类 java.awt.font.NumericShaper 中的静态变量
标识 ETHIOPIC 范围和十进制基数。
ETHIOPIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Ethiopic”Unicode 字符块的常量。
EUROPEAN - 类 java.awt.font.NumericShaper 中的静态变量
标识 Latin-1（欧洲语）和扩展范围，以及 Latin-1（欧洲语）十进制基数。
eval(Reader, Bindings) - 类 javax.script.AbstractScriptEngine 中的方法
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
eval(String, Bindings) - 类 javax.script.AbstractScriptEngine 中的方法
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。
eval(Reader) - 类 javax.script.AbstractScriptEngine 中的方法
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。
eval(String) - 类 javax.script.AbstractScriptEngine 中的方法
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。
eval(ScriptContext) - 类 javax.script.CompiledScript 中的方法
执行存储在此 CompiledScript 对象中的程序。
eval(Bindings) - 类 javax.script.CompiledScript 中的方法
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。
eval() - 类 javax.script.CompiledScript 中的方法
执行存储在 CompiledScript 对象中的程序。
eval(String, ScriptContext) - 接口 javax.script.ScriptEngine 中的方法
立即执行脚本，该脚本的源是作为第一个参数传递的 String。
eval(Reader, ScriptContext) - 接口 javax.script.ScriptEngine 中的方法
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
eval(String) - 接口 javax.script.ScriptEngine 中的方法
执行指定的脚本。
eval(Reader) - 接口 javax.script.ScriptEngine 中的方法
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。
eval(String, Bindings) - 接口 javax.script.ScriptEngine 中的方法
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。
eval(Reader, Bindings) - 接口 javax.script.ScriptEngine 中的方法
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
evaluate(RowSet) - 接口 javax.sql.rowset.Predicate 中的方法
此方法通常称为 FilteredRowSet 对象内部方法（非公共），它控制 RowSet 对象的指针从一行移动到下一行。
evaluate(Object, int) - 接口 javax.sql.rowset.Predicate 中的方法
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter() 方法设置的过滤标准（或标准，如果存在多个约束）中。
evaluate(Object, String) - 接口 javax.sql.rowset.Predicate 中的方法
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。
evaluate(String, Object, QName) - 接口 javax.xml.xpath.XPath 中的方法
计算指定上下文中的 XPath 表达式并返回指定类型的结果。
evaluate(String, Object) - 接口 javax.xml.xpath.XPath 中的方法
计算指定上下文中的 XPath 表达式并返回 String 形式的结果。
evaluate(String, InputSource, QName) - 接口 javax.xml.xpath.XPath 中的方法
计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。
evaluate(String, InputSource) - 接口 javax.xml.xpath.XPath 中的方法
计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。
evaluate(Object, QName) - 接口 javax.xml.xpath.XPathExpression 中的方法
计算指定上下文中的 XPath 表达式并返回指定类型的结果。
evaluate(Object) - 接口 javax.xml.xpath.XPathExpression 中的方法
计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。
evaluate(InputSource, QName) - 接口 javax.xml.xpath.XPathExpression 中的方法
计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。
evaluate(InputSource) - 接口 javax.xml.xpath.XPathExpression 中的方法
计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。
evaluate(List) - 接口 javax.xml.xpath.XPathFunction 中的方法
计算带指定参数的函数。
evaluateChallenge(byte[]) - 接口 javax.security.sasl.SaslClient 中的方法
评估 challenge 数据并生成一个响应。
evaluateResponse(byte[]) - 接口 javax.security.sasl.SaslServer 中的方法
评估响应数据并生成一个 challenge。
Event - java.awt 中的 类
注：Event 类已废弃，只可用于向后兼容。
Event(Object, long, int, int, int, int, int, Object) - 类 java.awt.Event 的构造方法
注：Event 类已废弃，只可用于向后兼容。
Event(Object, long, int, int, int, int, int) - 类 java.awt.Event 的构造方法
注：Event 类已废弃，只可用于向后兼容。
Event(Object, int, Object) - 类 java.awt.Event 的构造方法
注：Event 类已废弃，只可用于向后兼容。
event - 异常 javax.swing.tree.ExpandVetoException 中的变量
为其创建异常的事件。
Event - org.w3c.dom.events 中的 接口
Event 接口用于为处理事件的处理程序提供关于事件的上下文信息。
EventContext - javax.naming.event 中的 接口
包含注册/注销侦听器的一些方法，这些侦听器在上下文中命名的对象发生更改时获得触发事件的通知。
EventDirContext - javax.naming.event 中的 接口
包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。
eventDispatched(AWTEvent) - 接口 java.awt.event.AWTEventListener 中的方法
在 AWT 中指派事件时调用。
eventDispatched(AWTEvent) - 类 java.awt.event.AWTEventListenerProxy 中的方法
将属性更改事件转发给侦听器代理。
EventException - org.w3c.dom.events 中的 异常
事件操作可以像在其方法描述中指定的那样抛出 EventException。
EventException(short, String) - 异常 org.w3c.dom.events.EventException 的构造方法
EventFilter - javax.xml.stream 中的 接口
此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLEventReader。
EventHandler - java.beans 中的 类
EventHandler 类为动态生成事件侦听器提供支持，这些侦听器的方法执行一条涉及传入事件对象和目标对象的简单语句。
EventHandler(Object, String, String, String) - 类 java.beans.EventHandler 的构造方法
创建一个新的 EventHandler 对象；通常使用 create 方法之一，而不是直接调用此构造方法。
EventListener - java.util 中的 接口
所有事件侦听器接口必须扩展的标记接口。
EventListener - org.w3c.dom.events 中的 接口
EventListener 接口是处理事件的主要方法。
EventListenerList - javax.swing.event 中的 类
保存 EventListener 列表的类。
EventListenerList() - 类 javax.swing.event.EventListenerList 的构造方法
EventListenerProxy - java.util 中的 类
将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。
EventListenerProxy(EventListener) - 类 java.util.EventListenerProxy 的构造方法
EventObject - java.util 中的 类
所有事件状态对象都将从其派生的根类。
EventObject(Object) - 类 java.util.EventObject 的构造方法
构造一个原型 Event。
EventQueue - java.awt 中的 类
EventQueue 是一个与平台无关的类，它将来自于底层同位体类和受信任的应用程序类的事件列入队列。
EventQueue() - 类 java.awt.EventQueue 的构造方法
EventReaderDelegate - javax.xml.stream.util 中的 类
该类是用于派生 XMLEventReader 过滤器的基类。
EventReaderDelegate() - 类 javax.xml.stream.util.EventReaderDelegate 的构造方法
构造没有父过滤器的空过滤器。
EventReaderDelegate(XMLEventReader) - 类 javax.xml.stream.util.EventReaderDelegate 的构造方法
用指定的父过滤器来构造一个过滤器。
events - 类 java.awt.dnd.DragGestureRecognizer 中的变量
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。
EventSetDescriptor - java.beans 中的 类
描述给定 Java bean 激发的一组事件的 EventSetDescriptor。
EventSetDescriptor(Class<?>, String, Class<?>, String) - 类 java.beans.EventSetDescriptor 的构造方法
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String) - 类 java.beans.EventSetDescriptor 的构造方法
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String, String) - 类 java.beans.EventSetDescriptor 的构造方法
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(String, Class<?>, Method[], Method, Method) - 类 java.beans.EventSetDescriptor 的构造方法
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String, Class<?>, Method[], Method, Method, Method) - 类 java.beans.EventSetDescriptor 的构造方法
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String, Class<?>, MethodDescriptor[], Method, Method) - 类 java.beans.EventSetDescriptor 的构造方法
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventTarget - org.w3c.dom.events 中的 接口
EventTarget 接口由支持 DOM Event Model 的实现中的所有 Nodes 实现。
eventTypeEnabled(int) - 类 java.awt.ScrollPane 中的方法
如果启用滚轮滚动，则对 MouseWheelEvents 返回 true
evt - 类 java.awt.Event 中的变量
下一事件。
examineAllHeaderElements() - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator。
examineHeaderElements(String) - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中具有指定的 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator。
examineMustUnderstandHeaderElements(String) - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中所有符合以下条件的 SOAPHeaderElement 对象上进行迭代的 Iterator：具有指定的 actor 以及一个值等于 true 的 MustUnderstand 属性。
ExcC14NParameterSpec - javax.xml.crypto.dsig.spec 中的 类
W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。
ExcC14NParameterSpec() - 类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 的构造方法
创建带有空前缀列表的 ExcC14NParameterSpec。
ExcC14NParameterSpec(List) - 类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 的构造方法
创建带有指定前缀列表的 ExcC14NParameterSpec。
ExcellentBreakWeight - 类 javax.swing.text.View 中的静态变量
该权重指示视图支持拆分，并且表示拆分的极好时机。
except(Any) - 类 org.omg.CORBA.ServerRequest 中的方法
已过时。 使用 set_exception()
except - 异常 org.omg.CORBA.UnknownUserException 中的变量
包含由服务器抛出的实际用户异常的 Any 实例。
Exception - java.lang 中的 异常
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Exception() - 异常 java.lang.Exception 的构造方法
构造详细消息为 null 的新异常。
Exception(String) - 异常 java.lang.Exception 的构造方法
构造带指定详细消息的新异常。
Exception(String, Throwable) - 异常 java.lang.Exception 的构造方法
构造带指定详细消息和原因的新异常。
Exception(Throwable) - 异常 java.lang.Exception 的构造方法
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造新异常（它通常包含 cause 的类和详细消息）。
exception() - 类 org.omg.CORBA.Environment 中的方法
检索此 Environment 对象中的异常。
exception(Exception) - 类 org.omg.CORBA.Environment 中的方法
将给定异常插入此 Environment 对象。
ExceptionDetailMessage - org.omg.IOP 中的 接口
org/omg/IOP/ExceptionDetailMessage.java。
ExceptionInInitializerError - java.lang 中的 错误
静态初始化程序中发生意外异常的信号。
ExceptionInInitializerError() - 错误 java.lang.ExceptionInInitializerError 的构造方法
构造一个 ExceptionInInitializerError，使用 null 作为其详细消息字符串，并且不使用任何保存的 throwable 对象。
ExceptionInInitializerError(Throwable) - 错误 java.lang.ExceptionInInitializerError 的构造方法
保存对抛出的 Throwable 对象的引用，以便以后通过 ExceptionInInitializerError.getException() 方法对其进行获取，通过这种方式构造一个新的 ExceptionInInitializerError 类。
ExceptionInInitializerError(String) - 错误 java.lang.ExceptionInInitializerError 的构造方法
构造带指定详细消息的 ExceptionInInitializerError。
ExceptionList - org.omg.CORBA 中的 类
Request 操作中使用的对象，用于描述可由某一方法抛出的异常。
ExceptionList() - 类 org.omg.CORBA.ExceptionList 的构造方法
ExceptionListener - java.beans 中的 接口
ExceptionListener 是在发生内部异常时获得通知。
exceptions() - 类 org.omg.CORBA.Request 中的方法
检索用于此请求的 ExceptionList 对象。
exceptions() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 TypeCode 对象数组，这些对象描述此操作调用可能抛出的用户异常的 TypeCode。
exceptionThrown(Exception) - 接口 java.beans.ExceptionListener 中的方法
此方法在捕获可恢复的异常时调用。
exchange(V) - 类 java.util.concurrent.Exchanger 中的方法
等待另一个线程到达此交换点（除非当前线程被中断），然后将给定的对象传送给该线程，并接收该线程的对象。
exchange(V, long, TimeUnit) - 类 java.util.concurrent.Exchanger 中的方法
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
Exchanger<V> - java.util.concurrent 中的 类
可以在对中对元素进行配对和交换的线程的同步点。
Exchanger() - 类 java.util.concurrent.Exchanger 的构造方法
创建一个新的 Exchanger。
exclusions - 类 javax.swing.text.html.parser.Element 中的变量
EXCLUSIVE - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的静态变量
Exclusive Canonical XML（不带注释）规范化方法的算法 URI。
EXCLUSIVE_WITH_COMMENTS - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的静态变量
带注释的 Exclusive Canonical XML 规范化方法的算法 URI。
exclusiveOr(Area) - 类 java.awt.geom.Area 中的方法
将此 Area 的形状设置为其当前形状与指定 Area 形状的组合区域，并减去其交集。
exec(String) - 类 java.lang.Runtime 中的方法
在单独的进程中执行指定的字符串命令。
exec(String, String[]) - 类 java.lang.Runtime 中的方法
在指定环境的单独进程中执行指定的字符串命令。
exec(String, String[], File) - 类 java.lang.Runtime 中的方法
在有指定环境和工作目录的独立进程中执行指定的字符串命令。
exec(String[]) - 类 java.lang.Runtime 中的方法
在单独的进程中执行指定命令和变量。
exec(String[], String[]) - 类 java.lang.Runtime 中的方法
在指定环境的独立进程中执行指定命令和变量。
exec(String[], String[], File) - 类 java.lang.Runtime 中的方法
在指定环境和工作目录的独立进程中执行指定的命令和变量。
ExecutableElement - javax.lang.model.element 中的 接口
表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。
ExecutableType - javax.lang.model.type 中的 接口
表示 executable 的类型。
execute() - 类 java.beans.Statement 中的方法
执行方法找到一个与 methodName 属性同名的方法，并在目标上调用该方法。
execute() - 接口 java.sql.PreparedStatement 中的方法
在此 PreparedStatement 对象中执行 SQL 语句，该语句可以是任何种类的 SQL 语句。
execute(String) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，该语句可能返回多个结果。
execute(String, int) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序所有自动生成的键都应该可用于获取。
execute(String, int[]) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
execute(String, String[]) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
execute(Runnable) - 接口 java.util.concurrent.Executor 中的方法
在未来某个时间执行给定的命令。
execute(Runnable) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
使用所要求的零延迟执行命令。
execute(Runnable) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
在将来某个时间执行给定任务。
execute(Connection) - 接口 javax.sql.rowset.CachedRowSet 中的方法
用数据填充此 CachedRowSet 对象，使用给定的连接来生成从中读取数据的结果集。
execute() - 接口 javax.sql.RowSet 中的方法
使用数据填充此 RowSet 对象。
execute() - 类 javax.swing.SwingWorker 中的方法
调度此 SwingWorker 以便在 worker 线程上执行。
EXECUTE_FAILED - 接口 java.sql.Statement 中的静态变量
该常量指示在执行批量语句时发生错误。
executeBatch() - 接口 java.sql.Statement 中的方法
将一批命令提交给数据库来执行，如果全部命令执行成功，则返回更新计数组成的数组。
executeCall() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
executeQuery() - 接口 java.sql.PreparedStatement 中的方法
在此 PreparedStatement 对象中执行 SQL 查询，并返回该查询生成的 ResultSet 对象。
executeQuery(String) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。
executeUpdate() - 接口 java.sql.PreparedStatement 中的方法
在此 PreparedStatement 对象中执行 SQL 语句，该语句必须是一个 SQL 数据操作语言（Data Manipulation Language，DML）语句，比如 INSERT、UPDATE 或 DELETE 语句；或者是无返回内容的 SQL 语句，比如 DDL 语句。
executeUpdate(String) - 接口 java.sql.Statement 中的方法
执行给定 SQL 语句，该语句可能为 INSERT、UPDATE 或 DELETE 语句，或者不返回任何内容的 SQL 语句（如 SQL DDL 语句）。
executeUpdate(String, int) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，并用给定标志通知驱动程序由此 Statement 生成的自动生成键是否可用于获取。
executeUpdate(String, int[]) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
executeUpdate(String, String[]) - 接口 java.sql.Statement 中的方法
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
ExecutionException - java.util.concurrent 中的 异常
当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
ExecutionException() - 异常 java.util.concurrent.ExecutionException 的构造方法
构造不带详细消息的 ExecutionException。
ExecutionException(String) - 异常 java.util.concurrent.ExecutionException 的构造方法
构造带指定详细消息的 ExecutionException。
ExecutionException(String, Throwable) - 异常 java.util.concurrent.ExecutionException 的构造方法
构造带指定详细消息和原因的 ExecutionException。
ExecutionException(Throwable) - 异常 java.util.concurrent.ExecutionException 的构造方法
构造带指定原因的 ExecutionException。
EXECUTIVE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Executive (7 1/4 x 10 1/2 in) 的 MediaType 实例。
EXECUTIVE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 executive 尺寸，7.25 inch × 10.5 inch。
EXECUTIVE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
executive 尺寸。
Executor - java.util.concurrent 中的 接口
执行已提交的 Runnable 任务的对象。
ExecutorCompletionService<V> - java.util.concurrent 中的 类
使用提供的 Executor 来执行任务的 CompletionService。
ExecutorCompletionService(Executor) - 类 java.util.concurrent.ExecutorCompletionService 的构造方法
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将 LinkedBlockingQueue 作为完成队列。
ExecutorCompletionService(Executor, BlockingQueue<Future<V>>) - 类 java.util.concurrent.ExecutorCompletionService 的构造方法
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。
Executors - java.util.concurrent 中的 类
此包中所定义的 Executor、ExecutorService、ScheduledExecutorService、ThreadFactory 和 Callable 类的工厂和实用方法。
ExecutorService - java.util.concurrent 中的 接口
Executor 提供了管理终止的方法，以及可为跟踪一个或多个异步任务执行状况而生成 Future 的方法。
ExemptionMechanism - javax.crypto 中的 类
此类提供了豁免 (exemption) 机制的功能，例如，密钥恢复、密钥唤醒 和密钥托管。
ExemptionMechanism(ExemptionMechanismSpi, Provider, String) - 类 javax.crypto.ExemptionMechanism 的构造方法
创建 ExemptionMechanism 对象。
ExemptionMechanismException - javax.crypto 中的 异常
此为一般 ExemptionMechanism 异常。
ExemptionMechanismException() - 异常 javax.crypto.ExemptionMechanismException 的构造方法
构造不带详细消息的 ExemptionMechanismException。
ExemptionMechanismException(String) - 异常 javax.crypto.ExemptionMechanismException 的构造方法
构造带指定详细消息的 ExemptionMechanismException。
ExemptionMechanismSpi - javax.crypto 中的 类
此类为 ExemptionMechanism 类定义了服务提供者接口 (SPI)。
ExemptionMechanismSpi() - 类 javax.crypto.ExemptionMechanismSpi 的构造方法
exists() - 类 java.io.File 中的方法
测试此抽象路径名表示的文件或目录是否存在。
exit(int) - 类 java.lang.Runtime 中的方法
通过启动虚拟机的关闭序列，终止当前正在运行的 Java 虚拟机。
exit(int) - 类 java.lang.System 中的静态方法
终止当前正在运行的 Java 虚拟机。
EXIT_ON_CLOSE - 类 javax.swing.JFrame 中的静态变量
退出应用程序后的默认窗口关闭操作。
EXIT_ON_CLOSE - 接口 javax.swing.WindowConstants 中的静态变量
退出应用程序默认窗口关闭操作。
EXITED - 类 javax.swing.event.HyperlinkEvent.EventType 中的静态变量
退出类型。
exiting(String, String) - 类 java.util.logging.Logger 中的方法
记录一个方法返回。
exiting(String, String, Object) - 类 java.util.logging.Logger 中的方法
记录一个方法返回，带有结果对象。
exitValue() - 类 java.lang.Process 中的方法
返回子进程的出口值。
exp(double) - 类 java.lang.Math 中的静态方法
返回欧拉数 e 的 double 次幂的值。
exp(double) - 类 java.lang.StrictMath 中的静态方法
返回欧拉数 e 的 double 次幂的值。
EXPANDABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象允许逐步显示其子级。
EXPANDED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是展开的。
expandedIcon - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
expandPath(TreePath) - 类 javax.swing.JTree 中的方法
确保指定路径标识的节点展开，并且可查看。
expandRow(int) - 类 javax.swing.JTree 中的方法
确保指定行中的节点展开，并且可查看。
EXPANDS_SELECTED_PATHS_PROPERTY - 类 javax.swing.JTree 中的静态变量
展开选择路径属性的绑定属性名称
expandTabRunsArray() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
ExpandVetoException - javax.swing.tree 中的 异常
用于阻止扩展/折叠发生的异常。
ExpandVetoException(TreeExpansionEvent) - 异常 javax.swing.tree.ExpandVetoException 的构造方法
构造不带任何消息的 ExpandVetoException 对象。
ExpandVetoException(TreeExpansionEvent, String) - 异常 javax.swing.tree.ExpandVetoException 的构造方法
构造带指定消息的 ExpandVetoException 对象。
expm1(double) - 类 java.lang.Math 中的静态方法
返回 ex -1。
expm1(double) - 类 java.lang.StrictMath 中的静态方法
返回 ex -1。
EXPONENT - 类 java.text.NumberFormat.Field 中的静态变量
标识指数字段的常量。
EXPONENT_SIGN - 类 java.text.NumberFormat.Field 中的静态变量
标识指数符号 (exponent sign) 字段的常量。
EXPONENT_SYMBOL - 类 java.text.NumberFormat.Field 中的静态变量
标识指数符号 (exponent symbol) 字段的常量。
export() - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
export() - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
export() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
导出此 RMI 对象。
export() - 接口 org.ietf.jgss.GSSContext 中的方法
导出此上下文，以便使其他进程能够导入它。
export() - 接口 org.ietf.jgss.GSSName 中的方法
返回机制名称 (MN) 的规范化连续字节表示形式，适合通过授权的功能进行直接的、逐字节比较。
exportAsDrag(JComponent, InputEvent, int) - 类 javax.swing.TransferHandler 中的方法
导致 Swing 拖动支持的启用。
exportDone(JComponent, Transferable, int) - 类 javax.swing.TransferHandler 中的方法
在导出数据之后调用。
ExportException - java.rmi.server 中的 异常
ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
ExportException(String) - 异常 java.rmi.server.ExportException 的构造方法
构造带指定详细消息的 ExportException。
ExportException(String, Exception) - 异常 java.rmi.server.ExportException 的构造方法
构造带指定详细消息和嵌入异常的 ExportException。
exportNode(OutputStream) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
exportNode(OutputStream) - 类 java.util.prefs.Preferences 中的方法
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
exportObject(Remote, String, MarshalledObject<?>, boolean, int) - 类 java.rmi.activation.Activatable 中的静态方法
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
exportObject(Remote, String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.activation.Activatable 中的静态方法
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
exportObject(Remote, ActivationID, int) - 类 java.rmi.activation.Activatable 中的静态方法
将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
exportObject(Remote, ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.activation.Activatable 中的静态方法
将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
exportObject(Remote, Object) - 接口 java.rmi.server.ServerRef 中的方法
为提供的 Remote 对象创建客户机 stub 对象。
exportObject(Remote) - 类 java.rmi.server.UnicastRemoteObject 中的静态方法
使用匿名端口导出远程对象，以便能够接收传入的调用。
exportObject(Remote, int) - 类 java.rmi.server.UnicastRemoteObject 中的静态方法
使用提供的特定端口导出远程对象，以便能够接收传入的调用。
exportObject(Remote, int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.server.UnicastRemoteObject 中的静态方法
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
exportObject(Remote) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.exportObject(java.rmi.Remote) 的委托调用。
exportObject(Remote) - 类 javax.rmi.PortableRemoteObject 中的静态方法
准备服务器对象，以接收远程调用。
exportSubtree(OutputStream) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
exportSubtree(OutputStream) - 类 java.util.prefs.Preferences 中的方法
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。
exportToClipboard(JComponent, Clipboard, int) - 类 javax.swing.TransferHandler 中的方法
导致从给定组件到给定剪贴板的传输。
Expression - java.beans 中的 类
Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。
Expression(Object, String, Object[]) - 类 java.beans.Expression 的构造方法
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。
Expression(Object, Object, String, Object[]) - 类 java.beans.Expression 的构造方法
为某个返回结果的方法创建一个新的 Expression 对象。
extendedOperation(ExtendedRequest) - 类 javax.naming.ldap.InitialLdapContext 中的方法
extendedOperation(ExtendedRequest) - 接口 javax.naming.ldap.LdapContext 中的方法
执行扩展操作。
ExtendedRequest - javax.naming.ldap 中的 接口
此接口表示在 RFC 2251 中定义的 LDAPv3 扩展操作请求。
ExtendedResponse - javax.naming.ldap 中的 接口
此接口表示在 RFC 2251 中定义的 LDAP 扩展操作响应。
extension - 枚举 javax.tools.JavaFileObject.Kind 中的变量
通常用于此类文件对象的扩展名（按照约定）。
EXTENSION_INSTALLATION - 类 java.util.jar.Attributes.Name 中的静态变量
Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
EXTENSION_LIST - 类 java.util.jar.Attributes.Name 中的静态变量
Extension-List 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
EXTENSION_NAME - 类 java.util.jar.Attributes.Name 中的静态变量
Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
extent - 类 java.awt.geom.Arc2D.Double 中的变量
弧的角跨越（以度数表示）。
extent - 类 java.awt.geom.Arc2D.Float 中的变量
弧的角跨越（以度数表示）。
externalEntityDecl(String, String, String) - 接口 org.xml.sax.ext.DeclHandler 中的方法
报告解析的外部实体声明。
externalEntityDecl(String, String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
Externalizable - java.io 中的 接口
Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。
extract(Any) - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ObjectHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.StringValueHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
extract(Any) - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.BindingHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.IstringHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NameHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
extract(Any) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
extract(Any) - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.IORHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
extract(Any) - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
extract(Any) - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
extract(Any) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
extract_any() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 Any 对象。
extract_boolean() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 boolean 值。
extract_char() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 char 值。
extract_double() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 double 值。
extract_fixed() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 java.math.BigDecimal 对象。
extract_float() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 float 值。
extract_long() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 int 值。
extract_longlong() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 long 值。
extract_Object() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 org.omg.CORBA.Object。
extract_octet() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 byte 值。
extract_Principal() - 类 org.omg.CORBA.Any 中的方法
已过时。 由 CORBA 2.2 取代。
extract_short() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 short 值。
extract_Streamable() - 类 org.omg.CORBA.Any 中的方法
从此 Any 对象的 value 字段提取 Streamable。
extract_string() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 String 对象。
extract_TypeCode() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 TypeCode 对象。
extract_ulong() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 int 值。
extract_ulonglong() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 long 值。
extract_ushort() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 short 值。
extract_Value() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 java.io.Serializable 对象。
extract_wchar() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 char 值。
extract_wstring() - 类 org.omg.CORBA.Any 中的方法
提取此 Any 对象 value 字段中的 String 对象。
extractAllHeaderElements() - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
extractContentAsDocument() - 接口 javax.xml.soap.SOAPBody 中的方法
创建新的 DOM Document，并将此 SOAPBody 的第一个子元素设置为它的文档元素。
extractHeaderElements(String) - 接口 javax.xml.soap.SOAPHeader 中的方法
返回可在此 SOAPHeader 对象中所有具有指定 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
extraImageMetadataFormatClassNames - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的其他任何图像元数据格式的类名称的 String 数组，该数组最初为 null。
extraImageMetadataFormatNames - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的其他任何图像元数据格式的名称的 String 数组，该数组最初为 null。
extraMetadataFormatClassNames - 类 javax.imageio.metadata.IIOMetadata 中的变量
实现 IIOMetadataFormat 和表示此插件支持的元数据格式（标准格式和本机格式除外）的类的名称所组成的数组，初始化为 null，通过构造方法设置。
extraMetadataFormatNames - 类 javax.imageio.metadata.IIOMetadata 中的变量
此插件支持的格式（标准格式和本机格式除外）的名称所组成的数组，初始化为 null，通过构造方法设置。
extraStreamMetadataFormatClassNames - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的其他任何流元数据格式的类名称的 String 数组，该数组最初为 null。
extraStreamMetadataFormatNames - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的其他任何流元数据格式的名称的 String 数组，该字符串最初为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


F - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

F

F0 - 类 java.security.spec.RSAKeyGenParameterSpec 中的静态变量
公用指数值 F0 = 3。
F1 - 类 java.awt.Event 中的静态变量
F1 功能键，一个非 ASCII 操作键。
F10 - 类 java.awt.Event 中的静态变量
F10 功能键，一个非 ASCII 操作键。
F11 - 类 java.awt.Event 中的静态变量
F11 功能键，一个非 ASCII 操作键。
F12 - 类 java.awt.Event 中的静态变量
F12 功能键，一个非 ASCII 操作键。
F2 - 类 java.awt.Event 中的静态变量
F2 功能键，一个非 ASCII 操作键。
F3 - 类 java.awt.Event 中的静态变量
F3 功能键，一个非 ASCII 操作键。
F4 - 类 java.awt.Event 中的静态变量
F4 功能键，一个非 ASCII 操作键。
F4 - 类 java.security.spec.RSAKeyGenParameterSpec 中的静态变量
公用指数值 F4 = 65537。
F5 - 类 java.awt.Event 中的静态变量
F5 功能键，一个非 ASCII 操作键。
F6 - 类 java.awt.Event 中的静态变量
F6 功能键，一个非 ASCII 操作键。
F7 - 类 java.awt.Event 中的静态变量
F7 功能键，一个非 ASCII 操作键。
F8 - 类 java.awt.Event 中的静态变量
F8 功能键，一个非 ASCII 操作键。
F9 - 类 java.awt.Event 中的静态变量
F9 功能键，一个非 ASCII 操作键。
FACE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
FactoryConfigurationError - javax.xml.parsers 中的 错误
当解析器工厂的配置存在问题时抛出该异常。
FactoryConfigurationError() - 错误 javax.xml.parsers.FactoryConfigurationError 的构造方法
创建一个新的不带详细消息的 FactoryConfigurationError。
FactoryConfigurationError(String) - 错误 javax.xml.parsers.FactoryConfigurationError 的构造方法
创建一个新的 FactoryConfigurationError，并将 String 指定为一个错误消息。
FactoryConfigurationError(Exception) - 错误 javax.xml.parsers.FactoryConfigurationError 的构造方法
使用错误的给定 Exception 基本原因创建一个新的 FactoryConfigurationError。
FactoryConfigurationError(Exception, String) - 错误 javax.xml.parsers.FactoryConfigurationError 的构造方法
使用给定 Exception 的基本原因和详细消息创建一个新的 FactoryConfigurationError。
FactoryConfigurationError - javax.xml.stream 中的 错误
一个用于报告工厂配置错误的错误类。
FactoryConfigurationError() - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
默认构造方法。
FactoryConfigurationError(Exception) - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
构造具有嵌套内部异常的异常。
FactoryConfigurationError(Exception, String) - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
构造具有嵌套内部异常和消息的异常。
FactoryConfigurationError(String, Exception) - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
构造具有嵌套内部异常和消息的异常。
FactoryConfigurationError(String) - 错误 javax.xml.stream.FactoryConfigurationError 的构造方法
构造具有关联消息的异常。
FAILED - 类 javax.management.remote.JMXConnectionNotification 中的静态变量
连接失败通知的通知类型字符串。
FailedLoginException - javax.security.auth.login 中的 异常
当用户验证失败时抛出此异常。
FailedLoginException() - 异常 javax.security.auth.login.FailedLoginException 的构造方法
构造不带详细消息的 FailedLoginException。
FailedLoginException(String) - 异常 javax.security.auth.login.FailedLoginException 的构造方法
构造带指定详细消息的 FailedLoginException。
failure(Exception) - 接口 java.rmi.server.RMIFailureHandler 中的方法
在 RMI 运行时无法通过 RMISocketFactory 创建 ServerSocket 时调用该 failure 回调。
FAILURE - 异常 org.ietf.jgss.GSSException 中的静态变量
未在 GSS-API 级别指定的一般故障。
FALSE - 类 java.lang.Boolean 中的静态变量
对应基值 false 的 Boolean 对象。
FALSE - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "false"，某些属性的可能值。
FALSE - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
字符串 "false"，某些属性的可能值。
FAMILY - 类 java.awt.font.TextAttribute 中的静态变量
字体名称的属性键。
Family - 类 javax.swing.text.StyleConstants 中的静态变量
字体系列的名称。
FATAL_ERROR - 接口 javax.xml.bind.ValidationEvent 中的静态变量
对应于 W3C XML 1.0 Recommendation 第 1.2 节中的“致命错误”的定义的条件。
fatalError(TransformerException) - 接口 javax.xml.transform.ErrorListener 中的方法
接收不可恢复错误的通知。
fatalError(SAXParseException) - 接口 org.xml.sax.ErrorHandler 中的方法
接收不可恢复的错误的通知。
fatalError(SAXParseException) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 报告严重的 XML 解析错误。
fatalError(SAXParseException) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
报告严重的 XML 解析错误。
fatalError(SAXParseException) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个严重的错误事件。
fd - 类 java.net.DatagramSocketImpl 中的变量
文件描述符对象。
fd - 类 java.net.SocketImpl 中的变量
此套接字的文件描述符对象。
FEATURE - 类 javax.xml.transform.dom.DOMResult 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
FEATURE - 类 javax.xml.transform.dom.DOMSource 中的静态变量
当将此值作为参数传递时如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。
FEATURE - 类 javax.xml.transform.sax.SAXResult 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
FEATURE - 类 javax.xml.transform.sax.SAXSource 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。
FEATURE - 类 javax.xml.transform.sax.SAXTransformerFactory 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则从 TransformerFactory.newInstance() 返回的 TransformerFactory 可以安全地被转换为 SAXTransformerFactory。
FEATURE - 类 javax.xml.transform.stax.StAXResult 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Result 输出。
FEATURE - 类 javax.xml.transform.stax.StAXSource 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Source 输入。
FEATURE - 类 javax.xml.transform.stream.StreamResult 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。
FEATURE - 类 javax.xml.transform.stream.StreamSource 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source。
FEATURE_SECURE_PROCESSING - 类 javax.xml.XMLConstants 中的静态变量
用于安全处理的功能。
FEATURE_XMLFILTER - 类 javax.xml.transform.sax.SAXTransformerFactory 中的静态变量
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 SAXTransformerFactory.newXMLFilter(Source src) 和 SAXTransformerFactory.newXMLFilter(Templates templates) 方法是受支持的。
FeatureDescriptor - java.beans 中的 类
FeatureDescriptor 类是 PropertyDescriptor、EventSetDescriptor 和 MethodDescriptor 等的公共基类。
FeatureDescriptor() - 类 java.beans.FeatureDescriptor 的构造方法
构造一个 FeatureDescriptor。
FEBRUARY - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第二个月的 Calendar.MONTH 字段值。
FEBRUARY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第二个月的值。
FETCH_FORWARD - 接口 java.sql.ResultSet 中的静态变量
该常量指示将按正向（即从第一个到最后一个）处理结果集中的行。
FETCH_REVERSE - 接口 java.sql.ResultSet 中的静态变量
该常量指示将按逆向（即从最后一个到第一个）处理结果集中的行处理。
FETCH_UNKNOWN - 接口 java.sql.ResultSet 中的静态变量
该常量指示结果集中的行的处理顺序未知。
fetchNotifications(long, int, long) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
检索来自连接器服务器的通知。
fetchNotifications(long, int, long) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
fetchNotifications(long, int, long) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
fictional() - 类 javax.swing.text.html.parser.TagElement 中的方法
Fidelity - javax.print.attribute.standard 中的 类
Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
Fidelity(int) - 类 javax.print.attribute.standard.Fidelity 的构造方法
构造具有给定整数值的新保真度枚举值。
FIDELITY_FALSE - 类 javax.print.attribute.standard.Fidelity 中的静态变量
打印机应对打印作业进行合理尝试，即使它不能完全按照指定的要求打印该作业。
FIDELITY_TRUE - 类 javax.print.attribute.standard.Fidelity 中的静态变量
必须完全按照指定的要求打印作业，或者拒绝该作业。
Field - java.lang.reflect 中的 类
Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
FIELD_ATTRIBUTE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
当与字段属性名称连在一起时，指出该属性的格式。
FIELD_COUNT - 类 java.util.Calendar 中的静态变量
get 和 set 可识别的不同字段的数量。
FIELD_UNDEFINED - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
指定不设置“int”字段。
FieldNameHelper - org.omg.CORBA 中的 类
FieldName 的 Helper。
FieldNameHelper() - 类 org.omg.CORBA.FieldNameHelper 的构造方法
FieldNameHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/FieldNameHelper.java。
FieldNameHelper() - 类 org.omg.DynamicAny.FieldNameHelper 的构造方法
FieldPosition - java.text 中的 类
FieldPosition 是 Format 及其子类用于在格式输出中标识字段的简单类。
FieldPosition(int) - 类 java.text.FieldPosition 的构造方法
为给定字段创建一个 FieldPosition 对象。
FieldPosition(Format.Field) - 类 java.text.FieldPosition 的构造方法
为给定的字段常量创建一个 FieldPosition 对象。
FieldPosition(Format.Field, int) - 类 java.text.FieldPosition 的构造方法
为给定的字段创建一个 FieldPosition 对象。
fields - 类 java.util.Calendar 中的变量
此日历当前设置时间的日历字段值。
fieldsIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中字段的列表。
fieldsIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中字段的集合。
FieldView - javax.swing.text 中的 类
扩展多行纯文本视图，使其适合单行编辑器视图。
FieldView(Element) - 类 javax.swing.text.FieldView 的构造方法
构造包装了元素的新 FieldView。
FILE - 类 java.awt.JobAttributes.DestinationType 中的静态变量
用于指定打印到文件的 DestinationType 实例。
File - java.io 中的 类
文件和目录路径名的抽象表示形式。
File(String) - 类 java.io.File 的构造方法
通过将给定路径名字符串转换为抽象路径名来创建一个新 File 实例。
File(String, String) - 类 java.io.File 的构造方法
根据 parent 路径名字符串和 child 路径名字符串创建一个新 File 实例。
File(File, String) - 类 java.io.File 的构造方法
根据 parent 抽象路径名和 child 路径名字符串创建一个新 File 实例。
File(URI) - 类 java.io.File 的构造方法
通过将给定的 file: URI 转换为一个抽象路径名来创建一个新的 File 实例。
FILE - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
特定于主机的文件名称。
FILE_CHOOSER - 类 javax.accessibility.AccessibleRole 中的静态变量
一个专用的对话框，它显示目录中的文件，并允许用户选择文件、浏览不同的目录，或指定一个文件名。
FILE_CHOOSER - 类 javax.swing.plaf.synth.Region 中的静态变量
FileChooser 的 region。
FILE_CHOOSER_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
FILE_FILTER_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
用户更改要显示的文件种类。
FILE_HIDING_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识在显示隐藏文件属性中的更改。
FILE_SELECTION_MODE_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识在选择种类（选择单个、多个等等）方面的更改。
FILE_SYSTEM_VIEW_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
声明使用其他对象在系统上查找可用的驱动器。
FILE_VERSION - 类 javax.swing.text.html.parser.DTD 中的静态变量
FILE_VIEW_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
声明使用其他对象检索文件信息。
FileCacheImageInputStream - javax.imageio.stream 中的 类
从常规 InputStream 获取其输入的 ImageInputStream 的实现。
FileCacheImageInputStream(InputStream, File) - 类 javax.imageio.stream.FileCacheImageInputStream 的构造方法
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
FileCacheImageOutputStream - javax.imageio.stream 中的 类
将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
FileCacheImageOutputStream(OutputStream, File) - 类 javax.imageio.stream.FileCacheImageOutputStream 的构造方法
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
FileChannel - java.nio.channels 中的 类
用于读取、写入、映射和操作文件的通道。
FileChannel() - 类 java.nio.channels.FileChannel 的构造方法
初始化此类的一个新实例。
FileChannel.MapMode - java.nio.channels 中的 类
文件映射模式的类型安全的枚举。
FileChooserUI - javax.swing.plaf 中的 类
JFileChooser 的可插入外观界面。
FileChooserUI() - 类 javax.swing.plaf.FileChooserUI 的构造方法
FileDataSource - javax.activation 中的 类
FileDataSource 类实现一个封装文件的简单 DataSource 对象。
FileDataSource(File) - 类 javax.activation.FileDataSource 的构造方法
根据 File 对象创建 FileDataSource。
FileDataSource(String) - 类 javax.activation.FileDataSource 的构造方法
根据指定的路径名创建 FileDataSource。
FileDescriptor - java.io 中的 类
文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。
FileDescriptor() - 类 java.io.FileDescriptor 的构造方法
构造一个（无效的）FileDescriptor 对象。
FileDialog - java.awt 中的 类
FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
FileDialog(Frame) - 类 java.awt.FileDialog 的构造方法
创建一个文件对话框，用于加载文件。
FileDialog(Frame, String) - 类 java.awt.FileDialog 的构造方法
创建一个具有指定标题的文件对话框窗口，用于加载文件。
FileDialog(Frame, String, int) - 类 java.awt.FileDialog 的构造方法
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。
FileDialog(Dialog) - 类 java.awt.FileDialog 的构造方法
创建一个文件对话框，用于加载文件。
FileDialog(Dialog, String) - 类 java.awt.FileDialog 的构造方法
创建一个具有指定标题的文件对话框，用于加载文件。
FileDialog(Dialog, String, int) - 类 java.awt.FileDialog 的构造方法
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。
FileFilter - java.io 中的 接口
用于抽象路径名的过滤器。
FileFilter - javax.swing.filechooser 中的 类
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。
FileFilter() - 类 javax.swing.filechooser.FileFilter 的构造方法
FileHandler - java.util.logging 中的 类
简单的文件日志记录 Handler。
FileHandler() - 类 java.util.logging.FileHandler 的构造方法
构造一个默认的 FileHandler。
FileHandler(String) - 类 java.util.logging.FileHandler 的构造方法
初始化要写入给定文件名的 FileHandler 。
FileHandler(String, boolean) - 类 java.util.logging.FileHandler 的构造方法
初始化要写入给定文件名的 FileHandler（使用可选的 append）。
FileHandler(String, int, int) - 类 java.util.logging.FileHandler 的构造方法
初始化要写入文件集的 FileHandler。
FileHandler(String, int, int, boolean) - 类 java.util.logging.FileHandler 的构造方法
初始化要写入文件集的 FileHandler（使用可选的 append）。
fileIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
FileImageInputStream - javax.imageio.stream 中的 类
从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
FileImageInputStream(File) - 类 javax.imageio.stream.FileImageInputStream 的构造方法
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageInputStream(RandomAccessFile) - 类 javax.imageio.stream.FileImageInputStream 的构造方法
构造一个将从给定 RandomAccessFile 进行读取的 FileImageInputStream。
FileImageOutputStream - javax.imageio.stream 中的 类
将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
FileImageOutputStream(File) - 类 javax.imageio.stream.FileImageOutputStream 的构造方法
构造一个将向给定 File 进行写入的 FileImageOutputStream。
FileImageOutputStream(RandomAccessFile) - 类 javax.imageio.stream.FileImageOutputStream 的构造方法
构造一个向给定 FileImageOutputStream 进行写入的 RandomAccessFile。
FileInputStream - java.io 中的 类
FileInputStream 从文件系统中的某个文件中获得输入字节。
FileInputStream(String) - 类 java.io.FileInputStream 的构造方法
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的路径名 name 指定。
FileInputStream(File) - 类 java.io.FileInputStream 的构造方法
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的 File 对象 file 指定。
FileInputStream(FileDescriptor) - 类 java.io.FileInputStream 的构造方法
通过使用文件描述符 fdObj 创建一个 FileInputStream，该文件描述符表示到文件系统中某个实际文件的现有连接。
FileLock - java.nio.channels 中的 类
表示文件区域锁定的标记。
FileLock(FileChannel, long, long, boolean) - 类 java.nio.channels.FileLock 的构造方法
初始化此类的一个新实例。
FileLockInterruptionException - java.nio.channels 中的 异常
当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
FileLockInterruptionException() - 异常 java.nio.channels.FileLockInterruptionException 的构造方法
构造此类的一个实例。
fileManager - 类 javax.tools.ForwardingJavaFileManager 中的变量
一个文件管理器，所有方法都将委托给它。
FILENAME - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它是将被执行的文件的名称。
FileNameExtensionFilter - javax.swing.filechooser 中的 类
FileFilter 的一个实现，它使用指定的扩展名集合进行过滤。
FileNameExtensionFilter(String, String...) - 类 javax.swing.filechooser.FileNameExtensionFilter 的构造方法
使用指定的描述和文件扩展名创建一个 FileNameExtensionFilter。
FilenameFilter - java.io 中的 接口
实现此接口的类实例可用于过滤器文件名。
FileNameMap - java.net 中的 接口
提供在文件名和 MIME 类型字符串之间进行映射的机制的简单接口。
FileNotFoundException - java.io 中的 异常
当试图打开指定路径名表示的文件失败时，抛出此异常。
FileNotFoundException() - 异常 java.io.FileNotFoundException 的构造方法
使用 null 作为错误详细消息构造 FileNotFoundException。
FileNotFoundException(String) - 异常 java.io.FileNotFoundException 的构造方法
构造带有指定详细消息的 FileNotFoundException。
FileObject - javax.tools 中的 接口
工具的文件抽象。
fileObject - 类 javax.tools.ForwardingFileObject 中的变量
一个文件对象，所有方法都将委托给它。
FileOutputStream - java.io 中的 类
文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
FileOutputStream(String) - 类 java.io.FileOutputStream 的构造方法
创建一个向具有指定名称的文件中写入数据的输出文件流。
FileOutputStream(String, boolean) - 类 java.io.FileOutputStream 的构造方法
创建一个向具有指定 name 的文件中写入数据的输出文件流。
FileOutputStream(File) - 类 java.io.FileOutputStream 的构造方法
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(File, boolean) - 类 java.io.FileOutputStream 的构造方法
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(FileDescriptor) - 类 java.io.FileOutputStream 的构造方法
创建一个向指定文件描述符处写入数据的输出文件流，该文件描述符表示一个到文件系统中的某个实际文件的现有连接。
FilePermission - java.io 中的 类
此类表示对文件和目录的访问。
FilePermission(String, String) - 类 java.io.FilePermission 的构造方法
创建具有指定操作的新 FilePermission 对象，path 是文件或目录的路径名，actions 包含对文件或目录授予的所需操作的列表，该列表由逗号分隔。
Filer - javax.annotation.processing 中的 接口
此接口支持通过注释处理器创建新文件。
FileReader - java.io 中的 类
用来读取字符文件的便捷类。
FileReader(String) - 类 java.io.FileReader 的构造方法
在给定从中读取数据的文件名的情况下创建一个新 FileReader。
FileReader(File) - 类 java.io.FileReader 的构造方法
在给定从中读取数据的 File 的情况下创建一个新 FileReader。
FileReader(FileDescriptor) - 类 java.io.FileReader 的构造方法
在给定从中读取数据的 FileDescriptor 的情况下创建一个新 FileReader。
FilerException - javax.annotation.processing 中的 异常
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。
FilerException(String) - 异常 javax.annotation.processing.FilerException 的构造方法
构造带指定详细消息的异常。
FILES_AND_DIRECTORIES - 类 javax.swing.JFileChooser 中的静态变量
指示显示文件和目录。
FILES_ONLY - 类 javax.swing.JFileChooser 中的静态变量
指示仅显示文件。
FileSystemView - javax.swing.filechooser 中的 类
FileSystemView 是 JFileChooser 的文件系统网关。
FileSystemView() - 类 javax.swing.filechooser.FileSystemView 的构造方法
FileTypeMap - javax.activation 中的 类
FileTypeMap 是一个抽象类，它为文件提供数据分类接口。
FileTypeMap() - 类 javax.activation.FileTypeMap 的构造方法
默认的构造方法。
FileView - javax.swing.filechooser 中的 类
FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。
FileView() - 类 javax.swing.filechooser.FileView 的构造方法
FileWriter - java.io 中的 类
用来写入字符文件的便捷类。
FileWriter(String) - 类 java.io.FileWriter 的构造方法
根据给定的文件名构造一个 FileWriter 对象。
FileWriter(String, boolean) - 类 java.io.FileWriter 的构造方法
根据给定的文件名以及指示是否附加写入数据的 boolean 值来构造 FileWriter 对象。
FileWriter(File) - 类 java.io.FileWriter 的构造方法
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(File, boolean) - 类 java.io.FileWriter 的构造方法
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(FileDescriptor) - 类 java.io.FileWriter 的构造方法
构造与某个文件描述符相关联的 FileWriter 对象。
FILL - 类 java.awt.font.ShapeGraphicAttribute 中的静态变量
指示应填充该形状的键。
fill(Shape) - 类 java.awt.Graphics2D 中的方法
使用 Graphics2D 上下文的设置，填充 Shape 的内部区域。
fill - 类 java.awt.GridBagConstraints 中的变量
当组件的显示区域大于它所请求的显示区域的大小时使用此字段。
fill(long[], long) - 类 java.util.Arrays 中的静态方法
将指定的 long 值分配给指定 long 型数组的每个元素。
fill(long[], int, int, long) - 类 java.util.Arrays 中的静态方法
将指定的 long 值分配给指定 long 型数组指定范围中的每个元素。
fill(int[], int) - 类 java.util.Arrays 中的静态方法
将指定的 int 值分配给指定 int 型数组的每个元素。
fill(int[], int, int, int) - 类 java.util.Arrays 中的静态方法
将指定的 int 值分配给指定 int 型数组指定范围中的每个元素。
fill(short[], short) - 类 java.util.Arrays 中的静态方法
将指定的 short 值分配给指定 short 型数组的每个元素。
fill(short[], int, int, short) - 类 java.util.Arrays 中的静态方法
将指定的 short 值分配给指定 short 型数组指定范围中的每个元素。
fill(char[], char) - 类 java.util.Arrays 中的静态方法
将指定的 char 值分配给指定 char 型数组的每个元素。
fill(char[], int, int, char) - 类 java.util.Arrays 中的静态方法
将指定的 char 值分配给指定 char 型数组指定范围中的每个元素。
fill(byte[], byte) - 类 java.util.Arrays 中的静态方法
将指定的 byte 值分配给指定 byte 节型数组的每个元素。
fill(byte[], int, int, byte) - 类 java.util.Arrays 中的静态方法
将指定的 byte 值分配给指定 byte 型数组指定范围中的每个元素。
fill(boolean[], boolean) - 类 java.util.Arrays 中的静态方法
将指定的 boolean 值分配给指定 boolean 型数组的每个元素。
fill(boolean[], int, int, boolean) - 类 java.util.Arrays 中的静态方法
将指定的 boolean 值分配给指定 boolean 型数组指定范围中的每个元素。
fill(double[], double) - 类 java.util.Arrays 中的静态方法
将指定的 double 值分配给指定 double 型数组的每个元素。
fill(double[], int, int, double) - 类 java.util.Arrays 中的静态方法
将指定的 double 值分配给指定 double 型数组指定范围中的每个元素。
fill(float[], float) - 类 java.util.Arrays 中的静态方法
将指定的 float 值分配给指定 float 型数组的每个元素。
fill(float[], int, int, float) - 类 java.util.Arrays 中的静态方法
将指定的 float 值分配给指定 float 型数组指定范围中的每个元素。
fill(Object[], Object) - 类 java.util.Arrays 中的静态方法
将指定的 Object 引用分配给指定 Object 数组的每个元素。
fill(Object[], int, int, Object) - 类 java.util.Arrays 中的静态方法
将指定的 Object 引用分配给指定 Object 数组指定范围中的每个元素。
fill(List<? super T>, T) - 类 java.util.Collections 中的静态方法
使用指定元素替换指定列表中的所有元素。
fill() - 类 java.util.zip.InflaterInputStream 中的方法
使用更多要解压缩的数据填充输入缓冲区。
fill3DRect(int, int, int, int, boolean) - 类 java.awt.Graphics 中的方法
绘制一个用当前颜色填充的 3-D 高亮显示矩形。
fill3DRect(int, int, int, int, boolean) - 类 java.awt.Graphics2D 中的方法
绘制一个用当前颜色填充的 3-D 高亮显示矩形。
fill3DRect(int, int, int, int, boolean) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fill3DRect。
fillArc(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
填充覆盖指定矩形的圆弧或椭圆弧。
fillArc(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillArc。
filledSlider - 类 javax.swing.plaf.metal.MetalSliderUI 中的变量
FILLER - 类 javax.accessibility.AccessibleRole 中的静态变量
填补用户界面空间的对象。
fillInStackTrace() - 类 java.lang.Throwable 中的方法
在异常堆栈跟踪中填充。
fillOval(int, int, int, int) - 类 java.awt.Graphics 中的方法
使用当前颜色填充外接指定矩形框的椭圆。
fillOval(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillOval。
fillPolygon(int[], int[], int) - 类 java.awt.Graphics 中的方法
填充由 x 和 y 坐标数组定义的闭合多边形。
fillPolygon(Polygon) - 类 java.awt.Graphics 中的方法
用图形上下文的当前颜色填充指定 Polygon 对象定义的多边形。
fillPolygon(int[], int[], int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillPolygon。
fillRect(int, int, int, int) - 类 java.awt.Graphics 中的方法
填充指定的矩形。
fillRect(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillRect。
fillRoundRect(int, int, int, int, int, int) - 类 java.awt.Graphics 中的方法
用当前颜色填充指定的圆角矩形。
fillRoundRect(int, int, int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.fillRoundRect。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.AffineTransformOp 中的方法
转换源 BufferedImage 并将结果存储在目标 BufferedImage 中。
filter(Raster, WritableRaster) - 类 java.awt.image.AffineTransformOp 中的方法
转换源 Raster 并将结果存储在目标 Raster 中。
filter(Raster, WritableRaster) - 类 java.awt.image.BandCombineOp 中的方法
使用构造方法中指定的矩阵变换该 Raster。
filter(BufferedImage, BufferedImage) - 接口 java.awt.image.BufferedImageOp 中的方法
对 BufferedImage 执行单输入/单输出操作。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.ColorConvertOp 中的方法
对源 BufferedImage 进行颜色转换。
filter(Raster, WritableRaster) - 类 java.awt.image.ColorConvertOp 中的方法
对源 Raster 中的图像数据进行颜色转换。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.ConvolveOp 中的方法
对 BufferedImage 执行卷积运算。
filter(Raster, WritableRaster) - 类 java.awt.image.ConvolveOp 中的方法
对 Raster 执行卷积运算。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.LookupOp 中的方法
对 BufferedImage 执行查找操作。
filter(Raster, WritableRaster) - 类 java.awt.image.LookupOp 中的方法
在 Raster 上执行查找操作。
filter(Raster, WritableRaster) - 接口 java.awt.image.RasterOp 中的方法
执行从源 Raster 到目标 Raster 的单输入/单输出操作。
filter(BufferedImage, BufferedImage) - 类 java.awt.image.RescaleOp 中的方法
对源 BufferedImage 进行重缩放。
filter(Raster, WritableRaster) - 类 java.awt.image.RescaleOp 中的方法
对源 Raster 中的像素数据进行重缩放。
Filter - java.util.logging 中的 接口
Filter 可用于为记录内容提供比记录级别所提供的更细粒度的控制。
filter(Object) - 接口 javax.imageio.spi.ServiceRegistry.Filter 中的方法
如果给定的 provider 对象与由此 Filter 定义的条件匹配，则返回 true。
FILTER_ACCEPT - 接口 org.w3c.dom.ls.LSParserFilter 中的静态变量
接受节点。
FILTER_INTERRUPT - 接口 org.w3c.dom.ls.LSParserFilter 中的静态变量
中断对文档的常规处理。
FILTER_REJECT - 接口 org.w3c.dom.ls.LSParserFilter 中的静态变量
拒绝节点及其子节点。
FILTER_SKIP - 接口 org.w3c.dom.ls.LSParserFilter 中的静态变量
跳过此单个节点。
FILTERED - 类 java.util.zip.Deflater 中的静态变量
最适用于主要由小值组成并具有某种程度随意分布的数据的压缩策略。
FilteredImageSource - java.awt.image 中的 类
此类是 ImageProducer 接口的一个实现，该接口使用现有的图像和过滤器对象作为参数，并使用它们为原图像的新过滤版本产生图像数据。
FilteredImageSource(ImageProducer, ImageFilter) - 类 java.awt.image.FilteredImageSource 的构造方法
根据现有的 ImageProducer 和过滤器对象构造一个 ImageProducer 对象。
FilteredRowSet - javax.sql.rowset 中的 接口
所有标准 FilteredRowSet 实现都必须实现的标准接口。
filterIndexColorModel(IndexColorModel) - 类 java.awt.image.RGBImageFilter 中的方法
过滤 IndexColorModel 对象：通过 filterRGB 函数（RGBImageFilter 子类必须提供该函数）运行该对象颜色表中的每一项。
FilterInputStream - java.io 中的 类
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
FilterInputStream(InputStream) - 类 java.io.FilterInputStream 的构造方法
将参数 in 分配给字段 this.in，以便记住它供以后使用，通过这种方式创建一个 FilterInputStream。
FilterOutputStream - java.io 中的 类
此类是过滤输出流的所有类的超类。
FilterOutputStream(OutputStream) - 类 java.io.FilterOutputStream 的构造方法
创建一个构建在指定基础输出流之上的输出流过滤器。
FilterReader - java.io 中的 类
用于读取已过滤的字符流的抽象类。
FilterReader(Reader) - 类 java.io.FilterReader 的构造方法
创建一个新的 filtered reader。
filterRGB(int, int, int) - 类 java.awt.image.RGBImageFilter 中的方法
子类必须指定该方法，以将使用默认 RGB ColorModel 的单个输入像素转换成单个输出像素。
filterRGB(int, int, int) - 类 javax.swing.GrayFilter 中的方法
重写 RGBImageFilter.filterRGB。
filterRGBPixels(int, int, int, int, int[], int, int) - 类 java.awt.image.RGBImageFilter 中的方法
过滤缓冲区中使用默认 RGB ColorModel 的像素：将其一个接一个地传递给 filterRGB 方法。
filters - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的变量
FilterWriter - java.io 中的 类
用于写入已过滤的字符流的抽象类。
FilterWriter(Writer) - 类 java.io.FilterWriter 的构造方法
创建一个新的 filtered writer。
FINAL - 类 java.lang.reflect.Modifier 中的静态变量
表示 final 修饰符的 int 值。
FINAL_QUOTE_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pf”。
finalize() - 类 java.awt.color.ICC_Profile 中的方法
释放与 ICC_Profile 对象关联的资源。
finalize() - 类 java.awt.Font 中的方法
移除本机 Font 对象。
finalize() - 类 java.awt.Graphics 中的方法
一旦不再引用此图形上下文就释放它。
finalize() - 类 java.awt.image.ColorModel 中的方法
一旦不再引用此 ColorModel，就要释放与此 ColorModel 相关的系统资源。
finalize() - 类 java.awt.image.IndexColorModel 中的方法
不再引用此 ColorModel 后，释放与此 ColorModel 关联的系统资源。
finalize() - 类 java.awt.PrintJob 中的方法
一旦不再引用此打印作业，即可终止它。
finalize() - 类 java.io.FileInputStream 中的方法
确保在不再引用文件输入流时调用其 close 方法。
finalize() - 类 java.io.FileOutputStream 中的方法
清理到文件的连接，并确保在不再引用此文件输出流时调用此流的 close 方法。
finalize() - 类 java.lang.Enum 中的方法
枚举类不能有 finalize 方法。
finalize() - 类 java.lang.Object 中的方法
当垃圾回收器确定不存在对该对象的更多引用时，由对象的垃圾回收器调用此方法。
finalize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
当不再引用此执行程序时，调用 shutdown。
finalize() - 类 java.util.zip.Deflater 中的方法
回收垃圾时关闭压缩器。
finalize() - 类 java.util.zip.Inflater 中的方法
回收垃圾时关闭解压缩器。
finalize() - 类 java.util.zip.ZipFile 中的方法
确保不再引用此 ZIP 文件时调用它的 close 方法。
finalize() - 类 javax.crypto.ExemptionMechanism 中的方法
确保不存在对此 ExemptionMechanism 对象存储的密钥的引用时，该密钥将被除去。
finalize() - 类 javax.imageio.spi.ServiceRegistry 中的方法
在垃圾回收前终止此对象。
finalize() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
在垃圾回收前结束此对象。
finalize() - 类 javax.imageio.stream.FileImageInputStream 中的方法
在垃圾回收前结束此对象。
finalize() - 类 javax.imageio.stream.FileImageOutputStream 中的方法
在垃圾回收前结束此对象。
finalize() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
在垃圾回收前结束此对象。
finalize() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
在垃圾回收前结束此对象。
finalSubString(AttributeValueExp, StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于字符串参数的约束条件。
find() - 类 java.util.regex.Matcher 中的方法
尝试查找与该模式匹配的输入序列的下一个子序列。
find(int) - 类 java.util.regex.Matcher 中的方法
重置此匹配器，然后尝试查找匹配该模式、从指定索引开始的输入序列的下一个子序列。
find_POA(String, boolean) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。
findAssociatedMBeans(ObjectName, String, String) - 类 javax.management.relation.RelationService 中的方法
检索与关系中给定关系相关的 MBean。
findAssociatedMBeans(ObjectName, String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索与关系中给定关系相关的 MBean。
findClass(String) - 类 java.lang.ClassLoader 中的方法
使用指定的二进制名称查找类。
findClass(String) - 类 java.net.URLClassLoader 中的方法
通过 URL 搜索路径查找并加载具有指定名称的类。
findClass(String) - 类 javax.management.loading.MLet 中的方法
这是要重新定义的类加载器的主要方法。
findColumn(String) - 接口 java.sql.ResultSet 中的方法
将给定的 ResultSet 列标签映射到其 ResultSet 列索引。
findColumn(String) - 类 javax.swing.table.AbstractTableModel 中的方法
返回具有给定名称的列。
findComponentAt(int, int) - 类 java.awt.Container 中的方法
对包含指定位置的可视子组件进行定位。
findComponentAt(Point) - 类 java.awt.Container 中的方法
对包含指定点的可视子组件进行定位。
findDeadlockedThreads() - 接口 java.lang.management.ThreadMXBean 中的方法
查找因为等待获得对象监视器或可拥有同步器而处于死锁状态的线程循环。
findEditor(Class<?>) - 类 java.beans.PropertyEditorManager 中的静态方法
查找给定目标类型的值编辑器。
findElementMatchingTag(HTMLDocument, int, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法
返回在 offset 处与 tag 匹配的最深的元素。
findFocusOwner(Component) - 类 javax.swing.SwingUtilities 中的静态方法
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
findInLine(String) - 类 java.util.Scanner 中的方法
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。
findInLine(Pattern) - 类 java.util.Scanner 中的方法
试图在忽略分隔符的情况下查找下一个指定模式。
findLibrary(String) - 类 java.lang.ClassLoader 中的方法
返回本机库的绝对路径名。
findLibrary(String) - 类 javax.management.loading.MLet 中的方法
返回本机库的绝对路径名称。
findLoadedClass(String) - 类 java.lang.ClassLoader 中的方法
如果 Java 虚拟机已将此加载器记录为具有给定二进制名称的某个类的启动加载器，则返回该二进制名称的类。
findMBeanServer(String) - 类 javax.management.MBeanServerFactory 中的静态方法
返回已注册 MBeanServer 对象的列表。
findMedia(float, float, int) - 类 javax.print.attribute.standard.MediaSize 中的静态方法
指定的维度用于从所有标准 MediaSize 实例中定位一个匹配的 MediaSize 实例。
findMonitorDeadlockedThreads() - 接口 java.lang.management.ThreadMXBean 中的方法
找到处于死锁状态（等待获取对象监视器）的线程的周期。
findOffsetToCharactersInString(char[], int) - 类 javax.swing.text.ParagraphView 中的方法
根据 string 中字符查找文档中的下一个字符，起点是偏移量 start。
findReferencingRelations(ObjectName, String, String) - 类 javax.management.relation.RelationService 中的方法
检索在引用给定 MBean 的引用关系。
findReferencingRelations(ObjectName, String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索在其中引用给定 MBean 的关系。
findRelationsOfType(String) - 类 javax.management.relation.RelationService 中的方法
返回给定类型的关系的关系 id。
findRelationsOfType(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回给定类型的关系的关系 id。
findResource(String) - 类 java.lang.ClassLoader 中的方法
查找具有给定名称的资源。
findResource(String) - 类 java.net.URLClassLoader 中的方法
在 URL 搜索路径中查找具有指定名称的资源。
findResources(String) - 类 java.lang.ClassLoader 中的方法
返回表示所有具有给定名称的资源的 URL 对象的枚举。
findResources(String) - 类 java.net.URLClassLoader 中的方法
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。
findSystemClass(String) - 类 java.lang.ClassLoader 中的方法
查找具有指定的二进制名称的类，必要时加载它。
findWithinHorizon(String, int) - 类 java.util.Scanner 中的方法
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。
findWithinHorizon(Pattern, int) - 类 java.util.Scanner 中的方法
试图查找下一个指定模式。
FINE - 类 java.util.logging.Level 中的静态变量
FINE 是提供跟踪信息的消息级别。
fine(String) - 类 java.util.logging.Logger 中的方法
记录一条 FINE 消息。
FINER - 类 java.util.logging.Level 中的静态变量
FINER 指示一条相当详细的跟踪消息。
finer(String) - 类 java.util.logging.Logger 中的方法
记录一条 FINER 消息。
FINEST - 类 java.util.logging.Level 中的静态变量
FINEST 指示一条最详细的跟踪消息。
finest(String) - 类 java.util.logging.Logger 中的方法
记录一条 FINEST 消息。
finish() - 类 java.util.zip.Deflater 中的方法
调用时，指示压缩应当以输入缓冲区的当前内容结尾。
finish() - 类 java.util.zip.DeflaterOutputStream 中的方法
完成将压缩数据写入输出流的操作，无需关闭底层流。
finish() - 类 java.util.zip.GZIPOutputStream 中的方法
完成将压缩数据写入输出流的操作，无需关闭底层流。
finish() - 类 java.util.zip.InflaterOutputStream 中的方法
完成将未压缩数据写入输出流的操作，无需关闭底层流。
finish() - 类 java.util.zip.ZipOutputStream 中的方法
完成写入 ZIP 输出流的内容，无需关闭底层流。
finishConnect() - 类 java.nio.channels.SocketChannel 中的方法
完成套接字通道的连接过程。
finishDraggingTo(int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
利用包含此实例的 finishDraggingTo 传递 BasicSplitPaneUI 的消息。
finishDraggingTo(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
传递消息以完成拖动会话。
finished() - 类 java.util.zip.Deflater 中的方法
如果已到达压缩数据输出流的结尾，则返回 true。
finished() - 类 java.util.zip.Inflater 中的方法
如果已到达压缩数据流的结尾，则返回 true。
finishedPaintingChildren(JSplitPane, Graphics) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
在 JSplitPane 接收者将为绘制其子级提供外观后传递消息。
finishedPaintingChildren(JSplitPane, Graphics) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 finishedPaintingChildren 方法。
finishedPaintingChildren(JSplitPane, Graphics) - 类 javax.swing.plaf.SplitPaneUI 中的方法
在 JSplitPane 接收方提供外观来绘制其子组件之后传递消息。
Finishings - javax.print.attribute.standard 中的 类
Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
Finishings(int) - 类 javax.print.attribute.standard.Finishings 的构造方法
构造具有给定整数值的新 finishings 绑定枚举值。
fireActionEvent() - 类 javax.swing.JComboBox 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireActionPerformed(ActionEvent) - 类 javax.swing.AbstractButton 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireActionPerformed(ActionEvent) - 类 javax.swing.DefaultButtonModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireActionPerformed(String) - 类 javax.swing.JFileChooser 中的方法
通知对此事件类型感兴趣的所有侦听器。
fireActionPerformed() - 类 javax.swing.JTextField 中的方法
通知对此事件类型需要的所有侦听器。
fireActionPerformed(ActionEvent) - 类 javax.swing.Timer 中的方法
通知为此事件类型的通知而注册的所有侦听器。
fireAdjustmentValueChanged(int, int, int) - 类 javax.swing.JScrollBar 中的方法
通知侦听器该滚动条的模型已更改。
fireCaretUpdate(CaretEvent) - 类 javax.swing.text.JTextComponent 中的方法
通知所有已注册需要此事件类型的通知的侦听器。
fireChangedUpdate(DocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireChangedUpdate(DocumentEvent) - 类 javax.swing.text.html.HTMLDocument 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireChildrenAdded(BeanContextMembershipEvent) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。
fireChildrenRemoved(BeanContextMembershipEvent) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。
fireColumnAdded(TableColumnModelEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireColumnMarginChanged() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireColumnMoved(TableColumnModelEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireColumnRemoved(TableColumnModelEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireColumnSelectionChanged(ListSelectionEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireContentsChanged(Object, int, int) - 类 javax.swing.AbstractListModel 中的方法
AbstractListModel 子类必须在列表的一个或多个元素发生更改之后调用此方法。
fireContentsChanged() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
fireDragGestureRecognized(int, Point) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
通知 DragGestureListener 已发生了 Drag 和 Drop 开始动作。
fireEditingCanceled() - 类 javax.swing.AbstractCellEditor 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireEditingStopped() - 类 javax.swing.AbstractCellEditor 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireHyperlinkUpdate(HyperlinkEvent) - 类 javax.swing.JEditorPane 中的方法
通知因对此事件类型的通知感兴趣而已注册的所有侦听器。
fireIndexedPropertyChange(String, int, Object, Object) - 类 java.beans.PropertyChangeSupport 中的方法
报告所有已注册侦听器的绑定 (bound) 索引 (indexed) 属性更新。
fireIndexedPropertyChange(String, int, int, int) - 类 java.beans.PropertyChangeSupport 中的方法
以 int 值形式报告所有已注册侦听器的绑定索引属性更新。
fireIndexedPropertyChange(String, int, boolean, boolean) - 类 java.beans.PropertyChangeSupport 中的方法
以 boolean 值形式报告所有已注册侦听器的绑定索引属性更新。
fireInsertUpdate(DocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireInternalFrameEvent(int) - 类 javax.swing.JInternalFrame 中的方法
激发内部窗体事件。
fireIntervalAdded(Object, int, int) - 类 javax.swing.AbstractListModel 中的方法
AbstractListModel 子类必须在将一个或多个元素添加到模型中之后调用此方法。
fireIntervalRemoved(Object, int, int) - 类 javax.swing.AbstractListModel 中的方法
AbstractListModel 子类必须在从模型中移除一个或多个元素之后调用此方法。
fireItemStateChanged(ItemEvent) - 类 javax.swing.AbstractButton 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireItemStateChanged(ItemEvent) - 类 javax.swing.DefaultButtonModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireItemStateChanged(ItemEvent) - 类 javax.swing.JComboBox 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireMenuCanceled() - 类 javax.swing.JMenu 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireMenuDeselected() - 类 javax.swing.JMenu 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireMenuDragMouseDragged(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuDragMouseEntered(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuDragMouseExited(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuDragMouseReleased(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuKeyPressed(MenuKeyEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuKeyReleased(MenuKeyEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuKeyTyped(MenuKeyEvent) - 类 javax.swing.JMenuItem 中的方法
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
fireMenuSelected() - 类 javax.swing.JMenu 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
firePopupMenuCanceled() - 类 javax.swing.JComboBox 中的方法
通知 PopupMenuListener 组合框的弹出部分已被取消。
firePopupMenuCanceled() - 类 javax.swing.JPopupMenu 中的方法
通知 PopupMenuListener 此弹出菜单将被取消。
firePopupMenuCanceled() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
firePopupMenuWillBecomeInvisible() - 类 javax.swing.JComboBox 中的方法
通知 PopupMenuListener 组合框的弹出部分已变得不可见。
firePopupMenuWillBecomeInvisible() - 类 javax.swing.JPopupMenu 中的方法
通知 PopupMenuListener 此弹出菜单将变得不可见。
firePopupMenuWillBecomeInvisible() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
firePopupMenuWillBecomeVisible() - 类 javax.swing.JComboBox 中的方法
通知 PopupMenuListener 组合框的弹出部分将变得可见。
firePopupMenuWillBecomeVisible() - 类 javax.swing.JPopupMenu 中的方法
通知 PopupMenuListener 此弹出菜单将变得可见。
firePopupMenuWillBecomeVisible() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
firePropertyChange(String, Object, Object) - 类 java.awt.Component 中的方法
支持报告 Object 属性的绑定属性改变。
firePropertyChange(String, boolean, boolean) - 类 java.awt.Component 中的方法
支持报告布尔属性的绑定属性改变。
firePropertyChange(String, int, int) - 类 java.awt.Component 中的方法
支持报告整数属性的绑定属性改变。
firePropertyChange(String, byte, byte) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, char, char) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, short, short) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, long, long) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, float, float) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, double, double) - 类 java.awt.Component 中的方法
报告绑定属性的改变。
firePropertyChange(String, Object, Object) - 类 java.awt.KeyboardFocusManager 中的方法
激发 PropertyChangeEvent 以响应绑定属性中的更改。
firePropertyChange(String, Object, Object) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
向所有已注册的侦听器报告绑定 (bound) 属性更新。
firePropertyChange(String, Object, Object) - 类 java.beans.PropertyChangeSupport 中的方法
报告所有已注册侦听器的绑定属性更新。
firePropertyChange(String, int, int) - 类 java.beans.PropertyChangeSupport 中的方法
以 int 值形式报告所有已注册侦听器的绑定属性更新。
firePropertyChange(String, boolean, boolean) - 类 java.beans.PropertyChangeSupport 中的方法
以 boolean 值形式报告所有已注册侦听器的绑定属性更新。
firePropertyChange(PropertyChangeEvent) - 类 java.beans.PropertyChangeSupport 中的方法
对所有已注册侦听器激发一个现有 PropertyChangeEvent。
firePropertyChange() - 类 java.beans.PropertyEditorSupport 中的方法
报告已经修改所有感兴趣的侦听器。
firePropertyChange(String, Object, Object) - 类 javax.accessibility.AccessibleContext 中的方法
对报告 bound 属性更改的支持。
firePropertyChange(String, Object, Object) - 类 javax.swing.AbstractAction 中的方法
支持报告绑定 (bound) 属性的改变。
firePropertyChange(String, Object, Object) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, byte, byte) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, char, char) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, short, short) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, int, int) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, long, long) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, float, float) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, double, double) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, boolean, boolean) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(PropertyChangeEvent) - 类 javax.swing.event.SwingPropertyChangeSupport 中的方法
对所有已注册侦听器激发一个现有 PropertyChangeEvent。
firePropertyChange(String, boolean, boolean) - 类 javax.swing.JComponent 中的方法
支持报告 boolean 属性的绑定属性更改。
firePropertyChange(String, int, int) - 类 javax.swing.JComponent 中的方法
支持报告整数属性的绑定属性更改。
firePropertyChange(String, char, char) - 类 javax.swing.JComponent 中的方法
firePropertyChange(String, Object, Object) - 类 javax.swing.JViewport 中的方法
通知侦听器发生的属性更改。
firePropertyChange(String, Object, Object) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
支持报告 boolean 属性的绑定属性的改变。
firePropertyChange(String, Object, Object) - 类 javax.swing.SwingWorker 中的方法
向所有已注册的侦听器报告绑定属性更新。
firePropertyChange(String, Object, Object) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, boolean, boolean) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, Object, Object) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, byte, byte) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, char, char) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, short, short) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, int, int) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, long, long) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, float, float) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, double, double) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, boolean, boolean) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
firePropertyChange(String, Object, Object) - 类 javax.swing.UIDefaults 中的方法
支持报告绑定属性更改。
fireRemoveUpdate(DocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireRowSorterChanged(int[]) - 类 javax.swing.RowSorter 中的方法
通知侦听器映射关系发生了更改。
fireSelectionValueChanged(int, int, boolean) - 类 javax.swing.JList 中的方法
通知直接添加到列表的 ListSelectionListener 对列表模型做出了选择更改。
fireServiceAdded(Class) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
触发一个通知新服务的 BeanContextServiceEvent。
fireServiceAdded(BeanContextServiceAvailableEvent) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
触发一个指示新服务已变得可用的 BeanContextServiceAvailableEvent。
fireServiceRevoked(BeanContextServiceRevokedEvent) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
触发一个通知将被取消的服务的 BeanContextServiceEvent。
fireServiceRevoked(Class, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
触发一个指示某一特定服务不再可用的 BeanContextServiceRevokedEvent。
fireSortOrderChanged() - 类 javax.swing.RowSorter 中的方法
通知侦听器排序顺序发生了更改。
fireStateChanged() - 类 javax.swing.AbstractButton 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireStateChanged() - 类 javax.swing.AbstractSpinnerModel 中的方法
运行每个 ChangeListeners stateChanged() 方法。
fireStateChanged() - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
运行每个 ChangeListener 的 stateChanged 方法。
fireStateChanged() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
运行每个 ChangeListener 的 stateChanged 方法。
fireStateChanged() - 类 javax.swing.DefaultButtonModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireStateChanged() - 类 javax.swing.DefaultSingleSelectionModel 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireStateChanged() - 类 javax.swing.JProgressBar 中的方法
将一个 ChangeEvent（其源是此 JProgressBar）发送给针对 ChangeEvent 的所有已注册 ChangeListener。
fireStateChanged() - 类 javax.swing.JSlider 中的方法
将一个其源为此 JSlider 的 ChangeEvent 发送到所有需要 ChangeEvent 的已注册 ChangeListener。
fireStateChanged() - 类 javax.swing.JSpinner 中的方法
将一个其源为此 JSpinner 的 ChangeEvent 发送到每个 ChangeListener。
fireStateChanged() - 类 javax.swing.JTabbedPane 中的方法
将一个 ChangeEvent（以此 JTabbedPane 作为源）发送到每个已注册的侦听器。
fireStateChanged() - 类 javax.swing.JViewport 中的方法
在视图的大小、位置或视口的扩展大小更改时通知所有 ChangeListeners。
fireStateChanged() - 类 javax.swing.MenuSelectionManager 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireStateChanged() - 类 javax.swing.text.DefaultCaret 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireStateChanged() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
通知所有对此事件类型的通知感兴趣的已注册侦听器。
fireTableCellUpdated(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，已更新 [row, column] 处的单元格值。
fireTableChanged(TableModelEvent) - 类 javax.swing.table.AbstractTableModel 中的方法
将给定的通知事件转发到所有将自身注册为此表模型的侦听器的 TableModelListeners。
fireTableDataChanged() - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，表的所有行单元格值可能已更改。
fireTableRowsDeleted(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，已删除范围在 [firstRow, lastRow]（包括）的行。
fireTableRowsInserted(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，已插入范围在 [firstRow, lastRow]（包括）的行。
fireTableRowsUpdated(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，已更新范围在 [firstRow, lastRow]（包括）的行。
fireTableStructureChanged() - 类 javax.swing.table.AbstractTableModel 中的方法
通知所有侦听器，表的结构已更改。
fireTreeCollapsed(TreePath) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireTreeExpanded(TreePath) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireTreeNodesChanged(Object, Object[], int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireTreeNodesInserted(Object, Object[], int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireTreeNodesRemoved(Object, Object[], int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireTreeStructureChanged(Object, Object[], int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireTreeWillCollapse(TreePath) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireTreeWillExpand(TreePath) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireUndoableEditUpdate(UndoableEditEvent) - 类 javax.swing.text.AbstractDocument 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireUndoableEditUpdate(UndoableEditEvent) - 类 javax.swing.text.html.HTMLDocument 中的方法
通知所有需要此事件类型的通知的已注册侦听器。
fireValueChanged(boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
通知侦听器已经结束了一系列的调整。
fireValueChanged(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
通知 ListSelectionListener 选择的值已发生更改，该值在 firstIndex 和 lastIndex 组成的闭区间内。
fireValueChanged(int, int, boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
fireValueChanged(TreeSelectionEvent) - 类 javax.swing.JTree 中的方法
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
fireValueChanged(TreeSelectionEvent) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
通知已注册此对象上的树选择事件的所有侦听器。
fireVetoableChange(String, Object, Object) - 类 java.awt.KeyboardFocusManager 中的方法
激发 PropertyChangeEvent 以响应可否决属性中的更改。
fireVetoableChange(String, Object, Object) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
向所有已注册的侦听器报告 vetoable 属性更新。
fireVetoableChange(String, Object, Object) - 类 java.beans.VetoableChangeSupport 中的方法
向所有已注册的侦听器报告 vetoable 属性更新。
fireVetoableChange(String, int, int) - 类 java.beans.VetoableChangeSupport 中的方法
向所有已注册的侦听器报告一个 int vetoable 属性更新。
fireVetoableChange(String, boolean, boolean) - 类 java.beans.VetoableChangeSupport 中的方法
向所有已注册的侦听器报告一个 boolean vetoable 属性更新。
fireVetoableChange(PropertyChangeEvent) - 类 java.beans.VetoableChangeSupport 中的方法
对所有已注册侦听器激发一个 vetoable 属性更新。
fireVetoableChange(String, Object, Object) - 类 javax.swing.JComponent 中的方法
支持报告约束 (constrained) 属性的更改。
fireVisibleDataPropertyChange() - 类 javax.swing.JTree.AccessibleJTree 中的方法
激发可见数据属性更改通知。
first(Container) - 类 java.awt.CardLayout 中的方法
翻转到容器的第一张卡片。
first() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的第一行。
first() - 类 java.text.BreakIterator 中的方法
返回第一个边界。
first() - 接口 java.text.CharacterIterator 中的方法
将位置设置为 getBeginIndex()，并返回该位置的字符。
first() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.first()。
first() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
first() - 接口 java.util.SortedSet 中的方法
返回此 set 中当前第一个（最低）元素。
first() - 类 java.util.TreeSet 中的方法
first() - 类 javax.swing.text.ElementIterator 中的方法
获取第一个元素。
first(Object) - 类 javax.swing.text.html.parser.ContentModel 中的方法
如果标记可能为输入流中第一个标记，则返回 true。
first() - 类 javax.swing.text.html.parser.ContentModel 中的方法
返回必须具有下一个的元素。
first() - 类 javax.swing.text.Segment 中的方法
将位置设置为 getBeginIndex()，并返回该位置的字符。
FIRST_LINE_END - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于显示区域的一角，在该区域中，当前 ComponentOrienation 的页面的第一个文本行正常结束。
FIRST_LINE_START - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的开始位置。
firstColumn - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
firstElement() - 类 java.util.Vector 中的方法
返回此向量的第一个组件（位于索引 0) 处的项）。
firstElement() - 类 javax.swing.DefaultListModel 中的方法
返回此列表中的第一个组件。
firstEntry() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
firstEntry() - 接口 java.util.NavigableMap 中的方法
返回一个与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
firstEntry() - 类 java.util.TreeMap 中的方法
firstKey() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
firstKey() - 接口 java.util.SortedMap 中的方法
返回此映射中当前第一个（最低）键。
firstKey() - 类 java.util.TreeMap 中的方法
firstLineIndent - 类 javax.swing.text.ParagraphView 中的变量
相对于左边的 inset 进行的第一行的缩进。
FirstLineIndent - 类 javax.swing.text.StyleConstants 中的静态变量
段落第一行要缩进的空间量。
firstRow - 类 javax.swing.event.TableModelEvent 中的变量
firstRow - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
FIXED - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
fixed_digits() - 类 org.omg.CORBA.TypeCode 中的方法
返回此 TypeCode 对象所描述的 fixed 类型中数字的数量。
fixed_scale() - 类 org.omg.CORBA.TypeCode 中的方法
返回此 TypeCode 对象所描述的 fixed 类型的标度。
fixedCellHeightChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
fixedCellWidthChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
fixedContentLength - 类 java.net.HttpURLConnection 中的变量
使用固定长度流模式时的固定内容长度。
FixedHeightLayoutCache - javax.swing.tree 中的 类
注：在以后的版本中，这将变得更加开放。
FixedHeightLayoutCache() - 类 javax.swing.tree.FixedHeightLayoutCache 的构造方法
FixedHolder - org.omg.CORBA 中的 类
Fixed 的 Holder。
FixedHolder() - 类 org.omg.CORBA.FixedHolder 的构造方法
构造 FixedHolder，不初始化所包含的值。
FixedHolder(BigDecimal) - 类 org.omg.CORBA.FixedHolder 的构造方法
构造 FixedHolder，并使用给定值初始化。
FLAG_COMPLEX_GLYPHS - 类 java.awt.font.GlyphVector 中的静态变量
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 具有从字形到字符的复杂映射关系（此映射并非严格按照与排列方向匹配的升序或降序顺序将字形一一映射到字符）。
FLAG_HAS_POSITION_ADJUSTMENTS - 类 java.awt.font.GlyphVector 中的静态变量
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 调整了位置。
FLAG_HAS_TRANSFORMS - 类 java.awt.font.GlyphVector 中的静态变量
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 的每个字形都有转换。
FLAG_MASK - 类 java.awt.font.GlyphVector 中的静态变量
getLayoutFlags 支持标志的掩码。
FLAG_RUN_RTL - 类 java.awt.font.GlyphVector 中的静态变量
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 具有从右到左的排列方向。
flags() - 类 java.util.regex.Pattern 中的方法
返回此模式的匹配标志。
flags() - 类 org.omg.CORBA.NamedValue 中的方法
检索用于此 NamedValue 对象的参数模式标志。
FLASH_OPTION - 类 javax.swing.DebugGraphics 中的静态变量
Flash 图形操作。
flashColor() - 类 javax.swing.DebugGraphics 中的静态方法
返回用于 flash 绘制操作的 Color。
flashCount() - 类 javax.swing.DebugGraphics 中的静态方法
绘制操作将要 flash 的次数。
flashTime() - 类 javax.swing.DebugGraphics 中的静态方法
返回绘制操作 flash 的时间延迟。
FlatteningPathIterator - java.awt.geom 中的 类
FlatteningPathIterator 类返回另一个 PathIterator 对象的变平视图。
FlatteningPathIterator(PathIterator, double) - 类 java.awt.geom.FlatteningPathIterator 的构造方法
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。
FlatteningPathIterator(PathIterator, double, int) - 类 java.awt.geom.FlatteningPathIterator 的构造方法
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。
FlavorEvent - java.awt.datatransfer 中的 类
FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。
FlavorEvent(Clipboard) - 类 java.awt.datatransfer.FlavorEvent 的构造方法
构造一个 FlavorEvent 对象。
FlavorException - javax.print 中的 接口
接口 FlavorException 是一个混合接口，PrintException 的子类可实现它来报告有关某个 DocFlavor 或多个 DocFlavor（类 DocFlavor）的错误状况。
FlavorListener - java.awt.datatransfer 中的 接口
定义侦听 FlavorEvent 的对象。
FlavorMap - java.awt.datatransfer 中的 接口
"native" (String)（对应于特定平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的双向 Map。
flavorsChanged(FlavorEvent) - 接口 java.awt.datatransfer.FlavorListener 中的方法
当侦听器的目标 Clipboard 已更改其可用的 DataFlavor 时调用。
FlavorTable - java.awt.datatransfer 中的 接口
放宽传统一对一 Map 限制的 FlavorMap。
flip(BufferCapabilities.FlipContents) - 类 java.awt.Component.FlipBufferStrategy 中的方法
将底层缓冲区的内容翻转移动到前台缓冲区，可通过复制或移动视频指针来执行。
flip() - 类 java.nio.Buffer 中的方法
反转此缓冲区。
flip(int) - 类 java.util.BitSet 中的方法
将指定索引处的位设置为其当前值的补码。
flip(int, int) - 类 java.util.BitSet 中的方法
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的每个位设置为其当前值的补码。
flipBit(int) - 类 java.math.BigInteger 中的方法
返回其值与对此 BigInteger 进行指定位翻转后的值等效的 BigInteger。
flipEastAndWestAtEnds(int, Position.Bias) - 类 javax.swing.text.BoxView 中的方法
确定下一个视图的放置方向。
flipEastAndWestAtEnds(int, Position.Bias) - 类 javax.swing.text.CompositeView 中的方法
确定下一个视图放置的朝向。
flipEastAndWestAtEnds(int, Position.Bias) - 类 javax.swing.text.ParagraphView 中的方法
确定下一个视图要布置的方向。
Float - java.lang 中的 类
Float 类在对象中包装一个基本类型 float 的值。
Float(float) - 类 java.lang.Float 的构造方法
构造一个新分配的 Float 对象，它表示基本的 float 参数。
Float(double) - 类 java.lang.Float 的构造方法
构造一个新分配的 Float 对象，它表示转换为 float 类型的参数。
Float(String) - 类 java.lang.Float 的构造方法
构造一个新分配的 Float 对象，它表示用字符串表示的 float 类型的浮点值。
FLOAT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 FLOAT 的 Java 编程语言中的常量（有时称为类型代码）。
FLOAT - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Float 的值。
FLOAT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
floatAt(Point, Point) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
FloatBuffer - java.nio 中的 类
float 缓冲区。
FloatControl - javax.sound.sampled 中的 类
FloatControl 对象提供对浮点值范围的控制。
FloatControl(FloatControl.Type, float, float, float, int, float, String, String, String, String) - 类 javax.sound.sampled.FloatControl 的构造方法
构造具有给定参数的新 float 控件对象
FloatControl(FloatControl.Type, float, float, float, int, float, String) - 类 javax.sound.sampled.FloatControl 的构造方法
构造具有给定参数的新 float 控件对象。
FloatControl.Type - javax.sound.sampled 中的 类
FloatControl.Type 内部类的实例标识了某种 float 控件。
FloatControl.Type(String) - 类 javax.sound.sampled.FloatControl.Type 的构造方法
构造新的 float 控件类型。
FloatHolder - org.omg.CORBA 中的 类
Float 的 Holder。
FloatHolder() - 类 org.omg.CORBA.FloatHolder 的构造方法
构造一个新的 FloatHolder 对象，将其 value 字段初始化为 0.0。
FloatHolder(float) - 类 org.omg.CORBA.FloatHolder 的构造方法
为给定 float 值构造一个新 FloatHolder 对象。
floatingBorderColor - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
floatingColor - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
FloatSeqHelper - org.omg.CORBA 中的 类
FloatSeq 的 Helper。
FloatSeqHelper() - 类 org.omg.CORBA.FloatSeqHelper 的构造方法
FloatSeqHolder - org.omg.CORBA 中的 类
FloatSeq 的 Holder。
FloatSeqHolder() - 类 org.omg.CORBA.FloatSeqHolder 的构造方法
FloatSeqHolder(float[]) - 类 org.omg.CORBA.FloatSeqHolder 的构造方法
floatToIntBits(float) - 类 java.lang.Float 中的静态方法
根据 IEEE 754 浮点“单一格式”位布局，返回指定浮点值的表示形式。
floatToRawIntBits(float) - 类 java.lang.Float 中的静态方法
根据 IEEE 754 浮点“单一格式”位布局，返回指定浮点值的表示形式，并保留非数字 (NaN) 值。
floatValue() - 类 java.lang.Byte 中的方法
作为一个 float 返回此 Byte 的值。
floatValue() - 类 java.lang.Double 中的方法
返回此 Double 对象的 float 值。
floatValue() - 类 java.lang.Float 中的方法
返回此 Float 对象的 float 值。
floatValue() - 类 java.lang.Integer 中的方法
以 float 类型返回该 Integer 的值。
floatValue() - 类 java.lang.Long 中的方法
以 float 形式返回此 Long 的值。
floatValue() - 类 java.lang.Number 中的方法
以 float 形式返回指定的数值。
floatValue() - 类 java.lang.Short 中的方法
以 float 形式返回此 Short 的值。
floatValue() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 float。
floatValue() - 类 java.math.BigInteger 中的方法
将此 BigInteger 转换为 float。
floatValue() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
floatValue() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
floor(double) - 类 java.lang.Math 中的静态方法
返回最大的（最接近正无穷大）double 值，该值小于等于参数，并等于某个整数。
floor(double) - 类 java.lang.StrictMath 中的静态方法
返回最大的（最接近正无穷大）double 值，该值小于等于参数，并等于某个整数。
floor(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
floor(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 中小于等于给定元素的最大元素；如果不存在这样的元素，则返回 null。
floor(E) - 类 java.util.TreeSet 中的方法
floorEntry(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与小于等于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
floorEntry(K) - 接口 java.util.NavigableMap 中的方法
返回一个键-值映射关系，它与小于等于给定键的最大键关联；如果不存在这样的键，则返回 null。
floorEntry(K) - 类 java.util.TreeMap 中的方法
floorKey(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
floorKey(K) - 接口 java.util.NavigableMap 中的方法
返回小于等于给定键的最大键；如果不存在这样的键，则返回 null。
floorKey(K) - 类 java.util.TreeMap 中的方法
floppyDriveIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
FlowLayout - java.awt 中的 类
流布局用于安排有向流中的组件，这非常类似于段落中的文本行。
FlowLayout() - 类 java.awt.FlowLayout 的构造方法
构造一个新的 FlowLayout，它是居中对齐的，默认的水平和垂直间隙是 5 个单位。
FlowLayout(int) - 类 java.awt.FlowLayout 的构造方法
构造一个新的 FlowLayout，它具有指定的对齐方式，默认的水平和垂直间隙是 5 个单位。
FlowLayout(int, int, int) - 类 java.awt.FlowLayout 的构造方法
创建一个新的流布局管理器，它具有指定的对齐方式以及指定的水平和垂直间隙。
FLOWS_FROM - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象出现在该对象前面。
FLOWS_FROM_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个对象之间的 FLOWS_FROM 关系已更改。
FLOWS_TO - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象在该对象后面出现。
FLOWS_TO_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个对象之间的 FLOWS_TO 关系已更改。
FlowView - javax.swing.text 中的 类
试图将其子级流入某个部分受约束的空间的视图。
FlowView(Element, int) - 类 javax.swing.text.FlowView 的构造方法
构造给定元素的 FlowView。
FlowView.FlowStrategy - javax.swing.text 中的 类
维护流的物理形式的策略。
FlowView.FlowStrategy() - 类 javax.swing.text.FlowView.FlowStrategy 的构造方法
flush() - 类 java.awt.Image 中的方法
刷新此 Image 对象正在使用的所有可重构的资源。
flush() - 类 java.beans.XMLEncoder 中的方法
如果还没有写出导言，那么此方法将写出与 XML 编码有关的导言，并随后写出从最后一次调用 flush 以来写入流中的所有值。
flush() - 类 java.io.BufferedOutputStream 中的方法
刷新此缓冲的输出流。
flush() - 类 java.io.BufferedWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.CharArrayWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.Console 中的方法
刷新控制台，并强制立即写入所有缓冲的输出。
flush() - 类 java.io.DataOutputStream 中的方法
清空此数据输出流。
flush() - 类 java.io.FilterOutputStream 中的方法
刷新此输出流，并强制将所有已缓冲的输出字节写入该流中。
flush() - 类 java.io.FilterWriter 中的方法
刷新该流的缓冲。
flush() - 接口 java.io.Flushable 中的方法
通过将所有已缓冲输出写入底层流来刷新此流。
flush() - 接口 java.io.ObjectOutput 中的方法
刷新该流的缓冲。
flush() - 类 java.io.ObjectOutputStream 中的方法
刷新该流的缓冲。
flush() - 类 java.io.OutputStream 中的方法
刷新此输出流并强制写出所有缓冲的输出字节。
flush() - 类 java.io.OutputStreamWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.PipedOutputStream 中的方法
刷新此输出流并强制写出所有缓冲的输出字节。
flush() - 类 java.io.PipedWriter 中的方法
刷新此输出流并强制写出所有缓冲的输出字符。
flush() - 类 java.io.PrintStream 中的方法
刷新该流的缓冲。
flush() - 类 java.io.PrintWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.StringWriter 中的方法
刷新该流的缓冲。
flush() - 类 java.io.Writer 中的方法
刷新该流的缓冲。
flush(CharBuffer) - 类 java.nio.charset.CharsetDecoder 中的方法
刷新此解码器。
flush(ByteBuffer) - 类 java.nio.charset.CharsetEncoder 中的方法
刷新此编码器。
flush() - 类 java.util.Formatter 中的方法
刷新此 formatter。
flush() - 类 java.util.logging.Handler 中的方法
刷新所有的缓冲输出。
flush() - 类 java.util.logging.MemoryHandler 中的方法
导致目标 Handler 上的刷新。
flush() - 类 java.util.logging.StreamHandler 中的方法
刷新所有缓冲消息。
flush() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.flush() 中的规范实现 flush 方法。
flush() - 类 java.util.prefs.Preferences 中的方法
强制进行从此首选项节点及其子节点到持久存储的内容更改。
flush() - 类 java.util.zip.InflaterOutputStream 中的方法
刷新此输出流，并强制写出挂起的所有缓冲输出字节。
flush() - 类 javax.crypto.CipherOutputStream 中的方法
强制写出已由封装的密码对象处理的任何缓存输出字节来刷新此输出流。
flush() - 接口 javax.imageio.stream.ImageInputStream 中的方法
丢弃当前流位置之前的流初始部分。
flush() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
flush() - 接口 javax.sound.sampled.DataLine 中的方法
刷新数据行中已列队的数据。
flush() - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
在 reader 上调用的最后一个方法。
flush() - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
flush() - 类 javax.tools.ForwardingJavaFileManager 中的方法
flush() - 接口 javax.tools.JavaFileManager 中的方法
刷新此文件管理器直接或间接为输出打开的所有资源。
flush() - 接口 javax.xml.stream.XMLEventWriter 中的方法
将所有缓存事件写入到底层输出机制。
flush() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
将所有缓存数据写入底层输出机制。
FLUSH_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
FLUSH_FAILURE 用于对输出流的刷新失败时。
Flushable - java.io 中的 接口
Flushable 是可刷新数据的目标地。
flushAttributes() - 类 javax.swing.text.html.parser.Parser 中的方法
flushBefore(long) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
flushBefore(long) - 接口 javax.imageio.stream.ImageInputStream 中的方法
丢弃所指示位置之前的流初始部分。
flushBefore(long) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
flushBefore(long) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
刷新给定位置之前所有数据的缓冲并转到底层目标（如 OutputStream 或 File）。
flushBefore(long) - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
flushBefore(long) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
flushBits() - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
如果位偏移量为非零，则将当前字节中的剩余位强制归 0，并将流位置前移一个字节。
flushCaches() - 类 java.beans.Introspector 中的静态方法
刷新所有 Introspector 的内部缓存。
flushedPos - 类 javax.imageio.stream.ImageInputStreamImpl 中的变量
可能丢弃的数据前面的那个位置。
flushFromCaches(Class<?>) - 类 java.beans.Introspector 中的静态方法
刷新给定类的 Introspector 的内部缓存信息。
flushRequirementChanges() - 类 javax.swing.text.AsyncBoxView 中的方法
将首选项中的更改向上发布到父视图。
flushSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
此方法是在此节点被锁定的情况下调用的。
focus - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
FOCUS - 类 javax.swing.plaf.synth.ColorType 中的静态变量
焦点的 ColorType。
FOCUS_ACCELERATOR_KEY - 类 javax.swing.text.JTextComponent 中的静态变量
焦点加速键的绑定 (bound) 属性名称。
FOCUS_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择焦点事件的事件掩码。
FOCUS_FIRST - 类 java.awt.event.FocusEvent 中的静态变量
用于焦点事件的 id 范围的起始编号。
FOCUS_GAINED - 类 java.awt.event.FocusEvent 中的静态变量
此事件指示 Component 现在是焦点所有者。
FOCUS_LAST - 类 java.awt.event.FocusEvent 中的静态变量
用于焦点事件的 id 范围的结束编号。
FOCUS_LOST - 类 java.awt.event.FocusEvent 中的静态变量
此事件指示 Component 不再是焦点所有者。
FOCUS_MANAGER_CLASS_PROPERTY - 类 javax.swing.FocusManager 中的静态变量
该字段已被废弃，不鼓励使用它，因为它的规范与 1.4 focus API 不兼容。
FOCUS_PAINTED_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识是否在边框拥有焦点时高亮显示。
FOCUSABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象可以接受键盘焦点，这意味着当它具有焦点时，由键盘上的键入操作所产生的所有事件将被传递到此对象。
FocusAdapter - java.awt.event 中的 类
用于接收键盘焦点事件的抽象适配器类。
FocusAdapter() - 类 java.awt.event.FocusAdapter 的构造方法
focusColor - 类 javax.swing.plaf.metal.MetalButtonUI 中的变量
focusColor - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的变量
focusColor - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的变量
FOCUSED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象当前具有键盘焦点。
FOCUSED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 拥有焦点。
focusedCompIndex - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
FocusEvent - java.awt.event 中的 类
指示 Component 已获得或失去输入焦点的低级别事件。
FocusEvent(Component, int, boolean, Component) - 类 java.awt.event.FocusEvent 的构造方法
构造一个 FocusEvent 对象，它具有指定的暂时状态和对立 Component。
FocusEvent(Component, int, boolean) - 类 java.awt.event.FocusEvent 的构造方法
构造一个 FocusEvent 对象，并将标识更改是否为暂时的。
FocusEvent(Component, int) - 类 java.awt.event.FocusEvent 的构造方法
构造一个 FocusEvent 对象，并将它标识为一个持久性焦点更改。
focusGained(FocusEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 focusGained 方法处理 focusGained 事件。
focusGained(FocusEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 中的方法
focusGained(FocusEvent) - 类 java.awt.event.FocusAdapter 中的方法
组件获得键盘焦点时调用。
focusGained(FocusEvent) - 接口 java.awt.event.FocusListener 中的方法
组件获得键盘焦点时调用。
focusGained(FocusEvent) - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicListUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicTableUI.FocusHandler 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 中的方法
focusGained(FocusEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 中的方法
在当前树上激活焦点、重绘前导行时调用。
focusGained(FocusEvent) - 类 javax.swing.text.DefaultCaret 中的方法
在包含插入符的组件获得焦点时调用。
focusInsets - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
FocusListener - java.awt.event 中的 接口
用于接收组件上的键盘焦点事件的侦听器接口。
focusListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
focusListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
focusListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
focusListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
此 JSplitPane 的 FocusListener 的实例。
focusListener - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
focusListener - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
focusLost(FocusEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 focusLost 方法处理 focusLost 事件。
focusLost(FocusEvent) - 类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 中的方法
focusLost(FocusEvent) - 类 java.awt.event.FocusAdapter 中的方法
组件失去键盘焦点时调用。
focusLost(FocusEvent) - 接口 java.awt.event.FocusListener 中的方法
组件失去键盘焦点时调用。
focusLost(FocusEvent) - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicListUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicTableUI.FocusHandler 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener 中的方法
focusLost(FocusEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.FocusHandler 中的方法
在当前树上激活焦点、重绘前导行时调用。
focusLost(FocusEvent) - 类 javax.swing.text.DefaultCaret 中的方法
在包含插入符的组件失去焦点时调用。
FocusManager - javax.swing 中的 类
从 1.4 focus API 开始，此类已被废弃。
FocusManager() - 类 javax.swing.FocusManager 的构造方法
focusNextComponent(Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
使 aComponent 后面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
focusNextComponent(Component) - 类 java.awt.KeyboardFocusManager 中的方法
聚焦 aComponent 之后的 Component，通常基于 FocusTraversalPolicy。
focusNextComponent() - 类 java.awt.KeyboardFocusManager 中的方法
聚焦当前焦点所有者之后的 Component。
focusPreviousComponent(Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
使 aComponent 前面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
focusPreviousComponent(Component) - 类 java.awt.KeyboardFocusManager 中的方法
聚焦 aComponent 之前的 Component，通常基于 FocusTraversalPolicy。
focusPreviousComponent() - 类 java.awt.KeyboardFocusManager 中的方法
聚焦当前焦点所有者之前的 Component。
focusRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
FocusTraversalPolicy - java.awt 中的 类
FocusTraversalPolicy 定义一种顺序，按此顺序遍历具有特定焦点循环根的 Component。
FocusTraversalPolicy() - 类 java.awt.FocusTraversalPolicy 的构造方法
FOLIO - 类 java.awt.PageAttributes.MediaType 中的静态变量
Folio (8 1/2 x 13 in) 的 MediaType 实例。
FOLIO - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 folio 尺寸，8.5 inch × 13 inch。
FOLIO - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
folio 尺寸。
following(int) - 类 java.text.BreakIterator 中的方法
返回指定字符偏移量后面的第一个边界。
Font - java.awt 中的 类
Font 类表示字体，可以使用它以可见方式呈现文本。
Font(String, int, int) - 类 java.awt.Font 的构造方法
根据指定名称、样式和磅值大小，创建一个新 Font。
Font(Map<? extends AttributedCharacterIterator.Attribute, ?>) - 类 java.awt.Font 的构造方法
创建一个具有指定属性的新 Font。
Font(Font) - 类 java.awt.Font 的构造方法
根据指定 font 创建一个新 Font。
FONT - 类 java.awt.font.TextAttribute 中的静态变量
用于提供呈现文本字体的属性键。
font - 类 java.awt.FontMetrics 中的变量
实际的 Font，字体规格是由此创建的。
FONT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
font - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
用以绘制的字体，null 指示将使用呈现器的字体。
FONT_CHANGE_BIGGER - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
字体大小增大到下一个值的动作标识符
FONT_CHANGE_SMALLER - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
字体大小减小到下一个值的动作标识符
FONT_CHOOSER - 类 javax.accessibility.AccessibleRole 中的静态变量
FONT_CHOOSER 是允许用户选择各种字体属性的组件。
FONT_FAMILY - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT_SIZE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT_STYLE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT_VARIANT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
FONT_WEIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
fontChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
FontFamily - 类 javax.swing.text.StyleConstants 中的静态变量
字体系列的名称。
FontFormatException - java.awt 中的 异常
此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
FontFormatException(String) - 异常 java.awt.FontFormatException 的构造方法
报告一个指定了原因的 FontFormatException。
FontMetrics - java.awt 中的 类
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
FontMetrics(Font) - 类 java.awt.FontMetrics 的构造方法
创建一个新 FontMetrics 对象，用于查找该 Font 中关于指定 Font 和特定字符字形的 height 和 width 信息。
FontRenderContext - java.awt.font 中的 类
FontRenderContext 类是正确测量文本所需的信息容器。
FontRenderContext() - 类 java.awt.font.FontRenderContext 的构造方法
构造一个新 FontRenderContext 对象。
FontRenderContext(AffineTransform, boolean, boolean) - 类 java.awt.font.FontRenderContext 的构造方法
根据可选的 AffineTransform 和两个 boolean 值构造一个 FontRenderContext 对象，这两个 boolean 值确定新构造的对象是否具有 anti-aliasing 或 fractional metrics 属性。
FontRenderContext(AffineTransform, Object, Object) - 类 java.awt.font.FontRenderContext 的构造方法
根据一个可选 AffineTransform 和两个 Object 值构造一个 FontRenderContext 对象，这两个值决定了新创建的对象是具有 anti-aliasing 属性，还是具有 fractional metrics 属性。
FontSize - 类 javax.swing.text.StyleConstants 中的静态变量
字体大小的名称。
FontUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 java.awt.Font 的子类。
FontUIResource(String, int, int) - 类 javax.swing.plaf.FontUIResource 的构造方法
FontUIResource(Font) - 类 javax.swing.plaf.FontUIResource 的构造方法
FOOTER - 类 javax.accessibility.AccessibleRole 中的静态变量
文本脚注
force(boolean) - 类 java.nio.channels.FileChannel 中的方法
强制将所有对此通道的文件更新写入包含该文件的存储设备中。
force() - 类 java.nio.MappedByteBuffer 中的方法
将此缓冲区所做的内容更改强制写入包含映射文件的存储设备中。
ForcedBreakWeight - 类 javax.swing.text.View 中的静态变量
该权重指示视图支持拆分，并且在被置入一个通过拆分其子级来格式化子级的视图时，必须拆分该视图以恰当的表示它。
forClass() - 类 java.io.ObjectStreamClass 中的方法
返回此版本所映射的本地 VM 中的类。
forDigit(int, int) - 类 java.lang.Character 中的静态方法
确定使用指定基数的特定数字的字符表示形式。
FOREGROUND - 类 java.awt.font.TextAttribute 中的静态变量
用于呈现文本的 paint 的属性键。
FOREGROUND - 类 javax.swing.plaf.synth.ColorType 中的静态变量
某一 region 前景的 ColorType。
Foreground - 类 javax.swing.text.StyleConstants 中的静态变量
前景色属性的名称。
forget(Xid) - 接口 javax.transaction.xa.XAResource 中的方法
告知资源管理器忽略以启发式完成的事务分支。
FORM - 类 javax.swing.text.html.HTML.Tag 中的静态变量
format(String, Object...) - 类 java.io.Console 中的方法
使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。
format(String, Object...) - 类 java.io.PrintStream 中的方法
使用指定格式字符串和参数将格式化字符串写入此输出流中。
format(Locale, String, Object...) - 类 java.io.PrintStream 中的方法
使用指定格式字符串和参数将格式化字符串写入此输出流中。
format(String, Object...) - 类 java.io.PrintWriter 中的方法
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
format(Locale, String, Object...) - 类 java.io.PrintWriter 中的方法
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
FORMAT - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Cf”。
format(String, Object...) - 类 java.lang.String 中的静态方法
使用指定的格式字符串和参数返回一个格式化字符串。
format(Locale, String, Object...) - 类 java.lang.String 中的静态方法
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。
format(long, StringBuffer, FieldPosition) - 类 java.text.ChoiceFormat 中的方法
特殊格式。
format(double, StringBuffer, FieldPosition) - 类 java.text.ChoiceFormat 中的方法
返回带已格式化 double 的模式。
format(Object, StringBuffer, FieldPosition) - 类 java.text.DateFormat 中的方法
重写 Format。
format(Date, StringBuffer, FieldPosition) - 类 java.text.DateFormat 中的方法
将一个 Date 格式化为日期/时间字符串。
format(Date) - 类 java.text.DateFormat 中的方法
将一个 Date 格式化为日期/时间字符串。
format(Object, StringBuffer, FieldPosition) - 类 java.text.DecimalFormat 中的方法
格式化一个数，并将所得文本追加到给定的字符串缓冲区。
format(double, StringBuffer, FieldPosition) - 类 java.text.DecimalFormat 中的方法
格式化一个 double 值，以生成一个字符串。
format(long, StringBuffer, FieldPosition) - 类 java.text.DecimalFormat 中的方法
格式化一个 long 值，以生成一个字符串。
Format - java.text 中的 类
Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
Format() - 类 java.text.Format 的构造方法
单独的构造方法。
format(Object) - 类 java.text.Format 中的方法
格式化一个对象以生成一个字符串。
format(Object, StringBuffer, FieldPosition) - 类 java.text.Format 中的方法
格式化一个对象，并将得到的文本添加到给定的字符缓冲区。
format(Object[], StringBuffer, FieldPosition) - 类 java.text.MessageFormat 中的方法
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
format(String, Object...) - 类 java.text.MessageFormat 中的静态方法
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。
format(Object, StringBuffer, FieldPosition) - 类 java.text.MessageFormat 中的方法
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
format(Object, StringBuffer, FieldPosition) - 类 java.text.NumberFormat 中的方法
格式化一个数并将所得文本添加到给定字符串缓冲区。
format(double) - 类 java.text.NumberFormat 中的方法
格式规范。
format(long) - 类 java.text.NumberFormat 中的方法
格式规范。
format(double, StringBuffer, FieldPosition) - 类 java.text.NumberFormat 中的方法
格式规范。
format(long, StringBuffer, FieldPosition) - 类 java.text.NumberFormat 中的方法
格式规范。
format(Date, StringBuffer, FieldPosition) - 类 java.text.SimpleDateFormat 中的方法
将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
format(String, Object...) - 类 java.util.Formatter 中的方法
使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。
format(Locale, String, Object...) - 类 java.util.Formatter 中的方法
使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。
format(LogRecord) - 类 java.util.logging.Formatter 中的方法
格式化给定的日志记录，并返回格式化后的字符串。
format(LogRecord) - 类 java.util.logging.SimpleFormatter 中的方法
格式化给定的 LogRecord。
format(LogRecord) - 类 java.util.logging.XMLFormatter 中的方法
将给定消息格式化为 XML。
format - 类 javax.sound.sampled.AudioInputStream 中的变量
流中包含的音频数据的格式。
format - 类 org.omg.IOP.Encoding 中的变量
编码格式。
Format.Field - java.text 中的 类
定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
Format.Field(String) - 类 java.text.Format.Field 的构造方法
创建具有指定名称的 Field。
FORMAT_CLASS - 类 java.util.ResourceBundle.Control 中的静态变量
包含 "java.class" 的纯类 (class-only) 格式 List。
FORMAT_DEFAULT - 类 java.util.ResourceBundle.Control 中的静态变量
默认的格式 List，它包含字符串 "java.class" 和 "java.properties"（按此顺序）。
FORMAT_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
FORMAT_FAILURE 用于因任何格式化问题导致的失败 。
FORMAT_PROPERTIES - 类 java.util.ResourceBundle.Control 中的静态变量
包含 "java.properties" 的纯属性 (properties-only) 格式 List。
FormatConversionProvider - javax.sound.sampled.spi 中的 类
格式转换提供者提供从一种或多种输入格式到一种或多种输出格式的格式转换服务。
FormatConversionProvider() - 类 javax.sound.sampled.spi.FormatConversionProvider 的构造方法
FormatFlagsConversionMismatchException - java.util 中的 异常
转换与标志不兼容时抛出未经检查的异常。
FormatFlagsConversionMismatchException(String, char) - 异常 java.util.FormatFlagsConversionMismatchException 的构造方法
构造带指定标志和转换的此类的一个实例。
formatMessage(LogRecord) - 类 java.util.logging.Formatter 中的方法
本地化和格式化来自日志记录的消息字符串。
FormatMismatch - org.omg.IOP.CodecPackage 中的 异常
org/omg/IOP/CodecPackage/FormatMismatch.java。
FormatMismatch() - 异常 org.omg.IOP.CodecPackage.FormatMismatch 的构造方法
FormatMismatch(String) - 异常 org.omg.IOP.CodecPackage.FormatMismatch 的构造方法
FormatMismatchHelper - org.omg.IOP.CodecPackage 中的 类
org/omg/IOP/CodecPackage/FormatMismatchHelper.java。
FormatMismatchHelper() - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 的构造方法
Formattable - java.util 中的 接口
Formattable 接口必须通过需要执行自定义格式化（使用 Formatter 的 's' 转换说明符）的任何类来实现。
FormattableFlags - java.util 中的 类
将 FomattableFlags 传递给 Formattable.formatTo() 方法，并修改 Formattables 的输出格式。
FORMATTED_TEXT_FIELD - 类 javax.swing.plaf.synth.Region 中的静态变量
FormattedTextField 的 region。
Formatter - java.util 中的 类
printf 风格的格式字符串的解释程序。
Formatter() - 类 java.util.Formatter 的构造方法
构造一个新 formatter。
Formatter(Appendable) - 类 java.util.Formatter 的构造方法
构造一个带指定目标文件的新 formatter。
Formatter(Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定语言环境的新 formatter。
Formatter(Appendable, Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定目标文件和语言环境的新 formatter。
Formatter(String) - 类 java.util.Formatter 的构造方法
构造一个带指定文件名的新 formatter。
Formatter(String, String) - 类 java.util.Formatter 的构造方法
构造一个带指定文件名和字符集的新 formatter。
Formatter(String, String, Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定文件名、字符集和语言环境的新 formatter。
Formatter(File) - 类 java.util.Formatter 的构造方法
构造一个带指定文件的新 formatter。
Formatter(File, String) - 类 java.util.Formatter 的构造方法
构造一个带指定文件和字符集的新 formatter。
Formatter(File, String, Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(PrintStream) - 类 java.util.Formatter 的构造方法
构造一个带指定输出流的新 formatter。
Formatter(OutputStream) - 类 java.util.Formatter 的构造方法
构造一个带指定输出流的新 formatter。
Formatter(OutputStream, String) - 类 java.util.Formatter 的构造方法
构造一个带指定输出流和字符集的新 formatter。
Formatter(OutputStream, String, Locale) - 类 java.util.Formatter 的构造方法
构造一个带指定输出流、字符集和语言环境的新 formatter。
Formatter - java.util.logging 中的 类
Formatter 为格式化 LogRecords 提供支持。
Formatter() - 类 java.util.logging.Formatter 的构造方法
构造一个新的 Formatter。
Formatter.BigDecimalLayoutForm - java.util 中的 枚举
FormatterClosedException - java.util 中的 异常
格式器已关闭时抛出的未经检查的异常。
FormatterClosedException() - 异常 java.util.FormatterClosedException 的构造方法
构造此类的一个实例。
formatTo(Formatter, int, int, int) - 接口 java.util.Formattable 中的方法
使用提供的格式器来格式化对象。
formatToCharacterIterator(Object) - 类 java.text.DecimalFormat 中的方法
格式化一个 Object，以生成一个 AttributedCharacterIterator。
formatToCharacterIterator(Object) - 类 java.text.Format 中的方法
格式化一个对象，生成一个 AttributedCharacterIterator。
formatToCharacterIterator(Object) - 类 java.text.MessageFormat 中的方法
格式化一个对象数组，并将它们插入 MessageFormat 的模式中，生成一个 AttributedCharacterIterator。
formatToCharacterIterator(Object) - 类 java.text.SimpleDateFormat 中的方法
格式化生成 AttributedCharacterIterator 的对象。
FormSubmitEvent - javax.swing.text.html 中的 类
FormSubmitEvent 用于通知提交表单所需的参与者。
FormSubmitEvent.MethodType - javax.swing.text.html 中的 枚举
表示 HTML 表单方法类型。
FormView - javax.swing.text.html 中的 类
实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
FormView(Element) - 类 javax.swing.text.html.FormView 的构造方法
创建新的 FormView 对象。
FormView.MouseEventListener - javax.swing.text.html 中的 类
当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
FormView.MouseEventListener() - 类 javax.swing.text.html.FormView.MouseEventListener 的构造方法
forName(String) - 类 java.lang.Character.UnicodeBlock 中的静态方法
返回带有给定名称的 UnicodeBlock。
forName(String) - 类 java.lang.Class 中的静态方法
返回与带有给定字符串名的类或接口相关联的 Class 对象。
forName(String, boolean, ClassLoader) - 类 java.lang.Class 中的静态方法
使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
forName(String) - 类 java.nio.charset.Charset 中的静态方法
返回指定 charset 的 charset 对象。
Forward - 类 javax.swing.text.Position.Bias 中的静态变量
指示到模型中下一字符的偏差。
forward - 异常 org.omg.PortableInterceptor.ForwardRequest 中的变量
将请求转发到的新对象。
forward_reference() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
如果 reply_status 属性为 LOCATION_FORWARD，则包含要将请求转发到的对象。
forward_reference - 异常 org.omg.PortableServer.ForwardRequest 中的变量
FORWARD_TRAVERSAL_KEYS - 类 java.awt.KeyboardFocusManager 中的静态变量
Forward 焦点遍历键的标识符。
forwardAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符逻辑向前移动一个位置的动作名称。
ForwardingFileObject<F extends FileObject> - javax.tools 中的 类
将调用转发到给定的文件对象。
ForwardingFileObject(F) - 类 javax.tools.ForwardingFileObject 的构造方法
创建一个新的 ForwardingFileObject 实例。
ForwardingJavaFileManager<M extends JavaFileManager> - javax.tools 中的 类
将调用转发到给定的文件管理器。
ForwardingJavaFileManager(M) - 类 javax.tools.ForwardingJavaFileManager 的构造方法
创建一个新的 ForwardingJavaFileManager 的实例。
ForwardingJavaFileObject<F extends JavaFileObject> - javax.tools 中的 类
将调用转发到给定的文件对象。
ForwardingJavaFileObject(F) - 类 javax.tools.ForwardingJavaFileObject 的构造方法
创建一个新的 ForwardingJavaFileObject 实例。
ForwardRequest - org.omg.PortableInterceptor 中的 异常
org/omg/PortableInterceptor/ForwardRequest.java。
ForwardRequest() - 异常 org.omg.PortableInterceptor.ForwardRequest 的构造方法
ForwardRequest(Object) - 异常 org.omg.PortableInterceptor.ForwardRequest 的构造方法
ForwardRequest(String, Object) - 异常 org.omg.PortableInterceptor.ForwardRequest 的构造方法
ForwardRequest - org.omg.PortableServer 中的 异常
org/omg/PortableServer/ForwardRequest.java。
ForwardRequest() - 异常 org.omg.PortableServer.ForwardRequest 的构造方法
ForwardRequest(Object) - 异常 org.omg.PortableServer.ForwardRequest 的构造方法
ForwardRequest(String, Object) - 异常 org.omg.PortableServer.ForwardRequest 的构造方法
ForwardRequestHelper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/ForwardRequestHelper.java。
ForwardRequestHelper() - 类 org.omg.PortableInterceptor.ForwardRequestHelper 的构造方法
ForwardRequestHelper - org.omg.PortableServer 中的 类
org/omg/PortableServer/ForwardRequestHelper.java。
ForwardRequestHelper() - 类 org.omg.PortableServer.ForwardRequestHelper 的构造方法
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.BoxView 中的方法
将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.TableView 中的方法
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
forwardUpdateToView(View, DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
将 DocumentEvent 转发到给定的子视图。
foundType() - 异常 java.lang.annotation.AnnotationTypeMismatchException 中的方法
返回在类型不正确的元素中找到的数据类型。
FRACTION - 类 java.text.NumberFormat.Field 中的静态变量
标识小数字段的常量。
FRACTION_FIELD - 类 java.text.NumberFormat 中的静态变量
用于构造 FieldPosition 对象的字段常量。
Frame - java.awt 中的 类
Frame 是带有标题和边框的顶层窗口。
Frame() - 类 java.awt.Frame 的构造方法
构造一个最初不可见的 Frame 新实例（）。
Frame(GraphicsConfiguration) - 类 java.awt.Frame 的构造方法
使用指定的 GraphicsConfiguration 构造一个最初不可见的新 Frame。
Frame(String) - 类 java.awt.Frame 的构造方法
构造一个新的、最初不可见的、具有指定标题的 Frame 对象。
Frame(String, GraphicsConfiguration) - 类 java.awt.Frame 的构造方法
构造一个新的、初始不可见的、具有指定标题和 GraphicsConfiguration 的 Frame 对象。
FRAME - 类 javax.accessibility.AccessibleRole 中的静态变量
带有标题栏、边框、菜单栏等的顶层窗口。
FRAME - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
frame - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的变量
frame - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
frame - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
FRAME - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Frame.AccessibleAWTFrame - java.awt 中的 类
此类实现对 Frame 类的可访问性支持。
Frame.AccessibleAWTFrame() - 类 java.awt.Frame.AccessibleAWTFrame 的构造方法
FRAME_CONTENT_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Frame Content 层的便捷对象。
FRAME_ICON_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
FRAMEBITS - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示多帧图像（以前绘制的）的另一个完整帧现在可以再次绘制。
FRAMEBORDER - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
frameIcon - 类 javax.swing.JInternalFrame 中的变量
此内部窗体左上角显示的图标。
frameInit() - 类 javax.swing.JFrame 中的方法
由构造方法调用，以适当地初始化 JFrame。
frameLength - 类 javax.sound.sampled.AudioInputStream 中的变量
此流的长度，以示例帧为单位。
framePos - 类 javax.sound.sampled.AudioInputStream 中的变量
此流中的当前位置，以示例帧为单位（从零开始）。
frameRate - 类 javax.sound.sampled.AudioFormat 中的变量
具有此格式的声音每秒播放和录制的帧数。
FRAMESET - 类 javax.swing.text.html.HTML.Tag 中的静态变量
frameSize - 类 javax.sound.sampled.AudioFormat 中的变量
每个具有此格式的声音帧包含的字节数。
frameSize - 类 javax.sound.sampled.AudioInputStream 中的变量
每帧的大小，以字节为单位。
FRANCE - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
free() - 接口 java.sql.Array 中的方法
此方法释放 Array 对象以及它占用的资源。
free() - 接口 java.sql.Blob 中的方法
此方法释放 Blob 对象以及它所占用的资源。
free() - 接口 java.sql.Clob 中的方法
此方法释放 Clob 对象以及它所占用的资源。
free() - 接口 java.sql.SQLXML 中的方法
此方法关闭此对象并释放其持有的资源。
free() - 类 javax.sql.rowset.serial.SerialArray 中的方法
此方法释放 Array 对象及其占有的资源。
free() - 类 javax.sql.rowset.serial.SerialBlob 中的方法
此方法释放 Blob 对象及其占有的资源。
free() - 类 javax.sql.rowset.serial.SerialClob 中的方法
FREE_MEM - org.omg.CORBA 中的 异常
当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
FREE_MEM() - 异常 org.omg.CORBA.FREE_MEM 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。
FREE_MEM(String) - 异常 org.omg.CORBA.FREE_MEM 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。
FREE_MEM(int, CompletionStatus) - 异常 org.omg.CORBA.FREE_MEM 的构造方法
使用指定次要代码和完成状态构造一个 FREE_MEM 异常。
FREE_MEM(String, int, CompletionStatus) - 异常 org.omg.CORBA.FREE_MEM 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 FREE_MEM 异常。
FREE_STANDING_PROP - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的静态变量
freeMemory() - 类 java.lang.Runtime 中的方法
返回 Java 虚拟机中的空闲内存量。
FRENCH - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
frequency(Collection<?>, Object) - 类 java.util.Collections 中的静态方法
返回指定 collection 中等于指定对象的元素数。
FRIDAY - 类 java.util.Calendar 中的静态变量
指示 Friday 的 Calendar.DAY_OF_WEEK 字段值。
from(CompositeData) - 类 java.lang.management.MemoryNotificationInfo 中的静态方法
返回由给定 CompositeData 表示的 MemoryNotificationInfo 对象。
from(CompositeData) - 类 java.lang.management.MemoryUsage 中的静态方法
返回由给定 CompositeData 表示的 MemoryUsage 对象。
from(CompositeData) - 类 java.lang.management.MonitorInfo 中的静态方法
返回给定 CompositeData 表示的 MonitorInfo 对象。
from(CompositeData) - 类 java.lang.management.ThreadInfo 中的静态方法
返回由给定 CompositeData 表示的 ThreadInfo 对象。
from_any(Any) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 根据 Any 对象生成一个 DynAny 对象。
from_any(Any) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynStructStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
from_any(Any) - 类 org.omg.DynamicAny._DynValueStub 中的方法
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
from_any(Any) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
使用 any 中包含的值初始化与 DynAny 对象有关联的值。
from_int(int) - 类 org.omg.CORBA.CompletionStatus 中的静态方法
根据给定的 int 创建一个 CompletionStatus 对象。
from_int(int) - 类 org.omg.CORBA.DefinitionKind 中的静态方法
创建一个对应于给定代码的 DefinitionKind 实例。
from_int(int) - 类 org.omg.CORBA.ParameterMode 中的静态方法
from_int(int) - 类 org.omg.CORBA.SetOverrideType 中的静态方法
将给定 int 值转换成相应的 SetOverrideType 实例。
from_int(int) - 类 org.omg.CORBA.TCKind 中的静态方法
将给定 int 值转换成相应的 TCKind 实例。
from_int(int) - 类 org.omg.CosNaming.BindingType 中的静态方法
from_int(int) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态方法
from_int(int) - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态方法
from_int(int) - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态方法
from_int(int) - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态方法
fromCIEXYZ(float[]) - 类 java.awt.color.ColorSpace 中的方法
将假定为 CS_CIEXYZ 变换颜色空间中的颜色值转换成此 ColorSpace 中的值。
fromCIEXYZ(float[]) - 类 java.awt.color.ICC_ColorSpace 中的方法
将假定为 CS_CIEXYZ 变换颜色空间中的颜色值转换为此 ColorSpace 中的值。
fromIndex - 类 javax.swing.event.TableColumnModelEvent 中的变量
列的索引，从该索引处移动或移除列
fromRGB(float[]) - 类 java.awt.color.ColorSpace 中的方法
将假定为默认 CS_sRGB 颜色空间中的颜色值转换成此 ColorSpace 中的值。
fromRGB(float[]) - 类 java.awt.color.ICC_ColorSpace 中的方法
将假定为默认 CS_sRGB 颜色空间中的颜色值转换成此 ColorSpace 中的值。
fromString(String) - 类 java.util.UUID 中的静态方法
根据 UUID.toString() 方法中描述的字符串标准表示形式创建 UUID。
FTP - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
文件传输协议 (FTP)。
FULL - 类 java.text.DateFormat 中的静态变量
用于 FULL 模式的常量。
FULL_DECOMPOSITION - 类 java.text.Collator 中的静态变量
Decomposition 模式值。
FULL_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供一个完全 JOIN。
FULLWIDTH_DIGITS - 类 java.awt.im.InputSubset 中的静态变量
Unicode 半角和全角字符块中包括的全角数字常量。
FULLWIDTH_LATIN - 类 java.awt.im.InputSubset 中的静态变量
Unicode 半角和全角字符块的全角 ASCII 变体子集常量。
functionColumnIn - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是一个 IN 参数。
functionColumnInOut - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是一个 INOUT 参数。
functionColumnOut - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是一个 OUT 参数。
functionColumnResult - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是结果集中的一列。
functionColumnUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示该类型的参数或列未知。
functionNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不允许 NULL 值。
functionNoTable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示函数不返回一个表。
functionNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示允许 NULL 值。
functionNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示是否允许 NULL 值是未知的。
functionResultUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道函数是返回一个结果还是一个表。
functionReturn - 接口 java.sql.DatabaseMetaData 中的静态变量
指示参数或列是一个返回值。
functionReturnsTable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示函数返回一个表。
FUSER_OVER_TEMP - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
热熔器温度高于正常值。
FUSER_UNDER_TEMP - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
热熔器温度低于正常值。
Future<V> - java.util.concurrent 中的 接口
Future 表示异步计算的结果。
FutureTask<V> - java.util.concurrent 中的 类
可取消的异步计算。
FutureTask(Callable<V>) - 类 java.util.concurrent.FutureTask 的构造方法
创建一个 FutureTask，一旦运行就执行给定的 Callable。
FutureTask(Runnable, V) - 类 java.util.concurrent.FutureTask 的构造方法
创建一个 FutureTask，一旦运行就执行给定的 Runnable，并安排成功完成时 get 返回给定的结果 。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


G - 索引 (Java Platform SE 6)

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM Platform
Standard Ed. 6

上一个字母 下一个字母

框架 无框架

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

G

GAP_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
未收到需要的 per-message 标记。
GapContent - javax.swing.text 中的 类
AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。
GapContent() - 类 javax.swing.text.GapContent 的构造方法
创建新的 GapContent 对象。
GapContent(int) - 类 javax.swing.text.GapContent 的构造方法
创建具有指定初始大小的新 GapContent 对象。
GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE - 类 java.lang.management.ManagementFactory 中的静态变量
GarbageCollectorMXBean 的 ObjectName 中的域名和类型键属性。
GarbageCollectorMXBean - java.lang.management 中的 接口
用于 Java 虚拟机的垃圾回收的管理接口。
GatheringByteChannel - java.nio.channels 中的 接口
可从缓冲区序列写入字节的通道。
GaugeMonitor - javax.management.monitor 中的 类
定义专门用来观察尺度属性值的监视器 MBean。
GaugeMonitor() - 类 javax.management.monitor.GaugeMonitor 的构造方法
默认的构造方法。
GaugeMonitorMBean - javax.management.monitor 中的 接口
公开尺度监视器 MBean 的远程管理接口。
gc() - 接口 java.lang.management.MemoryMXBean 中的方法
运行垃圾回收器。
gc() - 类 java.lang.Runtime 中的方法
运行垃圾回收器。
gc() - 类 java.lang.System 中的静态方法
运行垃圾回收器。
gcd(BigInteger) - 类 java.math.BigInteger 中的方法
返回一个 BigInteger，其值是 abs(this) 和 abs(val) 的最大公约数。
GDAY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gDay 的完全限定名称。
GE - 类 javax.management.Query 中的静态变量
表示 Query.geq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
GENERAL - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量

GENERAL_PUNCTUATION - 类 java.lang.Character.UnicodeBlock 中的静态变量
“General Punctuation”Unicode 字符块的常量。
GeneralPath - java.awt.geom 中的 类
GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
GeneralPath() - 类 java.awt.geom.GeneralPath 的构造方法
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的单精度空 GeneralPath 对象。
GeneralPath(int) - 类 java.awt.geom.GeneralPath 的构造方法
根据指定旋绕规则构造一个新的 GeneralPath 对象，以控制需要定义路径内部的操作。
GeneralPath(int, int) - 类 java.awt.geom.GeneralPath 的构造方法
根据指定旋绕规则和指定初始容量构造一个新的 GeneralPath 对象，以存储路径坐标。
GeneralPath(Shape) - 类 java.awt.geom.GeneralPath 的构造方法
根据任意 Shape 对象构造一个新 GeneralPath 对象。
GeneralSecurityException - java.security 中的 异常
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
GeneralSecurityException() - 异常 java.security.GeneralSecurityException 的构造方法
构造不带详细消息的 GeneralSecurityException。
GeneralSecurityException(String) - 异常 java.security.GeneralSecurityException 的构造方法
构造带指定详细消息的 GeneralSecurityException。
GeneralSecurityException(String, Throwable) - 异常 java.security.GeneralSecurityException 的构造方法
创建带指定详细消息和 cause 的 GeneralSecurityException。
GeneralSecurityException(Throwable) - 异常 java.security.GeneralSecurityException 的构造方法
用指定的原因和详细消息创建一个 GeneralSecurityException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
generateCertificate(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
generateCertificates(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
generateCertPath(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
generateCertPath(InputStream, String) - 类 java.security.cert.CertificateFactory 中的方法
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
generateCertPath(List<? extends Certificate>) - 类 java.security.cert.CertificateFactory 中的方法
生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
generateCRL(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
generateCRLs(InputStream) - 类 java.security.cert.CertificateFactory 中的方法
返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Generated - javax.annotation 中的 注释类型
Generated 注释用于标记已生成的源代码。
generateKey() - 类 javax.crypto.KeyGenerator 中的方法
生成一个密钥。
generateKeyPair() - 类 java.security.KeyPairGenerator 中的方法
生成一个密钥对。
generateKeyPair() - 类 java.security.KeyPairGeneratorSpi 中的方法
生成密钥对。
generateParameters() - 类 java.security.AlgorithmParameterGenerator 中的方法
生成参数。
generatePrivate(KeySpec) - 类 java.security.KeyFactory 中的方法
根据提供的密钥规范（密钥材料）生成私钥对象。
generatePublic(KeySpec) - 类 java.security.KeyFactory 中的方法
根据提供的密钥规范（密钥材料）生成公钥对象。
generateSchema(SchemaOutputResolver) - 类 javax.xml.bind.JAXBContext 中的方法
生成此上下文的模式文档。
generateSecret() - 类 javax.crypto.KeyAgreement 中的方法
生成共享秘密并在新的缓冲区中返回它。
generateSecret(byte[], int) - 类 javax.crypto.KeyAgreement 中的方法
生成共享秘密，并将其放入缓冲区 sharedSecret，从 offset（包括）开始。
generateSecret(String) - 类 javax.crypto.KeyAgreement 中的方法
创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
generateSecret(KeySpec) - 类 javax.crypto.SecretKeyFactory 中的方法
根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
generateSeed(int) - 类 java.security.SecureRandom 中的方法
返回给定的种子字节数量，该数量可使用此类用来将自身设置为种子的种子生成算法来计算。
GENERIC_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
GENERIC_FAILURE 用于不属于其他任何一类的失败。
GenericArrayType - java.lang.reflect 中的 接口
GenericArrayType 表示一种数组类型，其组件类型为参数化类型或类型变量。
GenericDeclaration - java.lang.reflect 中的 接口
声明类型变量的所有实体的公共接口。
GenericSignatureFormatError - java.lang.reflect 中的 错误
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。
GenericSignatureFormatError() - 错误 java.lang.reflect.GenericSignatureFormatError 的构造方法

genExemptionBlob() - 类 javax.crypto.ExemptionMechanism 中的方法
生成豁免机制密钥 blob。
genExemptionBlob(byte[]) - 类 javax.crypto.ExemptionMechanism 中的方法
生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
genExemptionBlob(byte[], int) - 类 javax.crypto.ExemptionMechanism 中的方法
生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
genKeyPair() - 类 java.security.KeyPairGenerator 中的方法
生成密钥对。
GEOMETRIC_SHAPES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Geometric Shapes”Unicode 字符块的常量。
GEORGIAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Georgian”Unicode 字符块的常量。
geq(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于两个值的“大于或等于”约束条件。
GERMAN - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
GERMANY - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
get(Object) - 类 java.awt.RenderingHints 中的方法
返回指定键所映射的值。
get(Object) - 类 java.beans.Encoder 中的方法
在由此流创建的环境中返回 oldInstance 的一个实验值。
get(String, boolean) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定的 boolean 字段值。
get(String, byte) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定字节字段的值。
get(String, char) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 char 字段的值。
get(String, short) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定的 short 字段值。
get(String, int) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定的 int 字段值。
get(String, long) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 long 字段的值。
get(String, float) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 float 字段的值。
get(String, double) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 double 字段的值。
get(String, Object) - 类 java.io.ObjectInputStream.GetField 中的方法
从持久字段获取指定 Object 字段的值。
get() - 类 java.lang.ref.PhantomReference 中的方法
返回此引用对象的指示对象。
get() - 类 java.lang.ref.Reference 中的方法
返回此引用对象的指示对象。
get() - 类 java.lang.ref.SoftReference 中的方法
返回此引用对象的指示对象。
get(Object, int) - 类 java.lang.reflect.Array 中的静态方法
返回指定数组对象中索引组件的值。
get(Object) - 类 java.lang.reflect.Field 中的方法
返回指定对象上此 Field 表示的字段的值。
get() - 类 java.lang.ThreadLocal 中的方法
返回此线程局部变量的当前线程副本中的值。
get(URI, Map<String, List<String>>) - 类 java.net.CookieHandler 中的方法
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
get(URI, Map<String, List<String>>) - 类 java.net.CookieManager 中的方法

get(URI) - 接口 java.net.CookieStore 中的方法
获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
get(URI, String, Map<String, List<String>>) - 类 java.net.ResponseCache 中的方法
根据请求的 uri、请求方法和请求头获取缓存的响应。
get() - 类 java.nio.ByteBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.ByteBuffer 中的方法
绝对 get 方法。
get(byte[], int, int) - 类 java.nio.ByteBuffer 中的方法
相对批量 get 方法。
get(byte[]) - 类 java.nio.ByteBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.CharBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.CharBuffer 中的方法
绝对 get 方法。
get(char[], int, int) - 类 java.nio.CharBuffer 中的方法
相对批量 get 方法。
get(char[]) - 类 java.nio.CharBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.DoubleBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.DoubleBuffer 中的方法
绝对 get 方法。
get(double[], int, int) - 类 java.nio.DoubleBuffer 中的方法
相对批量 get 方法。
get(double[]) - 类 java.nio.DoubleBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.FloatBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.FloatBuffer 中的方法
绝对 get 方法。
get(float[], int, int) - 类 java.nio.FloatBuffer 中的方法
相对批量 get 方法。
get(float[]) - 类 java.nio.FloatBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.IntBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.IntBuffer 中的方法
绝对 get 方法。
get(int[], int, int) - 类 java.nio.IntBuffer 中的方法
相对批量 get 方法。
get(int[]) - 类 java.nio.IntBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.LongBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.LongBuffer 中的方法
绝对 get 方法。
get(long[], int, int) - 类 java.nio.LongBuffer 中的方法
相对批量 get 方法。
get(long[]) - 类 java.nio.LongBuffer 中的方法
相对批量 get 方法。
get() - 类 java.nio.ShortBuffer 中的方法
相对 get 方法。
get(int) - 类 java.nio.ShortBuffer 中的方法
绝对 get 方法。
get(short[], int, int) - 类 java.nio.ShortBuffer 中的方法
相对批量 get 方法。
get(short[]) - 类 java.nio.ShortBuffer 中的方法
相对批量 get 方法。
get() - 类 java.rmi.MarshalledObject 中的方法
返回所包含的 marshalledobject 的新副本。
get(Object) - 类 java.security.Provider 中的方法

get(int) - 类 java.util.AbstractList 中的方法
返回列表中指定位置的元素。
get(Object) - 类 java.util.AbstractMap 中的方法
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。
get(int) - 类 java.util.AbstractSequentialList 中的方法
返回此列表中指定位置上的元素。
get(int) - 类 java.util.ArrayList 中的方法
返回此列表中指定位置上的元素。
get(int) - 类 java.util.BitSet 中的方法
返回指定索引处的位值。
get(int, int) - 类 java.util.BitSet 中的方法
返回一个新的 BitSet，它由此 BitSet 中从 fromIndex（包括）到 toIndex（不包括）范围内的位组成。
get(int) - 类 java.util.Calendar 中的方法
返回给定日历字段的值。
get() - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
返回当前值。
get() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
获取当前值。
get(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
获取位置 i 的当前值。
get(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
获取此更新器管理的在给定对象的字段中保持的当前值。
get() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
获取当前值。
get(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
获取位置 i 的当前值。
get(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
获取此更新器管理的在给定对象的字段中保持的当前值。
get(boolean[]) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
返回该引用和该标记的当前值。
get() - 类 java.util.concurrent.atomic.AtomicReference 中的方法
获取当前值。
get(int) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
获取位置 i 的当前值。
get(T) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
获取由此更新器管理的在给定对象的字段中保持的当前值。
get(int[]) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
返回该引用和该标志的当前值。
get(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回指定键所映射到的值，如果此映射不包含该键的映射关系，则返回 null。
get(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回指定键所映射到的值；如果此映射不包含该键的映射关系，则返回 null。
get(int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回列表中指定位置的元素。
get() - 接口 java.util.concurrent.Future 中的方法
如有必要，等待计算完成，然后获取其结果。
get(long, TimeUnit) - 接口 java.util.concurrent.Future 中的方法
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
get() - 类 java.util.concurrent.FutureTask 中的方法

get(long, TimeUnit) - 类 java.util.concurrent.FutureTask 中的方法

get(Object) - 类 java.util.Dictionary 中的方法
返回此 dictionary 中该键所映射到的值。
get(Object) - 类 java.util.EnumMap 中的方法
返回指定键所映射的值，如果此映射不包含此键的映射关系，则返回 null。
get(Object) - 类 java.util.HashMap 中的方法
返回指定键所映射的值；如果对于该键来说，此映射不包含任何映射关系，则返回 null。
get(Object) - 类 java.util.Hashtable 中的方法
返回指定键所映射到的值，如果此映射不包含此键的映射，则返回 null. 更确切地讲，如果此映射包含满足 (key.equals(k)) 的从键 k 到值 v 的映射，则此方法返回 v；否则，返回 null。
get(Object) - 类 java.util.IdentityHashMap 中的方法
返回指定键映射的值；如果映射不包含此键的任何映射关系，则返回 null。
get(Object) - 类 java.util.jar.Attributes 中的方法
返回指定的属性名称的值，如果未找到属性名称，则返回 null。
get(Object) - 类 java.util.LinkedHashMap 中的方法
返回此映射到指定键的值。
get(int) - 类 java.util.LinkedList 中的方法
返回此列表中指定位置处的元素。
get(int) - 接口 java.util.List 中的方法
返回列表中指定位置的元素。
get(Object) - 接口 java.util.Map 中的方法
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。
get(String, String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.get(String,String) 中的规范实现 get 方法。
get(String, String) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定键相关联的值。
get(Object) - 类 java.util.TreeMap 中的方法
返回指定键所映射的值，如果对于该键而言，此映射不包含任何映射关系，则返回 null。
get(int) - 类 java.util.Vector 中的方法
返回向量中指定位置的元素。
get(Object) - 类 java.util.WeakHashMap 中的方法
返回指定键所映射的值，如果对于该键来说，此映射不包含任何映射关系，则返回 null。
get(String) - 类 javax.accessibility.AccessibleRelationSet 中的方法
返回与指定键匹配的关系。
get(String) - 类 javax.activation.MimeTypeParameterList 中的方法
获取与给定名称关联的值；如果不存在当前关联，则返回 null。
get(String) - 接口 javax.management.openmbean.CompositeData 中的方法
返回名称为 key 的项的值。
get(String) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回其名称是 key 的项的值。
get(Object[]) - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例中其索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
get(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
此方法仅调用 get((Object[]) key)。
get(Object[]) - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularData 实例中索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
get(int) - 类 javax.naming.CompositeName 中的方法
检索此复合名称的组件。
get(int) - 类 javax.naming.CompoundName 中的方法
检索此组合名称的组件。
get() - 接口 javax.naming.directory.Attribute 中的方法
检索此属性的其中一个值。
get(int) - 接口 javax.naming.directory.Attribute 中的方法
从属性值的有序列表中检索属性值。
get(String) - 接口 javax.naming.directory.Attributes 中的方法
利用属性集中的给定属性 id 检索属性。
get() - 类 javax.naming.directory.BasicAttribute 中的方法
检索此属性的其中一个值。
get(int) - 类 javax.naming.directory.BasicAttribute 中的方法

get(String) - 类 javax.naming.directory.BasicAttributes 中的方法

get(int) - 类 javax.naming.ldap.LdapName 中的方法
以字符串形式检索此 LDAP 名称的组件。
get(int) - 接口 javax.naming.Name 中的方法
检索此名称的组件。
get(String) - 类 javax.naming.Reference 中的方法
检索地址类型为 'addrType' 的第一个地址。
get(int) - 类 javax.naming.Reference 中的方法
检索索引 posn 处的地址。
get(Class<?>) - 接口 javax.print.attribute.AttributeSet 中的方法
返回此属性集在给定的属性类别中包含的属性值。
get(Class<?>) - 类 javax.print.attribute.HashAttributeSet 中的方法
返回此属性集在给定的属性类别中包含的属性值。
get(String) - 类 javax.script.AbstractScriptEngine 中的方法
获取受保护 context 字段的 ENGINE_SCOPE 中指定键的值。
get(Object) - 接口 javax.script.Bindings 中的方法
返回此映射将指定键所映射的值。
get(String) - 接口 javax.script.ScriptEngine 中的方法
获取在此引擎的状态中设置的值。
get(String) - 类 javax.script.ScriptEngineManager 中的方法
获取 Global Scope 中指定键的值。
get(Object) - 类 javax.script.SimpleBindings 中的方法
返回此映射将指定键所映射到的值。
get(int) - 类 javax.sound.midi.Track 中的方法
获得位于指定索引处的事件。
get(Object) - 类 javax.swing.ActionMap 中的方法
返回 key 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 ActionMap。
get(int) - 类 javax.swing.DefaultListModel 中的方法
返回列表中指定位置处的元素。
get(KeyStroke) - 类 javax.swing.InputMap 中的方法
返回 keyStroke 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 InputMap。
get(SynthContext, Object) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
某个 region 特定样式属性的获取器。
get() - 类 javax.swing.SwingWorker 中的方法
如有必要，等待计算完成，然后获取其结果。
get(long, TimeUnit) - 类 javax.swing.SwingWorker 中的方法
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
get(Object) - 类 javax.swing.UIDefaults 中的方法
返回键的值。
get(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
返回与给定语言环境相关的那些键的值。
get(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个对象。
get(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个对象。
get(Object) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 获取指定键所映射的对象。
get(Object) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回此上下文将指定键映射到的值。
get(Object) - 类 javax.xml.soap.SOAPConnection 中的方法
从特定端点获取消息，在收到消息前将一直阻塞。
get2DigitYearStart() - 类 java.text.SimpleDateFormat 中的方法
返回在 100 年周期内被解释的两位数字年份的开始日期。
get_any() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Any。
get_any() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
提取由此 DynAny 表示的 Any 中包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynStructStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_any() - 类 org.omg.DynamicAny._DynValueStub 中的方法
提取由此 DynAny 表示的 Any 中包含的 Any 值。
get_any() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值。
get_as_string() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
以 IDL 标识符的形式返回 DynEnum 的值。
get_as_string() - 接口 org.omg.DynamicAny.DynEnumOperations 中的方法
以 IDL 标识符的形式返回 DynEnum 的值。
get_as_ulong() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
以枚举值的序数值 (ordinal value) 的形式返回 DynEnum 的值。
get_as_ulong() - 接口 org.omg.DynamicAny.DynEnumOperations 中的方法
以枚举值序号的形式返回 DynEnum 的值。
get_boolean() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 析取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 boolean 值。
get_boolean() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 boolean 值。
get_boxed_value() - 接口 org.omg.DynamicAny.DynValueBoxOperations 中的方法
以 Any 的形式返回装箱值。
get_boxed_value_as_dyn_any() - 接口 org.omg.DynamicAny.DynValueBoxOperations 中的方法
以 DynAny 的形式返回已装箱值。
get_char() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 char 值。
get_char() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 析取 char 值。
get_char() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 析取 char 值。
get_char() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 char 值。
get_char() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 char 值。
get_codebase(Object) - 类 org.omg.CORBA_2_3.portable.Delegate 中的方法
返回提供的对象引用的代码基。
get_compact_typecode() - 类 org.omg.CORBA.TypeCode 中的方法
剔除所有可选名称和成员名称字段，但使所有别名 typecode 保留原样。
get_current() - 类 org.omg.CORBA.ORB 中的方法
已过时。 使用 resolve_initial_references。
get_default_context() - 类 org.omg.CORBA.ORB 中的方法
获取默认 Context 对象。
get_discriminator() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前鉴别符值。
get_discriminator() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回当前鉴别符值。
get_domain_managers(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
检索此对象的 DomainManager。
get_domain_policy(int) - 接口 org.omg.CORBA.DomainManagerOperations 中的方法
此方法为此域中的对象返回指定类型的策略。
get_double() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 double 值。
get_double() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 析取 double 值。
get_double() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 double 值。
get_double() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 double 值。
get_dyn_any() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
析取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynStructStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 类 org.omg.DynamicAny._DynValueStub 中的方法
提取由此 DynAny 表示的 Any 中包含的 Any 值，并将其包装在新 DynAny 中返回。
get_dyn_any() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
提取由此 DynAny 表示的 Any 中所包含的 Any 值，并将其包装在新 DynAny 中返回。
get_effective_component(int) - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回为此请求选择的配置文件中带有给定 ID 的 IOP.TaggedComponent。
get_effective_components(int) - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回为此请求选择的配置文件中具有给定 ID 的带标记组件所组成的数组。
get_effective_policy(int) - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
允许 ORB 服务实现确定对将构造的 IOR 有效的特定类型服务器端策略。
get_elements() - 接口 org.omg.CORBA.DynArray 中的方法
已过时。 返回此数组所有元素的值。
get_elements() - 接口 org.omg.CORBA.DynSequence 中的方法
已过时。 返回此 sequence 中每个元素的值。
get_elements() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
返回 DynArray 的元素。
get_elements() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回序列的元素。
get_elements() - 接口 org.omg.DynamicAny.DynArrayOperations 中的方法
返回 DynArray 的元素。
get_elements() - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
返回序列的元素。
get_elements_as_dyn_any() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
以 DynAny 的形式返回 DynArray 的元素。
get_elements_as_dyn_any() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回表示序列的元素的 DynAny。
get_elements_as_dyn_any() - 接口 org.omg.DynamicAny.DynArrayOperations 中的方法
以 DynAny 的形式返回 DynArray 的元素。
get_elements_as_dyn_any() - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
返回表示序列元素的 DynAny。
get_float() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 float 值。
get_float() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 float 值。
get_float() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 float 值。
get_id() - 接口 org.omg.CORBA.portable.BoxedValueHelper 中的方法

get_id() - 类 org.omg.CORBA.StringValueHelper 中的方法

get_id() - 类 org.omg.CORBA.WStringValueHelper 中的方法

get_interface_def(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回一个所提供对象引用的 InterfaceDef。
get_interface_def(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此操作返回接口 Repository 中的一个对象，该对象提供可能对编程有用的类型信息。
get_length() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回当前序列的长度。
get_length() - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
返回序列的当前长度。
get_long() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 int 值。
get_long() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 析取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 integer 值。
get_long() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 integer 值。
get_longlong() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 long 值。
get_longlong() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 long 值。
get_members() - 接口 org.omg.CORBA.DynStruct 中的方法
已过时。 返回包含所有已存储 struct 成员的数组。
get_members() - 接口 org.omg.CORBA.DynValue 中的方法
已过时。 返回一个数组，它包含存储在此 DynValue 中 value 对象的所有成员。
get_members() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
get_members() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
get_members() - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
返回一个 NameValuePair 序列，这些 NameValuePair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
get_members() - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
返回一个 NameValuePair 序列，这些 NameValuePair 描述该值类型的每个成员的名称和值。
get_members_as_dyn_any() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
get_members_as_dyn_any() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
get_members_as_dyn_any() - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述与 DynStruct 对象关联的结构数据中每个成员的名称和值。
get_members_as_dyn_any() - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
返回一个 NameDynAnyPair 序列，这些 NameDynAnyPair 描述该值类型中每个成员的名称和值。
get_next_response() - 类 org.omg.CORBA.ORB 中的方法
获取已接收到响应的下一个 Request 实例。
get_object_id() - 接口 org.omg.PortableServer.CurrentOperations 中的方法
返回一个 ObjectId，标识此方法在其上下文中调用的对象。
get_octet() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 析取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 析取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 byte 值。
get_octet() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 byte 值。
get_POA() - 接口 org.omg.PortableServer.CurrentOperations 中的方法
返回对 POA 的引用，该 POA 实现此方法在其上下文中调用的对象。
get_policy(Object, int) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回应用于此对象的指定类型的 Policy 对象。
get_primitive_tc(TCKind) - 类 org.omg.CORBA.ORB 中的方法
检索表示给定基本 IDL 类型的 TypeCode 对象。
get_reference() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.Other。
get_reference() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 析取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reference() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取对 CORBA 对象的引用。
get_reply_service_context(int) - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回具有给定 ID 的与应答关联的服务上下文复本。
get_request_policy(int) - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回此操作实行的给定策略。
get_request_service_context(int) - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回具有给定 ID 的与请求关联的服务上下文复本。
get_response() - 类 org.omg.CORBA.Request 中的方法
允许用户访问之前使用 send_deferred 方法所触发调用的响应。
get_servant() - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作返回与 POA 关联的默认 servant。
get_servant_manager() - 接口 org.omg.PortableServer.POAOperations 中的方法
如果 POA 的 ServantRetentionPolicy 为 RETAIN，则 ServantManager 参数 (imgr) 应该支持 ServantActivator 接口。
get_server_policy(int) - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回此操作实行的具有给定策略类型的策略。
get_service_information(short, ServiceInformationHolder) - 类 org.omg.CORBA.ORB 中的方法
用来获取有关受此 ORB 支持的 CORBA 资源和服务的信息。
get_short() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 short 值。
get_short() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 析取 short 值。
get_short() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 short 值。
get_short() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 short 值。
get_slot(int) - 接口 org.omg.PortableInterceptor.CurrentOperations 中的方法
检索应用程序通过 get_slot 在 PICurrent 中设置的槽数据。
get_slot(int) - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回请求域内 PortableInterceptor.Current 给定槽 (slot) 中的数据。
get_state() - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作返回 POA 管理器的状态。
get_string() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 String。
get_string() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 string 值。
get_string() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 string 值。
get_typecode() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 org.omg.CORBA.TypeCode。
get_typecode() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 析取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_typecode() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 TypeCode 对象。
get_ulong() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 int 值。
get_ulong() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 integer 值。
get_ulong() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 integer 值。
get_ulonglong() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 long 值。
get_ulonglong() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 long 值。
get_ushort() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 short 值。
get_ushort() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 short 值。
get_val() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 java.io.Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 Serializable 对象。
get_val() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 Serializable 对象。
get_value() - 接口 org.omg.CORBA.DynFixed 中的方法
已过时。 返回此 DynFixed 对象表示的 fixed 类型的值。
get_value() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
返回 DynFixed 的值。
get_value() - 接口 org.omg.DynamicAny.DynFixedOperations 中的方法
返回 DynFixed 的值。
get_value_def(String) - 类 org.omg.CORBA_2_3.ORB 中的方法

get_values(String, int, String) - 类 org.omg.CORBA.Context 中的方法
检索 name 字段与给定名称或名称模式匹配的 NamedValue 对象。
get_wchar() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 char 值。
get_wchar() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 long 值。
get_wchar() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 long 值。
get_wstring() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 检索此 DynAny 对象中包含的 String。
get_wstring() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从此 DynAny 中提取 string 值。
get_wstring() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从此 DynAny 中提取 string 值。
getA() - 类 java.security.spec.EllipticCurve 中的方法
返回椭圆曲线的第一个系数 a。
getAbsoluteFile() - 类 java.io.File 中的方法
返回此抽象路径名的绝对路径名形式。
getAbsolutePath() - 类 java.io.File 中的方法
返回此抽象路径名的绝对路径名字符串。
getAccelerationPriority() - 类 java.awt.Image 中的方法
返回加速优先级提示的当前值。
getAccelerator() - 类 javax.swing.JMenuItem 中的方法
返回作为菜单项的加速器的 KeyStroke。
getAcceleratorForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的加速器前景颜色。
getAcceleratorForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回加速器前景色。
getAcceleratorSelectedForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的加速器选中前景颜色。
getAcceleratorSelectedForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回加速器选中前景色。
getAcceleratorString() - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法

getAcceptAllFileFilter() - 类 javax.swing.JFileChooser 中的方法
返回 AcceptAll 文件过滤器。
getAcceptAllFileFilter(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
返回默认接受所有文件过滤器
getAcceptAllFileFilter(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法

getAcceptAllFileFilter(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAcceptAllFileFilter 方法。
getAcceptedIssuers() - 接口 javax.net.ssl.X509TrustManager 中的方法
返回受验证同位体信任的认证中心的数组。
getAcceptorAddress() - 类 org.ietf.jgss.ChannelBinding 中的方法
获得此通道绑定的接受端的地址。
getAccessibleAction() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取与此对象相关的 AccessibleAction。
getAccessibleAction() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取与此对象相关的 AccessibleAction。
getAccessibleAction() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取与此对象相关的 AccessibleAction。
getAccessibleAction() - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
获取与此对象相关的 AccessibleAction。
getAccessibleAction() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
获取与此对象关联的 AccessibleAction。
getAccessibleAction() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获取与此对象关联的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
获取与此对象关联的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleAction() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取与此对象关联的可支持一个或多个操作的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleAction（如果存在）。
getAccessibleAction() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleAction。
getAccessibleAction() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleAction() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法

getAccessibleActionAnchor(int) - 类 javax.accessibility.AccessibleHyperlink 中的方法
返回表示适合于该链接的链接锚点的对象。
getAccessibleActionAnchor(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
返回表示适合于该链接的链接锚点的对象。
getAccessibleActionCount() - 类 java.awt.Button.AccessibleAWTButton 中的方法
返回此对象中可用的 Action 的数目。
getAccessibleActionCount() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
返回此对象中可用的 Action 的数目。
getAccessibleActionCount() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
返回此对象中可用的 Actions 的数目。
getAccessibleActionCount() - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
返回此对象中可用的可访问操作的数目，如果大于 1，则第一个作为该对象的“默认”操作。
getAccessibleActionCount() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
返回此对象中可用的操作数。
getAccessibleActionCount() - 接口 javax.accessibility.AccessibleAction 中的方法
返回此对象中可用的可访问动作数。
getAccessibleActionCount() - 类 javax.accessibility.AccessibleHyperlink 中的方法
返回此 Link 中可用的可访问动作数（如果有多个），不认为第一个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。
getAccessibleActionCount() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回此对象中可用 Action 的数量。
getAccessibleActionCount() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回此对象中可用 Action 的数量。
getAccessibleActionCount() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
返回此 Link 中的可访问操作数目（如果有多个），不认为首个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。
getAccessibleActionCount() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回此对象中可访问的操作数，如果多于一个，则第一个就被认为是此对象的“默认”操作。
getAccessibleActionCount() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回此树节点中可用的可访问操作数。
getAccessibleActionCount() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回此对象中可用的可访问操作的数目，如果多于一个，则第一个视为该对象的“默认”操作。
getAccessibleActionDescription(int) - 类 java.awt.Button.AccessibleAWTButton 中的方法
返回对象指定操作的描述。
getAccessibleActionDescription(int) - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
返回对象指定操作的描述。
getAccessibleActionDescription(int) - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
返回对象指定操作的描述。
getAccessibleActionDescription(int) - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
返回对象指定操作的描述。
getAccessibleActionDescription(int) - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
返回对该对象指定操作的描述。
getAccessibleActionDescription(int) - 接口 javax.accessibility.AccessibleAction 中的方法
返回对对象指定动作的描述。
getAccessibleActionDescription(int) - 类 javax.accessibility.AccessibleHyperlink 中的方法
返回此特定链接动作的 String 描述。
getAccessibleActionDescription(int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回对该对象的指定操作的描述。
getAccessibleActionDescription(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回该对象的指定操作的描述。
getAccessibleActionDescription(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
返回此特定链接操作的 String 描述。
getAccessibleActionDescription(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回此对象指定操作的描述。
getAccessibleActionDescription(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回该树节点的指定操作的描述。
getAccessibleActionDescription(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回对该对象的指定操作的描述。
getAccessibleActionObject(int) - 类 javax.accessibility.AccessibleHyperlink 中的方法
返回表示适合于该链接的链接动作的对象。
getAccessibleActionObject(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
返回表示该链接的 URL 对象。
getAccessibleAt(Point) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回包含在局部坐标 Point 上的 Accessible 子对象（如果存在这样的对象）。
getAccessibleAt(Point) - 类 java.awt.Container.AccessibleAWTContainer 中的方法
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
getAccessibleAt(Point) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。
getAccessibleAt(Point) - 类 java.awt.List.AccessibleAWTList 中的方法
返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
getAccessibleAt(Point) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回本地坐标 Point 包含的 Accessible 子对象（如果存在）。
getAccessibleAt(Point) - 接口 javax.accessibility.AccessibleComponent 中的方法
返回本地坐标 Point 包含的可访问子级（如果存在）。
getAccessibleAt(int, int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中指定行和列处的 Accessible。
getAccessibleAt(Point) - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 中的方法
返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
getAccessibleAt(Point) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleAt(Point) - 类 javax.swing.JList.AccessibleJList 中的方法
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
getAccessibleAt(Point) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
getAccessibleAt(Point) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法

getAccessibleAt(Point) - 类 javax.swing.JTable.AccessibleJTable 中的方法
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回 Accessible 子级。
getAccessibleAt(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法

getAccessibleAt(Point) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
getAccessibleAt(Point) - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
getAccessibleAt(Component, Point) - 类 javax.swing.SwingUtilities 中的静态方法
如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
getAccessibleAt(Point) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleAt(Point) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 中的方法
返回本地坐标 Point 包含的可访问子级（如果存在）。
getAccessibleCaption() - 接口 javax.accessibility.AccessibleTable 中的方法
返回此表的标题。
getAccessibleCaption() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回此表的标题。
getAccessibleChild(int) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回该对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 java.awt.Container.AccessibleAWTContainer 中的方法
返回对象的第 n 个 Accessible 子容器。
getAccessibleChild(int) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 java.awt.List.AccessibleAWTList 中的方法
返回对象的第 n 个可访问子级。
getAccessibleChild(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回该对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 javax.accessibility.AccessibleContext 中的方法
返回该对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
返回对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回对象的第 n 个可访问子级。
getAccessibleChild(int) - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回对象的第 n 个可访问子级。
getAccessibleChild(int) - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleChild(int) - 类 javax.swing.JList.AccessibleJList 中的方法
返回对象的第 n 个可访问子级。
getAccessibleChild(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
返回对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JRootPane.AccessibleJRootPane 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
返回对象的指定 Accessible 子级。
getAccessibleChild(int) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
返回此对象的指定的 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回该对象的第 n 个 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回对象的指定 Accessible 子对象。
getAccessibleChild(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回对象的第 n 个可访问子对象。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法

getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.ComponentUI 中的方法
返回对象的第 i 个 Accessible 子对象。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(JComponent, int) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
getAccessibleChild(int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回该对象指定的 Accessible 子对象。
getAccessibleChild(Component, int) - 类 javax.swing.SwingUtilities 中的静态方法
返回对象的第 n 个可访问子对象。
getAccessibleChild(int) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleChild(int) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 中的方法
返回该对象的第 n 个可访问子对象。
getAccessibleChildrenCount() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回此对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 java.awt.Container.AccessibleAWTContainer 中的方法
返回对象中可访问的子容器数。
getAccessibleChildrenCount() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 java.awt.List.AccessibleAWTList 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回该对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.accessibility.AccessibleContext 中的方法
返回该对象的可访问子级数。
getAccessibleChildrenCount() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
返回对象中 accessible 子对象的数量。
getAccessibleChildrenCount() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount() - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleChildrenCount() - 类 javax.swing.JList.AccessibleJList 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
返回该对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.swing.JRootPane.AccessibleJRootPane 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回对象的可访问子级数。
getAccessibleChildrenCount() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
返回此对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回该对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回对象中的可访问子对象数。
getAccessibleChildrenCount() - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回此 JTree 的顶层子节点数。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法

getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回对象中的可访问子对象数。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getAccessibleChildrenCount 方法。
getAccessibleChildrenCount() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回对象中可访问的子级数。
getAccessibleChildrenCount(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回对象中可访问的子对象数。
getAccessibleChildrenCount() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleChildrenCount() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 中的方法
返回该对象中可访问的子对象数。
getAccessibleColumn(int) - 接口 javax.accessibility.AccessibleExtendedTable 中的方法
返回表中一个索引的列号。
getAccessibleColumn(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中一个索引的列数。
getAccessibleColumnAtIndex(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回在表中给定的索引位置的列。
getAccessibleColumnCount() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中的列数。
getAccessibleColumnCount() - 类 javax.swing.JTable.AccessibleJTable 中的方法

getAccessibleColumnDescription(int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中指定列的描述文本。
getAccessibleColumnDescription(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回对表中指定列的描述。
getAccessibleColumnExtentAt(int, int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中指定行和列处 Accessible 占用的列数。
getAccessibleColumnExtentAt(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回 Accessible 在给定的 (row, column) 占用的列数。
getAccessibleColumnHeader() - 接口 javax.accessibility.AccessibleTable 中的方法
返回以 AccessibleTable 表示的列标题。
getAccessibleColumnHeader() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回以 AccessibleTable 表示的列标题。
getAccessibleComponent() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取与此对象相关的 AccessibleComponent（如果存在一个这样的组件）。
getAccessibleComponent() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取与此对象关联的 AccessibleComponent（如果存在）。
getAccessibleComponent() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的 AccessibleComponent，它具有图形表示形式。
getAccessibleComponent() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
获取与此对象关联的 AccessibleComponent。
getAccessibleComponent() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleComponent（如果存在）。
getAccessibleComponent() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleComponent。
getAccessibleComponent() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取与此对象关联的 AccessibleComponent，它具有图形表示形式。
getAccessibleComponent() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
获取与此对象关联的 AccessibleComponent。
getAccessibleContext() - 类 java.applet.Applet 中的方法
获取与此 Applet 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Button 中的方法
获取与此 Button 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Canvas 中的方法
获取与此 Canvas 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Checkbox 中的方法
获取与此 Checkbox 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.CheckboxMenuItem 中的方法
获取与此 CheckboxMenuItem 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Choice 中的方法
获取与此 Choice 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Component 中的方法
获取与此 Component 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Dialog 中的方法
获取与此 Dialog 有关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Frame 中的方法
获取与此窗体有关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Label 中的方法
获取与此标签相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的 AccessibleContext。
getAccessibleContext() - 类 java.awt.List 中的方法
获取与此 List 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Menu 中的方法
获取与此菜单关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.MenuBar 中的方法
获取与此菜单栏关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.MenuComponent 中的方法
获取与此 MenuComponent 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.MenuItem 中的方法
获取与此菜单项关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Panel 中的方法
获取与 Panel 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.PopupMenu 中的方法
获取与此 PopupMenu 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Scrollbar 中的方法
获取与此 Scrollbar 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.ScrollPane 中的方法
获取与此 ScrollPane 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.TextArea 中的方法
返回与此 TextArea 相关的 AccessibleContext。
getAccessibleContext() - 类 java.awt.TextComponent 中的方法
获取与此 TextComponent 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.TextField 中的方法
获取与此 TextField 关联的 AccessibleContext。
getAccessibleContext() - 类 java.awt.Window 中的方法
获取与此窗口关联的 AccessibleContext。
getAccessibleContext() - 接口 javax.accessibility.Accessible 中的方法
返回与此对象关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.Box.Filler 中的方法
获取与此 Box.Filler 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.Box 中的方法
获取与此 Box 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.CellRendererPane 中的方法
获取与此 CellRendererPane 相关的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.ImageIcon 中的方法
获得与此 ImageIcon 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JApplet 中的方法
获取与此 JApplet 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JButton 中的方法
获取与此 JButton 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JCheckBox 中的方法
获取与此 JCheckBox 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JCheckBoxMenuItem 中的方法
获得与此 JCheckBoxMenuItem 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JColorChooser 中的方法
获取与此 JColorChooser 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JComboBox 中的方法
获取与此 JComboBox 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JComponent 中的方法
返回与此 JComponent 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JDesktopPane 中的方法
获取与此 JDesktopPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JDialog 中的方法
获取与此 JDialog 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JEditorPane 中的方法
获取与此 JEditorPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JFileChooser 中的方法
获取与此 JFileChooser 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JFrame 中的方法
获得与此 JFrame 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JInternalFrame 中的方法
获得与此 JInternalFrame 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
获取与此 JDesktopIcon 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JLabel 中的方法
获得此对象的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JLayeredPane 中的方法
获得与此 JLayeredPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
获取此对象的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JList 中的方法
获取与此 JList 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JMenu 中的方法
获取与此 JMenu 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JMenuBar 中的方法
获取与此 JMenuBar 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JMenuItem 中的方法
返回与此 JMenuItem 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JOptionPane 中的方法
返回与此 JOptionPane 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JPanel 中的方法
获取与此 JPanel 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JPasswordField 中的方法
返回与此 JPasswordField 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JPopupMenu 中的方法
获取与此 JPopupMenu 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JProgressBar 中的方法
获得与此 JProgressBar 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JRadioButton 中的方法
获取与此 JRadioButton 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JRadioButtonMenuItem 中的方法
获取与此 JRadioButtonMenuItem 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JRootPane 中的方法
获取与此 JRootPane 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JScrollBar 中的方法
获取与此 JScrollBar 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JScrollPane 中的方法
获取与此 JScrollPane 相关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JSeparator 中的方法
获取与此 JSeparator 相关的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JSlider 中的方法
获取与此 JSlider 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JSpinner 中的方法
获取此 JSpinner 的 AccessibleContext
getAccessibleContext() - 类 javax.swing.JSplitPane 中的方法
获取与 JSplitPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTabbedPane 中的方法
获取与此 JTabbedPane 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此组件关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTable 中的方法
获取与此 JTable 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTextArea 中的方法
获取与此 JTextArea 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTextField 中的方法
获取与此 JTextField 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JToggleButton 中的方法
获取与此 JToggleButton 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JToolBar 中的方法
获取与此 JToolBar 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JToolTip 中的方法
获取与此 JToolTip 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此树节点关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JTree 中的方法
获取与此 JTree 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JViewport 中的方法
获取与此 JViewport 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.JWindow 中的方法
获取与此 JWindow 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
获取与此 BasicComboPopup 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.ProgressMonitor 中的方法
获得 ProgressMonitor 的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
获取与此对象关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.table.JTableHeader 中的方法
获取与此 JTableHeader 关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
返回与此编辑器工具包关联的 AccessibleContext。
getAccessibleContext() - 类 javax.swing.text.JTextComponent 中的方法
获取与此 JTextComponent 关联的 AccessibleContext。
getAccessibleDescription() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的可访问描述。
getAccessibleDescription() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的可访问的描述。
getAccessibleDescription() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的 accessibleDescription 属性。
getAccessibleDescription() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
获取此对象的可访问描述。
getAccessibleDescription() - 类 javax.swing.JEditorPane.AccessibleJEditorPane 中的方法
获得此对象的 accessibleDescription 属性。
getAccessibleDescription() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleDescription() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的可访问的描述。
getAccessibleDescription() - 类 javax.swing.JToolTip.AccessibleJToolTip 中的方法
获取此对象的可访问的描述。
getAccessibleDescription() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的可访问的描述。
getAccessibleDescription() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取对象的 accessibleDescription 属性。
getAccessibleDescription() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleEditableText() - 类 javax.accessibility.AccessibleContext 中的方法
获取与在显示器上显示可编辑文本的此对象关联的 AccessibleEditableText。
getAccessibleEditableText() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回此文本组件的 AccessibleEditableText 接口。
getAccessibleIcon() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的具有一个或多个相关图标的 AccessibleIcons
getAccessibleIcon() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。
getAccessibleIcon() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。
getAccessibleIcon() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
返回元素渲染器的图标，作为 AccessibleIcon 数组的唯一项；如果渲染器组件不包含任何图标，则返回一个 null 数组。
getAccessibleIconDescription() - 接口 javax.accessibility.AccessibleIcon 中的方法
获取此图标的描述。
getAccessibleIconDescription() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此图标的描述。
getAccessibleIconHeight() - 接口 javax.accessibility.AccessibleIcon 中的方法
获取图标的高度。
getAccessibleIconHeight() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得图标的高度。
getAccessibleIconWidth() - 接口 javax.accessibility.AccessibleIcon 中的方法
获取图标的宽度。
getAccessibleIconWidth() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得图标的宽度。
getAccessibleIndex(int, int) - 接口 javax.accessibility.AccessibleExtendedTable 中的方法

getAccessibleIndex(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中在某一行和某一列的索引。
getAccessibleIndexAt(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中在给定的 (row, column) 位置的索引。
getAccessibleIndexInParent() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象在其可访问父对象中的索引。
getAccessibleIndexInParent() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的可访问父级中基于 0 的索引。
getAccessibleIndexInParent() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象在其可访问父级中的基于零的索引。
getAccessibleIndexInParent() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleIndexInParent() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象在其可访问父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.JTree.AccessibleJTree 中的方法
获取此对象在其可访问父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent(Component) - 类 javax.swing.SwingUtilities 中的静态方法
获取此对象在其可访问的父对象中的索引。
getAccessibleIndexInParent() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleKeyBinding() - 接口 javax.accessibility.AccessibleExtendedComponent 中的方法
返回与此对象关联的键绑定。
getAccessibleKeyBinding(int) - 接口 javax.accessibility.AccessibleKeyBinding 中的方法
返回此对象的键绑定。
getAccessibleKeyBinding() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回与此对象有关的键绑定。
getAccessibleKeyBinding() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回与此对象关联的键绑定
getAccessibleKeyBinding() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回与此对象关联的键绑定
getAccessibleKeyBindingCount() - 接口 javax.accessibility.AccessibleKeyBinding 中的方法
返回此对象的键绑定数。
getAccessibleName() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 java.awt.Label.AccessibleAWTLabel 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的可访问的名称。
getAccessibleName() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的 accessibleName 属性。
getAccessibleName() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JDialog.AccessibleJDialog 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JFrame.AccessibleJFrame 中的方法
获得此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleName() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
返回此对象的可访问名称；如果没有可访问名称，则返回 null。
getAccessibleName() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的可访问的名称。
getAccessibleName() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的可访问名称。
getAccessibleName() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象的 accessibleName 属性。
getAccessibleName() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleParent() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的 Accessible 父对象。
getAccessibleParent() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象的 Accessible 父对象。
getAccessibleRelationSet() - 类 javax.accessibility.AccessibleContext 中的方法
获取与某个对象关联的 AccessibleRelationSet
getAccessibleRelationSet() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获得与此对象关联的 AccessibleRelationSet（如果存在）。
getAccessibleRelationSet() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
获取与此对象关联的 AccessibleRelationSet（如果存在）。
getAccessibleRole() - 类 java.applet.Applet.AccessibleApplet 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Canvas.AccessibleAWTCanvas 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Choice.AccessibleAWTChoice 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Dialog.AccessibleAWTDialog 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Frame.AccessibleAWTFrame 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Label.AccessibleAWTLabel 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.List.AccessibleAWTList 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Menu.AccessibleAWTMenu 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.MenuBar.AccessibleAWTMenuBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Panel.AccessibleAWTPanel 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.PopupMenu.AccessibleAWTPopupMenu 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.ScrollPane.AccessibleAWTScrollPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
获取此对象的职责。
getAccessibleRole() - 类 java.awt.Window.AccessibleAWTWindow 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.Box.AccessibleBox 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.Box.Filler.AccessibleBoxFiller 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.CellRendererPane.AccessibleCellRendererPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此对象的职责。
getAccessibleRole() - 类 javax.swing.JButton.AccessibleJButton 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JCheckBox.AccessibleJCheckBox 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JColorChooser.AccessibleJColorChooser 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JDesktopPane.AccessibleJDesktopPane 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JFileChooser.AccessibleJFileChooser 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JLayeredPane.AccessibleJLayeredPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleRole() - 类 javax.swing.JList.AccessibleJList 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JMenuItem.AccessibleJMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JOptionPane.AccessibleJOptionPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JPanel.AccessibleJPanel 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JPopupMenu.AccessibleJPopupMenu 中的方法
获得此对象的职责。
getAccessibleRole() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JRadioButton.AccessibleJRadioButton 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JRootPane.AccessibleJRootPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JSeparator.AccessibleJSeparator 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JTable.AccessibleJTable 中的方法
获取此对象的功能。
getAccessibleRole() - 类 javax.swing.JToggleButton.AccessibleJToggleButton 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JToolBar.AccessibleJToolBar 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JToolTip.AccessibleJToolTip 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JTree.AccessibleJTree 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.JViewport.AccessibleJViewport 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleRole() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 中的方法
获取此对象的职责。
getAccessibleRole() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
获取此对象的职责。
getAccessibleRow(int) - 接口 javax.accessibility.AccessibleExtendedTable 中的方法
返回表中一个索引的行号。
getAccessibleRow(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中一个索引的行数。
getAccessibleRowAtIndex(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中在一个给定的索引位置的行。
getAccessibleRowCount() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中的行数。
getAccessibleRowCount() - 类 javax.swing.JTable.AccessibleJTable 中的方法

getAccessibleRowDescription(int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回对表中指定行的描述。
getAccessibleRowDescription(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回对表中指定行的描述。
getAccessibleRowExtentAt(int, int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中指定行和列处的 Accessible 所占用的行数。
getAccessibleRowExtentAt(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回 Accessible 在表中指定行和列占用的行数。
getAccessibleRowHeader() - 接口 javax.accessibility.AccessibleTable 中的方法
返回以 AccessibleTable 表示的行标题。
getAccessibleRowHeader() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回以 AccessibleTable 表示的行标题。
getAccessibleSelection() - 类 java.awt.List.AccessibleAWTList 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 java.awt.List.AccessibleAWTList 中的方法
返回表示对象中指定选项的 Accessible。
getAccessibleSelection() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子对象。
getAccessibleSelection(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回 Accessible，它表示该对象中指定的已选择的子对象。
getAccessibleSelection() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。
getAccessibleSelection(int) - 接口 javax.accessibility.AccessibleSelection 中的方法
返回表示指定的所选对象子级的 Accessible。
getAccessibleSelection() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回表示弹出对象中指定选择子级的 Accessible。
getAccessibleSelection() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleSelection() - 类 javax.swing.JList.AccessibleJList 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JList.AccessibleJList 中的方法
返回表示对象中指定选项的 Accessible。
getAccessibleSelection() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
返回当前选择的子菜单（如果选择了），否则返回 null（只能选择一项并且只能选择子菜单，除非菜单项没有保持选中状态）。
getAccessibleSelection() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
返回当前选择的菜单（如果选择了一个）；否则返回 null。
getAccessibleSelection() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
获取与此对象关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法

getAccessibleSelection() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleSelection（如果存在）。
getAccessibleSelection() - 类 javax.swing.JTable.AccessibleJTable 中的方法
获取与此对象关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回 Accessible，它表示该对象中指定的已选择的子对象。
getAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleSelection（如果存在）。
getAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回表示对象中指定选择项的 Accessible。
getAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree 中的方法
获取与此对象相关联的 AccessibleSelection。
getAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回表示对象中指定选择项的 Accessible。
getAccessibleSelection() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleSelectionCount() - 类 java.awt.List.AccessibleAWTList 中的方法
返回当前选择的项数。
getAccessibleSelectionCount() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回当前选择的 Accessible 子对象数。
getAccessibleSelectionCount() - 接口 javax.accessibility.AccessibleSelection 中的方法
返回当前选中的 Accessible 子级数。
getAccessibleSelectionCount() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
返回当前选定的 Accessible 子对象数。
getAccessibleSelectionCount() - 类 javax.swing.JList.AccessibleJList 中的方法
返回当前选择的项数。
getAccessibleSelectionCount() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
如果当前在此菜单中选择了子菜单，则返回 1。
getAccessibleSelectionCount() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
如果当前在此菜单栏中选择了菜单，则返回 1。
getAccessibleSelectionCount() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法

getAccessibleSelectionCount() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回当前选择的 Accessible 子对象数。
getAccessibleSelectionCount() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
返回当前选中的项数。
getAccessibleSelectionCount() - 类 javax.swing.JTree.AccessibleJTree 中的方法
返回当前选中的项数。
getAccessibleStateSet() - 类 java.applet.Applet.AccessibleApplet 中的方法
获得此对象的状态。
getAccessibleStateSet() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 java.awt.Dialog.AccessibleAWTDialog 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 java.awt.Frame.AccessibleAWTFrame 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.List.AccessibleAWTList 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.TextArea.AccessibleAWTTextArea 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
获取 TextComponent 的状态设置。
getAccessibleStateSet() - 类 java.awt.TextField.AccessibleAWTTextField 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 java.awt.Window.AccessibleAWTWindow 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.accessibility.AccessibleContext 中的方法
获取此对象的状态集合。
getAccessibleStateSet() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获得此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
获得此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JDialog.AccessibleJDialog 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JEditorPane.AccessibleJEditorPane 中的方法
获取此对象的状态集。
getAccessibleStateSet() - 类 javax.swing.JFrame.AccessibleJFrame 中的方法
获得此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleStateSet() - 类 javax.swing.JList.AccessibleJList 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
获得此对象的可访问性状态设置。
getAccessibleStateSet() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的状态集。
getAccessibleStateSet() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的状态集。
getAccessibleStateSet() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JTextArea.AccessibleJTextArea 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JTextField.AccessibleJTextField 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.JToolBar.AccessibleJToolBar 中的方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的状态设置。
getAccessibleStateSet() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取此对象的状态集。
getAccessibleStateSet(Component) - 类 javax.swing.SwingUtilities 中的静态方法
获取此对象的状态。
getAccessibleStateSet() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleStateSet() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
获取 JTextComponent 的状态设置。
getAccessibleSummary() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表的摘要描述。
getAccessibleSummary() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表的摘要描述。
getAccessibleTable() - 类 javax.accessibility.AccessibleContext 中的方法
获取与某个对象关联的 AccessibleTable
getAccessibleTable() - 类 javax.swing.JTable.AccessibleJTable 中的方法
获取与此对象关联的 AccessibleTable。
getAccessibleText() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
获取与此对象相关的 AccessibleText。
getAccessibleText() - 类 javax.accessibility.AccessibleContext 中的方法
获取与在显示器上显示文本的此对象关联的 AccessibleText。
getAccessibleText() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法

getAccessibleText() - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 中的方法

getAccessibleText() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法

getAccessibleText() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleText() - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
获取 JPasswordField 的 AccessibleText。
getAccessibleText() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取与此对象相关联的可在显示器上表示的 AccessibleText。
getAccessibleText() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleText （如果存在）。
getAccessibleText() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleText（如果存在）。
getAccessibleText() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取与在显示器上显示文本的此对象关联的 AccessibleText。
getAccessibleText() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessibleText() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
获取与此对象关联的 AccessibleText。
getAccessibleValue() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取与此对象相关的 AccessibleValue。
getAccessibleValue() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取与此对象相关的 AccessibleValue。
getAccessibleValue() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取与此对象相关的 AccessibleValue。
getAccessibleValue() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获得与此对象相关的 AccessibleValue。
getAccessibleValue() - 类 javax.accessibility.AccessibleContext 中的方法
获取与此对象关联的支持 Numerical 值的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getAccessibleValue() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获得与此对象相关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取与此对象关联的 AccessibleValue。
getAccessibleValue() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取与此对象关联的 AccessibleValue（如果存在）。
getAccessibleValue() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取与此对象关联的 AccessibleValue（如果存在）。
getAccessibleValue() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取与此对象关联的 AccessibleValue，该对象支持数值。
getAccessibleValue() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getAccessLevel() - 类 javax.tools.ForwardingJavaFileObject 中的方法

getAccessLevel() - 接口 javax.tools.JavaFileObject 中的方法
提供有关此文件对象表示的类的访问级别的提示。
getAccessLevel() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现返回 null。
getAccessory() - 类 javax.swing.JFileChooser 中的方法
返回 accessory 组件。
getAccessoryPanel() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getACHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
返回最近一次调用 setDecodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getACHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回最近一次调用 setEncodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getAction() - 类 java.beans.EventHandler 中的方法
返回此事件处理程序将设置的目标的可写属性名称，或者此事件处理程序将在目标上调用的方法名称。
getAction() - 类 javax.swing.AbstractButton 中的方法
返回当前为此 ActionEvent 源设置的 Action，如果没有设置任何 Action，则返回 null。
getAction() - 类 javax.swing.JComboBox 中的方法
返回此 ActionEvent 源当前设置的 Action，如果没有设置任何 Action，则返回 null。
getAction() - 类 javax.swing.JTextField 中的方法
返回此 ActionEvent 源当前设置的 Action，如果没有设置 Action 则返回 null。
getAction(KeyStroke) - 接口 javax.swing.text.Keymap 中的方法
获取适合于给定符号事件序列的操作。
getActionCommand() - 类 java.awt.Button 中的方法
返回此按钮激发的动作事件的命令名称。
getActionCommand() - 类 java.awt.event.ActionEvent 中的方法
返回与此动作相关的命令字符串。
getActionCommand() - 类 java.awt.MenuItem 中的方法
获取由此菜单项引发的动作事件的命令名。
getActionCommand() - 类 java.awt.TrayIcon 中的方法
返回由此托盘图标触发的动作事件的命令名。
getActionCommand() - 类 javax.swing.AbstractButton 中的方法
返回此按钮的动作命令。
getActionCommand() - 接口 javax.swing.ButtonModel 中的方法
返回该按钮的动作命令字符串。
getActionCommand() - 类 javax.swing.DefaultButtonModel 中的方法
返回该按钮的动作命令字符串。
getActionCommand() - 类 javax.swing.JComboBox 中的方法
返回发送到动作侦听器的事件中包括的动作命令。
getActionCommand() - 类 javax.swing.Timer 中的方法
返回将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。
getActionForKeyStroke(KeyStroke) - 类 javax.swing.JComponent 中的方法
返回执行针对给定键击而注册的操作的对象。
getActionListeners() - 类 java.awt.Button 中的方法
返回在此按钮上注册的所有动作侦听器的一个数组。
getActionListeners() - 类 java.awt.List 中的方法
返回已在此列表上注册的所有动作侦听器的数组。
getActionListeners() - 类 java.awt.MenuItem 中的方法
返回在此菜单项上注册的所有动作侦听器组成的数组。
getActionListeners() - 类 java.awt.TextField 中的方法
返回此文本字段上已注册的所有操作侦听器的数组。
getActionListeners() - 类 java.awt.TrayIcon 中的方法
返回在已此 TrayIcon 上注册的所有动作侦听器的数组。
getActionListeners() - 类 javax.swing.AbstractButton 中的方法
返回使用 addActionListener() 添加到此 AbstractButton 的所有 ActionListener 组成的数组。
getActionListeners() - 类 javax.swing.DefaultButtonModel 中的方法
返回此 DefaultButtonModel 上所有已注册的操作侦听器组成的数组。
getActionListeners() - 类 javax.swing.JComboBox 中的方法
返回使用 addActionListener() 添加到此 JComboBox 的所有 ActionListener 组成的数组。
getActionListeners() - 类 javax.swing.JFileChooser 中的方法
返回在此文件选择器上注册的所有操作侦听器的数组。
getActionListeners() - 类 javax.swing.JTextField 中的方法
返回通过 addActionListener() 添加到此 JTextField 中的所有 ActionListener 的数组。
getActionListeners() - 类 javax.swing.Timer 中的方法
返回已在此计时器上注册的所有动作侦听器所组成的数组。
getActionMap() - 类 javax.swing.JComponent 中的方法
返回用于确定为特定 KeyStroke 绑定触发何种 Action 的 ActionMap。
getActionMap() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getActions() - 类 java.io.FilePermission 中的方法
返回操作的“规范化字符串表示形式”。
getActions() - 类 java.net.SocketPermission 中的方法
返回动作的规范化字符串表示形式。
getActions() - 类 java.security.AllPermission 中的方法
返回操作的规范化字符串表示形式。
getActions() - 类 java.security.BasicPermission 中的方法
返回操作的规范化字符串表示形式，该表示形式当前为空字符串 ""，因为不存在 BasicPermission 的操作。
getActions() - 类 java.security.Permission 中的方法
以 String 的形式返回操作。
getActions() - 类 java.security.UnresolvedPermission 中的方法
返回这些操作的规范的字符串表示形式，该字符串当前为空字符串 ""，原因是没有针对 UnresolvedPermission 的操作。
getActions() - 类 java.util.PropertyPermission 中的方法
返回动作的“规范化字符串表示形式”。
getActions() - 类 javax.management.MBeanPermission 中的方法
返回操作的“规范化字符串表示形式”。
getActions() - 类 javax.security.auth.kerberos.ServicePermission 中的方法
返回动作的规范化字符串表示形式。
getActions() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回操作的“规范的字符串表示形式”。
getActions() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
如果想提供自定义的 Action 集合，则应进行子类化和重写。
getActions() - 类 javax.swing.JFormattedTextField 中的方法
获取编辑器的命令列表。
getActions() - 类 javax.swing.JTextField 中的方法
获取编辑器的命令列表。
getActions() - 类 javax.swing.text.DefaultEditorKit 中的方法
获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
getActions() - 类 javax.swing.text.EditorKit 中的方法
获取能在文本组件上使用的一组命令，该文本组件使用由此工具包生成的模型和视图。
getActions() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取编辑器的命令列表。
getActions() - 类 javax.swing.text.InternationalFormatter 中的方法
如果 getSupportsIncrement 返回 true，则这将返回两个适合增加/减少该值的 Action。
getActions() - 类 javax.swing.text.JTextComponent 中的方法
获取编辑器的命令列表。
getActions() - 类 javax.swing.text.StyledEditorKit 中的方法
获取编辑器的命令列表。
getActivationDesc(ActivationID) - 接口 java.rmi.activation.ActivationSystem 中的方法
为具有该激活标识符 id 的对象返回激活描述符。
getActivationGroupDesc(ActivationGroupID) - 接口 java.rmi.activation.ActivationSystem 中的方法
为具有该激活组标识符 id 的组返回激活组描述符。
getActiveCount() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回主动执行任务的近似线程数。
getActiveWindow() - 类 java.awt.KeyboardFocusManager 中的方法
如果活动 Window 与调用线程位于同一个上下文中，则返回活动 Window。
getActor() - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
返回此 SOAPHeaderElement actor 属性的 URL。
getActualMaximum(int) - 类 java.util.Calendar 中的方法
给定此 Calendar 的时间值，返回指定日历字段可能拥有的最大值。
getActualMaximum(int) - 类 java.util.GregorianCalendar 中的方法
考虑到给定的时间值和 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，返回此日历字段可能具有的最大值。
getActualMinimum(int) - 类 java.util.Calendar 中的方法
给定此 Calendar 的时间值，返回指定日历字段可能拥有的最小值。
getActualMinimum(int) - 类 java.util.GregorianCalendar 中的方法
考虑到给定的时间值和 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，返回此日历字段可能具有的最小值。
getActualTypeArguments() - 接口 java.lang.reflect.ParameterizedType 中的方法
返回表示此类型实际类型参数的 Type 对象的数组。
getAdapter(Class<A>) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getAdapter(Class<A>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法

getAdapter(Class<A>) - 接口 javax.xml.bind.Marshaller 中的方法
获取与指定类型关联的适配器。
getAdapter(Class<A>) - 接口 javax.xml.bind.Unmarshaller 中的方法
获取与指定类型关联的适配器。
getAdditionalBeanInfo() - 接口 java.beans.BeanInfo 中的方法
此方法允许 BeanInfo 对象返回提供关于当前 bean 额外信息的 BeanInfo 对象组成的任意集合。
getAdditionalBeanInfo() - 类 java.beans.SimpleBeanInfo 中的方法
声明没有其他有关的 BeanInfo 对象。
getAdditionalHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法

getAdditionalHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法

getAdditionalHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 中的方法

getAdditionalHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 中的方法

getAddListenerMethod() - 类 java.beans.EventSetDescriptor 中的方法
获得用来添加事件侦听器的方法。
getAddress() - 类 java.net.DatagramPacket 中的方法
返回某台机器的 IP 地址，此数据报将要发往该机器或者是从该机器接收到的。
getAddress() - 类 java.net.Inet4Address 中的方法
返回此 InetAddress 对象的原始 IP 地址。
getAddress() - 类 java.net.Inet6Address 中的方法
返回此 InetAddress 对象的原始 IP 地址。
getAddress() - 类 java.net.InetAddress 中的方法
返回此 InetAddress 对象的原始 IP 地址。
getAddress() - 类 java.net.InetSocketAddress 中的方法
获取 InetAddress。
getAddress() - 类 java.net.InterfaceAddress 中的方法
返回此地址的 InetAddress。
getAddress() - 接口 javax.management.remote.JMXAddressable 中的方法
此对象的地址。
getAddress() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
该连接器服务器的地址。
getAddress() - 类 javax.management.remote.rmi.RMIConnector 中的方法
此连接器的地址。
getAddress() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法

getAdjustable() - 类 java.awt.event.AdjustmentEvent 中的方法
返回发起此事件的 Adjustable 对象。
getAdjustmentListeners() - 类 java.awt.Scrollbar 中的方法
返回在此滚动条上所有已注册调整侦听器组成的数组。
getAdjustmentListeners() - 类 java.awt.ScrollPaneAdjustable 中的方法
返回在此 ScrollPaneAdjustable 上所有已注册调整侦听器组成的数组。
getAdjustmentListeners() - 类 javax.swing.JScrollBar 中的方法
返回使用 addAdjustmentListener() 添加到此 JScrollBar 中的 AdjustmentListener 组成的数组。
getAdjustmentType() - 类 java.awt.event.AdjustmentEvent 中的方法
返回导致值更改事件的调整类型。
getAdler() - 类 java.util.zip.Deflater 中的方法
返回未压缩数据的 ADLER-32 值。
getAdler() - 类 java.util.zip.Inflater 中的方法
返回未压缩数据的 ADLER-32 值。
getAdvance() - 类 java.awt.font.GlyphMetrics 中的方法
返回沿基线（水平基线或垂直基线）的字形 advance。
getAdvance() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的 advance。
getAdvance() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回此 ImageGraphicAttribute 的 advance。
getAdvance() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回此 ShapeGraphicAttribute 的 advance。
getAdvance() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的 advance。
getAdvanceBetween(int, int) - 类 java.awt.font.TextMeasurer 中的方法
返回从 start 开始并包括一直到 limit 的字符的行的图形宽度。
getAdvanceX() - 类 java.awt.font.GlyphMetrics 中的方法
返回字形 advance 的 x 分量。
getAdvanceY() - 类 java.awt.font.GlyphMetrics 中的方法
返回字形 advance 的 y 分量。
getAffineX() - 类 java.security.spec.ECPoint 中的方法
返回仿射 x 坐标 x。
getAffineY() - 类 java.security.spec.ECPoint 中的方法
返回仿射 y 坐标 y。
getAfterIndex(int, int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回给定索引后面的 String。
getAfterIndex(int, int) - 接口 javax.accessibility.AccessibleText 中的方法
返回给定索引后面的 String。
getAfterIndex(int, int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回给定索引之后的 String。
getAfterIndex(int, int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回给定索引后的 String。
getAfterIndex(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 之后的 String。
getAfterIndex(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回给定索引后的 String。
getAfterIndex(int, int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回给定索引后面的 String。
getAfterIndex(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定索引之后的 String。
getAlgName() - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
返回加密算法。
getAlgorithm() - 类 java.security.AlgorithmParameterGenerator 中的方法
返回与此参数生成器关联的算法的标准名称。
getAlgorithm() - 类 java.security.AlgorithmParameters 中的方法
返回与此参数对象关联的算法的名称。
getAlgorithm() - 类 java.security.cert.CertPathBuilder 中的方法
返回此 CertPathBuilder 的算法名称。
getAlgorithm() - 类 java.security.cert.CertPathValidator 中的方法
返回此 CertPathValidator 的算法名称。
getAlgorithm() - 接口 java.security.Key 中的方法
返回此密钥的标准算法名称。
getAlgorithm() - 类 java.security.KeyFactory 中的方法
获取与此 KeyFactory 关联的算法的名称。
getAlgorithm() - 类 java.security.KeyPairGenerator 中的方法
返回此密钥对生成器算法的标准名称。
getAlgorithm() - 类 java.security.MessageDigest 中的方法
返回标识算法的独立于实现细节的字符串。
getAlgorithm() - 类 java.security.Provider.Service 中的方法
返回此服务的算法的名称。
getAlgorithm() - 类 java.security.SecureRandom 中的方法
返回此 SecureRandom 对象实现的算法的名称。
getAlgorithm() - 类 java.security.Signature 中的方法
返回此签名对象的算法名称。
getAlgorithm() - 类 java.security.SignedObject 中的方法
获取签名算法的名称。
getAlgorithm() - 类 javax.crypto.Cipher 中的方法
返回此 Cipher 对象的算法名称。
getAlgorithm() - 类 javax.crypto.KeyAgreement 中的方法
返回此 KeyAgreement 对象的算法名称。
getAlgorithm() - 类 javax.crypto.KeyGenerator 中的方法
返回此 KeyGenerator 对象的算法名称。
getAlgorithm() - 类 javax.crypto.Mac 中的方法
返回此 Mac 对象的算法名称。
getAlgorithm() - 类 javax.crypto.SealedObject 中的方法
返回用于密封此对象的算法。
getAlgorithm() - 类 javax.crypto.SecretKeyFactory 中的方法
返回此 SecretKeyFactory 对象的算法名称。
getAlgorithm() - 类 javax.crypto.spec.PSource 中的方法
返回 PSource 算法名称。
getAlgorithm() - 类 javax.crypto.spec.SecretKeySpec 中的方法
返回与此密钥关联的算法的名称。
getAlgorithm() - 类 javax.net.ssl.KeyManagerFactory 中的方法
返回此 KeyManagerFactory 对象的算法名称。
getAlgorithm() - 类 javax.net.ssl.TrustManagerFactory 中的方法
返回此 TrustManagerFactory 对象的算法名称。
getAlgorithm() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此密钥的标准算法名称。
getAlgorithm() - 接口 javax.xml.crypto.AlgorithmMethod 中的方法
返回此 AlgorithmMethod 的算法 URI。
getAlgorithm() - 类 javax.xml.crypto.dsig.TransformService 中的方法
返回此 TransformService 支持的算法 URI。
getAlgorithmProperty(String, String) - 类 java.security.Security 中的静态方法
已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。
getAlgorithms(String) - 类 java.security.Security 中的静态方法
返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。
getAlgParameters() - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
返回加密算法使用的算法参数。
getAlias() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
返回 KeyStore 别名。
getAlignedSizeRequirements(SizeRequirements[]) - 类 javax.swing.SizeRequirements 中的静态方法
确定对齐一组组件所需的总空间。
getAlignment() - 类 java.awt.FlowLayout 中的方法
获取此布局的对齐方式。
getAlignment() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的对齐方式。
getAlignment() - 类 java.awt.Label 中的方法
获取此标签的当前对齐方式。
getAlignment(int) - 类 javax.swing.text.BoxView 中的方法
确定此视图沿某个轴所需的调整值。
getAlignment(int) - 类 javax.swing.text.ComponentView 中的方法
确定此视图沿某轴所需的对齐方式。
getAlignment(int) - 类 javax.swing.text.GlyphView 中的方法
确定此视图沿某个轴所需的对齐方式。
getAlignment(int) - 类 javax.swing.text.html.BlockView 中的方法
获取对齐方式。
getAlignment(int) - 类 javax.swing.text.html.ImageView 中的方法
确定此视图沿某个轴所需的调整值。
getAlignment(int) - 类 javax.swing.text.html.ListView 中的方法
计算所需的列表形状。
getAlignment(int) - 类 javax.swing.text.IconView 中的方法
确定此视图沿某个轴所需的调整值。
getAlignment(int) - 类 javax.swing.text.ParagraphView 中的方法
确定此视图沿某轴所需的对齐方式。
getAlignment(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取对齐设置。
getAlignment() - 类 javax.swing.text.TabStop 中的方法
以 integer 的形式返回制表符的对齐方式。
getAlignment(int) - 类 javax.swing.text.View 中的方法
确定此视图沿某个轴所需的对齐方式。
getAlignmentX() - 类 java.awt.Component 中的方法
返回 x 轴的对齐方式。
getAlignmentX() - 类 java.awt.Container 中的方法
返回沿 x 轴的对齐方式。
getAlignmentX() - 类 javax.swing.JComponent 中的方法
重写 Container.getAlignmentX 以返回垂直对齐方式。
getAlignmentY() - 类 java.awt.Component 中的方法
返回 y 轴的对齐方式。
getAlignmentY() - 类 java.awt.Container 中的方法
返回沿 y 轴的对齐方式。
getAlignmentY() - 类 javax.swing.JComponent 中的方法
重写 Container.getAlignmentY 以返回水平对齐方式。
getAlignOnBaseline() - 类 java.awt.FlowLayout 中的方法
如果组件将沿其基线垂直对齐，则返回 true。
getAll(String[]) - 接口 javax.management.openmbean.CompositeData 中的方法
返回通过 keys 指定其项名称的值组成的数组，值排列的顺序与 keys 相同。
getAll(String[]) - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回由 keys 指定其项名称的值的数组，顺序与 keys 相同。
getAll() - 类 javax.naming.CompositeName 中的方法
以字符串枚举的形式检索此复合名称的组件。
getAll() - 类 javax.naming.CompoundName 中的方法
以字符串枚举的形式检索此组合名称的组件。
getAll() - 接口 javax.naming.directory.Attribute 中的方法
检索属性值的枚举。
getAll() - 接口 javax.naming.directory.Attributes 中的方法
检索属性集中属性的枚举。
getAll() - 类 javax.naming.directory.BasicAttribute 中的方法
检索此属性值的枚举。
getAll() - 类 javax.naming.directory.BasicAttributes 中的方法

getAll() - 类 javax.naming.ldap.LdapName 中的方法
以字符串枚举的形式检索此名称的组件。
getAll() - 接口 javax.naming.Name 中的方法
以字符串枚举的形式检索此名称的组件。
getAll() - 类 javax.naming.Reference 中的方法
返回此索引中的地址所组成的枚举。
getAllAnnotationMirrors(Element) - 接口 javax.lang.model.util.Elements 中的方法
返回元素的所有注释，不管是继承的还是直接存在的。
getAllAttributeKeys() - 接口 java.text.AttributedCharacterIterator 中的方法
返回定义于迭代器文本范围上的所有属性的键。
getAllAttributeKeys() - 类 javax.swing.text.html.CSS 中的静态方法
返回所有可能的 CSS 属性键集合。
getAllAttributeKeys() - 类 javax.swing.text.html.HTML 中的静态方法
返回所识别的 HTML 属性集。
getAllAttributes() - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在此 SOAPElement 对象中所有属性 Name 对象上进行迭代的 Iterator。
getAllAttributesAsQNames() - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在此 SOAPElement 对象（以 QName 对象的形式）中的所有属性上进行迭代的 Iterator。
getAllByName(String) - 类 java.net.InetAddress 中的静态方法
在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。
getAllCommands(String) - 类 javax.activation.CommandMap 中的方法
获取此类型的所有可用命令。
getAllCommands(String, DataSource) - 类 javax.activation.CommandMap 中的方法
获取此类型的所有可用命令。
getAllCommands() - 类 javax.activation.DataHandler 中的方法
返回此数据类型的所有命令。
getAllCommands(String) - 类 javax.activation.MailcapCommandMap 中的方法
针对此 MIME 类型获取此 MailcapCommandMap 实例已知的所有 mailcap 文件中的所有可用命令。
getAllFonts() - 类 java.awt.GraphicsEnvironment 中的方法
返回一个数组，它包含此 GraphicsEnvironment 中所有可用字体的像素级实例。
getAllFrames() - 类 javax.swing.JDesktopPane 中的方法
返回桌面中当前显示的所有 JInternalFrames。
getAllFramesInLayer(int) - 类 javax.swing.JDesktopPane 中的方法
返回桌面指定层中当前所显示的所有 JInternalFrames。
getAllHeaders() - 类 javax.xml.soap.MimeHeaders 中的方法
返回此 MimeHeaders 对象中的所有 MimeHeader。
getAllLoadedClasses() - 接口 java.lang.instrument.Instrumentation 中的方法
返回 JVM 当前加载的所有类的数组。
getAllMembers(TypeElement) - 接口 javax.lang.model.util.Elements 中的方法
返回类型元素的所有成员，不管是继承的还是直接声明的。
getAllMimeHeaders() - 类 javax.xml.soap.AttachmentPart 中的方法
以 MimeHeader 对象上的迭代器形式，检索此 AttachmentPart 对象的所有头。
getAllMimeHeaders() - 类 javax.xml.soap.SOAPPart 中的方法
以可在 MimeHeader 对象上进行迭代的迭代器形式，检索此 SOAPPart 对象的所有头。
getAllNotificationIDs() - 类 javax.management.timer.Timer 中的方法
获得所有在通知列表中注册的计时器通知标识符。
getAllNotificationIDs() - 接口 javax.management.timer.TimerMBean 中的方法
获得所有在通知的列表中注册的计时器通知标识符。
getAllowsChildren() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
如果接收方允许有子级，则返回 true。
getAllowsChildren() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
如果接收者允许接收子元素，则返回 true。
getAllowsChildren() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
如果接收者允许接收子元素，则返回 true。
getAllowsChildren() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果允许此节点拥有子节点，则返回 true。
getAllowsChildren() - 接口 javax.swing.tree.TreeNode 中的方法
如果接收者允许有子节点，则返回 true。
getAllowsInvalid() - 类 javax.swing.text.DefaultFormatter 中的方法
返回编辑的值是否在一段时间内允许为无效。
getAllowUserInteraction() - 类 java.net.URLConnection 中的方法
返回此对象的 allowUserInteraction 字段的值。
getAllRelationIds() - 类 javax.management.relation.RelationService 中的方法
返回由 Relation Service 处理的所有关系的所有关系 id。
getAllRelationIds() - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回由 Relation Service 处理的所有关系的所有关系 id。
getAllRelationTypeNames() - 类 javax.management.relation.RelationService 中的方法
检索所有已知关系类型的名称。
getAllRelationTypeNames() - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索所有已知关系类型的名称。
getAllRoles() - 接口 javax.management.relation.Relation 中的方法
返回该关系中存在的所有角色。
getAllRoles(String) - 类 javax.management.relation.RelationService 中的方法
返回关系中存在的所有角色。
getAllRoles(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回关系中存在的所有角色。
getAllRoles() - 类 javax.management.relation.RelationSupport 中的方法
返回关系中存在的所有角色。
getAllStackTraces() - 类 java.lang.Thread 中的静态方法
返回所有活动线程的堆栈跟踪的一个映射。
getAllTags() - 类 javax.swing.text.html.HTML 中的静态方法
返回默认 HTML reader 所识别的实际 HTML 标记集。
getAllThreadIds() - 接口 java.lang.management.ThreadMXBean 中的方法
返回活动线程 ID。
getAlpha() - 类 java.awt.AlphaComposite 中的方法
返回此 AlphaComposite 的 alpha 值。
getAlpha() - 类 java.awt.Color 中的方法
返回位于范围 0-255 中的 alpha 分量。
getAlpha(int) - 类 java.awt.image.ColorModel 中的方法
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
getAlpha(Object) - 类 java.awt.image.ColorModel 中的方法
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
getAlpha(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
getAlpha(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
getAlpha(int) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
getAlpha(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
getAlpha(int) - 类 java.awt.image.IndexColorModel 中的方法
返回指定像素的 alpha 分量，该值为 0 到 255。
getAlphaMask() - 类 java.awt.image.DirectColorModel 中的方法
返回指示 int 像素表示形式中哪些位包含 alpha 分量的掩码。
getAlphaRaster() - 类 java.awt.image.BufferedImage 中的方法
返回一个 WritableRaster，它使用支持单独空间 alpha 通道的 ColorModel 对象（比如 ComponentColorModel 和 DirectColorModel）表示 BufferedImage 对象的 alpha 通道。
getAlphaRaster(WritableRaster) - 类 java.awt.image.ColorModel 中的方法
返回表示图像（从输入 Raster 中提取）的 alpha 通道的 Raster，除非此 ColorModel 的像素值将颜色和 alpha 信息表示为独立的空间 band（如 ComponentColorModel 和 DirectColorModel）。
getAlphaRaster(WritableRaster) - 类 java.awt.image.ComponentColorModel 中的方法
返回表示某图像（从输入 Raster 提取）的 alpha 通道的 Raster。
getAlphaRaster(WritableRaster) - 类 java.awt.image.PackedColorModel 中的方法
返回从输入 WritableRaster 提取，并且表示图像 alpha 通道的 WritableRaster。
getAlphas(byte[]) - 类 java.awt.image.IndexColorModel 中的方法
将 alpha 透明度分量数组复制到指定的数组中。
getAltKey() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于指示在触发事件期间是否按下 'alt' 键。
getAltName() - 异常 javax.naming.CannotProceedException 中的方法
检索此异常的 altName 字段。
getAltNameCtx() - 异常 javax.naming.CannotProceedException 中的方法
检索此异常的 altNameCtx 字段。
getAltText() - 类 javax.swing.text.html.ImageView 中的方法
如果不能加载图像，则返回要显示的文本。
getAmountFull(Insets, int, int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
此方法确定进度条的量，该量应该基于从模型搜集的完成百分比填充。
getAmPmStrings() - 类 java.text.DateFormatSymbols 中的方法
获取 ampm 字符串。
getAncestor() - 类 javax.swing.event.AncestorEvent 中的方法
返回实际发生事件的祖先组件。
getAncestorListeners() - 类 javax.swing.JComponent 中的方法
返回在此组件上注册的所有祖先侦听器所组成的数组。
getAncestorNamed(String, Component) - 类 javax.swing.SwingUtilities 中的静态方法
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。
getAncestorOfClass(Class<?>, Component) - 类 javax.swing.SwingUtilities 中的静态方法
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
getAncestorParent() - 类 javax.swing.event.AncestorEvent 中的方法
返回实际发生事件的祖先组件的父组件。
getAnchorRect() - 类 java.awt.TexturePaint 中的方法
返回定位纹理图像并设置其大小的固定矩形的副本。
getAnchorSelectionIndex() - 类 javax.swing.DefaultListSelectionModel 中的方法
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第一个索引参数。
getAnchorSelectionIndex() - 类 javax.swing.JList 中的方法
返回定位选择索引。
getAnchorSelectionIndex() - 接口 javax.swing.ListSelectionModel 中的方法
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第一个索引参数。
getAnchorSelectionPath() - 类 javax.swing.JTree 中的方法
返回标识为定位的路径。
getAndAdd(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将给定值与当前值相加。
getAndAdd(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将给定值与索引 i 的元素相加。
getAndAdd(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将给定值添加到此更新器管理的给定对象的当前值。
getAndAdd(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将给定值添加到当前值。
getAndAdd(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将给定值与索引 i 的元素相加。
getAndAdd(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将给定值添加到此更新器管理的给定对象的字段的当前值。
getAndDecrement() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将当前值减 1。
getAndDecrement(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将索引 i 的元素减 1。
getAndDecrement(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的当前值减 1。
getAndDecrement() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将当前值减 1。
getAndDecrement(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将索引 i 的元素减 1。
getAndDecrement(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象字段当前值减 1。
getAndIncrement() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将当前值加 1。
getAndIncrement(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将索引 i 的元素加 1。
getAndIncrement(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的当前值加 1。
getAndIncrement() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将当前值加 1。
getAndIncrement(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将索引 i 的元素加 1。
getAndIncrement(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象字段的当前值加 1。
getAndSet(boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
以原子方式设置为给定值，并返回以前的值。
getAndSet(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式设置为给定值，并返回旧值。
getAndSet(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
将位置 i 的元素以原子方式设置为给定值，并返回旧值。
getAndSet(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的字段设置为给定值，并返回旧值。
getAndSet(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式设置为给定值，并返回旧值。
getAndSet(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将位置 i 的元素设置为给定值，并返回旧值。
getAndSet(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
将此更新器管理的给定对象的字段以原子方式设置为给定值，并返回旧值。
getAndSet(V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
以原子方式设置为给定值，并返回旧值。
getAndSet(int, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
以原子方式将位置 i 的元素设置为给定值，并返回旧值。
getAndSet(T, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
将此更新器管理的给定对象的字段自动设置为给定值，并返回旧值。
getAngleExtent() - 类 java.awt.geom.Arc2D.Double 中的方法
返回弧的角跨越。
getAngleExtent() - 类 java.awt.geom.Arc2D.Float 中的方法
返回弧的角跨越。
getAngleExtent() - 类 java.awt.geom.Arc2D 中的方法
返回弧的角跨越。
getAngleStart() - 类 java.awt.geom.Arc2D.Double 中的方法
返回弧的起始角度。
getAngleStart() - 类 java.awt.geom.Arc2D.Float 中的方法
返回弧的起始角度。
getAngleStart() - 类 java.awt.geom.Arc2D 中的方法
返回弧的起始角度。
getAnimationIndex() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
获取当前动画窗体的索引。
getAnnotation(Class<A>) - 类 java.lang.Class 中的方法

getAnnotation(Class<A>) - 类 java.lang.Package 中的方法

getAnnotation(Class<T>) - 类 java.lang.reflect.AccessibleObject 中的方法

getAnnotation(Class<T>) - 接口 java.lang.reflect.AnnotatedElement 中的方法
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
getAnnotation(Class<T>) - 类 java.lang.reflect.Constructor 中的方法

getAnnotation(Class<T>) - 类 java.lang.reflect.Field 中的方法

getAnnotation(Class<T>) - 类 java.lang.reflect.Method 中的方法

getAnnotation(Class<A>) - 接口 javax.lang.model.element.Element 中的方法
返回此元素针对指定类型的注释（如果存在这样的注释），否则返回 null。
getAnnotationMirrors() - 接口 javax.lang.model.element.Element 中的方法
返回直接存在于此元素上的注释。
getAnnotations() - 类 java.lang.Class 中的方法

getAnnotations() - 类 java.lang.Package 中的方法

getAnnotations() - 类 java.lang.reflect.AccessibleObject 中的方法

getAnnotations() - 接口 java.lang.reflect.AnnotatedElement 中的方法
返回此元素上存在的所有注释。
getAnnotationType() - 接口 javax.lang.model.element.AnnotationMirror 中的方法
返回此注释的类型。
getAnonymityState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否会向上下文接受端对上下文初始端进行匿名验证。
getAnonymousLogger() - 类 java.util.logging.Logger 中的静态方法
创建一个匿名的 Logger。
getAnonymousLogger(String) - 类 java.util.logging.Logger 中的静态方法
创建一个匿名的 Logger。
getAntiAliasingHint() - 类 java.awt.font.FontRenderContext 中的方法
返回此 FontRenderContext 中使用的文本 anti-aliasing 呈现模式提示。
getAppConfigurationEntry(String) - 类 javax.security.auth.login.Configuration 中的方法
获取此 Configuration 中指定 name 的 AppConfigurationEntry。
getApplet(String) - 接口 java.applet.AppletContext 中的方法
通过给定名称找到并返回此 applet 上下文表示的文档中的 applet。
getAppletContext() - 类 java.applet.Applet 中的方法
确定此 applet 的上下文，上下文允许 applet 查询和影响它所运行的环境。
getAppletContext() - 接口 java.applet.AppletStub 中的方法
返回 applet 的上下文。
getAppletInfo() - 类 java.applet.Applet 中的方法
返回有关此 applet 的信息。
getApplets() - 接口 java.applet.AppletContext 中的方法
找到此 applet 上下文表示的文档中的所有 applet。
getApplicationBufferSize() - 接口 javax.net.ssl.SSLSession 中的方法
获取使用此会话时期望的最大应用程序数据的当前大小。
getApplicationData() - 类 org.ietf.jgss.ChannelBinding 中的方法
获得此通道绑定的应用程序指定的数据。
getApproveButton(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getApproveButton(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getApproveButtonMnemonic() - 类 javax.swing.JFileChooser 中的方法
返回确认按钮的助记符。
getApproveButtonMnemonic(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getApproveButtonText() - 类 javax.swing.JFileChooser 中的方法
返回 ApproveButton 中的 FileChooserUI 内使用的文本。
getApproveButtonText(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getApproveButtonText(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法

getApproveButtonText(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getApproveButtonText 方法。
getApproveButtonToolTipText() - 类 javax.swing.JFileChooser 中的方法
返回 ApproveButton 中使用的工具提示文本。
getApproveButtonToolTipText(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getApproveSelectionAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getArch() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回操作系统的架构。
getArcHeight() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
获取圆角弧的高度。
getArcHeight() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
获取圆角弧的高度。
getArcHeight() - 类 java.awt.geom.RoundRectangle2D 中的方法
获取圆角弧的高度。
getArcType() - 类 java.awt.geom.Arc2D 中的方法
返回弧的弧闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
getArcWidth() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
获取圆角弧的宽度。
getArcWidth() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
获取圆角弧的宽度。
getArcWidth() - 类 java.awt.geom.RoundRectangle2D 中的方法
获取圆角弧的宽度。
getAreaOfInterest() - 类 java.awt.image.renderable.RenderContext 中的方法
获取当前包含在 RenderContext 中的感兴趣区域。
getArgument() - 异常 javax.lang.model.element.UnknownAnnotationValueException 中的方法
返回附加参数。
getArgument() - 异常 javax.lang.model.element.UnknownElementException 中的方法
返回附加参数。
getArgument() - 异常 javax.lang.model.type.UnknownTypeException 中的方法
返回附加参数。
getArgumentClass() - 异常 java.util.IllegalFormatConversionException 中的方法
返回不匹配参数的类。
getArguments() - 类 java.beans.Statement 中的方法
返回此语句的参数。
getArray() - 接口 java.sql.Array 中的方法
以 Java 编程语言数组的形式获取由此 Array 对象指定的 SQL ARRAY 值的内容。
getArray(Map<String, Class<?>>) - 接口 java.sql.Array 中的方法
获取由此 Array 对象指定的 SQL ARRAY 值的内容。
getArray(long, int) - 接口 java.sql.Array 中的方法
获取由此 Array 对象指定的 SQL ARRAY 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
getArray(long, int, Map<String, Class<?>>) - 接口 java.sql.Array 中的方法
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
getArray(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Array 对象的形式获取指定的 JDBC ARRAY 参数的值。
getArray(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。
getArray(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getArray(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getArray() - 类 javax.sql.rowset.serial.SerialArray 中的方法
返回一个新数组，它是此 SerialArray 对象的副本。
getArray(Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 中的方法
返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
getArray(long, int) - 类 javax.sql.rowset.serial.SerialArray 中的方法
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
getArray(long, int, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 中的方法
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
getArray() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得字符数组。
getArrayLength() - 类 javax.swing.text.GapContent 中的方法
获取分配的数组的长度。
getArrayType(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回具有指定组件类型的数组类型。
getArrayType(OpenType<E>) - 类 javax.management.openmbean.ArrayType 中的静态方法
以类型安全的方式创建一个 ArrayType 实例。
getAscent() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的 ascent。
getAscent() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回此 ImageGraphicAttribute 的 ascent。
getAscent() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的 ascent。
getAscent() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回此 ShapeGraphicAttribute 的 ascent。
getAscent() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的 ascent。
getAscent() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的 font ascent。
getAscent(GlyphView) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法

getAsciiStream() - 接口 java.sql.Clob 中的方法
以 ascii 流形式获取此 Clob 对象指定的 CLOB 值。
getAsciiStream(int) - 接口 java.sql.ResultSet 中的方法
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
getAsciiStream(String) - 接口 java.sql.ResultSet 中的方法
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
getAsciiStream() - 类 javax.sql.rowset.serial.SerialClob 中的方法
以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
getAspectRatio(int) - 类 javax.imageio.ImageReader 中的方法
以 float 的形式返回给定图像的高宽比（即宽度除以高度）。
getAssociatedStylesheet(Source, String, String, String) - 类 javax.xml.transform.TransformerFactory 中的方法
通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。
getAsText() - 接口 java.beans.PropertyEditor 中的方法
以文本形式获得属性值。
getAsText() - 类 java.beans.PropertyEditorSupport 中的方法
获得人类可编辑的适当字符串表示形式的属性值。
getAsTree(String) - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回 XML DOM Node 对象，该对象表示此对象所包含的元数据树的根（根据给定元数据格式定义的约定）。
getAsync() - 接口 org.w3c.dom.ls.LSParser 中的方法
如果 LSParser 是异步的，为 true，如果它是同步的，则为 false。
getAsynchronousLoadPriority() - 类 javax.swing.text.AbstractDocument 中的方法
获得异步加载优先级。
getAtIndex(int, int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 接口 javax.accessibility.AccessibleText 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 处的 String。
getAtIndex(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回给定索引处的 String。
getAtIndex(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定索引处的 String。
getAttachment(SOAPElement) - 类 javax.xml.soap.SOAPMessage 中的方法
返回与此 SOAPElement 引用的附件关联的 AttachmentPart 对象，如果不存在此类附件，则返回 null。
getAttachmentAsByteArray(String) - 类 javax.xml.bind.attachment.AttachmentUnmarshaller 中的方法
以 byte[] 形式检索由内容 id（即 cid）标识的附件。
getAttachmentAsDataHandler(String) - 类 javax.xml.bind.attachment.AttachmentUnmarshaller 中的方法
通过内容 id（即 cid）查找 MIME 内容，并作为 DataHandler 返回。
getAttachmentMarshaller() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getAttachmentMarshaller() - 接口 javax.xml.bind.Marshaller 中的方法

getAttachments() - 类 javax.xml.soap.SOAPMessage 中的方法
检索所有作为此 SOAPMessage 对象一部分的 AttachmentPart 对象。
getAttachments(MimeHeaders) - 类 javax.xml.soap.SOAPMessage 中的方法
检索所有头条目匹配指定头的 AttachmentPart 对象。
getAttachmentUnmarshaller() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法

getAttachmentUnmarshaller() - 接口 javax.xml.bind.Unmarshaller 中的方法

getAttrChange() - 接口 org.w3c.dom.events.MutationEvent 中的方法
attrChange 指示触发 DOMAttrModified 事件的更改类型。
getAttribute(String) - 类 java.security.Provider.Service 中的方法
返回指定属性的值，如果没有为此 Service 设置此属性，则返回 null。
getAttribute(AttributedCharacterIterator.Attribute) - 接口 java.text.AttributedCharacterIterator 中的方法
返回当前字符的命名属性的值。
getAttribute(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getAttribute(ObjectName) - 类 javax.management.AttributeValueExp 中的方法
返回指定的 MBean 中给定属性的值。
getAttribute(String) - 接口 javax.management.DynamicMBean 中的方法
获得 Dynamic MBean 的特定属性的值。
getAttribute(ObjectName, String) - 接口 javax.management.MBeanServer 中的方法

getAttribute(ObjectName, String) - 接口 javax.management.MBeanServerConnection 中的方法
获得指定 MBean 的特定属性值。
getAttribute(String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回通过名称请求的 ModelMBeanAttributeInfo。
getAttribute(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getAttribute(String) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回为此 ModelMBean 定义的指定属性的值。
getAttribute(ObjectName, String, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
getAttribute(ObjectName, String, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getAttribute(ObjectName, String, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getAttribute(String) - 类 javax.management.StandardMBean 中的方法

getAttribute() - 类 javax.naming.directory.ModificationItem 中的方法
检索与此修改项关联的属性。
getAttribute(Class<T>) - 接口 javax.print.PrintService 中的方法
获取单个指定服务属性的值。
getAttribute(String, int) - 接口 javax.script.ScriptContext 中的方法
获取给定范围中某一属性的值。
getAttribute(String) - 接口 javax.script.ScriptContext 中的方法
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。
getAttribute(String) - 类 javax.script.SimpleScriptContext 中的方法
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。
getAttribute(String, int) - 类 javax.script.SimpleScriptContext 中的方法
获取给定范围中某一属性的值。
getAttribute(Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取属性值。
getAttribute(Object) - 接口 javax.swing.text.AttributeSet 中的方法
获取给定属性的值。
getAttribute(String) - 类 javax.swing.text.html.CSS 中的静态方法
将字符串转换为 CSS.Attribute 对象。
getAttribute(String) - 类 javax.swing.text.html.parser.Element 中的方法
按名称获取一个元素。
getAttribute(Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
获取属性的值。
getAttribute(Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
获取属性的值。
getAttribute(Object) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
获取属性的值。
getAttribute(String) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
允许用户在底层实现上检索特定属性。
getAttribute(String) - 类 javax.xml.transform.TransformerFactory 中的方法
允许用户在底层实现上检索指定属性。
getAttribute(String) - 接口 org.w3c.dom.Element 中的方法
通过名称获得属性值。
getAttributeByName(QName) - 接口 javax.xml.stream.events.StartElement 中的方法
返回此名称引用的属性
getAttributeByValue(String) - 类 javax.swing.text.html.parser.Element 中的方法
按值获取一个属性。
getAttributeContext() - 类 javax.swing.text.AbstractDocument 中的方法
获取管理属性的上下文。
getAttributeCount() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取所定义的属性数量。
getAttributeCount() - 接口 javax.swing.text.AttributeSet 中的方法
返回此集合中本地定义的属性个数。
getAttributeCount() - 类 javax.swing.text.SimpleAttributeSet 中的方法
获取属性数目的总数。
getAttributeCount() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
返回定义的属性数。
getAttributeCount() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
返回定义的属性数。
getAttributeCount() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeCount() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回此 START_ELEMENT 中的属性计数，此方法仅对 START_ELEMENT 或 ATTRIBUTE 有效。
getAttributeDataType(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回以 DATATYPE_ 开头的常量之一，指示指定元素中给定属性的值的格式和解释。
getAttributeDataType(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeDefaultValue(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。
getAttributeDefaultValue(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeDefinition() - 接口 javax.naming.directory.Attribute 中的方法
检索属性的模式定义。
getAttributeDefinition() - 类 javax.naming.directory.BasicAttribute 中的方法
检索此属性的模式定义。
getAttributeDescription(String, String, Locale) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回包含指定属性的描述的 String，或者 null。
getAttributeDescription(String, String, Locale) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
返回包含指定属性的描述的 String，或者 null。
getAttributeEnumerations(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。
getAttributeEnumerations(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeID() - 类 javax.naming.ldap.SortKey 中的方法
检索排序键的属性 ID。
getAttributeID() - 类 javax.naming.ldap.SortResponseControl 中的方法
检索导致排序失败的属性的 ID。
getAttributeKey(String) - 类 javax.swing.text.html.HTML 中的静态方法
获取已知属性名称的属性常量（即集合 {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG} 中的某个属性）。
getAttributeListMaxLength(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回可用于定义此属性的最大列表项数。
getAttributeListMaxLength(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeListMinLength(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回可用于定义此属性的最小列表项数。
getAttributeListMinLength(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeLocalName(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeLocalName(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的 localName
getAttributeMaxValue(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回属性的最大合法值。
getAttributeMaxValue(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeMinValue(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回属性的最小合法值。
getAttributeMinValue(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeName() - 类 javax.management.AttributeChangeNotification 中的方法
获得已更改属性的名称。
getAttributeName() - 类 javax.management.AttributeValueExp 中的方法
返回该属性名称的字符串表示形式。
getAttributeName(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeName(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的 qname
getAttributeNames(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。
getAttributeNames(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttributeNames() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取所有属性的名称。
getAttributeNames() - 接口 javax.swing.text.AttributeSet 中的方法
返回集合中本地定义的属性名称的枚举。
getAttributeNames() - 类 javax.swing.text.SimpleAttributeSet 中的方法
获取集合中的属性名称。
getAttributeNames() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
获取所有属性的名称。
getAttributeNames() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
获取所有属性的名称。
getAttributeNamespace(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeNamespace(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的名称空间
getAttributeNode(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getAttributeNode(String) - 接口 org.w3c.dom.Element 中的方法
通过名称获得属性节点。
getAttributeNodeNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 getAttributeNode(localName)。
getAttributeNodeNS(String, String) - 接口 org.w3c.dom.Element 中的方法
通过本地名称和名称空间 URI 获得 Attr 节点。
getAttributeNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 getAttribute(localName)。
getAttributeNS(String, String) - 接口 org.w3c.dom.Element 中的方法
通过本地名称和名称空间 URI 获得属性值。
getAttributePrefix(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributePrefix(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的前缀
getAttributes() - 类 java.awt.Font 中的方法
返回此 Font 中可用的字体属性的映射。
getAttributes() - 类 java.net.JarURLConnection 中的方法
如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。
getAttributes(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。
getAttributes() - 接口 java.sql.Struct 中的方法
生成此 Struct 对象所表示的 SQL 结构类型属性的有序值。
getAttributes(Map<String, Class<?>>) - 接口 java.sql.Struct 中的方法
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
getAttributes() - 接口 java.text.AttributedCharacterIterator 中的方法
返回具有定义于当前字符上的多个属性的映射。
getAttributes() - 类 java.util.jar.JarEntry 中的方法
返回此条目的 Manifest Attributes；如果没有，则返回 null。
getAttributes(String) - 类 java.util.jar.Manifest 中的方法
返回指定条目名称的 Attributes。
getAttributes() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getAttributes(String[]) - 接口 javax.management.DynamicMBean 中的方法
获得 Dynamic MBean 多个属性的值。
getAttributes() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的属性。
getAttributes() - 类 javax.management.MBeanInfo 中的方法
返回为了便于管理而公开的属性的列表。
getAttributes(ObjectName, String[]) - 接口 javax.management.MBeanServer 中的方法

getAttributes(ObjectName, String[]) - 接口 javax.management.MBeanServerConnection 中的方法
获得指定 MBean 的多个属性值。
getAttributes() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回为管理公开的属性列表。
getAttributes(String[]) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回 ModelMBean 中几个属性的值。
getAttributes() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回 OpenMBeanAttributeInfo 实例的数组，该实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个属性。
getAttributes() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
此连接器服务器的属性。
getAttributes(ObjectName, String[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
getAttributes(ObjectName, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getAttributes(ObjectName, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getAttributes() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法

getAttributes(String[]) - 类 javax.management.StandardMBean 中的方法

getAttributes(Name) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的所有属性。
getAttributes(String) - 接口 javax.naming.directory.DirContext 中的方法
检索所有与命名对象关联的属性。
getAttributes(Name, String[]) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的选定属性。
getAttributes(String, String[]) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的选定属性。
getAttributes(String) - 类 javax.naming.directory.InitialDirContext 中的方法

getAttributes(String, String[]) - 类 javax.naming.directory.InitialDirContext 中的方法

getAttributes(Name) - 类 javax.naming.directory.InitialDirContext 中的方法

getAttributes(Name, String[]) - 类 javax.naming.directory.InitialDirContext 中的方法

getAttributes() - 类 javax.naming.directory.SearchResult 中的方法
检索此搜索结果中的属性。
getAttributes() - 类 javax.naming.spi.DirStateFactory.Result 中的方法
检索要绑定的属性。
getAttributes() - 接口 javax.print.Doc 中的方法
获取此 doc 对象的打印属性集。
getAttributes() - 接口 javax.print.DocPrintJob 中的方法
获取此 PrintJob 的打印属性集。
getAttributes() - 类 javax.print.event.PrintJobAttributeEvent 中的方法
确定已经更改的打印属性及其新值。
getAttributes() - 类 javax.print.event.PrintServiceAttributeEvent 中的方法
确定已经更改的打印服务属性及其新值。
getAttributes() - 接口 javax.print.PrintService 中的方法
获得此 PrintService 的打印机描述属性集，这些属性给出了此 PrintService 的状态。
getAttributes() - 类 javax.print.SimpleDoc 中的方法
获得此 doc 对象的打印属性集。
getAttributes() - 类 javax.sql.rowset.serial.SerialStruct 中的方法
获取 Object 值的数组，该数组包含此 SerialStruct 对象所表示的 SQL 结构类型的属性。
getAttributes(Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialStruct 中的方法
获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
getAttributes() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素的属性。
getAttributes() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得元素属性。
getAttributes() - 接口 javax.swing.text.Element 中的方法
获取此元素包含的属性集合。
getAttributes() - 类 javax.swing.text.html.BlockView 中的方法
获取呈现时要使用的属性。
getAttributes() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
返回此标记的属性。
getAttributes() - 类 javax.swing.text.html.ImageView 中的方法
获取呈现时要使用的属性。
getAttributes() - 类 javax.swing.text.html.InlineView 中的方法
获取呈现时要使用的属性。
getAttributes() - 类 javax.swing.text.html.Option 中的方法
获取与此选项相关的属性。
getAttributes() - 类 javax.swing.text.html.ParagraphView 中的方法
获取呈现时所使用的属性。
getAttributes() - 类 javax.swing.text.html.parser.Element 中的方法
获取属性。
getAttributes() - 类 javax.swing.text.html.parser.Parser 中的方法

getAttributes() - 类 javax.swing.text.View 中的方法
获取呈现时要使用的属性。
getAttributes() - 接口 javax.xml.stream.events.StartElement 中的方法
返回在此 START_ELEMENT 上声明的已声明非名称空间属性的 Iterator；如果没有这样的属性，则返回空迭代器。
getAttributes() - 接口 org.w3c.dom.Node 中的方法
包含此节点的属性的 NamedNodeMap（如果它是 Element）；否则为 null。
getAttributesScope(String) - 接口 javax.script.ScriptContext 中的方法
获取定义了某个属性的最小范围。
getAttributesScope(String) - 类 javax.script.SimpleScriptContext 中的方法
获取用来定义属性的最小范围。
getAttributeSyntaxDefinition() - 接口 javax.naming.directory.Attribute 中的方法
检索与属性关联的语法定义。
getAttributeSyntaxDefinition() - 类 javax.naming.directory.BasicAttribute 中的方法
检索与此属性关联的语法定义。
getAttributeType() - 类 javax.management.AttributeChangeNotification 中的方法
获得已更改属性的类型。
getAttributeType(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeType(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回所提供索引处的属性的 XML 类型
getAttributeTypeInfo(int) - 类 javax.xml.validation.TypeInfoProvider 中的方法
返回指定的当前元素属性的不可变的 TypeInfo 对象。
getAttributeValue(Name) - 接口 javax.xml.soap.SOAPElement 中的方法
返回带有指定名称的属性值。
getAttributeValue(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
返回带有指定 qname 的属性值。
getAttributeValue(String, String) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeValue(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getAttributeValue(String, String) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回带有名称空间和 localName 的属性的规范化属性值。
getAttributeValue(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回 index 处的属性值
getAttributeValueType(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回以 VALUE_ 开头的常量之一，指示指定元素中给定属性的值是任意值、被限制在指定范围中的值、被限制为一组枚举值之一，还是一个任意值的以空白分隔的列表。
getAttributeValueType(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getAttrName() - 接口 org.w3c.dom.events.MutationEvent 中的方法
attrName 指示 DOMAttrModified 事件中已更改的 Attr 节点的名称。
getAudioActionMap() - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
返回包含此外观音频动作的 ActionMap。
getAudioClip(URL) - 类 java.applet.Applet 中的方法
返回 URL 参数指定的 AudioClip 对象。
getAudioClip(URL, String) - 类 java.applet.Applet 中的方法
返回 URL 和 name 参数指定的 AudioClip 对象。
getAudioClip(URL) - 接口 java.applet.AppletContext 中的方法
创建音频剪辑。
getAudioFileFormat(InputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得提供的音频输入流的音频文件格式。
getAudioFileFormat(URL) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得指定 URL 的音频文件格式。
getAudioFileFormat(File) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得指定 File 的音频文件格式。
getAudioFileFormat(InputStream) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
获得所提供输入流的音频文件格式。
getAudioFileFormat(URL) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
获得所提供 URL 的音频文件格式。
getAudioFileFormat(File) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
获得所提供 File 的音频文件格式。
getAudioFileTypes() - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得由系统为其提供文件写入支持的文件类型。
getAudioFileTypes(AudioInputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得系统可从指定音频输入流写入的文件类型。
getAudioFileTypes() - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
获得此音频文件 writer 为其提供文件写入支持的文件类型。
getAudioFileTypes(AudioInputStream) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
获得此音频文件 writer 可以从指定的音频输入流写入的文件类型。
getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
通过转换提供的音频输入流，获得所指示编码的音频输入流。
getAudioInputStream(AudioFormat, AudioInputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
通过转换提供的音频输入流，获得所指示格式的音频输入流。
getAudioInputStream(InputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
从提供的输入流获得音频输入流。
getAudioInputStream(URL) - 类 javax.sound.sampled.AudioSystem 中的静态方法
从提供的 URL 获得音频输入流。
getAudioInputStream(File) - 类 javax.sound.sampled.AudioSystem 中的静态方法
从提供的 File 获得音频输入流。
getAudioInputStream(InputStream) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
从所提供的输入流中获得音频输入流。
getAudioInputStream(URL) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
从所提供的 URL 获得音频输入流。
getAudioInputStream(File) - 类 javax.sound.sampled.spi.AudioFileReader 中的方法
从所提供的 File 获得音频输入流。
getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
从给定的音频输入流获得具有指定编码的音频输入流。
getAudioInputStream(AudioFormat, AudioInputStream) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
从给定的音频输入流获得具有指定格式的音频输入流。
getAuthenticationID() - 类 javax.security.sasl.AuthorizeCallback 中的方法
返回要检查的验证 id。
getAuthority() - 类 java.net.URI 中的方法
返回此 URI 的已解码的授权组成部分。
getAuthority() - 类 java.net.URL 中的方法
获取此 URL 的授权部分。
getAuthorityKeyIdentifier() - 类 java.security.cert.X509CertSelector 中的方法
返回 authorityKeyIdentifier 标准。
getAuthorizationID() - 类 javax.security.sasl.AuthorizeCallback 中的方法
返回要检查的授权 id。
getAuthorizationID() - 接口 javax.security.sasl.SaslServer 中的方法
报告此会话客户端的有效授权 ID。
getAuthorizedID() - 类 javax.security.sasl.AuthorizeCallback 中的方法
返回已授权用户的 id。
getAuthTime() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回客户端进行验证的时间。
getAutoCommit() - 接口 java.sql.Connection 中的方法
获取此 Connection 对象的当前自动提交模式。
getAutoCommit() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
getAutoCreateColumnsFromModel() - 类 javax.swing.JTable 中的方法
确定表是否要根据模型创建默认的列。
getAutoCreateContainerGaps() - 类 javax.swing.GroupLayout 中的方法
如果自动创建容器与触到容器边框的组件之间的间隙，则返回 true。
getAutoCreateGaps() - 类 javax.swing.GroupLayout 中的方法
如果自动创建组件之间的间隙，则返回 true。
getAutoCreateRowSorter() - 类 javax.swing.JTable 中的方法
如果每当模型更改时，都应该创建一个新 RowSorter 并作为该表的排序器安装，则返回 true；否则，返回 false。
getAutoDelay() - 类 java.awt.Robot 中的方法
返回此 Robot 在生成一个事件后睡眠的毫秒数。
getAutoResizeMode() - 类 javax.swing.JTable 中的方法
返回表的自动调整模式。
getAutoscrollInsets() - 接口 java.awt.dnd.Autoscroll 中的方法
此方法返回 Insets，用于描述相对于实现 Component 几何形状的自动滚动区域或边界。
getAutoscrolls() - 类 javax.swing.JComponent 中的方法
获取 autoscrolls 属性。
getAuxiliaryLookAndFeels() - 类 javax.swing.UIManager 中的静态方法
返回辅助外观的列表（可以为 null）。
getAvailableAcceleratedMemory() - 类 java.awt.GraphicsDevice 中的方法
此方法返回此设备上加速内存中可用的字节数。
getAvailableAttributes() - 类 java.awt.Font 中的方法
返回由此 Font 支持的所有属性的键。
getAvailableDataFlavors() - 类 java.awt.datatransfer.Clipboard 中的方法
返回 DataFlavor 的数组，其中提供了此剪贴板的当前内容。
getAvailableFontFamilyNames() - 类 java.awt.GraphicsEnvironment 中的方法
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，它针对默认语言环境进行了本地化，由 Locale.getDefault() 返回。
getAvailableFontFamilyNames(Locale) - 类 java.awt.GraphicsEnvironment 中的方法
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，已针对默认语言环境对它进行了本地化。
getAvailableIDs(int) - 类 java.util.TimeZone 中的静态方法
根据给定的时区偏移量（以毫秒为单位）获取可用的 ID。
getAvailableIDs() - 类 java.util.TimeZone 中的静态方法
获取受支持的所有可用 ID。
getAvailableInstruments() - 接口 javax.sound.midi.Synthesizer 中的方法
获得该合成器随附的乐器列表。
getAvailableLocales() - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
返回相应输入方法支持的语言环境。
getAvailableLocales() - 类 java.text.BreakIterator 中的静态方法
返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
getAvailableLocales() - 类 java.text.Collator 中的静态方法
返回一个所有受支持语言环境的数组，此类的 getInstance 方法可为这些语言环境返回已本地化的实例。
getAvailableLocales() - 类 java.text.DateFormat 中的静态方法
返回所有语言环境的数组，此类的 get*Instance 方法可以为其返回已本地化的实例。
getAvailableLocales() - 类 java.text.DateFormatSymbols 中的静态方法
返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
getAvailableLocales() - 类 java.text.DecimalFormatSymbols 中的静态方法
返回一个数组，它包括所有此类的 getInstance 方法可为之返回本地化实例的语言环境。
getAvailableLocales() - 类 java.text.NumberFormat 中的静态方法
返回一个数组，它包含所有此类的 get*Instance 方法可以为其返回本地化实例的语言环境。
getAvailableLocales() - 类 java.util.Calendar 中的静态方法
返回所有语言环境的数组，此类的 getInstance 方法可以为其返回本地化的实例。
getAvailableLocales() - 类 java.util.Locale 中的静态方法
返回所有已安装语言环境的数组。
getAvailableLocales() - 类 java.util.spi.LocaleServiceProvider 中的方法
返回一个数组，它包含此语言环境服务提供者可以为其提供本地化对象或名称的所有语言环境。
getAvailableLocales() - 类 javax.imageio.ImageReader 中的方法
返回可用来初始化警告侦听器和压缩设置值的 Locale 所组成的数组。
getAvailableLocales() - 类 javax.imageio.ImageWriter 中的方法
返回可用来初始化警告侦听器和压缩设置的 Locale 组成的数组。
getAvailableProcessors() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回 Java 虚拟机可以使用的处理器数目。
getAvailableSize(Dimension, Insets) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回基于容器大小和 Insets 的可用宽度。
getAWTEventListeners() - 类 java.awt.Toolkit 中的方法
返回在此工具包上所有已注册 AWTEventListener 所组成的数组。
getAWTEventListeners(long) - 类 java.awt.Toolkit 中的方法
返回已在此工具包上注册的所有 AWTEventListener 所组成的数组，这些侦听器侦听用 eventMask 参数指定的所有事件类型。
getAWTKeyStroke(char) - 类 java.awt.AWTKeyStroke 中的静态方法
返回表示指定字符的 KEY_TYPED 事件的 AWTKeyStroke 的一个共享实例。
getAWTKeyStroke(Character, int) - 类 java.awt.AWTKeyStroke 中的静态方法
返回一个共享的 AWTKeyStroke 实例，它表示针对指定 Character 对象和一组组合键的 KEY_TYPED 事件。
getAWTKeyStroke(int, int, boolean) - 类 java.awt.AWTKeyStroke 中的静态方法
在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例，指定该键在按下或释放时是否是被激活。
getAWTKeyStroke(int, int) - 类 java.awt.AWTKeyStroke 中的静态方法
在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例。
getAWTKeyStroke(String) - 类 java.awt.AWTKeyStroke 中的静态方法
分析字符串并返回一个 AWTKeyStroke。
getAWTKeyStrokeForEvent(KeyEvent) - 类 java.awt.AWTKeyStroke 中的静态方法
返回一个 AWTKeyStroke，它表示生成给定 KeyEvent 的键击事件。
getAxis() - 类 javax.swing.BoxLayout 中的方法
返回用于布局组件的轴。
getAxis() - 类 javax.swing.text.BoxView 中的方法
获取平铺轴属性。
getB() - 类 java.security.spec.EllipticCurve 中的方法
返回椭圆曲线的第二个系数 b。
getBackBuffer() - 类 java.awt.Component.FlipBufferStrategy 中的方法

getBackBufferCapabilities() - 类 java.awt.BufferCapabilities 中的方法

getBackground() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的背景色。
getBackground() - 类 java.awt.Component 中的方法
获取组件的背景色。
getBackground() - 类 java.awt.Graphics2D 中的方法
返回用于清除区域的背景色。
getBackground() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的背景颜色。
getBackground() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的背景色。
getBackground() - 类 java.awt.TextComponent 中的方法
获得此文本组件的背景色。
getBackground() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的背景色。
getBackground() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getBackground() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的背景色。
getBackground() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的背景色。
getBackground() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getBackground(AttributeSet) - 类 javax.swing.text.DefaultStyledDocument 中的方法
从属性集获得背景颜色。
getBackground() - 类 javax.swing.text.GlyphView 中的方法
获取用于呈现字形的背景色。
getBackground(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取一个属性集并将其转换为背景色规范。
getBackground() - 类 javax.swing.text.LabelView 中的方法
获取用于呈现字形的背景色。
getBackground(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取背景色设置。
getBackground(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
使用一个属性集并将其转换成为一个背景色规范。
getBackground(AttributeSet) - 接口 javax.swing.text.StyledDocument 中的方法
使用一个属性集并将其转换为一个背景色规范。
getBackgroundAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡背景色。
getBackgroundNonSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回用于非选定节点的背景色。
getBackgroundSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回在选定节点的情况下背景所使用的颜色。
getBandOffsets() - 类 java.awt.image.ComponentSampleModel 中的方法
返回所有 band 的 band 偏移量。
getBank() - 类 javax.sound.midi.Patch 中的方法
返回包含该 Patch 指定其位置乐器的库的号码。
getBankData() - 类 java.awt.image.DataBufferByte 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferDouble 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferFloat 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferInt 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferShort 中的方法
返回所有存储单元的数据数组。
getBankData() - 类 java.awt.image.DataBufferUShort 中的方法
返回所有存储单元的数据数组。
getBankIndices() - 类 java.awt.image.ComponentSampleModel 中的方法
返回所有 band 的存储单元索引。
getBase() - 类 javax.swing.text.html.HTMLDocument 中的方法
返回解析相对 URL 所根据的位置。
getBase() - 类 javax.swing.text.html.StyleSheet 中的方法
返回 base。
getBase64Content() - 类 javax.xml.soap.AttachmentPart 中的方法
以 Base64 编码字符数据的形式返回可用于获取 AttachmentPart 内容的 InputStream，此方法将对附件的原始字节进行 Base64 编码，然后返回该内容。
getBaseLevel() - 类 java.text.Bidi 中的方法
返回基本层次（如果是从左到右，则为 0；如果是从右到左，则为 1）。
getBaseline(int, int) - 类 java.awt.Component 中的方法
返回基线。
getBaseline() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的基线。
getBaseline(Component, int, int) - 类 javax.swing.border.AbstractBorder 中的方法
返回基线。
getBaseline(Component, int, int) - 类 javax.swing.border.TitledBorder 中的方法
返回基线。
getBaseline(int, int) - 类 javax.swing.JComponent 中的方法
返回基线。
getBaseline(int, int) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回基线。
getBaseline(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回指定选项卡的基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.ComponentUI 中的方法
返回基线。
getBaseline(JComponent, int, int) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
返回基线。
getBaselineFor(char) - 类 java.awt.Font 中的方法
返回适合用来显示此字符的基线。
getBaselineIndex() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的基线索引。
getBaselineOffset() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回基线偏移的距离。
getBaselineOffset() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
返回基线偏移的距离。
getBaselineOffsets() - 类 java.awt.font.LineMetrics 中的方法
返回文本的基线偏移量（相对于文本的基线）。
getBaselineOffsets() - 类 java.awt.font.TextLayout 中的方法
返回用于此 TextLayout 的基线偏移量数组。
getBaselineResizeBehavior() - 类 java.awt.Component 中的方法
返回一个指示组件的基线如何随大小发生更改的枚举。
getBaselineResizeBehavior(Component) - 类 javax.swing.border.AbstractBorder 中的方法
返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(Component) - 类 javax.swing.border.TitledBorder 中的方法
返回一个枚举，指示该边框的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior() - 类 javax.swing.JComponent 中的方法
返回一个枚举，指示组件的基线如何随大小更改而发生更改。
getBaselineResizeBehavior() - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回指示该组件的基线如何随大小的改变而发生更改的枚举。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的方法
返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
getBaselineResizeBehavior(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
getBaseType() - 接口 java.sql.Array 中的方法
在由此 Array 对象指定的数组中获取元素的 JDBC 类型。
getBaseType() - 类 javax.activation.MimeType 中的方法
返回此对象的 String 表示形式，不带参数列表。
getBaseType() - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取此 SerialArray 对象中 SQL 类型的元素。
getBaseTypeName() - 接口 java.sql.Array 中的方法
在由此 Array 对象指定的数组中获取元素的 SQL 类型名称。
getBaseTypeName() - 接口 java.sql.Ref 中的方法
获取此 Ref 对象所引用 SQL 结构类型的完全限定的 SQL 名称。
getBaseTypeName() - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取此 SerialArray 对象元素特定于 DBMS 的类型名称。
getBaseTypeName() - 类 javax.sql.rowset.serial.SerialRef 中的方法
返回描述 Ref 的基本类型名称的字符串。
getBaseURI() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getBaseURI() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法

getBaseURI() - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回基本 URI。
getBaseURI() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
获取此引用的基准 URI，如果此信息不可用，则获得 null
getBaseURI() - 接口 org.w3c.dom.ls.LSInput 中的方法
基 URI（请参阅 [IETF RFC 2396]中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。
getBaseURI() - 接口 org.w3c.dom.Node 中的方法
此节点的绝对基 URI；如果实现不能获得绝对 URI，则为 null。
getBasicConstraints() - 类 java.security.cert.X509Certificate 中的方法
从关键 BasicConstraints 扩展 (OID = 2.5.29.19) 中获取证书的限制路径长度。
getBasicConstraints() - 类 java.security.cert.X509CertSelector 中的方法
返回 BasicConstraints 限制。
getBasicSplitPaneUI() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回接收者当前位于其中的 SplitPaneUI。
getBean(CommandInfo) - 类 javax.activation.DataHandler 中的方法
一个便捷方法，它接受 CommandInfo 对象并且实例化相应的命令，通常是 JavaBean 组件。
getBeanClass() - 类 java.beans.BeanDescriptor 中的方法
获得 bean 的 Class 对象。
getBeanContext() - 接口 java.beans.beancontext.BeanContextChild 中的方法
获得与此 BeanContextChild 相关联的 BeanContext。
getBeanContext() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
获得此 BeanContextChildSupport 的嵌套 BeanContext。
getBeanContext() - 类 java.beans.beancontext.BeanContextEvent 中的方法
获得与此事件相关联的 BeanContext。
getBeanContextChildPeer() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
获得与此 BeanContextChildSupport 相关联的 BeanContextChild。
getBeanContextPeer() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得 BeanContext 的实例，此对象将为其提供实现。
getBeanContextProxy() - 接口 java.beans.beancontext.BeanContextProxy 中的方法
获得与此对象相关联的 BeanContextChild（或子接口）。
getBeanContextServicesPeer() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
获得与此 BeanContextServicesSupport 相关联的 BeanContextServices。
getBeanDescriptor() - 接口 java.beans.BeanInfo 中的方法
获得 beans BeanDescriptor。
getBeanDescriptor() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝关于 bean 的类和 customizer 的信息。
getBeanInfo(Class<?>) - 类 java.beans.Introspector 中的静态方法
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
getBeanInfo(Class<?>, int) - 类 java.beans.Introspector 中的静态方法
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。
getBeanInfo(Class<?>, Class<?>) - 类 java.beans.Introspector 中的静态方法
在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
getBeanInfoSearchPath() - 类 java.beans.Introspector 中的静态方法
获得将用来查找 BeanInfo 类的包名称的列表。
getBeforeIndex(int, int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回给定索引前面的 String。
getBeforeIndex(int, int) - 接口 javax.accessibility.AccessibleText 中的方法
返回给定索引前面的 String。
getBeforeIndex(int, int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回给定索引前面的 String。
getBeforeIndex(int, int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回给定索引前的 String。
getBeforeIndex(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 之前的 String。
getBeforeIndex(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回给定索引前的 String。
getBeforeIndex(int, int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回给定索引前面的 String。
getBeforeIndex(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定索引之前的 String。
getBeginIndex() - 接口 java.text.CharacterIterator 中的方法
返回文本的起始索引。
getBeginIndex() - 类 java.text.FieldPosition 中的方法
获取请求字段中第一个字符的索引。
getBeginIndex() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.getBeginIndex()。
getBeginIndex() - 类 javax.swing.text.Segment 中的方法
返回文本的起始索引。
getBestConfiguration(GraphicsConfiguration[]) - 类 java.awt.GraphicsConfigTemplate 中的方法
返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
getBestConfiguration(GraphicsConfigTemplate) - 类 java.awt.GraphicsDevice 中的方法
返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
getBestCursorSize(int, int) - 类 java.awt.Toolkit 中的方法
返回最接近所需大小的受支持光标尺寸。
getBestRowIdentifier(String, String, String, int, boolean) - 接口 java.sql.DatabaseMetaData 中的方法
获取唯一标识行的表的最佳列集合的描述。
getBevelType() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框的类型。
getBias() - 类 javax.swing.text.JTextComponent.DropLocation 中的方法
返回放置索引的偏差。
getBidiLevel(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取 BidiLevel 设置。
getBidiRootElement() - 类 javax.swing.text.AbstractDocument 中的方法
返回此文档双向结构的根元素。
getBigDecimal(int, int) - 接口 java.sql.CallableStatement 中的方法
已过时。 使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)
getBigDecimal(int) - 接口 java.sql.CallableStatement 中的方法
以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
getBigDecimal(String) - 接口 java.sql.CallableStatement 中的方法
以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
getBigDecimal(int, int) - 接口 java.sql.ResultSet 中的方法
已过时。
getBigDecimal(String, int) - 接口 java.sql.ResultSet 中的方法
已过时。
getBigDecimal(int) - 接口 java.sql.ResultSet 中的方法
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
getBigDecimal(String) - 接口 java.sql.ResultSet 中的方法
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
getBinaryName(TypeElement) - 接口 javax.lang.model.util.Elements 中的方法
返回类型元素的二进制名称。
getBinaryStream() - 接口 java.sql.Blob 中的方法
以流的形式获取此 Blob 实例指定的 BLOB 值。
getBinaryStream(long, long) - 接口 java.sql.Blob 中的方法
返回包含部分 Blob 值的 InputStream 对象，该值从 pos 指定的字节开始，长度为 length 个字节。
getBinaryStream(int) - 接口 java.sql.ResultSet 中的方法
以未解释字节的流的形式获取此 ResultSet 对象的当前行中指定列的值。
getBinaryStream(String) - 接口 java.sql.ResultSet 中的方法
以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。
getBinaryStream() - 接口 java.sql.SQLXML 中的方法
以流的形式获取此 SQLXML 实例指定的 XML 值。
getBinaryStream() - 类 javax.sql.rowset.serial.SerialBlob 中的方法
以输入流的形式返回此 SerialBlob 对象。
getBinaryStream(long, long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
返回一个包含部分 Blob 值的 InputStream 对象，它从 pos 指定的字节开始，具有 length 个字节长度。
getBinding() - 接口 javax.xml.ws.BindingProvider 中的方法
获取此绑定提供者的 Binding。
getBinding() - 类 javax.xml.ws.Endpoint 中的方法
返回此端点的绑定。
getBindingID() - 接口 javax.xml.ws.handler.PortInfo 中的方法
获取标识正由被访问的端口所用绑定的 URI。
getBindings(int) - 类 javax.script.AbstractScriptEngine 中的方法
返回受保护 context 字段中具有指定范围值的 Bindings。
getBindings(int) - 接口 javax.script.ScriptContext 中的方法
获取与此 ScriptContext 中的给定范围关联的 Bindings。
getBindings(int) - 接口 javax.script.ScriptEngine 中的方法
返回指定值的范围。
getBindings() - 类 javax.script.ScriptEngineManager 中的方法
getBindings 返回 globalScope 字段的值。
getBindings(int) - 类 javax.script.SimpleScriptContext 中的方法
如果指定范围为 ENGINE_SCOPE，则返回 engineScope 字段的值。
getBitDepth() - 类 java.awt.DisplayMode 中的方法
返回显示的位深（以位/像素表示）。
getBitMasks() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回所有 band 的位掩码。
getBitOffset(int) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回数据元素中存储扫描行第 x 个像素的偏移量(以位为单位)。
getBitOffset() - 接口 javax.imageio.stream.ImageInputStream 中的方法
以整数的形式返回当前位偏移量，该整数在 0 到 7 之间（包含两者）。
getBitOffset() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法

getBitOffsets() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回表示所有 band 像素的数据数组元素中的位偏移量。
getBitRate(float) - 类 javax.imageio.ImageWriteParam 中的方法
返回一个 float 值，该值指示对给定质量级别上用于输入图像数据的每个位的输出数据位数的估计。
getBitsPerBand(int) - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回用来表示给定 band 样本的位数。
getBlack() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的黑色。
getBlack() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回黑色。
getBlack() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回黑色。
getBlackBoxBounds(int, int) - 类 java.awt.font.TextLayout 中的方法
返回指定范围中字符的黑框边界。
getBlackLineBorderUIResource() - 类 javax.swing.plaf.BorderUIResource 中的静态方法

getBlinkRate() - 接口 javax.swing.text.Caret 中的方法
获取插入符的闪烁率。
getBlinkRate() - 类 javax.swing.text.DefaultCaret 中的方法
获取插入符闪烁率。
getBlob(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
getBlob(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。
getBlob(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getBlob(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getBlockedCount() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程被阻塞进入或重进入监视器的总次数。
getBlockedTime() - 类 java.lang.management.ThreadInfo 中的方法
返回自从启用线程争用监视以来，与此 ThreadInfo 关联的线程被阻塞进入或重进入监视器的近似累计时间（以毫秒为单位）。
getBlocker(Thread) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
返回提供给最近一次尚未解除阻塞的 park 方法调用的 blocker 对象，如果该调用不受阻塞，则返回 null。
getBlockIncrement() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的块值增量。
getBlockIncrement() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的块增量。
getBlockIncrement() - 类 java.awt.ScrollPaneAdjustable 中的方法

getBlockIncrement(int) - 类 javax.swing.JScrollBar 中的方法
针对一个向上/向下滚动一个块（通常为 "page"）的请求，返回滚动条值的更改量。
getBlockIncrement() - 类 javax.swing.JScrollBar 中的方法
供与 java.awt.Scrollbar 向后兼容。
getBlockIncrement(int) - 类 javax.swing.JScrollPane.ScrollBar 中的方法
如果视口中的视图为 Scrollable 对象，将计算滚动的块增量值。
getBlockSize() - 类 javax.crypto.Cipher 中的方法
返回块的大小（以字节为单位）。
getBlue() - 类 java.awt.Color 中的方法
返回默认 sRGB 空间中位于范围 0-255 中的蓝色分量。
getBlue(int) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的蓝色分量的值，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(Object) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的蓝色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(int) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的蓝色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getBlue(int) - 类 java.awt.image.IndexColorModel 中的方法
返回指定像素的蓝色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
getBlueMask() - 类 java.awt.image.DirectColorModel 中的方法
返回指示 int 像素表示形式中哪些位包含蓝色颜色分量的掩码。
getBlues(byte[]) - 类 java.awt.image.IndexColorModel 中的方法
将蓝色分量数组复制到指定的数组中。
getBody() - 类 java.net.CacheRequest 中的方法
返回可以将响应正文写入其中的 OutputStream。
getBody() - 类 java.net.CacheResponse 中的方法
以 InputStream 的形式返回响应正文。
getBody() - 接口 javax.xml.soap.SOAPEnvelope 中的方法
返回与此 SOAPEnvelope 对象关联的 SOAPBody 对象。
getBoolean(String) - 类 java.lang.Boolean 中的静态方法
当且仅当以参数命名的系统属性存在，且等于 "true" 字符串时，才返回 true。
getBoolean(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 boolean 形式返回指定数组对象中索引组件的值。
getBoolean(Object) - 类 java.lang.reflect.Field 中的方法
获取一个静态或实例 boolean 字段的值。
getBoolean(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 boolean 值的形式获取指定的 JDBC BIT 或 BOOLEAN 参数的值。
getBoolean(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 boolean 值的形式获取 JDBC BIT 或 BOOLEAN 参数的值。
getBoolean(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
getBoolean(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
getBoolean(String, boolean) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getBoolean(String,boolean) 中的规范实现 getBoolean 方法。
getBoolean(String, boolean) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定的键相关联的、由字符串表示的 boolean 值。
getBoolean(SynthContext, Object, boolean) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
获得其值是一个 Boolean 值的特定样式属性的便捷方法。
getBoolean(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 是 boolean 值，则返回该 boolean 值，否则返回 false。
getBoolean(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。
getBoolean(Object) - 类 javax.swing.UIManager 中的静态方法
从与键值相关的默认值中返回一个布尔变量。
getBoolean(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从与键值和给定的 Locale 相关的默认值中返回一个布尔变量。
getBootClassPath() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回由引导类加载器用于搜索类文件的引导类路径。
getBorder() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的边框。
getBorder() - 类 javax.swing.JComponent 中的方法
返回此组件的边框；如果当前未设置边框，则返回 null。
getBorder() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回此组件的边框，如果当前没有设置边框，则返回 null。
getBorder() - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的方法
重写 JComponent.getBorder，以返回当前边框。
getBorder(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Border，则返回该 Border，否则返回 null。
getBorder(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。
getBorder(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个边框。
getBorder(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个边框。
getBorderColor() - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法

getBorderInsets(Component) - 类 javax.swing.border.AbstractBorder 中的方法
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
getBorderInsets(Component, Insets) - 类 javax.swing.border.AbstractBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.BevelBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 接口 javax.swing.border.Border 中的方法
返回该边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.CompoundBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.border.CompoundBorder 中的方法
返回复合边框的 insets，它是外部边框的 insets 与内部边框的 insets 相加所得的结果。
getBorderInsets(Component) - 类 javax.swing.border.EmptyBorder 中的方法
返回此边框的 insets
getBorderInsets(Component, Insets) - 类 javax.swing.border.EmptyBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数
getBorderInsets() - 类 javax.swing.border.EmptyBorder 中的方法
返回此边框的 insets。
getBorderInsets(Component) - 类 javax.swing.border.EtchedBorder 中的方法
返回边框的 insets
getBorderInsets(Component, Insets) - 类 javax.swing.border.EtchedBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数
getBorderInsets(Component) - 类 javax.swing.border.LineBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.LineBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.border.MatteBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.MatteBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets() - 类 javax.swing.border.MatteBorder 中的方法
返回此边框的 insets。
getBorderInsets(Component) - 类 javax.swing.border.SoftBevelBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.SoftBevelBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.border.TitledBorder 中的方法
返回边框的 insets。
getBorderInsets(Component, Insets) - 类 javax.swing.border.TitledBorder 中的方法
用此边框的当前 Insets 重新初始化 insets 参数。
getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.MarginBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.MarginBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.BorderUIResource 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 中的方法

getBorderInsets(Component) - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 中的方法

getBorderInsets(Component, Insets) - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 中的方法

getBorderSelectionColor() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
返回绘制边框的颜色。
getBorderSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回绘制边框时所使用的颜色。
getBorderTitle(Border) - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
在边界层次结构（如果存在）中递归地搜索带有非 null 标题的 TitledBorder。
getBottomComponent() - 类 javax.swing.JSplitPane 中的方法
返回分隔条下面或者右边的组件。
getBottomInset() - 类 javax.swing.text.AsyncBoxView 中的方法
获得视图四周底部的空白部分。
getBottomInset() - 类 javax.swing.text.CompositeView 中的方法
获取底部 inset。
getBottomPanel() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getBoundActions() - 接口 javax.swing.text.Keymap 中的方法
获取在此 keymap 中定义的所有操作。
getBoundedPosition(GlyphView, int, float, float) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
确定表示符合给定区域的最大 advance 的模型位置。
getBoundingBox() - 类 java.awt.Polygon 中的方法
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
getBoundKeyStrokes() - 接口 javax.swing.text.Keymap 中的方法
获取在此映射中绑定到其他操作的所有击键。
getBounds() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的边界，用 Rectangle 对象的形式表示它。
getBounds() - 类 java.awt.Component 中的方法
以 Rectangle 对象的形式获取组件的边界。
getBounds(Rectangle) - 类 java.awt.Component 中的方法
将组件的边界存储到“返回值”rv 中并返回 rv。
getBounds() - 类 java.awt.font.GraphicAttribute 中的方法
返回包括所有位的 Rectangle2D，这些位由与呈现位置相关的 GraphicAttribute 绘制。
getBounds() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回一个 Rectangle2D，它封装此 ImageGraphicAttribute 相对于呈现位置呈现的所有位。
getBounds() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回一个 Rectangle2D，它封装此 ShapeGraphicAttribute 相对于呈现位置绘制的所有位。
getBounds() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的边界。
getBounds() - 类 java.awt.geom.Area 中的方法
返回完全包围此 Area 的边界 Rectangle。
getBounds() - 类 java.awt.geom.CubicCurve2D 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.geom.Line2D 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.geom.Path2D 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.geom.QuadCurve2D 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.geom.RectangularShape 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.GraphicsConfiguration 中的方法
返回 GraphicsConfiguration 在设备坐标中的边界。
getBounds() - 类 java.awt.image.Raster 中的方法
返回此 Raster 的边界 Rectangle。
getBounds() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
以 Rectangle 对象的形式获取此对象的界限。
getBounds() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
以 Rectangle 对象的形式获取此对象的边界。
getBounds() - 类 java.awt.Polygon 中的方法
获取此 Polygon 的边界框。
getBounds() - 类 java.awt.Rectangle 中的方法
获取此 Rectangle 的边界 Rectangle。
getBounds() - 接口 java.awt.Shape 中的方法
返回一个完全包围 Shape 的整型 Rectangle。
getBounds() - 类 java.awt.SplashScreen 中的方法
以 Rectangle 形式返回闪现屏幕窗口的边界。
getBounds() - 接口 java.lang.reflect.TypeVariable 中的方法
返回表示此类型变量上边界的 Type 对象的数组。
getBounds() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取 Rectangle 对象形式的此对象的边界。
getBounds() - 接口 javax.lang.model.element.TypeParameterElement 中的方法
返回此类型参数的边界。
getBounds(Rectangle) - 类 javax.swing.JComponent 中的方法
将此组件的边界存储到“返回值”rv 中并返回 rv。
getBounds() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getBounds() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法

getBounds() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getBounds() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getBounds(TreePath, Rectangle) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回一个矩形，该矩形给出了绘制路径所需的 bounds。
getBounds(TreePath, Rectangle) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回给出绘制路径所需边界的矩形。
getBounds(TreePath, Rectangle) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
getBounds2D() - 类 java.awt.font.GlyphMetrics 中的方法
返回该字形的边界。
getBounds2D() - 类 java.awt.geom.Arc2D 中的方法
返回弧的高精度窗体矩形。
getBounds2D() - 类 java.awt.geom.Area 中的方法
返回完全包围此 Area 的高精度边界 Rectangle2D。
getBounds2D() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Ellipse2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Ellipse2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Line2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Line2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Path2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Path2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Rectangle2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Rectangle2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.Rectangle2D 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D(BufferedImage) - 类 java.awt.image.AffineTransformOp 中的方法
返回转换后的目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.AffineTransformOp 中的方法
返回转换后的目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.BandCombineOp 中的方法
返回变换后目标图像的边界框。
getBounds2D(BufferedImage) - 接口 java.awt.image.BufferedImageOp 中的方法
返回已过滤目标图像的边界框。
getBounds2D(BufferedImage) - 类 java.awt.image.ColorConvertOp 中的方法
返回给定源的目标边界框。
getBounds2D(Raster) - 类 java.awt.image.ColorConvertOp 中的方法
返回给定源的目标边界框。
getBounds2D(BufferedImage) - 类 java.awt.image.ConvolveOp 中的方法
返回已过滤目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.ConvolveOp 中的方法
返回已过滤目标 Raster 的边界框。
getBounds2D(BufferedImage) - 类 java.awt.image.LookupOp 中的方法
返回过滤后的目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.LookupOp 中的方法
返回过滤后目标 Raster 的边界框。
getBounds2D(Raster) - 接口 java.awt.image.RasterOp 中的方法
返回过滤后目标 Raster 的边界框。
getBounds2D(ParameterBlock) - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
返回操作的输出的边界框，该操作在与呈现无关的空间中给定的一组源上执行。
getBounds2D(BufferedImage) - 类 java.awt.image.RescaleOp 中的方法
返回重缩放后的目标图像的边界框。
getBounds2D(Raster) - 类 java.awt.image.RescaleOp 中的方法
返回重缩放后的目标 Raster 的边界框。
getBounds2D() - 类 java.awt.Polygon 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 类 java.awt.Rectangle 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBounds2D() - 接口 java.awt.Shape 中的方法
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
getBoundsAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡边界。
getBoundsForIconOf(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
iconifyFrame() 代码调用此方法来确定 desktopIcon 的适当边界。
getBox(Rectangle) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
存储将为 r 中的当前动画索引绘制并返回 r 的跳动框中位置和大小。
getBoxLength(int, int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回要绘制的“跳动框”的长度。
getBoxPainter(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取给定 CSS 属性集合使用的框 formatter。
getBranchQualifier() - 接口 javax.transaction.xa.Xid 中的方法
获取 XID 的事务分支标识符部分作为字节数组。
getBreakLocation(Segment, FontMetrics, int, int, TabExpander, int) - 类 javax.swing.text.Utilities 中的静态方法
确定对给定文本进行拆分的位置，以符合给定的跨距。
getBreakWeight(int, float, float) - 类 javax.swing.text.GlyphView 中的方法
确定此视图拆分几率有多大。
getBreakWeight(int, float, float) - 类 javax.swing.text.html.InlineView 中的方法
确定此视图拆分的可能性有多大。
getBreakWeight(int, float) - 类 javax.swing.text.ParagraphView 中的方法
获取给定位置的拆分权重。
getBreakWeight(int, float, float) - 类 javax.swing.text.View 中的方法
确定此视图中拆分时机的权重大小。
getBroadcast() - 类 java.net.DatagramSocket 中的方法
检测是否启用了 SO_BROADCAST。
getBroadcast() - 类 java.net.InterfaceAddress 中的方法
返回此 InterfaceAddress 广播地址的 InetAddress。
getBubbles() - 接口 org.w3c.dom.events.Event 中的方法
用于指示事件是否是 bubbling 事件。
getBuffer() - 类 java.io.StringWriter 中的方法
返回该字符串缓冲区本身。
getBufferCapabilities() - 类 java.awt.GraphicsConfiguration 中的方法
返回此 GraphicsConfiguration 的缓冲区能力。
getBufferedImageOp() - 类 java.awt.image.BufferedImageFilter 中的方法
返回 BufferedImageOp。
getBufferedImageType() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回一个 int 值，它包含某一来自 BufferedImage 的描述图像的枚举常量值。
getBufferSize() - 接口 javax.sound.sampled.DataLine 中的方法
获得将适合数据行的内部缓冲区的最大数据字节数。
getBufferStrategy() - 类 java.awt.Canvas 中的方法
返回由此组件使用的 BufferStrategy。
getBufferStrategy() - 类 java.awt.Window 中的方法
返回此组件使用的 BufferStrategy。
getBuilder() - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法

getBundle(String) - 类 java.util.ResourceBundle 中的静态方法
使用指定的基本名称、默认的语言环境和调用者的类加载器获取资源包。
getBundle(String, ResourceBundle.Control) - 类 java.util.ResourceBundle 中的静态方法
使用指定基本名称、默认语言环境和指定控件返回一个资源包。
getBundle(String, Locale) - 类 java.util.ResourceBundle 中的静态方法
使用指定的基本名称、语言环境和调用者的类加载器获取资源包。
getBundle(String, Locale, ResourceBundle.Control) - 类 java.util.ResourceBundle 中的静态方法
使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
getBundle(String, Locale, ClassLoader) - 类 java.util.ResourceBundle 中的静态方法
使用指定的基本名称、语言环境和类加载器获取资源包。
getBundle(String, Locale, ClassLoader, ResourceBundle.Control) - 类 java.util.ResourceBundle 中的静态方法
使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
getBusy() - 接口 org.w3c.dom.ls.LSParser 中的方法
如果 LSParser 当前正忙于加载文档，则为 true，否则为 false。
getButton() - 类 java.awt.event.MouseEvent 中的方法
返回更改了状态的鼠标按键（如果有）。
getButton() - 接口 org.w3c.dom.events.MouseEvent 中的方法
在由按下或释放鼠标的按键引起的鼠标事件期间，button 用于指示哪一个鼠标按键改变了状态。
getButtonBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于 JButton 的 border 实例
getButtonCount() - 类 javax.swing.ButtonGroup 中的方法
返回此组中的按钮数。
getButtonPanel() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getButtons() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回从接收者为其提供外观的 JOptionPane 显示的按钮。
getButtonWidth() - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法

getByAddress(String, byte[], NetworkInterface) - 类 java.net.Inet6Address 中的静态方法
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。
getByAddress(String, byte[], int) - 类 java.net.Inet6Address 中的静态方法
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。
getByAddress(String, byte[]) - 类 java.net.InetAddress 中的静态方法
根据提供的主机名和 IP 地址创建 InetAddress。
getByAddress(byte[]) - 类 java.net.InetAddress 中的静态方法
在给定原始 IP 地址的情况下，返回 InetAddress 对象。
getByInetAddress(InetAddress) - 类 java.net.NetworkInterface 中的静态方法
一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
getByName(String) - 类 java.net.InetAddress 中的静态方法
在给定主机名的情况下确定主机的 IP 地址。
getByName(String) - 类 java.net.NetworkInterface 中的静态方法
搜索具有指定名称的网络接口。
getByte(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 byte 形式返回指定数组对象中索引组件的值。
getByte(Object) - 类 java.lang.reflect.Field 中的方法
获取一个静态或实例 byte 字段的值。
getByte(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 byte 的形式获取指定的 JDBC TINYINT 参数的值。
getByte(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 byte 值的形式获取 JDBC TINYINT 参数的值。
getByte(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
getByte(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
getByteArray(String, byte[]) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getByteArray(String,byte[]) 中的规范实现 getByteArray 方法。
getByteArray(String, byte[]) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定键相关联的、由字符串表示的字节数组。
getByteLength() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件的长度，用 8 位字节表示。
getByteLength() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得以字节为单位的整个文件（不只是其音频数据）的大小。
getByteOffset() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的输入源中的字节偏移量；如果没有可用的字节偏移量，则为 -1。
getByteOrder() - 接口 javax.imageio.stream.ImageInputStream 中的方法
以 java.nio.ByteOrder 枚举实例的形式返回从此流中读取数据值时所使用的字节顺序。
getByteOrder() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法

getByteParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 byte 返回参数的便捷方法。
getBytes(int, int, byte[], int) - 类 java.lang.String 中的方法
已过时。 该方法无法将字符正确转换为字节。从 JDK 1.1 起，完成该转换的首选方法是通过 String.getBytes() 方法，该方法使用平台的默认字符集。
getBytes(String) - 类 java.lang.String 中的方法
使用指定的字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。
getBytes(Charset) - 类 java.lang.String 中的方法
使用给定的 charset 将此 String 编码到 byte 序列，并将结果存储到新的 byte 数组。
getBytes() - 类 java.lang.String 中的方法
使用平台的默认字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。
getBytes(long, int) - 接口 java.sql.Blob 中的方法
以 byte 数组的形式获取此 Blob 对象表示的全部或部分 BLOB 值。
getBytes(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 byte 数组值的形式获取指定的 JDBC BINARY 或 VARBINARY 参数的值。
getBytes(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 byte 数组值的形式获取 JDBC BINARY 或 VARBINARY 参数的值。
getBytes(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
getBytes(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
getBytes() - 接口 java.sql.RowId 中的方法
返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 byte 数组。
getBytes(long, int) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
将指定的字节数（从给定位置开始）从此 SerialBlob 对象复制到另一个字节数组。
getBytesRead() - 类 java.util.zip.Deflater 中的方法
返回到目前为止输入未压缩字节的总数。
getBytesRead() - 类 java.util.zip.Inflater 中的方法
返回到目前为止输入压缩字节的总数。
getByteStream() - 接口 org.w3c.dom.ls.LSInput 中的方法
依赖于语言和绑定类型的属性，表示字节的流。
getByteStream() - 接口 org.w3c.dom.ls.LSOutput 中的方法
具有语言和绑定依赖性类型的属性，表示字节的可写流。
getByteStream() - 类 org.xml.sax.InputSource 中的方法
获取此输入源的字节流。
getBytesWritten() - 类 java.util.zip.Deflater 中的方法
返回到目前为止输出压缩字节的总数。
getBytesWritten() - 类 java.util.zip.Inflater 中的方法
返回到目前为止输出未压缩字节的总数。
getCA() - 类 java.security.cert.TrustAnchor 中的方法
以 X500Principal 的形式返回最受信任的 CA 的名称。
getCachedIcon(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getCacheDirectory() - 类 javax.imageio.ImageIO 中的静态方法
返回由 setCacheDirectory 设置的当前值；如果没有显式设置该值，则返回 null。
getCachedMBeanInfo() - 类 javax.management.StandardMBean 中的方法
自定义钩子：返回为此对象缓存的 MBeanInfo。
getCalculatedDigestValue() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回执行验证操作后计算的此 Reference 的摘要值。
getCalendar() - 类 java.text.DateFormat 中的方法
获取与此日期/时间格式器关联的日历。
getCalendarField() - 类 java.text.DateFormat.Field 中的方法
返回与此属性关联的 Calendar 字段。
getCalendarField() - 类 javax.swing.SpinnerDateModel 中的方法
返回由 nextValue 和 previousValue 方法添加或去掉的 Calendar 字段。
getCallback() - 异常 javax.security.auth.callback.UnsupportedCallbackException 中的方法
获取未识别的 Callback。
getCallbackHandler() - 类 java.security.KeyStore.CallbackHandlerProtection 中的方法
返回 CallbackHandler。
getCAName() - 类 java.security.cert.TrustAnchor 中的方法
以 RFC 2253 String 格式返回最受信任的 CA 的名称。
getCancelable() - 接口 org.w3c.dom.events.Event 中的方法
用于指示事件是否可以阻止其默认操作。
getCancelSelectionAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getCandidateLocales(String, Locale) - 类 java.util.ResourceBundle.Control 中的方法
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。
getCanonicalFile() - 类 java.io.File 中的方法
返回此抽象路径名的规范形式。
getCanonicalHostName() - 类 java.net.InetAddress 中的方法
获取此 IP 地址的完全限定域名。
getCanonicalizationMethod() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
返回此 SignedInfo 的规范化方法。
getCanonicalizedData() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
在执行签名或验证操作后，返回规范化的签名信息字节。
getCanonicalKeyPropertyListString() - 类 javax.management.ObjectName 中的方法
返回键属性列表的字符串表示形式，其中键属性按词汇顺序排序。
getCanonicalName() - 类 java.lang.Class 中的方法
返回 Java Language Specification 中所定义的底层类的规范化名称。
getCanonicalName() - 类 javax.management.ObjectName 中的方法
返回该名称的规范形式；也就是说，一种字符串表示形式，其中属性按词汇顺序排序。
getCanonicalPath() - 类 java.io.File 中的方法
返回此抽象路径名的规范路径名字符串。
getCanWrapLines() - 类 javax.swing.text.AbstractWriter 中的方法
返回是否可以换行。
getCapabilities() - 类 java.awt.Component.BltBufferStrategy 中的方法

getCapabilities() - 类 java.awt.Component.FlipBufferStrategy 中的方法

getCapabilities() - 类 java.awt.image.BufferStrategy 中的方法
返回此 BufferStrategy 的 BufferCapabilities。
getCapabilities(GraphicsConfiguration) - 类 java.awt.Image 中的方法
返回 ImageCapabilities 对象，查询该对象便可以了解使用指定 GraphicsConfiguration 时此 Image 的功能。
getCapabilities() - 类 java.awt.image.VolatileImage 中的方法
返回 ImageCapabilities 对象，查询此对象即可了解此 VolatileImage 的特定功能。
getCAPublicKey() - 类 java.security.cert.TrustAnchor 中的方法
返回最受信任的 CA 的公钥。
getCaret() - 类 java.awt.event.InputMethodEvent 中的方法
获取插入符。
getCaret() - 类 javax.swing.text.JTextComponent 中的方法
获取允许在视图上进行面向文本导航的插入符。
getCaret() - 类 javax.swing.text.NavigationFilter.FilterBypass 中的方法
返回不断变化的 Caret。
getCaretColor() - 类 javax.swing.text.JTextComponent 中的方法
获取用于呈现插入符的当前颜色。
getCaretInfo(TextHitInfo, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回与对应于 hit 的插入符有关的信息。
getCaretInfo(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回与对应于 hit 的插入符有关的信息。
getCaretListeners() - 类 javax.swing.text.JTextComponent 中的方法
返回在此文本组件上已注册的所有插入符侦听器的数组。
getCaretPosition() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回插入记号的从零开始的偏移量。
getCaretPosition() - 类 java.awt.TextComponent 中的方法
返回文本插入符的位置。
getCaretPosition() - 接口 javax.accessibility.AccessibleText 中的方法
返回插入符从 0 开始的偏移量。
getCaretPosition() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回插入符号的从零开始的偏移量。
getCaretPosition() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回从 0 开始的插入符号偏移量。
getCaretPosition() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回从 0 开始的插入符号偏移量。
getCaretPosition() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回插入符号的从零开始的偏移量。
getCaretPosition() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回插入符的从零开始的偏移量。
getCaretPosition() - 类 javax.swing.text.JTextComponent 中的方法
返回文本组件的文本插入符的位置。
getCaretShape(TextHitInfo, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回表示指定边界内指定目标字符处插入符的 Shape。
getCaretShape(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回表示此 TextLayout 的自然边界中指定目标字符处插入符的 Shape。
getCaretShapes(int, Rectangle2D, TextLayout.CaretPolicy) - 类 java.awt.font.TextLayout 中的方法
返回对应于强插入符和弱插入符的两条路径。
getCaretShapes(int, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回对应于强插入符和弱插入符的两条路径。
getCaretShapes(int) - 类 java.awt.font.TextLayout 中的方法
返回对应于强插入符和弱插入符的两条路径。
getCatalog() - 接口 java.sql.Connection 中的方法
获取此 Connection 对象的当前目录名称。
getCatalogName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的表目录名称。
getCatalogName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取派生指定列中值的表的类别名称。
getCatalogs() - 接口 java.sql.DatabaseMetaData 中的方法
获取可在此数据库中使用的类别名称。
getCatalogSeparator() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库用作类别和表名之间的分隔符的 String。
getCatalogTerm() - 接口 java.sql.DatabaseMetaData 中的方法
获取数据库供应商用于 "catalog" 的首选术语。
getCategories() - 类 javax.imageio.spi.ServiceRegistry 中的方法
返回指示当前类别集的 Class 对象的 Iterator。
getCategory() - 接口 javax.print.attribute.Attribute 中的方法
将此打印属性值添加到属性集时，为它获取用作“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Chromaticity 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.ColorSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Compression 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Copies 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.CopiesSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.DateTimeAtCompleted 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.DateTimeAtCreation 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.DateTimeAtProcessing 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Destination 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.DocumentName 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Fidelity 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Finishings 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobHoldUntil 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobImpressions 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobImpressionsCompleted 中的方法
获取被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobImpressionsSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobKOctets 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobKOctetsProcessed 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobKOctetsSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobMediaSheets 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobMediaSheetsCompleted 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobMediaSheetsSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobMessageFromOperator 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobName 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobOriginatingUserName 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobPriority 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobPrioritySupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobSheets 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobState 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobStateReason 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.JobStateReasons 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Media 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.MediaSize 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.NumberOfDocuments 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.NumberOfInterveningJobs 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.NumberUp 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.NumberUpSupported 中的方法
获取将被用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.OutputDeviceAssigned 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PageRanges 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PagesPerMinute 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PagesPerMinuteColor 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PDLOverrideSupported 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PresentationDirection 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterInfo 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterLocation 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterMakeAndModel 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterMessageFromOperator 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterMoreInfo 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterName 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterResolution 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterState 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterStateReason 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterStateReasons 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrinterURI 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.PrintQuality 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.QueuedJobCount 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.RequestingUserName 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Severity 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.SheetCollate 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCategory() - 类 javax.print.attribute.standard.Sides 中的方法
获取将用作此打印属性值的“类别”的打印属性类。
getCause() - 异常 java.awt.print.PrinterIOException 中的方法
返回此异常的 cause（终止打印作业的 IOException）。
getCause() - 异常 java.io.WriteAbortedException 中的方法
返回终止操作的异常（即 cause）。
getCause() - 异常 java.lang.ClassNotFoundException 中的方法
返回此异常的原因（尝试加载类时发生错误引发的异常；否则返回 null）。
getCause() - 错误 java.lang.ExceptionInInitializerError 中的方法
返回导致该错误的原因（导致发生此错误的静态初始化期间发生的异常）。
getCause() - 异常 java.lang.reflect.InvocationTargetException 中的方法
返回此异常的原因（抛出的目标异常，可能为 null）。
getCause() - 异常 java.lang.reflect.UndeclaredThrowableException 中的方法
返回此异常的原因（此 UndeclaredThrowableException 中包装的 Throwable 实例，可能为 null）。
getCause() - 类 java.lang.Throwable 中的方法
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
getCause() - 异常 java.rmi.activation.ActivationException 中的方法
返回此异常的原因。
getCause() - 异常 java.rmi.RemoteException 中的方法
返回此异常的原因。
getCause() - 异常 java.rmi.server.ServerCloneException 中的方法
返回此异常的原因。
getCause() - 异常 java.security.PrivilegedActionException 中的方法
返回此异常（特权计算抛出的异常，该异常导致此 PrivilegedActionException）的 cause。
getCause() - 异常 javax.management.MBeanException 中的方法
返回实际抛出的 Exception。
getCause() - 异常 javax.management.ReflectionException 中的方法
返回抛出的实际 Exception。
getCause() - 异常 javax.management.remote.JMXProviderException 中的方法

getCause() - 异常 javax.management.remote.JMXServerErrorException 中的方法

getCause() - 异常 javax.management.RuntimeErrorException 中的方法
返回抛出的实际 Error。
getCause() - 异常 javax.management.RuntimeMBeanException 中的方法
返回抛出的实际 RuntimeException。
getCause() - 异常 javax.management.RuntimeOperationsException 中的方法
返回抛出的实际 RuntimeException。
getCause() - 异常 javax.naming.NamingException 中的方法
返回此异常的 cause。
getCause() - 异常 javax.security.sasl.SaslException 中的方法

getCause() - 异常 javax.xml.bind.JAXBException 中的方法

getCause() - 异常 javax.xml.crypto.dsig.TransformException 中的方法
返回此 TransformException 的 cause，如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.dsig.XMLSignatureException 中的方法
返回此 XMLSignatureException 的 cause；如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.KeySelectorException 中的方法
返回此 KeySelectorException 的 cause，如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.MarshalException 中的方法
返回此 MarshalException 的 cause；如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.NoSuchMechanismException 中的方法
返回此 NoSuchMechanismException 的 cause，如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.crypto.URIReferenceException 中的方法
返回此 URIReferenceException 的 cause，如果 cause 不存在或未知，则返回 null。
getCause() - 异常 javax.xml.soap.SOAPException 中的方法
返回此 SOAPException 中嵌入的 Throwable 对象（如果有）。
getCause() - 异常 javax.xml.transform.TransformerException 中的方法
返回此抛出对象的原因，如果原因不存在或未知，则返回 null。
getCause() - 异常 javax.xml.xpath.XPathException 中的方法
获取此 XPathException 的 cause。
getCellBounds(int, int) - 类 javax.swing.JList 中的方法
返回列表的坐标系统中两个索引所指定单元范围内的边界矩形。
getCellBounds(JList, int, int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
getCellBounds(JList, int, int) - 类 javax.swing.plaf.ListUI 中的方法
返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
getCellBounds(JList, int, int) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getCellBounds 方法。
getCellEditor() - 类 javax.swing.JTable 中的方法
返回活动单元格编辑器；如果该表当前没有被编辑，则返回 null。
getCellEditor(int, int) - 类 javax.swing.JTable 中的方法
返回适用于由 row 和 column 所指定单元格的编辑器。
getCellEditor() - 类 javax.swing.JTree 中的方法
返回用于编辑树中条目的编辑器。
getCellEditor() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getCellEditor() - 类 javax.swing.table.TableColumn 中的方法
返回 JTable 用于编辑此列各值的 TableCellEditor。
getCellEditorListeners() - 类 javax.swing.AbstractCellEditor 中的方法
返回使用 addCellEditorListener() 添加到此 AbstractCellEditor 中的所有 CellEditorListener 组成的数组。
getCellEditorListeners() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
返回使用 addCellEditorListener() 添加到此 DefaultTreeCellEditor 中的所有 CellEditorListener 组成的数组。
getCellEditorValue() - 接口 javax.swing.CellEditor 中的方法
返回编辑器中包含的值。
getCellEditorValue() - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
返回此单元格的值。
getCellEditorValue() - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
getCellEditorValue() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
返回当前正在编辑的值。
getCellLength() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回要在进度条中呈现的每个单个单元格/单元的宽度（如果为 HORIZONTAL）或高度（如果为 VERTICAL）。
getCellRect(int, int, boolean) - 类 javax.swing.JTable 中的方法
返回位于 row 和 column 相交位置的单元格矩形。
getCellRenderer() - 类 javax.swing.JList 中的方法
返回负责绘制列表项的对象。
getCellRenderer(int, int) - 类 javax.swing.JTable 中的方法
返回适于由此行和列所指定单元格的渲染器。
getCellRenderer() - 类 javax.swing.JTree 中的方法
返回正在呈现每个单元格的当前 TreeCellRenderer。
getCellRenderer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回 currentCellRenderer，可以为树渲染器，也可以为 defaultCellRenderer，无论哪个都不为 null。
getCellRenderer() - 类 javax.swing.table.TableColumn 中的方法
返回 JTable 用于绘制此列各值的 TableCellRenderer。
getCellSelectionEnabled() - 类 javax.swing.JTable 中的方法
如果同时启用了行选择模型和列选择模型，则返回 true。
getCellSpacing() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回进度条中每个单元格/单元之间的间隔。
getCenterPoint() - 类 java.awt.GraphicsEnvironment 中的方法
返回 Windows 应居中的点。
getCenterPoint() - 类 java.awt.RadialGradientPaint 中的方法
返回辐射状渐变中心点的副本。
getCentersChildren() - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法

getCenterX() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 的窗体矩形中心的 X 坐标。
getCenterY() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 的窗体矩形中心的 Y 坐标。
getCertificate() - 类 java.security.cert.X509CertSelector 中的方法
返回 certificateEquals 标准。
getCertificate(String) - 类 java.security.KeyStore 中的方法
返回与给定别名关联的证书。
getCertificate() - 类 java.security.KeyStore.PrivateKeyEntry 中的方法
从此项中的证书链获取终端实体 Certificate。
getCertificate() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
返回 X.509 证书。
getCertificateAlias(Certificate) - 类 java.security.KeyStore 中的方法
返回证书与给定证书匹配的第一个 keystore 条目的别名。
getCertificateChain(String) - 类 java.security.KeyStore 中的方法
返回与给定别名关联的证书链。
getCertificateChain() - 类 java.security.KeyStore.PrivateKeyEntry 中的方法
从此项获取 Certificate 链。
getCertificateChain(String) - 接口 javax.net.ssl.X509KeyManager 中的方法
返回与给定别名关联的证书链。
getCertificateChecking() - 类 java.security.cert.X509CRLSelector 中的方法
返回要检查的证书。
getCertificateIssuer() - 类 java.security.cert.X509CRLEntry 中的方法
获取此项所描述的 X509Certificate 的发布方。
getCertificates() - 类 java.net.JarURLConnection 中的方法
如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。
getCertificates() - 类 java.security.cert.CertPath 中的方法
返回此证书路径中的证书列表。
getCertificates(CertSelector) - 类 java.security.cert.CertStore 中的方法
返回与指定选择器匹配的 Certificate 的 Collection。
getCertificates() - 类 java.security.CodeSource 中的方法
返回与此 CodeSource 关联的证书。
getCertificates() - 类 java.util.jar.JarEntry 中的方法
返回此条目的 Certificate 对象；如果没有，则返回 null。
getCertificateValid() - 类 java.security.cert.X509CertSelector 中的方法
返回 certificateValid 标准。
getCertifiedText() - 接口 org.w3c.dom.ls.LSInput 中的方法
如果设置为 true，则假定解析 [XML 1.1] 时对输入进行认证（请参阅 [XML 1.1] 中的 2.13 节）。
getCertPath() - 接口 java.security.cert.CertPathBuilderResult 中的方法
返回已构建的证书路径。
getCertPath() - 异常 java.security.cert.CertPathValidatorException 中的方法
返回抛出异常时正在验证的证书路径
getCertPath() - 类 java.security.cert.PKIXCertPathBuilderResult 中的方法
返回已构建并已验证的证书路径。
getCertPathCheckers() - 类 java.security.cert.PKIXParameters 中的方法
返回证书路径检查器的 List。
getCertPathEncodings() - 类 java.security.cert.CertificateFactory 中的方法
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
getCertStoreParameters() - 类 java.security.cert.CertStore 中的方法
返回初始化此 CertStore 所用的参数。
getCertStores() - 类 java.security.cert.PKIXParameters 中的方法
返回用于查找证书和 CRL 的不可变 CertStore List。
getChange(Element) - 接口 javax.swing.event.DocumentEvent 中的方法
获得给定元素的更改信息。
getChange(Element) - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
获得元素的更改。
getChanged() - 类 java.awt.event.HierarchyEvent 中的方法
返回位于被更改层次结构顶部的 Component。
getChangedParent() - 类 java.awt.event.HierarchyEvent 中的方法
返回由 getChanged() 返回的 Component 的父级。
getChangeFlags() - 类 java.awt.event.HierarchyEvent 中的方法
返回指示此事件对象中表示的 HIERARCHY_CHANGED 事件类型的位掩码。
getChangeInfo() - 类 javax.naming.event.NamingEvent 中的方法
检索此事件的更改信息。
getChangeListeners() - 类 javax.swing.AbstractButton 中的方法
返回使用 addChangeListener() 添加到此 AbstractButton 中的所有 ChangeListener 组成的数组。
getChangeListeners() - 类 javax.swing.AbstractSpinnerModel 中的方法
返回使用 addChangeListener() 添加到此 AbstractSpinnerModel 中的所有 ChangeListener 组成的数组。
getChangeListeners() - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
返回一个使用 addChangeListener 添加到此 DefaultColorSelectionModel 中的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回此 DefaultBoundedRangeModel 上所有已注册的更改侦听器组成的数组。
getChangeListeners() - 类 javax.swing.DefaultButtonModel 中的方法
返回此 DefaultButtonModel 上所有已注册的更改侦听器组成的数组。
getChangeListeners() - 类 javax.swing.DefaultSingleSelectionModel 中的方法
返回此 DefaultSingleSelectionModel 上所有已注册的更改侦听器组成的数组。
getChangeListeners() - 类 javax.swing.JProgressBar 中的方法
返回通过 addChangeListener 添加到此进度条的所有 ChangeListener 组成的数组。
getChangeListeners() - 类 javax.swing.JSlider 中的方法
返回一个通过 addChangeListener() 方法添加此 JSlider 的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.JSpinner 中的方法
返回一个通过 addChangeListener() 方法添加到此 JSpinner 的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.JTabbedPane 中的方法
返回通过 addChangeListener 方法添加到此 JTabbedPane 中的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.JViewport 中的方法
返回使用 addChangeListener() 添加到此 JViewport 的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.MenuSelectionManager 中的方法
返回使用 addChangeListener() 添加到此 MenuSelectionManager 的所有 ChangeListener 的数组。
getChangeListeners() - 类 javax.swing.text.DefaultCaret 中的方法
返回此插入符上所有已注册的更改侦听器组成的数组。
getChangeListeners() - 类 javax.swing.text.StyleContext 中的方法
返回使用 addChangeListener() 添加到此 StyleContext 中的所有 ChangeListener 组成的数组。
getChangeListeners() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
返回使用 addChangeListener() 添加到此 NamedStyle 中的所有 ChangeListener 组成的数组。
getChangeToParentDirectoryAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getChannel() - 类 java.io.FileInputStream 中的方法
返回与此文件输入流有关的唯一 FileChannel 对象。
getChannel() - 类 java.io.FileOutputStream 中的方法
返回与此文件输出流有关的唯一 FileChannel 对象。
getChannel() - 类 java.io.RandomAccessFile 中的方法
返回与此文件关联的唯一 FileChannel 对象。
getChannel() - 类 java.net.DatagramSocket 中的方法
返回与此数据报套接字关联的唯一 DatagramChannel 对象（如果有）。
getChannel() - 类 java.net.ServerSocket 中的方法
返回与此套接字关联的唯一 ServerSocketChannel 对象（如果有）。
getChannel() - 类 java.net.Socket 中的方法
返回与此数据报套接字关联的唯一 SocketChannel 对象（如果有）。
getChannel() - 类 javax.sound.midi.ShortMessage 中的方法
获取与此事件关联的 MIDI 通道。
getChannelPressure() - 接口 javax.sound.midi.MidiChannel 中的方法
获得通道的键盘力度。
getChannels() - 接口 javax.sound.midi.Synthesizer 中的方法
获得此合成器控制的一组 MIDI 通道。
getChannels() - 类 javax.sound.sampled.AudioFormat 中的方法
获取信道数。
getChar(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 char 形式返回指定数组对象中索引组件的值。
getChar(Object) - 类 java.lang.reflect.Field 中的方法
获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。
getChar() - 类 java.nio.ByteBuffer 中的方法
用于读取 char 值的相对 get 方法。
getChar(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 char 值的绝对 get 方法。
getCharacterAttribute(int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回给定字符（位于给定索引处）的 AttributeSet。
getCharacterAttribute(int) - 接口 javax.accessibility.AccessibleText 中的方法
返回给定索引处给定字符的 AttributeSet
getCharacterAttribute(int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回位于给定索引处的给定字符的 AttributeSet。
getCharacterAttribute(int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回给定索引处给定字符的 AttributeSet
getCharacterAttribute(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回给定索引处给定字符的 AttributeSet
getCharacterAttribute(int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回位于给定索引处的给定字符的 AttributeSet
getCharacterAttribute(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定字符（位于给定索引处）的 AttributeSet。
getCharacterAttributeRun() - 类 javax.swing.text.StyledEditorKit 中的方法
获取表示该插入符处当前运行的字符属性的元素。
getCharacterAttributes() - 类 javax.swing.JTextPane 中的方法
获取在当前插入符号位置的有效字符属性，或者 null。
getCharacterBounds(int) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterBounds(int) - 接口 javax.accessibility.AccessibleText 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterBounds(int) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterBounds(int) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
确定给定字符串索引处字符的边界框。
getCharacterBounds(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
确定给定字符串索引处字符的边界。
getCharacterBounds(int) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterBounds(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
确定字符串中给定索引处的字符的边界框。
getCharacterCount() - 类 java.awt.font.TextLayout 中的方法
返回由此 TextLayout 表示的字符数。
getCharacterElement(int) - 类 javax.swing.text.DefaultStyledDocument 中的方法
获得基于某个位置的字符元素。
getCharacterElement(int) - 接口 javax.swing.text.StyledDocument 中的方法
获取表示文档中给定偏移量处字符的元素。
getCharacterEncodingScheme() - 接口 javax.xml.stream.events.StartDocument 中的方法
返回 XML 数据的编码样式
getCharacterEncodingScheme() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getCharacterEncodingScheme() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回 xml 声明中声明的字符编码。
getCharacterInstance() - 类 java.text.BreakIterator 中的静态方法
返回一个用于默认语言环境 字符分解的新 BreakIterator 实例。
getCharacterInstance(Locale) - 类 java.text.BreakIterator 中的静态方法
返回一个用于给定语言环境字符分解的新 BreakIterator 实例。
getCharacterInstance(Locale) - 类 java.text.spi.BreakIteratorProvider 中的方法
为给定语言环境的字符分解返回新的 BreakIterator 实例。
getCharacterLevel(int) - 类 java.awt.font.TextLayout 中的方法
返回 index 处字符的级别。
getCharacterOffset() - 接口 javax.xml.stream.Location 中的方法
返回此位置所指向的输入源中的字节或字符偏移量。
getCharacterStream(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
getCharacterStream(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
getCharacterStream() - 接口 java.sql.Clob 中的方法
以 java.io.Reader 对象形式（或字符流形式）获取此 Clob 对象指定的 CLOB 值。
getCharacterStream(long, long) - 接口 java.sql.Clob 中的方法
返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。
getCharacterStream(int) - 接口 java.sql.ResultSet 中的方法
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getCharacterStream(String) - 接口 java.sql.ResultSet 中的方法
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getCharacterStream() - 接口 java.sql.SQLXML 中的方法
以 java.io.Reader 对象的形式获取此 SQLXML 实例指定的 XML 值。
getCharacterStream() - 类 javax.sql.rowset.serial.SerialClob 中的方法
以 Unicode 字符流的形式返回此 SerialClob 对象的数据。
getCharacterStream(long, long) - 类 javax.sql.rowset.serial.SerialClob 中的方法

getCharacterStream() - 接口 org.w3c.dom.ls.LSInput 中的方法
依赖于语言和绑定类型的属性，表示 16 位单元流。
getCharacterStream() - 接口 org.w3c.dom.ls.LSOutput 中的方法
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。
getCharacterStream() - 类 org.xml.sax.InputSource 中的方法
获取此输入源的字符流。
getCharContent(boolean) - 接口 javax.tools.FileObject 中的方法
返回此文件对象的字符内容（如果有）。
getCharContent(boolean) - 类 javax.tools.ForwardingFileObject 中的方法

getCharContent(boolean) - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现总是抛出 UnsupportedOperationException。
getCharCount() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回字符（有效索引）的数量
getCharCount() - 接口 javax.accessibility.AccessibleText 中的方法
返回字符（有效索引）数
getCharCount() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回字符（有效索引）的数量
getCharCount() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回字符（有效索引）数。
getCharCount() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回字符（有效索引）数。
getCharCount() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回字符（有效索引）的数量
getCharCount() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回字符（有效索引）的数量
getCharIndex() - 类 java.awt.font.TextHitInfo 中的方法
返回目标字符的索引。
getCharParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 char 返回参数的便捷方法。
getChars(int, int, char[], int) - 类 java.lang.String 中的方法
将字符从此字符串复制到目标字符数组。
getChars(int, int, char[], int) - 类 java.lang.StringBuffer 中的方法

getChars(int, int, Segment) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
获得字符序列并将其复制到 Segment 中。
getChars(int, int, Segment) - 类 javax.swing.text.GapContent 中的方法
检索部分内容。
getChars(int, int, Segment) - 类 javax.swing.text.StringContent 中的方法
检索内容的某一部分，where ＋ len 必须 <= length()
getCharsetName() - 异常 java.nio.charset.IllegalCharsetNameException 中的方法
获取非法的 charset 名称。
getCharsetName() - 异常 java.nio.charset.UnsupportedCharsetException 中的方法
获取不受支持的 charset 的名称。
getCharSetSpec() - 异常 javax.swing.text.ChangedCharSetException 中的方法

getCheckboxGroup() - 类 java.awt.Checkbox 中的方法
确定此复选框的组。
getCheckBoxIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getCheckBoxIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法
返回一个复选框图标。
getCheckBoxMenuItemIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getCheckBoxMenuItemIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getChecksum() - 类 java.util.zip.CheckedInputStream 中的方法
返回此输入流的校验和。
getChecksum() - 类 java.util.zip.CheckedOutputStream 中的方法
返回此输出流的校验和。
getChild() - 类 java.awt.event.ContainerEvent 中的方法
返回受事件影响的组件。
getChild(String) - 类 java.util.prefs.AbstractPreferences 中的方法
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。
getChild() - 类 java.util.prefs.NodeChangeEvent 中的方法
返回添加或移除的节点。
getChild(File, String) - 类 javax.swing.filechooser.FileSystemView 中的方法

getChild(Object, int) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回父节点的子节点数组中索引 index 处的 parent 的子节点。
getChild(Object, int) - 接口 javax.swing.tree.TreeModel 中的方法
返回父节点的子数组中索引 index 位置的 parent 的子节点。
getChildAfter(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数组中刚好跟在 aChild 之后的子节点，它必须是此节点的子节点。
getChildAllocation(int, Shape) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
获取用于子视图的分配区域。
getChildAllocation(int) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
获取用于子视图的分配区域。
getChildAllocation(int, Shape) - 类 javax.swing.text.AsyncBoxView 中的方法
获取给定子视图的分配区域。
getChildAllocation(int, Shape) - 类 javax.swing.text.BoxView 中的方法
获取给定子视图的分配。
getChildAllocation(int, Shape) - 类 javax.swing.text.CompositeView 中的方法
获取要在其中呈现的给定子视图的分配区域。
getChildAllocation(int, Shape) - 类 javax.swing.text.View 中的方法
获取给定子视图的分配。
getChildAt(int) - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
必要时创建子类以加载此子节点。
getChildAt(int) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
在索引 childIndex 处返回子级 TreeNode。
getChildAt(int) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数组中指定索引处的子节点。
getChildAt(int) - 接口 javax.swing.tree.TreeNode 中的方法
返回索引 childIndex 位置的子 TreeNode。
getChildBeanContextChild(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
与指定 Child 相关联的 BeanContextChild（如果有）。
getChildBeanContextMembershipListener(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
与指定 Child 相关联的 BeanContextMembershipListener（如果有）。
getChildBeanContextServicesListener(Object) - 类 java.beans.beancontext.BeanContextServicesSupport 中的静态方法
获得指定子级的 BeanContextServicesListener（如果有）。
getChildBefore(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数组中刚好在 aChild 之前的子节点，它必须是此节点的子节点。
getChildCount() - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
返回子节点数。
getChildCount() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
返回接受方所包含的子级 TreeNode 的数量。
getChildCount() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数。
getChildCount(Object) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回 parent 的子节点数。
getChildCount(Object) - 接口 javax.swing.tree.TreeModel 中的方法
返回 parent 的子节点数。
getChildCount() - 接口 javax.swing.tree.TreeNode 中的方法
返回接收者包含的子 TreeNode 数。
getChildElements() - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在此元素的所有直接子 Node 上进行迭代的 Iterator。
getChildElements(Name) - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在带有指定名称的此元素所有直接子 Node 上进行迭代的 Iterator。
getChildElements(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在带有指定 qname 的此元素所有直接子 Node 上进行迭代的 Iterator。
getChildIndex() - 类 javax.swing.JTree.DropLocation 中的方法
对于 getPath() 返回的路径，返回应该插入放置数据的位置的索引。
getChildIndices() - 类 javax.swing.event.TreeModelEvent 中的方法
返回子索引的值。
getChildNames(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。
getChildNames(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getChildNodes() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getChildNodes() - 接口 org.w3c.dom.Node 中的方法
包含此节点的所有子节点的 NodeList。
getChildPolicy(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回以 CHILD_POLICY_ 开头的常量之一，指示指定元素子元素的合法模式。
getChildPolicy(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getChildPropertyChangeListener(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
与指定 Child 相关联的 PropertyChangeListener（如果有）
getChildren() - 接口 java.security.cert.PolicyNode 中的方法
返回在此节点的子节点上进行迭代的迭代器。
getChildren() - 类 javax.swing.event.TreeModelEvent 中的方法
返回位于 getChildIndices 指定位置处的、作为 getPath 所标识节点的子节点的对象。
getChildrenAdded() - 接口 javax.swing.event.DocumentEvent.ElementChange 中的方法
获得添加到给定父元素中的子元素。
getChildrenAdded() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
获得已添加的子元素列表。
getChildrenRemoved() - 接口 javax.swing.event.DocumentEvent.ElementChange 中的方法
获得从给定父元素中移除的子元素。
getChildrenRemoved() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
获得已移除的子元素列表。
getChildSerializable(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
获得与指定 Child 相关联的 Serializable（如果有）
getChildState(int) - 类 javax.swing.text.AsyncBoxView 中的方法
获取对象，该对象表示在给定索引位置的子视图的布局状态。
getChildVetoableChangeListener(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
与指定 Child 相关联的 VetoableChangeListener（如果有）。
getChildView() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
获取此记录表示的子视图。
getChildVisibility(Object) - 类 java.beans.beancontext.BeanContextSupport 中的静态方法
获得与指定子级相关联的 Component（如果有）。
getChoices() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取选项列表。
getChoosableFileFilters() - 类 javax.swing.JFileChooser 中的方法
获得用户可选择的文件过滤器列表。
getChooserPanels() - 类 javax.swing.JColorChooser 中的方法
返回指定的颜色面板。
getCipherSuite() - 类 java.net.SecureCacheResponse 中的方法
返回正在获得了网络资源的初始连接上使用的密码套件。
getCipherSuite() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回由握手产生的会话所使用的密码套件。
getCipherSuite() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回在此连接上使用的密码套件。
getCipherSuite() - 接口 javax.net.ssl.SSLSession 中的方法
返回会话中的所有连接所使用的 SSL 密码套件的名称。
getCipherSuites() - 类 javax.net.ssl.SSLParameters 中的方法
返回密码套件数组的副本；如果未设置，则返回 null。
getClass() - 类 java.lang.Object 中的方法
返回此 Object 的运行时类。
getClassAnnotation(Class<?>) - 类 java.rmi.server.RMIClassLoader 中的静态方法
返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。
getClassAnnotation(Class<?>) - 类 java.rmi.server.RMIClassLoaderSpi 中的方法
提供 RMIClassLoader.getClassAnnotation(Class) 的实现。
getClassContext() - 类 java.lang.SecurityManager 中的方法
以类数组的形式返回当前执行堆栈。
getClasses() - 类 java.lang.Class 中的方法
返回一个包含某些 Class 对象的数组，这些对象表示属于此 Class 对象所表示的类的成员的所有公共类和接口。
getClassLoader() - 类 java.lang.Class 中的方法
返回该类的类加载器。
getClassLoader(String) - 类 java.rmi.server.RMIClassLoader 中的静态方法
返回从给定的基本代码 URL 路径加载类的类加载器。
getClassLoader(String) - 类 java.rmi.server.RMIClassLoaderSpi 中的方法
提供 RMIClassLoader.getClassLoader(String) 的实现。
getClassLoader() - 类 java.security.ProtectionDomain 中的方法
返回此域的 ClassLoader。
getClassLoader(ObjectName) - 接口 javax.management.MBeanServer 中的方法
返回指定的 ClassLoader。
getClassLoader(JavaFileManager.Location) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getClassLoader(JavaFileManager.Location) - 接口 javax.tools.JavaFileManager 中的方法
获取可从给定位置加载插件的类加载器。
getClassLoaderFor(ObjectName) - 接口 javax.management.MBeanServer 中的方法
返回用于加载指定 MBean 的类的 ClassLoader。
getClassLoaderRepository() - 接口 javax.management.MBeanServer 中的方法
返回此 MBeanServer 的 ClassLoaderRepository。
getClassLoaderRepository(MBeanServer) - 类 javax.management.MBeanServerFactory 中的静态方法
返回给定 MBeanServer 使用的 ClassLoaderRepository。
getClassLoaderRepository() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回用于执行类加载的 Class Loader Repository。
getClassLoadingMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的类加载系统的管理 Bean。
getClassName() - 类 java.lang.management.LockInfo 中的方法
返回锁对象的完全限定类名称。
getClassName() - 类 java.lang.StackTraceElement 中的方法
返回类的完全限定名，该类包含由该堆栈跟踪元素所表示的执行点。
getClassName() - 类 java.rmi.activation.ActivationDesc 中的方法
返回此描述符指定的对象的类名。
getClassName() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的类名（可能为 null）。
getClassName() - 类 java.security.Provider.Service 中的方法
返回实现此服务的类的名称。
getClassName() - 异常 java.util.MissingResourceException 中的方法
获得构造方法所传递的参数。
getClassName() - 类 javax.management.MBeanInfo 中的方法
返回此 MBeanInfo 描述的 MBean 的 Java 类名。
getClassName() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回此 MBeanInfo 所描述的 MBean 的 Java 类名称。
getClassName() - 类 javax.management.ObjectInstance 中的方法
返回类部分。
getClassName() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回此 OpenMBeanInfo 描述的 open MBean 实例的完全限定的 Java 类名。
getClassName() - 类 javax.management.openmbean.OpenType 中的方法
返回此开放类型描述的开放数据值的完全限定的 Java 类名。
getClassName(MBeanInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 className。
getClassName() - 类 javax.naming.Binding 中的方法
检索绑定到此绑定名称的对象的类名称。
getClassName() - 类 javax.naming.NameClassPair 中的方法
检索绑定到此绑定名称的对象的类名称。
getClassName() - 类 javax.naming.Reference 中的方法
检索此引用所引用对象的类名称。
getClassName() - 类 javax.swing.UIManager.LookAndFeelInfo 中的方法
返回实现此外观的类名称。
getClassPath() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回系统类加载器用于搜索类文件的 Java 类路径。
getClickCount() - 类 java.awt.event.MouseEvent 中的方法
返回与此事件关联的鼠标单击次数。
getClickCountToStart() - 类 javax.swing.DefaultCellEditor 中的方法
返回开始编辑所需的单击次数。
getClient() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的客户端主体。
getClientAddresses() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回可从其所指位置使用票据的地址列表。
getClientAliases(String, Principal[]) - 接口 javax.net.ssl.X509KeyManager 中的方法
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。
getClientHost() - 类 java.rmi.server.RemoteServer 中的静态方法
返回一个客户机主机的字符串表示形式，用于在当前线程中正在处理的远程方法调用。
getClientHost() - 接口 java.rmi.server.ServerRef 中的方法
返回当前客户机的主机名。
getClientInfo(String) - 接口 java.sql.Connection 中的方法
返回通过名称指定的客户端信息属性的值。
getClientInfo() - 接口 java.sql.Connection 中的方法
返回一个列表，它包含驱动程序支持的每个客户端信息属性的名称和当前值。
getClientInfoProperties() - 接口 java.sql.DatabaseMetaData 中的方法
获取驱动程序支持的客户端信息属性的列表。
getClientProperty(Object) - 类 javax.swing.JComponent 中的方法
返回具有指定键的属性的值。
getClientSessionContext() - 类 javax.net.ssl.SSLContext 中的方法
返回客户端会话上下文，它表示可供客户端 SSL 套接字握手阶段所使用的 SSL 会话集。
getClientX() - 接口 org.w3c.dom.events.MouseEvent 中的方法
相对于 DOM 实现的客户区域的水平坐标(事件发生在此处)。
getClientY() - 接口 org.w3c.dom.events.MouseEvent 中的方法
相对于 DOM 实现的客户区域的垂直坐标(事件发生在此处)。
getClip() - 类 java.awt.Graphics 中的方法
获取当前剪贴区域。
getClip() - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得可用于回放音频文件或音频流的剪辑。
getClip(Mixer.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
从指定混频器获得可用于回放音频文件或音频流的剪辑。
getClip() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.getClip。
getClipBounds() - 类 java.awt.Graphics 中的方法
返回当前剪贴区域的边界矩形。
getClipBounds(Rectangle) - 类 java.awt.Graphics 中的方法
返回当前剪贴区域的边界矩形。
getClipBounds() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.getClipBounds。
getClipRect() - 类 java.awt.Graphics 中的方法
已过时。 从 JDK version 1.1 开始，由 getClipBounds() 取代。
getClob(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
getClob(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。
getClob(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getClob(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getClosedIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回用于表示没有扩展的非叶节点的图标。
getClosestPathForLocation(int, int) - 类 javax.swing.JTree 中的方法
返回离 x,y 最近的节点的路径。
getClosestPathForLocation(JTree, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回到达最接近于 x,y 的那个节点的路径。
getClosestPathForLocation(JTree, int, int) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getClosestPathForLocation 方法。
getClosestPathForLocation(JTree, int, int) - 类 javax.swing.plaf.TreeUI 中的方法
返回到达最接近于 x,y 的那个节点的路径。
getClosestPositionTo(int, Position.Bias, Shape, int, Position.Bias[], int, int) - 类 javax.swing.text.ParagraphView 中的方法
返回最接近 x 处的模型位置。
getClosestRowForLocation(int, int) - 类 javax.swing.JTree 中的方法
返回离 x,y 最近的节点的行。
getCode() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的 CODE 属性的值。
getCode() - 接口 javax.tools.Diagnostic 中的方法
获取指示诊断类型的诊断代码。
getCodeBase() - 类 java.applet.Applet 中的方法
获得基 URL。
getCodeBase() - 接口 java.applet.AppletStub 中的方法
获取基 URL。
getCodeBase() - 类 javax.management.loading.MLetContent 中的方法
获取代码基 URL。
getCodebase(Class) - 类 javax.rmi.CORBA.Util 中的静态方法
返回给定类的代码基（如果存在）。
getCodebase(Class) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.getCodebase(java.lang.Class) 的委托调用。
getCodePoint() - 异常 java.util.IllegalFormatCodePointException 中的方法
返回 Character.isValidCodePoint(int) 所定义的非法代码点。
getCodeSigners() - 类 java.security.CodeSource 中的方法
返回与此 CodeSource 关联的代码签名者。
getCodeSigners() - 类 java.util.jar.JarEntry 中的方法
返回此条目的 CodeSigner 对象；如果没有，则返回 null。
getCodeSource() - 类 java.security.ProtectionDomain 中的方法
返回此域的 CodeSource。
getCofactor() - 类 java.security.spec.ECParameterSpec 中的方法
返回余因子。
getCollapsedIcon() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getCollationElementIterator(String) - 类 java.text.RuleBasedCollator 中的方法
返回给定 String 的 CollationElementIterator。
getCollationElementIterator(CharacterIterator) - 类 java.text.RuleBasedCollator 中的方法
返回给定 String 的 CollationElementIterator。
getCollationKey(String) - 类 java.text.Collator 中的方法
将该 String 转换为一系列可以和其他 CollationKey 按位进行比较的位。
getCollationKey(String) - 类 java.text.RuleBasedCollator 中的方法
将字符串转换为能够与 CollationKey.compareTo 进行比较的一系列字符。
getCollection() - 类 java.security.cert.CollectionCertStoreParameters 中的方法
返回从中获取 Certificate 和 CRL 的 Collection。
getCollectionCount() - 接口 java.lang.management.GarbageCollectorMXBean 中的方法
返回已发生的回收的总次数。
getCollectionTime() - 接口 java.lang.management.GarbageCollectorMXBean 中的方法
返回近似的累积回收时间（以毫秒为单位）。
getCollectionUsage() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回 Java 虚拟机最近回收了此内存池中的不使用的对象之后的内存使用量。
getCollectionUsageThreshold() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回此内存池的回收使用量阈值（以字节为单位）。
getCollectionUsageThresholdCount() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回 Java 虚拟机已检测到内存使用量达到或超过回收使用量阈值的次数。
getColor(String) - 类 java.awt.Color 中的静态方法
查找系统属性中的一种颜色。
getColor(String, Color) - 类 java.awt.Color 中的静态方法
查找系统属性中的一种颜色。
getColor(String, int) - 类 java.awt.Color 中的静态方法
查找系统属性中的一种颜色。
getColor() - 类 java.awt.Graphics 中的方法
获取此图形上下文的当前颜色。
getColor() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面是以彩色呈现，还是以单色呈现。
getColor() - 类 javax.swing.DebugGraphics 中的方法
返回用于文本绘制操作的 Color。
getColor() - 类 javax.swing.JColorChooser 中的方法
获取颜色选取器的当前颜色值。
getColor(SynthContext, ColorType) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定状态的颜色。
getColor() - 类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 中的方法
返回高亮显示的颜色。
getColor(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Color，则返回它，否则返回 null。
getColor(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。
getColor(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值返回一种颜色。
getColor(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一种颜色。
getColor1() - 类 java.awt.GradientPaint 中的方法
返回点 P1 的颜色 C1。
getColor2() - 类 java.awt.GradientPaint 中的方法
返回点 P2 的颜色 C2。
getColorComponents(float[]) - 类 java.awt.Color 中的方法
根据 Color 的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。
getColorComponents(ColorSpace, float[]) - 类 java.awt.Color 中的方法
根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。
getColorForGap(int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法

getColorForState(SynthContext, ColorType) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定状态的颜色。
getColorFromModel() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回当前所选取的颜色。
getColorModel() - 类 java.awt.Component 中的方法
获取用于在输出设备上显示组件的 ColorModel 实例。
getColorModel() - 类 java.awt.GraphicsConfiguration 中的方法
返回与此 GraphicsConfiguration 关联的 ColorModel。
getColorModel(int) - 类 java.awt.GraphicsConfiguration 中的方法
返回与此 GraphicsConfiguration 关联并支持指定透明度的 ColorModel。
getColorModel() - 类 java.awt.image.BufferedImage 中的方法
返回 ColorModel。
getColorModel() - 类 java.awt.image.PixelGrabber 中的方法
获取该数组中所存储像素的 ColorModel。
getColorModel() - 接口 java.awt.image.RenderedImage 中的方法
返回与此图像相关的 ColorModel。
getColorModel() - 接口 java.awt.PaintContext 中的方法
返回输出的 ColorModel。
getColorModel() - 类 java.awt.Toolkit 中的方法
确定此工具包屏幕的颜色模型。
getColorModel() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回此对象指定的 ColorModel。
getColors() - 类 java.awt.MultipleGradientPaint 中的方法
返回此渐变所使用的颜色数组的副本。
getColorSelectionModel() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回选取器面板正在编辑的模型。
getColorSpace() - 类 java.awt.Color 中的方法
返回此 Color 的 ColorSpace。
getColorSpace() - 类 java.awt.image.ColorModel 中的方法
返回与此 ColorModel 相关的 ColorSpace。
getColorSpace() - 类 java.awt.MultipleGradientPaint 中的方法
返回指定用于插值的颜色空间的枚举类型。
getColorSpaceType() - 类 java.awt.color.ICC_Profile 中的方法
返回颜色空间类型。
getColumn() - 类 javax.swing.event.TableModelEvent 中的方法
返回事件的列。
getColumn() - 类 javax.swing.JTable.DropLocation 中的方法
返回表中应该用来放入放置项的列索引。
getColumn(Object) - 类 javax.swing.JTable 中的方法
返回表中列的 TableColumn 对象，当使用 equals 进行比较时，表的标识符等于 identifier。
getColumn() - 类 javax.swing.RowSorter.SortKey 中的方法
返回列的索引。
getColumn(int) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回 columnIndex 处列的 TableColumn 对象。
getColumn(int) - 接口 javax.swing.table.TableColumnModel 中的方法
返回 columnIndex 位置列的 TableColumn 对象。
getColumnClass(int) - 类 javax.swing.JTable 中的方法
返回出现在视图中 column 列位置处的列类型。
getColumnClass(int) - 类 javax.swing.table.AbstractTableModel 中的方法
返回 Object.class 而不管 columnIndex 是多少。
getColumnClass(int) - 接口 javax.swing.table.TableModel 中的方法
针对列中所有的单元格值，返回最具体的超类。
getColumnClassName(int) - 接口 java.sql.ResultSetMetaData 中的方法
如果调用方法 ResultSet.getObject 从列中获取值，则返回构造其实例的 Java 类的完全限定名称。
getColumnClassName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取 Java 编程语言中一个类的完全限定名，该类是指定列中的值将映射到的那个类。
getColumnCount() - 接口 java.sql.ResultSetMetaData 中的方法
返回此 ResultSet 对象中的列数。
getColumnCount() - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中的列数。
getColumnCount() - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回模型中的列数。
getColumnCount() - 类 javax.swing.JTable 中的方法
返回列模型中的列数。
getColumnCount() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回 tableColumns 数组中的列数。
getColumnCount() - 类 javax.swing.table.DefaultTableModel 中的方法
返回此数据表中的列数。
getColumnCount() - 接口 javax.swing.table.TableColumnModel 中的方法
返回该模型中的列数。
getColumnCount() - 接口 javax.swing.table.TableModel 中的方法
返回该模型中的列数。
getColumnCount() - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 获取此单元格所跨的列数（即网格宽度）。
getColumnDisplaySize(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定列的最大标准宽度，以字符为单位。
getColumnDisplaySize(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取以 char 为单位的指定列的正常最大宽度。
getColumnHeader() - 类 javax.swing.JScrollPane 中的方法
返回列标题。
getColumnHeader() - 类 javax.swing.ScrollPaneLayout 中的方法
返回列标题对应的 JViewport 对象。
getColumnIndex(Object) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回 tableColumns 数组中第一列的索引，当使用 equals 进行比较时，该列的标识符等于 identifier。
getColumnIndex(Object) - 接口 javax.swing.table.TableColumnModel 中的方法
返回该表中首列的索引，使用 equals 进行比较时，该列的标识符等于 identifier。
getColumnIndexAtX(int) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回位于 x 处列的索引，如果该点处没有列，则返回 -1。
getColumnIndexAtX(int) - 接口 javax.swing.table.TableColumnModel 中的方法
返回位于该水平点 xPosition 位置列的索引；如果该点位于任何列边界外，则返回 -1。
getColumnLabel(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取用于打印输出和显示的指定列的建议标题。
getColumnLabel(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取用于打印输出和显示的指定列的建议列标题。
getColumnMargin() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回 TableColumn 的空白宽度。
getColumnMargin() - 接口 javax.swing.table.TableColumnModel 中的方法
返回每列中单元格之间的宽度。
getColumnModel() - 类 javax.swing.JTable 中的方法
返回包含此表所有列信息的 TableColumnModel。
getColumnModel() - 类 javax.swing.table.JTableHeader 中的方法
返回包含此表头所有列信息的 TableColumnModel。
getColumnModelListeners() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回一个包含在此模型上注册的所有列模型侦听器的数组。
getColumnName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的名称。
getColumnName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取指定列的名称。
getColumnName(int) - 类 javax.swing.JTable 中的方法
返回出现在视图中 column 列位置处的列名称。
getColumnName(int) - 类 javax.swing.table.AbstractTableModel 中的方法
返回列默认名称，其中列使用以下工作表约定：A、B、C……Z、AA、AB 等等。
getColumnName(int) - 类 javax.swing.table.DefaultTableModel 中的方法
返回列名称。
getColumnName(int) - 接口 javax.swing.table.TableModel 中的方法
返回 columnIndex 位置的列的名称。
getColumnNumber() - 异常 javax.script.ScriptException 中的方法
获取发生错误的列号。
getColumnNumber() - 接口 javax.tools.Diagnostic 中的方法
返回由 Diagnostic.getPosition() 返回的字符偏移量的列号。
getColumnNumber() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getColumnNumber() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回列号（如果可用）。
getColumnNumber() - 接口 javax.xml.stream.Location 中的方法
返回当前事件结束位置的列号，如果没有可用的列号，则返回 -1。
getColumnNumber() - 接口 javax.xml.transform.SourceLocator 中的方法
返回当前文档事件结束的字符位置。
getColumnNumber() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的列号；如果没有可用的列号，则为 -1。
getColumnNumber() - 类 org.xml.sax.helpers.LocatorImpl 中的方法
返回保存的列数（从 1 开始）。
getColumnNumber() - 接口 org.xml.sax.Locator 中的方法
返回当前文档事件结束处的列号。
getColumnNumber() - 异常 org.xml.sax.SAXParseException 中的方法
发生异常的文本结尾的列号。
getColumnPrivileges(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取用于表列的访问权的描述。
getColumns() - 类 java.awt.GridLayout 中的方法
获取此布局中的列数。
getColumns() - 类 java.awt.TextArea 中的方法
返回此文本区中的列数。
getColumns() - 类 java.awt.TextField 中的方法
获取此文本字段中的列数。
getColumns(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在指定类别中使用的表列的描述。
getColumns() - 类 javax.swing.JTextArea 中的方法
返回 TextArea 中的列数。
getColumns() - 类 javax.swing.JTextField 中的方法
返回此 TextField 中的列数。
getColumns() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回该模型中所有列的一个 Enumeration。
getColumns() - 接口 javax.swing.table.TableColumnModel 中的方法
返回该模型中所有列的 Enumeration。
getColumnSelectionAllowed() - 类 javax.swing.JTable 中的方法
如果可以选择列，则返回 true。
getColumnSelectionAllowed() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
如果允许列选择，则返回 true，否则返回 false。
getColumnSelectionAllowed() - 接口 javax.swing.table.TableColumnModel 中的方法
如果可以选择列，则返回 true。
getColumnType(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的 SQL 类型。
getColumnType(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定行中值的 SQL 类型的类型代码（java.sql.Types 常量之一）。
getColumnTypeName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的数据库特定的类型名称。
getColumnTypeName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定列中值的特定于 DBMS 的类型名称。
getColumnWidth() - 类 javax.swing.JTextArea 中的方法
获取列的宽度。
getColumnWidth() - 类 javax.swing.JTextField 中的方法
返回列宽度。
getComboBox() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法

getComboIcon() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法

getCommand(String, String) - 类 javax.activation.CommandMap 中的方法
获取与 MIME 类型对应的默认命令。
getCommand(String, String, DataSource) - 类 javax.activation.CommandMap 中的方法
获取与 MIME 类型对应的默认命令。
getCommand(String) - 类 javax.activation.DataHandler 中的方法
获取命令 cmdName。
getCommand(String, String) - 类 javax.activation.MailcapCommandMap 中的方法
针对 MIME 类型获取与 cmdName 对应的命令。
getCommand() - 类 javax.sound.midi.ShortMessage 中的方法
获取与此事件关联的 MIDI 命令。
getCommand() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取作为此 RowSet 对象的命令的 SQL 查询。
getCommand() - 接口 javax.sql.RowSet 中的方法
获取此 RowSet 对象的命令属性。
getCommandClass() - 类 javax.activation.CommandInfo 中的方法
返回命令的类名。
getCommandEnvironment() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的命令环境控制对象。
getCommandName() - 类 javax.activation.CommandInfo 中的方法
返回命令动词。
getCommandObject(DataHandler, ClassLoader) - 类 javax.activation.CommandInfo 中的方法
返回已实例化的 JavaBean 组件。
getCommandOptions() - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 中的方法
取得配置的 java 命令选项。
getCommandPath() - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 中的方法
取得配置的限定路径的 java 命令名称。
getComment() - 类 java.net.HttpCookie 中的方法
返回描述此 cookie 用途的注释；如果该 cookie 没有注释，则返回 null。
getComment() - 类 java.util.zip.ZipEntry 中的方法
返回条目的注释字符串；如果没有，则返回 null。
getCommentURL() - 类 java.net.HttpCookie 中的方法
返回描述此 cookie 用途的注释 URL；如果 cookie 没有注释 URL，则返回 null。
getCommitsOnValidEdit() - 类 javax.swing.text.DefaultFormatter 中的方法
返回何时将编辑内容发布回 JFormattedTextField。
getCommitted() - 类 java.lang.management.MemoryUsage 中的方法
返回已提交给 Java 虚拟机使用的内存量（以字节为单位）。
getCommittedCharacterCount() - 类 java.awt.event.InputMethodEvent 中的方法
获取文本中已提交字符的数量。
getCommittedText(int, int, AttributedCharacterIterator.Attribute[]) - 接口 java.awt.im.InputMethodRequests 中的方法
获取提供对文本编辑组件中包含的除未提交文本外整个文本和属性访问的迭代器。
getCommittedTextLength() - 接口 java.awt.im.InputMethodRequests 中的方法
获取文本编辑组件中包含的除未提交（撰写）文本外整个文本的长度。
getComparator(int) - 类 javax.swing.DefaultRowSorter 中的方法
返回指定列的 Comparator。
getComparator() - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回将用于对焦点遍历循环中的 Components 排序的 Comparator。
getComparator(int) - 类 javax.swing.table.TableRowSorter 中的方法
返回指定列的 Comparator。
getCompilationMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的编译系统的管理 Bean。
getCompletedTaskCount() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回已完成执行的近似任务总数。
getCompletions(Element, AnnotationMirror, ExecutableElement, String) - 类 javax.annotation.processing.AbstractProcessor 中的方法
返回一个空的 completion 迭代。
getCompletions(Element, AnnotationMirror, ExecutableElement, String) - 接口 javax.annotation.processing.Processor 中的方法
向工具框架返回某一注释的建议 completion 迭代。
getComponent(int) - 类 java.awt.Container 中的方法
获取此容器中的第 n 个组件。
getComponent() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回与此 DragGestureEvent 关联的 Component。
getComponent() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法返回 DragGestureRecognizer 所“观察”的 Component，以便了解拖动开始动作。
getComponent() - 类 java.awt.dnd.DragSourceContext 中的方法
返回与此 DragSourceContext 关联的 Component。
getComponent() - 类 java.awt.dnd.DropTarget 中的方法
获取与此 DropTarget 关联的 Component。
getComponent() - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回与此 DropTargetContext 相关的 Component。
getComponent() - 类 java.awt.event.ComponentEvent 中的方法
返回事件的始发者。
getComponent() - 类 java.awt.event.HierarchyEvent 中的方法
返回事件的始发者。
getComponent() - 接口 java.beans.beancontext.BeanContextChildComponentProxy 中的方法
获得与此 BeanContextChild 相关联的 java.awt.Component。
getComponent() - 类 javax.swing.ComponentInputMap 中的方法
返回为其创建 InputMap 的组件。
getComponent() - 类 javax.swing.DefaultCellEditor 中的方法
返回对编辑器组件的引用。
getComponent() - 类 javax.swing.event.AncestorEvent 中的方法
返回添加了侦听器的组件。
getComponent() - 类 javax.swing.JMenu 中的方法
返回用于绘制此 MenuElement 的 java.awt.Component。
getComponent() - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement。
getComponent() - 类 javax.swing.JMenuItem 中的方法
返回用于绘制此对象的 java.awt.Component。
getComponent() - 类 javax.swing.JPopupMenu 中的方法
返回此 JPopupMenu 组件。
getComponent() - 类 javax.swing.JToolTip 中的方法
返回工具提示所描述的组件。
getComponent() - 接口 javax.swing.MenuElement 中的方法
此方法应返回用于绘制接收元素的 java.awt.Component。
getComponent() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取与此 UI 实现关联的文本组件。
getComponent() - 类 javax.swing.plaf.synth.SynthContext 中的方法
返回包含 region 的承载组件。
getComponent() - 接口 javax.swing.Renderer 中的方法
返回用于呈现该值的组件。
getComponent() - 类 javax.swing.text.ComponentView 中的方法
获取与此视图关联的组件。
getComponent() - 类 javax.swing.text.DefaultCaret 中的方法
获取此插入符所绑定的文本编辑器组件。
getComponent(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取组件设置。
getComponent() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回此传输的目标组件。
getComponentAfter(Container, Component) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回应该接收 aComponent 后面的焦点的 Component。
getComponentAfter(Container, Component) - 类 java.awt.FocusTraversalPolicy 中的方法
返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
getComponentAfter(Container, Component) - 类 javax.swing.DefaultFocusManager 中的方法

getComponentAfter(Container, Component) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
返回应在 aComponent 之后接收焦点的 Component。
getComponentAfter(Container, Component) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回应该接收 aComponent 后面的焦点的 Component。
getComponentAt(int, int) - 类 java.awt.Component 中的方法
确定此组件或其直接子组件之一是否包含（x，y）位置，并且如果是，则返回包含该位置的组件。
getComponentAt(Point) - 类 java.awt.Component 中的方法
返回包含指定点的组件或子组件。
getComponentAt(int, int) - 类 java.awt.Container 中的方法
对包含 x，y 位置的组件进行定位。
getComponentAt(Point) - 类 java.awt.Container 中的方法
获取包含指定点的组件。
getComponentAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的组件。
getComponentAtIndex(int) - 类 javax.swing.JMenuBar 中的方法
已过时。 由 getComponent(int i) 取代
getComponentAtIndex(int) - 类 javax.swing.JPopupMenu 中的方法
已过时。 由 Container.getComponent(int) 取代
getComponentAtIndex(int) - 类 javax.swing.JToolBar 中的方法
返回指定索引位置的组件。
getComponentBefore(Container, Component) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回应该接收 aComponent 前面的焦点的 Component。
getComponentBefore(Container, Component) - 类 java.awt.FocusTraversalPolicy 中的方法
返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
getComponentBefore(Container, Component) - 类 javax.swing.DefaultFocusManager 中的方法

getComponentBefore(Container, Component) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
返回应在 aComponent 之前接收焦点的 Component。
getComponentBefore(Container, Component) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回应该接收 aComponent 前面的焦点的 Component。
getComponentCount() - 类 java.awt.Container 中的方法
获取此面板中的组件数。
getComponentCountInLayer(int) - 类 javax.swing.JLayeredPane 中的方法
返回指定层中当前的子组件数。
getComponentGraphics(Graphics) - 类 javax.swing.JComponent 中的方法
返回用于绘制此组件的图形对象。
getComponentIndex(Component) - 类 javax.swing.JMenuBar 中的方法
返回指定组件的索引。
getComponentIndex(Component) - 类 javax.swing.JPopupMenu 中的方法
返回指定组件的索引。
getComponentIndex(Component) - 类 javax.swing.JToolBar 中的方法
返回指定组件的索引。
getComponentListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的组件侦听器的数组。
getComponentOrientation() - 类 java.awt.Component 中的方法
检索将用于排序此组件内的元素或文本的语言敏感的方向。
getComponentPopupMenu() - 类 javax.swing.JComponent 中的方法
返回为此组件分配的 JPopupMenu。
getComponents(float[]) - 类 java.awt.Color 中的方法
根据 Color 的 ColorSpace，返回一个 float 数组，该数组包含 Color 的颜色分量和 alpha 分量。
getComponents(ColorSpace, float[]) - 类 java.awt.Color 中的方法
根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的 alpha 分量。
getComponents() - 类 java.awt.Container 中的方法
获取此容器中的所有组件。
getComponents(int, int[], int) - 类 java.awt.image.ColorModel 中的方法
返回在 ColorModel 中已给定像素的非标准化颜色/alpha 分量。
getComponents(Object, int[], int) - 类 java.awt.image.ColorModel 中的方法
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。
getComponents(int, int[], int) - 类 java.awt.image.ComponentColorModel 中的方法
返回在 ColorModel 中已给定像素的非标准化颜色/alpha 分量。
getComponents(Object, int[], int) - 类 java.awt.image.ComponentColorModel 中的方法
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。
getComponents(int, int[], int) - 类 java.awt.image.DirectColorModel 中的方法
返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。
getComponents(Object, int[], int) - 类 java.awt.image.DirectColorModel 中的方法
返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。
getComponents(int, int[], int) - 类 java.awt.image.IndexColorModel 中的方法
返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。
getComponents(Object, int[], int) - 类 java.awt.image.IndexColorModel 中的方法
返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。
getComponentsInLayer(int) - 类 javax.swing.JLayeredPane 中的方法
返回指定层中组件的数组。
getComponentSize(int) - 类 java.awt.image.ColorModel 中的方法
返回指定颜色/alpha 分量的位数。
getComponentSize() - 类 java.awt.image.ColorModel 中的方法
返回每个颜色/alpha 分量的位数数组。
getComponentSize() - 类 java.awt.image.IndexColorModel 中的方法
返回包含各个颜色/alpha 分量位数的数组。
getComponentState() - 类 javax.swing.plaf.synth.SynthContext 中的方法
返回窗口小部件的状态，它是 SynthConstants 中定义的值的位掩码。
getComponentToLayer() - 类 javax.swing.JLayeredPane 中的方法
返回将组件映射到层的哈希表。
getComponentType() - 类 java.lang.Class 中的方法
返回表示数组组件类型的 Class。
getComponentType() - 接口 javax.lang.model.type.ArrayType 中的方法
返回此数组类型的组件类型。
getComponentZOrder(Component) - 类 java.awt.Container 中的方法
返回容器内组件的 z 顺序索引。
getComposite() - 类 java.awt.Graphics2D 中的方法
返回 Graphics2D 上下文中的当前 Composite
getCompositeData() - 类 javax.management.openmbean.CompositeDataInvocationHandler 中的方法
返回提供给构造方法的 CompositeData。
getCompositeType() - 接口 javax.management.openmbean.CompositeData 中的方法
返回此复合数据 实例的复合类型。
getCompositeType() - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回此复合数据 实例的复合类型。
getCompressedSize() - 类 java.util.zip.ZipEntry 中的方法
返回压缩条目数据的大小；如果未知，则返回 -1。
getCompressionMode() - 类 javax.imageio.ImageWriteParam 中的方法
如果支持压缩，则返回当前压缩模式。
getCompressionQuality() - 类 javax.imageio.ImageWriteParam 中的方法
返回当前压缩质量设置。
getCompressionQualityDescriptions() - 类 javax.imageio.ImageWriteParam 中的方法
返回一个 String 数组，可作为用户界面的一部分与 getCompressionQualityValues 一起使用，以设置或显示压缩质量级别。
getCompressionQualityDescriptions() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法

getCompressionQualityValues() - 类 javax.imageio.ImageWriteParam 中的方法
返回一个 float 数组，可作为用户界面的一部分与 getCompressionQualityDescriptions 一起使用，以设置或显示压缩质量级别。
getCompressionQualityValues() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法

getCompressionThreshold() - 类 javax.swing.text.StyleContext 中的方法
返回键/值对的最大数目，尝试将其压缩到一个惟一/不可变的集合中。
getCompressionType() - 类 javax.imageio.ImageWriteParam 中的方法
返回当前设置的压缩类型，如果没有设置任何压缩类型，则返回 null。
getCompressionTypes() - 类 javax.imageio.ImageWriteParam 中的方法
以数组或 String 形式返回可用压缩类型的列表，如果不能使用这些接口选择压缩类型，则返回 null。
getConcurrency() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的并发模式。
getConcurrency() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回此 RowSet 对象的并发性。
getConditionForKeyStroke(KeyStroke) - 类 javax.swing.JComponent 中的方法
返回确定是否发生已注册动作以响应指定键击事件的条件。
getConfiguration() - 类 javax.security.auth.login.Configuration 中的静态方法
获取已安装的登录 Configuration。
getConfigurations() - 类 java.awt.GraphicsDevice 中的方法
返回与此 GraphicsDevice 关联的所有 GraphicsConfiguration 对象。
getConflictValue(int) - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
getConflictValue(String) - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
getConfState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定数据机密性是否可用于上下文。
getConnectControls() - 类 javax.naming.ldap.InitialLdapContext 中的方法

getConnectControls() - 接口 javax.naming.ldap.LdapContext 中的方法
检索对此上下文有效的连接请求控件。
getConnection() - 接口 java.sql.DatabaseMetaData 中的方法
获取此元数据对象所产生的连接。
getConnection(String, Properties) - 类 java.sql.DriverManager 中的静态方法
试图建立到给定数据库 URL 的连接。
getConnection(String, String, String) - 类 java.sql.DriverManager 中的静态方法
试图建立到给定数据库 URL 的连接。
getConnection(String) - 类 java.sql.DriverManager 中的静态方法
试图建立到给定数据库 URL 的连接。
getConnection() - 接口 java.sql.Statement 中的方法
获取生成此 Statement 对象的 Connection 对象。
getConnection() - 接口 javax.sql.DataSource 中的方法
尝试建立与此 DataSource 对象所表示的数据源的连接。
getConnection(String, String) - 接口 javax.sql.DataSource 中的方法
尝试建立与此 DataSource 对象所表示的数据源的连接。
getConnection() - 接口 javax.sql.PooledConnection 中的方法
创建并返回一个 Connection 对象，它是此 PooledConnection 对象表示的物理连接的句柄。
getConnection() - 接口 javax.sql.RowSetInternal 中的方法
获取传递给此 RowSet 对象的 Connection 对象。
getConnectionId() - 类 javax.management.remote.JMXConnectionNotification 中的方法
该通知所属连接的连接 ID。
getConnectionId() - 接口 javax.management.remote.JMXConnector 中的方法
获得来自连接器服务器的连接 ID。
getConnectionId() - 接口 javax.management.remote.rmi.RMIConnection 中的方法
返回连接 ID。
getConnectionId() - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getConnectionId() - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getConnectionId() - 类 javax.management.remote.rmi.RMIConnector 中的方法

getConnectionIds() - 类 javax.management.remote.JMXConnectorServer 中的方法

getConnectionIds() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
当前打开的到此连接器服务器的连接 ID 列表。
getConnectTimeout() - 类 java.net.URLConnection 中的方法
返回连接超时设置。
getConstantExpression(Object) - 接口 javax.lang.model.util.Elements 中的方法
返回表示基本值或字符串的常量表达式 文本。
getConstantValue() - 接口 javax.lang.model.element.VariableElement 中的方法
如果此变量是一个被初始化为编译时常量的 static final 字段，则返回此变量的值。
getConstraint(String) - 类 javax.swing.SpringLayout.Constraints 中的方法
返回指定边的值，它可以为一个派生值，甚至可以为 null。
getConstraint(String, Component) - 类 javax.swing.SpringLayout 中的方法
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。
getConstraints(Component) - 类 java.awt.BorderLayout 中的方法
获取指定组件的约束
getConstraints(Component) - 类 java.awt.GridBagLayout 中的方法
获取指定组件的约束。
getConstraints(Component) - 类 javax.swing.SpringLayout 中的方法
返回指定组件的约束。
getConstructor(Class<?>...) - 类 java.lang.Class 中的方法
返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
getConstructor(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
返回通过名称请求的 ModelMBeanConstructorInfo。
getConstructors() - 类 java.lang.Class 中的方法
返回一个包含某些 Constructor 对象的数组，这些对象反映此 Class 对象所表示的类的所有公共构造方法。
getConstructors() - 类 javax.management.MBeanInfo 中的方法
返回 MBean 的公共构造方法列表。
getConstructors() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回 MBean 的公共构造方法列表。
getConstructors() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回 OpenMBeanConstructorInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个构造方法。
getConstructors(MBeanConstructorInfo[], Object) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。
getContainer() - 类 java.awt.event.ContainerEvent 中的方法
返回事件的始发者。
getContainer() - 接口 java.beans.beancontext.BeanContextContainerProxy 中的方法
获得与此 BeanContext 相关联的 java.awt.Container。
getContainer() - 类 javax.swing.text.View 中的方法
获取承载视图的容器。
getContainerGap(JComponent, int, Container) - 类 javax.swing.LayoutStyle 中的方法
返回组件与其父容器的指定边缘之间放置的空格数量。
getContainerListeners() - 类 java.awt.Container 中的方法
返回已在此容器上注册的所有容器侦听器的数组。
getContent(URLConnection) - 类 java.net.ContentHandler 中的方法
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。
getContent(URLConnection, Class[]) - 类 java.net.ContentHandler 中的方法
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。
getContent() - 类 java.net.URL 中的方法
获取此 URL 的内容。
getContent(Class[]) - 类 java.net.URL 中的方法
获取此 URL 的内容。
getContent() - 类 java.net.URLConnection 中的方法
获取此 URL 连接的内容。
getContent(Class[]) - 类 java.net.URLConnection 中的方法
获取此 URL 连接的内容。
getContent(DataSource) - 接口 javax.activation.DataContentHandler 中的方法
返回一个对象，该对象表示其首选形式的数据。
getContent() - 类 javax.activation.DataHandler 中的方法
以其首选 Object 的形式返回数据。
getContent() - 类 javax.naming.BinaryRefAddr 中的方法
以 Object 形式检索此地址的内容。
getContent() - 类 javax.naming.RefAddr 中的方法
检索此地址的内容。
getContent() - 类 javax.naming.StringRefAddr 中的方法
检索此地址的内容。
getContent() - 类 javax.swing.text.AbstractDocument 中的方法
获得文档的内容。
getContent() - 类 javax.swing.text.html.parser.Element 中的方法
获取内容模式
getContent() - 接口 javax.xml.crypto.dsig.keyinfo.KeyInfo 中的方法
返回包含密钥信息的 unmodifiable list。
getContent() - 接口 javax.xml.crypto.dsig.keyinfo.X509Data 中的方法
返回一个不可修改的列表，由此 X509Data 的内容组成。
getContent() - 接口 javax.xml.crypto.dsig.SignatureProperty 中的方法
返回一个不可修改的列表，由包含在此 SignatureProperty 中的一个或多个 XMLStructure 组成。
getContent() - 接口 javax.xml.crypto.dsig.XMLObject 中的方法
返回一个可修改列表，由包含在此 XMLObject 中的 XMLStructure 组成，其中 XMLObject 表示来自任何命名空间的元素。
getContent() - 类 javax.xml.soap.AttachmentPart 中的方法
以 Java 对象的形式获取此 AttachmentPart 对象的内容。
getContent() - 类 javax.xml.soap.SOAPPart 中的方法
以 JAXP Source 对象的形式返回 SOAPEnvelope 的内容。
getContentBorderInsets(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getContentDescription() - 类 javax.xml.soap.SOAPMessage 中的方法
检索此 SOAPMessage 对象内容的描述。
getContentEncoding() - 类 java.net.URLConnection 中的方法
返回 content-encoding 头字段的值。
getContentHandler() - 类 javax.xml.validation.ValidatorHandler 中的方法
获取接收扩充的验证结果的 ContentHandler。
getContentHandler() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
返回当前内容处理程序。
getContentHandler() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取内容事件处理程序。
getContentHandler() - 接口 org.xml.sax.XMLReader 中的方法
返回当前的内容处理程序。
getContentId() - 类 javax.xml.soap.AttachmentPart 中的方法
获取名为 "Content-ID" 的 MIME 头的值。
getContentId() - 类 javax.xml.soap.SOAPPart 中的方法
检索名为 "Content-Id" 的 MIME 头的值。
getContentLength() - 类 java.net.URLConnection 中的方法
返回 content-length 头字段的值。
getContentLocation() - 类 javax.xml.soap.AttachmentPart 中的方法
获取名为 "Content-Location" 的 MIME 头的值。
getContentLocation() - 类 javax.xml.soap.SOAPPart 中的方法
检索名为 "Content-Location" 的 MIME 头的值。
getContentPane() - 类 javax.swing.JApplet 中的方法
返回此 applet 的 contentPane 对象。
getContentPane() - 类 javax.swing.JDialog 中的方法
返回此对话框的 contentPane 对象。
getContentPane() - 类 javax.swing.JFrame 中的方法
返回此窗体的 contentPane 对象
getContentPane() - 类 javax.swing.JInternalFrame 中的方法
返回此内部窗体的内容窗格。
getContentPane() - 类 javax.swing.JRootPane 中的方法
返回内容窗格，它是保存以根窗格为父级的组件的容器。
getContentPane() - 类 javax.swing.JWindow 中的方法
返回作为此窗口的 contentPane 的 Container。
getContentPane() - 接口 javax.swing.RootPaneContainer 中的方法
返回 contentPane。
getContents(Object) - 类 java.awt.datatransfer.Clipboard 中的方法
返回表示剪贴板当前内容的 transferable 对象。
getContents() - 类 java.util.ListResourceBundle 中的方法
返回一个数组，其中 Object 数组中的每个项都是一个对象对。
getContents() - 类 javax.accessibility.AccessibleResourceBundle 中的方法
已过时。 返回编程键和本地化显示字符串之间的映射关系。
getContentType() - 类 java.net.URLConnection 中的方法
返回 content-type 头字段的值。
getContentType() - 类 javax.activation.DataHandler 中的方法
返回从源对象中获取的此对象的 MIME 类型。
getContentType() - 接口 javax.activation.DataSource 中的方法
此方法以字符串形式返回数据的 MIME 类型。
getContentType() - 类 javax.activation.FileDataSource 中的方法
此方法以字符串形式返回数据的 MIME 类型。
getContentType(File) - 类 javax.activation.FileTypeMap 中的方法
返回文件对象的类型。
getContentType(String) - 类 javax.activation.FileTypeMap 中的方法
返回传入文件的类型。
getContentType(File) - 类 javax.activation.MimetypesFileTypeMap 中的方法
返回该文件对象的 MIME 类型。
getContentType(String) - 类 javax.activation.MimetypesFileTypeMap 中的方法
返回基于指定文件名的 MIME 类型。
getContentType() - 类 javax.activation.URLDataSource 中的方法
返回 URL 内容-类型 (content-type) 头字段的值。
getContentType() - 类 javax.swing.JEditorPane 中的方法
获得设置此编辑器当前要处理的内容类型。
getContentType() - 类 javax.swing.text.DefaultEditorKit 中的方法
获取此工具包声明支持的数据的 MIME 类型。
getContentType() - 类 javax.swing.text.EditorKit 中的方法
获得此工具包声明支持的数据的 MIME 类型。
getContentType() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取此工具包支持的 MIME 类型的数据。
getContentType() - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
获取此工具包支持的 MIME 类型的数据。
getContentType() - 类 javax.xml.soap.AttachmentPart 中的方法
获取名为 "Content-Type" 的 MIME 头的值。
getContentTypeFor(String) - 接口 java.net.FileNameMap 中的方法
获取指定文件名的 MIME 类型。
getContext() - 类 java.security.AccessController 中的静态方法
此方法获取当前调用上下文（包括当前 Thread 的继承 AccessControlContext）的“快照”，并将其置于 AccessControlContext 对象中。
getContext() - 类 javax.script.AbstractScriptEngine 中的方法
返回受保护 context 字段的值。
getContext() - 接口 javax.script.ScriptEngine 中的方法
返回 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。
getContext() - 接口 javax.xml.ws.Response 中的方法
获取所含的响应上下文。
getContextClassLoader() - 类 java.lang.Thread 中的方法
返回该线程的上下文 ClassLoader。
getContextualShaper(int) - 类 java.awt.font.NumericShaper 中的静态方法
返回提供的 unicode 范围的上下文成形器。
getContextualShaper(int, int) - 类 java.awt.font.NumericShaper 中的静态方法
返回提供的 unicode 范围的上下文成形器。
getContinuationContext(CannotProceedException) - 类 javax.naming.spi.NamingManager 中的静态方法
创建一个将继续上下文操作的上下文。
getContinuationDirContext(CannotProceedException) - 类 javax.naming.spi.DirectoryManager 中的静态方法
创建一个将继续某个 DirContext 操作的上下文。
getContinueExistingPeriodicTasksAfterShutdownPolicy() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
获取有关在此执行程序已 shutdown 的情况下、是否继续执行现有定期任务的策略。
getControl(List<String>) - 类 java.util.ResourceBundle.Control 中的静态方法
返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。
getControl(Control.Type) - 接口 javax.sound.sampled.Line 中的方法
获得指定类型的控件，如果有的话。
getControl() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件颜色。
getControl() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件颜色。
getControlButtonsAreShown() - 类 javax.swing.JFileChooser 中的方法
返回 controlButtonsAreShown 属性的值。
getControlDarkShadow() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件加黑阴影颜色。
getControlDarkShadow() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件加黑阴影颜色。
getControlDisabled() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件禁用颜色。
getControlDisabled() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件禁用的颜色。
getControlFlag() - 类 javax.security.auth.login.AppConfigurationEntry 中的方法
返回此 LoginModule 的 controlFlag（REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL 中的任何一个）。
getControlHighlight() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件高亮显示颜色。
getControlHighlight() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件高亮显示颜色。
getControlInfo() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件信息颜色。
getControlInfo() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件信息颜色。
getControlInstance(Control) - 类 javax.naming.ldap.ControlFactory 中的方法
使用此控件工厂创建控件。
getControlInstance(Control, Context, Hashtable<?, ?>) - 类 javax.naming.ldap.ControlFactory 中的静态方法
使用已知控件工厂创建控件。
getController() - 类 javax.imageio.IIOParam 中的方法
返回当前已安装的所有 IIOParamController。
getController() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回当前已安装的所有 IIOMetadataController。
getController(int) - 接口 javax.sound.midi.MidiChannel 中的方法
获得指定控件的当前值。
getControlObject() - 接口 java.awt.im.spi.InputMethod 中的方法
从此输入方法返回一个控制对象，或 null。
getControls() - 接口 javax.naming.ldap.HasControls 中的方法
从实现此接口的对象中检索 Control 数组。
getControls() - 接口 javax.sound.sampled.Line 中的方法
获得与此行相关的控件集合。
getControlShadow() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件阴影颜色。
getControlShadow() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件阴影颜色。
getControlSize() - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法

getControlTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件文本颜色。
getControlTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件文本颜色。
getControlTextColor() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回控件文本颜色。
getControlTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回控件文本字体。
getControlTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的控件文本字体。
getControlTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回控件文本字体。
getConversion() - 异常 java.util.FormatFlagsConversionMismatchException 中的方法
返回不兼容的转换。
getConversion() - 异常 java.util.IllegalFormatConversionException 中的方法
返回不适用的转换。
getConversion() - 异常 java.util.UnknownFormatConversionException 中的方法
返回未知的转换。
getCookie() - 类 javax.naming.ldap.PagedResultsResponseControl 中的方法
检索服务器生成的 cookie。
getCookies() - 接口 java.net.CookieStore 中的方法
获取 cookie 存储区中所有未过期的 cookie。
getCookieStore() - 类 java.net.CookieManager 中的方法
获取当前 cookie 存储区。
getCopies() - 类 java.awt.JobAttributes 中的方法
返回应用程序应该使用这些属性呈现作业的份数。
getCopies() - 类 java.awt.print.PrinterJob 中的方法
获取要打印的副本数。
getCopyAction() - 类 javax.swing.TransferHandler 中的静态方法
返回一个执行复制到剪贴板操作的 Action。
getCorePoolSize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回核心线程数。
getCorner(String) - 类 javax.swing.JScrollPane 中的方法
返回位于指定角的组件。
getCorner(String) - 类 javax.swing.ScrollPaneLayout 中的方法
返回位于指定角的 Component。
getCount() - 类 java.lang.management.MemoryNotificationInfo 中的方法
返回构造通知时内存使用量超过阈值的次数。
getCount() - 类 java.util.concurrent.CountDownLatch 中的方法
返回当前计数。
getCountLimit() - 类 javax.naming.directory.SearchControls 中的方法
检索将作为搜索结果返回的最大项数。
getCountry() - 类 java.util.Locale 中的方法
返回此语言环境的国家/地区代码，将为空字符串或大写的 ISO 3166 两字母代码。
getCrc() - 类 java.util.zip.ZipEntry 中的方法
返回未压缩条目数据的 CRC-32 校验和；如果未知，则返回 -1。
getCreationDate(String) - 类 java.security.KeyStore 中的方法
返回给定别名标识的条目的创建日期。
getCreationTime() - 接口 javax.net.ssl.SSLSession 中的方法
返回创建此会话表示的时间，该时间是自协调世界时 1970 年 1 月 1 日午夜起经过的毫秒数。
getCredDelegState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否在此上下文上启用凭据委托。
getCredentialClass() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回与此 PrivateCredentialPermission 相关联的 Credential 的 Class 名称。
getCriticalExtensionOIDs() - 接口 java.security.cert.X509Extension 中的方法
获取实现此接口的对象所管理的证书/CRL 中，被标记为 CRITICAL 的扩展的 OID 字符串 Set。
getCRLs(CRLSelector) - 类 java.security.cert.CertStore 中的方法
返回与指定选择器匹配的 CRL 的 Collection。
getCrossFeedResolution(int) - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回给定单位的此分辨率属性的反向进纸分辨率。
getCrossFeedResolutionDphi() - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回以 dphi 为单位的此分辨率属性的反向进纸分辨率。
getCrossPlatformLookAndFeelClassName() - 类 javax.swing.UIManager 中的静态方法
返回实现默认的跨平台外观 -- Java Look and Feel (JLF) -- 的 LookAndFeel 类的名称。
getCrossReference(String, String, String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。
getCrtCoefficient() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 crtCoefficient。
getCrtCoefficient() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 crtCoefficient。
getCrtCoefficient() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 crtCoefficient。
getCrtCoefficient() - 类 java.security.spec.RSAOtherPrimeInfo 中的方法
返回素数的 crtCoefficient。
getCrtCoefficient() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 crtCoefficient。
getCtrlKey() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于指示在触发事件事件期间是否按下 'ctrl' 键。
getCtrlP1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回第一个控制点。
getCtrlP1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回第一个控制点。
getCtrlP1() - 类 java.awt.geom.CubicCurve2D 中的方法
返回第一个控制点。
getCtrlP2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回第二个控制点。
getCtrlP2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回第二个控制点。
getCtrlP2() - 类 java.awt.geom.CubicCurve2D 中的方法
返回第二个控制点。
getCtrlPt() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
返回控制点。
getCtrlPt() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
返回控制点。
getCtrlPt() - 类 java.awt.geom.QuadCurve2D 中的方法
返回控制点。
getCtrlX() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回控制点的 X 坐标。
getCtrlX() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回控制点的 X 坐标。
getCtrlX() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回控制点的 X 坐标。
getCtrlX1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回第一个控制点的 X 坐标。
getCtrlX1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回第一个控制点的 X 坐标。
getCtrlX1() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回第一个控制点的 X 坐标。
getCtrlX2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回第二个控制点的 X 坐标。
getCtrlX2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回第二个控制点的 X 坐标。
getCtrlX2() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回第二个控制点的 X 坐标。
getCtrlY() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回控制点的 Y 坐标。
getCtrlY() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回控制点的 Y 坐标。
getCtrlY() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回控制点的 Y 坐标。
getCtrlY1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回第一个控制点的 Y 坐标。
getCtrlY1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回第一个控制点的 Y 坐标。
getCtrlY1() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回第一个控制点的 Y 坐标。
getCtrlY2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回第二个控制点的 Y 坐标。
getCtrlY2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回第二个控制点的 Y 坐标。
getCtrlY2() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回第二个控制点的 Y 坐标。
getCurrency() - 类 java.text.DecimalFormat 中的方法
获取格式化货币值时，此十进制格式使用的货币。
getCurrency() - 类 java.text.DecimalFormatSymbols 中的方法
获得这些 DecimalFormatSymbols 的货币。
getCurrency() - 类 java.text.NumberFormat 中的方法
获取格式化货币值时此数值格式使用的货币。
getCurrencyCode() - 类 java.util.Currency 中的方法
获取此货币的 ISO 4217 货币代码。
getCurrencyInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的货币格式。
getCurrencyInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的货币格式。
getCurrencyInstance(Locale) - 类 java.text.spi.NumberFormatProvider 中的方法
返回新的 NumberFormat 实例，此实例为指定的语言环境格式化货币价值。
getCurrencySymbol() - 类 java.text.DecimalFormatSymbols 中的方法
返回这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。
getCurrent() - 类 java.awt.CheckboxGroup 中的方法
已过时。 从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。
getCurrentAccessibleContext() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取表单元格渲染器的 AccessibleContext。
getCurrentAccessibleValue() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的值，它是一个 Number。
getCurrentAccessibleValue() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的值，它是一个 Number。
getCurrentAccessibleValue() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取此对象的值，它是一个 Number。
getCurrentAccessibleValue() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
以数字形式获取此对象的值。
getCurrentAccessibleValue() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的可访问值。
getCurrentAccessibleValue() - 接口 javax.accessibility.AccessibleValue 中的方法
以 Number 形式获取此对象的值。
getCurrentAccessibleValue() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
以 Number 形式获取此对象的值。
getCurrentAccessibleValue() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
以 Number 形式获取此对象的值。
getCurrentAccessibleValue() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
以 Number 形式获取此对象的值。
getCurrentAccessibleValue() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的可访问值。
getCurrentAccessibleValue() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的可访问值。
getCurrentAccessibleValue() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的可访问值。
getCurrentAccessibleValue() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取此对象数字形式的值。
getCurrentAccessibleValue() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的可访问值。
getCurrentComponent() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取表单元格渲染器组件。
getCurrentDataFlavors() - 类 java.awt.dnd.DropTargetContext 中的方法
获取此操作的 Transferable 操作数的可用 DataFlavor。
getCurrentDataFlavors() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回来自 DropTargetContext 的当前 DataFlavor。
getCurrentDataFlavors() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回当前的 DataFlavor。
getCurrentDataFlavorsAsList() - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回 Transferable 操作数当前可用的 DataFlavor，作为一个 java.util.List。
getCurrentDataFlavorsAsList() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法以 java.util.List 形式返回当前的 DataFlavor
getCurrentDataFlavorsAsList() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法以 java.util.List 形式返回当前可用的 DataFlavor。
getCurrentDirectory() - 类 javax.swing.JFileChooser 中的方法
返回当前目录。
getCurrentEvent() - 类 java.awt.EventQueue 中的静态方法
返回当前正在被 EventQueue（它与正在调用的线程相关）指派的事件。
getCurrentFocusCycleRoot() - 类 java.awt.KeyboardFocusManager 中的方法
如果当前焦点循环根与调用线程位于相同的上下文中，则返回当前焦点循环根。
getCurrentKeyboardFocusManager() - 类 java.awt.KeyboardFocusManager 中的静态方法
返回调用线程上下文的当前 KeyboardFocusManager 实例。
getCurrentLine() - 类 javax.swing.text.html.parser.Parser 中的方法

getCurrentLineLength() - 类 javax.swing.text.AbstractWriter 中的方法
返回当前行的长度。
getCurrentManager() - 类 javax.swing.FocusManager 中的静态方法
返回调用线程上下文的当前 KeyboardFocusManager 实例。
getCurrentPoint() - 类 java.awt.geom.Path2D 中的方法
返回最近添加到路径尾部的坐标（以 Point2D 对象形式）。
getCurrentPos() - 类 javax.swing.text.html.parser.Parser 中的方法

getCurrentServiceClasses() - 接口 java.beans.beancontext.BeanContextServices 中的方法
获得此上下文的当前可用服务。
getCurrentServiceClasses() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法

getCurrentServiceSelectors() - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 中的方法
获得与服务相关的选择器列表。
getCurrentServiceSelectors(BeanContextServices, Class) - 接口 java.beans.beancontext.BeanContextServiceProvider 中的方法
由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
getCurrentServiceSelectors(Class) - 接口 java.beans.beancontext.BeanContextServices 中的方法
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。
getCurrentServiceSelectors(BeanContextServices, Class) - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 中的方法

getCurrentServiceSelectors(Class) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法

getCurrentTarget() - 接口 org.w3c.dom.events.Event 中的方法
用于指示当前正在处理其 EventListeners 的 EventTarget。
getCurrentTheme() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回 MetalLookAndFeel 当前正在使用的主题。
getCurrentThreadCpuTime() - 接口 java.lang.management.ThreadMXBean 中的方法
返回当前线程的总 CPU 时间（以毫微秒为单位）。
getCurrentThreadUserTime() - 接口 java.lang.management.ThreadMXBean 中的方法
返回当前线程在用户模式中执行的 CPU 时间（以毫微秒为单位）。
getCurrentWriter() - 类 javax.swing.text.AbstractDocument 中的方法
获取当前的写入线程（如果有的话）。
getCursor() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的 Cursor。
getCursor() - 类 java.awt.Component 中的方法
获取组件中的光标集合。
getCursor() - 类 java.awt.dnd.DragSourceContext 中的方法
返回当前的拖动 Cursor
getCursor() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的 Cursor。
getCursor() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的 Cursor。
getCursor() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的 Cursor。
getCursor() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getCursor() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的 Cursor。
getCursor() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getCursor() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getCursorName() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象使用的 SQL 光标的名称。
getCursorType() - 类 java.awt.Frame 中的方法
已过时。 从 JDK version 1.1 开始，由 Component.getCursor() 取代。
getCurve() - 类 java.security.spec.ECParameterSpec 中的方法
返回此参数定义的椭圆曲线。
getCustomEditor() - 接口 java.beans.PropertyEditor 中的方法
PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。
getCustomEditor() - 类 java.beans.PropertyEditorSupport 中的方法
PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。
getCustomizerClass() - 类 java.beans.BeanDescriptor 中的方法
获得 bean 的 customizer 的 Class 对象。
getCutAction() - 类 javax.swing.TransferHandler 中的静态方法
返回一个执行剪切到剪贴板操作的 Action。
getCycleMethod() - 类 java.awt.MultipleGradientPaint 中的方法
返回指定循环行为的枚举类型。
getDaemonThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
返回活动守护线程的当前数目。
getDashArray() - 类 java.awt.BasicStroke 中的方法
返回表示虚线线段长度的数组。
getDashPhase() - 类 java.awt.BasicStroke 中的方法
返回当前虚线相位。
getData() - 类 java.awt.color.ICC_Profile 中的方法
返回与 ICC_Profile 数据相对应的 byte 数组。
getData(int) - 类 java.awt.color.ICC_Profile 中的方法
从配置文件中返回包含特定标记数据元素的 byte 数组。
getData(DataFlavor) - 类 java.awt.datatransfer.Clipboard 中的方法
返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
getData() - 类 java.awt.image.BufferedImage 中的方法
以一个大 tile 的形式返回图像。
getData(Rectangle) - 类 java.awt.image.BufferedImage 中的方法
计算并返回 BufferedImage 的一个任意区域。
getData() - 类 java.awt.image.DataBufferByte 中的方法
返回默认（第一个）字节数据数组。
getData(int) - 类 java.awt.image.DataBufferByte 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferDouble 中的方法
返回默认（第一个）double 数据数组。
getData(int) - 类 java.awt.image.DataBufferDouble 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferFloat 中的方法
返回默认（第一个）float 数据数组。
getData(int) - 类 java.awt.image.DataBufferFloat 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferInt 中的方法
返回 DataBuffer 中的默认（第一个）int 数据数组。
getData(int) - 类 java.awt.image.DataBufferInt 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferShort 中的方法
返回默认（第一个）字节数据数组。
getData(int) - 类 java.awt.image.DataBufferShort 中的方法
返回指定存储单元的数据数组。
getData() - 类 java.awt.image.DataBufferUShort 中的方法
返回默认的（第一个）无符号 short 数据数组。
getData(int) - 类 java.awt.image.DataBufferUShort 中的方法
返回指定存储单元的数据数组。
getData() - 接口 java.awt.image.RenderedImage 中的方法
以一个大 tile 的形式返回图像（对于基于 tile 的图像，此方法需要获取整个图像并复制全部图像数据）。
getData(Rectangle) - 接口 java.awt.image.RenderedImage 中的方法
计算并返回 RenderedImage 的任意区域。
getData() - 类 java.net.DatagramPacket 中的方法
返回数据缓冲区。
getData() - 类 java.rmi.activation.ActivationDesc 中的方法
为此描述符指定的对象返回包含初始化/激活数据的“编组对象”。
getData() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的初始化数据。
getData() - 类 javax.imageio.stream.IIOByteBuffer 中的方法
返回对字节数组的引用。
getData() - 类 javax.sound.midi.MetaMessage 中的方法
获得元消息数据的副本。
getData() - 类 javax.sound.midi.SoundbankResource 中的方法
获得存储在此 SoundbankResource 中的采样音频。
getData() - 类 javax.sound.midi.SysexMessage 中的方法
获得系统独占消息数据的副本。
getData() - 类 javax.swing.text.html.FormSubmitEvent 中的方法
获取表单提交数据。
getData() - 类 javax.swing.text.html.parser.Entity 中的方法
返回 data。
getData() - 接口 javax.xml.stream.events.Characters 中的方法
获取此事件的字符数据。
getData() - 接口 javax.xml.stream.events.ProcessingInstruction 中的方法
处理指令的数据部分。
getData() - 接口 org.w3c.dom.CharacterData 中的方法
实现此接口的节点的字符数据。
getData() - 接口 org.w3c.dom.ProcessingInstruction 中的方法
此处理指令的内容。
getData1() - 类 javax.sound.midi.ShortMessage 中的方法
获取消息中的第一个数据字节。
getData2() - 类 javax.sound.midi.ShortMessage 中的方法
获取消息中的第二个数据字节。
getDatabaseMajorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取底层数据库的主版本号。
getDatabaseMinorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
底层数据库的次版本号。
getDatabaseProductName() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库产品的名称。
getDatabaseProductVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库产品的版本号。
getDataBitOffset() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回数据位的偏移量（以位为单位）。
getDataBuffer() - 类 java.awt.image.Raster 中的方法
返回与此 Raster 关联的 DataBuffer。
getDataClass() - 类 javax.sound.midi.SoundbankResource 中的方法
获得此采样所使用的表示其数据的类。
getDataElement(int[], int) - 类 java.awt.image.ColorModel 中的方法
在已给定非标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中以 int 类型表示的像素值。
getDataElement(float[], int) - 类 java.awt.image.ColorModel 中的方法
在已给定标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
getDataElement(int[], int) - 类 java.awt.image.ComponentColorModel 中的方法
返回在 ColorModel 中表示为 int 的像素值（已给定非标准化颜色/alpha 分量的数组）。
getDataElement(float[], int) - 类 java.awt.image.ComponentColorModel 中的方法
在已给定标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
getDataElement(int[], int) - 类 java.awt.image.DirectColorModel 中的方法
在给定未标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
getDataElement(int[], int) - 类 java.awt.image.IndexColorModel 中的方法
在给定非标准化颜色/alpha 分量数组的情况下，以 int 形式返回此 ColorModel 中的像素值。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
在 TransferType 类型基本数组中返回单个像素的数据。
getDataElements(int, Object) - 类 java.awt.image.ColorModel 中的方法
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
getDataElements(int[], int, Object) - 类 java.awt.image.ColorModel 中的方法
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(float[], int, Object) - 类 java.awt.image.ColorModel 中的方法
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(int, Object) - 类 java.awt.image.ComponentColorModel 中的方法
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
getDataElements(int[], int, Object) - 类 java.awt.image.ComponentColorModel 中的方法
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(float[], int, Object) - 类 java.awt.image.ComponentColorModel 中的方法
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
以 TransferType 类型基本数组形式返回单个像素的数据。
getDataElements(int, Object) - 类 java.awt.image.DirectColorModel 中的方法
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
getDataElements(int[], int, Object) - 类 java.awt.image.DirectColorModel 中的方法
在给定未标准化的颜色/alpha 分量的数组的情况下，返回此 ColorModel 中的像素的数据元素数组表示形式。
getDataElements(int, Object) - 类 java.awt.image.IndexColorModel 中的方法
根据默认 RGB 颜色模型中的整数像素表示形式，返回此 ColorModel 中像素的数据元素数组表示形式。
getDataElements(int[], int, Object) - 类 java.awt.image.IndexColorModel 中的方法
在给定非标准化颜色/alpha 分量数组的情况下，返回表示此 ColorModel 中像素的数据元素数组。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回 TransferType 类型基本数组中单个像素的数据。
getDataElements(int, int, Object) - 类 java.awt.image.Raster 中的方法
以 TransferType 类型的基本数组形式返回单个像素的数据。
getDataElements(int, int, int, int, Object) - 类 java.awt.image.Raster 中的方法
以 TransferType 类型基本数组形式返回指定像素矩形的像素数据。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在 TransferType 类型的基本数组中返回单个像素的数据。
getDataElements(int, int, int, int, Object, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在 TransferType 类型基本数组中返回指定像素矩形的像素数据。
getDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回 TransferType 类型基本数组中单个像素的数据。
getDataFlavors() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回此传输的数据 flavor。
getDataHandler() - 类 javax.xml.soap.AttachmentPart 中的方法
获取针对此 AttachmentPart 对象的 DataHandler 对象。
getDataLength(int) - 类 javax.sound.midi.ShortMessage 中的方法
检索与特定状态字节值关联的数据字节数。
getDatalink() - 类 javax.sql.rowset.serial.SerialDatalink 中的方法
返回一个新 URL，它是此 SerialDatalink 对象的副本。
getDataSize() - 异常 java.sql.DataTruncation 中的方法
获得应该传输的数据字节数。
getDataSource() - 类 javax.activation.DataHandler 中的方法
返回与此 DataHandler 实例关联的 DataSource。
getDataSourceLock() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回在此 SyncProvider 实现中活动的当前数据源锁定严重性级别。
getDataSourceName() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回向使用 Java Naming and Directory Interface (JNDI) API 的命名服务所提供的逻辑名，这将获得 javax.sql.DataSource 对象。
getDataSourceName() - 接口 javax.sql.RowSet 中的方法
获取标识此 RowSet 对象的数据源的逻辑名称。
getDataType() - 类 java.awt.image.DataBuffer 中的方法
返回此 DataBuffer 的数据类型。
getDataType() - 类 java.awt.image.SampleModel 中的方法
返回存储像素数据的 DataBuffer 的数据类型。
getDataTypeSize(int) - 类 java.awt.image.DataBuffer 中的静态方法
返回由给定 datatype 标记所代表的数据类型的大小（以位为单位）。
getDataVector() - 类 javax.swing.table.DefaultTableModel 中的方法
返回由多个包含表数据值的 Vector 组成的 Vector。
getDate() - 类 java.net.URLConnection 中的方法
返回 date 头字段的值。
getDate() - 类 java.security.cert.PKIXParameters 中的方法
返回应该确定证书路径有效性的时间。
getDate(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值。
getDate(int, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
getDate(String) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。
getDate(String, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
getDate(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getDate(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getDate(int, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getDate(String, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getDate() - 类 java.sql.Time 中的方法
已过时。
getDate() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_MONTH) 取代。
getDate(Integer) - 类 javax.management.timer.Timer 中的方法
获得与计时器通知关联的日期的一个副本。
getDate(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与计时器通知关联的日期的一个副本。
getDate() - 类 javax.swing.SpinnerDateModel 中的方法
返回此 Date 序列中的当前元素。
getDateAndTime() - 类 java.security.cert.X509CRLSelector 中的方法
返回 dateAndTime 标准。
getDateFormatSymbols() - 类 java.text.SimpleDateFormat 中的方法
获取此日期格式的日期和时间格式符号的一个副本。
getDateInstance() - 类 java.text.DateFormat 中的静态方法
获取日期格式器，该格式器具有默认语言环境的默认格式化风格。
getDateInstance(int) - 类 java.text.DateFormat 中的静态方法
获取日期格式器，该格式器具有默认语言环境的给定格式化风格。
getDateInstance(int, Locale) - 类 java.text.DateFormat 中的静态方法
获取日期格式器，该格式器具有给定语言环境的给定格式化风格。
getDateInstance(int, Locale) - 类 java.text.spi.DateFormatProvider 中的方法
返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期。
getDateTimeInstance() - 类 java.text.DateFormat 中的静态方法
获取日期/时间格式器，该格式器具有默认语言环境的默认格式化风格。
getDateTimeInstance(int, int) - 类 java.text.DateFormat 中的静态方法
获取日期/时间格式器，该格式器具有默认语言环境的给定日期和时间格式化风格。
getDateTimeInstance(int, int, Locale) - 类 java.text.DateFormat 中的静态方法
获取日期/时间格式器，该格式器具有给定语言环境的给定格式化风格。
getDateTimeInstance(int, int, Locale) - 类 java.text.spi.DateFormatProvider 中的方法
返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期和时间。
getDay() - 类 java.sql.Time 中的方法
已过时。
getDay() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_WEEK) 取代。
getDay() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回月中的日或 DatatypeConstants.FIELD_UNDEFINED。
getDays() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 DAYS 字段的值，如果不存在，则值为 0。
getDCHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
返回最近一次调用 setDecodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getDCHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回最近一次调用 setEncodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getDebugGraphicsOptions() - 类 javax.swing.JComponent 中的方法
返回图形调试的状态。
getDebugOptions() - 类 javax.swing.DebugGraphics 中的方法
返回此 DebugGraphics 的当前调试选项。
getDecayTime() - 类 javax.sound.sampled.ReverbType 中的方法
获得衰减时间，该时间是晚期反射削弱到有效 0 的总时间差。
getDecimalFormatSymbols() - 类 java.text.DecimalFormat 中的方法
返回小数格式符号的一个副本，通常程序员或用户不改变此副本。
getDecimalSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于十进制符号的字符。
getDeclaration(String) - 类 javax.swing.text.html.StyleSheet 中的方法
将 CSS 声明转换为表示 CSS 声明的 AttributeSet。
getDeclaration() - 接口 javax.xml.stream.events.EntityReference 中的方法
返回此实体的声明。
getDeclaredAnnotations() - 类 java.lang.Class 中的方法

getDeclaredAnnotations() - 类 java.lang.Package 中的方法

getDeclaredAnnotations() - 类 java.lang.reflect.AccessibleObject 中的方法

getDeclaredAnnotations() - 接口 java.lang.reflect.AnnotatedElement 中的方法
返回直接存在于此元素上的所有注释。
getDeclaredAnnotations() - 类 java.lang.reflect.Constructor 中的方法

getDeclaredAnnotations() - 类 java.lang.reflect.Field 中的方法

getDeclaredAnnotations() - 类 java.lang.reflect.Method 中的方法

getDeclaredClasses() - 类 java.lang.Class 中的方法
返回 Class 对象的一个数组，这些对象反映声明为此 Class 对象所表示的类的成员的所有类和接口。
getDeclaredConstructor(Class<?>...) - 类 java.lang.Class 中的方法
返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
getDeclaredConstructors() - 类 java.lang.Class 中的方法
返回 Constructor 对象的一个数组，这些对象反映此 Class 对象表示的类声明的所有构造方法。
getDeclaredField(String) - 类 java.lang.Class 中的方法
返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
getDeclaredFields() - 类 java.lang.Class 中的方法
返回 Field 对象的一个数组，这些对象反映此 Class 对象所表示的类或接口所声明的所有字段。
getDeclaredMethod(String, Class<?>...) - 类 java.lang.Class 中的方法
返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
getDeclaredMethods() - 类 java.lang.Class 中的方法
返回 Method 对象的一个数组，这些对象反映此 Class 对象表示的类或接口声明的所有方法，包括公共、保护、默认（包）访问和私有方法，但不包括继承的方法。
getDeclaredPrefixes() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
返回此上下文中声明的所有前缀的枚举。
getDeclaredType(TypeElement, TypeMirror...) - 接口 javax.lang.model.util.Types 中的方法
返回对应于类型元素和实际类型参数的类型。
getDeclaredType(DeclaredType, TypeElement, TypeMirror...) - 接口 javax.lang.model.util.Types 中的方法
根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
getDeclaredType() - 类 javax.xml.bind.JAXBElement 中的方法
返回 xml 元素声明的类型属性的 Java 绑定。
getDeclaringClass() - 类 java.lang.Class 中的方法
如果此 Class 对象所表示的类或接口是另一个类的成员，则返回的 Class 对象表示该对象的声明类。
getDeclaringClass() - 类 java.lang.Enum 中的方法
返回与此枚举常量的枚举类型相对应的 Class 对象。
getDeclaringClass() - 类 java.lang.reflect.Constructor 中的方法
返回 Class 对象，该对象表示声明由此 Constructor 对象表示的构造方法的类。
getDeclaringClass() - 类 java.lang.reflect.Field 中的方法
返回表示类或接口的 Class 对象，该类或接口声明由此 Field 对象表示的字段。
getDeclaringClass() - 接口 java.lang.reflect.Member 中的方法
返回表示声明由此 Member 表示的成员或构造方法的类或接口的 Class 对象。
getDeclaringClass() - 类 java.lang.reflect.Method 中的方法
返回表示声明由此 Method 对象表示的方法的类或接口的 Class 对象。
getDecomposition() - 类 java.text.Collator 中的方法
获取此 Collator 的 decomposition 模式。
getDeepestComponentAt(Component, int, int) - 类 javax.swing.SwingUtilities 中的静态方法
返回包含位置 x、y 的 parent 的最深可见后代组件。
getDefault() - 类 java.net.CookieHandler 中的静态方法
获取系统级 cookie 处理程序。
getDefault() - 类 java.net.ProxySelector 中的静态方法
获取系统级代理选择器。
getDefault() - 类 java.net.ResponseCache 中的静态方法
获取系统级响应缓存。
getDefault() - 类 java.util.Locale 中的静态方法
获得此 Java 虚拟机实例的当前默认语言环境值。
getDefault() - 类 java.util.TimeZone 中的静态方法
获取此主机的默认 TimeZone。
getDefault() - 类 javax.net.ServerSocketFactory 中的静态方法
返回该环境默认套接字工厂的一个副本。
getDefault() - 类 javax.net.SocketFactory 中的静态方法
返回该环境默认套接字工厂的一个副本。
getDefault() - 类 javax.net.ssl.SSLContext 中的静态方法
返回默认的 SSL 上下文。
getDefault() - 类 javax.net.ssl.SSLServerSocketFactory 中的静态方法
返回默认的 SSL 服务器套接字工厂。
getDefault() - 类 javax.net.ssl.SSLSocketFactory 中的静态方法
返回默认的 SSL 套接字工厂。
getDefaultAction() - 接口 javax.swing.text.Keymap 中的方法
当击键（即接收 KEY_TYPED KeyEvent）且该键没有绑定操作的情况下获取激发的默认操作。
getDefaultActions() - 类 java.awt.dnd.DropTarget 中的方法
获取表示受此 DropTarget 支持的当前操作的 int 值。
getDefaultAlgorithm() - 类 javax.net.ssl.KeyManagerFactory 中的静态方法
获取默认的 KeyManagerFactory 算法名称。
getDefaultAlgorithm() - 类 javax.net.ssl.TrustManagerFactory 中的静态方法
获取默认的 TrustManagerFactory 算法名称。
getDefaultAllowUserInteraction() - 类 java.net.URLConnection 中的静态方法
返回 allowUserInteraction 字段的默认值。
getDefaultAttributeValue(Class<? extends Attribute>) - 接口 javax.print.PrintService 中的方法
确定给定类别中此 PrintService 的默认打印属性值。
getDefaultButton() - 类 javax.swing.JRootPane 中的方法
返回 defaultButton 属性的值。
getDefaultChoice() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取 defaultChoice。
getDefaultChooserPanels() - 类 javax.swing.colorchooser.ColorChooserComponentFactory 中的静态方法

getDefaultCipherSuites() - 类 javax.net.ssl.SSLServerSocketFactory 中的方法
返回默认情况下启用的密码套件的列表。
getDefaultCipherSuites() - 类 javax.net.ssl.SSLSocketFactory 中的方法
返回默认情况下启用的密码套件的列表。
getDefaultClassLoader() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
获得此连接器服务器使用的默认 ClassLoader。
getDefaultClosedIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回默认图标，对于当前的 laf，它用于表示没有扩展的非叶节点。
getDefaultCloseOperation() - 类 javax.swing.JDialog 中的方法
返回用户在此对话框上启动 "close" 时所执行的操作。
getDefaultCloseOperation() - 类 javax.swing.JFrame 中的方法
返回用户在此窗体上发起 "close" 时执行的操作。
getDefaultCloseOperation() - 类 javax.swing.JInternalFrame 中的方法
返回用户在此内部窗体上发起 "close" 时默认执行的操作。
getDefaultCommandMap() - 类 javax.activation.CommandMap 中的静态方法
获取默认的 CommandMap。
getDefaultComponent(Container) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回默认拥有焦点的 Component。
getDefaultComponent(Container) - 类 java.awt.FocusTraversalPolicy 中的方法
返回要聚焦的默认 Component。
getDefaultComponent(Container) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回默认拥有焦点的 Component。
getDefaultConfiguration() - 类 java.awt.GraphicsDevice 中的方法
返回与此 GraphicsDevice 关联的默认 GraphicsConfiguration。
getDefaultController() - 类 javax.imageio.IIOParam 中的方法
返回默认 IIOParamController（如果有），不考虑当前安装的控制器。
getDefaultController() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回默认 IIOMetadataController（如果有），不考虑当前安装的控制器。
getDefaultCursor() - 类 java.awt.Cursor 中的静态方法
返回系统默认光标。
getDefaultCursor() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
返回默认光标。
getDefaultDirectory() - 类 javax.swing.filechooser.FileSystemView 中的方法
返回文件选择器的用户默认起始目录。
getDefaultDomain() - 接口 javax.management.MBeanServer 中的方法

getDefaultDomain() - 接口 javax.management.MBeanServerConnection 中的方法
返回对 MBean 命名时使用的默认域。
getDefaultDomain(Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getDefaultDomain() 方法。
getDefaultDomain(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getDefaultDomain(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getDefaultDragSource() - 类 java.awt.dnd.DragSource 中的静态方法
获取与基础平台关联的 DragSource 对象。
getDefaultEditor(Class<?>) - 类 javax.swing.JTable 中的方法
尚未在 TableColumn 中设置编辑器时，返回要使用的编辑器。
getDefaultEventIndex() - 接口 java.beans.BeanInfo 中的方法
bean 可能有一个“默认”事件，即使用 bean 时通常最有可能由用户使用的事件。
getDefaultEventIndex() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝默认事件的信息。
getDefaultFileTypeMap() - 类 javax.activation.FileTypeMap 中的静态方法
返回系统的默认 FileTypeMap。
getDefaultFlavorMap() - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
返回此线程的 ClassLoader 的默认 FlavorMap。
getDefaultFocusTraversalKeys(int) - 类 java.awt.KeyboardFocusManager 中的方法
返回给定遍历操作的默认焦点遍历键的 Set。
getDefaultFocusTraversalPolicy() - 类 java.awt.KeyboardFocusManager 中的方法
返回默认 FocusTraversalPolicy。
getDefaultFormatter() - 类 javax.swing.text.DefaultFormatterFactory 中的方法
返回供最后选择使用的 JFormattedTextField.AbstractFormatter，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
getDefaultFractionDigits() - 类 java.util.Currency 中的方法
获取与此货币一起使用的默认小数位数。
getDefaultHostnameVerifier() - 类 javax.net.ssl.HttpsURLConnection 中的静态方法
获取此类的新实例所继承的默认 HostnameVerifier。
getDefaultIcon() - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法

getDefaultImageMetadata(ImageTypeSpecifier, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
getDefaultInitCtx() - 类 javax.naming.InitialContext 中的方法
通过调用 NamingManager.getInitialContext() 获取初始上下文，并将它缓存在 defaultInitCtx 中。
getDefaultInstance() - 类 javax.imageio.spi.IIORegistry 中的静态方法
返回 Image I/O API 使用的默认 IIORegistry 实例。
getDefaultLeafIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回默认图标，对于当前的 laf，它用于表示叶节点。
getDefaultLightWeightPopupEnabled() - 类 javax.swing.JPopupMenu 中的静态方法
获取 defaultLightWeightPopupEnabled 属性，默认情况下，该属性为 true。
getDefaultLocale() - 类 javax.swing.JComponent 中的静态方法
返回在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。
getDefaultLocale() - 类 javax.swing.UIDefaults 中的方法
返回该默认语言环境。
getDefaultName() - 类 javax.security.auth.callback.NameCallback 中的方法
获取默认名称。
getDefaultNamespacePrefix() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法

getDefaultNamespacePrefix() - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回默认名称空间前缀。
getDefaultOpenIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回默认图标，对于当前的 laf，它用于表示扩展的非叶节点。
getDefaultOption() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取默认选项。
getDefaultPort() - 类 java.net.URL 中的方法
获取与此 URL 关联协议的默认端口号。
getDefaultPort() - 类 java.net.URLStreamHandler 中的方法
返回由该处理程序解析的 URL 的默认端口。
getDefaultPrintService() - 类 javax.print.PrintServiceLookup 中的方法
应用程序不直接调用它。
getDefaultPropertyIndex() - 接口 java.beans.BeanInfo 中的方法
bean 可能有一个“默认”属性，即通常最有可能由自定义 bean 的用户一开始就选择更新的属性。
getDefaultPropertyIndex() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝默认属性的信息。
getDefaultProviderInstance() - 类 java.rmi.server.RMIClassLoader 中的静态方法
返回服务提供者接口 RMIClassLoaderSpi 的默认提供者的规范化实例。
getDefaultQueue() - 类 javax.swing.text.LayoutQueue 中的静态方法
返回默认的布局队列。
getDefaultReadParam() - 类 javax.imageio.ImageReader 中的方法
返回一个适合此格式的默认 ImageReadParam 对象。
getDefaultRenderer(Class<?>) - 类 javax.swing.JTable 中的方法
尚未在 TableColumn 中设置渲染器时，返回要使用的单元格渲染器。
getDefaultRenderer() - 类 javax.swing.table.JTableHeader 中的方法
返回 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
getDefaultRepresentationClass() - 类 java.awt.datatransfer.DataFlavor 中的方法

getDefaultRepresentationClassAsString() - 类 java.awt.datatransfer.DataFlavor 中的方法

getDefaultRequestProperty(String) - 类 java.net.URLConnection 中的静态方法
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。
getDefaultRootElement() - 类 javax.swing.text.AbstractDocument 中的方法
返回视图赖依存在的根元素，除非提供了向元素结构指派视图的其他机制。
getDefaultRootElement() - 类 javax.swing.text.DefaultStyledDocument 中的方法
获得默认的根元素。
getDefaultRootElement() - 接口 javax.swing.text.Document 中的方法
返回视图赖以存在的根元素，除非提供了向元素结构指定视图的其他机制。
getDefaultRootElement() - 类 javax.swing.text.PlainDocument 中的方法
获取文档模型的默认根元素。
getDefaults() - 类 javax.swing.LookAndFeel 中的方法
返回外观的默认值。
getDefaults() - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
返回外观默认值。
getDefaults() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回外观的默认值。
getDefaults() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
创建、初始化并返回特定于外观的默认值。
getDefaults() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回此 SynthLookAndFeel 的默认值。
getDefaults() - 类 javax.swing.UIManager 中的静态方法
返回该默认值。
getDefaultScreenDevice() - 类 java.awt.GraphicsEnvironment 中的方法
返回默认的屏幕 GraphicsDevice。
getDefaultSelection() - 类 java.awt.JobAttributes 中的方法
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。
getDefaultSize() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回使用当前渲染器和字体的组合框的空显示区域的默认大小。
getDefaultSocketFactory() - 类 java.rmi.server.RMISocketFactory 中的静态方法
返回对此 RMI 实现使用的默认套接字工厂的引用。
getDefaultSoundbank() - 接口 javax.sound.midi.Synthesizer 中的方法
获得合成器的默认音库（如果合成器存在）。
getDefaultSSLParameters() - 类 javax.net.ssl.SSLContext 中的方法
返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
getDefaultSSLSocketFactory() - 类 javax.net.ssl.HttpsURLConnection 中的静态方法
获取此类的新实例所继承的默认静态 SSLSocketFactory。
getDefaultStream() - 类 java.rmi.server.LogStream 中的静态方法
已过时。 无替代版本
getDefaultStreamMetadata(ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
返回包含用来对图像流进行编码的默认值的 IIOMetadata 对象。
getDefaultStyleContext() - 类 javax.swing.text.StyleContext 中的静态方法
返回由所有文档共享的默认 AttributeContext，这些文档不影响定义/提供其自己的上下文。
getDefaultText() - 类 javax.security.auth.callback.TextInputCallback 中的方法
获取默认文本。
getDefaultTextIconGap(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getDefaultToolkit() - 类 java.awt.Toolkit 中的静态方法
获取默认工具包。
getDefaultTransactionIsolation() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库的默认事务隔离级别。
getDefaultTransform() - 类 java.awt.GraphicsConfiguration 中的方法
返回此 GraphicsConfiguration 的默认 AffineTransform。
getDefaultTreeModel() - 类 javax.swing.JTree 中的静态方法
创建并返回一个示例 TreeModel。
getDefaultType() - 类 java.security.cert.CertPathBuilder 中的静态方法
返回 Java 安全属性文件中所指定的默认 CertPathBuilder 类型，如果没有此属性，则返回字符串 "PKIX"。
getDefaultType() - 类 java.security.cert.CertPathValidator 中的静态方法
返回 Java 安全属性文件中所指定的默认 CertPathValidator 类型，如果没有此属性，则返回字符串 "PKIX"。
getDefaultType() - 类 java.security.cert.CertStore 中的静态方法
返回 Java 安全属性文件中指定的默认 CertStore 类型；如果没有此属性，则返回字符串 "LDAP"。
getDefaultType() - 类 java.security.KeyStore 中的静态方法
返回 Java 安全属性文件中指定的默认 keystore 类型；如果不存在此类属性，则返回字符串 "jks"（"Java keystore" 的首字母缩写）。
getDefaultUncaughtExceptionHandler() - 类 java.lang.Thread 中的静态方法
返回线程由于未捕获到异常而突然终止时调用的默认处理程序。
getDefaultUseCaches() - 类 java.net.URLConnection 中的方法
返回 URLConnection 的 useCaches 标志的默认值。
getDefaultValue() - 类 java.lang.reflect.Method 中的方法
返回由此 Method 实例表示的注释成员的默认值。
getDefaultValue() - 接口 javax.lang.model.element.ExecutableElement 中的方法
如果此 executable 是一个注释类型元素，则返回默认值。
getDefaultValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的默认值（如果已指定），否则返回 null。
getDefaultValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此参数的默认值（如果存在），否则返回 null。
getDefaultValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的默认值（如果指定），否则返回 null。
getDefaultValue() - 类 javax.swing.text.html.CSS.Attribute 中的方法
获取属性的默认值。
getDefaultWriteParam() - 类 javax.imageio.ImageWriter 中的方法
返回适用于此文件格式的适当类型的新 ImageWriteParam 对象，该对象包含默认值，即那些将在没有指定 ImageWriteParam 对象时使用的值。
getDefinitionClass() - 类 java.lang.instrument.ClassDefinition 中的方法
返回该类。
getDefinitionClassFile() - 类 java.lang.instrument.ClassDefinition 中的方法
返回包含新的类文件的 byte 数组。
getDelay(TimeUnit) - 接口 java.util.concurrent.Delayed 中的方法
返回与此对象相关的剩余延迟时间，以给定的时间单位表示。
getDelay() - 类 javax.swing.JMenu 中的方法
返回子菜单向上或向下弹出前建议的延迟（以毫秒为单位）。
getDelay() - 类 javax.swing.Timer 中的方法
返回两次触发动作事件间延迟，以毫秒为单位。
getDelegatedTask() - 类 javax.net.ssl.SSLEngine 中的方法
返回此 SSLEngine 的一个委托 Runnable 任务。
getDelegCred() - 接口 org.ietf.jgss.GSSContext 中的方法
获取上下文初始端委托给上下文接受端的凭据。
getDepth() - 接口 java.security.cert.PolicyNode 中的方法
返回有效策略树中此节点的深度。
getDepth(int) - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法

getDepth() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回以此节点为根的树的深度 -- 从此节点到叶节点的最长距离。
getDER() - 类 org.ietf.jgss.Oid 中的方法
返回此 oid 对象的全部 ASN.1 DER 编码，其中包括标记和长度。
getDereferencedData() - 接口 javax.xml.crypto.dsig.Reference 中的方法
如果已启用引用缓存，则返回被取消引用的数据。
getDerefLinkFlag() - 类 javax.naming.directory.SearchControls 中的方法
确定在搜索期间是否将取消对链接的引用。
getDerivedGauge(ObjectName) - 类 javax.management.monitor.CounterMonitor 中的方法
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
getDerivedGauge() - 类 javax.management.monitor.CounterMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGauge(ObjectName) 取代
getDerivedGauge() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGauge(ObjectName) 取代
getDerivedGauge(ObjectName) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取指定的 MBean 的派生尺度。
getDerivedGauge(ObjectName) - 类 javax.management.monitor.GaugeMonitor 中的方法
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
getDerivedGauge() - 类 javax.management.monitor.GaugeMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGauge(ObjectName) 取代
getDerivedGauge() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGauge(ObjectName) 取代
getDerivedGauge(ObjectName) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取指定的 MBean 的派生尺度。
getDerivedGauge() - 类 javax.management.monitor.MonitorNotification 中的方法
获取此监视器通知的派生尺度。
getDerivedGauge(ObjectName) - 类 javax.management.monitor.StringMonitor 中的方法
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生的尺度，否则将为 null。
getDerivedGauge() - 类 javax.management.monitor.StringMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGauge(ObjectName) 取代
getDerivedGauge() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGauge(ObjectName) 取代
getDerivedGauge(ObjectName) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取指定 MBean 的派生尺度。
getDerivedGaugeTimeStamp(ObjectName) - 类 javax.management.monitor.CounterMonitor 中的方法
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
getDerivedGaugeTimeStamp() - 类 javax.management.monitor.CounterMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp(ObjectName) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取指定 MBean 的派生尺度时间戳。
getDerivedGaugeTimeStamp(ObjectName) - 类 javax.management.monitor.GaugeMonitor 中的方法
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
getDerivedGaugeTimeStamp() - 类 javax.management.monitor.GaugeMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp(ObjectName) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取指定 MBean 的派生尺度时间戳。
getDerivedGaugeTimeStamp(ObjectName) - 类 javax.management.monitor.StringMonitor 中的方法
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
getDerivedGaugeTimeStamp() - 类 javax.management.monitor.StringMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
getDerivedGaugeTimeStamp(ObjectName) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取指定 MBean 的派生尺度时间戳。
getDescendantToggledPaths(TreePath) - 类 javax.swing.JTree 中的方法
返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
getDescent() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的 descent。
getDescent() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回此 ImageGraphicAttribute 的 descent。
getDescent() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的 descent。
getDescent() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回此 ShapeGraphicAttribute 的 descent。
getDescent() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的 descent。
getDescent() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的 font descent。
getDescent(GlyphView) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法

getDescription() - 异常 java.util.regex.PatternSyntaxException 中的方法
获取错误的描述。
getDescription(Locale) - 类 javax.imageio.spi.IIOServiceProvider 中的方法
返回此服务提供者及其相关实现的一个简明的可读描述。
getDescription() - 类 javax.management.MBeanFeatureInfo 中的方法
返回该功能的可读描述。
getDescription() - 类 javax.management.MBeanInfo 中的方法
返回该 MBean 的可读描述。
getDescription() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回 MBean 的可读描述。
getDescription(String) - 类 javax.management.openmbean.CompositeType 中的方法
返回名称是 itemName 的项的描述，如果此 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。
getDescription() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回此 OpenMBeanConstructorInfo 实例描述的构造方法的可读描述。
getDescription() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回此 OpenMBeanInfo 描述的 open MBean 实例的类型的可读描述。
getDescription() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例描述的操作的可读描述。
getDescription() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例描述的参数的可读描述。
getDescription() - 类 javax.management.openmbean.OpenType 中的方法
返回此 OpenType 实例的文本描述。
getDescription() - 类 javax.management.relation.RoleInfo 中的方法
返回角色的描述文本。
getDescription(MBeanInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的描述。
getDescription(MBeanFeatureInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanFeatureInfo 中使用的描述。
getDescription(MBeanAttributeInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanAttributeInfo 中使用的描述。
getDescription(MBeanConstructorInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanConstructorInfo 中使用的描述。
getDescription(MBeanConstructorInfo, MBeanParameterInfo, int) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。
getDescription(MBeanOperationInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的描述。
getDescription(MBeanOperationInfo, MBeanParameterInfo, int) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。
getDescription() - 类 javax.sound.midi.MidiDevice.Info 中的方法
获得关于设备的描述。
getDescription() - 接口 javax.sound.midi.Soundbank 中的方法
获得音库适于显示的文本描述。
getDescription() - 类 javax.sound.sampled.Mixer.Info 中的方法
获得混频器的描述。
getDescription() - 类 javax.swing.event.HyperlinkEvent 中的方法
获得链接描述的字符串表示形式。
getDescription() - 类 javax.swing.filechooser.FileFilter 中的方法
此过滤器的描述。
getDescription() - 类 javax.swing.filechooser.FileNameExtensionFilter 中的方法
此过滤器的描述。
getDescription(File) - 类 javax.swing.filechooser.FileView 中的方法
文件的可读描述。
getDescription() - 类 javax.swing.ImageIcon 中的方法
获得图像的描述。
getDescription(File) - 类 javax.swing.JFileChooser 中的方法
返回文件描述。
getDescription() - 类 javax.swing.LookAndFeel 中的方法
返回对此外观实现的单行描述，例如，"The CDE/Motif Look and Feel"。
getDescription() - 类 javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter 中的方法

getDescription(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getDescription() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回此外观的简短描述。
getDescription() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回对此外观的一行描述。
getDescription() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回 SynthLookAndFeel 的文本描述。
getDescriptor() - 接口 javax.management.DescriptorRead 中的方法
返回 Descriptor 的副本。
getDescriptor() - 类 javax.management.MBeanFeatureInfo 中的方法
返回该功能的描述符。
getDescriptor() - 类 javax.management.MBeanInfo 中的方法
获取此 MBean 的描述符。
getDescriptor() - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 中的方法
获取 ModelMBeanAttributeInfo 的关联 Descriptor 的副本。
getDescriptor() - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 中的方法
返回关联 Descriptor 的副本。
getDescriptor(String, String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回通过 name 和 descriptorType 请求的 Descriptor。
getDescriptor(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
返回通过名称请求的 Descriptor。
getDescriptor(String, String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getDescriptor() - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getDescriptor() - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 中的方法
返回 ModelMBeanNotificationInfo 的关联 Descriptor 的副本。
getDescriptor() - 类 javax.management.modelmbean.ModelMBeanOperationInfo 中的方法
返回 ModelMBeanOperationInfo 的关联 Descriptor 的副本。
getDescriptors(String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
getDescriptors(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getDesignAxisDefaults() - 接口 java.awt.font.MultipleMaster 中的方法
返回每个轴的默认设计值的数组。
getDesignAxisNames() - 接口 java.awt.font.MultipleMaster 中的方法
返回每个设计轴的名称。
getDesignAxisRanges() - 接口 java.awt.font.MultipleMaster 中的方法
为每个轴返回以 [from->to] 形式交错的设计限制的数组。
getDesktop() - 类 java.awt.Desktop 中的静态方法
返回当前浏览器上下文的 Desktop 实例。
getDesktopColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的桌面颜色。
getDesktopColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回桌面颜色。
getDesktopColor() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回桌面颜色。
getDesktopIcon() - 类 javax.swing.JInternalFrame 中的方法
返回图标化此 JInternalFrame 时使用的 JDesktopIcon。
getDesktopIconBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于 Desktop Icon 的 border 实例
getDesktopManager() - 类 javax.swing.JDesktopPane 中的方法
返回处理特定于桌面 UI 操作的 DesktopManger。
getDesktopManager() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
返回适当的 DesktopManager。
getDesktopPane() - 类 javax.swing.JInternalFrame 中的方法
在祖先层次结构中搜索 JDesktop 实例的便捷方法。
getDesktopPane() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
询问该图标所属的 Desktop 对象的便捷方法。
getDesktopPaneForComponent(Component) - 类 javax.swing.JOptionPane 中的静态方法
返回指定组件的桌面窗格。
getDesktopProperty(String) - 类 java.awt.Toolkit 中的方法
获取指定桌面属性的值。
getDesktopPropertyValue(String, Object) - 类 javax.swing.LookAndFeel 中的静态方法
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。
getDestination() - 类 java.awt.JobAttributes 中的方法
指定将输出到打印机还是使用这些属性的作业文件。
getDestination(ImageReadParam, Iterator<ImageTypeSpecifier>, int, int) - 类 javax.imageio.ImageReader 中的静态方法
返回应该在其中写入解码的像素数据的 BufferedImage。
getDestination() - 类 javax.imageio.ImageReadParam 中的方法
返回当前由 setDestination 方法设置的 BufferedImage，如果没有设置，则返回 null。
getDestinationBands() - 类 javax.imageio.ImageReadParam 中的方法
返回 band 索引的集合，数据将置于该集合中。
getDestinationOffset() - 类 javax.imageio.IIOParam 中的方法
返回目标图像中的偏移量，像素将置于该处。
getDestinationType() - 类 javax.imageio.IIOParam 中的方法
以 ImageTypeSpecifier 的形式返回将由读取操作返回的图像类型，如果通过调用 setDestination(ImageTypeSpecifier) 设置了类型的话。
getDetail() - 接口 javax.xml.soap.SOAPFault 中的方法
返回此 SOAPFault 对象的可选 detail 元素。
getDetail() - 接口 org.w3c.dom.events.UIEvent 中的方法
指定关于 Event 的一些详细信息，具体取决于事件的类型。
getDetailEntries() - 接口 javax.xml.soap.Detail 中的方法
获取在此 Detail 对象中所有 DetailEntry 上进行迭代的迭代器。
getDeterminant() - 类 java.awt.geom.AffineTransform 中的方法
返回变换的矩阵表示形式的决定因子。
getDevice() - 类 java.awt.GraphicsConfiguration 中的方法
返回与此 GraphicsConfiguration 关联的 GraphicsDevice。
getDevice() - 类 java.awt.PointerInfo 中的方法
返回在创建此 PointerInfo 时鼠标指针所在的 GraphicsDevice。
getDevice(MidiDevice.Info) - 类 javax.sound.midi.spi.MidiDeviceProvider 中的方法
获得由信息对象表示的设备的实例。
getDeviceConfiguration() - 类 java.awt.Graphics2D 中的方法
返回与此 Graphics2D 关联的设备配置。
getDeviceInfo() - 接口 javax.sound.midi.MidiDevice 中的方法
获得有关设备的信息，其中包括包含了其名称、供应商和描述的 Java 类和 Strings。
getDeviceInfo() - 类 javax.sound.midi.spi.MidiDeviceProvider 中的方法
获得表示设备或由此 MidiDeviceProvider 提供的设备的信息对象集合。
getDiagnostics() - 类 javax.tools.DiagnosticCollector 中的方法
获取此对象收集的诊断所组成的列表视图。
getDialog() - 类 java.awt.JobAttributes 中的方法
返回对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。
getDialogTitle() - 类 javax.swing.JFileChooser 中的方法
获得 JFileChooser 的标题栏中所显示的字符串。
getDialogTitle(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
返回此对话框的标题
getDialogTitle(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法

getDialogTitle(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getDialogTitle 方法。
getDialogType() - 类 javax.swing.JFileChooser 中的方法
返回此对话框的类型。
getDifferenceMode() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察到的 MBeans 的共同的差分模式标志值。
getDifferenceMode() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取差分模式标志值。
getDifferenceMode() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有观察到的 MBean 的公共差分模式标志值。
getDifferenceMode() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取差分模式标志值。
getDigestAlgorithm() - 类 java.security.spec.MGF1ParameterSpec 中的方法
返回掩码生成函数使用的消息摘要的算法名称。
getDigestAlgorithm() - 类 java.security.spec.PSSParameterSpec 中的方法
返回消息摘要算法名称。
getDigestAlgorithm() - 类 javax.crypto.spec.OAEPParameterSpec 中的方法
返回信息摘要算法名称。
getDigestInputStream() - 接口 javax.xml.crypto.dsig.Reference 中的方法
如果已启用引用缓存，则返回预整理的输入流。
getDigestLength() - 类 java.security.MessageDigest 中的方法
返回以字节为单位的摘要长度，如果提供者不支持此操作并且实现是不可复制的，则返回 0。
getDigestMethod() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回此 Reference 的摘要方法。
getDigestValue() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回此 Reference 的摘要值。
getDigit() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于某种模式中数字的字符。
getDimension() - 类 javax.management.openmbean.ArrayType 中的方法
返回此 ArrayType 实例描述的数组的维度。
getDimension(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
getDimension(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
getDimension(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个维数。
getDimension(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个维数。
getDirection() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回箭头的方向。
getDirection() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得方向。
getDirectionality(char) - 类 java.lang.Character 中的静态方法
返回给定字符的 Unicode 方向属性。
getDirectionality(int) - 类 java.lang.Character 中的静态方法
返回给定字符（Unicode 代码点）的 Unicode 方向属性。
getDirectories() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法

getDirectory() - 类 java.awt.FileDialog 中的方法
获取此文件对话框的目录。
getDirectory() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
记忆当前在 UI 中选择的目录的属性。
getDirectoryName() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getDirectoryName() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getDirtyRegion(JComponent) - 类 javax.swing.RepaintManager 中的方法
返回组件的当前脏区。
getDisabledIcon() - 类 javax.swing.AbstractButton 中的方法
返回禁用按钮时按钮使用的图标。
getDisabledIcon() - 类 javax.swing.JLabel 中的方法
返回该标签被禁用时所使用的图标。
getDisabledIcon(JComponent, Icon) - 类 javax.swing.LookAndFeel 中的方法
返回具有禁用外观的 Icon。
getDisabledIcon(JComponent, Icon) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回具有禁用外观的 Icon。
getDisabledIconAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡禁用图标。
getDisabledObjectNames() - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
获取禁用的所有 ObjectName。
getDisabledSelectedIcon() - 类 javax.swing.AbstractButton 中的方法
返回禁用并选择按钮时按钮使用的图标。
getDisabledSelectedIcon(JComponent, Icon) - 类 javax.swing.LookAndFeel 中的方法
返回由选定的禁用组件使用的 Icon。
getDisabledSelectedIcon(JComponent, Icon) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回由选定的禁用组件使用的 Icon。
getDisabledTextColor() - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法

getDisabledTextColor() - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法

getDisabledTextColor() - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法

getDisabledTextColor() - 类 javax.swing.text.JTextComponent 中的方法
获取用于呈现禁用文本的当前颜色。
getDiscard() - 类 java.net.HttpCookie 中的方法
返回 cookie 的丢弃属性
getDismissDelay() - 类 javax.swing.ToolTipManager 中的方法
返回取消工具提示的延迟值。
getDisplayCountry() - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境国家/地区名。
getDisplayCountry(Locale) - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境国家/地区名。
getDisplayCountry(String, Locale) - 类 java.util.spi.LocaleNameProvider 中的方法
返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。
getDisplayedMnemonic() - 类 javax.swing.JLabel 中的方法
返回指示助记符键的键代码。
getDisplayedMnemonicIndex() - 类 javax.swing.AbstractButton 中的方法
以索引形式返回字符，它表示助记符字符，外观应该对其提供装饰。
getDisplayedMnemonicIndex() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
提供关于 getDisplayName 中字符的索引在外观方面的提示，字符索引应以可视化的方式标识为助记符。
getDisplayedMnemonicIndex() - 类 javax.swing.JLabel 中的方法
以索引的形式返回字符，外观应提供该字符的装饰以表示助记符。
getDisplayedMnemonicIndexAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回作为索引的字符，外观必须提供它来表示助记符字符。
getDisplayFormatter() - 类 javax.swing.text.DefaultFormatterFactory 中的方法
返回在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
getDisplayLanguage() - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境语言名。
getDisplayLanguage(Locale) - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境语言名。
getDisplayLanguage(String, Locale) - 类 java.util.spi.LocaleNameProvider 中的方法
返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。
getDisplayMode() - 类 java.awt.GraphicsDevice 中的方法
返回此 GraphicsDevice 的当前显示模式。
getDisplayModes() - 类 java.awt.GraphicsDevice 中的方法
返回可用于此 GraphicsDevice 的所有显示模式。
getDisplayName() - 类 java.beans.FeatureDescriptor 中的方法
获得此特性的本地化显示名称。
getDisplayName() - 类 java.net.NetworkInterface 中的方法
获取此网络接口的显示名称。
getDisplayName(int, int, Locale) - 类 java.util.Calendar 中的方法
返回给定 style 和 locale 下的日历 field 值的字符串表示形式。
getDisplayName() - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境名。
getDisplayName(Locale) - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境名。
getDisplayName(String, boolean, int, Locale) - 类 java.util.spi.TimeZoneNameProvider 中的方法
返回适于展示给指定语言环境用户的给定时区 ID 名称。
getDisplayName() - 类 java.util.TimeZone 中的方法
返回适合于展示给默认区域的用户的时区名称。
getDisplayName(Locale) - 类 java.util.TimeZone 中的方法
返回适合于展示给指定区域的用户的时区名称。
getDisplayName(boolean, int) - 类 java.util.TimeZone 中的方法
返回适合于展示给默认区域的用户的时区名称。
getDisplayName(boolean, int, Locale) - 类 java.util.TimeZone 中的方法
返回适合于展示给指定区域的用户的时区名称。
getDisplayName() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回一个包含面板显示名称的字符串。
getDisplayNames(int, int, Locale) - 类 java.util.Calendar 中的方法
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。
getDisplaySize() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回显示区域的计算大小。
getDisplayVariant() - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境变量代码名。
getDisplayVariant(Locale) - 类 java.util.Locale 中的方法
返回适合向用户显示的语言环境变量代码名。
getDisplayVariant(String, Locale) - 类 java.util.spi.LocaleNameProvider 中的方法
返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。
getDivider() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回顶层 Component 之间的分隔符。
getDividerBorderSize() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
已过时。 从 Java 2 平台 v1.3 开始，由在分隔符上设置边框取代。
getDividerLocation() - 类 javax.swing.JSplitPane 中的方法
返回最后传递给 setDividerLocation 的值。
getDividerLocation(JSplitPane) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回分隔符的位置，该位置可能不同于拆分窗格认为分隔符所在的位置。
getDividerLocation(JSplitPane) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getDividerLocation 方法。
getDividerLocation(JSplitPane) - 类 javax.swing.plaf.SplitPaneUI 中的方法
返回分隔符的位置。
getDividerSize() - 类 javax.swing.JSplitPane 中的方法
返回分隔条的大小。
getDividerSize() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回分隔符的大小。
getDivisionType() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件的定时 division 类型。
getDivisionType() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 的定时 division 类型。
getDoc() - 接口 javax.print.MultiDoc 中的方法
获取当前的 doc 对象。
getDocComment(Element) - 接口 javax.lang.model.util.Elements 中的方法
返回元素的文档（"Javadoc"）注释文本。
getDocFlavor() - 接口 javax.print.Doc 中的方法
确定此 doc 对象提供其部分打印数据所用的 DocFlavor。
getDocFlavor() - 类 javax.print.SimpleDoc 中的方法
确定其 doc 对象将提供其部分打印数据的 doc flavor。
getDockingColor() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
获取在连接 (docking) 区域上时显示的颜色。
getDoctype() - 接口 org.w3c.dom.Document 中的方法
与此文档相关的文档类型声明（参见 DocumentType）。
getDocument() - 接口 javax.swing.event.DocumentEvent 中的方法
获得发起更改事件的文档。
getDocument() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获得基础模型。
getDocument() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
获得发起更改事件的文档。
getDocument() - 类 javax.swing.text.AbstractWriter 中的方法
获取文档。
getDocument() - 类 javax.swing.text.DocumentFilter.FilterBypass 中的方法
返回发生变化的 Document。
getDocument() - 接口 javax.swing.text.Element 中的方法
获取与此元素关联的文档。
getDocument() - 类 javax.swing.text.JTextComponent 中的方法
获取与编辑器关联的模型。
getDocument() - 类 javax.swing.text.View 中的方法
获取与视图关联的模型。
getDocumentBase() - 类 java.applet.Applet 中的方法
获取嵌入此 applet 的文档的 URL。
getDocumentBase() - 接口 java.applet.AppletStub 中的方法
获取嵌入 applet 的文档的 URL。
getDocumentBase() - 类 javax.management.loading.MLetContent 中的方法
获取 MLet 文本文件的基本 URL。
getDocumentElement() - 接口 org.w3c.dom.Document 中的方法
这是一种便捷属性，该属性允许直接访问文档的文档元素的子节点。
getDocumentFilter() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
如果想要提供某个 DocumentFilter 以限制输入内容，则应进行子类化和重写。
getDocumentFilter() - 类 javax.swing.text.AbstractDocument 中的方法
返回负责进行插入/移除过滤的 DocumentFilter。
getDocumentFilter() - 类 javax.swing.text.DefaultFormatter 中的方法
返回用于限制放置到 JFormattedTextField 中的字符的 DocumentFilter。
getDocumentListeners() - 类 javax.swing.text.AbstractDocument 中的方法
返回在此文档上注册的所有文档侦听器的数组。
getDocumentProperties() - 类 javax.swing.text.AbstractDocument 中的方法
支持管理属性集。
getDocumentTypeDeclaration() - 接口 javax.xml.stream.events.DTD 中的方法
以字符串形式返回完整文档类型声明，其中包括内部 DTD 子集。
getDocumentURI() - 接口 org.w3c.dom.Document 中的方法
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。
getDoInput() - 类 java.net.URLConnection 中的方法
返回此 URLConnection 的 doInput 标志的值。
getDomain() - 类 java.net.HttpCookie 中的方法
返回为此 cookie 设置的域名。
getDomain() - 类 javax.management.ObjectName 中的方法
返回域部分。
getDomainCombiner() - 类 java.security.AccessControlContext 中的方法
获取与此 AccessControlContext 关联的 DomainCombiner。
getDomains() - 接口 javax.management.MBeanServer 中的方法

getDomains() - 接口 javax.management.MBeanServerConnection 中的方法
返回其中所有 MBean 当前已注册的域的列表。
getDomains(Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getDomains() 方法。
getDomains(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getDomains(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getDomConfig() - 接口 org.w3c.dom.Document 中的方法
调用 Document.normalizeDocument() 时使用的配置。
getDomConfig() - 接口 org.w3c.dom.ls.LSParser 中的方法
解析输入源时使用的 DOMConfiguration 对象。
getDomConfig() - 接口 org.w3c.dom.ls.LSSerializer 中的方法
在序列化 DOM 节点时由 LSSerializer 使用的 DOMConfiguration 对象。
getDOMImplementation() - 类 javax.xml.parsers.DocumentBuilder 中的方法
获取 DOMImplementation 对象的一个实例。
getDOMImplementation(String) - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的方法
返回第一个具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。
getDOMImplementation(String) - 接口 org.w3c.dom.DOMImplementationSource 中的方法
请求支持指定的功能的第一个 DOM 实现的方法。
getDOMImplementationList(String) - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的方法
返回支持所需功能的实现列表。
getDOMImplementationList(String) - 接口 org.w3c.dom.DOMImplementationSource 中的方法
请求支持指定功能和版本的 DOM 实现的列表的方法，如下所述。
getDoOutput() - 类 java.net.URLConnection 中的方法
返回此 URLConnection 的 doOutput 标志的值。
getDot() - 类 javax.swing.event.CaretEvent 中的方法
获得插入符的位置。
getDot() - 接口 javax.swing.text.Caret 中的方法
获取插入符的当前位置。
getDot() - 类 javax.swing.text.DefaultCaret 中的方法
获取插入符的当前位置。
getDotBias() - 类 javax.swing.text.DefaultCaret 中的方法
返回插入符位置的偏差。
getDouble(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 double 形式返回指定数组对象中索引组件的值。
getDouble(Object) - 类 java.lang.reflect.Field 中的方法
获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。
getDouble() - 类 java.nio.ByteBuffer 中的方法
用于读取 double 值的相对 get 方法。
getDouble(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 double 值的绝对 get 方法。
getDouble(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 double 值的形式获取指定的 JDBC DOUBLE 参数的值。
getDouble(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 double 值的形式获取 JDBC DOUBLE 参数的值。
getDouble(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
getDouble(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
getDouble(String, double) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getDouble(String,double) 中的规范实现 getDouble 方法。
getDouble(String, double) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定的键相关联的、由字符串表示的 double 值。
getDoubleBufferMaximumSize() - 类 javax.swing.RepaintManager 中的方法
返回最大双缓冲区大小。
getDoubleParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 double 返回参数的便捷方法。
getDragAction() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回用户所选操作的 int 表示形式。
getDragEnabled() - 类 javax.swing.JColorChooser 中的方法
获取 dragEnabled 属性的值。
getDragEnabled() - 类 javax.swing.JFileChooser 中的方法
获得 dragEnabled 属性的值。
getDragEnabled() - 类 javax.swing.JList 中的方法
返回是否启用自动拖动处理。
getDragEnabled() - 类 javax.swing.JTable 中的方法
返回是否启用自动拖动处理。
getDragEnabled() - 类 javax.swing.JTree 中的方法
返回是否启用自动拖动处理。
getDragEnabled() - 类 javax.swing.text.JTextComponent 中的方法
返回是否启用自动拖动处理。
getDraggedColumn() - 类 javax.swing.table.JTableHeader 中的方法
当且仅当正在进行拖动时，返回被拖动的列，否则返回 null。
getDraggedDistance() - 类 javax.swing.table.JTableHeader 中的方法
当且仅当正在进行拖动时，返回该列到其初始位置的水平距离。
getDragMode() - 类 javax.swing.JDesktopPane 中的方法
获取桌面窗格当前使用的“拖动样式”。
getDragOrigin() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回 Component 坐标中开始拖动位置的 Point。
getDragSource() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回 DragSource。
getDragSource() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法返回 DragSource，为了进行 Drag 和 Drop 操作，将使用此 DragGestureRecognizer。
getDragSource() - 类 java.awt.dnd.DragSourceContext 中的方法
返回实例化此 DragSourceContext 的 DragSource。
getDragSourceContext() - 类 java.awt.dnd.DragSourceEvent 中的方法
此方法返回引起事件的 DragSourceContext。
getDragSourceListeners() - 类 java.awt.dnd.DragSource 中的方法
获得向此 DragSource 注册的所有 DragSourceListener。
getDragSourceMotionListeners() - 类 java.awt.dnd.DragSource 中的方法
获得向此 DragSource 注册的所有 DragSourceMotionListener。
getDragThreshold() - 类 java.awt.dnd.DragSource 中的静态方法
返回拖动操作移动阈值。
getDrawGraphics() - 类 java.awt.Component.BltBufferStrategy 中的方法

getDrawGraphics() - 类 java.awt.Component.FlipBufferStrategy 中的方法

getDrawGraphics() - 类 java.awt.image.BufferStrategy 中的方法
创建用于绘制缓冲区的图形上下文。
getDrawsLayeredHighlights() - 类 javax.swing.text.DefaultHighlighter 中的方法

getDriver(String) - 类 java.sql.DriverManager 中的静态方法
试图查找能理解给定 URL 的驱动程序。
getDriverMajorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 JDBC 驱动程序的主版本号。
getDriverMinorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 JDBC 驱动程序的次版本号。
getDriverName() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 JDBC 驱动程序的名称。
getDrivers() - 类 java.sql.DriverManager 中的静态方法
获取带有当前调用者可以访问的所有当前已加载 JDBC 驱动程序的 Enumeration。
getDriverVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 JDBC 驱动程序的 String 形式的版本号。
getDropAction() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回目标放置动作与拖动源支持的放置动作集合的逻辑交集。
getDropAction() - 类 java.awt.dnd.DragSourceDropEvent 中的方法
此方法返回一个 int 值，表示放置主题目标执行的操作。
getDropAction() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回用户 drop 操作。
getDropAction() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回用户 drop 操作。
getDropAction() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
当此 TransferSupport 表示放置操作时，返回为其选择的动作。
getDropLocation() - 类 javax.swing.JList 中的方法
返回在该组件上执行 DnD 操作期间此组件应该视觉上指示为放置位置的位置；如果当前没有任何显示的位置，则返回 null。
getDropLocation() - 类 javax.swing.JTable 中的方法
返回对组件的 DnD 操作期间此组件应该可见地指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。
getDropLocation() - 类 javax.swing.JTree 中的方法
返回该组件上 DnD 操作期间此组件应该视觉上指示为放置操作的位置；如果当前未显示任何位置，则返回 null。
getDropLocation() - 类 javax.swing.text.JTextComponent 中的方法
返回在组件上进行 DnD 操作过程中此组件在视觉上指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。
getDropLocation() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
此 TransferSupport 表示一个放置操作时，返回组件的当前放置位置（非 null）。
getDropMode() - 类 javax.swing.JList 中的方法
返回此组件的放置模式。
getDropMode() - 类 javax.swing.JTable 中的方法
返回此组件的放置模式。
getDropMode() - 类 javax.swing.JTree 中的方法
返回此组件的放置模式。
getDropMode() - 类 javax.swing.text.JTextComponent 中的方法
返回此组件的放置模式。
getDropPoint() - 类 javax.swing.TransferHandler.DropLocation 中的方法
返回放置点，表示组件内鼠标的当前位置。
getDropSuccess() - 类 java.awt.dnd.DragSourceDropEvent 中的方法
此方法返回表示放置是否成功的 boolean 值。
getDropTarget() - 类 java.awt.Component 中的方法
获取与此 Component 相关的 DropTarget。
getDropTarget() - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回与此 DropTargetContext 相关的 DropTarget。
getDropTargetContext() - 类 java.awt.dnd.DropTarget 中的方法
获取与此 DropTarget 关联的 DropTargetContext。
getDropTargetContext() - 类 java.awt.dnd.DropTargetEvent 中的方法
此方法返回与该 DropTargetEvent 相关的 DropTargetContext。
getDSTSavings() - 类 java.util.SimpleTimeZone 中的方法
返回设置在夏令时期间时钟提前的时间量（以毫秒为单位）。
getDSTSavings() - 类 java.util.TimeZone 中的方法
返回要添加到本地标准时间以获取本地挂钟时间的时间量。
getDTD(String) - 类 javax.swing.text.html.parser.DTD 中的静态方法
返回具有指定 name 的 DTD。
getDTDHandler() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
返回当前 DTD 处理程序。
getDTDHandler() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取当前 DTD 事件处理程序。
getDTDHandler() - 接口 org.xml.sax.XMLReader 中的方法
返回当前的 DTD 处理程序。
getDTDType() - 接口 javax.xml.stream.events.Attribute 中的方法
获取此属性的类型，默认值是字符串 "CDATA"，
getEarliestSequenceNumber() - 类 javax.management.remote.NotificationResult 中的方法
返回缓存中保留的最早通知的序列号。
getEarlyReflectionDelay() - 类 javax.sound.sampled.ReverbType 中的方法
返回早期反射延迟时间，以微秒为单位。
getEarlyReflectionIntensity() - 类 javax.sound.sampled.ReverbType 中的方法
返回早期反射密度，以分贝为单位。
getEastPane() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getEchoChar() - 类 java.awt.TextField 中的方法
获取用于回显的字符。
getEchoChar() - 类 javax.swing.JPasswordField 中的方法
返回要用于回显的字符。
getEdgeCondition() - 类 java.awt.image.ConvolveOp 中的方法
返回边缘条件。
getEdit() - 类 javax.swing.event.UndoableEditEvent 中的方法
返回 edit 值。
getEditFormatter() - 类 javax.swing.text.DefaultFormatterFactory 中的方法
返回在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
getEditingColumn() - 类 javax.swing.JTable 中的方法
返回包含当前被编辑的单元格的列索引。
getEditingPath() - 类 javax.swing.JTree 中的方法
返回当前正在编辑的元素的路径。
getEditingPath(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回到达正被编辑的元素的路径。
getEditingPath(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getEditingPath 方法。
getEditingPath(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
返回到达正被编辑的元素的路径。
getEditingRow() - 类 javax.swing.JTable 中的方法
返回包含当前被编辑的单元格的行索引。
getEditor() - 类 javax.swing.JComboBox 中的方法
返回用于绘制和编辑 JComboBox 字段中所选项的编辑器。
getEditor() - 类 javax.swing.JSpinner 中的方法
返回显示和潜在更改模型值的组件。
getEditor(ActionEvent) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
获得操作的目标编辑器。
getEditorComponent() - 接口 javax.swing.ComboBoxEditor 中的方法
返回应该添加到此编辑器的树层次结构中的组件。
getEditorComponent() - 类 javax.swing.JTable 中的方法
返回处理编辑会话的组件。
getEditorComponent() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法

getEditorKit() - 类 javax.swing.JEditorPane 中的方法
获取用于处理内容的、当前已安装的工具包。
getEditorKit(JTextComponent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
获取 UI 的 EditorKit。
getEditorKit(JTextComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取 UI 的 EditorKit。
getEditorKit(JTextComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getEditorKit 方法。
getEditorKit(JTextComponent) - 类 javax.swing.plaf.TextUI 中的方法
获取为要编辑的文档类型设置策略的服务绑定。
getEditorKitClassNameForContentType(String) - 类 javax.swing.JEditorPane 中的静态方法
返回当前向类型 type 所注册的 EditorKit 类名。
getEditorKitForContentType(String) - 类 javax.swing.JEditorPane 中的方法
获取用于给定内容类型的编辑器工具包。
getEditorSearchPath() - 类 java.beans.PropertyEditorManager 中的静态方法
获得用来搜索属性编辑器的包名称。
getEffectiveKeyBits() - 类 javax.crypto.spec.RC2ParameterSpec 中的方法
返回以位为单位的有效密钥大小。
getElem(int) - 类 java.awt.image.DataBuffer 中的方法
以整数类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBuffer 中的方法
以整数类型返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferByte 中的方法
返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferByte 中的方法
返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferDouble 中的方法
以 int 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferDouble 中的方法
以 int 类型返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferFloat 中的方法
以 int 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferFloat 中的方法
以 int 类型返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferInt 中的方法
返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferInt 中的方法
返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferShort 中的方法
返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferShort 中的方法
返回指定存储单元中所请求的数据数组元素。
getElem(int) - 类 java.awt.image.DataBufferUShort 中的方法
返回第一个（默认）存储单元中所请求的数据数组元素。
getElem(int, int) - 类 java.awt.image.DataBufferUShort 中的方法
返回指定存储单元中所请求的数据数组元素。
getElemDouble(int) - 类 java.awt.image.DataBuffer 中的方法
以 double 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemDouble(int, int) - 类 java.awt.image.DataBuffer 中的方法
以 double 类型返回指定存储单元所请求的数据数组元素。
getElemDouble(int) - 类 java.awt.image.DataBufferDouble 中的方法
以 double 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemDouble(int, int) - 类 java.awt.image.DataBufferDouble 中的方法
以 double 类型返回指定存储单元中所请求的数据数组元素。
getElemDouble(int) - 类 java.awt.image.DataBufferFloat 中的方法
以 double 类型返回第一个（默认）存储单元所请求的数据数组元素。
getElemDouble(int, int) - 类 java.awt.image.DataBufferFloat 中的方法
以 double 类型返回指定存储单元所请求的数据数组元素。
getElement() - 接口 javax.swing.event.DocumentEvent.ElementChange 中的方法
返回所表示的元素。
getElement(int) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取子元素。
getElement(int) - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得一个子元素。
getElement() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
返回基础元素。
getElement(int) - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得一个子元素。
getElement(int) - 接口 javax.swing.text.Element 中的方法
获取给定索引处的子元素。
getElement(String) - 类 javax.swing.text.html.HTMLDocument 中的方法
返回具有给定 id Attribute 的元素。
getElement(Element, Object, Object) - 类 javax.swing.text.html.HTMLDocument 中的方法
返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。
getElement(String) - 类 javax.swing.text.html.parser.DTD 中的方法
按名称获取一个元素。
getElement(int) - 类 javax.swing.text.html.parser.DTD 中的方法
按索引获取一个元素。
getElement() - 类 javax.swing.text.html.parser.TagElement 中的方法

getElement() - 类 javax.swing.text.View 中的方法
获取此视图所映射的主题的结构化部分。
getElement(ResultT) - 接口 javax.xml.bind.annotation.DomHandler 中的方法
将部分发送到 Result 后，JAXB 提供者将调用此方法来获取已解组元素表示形式。
getElement(DOMResult) - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法

getElementAt(int) - 类 javax.swing.DefaultComboBoxModel 中的方法

getElementAt(int) - 类 javax.swing.DefaultListModel 中的方法
返回指定索引处的组件。
getElementAt(int) - 接口 javax.swing.ListModel 中的方法
返回指定索引处的值。
getElementAt(int) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法

getElementAt(int) - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法

getElementAt(int) - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法

getElementById(String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
返回具有指定 ID 属性值的 Element。
getElementById(String) - 接口 org.w3c.dom.Document 中的方法
返回具有带给定值的 ID 属性的 Element。
getElementCount() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素子级的数量。
getElementCount() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得该元素的子元素数。
getElementCount() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
返回子元素的数量。
getElementCount() - 接口 javax.swing.text.Element 中的方法
获得此元素包含的子元素数。
getElementDescription(String, Locale) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回包含指定元素的描述的 String，或者 null。
getElementDescription(String, Locale) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
返回包含指定元素的描述的 String，或者 null。
getElementIndex(int) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取最接近给定模型偏移量的子元素索引。
getElementIndex(int) - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得与给定模型偏移量最接近的子元素索引。
getElementIndex(int) - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得与给定模型偏移量最接近的子元素索引。
getElementIndex(int) - 接口 javax.swing.text.Element 中的方法
获得离给定偏移量最近的子元素索引。
getElementIterator() - 类 javax.swing.text.AbstractWriter 中的方法
获取 ElementIterator。
getElementMaxChildren(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最大子元素数。
getElementMaxChildren(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getElementMinChildren(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最小子元素数。
getElementMinChildren(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getElementName(Object) - 类 javax.xml.bind.JAXBIntrospector 中的方法
获取 jaxbElement 的 xml 元素 qname。
getElementName() - 接口 javax.xml.soap.SOAPElement 中的方法
返回此 SOAPElement 对象的名称。
getElementOpenType() - 类 javax.management.openmbean.ArrayType 中的方法
返回此 ArrayType 实例描述的数组中包含的元素值的开放类型。
getElementQName() - 接口 javax.xml.soap.SOAPElement 中的方法
返回此 SOAPElement 对象的 qname。
getElements() - 类 javax.swing.ButtonGroup 中的方法
返回此组中的所有按钮。
getElements(Vector<Element>) - 类 javax.swing.text.html.parser.ContentModel 中的方法
使用作为此 contentModel 一部分的元素列表更新 elemVec。
getElementsAnnotatedWith(TypeElement) - 接口 javax.annotation.processing.RoundEnvironment 中的方法
返回使用给定注释类型注释的元素。
getElementsAnnotatedWith(Class<? extends Annotation>) - 接口 javax.annotation.processing.RoundEnvironment 中的方法
返回使用给定注释类型注释的元素。
getElementsAt(HTMLDocument, int) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法
返回包含 offset 的 Elements 数组。
getElementsByTagName(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getElementsByTagName(String) - 接口 org.w3c.dom.Document 中的方法
按文档顺序返回包含在文档中且具有给定标记名称的所有 Element 的 NodeList。
getElementsByTagName(String) - 接口 org.w3c.dom.Element 中的方法
以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。
getElementsByTagNameNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 getElementsByTagName(localName)。
getElementsByTagNameNS(String, String) - 接口 org.w3c.dom.Document 中的方法
以文档顺序返回具有给定本地名称和名称空间 URI 的所有 Elements 的 NodeList。
getElementsByTagNameNS(String, String) - 接口 org.w3c.dom.Element 中的方法
以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。
getElementText() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法

getElementText() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getElementText() - 接口 javax.xml.stream.XMLEventReader 中的方法
读取纯文本元素的内容。
getElementText() - 接口 javax.xml.stream.XMLStreamReader 中的方法
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。
getElementTypeInfo() - 类 javax.xml.validation.TypeInfoProvider 中的方法
返回当前元素的不可变的 TypeInfo 对象。
getElementUtils() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回用来在元素上进行操作的某些实用工具方法的实现。
getElementValues() - 接口 javax.lang.model.element.AnnotationMirror 中的方法
返回此注释元素的值。
getElementValuesWithDefaults(AnnotationMirror) - 接口 javax.lang.model.util.Elements 中的方法
返回注释元素的值，包括默认值。
getElemFloat(int) - 类 java.awt.image.DataBuffer 中的方法
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemFloat(int, int) - 类 java.awt.image.DataBuffer 中的方法
以 float 类型返回指定存储单元中所请求的数据数组元素。
getElemFloat(int) - 类 java.awt.image.DataBufferDouble 中的方法
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemFloat(int, int) - 类 java.awt.image.DataBufferDouble 中的方法
以 float 类型返回指定存储单元中所请求的数据数组元素。
getElemFloat(int) - 类 java.awt.image.DataBufferFloat 中的方法
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
getElemFloat(int, int) - 类 java.awt.image.DataBufferFloat 中的方法
以 float 类型返回指定存储单元中所请求的数据数组元素。
getEmptySet() - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
获取一个空的 AttributeSet。
getEmptySet() - 类 javax.swing.text.StyleContext 中的方法
获取空 AttributeSet。
getEnabledAttributes() - 类 javax.management.AttributeChangeNotificationFilter 中的方法
获得此过滤器的所有已启用属性名称。
getEnabledCipherSuites() - 类 javax.net.ssl.SSLEngine 中的方法
返回为了在此引擎上使用而当前已启用的 SSL 密码套件名称。
getEnabledCipherSuites() - 类 javax.net.ssl.SSLServerSocket 中的方法
返回当前被启用以供新接受的连接使用的密码套件列表。
getEnabledCipherSuites() - 类 javax.net.ssl.SSLSocket 中的方法
返回当前启用以供此连接使用的 SSL 密码套件的名称。
getEnabledCipherSuites() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的密码套件的名称，如果此工厂使用默认启用的密码套件，则返回 null。
getEnabledObjectNames() - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
获取所有已启用的 ObjectName。
getEnabledProtocols() - 类 javax.net.ssl.SSLEngine 中的方法
返回当前已启用的，以便让 SSLEngine 使用的协议版本的名称。
getEnabledProtocols() - 类 javax.net.ssl.SSLServerSocket 中的方法
返回当前新接受的连接启用的协议的名称。
getEnabledProtocols() - 类 javax.net.ssl.SSLSocket 中的方法
返回当前启用以供此连接使用的协议版本的名称。
getEnabledProtocols() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的协议版本的名称，如果此工厂使用默认启用的协议版本，则返回 null。
getEnabledTypes() - 类 javax.management.NotificationFilterSupport 中的方法
获得此过滤器的所有允许通知类型。
getEnableSessionCreation() - 类 javax.net.ssl.SSLEngine 中的方法
如果可以由此引擎建立新的 SSL 会话，则返回 true。
getEnableSessionCreation() - 类 javax.net.ssl.SSLServerSocket 中的方法
如果新 SSL 会话可以通过此服务器套接字创建的套接字建立，则返回 true。
getEnableSessionCreation() - 类 javax.net.ssl.SSLSocket 中的方法
如果可以使用此套接字建立新的 SSL 会话，则返回 true。
getEnclosedElements() - 接口 javax.lang.model.element.Element 中的方法
返回此元素直接封装（非严格意义上）的元素。
getEnclosingClass() - 类 java.lang.Class 中的方法
返回底层类的立即封闭类。
getEnclosingConstructor() - 类 java.lang.Class 中的方法
如果该 Class 对象表示构造方法中的一个本地或匿名类，则返回 Constructor 对象，它表示底层类的立即封闭构造方法。
getEnclosingElement() - 接口 javax.lang.model.element.Element 中的方法
返回封装此元素（非严格意义上）的最里层元素。
getEnclosingMethod() - 类 java.lang.Class 中的方法
如果此 Class 对象表示某一方法中的一个本地或匿名类，则返回 Method 对象，它表示底层类的立即封闭方法。
getEnclosingType() - 接口 javax.lang.model.type.DeclaredType 中的方法
返回封装实例的最里层类型；如果没有任何封装实例，则返回种类为 NONE 的 NoType。
getEncoded() - 类 java.security.AlgorithmParameters 中的方法
返回基本编码格式的参数。
getEncoded(String) - 类 java.security.AlgorithmParameters 中的方法
返回以指定方案编码的参数。
getEncoded() - 类 java.security.cert.Certificate 中的方法
返回此证书的编码形式。
getEncoded() - 类 java.security.cert.CertPath 中的方法
返回此证书路径的编码形式，使用默认的编码。
getEncoded(String) - 类 java.security.cert.CertPath 中的方法
返回此证书路径的编码形式，使用指定的编码。
getEncoded() - 类 java.security.cert.PolicyQualifierInfo 中的方法
返回此 PolicyQualifierInfo 的 ASN.1 DER 编码形式。
getEncoded() - 类 java.security.cert.X509CRL 中的方法
返回此 CRL 的 ASN.1 DER 编码形式。
getEncoded() - 类 java.security.cert.X509CRLEntry 中的方法
返回此 CRL Entry 的 ASN.1 DER 编码形式，即内部 SEQUENCE。
getEncoded() - 接口 java.security.Key 中的方法
返回基本编码格式的密钥，如果此密钥不支持编码，则返回 null。
getEncoded() - 类 java.security.spec.EncodedKeySpec 中的方法
返回编码密钥。
getEncoded() - 类 java.security.spec.PKCS8EncodedKeySpec 中的方法
返回按照 PKCS #8 标准编码的密钥字节。
getEncoded() - 类 java.security.spec.X509EncodedKeySpec 中的方法
返回按照 X.509 标准进行编码的密钥的字节。
getEncoded() - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
返回此对象的 ASN.1 编码。
getEncoded() - 类 javax.crypto.spec.SecretKeySpec 中的方法
返回此密钥的密钥内容。
getEncoded() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回秘密密钥的密钥材料。
getEncoded() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回整个票据的 ASN.1 编码。
getEncoded() - 类 javax.security.auth.x500.X500Principal 中的方法
返回 ASN.1 DER 编码形式的标识名。
getEncoded() - 类 javax.security.cert.Certificate 中的方法
返回此证书的编码形式。
getEncodedValue() - 类 javax.naming.ldap.BasicControl 中的方法
检索控件的 ASN.1 BER 编码值。
getEncodedValue() - 接口 javax.naming.ldap.Control 中的方法
检索 LDAP 控件的 ASN.1 BER 编码值。
getEncodedValue() - 接口 javax.naming.ldap.ExtendedRequest 中的方法
检索 LDAP 扩展操作请求的 ASN.1 BER 编码值。
getEncodedValue() - 接口 javax.naming.ldap.ExtendedResponse 中的方法
检索 LDAP 扩展操作响应的 ASN.1 BER 编码值。
getEncodedValue() - 类 javax.naming.ldap.StartTlsRequest 中的方法
检索 StartTLS 请求的 ASN.1 BER 编码值。
getEncodedValue() - 类 javax.naming.ldap.StartTlsResponse 中的方法
检索 StartTLS 响应的 ASN.1 BER 编码值。
getEncoding() - 类 java.io.InputStreamReader 中的方法
返回此流使用的字符编码的名称。
getEncoding() - 类 java.io.OutputStreamWriter 中的方法
返回此流使用的字符编码的名称。
getEncoding() - 类 java.util.logging.Handler 中的方法
返回该 Handler 的字符编码。
getEncoding() - 类 javax.sound.sampled.AudioFormat 中的方法
获取此格式声音的编码类型。
getEncoding() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取当前输出编码的便捷方法。
getEncoding() - 接口 javax.xml.crypto.dsig.XMLObject 中的方法
返回此 XMLObject 的编码 URI。
getEncoding() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getEncoding() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果输入编码已知，则返回输入编码；如果未知，则返回 null。
getEncoding() - 接口 org.w3c.dom.ls.LSInput 中的方法
字符编码（如果已知）。
getEncoding() - 接口 org.w3c.dom.ls.LSOutput 中的方法
用于输出的字符编码。
getEncoding() - 接口 org.xml.sax.ext.Locator2 中的方法
返回实体的字符编码的名称。
getEncoding() - 类 org.xml.sax.ext.Locator2Impl 中的方法
返回编码属性的当前值。
getEncoding() - 类 org.xml.sax.InputSource 中的方法
获取字节流或 URI 的字符编码。
getEncodings() - 类 java.security.cert.CertPath 中的方法
返回此证书路径支持的编码的迭代，默认编码方式优先。
getEncodingStyle() - 接口 javax.xml.soap.SOAPElement 中的方法
返回此 SOAPElement 对象的编码样式。
getEncryptedData() - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
返回加密的数据。
getEnd() - 类 javax.swing.SpinnerDateModel 中的方法
返回序列中的最后一个 Date。
getEndCap() - 类 java.awt.BasicStroke 中的方法
返回端点的 cap 样式。
getEndIndex() - 接口 java.text.CharacterIterator 中的方法
返回文本的结束索引。
getEndIndex() - 类 java.text.FieldPosition 中的方法
获取紧跟请求字段中最后一个字符的字符索引。
getEndIndex() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.getEndIndex()。
getEndIndex() - 类 javax.accessibility.AccessibleHyperlink 中的方法
获得此链接结束处该超文本文档的索引
getEndIndex() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
获得此链接结束处该超文本文档的索引
getEndIndex() - 类 javax.swing.text.Segment 中的方法
返回文本的结束索引。
getEndOffset() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素在此模型中的终止偏移量。
getEndOffset() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得模型中该元素的结束偏移量。
getEndOffset() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得模型中该元素的结束偏移量。
getEndOffset() - 类 javax.swing.text.AbstractWriter 中的方法
选择要输出内容的最后一个偏移量。
getEndOffset() - 接口 javax.swing.text.Element 中的方法
获取此元素结束处的文档起始偏移量。
getEndOffset() - 类 javax.swing.text.GlyphView 中的方法
获取此视图负责的一部分模型。
getEndOffset() - 接口 javax.swing.text.Highlighter.Highlight 中的方法
获取高亮显示结束模型偏移量。
getEndOffset() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
返回当前出现的标记所定义的并具有相同属性的范围结尾处。
getEndOffset() - 类 javax.swing.text.View 中的方法
获取此视图负责的模型的一部分。
getEndPoint() - 类 java.awt.geom.Arc2D 中的方法
返回弧的结束点。
getEndPoint() - 类 java.awt.LinearGradientPaint 中的方法
返回渐变轴结束点的副本。
getEndPosition() - 类 javax.swing.text.AbstractDocument 中的方法
返回表示文档结尾的位置。
getEndPosition() - 接口 javax.swing.text.Document 中的方法
返回代表文档结束处的位置。
getEndPosition() - 接口 javax.tools.Diagnostic 中的方法
获取距文件开始位置的字符偏移量，其中文件与指示问题结束位置的此诊断关联。
getEndTime() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回此票据有效期的期满时间。
getEngine() - 类 javax.script.CompiledScript 中的方法
返回用 compile 方法创建了此 CompiledScript 的 ScriptEngine。
getEngineByExtension(String) - 类 javax.script.ScriptEngineManager 中的方法
查找并创建一个给定扩展的 ScriptEngine。
getEngineByMimeType(String) - 类 javax.script.ScriptEngineManager 中的方法
查找并创建一个给定 mime 类型的 ScriptEngine。
getEngineByName(String) - 类 javax.script.ScriptEngineManager 中的方法
查找并创建一个给定名称的 ScriptEngine。
getEngineFactories() - 类 javax.script.ScriptEngineManager 中的方法
返回一个数组，该数组的元素是发现机制找到的所有 ScriptEngineFactory 类的实例。
getEngineName() - 接口 javax.script.ScriptEngineFactory 中的方法
返回 ScriptEngine 的完全名称。
getEngineVersion() - 接口 javax.script.ScriptEngineFactory 中的方法
返回 ScriptEngine 的版本。
getEntities() - 接口 javax.xml.stream.events.DTD 中的方法
返回一个列表，其中包含在 DTD 中声明的外部和内部常规实体。
getEntities() - 接口 org.w3c.dom.DocumentType 中的方法
包含在 DTD 中声明的内部和外部常规实体的 NamedNodeMap。
getEntity(String) - 类 javax.swing.text.html.parser.DTD 中的方法
按名称获取一个实体。
getEntity(int) - 类 javax.swing.text.html.parser.DTD 中的方法
获取一个字符实体。
getEntityResolver() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
返回当前实体解析器。
getEntityResolver() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取当前实体解析器。
getEntityResolver() - 接口 org.xml.sax.XMLReader 中的方法
返回当前的实体解析器。
getEntries() - 类 java.util.jar.Manifest 中的方法
返回此 Manifest 中所包含条目的 Map。
getEntry(String, KeyStore.ProtectionParameter) - 类 java.security.KeyStore 中的方法
使用指定保护参数获取指定别名的 keystore Entry。
getEntry(String) - 类 java.util.jar.JarFile 中的方法
返回给定条目名称的 ZipEntry；如果未找到，则返回 null。
getEntry(String) - 类 java.util.zip.ZipFile 中的方法
返回指定名称的 ZIP 文件条目；如果未找到，则返回 null。
getEntryName() - 类 java.net.JarURLConnection 中的方法
返回此连接的条目名称。
getEnumConstants() - 类 java.lang.Class 中的方法
如果此 Class 对象不表示枚举类型，则返回枚举类的元素或 null。
getEnumValueTable() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的枚举类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Chromaticity 中的方法
返回 Chromaticity 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.ColorSupported 中的方法
返回 ColorSupported 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Compression 中的方法
返回 Compression 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Fidelity 中的方法
返回 Fidelity 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Finishings 中的方法
返回 Finishings 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.JobSheets 中的方法
返回 class JobSheets 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.JobState 中的方法
返回 JobState 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.JobStateReason 中的方法
返回 JobStateReason 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.MediaName 中的方法
返回 MediaTray 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.MediaSizeName 中的方法
返回 MediaSizeName 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.MediaTray 中的方法
返回 MediaTray 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的方法
返回 MultipleDocumentHandling 类的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
返回类 OrientationRequested 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PDLOverrideSupported 中的方法
返回类 PDLOverrideSupported 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PresentationDirection 中的方法
返回类 PresentationDirection 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的方法
返回类 PrinterIsAcceptingJobs 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PrinterState 中的方法
返回类 PrinterState 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PrinterStateReason 中的方法
返回类 PrinterStateReason 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.PrintQuality 中的方法
返回类 PrintQuality 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的方法
返回类 ReferenceUriSchemesSupported 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Severity 中的方法
返回类 Severity 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.SheetCollate 中的方法
返回类 SheetCollate 的枚举值表。
getEnumValueTable() - 类 javax.print.attribute.standard.Sides 中的方法
返回类 Sides 的枚举值表。
getenv(String) - 类 java.lang.System 中的静态方法
获取指定的环境变量值。
getenv() - 类 java.lang.System 中的静态方法
返回一个不能修改的当前系统环境的字符串映射视图。
getEnvelope() - 类 javax.xml.soap.SOAPPart 中的方法
获取与此 SOAPPart 对象关联的 SOAPEnvelope 对象。
getEnvironment() - 异常 javax.naming.CannotProceedException 中的方法
检索创建此异常时受影响的环境。
getEnvironment() - 接口 javax.naming.Context 中的方法
检索对此上下文有效的环境。
getEnvironment() - 类 javax.naming.InitialContext 中的方法

getEon() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 year XML 模式 1.0 日期时间数据类型字段的高顺序组件。
getEonAndYear() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 year XML 模式 1.0 的日期时间数据类型字段。
getEras() - 类 java.text.DateFormatSymbols 中的方法
获取年代字符串。
getErrorCode() - 异常 java.sql.SQLException 中的方法
获取此 SQLException 对象的特定于供应商的异常代码。
getErrorCode() - 异常 javax.xml.bind.JAXBException 中的方法
获取特定于供应商的错误代码。
getErrorCode() - 异常 javax.xml.bind.TypeConstraintException 中的方法
获取特定于供应商的错误代码。
getErrorHandler() - 类 javax.xml.validation.SchemaFactory 中的方法
获取设置为此 SchemaFactory 的当前 ErrorHandler。
getErrorHandler() - 类 javax.xml.validation.Validator 中的方法
获取设置为此 Validator 的当前 ErrorHandler。
getErrorHandler() - 类 javax.xml.validation.ValidatorHandler 中的方法
获取设置为此 ValidatorHandler 的当前 ErrorHandler。
getErrorHandler() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
返回当前错误处理程序。
getErrorHandler() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取当前错误事件处理程序。
getErrorHandler() - 接口 org.xml.sax.XMLReader 中的方法
返回当前的错误处理程序。
getErrorIndex() - 类 java.text.ParsePosition 中的方法
获取出错时的索引，如果没有设置错误索引，则为 -1。
getErrorListener() - 类 javax.xml.transform.Transformer 中的方法
获取转换的实际错误事件处理程序。
getErrorListener() - 类 javax.xml.transform.TransformerFactory 中的方法
获取 TransformerFactory 的错误事件处理程序。
getErrorManager() - 类 java.util.logging.Handler 中的方法
获取该 Handler 的 ErrorManager。
getErrorOffset() - 异常 java.text.ParseException 中的方法
返回发现错误的位置。
getErrorsAny() - 类 java.awt.MediaTracker 中的方法
返回所有出错媒体的列表。
getErrorsID(int) - 类 java.awt.MediaTracker 中的方法
返回具有出错的指定 ID 的媒体列表。
getErrorStream() - 类 java.lang.Process 中的方法
获取子进程的错误流。
getErrorStream() - 类 java.net.HttpURLConnection 中的方法
如果连接失败但服务器仍然发送了有用数据，则返回错误流。
getErrorWriter() - 接口 javax.script.ScriptContext 中的方法
返回用来显示错误输出的 Writer。
getErrorWriter() - 类 javax.script.SimpleScriptContext 中的方法
返回用来显示错误输出的 Writer。
getEscapeProcessing() - 类 javax.sql.rowset.BaseRowSet 中的方法
确定是否为此 RowSet 对象启用了转义处理。
getEscapeProcessing() - 接口 javax.sql.RowSet 中的方法
获取是否为此 RowSet 对象启用转义处理。
getEstimatedMajorSpan() - 类 javax.swing.text.AsyncBoxView 中的方法
主跨距当前是估计值吗？
getEtchedBorderUIResource() - 类 javax.swing.plaf.BorderUIResource 中的静态方法

getEtchedInsets() - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
返回 drawEtchedRect() 绘制边框占用的空间量。
getEtchType() - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框设置的蚀刻类型。
getEventAllocator() - 类 javax.xml.stream.XMLInputFactory 中的方法
获取用此工厂创建的流所使用的分配器。
getEventContext() - 类 javax.naming.event.NamingEvent 中的方法
检索触发此事件的事件源。
getEventContext() - 类 javax.naming.event.NamingExceptionEvent 中的方法
检索触发此事件的 EventContext。
getEventHandler() - 类 javax.xml.bind.Binder 中的方法
当前的事件处理程序；如果没有设置，则返回默认事件处理程序。
getEventHandler() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getEventHandler() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
getEventHandler() - 接口 javax.xml.bind.Marshaller 中的方法
返回当前的事件处理程序，如果没有设置该处理程序，则返回默认的事件处理程序。
getEventHandler() - 接口 javax.xml.bind.Unmarshaller 中的方法
返回当前的事件处理程序，如果没有设置事件处理程序，则返回默认的事件处理程序。
getEventHandler() - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
getEventMask() - 类 java.awt.event.AWTEventListenerProxy 中的方法
返回与侦听器有关的事件掩码。
getEventPhase() - 接口 org.w3c.dom.events.Event 中的方法
用于指示当前正在评诂哪个阶段的事件流。
getEventPropertyName() - 类 java.beans.EventHandler 中的方法
返回应该在应用于目标的动作中使用的事件属性。
getEvents() - 类 javax.xml.bind.util.ValidationEventCollector 中的方法
返回一个 ValidationEvent 对象数组，这些对象包含所有收集的错误和警告的副本。
getEventSetDescriptors() - 接口 java.beans.BeanInfo 中的方法
获得 beans EventSetDescriptor。
getEventSetDescriptors() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝事件集的信息。
getEventType() - 类 javax.swing.event.HyperlinkEvent 中的方法
获得事件类型。
getEventType() - 接口 javax.xml.stream.events.XMLEvent 中的方法
返回此事件的整数码。
getEventType() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getEventType() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回一个整数码，指示光标所指向的事件的类型。
getException() - 类 java.awt.event.InvocationEvent 中的方法
返回在执行 Runnable 的 run() 方法时捕获的任何 Exception。
getException() - 异常 java.lang.ClassNotFoundException 中的方法
返回尝试加载类时发生错误引发的异常。
getException() - 错误 java.lang.ExceptionInInitializerError 中的方法
返回静态初始化期间发生的异常，该异常导致发生此错误。
getException() - 异常 java.security.PrivilegedActionException 中的方法
返回特权计算抛出的异常，该异常导致此 PrivilegedActionException。
getException() - 类 javax.naming.event.NamingExceptionEvent 中的方法
检索抛出的异常。
getException() - 类 javax.naming.ldap.SortResponseControl 中的方法
检索适合结果代码的 NamingException。
getException() - 接口 javax.naming.ldap.UnsolicitedNotification 中的方法
检索使用服务器发送的信息构造的异常。
getException() - 错误 javax.xml.parsers.FactoryConfigurationError 中的方法
返回引发此异常的实际异常（如果有）。
getException() - 错误 javax.xml.stream.FactoryConfigurationError 中的方法
返回嵌套异常（如果有）。
getException() - 异常 javax.xml.transform.TransformerException 中的方法
此方法检索此异常所包装的异常。
getException() - 错误 javax.xml.transform.TransformerFactoryConfigurationError 中的方法
返回引发此异常的实际异常（如果有）。
getException() - 异常 org.xml.sax.SAXException 中的方法
返回嵌入的异常（如果有）。
getExceptionListener() - 类 java.beans.Encoder 中的方法
获得此流的异常处理程序。
getExceptionListener() - 类 java.beans.XMLDecoder 中的方法
获得此流的异常处理程序。
getExceptionTypes() - 类 java.lang.reflect.Constructor 中的方法
返回一组表示声明要抛出的异常类型的 Class 对象，这些异常是由此 Constructor 对象表示的底层构造方法抛出的。
getExceptionTypes() - 类 java.lang.reflect.Method 中的方法
返回 Class 对象的数组，这些对象描述了声明将此 Method 对象表示的底层方法抛出的异常类型。
getExclusiveOwnerThread() - 类 java.util.concurrent.locks.AbstractOwnableSynchronizer 中的方法
返回由 setExclusiveOwnerThread 最后设置的线程；如果从未设置，则返回 null。
getExclusiveQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回一个 collection，该 collection 包含正以独占模式等待获取的线程。
getExclusiveQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回包含可能正以独占模式等待获取的线程 collection。
getExecuteExistingDelayedTasksAfterShutdownPolicy() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
获取有关在此执行程序已 shutdown 的情况下是否继续执行现有延迟任务的策略。
getExecutor() - 类 javax.xml.ws.Endpoint 中的方法
返回此 Endpoint 实例的执行程序。
getExecutor() - 类 javax.xml.ws.Service 中的方法
返回此 Service 实例的执行程序。
getExecutor() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
返回此 Service 实例的执行程序。
getExemptionMechanism() - 类 javax.crypto.Cipher 中的方法
返回此 Cipher 使用的豁免 (exemption) 机制对象。
getExp() - 异常 javax.management.BadBinaryOpValueExpException 中的方法
返回产生该异常的 ValueExp。
getExpandedDescendants(TreePath) - 类 javax.swing.JTree 中的方法
返回当前展开的 parent 路径的子路径的 Enumeration。
getExpandedIcon() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getExpandedState(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
如果路径已扩展并且可视，则返回 true。
getExpandedState(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
如果该路径已扩展，并且可见，则返回 true。
getExpandedState(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
如果路径已扩展，并且可见，则返回 true。
getExpandsSelectedPaths() - 类 javax.swing.JTree 中的方法
返回 expandsSelectedPaths 属性。
getExpectedPolicies() - 接口 java.security.cert.PolicyNode 中的方法
返回预期的策略集，其中的策略将满足下一个要处理证书中此节点的有效策略。
getExpiration() - 类 java.net.URLConnection 中的方法
返回 expires 头字段的值。
getExplanation() - 异常 javax.naming.NamingException 中的方法
检索与此异常关联的解释。
getExponent(float) - 类 java.lang.Math 中的静态方法
返回 float 表示形式中使用的无偏指数。
getExponent(double) - 类 java.lang.Math 中的静态方法
返回 double 表示形式中使用的无偏指数。
getExponent(float) - 类 java.lang.StrictMath 中的静态方法
返回 float 表示形式中使用的无偏指数。
getExponent(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 表示形式中使用的无偏指数。
getExponent() - 类 java.security.spec.RSAOtherPrimeInfo 中的方法
返回素数的指数。
getExponentSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
返回用于分隔尾数和指数的字符串。
getExponentSize() - 类 javax.crypto.spec.DHGenParameterSpec 中的方法
以位为单位返回随机指数的大小（私有值）。
getExportedKeys(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取引用给定表的主键列（表导入的外键）的外键列的描述。
getExpression() - 类 javax.xml.crypto.dsig.spec.XPathType 中的方法
返回要计算的 XPath 表达式。
getExtendedKeyUsage() - 类 java.security.cert.X509Certificate 中的方法
获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。
getExtendedKeyUsage() - 类 java.security.cert.X509CertSelector 中的方法
返回 extendedKeyUsage 标准。
getExtendedState() - 类 java.awt.Frame 中的方法
获取此窗体的状态。
getExtendsBound() - 接口 javax.lang.model.type.WildcardType 中的方法
返回此通配符的上边界。
getExtension() - 类 javax.sound.sampled.AudioFileFormat.Type 中的方法
获得此文件类型的常见文件扩展名。
getExtensions() - 接口 javax.script.ScriptEngineFactory 中的方法
返回文件扩展名的不可变列表，这些扩展名通常标识使用此 ScriptEngine 支持的语言所编写的脚本。
getExtensions() - 类 javax.swing.filechooser.FileNameExtensionFilter 中的方法
返回要测试文件的文件扩展名集合。
getExtensionValue(String) - 接口 java.security.cert.X509Extension 中的方法
获取扩展值 (extnValue) 的 DER 编码 OCTET 字符串，该扩展值由传入的 oid String 标识。
getExtent() - 接口 javax.swing.BoundedRangeModel 中的方法
返回模型的 extent，即从模型的 value 开始的内部范围的长度。
getExtent() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回模型的 extent。
getExtent() - 类 javax.swing.JSlider 中的方法
从 BoundedRangeModel 返回“范围”。
getExtentSize() - 类 javax.swing.JViewport 中的方法
返回视图坐标中视图的可见部分的大小。
getExternalElements() - 接口 javax.xml.crypto.dsig.keyinfo.PGPData 中的方法
返回一个不可修改列表，由表示外部名称空间元素中的 XMLStructure 组成。
getExternalSubset(String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
getExternalSubset(String, String) - 接口 org.xml.sax.ext.EntityResolver2 中的方法
允许应用程序为不能显式定义外部子集的文档提供外部子集。
getExtra() - 类 java.util.zip.ZipEntry 中的方法
返回条目的额外字段数据；如果没有，则返回 null。
getExtraImageMetadataFormatNames() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回包含其他文档格式名称，而不是此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。
getExtraMetadataFormatNames() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回一个 String 数组，包含此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的其他元数据格式（本机格式和标准格式除外）的名称。
getExtraNameCharacters() - 接口 java.sql.DatabaseMetaData 中的方法
获取可以在不带引号的标识符名称中使用的所有“额外”字符（除了 a-z、A-Z、0-9 和 _ 以外的字符）。
getExtraStreamMetadataFormatNames() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回包含其他文档格式名称，而不是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。
getFactory() - 接口 javax.script.ScriptEngine 中的方法
返回此 ScriptEngine 所属的类的 ScriptEngineFactory。
getFactoryClassLocation() - 类 javax.naming.Reference 中的方法
检索此引用所引用对象的工厂的位置。
getFactoryClassName() - 类 javax.naming.Reference 中的方法
检索此引用所引用对象的工厂的类名称。
getFailedProperties() - 异常 java.sql.SQLClientInfoException 中的方法
返回无法设置的客户端信息属性列表。
getFailureHandler() - 类 java.rmi.server.RMISocketFactory 中的静态方法
返回由 setFailureHandler 方法设置的套接字创建失败的处理程序。
getFallbackLocale(String, Locale) - 类 java.util.ResourceBundle.Control 中的方法
返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。
getFamily() - 类 java.awt.Font 中的方法
返回此 Font 的系列名称。
getFamily(Locale) - 类 java.awt.Font 中的方法
返回此 Font 的系列名称（已经针对指定语言环境进行了本地化）。
getFault() - 接口 javax.xml.soap.SOAPBody 中的方法
返回此 SOAPBody 对象中的 SOAPFault 对象。
getFault() - 异常 javax.xml.ws.soap.SOAPFaultException 中的方法
获取嵌入的 SOAPFault 实例。
getFaultActor() - 接口 javax.xml.soap.SOAPFault 中的方法
获取此 SOAPFault 对象的错误参与者。
getFaultCode() - 接口 javax.xml.soap.SOAPFault 中的方法
获取此 SOAPFault 对象的错误代码。
getFaultCodeAsName() - 接口 javax.xml.soap.SOAPFault 中的方法
以 SAAJ Name 对象形式获取此 SOAPFault 对象的强制性 SOAP 1.1 错误代码。
getFaultCodeAsQName() - 接口 javax.xml.soap.SOAPFault 中的方法
以 QName 对象形式获取此 SOAPFault 对象的错误代码。
getFaultNode() - 接口 javax.xml.soap.SOAPFault 中的方法
返回此 SOAPFault 对象的可选 Node 元素值。
getFaultReasonLocales() - 接口 javax.xml.soap.SOAPFault 中的方法
返回一个 Iterator，它可以在与 Reason Text 项关联的 Locale 独特序列上进行迭代。
getFaultReasonText(Locale) - 接口 javax.xml.soap.SOAPFault 中的方法
返回与给定 Locale 关联的 Reason Text。
getFaultReasonTexts() - 接口 javax.xml.soap.SOAPFault 中的方法
返回一个 Iterator，它可以在包含此 SOAPFault 所有 Reason Text 项的 String 对象序列上进行迭代。
getFaultRole() - 接口 javax.xml.soap.SOAPFault 中的方法
返回此 SOAPFault 对象的可选 Role 元素值。
getFaultString() - 接口 javax.xml.soap.SOAPFault 中的方法
获取此 SOAPFault 对象的错误字符串。
getFaultStringLocale() - 接口 javax.xml.soap.SOAPFault 中的方法
获取此 SOAPFault 对象错误字符串的语言环境。
getFaultSubcodes() - 接口 javax.xml.soap.SOAPFault 中的方法
以 QNames 迭代器形式获取此 SOAPFault 的 Subcode。
getFD() - 类 java.io.FileInputStream 中的方法
返回表示到文件系统中实际文件的连接的 FileDescriptor 对象，该文件系统正被此 FileInputStream 使用。
getFD() - 类 java.io.FileOutputStream 中的方法
返回与此流有关的文件描述符。
getFD() - 类 java.io.RandomAccessFile 中的方法
返回与此流关联的不透明文件描述符对象。
getFeature(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getFeature(String) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
获取指定功能的状态。
getFeature(String) - 类 javax.xml.parsers.SAXParserFactory 中的方法
返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。
getFeature(String) - 类 javax.xml.transform.TransformerFactory 中的方法
查找功能值。
getFeature(String) - 类 javax.xml.validation.SchemaFactory 中的方法
查找功能标志的值。
getFeature(String) - 类 javax.xml.validation.Validator 中的方法
查找功能标志的值。
getFeature(String) - 类 javax.xml.validation.ValidatorHandler 中的方法
查找特性标志的值。
getFeature(String) - 类 javax.xml.xpath.XPathFactory 中的方法
获取指定功能的状态。
getFeature(String, String) - 接口 org.w3c.dom.DOMImplementation 中的方法
此方法返回一个特定的对象，该对象实现了 DOM Features 中所指定的特定特性或版本的特殊 API。
getFeature(String, String) - 接口 org.w3c.dom.Node 中的方法
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。
getFeature(String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
检查解析器功能标志。
getFeature(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
查找功能值。
getFeature(String) - 接口 org.xml.sax.XMLReader 中的方法
查找功能标志的值。
getFeedResolution(int) - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回给定单位的此分辨率属性的进纸分辨率。
getFeedResolutionDphi() - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回以 dphi 为单位的此分辨率属性的进纸分辨率。
getFetchDirection() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的获取方向。
getFetchDirection() - 接口 java.sql.Statement 中的方法
获取从数据库表获取行的方向，该方向是根据此 Statement 对象生成的结果集合的默认值。
getFetchDirection() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取此 RowSet 对象的当前有关获取方向的设置。
getFetchSize() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的获取大小。
getFetchSize() - 接口 java.sql.Statement 中的方法
获取结果集合的行数，该数是根据此 Statement 对象生成的 ResultSet 对象的默认获取大小。
getFetchSize() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回此 RowSet 对象的获取大小。
getField(String) - 类 java.io.ObjectStreamClass 中的方法
按名称获取此类的字段。
getField(String) - 类 java.lang.Class 中的方法
返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。
getField() - 类 java.security.spec.EllipticCurve 中的方法
返回此椭圆曲线结束的有限字段 field。
getField() - 类 java.text.FieldPosition 中的方法
获取字段的标识符。
getField(DatatypeConstants.Field) - 类 javax.xml.datatype.Duration 中的方法
获取字段的值。
getFieldAttribute() - 类 java.text.FieldPosition 中的方法
以来自 Field 子类之一的属性常量返回该字段的标识符。
getFieldNames() - 接口 javax.management.Descriptor 中的方法
返回描述符中的所有字段名。
getFieldNames() - 类 javax.management.ImmutableDescriptor 中的方法

getFieldNames() - 类 javax.management.modelmbean.DescriptorSupport 中的方法

getFields() - 类 java.io.ObjectStreamClass 中的方法
返回此可序列化类的字段组成的数组。
getFields() - 类 java.lang.Class 中的方法
返回一个包含某些 Field 对象的数组，这些对象反映此 Class 对象所表示的类或接口的所有可访问公共字段。
getFields() - 接口 javax.management.Descriptor 中的方法
以 string 数组的形式返回此 descriptor 中所包含的所有字段。
getFields() - 类 javax.management.ImmutableDescriptor 中的方法

getFields() - 类 javax.management.modelmbean.DescriptorSupport 中的方法

getFields() - 类 javax.sql.rowset.serial.SerialJavaObject 中的方法
返回 Field 对象数组，该对象包含此帮助器类将序列化的对象的每个字段。
getFields(int) - 类 javax.swing.text.InternationalFormatter 中的方法
返回与 offset 处的文本相关的 Format.Field 常量。
getFieldSize() - 接口 java.security.spec.ECField 中的方法
返回以比特为单位的字段大小。
getFieldSize() - 类 java.security.spec.ECFieldF2m 中的方法
返回以比特为单位的字段大小，对于此首数为 2 的有限字段，该字段大小为 m。
getFieldSize() - 类 java.security.spec.ECFieldFp 中的方法
返回以比特为单位的字段大小，对于此素数有限字段，则为素数 p 的大小。
getFieldValue(String) - 接口 javax.management.Descriptor 中的方法
返回指定字段名的值，如果该名称不存在任何值，则返回 null。
getFieldValue(String) - 类 javax.management.ImmutableDescriptor 中的方法

getFieldValue(String) - 类 javax.management.modelmbean.DescriptorSupport 中的方法

getFieldValues(String...) - 接口 javax.management.Descriptor 中的方法
以 Object 数组的形式返回该 descriptor 中的所有字段值。
getFieldValues(String...) - 类 javax.management.ImmutableDescriptor 中的方法

getFieldValues(String...) - 类 javax.management.modelmbean.DescriptorSupport 中的方法

getFile() - 类 java.awt.FileDialog 中的方法
获取此文件对话框的选定文件。
getFile() - 类 java.net.URL 中的方法
获取此 URL 的文件名。
getFile() - 类 javax.activation.FileDataSource 中的方法
返回与此 FileDataSource 对应的 File 对象。
getFileChooser() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getFileChooserDetailViewIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileChooserHomeFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileChooserListViewIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileChooserNewFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileChooserUpFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getFileDescriptor() - 类 java.net.DatagramSocketImpl 中的方法
获取数据报套接字文件描述符。
getFileDescriptor() - 类 java.net.SocketImpl 中的方法
返回此套接字的 fd 字段的值。
getFileFilter() - 类 javax.swing.JFileChooser 中的方法
返回当前选择的文件过滤器。
getFileForInput(JavaFileManager.Location, String, String) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getFileForInput(JavaFileManager.Location, String, String) - 接口 javax.tools.JavaFileManager 中的方法
获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
getFileForOutput(JavaFileManager.Location, String, String, FileObject) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getFileForOutput(JavaFileManager.Location, String, String, FileObject) - 接口 javax.tools.JavaFileManager 中的方法
获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
getFileName() - 类 java.awt.JobAttributes 中的方法
指定使用这些属性的作业的输出文件的文件名。
getFileName() - 类 java.lang.StackTraceElement 中的方法
返回源文件名，该文件包含由该堆栈跟踪元素所表示的执行点。
getFileName() - 异常 javax.script.ScriptException 中的方法
获取导致错误的脚本的源。
getFileName() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getFileName() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法

getFilenameFilter() - 类 java.awt.FileDialog 中的方法
确定此文件对话框的文件名过滤器。
getFileNameMap() - 类 java.net.URLConnection 中的静态方法
从数据文件加载文件名映射（一个 mimetable）。
getFilePointer() - 类 java.io.RandomAccessFile 中的方法
返回此文件中的当前偏移量。
getFiler() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回用来创建新源、类或辅助文件的 Filer。
getFiles(File, boolean) - 类 javax.swing.filechooser.FileSystemView 中的方法
获取显示的（即未隐藏）文件的列表。
getFiles() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法

getFileSelectionMode() - 类 javax.swing.JFileChooser 中的方法
返回当前的文件选择模式。
getFileSuffixes() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回一个包含通常可由与此服务提供者关联的 ImageReader 或 ImageWriter 实现所用格式所关联文件后缀列表的 String 数组。
getFileSystemView() - 类 javax.swing.filechooser.FileSystemView 中的静态方法

getFileSystemView() - 类 javax.swing.JFileChooser 中的方法
返回文件系统视图。
getFileView() - 类 javax.swing.JFileChooser 中的方法
返回当前的文件视图。
getFileView(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getFileView(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法

getFileView(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getFileView 方法。
getFillsViewportHeight() - 类 javax.swing.JTable 中的方法
返回此表是否始终大到足以填充封闭视口的高度。
getFilter() - 类 java.util.logging.Handler 中的方法
获得该 Handler 的当前 Filter。
getFilter() - 类 java.util.logging.Logger 中的方法
获取此 Logger 的当前过滤器。
getFilter() - 接口 javax.sql.rowset.FilteredRowSet 中的方法
获取此 FilteredRowSet 对象的活动过滤器。
getFilter() - 类 javax.xml.crypto.dsig.spec.XPathType 中的方法
返回过滤操作。
getFilter() - 接口 org.w3c.dom.ls.LSParser 中的方法
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。
getFilter() - 接口 org.w3c.dom.ls.LSSerializer 中的方法
当应用程序提供过滤器时，在序列化每个节点前串行器先调出过滤器。
getFilterInstance(ImageConsumer) - 类 java.awt.image.ImageFilter 中的方法
返回为指定 ImageConsumer 实际执行过滤的 ImageFilter 对象的惟一实例。
getFirst() - 类 java.util.ArrayDeque 中的方法

getFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法

getFirst() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列的第一个元素。
getFirst() - 类 java.util.LinkedList 中的方法
返回此列表的第一个元素。
getFirstChild() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
此节点的第一个子节点；如果该节点没有子节点，则返回 null。
getFirstChild() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的第一个子节点。
getFirstChild() - 接口 org.w3c.dom.Node 中的方法
此节点的第一个子节点。
getFirstColumn() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回已更改的第一列。
getFirstColumn() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getFirstComponent(Container) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回遍历循环中的第一个 Component。
getFirstComponent(Container) - 类 java.awt.FocusTraversalPolicy 中的方法
返回遍历循环中的第一个 Component。
getFirstComponent(Container) - 类 javax.swing.DefaultFocusManager 中的方法

getFirstComponent(Container) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
返回遍历循环中的第一个 Component。
getFirstComponent(Container) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回遍历循环中的第一个 Component。
getFirstDayOfWeek() - 类 java.util.Calendar 中的方法
获取一星期的第一天；例如，在美国，这一天是 SUNDAY，而在法国，这一天是 MONDAY。
getFirstIndex() - 类 javax.swing.event.ListSelectionEvent 中的方法
返回第一个选择状态可能发生更改的行的索引。
getFirstLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
查找并返回为此节点后代的第一个叶节点，即此节点或其第一个子节点的第一个叶节点。
getFirstLineIndent(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取首行缩进设置。
getFirstQueuedThread() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回队列中第一个（等待时间最长的）线程；如果当前没有将任何线程加入队列，则返回 null。
getFirstQueuedThread() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回队列中第一个（等待时间最长的）线程，如果目前没有将任何线程加入队列，则返回 null. 在此实现中，该操作是以固定时间返回的，但是，如果其他线程目前正在并发修改该队列，则可能出现循环争用。
getFirstRow() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回已更改的第一行。
getFirstRow() - 类 javax.swing.event.TableModelEvent 中的方法
返回第一个被更改的行。
getFirstRow() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getFirstVisibleIndex() - 类 javax.swing.JList 中的方法
返回当前可见的最小的列表索引。
getFixedCellHeight() - 类 javax.swing.JList 中的方法
返回 fixedCellHeight 属性的值。
getFixedCellWidth() - 类 javax.swing.JList 中的方法
返回 fixedCellWidth 属性的值。
getFixedRate(Integer) - 类 javax.management.timer.Timer 中的方法
获得此种标志的一个副本：该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
getFixedRate(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得此种标志的一个副本，该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
getFlags() - 异常 java.util.DuplicateFormatFlagsException 中的方法
返回包含重复标志的一组标志。
getFlags() - 异常 java.util.FormatFlagsConversionMismatchException 中的方法
返回不兼容的标志。
getFlags() - 异常 java.util.IllegalFormatFlagsException 中的方法
返回包含非法组合的标志的集合。
getFlags() - 异常 java.util.UnknownFormatFlagsException 中的方法
返回包含未知标志的标志集。
getFlags() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的标志。
getFlatness(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的静态方法
返回由指示控制点指定的三次曲线的平面度。
getFlatness(double[], int) - 类 java.awt.geom.CubicCurve2D 中的静态方法
返回由控制点（存储在指示数组中的指示索引处）指定的三次曲线的平面度。
getFlatness() - 类 java.awt.geom.CubicCurve2D 中的方法
返回此曲线的平面度。
getFlatness() - 类 java.awt.geom.FlatteningPathIterator 中的方法
返回此迭代器的平面度。
getFlatness(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的静态方法
返回由指示控制点指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）。
getFlatness(double[], int) - 类 java.awt.geom.QuadCurve2D 中的静态方法
返回由控制点（存储在指示数组中的指示索引处）指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）。
getFlatness() - 类 java.awt.geom.QuadCurve2D 中的方法
返回此 QuadCurve2D 的平面度（或者说从控制点到连接端点的线的最大距离）。
getFlatnessSq(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的静态方法
返回由指示的控制点指定的三次曲线平面度的平方。
getFlatnessSq(double[], int) - 类 java.awt.geom.CubicCurve2D 中的静态方法
返回由控制点（存储在指示数组中的指示索引处）指定的三次曲线平面度的平方。
getFlatnessSq() - 类 java.awt.geom.CubicCurve2D 中的方法
返回此曲线平面度的平方。
getFlatnessSq(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的静态方法
返回由指示控制点指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）的平方。
getFlatnessSq(double[], int) - 类 java.awt.geom.QuadCurve2D 中的静态方法
返回由控制点（存储在指示数组中的指示索引处）指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）的平方。
getFlatnessSq() - 类 java.awt.geom.QuadCurve2D 中的方法
返回此 QuadCurve2D 的平面度（或者说从控制点到连接端点的线的最大距离）的平方。
getFlavorListeners() - 类 java.awt.datatransfer.Clipboard 中的方法
返回一组目前在此 Clipboard 上注册的所有 FlavorListener。
getFlavorMap() - 类 java.awt.dnd.DragSource 中的方法
此方法返回此 DragSource 的 FlavorMap。
getFlavorMap() - 类 java.awt.dnd.DropTarget 中的方法
获取与此 DropTarget 关联的 FlavorMap。
getFlavorsForNative(String) - 接口 java.awt.datatransfer.FlavorTable 中的方法
返回与指定 String 对应的 DataFlavor 的 List。
getFlavorsForNative(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。
getFlavorsForNatives(String[]) - 接口 java.awt.datatransfer.FlavorMap 中的方法
返回指定 String native 到其相应 DataFlavor 的 Map。
getFlavorsForNatives(String[]) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
返回指定 String native 到其大多数首选 DataFlavor 的 Map。
getFlipContents() - 类 java.awt.BufferCapabilities 中的方法

getFloat(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 float 形式返回指定数组对象中索引组件的值。
getFloat(Object) - 类 java.lang.reflect.Field 中的方法
获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。
getFloat() - 类 java.nio.ByteBuffer 中的方法
用于读取 float 值的相对 get 方法。
getFloat(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 float 值的绝对 get 方法。
getFloat(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 float 值的形式获取指定的 JDBC FLOAT 参数的值。
getFloat(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 float 值的形式获取 JDBC FLOAT 参数的值。
getFloat(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
getFloat(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
getFloat(String, float) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getFloat(String,float) 中的规范实现 getFloat 方法。
getFloat(String, float) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定的键相关联的、由字符串表示的 float 值。
getFloatingColor() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
获取在浮动区域上时显示的颜色。
getFloatParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 float 返回参数的便捷方法。
getFlowAxis() - 类 javax.swing.text.FlowView 中的方法
获取应沿其流入视图的轴。
getFlowSpan(int) - 类 javax.swing.text.FlowView 中的方法
获取给定子索引流入的约束区域。
getFlowSpan(int) - 类 javax.swing.text.ParagraphView 中的方法
获取给定子索引流入的约束区域。
getFlowStart(int) - 类 javax.swing.text.FlowView 中的方法
获取沿流轴的流区域开始位置。
getFlowStart(int) - 类 javax.swing.text.ParagraphView 中的方法
获取沿流轴的流区域开始位置。
getFlushedPosition() - 接口 javax.imageio.stream.ImageInputStream 中的方法
返回流中可以执行查找的最早位置。
getFlushedPosition() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法

getFocusableWindowState() - 类 java.awt.Window 中的方法
返回如果此窗口满足 isFocusableWindow 中列出的其他要求，其是否可以成为焦点窗口。
getFocusAccelerator() - 类 javax.swing.text.JTextComponent 中的方法
返回将导致接收文本组件获取焦点的加速键。
getFocusColor() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getFocusColor() - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法

getFocusColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的焦点颜色。
getFocusColor() - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法

getFocusColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回焦点颜色。
getFocusColor() - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法

getFocusCycleRootAncestor() - 类 java.awt.Component 中的方法
返回作为此 Component 焦点遍历循环的焦点循环根的 Container。
getFocusCycleRootAncestor() - 类 java.awt.Window 中的方法
始终返回 null，因为窗口没有祖先；它们表示组件层次结构的顶层。
getFocusCycleRootAncestor() - 类 javax.swing.JInternalFrame 中的方法
始终返回 null，原因是 JInternalFrame 必须始终为焦点遍历循环的根。
getFocusedComponent() - 类 javax.swing.text.TextAction 中的方法
获取当前具有焦点的文本组件。
getFocusedWindow() - 类 java.awt.KeyboardFocusManager 中的方法
如果聚焦窗口与调用线程位于同一个上下文中，则返回聚焦窗口。
getFocusIndex() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回具有焦点的选项卡的索引。
getFocusListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的焦点侦听器的数组。
getFocusLostBehavior() - 类 javax.swing.JFormattedTextField 中的方法
返回丢失焦点时的行为。
getFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
如果焦点所有者与调用线程位于同一个上下文中，则返回该焦点所有者。
getFocusOwner() - 类 java.awt.Window 中的方法
如果此窗口为焦点窗口，则返回是焦点窗口的子组件；否则返回 null。
getFocusOwner() - 类 javax.swing.JInternalFrame 中的方法
如果此 JInternalFrame 处于激活状态，则返回具有焦点的子组件。
getFocusPoint() - 类 java.awt.RadialGradientPaint 中的方法
返回渐变轴结束点的副本。
getFocusTraversalKeys(int) - 类 java.awt.Component 中的方法
返回此 Component 的给定遍历操作的焦点遍历键 Set。
getFocusTraversalKeys(int) - 类 java.awt.Container 中的方法
为此 Container 的给定遍历操作返回焦点遍历键的 Set。
getFocusTraversalKeys(int) - 类 java.awt.Window 中的方法
获取此窗口的焦点遍历键。
getFocusTraversalKeysEnabled() - 类 java.awt.Component 中的方法
返回是否已为此 Component 启用了焦点遍历键。
getFocusTraversalPolicy() - 类 java.awt.Container 中的方法
返回焦点遍历策略，用于管理此 Container 子组件的键盘遍历；如果此 Container 不是一个焦点循环根，则返回 null。
getFollowRedirects() - 类 java.net.HttpURLConnection 中的静态方法
返回指示是否应该自动执行 HTTP 重定向 (3xx) 的 boolean 值。
getFont() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的 Font。
getFont() - 类 java.awt.Component 中的方法
获取组件的字体。
getFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - 类 java.awt.Font 中的静态方法
返回适合于这些属性的 Font。
getFont(String) - 类 java.awt.Font 中的静态方法
从系统属性列表返回一个 Font 对象。
getFont(String, Font) - 类 java.awt.Font 中的静态方法
从系统属性列表获取指定的 Font。
getFont() - 类 java.awt.font.GlyphVector 中的方法
返回与此 GlyphVector 关联的 Font。
getFont() - 类 java.awt.FontMetrics 中的方法
获取此 FontMetrics 对象所描述的 Font。
getFont() - 类 java.awt.Graphics 中的方法
获取当前字体。
getFont() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的 Font。
getFont() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的 Font。
getFont() - 类 java.awt.MenuComponent 中的方法
获取用于此菜单组件的字体。
getFont() - 接口 java.awt.MenuContainer 中的方法

getFont() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的 Font。
getFont(Component) - 类 javax.swing.border.TitledBorder 中的方法

getFont() - 类 javax.swing.DebugGraphics 中的方法
返回用于文本绘制操作的 Font。
getFont() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getFont() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的 Font。
getFont() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getFont(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定状态的 Font。
getFont() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getFont(AttributeSet) - 类 javax.swing.text.DefaultStyledDocument 中的方法
从属性集获得字体。
getFont() - 类 javax.swing.text.GlyphView 中的方法
获取字形应该以其为依据的字体。
getFont(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取给定属性集使用的字体。
getFont() - 类 javax.swing.text.LabelView 中的方法
获取字形应该以其为依据的字体。
getFont(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
从属性集中获取字体。
getFont(String, int, int) - 类 javax.swing.text.StyleContext 中的方法
获取新字体。
getFont(AttributeSet) - 接口 javax.swing.text.StyledDocument 中的方法
使用一个属性集并将其转换为字体规范。
getFont() - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的方法

getFont() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
获取用于编辑的字体。
getFont() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
获取此组件的字体。
getFont(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Font，则返回该 Font，否则返回 null。
getFont(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。
getFont(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值返回一种字体。
getFont(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一种字体。
getFontFamily(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取字体系列设置。
getFontForState(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定状态的字体。
getFontList() - 类 java.awt.Toolkit 中的方法
已过时。 请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()
getFontMetrics(Font) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的 FontMetrics。
getFontMetrics(Font) - 类 java.awt.Component 中的方法
获取指定字体的字体规格。
getFontMetrics() - 类 java.awt.Graphics 中的方法
获取当前字体的字体规格。
getFontMetrics(Font) - 类 java.awt.Graphics 中的方法
获取指定字体的字体规格。
getFontMetrics(Font) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的 FontMetrics。
getFontMetrics(Font) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的 FontMetrics。
getFontMetrics(Font) - 类 java.awt.Toolkit 中的方法
已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
getFontMetrics(Font) - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的 FontMetrics。
getFontMetrics() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.getFontMetrics。
getFontMetrics(Font) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.getFontMetrics。
getFontMetrics(Font) - 类 javax.swing.JComponent 中的方法
获取指定 Font 的 FontMetrics。
getFontMetrics(Font) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getFontMetrics(Font) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的 FontMetrics。
getFontMetrics(Font) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getFontMetrics() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getFontMetrics(Font) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getFontMetrics() - 类 javax.swing.text.FieldView 中的方法
获取与承载此视图组件相关的字体规格。
getFontMetrics() - 类 javax.swing.text.LabelView 中的方法
已过时。 FontMetrics 不用于在 JDK 中运行时的字形呈现。
getFontMetrics(Font) - 类 javax.swing.text.StyleContext 中的方法
获取某种字体的字体规格。
getFontName() - 类 java.awt.Font 中的方法
返回此 Font 的字体外观名称。
getFontName(Locale) - 类 java.awt.Font 中的方法
返回此 Font 的字体外观名称（已经针对指定语言环境进行了本地化）。
getFontPeer(String, int) - 类 java.awt.Toolkit 中的方法
已过时。 请参阅 java.awt.GraphicsEnvironment#getAllFonts
getFontRenderContext() - 类 java.awt.font.GlyphVector 中的方法
返回与此 GlyphVector 关联的 FontRenderContext。
getFontRenderContext() - 类 java.awt.FontMetrics 中的方法
获取此 FontMetrics 对象用来测量文本的 FontRenderContext。
getFontRenderContext() - 类 java.awt.Graphics2D 中的方法
获取此 Graphics2D 上下文中 Font 的呈现上下文。
getFontSize(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取字体大小设置。
getFontTable(int) - 接口 java.awt.font.OpenType 中的方法
返回作为指定标签字节数组的表。
getFontTable(String) - 接口 java.awt.font.OpenType 中的方法
返回作为指定标签字节数组的表。
getFontTable(int, int, int) - 接口 java.awt.font.OpenType 中的方法
返回作为指定标签字节数组的表的子集。
getFontTable(String, int, int) - 接口 java.awt.font.OpenType 中的方法
返回作为指定标签字节数组的表的子集。
getFontTableSize(int) - 接口 java.awt.font.OpenType 中的方法
返回指定标签的表的大小。
getFontTableSize(String) - 接口 java.awt.font.OpenType 中的方法
返回指定标签的表的大小。
getForeground() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
获取此对象的前景色。
getForeground() - 类 java.awt.Component 中的方法
获取组件的前景色。
getForeground() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象的前景颜色。
getForeground() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
获取此对象的前景色。
getForeground() - 接口 javax.accessibility.AccessibleComponent 中的方法
获取此对象的前景色。
getForeground() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getForeground() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的前景色。
getForeground() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取此对象的前景色。
getForeground() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getForeground(AttributeSet) - 类 javax.swing.text.DefaultStyledDocument 中的方法
从属性集获得前景色。
getForeground() - 类 javax.swing.text.GlyphView 中的方法
获取用于呈现字形的前景色。
getForeground(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取一个属性集并将其转换为前景色规范。
getForeground() - 类 javax.swing.text.LabelView 中的方法
获取用于呈现字形的前景色。
getForeground(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取前景色设置。
getForeground(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
使用一个属性集并将其转换成为一个前景色规范。
getForeground(AttributeSet) - 接口 javax.swing.text.StyledDocument 中的方法
使用一个属性集并将其转换成为一个前景色规范。
getForegroundAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡背景色。
getFormat() - 接口 java.security.Certificate 中的方法
已过时。 返回编码格式的名称。
getFormat() - 接口 java.security.Key 中的方法
返回此密钥的基本编码格式，如果此密钥不支持编码，则返回 null。
getFormat() - 类 java.security.spec.EncodedKeySpec 中的方法
返回与此密钥规范关联的编码格式的名称。
getFormat() - 类 java.security.spec.PKCS8EncodedKeySpec 中的方法
返回与此密钥规范关联的编码格式的名称。
getFormat() - 类 java.security.spec.X509EncodedKeySpec 中的方法
返回与此密钥规范关联的编码格式的名称。
getFormat() - 类 javax.crypto.spec.SecretKeySpec 中的方法
返回此密钥编码格式的名称。
getFormat() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此秘密密钥的编码格式的名称。
getFormat() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得音频文件中包含的音频数据的格式。
getFormat() - 类 javax.sound.sampled.AudioInputStream 中的方法
获得此音频输入流中声音数据的音频格式。
getFormat() - 接口 javax.sound.sampled.DataLine 中的方法
获得数据行的音频数据的当前格式（编码、样本频率、信道数，等等）。
getFormat() - 类 javax.swing.JSpinner.DateEditor 中的方法
返回 JFormattedTextField 用于分析和格式化数字的 java.text.SimpleDateFormat 对象。
getFormat() - 类 javax.swing.JSpinner.NumberEditor 中的方法
返回 JFormattedTextField 用于分析和格式化数字的 java.text.DecimalFormat 对象。
getFormat() - 类 javax.swing.text.InternationalFormatter 中的方法
返回指示可以编辑和显示的合法值的格式。
getFormatId() - 接口 javax.transaction.xa.Xid 中的方法
获取 XID 的格式标识符部分。
getFormatName() - 类 javax.imageio.ImageReader 中的方法
返回一个标识输入源格式的 String。
getFormatNames() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回一个 String 数组，该数组包含通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的那些格式的可读名称。
getFormats() - 类 java.text.ChoiceFormat 中的方法
获取传入构造方法的 format。
getFormats() - 类 java.text.MessageFormat 中的方法
获取用于以前所设置的模式字符串中格式元素的格式。
getFormats(String) - 类 java.util.ResourceBundle.Control 中的方法
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。
getFormats() - 类 javax.sound.sampled.DataLine.Info 中的方法
获得数据行支持的音频格式的集合。
getFormatsByArgumentIndex() - 类 java.text.MessageFormat 中的方法
获取传递给 format 方法或从 parse 方法返回的值的格式。
getFormatSpecifier() - 异常 java.util.MissingFormatArgumentException 中的方法
返回不匹配的格式说明符。
getFormatSpecifier() - 异常 java.util.MissingFormatWidthException 中的方法
返回没有宽度的格式说明符。
getFormattedTextField() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
返回 AbstractFormatter 所安装到的当前 JFormattedTextField。
getFormatter() - 类 java.util.logging.Handler 中的方法
返回该 Handler 的 Formatter。
getFormatter(JFormattedTextField) - 类 javax.swing.JFormattedTextField.AbstractFormatterFactory 中的方法
返回一个 AbstractFormatter，它对传入的 JFormattedTextField 进行格式化。
getFormatter() - 类 javax.swing.JFormattedTextField 中的方法
返回用于格式化和分析当前值的 AbstractFormatter。
getFormatter(JFormattedTextField) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
根据 JFormattedTextField 的状态返回默认的 formatter、显示 formatter、编辑器 formatter 或 null formatter。
getFormatterFactory() - 类 javax.swing.JFormattedTextField 中的方法
返回当前的 AbstractFormatterFactory。
getFractionalMetricsHint() - 类 java.awt.font.FontRenderContext 中的方法
返回此 FontRenderContext 中使用的文本 fractional metrics 呈现模式提示。
getFractionalSecond() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回小数秒。
getFractions() - 类 java.awt.MultipleGradientPaint 中的方法
返回此渐变所使用的 float 数组的副本，以计算颜色分布。
getFragment() - 类 java.net.URI 中的方法
返回此 URI 的已解码的片段组成部分。
getFrame() - 类 java.awt.geom.RectangularShape 中的方法
返回定义此对象的总体形状的窗体 Rectangle2D。
getFrameCount() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
返回不确定 JProgessBar 所使用的完整动画循环的窗体数。
getFrameForComponent(Component) - 类 javax.swing.JOptionPane 中的静态方法
返回指定组件的 Frame。
getFrameIcon() - 类 javax.swing.JInternalFrame 中的方法
返回要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
getFrameLength() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得文件中包含的音频数据的长度，以示例帧为单位表示。
getFrameLength() - 类 javax.sound.sampled.AudioInputStream 中的方法
获得流的长度，以示例帧表示，而不是以字节表示。
getFrameLength() - 接口 javax.sound.sampled.Clip 中的方法
获得介质长度（以示例帧为单位）。
getFramePosition() - 接口 javax.sound.sampled.DataLine 中的方法
获得音频数据中的当前位置（以样本帧为单位）。
getFramePosition() - 类 javax.sound.sampled.LineEvent 中的方法
获得事件发生时行的音频数据的位置，用样本帧表示。
getFrameRate() - 类 javax.sound.sampled.AudioFormat 中的方法
获取以帧每秒为单位的帧速率。
getFrames() - 类 java.awt.Frame 中的静态方法
返回一个此应用程序创建的所有 Frame 所组成的数组。
getFrameSize() - 类 javax.sound.sampled.AudioFormat 中的方法
获取以字节为单位的帧大小。
getFreeSpace() - 类 java.io.File 中的方法
返回此抽象路径名指定的分区中未分配的字节数。
getFromIndex() - 类 javax.swing.event.TableColumnModelEvent 中的方法
返回 fromIndex。
getFromPage() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则返回要打印的第一页。
getFrontBufferCapabilities() - 类 java.awt.BufferCapabilities 中的方法

getFullScreenWindow() - 类 java.awt.GraphicsDevice 中的方法
如果设备处于全屏模式，则返回表示全屏窗口的 Window 对象。
getFunctionColumns(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定类别的系统或用户函数参数和返回类型的描述。
getFunctions(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定类别中可用的系统和用户函数的描述。
getG() - 接口 java.security.interfaces.DSAParams 中的方法
返回基数 g。
getG() - 类 java.security.spec.DSAParameterSpec 中的方法
返回基数 g。
getG() - 类 java.security.spec.DSAPrivateKeySpec 中的方法
返回基数 g。
getG() - 类 java.security.spec.DSAPublicKeySpec 中的方法
返回基数 g。
getG() - 类 javax.crypto.spec.DHParameterSpec 中的方法
返回基生成器 g。
getG() - 类 javax.crypto.spec.DHPrivateKeySpec 中的方法
返回基生成器 g。
getG() - 类 javax.crypto.spec.DHPublicKeySpec 中的方法
返回基生成器 g。
getGamma() - 类 java.awt.color.ICC_ProfileGray 中的方法
返回一个表示色调再现曲线 (TRC) 的 gamma 值。
getGamma(int) - 类 java.awt.color.ICC_ProfileRGB 中的方法
返回表示特定分量色调再现曲线 (TRC) 的 gamma 值。
getGarbageCollectorMXBeans() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机中的 GarbageCollectorMXBean 对象列表。
getGeneratedKeys() - 接口 java.sql.Statement 中的方法
获取由于执行此 Statement 对象而创建的所有自动生成的键。
getGenerator() - 类 java.security.spec.ECParameterSpec 中的方法
返回也称为基点的生成器。
getGenericComponentType() - 接口 java.lang.reflect.GenericArrayType 中的方法
返回表示此数组的组件类型的 Type 对象。
getGenericDeclaration() - 接口 java.lang.reflect.TypeVariable 中的方法
返回 GenericDeclaration 对象，该对象表示声明此类型变量的一般声明。
getGenericElement() - 接口 javax.lang.model.element.TypeParameterElement 中的方法
返回由此类型参数参数化的一般类、接口、方法或构造方法。
getGenericExceptionTypes() - 类 java.lang.reflect.Constructor 中的方法
返回一组 Type 对象，这些对象表示声明要由此 Constructor 对象抛出的异常。
getGenericExceptionTypes() - 类 java.lang.reflect.Method 中的方法
返回 Type 对象数组，这些对象描述了声明由此 Method 对象抛出的异常。
getGenericInterfaces() - 类 java.lang.Class 中的方法
返回表示某些接口的 Type，这些接口由此对象所表示的类或接口直接实现。
getGenericParameterTypes() - 类 java.lang.reflect.Constructor 中的方法
按照声明顺序返回一组 Type 对象，这些对象表示此 Constructor 对象所表示的方法的形参类型。
getGenericParameterTypes() - 类 java.lang.reflect.Method 中的方法
按照声明顺序返回 Type 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型的。
getGenericReturnType() - 类 java.lang.reflect.Method 中的方法
返回表示由此 Method 对象所表示方法的正式返回类型的 Type 对象。
getGenericSuperclass() - 类 java.lang.Class 中的方法
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的直接超类的 Type。
getGenericType() - 类 java.lang.reflect.Field 中的方法
返回一个 Type 对象，它表示此 Field 对象所表示字段的声明类型。
getGestureModifiers() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回一个 int 值，表示与用户动作关联的输入设备修饰符的当前状态。
getGestureModifiersEx() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回一个 int 值，表示与用户动作关联的输入设备扩展修饰符的当前状态。
getGetListenerMethod() - 类 java.beans.EventSetDescriptor 中的方法
获得用来访问已注册事件侦听器的方法。
getGlassPane() - 类 javax.swing.JApplet 中的方法
返回此 applet 的 glassPane 对象。
getGlassPane() - 类 javax.swing.JDialog 中的方法
返回此对话框的 glassPane 对象。
getGlassPane() - 类 javax.swing.JFrame 中的方法
返回此窗体的 glassPane 对象。
getGlassPane() - 类 javax.swing.JInternalFrame 中的方法
返回此内部窗体的玻璃窗格。
getGlassPane() - 类 javax.swing.JRootPane 中的方法
返回此 JRootPane 的当前玻璃窗格。
getGlassPane() - 类 javax.swing.JWindow 中的方法
返回此窗口的 glassPane Component。
getGlassPane() - 接口 javax.swing.RootPaneContainer 中的方法
返回 glassPane。
getGlobalActiveWindow() - 类 java.awt.KeyboardFocusManager 中的方法
返回活动 Window，即使调用线程处于活动 Window 之外的上下文中。
getGlobalCurrentFocusCycleRoot() - 类 java.awt.KeyboardFocusManager 中的方法
返回当前焦点循环根，即使调用线程处于当前焦点循环根之外的上下文中。
getGlobalFocusedWindow() - 类 java.awt.KeyboardFocusManager 中的方法
返回聚焦 Window，即使调用线程处于聚焦 Window 之外的上下文中。
getGlobalFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
返回焦点所有者，即使调用线程处于焦点所有者之外的上下文中。
getGlobalPermanentFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
返回持久焦点所有者，即使调用线程处于该持久焦点所有者之外的上下文中。
getGlobalTransactionId() - 接口 javax.transaction.xa.Xid 中的方法
获取 XID 的全局事务标识符部分作为字节数组。
getGlyphCharIndex(int) - 类 java.awt.font.GlyphVector 中的方法
返回指定字形的字符索引。
getGlyphCharIndices(int, int, int[]) - 类 java.awt.font.GlyphVector 中的方法
返回指定字形的字符索引。
getGlyphCode(int) - 类 java.awt.font.GlyphVector 中的方法
返回指定字形的 glyphcode。
getGlyphCodes(int, int, int[]) - 类 java.awt.font.GlyphVector 中的方法
返回指定字形的 glyphcode 数组。
getGlyphJustificationInfo(int) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中指定索引处的字形调整信息。
getGlyphLogicalBounds(int) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中指定字形的逻辑边界。
getGlyphMetrics(int) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中指定索引处的字形规格。
getGlyphOutline(int) - 类 java.awt.font.GlyphVector 中的方法
返回其内部区域与此 GlyphVector 中指定字形的可视表示形式对应的 Shape。
getGlyphOutline(int, float, float) - 类 java.awt.font.GlyphVector 中的方法
返回一个 Shape，其内部区域与此 GlyphVector 中指定字形的可视表示形式对应，并偏移到 x、y。
getGlyphPainter() - 类 javax.swing.text.GlyphView 中的方法
获取当前安装的字形 painter。
getGlyphPixelBounds(int, FontRenderContext, float, float) - 类 java.awt.font.GlyphVector 中的方法
返回当此 GlyphVector 在 Graphics 中以给定 FontRenderContext 在给定位置呈现时，index 处字形的像素边界。
getGlyphPosition(int) - 类 java.awt.font.GlyphVector 中的方法
返回与此 GlyphVector 原点对应的指定字形的位置。
getGlyphPositions(int, int, float[]) - 类 java.awt.font.GlyphVector 中的方法
返回包含指定字形位置的数组。
getGlyphTransform(int) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中指定字形的转换。
getGlyphVisualBounds(int) - 类 java.awt.font.GlyphVector 中的方法
返回 GlyphVector 中指定字形的可视边界。
getGoHomeAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getGranularityPeriod() - 类 javax.management.monitor.Monitor 中的方法
获取粒度周期（以毫秒为单位）。
getGranularityPeriod() - 接口 javax.management.monitor.MonitorMBean 中的方法
获取粒度时段（以毫秒为单位）。
getGraphics() - 类 java.awt.Component 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 java.awt.image.BufferedImage 中的方法
此方法返回 Graphics2D，但此处是出于向后兼容性的考虑。
getGraphics() - 类 java.awt.Image 中的方法
创建供绘制闭屏图像（off-screen image）使用的图形上下文。
getGraphics() - 类 java.awt.image.VolatileImage 中的方法
此方法返回 Graphics2D，但它存在于此处是出于向后兼容性的考虑。
getGraphics() - 类 java.awt.PrintJob 中的方法
获取将绘制到下一页的 Graphics 对象。
getGraphics() - 类 javax.swing.JApplet 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 javax.swing.JComponent 中的方法
返回此组件的图形上下文，该上下文允许您绘制组件。
getGraphics() - 类 javax.swing.JDialog 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 javax.swing.JFrame 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 javax.swing.JWindow 中的方法
为组件创建一个图形上下文。
getGraphics() - 类 javax.swing.text.View 中的方法
获取用于呈现的 Graphics。
getGraphicsConfiguration() - 类 java.awt.Component 中的方法
获取与此 Component 相关的 GraphicsConfiguration。
getGraphicsConfiguration() - 类 java.awt.Window 中的方法
此方法返回由此窗口使用的 GraphicsConfiguration。
getGraphicsUtils(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回指定上下文的 SynthGraphicUtils。
getGreatestMinimum(int) - 类 java.util.Calendar 中的方法
返回此 Calendar 实例给定日历字段的最高的最小值。
getGreatestMinimum(int) - 类 java.util.GregorianCalendar 中的方法
返回此 GregorianCalendar 实例给定日历字段的最高的最小值。
getGreen() - 类 java.awt.Color 中的方法
返回默认 sRGB 空间中位于范围 0-255 中的绿色分量。
getGreen(int) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(Object) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255）。
getGreen(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(int) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的绿色颜色分量，指定像素在默认 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getGreen(int) - 类 java.awt.image.IndexColorModel 中的方法
返回指定像素的绿色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
getGreenMask() - 类 java.awt.image.DirectColorModel 中的方法
返回指示 int 像素表示形式中哪些位包含绿色颜色分量的掩码。
getGreens(byte[]) - 类 java.awt.image.IndexColorModel 中的方法
将绿色分量数组复制到指定的数组中。
getGregorianChange() - 类 java.util.GregorianCalendar 中的方法
获得格里高利历的更改日期。
getGridColor() - 类 javax.swing.JTable 中的方法
返回用来绘制网格线的颜色。
getGridColumn() - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 获取网格位置的列
getGridRow() - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 获取网格位置的行
getGrooveInsets() - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法
返回 drawGroove() 绘制边框占用的空间量。
getGroup() - 类 javax.swing.DefaultButtonModel 中的方法
返回该按钮所属的组。
getGroupID() - 类 java.rmi.activation.ActivationDesc 中的方法
返回由此描述符指定的对象的组标识符。
getGroupingSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于千位分隔符的字符。
getGroupingSize() - 类 java.text.DecimalFormat 中的方法
返回分组大小。
getGuarantor() - 接口 java.security.Certificate 中的方法
已过时。 返回证书的保证人，即某个主体，其保证与此证书关联的公钥是与此证书关联的主体的公钥。
getHAdjustable() - 类 java.awt.ScrollPane 中的方法
返回表示水平滚动条状态的 ScrollPaneAdjustable 对象。
getHandler() - 类 javax.xml.transform.sax.SAXResult 中的方法
获取作为 Result 的 ContentHandler。
getHandlerChain() - 接口 javax.xml.ws.Binding 中的方法
获取协议绑定实例处理程序链的副本。
getHandlerChain(PortInfo) - 接口 javax.xml.ws.handler.HandlerResolver 中的方法
获取指定端口的处理程序链。
getHandlerResolver() - 类 javax.xml.ws.Service 中的方法
返回已配置的处理程序解析器。
getHandlerResolver() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
返回已配置的处理程序解析器。
getHandlers() - 类 java.util.logging.Logger 中的方法
获得与此 logger 相关的 Handler。
getHandshakeStatus() - 类 javax.net.ssl.SSLEngine 中的方法
返回此 SSLEngine 的当前握手状态。
getHandshakeStatus() - 类 javax.net.ssl.SSLEngineResult 中的方法
获得此 SSLEngine 操作的握手状态。
getHardwareAddress() - 类 java.net.NetworkInterface 中的方法
如果存在硬件地址并可以使用给定的当前权限访问，则返回该硬件地址（通常是 MAC）。
getHashColor() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getHead(Handler) - 类 java.util.logging.Formatter 中的方法
返回一组格式化记录的头部字符串。
getHead(Handler) - 类 java.util.logging.XMLFormatter 中的方法
返回一组 XML 格式记录的头部字符串。
getHeader(String) - 类 javax.xml.soap.MimeHeaders 中的方法
以 String 对象数组的形式返回指定头的所有值。
getHeader() - 接口 javax.xml.soap.SOAPEnvelope 中的方法
返回此 SOAPEnvelope 对象的 SOAPHeader 对象。
getHeaderField(int) - 类 java.net.HttpURLConnection 中的方法
返回 nth 头字段的值。
getHeaderField(String) - 类 java.net.URLConnection 中的方法
返回指定的头字段的值。
getHeaderField(int) - 类 java.net.URLConnection 中的方法
返回第 n 个头字段的值。
getHeaderFieldDate(String, long) - 类 java.net.HttpURLConnection 中的方法

getHeaderFieldDate(String, long) - 类 java.net.URLConnection 中的方法
返回解析为日期的指定字段的值。
getHeaderFieldInt(String, int) - 类 java.net.URLConnection 中的方法
返回解析为数字的指定字段的值。
getHeaderFieldKey(int) - 类 java.net.HttpURLConnection 中的方法
返回 nth 头字段的键。
getHeaderFieldKey(int) - 类 java.net.URLConnection 中的方法
返回第 n 个头字段的键。
getHeaderFields() - 类 java.net.URLConnection 中的方法
返回头字段的不可修改的 Map。
getHeaderRect(int) - 类 javax.swing.table.JTableHeader 中的方法
返回包含 column 处头 tile 的矩形。
getHeaderRenderer() - 类 javax.swing.table.TableColumn 中的方法
返回用于绘制 TableColumn 标题的 TableCellRenderer。
getHeaders() - 类 java.net.CacheResponse 中的方法
以 Map 的形式返回响应头。
getHeaders() - 接口 javax.xml.ws.handler.soap.SOAPHandler 中的方法
获取可以由此处理程序实例处理的头块。
getHeaders(QName, JAXBContext, boolean) - 接口 javax.xml.ws.handler.soap.SOAPMessageContext 中的方法
从消息上下文的消息中获得具有特定限定名的头。
getHeaderValue() - 类 javax.swing.table.TableColumn 中的方法
返回用作标题渲染器值的 Object。
getHeapMemoryUsage() - 接口 java.lang.management.MemoryMXBean 中的方法
返回用于对象分配的堆的当前内存使用量。
getHeight() - 类 java.awt.Component 中的方法
返回组件的当前高度。
getHeight() - 类 java.awt.Dimension 中的方法
返回此 Dimension 的高度（以 double 精度表示）。
getHeight() - 类 java.awt.DisplayMode 中的方法
返回显示的高度（以像素表示）。
getHeight() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的高度。
getHeight() - 类 java.awt.FontMetrics 中的方法
获取此 Font 中文本行的标准 height。
getHeight() - 类 java.awt.geom.Arc2D.Double 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Arc2D.Float 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Dimension2D 中的方法
返回此 Dimension 的高度（以 double 精度表示）。
getHeight() - 类 java.awt.geom.Ellipse2D.Double 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Ellipse2D.Float 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Rectangle2D.Double 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.Rectangle2D.Float 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
以 double 精度返回窗体矩形的高度。
getHeight() - 类 java.awt.image.BufferedImage 中的方法
返回 BufferedImage 的高度。
getHeight(ImageObserver) - 类 java.awt.image.BufferedImage 中的方法
返回 BufferedImage 的高度。
getHeight(ImageObserver) - 类 java.awt.Image 中的方法
确定图像的高度。
getHeight() - 类 java.awt.image.Kernel 中的方法
返回此 Kernel 的高度。
getHeight() - 类 java.awt.image.PixelGrabber 中的方法
获取（调整图像高度后的）像素缓冲区的高度。
getHeight() - 类 java.awt.image.Raster 中的方法
返回 Raster 的像素高度。
getHeight() - 接口 java.awt.image.renderable.RenderableImage 中的方法
获取用户坐标空间中的高度。
getHeight() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取用户坐标空间中的高度。
getHeight() - 接口 java.awt.image.RenderedImage 中的方法
返回 RenderedImage 的高度。
getHeight() - 类 java.awt.image.SampleModel 中的方法
返回像素高度。
getHeight() - 类 java.awt.image.VolatileImage 中的方法
返回此 VolatileImage 的高度。
getHeight() - 类 java.awt.print.PageFormat 中的方法
返回页面的高度（以 1/72 英寸为单位）。
getHeight() - 类 java.awt.print.Paper 中的方法
返回页面的高度（以 1/72 英寸为单位）。
getHeight() - 类 java.awt.Rectangle 中的方法
以 double 精度返回边界 Rectangle 的高度。
getHeight(int) - 类 javax.imageio.ImageReader 中的方法
返回输入源中的给定图像的高度，以像素为单位。
getHeight(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以指定单位获取可打印区域的 height。
getHeight() - 类 javax.swing.JComponent 中的方法
返回此组件的当前高度。
getHeight() - 类 javax.swing.SpringLayout.Constraints 中的方法
返回 height 属性的值。
getHeight() - 类 javax.swing.text.BoxView 中的方法
返回框的当前高度。
getHeight(GlyphView) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法

getHeightOfHighValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getHeightOfLowValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getHeightOfTallestLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getHelpMenu() - 类 java.awt.MenuBar 中的方法
获取该菜单栏上的帮助菜单。
getHelpMenu() - 类 javax.swing.JMenuBar 中的方法
获取菜单栏的帮助菜单。
getHere() - 接口 javax.xml.crypto.dom.DOMURIReference 中的方法
返回当前位置的节点。
getHgap() - 类 java.awt.BorderLayout 中的方法
返回组件之间的水平间距。
getHgap() - 类 java.awt.CardLayout 中的方法
获取组件之间的水平间距。
getHgap() - 类 java.awt.FlowLayout 中的方法
获取组件之间以及组件与 Container 的边之间的水平间隙。
getHgap() - 类 java.awt.GridLayout 中的方法
获取组件之间的水平间距。
getHideActionText() - 类 javax.swing.AbstractButton 中的方法
返回 hideActionText 属性的值，该属性确定按钮是否显示 Action 的文本。
getHierarchyBoundsListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的层次结构边界侦听器的数组。
getHierarchyListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的层次结构侦听器的数组。
getHighestValue() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回在标签表中有一个项的最大值。
getHighestValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回与标签表中的最低滑块值相对应的标签。
getHighlightColor(Component) - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框在指定组件上呈现的高亮显示颜色。
getHighlightColor() - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框的高亮显示颜色。
getHighlightColor() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getHighlightedTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的加亮文本颜色。
getHighlightedTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回高亮显示的文本颜色。
getHighlighter() - 类 javax.swing.text.JTextComponent 中的方法
获取负责进行高亮显示的对象。
getHighlightInnerColor(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框在指定组件上呈现的内部高亮显示颜色。
getHighlightInnerColor() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框内部的高亮显示颜色。
getHighlightOuterColor(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框在指定组件上呈现的外部高亮显示颜色。
getHighlightOuterColor() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框外部的高亮显示颜色。
getHighlights() - 类 javax.swing.text.DefaultHighlighter 中的方法
制作高亮显示的副本。
getHighlights() - 接口 javax.swing.text.Highlighter 中的方法
获取高亮显示的当前列表。
getHighThreshold() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有所观察的 MBean 的公共高阈值。
getHighThreshold() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取高阈值。
getHoldability() - 接口 java.sql.Connection 中的方法
获取使用此 Connection 对象创建的 ResultSet 对象的当前可保存性。
getHoldability() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的可保存性
getHoldCount() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询当前线程保持此锁的次数。
getHoldCount() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
查询当前线程保持写入锁的数量。
getHomeDirectory() - 类 javax.swing.filechooser.FileSystemView 中的方法

getHonorsVisibility() - 类 javax.swing.GroupLayout 中的方法
返回确定组件的大小和位置时是否要考虑组件的可见性。
getHorizontalAlignment() - 类 javax.swing.AbstractButton 中的方法
返回图标和文本的水平对齐方式。
getHorizontalAlignment() - 类 javax.swing.JLabel 中的方法
返回标签内容沿 X 轴的对齐方式。
getHorizontalAlignment() - 类 javax.swing.JTextField 中的方法
返回文本的水平对齐方式。
getHorizontalLegBuffer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
默认情况下，节点间支路的水平元素开始于子节点左侧的右边。
getHorizontalLegBuffer() - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法

getHorizontalScrollBar() - 类 javax.swing.JScrollPane 中的方法
返回控制视口的水平视图位置的水平滚动条。
getHorizontalScrollBar() - 类 javax.swing.ScrollPaneLayout 中的方法
返回处理水平滚动的 JScrollBar 对象。
getHorizontalScrollBarPolicy() - 类 javax.swing.JScrollPane 中的方法
返回水平滚动条策略值。
getHorizontalScrollBarPolicy() - 类 javax.swing.ScrollPaneLayout 中的方法
返回水平滚动条的显示策略。
getHorizontalSliderThumbIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getHorizontalTextPosition() - 类 javax.swing.AbstractButton 中的方法
返回文本相对于图标的水平位置。
getHorizontalTextPosition() - 类 javax.swing.JLabel 中的方法
返回标签的文本相对其图像的水平位置。
getHorizontalVisibility() - 类 javax.swing.JTextField 中的方法
获取文本字段的可见性。
getHost() - 类 java.net.URI 中的方法
返回此 URI 的主机组成部分。
getHost() - 类 java.net.URL 中的方法
获取此 URL 的主机名（如果适用）。
getHost() - 类 javax.management.remote.JMXServiceURL 中的方法
Service URL 的主机部分。
getHostAddress() - 类 java.net.Inet4Address 中的方法
返回 IP 地址字符串（以文本表现形式）。
getHostAddress() - 类 java.net.Inet6Address 中的方法
返回 IP 地址字符串（以文本表现形式）。
getHostAddress() - 类 java.net.InetAddress 中的方法
返回 IP 地址字符串（以文本表现形式）。
getHostAddress(URL) - 类 java.net.URLStreamHandler 中的方法
获取主机的 IP 地址。
getHostName() - 类 java.net.InetAddress 中的方法
获取此 IP 地址的主机名。
getHostName() - 类 java.net.InetSocketAddress 中的方法
获取 hostname。
getHostnameVerifier() - 类 javax.net.ssl.HttpsURLConnection 中的方法
获取此实例适当的 HostnameVerifier。
getHour() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回时或 DatatypeConstants.FIELD_UNDEFINED。
getHours() - 类 java.sql.Date 中的方法
已过时。
getHours() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.HOUR_OF_DAY) 取代。
getHours() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 HOURS 字段的值，如果不存在，则值为 0。
getHSBColor(float, float, float) - 类 java.awt.Color 中的静态方法
根据所指定的数值，创建一个基于 HSB 颜色模型的 Color 对象。
getHScrollbarHeight() - 类 java.awt.ScrollPane 中的方法
返回水平滚动条占用的高度，它与当前是否由滚动窗格显示无关。
getHTMLBaseline(View, int, int) - 类 javax.swing.plaf.basic.BasicHTML 中的静态方法
返回 html 渲染器的基线。
getHTMLDocument(JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法

getHTMLEditorKit(JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 中的方法

getHTMLTag() - 类 javax.swing.text.html.parser.TagElement 中的方法

getHumanPresentableName() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 表示的数据格式的得体的名称。
getHumanPresentableName() - 类 javax.activation.ActivationDataFlavor 中的方法
返回得体的名称。
getHyperlinkListeners() - 类 javax.swing.JEditorPane 中的方法
返回使用 addHyperlinkListener() 添加到此 JEditorPane 的所有 HyperLinkListener 的数组。
getICC_Profiles() - 类 java.awt.image.ColorConvertOp 中的方法
返回用于构造此 ColorConvertOp 的 ICC_Profiles 的数组。
getIcon(int) - 接口 java.beans.BeanInfo 中的方法
此方法返回一个图像对象，可用该对象表示工具框、工具栏等中的 bean。
getIcon(int) - 类 java.beans.SimpleBeanInfo 中的方法
声明没有可用的图标。
getIcon() - 类 javax.swing.AbstractButton 中的方法
返回默认图标。
getIcon(File) - 类 javax.swing.filechooser.FileView 中的方法
表示 JFileChooser 中此文件的图标。
getIcon(File) - 类 javax.swing.JFileChooser 中的方法
返回此文件或文件类型的图标，这取决于系统。
getIcon() - 类 javax.swing.JLabel 中的方法
返回该标签显示的图形图像（字形、图标）。
getIcon() - 类 javax.swing.JOptionPane 中的方法
返回此窗格显示的图标。
getIcon(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getIcon() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回来自接收者为其提供外观的 JOptionPane 的图标，或者从 getDefaultIcon 返回的默认图标。
getIcon(SynthContext, Object) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
获得其值是一个 Icon 的特定样式属性的便捷方法。
getIcon(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
从属性列表中获取图标设置。
getIcon(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Icon，则返回该 Icon，否则返回 null。
getIcon(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。
getIcon(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个 Icon。
getIcon(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个 Icon。
getIconAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡图标。
getIconForTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getIconForType(int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回用于传入类型的图标。
getIconHeight() - 接口 javax.swing.Icon 中的方法
返回图标的高度。
getIconHeight() - 类 javax.swing.ImageIcon 中的方法
获得图标的高度。
getIconHeight() - 类 javax.swing.plaf.IconUIResource 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalComboBoxIcon 中的方法
创建一个满足该接口的 stub。
getIconHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 中的方法

getIconHeight() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的方法

getIconImage() - 类 java.awt.Frame 中的方法
返回要作为此窗体图标显示的图像。
getIconImages() - 类 java.awt.Window 中的方法
返回要作为此窗口的图标显示的图像序列。
getIconTextGap() - 类 javax.swing.AbstractButton 中的方法
返回此按钮中显示的文本与图标之间的间隔量。
getIconTextGap() - 类 javax.swing.JLabel 中的方法
返回此标签中显示的文本和图标之间的间隔量。
getIconWidth() - 接口 javax.swing.Icon 中的方法
返回图标的宽度。
getIconWidth() - 类 javax.swing.ImageIcon 中的方法
获得图标的宽度。
getIconWidth() - 类 javax.swing.plaf.IconUIResource 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalComboBoxIcon 中的方法
创建一个满足该接口的 stub。
getIconWidth() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 中的方法

getIconWidth() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的方法

getID() - 类 java.awt.AWTEvent 中的方法
返回事件类型。
getId() - 类 java.lang.Thread 中的方法
返回该线程的标识符。
getID() - 类 java.rmi.activation.Activatable 中的方法
返回对象的激活标识符。
getID() - 类 java.util.TimeZone 中的方法
获取此时区的 ID。
getID() - 接口 javax.naming.directory.Attribute 中的方法
检索此属性的 id。
getID() - 类 javax.naming.directory.BasicAttribute 中的方法

getID() - 类 javax.naming.ldap.BasicControl 中的方法
检索控件的对象标识符字符串。
getID() - 接口 javax.naming.ldap.Control 中的方法
检索为 LDAP 控件分配的对象标识符。
getID() - 接口 javax.naming.ldap.ExtendedRequest 中的方法
检索请求的对象标识符。
getID() - 接口 javax.naming.ldap.ExtendedResponse 中的方法
检索响应的对象标识符。
getID() - 类 javax.naming.ldap.StartTlsRequest 中的方法
检索 StartTLS 请求的对象标识符字符串。
getID() - 类 javax.naming.ldap.StartTlsResponse 中的方法
检索 StartTLS 响应的对象标识符字符串。
getId() - 接口 javax.net.ssl.SSLSession 中的方法
返回分配给此会话的标识符。
getID() - 类 javax.swing.LookAndFeel 中的方法
返回标识此外观的字符串。
getID() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
此外观的标识符。
getID() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回适合应用程序/服务使用、标识此外观的 string。
getID() - 类 javax.swing.plaf.synth.ColorType 中的方法
以整数形式返回此 ColorType 的唯一 id。
getID() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回一个标识此外观的短字符串。
getId() - 接口 javax.xml.crypto.dsig.keyinfo.KeyInfo 中的方法
返回此 KeyInfo 的可选 Id 属性，这对于从其他 XML 结构引用此 KeyInfo 可能很有用。
getId() - 接口 javax.xml.crypto.dsig.Manifest 中的方法
返回此 Manifest 的 Id。
getId() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回此 Reference 的可选 Id 属性，该属性允许从其他地方引用此 Reference。
getId() - 接口 javax.xml.crypto.dsig.SignatureProperties 中的方法
返回此 SignatureProperties 的 Id。
getId() - 接口 javax.xml.crypto.dsig.SignatureProperty 中的方法
返回此 SignatureProperty 的 Id。
getId() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
返回此 SignedInfo 的可选 Id 属性。
getId() - 接口 javax.xml.crypto.dsig.XMLObject 中的方法
返回此 XMLObject 的 Id。
getId() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回此 XMLSignature 的可选 Id。
getId() - 接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue 中的方法
返回此 SignatureValue 的可选 Id 属性，该属性允许从其他地方引用此元素。
getId() - 类 javax.xml.datatype.DatatypeConstants.Field 中的方法
获取此字段的 ID。
getId() - 异常 org.omg.CORBA.portable.ApplicationException 中的方法
返回异常的 CORBA 存储库 ID 而不会将其从异常输入流中移除。
getIdentifier(int) - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回指定行的标识符。
getIdentifier() - 类 javax.swing.RowFilter.Entry 中的方法
返回条目的标识符（在模型中）。
getIdentifier() - 类 javax.swing.table.TableColumn 中的方法
返回此列的 identifier 对象。
getIdentifierQuoteString() - 接口 java.sql.DatabaseMetaData 中的方法
获取用于引用 SQL 标识符的字符串。
getIdentity(String) - 类 java.security.IdentityScope 中的方法
已过时。 返回此作用域内具有指定名称的身份（如果有的话）。
getIdentity(Principal) - 类 java.security.IdentityScope 中的方法
已过时。 获取名称与指定的主体相同的身份。
getIdentity(PublicKey) - 类 java.security.IdentityScope 中的方法
已过时。 获取具有指定公钥的身份。
getIdentityHashCode() - 类 java.lang.management.LockInfo 中的方法
返回从 System.identityHashCode(java.lang.Object) 方法返回的锁对象的标识哈希码。
getIDs() - 接口 javax.naming.directory.Attributes 中的方法
检索属性集中属性的 id 的枚举。
getIDs() - 类 javax.naming.directory.BasicAttributes 中的方法

getIds() - 接口 javax.net.ssl.SSLSessionContext 中的方法
返回在此 SSLSessionContext 下分组的所有会话 id 的 Enumeration。
getIDstring() - 类 java.awt.GraphicsDevice 中的方法
返回与此 GraphicsDevice 关联的标识字符串。
getIfModifiedSince() - 类 java.net.URLConnection 中的方法
返回此对象的 ifModifiedSince 字段的值。
getIgnoreRepaint() - 类 java.awt.Component 中的方法

getImage(URL) - 类 java.applet.Applet 中的方法
返回能被绘制到屏幕上的 Image 对象。
getImage(URL, String) - 类 java.applet.Applet 中的方法
返回能被绘制到屏幕上的 Image 对象。
getImage(URL) - 接口 java.applet.AppletContext 中的方法
返回能被绘制到屏幕上的 Image 对象。
getImage() - 类 java.awt.TexturePaint 中的方法
返回用于填充形状的 BufferedImage 纹理。
getImage(String) - 类 java.awt.Toolkit 中的方法
返回一幅图像，该图像从指定文件中获取像素数据，图像格式可以是 GIF、JPEG 或 PNG。
getImage(URL) - 类 java.awt.Toolkit 中的方法
返回一幅图像，该图像从指定 URL 获取像素数据。
getImage() - 类 java.awt.TrayIcon 中的方法
返回用于此 TrayIcon 的当前图像。
getImage() - 类 javax.swing.ImageIcon 中的方法
返回此图标的 Image。
getImage() - 类 javax.swing.text.html.ImageView 中的方法
返回要呈现的图像。
getImageableHeight() - 类 java.awt.print.PageFormat 中的方法
返回页面可成像区域的高度（以 1/72 英寸为单位）。
getImageableHeight() - 类 java.awt.print.Paper 中的方法
返回此 Paper 对象可成像区域的高度。
getImageableWidth() - 类 java.awt.print.PageFormat 中的方法
返回页面可成像区域的宽度（以 1/72 英寸为单位）。
getImageableWidth() - 类 java.awt.print.Paper 中的方法
返回此 Paper 对象可成像区域的宽度。
getImageableX() - 类 java.awt.print.PageFormat 中的方法
返回与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 x 坐标。
getImageableX() - 类 java.awt.print.Paper 中的方法
返回此 Paper 对象可成像区域左上角的 x 坐标。
getImageableY() - 类 java.awt.print.PageFormat 中的方法
返回与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 y 坐标。
getImageableY() - 类 java.awt.print.Paper 中的方法
返回此 Paper 对象可成像区域左上角的 y 坐标。
getImageCapabilities() - 类 java.awt.GraphicsConfiguration 中的方法
返回此 GraphicsConfiguration 的图像能力。
getImageLoadStatus() - 类 javax.swing.ImageIcon 中的方法
返回图像加载操作的状态。
getImageMetadata(int) - 类 javax.imageio.ImageReader 中的方法
返回包含与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
getImageMetadata(int, String, Set<String>) - 类 javax.imageio.ImageReader 中的方法
返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
getImageMetadataFormat(String) - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回描述给定的图像元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
getImageObserver() - 类 javax.swing.ImageIcon 中的方法
返回图像的图像观察者。
getImageReader(ImageWriter) - 类 javax.imageio.ImageIO 中的静态方法
返回对应于给定 ImageWriter 的 ImageReader（如果有）；如果此 ImageWriter 的插件没有指定相应的 ImageReader，或者给定 ImageWriter 没有注册，则返回 null。
getImageReaders(Object) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。
getImageReadersByFormatName(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。
getImageReadersByMIMEType(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。
getImageReadersBySuffix(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。
getImageReaderSpiNames() - 类 javax.imageio.spi.ImageWriterSpi 中的方法
返回一个 String 数组，该数组包含所有能够理解由与此服务提供者关联的 ImageWriter 使用的内部元数据表示形式的 ImageReaderSpi 类的完全限定名。
getImageTranscoders(ImageReader, ImageWriter) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。
getImageTypes(int) - 类 javax.imageio.ImageReader 中的方法
以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。
getImageURL() - 类 java.awt.SplashScreen 中的方法
返回当前闪现屏幕图像。
getImageURL() - 类 javax.swing.text.html.ImageView 中的方法
返回图像源的 URL，如果不能确定图像源，则返回 null。
getImageWriter(ImageReader) - 类 javax.imageio.ImageIO 中的静态方法
返回对应于给定 ImageReader 的 ImageWriter（如果有）；如果此 ImageReader 的插件没有指定相应的 ImageWriter，或者给定的 ImageReader 没有注册，则返回 null。
getImageWriters(ImageTypeSpecifier, String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
getImageWritersByFormatName(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。
getImageWritersByMIMEType(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。
getImageWritersBySuffix(String) - 类 javax.imageio.ImageIO 中的静态方法
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。
getImageWriterSpiNames() - 类 javax.imageio.spi.ImageReaderSpi 中的方法
返回一个 String 数组，其包含所有能够理解由与此服务提供者关联的 ImageReader 使用的内部元数据表示形式的 ImageWriterSpi 类的完全限定名。
getImpact() - 类 javax.management.MBeanOperationInfo 中的方法
返回该方法所产生的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。
getImpact() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回一个 int 常量，该常量限定此 OpenMBeanOperationInfo 实例描述的操作的效果。
getImpact(MBeanOperationInfo) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的操作的 impact 标志。
getImplementation() - 类 javax.management.StandardMBean 中的方法
获取此 Standard MBean（或 MXBean）的实现。
getImplementation() - 接口 org.w3c.dom.Document 中的方法
处理此文档的 DOMImplementation 对象。
getImplementationClass() - 类 javax.management.StandardMBean 中的方法
获取此 Standard MBean（或 MXBean）的实现类。
getImplementationName() - 类 javax.management.MBeanServerDelegate 中的方法
返回 JMX 实现的名称（此产品的名称）。
getImplementationName() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回 JMX 实现名（此产品的名称）。
getImplementationTitle() - 类 java.lang.Package 中的方法
返回此包的标题。
getImplementationVendor() - 类 java.lang.Package 中的方法
返回提供该实现的组织、供应商或公司的名称。
getImplementationVendor() - 类 javax.management.MBeanServerDelegate 中的方法
返回 JMX 实现供应商（此产品的供应商）。
getImplementationVendor() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回 JMX 实现供应商（此产品的供应商）。
getImplementationVersion() - 类 java.lang.Package 中的方法
返回该实现的版本。
getImplementationVersion() - 类 javax.management.MBeanServerDelegate 中的方法
返回 JMX 实现的版本（此产品的版本）。
getImplementationVersion() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回 JMX 实现版本（此产品的版本）。
getImplementor() - 类 javax.xml.ws.Endpoint 中的方法
返回此端点的实现对象。
getImplicitDownCycleTraversal() - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回对此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环的判断。
getImplicitDownCycleTraversal() - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回对此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环的判断。
getImportedKeys(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取由给定表的外键列（表导入的主键）引用的主键列的描述。
getInactiveControlTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的非活动控件文本颜色。
getInactiveControlTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回非活动控件文本颜色。
getInactiveControlTextColor() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回非活动控件文本颜色。
getInactiveSystemTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的非活动系统文本颜色。
getInactiveSystemTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回非活动系统文本颜色。
getInCheck() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
getIndentLevel() - 类 javax.swing.text.AbstractWriter 中的方法
返回当前的缩进级别。
getIndentSpace() - 类 javax.swing.text.AbstractWriter 中的方法
返回要缩进的空格量。
getIndex() - 类 java.beans.IndexedPropertyChangeEvent 中的方法
获得被更改属性的索引。
getIndex() - 异常 java.net.URISyntaxException 中的方法
返回输入字符串中出现解析错误的位置的索引，或者如果该位置为未知，则返回 -1。
getIndex() - 异常 java.security.cert.CertPathValidatorException 中的方法
返回导致该异常抛出的证书在证书路径中的索引。
getIndex() - 异常 java.sql.DataTruncation 中的方法
获取被截断的列或参数的索引。
getIndex() - 接口 java.text.CharacterIterator 中的方法
返回当前索引。
getIndex() - 类 java.text.ParsePosition 中的方法
获取当前的解析位置。
getIndex() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.getIndex()。
getIndex() - 异常 java.util.regex.PatternSyntaxException 中的方法
获取错误的索引。
getIndex() - 接口 javax.swing.event.DocumentEvent.ElementChange 中的方法
获得所表示元素中的索引。
getIndex() - 类 javax.swing.JList.DropLocation 中的方法
返回列表中应该用来放入放置数据的索引。
getIndex(int) - 类 javax.swing.SizeSequence 中的方法
返回与指定位置对应的条目的索引。
getIndex(TreeNode) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
返回接收方子级中 node 的索引。
getIndex() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
返回元素列表中的索引。
getIndex() - 类 javax.swing.text.html.parser.Element 中的方法
获取索引。
getIndex() - 类 javax.swing.text.JTextComponent.DropLocation 中的方法
返回关联组件中应该用来插入放置数据的位置的索引。
getIndex() - 类 javax.swing.text.Segment 中的方法
返回当前索引。
getIndex(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的子节点数组中指定子节点的索引。
getIndex(TreeNode) - 接口 javax.swing.tree.TreeNode 中的方法
返回接收者子节点中的 node 的索引。
getIndex(String, String) - 接口 org.xml.sax.Attributes 中的方法
通过名称空间的名称查找属性的索引。
getIndex(String) - 接口 org.xml.sax.Attributes 中的方法
通过 XML 限定（前缀）名查找属性的索引。
getIndex(String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过名称空间名称查找属性的索引。
getIndex(String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定（加前缀的）名称查找属性的索引。
getIndex0() - 类 javax.swing.event.ListDataEvent 中的方法
返回该范围的较小的索引。
getIndex1() - 类 javax.swing.event.ListDataEvent 中的方法
返回该范围的较大的索引。
getIndexAtPoint(Point) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
给出本地坐标中的一个点，返回该 Point 下的、从零开始的字符索引。
getIndexAtPoint(Point) - 接口 javax.accessibility.AccessibleText 中的方法
给定本地坐标中的一点，返回在该点下的字符从 0 开始的索引。
getIndexAtPoint(Point) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
getIndexAtPoint(Point) - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
getIndexAtPoint(Point) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
getIndexAtPoint(Point) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
在本地坐标中给定一个点，返回该 Point 下字符的从零开始的索引。
getIndexAtPoint(Point) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
getIndexedPropertyType() - 类 java.beans.IndexedPropertyDescriptor 中的方法
获得索引属性类型的 Class 对象。
getIndexedReadMethod() - 类 java.beans.IndexedPropertyDescriptor 中的方法
获得应该用于读取索引属性值的方法。
getIndexedWriteMethod() - 类 java.beans.IndexedPropertyDescriptor 中的方法
获得应该用于写入索引属性值的方法。
getIndexInfo(String, String, String, boolean, boolean) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定表的索引和统计信息的描述。
getIndexNames() - 类 javax.management.openmbean.TabularType 中的方法
按照提供此实例的构造方法的顺序返回一个不可修改的项名称列表，可以使用该列表的值唯一地索引此 TabularType 实例所描述的表格数据值的每个行元素。
getIndexOf(Object) - 类 javax.swing.DefaultComboBoxModel 中的方法
返回指定对象在列表中的索引位置。
getIndexOf(Component) - 类 javax.swing.JLayeredPane 中的方法
返回指定 Component 的索引。
getIndexOfChild(Object, Object) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回父节点中子节点的索引。
getIndexOfChild(Object, Object) - 接口 javax.swing.tree.TreeModel 中的方法
返回父节点中子节点的索引。
getIndexOfSize(float) - 类 javax.swing.text.html.StyleSheet 中的静态方法

getInetAddress() - 类 java.net.DatagramSocket 中的方法
返回此套接字连接的地址。
getInetAddress() - 类 java.net.ServerSocket 中的方法
返回此服务器套接字的本地地址。
getInetAddress() - 类 java.net.Socket 中的方法
返回套接字连接的地址。
getInetAddress() - 类 java.net.SocketImpl 中的方法
返回此套接字的 address 字段的值。
getInetAddresses() - 类 java.net.NetworkInterface 中的方法
一个便捷方法，返回一个具有绑定到此网络接口全部或部分 InetAddress 的 Enumeration。
getInfinity() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于表示无穷大的字符串。
getInfo() - 类 java.security.Identity 中的方法
已过时。 返回以前为此 Identity 指定的常规信息字符串。
getInfo() - 类 java.security.Provider 中的方法
返回 provider 及其服务的人可读 (human-readable) 的描述。
getInheritsPopupMenu() - 类 javax.swing.JComponent 中的方法
如果应该从父组件继承 JPopupMenu，则返回 true。
getInit() - 类 java.lang.management.MemoryUsage 中的方法
返回 Java 虚拟机最初从操作系统请求用于内存管理的内存量（以字节为单位）。
getInitialComponent(Window) - 类 java.awt.FocusTraversalPolicy 中的方法
返回第一次将窗口设置为可见时，应该接收焦点的 Component。
getInitialComponent(JInternalFrame) - 类 javax.swing.InternalFrameFocusTraversalPolicy 中的方法
返回第一次选择 JInternalFrame 时应该接收焦点的 Component。
getInitialContext(Hashtable<?, ?>) - 接口 javax.naming.spi.InitialContextFactory 中的方法
创建一个初始上下文，以便开始进行名称解析。
getInitialContext(Hashtable<?, ?>) - 类 javax.naming.spi.NamingManager 中的静态方法
使用指定环境属性创建一个初始上下文工厂。
getInitialDelay() - 类 javax.swing.Timer 中的方法
返回 Timer 的初始延迟。
getInitialDelay() - 类 javax.swing.ToolTipManager 中的方法
返回初始延迟值。
getInitialLocation(Insets) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
如果 Insets 不为 null，则返回左边 inset；如果其为 null，则返回 0。
getInitialPolicies() - 类 java.security.cert.PKIXParameters 中的方法
返回初始策略标识符（OID 字符串）的不可变 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
getInitialSelectionValue() - 类 javax.swing.JOptionPane 中的方法
返回（根据最初选择）向用户显示的输入值。
getInitialValue() - 类 javax.swing.JOptionPane 中的方法
返回初始值。
getInitialValueIndex() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
将初始索引返回给要选择的按钮。
getInitiatedClasses(ClassLoader) - 接口 java.lang.instrument.Instrumentation 中的方法
返回所有初始化加载器是 loader 的类的数组。
getInitiatorAddress() - 类 org.ietf.jgss.ChannelBinding 中的方法
获得此通道绑定的初始端地址。
getInitThreshold() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察对象的公共初始阈值。
getInitThreshold() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取所有 observed 对象的公共初始阈值。
getInput() - 异常 java.net.URISyntaxException 中的方法
返回输入字符串。
getInput() - 类 javax.imageio.ImageReader 中的方法
返回以前设置为输入源的 ImageInputStream 或其他 Object。
getInput() - 接口 org.w3c.dom.ls.LSLoadEvent 中的方法
被解析的输入源。
getInput() - 接口 org.w3c.dom.ls.LSProgressEvent 中的方法
被解析的输入源。
getInputArguments() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回传递给 Java 虚拟机的输入变量，其中不包括传递给 main 方法的变量。
getInputAttributes() - 类 javax.swing.JTextPane 中的方法
获取窗格的输入属性。
getInputAttributes() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取该样式编辑动作的输入属性。
getInputAttributes() - 类 javax.swing.text.StyledEditorKit 中的方法
获取该窗格的输入属性。
getInputClass() - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
返回表示必须由输入源实现（以便使用 createInputStreamInstance 方法在 ImageInputStream 中“包装”）的类或接口的类型的 Class 对象。
getInputContext() - 类 java.awt.Component 中的方法
获取此组件使用的输入上下文，用于处理在此组件中输入文本时与输入方法的通信。
getInputContext() - 类 java.awt.Window 中的方法
获取此窗口的输入上下文。
getInputEncoding() - 接口 org.w3c.dom.Document 中的方法
指定解析时此文档使用的编码的属性。
getInputEncoding() - 接口 org.w3c.dom.Entity 中的方法
当实体为外部解析实体时，它是在解析时用于此实体的指定编码的属性。
getInputLength() - 异常 java.nio.charset.MalformedInputException 中的方法

getInputLength() - 异常 java.nio.charset.UnmappableCharacterException 中的方法

getInputMap(int) - 类 javax.swing.JComponent 中的方法
返回 condition 中所使用的 InputMap。
getInputMap() - 类 javax.swing.JComponent 中的方法
返回组件具有焦点时所使用的 InputMap。
getInputMethodControlObject() - 类 java.awt.im.InputContext 中的方法
返回当前输入方法中的一个控制对象，或 null。
getInputMethodDisplayName(Locale, Locale) - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
用将显示该名称的语言返回用户可视名称，该名称与给定的输入语言环境的输入方法相对应。
getInputMethodIcon(Locale) - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
返回相应输入方法的图标。
getInputMethodListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的输入方法侦听器的数组。
getInputMethodRequests() - 类 java.awt.Component 中的方法
获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。
getInputMethodRequests() - 类 java.awt.TextComponent 中的方法

getInputMethodRequests() - 类 javax.swing.text.JTextComponent 中的方法

getInputSource() - 类 javax.xml.transform.sax.SAXSource 中的方法
获取要用于 Source 的 SAX InputSource。
getInputStream() - 类 java.lang.Process 中的方法
获取子进程的输入流。
getInputStream() - 类 java.net.Socket 中的方法
返回此套接字的输入流。
getInputStream() - 类 java.net.SocketImpl 中的方法
返回此套接字的输入流。
getInputStream() - 类 java.net.URLConnection 中的方法
返回从此打开的连接读取的输入流。
getInputStream() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
getInputStream(ZipEntry) - 类 java.util.jar.JarFile 中的方法
返回用于读取指定 zip 文件条目内容的输入流。
getInputStream(ZipEntry) - 类 java.util.zip.ZipFile 中的方法
返回输入流以读取指定 ZIP 文件条目的内容。
getInputStream() - 类 javax.activation.DataHandler 中的方法
获取此对象的 InputSteam。
getInputStream() - 接口 javax.activation.DataSource 中的方法
此方法返回一个表示数据的 InputStream；如果无法提供，则抛出适当的异常。
getInputStream() - 类 javax.activation.FileDataSource 中的方法
此方法将返回一个表示数据的 InputStream；如果不能返回，则抛出 IOException。
getInputStream() - 类 javax.activation.URLDataSource 中的方法
URL 的 getInputStream 方法。
getInputStream() - 类 javax.xml.transform.stream.StreamSource 中的方法
获取通过 setByteStream 设置的字节流。
getInputStream() - 异常 org.omg.CORBA.portable.ApplicationException 中的方法
返回可从中读取异常数据作为其参数的输入流。
getInputTypes() - 类 javax.imageio.spi.ImageReaderSpi 中的方法
返回 Class 对象数组，指示可用作 reader 的 setInput 方法参数的对象类型。
getInputValue() - 类 javax.swing.JOptionPane 中的方法
如果 wantsInput 为 true，则返回用户已输入的值。
getInputVerifier() - 类 javax.swing.JComponent 中的方法
返回此组件的输入校验器。
getInsertionIndex() - 类 java.awt.font.TextHitInfo 中的方法
返回插入索引。
getInsertPositionOffset() - 接口 java.awt.im.InputMethodRequests 中的方法
获取文本编辑组件中包含的提交文本中的插入位置偏移量。
getInset(int, View) - 类 javax.swing.text.html.StyleSheet.BoxPainter 中的方法
获取给定边上所需的 inset，以便计算空白、边框和填充数量。
getInsets() - 类 java.awt.Container 中的方法
确定此容器的 insets，它指示容器边框的大小。
getInsets() - 类 javax.swing.JComponent 中的方法
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
getInsets(Insets) - 类 javax.swing.JComponent 中的方法
返回包含此组件 inset 值的 Insets 对象。
getInsets() - 类 javax.swing.JViewport 中的方法
返回 inset（边框）维数 (0,0,0,0)，因为在 JViewport 上不支持边框。
getInsets(Insets) - 类 javax.swing.JViewport 中的方法
返回包含此 JViewport 的 inset 值的 inset 对象。
getInsets() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
获取 JComboBox 的 insets。
getInsets(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法

getInsets() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
getInsets(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回 insets。
getInsets() - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法

getInsets(SynthContext, Insets) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回用来计算大小调整信息的 Insets。
getInsets(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Insets，则返回它，否则返回 null。
getInsets(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。
getInsets(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个 Insets 对象。
getInsets(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个 Insets 对象。
getInsetSpan(int) - 类 javax.swing.text.AsyncBoxView 中的方法
获取 insets 所占据的沿某个轴的跨距。
getInsideAllocation(Shape) - 类 javax.swing.text.CompositeView 中的方法
将分配给视图的不可变分配区域转换为表示内部分配区域的可变分配区域（即给定分配区域的边界，其顶部、左部、底部和右部的 insets 已移除）。
getInsideBorder() - 类 javax.swing.border.CompoundBorder 中的方法
返回内部边框对象。
getInstalledLookAndFeels() - 类 javax.swing.UIManager 中的静态方法
返回表示当前可用的 LookAndFeel 实现的 LookAndFeelInfo 数组。
getInstance(int) - 类 java.awt.AlphaComposite 中的静态方法
创建一个具有指定规则的 AlphaComposite 对象。
getInstance(int, float) - 类 java.awt.AlphaComposite 中的静态方法
创建一个 AlphaComposite 对象，它具有指定的规则和用来乘源色 alpha 值的常量 alpha 值。
getInstance(int) - 类 java.awt.color.ColorSpace 中的静态方法
返回表示特定于预定义颜色空间之一的 ColorSpace。
getInstance(byte[]) - 类 java.awt.color.ICC_Profile 中的静态方法
构造一个与 byte 数组中的数据相对应的 ICC_Profile 对象。
getInstance(int) - 类 java.awt.color.ICC_Profile 中的静态方法
构造一个与 ColorSpace 类所定义的指定颜色空间之一（如 CS_sRGB）相对应的 ICC_Profile。
getInstance(String) - 类 java.awt.color.ICC_Profile 中的静态方法
构造一个与文件中的数据相对应的 ICC_Profile。
getInstance(InputStream) - 类 java.awt.color.ICC_Profile 中的静态方法
构造一个与 InputStream 中的数据相对应的 ICC_Profile。
getInstance() - 类 java.awt.im.InputContext 中的静态方法
返回新 InputContext 实例。
getInstance(String) - 类 java.security.AlgorithmParameterGenerator 中的静态方法
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
getInstance(String, String) - 类 java.security.AlgorithmParameterGenerator 中的静态方法
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
getInstance(String, Provider) - 类 java.security.AlgorithmParameterGenerator 中的静态方法
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
getInstance(String) - 类 java.security.AlgorithmParameters 中的静态方法
返回指定算法的参数对象。
getInstance(String, String) - 类 java.security.AlgorithmParameters 中的静态方法
返回指定算法的参数对象。
getInstance(String, Provider) - 类 java.security.AlgorithmParameters 中的静态方法
返回指定算法的参数对象。
getInstance(String) - 类 java.security.cert.CertificateFactory 中的静态方法
返回实现指定证书类型的 CertificateFactory 对象。
getInstance(String, String) - 类 java.security.cert.CertificateFactory 中的静态方法
返回指定证书类型的 CertificateFactory 对象。
getInstance(String, Provider) - 类 java.security.cert.CertificateFactory 中的静态方法
返回指定证书类型的 CertificateFactory 对象。
getInstance(String) - 类 java.security.cert.CertPathBuilder 中的静态方法
返回实现了指定算法的 CertPathBuilder 对象。
getInstance(String, String) - 类 java.security.cert.CertPathBuilder 中的静态方法
返回实现了指定算法的 CertPathBuilder 对象。
getInstance(String, Provider) - 类 java.security.cert.CertPathBuilder 中的静态方法
返回实现了指定算法的 CertPathBuilder 对象。
getInstance(String) - 类 java.security.cert.CertPathValidator 中的静态方法
返回实现了指定算法的 CertPathValidator 对象。
getInstance(String, String) - 类 java.security.cert.CertPathValidator 中的静态方法
返回实现指定算法的 CertPathValidator 对象。
getInstance(String, Provider) - 类 java.security.cert.CertPathValidator 中的静态方法
返回实现指定算法的 CertPathValidator 对象。
getInstance(String, CertStoreParameters) - 类 java.security.cert.CertStore 中的静态方法
返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
getInstance(String, CertStoreParameters, String) - 类 java.security.cert.CertStore 中的静态方法
返回一个实现指定 CertStore 类型的 CertStore 对象。
getInstance(String, CertStoreParameters, Provider) - 类 java.security.cert.CertStore 中的静态方法
返回一个实现指定 CertStore 类型的 CertStore 对象。
getInstance(String) - 类 java.security.KeyFactory 中的静态方法
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
getInstance(String, String) - 类 java.security.KeyFactory 中的静态方法
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
getInstance(String, Provider) - 类 java.security.KeyFactory 中的静态方法
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
getInstance(String) - 类 java.security.KeyPairGenerator 中的静态方法
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
getInstance(String, String) - 类 java.security.KeyPairGenerator 中的静态方法
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
getInstance(String, Provider) - 类 java.security.KeyPairGenerator 中的静态方法
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
getInstance(String) - 类 java.security.KeyStore 中的静态方法
返回指定类型的 keystore 对象。
getInstance(String, String) - 类 java.security.KeyStore 中的静态方法
返回指定类型的 keystore 对象。
getInstance(String, Provider) - 类 java.security.KeyStore 中的静态方法
返回指定类型的 keystore 对象。
getInstance(String) - 类 java.security.MessageDigest 中的静态方法
返回实现指定摘要算法的 MessageDigest 对象。
getInstance(String, String) - 类 java.security.MessageDigest 中的静态方法
返回实现指定摘要算法的 MessageDigest 对象。
getInstance(String, Provider) - 类 java.security.MessageDigest 中的静态方法
返回实现指定摘要算法的 MessageDigest 对象。
getInstance(String, Policy.Parameters) - 类 java.security.Policy 中的静态方法
返回指定类型的 Policy 对象。
getInstance(String, Policy.Parameters, String) - 类 java.security.Policy 中的静态方法
返回指定类型的 Policy 对象。
getInstance(String, Policy.Parameters, Provider) - 类 java.security.Policy 中的静态方法
返回指定类型的 Policy 对象。
getInstance(String) - 类 java.security.SecureRandom 中的静态方法
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
getInstance(String, String) - 类 java.security.SecureRandom 中的静态方法
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
getInstance(String, Provider) - 类 java.security.SecureRandom 中的静态方法
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
getInstance(String) - 类 java.security.Signature 中的静态方法
返回实现指定签名算法的 Signature 对象。
getInstance(String, String) - 类 java.security.Signature 中的静态方法
返回实现指定签名算法的 Signature 对象。
getInstance(String, Provider) - 类 java.security.Signature 中的静态方法
返回实现指定签名算法的 Signature 对象。
getInstance() - 类 java.text.Collator 中的静态方法
获取当前默认语言环境的 Collator。
getInstance(Locale) - 类 java.text.Collator 中的静态方法
获取所需语言环境的 Collator。
getInstance() - 类 java.text.DateFormat 中的静态方法
获取为日期和时间使用 SHORT 风格的默认日期/时间格式器。
getInstance() - 类 java.text.DateFormatSymbols 中的静态方法
获取默认语言环境的 DateFormatSymbols 实例。
getInstance(Locale) - 类 java.text.DateFormatSymbols 中的静态方法
获取指定语言环境的 DateFormatSymbols 实例。
getInstance() - 类 java.text.DecimalFormatSymbols 中的静态方法
获取默认语言环境的 DecimalFormatSymbols 实例。
getInstance(Locale) - 类 java.text.DecimalFormatSymbols 中的静态方法
获取指定语言环境的 DecimalFormatSymbols 实例。
getInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的通用数值格式。
getInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的通用数值格式。
getInstance(Locale) - 类 java.text.spi.CollatorProvider 中的方法
为指定语言环境返回新的 Collator 实例。
getInstance(Locale) - 类 java.text.spi.DateFormatSymbolsProvider 中的方法
为指定语言环境返回一个新的 DateFormatSymbols 实例。
getInstance(Locale) - 类 java.text.spi.DecimalFormatSymbolsProvider 中的方法
为指定语言环境返回新的 DecimalFormatSymbols 实例。
getInstance() - 类 java.util.Calendar 中的静态方法
使用默认时区和语言环境获得一个日历。
getInstance(TimeZone) - 类 java.util.Calendar 中的静态方法
使用指定时区和默认语言环境获得一个日历。
getInstance(Locale) - 类 java.util.Calendar 中的静态方法
使用默认时区和指定语言环境获得一个日历。
getInstance(TimeZone, Locale) - 类 java.util.Calendar 中的静态方法
使用指定时区和语言环境获得一个日历。
getInstance(String) - 类 java.util.Currency 中的静态方法
返回给定货币代码的 Currency 实例。
getInstance(Locale) - 类 java.util.Currency 中的静态方法
返回给定语言环境的国家/地区的 Currency 实例。
getInstance(String) - 类 javax.crypto.Cipher 中的静态方法
返回实现指定转换的 Cipher 对象。
getInstance(String, String) - 类 javax.crypto.Cipher 中的静态方法
返回实现指定转换的 Cipher 对象。
getInstance(String, Provider) - 类 javax.crypto.Cipher 中的静态方法
返回实现指定转换的 Cipher 对象。
getInstance(String) - 类 javax.crypto.ExemptionMechanism 中的静态方法
返回实现指定豁免机制算法的 ExemptionMechanism 对象。
getInstance(String, String) - 类 javax.crypto.ExemptionMechanism 中的静态方法
返回实现指定豁免机制算法的 ExemptionMechanism 对象。
getInstance(String, Provider) - 类 javax.crypto.ExemptionMechanism 中的静态方法
返回实现指定豁免机制算法的 ExemptionMechanism 对象。
getInstance(String) - 类 javax.crypto.KeyAgreement 中的静态方法
返回实现指定密钥协定算法的 KeyAgreement 对象。
getInstance(String, String) - 类 javax.crypto.KeyAgreement 中的静态方法
返回实现指定密钥协定算法的 KeyAgreement 对象。
getInstance(String, Provider) - 类 javax.crypto.KeyAgreement 中的静态方法
返回实现指定密钥协定算法的 KeyAgreement 对象。
getInstance(String) - 类 javax.crypto.KeyGenerator 中的静态方法
返回生成指定算法的秘密密钥的 KeyGenerator 对象。
getInstance(String, String) - 类 javax.crypto.KeyGenerator 中的静态方法
返回生成指定算法的秘密密钥的 KeyGenerator 对象。
getInstance(String, Provider) - 类 javax.crypto.KeyGenerator 中的静态方法
返回生成指定算法的秘密密钥的 KeyGenerator 对象。
getInstance(String) - 类 javax.crypto.Mac 中的静态方法
返回实现指定 MAC 算法的 Mac 对象。
getInstance(String, String) - 类 javax.crypto.Mac 中的静态方法
返回实现指定 MAC 算法的 Mac 对象。
getInstance(String, Provider) - 类 javax.crypto.Mac 中的静态方法
返回实现指定 MAC 算法的 Mac 对象。
getInstance(String) - 类 javax.crypto.SecretKeyFactory 中的静态方法
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
getInstance(String, String) - 类 javax.crypto.SecretKeyFactory 中的静态方法
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
getInstance(String, Provider) - 类 javax.crypto.SecretKeyFactory 中的静态方法
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
getInstance(String) - 类 javax.management.ObjectName 中的静态方法
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
getInstance(String, String, String) - 类 javax.management.ObjectName 中的静态方法
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。
getInstance(String, Hashtable<String, String>) - 类 javax.management.ObjectName 中的静态方法
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
getInstance(ObjectName) - 类 javax.management.ObjectName 中的静态方法
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
getInstance(String) - 类 javax.net.ssl.KeyManagerFactory 中的静态方法
返回充当密钥管理器工厂的 KeyManagerFactory 对象。
getInstance(String, String) - 类 javax.net.ssl.KeyManagerFactory 中的静态方法
返回充当密钥管理器工厂的 KeyManagerFactory 对象。
getInstance(String, Provider) - 类 javax.net.ssl.KeyManagerFactory 中的静态方法
返回充当密钥管理器工厂的 KeyManagerFactory 对象。
getInstance(String) - 类 javax.net.ssl.SSLContext 中的静态方法
返回实现指定安全套接字协议的 SSLContext 对象。
getInstance(String, String) - 类 javax.net.ssl.SSLContext 中的静态方法
返回实现指定安全套接字协议的 SSLContext 对象。
getInstance(String, Provider) - 类 javax.net.ssl.SSLContext 中的静态方法
返回实现指定安全套接字协议的 SSLContext 对象。
getInstance(String) - 类 javax.net.ssl.TrustManagerFactory 中的静态方法
返回充当信任管理器工厂的 TrustManagerFactory 对象。
getInstance(String, String) - 类 javax.net.ssl.TrustManagerFactory 中的静态方法
返回充当信任管理器工厂的 TrustManagerFactory 对象。
getInstance(String, Provider) - 类 javax.net.ssl.TrustManagerFactory 中的静态方法
返回充当信任管理器工厂的 TrustManagerFactory 对象。
getInstance(String, Configuration.Parameters) - 类 javax.security.auth.login.Configuration 中的静态方法
返回指定类型的 Configuration 对象。
getInstance(String, Configuration.Parameters, String) - 类 javax.security.auth.login.Configuration 中的静态方法
返回指定类型的 Configuration 对象。
getInstance(String, Configuration.Parameters, Provider) - 类 javax.security.auth.login.Configuration 中的静态方法
返回指定类型的 Configuration 对象。
getInstance(InputStream) - 类 javax.security.cert.X509Certificate 中的静态方法
实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。
getInstance(byte[]) - 类 javax.security.cert.X509Certificate 中的静态方法
实例化一个 X509Certificate 对象，并使用指定的 byte 数组初始化它。
getInstance(String) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
返回 providerID 标识的 SyncProvider 实例。
getInstance() - 类 javax.swing.LayoutStyle 中的静态方法
返回 LayoutStyle 的共享实例。
getInstance(String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的静态方法
返回 KeyInfoFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
getInstance(String, Provider) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的静态方法
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。
getInstance(String, String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的静态方法
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。
getInstance() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的静态方法
返回支持默认 XML 处理机制和表示形式类型（“DOM”） 的 KeyInfoFactory。
getInstance(String, String) - 类 javax.xml.crypto.dsig.TransformService 中的静态方法
返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。
getInstance(String, String, Provider) - 类 javax.xml.crypto.dsig.TransformService 中的静态方法
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
getInstance(String, String, String) - 类 javax.xml.crypto.dsig.TransformService 中的静态方法
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
getInstance(String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的静态方法
返回 XMLSignatureFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。
getInstance(String, Provider) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的静态方法
返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
getInstance(String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的静态方法
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
getInstance() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的静态方法
返回支持默认的 XML 处理机制和表示形式类型（“DOM”） 的 XMLSignatureFactory。
getInstance() - 类 org.ietf.jgss.GSSManager 中的静态方法
返回默认的 GSSManager 实现。
getInstanceFollowRedirects() - 类 java.net.HttpURLConnection 中的方法
返回此 HttpURLConnection 的 instanceFollowRedirects 字段的值。
getInstanceOf(Object, Class<?>) - 类 java.beans.Beans 中的静态方法
从给定 bean 中获得表示源对象的指定类型视图的对象。
getInstrument(Patch) - 接口 javax.sound.midi.Soundbank 中的方法
获得取自给定 Patch 的 Instrument。
getInstruments() - 接口 javax.sound.midi.Soundbank 中的方法
获得包含在此音库中的乐器列表。
getInt(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 int 形式返回指定数组对象中索引组件的值。
getInt(Object) - 类 java.lang.reflect.Field 中的方法
获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。
getInt() - 类 java.nio.ByteBuffer 中的方法
用于读取 int 值的相对 get 方法。
getInt(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 int 值的绝对 get 方法。
getInt(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 int 值的形式获取指定的 JDBC INTEGER 参数的值。
getInt(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 int 值的形式获取 JDBC INTEGER 参数的值。
getInt(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
getInt(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
getInt(String, int) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getInt(String,int) 中的规范实现 getInt 方法。
getInt(String, int) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中与指定键相关联的、由字符串表示的 int 值。
getInt(SynthContext, Object, int) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
获得值为 Number 的一个特定样式属性的便捷方法。
getInt(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 Integer，则返回该整数值，否则返回 0。
getInt(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 Integer，则返回其整数值，否则返回 0。
getInt(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个整数。
getInt(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个整数。
getInteger(String) - 类 java.lang.Integer 中的静态方法
确定具有指定名称的系统属性的整数值。
getInteger(String, int) - 类 java.lang.Integer 中的静态方法
确定具有指定名称的系统属性的整数值。
getInteger(String, Integer) - 类 java.lang.Integer 中的静态方法
返回具有指定名称的系统属性的整数值。
getIntegerAttributeValue(AttributeSet, HTML.Attribute, int) - 类 javax.swing.text.html.HTML 中的静态方法
获取整数属性值。
getIntegerInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的整数格式。
getIntegerInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的整数格式。
getIntegerInstance(Locale) - 类 java.text.spi.NumberFormatProvider 中的方法
返回新的 NumberFormat 实例，此实例为指定的语言环境格式化整数值。
getIntegState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定数据完整性是否可用于上下文。
getIntercellSpacing() - 类 javax.swing.JTable 中的方法
返回单元格之间的水平间距和垂直间距。
getInterface() - 类 java.net.MulticastSocket 中的方法
获取用于多播数据包的网络接口的地址。
getInterface(Class<T>) - 接口 javax.script.Invocable 中的方法
返回一个接口的实现，该接口使用解释器中编译的函数。
getInterface(Object, Class<T>) - 接口 javax.script.Invocable 中的方法
返回一个接口的实现，该接口使用解释器中已编译脚本对象的成员函数。
getInterfaceAddresses() - 类 java.net.NetworkInterface 中的方法
获取此网络接口的全部或部分 InterfaceAddresses 所组成的列表。
getInterfaces() - 类 java.lang.Class 中的方法
确定此对象所表示的类或接口实现的接口。
getInterfaces() - 接口 javax.lang.model.element.TypeElement 中的方法
返回直接由此类实现或直接由此接口扩展的接口类型。
getInteriorRectangle(Component, int, int, int, int) - 类 javax.swing.border.AbstractBorder 中的方法
此便捷方法调用静态方法。
getInteriorRectangle(Component, Border, int, int, int, int) - 类 javax.swing.border.AbstractBorder 中的静态方法
返回一个用所给的参数减去边框 insets 得到的矩形。
getInternalFrame() - 类 javax.swing.event.InternalFrameEvent 中的方法
返回事件的发起者。
getInternalFrame() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
返回与此 DesktopIcon 关联的 JInternalFrame。
getInternalFrameAltMaximizeIcon(int) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalFrameBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getInternalFrameCloseIcon(int) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalFrameDefaultMenuIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalFrameListeners() - 类 javax.swing.JInternalFrame 中的方法
返回使用 addInternalFrameListener 添加到此 JInternalFrame 的所有 InternalFrameListener 的数组。
getInternalFrameMaximizeIcon(int) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalFrameMinimizeIcon(int) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getInternalSubset() - 接口 org.w3c.dom.DocumentType 中的方法
以字符串表示的内部子集，如果没有内部子集，则为 null。
getInternationalCurrencySymbol() - 类 java.text.DecimalFormatSymbols 中的方法
返回这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。
getInterpolationType() - 类 java.awt.image.AffineTransformOp 中的方法
返回由此 op 使用的插值类型。
getIntParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 int 返回参数的便捷方法。
getInvalidCharacters() - 类 javax.swing.text.MaskFormatter 中的方法
返回输入无效的字符。
getInverted() - 类 javax.swing.JSlider 中的方法
如果滑块显示的值范围反转，则返回 true。
getInvocationHandler(Object) - 类 java.lang.reflect.Proxy 中的静态方法
返回指定代理实例的调用处理程序。
getInvoker() - 类 javax.swing.JPopupMenu 中的方法
返回作为此弹出菜单的“调用者”的组件。
getInvokesStopCellEditing() - 类 javax.swing.JTree 中的方法
返回告知编辑中断时发生了什么情况的指示符。
getIOException() - 异常 java.awt.print.PrinterIOException 中的方法
返回终止打印作业的 IOException。
getISO3Country() - 类 java.util.Locale 中的方法
返回此语言环境国家/地区的三字母缩写。
getISO3Language() - 类 java.util.Locale 中的方法
返回此语言环境语言的三字母缩写。
getISOCountries() - 类 java.util.Locale 中的静态方法
返回 ISO 3166 中所定义的所有两字母国家/地区代码。
getISOLanguages() - 类 java.util.Locale 中的静态方法
返回 ISO 639 中所定义的所有两字母语言代码。
getIssuer() - 类 java.security.cert.X509CertSelector 中的方法
以 X500Principal 的形式返回 issuer 标准。
getIssuerAlternativeNames() - 类 java.security.cert.X509Certificate 中的方法
从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
getIssuerAsBytes() - 类 java.security.cert.X509CertSelector 中的方法
返回以 byte 数组表示的 issuer 标准。
getIssuerAsString() - 类 java.security.cert.X509CertSelector 中的方法
已过时，使用 X509CertSelector.getIssuer() 或 X509CertSelector.getIssuerAsBytes() 替代。
getIssuerDN() - 类 java.security.cert.X509Certificate 中的方法
已过时，由 X509Certificate.getIssuerX500Principal() 替代。
getIssuerDN() - 类 java.security.cert.X509CRL 中的方法
已过时，由 X509CRL.getIssuerX500Principal() 替代。
getIssuerDN() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的 issuer（发布方的标识名）值。
getIssuerName() - 接口 javax.xml.crypto.dsig.keyinfo.X509IssuerSerial 中的方法
返回 RFC 2253 String 格式的此 X509IssuerSerial 的 X.500 标识名。
getIssuerNames() - 类 java.security.cert.X509CRLSelector 中的方法
返回该 issuerNames 标准的一个副本。
getIssuers() - 类 java.security.cert.X509CRLSelector 中的方法
返回 issuerNames 标准。
getIssuerUniqueID() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 issuerUniqueID 值。
getIssuerX500Principal() - 类 java.security.cert.X509Certificate 中的方法
以 X500Principal 的形式返回证书的发布方（发布方标识名）值。
getIssuerX500Principal() - 类 java.security.cert.X509CRL 中的方法
以 X500Principal 的形式返回 CRL 的发布方（发布方标识名）值。
getItalicAngle() - 类 java.awt.Font 中的方法
返回此 Font 的斜角。
getItem(int) - 类 java.awt.Choice 中的方法
获取此 Choice 菜单中指定索引上的字符串。
getItem() - 类 java.awt.event.ItemEvent 中的方法
返回受事件影响的项。
getItem(int) - 类 java.awt.List 中的方法
获取与指定索引关联的项。
getItem(int) - 类 java.awt.Menu 中的方法
获取此菜单的指定索引处的项。
getItem() - 接口 javax.swing.ComboBoxEditor 中的方法
返回已编辑项。
getItem(int) - 类 javax.swing.JMenu 中的方法
返回指定位置的 JMenuItem。
getItem() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法

getItemAt(int) - 类 javax.swing.JComboBox 中的方法
返回指定索引处的列表项。
getItemCount() - 类 java.awt.Choice 中的方法
返回此 Choice 菜单中项的数量。
getItemCount() - 类 java.awt.List 中的方法
获取列表中的项数。
getItemCount() - 类 java.awt.Menu 中的方法
获取此菜单中的项数。
getItemCount() - 类 javax.swing.JComboBox 中的方法
返回列表中的项数。
getItemCount() - 类 javax.swing.JMenu 中的方法
返回菜单上的项数，包括分隔符。
getItemListeners() - 类 java.awt.Checkbox 中的方法
返回已在此复选框上注册的所有项侦听器所组成的数组。
getItemListeners() - 类 java.awt.CheckboxMenuItem 中的方法
返回在此复选框菜单项上注册的所有项侦听器组成的数组。
getItemListeners() - 类 java.awt.Choice 中的方法
返回已在此选择上注册的所有项侦听器组成的数组。
getItemListeners() - 类 java.awt.List 中的方法
返回已在此列表上注册的所有项侦听器的数组。
getItemListeners() - 类 javax.swing.AbstractButton 中的方法
返回使用 addItemListener() 添加到此 AbstractButton 中的所有 ItemListener 组成的数组。
getItemListeners() - 类 javax.swing.DefaultButtonModel 中的方法
返回此 DefaultButtonModel 上所有已注册的项侦听器组成的数组。
getItemListeners() - 类 javax.swing.JComboBox 中的方法
返回使用 addItemListener() 添加到此 JComboBox 中的所有 ItemListener 组成的数组。
getItems() - 类 java.awt.List 中的方法
获取列表中的项。
getItemSelectable() - 类 java.awt.event.ItemEvent 中的方法
返回事件的产生程序。
getIterationCount() - 接口 javax.crypto.interfaces.PBEKey 中的方法
返回迭代计数；如果未指定，则返回 0。
getIterationCount() - 类 javax.crypto.spec.PBEKeySpec 中的方法
返回迭代计数，如果未指定则返回 0。
getIterationCount() - 类 javax.crypto.spec.PBEParameterSpec 中的方法
返回迭代计数。
getIterator() - 类 java.text.AttributedString 中的方法
创建一个 AttributedCharacterIterator 实例，提供对整个字符串内容的访问。
getIterator(AttributedCharacterIterator.Attribute[]) - 类 java.text.AttributedString 中的方法
创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
getIterator(AttributedCharacterIterator.Attribute[], int, int) - 类 java.text.AttributedString 中的方法
创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
getIterator(HTML.Tag) - 类 javax.swing.text.html.HTMLDocument 中的方法
获取指定 HTML 标记的迭代器。
getIV() - 类 javax.crypto.Cipher 中的方法
返回新缓冲区中的初始化向量 (IV)。
getIV() - 类 javax.crypto.spec.IvParameterSpec 中的方法
返回初始化向量 (IV)。
getIV() - 类 javax.crypto.spec.RC2ParameterSpec 中的方法
返回 IV，如果此参数集没有包含 IV 则返回 null。
getIV() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
返回 IV，如果此参数集没有包含 IV 则返回 null。
getJarEntry() - 类 java.net.JarURLConnection 中的方法
返回此连接的 JAR 条目对象（如果有）。
getJarEntry(String) - 类 java.util.jar.JarFile 中的方法
返回给定条目名称的 JarEntry；如果未找到，则返回 null。
getJarFile() - 类 java.net.JarURLConnection 中的方法
返回此连接的 JAR 文件。
getJarFiles() - 类 javax.management.loading.MLetContent 中的方法
获取由 MLET 标记的 ARCHIVE 属性指定的 .jar 文件的列表。
getJarFileURL() - 类 java.net.JarURLConnection 中的方法
返回此连接的 Jar 文件的 URL。
getJavaEncoding(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
从 IANA 名称获取相应的 Java 编码名称。
getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - 接口 javax.tools.JavaFileManager 中的方法
获取输入的文件对象，它表示给定位置处指定类型的指定类。
getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - 类 javax.tools.ForwardingJavaFileManager 中的方法

getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - 接口 javax.tools.JavaFileManager 中的方法
获取输出的文件对象，它表示给定位置处指定类型的指定类。
getJavaFileObjects(File...) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取表示给定文件的文件对象。
getJavaFileObjects(String...) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取表示给定文件名称的文件对象。
getJavaFileObjectsFromFiles(Iterable<? extends File>) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取表示给定文件的文件对象。
getJavaFileObjectsFromStrings(Iterable<String>) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取表示给定文件名称的文件对象。
getJavaInitializationString() - 接口 java.beans.PropertyEditor 中的方法
返回一部分 Java 代码，可以使用这部分代码来设置某个属性，以匹配编辑器当前状态。
getJavaInitializationString() - 类 java.beans.PropertyEditorSupport 中的方法
生成 Java 代码来设置属性值时使用此方法。
getJAXBNode(XmlNode) - 类 javax.xml.bind.Binder 中的方法
获取与给定 XML 元素关联的 JAXB 对象。
getJDBCMajorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此驱动程序的主 JDBC 版本号。
getJDBCMinorVersion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此驱动程序的次 JDBC 版本号。
getJMenuBar() - 类 javax.swing.JApplet 中的方法
返回此 applet 上的菜单栏设置。
getJMenuBar() - 类 javax.swing.JDialog 中的方法
返回此对话框上设置的菜单栏。
getJMenuBar() - 类 javax.swing.JFrame 中的方法
返回此窗体上设置的菜单栏。
getJMenuBar() - 类 javax.swing.JInternalFrame 中的方法
返回此 JInternalFrame 的当前 JMenuBar；如果尚未设置菜单栏，则返回 null。
getJMenuBar() - 类 javax.swing.JRootPane 中的方法
返回窗格层的菜单栏。
getJobName() - 类 java.awt.print.PrinterJob 中的方法
获取要打印的文档名称。
getJoinType() - 接口 javax.sql.rowset.JoinRowSet 中的方法
返回一个 int 值，它描述控制此 JoinRowSet 实例的已设置 SQL JOIN 类型。
getJustificationInfo() - 类 java.awt.font.GraphicAttribute 中的方法
返回此 GraphicAttribute 的调整信息。
getJustifiedLayout(float) - 类 java.awt.font.TextLayout 中的方法
创建调整到指定宽度的此 TextLayout 的一个副本。
getKeepAlive() - 类 java.net.Socket 中的方法
测试是否启用 SO_KEEPALIVE。
getKeepAliveTime(TimeUnit) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回线程保持活动的时间，该时间就是超过核心池大小的线程可以在终止前保持空闲的时间值。
getKernel() - 类 java.awt.image.ConvolveOp 中的方法
返回 Kernel。
getKernelData(float[]) - 类 java.awt.image.Kernel 中的方法
以行优先顺序返回 kernel 数据。
getKey() - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式的原键代码。
getKey(String, char[]) - 类 java.security.KeyStore 中的方法
返回与给定别名关联的密钥，并用给定密码来恢复它。
getKey() - 类 java.util.AbstractMap.SimpleEntry 中的方法
返回对应于此项的键。
getKey() - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
返回对应于此项的键。
getKey() - 接口 java.util.Map.Entry 中的方法
返回与此项对应的键。
getKey() - 异常 java.util.MissingResourceException 中的方法
获得构造方法所传递的参数。
getKey() - 类 java.util.prefs.PreferenceChangeEvent 中的方法
返回已更改首选项的键。
getKey() - 类 javax.accessibility.AccessibleRelation 中的方法
返回此关系的键
getKey() - 类 javax.crypto.spec.DESedeKeySpec 中的方法
返回 DES-EDE 密钥。
getKey() - 类 javax.crypto.spec.DESKeySpec 中的方法
返回 DES 密钥内容。
getKey() - 接口 javax.xml.crypto.KeySelectorResult 中的方法
返回选定的密钥。
getKeyChar() - 类 java.awt.AWTKeyStroke 中的方法
返回此 AWTKeyStroke 的字符。
getKeyChar() - 类 java.awt.event.KeyEvent 中的方法
返回与此事件中的键关联的字符。
getKeyCode() - 类 java.awt.AWTKeyStroke 中的方法
返回此 AWTKeyStroke 的数字键代码。
getKeyCode() - 类 java.awt.event.KeyEvent 中的方法
返回与此事件中的键关联的整数 keyCode。
getKeyColumns() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回一个包含一个或多个列号的数组，这些列号指示了形成某个键的列，该键唯一地标识了此 CachedRowSet 对象中的某个行。
getKeyEventDispatchers() - 类 java.awt.KeyboardFocusManager 中的方法
作为 List 返回此 KeyboardFocusManager 的 KeyEventDispatcher 链。
getKeyEventPostProcessors() - 类 java.awt.KeyboardFocusManager 中的方法
作为 List 返回此 KeyboardFocusManager 的 KeyEventPostProcessor 链。
getKeyEventType() - 类 java.awt.AWTKeyStroke 中的方法
返回 KeyEvent 的类型，它对应于此 AWTKeyStroke。
getKeyId() - 接口 javax.xml.crypto.dsig.keyinfo.PGPData 中的方法
返回此 PGPData 的 PGP 公钥标识符，正如第 11.2 节的 RFC 2440 中所定义的。
getKeyInfo() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回此 XMLSignature 的密钥信息。
getKeyInfoFactory() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
返回创建 KeyInfo 对象的 KeyInfoFactory。
getKeyLength() - 类 javax.crypto.spec.PBEKeySpec 中的方法
返回要导出的密钥长度，如果未指定则返回 0。
getKeyListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.getKeyListener() 的实现。
getKeyListener() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
返回将添加到组合框的键侦听器或 null。
getKeyListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的按键侦听器的数组。
getKeyLocation() - 类 java.awt.event.KeyEvent 中的方法
返回产生此按键事件的键位置。
getKeyManagers() - 类 javax.net.ssl.KeyManagerFactory 中的方法
为每类密钥内容返回一个密钥管理器。
getKeymap() - 类 javax.swing.text.JTextComponent 中的方法
获取当前在此文本组件中活动的 keymap。
getKeymap(String) - 类 javax.swing.text.JTextComponent 中的静态方法
获取以前添加到文档中的已命名 keymap。
getKeymapName() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取默认情况下为此 UI 安装或用于此 UI 的 keymap 的名称。
getKeyModifiersText(int) - 类 java.awt.event.KeyEvent 中的静态方法
返回描述修改键的 String，如 "Shift" 或 "Ctrl+Shift"。
getKeyPacket() - 接口 javax.xml.crypto.dsig.keyinfo.PGPData 中的方法
返回此 PGPData 的 PGP 密钥材料包，正如第 5.5 节的 RFC 2440 中所定义的。
getKeyProperty(String) - 类 javax.management.ObjectName 中的方法
获得与键属性中某个键相关联的值。
getKeyPropertyList() - 类 javax.management.ObjectName 中的方法
以哈希表的形式返回键属性。
getKeyPropertyListString() - 类 javax.management.ObjectName 中的方法
返回创建时指定的键属性列表的字符串表示形式。
getKeys() - 类 java.util.ListResourceBundle 中的方法
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
getKeys() - 类 java.util.PropertyResourceBundle 中的方法
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
getKeys() - 类 java.util.ResourceBundle 中的方法
返回键的枚举。
getKeys() - 类 javax.swing.AbstractAction 中的方法
返回 Object 的数组，这些对象是一些已经为其设置此 AbstractAction 值的键，如果没有已经设置该值的键，则返回 null。
getKeySelectionManager() - 类 javax.swing.JComboBox 中的方法
返回列表的键选择管理器。
getKeySelector() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法

getKeySelector() - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回用于查找某个密钥的密钥选择器。
getKeySelectorResult() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
在对此 XMLSignature 进行签名或验证后，返回密钥选择器 KeySelector（如果已指定）的结果。
getKeysize() - 类 java.security.spec.RSAKeyGenParameterSpec 中的方法
返回密钥大小。
getKeySpec(Key, Class<T>) - 类 java.security.KeyFactory 中的方法
返回给定密钥对象的规范（密钥材料）。
getKeySpec(Cipher) - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
getKeySpec(Key) - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
getKeySpec(Key, String) - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
getKeySpec(Key, Provider) - 类 javax.crypto.EncryptedPrivateKeyInfo 中的方法
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
getKeySpec(SecretKey, Class) - 类 javax.crypto.SecretKeyFactory 中的方法
以请求的格式返回给定密钥对象的规范（密钥材料）。
getKeyStore() - 类 java.security.KeyStore.Builder 中的方法
返回此对象描述的 KeyStore。
getKeyStroke(char) - 类 javax.swing.KeyStroke 中的静态方法
返回 KeyStroke 的共享实例，前者表示指定字符的 KEY_TYPED 事件。
getKeyStroke(char, boolean) - 类 javax.swing.KeyStroke 中的静态方法
已过时。 使用 getKeyStroke(char)
getKeyStroke(Character, int) - 类 javax.swing.KeyStroke 中的静态方法
返回 KeyStroke 的一个共享实例，它表示指定 Character 对象和一组修饰符的 KEY_TYPED 事件。
getKeyStroke(int, int, boolean) - 类 javax.swing.KeyStroke 中的静态方法
在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例，指定该键在按下或释放时是否为已激活。
getKeyStroke(int, int) - 类 javax.swing.KeyStroke 中的静态方法
在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例。
getKeyStroke(String) - 类 javax.swing.KeyStroke 中的静态方法
分析字符串并返回 KeyStroke。
getKeyStrokeForEvent(KeyEvent) - 类 javax.swing.KeyStroke 中的静态方法
返回一个 KeyStroke，它表示生成给定 KeyEvent 的快捷键事件。
getKeyStrokesForAction(Action) - 接口 javax.swing.text.Keymap 中的方法
获取将导致给定操作的击键。
getKeyText(int) - 类 java.awt.event.KeyEvent 中的静态方法
返回描述 keyCode 的 String，如 "HOME"、"F1" 或 "A"。
getKeyType() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此长期密钥的密钥类型。
getKeyUsage() - 类 java.security.cert.X509Certificate 中的方法
获取一个表示 KeyUsage 扩展 (OID = 2.5.29.15) 的各个位的 boolean 数组。
getKeyUsage() - 类 java.security.cert.X509CertSelector 中的方法
返回 keyUsage 标准。
getKind() - 接口 javax.lang.model.element.Element 中的方法
返回此元素的类型。
getKind() - 接口 javax.lang.model.type.TypeMirror 中的方法
返回此类型的 kind。
getKind() - 接口 javax.tools.Diagnostic 中的方法
获取此诊断的类型，例如，错误或者警告。
getKind() - 类 javax.tools.ForwardingJavaFileObject 中的方法

getKind() - 接口 javax.tools.JavaFileObject 中的方法
获取此文件对象的种类。
getKind() - 类 javax.tools.SimpleJavaFileObject 中的方法

getL() - 类 javax.crypto.spec.DHParameterSpec 中的方法
返回以位为单位的随机指数的大小 l（私有值）。
getLabel() - 类 java.awt.Button 中的方法
获取此按钮的标签。
getLabel() - 类 java.awt.Checkbox 中的方法
获取此复选框的标签。
getLabel() - 类 java.awt.MenuItem 中的方法
获取此菜单项的标签。
getLabel() - 类 javax.swing.AbstractButton 中的方法
已过时。 - 由 getText 取代
getLabel() - 类 javax.swing.JPopupMenu 中的方法
返回弹出菜单的标签。
getLabel() - 类 javax.swing.text.html.Option 中的方法
获取与该选项相关的标签。
getLabelFor() - 类 javax.swing.JLabel 中的方法
获取要添加标签的组件。
getLabelTable() - 类 javax.swing.JSlider 中的方法
返回哪些标签在哪些值处绘制的字典。
getLanguage() - 类 java.util.Locale 中的方法
返回此语言环境的语言代码，可以是空字符串或小写的 ISO 639 代码。
getLanguageName() - 接口 javax.script.ScriptEngineFactory 中的方法
返回此 ScriptEngine 支持的脚本语言的名称。
getLanguageVersion() - 接口 javax.script.ScriptEngineFactory 中的方法
返回此 ScriptEngine 支持的脚本语言的版本。
getLargeDisplayIcon() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回此面板的大显示图标。
getLargestPoolSize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回曾经同时位于池中的最大线程数。
getLast() - 类 java.util.ArrayDeque 中的方法

getLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法

getLast() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列的最后一个元素。
getLast() - 类 java.util.LinkedList 中的方法
返回此列表的最后一个元素。
getLastAccessedTime() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话表示上一次被会话层应用访问的时间，该时间是自协调世界时 1970 年 1 月 1 日午夜起经过的毫秒数。
getLastChild() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的最后一个子节点；如果该节点没有子节点，则返回 null。
getLastChild() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的最后一个子节点。
getLastChild() - 接口 org.w3c.dom.Node 中的方法
此节点的最后一个节点。
getLastChildPath(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回到 parent 的最后一个子节点的路径。
getLastColumn() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回已更改的最后一列。
getLastColumn() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getLastComponent(Container) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
返回遍历循环中的最后一个 Component。
getLastComponent(Container) - 类 java.awt.FocusTraversalPolicy 中的方法
返回遍历循环中的最后一个 Component。
getLastComponent(Container) - 类 javax.swing.DefaultFocusManager 中的方法

getLastComponent(Container) - 类 javax.swing.LayoutFocusTraversalPolicy 中的方法
返回遍历循环中的最后一个 Component。
getLastComponent(Container) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
返回遍历循环中的最后一个 Component。
getLastCursor() - 类 javax.swing.JInternalFrame 中的方法
返回通过 setCursor 方法设置的最后一个 Cursor，它是不可调整大小的 Cursor。
getLastDividerLocation() - 类 javax.swing.JSplitPane 中的方法
返回分隔条所处的最后位置。
getLastDragLocation() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回 JSplitPane 的最后拖动位置。
getLastIndex() - 类 javax.swing.event.ListSelectionEvent 中的方法
返回最后一个选择状态可能已发生更改的行的索引。
getLastLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
查找并返回为此节点后代的最后一个叶节点，即此节点或其最后一个子节点的最后一个叶节点。
getLastModified() - 类 java.net.URLConnection 中的方法
返回 last-modified 头字段的值。
getLastModified() - 接口 javax.tools.FileObject 中的方法
获取最后一次修改此文件对象的时间。
getLastModified() - 类 javax.tools.ForwardingFileObject 中的方法

getLastModified() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现返回 0L。
getLastPathComponent() - 类 javax.swing.tree.TreePath 中的方法
返回此路径的最后一个组件。
getLastRow() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回已更改的最后一行。
getLastRow() - 类 javax.swing.event.TableModelEvent 中的方法
返回最后一个被更改的行。
getLastRow() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getLastSelectedPathComponent() - 类 javax.swing.JTree 中的方法
返回当前选择的第一个节点中的最后一个路径组件。
getLastVisibleIndex() - 类 javax.swing.JList 中的方法
返回当前可见的最大列表索引。
getLatency() - 接口 javax.sound.midi.Synthesizer 中的方法
获得此合成器导致的处理延迟，用微秒表示。
getLateReflectionDelay() - 类 javax.sound.sampled.ReverbType 中的方法
返回晚期反射延迟时间，以微秒为单位。
getLateReflectionIntensity() - 类 javax.sound.sampled.ReverbType 中的方法
返回晚期反射密度，以分贝为单位。
getLayer() - 类 javax.swing.JInternalFrame 中的方法
获得此组件 layer 属性的便捷方法。
getLayer(JComponent) - 类 javax.swing.JLayeredPane 中的静态方法
获得 JComponent 的 layer 属性，此方法不会产生与 setLayer() 类似的副作用（绘制、添加/移除等）。
getLayer(Component) - 类 javax.swing.JLayeredPane 中的方法
返回指定 Component 的 layer 属性。
getLayeredPane() - 类 javax.swing.JApplet 中的方法
返回此 applet 的 layeredPane 对象。
getLayeredPane() - 类 javax.swing.JDialog 中的方法
返回此对话框的 layeredPane 对象。
getLayeredPane() - 类 javax.swing.JFrame 中的方法
返回此窗体的 layeredPane 对象。
getLayeredPane() - 类 javax.swing.JInternalFrame 中的方法
返回此内部窗体的分层窗格。
getLayeredPane() - 类 javax.swing.JRootPane 中的方法
获取供根窗格使用的分层窗格。
getLayeredPane() - 类 javax.swing.JWindow 中的方法
返回此窗口的 layeredPane 对象。
getLayeredPane() - 接口 javax.swing.RootPaneContainer 中的方法
返回 layeredPane。
getLayeredPaneAbove(Component) - 类 javax.swing.JLayeredPane 中的静态方法
一个便捷方法，它返回包含指定组件的第一个 JLayeredPane。
getLayout() - 类 java.awt.Container 中的方法
获取此容器的布局管理器。
getLayout(int, int) - 类 java.awt.font.TextMeasurer 中的方法
返回给定字符范围上的 TextLayout。
getLayoutAlignmentX(Container) - 类 java.awt.BorderLayout 中的方法
返回沿 x 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 java.awt.CardLayout 中的方法
返回沿 x 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 java.awt.GridBagLayout 中的方法
返回沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 接口 java.awt.LayoutManager2 中的方法
返回沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.BoxLayout 中的方法
返回容器沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.GroupLayout 中的方法
返回沿 x 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法

getLayoutAlignmentX(Container) - 类 javax.swing.OverlayLayout 中的方法
返回容器沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回容器沿 X 轴的对齐方式。
getLayoutAlignmentX(Container) - 类 javax.swing.SpringLayout 中的方法
返回 0.5f（居中）。
getLayoutAlignmentY(Container) - 类 java.awt.BorderLayout 中的方法
返回沿 y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 java.awt.CardLayout 中的方法
返回沿 y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 java.awt.GridBagLayout 中的方法
返回沿 y 轴的对齐方式。
getLayoutAlignmentY(Container) - 接口 java.awt.LayoutManager2 中的方法
返回沿 Y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.BoxLayout 中的方法
返回容器沿 Y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.GroupLayout 中的方法
返回沿 y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法

getLayoutAlignmentY(Container) - 类 javax.swing.OverlayLayout 中的方法
返回容器沿 Y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回容器沿 Y 轴的对齐方式。
getLayoutAlignmentY(Container) - 类 javax.swing.SpringLayout 中的方法
返回 0.5f（居中）。
getLayoutComponent(Object) - 类 java.awt.BorderLayout 中的方法
获取使用给定约束添加的组件。
getLayoutComponent(Container, Object) - 类 java.awt.BorderLayout 中的方法
基于目标 Container 的组件方向，返回给定约束位置对应的组件。
getLayoutDimensions() - 类 java.awt.GridBagLayout 中的方法
确定布局网格的列宽度和行高度。
getLayoutFlags() - 类 java.awt.font.GlyphVector 中的方法
返回描述该 GlyphVector 全局状态的标志。
getLayoutInfo(Container, int) - 类 java.awt.GridBagLayout 中的方法
为当前受管子级的集合填充 GridBagLayoutInfo 的实例。
GetLayoutInfo(Container, int) - 类 java.awt.GridBagLayout 中的方法
此方法已过时，仅为提供向后兼容性；新代码应该调用 getLayoutInfo 来代替。
getLayoutOrientation() - 类 javax.swing.JList 中的方法
返回列表的布局方向属性：如果布局是单列单元，则返回 VERTICAL；如果布局是“报纸样式”并且内容按先垂直后水平排列， 则返回 VERTICAL_WRAP；如果布局是“报纸样式”并且内容按先水平后垂直排列，则返回 HORIZONTAL_WRAP。
getLayoutOrigin() - 类 java.awt.GridBagLayout 中的方法
在目标容器的图形坐标空间确定布局区域的原点。
getLayoutPath() - 类 java.awt.font.TextLayout 中的方法
返回 LayoutPath，如果布局路径是默认路径（x 映射到 advance，y 映射到 offset），则返回 null。
getLayoutQueue() - 类 javax.swing.text.AsyncBoxView 中的方法
获取用于布局处理的队列。
getLayoutStyle() - 类 javax.swing.GroupLayout 中的方法
返回 LayoutStyle，用于计算组件之间的首选间隙。
getLayoutStyle() - 类 javax.swing.LookAndFeel 中的方法
返回此外观的 LayoutStyle。
getLayoutStyle() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回一个 LayoutStyle，它实现 http://java.sun.com/products/jlf/ed2/book/HIG.Visual2.html 中指定的 Java 外观设计原则。
getLayoutView(int) - 类 javax.swing.text.ParagraphView 中的方法
返回给定 index 处的视图。
getLayoutViewCount() - 类 javax.swing.text.ParagraphView 中的方法
返回此视图负责的视图数。
getLayoutWeights() - 类 java.awt.GridBagLayout 中的方法
确定布局网格的行与列的权重。
getLeader() - 类 javax.swing.text.TabStop 中的方法
返回制表符的前导字符。
getLeading() - 类 java.awt.font.LineMetrics 中的方法
返回该文本的 leading。
getLeading() - 类 java.awt.font.TextLayout 中的方法
返回 TextLayout 的行距。
getLeading() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的标准行间距。
getLeadSelectionIndex() - 类 javax.swing.DefaultListSelectionModel 中的方法
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第二个索引参数。
getLeadSelectionIndex() - 类 javax.swing.JList 中的方法
返回前导选择索引。
getLeadSelectionIndex() - 接口 javax.swing.ListSelectionModel 中的方法
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第二个索引参数。
getLeadSelectionPath() - 类 javax.swing.JTree 中的方法
返回标识为前导的路径。
getLeadSelectionPath() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回添加的最后一条路径。
getLeadSelectionPath() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回添加的最后一个路径。
getLeadSelectionRow() - 类 javax.swing.JTree 中的方法
返回与前导路径对应的行索引。
getLeadSelectionRow() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回 lead selection 索引。
getLeadSelectionRow() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回前导选择索引。
getLeafCount() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回为此节点后代的叶节点总数。
getLeafIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回用于表示叶节点的图标。
getLeastMaximum(int) - 类 java.util.Calendar 中的方法
返回此 Calendar 实例给定日历字段的最低的最大值。
getLeastMaximum(int) - 类 java.util.GregorianCalendar 中的方法
返回此 GregorianCalendar 实例给定日历字段的最低的最大值。
getLeastSignificantBits() - 类 java.util.UUID 中的方法
返回此 UUID 的 128 位值中的最低有效 64 位。
getLeftChildIndent() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getLeftComponent() - 类 javax.swing.JSplitPane 中的方法
返回分隔条左边（或者上面）的组件。
getLeftIndent(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取左边缩进设置。
getLeftInset() - 类 javax.swing.text.AsyncBoxView 中的方法
获得视图四周左侧的空白部分。
getLeftInset() - 类 javax.swing.text.CompositeView 中的方法
获取左部 inset。
getLegalValues() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的合法值的不可修改的 Set（如果已指定），否则返回 null。
getLegalValues() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此参数的合法值的集合（如果存在），否则返回 null。
getLegalValues() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的合法参数值的不可修改的 Set（如果指定），否则返回 null。
getLength(Object) - 类 java.lang.reflect.Array 中的静态方法
以 int 形式返回指定数组对象的长度。
getLength() - 类 java.net.DatagramPacket 中的方法
返回将要发送或接收到的数据的长度。
getLength() - 类 java.text.Bidi 中的方法
返回该行中文本的长度。
getLength() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getLength() - 类 javax.imageio.stream.IIOByteBuffer 中的方法
返回 getData 返回的字节数组中感兴趣的数据长度。
getLength() - 类 javax.sound.midi.MidiMessage 中的方法
获得 MIDI 消息的总长度，以字节为单位。
getLength() - 接口 javax.swing.event.DocumentEvent 中的方法
返回更改的长度。
getLength() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
返回更改的长度。
getLength() - 类 javax.swing.text.AbstractDocument 中的方法
返回数据的长度。
getLength() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得长度。
getLength() - 接口 javax.swing.text.Document 中的方法
返回文档中当前内容的字符数。
getLength() - 接口 org.w3c.dom.CharacterData 中的方法
通过下面的 data 和 substringData 方法可使用的 16 位单元数。
getLength() - 接口 org.w3c.dom.DOMImplementationList 中的方法
列表中 DOMImplementation 的数目。
getLength() - 接口 org.w3c.dom.DOMStringList 中的方法
列表中 DOMString 的数目。
getLength() - 接口 org.w3c.dom.NamedNodeMap 中的方法
此映射中的节点数。
getLength() - 接口 org.w3c.dom.NameList 中的方法
列表中的对（名称和名称空间 URI）数。
getLength() - 接口 org.w3c.dom.NodeList 中的方法
列表中的节点数。
getLength() - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回此列表中属性的个数。
getLength() - 接口 org.xml.sax.Attributes 中的方法
返回此列表中的属性个数。
getLength() - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 返回列表中的属性个数。
getLength() - 类 org.xml.sax.helpers.AttributesImpl 中的方法
返回列表中的属性个数。
getLengths() - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的方法
返回 short 数组，该数组包含 Huffman 表每个长度的值数。
getLevel() - 类 java.util.logging.Handler 中的方法
获得用于指定该 Handler 所记录信息的日志级别。
getLevel() - 类 java.util.logging.Logger 中的方法
获取已为此 Logger 指定的日志级别（Level）。
getLevel() - 类 java.util.logging.LogRecord 中的方法
获取日志消息级别，例如 Level.SEVERE。
getLevel() - 接口 javax.sound.sampled.DataLine 中的方法
获得行的当前音量级别。
getLevel() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点上的级数 -- 从根到此节点的距离。
getLevelAt(int) - 类 java.text.Bidi 中的方法
返回偏移位置处的字符的解析层次。
getLexicalHandler() - 类 javax.xml.transform.sax.SAXResult 中的方法
获取输出的 SAX2 LexicalHandler。
getLibraryDirectory() - 类 javax.management.loading.MLet 中的方法
获取库加载器在将本机库加载到内存中之前用于存储这些本机库的当前目录。
getLibraryDirectory() - 接口 javax.management.loading.MLetMBean 中的方法
获取在将本机库加载到内存中之前库加载器用来存储这些本机库的当前目录。
getLibraryPath() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 库路径。
getLifetime() - 接口 org.ietf.jgss.GSSContext 中的方法
确定此上下文剩余的生存期是多长。
getLimit() - 类 javax.swing.undo.UndoManager 中的方法
返回此 UndoManager 保持的最大编辑数。
getLimits() - 类 java.text.ChoiceFormat 中的方法
获取传入构造方法的 limit。
getLine(Line.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得与指定 Line.Info 对象中的描述匹配的行。
getLine() - 类 javax.sound.sampled.LineEvent 中的方法
获得作为此事件的源的音频行。
getLine(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
getLineBreakIndex(int, float) - 类 java.awt.font.TextMeasurer 中的方法
返回不能置于文本行上的第一个字符，该文本行从 start 开始并可能测量到图形宽度的 maxAdvance。
getLineBuffer() - 类 javax.swing.text.PlainView 中的方法
提供对可用于从相关文档获取文本的缓冲区的访问。
getLineBuffer() - 类 javax.swing.text.WrappedPlainView 中的方法
提供对能用于从关联文档获取文本的缓冲区的访问。
getLineClass() - 类 javax.sound.sampled.Line.Info 中的方法
获得此 Line.Info 对象所描述的行的类。
getLineColor() - 类 javax.swing.border.LineBorder 中的方法
返回边框的颜色。
getLineCount() - 类 javax.swing.JTextArea 中的方法
确定文本区中所包含的行数。
getLineEndOffset(int) - 类 javax.swing.JTextArea 中的方法
确定给定行结尾处的偏移量。
getLineIncrement() - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 getUnitIncrement() 取代。
getLineInfo() - 接口 javax.sound.sampled.Line 中的方法
获得描述此行的 Line.Info 对象。
getLineInstance() - 类 java.text.BreakIterator 中的静态方法
返回一个用于默认语言环境 行分解的新 BreakIterator 实例。
getLineInstance(Locale) - 类 java.text.BreakIterator 中的静态方法
返回一个用于给定语言环境行分解的新 BreakIterator 实例。
getLineInstance(Locale) - 类 java.text.spi.BreakIteratorProvider 中的方法
为给定语言环境的行分解返回新的 BreakIterator 实例。
getLineJoin() - 类 java.awt.BasicStroke 中的方法
返回线条连接样式。
getLineLength() - 类 javax.swing.text.AbstractWriter 中的方法
返回最大行长度。
getLineMetrics(String, FontRenderContext) - 类 java.awt.Font 中的方法
返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。
getLineMetrics(String, int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回使用指定参数创建的 LineMetrics 对象。
getLineMetrics(char[], int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回使用指定参数创建的 LineMetrics 对象。
getLineMetrics(CharacterIterator, int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回使用指定参数创建的 LineMetrics 对象。
getLineMetrics(String, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
getLineMetrics(String, int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
getLineMetrics(char[], int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定字符数组的 LineMetrics 对象。
getLineMetrics(CharacterIterator, int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
getLineNumber() - 类 java.io.LineNumberInputStream 中的方法
已过时。 返回当前行号。
getLineNumber() - 类 java.io.LineNumberReader 中的方法
获得当前行号。
getLineNumber() - 类 java.lang.StackTraceElement 中的方法
返回源行的行号，该行包含由该堆栈该跟踪元素所表示的执行点。
getLineNumber() - 异常 javax.script.ScriptException 中的方法
获取发生错误的行号。
getLineNumber() - 接口 javax.tools.Diagnostic 中的方法
返回由 Diagnostic.getPosition() 返回的字符偏移量的行号。
getLineNumber() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getLineNumber() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回行号（如果可用）。
getLineNumber() - 接口 javax.xml.stream.Location 中的方法
返回当前事件结束位置的行号，如果没有可用的行号，则返回 -1。
getLineNumber() - 接口 javax.xml.transform.SourceLocator 中的方法
返回当前文档事件结束位置的行数。
getLineNumber() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的行号；如果没有可用的行号，则为 -1。
getLineNumber() - 类 org.xml.sax.helpers.LocatorImpl 中的方法
返回保存的行数（从 1 开始）。
getLineNumber() - 接口 org.xml.sax.Locator 中的方法
返回当前文档事件结束处的行号。
getLineNumber() - 异常 org.xml.sax.SAXParseException 中的方法
发生异常的文本结尾的行号。
getLineOfOffset(int) - 类 javax.swing.JTextArea 中的方法
将组件文本中的偏移量转换为行号。
getLineSeparator() - 类 javax.swing.text.AbstractWriter 中的方法
返回用于表示换行的 String。
getLineSpacing(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取行间距设置。
getLineStartOffset(int) - 类 javax.swing.JTextArea 中的方法
确定给定行起始处的偏移量。
getLineWidth() - 类 java.awt.BasicStroke 中的方法
返回线条的宽度。
getLineWrap() - 类 javax.swing.JTextArea 中的方法
获取文本区的换行策略。
getLink(int) - 接口 javax.accessibility.AccessibleHypertext 中的方法
返回此 Hypertext 文档中第 n 个链接。
getLink(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 中的方法
返回超链接数组中该索引处的链接。
getLinkCount() - 接口 javax.accessibility.AccessibleHypertext 中的方法
返回此超文本文档中的链接数。
getLinkCount() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 中的方法
返回此超文本文档中的链接数。
getLinkCursor() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
返回要在超链接上使用的光标。
getLinkedException() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法

getLinkedException() - 异常 javax.xml.bind.JAXBException 中的方法
获取链接的异常。
getLinkedException() - 异常 javax.xml.bind.TypeConstraintException 中的方法
获取链接的异常。
getLinkedException() - 接口 javax.xml.bind.ValidationEvent 中的方法
检索此警告/错误的链接异常。
getLinkExplanation() - 异常 javax.naming.LinkException 中的方法
检索与解析某一链接时遇到的问题关联的解释。
getLinkIndex(int) - 接口 javax.accessibility.AccessibleHypertext 中的方法
返回超链接数组中与此字符索引关联的索引；如果没有与此索引关联的超链接，则返回 -1。
getLinkIndex(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 中的方法
返回超链接数组中与此字符索引关联的超链接索引；如果没有与此索引关联的超链接，则返回 -1。
getLinkName() - 类 javax.naming.LinkRef 中的方法
检索此链接的名称。
getLinkRemainingName() - 异常 javax.naming.LinkException 中的方法
检索链接名称的剩余未解析部分。
getLinkResolvedName() - 异常 javax.naming.LinkException 中的方法
检索成功被解析的链接名称的开头部分。
getLinkResolvedObj() - 异常 javax.naming.LinkException 中的方法
检索已成功解析成的对象。
getLinkText(int) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 中的方法
返回文档中与此超链接关联的连续文本。
getList() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.getList() 的实现。
getList() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
返回要用于在组合框中绘制项的列表。
getList() - 类 javax.swing.SpinnerListModel 中的方法
返回定义此模型的序列的 List。
getListCellRendererComponent(JList, Object, int, boolean, boolean) - 类 javax.swing.DefaultListCellRenderer 中的方法

getListCellRendererComponent(JList, Object, int, boolean, boolean) - 接口 javax.swing.ListCellRenderer 中的方法
返回已配置用于显示指定值的组件。
getListCellRendererComponent(JList, Object, int, boolean, boolean) - 类 javax.swing.plaf.basic.BasicComboBoxRenderer 中的方法

getListCellRendererComponent(JList, Object, int, boolean, boolean) - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer 中的方法

getListDataListeners() - 类 javax.swing.AbstractListModel 中的方法
返回已在此 AbstractListModel 上注册的所有列表数据侦听器组成的数组。
getListener() - 类 java.util.EventListenerProxy 中的方法

getListener() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getListener() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法

getListener() - 接口 javax.xml.bind.Marshaller 中的方法
返回向此 Marshaller 注册的 Marshaller.Listener。
getListener() - 接口 javax.xml.bind.Unmarshaller 中的方法
返回向此 Unmarshaller 注册的 Unmarshaller.Listener。
getListenerCount() - 类 javax.swing.event.EventListenerList 中的方法
返回此侦听器列表中侦听器的总数。
getListenerCount(Class<?>) - 类 javax.swing.event.EventListenerList 中的方法
返回此侦听器列表中所提供类型的侦听器的总数。
getListenerID() - 类 javax.management.remote.TargetedNotification 中的方法
此通知所定向的侦听器的 ID。
getListenerList() - 类 javax.swing.event.EventListenerList 中的方法
将事件侦听器列表以 ListenerType 侦听器对数组的形式传回。
getListenerMethodDescriptors() - 类 java.beans.EventSetDescriptor 中的方法
获得目标侦听器接口的 MethodDescriptor。
getListenerMethodName() - 类 java.beans.EventHandler 中的方法
返回将触发动作的属性名称。
getListenerMethods() - 类 java.beans.EventSetDescriptor 中的方法
获得目标侦听器接口的方法。
getListeners(EventListener, Class<T>) - 类 java.awt.AWTEventMulticaster 中的静态方法
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.Button 中的方法
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.Checkbox 中的方法
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.CheckboxMenuItem 中的方法
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.Choice 中的方法
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.Component 中的方法
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.Container 中的方法
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.dnd.DragSource 中的方法
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。
getListeners(Class<T>) - 类 java.awt.List 中的方法
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.MenuItem 中的方法
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.Scrollbar 中的方法
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 java.awt.TextComponent 中的方法
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.TextField 中的方法
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 java.awt.Window 中的方法
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
getListeners(Class<T>) - 类 javax.swing.AbstractListModel 中的方法
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.AbstractSpinnerModel 中的方法
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
getListeners(Class<T>) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.DefaultButtonModel 中的方法
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.DefaultListSelectionModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.DefaultSingleSelectionModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.event.EventListenerList 中的方法
返回给定类型的所有侦听器组成的数组。
getListeners(Class<T>) - 类 javax.swing.JComponent 中的方法
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。
getListeners(Class<T>) - 类 javax.swing.table.AbstractTableModel 中的方法
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。
getListeners(Class<T>) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.text.AbstractDocument 中的方法
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.text.DefaultCaret 中的方法
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
getListeners(Class<T>) - 类 javax.swing.Timer 中的方法
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
getListeners(Class<T>) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListeners(Class<T>) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
getListenerType() - 类 java.beans.EventSetDescriptor 中的方法
获得目标接口的 Class 对象。
getListPainter(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
获取给定 CSS 属性集合使用的列表 formatter。
getListSelectionListeners() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回已在此 DefaultListSelectionModel 上注册的所有列表选择侦听器组成的数组。
getListSelectionListeners() - 类 javax.swing.JList 中的方法
返回通过 addListSelectionListener 添加到此 JList 中的所有 ListSelectionListener 所组成的数组。
getLoadedClassCount() - 接口 java.lang.management.ClassLoadingMXBean 中的方法
返回当前加载到 Java 虚拟机中的类的数量。
getLoadedInstruments() - 接口 javax.sound.midi.Synthesizer 中的方法
获得当前加载到此 Synthesizer 中的乐器列表。
getLoadingImageIcon() - 类 javax.swing.text.html.ImageView 中的方法
返回加载图像过程中要使用的图标。
getLoadsSynchronously() - 类 javax.swing.text.html.ImageView 中的方法
如果图像应该在首次被请求时加载，则返回 true。
getLocalAddress() - 类 java.net.DatagramSocket 中的方法
获取套接字绑定的本地地址。
getLocalAddress() - 类 java.net.Socket 中的方法
获取套接字绑定的本地地址。
getLocalBounds(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回组件 aComponent 的矩形 (0,0,bounds.width,bounds.height)。
getLocalCertificateChain() - 类 java.net.SecureCacheResponse 中的方法
返回在获得了网络资源的初始连接的联络期间发送到服务器的证书链。
getLocalCertificates() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回握手期间发送到同位体的证书。
getLocalCertificates() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回握手期间发送给服务器的证书。
getLocalCertificates() - 接口 javax.net.ssl.SSLSession 中的方法
返回握手期间发送给同位体的证书。
getLocale() - 类 java.applet.Applet 中的方法
获取 applet 的语言环境。
getLocale() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回此对象的区域。
getLocale() - 类 java.awt.Component 中的方法
获取组件的语言环境。
getLocale() - 类 java.awt.im.InputContext 中的方法
返回当前输入方法或键盘布局的当前语言环境。
getLocale() - 接口 java.awt.im.spi.InputMethod 中的方法
返回当前的输入语言环境。
getLocale() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取组件的区域设置。
getLocale() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回此对象的区域。
getLocale() - 类 java.awt.Window 中的方法
如果设置了区域，则获取与此窗口关联的 Locale 对象。
getLocale() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得此 BeanContext 的语言环境。
getLocale() - 类 java.text.MessageFormat 中的方法
获取创建或比较子格式时所使用的语言环境。
getLocale() - 类 java.util.ResourceBundle 中的方法
返回此资源包的语言环境。
getLocale() - 类 javax.accessibility.AccessibleContext 中的方法
获取该组件的语言环境。
getLocale() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回当前语言环境；如果没有有效的语言环境，则返回 null。
getLocale() - 类 javax.imageio.ImageReader 中的方法
返回当前设置的 Locale，如果没有设置 Locale，则返回 null。
getLocale() - 类 javax.imageio.ImageWriteParam 中的方法
返回当前设置的 Locale，如果仅支持默认 Locale，则返回 null。
getLocale() - 类 javax.imageio.ImageWriter 中的方法
返回当前设置的 Locale，如果没有设置 Locale，则返回 null。
getLocale() - 类 javax.print.attribute.TextSyntax 中的方法
返回此文本属性的文本字符串的自然语言（语言环境）。
getLocale() - 类 javax.security.auth.callback.LanguageCallback 中的方法
获取检索到的 Locale。
getLocale() - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
返回此对象的区域。
getLocale() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getLocale() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取该组件的语言环境。
getLocale() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
获取组件的区域。
getLocale() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
获取该组件的语言环境。
getLocale() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getLocalGraphicsEnvironment() - 类 java.awt.GraphicsEnvironment 中的静态方法
返回本地 GraphicsEnvironment。
getLocalHost() - 类 java.net.InetAddress 中的静态方法
返回本地主机。
getLocalizedCompressionTypeName() - 类 javax.imageio.ImageWriteParam 中的方法
返回当前压缩类型的本地化名称，使用 getLocale 返回的 Locale。
getLocalizedInputStream(InputStream) - 类 java.lang.Runtime 中的方法
已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
getLocalizedMessage() - 类 java.lang.Throwable 中的方法
创建此 throwable 的本地化描述。
getLocalizedName() - 类 java.util.logging.Level 中的方法
返回当前默认语言环境的 Level 的本地化字符串名称。
getLocalizedOutputStream(OutputStream) - 类 java.lang.Runtime 中的方法
已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。
getLocalName() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 getNodeName。
getLocalName() - 接口 javax.xml.soap.Name 中的方法
获取此 Name 对象表示的 XML 名称的本地名称部分。
getLocalName() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getLocalName() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回当前事件的（本地）名称。
getLocalName() - 接口 org.w3c.dom.Node 中的方法
返回此节点限定名称的本地部分。
getLocalName(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的本地名称。
getLocalName(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
返回属性的本地名称。
getLocalPart() - 类 javax.xml.namespace.QName 中的方法
获取此 QName 的本地部分。
getLocalPatternChars() - 类 java.text.DateFormatSymbols 中的方法
获取本地化的日期-时间模式字符。
getLocalPort() - 类 java.net.DatagramSocket 中的方法
返回此套接字绑定的本地主机上的端口号。
getLocalPort() - 类 java.net.DatagramSocketImpl 中的方法
获取本地端口。
getLocalPort() - 类 java.net.ServerSocket 中的方法
返回此套接字在其上侦听的端口。
getLocalPort() - 类 java.net.Socket 中的方法
返回此套接字绑定到的本地端口。
getLocalPort() - 类 java.net.SocketImpl 中的方法
返回此套接字的 localport 字段的值。
getLocalPrincipal() - 类 java.net.SecureCacheResponse 中的方法
返回在获得了网络资源的初始连接中的联络期间发送到服务器的主体。
getLocalPrincipal() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回握手期间发送到同位体的主体。
getLocalPrincipal() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回握手期间发送到服务器的主体。
getLocalPrincipal() - 接口 javax.net.ssl.SSLSession 中的方法
返回握手期间发送给同位体的主体。
getLocalSocketAddress() - 类 java.net.DatagramSocket 中的方法
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
getLocalSocketAddress() - 类 java.net.ServerSocket 中的方法
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
getLocalSocketAddress() - 类 java.net.Socket 中的方法
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
getLocation() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
通过用一个点指定该对象的左上角在屏幕坐标空间中的位置的形式，获取此对象相对于父对象的位置。
getLocation() - 类 java.awt.Component 中的方法
获取组件的位置，形式是指定组件左上角的一个点。
getLocation(Point) - 类 java.awt.Component 中的方法
将组件的 x，y 原点存储到“返回值” rv 中并返回 rv。
getLocation() - 类 java.awt.dnd.DragSourceEvent 中的方法
此方法返回一个 Point，指示事件发生时光标在屏幕坐标中的位置，如果没有为此事件指定光标位置，则返回 null。
getLocation() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回一个指示 Component 坐标中 Cursor 当前位置的 Point。
getLocation() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回一个 Point，指示 Component 坐标中 Cursor 的当前位置。
getLocation() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
获取此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
getLocation() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
getLocation() - 类 java.awt.Point 中的方法
返回此点的位置。
getLocation() - 类 java.awt.PointerInfo 中的方法
返回在屏幕上表示指针坐标的 Point。
getLocation() - 类 java.awt.Rectangle 中的方法
返回此 Rectangle 的位置。
getLocation() - 异常 java.net.HttpRetryException 中的方法
如果重定向产生错误，则返回 Location 头字段的值。
getLocation() - 类 java.rmi.activation.ActivationDesc 中的方法
返回此描述符指定的对象的代码基。
getLocation() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的代码基。
getLocation() - 类 java.security.CodeSource 中的方法
返回与此 CodeSource 关联的位置。
getLocation() - 接口 javax.accessibility.AccessibleComponent 中的方法
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
getLocation(Point) - 类 javax.swing.JComponent 中的方法
将此组件的 x，y 原点存储到“返回值”rv 中并返回 rv。
getLocation() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getLocation() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
getLocation() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getLocation() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getLocation(JavaFileManager.Location) - 接口 javax.tools.StandardJavaFileManager 中的方法
获取与给定位置关联的路径。
getLocation() - 接口 javax.xml.stream.events.XMLEvent 中的方法
返回此事件的位置。
getLocation() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getLocation() - 异常 javax.xml.stream.XMLStreamException 中的方法
获取异常的位置
getLocation() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回处理器的当前位置。
getLocation() - 接口 org.w3c.dom.DOMError 中的方法
错误的位置。
getLocationAsString() - 异常 javax.xml.transform.TransformerException 中的方法
获取字符串形式的位置信息。
getLocationInJTree() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getLocationOffset(int, int) - 接口 java.awt.im.InputMethodRequests 中的方法
获取撰写文本相对于屏幕上指定 x 和 y 绝对坐标的偏移量。
getLocationOnScreen() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 类 java.awt.Component 中的方法
获取组件的位置，形式是一个指定屏幕坐标空间中组件左上角的一个点。
getLocationOnScreen() - 类 java.awt.event.MouseEvent 中的方法
返回事件的绝对 x, y 坐标。
getLocationOnScreen() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 接口 javax.accessibility.AccessibleComponent 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getLocationOnScreen() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
返回对象在屏幕上的位置。
getLocationOnScreen() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getLocationOnScreen() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getLocator() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法

getLocator() - 接口 javax.xml.bind.ValidationEvent 中的方法
检索此警告/错误的定位符。
getLocator() - 异常 javax.xml.transform.TransformerException 中的方法
getLocator 方法检索 SourceLocator 对象的实例，此对象指定了错误发生的位置。
getLockedMonitors() - 类 java.lang.management.ThreadInfo 中的方法
返回 MonitorInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的对象监视器。
getLockedStackDepth() - 类 java.lang.management.MonitorInfo 中的方法
返回锁定对象监视器的堆栈跟踪中的深度。
getLockedStackFrame() - 类 java.lang.management.MonitorInfo 中的方法
返回锁定对象监视器的堆栈帧。
getLockedSynchronizers() - 类 java.lang.management.ThreadInfo 中的方法
返回 LockInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的可拥有同步器。
getLockInfo() - 类 java.lang.management.ThreadInfo 中的方法
返回对象的 LockInfo，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
getLockingKeyState(int) - 类 java.awt.Toolkit 中的方法
返回键盘上给定锁定键是否处于 "on" 状态。
getLockName() - 类 java.lang.management.ThreadInfo 中的方法
返回对象的字符串表示形式，与此 ThreadInfo 关联的线程被锁定并等待该对象。
getLockOwnerId() - 类 java.lang.management.ThreadInfo 中的方法
返回拥有对象的线程的 ID，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
getLockOwnerName() - 类 java.lang.management.ThreadInfo 中的方法
返回拥有对象的线程的名称，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
getLog() - 类 java.rmi.server.RemoteServer 中的静态方法
返回用于 RMI 调用日志的流。
getLogger(String) - 类 java.util.logging.Logger 中的静态方法
为指定子系统查找或创建一个 logger。
getLogger(String, String) - 类 java.util.logging.Logger 中的静态方法
为指定子系统查找或创建一个 logger。
getLogger(String) - 类 java.util.logging.LogManager 中的方法
查找指定 logger 的方法。
getLogger() - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
返回应用程序的日志对象，以获取 SyncProvider 实现发送的同步事件。
getLoggerLevel(String) - 接口 java.util.logging.LoggingMXBean 中的方法
获取与指定 logger 相关的日志级别名称。
getLoggerName() - 类 java.util.logging.LogRecord 中的方法
获取源 Logger 名称
getLoggerNames() - 接口 java.util.logging.LoggingMXBean 中的方法
返回当前已注册的 logger 列表。
getLoggerNames() - 类 java.util.logging.LogManager 中的方法
获取已知 logger 名称的枚举。
getLoggingMXBean() - 类 java.util.logging.LogManager 中的静态方法
返回管理 logger 的 LoggingMXBean。
getLogicalBounds() - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 的逻辑边界。
getLogicalHighlightShape(int, int, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回封闭指定范围中扩展到指定 bounds 的逻辑选择范围的 Shape。
getLogicalHighlightShape(int, int) - 类 java.awt.font.TextLayout 中的方法
返回封装指定范围中逻辑选择范围的 Shape，它扩展到此 TextLayout 的自然边界。
getLogicalRangesForVisualSelection(TextHitInfo, TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回对应于可视选择范围的逻辑文本范围。
getLogicalStyle() - 类 javax.swing.JTextPane 中的方法
获取分配给由当前插入符号位置表示的段落的逻辑样式，或者 null。
getLogicalStyle(int) - 类 javax.swing.text.DefaultStyledDocument 中的方法
获取表示给定位置处分配给段落的逻辑样式。
getLogicalStyle(int) - 接口 javax.swing.text.StyledDocument 中的方法
获取段落中给定位置的逻辑样式。
getLogicalView(FlowView) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
此方法提供访问 FlowView 的逻辑视图的流策略。
getLoginModuleName() - 类 javax.security.auth.login.AppConfigurationEntry 中的方法
获取所配置的 LoginModule 的类名称。
getLoginTimeout() - 类 java.sql.DriverManager 中的静态方法
获取驱动程序试图登录到某一数据库时可以等待的最长时间，以秒为单位。
getLoginTimeout() - 接口 javax.sql.CommonDataSource 中的方法
获取此数据源试图连接到某一数据库时可以等待的最长时间，以秒为单位。
getLogManager() - 类 java.util.logging.LogManager 中的静态方法
返回全局 LogManager 对象。
getLogStream() - 类 java.sql.DriverManager 中的静态方法
已过时。
getLogTimers() - 类 javax.swing.Timer 中的静态方法
如果启用了日志记录，则返回 true。
getLogWriter() - 类 java.sql.DriverManager 中的静态方法
获取日志 writer。
getLogWriter() - 接口 javax.sql.CommonDataSource 中的方法
获取此 DataSource 对象的日志 writer。
getLong(String) - 类 java.lang.Long 中的静态方法
确定具有指定名称的系统属性的 long 值。
getLong(String, long) - 类 java.lang.Long 中的静态方法
使用指定名称确定系统属性的 long 值。
getLong(String, Long) - 类 java.lang.Long 中的静态方法
使用指定名称返回系统属性的 long 值。
getLong(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 long 形式返回指定数组对象中索引组件的值。
getLong(Object) - 类 java.lang.reflect.Field 中的方法
获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。
getLong() - 类 java.nio.ByteBuffer 中的方法
用于读取 long 值的相对 get 方法。
getLong(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 long 值的绝对 get 方法。
getLong(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 long 值的形式获取指定的 JDBC BIGINT 参数的值。
getLong(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 long 值的形式获取 JDBC BIGINT 参数的值。
getLong(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
getLong(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
getLong(String, long) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.getLong(String,long) 中的规范实现 getLong 方法。
getLong(String, long) - 类 java.util.prefs.Preferences 中的方法
返回与此首选项节点中指定的键相关联的、由字符串表示的 long 值。
getLongFramePosition() - 接口 javax.sound.sampled.DataLine 中的方法
获得音频数据中的当前位置（以样本帧为单位）。
getLongParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 long 返回参数的便捷方法。
getLookAndFeel() - 类 javax.swing.UIManager 中的静态方法
返回当前外观或 null。
getLookAndFeelDefaults() - 类 javax.swing.UIManager 中的静态方法
从当前外观返回 UIDefaults，UIDefaults 在安装该外观时获得。
getLoopbackMode() - 类 java.net.MulticastSocket 中的方法
获取多播数据报的本地回送的设置。
getLoopCount() - 接口 javax.sound.midi.Sequencer 中的方法
获得回放的重复次数。
getLoopEndPoint() - 接口 javax.sound.midi.Sequencer 中的方法
获得循环的结束位置，以 MIDI 节拍为单位。
getLoopStartPoint() - 接口 javax.sound.midi.Sequencer 中的方法
获得循环的起始位置，以 MIDI 节拍为单位。
getLowerBound() - 接口 javax.lang.model.type.TypeVariable 中的方法
返回此类型变量的下边界。
getLowerBounds() - 接口 java.lang.reflect.WildcardType 中的方法
返回表示此类型变量下边界的 Type 对象的数组。
getLoweredBevelBorderUIResource() - 类 javax.swing.plaf.BorderUIResource 中的静态方法

getLowestSetBit() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 最右端（最低位）1 比特的索引（即从此字节的右端开始到本字节中最右端 1 比特之间的 0 比特的位数）。
getLowestValue() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回在标签表中有一个项的最小值。
getLowestValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回与标签表中的最高滑块值相对应的标签。
getLowThreshold() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有观察到的 MBean 的公共低阈值。
getLowThreshold() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取低阈值。
getLSB() - 类 java.awt.font.GlyphMetrics 中的方法
返回该字形的左（上）跨距。
getM() - 类 java.security.spec.ECFieldF2m 中的方法
返回此首数为 2 的有限字段的值 m。
getMacLength() - 类 javax.crypto.Mac 中的方法
返回 MAC 的长度，以字节为单位。
getMagicCaretPosition() - 接口 javax.swing.text.Caret 中的方法
获取当前插入符可见位置。
getMagicCaretPosition() - 类 javax.swing.text.DefaultCaret 中的方法
获取保存的插入符位置。
getMainAttributes() - 类 java.net.JarURLConnection 中的方法
返回此连接的 JAR 文件的主要 Attribute。
getMainAttributes() - 类 java.util.jar.Manifest 中的方法
返回 Manifest 的主 Attributes。
getMajor() - 异常 org.ietf.jgss.GSSException 中的方法
返回导致抛出此异常的问题的 GSS-API 级主要错误代码。
getMajorAxis() - 类 javax.swing.text.AsyncBoxView 中的方法
获取主轴（即子级平铺时沿用的轴）。
getMajorOffset() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
沿主轴的偏移量是什么。
getMajorSpan() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
沿主轴的跨距是什么。
getMajorString() - 异常 org.ietf.jgss.GSSException 中的方法
返回一个字符串，解释在此异常中 GSS-API 级的主要错误代码。
getMajorTickSpacing() - 类 javax.swing.JSlider 中的方法
此方法返回主刻度标记的间隔。
getMajorVersion() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件的主版本号。
getMajorVersion() - 接口 java.sql.Driver 中的方法
获取此驱动程序的主版本号。
getManagementSpecVersion() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回正在运行的 Java 虚拟机实现的管理接口的规范版本。
getManifest() - 类 java.net.JarURLConnection 中的方法
返回此连接的 Manifest；如果没有，则返回 null。
getManifest() - 类 java.util.jar.JarFile 中的方法
返回 jar 文件清单；如果没有，则返回 null。
getManifest() - 类 java.util.jar.JarInputStream 中的方法
返回此 JAR 文件的 Manifest；如果没有，则返回 null。
getMapSize() - 类 java.awt.image.IndexColorModel 中的方法
返回此 IndexColorModel 中颜色/alpha 分量数组的大小。
getMargin() - 类 javax.swing.AbstractButton 中的方法
返回按钮边框和标签之间的空白。
getMargin() - 类 javax.swing.JMenuBar 中的方法
返回菜单栏的边框与其菜单之间的空白。
getMargin() - 类 javax.swing.JPopupMenu 中的方法
返回弹出菜单的边框与其包含内容之间的空白（以像素表示）。
getMargin() - 类 javax.swing.JToolBar 中的方法
返回工具栏边框和它的按钮之间的空白。
getMargin() - 类 javax.swing.text.JTextComponent 中的方法
返回文本组件的边框和它的文本之间的空白。
getMark() - 类 javax.swing.event.CaretEvent 中的方法
获得逻辑选择的另一端的位置。
getMark() - 接口 javax.swing.text.Caret 中的方法
获取标记的当前位置。
getMark() - 类 javax.swing.text.DefaultCaret 中的方法
获取标记的当前位置。
getMarkBias() - 类 javax.swing.text.DefaultCaret 中的方法
返回标记的偏差。
getMask(int) - 类 java.awt.image.PackedColorModel 中的方法
返回指示像素中哪些位包含指定颜色/alpha 采样的掩码。
getMask() - 类 javax.swing.text.MaskFormatter 中的方法
返回格式化掩码。
getMasks() - 类 java.awt.image.PackedColorModel 中的方法
返回指示像素中的哪些位包含颜色和 alpha 采样的掩码数组。
getMasterSyncMode() - 接口 javax.sound.midi.Sequencer 中的方法
获得此 sequencer 的当前主同步模式。
getMasterSyncModes() - 接口 javax.sound.midi.Sequencer 中的方法
获得此 sequencer 支持的主同步模式集。
getMatchAllSubjectAltNames() - 类 java.security.cert.X509CertSelector 中的方法
指示 X509Certificate 是否必须包含 setSubjectAlternativeNames 或 addSubjectAlternativeName 方法中所指定的所有或至少某个 subjectAlternativeNames。
getMatchColumnIndexes() - 接口 javax.sql.rowset.Joinable 中的方法
获取使用方法 setMatchColumn(int[] columnIdxes) 为此 RowSet 对象设置的匹配列的索引。
getMatchColumnNames() - 接口 javax.sql.rowset.Joinable 中的方法
获取使用方法 setMatchColumn(String [] columnNames) 为此 RowSet 对象设置的匹配列的名称。
getMatchingHeaders(String[]) - 类 javax.xml.soap.MimeHeaders 中的方法
返回其名称与给定名称数组中的任一名称匹配的所有 MimeHeader 对象。
getMatchingMimeHeaders(String[]) - 类 javax.xml.soap.AttachmentPart 中的方法
检索匹配给定数组中名称的所有 MimeHeader 对象。
getMatchingMimeHeaders(String[]) - 类 javax.xml.soap.SOAPPart 中的方法
检索与给定数组中的名称匹配的所有 MimeHeader 对象。
getMatchingRuleID() - 类 javax.naming.ldap.SortKey 中的方法
检索用于排序属性值的匹配规则 ID。
getMatrix() - 类 java.awt.color.ICC_ProfileRGB 中的方法
返回一个由配置文件的 redColorantTag、greenColorantTag 和 blueColorantTag 的 X、Y 和 Z 分量构造的 3x3 float 矩阵。
getMatrix(double[]) - 类 java.awt.geom.AffineTransform 中的方法
在 3x3 仿射变换矩阵中检索 6 个可指定值，并将其置于双精度值的数组中。
getMatrix() - 类 java.awt.image.BandCombineOp 中的方法
返回线性组合矩阵的一个副本。
getMatrix() - 类 java.awt.print.PageFormat 中的方法
返回一个变换矩阵，该矩阵将呈现的用户空间向请求的方向平移。
getMatteColor() - 类 javax.swing.border.MatteBorder 中的方法
返回平铺边框的颜色，如果使用了平铺图标，则返回 null。
getMax() - 类 java.lang.management.MemoryUsage 中的方法
返回可以用于内存管理的最大内存量（以字节为单位）。
getMaxAdvance() - 类 java.awt.FontMetrics 中的方法
获取此 Font 中所有字符的最大 advance width。
getMaxAge() - 类 java.net.HttpCookie 中的方法
返回以秒为单位指定的 cookie 最大生存时间。
getMaxAllowedKeyLength(String) - 类 javax.crypto.Cipher 中的静态方法
根据所安装的 JCE 仲裁策略文件，返回指定转换的最大密钥长度。
getMaxAllowedParameterSpec(String) - 类 javax.crypto.Cipher 中的静态方法
根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。
getMaxAscent() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的最大 ascent。
getMaxBinaryLiteralLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在内嵌二进制字面值中使用的最大十六进制字符数。
getMaxBufferSize() - 类 javax.sound.sampled.DataLine.Info 中的方法
获得数据行支持的最大缓冲区大小。
getMaxCatalogNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于类别名称的最大字符数。
getMaxCharactersPerLineCount() - 类 javax.swing.JOptionPane 中的方法
返回要置于消息的行中的最大字符数。
getMaxCharactersPerLineCount() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回要置于行中的最大字符数。
getMaxCharBounds(FontRenderContext) - 类 java.awt.Font 中的方法
返回最大边界定义在 FontRenderContext 中的字符的边界。
getMaxCharBounds(Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中具有最大边界的字符的边界。
getMaxCharLiteralLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于字符字面值的最大字符数。
getMaxColumnNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于列名称的最大字符数。
getMaxColumnsInGroupBy() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 GROUP BY 子句中使用的最大列数。
getMaxColumnsInIndex() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在索引中使用的最大列数。
getMaxColumnsInOrderBy() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 ORDER BY 子句中使用的最大列数。
getMaxColumnsInSelect() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 SELECT 列表中使用的最大列数。
getMaxColumnsInTable() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在表中使用的最大列数。
getMaxConnections() - 接口 java.sql.DatabaseMetaData 中的方法
获取连接到此数据库的并发连接的可能最大数。
getMaxCRL() - 类 java.security.cert.X509CRLSelector 中的方法
返回 maxCRLNumber 标准。
getMaxCursorNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于游标名称的最大字符数。
getMaxDecent() - 类 java.awt.FontMetrics 中的方法
已过时。 从 JDK version 1.1.1 开始，由 getMaxDescent() 取代。
getMaxDegree() - 类 javax.management.relation.RoleInfo 中的方法
返回相应角色引用的最大程度。
getMaxDescent() - 类 java.awt.FontMetrics 中的方法
确定此 FontMetrics 对象所描述的 Font 的最大 descent。
getMaxExpansion(int) - 类 java.text.CollationElementIterator 中的方法
返回以指定比较顺序结束的所有扩展序列的最大长度。
getMaxFieldSize() - 接口 java.sql.Statement 中的方法
获取可以为此 Statement 对象所生成 ResultSet 对象中的字符和二进制列值返回的最大字节数。
getMaxFieldSize() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取可用于此 RowSet 对象列值的最大字节数。
getMaxFieldSize() - 接口 javax.sql.RowSet 中的方法
获取可以对某些列值返回的最大字节数。
getMaximizedBounds() - 类 java.awt.Frame 中的方法
获取此窗体的最大化边界。
getMaximum() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的最大值。
getMaximum() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的最大值。
getMaximum() - 类 java.awt.ScrollPaneAdjustable 中的方法

getMaximum(int) - 类 java.util.Calendar 中的方法
返回此 Calendar 实例给定日历字段的最大值。
getMaximum(int) - 类 java.util.GregorianCalendar 中的方法
返回此 GregorianCalendar 实例的给定日历字段的最大值。
getMaximum() - 类 javax.sound.sampled.FloatControl 中的方法
获得所允许的最大值。
getMaximum() - 接口 javax.swing.BoundedRangeModel 中的方法
返回模型的 maximum。
getMaximum() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回模型的 maximum。
getMaximum() - 类 javax.swing.JProgressBar 中的方法
从 BoundedRangeModel 返回进度条的 maximum 值。
getMaximum() - 类 javax.swing.JScrollBar 中的方法
滚动条的最大值为最大跨度。
getMaximum() - 类 javax.swing.JSlider 中的方法
从 BoundedRangeModel 返回滑块所支持的最大值。
getMaximum() - 类 javax.swing.ProgressMonitor 中的方法
返回最大值 - 进度值的较高端。
getMaximum() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列中的最后一个数字。
getMaximum() - 类 javax.swing.text.InternationalFormatter 中的方法
返回最大允许值。
getMaximumAccessibleValue() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的最大值，它是一个 Number。
getMaximumAccessibleValue() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的最大值，它是一个 Number。
getMaximumAccessibleValue() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取此对象的最大值，它是一个 Number。
getMaximumAccessibleValue() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
以数字形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的最大可访问值。
getMaximumAccessibleValue() - 接口 javax.accessibility.AccessibleValue 中的方法
以 Number 形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
以 Number 形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
以 Number 形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
以 Number 形式获取此对象的最大值。
getMaximumAccessibleValue() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的最大可访问值。
getMaximumAccessibleValue() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的最大可访问值。
getMaximumAccessibleValue() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的最大可访问值。
getMaximumAccessibleValue() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取此对象数字形式的最大值。
getMaximumAccessibleValue() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的最大可访问值。
getMaximumCharHeight(SynthContext) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
根据传入的 SynthContext 返回 Font 的最大高度。
getMaximumCursorColors() - 类 java.awt.Toolkit 中的方法
返回自定义光标调色板中 Toolkit 支持的最大颜色数。
getMaximumDividerLocation() - 类 javax.swing.JSplitPane 中的方法
返回外观实现中分隔条的最大位置。
getMaximumDividerLocation(JSplitPane) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
获取分隔符的最大位置。
getMaximumDividerLocation(JSplitPane) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumDividerLocation 方法。
getMaximumDividerLocation(JSplitPane) - 类 javax.swing.plaf.SplitPaneUI 中的方法
返回分隔符的最大可能位置。
getMaximumFractionDigits() - 类 java.text.DecimalFormat 中的方法
获取某个数的小数部分中所允许的最大数字位数。
getMaximumFractionDigits() - 类 java.text.NumberFormat 中的方法
返回数的小数部分所允许的最大位数。
getMaximumIntegerDigits() - 类 java.text.DecimalFormat 中的方法
获取某个数的整数部分中所允许的最大数字位数。
getMaximumIntegerDigits() - 类 java.text.NumberFormat 中的方法
返回数的整数部分所允许的最大位数。
getMaximumPoolSize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回允许的最大线程数。
getMaximumRowCount() - 类 javax.swing.JComboBox 中的方法
返回组合框不使用滚动条可以显示的最大项数
getMaximumSize() - 类 java.awt.Component 中的方法
获取组件的最大大小。
getMaximumSize() - 类 java.awt.Container 中的方法
返回此容器的最大大小。
getMaximumSize() - 类 javax.swing.JComponent 中的方法
如果已将最大大小设置为一个非 null 值，则返回该值。
getMaximumSize() - 类 javax.swing.JScrollBar 中的方法
滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
getMaximumSize() - 类 javax.swing.JToolBar.Separator 中的方法
返回分隔符的最小大小。
getMaximumSize() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回 BasicArrowButton 的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
不能调整桌面图标的大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回传入组件的最大大小，该大小将传递给当前布局管理器。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回标题的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回表的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取编辑器组件的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回此组件的最大大小，如果实例当前位于 JTree 中或 0, 0 处，则该大小将为首选大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回指定组件的适合外观的最大大小。
getMaximumSize(JComponent) - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
返回 JFileChooser 的最大大小。
getMaximumSize() - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法

getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
getMaximumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
返回正确呈现图标和文本所需的最大大小。
getMaximumSpan(int) - 类 javax.swing.text.AsyncBoxView 中的方法
确定此视图沿某轴的最大跨距。
getMaximumSpan(int) - 类 javax.swing.text.BoxView 中的方法
确定此视图沿某个轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.ComponentView 中的方法
确定此视图沿某轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.html.BlockView 中的方法
确定此视图沿某轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.html.FormView 中的方法
确定此视图沿某轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.html.ParagraphView 中的方法
确定此视图沿某轴的最大区域。
getMaximumSpan(int) - 类 javax.swing.text.View 中的方法
确定此视图沿某个轴的最大跨距。
getMaximumSpan(int) - 类 javax.swing.text.WrappedPlainView 中的方法
确定此视图沿某个轴的最大跨距。
getMaximumStreamFormatVersion() - 接口 javax.rmi.CORBA.ValueHandlerMultiFormat 中的方法
返回由此 ValueHandler 对象支持的 RMI/IDL 自定义值类型的最大流格式版本。
getMaximumThumbSize() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
返回 thumb 的最大可接受大小。
getMaximumValue() - 类 javax.swing.Spring 中的方法
返回此 Spring 的 maximum 值。
getMaximumWindowBounds() - 类 java.awt.GraphicsEnvironment 中的方法
返回居中 Windows 的最大边界。
getMaximumZoneSize() - 类 javax.swing.text.ZoneView 中的方法
获取当前最大的分区大小。
getMaxIndexLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于索引（包括索引的所有部分）的最大字节数。
getMaxLabel() - 类 javax.sound.sampled.FloatControl 中的方法
获得最大值的标签，如 "Right" 或 "Full"。
getMaxLines(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
获得可以在此混频器上同时打开的所请求类型的行的最大近似数。
getMaxPage() - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户可以指定为要打印的最后一页的最大值。
getMaxPathLength() - 类 java.security.cert.PKIXBuilderParameters 中的方法
返回证书路径中可能存在的中间非自发布证书的最大数目值。
getMaxPolyphony() - 接口 javax.sound.midi.Synthesizer 中的方法
获得此合成器可同时发声的最大音符数。
getMaxPriority() - 类 java.lang.ThreadGroup 中的方法
返回此线程组的最高优先级。
getMaxProcedureNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许用于过程名称的最大字符数。
getMaxReceivers() - 接口 javax.sound.midi.MidiDevice 中的方法
获得该 MIDI 设备上用于接收 MIDI 数据的最大可用 MIDI IN 连接数。
getMaxRows() - 接口 java.sql.Statement 中的方法
获取由此 Statement 对象生成的 ResultSet 对象可以包含的最大行数。
getMaxRows() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取此 RowSet 对象可以包含的最大行数。
getMaxRows() - 接口 javax.sql.RowSet 中的方法
获取此 RowSet 对象可以包含的最大行数。
getMaxRowSize() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在单行中使用的最大字节数。
getMaxSchemaNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在模式名称中使用的最大字符数。
getMaxSelectionIndex() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回最后选择的索引，如果选择为空，则返回 -1。
getMaxSelectionIndex() - 类 javax.swing.JList 中的方法
返回选择的最大单元索引；如果选择为空，则返回 -1。
getMaxSelectionIndex() - 接口 javax.swing.ListSelectionModel 中的方法
返回最后选择的索引，如果选择为空，则返回 -1。
getMaxSelectionRow() - 类 javax.swing.JTree 中的方法
返回选择的最后一行。
getMaxSelectionRow() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回从 RowMapper 获取的已选择的 TreePath 的当前集合中的最大值。
getMaxSelectionRow() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回从 RowMapper 获取的已选的 TreePath 当前集合中的最大值。
getMaxSortKeys() - 类 javax.swing.DefaultRowSorter 中的方法
返回排序键的最大数量。
getMaxStatementLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 SQL 语句中使用的最大字符数。
getMaxStatements() - 接口 java.sql.DatabaseMetaData 中的方法
获取在此数据库中在同一时间内可处于开放状态的最大活动语句数。
getMaxTableNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在表名称中使用的最大字符数。
getMaxTablesInSelect() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在 SELECT 语句中使用的表的最大数量。
getMaxTransmitters() - 接口 javax.sound.midi.MidiDevice 中的方法
获得该 MIDI 设备用于传输 MIDI 数据的最大可用 MIDI OUT 连接数。
getMaxUserNameLength() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库允许在用户名称中使用的最大字符数。
getMaxValue(int) - 类 java.awt.color.ColorSpace 中的方法
返回指定分量的最大标准化颜色分量值。
getMaxValue(int) - 类 java.awt.color.ICC_ColorSpace 中的方法
返回指定分量的最大标准化颜色分量值。
getMaxValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最大值（如果已指定），否则返回 null。
getMaxValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此参数的最大值（如果存在），否则返回 null。
getMaxValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最大值（如果指定），否则返回 null。
getMaxWidth() - 类 javax.swing.table.TableColumn 中的方法
返回 TableColumn 的最大宽度。
getMaxX() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 窗体矩形的最大 X 坐标。
getMaxY() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 窗体矩形的最大 Y 坐标。
getMaxZonesLoaded() - 类 javax.swing.text.ZoneView 中的方法
获取当前设置的允许同时加载的分区数。
getMBeanCount() - 接口 javax.management.MBeanServer 中的方法
返回 MBean 服务器中已注册的 MBean 的数目。
getMBeanCount() - 接口 javax.management.MBeanServerConnection 中的方法
返回 MBean 服务器中已注册的 MBean 数目。
getMBeanCount(Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getMBeanCount() 方法。
getMBeanCount(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getMBeanCount(Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getMBeanDescriptor() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回包含 MBean 级策略的 ModelMBean 的描述符。
getMBeanDescriptor() - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getMBeanInfo() - 接口 javax.management.DynamicMBean 中的方法
使用 MBeanInfo 对象提供该 Dynamic MBean 已公开的属性和操作。
getMBeanInfo(ObjectName) - 接口 javax.management.MBeanServer 中的方法

getMBeanInfo(ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
此方法发现了 MBean 为管理而公开的属性和操作。
getMBeanInfo() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回此 RequiredModelMBean 公开的属性、操作、构造方法和通知是为了便于管理。
getMBeanInfo(ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
getMBeanInfo(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getMBeanInfo(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getMBeanInfo() - 类 javax.management.StandardMBean 中的方法
获取此 MBean 的 MBeanInfo。
getMBeanInterface() - 类 javax.management.StandardMBean 中的方法
获取此 Standard MBean（或 MXBean）的管理接口。
getMBeanName() - 类 javax.management.MBeanServerNotification 中的方法
返回导致该通知的 MBean 的对象名。
getMBeanServer() - 类 javax.management.QueryEval 中的静态方法
返回此线程最近一次提供给 setMBeanServer 方法的 MBean 服务器。
getMBeanServer() - 类 javax.management.remote.JMXConnectorServer 中的方法
返回该连接器服务器连接到的 MBean 服务器。
getMBeanServer() - 接口 javax.management.remote.MBeanServerForwarder 中的方法
返回请求将转发到其上的 MBeanServer 对象。
getMBeanServer() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
此连接器服务器所连接的 MBeanServer。
getMBeanServerConnection() - 类 javax.management.MBeanServerInvocationHandler 中的方法
MBean 服务器连接，使用此处理程序的代理的方法是通过此连接转发的。
getMBeanServerConnection() - 接口 javax.management.remote.JMXConnector 中的方法
返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。
getMBeanServerConnection(Subject) - 接口 javax.management.remote.JMXConnector 中的方法
返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。
getMBeanServerConnection() - 类 javax.management.remote.rmi.RMIConnector 中的方法

getMBeanServerConnection(Subject) - 类 javax.management.remote.rmi.RMIConnector 中的方法

getMBeanServerId() - 类 javax.management.MBeanServerDelegate 中的方法
返回 MBean 服务器代理标识。
getMBeanServerId() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回 MBean 服务器代理标识。
getMBeansFromURL(URL) - 类 javax.management.loading.MLet 中的方法
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
getMBeansFromURL(String) - 类 javax.management.loading.MLet 中的方法
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
getMBeansFromURL(String) - 接口 javax.management.loading.MLetMBean 中的方法
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
getMBeansFromURL(URL) - 接口 javax.management.loading.MLetMBean 中的方法
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
getMBeansToUnregister() - 类 javax.management.relation.RelationNotification 中的方法
返回因为关系移除而需要注销的 MBean 的 ObjectName 列表（仅限于关系移除）。
getMech() - 接口 org.ietf.jgss.GSSContext 中的方法
确定什么机制正用于此上下文。
getMechanismName() - 接口 javax.security.sasl.SaslClient 中的方法
返回此 SASL 客户端的 IANA 注册机制名。
getMechanismName() - 接口 javax.security.sasl.SaslServer 中的方法
返回此 SASL 服务器的 IANA 注册机制名。
getMechanismNames(Map<String, ?>) - 接口 javax.security.sasl.SaslClientFactory 中的方法
返回与指定的机制选择策略相符的机制的名称数组。
getMechanismNames(Map<String, ?>) - 接口 javax.security.sasl.SaslServerFactory 中的方法
返回与指定的机制选择策略相符的机制的名称数组。
getMechanismType() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
返回此 KeyInfoFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。
getMechanismType() - 类 javax.xml.crypto.dsig.TransformService 中的方法
返回此 TransformService 支持的机制类型。
getMechanismType() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
返回此 XMLSignatureFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。
getMechs() - 接口 org.ietf.jgss.GSSCredential 中的方法
返回受此凭据支持的机制的列表。
getMechs() - 类 org.ietf.jgss.GSSManager 中的方法
返回一个可通过此 GSSManager 提供给 GSS-API 调用者的机制列表。
getMechsForName(Oid) - 类 org.ietf.jgss.GSSManager 中的方法
返回支持指定的名称类型的机制的列表。
getMedia() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面的纸张尺寸。
getMediaSizeForName(MediaSizeName) - 类 javax.print.attribute.standard.MediaSize 中的静态方法
获取指定的命名介质的 MediaSize。
getMediaSizeName() - 类 javax.print.attribute.standard.MediaSize 中的方法
获取此尺寸的介质名称（如果有）。
getMediaSubtype() - 类 javax.print.DocFlavor 中的方法
返回此 DocFlavor 对象的媒体子类型（根据 MIME 类型）。
getMediaType() - 类 javax.print.DocFlavor 中的方法
返回此 DocFlavor 对象的媒体类型（根据 MIME 类型）。
getMediaWhitePoint() - 类 java.awt.color.ICC_ProfileGray 中的方法
返回一个长度为 3 的 float 数组，在其 ICC 配置文件中包含 mediaWhitePointTag 的 X、Y 和 Z 分量。
getMediaWhitePoint() - 类 java.awt.color.ICC_ProfileRGB 中的方法
返回包含配置文件的 mediaWhitePointTag 分量的数组。
getMemberControls() - 类 javax.sound.sampled.CompoundControl 中的方法
返回组成组合控件的成员控件集合。
getMembers() - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
获取规范数组形式的此整数集属性的成员。
getMemoryManagerMXBeans() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机中的 MemoryManagerMXBean 对象列表。
getMemoryManagerNames() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回管理此内存池的内存管理器的名称。
getMemoryMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的内存系统的管理 Bean。
getMemoryPoolMXBeans() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机中的 MemoryPoolMXBean 对象列表。
getMemoryPoolNames() - 接口 java.lang.management.MemoryManagerMXBean 中的方法
返回此内存管理器管理的内存池名称。
getMenu(int) - 类 java.awt.MenuBar 中的方法
获取指定的菜单。
getMenu(int) - 类 javax.swing.JMenuBar 中的方法
返回菜单栏中指定位置的菜单。
getMenuArrowIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getMenuArrowIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getMenuBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单背景颜色。
getMenuBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单背景色。
getMenuBar() - 类 java.awt.Frame 中的方法
获取此窗体的菜单栏。
getMenuBar() - 类 javax.swing.JInternalFrame 中的方法
已过时。 从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。
getMenuBar() - 类 javax.swing.JRootPane 中的方法
已过时。 从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。
getMenuBarBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getMenuComponent(int) - 类 javax.swing.JMenu 中的方法
返回位于位置 n 的组件。
getMenuComponentCount() - 类 javax.swing.JMenu 中的方法
返回菜单上的组件数。
getMenuComponents() - 类 javax.swing.JMenu 中的方法
返回菜单子组件的 Component 数组。
getMenuCount() - 类 java.awt.MenuBar 中的方法
获取该菜单栏上的菜单数。
getMenuCount() - 类 javax.swing.JMenuBar 中的方法
返回菜单栏上的菜单数。
getMenuDisabledForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单禁用前景颜色。
getMenuDisabledForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单禁用前景色。
getMenuDisabledForeground() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回菜单禁用前景色。
getMenuDragMouseListeners() - 类 javax.swing.JMenuItem 中的方法
返回利用 addMenuDragMouseListener() 添加到此 JMenuItem 的所有 MenuDragMouseListener 组成的数组。
getMenuForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单前景颜色。
getMenuForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单前景色。
getMenuItemArrowIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getMenuItemArrowIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getMenuItemCheckIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getMenuItemCheckIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法
返回一个将由 JCheckBoxMenuItem 使用的图标。
getMenuKeyListeners() - 类 javax.swing.JMenuItem 中的方法
返回利用 addMenuKeyListener() 添加到此 JMenuItem 的所有 MenuKeyListener 的数组。
getMenuKeyListeners() - 类 javax.swing.JPopupMenu 中的方法
返回利用 addMenuKeyListener() 添加到此 JPopupMenu 的所有 MenuKeyListener 组成的数组。
getMenuListeners() - 类 javax.swing.JMenu 中的方法
返回利用 addMenuListener() 添加到此 JMenu 的所有 MenuListener 组成的数组。
getMenuSelectedBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单选中背景颜色。
getMenuSelectedBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单选中背景色。
getMenuSelectedForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单选中前景颜色。
getMenuSelectedForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单选中前景色。
getMenuSelectionManager() - 类 javax.swing.event.MenuDragMouseEvent 中的方法
返回当前菜单选项管理器。
getMenuSelectionManager() - 类 javax.swing.event.MenuKeyEvent 中的方法
返回当前菜单选项管理器。
getMenuShortcutKeyMask() - 类 java.awt.Toolkit 中的方法
确定哪一个修改键是菜单快捷方式的适当加速键。
getMenuTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回菜单文本字体。
getMenuTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的菜单文本字体。
getMenuTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回菜单文本字体。
getMessage() - 异常 java.awt.HeadlessException 中的方法

getMessage() - 异常 java.io.InvalidClassException 中的方法
生成消息并包括类名称（如果存在）。
getMessage() - 异常 java.io.WriteAbortedException 中的方法
生成此消息并包括嵌入异常的消息（如果有）。
getMessage() - 类 java.lang.Throwable 中的方法
返回此 throwable 的详细消息字符串。
getMessage() - 异常 java.net.URISyntaxException 中的方法
返回描述解析错误的字符串。
getMessage() - 异常 java.nio.charset.MalformedInputException 中的方法

getMessage() - 异常 java.nio.charset.UnmappableCharacterException 中的方法

getMessage() - 异常 java.rmi.activation.ActivationException 中的方法
返回包含来自此异常的原因（如果有）的消息的详细消息。
getMessage() - 异常 java.rmi.RemoteException 中的方法
返回此异常的详细消息，包括来自原因（如果有）方面的消息。
getMessage() - 异常 java.rmi.server.ServerCloneException 中的方法
返回此异常的详细信息，包括原因的消息（如果有）。
getMessage() - 异常 java.util.DuplicateFormatFlagsException 中的方法

getMessage() - 异常 java.util.FormatFlagsConversionMismatchException 中的方法

getMessage() - 异常 java.util.IllegalFormatCodePointException 中的方法

getMessage() - 异常 java.util.IllegalFormatConversionException 中的方法

getMessage() - 异常 java.util.IllegalFormatFlagsException 中的方法

getMessage() - 异常 java.util.IllegalFormatPrecisionException 中的方法

getMessage() - 异常 java.util.IllegalFormatWidthException 中的方法

getMessage() - 类 java.util.logging.LogRecord 中的方法
获取本地化或格式化之前的“原始”日志消息。
getMessage() - 异常 java.util.MissingFormatArgumentException 中的方法

getMessage() - 异常 java.util.MissingFormatWidthException 中的方法

getMessage() - 异常 java.util.regex.PatternSyntaxException 中的方法
返回多行字符串，包含语法错误及其索引的描述、错误的正则表达式模式和模式中错误索引的可视化指示。
getMessage() - 异常 java.util.UnknownFormatConversionException 中的方法

getMessage() - 异常 java.util.UnknownFormatFlagsException 中的方法

getMessage() - 接口 javax.annotation.processing.Completion 中的方法
返回包含许多有关 completion 信息的消息。
getMessage() - 类 javax.management.Notification 中的方法
获得通知消息。
getMessage() - 异常 javax.script.ScriptException 中的方法
返回一条消息，该消息包含传递给构造方法的 String，以及行号、列号和文件名（如果它们已知）。
getMessage() - 类 javax.security.auth.callback.TextOutputCallback 中的方法
获取将要显示的消息。
getMessage() - 类 javax.sound.midi.MidiEvent 中的方法
获得事件中包含的 MIDI 消息。
getMessage() - 类 javax.sound.midi.MidiMessage 中的方法
获得 MIDI 消息数据。
getMessage() - 类 javax.swing.JOptionPane 中的方法
返回此窗格显示的消息对象。
getMessage() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回从接收者为其提供外观的 JOptionPane 显示的消息。
getMessage(Locale) - 接口 javax.tools.Diagnostic 中的方法
获取给定语言环境的本地化消息。
getMessage() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法

getMessage() - 接口 javax.xml.bind.ValidationEvent 中的方法
检索此警告/错误的文本消息。
getMessage() - 错误 javax.xml.parsers.FactoryConfigurationError 中的方法
返回此错误的消息（如果有）。
getMessage() - 异常 javax.xml.soap.SOAPException 中的方法
返回此 SOAPException 对象的详细消息。
getMessage() - 错误 javax.xml.stream.FactoryConfigurationError 中的方法
报告与此错误关联的消息。
getMessage() - 错误 javax.xml.transform.TransformerFactoryConfigurationError 中的方法
返回针对此错误的消息（如果有）。
getMessage() - 接口 javax.xml.ws.handler.LogicalMessageContext 中的方法
从此消息上下文中获得消息。
getMessage() - 接口 javax.xml.ws.handler.soap.SOAPMessageContext 中的方法
从此消息上下文中获取 SOAPMessage。
getMessage() - 异常 org.ietf.jgss.GSSException 中的方法
返回主要和次要状态码的文本表示形式。
getMessage() - 接口 org.w3c.dom.DOMError 中的方法
描述所发生错误的特定于实现的字符串。
getMessage() - 异常 org.xml.sax.SAXException 中的方法
返回此异常的详细消息。
getMessageAndLocation() - 异常 javax.xml.transform.TransformerException 中的方法
获取带有追加的位置信息的错误消息。
getMessageContext() - 接口 javax.xml.ws.WebServiceContext 中的方法
调用此方法时，返回正在服务的请求的 MessageContext。
getMessageDigest() - 类 java.security.DigestInputStream 中的方法
返回与此流关联的消息摘要。
getMessageDigest() - 类 java.security.DigestOutputStream 中的方法
返回与此流关联的消息摘要。
getMessageFactory() - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
获取此 SOAP 绑定使用的 SAAJ MessageFactory 实例。
getMessager() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回用来报告错误、警报和其他通知的 Messager。
getMessageType() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取消息类型。
getMessageType() - 类 javax.security.auth.callback.TextOutputCallback 中的方法
获取消息类型。
getMessageType() - 类 javax.swing.JOptionPane 中的方法
返回消息类型。
getMetaData() - 接口 java.sql.Connection 中的方法
获取一个 DatabaseMetaData 对象，该对象包含关于此 Connection 对象所连接的数据库的元数据。
getMetaData() - 接口 java.sql.PreparedStatement 中的方法
获取包含有关 ResultSet 对象列信息的 ResultSetMetaData 对象，ResultSet 对象将在执行此 PreparedStatement 对象时返回。
getMetaData() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的列的编号、类型和属性。
getMetadata() - 类 javax.imageio.IIOImage 中的方法
返回对当前 IIOMetadata 对象的引用，如果没有设置任何这样的对象，则返回 null。
getMetadata() - 类 javax.xml.ws.Endpoint 中的方法
返回服务的元数据文档列表。
getMetadataFormat(String) - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回描述给定元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
getMetadataFormatNames() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回一个 String 数组，包含包括此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的所有元数据格式（包括本机格式和标准格式）的名称。
getMetaKey() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于指示在触发事件期间是否按下 'meta' 键。
getMethod() - 类 java.beans.MethodDescriptor 中的方法
获得此 MethodDescriptor 封装的方法。
getMethod(String, Class<?>...) - 类 java.lang.Class 中的方法
返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
getMethod() - 类 java.util.zip.ZipEntry 中的方法
返回条目的压缩方法；如果未指定，则返回 -1。
getMethod() - 类 javax.swing.text.html.FormSubmitEvent 中的方法
获取表单方法类型。
getMethodCallSyntax(String, String, String...) - 接口 javax.script.ScriptEngineFactory 中的方法
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。
getMethodDescriptors() - 接口 java.beans.BeanInfo 中的方法
获得 beans MethodDescriptor。
getMethodDescriptors() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝方法的信息。
getMethodName() - 类 java.beans.Statement 中的方法
返回方法名称。
getMethodName() - 类 java.lang.StackTraceElement 中的方法
返回方法名，此方法包含由该堆栈跟踪元素所表示的执行点。
getMethods() - 类 java.lang.Class 中的方法
返回一个包含某些 Method 对象的数组，这些对象反映此 Class 对象所表示的类或接口（包括那些由该类或接口声明的以及从超类和超接口继承的那些的类或接口）的公共 member 方法。
getMGFAlgorithm() - 类 java.security.spec.PSSParameterSpec 中的方法
返回掩码生成函数算法名称。
getMGFAlgorithm() - 类 javax.crypto.spec.OAEPParameterSpec 中的方法
返回掩码生成函数算法名称。
getMGFParameters() - 类 java.security.spec.PSSParameterSpec 中的方法
返回掩码生成函数的参数。
getMGFParameters() - 类 javax.crypto.spec.OAEPParameterSpec 中的方法
返回掩码生成函数的参数。
getMIC(byte[], int, int, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
返回包含所提供消息的加密消息完整性代码 (MIC) 的标记，以便传输到同位体应用程序。
getMIC(InputStream, OutputStream, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
getMicrosecondLength() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件的长度，用微秒表示。
getMicrosecondLength() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 的持续时间，用微秒表示。
getMicrosecondLength() - 接口 javax.sound.midi.Sequencer 中的方法
获得当前 sequence 的长度，用微秒表示，如果未设置 sequence，则为 0。
getMicrosecondLength() - 接口 javax.sound.sampled.Clip 中的方法
获得介质持续时间（以微秒为单位）
getMicrosecondPosition() - 接口 javax.sound.midi.MidiDevice 中的方法
获得设备的当前时间戳，以微秒为单位。
getMicrosecondPosition() - 接口 javax.sound.midi.Sequencer 中的方法
获得 sequence 中的当前位置，用微秒表示。
getMicrosecondPosition() - 接口 javax.sound.sampled.DataLine 中的方法
获得音频数据中的当前位置（以微秒为单位）。
getMidiDevice(MidiDevice.Info) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得请求的 MIDI 设备。
getMidiDeviceInfo() - 类 javax.sound.midi.MidiSystem 中的静态方法
获得信息对象数组，表示系统中可用的所有 MIDI 设备集。
getMidiFileFormat(InputStream) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得指定的输入流中数据的 MIDI 文件格式。
getMidiFileFormat(URL) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得指定 URL 中数据的 MIDI 文件格式。
getMidiFileFormat(File) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得指定 File 的 MIDI 文件格式。
getMidiFileFormat(InputStream) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
获得所提供的输入流的 MIDI 文件格式。
getMidiFileFormat(URL) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
获得提供的 URL 的 MIDI 文件格式。
getMidiFileFormat(File) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
获得提供的 File 的 MIDI 文件格式。
getMidiFileTypes() - 类 javax.sound.midi.MidiSystem 中的静态方法
获得系统为其提供文件写入支持的 MIDI 文件类型的集合。
getMidiFileTypes(Sequence) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得系统可从指定 sequence 写入的 MIDI 文件类型集合。
getMidiFileTypes() - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
获得此文件 writer 为其提供文件写入支持的 MIDI 文件类型的集合。
getMidiFileTypes(Sequence) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
获得此文件 writer 可从指定的序列写入的文件类型。
getMidLabel() - 类 javax.sound.sampled.FloatControl 中的方法
获得中点值的标签，如 "Center" 或 "Default"。
getMidTermsOfReductionPolynomial() - 类 java.security.spec.ECFieldF2m 中的方法
对于多项式方法，返回包含降序排列多项式的中间项顺序的整数数组，对于常规方法，返回 null。
getMillis() - 类 java.util.logging.LogRecord 中的方法
获取自从 1970 年以毫秒为单位的事件时间。
getMillisecond() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 XMLGregorianCalendar.getFractionalSecond() 的毫秒精度。
getMillisToDecideToPopup() - 类 javax.swing.ProgressMonitor 中的方法
返回在确定是否弹出进度监视器之前此对象等待的时间量。
getMillisToPopup() - 类 javax.swing.ProgressMonitor 中的方法
返回显示弹出监视器花费的时间量。
getMimeHeader(String) - 类 javax.xml.soap.AttachmentPart 中的方法
获取给定 String 所标识的头的所有值。
getMimeHeader(String) - 类 javax.xml.soap.SOAPPart 中的方法
获取此 SOAPPart 对象中所有由给定 String 标识的 MimeHeader 对象的值。
getMimeHeaders() - 类 javax.xml.soap.SOAPMessage 中的方法
以与传输无关的方式返回此 SOAPMessage 对象所有特定于传输的 MIME 头。
getMimeType() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的 MIME 类型字符串。
getMimeType() - 类 javax.activation.ActivationDataFlavor 中的方法
返回此 DataFlavor 的 MIME 类型。
getMimeType() - 类 javax.print.DocFlavor 中的方法
根据 MIME 类型的规范形式返回此 DocFlavor 对象的 MIME 类型字符串。
getMimeType() - 接口 javax.xml.crypto.dsig.XMLObject 中的方法
返回此 XMLObject 的 MIME 类型。
getMimeType() - 类 javax.xml.crypto.OctetStreamData 中的方法
返回与由此 OctetStreamData 表示的数据对象关联的 MIME 类型。
getMimeTypes() - 接口 javax.accessibility.AccessibleStreamable 中的方法
返回此对象所支持的 MIME 类型的 DataFlavor 对象数组。
getMimeTypes() - 类 javax.activation.CommandMap 中的方法
获取此命令映射已知的所有 MIME 类型。
getMimeTypes() - 类 javax.activation.MailcapCommandMap 中的方法
获取此命令映射已知的所有 MIME 类型。
getMIMETypes() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回一个 String 数组，该数组包含与通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的格式有关的 MIME 类型的列表。
getMimeTypes() - 接口 javax.script.ScriptEngineFactory 中的方法
返回 mimetypes 的不可变列表，这些 mimetypes 与可由引擎执行的脚本关联。
getMinBufferSize() - 类 javax.sound.sampled.DataLine.Info 中的方法
获得数据行支持的最小缓冲区大小。
getMinCRL() - 类 java.security.cert.X509CRLSelector 中的方法
返回 minCRLNumber 标准。
getMinDegree() - 类 javax.management.relation.RoleInfo 中的方法
返回相应角色引用的最小程度。
getMinimalDaysInFirstWeek() - 类 java.util.Calendar 中的方法
获取一年中第一个星期所需的最少天数，例如，如果定义第一个星期包含一年第一个月的第一天，则此方法将返回 1。
getMinimum() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的最小值。
getMinimum() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的最小值。
getMinimum() - 类 java.awt.ScrollPaneAdjustable 中的方法

getMinimum(int) - 类 java.util.Calendar 中的方法
返回此 Calendar 实例给定日历字段的最小值。
getMinimum(int) - 类 java.util.GregorianCalendar 中的方法
返回此 GregorianCalendar 实例的给定日历字段的最小值。
getMinimum() - 类 javax.sound.sampled.FloatControl 中的方法
获得所允许的最小值。
getMinimum() - 接口 javax.swing.BoundedRangeModel 中的方法
返回最小的可接受值。
getMinimum() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回模型的 minimum。
getMinimum() - 类 javax.swing.JProgressBar 中的方法
从 BoundedRangeModel 返回进度条的 minimum 值。
getMinimum() - 类 javax.swing.JScrollBar 中的方法
返回滚动条支持的最小值（通常为 0）。
getMinimum() - 类 javax.swing.JSlider 中的方法
从 BoundedRangeModel 返回滑块所支持的最小值。
getMinimum() - 类 javax.swing.ProgressMonitor 中的方法
返回最小值 - 进度值的较低端。
getMinimum() - 类 javax.swing.SpinnerNumberModel 中的方法
返回此序列中的第一个数字。
getMinimum() - 类 javax.swing.text.InternationalFormatter 中的方法
返回最小允许值。
getMinimumAccessibleValue() - 类 java.awt.Button.AccessibleAWTButton 中的方法
获取此对象的最小值，它是一个 Number。
getMinimumAccessibleValue() - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
获取此对象的最小值，它是一个 Number。
getMinimumAccessibleValue() - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
获取此对象的最小值，它是一个 Number。
getMinimumAccessibleValue() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
以数字形式获取此对象的最小值。
getMinimumAccessibleValue() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
获取此对象的最小可访问值。
getMinimumAccessibleValue() - 接口 javax.accessibility.AccessibleValue 中的方法
以 Number 形式设置此对象的最小值。
getMinimumAccessibleValue() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
以 Number 形式获取此对象的最小值。
getMinimumAccessibleValue() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
以 Number 形式获取此对象的最小值。
getMinimumAccessibleValue() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
以 Number 形式获取此对象的最小值。
getMinimumAccessibleValue() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
获取此对象的最小可访问值。
getMinimumAccessibleValue() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
获取此对象的最小可访问值。
getMinimumAccessibleValue() - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
获取此对象的最小可访问值。
getMinimumAccessibleValue() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
获取此对象数字形式的最小值。
getMinimumAccessibleValue() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
获取此对象的最小可访问值。
getMinimumDividerLocation() - 类 javax.swing.JSplitPane 中的方法
返回外观实现中分隔条的最小位置。
getMinimumDividerLocation(JSplitPane) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
获取分隔符的最小位置。
getMinimumDividerLocation(JSplitPane) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumDividerLocation 方法。
getMinimumDividerLocation(JSplitPane) - 类 javax.swing.plaf.SplitPaneUI 中的方法
返回分隔符的最小可能位置。
getMinimumFractionDigits() - 类 java.text.DecimalFormat 中的方法
获取某个数的小数部分中所允许的最小数字位数。
getMinimumFractionDigits() - 类 java.text.NumberFormat 中的方法
返回数的小数部分所允许的最小位数。
getMinimumHorizontalSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getMinimumIntegerDigits() - 类 java.text.DecimalFormat 中的方法
获取某个数的整数部分中所允许的最小数字位数。
getMinimumIntegerDigits() - 类 java.text.NumberFormat 中的方法
返回数的整数部分所允许的最小位数。
getMinimumOptionPaneSize() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回选项窗格应该具有的最小大小。
getMinimumSize() - 类 java.awt.Component 中的方法
获取组件的最小大小。
getMinimumSize() - 类 java.awt.Container 中的方法
返回此容器的最小大小。
getMinimumSize(int) - 类 java.awt.List 中的方法
获取具有指定行数的列表的最少维数。
getMinimumSize() - 类 java.awt.List 中的方法
确定此滚动列表的最小大小。
getMinimumSize(int, int) - 类 java.awt.TextArea 中的方法
确定具有指定行数和列数的文本区的最小大小。
getMinimumSize() - 类 java.awt.TextArea 中的方法
确定此文本区的最小大小。
getMinimumSize(int) - 类 java.awt.TextField 中的方法
获取具有指定列数的文本字段的最小尺寸。
getMinimumSize() - 类 java.awt.TextField 中的方法
获取此文本字段的最小尺寸。
getMinimumSize(Component) - 类 javax.swing.border.TitledBorder 中的方法
返回此边框完全显示边框和标题所需的最小大小。
getMinimumSize() - 类 javax.swing.JComponent 中的方法
如果已将最小大小设置为一个非 null 值，则返回该值。
getMinimumSize() - 类 javax.swing.JScrollBar 中的方法
滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
getMinimumSize() - 类 javax.swing.JToolBar.Separator 中的方法
返回分隔符的最小大小。
getMinimumSize() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回 BasicArrowButton 的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
最小大小为显示区域加上 insets 再加上按钮的大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
此组件的最小大小为 10。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getMinimumSize() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回 dividerSize x dividerSize
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回传入组件的最小大小，该大小将传递给当前布局管理器。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回标题的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回表的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
重写此方法以将插入符的宽度考虑在内。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取编辑器组件的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回此组件的最小大小。
getMinimumSize(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回指定组件的适合外观的最小大小。
getMinimumSize() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
返回 JFileChooser 的最小大小。
getMinimumSize() - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法

getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
getMinimumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
返回正确呈现图标和文本所需的最小大小。
getMinimumSpan(int) - 类 javax.swing.text.AsyncBoxView 中的方法
确定此视图沿某轴的最小跨距。
getMinimumSpan(int) - 类 javax.swing.text.BoxView 中的方法
确定此视图沿某个轴的最小区域。
getMinimumSpan(int) - 类 javax.swing.text.ComponentView 中的方法
确定此视图沿某轴的最小区域。
getMinimumSpan(int) - 类 javax.swing.text.html.BlockView 中的方法
确定此视图沿某个轴的最小区域。
getMinimumSpan(int) - 类 javax.swing.text.html.ParagraphView 中的方法
确定此视图沿某轴的最小区域。
getMinimumSpan(int) - 类 javax.swing.text.View 中的方法
确定此视图沿某个轴的最小跨距。
getMinimumSpan(int) - 类 javax.swing.text.WrappedPlainView 中的方法
确定此视图沿某个轴的最小跨距。
getMinimumThumbSize() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
返回 thumb 的最小可接受大小。
getMinimumThumbSize() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法

getMinimumValue() - 类 javax.swing.Spring 中的方法
返回此 Spring 的 minimum 值。
getMinimumVerticalSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getMinIndex() - 类 javax.imageio.ImageReader 中的方法
返回用于读取图像、缩略图或图像元数据的最低有效索引。
getMinLabel() - 类 javax.sound.sampled.FloatControl 中的方法
获得最小值的标签，如 "Left" 或 "Off"。
getMinor() - 异常 org.ietf.jgss.GSSException 中的方法
返回导致抛出此异常的问题的机制级错误代码。
getMinorAxis() - 类 javax.swing.text.AsyncBoxView 中的方法
获取辅轴（与平铺轴垂直的轴）。
getMinorOffset() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
沿辅轴的偏移量是什么
getMinorSpan() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
沿辅轴的跨距是什么。
getMinorStatus() - 类 org.ietf.jgss.MessageProp 中的方法
检索基础验证机制可能已经为此 per-message 操作设置的次要状态码.
getMinorString() - 异常 org.ietf.jgss.GSSException 中的方法
返回解释特定于机制的错误代码的字符串。
getMinorString() - 类 org.ietf.jgss.MessageProp 中的方法
检索解释次要状态码的字符串。
getMinorTickSpacing() - 类 javax.swing.JSlider 中的方法
此方法返回次刻度标记的间隔。
getMinorVersion() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件的次版本号。
getMinorVersion() - 接口 java.sql.Driver 中的方法
获得此驱动程序的次版本号。
getMinPage() - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户可以指定为要打印的第一页的最小值。
getMinSelectionIndex() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回第一个选择的索引，如果选择为空，则返回 -1。
getMinSelectionIndex() - 类 javax.swing.JList 中的方法
返回选择的最小单元索引；如果选择为空，则返回 -1。
getMinSelectionIndex() - 接口 javax.swing.ListSelectionModel 中的方法
返回第一个选择的索引，如果选择为空，则返回 -1。
getMinSelectionRow() - 类 javax.swing.JTree 中的方法
获取选择的第一行。
getMinSelectionRow() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回从 RowMapper 获取的已选择的 TreePath 的当前集合中的最小值。
getMinSelectionRow() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回从 RowMapper 获取的已选的 TreePath 当前集合中的最小值。
getMinSize(Container, GridBagLayoutInfo) - 类 java.awt.GridBagLayout 中的方法
基于 getLayoutInfo 中的信息计算其所有者的最小大小。
GetMinSize(Container, GridBagLayoutInfo) - 类 java.awt.GridBagLayout 中的方法
此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。
getMinTileX() - 类 java.awt.image.BufferedImage 中的方法
返回 x 方向的最小 tile 索引。
getMinTileX() - 接口 java.awt.image.RenderedImage 中的方法
返回 X 方向的最小 tile 索引。
getMinTileY() - 类 java.awt.image.BufferedImage 中的方法
返回 y 方向的最小 tile 索引。
getMinTileY() - 接口 java.awt.image.RenderedImage 中的方法
返回 Y 方向的最小 tile 索引。
getMinusSign() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于表示减号的字符。
getMinute() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回分或 DatatypeConstants.FIELD_UNDEFINED。
getMinutes() - 类 java.sql.Date 中的方法
已过时。
getMinutes() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MINUTE) 取代。
getMinutes() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 MINUTES 字段的值，如果不存在，则值为 0。
getMinValue(int) - 类 java.awt.color.ColorSpace 中的方法
返回指定分量的最小标准化颜色分量值。
getMinValue(int) - 类 java.awt.color.ICC_ColorSpace 中的方法
返回指定分量的最小标准化颜色分量值。
getMinValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最小值（如果已指定），否则返回 null。
getMinValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此参数的最小值（如果存在），否则返回 null。
getMinValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最小值（如果指定），否则返回 null。
getMinWidth() - 类 javax.swing.table.TableColumn 中的方法
返回 TableColumn 的最小宽度。
getMinX() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 窗体矩形的最小 X 坐标。
getMinX() - 类 java.awt.image.BufferedImage 中的方法
返回此 BufferedImage 的最小 x 坐标。
getMinX() - 类 java.awt.image.Raster 中的方法
返回 Raster 的最小有效 X 坐标。
getMinX() - 接口 java.awt.image.renderable.RenderableImage 中的方法
获取与呈现无关的图像数据的最小 X 坐标。
getMinX() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取与呈现无关的图像数据的最小 X 坐标。
getMinX() - 接口 java.awt.image.RenderedImage 中的方法
返回 RenderedImage 的最小 X 坐标（包括）。
getMinY() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回 Shape 窗体矩形的最小 Y 坐标。
getMinY() - 类 java.awt.image.BufferedImage 中的方法
返回此 BufferedImage 的最小 y 坐标。
getMinY() - 类 java.awt.image.Raster 中的方法
返回 Raster 的最小有效 Y 坐标。
getMinY() - 接口 java.awt.image.renderable.RenderableImage 中的方法
获取与呈现无关的图像数据的最小 Y 坐标。
getMinY() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取与呈现无关的图像数据的最小 Y 坐标。
getMinY() - 接口 java.awt.image.RenderedImage 中的方法
返回 RenderedImage 的最小 Y 坐标（包括）。
getMissingGlyphCode() - 类 java.awt.Font 中的方法
返回此 Font 不具有指定的 unicode 字形时所使用的 glyphCode 代码点。
getMiterLimit() - 类 java.awt.BasicStroke 中的方法
返回斜接的限制。
getMixer(Mixer.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得请求的音频混频器。
getMixer(Mixer.Info) - 类 javax.sound.sampled.spi.MixerProvider 中的方法
获得由 info 对象表示的混频器的实例。
getMixerInfo() - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得混频器信息对象的数组，该数组表示当前安装在系统上的音频混频器的集合。
getMixerInfo() - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器的信息，包括产品名称、版本、供应商，等等。
getMixerInfo() - 类 javax.sound.sampled.spi.MixerProvider 中的方法
获得表示由该 MixerProvider 提供的混频器的 info 对象集合。
getMnemonic() - 类 javax.swing.AbstractButton 中的方法
返回当前模型中的键盘助记符。
getMnemonic() - 接口 javax.swing.ButtonModel 中的方法
获取该按钮的键盘助记符。
getMnemonic() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
提供关于 KeyEvent.VK 常量的外观方面的提示，此常量可用作访问面板的助记符。
getMnemonic() - 类 javax.swing.DefaultButtonModel 中的方法
获取该按钮的键盘助记符。
getMnemonicAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回用于访问指定选项卡的键盘助记符。
getModalExclusionType() - 类 java.awt.Window 中的方法
返回此窗口的模式排斥类型。
getModalityType() - 类 java.awt.Dialog 中的方法
返回此 dialog 的模式类型。
getMode() - 类 java.awt.FileDialog 中的方法
指示此文件对话框是用于从文件加载内容还是将内容保存到文件。
getModel() - 类 javax.swing.AbstractButton 中的方法
返回此按钮表示的模型。
getModel() - 类 javax.swing.DefaultRowSorter 中的方法
返回底层模型。
getModel() - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回此 Model 包装的底层模型。
getModel() - 类 javax.swing.JComboBox 中的方法
返回 JComboBox 当前使用的数据模型。
getModel() - 类 javax.swing.JList 中的方法
返回保存由 JList 组件显示的项列表的数据模型。
getModel() - 类 javax.swing.JProgressBar 中的方法
返回此进度条使用的数据模型。
getModel() - 类 javax.swing.JScrollBar 中的方法
返回处理滚动条的四个基本属性的数据模型：minimum、maximum、value 和 extent。
getModel() - 类 javax.swing.JSlider 中的方法
返回处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
getModel() - 类 javax.swing.JSpinner.DateEditor 中的方法
返回微调器祖先的 SpinnerDateModel。
getModel() - 类 javax.swing.JSpinner 中的方法
返回定义此 spinner 值序列的 SpinnerModel。
getModel() - 类 javax.swing.JSpinner.ListEditor 中的方法
返回 spinner 祖先的 SpinnerNumberModel。
getModel() - 类 javax.swing.JSpinner.NumberEditor 中的方法
返回 spinner 祖先的 SpinnerNumberModel。
getModel() - 类 javax.swing.JTabbedPane 中的方法
返回与此选项卡窗格关联的模型。
getModel() - 类 javax.swing.JTable 中的方法
返回提供此 JTable 所显示数据的 TableModel。
getModel() - 类 javax.swing.JTree 中的方法
返回正在提供数据的 TreeModel。
getModel() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getModel() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getModel() - 类 javax.swing.RowFilter.Entry 中的方法
返回底层模型。
getModel() - 类 javax.swing.RowSorter 中的方法
返回底层模型。
getModel() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回要提供数据的 TreeModel。
getModelIndex() - 类 javax.swing.table.TableColumn 中的方法
返回此列的模型索引。
getModelRowCount() - 类 javax.swing.DefaultRowSorter 中的方法
返回底层模型中的行数。
getModelRowCount() - 类 javax.swing.RowSorter 中的方法
返回底层模型中的行数。
getModelWrapper() - 类 javax.swing.DefaultRowSorter 中的方法
返回模型包装器，它提供将要进行排序和过滤的数据。
getModificationOp() - 类 javax.naming.directory.ModificationItem 中的方法
检索此修改项的修改代码。
getModifier() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getModifiers() - 类 java.awt.AWTKeyStroke 中的方法
返回此 AWTKeyStroke 的修饰符键。
getModifiers() - 类 java.awt.event.ActionEvent 中的方法
返回发生此动作事件期间按下的修改键。
getModifiers() - 类 java.awt.event.InputEvent 中的方法
返回此事件的修饰符掩码。
getModifiers() - 类 java.lang.Class 中的方法
返回此类或接口以整数编码的 Java 语言修饰符。
getModifiers() - 类 java.lang.reflect.Constructor 中的方法
以整数形式返回此 Constructor 对象所表示构造方法的 Java 语言修饰符。
getModifiers() - 类 java.lang.reflect.Field 中的方法
以整数形式返回由此 Field 对象表示的字段的 Java 语言修饰符。
getModifiers() - 接口 java.lang.reflect.Member 中的方法
作为整数返回由此 Member 所表示的成员或构造方法的 Java 语言修饰符。
getModifiers() - 类 java.lang.reflect.Method 中的方法
以整数形式返回此 Method 对象所表示方法的 Java 语言修饰符。
getModifiers() - 接口 javax.lang.model.element.Element 中的方法
返回此元素的修饰符，不包括注释。
getModifiersEx() - 类 java.awt.event.InputEvent 中的方法
返回此事件的扩展修饰符掩码。
getModifiersExText(int) - 类 java.awt.event.InputEvent 中的静态方法
返回描述扩展修改键和鼠标按钮（例如 "Shift"、"Button1" 或 "Ctrl+Shift"）的 String。
getModulus() - 接口 java.security.interfaces.RSAKey 中的方法
返回该系数。
getModulus() - 类 java.security.spec.RSAPrivateKeySpec 中的方法
返回系数。
getModulus() - 类 java.security.spec.RSAPublicKeySpec 中的方法
返回该系数。
getModulus() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察到的 MBeans 共同的模值。
getModulus() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取模值。
getMonetaryDecimalSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
返回货币小数点分隔符。
getMono() - 接口 javax.sound.midi.MidiChannel 中的方法
获得当前的 mono/poly 模式。
getMonth() - 类 java.sql.Time 中的方法
已过时。
getMonth() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MONTH) 取代。
getMonth() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回月数或 DatatypeConstants.FIELD_UNDEFINED。
getMonths() - 类 java.text.DateFormatSymbols 中的方法
获取月份字符串。
getMonths() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 MONTHS 字段的值，如果不存在，则值为 0。
getMoreResults() - 接口 java.sql.Statement 中的方法
移动到此 Statement 对象的下一个结果，如果其为 ResultSet 对象，则返回 true，并隐式关闭利用方法 getResultSet 获取的所有当前 ResultSet 对象。
getMoreResults(int) - 接口 java.sql.Statement 中的方法
将此 Statement 对象移动到下一个结果，根据给定标志指定的指令处理所有当前 ResultSet 对象；如果下一个结果为 ResultSet 对象，则返回 true。
getMostRecentEventTime() - 类 java.awt.EventQueue 中的静态方法
返回最近事件的时间戳（如果有），该事件从 EventQueue（它与正在调用的线程相关）进行指派。
getMostRecentFocusOwner() - 类 java.awt.Window 中的方法
返回此窗口的子组件，该子组件在此窗口为焦点窗口时将接收焦点。
getMostRecentFocusOwner() - 类 javax.swing.JInternalFrame 中的方法
返回选定此 JInternalFrame 时，将接收焦点的 JInternalFrame 子组件。
getMostSignificantBits() - 类 java.util.UUID 中的方法
返回此 UUID 的 128 位值中的最高有效 64 位。
getMouseInfoPeer() - 类 java.awt.Toolkit 中的方法
使用指定同位体接口创建此工具包的 MouseInfo 实现。
getMouseListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.getMouseListener() 的实现。
getMouseListener() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
返回将添加到组合框的鼠标侦听器或 null。
getMouseListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的鼠标侦听器的数组。
getMouseListeners() - 类 java.awt.TrayIcon 中的方法
返回已在此 TrayIcon 上注册的所有鼠标侦听器的数组。
getMouseModifiersText(int) - 类 java.awt.event.MouseEvent 中的静态方法
返回一个描述事件期间所按下的修改键和鼠标按键（如“Shift”或“Ctrl+Shift”）的 String。
getMouseMotionListener() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.getMouseMotionListener() 的实现。
getMouseMotionListener() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
返回将添加到组合框的鼠标移动侦听器或 null。
getMouseMotionListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的鼠标移动侦听器的数组。
getMouseMotionListeners() - 类 java.awt.TrayIcon 中的方法
返回已在此 TrayIcon 上注册的所有鼠标移动侦听器的数组。
getMousePosition() - 类 java.awt.Component 中的方法
如果此 Component 正好位于鼠标指针下，则返回鼠标指针在该 Component 的坐标空间中的位置；否则返回 null。
getMousePosition(boolean) - 类 java.awt.Container 中的方法
如果 Container 位于鼠标指针下，则返回鼠标指针在此 Container 的坐标中的位置，否则返回 null。
getMouseWheelListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的鼠标滚轮侦听器的数组。
getMTU() - 类 java.net.NetworkInterface 中的方法
返回此接口的最大传输单元（Maximum Transmission Unit，MTU）。
getMultiClickThreshhold() - 类 javax.swing.AbstractButton 中的方法
获取对按钮按下鼠标到生成相应动作事件所需的时间量（以毫秒为单位）。
getMultiDocPrintServices(DocFlavor[], AttributeSet) - 类 javax.print.PrintServiceLookup 中的方法
应用程序不直接调用它。
getMultipleDocumentHandling() - 类 java.awt.JobAttributes 中的方法
为使用这些属性的作业指定多份处理，包括整理。
getMultiplier() - 类 java.text.DecimalFormat 中的方法
获取百分数、千分数和类似格式中使用的乘数。
getMustUnderstand() - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
返回此 SOAPHeaderElement mustUnderstand 属性的 boolean 值。
getMute() - 接口 javax.sound.midi.MidiChannel 中的方法
获得此通道的当前静音状态。
getMutualAuthState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否在此上下文上启用了相互验证。
getName(int) - 类 java.awt.color.ColorSpace 中的方法
返回给定分量索引处的分量名称。
getName() - 类 java.awt.Component 中的方法
获取组件的名称。
getName() - 类 java.awt.Cursor 中的方法
返回此光标的名称。
getName() - 类 java.awt.datatransfer.Clipboard 中的方法
返回此剪贴板对象的名称。
getName() - 类 java.awt.Font 中的方法
返回此 Font 的逻辑名称。
getName() - 类 java.awt.MenuComponent 中的方法
获取该菜单组件的名称。
getName() - 类 java.beans.FeatureDescriptor 中的方法
获得此特性的编程名称。
getName() - 类 java.io.File 中的方法
返回由此抽象路径名表示的文件或目录的名称。
getName() - 类 java.io.ObjectStreamClass 中的方法
返回由此描述符描述的类的名称。
getName() - 类 java.io.ObjectStreamField 中的方法
获取此字段的名称。
getName() - 类 java.lang.Class 中的方法
以 String 的形式返回此 Class 对象所表示的实体（类、接口、数组类、基本类型或 void）名称。
getName() - 接口 java.lang.management.CompilationMXBean 中的方法
返回即时 (JIT) 编译器的名称。
getName() - 接口 java.lang.management.MemoryManagerMXBean 中的方法
返回表示此内存管理器的名称。
getName() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回表示此内存池的名称。
getName() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回操作系统名称。
getName() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回表示正在运行的 Java 虚拟机的名称。
getName() - 类 java.lang.Package 中的方法
返回此包的名称。
getName() - 类 java.lang.reflect.Constructor 中的方法
以字符串形式返回此构造方法的名称。
getName() - 类 java.lang.reflect.Field 中的方法
返回此 Field 对象表示的字段的名称。
getName() - 接口 java.lang.reflect.Member 中的方法
返回此 Member 表示的底层成员或构造方法的简单名称。
getName() - 类 java.lang.reflect.Method 中的方法
以 String 形式返回此 Method 对象表示的方法名称。
getName() - 接口 java.lang.reflect.TypeVariable 中的方法
返回此类型变量的名称，它出现在源代码中。
getName() - 类 java.lang.Thread 中的方法
返回该线程的名称。
getName() - 类 java.lang.ThreadGroup 中的方法
返回此线程组的名称。
getName() - 类 java.net.HttpCookie 中的方法
返回 cookie 的名称。
getName() - 类 java.net.NetworkInterface 中的方法
获取此网络接口的名称。
getName() - 接口 java.security.acl.Acl 中的方法
返回此 ACL 的名称。
getName() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的名称。
getName() - 类 java.security.Permission 中的方法
返回此 Permission 的名称。
getName() - 接口 java.security.Principal 中的方法
返回此主体的名称。
getName() - 类 java.security.Provider 中的方法
返回此 provider 的名称。
getName() - 类 java.security.spec.ECGenParameterSpec 中的方法
返回要生成的 EC 域参数的标准名称或预定义名称。
getName() - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
返回此属性的名称。
getName() - 类 java.util.logging.Level 中的方法
返回 Level 的非本地化字符串名称。
getName() - 类 java.util.logging.Logger 中的方法
获取此 logger 的名称。
getName() - 类 java.util.zip.ZipEntry 中的方法
返回条目名称。
getName() - 类 java.util.zip.ZipFile 中的方法
返回 ZIP 文件的路径名。
getName() - 类 javax.activation.DataHandler 中的方法
返回数据对象的名称。
getName() - 接口 javax.activation.DataSource 中的方法
返回此对象的名称，其中对象的名称依赖于底层对象的特性。
getName() - 类 javax.activation.FileDataSource 中的方法
返回此对象的名称。
getName() - 类 javax.activation.URLDataSource 中的方法
调用用于实例化对象的 URL 的 getFile 方法。
getName() - 类 javax.crypto.ExemptionMechanism 中的方法
返回此 ExemptionMechanism 对象的豁免机制名称。
getName(CharSequence) - 接口 javax.lang.model.util.Elements 中的方法
返回与参数具有相同字符序列的名称。
getName() - 类 javax.management.Attribute 中的方法
返回包含该 Attribute 的名称的 String。
getName() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的 NAME 属性的值。
getName() - 类 javax.management.MBeanFeatureInfo 中的方法
返回该功能的名称。
getName() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回此 OpenMBeanConstructorInfo 实例描述的构造方法名称。
getName() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例描述的操作名称。
getName() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例描述的参数名称。
getName() - 类 javax.management.relation.RoleInfo 中的方法
返回角色名称。
getName() - 类 javax.management.remote.JMXPrincipal 中的方法
返回此 principal 的名称。
getName() - 类 javax.naming.NameClassPair 中的方法
检索此绑定的名称。
getName() - 类 javax.net.ssl.SSLSessionBindingEvent 中的方法
返回将对象绑定到或从其解除绑定的名称。
getName() - 接口 javax.print.attribute.Attribute 中的方法
获取类别的名称,此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.Chromaticity 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.ColorSupported 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Compression 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Copies 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.CopiesSupported 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.DateTimeAtCompleted 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.DateTimeAtCreation 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.DateTimeAtProcessing 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Destination 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.DocumentName 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Fidelity 中的方法
获取类别名称，这里此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.Finishings 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobHoldUntil 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobImpressions 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobImpressionsCompleted 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobImpressionsSupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobKOctets 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobKOctetsProcessed 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobKOctetsSupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobMediaSheets 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobMediaSheetsCompleted 中的方法
获取类别名称，此属性值是该类别的实例。
getName() - 类 javax.print.attribute.standard.JobMediaSheetsSupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobMessageFromOperator 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobName 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobOriginatingUserName 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobPriority 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobPrioritySupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobSheets 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobState 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobStateReason 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.JobStateReasons 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.Media 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.MediaSize 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.NumberOfDocuments 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.NumberOfInterveningJobs 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.NumberUp 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.NumberUpSupported 中的方法
获取类别名称，此属性值为该类别的实例。
getName() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.OutputDeviceAssigned 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PageRanges 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PagesPerMinute 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PagesPerMinuteColor 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PDLOverrideSupported 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PresentationDirection 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterInfo 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterLocation 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterMakeAndModel 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterMessageFromOperator 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterMoreInfo 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterName 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterResolution 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterState 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterStateReason 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterStateReasons 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrinterURI 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.PrintQuality 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.QueuedJobCount 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.RequestingUserName 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.Severity 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.SheetCollate 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 类 javax.print.attribute.standard.Sides 中的方法
获取类别的名称，此属性值是该类别的一个实例。
getName() - 接口 javax.print.PrintService 中的方法
返回此 PrintService 的 String 名称，应用程序可以使用该名称来请求特定的 PrintService。
getName() - 类 javax.security.auth.callback.NameCallback 中的方法
获取检索到的名称。
getName() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
返回的字符串对应于 Kerberos Principal 名称的 single-string 表示形式，RFC 1964 的 2.1 小节中指定了这种表示形式。
getName() - 类 javax.security.auth.x500.X500Principal 中的方法
返回使用 RFC 2253 中所定义格式的 X.500 标识名的字符串表示形式。
getName(String) - 类 javax.security.auth.x500.X500Principal 中的方法
返回使用指定格式的 X.500 标识名的字符串表示形式。
getName(String, Map<String, String>) - 类 javax.security.auth.x500.X500Principal 中的方法
返回使用指定格式的 X.500 标识名的字符串表示形式。
getName() - 类 javax.sound.midi.MidiDevice.Info 中的方法
获得设备的名称。
getName() - 接口 javax.sound.midi.Soundbank 中的方法
获得音库的名称。
getName() - 类 javax.sound.midi.SoundbankResource 中的方法
获得资源的名称。
getName() - 类 javax.sound.sampled.Mixer.Info 中的方法
获得混频器的名称。
getName() - 类 javax.sound.sampled.Port.Info 中的方法
获得端口的名称。
getName() - 类 javax.sound.sampled.ReverbType 中的方法
获得此回响类型的名称。
getName(File) - 类 javax.swing.filechooser.FileView 中的方法
文件名称。
getName(File) - 类 javax.swing.JFileChooser 中的方法
返回文件名。
getName() - 类 javax.swing.LookAndFeel 中的方法
返回标识此外观的短字符串，例如 "CDE/Motif"。
getName(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getName() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回此主题的名称。
getName() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回此外观的名称。
getName() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回此主题的名称。
getName() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回此主题的名称，即 "Ocean"。
getName() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回适合在菜单中使用、标识此外观的 string。
getName() - 类 javax.swing.plaf.synth.Region 中的方法
返回 region 的名称。
getName() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回一个标识此外观的短字符串。
getName() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素的名称。
getName() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得元素名。
getName() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得元素名。
getName() - 类 javax.swing.text.DefaultStyledDocument.SectionElement 中的方法
获得元素的名称。
getName() - 接口 javax.swing.text.Element 中的方法
获取元素的名称。
getName() - 类 javax.swing.text.html.HTMLDocument.BlockElement 中的方法
获取元素名称。
getName() - 类 javax.swing.text.html.HTMLDocument.RunElement 中的方法
获取元素名称。
getName() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getName() - 类 javax.swing.text.html.parser.DTD 中的方法
获取 DTD 的名称。
getName() - 类 javax.swing.text.html.parser.Element 中的方法
获取元素的名称。
getName() - 类 javax.swing.text.html.parser.Entity 中的方法
获取实体的名称。
getName() - 接口 javax.swing.text.Keymap 中的方法
获取键绑定集合的名称。
getName() - 接口 javax.swing.text.Style 中的方法
获取样式名称。
getName() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
获取样式的名称。
getName() - 类 javax.swing.UIManager.LookAndFeelInfo 中的方法
以适合菜单或其他展示的形式返回外观的名称
getName() - 接口 javax.tools.FileObject 中的方法
获取此文件对象的用户友好 (user-friendly) 的名称。
getName() - 类 javax.tools.ForwardingFileObject 中的方法

getName() - 接口 javax.tools.JavaFileManager.Location 中的方法
获取此位置的名称。
getName() - 类 javax.tools.SimpleJavaFileObject 中的方法

getName() - 枚举 javax.tools.StandardLocation 中的方法

getName() - 类 javax.xml.bind.JAXBElement 中的方法
返回 xml 元素标记名称。
getName() - 接口 javax.xml.crypto.dsig.keyinfo.KeyName 中的方法
返回此 KeyName 的名称。
getName() - 类 javax.xml.soap.MimeHeader 中的方法
返回此 MimeHeader 对象的名称。
getName() - 接口 javax.xml.stream.events.Attribute 中的方法
返回此属性的 QName。
getName() - 接口 javax.xml.stream.events.EndElement 中的方法
获取此事件的名称
getName() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
实体的名称
getName() - 接口 javax.xml.stream.events.EntityReference 中的方法
实体的名称
getName() - 接口 javax.xml.stream.events.NotationDeclaration 中的方法
注释的名称。
getName() - 接口 javax.xml.stream.events.StartElement 中的方法
获取此事件的名称
getName() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getName() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回当前 START_ELEMENT 或 END_ELEMENT 事件的 QName
getName() - 接口 org.ietf.jgss.GSSCredential 中的方法
检索凭据所维护的实体的名称。
getName(Oid) - 接口 org.ietf.jgss.GSSCredential 中的方法
检索凭据所维护的实体的 Mechanism Name（机制名称）。
getName() - 接口 org.w3c.dom.Attr 中的方法
返回此属性的名称。
getName() - 接口 org.w3c.dom.DocumentType 中的方法
DTD 的名称；即紧跟在 DOCTYPE 关键字后面的名称。
getName(int) - 接口 org.w3c.dom.NameList 中的方法
返回集合中的第 index 个名称项。
getName(int) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回此列表中属性的名称（根据位置）。
getName(int) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性名称（按位置）。
getNameConstraints() - 类 java.security.cert.TrustAnchor 中的方法
返回 nameConstraints 参数。
getNameConstraints() - 类 java.security.cert.X509CertSelector 中的方法
返回 NameConstraints 标准。
getNamedItem(String) - 接口 org.w3c.dom.NamedNodeMap 中的方法
检索通过名称指定的节点。
getNamedItemNS(String, String) - 接口 org.w3c.dom.NamedNodeMap 中的方法
检索通过本地名称和名称空间 URI 指定的节点。
getNameInNamespace() - 接口 javax.naming.Context 中的方法
在此上下文自己的名称空间中检索其完全名称。
getNameInNamespace() - 类 javax.naming.InitialContext 中的方法

getNameInNamespace() - 类 javax.naming.NameClassPair 中的方法
检索此绑定的完全名称。
getNameParser(Name) - 接口 javax.naming.Context 中的方法
检索与指定上下文关联的解析器。
getNameParser(String) - 接口 javax.naming.Context 中的方法
检索与指定上下文关联的解析器。
getNameParser(String) - 类 javax.naming.InitialContext 中的方法

getNameParser(Name) - 类 javax.naming.InitialContext 中的方法

getNames() - 类 javax.activation.MimeTypeParameterList 中的方法
获取此列表中所有名称的枚举。
getNames() - 接口 javax.script.ScriptEngineFactory 中的方法
返回 ScriptEngine 短名称的不可变列表，这些名称由 ScriptEngineManager 用来标识 ScriptEngine。
getNamesForMech(Oid) - 类 org.ietf.jgss.GSSManager 中的方法
然后返回由指定的机制所支持的名称类型。
getNamespaceContext() - 接口 javax.xml.stream.events.StartElement 中的方法
获取只读名称空间上下文。
getNamespaceContext() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceContext() - 接口 javax.xml.stream.XMLEventWriter 中的方法
返回当前名称空间上下文。
getNamespaceContext() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回当前位置的只读名称空间上下文。
getNamespaceContext() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
返回当前名称空间上下文。
getNamespaceContext() - 接口 javax.xml.xpath.XPath 中的方法
返回当前的名称空间上下文。
getNamespaceCount() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceCount() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回在 START_ELEMENT 或 END_ELEMENT 中声明的名称空间的计数，此方法仅对 START_ELEMENT、END_ELEMENT 或 NAMESPACE 有效。
getNamespaceMap() - 类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 中的方法
返回名称空间前缀的映射表。
getNamespaceMap() - 类 javax.xml.crypto.dsig.spec.XPathType 中的方法
返回名称空间前缀的映射表。
getNamespacePrefix(String, String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 来获取指定 URI 所映射的前缀。
getNamespacePrefix(String, String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回与指定的名称空间 URI 关联的名称空间前缀。
getNamespacePrefix(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespacePrefix(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回在 index 处声明的名称空间前缀。
getNamespacePrefixes() - 接口 javax.xml.soap.SOAPElement 中的方法
返回可在此元素声明的名称空间前缀 String 上进行迭代的 Iterator。
getNamespaces() - 接口 javax.xml.stream.events.EndElement 中的方法
返回超出范围名称空间的 Iterator。
getNamespaces() - 接口 javax.xml.stream.events.StartElement 中的方法
返回在此元素上声明的名称空间的 Iterator。
getNamespaceURI() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回 null，因为不支持名称空间。
getNamespaceURI(String) - 接口 javax.xml.namespace.NamespaceContext 中的方法
获取绑定到当前范围中的前缀的名称空间 URI。
getNamespaceURI() - 类 javax.xml.namespace.QName 中的方法
获取此 QName 的名称空间 URI。
getNamespaceURI(String) - 接口 javax.xml.soap.SOAPElement 中的方法
返回带有给定前缀的名称空间的 URI。
getNamespaceURI() - 接口 javax.xml.stream.events.Namespace 中的方法
获取绑定到此名称空间的前缀的 URI。
getNamespaceURI(String) - 接口 javax.xml.stream.events.StartElement 中的方法
获取绑定在此元素上下文中的前缀的值。
getNamespaceURI(String) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceURI(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceURI() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getNamespaceURI(String) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回给定前缀的 URI。
getNamespaceURI(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回在 index 处声明的名称空间 URI。
getNamespaceURI() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果当前事件是 START_ELEMENT 或 END_ELEMENT，则此方法返回前缀的 URI 或默认名称空间。
getNamespaceURI(int) - 接口 org.w3c.dom.NameList 中的方法
返回集合中的第 index 个 namespaceURI 项。
getNamespaceURI() - 接口 org.w3c.dom.Node 中的方法
此节点的名称空间 URI；如果它未被指定，则返回 null（参见）。
getNameType() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
返回 KerberosPrincipal 的名称类型。
getNaN() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于表示“非数字”的字符串。
getNanos() - 类 java.sql.Timestamp 中的方法
获取此 Timestamp 对象的 nanos 值。
getNativeCommands(String) - 类 javax.activation.MailcapCommandMap 中的方法
获取给定 MIME 类型的本地命令。
getNativeContainer(Component) - 类 java.awt.Toolkit 中的静态方法
使本机同位体能够查询给定本机组件的本机容器（例如，直接父组件可以是轻量级的）。
getNativeImageMetadataFormatName() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回此插件的“本地”图像元数据格式的名称，它通常允许无损失地编码或传输按照由此插件处理的格式存储的图像元数据。
getNativeMetadataFormatName() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回此插件的“本机”元数据格式的名称，该格式通常允许无损失地编码和传输以此插件处理的格式存储的元数据。
getNativesForFlavor(DataFlavor) - 接口 java.awt.datatransfer.FlavorTable 中的方法
返回与指定 DataFlavor 对应的 String native 的 List。
getNativesForFlavor(DataFlavor) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。
getNativesForFlavors(DataFlavor[]) - 接口 java.awt.datatransfer.FlavorMap 中的方法
返回指定 DataFlavor 到其对应的 String native 的 Map。
getNativesForFlavors(DataFlavor[]) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
getNativeStreamMetadataFormatName() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回此插件的“本地”流元数据格式的名称，它通常允许无损失地编码和传输按照由此插件处理的格式存储的流元数据。
getNavigationFilter() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
如果想要提供过滤器以限制用户可导航的位置，则应进行子类化和重写。
getNavigationFilter() - 类 javax.swing.text.DefaultFormatter 中的方法
返回用于限制光标放置位置的 NavigationFilter。
getNavigationFilter() - 类 javax.swing.text.JTextComponent 中的方法
返回 NavigationFilter。
getNbNotifications() - 类 javax.management.timer.Timer 中的方法
获得在通知列表中注册的计时器通知数。
getNbNotifications() - 接口 javax.management.timer.TimerMBean 中的方法
获得在通知的列表中注册的计时器通知数。
getNbOccurences(Integer) - 类 javax.management.timer.Timer 中的方法
获得与计时器通知关联的剩余出现数量的一个副本。
getNbOccurences(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与计时器通知关联的剩余出现数量的一个副本。
getNCharacterStream(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
getNCharacterStream(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
getNCharacterStream(int) - 接口 java.sql.ResultSet 中的方法
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getNCharacterStream(String) - 接口 java.sql.ResultSet 中的方法
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getNClob(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.NClob 对象的形式获取指定的 JDBC NCLOB 参数的值。
getNClob(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。
getNClob(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getNClob(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getNeedClientAuth() - 类 javax.net.ssl.SSLEngine 中的方法
如果引擎要求 客户端验证，则返回 true。
getNeedClientAuth() - 类 javax.net.ssl.SSLParameters 中的方法
返回是否应该要求客户机验证。
getNeedClientAuth() - 类 javax.net.ssl.SSLServerSocket 中的方法
如果新 accept 的服务器模式的 SSLSocket 要求 客户端验证，则返回 true。
getNeedClientAuth() - 类 javax.net.ssl.SSLSocket 中的方法
如果套接字要求 客户机验证，则返回 true。
getNeedClientAuth() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
如果由此工厂创建的服务器套接字所接受的 SSL 连接上要求客户机进行验证，则返回 true。
getNeededLocation(int, int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
返回 x 参数，因为可以将其用于水平拆分。
getNeededLocation(int, int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 中的方法
返回 y 参数，因为可以将其用于垂直拆分。
getNegativePrefix() - 类 java.text.DecimalFormat 中的方法
获取负数前缀。
getNegativeSuffix() - 类 java.text.DecimalFormat 中的方法
获取负数后缀。
getNegotiatedProperty(String) - 接口 javax.security.sasl.SaslClient 中的方法
获取已协商的属性。
getNegotiatedProperty(String) - 接口 javax.security.sasl.SaslServer 中的方法
获取已协商的属性。
getNestedException() - 异常 javax.xml.stream.XMLStreamException 中的方法
获取嵌套异常。
getNestingKind() - 接口 javax.lang.model.element.TypeElement 中的方法
返回此类型元素的嵌套种类 (nesting kind)。
getNestingKind() - 类 javax.tools.ForwardingJavaFileObject 中的方法

getNestingKind() - 接口 javax.tools.JavaFileObject 中的方法
提供有关此文件对象表示的类的嵌套层次的提示。
getNestingKind() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现返回 null。
getNetworkInterface() - 类 java.net.MulticastSocket 中的方法
获取多播网络接口集合。
getNetworkInterfaces() - 类 java.net.NetworkInterface 中的静态方法
返回此机器上的所有接口。
getNetworkPrefixLength() - 类 java.net.InterfaceAddress 中的方法
返回此地址的网络前缀长度。
getNewBinding() - 类 javax.naming.event.NamingEvent 中的方法
检索更改后对象的绑定。
getNewDocument() - 接口 org.w3c.dom.ls.LSLoadEvent 中的方法
完成加载的文档。
getNewFolderAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getNewLeadSelectionPath() - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回当前前导路径。
getNewLine() - 接口 org.w3c.dom.ls.LSSerializer 中的方法
在所写出的 XML 中使用的字符的行尾序列。
getNewRoleValue() - 类 javax.management.relation.RelationNotification 中的方法
返回更新的角色的新值（仅限于角色更新）。
getNewState() - 类 java.awt.event.WindowEvent 中的方法
对于 WINDOW_STATE_CHANGED 事件，返回新的窗口状态。
getNewValue() - 类 java.beans.PropertyChangeEvent 中的方法
获取属性的新值，以 Object 的形式表示。
getNewValue() - 类 java.util.prefs.PreferenceChangeEvent 中的方法
返回首选项的新值。
getNewValue() - 类 javax.management.AttributeChangeNotification 中的方法
获得已更改属性的新值。
getNewValue() - 接口 org.w3c.dom.events.MutationEvent 中的方法
newValue 指示 DOMAttrModified 事件中 Attr 节点的新值，以及 DOMCharacterDataModified 中 CharacterData 节点的新值。
getNext() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getNextEastWestVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.CompositeView 中的方法
返回光标的下一个可视位置，可以在东或在西。
getNextEntry() - 类 java.util.jar.JarInputStream 中的方法
读取下一个 ZIP 文件条目，并将流定位于此条目数据的开始处。
getNextEntry() - 类 java.util.zip.ZipInputStream 中的方法
读取下一个 ZIP 文件条目并将流定位到该条目数据的开始处。
getNextEvent() - 类 java.awt.EventQueue 中的方法
从 EventQueue 中移除一个事件，并返回该事件。
getNextException() - 异常 java.sql.SQLException 中的方法
通过 setNextException(SQLException ex) 获取链接到此 SQLException 对象的异常。
getNextFocusableComponent() - 类 javax.swing.JComponent 中的方法
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代。
getNextJarEntry() - 类 java.util.jar.JarInputStream 中的方法
读取下一个 JAR 文件条目，并将流定位于此条目数据的开始处。
getNextLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点后面的叶节点，如果此节点是树中的最后一个叶节点，则返回 null。
getNextLeftHit(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
getNextLeftHit(int, TextLayout.CaretPolicy) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
getNextLeftHit(int) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
getNextMatch(String, int, Position.Bias) - 类 javax.swing.JList 中的方法
返回其 toString 值以给定前缀开头的下一个列表元素。
getNextMatch(String, int, Position.Bias) - 类 javax.swing.JTree 中的方法
将 TreePath 返回到以一个前缀开头的下一个树元素。
getNextNode() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回在此节点的树的前序遍历中此节点之后的节点。
getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.CompositeView 中的方法
返回光标的下一个可视位置，可以在北也可以在南。
getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.ParagraphView 中的方法
在东或西方向返回光标的下一个可视位置。
getNextRightHit(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
getNextRightHit(int, TextLayout.CaretPolicy) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
getNextRightHit(int) - 类 java.awt.font.TextLayout 中的方法
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
getNextSequenceNumber() - 类 javax.management.remote.NotificationResult 中的方法
返回下一个可供查询使用的通知的序列号。
getNextSibling() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的下一个兄弟节点；如果该节点没有下一个兄弟节点，则返回 null。
getNextSibling() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回父节点的子节点数组中此节点的下一个兄弟节点。
getNextSibling() - 类 javax.xml.crypto.dsig.dom.DOMSignContext 中的方法
返回 nextSibling 节点。
getNextSibling() - 类 javax.xml.transform.dom.DOMResult 中的方法
获取将要插入的结果节点之后的子节点。
getNextSibling() - 接口 org.w3c.dom.Node 中的方法
直接在此节点之后的节点。
getNextTabIndex(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getNextTabIndexInRun(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getNextTabRun(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getNextUpdate() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的 nextUpdate 日期。
getNextValue() - 类 javax.swing.JSpinner 中的方法
返回序列中由 getValue() 所返回的对象之后的对象。
getNextValue() - 类 javax.swing.SpinnerDateModel 中的方法
返回序列中的下一个 Date，如果下一个日期在 end 之后，则返回 null。
getNextValue() - 类 javax.swing.SpinnerListModel 中的方法
返回基础序列的下一个合法值，如果值已经是最后一个元素，则返回 null。
getNextValue() - 接口 javax.swing.SpinnerModel 中的方法
返回该序列中出现在 getValue() 返回的对象之后的对象。
getNextValue() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列中的下一个数字。
getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
提供确定下一个可以放置一个插入符的可见模型位置的方法。
getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getNextVisualPositionFrom 方法。
getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - 类 javax.swing.plaf.TextUI 中的方法
提供确定下一个可以放置一个插入符的可见模型位置的方法。
getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.AsyncBoxView 中的方法
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.CompositeView 中的方法
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.GlyphView 中的方法
提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
getNextVisualPositionFrom(GlyphView, int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - 类 javax.swing.text.NavigationFilter 中的方法
返回从现在位置起的下一个放置插入符的可视位置。
getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - 类 javax.swing.text.View 中的方法
提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
getNextWarning() - 异常 java.sql.SQLWarning 中的方法
通过 setNextWarning 获取链接到此 SQLWarning 对象的警告。
getNextWarning() - 异常 javax.sql.rowset.RowSetWarning 中的方法
获取链接到此 SQLWarning 对象的警告。
getNextWord(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定针对给定位置的下一个单词开头。
getNode() - 类 java.util.prefs.PreferenceChangeEvent 中的方法
返回发出事件的首选项节点。
getNode(Object) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。
getNode() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getNode(Object) - 接口 javax.xml.bind.Marshaller 中的方法
获取内容树的 DOM 树视图（可选）。
getNode() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回对 DOM Node 的引用（如果可用）。
getNode() - 类 javax.xml.crypto.dom.DOMStructure 中的方法
返回包含在此 DOMStructure 中的节点。
getNode() - 类 javax.xml.crypto.dsig.dom.DOMValidateContext 中的方法
返回节点。
getNode() - 类 javax.xml.transform.dom.DOMResult 中的方法
获取将包含结果 DOM 树的节点。
getNode() - 类 javax.xml.transform.dom.DOMSource 中的方法
获取表示 Source DOM 树的节点。
getNodeDimensions(Object, int, int, boolean, Rectangle) - 类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 中的方法
负责获取特定节点的大小。
getNodeDimensions() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回呈现树中节点的对象，它负责计算各个节点的尺寸。
getNodeDimensions(Object, int, int, boolean, Rectangle) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回通过 placeIn 中的引用，表示 value 所需的大小。
getNodeDimensions(Object, int, int, boolean, Rectangle) - 类 javax.swing.tree.AbstractLayoutCache.NodeDimensions 中的方法
通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。
getNodeName() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回与此节点关联的节点名称。
getNodeName() - 接口 org.w3c.dom.Node 中的方法
此节点的名称，取决于其类型；参见上表。
getNodeType() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回节点类型，其始终为 ELEMENT_NODE。
getNodeType() - 接口 org.w3c.dom.Node 中的方法
表示基础对象的类型的节点，如上所述。
getNodeValue() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getNodeValue() - 接口 org.w3c.dom.Node 中的方法
此节点的值，取决于其类型；参见上表。
getNoFallbackControl(List<String>) - 类 java.util.ResourceBundle.Control 中的静态方法
返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。
getNoImageIcon() - 类 javax.swing.text.html.ImageView 中的方法
如果不能找到图像，则返回要使用的图标。
getNonContinuousLayoutDivider() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回要在将 splitPane 配置为非连续布局时使用的分隔符。
getNonCriticalExtensionOIDs() - 接口 java.security.cert.X509Extension 中的方法
获取实现此接口的对象所管理的证书/CRL 中，被标记为 NON-CRITICAL 的扩展的 OID 字符串 Set。
getNonHeapMemoryUsage() - 接口 java.lang.management.MemoryMXBean 中的方法
返回 Java 虚拟机使用的非堆内存的当前内存使用量。
getNonMatchingHeaders(String[]) - 类 javax.xml.soap.MimeHeaders 中的方法
返回其名称与给定名称数组中的任何名称都不匹配的所有 MimeHeader 对象。
getNonMatchingMimeHeaders(String[]) - 类 javax.xml.soap.AttachmentPart 中的方法
检索所有名称不匹配给定数组中任一名称的 MimeHeader 对象。
getNonMatchingMimeHeaders(String[]) - 类 javax.xml.soap.SOAPPart 中的方法
检索名称与给定数组中任一名称不匹配的所有 MimeHeader 对象。
getNonRolloverBorder(AbstractButton) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
返回按钮的非翻转边框。
getNoNSSchemaLocation() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取当前 noNamespaceSchemaLocation 的便捷方法。
getNormalBounds() - 类 javax.swing.JInternalFrame 中的方法
如果 JInternalFrame 未处于最大化状态，则返回 getBounds()；否则返回还原 JInternalFrame 后的边界。
getNormalizedComponents(int[], int, float[], int) - 类 java.awt.image.ColorModel 中的方法
在给定标准化分量数组的情况下，返回以标准化形式存在的所有颜色/alpha 分量的数组。
getNormalizedComponents(Object, float[], int) - 类 java.awt.image.ColorModel 中的方法
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。
getNormalizedComponents(int[], int, float[], int) - 类 java.awt.image.ComponentColorModel 中的方法
在给定标准化分量数组的情况下，返回以标准化形式存在的所有颜色/alpha 分量的数组。
getNormalizedComponents(Object, float[], int) - 类 java.awt.image.ComponentColorModel 中的方法
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。
getNormalizingTransform() - 类 java.awt.GraphicsConfiguration 中的方法
返回可与 GraphicsConfiguration 的默认 AffineTransform 连接的 AffineTransform，从而用户空间的 72 单位等于设备空间的 1 英寸。
getNorthPane() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getNotAfter() - 类 java.security.cert.X509Certificate 中的方法
获取证书有效期的 notAfter 日期。
getNotAfter() - 类 javax.security.cert.X509Certificate 中的方法
获取证书有效期的 notAfter 日期。
getNotationName() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
关联的注释的名称。
getNotationName() - 接口 org.w3c.dom.Entity 中的方法
对于未解析实体，则为该实体的表示法名称。
getNotations() - 接口 javax.xml.stream.events.DTD 中的方法
返回一个 List，其中包含在 DTD 中声明的注释。
getNotations() - 接口 org.w3c.dom.DocumentType 中的方法
包含在 DTD 中声明的表示法的 NamedNodeMap。
getNotBefore() - 类 java.security.cert.X509Certificate 中的方法
获取证书有效期的 notBefore 日期。
getNotBefore() - 类 javax.security.cert.X509Certificate 中的方法
获取证书有效期的 notBefore 日期。
getNote() - 类 javax.swing.ProgressMonitor 中的方法
指定随进度消息一起显示的其他注释。
getNotification(String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回通过名称请求的 ModelMBeanNotificationInfo。
getNotification(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getNotification() - 类 javax.management.remote.TargetedNotification 中的方法
发出的通知。
getNotification() - 类 javax.naming.ldap.UnsolicitedNotificationEvent 中的方法
返回未经请求的通知。
getNotificationID() - 类 javax.management.timer.TimerNotification 中的方法
获取此计时器通知的标识符。
getNotificationIDs(String) - 类 javax.management.timer.Timer 中的方法
获得所有与指定类型对应的计时器通知的标识符。
getNotificationIDs(String) - 接口 javax.management.timer.TimerMBean 中的方法
获得所有与指定类型对应的计时器通知的标识符。
getNotificationInfo() - 类 javax.management.MBeanServerDelegate 中的方法

getNotificationInfo() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
返回总是由 RequiredModelMBean 生成的 Notification 数组。
getNotificationInfo() - 类 javax.management.monitor.CounterMonitor 中的方法
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由计数器监视器发送的通知类型。
getNotificationInfo() - 类 javax.management.monitor.GaugeMonitor 中的方法
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由尺度监视器发送的通知类型。
getNotificationInfo() - 类 javax.management.monitor.StringMonitor 中的方法
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由字符串监视器发送的通知类型。
getNotificationInfo() - 接口 javax.management.NotificationBroadcaster 中的方法
返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
getNotificationInfo() - 类 javax.management.NotificationBroadcasterSupport 中的方法

getNotificationInfo() - 类 javax.management.relation.RelationService 中的方法
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和发送的通知类型。
getNotificationInfo() - 类 javax.management.remote.JMXConnectorServer 中的方法
返回一个指示由该 MBean 发送的通知的数组。
getNotificationInfo() - 类 javax.management.StandardEmitterMBean 中的方法

getNotificationInfo() - 类 javax.management.timer.Timer 中的方法

getNotificationMessage(Integer) - 类 javax.management.timer.Timer 中的方法
获得与指定标识符对应的计时器通知的详细消息。
getNotificationMessage(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与指定的标识符对应的计时器通知的详细消息。
getNotifications() - 类 javax.management.MBeanInfo 中的方法
返回 MBean 所发出的通知列表。
getNotifications() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回 MBean 所发送的通知列表。
getNotifications() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回 MBeanNotificationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 所发出的每个通知。
getNotificationType(Integer) - 类 javax.management.timer.Timer 中的方法
获得与指定标识符对应的计时器通知类型。
getNotificationType(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与指定标识符对应的计时器通知类型。
getNotificationUserData(Integer) - 类 javax.management.timer.Timer 中的方法
获得与指定标识符对应的计时器通知用户数据对象。
getNotificationUserData(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与指定的标识符对应的计时器通知用户数据对象。
getNotifTypes() - 类 javax.management.MBeanNotificationInfo 中的方法
返回包含 MBean 可发出的通知类型的字符串数组（用点表示）。
getNotify() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察到的 MBeans 共同的通知的开/关切换值。
getNotify() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取通知的开/关切换值。
getNotifyDiffer() - 类 javax.management.monitor.StringMonitor 中的方法
获取所有观察到的 MBeans 共同的不同通知的开/关切换值。
getNotifyDiffer() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取不同通知的开/关切换值。
getNotifyHigh() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有观察到的 MBean 的公共高阈值通知 (high notification) 的开/关切换值。
getNotifyHigh() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取高阈值通知的开/关切换值。
getNotifyLow() - 类 javax.management.monitor.GaugeMonitor 中的方法
获取所有观察到的 MBean 的公共低阈值通知 (low notification) 的开/关切换值。
getNotifyLow() - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
获取低阈值通知的开/关切换值。
getNotifyMatch() - 类 javax.management.monitor.StringMonitor 中的方法
获取所有观察到的 MBeans 共同的匹配通知的开/关切换值。
getNotifyMatch() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取匹配的通知的开/关切换值。
getNoType(TypeKind) - 接口 javax.lang.model.util.Types 中的方法
返回在实际类型不适用的地方所使用的伪类型。
getNString(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
getNString(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
getNString(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
getNString(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
getNullFormatter() - 类 javax.swing.text.DefaultFormatterFactory 中的方法
返回值为 null 时使用的 formatter。
getNullType() - 接口 javax.lang.model.util.Types 中的方法
返回 null 类型。
getNumBands() - 类 java.awt.image.Raster 中的方法
返回此 Raster 中的 band 数（每像素样本）。
getNumBands() - 类 java.awt.image.SampleModel 中的方法
返回图像数据的总 band 数。
getNumBands() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回此对象指定的 band 数。
getNumBanks() - 类 java.awt.image.DataBuffer 中的方法
返回此 DataBuffer 中存储单元的数量。
getNumber() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列的当前元素的值。
getNumberFormat() - 类 java.text.DateFormat 中的方法
获取此日期/时间格式器用于格式化和解析时间的数字格式器。
getNumberInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的通用数值格式。
getNumberInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的通用数值格式。
getNumberInstance(Locale) - 类 java.text.spi.NumberFormatProvider 中的方法
为指定语言环境返回新的通用 NumberFormat 实例。
getNumberOfButtons() - 类 java.awt.MouseInfo 中的静态方法
返回鼠标上的按钮数。
getNumberOfPages() - 类 java.awt.print.Book 中的方法
返回此 Book 中的页数。
getNumberOfPages() - 接口 java.awt.print.Pageable 中的方法
返回集合中的页面数。
getNumberWaiting() - 类 java.util.concurrent.CyclicBarrier 中的方法
返回当前在屏障处等待的参与者数目。
getNumChars() - 类 java.awt.font.LineMetrics 中的方法
返回文本中的字符数量（char 值），该文本的规格由此 LineMetrics 对象封装。
getNumColorComponents() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 中颜色分量数。
getNumComponents() - 类 java.awt.color.ColorSpace 中的方法
返回此 ColorSpace 的分量数。
getNumComponents() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件的“输入”颜色空间中的颜色分量数。
getNumComponents() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 中分量数（包括 alpha 分量数）。
getNumComponents() - 类 java.awt.image.LookupTable 中的方法
返回查找表中的分量数。
getNumComponents() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回此对象指定的颜色组件的数量。
getNumDataElements() - 类 java.awt.image.ComponentSampleModel 中的方法
返回使用 ComponentSampleModel.getDataElements(int, int, Object, DataBuffer) 和 ComponentSampleModel.setDataElements(int, int, Object, DataBuffer) 方法传输像素所需的数据元素的数量。
getNumDataElements() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回通过 MultiPixelPackedSampleModel.getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) 和 MultiPixelPackedSampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) 方法传输一个像素所需的数据元素数。
getNumDataElements() - 类 java.awt.image.Raster 中的方法
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
getNumDataElements() - 类 java.awt.image.SampleModel 中的方法
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
getNumDataElements() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
getNumDesignAxes() - 接口 java.awt.font.MultipleMaster 中的方法
返回 multiple master 设计控制的数量。
getNumericFunctions() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于此数据库的数学函数的逗号分隔列表。
getNumericValue(char) - 类 java.lang.Character 中的静态方法
返回指定的 Unicode 字符表示的 int 值。
getNumericValue(int) - 类 java.lang.Character 中的静态方法
返回指定字符（Unicode 代码点）表示的 int 值。
getNumFactors() - 类 java.awt.image.RescaleOp 中的方法
返回此 RescaleOp 中使用的缩放因子和偏移量的数量。
getNumGlyphs() - 类 java.awt.Font 中的方法
返回此 Font 中的字形数量。
getNumGlyphs() - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 中的字形数。
getNumImages(boolean) - 类 javax.imageio.ImageReader 中的方法
返回当前输入源中可用的图像数，不包括缩略图。
getNumParameters() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回参数的数量（不包括源图像）。
getNumSources() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回源图像的数量。
getNumThumbnails() - 类 javax.imageio.IIOImage 中的方法
返回此 IIOImage 中存储的缩略图的数量。
getNumThumbnails(int) - 类 javax.imageio.ImageReader 中的方法
返回与给定图像关联的缩略图预览图像的数量。
getNumThumbnailsSupported(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
getNumXTiles() - 类 java.awt.image.BufferedImage 中的方法
返回 x 方向的 tile 数。
getNumXTiles() - 接口 java.awt.image.RenderedImage 中的方法
返回 X 方向的 tile 数量。
getNumYTiles() - 类 java.awt.image.BufferedImage 中的方法
返回 y 方向的 tile 数。
getNumYTiles() - 接口 java.awt.image.RenderedImage 中的方法
返回 Y 方向的 tile 数量。
getObject() - 类 java.security.GuardedObject 中的方法
获取受保护对象；如果 guard 拒绝了对受保护对象的访问，则抛出异常。
getObject() - 类 java.security.SignedObject 中的方法
获取已封装的对象。
getObject(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Object 的形式获取指定参数的值。
getObject(int, Map<String, Class<?>>) - 接口 java.sql.CallableStatement 中的方法
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
getObject(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Object 的形式获取参数的值。
getObject(String, Map<String, Class<?>>) - 接口 java.sql.CallableStatement 中的方法
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
getObject(Map<String, Class<?>>) - 接口 java.sql.Ref 中的方法
获取引用对象并使用给定类型映射表将其映射到 Java 类型。
getObject() - 接口 java.sql.Ref 中的方法
获取此 Ref 对象引用的 SQL 结构类型实例。
getObject(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
getObject(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
getObject(int, Map<String, Class<?>>) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
getObject(String, Map<String, Class<?>>) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
getObject(String) - 类 java.util.ResourceBundle 中的方法
从此资源包或它的某个父包中获取给定键的对象。
getObject(Key) - 类 javax.crypto.SealedObject 中的方法
获取原始（封装的）对象。
getObject(Cipher) - 类 javax.crypto.SealedObject 中的方法
获取原始（封装的）对象。
getObject(Key, String) - 类 javax.crypto.SealedObject 中的方法
获取原始（封装的）对象。
getObject() - 类 javax.naming.Binding 中的方法
检索绑定到此绑定名称的对象。
getObject() - 类 javax.naming.spi.DirStateFactory.Result 中的方法
检索要绑定的对象。
getObject() - 类 javax.sql.rowset.serial.SerialJavaObject 中的方法
返回一个 Object，它是此 SerialJavaObject 对象的副本。
getObject(Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialRef 中的方法
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
getObject() - 类 javax.sql.rowset.serial.SerialRef 中的方法
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
getObject() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getObject() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回对 Java 内容树中对象的引用（如果可用）。
getObjectArrayMaxLength(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回指定元素中可用于定义 Object 引用的最大数组元素数。
getObjectArrayMaxLength(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectArrayMinLength(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回指定元素中可用于定义 Object 引用的最小数组元素数。
getObjectArrayMinLength(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectClass(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回存储在元素中的 Class 类型的 Object 引用。
getObjectClass(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectDefaultValue(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回包含指定元素中 Object 引用的默认值的 Object。
getObjectDefaultValue(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectEnumerations(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。
getObjectEnumerations(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectForLayer(int) - 类 javax.swing.JLayeredPane 中的方法
返回与指定层关联的 Integer 对象。
getObjectInstance(ObjectName) - 接口 javax.management.MBeanServer 中的方法

getObjectInstance(ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
getObjectInstance(ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
getObjectInstance(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法

getObjectInstance(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法

getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - 类 javax.naming.spi.DirectoryManager 中的静态方法
为指定对象、属性和环境创建一个对象实例。
getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - 接口 javax.naming.spi.DirObjectFactory 中的方法
使用位置或引用信息以及指定的属性创建一个对象。
getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - 类 javax.naming.spi.NamingManager 中的静态方法
为指定对象和环境创建一个对象实例。
getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - 接口 javax.naming.spi.ObjectFactory 中的方法
使用指定的位置或引用信息创建一个对象。
getObjectMaxValue(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回指定元素中 Object 引用的最大合法值。
getObjectMaxValue(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectMinValue(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回指定元素中 Object 引用的最小合法值。
getObjectMinValue(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObjectName() - 类 javax.management.MBeanServerInvocationHandler 中的方法
MBean 服务器中 MBean 的名称，一些方法将转发到该 MBean。
getObjectName() - 类 javax.management.ObjectInstance 中的方法
返回对象名部分。
getObjectName() - 类 javax.management.relation.RelationNotification 中的方法
返回创建/移除/更新的关系的 ObjectName。
getObjectParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
获取作为对象的参数。
getObjectPendingFinalizationCount() - 接口 java.lang.management.MemoryMXBean 中的方法
返回其终止被挂起的对象的近似数目。
getObjects() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回一个可修改的列表，由包含在此 XMLSignature 中的 XMLObject 组成。
getObjectSize(Object) - 接口 java.lang.instrument.Instrumentation 中的方法
返回指定对象使用的特定于实现的近似存储量。
getObjectStreamClass() - 类 java.io.ObjectInputStream.GetField 中的方法
获取描述流中字段的 ObjectStreamClass。
getObjectValueType(String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回以 VALUE_ 开头的枚举值之一，指示允许用于 Object 引用的值（枚举、范围或数组）的类型。
getObjectValueType(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getObservedAttribute() - 类 javax.management.monitor.Monitor 中的方法
获取要观察的属性。
getObservedAttribute() - 接口 javax.management.monitor.MonitorMBean 中的方法
获取要观察的属性。
getObservedAttribute() - 类 javax.management.monitor.MonitorNotification 中的方法
获取此监视器通知的被观察属性。
getObservedObject() - 类 javax.management.monitor.Monitor 中的方法
已过时。 从 JMX 1.2 开始，由 Monitor.getObservedObjects() 取代
getObservedObject() - 接口 javax.management.monitor.MonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 MonitorMBean.getObservedObjects() 取代
getObservedObject() - 类 javax.management.monitor.MonitorNotification 中的方法
获取此监视器通知的被观察对象。
getObservedObjects() - 类 javax.management.monitor.Monitor 中的方法
返回一个包含要观察的对象的数组。
getObservedObjects() - 接口 javax.management.monitor.MonitorMBean 中的方法
返回一个包含要观察的对象的数组。
getOctetStream() - 类 javax.xml.crypto.OctetStreamData 中的方法
返回此 OctetStreamData 的输入流。
getOffendingNode() - 异常 javax.imageio.metadata.IIOInvalidTreeException 中的方法
返回导致解析错误的 Node。
getOffscreenBuffer(Component, int, int) - 类 javax.swing.RepaintManager 中的方法
返回屏幕外缓冲区，它应用作带有组件 c 的双缓冲区。
getOffset(int, int) - 类 java.awt.image.ComponentSampleModel 中的方法
获取像素 (x,y) 的第一个 band 的偏移量。
getOffset(int, int, int) - 类 java.awt.image.ComponentSampleModel 中的方法
获取像素 (x,y) 的 band b 的偏移量。
getOffset() - 类 java.awt.image.DataBuffer 中的方法
返回数组元素中默认存储单元的偏移量。
getOffset() - 类 java.awt.image.LookupTable 中的方法
返回偏移量。
getOffset(int, int) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回数据数组元素中像素 (x, y) 的偏移量。
getOffset(int, int) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回像素 (x,y)（在数据数组元素中）的偏移量。
getOffset() - 类 java.io.ObjectStreamField 中的方法
实例数据中字段的偏移量。
getOffset() - 类 java.net.DatagramPacket 中的方法
返回将要发送或接收到的数据的偏移量。
getOffset() - 类 java.text.CollationElementIterator 中的方法
返回源文本中对应于下一个 collation 元素的字符偏移量。
getOffset(long) - 类 java.util.SimpleTimeZone 中的方法
从给定时间的 UTC 返回此时区的偏移量。
getOffset(int, int, int, int, int, int) - 类 java.util.SimpleTimeZone 中的方法
返回以毫秒为单位的本地时间与 UTC 之间的差别，对于指定日期和时间，把原始偏移量和夏令时的效果同时考虑在内。
getOffset(int, int, int, int, int, int) - 类 java.util.TimeZone 中的方法
获取当前日期的时区偏移量（在夏令时情况下进行修改）。
getOffset(long) - 类 java.util.TimeZone 中的方法
从给定日期的 UTC 返回此时区的偏移量。
getOffset() - 类 javax.imageio.stream.IIOByteBuffer 中的方法
返回 getData 返回的字节数组中的偏移量，感兴趣的数据从该处开始。
getOffset() - 类 javax.management.monitor.CounterMonitor 中的方法
获取所有观察到的 MBeans 共同的偏移量值。
getOffset() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取偏移值。
getOffset() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的枚举类使用的最小整数值。
getOffset() - 类 javax.print.attribute.standard.Finishings 中的方法
返回 Finishings 类所使用的最小整数值。
getOffset() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
返回类 OrientationRequested 所使用的最小整数值。
getOffset() - 类 javax.print.attribute.standard.PrintQuality 中的方法
返回类 PrintQuality 所使用的最小整数值。
getOffset() - 接口 javax.swing.event.DocumentEvent 中的方法
返回文档中更改开始的偏移量。
getOffset() - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法

getOffset() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
返回文档中更改开始位置的偏移量。
getOffset(int, int) - 类 javax.swing.text.BoxView 中的方法
获取特定子级当前布局的偏移量。
getOffset() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得起始偏移量。
getOffset() - 接口 javax.swing.text.Position 中的方法
获取文档内的当前偏移量。
getOffset() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getOffset() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回字节偏移量（如果可用）。
getOffsetHit(int) - 类 java.awt.font.TextHitInfo 中的方法
创建一个 TextHitInfo，其字符索引从此 TextHitInfo 的 charIndex 偏移 delta。
getOffsets() - 类 java.awt.image.DataBuffer 中的方法
返回所有存储单元的偏移量（按数组元素）。
getOffsets(float[]) - 类 java.awt.image.RescaleOp 中的方法
返回给定数组中的偏移量。
getOldBinding() - 类 javax.naming.event.NamingEvent 中的方法
检索更改前对象的绑定。
getOldLeadSelectionPath() - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回以前是前导路径的路径。
getOldRoleValue() - 类 javax.management.relation.RelationNotification 中的方法
返回更新的角色的旧值（仅限于角色更新）。
getOldState() - 类 java.awt.event.WindowEvent 中的方法
对于 WINDOW_STATE_CHANGED 事件，返回以前的窗口状态。
getOldValue() - 类 java.beans.PropertyChangeEvent 中的方法
获取属性的旧值，以 Object 的形式表示。
getOldValue() - 类 javax.management.AttributeChangeNotification 中的方法
获得已更改属性的旧值。
getOmni() - 接口 javax.sound.midi.MidiChannel 中的方法
获得当前的 omni 模式。
getOOBInline() - 类 java.net.Socket 中的方法
测试是否启用 OOBINLINE。
getOpenIcon() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回用于表示扩展的非叶节点的图标。
getOpenType() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性值的开放类型。
getOpenType() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例描述的参数值的开放类型。
getOpenType() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例描述的参数值的开放类型。
getOperatingSystemMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回运行 Java 虚拟机的操作系统的管理 Bean。
getOperation() - 类 java.rmi.server.Operation 中的方法
已过时。 无替代版本
getOperation(String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回通过名称请求的 ModelMBeanOperationInfo。
getOperation(String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法

getOperations() - 接口 java.rmi.server.Skeleton 中的方法
已过时。 无替代版本
getOperations() - 类 javax.management.MBeanInfo 中的方法
返回 MBean 的操作列表。
getOperations() - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
返回 MBean 的操作列表。
getOperations() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回 OpenMBeanOperationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例所描述的 open MBean 中的每个操作。
getOppositeComponent() - 类 java.awt.event.FocusEvent 中的方法
返回此焦点更改中涉及的另一个 Component。
getOppositeWindow() - 类 java.awt.event.WindowEvent 中的方法
返回在此焦点或活动性变化中所涉及的其他 Window。
getOptimizeHuffmanTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回传入对 setOptimizeHuffmanTables 的最近一次调用中的值；如果从未调用 setOptimizeHuffmanTables，则返回 false。
getOption(int) - 接口 java.net.SocketOptions 中的方法
获取选项的值。
getOptions() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回传递给注释处理工具的特定于 processor 的选项。
getOptions() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取确认选项。
getOptions() - 类 javax.security.auth.login.AppConfigurationEntry 中的方法
获取为此 LoginModule 配置的选项。
getOptions() - 类 javax.swing.JOptionPane 中的方法
返回用户可以作出的选择。
getOptionType() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取选项类型。
getOptionType() - 类 javax.swing.JOptionPane 中的方法
返回显示的选项类型。
getOrder() - 类 java.security.spec.ECParameterSpec 中的方法
返回生成器的顺序。
getOrientation() - 接口 java.awt.Adjustable 中的方法
获取此可调整对象的方向。
getOrientation(Locale) - 类 java.awt.ComponentOrientation 中的静态方法
返回适合于给定区域的方向。
getOrientation(ResourceBundle) - 类 java.awt.ComponentOrientation 中的静态方法
已过时。 在 J2SE 1.4 中，使用 ComponentOrientation.getOrientation(java.util.Locale)。
getOrientation() - 类 java.awt.print.PageFormat 中的方法
返回此 PageFormat 的方向。
getOrientation() - 类 java.awt.Scrollbar 中的方法
返回此滚动条的方向。
getOrientation() - 类 java.awt.ScrollPaneAdjustable 中的方法
返回此滚动条的方向。
getOrientation() - 类 javax.swing.JProgressBar 中的方法
根据进度条的方向返回 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
getOrientation() - 类 javax.swing.JScrollBar 中的方法
返回组件的方向（横向或纵向）。
getOrientation() - 类 javax.swing.JSeparator 中的方法
返回此分隔符的方向。
getOrientation() - 类 javax.swing.JSlider 中的方法
返回此滑块的垂直或者水平方向。
getOrientation() - 类 javax.swing.JSplitPane 中的方法
返回方向。
getOrientation() - 类 javax.swing.JToolBar 中的方法
返回工具栏的当前方向。
getOrientation() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回 JSplitPane 的方向。
getOrientation() - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
当工具栏浮动时，返回工具栏窗口的方向。
getOrientationRequested() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面的打印方向。
getOrigin() - 类 java.awt.PageAttributes 中的方法
返回在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。
getOriginal() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回一个包含此 CachedRowSet 对象原始值的 ResultSet 对象。
getOriginal() - 接口 javax.sql.RowSetInternal 中的方法
获取包含此 RowSet 对象原始值的 ResultSet 对象。
getOriginalRow() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回一个只包含此 CachedRowSet 对象当前行原始值的 ResultSet 对象。
getOriginalRow() - 接口 javax.sql.RowSetInternal 中的方法
获取仅包含当前行原始值的 ResultSet 对象。
getOriginatingNode() - 接口 javax.xml.transform.dom.DOMLocator 中的方法
返回事件发生的节点位置。
getOriginatingProvider() - 类 javax.imageio.ImageReader 中的方法
返回传入构造方法的 ImageReaderSpi。
getOriginatingProvider() - 类 javax.imageio.ImageWriter 中的方法
返回创建此 ImageWriter 的 ImageWriterSpi 对象，如果此对象不是通过 IIORegistry 创建的，则返回 null。
getOtherHit() - 类 java.awt.font.TextHitInfo 中的方法
在插入点的另一侧创建一个 TextHitInfo。
getOtherPrimeInfo() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 otherPrimeInfo；如果仅存在两个素数因子（p 和 q），则返回 null。
getOtherPrimeInfo() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 otherPrimeInfo 的副本，如果仅有两个素数因子（p 和 q），则返回 null。
getOutline() - 类 java.awt.font.GlyphVector 中的方法
返回其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
getOutline(float, float) - 类 java.awt.font.GlyphVector 中的方法
返回在 x、y 处呈现时，其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
getOutline(AffineTransform) - 类 java.awt.font.GraphicAttribute 中的方法
返回表示此 GraphicAttribute 呈现区域的 Shape。
getOutline(AffineTransform) - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回一个表示此 ShapeGraphicAttribute 呈现区域的 Shape。
getOutline(AffineTransform) - 类 java.awt.font.TextLayout 中的方法
返回表示此 TextLayout 的轮廓的 Shape。
getOutput() - 类 javax.imageio.ImageWriter 中的方法
返回 ImageOutputStream 或最近一次调用 setOutput 方法设置的其他 Object如果没有设置目标，则返回 null。
getOutputClass() - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
返回表示必须由输出目标位置实现（以便使用 createOutputStreamInstance 方法在 ImageOutputStream 中“包装”）的类或接口的类型的 Class 对象。
getOutputFormat() - 类 javax.print.StreamPrintService 中的方法
返回此 PrintService 所发出的文档格式。
getOutputFormat() - 类 javax.print.StreamPrintServiceFactory 中的方法
查询该工厂，了解从此工厂获得的打印机所发出的文档的格式。
getOutputLength() - 类 javax.xml.crypto.dsig.spec.HMACParameterSpec 中的方法
返回截断长度。
getOutputProperties() - 接口 javax.xml.transform.Templates 中的方法
获取对应于有效 xsl:output 元素的属性。
getOutputProperties() - 类 javax.xml.transform.Transformer 中的方法
获取转换的输出属性的副本。
getOutputProperty(String) - 类 javax.xml.transform.Transformer 中的方法
获取对转换器有效的输出属性。
getOutputSize(int) - 类 javax.crypto.Cipher 中的方法
根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 update 或 doFinal 操作结果所需的输出缓冲区长度（以字节为单位）。
getOutputSize(int) - 类 javax.crypto.ExemptionMechanism 中的方法
根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 genExemptionBlob 操作结果所需的输出缓冲区长度（以字节为单位）。
getOutputStatement(String) - 接口 javax.script.ScriptEngineFactory 中的方法
返回一个 String，该 String 可用作一个语句来显示使用受支持脚本语言语法的指定 String。
getOutputStream() - 类 java.lang.Process 中的方法
获取子进程的输出流。
getOutputStream() - 类 java.net.Socket 中的方法
返回此套接字的输出流。
getOutputStream() - 类 java.net.SocketImpl 中的方法
返回此套接字的输出流。
getOutputStream() - 类 java.net.URLConnection 中的方法
返回写入到此连接的输出流。
getOutputStream() - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
getOutputStream() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
getOutputStream() - 类 javax.activation.DataHandler 中的方法
获取此 DataHandler 的 OutputStream，以允许重写底层数据。
getOutputStream() - 接口 javax.activation.DataSource 中的方法
此方法返回一个可以写入数据的 OutputStream，如果无法返回，则抛出适当的异常。
getOutputStream() - 类 javax.activation.FileDataSource 中的方法
此方法将返回一个表示数据的 OutputStream；如果不能返回，则抛出 IOException。
getOutputStream() - 类 javax.activation.URLDataSource 中的方法
URL 的 getOutputStream 方法。
getOutputStream() - 类 javax.print.StreamPrintService 中的方法
获得输出流。
getOutputStream() - 类 javax.xml.transform.stream.StreamResult 中的方法
获取通过 setOutputStream 设置的字节流。
getOutputTypes() - 类 javax.imageio.spi.ImageWriterSpi 中的方法
返回 Class 对象数组，指示可用作 setOutput 方法参数的对象类型。
getOutsideBorder() - 类 javax.swing.border.CompoundBorder 中的方法
返回外部边框对象。
getOverwriteMode() - 类 javax.swing.text.DefaultFormatter 中的方法
返回插入字符时的行为。
getOwnedWindows() - 类 java.awt.Window 中的方法
返回包含此窗口当前拥有的所有窗口的数组。
getOwner() - 类 java.awt.Window 中的方法
返回此窗口的所有者。
getOwner() - 类 java.beans.XMLDecoder 中的方法
获得此解码器的所有者。
getOwner() - 类 java.beans.XMLEncoder 中的方法
获得此编码器的所有者。
getOwner() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回目前拥有此锁的线程，如果此锁不被任何线程拥有，则返回 null。
getOwner() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回当前拥有写入锁的线程，如果没有这样的线程，则返回 null。
getOwnerDocument() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回 null，因为 IIOMetadataNode 不属于任何 Document。
getOwnerDocument() - 接口 org.w3c.dom.Node 中的方法
与此节点相关的 Document 对象。
getOwnerElement() - 接口 org.w3c.dom.Attr 中的方法
此属性连接到的 Element 节点；如果未使用此属性，则为 null。
getOwnerlessWindows() - 类 java.awt.Window 中的静态方法
返回一个数组，该数组由此应用程序创建的所有没有所有者的 Window 组成。
getOwnerType() - 接口 java.lang.reflect.ParameterizedType 中的方法
返回 Type 对象，表示此类型是其成员之一的类型。
getP() - 接口 java.security.interfaces.DSAParams 中的方法
返回素数 p。
getP() - 类 java.security.spec.DSAParameterSpec 中的方法
返回素数 p。
getP() - 类 java.security.spec.DSAPrivateKeySpec 中的方法
返回素数 p。
getP() - 类 java.security.spec.DSAPublicKeySpec 中的方法
返回素数 p。
getP() - 类 java.security.spec.ECFieldFp 中的方法
返回此素数有限字段的素数 p。
getP() - 类 javax.crypto.spec.DHParameterSpec 中的方法
返回质数模数 p。
getP() - 类 javax.crypto.spec.DHPrivateKeySpec 中的方法
返回质数模数 p。
getP() - 类 javax.crypto.spec.DHPublicKeySpec 中的方法
返回质数模数 p。
getP1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回起始点。
getP1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回起始点。
getP1() - 类 java.awt.geom.CubicCurve2D 中的方法
返回起始点。
getP1() - 类 java.awt.geom.Line2D.Double 中的方法
返回此 Line2D 的起始 Point2D。
getP1() - 类 java.awt.geom.Line2D.Float 中的方法
返回此 Line2D 的起始 Point2D。
getP1() - 类 java.awt.geom.Line2D 中的方法
返回此 Line2D 的起始 Point2D。
getP1() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
返回起始点。
getP1() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
返回起始点。
getP1() - 类 java.awt.geom.QuadCurve2D 中的方法
返回起始点。
getP2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
返回结束点。
getP2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
返回结束点。
getP2() - 类 java.awt.geom.CubicCurve2D 中的方法
返回结束点。
getP2() - 类 java.awt.geom.Line2D.Double 中的方法
返回此 Line2D 的结束 Point2D。
getP2() - 类 java.awt.geom.Line2D.Float 中的方法
返回此 Line2D 的结束 Point2D。
getP2() - 类 java.awt.geom.Line2D 中的方法
返回此 Line2D 的结束 Point2D。
getP2() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
返回结束点。
getP2() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
返回结束点。
getP2() - 类 java.awt.geom.QuadCurve2D 中的方法
返回结束点。
getPackage() - 类 java.lang.Class 中的方法
获取此类的包。
getPackage(String) - 类 java.lang.ClassLoader 中的方法
返回由此类加载器或其任何祖先所定义的 Package。
getPackage(String) - 类 java.lang.Package 中的静态方法
通过调用方的 ClassLoader 实例中的名称找到一个包。
getPackageElement(CharSequence) - 接口 javax.lang.model.util.Elements 中的方法
返回已给出其完全限定名称的包。
getPackageOf(Element) - 接口 javax.lang.model.util.Elements 中的方法
返回元素的包。
getPackages() - 类 java.lang.ClassLoader 中的方法
返回此类加载器及其祖先所定义的所有 Package。
getPackages() - 类 java.lang.Package 中的静态方法
获得调用方的 ClassLoader 实例当前已知的所有包。
getPacketBufferSize() - 接口 javax.net.ssl.SSLSession 中的方法
获取使用此会话时期望的最大 SSL/TLS 包的当前大小。
getPadding() - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法

getPage() - 类 javax.swing.JEditorPane 中的方法
获得当前正在显示的 URL。
getPageDimension() - 类 java.awt.PrintJob 中的方法
返回页面的维数，以像素为单位。
getPageFormat(int) - 类 java.awt.print.Book 中的方法
返回 pageIndex 指定的页面的 PageFormat。
getPageFormat(int) - 接口 java.awt.print.Pageable 中的方法
返回 pageIndex 指定的页面的 PageFormat。
getPageFormat(PrintRequestAttributeSet) - 类 java.awt.print.PrinterJob 中的方法
使用与受此作业 PrintService 支持的那些值一致的值（即由 getPrintService() 返回的值），以及 attributes 中包含的介质、可打印区域和方向计算 PageFormat。
getPageIncrement() - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 getBlockIncrement() 取代。
getPageRanges() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的页面范围。
getPageResolution() - 类 java.awt.PrintJob 中的方法
返回页面的分辨率，以每英寸的像素为单位。
getPageSize() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回 CachedRowSet 对象的页大小。
getPaint() - 类 java.awt.Graphics2D 中的方法
返回 Graphics2D 上下文中的当前 Paint
getPainter(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
返回将用于绘制的 SynthPainter。
getPainter(GlyphView, int, int) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
创建用于给定 GlyphView 的 painter。
getPainter() - 接口 javax.swing.text.Highlighter.Highlight 中的方法
获取 highlighter 的 painter。
getPaintLabels() - 类 javax.swing.JSlider 中的方法
告知是否绘制标签。
getPaintTicks() - 类 javax.swing.JSlider 中的方法
告知是否绘制刻度标记。
getPaintTrack() - 类 javax.swing.JSlider 中的方法
告知是否绘制滑道（滑块滑动的区域）。
getPaper() - 类 java.awt.print.PageFormat 中的方法
返回与此 PageFormat 相关的 Paper 对象的一个副本。
getParagraphAttributes() - 类 javax.swing.JTextPane 中的方法
获取插入符号位置的当前有效段落属性，如果没有，则返回 null。
getParagraphElement(int) - 类 javax.swing.text.AbstractDocument 中的方法
获得包含给定位置的段落元素。
getParagraphElement(int) - 类 javax.swing.text.DefaultStyledDocument 中的方法
获得位于偏移量 pos 的段落元素。
getParagraphElement(int) - 类 javax.swing.text.PlainDocument 中的方法
获取包含给定位置的段落元素。
getParagraphElement(int) - 接口 javax.swing.text.StyledDocument 中的方法
获取表示包含文档中给定偏移量的段落的元素。
getParagraphElement(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定某个段落/行要使用的元素。
getParamClasses() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回描述该参数的 Class 对象的数组。
getParameter(String) - 类 java.applet.Applet 中的方法
返回 HTML 标记中指定参数的值。
getParameter(String) - 接口 java.applet.AppletStub 中的方法
返回 HTML 标记中命名参数的值。
getParameter(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
如果 paramName 等于 "humanPresentableName"，则返回此 DataFlavor 的得体的名称。
getParameter(String) - 类 java.security.Signature 中的方法
已过时。
getParameter() - 异常 java.sql.DataTruncation 中的方法
指示被截断的值是一个参数值还是一个列值。
getParameter(String) - 类 javax.activation.MimeType 中的方法
获取与给定名称关联的值；如果没有当前关联，则返回 null。
getParameter(String) - 类 javax.print.DocFlavor 中的方法
返回表示 MIME 参数的 String。
getParameter(String) - 接口 javax.script.ScriptEngineFactory 中的方法
返回属性值，该属性的含义可能是特定于实现的。
getParameter(String) - 类 javax.xml.transform.Transformer 中的方法
获取通过 setParameter 显式设置的参数。
getParameter(String) - 接口 org.w3c.dom.DOMConfiguration 中的方法
如果已知，则返回参数的值。
getParameterAnnotations() - 类 java.lang.reflect.Constructor 中的方法
按照声明顺序返回一组数组，这些数组表示通过此 Constructor 对象表示的方法的形参上的注释。
getParameterAnnotations() - 类 java.lang.reflect.Method 中的方法
返回表示按照声明顺序对此 Method 对象所表示方法的形参进行注释的那个数组的数组。
getParameterBlock() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
返回到对当前参数块的一个引用。
getParameterClassName(int) - 接口 java.sql.ParameterMetaData 中的方法
获取 Java 类的完全限定名称，该类的实例应该传递给 PreparedStatement.setObject 方法。
getParameterCount() - 接口 java.sql.ParameterMetaData 中的方法
获取 PreparedStatement 对象中的参数的数量，此 ParameterMetaData 对象包含了该对象的信息。
getParameterDescriptors() - 类 java.beans.MethodDescriptor 中的方法
获得此 MethodDescriptor 每个方法参数的 ParameterDescriptor。
getParameterInfo() - 类 java.applet.Applet 中的方法
返回此 applet 理解的关于参数的信息。
getParameterMetaData() - 接口 java.sql.PreparedStatement 中的方法
获取此 PreparedStatement 对象的参数的编号、类型和属性。
getParameterMode(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的模式。
getParameterName(MBeanConstructorInfo, MBeanParameterInfo, int) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。
getParameterName(MBeanOperationInfo, MBeanParameterInfo, int) - 类 javax.management.StandardMBean 中的方法
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。
getParameterNames() - 接口 org.w3c.dom.DOMConfiguration 中的方法
此 DOMConfiguration 对象支持的参数列表，并且应用程序至少可以为其设置一个值。
getParameters() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回参数的整个 Vector。
getParameters() - 类 java.security.Policy 中的方法
返回 Policy 参数。
getParameters() - 类 java.security.Signature 中的方法
返回与此签名对象一起使用的参数。
getParameters() - 类 java.util.logging.LogRecord 中的方法
获取日志消息的参数。
getParameters() - 类 javax.activation.MimeType 中的方法
获取此对象的参数列表。
getParameters() - 类 javax.crypto.Cipher 中的方法
返回此 Cipher 使用的参数。
getParameters() - 接口 javax.lang.model.element.ExecutableElement 中的方法
返回此 executable 的形参。
getParameters() - 类 javax.net.ssl.CertPathTrustManagerParameters 中的方法
返回此类封装的 CertPathParameters 的副本。
getParameters() - 类 javax.net.ssl.KeyStoreBuilderParameters 中的方法
返回此对象封装的不可修改的 KeyStore.Builder 列表。
getParameters() - 类 javax.security.auth.login.Configuration 中的方法
返回 Configuration 参数。
getParameterSpec(Class<T>) - 类 java.security.AlgorithmParameters 中的方法
返回此参数对象的（透明）规范。
getParameterSpec() - 接口 javax.xml.crypto.AlgorithmMethod 中的方法
返回此 AlgorithmMethod 的算法参数。
getParameterSpec() - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的方法
返回与此 CanonicalizationMethod 关联的特定于算法的输入参数。
getParameterSpec() - 接口 javax.xml.crypto.dsig.DigestMethod 中的方法
返回与此 DigestMethod 关联的特定于算法的输入参数。
getParameterSpec() - 接口 javax.xml.crypto.dsig.SignatureMethod 中的方法
返回此 SignatureMethod 的特定于算法的输入参数。
getParameterSpec() - 接口 javax.xml.crypto.dsig.Transform 中的方法
返回与此 Transform 关联的特定于算法的输入参数。
getParameterType(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的 SQL 类型。
getParameterTypeName(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的特定于数据库的类型名称。
getParameterTypes() - 类 java.lang.reflect.Constructor 中的方法
按照声明顺序返回一组 Class 对象，这些对象表示此 Constructor 对象所表示构造方法的形参类型。
getParameterTypes() - 类 java.lang.reflect.Method 中的方法
按照声明顺序返回 Class 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型。
getParameterTypes() - 接口 javax.lang.model.type.ExecutableType 中的方法
返回此 executable 的形参类型。
getParameterTypes() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 TYPE 属性值的列表。
getParameterValues() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 VALUE 属性值的列表。
getParams() - 接口 java.security.interfaces.DSAKey 中的方法
返回特定于 DSA 的密钥参数。
getParams() - 接口 java.security.interfaces.ECKey 中的方法
返回与此密钥关联的域参数。
getParams() - 类 java.security.spec.ECPrivateKeySpec 中的方法
返回关联的椭圆曲线域参数。
getParams() - 类 java.security.spec.ECPublicKeySpec 中的方法
返回关联的椭圆曲线域参数。
getParams() - 接口 javax.crypto.interfaces.DHKey 中的方法
返回密钥参数。
getParams() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取一个数组，其中包含为此 RowSet 对象命令设置的参数值（包括 Object 和基本类型），如果尚未设置任何参数，则抛出 SQLException 对象。
getParams() - 接口 javax.sql.RowSetInternal 中的方法
获取已为此 RowSet 对象的命令设置的参数。
getParent() - 类 java.awt.Component 中的方法
获取此组件的父级。
getParent() - 类 java.awt.image.Raster 中的方法
返回此 Raster 的父 Raster（如果有），或者 null。
getParent() - 类 java.awt.MenuComponent 中的方法
返回此菜单组件的父容器。
getParent() - 类 java.awt.PopupMenu 中的方法
返回此菜单组件的父容器。
getParent() - 类 java.io.File 中的方法
返回此抽象路径名父目录的路径名字符串；如果此路径名没有指定父目录，则返回 null。
getParent() - 类 java.lang.ClassLoader 中的方法
返回委托的父类加载器。
getParent() - 类 java.lang.ThreadGroup 中的方法
返回此线程组的父线程组。
getParent() - 类 java.net.NetworkInterface 中的方法
如果此接口是子接口，则返回它的父 NetworkInterface；如果它是物理（非虚拟）接口或没有父接口，则返回 null。
getParent() - 接口 java.security.cert.PolicyNode 中的方法
返回此节点的父节点，如果此节点是根节点，则返回 null。
getParent() - 类 java.util.logging.Logger 中的方法
返回此 Logger 的父 logger。
getParent() - 类 java.util.prefs.NodeChangeEvent 中的方法
返回添加或移除节点的父节点。
getParent() - 类 javax.swing.ActionMap 中的方法
返回此 ActionMap 的父级。
getParent() - 类 javax.swing.InputMap 中的方法
获得此 InputMap 的父级。
getParent() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
返回接收方的父级 TreeNode。
getParent() - 类 javax.swing.text.View 中的方法
返回视图的父级。
getParent() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的父节点，如果此节点没有父节点，则返回 null。
getParent() - 接口 javax.swing.tree.TreeNode 中的方法
返回接收者的父 TreeNode。
getParent() - 类 javax.xml.crypto.dsig.dom.DOMSignContext 中的方法
返回父节点。
getParent() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
获取此实例的父实例。
getParent() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
获取此实例的父实例。
getParent() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
获取父读取器。
getParent() - 接口 org.xml.sax.XMLFilter 中的方法
获取父阅读器。
getParentDirectory(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
返回 dir 的父目录。
getParentElement() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素的父级。
getParentElement() - 接口 javax.swing.text.Element 中的方法
获得父元素。
getParentElement() - 接口 javax.xml.soap.Node 中的方法
返回此 Node 对象的父元素。
getParentFile() - 类 java.io.File 中的方法
返回此抽象路径名父目录的抽象路径名；如果此路径名没有指定父目录，则返回 null。
getParentLoggerName(String) - 接口 java.util.logging.LoggingMXBean 中的方法
返回指定 logger 的父 logger 名称。
getParentNode() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的父节点。
getParentNode() - 接口 org.w3c.dom.Node 中的方法
此节点的父节点。
getParentPath() - 类 javax.swing.tree.TreePath 中的方法
返回包含除最后一个路径组件之外的此对象所有元素的路径。
getParser() - 类 javax.swing.text.html.HTMLDocument 中的方法
返回将 HTML 插入现有文档时所使用的解析器。
getParser() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取要用于读取 HTML 流的解析器。
getParser() - 类 javax.xml.parsers.SAXParser 中的方法
返回由此类的实现封装的 SAX 解析器。
getPartialSize(int, int) - 类 javax.swing.text.ParagraphView 中的方法
返回 startOffset 和 endOffset 之间的视图使用的大小。
getPartialSpan(int, int) - 类 javax.swing.text.GlyphView 中的方法
确定沿与选项卡扩展同轴的区域是否为该视图的一部分。
getPartialSpan(int, int) - 接口 javax.swing.text.TabableView 中的方法
确定部分视图沿与制表符扩展相同的轴的跨距。
getParties() - 类 java.util.concurrent.CyclicBarrier 中的方法
返回要求启动此 barrier 的参与者数目。
getPassword() - 类 java.net.PasswordAuthentication 中的方法
返回用户密码。
getPassword() - 类 java.security.KeyStore.PasswordProtection 中的方法
获取密码。
getPassword() - 接口 javax.crypto.interfaces.PBEKey 中的方法
返回密码。
getPassword() - 类 javax.crypto.spec.PBEKeySpec 中的方法
返回密码的一份副本。
getPassword() - 类 javax.security.auth.callback.PasswordCallback 中的方法
获取检索到的密码。
getPassword() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回用于创建此 RowSet 对象的数据库连接的密码。
getPassword() - 接口 javax.sql.RowSet 中的方法
获取用于创建数据库连接的密码。
getPassword() - 类 javax.swing.JPasswordField 中的方法
返回此 TextComponent 中所包含的文本。
getPasswordAuthentication() - 类 java.net.Authenticator 中的方法
需要密码授权时调用。
getPasteAction() - 类 javax.swing.TransferHandler 中的静态方法
返回一个从剪贴板执行粘贴操作的 Action。
getPatch() - 类 javax.sound.midi.Instrument 中的方法
获得 Patch 对象，该对象指示此乐器在合成器中存储位置处的库和程序号。
getPatchList() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 中引用的包列表。
getPath() - 类 java.io.File 中的方法
将此抽象路径名转换为一个路径名字符串。
getPath() - 类 java.net.HttpCookie 中的方法
返回浏览器将此 cookie 返回到的服务器上的路径。
getPath() - 类 java.net.URI 中的方法
返回此 URI 的已解码的路径组成部分。
getPath() - 类 java.net.URL 中的方法
获取此 URL 的路径部分。
getPath() - 类 javax.swing.event.MenuDragMouseEvent 中的方法
返回选定菜单项所在的路径。
getPath() - 类 javax.swing.event.MenuKeyEvent 中的方法
返回到达此事件引用的菜单项的路径。
getPath() - 类 javax.swing.event.TreeExpansionEvent 中的方法
返回到达已被扩展/折叠的值的路径。
getPath() - 类 javax.swing.event.TreeModelEvent 中的方法
从此事件包装的 TreePath 实例中获得对象数组的便捷方法。
getPath() - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回第一个路径元素。
getPath() - 类 javax.swing.JTree.DropLocation 中的方法
返回树中应该用来放入放置数据的路径。
getPath() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getPath() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回从根到达此节点的路径。
getPath() - 类 javax.swing.tree.TreePath 中的方法
返回有序的 Objects 数组，它包含此 TreePath 的组件。
getPathBetweenRows(int, int) - 类 javax.swing.JTree 中的方法
返回 JTreePath 实例，它表示 index0 和 index1（包括 index1）之间的路径。
getPathBounds(TreePath) - 类 javax.swing.JTree 中的方法
返回将指定节点绘入的 Rectangle。
getPathBounds(JTree, TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
getPathBounds(JTree, TreePath) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getPathBounds 方法。
getPathBounds(JTree, TreePath) - 类 javax.swing.plaf.TreeUI 中的方法
返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
getPathClosestTo(int, int) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回最接近 x,y 节点的路径。
getPathClosestTo(int, int) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回最接近 x,y 的节点的路径。
getPathClosestTo(int, int) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回最接近 x,y 的节点的路径。
getPathComponent(int) - 类 javax.swing.tree.TreePath 中的方法
返回指定索引位置的路径组件。
getPathCount() - 类 javax.swing.tree.TreePath 中的方法
返回路径中的元素数。
getPathForLocation(int, int) - 类 javax.swing.JTree 中的方法
返回指定位置处的节点路径。
getPathForRow(int) - 类 javax.swing.JTree 中的方法
返回指定行的路径。
getPathForRow(JTree, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回传入的 row 的路径。
getPathForRow(JTree, int) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getPathForRow 方法。
getPathForRow(JTree, int) - 类 javax.swing.plaf.TreeUI 中的方法
返回传入的 row 的路径。
getPathForRow(int) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回传入行的路径。
getPathForRow(int) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回传入行的路径。
getPathForRow(int) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回 row 的路径。
getPathIterator(AffineTransform) - 类 java.awt.geom.Arc2D 中的方法
返回定义弧边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Area 中的方法
为此 Area 对象的轮廓创建一个 PathIterator。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.Area 中的方法
为此 Area 对象的变平轮廓创建 PathIterator。
getPathIterator(AffineTransform) - 类 java.awt.geom.CubicCurve2D 中的方法
返回定义形状边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.CubicCurve2D 中的方法
返回定义变平形状边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Ellipse2D 中的方法
返回定义此 Ellipse2D 边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Line2D 中的方法
返回定义此 Line2D 边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.Line2D 中的方法
返回定义此变平的 Line2D 边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Path2D.Double 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Path2D.Float 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.Path2D 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.QuadCurve2D 中的方法
返回定义此 QuadCurve2D 的形状边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.QuadCurve2D 中的方法
返回定义此 QuadCurve2D 的变平形状边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.geom.Rectangle2D 中的方法
返回定义此 Rectangle2D 边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.Rectangle2D 中的方法
返回定义变平的 Rectangle2D 边界的迭代对象。
getPathIterator(AffineTransform, double) - 类 java.awt.geom.RectangularShape 中的方法
返回一个迭代器对象，它可沿 Shape 对象的边界进行迭代，并提供对 Shape 对象轮廓几何形状平面视图的访问。
getPathIterator(AffineTransform) - 类 java.awt.geom.RoundRectangle2D 中的方法
返回定义此 RoundRectangle2D 边界的迭代对象。
getPathIterator(AffineTransform) - 类 java.awt.Polygon 中的方法
返回迭代器对象，此对象沿此 Polygon 的边界进行迭代，并且提供对此 Polygon 轮廓的几何形状的访问。
getPathIterator(AffineTransform, double) - 类 java.awt.Polygon 中的方法
返回迭代器对象，此对象沿 Shape 的边界进行迭代，并且提供了对 Shape 轮廓的几何形状的访问。
getPathIterator(AffineTransform) - 接口 java.awt.Shape 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
getPathIterator(AffineTransform, double) - 接口 java.awt.Shape 中的方法
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
getPaths() - 类 javax.swing.event.TreeSelectionEvent 中的方法
返回已经添加到该选择中或已从中移除的路径。
getPathToNames() - 类 java.security.cert.X509CertSelector 中的方法
返回 pathToNames 标准的一个副本。
getPathToRoot(TreeNode, int) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
构建节点的父节点一直到根节点（包括根节点），其中源节点是返回数组中的最后一个元素。
getPathToRoot(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
getPathToRoot(TreeNode, int) - 类 javax.swing.tree.DefaultTreeModel 中的方法
向上构建节点的父节点一直到根节点（包括根节点），其中原始节点是返回数组中的最后一个元素。
getPattern() - 异常 java.util.regex.PatternSyntaxException 中的方法
获取错误的正则表达式模式。
getPatternSeparator() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于在模式中分隔正数和负数子模式的字符。
getPayload() - 接口 javax.xml.ws.LogicalMessage 中的方法
以 XML 源的形式获取消息负载，可以在相同的 LogicalMessage 实例上多次调用，总是返回可以用来检索整个消息负载的新的 Source。
getPayload(JAXBContext) - 接口 javax.xml.ws.LogicalMessage 中的方法
以 JAXB 对象的形式获取消息负载。
getPCSType() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件连接空间 (PCS) 的颜色空间类型。
getPeakThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
返回自从 Java 虚拟机启动或峰值重置以来峰值活动线程计数。
getPeakUsage() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回自 Java 虚拟机启动以来或自峰值重置以来此内存池的峰值内存使用量。
getPeer() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体；由 boolean isDisplayable() 取代。
getPeer() - 类 java.awt.Font 中的方法
已过时。 现在，字体呈现与平台无关。
getPeer() - 类 java.awt.MenuComponent 中的方法
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体。
getPeerCertificateChain() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回同位体的标识，同位体是作为定义会话的一部分而标识的。
getPeerCertificateChain() - 接口 javax.net.ssl.SSLSession 中的方法
返回同级身份，该同级身份被标识作为定义会话的一部分。
getPeerCertificates() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回同位体的标识，同位体是作为定义会话的一部分而建立的。
getPeerCertificates() - 接口 javax.net.ssl.SSLSession 中的方法
返回同级身份，该同级身份是作为定义会话的一部分而建立的。
getPeerHost() - 类 javax.net.ssl.SSLEngine 中的方法
返回同位体的主机名。
getPeerHost() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话中同位体的主机名称。
getPeerPort() - 类 javax.net.ssl.SSLEngine 中的方法
返回同位体的端口号。
getPeerPort() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话中同位体的端口号。
getPeerPrincipal() - 类 java.net.SecureCacheResponse 中的方法
返回服务器的主体，该主体是作为在获得了网络资源的初始连接期间定义会话的一部分建立的。
getPeerPrincipal() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回同位体的标识，同位体是作为定义会话的一部分而建立的。
getPeerPrincipal() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回服务器的主体，它是作为定义会话的一部分而建立的。
getPeerPrincipal() - 接口 javax.net.ssl.SSLSession 中的方法
返回同级身份，该同级身份是作为定义会话的一部分而建立的。
getPercent() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于百分数符号的字符。
getPercentComplete() - 类 javax.swing.JProgressBar 中的方法
返回进度条的完成百分比。
getPercentInstance() - 类 java.text.NumberFormat 中的静态方法
返回当前默认语言环境的百分比格式。
getPercentInstance(Locale) - 类 java.text.NumberFormat 中的静态方法
返回指定语言环境的百分比格式。
getPercentInstance(Locale) - 类 java.text.spi.NumberFormatProvider 中的方法
返回新的 NumberFormat 实例，此实例为指定语言环境格式化百分比值。
getPeriod(Integer) - 类 javax.management.timer.Timer 中的方法
获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
getPeriod(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
getPermanentFocusOwner() - 类 java.awt.KeyboardFocusManager 中的方法
如果持久焦点所有者与调用线程位于同一个上下文中，则返回持久焦点所有者。
getPerMill() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于千分数符号的字符。
getPermission() - 类 java.net.HttpURLConnection 中的方法

getPermission() - 类 java.net.URLConnection 中的方法
返回一个权限对象，其代表建立此对象表示的连接所需的权限。
getPermission() - 异常 java.security.AccessControlException 中的方法
获取与此异常关联的 Permission 对象；如果不存在相应的 Permission 对象，则为 null。
getPermissions(CodeSource) - 类 java.net.URLClassLoader 中的方法
返回给定 codesource 对象的权限。
getPermissions(Principal) - 接口 java.security.acl.Acl 中的方法
返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
getPermissions(CodeSource) - 类 java.security.Policy 中的方法
返回一个 PermissionCollection 对象，它包含授予指定 CodeSource 的权限集。
getPermissions(ProtectionDomain) - 类 java.security.Policy 中的方法
返回一个 PermissionCollection 对象，它包含授予指定 ProtectionDomain 的权限集。
getPermissions() - 类 java.security.ProtectionDomain 中的方法
返回授予此域的静态权限。
getPermissions(CodeSource) - 类 java.security.SecureClassLoader 中的方法
返回给定的 CodeSource 对象的权限。
getPermissions(Subject, CodeSource) - 类 javax.security.auth.Policy 中的方法
已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。
getPersistenceDelegate(Class<?>) - 类 java.beans.Encoder 中的方法
返回给定类型的持久委托。
getPIData() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getPIData() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取处理指令的数据节
getPITarget() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getPITarget() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取处理指令的目标
getPitchBend() - 接口 javax.sound.midi.MidiChannel 中的方法
获得此通道的向上或向下的音高偏移量。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
在 int 数组中返回指定像素的所有样本。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
返回对应 int 数组中指定像素的所有样本，每个数组元素对应一个样本。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回 int 数组第一个元素中的指定单个 band 像素。
getPixel(int, int, int[]) - 类 java.awt.image.Raster 中的方法
以 int 数组形式返回指定像素的样本。
getPixel(int, int, float[]) - 类 java.awt.image.Raster 中的方法
以 float 数组形式返回指定像素的样本。
getPixel(int, int, double[]) - 类 java.awt.image.Raster 中的方法
以 double 数组形式返回指定像素的样本。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 int 数组中返回指定像素的样本，每个数组元素对应一个样本。
getPixel(int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 float 数组中返回指定像素的样本。
getPixel(int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 double 数组中返回指定像素的样本。
getPixel(int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
在一个 int 数组中返回对应于指定像素的所有样本。
getPixelBitStride() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回像素位间距，以位为单位。
getPixelBounds(FontRenderContext, float, float) - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 在图形中以给定 FontRenderContext 在给定位置处呈现时的像素边界。
getPixelBounds(FontRenderContext, float, float) - 类 java.awt.font.TextLayout 中的方法
返回在图形中使用给定 FontRenderContext 在给定位置处呈现 TextLayout 时的像素边界。
getPixelColor(int, int) - 类 java.awt.Robot 中的方法
返回给定屏幕坐标处的像素颜色。
getPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
在 int 数组中返回指定像素矩形的所有样本，每个数据数组元素对应一个样本。
getPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
返回对应 int 数组中像素指定矩形区域的所有样本（每个数组元素对应一个样本）。
getPixels() - 类 java.awt.image.PixelGrabber 中的方法
获取像素缓冲区。
getPixels(int, int, int, int, int[]) - 类 java.awt.image.Raster 中的方法
返回一个包含像素矩形所有样本的 int 数组，每个数组元素对应一个样本。
getPixels(int, int, int, int, float[]) - 类 java.awt.image.Raster 中的方法
返回一个包含像素矩形所有样本的 float 数组，每个数组元素对应一个样本。
getPixels(int, int, int, int, double[]) - 类 java.awt.image.Raster 中的方法
返回一个包含像素矩形所有样本的 double 数组，每个数组元素对应一个样本。
getPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 int 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
getPixels(int, int, int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 float 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
getPixels(int, int, int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 double 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
getPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
在一个 int 数组中返回对应于指定像素矩形的所有样本，每个数组元素对应一个样本。
getPixelSize() - 类 java.awt.image.ColorModel 中的方法
返回由此 ColorModel 描述的每像素的位数。
getPixelStride() - 类 java.awt.image.ComponentSampleModel 中的方法
返回此 ComponentSampleModel 的像素间距。
getPlaceholder() - 类 javax.swing.text.MaskFormatter 中的方法
如果值未完全填充掩码，则返回要使用的 String。
getPlaceholderCharacter() - 类 javax.swing.text.MaskFormatter 中的方法
返回用来替代值中没有的字符的字符（即用户必须填充它们）。
getPlatformMBeanServer() - 类 java.lang.management.ManagementFactory 中的静态方法
返回平台 MBeanServer。
getPluginClassName() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回与此服务提供者关联的 ImageReader 或 ImageWriter 插件的完全限定类名称。
getPoint() - 类 java.awt.event.MouseEvent 中的方法
返回事件相对于源组件的 x, y 坐标。
getPoint1() - 类 java.awt.GradientPaint 中的方法
返回着第一种颜色的点 P1 的副本。
getPoint2() - 类 java.awt.GradientPaint 中的方法
返回着第二种颜色的点 P2 的副本。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.AffineTransformOp 中的方法
返回与源图像中给定点对应的目标点的位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.BandCombineOp 中的方法
返回与源 Raster 中给定点对应的目标点的位置。
getPoint2D(Point2D, Point2D) - 接口 java.awt.image.BufferedImageOp 中的方法
返回与源图像中给定点对应的目标点的位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.ColorConvertOp 中的方法
返回源中给定点的目标点的位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.ConvolveOp 中的方法
返回源中给定点的目标点位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.LookupOp 中的方法
在给定源图像中某个点的情况下，返回目标点的位置。
getPoint2D(Point2D, Point2D) - 接口 java.awt.image.RasterOp 中的方法
在给定源 Raster 中一个点的情况下，返回目标点的位置。
getPoint2D(Point2D, Point2D) - 类 java.awt.image.RescaleOp 中的方法
给定源中的一个点，返回对应目标点的位置。
getPointerInfo() - 类 java.awt.MouseInfo 中的静态方法
返回表示鼠标指针当前位置的 PointerInfo 实例。
getPointSize(int) - 类 javax.swing.text.html.StyleSheet 中的方法
在给定大小索引的情况下返回点大小。
getPointSize(String) - 类 javax.swing.text.html.StyleSheet 中的方法
如果给定字符串（如 "+2"、"-2" 或 "2"），则返回点大小值。
getPolicy() - 类 java.security.cert.X509CertSelector 中的方法
返回策略标准。
getPolicy() - 类 java.security.Policy 中的静态方法
返回安装的 Policy 对象。
getPolicy() - 类 javax.security.auth.Policy 中的静态方法
已过时。 返回安装的 Policy 对象。
getPolicyQualifier() - 类 java.security.cert.PolicyQualifierInfo 中的方法
返回此 PolicyQualifierInfo 的 qualifier 字段的 ASN.1 DER 编码形式。
getPolicyQualifierId() - 类 java.security.cert.PolicyQualifierInfo 中的方法
返回此 PolicyQualifierInfo 的 policyQualifierId 字段。
getPolicyQualifiers() - 接口 java.security.cert.PolicyNode 中的方法
返回与此节点所表示的有效策略相关联的策略限定符集。
getPolicyQualifiersRejected() - 类 java.security.cert.PKIXParameters 中的方法
获取 PolicyQualifiersRejected 标志。
getPolicyTree() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回 PKIX 证书路径验证算法所得的有效策略树的根节点。
getPolyPressure(int) - 接口 javax.sound.midi.MidiChannel 中的方法
获得指定键被按下的力度。
getPooledConnection() - 接口 javax.sql.ConnectionPoolDataSource 中的方法
尝试建立可用作入池连接的物理数据库连接。
getPooledConnection(String, String) - 接口 javax.sql.ConnectionPoolDataSource 中的方法
尝试建立可用作入池连接的物理数据库连接。
getPoolName() - 类 java.lang.management.MemoryNotificationInfo 中的方法
返回触发此通知的内存池的名称。
getPoolSize() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回池中的当前线程数。
getPopup(JPopupMenu, int, int) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getPopup 方法。
getPopup(JPopupMenu, int, int) - 类 javax.swing.plaf.PopupMenuUI 中的方法
返回将负责显示 JPopupMenu 的 Popup。
getPopup(Component, Component, int, int) - 类 javax.swing.PopupFactory 中的方法
为包含 Component contents 的 Component owner 创建 Popup。
getPopupHeightForRowCount(int) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
基于当前 ListCellRenderer 和最大行数检索弹出部分的高度。
getPopupLocation(MouseEvent) - 类 javax.swing.JComponent 中的方法
返回在此组件坐标系统中显示弹出式菜单的首选位置。
getPopupMenu() - 类 java.awt.TrayIcon 中的方法
返回与此 TrayIcon 关联的弹出菜单。
getPopupMenu() - 类 javax.swing.JMenu 中的方法
返回与此菜单关联的弹出菜单。
getPopupMenuListeners() - 类 javax.swing.JComboBox 中的方法
返回利用 addPopupMenuListener() 添加到此 JComboBox 的所有 PopupMenuListener 组成的数组。
getPopupMenuListeners() - 类 javax.swing.JPopupMenu 中的方法
返回利用 addPopupMenuListener() 添加到此 JMenuItem 的所有 PopupMenuListener 组成的数组。
getPopupMenuOrigin() - 类 javax.swing.JMenu 中的方法
计算 JMenu 的弹出菜单的原点。
getPort() - 类 java.net.DatagramPacket 中的方法
返回某台远程主机的端口号，此数据报将要发往该主机或者是从该主机接收到的。
getPort() - 类 java.net.DatagramSocket 中的方法
返回此套接字的端口。
getPort() - 类 java.net.InetSocketAddress 中的方法
获取端口号。
getPort() - 类 java.net.Socket 中的方法
返回此套接字连接到的远程端口。
getPort() - 类 java.net.SocketImpl 中的方法
返回此套接字的 port 字段的值。
getPort() - 类 java.net.URI 中的方法
返回此 URI 的端口号。
getPort() - 类 java.net.URL 中的方法
获取此 URL 的端口号。
getPort() - 类 java.security.cert.LDAPCertStoreParameters 中的方法
返回 LDAP 服务器的端口号。
getPort() - 类 javax.management.remote.JMXServiceURL 中的方法
Service URL 的端口部分。
getPort(QName, Class<T>) - 类 javax.xml.ws.Service 中的方法
getPort 方法返回 stub。
getPort(Class<T>) - 类 javax.xml.ws.Service 中的方法
getPort 返回 stub。
getPort(QName, Class<T>) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
getPort 方法返回一个桩模块 (stub)。
getPort(Class<T>) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
getPort 方法返回一个桩模块。
getPortlist() - 类 java.net.HttpCookie 中的方法
返回 cookie 的端口列表属性
getPortName() - 接口 javax.xml.ws.handler.PortInfo 中的方法
获取正被访问的 WSDL 端口的限定名。
getPorts() - 类 javax.xml.ws.Service 中的方法
返回一个 Iterator，它用于此服务所组合的服务端点的 QName 列表。
getPorts() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
返回一个 Iterator，该迭代器用于根据此服务分组的服务端点的 QName 列表。
getPosition() - 类 java.awt.font.LineBreakMeasurer 中的方法
返回此 LineBreakMeasurer 的当前位置。
getPosition(Component) - 类 javax.swing.JLayeredPane 中的方法
获得该组件在其所在层中的相对位置。
getPosition(int) - 类 javax.swing.SizeSequence 中的方法
返回指定条目的起始位置。
getPosition() - 类 javax.swing.text.TabStop 中的方法
以 float 的形式返回制表符的位置。
getPosition() - 接口 javax.tools.Diagnostic 中的方法
获取距源对象开始位置的字符偏移量，其中源对象与指示问题位置的此诊断关联。
getPosition() - 接口 org.w3c.dom.ls.LSProgressEvent 中的方法
输入源中的当前位置，包括所有的外部实体和已经读取的其他资源。
getPositionAbove(JTextComponent, int, int) - 类 javax.swing.text.Utilities 中的静态方法
确定模型中离行上方给定的视图位置最近的位置。
getPositionBelow(JTextComponent, int, int) - 类 javax.swing.text.Utilities 中的静态方法
确定模型中离行下方给定的视图位置最近的位置。
getPositionsInRange(Vector, int, int) - 类 javax.swing.text.GapContent 中的方法
返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
getPositionsInRange(Vector, int, int) - 类 javax.swing.text.StringContent 中的方法
返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
getPositivePrefix() - 类 java.text.DecimalFormat 中的方法
获取正数前缀。
getPositiveSuffix() - 类 java.text.DecimalFormat 中的方法
获取正数后缀。
getPrecision() - 类 java.math.MathContext 中的方法
返回 precision 设置。
getPrecision(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的指定列大小。
getPrecision(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的指定列宽。
getPrecision() - 异常 java.util.IllegalFormatPrecisionException 中的方法
返回精度。
getPrecision() - 类 javax.sound.sampled.FloatControl 中的方法
获得该控件的分辨率或粒度，以该控件测量的单位为准。
getPrecision(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定列中的值的数字总数。
getPredefinedCursor(int) - 类 java.awt.Cursor 中的静态方法
返回一个具有指定预定义类型的光标对象。
getPreferredButtonSize(AbstractButton, int) - 类 javax.swing.plaf.basic.BasicGraphicsUtils 中的静态方法

getPreferredCommands(String) - 类 javax.activation.CommandMap 中的方法
从 MIME 类型获取首选命令表。
getPreferredCommands(String, DataSource) - 类 javax.activation.CommandMap 中的方法
从 MIME 类型获取首选命令表。
getPreferredCommands() - 类 javax.activation.DataHandler 中的方法
返回此数据类型的首选 命令。
getPreferredCommands(String) - 类 javax.activation.MailcapCommandMap 中的方法
获取 MIME 类型的首选命令列表。
getPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, Container) - 类 javax.swing.LayoutStyle 中的方法
返回两个组件之间使用的空格的数量。
getPreferredHeight() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回首选高度。
getPreferredHeight() - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回首选高度。
getPreferredHorizontalSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getPreferredInnerHorizontal() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法

getPreferredInnerVertical() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getPreferredMinSize() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回最小首选大小。
getPreferredScrollableViewportSize() - 类 javax.swing.JList 中的方法
计算显示 visibleRowCount 行所需的视口的大小。
getPreferredScrollableViewportSize() - 类 javax.swing.JTable 中的方法
返回此表视口的首选大小。
getPreferredScrollableViewportSize() - 类 javax.swing.JTextArea 中的方法
如果此组件被嵌入 JScrollPane 中，则返回 viewport 的首选大小。
getPreferredScrollableViewportSize() - 类 javax.swing.JTree 中的方法
返回 JTree 的首选显示大小。
getPreferredScrollableViewportSize() - 接口 javax.swing.Scrollable 中的方法
返回视图组件视口的首选大小。
getPreferredScrollableViewportSize() - 类 javax.swing.text.JTextComponent 中的方法
返回视图组件视口的首选大小。
getPreferredSize() - 类 java.awt.Component 中的方法
获取组件的首选大小。
getPreferredSize() - 类 java.awt.Container 中的方法
返回此容器的首选大小。
getPreferredSize(int) - 类 java.awt.List 中的方法
获取具有指定行数的列表的首选维数。
getPreferredSize() - 类 java.awt.List 中的方法
获取此滚动列表的首选大小。
getPreferredSize(int, int) - 类 java.awt.TextArea 中的方法
确定具有指定行数和列数的文本区的首选大小。
getPreferredSize() - 类 java.awt.TextArea 中的方法
确定此文本区的首选大小。
getPreferredSize(int) - 类 java.awt.TextField 中的方法
获取具有指定列数的文本字段的首选大小。
getPreferredSize() - 类 java.awt.TextField 中的方法
获取此文本字段的首选大小。
getPreferredSize() - 类 javax.swing.JComponent 中的方法
如果 preferredSize 已设置为一个非 null 值，则返回该值。
getPreferredSize() - 类 javax.swing.JEditorPane 中的方法
返回该 JEditorPane 的首选大小。
getPreferredSize() - 类 javax.swing.JTextArea 中的方法
返回 TextArea 的首选大小。
getPreferredSize() - 类 javax.swing.JTextField 中的方法
返回此 TextField 所需的首选大小 Dimensions。
getPreferredSize() - 类 javax.swing.JToolBar.Separator 中的方法
返回分隔符的首选大小。
getPreferredSize() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回 BasicArrowButton 的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getPreferredSize() - 类 javax.swing.plaf.basic.BasicComboBoxRenderer 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
列表的 preferredSize 依赖于布局方向。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
如果 c 为包含接收者的 JOptionPane，则返回的首选大小为 JOptionPane 的 LayoutManager 的最大首选大小和 getMinimumOptionPaneSize。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
单选按钮的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getPreferredSize() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回 dividerSize x dividerSize
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回传入组件的首选大小，该大小将传递给当前布局管理器。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回标题的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
返回表的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
重写此方法以将插入符的宽度考虑在内。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取编辑器组件的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回首选大小以正确显示树，这是一种 getPreferredSize(c, false) 的替代方法。
getPreferredSize(JComponent, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回首选大小以表示 c 中的树。
getPreferredSize(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
返回指定组件的适合外观的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
返回指定 JFileChooser 的首选大小。
getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法

getPreferredSize() - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalSeparatorUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法

getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
getPreferredSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
返回正确呈现图标和文本所需的首选大小。
getPreferredSize() - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的方法
重写 JTextField.getPreferredSize，以根据当前字体（如果设置）返回首选大小，否则使用 renderer 的字体。
getPreferredSize() - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 中的方法
返回 Container 的首选大小。
getPreferredSize() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
重写 JComponent.getPreferredSize，以返回稍宽的首选大小值。
getPreferredSizeOfComponent(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回传入 Component 的首选大小的宽度。
getPreferredSpan(int) - 类 javax.swing.text.AsyncBoxView 中的方法
确定此视图沿某轴的首选跨距。
getPreferredSpan(int) - 类 javax.swing.text.BoxView 中的方法
确定此视图沿某个轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.ComponentView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.FieldView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.GlyphView 中的方法
确定此视图沿某个轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.html.BlockView 中的方法
确定此视图沿某个轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.html.ImageView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.html.ParagraphView 中的方法
确定此视图的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.IconView 中的方法
确定此视图沿某个轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.PasswordView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.PlainView 中的方法
确定此视图沿某轴的首选区域。
getPreferredSpan(int) - 类 javax.swing.text.View 中的方法
确定此视图沿某个轴的首选跨距。
getPreferredSpan(int) - 类 javax.swing.text.WrappedPlainView 中的方法
确定此视图沿某个轴的首选跨距。
getPreferredThumbnailSizes(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
getPreferredTileSizes() - 类 javax.imageio.ImageWriteParam 中的方法
返回一个 Dimension 数组，指示在输出文件或流中进行编码时 tile 的合法大小范围。
getPreferredValue() - 类 javax.swing.Spring 中的方法
返回此 Spring 的 preferred 值。
getPreferredVerticalSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getPreferredWidth() - 类 javax.swing.table.TableColumn 中的方法
返回 TableColumn 的首选宽度。
getPreferredWidth(Rectangle) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回传入区域的首选宽度。
getPreferredWidth(Rectangle) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回 visibleRegion 中区域的首选宽度和高度。
getPrefix() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回 null，因为不支持名称空间。
getPrefix(int) - 类 javax.naming.CompositeName 中的方法
创建一个复合名称，其组件由此复合名称中组件的前缀组成。
getPrefix(int) - 类 javax.naming.CompoundName 中的方法
创建一个组合名称，其组件由此组合名称中组件的前缀组成。
getPrefix(int) - 类 javax.naming.ldap.LdapName 中的方法
创建一个名称，其组件由此 LDAP 名称中组件的前缀组成。
getPrefix(int) - 接口 javax.naming.Name 中的方法
创建一个名称，其组件由此名称中组件的前缀组成。
getPrefix(String) - 接口 javax.xml.namespace.NamespaceContext 中的方法
获取绑定到当前范围中名称空间 URI 的前缀。
getPrefix() - 类 javax.xml.namespace.QName 中的方法
获取此 QName 的前缀。
getPrefix() - 接口 javax.xml.soap.Name 中的方法
返回初始化此 Name 对象时指定的前缀。
getPrefix() - 接口 javax.xml.stream.events.Namespace 中的方法
获取前缀，如果它是默认名称空间声明，则返回 ""。
getPrefix() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getPrefix(String) - 接口 javax.xml.stream.XMLEventWriter 中的方法
获取绑定 URI 的前缀。
getPrefix() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回当前事件的前缀，如果事件没有前缀，则返回 null
getPrefix(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
获取绑定 URI 的前缀
getPrefix() - 接口 org.w3c.dom.Node 中的方法
此节点的名称空间前缀；如果它未被指定，则为 null。
getPrefix(String) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
返回映射到名称空间 URI 的前缀之一。
getPrefixes(String) - 接口 javax.xml.namespace.NamespaceContext 中的方法
获取绑定到当前范围中名称空间 URI 的所有前缀。
getPrefixes() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
返回所有前缀的枚举，其声明在当前上下文中是活动的。
getPrefixes(String) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
返回给定 URI 的 所有前缀的枚举，给定 URI 的声明在当前上下文中是活动的。
getPrefixList() - 类 javax.xml.crypto.dsig.spec.ExcC14NParameterSpec 中的方法
返回相容名称空间前缀列表。
getPresentationName() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
提供此次编辑的已本地化的、可读的描述，比如，适合于在更改日志中使用的。
getPresentationName() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
此默认实现返回 ""。
getPresentationName() - 类 javax.swing.undo.CompoundEdit 中的方法
从添加到 edits 的最后 UndoableEdit 返回 getPresentationName。
getPresentationName() - 类 javax.swing.undo.StateEdit 中的方法
获取此编辑的表示名称
getPresentationName() - 接口 javax.swing.undo.UndoableEdit 中的方法
返回此编辑的本地化可读描述，例如，适于在更改日志中使用。
getPreservesUnknownTags() - 类 javax.swing.text.html.HTMLDocument 中的方法
返回在遇到未知标记时所观察到的解析器行为。
getPressedIcon() - 类 javax.swing.AbstractButton 中的方法
返回按钮的按下图标。
getPreviewPanel() - 类 javax.swing.colorchooser.ColorChooserComponentFactory 中的静态方法

getPreviewPanel() - 类 javax.swing.JColorChooser 中的方法
返回显示选取颜色的预览面板。
getPreviousBounds(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
在将组件最大化之前，获得该组件的普通边界。
getPreviousLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点之前的叶节点，如果此节点是树中的第一个叶节点，则返回 null。
getPreviousNode() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回在此节点树的前序遍历中此节点之前的节点。
getPreviousRowCount() - 类 javax.swing.event.RowSorterEvent 中的方法
返回排序之前行的数量。
getPreviousSibling() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回此节点的上一个兄弟节点；如果该节点没有上一个兄弟节点，则返回 null。
getPreviousSibling() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回父节点的子节点数组中此节点的前一个兄弟节点。
getPreviousSibling() - 接口 org.w3c.dom.Node 中的方法
直接在此节点之前的节点。
getPreviousTabIndex(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getPreviousTabIndexInRun(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getPreviousTabRun(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getPreviousValue() - 类 javax.swing.JSpinner 中的方法
返回序列中由 getValue() 所返回对象之前的对象。
getPreviousValue() - 类 javax.swing.SpinnerDateModel 中的方法
返回序列中上一个 Date，如果上一个日期是在 start 之前，则返回 null。
getPreviousValue() - 类 javax.swing.SpinnerListModel 中的方法
返回该基础序列的前一个元素，如果值已经是第一个元素，则返回 null。
getPreviousValue() - 接口 javax.swing.SpinnerModel 中的方法
返回该序列中出现在 getValue() 返回的对象之前的对象。
getPreviousValue() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列中的上一个数字。
getPreviousWord(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定针对给定位置的上一个单词开头。
getPrevValue() - 接口 org.w3c.dom.events.MutationEvent 中的方法
prevValue 指示 DOMAttrModified 事件中 Attr 节点以前的值，以及 DOMCharacterDataModified 事件中 CharacterData 节点以前的值。
getPrimary1() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 primary 1 颜色。
getPrimary1() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 1 颜色。
getPrimary1() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 primary 1 颜色。
getPrimary2() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 primary 2 颜色。
getPrimary2() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 2 颜色。
getPrimary2() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 primary 2 颜色。
getPrimary3() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 primary 3 颜色。
getPrimary3() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 3 颜色。
getPrimary3() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 primary 3 颜色。
getPrimaryControl() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件颜色。
getPrimaryControl() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件颜色。
getPrimaryControlDarkShadow() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件加黑阴影颜色。
getPrimaryControlDarkShadow() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件加黑阴影颜色。
getPrimaryControlHighlight() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件高亮显示颜色。
getPrimaryControlHighlight() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件高亮显示颜色。
getPrimaryControlInfo() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件信息颜色。
getPrimaryControlInfo() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件信息颜色。
getPrimaryControlShadow() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的 primary 控件阴影颜色。
getPrimaryControlShadow() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 primary 控件阴影颜色。
getPrimaryKeys(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取对给定表的主键列的描述。
getPrimaryType() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的基本 MIME 类型。
getPrimaryType() - 类 javax.activation.MimeType 中的方法
获取此对象的基本类型。
getPrime() - 类 java.security.spec.RSAOtherPrimeInfo 中的方法
返回素数。
getPrimeExponentP() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 primeExponentP。
getPrimeExponentP() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 primeExponentP。
getPrimeExponentP() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 primeExponentP。
getPrimeExponentP() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 primeExponentP。
getPrimeExponentQ() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 primeExponentQ。
getPrimeExponentQ() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 primeExponentQ。
getPrimeExponentQ() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 primeExponentQ。
getPrimeExponentQ() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 primeExponentQ。
getPrimeP() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 primeP。
getPrimeP() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 primeP。
getPrimeP() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 primeP。
getPrimeP() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 primeP。
getPrimeQ() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回 primeQ。
getPrimeQ() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回 primeQ。
getPrimeQ() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回 primeQ。
getPrimeQ() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回 primeQ。
getPrimeSize() - 类 javax.crypto.spec.DHGenParameterSpec 中的方法
以位为单位返回质数模数的大小。
getPrimitiveArrayType(Class<T>) - 类 javax.management.openmbean.ArrayType 中的静态方法
以类型安全的方式创建一个 ArrayType 实例。
getPrimitiveType(TypeKind) - 接口 javax.lang.model.util.Types 中的方法
返回基本类型。
getPrincipal() - 接口 java.security.acl.AclEntry 中的方法
返回此 ACL 项将为其授予或拒绝权限的主体。
getPrincipal() - 接口 java.security.Certificate 中的方法
已过时。 返回保证人所保证的主体密钥对的主体。
getPrincipal() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此密钥所属的主体。
getPrincipals() - 类 java.security.ProtectionDomain 中的方法
返回此域的 principals 数组。
getPrincipals() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回与此 PrivateCredentialPermission 相关联的 Principal 类和名称。
getPrincipals() - 类 javax.security.auth.Subject 中的方法
返回与此 Subject 关联的 Principal Set。
getPrincipals(Class<T>) - 类 javax.security.auth.Subject 中的方法
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。
getPrintable(int) - 类 java.awt.print.Book 中的方法
返回 Printable 实例，该实例负责呈现 pageIndex 指定的页面。
getPrintable(int) - 接口 java.awt.print.Pageable 中的方法
返回负责呈现 pageIndex 指定的页面的 Printable 实例。
getPrintable(JTable.PrintMode, MessageFormat, MessageFormat) - 类 javax.swing.JTable 中的方法
返回打印此 JTable 中所使用的 Printable。
getPrintable(MessageFormat, MessageFormat) - 类 javax.swing.text.JTextComponent 中的方法
返回一个 Printable，用于打印此 JTextComponent 的内容。
getPrintableArea(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以顺序为 x, y, w, h 的 4 个值的数组形式获取可打印区域。
getPrintData() - 接口 javax.print.Doc 中的方法
获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。
getPrintData() - 类 javax.print.SimpleDoc 中的方法

getPrinter() - 类 java.awt.JobAttributes 中的方法
为使用这些属性的作业返回目标打印机。
getPrinterJob() - 接口 java.awt.print.PrinterGraphics 中的方法
返回正在控制当前呈现请求的 PrinterJob。
getPrinterJob() - 类 java.awt.print.PrinterJob 中的静态方法
创建并返回初始化时与默认打印机关联的 PrinterJob。
getPrinterResolution() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面的打印分辨率。
getPrintEventType() - 类 javax.print.event.PrintJobEvent 中的方法
获得此事件的原因。
getPrintJob() - 接口 java.awt.PrintGraphics 中的方法
返回从其产生 PrintGraphics 对象的 PrintJob 对象。
getPrintJob(Frame, String, Properties) - 类 java.awt.Toolkit 中的方法
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
getPrintJob(Frame, String, JobAttributes, PageAttributes) - 类 java.awt.Toolkit 中的方法
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
getPrintJob() - 类 javax.print.event.PrintJobAttributeEvent 中的方法
确定此打印作业事件适合的 Print Job。
getPrintJob() - 类 javax.print.event.PrintJobEvent 中的方法
确定此打印作业事件适合的 DocPrintJob。
getPrintQuality() - 类 java.awt.PageAttributes 中的方法
返回使用这些属性的页面的打印质量。
getPrintService() - 类 java.awt.print.PrinterJob 中的方法
返回此打印机作业的服务（打印机）。
getPrintService() - 接口 javax.print.DocPrintJob 中的方法
确定此 PrintJob 对象所绑定到的 PrintService 对象。
getPrintService() - 类 javax.print.event.PrintServiceAttributeEvent 中的方法
返回打印服务。
getPrintService(OutputStream) - 类 javax.print.StreamPrintServiceFactory 中的方法
返回可打印到指定输出流的 StreamPrintService。
getPrintServices(DocFlavor, AttributeSet) - 类 javax.print.PrintServiceLookup 中的方法
查找肯定可支持指定属性和 DocFlavor 组合的服务。
getPrintServices() - 类 javax.print.PrintServiceLookup 中的方法
应用程序不直接调用它。
getPriority() - 类 java.lang.Thread 中的方法
返回线程的优先级。
getPrivacy() - 类 org.ietf.jgss.MessageProp 中的方法
检索私密状态。
getPrivate() - 类 java.security.KeyPair 中的方法
返回对此密钥对的私钥组件的引用。
getPrivateCredentials() - 类 javax.security.auth.Subject 中的方法
返回此 Subject 中包含的私有证书 Set。
getPrivateCredentials(Class<T>) - 类 javax.security.auth.Subject 中的方法
返回与此 Subject关联的私有证书 Set，它是指定的 Class 的实例或子类。
getPrivateExponent() - 接口 java.security.interfaces.RSAPrivateKey 中的方法
返回专用指数。
getPrivateExponent() - 类 java.security.spec.RSAPrivateKeySpec 中的方法
返回专用指数。
getPrivateKey() - 类 java.security.KeyStore.PrivateKeyEntry 中的方法
从此项获取 PrivateKey。
getPrivateKey() - 类 java.security.Signer 中的方法
已过时。 返回此 signer 的私钥。
getPrivateKey(String) - 接口 javax.net.ssl.X509KeyManager 中的方法
返回与给定别名关联的密钥。
getPrivateKey() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
返回 PrivateKey。
getPrivateKeyValid() - 类 java.security.cert.X509CertSelector 中的方法
返回 privateKeyValid 标准。
getProblemType() - 类 javax.management.relation.RoleUnresolved 中的方法
检索问题类型。
getProcedureColumns(String, String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取给定类别的存储过程参数和结果列的描述。
getProcedures(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在给定类别中使用的存储过程的描述。
getProcedureTerm() - 接口 java.sql.DatabaseMetaData 中的方法
获取数据库供应商用于 "procedure" 的首选术语。
getProcessedDTD() - 接口 javax.xml.stream.events.DTD 中的方法
返回定义 DTD 表示形式的实现。
getProfile() - 类 java.awt.color.ICC_ColorSpace 中的方法
返回此 ICC_ColorSpace 的 ICC_Profile。
getProfileClass() - 类 java.awt.color.ICC_Profile 中的方法
返回配置文件类。
getProgram(String...) - 接口 javax.script.ScriptEngineFactory 中的方法
返回一个包含给定语句的有效脚本语言的可执行程序。
getProgram() - 接口 javax.sound.midi.MidiChannel 中的方法
获得此通道的当前程序号。
getProgram() - 类 javax.sound.midi.Patch 中的方法
返回该 Patch 指定其位置的乐器在库中的索引号。
getProgress() - 类 javax.swing.SwingWorker 中的方法
返回 progress 绑定属性。
getProgressBarBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getProgressiveMode() - 类 javax.imageio.ImageWriteParam 中的方法
返回以逐步方式将数据写入流的当前模式。
getProgressMonitor() - 类 javax.swing.ProgressMonitorInputStream 中的方法
获取此流使用的 ProgressMonitor 对象。
getPrompt() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取提示。
getPrompt() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取提示。
getPrompt() - 类 javax.security.auth.callback.NameCallback 中的方法
获取提示。
getPrompt() - 类 javax.security.auth.callback.PasswordCallback 中的方法
获取提示。
getPrompt() - 类 javax.security.auth.callback.TextInputCallback 中的方法
获取提示。
getPropagatedFrom() - 类 java.beans.beancontext.BeanContextEvent 中的方法
获得作为此事件传播源的 BeanContext。
getPropagationId() - 类 java.beans.PropertyChangeEvent 中的方法
保留 "propagationId" 字段以供将来使用。
getProperties() - 类 java.lang.System 中的静态方法
确定当前的系统属性。
getProperties() - 接口 javax.xml.crypto.dsig.SignatureProperties 中的方法
返回一个可修改的列表，由包含此在 SignatureProperties 中的一个或多个 SignatureProperty 组成。
getProperties() - 类 javax.xml.ws.Endpoint 中的方法
返回此 Endpoint 实例的属性包。
getProperty(String, ImageObserver) - 类 java.awt.image.BufferedImage 中的方法
按名称返回图像的属性。
getProperty(String) - 类 java.awt.image.BufferedImage 中的方法
按名称返回图像的属性。
getProperty(String, ImageObserver) - 类 java.awt.Image 中的方法
通过名称获取此图像的属性。
getProperty(ParameterBlock, String) - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
获取由 name 参数指定的属性的适当实例。
getProperty(String) - 接口 java.awt.image.renderable.RenderableImage 中的方法
从此图像的属性集中获取某个属性。
getProperty(String) - 类 java.awt.image.renderable.RenderableImageOp 中的方法
从此图像的属性集中获取某个属性。
getProperty(String) - 接口 java.awt.image.RenderedImage 中的方法
从此图像的属性设置中获取一个属性。
getProperty(String, String) - 类 java.awt.Toolkit 中的静态方法
获取具有指定键和默认值的属性。
getProperty(String) - 类 java.lang.System 中的静态方法
获取指定键指示的系统属性。
getProperty(String, String) - 类 java.lang.System 中的静态方法
获取用指定键描述的系统属性。
getProperty(String) - 类 java.security.Provider 中的方法

getProperty(String) - 类 java.security.Security 中的静态方法
获取安全属性值。
getProperty(String) - 类 java.util.logging.LogManager 中的方法
获取日志属性的值。
getProperty(String) - 类 java.util.Properties 中的方法
用指定的键在此属性列表中搜索属性。
getProperty(String, String) - 类 java.util.Properties 中的方法
用指定的键在属性列表中搜索属性。
getProperty(String) - 类 javax.sound.midi.MidiFileFormat 中的方法
获得由键指定的属性值。
getProperty(String) - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得键指定的属性值。
getProperty(String) - 类 javax.sound.sampled.AudioFormat 中的方法
获取键指定的属性值。
getProperty(Object) - 类 javax.swing.text.AbstractDocument 中的方法
查找属性值的便捷方法。
getProperty(Object) - 接口 javax.swing.text.Document 中的方法
获得与文档关联的属性。
getProperty(String) - 类 javax.xml.bind.Binder 中的方法
获取 Binder 的基础实现中的特定属性。
getProperty(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
getProperty(String) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。
getProperty(String) - 接口 javax.xml.bind.Marshaller 中的方法
获取 Marshaller 底层实现中的特定属性。
getProperty(String) - 接口 javax.xml.bind.Unmarshaller 中的方法
获取 Unmarshaller 底层实现中的特定属性。
getProperty(String) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
getProperty(String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 获取指定名称所映射的对象。
getProperty(String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回指定属性的值。
getProperty(String) - 类 javax.xml.parsers.SAXParser 中的方法
返回 XMLReader 的底层实现中请求的特定属性。
getProperty(String) - 类 javax.xml.soap.SOAPMessage 中的方法
检索指定属性的值。
getProperty(String) - 类 javax.xml.stream.util.EventReaderDelegate 中的方法

getProperty(String) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getProperty(String) - 接口 javax.xml.stream.XMLEventReader 中的方法
从底层实现获取功能/属性值。
getProperty(String) - 类 javax.xml.stream.XMLInputFactory 中的方法
从底层实现获取功能/属性的值。
getProperty(String) - 类 javax.xml.stream.XMLOutputFactory 中的方法
获取底层实现上的功能/属性
getProperty(String) - 接口 javax.xml.stream.XMLStreamReader 中的方法
从底层实现获取功能/属性的值
getProperty(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
从底层实现获取功能/属性值
getProperty(String) - 类 javax.xml.validation.SchemaFactory 中的方法
查找属性值。
getProperty(String) - 类 javax.xml.validation.Validator 中的方法
查找属性值。
getProperty(String) - 类 javax.xml.validation.ValidatorHandler 中的方法
查找属性值。
getProperty(String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
获取解析器属性。
getProperty(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
查找属性值。
getProperty(String) - 接口 org.xml.sax.XMLReader 中的方法
查找属性的值。
getPropertyChangeEvent() - 异常 java.beans.PropertyVetoException 中的方法
获得禁止的 PropertyChangeEvent。
getPropertyChangeListeners() - 类 java.awt.Component 中的方法
返回在此组件上所有已注册的属性更改侦听器的数组。
getPropertyChangeListeners(String) - 类 java.awt.Component 中的方法
返回与指定属性相关联的所有侦听器的数组。
getPropertyChangeListeners() - 类 java.awt.KeyboardFocusManager 中的方法
返回在此键盘焦点管理器上注册的所有属性更改侦听器组成的数组。
getPropertyChangeListeners(String) - 类 java.awt.KeyboardFocusManager 中的方法
返回与指定属性相关联的所有 PropertyChangeListener 组成的数组。
getPropertyChangeListeners(String) - 类 java.awt.SystemTray 中的方法
返回与指定属性关联的所有侦听器的数组。
getPropertyChangeListeners() - 类 java.awt.Toolkit 中的方法
返回在此工具包上所有已注册的属性更改侦听器所组成的数组。
getPropertyChangeListeners(String) - 类 java.awt.Toolkit 中的方法
返回与指定属性关联的所有 PropertyChangeListener 所组成的数组。
getPropertyChangeListeners() - 类 java.beans.PropertyChangeSupport 中的方法
返回使用 addPropertyChangeListener() 添加到此 PropertyChangeSupport 对象中的所有侦听器组成的数组。
getPropertyChangeListeners(String) - 类 java.beans.PropertyChangeSupport 中的方法
返回与指定属性相关联的所有侦听器的列表。
getPropertyChangeListeners() - 类 javax.swing.AbstractAction 中的方法
返回使用 addPropertyChangeListener() 添加到此 AbstractAction 中的所有 PropertyChangeListener 组成的数组。
getPropertyChangeListeners() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
返回一个在此组件上注册的所有属性更改侦听器的数组。
getPropertyChangeListeners() - 类 javax.swing.table.TableColumn 中的方法
返回使用 addPropertyChangeListener() 添加到此 TableColumn 的所有 PropertyChangeListener 组成的数组。
getPropertyChangeListeners() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回此 DefaultTreeSelectionModel 上注册的所有属性更改侦听器组成的数组。
getPropertyChangeListeners() - 类 javax.swing.UIDefaults 中的方法
返回使用 addPropertyChangeListener() 添加到此 UIDefaults 的所有 PropertyChangeListener 组成的数组。
getPropertyChangeListeners() - 类 javax.swing.UIManager 中的静态方法
返回添加到此 UIManager（具有 addPropertyChangeListener()）的所有 PropertyChangeListener 的数组。
getPropertyChangeSupport() - 类 javax.swing.SwingWorker 中的方法
返回此 SwingWorker 的 PropertyChangeSupport。
getPropertyDescriptors() - 接口 java.beans.BeanInfo 中的方法
获得 beans PropertyDescriptor。
getPropertyDescriptors() - 类 java.beans.SimpleBeanInfo 中的方法
拒绝属性的信息。
getPropertyEditorClass() - 类 java.beans.PropertyDescriptor 中的方法
获得已为此属性注册的任何显式 PropertyEditor Class。
getPropertyInfo(String, Properties) - 接口 java.sql.Driver 中的方法
获得此驱动程序的可能属性信息。
getPropertyName() - 类 java.beans.PropertyChangeEvent 中的方法
获取已更改属性的编程名称。
getPropertyName() - 类 java.beans.PropertyChangeListenerProxy 中的方法
返回与侦听器相关联的指定属性的名称。
getPropertyName() - 类 java.beans.VetoableChangeListenerProxy 中的方法
返回与侦听器有关联的指定属性的名称。
getPropertyNames() - 类 java.awt.image.BufferedImage 中的方法
返回由 getProperty(String) 识别的名称数组；如果没有识别出属性名，则返回 null。
getPropertyNames() - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
返回由 getProperty 识别的名称列表。
getPropertyNames() - 接口 java.awt.image.renderable.RenderableImage 中的方法
返回由 getProperty 识别的名称列表。
getPropertyNames() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
返回由 getProperty 识别的名称列表。
getPropertyNames() - 接口 java.awt.image.RenderedImage 中的方法
返回由 getProperty(String) 识别的名称的数组，如果没有属性名被识别，则返回 null。
getPropertyOverrides() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
返回组的重写属性列表。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicCheckBoxUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicFormattedTextFieldUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicTextFieldUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicTextPaneUI 中的方法
获取用作键以通过 UIManager 查找属性的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取通过 UIManager 查找属性时用作键的名称。
getPropertyPrefix() - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的方法

getPropertyPrefix() - 类 javax.swing.plaf.metal.MetalCheckBoxUI 中的方法

getPropertyType() - 类 java.beans.PropertyDescriptor 中的方法
获得属性的 Class 对象。
getProtectionDomain() - 类 java.lang.Class 中的方法
返回该类的 ProtectionDomain。
getProtectionParameter(String) - 类 java.security.KeyStore.Builder 中的方法
返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。
getProtectionParameter() - 接口 java.security.KeyStore.LoadStoreParameter 中的方法
获取用于保护 keystore 数据的参数。
getProtocol() - 类 java.net.URL 中的方法
获取此 URL 的协议名称。
getProtocol() - 类 javax.management.remote.JMXServiceURL 中的方法
Service URL 的协议部分。
getProtocol() - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法

getProtocol() - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法

getProtocol() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
返回该对象的协议字符串。
getProtocol() - 类 javax.net.ssl.SSLContext 中的方法
返回此 SSLContext 对象的协议名称。
getProtocol() - 接口 javax.net.ssl.SSLSession 中的方法
返回会话中的所有连接使用的协议的标准名称。
getProtocols() - 类 javax.net.ssl.SSLParameters 中的方法
返回协议数组的副本；如果未设置，则返回 null。
getPrototypeCellValue() - 类 javax.swing.JList 中的方法
返回“原型的”单元值，即用于计算单元的固定宽度和高度的值。
getPrototypeDisplayValue() - 类 javax.swing.JComboBox 中的方法
返回“原型显示”值，即用于计算显示高度和宽度的 Object。
getProvider() - 类 java.security.AlgorithmParameterGenerator 中的方法
返回此算法参数生成器对象的提供者。
getProvider() - 类 java.security.AlgorithmParameters 中的方法
返回此参数对象的提供者。
getProvider() - 类 java.security.cert.CertificateFactory 中的方法
返回此 CertificateFactory 的提供者。
getProvider() - 类 java.security.cert.CertPathBuilder 中的方法
返回此 CertPathBuilder 的提供者。
getProvider() - 类 java.security.cert.CertPathValidator 中的方法
返回此 CertPathValidator 的 Provider。
getProvider() - 类 java.security.cert.CertStore 中的方法
返回此 CertStore 的提供者。
getProvider() - 类 java.security.KeyFactory 中的方法
返回此密钥工厂对象的提供者。
getProvider() - 类 java.security.KeyPairGenerator 中的方法
返回此密钥对生成器对象的提供者。
getProvider() - 类 java.security.KeyStore 中的方法
返回此 keystore 的提供者。
getProvider() - 类 java.security.MessageDigest 中的方法
返回此信息摘要对象的提供者。
getProvider() - 类 java.security.Policy 中的方法
返回此 Policy 的 Provider。
getProvider() - 类 java.security.Provider.Service 中的方法
返回此服务的 Provider。
getProvider() - 类 java.security.SecureRandom 中的方法
返回此 SecureRandom 对象的提供者。
getProvider(String) - 类 java.security.Security 中的静态方法
返回使用指定的名称安装的提供者（如果有）。
getProvider() - 类 java.security.Signature 中的方法
返回此签名对象的提供者。
getProvider() - 类 javax.crypto.Cipher 中的方法
返回此 Cipher 对象的提供者。
getProvider() - 类 javax.crypto.ExemptionMechanism 中的方法
返回此 ExemptionMechanism 对象的提供者。
getProvider() - 类 javax.crypto.KeyAgreement 中的方法
返回此 KeyAgreement 对象的提供者。
getProvider() - 类 javax.crypto.KeyGenerator 中的方法
返回此 KeyGenerator 对象的提供者。
getProvider() - 类 javax.crypto.Mac 中的方法
返回此 Mac 对象的提供者。
getProvider() - 类 javax.crypto.SecretKeyFactory 中的方法
返回此 SecretKeyFactory 对象的提供者。
getProvider() - 类 javax.net.ssl.KeyManagerFactory 中的方法
返回此 KeyManagerFactory 对象的提供者。
getProvider() - 类 javax.net.ssl.SSLContext 中的方法
返回此 SSLContext 对象的提供者。
getProvider() - 类 javax.net.ssl.TrustManagerFactory 中的方法
返回此 TrustManagerFactory 对象的提供者。
getProvider() - 类 javax.security.auth.login.Configuration 中的方法
返回此 Configuration 的 Provider。
getProvider() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
返回此 KeyInfoFactory 的提供者。
getProvider() - 类 javax.xml.crypto.dsig.TransformService 中的方法
返回此 TransformService 的提供者。
getProvider() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
返回此 XMLSignatureFactory 的提供者。
getProviderGrade() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回一个常量，它指示 RowSet 对象希望从此 SyncProvider 对象获得的同步等级。
getProviderID() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回此 SyncProvider 对象的唯一标识符。
getProviders() - 类 java.security.Security 中的静态方法
返回包含所有已安装的提供者的数组。
getProviders(String) - 类 java.security.Security 中的静态方法
返回包含满足指定的选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
getProviders(Map<String, String>) - 类 java.security.Security 中的静态方法
返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
getProxyClass(ClassLoader, Class<?>...) - 类 java.lang.reflect.Proxy 中的静态方法
返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
getPSName() - 类 java.awt.Font 中的方法
返回此 Font 的 postscript 名称。
getPSource() - 类 javax.crypto.spec.OAEPParameterSpec 中的方法
返回编码输入 P 的源。
getPublic() - 类 java.security.KeyPair 中的方法
返回对此密钥对的公钥组件的引用。
getPublicCredentials() - 类 javax.security.auth.Subject 中的方法
返回此 Subject 中包含的公开证书 Set。
getPublicCredentials(Class<T>) - 类 javax.security.auth.Subject 中的方法
返回与此 Subject 关联的公开证书 Set，它是指定的 Class 的实例或子类。
getPublicExponent() - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的方法
返回公用指数。
getPublicExponent() - 接口 java.security.interfaces.RSAPrivateCrtKey 中的方法
返回公用指数。
getPublicExponent() - 接口 java.security.interfaces.RSAPublicKey 中的方法
返回该公用指数。
getPublicExponent() - 类 java.security.spec.RSAKeyGenParameterSpec 中的方法
返回公用指数值。
getPublicExponent() - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 中的方法
返回公用指数。
getPublicExponent() - 类 java.security.spec.RSAPrivateCrtKeySpec 中的方法
返回公用指数。
getPublicExponent() - 类 java.security.spec.RSAPublicKeySpec 中的方法
返回该公用指数。
getPublicId() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
实体的公共标识符，如果未给定该标识符，则为 null
getPublicId() - 接口 javax.xml.stream.events.NotationDeclaration 中的方法
注释的公共标识符，如果未提供该标识符，则为 null。
getPublicId() - 接口 javax.xml.stream.Location 中的方法
返回 XML 的公共 ID
getPublicId() - 接口 javax.xml.transform.SourceLocator 中的方法
返回当前文档事件的公共标识符。
getPublicId() - 类 javax.xml.transform.stream.StreamSource 中的方法
获取通过 setPublicId 设置的公共标识符。
getPublicId() - 接口 org.w3c.dom.DocumentType 中的方法
外部子集的公共标识符。
getPublicId() - 接口 org.w3c.dom.Entity 中的方法
如果已指定，则为与实体相关的公共标识符；否则为 null。
getPublicId() - 接口 org.w3c.dom.ls.LSInput 中的方法
此输入源的公共标识符。
getPublicId() - 接口 org.w3c.dom.Notation 中的方法
此表示法的公共标识符。
getPublicId() - 类 org.xml.sax.helpers.LocatorImpl 中的方法
返回保存的公开标识符。
getPublicId() - 类 org.xml.sax.InputSource 中的方法
获取此输入源的公共标识符。
getPublicId() - 接口 org.xml.sax.Locator 中的方法
返回当前文档事件的公共标识符。
getPublicId() - 异常 org.xml.sax.SAXParseException 中的方法
获取发生异常的实体的公共标识符。
getPublicKey() - 类 java.security.cert.Certificate 中的方法
从此证书中获取公钥。
getPublicKey() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回证书路径主体（目标）的公钥，如果适用，要包括所有继承的公钥参数。
getPublicKey() - 接口 java.security.Certificate 中的方法
已过时。 返回保证人所保证的主体密钥对的密钥。
getPublicKey() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的公钥。
getPublicKey() - 类 javax.security.cert.Certificate 中的方法
从此证书中获取公钥。
getPublicKey() - 接口 javax.xml.crypto.dsig.keyinfo.KeyValue 中的方法
返回此 KeyValue 的公钥。
getPurgeFlag() - 类 javax.management.relation.RelationService 中的方法
返回一个标志，以指示何时接收注销关系中引用的 MBean 的通知，指示是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在将显式调用 purgeRelations 方法时执行该操作。
getPurgeFlag() - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回一个标志，以指示注销关系中引用的 MBean 时是否接收到通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
getPushLevel() - 类 java.util.logging.MemoryHandler 中的方法
获得 pushLevel。
getQ() - 接口 java.security.interfaces.DSAParams 中的方法
返回子素数 q。
getQ() - 类 java.security.spec.DSAParameterSpec 中的方法
返回子素数 q。
getQ() - 类 java.security.spec.DSAPrivateKeySpec 中的方法
返回子素数 q。
getQ() - 类 java.security.spec.DSAPublicKeySpec 中的方法
返回子素数 q。
getQName(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的 XML 限定（前缀）名。
getQName(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
返回属性的限定（加前缀的）名称。
getQOP() - 类 org.ietf.jgss.MessageProp 中的方法
检索 QOP 值。
getQTables() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
返回最近一次调用 setDecodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getQTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回最近一次调用 setEncodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
getQuadrantRotateInstance(int) - 类 java.awt.geom.AffineTransform 中的静态方法
返回按指定象限数旋转坐标的变换。
getQuadrantRotateInstance(int, double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回按指定象限数绕指定锚点旋转坐标的变换。
getQualifiedName() - 接口 javax.lang.model.element.PackageElement 中的方法
返回此包的完全限定名称。
getQualifiedName() - 接口 javax.lang.model.element.TypeElement 中的方法
返回此类型元素的完全限定名称。
getQualifiedName() - 接口 javax.xml.soap.Name 中的方法
获取此 Name 对象表示的 XML 名称限定于命名空间的名称。
getQuery() - 类 java.net.URI 中的方法
返回此 URI 的已解码的查询组成部分。
getQuery() - 类 java.net.URL 中的方法
获取此 URL 的查询部分。
getQueryTimeout() - 接口 java.sql.Statement 中的方法
获取驱动程序等待 Statement 对象执行的秒数。
getQueryTimeout() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取驱动程序等待查询执行的最大秒数。
getQueryTimeout() - 接口 javax.sql.RowSet 中的方法
获取驱动程序等待语句执行的最大秒数。
getQueue() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
返回此执行程序使用的任务队列。
getQueue() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回此执行程序使用的任务队列。
getQueuedReaderThreads() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回一个 collection，它包含可能正在等待获取读取锁的线程。
getQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回一个 collection，该 collection 包含正在等待获取的线程。
getQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回包含可能正在等待获取的线程 collection。
getQueuedThreads() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回一个 collection，它包含可能正等待获取此锁的线程。
getQueuedThreads() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回一个 collection，它包含可能正在等待获取读取或写入锁的线程。
getQueuedThreads() - 类 java.util.concurrent.Semaphore 中的方法
返回一个 collection，包含可能等待获取的线程。
getQueuedWriterThreads() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回一个 collection，它包含可能正在等待获取写入锁的线程。
getQueueLength() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回等待获取的线程估计数。
getQueueLength() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回等待获取的线程数估计值。
getQueueLength() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回正等待获取此锁的线程估计数。
getQueueLength() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回等待获取读取或写入锁的线程估计数目。
getQueueLength() - 类 java.util.concurrent.Semaphore 中的方法
返回正在等待获取的线程的估计数目。
getRadioButtonBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getRadioButtonIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getRadioButtonIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getRadioButtonMenuItemIcon() - 类 javax.swing.plaf.basic.BasicIconFactory 中的静态方法

getRadioButtonMenuItemIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getRadius() - 类 java.awt.RadialGradientPaint 中的方法
返回定义辐射状渐变的圆的半径。
getRaisedBevelBorderUIResource() - 类 javax.swing.plaf.BorderUIResource 中的静态方法

getRanges() - 类 java.awt.font.NumericShaper 中的方法
返回一个 int，它使用或操作 (OR) 连接所有将成形的范围的值。
getRaster() - 类 java.awt.image.BufferedImage 中的方法
返回 WritableRaster。
getRaster(int, int, int, int) - 接口 java.awt.PaintContext 中的方法
返回包含为图形操作生成的颜色的 Raster。
getRaster() - 类 javax.imageio.IIOImage 中的方法
返回当前设置好的 Raster，如果只有一个 RenderedImage 可用，则返回 null。
getRawAuthority() - 类 java.net.URI 中的方法
返回此 URI 的原始授权组成部分。
getRawContent() - 类 javax.xml.soap.AttachmentPart 中的方法
以 InputStream 的形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
getRawContentBytes() - 类 javax.xml.soap.AttachmentPart 中的方法
以 byte[] 数组形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。
getRawFragment() - 类 java.net.URI 中的方法
返回此 URI 的原始片段组成部分。
getRawImageType(int) - 类 javax.imageio.ImageReader 中的方法
返回一个 ImageTypeSpecifier，指示最能代表图像“原始”内部格式的 SampleModel 和 ColorModel。
getRawOffset() - 类 java.util.SimpleTimeZone 中的方法
获取此时区的 GMT 偏移量。
getRawOffset() - 类 java.util.TimeZone 中的方法
返回添加到 UTC 以获取此时区中的标准时间的时间量（以毫秒为单位）。
getRawPath() - 类 java.net.URI 中的方法
返回此 URI 的原始路径组成部分。
getRawQuery() - 类 java.net.URI 中的方法
返回此 URI 的原始查询组成部分。
getRawSchemeSpecificPart() - 类 java.net.URI 中的方法
返回此 URI 原始的、特定于方案的部分。
getRawType() - 接口 java.lang.reflect.ParameterizedType 中的方法
返回 Type 对象，表示声明此类型的类或接口。
getRawUserInfo() - 类 java.net.URI 中的方法
返回此 URI 的原始用户信息组成部分。
getRdn(int) - 类 javax.naming.ldap.LdapName 中的方法
以 Rdn 形式检索此 LDAP 名称的 RDN。
getRdns() - 类 javax.naming.ldap.LdapName 中的方法
检索相对标识名列表。
getRead() - 异常 java.sql.DataTruncation 中的方法
指示该值是否在读取时被截断。
getReader() - 接口 javax.script.ScriptContext 中的方法
返回脚本用来读取输入的 Reader。
getReader() - 类 javax.script.SimpleScriptContext 中的方法
返回脚本用来读取输入的 Reader。
getReader(int) - 类 javax.swing.text.html.HTMLDocument 中的方法
获取加载带有 HTML 的文档时所用解析器的 reader。
getReader(int, int, int, HTML.Tag) - 类 javax.swing.text.html.HTMLDocument 中的方法
返回加载带有 HTML 的文档时所用解析器的 reader。
getReader() - 类 javax.xml.transform.stream.StreamSource 中的方法
获取通过 setReader 设置的字符流。
getReaderFileSuffixes() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出与当前已注册 reader 集合所理解的格式关联的所有文件后缀。
getReaderFormatNames() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有非正式格式名称。
getReaderForText(Transferable) - 类 java.awt.datatransfer.DataFlavor 中的方法
获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
getReaderForText() - 接口 javax.print.Doc 中的方法
获得一个从此 doc 中提取字符打印数据的 reader。
getReaderForText() - 类 javax.print.SimpleDoc 中的方法
获得一个从此 doc 中提取字符打印数据的 reader。
getReaderMIMETypes() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有 MIME 类型。
getReaderServiceProviderName() - 类 javax.imageio.spi.ImageTranscoderSpi 中的方法
返回 ImageReaderSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。
getReadHoldCount() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询当前线程在此锁上保持的重入读取锁数量。
getReadLockCount() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询为此锁保持的读取锁数量。
getReadMethod() - 类 java.beans.PropertyDescriptor 中的方法
获得应该用于读取属性值的方法。
getReadTimeout() - 类 java.net.URLConnection 中的方法
返回读入超时设置。
getRealm() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
返回此 Kerberos 主体的域组件。
getReason() - 异常 java.net.HttpRetryException 中的方法
返回解释不能重试 http 请求的原因的字符串。
getReason() - 异常 java.net.URISyntaxException 中的方法
返回一个字符串，解释输入字符串不能解析的原因。
getReason() - 接口 javax.print.URIException 中的方法
返回事件的原因。
getReceiveBufferSize() - 类 java.net.DatagramSocket 中的方法
获取此 DatagramSocket 的 SO_RCVBUF 选项的值，该值是平台在 DatagramSocket 上输入时使用的缓冲区大小。
getReceiveBufferSize() - 类 java.net.ServerSocket 中的方法
获取此 ServerSocket 的 SO_RCVBUF 选项的值，该值是将用于从此 ServerSocket 接受的套接字的建议缓冲区大小。
getReceiveBufferSize() - 类 java.net.Socket 中的方法
获取此 Socket 的 SO_RCVBUF 选项的值，该值是平台在 Socket 上输入时使用的缓冲区大小。
getReceiver() - 接口 javax.sound.midi.MidiDevice 中的方法
获得 MIDI 设备可通过其接收 MIDI 数据的 MIDI IN 接收器。
getReceiver() - 类 javax.sound.midi.MidiSystem 中的静态方法
从外部 MIDI 端口或其他默认设备获得 MIDI 接收器。
getReceiver() - 接口 javax.sound.midi.Transmitter 中的方法
获得此传输器将向其传送 MIDI 消息的当前接收器。
getReceivers() - 接口 javax.sound.midi.MidiDevice 中的方法
返回与该 MidiDevice 连接的所有当前活动的、非关闭的接收器。
getRecursionLimit() - 类 java.awt.geom.FlatteningPathIterator 中的方法
返回此迭代器的递归限制。
getRed() - 类 java.awt.Color 中的方法
返回默认 sRGB 空间中位于范围 0-255 中的红色分量。
getRed(int) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(Object) - 类 java.awt.image.ColorModel 中的方法
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(int) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
getRed(int) - 类 java.awt.image.IndexColorModel 中的方法
返回指定像素的红色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
getRedMask() - 类 java.awt.image.DirectColorModel 中的方法
返回指定 int 像素表示形式中哪些位包含红色分量的掩码。
getRedoPresentationName() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
提供此次编辑可重复执行形式的、已本地化的、可读的描述，例如用作 Redo 菜单项。
getRedoPresentationName() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
检索默认表中 AbstractUndoableEdit.redoText 键的值，并返回该值，后跟一个空格和 getPresentationName。
getRedoPresentationName() - 类 javax.swing.undo.CompoundEdit 中的方法
从添加到 edits 的最后 UndoableEdit 返回 getRedoPresentationName。
getRedoPresentationName() - 接口 javax.swing.undo.UndoableEdit 中的方法
返回此编辑可恢复形式的本地化可读描述，例如，适于用作 “Redo” 菜单项。
getRedoPresentationName() - 类 javax.swing.undo.UndoManager 中的方法
返回此编辑可恢复形式的描述。
getReds(byte[]) - 类 java.awt.image.IndexColorModel 中的方法
将红色分量数组复制到指定的数组中。
getReductionPolynomial() - 类 java.security.spec.ECFieldF2m 中的方法
对于多项式方法，返回一个 BigInteger，其第 i 位对应于降序排列多项式的第 i 个系数，对于常规方法，返回 null。
getRef() - 类 java.net.URL 中的方法
获取此 URL 的锚点（也称为“引用”）。
getRef() - 类 java.rmi.server.RemoteObject 中的方法
返回远程对象的远程引用。
getRef(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Ref 对象的形式获取指定的 JDBC REF(<structured-type>) 参数的值。
getRef(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。
getRef(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getRef(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getRefClass(ObjectOutput) - 接口 java.rmi.server.RemoteRef 中的方法
返回要在流 'out' 上序列化的 ref 类型的类名称。
getReference() - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
返回该引用的当前值。
getReference() - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
返回该引用的当前值。
getReference() - 接口 javax.naming.Referenceable 中的方法
检索此对象的 Reference。
getReferencedMBeans() - 接口 javax.management.relation.Relation 中的方法
检索在该关系的各种角色中引用的 MBean。
getReferencedMBeans(String) - 类 javax.management.relation.RelationService 中的方法
检索关系的各种角色中引用的 MBean。
getReferencedMBeans(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索关系的各种角色中引用的 MBean。
getReferencedMBeans() - 类 javax.management.relation.RelationSupport 中的方法
检索在该关系的各种角色中引用的 MBean。
getReferences() - 接口 javax.xml.crypto.dsig.Manifest 中的方法
返回一个不可修改的列表，由包含在此 Manifest 中的一个或多个 Reference 组成。
getReferences() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
返回一个或多个 Reference 的不可修改的列表。
getReferralContext() - 异常 javax.naming.ldap.LdapReferralException 中的方法
使用上下文的环境（但不使用控件）检索继续该方法的上下文。
getReferralContext(Hashtable<?, ?>) - 异常 javax.naming.ldap.LdapReferralException 中的方法
使用环境属性（但不使用控件）检索继续该方法的上下文。
getReferralContext(Hashtable<?, ?>, Control[]) - 异常 javax.naming.ldap.LdapReferralException 中的方法
使用请求控件和环境属性检索继续该方法的上下文。
getReferralContext() - 异常 javax.naming.ReferralException 中的方法
检索继续该方法的上下文。
getReferralContext(Hashtable<?, ?>) - 异常 javax.naming.ReferralException 中的方法
使用环境属性检索继续该方法的上下文。
getReferralInfo() - 异常 javax.naming.ReferralException 中的方法
检索与此引用有关的信息（比如 URL）。
getReferrals() - 接口 javax.naming.ldap.UnsolicitedNotification 中的方法
检索服务器发送的引用。
getRefMBeanClassName() - 类 javax.management.relation.RoleInfo 中的方法
返回期望在相应角色中引用的 MBean 的类型名称。
getRefreshRate() - 类 java.awt.DisplayMode 中的方法
返回显示的刷新率（以赫兹表示）如果信息不可用，则它可以是 REFRESH_RATE_UNKNOWN。
getRegion() - 类 javax.swing.plaf.synth.SynthContext 中的方法
返回标识此状态的 Region。
getRegion(JComponent) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
返回 JComponent c 的 Region。
getRegisteredKeyStrokes() - 类 javax.swing.JComponent 中的方法
返回启动已注册动作的 KeyStrokes。
getRegisteredProviders() - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
返回当前已注册的同步提供者所组成的枚举。
getRegistry() - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回本地主机在默认注册表端口 1099 上对远程对象 Registry 的引用。
getRegistry(int) - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回本地主机在指定 port 上对远程对象 Registry 的引用。
getRegistry(String) - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。
getRegistry(String, int) - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回指定的 host 和 port 上对远程对象 Registry 的引用。
getRegistry(String, int, RMIClientSocketFactory) - 类 java.rmi.registry.LocateRegistry 中的静态方法
返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。
getRejectedExecutionHandler() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回用于未执行任务的当前处理程序。
getRelatedData() - 接口 org.w3c.dom.DOMError 中的方法
相关的与 DOMError.type 有关的数据（如果有）。
getRelatedException() - 接口 org.w3c.dom.DOMError 中的方法
相关的与相关平台有关的异常（如果有）。
getRelatedNode() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的节点；如果没有可用的节点，则为 null。
getRelatedNode() - 接口 org.w3c.dom.events.MutationEvent 中的方法
relatedNode 用于识别与 mutation 事件相关联的辅助节点。
getRelatedTarget() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于识别与 UI 事件相关的辅助 EventTarget。
getRelationId() - 接口 javax.management.relation.Relation 中的方法
返回关系标识符（用于唯一标识 Relation Service 内的关系）。
getRelationId() - 类 javax.management.relation.RelationNotification 中的方法
返回创建/移除/更新的关系的关系标识符。
getRelationId() - 类 javax.management.relation.RelationSupport 中的方法
返回关系标识符（用于唯一标识 Relation Service 中的关系）。
getRelationServiceName() - 接口 javax.management.relation.Relation 中的方法
返回处理关系的 Relation Service 的 ObjectName。
getRelationServiceName() - 类 javax.management.relation.RelationSupport 中的方法
返回处理关系的 Relation Service 的 ObjectName。
getRelationTypeName() - 接口 javax.management.relation.Relation 中的方法
返回相关关系类型的名称。
getRelationTypeName() - 类 javax.management.relation.RelationNotification 中的方法
返回创建/移除/更新的关系的关系类型名称。
getRelationTypeName(String) - 类 javax.management.relation.RelationService 中的方法
返回给定关系的相关关系类型的名称。
getRelationTypeName(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
返回给定关系的相关关系类型的名称。
getRelationTypeName() - 类 javax.management.relation.RelationSupport 中的方法
返回相关关系类型的名称。
getRelationTypeName() - 接口 javax.management.relation.RelationType 中的方法
返回关系类型名称。
getRelationTypeName() - 类 javax.management.relation.RelationTypeSupport 中的方法
返回关系类型名称。
getRelay() - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
返回此 SOAPHeaderElement relay 属性的 boolean 值。
getRemaining() - 类 java.util.zip.Inflater 中的方法
返回输入缓冲区中剩余的字节总数。
getRemainingAcceptLifetime(Oid) - 接口 org.ietf.jgss.GSSCredential 中的方法
返回凭据以秒为单位的生存期，以便能够继续使用指定的机制接受安全上下文。
getRemainingInitLifetime(Oid) - 接口 org.ietf.jgss.GSSCredential 中的方法
返回凭据以秒为单位的生存期，以便能够继续使用指定的机制初始化安全上下文。
getRemainingLifetime() - 接口 org.ietf.jgss.GSSCredential 中的方法
返回凭据所剩余的以秒为单位的生存期。
getRemainingName() - 异常 javax.naming.NamingException 中的方法
检索名称的剩余未解析部分。
getRemainingName() - 类 javax.naming.spi.ResolveResult 中的方法
检索名称的剩余未解析部分。
getRemainingNewName() - 异常 javax.naming.CannotProceedException 中的方法
检索此异常的 "remaining new name" 字段，当执行 rename() 操作期间抛出此异常时，将使用该字段。
getRemoteSocketAddress() - 类 java.net.DatagramSocket 中的方法
返回此套接字连接的端点的地址，如果未连接则返回 null。
getRemoteSocketAddress() - 类 java.net.Socket 中的方法
返回此套接字连接的端点的地址，如果未连接则返回 null。
getRemoveListenerMethod() - 类 java.beans.EventSetDescriptor 中的方法
获得用来移除事件侦听器的方法。
getRenderableSource(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回作为 RenderableImage 的源。
getRenderedImage() - 类 javax.imageio.IIOImage 中的方法
返回当前设置好的 RenderedImage，如果只有一个 Raster 可用，则返回 null。
getRenderedSource(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回作为 RenderedImage 的源。
getRenderer() - 类 javax.swing.JComboBox 中的方法
返回用于显示 JComboBox 字段中所选项的渲染器。
getRenderingHint(RenderingHints.Key) - 类 java.awt.Graphics2D 中的方法
返回呈现算法的单个首选项的值。
getRenderingHints() - 类 java.awt.Graphics2D 中的方法
获取呈现算法的首选项。
getRenderingHints() - 类 java.awt.image.AffineTransformOp 中的方法
返回此转换操作使用的呈现提示。
getRenderingHints() - 类 java.awt.image.BandCombineOp 中的方法
返回针对此操作呈现的提示。
getRenderingHints() - 接口 java.awt.image.BufferedImageOp 中的方法
返回针对此操作所呈现的提示。
getRenderingHints() - 类 java.awt.image.ColorConvertOp 中的方法
此操作使用的呈现提示。
getRenderingHints() - 类 java.awt.image.ConvolveOp 中的方法
返回此 op 的呈现提示。
getRenderingHints() - 类 java.awt.image.LookupOp 中的方法
返回此操作的呈现提示。
getRenderingHints() - 接口 java.awt.image.RasterOp 中的方法
返回此 RasterOp 的呈现提示。
getRenderingHints() - 类 java.awt.image.renderable.RenderContext 中的方法
获取此 RenderContext 的呈现提示。
getRenderingHints() - 类 java.awt.image.RescaleOp 中的方法
返回此操作的呈现提示。
getRenewTill() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回此票据最新的期满时间，包括所有的更新。
getReorderingAllowed() - 类 javax.swing.table.JTableHeader 中的方法
如果允许用户通过拖动各列的头对其进行重新安排，则返回 true；否则返回 false。
getReplacementText() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
实体的替换文本。
getReplayDetState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否针对此上下文中的 per-message 安全服务启用了重放检测。
getRepresentationClass() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回请求此 DataFlavor 时，支持此 DataFlavor 的对象将返回的 Class。
getRepresentationClass() - 类 javax.activation.ActivationDataFlavor 中的方法
返回表示形式类。
getRepresentationClassName() - 类 javax.print.DocFlavor 中的方法
返回此 DocFlavor 对象的表示形式类名。
getRequestContext() - 接口 javax.xml.ws.BindingProvider 中的方法
获取用于初始化请求消息的消息上下文的上下文。
getRequestControls() - 类 javax.naming.ldap.InitialLdapContext 中的方法

getRequestControls() - 接口 javax.naming.ldap.LdapContext 中的方法
检索对此上下文有效的请求控件。
getRequestingHost() - 类 java.net.Authenticator 中的方法
获取请求验证的站点或代理的 hostname；如果不可用，则为 null。
getRequestingPort() - 类 java.net.Authenticator 中的方法
获取所请求的连接的端口号。
getRequestingPrompt() - 类 java.net.Authenticator 中的方法
获取请求方给出的提示字符串。
getRequestingProtocol() - 类 java.net.Authenticator 中的方法
给出正在请求连接的协议。
getRequestingScheme() - 类 java.net.Authenticator 中的方法
获取请求方的方案（例如，HTTP 防火墙的 HTTP 方案）。
getRequestingSite() - 类 java.net.Authenticator 中的方法
获取请求授权的站点的 InetAddress；如果不可用，则为 null。
getRequestingURL() - 类 java.net.Authenticator 中的方法
返回导致请求验证的 URL。
getRequestMethod() - 类 java.net.HttpURLConnection 中的方法
获取请求方法。
getRequestorType() - 类 java.net.Authenticator 中的方法
返回请求方是代理还是服务器。
getRequestProperties() - 类 java.net.URLConnection 中的方法
返回一个由此连接的一般请求属性构成的不可修改的 Map。
getRequestProperty(String) - 类 java.net.URLConnection 中的方法
返回此连接指定的一般请求属性值。
getReshowDelay() - 类 javax.swing.ToolTipManager 中的方法
返回重新显示延迟属性。
getResizable() - 类 javax.swing.table.TableColumn 中的方法
如果允许用户调整 TableColumn 的宽度，则返回 true；否则返回 false。
getResizeWeight() - 类 javax.swing.JSplitPane 中的方法
返回确定额外空间如何分配的数。
getResizeWeight(int) - 类 javax.swing.text.BoxView 中的方法
获取调整的权重。
getResizeWeight(int) - 类 javax.swing.text.FieldView 中的方法
确定视图沿给定轴的大小可调整性。
getResizeWeight(int) - 类 javax.swing.text.html.BlockView 中的方法
获取调整的权重。
getResizeWeight(int) - 类 javax.swing.text.TableView.TableRow 中的方法
确定视图沿给定轴的大小可调整性。
getResizeWeight(int) - 类 javax.swing.text.View 中的方法
确定视图沿给定轴的大小可调整性。
getResizingAllowed() - 类 javax.swing.table.JTableHeader 中的方法
如果允许用户通过在头间拖动来调整各列的大小，则返回 true；否则返回 false。
getResizingColumn() - 类 javax.swing.table.JTableHeader 中的方法
返回正在调整其大小的列。
getResolution(int) - 类 javax.print.attribute.ResolutionSyntax 中的方法
获取给定单位的此分辨率属性的分辨率值。
getResolution() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件的定时精度。
getResolution() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 的定时精度。
getResolvedName() - 异常 javax.naming.NamingException 中的方法
检索成功被解析的名称的开头部分。
getResolvedObj() - 异常 javax.naming.NamingException 中的方法
检索已成功解析成的对象。
getResolvedObj() - 类 javax.naming.spi.ResolveResult 中的方法
检索已成功解析成的 Object。
getResolveParent() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取要解析的父级。
getResolveParent() - 接口 javax.swing.text.AttributeSet 中的方法
获取解析父集合。
getResolveParent() - 类 javax.swing.text.html.HTMLDocument.BlockElement 中的方法
获得解析父级。
getResolveParent() - 类 javax.swing.text.html.HTMLDocument.RunElement 中的方法
获得解析父级。
getResolveParent() - 接口 javax.swing.text.Keymap 中的方法
获取用于解析键绑定的父级 keymap。
getResolveParent() - 类 javax.swing.text.SimpleAttributeSet 中的方法
获取正解析的父级。
getResolveParent() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
从父级获取属性。
getResolveParent() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
如果未重写，解析父级默认为是解析父元素。
getResource(String, BeanContextChild) - 接口 java.beans.beancontext.BeanContext 中的方法
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
getResource(String, BeanContextChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法

getResource(String) - 类 java.lang.Class 中的方法
查找带有给定名称的资源。
getResource(String) - 类 java.lang.ClassLoader 中的方法
查找具有给定名称的资源。
getResource(JavaFileManager.Location, CharSequence, CharSequence) - 接口 javax.annotation.processing.Filer 中的方法
返回一个用于读取现有资源的对象。
getResource(String) - 接口 javax.management.loading.MLetMBean 中的方法
查找具有给定名称的资源。
getResourceAsStream(String, BeanContextChild) - 接口 java.beans.beancontext.BeanContext 中的方法
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
getResourceAsStream(String, BeanContextChild) - 类 java.beans.beancontext.BeanContextSupport 中的方法

getResourceAsStream(String) - 类 java.lang.Class 中的方法
查找具有给定名称的资源。
getResourceAsStream(String) - 类 java.lang.ClassLoader 中的方法
返回读取指定资源的输入流。
getResourceAsStream(String) - 接口 javax.management.loading.MLetMBean 中的方法
返回读取指定资源的输入流。
getResourceBaseName() - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
返回当前设置的用于查找 ResourceBundle 的基本名称。
getResourceBundle() - 类 java.util.logging.Logger 中的方法
获取此 logger 在当前默认语言环境的本地化资源包。
getResourceBundle() - 类 java.util.logging.LogRecord 中的方法
获取本地化资源包。
getResourceBundleName() - 类 java.util.logging.Level 中的方法
返回级别的本地化资源包名称；如果没有定义本地化包，则返回 null。
getResourceBundleName() - 类 java.util.logging.Logger 中的方法
获取此 logger 的本地化资源包名称。
getResourceBundleName() - 类 java.util.logging.LogRecord 中的方法
获取本地化资源包名称。
getResourceResolver() - 类 javax.xml.validation.SchemaFactory 中的方法
获取设置为此 SchemaFactory 的当前 LSResourceResolver。
getResourceResolver() - 类 javax.xml.validation.Validator 中的方法
获取设置为此 Validator 的当前 LSResourceResolver。
getResourceResolver() - 类 javax.xml.validation.ValidatorHandler 中的方法
获取设置到此 ValidatorHandler 的当前 LSResourceResolver。
getResources(String) - 类 java.lang.ClassLoader 中的方法
查找所有给定名称的资源。
getResources(String) - 接口 javax.management.loading.MLetMBean 中的方法
查找所有具有给定名称的资源。
getResources() - 接口 javax.sound.midi.Soundbank 中的方法
提取音库中包含的非乐器资源列表。
getResponseCode() - 类 java.net.HttpURLConnection 中的方法
从 HTTP 响应消息获取状态码。
getResponseContext() - 接口 javax.xml.ws.BindingProvider 中的方法
获取处理响应消息所得的上下文。
getResponseControls() - 类 javax.naming.ldap.InitialLdapContext 中的方法

getResponseControls() - 接口 javax.naming.ldap.LdapContext 中的方法
检索对此上下文调用的最后一个方法所生成的响应控件。
getResponseMessage() - 类 java.net.HttpURLConnection 中的方法
获取与来自服务器的响应代码一起返回的 HTTP 响应消息（如果有）。
getRestartMode() - 类 java.rmi.activation.ActivationDesc 中的方法
返回与此激活描述符关联的对象的“重启”模式。
getResult() - 接口 javax.xml.bind.UnmarshallerHandler 中的方法
获得解组的结果。
getResult() - 类 javax.xml.bind.util.JAXBResult 中的方法
获取通过转换创建的已解组对象。
getResult() - 类 javax.xml.soap.SAAJResult 中的方法

getResultCode() - 类 javax.naming.ldap.SortResponseControl 中的方法
检索排序操作的 LDAP 结果代码。
getResultSet() - 接口 java.sql.Array 中的方法
获取包含此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
getResultSet(Map<String, Class<?>>) - 接口 java.sql.Array 中的方法
获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
getResultSet(long, int) - 接口 java.sql.Array 中的方法
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
getResultSet(long, int, Map<String, Class<?>>) - 接口 java.sql.Array 中的方法
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
getResultSet() - 接口 java.sql.Statement 中的方法
以 ResultSet 对象的形式获取当前结果。
getResultSet(long, int) - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取保存子数组元素的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
getResultSet(Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。
getResultSet() - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 ARRAY 值中的元素。
getResultSet(long, int, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 中的方法
获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
getResultSetConcurrency() - 接口 java.sql.Statement 中的方法
获取此 Statement 对象生成的 ResultSet 对象的结果集合并发性。
getResultSetHoldability() - 接口 java.sql.DatabaseMetaData 中的方法
针对 ResultSet 对象获取此数据库的默认可保存性。
getResultSetHoldability() - 接口 java.sql.Statement 中的方法
获取此 Statement 对象生成的 ResultSet 对象的结果集合可保存性。
getResultSetType() - 接口 java.sql.Statement 中的方法
获取此 Statement 对象生成的 ResultSet 对象的结果集合类型。
getResultSize() - 类 javax.naming.ldap.PagedResultsResponseControl 中的方法
检索搜索结果中的项数（估计值）。
getResultStream(boolean) - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
getReturningAttributes() - 类 javax.naming.directory.SearchControls 中的方法
检索将作为搜索的一部分返回的属性。
getReturningObjFlag() - 类 javax.naming.directory.SearchControls 中的方法
确定对象是否将作为结果的一部分返回。
getReturnOpenType() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 描述的操作所返回的值的开放类型。
getReturnOpenType() - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 中的方法
返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的开放类型。
getReturnType() - 类 java.lang.reflect.Method 中的方法
返回一个 Class 对象，该对象描述了此 Method 对象所表示的方法的正式返回类型。
getReturnType() - 接口 javax.lang.model.element.ExecutableElement 中的方法
返回此 executable 的返回类型。
getReturnType() - 接口 javax.lang.model.type.ExecutableType 中的方法
返回此 executable 的返回类型。
getReturnType() - 类 javax.management.MBeanOperationInfo 中的方法
返回该方法的返回值的类型。
getReturnType() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的完全限定的 Java 类名。
getReuseAddress() - 类 java.net.DatagramSocket 中的方法
检测是否启用了 SO_REUSEADDR。
getReuseAddress() - 类 java.net.ServerSocket 中的方法
测试是否启用 SO_REUSEADDR。
getReuseAddress() - 类 java.net.Socket 中的方法
测试是否启用 SO_REUSEADDR。
getRevocationDate() - 类 java.security.cert.X509CRLEntry 中的方法
获取此 X509CRLEntry 的撤消日期 revocationDate。
getRevokedCertificate(BigInteger) - 类 java.security.cert.X509CRL 中的方法
获取具有给定证书 serialNumber 的 CRL 项（如果有）。
getRevokedCertificate(X509Certificate) - 类 java.security.cert.X509CRL 中的方法
获取给定证书的 CRL 项（如果有）。
getRevokedCertificates() - 类 java.security.cert.X509CRL 中的方法
获取此 CRL 中的所有项。
getRGB() - 类 java.awt.Color 中的方法
返回默认 sRGB ColorModel 中表示颜色的 RGB 值。
getRGB(int, int) - 类 java.awt.image.BufferedImage 中的方法
返回默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中的整数像素。
getRGB(int, int, int, int, int[], int, int) - 类 java.awt.image.BufferedImage 中的方法
从图像数据的某一部分返回默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中整数像素数组。
getRGB(int) - 类 java.awt.image.ColorModel 中的方法
返回默认的 RGB 颜色模型格式中像素的颜色/alpha 分量。
getRGB(Object) - 类 java.awt.image.ColorModel 中的方法
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
getRGB(int) - 类 java.awt.image.ComponentColorModel 中的方法
返回默认的 RGB 颜色模型格式中像素的颜色/alpha 分量。
getRGB(Object) - 类 java.awt.image.ComponentColorModel 中的方法
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
getRGB(int) - 类 java.awt.image.DirectColorModel 中的方法
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
getRGB(Object) - 类 java.awt.image.DirectColorModel 中的方法
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
getRGB(int) - 类 java.awt.image.IndexColorModel 中的方法
以默认 RGB 颜色模型格式返回像素的颜色/alpha 分量。
getRGB() - 类 java.awt.SystemColor 中的方法
获取表示象征性颜色的“当前”RGB 值。
getRGBColorComponents(float[]) - 类 java.awt.Color 中的方法
根据默认的 sRGB color space，返回一个 float 数组，该数组只包含 Color 的颜色分量。
getRGBComponents(float[]) - 类 java.awt.Color 中的方法
根据默认的 sRGB color space，返回一个 float 数组，该数组包含 Color 的颜色分量和 alpha 分量。
getRGBdefault() - 类 java.awt.image.ColorModel 中的静态方法
返回描述整数 RGB 值的默认格式的 DirectColorModel，该整数 RGB 值可以在便于程序员使用的 AWT 图像接口中的许多方法中使用。
getRGBs(int[]) - 类 java.awt.image.IndexColorModel 中的方法
将颜色和 alpha 分量数组中每个索引的数据转换成默认 RGB ColorModel 格式的 int 值，并将得到的 32 位 ARGB 值复制到指定数组中。
getRightChildIndent() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getRightComponent() - 类 javax.swing.JSplitPane 中的方法
返回分隔条右边（或者下面）的组件。
getRightIndent(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取右边缩进设置。
getRightInset() - 类 javax.swing.text.AsyncBoxView 中的方法
获得视图四周右侧的空白部分。
getRightInset() - 类 javax.swing.text.CompositeView 中的方法
获取右部 inset。
getRMIRepositoryID(Class) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
返回给定 Java 类的 CORBA RepositoryId。
getRole(String) - 接口 javax.management.relation.Relation 中的方法
检索给定角色名称的角色值。
getRole(String, String) - 类 javax.management.relation.RelationService 中的方法
检索给定关系中给定角色名称的角色值。
getRole(String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定关系中给定角色名称的角色值。
getRole(String) - 类 javax.management.relation.RelationSupport 中的方法
检索给定角色名称的角色值。
getRole() - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
返回此 SOAPHeaderElement Role 属性的值。
getRoleCardinality(String) - 接口 javax.management.relation.Relation 中的方法
返回当前在给定角色中引用的 MBean 数。
getRoleCardinality(String, String) - 类 javax.management.relation.RelationService 中的方法
检索给定角色中当前引用的 MBean 数。
getRoleCardinality(String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定角色中当前引用的 MBean 数。
getRoleCardinality(String) - 类 javax.management.relation.RelationSupport 中的方法
返回当前在给定角色中引用的 MBean 数。
getRoleInfo(String, String) - 类 javax.management.relation.RelationService 中的方法
检索给定关系类型的给定角色名称的角色信息。
getRoleInfo(String, String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定关系类型的给定角色的角色信息。
getRoleInfo(String) - 接口 javax.management.relation.RelationType 中的方法
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
getRoleInfo(String) - 类 javax.management.relation.RelationTypeSupport 中的方法
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
getRoleInfos(String) - 类 javax.management.relation.RelationService 中的方法
检索给定关系类型的角色信息（RoleInfo 对象）的列表。
getRoleInfos(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定关系类型的角色信息（RoleInfo 对象）的列表。
getRoleInfos() - 接口 javax.management.relation.RelationType 中的方法
返回角色定义的列表（RoleInfo 对象的 ArrayList）。
getRoleInfos() - 类 javax.management.relation.RelationTypeSupport 中的方法
返回角色定义的列表（RoleInfo 对象的 ArrayList）。
getRoleName() - 类 javax.management.relation.RelationNotification 中的方法
返回更新关系的更新角色的名称（仅限于角色更新）。
getRoleName() - 类 javax.management.relation.Role 中的方法
检索角色名称。
getRoleName() - 类 javax.management.relation.RoleUnresolved 中的方法
检索角色名称。
getRoles(String[]) - 接口 javax.management.relation.Relation 中的方法
检索具有给定名称的角色值。
getRoles(String, String[]) - 类 javax.management.relation.RelationService 中的方法
检索给定关系中具有给定名称的角色值。
getRoles(String, String[]) - 接口 javax.management.relation.RelationServiceMBean 中的方法
检索给定关系中具有给定名称的角色值。
getRoles(String[]) - 类 javax.management.relation.RelationSupport 中的方法
检索具有给定名称的角色值。
getRoles() - 类 javax.management.relation.RoleResult 中的方法
检索成功访问的角色列表。
getRoles() - 接口 javax.xml.ws.handler.soap.SOAPMessageContext 中的方法
获取与执行处理程序链关联的 SOAP 参与者角色。
getRoles() - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
获取 SOAP 绑定实例所扮演的角色。
getRolesUnresolved() - 类 javax.management.relation.RoleResult 中的方法
检索未成功访问的角色列表。
getRoleValue() - 类 javax.management.relation.Role 中的方法
检索角色值。
getRoleValue() - 类 javax.management.relation.RoleUnresolved 中的方法
检索角色值。
getRolloverBorder(AbstractButton) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
返回按钮的翻转边框。
getRolloverColumn() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
返回鼠标当前位于其上的列标题的索引。
getRolloverIcon() - 类 javax.swing.AbstractButton 中的方法
返回按钮的翻转图标。
getRolloverSelectedIcon() - 类 javax.swing.AbstractButton 中的方法
返回按钮的翻转选定图标。
getRolloverTab() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回当前有鼠标位于其上方的选项卡；如果鼠标不再位于任何选项卡上，则返回 -1。
getRoot(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回当前组件树结构的根组件。
getRoot() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回包含此节点的树的根。
getRoot() - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回树的根。
getRoot() - 接口 javax.swing.tree.TreeModel 中的方法
返回树的根。
getRootCause() - 异常 javax.naming.NamingException 中的方法
检索此 NamingException 的根 cause，如果有的话。
getRootElement() - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
获得根元素。
getRootElements() - 接口 javax.annotation.processing.RoundEnvironment 中的方法
返回以前的 round 生成的注释处理根元素。
getRootElements() - 类 javax.swing.text.AbstractDocument 中的方法
获得已定义的所有根元素。
getRootElements() - 接口 javax.swing.text.Document 中的方法
返回定义的所有根元素。
getRootFrame() - 类 javax.swing.JOptionPane 中的静态方法
返回用于不提供窗体的类方法中的 Frame。
getRootName() - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
返回格式的根元素的名称。
getRootName() - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法

getRootPane() - 类 javax.swing.JApplet 中的方法
返回此 applet 的 rootPane 对象。
getRootPane() - 类 javax.swing.JComponent 中的方法
返回此组件的 JRootPane 祖先。
getRootPane() - 类 javax.swing.JDialog 中的方法
返回此对话框的 rootPane 对象。
getRootPane() - 类 javax.swing.JFrame 中的方法
返回此窗体的 rootPane 对象。
getRootPane() - 类 javax.swing.JInternalFrame 中的方法
返回此内部窗体的 rootPane 对象。
getRootPane() - 类 javax.swing.JWindow 中的方法
返回此窗口的 rootPane 对象。
getRootPane() - 接口 javax.swing.RootPaneContainer 中的方法
返回此组件的单个 JRootPane 子组件。
getRootPane(Component) - 类 javax.swing.SwingUtilities 中的静态方法
如果 c 是一个 JRootPane 后代，则返回其 JRootPane 祖先。
getRoots() - 类 javax.swing.filechooser.FileSystemView 中的方法
返回此系统的所有根分区。
getRootView(JTextComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取分配了相关文本组件（即层次结构的根）的 View，可通过遍历该视图确定模型在空间中的表示形式。
getRootView(JTextComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getRootView 方法。
getRootView(JTextComponent) - 类 javax.swing.plaf.TextUI 中的方法
获取分配了相关文本组件（即层次结构的根）的 View，可遍历这些组件来确定在空间中表示模型的形式。
getRotateInstance(double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回表示旋转变换的变换。
getRotateInstance(double, double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回绕锚点旋转坐标的变换。
getRotateInstance(double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回根据旋转向量旋转坐标的变换。
getRotateInstance(double, double, double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回根据旋转向量绕锚点坐标旋转坐标的变换。
getRoundedCorners() - 类 javax.swing.border.LineBorder 中的方法
返回是否将此边框绘制为圆弧拐角边框。
getRoundingMode() - 类 java.math.MathContext 中的方法
返回 roundingMode 设置。
getRoundingMode() - 类 java.text.DecimalFormat 中的方法
获取在此 DecimalFormat 中使用的 RoundingMode。
getRoundingMode() - 类 java.text.NumberFormat 中的方法
获取在此 NumberFormat 中使用的 RoundingMode。
getRounds() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
返回 rounds 的数量。
getRow() - 接口 java.sql.ResultSet 中的方法
获取当前行编号。
getRow() - 类 javax.swing.JTable.DropLocation 中的方法
返回表中应该用来放入放置项的行索引。
getRowBounds(int) - 类 javax.swing.JTree 中的方法
返回将指定行处的节点绘入的 Rectangle。
getRowCount() - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回模型中的行数。
getRowCount() - 类 javax.swing.JTable 中的方法
返回 JTable 中可以显示的行数（给定无限空间）。
getRowCount() - 类 javax.swing.JTree 中的方法
返回当前正在显示的行数。
getRowCount(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回将显示的行数。
getRowCount(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getRowCount 方法。
getRowCount(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
返回将显示的行数。
getRowCount() - 类 javax.swing.table.DefaultTableModel 中的方法
返回此数据表中的行数。
getRowCount() - 接口 javax.swing.table.TableModel 中的方法
返回该模型中的行数。
getRowCount() - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 获取此单元格所跨的行数（即网格高度）。
getRowCount() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
显示的行数。
getRowCount() - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回可视的行数。
getRowCount() - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回可见的行数。
getRowEnd(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定包含指定模型位置的行的结束行模型位置。
getRowFilter() - 类 javax.swing.DefaultRowSorter 中的方法
返回用于确定哪些行（如果有）应该在视图中隐藏的过滤器。
getRowForLocation(int, int) - 类 javax.swing.JTree 中的方法
返回指定位置的行。
getRowForPath(TreePath) - 类 javax.swing.JTree 中的方法
返回显示由指定路径标识的节点的行。
getRowForPath(JTree, TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回可在其中看见路径中标识的最后一个项的行。
getRowForPath(JTree, TreePath) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 getRowForPath 方法。
getRowForPath(JTree, TreePath) - 类 javax.swing.plaf.TreeUI 中的方法
返回可在其中看见路径中标识的最后一个项的行。
getRowForPath(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回其路径中标识的最后一项可视的行。
getRowForPath(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回路径中标识的最后一项可见的行。
getRowForPath(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回路径中标识的最后一项在其中可见的行。
getRowHeader() - 类 javax.swing.JScrollPane 中的方法
返回行标题。
getRowHeader() - 类 javax.swing.ScrollPaneLayout 中的方法
返回行标题对应的 JViewport 对象。
getRowHeight() - 类 javax.swing.JTable 中的方法
返回表的行高，以像素为单位。
getRowHeight(int) - 类 javax.swing.JTable 中的方法
返回 row 中单元格的高度，以像素为单位。
getRowHeight() - 类 javax.swing.JTextArea 中的方法
定义行高的意义。
getRowHeight() - 类 javax.swing.JTree 中的方法
返回每个行的高度。
getRowHeight(int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回基于当前布局的指定行的高度。
getRowHeight() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getRowHeight() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回每行高度。
getRowId(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
getRowId(String) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
getRowId(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getRowId(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getRowIdLifetime() - 接口 java.sql.DatabaseMetaData 中的方法
指示此数据源是否支持 SQL ROWID 类型，如果支持，则 RowId 对象在该类型的生存期内持续有效。
getRowMapper() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回能够将 TreePath 映射到行的 RowMapper 实例。
getRowMapper() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回能够将 TreePath 映射到行的 RowMapper 实例。
getRowMargin() - 类 javax.swing.JTable 中的方法
获取单元格之间的间距，以像素为单位。
getRows() - 类 java.awt.GridLayout 中的方法
获取此布局中的行数。
getRows() - 类 java.awt.List 中的方法
获取此列表中的可视行数。
getRows() - 类 java.awt.TextArea 中的方法
返回此文本区的行数。
getRows() - 类 javax.swing.JTextArea 中的方法
返回 TextArea 中的行数。
getRowSelectionAllowed() - 类 javax.swing.JTable 中的方法
如果可以选择行，则返回 true。
getRowSetNames() - 接口 javax.sql.rowset.JoinRowSet 中的方法
返回一个 String 数组，包含添加到此 JoinRowSet 对象的 RowSet 对象的名称。
getRowSetReader() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回 javax.sql.RowSetReader 对象，它可以用于填充带有数据的 RowSet 对象。
getRowSets() - 接口 javax.sql.rowset.JoinRowSet 中的方法
返回一个 Collection 对象，包含已经添加到此 JoinRowSet 对象的 RowSet 对象。
getRowSetWarnings() - 接口 javax.sql.rowset.CachedRowSet 中的方法
获取此 RowSet 对象上的调用报告的第一个警告。
getRowSetWarnings() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
获取此 JdbcRowSet 对象上的调用报告的第一个警告。
getRowSetWriter() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回 javax.sql.RowSetWriter 对象，它可以用于将 RowSet 对象的数据写回底层数据源。
getRowsForPaths(TreePath[]) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回在其中显示 path 中 TreePath 实例的行。
getRowsForPaths(TreePath[]) - 接口 javax.swing.tree.RowMapper 中的方法
返回显示 path 中的 TreePath 实例的行。
getRowSorter() - 类 javax.swing.JTable 中的方法
返回负责排序的对象。
getRowStart(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定包含指定模型位置的行的起始行模型位置。
getRowType() - 类 javax.management.openmbean.TabularType 中的方法
返回此 TabularType 实例描述的表格数据值的行元素的类型。
getRowX(int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回沿 x 轴呈现特定行的位置。
getRowX(int, int) - 类 javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler 中的方法

getRSB() - 类 java.awt.font.GlyphMetrics 中的方法
返回该字形的右（底）跨距。
getRule() - 类 java.awt.AlphaComposite 中的方法
返回此 AlphaComposite 的合成规则。
getRule(HTML.Tag, Element) - 类 javax.swing.text.html.StyleSheet 中的方法
获取用来呈现给定类型的 HTML 标记的样式。
getRule(String) - 类 javax.swing.text.html.StyleSheet 中的方法
获取最能匹配以字符串形式表示的选择器的规则。
getRules() - 类 java.text.RuleBasedCollator 中的方法
获取 collation 对象的基于表的规则。
getRunCount() - 类 java.text.Bidi 中的方法
返回层次运行的数目。
getRunForTab(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getRunLevel(int) - 类 java.text.Bidi 中的方法
返回该行中第 n 次逻辑运行的层次。
getRunLimit() - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的所有属性的运行之后的第一个字符的索引。
getRunLimit(AttributedCharacterIterator.Attribute) - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的给定属性的运行之后的第一个字符的索引。
getRunLimit(Set<? extends AttributedCharacterIterator.Attribute>) - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的给定多个属性的运行之后的第一个字符的索引。
getRunLimit(int) - 类 java.text.Bidi 中的方法
以该行开始的偏移量返回该行中第 n 次逻辑运行之后的字符索引。
getRunStart() - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的所有属性的运行的第一个字符的索引。
getRunStart(AttributedCharacterIterator.Attribute) - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的给定属性的运行的第一个字符的索引。
getRunStart(Set<? extends AttributedCharacterIterator.Attribute>) - 接口 java.text.AttributedCharacterIterator 中的方法
返回关于包含当前字符的给定多个属性的运行的第一个字符的索引。
getRunStart(int) - 类 java.text.Bidi 中的方法
以该行开始的偏移量返回该行中第 n 次逻辑运行开始时的字符索引。
getRuntime() - 类 java.lang.Runtime 中的静态方法
返回与当前 Java 应用程序相关的运行时对象。
getRunTimeCodeBase() - 接口 javax.rmi.CORBA.ValueHandler 中的方法
返回此 ValueHandler 的 CodeBase。
getRuntimeMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的运行时系统的管理 Bean。
getS() - 接口 java.security.interfaces.ECPrivateKey 中的方法
返回专用密钥值 S。
getS() - 类 java.security.spec.ECPrivateKeySpec 中的方法
返回专用值 S。
getSalt() - 接口 javax.crypto.interfaces.PBEKey 中的方法
返回 salt；如果未指定，则返回 null。
getSalt() - 类 javax.crypto.spec.PBEKeySpec 中的方法
返回 salt 的一份副本，如果未指定则返回 null。
getSalt() - 类 javax.crypto.spec.PBEParameterSpec 中的方法
返回 salt。
getSaltLength() - 类 java.security.spec.PSSParameterSpec 中的方法
返回 salt 长度（以比特为单位）。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x, y) 处像素的样本。
getSample(int, int, int) - 类 java.awt.image.Raster 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSample(int, int, int, DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleDouble(int, int, int, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleDouble(int, int, int, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleDouble(int, int, int) - 类 java.awt.image.Raster 中的方法
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleDouble(int, int, int, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleFloat(int, int, int, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleFloat(int, int, int, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleFloat(int, int, int) - 类 java.awt.image.Raster 中的方法
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleFloat(int, int, int, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
getSampleModel() - 类 java.awt.image.BufferedImage 中的方法
返回与此 BufferedImage 关联的 SampleModel。
getSampleModel() - 类 java.awt.image.Raster 中的方法
返回描述图像数据布局的 SampleModel。
getSampleModel() - 接口 java.awt.image.RenderedImage 中的方法
返回与此图像相关的 SampleModel。
getSampleModel() - 类 javax.imageio.ImageTypeSpecifier 中的方法
根据此对象中封装的设置返回一个 SampleModel。
getSampleModel(int, int) - 类 javax.imageio.ImageTypeSpecifier 中的方法
根据此对象中封装的设置值返回一个 SampleModel。
getSampleModelTranslateX() - 类 java.awt.image.Raster 中的方法
返回从 SampleModel 坐标系到 Raster 坐标系的 X 平移。
getSampleModelTranslateY() - 类 java.awt.image.Raster 中的方法
返回从 SampleModel 坐标系到 Raster 坐标系的 Y 平移。
getSampleRate() - 类 javax.sound.sampled.AudioFormat 中的方法
获取样本速率。
getSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
在 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数据数组元素对应一个样本。
getSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
返回指定 band 中对应于 int 数组中指定像素矩形的样本，每个数据数组元素一个样本。
getSamples(int, int, int, int, int, int[]) - 类 java.awt.image.Raster 中的方法
以 int 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, float[]) - 类 java.awt.image.Raster 中的方法
以 float 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, double[]) - 类 java.awt.image.Raster 中的方法
以 double 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 float 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
在一个 double 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
getSampleSize() - 类 java.awt.image.ComponentSampleModel 中的方法
返回所有 band 每个样本的位数。
getSampleSize(int) - 类 java.awt.image.ComponentSampleModel 中的方法
返回指定 band 每个样本的位数。
getSampleSize() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回所有 band 的每样本位数。
getSampleSize(int) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回指定 band 的每样本位数。
getSampleSize() - 类 java.awt.image.SampleModel 中的方法
返回所有 band 样本的大小（以位为单位）。
getSampleSize(int) - 类 java.awt.image.SampleModel 中的方法
返回指定 band 样本的大小（以位为单位）。
getSampleSize() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回所有 band 的每样本位数。
getSampleSize(int) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回指定 band 的每样本位数。
getSampleSizeInBits() - 类 javax.sound.sampled.AudioFormat 中的方法
获取样本的大小。
getSaslClientFactories() - 类 javax.security.sasl.Sasl 中的静态方法
获得用于生成 SaslClient 的已知工厂的枚举。
getSaslServerFactories() - 类 javax.security.sasl.Sasl 中的静态方法
获得用于生成 SaslServer 的已知工厂的枚举。
getSavepointId() - 接口 java.sql.Savepoint 中的方法
获取此 Savepoint 对象表示的保存点的生成 ID。
getSavepointName() - 接口 java.sql.Savepoint 中的方法
获取此 Savepoint 对象表示的保存点的名称。
getScale(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的小数点右边的位数。
getScale(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的小数点右边的位数。
getScale(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定列中的值的小数点右边的数字数。
getScaledInstance(int, int, int) - 类 java.awt.Image 中的方法
创建此图像的缩放版本。
getScaledInstance(float, boolean) - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的方法
返回新的量化表，其中所有值都乘以 scaleFactor，然后取 1 到 32767（如果 forceBaseline 为 true，则使用 1 到 255）范围中的值。
getScaleFactors(float[]) - 类 java.awt.image.RescaleOp 中的方法
返回给定数组中的缩放因子。
getScaleInstance(double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回表示缩放变换的变换。
getScaleX() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵缩放元素 (m00) 的 X 坐标。
getScaleY() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵缩放元素 (m11) 的 Y 坐标。
getScanlineStride() - 类 java.awt.image.ComponentSampleModel 中的方法
返回此 ComponentSampleModel 的扫描行间距。
getScanlineStride() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回扫描行的间距。
getScanlineStride() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
返回此 SinglePixelPackedSampleModel 的扫描行间距。
getSchema(Name) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的模式。
getSchema(String) - 接口 javax.naming.directory.DirContext 中的方法
检索与命名对象关联的模式。
getSchema(String) - 类 javax.naming.directory.InitialDirContext 中的方法

getSchema(Name) - 类 javax.naming.directory.InitialDirContext 中的方法

getSchema() - 类 javax.xml.bind.Binder 中的方法
获取 Binder.setSchema(Schema) 方法设置的最后一个 Schema 对象（包括 null）。
getSchema() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法

getSchema() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法

getSchema() - 接口 javax.xml.bind.Marshaller 中的方法
获取用于执行编组时验证的 JAXP 1.3 Schema 对象。
getSchema() - 接口 javax.xml.bind.Unmarshaller 中的方法
获取用于执行解组时验证的 JAXP 1.3 Schema 对象。
getSchema() - 类 javax.xml.parsers.DocumentBuilder 中的方法
获取由 XML 处理器使用的 Schema 的引用。
getSchema() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
获取通过 DocumentBuilderFactory.setSchema(Schema schema) 方法指定的 Schema 对象。
getSchema() - 类 javax.xml.parsers.SAXParser 中的方法
获取对 XML 处理器使用的 Schema 的引用。
getSchema() - 类 javax.xml.parsers.SAXParserFactory 中的方法
获取通过 SAXParserFactory.setSchema(Schema schema) 方法指定的 Schema 对象。
getSchemaClassDefinition(Name) - 接口 javax.naming.directory.DirContext 中的方法
检索包含命名对象类定义的模式对象的上下文。
getSchemaClassDefinition(String) - 接口 javax.naming.directory.DirContext 中的方法
检索包含命名对象类定义的模式对象的上下文。
getSchemaClassDefinition(String) - 类 javax.naming.directory.InitialDirContext 中的方法

getSchemaClassDefinition(Name) - 类 javax.naming.directory.InitialDirContext 中的方法

getSchemaLocation() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取当前 schemaLocation 的便捷方法。
getSchemaName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的表模式。
getSchemaName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取派生指定列中值的表的模式名称。
getSchemas() - 接口 java.sql.DatabaseMetaData 中的方法
获取可在此数据库中使用的模式名称。
getSchemas(String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库中可用的模式名称。
getSchemaTerm() - 接口 java.sql.DatabaseMetaData 中的方法
获取数据库供应商用于 "schema" 的首选术语。
getSchemaType() - 接口 javax.xml.stream.events.XMLEvent 中的方法
提供此方法是为了提供有关关联事件的可选类型信息。
getSchemaTypeInfo() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getSchemaTypeInfo() - 接口 org.w3c.dom.Attr 中的方法
与此属性相关联的类型信息。
getSchemaTypeInfo() - 接口 org.w3c.dom.Element 中的方法
与此元素相关的类型信息。
getScheme() - 类 java.net.URI 中的方法
返回此 URI 的方案组成部分。
getSchemeSpecificPart() - 类 java.net.URI 中的方法
返回此 URI 的特定于方案的解码部分。
getScope() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的作用域。
getScope() - 类 javax.xml.bind.JAXBElement 中的方法
返回 xml 元素声明的作用域。
getScope(String) - 接口 javax.xml.ws.handler.MessageContext 中的方法
获得属性的作用域。
getScopedInterface() - 类 java.net.Inet6Address 中的方法
如果此实例是使用范围接口创建的，则返回范围接口。
getScopeId() - 类 java.net.Inet6Address 中的方法
如果此实例与接口关联，则返回数字 scoped_id。
getScopes() - 接口 javax.script.ScriptContext 中的方法
返回 ScriptContext 中所有有效范围值的不可变 List。
getScopes() - 类 javax.script.SimpleScriptContext 中的方法
返回 ScriptContext 中所有有效范围值的不可变 List。
getScreenDevices() - 类 java.awt.GraphicsEnvironment 中的方法
返回所有屏幕 GraphicsDevice 对象组成的数组。
getScreenInsets(GraphicsConfiguration) - 类 java.awt.Toolkit 中的方法
获得屏幕的 insets。
getScreenResolution() - 类 java.awt.Toolkit 中的方法
返回屏幕分辨率，以每英寸的点数为单位。
getScreenSize() - 类 java.awt.Toolkit 中的方法
获取屏幕的大小。
getScreenX() - 接口 org.w3c.dom.events.MouseEvent 中的方法
相对于屏幕坐标系统原点的水平坐标(事件发生在此处)。
getScreenY() - 接口 org.w3c.dom.events.MouseEvent 中的方法
相对于屏幕坐标系统原点的垂直坐标(事件发生在此处)。
getScriptContext(Bindings) - 类 javax.script.AbstractScriptEngine 中的方法
返回一个 SimpleScriptContext。
getScriptEngine() - 接口 javax.script.ScriptEngineFactory 中的方法
返回与此 ScriptEngineFactory 关联的 ScriptEngine 的实例。
getScrollableBlockIncrement(Rectangle, int, int) - 类 javax.swing.JList 中的方法
返回为显露上一个或下一个块而滚动的距离。
getScrollableBlockIncrement(Rectangle, int, int) - 类 javax.swing.JTable 中的方法
返回 visibleRect.height 或 visibleRect.width，这取决于此表的方向。
getScrollableBlockIncrement(Rectangle, int, int) - 类 javax.swing.JTree 中的方法
返回块增量的数量，它是基于 orientation 的 visibleRect 高度或宽度。
getScrollableBlockIncrement(Rectangle, int, int) - 接口 javax.swing.Scrollable 中的方法
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
getScrollableBlockIncrement(Rectangle, int, int) - 类 javax.swing.text.JTextComponent 中的方法
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
getScrollableTracksViewportHeight() - 类 javax.swing.JEditorPane 中的方法
如果某个视口始终应该强迫此 Scrollable 的高度符合该视口的高度，则返回 true。
getScrollableTracksViewportHeight() - 类 javax.swing.JList 中的方法
如果此 JList 在 JViewport 中显示并且视口的高度大于列表的首选高度，或者布局方向为 VERTICAL_WRAP 或 visibleRowCount <= 0，则返回 true；否则返回 false。
getScrollableTracksViewportHeight() - 类 javax.swing.JTable 中的方法
返回 false 指示表的高度不是由视口的高度决定的，除非 getFillsViewportHeight 为 true 并且该表的首选高度小于视口的高度。
getScrollableTracksViewportHeight() - 类 javax.swing.JTree 中的方法
返回 false 指示视口的高度不能确定表的高度，除非树的首选高度小于视口高度。
getScrollableTracksViewportHeight() - 接口 javax.swing.Scrollable 中的方法
如果视口总是强制此 Scrollable 的高度与视口高度匹配，则返回 true。
getScrollableTracksViewportHeight() - 类 javax.swing.text.JTextComponent 中的方法
如果视口总是强制此 Scrollable 的高度与视口高度匹配，则返回 true。
getScrollableTracksViewportWidth() - 类 javax.swing.JEditorPane 中的方法
如果某个视口始终应该强迫此 Scrollable 的宽度符合该视口的宽度，则返回 true。
getScrollableTracksViewportWidth() - 类 javax.swing.JList 中的方法
如果此 JList 在 JViewport 中显示并且视口的宽度大于列表的首选宽度，或者布局方向为 HORIZONTAL_WRAP 和 visibleRowCount <= 0，则返回 true；否则返回 false。
getScrollableTracksViewportWidth() - 类 javax.swing.JTable 中的方法
如果 autoResizeMode 设置为 AUTO_RESIZE_OFF，则返回 false，这指示表的宽度不是由视口的宽度决定的。
getScrollableTracksViewportWidth() - 类 javax.swing.JTextArea 中的方法
如果 viewport 总是强制要求此 Scrollable 的宽度与 viewport 的宽度相匹配，则返回 true。
getScrollableTracksViewportWidth() - 类 javax.swing.JTree 中的方法
返回 false 指示视口的宽度不能确定表的宽度，除非树的首选宽度小于视口宽度。
getScrollableTracksViewportWidth() - 接口 javax.swing.Scrollable 中的方法
如果视口总是强制此 Scrollable 的宽度与视口宽度匹配，则返回 true。
getScrollableTracksViewportWidth() - 类 javax.swing.text.JTextComponent 中的方法
如果视口总是强制此 Scrollable 的宽度与视口宽度匹配，则返回 true。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.JList 中的方法
返回为显露上一个或下一个行（垂直滚动）或列（水平滚动）而滚动的距离。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.JTable 中的方法
返回完全呈现出一个新行或新列（取决于方向）的滚动增量（以像素为单位）。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.JTextArea 中的方法
显示逻辑行或列的组件应根据方向的值计算滚动增量，此滚动增量将完全显示一个新行或新列。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.JTree 中的方法
返回滚动时增加的数量。
getScrollableUnitIncrement(Rectangle, int, int) - 接口 javax.swing.Scrollable 中的方法
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
getScrollableUnitIncrement(Rectangle, int, int) - 类 javax.swing.text.JTextComponent 中的方法
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
getScrollAmount() - 类 java.awt.event.MouseWheelEvent 中的方法
返回每转动一下鼠标滚轮应该滚动的单位数。
getScrollbarDisplayPolicy() - 类 java.awt.ScrollPane 中的方法
返回滚动条的显示策略。
getScrollbarVisibility() - 类 java.awt.TextArea 中的方法
返回指示文本区使用何种滚动条的枚举值。
getScrollMode() - 类 javax.swing.JViewport 中的方法
返回当前的滚动模式。
getScrollOffset() - 类 javax.swing.JTextField 中的方法
获取滚动偏移量（以像素为单位）。
getScrollPane() - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的方法
返回容纳 JTree 的 JScrollPane；如果一个也没有找到，则返回 null。
getScrollPosition() - 类 java.awt.ScrollPane 中的方法
返回子组件中的当前 x,y 位置，子组件显示在滚动窗格视口的 0,0 位置。
getScrollsOnExpand() - 类 javax.swing.JTree 中的方法
返回 scrollsOnExpand 属性的值。
getScrollType() - 类 java.awt.event.MouseWheelEvent 中的方法
返回响应此事件时应该发生的滚动类型。
getSearchScope() - 类 javax.naming.directory.SearchControls 中的方法
检索这些 SearchControls 的搜索范围。
getSearchStringEscape() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于转义通配符的字符串。
getSecond() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回秒或 DatatypeConstants.FIELD_UNDEFINED。
getSecondary1() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 secondary 1 颜色。
getSecondary1() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 secondary 1 颜色。
getSecondary1() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 secondary 1 颜色。
getSecondary2() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 secondary 2 颜色。
getSecondary2() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 secondary 2 颜色。
getSecondary2() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 secondary 2 颜色。
getSecondary3() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回 secondary 3 颜色。
getSecondary3() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回 secondary 3 颜色。
getSecondary3() - 类 javax.swing.plaf.metal.OceanTheme 中的方法
返回 secondary 3 颜色。
getSeconds() - 类 java.sql.Date 中的方法
已过时。
getSeconds() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.SECOND) 取代。
getSeconds() - 类 javax.xml.datatype.Duration 中的方法
获取整数值形式的 SECONDS 字段的值，如果不存在，则值为 0。
getSecretKey() - 类 java.security.KeyStore.SecretKeyEntry 中的方法
从此项中获取 SecretKey。
getSecure() - 类 java.net.HttpCookie 中的方法
如果浏览器仅通过安全协议发送 cookie，则返回 true；如果浏览器可以使用任何协议发送 cookie，则返回 false。
getSecurityContext() - 类 java.lang.SecurityManager 中的方法
创建一个封装当前执行环境的对象。
getSecurityContext(ClassLoader) - 接口 java.rmi.server.LoaderHandler 中的方法
已过时。 无替代版本
getSecurityContext(ClassLoader) - 类 java.rmi.server.RMIClassLoader 中的静态方法
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。
getSecurityManager() - 类 java.lang.System 中的静态方法
获取系统安全接口。
getSeed(int) - 类 java.security.SecureRandom 中的静态方法
返回给定的种子字节数量，该数量可使用此类用来将自身设置为种子的种子生成算法来计算。
getSeed() - 类 java.security.spec.EllipticCurve 中的方法
返回曲线生成期间所使用的种子字节 seed。
getSelectColor() - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法

getSelectColor() - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法

getSelectColor() - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法

getSelectedAccessibleColumns() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中选中的列。
getSelectedAccessibleColumns() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中选择的列。
getSelectedAccessibleRows() - 接口 javax.accessibility.AccessibleTable 中的方法
返回表中选中的行。
getSelectedAccessibleRows() - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回表中选择的行。
getSelectedCheckbox() - 类 java.awt.CheckboxGroup 中的方法
从此复选框组中获取当前选择。
getSelectedColor() - 接口 javax.swing.colorchooser.ColorSelectionModel 中的方法
返回所选取的 Color，它不应为 null。
getSelectedColor() - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
返回所选取的 Color，它不应为 null。
getSelectedColumn() - 类 javax.swing.JTable 中的方法
返回第一个选定列的索引；如果没有选定的列，则返回 -1。
getSelectedColumnCount() - 类 javax.swing.JTable 中的方法
返回选定列数。
getSelectedColumnCount() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回选定的列数。
getSelectedColumnCount() - 接口 javax.swing.table.TableColumnModel 中的方法
返回选定的列数。
getSelectedColumns() - 类 javax.swing.JTable 中的方法
返回所有选定列的索引。
getSelectedColumns() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回包含选定列的数组。
getSelectedColumns() - 接口 javax.swing.table.TableColumnModel 中的方法
返回所有选定列的索引数组。
getSelectedComponent() - 类 javax.swing.JTabbedPane 中的方法
返回此选项卡窗格当前选择的组件。
getSelectedFile() - 类 javax.swing.JFileChooser 中的方法
返回选中的文件。
getSelectedFiles() - 类 javax.swing.JFileChooser 中的方法
如果将文件选择器设置为允许选择多个文件，则返回选中文件的列表。
getSelectedFrame() - 类 javax.swing.JDesktopPane 中的方法
返回此 JDesktopPane 中当前活动的 JInternalFrame，如果当前没有活动的 JInternalFrame，则返回 null。
getSelectedIcon() - 类 javax.swing.AbstractButton 中的方法
返回按钮的选择图标。
getSelectedIndex() - 类 java.awt.Choice 中的方法
返回当前选定项的索引。
getSelectedIndex() - 类 java.awt.List 中的方法
获取列表中选中项的索引。
getSelectedIndex() - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
获取选中的确认选项。
getSelectedIndex() - 类 javax.swing.DefaultSingleSelectionModel 中的方法

getSelectedIndex() - 类 javax.swing.JComboBox 中的方法
返回列表中与给定项匹配的第一个选项。
getSelectedIndex() - 类 javax.swing.JList 中的方法
返回最小的选择单元索引；只选择了列表中单个项时，返回该选择。
getSelectedIndex() - 类 javax.swing.JTabbedPane 中的方法
返回当前选择的此选项卡窗格的索引。
getSelectedIndex() - 接口 javax.swing.SingleSelectionModel 中的方法
返回模型的选项。
getSelectedIndexes() - 类 java.awt.List 中的方法
获取列表中选中的索引。
getSelectedIndexes() - 类 javax.security.auth.callback.ChoiceCallback 中的方法
获取选中的选项。
getSelectedIndices() - 类 javax.swing.JList 中的方法
返回所选的全部索引的数组（按升序排列）。
getSelectedItem() - 类 java.awt.Choice 中的方法
获取当前选择的字符串表示形式。
getSelectedItem() - 类 java.awt.List 中的方法
获取此滚动列表中选中的项。
getSelectedItem() - 接口 javax.swing.ComboBoxModel 中的方法
返回选择的项
getSelectedItem() - 类 javax.swing.DefaultComboBoxModel 中的方法

getSelectedItem() - 类 javax.swing.JComboBox 中的方法
返回当前所选项。
getSelectedItem() - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法

getSelectedItem() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法

getSelectedItems() - 类 java.awt.List 中的方法
获取此滚动列表中选中的项。
getSelectedObjects() - 类 java.awt.Checkbox 中的方法
返回包含复选框标签的数组 (length 1)，如果没有选定复选框，则返回 null。
getSelectedObjects() - 类 java.awt.CheckboxMenuItem 中的方法
返回一个数组（长度为 1)，它包含复选框菜单项的标签，如果没有选中复选框，则返回 null。
getSelectedObjects() - 类 java.awt.Choice 中的方法
返回包含当前选定项的数组（长度为 1）。
getSelectedObjects() - 接口 java.awt.ItemSelectable 中的方法
返回选定项；如果没有选定的项，则返回 null。
getSelectedObjects() - 类 java.awt.List 中的方法
获取对象数组中此滚动列表的选中项。
getSelectedObjects() - 类 javax.swing.AbstractButton 中的方法
返回包含标签的数组（长度为 1），如果没有选择按钮，则返回 null。
getSelectedObjects() - 类 javax.swing.DefaultButtonModel 中的方法
重写以返回 null。
getSelectedObjects() - 类 javax.swing.JCheckBoxMenuItem 中的方法
返回包含复选框菜单项标签的数组 (length 1)，如果没有选定复选框，则返回 null。
getSelectedObjects() - 类 javax.swing.JComboBox 中的方法
返回包含所选项的数组。
getSelectedPath() - 类 javax.swing.MenuSelectionManager 中的方法
返回当前选择菜单项的路径
getSelectedRow() - 类 javax.swing.JTable 中的方法
返回第一个选定行的索引；如果没有选定的行，则返回 -1。
getSelectedRowCount() - 类 javax.swing.JTable 中的方法
返回选定行数。
getSelectedRows() - 类 javax.swing.JTable 中的方法
返回所有选定行的索引。
getSelectedTabPadInsets(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getSelectedText(AttributedCharacterIterator.Attribute[]) - 接口 java.awt.im.InputMethodRequests 中的方法
从文本编辑组件中获取当前已选定文本。
getSelectedText() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回选定文本的一部分。
getSelectedText() - 类 java.awt.TextComponent 中的方法
返回此文本组件所表示文本的选定文本。
getSelectedText() - 接口 javax.accessibility.AccessibleText 中的方法
返回选定的部分文本。
getSelectedText() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回选定文本的一部分。
getSelectedText() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回选定的部分文本。
getSelectedText() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回选中的部分文本。
getSelectedText() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回选择的一部分文本。
getSelectedText() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回选定文本的某一部分。
getSelectedText() - 类 javax.swing.text.JTextComponent 中的方法
返回此 TextComponent 中包含的选定文本。
getSelectedTextColor() - 类 javax.swing.text.JTextComponent 中的方法
获取用于呈现选定文本的当前颜色。
getSelectedValue() - 类 javax.swing.JList 中的方法
返回最小的选择单元索引的值；只选择了列表中单个项时，返回所选值。
getSelectedValues() - 类 javax.swing.JList 中的方法
返回所有选择值的数组，根据其列表中的索引顺序按升序排序。
getSelection() - 类 javax.swing.ButtonGroup 中的方法
返回选择按钮的模型。
getSelectionBackground() - 类 javax.swing.JList 中的方法
返回用于绘制选定项的背景的颜色。
getSelectionBackground() - 类 javax.swing.JTable 中的方法
返回选定单元格的背景色。
getSelectionBackground() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
如果在进度条的未填充区域上绘制文本，则文本的颜色为 "selectionBackground"。
getSelectionColor() - 类 javax.swing.text.JTextComponent 中的方法
获取用于呈现选定的当前颜色。
getSelectionCount() - 类 javax.swing.JTree 中的方法
返回选择的节点数。
getSelectionCount() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回选择的路径数。
getSelectionCount() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回选择的路径数。
getSelectionEnd() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回选定文本中的终止偏移量。
getSelectionEnd() - 类 java.awt.TextComponent 中的方法
获取此文本组件中选定文本的结束位置。
getSelectionEnd() - 接口 javax.accessibility.AccessibleText 中的方法
返回选定文本中的结束偏移量。
getSelectionEnd() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回选定文本中的结束偏移量。
getSelectionEnd() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回选定文本中的结尾偏移量。
getSelectionEnd() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回选定文本中的结尾偏移量。
getSelectionEnd() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回选择文本中的结束偏移量。
getSelectionEnd() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回选定文本中的结束偏移量。
getSelectionEnd() - 类 javax.swing.text.JTextComponent 中的方法
返回选定文本的结束位置。
getSelectionForeground() - 类 javax.swing.JList 中的方法
返回用于绘制选定项的前景的颜色。
getSelectionForeground() - 类 javax.swing.JTable 中的方法
返回选定单元格的前景色。
getSelectionForeground() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
如果在进度条的填充区域上绘制文本，文本的颜色为 "selectionForeground"。
getSelectionMode() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回当前选择模式。
getSelectionMode() - 类 javax.swing.JList 中的方法
返回列表的当前选择模式。
getSelectionMode() - 接口 javax.swing.ListSelectionModel 中的方法
返回当前选择模式。
getSelectionMode() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回选择模式，它是 SINGLE_TREE_SELECTION、DISCONTIGUOUS_TREE_SELECTION 或 CONTIGUOUS_TREE_SELECTION 之一。
getSelectionMode() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回当前选择的模式（SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一）。
getSelectionModel() - 类 javax.swing.JColorChooser 中的方法
返回处理颜色选择的数据模型。
getSelectionModel() - 类 javax.swing.JList 中的方法
返回当前选择模型。
getSelectionModel() - 类 javax.swing.JMenuBar 中的方法
返回处理单个选择的模型对象。
getSelectionModel() - 类 javax.swing.JPopupMenu 中的方法
返回处理单个选择的模型对象。
getSelectionModel() - 类 javax.swing.JTable 中的方法
返回用来维持行选择状态的 ListSelectionModel。
getSelectionModel() - 类 javax.swing.JTree 中的方法
返回选择的模型。
getSelectionModel() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getSelectionModel() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回用来维护列选择状态的 ListSelectionModel。
getSelectionModel() - 接口 javax.swing.table.TableColumnModel 中的方法
返回当前的选择模型。
getSelectionModel() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回用于维护该选择的模型。
getSelectionPainter() - 类 javax.swing.text.DefaultCaret 中的方法
获取此 Highlighter 的 painter。
getSelectionPath() - 类 javax.swing.JTree 中的方法
返回首选节点的路径。
getSelectionPath() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回 selection 中的第一个路径。
getSelectionPath() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回选择中的第一个路径。
getSelectionPaths() - 类 javax.swing.JTree 中的方法
返回所有选择值的路径。
getSelectionPaths() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回 selection 中的路径。
getSelectionPaths() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回选择中的路径。
getSelectionRows() - 类 javax.swing.JTree 中的方法
返回所有当前选择的行。
getSelectionRows() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回当前已选的所有行。
getSelectionRows() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
返回所有当前已选的行。
getSelectionStart() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
返回选定文本中的起始偏移量。
getSelectionStart() - 类 java.awt.TextComponent 中的方法
获取此文本组件中选定文本的开始位置。
getSelectionStart() - 接口 javax.accessibility.AccessibleText 中的方法
返回选定文本中的起始偏移量。
getSelectionStart() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回选定文本中的起始偏移量。
getSelectionStart() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回选定文本中的开始偏移量。
getSelectionStart() - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回选定文本中的开始偏移量。
getSelectionStart() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
返回选择的文本中的初始偏移量。
getSelectionStart() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回选定文本中的起始偏移量。
getSelectionStart() - 类 javax.swing.text.JTextComponent 中的方法
返回选定文本的起始位置。
getSelectionValues() - 类 javax.swing.JOptionPane 中的方法
返回输入选择值。
getSendBufferSize() - 类 java.net.DatagramSocket 中的方法
获取此 DatagramSocket 的 SO_SNDBUF 选项的值，该值是平台在 DatagramSocket 上输出时使用的缓冲区大小。
getSendBufferSize() - 类 java.net.Socket 中的方法
获取此 Socket 的 SO_SNDBUF 选项的值，该值是平台在 Socket 上输出时使用的缓冲区大小。
getSendPastNotifications() - 类 javax.management.timer.Timer 中的方法
获得一个指示计时器是否发送过期通知的标志。
getSendPastNotifications() - 接口 javax.management.timer.TimerMBean 中的方法
获得一个指示计时器是否发送过期通知的标志。
getSentenceInstance() - 类 java.text.BreakIterator 中的静态方法
返回一个用于默认语言环境 句子分解的新 BreakIterator 实例。
getSentenceInstance(Locale) - 类 java.text.BreakIterator 中的静态方法
返回一个用于给定语言环境句子分解的新 BreakIterator 实例。
getSentenceInstance(Locale) - 类 java.text.spi.BreakIteratorProvider 中的方法
为给定语言环境的句子分解返回新的 BreakIterator 实例。
getSeparatorBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的分隔符背景颜色。
getSeparatorBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回分隔符背景色。
getSeparatorForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的分隔符前景颜色。
getSeparatorForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回分隔符前景色。
getSeparatorSize() - 类 javax.swing.JToolBar.Separator 中的方法
返回分隔符的大小
getSequence(InputStream) - 类 javax.sound.midi.MidiSystem 中的静态方法
从指定的输入流获得 MIDI 序列。
getSequence(URL) - 类 javax.sound.midi.MidiSystem 中的静态方法
从指定的 URL 获得 MIDI 序列。
getSequence(File) - 类 javax.sound.midi.MidiSystem 中的静态方法
从指定的 File 获得 MIDI 序列。
getSequence() - 接口 javax.sound.midi.Sequencer 中的方法
获得 Sequencer 当前所操作的 sequence。
getSequence(InputStream) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
从提供的输入流获得 MIDI 序列。
getSequence(URL) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
从提供的 URL 获得 MIDI 序列。
getSequence(File) - 类 javax.sound.midi.spi.MidiFileReader 中的方法
从提供的 File 获得 MIDI 序列。
getSequenceDetState() - 接口 org.ietf.jgss.GSSContext 中的方法
确定是否针对本上下文中的 per-message 安全服务启用了序列检查。
getSequenceNumber() - 类 java.util.logging.LogRecord 中的方法
获取序列号。
getSequenceNumber() - 类 javax.management.Notification 中的方法
获得通知序列号。
getSequencer() - 类 javax.sound.midi.MidiSystem 中的静态方法
获得连接到默认设备上的默认的 Sequencer。
getSequencer(boolean) - 类 javax.sound.midi.MidiSystem 中的静态方法
获得默认的 Sequencer，它可选地连接到默认设备上。
getSerializedObject() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的 OBJECT 属性的值。
getSerialNumber() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 serialNumber 值。
getSerialNumber() - 类 java.security.cert.X509CertSelector 中的方法
返回 serialNumber 标准。
getSerialNumber() - 类 java.security.cert.X509CRLEntry 中的方法
获取此 X509CRLEntry 的序列号 userCertificate。
getSerialNumber() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的 serialNumber 值。
getSerialNumber() - 接口 javax.xml.crypto.dsig.keyinfo.X509IssuerSerial 中的方法
返回此 X509IssuerSerial 的序列号。
getSerialVersionUID() - 类 java.io.ObjectStreamClass 中的方法
返回此类的 serialVersionUID。
getServer() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的服务主体。
getServerAliases(String, Principal[]) - 接口 javax.net.ssl.X509KeyManager 中的方法
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。
getServerCertificateChain() - 类 java.net.SecureCacheResponse 中的方法
从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。
getServerCertificates() - 类 javax.net.ssl.HttpsURLConnection 中的方法
返回服务器的证书链，它是作为定义会话的一部分而建立的。
getServerName() - 类 java.security.cert.LDAPCertStoreParameters 中的方法
返回 LDAP 服务器的 DNS 名称。
getServerSessionContext() - 类 javax.net.ssl.SSLContext 中的方法
返回服务器会话上下文，它表示可供服务器端 SSL 套接字握手阶段所使用的 SSL 会话集。
getServerSocketFactory() - 类 javax.net.ssl.SSLContext 中的方法
返回此上下文的 ServerSocketFactory 对象。
getService(BeanContextServices, Object, Class, Object) - 接口 java.beans.beancontext.BeanContextServiceProvider 中的方法
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。
getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener) - 接口 java.beans.beancontext.BeanContextServices 中的方法
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
getService(BeanContextServices, Object, Class, Object) - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 中的方法

getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
获得一个可被委托的服务。
getService(String, String) - 类 java.security.Provider 中的方法
获取描述此算法或别名的指定类型的此 Provider 实现的服务。
getServiceClass() - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 中的方法
获得作为此通知主题的服务类。
getServiceClass() - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的方法
获得作为此通知主题的服务类
getServiceName() - 接口 javax.xml.ws.handler.PortInfo 中的方法
获取包含正被访问端口的 WSDL 服务名称的限定名。
getServiceName() - 类 javax.xml.ws.Service 中的方法
获取此服务的名称。
getServiceName() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
获取此服务的名称。
getServiceProvider() - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider 中的方法

getServiceProviderByClass(Class<T>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
返回当前注册的属于给定类类型的服务提供者对象。
getServiceProviders(Class<T>, boolean) - 类 javax.imageio.spi.ServiceRegistry 中的方法
返回一个包含给定类别中的所有已注册的服务提供者的 Iterator。
getServiceProviders(Class<T>, ServiceRegistry.Filter, boolean) - 类 javax.imageio.spi.ServiceRegistry 中的方法
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。
getServices() - 类 java.security.Provider 中的方法
获取此 Provider 支持的所有服务的一个不可修改的 Set。
getServicesBeanInfo() - 接口 java.beans.beancontext.BeanContextServiceProviderBeanInfo 中的方法
获得一个 BeanInfo 数组，为每个可从此 ServiceProvider 中静态得到的类或接口返回一个数组。
getServiceUIFactory() - 接口 javax.print.PrintService 中的方法
返回 UI 组件的工厂方法，该组件允许用户通过各种角色与服务交互。
getSession() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回触发此事件的会话。
getSession() - 类 javax.net.ssl.SSLEngine 中的方法
返回此 SSLEngine 中使用的 SSLSession。
getSession() - 类 javax.net.ssl.SSLSessionBindingEvent 中的方法
返回 SSLSession，将侦听器绑定其中或从其解除绑定。
getSession(byte[]) - 接口 javax.net.ssl.SSLSessionContext 中的方法
返回绑定到指定会话 id 的 SSLSession。
getSession() - 类 javax.net.ssl.SSLSocket 中的方法
返回此连接使用的 SSL 会话。
getSessionCacheSize() - 接口 javax.net.ssl.SSLSessionContext 中的方法
返回用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。
getSessionContext() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话所在的上下文。
getSessionKey() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的会话密钥。
getSessionKeyType() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回与此票据有关联的会话密钥的密钥类型（由 Kerberos Protocol Specification 定义）。
getSessionTimeout() - 接口 javax.net.ssl.SSLSessionContext 中的方法
返回在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。
getSeverity() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法

getSeverity() - 接口 javax.xml.bind.ValidationEvent 中的方法
检索此警告/错误的严重性代码。
getSeverity() - 接口 org.w3c.dom.DOMError 中的方法
错误的严重性，SEVERITY_WARNING、SEVERITY_ERROR 或 SEVERITY_FATAL_ERROR。
getShadowColor(Component) - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框在指定组件上呈现的阴影颜色。
getShadowColor() - 类 javax.swing.border.EtchedBorder 中的方法
返回浮雕化边框的阴影颜色。
getShadowColor() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getShadowInnerColor(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框在指定组件上呈现的内部阴影颜色。
getShadowInnerColor() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框内部的阴影颜色。
getShadowOuterColor(Component) - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框在指定组件上呈现的外部阴影颜色。
getShadowOuterColor() - 类 javax.swing.border.BevelBorder 中的方法
返回斜面边框的外部阴影颜色。
getShaper(int) - 类 java.awt.font.NumericShaper 中的静态方法
返回所提供的 unicode 范围的成形器。
getSharedAncestor(DefaultMutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点和 aNode 最近的共同祖先。
getSharedInstance() - 类 javax.swing.PopupFactory 中的静态方法
返回共享 PopupFactory，它可用于获取 Popup。
getSharedQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回一个 collection，该 collection 包含正以共享模式等待获取的线程。
getSharedQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回包含可能正以共享模式等待获取的线程 collection。
getShearInstance(double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回表示错切变换的变换。
getShearX() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵错切元素 (m01) 的 X 坐标。
getShearY() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵错切元素 (m10) 的 Y 坐标。
getShift() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法

getShift() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法

getShift() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 中的方法

getShift() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 中的方法

getShiftKey() - 接口 org.w3c.dom.events.MouseEvent 中的方法
用于指示在触发事件期间是否按下 'shift' 键。
getShort(Object, int) - 类 java.lang.reflect.Array 中的静态方法
以 short 形式返回指定数组对象中索引组件的值。
getShort(Object) - 类 java.lang.reflect.Field 中的方法
获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。
getShort() - 类 java.nio.ByteBuffer 中的方法
用于读取 short 值的相对 get 方法。
getShort(int) - 类 java.nio.ByteBuffer 中的方法
用于读取 short 值的绝对 get 方法。
getShort(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 short 值的形式获取指定的 JDBC SMALLINT 参数的值。
getShort(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 short 值的形式获取 JDBC SMALLINT 参数的值。
getShort(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
getShort(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
getShortcut() - 类 java.awt.MenuItem 中的方法
获取与此菜单项关联的 MenuShortcut 对象。
getShortcutMenuItem(MenuShortcut) - 类 java.awt.MenuBar 中的方法
获取与指定 MenuShortcut 对象关联的 MenuItem 的实例，如果此菜单栏正在管理的菜单项均与指定的菜单快捷方式无关联，则为 null。
getShortDescription() - 类 java.beans.FeatureDescriptor 中的方法
获得此特性的简短描述。
getShortMonths() - 类 java.text.DateFormatSymbols 中的方法
获取简短形式的月份字符串。
getShortParameter(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
作为 short 返回参数的便捷方法。
getShortWeekdays() - 类 java.text.DateFormatSymbols 中的方法
获取简短形式的星期字符串。
getShowDeleted() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
getShowDeleted() - 接口 javax.sql.rowset.CachedRowSet 中的方法
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
getShowDeleted() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
getShowHorizontalLines() - 类 javax.swing.JTable 中的方法
如果表绘制单元格之间的水平线，则返回 true，否则返回 false。
getShowsRootHandles() - 类 javax.swing.JTree 中的方法
返回 showsRootHandles 属性的值。
getShowsRootHandles() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法

getShowVerticalLines() - 类 javax.swing.JTable 中的方法
如果表绘制单元格之间的垂直线，则返回 true，否则返回 false。
getSiblingCount() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的兄弟节点数。
getSides() - 类 java.awt.JobAttributes 中的方法
返回对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。
getSigAlgName() - 类 java.security.cert.X509Certificate 中的方法
获取证书签名算法的签名算法名。
getSigAlgName() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 签名算法的签名算法名。
getSigAlgName() - 类 javax.security.cert.X509Certificate 中的方法
获取用于该证书签名算法的名称。
getSigAlgOID() - 类 java.security.cert.X509Certificate 中的方法
获取证书的签名算法 OID 字符串。
getSigAlgOID() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的签名算法 OID 字符串。
getSigAlgOID() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的签名算法 OID 字符串。
getSigAlgParams() - 类 java.security.cert.X509Certificate 中的方法
从此证书的签名算法中获取 DER 编码形式的签名算法参数。
getSigAlgParams() - 类 java.security.cert.X509CRL 中的方法
获取此 CRL 的签名算法中 DER 编码形式的签名算法参数。
getSigAlgParams() - 类 javax.security.cert.X509Certificate 中的方法
从此证书的签名算法中获取 DER 编码形式的签名算法参数。
getSign() - 类 javax.xml.datatype.Duration 中的方法
以 -1、0 或 1 的形式返回此持续时间的符号。
getSignature() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 signature 值（原始签名位）。
getSignature() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的 signature 值（原始签名位）。
getSignature() - 类 java.security.SignedObject 中的方法
在已签名对象上按 byte 数组的形式获取签名。
getSignature() - 类 javax.management.MBeanConstructorInfo 中的方法
返回此构造方法的参数列表。
getSignature() - 类 javax.management.MBeanOperationInfo 中的方法
返回此操作的参数列表。
getSignature() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回 OpenMBeanParameterInfo 实例的数组，该实例描述此 OpenMBeanConstructorInfo 实例描述的构造方法签名中的每个参数。
getSignature() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回 OpenMBeanOperationInfo 实例的数组，该实例描述此 OpenMBeanParameterInfo 实例所描述操作的签名中的每个参数。
getSignatureMethod() - 接口 javax.xml.crypto.dsig.SignedInfo 中的方法
返回此 SignedInfo 的签名方法。
getSignatureValue() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回此 XMLSignature 的签名值。
getSignedInfo() - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
返回此 XMLSignature 的签名信息。
getSignerCertPath() - 类 java.security.CodeSigner 中的方法
返回签名者的证书路径。
getSignerCertPath() - 类 java.security.Timestamp 中的方法
返回 Timestamping Authority 的证书路径。
getSigners() - 类 java.lang.Class 中的方法
获取此类的标记。
getSigProvider() - 类 java.security.cert.PKIXParameters 中的方法
返回签名提供者的名称，如果未设置，则返回 null。
getSimpleName() - 类 java.lang.Class 中的方法
返回源代码中给出的底层类的简称。
getSimpleName() - 接口 javax.lang.model.element.Element 中的方法
返回此元素的简单（未限定）名称。
getSize() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回此对象的大小，用 Dimension 对象的形式表示它。
getSize() - 类 java.awt.Component 中的方法
以 Dimension 对象的形式返回组件的大小。
getSize(Dimension) - 类 java.awt.Component 中的方法
将组件的宽度/高度存储到“返回值”rv 中并返回 rv。
getSize() - 类 java.awt.Dimension 中的方法
获取此 Dimension 对象的大小。
getSize() - 类 java.awt.Font 中的方法
返回此 Font 的磅值大小，舍入为整数。
getSize() - 类 java.awt.image.DataBuffer 中的方法
返回所有存储单元的大小（按数组元素）。
getSize() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
以 Dimension 对象的形式返回此对象的大小。
getSize() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
以 Dimension 对象的形式返回此对象的大小。
getSize() - 类 java.awt.Rectangle 中的方法
获取此 Rectangle 的大小，用返回的 Dimension 表示。
getSize() - 类 java.awt.SplashScreen 中的方法
以 Dimension 形式返回闪现屏幕窗口的大小。
getSize() - 类 java.awt.TrayIcon 中的方法
返回托盘图标在系统托盘上占用的空间大小（以像素为单位）。
getSize() - 类 java.util.zip.ZipEntry 中的方法
返回条目数据的未压缩大小；如果未知，则返回 -1。
getSize() - 接口 javax.accessibility.AccessibleComponent 中的方法
以 Dimension 对象的形式返回此对象的大小。
getSize(int) - 类 javax.print.attribute.Size2DSyntax 中的方法
获取给定单位的此二维大小属性的维度作为浮点值。
getSize() - 类 javax.swing.DefaultComboBoxModel 中的方法

getSize() - 类 javax.swing.DefaultListModel 中的方法
返回此列表中的组件数。
getSize(Dimension) - 类 javax.swing.JComponent 中的方法
将此组件的宽度/高度存储到“返回值”rv 中并返回 rv。
getSize() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法

getSize() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法

getSize() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法

getSize() - 接口 javax.swing.ListModel 中的方法
返回列表的长度。
getSize() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法

getSize() - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法

getSize() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法

getSize(int) - 类 javax.swing.SizeSequence 中的方法
返回指定条目的大小。
getSize() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法

getSize() - 类 javax.xml.soap.AttachmentPart 中的方法
返回此 AttachmentPart 对象中的字节数。
getSize2D() - 类 java.awt.Font 中的方法
返回此 Font 的磅值大小（以 float 值表示）。
getSizeButtonsToSameWidth() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
返回 true，基本 L&F 希望所有按钮具有相同的宽度。
getSizeOfComponent(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回传入组件的宽度。
getSizes() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回组件的大小。
getSizes() - 类 javax.swing.SizeSequence 中的方法
返回所有条目的大小。
getSlaveSyncMode() - 接口 javax.sound.midi.Sequencer 中的方法
获得此 sequencer 的当前从同步模式。
getSlaveSyncModes() - 接口 javax.sound.midi.Sequencer 中的方法
获得此 sequencer 支持的从同步模式集。
getSmallDisplayIcon() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
返回此面板的小图标。
getSnapshot() - 类 java.awt.image.VolatileImage 中的方法
返回此对象的静态快照图像。
getSnapToTicks() - 类 javax.swing.JSlider 中的方法
如果滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值，则返回为 true。
getSOAPBody() - 类 javax.xml.soap.SOAPMessage 中的方法
获取此 SOAPMessage 对象中包含的 SOAP Body。
getSOAPFactory() - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
获取此 SOAP 绑定使用的 SAAJ SOAPFactory 实例。
getSOAPHeader() - 类 javax.xml.soap.SOAPMessage 中的方法
获取此 SOAPMessage 对象中包含的 SOAP Header。
getSOAPPart() - 类 javax.xml.soap.SOAPMessage 中的方法
获取此 SOAPMessage 对象的 SOAP 部分。
getSocket() - 类 javax.net.ssl.HandshakeCompletedEvent 中的方法
返回作为此事件源的套接字。
getSocketAddress() - 类 java.net.DatagramPacket 中的方法
获取要将此包发送到的或发出此数据报的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。
getSocketFactory() - 类 java.rmi.server.RMISocketFactory 中的静态方法
返回由 setSocketFactory 方法设置的套接字工厂。
getSocketFactory() - 类 javax.net.ssl.SSLContext 中的方法
返回此上下文的 SocketFactory 对象。
getSoLinger() - 类 java.net.Socket 中的方法
返回 SO_LINGER 的设置。
getSolo() - 接口 javax.sound.midi.MidiChannel 中的方法
获得此通道的当前 solo 状态。
getSortKeys() - 类 javax.swing.DefaultRowSorter 中的方法
返回当前排序键。
getSortKeys() - 类 javax.swing.RowSorter 中的方法
返回当前排序键。
getSortOrder() - 类 javax.swing.RowSorter.SortKey 中的方法
返回列的排序顺序。
getSortsOnUpdates() - 类 javax.swing.DefaultRowSorter 中的方法
如果底层模型更新时应该进行排序，则返回 true；否则返回 false。
getSoTimeout() - 类 java.net.DatagramSocket 中的方法
获取 SO_TIMEOUT 的设置。
getSoTimeout() - 类 java.net.ServerSocket 中的方法
获取 SO_TIMEOUT 的设置。
getSoTimeout() - 类 java.net.Socket 中的方法
返回 SO_TIMEOUT 的设置。
getSoundbank(InputStream) - 类 javax.sound.midi.MidiSystem 中的静态方法
通过从指定的流读取来构造一个 MIDI 音库。
getSoundbank(URL) - 类 javax.sound.midi.MidiSystem 中的静态方法
通过从指定的 URL 处读取来构造一个 Soundbank。
getSoundbank(File) - 类 javax.sound.midi.MidiSystem 中的静态方法
通过从指定的 File 读取来构造一个 Soundbank。
getSoundbank() - 类 javax.sound.midi.SoundbankResource 中的方法
获得包含此 SoundbankResource 的音库。
getSoundbank(URL) - 类 javax.sound.midi.spi.SoundbankReader 中的方法
从提供的 URL 获得音库对象。
getSoundbank(InputStream) - 类 javax.sound.midi.spi.SoundbankReader 中的方法
从提供的 InputStream 获得音库对象。
getSoundbank(File) - 类 javax.sound.midi.spi.SoundbankReader 中的方法
从提供的 File 获得音库对象。
getSource() - 类 java.awt.image.BufferedImage 中的方法
返回生成该图像像素的对象。
getSource() - 类 java.awt.Image 中的方法
获取生成图像像素的对象。
getSource(int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回作为通用 Object 的源。
getSource() - 类 java.awt.image.VolatileImage 中的方法
此方法返回此 VolatileImage 的 ImageProducer。
getSource() - 类 java.beans.PropertyEditorSupport 中的方法
返回用作事件源的 bean。
getSource(Class<T>) - 接口 java.sql.SQLXML 中的方法
返回读取此 SQLXML 实例指定的 XML 值的 Source。
getSource() - 类 java.util.EventObject 中的方法
最初发生 Event 的对象。
getSource() - 类 javax.swing.event.RowSorterEvent 中的方法
返回以 RowSorter 形式表示的事件源。
getSource() - 接口 javax.tools.Diagnostic 中的方法
获取与此诊断关联的源对象。
getSourceActions() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法返回 Drag 和 Drop 操作所支持动作类型的 int 表示形式。
getSourceActions() - 类 java.awt.dnd.DragSourceContext 中的方法
返回 DnDConstants 的位掩码，表示拖动源针对与此 DragSourceContext 关联的拖动操作所支持的放置动作集合。
getSourceActions() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回源 drop 操作。
getSourceActions() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回源 drop 操作。
getSourceActions(JComponent) - 类 javax.swing.TransferHandler 中的方法
返回源支持的传输动作的类型；COPY、MOVE 和 LINK 的任意按位或组合。
getSourceAsBeanContextServices() - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 中的方法
获得作为 BeanContextServices 类型引用的源。
getSourceAsBeanContextServices() - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的方法
获得作为 BeanContextServices 类型引用的源
getSourceAsDragGestureRecognizer() - 类 java.awt.dnd.DragGestureEvent 中的方法
以 DragGestureRecognizer 的形式返回源。
getSourceBands() - 类 javax.imageio.IIOParam 中的方法
返回要使用的源 band 的集合。
getSourceClassName() - 类 java.util.logging.LogRecord 中的方法
获取发出日志请求的类的名称。
getSourceDataLine(AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
getSourceDataLine(AudioFormat, Mixer.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
getSourceDropActions() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
当此 TransferSupport 表示放置操作时，返回拖动源受支持的放置动作。
getSourceElement() - 类 javax.swing.event.HyperlinkEvent 中的方法
返回对应于事件源的 Element。
getSourceEncodings() - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
获得源格式编码的集合，此提供者从该集合中提供格式转换服务。
getSourceLineInfo(Line.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得关于已安装混频器所支持特定类型的全部源行的信息。
getSourceLineInfo() - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器支持的源行集合的信息。
getSourceLineInfo(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器支持的特定类型源行的信息。
getSourceLines() - 接口 javax.sound.sampled.Mixer 中的方法
获得当前对此混频器打开的所有源行的集合。
getSourceMaxProgressivePass() - 类 javax.imageio.ImageReadParam 中的方法
如果 getSourceNumProgressivePasses 等于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。
getSourceMethodName() - 类 java.util.logging.LogRecord 中的方法
获取（可能）发出日志请求的方法的名称。
getSourceMinProgressivePass() - 类 javax.imageio.ImageReadParam 中的方法
返回将被解码的第一个逐步传递的索引。
getSourceNumProgressivePasses() - 类 javax.imageio.ImageReadParam 中的方法
返回将被解码的逐步传递的数量。
getSourceRegion() - 类 javax.imageio.IIOParam 中的方法
返回将使用的源区域。
getSourceRegion(ImageReadParam, int, int) - 类 javax.imageio.ImageReader 中的静态方法
reader 可用来计算应该读取的源图像区域的一个实用方法，计算时考虑任何源区域，并在所提供的 ImageReadParam 中对偏移量设置进行二次取样。
getSourceRenderSize() - 类 javax.imageio.ImageReadParam 中的方法
返回解码期间将呈现的源图像的宽度和高度，如果已经通过 setSourceRenderSize 方法设置了的话。
getSources() - 类 java.awt.image.BufferedImage 中的方法
返回 RenderedImage 对象的 Vector，该对象是此 BufferedImage 图像数据的直接来源，而不是这些直接来源的来源。
getSources() - 类 java.awt.image.renderable.ParameterBlock 中的方法
返回源的整个 Vector。
getSources() - 接口 java.awt.image.renderable.RenderableImage 中的方法
返回作为此 RenderableImage 的图像数据源的 RenderableImage 的向量。
getSources() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
返回作为此 RenderableImage 图像数据源的 RenderableImage 的向量。
getSources() - 接口 java.awt.image.RenderedImage 中的方法
返回作为此 RenderedImage 直接图像数据源的 RenderedImage 向量。
getSourceString() - 类 java.text.CollationKey 中的方法
返回此 CollationKey 表示的 String。
getSourceVersion() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回任何生成的源和类文件应该符合的源版本。
getSourceVersions() - 接口 javax.tools.Tool 中的方法
获取此工具支持的 Java™ 编程语言的源版本。
getSourceXSubsampling() - 类 javax.imageio.IIOParam 中的方法
返回对于每个像素要前进的源列数。
getSourceYSubsampling() - 类 javax.imageio.IIOParam 中的方法
返回对于每个像素要前进的行数。
getSouthPane() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getSpaceAbove(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取上部空间设置。
getSpaceBelow(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取下部空间设置。
getSpan(int, int) - 类 javax.swing.text.BoxView 中的方法
获取特定子级的当前布局的区域。
getSpan(GlyphView, int, int, TabExpander, float) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
确定给定开始位置（相对于选项卡扩展而言）的字形区域。
getSpecificationName() - 类 javax.management.MBeanServerDelegate 中的方法
返回此产品实现的 JMX 规范的全名。
getSpecificationName() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回此产品实现的 JMX 规范的全名。
getSpecificationTitle() - 类 java.lang.Package 中的方法
返回此包实现的规范标题。
getSpecificationVendor() - 类 java.lang.Package 中的方法
返回拥有并维护实现此包的类规范的组织、供应商或公司的名称。
getSpecificationVendor() - 类 javax.management.MBeanServerDelegate 中的方法
返回此产品实现的 JMX 规范的供应商。
getSpecificationVendor() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回此产品实现的 JMX 规范的供应商。
getSpecificationVersion() - 类 java.lang.Package 中的方法
返回此包实现的规范的版本号。
getSpecificationVersion() - 类 javax.management.MBeanServerDelegate 中的方法
返回此产品实现的 JMX 规范的版本。
getSpecificationVersion() - 接口 javax.management.MBeanServerDelegateMBean 中的方法
返回此产品实现的 JMX 规范的版本。
getSpecified() - 接口 org.w3c.dom.Attr 中的方法
如果在实例文档中显式给此属性一个值，则为 True；否则为 false。
getSpecName() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机规范名称。
getSpecVendor() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机规范供应商。
getSpecVersion() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机规范版本。
getSpi(String) - 类 java.util.prefs.AbstractPreferences 中的方法
返回与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。
getSpinner() - 类 javax.swing.JSpinner.DefaultEditor 中的方法
如果此编辑器的 JSpinner 祖先，如果祖先都不为 JSpinner，则返回 null。
getSplashScreen() - 类 java.awt.SplashScreen 中的静态方法
返回用于 Java 启动闪现屏幕控制的 SplashScreen 对象。
getSplitPane() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
返回当前包含此实例的拆分窗格。
getSplitPaneBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getSplitPaneDividerBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法
返回 JSplitPane 分隔符的边框实例
getSQLException() - 类 javax.sql.ConnectionEvent 中的方法
获取此 ConnectionEvent 对象的 SQLException。
getSQLException() - 类 javax.sql.StatementEvent 中的方法
返回驱动程序将要抛出的 SQLException。
getSQLKeywords() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库的还“不”是 SQL:2003 关键字的所有 SQL 关键字的逗号分隔列表。
getSQLState() - 异常 java.sql.SQLException 中的方法
获取此 SQLException 对象的 SQLState。
getSQLStateType() - 接口 java.sql.DatabaseMetaData 中的方法
指示由 SQLException.getSQLState 返回的 SQLSTATE 是 X/Open（现在称为 Open Group）SQL CLI 还是 SQL:2003。
getSQLTypeName() - 接口 java.sql.SQLData 中的方法
返回此对象表示的 SQL 用户定义类型的完全限定名。
getSQLTypeName() - 接口 java.sql.Struct 中的方法
获取此 Struct 对象所表示 SQL 结构的完全限定的 SQL 名称。
getSQLTypeName() - 类 javax.sql.rowset.serial.SerialStruct 中的方法
获取此 SerialStruct 对象的 SQL 类型名称。
getSQLXML(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
getSQLXML(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
getSQLXML(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getSQLXML(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getSrcName() - 接口 org.ietf.jgss.GSSContext 中的方法
返回上下文初始端的名称。
getSSLParameters() - 类 javax.net.ssl.SSLEngine 中的方法
返回对此 SSLEngine 有效的 SSLParameters。
getSSLParameters() - 类 javax.net.ssl.SSLSocket 中的方法
返回对此 SSLSocket 有效的 SSLParameters。
getSSLSocketFactory() - 类 javax.net.ssl.HttpsURLConnection 中的方法
获取为安全 https URL 连接创建套接字时使用的 SSL 套接字工厂。
getStackTrace() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程的堆栈跟踪。
getStackTrace() - 类 java.lang.Thread 中的方法
返回一个表示该线程堆栈转储的堆栈跟踪元素数组。
getStackTrace() - 类 java.lang.Throwable 中的方法
提供编程访问由 Throwable.printStackTrace() 输出的堆栈跟踪信息。
getStamp() - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
返回该标志的当前值。
getStandardChromaNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的色度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardCompressionNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的压缩信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardDataNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的数据格式信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardDimensionNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的维度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardDocumentNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的文档信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset) - 接口 javax.tools.JavaCompiler 中的方法
为此工具获取一个标准文件管理器实现的新实例。
getStandardFormatInstance() - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的静态方法
返回描述标准、插件无关的 javax.imageio_1.0 元数据文档格式的 IIOMetadataFormat 对象，该文档格式在 javax.imageio.metadata 包的注释中描述。
getStandardTextNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的文本信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardTileNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的平铺信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardTransparencyNode() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示标准 javax_imageio_1.0 元数据格式的透明度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
getStandardTree() - 类 javax.imageio.metadata.IIOMetadata 中的方法
返回表示此对象中所包含元数据的 IIOMetadataNode 的树（根据标准 javax_imageio_1.0 元数据格式的约定）的实用方法。
getStart() - 类 javax.swing.SpinnerDateModel 中的方法
返回序列中的第一个 Date。
getStartIndex() - 类 javax.accessibility.AccessibleHyperlink 中的方法
获得此链接开始处该超文本文档的索引
getStartIndex() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
获得此链接开始处该超文本文档的索引
getStartOffset() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
获取该元素在此模型中的起始偏移量。
getStartOffset() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得模型中该元素的起始偏移量。
getStartOffset() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
获得模型中该元素的起始偏移量。
getStartOffset() - 类 javax.swing.text.AbstractWriter 中的方法
返回要输出内容的第一个偏移量。
getStartOffset() - 接口 javax.swing.text.Element 中的方法
获取此元素开始处的文档起始偏移量。
getStartOffset() - 类 javax.swing.text.GlyphView 中的方法
获取此视图负责的一部分模型。
getStartOffset() - 接口 javax.swing.text.Highlighter.Highlight 中的方法
获取高亮显示的初始模型偏移量。
getStartOffset() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
返回当前出现的标记所定义的并具有相同属性的范围起始处。
getStartOffset() - 类 javax.swing.text.View 中的方法
获取此视图负责的模型的一部分。
getStartPoint() - 类 java.awt.geom.Arc2D 中的方法
返回弧的起始点。
getStartPoint() - 类 java.awt.LinearGradientPaint 中的方法
返回渐变轴起始点的副本。
getStartPosition() - 类 javax.swing.text.AbstractDocument 中的方法
返回表示文档开始的位置。
getStartPosition() - 接口 javax.swing.text.Document 中的方法
返回代表文档起始处的位置。
getStartPosition() - 接口 javax.tools.Diagnostic 中的方法
获取距文件开始位置的字符偏移量，其中文件与指示问题开始位置的此诊断关联。
getStartTime() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机的启动时间（以毫秒为单位）。
getStartTime() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回此票据有效期的开始时间。
getState() - 类 java.awt.Checkbox 中的方法
确定此复选框是处于“开”状态，还是处于“关”状态。
getState() - 类 java.awt.CheckboxMenuItem 中的方法
确定此复选框菜单项的状态是 "开" 还是 "关"。
getState() - 类 java.awt.Frame 中的方法
获取此窗体的状态（已废弃）。
getState() - 类 java.awt.im.InputMethodHighlight 中的方法
返回文本范围的转换状态。
getState() - 类 java.lang.Thread 中的方法
返回该线程的状态。
getState() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回同步状态的当前值。
getState() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回同步状态的当前值。
getState() - 类 javax.swing.JCheckBoxMenuItem 中的方法
返回菜单项的选定状态。
getState() - 类 javax.swing.SwingWorker 中的方法
返回 SwingWorker 状态绑定属性。
getStateChange() - 类 java.awt.event.ItemEvent 中的方法
返回状态更改的类型（已选定或已取消选定）。
getStateLabel(boolean) - 类 javax.sound.sampled.BooleanControl 中的方法
获得指定状态的标签。
getStatement() - 接口 java.sql.ResultSet 中的方法
获取生成此 ResultSet 对象的 Statement 对象。
getStatement() - 类 javax.sql.StatementEvent 中的方法
返回正在关闭或无效的 PreparedStatement。
getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - 类 javax.naming.spi.DirectoryManager 中的静态方法
在给定初始对象及其属性时，检索用于绑定的对象的状态。
getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - 接口 javax.naming.spi.DirStateFactory 中的方法
在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
getStateToBind(Object, Name, Context, Hashtable<?, ?>) - 类 javax.naming.spi.NamingManager 中的静态方法
检索用于绑定的对象的状态。
getStateToBind(Object, Name, Context, Hashtable<?, ?>) - 接口 javax.naming.spi.StateFactory 中的方法
检索用于绑定的对象状态。
getStaticAttribute(Object) - 类 javax.swing.text.StyleContext 中的静态方法
返回以前用 registerStaticAttributeKey 注册的对象。
getStaticAttributeKey(Object) - 类 javax.swing.text.StyleContext 中的静态方法
返回其 key 将要注册的 String
getStatus() - 类 java.awt.image.PixelGrabber 中的方法
返回像素的状态。
getStatus() - 类 javax.net.ssl.SSLEngineResult 中的方法
获得此 SSLEngine 操作的返回值。
getStatus() - 类 javax.sound.midi.MidiMessage 中的方法
获得 MIDI 消息的状态字节。
getStatus() - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
获取此 SyncResolver 的当前行的冲突状态，它指示在发生冲突时 RowSet 对象正尝试的操作。
getStatusCode() - 异常 javax.xml.ws.http.HTTPException 中的方法
获取 HTTP 状态代码。
getStepSize() - 类 javax.swing.SpinnerNumberModel 中的方法
返回由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。
getStream(String) - 接口 java.applet.AppletContext 中的方法
返回此 applet 上下文中指定键所关联的流。
getStream(DataFlavor) - 接口 javax.accessibility.AccessibleStreamable 中的方法
返回 DataFlavor 的 InputStream
getStream(URL) - 类 javax.swing.JEditorPane 中的方法
获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。
getStreamForBytes() - 接口 javax.print.Doc 中的方法
获得一个从此 doc 中提取 byte 打印数据的输入流。
getStreamForBytes() - 类 javax.print.SimpleDoc 中的方法
获得一个从此 doc 中提取 byte 打印数据的输入流。
getStreamKeys() - 接口 java.applet.AppletContext 中的方法
找到此 applet 上下文中所有流对应的键。
getStreamMetadata() - 类 javax.imageio.ImageReader 中的方法
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）；如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
getStreamMetadata(String, Set<String>) - 类 javax.imageio.ImageReader 中的方法
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。
getStreamMetadataFormat(String) - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
返回描述给定的流元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
getStreamPosition() - 接口 javax.imageio.stream.ImageInputStream 中的方法
返回流的当前字节位置。
getStreamPosition() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法

getStrength() - 类 java.text.Collator 中的方法
返回此 Collator 的 strength 属性。
getStrictErrorChecking() - 接口 org.w3c.dom.Document 中的方法
指定是否强制执行错误检查的属性。
getStrikethroughOffset() - 类 java.awt.font.LineMetrics 中的方法
返回删除线相对于基线的位置。
getStrikethroughThickness() - 类 java.awt.font.LineMetrics 中的方法
返回删除线的宽度。
getString(int) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 String 的形式获取指定的 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
getString(String) - 接口 java.sql.CallableStatement 中的方法
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
getString(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
getString(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
getString() - 接口 java.sql.SQLXML 中的方法
返回此 SQLXML 实例指定的 XML 值的字符串表示形式。
getString(String) - 类 java.util.ResourceBundle 中的方法
从此资源包或它的某个父包中获取给定键的字符串。
getString() - 类 javax.swing.JProgressBar 中的方法
返回当前进度的 String 表示形式。
getString(SynthContext, Object, String) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
获得其值是一个 String 值的特定样式属性的便捷方法。
getString(int, int) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
获取序列中包含的字符串。
getString(int, int) - 类 javax.swing.text.GapContent 中的方法
检索部分内容。
getString() - 类 javax.swing.text.html.parser.Entity 中的方法
返回以 String 表示的数据。
getString(int, int) - 类 javax.swing.text.StringContent 中的方法
检索内容的某一部分，where ＋ len 必须 <= length()。
getString(Object) - 类 javax.swing.UIDefaults 中的方法
如果 key 值为一个 String，则返回该 String，否则返回 null。
getString(Object, Locale) - 类 javax.swing.UIDefaults 中的方法
如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。
getString(Object) - 类 javax.swing.UIManager 中的静态方法
从默认值中返回一个字符串。
getString(Object, Locale) - 类 javax.swing.UIManager 中的静态方法
从适合给定语言环境的默认值中返回一个字符串。
getStringArray(String) - 类 java.util.ResourceBundle 中的方法
从此资源包或它的某个父包中获取给定键的字符串数组。
getStringBounds(String, FontRenderContext) - 类 java.awt.Font 中的方法
返回指定 FontRenderContext 中指定 String 的逻辑边界。
getStringBounds(String, int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回指定 FontRenderContext 中指定 String 的逻辑边界。
getStringBounds(char[], int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回指定 FontRenderContext 指定字符数组的逻辑边界。
getStringBounds(CharacterIterator, int, int, FontRenderContext) - 类 java.awt.Font 中的方法
返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
getStringBounds(String, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 String 的边界。
getStringBounds(String, int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定 String 的边界。
getStringBounds(char[], int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回指定 Graphics 上下文中指定字符数组的边界。
getStringBounds(CharacterIterator, int, int, Graphics) - 类 java.awt.FontMetrics 中的方法
返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。
getStringConverter() - 类 javax.swing.table.TableRowSorter 中的方法
返回负责将值从模型转换为字符串的对象。
getStringData() - 接口 org.w3c.dom.ls.LSInput 中的方法
要解析的字符串数据。
getStringFunctions() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于此数据库的字符串函数的逗号分隔列表。
getStringNameType() - 接口 org.ietf.jgss.GSSName 中的方法
返回此名称的可打印表示形式的名称类型，此名称可从 toString 方法中获取。
getStringPlacement(Graphics, String, int, int, int, int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
指定将绘制进度字符串的位置。
getStringTable() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的枚举类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Chromaticity 中的方法
返回 Chromaticity 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.ColorSupported 中的方法
返回 ColorSupported 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Compression 中的方法
返回 Compression 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Fidelity 中的方法
返回 Fidelity 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Finishings 中的方法
返回 Finishings 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.JobSheets 中的方法
返回 JobSheets 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.JobState 中的方法
返回 JobState 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.JobStateReason 中的方法
返回 JobStateReason 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.MediaName 中的方法
返回 MediaTray 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.MediaSizeName 中的方法
返回 MediaSizeName 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.MediaTray 中的方法
返回 MediaTray 类字符串表。
getStringTable() - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的方法
返回 MultipleDocumentHandling 类的字符串表。
getStringTable() - 类 javax.print.attribute.standard.OrientationRequested 中的方法
返回类 OrientationRequested 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PDLOverrideSupported 中的方法
返回类 PDLOverrideSupported 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PresentationDirection 中的方法
返回类 PresentationDirection 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的方法
返回类 PrinterIsAcceptingJobs 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PrinterState 中的方法
返回类 PrinterState 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PrinterStateReason 中的方法
返回类 PrinterStateReason 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.PrintQuality 中的方法
返回类 PrintQuality 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的方法
返回类 ReferenceUriSchemesSupported 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Severity 中的方法
返回类 Severity 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.SheetCollate 中的方法
返回类 SheetCollate 的字符串表。
getStringTable() - 类 javax.print.attribute.standard.Sides 中的方法
返回类 Sides 的字符串表。
getStringToCompare() - 类 javax.management.monitor.StringMonitor 中的方法
获取要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。
getStringToCompare() - 接口 javax.management.monitor.StringMonitorMBean 中的方法
获取要与 observed 属性进行比较的字符串。
getStringValue(int) - 类 javax.swing.RowFilter.Entry 中的方法
返回指定索引处的字符串值。
getStringValueAt(int, int) - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
以 String 的形式返回指定索引处的值。
getStroke() - 类 java.awt.Graphics2D 中的方法
返回 Graphics2D 上下文中的当前 Stroke
getStrongCaret(TextHitInfo, TextHitInfo, TextLayout) - 类 java.awt.font.TextLayout.CaretPolicy 中的方法
选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。
getStyle() - 类 java.awt.Font 中的方法
返回此 Font 的样式。
getStyle() - 类 java.awt.im.InputMethodHighlight 中的方法
返回文本范围的呈现样式属性，或 null。
getStyle(String) - 类 javax.swing.JTextPane 中的方法
获取以前添加的已命名的非 null 样式。
getStyle() - 类 javax.swing.plaf.synth.SynthContext 中的方法
返回与此 Region 相关的样式。
getStyle(JComponent, Region) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
获取指定组件的指定 region 的 SynthStyle。
getStyle(JComponent, Region) - 类 javax.swing.plaf.synth.SynthStyleFactory 中的方法
返回指定 Component 的样式。
getStyle(String) - 类 javax.swing.text.DefaultStyledDocument 中的方法
获取以前添加的已命名的样式。
getStyle(String) - 类 javax.swing.text.StyleContext 中的方法
获取以前添加到文档中的已命名样式
getStyle(String) - 接口 javax.swing.text.StyledDocument 中的方法
获取以前添加的指定样式。
getStyledDocument() - 类 javax.swing.JTextPane 中的方法
获取与编辑器关联的模型。
getStyledDocument(JEditorPane) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
获取与编辑器窗格相关的文档。
getStyledEditorKit() - 类 javax.swing.JTextPane 中的方法
获取编辑器工具包。
getStyledEditorKit(JEditorPane) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
获取与编辑器窗格相关的编辑器工具包。
getStyleFactory() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
返回当前 SynthStyleFactory。
getStyleNames() - 类 javax.swing.text.DefaultStyledDocument 中的方法
获取样式名称列表。
getStyleNames() - 类 javax.swing.text.StyleContext 中的方法
获取定义的样式名称。
getStyleSheet() - 类 javax.swing.text.html.BlockView 中的方法

getStyleSheet() - 类 javax.swing.text.html.HTMLDocument 中的方法
获取具有特定于文档的显示规则（CSS）的 StyleSheet，其中这些规则是在 HTML 文档本身中指定的。
getStyleSheet() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取当前正用于呈现 HTML 元素的样式集。
getStyleSheet() - 类 javax.swing.text.html.ImageView 中的方法
获取 StyleSheet 的便捷方法。
getStyleSheet() - 类 javax.swing.text.html.InlineView 中的方法

getStyleSheet() - 类 javax.swing.text.html.ParagraphView 中的方法

getStylesheet() - 类 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec 中的方法
返回样式表。
getStyleSheets() - 类 javax.swing.text.html.StyleSheet 中的方法
返回一个链接 StyleSheet 的数组。
getSubElements() - 类 javax.swing.JMenu 中的方法
返回由 MenuElement 组成的数组，其中包含此菜单组件的子菜单。
getSubElements() - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement（返回此菜单栏中的菜单）。
getSubElements() - 类 javax.swing.JMenuItem 中的方法
此方法返回包含此菜单组件的子菜单组件的数组。
getSubElements() - 类 javax.swing.JPopupMenu 中的方法
返回 MenuElement 组成的数组，包含此菜单组件的子菜单。
getSubElements() - 接口 javax.swing.MenuElement 中的方法
此方法应返回一个包含接收菜单元素的子元素的数组
getSubimage(int, int, int, int) - 类 java.awt.image.BufferedImage 中的方法
返回由指定矩形区域定义的子图像。
getSubInterfaces() - 类 java.net.NetworkInterface 中的方法
获取具有连接到此网络接口的所有子接口（也称虚拟接口）的 Enumeration。
getSubject() - 类 java.security.cert.X509CertSelector 中的方法
以 X500Principal 的形式返回 subject 标准。
getSubject() - 类 javax.security.auth.login.LoginContext 中的方法
返回已进行验证的 Subject。
getSubject(AccessControlContext) - 类 javax.security.auth.Subject 中的静态方法
获取与提供的 AccessControlContext 关联的 Subject。
getSubject() - 类 javax.security.auth.SubjectDomainCombiner 中的方法
获取与此 SubjectDomainCombiner 关联的 Subject。
getSubjectAlternativeNames() - 类 java.security.cert.X509Certificate 中的方法
从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。
getSubjectAlternativeNames() - 类 java.security.cert.X509CertSelector 中的方法
返回 subjectAlternativeNames 标准的一个副本。
getSubjectAsBytes() - 类 java.security.cert.X509CertSelector 中的方法
以 byte 数组的形式返回 subject 标准。
getSubjectAsString() - 类 java.security.cert.X509CertSelector 中的方法
已过时，使用 X509CertSelector.getSubject() 或 X509CertSelector.getSubjectAsBytes() 替代。
getSubjectDN() - 类 java.security.cert.X509Certificate 中的方法
已过时，由 X509Certificate.getSubjectX500Principal() 替代。
getSubjectDN() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的 subject（主体的标识名）值。
getSubjectKeyIdentifier() - 类 java.security.cert.X509CertSelector 中的方法
返回 subjectKeyIdentifier 标准。
getSubjectPublicKey() - 类 java.security.cert.X509CertSelector 中的方法
返回 subjectPublicKey 标准。
getSubjectPublicKeyAlgID() - 类 java.security.cert.X509CertSelector 中的方法
返回 subjectPublicKeyAlgID 标准。
getSubjectUniqueID() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 subjectUniqueID 值。
getSubjectX500Principal() - 类 java.security.cert.X509Certificate 中的方法
以 X500Principal 的形式返回证书的主体（主体标识名）值。
getSubsamplingXOffset() - 类 javax.imageio.IIOParam 中的方法
返回二次取样网格的水平偏移量。
getSubsamplingYOffset() - 类 javax.imageio.IIOParam 中的方法
返回二次取样网格的垂直偏移量。
getSubString(long, int) - 接口 java.sql.Clob 中的方法
获取此 Clob 对象指定的 CLOB 值中指定子字符串的副本。
getSubString(long, int) - 类 javax.sql.rowset.serial.SerialClob 中的方法
返回包含在此 SerialClob 对象中的子字符串的副本，从给定位置开始，后跟指定字符数。
getSubTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回子文本字体。
getSubTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的子文本字体。
getSubTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回子文本字体。
getSubType() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的子 MIME 类型。
getSubType() - 类 javax.activation.MimeType 中的方法
获取此对象的子类型。
getSuffix(int) - 类 javax.naming.CompositeName 中的方法
创建一个复合名称，其组件由此复合名称中组件的后缀组成。
getSuffix(int) - 类 javax.naming.CompoundName 中的方法
创建一个组合名称，其组件由该组合名称中组件的后缀组成。
getSuffix(int) - 类 javax.naming.ldap.LdapName 中的方法
创建一个名称，其组件由此 LDAP 名称中组件的后缀组成。
getSuffix(int) - 接口 javax.naming.Name 中的方法
创建一个名称，其组件由此名称中组件的后缀组成。
getSuperBound() - 接口 javax.lang.model.type.WildcardType 中的方法
返回此通配符的下边界。
getSuperclass() - 类 java.lang.Class 中的方法
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的超类的 Class。
getSuperclass() - 接口 javax.lang.model.element.TypeElement 中的方法
返回此类型元素的直接超类。
getSuperTables(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取在此数据库的特定模式中定义的表分层结构的描述。
getSuperTypes(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。
getSupportedAnnotationTypes() - 类 javax.annotation.processing.AbstractProcessor 中的方法
如果 processor 类是使用 SupportedAnnotationTypes 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
getSupportedAnnotationTypes() - 接口 javax.annotation.processing.Processor 中的方法
返回此 Processor 支持的注释类型的名称。
getSupportedAttributeCategories() - 接口 javax.print.PrintService 中的方法
确定客户端在设置此 PrintService 的作业时，可以指定的打印属性类别。
getSupportedAttributeValues(Class<? extends Attribute>, DocFlavor, AttributeSet) - 接口 javax.print.PrintService 中的方法
确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLEngine 中的方法
返回为了在此引擎上使用而可以启用的密码套件名称。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLServerSocket 中的方法
返回可以启用以供 SSL 连接使用的密码套件的名称。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLServerSocketFactory 中的方法
返回可以在由此工厂创建的 SSL 连接上启用的密码套件的名称。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLSocket 中的方法
返回可以启用以供此连接使用的密码套件的名称。
getSupportedCipherSuites() - 类 javax.net.ssl.SSLSocketFactory 中的方法
返回可以在 SSL 连接上启用的密码套件的名称。
getSupportedDocFlavors() - 接口 javax.print.PrintService 中的方法
确定在设置此 PrintService 的作业时，客户端可以指定的打印数据格式。
getSupportedDocFlavors() - 类 javax.print.StreamPrintServiceFactory 中的方法
查询该工厂，了解从此工厂所获得打印机可接受的 doc flavor。
getSupportedExtensions() - 类 java.security.cert.PKIXCertPathChecker 中的方法
返回一个此 PKIXCertPathChecker 支持（也就是识别，即能够处理）的 X.509 证书扩展的不可变的 Set，如果不支持这些扩展，则返回 null。
getSupportedOptions() - 类 javax.annotation.processing.AbstractProcessor 中的方法
如果 processor 类是使用 SupportedOptions 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
getSupportedOptions() - 接口 javax.annotation.processing.Processor 中的方法
返回此 Processor 识别的选项。
getSupportedProtocols() - 类 javax.net.ssl.SSLEngine 中的方法
返回能够被启用，以便让 SSLEngine 可使用的协议的名称。
getSupportedProtocols() - 类 javax.net.ssl.SSLServerSocket 中的方法
返回可以启用的协议的名称。
getSupportedProtocols() - 类 javax.net.ssl.SSLSocket 中的方法
返回能够被启用以供 SSL 连接使用的协议的名称。
getSupportedSourceVersion() - 类 javax.annotation.processing.AbstractProcessor 中的方法
如果 processor 类是使用 SupportedSourceVersion 注释的，则返回注释中的源版本。
getSupportedSourceVersion() - 接口 javax.annotation.processing.Processor 中的方法
返回此注释 Processor 支持的最新的源版本。
getSupportedSSLParameters() - 类 javax.net.ssl.SSLContext 中的方法
返回表示此 SSL 上下文受支持设置的 SSLParameters 的副本。
getSupportsAbsolutePositioning() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
指示用户是否可以利用鼠标动作（通常使用中间的鼠标按键）来绝对定位 thumb。
getSupportsWindowDecorations() - 类 javax.swing.LookAndFeel 中的方法
如果 LookAndFeel 返回的 RootPaneUI 实例支持 JRootPane 中提供 Window 装饰，则返回 true。
getSupportsWindowDecorations() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回 true； metal 可以提供 Window 装饰。
getSurrendersFocusOnKeystroke() - 类 javax.swing.JTable 中的方法
如果在键击导致编辑器被激活时编辑器应该获得焦点，则返回 true
getSymbol() - 类 java.util.Currency 中的方法
获取默认语言环境的货币符号。
getSymbol(Locale) - 类 java.util.Currency 中的方法
获取指定语言环境的货币符号。
getSymbol(String, Locale) - 类 java.util.spi.CurrencyNameProvider 中的方法
获取指定语言环境的给定货币代码的符号。
getSyncAllWidths() - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法

getSyncFactory() - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
返回一个 SyncFactory。
getSyncProvider() - 接口 javax.sql.rowset.CachedRowSet 中的方法
获取此 CachedRowSet 对象的 SyncProvider 实现。
getSyncResolver() - 异常 javax.sql.rowset.spi.SyncProviderException 中的方法
获取为此 SyncProviderException 对象设置的 SyncResolver 对象，如果没有设置，则获取包含在参考实现中的默认 SyncResolver 实现的实例。
getSynthesizer() - 类 javax.sound.midi.MidiSystem 中的静态方法
获得默认的合成器。
getSystem() - 类 java.rmi.activation.ActivationGroup 中的静态方法
返回该 VM 的激活系统。
getSystem() - 类 java.rmi.activation.ActivationGroupID 中的方法
返回组的激活系统。
getSystemClassLoader() - 类 java.lang.ClassLoader 中的静态方法
返回委托的系统类加载器。
getSystemClipboard() - 类 java.awt.Toolkit 中的方法
获取系统 Clipboard 的一个实例，该 Clipboard 可作为本机平台提供的剪贴板工具的接口。
getSystemCustomCursor(String) - 类 java.awt.Cursor 中的静态方法
返回与指定名称匹配的特定于系统的定制光标对象。
getSystemDisplayName(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
在系统文件浏览器中显示的文件、目录或文件夹名。
getSystemEventQueue() - 类 java.awt.Toolkit 中的方法
获取应用程序或 applet 的 EventQueue 实例。
getSystemEventQueueImpl() - 类 java.awt.Toolkit 中的方法
获取应用程序或 applet 的 EventQueue 实例，不检查访问权。
getSystemFunctions() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于此数据库的系统函数的逗号分隔列表。
getSystemIcon(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
在系统文件浏览器中显示的文件、目录或文件夹的图标。
getSystemId() - 接口 javax.xml.stream.events.EntityDeclaration 中的方法
实体的系统标识符。
getSystemId() - 接口 javax.xml.stream.events.NotationDeclaration 中的方法
注释的系统标识符，如果未提供该标识符，则为 null。
getSystemId() - 接口 javax.xml.stream.events.StartDocument 中的方法
返回 XML 数据的系统 ID
getSystemId() - 接口 javax.xml.stream.Location 中的方法
返回 XML 的系统 ID
getSystemId() - 类 javax.xml.transform.dom.DOMResult 中的方法
获取系统标识符。
getSystemId() - 类 javax.xml.transform.dom.DOMSource 中的方法
获取将从其解析 URL 的基本 ID（URL 或系统 ID）。
getSystemId() - 接口 javax.xml.transform.Result 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 类 javax.xml.transform.sax.SAXResult 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 类 javax.xml.transform.sax.SAXSource 中的方法
获取要从其解析 URI 的基本 ID（URI 或系统 ID）。
getSystemId() - 接口 javax.xml.transform.sax.TemplatesHandler 中的方法
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
getSystemId() - 接口 javax.xml.transform.sax.TransformerHandler 中的方法
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
getSystemId() - 接口 javax.xml.transform.Source 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 接口 javax.xml.transform.SourceLocator 中的方法
返回当前文档事件的系统标识符。
getSystemId() - 类 javax.xml.transform.stax.StAXResult 中的方法
返回的系统标识符始终为 null。
getSystemId() - 类 javax.xml.transform.stax.StAXSource 中的方法
获取此 StAXSource 使用的系统标识符。
getSystemId() - 类 javax.xml.transform.stream.StreamResult 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 类 javax.xml.transform.stream.StreamSource 中的方法
获取通过 setSystemId 设置的系统标识符。
getSystemId() - 接口 org.w3c.dom.DocumentType 中的方法
外部子集的系统标识符。
getSystemId() - 接口 org.w3c.dom.Entity 中的方法
如果已指定，则为与实体相关的系统标识符；否则为 null。
getSystemId() - 接口 org.w3c.dom.ls.LSInput 中的方法
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。
getSystemId() - 接口 org.w3c.dom.ls.LSOutput 中的方法
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。
getSystemId() - 接口 org.w3c.dom.Notation 中的方法
此表示法的系统标识符。
getSystemId() - 类 org.xml.sax.helpers.LocatorImpl 中的方法
返回保存的系统标识符。
getSystemId() - 类 org.xml.sax.InputSource 中的方法
获取此输入源的系统标识符。
getSystemId() - 接口 org.xml.sax.Locator 中的方法
返回当前文档事件的系统标识符。
getSystemId() - 异常 org.xml.sax.SAXParseException 中的方法
获取发生异常的实体的系统标识符。
getSystemJavaCompiler() - 类 javax.tools.ToolProvider 中的静态方法
获取此平台提供的 Java™ 编程语言编译器。
getSystemLoadAverage() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回最后一分钟内系统加载平均值。
getSystemLookAndFeelClassName() - 类 javax.swing.UIManager 中的静态方法
如果有实现本机系统外观的 LookAndFeel 类的名称，则返回该名称；否则返回默认的跨平台 LookAndFeel 类的名称。
getSystemProperties() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回所有系统属性的名称和值的映射。
getSystemResource(String) - 类 java.lang.ClassLoader 中的静态方法
从用来加载类的搜索路径中查找具有指定名称的资源。
getSystemResourceAsStream(String) - 类 java.lang.ClassLoader 中的静态方法
从用来加载类的搜索路径打开具有指定名称的资源，以读取该资源。
getSystemResources(String) - 类 java.lang.ClassLoader 中的静态方法
从用来加载类的搜索路径中查找所有具有指定名称的资源。
getSystemScope() - 类 java.security.IdentityScope 中的静态方法
已过时。 返回系统的身份作用域。
getSystemSelection() - 类 java.awt.Toolkit 中的方法
以 Clipboard 对象的形式获取系统选择的一个实例。
getSystemTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的系统文本颜色。
getSystemTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回系统文本颜色。
getSystemTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回系统文本字体。
getSystemTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的系统文本字体。
getSystemTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回系统文本字体。
getSystemToolClassLoader() - 类 javax.tools.ToolProvider 中的静态方法
返回此平台提供的工具的类加载器。
getSystemTray() - 类 java.awt.SystemTray 中的静态方法
获取表示桌面托盘区的 SystemTray 实例。
getSystemTypeDescription(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
在系统文件浏览器中显示的文件、目录或文件夹类型描述。
getTab(int) - 类 javax.swing.text.TabSet 中的方法
返回索引 index 处的 TabStop。
getTabAfter(float) - 类 javax.swing.text.TabSet 中的方法
返回 location 之后的 Tab 实例。
getTabAreaInsets(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabBase() - 类 javax.swing.text.ParagraphView 中的方法
返回从中计算制表符的位置。
getTabbedSpan(float, TabExpander) - 类 javax.swing.text.GlyphView 中的方法
确定使用给定选项卡扩展实现时所需的区域。
getTabbedSpan(float, TabExpander) - 接口 javax.swing.text.TabableView 中的方法
确定当使用给定的制表符扩展实现时所需的跨距。
getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int) - 类 javax.swing.text.Utilities 中的静态方法
确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int, boolean) - 类 javax.swing.text.Utilities 中的静态方法

getTabbedTextWidth(Segment, FontMetrics, int, TabExpander, int) - 类 javax.swing.text.Utilities 中的静态方法
确定给定的考虑制表符的文本段的宽度。
getTabBounds(JTabbedPane, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回指定选项卡索引的边界。
getTabBounds(int, Rectangle) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回 JTabbedPane 组件的坐标空间中指定选项卡的边界。
getTabBounds(JTabbedPane, int) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getTabBounds 方法。
getTabBounds(JTabbedPane, int) - 类 javax.swing.plaf.TabbedPaneUI 中的方法

getTabComponentAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置上的选项卡组件。
getTabCount() - 类 javax.swing.JTabbedPane 中的方法
返回此 tabbedpane 的选项卡数。
getTabCount() - 类 javax.swing.text.TabSet 中的方法
返回接收者包含的 Tab 实例数。
getTabExpander() - 类 javax.swing.text.GlyphView 中的方法
如果此视图中存在选项卡，则获取要使用的 TabExpander。
getTabIndex(TabStop) - 类 javax.swing.text.TabSet 中的方法

getTabIndexAfter(float) - 类 javax.swing.text.TabSet 中的方法
返回 location 之后使用的 Tab 的索引。
getTabInsets(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabLabelShiftX(int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabLabelShiftX(int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
重写该方法，使其不对 Java L&F 进行任何操作。
getTabLabelShiftY(int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabLabelShiftY(int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
重写该方法，使其不对 Java L&F 进行任何操作。
getTabLayoutPolicy() - 类 javax.swing.JTabbedPane 中的方法
返回在一次运行中不能放入所有的选项卡时，选项卡窗格使用的对选项卡进行布局安排的策略。
getTable() - 类 java.awt.image.ByteLookupTable 中的方法
按引用返回 lookup table 数据。
getTable() - 类 java.awt.image.LookupOp 中的方法
返回 LookupTable。
getTable() - 类 java.awt.image.ShortLookupTable 中的方法
根据引用返回查找表数据。
getTable() - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的方法
以 int 数组的形式按自然（非 Z 字形）顺序返回当前量化表的副本。
getTable() - 类 javax.swing.table.JTableHeader 中的方法
返回与此头关联的表。
getTableCellEditorComponent(JTable, Object, boolean, int, int) - 类 javax.swing.DefaultCellEditor 中的方法
实现 TableCellEditor 接口。
getTableCellEditorComponent(JTable, Object, boolean, int, int) - 接口 javax.swing.table.TableCellEditor 中的方法
为编辑器设置初始 value。
getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
返回默认的表单元格渲染器。
getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - 接口 javax.swing.table.TableCellRenderer 中的方法
返回用于绘制单元格的组件。
getTableHeader() - 类 javax.swing.JTable 中的方法
返回此 JTable 所使用的 tableHeader。
getTableModelListeners() - 类 javax.swing.table.AbstractTableModel 中的方法
返回一个包含在此模型上注册的所有表模型侦听器的数组。
getTableName(int) - 接口 java.sql.ResultSetMetaData 中的方法
获取指定列的名称。
getTableName() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回创建此 CachedRowSet 对象时所用对象（表）的标识符。
getTableName(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取派生指定列中值的表名称。
getTablePrivileges(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在类别中使用的每个表的访问权的描述。
getTables(String, String, String, String[]) - 接口 java.sql.DatabaseMetaData 中的方法
获取可在给定类别中使用的表的描述。
getTableTypes() - 接口 java.sql.DatabaseMetaData 中的方法
获取可在此数据库中使用的表类型。
getTabPlacement() - 类 javax.swing.JTabbedPane 中的方法
返回此选项卡窗格的选项卡布局。
getTabRunCount() - 类 javax.swing.JTabbedPane 中的方法
返回当前运行的用于显示选项卡的选项卡数。
getTabRunCount(JTabbedPane) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabRunCount(JTabbedPane) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 getTabRunCount 方法。
getTabRunCount(JTabbedPane) - 类 javax.swing.plaf.TabbedPaneUI 中的方法

getTabRunIndent(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabRunOffset(int, int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabRunOverlay(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getTabRunOverlay(int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法

getTabSet() - 类 javax.swing.text.ParagraphView 中的方法
获取计算制表符时使用的 Tabset。
getTabSet(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
获取 TabSet。
getTabSize() - 类 javax.swing.JTextArea 中的方法
获取用于扩展选项卡的字符数。
getTabSize() - 类 javax.swing.text.PlainView 中的方法
返回文档中制表符大小的集合，默认值是 8。
getTabSize() - 类 javax.swing.text.WrappedPlainView 中的方法
返回文档的制表符大小设置，默认为 8。
getTabularType() - 接口 javax.management.openmbean.TabularData 中的方法
返回描述此 TabularData 实例的表格类型。
getTabularType() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回描述此 TabularData 实例的表格类型。
getTag(String) - 类 javax.swing.text.html.HTML 中的静态方法
获取已知标记名称的标记常量（即集合 {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR} 中的某个标记）。
getTag() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
此迭代器所表示的标记类型。
getTagName() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getTagName() - 接口 org.w3c.dom.Element 中的方法
元素的名称。
getTags() - 接口 java.beans.PropertyEditor 中的方法
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记数组。
getTags() - 类 java.beans.PropertyEditorSupport 中的方法
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记值数组。
getTail(Handler) - 类 java.util.logging.Formatter 中的方法
返回一组格式化记录的尾部字符串。
getTail(Handler) - 类 java.util.logging.XMLFormatter 中的方法
返回一组 XML 格式记录的尾部字符串。
getTarget() - 类 java.beans.EventHandler 中的方法
返回此事件处理程序将为其发送消息的对象。
getTarget() - 类 java.beans.Statement 中的方法
返回此语句的目标。
getTarget() - 类 javax.accessibility.AccessibleRelation 中的方法
返回此关系的目标对象
getTarget() - 接口 javax.rmi.CORBA.Tie 中的方法
返回此 tie 的目标。
getTarget() - 类 javax.swing.BoxLayout 中的方法
返回使用此布局管理器的容器。
getTarget() - 类 javax.swing.OverlayLayout 中的方法
返回使用此布局管理器的容器。
getTarget() - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 中的方法
返回链接的目标。
getTarget() - 接口 javax.xml.crypto.dsig.SignatureProperty 中的方法
返回此 SignatureProperty 的目标 URI。
getTarget() - 接口 javax.xml.stream.events.ProcessingInstruction 中的方法
处理指令的目标部分。
getTarget() - 接口 org.w3c.dom.events.Event 中的方法
用于指示 EventTarget，最初将事件指派给它。
getTarget() - 接口 org.w3c.dom.ProcessingInstruction 中的方法
此处理指令的目标。
getTargetActions() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回目标放置动作。
getTargetActions() - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回一个 int，表示此 DropTarget 将接受的当前操作。
getTargetCertConstraints() - 类 java.security.cert.PKIXParameters 中的方法
返回目标证书所需的限制。
getTargetDataLine(AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
getTargetDataLine(AudioFormat, Mixer.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。
getTargetedNotifications() - 类 javax.management.remote.NotificationResult 中的方法
返回查询到的通知以及相应的侦听器。
getTargetEncodings(AudioFormat.Encoding) - 类 javax.sound.sampled.AudioSystem 中的静态方法
使用已安装的格式转换器集合获得系统可以从具有指定编码的音频输入流中获得的编码。
getTargetEncodings(AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
使用已安装的格式转换器集合，获得系统可以从具有指定格式的音频输入流中获得的编码。
getTargetEncodings() - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
获得目标格式编码的集合，此提供者向该集合提供格式转换服务。
getTargetEncodings(AudioFormat) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
获得受给定了特定源格式的格式转换器支持的目标格式编码集合。
getTargetError() - 异常 javax.management.RuntimeErrorException 中的方法
返回抛出的实际 Error。
getTargetException() - 异常 java.lang.reflect.InvocationTargetException 中的方法
获取抛出的目标异常。
getTargetException() - 异常 javax.management.MBeanException 中的方法
返回实际抛出的 Exception。
getTargetException() - 异常 javax.management.ReflectionException 中的方法
返回抛出的实际 Exception。
getTargetException() - 异常 javax.management.RuntimeMBeanException 中的方法
返回抛出的实际 RuntimeException。
getTargetException() - 异常 javax.management.RuntimeOperationsException 中的方法
返回抛出的实际 RuntimeException。
getTargetFormats(AudioFormat.Encoding, AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。
getTargetFormats(AudioFormat.Encoding, AudioFormat) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
获得具有受格式转换器支持的指定编码的目标格式集合。
getTargetLineInfo(Line.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
获得关于已安装混频器所支持特定类型的全部目标行的信息。
getTargetLineInfo() - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器支持的目标行集合的信息。
getTargetLineInfo(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
获得关于此混频器支持的特定类型目标行的信息。
getTargetLines() - 接口 javax.sound.sampled.Mixer 中的方法
获得当前从此混频器打开的所有目标行的集合。
getTargName() - 接口 org.ietf.jgss.GSSContext 中的方法
返回上下文接受端的名称。
getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Iterable<String>, Iterable<String>, Iterable<? extends JavaFileObject>) - 接口 javax.tools.JavaCompiler 中的方法
使用给定组件和参数创建编译任务的 future。
getTaskCount() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回曾计划执行的近似任务总数。
getTBSCertificate() - 类 java.security.cert.X509Certificate 中的方法
从此证书中获取以 DER 编码的证书信息，即 tbsCertificate。
getTBSCertList() - 类 java.security.cert.X509CRL 中的方法
从此 CRL 中获取以 DER 编码的 CRL 信息，即 tbsCertList。
getTcpNoDelay() - 类 java.net.Socket 中的方法
测试是否启用 TCP_NODELAY。
getTemplates() - 接口 javax.xml.transform.sax.TemplatesHandler 中的方法
当 TemplatesHandler 对象用作 ContentHandler（用于转换指令的解析）时，它创建 Templates 对象，调用者可以在 SAX 事件已完成后获取该对象。
getTempoFactor() - 接口 javax.sound.midi.Sequencer 中的方法
返回 sequencer 的当前速度因子。
getTempoInBPM() - 接口 javax.sound.midi.Sequencer 中的方法
获得当前的速度，用每分钟的拍数表示。
getTempoInMPQ() - 接口 javax.sound.midi.Sequencer 中的方法
获得当前的速度，用每四分音符的微秒数表示。
getText() - 类 java.awt.event.InputMethodEvent 中的方法
获取已提交文本和撰写文本的组合。
getText() - 类 java.awt.Label 中的方法
获取此标签的文本。
getText() - 类 java.awt.TextComponent 中的方法
返回此文本组件表示的文本。
getText() - 类 java.text.BreakIterator 中的方法
获取被扫描的文本
getText() - 类 javax.security.auth.callback.TextInputCallback 中的方法
获取检索到的文本。
getText() - 类 javax.swing.AbstractButton 中的方法
返回按钮的文本。
getText() - 类 javax.swing.JEditorPane 中的方法
根据此编辑器的内容类型返回此 TextComponent 中所包含的文本。
getText() - 类 javax.swing.JLabel 中的方法
返回该标签所显示的文本字符串。
getText() - 类 javax.swing.JPasswordField 中的方法
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
getText(int, int) - 类 javax.swing.JPasswordField 中的方法
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
getText(int, int) - 类 javax.swing.text.AbstractDocument 中的方法
从文档中获得文本序列。
getText(int, int, Segment) - 类 javax.swing.text.AbstractDocument 中的方法
获取文档给定部分内包含的文本。
getText(Element) - 类 javax.swing.text.AbstractWriter 中的方法
返回与该元素关联的文本。
getText(int, int) - 接口 javax.swing.text.Document 中的方法
获取文档中给定部分包含的文本。
getText(int, int, Segment) - 接口 javax.swing.text.Document 中的方法
获取文档中给定部分包含的文本。
getText(int, int) - 类 javax.swing.text.GlyphView 中的方法
获取对占用给定范围的文本的引用。
getText(int, int) - 类 javax.swing.text.JTextComponent 中的方法
获取由组件表示的文本部分。
getText() - 类 javax.swing.text.JTextComponent 中的方法
返回此 TextComponent 中包含的文本。
getText() - 接口 javax.xml.stream.events.Comment 中的方法
返回注释的字符串数据，如果不存在这样的数据，则返回空字符串。
getText() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getText() - 接口 javax.xml.stream.XMLStreamReader 中的方法
以字符串的形式返回解析事件的当前值，此方法返回 CHARACTERS 事件的字符串值，返回 COMMENT 的值、ENTITY_REFERENCE 的替代值、CDATA 节的字符串值、SPACE 事件的字符串值、DTD 内部子集的字符串值。
getTextBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于文本组件的 border 实例
getTextBounds(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回两个索引之间文本的边界矩形。
getTextBounds(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回包围两个索引之间文本的 Rectangle。
getTextCharacters(int, char[], int, int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getTextCharacters() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getTextCharacters() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回一个包含此事件中字符的数组。
getTextCharacters(int, char[], int, int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取与 CHARACTERS、SPACE 或 CDATA 事件关联的文本。
getTextComponent(ActionEvent) - 类 javax.swing.text.TextAction 中的方法
确定动作所使用的组件。
getTextContent() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getTextContent() - 接口 org.w3c.dom.Node 中的方法
此属性返回此节点及其后代的文本内容。
getTextField() - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回此编辑器的子 JFormattedTextField。
getTextFieldBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getTextFieldBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于 JTextField 的 border 实例
getTextHighlightColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的文本高亮显示颜色。
getTextHighlightColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回文本高亮显示的颜色。
getTextLength() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getTextLength() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回文本字符数组中此文本事件的字符序列长度。
getTextListeners() - 类 java.awt.TextComponent 中的方法
返回在此文本组件上所有已注册文本侦听器的数组。
getTextLocation(TextHitInfo) - 接口 java.awt.im.InputMethodRequests 中的方法
获取当前撰写文本中指定偏移量的位置，或已提交文本中的选择位置。
getTextNonSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回未选定节点时绘制文本所使用的颜色。
getTextPlainUnicodeFlavor() - 类 java.awt.datatransfer.DataFlavor 中的静态方法
返回表示具有 Unicode 编码的纯文本的 DataFlavor，其中： representationClass = java.io.InputStream mimeType = "text/plain; charset=<platform default Unicode encoding>" Sun 的 Microsoft Windows 实现使用编码 utf-16le。
getTextRange(int, int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
返回两个索引之间的文本字符串。
getTextRange(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回两个索引之间的文本。
getTextRange(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回两个索引之间的文本。
getTextRange(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
返回两个索引之间的文本字符串。
getTextRange(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回两个索引之间的文本字符串。
getTextSelectionColor() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
返回选定节点时绘制文本所使用的颜色。
getTextSequenceAfter(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回给定索引后面的 AccessibleTextSequence。
getTextSequenceAfter(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 之后的 AccessibleTextSequence。
getTextSequenceAfter(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定 index 之后的 AccessibleTextSequence。
getTextSequenceAt(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回给定索引处的 AccessibleTextSequence。
getTextSequenceAt(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 处的 AccessibleTextSequence。
getTextSequenceAt(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定 index 处的 AccessibleTextSequence。
getTextSequenceBefore(int, int) - 接口 javax.accessibility.AccessibleExtendedText 中的方法
返回给定索引前面的 AccessibleTextSequence。
getTextSequenceBefore(int, int) - 类 javax.swing.JPasswordField.AccessibleJPasswordField 中的方法
返回给定 index 之前的 AccessibleTextSequence。
getTextSequenceBefore(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
返回给定 index 之前的 AccessibleTextSequence。
getTextShiftOffset() - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法

getTextShiftOffset() - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的方法
重写以便不用为 Toggle 按钮和子类交替呈现文本。
getTextStart() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getTextStart() - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回存储（此文本事件的）第一个字符位置处的文本字符数组的偏移量。
getTextViewForTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回为指定选项卡呈现样式化文本 (HTML) 所需的文本 View 对象；如果此选项卡不需要任何特殊化的文本呈现，则返回 null。
getThickness() - 类 javax.swing.border.LineBorder 中的方法
返回边框的厚度。
getThisUpdate() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的 thisUpdate 日期。
getThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
返回活动线程的当前数目，包括守护线程和非守护线程。
getThreadCpuTime(long) - 接口 java.lang.management.ThreadMXBean 中的方法
返回指定 ID 的线程的总 CPU 时间（以毫微秒为单位）。
getThreadFactory() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
返回用于创建新线程的线程工厂。
getThreadGroup() - 类 java.lang.SecurityManager 中的方法
调用此方法时，返回所有新创建的线程实例化后所在的线程组。
getThreadGroup() - 类 java.lang.Thread 中的方法
返回该线程所属的线程组。
getThreadId() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程的 ID。
getThreadID() - 类 java.util.logging.LogRecord 中的方法
获取产生消息的线程的标识符。
getThreadInfo(long) - 接口 java.lang.management.ThreadMXBean 中的方法
返回指定 id 的不具有堆栈跟踪的线程的线程信息。
getThreadInfo(long[]) - 接口 java.lang.management.ThreadMXBean 中的方法
返回其 ID 在输出数组 ids 中的每个线程的线程信息，这些线程不具有堆栈跟踪。
getThreadInfo(long, int) - 接口 java.lang.management.ThreadMXBean 中的方法
返回指定 id 的线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。
getThreadInfo(long[], int) - 接口 java.lang.management.ThreadMXBean 中的方法
返回其 ID 在输入数组 ids 中的每个线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。
getThreadInfo(long[], boolean, boolean) - 接口 java.lang.management.ThreadMXBean 中的方法
返回每个线程的线程信息，线程 ID 位于输入数组 ids 中，带有堆栈跟踪和同步信息。
getThreadMXBean() - 类 java.lang.management.ManagementFactory 中的静态方法
返回 Java 虚拟机的线程系统的管理 Bean。
getThreadName() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程的名称。
getThreadState() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程的状态。
getThreadUserTime(long) - 接口 java.lang.management.ThreadMXBean 中的方法
返回指定 ID 的线程在用户模式中执行的 CPU 时间（以毫微秒为单位）。
getThreshold(ObjectName) - 类 javax.management.monitor.CounterMonitor 中的方法
如果指定的对象包含在观察到的 MBeans 集中，则获取指定对象的当前阈值，否则将为 null。
getThreshold() - 类 javax.management.monitor.CounterMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getThreshold(ObjectName) 取代
getThreshold() - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getThreshold(ObjectName) 取代
getThreshold(ObjectName) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
获取指定 MBean 的阈值。
getThrowable() - 类 java.awt.event.InvocationEvent 中的方法
返回在执行 Runnable 的 run() 方法时捕获的任何 Throwable。
getThrown() - 类 java.util.logging.LogRecord 中的方法
获取与日志记录相关联的所有 throwable。
getThrownTypes() - 接口 javax.lang.model.element.ExecutableElement 中的方法
按声明顺序返回此方法或构造方法的 throws 子句中所列出的异常和其他 throwable。
getThrownTypes() - 接口 javax.lang.model.type.ExecutableType 中的方法
返回此 executable 的 throws 子句中列出的异常和其他 throwable。
getThumbBounds() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
返回 thumb 的当前大小/位置。
getThumbnail(int) - 类 javax.imageio.IIOImage 中的方法
返回与主图像关联的缩略图。
getThumbnailHeight(int, int) - 类 javax.imageio.ImageReader 中的方法
返回通过索引 thumbnailIndex 指定的缩略图预览图像的高度，其与通过索引 ImageIndex 指定的图像关联。
getThumbnails() - 类 javax.imageio.IIOImage 中的方法
返回缩略图 BufferedImage 的当前 List，如果没有设置任何缩略图，则返回 null。
getThumbnailWidth(int, int) - 类 javax.imageio.ImageReader 中的方法
返回通过索引 thumbnailIndex 指定的缩略图预览图像的宽度，其与通过索引 ImageIndex 指定的图像关联。
getThumbOverhang() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
返回 thumb 在滑杆上滑过的量。
getThumbSize() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getThumbSize() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法

getTick() - 类 javax.sound.midi.MidiEvent 中的方法
获得事件的用 MIDI 刻度表示的时间戳
getTickLength() - 类 javax.sound.midi.Sequence 中的方法
获得此 Sequence 的持续时间，用 MIDI 节拍数表示。
getTickLength() - 接口 javax.sound.midi.Sequencer 中的方法
获得当前 sequence 的长度，用 MIDI 节拍数表示，如果未设置 sequence，则为 0。
getTickLength() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
获取水平滑块的刻度区域的高度和垂直滑块的刻度区域的宽度。
getTickLength() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
获取水平滑块的刻度区域高度和垂直滑块的刻度区域宽度。
getTickPosition() - 接口 javax.sound.midi.Sequencer 中的方法
获得 sequence 的当前位置，用 MIDI 节拍数表示。
getTie(Remote) - 类 javax.rmi.CORBA.Util 中的静态方法
返回给定目标对象的 tie（如果存在）。
getTie(Remote) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.getTie(java.rmi.Remote) 的委托调用。
getTile(int, int) - 类 java.awt.image.BufferedImage 中的方法
返回 tile (tileX, tileY)。
getTile(int, int) - 接口 java.awt.image.RenderedImage 中的方法
返回 tile (tileX, tileY)。
getTiledSizeRequirements(SizeRequirements[]) - 类 javax.swing.SizeRequirements 中的静态方法
确定端到端放置一组组件需要占用的总空间。
getTileGridXOffset() - 类 java.awt.image.BufferedImage 中的方法
返回 tile 网格相对于原点的 x 偏移量（例如，tile (0, 0) 位置的 x 坐标）。
getTileGridXOffset() - 接口 java.awt.image.RenderedImage 中的方法
返回 tile 网格相对于原点的 X 偏移量，即 tile (0, 0) 左上角像素的 X 坐标。
getTileGridXOffset(int) - 类 javax.imageio.ImageReader 中的方法
返回给定图像中 tile (0, 0) 的左上角的 X 坐标。
getTileGridXOffset() - 类 javax.imageio.ImageWriteParam 中的方法
返回图像的水平 tile 网格偏移量，将根据该偏移量对输出流进行写入。
getTileGridYOffset() - 类 java.awt.image.BufferedImage 中的方法
返回 tile 网格相对于原点的 y 偏移量（例如，tile (0, 0) 位置的 y 坐标）。
getTileGridYOffset() - 接口 java.awt.image.RenderedImage 中的方法
返回 tile 网格相对于原点的 Y 偏移量，即 tile (0, 0) 左上角像素的 Y 坐标。
getTileGridYOffset(int) - 类 javax.imageio.ImageReader 中的方法
返回给定图像中 tile (0, 0) 的左上角的 Y 坐标。
getTileGridYOffset() - 类 javax.imageio.ImageWriteParam 中的方法
返回图像的垂直 tile 网格偏移量，将根据该偏移量对输出流进行写入。
getTileHeight() - 类 java.awt.image.BufferedImage 中的方法
返回 tile 高度（以像素为单位）。
getTileHeight() - 接口 java.awt.image.RenderedImage 中的方法
返回 tile 的高度，以像素为单位。
getTileHeight(int) - 类 javax.imageio.ImageReader 中的方法
返回给定图像中 tile 的高度。
getTileHeight() - 类 javax.imageio.ImageWriteParam 中的方法
返回图像中每个 tile 的高度，将根据该高度对输出流进行写入。
getTileIcon() - 类 javax.swing.border.MatteBorder 中的方法
返回平铺边框的图标，如果使用了纯色，则返回 null。
getTileWidth() - 类 java.awt.image.BufferedImage 中的方法
返回 tile 宽度（以像素为单位）。
getTileWidth() - 接口 java.awt.image.RenderedImage 中的方法
返回 tile 的宽度，以像素为单位。
getTileWidth(int) - 类 javax.imageio.ImageReader 中的方法
返回给定图像中 tile 的宽度。
getTileWidth() - 类 javax.imageio.ImageWriteParam 中的方法
返回图像中每个 tile 的宽度，将根据该宽度对输出流进行写入。
getTilingMode() - 类 javax.imageio.ImageWriteParam 中的方法
如果支持平铺，则返回当前平铺模式。
getTime(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值。
getTime(int, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
getTime(String) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。
getTime(String, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
getTime(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTime(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTime(int, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTime(String, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTime() - 类 java.sql.Timestamp 中的方法
返回此 Timestamp 对象表示的自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。
getTime() - 类 java.util.Calendar 中的方法
返回一个表示此 Calendar 时间值（从历元至现在的毫秒偏移量）的 Date 对象。
getTime() - 类 java.util.Date 中的方法
返回自 1970 年 1 月 1 日 00:00:00 GMT 以来此 Date 对象表示的毫秒数。
getTime() - 类 java.util.zip.ZipEntry 中的方法
返回条目的修改时间；如果未指定，则返回 -1。
getTimeDateFunctions() - 接口 java.sql.DatabaseMetaData 中的方法
获取可用于此数据库的时间和日期函数的逗号分隔列表。
getTimeInMillis() - 类 java.util.Calendar 中的方法
返回此 Calendar 的时间值，以毫秒为单位。
getTimeInMillis(Calendar) - 类 javax.xml.datatype.Duration 中的方法
返回以毫秒为单位的持续时间的长度。
getTimeInMillis(Date) - 类 javax.xml.datatype.Duration 中的方法
返回以毫秒为单位的持续时间的长度。
getTimeInstance() - 类 java.text.DateFormat 中的静态方法
获取时间格式器，该格式器具有默认语言环境的默认格式化风格。
getTimeInstance(int) - 类 java.text.DateFormat 中的静态方法
获取时间格式器，该格式器具有默认语言环境的给定格式化风格。
getTimeInstance(int, Locale) - 类 java.text.DateFormat 中的静态方法
获取时间格式器，该格式器具有给定语言环境的给定格式化风格。
getTimeInstance(int, Locale) - 类 java.text.spi.DateFormatProvider 中的方法
返回一个新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化时间。
getTimeLimit() - 类 javax.naming.directory.SearchControls 中的方法
检索这些 SearchControls 以毫秒为单位的时间限制。
getTimestamp() - 类 java.security.CodeSigner 中的方法
返回签名时间戳。
getTimestamp() - 类 java.security.Timestamp 中的方法
返回生成时间戳时的日期和时间。
getTimestamp(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值。
getTimestamp(int, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
getTimestamp(String) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。
getTimestamp(String, Calendar) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
getTimestamp(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTimestamp(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTimestamp(int, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTimestamp(String, Calendar) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getTimeStamp() - 类 javax.management.Notification 中的方法
获得通知时间戳。
getTimeStamp() - 接口 org.w3c.dom.events.Event 中的方法
用于指定创建事件的时间（与历元相关，以毫秒为单位）。
getTimeToLive() - 类 java.net.DatagramSocketImpl 中的方法
获取 TTL （生存时间）选项。
getTimeToLive() - 类 java.net.MulticastSocket 中的方法
获取在套接字上发出的多播数据包的默认生存时间。
getTimeToLive(String, Locale) - 类 java.util.ResourceBundle.Control 中的方法
返回在此 ResourceBundle.Control 下加载的资源包生存时间 (TTL) 值。
getTimeZone() - 类 java.text.DateFormat 中的方法
获取时区。
getTimeZone() - 类 java.util.Calendar 中的方法
获得时区。
getTimeZone() - 类 java.util.GregorianCalendar 中的方法

getTimeZone(String) - 类 java.util.TimeZone 中的静态方法
获取给定 ID 的 TimeZone。
getTimezone() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回以分为单位的时区偏移量，如果未定义此可选字段，则返回 DatatypeConstants.FIELD_UNDEFINED。
getTimeZone(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回此类的 java.util.TimeZone。
getTimezoneOffset() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000) 取代。
getTipText() - 类 javax.swing.JToolTip 中的方法
返回显示工具提示时所显示的文本。
getTitle() - 类 java.awt.Dialog 中的方法
获取 dialog 的标题。
getTitle() - 类 java.awt.Frame 中的方法
获得窗体的标题。
getTitle() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题。
getTitle() - 类 javax.swing.JInternalFrame 中的方法
返回 JInternalFrame 的标题。
getTitle(String, FontMetrics, int) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法

getTitleAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡标题。
getTitleColor() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题颜色。
getTitledBorderText() - 接口 javax.accessibility.AccessibleExtendedComponent 中的方法
返回有标题的边框文本
getTitledBorderText() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回加标题的边界文本
getTitledBorderText() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回有标题边界的文本
getTitledBorderText() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回有标题边框的文本
getTitleFont() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题字体。
getTitleJustification() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题对齐方式。
getTitlePosition() - 类 javax.swing.border.TitledBorder 中的方法
返回带标题边框的标题位置。
getToggleButtonBorder() - 类 javax.swing.plaf.basic.BasicBorders 中的静态方法

getToggleButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders 中的静态方法
返回一个用于 JToggleButton 的 border 实例
getToggleClickCount() - 类 javax.swing.JTree 中的方法
返回展开或关闭节点所需的鼠标单击数。
getToIndex() - 类 javax.swing.event.TableColumnModelEvent 中的方法
返回 toIndex。
getTokenThreshold() - 类 javax.swing.text.html.HTMLDocument 中的方法
获取在试图更新文档元素结构之前要缓冲的标记数。
getToolkit() - 类 java.awt.Component 中的方法
获取此组件的工具包。
getToolkit() - 类 java.awt.Window 中的方法
返回此窗体的工具包。
getToolTip() - 类 java.awt.TrayIcon 中的方法
返回与此 TrayIcon 关联的工具提示字符串。
getToolTipLocation(MouseEvent) - 类 javax.swing.JComponent 中的方法
返回工具提示在此组件坐标系统中的位置。
getToolTipText() - 接口 javax.accessibility.AccessibleExtendedComponent 中的方法
返回工具提示文本
getToolTipText() - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
返回工具提示文本
getToolTipText() - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
返回工具提示文本
getToolTipText() - 类 javax.swing.JComponent 中的方法
返回通过 setToolTipText 所设置的工具提示字符串。
getToolTipText(MouseEvent) - 类 javax.swing.JComponent 中的方法
返回用作 event 工具提示的字符串。
getToolTipText() - 类 javax.swing.JLabel.AccessibleJLabel 中的方法
返回工具提示文本
getToolTipText(MouseEvent) - 类 javax.swing.JList 中的方法
返回用于给定事件的工具提示文本。
getToolTipText(MouseEvent) - 类 javax.swing.JTabbedPane 中的方法
返回由鼠标事件位置确定的组件的工具提示文本。
getToolTipText(MouseEvent) - 类 javax.swing.JTable 中的方法
重写 JComponent 的 getToolTipText 方法，从而允许使用渲染器的提示（如果设置了文本）。
getToolTipText(MouseEvent) - 类 javax.swing.JTree 中的方法
重写 JComponent 的 getToolTipText 方法，以允许使用渲染器的提示（如果渲染器设置了文本）。
getToolTipText(JTextComponent, Point) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
返回在传入位置上用作工具提示的字符串。
getToolTipText(JTextComponent, Point) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 getToolTipText 方法。
getToolTipText(JTextComponent, Point) - 类 javax.swing.plaf.TextUI 中的方法
返回在传入位置上用作工具提示的字符串。
getToolTipText(MouseEvent) - 类 javax.swing.table.JTableHeader 中的方法
如果设置了提示文本，则允许使用渲染器的提示。
getToolTipText(float, float, Shape) - 类 javax.swing.text.html.ImageView 中的方法
对于图像，工具提示文本来自于 ALT 属性指定的文本。
getToolTipText(MouseEvent) - 类 javax.swing.text.JTextComponent 中的方法
返回用作 event 的工具提示的字符串。
getToolTipText(float, float, Shape) - 类 javax.swing.text.View 中的方法
返回提定位置的工具提示文本。
getToolTipTextAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回 index 位置的选项卡工具提示文本。
getToPage() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则返回要打印的最后一页（包括该页）。
getTopComponent() - 类 javax.swing.JSplitPane 中的方法
返回分隔条上面或者左边的组件。
getTopInset() - 类 javax.swing.text.AsyncBoxView 中的方法
获得视图四周顶部的空白部分。
getTopInset() - 类 javax.swing.text.CompositeView 中的方法
获取顶部 inset。
getTopLevelAncestor() - 类 javax.swing.JComponent 中的方法
返回此组件的顶层祖先（包含的 Window 或 Applet）；如果尚未将此组件添加到任意容器中，则返回 null。
getTotalColumnWidth() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
返回所有列的总宽度。
getTotalColumnWidth() - 接口 javax.swing.table.TableColumnModel 中的方法
返回所有列的总宽度。
getTotalCompilationTime() - 接口 java.lang.management.CompilationMXBean 中的方法
返回在编译上花费的累积耗费时间的近似值（以毫秒为单位）。
getTotalIn() - 类 java.util.zip.Deflater 中的方法
返回到目前为止输入未压缩字节的总数。
getTotalIn() - 类 java.util.zip.Inflater 中的方法
返回到目前为止输入压缩字节的总数。
getTotalLoadedClassCount() - 接口 java.lang.management.ClassLoadingMXBean 中的方法
返回自 Java 虚拟机开始执行到目前已经加载的类的总数。
getTotalOut() - 类 java.util.zip.Deflater 中的方法
返回到目前为止输出压缩字节的总数。
getTotalOut() - 类 java.util.zip.Inflater 中的方法
返回到目前为止输出未压缩字节的总数。
getTotalSize() - 接口 org.w3c.dom.ls.LSProgressEvent 中的方法
包括所有外部资源的文档的总大小，如果能看到对更多的外部资源的引用，则此数量可能在解析文档时而改变。
getTotalSpace() - 类 java.io.File 中的方法
返回此抽象路径名指定的分区大小。
getTotalStartedThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
返回自从 Java 虚拟机启动以来创建和启动的线程总数目。
getTrackBounds() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
返回滑道的当前边界，即递增和递减按钮之间的空间（减去 insets）。
getTrackLength() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
返回较长的滑杆尺寸。
getTrackMute(int) - 接口 javax.sound.midi.Sequencer 中的方法
获得轨道的当前静音状态。
getTracks() - 类 javax.sound.midi.Sequence 中的方法
获得包含此 Sequence 中所有轨道的数组。
getTrackSolo(int) - 接口 javax.sound.midi.Sequencer 中的方法
获得轨道的当前 solo 状态。
getTrackWidth() - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
返回较短的滑道尺寸。
getTrafficClass() - 类 java.net.DatagramSocket 中的方法
为从此 DatagramSocket 上发送的包获取 IP 数据报头中的流量类别或服务类型。
getTrafficClass() - 类 java.net.Socket 中的方法
为从此 Socket 上发送的包获取 IP 头中的流量类别或服务类型。
getTrailerField() - 类 java.security.spec.PSSParameterSpec 中的方法
返回尾部字段的值，即：PKCS#1 v2.1 中的 bc。
getTransactionIsolation() - 接口 java.sql.Connection 中的方法
获取此 Connection 对象的当前事务隔离级别。
getTransactionIsolation() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回此 RowSet 对象连接的事务隔离属性。
getTransactionIsolation() - 接口 javax.sql.RowSet 中的方法
获取为此 RowSet 对象设置的事务隔离级别。
getTransactionTimeout() - 接口 javax.transaction.xa.XAResource 中的方法
获取为此 XAResource 实例设置的当前事务超时值。
getTransferable() - 类 java.awt.dnd.DragSourceContext 中的方法
返回与此 DragSourceContext 关联的 Transferable。
getTransferable() - 类 java.awt.dnd.DropTargetContext 中的方法
获取此操作的 Transferable（代理）操作数
getTransferable() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回 Transferable 对象，该对象表示与当前的 drag 操作有关的数据。
getTransferable() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回与 drop 相关的 Transferable 对象。
getTransferable() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回与此传输关联的 Transferable。
getTransferData(DataFlavor) - 类 java.awt.datatransfer.StringSelection 中的方法
如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
getTransferData(DataFlavor) - 接口 java.awt.datatransfer.Transferable 中的方法
返回一个对象，该对象表示将要被传输的数据。
getTransferData(DataFlavor) - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的方法
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。
getTransferData(DataFlavor, DataSource) - 接口 javax.activation.DataContentHandler 中的方法
返回一个对象，该对象表示将要传输的数据。
getTransferData(DataFlavor) - 类 javax.activation.DataHandler 中的方法
返回一个对象，该对象表示要传输的数据。
getTransferDataFlavors() - 类 java.awt.datatransfer.StringSelection 中的方法
返回 flavor 的数组，Transferable 可用该 flavor 提供数据。
getTransferDataFlavors() - 接口 java.awt.datatransfer.Transferable 中的方法
返回 DataFlavor 对象的数组，指示可用于提供数据的 flavor。
getTransferDataFlavors() - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的方法
返回一个 DataFlavor 对象数组，指示该数据的 flavor 是否可由封装的 transferable 提供。
getTransferDataFlavors() - 接口 javax.activation.DataContentHandler 中的方法
返回一个 DataFlavor 对象数组，这些对象指示可用于提供数据的 flavor。
getTransferDataFlavors() - 类 javax.activation.DataHandler 中的方法
返回此数据在其中可用的 DataFlavor。
getTransferHandler() - 类 javax.swing.JApplet 中的方法
获取 transferHandler 属性。
getTransferHandler() - 类 javax.swing.JComponent 中的方法
获取 transferHandler 属性。
getTransferHandler() - 类 javax.swing.JDialog 中的方法
获取 transferHandler 属性。
getTransferHandler() - 类 javax.swing.JFrame 中的方法
获取 transferHandler 属性。
getTransferHandler() - 类 javax.swing.JWindow 中的方法
获取 transferHandler 属性。
getTransferSize() - 异常 java.sql.DataTruncation 中的方法
获得实际传输的数据字节数。
getTransferType() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 的转换类型。
getTransferType() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
getTransferType() - 类 java.awt.image.Raster 中的方法
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
getTransferType() - 类 java.awt.image.SampleModel 中的方法
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
getTransform() - 类 java.awt.font.FontRenderContext 中的方法
获取用于在此 FontRenderContext 中将印刷点缩放为像素的转换。
getTransform() - 类 java.awt.Font 中的方法
返回与此 Font 相关的变换的副本。
getTransform() - 类 java.awt.font.TransformAttribute 中的方法
返回包装转换的一个副本。
getTransform() - 类 java.awt.Graphics2D 中的方法
返回 Graphics2D 上下文中当前 Transform 的副本。
getTransform() - 类 java.awt.image.AffineTransformOp 中的方法
返回此转换操作使用的仿射转换。
getTransform() - 类 java.awt.image.renderable.RenderContext 中的方法
获取当前“用户到设备”的 AffineTransform。
getTransform() - 类 java.awt.MultipleGradientPaint 中的方法
返回应用于渐变的变换的副本。
getTransformer() - 接口 javax.xml.transform.sax.TransformerHandler 中的方法
获取与此处理程序关联的 Transformer，用于设置参数和输出属性。
getTransforms() - 接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod 中的方法
返回一个不可修改的列表，由此 RetrievalMethod 的 Transform 组成。
getTransforms() - 接口 javax.xml.crypto.dsig.Reference 中的方法
返回一个 不可修改的列表，由包含在此 Reference 中的 Transform 组成。
getTransformType() - 类 java.awt.font.FontRenderContext 中的方法
返回此 FontRenderContext 的仿射转换的整数类型，该类型由 AffineTransform.getType() 指定。
getTranslateInstance(double, double) - 类 java.awt.geom.AffineTransform 中的静态方法
返回表示平移变换的变换。
getTranslateX() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵平移元素 (m02) 的 X 坐标。
getTranslateY() - 类 java.awt.geom.AffineTransform 中的方法
返回 3x3 仿射变换矩阵平移元素 (m12) 的 Y 坐标。
getTransmitter() - 接口 javax.sound.midi.MidiDevice 中的方法
获得 MIDI 设备将从其传输 MIDI 数据的 MIDI OUT 连接。
getTransmitter() - 类 javax.sound.midi.MidiSystem 中的静态方法
从外部 MIDI 端口或其他默认源获得 MIDI 传输器。
getTransmitters() - 接口 javax.sound.midi.MidiDevice 中的方法
返回与该 MidiDevice 连接的所有当前活动的、非关闭的传输器。
getTransparency() - 类 java.awt.Color 中的方法
返回此 Color 的透明模式。
getTransparency() - 类 java.awt.GradientPaint 中的方法
返回此 GradientPaint 的透明度模式。
getTransparency() - 类 java.awt.image.BufferedImage 中的方法
返回透明度。
getTransparency() - 类 java.awt.image.ColorModel 中的方法
返回透明度。
getTransparency() - 类 java.awt.image.IndexColorModel 中的方法
返回透明度。
getTransparency() - 类 java.awt.image.VolatileImage 中的方法
返回透明度。
getTransparency() - 类 java.awt.MultipleGradientPaint 中的方法
返回此 Paint 对象的透明度模式。
getTransparency() - 类 java.awt.TexturePaint 中的方法
返回此 TexturePaint 的透明模式。
getTransparency() - 接口 java.awt.Transparency 中的方法
返回此 Transparency 的类型。
getTransparentPixel() - 类 java.awt.image.IndexColorModel 中的方法
返回此 IndexColorModel 中透明像素的索引；如果没有 alpha 值为 0 的像素，则返回 -1。
getTrayIcons() - 类 java.awt.SystemTray 中的方法
返回由此应用程序添加到托盘中的所有图标的数组。
getTrayIconSize() - 类 java.awt.SystemTray 中的方法
返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
getTRC() - 类 java.awt.color.ICC_ProfileGray 中的方法
以 short 数组的形式返回 TRC。
getTRC(int) - 类 java.awt.color.ICC_ProfileRGB 中的方法
以数组形式返回特定分量的 TRC。
getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - 类 javax.swing.DefaultCellEditor 中的方法
实现 TreeCellEditor 接口。
getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
配置编辑器。
getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - 接口 javax.swing.tree.TreeCellEditor 中的方法
设置编辑器的初始值。
getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
配置基于传入组件的渲染器。
getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - 接口 javax.swing.tree.TreeCellRenderer 中的方法
将当前树单元格的值设置为 value。
getTreeComputerIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeControlIcon(boolean) - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeExpansionListeners() - 类 javax.swing.JTree 中的方法
返回使用 addTreeExpansionListener() 添加到此 JTree 的所有 TreeExpansionListener 的数组。
getTreeFloppyDriveIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeHardDriveIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeLeafIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getTreeLock() - 类 java.awt.Component 中的方法
获取此组件用于 AWT 组件树和布局操作的锁定对象（拥有线程同步监视器的对象）。
getTreeLock() - 类 java.awt.MenuComponent 中的方法
获取此组件的锁定对象（拥有该线程同步监视器的对象），该对象可用于 AWT 组件树和布局操作。
getTreeModelListeners() - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回在此模型上注册的所有树模型侦听器组成的数组。
getTreePath() - 类 javax.swing.event.TreeModelEvent 中的方法
对于除 treeStructureChanged 以外的所有事件，返回已更改节点的父节点。
getTreeSelectionListeners() - 类 javax.swing.JTree 中的方法
返回使用 addTreeSelectionListener() 添加到此 JTree 的所有 TreeSelectionListener 的数组。
getTreeSelectionListeners() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回已在此模型上注册的所有树选择侦听器组成的数组。
getTreeWillExpandListeners() - 类 javax.swing.JTree 中的方法
返回使用 addTreeWillExpandListener() 添加到此 JTree 的所有 TreeWillExpandListener 的数组。
getTrigger() - 类 java.awt.dnd.DragSourceContext 中的方法
返回最初触发该拖动的 DragGestureEvent。
getTrigger() - 类 javax.management.monitor.MonitorNotification 中的方法
获取触发此监视器通知的阈值/字符串（取决于监视器类型）。
getTriggerEvent() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回触发动作的初始事件。
getTriggerEvent() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法返回发起 Drag 和 Drop 操作的系列事件中的首个事件。
getTrustAnchor() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回描述作为证书路径受信定位点的 CA 的 TrustAnchor。
getTrustAnchors() - 类 java.security.cert.PKIXParameters 中的方法
返回不可变的、最受信任的 CA Set。
getTrustedCert() - 类 java.security.cert.TrustAnchor 中的方法
返回最受信任的 CA 证书。
getTrustedCertificate() - 类 java.security.KeyStore.TrustedCertificateEntry 中的方法
从此项获取可信 Certficate。
getTrustManagers() - 类 javax.net.ssl.TrustManagerFactory 中的方法
为每种信任材料返回一个信任管理器。
getTTL() - 类 java.net.DatagramSocketImpl 中的方法
已过时。 使用 getTimeToLive 代替。
getTTL() - 类 java.net.MulticastSocket 中的方法
已过时。 使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。
getType() - 类 java.awt.color.ColorSpace 中的方法
返回此 ColorSpace 的颜色空间类型（例如 TYPE_RGB、TYPE_XYZ……）。
getType() - 类 java.awt.Cursor 中的方法
返回此光标的类型。
getType() - 类 java.awt.font.GlyphMetrics 中的方法
返回原始字形类型代码。
getType() - 类 java.awt.geom.AffineTransform 中的方法
检索描述此变换的变换属性的标志位。
getType() - 类 java.awt.GraphicsDevice 中的方法
返回此 GraphicsDevice 的类型。
getType() - 类 java.awt.image.BufferedImage 中的方法
返回图像类型。
getType() - 类 java.io.ObjectStreamField 中的方法
获取字段的类型。
getType(char) - 类 java.lang.Character 中的静态方法
返回一个指示字符的常规类别的值。
getType(int) - 类 java.lang.Character 中的静态方法
返回一个指示字符的常规类别的值。
getType() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回此内存池的类型。
getType() - 类 java.lang.reflect.Field 中的方法
返回一个 Class 对象，它标识了此 Field 对象所表示字段的声明类型。
getType() - 类 java.security.cert.Certificate 中的方法
返回此证书的类型。
getType() - 类 java.security.cert.CertificateFactory 中的方法
返回与此 CertificateFactory 关联的证书类型的名称。
getType() - 类 java.security.cert.CertPath 中的方法
返回此证书路径中的 Certificate 类型。
getType() - 类 java.security.cert.CertStore 中的方法
返回此 CertStore 的类型。
getType() - 类 java.security.cert.CRL 中的方法
返回此 CRL 的类型。
getType() - 类 java.security.KeyStore 中的方法
返回此 keystore 的类型。
getType() - 类 java.security.Policy 中的方法
返回此 Policy 的类型。
getType() - 类 java.security.Provider.Service 中的方法
获取此服务的类型。
getType() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象的类型。
getType() - 接口 javax.accessibility.AccessibleTableModelChange 中的方法
返回事件的类型
getType() - 类 javax.management.MBeanAttributeInfo 中的方法
返回该属性的类名。
getType() - 类 javax.management.MBeanParameterInfo 中的方法
返回该数据的类型或类名。
getType() - 类 javax.management.Notification 中的方法
获得通知类型。
getType(String) - 类 javax.management.openmbean.CompositeType 中的方法
返回名称是 itemName 的项的开放类型，如果 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。
getType() - 类 javax.naming.event.NamingEvent 中的方法
返回此事件的类型。
getType() - 类 javax.naming.ldap.Rdn 中的方法
检索一个此 Rdn 的类型。
getType() - 类 javax.naming.RefAddr 中的方法
检索此地址的地址类型。
getType() - 类 javax.security.auth.login.Configuration 中的方法
返回此 Configuration 的类型。
getType() - 类 javax.sound.midi.MetaMessage 中的方法
获得 MetaMessage 的类型。
getType() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得 MIDI 文件类型。
getType() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得音频文件类型，如 WAVE 或 AU。
getType() - 类 javax.sound.sampled.Control 中的方法
获得控件的类型。
getType() - 类 javax.sound.sampled.LineEvent 中的方法
获得事件的类型。
getType() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回此 RowSet 对象的类型。
getType() - 接口 javax.swing.event.DocumentEvent 中的方法
获得事件类型。
getType() - 类 javax.swing.event.ListDataEvent 中的方法
返回事件类型。
getType() - 类 javax.swing.event.RowSorterEvent 中的方法
返回事件的类型。
getType() - 类 javax.swing.event.TableModelEvent 中的方法
返回事件类型，该类型为以下类型之一：INSERT、UPDATE 和 DELETE。
getType() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的方法

getType() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
返回事件的类型。
getType() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
获得元素类型。
getType() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getType() - 类 javax.swing.text.html.parser.Element 中的方法
获取类型。
getType() - 类 javax.swing.text.html.parser.Entity 中的方法
获取实体的类型。
getType() - 接口 javax.xml.crypto.URIReference 中的方法
返回通过此 URI 引用的数据类型。
getType() - 接口 org.w3c.dom.DOMError 中的方法
DOMString，指示在 relatedData 中哪个相关数据是所期望的。
getType() - 接口 org.w3c.dom.events.Event 中的方法
事件的名称（不区分大小写）。
getType(int) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回列表中属性的类型（根据位置）。
getType(String) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回列表中属性的类型（根据名称）。
getType(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的类型。
getType(String, String) - 接口 org.xml.sax.Attributes 中的方法
根据名称空间的名称查找属性的类型。
getType(String) - 接口 org.xml.sax.Attributes 中的方法
通过 XML 限定（前缀）名查找属性的类型。
getType(int) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性的类型（按位置）。
getType(String) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性的类型（按名称）。
getType(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过索引返回属性的类型。
getType(String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定名称空间的名称查找属性的类型。
getType(String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定（加前缀的）名称查找属性的类型。
getTypeArguments() - 接口 javax.lang.model.type.DeclaredType 中的方法
返回此类型的实际类型参数。
getTypeCode() - 类 java.io.ObjectStreamField 中的方法
返回字段类型的字符编码。
getTypeDescription(File) - 类 javax.swing.filechooser.FileView 中的方法
文件类型的可读描述。
getTypeDescription(File) - 类 javax.swing.JFileChooser 中的方法
返回文件类型。
getTypeDescription(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法

getTypeElement(CharSequence) - 接口 javax.lang.model.util.Elements 中的方法
返回已给出其规范名称的类型元素。
getTypeInfo() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库支持的所有数据类型的描述。
getTypeInfoProvider() - 类 javax.xml.validation.ValidatorHandler 中的方法
获取此 ValidatorHandler 的 TypeInfoProvider 实现。
getTypeMap() - 接口 java.sql.Connection 中的方法
获取与此 Connection 对象关联的 Map 对象。
getTypeMap() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。
getTypeMap() - 接口 javax.sql.RowSet 中的方法
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。
getTypeMirror() - 异常 javax.lang.model.type.MirroredTypeException 中的方法
返回对应于要访问类型的类型镜像。
getTypeMirrors() - 异常 javax.lang.model.type.MirroredTypesException 中的方法
返回对应于要访问的类型的类型镜像。
getTypeName() - 类 javax.management.openmbean.OpenType 中的方法
返回此 OpenType 实例的名称。
getTypeName() - 接口 org.w3c.dom.TypeInfo 中的方法
为相关元素或属性声明的类型的名称；如果未知，则为 null。
getTypeNamespace() - 接口 org.w3c.dom.TypeInfo 中的方法
为相关元素或属性声明的类型的名称空间；如果该元素没有声明或如果没有名称空间信息可用，则为 null。
getTypeParameters() - 类 java.lang.Class 中的方法
按声明顺序返回 TypeVariable 对象的一个数组，这些对象表示用此 GenericDeclaration 对象所表示的常规声明来声明的类型变量。
getTypeParameters() - 类 java.lang.reflect.Constructor 中的方法
按照声明顺序返回一组 TypeVariable 对象，这些对象表示通过此 GenericDeclaration 对象所表示的一般声明来声明的类型变量。
getTypeParameters() - 接口 java.lang.reflect.GenericDeclaration 中的方法
返回声明顺序的 TypeVariable 对象的数组，这些对象表示由此 GenericDeclaration 对象表示的一般声明声明的类型变量。
getTypeParameters() - 类 java.lang.reflect.Method 中的方法
返回 TypeVariable 对象的数组，这些对象描述了由 GenericDeclaration 对象表示的一般声明按声明顺序来声明的类型变量。
getTypeParameters() - 接口 javax.lang.model.element.ExecutableElement 中的方法
按照声明顺序返回此 executable 的形式类型参数。
getTypeParameters() - 接口 javax.lang.model.element.TypeElement 中的方法
按照声明顺序返回此类型元素的形式类型参数。
getTypeString() - 类 java.io.ObjectStreamField 中的方法
返回 JVM 类型签名。
getTypeUtils() - 接口 javax.annotation.processing.ProcessingEnvironment 中的方法
返回用来在类型上进行操作的某些实用工具方法的实现。
getTypeVariables() - 接口 javax.lang.model.type.ExecutableType 中的方法
返回由此 executable 的形式类型参数所声明的类型变量。
getUDTs(String, String, String, int[]) - 接口 java.sql.DatabaseMetaData 中的方法
获取在特定模式中定义的用户定义类型 (UDT) 的描述。
getUI(int, String) - 类 javax.print.ServiceUIFactory 中的方法
获得一个 UI 对象，它可能被应用程序强制转换为所请求的 UI 类型并在该应用程序的用户界面中使用。
getUI() - 类 javax.swing.AbstractButton 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JColorChooser 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JComboBox 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JDesktopPane 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JFileChooser 中的方法
获得实现此组件 L&F 的 UI 对象。
getUI() - 类 javax.swing.JInternalFrame 中的方法
返回呈现此组件的外观对象。
getUI() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
返回呈现此组件的外观对象。
getUI() - 类 javax.swing.JLabel 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JList 中的方法
返回呈现此组件的外观对象 ListUI。
getUI() - 类 javax.swing.JMenuBar 中的方法
返回菜单栏的当前 UI。
getUI() - 类 javax.swing.JOptionPane 中的方法
返回实现此组件 L&F 的 UI 对象。
getUI() - 类 javax.swing.JPanel 中的方法
返回呈现此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.JPopupMenu 中的方法
返回用于呈现此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.JProgressBar 中的方法
返回呈现此组件的外观对象。
getUI() - 类 javax.swing.JRootPane 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JScrollBar 中的方法
返回实现此组件的外观的委托。
getUI() - 类 javax.swing.JScrollPane 中的方法
返回呈现此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.JSeparator 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JSlider 中的方法
获取实现此组件 L&F 的 UI 对象。
getUI() - 类 javax.swing.JSpinner 中的方法
返回呈现此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.JSplitPane 中的方法
返回提供当前外观的 SplitPaneUI。
getUI() - 类 javax.swing.JTabbedPane 中的方法
返回实现此组件的 L&F 的 UI 对象。
getUI() - 类 javax.swing.JTable 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JToolBar 中的方法
返回工具栏的当前 UI。
getUI() - 类 javax.swing.JToolTip 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JTree 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.JViewport 中的方法
返回呈现此组件的 L&F 对象。
getUI() - 类 javax.swing.table.JTableHeader 中的方法
返回渲染此组件的外观 (L&F) 对象。
getUI() - 类 javax.swing.text.JTextComponent 中的方法
获取此面向文本的编辑器的用户界面工厂。
getUI(JComponent) - 类 javax.swing.UIDefaults 中的方法
创建一个指定组件的 ComponentUI 实现。
getUI(JComponent) - 类 javax.swing.UIManager 中的静态方法
返回 target 的适当 ComponentUI 实现。
getUIActionMap(JComponent) - 类 javax.swing.SwingUtilities 中的静态方法
返回该 UI 在组件 component 中提供的 ActionMap。
getUIClass(String, ClassLoader) - 类 javax.swing.UIDefaults 中的方法
get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。
getUIClass(String) - 类 javax.swing.UIDefaults 中的方法
返回呈现此组件的 L&F 类。
getUIClassID() - 类 javax.swing.JButton 中的方法
返回指定呈现此组件的 L&F 类名的字符串。
getUIClassID() - 类 javax.swing.JCheckBox 中的方法
返回指定呈现此组件的 L&F 类名的字符串。
getUIClassID() - 类 javax.swing.JCheckBoxMenuItem 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JColorChooser 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JComboBox 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JComponent 中的方法
返回用于查找 wing.plaf.ComponentUI 类（定义了此组件的外观）名的 UIDefaults 键。
getUIClassID() - 类 javax.swing.JDesktopPane 中的方法
返回呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JEditorPane 中的方法
获得该 UI 的类 ID。
getUIClassID() - 类 javax.swing.JFileChooser 中的方法
返回一个指示 L&F 类名的字符串，该类负责呈现此组件。
getUIClassID() - 类 javax.swing.JFormattedTextField 中的方法
获得 UI 的类 ID。
getUIClassID() - 类 javax.swing.JInternalFrame 中的方法
返回呈现此组件的外观类名。
getUIClassID() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
返回呈现此组件的外观类名。
getUIClassID() - 类 javax.swing.JLabel 中的方法
返回一个指定 L&F 类名称的字符串，该类呈现此组件。
getUIClassID() - 类 javax.swing.JList 中的方法
返回 "ListUI"，它是用于查找定义此组件外观的 javax.swing.plaf.ListUI 类名称的 UIDefaults 键。
getUIClassID() - 类 javax.swing.JMenu 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JMenuBar 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JMenuItem 中的方法
返回用于构造呈现此组件时使用的 L&F 类名称的后缀。
getUIClassID() - 类 javax.swing.JOptionPane 中的方法
返回实现此组件 L&F 的 UI 类的名称。
getUIClassID() - 类 javax.swing.JPanel 中的方法
返回指定呈现此组件的 L&F 类名的字符串。
getUIClassID() - 类 javax.swing.JPasswordField 中的方法
返回呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JPopupMenu 中的方法
返回用于呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JPopupMenu.Separator 中的方法
返回呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JProgressBar 中的方法
返回呈现此组件的外观类的名称。
getUIClassID() - 类 javax.swing.JRadioButton 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JRadioButtonMenuItem 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JRootPane 中的方法
返回一个指定呈现此组件的 L&F 类名称的字符串。
getUIClassID() - 类 javax.swing.JScrollBar 中的方法
返回此组件的 LookAndFeel 类的名称。
getUIClassID() - 类 javax.swing.JScrollPane 中的方法
返回用于构造呈现此组件时所用 L&F 类的名称的后缀。
getUIClassID() - 类 javax.swing.JSeparator 中的方法
返回呈现此组件的 L&F 的类名。
getUIClassID() - 类 javax.swing.JSlider 中的方法
返回呈现此组件的 L&F 的类名。
getUIClassID() - 类 javax.swing.JSpinner 中的方法
返回用于构造呈现此组件外观 (L&F) 类的名称的后缀。
getUIClassID() - 类 javax.swing.JSplitPane 中的方法
返回呈现此组件的 L&F 类名。
getUIClassID() - 类 javax.swing.JTabbedPane 中的方法
返回实现此组件的 L&F 的 UI 类的名称。
getUIClassID() - 类 javax.swing.JTable 中的方法
返回用于构造呈现此组件时所用 L&F 类名称的后缀。
getUIClassID() - 类 javax.swing.JTextArea 中的方法
返回 UI 的类 ID。
getUIClassID() - 类 javax.swing.JTextField 中的方法
获取 UI 的类 ID。
getUIClassID() - 类 javax.swing.JTextPane 中的方法
返回 UI 的类 ID。
getUIClassID() - 类 javax.swing.JToggleButton 中的方法
返回指定了 l&f 类名称的字符串，其中 l&f 类呈现此组件。
getUIClassID() - 类 javax.swing.JToolBar 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JToolBar.Separator 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JToolTip 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JTree 中的方法
返回呈现此组件的 L&F 类的名称。
getUIClassID() - 类 javax.swing.JViewport 中的方法
返回指定呈现此组件的 L&F 类名称的字符串。
getUIClassID() - 类 javax.swing.table.JTableHeader 中的方法
返回用于构造外观 (L&F) 类名称的后缀，该类用于渲染此组件。
getUIClassNamesForRole(int) - 类 javax.print.ServiceUIFactory 中的方法
给定从此工厂获取的 UI 角色，获取实现此角色的此工厂可提供的 UI 类型。
getUIError(String) - 类 javax.swing.UIDefaults 中的方法
如果由于某种原因导致 getUI() 失败，则它会在返回 null 之前调用此方法。
getUIInputMap(JComponent, int) - 类 javax.swing.SwingUtilities 中的静态方法
返回由组件 component 中的条件 condition 的 UI 提供的 InputMap。
getUIs() - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiListUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUIs() - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
返回与此多路 UI 关联的 UI 列表。
getUncaughtExceptionHandler() - 类 java.lang.Thread 中的方法
返回该线程由于未捕获到异常而突然终止时调用的处理程序。
getUndeclaredThrowable() - 异常 java.lang.reflect.UndeclaredThrowableException 中的方法
返回此 UndeclaredThrowableException 中包装的 Throwable 实例，它可能为 null。
getUnderlineOffset() - 类 java.awt.font.LineMetrics 中的方法
返回下划线相对于基线的位置。
getUnderlineThickness() - 类 java.awt.font.LineMetrics 中的方法
返回下划线的宽度。
getUndoableEditListeners() - 类 javax.swing.text.AbstractDocument 中的方法
返回在此文档上注册的所有可撤消编辑侦听器的数组。
getUndoableEditListeners() - 类 javax.swing.undo.UndoableEditSupport 中的方法
返回使用 addUndoableEditListener() 添加到此 UndoableEditSupport 中的所有 UndoableEditListener 组成的数组。
getUndoOrRedoPresentationName() - 类 javax.swing.undo.UndoManager 中的方法
一个便捷方法，它返回 getUndoPresentationName 或 getRedoPresentationName。
getUndoPresentationName() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
提供此次编辑可撤消形式的、已本地化的、可读的描述，例如，用作 Undo 菜单项。
getUndoPresentationName() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
检索默认表中 AbstractUndoableEdit.undoText 键的值，并返回该值，后跟一个空格和 getPresentationName。
getUndoPresentationName() - 类 javax.swing.undo.CompoundEdit 中的方法
从添加到 edits 的最后 UndoableEdit 返回 getUndoPresentationName。
getUndoPresentationName() - 接口 javax.swing.undo.UndoableEdit 中的方法
返回此编辑可撤消形式的本地化可读描述，例如，适于用作 “Undo” 菜单项。
getUndoPresentationName() - 类 javax.swing.undo.UndoManager 中的方法
返回此编辑可撤消形式的描述。
getUnexecutedModifications() - 异常 javax.naming.directory.AttributeModificationException 中的方法
检索未执行修改的列表。
getUnicodeStream(int) - 接口 java.sql.ResultSet 中的方法
已过时。 使用 getCharacterStream 取代 getUnicodeStream
getUnicodeStream(String) - 接口 java.sql.ResultSet 中的方法
已过时。 使用 getCharacterStream 代替
getUnitIncrement() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的单位值增量。
getUnitIncrement() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的单位增量。
getUnitIncrement() - 类 java.awt.ScrollPaneAdjustable 中的方法

getUnitIncrement(int) - 类 javax.swing.JScrollBar 中的方法
针对一个向上/向下滚动一个单位的请求，返回滚动条值的更改量。
getUnitIncrement() - 类 javax.swing.JScrollBar 中的方法
供与 java.awt.Scrollbar 向后兼容。
getUnitIncrement(int) - 类 javax.swing.JScrollPane.ScrollBar 中的方法
如果视口中的视图为 Scrollable 对象，将计算滚动的单位增量值。
getUnits() - 类 javax.sound.sampled.FloatControl 中的方法
获得表示控件值的单位标签，如 "dB" 或 "frames per second"。
getUnitsToScroll() - 类 java.awt.event.MouseWheelEvent 中的方法
这是帮助实现常用 MouseWheelListener 的便捷方法，以使 ScrollPane 或 JScrollPane 的滚动量符合平台的设置。
getUnknownAnnotationValue() - 异常 javax.lang.model.element.UnknownAnnotationValueException 中的方法
返回未知注释值。
getUnknownElement() - 异常 javax.lang.model.element.UnknownElementException 中的方法
返回未知元素。
getUnknownType() - 异常 javax.lang.model.type.UnknownTypeException 中的方法
返回未知类型。
getUnloadedClassCount() - 接口 java.lang.management.ClassLoadingMXBean 中的方法
返回自 Java 虚拟机开始执行到目前已经卸载的类的总数。
getUnmarshallerHandler() - 接口 javax.xml.bind.Unmarshaller 中的方法
获取可用作 XML 管线中的组件的 unmarshaller 处理程序对象。
getUnnormalizedComponents(float[], int, int[], int) - 类 java.awt.image.ColorModel 中的方法
在已给定标准化分量数组的情况下，返回以非标准化形式存在的所有颜色/alpha 分量的数组。
getUnnormalizedComponents(float[], int, int[], int) - 类 java.awt.image.ComponentColorModel 中的方法
在已给定标准化分量数组的情况下，返回以非标准化形式存在的所有颜色/alpha 分量的数组。
getUnresolvedActions() - 类 java.security.UnresolvedPermission 中的方法
获取尚未解析的基础权限的操作。
getUnresolvedCerts() - 类 java.security.UnresolvedPermission 中的方法
获取尚未解析的基础权限的签署者证书（无任何支持链）。
getUnresolvedName() - 类 java.security.UnresolvedPermission 中的方法
获取尚未解析的基础权限的目标名称。
getUnresolvedType() - 类 java.security.UnresolvedPermission 中的方法
获取尚未解析的基础权限的类型（类名称）。
getUnsupportedAttributes() - 接口 javax.print.AttributeException 中的方法
返回其 PrintService 实例根本不支持该属性的打印属性类数组，如果没有这种属性，则返回 null。
getUnsupportedAttributes(DocFlavor, AttributeSet) - 接口 javax.print.PrintService 中的方法
标识在特定 DocFlavor 的上下文中打印请求不支持的属性。
getUnsupportedFlavors() - 接口 javax.print.FlavorException 中的方法
返回不受支持的 flavor。
getUnsupportedURI() - 接口 javax.print.URIException 中的方法
返回 URI。
getUnsupportedValues() - 接口 javax.print.AttributeException 中的方法
返回其 PrintService 实例支持该属性，但是不支持该属性特定值的打印属性数组，如果没有这种属性值，则返回 null。
getUpdateAction() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法

getUpdateCount() - 接口 java.sql.Statement 中的方法
以更新计数的形式获取当前结果；如果结果为 ResultSet 对象或没有更多结果，则返回 -1。
getUpdateCounts() - 异常 java.sql.BatchUpdateException 中的方法
获取发生此异常前批量更新中成功执行的每个更新语句的更新计数。
getUpdateLevel() - 类 javax.swing.undo.UndoableEditSupport 中的方法
返回更新级别值。
getUpdatePeriod() - 类 javax.sound.sampled.FloatControl 中的方法
获得最小时间间隔（以微秒为单位），在此段时间内，控件值可以在移动期间更改。
getUpdatePolicy() - 类 javax.swing.text.DefaultCaret 中的方法
获取文档更新时的插入符移动策略。
getUpdateRect() - 类 java.awt.event.PaintEvent 中的方法
返回表示需要重绘区域以响应此事件的矩形。
getUpdateSelectionOnSort() - 类 javax.swing.JTable 中的方法
如果排序后应该更新选择，则返回 true。
getUpdateTableInRealTime() - 类 javax.swing.table.JTableHeader 中的方法
从 Java 2 platform v1.3 开始已过时。
getUpperBound() - 接口 javax.lang.model.type.TypeVariable 中的方法
返回此类型变量的上边界。
getUpperBounds() - 接口 java.lang.reflect.WildcardType 中的方法
返回表示此类型变量上边界的 Type 对象的数组。
getUptime() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机的正常运行时间（以毫秒为单位）。
getURI() - 类 java.security.URIParameter 中的方法
返回 URI。
getURI() - 类 javax.print.attribute.URISyntax 中的方法
返回此 URI 属性的 URI 值。
getURI() - 接口 javax.xml.crypto.dsig.keyinfo.RetrievalMethod 中的方法
返回已引用的 KeyInfo 信息的 URI。
getURI() - 类 javax.xml.crypto.OctetStreamData 中的方法
返回用来标识由此 OctetStreamData 表示的数据对象的 URI String。
getURI() - 接口 javax.xml.crypto.URIReference 中的方法
返回所引用数据对象的 URI。
getURI() - 接口 javax.xml.soap.Name 中的方法
返回此 Name 对象表示的 XML 名称命名空间的 URI。
getUri() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的 URI；如果没有可用的 URI，则为 null。
getURI(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的名称空间 URI。
getURI(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
返回属性的名称空间 URI。
getURI(String) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
查找前缀，并获取当前映射的名称空间 URI。
getURIDereferencer() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法

getURIDereferencer() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
返回对 URIDereferencer 的引用，默认情况下用于取消引用 RetrievalMethod 对象中的 URI。
getURIDereferencer() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
返回对 URIDereferencer 的引用，默认情况下该引用用于取消 Reference 对象中对 URI 的引用。
getURIDereferencer() - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
返回用来取消引用 URIReference 的 URIDereferencer。
getURIReference() - 异常 javax.xml.crypto.URIReferenceException 中的方法
返回抛出异常时正被取消引用的 URIReference。
getURIResolver() - 类 javax.xml.transform.Transformer 中的方法
获取将用于解析在 document() 中使用的 URI 的对象。
getURIResolver() - 类 javax.xml.transform.TransformerFactory 中的方法
获取在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。
getURIs() - 接口 java.net.CookieStore 中的方法
获取所有标识此 cookie 存储区中 cookie 的 URI。
getURL() - 类 java.net.URLConnection 中的方法
返回此 URLConnection 的 URL 字段的值。
getURL(int) - 接口 java.sql.CallableStatement 中的方法
以 java.sql.URL 对象的形式获取指定 JDBC DATALINK 参数的值。
getURL(String) - 接口 java.sql.CallableStatement 中的方法
以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。
getURL() - 接口 java.sql.DatabaseMetaData 中的方法
获取此 DBMS 的 URL。
getURL(int) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getURL(String) - 接口 java.sql.ResultSet 中的方法
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
getURL() - 类 javax.activation.URLDataSource 中的方法
返回用于创建此 DataSource 的 URL。
getUrl() - 类 javax.sql.rowset.BaseRowSet 中的方法
获取此 RowSet 对象的 javax.sql.Reader 对象用来建立与关系数据库连接（使用启用 JDBC 技术的驱动程序）的 JDBC URL。
getUrl() - 接口 javax.sql.RowSet 中的方法
如果此 RowSet 对象使用 DriverManager 而非 DataSource 对象建立连接，则获取创建连接时将使用的 url 属性。
getURL() - 类 javax.swing.event.HyperlinkEvent 中的方法
获得链接引用的 URL。
getURL() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法

getURL() - 接口 javax.xml.bind.ValidationEventLocator 中的方法
返回 URL 形式的 XML 源名称（如果可用）。
getURLContext(String, Hashtable<?, ?>) - 类 javax.naming.spi.NamingManager 中的静态方法
为给定的 URL 方案 id 创建一个上下文。
getURLOrDefaultInitCtx(String) - 类 javax.naming.InitialContext 中的方法
获取用来解析字符串名称 name 的上下文。
getURLOrDefaultInitCtx(Name) - 类 javax.naming.InitialContext 中的方法
获取用来解析 name 的上下文。
getURLPath() - 类 javax.management.remote.JMXServiceURL 中的方法
Service URL 的 URL Path 部分。
getURLs() - 类 java.net.URLClassLoader 中的方法
返回用于加载类和资源的 URL 搜索路径。
getURLs() - 类 javax.management.loading.MLet 中的方法
返回用于加载类和资源的 URL 搜索路径。
getURLs() - 接口 javax.management.loading.MLetMBean 中的方法
返回用于加载类和资源的 URL 搜索路径。
getUsableSpace() - 类 java.io.File 中的方法
返回此抽象路径名指定的分区上可用于此虚拟机的字节数。
getUsage() - 类 java.lang.management.MemoryNotificationInfo 中的方法
返回构造此通知时内存池的内存使用量。
getUsage() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回此内存池的内存使用量的估计数。
getUsage() - 接口 org.ietf.jgss.GSSCredential 中的方法
返回凭据使用模式。
getUsage(Oid) - 接口 org.ietf.jgss.GSSCredential 中的方法
返回特定机制的凭据使用模式。
getUsageThreshold() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回此内存池的使用量阈值（以字节为单位）。
getUsageThresholdCount() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
返回内存使用量超过其阈值的次数。
getUseCache() - 类 javax.imageio.ImageIO 中的静态方法
返回由 setUseCache 设置的当前值；如果没有显式设置该值，则返回 true。
getUseCaches() - 类 java.net.URLConnection 中的方法
返回此 URLConnection 的 useCaches 字段的值。
getUseClientMode() - 类 javax.net.ssl.SSLEngine 中的方法
如果引擎设置为在握手时使用客户端模式，则返回 true。
getUseClientMode() - 类 javax.net.ssl.SSLServerSocket 中的方法
如果接受的连接处于 SSL 客户端模式，则返回 true。
getUseClientMode() - 类 javax.net.ssl.SSLSocket 中的方法
如果套接字设置为握手时使用客户机模式，则返回 true。
getUsed() - 类 java.lang.management.MemoryUsage 中的方法
返回已使用的内存量（以字节为单位）。
getUseParentHandlers() - 类 java.util.logging.Logger 中的方法
获知此 logger 是否将其输出发送到它的父 logger。
getUserAction() - 类 java.awt.dnd.DragSourceDragEvent 中的方法
此方法返回用户放置动作。
getUserData(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法

getUserData() - 类 javax.management.Notification 中的方法
获得用户数据。
getUserData(String) - 接口 org.w3c.dom.Node 中的方法
检索与此节点上的某个键相关联的对象。
getUserDropAction() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
当此 TransferSupport 表示一个放置操作时，返回其用户放置动作。
getUserInfo() - 类 java.net.URI 中的方法
返回此 URI 的已解码的用户信息组成部分。
getUserInfo() - 类 java.net.URL 中的方法
获取此 URL 的 userInfo 部分。
getUserName() - 类 java.awt.print.PrinterJob 中的方法
获取打印用户的名称。
getUserName() - 类 java.net.PasswordAuthentication 中的方法
返回用户名。
getUserName() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库的已知的用户名称。
getUsername() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回用于创建数据库连接的用户名。
getUsername() - 接口 javax.sql.RowSet 中的方法
获取用于创建此 RowSet 对象的数据库连接的用户名。
getUserObject() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回与此节点关联的 Object 值。
getUserObject() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回此节点的用户对象。
getUserObjectPath() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回从根到达此节点的路径。
getUserPrincipal() - 接口 javax.xml.ws.WebServiceContext 中的方法
返回标识当前正服务请求发送方的 Principal。
getUserTextColor() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的用户文本颜色。
getUserTextColor() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回用户文本颜色。
getUserTextFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回用户文本字体。
getUserTextFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的用户文本字体。
getUserTextFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回用户文本字体。
getUtf16Offset() - 接口 org.w3c.dom.DOMLocator 中的方法
此定位器指向的输入源中的 UTF-16 偏移量（如在 [Unicode] 和 [ISO/IEC 10646] 的 Amendment 1 中定义的那样）；如果不存在可用的 UTF-16 偏移量，则为 -1。
getVAdjustable() - 类 java.awt.ScrollPane 中的方法
返回表示垂直滚动条状态的 ScrollPaneAdjustable 对象。
getValidCharacters() - 类 javax.swing.text.MaskFormatter 中的方法
返回可以输入的有效字符。
getValidPixels() - 类 java.awt.image.IndexColorModel 中的方法
返回一个指示 colormap 中有效/无效像素的 BigInteger。
getValidPolicy() - 接口 java.security.cert.PolicyNode 中的方法
返回此节点所表示的有效策略。
getValue() - 接口 java.awt.Adjustable 中的方法
获取可调整对象的当前值。
getValue() - 类 java.awt.event.AdjustmentEvent 中的方法
返回调整事件中的当前值。
getValue() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的当前值。
getValue() - 类 java.awt.ScrollPaneAdjustable 中的方法

getValue() - 类 java.beans.Expression 中的方法
如果此实例的 value 属性尚未设置，则此方法利用这些参数，在此目标上动态查找具有指定 methodName 的方法，并调用该方法。
getValue(String) - 类 java.beans.FeatureDescriptor 中的方法
利用此特性检索指定属性。
getValue() - 接口 java.beans.PropertyEditor 中的方法
获取属性值。
getValue() - 类 java.beans.PropertyEditorSupport 中的方法
获得属性值。
getValue() - 类 java.net.HttpCookie 中的方法
返回 cookie 的值。
getValue() - 类 java.rmi.dgc.Lease 中的方法
返回租借期限。
getValue() - 类 java.text.Annotation 中的方法
返回属性值，可能为 null。
getValue() - 类 java.util.AbstractMap.SimpleEntry 中的方法
返回对应于此项的值。
getValue() - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
返回对应于此项的值。
getValue(String) - 类 java.util.jar.Attributes 中的方法
返回指定属性名称的值，如果未找到，则返回 null。
getValue(Attributes.Name) - 类 java.util.jar.Attributes 中的方法
返回指定的 Attributes.Name 的值，如果未找到，则返回 null。
getValue() - 接口 java.util.Map.Entry 中的方法
返回与此项对应的值。
getValue() - 类 java.util.zip.Adler32 中的方法
返回校验和值。
getValue() - 接口 java.util.zip.Checksum 中的方法
返回当前的校验和值。
getValue() - 类 java.util.zip.CRC32 中的方法
返回 CRC-32 值。
getValue() - 接口 javax.annotation.processing.Completion 中的方法
返回建议 completion 的文本。
getValue() - 类 javax.crypto.spec.PSource.PSpecified 中的方法
返回编码输入 P 的值。
getValue() - 接口 javax.lang.model.element.AnnotationValue 中的方法
返回值。
getValue() - 类 javax.management.Attribute 中的方法
返回此 Attribute 值的 Object。
getValue() - 类 javax.management.StringValueExp 中的方法
返回由 StringValueExp 实例表示的字符串。
getValue() - 类 javax.naming.ldap.Rdn 中的方法
检索一个此 Rdn 的值。
getValue(String) - 接口 javax.net.ssl.SSLSession 中的方法
返回会话的应用层数据中的绑定到给定名称的对象。
getValue() - 类 javax.print.attribute.DateTimeSyntax 中的方法
返回此日期-时间属性的 java.util.Date 值。
getValue() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的整数值。
getValue() - 类 javax.print.attribute.IntegerSyntax 中的方法
返回此整数属性的整数值。
getValue() - 类 javax.print.attribute.TextSyntax 中的方法
返回此文本属性的文本字符串。
getValue() - 类 javax.sound.sampled.BooleanControl 中的方法
获得此控件的当前值。
getValue() - 类 javax.sound.sampled.EnumControl 中的方法
获得此控件的当前值。
getValue() - 类 javax.sound.sampled.FloatControl 中的方法
获得此控件的当前值。
getValue(String) - 类 javax.swing.AbstractAction 中的方法
获得与指定键关联的 Object。
getValue(String) - 接口 javax.swing.Action 中的方法
使用关联的键获取此对象的一个属性。
getValue() - 接口 javax.swing.BoundedRangeModel 中的方法
返回模型的当前值。
getValue() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回模型的当前值。
getValue() - 类 javax.swing.JFormattedTextField 中的方法
返回最后一个有效值。
getValue() - 类 javax.swing.JOptionPane 中的方法
返回用户所选值。
getValue() - 类 javax.swing.JProgressBar 中的方法
从 BoundedRangeModel 返回进度条的当前 value。
getValue() - 类 javax.swing.JScrollBar 中的方法
返回滚动条的值。
getValue() - 类 javax.swing.JSlider 中的方法
从 BoundedRangeModel 返回滑块的当前值。
getValue() - 类 javax.swing.JSpinner 中的方法
返回模型的当前值，通常此值是 editor 所显示的值。
getValue(int) - 类 javax.swing.RowFilter.Entry 中的方法
返回指定索引处的值。
getValue() - 类 javax.swing.SpinnerDateModel 中的方法
返回此 Date 序列中的当前元素。
getValue() - 类 javax.swing.SpinnerListModel 中的方法
返回该序列的当前元素。
getValue() - 接口 javax.swing.SpinnerModel 中的方法
该序列的当前元素。
getValue() - 类 javax.swing.SpinnerNumberModel 中的方法
返回该序列的当前元素的值。
getValue() - 类 javax.swing.Spring 中的方法
返回此 Spring 的当前 value。
getValue() - 类 javax.swing.text.html.Option 中的方法
返回与 value 属性相关的字符串的便捷方法。
getValue() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getValue() - 类 javax.xml.bind.JAXBElement 中的方法
返回此元素的内容模式和属性值。
getValue(Object) - 类 javax.xml.bind.JAXBIntrospector 中的静态方法
获取 JAXB 元素的元素值。
getValue() - 接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue 中的方法
返回此 SignatureValue 的签名值。
getValue() - 类 javax.xml.soap.MimeHeader 中的方法
返回此 MimeHeader 对象的值。
getValue() - 接口 javax.xml.soap.Node 中的方法
如果这是一个 Text 节点，则返回此节点的值，否则返回此节点的直接子节点值。
getValue() - 接口 javax.xml.stream.events.Attribute 中的方法
获取此属性的标准化值。
getValue() - 接口 org.w3c.dom.Attr 中的方法
检索时，该属性值以字符串形式返回。
getValue(int) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回列表中属性的值（根据位置）。
getValue(String) - 接口 org.xml.sax.AttributeList 中的方法
已过时。 返回列表中属性的值（根据名称）。
getValue(int) - 接口 org.xml.sax.Attributes 中的方法
通过索引查找属性的值。
getValue(String, String) - 接口 org.xml.sax.Attributes 中的方法
根据名称空间的名称查找属性的值。
getValue(String) - 接口 org.xml.sax.Attributes 中的方法
通过 XML 限定（前缀）名查找属性的值。
getValue(int) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性的值（按位置）。
getValue(String) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 获取属性的值（按名称）。
getValue(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过索引返回属性的值。
getValue(String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定名称空间的名称查找属性的值。
getValue(String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
通过限定（加前缀的）名称查找属性的值。
getValueAt(int, int) - 类 javax.swing.DefaultRowSorter.ModelWrapper 中的方法
返回指定索引处的值。
getValueAt(int, int) - 类 javax.swing.JTable 中的方法
返回 row 和 column 位置的单元格值。
getValueAt(int, int) - 类 javax.swing.table.DefaultTableModel 中的方法
返回 row 和 column 处单元格的属性值。
getValueAt(int, int) - 接口 javax.swing.table.TableModel 中的方法
返回 columnIndex 和 rowIndex 位置的单元格值。
getValueClass() - 类 javax.swing.text.DefaultFormatter 中的方法
返回用于创建新 Objects 的类。
getValueContainsLiteralCharacters() - 类 javax.swing.text.MaskFormatter 中的方法
如果 stringToValue 应该返回掩码中的字面值，则返回 true。
getValueCount() - 类 javax.swing.RowFilter.Entry 中的方法
返回条目中值的数量。
getValueIsAdjusting() - 类 java.awt.event.AdjustmentEvent 中的方法
如果此事件是多个调整事件之一，则返回 true。
getValueIsAdjusting() - 类 java.awt.Scrollbar 中的方法
如果该值作为用户执行动作的结果正处于更改过程中，则返回 true。
getValueIsAdjusting() - 类 java.awt.ScrollPaneAdjustable 中的方法
当作为用户所采用操作的结果的值正处于更改过程中时，返回 true。
getValueIsAdjusting() - 接口 javax.swing.BoundedRangeModel 中的方法
如果 value 属性的当前更改是一系列更改的一部分，则返回 true。
getValueIsAdjusting() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
如果该值由于用户正执行操作而处于更改过程中，则返回 true。
getValueIsAdjusting() - 类 javax.swing.DefaultListSelectionModel 中的方法
如果选择在进行一系列更改，则返回 true。
getValueIsAdjusting() - 类 javax.swing.event.ListSelectionEvent 中的方法
返回此事件是否是仍然在更改的多个不同事件之一。
getValueIsAdjusting() - 类 javax.swing.JList 中的方法
返回选择模型的 isAdjusting 属性的值。
getValueIsAdjusting() - 类 javax.swing.JScrollBar 中的方法
如果滚动条滑块被拖动，则返回 True。
getValueIsAdjusting() - 类 javax.swing.JSlider 中的方法
从模型返回 valueIsAdjusting 属性。
getValueIsAdjusting() - 接口 javax.swing.ListSelectionModel 中的方法
如果选择在进行一系列更改，则返回 true。
getValueNames() - 接口 javax.net.ssl.SSLSession 中的方法
返回绑定到会话中的所有应用层数据对象的名称组成的数组。
getValues() - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的方法
返回 short 数组，该数组包含按其相应代码的长度递增排序的值。
getValues() - 类 javax.sound.sampled.EnumControl 中的方法
返回此控件的可能值的集合。
getValues() - 类 javax.swing.text.html.parser.AttributeList 中的方法

getVariant() - 类 java.util.Locale 中的方法
返回此语言环境的变量代码。
getVariation() - 类 java.awt.im.InputMethodHighlight 中的方法
返回文本范围的变量。
getVendor() - 类 javax.sound.midi.MidiDevice.Info 中的方法
获得提供设备的公司名称。
getVendor() - 接口 javax.sound.midi.Soundbank 中的方法
获得命名提供此音库的公司的 string
getVendor() - 类 javax.sound.sampled.Mixer.Info 中的方法
获得混频器的供应商。
getVendor() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回此 SyncProvider 实例的供应商名称
getVendorName() - 类 javax.imageio.spi.IIOServiceProvider 中的方法
返回负责创建此服务提供者及其相关实现的供应商名称。
getVerifyInputWhenFocusTarget() - 类 javax.swing.JComponent 中的方法
返回值指示是否在此组件请求焦点前，为当前的焦点所有者调用输入校验器。
getVersion() - 接口 java.awt.font.OpenType 中的方法
返回 OpenType 字体的版本。
getVersion() - 接口 java.lang.management.OperatingSystemMXBean 中的方法
返回操作系统的版本。
getVersion() - 类 java.net.HttpCookie 中的方法
返回此 cookie 遵守的协议版本。
getVersion() - 类 java.security.cert.X509Certificate 中的方法
获取证书的 version（版本号）值。
getVersion() - 类 java.security.cert.X509CRL 中的方法
获取 CRL 的 version（版本号）值。
getVersion() - 类 java.security.Provider 中的方法
返回此 provider 的版本号。
getVersion() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
返回版本。
getVersion() - 类 javax.imageio.spi.IIOServiceProvider 中的方法
返回描述此服务提供者版本号及其相关实现的字符串。
getVersion() - 类 javax.management.loading.MLetContent 中的方法
获取 MLET 标记的 VERSION 属性的值。
getVersion() - 接口 javax.management.remote.rmi.RMIServer 中的方法
此连接器服务器能识别的 RMI 连接协议版本。
getVersion() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法

getVersion() - 类 javax.management.remote.rmi.RMIServerImpl_Stub 中的方法

getVersion() - 类 javax.security.cert.X509Certificate 中的方法
获取证书的 version（版本号）值。
getVersion() - 类 javax.sound.midi.MidiDevice.Info 中的方法
获得设备的版本。
getVersion() - 接口 javax.sound.midi.Soundbank 中的方法
获得音库的版本字符串。
getVersion() - 类 javax.sound.sampled.Mixer.Info 中的方法
获得混频器的版本。
getVersion() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回此 SyncProvider 实例的发行版本。
getVersion() - 接口 javax.xml.stream.events.StartDocument 中的方法
返回此 XML 流的 XML 版本
getVersion() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法

getVersion() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取在 xml 声明中声明的 xml 版本，如果没有声明版本，则返回 null
getVersionColumns(String, String, String) - 接口 java.sql.DatabaseMetaData 中的方法
获取在更新行中的任意值时自动更新的表列的描述。
getVersionNumber() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回密钥版本号。
getVerticalAlignment() - 类 javax.swing.AbstractButton 中的方法
返回文本和图标的垂直对齐方式。
getVerticalAlignment() - 类 javax.swing.JLabel 中的方法
返回标签内容沿 Y 轴的对齐方式。
getVerticalLegBuffer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
默认情况下，节点间支路的垂直元素开始于父节点的底部。
getVerticalScrollBar() - 类 javax.swing.JScrollPane 中的方法
返回控制视口垂直视图位置的垂直滚动条。
getVerticalScrollBar() - 类 javax.swing.ScrollPaneLayout 中的方法
返回处理垂直滚动的 JScrollBar 对象。
getVerticalScrollBarPolicy() - 类 javax.swing.JScrollPane 中的方法
返回垂直滚动条策略值。
getVerticalScrollBarPolicy() - 类 javax.swing.ScrollPaneLayout 中的方法
返回垂直滚动条的显示策略。
getVerticalSliderThumbIcon() - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态方法

getVerticalTextPosition() - 类 javax.swing.AbstractButton 中的方法
返回文本相对于图标的垂直位置。
getVerticalTextPosition() - 类 javax.swing.JLabel 中的方法
返回标签的文本相对其图像的垂直位置。
getVetoableChangeListeners() - 类 java.awt.KeyboardFocusManager 中的方法
返回在此键盘焦点管理器上注册的所有可否决更改侦听器组成的数组。
getVetoableChangeListeners(String) - 类 java.awt.KeyboardFocusManager 中的方法
返回与指定属性相关联的所有 VetoableChangeListener 组成的数组。
getVetoableChangeListeners() - 类 java.beans.VetoableChangeSupport 中的方法
返回 VetoableChangeListener 的列表。
getVetoableChangeListeners(String) - 类 java.beans.VetoableChangeSupport 中的方法
返回与指定属性相关联的所有侦听器组成的数组。
getVetoableChangeListeners() - 类 javax.swing.JComponent 中的方法
返回在此组件上注册的所有可否决更改侦听器所组成的数组。
getVgap() - 类 java.awt.BorderLayout 中的方法
返回组件之间的垂直间距。
getVgap() - 类 java.awt.CardLayout 中的方法
获取组件之间的垂直间距。
getVgap() - 类 java.awt.FlowLayout 中的方法
获取组件之间以及组件与 Container 的边之间的垂直间隙。
getVgap() - 类 java.awt.GridLayout 中的方法
获取组件之间的垂直间距。
getView() - 类 javax.swing.JViewport 中的方法
返回 JViewport 的一个子对象或 null。
getView(int) - 类 javax.swing.text.AsyncBoxView 中的方法
获得第 n 个子视图。
getView(int) - 类 javax.swing.text.CompositeView 中的方法
返回该容器中的第 n 个视图。
getView(int) - 类 javax.swing.text.View 中的方法
获取第 n 个子视图。
getView() - 接口 org.w3c.dom.events.UIEvent 中的方法
view 属性标识生成事件的 AbstractView。
getViewAtPoint(int, int, Rectangle) - 类 javax.swing.text.BoxView 中的方法
获取给定坐标处的子视图。
getViewAtPoint(int, int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
获取位于给定坐标的子视图。
getViewAtPosition(int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
获取表示模型中给定位置的子视图。
getViewAtPosition(int, Rectangle) - 类 javax.swing.text.TableView 中的方法
获取表示模型中给定位置的子视图。
getViewAtPosition(int, Rectangle) - 类 javax.swing.text.TableView.TableRow 中的方法
获取表示模型中给定位置的子视图。
getViewAttributes(View) - 类 javax.swing.text.html.StyleSheet 中的方法
获取用来显示视图的属性集。
getViewCount() - 类 javax.swing.text.AsyncBoxView 中的方法
返回此视图中的视图数。
getViewCount() - 类 javax.swing.text.CompositeView 中的方法
返回此视图的子视图数。
getViewCount() - 类 javax.swing.text.View 中的方法
返回此视图中的视图数。
getViewFactory() - 类 javax.swing.text.DefaultEditorKit 中的方法
获取一个适合供由此包所产生的任何模型来产生视图的工厂。
getViewFactory() - 类 javax.swing.text.EditorKit 中的方法
获取适合生成此工具包生成的任何模型视图的工厂。
getViewFactory() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
获取一个适合供由此包所产生的任何模型来产生视图的工厂。
getViewFactory() - 类 javax.swing.text.StyledEditorKit 中的方法
获取一个适合供由此包所产生的任何模型来产生视图的工厂。
getViewFactory() - 类 javax.swing.text.View 中的方法
获取将提供给视图层次结构的 ViewFactory 实现。
getViewIndex(int, Position.Bias) - 类 javax.swing.text.AsyncBoxView 中的方法
返回该模型中表示给定位置的子视图索引。
getViewIndex(int, Position.Bias) - 类 javax.swing.text.CompositeView 中的方法
返回表示模型中给定位置的子视图索引。
getViewIndex(int, Position.Bias) - 类 javax.swing.text.View 中的方法
返回表示模型中给定位置的子视图索引。
getViewIndex(float, float, Shape) - 类 javax.swing.text.View 中的方法
返回表示视图中给定位置的子视图索引。
getViewIndexAtPoint(float, float, Shape) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
获取位于给定点的子视图索引。
getViewIndexAtPosition(int, Position.Bias) - 类 javax.swing.text.AsyncBoxView 中的方法
获取此模型中表示给定位置的子视图索引。
getViewIndexAtPosition(int) - 类 javax.swing.text.CompositeView 中的方法
获取表示模型中给定位置的子视图索引。
getViewIndexAtPosition(int) - 类 javax.swing.text.FlowView 中的方法
获取此模型中表示给定位置的子视图索引。
getViewIndexAtPosition(int) - 类 javax.swing.text.ZoneView 中的方法
返回表示模型中给定位置的子视图索引。
getViewIndexAtVisualOffset(float) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
查找负责表示沿主轴方向框中偏移量位置的视图。
getViewport() - 类 javax.swing.JScrollPane 中的方法
返回当前的 JViewport。
getViewport() - 类 javax.swing.ScrollPaneLayout 中的方法
返回显示滚动组件内容的 JViewport 对象。
getViewportBorder() - 类 javax.swing.JScrollPane 中的方法
返回围绕该视口的 Border 对象。
getViewportBorderBounds() - 类 javax.swing.JScrollPane 中的方法
返回视口边界的范围。
getViewportBorderBounds(JScrollPane) - 类 javax.swing.ScrollPaneLayout 中的方法
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
getViewportSize() - 类 java.awt.ScrollPane 中的方法
返回滚动条窗格视口的当前大小。
getViewPosition() - 类 javax.swing.JViewport 中的方法
返回显示在视口左上角的视图坐标，如果不存在视图，则返回（0,0）。
getViewRect() - 类 javax.swing.JViewport 中的方法
返回一个矩形，其原位置在 getViewPosition，大小为 getExtentSize。
getViewRowCount() - 类 javax.swing.DefaultRowSorter 中的方法
返回视图中的行数。
getViewRowCount() - 类 javax.swing.RowSorter 中的方法
返回视图中的行数。
getViewSize() - 类 javax.swing.JViewport 中的方法
如果未显式设置视图的大小，则返回首选大小，否则返回该视图的当前大小。
getVisible() - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 getVisibleAmount() 取代。
getVisibleAdvance() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的 advance，减去结尾空格。
getVisibleAmount() - 接口 java.awt.Adjustable 中的方法
获取比例指示器的长度。
getVisibleAmount() - 类 java.awt.Scrollbar 中的方法
获取此滚动条的可见量。
getVisibleAmount() - 类 java.awt.ScrollPaneAdjustable 中的方法

getVisibleAmount() - 类 javax.swing.JScrollBar 中的方法
返回滚动条的跨度，即它的 "visibleAmount"。
getVisibleChildCount(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回行的可视子节点数。
getVisibleChildCount(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回行的可见子对象数。
getVisibleChildCount(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回 path 的可见子路径数。
getVisibleComponent() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法

getVisibleEditorRect() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
获取给出根 View 的分配。
getVisibleIndex() - 类 java.awt.List 中的方法
获取上次由 makeVisible 方法使其可视的项的索引。
getVisibleNamespacePrefixes() - 接口 javax.xml.soap.SOAPElement 中的方法
返回在此元素可见的名称空间前缀 String 上进行迭代的 Iterator。
getVisiblePathsFrom(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。
getVisiblePathsFrom(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
返回表示从传入位置开始的可见路径的增量的 Enumerator。
getVisiblePathsFrom(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
返回从传入位置开始的可见路径的增量的 Enumerator。
getVisiblePosition() - 类 java.awt.event.InputMethodEvent 中的方法
获取对于可见性至关重要的位置。
getVisibleRect() - 类 javax.swing.JComponent 中的方法
返回该 Component 的“可见矩形”，即此组件的可见矩形 new Rectangle(0, 0, getWidth(), getHeight()) 及其所有祖先的可见矩形的交集。
getVisibleRowCount() - 类 javax.swing.JList 中的方法
返回 visibleRowCount 属性的值。
getVisibleRowCount() - 类 javax.swing.JTree 中的方法
返回显示区域中显示的行数。
getVisualBounds() - 类 java.awt.font.GlyphVector 中的方法
返回此 GlyphVector 的可视边界，可视边界是此 GlyphVector 轮廓的边界框。
getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。
getVisualHighlightShape(TextHitInfo, TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回封闭指定范围中扩展到指定边界的可视选择范围的 Shape。
getVisualOtherHit(TextHitInfo) - 类 java.awt.font.TextLayout 中的方法
返回位于指定目标字符插入符另一侧的目标字符。
getVisualRepresentation(Transferable) - 类 javax.swing.TransferHandler 中的方法
返回一个建立传输外观的对象。
getVMID() - 类 java.rmi.dgc.Lease 中的方法
返回与此 lease 关联的客户机 VMID。
getVmName() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机实现名称。
getVmVendor() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机实现供应商。
getVmVersion() - 接口 java.lang.management.RuntimeMXBean 中的方法
返回 Java 虚拟机实现版本。
getVoiceStatus() - 接口 javax.sound.midi.Synthesizer 中的方法
获得由此合成器生成的声音的当前状态。
getVolatileOffscreenBuffer(Component, int, int) - 类 javax.swing.RepaintManager 中的方法
返回可变屏幕外缓冲区，它应用作带有指定组件 c 的双缓冲区。
getVScrollbarWidth() - 类 java.awt.ScrollPane 中的方法
返回垂直滚动条占用的宽度，它与当前是否由滚动窗格显示无关。
getW() - 接口 java.security.interfaces.ECPublicKey 中的方法
返回公用点 W。
getW() - 类 java.security.spec.ECPublicKeySpec 中的方法
返回公用点 W。
getWaitedCount() - 类 java.lang.management.ThreadInfo 中的方法
返回与此 ThreadInfo 关联的线程等待通知的总次数。
getWaitedTime() - 类 java.lang.management.ThreadInfo 中的方法
返回自从启用线程争用监视以来,与此 ThreadInfo 关联的线程等待通知的近似累计时间（以毫秒为单位）。
getWaitingThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
返回一个 collection，该 collection 包含那些正在此条件等待的线程。
getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
getWaitingThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
返回包含那些可能正在等待此条件的线程 collection。
getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
getWaitingThreads(Condition) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。
getWaitingThreads(Condition) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
getWaitQueueLength() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
返回正在此条件等待的线程估计数。
getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回正在与此同步器关联的给定条件上等待的线程估计数。
getWaitQueueLength() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
返回正在等待此条件的线程数估计值。
getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回正在等待与此同步器有关的给定条件的线程数估计值。
getWaitQueueLength(Condition) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回等待与此锁相关的给定条件的线程估计数。
getWaitQueueLength(Condition) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回正等待与写入锁相关的给定条件的线程估计数目。
getWantClientAuth() - 类 javax.net.ssl.SSLEngine 中的方法
如果引擎请求 客户端验证，则返回 true。
getWantClientAuth() - 类 javax.net.ssl.SSLParameters 中的方法
返回是否应该请求客户机验证。
getWantClientAuth() - 类 javax.net.ssl.SSLServerSocket 中的方法
如果新接受的服务器模式的连接请求 客户端验证，则返回 true。
getWantClientAuth() - 类 javax.net.ssl.SSLSocket 中的方法
如果套接字请求 客户机验证，则返回 true。
getWantsInput() - 类 javax.swing.JOptionPane 中的方法
返回 wantsInput 属性的值。
getWarnings() - 接口 java.sql.Connection 中的方法
获取此 Connection 对象上的调用报告的第一个警告。
getWarnings() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象上的调用报告的第一个警告。
getWarnings() - 接口 java.sql.Statement 中的方法
获取此 Statement 对象上的调用报告的第一个警告。
getWarningString() - 类 java.awt.Window 中的方法
获取此窗口中显示的警告字符串。
getWarningString() - 类 javax.swing.JInternalFrame 中的方法
获取此内部窗体中显示的警告字符串。
getWeekdays() - 类 java.text.DateFormatSymbols 中的方法
获取星期字符串。
getWestPane() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法

getWhatToShow() - 接口 org.w3c.dom.ls.LSParserFilter 中的方法
告知 LSParser 将向方法 LSParserFilter.acceptNode 显示什么类型的节点。
getWhatToShow() - 接口 org.w3c.dom.ls.LSSerializerFilter 中的方法
告诉 LSSerializer 向过滤器显示什么类型的节点。
getWheelRotation() - 类 java.awt.event.MouseWheelEvent 中的方法
返回鼠标滚轮旋转的“喀哒声”的次数。
getWhen() - 类 java.awt.event.ActionEvent 中的方法
返回发生此事件时的时间戳。
getWhen() - 类 java.awt.event.InputEvent 中的方法
返回此事件发生时的时间戳。
getWhen() - 类 java.awt.event.InputMethodEvent 中的方法
返回此事件发生时的时间戳。
getWhen() - 类 java.awt.event.InvocationEvent 中的方法
返回此事件发生时的时间戳。
getWhereClause() - 接口 javax.sql.rowset.JoinRowSet 中的方法
返回在 JoinRowSet 对象中使用的 WHERE 子句的类似 SQL 的描述。
getWhite() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的白色。
getWhite() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回白色。
getWholeText() - 接口 org.w3c.dom.Text 中的方法
返回 Text 节点（逻辑上与此节点相邻的节点）的以文档顺序串接的所有文本。
getWidth() - 类 java.awt.Component 中的方法
返回组件的当前宽度。
getWidth() - 类 java.awt.Dimension 中的方法
返回此 Dimension 的宽度（以 double 精度表示）。
getWidth() - 类 java.awt.DisplayMode 中的方法
返回显示的宽度（以像素表示）。
getWidth() - 类 java.awt.geom.Arc2D.Double 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Arc2D.Float 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Dimension2D 中的方法
返回此 Dimension 的宽度（以 double 精度表示）。
getWidth() - 类 java.awt.geom.Ellipse2D.Double 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Ellipse2D.Float 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Rectangle2D.Double 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.Rectangle2D.Float 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
以 double 精度返回窗体矩形的宽度。
getWidth() - 类 java.awt.image.BufferedImage 中的方法
返回 BufferedImage 的宽度。
getWidth(ImageObserver) - 类 java.awt.image.BufferedImage 中的方法
返回 BufferedImage 的宽度。
getWidth(ImageObserver) - 类 java.awt.Image 中的方法
确定图像的宽度。
getWidth() - 类 java.awt.image.Kernel 中的方法
返回此 Kernel 的宽度。
getWidth() - 类 java.awt.image.PixelGrabber 中的方法
获取（调整图像宽度后的）像素缓冲区的宽度。
getWidth() - 类 java.awt.image.Raster 中的方法
返回 Raster 的像素宽度。
getWidth() - 接口 java.awt.image.renderable.RenderableImage 中的方法
获取用户坐标空间中的宽度。
getWidth() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
获取用户坐标空间中的宽度。
getWidth() - 接口 java.awt.image.RenderedImage 中的方法
返回 RenderedImage 的宽度。
getWidth() - 类 java.awt.image.SampleModel 中的方法
返回像素宽度。
getWidth() - 类 java.awt.image.VolatileImage 中的方法
返回 VolatileImage 的宽度。
getWidth() - 类 java.awt.print.PageFormat 中的方法
返回页面的宽度（以 1/72 英寸为单位）。
getWidth() - 类 java.awt.print.Paper 中的方法
返回页面的宽度（以 1/72 英寸为单位）。
getWidth() - 类 java.awt.Rectangle 中的方法
以 double 精度返回边界 Rectangle 的宽度。
getWidth() - 异常 java.util.IllegalFormatWidthException 中的方法
返回宽度。
getWidth(int) - 类 javax.imageio.ImageReader 中的方法
返回输入源中的给定图像的宽度，以像素为单位。
getWidth(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以指定单位获取可打印区域的 width。
getWidth() - 类 javax.swing.JComponent 中的方法
返回此组件的当前宽度。
getWidth() - 类 javax.swing.SpringLayout.Constraints 中的方法
返回 width 属性的值。
getWidth() - 类 javax.swing.table.TableColumn 中的方法
返回该 TableColumn 的宽度。
getWidth() - 类 javax.swing.text.BoxView 中的方法
返回框的当前宽度。
getWidthOfHighValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getWidthOfLowValueLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getWidthOfWidestLabel() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法

getWidths() - 类 java.awt.FontMetrics 中的方法
获取此 Font 中前 256 个字符的 advance width。
getWildcardType(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回新的通配符类型参数。
getWindingRule() - 类 java.awt.geom.FlatteningPathIterator 中的方法
返回用于确定路径迭代的旋绕规则。
getWindingRule() - 类 java.awt.geom.Path2D 中的方法
返回填充风格旋绕规则。
getWindingRule() - 接口 java.awt.geom.PathIterator 中的方法
返回用于确定路径迭代的旋绕规则。
getWindow() - 类 java.awt.event.WindowEvent 中的方法
返回事件的发起方。
getWindowAncestor(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
getWindowBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口背景颜色。
getWindowBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口背景色。
getWindowDecorationStyle() - 类 javax.swing.JRootPane 中的方法
返回一个常量，它标识 JRootPane 提供的 Window 装饰类型。
getWindowFocusListeners() - 类 java.awt.Window 中的方法
返回在此窗口注册的所有窗口焦点侦听器所组成的数组。
getWindowListeners() - 类 java.awt.Window 中的方法
返回在此窗口注册的所有窗口侦听器所组成的数组。
getWindows() - 类 java.awt.Window 中的静态方法
返回一个数组，该数组由此应用程序创建的所有 Window（包括被拥有的和不被拥有的）组成。
getWindowStateListeners() - 类 java.awt.Window 中的方法
返回在此窗口注册的所有窗口状态侦听器所组成的数组。
getWindowTitleBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题背景颜色。
getWindowTitleBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题背景色。
getWindowTitleFont() - 类 javax.swing.plaf.metal.DefaultMetalTheme 中的方法
返回窗口标题字体。
getWindowTitleFont() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题字体。
getWindowTitleFont() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题字体。
getWindowTitleForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题前景色。
getWindowTitleForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题前景色。
getWindowTitleInactiveBackground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题非活动背景颜色。
getWindowTitleInactiveBackground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题非活动背景色。
getWindowTitleInactiveForeground() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
返回当前主题的窗口标题非活动前景颜色。
getWindowTitleInactiveForeground() - 类 javax.swing.plaf.metal.MetalTheme 中的方法
返回窗口标题非活动前景色。
getWordEnd(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定针对给定位置的单词结尾。
getWordInstance() - 类 java.text.BreakIterator 中的静态方法
返回一个用于默认语言环境 单词分解的新 BreakIterator 实例。
getWordInstance(Locale) - 类 java.text.BreakIterator 中的静态方法
返回一个用于给定语言环境单词分解的新 BreakIterator 实例。
getWordInstance(Locale) - 类 java.text.spi.BreakIteratorProvider 中的方法
为给定语言环境的单词分解返回一个新 BreakIterator 实例。
getWordSize() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
返回以位为单位的 word 大小。
getWordStart(JTextComponent, int) - 类 javax.swing.text.Utilities 中的静态方法
确定针对给定模型位置的单词开头。
getWrapSizeLimit(int, boolean, int) - 接口 org.ietf.jgss.GSSContext 中的方法
用来确定可以传输给 wrap 的消息的大小限制。
getWrapStyleWord() - 类 javax.swing.JTextArea 中的方法
获取换行方式（如果文本区要换行）。
getWritableParent() - 类 java.awt.image.WritableRaster 中的方法
返回此 WritableRaster 的父 WritableRaster（如果有），否则返回 null。
getWritableTile(int, int) - 类 java.awt.image.BufferedImage 中的方法
为写入签出一个 tile。
getWritableTile(int, int) - 接口 java.awt.image.WritableRenderedImage 中的方法
为写入签出一个 tile。
getWritableTileIndices() - 类 java.awt.image.BufferedImage 中的方法
返回 Point 对象的数组，它指示为写入签出了哪些 tile。
getWritableTileIndices() - 接口 java.awt.image.WritableRenderedImage 中的方法
返回 Point 对象的数组，它指示为写入签出了哪些 tile。
getWriteHoldCount() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询当前线程在此锁上保持的重入写入锁数量。
getWriteMethod() - 类 java.beans.PropertyDescriptor 中的方法
获得应该用于写入属性值的方法。
getWriter() - 接口 javax.script.ScriptContext 中的方法
返回脚本的 Writer，以便在显示输出时使用。
getWriter() - 类 javax.script.SimpleScriptContext 中的方法
返回脚本的 Writer，以便在显示输出时使用。
getWriter() - 类 javax.swing.text.AbstractWriter 中的方法
返回用于输出内容的 Writer。
getWriter() - 类 javax.xml.transform.stream.StreamResult 中的方法
获取通过 setWriter 设置的字符流。
getWriterFileSuffixes() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出与当前已注册 writer 集合所理解的格式关联的所有文件后缀。
getWriterFormatNames() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有非正式格式名称。
getWriterMIMETypes() - 类 javax.imageio.ImageIO 中的静态方法
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有 MIME 类型。
getWriterServiceProviderName() - 类 javax.imageio.spi.ImageTranscoderSpi 中的方法
返回 ImageWriterSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。
getWSDLDocumentLocation() - 类 javax.xml.ws.Service 中的方法
获取此 Service 的 WSDL 文档的位置。
getWSDLDocumentLocation() - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
获取此服务的 WSDL 文档的位置。
getX() - 类 java.awt.Component 中的方法
返回组件原点的当前 x 坐标。
getX() - 类 java.awt.dnd.DragSourceEvent 中的方法
此方法返回事件发生时在屏幕坐标中光标位置的水平坐标，如果没有为此事件指定光标位置，则返回零。
getX() - 类 java.awt.event.MouseEvent 中的方法
返回事件相对于源组件的水平 x 坐标。
getX() - 类 java.awt.geom.Arc2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Arc2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Ellipse2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Ellipse2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Point2D.Double 中的方法
以 double 精度返回此 Point2D 的 X 坐标。
getX() - 类 java.awt.geom.Point2D.Float 中的方法
以 double 精度返回此 Point2D 的 X 坐标。
getX() - 类 java.awt.geom.Point2D 中的方法
以 double 精度返回此 Point2D 的 X 坐标。
getX() - 类 java.awt.geom.Rectangle2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.Rectangle2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 X 坐标。
getX() - 类 java.awt.Point 中的方法
以 double 精度返回此 Point2D 的 X 坐标。
getX() - 类 java.awt.Rectangle 中的方法
以 double 精度返回边界 Rectangle 的 X 坐标。
getX() - 接口 java.security.interfaces.DSAPrivateKey 中的方法
返回专用密钥值 x。
getX() - 类 java.security.spec.DSAPrivateKeySpec 中的方法
返回专用密钥 x。
getX() - 接口 javax.crypto.interfaces.DHPrivateKey 中的方法
返回私钥值 x。
getX() - 类 javax.crypto.spec.DHPrivateKeySpec 中的方法
返回私有值 x。
getX(int) - 类 javax.print.attribute.Size2DSyntax 中的方法
返回给定单位的此二维大小属性的 X 维度作为浮点值。
getX(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以指定的单位获取可打印区域的原点的 x 位置。
getX() - 类 javax.swing.JComponent 中的方法
返回组件原点的当前 x 坐标。
getX() - 类 javax.swing.SpringLayout.Constraints 中的方法
返回 x 属性的值。
getX1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.Line2D.Double 中的方法
返回起始点的 X 坐标（以 double 精度表示）。
getX1() - 类 java.awt.geom.Line2D.Float 中的方法
返回起始点的 X 坐标（以 double 精度表示）。
getX1() - 类 java.awt.geom.Line2D 中的方法
返回起始点的 X 坐标（以 double 精度表示）。
getX1() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回起始点的 X 坐标。
getX1() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回起始点的 X 坐标。
getX2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.Line2D.Double 中的方法
返回结束点的 X 坐标（以 double 精度表示）。
getX2() - 类 java.awt.geom.Line2D.Float 中的方法
返回结束点的 X 坐标（以 double 精度表示）。
getX2() - 类 java.awt.geom.Line2D 中的方法
返回结束点的 X 坐标（以 double 精度表示）。
getX2() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回结束点的 X 坐标。
getX2() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回结束点的 X 坐标。
getXAConnection() - 接口 javax.sql.XADataSource 中的方法
尝试建立可在分布式事务中使用的物理数据库连接。
getXAConnection(String, String) - 接口 javax.sql.XADataSource 中的方法
使用给定的用户名和密码，尝试建立一个物理数据库连接。
getXAResource() - 接口 javax.sql.XAConnection 中的方法
获取 XAResource 对象，事务管理器将使用该对象管理此 XAConnection 对象如何参与到分布式事务中。
getXMicrometers() - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性的 X 维度（以微米为单位）。
getXmlEncoding() - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明的一部分，指定此文档编码的属性。
getXmlEncoding() - 接口 org.w3c.dom.Entity 中的方法
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体的编码的属性。
getXMLEventReader() - 类 javax.xml.transform.stax.StAXSource 中的方法
获取此 StAXSource 使用的 XMLEventReader。
getXMLEventWriter() - 类 javax.xml.transform.stax.StAXResult 中的方法
获取此 StAXResult 使用的 XMLEventWriter。
getXMLNode(Object) - 类 javax.xml.bind.Binder 中的方法
获取与给定 JAXB 对象关联的 XML 元素。
getXMLReader() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
获取配置好的 XMLReader。
getXMLReader() - 类 javax.xml.parsers.SAXParser 中的方法
返回由此类的实现封装的 XMLReader。
getXMLReader() - 类 javax.xml.transform.sax.SAXSource 中的方法
获取要用于 Source 的 XMLReader。
getXMLReporter() - 类 javax.xml.stream.XMLInputFactory 中的方法
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。
getXMLResolver() - 类 javax.xml.stream.XMLInputFactory 中的方法
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。
getXMLSchemaType() - 类 javax.xml.datatype.Duration 中的方法
返回此实例映射到的 XML 模式日期/时间类型的名称。
getXMLSchemaType() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回此实例映射到的 XML 模式日期/时间类型的名称。
getXmlStandalone() - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明的一部分，指定此文档是否为独立文档的属性。
getXMLStreamReader() - 类 javax.xml.transform.stax.StAXSource 中的方法
获取此 StAXSource 使用的 XMLStreamReader。
getXMLStreamWriter() - 类 javax.xml.transform.stax.StAXResult 中的方法
获取此 StAXResult 使用的 XMLStreamWriter。
getXmlVersion() - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明 的一部分指定此文档版本号的属性。
getXmlVersion() - 接口 org.w3c.dom.Entity 中的方法
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体版本号的属性。
getXMLVersion() - 接口 org.xml.sax.ext.Locator2 中的方法
返回用于该实体的 XML 的版本。
getXMLVersion() - 类 org.xml.sax.ext.Locator2Impl 中的方法
返回版本属性的当前值。
getXOnScreen() - 类 java.awt.event.MouseEvent 中的方法
返回事件的绝对水平 x 坐标。
getXOrigin() - 类 java.awt.image.Kernel 中的方法
返回此 Kernel 的 X 原点。
getXPath() - 类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 中的方法
返回要计算的 XPath 表达式。
getXPathFunctionResolver() - 接口 javax.xml.xpath.XPath 中的方法
返回当前的函数解析器。
getXPathList() - 类 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec 中的方法
返回一个列表，由一个或多个 XPathType 对象组成。
getXPathVariableResolver() - 接口 javax.xml.xpath.XPath 中的方法
返回当前的变量解析器。
getY() - 类 java.awt.Component 中的方法
返回组件原点的当前 y 坐标。
getY() - 类 java.awt.dnd.DragSourceEvent 中的方法
此方法返回事件发生时在屏幕坐标中光标位置的垂直坐标，如果没有为此事件指定光标位置，则返回零。
getY() - 类 java.awt.event.MouseEvent 中的方法
返回事件相对于源组件的垂直 y 坐标。
getY() - 类 java.awt.geom.Arc2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Arc2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Ellipse2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Ellipse2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Point2D.Double 中的方法
以 double 精度返回此 Point2D 的 Y 坐标。
getY() - 类 java.awt.geom.Point2D.Float 中的方法
以 double 精度返回此 Point2D 的 Y 坐标。
getY() - 类 java.awt.geom.Point2D 中的方法
以 double 精度返回此 Point2D 的 Y 坐标。
getY() - 类 java.awt.geom.Rectangle2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.Rectangle2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.RectangularShape 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
以 double 精度返回窗体矩形左上角的 Y 坐标。
getY() - 类 java.awt.Point 中的方法
以 double 精度返回此 Point2D 的 Y 坐标。
getY() - 类 java.awt.Rectangle 中的方法
以 double 精度返回边界 Rectangle 的 Y 坐标。
getY() - 接口 java.security.interfaces.DSAPublicKey 中的方法
返回公用密钥值 y。
getY() - 类 java.security.spec.DSAPublicKeySpec 中的方法
返回公用密钥 y。
getY() - 接口 javax.crypto.interfaces.DHPublicKey 中的方法
返回公钥值 y。
getY() - 类 javax.crypto.spec.DHPublicKeySpec 中的方法
返回公有值 y。
getY(int) - 类 javax.print.attribute.Size2DSyntax 中的方法
返回给定单位的此二维大小属性的 Y 维度作为浮点值。
getY(int) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以指定单位获取可打印区域的原点的 y 位置。
getY() - 类 javax.swing.JComponent 中的方法
返回组件原点的当前 y 坐标。
getY() - 类 javax.swing.SpringLayout.Constraints 中的方法
返回 y 属性的值。
getY1() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.Line2D.Double 中的方法
返回起始点的 Y 坐标（以 double 精度表示）。
getY1() - 类 java.awt.geom.Line2D.Float 中的方法
返回起始点的 Y 坐标（以 double 精度表示）。
getY1() - 类 java.awt.geom.Line2D 中的方法
返回起始点的 Y 坐标（以 double 精度表示）。
getY1() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回起始点的 Y 坐标。
getY1() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回起始点的 Y 坐标。
getY2() - 类 java.awt.geom.CubicCurve2D.Double 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.CubicCurve2D.Float 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.CubicCurve2D 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.Line2D.Double 中的方法
返回结束点的 Y 坐标（以 double 精度表示）。
getY2() - 类 java.awt.geom.Line2D.Float 中的方法
返回结束点的 Y 坐标（以 double 精度表示）。
getY2() - 类 java.awt.geom.Line2D 中的方法
返回结束点的 Y 坐标（以 double 精度表示）。
getY2() - 类 java.awt.geom.QuadCurve2D.Double 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.QuadCurve2D.Float 中的方法
以 double 精度返回结束点的 Y 坐标。
getY2() - 类 java.awt.geom.QuadCurve2D 中的方法
以 double 精度返回结束点的 Y 坐标。
getYear() - 类 java.sql.Time 中的方法
已过时。
getYear() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.YEAR) - 1900 取代。
getYear() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 year 或 DatatypeConstants.FIELD_UNDEFINED XML 模式 1.0 日期时间数据类型字段的低顺序组件。
getYears() - 类 javax.xml.datatype.Duration 中的方法
获取此 Duration 以 int 表示的 years 值，如果不存在，则值为 0。
getYMicrometers() - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性的 Y 维度（以微米为单位）。
getYOnScreen() - 类 java.awt.event.MouseEvent 中的方法
返回事件的绝对垂直 y 坐标。
getYOrigin() - 类 java.awt.image.Kernel 中的方法
返回此 Kernel 的 Y 原点。
getZeroDigit() - 类 java.text.DecimalFormatSymbols 中的方法
获得用于零的字符。
getZoneStrings() - 类 java.text.DateFormatSymbols 中的方法
获取时区字符串。
GIF - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "image/gif"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
GIF - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
GIF - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
GLASS_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
一个窗格，保证此窗格在其所有下级窗格之上进行绘制。
GLASS_PANE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
glassPane - 类 javax.swing.JRootPane 中的变量
覆盖菜单栏和内容窗格的玻璃窗格，便于截取鼠标移动等操作。
glassPaneDispatcher - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量

global - 类 java.util.logging.Logger 中的静态变量
已过时。 此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。
GLOBAL_LOGGER_NAME - 类 java.util.logging.Logger 中的静态变量
GLOBAL_LOGGER_NAME 是全局 logger 的一个名称。
GLOBAL_SCOPE - 接口 javax.script.ScriptContext 中的静态变量
GlobalScope 属性对于同一 ScriptEngineFactory 创建的所有引擎都是可见的。
globalHierarchyLock - 接口 java.beans.beancontext.BeanContext 中的静态变量
BeanContext 和 BeanContextServices 实现者均使用此全局锁定来序列化 BeanContext 中的更改和所有服务请求等。
globalScope - 类 javax.script.SimpleScriptContext 中的变量
此字段是全局范围 bindings。
GlyphJustificationInfo - java.awt.font 中的 类
GlyphJustificationInfo 类表示关于字形调整属性的信息。
GlyphJustificationInfo(float, boolean, int, float, float, boolean, int, float, float) - 类 java.awt.font.GlyphJustificationInfo 的构造方法
构造有关字形调整属性的信息。
GlyphMetrics - java.awt.font 中的 类
GlyphMetrics 类表示单个字形的信息。
GlyphMetrics(float, Rectangle2D, byte) - 类 java.awt.font.GlyphMetrics 的构造方法
构造一个 GlyphMetrics 对象。
GlyphMetrics(boolean, float, float, Rectangle2D, byte) - 类 java.awt.font.GlyphMetrics 的构造方法
构造一个 GlyphMetrics 对象。
GlyphVector - java.awt.font 中的 类
GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。
GlyphVector() - 类 java.awt.font.GlyphVector 的构造方法

GlyphView - javax.swing.text 中的 类
GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
GlyphView(Element) - 类 javax.swing.text.GlyphView 的构造方法
构造在元素上包装的新视图。
GlyphView.GlyphPainter - javax.swing.text 中的 类
执行字形呈现的类。
GlyphView.GlyphPainter() - 类 javax.swing.text.GlyphView.GlyphPainter 的构造方法

GMONTH - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gMonth 的完全限定名称。
GMONTHDAY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gMonthDay 的完全限定名称。
GoodBreakWeight - 类 javax.swing.text.View 中的静态变量
该权重指示视图支持拆分，但是可能存在更好时机。
GOPHER - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
Gopher 协议。
GOT_FOCUS - 类 java.awt.Event 中的静态变量
组件获得焦点。
gotDefault - 类 javax.naming.InitialContext 中的变量
该字段指示是否已通过调用 NamingManager.getInitialContext() 获得了初始上下文。
gotFocus(Event, Object) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
GOTHIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Gothic”Unicode 字符块的常量。
grabFocus() - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点，并请求此 Component 的顶层祖先成为获得焦点的 Window。
grabPixels() - 类 java.awt.image.PixelGrabber 中的方法
请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素。
grabPixels(long) - 类 java.awt.image.PixelGrabber 中的方法
请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素，或者等待到用完超时期。
GRADE_CHECK_ALL_AT_COMMIT - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示关于原始数据源的高级别乐观同步等级。
GRADE_CHECK_MODIFIED_AT_COMMIT - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示关于原始数据源的低级别乐观同步等级。
GRADE_LOCK_WHEN_LOADED - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示关于原始数据源的最悲观同步等级。
GRADE_LOCK_WHEN_MODIFIED - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示关于原始数据源的悲观同步等级。
GRADE_NONE - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示没有提供与原始数据源的同步。
GradientPaint - java.awt 中的 类
GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。
GradientPaint(float, float, Color, float, float, Color) - 类 java.awt.GradientPaint 的构造方法
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(Point2D, Color, Point2D, Color) - 类 java.awt.GradientPaint 的构造方法
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(float, float, Color, float, float, Color, boolean) - 类 java.awt.GradientPaint 的构造方法
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
GradientPaint(Point2D, Color, Point2D, Color, boolean) - 类 java.awt.GradientPaint 的构造方法
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
GraphicAttribute - java.awt.font 中的 类
此类与 CHAR_REPLACEMENT 属性一起使用。
GraphicAttribute(int) - 类 java.awt.font.GraphicAttribute 的构造方法
构造一个 GraphicAttribute。
Graphics - java.awt 中的 类
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Graphics() - 类 java.awt.Graphics 的构造方法
构造一个新的 Graphics 对象。
Graphics2D - java.awt 中的 类
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。
Graphics2D() - 类 java.awt.Graphics2D 的构造方法
构建一个新的 Graphics2D 对象。
GraphicsConfigTemplate - java.awt 中的 类
GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。
GraphicsConfigTemplate() - 类 java.awt.GraphicsConfigTemplate 的构造方法
此类是一个抽象类，因此只有子类才可以实例化。
GraphicsConfiguration - java.awt 中的 类
GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。
GraphicsConfiguration() - 类 java.awt.GraphicsConfiguration 的构造方法
这是一个不可直接实例化的抽象类。
GraphicsDevice - java.awt 中的 类
GraphicsDevice 类描述可以在特定图形环境中使用的图形设备。
GraphicsDevice() - 类 java.awt.GraphicsDevice 的构造方法
这是一个无法直接实例化的抽象类。
GraphicsEnvironment - java.awt 中的 类
GraphicsEnvironment 类描述了 Java(tm) 应用程序在特定平台上可用的 GraphicsDevice 对象和 Font 对象的集合。
GraphicsEnvironment() - 类 java.awt.GraphicsEnvironment 的构造方法
这是一个抽象类，不能直接将其实例化。
gray - 类 java.awt.Color 中的静态变量
灰色。
GRAY - 类 java.awt.Color 中的静态变量
灰色。
GrayFilter - javax.swing 中的 类
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。
GrayFilter(boolean, int) - 类 javax.swing.GrayFilter 的构造方法
构造一个 GrayFilter 对象，该对象将彩色图像过滤成灰度级图像。
GREATER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
比较结果。
GREEK - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Greek and Coptic”Unicode 字符块的常量。
GREEK_EXTENDED - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Greek Extended”Unicode 字符块的常量。
green - 类 java.awt.Color 中的静态变量
绿色。
GREEN - 类 java.awt.Color 中的静态变量
绿色。
GREENCOMPONENT - 类 java.awt.color.ICC_ProfileRGB 中的静态变量
用于获取绿色分量的 gamma 值或 TRC。
GregorianCalendar - java.util 中的 类
GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
GregorianCalendar() - 类 java.util.GregorianCalendar 的构造方法
在具有默认语言环境的默认时区内使用当前时间构造一个默认的 GregorianCalendar。
GregorianCalendar(TimeZone) - 类 java.util.GregorianCalendar 的构造方法
在具有默认语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(Locale) - 类 java.util.GregorianCalendar 的构造方法
在具有给定语言环境的默认时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(TimeZone, Locale) - 类 java.util.GregorianCalendar 的构造方法
在具有给定语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(int, int, int) - 类 java.util.GregorianCalendar 的构造方法
在具有默认语言环境的默认时区内构造一个带有给定日期设置的 GregorianCalendar。
GregorianCalendar(int, int, int, int, int) - 类 java.util.GregorianCalendar 的构造方法
为具有默认语言环境的默认时区构造一个具有给定日期和时间设置的 GregorianCalendar。
GregorianCalendar(int, int, int, int, int, int) - 类 java.util.GregorianCalendar 的构造方法
为具有默认语言环境的默认时区构造一个具有给定日期和时间设置的 GregorianCalendar。
GridBagConstraints - java.awt 中的 类
GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
GridBagConstraints() - 类 java.awt.GridBagConstraints 的构造方法
创建一个 GridBagConstraint 对象，将其所有字段都设置为默认值。
GridBagConstraints(int, int, int, int, double, double, int, int, Insets, int, int) - 类 java.awt.GridBagConstraints 的构造方法
创建一个 GridBagConstraints 对象，将其所有字段都设置为传入参数。
GridBagLayout - java.awt 中的 类
GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。
GridBagLayout() - 类 java.awt.GridBagLayout 的构造方法
创建网格包布局管理器。
GridBagLayoutInfo - java.awt 中的 类
GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。
gridColor - 类 javax.swing.JTable 中的变量
网格的颜色。
gridheight - 类 java.awt.GridBagConstraints 中的变量
指定在组件显示区域的一列中的单元格数。
GridLayout - java.awt 中的 类
GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。
GridLayout() - 类 java.awt.GridLayout 的构造方法
创建具有默认值的网格布局，即每个组件占据一行一列。
GridLayout(int, int) - 类 java.awt.GridLayout 的构造方法
创建具有指定行数和列数的网格布局。
GridLayout(int, int, int, int) - 类 java.awt.GridLayout 的构造方法
创建具有指定行数和列数的网格布局。
gridwidth - 类 java.awt.GridBagConstraints 中的变量
指定组件显示区域的某一行中的单元格数。
gridx - 类 java.awt.GridBagConstraints 中的变量
指定包含组件的显示区域开始边的单元格，其中行的第一个单元格为 gridx=0。
gridy - 类 java.awt.GridBagConstraints 中的变量
指定位于组件显示区域的顶部的单元格，其中最上边的单元格为 gridy=0。
Group - java.security.acl 中的 接口
此接口用于表示一个主体组。
group() - 类 java.util.regex.Matcher 中的方法
返回由以前匹配操作所匹配的输入子序列。
group(int) - 类 java.util.regex.Matcher 中的方法
返回在以前匹配操作期间由给定组捕获的输入子序列。
group() - 接口 java.util.regex.MatchResult 中的方法
返回由以前匹配所匹配的输入子序列。
group(int) - 接口 java.util.regex.MatchResult 中的方法
返回在以前匹配操作期间由给定组捕获的输入子序列。
group - 类 javax.swing.DefaultButtonModel 中的变量
按钮所属的按钮组。
GROUP_BOX - 类 javax.accessibility.AccessibleRole 中的静态变量
GROUP_BOX 是包含它周围的边框及其内部组件的简单容器。
groupCount() - 类 java.util.regex.Matcher 中的方法
返回此匹配器模式中的捕获组数。
groupCount() - 接口 java.util.regex.MatchResult 中的方法
返回此匹配结果的模式中的捕获组数。
GROUPING_SEPARATOR - 类 java.text.NumberFormat.Field 中的静态变量
标识组分隔符字段的常量。
GroupLayout - javax.swing 中的 类
GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。
GroupLayout(Container) - 类 javax.swing.GroupLayout 的构造方法
为指定的 Container 创建 GroupLayout。
GroupLayout.Alignment - javax.swing 中的 枚举
ParallelGroup 能够对齐其子元素的可能方式的枚举。
GroupLayout.Group - javax.swing 中的 类
Group 为 GroupLayout 所支持的以下两种操作提供基础：一个接一个地布置组件（SequentialGroup）或对齐组件（ParallelGroup）。
GroupLayout.ParallelGroup - javax.swing 中的 类
一个 Group，它对齐其子元素并确定其大小。
GroupLayout.SequentialGroup - javax.swing 中的 类
一个 Group，它按顺序一个接一个地确定其元素的位置和大小。
grow(int, int) - 类 java.awt.Rectangle 中的方法
在水平方向和垂直方向上同时调整 Rectangle 的大小。
growAbsorb - 类 java.awt.font.GlyphJustificationInfo 中的变量
如果为 true，那么当此字形增大时，它会占有此 priority 和更低 priority 的所有额外空间。
growLeftLimit - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形左边可以增大的最大量。
growPriority - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形增大时的 priority 级别。
growRightLimit - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形右边可以增大的最大量。
GSSContext - org.ietf.jgss 中的 接口
此接口将封装 GSS-API 安全上下文，并提供可通过上下文提供的安全服务。
GSSCredential - org.ietf.jgss 中的 接口
此接口将为实体封装 GSS-API 凭据。
GSSException - org.ietf.jgss 中的 异常
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。
GSSException(int) - 异常 org.ietf.jgss.GSSException 的构造方法
使用指定的主要代码创建一个 GSSException 对象。
GSSException(int, int, String) - 异常 org.ietf.jgss.GSSException 的构造方法
使用指定的主要代码、次要代码和次要代码文本性解释，创建一个 GSSException 对象。
GSSManager - org.ietf.jgss 中的 类
此类作为其他重要 GSS-API 类的工厂，并且还提供有关受支持的机制的信息。
GSSManager() - 类 org.ietf.jgss.GSSManager 的构造方法

GSSName - org.ietf.jgss 中的 接口
此接口将封装单一的 GSS-API 主体实体。
GT - 类 javax.management.Query 中的静态变量
表示 Query.gt(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
gt(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于两个值的“大于”约束条件。
Guard - java.security 中的 接口
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
GuardedObject - java.security 中的 类
GuardedObject 是一个用来保护对另一个对象的访问的对象。
GuardedObject(Object, Guard) - 类 java.security.GuardedObject 的构造方法
使用指定的对象和 guard 构造 GuardedObject。
guessContentTypeFromName(String) - 类 java.net.URLConnection 中的静态方法
根据 URL 的指定 "file" 部分尝试确定对象的内容类型。
guessContentTypeFromStream(InputStream) - 类 java.net.URLConnection 中的静态方法
根据输入流的开始字符尝试确定输入流的类型。
GUJARATI - 类 java.awt.font.NumericShaper 中的静态变量
标识 GUJARATI 范围和十进制基数。
GUJARATI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Gujarati”Unicode 字符块的常量。
GURMUKHI - 类 java.awt.font.NumericShaper 中的静态变量
标识 GURMUKHI 范围和十进制基数。
GURMUKHI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Gurmukhi”Unicode 字符块的常量。
GYEAR - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gYear 的完全限定名称。
GYEARMONTH - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 gYearMonth 的完全限定名称。
GZIP - 类 javax.print.attribute.standard.Compression 中的静态变量
RFC 1952 中所描述的 GNU zip 压缩技术。
GZIP_MAGIC - 类 java.util.zip.GZIPInputStream 中的静态变量
GZIP 头幻数。
GZIPInputStream - java.util.zip 中的 类
此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
GZIPInputStream(InputStream, int) - 类 java.util.zip.GZIPInputStream 的构造方法
使用指定缓冲区大小创建新的输入流。
GZIPInputStream(InputStream) - 类 java.util.zip.GZIPInputStream 的构造方法
使用默认缓冲区大小创建新的输入流。
GZIPOutputStream - java.util.zip 中的 类
此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
GZIPOutputStream(OutputStream, int) - 类 java.util.zip.GZIPOutputStream 的构造方法
使用指定缓冲区大小创建新的输出流。
GZIPOutputStream(OutputStream) - 类 java.util.zip.GZIPOutputStream 的构造方法
使用默认缓冲区大小创建新的输出流。

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM Platform
Standard Ed. 6

上一个字母 下一个字母

框架 无框架

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


H - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

H

h - 类 java.lang.reflect.Proxy 中的变量
此代理实例的调用处理程序。
H1 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H2 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H3 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H4 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H5 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
H6 - 类 javax.swing.text.html.HTML.Tag 中的静态变量
HALFWIDTH_AND_FULLWIDTH_FORMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Halfwidth and Fullwidth Forms”Unicode 字符块的常量。
HALFWIDTH_KATAKANA - 类 java.awt.im.InputSubset 中的静态变量
Unicode 半角和全角字符块的半角片假名子集常量。
HALIGN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
halt(int) - 类 java.lang.Runtime 中的方法
强行终止目前正在运行的 Java 虚拟机。
HAND_CURSOR - 类 java.awt.Cursor 中的静态变量
手状光标类型。
HAND_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.HAND_CURSOR 取代。
handle(Callback[]) - 接口 javax.security.auth.callback.CallbackHandler 中的方法
获取或显示在提供的 Callback 中请求的信息。
handle(short, String, Object, Node, Node) - 接口 org.w3c.dom.UserDataHandler 中的方法
每当导入或克隆为其注册此处理程序的节点时，调用此方法。
handleComment(char[], int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
handleComment(char[], int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleComment(char[]) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
handleComment(char[]) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到 HTML 注释时调用。
handleEmptyTag(TagElement) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
处理空标记。
handleEmptyTag(TagElement) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到空标记时调用。
handleEndOfLineString(String) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
它的调用是在完成流的解析之后且在调用 flush 之前。
handleEndOfLineString(String) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
它的调用是在完成流的解析之后且在调用 flush 之前。
handleEndTag(HTML.Tag, int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
从解析器回调。
handleEndTag(HTML.Tag, int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleEndTag(TagElement) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
处理结束标记。
handleEndTag(TagElement) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到结束标记时调用。
handleEOFInComment() - 类 javax.swing.text.html.parser.Parser 中的方法
handleError(String, int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleError(int, String) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
handleError(int, String) - 类 javax.swing.text.html.parser.Parser 中的方法
发生了一个错误。
handleError(DOMError) - 接口 org.w3c.dom.DOMErrorHandler 中的方法
发生错误时在错误处理程序上调用此方法。
handleEvent(Event) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。
handleEvent(ValidationEvent) - 类 javax.xml.bind.helpers.DefaultValidationEventHandler 中的方法
handleEvent(ValidationEvent) - 类 javax.xml.bind.util.ValidationEventCollector 中的方法
handleEvent(ValidationEvent) - 接口 javax.xml.bind.ValidationEventHandler 中的方法
接收验证警告或错误的通知。
handleEvent(Event) - 接口 org.w3c.dom.events.EventListener 中的方法
每当发生 EventListener 接口为其注册的类型的事件时，即可调用此方法。
handleExpandControlClick(TreePath, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
当用户单击特定行时传递消息，此方法调用 toggleExpandState。
handleFault(C) - 接口 javax.xml.ws.handler.Handler 中的方法
可调用 handleFault 方法进行错误消息处理。
handleGetObject(String) - 类 java.util.ListResourceBundle 中的方法
handleGetObject(String) - 类 java.util.PropertyResourceBundle 中的方法
handleGetObject(String) - 类 java.util.ResourceBundle 中的方法
从此资源包中获取给定键的对象。
handleJustify(float) - 类 java.awt.font.TextLayout 中的方法
调整此布局。
handleKeySet() - 类 java.util.ListResourceBundle 中的方法
返回只 包含在此 ResourceBundle 中的键的 Set。
handleKeySet() - 类 java.util.PropertyResourceBundle 中的方法
返回只 包含在此 ResourceBundle 中的键的 Set。
handleKeySet() - 类 java.util.ResourceBundle 中的方法
返回只 包含在此 ResourceBundle 中的键的 Set。
handleMBeanUnregistration(ObjectName, String) - 接口 javax.management.relation.Relation 中的方法
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
handleMBeanUnregistration(ObjectName, String) - 类 javax.management.relation.RelationSupport 中的方法
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
handleMessage(C) - 接口 javax.xml.ws.handler.Handler 中的方法
可调用 handleMessage 方法进行普通的入站和出站消息处理。
handleNotification(NotificationListener, Notification, Object) - 类 javax.management.NotificationBroadcasterSupport 中的方法
为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。
handleNotification(Notification, Object) - 接口 javax.management.NotificationListener 中的方法
出现 JMX 通知时调用。
handleNotification(Notification, Object) - 类 javax.management.relation.RelationService 中的方法
出现 JMX 通知时调用。
handleOption(String, Iterator<String>) - 类 javax.tools.ForwardingJavaFileManager 中的方法
handleOption(String, Iterator<String>) - 接口 javax.tools.JavaFileManager 中的方法
处理一个选项。
Handler - java.util.logging 中的 类
Handler 对象从 Logger 中获取日志信息，并将这些信息导出。
Handler() - 类 java.util.logging.Handler 的构造方法
默认构造方法。
Handler<C extends MessageContext> - javax.xml.ws.handler 中的 接口
Handler 接口是 JAX-WS 处理程序的基本接口。
HandlerBase - org.xml.sax 中的 类
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。
HandlerBase() - 类 org.xml.sax.HandlerBase 的构造方法
已过时。
HandlerChain - javax.jws 中的 注释类型
将 Web Service 与外部定义的处理程序链关联。
handleResponse(Response<T>) - 接口 javax.xml.ws.AsyncHandler 中的方法
当可以获得对异步操作的响应时调用。
HandlerResolver - javax.xml.ws.handler 中的 接口
HandlerResolver 是由应用程序实现的接口，用于控制创建 proxy/dispatch 对象时设置在这些对象上的处理程序链。
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
从解析器回调。
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleStartTag(HTML.Tag, MutableAttributeSet, int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
从解析器回调。
handleStartTag(HTML.Tag, MutableAttributeSet, int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleStartTag(TagElement) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
处理开始标记。
handleStartTag(TagElement) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到开始标记时调用。
handleText(char[], int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
解析器调用它来指示遇到一个文本块。
handleText(char[], int) - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的方法
handleText(char[]) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
处理文本。
handleText(char[]) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到 PCDATA 时调用。
handleTitle(char[]) - 类 javax.swing.text.html.parser.Parser 中的方法
在遇到 HTML 标题标记时调用。
handshakeCompleted(HandshakeCompletedEvent) - 接口 javax.net.ssl.HandshakeCompletedListener 中的方法
当 SSL 握手结束时，在已注册的对象上调用此方法。
HandshakeCompletedEvent - javax.net.ssl 中的 类
此事件指示在给定的 SSL 连接上 SSL 握手结束。
HandshakeCompletedEvent(SSLSocket, SSLSession) - 类 javax.net.ssl.HandshakeCompletedEvent 的构造方法
构造一个新的 HandshakeCompletedEvent。
HandshakeCompletedListener - javax.net.ssl 中的 接口
任何希望接收有关给定 SSL 连接上 SSL 协议握手结束通知的类实现此接口。
HANGING_BASELINE - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形的原点与行的悬挂基线对齐。
HANGING_BASELINE - 类 java.awt.Font 中的静态变量
布置文本时，在 Devanigiri 和类似脚本中使用的基线。
HANGUL_COMPATIBILITY_JAMO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hangul Compatibility Jamo”Unicode 字符块的常量。
HANGUL_JAMO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hangul Jamo”Unicode 字符块的常量。
HANGUL_SYLLABLES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hangul Syllables”Unicode 字符块的常量。
HANJA - 类 java.awt.im.InputSubset 中的静态变量
编写韩语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项的韩语汉字字集。
HANUNOO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hanunoo”Unicode 字符块的常量。
hardDriveIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
has_no_active_member() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
如果联合数据没有活动成员，即这些联合数据值仅由其鉴别符组成（因为鉴别符的值不作为显式 case 标签列出），则返回 true。
has_no_active_member() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
如果联合数据没有活动成员，即这些联合数据值仅由其鉴别符组成（因为鉴别符的值不作为显式 case 标签列出），则返回 true。
hasAlpha() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 中是否支持 alpha。
hasAnchoringBounds() - 类 java.util.regex.Matcher 中的方法
查询此匹配器区域界限的定位。
hasArray() - 类 java.nio.Buffer 中的方法
告知此缓冲区是否具有可访问的底层实现数组。
hasArray() - 类 java.nio.ByteBuffer 中的方法
判断是否可通过一个可访问的 byte 数组实现此缓冲区。
hasArray() - 类 java.nio.CharBuffer 中的方法
判断该缓冲区是否可通过一个可访问的字符数组实现。
hasArray() - 类 java.nio.DoubleBuffer 中的方法
判断是否可通过一个可访问的 double 数组实现此缓冲区。
hasArray() - 类 java.nio.FloatBuffer 中的方法
判断是否可通过一个可访问的 float 数组实现此缓冲区。
hasArray() - 类 java.nio.IntBuffer 中的方法
判断是否可通过一个可访问的 int 数组实现此缓冲区。
hasArray() - 类 java.nio.LongBuffer 中的方法
判断是否可通过一个可访问的 long 数组实现此缓冲区。
hasArray() - 类 java.nio.ShortBuffer 中的方法
判断是否可通过一个可访问的 short 数组实现此缓冲区。
hasAttribute(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
hasAttribute(String) - 接口 org.w3c.dom.Element 中的方法
当具有给定名称的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
hasAttributeNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 hasAttribute(localName)。
hasAttributeNS(String, String) - 接口 org.w3c.dom.Element 中的方法
当具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
hasAttributes() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
hasAttributes() - 接口 org.w3c.dom.Node 中的方法
返回此节点（如果它是一个元素）是否具有任何属性。
hasBeenExpanded(TreePath) - 类 javax.swing.JTree 中的方法
如果已经展开路径标识的节点，则返回 true。
hasChanged() - 类 java.util.Observable 中的方法
测试对象是否改变。
hasChildNodes() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
如果此节点有子节点，则返回 true。
hasChildNodes() - 接口 org.w3c.dom.Node 中的方法
返回此节点是否具有任何子节点。
hasChildren - 类 javax.swing.JTree.DynamicUtilTreeNode 中的变量
此 JTree 是否具有子节点？目前未实现此属性。
hasContended() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
查询是否有线程曾经为获取此同步器而发生争用；也就是说，是否某个 acquire 方法曾被阻塞。
hasContended() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
查询是否其他线程也曾争着获取此同步器；也就是说，是否某个 acquire 方法已经阻塞。
hasController() - 类 javax.imageio.IIOParam 中的方法
如果有一个为此 IIOParam 对象安装的控制器，则返回 true。
hasController() - 类 javax.imageio.metadata.IIOMetadata 中的方法
如果存在为此 IIOMetadata 对象安装的控制器，则返回 true。
HasControls - javax.naming.ldap 中的 接口
此接口用于返回控件，并使对象返回在 NamingEnumeration 中。
hasCustomComponents - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
如果 Component 包含在消息或按钮中，则将其设置为 true。
hasDefaultValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 默认值，则返回 true，否则返回 false。
hasDefaultValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
如果此参数存在指定的默认值，则返回 true，否则返回 false。
hasDefaultValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的默认值，则返回 true，否则返回 false。
hasDetail() - 接口 javax.xml.soap.SOAPFault 中的方法
如果此 SOAPFault 有一个 Detail 子元素，则返回 true，否则返回 false。
hasDynamicLocaleList() - 接口 java.awt.im.spi.InputMethodDescriptor 中的方法
返回可用语言环境列表是否可在运行时更改。
hasEntered - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
hasEvents() - 类 javax.xml.bind.util.ValidationEventCollector 中的方法
如果此事件收集器至少包含一个 ValidationEvent，则返回 true。
hasExpired() - 类 java.net.HttpCookie 中的方法
报告此 http cookie 是否已过期。
hasExtensions() - 类 java.security.cert.X509CRLEntry 中的方法
如果此 CRL 项有扩展，则返回 true。
hasFault() - 接口 javax.xml.soap.SOAPBody 中的方法
指示此 SOAPBody 对象中是否存在 SOAPFault 对象。
hasFeature(String, String) - 接口 org.w3c.dom.DOMImplementation 中的方法
测试 DOM 实现是否实现在 DOM Features 中指定的特定特性和版本。
hasFocus() - 类 java.awt.Component 中的方法
如果此 Component 是焦点所有者，则返回 true。
hasFocus - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
hasFocus - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
如果有焦点，则为 true。
hash(Object, int) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回此对象引用的内部 ORB 标识符（哈希码）。
HashAttributeSet - javax.print.attribute 中的 类
类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。
HashAttributeSet() - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个新的、空属性集。
HashAttributeSet(Attribute) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定属性填充的新属性集。
HashAttributeSet(Attribute[]) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新属性集。
HashAttributeSet(AttributeSet) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集。
HashAttributeSet(Class<?>) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个新的空属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Attribute, Class<?>) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定属性填充的新属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Attribute[], Class<?>) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个新的属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(AttributeSet, Class<?>) - 类 javax.print.attribute.HashAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于给定的接口。
hashCode() - 类 java.awt.AlphaComposite 中的方法
返回此合成的哈希码。
hashCode() - 类 java.awt.AWTKeyStroke 中的方法
返回此对象的数值，它可能是唯一的，将它用作哈希表中的索引值是一个好选择。
hashCode() - 类 java.awt.BasicStroke 中的方法
返回此笔划的哈希码。
hashCode() - 类 java.awt.Color 中的方法
计算此 Color 的哈希码。
hashCode() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的哈希码。
hashCode() - 类 java.awt.Dimension 中的方法
返回此 Dimension 的哈希码。
hashCode() - 类 java.awt.DisplayMode 中的方法
返回该对象的哈希码值。
hashCode() - 类 java.awt.font.FontRenderContext 中的方法
返回此 FontRenderContext 的哈希码。
hashCode() - 类 java.awt.Font 中的方法
返回此 Font 的哈希码。
hashCode() - 类 java.awt.font.ImageGraphicAttribute 中的方法
返回此 ImageGraphicAttribute 的哈希码。
hashCode() - 类 java.awt.font.NumericShaper 中的方法
返回此成形器的哈希码。
hashCode() - 类 java.awt.font.ShapeGraphicAttribute 中的方法
返回此 ShapeGraphicAttribute 的哈希码。
hashCode() - 类 java.awt.font.TextHitInfo 中的方法
返回哈希码。
hashCode() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的哈希码。
hashCode() - 类 java.awt.font.TransformAttribute 中的方法
hashCode() - 类 java.awt.geom.AffineTransform 中的方法
返回此变换的哈希码。
hashCode() - 类 java.awt.geom.Arc2D 中的方法
返回此 Arc2D 的哈希码。
hashCode() - 类 java.awt.geom.Ellipse2D 中的方法
返回此 Ellipse2D 的哈希码。
hashCode() - 类 java.awt.geom.Point2D 中的方法
返回此 Point2D 的哈希码。
hashCode() - 类 java.awt.geom.Rectangle2D 中的方法
返回此 Rectangle2D 的哈希码。
hashCode() - 类 java.awt.geom.RoundRectangle2D 中的方法
返回此 RoundRectangle2D 的哈希码。
hashCode() - 类 java.awt.image.BandedSampleModel 中的方法
hashCode() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 的哈希码。
hashCode() - 类 java.awt.image.ComponentSampleModel 中的方法
hashCode() - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
hashCode() - 类 java.awt.image.PixelInterleavedSampleModel 中的方法
hashCode() - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
hashCode() - 类 java.awt.Insets 中的方法
返回此 Insets 的哈希码。
hashCode() - 类 java.awt.JobAttributes 中的方法
返回此 JobAttributes 的哈希码值。
hashCode() - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式的哈希码。
hashCode() - 类 java.awt.PageAttributes 中的方法
返回此 PageAttributes 的哈希码值。
hashCode() - 类 java.awt.RenderingHints 中的方法
返回此 RenderingHints 中的哈希码值。
hashCode() - 类 java.awt.RenderingHints.Key 中的方法
所有 Key 对象的哈希码将与 System.identityHashCode() 方法定义的对象的系统识别码相同。
hashCode() - 类 java.beans.IndexedPropertyDescriptor 中的方法
返回对象的哈希码值。
hashCode() - 类 java.beans.PropertyDescriptor 中的方法
返回对象的哈希码。
hashCode() - 类 java.io.File 中的方法
计算此抽象路径名的哈希码。
hashCode() - 类 java.io.FilePermission 中的方法
返回此对象的哈希码值。
hashCode() - 接口 java.lang.annotation.Annotation 中的方法
返回此 annotation 的哈希码，具体说明如下： 一个 annotation 的哈希码是其成员（包括那些带有默认值的成员）的哈希码的和，具体说明如下： annotation 成员的哈希码是成员值哈希码的 XOR（它是 String.hashCode() 计算得到的成员名哈希码的 127 倍），具体说明如下： 成员值的哈希码取决于其类型： 基值 v 的哈希码等于 WrapperType.valueOf(v).hashCode()，其中 WrapperType 是对应 v 的基本类型的包装器类型（Byte、Character、Double、Float、Integer、Long、Short 或 Boolean）。
hashCode() - 类 java.lang.Boolean 中的方法
返回该 Boolean 对象的哈希码。
hashCode() - 类 java.lang.Byte 中的方法
返回此 Byte 的哈希码。
hashCode() - 类 java.lang.Character 中的方法
返回此 Character 的哈希码。
hashCode() - 类 java.lang.Character.Subset 中的方法
返回 Object.hashCode() 方法定义的标准哈希码。
hashCode() - 类 java.lang.Double 中的方法
返回此 Double 对象的哈希码。
hashCode() - 类 java.lang.Enum 中的方法
返回枚举常量的哈希码。
hashCode() - 类 java.lang.Float 中的方法
返回此 Float 对象的哈希码。
hashCode() - 类 java.lang.Integer 中的方法
返回此 Integer 的哈希码。
hashCode() - 类 java.lang.Long 中的方法
返回 Long 的哈希码。
hashCode() - 类 java.lang.Object 中的方法
返回该对象的哈希码值。
hashCode() - 类 java.lang.Package 中的方法
返回从包名称计算的哈希码。
hashCode() - 类 java.lang.reflect.Constructor 中的方法
返回此 Constructor 的哈希码。
hashCode() - 类 java.lang.reflect.Field 中的方法
返回该 Field 的哈希码。
hashCode() - 类 java.lang.reflect.Method 中的方法
返回此 Method 的哈希码。
hashCode() - 类 java.lang.Short 中的方法
返回此 Short 的哈希码。
hashCode() - 类 java.lang.StackTraceElement 中的方法
返回此堆栈跟踪元素的哈希码值。
hashCode() - 类 java.lang.String 中的方法
返回此字符串的哈希码。
hashCode() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的哈希码。
hashCode() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的哈希码。
hashCode() - 类 java.math.MathContext 中的方法
返回此 MathContext 的哈希码。
hashCode() - 类 java.net.HttpCookie 中的方法
返回此 http cookie 的哈希码。
hashCode() - 类 java.net.Inet4Address 中的方法
返回此 IP 地址的哈希码。
hashCode() - 类 java.net.Inet6Address 中的方法
返回此 IP 地址的哈希码。
hashCode() - 类 java.net.InetAddress 中的方法
返回此 IP 地址的哈希码。
hashCode() - 类 java.net.InetSocketAddress 中的方法
返回此套接字地址的哈希码。
hashCode() - 类 java.net.InterfaceAddress 中的方法
返回此接口地址的哈希码。
hashCode() - 类 java.net.NetworkInterface 中的方法
hashCode() - 类 java.net.Proxy 中的方法
返回此代理的哈希码。
hashCode() - 类 java.net.SocketPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.net.URI 中的方法
返回此 URI 的哈希码值。
hashCode() - 类 java.net.URL 中的方法
创建一个适合哈希表索引的整数。
hashCode(URL) - 类 java.net.URLStreamHandler 中的方法
提供默认的哈希计算。
hashCode() - 类 java.nio.ByteBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.CharBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.charset.Charset 中的方法
计算此 charset 的哈希码。
hashCode() - 类 java.nio.DoubleBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.FloatBuffer 中的方法
返回此缓冲区的哈希码。
hashCode() - 类 java.nio.IntBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.LongBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.nio.ShortBuffer 中的方法
返回此缓冲区的当前哈希码。
hashCode() - 类 java.rmi.activation.ActivationDesc 中的方法
为类似的 ActivationDesc 返回相同的哈希码
hashCode() - 类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 中的方法
返回类似 CommandEnvironment 的相同值。
hashCode() - 类 java.rmi.activation.ActivationGroupDesc 中的方法
为类似的 ActivationGroupDesc 产生同样的数。
hashCode() - 类 java.rmi.activation.ActivationGroupID 中的方法
返回用于组标识符的哈希码。
hashCode() - 类 java.rmi.activation.ActivationID 中的方法
返回激活 id 的哈希码。
hashCode() - 类 java.rmi.dgc.VMID 中的方法
计算针对此 VMID 的哈希码。
hashCode() - 类 java.rmi.MarshalledObject 中的方法
返回该 MarshalledObject 的哈希码。
hashCode() - 类 java.rmi.server.ObjID 中的方法
返回此对象标识符、对象数的哈希码值。
hashCode() - 类 java.rmi.server.RemoteObject 中的方法
返回远程对象的哈希码。
hashCode() - 类 java.rmi.server.UID 中的方法
返回此 UID 的哈希码值。
hashCode() - 类 java.security.AccessControlContext 中的方法
返回此上下文的哈希码值。
hashCode() - 类 java.security.AllPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.security.BasicPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.security.cert.Certificate 中的方法
根据此证书的编码形式返回该证书的哈希码值。
hashCode() - 类 java.security.cert.CertPath 中的方法
返回此证书路径的哈希码。
hashCode() - 类 java.security.cert.X509CRL 中的方法
根据此 CRL 的编码形式返回该 CRL 的哈希码值。
hashCode() - 类 java.security.cert.X509CRLEntry 中的方法
根据此 CRL 项的编码形式返回该 CRL 项的哈希码值。
hashCode() - 类 java.security.CodeSigner 中的方法
返回此代码签名者的哈希码值。
hashCode() - 类 java.security.CodeSource 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的哈希码。
hashCode() - 类 java.security.Permission 中的方法
返回此 Permission 对象的哈希码值。
hashCode() - 接口 java.security.Principal 中的方法
返回此主体的哈希码。
hashCode() - 类 java.security.spec.ECFieldF2m 中的方法
返回此首数为 2 的有限字段的哈希码值。
hashCode() - 类 java.security.spec.ECFieldFp 中的方法
返回此素数有限字段的哈希码值。
hashCode() - 类 java.security.spec.ECPoint 中的方法
返回此椭圆曲线点的哈希码值。
hashCode() - 类 java.security.spec.EllipticCurve 中的方法
返回此椭圆曲线的哈希码值。
hashCode() - 类 java.security.Timestamp 中的方法
返回此时间戳的哈希码值。
hashCode() - 类 java.security.UnresolvedPermission 中的方法
返回此对象的哈希码值。
hashCode() - 接口 java.sql.RowId 中的方法
返回此 RowId 对象的哈希码值。
hashCode() - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.text.ChoiceFormat 中的方法
为消息格式对象生成哈希码。
hashCode() - 类 java.text.Collator 中的方法
生成此 Collator 的哈希码。
hashCode() - 类 java.text.DateFormat 中的方法
重写 hashCode
hashCode() - 类 java.text.DateFormatSymbols 中的方法
重写 hashCode。
hashCode() - 类 java.text.DecimalFormat 中的方法
重写 hashCode
hashCode() - 类 java.text.DecimalFormatSymbols 中的方法
重写 hashCode。
hashCode() - 类 java.text.FieldPosition 中的方法
返回此 FieldPosition 的哈希码。
hashCode() - 类 java.text.MessageFormat 中的方法
生成此消息格式对象的哈希码。
hashCode() - 类 java.text.NumberFormat 中的方法
重写 hashCode
hashCode() - 类 java.text.ParsePosition 中的方法
返回此 ParsePosition 的哈希码。
hashCode() - 类 java.text.RuleBasedCollator 中的方法
生成基于表的 collation 对象的哈希码
hashCode() - 类 java.text.SimpleDateFormat 中的方法
返回此 SimpleDateFormat 对象的哈希码值。
hashCode() - 类 java.text.StringCharacterIterator 中的方法
计算此迭代器的哈希码。
hashCode() - 类 java.util.AbstractList 中的方法
返回此列表的哈希码值。
hashCode() - 类 java.util.AbstractMap 中的方法
返回此映射的哈希码值。
hashCode() - 类 java.util.AbstractMap.SimpleEntry 中的方法
返回此映射项的哈希码值。
hashCode() - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
返回此映射项的哈希码值。
hashCode() - 类 java.util.AbstractSet 中的方法
返回此 set 的哈希码值。
hashCode(long[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(int[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(short[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(char[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(byte[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(boolean[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(float[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(double[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode(Object[]) - 类 java.util.Arrays 中的静态方法
基于指定数组的内容返回哈希码。
hashCode() - 类 java.util.BitSet 中的方法
返回此位 set 的哈希码值。
hashCode() - 类 java.util.Calendar 中的方法
返回该此日历的哈希码。
hashCode() - 接口 java.util.Collection 中的方法
返回此 collection 的哈希码值。
hashCode() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表的哈希码值。
hashCode() - 类 java.util.Date 中的方法
返回此对象的哈希码值。
hashCode() - 类 java.util.GregorianCalendar 中的方法
生成此 GregorianCalendar 对象的哈希码。
hashCode() - 类 java.util.Hashtable 中的方法
按照 Map 接口的定义，返回此 Map 的哈希码值。
hashCode() - 类 java.util.IdentityHashMap 中的方法
返回映射的哈希码值。
hashCode() - 类 java.util.jar.Attributes 中的方法
返回此 Map 的哈希码值。
hashCode() - 类 java.util.jar.Attributes.Name 中的方法
计算此属性名称的哈希值。
hashCode() - 类 java.util.jar.Manifest 中的方法
返回 Manifest 的哈希码。
hashCode() - 接口 java.util.List 中的方法
返回列表的哈希码值。
hashCode() - 类 java.util.Locale 中的方法
重写 hashCode。
hashCode() - 类 java.util.logging.Level 中的方法
生成哈希码。
hashCode() - 接口 java.util.Map.Entry 中的方法
返回此映射项的哈希码值。
hashCode() - 接口 java.util.Map 中的方法
返回此映射的哈希码值。
hashCode() - 类 java.util.PropertyPermission 中的方法
返回对象的哈希码值。
hashCode() - 接口 java.util.Set 中的方法
返回 set 的哈希码值。
hashCode() - 类 java.util.SimpleTimeZone 中的方法
生成 SimpleDateFormat 对象的哈希码。
hashCode() - 类 java.util.UUID 中的方法
返回此 UUID 的哈希码。
hashCode() - 类 java.util.Vector 中的方法
返回此向量的哈希码值。
hashCode() - 类 java.util.zip.ZipEntry 中的方法
返回此条目的哈希码值。
hashCode() - 类 javax.crypto.spec.RC2ParameterSpec 中的方法
计算此对象的哈希码值。
hashCode() - 类 javax.crypto.spec.RC5ParameterSpec 中的方法
计算此对象的哈希码值。
hashCode() - 类 javax.crypto.spec.SecretKeySpec 中的方法
计算此对象的哈希码值。
hashCode() - 类 javax.imageio.ImageTypeSpecifier 中的方法
返回此 ImageTypeSpecifier 的哈希码。
hashCode() - 接口 javax.lang.model.element.Element 中的方法
遵守 Object.hashCode 的常规协定。
hashCode() - 接口 javax.lang.model.element.Name 中的方法
遵守 Object.hashCode 的常规协定。
hashCode() - 接口 javax.lang.model.type.TypeMirror 中的方法
遵守 Object.hashCode 的常规协定。
hashCode() - 类 javax.management.Attribute 中的方法
返回此属性的哈希码值。
hashCode() - 接口 javax.management.Descriptor 中的方法
返回此描述符的哈希码值。
hashCode() - 类 javax.management.ImmutableDescriptor 中的方法
返回此描述符的哈希码值。
hashCode() - 类 javax.management.MBeanAttributeInfo 中的方法
hashCode() - 类 javax.management.MBeanConstructorInfo 中的方法
hashCode() - 类 javax.management.MBeanFeatureInfo 中的方法
hashCode() - 类 javax.management.MBeanInfo 中的方法
hashCode() - 类 javax.management.MBeanNotificationInfo 中的方法
hashCode() - 类 javax.management.MBeanOperationInfo 中的方法
hashCode() - 类 javax.management.MBeanParameterInfo 中的方法
hashCode() - 类 javax.management.MBeanPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 javax.management.MBeanServerPermission 中的方法
hashCode() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
返回此描述符的哈希码值。
hashCode() - 类 javax.management.ObjectInstance 中的方法
hashCode() - 类 javax.management.ObjectName 中的方法
返回此 ObjectName 的哈希码。
hashCode() - 类 javax.management.openmbean.ArrayType 中的方法
返回此 ArrayType 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.CompositeData 中的方法
返回此 CompositeData 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回此 CompositeDataSupport 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.CompositeType 中的方法
返回此 CompositeType 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
返回此 OpenMBeanAttributeInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回此 OpenMBeanConstructorInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 中的方法
返回此 OpenMBeanConstructorInfoSupport 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回此 OpenMBeanInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanInfoSupport 中的方法
返回此 OpenMBeanInfoSupport 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 中的方法
返回此 OpenMBeanOperationInfoSupport 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.OpenType 中的方法
hashCode() - 类 javax.management.openmbean.SimpleType 中的方法
返回此 SimpleType 实例的哈希码值。
hashCode() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例的哈希码值。
hashCode() - 类 javax.management.openmbean.TabularType 中的方法
返回此 TabularType 实例的哈希码值。
hashCode() - 类 javax.management.remote.JMXPrincipal 中的方法
返回此 JMXPrincipal 的哈希码。
hashCode() - 类 javax.management.remote.JMXServiceURL 中的方法
hashCode() - 类 javax.naming.BinaryRefAddr 中的方法
使用地址类型和内容计算此地址的哈希码。
hashCode() - 类 javax.naming.CompositeName 中的方法
计算此复合名称的哈希码。
hashCode() - 类 javax.naming.CompoundName 中的方法
计算此组合名称的哈希码。
hashCode() - 类 javax.naming.directory.BasicAttribute 中的方法
计算此属性的哈希码。
hashCode() - 类 javax.naming.directory.BasicAttributes 中的方法
计算此 BasicAttributes 的哈希码。
hashCode() - 类 javax.naming.ldap.LdapName 中的方法
计算此 LDAP 名称的哈希码。
hashCode() - 类 javax.naming.ldap.Rdn 中的方法
返回此 RDN 的哈希码。
hashCode() - 类 javax.naming.RefAddr 中的方法
使用地址类型和内容计算此地址的哈希码。
hashCode() - 类 javax.naming.Reference 中的方法
计算此引用的哈希码。
hashCode() - 接口 javax.print.attribute.AttributeSet 中的方法
返回此属性集的哈希码值。
hashCode() - 类 javax.print.attribute.DateTimeSyntax 中的方法
返回此日期-时间属性的哈希码值。
hashCode() - 类 javax.print.attribute.EnumSyntax 中的方法
返回此枚举值的哈希码值。
hashCode() - 类 javax.print.attribute.HashAttributeSet 中的方法
返回此属性集的哈希码值。
hashCode() - 类 javax.print.attribute.IntegerSyntax 中的方法
返回此整数属性的哈希码值。
hashCode() - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回此分辨率属性的哈希码值。
hashCode() - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
返回此整数集属性的哈希码值。
hashCode() - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性的哈希码值。
hashCode() - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
返回此属性的哈希码值。
hashCode() - 类 javax.print.attribute.TextSyntax 中的方法
返回此文本属性的哈希码。
hashCode() - 类 javax.print.attribute.URISyntax 中的方法
返回此 URI 属性的哈希码。
hashCode() - 类 javax.print.DocFlavor 中的方法
返回此 DocFlavor 对象的哈希码。
hashCode() - 接口 javax.print.PrintService 中的方法
此方法的实现方式应该与 equals(Object) 具有一致性。
hashCode() - 类 javax.rmi.CORBA.Stub 中的方法
返回对象的哈希码值，对于表示同一远程对象的所有 stub，其哈希码值是相等的。
hashCode(Stub) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.hashCode() 的委托调用。
hashCode() - 类 javax.rmi.ssl.SslRMIClientSocketFactory 中的方法
返回此 SslRMIClientSocketFactory 的哈希码值。
hashCode() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 中的方法
返回此 SslRMIServerSocketFactory 的哈希码值。
hashCode() - 类 javax.security.auth.kerberos.DelegationPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
返回此 KerberosKey 的哈希码。
hashCode() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
返回此主体的哈希码。
hashCode() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
返回此 KerberosTicket 的哈希码。
hashCode() - 类 javax.security.auth.kerberos.ServicePermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回此对象的哈希码值。
hashCode() - 类 javax.security.auth.Subject 中的方法
返回此 Subject 的哈希码。
hashCode() - 类 javax.security.auth.x500.X500Principal 中的方法
返回此 X500Principal 的哈希码。
hashCode() - 类 javax.security.cert.Certificate 中的方法
返回根据此证书的编码形式得出的证书的哈希码值。
hashCode() - 类 javax.sound.midi.MidiDevice.Info 中的方法
终结 hashcode 方法。
hashCode() - 类 javax.sound.midi.Sequencer.SyncMode 中的方法
终结 hashcode 方法。
hashCode() - 类 javax.sound.sampled.AudioFileFormat.Type 中的方法
终止 hashCode 方法
hashCode() - 类 javax.sound.sampled.AudioFormat.Encoding 中的方法
终止 hashCode 方法
hashCode() - 类 javax.sound.sampled.Control.Type 中的方法
终止 hashCode 方法
hashCode() - 类 javax.sound.sampled.LineEvent.Type 中的方法
终止 hashcode 方法。
hashCode() - 类 javax.sound.sampled.Mixer.Info 中的方法
终止该 hashcode 方法。
hashCode() - 类 javax.sound.sampled.Port.Info 中的方法
终止 hashCode 方法
hashCode() - 类 javax.sound.sampled.ReverbType 中的方法
终止 hashcode 方法。
hashCode() - 类 javax.swing.RowSorter.SortKey 中的方法
返回此 SortKey 的哈希码。
hashCode() - 类 javax.swing.text.html.HTML.UnknownTag 中的方法
返回对应于此标记的字符串的哈希代码。
hashCode() - 类 javax.swing.text.SimpleAttributeSet 中的方法
返回此属性集的哈希代码。
hashCode() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
返回此属性集的一个哈希代码。
hashCode() - 类 javax.swing.text.TabSet 中的方法
返回此 TabStop 集合的哈希代码。
hashCode() - 类 javax.swing.text.TabStop 中的方法
返回此对象的哈希代码。
hashCode() - 类 javax.swing.tree.TreePath 中的方法
返回该对象的 hashCode。
hashCode() - 类 javax.xml.datatype.Duration 中的方法
返回与 equals 方法的定义一致的哈希码。
hashCode() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回与 equals 方法的定义一致的哈希码。
hashCode() - 类 javax.xml.namespace.QName 中的方法
生成此 QName 的哈希码。
hashCode() - 类 org.ietf.jgss.ChannelBinding 中的方法
返回此 ChannelBinding 对象的哈希码值。
hashCode() - 接口 org.ietf.jgss.GSSCredential 中的方法
返回此 GSSCredential 的哈希码值。
hashCode() - 接口 org.ietf.jgss.GSSName 中的方法
返回此 GSSName 的哈希码值。
hashCode() - 类 org.ietf.jgss.Oid 中的方法
返回此 Oid 的哈希码值。
hashCode(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
提供重写委托 CORBA 对象的 hashCode() 方法的实现。
hashCode() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回此 ObjectImpl 对象的哈希码。
HashDocAttributeSet - javax.print.attribute 中的 类
类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
HashDocAttributeSet() - 类 javax.print.attribute.HashDocAttributeSet 的构造方法
构造一个新的空哈希文档属性集。
HashDocAttributeSet(DocAttribute) - 类 javax.print.attribute.HashDocAttributeSet 的构造方法
构造一个最初使用给定值填充的新哈希文档属性集。
HashDocAttributeSet(DocAttribute[]) - 类 javax.print.attribute.HashDocAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新哈希文档属性集。
HashDocAttributeSet(DocAttributeSet) - 类 javax.print.attribute.HashDocAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 DocAttribute 接口。
HashMap<K,V> - java.util 中的 类
基于哈希表的 Map 接口的实现。
HashMap(int, float) - 类 java.util.HashMap 的构造方法
构造一个带指定初始容量和加载因子的空 HashMap。
HashMap(int) - 类 java.util.HashMap 的构造方法
构造一个带指定初始容量和默认加载因子 (0.75) 的空 HashMap。
HashMap() - 类 java.util.HashMap 的构造方法
构造一个具有默认初始容量 (16) 和默认加载因子 (0.75) 的空 HashMap。
HashMap(Map<? extends K, ? extends V>) - 类 java.util.HashMap 的构造方法
构造一个映射关系与指定 Map 相同的新 HashMap。
HashPrintJobAttributeSet - javax.print.attribute 中的 类
类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
HashPrintJobAttributeSet() - 类 javax.print.attribute.HashPrintJobAttributeSet 的构造方法
构造一个新的空哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute) - 类 javax.print.attribute.HashPrintJobAttributeSet 的构造方法
构造一个最初使用给定值填充的新哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute[]) - 类 javax.print.attribute.HashPrintJobAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttributeSet) - 类 javax.print.attribute.HashPrintJobAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintJobAttribute 接口。
HashPrintRequestAttributeSet - javax.print.attribute 中的 类
类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
HashPrintRequestAttributeSet() - 类 javax.print.attribute.HashPrintRequestAttributeSet 的构造方法
构造一个新的空打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute) - 类 javax.print.attribute.HashPrintRequestAttributeSet 的构造方法
构造一个最初使用给定值填充的新打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute[]) - 类 javax.print.attribute.HashPrintRequestAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttributeSet) - 类 javax.print.attribute.HashPrintRequestAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 (PrintRequestAttributeSe 接口。
HashPrintServiceAttributeSet - javax.print.attribute 中的 类
类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。
HashPrintServiceAttributeSet() - 类 javax.print.attribute.HashPrintServiceAttributeSet 的构造方法
构造一个新的空哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute) - 类 javax.print.attribute.HashPrintServiceAttributeSet 的构造方法
构造一个最初使用给定值填充的新哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute[]) - 类 javax.print.attribute.HashPrintServiceAttributeSet 的构造方法
构造一个最初使用给定数组中的值填充的新打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttributeSet) - 类 javax.print.attribute.HashPrintServiceAttributeSet 的构造方法
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintServiceAttribute 接口。
HashSet<E> - java.util 中的 类
此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
HashSet() - 类 java.util.HashSet 的构造方法
构造一个新的空 set，其底层 HashMap 实例的默认初始容量是 16，加载因子是 0.75。
HashSet(Collection<? extends E>) - 类 java.util.HashSet 的构造方法
构造一个包含指定 collection 中的元素的新 set。
HashSet(int, float) - 类 java.util.HashSet 的构造方法
构造一个新的空 set，其底层 HashMap 实例具有指定的初始容量和指定的加载因子。
HashSet(int) - 类 java.util.HashSet 的构造方法
构造一个新的空 set，其底层 HashMap 实例具有指定的初始容量和默认的加载因子（0.75）。
Hashtable<K,V> - java.util 中的 类
此类实现一个哈希表，该哈希表将键映射到相应的值。
Hashtable(int, float) - 类 java.util.Hashtable 的构造方法
用指定初始容量和指定加载因子构造一个新的空哈希表。
Hashtable(int) - 类 java.util.Hashtable 的构造方法
用指定初始容量和默认的加载因子 (0.75) 构造一个新的空哈希表。
Hashtable() - 类 java.util.Hashtable 的构造方法
用默认的初始容量 (11) 和加载因子 (0.75) 构造一个新的空哈希表。
Hashtable(Map<? extends K, ? extends V>) - 类 java.util.Hashtable 的构造方法
构造一个与给定的 Map 具有相同映射关系的新哈希表。
hasInitialContextFactoryBuilder() - 类 javax.naming.spi.NamingManager 中的静态方法
确定是否已经设置了初始上下文工厂生成器。
hasInitialResponse() - 接口 javax.security.sasl.SaslClient 中的方法
确定此机制是否具有可选的初始响应。
hasLayoutAttributes() - 类 java.awt.Font 中的方法
如果此 Font 包含需要额外布局处理的属性，则返回 true。
hasLegalValues() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的合法值集，则返回 true，否则返回 false。
hasLegalValues() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
如果此参数存在指定的合法值的集合，则返回 true，否则返回 false。
hasLegalValues() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的合法值集，则返回 true，否则返回 false。
hasListeners(String) - 类 java.beans.PropertyChangeSupport 中的方法
检查是否存在特定属性的任何侦听器，包括那些已在所有属性上注册的侦听器。
hasListeners(String) - 类 java.beans.VetoableChangeSupport 中的方法
检查是否存在特定属性的侦听器，包括那些已在所有属性上注册的侦听器。
hasLocation(JavaFileManager.Location) - 类 javax.tools.ForwardingJavaFileManager 中的方法
hasLocation(JavaFileManager.Location) - 接口 javax.tools.JavaFileManager 中的方法
确定此文件管理器是否已知某位置。
hasMaxValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的最大值，则返回 true，否则返回 false。
hasMaxValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
如果此参数存在指定的最大值，则返回 true，否则返回 false。
hasMaxValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的最大值，则返回 true，否则返回 false。
hasMinValue() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的最小值，则返回 true，否则返回 false。
hasMinValue() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
如果此参数存在指定的最小值，则返回 true，否则返回 false。
hasMinValue() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
如果此 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的最小值，则返回 true，否则返回 false。
hasMore() - 接口 javax.naming.NamingEnumeration 中的方法
确定枚举中是否还有元素。
hasMoreElements() - 接口 java.util.Enumeration 中的方法
测试此枚举是否包含更多的元素。
hasMoreElements() - 类 java.util.StringTokenizer 中的方法
返回与 hasMoreTokens 方法相同的值。
hasMoreTokens() - 类 java.util.StringTokenizer 中的方法
测试此 tokenizer 的字符串中是否还有更多的可用标记。
hasName() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
hasName() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果当前事件有名称（是 START_ELEMENT 或 END_ELEMENT），则返回 ture，否则返回 false
hasNext() - 类 java.beans.beancontext.BeanContextSupport.BCSIterator 中的方法
hasNext() - 接口 java.util.Iterator 中的方法
如果仍有元素可以迭代，则返回 true。
hasNext() - 接口 java.util.ListIterator 中的方法
以正向遍历列表时，如果列表迭代器有多个元素，则返回 true（换句话说，如果 next 返回一个元素而不是抛出异常，则返回 true）。
hasNext() - 类 java.util.Scanner 中的方法
如果此扫描器的输入中有另一个标记，则返回 true。
hasNext(String) - 类 java.util.Scanner 中的方法
如果下一个标记与从指定字符串构造的模式匹配，则返回 true。
hasNext(Pattern) - 类 java.util.Scanner 中的方法
如果下一个完整标记与指定模式匹配，则返回 true。
hasNext() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
hasNext() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
hasNext() - 接口 javax.xml.stream.XMLEventReader 中的方法
检查是否有多个事件。
hasNext() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果有多个解析事件，则返回 true，如果不再有事件，则返回 false。
hasNextBigDecimal() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextBigDecimal() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 BigDecimal，则返回 true。
hasNextBigInteger() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextBigInteger() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 BigInteger 值，则返回 true。
hasNextBigInteger(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextBigInteger() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 BigInteger 值，则返回 true。
hasNextBoolean() - 类 java.util.Scanner 中的方法
如果通过使用一个从字符串 "true|false" 创建的大小写敏感的模式，此扫描器输入信息中的下一个标记可以解释为一个布尔值，则返回 true。
hasNextByte() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextByte() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个字节值，则返回 true。
hasNextByte(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextByte() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个字节值，则返回 true。
hasNextDouble() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextDouble() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 double 值，则返回 true。
hasNextFloat() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextFloat() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 float 值，则返回 true。
hasNextInt() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextInt() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 int 值，则返回 true。
hasNextInt(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextInt() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 int 值，则返回 true。
hasNextLine() - 类 java.util.Scanner 中的方法
如果在此扫描器的输入中存在另一行，则返回 true。
hasNextLong() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextLong() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 long 值，则返回 true。
hasNextLong(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextLong() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 long 值，则返回 true。
hasNextShort() - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextShort() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 short 值，则返回 true。
hasNextShort(int) - 类 java.util.Scanner 中的方法
如果通过使用 Scanner.nextShort() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 short 值，则返回 true。
hasPrevious() - 接口 java.util.ListIterator 中的方法
如果以逆向遍历列表，列表迭代器有多个元素，则返回 true。
hasQueuedThread(Thread) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询给定线程是否正在等待获取此锁。
hasQueuedThread(Thread) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询是否给定线程正在等待获取读取或写入锁。
hasQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
查询是否有等待获取的线程。
hasQueuedThreads() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
查询是否有正在等待获取的任何线程。
hasQueuedThreads() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询是否有些线程正在等待获取此锁。
hasQueuedThreads() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询是否所有的线程正在等待获取读取或写入锁。
hasQueuedThreads() - 类 java.util.concurrent.Semaphore 中的方法
查询是否有线程正在等待获取。
hasRaster() - 类 javax.imageio.IIOImage 中的方法
如果此 IIOImage 存储了一个 Raster 而不是 RenderedImage，则返回 true。
hasRelation(String) - 类 javax.management.relation.RelationService 中的方法
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
hasRelation(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
hasRemaining() - 类 java.nio.Buffer 中的方法
告知在当前位置和限制之间是否有元素。
hasSameRules(TimeZone) - 类 java.util.SimpleTimeZone 中的方法
如果此时区与另一时区具有相同的规则和偏移量，则返回 true。
hasSameRules(TimeZone) - 类 java.util.TimeZone 中的方法
如果此区域和另一个区域具有相同的规则和偏移量，也就是说，如果此区域只可能在 ID 上与另一个区域不同，则返回 true。
hasService(Class) - 接口 java.beans.beancontext.BeanContextServices 中的方法
报告是否可以从此上下文中得到给定服务。
hasService(Class) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
具有一个可被委托的服务。
hasText() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
hasText() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果当前事件具有文本，则返回 true，否则返回 false。
hasThumbnails(int) - 类 javax.imageio.ImageReader 中的方法
如果给定图像具有与之关联的缩略图预览图像，则返回 true。
hasTileWriters() - 类 java.awt.image.BufferedImage 中的方法
返回是否有为写入签出的 tile。
hasTileWriters() - 接口 java.awt.image.WritableRenderedImage 中的方法
返回是否有为写入而签出的 tile。
hasTransparentBounds() - 类 java.util.regex.Matcher 中的方法
查询此匹配器区域边界的透明度。
hasUniformLineMetrics() - 类 java.awt.Font 中的方法
检查此 Font 是否具有统一的行规格。
hasUniformLineMetrics() - 类 java.awt.FontMetrics 中的方法
检查 Font 是否具有统一的行规格。
hasUnsupportedCriticalExtension() - 接口 java.security.cert.X509Extension 中的方法
检查是否存在不支持的关键扩展。
hasWaiters() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
查询是否有线程正在此条件等待。
hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
查询是否有线程正在与此同步器关联的给定条件上等待。
hasWaiters() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
查询是否有正在等待此条件的任何线程。
hasWaiters(AbstractQueuedSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
查询是否有线程正在等待给定的、与此同步器相关的条件。
hasWaiters(Condition) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询是否有些线程正在等待与此锁有关的给定条件。
hasWaiters(Condition) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询是否有些线程正在等待与写入锁有关的给定条件。
HEAD - 类 javax.swing.text.html.HTML.Tag 中的静态变量
head - 类 javax.swing.text.html.parser.DTD 中的变量
HEADER - 类 javax.accessibility.AccessibleRole 中的静态变量
文本标题
header - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的变量
要将绘制委托给此 UI 的 JTableHeader。
HEADER_RENDERER_PROPERTY - 类 javax.swing.table.TableColumn 中的静态变量
从 Java 2 platform v1.3 开始已过时。
HEADER_ROW - 类 javax.swing.event.TableModelEvent 中的静态变量
标识标题行。
HEADER_VALUE_PROPERTY - 类 javax.swing.table.TableColumn 中的静态变量
从 Java 2 platform v1.3 开始已过时。
headerRenderer - 类 javax.swing.table.TableColumn 中的变量
用于绘制列标题的渲染器。
headerValue - 类 javax.swing.table.TableColumn 中的变量
列的标题值。
HeadlessException - java.awt 中的 异常
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
HeadlessException() - 异常 java.awt.HeadlessException 的构造方法
HeadlessException(String) - 异常 java.awt.HeadlessException 的构造方法
headMap(K, boolean) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
headMap(K) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
headMap(K, boolean) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
headMap(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
headMap(K, boolean) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。
headMap(K) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键值严格小于 toKey。
headMap(K) - 接口 java.util.SortedMap 中的方法
返回此映射的部分视图，其键值严格小于 toKey。
headMap(K, boolean) - 类 java.util.TreeMap 中的方法
headMap(K) - 类 java.util.TreeMap 中的方法
HEADPHONE - 类 javax.sound.sampled.Port.Info 中的静态变量
向耳机插孔发送音频端口类型。
headSet(E, boolean) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
headSet(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
headSet(E, boolean) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。
headSet(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素严格小于 toElement。
headSet(E) - 接口 java.util.SortedSet 中的方法
返回此 set 的部分视图，其元素严格小于 toElement。
headSet(E, boolean) - 类 java.util.TreeSet 中的方法
headSet(E) - 类 java.util.TreeSet 中的方法
heavyWeightPopupEnabled - 类 javax.swing.ToolTipManager 中的变量
HEBREW - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hebrew”Unicode 字符块的常量。
height - 类 java.awt.Component.BltBufferStrategy 中的变量
height - 类 java.awt.Dimension 中的变量
dimension 的高度，可以使用负值。
height - 类 java.awt.geom.Arc2D.Double 中的变量
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。
height - 类 java.awt.geom.Arc2D.Float 中的变量
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。
height - 类 java.awt.geom.Ellipse2D.Double 中的变量
此 Ellipse2D 的总高度。
height - 类 java.awt.geom.Ellipse2D.Float 中的变量
此 Ellipse2D 的总高度。
height - 类 java.awt.geom.Rectangle2D.Double 中的变量
此 Rectangle2D 的高度。
height - 类 java.awt.geom.Rectangle2D.Float 中的变量
此 Rectangle2D 的高度。
height - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
此 RoundRectangle2D 的高度。
height - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
此 RoundRectangle2D 的高度。
HEIGHT - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示基本图像的高度现在可用，并且可从 height 参数中获取此高度到 imageUpdate 回调方法。
height - 类 java.awt.image.Raster 中的变量
此 Raster 的高度。
height - 类 java.awt.image.SampleModel 中的变量
此 SampleModel 描述的图像数据区域的高度（以像素位单位）。
height - 类 java.awt.Rectangle 中的变量
Rectangle 的高度。
height(Component) - 类 javax.swing.Spring 中的静态方法
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的高度定义。
HEIGHT - 类 javax.swing.SpringLayout 中的静态变量
指定组件边界矩形的高度。
HEIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
HEIGHT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
helpButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
helpButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
helpButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
HexBinaryAdapter - javax.xml.bind.annotation.adapters 中的 类
xs:hexBinary 的 XmlAdapter。
HexBinaryAdapter() - 类 javax.xml.bind.annotation.adapters.HexBinaryAdapter 的构造方法
hiddenDivider - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
用于非连续布局模式的分隔符。
hide() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
hide() - 类 java.awt.Dialog 中的方法
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
hide() - 类 java.awt.Window 中的方法
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
hide() - 类 javax.swing.JInternalFrame 中的方法
hide() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.hide() 的实现。
hide() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
隐藏弹出菜单
hide() - 类 javax.swing.Popup 中的方法
隐藏和移除 Popup。
HIDE_ON_CLOSE - 接口 javax.swing.WindowConstants 中的静态变量
隐藏窗口的默认窗口关闭操作
hidePopup() - 类 javax.swing.JComboBox 中的方法
促使组合框关闭其弹出窗口。
hides(Element, Element) - 接口 javax.lang.model.util.Elements 中的方法
测试一个类型、方法或字段是否隐藏了另一个类型、方法或字段。
hideWindows() - 接口 java.awt.im.spi.InputMethod 中的方法
关闭或隐藏由此输入方法实例或其类打开的所有窗口。
HIERARCHY_BOUNDS_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择层次结构边界事件的事件掩码。
HIERARCHY_CHANGED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示对整个层次结构树进行修改的事件 id。
HIERARCHY_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择层次结构事件的事件掩码。
HIERARCHY_FIRST - 类 java.awt.event.HierarchyEvent 中的静态变量
标记层次结构事件 id 范围的第一个整数 id。
HIERARCHY_LAST - 类 java.awt.event.HierarchyEvent 中的静态变量
标记祖先事件 id 范围的最后一个整数 id。
HIERARCHY_REQUEST_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果在不属于 Node 的位置将任何 Node 插入。
HierarchyBoundsAdapter - java.awt.event 中的 类
用于接收祖先的移动和大小重调事件的抽象适配器类。
HierarchyBoundsAdapter() - 类 java.awt.event.HierarchyBoundsAdapter 的构造方法
HierarchyBoundsListener - java.awt.event 中的 接口
用于接收祖先的移动和大小调整事件的侦听器接口。
hierarchyChanged(HierarchyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 hierarchyChanged 方法处理 hierarchyChanged 事件。
hierarchyChanged(HierarchyEvent) - 接口 java.awt.event.HierarchyListener 中的方法
层次结构已更改时调用。
HierarchyEvent - java.awt.event 中的 类
指示 Component 所属的 Component 层次结构发生更改的事件。
HierarchyEvent(Component, int, Component, Container) - 类 java.awt.event.HierarchyEvent 的构造方法
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyEvent(Component, int, Component, Container, long) - 类 java.awt.event.HierarchyEvent 的构造方法
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyListener - java.awt.event 中的 接口
用于接收层次结构更改事件的侦听器接口。
HIGH - 类 java.awt.PageAttributes.PrintQualityType 中的静态变量
用于指定高打印质量的 PrintQualityType 实例。
HIGH - 类 javax.print.attribute.standard.PrintQuality 中的静态变量
打印机可提供的最高打印质量。
HIGH_PRIVATE_USE_SURROGATES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“High Private Use Surrogates”Unicode 字符块的常量。
HIGH_SURROGATES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“High Surrogates”Unicode 字符块的常量。
higher(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
higher(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 中严格大于给定元素的最小元素；如果不存在这样的元素，则返回 null。
higher(E) - 类 java.util.TreeSet 中的方法
higherEntry(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与严格大于给定键的最小键关联的键-值映射关系；如果不存在这样的键，则返回 null。
higherEntry(K) - 接口 java.util.NavigableMap 中的方法
返回一个键-值映射关系，它与严格大于给定键的最小键关联；如果不存在这样的键，则返回 null。
higherEntry(K) - 类 java.util.TreeMap 中的方法
higherKey(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
higherKey(K) - 接口 java.util.NavigableMap 中的方法
返回严格大于给定键的最小键；如果不存在这样的键，则返回 null。
higherKey(K) - 类 java.util.TreeMap 中的方法
highestLayer() - 类 javax.swing.JLayeredPane 中的方法
返回所有当前子组件的最高层值。
highestOneBit(int) - 类 java.lang.Integer 中的静态方法
返回具有至多单个 1 位的 int 值，在指定的 int 值中最高位（最左边）的 1 位的位置。
highestOneBit(long) - 类 java.lang.Long 中的静态方法
返回至多有一个 1 位的 long 值，在指定的 long 值中最高位（最左边）的 1 位的位置。
highlight - 类 javax.swing.border.EtchedBorder 中的变量
highlight - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的变量
highlight - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的变量
highlight - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的变量
highlight - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的变量
highlight - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
highlightColor - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
Highlighter - javax.swing.text 中的 接口
一个允许用户用带有颜色的区域标出背景的对象接口。
Highlighter.Highlight - javax.swing.text 中的 接口
Highlighter.HighlightPainter - javax.swing.text 中的 接口
呈现高亮显示。
highlightInner - 类 javax.swing.border.BevelBorder 中的变量
highlightOuter - 类 javax.swing.border.BevelBorder 中的变量
HINTS_OBSERVED - 接口 java.awt.image.renderable.RenderableImage 中的静态变量
可以用于在通过 createRendering 或 createScaledRendering 方法获取的 RenderedImage 上标识属性的字符串常量。
HIRAGANA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Hiragana”Unicode 字符块的常量。
hit(Rectangle, Shape, boolean) - 类 java.awt.Graphics2D 中的方法
检查指定的 Shape 是否与设备空间中的指定 Rectangle 相交。
hitClip(int, int, int, int) - 类 java.awt.Graphics 中的方法
如果指定的矩形区域与当前的剪贴区域相交，则返回 true。
hitEnd() - 类 java.util.regex.Matcher 中的方法
如果匹配器执行的最后匹配操作中搜索引擎遇到输入结尾，则返回 true。
hitTestChar(float, float, Rectangle2D) - 类 java.awt.font.TextLayout 中的方法
返回对应于指定点的 TextHitInfo。
hitTestChar(float, float) - 类 java.awt.font.TextLayout 中的方法
返回对应于指定点的 TextHitInfo。
hitToPoint(TextHitInfo, Point2D) - 类 java.awt.font.TextLayout 中的方法
将一个命中点转换为标准坐标中的一个点。
HMAC_SHA1 - 接口 javax.xml.crypto.dsig.SignatureMethod 中的静态变量
HMAC-SHA1 MAC 签名方法的算法 URI。
HMACParameterSpec - javax.xml.crypto.dsig.spec 中的 类
XML Signature HMAC Algorithm 的参数。
HMACParameterSpec(int) - 类 javax.xml.crypto.dsig.spec.HMACParameterSpec 的构造方法
创建具有指定截断长度的 HMACParameterSpec。
HOLD_CURSORS_OVER_COMMIT - 接口 java.sql.ResultSet 中的静态变量
该常量指示提交当前事务时，具有此可保存性的打开的 ResultSet 对象将保持开放。
hold_requests(boolean) - 接口 org.omg.PortableServer.POAManagerOperations 中的方法
此操作将 POA 管理器更改为保持 (holding) 状态，促使关联的 POA 将传入请求排队。
Holder<T> - javax.xml.ws 中的 类
包含类型为 T 的值。
Holder() - 类 javax.xml.ws.Holder 的构造方法
创建一个新的持有者，其值为 null。
Holder(T) - 类 javax.xml.ws.Holder 的构造方法
创建具有指定值的新持有者。
HOLDING - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/HOLDING.java。
HOLDING - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
holdsLock(Object) - 类 java.lang.Thread 中的静态方法
当且仅当当前线程在指定的对象上保持监视器锁时，才返回 true。
HOME - 类 java.awt.Event 中的静态变量
Home 键，一个非 ASCII 操作键。
homeFolderIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
homeKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
HONOR_DISPLAY_PROPERTIES - 类 javax.swing.JEditorPane 中的静态变量
用于客户机属性的关键字，指示如果在样式化文本中未指定字体或前景色，那么是否使用该组件的默认字体和前景色。
HORIZONTAL - 接口 java.awt.Adjustable 中的静态变量
指示 Adjustable 具有水平方向。
HORIZONTAL - 类 java.awt.GridBagConstraints 中的静态变量
在水平方向而不是垂直方向上调整组件大小。
HORIZONTAL - 类 java.awt.Scrollbar 中的静态变量
指示一个水平滚动条的常量。
HORIZONTAL - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象的方向为水平方向。
HORIZONTAL - 接口 javax.swing.SwingConstants 中的静态变量
水平方向。
HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的水平对齐方式的更改。
HORIZONTAL_CENTER - 类 javax.swing.SpringLayout 中的静态变量
指定组件边界矩形的水平中央位置。
HORIZONTAL_SCROLLBAR - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识水平滚动条。
HORIZONTAL_SCROLLBAR_ALWAYS - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置水平滚动条策略以使水平滚动条一直显示。
HORIZONTAL_SCROLLBAR_AS_NEEDED - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置水平滚动条策略以使水平滚动条只在需要时显示。
HORIZONTAL_SCROLLBAR_NEVER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置水平滚动条策略以使水平滚动条从不显示。
HORIZONTAL_SCROLLBAR_POLICY - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识水平滚动条策略属性。
HORIZONTAL_SPLIT - 类 javax.swing.JSplitPane 中的静态变量
水平分割表示 Component 沿 x 轴分割。
HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的水平文本位置的更改。
HORIZONTAL_WRAP - 类 javax.swing.JList 中的静态变量
指示“报纸样式”布局，单元按先水平后垂直排列。
horizontalScrollBar - 类 javax.swing.JScrollPane 中的变量
滚动窗格的水平滚动条子级。
horizontalScrollBarPolicy - 类 javax.swing.JScrollPane 中的变量
用于水平滚动条的显示策略。
horizThumbIcon - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
默认水平 thumb Icon。
hostEncoding - 类 javax.print.DocFlavor 中的静态变量
表示主机操作系统编码的 String。
HostnameVerifier - javax.net.ssl 中的 接口
此类是用于主机名验证的基接口。
hostnameVerifier - 类 javax.net.ssl.HttpsURLConnection 中的变量
此对象的 hostnameVerifier。
hostsEqual(URL, URL) - 类 java.net.URLStreamHandler 中的方法
比较两个 URL 的主机组件。
HOUR - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示上午或下午的小时。
HOUR0 - 类 java.text.DateFormat.Field 中的静态变量
标识 HOUR0 字段的常量，其合法的值是 1 到 11。
HOUR0_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐从 0 开始的 HOUR 字段的有用常量。
HOUR1 - 类 java.text.DateFormat.Field 中的静态变量
标识 HOUR1 字段的常量，其合法的值是 1 到 12。
HOUR1_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐从 1 开始的 HOUR 字段的有用常量。
HOUR_OF_DAY - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一天中的小时。
HOUR_OF_DAY0 - 类 java.text.DateFormat.Field 中的静态变量
标识 HOUR_OF_DAY0 字段的常量，其合法的值是 0 到 23。
HOUR_OF_DAY0_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐从 0 开始的 HOUR_OF_DAY 字段的有用常量。
HOUR_OF_DAY1 - 类 java.text.DateFormat.Field 中的静态变量
标识 HOUR_OF_DAY1 字段的常量，其合法的值是 1 到 24。
HOUR_OF_DAY1_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐从 1 开始的 HOUR_OF_DAY 字段的有用常量。
HOURS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示小时字段的常量。
HR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
HREF - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
hsb - 类 javax.swing.ScrollPaneLayout 中的变量
滚动窗格的子级水平滚动条。
hsbChangeListener - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
hsbPolicy - 类 javax.swing.ScrollPaneLayout 中的变量
水平滚动条的显示策略。
HSBtoRGB(float, float, float) - 类 java.awt.Color 中的静态方法
将由 HSB 模型指定的颜色分量转换为等价的默认 RGB 模型的值的集合。
HSPACE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
HTML - javax.swing.text.html 中的 类
HTMLDocument 中使用的常量。
HTML() - 类 javax.swing.text.html.HTML 的构造方法
HTML - 类 javax.swing.text.html.HTML.Tag 中的静态变量
html - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
要插入的 HTML。
html - 类 javax.swing.text.html.parser.DTD 中的变量
HTML.Attribute - javax.swing.text.html 中的 类
表示 HTML 属性的类型安全的枚举。
HTML.Tag - javax.swing.text.html 中的 类
HTML 标记的类型安全的枚举。
HTML.Tag() - 类 javax.swing.text.html.HTML.Tag 的构造方法
HTML.Tag(String) - 类 javax.swing.text.html.HTML.Tag 的构造方法
创建具有指定 id 的新 Tag，且 causesBreak 和 isBlock 设置为 false。
HTML.Tag(String, boolean, boolean) - 类 javax.swing.text.html.HTML.Tag 的构造方法
创建具有指定 id 的新 Tag；causesBreak 和 isBlock 由用户定义。
HTML.UnknownTag - javax.swing.text.html 中的 类
HTML.UnknownTag(String) - 类 javax.swing.text.html.HTML.UnknownTag 的构造方法
创建具有指定 id 的新 UnknownTag。
HTML_CONTAINER - 类 javax.accessibility.AccessibleRole 中的静态变量
包含一起能表示 HTML 内容的 Accessible 集合的对象。
HTMLDocument - javax.swing.text.html 中的 类
对 HTML 进行建模的文档。
HTMLDocument() - 类 javax.swing.text.html.HTMLDocument 的构造方法
使用默认的缓冲区大小和默认的 StyleSheet 构造 HTML 文档。
HTMLDocument(StyleSheet) - 类 javax.swing.text.html.HTMLDocument 的构造方法
构造具有默认内容存储实现和指定样式/属性存储机制的 HTML 文档。
HTMLDocument(AbstractDocument.Content, StyleSheet) - 类 javax.swing.text.html.HTMLDocument 的构造方法
构造具有给定内容存储实现和给定样式/属性存储机制的 HTML 文档。
HTMLDocument.BlockElement - javax.swing.text.html 中的 类
表示结构性 HTML 块 的元素。
HTMLDocument.BlockElement(Element, AttributeSet) - 类 javax.swing.text.html.HTMLDocument.BlockElement 的构造方法
构造初始不包含子元素的复合元素。
HTMLDocument.HTMLReader - javax.swing.text.html 中的 类
一个 HTML reader，用来加载具有 HTML 元素结构的 HTML 文档。
HTMLDocument.HTMLReader(int) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 的构造方法
HTMLDocument.HTMLReader(int, int, int, HTML.Tag) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 的构造方法
HTMLDocument.HTMLReader.BlockAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.BlockAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction 的构造方法
HTMLDocument.HTMLReader.CharacterAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.CharacterAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 的构造方法
HTMLDocument.HTMLReader.FormAction - javax.swing.text.html 中的 类
此动作通过构建所有用于表示表单控件的元素来支持表单。
HTMLDocument.HTMLReader.FormAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 的构造方法
HTMLDocument.HTMLReader.HiddenAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.HiddenAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 的构造方法
HTMLDocument.HTMLReader.IsindexAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.IsindexAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction 的构造方法
HTMLDocument.HTMLReader.ParagraphAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.ParagraphAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 的构造方法
HTMLDocument.HTMLReader.PreAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.PreAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 的构造方法
HTMLDocument.HTMLReader.SpecialAction - javax.swing.text.html 中的 类
HTMLDocument.HTMLReader.SpecialAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction 的构造方法
HTMLDocument.HTMLReader.TagAction - javax.swing.text.html 中的 类
为响应对标记的解析而执行的动作。
HTMLDocument.HTMLReader.TagAction() - 类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 的构造方法
HTMLDocument.Iterator - javax.swing.text.html 中的 类
对特定类型的标记进行迭代的迭代器。
HTMLDocument.Iterator() - 类 javax.swing.text.html.HTMLDocument.Iterator 的构造方法
HTMLDocument.RunElement - javax.swing.text.html 中的 类
表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。
HTMLDocument.RunElement(Element, AttributeSet, int, int) - 类 javax.swing.text.html.HTMLDocument.RunElement 的构造方法
构造表示文档内部（没有子级）内容的元素。
HTMLEditorKit - javax.swing.text.html 中的 类
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。
HTMLEditorKit() - 类 javax.swing.text.html.HTMLEditorKit 的构造方法
构造 HTMLEditorKit，创建 StyleContext，并加载样式表。
HTMLEditorKit.HTMLFactory - javax.swing.text.html 中的 类
用于构建 HTML 视图的工厂。
HTMLEditorKit.HTMLFactory() - 类 javax.swing.text.html.HTMLEditorKit.HTMLFactory 的构造方法
HTMLEditorKit.HTMLTextAction - javax.swing.text.html 中的 类
提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
HTMLEditorKit.HTMLTextAction(String) - 类 javax.swing.text.html.HTMLEditorKit.HTMLTextAction 的构造方法
HTMLEditorKit.InsertHTMLTextAction - javax.swing.text.html 中的 类
InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
HTMLEditorKit.InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 的构造方法
HTMLEditorKit.InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag, HTML.Tag, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 的构造方法
HTMLEditorKit.LinkController - javax.swing.text.html 中的 类
此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。
HTMLEditorKit.LinkController() - 类 javax.swing.text.html.HTMLEditorKit.LinkController 的构造方法
HTMLEditorKit.Parser - javax.swing.text.html 中的 类
解析器要支持的接口。
HTMLEditorKit.Parser() - 类 javax.swing.text.html.HTMLEditorKit.Parser 的构造方法
HTMLEditorKit.ParserCallback - javax.swing.text.html 中的 类
解析结果驱动这些回调方法。
HTMLEditorKit.ParserCallback() - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 的构造方法
HTMLFrameHyperlinkEvent - javax.swing.text.html 中的 类
HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的构造方法
创建一个表示 html 框架超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, String) - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, Element, String) - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, String) - 类 javax.swing.text.html.HTMLFrameHyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HTMLWriter - javax.swing.text.html 中的 类
这是用于 HTMLDocuments 的 writer。
HTMLWriter(Writer, HTMLDocument) - 类 javax.swing.text.html.HTMLWriter 的构造方法
创建新的 HTMLWriter。
HTMLWriter(Writer, HTMLDocument, int, int) - 类 javax.swing.text.html.HTMLWriter 的构造方法
创建新的 HTMLWriter。
HTTP - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
超文本传输协议 (HTTP)。
HTTP_ACCEPTED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 202：Accepted。
HTTP_BAD_GATEWAY - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 502：Bad Gateway。
HTTP_BAD_METHOD - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 405：Method Not Allowed。
HTTP_BAD_REQUEST - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 400：Bad Request。
HTTP_BINDING - 接口 javax.xml.ws.http.HTTPBinding 中的静态变量
表示 XML/HTTP 绑定标识的常量。
HTTP_CLIENT_TIMEOUT - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 408：Request Time-Out。
HTTP_CONFLICT - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 409：Conflict。
HTTP_CREATED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 201：Created。
HTTP_ENTITY_TOO_LARGE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 413：Request Entity Too Large。
HTTP_FORBIDDEN - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 403：Forbidden。
HTTP_GATEWAY_TIMEOUT - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 504：Gateway Timeout。
HTTP_GONE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 410：Gone。
HTTP_INTERNAL_ERROR - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 500：Internal Server Error。
HTTP_LENGTH_REQUIRED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 411：Length Required。
HTTP_MOVED_PERM - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 301：Moved Permanently。
HTTP_MOVED_TEMP - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 302：Temporary Redirect。
HTTP_MULT_CHOICE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 300：Multiple Choices。
HTTP_NO_CONTENT - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 204：No Content。
HTTP_NOT_ACCEPTABLE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 406：Not Acceptable。
HTTP_NOT_AUTHORITATIVE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 203：Non-Authoritative Information。
HTTP_NOT_FOUND - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 404：Not Found。
HTTP_NOT_IMPLEMENTED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 501：Not Implemented。
HTTP_NOT_MODIFIED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 304：Not Modified。
HTTP_OK - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 200：OK。
HTTP_PARTIAL - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 206：Partial Content。
HTTP_PAYMENT_REQUIRED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 402：Payment Required。
HTTP_PRECON_FAILED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 412：Precondition Failed。
HTTP_PROXY_AUTH - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 407：Proxy Authentication Required。
HTTP_REQ_TOO_LONG - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 414：Request-URI Too Large。
HTTP_REQUEST_HEADERS - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：HTTP 请求头。
HTTP_REQUEST_METHOD - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：HTTP 请求方法。
HTTP_RESET - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 205：Reset Content。
HTTP_RESPONSE_CODE - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：HTTP 响应状态代码。
HTTP_RESPONSE_HEADERS - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：HTTP 响应头。
HTTP_SEE_OTHER - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 303：See Other。
HTTP_SERVER_ERROR - 类 java.net.HttpURLConnection 中的静态变量
已过时。 放错了位置，它不应该存在。
HTTP_UNAUTHORIZED - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 401：Unauthorized。
HTTP_UNAVAILABLE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 503：Service Unavailable。
HTTP_UNSUPPORTED_TYPE - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 415：Unsupported Media Type。
HTTP_USE_PROXY - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 305：Use Proxy。
HTTP_VERSION - 类 java.net.HttpURLConnection 中的静态变量
HTTP 状态码 505：HTTP Version Not Supported。
HTTPBinding - javax.xml.ws.http 中的 接口
HTTPBinding 接口是 XML/HTTP 绑定的抽象。
HttpCookie - java.net 中的 类
HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。
HttpCookie(String, String) - 类 java.net.HttpCookie 的构造方法
构造带有指定名称和值的 cookie。
HTTPEQUIV - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
HTTPException - javax.xml.ws.http 中的 异常
HTTPException 异常表示一个 XML/HTTP 故障。
HTTPException(int) - 异常 javax.xml.ws.http.HTTPException 的构造方法
HTTPException 的构造方法
HttpRetryException - java.net 中的 异常
抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
HttpRetryException(String, int) - 异常 java.net.HttpRetryException 的构造方法
根据指定的响应代码和异常详细消息构造新 HttpRetryException。
HttpRetryException(String, int, String) - 异常 java.net.HttpRetryException 的构造方法
构造一个新 HttpRetryException，使其具有详细消息 responseCode 和 Location 响应头字段的内容。
HTTPS - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
安全超文本传输协议 (HTTPS)。
HttpsURLConnection - javax.net.ssl 中的 类
HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。
HttpsURLConnection(URL) - 类 javax.net.ssl.HttpsURLConnection 的构造方法
使用指定的 URL 创建 HttpsURLConnection。
HttpURLConnection - java.net 中的 类
支持 HTTP 特定功能的 URLConnection。
HttpURLConnection(URL) - 类 java.net.HttpURLConnection 的构造方法
HttpURLConnection 的构造方法。
HUFFMAN_ONLY - 类 java.util.zip.Deflater 中的静态变量
仅适用于 Huffman 编码的压缩策略。
HYPERLINK - 类 javax.accessibility.AccessibleRole 中的静态变量
超文本锚
HyperlinkEvent - javax.swing.event 中的 类
HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL) - 类 javax.swing.event.HyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - 类 javax.swing.event.HyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element) - 类 javax.swing.event.HyperlinkEvent 的构造方法
创建一个表示超文本链接事件的新对象。
HyperlinkEvent.EventType - javax.swing.event 中的 类
定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。
HyperlinkListener - javax.swing.event 中的 接口
HyperlinkListener
hyperlinkUpdate(HyperlinkEvent) - 接口 javax.swing.event.HyperlinkListener 中的方法
在更新超文本链接时调用。
hypot(double, double) - 类 java.lang.Math 中的静态方法
返回 sqrt(x2 +y2)，没有中间溢出或下溢。
hypot(double, double) - 类 java.lang.StrictMath 中的静态方法
返回 sqrt(x2 +y2)，没有中间溢出或下溢。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


I - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

I

I - 类 javax.swing.text.html.HTML.Tag 中的静态变量
icAbsoluteColorimetric - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：AbsoluteColorimetric。
ICC_ColorSpace - java.awt.color 中的 类
ICC_ColorSpace 类是抽象 ColorSpace 类的实现。
ICC_ColorSpace(ICC_Profile) - 类 java.awt.color.ICC_ColorSpace 的构造方法
由 ICC_Profile 对象构造一个新的 ICC_ColorSpace。
ICC_Profile - java.awt.color 中的 类
与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。
ICC_ProfileGray - java.awt.color 中的 类
ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。
ICC_ProfileRGB - java.awt.color 中的 类
ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。
icCurveCount - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：curveType 计数。
icCurveData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：curveType 数据。
icHdrAttributes - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：设备属性。
icHdrCmmId - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：此配置文件的 CMM。
icHdrColorSpace - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：数据的颜色空间。
icHdrCreator - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：配置文件创建者。
icHdrDate - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：创建的日期配置文件。
icHdrDeviceClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：配置文件类型。
icHdrFlags - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：各种位设置。
icHdrIlluminant - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：配置文件光源。
icHdrMagic - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：icMagicNumber。
icHdrManufacturer - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：设备制造商。
icHdrModel - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：设备型号。
icHdrPcs - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：PCS - XYZ 或 Lab。
icHdrPlatform - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：原始平台。
icHdrProfileID - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：配置文件的 ID。
icHdrRenderingIntent - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：呈现目的。
icHdrSize - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：以字节为单位的配置文件的大小。
icHdrVersion - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件头位置：格式版本号。
icICCAbsoluteColorimetric - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：ICC-AbsoluteColorimetric。
icMediaRelativeColorimetric - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：Media-RelativeColorimetric。
ICON - 类 javax.accessibility.AccessibleRole 中的静态变量
一个固定大小的小图片，通常用于装饰组件。
Icon - javax.swing 中的 接口
一个小的固定大小图片，通常用于装饰组件。
icon - 类 javax.swing.JOptionPane 中的变量
在窗格中使用的图标。
icon - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的变量
ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对表示该按钮的图标的更改。
ICON_COLOR_16x16 - 接口 java.beans.BeanInfo 中的静态变量
指示 16 x 16 彩色图标的常量。
ICON_COLOR_32x32 - 接口 java.beans.BeanInfo 中的静态变量
指示 32 x 32 彩色图标的常量。
ICON_MONO_16x16 - 接口 java.beans.BeanInfo 中的静态变量
指示 16 x 16 单色图标的常量。
ICON_MONO_32x32 - 接口 java.beans.BeanInfo 中的静态变量
指示 32 x 32 单色图标的常量。
ICON_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
icon 的绑定属性名。
iconable - 类 javax.swing.JInternalFrame 中的变量
可以“图标化”窗体（缩小并显示为图标图像）。
IconAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
图标属性的名称。
iconButton - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
iconCache - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的变量
IconElementName - 类 javax.swing.text.StyleConstants 中的静态变量
用于表示图标的元素名称。
iconIcon - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
ICONIFIED - 类 java.awt.Frame 中的静态变量
此状态位指示将窗体图标化。
ICONIFIED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是最小化的，并只通过一个图标来表示。
ICONIFY_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
iconifyAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
iconifyFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
从父窗体中移除窗体，并将其 desktopIcon 添加到父窗体中。
iconifyFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常从父窗体中移除此窗体，并添加一个图标表示形式。
iconifyFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要图标化窗体时调用此方法。
iconOnly - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
iconPane - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的变量
在桌面图标中使用的标题窗格组件。
IconUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 Icon 包装类。
IconUIResource(Icon) - 类 javax.swing.plaf.IconUIResource 的构造方法
创建一个 UIResource 图标对象，该对象包装了一个现有 Icon 实例。
IconView - javax.swing.text 中的 类
实现视图接口的图标修饰符。
IconView(Element) - 类 javax.swing.text.IconView 的构造方法
创建表示元素的新图标视图。
icPerceptual - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：Perceptual。
icRelativeColorimetric - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：RelativeColorimetric。
icSaturation - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件呈现目的：Saturation。
icSigAbstractClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'abst'。
icSigAToB0Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'A2B0'。
icSigAToB1Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'A2B1'。
icSigAToB2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'A2B2'。
icSigBlueColorantTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bXYZ'。
icSigBlueMatrixColumnTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bXYZ'。
icSigBlueTRCTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bTRC'。
icSigBToA0Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'B2A0'。
icSigBToA1Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'B2A1'。
icSigBToA2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'B2A2'。
icSigCalibrationDateTimeTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'calt'。
icSigCharTargetTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'targ'。
icSigChromaticAdaptationTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'chad'。
icSigChromaticityTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'chrm'。
icSigCmyData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'CMY '。
icSigCmykData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'CMYK'。
icSigColorantOrderTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'clro'。
icSigColorantTableTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'clrt'。
icSigColorSpaceClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'spac'。
icSigCopyrightTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'cprt'。
icSigCrdInfoTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'crdi'。
icSigDeviceMfgDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'dmnd'。
icSigDeviceModelDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'dmdd'。
icSigDeviceSettingsTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'devs'。
icSigDisplayClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'mntr'。
icSigGamutTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'gamt'。
icSigGrayData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'GRAY'。
icSigGrayTRCTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'kTRC'。
icSigGreenColorantTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'gXYZ'。
icSigGreenMatrixColumnTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'gXYZ'。
icSigGreenTRCTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'gTRC'。
icSigHead - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'head' - 专用。
icSigHlsData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'HLS'。
icSigHsvData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'HSV'。
icSigInputClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'scnr'。
icSigLabData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'Lab '。
icSigLinkClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'link'。
icSigLuminanceTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'lumi'。
icSigLuvData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'Luv '。
icSigMeasurementTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'meas'。
icSigMediaBlackPointTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bkpt'。
icSigMediaWhitePointTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'wtpt'。
icSigNamedColor2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'ncl2'。
icSigNamedColorClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'nmcl'。
icSigOutputClass - 类 java.awt.color.ICC_Profile 中的静态变量
ICC Profile 类签名：'prtr'。
icSigOutputResponseTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'resp'。
icSigPreview0Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'pre0'。
icSigPreview1Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'pre1'。
icSigPreview2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'pre2'。
icSigProfileDescriptionTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'desc'。
icSigProfileSequenceDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'pseq'。
icSigPs2CRD0Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'psd0'。
icSigPs2CRD1Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'psd1'。
icSigPs2CRD2Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'psd2'。
icSigPs2CRD3Tag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'psd3'。
icSigPs2CSATag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'ps2s'。
icSigPs2RenderingIntentTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'ps2i'。
icSigRedColorantTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'rXYZ'。
icSigRedMatrixColumnTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'rXYZ'。
icSigRedTRCTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'rTRC'。
icSigRgbData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'RGB '。
icSigScreeningDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'scrd'。
icSigScreeningTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'scrn'。
icSigSpace2CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'2CLR'。
icSigSpace3CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'3CLR'。
icSigSpace4CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'4CLR'。
icSigSpace5CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'5CLR'。
icSigSpace6CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'6CLR'。
icSigSpace7CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'7CLR'。
icSigSpace8CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'8CLR'。
icSigSpace9CLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'9CLR'。
icSigSpaceACLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'ACLR'。
icSigSpaceBCLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'BCLR'。
icSigSpaceCCLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'CCLR'。
icSigSpaceDCLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'DCLR'。
icSigSpaceECLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'ECLR'。
icSigSpaceFCLR - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'FCLR'。
icSigTechnologyTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'tech'。
icSigUcrBgTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'bfd '。
icSigViewingCondDescTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'vued'。
icSigViewingConditionsTag - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件标记签名：'view'。
icSigXYZData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'XYZ '。
icSigYCbCrData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'YCbr'。
icSigYxyData - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件颜色空间类型签名：'Yxy '。
icTagReserved - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：保留。
icTagType - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：标记类型 signaturE。
icXYZNumberX - 类 java.awt.color.ICC_Profile 中的静态变量
ICC 配置文件常量：XYZNumber X。
id - 类 java.awt.AWTEvent 中的变量
事件的 id。
id - 类 java.awt.Event 中的变量
指示事件是什么类型的事件，其他哪个 Event 变量与该事件有关。
id - 类 javax.naming.ldap.BasicControl 中的变量
控件的对象标识符字符串。
ID - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ID - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
id() - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
id() - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
id() - 类 org.omg.CORBA.CurrentHelper 中的静态方法
id() - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
id() - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
id() - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
id() - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
id() - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
id - 类 org.omg.CORBA.NameValuePair 中的变量
将通过此 NameValuePair 对象与某一值关联的名称。
id() - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
id() - 类 org.omg.CORBA.ObjectHelper 中的静态方法
id() - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
id() - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
id() - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
id() - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
id() - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
id() - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
id() - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.StringValueHelper 中的静态方法
id() - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
id() - 类 org.omg.CORBA.TypeCode 中的方法
检索全局标识此 TypeCode 对象类型的 RepositoryId。
id() - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
id() - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
id() - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
id - 类 org.omg.CORBA.ValueMember 中的变量
此 ValueMember 对象所描述的 value 成员的存储库 ID
id() - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
id() - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
id() - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
id() - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
id() - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
id() - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
id() - 类 org.omg.CosNaming.BindingHelper 中的静态方法
id() - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
id() - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
id() - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
id() - 类 org.omg.CosNaming.IstringHelper 中的静态方法
id - 类 org.omg.CosNaming.NameComponent 中的变量
id() - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
id() - 类 org.omg.CosNaming.NameHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
id() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
id() - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
id() - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
id() - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
id - 类 org.omg.DynamicAny.NameDynAnyPair 中的变量
与 DynAny 关联的名称。
id() - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
id() - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
id - 类 org.omg.DynamicAny.NameValuePair 中的变量
与 Any 有关联的名称。
id() - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
id() - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
id() - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
id() - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
id() - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
id() - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
id() - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
id() - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
id() - 类 org.omg.IOP.IORHelper 中的静态方法
id() - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
id() - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
id() - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
id() - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
id() - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
id() - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
id() - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
id() - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
id() - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
id() - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
id() - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
id() - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
id() - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作在 POA 的创建过程中返回该 POA 的唯一 id。
id() - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
id() - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
id() - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
id() - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
ID_ASSIGNMENT_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java。
id_to_reference(byte[]) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果具有指定 Object Id 值的对象当前不是激活状态，则返回一个封装激活该对象时所用信息的引用。
id_to_servant(byte[]) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果 POA 具有 RETAIN 策略并且指定的 ObjectId 存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
ID_UNIQUENESS_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java。
IdAssignmentPolicy - org.omg.PortableServer 中的 接口
IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
IdAssignmentPolicyOperations - org.omg.PortableServer 中的 接口
IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
IdAssignmentPolicyValue - org.omg.PortableServer 中的 类
IdAssignmentPolicyValue 可以具有以下值。
IdAssignmentPolicyValue(int) - 类 org.omg.PortableServer.IdAssignmentPolicyValue 的构造方法
IDENTICAL - 类 java.text.Collator 中的静态变量
Collator 的 strength 值。
identifier - 类 javax.swing.table.TableColumn 中的变量
根据 JTable 的绘制机制，此对象不会在内部使用；可在 TableColumn 中设置标识符，并将其作为标记和定位表列的可选方式。
IdentifierHelper - org.omg.CORBA 中的 类
Identifier 的 Helper。
IdentifierHelper() - 类 org.omg.CORBA.IdentifierHelper 的构造方法
identities() - 类 java.security.IdentityScope 中的方法
已过时。 返回此身份作用域内所有身份的枚举。
IDENTITY - 类 java.awt.font.TransformAttribute 中的静态变量
表示恒等变换的 TransformAttribute。
Identity - java.security 中的 类
已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
Identity() - 类 java.security.Identity 的构造方法
已过时。 只用于序列化的构造器。
Identity(String, IdentityScope) - 类 java.security.Identity 的构造方法
已过时。 构造一个具有指定名称和作用域的 Identity。
Identity(String) - 类 java.security.Identity 的构造方法
已过时。 构造一个具有指定名称且没有作用域的 Identity。
identityEquals(Identity) - 类 java.security.Identity 中的方法
已过时。 测试指定 Identity 与此 Identity 的相等性。
identityHashCode(Object) - 类 java.lang.System 中的静态方法
返回给定对象的哈希码，该代码与默认的方法 hashCode() 返回的代码一样，无论给定对象的类是否重写 hashCode()。
IdentityHashMap<K,V> - java.util 中的 类
此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
IdentityHashMap() - 类 java.util.IdentityHashMap 的构造方法
构造一个具有默认期望最大数量 (21) 的新的空标识哈希映射。
IdentityHashMap(int) - 类 java.util.IdentityHashMap 的构造方法
构造一个具有指定期望最大数量的新的空映射。
IdentityHashMap(Map<? extends K, ? extends V>) - 类 java.util.IdentityHashMap 的构造方法
构造包含指定映射中键-值映射关系的新标识哈希映射。
IdentityScope - java.security 中的 类
已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
IdentityScope() - 类 java.security.IdentityScope 的构造方法
已过时。 此构造方法只用于序列化，不能被子类使用。
IdentityScope(String) - 类 java.security.IdentityScope 的构造方法
已过时。 构造具有指定名称的新身份作用域。
IdentityScope(String, IdentityScope) - 类 java.security.IdentityScope 的构造方法
已过时。 构造具有指定名称和作用域的新身份作用域。
IDEOGRAPHIC_DESCRIPTION_CHARACTERS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Ideographic Description Characters”Unicode 字符块的常量。
IDLE - 类 javax.print.attribute.standard.PrinterState 中的静态变量
指示可以开始处理新作业，无需等待。
IDLEntity - org.omg.CORBA.portable 中的 接口
一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
IDLType - org.omg.CORBA 中的 接口
由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
IDLTypeHelper - org.omg.CORBA 中的 类
IDLType 的 Helper。
IDLTypeHelper() - 类 org.omg.CORBA.IDLTypeHelper 的构造方法
IDLTypeOperations - org.omg.CORBA 中的 接口
此接口必须由所有 IDLType 对象实现。
IDN - java.net 中的 类
提供在普通 Unicode 表示形式和 ASCII 兼容性编码 (ACE) 表示形式之间进行国际化域名 (IDN) 转换的方法。
IDREF - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
IDREFS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
IdUniquenessPolicy - org.omg.PortableServer 中的 接口
IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
IdUniquenessPolicyOperations - org.omg.PortableServer 中的 接口
IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
IdUniquenessPolicyValue - org.omg.PortableServer 中的 类
IdUniquenessPolicyValue 可以具有以下值。
IdUniquenessPolicyValue(int) - 类 org.omg.PortableServer.IdUniquenessPolicyValue 的构造方法
IEEEremainder(double, double) - 类 java.lang.Math 中的静态方法
按照 IEEE 754 标准的规定，对两个参数进行余数运算。
IEEEremainder(double, double) - 类 java.lang.StrictMath 中的静态方法
按照 IEEE 754 标准的规定，对两个参数进行余数运算。
ifModifiedSince - 类 java.net.URLConnection 中的变量
有些协议支持跳过对象获取，除非该对象在某个特定时间点之后又进行了修改。
ignorableWhitespace(char[], int, int) - 接口 org.xml.sax.ContentHandler 中的方法
接收元素内容中可忽略的空白的通知。
ignorableWhitespace(char[], int, int) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收元素内容中可忽略的空白的通知。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收元素内容中可忽略的空白的通知。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收元素内容中可忽略空白的通知。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个可忽略空格的事件。
ignorableWhitespace(char[], int, int) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 忽略空白事件。
IGNORE - 类 java.nio.charset.CodingErrorAction 中的静态变量
指示通过删除错误输入和恢复编码操作来处理编码错误的操作。
IGNORE_ALL_BEANINFO - 类 java.beans.Introspector 中的静态变量
IGNORE_IMMEDIATE_BEANINFO - 类 java.beans.Introspector 中的静态变量
ignoreMetadata - 类 javax.imageio.ImageReader 中的变量
如果当前输入源已经被 setInput 标记为允许忽略元数据，则为 true。
IIOByteBuffer - javax.imageio.stream 中的 类
表示对某个字节数组及该数组中偏移量和长度的可变引用的类。
IIOByteBuffer(byte[], int, int) - 类 javax.imageio.stream.IIOByteBuffer 的构造方法
构造一个引用给定字节数组、偏移量和长度的 IIOByteBuffer。
IIOException - javax.imageio 中的 异常
该异常类用于发出关于读取和写入操作的运行时故障的信号。
IIOException(String) - 异常 javax.imageio.IIOException 的构造方法
构造带有给定消息 String 的 IIOException。
IIOException(String, Throwable) - 异常 javax.imageio.IIOException 的构造方法
构造一个 IIOException，使其带有给定消息 String 以及作为其底层 cause 的 Throwable。
IIOImage - javax.imageio 中的 类
一个聚集图像、缩略（预览）图像集和表示与图像关联的元数据的对象的简单容器类。
IIOImage(RenderedImage, List<? extends BufferedImage>, IIOMetadata) - 类 javax.imageio.IIOImage 的构造方法
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。
IIOImage(Raster, List<? extends BufferedImage>, IIOMetadata) - 类 javax.imageio.IIOImage 的构造方法
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOInvalidTreeException - javax.imageio.metadata 中的 异常
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。
IIOInvalidTreeException(String, Node) - 异常 javax.imageio.metadata.IIOInvalidTreeException 的构造方法
构造一个 IIOInvalidTreeException，使其具有消息字符串和对导致解析错误的 Node 的引用。
IIOInvalidTreeException(String, Throwable, Node) - 异常 javax.imageio.metadata.IIOInvalidTreeException 的构造方法
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。
IIOMetadata - javax.imageio.metadata 中的 类
将由表示与图像和流关联的元数据（非图像数据）的对象扩展的抽象类。
IIOMetadata() - 类 javax.imageio.metadata.IIOMetadata 的构造方法
构造一个空的 IIOMetadata 对象。
IIOMetadata(boolean, String, String, String[], String[]) - 类 javax.imageio.metadata.IIOMetadata 的构造方法
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。
IIOMetadataController - javax.imageio.metadata 中的 接口
该接口将由可以确定 IIOMetadata 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。
IIOMetadataFormat - javax.imageio.metadata 中的 接口
描述从 IIOMetadata.getAsTree 返回并传递给 IIOMetadata.setFromTree 和 mergeTree 的元数据文档结构的对象。
IIOMetadataFormatImpl - javax.imageio.metadata 中的 类
提供 IIOMetadataFormat 接口的可重用实现的具体类。
IIOMetadataFormatImpl(String, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 的构造方法
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略（CHILD_POLICY_REPEAT 除外）。
IIOMetadataFormatImpl(String, int, int) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 的构造方法
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略 CHILD_POLICY_REPEAT。
IIOMetadataNode - javax.imageio.metadata 中的 类
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。
IIOMetadataNode() - 类 javax.imageio.metadata.IIOMetadataNode 的构造方法
构造一个空的 IIOMetadataNode。
IIOMetadataNode(String) - 类 javax.imageio.metadata.IIOMetadataNode 的构造方法
构造一个具有给定节点名称的 IIOMetadataNode。
IIOParam - javax.imageio 中的 类
所有描述应该如何对流进行编码和解码的类的超类。
IIOParam() - 类 javax.imageio.IIOParam 的构造方法
受保护的构造方法，只能由子类调用。
IIOParamController - javax.imageio 中的 接口
该接口将由可以确定 IIOParam 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。
IIOReadProgressListener - javax.imageio.event 中的 接口
供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关进度的接口。
IIOReadUpdateListener - javax.imageio.event 中的 接口
供 ImageReader 实现用于通知其图像和缩略图的调用者相关像素更新的接口。
IIOReadWarningListener - javax.imageio.event 中的 接口
供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。
IIORegistry - javax.imageio.spi 中的 类
用于服务提供者实例的注册表。
IIOServiceProvider - javax.imageio.spi 中的 类
一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。
IIOServiceProvider(String, String) - 类 javax.imageio.spi.IIOServiceProvider 的构造方法
构造一个具有给定供应商名称和版本标识符的 IIOServiceProvider。
IIOServiceProvider() - 类 javax.imageio.spi.IIOServiceProvider 的构造方法
构造一个空的 IIOServiceProvider。
IIOWriteProgressListener - javax.imageio.event 中的 接口
供 ImageWriter 实现用于通知其图像和缩略图写入方法的调用者相关进度的方法。
IIOWriteWarningListener - javax.imageio.event 中的 接口
供 ImageWriter 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。
IllegalAccessError - java.lang 中的 错误
当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
IllegalAccessError() - 错误 java.lang.IllegalAccessError 的构造方法
构造不带详细消息的 IllegalAccessError。
IllegalAccessError(String) - 错误 java.lang.IllegalAccessError 的构造方法
构造带指定详细消息的 IllegalAccessError。
IllegalAccessException - java.lang 中的 异常
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
IllegalAccessException() - 异常 java.lang.IllegalAccessException 的构造方法
构造不带详细消息的 IllegalAccessException 。
IllegalAccessException(String) - 异常 java.lang.IllegalAccessException 的构造方法
构造带指定详细消息的 IllegalAccessException。
IllegalArgumentException - java.lang 中的 异常
抛出的异常表明向方法传递了一个不合法或不正确的参数。
IllegalArgumentException() - 异常 java.lang.IllegalArgumentException 的构造方法
构造不带详细消息的 IllegalArgumentException。
IllegalArgumentException(String) - 异常 java.lang.IllegalArgumentException 的构造方法
构造带指定详细消息的 IllegalArgumentException。
IllegalArgumentException(String, Throwable) - 异常 java.lang.IllegalArgumentException 的构造方法
根据指定的详细消息和原因构造一个新异常。
IllegalArgumentException(Throwable) - 异常 java.lang.IllegalArgumentException 的构造方法
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息构造一个新异常（它通常包含 cause 的类和详细消息）。
IllegalBlockingModeException - java.nio.channels 中的 异常
当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
IllegalBlockingModeException() - 异常 java.nio.channels.IllegalBlockingModeException 的构造方法
构造此类的一个实例。
IllegalBlockSizeException - javax.crypto 中的 异常
如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
IllegalBlockSizeException() - 异常 javax.crypto.IllegalBlockSizeException 的构造方法
构造不带详细信息的 IllegalBlockSizeException。
IllegalBlockSizeException(String) - 异常 javax.crypto.IllegalBlockSizeException 的构造方法
构造带指定详细信息的 IllegalBlockSizeException。
IllegalCharsetNameException - java.nio.charset 中的 异常
将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
IllegalCharsetNameException(String) - 异常 java.nio.charset.IllegalCharsetNameException 的构造方法
构造此类的一个实例。
IllegalClassFormatException - java.lang.instrument 中的 异常
当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
IllegalClassFormatException() - 异常 java.lang.instrument.IllegalClassFormatException 的构造方法
构造不带详细消息的 IllegalClassFormatException。
IllegalClassFormatException(String) - 异常 java.lang.instrument.IllegalClassFormatException 的构造方法
构造具有指定详细消息的 IllegalClassFormatException。
IllegalComponentStateException - java.awt 中的 异常
当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。
IllegalComponentStateException() - 异常 java.awt.IllegalComponentStateException 的构造方法
构造不带详细消息的 IllegalComponentStateException。
IllegalComponentStateException(String) - 异常 java.awt.IllegalComponentStateException 的构造方法
构造带指定详细消息的 IllegalComponentStateException。
IllegalFormatCodePointException - java.util 中的 异常
将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
IllegalFormatCodePointException(int) - 异常 java.util.IllegalFormatCodePointException 的构造方法
构造此类的实例，使其具有 Character.isValidCodePoint(int) 所定义的指定非法代码点。
IllegalFormatConversionException - java.util 中的 异常
当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
IllegalFormatConversionException(char, Class<?>) - 异常 java.util.IllegalFormatConversionException 的构造方法
使用不匹配转换和相应参数类构造此类的实例。
IllegalFormatException - java.util 中的 异常
当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
IllegalFormatFlagsException - java.util 中的 异常
当给出非法组合标志时，抛出未经检查的异常。
IllegalFormatFlagsException(String) - 异常 java.util.IllegalFormatFlagsException 的构造方法
构造带有指定标志的此类的一个实例。
IllegalFormatPrecisionException - java.util 中的 异常
当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
IllegalFormatPrecisionException(int) - 异常 java.util.IllegalFormatPrecisionException 的构造方法
构造带有指定精度的此类的一个实例。
IllegalFormatWidthException - java.util 中的 异常
当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
IllegalFormatWidthException(int) - 异常 java.util.IllegalFormatWidthException 的构造方法
构造带有指定宽度的此类的一个实例。
IllegalMonitorStateException - java.lang 中的 异常
抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
IllegalMonitorStateException() - 异常 java.lang.IllegalMonitorStateException 的构造方法
构造不带详细消息的 IllegalMonitorStateException。
IllegalMonitorStateException(String) - 异常 java.lang.IllegalMonitorStateException 的构造方法
构造带指定详细消息的 IllegalMonitorStateException。
IllegalPathStateException - java.awt.geom 中的 异常
对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
IllegalPathStateException() - 异常 java.awt.geom.IllegalPathStateException 的构造方法
构造不带任何详细消息的 IllegalPathStateException。
IllegalPathStateException(String) - 异常 java.awt.geom.IllegalPathStateException 的构造方法
构造带指定详细消息的 IllegalMonitorStateException。
IllegalSelectorException - java.nio.channels 中的 异常
试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
IllegalSelectorException() - 异常 java.nio.channels.IllegalSelectorException 的构造方法
构造此类的一个实例。
IllegalStateException - java.lang 中的 异常
在非法或不适当的时间调用方法时产生的信号。
IllegalStateException() - 异常 java.lang.IllegalStateException 的构造方法
构造不带详细消息的 IllegalStateException。
IllegalStateException(String) - 异常 java.lang.IllegalStateException 的构造方法
构造带指定详细消息的 IllegalStateException。
IllegalStateException(String, Throwable) - 异常 java.lang.IllegalStateException 的构造方法
构造一个新异常，它带有指定的详细消息和原因。
IllegalStateException(Throwable) - 异常 java.lang.IllegalStateException 的构造方法
构造一个新异常，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含 cause 的类和详细消息）。
IllegalThreadStateException - java.lang 中的 异常
指示线程没有处于请求操作所要求的适当状态时抛出的异常。
IllegalThreadStateException() - 异常 java.lang.IllegalThreadStateException 的构造方法
构造不带详细消息的 IllegalThreadStateException。
IllegalThreadStateException(String) - 异常 java.lang.IllegalThreadStateException 的构造方法
构造带指定详细消息的 IllegalThreadStateException。
Image - java.awt 中的 类
抽象类 Image 是表示图形图像的所有类的超类。
Image() - 类 java.awt.Image 的构造方法
image - 类 javax.imageio.IIOImage 中的变量
正被引用的 RenderedImage。
IMAGE_INCOMPATIBLE - 类 java.awt.image.VolatileImage 中的静态变量
经验证的图像与提供的 GraphicsConfiguration 对象不兼容，应该重新创建适当的图像。
IMAGE_OK - 类 java.awt.image.VolatileImage 中的静态变量
经验证的图像准备按原样使用。
IMAGE_RESTORED - 类 java.awt.image.VolatileImage 中的静态变量
经验证的图像已经被恢复并准备使用。
IMAGEABORTED - 接口 java.awt.image.ImageConsumer 中的静态变量
图像创建进程被故意中止。
ImageCapabilities - java.awt 中的 类
图像的功能和属性。
ImageCapabilities(boolean) - 类 java.awt.ImageCapabilities 的构造方法
创建用于指定图像功能的新对象。
imageComplete(int) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口的 imageComplete 方法中提供的信息。
imageComplete(int) - 接口 java.awt.image.ImageConsumer 中的方法
当 ImageProducer 已完成源图像所含所有像素的传递时，或者已完成多帧动画的单个帧时，或者加载或生成图像中出现错误时，就调用 imageComplete 方法。
imageComplete(int) - 类 java.awt.image.ImageFilter 中的方法
过滤 ImageConsumer 接口的 imageComplete 方法中所提供的信息。
imageComplete(int) - 类 java.awt.image.PixelGrabber 中的方法
imageComplete 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
imageComplete(ImageReader) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告当前图像读操作已经完成。
imageComplete(ImageWriter) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告图像写操作已经完成。
ImageConsumer - java.awt.image 中的 接口
对通过 ImageProducer 接口的图像数据感兴趣的对象接口。
IMAGEERROR - 接口 java.awt.image.ImageConsumer 中的静态变量
生成图像时遇到错误。
ImageFilter - java.awt.image 中的 类
此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
ImageFilter() - 类 java.awt.image.ImageFilter 的构造方法
imageFlavor - 类 java.awt.datatransfer.DataFlavor 中的静态变量
DataFlavor 表示 Java Image 类，其中：
ImageGraphicAttribute - java.awt.font 中的 类
ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。
ImageGraphicAttribute(Image, int) - 类 java.awt.font.ImageGraphicAttribute 的构造方法
根据指定的 Image 构造一个 ImageGraphicAttribute。
ImageGraphicAttribute(Image, int, float, float) - 类 java.awt.font.ImageGraphicAttribute 的构造方法
根据指定的 Image 构造一个 ImageGraphicAttribute。
ImageIcon - javax.swing 中的 类
一个 Icon 接口的实现，它根据 Image 绘制 Icon。
ImageIcon(String, String) - 类 javax.swing.ImageIcon 的构造方法
根据指定的文件创建一个 ImageIcon。
ImageIcon(String) - 类 javax.swing.ImageIcon 的构造方法
根据指定的文件创建一个 ImageIcon。
ImageIcon(URL, String) - 类 javax.swing.ImageIcon 的构造方法
根据指定的 URL 创建一个 ImageIcon。
ImageIcon(URL) - 类 javax.swing.ImageIcon 的构造方法
根据指定的 URL 创建一个 ImageIcon。
ImageIcon(Image, String) - 类 javax.swing.ImageIcon 的构造方法
根据图像创建一个 ImageIcon。
ImageIcon(Image) - 类 javax.swing.ImageIcon 的构造方法
根据图像对象创建一个 ImageIcon。
ImageIcon(byte[], String) - 类 javax.swing.ImageIcon 的构造方法
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。
ImageIcon(byte[]) - 类 javax.swing.ImageIcon 的构造方法
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。
ImageIcon() - 类 javax.swing.ImageIcon 的构造方法
创建一个未初始化的图像图标。
ImageIcon.AccessibleImageIcon - javax.swing 中的 类
此类实现 ImageIcon 类的可访问性支持。
ImageIcon.AccessibleImageIcon() - 类 javax.swing.ImageIcon.AccessibleImageIcon 的构造方法
ImageInputStream - javax.imageio.stream 中的 接口
供 ImageReader 使用的可查找输入流接口。
ImageInputStreamImpl - javax.imageio.stream 中的 类
实现 ImageInputStream 接口的抽象类。
ImageInputStreamImpl() - 类 javax.imageio.stream.ImageInputStreamImpl 的构造方法
构造一个 ImageInputStreamImpl。
ImageInputStreamSpi - javax.imageio.spi 中的 类
用于 ImageInputStream 的服务提供者接口 (SPI)。
ImageInputStreamSpi() - 类 javax.imageio.spi.ImageInputStreamSpi 的构造方法
构造一个空的 ImageInputStreamSpi。
ImageInputStreamSpi(String, String, Class<?>) - 类 javax.imageio.spi.ImageInputStreamSpi 的构造方法
用给定的一组值构造 ImageInputStreamSpi。
ImageIO - javax.imageio 中的 类
该类包含一些用来查找 ImageReader 和 ImageWriter 以及执行简单编码和解码的静态便捷方法。
ImageObserver - java.awt.image 中的 接口
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。
ImageOutputStream - javax.imageio.stream 中的 接口
供 ImageWriter 使用的可查找输出流接口。
ImageOutputStreamImpl - javax.imageio.stream 中的 类
实现 ImageOutputStream 接口的抽象类。
ImageOutputStreamImpl() - 类 javax.imageio.stream.ImageOutputStreamImpl 的构造方法
构造一个 ImageOutputStreamImpl。
ImageOutputStreamSpi - javax.imageio.spi 中的 类
用于 ImageOutputStream 的服务提供者接口 (SPI)。
ImageOutputStreamSpi() - 类 javax.imageio.spi.ImageOutputStreamSpi 的构造方法
构造一个空的 ImageOutputStreamSpi。
ImageOutputStreamSpi(String, String, Class<?>) - 类 javax.imageio.spi.ImageOutputStreamSpi 的构造方法
用给定的一组值构造 ImageOutputStreamSpi。
ImageProducer - java.awt.image 中的 接口
可为 Image 生成图像数据的对象的接口。
imageProgress(ImageReader, float) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告对关联 ImageReader 的 read 当前调用的近似完成程度。
imageProgress(ImageWriter, float) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告在关联的 ImageWriter 中完成当前 write 调用的近似程度。
ImageReader - javax.imageio 中的 类
用来解析和解码图像的抽象超类。
ImageReader(ImageReaderSpi) - 类 javax.imageio.ImageReader 的构造方法
构造一个 ImageReader，并将其 originatingProvider 字段设置为所提供的值。
ImageReaderSpi - javax.imageio.spi 中的 类
用于 ImageReader 的服务提供者接口 (SPI)。
ImageReaderSpi() - 类 javax.imageio.spi.ImageReaderSpi 的构造方法
构造一个空的 ImageReaderSpi。
ImageReaderSpi(String, String, String[], String[], String[], String, Class[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - 类 javax.imageio.spi.ImageReaderSpi 的构造方法
用给定的一组值构造 ImageReaderSpi。
ImageReaderWriterSpi - javax.imageio.spi 中的 类
包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。
ImageReaderWriterSpi(String, String, String[], String[], String[], String, boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - 类 javax.imageio.spi.ImageReaderWriterSpi 的构造方法
用给定的一组值构造 ImageReaderWriterSpi。
ImageReaderWriterSpi() - 类 javax.imageio.spi.ImageReaderWriterSpi 的构造方法
构造一个空的 ImageReaderWriterSpi。
ImageReadParam - javax.imageio 中的 类
描述如何对流进行解码的类。
ImageReadParam() - 类 javax.imageio.ImageReadParam 的构造方法
构造一个 ImageReadParam。
imageStarted(ImageReader, int) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告图像读操作将要开始。
imageStarted(ImageWriter, int) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告图像写操作将要开始。
imageSubmit(String) - 类 javax.swing.text.html.FormView 中的方法
调用此方法来提交表单，以响应在图像上的单击，此图像是类型为 "image" 的 <INPUT> 表单元素。
ImageTranscoder - javax.imageio 中的 接口
提供元数据代码转换功能的接口。
ImageTranscoderSpi - javax.imageio.spi 中的 类
用于 ImageTranscoder 的服务提供者接口 (SPI)。
ImageTranscoderSpi() - 类 javax.imageio.spi.ImageTranscoderSpi 的构造方法
构造一个空的 ImageTranscoderSpi。
ImageTranscoderSpi(String, String) - 类 javax.imageio.spi.ImageTranscoderSpi 的构造方法
用给定的一组值构造 ImageTranscoderSpi。
ImageTypeSpecifier - javax.imageio 中的 类
允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。
ImageTypeSpecifier(ColorModel, SampleModel) - 类 javax.imageio.ImageTypeSpecifier 的构造方法
直接根据 ColorModel 和 SampleModel 构造一个 ImageTypeSpecifier。
ImageTypeSpecifier(RenderedImage) - 类 javax.imageio.ImageTypeSpecifier 的构造方法
根据 RenderedImage 构造一个 ImageTypeSpecifier。
imageUpdate(Image, int, int, int, int, int) - 类 java.awt.Component 中的方法
图像已改变时重绘组件。
imageUpdate(Image, int, int, int, int, int) - 接口 java.awt.image.ImageObserver 中的方法
当以前使用异步接口所请求的图像的信息变得可用时就调用此方法。
imageUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告已更新图像的给定区域。
imageUpdate(Image, int, int, int, int, int) - 类 javax.swing.AbstractButton 中的方法
重写的此方法在当前 Icon 的 Image 不等于传入的 Image img 时返回 false。
imageUpdate(Image, int, int, int, int, int) - 类 javax.swing.JLabel 中的方法
如果当前图标的图像不等于传入的图像 img，则重写此方法以返回 false。
ImageView - javax.swing.text.html 中的 类
图像视图，用于支持 HTML <IMG> 标记。
ImageView(Element) - 类 javax.swing.text.html.ImageView 的构造方法
创建表示 IMG 元素的新视图。
ImageWriteParam - javax.imageio 中的 类
描述如何对流进行编码的类。
ImageWriteParam() - 类 javax.imageio.ImageWriteParam 的构造方法
构造一个空的 ImageWriteParam。
ImageWriteParam(Locale) - 类 javax.imageio.ImageWriteParam 的构造方法
构造一个 ImageWriteParam 集，以使用给定 Locale。
ImageWriter - javax.imageio 中的 类
用来编码和写入图像的抽象超类。
ImageWriter(ImageWriterSpi) - 类 javax.imageio.ImageWriter 的构造方法
构造一个 ImageWriter，并将其 originatingProvider 实例变量设置为所提供的值。
ImageWriterSpi - javax.imageio.spi 中的 类
用于 ImageWriter 的服务提供者接口 (SPI)。
ImageWriterSpi() - 类 javax.imageio.spi.ImageWriterSpi 的构造方法
构造一个空的 ImageWriterSpi。
ImageWriterSpi(String, String, String[], String[], String[], String, Class[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - 类 javax.imageio.spi.ImageWriterSpi 的构造方法
用给定的一组值构造 ImageWriterSpi。
ImagingOpException - java.awt.image 中的 异常
如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
ImagingOpException(String) - 异常 java.awt.image.ImagingOpException 的构造方法
构造带指定消息的 ImagingOpException 对象。
IMG - 类 javax.swing.text.html.HTML.Tag 中的静态变量
IMG_ALIGN_BOTTOM - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
将图像底部对齐。
IMG_ALIGN_MIDDLE - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
将图像居中对齐。
IMG_ALIGN_TOP - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
将图像顶部对齐。
IMG_BORDER - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
将图像对齐到边框。
IMMUTABLE_INFO_FIELD - 类 javax.management.JMX 中的静态变量
immutableInfo 字段的名称。
ImmutableDescriptor - javax.management 中的 类
不可变的描述符。
ImmutableDescriptor(String[], Object[]) - 类 javax.management.ImmutableDescriptor 的构造方法
构造包含给定字段和值的描述符。
ImmutableDescriptor(String...) - 类 javax.management.ImmutableDescriptor 的构造方法
构造包含给定字段的描述符。
ImmutableDescriptor(Map<String, ?>) - 类 javax.management.ImmutableDescriptor 的构造方法
构造一个描述符，其中字段名称和值是给定 Map 的键和值。
IMP_LIMIT - org.omg.CORBA 中的 异常
此异常指示在 OBR 运行时超过了某一项实现限制。
IMP_LIMIT() - 异常 org.omg.CORBA.IMP_LIMIT 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。
IMP_LIMIT(String) - 异常 org.omg.CORBA.IMP_LIMIT 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。
IMP_LIMIT(int, CompletionStatus) - 异常 org.omg.CORBA.IMP_LIMIT 的构造方法
使用指定次要代码和完成状态构造一个 IMP_LIMIT 异常。
IMP_LIMIT(String, int, CompletionStatus) - 异常 org.omg.CORBA.IMP_LIMIT 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 IMP_LIMIT 异常。
impl - 类 javax.naming.CompoundName 中的变量
此组合名称的实现。
implAccept(Socket) - 类 java.net.ServerSocket 中的方法
ServerSocket 的子类使用此方法重写 accept() 以返回它们自己的套接字子类。
implCloseChannel() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
关闭此通道。
implCloseChannel() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
关闭此通道。
implCloseSelectableChannel() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
关闭此可选择通道。
implCloseSelector() - 类 java.nio.channels.spi.AbstractSelector 中的方法
关闭此选择器。
implConfigureBlocking(boolean) - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
调整此通道的阻塞模式。
IMPLEMENTATION_TITLE - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Title 的 Name 对象给出了用于包的版本控制的属性。
IMPLEMENTATION_URL - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Vendor-URL 的 Name 对象给出了用于包的版本控制的属性。
IMPLEMENTATION_VENDOR - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Vendor 的 Name 对象给出了用于包的版本控制的属性。
IMPLEMENTATION_VENDOR_ID - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Vendor-Id 的 Name 对象给出了用于包的版本控制的属性。
IMPLEMENTATION_VERSION - 类 java.util.jar.Attributes.Name 中的静态变量
Implementation-Version 的 Name 对象给出了用于包的版本控制的属性。
implFlush(CharBuffer) - 类 java.nio.charset.CharsetDecoder 中的方法
刷新此解码器。
implFlush(ByteBuffer) - 类 java.nio.charset.CharsetEncoder 中的方法
刷新此编码器。
IMPLICIT_ACTIVATION - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态变量
IMPLICIT_ACTIVATION_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java。
ImplicitActivationPolicy - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 中是否支持隐式激活 servant。
ImplicitActivationPolicyOperations - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 中是否支持隐式激活 servant。
ImplicitActivationPolicyValue - org.omg.PortableServer 中的 类
ImplicitActivationPolicyValue 具有以下语义。
ImplicitActivationPolicyValue(int) - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 的构造方法
IMPLIED - 类 javax.swing.text.html.HTML.Tag 中的静态变量
所有文本内容必须包含在段落元素中。
IMPLIED - 类 javax.swing.text.html.HTMLEditorKit.ParserCallback 中的静态变量
这是作为属性集中的一个属性来传递的，用来指示元素是隐含的，例如字符串 '<>foo<\t>' 包含隐含的 html 元素和隐含的正文元素。
IMPLIED - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
implies(Permission) - 类 java.io.FilePermission 中的方法
检查 FilePermission 对象是否“隐含”指定的权限。
implies(Permission) - 类 java.net.SocketPermission 中的方法
检查此套接字权限对象是否“暗含”指定的权限。
implies(Permission) - 类 java.security.AllPermission 中的方法
检查此对象是否“暗含”指定的权限。
implies(Permission) - 类 java.security.BasicPermission 中的方法
检查此对象是否“暗含”指定的权限。
implies(CodeSource) - 类 java.security.CodeSource 中的方法
如果此 CodeSource 对象“暗含”指定的 CodeSource，则返回 true。
implies(Permission) - 类 java.security.Permission 中的方法
检查此对象的操作是否“暗含”指定权限的操作。
implies(Permission) - 类 java.security.PermissionCollection 中的方法
查看此 PermissionCollection 中保存的 Permission 对象集合是否暗含指定的权限。
implies(Permission) - 类 java.security.Permissions 中的方法
查看此对象用于指定 permission 类的 permissions 的 PermissionCollection 是否暗含了 permission 对象中表示的权限。
implies(ProtectionDomain, Permission) - 类 java.security.Policy 中的方法
计算授予 ProtectionDomain 的权限的全局策略，并测试是否授予了该权限。
implies(Permission) - 类 java.security.ProtectionDomain 中的方法
查看此 ProtectionDomain 是否暗含了 Permission 对象中表示的权限。
implies(Permission) - 类 java.security.UnresolvedPermission 中的方法
对于未解析的权限，此方法始终返回 false。
implies(Permission) - 类 java.util.PropertyPermission 中的方法
检查 PropertyPermission 对象是否“暗指”指定的权限。
implies(Permission) - 类 javax.management.MBeanPermission 中的方法
检查此 MBeanPermission 对象是否“隐含”指定的权限。
implies(Permission) - 类 javax.management.MBeanServerPermission 中的方法
检查此 MBeanServerPermission 对象是否“隐含”指定的权限。
implies(Permission) - 类 javax.security.auth.kerberos.DelegationPermission 中的方法
检查此 Kerberos 代理权限对象是否“隐含”指定的权限。
implies(Permission) - 类 javax.security.auth.kerberos.ServicePermission 中的方法
检查此 Kerberos 服务权限对象是否“隐含”指定的权限。
implies(Permission) - 类 javax.security.auth.PrivateCredentialPermission 中的方法
检查此 PrivateCredentialPermission 是否暗含指定的Permission。
implOnMalformedInput(CodingErrorAction) - 类 java.nio.charset.CharsetDecoder 中的方法
报告此解码器的错误输入操作的更改。
implOnMalformedInput(CodingErrorAction) - 类 java.nio.charset.CharsetEncoder 中的方法
报告此编码器的错误输入操作的更改。
implOnUnmappableCharacter(CodingErrorAction) - 类 java.nio.charset.CharsetDecoder 中的方法
报告此解码器的不可映射的字符操作的更改。
implOnUnmappableCharacter(CodingErrorAction) - 类 java.nio.charset.CharsetEncoder 中的方法
报告此编码器的不可映射的字符操作的更改。
implReplaceWith(String) - 类 java.nio.charset.CharsetDecoder 中的方法
报告此解码器替换值的更改。
implReplaceWith(byte[]) - 类 java.nio.charset.CharsetEncoder 中的方法
报告此编码器替换值的更改。
implReset() - 类 java.nio.charset.CharsetDecoder 中的方法
重置此解码器，清除所有特定于 charset 的内部状态。
implReset() - 类 java.nio.charset.CharsetEncoder 中的方法
重置此编码器，清除所有特定于 charset 的内部状态。
importData(TransferHandler.TransferSupport) - 类 javax.swing.TransferHandler 中的方法
导致从剪贴板或拖放操作的传输。
importData(JComponent, Transferable) - 类 javax.swing.TransferHandler 中的方法
导致从剪贴板或 DND 放置操作向组件的传输。
importedKeyCascade - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 列，指示在更新主键时，外键（导入的键）的更改要与之一致。
importedKeyInitiallyDeferred - 接口 java.sql.DatabaseMetaData 中的静态变量
指示可延迟性。
importedKeyInitiallyImmediate - 接口 java.sql.DatabaseMetaData 中的静态变量
指示可延迟性。
importedKeyNoAction - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 和 DELETE_RULE 列，指示如果主键已导入，则无法更新或删除它。
importedKeyNotDeferrable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示可延迟性。
importedKeyRestrict - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 列，指示如果主键已被另一个表作为外键导入，则可能不更新该主键。
importedKeySetDefault - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 和 DELETE_RULE 列，指示如果更新或删除了主键，则将外键（导入的键）设置为默认值。
importedKeySetNull - 接口 java.sql.DatabaseMetaData 中的静态变量
对于 UPDATE_RULE 和 DELETE_RULE 列，指示在更新或删除主键时，将外键（导入的键）更改为 NULL。
importNode(Node, boolean) - 接口 org.w3c.dom.Document 中的方法
从另一文档向此文档导入节点，而不改变或移除原始文档中的源节点；此方法创建源节点的一个新副本。
importPreferences(InputStream) - 类 java.util.prefs.Preferences 中的静态方法
导入指定输入流中由 XML 文档表示的所有首选项。
importStyleSheet(URL) - 类 javax.swing.text.html.StyleSheet 中的方法
从 url 导入样式表。
in - 类 java.io.FileDescriptor 中的静态变量
标准输入流的句柄。
in - 类 java.io.FilterInputStream 中的变量
要过滤的输入流。
in - 类 java.io.FilterReader 中的变量
底层字符输入流。
in - 类 java.io.PipedInputStream 中的变量
循环缓冲区中位置的索引，当从连接的管道输出流中接收到下一个数据字节时，会将其存储到该位置。
in - 类 java.lang.System 中的静态变量
“标准”输入流。
in(ValueExp, ValueExp[]) - 类 javax.management.Query 中的静态方法
返回一个表达式，限制某个值为显式列表中的一项。
inactive(ActivationID) - 类 java.rmi.activation.Activatable 中的静态方法
通知系统具有相应激活 id 的对象目前没有处于活动状态的。
INACTIVE - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/INACTIVE.java。
INACTIVE - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
INACTIVE_CAPTION - 类 java.awt.SystemColor 中的静态变量
SystemColor.inactiveCaption 系统颜色的数组索引。
INACTIVE_CAPTION_BORDER - 类 java.awt.SystemColor 中的静态变量
SystemColor.inactiveCaptionBorder 系统颜色的数组索引。
INACTIVE_CAPTION_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.inactiveCaptionText 系统颜色的数组索引。
inactiveCaption - 类 java.awt.SystemColor 中的静态变量
为非活动窗口的窗口标题提供的背景色。
inactiveCaptionBorder - 类 java.awt.SystemColor 中的静态变量
为非活动窗口的边框提供的颜色。
inactiveCaptionText - 类 java.awt.SystemColor 中的静态变量
为非活动窗口的窗口标题文本提供的颜色。
inactiveGroup() - 类 java.rmi.activation.ActivationGroup 中的方法
如果子类要进行对组监视器的 inactiveGroup 回调，则此 protected 方法是必要的。
inactiveGroup(ActivationGroupID, long) - 接口 java.rmi.activation.ActivationMonitor 中的方法
通知该组现在是不活动的。
inactiveObject(ActivationID) - 类 java.rmi.activation.ActivationGroup 中的方法
通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
inactiveObject(ActivationID) - 接口 java.rmi.activation.ActivationMonitor 中的方法
当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。
INBOUND_MESSAGE_ATTACHMENTS - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：用于入站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。
incarnate(byte[], POA) - 类 org.omg.PortableServer._ServantActivatorStub 中的方法
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到对当前未激活对象的请求，它就会调用此操作。
incarnate(byte[], POA) - 接口 org.omg.PortableServer.ServantActivatorOperations 中的方法
假定 POA 具有 USE_SERVANT_MANAGER 和 RETAIN 策略，则只要 POA 收到针对当前未激活对象的请求，它就会调用此操作。
INCH - 类 javax.print.attribute.Size2DSyntax 中的静态变量
指示单位为英寸 (in) 的值。
INCH - 类 javax.print.attribute.standard.MediaPrintableArea 中的静态变量
指示以 inch (in) 为单位的值。
inCheck - 类 java.lang.SecurityManager 中的变量
已过时。 建议不使用该类型的安全检查。建议使用 checkPermission 调用。
inClass(String) - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
inClassLoader() - 类 java.lang.SecurityManager 中的方法
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
include(RowFilter.Entry<? extends M, ? extends I>) - 类 javax.swing.RowFilter 中的方法
如果应该显示指定的条目，则返回 true；如果应该隐藏该条目，则返回 false。
inclusions - 类 javax.swing.text.html.parser.Element 中的变量
INCLUSIVE - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的静态变量
Canonical XML（不带注释）的规范化方法的算法 URI。
INCLUSIVE_WITH_COMMENTS - 接口 javax.xml.crypto.dsig.CanonicalizationMethod 中的静态变量
带注释的 Canonical XML 的规范化方法的算法 URI。
IncompatibleClassChangeError - java.lang 中的 错误
在某些类定义中出现不兼容的类更改时抛出该异常。
IncompatibleClassChangeError() - 错误 java.lang.IncompatibleClassChangeError 的构造方法
构造不带详细消息的 IncompatibleClassChangeError。
IncompatibleClassChangeError(String) - 错误 java.lang.IncompatibleClassChangeError 的构造方法
构造带指定详细消息的 IncompatibleClassChangeError。
IncompleteAnnotationException - java.lang.annotation 中的 异常
若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。
IncompleteAnnotationException(Class<? extends Annotation>, String) - 异常 java.lang.annotation.IncompleteAnnotationException 的构造方法
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。
InconsistentTypeCode - org.omg.CORBA.ORBPackage 中的 异常
当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
InconsistentTypeCode() - 异常 org.omg.CORBA.ORBPackage.InconsistentTypeCode 的构造方法
构造一个不带任何原因信息的 InconsistentTypeCode 用户异常。
InconsistentTypeCode(String) - 异常 org.omg.CORBA.ORBPackage.InconsistentTypeCode 的构造方法
构造一个带有指定原因信息的 InconsistentTypeCode 用户异常。
InconsistentTypeCode - org.omg.DynamicAny.DynAnyFactoryPackage 中的 异常
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java。
InconsistentTypeCode() - 异常 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode 的构造方法
InconsistentTypeCode(String) - 异常 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode 的构造方法
InconsistentTypeCodeHelper - org.omg.DynamicAny.DynAnyFactoryPackage 中的 类
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java。
InconsistentTypeCodeHelper() - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 的构造方法
incrButton - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
INCREASE_HIGHLIGHT - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的静态变量
increaseButton - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
INCREMENT - 接口 javax.accessibility.AccessibleAction 中的静态变量
增加某个值的动作。
incrementAndGet() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
以原子方式将当前值加 1。
incrementAndGet(int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
以原子方式将索引 i 的元素加 1。
incrementAndGet(T) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象的字段的当前值加 1。
incrementAndGet() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
以原子方式将当前值加 1。
incrementAndGet(int) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
以原子方式将索引 i 的元素加1。
incrementAndGet(T) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
以原子方式将此更新器管理的给定对象字段当前值加 1。
incrementAnimationIndex() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
将当前动画窗体的索引设置为下一个有效值，这将导致进度条的重绘。
incrIndent() - 类 javax.swing.text.AbstractWriter 中的方法
提高缩进级别。
inDaylightTime(Date) - 类 java.util.SimpleTimeZone 中的方法
如果给定日期在夏令时期间，则执行查询。
inDaylightTime(Date) - 类 java.util.TimeZone 中的方法
查询给定的日期是否在此时区的夏令时中。
INDEFINITE_LIFETIME - 接口 org.ietf.jgss.GSSContext 中的静态变量
一个表示不确定的上下文生存期的生存期常量。
INDEFINITE_LIFETIME - 接口 org.ietf.jgss.GSSCredential 中的静态变量
一个表示不确定的凭据生存期的生存期常量。
indent() - 类 javax.swing.text.AbstractWriter 中的方法
执行缩进。
INDENT - 类 javax.xml.transform.OutputKeys 中的静态变量
indent = "yes" | "no". indent 指定了当输出结果树时，Transformer 是否可以添加额外的空白；其值必须为 yes 或 no。
INDETERMINATE - 类 javax.accessibility.AccessibleState 中的静态变量
指示对象状态是不确定的。
INDETERMINATE - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
比较结果。
index - 类 javax.swing.text.html.parser.Element 中的变量
index - 异常 org.omg.PortableServer.POAPackage.InvalidPolicy 中的变量
INDEX_SIZE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果索引或大小为负，或大于允许的值。
indexAtLocation(int, int) - 类 javax.swing.JTabbedPane 中的方法
返回选项卡边界与指定区域相交的选项卡索引。
IndexColorModel - java.awt.image 中的 类
IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。
IndexColorModel(int, int, byte[], byte[], byte[]) - 类 java.awt.image.IndexColorModel 的构造方法
根据指定的红色、绿色和蓝色分量数组构造一个 IndexColorModel。
IndexColorModel(int, int, byte[], byte[], byte[], int) - 类 java.awt.image.IndexColorModel 的构造方法
根据给定的红色、绿色和蓝色分量数组构造一个 IndexColorModel。
IndexColorModel(int, int, byte[], byte[], byte[], byte[]) - 类 java.awt.image.IndexColorModel 的构造方法
根据给定的红色、绿色、蓝色和 alpha 分量数组构造一个 IndexColorModel。
IndexColorModel(int, int, byte[], int, boolean) - 类 java.awt.image.IndexColorModel 的构造方法
根据交错存取红色、绿色、蓝色和可选 alpha 分量的单个数组构造一个 IndexColorModel。
IndexColorModel(int, int, byte[], int, boolean, int) - 类 java.awt.image.IndexColorModel 的构造方法
根据交错存取红色、绿色、蓝色和可选 alpha 分量的单个数组构造一个 IndexColorModel。
IndexColorModel(int, int, int[], int, boolean, int, int) - 类 java.awt.image.IndexColorModel 的构造方法
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和可选 alpha 分量构成。
IndexColorModel(int, int, int[], int, int, BigInteger) - 类 java.awt.image.IndexColorModel 的构造方法
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和 alpha 分量构成。
IndexedPropertyChangeEvent - java.beans 中的 类
无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。
IndexedPropertyChangeEvent(Object, String, Object, Object, int) - 类 java.beans.IndexedPropertyChangeEvent 的构造方法
构造一个新的 IndexedPropertyChangeEvent 对象。
IndexedPropertyDescriptor - java.beans 中的 类
IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。
IndexedPropertyDescriptor(String, Class<?>) - 类 java.beans.IndexedPropertyDescriptor 的构造方法
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。
IndexedPropertyDescriptor(String, Class<?>, String, String, String, String) - 类 java.beans.IndexedPropertyDescriptor 的构造方法
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。
IndexedPropertyDescriptor(String, Method, Method, Method, Method) - 类 java.beans.IndexedPropertyDescriptor 的构造方法
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
indexOf(int) - 类 java.lang.String 中的方法
返回指定字符在此字符串中第一次出现处的索引。
indexOf(int, int) - 类 java.lang.String 中的方法
返回在此字符串中第一次出现指定字符处的索引，从指定的索引开始搜索。
indexOf(String) - 类 java.lang.String 中的方法
返回指定子字符串在此字符串中第一次出现处的索引。
indexOf(String, int) - 类 java.lang.String 中的方法
返回指定子字符串在此字符串中第一次出现处的索引，从指定的索引开始。
indexOf(String) - 类 java.lang.StringBuffer 中的方法
indexOf(String, int) - 类 java.lang.StringBuffer 中的方法
indexOf(String) - 类 java.lang.StringBuilder 中的方法
indexOf(String, int) - 类 java.lang.StringBuilder 中的方法
indexOf(Object) - 类 java.util.AbstractList 中的方法
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
indexOf(Object) - 类 java.util.ArrayList 中的方法
返回此列表中首次出现的指定元素的索引，或如果此列表不包含元素，则返回 -1。
indexOf(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
indexOf(E, int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回第一次出现的指定元素在此列表中的索引，从 index 开始向前搜索，如果没有找到该元素，则返回 -1。
indexOf(Object) - 类 java.util.LinkedList 中的方法
返回此列表中首次出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。
indexOf(Object) - 接口 java.util.List 中的方法
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
indexOf(Object) - 类 java.util.Vector 中的方法
返回此向量中第一次出现的指定元素的索引，如果此向量不包含该元素，则返回 -1。
indexOf(Object, int) - 类 java.util.Vector 中的方法
返回此向量中第一次出现的指定元素的索引，从 index 处正向搜索，如果未找到该元素，则返回 -1。
indexOf(Object) - 类 javax.swing.DefaultListModel 中的方法
搜索 elem 的第一次出现。
indexOf(Object, int) - 类 javax.swing.DefaultListModel 中的方法
从 index 开始搜索 elem 的第一次出现。
indexOf(Object) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
indexOfComponent(Component) - 类 javax.swing.JTabbedPane 中的方法
返回指定组件的选项卡索引。
indexOfSubList(List<?>, List<?>) - 类 java.util.Collections 中的静态方法
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
indexOfTab(String) - 类 javax.swing.JTabbedPane 中的方法
返回具有给定 title 的第一个选项卡索引，如果没有具有此标题的选项卡，则返回 -1。
indexOfTab(Icon) - 类 javax.swing.JTabbedPane 中的方法
返回具有给定的 icon 的第一个选项卡索引，如果没有具有此图标的选项卡，则返回 -1。
indexOfTabComponent(Component) - 类 javax.swing.JTabbedPane 中的方法
返回指定选项卡组件的选项卡索引。
IndexOutOfBoundsException - java.lang 中的 异常
指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
IndexOutOfBoundsException() - 异常 java.lang.IndexOutOfBoundsException 的构造方法
构造不带详细消息的 IndexOutOfBoundsException。
IndexOutOfBoundsException(String) - 异常 java.lang.IndexOutOfBoundsException 的构造方法
构造带指定详细消息的 IndexOutOfBoundsException。
indexToLocation(int) - 类 javax.swing.JList 中的方法
返回列表的坐标系统中指定项的原点。
indexToLocation(JList, int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回列表坐标系统中给定 JList 中指定项的原点。
indexToLocation(JList, int) - 类 javax.swing.plaf.ListUI 中的方法
返回列表坐标系统中给定 JList 中指定项的原点。
indexToLocation(JList, int) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 indexToLocation 方法。
IndirectionException - org.omg.CORBA.portable 中的 异常
Indirection 异常是一个特定于 Java 的系统异常。
IndirectionException(int) - 异常 org.omg.CORBA.portable.IndirectionException 的构造方法
使用正确的偏移量值创建一个 IndirectionException。
Inet4Address - java.net 中的 类
此类表示 Internet Protocol version 4 (IPv4) 地址。
Inet6Address - java.net 中的 类
此类表示互联网协议第 6 版 (IPv6) 地址。
InetAddress - java.net 中的 类
此类表示互联网协议 (IP) 地址。
InetSocketAddress - java.net 中的 类
此类实现 IP 套接字地址（IP 地址 + 端口号）。
InetSocketAddress(int) - 类 java.net.InetSocketAddress 的构造方法
创建套接字地址，其中 IP 地址为通配符地址，端口号为指定值。
InetSocketAddress(InetAddress, int) - 类 java.net.InetSocketAddress 的构造方法
根据 IP 地址和端口号创建套接字地址。
InetSocketAddress(String, int) - 类 java.net.InetSocketAddress 的构造方法
根据主机名和端口号创建套接字地址。
inf - 类 java.util.zip.InflaterInputStream 中的变量
流的解压缩器。
inf - 类 java.util.zip.InflaterOutputStream 中的变量
此流的解压缩器。
inferBinaryName(JavaFileManager.Location, JavaFileObject) - 类 javax.tools.ForwardingJavaFileManager 中的方法
inferBinaryName(JavaFileManager.Location, JavaFileObject) - 接口 javax.tools.JavaFileManager 中的方法
根据位置推断文件对象的二进制名称。
inflate(byte[], int, int) - 类 java.util.zip.Inflater 中的方法
将字节解压缩到指定的缓冲区。
inflate(byte[]) - 类 java.util.zip.Inflater 中的方法
将字节解压缩到指定的缓冲区。
Inflater - java.util.zip 中的 类
此类使用流行的 ZLIB 压缩程序库为通用解压缩提供支持。
Inflater(boolean) - 类 java.util.zip.Inflater 的构造方法
创建新的解压缩器。
Inflater() - 类 java.util.zip.Inflater 的构造方法
创建新的解压缩器。
InflaterInputStream - java.util.zip 中的 类
此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
InflaterInputStream(InputStream, Inflater, int) - 类 java.util.zip.InflaterInputStream 的构造方法
使用指定解压缩器和缓冲区大小创建一个新输入流。
InflaterInputStream(InputStream, Inflater) - 类 java.util.zip.InflaterInputStream 的构造方法
创建一个带有指定解压缩器和默认缓冲区大小的新输入流。
InflaterInputStream(InputStream) - 类 java.util.zip.InflaterInputStream 的构造方法
使用默认解压缩器和缓冲区大小创建一个新输入流。
InflaterOutputStream - java.util.zip 中的 类
为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
InflaterOutputStream(OutputStream) - 类 java.util.zip.InflaterOutputStream 的构造方法
创建一个带有默认解压缩器和缓冲区大小的新输出流。
InflaterOutputStream(OutputStream, Inflater) - 类 java.util.zip.InflaterOutputStream 的构造方法
创建一个带有指定解压缩器和默认缓冲区大小的新输出流。
InflaterOutputStream(OutputStream, Inflater, int) - 类 java.util.zip.InflaterOutputStream 的构造方法
创建一个带有指定解压缩器和缓冲区大小的新输出流。
INFO - 类 java.awt.SystemColor 中的静态变量
SystemColor.info 系统颜色的数组索引。
info - 类 java.awt.SystemColor 中的静态变量
为工具栏提示或定点帮助提供的背景色。
INFO - 类 java.util.logging.Level 中的静态变量
INFO 是报告消息的消息级别。
info(String) - 类 java.util.logging.Logger 中的方法
记录一条 INFO 消息。
INFO - 类 javax.management.MBeanOperationInfo 中的静态变量
指示该操作与读取操作类似，它主要返回一些信息。
INFO_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.infoText 系统颜色的数组索引。
inFontTag() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
如果我们当前正处在 <font> 标记中，则返回 true。
INFORMATION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
INFORMATION 消息类型。
INFORMATION - 类 javax.security.auth.callback.TextOutputCallback 中的静态变量
信息消息。
INFORMATION_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
INFORMATION_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
用于信息消息。
infoText - 类 java.awt.SystemColor 中的静态变量
为工具栏提示或定点帮助的文本提供的颜色。
InheritableThreadLocal<T> - java.lang 中的 类
该类扩展了 ThreadLocal，为子线程提供从父线程那里继承的值：在创建子线程时，子线程会接收所有可继承的线程局部变量的初始值，以获得父线程所具有的值。
InheritableThreadLocal() - 类 java.lang.InheritableThreadLocal 的构造方法
Inherited - java.lang.annotation 中的 注释类型
指示注释类型被自动继承。
inheritedChannel() - 类 java.lang.System 中的静态方法
返回从创建此 Java 虚拟机的实体中继承的信道。
inheritedChannel() - 类 java.nio.channels.spi.SelectorProvider 中的方法
返回从创建此 Java 虚拟机的实体中继承的通道。
inHitRegion(int, int) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果传入位置是要启动编辑的有效鼠标位置，则返回 true。
init() - 类 java.applet.Applet 中的方法
由浏览器或 applet viewer 调用，通知此 applet 它已经被加载到系统中。
init(int) - 类 java.security.AlgorithmParameterGenerator 中的方法
针对某个特定大小初始化此参数生成器。
init(int, SecureRandom) - 类 java.security.AlgorithmParameterGenerator 中的方法
针对某个特定大小和随机源初始化此参数生成器。
init(AlgorithmParameterSpec) - 类 java.security.AlgorithmParameterGenerator 中的方法
利用特定于算法的参数生成值集合初始化此参数生成器。
init(AlgorithmParameterSpec, SecureRandom) - 类 java.security.AlgorithmParameterGenerator 中的方法
利用特定于算法的参数生成值集合初始化此参数生成器。
init(AlgorithmParameterSpec) - 类 java.security.AlgorithmParameters 中的方法
使用在 paramSpec 中指定的参数初始化此参数对象。
init(byte[]) - 类 java.security.AlgorithmParameters 中的方法
根据参数的基本解码格式导入指定的参数并对其解码。
init(byte[], String) - 类 java.security.AlgorithmParameters 中的方法
根据指定的解码方案从 params 导入参数并对其解码。
init(boolean) - 类 java.security.cert.PKIXCertPathChecker 中的方法
初始化此 PKIXCertPathChecker 的内部状态。
init(ProcessingEnvironment) - 类 javax.annotation.processing.AbstractProcessor 中的方法
用处理环境初始化 processor，方法是将 processingEnv 字段设置为 processingEnv 参数的值。
init(ProcessingEnvironment) - 接口 javax.annotation.processing.Processor 中的方法
用处理环境初始化 Processor。
init(int, Key) - 类 javax.crypto.Cipher 中的方法
用密钥初始化此 Cipher。
init(int, Key, SecureRandom) - 类 javax.crypto.Cipher 中的方法
用密钥和随机源初始化此 Cipher。
init(int, Key, AlgorithmParameterSpec) - 类 javax.crypto.Cipher 中的方法
用密钥和一组算法参数初始化此 Cipher。
init(int, Key, AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.Cipher 中的方法
用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
init(int, Key, AlgorithmParameters) - 类 javax.crypto.Cipher 中的方法
用密钥和一组算法参数初始化此 Cipher。
init(int, Key, AlgorithmParameters, SecureRandom) - 类 javax.crypto.Cipher 中的方法
用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
init(int, Certificate) - 类 javax.crypto.Cipher 中的方法
用取自给定证书的公钥初始化此 Cipher。
init(int, Certificate, SecureRandom) - 类 javax.crypto.Cipher 中的方法
用取自给定证书的公钥和随机源初始化此 Cipher。
init(Key) - 类 javax.crypto.ExemptionMechanism 中的方法
用密钥初始化此豁免机制。
init(Key, AlgorithmParameterSpec) - 类 javax.crypto.ExemptionMechanism 中的方法
用一个密钥和一组算法参数初始化此豁免机制。
init(Key, AlgorithmParameters) - 类 javax.crypto.ExemptionMechanism 中的方法
用一个密钥和一组算法参数初始化此豁免机制。
init(Key) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥初始化此密钥协定，给定密钥需要包含此密钥协定所需的所有算法参数。
init(Key, SecureRandom) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥和随机源初始化此密钥协议。
init(Key, AlgorithmParameterSpec) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥和算法参数集初始化此密钥协定。
init(Key, AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.KeyAgreement 中的方法
用给定密钥、算法参数集和随机源初始化此密钥协定。
init(SecureRandom) - 类 javax.crypto.KeyGenerator 中的方法
初始化此密钥生成器。
init(AlgorithmParameterSpec) - 类 javax.crypto.KeyGenerator 中的方法
用指定参数集初始化此密钥生成器。
init(AlgorithmParameterSpec, SecureRandom) - 类 javax.crypto.KeyGenerator 中的方法
用指定参数集和用户提供的随机源初始化此密钥生成器。
init(int) - 类 javax.crypto.KeyGenerator 中的方法
初始化此密钥生成器，使其具有确定的密钥大小。
init(int, SecureRandom) - 类 javax.crypto.KeyGenerator 中的方法
使用用户提供的随机源初始化此密钥生成器，使其具有确定的密钥大小。
init(Key) - 类 javax.crypto.Mac 中的方法
用给定的密钥初始化此 Mac 对象。
init(Key, AlgorithmParameterSpec) - 类 javax.crypto.Mac 中的方法
用给定的密钥和算法参数初始化此 Mac 对象。
init(Hashtable<?, ?>) - 类 javax.naming.InitialContext 中的方法
使用所提供的环境初始化初始上下文。
init(KeyStore, char[]) - 类 javax.net.ssl.KeyManagerFactory 中的方法
使用密钥内容源初始化此工厂。
init(ManagerFactoryParameters) - 类 javax.net.ssl.KeyManagerFactory 中的方法
使用特定于提供者的密钥内容源初始化此工厂。
init(KeyManager[], TrustManager[], SecureRandom) - 类 javax.net.ssl.SSLContext 中的方法
初始化此上下文。
init(KeyStore) - 类 javax.net.ssl.TrustManagerFactory 中的方法
用证书授权源和相关的信任材料初始化此工厂。
init(ManagerFactoryParameters) - 类 javax.net.ssl.TrustManagerFactory 中的方法
使用特定于提供者的信任材料源初始化此工厂。
init(String, Icon) - 类 javax.swing.AbstractButton 中的方法
init(String, Icon) - 类 javax.swing.JMenuItem 中的方法
利用指定文本和图标初始化菜单项。
init(StateEditable, String) - 类 javax.swing.undo.StateEdit 中的方法
init(TransformParameterSpec) - 类 javax.xml.crypto.dsig.TransformService 中的方法
使用指定的参数初始化此 TransformService。
init(XMLStructure, XMLCryptoContext) - 类 javax.xml.crypto.dsig.TransformService 中的方法
使用指定的参数和文档上下文初始化此 TransformService。
init() - 类 org.omg.CORBA.ORB 中的静态方法
返回对象 ORB 单件。
init(String[], Properties) - 类 org.omg.CORBA.ORB 中的静态方法
为独立的应用程序创建一个新的 ORB 实例。
init(Applet, Properties) - 类 org.omg.CORBA.ORB 中的静态方法
为 applet 创建一个新的 ORB 实例。
initCause(Throwable) - 类 java.lang.Throwable 中的方法
将此 throwable 的 cause 初始化为指定值。
initCause(Throwable) - 异常 javax.naming.NamingException 中的方法
将此异常的 cause 初始化为指定值。
initCause(Throwable) - 异常 javax.security.sasl.SaslException 中的方法
initCause(Throwable) - 异常 javax.xml.soap.SOAPException 中的方法
使用给定的 Throwable 对象初始化此 SOAPException 对象的 cause 字段。
initCause(Throwable) - 异常 javax.xml.transform.TransformerException 中的方法
将此抛出对象的原因 初始化为指定值。
initClassDefaults(UIDefaults) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
用从 uiClassID 到 ui 类的完全限定名称的映射关系填充 table。
initClassDefaults(UIDefaults) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
用从 uiClassID 到 ui 类完全限定名的映射关系填充 table。
initComponentDefaults(UIDefaults) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
用基本外观的默认值填充 table。
initComponentDefaults(UIDefaults) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
用 metal 的默认值填充 table。
initEvent(String, boolean, boolean) - 接口 org.w3c.dom.events.Event 中的方法
initEvent 方法用于初始化通过 DocumentEvent 接口创建的 Event 的值。
INITIAL_CONTEXT_FACTORY - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定要使用的初始上下文工厂的环境属性名称。
INITIAL_QUOTE_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Pi”。
INITIAL_SELECTION_VALUE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
initialSelectionValue 的绑定属性名。
INITIAL_VALUE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
initialValue 的绑定属性名。
InitialContext - javax.naming 中的 类
此类是执行命名操作的初始上下文。
InitialContext(boolean) - 类 javax.naming.InitialContext 的构造方法
构造一个带有不进行初始化选项的初始上下文。
InitialContext() - 类 javax.naming.InitialContext 的构造方法
构造一个初始上下文。
InitialContext(Hashtable<?, ?>) - 类 javax.naming.InitialContext 的构造方法
使用所提供的环境构造一个初始上下文。
InitialContextFactory - javax.naming.spi 中的 接口
此接口表示创建初始上下文的工厂。
InitialContextFactoryBuilder - javax.naming.spi 中的 接口
此接口表示创建初始上下文工厂的生成器。
InitialDirContext - javax.naming.directory 中的 类
此类是执行目录操作的初始上下文。
InitialDirContext(boolean) - 类 javax.naming.directory.InitialDirContext 的构造方法
构造一个具有不进行初始化的选项的初始 DirContext。
InitialDirContext() - 类 javax.naming.directory.InitialDirContext 的构造方法
构造一个初始 DirContext。
InitialDirContext(Hashtable<?, ?>) - 类 javax.naming.directory.InitialDirContext 的构造方法
使用所提供的环境构造一个初始 DirContext。
initialFocusComponent - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
利用 selectInitialValue 传递消息时接收焦点的组件。
initialize(Applet, BeanContext) - 接口 java.beans.AppletInitializer 中的方法
如果传递给 java.beans.Beans.instantiate 的适当变体，将调用此方法来将新近实例化的 Applet (JavaBean) 与其 AppletContext、AppletStub 和 Container 相关联。
initialize() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
由 BeanContextSupport 超类在构造和反序列化期间调用，以初始化子类的瞬态。
initialize() - 类 java.beans.beancontext.BeanContextSupport 中的方法
从构造方法和 readObject 调用的受保护方法，以初始化 BeanContextSupport 实例的瞬态。
initialize(Class<?>, Object, Object, Encoder) - 类 java.beans.DefaultPersistenceDelegate 中的方法
initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。
initialize(Class<?>, Object, Object, Encoder) - 类 java.beans.PersistenceDelegate 中的方法
产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。
initialize(DSAParams, SecureRandom) - 接口 java.security.interfaces.DSAKeyPairGenerator 中的方法
使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。
initialize(int, boolean, SecureRandom) - 接口 java.security.interfaces.DSAKeyPairGenerator 中的方法
使用给定系数长度（而不是参数）和可选 SecureRandom 位源初始化密钥对生成器。
initialize(int) - 类 java.security.KeyPairGenerator 中的方法
初始化确定密钥大小的密钥对生成器，使用默认的参数集合，并使用以最高优先级安装的提供者的 SecureRandom 实现作为随机源。
initialize(int, SecureRandom) - 类 java.security.KeyPairGenerator 中的方法
使用给定的随机源（和默认的参数集合）初始化确定密钥大小的密钥对生成器。
initialize(AlgorithmParameterSpec) - 类 java.security.KeyPairGenerator 中的方法
初始化密钥对生成器，使用指定参数集合，并使用以最高优先级安装的提供者的 SecureRandom 的实现作为随机源。
initialize(AlgorithmParameterSpec, SecureRandom) - 类 java.security.KeyPairGenerator 中的方法
使用给定参数集合和随机源初始化密钥对生成器。
initialize(int, SecureRandom) - 类 java.security.KeyPairGeneratorSpi 中的方法
使用默认参数集初始化确定密钥大小的密钥对生成器。
initialize(AlgorithmParameterSpec, SecureRandom) - 类 java.security.KeyPairGeneratorSpi 中的方法
用指定参数集合和用户提供的随机源初始化密钥对生成器。
initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - 接口 javax.security.auth.spi.LoginModule 中的方法
初始化此 LoginModule。
initialize() - 类 javax.swing.LookAndFeel 中的方法
初始化外观。
initialize() - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
初始化外观。
initialize() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
在安装此外观时由 UIManager 调用。
INITIALIZE - org.omg.CORBA 中的 异常
ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
INITIALIZE() - 异常 org.omg.CORBA.INITIALIZE 的构造方法
使用默认次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。
INITIALIZE(String) - 异常 org.omg.CORBA.INITIALIZE 的构造方法
使用指定详细消息、次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。
INITIALIZE(int, CompletionStatus) - 异常 org.omg.CORBA.INITIALIZE 的构造方法
使用指定次要代码和完成状态构造一个 INITIALIZE 异常。
INITIALIZE(String, int, CompletionStatus) - 异常 org.omg.CORBA.INITIALIZE 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INITIALIZE 异常。
initializeAutoscrolling(Point) - 类 java.awt.dnd.DropTarget 中的方法
初始化自动滚动
initializeBeanContextResources() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
子类可重写此方法来提供它们自己的初始化行为。
initializeBeanContextResources() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
从 setBeanContext 中调用，以通知 BeanContextChild 分配从嵌套 BeanContext 中获得的资源。
initializeDesktopProperties() - 类 java.awt.Toolkit 中的方法
initializeDesktopProperties
initializeLocalVars() - 类 javax.swing.JTable 中的方法
将表的属性初始化为其默认值。
initializeLocalVars() - 类 javax.swing.table.JTableHeader 中的方法
使用默认值初始化局部变量和属性。
InitialLdapContext - javax.naming.ldap 中的 类
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。
InitialLdapContext() - 类 javax.naming.ldap.InitialLdapContext 的构造方法
不使用任何环境属性或连接请求控件构造初始上下文。
InitialLdapContext(Hashtable<?, ?>, Control[]) - 类 javax.naming.ldap.InitialLdapContext 的构造方法
使用环境属性或连接请求控件构造初始上下文。
initialSelectionValue - 类 javax.swing.JOptionPane 中的变量
要在 selectionValues 中选择的初始值。
initialSubString(AttributeValueExp, StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于字符串参数的约束条件。
initialValue() - 类 java.lang.ThreadLocal 中的方法
返回此线程局部变量的当前线程的“初始值”。
initialValue - 类 javax.swing.JOptionPane 中的变量
应该在 options 中最初选择的值。
INITIATE_AND_ACCEPT - 接口 org.ietf.jgss.GSSCredential 中的静态变量
凭据使用标志，它要求凭据既可用于上下文初始化也可用于接受。
INITIATE_ONLY - 接口 org.ietf.jgss.GSSCredential 中的静态变量
凭据使用标志，要求凭据仅可用于上下文初始化。
initMouseEvent(String, boolean, boolean, AbstractView, int, int, int, int, int, boolean, boolean, boolean, boolean, short, EventTarget) - 接口 org.w3c.dom.events.MouseEvent 中的方法
initMouseEvent 方法用于初始化通过 DocumentEvent 接口创建的 MouseEvent 的值。
initMutationEvent(String, boolean, boolean, Node, String, String, String, short) - 接口 org.w3c.dom.events.MutationEvent 中的方法
该 initMutationEvent 方法用于初始化通过 DocumentEvent 接口创建的 MutationEvent 的值。
InitParam - javax.jws.soap 中的 注释类型
已过时。 从 JSR-181 2.0 开始，无替代版本。
initParams() - 类 javax.sql.rowset.BaseRowSet 中的方法
执行必需的内部配置和初始化，从而允许所有 JDBC RowSet 实现开始使用 BaseRowSet 实例提供的标准设施。
initSecContext(byte[], int, int) - 接口 org.ietf.jgss.GSSContext 中的方法
由上下文初始端调用，以启动上下文创建阶段，处理由同位体的 acceptSecContext 方法生成的任何标记。
initSecContext(InputStream, OutputStream) - 接口 org.ietf.jgss.GSSContext 中的方法
由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
initSign(PrivateKey) - 类 java.security.Signature 中的方法
初始化这个用于签名的对象。
initSign(PrivateKey, SecureRandom) - 类 java.security.Signature 中的方法
初始化这个用于签名的对象。
initSystemColorDefaults(UIDefaults) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
用系统颜色填充 table。
initSystemColorDefaults(UIDefaults) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
用系统颜色填充 table。
initUIEvent(String, boolean, boolean, AbstractView, int) - 接口 org.w3c.dom.events.UIEvent 中的方法
initUIEvent 方法用于初始化通过 DocumentEvent 接口创建的 UIEvent 的值。
initVerify(PublicKey) - 类 java.security.Signature 中的方法
初始化此用于验证的对象。
initVerify(Certificate) - 类 java.security.Signature 中的方法
使用来自给定证书的公钥初始化此用于验证的对象。
InlineView - javax.swing.text.html 中的 类
显示基于 css 属性的 inline element 样式。
InlineView(Element) - 类 javax.swing.text.html.InlineView 的构造方法
构造在元素上包装的新视图。
INNER_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供两个表之间的内联合 (inner join)。
input - 类 javax.imageio.ImageReader 中的变量
由 setInput 设置并由 getInput 获取的 ImageInputStream 或其他 Object。
INPUT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
INPUT_METHOD_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择输入方法事件的事件掩码。
INPUT_METHOD_FIRST - 类 java.awt.event.InputMethodEvent 中的静态变量
标记输入方法事件 id 范围内的第一个整数 id。
INPUT_METHOD_HIGHLIGHT - 类 java.awt.font.TextAttribute 中的静态变量
用于输入法高亮显示样式的属性键。
INPUT_METHOD_LAST - 类 java.awt.event.InputMethodEvent 中的静态变量
标记输入方法事件 id 范围内最后一个整数 id。
INPUT_METHOD_SEGMENT - 类 java.text.AttributedCharacterIterator.Attribute 中的静态变量
输入法段的属性键。
INPUT_METHOD_TEXT_CHANGED - 类 java.awt.event.InputMethodEvent 中的静态变量
事件类型，它指示修改的输入方法文本。
INPUT_METHOD_UNDERLINE - 类 java.awt.font.TextAttribute 中的静态变量
输入法下划线的属性键。
INPUT_TRAY_MISSING - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备中没有一个或多个输入纸盒。
INPUT_VALUE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
inputValue 的绑定属性名。
inputClass - 类 javax.imageio.spi.ImageInputStreamSpi 中的变量
指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
inputComponent - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
如果 optionPane.getWantsInput() 返回 true，则 JComponent 提供输入。
InputContext - java.awt.im 中的 类
提供控制诸如输入方法和键盘布局之类的文本输入设施的方法。
InputContext() - 类 java.awt.im.InputContext 的构造方法
构造一个 InputContext。
InputEvent - java.awt.event 中的 类
所有组件级别输入事件的根事件类。
InputMap - javax.swing 中的 类
InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。
InputMap() - 类 javax.swing.InputMap 的构造方法
创建一个没有父级和映射关系的 InputMap。
InputMapUIResource - javax.swing.plaf 中的 类
实现 UIResource 的 javax.swing.InputMap 的子类。
InputMapUIResource() - 类 javax.swing.plaf.InputMapUIResource 的构造方法
InputMethod - java.awt.im.spi 中的 接口
定义支持复杂文本输入的输入方法接口。
InputMethodContext - java.awt.im.spi 中的 接口
提供输入方法可以用来与其客户端组件通信或用来请求其他服务的方法。
InputMethodDescriptor - java.awt.im.spi 中的 接口
定义提供足够的关于输入方法启用选择和该输入方法加载信息的方法。
InputMethodEvent - java.awt.event 中的 类
输入方法事件包含有关使用输入方法进行撰写的文本的信息。
InputMethodEvent(Component, int, long, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - 类 java.awt.event.InputMethodEvent 的构造方法
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component, int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - 类 java.awt.event.InputMethodEvent 的构造方法
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component, int, TextHitInfo, TextHitInfo) - 类 java.awt.event.InputMethodEvent 的构造方法
通过指定源组件、类型、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodHighlight - java.awt.im 中的 类
InputMethodHighlight 用于描述正在撰写的文本的高亮显示属性。
InputMethodHighlight(boolean, int) - 类 java.awt.im.InputMethodHighlight 的构造方法
构造输入方法高亮显示记录。
InputMethodHighlight(boolean, int, int) - 类 java.awt.im.InputMethodHighlight 的构造方法
构造输入方法高亮显示记录。
InputMethodHighlight(boolean, int, int, Map<TextAttribute, ?>) - 类 java.awt.im.InputMethodHighlight 的构造方法
构造输入方法高亮显示记录。
InputMethodListener - java.awt.event 中的 接口
接收输入方法事件的侦听器接口。
InputMethodRequests - java.awt.im 中的 接口
InputMethodRequests 定义文本编辑组件为了与输入方法一起使用而必须处理的请求。
inputMethodTextChanged(InputMethodEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 inputMethodTextChanged 方法处理 inputMethodTextChanged 事件。
inputMethodTextChanged(InputMethodEvent) - 接口 java.awt.event.InputMethodListener 中的方法
当通过输入方法输入的文本发生变化时调用。
InputMismatchException - java.util 中的 异常
由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
InputMismatchException() - 异常 java.util.InputMismatchException 的构造方法
构造 InputMismatchException，使用 null 作为其错误消息字符串。
InputMismatchException(String) - 异常 java.util.InputMismatchException 的构造方法
构造 InputMismatchException，将引用保存到错误消息字符串 s 中，以便将来由 getMessage 方法获取。
InputSource - org.xml.sax 中的 类
XML 实体的单一输入源。
InputSource() - 类 org.xml.sax.InputSource 的构造方法
零参数默认构造方法。
InputSource(String) - 类 org.xml.sax.InputSource 的构造方法
使用系统标识符创建新的输入源。
InputSource(InputStream) - 类 org.xml.sax.InputSource 的构造方法
使用字节流创建新的输入源。
InputSource(Reader) - 类 org.xml.sax.InputSource 的构造方法
使用字符流创建新的输入源。
InputStream - java.io 中的 类
此抽象类是表示字节输入流的所有类的超类。
InputStream() - 类 java.io.InputStream 的构造方法
InputStream - org.omg.CORBA.portable 中的 类
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。
InputStream() - 类 org.omg.CORBA.portable.InputStream 的构造方法
InputStream - org.omg.CORBA_2_3.portable 中的 类
InputStream 提供从流读取所有映射的 IDL 类型的接口。
InputStream() - 类 org.omg.CORBA_2_3.portable.InputStream 的构造方法
InputStreamReader - java.io 中的 类
InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
InputStreamReader(InputStream) - 类 java.io.InputStreamReader 的构造方法
创建一个使用默认字符集的 InputStreamReader。
InputStreamReader(InputStream, String) - 类 java.io.InputStreamReader 的构造方法
创建使用指定字符集的 InputStreamReader。
InputStreamReader(InputStream, Charset) - 类 java.io.InputStreamReader 的构造方法
创建使用给定字符集的 InputStreamReader。
InputStreamReader(InputStream, CharsetDecoder) - 类 java.io.InputStreamReader 的构造方法
创建使用给定字符集解码器的 InputStreamReader。
InputSubset - java.awt.im 中的 类
定义输入方法使用的其他 Unicode 子集。
inputTypes - 类 javax.imageio.spi.ImageReaderSpi 中的变量
将从 getInputTypes 返回的 Class 对象数组，该数组最初为 null。
inputValue - 类 javax.swing.JOptionPane 中的变量
用户已输入的值。
InputVerifier - javax.swing 中的 类
此类的用途是通过带文本字段的 GUI 帮助客户端支持流畅的焦点导航。
InputVerifier() - 类 javax.swing.InputVerifier 的构造方法
inRange(Element) - 类 javax.swing.text.AbstractWriter 中的方法
此方法确定当前元素是否位于指定的范围内。
insert(String, int) - 类 java.awt.Choice 中的方法
将菜单项插入此选择的指定位置上。
INSERT - 类 java.awt.Event 中的静态变量
Insert 键，一个非 ASCII 操作键。
insert(MenuItem, int) - 类 java.awt.Menu 中的方法
将菜单项插入到此菜单的指定位置。
insert(String, int) - 类 java.awt.Menu 中的方法
将带有指定标签的菜单项插入到此菜单的指定位置。
insert(String, int) - 类 java.awt.TextArea 中的方法
在此文本区的指定位置插入指定文本。
insert(int, char[], int, int) - 类 java.lang.StringBuffer 中的方法
insert(int, Object) - 类 java.lang.StringBuffer 中的方法
insert(int, String) - 类 java.lang.StringBuffer 中的方法
insert(int, char[]) - 类 java.lang.StringBuffer 中的方法
insert(int, CharSequence) - 类 java.lang.StringBuffer 中的方法
insert(int, CharSequence, int, int) - 类 java.lang.StringBuffer 中的方法
insert(int, boolean) - 类 java.lang.StringBuffer 中的方法
insert(int, char) - 类 java.lang.StringBuffer 中的方法
insert(int, int) - 类 java.lang.StringBuffer 中的方法
insert(int, long) - 类 java.lang.StringBuffer 中的方法
insert(int, float) - 类 java.lang.StringBuffer 中的方法
insert(int, double) - 类 java.lang.StringBuffer 中的方法
insert(int, char[], int, int) - 类 java.lang.StringBuilder 中的方法
insert(int, Object) - 类 java.lang.StringBuilder 中的方法
insert(int, String) - 类 java.lang.StringBuilder 中的方法
insert(int, char[]) - 类 java.lang.StringBuilder 中的方法
insert(int, CharSequence) - 类 java.lang.StringBuilder 中的方法
insert(int, CharSequence, int, int) - 类 java.lang.StringBuilder 中的方法
insert(int, boolean) - 类 java.lang.StringBuilder 中的方法
insert(int, char) - 类 java.lang.StringBuilder 中的方法
insert(int, int) - 类 java.lang.StringBuilder 中的方法
insert(int, long) - 类 java.lang.StringBuilder 中的方法
insert(int, float) - 类 java.lang.StringBuilder 中的方法
insert(int, double) - 类 java.lang.StringBuilder 中的方法
INSERT - 接口 javax.accessibility.AccessibleTableModelChange 中的静态变量
标识新行和/或新列的插入。
INSERT - 类 javax.swing.event.DocumentEvent.EventType 中的静态变量
插入类型。
INSERT - 类 javax.swing.event.TableModelEvent 中的静态变量
标识新行或新列的添加。
insert(String, int) - 类 javax.swing.JMenu 中的方法
在给定位置插入具有指定文本的新菜单项。
insert(JMenuItem, int) - 类 javax.swing.JMenu 中的方法
在给定位置插入指定的 JMenuitem。
insert(Action, int) - 类 javax.swing.JMenu 中的方法
在给定位置插入连接到指定 Action 对象的新菜单项。
insert(Action, int) - 类 javax.swing.JPopupMenu 中的方法
在给定位置插入指定 Action 对象的菜单项。
insert(Component, int) - 类 javax.swing.JPopupMenu 中的方法
将指定组件插入到菜单的给定位置。
insert(String, int) - 类 javax.swing.JTextArea 中的方法
将指定文本插入指定位置。
insert(int, int, DefaultStyledDocument.ElementSpec[], AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
插入新内容。
insert(int, DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.DefaultStyledDocument 中的方法
批量插入新元素。
insert(int, DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.html.HTMLDocument 中的方法
批量插入新元素。
insert(int, View) - 类 javax.swing.text.View 中的方法
插入单个子视图。
insert(MutableTreeNode, int) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
从其现有父节点移除 newChild（如果它有父节点），将子节点的父节点设置为此节点，然后，将该子节点添加到此节点位于索引 childIndex 处的子节点数组。
insert(MutableTreeNode, int) - 接口 javax.swing.tree.MutableTreeNode 中的方法
将 child 添加到 index 位置的接收者。
insert(Any, Any[]) - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
insert(Any, boolean[]) - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
insert(Any, char[]) - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
insert(Any, CompletionStatus) - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
insert(Any, Current) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
insert(Any, DefinitionKind) - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
insert(Any, double[]) - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
insert(Any, float[]) - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
insert(Any, IDLType) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
insert(Any, long[]) - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
insert(Any, int[]) - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
insert(Any, NameValuePair) - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
insert(Any, Object) - 类 org.omg.CORBA.ObjectHelper 中的静态方法
insert(Any, byte[]) - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
insert(Any, ParameterMode) - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
insert(Any, short) - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
insert(Any, PolicyError) - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
insert(Any, Policy) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
insert(Any, Policy[]) - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
insert(Any, int) - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
insert(Any, ServiceDetail) - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
insert(Any, ServiceInformation) - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
insert(Any, SetOverrideType) - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
insert(Any, short[]) - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
insert(Any, String[]) - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.StringValueHelper 中的静态方法
insert(Any, StructMember) - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
insert(Any, long[]) - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
insert(Any, int[]) - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
insert(Any, UnionMember) - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
insert(Any, UnknownUserException) - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
insert(Any, short[]) - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
insert(Any, Serializable) - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
insert(Any, ValueMember) - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
insert(Any, short) - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
insert(Any, char[]) - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
insert(Any, WrongTransaction) - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
insert(Any, String[]) - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
insert(Any, Binding) - 类 org.omg.CosNaming.BindingHelper 中的静态方法
insert(Any, BindingIterator) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
insert(Any, Binding[]) - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
insert(Any, BindingType) - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
insert(Any, String) - 类 org.omg.CosNaming.IstringHelper 中的静态方法
insert(Any, NameComponent) - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
insert(Any, NameComponent[]) - 类 org.omg.CosNaming.NameHelper 中的静态方法
insert(Any, NamingContextExt) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
insert(Any, String) - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
insert(Any, InvalidAddress) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
insert(Any, String) - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
insert(Any, String) - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
insert(Any, NamingContext) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
insert(Any, AlreadyBound) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
insert(Any, CannotProceed) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
insert(Any, InvalidName) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
insert(Any, NotEmpty) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
insert(Any, NotFound) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
insert(Any, NotFoundReason) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
insert(Any, Any[]) - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
insert(Any, DynAnyFactory) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
insert(Any, InconsistentTypeCode) - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
insert(Any, DynAny) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
insert(Any, InvalidValue) - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
insert(Any, TypeMismatch) - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
insert(Any, DynAny[]) - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
insert(Any, DynArray) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
insert(Any, DynEnum) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
insert(Any, DynFixed) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
insert(Any, DynSequence) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
insert(Any, DynStruct) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
insert(Any, DynUnion) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
insert(Any, DynValue) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
insert(Any, String) - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
insert(Any, NameDynAnyPair) - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
insert(Any, NameDynAnyPair[]) - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
insert(Any, NameValuePair) - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
insert(Any, NameValuePair[]) - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
insert(Any, CodecFactory) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
insert(Any, UnknownEncoding) - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
insert(Any, FormatMismatch) - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
insert(Any, InvalidTypeForEncoding) - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
insert(Any, TypeMismatch) - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
insert(Any, int) - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
insert(Any, IOR) - 类 org.omg.IOP.IORHelper 中的静态方法
insert(Any, TaggedComponent[]) - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
insert(Any, int) - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
insert(Any, ServiceContext) - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
insert(Any, ServiceContext[]) - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
insert(Any, int) - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
insert(Any, TaggedComponent) - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
insert(Any, TaggedProfile) - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
insert(Any, short) - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
insert(Any, int) - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
insert(Any, String[]) - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
insert(Any, short) - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
insert(Any, Current) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
insert(Any, ForwardRequest) - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
insert(Any, InvalidSlot) - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
insert(Any, IORInterceptor_3_0) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
insert(Any, byte[]) - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
insert(Any, ObjectReferenceFactory) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
insert(Any, ObjectReferenceTemplate) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
insert(Any, ObjectReferenceTemplate[]) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
insert(Any, String) - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
insert(Any, DuplicateName) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
insert(Any, InvalidName) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
insert(Any, String) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
insert(Any, String) - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
insert(Any, Current) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
insert(Any, NoContext) - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
insert(Any, ForwardRequest) - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
insert(Any, POA) - 类 org.omg.PortableServer.POAHelper 中的静态方法
insert(Any, AdapterInactive) - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
insert(Any, AdapterAlreadyExists) - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
insert(Any, AdapterNonExistent) - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
insert(Any, InvalidPolicy) - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
insert(Any, NoServant) - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
insert(Any, ObjectAlreadyActive) - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
insert(Any, ObjectNotActive) - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
insert(Any, ServantAlreadyActive) - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
insert(Any, ServantNotActive) - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
insert(Any, WrongAdapter) - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
insert(Any, WrongPolicy) - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
insert(Any, ServantActivator) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
insert(Any, ServantLocator) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
insert_any(Any) - 类 org.omg.CORBA.Any 中的方法
将给定 Any 对象插入此 Any 对象的 value 字段。
insert_any(Any) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 org.omg.CORBA.Any 对象作为此 DynAny 对象的值。
insert_any(Any) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 Any 值插入由此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_any(Any) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 Any 值插入此 DynAny 表示的 Any 中。
insert_boolean(boolean) - 类 org.omg.CORBA.Any 中的方法
将给定 boolean 值插入此 Any 对象的 value 字段。
insert_boolean(boolean) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 boolean 值作为此 DynAny 对象的值。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 boolean 值插入 DynAny 中。
insert_boolean(boolean) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 boolean 值插入 DynAny 中。
insert_char(char) - 类 org.omg.CORBA.Any 中的方法
将给定 char 值插入此 Any 对象的 value 字段。
insert_char(char) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 char 值作为此 DynAny 对象的值。
insert_char(char) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 char 值插入 DynAny 中。
insert_char(char) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 char 值插入 DynAny 中。
insert_double(double) - 类 org.omg.CORBA.Any 中的方法
将给定 double 值插入此 Any 对象的 value 字段。
insert_double(double) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 double 值作为此 DynAny 对象的值。
insert_double(double) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 double 值插入 DynAny 中。
insert_double(double) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 double 值插入 DynAny 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将参数 DynAny 中所包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_dyn_any(DynAny) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将参数 DynAny 中包含的 Any 值插入此 DynAny 表示的 Any 中。
insert_fixed(BigDecimal) - 类 org.omg.CORBA.Any 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
insert_fixed(BigDecimal, TypeCode) - 类 org.omg.CORBA.Any 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
insert_float(float) - 类 org.omg.CORBA.Any 中的方法
将给定 float 值插入此 Any 对象的 value 字段。
insert_float(float) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 float 值作为此 DynAny 对象的值。
insert_float(float) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 float 值插入 DynAny 中。
insert_float(float) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 float 值插入 DynAny 中。
insert_long(int) - 类 org.omg.CORBA.Any 中的方法
将给定 int 值插入此 Any 对象的 value 字段。
insert_long(int) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 int 值作为此 DynAny 对象的值。
insert_long(int) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 integer 值插入 DynAny 中。
insert_long(int) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 integer 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.CORBA.Any 中的方法
将给定 long 值插入此 Any 对象的 value 字段。
insert_longlong(long) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 long 值作为此 DynAny 对象的值。
insert_longlong(long) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 long 值插入 DynAny 中。
insert_longlong(long) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 long 值插入 DynAny 中。
insert_Object(Object) - 类 org.omg.CORBA.Any 中的方法
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
insert_Object(Object, TypeCode) - 类 org.omg.CORBA.Any 中的方法
将给定 org.omg.CORBA.Object 对象插入此 Any 对象的 value 字段。
insert_octet(byte) - 类 org.omg.CORBA.Any 中的方法
将给定 byte 值插入此 Any 对象的 value 字段。
insert_octet(byte) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 byte 值作为此 DynAny 对象的值。
insert_octet(byte) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 byte 值插入 DynAny 中。
insert_octet(byte) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 byte 值插入 DynAny 中。
insert_Principal(Principal) - 类 org.omg.CORBA.Any 中的方法
已过时。 由 CORBA 2.2 取代。
insert_reference(Object) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 org.omg.CORBA.Object 作为此 DynAny 对象的值。
insert_reference(Object) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将对 CORBA 对象的引用插入 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将对 CORBA 对象的引用插入 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将对 CORBA 对象的引用插入 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
insert_reference(Object) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将对 CORBA 对象的引用插入到 DynAny 中。
INSERT_ROW_CONFLICT - 接口 javax.sql.rowset.spi.SyncResolver 中的静态变量
指示在 RowSet 对象试图将行插入数据源中时发生冲突。
insert_short(short) - 类 org.omg.CORBA.Any 中的方法
将给定 short 值插入此 Any 对象的 value 字段。
insert_short(short) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 short 值作为此 DynAny 对象的值。
insert_short(short) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 short 值插入 DynAny 中。
insert_short(short) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 short 值插入 DynAny 中。
insert_Streamable(Streamable) - 类 org.omg.CORBA.Any 中的方法
将给定 Streamable 对象插入此 Any 对象的 value 字段。
insert_string(String) - 类 org.omg.CORBA.Any 中的方法
将给定 String 对象插入此 Any 对象的 value 字段。
insert_string(String) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 String 对象作为此 DynAny 对象的值。
insert_string(String) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 string 值插入 DynAny 中。
insert_string(String) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 string 值插入 DynAny 中。
insert_TypeCode(TypeCode) - 类 org.omg.CORBA.Any 中的方法
将给定 TypeCode 对象插入此 Any 对象的 value 字段。
insert_typecode(TypeCode) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 org.omg.CORBA.TypeCode 值作为此 DynAny 对象的值。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_typecode(TypeCode) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 TypeCode 对象插入 DynAny 中。
insert_ulong(int) - 类 org.omg.CORBA.Any 中的方法
将给定 int 值插入此 Any 对象的 value 字段。
insert_ulong(int) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 int 值作为此 DynAny 对象的值。
insert_ulong(int) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 integer 值插入 DynAny 中。
insert_ulong(int) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 integer 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.CORBA.Any 中的方法
将给定 long 值插入此 Any 对象的 value 字段。
insert_ulonglong(long) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 long 值作为此 DynAny 对象的值。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 long 值插入 DynAny 中。
insert_ulonglong(long) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 long 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.CORBA.Any 中的方法
将给定 short 值插入此 Any 对象的 value 字段。
insert_ushort(short) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 short 值作为此 DynAny 对象的值。
insert_ushort(short) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 short 值插入 DynAny 中。
insert_ushort(short) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 short 值插入 DynAny 中。
insert_val(Serializable) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 java.io.Serializable 对象作为此 DynAny 对象的值。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_val(Serializable) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将对 Serializable 对象的引用插入此 DynAny 中。
insert_Value(Serializable) - 类 org.omg.CORBA.Any 中的方法
将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
insert_Value(Serializable, TypeCode) - 类 org.omg.CORBA.Any 中的方法
将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
insert_wchar(char) - 类 org.omg.CORBA.Any 中的方法
将给定 char 值插入此 Any 对象的 value 字段。
insert_wchar(char) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 char 值作为此 DynAny 对象的值。
insert_wchar(char) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 char 值插入 DynAny 中。
insert_wchar(char) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 char 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.CORBA.Any 中的方法
将给定 String 对象插入此 Any 对象的 value 字段。
insert_wstring(String) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 插入给定 String 作为此 DynAny 对象的值。
insert_wstring(String) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 string 值插入 DynAny 中。
insert_wstring(String) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将 string 值插入 DynAny 中。
insertAfterEnd(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
将指定为字符串的 HTML 插入给定元素的起始处之后。
insertAfterStart(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
将指定为字符串的 HTML 插入元素的起始处。
insertAtBoundary(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的方法
当在边界上插入时调用。
insertAtBoundry(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的方法
已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
insertBefore(Node, Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
在现有子节点 refChild 之前插入节点 newChild。
insertBefore(Node, Node) - 接口 org.w3c.dom.Node 中的方法
在现有子节点 refChild 之前插入节点 newChild。
insertBeforeEnd(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
将指定为字符串的 HTML 插入元素的结尾处。
insertBeforeStart(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
将指定为字符串的 HTML 插入给定元素的起始处之前。
insertBreakAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
向文档放置行/段中断的动作名称。
insertChar(AttributedCharacterIterator, int) - 类 java.awt.font.LineBreakMeasurer 中的方法
将单个字符插入文本后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
insertChar(AttributedCharacterIterator, int) - 类 java.awt.font.TextMeasurer 中的方法
在将单个字符插入当前由此 TextMeasurer 表示的段落中后，更新该 TextMeasurer。
insertComponent(Component) - 类 javax.swing.JTextPane 中的方法
将一个组件插入到文档中，以替换当前选择的内容。
insertContentAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将内容置于关联文档中的动作名称。
insertData(int, String) - 接口 org.w3c.dom.CharacterData 中的方法
在指定的 16 位单元偏移量位置插入一个字符串。
insertElementAt(E, int) - 类 java.util.Vector 中的方法
将指定对象作为此向量中的组件插入到指定的 index 处。
insertElementAt(Object, int) - 类 javax.swing.DefaultComboBoxModel 中的方法
insertElementAt(Object, int) - 类 javax.swing.DefaultListModel 中的方法
将指定对象作为此列表中的组件插入到指定的 index 处。
insertElementAt(Object, int) - 接口 javax.swing.MutableComboBoxModel 中的方法
在指定索引处添加项。
insertEntries(int, int, int) - 类 javax.swing.SizeSequence 中的方法
将一组相邻的条目添加到此 SizeSequence 中。
insertHTML(HTMLDocument, int, String, int, int, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
将 HTML 插入现有文档。
insertHTML(JEditorPane, HTMLDocument, int, String, int, int, HTML.Tag) - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的方法
HTMLEditorKit.insertHTML 的一个覆盖。
insertIcon(Icon) - 类 javax.swing.JTextPane 中的方法
将一个图标插入文档中，以替换当前选择的内容。
insertIndexForLayer(int, int) - 类 javax.swing.JLayeredPane 中的方法
一个根据层和位置要求确定插入新子组件的正确位置的基本方法。
insertIndexInterval(int, int, boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
从 index 之前/之后开始插入 length 个索引。
insertIndexInterval(int, int, boolean) - 接口 javax.swing.ListSelectionModel 中的方法
在 index 之前/之后开始插入 length 个索引。
insertItemAt(Object, int) - 类 javax.swing.JComboBox 中的方法
在项列表中的给定索引处插入项。
insertNodeInto(MutableTreeNode, MutableTreeNode, int) - 类 javax.swing.tree.DefaultTreeModel 中的方法
对它进行调用，以便在父节点的子节点中的 index 位置插入 newChild。
insertProviderAt(Provider, int) - 类 java.security.Security 中的静态方法
在指定的位置添加新的提供者。
insertRow() - 接口 java.sql.ResultSet 中的方法
将插入行的内容插入到此 ResultSet 对象和数据库中。
insertRow(int, Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
在模型中的 row 位置插入一行。
insertRow(int, Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
在模型中的 row 位置插入一行。
insertsAreDetected(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以通过调用 ResultSet.rowInserted 方法检测可见行的插入。
insertSeparator(int) - 类 java.awt.Menu 中的方法
在指定的位置插入分隔符。
insertSeparator(int) - 类 javax.swing.JMenu 中的方法
在指定的位置插入分隔符。
insertString(int, String) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
向序列中插入一个字符串。
insertString(int, String, AttributeSet) - 类 javax.swing.text.AbstractDocument 中的方法
将某些内容插入文档。
insertString(int, String, AttributeSet) - 接口 javax.swing.text.Document 中的方法
插入内容字符串。
insertString(int, String, AttributeSet) - 类 javax.swing.text.DocumentFilter.FilterBypass 中的方法
插入指定的文本，绕过 DocumentFilter。
insertString(DocumentFilter.FilterBypass, int, String, AttributeSet) - 类 javax.swing.text.DocumentFilter 中的方法
将文本插入指定的 Document 之前调用。
insertString(int, String) - 类 javax.swing.text.GapContent 中的方法
在内容中插入字符串。
insertString(int, String, AttributeSet) - 类 javax.swing.text.PlainDocument 中的方法
向文档中插入某些内容。
insertString(int, String) - 类 javax.swing.text.StringContent 中的方法
将字符串插入到内容中。
insertTab(String, Icon, Component, String, int) - 类 javax.swing.JTabbedPane 中的方法
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。
insertTabAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将制表符置于文档中的动作名称。
insertText(String, int) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 insert(String, int) 取代。
insertTextAtIndex(int, String) - 接口 javax.accessibility.AccessibleEditableText 中的方法
在给定索引处插入指定的字符串。
insertTextAtIndex(int, String) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
在给定索引处插入指定的字符串。
insertTextAtIndex(int, String) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
在给定索引处插入指定字符串
insertUpdate(DocumentEvent) - 接口 javax.swing.event.DocumentListener 中的方法
给出对文档执行了插入操作的通知。
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - 类 javax.swing.text.AbstractDocument 中的方法
在文本插入后更新文档结构。
insertUpdate(DefaultStyledDocument.ElementSpec[]) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
向文档添加更新。
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - 类 javax.swing.text.DefaultStyledDocument 中的方法
在文本插入后更新文档结构。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FieldView 中的方法
通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(FlowView, DocumentEvent, Rectangle) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
发出通知，通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FlowView 中的方法
发出通知，通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.GlyphView 中的方法
发出通知，通知文档中此视图负责的位置已插入内容。
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - 类 javax.swing.text.html.HTMLDocument 中的方法
由于插入文本而导致更新文档的结构。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.InlineView 中的方法
发出通知，通知文档中此视图负责的位置已插入内容。
insertUpdate(DocumentEvent) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
处理文档插入（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - 类 javax.swing.text.PlainDocument 中的方法
随文本插入更新文档结构。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.PlainView 中的方法
发出通知，通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
发出通知，通知在文档中此视图负责的某个位置已插入内容。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.WrappedPlainView 中的方法
发出在文档中此视图负责的位置插入了某些内容的通知。
insertUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.ZoneView 中的方法
给出在文档中此视图负责的位置插入了某些内容的通知。
insetCache - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
insets() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 getInsets() 取代。
insets - 类 java.awt.GridBagConstraints 中的变量
此字段指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。
Insets - java.awt 中的 类
Insets 对象是容器边界的表示形式。
Insets(int, int, int, int) - 类 java.awt.Insets 的构造方法
创建并初始化具有指定顶部、左边、底部、右边 inset 的新 Insets 对象。
InsetsUIResource - javax.swing.plaf 中的 类
InsetsUIResource(int, int, int, int) - 类 javax.swing.plaf.InsetsUIResource 的构造方法
inside(int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
inside(int, int) - 类 java.awt.Polygon 中的方法
已过时。 从 JDK version 1.1 开始, 此函数为 contains(int, int)。
inside(int, int) - 类 java.awt.Rectangle 中的方法
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
insideBorder - 类 javax.swing.border.CompoundBorder 中的变量
install(JFormattedTextField) - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
将 AbstractFormatter 安装到特定的 JFormattedTextField。
install(JTextComponent) - 接口 javax.swing.text.Caret 中的方法
在将 UI 安装到 JTextComponent 的接口中时调用。
install(JTextComponent) - 类 javax.swing.text.DefaultCaret 中的方法
当 UI 装入一个 JTextComponent 的接口时调用。
install(JFormattedTextField) - 类 javax.swing.text.DefaultFormatter 中的方法
将 DefaultFormatter 安装到特定的 JFormattedTextField。
install(JTextComponent) - 类 javax.swing.text.DefaultHighlighter 中的方法
当 UI 安装到 JTextComponent 的接口时调用。
install(JEditorPane) - 类 javax.swing.text.EditorKit 中的方法
将工具包安装到 JEditorPane 中时调用。
install(JTextComponent) - 接口 javax.swing.text.Highlighter 中的方法
将 UI 安装到 JTextComponent 的接口时调用。
install(JEditorPane) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
将工具包安装到 JEditorPane 中时调用。
install(JFormattedTextField) - 类 javax.swing.text.InternationalFormatter 中的方法
将 DefaultFormatter 安装到特定的 JFormattedTextField 上。
install(JFormattedTextField) - 类 javax.swing.text.MaskFormatter 中的方法
将 DefaultFormatter 安装在特定的 JFormattedTextField 上。
install(JEditorPane) - 类 javax.swing.text.StyledEditorKit 中的方法
工具包安装到 JEditorPane 时调用。
installAncestorListener() - 类 javax.swing.JComboBox 中的方法
installBorder(JComponent, String) - 类 javax.swing.LookAndFeel 中的静态方法
使用默认的值设置组件边框属性的便捷方法。
installChooserPanel(JColorChooser) - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
将面板添加到选取器时被调用。
installColors(JComponent, String, String) - 类 javax.swing.LookAndFeel 中的静态方法
使用默认的值设置组件的前景和背景颜色属性的便捷方法。
installColorsAndFont(JComponent, String, String, String) - 类 javax.swing.LookAndFeel 中的静态方法
使用默认的值设置组件的前景、背景和字体属性的便捷方法。
installComboBoxListeners() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此方法在 JComboBox 中添加必需的侦听器。
installComboBoxModelListeners(ComboBoxModel) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
在组合框模型中安装侦听器。
installComponents() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
创建并初始化构成聚合组合框的组件。
installComponents() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
installComponents(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installComponents(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installComponents(JMenuItem) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
installComponents(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
创建并安装 JTabbedPane 的所有必需的子组件。
installComponents() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installComponents() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
安装作为渲染器窗格的树的子组件。
installComponents() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
installComponents(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
将默认颜色、默认字体、默认渲染器和默认编辑器安装到 JComboBox 中。
installDefaults() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
installDefaults(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installDefaults(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
初始化 JList 属性（如字体、前景和背景）并添加 CellRendererPane。
installDefaults() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
installDefaults(JPanel) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicPasswordFieldUI 中的方法
在 JPasswordField 上安装所需的属性。
installDefaults() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
installDefaults(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installDefaults(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
installDefaults(JSeparator) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
installDefaults(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
初始化 JSpinner border、foreground、background 属性以及基于默认表中对应的 "Spinner.*" 属性。
installDefaults() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
安装 UI 默认值。
installDefaults() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
初始化 JTableHeader 属性，例如，字体、前景和背景。
installDefaults() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
初始化 JTable 属性，例如，字体、前景和背景。
installDefaults() - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
初始化组件属性，例如，字体、前景、背景、插入符颜色、选择颜色、所选文本颜色、禁用文本颜色，以及边框颜色。
installDefaults(JSeparator) - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installDefaults(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
installDefaults() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
installDefaults(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalCheckBoxUI 中的方法
installDefaults() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
installDefaults() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法
installDefaults() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
installDefaults(JSeparator) - 类 javax.swing.plaf.metal.MetalSeparatorUI 中的方法
installDefaults() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
installDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
installDefaults(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
在 context 的 JComponent 上根据此 Style 安装必要的状态。
installDesktopManager() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
installIcons(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installKeyboardActions(JComponent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
注册默认键动作：按下空格键以“单击”按钮并注册键盘助记符（如果有）。
installKeyboardActions(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
将键盘动作添加到 JComboBox。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installKeyboardActions(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
在与 BasicListUI 关联的 JList 上注册键盘绑定。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
installKeyboardActions(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installKeyboardActions(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
installKeyboardActions(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
在 JSpinner 上安装键盘动作。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
安装 UI 的键盘动作。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
在 JTableHeader 上注册所有的键盘动作。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
在 JTable 上注册所有的键盘动作。
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
installKeyboardActions() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
installListeners(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
为组合框及其模型创建并安装侦听器。
installListeners() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
将从 createPropertyChangeListener 返回的 PropertyChangeListener 安装到 JDesktopPane 上。
installListeners(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installListeners(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
为 JList、其模型及其 selectionModel 创建并安装侦听器。
installListeners() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
installListeners(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installListeners(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
installListeners(JSeparator) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
installListeners(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
用将感兴趣的 PropertyChangeEvent 委托给受保护方法的共享对象初始化 PropertyChangeListener。
installListeners() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
安装 UI 的事件侦听器。
installListeners() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
将侦听器附加到 JTableHeader 上。
installListeners() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
将侦听器附加到 JTable 上。
installListeners() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
安装 UI 的侦听器。
installListeners() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installListeners(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
installListeners() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
installListeners() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
installListeners(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
installListeners() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
installListeners() - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
installListeners(JScrollPane) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
installListeners() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
installListListeners() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
将侦听器添加到列表控件。
installLookAndFeel(UIManager.LookAndFeelInfo) - 类 javax.swing.UIManager 中的静态方法
将指定的外观添加到可用外观的集合中。
installLookAndFeel(String, String) - 类 javax.swing.UIManager 中的静态方法
将指定的外观添加到可用外观的集合中。
installMouseHandlers(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installNextButtonListeners(Component) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
在下一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
installNonRolloverBorders(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
在 JComponent 的所有子组件上安装非翻转边框。
installNormalBorders(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
在 JComponent 的所有子组件上安装普通边框。
installPreviewPanel() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
installPreviousButtonListeners(Component) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
在上一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
installProperty(JComponent, String, Object) - 类 javax.swing.LookAndFeel 中的静态方法
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。
installRolloverBorders(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
在 JComponent 的所有子组件上安装翻转边框。
installStrings(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installStrings(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
installTitlePane() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
安装组件的 UI。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
按顺序调用 installDefaults()、installListeners() 和 installKeyboardActions() 来初始化 this.list。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
安装作为传入 JOptionPane 的 L&F 的接收者。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
调用 installDefaults、installListeners，然后添加由 createNextButton、createPreviousButton 和 createEditor 返回的组件。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
安装 UI。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
安装组件的 UI。
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
配置指定组件，使其适合外观。
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalMenuBarUI 中的方法
配置指定组件，使其适合 metal 外观。
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalRootPaneUI 中的方法
调用 installUI 的超实现来在传入的 JRootPane 上安装必要的状态，以呈现 RootPaneUI 的 metal 外观实现。
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
installUI(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 installUI 方法。
InstanceAlreadyExistsException - javax.management 中的 异常
已经在存储库中注册了 MBean。
InstanceAlreadyExistsException() - 异常 javax.management.InstanceAlreadyExistsException 的构造方法
默认的构造方法。
InstanceAlreadyExistsException(String) - 异常 javax.management.InstanceAlreadyExistsException 的构造方法
允许指定特定错误消息的构造方法。
instanceFollowRedirects - 类 java.net.HttpURLConnection 中的变量
如果为 true，则协议自动执行重定向。
InstanceNotFoundException - javax.management 中的 异常
存储库中不存在指定的 MBean。
InstanceNotFoundException() - 异常 javax.management.InstanceNotFoundException 的构造方法
默认的构造方法。
InstanceNotFoundException(String) - 异常 javax.management.InstanceNotFoundException 的构造方法
允许指定特定错误消息的构造方法。
instantiate(ClassLoader, String) - 类 java.beans.Beans 中的静态方法
实例化 JavaBean。
instantiate(ClassLoader, String, BeanContext) - 类 java.beans.Beans 中的静态方法
实例化 JavaBean。
instantiate(ClassLoader, String, BeanContext, AppletInitializer) - 类 java.beans.Beans 中的静态方法
实例化 bean。
instantiate(Object, Encoder) - 类 java.beans.DefaultPersistenceDelegate 中的方法
instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。
instantiate(Object, Encoder) - 类 java.beans.PersistenceDelegate 中的方法
返回其值为 oldInstance 的表达式。
instantiate(String) - 接口 javax.management.MBeanServer 中的方法
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。
instantiate(String, ObjectName) - 接口 javax.management.MBeanServer 中的方法
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
instantiate(String, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。
instantiate(String, ObjectName, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
实例化一个对象。
instantiateChild(String) - 接口 java.beans.beancontext.BeanContext 中的方法
实例化指定为此 BeanContext 的一个子级的 javaBean。
instantiateChild(String) - 类 java.beans.beancontext.BeanContextSupport 中的方法
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。
InstantiationError - java.lang 中的 错误
当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
InstantiationError() - 错误 java.lang.InstantiationError 的构造方法
构造不带详细消息的 InstantiationError。
InstantiationError(String) - 错误 java.lang.InstantiationError 的构造方法
构造带指定详细消息的 InstantiationError。
InstantiationException - java.lang 中的 异常
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
InstantiationException() - 异常 java.lang.InstantiationException 的构造方法
构造不带详细消息的 InstantiationException。
InstantiationException(String) - 异常 java.lang.InstantiationException 的构造方法
构造带指定详细消息的 InstantiationException。
Instrument - javax.sound.midi 中的 类
乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。
Instrument(Soundbank, Patch, String, Class<?>) - 类 javax.sound.midi.Instrument 的构造方法
从指定的 Patch 构造一个新的 MIDI 乐器。
Instrumentation - java.lang.instrument 中的 接口
此类提供检测 Java 编程语言代码所需的服务。
InsufficientResourcesException - javax.naming 中的 异常
当无法使用资源完成所请求的操作时，抛出此异常。
InsufficientResourcesException(String) - 异常 javax.naming.InsufficientResourcesException 的构造方法
使用解释构造一个新的 InsufficientResourcesException 实例。
InsufficientResourcesException() - 异常 javax.naming.InsufficientResourcesException 的构造方法
构造一个新的 InsufficientResourcesException 实例，将解释和所有名称解析字段初始化为 null。
insureRowContinuity() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
确保当前选择的 TreePath 对于当前选择模式是有效的。
insureUniqueness() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
此方法已过时，并且其实现现在是一个 noop。
intBitsToFloat(int) - 类 java.lang.Float 中的静态方法
返回对应于给定位表示形式的 float 值。
IntBuffer - java.nio 中的 类
int 缓冲区。
Integer - java.lang 中的 类
Integer 类在对象中包装了一个基本类型 int 的值。
Integer(int) - 类 java.lang.Integer 的构造方法
构造一个新分配的 Integer 对象，它表示指定的 int 值。
Integer(String) - 类 java.lang.Integer 的构造方法
构造一个新分配的 Integer 对象，它表示 String 参数所指示的 int 值。
INTEGER - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 INTEGER 的 Java 编程语言中的常量（有时称为类型代码）。
INTEGER - 类 java.text.NumberFormat.Field 中的静态变量
标识整数字段的常量。
INTEGER - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Integer 的值。
INTEGER_FIELD - 类 java.text.NumberFormat 中的静态变量
用于构造 FieldPosition 对象的字段常量。
IntegerSyntax - javax.print.attribute 中的 类
类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
IntegerSyntax(int) - 类 javax.print.attribute.IntegerSyntax 的构造方法
使用给定的整数值构造一个新的整数属性。
IntegerSyntax(int, int, int) - 类 javax.print.attribute.IntegerSyntax 的构造方法
使用给定的整数值构造一个新的整数属性，它必须位于给定的范围内。
Interceptor - org.omg.PortableInterceptor 中的 接口
所有 Portable Interceptor 实现 Interceptor。
InterceptorOperations - org.omg.PortableInterceptor 中的 接口
所有 Portable Interceptor 实现 Interceptor。
interestOps() - 类 java.nio.channels.SelectionKey 中的方法
获取此键的 interest 集合。
interestOps(int) - 类 java.nio.channels.SelectionKey 中的方法
将此键的 interest 集合设置为给定值。
INTERFACE - 类 java.lang.reflect.Modifier 中的静态变量
表示 interface 修饰符的 int 的值。
INTERFACE_CLASS_NAME_FIELD - 类 javax.management.JMX 中的静态变量
interfaceClassName 字段的名称。
InterfaceAddress - java.net 中的 类
此类表示网络接口地址。
INTERLOCK_OPEN - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
打印机上的一个或多个连锁设备未锁定。
intern() - 类 java.lang.String 中的方法
返回字符串对象的规范化表示形式。
INTERNAL - org.omg.CORBA 中的 异常
此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
INTERNAL() - 异常 org.omg.CORBA.INTERNAL 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。
INTERNAL(String) - 异常 org.omg.CORBA.INTERNAL 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。
INTERNAL(int, CompletionStatus) - 异常 org.omg.CORBA.INTERNAL 的构造方法
使用指定次要代码和完成状态构造一个 INTERNAL 异常。
INTERNAL(String, int, CompletionStatus) - 异常 org.omg.CORBA.INTERNAL 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INTERNAL 异常。
INTERNAL_CLOCK - 类 javax.sound.midi.Sequencer.SyncMode 中的静态变量
主同步模式，它使 sequencer 从其内部时钟获取计时信息。
INTERNAL_FRAME - 类 javax.accessibility.AccessibleRole 中的静态变量
通过桌面窗格剪切的类似于窗体的对象。
INTERNAL_FRAME - 类 javax.swing.plaf.synth.Region 中的静态变量
InternalFrame 的 region。
INTERNAL_FRAME_ACTIVATED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口激活”事件类型。
INTERNAL_FRAME_CLOSED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口关闭”事件。
INTERNAL_FRAME_CLOSING - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口正在关闭”事件。
INTERNAL_FRAME_DEACTIVATED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口取消激活”事件类型。
INTERNAL_FRAME_DEICONIFIED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口取消图标化”事件类型。
INTERNAL_FRAME_FIRST - 类 javax.swing.event.InternalFrameEvent 中的静态变量
用于内部窗体事件的 ID 范围的起始编号。
INTERNAL_FRAME_ICONIFIED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口图标化”事件。
INTERNAL_FRAME_LAST - 类 javax.swing.event.InternalFrameEvent 中的静态变量
用于内部窗体事件的 ID 范围的结束编号。
INTERNAL_FRAME_OPENED - 类 javax.swing.event.InternalFrameEvent 中的静态变量
“窗口打开”事件。
INTERNAL_FRAME_TITLE_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
InternalFrame 的 TitlePane。
internalEntityDecl(String, String) - 接口 org.xml.sax.ext.DeclHandler 中的方法
报告内部实体声明。
internalEntityDecl(String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
InternalError - java.lang 中的 错误
该异常指示 Java 虚拟机中出现一些意外的内部错误。
InternalError() - 错误 java.lang.InternalError 的构造方法
构造不带详细消息的 InternalError。
InternalError(String) - 错误 java.lang.InternalError 的构造方法
构造带指定详细消息的 InternalError。
internalFrameActivated(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体被激活时调用。
internalFrameActivated(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体被激活时调用。
internalFrameActivated(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
InternalFrameAdapter - javax.swing.event 中的 类
用于接收内部窗体事件的抽象适配器类。
InternalFrameAdapter() - 类 javax.swing.event.InternalFrameAdapter 的构造方法
internalFrameClosed(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体已关闭时调用。
internalFrameClosed(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体已关闭时调用。
internalFrameClosed(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
internalFrameClosing(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体正被关闭时调用。
internalFrameClosing(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体正被关闭时调用。
internalFrameClosing(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
internalFrameDeactivated(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体被取消激活时调用。
internalFrameDeactivated(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体被取消激活时调用。
internalFrameDeactivated(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
internalFrameDeiconified(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体被取消图标化时调用。
internalFrameDeiconified(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体被取消图标化时调用。
internalFrameDeiconified(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
InternalFrameEvent - javax.swing.event 中的 类
以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
InternalFrameEvent(JInternalFrame, int) - 类 javax.swing.event.InternalFrameEvent 的构造方法
构造一个 InternalFrameEvent 对象。
InternalFrameFocusTraversalPolicy - javax.swing 中的 类
该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。
InternalFrameFocusTraversalPolicy() - 类 javax.swing.InternalFrameFocusTraversalPolicy 的构造方法
internalFrameIconified(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体被图标化时调用。
internalFrameIconified(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体被图标化时调用。
internalFrameIconified(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
internalFrameLayout - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
InternalFrameListener - javax.swing.event 中的 接口
用于接收内部窗体事件的侦听器接口。
internalFrameOpened(InternalFrameEvent) - 类 javax.swing.event.InternalFrameAdapter 中的方法
当内部窗体已打开时调用。
internalFrameOpened(InternalFrameEvent) - 接口 javax.swing.event.InternalFrameListener 中的方法
当内部窗体已打开时调用。
internalFrameOpened(InternalFrameEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener 中的方法
InternalFrameUI - javax.swing.plaf 中的 类
JInternalFrame 的可插入外观界面。
InternalFrameUI() - 类 javax.swing.plaf.InternalFrameUI 的构造方法
internalGet(int) - 类 java.util.Calendar 中的方法
返回给定日历字段的值。
InternationalFormatter - javax.swing.text 中的 类
InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
InternationalFormatter() - 类 javax.swing.text.InternationalFormatter 的构造方法
创建一个不带指定 Format 的 InternationalFormatter。
InternationalFormatter(Format) - 类 javax.swing.text.InternationalFormatter 的构造方法
创建一个具有指定 Format 实例的 InternationalFormatter。
INTERPRETER_RESOURCE_UNAVAILABLE - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
解释器资源（例如字体、格式）不可用。
interrupt() - 类 java.lang.Thread 中的方法
中断线程。
interrupt() - 类 java.lang.ThreadGroup 中的方法
中断此线程组中的所有线程。
interrupted() - 类 java.lang.Thread 中的静态方法
测试当前线程是否已经中断。
InterruptedException - java.lang 中的 异常
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
InterruptedException() - 异常 java.lang.InterruptedException 的构造方法
构造不带详细消息的 InterruptedException。
InterruptedException(String) - 异常 java.lang.InterruptedException 的构造方法
构造带指定详细消息的 InterruptedException。
InterruptedIOException - java.io 中的 异常
I/O 操作已中断信号，抛出此异常。
InterruptedIOException() - 异常 java.io.InterruptedIOException 的构造方法
构造一个 InterruptedIOException，使用 null 作为其错误消息。
InterruptedIOException(String) - 异常 java.io.InterruptedIOException 的构造方法
构造带指定详细消息的 InterruptedIOException。
InterruptedNamingException - javax.naming 中的 异常
当正被调用的命名操作已经被中断时，抛出此异常。
InterruptedNamingException(String) - 异常 javax.naming.InterruptedNamingException 的构造方法
使用问题的解释构造一个 InterruptedNamingException 实例。
InterruptedNamingException() - 异常 javax.naming.InterruptedNamingException 的构造方法
构造一个 InterruptedNamingException 实例，将解释和所有名称解析字段初始化为 null。
InterruptibleChannel - java.nio.channels 中的 接口
可被异步关闭和中断的通道。
intersect(Area) - 类 java.awt.geom.Area 中的方法
将此 Area 的形状设置为其当前形状与指定 Area 形状的交集。
intersect(Rectangle2D, Rectangle2D, Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的静态方法
将指定的一对源 Rectangle2D 对象相交，并将结果置于指定的目标 Rectangle2D 对象中。
INTERSECT - 类 javax.xml.crypto.dsig.spec.XPathType.Filter 中的静态变量
相交过滤操作。
intersection(Rectangle) - 类 java.awt.Rectangle 中的方法
计算此 Rectangle 与指定 Rectangle 的交集。
intersects(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
确定弧的内部与指定矩形的内部是否相交。
intersects(double, double, double, double) - 类 java.awt.geom.Area 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.Area 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.CubicCurve2D 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.Ellipse2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.Line2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.Line2D 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(PathIterator, double, double, double, double) - 类 java.awt.geom.Path2D 中的静态方法
测试指定 PathIterator 的内部是否与指定直角坐标集的内部相交。
intersects(PathIterator, Rectangle2D) - 类 java.awt.geom.Path2D 中的静态方法
测试指定 PathIterator 的内部是否与指定 Rectangle2D 的内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.Path2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.Path2D 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.QuadCurve2D 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.geom.RectangularShape 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(double, double, double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(double, double, double, double) - 类 java.awt.Polygon 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 类 java.awt.Polygon 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(Rectangle) - 类 java.awt.Rectangle 中的方法
确定此 Rectangle 是否与指定的 Rectangle 相交。
intersects(double, double, double, double) - 接口 java.awt.Shape 中的方法
测试 Shape 内部是否与指定矩形区域的内部相交。
intersects(Rectangle2D) - 接口 java.awt.Shape 中的方法
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
intersects(BitSet) - 类 java.util.BitSet 中的方法
如果指定的 BitSet 中有设置为 true 的位，并且在此 BitSet 中也将其设置为 true，则返回 ture。
intersectsLine(double, double, double, double) - 类 java.awt.geom.Line2D 中的方法
测试从 (x1,y1) 到 (x2,y2) 的线段是否与此线段相交。
intersectsLine(Line2D) - 类 java.awt.geom.Line2D 中的方法
测试指定的线段是否与此线段相交。
intersectsLine(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
测试指定线段是否与此 Rectangle2D 的内部相交。
intersectsLine(Line2D) - 类 java.awt.geom.Rectangle2D 中的方法
测试指定的线段是否与此 Rectangle2D 的内部相交。
INTERVAL_ADDED - 类 javax.swing.event.ListDataEvent 中的静态变量
标识添加到列表中的一个或多个相邻项
INTERVAL_REMOVED - 类 javax.swing.event.ListDataEvent 中的静态变量
标识从列表中移除的一个或多个相邻项
intervalAdded(ListDataEvent) - 接口 javax.swing.event.ListDataListener 中的方法
在已将 index0,index1 区间中的索引插入数据模型中之后发送。
intervalAdded(ListDataEvent) - 类 javax.swing.JComboBox 中的方法
此方法作为实现的副作用存在的公共方法。
intervalAdded(ListDataEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
List Data Listener 间隔添加方法。
intervalAdded(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 中的方法
intervalAdded(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 中的方法
intervalAdded(ListDataEvent) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
废弃，不使用。
intervalAdded(ListDataEvent) - 类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 中的方法
intervalRemoved(ListDataEvent) - 接口 javax.swing.event.ListDataListener 中的方法
在已将 index0,index1 区间中的索引从数据模型中移除后发送。
intervalRemoved(ListDataEvent) - 类 javax.swing.JComboBox 中的方法
此方法作为实现的副作用存在的公共方法。
intervalRemoved(ListDataEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
List Data Listener 间隔移除方法。
intervalRemoved(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler 中的方法
intervalRemoved(ListDataEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListDataHandler 中的方法
intervalRemoved(ListDataEvent) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
废弃，不使用。
intervalRemoved(ListDataEvent) - 类 javax.swing.plaf.basic.BasicListUI.ListDataHandler 中的方法
INTF_REPOS - org.omg.CORBA 中的 异常
当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
INTF_REPOS() - 异常 org.omg.CORBA.INTF_REPOS 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTF_REPOS 异常。
INTF_REPOS(String) - 异常 org.omg.CORBA.INTF_REPOS 的构造方法
使用指定详细消息构造一个 INTF_REPOS 异常。
INTF_REPOS(int, CompletionStatus) - 异常 org.omg.CORBA.INTF_REPOS 的构造方法
使用指定次要代码和完成状态构造一个 INTF_REPOS 异常。
INTF_REPOS(String, int, CompletionStatus) - 异常 org.omg.CORBA.INTF_REPOS 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INTF_REPOS 异常。
IntHolder - org.omg.CORBA 中的 类
Int 的 Holder。
IntHolder() - 类 org.omg.CORBA.IntHolder 的构造方法
构造一个新的 IntHolder 对象，将其 value 字段初始化为 0。
IntHolder(int) - 类 org.omg.CORBA.IntHolder 的构造方法
构造一个新的 IntHolder 对象，并使用给定 int 初始化其 value 字段。
intKey() - 类 java.awt.RenderingHints.Key 中的方法
返回子类用来实例化此 Key 的私有整数键。
IntrospectionException - java.beans 中的 异常
在 Introspection 期间发生异常时抛出异常。
IntrospectionException(String) - 异常 java.beans.IntrospectionException 的构造方法
构造带详细消息的 IntrospectionException。
IntrospectionException - javax.management 中的 异常
在 MBean 的 introspection 期间出现的异常。
IntrospectionException() - 异常 javax.management.IntrospectionException 的构造方法
默认的构造方法。
IntrospectionException(String) - 异常 javax.management.IntrospectionException 的构造方法
允许指定特定错误消息的构造方法。
Introspector - java.beans 中的 类
Introspector 类为通过工具学习有关受目标 Java Bean 支持的属性、事件和方法的知识提供了一个标准方法。
intValue() - 类 java.lang.Byte 中的方法
作为一个 int 返回此 Byte 的值。
intValue() - 类 java.lang.Double 中的方法
以 int 形式返回此 Double 的值（通过强制转换为 int 类型）。
intValue() - 类 java.lang.Float 中的方法
将此 Float 值以 int 形式返回（强制转换为 int 类型）。
intValue() - 类 java.lang.Integer 中的方法
以 int 类型返回该 Integer 的值。
intValue() - 类 java.lang.Long 中的方法
以 int 形式返回此 Long 的值。
intValue() - 类 java.lang.Number 中的方法
以 int 形式返回指定的数值。
intValue() - 类 java.lang.Short 中的方法
以 int 形式返回此 Short 的值。
intValue() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 int。
intValue() - 类 java.math.BigInteger 中的方法
将此 BigInteger 转换为 int。
intValue() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
intValue() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
intValue() - 类 java.util.logging.Level 中的方法
获得此级别的整数值。
intValueExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 int，以检查丢失的信息。
INUSE_ATTRIBUTE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图添加已经在其他位置使用的属性。
INV_FLAG - org.omg.CORBA 中的 异常
在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
INV_FLAG() - 异常 org.omg.CORBA.INV_FLAG 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。
INV_FLAG(String) - 异常 org.omg.CORBA.INV_FLAG 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。
INV_FLAG(int, CompletionStatus) - 异常 org.omg.CORBA.INV_FLAG 的构造方法
使用指定次要代码和完成状态构造一个 INV_FLAG 异常。
INV_FLAG(String, int, CompletionStatus) - 异常 org.omg.CORBA.INV_FLAG 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INV_FLAG 异常。
INV_IDENT - org.omg.CORBA 中的 异常
此异常指示 IDL 标识符在语法上是无效的。
INV_IDENT() - 异常 org.omg.CORBA.INV_IDENT 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。
INV_IDENT(String) - 异常 org.omg.CORBA.INV_IDENT 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。
INV_IDENT(int, CompletionStatus) - 异常 org.omg.CORBA.INV_IDENT 的构造方法
使用指定次要代码和完成状态构造一个 INV_IDENT 异常。
INV_IDENT(String, int, CompletionStatus) - 异常 org.omg.CORBA.INV_IDENT 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INV_IDENT 异常。
INV_OBJREF - org.omg.CORBA 中的 异常
此异常指示对象引用存在内部错误。
INV_OBJREF() - 异常 org.omg.CORBA.INV_OBJREF 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。
INV_OBJREF(String) - 异常 org.omg.CORBA.INV_OBJREF 的构造方法
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。
INV_OBJREF(int, CompletionStatus) - 异常 org.omg.CORBA.INV_OBJREF 的构造方法
使用指定次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_OBJREF(String, int, CompletionStatus) - 异常 org.omg.CORBA.INV_OBJREF 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INV_OBJREF 异常。
INV_POLICY - org.omg.CORBA 中的 异常
当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
INV_POLICY() - 异常 org.omg.CORBA.INV_POLICY 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 INV_POLICY 异常。
INV_POLICY(String) - 异常 org.omg.CORBA.INV_POLICY 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_POLICY 异常。
INV_POLICY(int, CompletionStatus) - 异常 org.omg.CORBA.INV_POLICY 的构造方法
使用指定次要代码和完成状态构造一个 INV_POLICY 异常。
INV_POLICY(String, int, CompletionStatus) - 异常 org.omg.CORBA.INV_POLICY 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 INV_POLICY 异常。
Invalid - org.omg.CORBA.DynAnyPackage 中的 异常
动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
Invalid() - 异常 org.omg.CORBA.DynAnyPackage.Invalid 的构造方法
构造一个 Invalid 对象。
Invalid(String) - 异常 org.omg.CORBA.DynAnyPackage.Invalid 的构造方法
构造一个 Invalid 对象。
INVALID_ACCESS_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果基础对象不支持某个参数或操作。
INVALID_ACTIVITY - org.omg.CORBA 中的 异常
如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
INVALID_ACTIVITY() - 异常 org.omg.CORBA.INVALID_ACTIVITY 的构造方法
使用次要代码 0 和 CompletionStatus COMPLETED_NO 构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(String) - 异常 org.omg.CORBA.INVALID_ACTIVITY 的构造方法
使用指定消息构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(int, CompletionStatus) - 异常 org.omg.CORBA.INVALID_ACTIVITY 的构造方法
使用指定次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_ACTIVITY(String, int, CompletionStatus) - 异常 org.omg.CORBA.INVALID_ACTIVITY 的构造方法
使用指定消息、次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。
INVALID_CHARACTER_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果指定无效或非法字符，如在 XML 名称中。
INVALID_MODIFICATION_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图修改基础对象的类型。
INVALID_STATE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图使用不可用或不再可用的对象。
INVALID_TRANSACTION - org.omg.CORBA 中的 异常
当请求带有无效的事务上下文时，抛出此异常。
INVALID_TRANSACTION() - 异常 org.omg.CORBA.INVALID_TRANSACTION 的构造方法
使用默认次要代码 0 和完成状态 COMPLETED_NO 构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(String) - 异常 org.omg.CORBA.INVALID_TRANSACTION 的构造方法
使用指定消息构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(int, CompletionStatus) - 异常 org.omg.CORBA.INVALID_TRANSACTION 的构造方法
使用指定次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
INVALID_TRANSACTION(String, int, CompletionStatus) - 异常 org.omg.CORBA.INVALID_TRANSACTION 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。
InvalidActivityException - javax.activity 中的 异常
任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。
InvalidActivityException() - 异常 javax.activity.InvalidActivityException 的构造方法
构造一个新实例，其详细消息为 null。
InvalidActivityException(String) - 异常 javax.activity.InvalidActivityException 的构造方法
构造带有指定详细消息的新实例。
InvalidActivityException(Throwable) - 异常 javax.activity.InvalidActivityException 的构造方法
构造带有指定 cause 的新 throwable。
InvalidActivityException(String, Throwable) - 异常 javax.activity.InvalidActivityException 的构造方法
构造带有指定详细消息和 cause 的新 throwable。
InvalidAddress - org.omg.CosNaming.NamingContextExtPackage 中的 异常
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。
InvalidAddress() - 异常 org.omg.CosNaming.NamingContextExtPackage.InvalidAddress 的构造方法
InvalidAddress(String) - 异常 org.omg.CosNaming.NamingContextExtPackage.InvalidAddress 的构造方法
InvalidAddressHelper - org.omg.CosNaming.NamingContextExtPackage 中的 类
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java。
InvalidAddressHelper() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 的构造方法
InvalidAddressHolder - org.omg.CosNaming.NamingContextExtPackage 中的 类
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java。
InvalidAddressHolder() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 的构造方法
InvalidAddressHolder(InvalidAddress) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 的构造方法
InvalidAlgorithmParameterException - java.security 中的 异常
用于无效或不合适的算法参数的异常。
InvalidAlgorithmParameterException() - 异常 java.security.InvalidAlgorithmParameterException 的构造方法
构造不带详细消息的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(String) - 异常 java.security.InvalidAlgorithmParameterException 的构造方法
构造带指定详细消息的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(String, Throwable) - 异常 java.security.InvalidAlgorithmParameterException 的构造方法
创建带指定详细消息和 cause 的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(Throwable) - 异常 java.security.InvalidAlgorithmParameterException 的构造方法
创建带指定 cause 和详细消息的 InvalidAlgorithmParameterException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
InvalidApplicationException - javax.management 中的 异常
试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
InvalidApplicationException(Object) - 异常 javax.management.InvalidApplicationException 的构造方法
构造具有指定 Object 的 InvalidApplicationException。
invalidate() - 类 java.awt.Component 中的方法
使此组件无效。
invalidate() - 类 java.awt.Container 中的方法
使容器失效。
invalidate() - 类 java.awt.Polygon 中的方法
所有内部缓冲数据的失效或刷新都依赖于此 Polygon 的顶点坐标。
invalidate() - 接口 javax.net.ssl.SSLSession 中的方法
使会话失效。
invalidate() - 类 javax.swing.CellRendererPane 中的方法
重写此方法是为了避免配置单元格渲染器的子级时顺着树向上传播 invalidate。
invalidate() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
invalidate() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
invalidate() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
invalidateFileCache() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
此方法用于中断文件加载线程。
invalidateLayout(Container) - 类 java.awt.BorderLayout 中的方法
使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 类 java.awt.CardLayout 中的方法
使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 类 java.awt.GridBagLayout 中的方法
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 接口 java.awt.LayoutManager2 中的方法
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 类 javax.swing.BoxLayout 中的方法
指示一个子容器已经更改其布局相关信息，因此应该刷新所有已缓存的计算结果。
invalidateLayout(Container) - 类 javax.swing.GroupLayout 中的方法
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
invalidateLayout(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
invalidateLayout(Container) - 类 javax.swing.OverlayLayout 中的方法
指示子容器已更改其布局相关信息，这会导致刷新所有缓存计算。
invalidateLayout(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
不执行任何操作。
invalidateLayout(Container) - 类 javax.swing.SpringLayout 中的方法
invalidatePathBounds(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
指示 LayoutCache，path 的边界无效，需要进行更新。
invalidatePathBounds(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
不执行任何操作，FixedHeightLayoutCache 不缓存宽度（即所有可以更改的宽度）。
invalidatePathBounds(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
指示 LayoutCache path 的边界无效，需要更新。
invalidateSizes() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
通知 TreeState 需要重新计算它引用的所有大小。
invalidateSizes() - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
通知 TreeState 需要重新计算它引用的所有大小。
invalidateSizes() - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
通知 TreeState 需要重新计算它引用的所有大小。
InvalidAttributeIdentifierException - javax.naming.directory 中的 异常
在试图用无效的属性标识符创建属性时，抛出此异常。
InvalidAttributeIdentifierException(String) - 异常 javax.naming.directory.InvalidAttributeIdentifierException 的构造方法
使用所提供的解释构造一个新的 InvalidAttributeIdentifierException 实例。
InvalidAttributeIdentifierException() - 异常 javax.naming.directory.InvalidAttributeIdentifierException 的构造方法
构造一个新的 InvalidAttributeIdentifierException 实例。
InvalidAttributesException - javax.naming.directory 中的 异常
在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
InvalidAttributesException(String) - 异常 javax.naming.directory.InvalidAttributesException 的构造方法
使用解释构造一个新的 InvalidAttributesException 实例。
InvalidAttributesException() - 异常 javax.naming.directory.InvalidAttributesException 的构造方法
构造一个新的 InvalidAttributesException 实例。
InvalidAttributeValueException - javax.management 中的 异常
指定的值对该属性无效。
InvalidAttributeValueException() - 异常 javax.management.InvalidAttributeValueException 的构造方法
默认的构造方法。
InvalidAttributeValueException(String) - 异常 javax.management.InvalidAttributeValueException 的构造方法
允许指定特定错误消息的构造方法。
InvalidAttributeValueException - javax.naming.directory 中的 异常
在尝试添加一个与属性的模式定义有冲突的属性时，抛出此类。
InvalidAttributeValueException(String) - 异常 javax.naming.directory.InvalidAttributeValueException 的构造方法
使用解释构造一个新的 InvalidAttributeValueException 实例。
InvalidAttributeValueException() - 异常 javax.naming.directory.InvalidAttributeValueException 的构造方法
构造一个新的 InvalidAttributeValueException 实例。
InvalidClassException - java.io 中的 异常
当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
InvalidClassException(String) - 异常 java.io.InvalidClassException 的构造方法
报告指定了原因的 InvalidClassException。
InvalidClassException(String, String) - 异常 java.io.InvalidClassException 的构造方法
构造一个 InvalidClassException 对象。
InvalidDnDOperationException - java.awt.dnd 中的 异常
java.awt.dnd 包中的各种方法都会抛出此异常。
InvalidDnDOperationException() - 异常 java.awt.dnd.InvalidDnDOperationException 的构造方法
创建一个默认的异常。
InvalidDnDOperationException(String) - 异常 java.awt.dnd.InvalidDnDOperationException 的构造方法
创建一个带有其自身描述性消息的异常。
invalidEdit() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
用户键入无效字符时调用此方法。
invalidEdit() - 类 javax.swing.JFormattedTextField 中的方法
用户输入无效值时调用。
InvalidKeyException - java.security 中的 异常
用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
InvalidKeyException() - 异常 java.security.InvalidKeyException 的构造方法
构造不带详细消息的 InvalidKeyException。
InvalidKeyException(String) - 异常 java.security.InvalidKeyException 的构造方法
构造带指定详细消息的 InvalidKeyException。
InvalidKeyException(String, Throwable) - 异常 java.security.InvalidKeyException 的构造方法
创建带指定详细消息和 cause 的 InvalidKeyException。
InvalidKeyException(Throwable) - 异常 java.security.InvalidKeyException 的构造方法
创建带指定 cause 和详细消息的 InvalidKeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
InvalidKeyException - javax.management.openmbean 中的 异常
当方法参数作为复合数据 的项名称或表格数据 的行索引时，如果其无效，则抛出此运行时异常。
InvalidKeyException() - 异常 javax.management.openmbean.InvalidKeyException 的构造方法
不带详细消息的 InvalidKeyException。
InvalidKeyException(String) - 异常 javax.management.openmbean.InvalidKeyException 的构造方法
带详细消息的 InvalidKeyException。
InvalidKeySpecException - java.security.spec 中的 异常
这是针对无效密钥规范的异常。
InvalidKeySpecException() - 异常 java.security.spec.InvalidKeySpecException 的构造方法
构造不带详细消息的 InvalidKeySpecException。
InvalidKeySpecException(String) - 异常 java.security.spec.InvalidKeySpecException 的构造方法
构造带指定详细消息的 InvalidKeySpecException。
InvalidKeySpecException(String, Throwable) - 异常 java.security.spec.InvalidKeySpecException 的构造方法
创建带指定的详细消息和 cause 的 InvalidKeySpecException。
InvalidKeySpecException(Throwable) - 异常 java.security.spec.InvalidKeySpecException 的构造方法
创建带指定的 cause 和详细消息 (cause==null ? null : cause.toString()) 的 InvalidKeySpecException（它通常包含 cause 的类和详细消息）。
InvalidMarkException - java.nio 中的 异常
当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
InvalidMarkException() - 异常 java.nio.InvalidMarkException 的构造方法
构造此类的一个实例。
InvalidMidiDataException - javax.sound.midi 中的 异常
一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
InvalidMidiDataException() - 异常 javax.sound.midi.InvalidMidiDataException 的构造方法
构造一个 InvalidMidiDataException，使用 null 作为其错误详细消息。
InvalidMidiDataException(String) - 异常 javax.sound.midi.InvalidMidiDataException 的构造方法
构造带指定详细消息的 InvalidMidiDataException。
InvalidName - org.omg.CORBA.ORBPackage 中的 异常
当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。
InvalidName() - 异常 org.omg.CORBA.ORBPackage.InvalidName 的构造方法
构造一个不带原因消息的 InvalidName 异常。
InvalidName(String) - 异常 org.omg.CORBA.ORBPackage.InvalidName 的构造方法
构造一个带有指定原因消息的 InvalidName 异常。
InvalidName - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/InvalidName.java。
InvalidName() - 异常 org.omg.CosNaming.NamingContextPackage.InvalidName 的构造方法
InvalidName(String) - 异常 org.omg.CosNaming.NamingContextPackage.InvalidName 的构造方法
InvalidName - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 异常
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java。
InvalidName() - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName 的构造方法
InvalidName(String) - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName 的构造方法
InvalidNameException - javax.naming 中的 异常
此异常指示被指定的名称不符合命名系统的命名语法。
InvalidNameException(String) - 异常 javax.naming.InvalidNameException 的构造方法
使用问题的解释构造一个 InvalidNameException 实例。
InvalidNameException() - 异常 javax.naming.InvalidNameException 的构造方法
构造一个 InvalidNameException 实例，将所有字段设置为 null。
InvalidNameHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java。
InvalidNameHelper() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 的构造方法
InvalidNameHelper - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 类
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java。
InvalidNameHelper() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 的构造方法
InvalidNameHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java。
InvalidNameHolder() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 的构造方法
InvalidNameHolder(InvalidName) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 的构造方法
InvalidObjectException - java.io 中的 异常
指示一个或多个反序列化对象未通过验证测试。
InvalidObjectException(String) - 异常 java.io.InvalidObjectException 的构造方法
构造一个 InvalidObjectException。
InvalidOpenTypeException - javax.management.openmbean 中的 异常
当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
InvalidOpenTypeException() - 异常 javax.management.openmbean.InvalidOpenTypeException 的构造方法
不带详细消息的 InvalidOpenTypeException。
InvalidOpenTypeException(String) - 异常 javax.management.openmbean.InvalidOpenTypeException 的构造方法
带详细消息的 InvalidOpenTypeException。
InvalidParameterException - java.security 中的 异常
当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
InvalidParameterException() - 异常 java.security.InvalidParameterException 的构造方法
构造不带详细消息的 InvalidParameterException。
InvalidParameterException(String) - 异常 java.security.InvalidParameterException 的构造方法
构造带指定详细消息的 InvalidParameterException。
InvalidParameterSpecException - java.security.spec 中的 异常
这是针对无效参数规范的异常。
InvalidParameterSpecException() - 异常 java.security.spec.InvalidParameterSpecException 的构造方法
构造不带详细消息的 InvalidParameterSpecException。
InvalidParameterSpecException(String) - 异常 java.security.spec.InvalidParameterSpecException 的构造方法
构造带指定详细消息的 InvalidParameterSpecException。
InvalidPolicy - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/InvalidPolicy.java。
InvalidPolicy() - 异常 org.omg.PortableServer.POAPackage.InvalidPolicy 的构造方法
InvalidPolicy(short) - 异常 org.omg.PortableServer.POAPackage.InvalidPolicy 的构造方法
InvalidPolicy(String, short) - 异常 org.omg.PortableServer.POAPackage.InvalidPolicy 的构造方法
InvalidPolicyHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java。
InvalidPolicyHelper() - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 的构造方法
InvalidPreferencesFormatException - java.util.prefs 中的 异常
抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。
InvalidPreferencesFormatException(Throwable) - 异常 java.util.prefs.InvalidPreferencesFormatException 的构造方法
构造带指定原因的 InvalidPreferencesFormatException。
InvalidPreferencesFormatException(String) - 异常 java.util.prefs.InvalidPreferencesFormatException 的构造方法
构造带指定详细消息的 InvalidPreferencesFormatException。
InvalidPreferencesFormatException(String, Throwable) - 异常 java.util.prefs.InvalidPreferencesFormatException 的构造方法
构造带指定详细消息和原因的 InvalidPreferencesFormatException。
InvalidPropertiesFormatException - java.util 中的 异常
当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
InvalidPropertiesFormatException(Throwable) - 异常 java.util.InvalidPropertiesFormatException 的构造方法
构造一个带指定原因的 InvalidPropertiesFormatException。
InvalidPropertiesFormatException(String) - 异常 java.util.InvalidPropertiesFormatException 的构造方法
构造一个带指定详细消息的 InvalidPropertiesFormatException。
InvalidRelationIdException - javax.management.relation 中的 异常
为关系提供的关系 id 已使用时引发此异常。
InvalidRelationIdException() - 异常 javax.management.relation.InvalidRelationIdException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRelationIdException(String) - 异常 javax.management.relation.InvalidRelationIdException 的构造方法
异常中放置了给定消息的构造方法。
InvalidRelationServiceException - javax.management.relation 中的 异常
提供无效 Relation Service（关系服务）时引发此异常。
InvalidRelationServiceException() - 异常 javax.management.relation.InvalidRelationServiceException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRelationServiceException(String) - 异常 javax.management.relation.InvalidRelationServiceException 的构造方法
异常中放置了给定消息的构造方法。
InvalidRelationTypeException - javax.management.relation 中的 异常
无效的关系类型。
InvalidRelationTypeException() - 异常 javax.management.relation.InvalidRelationTypeException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRelationTypeException(String) - 异常 javax.management.relation.InvalidRelationTypeException 的构造方法
异常中放置了给定消息的构造方法。
InvalidRoleInfoException - javax.management.relation 中的 异常
在角色信息中，其最小程度大于其最大程度时，引发此异常。
InvalidRoleInfoException() - 异常 javax.management.relation.InvalidRoleInfoException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRoleInfoException(String) - 异常 javax.management.relation.InvalidRoleInfoException 的构造方法
异常中放置了给定消息的构造方法。
InvalidRoleValueException - javax.management.relation 中的 异常
角色值无效。
InvalidRoleValueException() - 异常 javax.management.relation.InvalidRoleValueException 的构造方法
默认的构造方法，其异常中未放置任何消息。
InvalidRoleValueException(String) - 异常 javax.management.relation.InvalidRoleValueException 的构造方法
异常中放置了给定消息的构造方法。
InvalidSearchControlsException - javax.naming.directory 中的 异常
在为搜索操作指定的 SearchControls 无效时，抛出此异常。
InvalidSearchControlsException() - 异常 javax.naming.directory.InvalidSearchControlsException 的构造方法
构造一个新的 InvalidSearchControlsException 实例。
InvalidSearchControlsException(String) - 异常 javax.naming.directory.InvalidSearchControlsException 的构造方法
使用解释构造一个新的 InvalidSearchControlsException 实例。
InvalidSearchFilterException - javax.naming.directory 中的 异常
当指定的搜索过滤器无效时，抛出此异常。
InvalidSearchFilterException() - 异常 javax.naming.directory.InvalidSearchFilterException 的构造方法
构造一个新的 InvalidSearchFilterException 实例。
InvalidSearchFilterException(String) - 异常 javax.naming.directory.InvalidSearchFilterException 的构造方法
使用解释构造一个新的 InvalidSearchFilterException 实例。
InvalidSeq - org.omg.CORBA.DynAnyPackage 中的 异常
任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
InvalidSeq() - 异常 org.omg.CORBA.DynAnyPackage.InvalidSeq 的构造方法
构造一个 InvalidSeq 对象。
InvalidSeq(String) - 异常 org.omg.CORBA.DynAnyPackage.InvalidSeq 的构造方法
构造一个 InvalidSeq 对象。
InvalidSlot - org.omg.PortableInterceptor 中的 异常
org/omg/PortableInterceptor/InvalidSlot.java。
InvalidSlot() - 异常 org.omg.PortableInterceptor.InvalidSlot 的构造方法
InvalidSlot(String) - 异常 org.omg.PortableInterceptor.InvalidSlot 的构造方法
InvalidSlotHelper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/InvalidSlotHelper.java。
InvalidSlotHelper() - 类 org.omg.PortableInterceptor.InvalidSlotHelper 的构造方法
InvalidTargetObjectTypeException - javax.management.modelmbean 中的 异常
当指定了无效的目标对象类型时，抛出此异常。
InvalidTargetObjectTypeException() - 异常 javax.management.modelmbean.InvalidTargetObjectTypeException 的构造方法
默认构造方法。
InvalidTargetObjectTypeException(String) - 异常 javax.management.modelmbean.InvalidTargetObjectTypeException 的构造方法
根据字符串进行构造的构造方法。
InvalidTargetObjectTypeException(Exception, String) - 异常 javax.management.modelmbean.InvalidTargetObjectTypeException 的构造方法
带有异常和字符串的构造方法。
InvalidTransactionException - javax.transaction 中的 异常
此异常指示该请求带来了无效的事务上下文。
InvalidTransactionException() - 异常 javax.transaction.InvalidTransactionException 的构造方法
InvalidTransactionException(String) - 异常 javax.transaction.InvalidTransactionException 的构造方法
InvalidTypeForEncoding - org.omg.IOP.CodecPackage 中的 异常
org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。
InvalidTypeForEncoding() - 异常 org.omg.IOP.CodecPackage.InvalidTypeForEncoding 的构造方法
InvalidTypeForEncoding(String) - 异常 org.omg.IOP.CodecPackage.InvalidTypeForEncoding 的构造方法
InvalidTypeForEncodingHelper - org.omg.IOP.CodecPackage 中的 类
org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java。
InvalidTypeForEncodingHelper() - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 的构造方法
InvalidValue - org.omg.CORBA.DynAnyPackage 中的 异常
InvalidValue() - 异常 org.omg.CORBA.DynAnyPackage.InvalidValue 的构造方法
构造一个 InvalidValue 对象。
InvalidValue(String) - 异常 org.omg.CORBA.DynAnyPackage.InvalidValue 的构造方法
构造一个 InvalidValue 对象。
InvalidValue - org.omg.DynamicAny.DynAnyPackage 中的 异常
org/omg/DynamicAny/DynAnyPackage/InvalidValue.java。
InvalidValue() - 异常 org.omg.DynamicAny.DynAnyPackage.InvalidValue 的构造方法
InvalidValue(String) - 异常 org.omg.DynamicAny.DynAnyPackage.InvalidValue 的构造方法
InvalidValueHelper - org.omg.DynamicAny.DynAnyPackage 中的 类
org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java。
InvalidValueHelper() - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 的构造方法
inverseTransform(Point2D, Point2D) - 类 java.awt.geom.AffineTransform 中的方法
逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
inverseTransform(double[], int, double[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来逆向变换双精度坐标数组。
invert() - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为它自身的逆变换。
INVITE - 类 java.awt.PageAttributes.MediaType 中的静态变量
INVITE_ENVELOPE 的别名。
INVITE_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Invitation Envelope (220 x 220 mm) 的 MediaType 实例。
Invocable - javax.script 中的 接口
由 ScriptEngines 实现的可选接口，该 ScriptEngines 的方法允许在以前执行过的脚本中调用程序。
INVOCATION_DEFAULT - 类 java.awt.event.InvocationEvent 中的静态变量
所有 InvocationEvent 的默认 id。
INVOCATION_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择调用事件的事件掩码。
INVOCATION_FIRST - 类 java.awt.event.InvocationEvent 中的静态变量
标记调用事件 id 范围内的第一个整数 id。
INVOCATION_LAST - 类 java.awt.event.InvocationEvent 中的静态变量
标记调用事件 id 范围内的最后一个整数 id。
InvocationEvent - java.awt.event 中的 类
当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
InvocationEvent(Object, Runnable) - 类 java.awt.event.InvocationEvent 的构造方法
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。
InvocationEvent(Object, Runnable, Object, boolean) - 类 java.awt.event.InvocationEvent 的构造方法
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。
InvocationEvent(Object, int, Runnable, Object, boolean) - 类 java.awt.event.InvocationEvent 的构造方法
构造一个具有指定源和 ID 的 InvocationEvent，此源和 ID 将在被指派时执行 runnable 的 run 方法。
InvocationHandler - java.lang.reflect 中的 接口
InvocationHandler 是代理实例的调用处理程序 实现的接口。
InvocationTargetException - java.lang.reflect 中的 异常
InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
InvocationTargetException() - 异常 java.lang.reflect.InvocationTargetException 的构造方法
构造以 null 作为目标异常的 InvocationTargetException。
InvocationTargetException(Throwable) - 异常 java.lang.reflect.InvocationTargetException 的构造方法
构造带目标异常的 InvocationTargetException。
InvocationTargetException(Throwable, String) - 异常 java.lang.reflect.InvocationTargetException 的构造方法
构造带目标异常和详细消息的 InvocationTargetException。
INVOICE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Invoice (5 1/2 x 8 1/2 in) 的 MediaType 实例。
INVOICE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 invoice 尺寸，5.5 inch × 8.5 inch。
INVOICE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
invoice 尺寸。
invoke(Object, Method, Object[]) - 类 java.beans.EventHandler 中的方法
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。
invoke(Object, Method, Object[]) - 接口 java.lang.reflect.InvocationHandler 中的方法
在代理实例上处理方法调用并返回结果。
invoke(Object, Object...) - 类 java.lang.reflect.Method 中的方法
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
invoke(Object, Method, Object[]) - 类 java.rmi.server.RemoteObjectInvocationHandler 中的方法
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。
invoke(Remote, Method, Object[], long) - 接口 java.rmi.server.RemoteRef 中的方法
调用某个方法。
invoke(RemoteCall) - 接口 java.rmi.server.RemoteRef 中的方法
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
invoke(String, Object[], String[]) - 接口 javax.management.DynamicMBean 中的方法
允许在 Dynamic MBean 上调用某个操作。
invoke(ObjectName, String, Object[], String[]) - 接口 javax.management.MBeanServer 中的方法
invoke(ObjectName, String, Object[], String[]) - 接口 javax.management.MBeanServerConnection 中的方法
在 MBean 上调用某个操作。
invoke(Object, Method, Object[]) - 类 javax.management.MBeanServerInvocationHandler 中的方法
invoke(String, Object[], String[]) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。
invoke(Object, Method, Object[]) - 类 javax.management.openmbean.CompositeDataInvocationHandler 中的方法
invoke(ObjectName, String, MarshalledObject, String[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
invoke(ObjectName, String, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
invoke(ObjectName, String, MarshalledObject, String[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
invoke(String, Object[], String[]) - 类 javax.management.StandardMBean 中的方法
invoke(T) - 接口 javax.xml.ws.Dispatch 中的方法
同步调用服务操作。
invoke(T) - 接口 javax.xml.ws.Provider 中的方法
根据请求消息的内容调用操作。
invoke(ServerRequest) - 类 org.omg.CORBA.DynamicImplementation 中的方法
已过时。 由 Portable Object Adapter 取代
invoke(Object, OutputStream) - 类 org.omg.CORBA.portable.Delegate 中的方法
由 stub 调用，以调用一个操作。
invoke() - 类 org.omg.CORBA.Request 中的方法
使用 Request 对象中的信息进行同步调用。
invoke(ServerRequest) - 类 org.omg.CosNaming._BindingIteratorImplBase 中的方法
invoke(ServerRequest) - 类 org.omg.CosNaming._NamingContextImplBase 中的方法
invoke(ServerRequest) - 类 org.omg.PortableServer.DynamicImplementation 中的方法
接收发布到任何由 DSI servant 实现的 CORBA 对象的请求，并进行执行该请求所需的处理。
invokeAll(Collection<? extends Callable<T>>) - 类 java.util.concurrent.AbstractExecutorService 中的方法
invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - 类 java.util.concurrent.AbstractExecutorService 中的方法
invokeAll(Collection<? extends Callable<T>>) - 接口 java.util.concurrent.ExecutorService 中的方法
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - 接口 java.util.concurrent.ExecutorService 中的方法
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
invokeAndWait(Runnable) - 类 java.awt.EventQueue 中的静态方法
导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
invokeAndWait(Runnable) - 类 javax.swing.SwingUtilities 中的静态方法
导致 doRun.run() 在 AWT 事件指派线程上同步执行。
invokeAny(Collection<? extends Callable<T>>) - 类 java.util.concurrent.AbstractExecutorService 中的方法
invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - 类 java.util.concurrent.AbstractExecutorService 中的方法
invokeAny(Collection<? extends Callable<T>>) - 接口 java.util.concurrent.ExecutorService 中的方法
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - 接口 java.util.concurrent.ExecutorService 中的方法
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
invokeAsync(T) - 接口 javax.xml.ws.Dispatch 中的方法
异步调用服务操作。
invokeAsync(T, AsyncHandler<T>) - 接口 javax.xml.ws.Dispatch 中的方法
异步调用服务操作。
invokeFunction(String, Object...) - 接口 javax.script.Invocable 中的方法
用于调用脚本中定义的顶层程序和函数。
InvokeHandler - org.omg.CORBA.portable 中的 接口
此接口为入呼叫 (incoming call) 提供调度机制。
invokeLater(Runnable) - 类 java.awt.EventQueue 中的静态方法
导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
invokeLater(Runnable) - 类 javax.swing.SwingUtilities 中的静态方法
导致 doRun.run() 在 AWT 事件指派线程上异步执行。
invokeMethod(Object, String, Object...) - 接口 javax.script.Invocable 中的方法
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。
invokeOneWay(T) - 接口 javax.xml.ws.Dispatch 中的方法
使用单向交互模式调用服务操作。
INVOKES_STOP_CELL_EDITING_PROPERTY - 类 javax.swing.JTree 中的静态变量
messagesStopCellEditing 的绑定属性名称。
invokesStopCellEditing - 类 javax.swing.JTree 中的变量
如果为 true，则在通过更改选择、更改树中的数据或通过其他方法停止编辑时，会调用 stopCellEditing，并保存更改。
IOError - java.io 中的 错误
当发生严重的 I/O 错误时，抛出此错误。
IOError(Throwable) - 错误 java.io.IOError 的构造方法
构造带有指定 cause 的新 IOError 实例。
IOException - java.io 中的 异常
当发生某种 I/O 异常时，抛出此异常。
IOException() - 异常 java.io.IOException 的构造方法
构造一个 IOException，使用 null 作为其错误详细消息。
IOException(String) - 异常 java.io.IOException 的构造方法
构造带指定详细消息的 IOException。
IOException(String, Throwable) - 异常 java.io.IOException 的构造方法
构造带有指定详细消息和 cause 的 IOException。
IOException(Throwable) - 异常 java.io.IOException 的构造方法
构造一个 IOException，使其具有指定的 cause 以及详细消息 (cause==null ? null : cause.toString())（通常包含类和 cause 的详细消息）。
ioException() - 类 java.util.Formatter 中的方法
返回由此 formatter 的 Appendable 方法上次抛出的 IOException 异常。
ioException() - 类 java.util.Scanner 中的方法
返回此 Scanner 的底层 Readable 最后抛出的 IOException。
IOR - org.omg.IOP 中的 类
org/omg/IOP/IOR.java。
IOR() - 类 org.omg.IOP.IOR 的构造方法
IOR(String, TaggedProfile[]) - 类 org.omg.IOP.IOR 的构造方法
IORHelper - org.omg.IOP 中的 类
org/omg/IOP/IORHelper.java。
IORHelper() - 类 org.omg.IOP.IORHelper 的构造方法
IORHolder - org.omg.IOP 中的 类
org/omg/IOP/IORHolder.java。
IORHolder() - 类 org.omg.IOP.IORHolder 的构造方法
IORHolder(IOR) - 类 org.omg.IOP.IORHolder 的构造方法
IORInfo - org.omg.PortableInterceptor 中的 接口
提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
IORInfoOperations - org.omg.PortableInterceptor 中的 接口
提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
IORInterceptor - org.omg.PortableInterceptor 中的 接口
Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
IORInterceptor_3_0 - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/IORInterceptor_3_0.java。
IORInterceptor_3_0Helper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java。
IORInterceptor_3_0Helper() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 的构造方法
IORInterceptor_3_0Holder - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java。
IORInterceptor_3_0Holder() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 的构造方法
IORInterceptor_3_0Holder(IORInterceptor_3_0) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 的构造方法
IORInterceptor_3_0Operations - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java。
IORInterceptorOperations - org.omg.PortableInterceptor 中的 接口
Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
IP_MULTICAST_IF - 接口 java.net.SocketOptions 中的静态变量
设置用于发送多播包的传出接口。
IP_MULTICAST_IF2 - 接口 java.net.SocketOptions 中的静态变量
同上。
IP_MULTICAST_LOOP - 接口 java.net.SocketOptions 中的静态变量
此选项启用或禁用多播数据报的本地回送。
IP_TOS - 接口 java.net.SocketOptions 中的静态变量
此选项为 TCP 或 UDP 套接字在 IP 地址头中设置服务类型或流量类字段。
IPA_EXTENSIONS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“IPA Extensions”Unicode 字符块的常量。
ipadx - 类 java.awt.GridBagConstraints 中的变量
此字段指定组件的内部填充，即给组件的最小宽度添加多大的空间。
ipady - 类 java.awt.GridBagConstraints 中的变量
此字段指定内部填充，即给组件的最小高度添加多大的空间。
IRObject - org.omg.CORBA 中的 接口
IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
IRObjectOperations - org.omg.CORBA 中的 接口
这是用于 IRObject 的映射的 Operations 接口。
is_a(Object, String) - 类 org.omg.CORBA.portable.Delegate 中的方法
检查对象引用是否是给定接口的实例。
is_a(Servant, String) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此方法查看指定的 repid 是否存在于 _all_interfaces() 返回的列表上，或者该 repid 是否是通用 CORBA 对象的存储库 id。
IS_CLOSED_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
约束属性名，指示该内部窗体已关闭。
IS_COALESCING - 类 javax.xml.stream.XMLInputFactory 中的静态变量
要求解析器组合相邻字符数据部分的属性。
is_equivalent(Object, Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
确定两个对象引用是否相等。
IS_ICON_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
约束属性名，指示该内部窗体已图标化。
is_local(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
如果此对象由本地 servant 实现，则返回 true。
IS_MAXIMUM_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
约束属性名，指示该内部窗体已最大化。
IS_NAMESPACE_AWARE - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于开启/关闭名称空间支持的属性，该属性用于支持 XML 1.0 文档，只有 true 设置是必须受支持的。
is_null() - 类 org.omg.DynamicAny._DynValueStub 中的方法
如果 DynValueCommon 表示 null 值类型，则返回 true。
is_null() - 接口 org.omg.DynamicAny.DynValueCommonOperations 中的方法
如果 DynValueCommon 表示 null 值类型，则返回 true。
IS_PALETTE - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的静态变量
IS_REPAIRING_NAMESPACES - 类 javax.xml.stream.XMLOutputFactory 中的静态变量
用于设置输出端上默认前缀的属性。
IS_REPLACING_ENTITY_REFERENCES - 类 javax.xml.stream.XMLInputFactory 中的静态变量
要求解析器用它们的替换文本替换内部实体引用并将它们报告为字符。
IS_SELECTED_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
约束属性名，指示此窗体具有选定状态。
IS_SUPPORTING_EXTERNAL_ENTITIES - 类 javax.xml.stream.XMLInputFactory 中的静态变量
要求解析器解析外部解析实体的属性。
IS_VALIDATING - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于开启/关闭特定于实现的验证的属性。
isAbsolute() - 类 java.io.File 中的方法
测试此抽象路径名是否为绝对路径名。
isAbsolute() - 类 java.net.URI 中的方法
判断此 URI 是否为绝对的。
isAbstract(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 abstract 修饰符，则返回 true，否则返回 false。
isAccelerated() - 类 java.awt.ImageCapabilities 中的方法
如果对象（它的功能封装在此 ImageCapabilities 中）可以被或者已经被 accelerated，则返回 true。
isAcceleratorHidden() - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法
isAcceptable() - 类 java.nio.channels.SelectionKey 中的方法
测试此键的通道是否已准备好接受新的套接字连接。
isAcceptAllFileFilterUsed() - 类 javax.swing.JFileChooser 中的方法
返回是否使用 AcceptAll FileFilter。
isAccessible() - 类 java.lang.reflect.AccessibleObject 中的方法
获取此对象的 accessible 标志的值。
isAccessibleChildSelected(int) - 类 java.awt.List.AccessibleAWTList 中的方法
如果选择了此对象的当前子级，则返回 true。
isAccessibleChildSelected(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
确定是否选择此对象的当前子对象。
isAccessibleChildSelected(int) - 接口 javax.accessibility.AccessibleSelection 中的方法
确定此对象的当前子级是否已选中。
isAccessibleChildSelected(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
确定是否选定此对象的当前子对象。
isAccessibleChildSelected(int) - 类 javax.swing.JList.AccessibleJList 中的方法
如果选择了此对象的当前子级，则返回 true。
isAccessibleChildSelected(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
如果选择了此对象的当前子对象（即此子对象为弹出子菜单），则返回 true。
isAccessibleChildSelected(int) - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
如果选择了此对象的当前子级，则返回 true。
isAccessibleChildSelected(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
isAccessibleChildSelected(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
确定是否选择此对象的当前子对象。
isAccessibleChildSelected(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
如果选择了此对象的当前子对象，则返回 true。
isAccessibleChildSelected(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
如果选择了此对象的当前子对象，则返回 true。
isAccessibleColumnSelected(int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回一个布尔值，它指示指定列是否为选中的。
isAccessibleColumnSelected(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回一个布尔值，它指示是否选择了指定的列。
isAccessibleRowSelected(int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回一个布尔值，它指示给定行是否已选中。
isAccessibleRowSelected(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回一个布尔值，它表示是否选择了指定的行。
isAccessibleSelected(int, int) - 接口 javax.accessibility.AccessibleTable 中的方法
返回一个布尔值，它指示在给定的行和列 accessible 是否选定。
isAccessibleSelected(int, int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
返回一个布尔值，它表明在给定的 (row, column) 是否选择为可访问的。
isActionKey() - 类 java.awt.event.KeyEvent 中的方法
返回此事件中的键是否为“动作”键。
isActive() - 类 java.applet.Applet 中的方法
确定 applet 是否处于活动状态。
isActive() - 接口 java.applet.AppletStub 中的方法
确定 applet 是否处于激活状态。
isActive() - 类 java.awt.dnd.DropTarget 中的方法
报告此 DropTarget 当前是否为激活状态（准备接受 drop）。
isActive() - 类 java.awt.Window 中的方法
返回此窗口是否为活动窗口。
isActive() - 类 javax.management.monitor.Monitor 中的方法
测试监视器 MBean 是否处于激活状态。
isActive() - 接口 javax.management.monitor.MonitorMBean 中的方法
测试监视器 MBean 是否处于激活状态。
isActive() - 类 javax.management.relation.RelationService 中的方法
检查该 Relation Service 是否处于活动状态。
isActive() - 接口 javax.management.relation.RelationServiceMBean 中的方法
检查该 Relation Service 是否处于活动状态。
isActive() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
确定连接器服务器是否活动。
isActive() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
isActive() - 类 javax.management.timer.Timer 中的方法
测试计时器 MBean 是否处于激活状态。
isActive() - 接口 javax.management.timer.TimerMBean 中的方法
测试计时器 MBean 是否处于激活状态。
isActive() - 接口 javax.sound.sampled.DataLine 中的方法
指示该行是否正在进行活动 I/O（如回放或捕获）。
isActive() - 类 javax.swing.text.DefaultCaret 中的方法
确定插入符当前是否处于激活状态。
isAddedPath() - 类 javax.swing.event.TreeSelectionEvent 中的方法
如果已经将第一个路径元素添加到选择中，则返回 true。
isAddedPath(TreePath) - 类 javax.swing.event.TreeSelectionEvent 中的方法
如果 path 标识的路径被添加到选择中，则返回 true。
isAddedPath(int) - 类 javax.swing.event.TreeSelectionEvent 中的方法
如果由 index 标识的路径被添加到选择中，则返回 true。
isAfter(int, int, Rectangle) - 类 javax.swing.text.BoxView 中的方法
确定一个点是否位于分配区域的后面。
isAfter(int, int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
测试一个点是否位于矩形范围之后。
isAfterLast() - 接口 java.sql.ResultSet 中的方法
获取光标是否位于此 ResultSet 对象的最后一行之后。
isAlive() - 类 java.lang.Thread 中的方法
测试线程是否处于活动状态。
isAllocationValid() - 类 javax.swing.text.BoxView 中的方法
子级分配是否仍有效。
isAlphaPremultiplied() - 类 java.awt.image.BufferedImage 中的方法
返回是否已预乘以 alpha。
isAlphaPremultiplied() - 类 java.awt.image.ColorModel 中的方法
返回是否在由此 ColorModel 转换的像素值中预乘 alpha。
isAltDown() - 类 java.awt.event.InputEvent 中的方法
返回 Alt 修饰符在此事件上是否为 down。
isAltGraphDown() - 类 java.awt.event.InputEvent 中的方法
返回 AltGraph 修饰符在此事件上是否为 down。
isAlwaysOnTop() - 类 java.awt.Window 中的方法
返回此窗口是否为 always-on-top 窗口。
isAlwaysOnTopSupported() - 类 java.awt.Toolkit 中的方法
返回此工具包是否支持 always-on-top 模式。
isAlwaysOnTopSupported() - 类 java.awt.Window 中的方法
返回此窗口是否支持 always-on-top 模式。
isAncestorOf(Component) - 类 java.awt.Container 中的方法
检查该组件是否包含在此容器的组件层次结构中。
isAnnotation() - 类 java.lang.Class 中的方法
如果此 Class 对象表示一个注释类型则返回 true。
isAnnotationPresent(Class<? extends Annotation>) - 类 java.lang.Class 中的方法
isAnnotationPresent(Class<? extends Annotation>) - 类 java.lang.Package 中的方法
isAnnotationPresent(Class<? extends Annotation>) - 类 java.lang.reflect.AccessibleObject 中的方法
isAnnotationPresent(Class<? extends Annotation>) - 接口 java.lang.reflect.AnnotatedElement 中的方法
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。
isAnonymous() - 接口 org.ietf.jgss.GSSName 中的方法
测试此名称对象是否表示匿名的实体。
isAnonymousClass() - 类 java.lang.Class 中的方法
当且仅当底层类是匿名类时返回 true。
isAntiAliased() - 类 java.awt.font.FontRenderContext 中的方法
返回一个 boolean 值，指示是否某些形式的抗锯齿由此 FontRenderContext 指定。
isAnyLocalAddress() - 类 java.net.Inet4Address 中的方法
检查 InetAddress 是否是通配符地址的实用例行程序。
isAnyLocalAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是通配符地址的实用例行程序。
isAnyLocalAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是通配符地址的实用例行程序。
isAnyPolicyInhibited() - 类 java.security.cert.PKIXParameters 中的方法
检查当证书中包括了任何策略 OID 时是否应该处理它。
isArmed() - 接口 javax.swing.ButtonModel 中的方法
指示触发按钮操作的部分委托事项。
isArmed() - 类 javax.swing.DefaultButtonModel 中的方法
指示触发按钮操作的部分委托事项。
isArmed() - 类 javax.swing.JMenuItem 中的方法
返回菜单项是否被“调出”。
isArray() - 类 java.lang.Class 中的方法
判定此 Class 对象是否表示一个数组类。
isArray() - 类 javax.management.openmbean.OpenType 中的方法
如果此开放类型描述的开放数据值是数组，则返回 true，否则返回 false。
isAscending() - 类 javax.naming.ldap.SortKey 中的方法
确定排序顺序。
isAssignable(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
测试一种类型是否可以指派给另一种类型。
isAssignableFrom(Class<?>) - 类 java.lang.Class 中的方法
判定此 Class 对象所表示的类或接口与指定的 Class 参数所表示的类或接口是否相同，或是否是其超类或超接口。
isAttribute() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 Attribute 的实用工具函数。
isAttributeCategorySupported(Class<? extends Attribute>) - 接口 javax.print.PrintService 中的方法
确定客户端在设置此 PrintService 的作业时，是否可以指定给定打印属性类别。
isAttributeRequired(String, String) - 接口 javax.imageio.metadata.IIOMetadataFormat 中的方法
如果指定属性必须在指定元素中存在，则返回 true。
isAttributeRequired(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
isAttributeSpecified(int) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isAttributeSpecified(int) - 接口 javax.xml.stream.XMLStreamReader 中的方法
返回一个 boolean 值，它指示此属性是否为默认创建的
isAttributeValueSupported(Attribute, DocFlavor, AttributeSet) - 接口 javax.print.PrintService 中的方法
确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。
isAuthorized() - 类 javax.security.sasl.AuthorizeCallback 中的方法
确定是否允许用验证 id 代表授权 id。
isAutoDetecting() - 类 java.nio.charset.CharsetDecoder 中的方法
通知此解码器是否实现了自动检测 charset。
isAutoFormSubmission() - 类 javax.swing.text.html.HTMLEditorKit 中的方法
指示是否自动处理 html 表单提交，或只是激发 FormSubmitEvent。
isAutoIncrement(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示是否自动为指定列进行编号。
isAutoIncrement(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取存储在指定列中的值是否自动编号，因而是只读的。
isAutoScrolling - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
isAutoWaitForIdle() - 类 java.awt.Robot 中的方法
返回此 Robot 在生成一个事件后是否自动调用 waitForIdle。
isBackgroundSet() - 类 java.awt.Component 中的方法
返回是否已为此组件显示地设置了背景色。
isBackingStoreEnabled() - 类 javax.swing.JViewport 中的方法
已过时。 从 Java 2 平台 1.3 版开始，由 getScrollMode() 取代。
isBefore(int, int, Rectangle) - 类 javax.swing.text.BoxView 中的方法
确定一个点是否位于分配区域的前面。
isBefore(int, int, Rectangle) - 类 javax.swing.text.CompositeView 中的方法
测试一个点是否位于矩形范围之前。
isBeforeFirst() - 接口 java.sql.ResultSet 中的方法
获取光标是否位于此 ResultSet 对象的第一行之前。
isBigEndian() - 类 javax.sound.sampled.AudioFormat 中的方法
指示是以 big-endian 顺序还是以 little-endian 顺序存储音频数据。
isBlock() - 类 javax.swing.text.html.HTML.Tag 中的方法
如果此标记是块标记（块标记是用于向文档添加结构的标记），则返回 true。
isBlocking() - 类 java.nio.channels.SelectableChannel 中的方法
判断此通道上的每个 I/O 操作在完成前是否被阻塞。
isBlocking() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
isBlockTag(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
确定与该元素关联的 HTML.Tag 是否为块标记。
isBold() - 类 java.awt.Font 中的方法
指示此 Font 对象的样式是否为 BOLD。
isBold(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了粗体属性。
isBootClassPathSupported() - 接口 java.lang.management.RuntimeMXBean 中的方法
测试 Java 虚拟机是否支持由引导类加载器用于搜索类文件的引导类路径机制。
isBorderOpaque() - 类 javax.swing.border.AbstractBorder 中的方法
此默认实现返回 false。
isBorderOpaque() - 类 javax.swing.border.BevelBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 接口 javax.swing.border.Border 中的方法
返回此边框是否透明。
isBorderOpaque() - 类 javax.swing.border.CompoundBorder 中的方法
返回此组合边框是否透明。
isBorderOpaque() - 类 javax.swing.border.EmptyBorder 中的方法
返回此边框是否透明。
isBorderOpaque() - 类 javax.swing.border.EtchedBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 类 javax.swing.border.LineBorder 中的方法
返回此边框是否透明。
isBorderOpaque() - 类 javax.swing.border.MatteBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 类 javax.swing.border.SoftBevelBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 类 javax.swing.border.TitledBorder 中的方法
返回边框是否透明。
isBorderOpaque() - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的方法
isBorderOpaque() - 类 javax.swing.plaf.BorderUIResource 中的方法
isBorderPainted() - 类 javax.swing.AbstractButton 中的方法
获取 borderPainted 属性。
isBorderPainted() - 类 javax.swing.JMenuBar 中的方法
如果应该绘制菜单栏的边框，则返回 true。
isBorderPainted() - 类 javax.swing.JPopupMenu 中的方法
检查是否应该绘制边框。
isBorderPainted() - 类 javax.swing.JProgressBar 中的方法
返回 borderPainted 属性。
isBorderPainted() - 类 javax.swing.JToolBar 中的方法
获取 borderPainted 属性。
isBorderPaintedFlat() - 类 javax.swing.JCheckBox 中的方法
获取 borderPaintedFlat 属性的值。
isBound() - 类 java.beans.PropertyDescriptor 中的方法
更新 "bound" 属性将导致更改该属性时激发 "PropertyChange" 事件。
isBound() - 类 java.net.DatagramSocket 中的方法
返回套接字的绑定状态。
isBound() - 类 java.net.ServerSocket 中的方法
返回 ServerSocket 的绑定状态。
isBound() - 类 java.net.Socket 中的方法
返回套接字的绑定状态。
isBoundary(int) - 类 java.text.BreakIterator 中的方法
如果指定字符偏移量是一个文本边界，则返回 true。
isBridge() - 类 java.lang.reflect.Method 中的方法
如果此方法是 bridge 方法，则返回 true；否则，返回 false。
isBroken() - 类 java.util.concurrent.CyclicBarrier 中的方法
查询此屏障是否处于损坏状态。
isCached() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
返回 true，因为此 ImageInputStream 为了允许逆向查找而缓存了数据。
isCached() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
返回 true，因为此 ImageOutputStream为了允许逆向查找而缓存了数据。
isCached() - 接口 javax.imageio.stream.ImageInputStream 中的方法
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，则返回 true。
isCached() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
默认实现返回 false。
isCached() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
返回 true，因为此 ImageInputStream为了允许逆向查找而缓存了数据。
isCached() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
返回 true，因为此 ImageOutputStream为了允许逆向查找而缓存了数据。
isCachedFile() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
返回 true，因为此 ImageInputStream 维护文件缓存。
isCachedFile() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
返回 true，因为此 ImageOutputStream 维护文件缓存。
isCachedFile() - 接口 javax.imageio.stream.ImageInputStream 中的方法
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，并且将其保存在临时文件中，则返回 true。
isCachedFile() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
默认实现返回 false。
isCachedFile() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
返回 false，因为此 ImageInputStream 不维护文件缓存。
isCachedFile() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
返回 false，因为此 ImageOutputStream 不维护文件缓存。
isCachedMemory() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
返回 false，因为此 ImageInputStream 不维护主存缓存。
isCachedMemory() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
返回 false，因为此 ImageOutputStream 不维护主存缓存。
isCachedMemory() - 接口 javax.imageio.stream.ImageInputStream 中的方法
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，并将其保存在主存中，则返回 true。
isCachedMemory() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
默认实现返回 false。
isCachedMemory() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
返回 true，因为此 ImageInputStream 维护主存缓存。
isCachedMemory() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
返回 true，因为此 ImageOutputStream 维护主存缓存。
isCanceled() - 类 javax.swing.ProgressMonitor 中的方法
如果用户单击进度对话框中的 Cancel 按钮，则返回 true。
isCancelled() - 类 java.awt.print.PrinterJob 中的方法
如果打印作业正在进行中，而下一次打印作业将被取消，则返回 true；否则返回 false。
isCancelled() - 接口 java.util.concurrent.Future 中的方法
如果在任务正常完成前将其取消，则返回 true。
isCancelled() - 类 java.util.concurrent.FutureTask 中的方法
isCancelled() - 类 javax.swing.SwingWorker 中的方法
如果在任务正常完成前将其取消，则返回 true。
isCaseIgnored() - 接口 javax.naming.directory.Attributes 中的方法
确定在检索或添加属性时属性集是否忽略属性标识符的大小写。
isCaseIgnored() - 类 javax.naming.directory.BasicAttributes 中的方法
isCaseSensitive(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示列的大小写是否有关系。
isCaseSensitive(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示指定列的名称是否区分大小写。
isCatalogAtStart() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别是否出现在完全限定表名的开头。
isCData() - 接口 javax.xml.stream.events.Characters 中的方法
如果它是一个 CData 节，则返回 true。
isCellEditable(EventObject) - 类 javax.swing.AbstractCellEditor 中的方法
返回 true。
isCellEditable(EventObject) - 接口 javax.swing.CellEditor 中的方法
询问编辑器它是否可以使用 anEvent 开始进行编辑。
isCellEditable(EventObject) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
如果 anEvent 不是一个 MouseEvent，则返回 true。
isCellEditable(EventObject) - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
isCellEditable(int, int) - 类 javax.swing.JTable 中的方法
如果 row 和 column 位置的单元格是可编辑的，则返回 true。
isCellEditable(int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
返回 false。
isCellEditable(int, int) - 类 javax.swing.table.DefaultTableModel 中的方法
无论参数值是多少都返回 true。
isCellEditable(int, int) - 接口 javax.swing.table.TableModel 中的方法
如果 rowIndex 和 columnIndex 位置的单元格是可编辑的，则返回 true。
isCellEditable(EventObject) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果 realEditor 将 true 返回到此消息，则会通知 prepareForEditing，并返回 true。
isCellSelected(int, int) - 类 javax.swing.JTable 中的方法
如果指定的索引位于行和列的有效范围内，并且位于该指定位置的单元格被选定，则返回 true。
isCertificateEntry(String) - 类 java.security.KeyStore 中的方法
如果给定别名标识的条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则返回 true。
isCharacters() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 Characters 的实用工具函数。
isCharacters() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isCharacters() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果光标指向字符数据事件，则返回 true
isCharsetDetected() - 类 java.nio.charset.CharsetDecoder 中的方法
通知此解码器是否已经检测到了一个 charset（可选操作）。
isClass() - 枚举 javax.lang.model.element.ElementKind 中的方法
如果此元素是以下种类的类，则返回 true：CLASS 或 ENUM。
isClosable() - 类 javax.swing.JInternalFrame 中的方法
返回是否可以通过某个用户操作关闭此 JInternalFrame。
isClosed() - 类 java.net.DatagramSocket 中的方法
返回是否关闭了套接字。
isClosed() - 类 java.net.ServerSocket 中的方法
返回 ServerSocket 的关闭状态。
isClosed() - 类 java.net.Socket 中的方法
返回套接字的关闭状态。
isClosed() - 接口 java.sql.Connection 中的方法
查询此 Connection 对象是否已经被关闭。
isClosed() - 接口 java.sql.ResultSet 中的方法
获取此 ResultSet 对象是否已关闭。
isClosed() - 接口 java.sql.Statement 中的方法
获取是否已关闭了此 Statement 对象。
isClosed - 类 javax.swing.JInternalFrame 中的变量
窗体已关闭。
isClosed() - 类 javax.swing.JInternalFrame 中的方法
返回此 JInternalFrame 当前是否已关闭。
isCoalesce() - 类 javax.swing.Timer 中的方法
如果 Timer 组合多个挂起的动作事件，则返回 true。
isCoalescing() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成满足以下条件的解析器：该解析器将 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点。
isCollapsed(TreePath) - 类 javax.swing.JTree 中的方法
如果当前折叠了路径标识的值，则返回 true，如果当前未显示路径中的任何值，则返回 false。
isCollapsed(int) - 类 javax.swing.JTree 中的方法
如果折叠了指定显示行处的节点，则返回 true。
isCollectionUsageThresholdExceeded() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试在 Java 虚拟机最近一次回收工作之后，此内存池的内存使用量是否达到或超过了其回收使用量阈值。
isCollectionUsageThresholdSupported() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试此内存池是否支持回收使用量阈值。
isColumnSelected(int) - 类 javax.swing.JTable 中的方法
如果指定的索引位于列的有效范围内，并且位于该索引的列被选定，则返回 true。
isCombining() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个组合字形，则返回 true。
isComment() - 接口 javax.xml.soap.Text 中的方法
检索此 Text 对象是否表示一个注释。
isCompatibleRaster(Raster) - 类 java.awt.image.ColorModel 中的方法
如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
isCompatibleRaster(Raster) - 类 java.awt.image.ComponentColorModel 中的方法
如果 raster 与此 ColorModel 兼容，则返回 true；如果不兼容，则返回 false。
isCompatibleRaster(Raster) - 类 java.awt.image.DirectColorModel 中的方法
如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
isCompatibleRaster(Raster) - 类 java.awt.image.IndexColorModel 中的方法
如果 raster 与此 ColorModel 兼容，则返回 true；如果不与此 ColorModel 兼容，则返回 false。
isCompatibleSampleModel(SampleModel) - 类 java.awt.image.ColorModel 中的方法
检查 SampleModel 是否与此 ColorModel 兼容。
isCompatibleSampleModel(SampleModel) - 类 java.awt.image.ComponentColorModel 中的方法
检查指定 SampleModel 是否与此 ColorModel 兼容。
isCompatibleSampleModel(SampleModel) - 类 java.awt.image.IndexColorModel 中的方法
检查指定的 SampleModel 是否与此 ColorModel 兼容。
isCompatibleSampleModel(SampleModel) - 类 java.awt.image.PackedColorModel 中的方法
检查指定的 SampleModel 是否与此 ColorModel 兼容。
isCompatibleValue(Object) - 类 java.awt.RenderingHints.Key 中的方法
如果指定对象是此 Key 的有效值，则返回 true。
isCompatibleWith(String) - 类 java.lang.Package 中的方法
比较此包的规范版本和所需版本。
isCompilationTimeMonitoringSupported() - 接口 java.lang.management.CompilationMXBean 中的方法
测试 Java 虚拟机是否支持监视编译时间。
isComplete() - 接口 javax.security.sasl.SaslClient 中的方法
确定验证交换是否已完成。
isComplete() - 接口 javax.security.sasl.SaslServer 中的方法
确定验证交换是否已完成。
isCompletelyDirty(JComponent) - 类 javax.swing.RepaintManager 中的方法
在下一个 paintDirtyRegions() 中全部绘制 aComponent 时返回 true 的便捷方法。
isComponent() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个分量字形，则返回 true。
isComponentPartOfCurrentMenu(Component) - 类 javax.swing.MenuSelectionManager 中的方法
如果 c 是当前使用菜单的一部分，则返回 true
isCompositionEnabled() - 类 java.awt.im.InputContext 中的方法
确定是否已启用当前输入方法以进行撰写。
isCompositionEnabled() - 接口 java.awt.im.spi.InputMethod 中的方法
确定此输入方法是否已启用。
isCompressionLossless() - 类 javax.imageio.ImageWriteParam 中的方法
如果当前压缩类型提供无损失的压缩，则返回 true。
isCompressionLossless() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
返回 false，因为 JPEG 插件仅支持有损失的压缩。
isComputerNode(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
UI 类使用此方法来决定是否为计算机节点显示特殊图标，例如，“我的电脑”或网络服务器。
isConnectable() - 类 java.nio.channels.SelectionKey 中的方法
测试此键的通道是否已完成其套接字连接操作。
isConnected() - 类 java.net.DatagramSocket 中的方法
返回套接字的连接状态。
isConnected() - 类 java.net.Socket 中的方法
返回套接字的连接状态。
isConnected() - 类 java.nio.channels.DatagramChannel 中的方法
判断是否已连接此通道的套接字。
isConnected() - 类 java.nio.channels.SocketChannel 中的方法
判断是否已连接此通道的网络套接字。
isConnectionPending() - 类 java.nio.channels.SocketChannel 中的方法
判断此通道上是否正在进行连接操作。
isConstrained() - 类 java.beans.PropertyDescriptor 中的方法
试图更新 "Constrained" 属性将导致更改该属性时激发 "VetoableChange" 事件。
isConsumed() - 类 java.awt.AWTEvent 中的方法
返回是否已经使用了此事件。
isConsumed() - 类 java.awt.event.InputEvent 中的方法
返回是否已经使用此事件。
isConsumed() - 类 java.awt.event.InputMethodEvent 中的方法
返回是否已经使用此事件。
isConsumer(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
确定一个 ImageConsumer 是否在对此图像数据感兴趣的使用者列表中。
isConsumer(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
确定指定的 ImageConsumer 对象目前是否已向此 ImageProducer 注册为其使用者之一。
isConsumer(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
确定某个 ImageConsumer 目前是否处于对此图像数据感兴趣的使用者列表中。
isConsumer(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
确定某个 ImageConsumer 是否在当前对此图像的数据感兴趣的使用者列表。
isContentAreaFilled() - 类 javax.swing.AbstractButton 中的方法
获取 contentAreaFilled 属性。
isContextual() - 类 java.awt.font.NumericShaper 中的方法
返回一个 boolean 值，指示此成形器是否以上下文方式成形。
isContinuousLayout() - 类 javax.swing.JSplitPane 中的方法
获取 continuousLayout 属性。
isContinuousLayout() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
确定是否将 JSplitPane 设置为使用连续布局。
isControlDown() - 类 java.awt.event.InputEvent 中的方法
返回 Control 修饰符在此事件上是为 down。
isControlSupported(Control.Type) - 接口 javax.sound.sampled.Line 中的方法
指示该行是否支持特定类型的控件。
isConversionSupported(AudioFormat.Encoding, AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示是否可以从具有指定格式的音频输入流获得指定编码的音频输入流。
isConversionSupported(AudioFormat, AudioFormat) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示是否可从另一指定格式的音频输入流获得指定格式的音频输入流。
isConversionSupported(AudioFormat.Encoding, AudioFormat) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
指示格式转换器是否支持从特定格式向特定编码的转换。
isConversionSupported(AudioFormat, AudioFormat) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
指示格式转换器是否支持到从一种特定格式到另一种格式的转换。
isCritical() - 接口 java.security.cert.PolicyNode 中的方法
返回最近处理的证书中其证书策略扩展的关键性指示符。
isCritical() - 类 javax.naming.ldap.BasicControl 中的方法
确定控件的关键性。
isCritical() - 接口 javax.naming.ldap.Control 中的方法
确定 LDAP 控件的关键性。
isCryptoAllowed(Key) - 类 javax.crypto.ExemptionMechanism 中的方法
返回此豁免机制是否已成功生成结果 blob。
isCS_sRGB() - 类 java.awt.color.ColorSpace 中的方法
如果 ColorSpace 是 CS_sRGB，则返回 true。
isCurrency(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定的列是否是一个哈希代码值。
isCurrency(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示存储在指定列中的值是否为缓存值。
isCurrent() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否仍旧是当前的。
isCurrent() - 接口 javax.security.auth.Refreshable 中的方法
确定此 Object 是否是当前的。
isCurrentServiceInvalidNow() - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的方法
报告当前服务是否被强行取消，在该情况下，引用当前无效并且不能使用。
isCurrentThreadCpuTimeSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机是否支持当前线程的 CPU 时间测量。
isCursorSet() - 类 java.awt.Component 中的方法
返回是否已为此组件显示地设置了光标。
isCustomMarshaled(Class) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
指示给定的类是执行自定义编组还是默认编组。
isCyclic() - 类 java.awt.GradientPaint 中的方法
如果渐变在两种颜色 C1 和 C2 之间重复循环，则返回 true。
isDaemon() - 类 java.lang.Thread 中的方法
测试该线程是否为守护线程。
isDaemon() - 类 java.lang.ThreadGroup 中的方法
测试此线程组是否为一个后台程序线程组。
isDataFlavorAvailable(DataFlavor) - 类 java.awt.datatransfer.Clipboard 中的方法
返回是否能够以指定的 DataFlavor 形式提供此剪贴板的当前内容。
isDataFlavorSupported(DataFlavor) - 类 java.awt.datatransfer.StringSelection 中的方法
返回所请求的 flavor 是否受此 Transferable 支持。
isDataFlavorSupported(DataFlavor) - 接口 java.awt.datatransfer.Transferable 中的方法
返回此对象是否支持指定的数据 flavor。
isDataFlavorSupported(DataFlavor) - 类 java.awt.dnd.DropTargetContext 中的方法
此方法返回一个 boolean 值，指示给定的 DataFlavor 是否受此 DropTargetContext 支持。
isDataFlavorSupported(DataFlavor) - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的方法
返回指定的数据 flavor 是否受封装的 transferable 支持。
isDataFlavorSupported(DataFlavor) - 类 java.awt.dnd.DropTargetDragEvent 中的方法
此方法返回一个指示指定的 DataFlavor 是否受支持 boolean 值。
isDataFlavorSupported(DataFlavor) - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回一个指示指定的 DataFlavor 是否可在源对象中使用的 boolean 值。
isDataFlavorSupported(DataFlavor) - 类 javax.activation.DataHandler 中的方法
返回此对象是否支持指定的数据 flavor。
isDataFlavorSupported(DataFlavor) - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回是否支持给定的数据 flavor。
isDecimalSeparatorAlwaysShown() - 类 java.text.DecimalFormat 中的方法
允许获取整数中小数分隔符的行为。
isDeclared(int) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 false，除非在 DTD 中声明了该属性。
isDeclared(String) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 false，除非在 DTD 中声明该属性。
isDeclared(String, String) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 false，除非在 DTD 中声明属性。
isDeclared(int) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“声明的”标志的当前值。
isDeclared(String, String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“声明的”标志的当前值。
isDeclared(String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“声明的”标志的当前值。
isDefaultButton() - 类 javax.swing.JButton 中的方法
获取 defaultButton 属性的值，如果为 true 则意味着此按钮是其 JRootPane 的当前默认按钮。
isDefaultCapable() - 类 javax.swing.JButton 中的方法
获取 defaultCapable 属性的值。
isDefaultLookAndFeelDecorated() - 类 javax.swing.JDialog 中的静态方法
如果应该通过当前外观为新创建的 JDialog 提供其 Window 装饰，则返回 true。
isDefaultLookAndFeelDecorated() - 类 javax.swing.JFrame 中的静态方法
如果新创建的 JFrame 应该由当前外观为其提供 Window 装饰，则返回 true。
isDefaultNamespace(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
isDefaultNamespace(String) - 接口 org.w3c.dom.Node 中的方法
此方法检查指定的 namespaceURI 是否是默认名称空间。
isDefaultNamespaceDeclaration() - 接口 javax.xml.stream.events.Namespace 中的方法
如果此属性声明的是默认名称空间，则返回 true。
isDefined(char) - 类 java.lang.Character 中的静态方法
确定字符是否被定义为 Unicode 中的字符。
isDefined(int) - 类 java.lang.Character 中的静态方法
确定字符（Unicode 代码点）是否被定义为 Unicode 中的字符。
isDefined(Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查是否定义了给定的属性。
isDefined(Object) - 接口 javax.swing.text.AttributeSet 中的方法
检查指定属性是否具有该属性集中指定的值，而无需通过其他属性集进行解析。
isDefined(Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
告知是否定义了给定的属性。
isDefined(Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
确定给定属性是否已定义。
isDefined(Object) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
检查给定属性是否已定义。
isDefinitelyWritable(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示在指定的列上进行写操作是否明确可以获得成功。
isDefinitelyWritable(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示在指定的列上进行写操作是否一定可以获得成功。
isDelegated() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
报告此类是否是另一个类的委托。
isDeprecated(Element) - 接口 javax.lang.model.util.Elements 中的方法
如果元素已过时，则返回 true，否则返回 false。
isDerivedFrom(String, String, int) - 接口 org.w3c.dom.TypeInfo 中的方法
此方法返回引用类型定义（即在其上调用该方法的 TypeInfo）和其他类型定义（即作为参数传递的类型定义）之间是否存在派生。
isDescendant(TreePath) - 类 javax.swing.tree.TreePath 中的方法
如果 aTreePath 为此 TreePath 的后代，则返回 true。
isDescendingFrom(Component, Component) - 类 javax.swing.SwingUtilities 中的静态方法
如果组件 a 从组件 b 继承，则返回 true。
isDesignTime() - 类 java.beans.beancontext.BeanContextSupport 中的方法
报告此对象当前是否处于设计时间模式下。
isDesignTime() - 类 java.beans.Beans 中的静态方法
测试是否正处于设计模式。
isDesignTime() - 接口 java.beans.DesignMode 中的方法
值为 true 表示 JavaBeans 应该在设计时间模式下运转，而 false 表示应该在运行时运转。
isDesktopSupported() - 类 java.awt.Desktop 中的静态方法
测试当前平台是否支持此类。
isDestroyed() - 类 java.lang.ThreadGroup 中的方法
测试此线程组是否已经被销毁。
isDestroyed() - 类 java.security.KeyStore.PasswordProtection 中的方法
确定密码是否已被清除。
isDestroyed() - 接口 javax.security.auth.Destroyable 中的方法
确定此 Object 是否已经销毁。
isDestroyed() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
确定此密钥是否已经销毁。
isDestroyed() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定是否已经销毁此票据。
isDestroyed() - 类 javax.security.auth.x500.X500PrivateCredential 中的方法
确定是否已清除对此对象中的 X.509 证书、私钥和 KeyStore 别名的引用。
isDeviceSupported(MidiDevice.Info) - 类 javax.sound.midi.spi.MidiDeviceProvider 中的方法
指示该设备提供者是否支持由指定的设备信息对象表示的设备。
isDigit(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为数字。
isDigit(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为数字。
isDirect() - 类 java.nio.Buffer 中的方法
告知此缓冲区是否为直接缓冲区。
isDirect() - 类 java.nio.ByteBuffer 中的方法
判断此字节缓冲区是否为直接的。
isDirect() - 类 java.nio.CharBuffer 中的方法
判断此字符缓冲区是否为直接的。
isDirect() - 类 java.nio.DoubleBuffer 中的方法
判断此 double 缓冲区是否为直接的。
isDirect() - 类 java.nio.FloatBuffer 中的方法
判断此 float 缓冲区是否为直接的。
isDirect() - 类 java.nio.IntBuffer 中的方法
判断此 int 缓冲区是否为直接的。
isDirect() - 类 java.nio.LongBuffer 中的方法
判断此 long 缓冲区是否为直接的。
isDirect() - 类 java.nio.ShortBuffer 中的方法
判断此 short 缓冲区是否为直接的。
isDirectory() - 类 java.io.File 中的方法
测试此抽象路径名表示的文件是否是一个目录。
isDirectory() - 类 java.util.zip.ZipEntry 中的方法
如果为目录条目，则返回 true。
isDirectorySelected() - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
记忆当前是否在 UI 中选择了目录的属性。
isDirectorySelectionEnabled() - 类 javax.swing.JFileChooser 中的方法
方便的调用，可根据当前的文件选择模式确定目录是否为可选择的。
isDispatchThread() - 类 java.awt.EventQueue 中的静态方法
如果正在调用的线程是当前 AWT EventQueue 的指派线程，则返回 true。
isDisplayable() - 类 java.awt.Component 中的方法
确定此组件是否可以显示。
isDisplayChangeSupported() - 类 java.awt.GraphicsDevice 中的方法
如果此 GraphicsDevice 支持低层显示更改，则返回 true。
isDisposed() - 类 javax.print.StreamPrintService 中的方法
返回一个 boolean 值，指示是否已处置此 StreamPrintService。
isDocFlavorSupported(DocFlavor) - 接口 javax.print.PrintService 中的方法
确定此 PrintService 是否支持具体 DocFlavor。
isDomainPattern() - 类 javax.management.ObjectName 中的方法
根据对象名的域部分检查对象名是否为一个模式。
isDone() - 类 java.awt.geom.FlatteningPathIterator 中的方法
测试迭代是否完成。
isDone() - 接口 java.awt.geom.PathIterator 中的方法
测试迭代是否完成。
isDone() - 接口 java.util.concurrent.Future 中的方法
如果任务已完成，则返回 true。
isDone() - 类 java.util.concurrent.FutureTask 中的方法
isDone() - 类 javax.swing.SwingWorker 中的方法
如果任务已完成，则返回 true。
isDoubleBuffered() - 类 java.awt.Component 中的方法
如果将此组件绘制到一个随后复制到屏幕上的屏幕外图像（“缓冲区”），则返回 true。
isDoubleBuffered() - 类 javax.swing.JComponent 中的方法
返回此组件是否应该使用缓冲区进行绘制。
isDoubleBufferingEnabled() - 类 javax.swing.RepaintManager 中的方法
如果此 RepaintManager 被双缓冲，则返回 true。
isDragging - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
isDragging() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
如果用户在拖动滑块，则返回 true。
isDragging - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的变量
isDragImageSupported() - 类 java.awt.dnd.DragSource 中的静态方法
报告基础平台是否提供对拖动 Image 的支持。
isDrawingBuffer() - 类 javax.swing.DebugGraphics 中的方法
返回 drawingBuffer 值。
isDrive(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
UI 类使用此方法来决定是否为驱动器或分区显示特殊图标，例如，“硬盘”图标。
isDrop() - 类 javax.swing.TransferHandler.TransferSupport 中的方法
返回此 TransferSupport 是否表示一个放置操作。
isDuplicateToken() - 类 org.ietf.jgss.MessageProp 中的方法
测试此标记是否为先前标记的一个副本。
isDynamic() - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
如果使用相同参数的后续呈现（即调用 create(RenderContext, ParameterBlock)）可以生成不同的结果，则返回 true。
isDynamic() - 接口 java.awt.image.renderable.RenderableImage 中的方法
如果使用相同参数的后续呈现（即调用 createRendering() 或 createScaledRendering()）可以生成不同的结果，则返回 true。
isDynamic() - 类 java.awt.image.renderable.RenderableImageOp 中的方法
如果使用相同参数的后续呈现（即调用 createRendering() 或 createScaledRendering()）可以生成不同结果，则返回 true。
isDynamicLayoutActive() - 类 java.awt.Toolkit 中的方法
返回当前是否激活了调整大小时的动态布局（以编程方式设置，并受底层操作系统和/或窗口管理器支持）。
isDynamicLayoutSet() - 类 java.awt.Toolkit 中的方法
返回 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。
isEchoOn() - 类 javax.security.auth.callback.PasswordCallback 中的方法
返回密码是否应该在键入时显示。
isEditable() - 类 java.awt.TextComponent 中的方法
指示此文本组件是否可编辑。
isEditable - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
isEditable() - 类 javax.swing.JComboBox 中的方法
如果 JComboBox 可编辑，则返回 true。
isEditable() - 类 javax.swing.JTree 中的方法
如果树可编辑，则返回 true。
isEditable() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
isEditable() - 类 javax.swing.text.JTextComponent 中的方法
返回指示此 TextComponent 是否可编辑的 boolean。
isEditing() - 类 javax.swing.JTable 中的方法
如果正在编辑单元格，则返回 true。
isEditing() - 类 javax.swing.JTree 中的方法
如果正在编辑树，则返回 true。
isEditing(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果树正被编辑，则返回 true。
isEditing(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 isEditing 方法。
isEditing(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
如果树正被编辑，则返回 true。
isEditValid() - 类 javax.swing.JFormattedTextField 中的方法
如果所编辑的当前值有效，则返回 true。
isElement(Object) - 类 javax.xml.bind.JAXBIntrospector 中的方法
如果 object 表示一个 JAXB 元素，则返回 true。
isElementContentWhitespace() - 接口 org.w3c.dom.Text 中的方法
返回此文本节点是否包含 元素内容空白符，即经常所称的“可忽略的空白符”。
isEmpty() - 类 java.awt.geom.Arc2D.Double 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Arc2D.Float 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Area 中的方法
测试此 Area 对象是否包括其他区域。
isEmpty() - 类 java.awt.geom.Ellipse2D.Double 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Ellipse2D.Float 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Rectangle2D.Double 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.Rectangle2D.Float 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.RectangularShape 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.Rectangle 中的方法
确定 RectangularShape 是否为空。
isEmpty() - 类 java.awt.RenderingHints 中的方法
如果此 RenderingHints 未包含键-值映射关系，则返回 true。
isEmpty() - 类 java.beans.beancontext.BeanContextSupport 中的方法
报告此 BeanContext 是否为空。
isEmpty() - 类 java.lang.String 中的方法
当且仅当 String.length() 为 0 时返回 true。
isEmpty() - 类 java.util.AbstractCollection 中的方法
如果此 collection 不包含元素，则返回 true。
isEmpty() - 类 java.util.AbstractMap 中的方法
如果此映射未包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.ArrayDeque 中的方法
如果此双端队列未包含任何元素，则返回 true。
isEmpty() - 类 java.util.ArrayList 中的方法
如果此列表中没有元素，则返回 true
isEmpty() - 类 java.util.BitSet 中的方法
如果此 BitSet 中没有包含任何设置为 true 的位，则返回 ture。
isEmpty() - 接口 java.util.Collection 中的方法
如果此 collection 不包含元素，则返回 true。
isEmpty() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
如果此映射不包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
如果此队列不包含任何元素，则返回 true。
isEmpty() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
如果此映射未包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
如果此 set 不包含任何元素，则返回 true。
isEmpty() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
如果此列表不包含任何元素，则返回 true。
isEmpty() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果此 set 不包含任何元素，则返回 true。
isEmpty() - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 true。
isEmpty() - 类 java.util.Dictionary 中的方法
测试此 dictionary 是否不存在从键到值的映射。
isEmpty() - 类 java.util.HashMap 中的方法
如果此映射不包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.HashSet 中的方法
如果此 set 不包含任何元素，则返回 true。
isEmpty() - 类 java.util.Hashtable 中的方法
测试此哈希表是否没有键映射到值。
isEmpty() - 类 java.util.IdentityHashMap 中的方法
如果此标识哈希映射不包含键-值映射关系，则返回 true。
isEmpty() - 类 java.util.jar.Attributes 中的方法
如果此 Map 不包含属性，则返回 true。
isEmpty() - 接口 java.util.List 中的方法
如果列表不包含元素，则返回 true。
isEmpty() - 接口 java.util.Map 中的方法
如果此映射未包含键-值映射关系，则返回 true。
isEmpty() - 接口 java.util.Set 中的方法
如果 set 不包含元素，则返回 true。
isEmpty() - 类 java.util.TreeSet 中的方法
如果此 set 不包含任何元素，则返回 true。
isEmpty() - 类 java.util.Vector 中的方法
测试此向量是否不包含组件。
isEmpty() - 类 java.util.WeakHashMap 中的方法
如果此映射不包含键-值映射关系，则返回 true。
isEmpty() - 类 javax.activation.MimeTypeParameterList 中的方法
确定此列表是否为空。
isEmpty() - 接口 javax.management.openmbean.TabularData 中的方法
如果此 TabularData 实例中包含的 CompositeData 值的数目（即行数）为零，则返回 true。
isEmpty() - 类 javax.management.openmbean.TabularDataSupport 中的方法
如果此 TabularDataSupport 实例不包含任何行，则返回 true。
isEmpty() - 类 javax.management.timer.Timer 中的方法
测试计时器通知列表是否为空。
isEmpty() - 接口 javax.management.timer.TimerMBean 中的方法
测试计时器通知列表是否为空。
isEmpty() - 类 javax.naming.CompositeName 中的方法
确定此复合名称是否为空。
isEmpty() - 类 javax.naming.CompoundName 中的方法
确定此组合名称是否为空。
isEmpty() - 类 javax.naming.ldap.LdapName 中的方法
确定此 LDAP 名称是否为空。
isEmpty() - 接口 javax.naming.Name 中的方法
确定此名称是否为空。
isEmpty() - 接口 javax.print.attribute.AttributeSet 中的方法
如果此属性集不包含任何属性，则返回 true。
isEmpty() - 类 javax.print.attribute.HashAttributeSet 中的方法
如果此属性集不包含任何属性，则返回 true。
isEmpty() - 类 javax.script.SimpleBindings 中的方法
如果此映射未包含键-值映射关系，则返回 true。
isEmpty() - 类 javax.swing.DefaultListModel 中的方法
测试此列表中是否有组件。
isEmpty() - 类 javax.swing.text.html.parser.Element 中的方法
检查是否为空
isEmpty() - 类 javax.swing.text.SimpleAttributeSet 中的方法
检查属性集是否为空。
isEnabled() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
确定是否启用了此对象。
isEnabled() - 类 java.awt.Component 中的方法
确定此组件是否已启用。
isEnabled() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
确定是否已启用对象。
isEnabled() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
确定是否启用该对象。
isEnabled() - 类 java.awt.MenuItem 中的方法
检查是否启用了此菜单项。
isEnabled() - 接口 javax.accessibility.AccessibleComponent 中的方法
确定是否已启用该对象。
isEnabled() - 类 javax.swing.AbstractAction 中的方法
如果启用该操作，则返回 true。
isEnabled() - 接口 javax.swing.Action 中的方法
返回 Action 的启用状态。
isEnabled() - 接口 javax.swing.ButtonModel 中的方法
指示是否可通过输入设备（比如鼠标指针）选择或触发按钮。
isEnabled() - 类 javax.swing.DefaultButtonModel 中的方法
指示是否可通过输入设备（比如鼠标指针）选择或触发按钮。
isEnabled() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
isEnabled() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
确定是否启用该对象。
isEnabled() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicSliderUI.ActionScroller 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreePageAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction 中的方法
isEnabled() - 类 javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction 中的方法
isEnabled() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
isEnabled() - 类 javax.swing.ToolTipManager 中的方法
如果启用该对象，则返回 true。
isEnabledAt(int) - 类 javax.swing.JTabbedPane 中的方法
返回当前是否启用了 index 位置的选项卡。
isEndDocument() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 EndDocument 的实用工具函数。
isEndElement() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 EndElement 的实用工具函数。
isEndElement() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isEndElement() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果光标指向结束标记，则返回 true（否则返回 false）
isEnqueued() - 类 java.lang.ref.Reference 中的方法
由程序或垃圾回收器通知是否已将此引用对象加入队列。
isEntityReference() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 EntityReference 的实用工具函数。
isEnum() - 类 java.lang.Class 中的方法
当且仅当该类声明为源代码中的枚举时返回 true。
isEnumConstant() - 类 java.lang.reflect.Field 中的方法
如果此字段表示枚举类型的元素，则返回 true；否则返回 false。
isEqual(byte[], byte[]) - 类 java.security.MessageDigest 中的静态方法
比较两个摘要的相等性。
isEqual(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查两个属性集合是否相等。
isEqual(AttributeSet) - 接口 javax.swing.text.AttributeSet 中的方法
确定两个属性集是否相等。
isEqual(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
比较两个属性集。
isEqual(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
检查两个属性集是否相等。
isEqual(AttributeSet) - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
检查两个属性集是否相等。
isEqualNode(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
isEqualNode(Node) - 接口 org.w3c.dom.Node 中的方法
测试两个节点是否相等。
isError() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述错误情况。
isErrorAny() - 类 java.awt.MediaTracker 中的方法
检查所有图像的错误状态。
isErrorID(int) - 类 java.awt.MediaTracker 中的方法
检查由此媒体跟踪器跟踪且具有指定标识符的所有图像的错误状态。
isEstablished() - 接口 org.ietf.jgss.GSSContext 中的方法
用来在上下文创建期间确定上下文的状态。
isEventDispatchThread() - 类 javax.swing.SwingUtilities 中的静态方法
如果当前线程是 AWT 事件指派线程，则返回 true。
isExpanded(TreePath) - 类 javax.swing.JTree 中的方法
如果当前展开了路径标识的节点，则返回 true。
isExpanded(int) - 类 javax.swing.JTree 中的方法
如果当前展开了指定显示行处的节点，则返回 true。
isExpanded(TreePath) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
如果当前扩展了由行标识的值，则返回 true。
isExpanded(TreePath) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
如果当前扩展了由行标识的值，则返回 true。
isExpanded(TreePath) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
如果当前扩展了 path 标识的值，则返回 true。
isExpandEntityReferences() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成扩展实体引用节点的解析器。
isExpert() - 类 java.beans.FeatureDescriptor 中的方法
"expert" 标志用于区分那些打算供高级用户使用的特性与那些打算供普通用户使用的特性。
isExplicitPolicyRequired() - 类 java.security.cert.PKIXParameters 中的方法
检查是否需要显式策略。
isFair() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
如果此锁的公平设置为 true，则返回 true。
isFair() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
如果此锁将公平性设置为 ture，则返回 true。
isFair() - 类 java.util.concurrent.Semaphore 中的方法
如果此信号量的公平设置为 true，则返回 true。
isFeatureSupported(String) - 类 javax.xml.crypto.dom.DOMStructure 中的方法
isFeatureSupported(String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
指示是否支持指定的功能。
isFeatureSupported(String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
指示是否支持指定的功能。
isFeatureSupported(String) - 接口 javax.xml.crypto.XMLStructure 中的方法
指示是否支持指定的功能。
isField() - 枚举 javax.lang.model.element.ElementKind 中的方法
如果此元素是以下种类的字段，则返回 true：FIELD 或 ENUM_CONSTANT。
isFile() - 类 java.io.File 中的方法
测试此抽象路径名表示的文件是否是一个标准文件。
isFileHidingEnabled() - 类 javax.swing.JFileChooser 中的方法
如果在文件选择器中不显示隐藏文件，则返回 true；否则返回 false。
isFileSelectionEnabled() - 类 javax.swing.JFileChooser 中的方法
方便的调用，可根据当前的文件选择模式确定文件是否为可选择的。
isFileSystem(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
检查 f 是否表示一个相对于特殊文件夹（如 "Desktop"）的实际目录或文件。
isFileSystemRoot(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
判断 dir 是否是文件系统（如驱动器或分区）中的树的根。
isFileTypeSupported(int) - 类 javax.sound.midi.MidiSystem 中的静态方法
指示系统是否提供了指定 MIDI 文件类型的文件写入支持。
isFileTypeSupported(int, Sequence) - 类 javax.sound.midi.MidiSystem 中的静态方法
指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
isFileTypeSupported(int) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
指示此文件 writer 是否提供指定 MIDI 文件类型的文件写入支持。
isFileTypeSupported(int, Sequence) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
isFileTypeSupported(AudioFileFormat.Type) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示系统是否提供指定文件类型的文件写入支持。
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示是否可以从指示的音频输入流写入指定文件类型的音频文件。
isFileTypeSupported(AudioFileFormat.Type) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
指示此音频文件 writer 是否提供指定文件类型的文件写入支持。
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
指示是否可以从指示的音频输入流写入指定类型的音频文件。
isFinal(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 final 修饰符，则返回 true，否则返回 false。
isFirst() - 接口 java.sql.ResultSet 中的方法
获取光标是否位于此 ResultSet 对象的第一行。
isFixedRowHeight() - 类 javax.swing.JTree 中的方法
如果每个显示行的高度为固定大小，则返回 true。
isFixedRowHeight() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
如果每行的高度为固定大小，则返回 true。
isFlavorJavaFileListType() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果指定的 DataFlavor 表示 File 对象列表，则返回 true。
isFlavorRemoteObjectType() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果指定的 DataFlavor 表示远程对象，则返回 true。
isFlavorSerializedObjectType() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果指定的 DataFlavor 表示序列化对象，则返回 true。
isFlavorTextType() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 是否是 Java 平台此实现的有效文本 flavor。
isFloatable() - 类 javax.swing.JToolBar 中的方法
获取 floatable 属性。
isFloating() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
isFloppyDrive(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
UI 类使用此方法来决定是否为软盘显示特殊图标。
isFocusable() - 类 java.awt.Component 中的方法
返回此 Component 是否可以获得焦点。
isFocusableWindow() - 类 java.awt.Window 中的方法
返回此窗口是否可以成为焦点窗口，也就是说，此窗口或其任何子组件是否可以成为焦点所有者。
isFocusCycleRoot(Container) - 类 java.awt.Component 中的方法
返回指定的 Container 是否为此 Component 焦点遍历循环的焦点循环根。
isFocusCycleRoot(Container) - 类 java.awt.Container 中的方法
返回指定的 Container 是否是此 Container 的焦点遍历循环的焦点循环根。
isFocusCycleRoot() - 类 java.awt.Container 中的方法
返回此 Container 是否是某个焦点遍历循环的根。
isFocusCycleRoot() - 类 java.awt.Window 中的方法
始终返回 true，因为所有窗口必须是焦点遍历循环的根。
isFocusCycleRoot() - 类 javax.swing.JInternalFrame 中的方法
始终返回 true，原因是所有 JInternalFrame 必须为焦点遍历循环的根。
isFocused() - 类 java.awt.Window 中的方法
返回此窗口是否为焦点窗口。
isFocusManagerEnabled() - 类 javax.swing.FocusManager 中的静态方法
已过时。 从 1.4 开始，由 KeyboardFocusManager.getDefaultFocusTraversalPolicy() 取代
isFocusOwner() - 类 java.awt.Component 中的方法
如果此 Component 是焦点所有者，则返回 true。
isFocusPainted() - 类 javax.swing.AbstractButton 中的方法
获取 paintFocus 属性。
isFocusTraversable() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
返回对此对象是否可以接受焦点的判断。
isFocusTraversable() - 类 java.awt.Component 中的方法
已过时。 从 1.4 开始，由 isFocusable() 取代。
isFocusTraversable() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
返回此对象是否可以接受焦点。
isFocusTraversable() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
返回此对象是否可以接受焦点。
isFocusTraversable() - 接口 javax.accessibility.AccessibleComponent 中的方法
返回此对象是否可以接受焦点。
isFocusTraversable() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
isFocusTraversable() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
isFocusTraversable() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
isFocusTraversable() - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
返回箭头按钮是否应该获取焦点。
isFocusTraversable(JComboBox) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
确定 JComboBox 是否是可焦点遍历的。
isFocusTraversable() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
重写以无条件返回 false。
isFocusTraversable() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 中的方法
isFocusTraversable(JComboBox) - 类 javax.swing.plaf.ComboBoxUI 中的方法
确定组合框本身是否是可遍历的
isFocusTraversable() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
isFocusTraversable(JComboBox) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 isFocusTraversable 方法。
isFocusTraversable() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
isFocusTraversalPolicyProvider() - 类 java.awt.Container 中的方法
返回此容器是否提供焦点遍历策略。
isFocusTraversalPolicySet() - 类 java.awt.Container 中的方法
返回是否为此 Container 明确设置焦点遍历策略。
isFontSet() - 类 java.awt.Component 中的方法
返回是否已为此组件显示地设置了字体。
isForegroundSet() - 类 java.awt.Component 中的方法
返回是否已为此组件显式地设置了前景色。
isFormatLossless() - 类 javax.imageio.spi.ImageWriterSpi 中的方法
如果此 writer 输出的格式准确保留了像素数据位，则返回 true。
isFormatSupported(AudioFormat) - 类 javax.sound.sampled.DataLine.Info 中的方法
指示此数据行是否支持特定的音频格式。
isFormattedOutput() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取格式化输出标志的便捷方法。
isForwardable() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是可转发的。
isForwardCheckingSupported() - 类 java.security.cert.PKIXCertPathChecker 中的方法
指示是否支持正向检查。
isForwarded() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
根据验证（包括转发的票据授权票据）确定此票据是否已经转发或发出。
isFragment() - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
获取片段标志的便捷方法。
isFrameStateSupported(int) - 类 java.awt.Toolkit 中的方法
返回 Toolkit 是否支持 Frame 状态。
isFreeStanding - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
isFullScreenRequired() - 类 java.awt.BufferCapabilities 中的方法
isFullScreenSupported() - 类 java.awt.GraphicsDevice 中的方法
如果此 GraphicsDevice 支持全屏独占模式，则返回 true。
isGapToken() - 类 org.ietf.jgss.MessageProp 中的方法
测试是否未接收到需要的标记（即一个或多个原先的标记尚未成功处理）。
isGeneral() - 类 javax.swing.text.html.parser.Entity 中的方法
如果是常规实体，则返回 true。
isGlobalScope() - 类 javax.xml.bind.JAXBElement 中的方法
如果此 xml 元素声明是全局性的，则返回 true。
isGraphicsConfigSupported(GraphicsConfiguration) - 类 java.awt.GraphicsConfigTemplate 中的方法
返回一个 boolean，它指示指定的 GraphicsConfiguration 是否可用于创建支持指定功能的绘图面。
isGroupingUsed() - 类 java.text.NumberFormat 中的方法
如果此格式中使用了分组，则返回 true。
isGuiAvailable() - 类 java.beans.Beans 中的静态方法
确定 bean 是否可以假定某个 GUI 是可用的。
isHeadless() - 类 java.awt.GraphicsEnvironment 中的静态方法
测试此环境是否支持显示器、键盘和鼠标。
isHeadlessInstance() - 类 java.awt.GraphicsEnvironment 中的方法
返回此图形环境是否支持显示器、键盘和鼠标。
isHeldByCurrentThread() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询当前线程是否保持此锁。
isHeldByCurrentThread() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
查询此写入锁是否由当前线程保持。
isHeldExclusively() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
如果对于当前（调用的）线程，同步是以独占方式进行的，则返回 true。
isHeldExclusively() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
如果对于当前（正调用的）线程，同步是以独占方式进行的，则返回 true。
isHidden() - 类 java.beans.FeatureDescriptor 中的方法
"hidden" 标志用于标识只打算供工具使用、不应对人类开放的特性。
isHidden() - 类 java.io.File 中的方法
测试此抽象路径名指定的文件是否是一个隐藏文件。
isHidden(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView 中的方法
isHiddenFile(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
返回某个文件是否被隐藏。
isHighSurrogate(char) - 类 java.lang.Character 中的静态方法
确定给出的 char 值是否为一个高代理项代码单元（也称为前导代理项代码单元）。
isHorizontal() - 类 java.awt.ComponentOrientation 中的方法
各行是水平的？这将为水平的、从左到右的书写系统（如罗马语）返回 true。
isHTMLString(String) - 类 javax.swing.plaf.basic.BasicHTML 中的静态方法
检查给定字符串以查看它是否应该在支持 html 呈现的非文本组件中触发 html 呈现逻辑。
isIcon - 类 javax.swing.JInternalFrame 中的变量
窗体已图标化。
isIcon() - 类 javax.swing.JInternalFrame 中的方法
返回 JInternalFrame 当前是否已图标化。
isIconifiable() - 类 javax.swing.JInternalFrame 中的方法
获取该 iconable 属性（默认情况下为 false）。
isIconOnly() - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
isId() - 接口 org.w3c.dom.Attr 中的方法
返回是否此属性属于类型 ID（即包含其所有者元素的标识符）。
isIdAttribute(int) - 类 javax.xml.validation.TypeInfoProvider 中的方法
如果指定属性确定为 ID，则返回 true。
isIdentifier(CharSequence) - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回 name 是否是语法上有效的标识符（简单名称）或最新源版本中的关键字。
isIdentifierIgnorable(char) - 类 java.lang.Character 中的静态方法
确定是否应该认为指定字符是 Java 标识符或 Unicode 标识符中可忽略的一个字符。
isIdentifierIgnorable(int) - 类 java.lang.Character 中的静态方法
确定是否应该认为指定字符（Unicode 代码点）是 Java 标识符或 Unicode 标识符中可忽略的一个字符。
isIdentity() - 类 java.awt.font.TransformAttribute 中的方法
如果包装转换是一个恒等变换，则返回 true。
isIdentity() - 类 java.awt.geom.AffineTransform 中的方法
如果此 AffineTransform 是恒等变换，则返回 true。
isIgnorableWhiteSpace() - 接口 javax.xml.stream.events.Characters 中的方法
如果它是 ignorableWhiteSpace，则返回 ture。
isIgnoringComments() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成忽略注释的解析器。
isIgnoringElementContentWhitespace() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成解析器，该解析器忽略元素内容中的可忽略空格。
isIgnoringMetadata() - 类 javax.imageio.ImageReader 中的方法
如果已经通过传递 true 作为 setInput 方法的 ignoreMetadata 参数将当前输入源标记为允许忽略元数据，则返回 true。
isImageAutoSize() - 类 java.awt.TrayIcon 中的方法
返回自动调整大小属性的值。
isImageTiled(int) - 类 javax.imageio.ImageReader 中的方法
如果图像被组织成 tile（即等大小的非重叠矩形），则返回 true。
isInboundDone() - 类 javax.net.ssl.SSLEngine 中的方法
返回 SSLEngine.unwrap(ByteBuffer, ByteBuffer) 是否再接受更多的入站数据报文。
isInDefaultEventSet() - 类 java.beans.EventSetDescriptor 中的方法
报告事件集是否在“默认”集合中。
isIndeterminate() - 类 javax.swing.JProgressBar 中的方法
返回 indeterminate 属性的值。
ISINDEX - 类 javax.swing.text.html.HTML.Tag 中的静态变量
isindex - 类 javax.swing.text.html.parser.DTD 中的变量
isIndexSelected(int) - 类 java.awt.List 中的方法
确定是否已选中此滚动列表中的指定项。
isInfinite(double) - 类 java.lang.Double 中的静态方法
如果指定数在数值上为无穷大，则返回 true；否则返回 false。
isInfinite() - 类 java.lang.Double 中的方法
如果此 Double 值在数值上为无穷大，则返回 true；否则返回 false。
isInfinite(float) - 类 java.lang.Float 中的静态方法
如果指定数的数值是无穷大，则返回 true，否则返回 false。
isInfinite() - 类 java.lang.Float 中的方法
如果此 Float 值的大小是无穷大，则返回 true，否则返回 false。
isInherited() - 类 javax.swing.text.html.CSS.Attribute 中的方法
指示是否应该从父级继承属性。
isInitial() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是使用 Kerberos AS-Exchange 协议发出的，而不是根据某些票据授权票据发出的。
isInitialized() - 类 javax.annotation.processing.AbstractProcessor 中的方法
如果此对象已被初始化，则返回 true，否则返回 false。
isInitiator() - 接口 org.ietf.jgss.GSSContext 中的方法
确定它是否为上下文初始端。
isInNative() - 类 java.lang.management.ThreadInfo 中的方法
测试与此 ThreadInfo 关联的线程是否通过 Java 本机接口 (JNI) 执行本机代码。
isInProgress() - 类 javax.swing.undo.CompoundEdit 中的方法
如果此编辑正在进行中（即未收到结束通知），则返回 true。
isInputShutdown() - 类 java.net.Socket 中的方法
返回是否关闭套接字连接的半读状态 (read-half)。
isInRelationService() - 类 javax.management.relation.RelationSupport 中的方法
返回指定该对象是否仍然由 Relation Service 处理的内部标志。
isInRelationService() - 接口 javax.management.relation.RelationSupportMBean 中的方法
返回指定该对象是否仍然由 Relation Service 处理的内部标志。
isInsert() - 类 javax.swing.JList.DropLocation 中的方法
返回此位置是否表示一个插入位置。
isInsertColumn() - 类 javax.swing.JTable.DropLocation 中的方法
返回此位置是否表示一个列的插入位置。
isInsertRow() - 类 javax.swing.JTable.DropLocation 中的方法
返回此位置是否表示一个行的插入位置。
isInstance(Object) - 类 java.lang.Class 中的方法
判定指定的 Object 是否与此 Class 所表示的对象赋值兼容。
isInstanceOf(Object, Class<?>) - 类 java.beans.Beans 中的静态方法
检查是否可以将 bean 视为给定目标类型。
isInstanceOf(ObjectName, String) - 接口 javax.management.MBeanServer 中的方法
isInstanceOf(ObjectName, String) - 接口 javax.management.MBeanServerConnection 中的方法
如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
isInstanceOf(StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于 MBean 类的继承约束条件。
isInstanceOf(ObjectName, String, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
isInstanceOf(ObjectName, String, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
isInstanceOf(ObjectName, String, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
isInterface() - 类 java.lang.Class 中的方法
判定指定的 Class 对象是否表示一个接口类型。
isInterface(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 interface 修饰符，则返回 true，否则返回 false。
isInterface() - 枚举 javax.lang.model.element.ElementKind 中的方法
如果此元素是以下种类的接口，则返回 true：INTERFACE 或 ANNOTATION_TYPE。
isInterrupted() - 类 java.lang.Thread 中的方法
测试线程是否已经中断。
isIPv4CompatibleAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是与 IPv4 兼容的 IPv6 地址的实用例行程序。
isIs() - 类 javax.management.MBeanAttributeInfo 中的方法
指示此属性是否有一个 "is" 获取方法。
isIs() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
如果通过 isXXX 获取方法（仅适用于 boolean 和 Boolean 值）访问此 OpenMBeanAttributeInfo 实例描述的属性，则返回 true，否则返回 false。
isISOControl(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为 ISO 控制字符。
isISOControl(int) - 类 java.lang.Character 中的静态方法
确定引用的字符（Unicode 代码点）是否为 ISO 控制字符。
isItalic() - 类 java.awt.Font 中的方法
指示此 Font 对象的样式是否为 ITALIC。
isItalic(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了斜体属性。
isJavaIdentifierPart(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否可以是 Java 标识符中首字符以外的部分。
isJavaIdentifierPart(int) - 类 java.lang.Character 中的静态方法
确定字符（Unicode 代码点）是否可以是 Java 标识符中首字符以外的部分。
isJavaIdentifierStart(char) - 类 java.lang.Character 中的静态方法
确定是否允许将指定字符作为 Java 标识符中的首字符。
isJavaIdentifierStart(int) - 类 java.lang.Character 中的静态方法
确定是否允许将字符（Unicode 代码点）作为 Java 标识符中的首字符。
isJavaLetter(char) - 类 java.lang.Character 中的静态方法
已过时。 由 isJavaIdentifierStart(char) 取代。
isJavaLetterOrDigit(char) - 类 java.lang.Character 中的静态方法
已过时。 由 isJavaIdentifierPart(char) 取代。
isJavaMIMEType(String) - 类 java.awt.datatransfer.SystemFlavorMap 中的静态方法
返回指定的 String 是否为编码的 Java MIME 类型。
isKeyBindingActive() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
isKeyBindingRegistered() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
isKeyDown - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的变量
keyPressed 处于激活状态时设置为 true。
isKeyEntry(String) - 类 java.security.KeyStore 中的方法
如果给定别名标识的条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 创建的，则返回 true。
isKeyword(CharSequence) - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回 s 是否是最新源版本中的关键字或字面值。
isLargeModel() - 类 javax.swing.JTree 中的方法
如果将树配置为大模型，则返回 true。
isLargeModel() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
isLast() - 接口 java.sql.ResultSet 中的方法
获取光标是否位于此 ResultSet 对象的最后一行。
isLayoutValid() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
是否已对子视图进行布局。
isLayoutValid(int) - 类 javax.swing.text.BoxView 中的方法
确定沿给定轴的布局是否有效。
isLeadAnchorNotificationEnabled() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回 leadAnchorNotificationEnabled 标志的值。
isLeadingEdge() - 类 java.awt.font.TextHitInfo 中的方法
如果字符的开始边是插入点，则返回 true。
isLeaf() - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
如果此节点允许子节点，则返回 true。
isLeaf(int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
isLeaf() - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
检查该元素是否为叶元素。
isLeaf() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
检查该元素是否为叶元素。
isLeaf() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
检查该元素是否为叶元素。
isLeaf() - 接口 javax.swing.text.Element 中的方法
确定此元素是否为叶元素。
isLeaf() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果此节点没有子节点，则返回 true。
isLeaf(Object) - 类 javax.swing.tree.DefaultTreeModel 中的方法
返回指定的节点是否为叶节点。
isLeaf(Object) - 接口 javax.swing.tree.TreeModel 中的方法
如果 node 为叶节点，则返回 true。
isLeaf() - 接口 javax.swing.tree.TreeNode 中的方法
如果接收者是一个叶节点，则返回 true。
isLeapYear(int) - 类 java.util.GregorianCalendar 中的方法
确定给定的年份是否为闰年。
isLeftMouseButton(MouseEvent) - 类 javax.swing.SwingUtilities 中的静态方法
如果鼠标事件指定左边鼠标按键，则返回 true。
isLeftToRight() - 类 java.awt.ComponentOrientation 中的方法
水平行：各项从左到右布局？
垂直行：各行从左到右布局？
这将为水平的、从左到右的书写系统（如罗马语）返回 true。
isLeftToRight() - 类 java.awt.font.TextLayout 中的方法
如果此 TextLayout 的基本方向是从左到右，则返回 true；如果基本方向是从右到左，则返回 false。
isLeftToRight() - 类 java.text.Bidi 中的方法
如果该行都是从左到右的文本且基本方向也是从左到右，则返回 true。
isLegalReplacement(byte[]) - 类 java.nio.charset.CharsetEncoder 中的方法
通知给定的 byte 数组是否为此编码器的合法替换值。
isLenient() - 类 java.text.DateFormat 中的方法
判断日期/时间解析是否为不严格的。
isLenient() - 类 java.util.Calendar 中的方法
判断日期/时间的解释是否为宽松的。
isLetter(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为字母。
isLetter(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为字母。
isLetterOrDigit(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为字母或数字。
isLetterOrDigit(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为字母或数字。
isLigature() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个连字字形，则返回 true。
isLight - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的变量
isLightweight() - 类 java.awt.Component 中的方法
轻量级组件没有本机工具包同位体。
isLightweightComponent(Component) - 类 javax.swing.JComponent 中的静态方法
如果此组件是轻量的，也就是说，如果它没有本机窗口系统同位体，则返回 true。
isLightWeightPopupEnabled() - 类 javax.swing.JComboBox 中的方法
获取 lightWeightPopupEnabled 属性的值。
isLightWeightPopupEnabled() - 类 javax.swing.JPopupMenu 中的方法
获取 lightWeightPopupEnabled 属性。
isLightWeightPopupEnabled() - 类 javax.swing.ToolTipManager 中的方法
如果使用轻量级（所有 Java）Tooltips，则返回 true；如果使用重量级（本机同位体）Tooltips，则返回 false。
isLineEmpty() - 类 javax.swing.text.AbstractWriter 中的方法
如果应该将当前行视为空行，则返回 true。
isLineSupported(Line.Info) - 类 javax.sound.sampled.AudioSystem 中的静态方法
指示系统是否支持与指定 Line.Info 对象匹配的行。
isLineSupported(Line.Info) - 接口 javax.sound.sampled.Mixer 中的方法
指示混频器是否支持与指定 Line.Info 对象匹配的一行（或多行）。
isLinkLocalAddress() - 类 java.net.Inet4Address 中的方法
检查 InetAddress 是否是链接本地地址的实用例行程序。
isLinkLocalAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是链接本地地址的实用例行程序。
isLinkLocalAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是链接本地地址的实用例行程序。
isLoaded() - 类 java.nio.MappedByteBuffer 中的方法
判断此缓冲区的内容是否位于物理内存中。
isLocal - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的变量
一个 boolean 值，指示所封装的 Transferable 对象是否表示执行本地 drag-n-drop 操作的结果（在同一个 JVM 中）。
isLocal(Stub) - 类 javax.rmi.CORBA.Util 中的静态方法
isLocal 方法与 ObjectImpl._is_local 方法具有相同的语义，否则可能抛出 RemoteException。
isLocal(Stub) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.isLocal(javax.rmi.CORBA.Stub) 的委托调用。
isLocalClass() - 类 java.lang.Class 中的方法
当且仅当底层类是本地类时返回 true。
isLocallyDefined(KeyStroke) - 接口 javax.swing.text.Keymap 中的方法
确定是否本地定义给定的键序列。
isLocalTransfer() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
此方法返回一个指示源对象与目标对象是否在同一 JVM 中的 int。
isLocationByPlatform() - 类 java.awt.Window 中的方法
如果此窗口下次可见时，出现在本机窗口操作系统的默认位置，则返回 true。
isLocationInExpandControl(TreePath, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果 mouseX 和 mouseY 落在用于展开/折叠节点的行的区域内，并且 row 的节点不表示叶节点，则返回 true。
isLocationInExpandControl(int, int, int, int) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
isLocked() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
查询此锁是否由任意线程保持。
isLoggable(LogRecord) - 接口 java.util.logging.Filter 中的方法
检查是否应该发布给定的日志记录。
isLoggable(LogRecord) - 类 java.util.logging.Handler 中的方法
检查该 Handler 是否实际记录给定的 LogRecord。
isLoggable(Level) - 类 java.util.logging.Logger 中的方法
检查给定级别的消息实际上是否由此 logger 记录。
isLoggable(LogRecord) - 类 java.util.logging.MemoryHandler 中的方法
检查此 Handler 是否实际将给定的 LogRecord 记录到其内部缓冲区。
isLoggable(LogRecord) - 类 java.util.logging.StreamHandler 中的方法
检查该 Handler 是否实际记录给定的 LogRecord。
isLongerThan(Duration) - 类 javax.xml.datatype.Duration 中的方法
检查此持续时间对象是否严格长于另一个 Duration 对象。
isLoopback() - 类 java.net.NetworkInterface 中的方法
返回网络接口是否是回送接口。
isLoopbackAddress() - 类 java.net.Inet4Address 中的方法
isLoopbackAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是回送地址中的实用例行程序。
isLoopbackAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是回送地址的实用例行程序。
isLowerCase(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为小写字母。
isLowerCase(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为小写字母。
isLowSurrogate(char) - 类 java.lang.Character 中的静态方法
确定给定 char 值是否一个低代理项代码单元（也称为尾部代理项代码单元）。
isMalformed() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述错误输入错误。
isManagingFocus() - 类 javax.swing.JComponent 中的方法
已过时。 从 1.4 版本开始，由 Component.setFocusTraversalKeys(int, Set) 和 Container.setFocusCycleRoot(boolean) 取代。
ISMAP - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
isMarked() - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
返回该标记的当前值。
isMaximizable() - 类 javax.swing.JInternalFrame 中的方法
获取该 maximizable 属性的值。
isMaximum - 类 javax.swing.JInternalFrame 中的变量
已将窗体扩展到其最大大小。
isMaximum() - 类 javax.swing.JInternalFrame 中的方法
返回 JInternalFrame 当前是否已最大化。
isMaximumSizeSet() - 类 java.awt.Component 中的方法
如果已将最大大小设置为非 null 值，则返回 true，否则返回 false。
isMCGlobal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有全局范围的实用例行程序。
isMCGlobal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有全球范围的实用例行程序。
isMCGlobal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有全局域的实用例行程序。
isMCLinkLocal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有链接范围的实用例行程序。
isMCLinkLocal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有链接范围的实用例行程序。
isMCLinkLocal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有链接范围的实用例行程序。
isMCNodeLocal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有节点范围的实用例行程序。
isMCNodeLocal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有节点范围的实用例行程序。
isMCNodeLocal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有节点范围的实用例行程序。
isMCOrgLocal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有组织范围的实用例程。
isMCOrgLocal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有组织范围的实用例行程序。
isMCOrgLocal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有组织范围的实用例行程序。
isMCSiteLocal() - 类 java.net.Inet4Address 中的方法
检查多播地址是否具有站点范围的实用例行程序。
isMCSiteLocal() - 类 java.net.Inet6Address 中的方法
检查多播地址是否具有站点范围的实用例行程序。
isMCSiteLocal() - 类 java.net.InetAddress 中的方法
检查多播地址是否具有站点范围的实用例行程序。
isMember(Principal) - 接口 java.security.acl.Group 中的方法
如果传递的主体是组的一个成员，则返回 true。
isMemberClass() - 类 java.lang.Class 中的方法
当且仅当底层类是成员类时返回 true。
isMenuComponent(Component) - 类 javax.swing.JMenu 中的方法
如果在子菜单层次结构中存在指定的组件，则返回 true。
isMetaDown() - 类 java.awt.event.InputEvent 中的方法
返回 Meta 修饰符在此事件上是否为 down。
isMiddleMouseButton(MouseEvent) - 类 javax.swing.SwingUtilities 中的静态方法
如果鼠标事件指定中间鼠标按键，则返回 true。
isMimeTypeEqual(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
返回传入的 MIME 类型的字符串表示形式是否等于此 DataFlavor 的 MIME 类型。
isMimeTypeEqual(DataFlavor) - 类 java.awt.datatransfer.DataFlavor 中的方法
比较两个 DataFlavor 对象的 mimeType。
isMimeTypeEqual(String) - 类 javax.activation.ActivationDataFlavor 中的方法
传入的 MIME 类型的字符串表示形式是否等效于此 DataFlavor 的 MIME 类型。
isMimeTypeSerializedObject() - 类 java.awt.datatransfer.DataFlavor 中的方法
DataFlavor 是否表示序列化对象？
isMinimumSizeDirty - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
isMinimumSizeSet() - 类 java.awt.Component 中的方法
返回是否已用非 null 值调用了 setMinimumSize。
isMirrored(char) - 类 java.lang.Character 中的静态方法
确定指定字符依据 Unicode 规范是否对称。
isMirrored(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）依据 Unicode 规范是否对称。
isMixed() - 类 java.text.Bidi 中的方法
如果该行既不是从左到右也不是从右到左，则返回 true。
isMixerSupported(Mixer.Info) - 类 javax.sound.sampled.spi.MixerProvider 中的方法
指示混频器提供者是否支持由指定混频器 info 对象表示的混频器。
isMN() - 接口 org.ietf.jgss.GSSName 中的方法
测试此名称对象是否表示一个机制名称 (MN)。
isModal() - 类 java.awt.Dialog 中的方法
指出 dialog 是否为有模式的。
isModalExclusionTypeSupported(Dialog.ModalExclusionType) - 类 java.awt.Toolkit 中的方法
返回此工具包是否支持给定的模式排斥类型。
isModalityTypeSupported(Dialog.ModalityType) - 类 java.awt.Toolkit 中的方法
返回此工具包是否支持给定的模式类型。
isModifiableClass(Class<?>) - 接口 java.lang.instrument.Instrumentation 中的方法
确定一个类是否可以被 retransformation 或 redefinition 修改。
isMouseOver() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
返回鼠标当前是否位于分隔符上
isMTOMEnabled() - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
如果启用了 MTOM，则返回 true。
isMultiBufferAvailable() - 类 java.awt.BufferCapabilities 中的方法
isMulticastAddress() - 类 java.net.Inet4Address 中的方法
检查 InetAddress 是否是 IP 多播地址的实用例行程序。
isMulticastAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否 IP 多播地址的实用例行程序。
isMulticastAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是 IP 多播地址的实用例行程序。
isMultipleMode() - 类 java.awt.List 中的方法
确定此列表是否允许进行多项选择。
isMultiSelectEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回 true 表示节点上的鼠标事件应该根据锚点作出选择。
isMultiSelectionEnabled() - 类 javax.swing.JFileChooser 中的方法
如果可以选择多个文件，则返回 true。
isMXBean() - 类 javax.management.MBeanServerInvocationHandler 中的方法
如果为 true，则该代理适用于 MXBean，并将适当映射应用于方法参数和返回值。
isMXBeanInterface(Class<?>) - 类 javax.management.JMX 中的静态方法
测试某接口是否是 MXBean 接口。
isName(CharSequence) - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回 name 是否是最新源版本中语法上有效的限定名称。
isNameCompatible(String, JavaFileObject.Kind) - 类 javax.tools.ForwardingJavaFileObject 中的方法
isNameCompatible(String, JavaFileObject.Kind) - 接口 javax.tools.JavaFileObject 中的方法
检查此文件对象是否与指定的简单名称和种类兼容。
isNameCompatible(String, JavaFileObject.Kind) - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现对其 URI 路径和给定简单名称进行比较。
isNamespace() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 Namespace 的实用工具函数。
isNamespaceAware() - 类 javax.xml.parsers.DocumentBuilder 中的方法
指示此解析器是否被配置为可识别名称空间。
isNamespaceAware() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成具有感知名称空间功能的解析器。
isNamespaceAware() - 类 javax.xml.parsers.SAXParser 中的方法
指示此解析器是否被配置为可识别名称空间。
isNamespaceAware() - 类 javax.xml.parsers.SAXParserFactory 中的方法
指示是否将工厂配置为生成具有感知名称空间功能的解析器。
isNamespaceDeclUris() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
如果将名称空间声明属性放置到名称空间中，则返回 true。
isNaN(double) - 类 java.lang.Double 中的静态方法
如果指定的数是一个 NaN 值，则返回 true；否则返回 false。
isNaN() - 类 java.lang.Double 中的方法
如果此 Double 值是非数字（NaN）值，则返回 true；否则返回 false。
isNaN(float) - 类 java.lang.Float 中的静态方法
如果指定的数是一个非数字 (NaN) 值，则返回 true，否则返回 false。
isNaN() - 类 java.lang.Float 中的方法
如果此 Float 值是一个非数字 (NaN) 值，则返回 true，否则返回 false。
isNative(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 native 修饰符，则返回 true，否则返回 false。
isNativeLookAndFeel() - 类 javax.swing.LookAndFeel 中的方法
如果底层平台具有“本机”外观，而且这是对它的一个实现，则返回 true。
isNativeLookAndFeel() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回 false；MetalLookAndFeel 不是本机外观。
isNativeLookAndFeel() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回 false；此外观对于任意平台而言不是本机的。
isNativeLookAndFeel() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回 false，SynthLookAndFeel 不是一个本机外观。
isNativeMethod() - 类 java.lang.StackTraceElement 中的方法
如果包含由该堆栈跟踪元素所表示的执行点的方法是一个本机方法，则返回 true。
isNativeMethodPrefixSupported() - 接口 java.lang.instrument.Instrumentation 中的方法
返回当前 JVM 配置是否支持设置本机方法前缀。
isNavigationKey(int) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回提供的 keyCode 是否映射到用于导航的键中。
isNegative() - 接口 java.security.acl.AclEntry 中的方法
如果此项是一个 negative ACL 项（关联的主体拒绝该项中的权限集合），则返回 true；否则返回 false。
isNested() - 枚举 javax.lang.model.element.NestingKind 中的方法
此常量是否对应于嵌套类型元素？嵌套 (nested) 类型元素是任何非顶层的元素。
isNil() - 类 javax.xml.bind.JAXBElement 中的方法
如果此元素实例内容模式为 nil，则返回 true。
isNodeAncestor(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果 anotherNode 是此节点的祖先 -- 如果它是此节点、此节点的父节点或此节点的父节点的祖先，则返回 true。
isNodeChild(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果 aNode 是此节点的子节点，则返回 true。
isNodeDescendant(DefaultMutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果 anotherNode 是此节点的后代 -- 如果它是此节点、此节点的一个子节点或此节点的一个子节点的后代，则返回 true。
isNodeRelated(DefaultMutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
当且仅当 aNode 位于与此节点相同的树中时，返回 true。
isNodeSibling(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果 anotherNode 是此节点的兄弟节点（与此节点共享同一父节点），则返回 true。
isNormalized(CharSequence, Normalizer.Form) - 类 java.text.Normalizer 中的静态方法
确定给定的 char 值序列是否被标准化。
isNotificationEnabled(Notification) - 类 javax.management.AttributeChangeNotificationFilter 中的方法
向侦听器发送指定的通知之前调用。
isNotificationEnabled(Notification) - 接口 javax.management.NotificationFilter 中的方法
向侦听器发送指定通知前调用。
isNotificationEnabled(Notification) - 类 javax.management.NotificationFilterSupport 中的方法
向侦听器发送指定的通知前调用。
isNotificationEnabled(Notification) - 类 javax.management.relation.MBeanServerNotificationFilter 中的方法
向侦听器发送指定通知之前调用。
isNotifyOnEDT() - 类 javax.swing.event.SwingPropertyChangeSupport 中的方法
返回 notifyOnEDT 属性。
isNullable(int) - 接口 java.sql.ParameterMetaData 中的方法
获取是否允许在指定参数中使用 null 值。
isNullable(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定列中的值是否可以为 null。
isNullable(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
获取指示是否可以在指定列中存储 NULL 值的常量。
ISO_2A0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS 2A0 (1189 x 1682 mm) 的 MediaType 实例。
ISO_4A0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS 4A0 ( 1682 x 2378 mm) 的 MediaType 实例。
ISO_A0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A0 (841 x 1189 mm) 的 MediaType 实例。
ISO_A0 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A0 尺寸。
ISO_A1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A1 (594 x 841 mm) 的 MediaType 实例。
ISO_A1 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A1 尺寸。
ISO_A10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A10 (26 x 37 mm) 的 MediaType 实例。
ISO_A10 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A10 尺寸。
ISO_A2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A2 (420 x 594 mm) 的 MediaType 实例。
ISO_A2 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A2 尺寸。
ISO_A3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A3 (297 x 420 mm) 的 MediaType 实例。
ISO_A3 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A3 尺寸。
ISO_A4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A4 (210 x 297 mm) 的 MediaType 实例。
ISO_A4 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A4 尺寸。
ISO_A4_TRANSPARENT - 类 javax.print.attribute.standard.MediaName 中的静态变量
A4 纸透明度。
ISO_A4_WHITE - 类 javax.print.attribute.standard.MediaName 中的静态变量
空白 A4 纸。
ISO_A5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A5 (148 x 210 mm) 的 MediaType 实例。
ISO_A5 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A5 尺寸。
ISO_A6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A6 (105 x 148 mm) 的 MediaType 实例。
ISO_A6 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A6 尺寸。
ISO_A7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A7 (74 x 105 mm) 的 MediaType 实例。
ISO_A7 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A7 尺寸。
ISO_A8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A8 (52 x 74 mm) 的 MediaType 实例。
ISO_A8 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A8 尺寸。
ISO_A9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN & JIS A9 (37 x 52 mm) 的 MediaType 实例。
ISO_A9 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
A9 尺寸。
ISO_B0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B0 (1000 x 1414 mm) 的 MediaType 实例。
ISO_B0 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B0 尺寸。
ISO_B1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B1 ( 707 x 1000 mm) 的 MediaType 实例。
ISO_B1 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B1 尺寸。
ISO_B10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B10 (31 x 44 mm) 的 MediaType 实例。
ISO_B10 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B10 尺寸。
ISO_B2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B2 (500 x 707 mm) 的 MediaType 实例。
ISO_B2 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B2 尺寸。
ISO_B3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B3 (353 x 500 mm) 的 MediaType 实例。
ISO_B3 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B3 尺寸。
ISO_B4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B4 (250 x 353 mm) 的 MediaType 实例。
ISO_B4 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B4 尺寸。
ISO_B4_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B4 的别名。
ISO_B5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B5 (176 x 250 mm) 的 MediaType 实例。
ISO_B5 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B5 尺寸。
ISO_B5_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_B5 的别名。
ISO_B6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B6 (125 x 176 mm) 的 MediaType 实例。
ISO_B6 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B6 尺寸。
ISO_B7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B7 (88 x 125 mm) 的 MediaType 实例。
ISO_B7 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B7 尺寸。
ISO_B8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B8 (62 x 88 mm) 的 MediaType 实例。
ISO_B8 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B8 尺寸。
ISO_B9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN B9 (44 x 62 mm) 的 MediaType 实例。
ISO_B9 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO B9 尺寸。
ISO_C0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C0 (917 x 1297 mm) 的 MediaType 实例。
ISO_C0 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C0 尺寸。
ISO_C0_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C0 的别名。
ISO_C1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C1 (648 x 917 mm) 的 MediaType 实例。
ISO_C1 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C1 尺寸。
ISO_C10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C10 (28 x 40 mm) 的 MediaType 实例。
ISO_C10_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C10 的别名。
ISO_C1_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C1 的别名。
ISO_C2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C2 (458 x 648 mm) 的 MediaType 实例。
ISO_C2 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C2 尺寸。
ISO_C2_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C2 的别名。
ISO_C3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C3 (324 x 458 mm) 的 MediaType 实例。
ISO_C3 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C3 尺寸。
ISO_C3_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C3 的别名。
ISO_C4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C4 (229 x 324 mm) 的 MediaType 实例。
ISO_C4 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C4 尺寸。
ISO_C4_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C4 的别名。
ISO_C5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C5 (162 x 229 mm) 的 MediaType 实例。
ISO_C5 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO C5 尺寸。
ISO_C5_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C5 的别名。
ISO_C6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C6 (114 x 162 mm) 的 MediaType 实例。
ISO_C6 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
信纸尺寸。
ISO_C6_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C6 的别名。
ISO_C7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C7 (81 x 114 mm) 的 MediaType 实例。
ISO_C7_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C7 的别名。
ISO_C8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C8 (57 x 81 mm) 的 MediaType 实例。
ISO_C8_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C8 的别名。
ISO_C9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO/DIN C9 (40 x 57 mm) 的 MediaType 实例。
ISO_C9_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_C9 的别名。
ISO_DESIGNATED_LONG - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO Designated Long (110 x 220 mm) 的 MediaType 实例。
ISO_DESIGNATED_LONG - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ISO designated long 尺寸。
ISO_DESIGNATED_LONG_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
ISO_DESIGNATED_LONG 的别名。
isObjectModelSupported(String) - 类 javax.xml.xpath.XPathFactory 中的方法
此 XPathFactory 是否支持指定的对象模型
isObjectMonitorUsageSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机是否支持使用对象监视器的监视。
isOldToken() - 类 org.ietf.jgss.MessageProp 中的方法
测试此标记是否还有效（即是否标记已经太陈旧而无法检查其复制情况）。
isOneTouchExpandable() - 类 javax.swing.JSplitPane 中的方法
获取 oneTouchExpandable 属性。
isOnKeyRelease() - 类 java.awt.AWTKeyStroke 中的方法
返回此 AWTKeyStroke 是否表示一个键释放操作。
isOpaque() - 类 java.awt.Component 中的方法
如果组件是完全不透明的，则返回 true，默认返回 false。
isOpaque() - 类 java.net.URI 中的方法
判断此 URI 是否为不透明的。
isOpaque() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
isOpaque() - 类 javax.swing.JComponent 中的方法
如果此组件是完全不透明的，则返回 true。
isOpaque() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 中的方法
isOpaque(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
如果 region 是不透明的，则返回 true。
isOpaque() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
isOpen() - 接口 java.nio.channels.Channel 中的方法
判断此通道是否处于打开状态。
isOpen() - 类 java.nio.channels.Selector 中的方法
告知此选择器是否已打开。
isOpen() - 类 java.nio.channels.spi.AbstractInterruptibleChannel 中的方法
isOpen() - 类 java.nio.channels.spi.AbstractSelector 中的方法
isOpen() - 接口 javax.sound.midi.MidiDevice 中的方法
报告设备是否为打开状态。
isOpen() - 接口 javax.sound.sampled.Line 中的方法
指示行是否已打开，行已打开则意味着它已保留系统资源并是可操作的，尽管它当前可能没有播放或捕获声音。
isOptimizedDrawingEnabled() - 类 javax.swing.JComponent 中的方法
如果此组件平铺显示其子组件（也就是说，它可以保证子组件不重叠），则返回 true。
isOptimizedDrawingEnabled() - 类 javax.swing.JLayeredPane 中的方法
如果窗格中的组件可以重叠，则返回 false（因为这会导致最优绘制无法进行）。
isOptimizedDrawingEnabled() - 类 javax.swing.JRootPane 中的方法
glassPane 和 contentPane 具有相同的边界，这意味着 JRootPane 并不对其子级平铺，应返回 false。
isOptimizedDrawingEnabled() - 类 javax.swing.JViewport 中的方法
JViewport 重写此方法（在 JComponent 中返回 false）的默认实现。
isOrdered() - 接口 javax.naming.directory.Attribute 中的方法
确定此属性的值是否是有序的。
isOrdered() - 类 javax.naming.directory.BasicAttribute 中的方法
isOutboundDone() - 类 javax.net.ssl.SSLEngine 中的方法
返回 SSLEngine.wrap(ByteBuffer, ByteBuffer) 是否再生成更多的出站数据报文。
isOutputLocation() - 接口 javax.tools.JavaFileManager.Location 中的方法
确定此位置是否为输出位置。
isOutputLocation() - 枚举 javax.tools.StandardLocation 中的方法
isOutputShutdown() - 类 java.net.Socket 中的方法
返回是否关闭套接字连接的半写状态 (write-half)。
isOverflow() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述溢出情况。
isOwner(Principal) - 接口 java.security.acl.Owner 中的方法
如果给定的主体是该 ACL 的所有者，则返回 true。
isOwnReader(ImageReader) - 类 javax.imageio.spi.ImageReaderSpi 中的方法
如果传入的 ImageReader 对象为与此服务提供者关联的 ImageReader 的实例，则返回 true。
isOwnWriter(ImageWriter) - 类 javax.imageio.spi.ImageWriterSpi 中的方法
如果传入的 ImageWriter 对象是与此服务提供者关联的 ImageWriter 的实例，则返回 true。
isPageFlipping() - 类 java.awt.BufferCapabilities 中的方法
isPaintable() - 接口 java.beans.PropertyEditor 中的方法
确定此属性编辑器是否是可绘制的。
isPaintable() - 类 java.beans.PropertyEditorSupport 中的方法
确定该类是否支持 paintValue 方法。
isPaintingForPrint() - 类 javax.swing.JComponent 中的方法
如果此组件上的当前绘制操作是 print 操作的一部分，则返回 true。
isPaintingTile() - 类 javax.swing.JComponent 中的方法
如果组件当前正在绘制 tile，则返回 true。
isPalette - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的变量
isParameter() - 类 javax.swing.text.html.parser.Entity 中的方法
如果为参数实体，则返回 true。
isParent(File, File) - 类 javax.swing.filechooser.FileSystemView 中的方法
在 Windows 中，一个文件可以出现在多个文件夹，但在文件系统中的父目录中除外。
isParityAdjusted(byte[], int) - 类 javax.crypto.spec.DESedeKeySpec 中的静态方法
确定给定的始于且包含 offset 的 DES-EDE 密钥是否是奇偶校验的 (parity-adjusted)。
isParityAdjusted(byte[], int) - 类 javax.crypto.spec.DESKeySpec 中的静态方法
确定给定的始于且包含 offset 的 DES 密钥内容是否是奇偶校验的 (parity-adjusted)。
isParseBigDecimal() - 类 java.text.DecimalFormat 中的方法
返回 DecimalFormat.parse(java.lang.String, java.text.ParsePosition) 方法是否返回 BigDecimal。
isParseIntegerOnly() - 类 java.text.NumberFormat 中的方法
如果此格式只将数作为整数解析，则返回 true。
isPartialReturn() - 类 javax.swing.text.Segment 中的方法
指示部分返回有效的标记。
isPathEditable(TreePath) - 类 javax.swing.JTree 中的方法
返回 isEditable。
isPathSelected(TreePath) - 类 javax.swing.JTree 中的方法
如果当前选择了路径标识的条目，则返回 true。
isPathSelected(TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果当前选择了路径 path，则返回 true。
isPathSelected(TreePath) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
如果路径 path 在当前的选择中，则返回 true。
isPattern() - 类 javax.management.ObjectName 中的方法
检查该对象名是否为一个模式。
isPeriodic() - 接口 java.util.concurrent.RunnableScheduledFuture 中的方法
如果这是一个定期任务，则返回 true。
isPlain() - 类 java.awt.Font 中的方法
指示此 Font 对象的样式是否为 PLAIN。
isPointToPoint() - 类 java.net.NetworkInterface 中的方法
返回网络接口是否是点对点接口。
isPolicyMappingInhibited() - 类 java.security.cert.PKIXParameters 中的方法
检查是否禁止策略映射。
isPolygonal() - 类 java.awt.geom.Area 中的方法
测试此 Area 是否完全由直边多边形组成。
isPoolable() - 接口 java.sql.Statement 中的方法
返回指示 Statement 是否是可池化的值。
isPopupMenuVisible() - 类 javax.swing.JMenu 中的方法
如果菜单的弹出窗口可见，则返回 true。
isPopupTrigger() - 类 java.awt.event.MouseEvent 中的方法
返回此鼠标事件是否为该平台的弹出菜单触发事件。
isPopupTrigger(MouseEvent) - 类 javax.swing.JPopupMenu 中的方法
如果 JPopupMenu 的当前安装 UI 将 MouseEvent 视为弹出菜单触发器，则返回 true。
isPopupTrigger(MouseEvent) - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
isPopupTrigger(MouseEvent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 isPopupTrigger 方法。
isPopupTrigger(MouseEvent) - 类 javax.swing.plaf.PopupMenuUI 中的方法
isPopupVisible() - 类 javax.swing.JComboBox 中的方法
确定弹出窗口的可见性。
isPopupVisible(JComboBox) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
告知弹出控件是否可见。
isPopupVisible(JComboBox) - 类 javax.swing.plaf.ComboBoxUI 中的方法
确定弹出窗口的可见性
isPopupVisible(JComboBox) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 isPopupVisible 方法。
isPostdated() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是延后的。
isPreferred() - 类 java.beans.FeatureDescriptor 中的方法
"preferred" 标志用于标识呈现给用户的特别重要的特性。
isPreferredSizeSet() - 类 java.awt.Component 中的方法
如果已将首选大小设置为非 null 值，则返回 true，否则返回 false。
isPreformatted() - 类 javax.swing.text.html.HTML.Tag 中的方法
如果此标记是预格式化的，则返回 true，即如果此标记是 PRE 或 TEXTAREA，则为 true。
isPreformatted() - 类 javax.swing.text.html.parser.TagElement 中的方法
isPressed() - 接口 javax.swing.ButtonModel 中的方法
指示按钮是否已被按下。
isPressed() - 类 javax.swing.DefaultButtonModel 中的方法
指示按钮是否已被按下。
isPrimitive() - 类 java.io.ObjectStreamField 中的方法
如果此字段为基本类型，则返回 true。
isPrimitive() - 类 java.lang.Class 中的方法
判定指定的 Class 对象是否表示一个基本类型。
isPrimitive() - 枚举 javax.lang.model.type.TypeKind 中的方法
如果此种类对应于某一基本类型，则返回 true，否则返回 false。
isPrimitiveArray() - 类 javax.management.openmbean.ArrayType 中的方法
如果此开放类型描述的开放数据值是基本类型数组，则返回 true；否则返回 false。
isPrivate(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 private 修饰符，则返回 true，否则返回 false。
isProbablePrime(int) - 类 java.math.BigInteger 中的方法
如果此 BigInteger 可能为素数，则返回 true，如果它一定为合数，则返回 false。
isProcessingInstruction() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 ProcessingInstruction 的实用工具函数。
isPropagated() - 类 java.beans.beancontext.BeanContextEvent 中的方法
报告此事件是否传播自某些其他 BeanContext。
isPropertyListPattern() - 类 javax.management.ObjectName 中的方法
检查对象名是否为一个键属性列表模式。
isPropertyPattern() - 类 javax.management.ObjectName 中的方法
检查对象名是否为一个键属性模式。
isPropertySupported(String) - 类 javax.xml.stream.XMLInputFactory 中的方法
查询此工厂支持的属性集合。
isPropertySupported(String) - 类 javax.xml.stream.XMLOutputFactory 中的方法
查询此工厂支持的属性集合。
isPropertyValuePattern() - 类 javax.management.ObjectName 中的方法
检查对象名是否为值部分至少有一个键属性的模式。
isPropertyValuePattern(String) - 类 javax.management.ObjectName 中的方法
检查键属性中与值关联的值是否为一个模式。
isProtected(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 protected 修饰符，则返回 true，否则返回 false。
isProtReady() - 接口 org.ietf.jgss.GSSContext 中的方法
确定上下文是否已为要在其上使用的 per message 准备就绪。
isProxiable() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是可代理的。
isProxy() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是代理票据。
isProxyClass(Class<?>) - 类 java.lang.reflect.Proxy 中的静态方法
当且仅当指定的类通过 getProxyClass 方法或 newProxyInstance 方法动态生成为代理类时，返回 true。
isPublic(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 public 修饰符，则返回 true，否则返回 false。
isPublished() - 类 javax.xml.ws.Endpoint 中的方法
如果端点已处于发布状态，则返回 true。
isQueued(Thread) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
如果给定线程当前已加入队列，则返回 true。
isQueued(Thread) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
如果给定线程的当前已加入队列，则返回 true。
isRandomAccessEasy(int) - 类 javax.imageio.ImageReader 中的方法
如果给定图像的存储格式不会给像素的随机访问带来内在妨碍，则返回 true。
isReachable(int) - 类 java.net.InetAddress 中的方法
测试是否可以达到该地址。
isReachable(NetworkInterface, int, int) - 类 java.net.InetAddress 中的方法
测试是否可以达到该地址。
isReadable() - 类 java.nio.channels.SelectionKey 中的方法
测试此键的通道是否已准备好进行读取。
isReadable() - 类 javax.management.MBeanAttributeInfo 中的方法
该属性的值是否可读。
isReadable() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
如果此 OpenMBeanAttributeInfo 实例描述的属性为可读的，则返回 true，否则返回 false。
isReadable() - 类 javax.management.relation.RoleInfo 中的方法
返回角色的读取访问模式（如果可读，则返回 true）。
isReadOnly() - 类 java.nio.Buffer 中的方法
告知此缓冲区是否为只读缓冲区。
isReadOnly() - 类 java.security.PermissionCollection 中的方法
如果此 PermissionCollection 对象被标记为只读，则返回 true。
isReadOnly() - 接口 java.sql.Connection 中的方法
查询此 Connection 对象是否处于只读模式。
isReadOnly() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否处于只读模式。
isReadOnly(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定的列是否明确不可写入。
isReadOnly() - 类 javax.imageio.metadata.IIOMetadata 中的方法
如果此对象不支持 mergeTree、setFromTree 和 reset 方法，则返回 true。
isReadOnly() - 类 javax.security.auth.Subject 中的方法
查询此 Subject 是否为只读的。
isReadOnly() - 类 javax.sql.rowset.BaseRowSet 中的方法
返回一个指示此 RowSet 对象是否为只读的 boolean 值。
isReadOnly() - 接口 javax.sql.RowSet 中的方法
获取此 RowSet 对象是否是只读的。
isReadOnly(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示指定的列是否一定不可写入，即只读。
isRecording() - 接口 javax.sound.midi.Sequencer 中的方法
指示 Sequencer 当前是否正在录制。
isRectangleContainingRectangle(Rectangle, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
如果 a 包含 b，则返回 true。
isRectangular() - 类 java.awt.geom.Area 中的方法
测试此 Area 的形状是否为矩形。
isRedefineClassesSupported() - 接口 java.lang.instrument.Instrumentation 中的方法
返回当前 JVM 配置是否支持类的重定义。
isRegistered() - 类 java.nio.channels.SelectableChannel 中的方法
判断此通道当前是否已向任何选择器注册。
isRegistered() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
isRegistered() - 类 java.nio.charset.Charset 中的方法
通知此 charset 是否已在 IANA Charset Registry 中注册。
isRegistered(ObjectName) - 接口 javax.management.MBeanServer 中的方法
isRegistered(ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。
isRegistered(ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
isRegistered(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
isRegistered(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
isRelation(ObjectName) - 类 javax.management.relation.RelationService 中的方法
如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。
isRelation(ObjectName) - 接口 javax.management.relation.RelationServiceMBean 中的方法
如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。
isRelationMBean(String) - 类 javax.management.relation.RelationService 中的方法
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
isRelationMBean(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
isRelative() - 类 javax.naming.NameClassPair 中的方法
确定此绑定的名称是否相对于目标上下文（由 list() 方法的第一个参数命名）。
isRemoved() - 类 java.util.prefs.AbstractPreferences 中的方法
当且仅当已经使用 AbstractPreferences.removeNode() 方法移除此节点（或其祖先）时才返回 true。
isRenewable() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
确定此票据是否是可更新的。
isRepeats() - 类 javax.swing.Timer 中的方法
如果 Timer 多次将一个动作事件发送到其侦听器，则返回 true（默认）。
isReplacing - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的变量
isRepresentationClassByteBuffer() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的表示形式类是 java.nio.ByteBuffer 还是其子类。
isRepresentationClassCharBuffer() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的表示形式类是 java.nio.CharBuffer 还是其子类。
isRepresentationClassInputStream() - 类 java.awt.datatransfer.DataFlavor 中的方法
DataFlavor 是否表示 java.io.InputStream？
isRepresentationClassReader() - 类 java.awt.datatransfer.DataFlavor 中的方法
返回此 DataFlavor 的表示形式类是 java.io.Reader 还是其子类。
isRepresentationClassRemote() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果表示形式类为 Remote，则返回 true。
isRepresentationClassSerializable() - 类 java.awt.datatransfer.DataFlavor 中的方法
如果表示形式类可序列化，则返回 true。
isRequestFocusEnabled() - 类 javax.swing.JComponent 中的方法
如果此 JComponent 应该获得焦点，则返回 true；否则返回 false。
isResizable() - 类 java.awt.Dialog 中的方法
指出此 dialog 是否可以由用户调整大小。
isResizable() - 类 java.awt.Frame 中的方法
指示此窗体是否可由用户调整大小。
isResizable() - 类 javax.swing.JInternalFrame 中的方法
返回是否可以通过某个用户操作调整 JInternalFrame 的大小。
isResizable - 类 javax.swing.table.TableColumn 中的变量
如果为 true，则允许用户调整列的大小；默认值为 true。
isRetransformClassesSupported() - 接口 java.lang.instrument.Instrumentation 中的方法
返回当前 JVM 配置是否支持类的重转换。
isRevocationEnabled() - 类 java.security.cert.PKIXParameters 中的方法
检查 RevocationEnabled 标志。
isRevoked(Certificate) - 类 java.security.cert.CRL 中的方法
检查给定的证书是否在此 CRL 中。
isRightMouseButton(MouseEvent) - 类 javax.swing.SwingUtilities 中的静态方法
如果鼠标事件指定右边鼠标按键，则返回 true。
isRightToLeft() - 类 java.text.Bidi 中的方法
如果该行都是从右到左的文本且基本方向也是从右到左，则返回 true。
isRoleStatus(int) - 类 javax.management.relation.RoleStatus 中的静态方法
如果给定值对应于已知角色状态，则返回 true；否则，返回 false。
isRollover() - 接口 javax.swing.ButtonModel 中的方法
指示鼠标是否在按钮上。
isRollover() - 类 javax.swing.DefaultButtonModel 中的方法
指示鼠标是否在按钮上。
isRollover() - 类 javax.swing.JToolBar 中的方法
返回 rollover 状态。
isRolloverBorders() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
返回一个标志，用于确定是否启用翻转按钮边框。
isRolloverEnabled() - 类 javax.swing.AbstractButton 中的方法
获取 rolloverEnabled 属性。
isRoot(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
确定给定文件是否是导航树中的根。
isRoot() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
如果此节点是树的根，则返回 true。
isRootPaneCheckingEnabled() - 类 javax.swing.JApplet 中的方法
返回是否将对 add 和 setLayout 的调用转发给 contentPane。
isRootPaneCheckingEnabled() - 类 javax.swing.JDialog 中的方法
返回是否将对 add 和 setLayout 的调用转发到 contentPane。
isRootPaneCheckingEnabled() - 类 javax.swing.JFrame 中的方法
返回是否将对 add 和 setLayout 的调用转发到 contentPane。
isRootPaneCheckingEnabled() - 类 javax.swing.JInternalFrame 中的方法
返回是否将对 add 和 setLayout 的调用转发到 contentPane。
isRootPaneCheckingEnabled() - 类 javax.swing.JWindow 中的方法
返回对 add 和 setLayout 的调用是否转发到 contentPane。
isRootVisible() - 类 javax.swing.JTree 中的方法
如果显示树的根节点，则返回 true。
isRootVisible() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
isRootVisible() - 类 javax.swing.tree.AbstractLayoutCache 中的方法
如果显示树的根节点，则返回 true。
isRowSelected(int) - 类 javax.swing.JTable 中的方法
如果指定的索引位于行的有效范围内，并且位于该索引的行被选定，则返回 true。
isRowSelected(int) - 类 javax.swing.JTree 中的方法
如果选择了行标识的节点，则返回 true。
isRowSelected(int) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果选择了由 row 标识的行，则返回 true。
isRowSelected(int) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
如果选择了由 row 标识的行，则返回 true。
isRunning() - 接口 javax.sound.midi.Sequencer 中的方法
指示 Sequencer 当前是否正在运行。
isRunning() - 接口 javax.sound.sampled.DataLine 中的方法
指示该行是否正在运行。
isRunning() - 类 javax.swing.Timer 中的方法
如果 Timer 正在运行，则返回 true。
isSameFile(FileObject, FileObject) - 类 javax.tools.ForwardingJavaFileManager 中的方法
isSameFile(FileObject, FileObject) - 接口 javax.tools.JavaFileManager 中的方法
比较两个文件对象，如果它们表示相同的底层对象，则返回 true。
isSameFile(FileObject, FileObject) - 接口 javax.tools.StandardJavaFileManager 中的方法
比较两个文件对象，如果它们表示相同的规范文件、zip 文件条目或者基于任何文件系统的容器中的条目，则返回 true。
isSameNode(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
isSameNode(Node) - 接口 org.w3c.dom.Node 中的方法
返回此节点是否是与给定节点相同的节点。
isSameRM(XAResource) - 接口 javax.transaction.xa.XAResource 中的方法
调用此方法，以确定目标对象表示的资源管理器实例是否与参数 xares 表示的资源管理器实例相同。
isSameType(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
测试两个 TypeMirror 对象是否表示同一类型。
isSchemaLanguageSupported(String) - 类 javax.xml.validation.SchemaFactory 中的方法
此 SchemaFactory 支持指定的模式吗？
isSealed() - 类 java.lang.Package 中的方法
如果此包是密封的，则返回 ture。
isSealed(URL) - 类 java.lang.Package 中的方法
如果此包对于指定的代码源 url 是密封的，则返回 ture。
isSearchable(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示是否可以在 where 子句中使用指定的列。
isSearchable(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示是否可以在 WHERE 子句中使用存储在指定列中的值。
isSeekForwardOnly() - 类 javax.imageio.ImageReader 中的方法
如果已经通过传递 true 作为 setInput 方法的 seekForwardOnly 参数将当前输入源标记为只向前搜索，则返回 true。
isSelected() - 类 java.awt.im.InputMethodHighlight 中的方法
返回是否已选定文本范围。
isSelected(int) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 isIndexSelected(int) 取代。
isSelected() - 类 javax.swing.AbstractButton 中的方法
返回按钮的状态。
isSelected(ButtonModel) - 类 javax.swing.ButtonGroup 中的方法
返回对是否已选择一个 ButtonModel 的判断。
isSelected() - 接口 javax.swing.ButtonModel 中的方法
指示按钮是否已经被选择。
isSelected() - 类 javax.swing.DefaultButtonModel 中的方法
指示按钮是否已经被选择。
isSelected() - 类 javax.swing.DefaultSingleSelectionModel 中的方法
isSelected - 类 javax.swing.JInternalFrame 中的变量
当前已选中窗体。
isSelected() - 类 javax.swing.JInternalFrame 中的方法
返回 JInternalFrame 当前是否为“选定的”或处于激活状态的窗体。
isSelected() - 类 javax.swing.JMenu 中的方法
如果菜单是当前选择的（即高亮显示的）菜单，则返回 true。
isSelected() - 类 javax.swing.JMenuBar 中的方法
如果当前已选择了菜单栏的组件，则返回 true。
isSelected() - 类 javax.swing.JToggleButton.ToggleButtonModel 中的方法
检查按钮是否是选定的。
isSelected - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的变量
isSelected() - 接口 javax.swing.SingleSelectionModel 中的方法
如果选项模型当前有一个选定的值，则返回 true。
isSelected() - 类 javax.swing.text.html.Option 中的方法
获取与此选项相关的选定状态。
isSelectedIndex(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
如果选择了指定的索引，则返回 true。
isSelectedIndex(int) - 类 javax.swing.JList 中的方法
如果选择了指定的索引，则返回 true；否则返回 false。
isSelectedIndex(int) - 接口 javax.swing.ListSelectionModel 中的方法
如果选择了指定的索引，则返回 true。
isSelectionEmpty() - 类 javax.swing.DefaultListSelectionModel 中的方法
如果没有选择索引，则返回 true。
isSelectionEmpty() - 类 javax.swing.JList 中的方法
如果什么也没有选择，则返回 true；否则返回 false。
isSelectionEmpty() - 类 javax.swing.JTree 中的方法
如果该选择当前为空，则返回 true。
isSelectionEmpty() - 接口 javax.swing.ListSelectionModel 中的方法
如果没有选择索引，则返回 true。
isSelectionEmpty() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
如果 selection 当前为空，则返回 true。
isSelectionEmpty() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
如果选择当前为空，则返回 true。
isSelectionVisible() - 接口 javax.swing.text.Caret 中的方法
确定选定项当前是否可见。
isSelectionVisible() - 类 javax.swing.text.DefaultCaret 中的方法
检查当前选定是否可见。
isSerializing() - 类 java.beans.beancontext.BeanContextSupport 中的方法
此 BeanContext 正处于序列化过程中吗？
isServiceClass(Class) - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的方法
检查此事件，以确定将被取消的服务是否属于某个特定类。
isSet - 类 java.util.Calendar 中的变量
通知是否设置了该日历某一指定日历字段的标志。
isSet(int) - 类 java.util.Calendar 中的方法
确定给定日历字段是否已经设置了一个值，其中包括因为调用 get 方法触发内部字段计算而导致已经设置该值的情况。
isSet(DatatypeConstants.Field) - 类 javax.xml.datatype.Duration 中的方法
检查是否设置了字段。
isShared() - 类 java.nio.channels.FileLock 中的方法
判断此锁定是否为共享的。
isShiftDown() - 类 java.awt.event.InputEvent 中的方法
返回 Shift 修饰符在此事件上是否为 down。
isShorterThan(Duration) - 类 javax.xml.datatype.Duration 中的方法
检查此持续时间对象是否严格短于另一个 Duration 对象。
isShowing() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
确定是否正在显示该对象。
isShowing() - 类 java.awt.Component 中的方法
确定此组件是否在屏幕上显示。
isShowing() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
确定是否正显示对象。
isShowing() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
确定该对象是否正在显示。
isShowing() - 类 java.awt.Window 中的方法
检查此窗口是否显示在屏幕上。
isShowing() - 接口 javax.accessibility.AccessibleComponent 中的方法
确定是否正显示对象。
isShowing() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
isShowing() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
确定该对象是否正在显示。
isShowing() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
isShowing() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
isShutdown() - 接口 java.util.concurrent.ExecutorService 中的方法
如果此执行程序已关闭，则返回 true。
isShutdown() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
isSigned(int) - 接口 java.sql.ParameterMetaData 中的方法
获取指定参数的值是否可以是带符号的数字。
isSigned(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示指定列中的值是否带正负号。
isSigned(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示存储在指定列中的值是否为有符号数。
isSignificant() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
DefaultDocument 事件是有意义的。
isSignificant() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
此默认实现返回 true。
isSignificant() - 类 javax.swing.undo.CompoundEdit 中的方法
如果 edits 中的任何 UndoableEdit 返回 true，则返回 true。
isSignificant() - 接口 javax.swing.undo.UndoableEdit 中的方法
如果认为此编辑有效，则返回 true。
isSingular() - 类 java.awt.geom.Area 中的方法
测试此 Area 是否由单个封闭子路径组成。
isSiteLocalAddress() - 类 java.net.Inet4Address 中的方法
检查 InetAddress 是否是站点本地地址的实用例行程序。
isSiteLocalAddress() - 类 java.net.Inet6Address 中的方法
检查 InetAddress 是否是站点本地地址的实用例行程序。
isSiteLocalAddress() - 类 java.net.InetAddress 中的方法
检查 InetAddress 是否是站点本地地址的实用例行程序。
isSortable(int) - 类 javax.swing.DefaultRowSorter 中的方法
如果指定的列可排序，则返回 true；否则返回 false。
isSorted() - 类 javax.naming.ldap.SortResponseControl 中的方法
确定是否已成功排序搜索结果。
isSoundbankSupported(Soundbank) - 接口 javax.sound.midi.Synthesizer 中的方法
通知调用者此合成器是否能够从指定的音库加载乐器。
isSource() - 类 javax.sound.sampled.Port.Info 中的方法
指示端口是其混频器的源还是目标。
isSourceEncodingSupported(AudioFormat.Encoding) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
指示格式转换器是否支持从指定源格式编码的转换。
isSpace(char) - 类 java.lang.Character 中的静态方法
已过时。 由 isWhitespace(char) 取代。
isSpaceChar(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为 Unicode 空白字符。
isSpaceChar(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为 Unicode 空白字符。
isSpecified() - 接口 javax.xml.stream.events.Attribute 中的方法
一个标志，用于指示此属性实际上是在其元素的开始标记中指定的，还是在模式中默认指定的。
isSpecified(int) - 类 javax.xml.validation.TypeInfoProvider 中的方法
如果属性是通过验证器添加的，则返回 false。
isSpecified(int) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 true，除非 DTD 默认提供属性值。
isSpecified(String, String) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 true，除非由 DTD 默认提供属性值。
isSpecified(String) - 接口 org.xml.sax.ext.Attributes2 中的方法
返回 true，除非由 DTD 默认提供属性值。
isSpecified(int) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“指定的”标志的当前值。
isSpecified(String, String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“指定的”标志的当前值。
isSpecified(String) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
返回属性的“指定的”标志的当前值。
isStandalone() - 接口 javax.xml.stream.events.StartDocument 中的方法
如果此 XML 是独立的，则返回 true。
isStandalone() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isStandalone() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取 xml 声明中的独立声明
isStandard() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个标准字形，则返回 true。
isStandardImageMetadataFormatSupported() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
如果标准元数据格式为此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的文档格式之一，则返回 true。
isStandardMetadataFormatSupported() - 类 javax.imageio.metadata.IIOMetadata 中的方法
如果 getMetadataFormat、getAsTree、setFromTree 和 mergeTree 支持标准元数据格式，则返回 true。
isStandardStreamMetadataFormatSupported() - 类 javax.imageio.spi.ImageReaderWriterSpi 中的方法
如果标准元数据格式是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法能够识别的文档格式之一，则返回 true。
isStartDocument() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 StartDocument 的实用工具函数。
isStartElement() - 接口 javax.xml.stream.events.XMLEvent 中的方法
检查此事件是否为 StartElement 的实用工具函数。
isStartElement() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isStartElement() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果光标指向开始标记，则返回 true（否则返回 false）
isStatic(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 static 修饰符，则返回 true，否则返回 false。
isStrict(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 strictfp 修饰符，则返回 true，否则返回 false。
isStrikeThrough() - 类 javax.swing.text.GlyphView 中的方法
确定字形是否应该有删除线。
isStrikeThrough() - 类 javax.swing.text.LabelView 中的方法
确定字形是否应该有删除线。
isStrikeThrough(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了删除线属性。
isStringPainted() - 类 javax.swing.JProgressBar 中的方法
返回 stringPainted 属性的值。
isSubregion() - 类 javax.swing.plaf.synth.Region 中的方法
如果 Region 是 Component 的子 region，则返回 true，否则返回 false。
isSubscript() - 类 javax.swing.text.GlyphView 中的方法
确定字形是否应该呈现为上标。
isSubscript() - 类 javax.swing.text.LabelView 中的方法
确定字形是否应该呈现为上标。
isSubscript(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了下标属性。
isSubsignature(ExecutableType, ExecutableType) - 接口 javax.lang.model.util.Types 中的方法
测试一个方法的签名是否是另一个方法的子签名。
isSubtype(TypeMirror, TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
测试一种类型是否是另一个类型的子类型。
isSuperscript() - 类 javax.swing.text.GlyphView 中的方法
确定字形是否应该呈现为下标。
isSuperscript() - 类 javax.swing.text.LabelView 中的方法
确定字形是否应该呈现为下标。
isSuperscript(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了上标属性。
isSupplementaryCodePoint(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否在增补字符范围内。
isSupported(Desktop.Action) - 类 java.awt.Desktop 中的方法
测试当前平台是否支持某一动作。
isSupported() - 类 java.awt.SystemTray 中的静态方法
返回当前平台是否支持系统托盘。
isSupported(String) - 类 java.nio.charset.Charset 中的静态方法
通知是否支持指定的 charset。
isSupported(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
返回 false，因为不支持 DOM 功能。
isSupported(String, String) - 接口 org.w3c.dom.Node 中的方法
测试 DOM 实现是否实现特定功能，且该功能是否受此节点支持，如下所述。
isSupportedLookAndFeel() - 类 javax.swing.LookAndFeel 中的方法
如果底层平台支持和/或允许此外观，则返回 true。
isSupportedLookAndFeel() - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
返回 true；可以在任意平台上运行 MetalLookAndFeel。
isSupportedLookAndFeel() - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的方法
返回 true；所有平台都允许此外观。
isSupportedLookAndFeel() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回 true，SynthLookAndFeel 总是受支持。
isSupportedOption(String) - 类 javax.tools.ForwardingJavaFileManager 中的方法
isSupportedOption(String) - 接口 javax.tools.OptionChecker 中的方法
确定是否支持给定选项，如果支持，则返回该选项所使用的参数数量。
isSurrogatePair(char, char) - 类 java.lang.Character 中的静态方法
确定指定的 char 值对是否为有效的代理项对。
isSuspended() - 类 java.lang.management.ThreadInfo 中的方法
测试与此 ThreadInfo 关联的线程是否被挂起。
isSynchronizationSupported(Line[], boolean) - 接口 javax.sound.sampled.Mixer 中的方法
报告此混频器是否支持指定行集合的同步。
isSynchronized(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 synchronized 修饰符，则返回 true，否则返回 false。
isSynchronizerUsageSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机是否支持使用 可拥有同步器的监视。
isSynthetic() - 类 java.lang.Class 中的方法
如果此类是复合类，则返回 true，否则 false。
isSynthetic() - 类 java.lang.reflect.Constructor 中的方法
如果此构造方法是一个复合构造方法，则返回 true；否则返回 false。
isSynthetic() - 类 java.lang.reflect.Field 中的方法
如果此字段是复合字段，则返回 true；否则返回 false。
isSynthetic() - 接口 java.lang.reflect.Member 中的方法
如果此成员是编译器引入的，则返回 true；否则，返回 false。
isSynthetic() - 类 java.lang.reflect.Method 中的方法
如果此方法为复合方法，则返回 true；否则，返回 false。
isTargetEncodingSupported(AudioFormat.Encoding) - 类 javax.sound.sampled.spi.FormatConversionProvider 中的方法
指示格式转换器是否支持到指定目标格式编码的转换。
isTearOff() - 类 java.awt.Menu 中的方法
指示此菜单是否为分离式菜单。
isTearOff() - 类 javax.swing.JMenu 中的方法
如果此菜单是分离式的，则返回 true。
isTemporary() - 类 java.awt.event.FocusEvent 中的方法
将焦点更改事件标识为暂时性的或持久性的。
isTerminated() - 接口 java.util.concurrent.ExecutorService 中的方法
如果关闭后所有任务都已完成，则返回 true。
isTerminated() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
isTerminating() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
如果此执行程序处于在 shutdown 或 shutdownNow 之后正在终止但尚未完全终止的过程中，则返回 true。
isText(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
如果元素是文本元素，则返回 true。
isThreadContentionMonitoringEnabled() - 接口 java.lang.management.ThreadMXBean 中的方法
测试是否启用了线程争用监视。
isThreadContentionMonitoringSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机是否支持线程争用监视。
isThreadCpuTimeEnabled() - 接口 java.lang.management.ThreadMXBean 中的方法
测试是否启用了线程 CPU 时间测量。
isThreadCpuTimeSupported() - 接口 java.lang.management.ThreadMXBean 中的方法
测试 Java 虚拟机实现是否支持任何线程的 CPU 时间测量。
isThumbRollover() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
如果鼠标当前位于 thumb 上，则返回 true。
isTileWritable(int, int) - 类 java.awt.image.BufferedImage 中的方法
返回当前是否为写入签出 tile。
isTileWritable(int, int) - 接口 java.awt.image.WritableRenderedImage 中的方法
返回当前是否正在为写入签出 tile。
isTimeSet - 类 java.util.Calendar 中的变量
如果 time 值是一个有效值，则返回 true。
isTitleCase(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为首字母大写字符。
isTitleCase(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为首字母大写字符。
isToggleEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回 true 指示应该基于事件切换鼠标下的行。
isToggleSelectionEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
返回 true 表示节点上的鼠标事件应该仅切换鼠标下的行的选择。
isTopDown() - 类 javax.imageio.plugins.bmp.BMPImageWriteParam 中的方法
返回 topDown 参数的值。
isTopLevelMenu() - 类 javax.swing.JMenu 中的方法
如果菜单是“顶层菜单”（即菜单栏的直接子级），则返回 true。
isTransferable() - 接口 org.ietf.jgss.GSSContext 中的方法
确定通过使用 export 方法，该上下文是否可以传输给其他进程。
isTransformed() - 类 java.awt.font.FontRenderContext 中的方法
指示此 FontRenderContext 对象是否需要考虑已转换的呈现上下文中的文本。
isTransformed() - 类 java.awt.Font 中的方法
指示此 Font 对象是否具有影响其大小以及 Size 属性的变换。
isTransient(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 transient 修饰符，则返回 true，否则返回 false。
isTraversable(File) - 类 javax.swing.filechooser.FileSystemView 中的方法
如果可以访问文件（目录），则返回 true。
isTraversable(File) - 类 javax.swing.filechooser.FileView 中的方法
目录是否是可遍历的。
isTraversable(File) - 类 javax.swing.JFileChooser 中的方法
如果可以返回该文件（目录），则返回 true。
IstringHelper - org.omg.CosNaming 中的 类
org/omg/CosNaming/IstringHelper.java。
IstringHelper() - 类 org.omg.CosNaming.IstringHelper 的构造方法
isTrueVolatile() - 类 java.awt.ImageCapabilities 中的方法
如果由此 ImageCapabilities 描述的 VolatileImage 可以丢失其图面，则返回 true。
isTypeSubstituted() - 类 javax.xml.bind.JAXBElement 中的方法
如果此 xml 元素实例的值的类型与 xml 元素声明的声明类型不同，则返回 true。
isUndecorated() - 类 java.awt.Dialog 中的方法
指出此 dialog 是否未装饰。
isUndecorated() - 类 java.awt.Frame 中的方法
指示此窗体是否未装饰。
isUnderflow() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述下溢情况。
isUnderline() - 类 javax.swing.text.GlyphView 中的方法
确定字形是否应加下划线。
isUnderline() - 类 javax.swing.text.LabelView 中的方法
确定字形是否应加下划线。
isUnderline(AttributeSet) - 类 javax.swing.text.StyleConstants 中的静态方法
确定是否设置了下划线属性。
isUnicast() - 类 java.beans.EventSetDescriptor 中的方法
通常事件源是多播的。
isUnicodeIdentifierPart(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否可以是 Unicode 标识符中首字符以外的部分。
isUnicodeIdentifierPart(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否可以是 Unicode 标识符中首字符以外的部分。
isUnicodeIdentifierStart(char) - 类 java.lang.Character 中的静态方法
确定是否允许将指定字符作为 Unicode 标识符中的首字符。
isUnicodeIdentifierStart(int) - 类 java.lang.Character 中的静态方法
确定是否允许将指定字符（Unicode 代码点）作为 Unicode 标识符中的首字符。
isUnique() - 类 java.rmi.dgc.VMID 中的静态方法
已过时。
isUnmappable() - 类 java.nio.charset.CoderResult 中的方法
通知此对象是否描述不可映射的字符错误。
isUnnamed() - 接口 javax.lang.model.element.PackageElement 中的方法
如果此包是一个未命名的包，则返回 true，否则返回 false。
isUnresolved() - 类 java.net.InetSocketAddress 中的方法
检查是否已解析地址。
isUnseqToken() - 类 org.ietf.jgss.MessageProp 中的方法
测试后面的标记是否已进行处理。
isUnshared() - 类 java.io.ObjectStreamField 中的方法
返回一个 boolean 值，指示由 ObjectStreamField 实例所表示的可序列化字段是否未共享。
isUp() - 类 java.net.NetworkInterface 中的方法
返回网络接口是否已经开启并运行。
isUpperCase(char) - 类 java.lang.Character 中的静态方法
确定指定字符是否为大写字母。
isUpperCase(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）是否为大写字母。
isUsageThresholdExceeded() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试此内存池的使用量是否达到或超过其使用量阈值。
isUsageThresholdSupported() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试此内存池是否支持使用量阈值。
isUserInRole(String) - 接口 javax.xml.ws.WebServiceContext 中的方法
返回一个布尔值，指示指定的逻辑角色中是否包含经过验证的用户。
isUserNode() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.isUserNode() 中的规范实现 isUserNode 方法。
isUserNode() - 类 java.util.prefs.Preferences 中的方法
如果此首选项节点位于用户首选项树中，则返回 true；如果其位于系统首选项树中，则返回 false。
isValid() - 类 java.awt.Component 中的方法
确定组件是否有效。
isValid(int) - 类 java.awt.image.IndexColorModel 中的方法
返回像素是否有效。
isValid() - 类 java.awt.image.IndexColorModel 中的方法
返回所有像素是否有效。
isValid() - 接口 java.lang.management.MemoryManagerMXBean 中的方法
测试此内存管理器在 Java 虚拟机中是否有效。
isValid() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
测试此内存池在 Java 虚拟机中是否有效。
isValid() - 类 java.nio.channels.FileLock 中的方法
判断此锁定是否有效。
isValid() - 类 java.nio.channels.SelectionKey 中的方法
告知此键是否有效。
isValid() - 类 java.nio.channels.spi.AbstractSelectionKey 中的方法
isValid(int) - 接口 java.sql.Connection 中的方法
如果连接尚未关闭并且仍然有效，则返回 true。
isValid() - 类 javax.accessibility.AccessibleHyperlink 中的方法
因为与某个链接相关联的文档可能已更改，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）的信息。
isValid() - 接口 javax.management.Descriptor 中的方法
如果所有字段在给定其名称的情况下都有合法值，则返回 true。
isValid() - 类 javax.management.ImmutableDescriptor 中的方法
如果所有字段在给定其名称的情况下都有合法值，则返回 true。
isValid() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
如果所有给定名称的字段都有合法值，则返回 true。
isValid() - 接口 javax.net.ssl.SSLSession 中的方法
返回此会话对于恢复和加入是否是有效的和可用的。
isValid() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 中的方法
因为与某个链接相关联的文档可能已改变，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）。
isValid() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
如果拖动会话有效，则返回 true。
isValid() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
指示当前迭代器是否正在表示出现的标记。
isValid() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
通过 getXMLSchemaType() 约束来验证实例。
isValidateRoot() - 类 javax.swing.JComponent 中的方法
如果此方法返回 true，则此组件的子代调用 revalidate 将导致从此根开始对整棵树进行验证。
isValidateRoot() - 类 javax.swing.JRootPane 中的方法
如果此 JRootPane 的一个后代调用 revalidate，将从此位置开始进行验证。
isValidateRoot() - 类 javax.swing.JScrollPane 中的方法
重写以返回 true，这样任何在此 JScrollPane 的任何后代上对 revalidate 的调用将使从此 JScrollPane 开始的整个树接受验证。
isValidateRoot() - 类 javax.swing.JSplitPane 中的方法
如果返回 true，则在此 JSplitPane 的任何后代上调用 revalidate，将导致在队列中加入一个验证 JSplitPane 及其所有后代的一个请求。
isValidateRoot() - 类 javax.swing.JTextField 中的方法
调用来自文本字段本身的 revalidate，将通过验证文本字段来处理，如果文本字段不包含在 JViewport 中，则在这种情况下将返回 false。
isValidating() - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
指示 Unmarshaller 是否被配置为在执行解组操作期间进行验证。
isValidating() - 接口 javax.xml.bind.Unmarshaller 中的方法
已过时。 从 JAXB 2.0 开始，请参阅 Unmarshaller.getSchema()
isValidating() - 类 javax.xml.parsers.DocumentBuilder 中的方法
指示此解析器是否被配置为验证 XML 文档。
isValidating() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指示是否将工厂配置为生成解析器，该解析器在解析时验证 XML 内容。
isValidating() - 类 javax.xml.parsers.SAXParser 中的方法
指示此解析器是否被配置为验证 XML 文档。
isValidating() - 类 javax.xml.parsers.SAXParserFactory 中的方法
指示是否将工厂配置为生成解析器，该解析器在解析时验证 XML 内容。
isValidCodePoint(int) - 类 java.lang.Character 中的静态方法
确定指定的代码点是否为从 0x0000 到 0x10FFFF 范围之内的有效 Unicode 代码点值。
isValue(Object) - 类 javax.management.openmbean.ArrayType 中的方法
测试 obj 是否为此 ArrayType 实例的值。
isValue(Object) - 类 javax.management.openmbean.CompositeType 中的方法
测试 obj 是否为此 CompositeType 实例可以描述的值。
isValue(Object) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
测试 obj 是否为此 OpenMBeanAttributeInfoSupport 实例描述的属性的有效值。
isValue(Object) - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。
isValue(Object) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。
isValue(Object) - 类 javax.management.openmbean.OpenType 中的方法
测试 obj 是否为此开放类型的值。
isValue(Object) - 类 javax.management.openmbean.SimpleType 中的方法
测试 obj 是否为此 SimpleType 实例的值。
isValue(Object) - 类 javax.management.openmbean.TabularType 中的方法
测试 obj 是否为此 TabularType 实例可以描述的值。
isVarArgs() - 类 java.lang.reflect.Constructor 中的方法
如果声明此构造方法可以带可变数量的参数，则返回 true；否则返回 false。
isVarArgs() - 类 java.lang.reflect.Method 中的方法
如果将此方法声明为带有可变数量的参数，则返回 true；否则，返回 false。
isVarArgs() - 接口 javax.lang.model.element.ExecutableElement 中的方法
如果此方法或构造方法接受可变数量的参数，则返回 true，否则返回 false。
isVerbose() - 接口 java.lang.management.ClassLoadingMXBean 中的方法
测试是否已为类加载系统启用了 verbose 输出。
isVerbose() - 接口 java.lang.management.MemoryMXBean 中的方法
测试内存系统的 verbose 输出是否已启用。
isVertical() - 类 java.awt.font.TextLayout 中的方法
如果此 TextLayout 是垂直的，则返回 true。
isViewSizeSet - 类 javax.swing.JViewport 中的变量
在确定视口的维数后为 true。
isVirtual() - 类 java.net.NetworkInterface 中的方法
返回此接口是否是虚拟接口（也称为子接口）。
isVisible() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
确定对象是否可见。
isVisible() - 类 java.awt.Component 中的方法
确定此组件在其父容器可见时是否应该可见。
isVisible() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
确定对象是否可见。
isVisible() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
确定该对象是否可见。
isVisible() - 类 java.awt.SplashScreen 中的方法
确定闪现屏幕是否可见。
isVisible() - 接口 javax.accessibility.AccessibleComponent 中的方法
确定此对象是否可见。
isVisible() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
isVisible() - 类 javax.swing.JPopupMenu 中的方法
如果弹出菜单可见（当前显示的），则返回 true。
isVisible() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
确定该对象是否可见。
isVisible() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
isVisible(TreePath) - 类 javax.swing.JTree 中的方法
如果当前可查看路径标识的值，则返回 true，这意味着该路径或者是根路径，或者它的所有父路径均被展开。
isVisible() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
如果弹出菜单可见（当前显示的），则返回 true。
isVisible() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
isVisible() - 接口 javax.swing.text.Caret 中的方法
确定插入符当前是否可见。
isVisible() - 类 javax.swing.text.DefaultCaret 中的方法
指示插入符当前是否可见。
isVisible() - 类 javax.swing.text.html.ParagraphView 中的方法
指示是否应显示此视图。
isVisible() - 类 javax.swing.text.View 中的方法
返回一个指示视图是否可视的 boolean 值。
isVolatile(int) - 类 java.lang.reflect.Modifier 中的静态方法
如果整数参数包括 volatile 修饰符，则返回 true，否则返回 false。
isWeak(byte[], int) - 类 javax.crypto.spec.DESKeySpec 中的静态方法
确定给定的 DES 密钥内容是否是全弱或者半弱的。
isWheelScrollingEnabled() - 类 java.awt.ScrollPane 中的方法
指示是否进行滚动来响应鼠标滚轮。
isWheelScrollingEnabled() - 类 javax.swing.JScrollPane 中的方法
指示是否进行滚动以响应鼠标滚轮。
isWhitespace() - 类 java.awt.font.GlyphMetrics 中的方法
如果这是一个空白字形，则返回 true。
isWhitespace(char) - 类 java.lang.Character 中的静态方法
确定指定字符依据 Java 标准是否为空白字符。
isWhitespace(int) - 类 java.lang.Character 中的静态方法
确定指定字符（Unicode 代码点）依据 Java 标准是否为空白字符。
isWhiteSpace(char) - 类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 中的静态方法
如果指定的 char 是空白字符，则返回 true。
isWhiteSpace() - 接口 javax.xml.stream.events.Characters 中的方法
如果此 Characters 集合中都是空格，则返回 true。
isWhiteSpace() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
isWhiteSpace() - 接口 javax.xml.stream.XMLStreamReader 中的方法
如果光标指向由所有空格组成的字符数据事件，则返回 true
isWhiteSpaceExceptSpace(char) - 类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 中的静态方法
如果指定的 char 是空白字符但不是 0x20，则返回 true。
isWrapperFor(Class<?>) - 接口 java.sql.Wrapper 中的方法
如果调用此方法的对象实现接口参数，或者是实现接口参数的对象的直接或间接包装器，则返回 true。
isWrapperFor(Class<?>) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
如果调用者实现接口参数或者是实现接口参数的对象的直接或间接包装器，则返回 true。
isWritable() - 类 java.nio.channels.SelectionKey 中的方法
测试此键的通道是否已准备好进行写入。
isWritable(int) - 接口 java.sql.ResultSetMetaData 中的方法
指示在指定的列上进行写操作是否可以获得成功。
isWritable() - 类 javax.management.MBeanAttributeInfo 中的方法
是否可将新值写入该属性。
isWritable() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
如果此 OpenMBeanAttributeInfo 实例描述的属性是可写的，则返回 true，否则返回 false。
isWritable() - 类 javax.management.relation.RoleInfo 中的方法
返回角色的写入访问模式（如果可写，则返回 true）。
isWritable(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
指示在指定的列上进行写操作是否可以获得成功。
isWriteLocked() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询是否某个线程保持了写入锁。
isWriteLockedByCurrentThread() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
查询当前线程是否保持了写入锁。
isXIncludeAware() - 类 javax.xml.parsers.DocumentBuilder 中的方法
获取此解析器的 XInclude 处理模式。
isXIncludeAware() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
获取 XInclude 处理的状态。
isXIncludeAware() - 类 javax.xml.parsers.SAXParser 中的方法
获取此解析器的 XInclude 处理模式。
isXIncludeAware() - 类 javax.xml.parsers.SAXParserFactory 中的方法
获取 XInclude 处理的状态。
isXOPPackage() - 类 javax.xml.bind.attachment.AttachmentMarshaller 中的方法
只读属性，如果 JAXB 编组器应该启用 XOP 创建，则返回 true。
isXOPPackage() - 类 javax.xml.bind.attachment.AttachmentUnmarshaller 中的方法
只读属性，如果 JAXB 解组程序需要执行 XOP 处理，则返回 true。
isZoneLoaded(View) - 类 javax.swing.text.ZoneView 中的方法
确定某个分区是否处于加载状态。
ITALIAN - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
ITALIC - 类 java.awt.Font 中的静态变量
斜体样式常量。
Italic - 类 javax.swing.text.StyleConstants 中的静态变量
斜体属性的名称。
ITALIC_ACTION - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
斜体动作标识符
ITALY - 类 java.awt.PageAttributes.MediaType 中的静态变量
ITALY_ENVELOPE 的别名。
ITALY - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
ITALY_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Italy Envelope (110 x 230 mm) 的 MediaType 实例。
ITALY_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Italy 信封尺寸，110 mm × 230 mm。
ITALY_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
Italy 信封尺寸。
item(int) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
item(int) - 类 org.omg.CORBA.ContextList 中的方法
返回位于给定索引的 String 对象。
item(int) - 类 org.omg.CORBA.ExceptionList 中的方法
返回给定索引处的 TypeCode 对象。
item(int) - 类 org.omg.CORBA.NVList 中的方法
检索给定索引处的 NamedValue 对象。
item(int) - 接口 org.w3c.dom.DOMImplementationList 中的方法
返回集合中的第 index 个项。
item(int) - 接口 org.w3c.dom.DOMStringList 中的方法
返回集合中的第 index 个项。
item(int) - 接口 org.w3c.dom.NamedNodeMap 中的方法
返回映射中第 index 个项。
item(int) - 接口 org.w3c.dom.NodeList 中的方法
返回集合中的第 index 个项。
ITEM_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择项事件的事件掩码。
ITEM_FIRST - 类 java.awt.event.ItemEvent 中的静态变量
项事件使用的 id 范围内的起始编号。
ITEM_LAST - 类 java.awt.event.ItemEvent 中的静态变量
项事件使用的 id 范围内的结束编号。
ITEM_STATE_CHANGED - 类 java.awt.event.ItemEvent 中的静态变量
此事件 id 指示项状态已更改。
ItemEvent - java.awt.event 中的 类
指示项被选定或取消选定的语义事件。
ItemEvent(ItemSelectable, int, Object, int) - 类 java.awt.event.ItemEvent 的构造方法
构造一个 ItemEvent 对象。
ItemListener - java.awt.event 中的 接口
接收项事件的侦听器接口。
itemListener - 类 javax.swing.AbstractButton 中的变量
按钮模型的 ItemListener。
itemListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
itemListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
ItemSelectable - java.awt 中的 接口
包含零个或多个可选则项的集合的对象接口。
itemStateChanged(ItemEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 itemStateChanged 方法处理 itemStateChanged 事件。
itemStateChanged(ItemEvent) - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
当切换按钮的状态变化时，激发可访问的属性更改事件。
itemStateChanged(ItemEvent) - 接口 java.awt.event.ItemListener 中的方法
在用户已选定或取消选定某项时调用。
itemStateChanged(ItemEvent) - 类 java.awt.List.AccessibleAWTList 中的方法
itemStateChanged(ItemEvent) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
在项的状态发生更改时，编辑被终止。
itemStateChanged(ItemEvent) - 类 javax.swing.JToggleButton.AccessibleJToggleButton 中的方法
当切换按钮的状态变化时，激发可访问的属性变更事件。
itemStateChanged(ItemEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler 中的方法
itemStateChanged(ItemEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ItemHandler 中的方法
Iterable<T> - java.lang 中的 接口
实现这个接口允许对象成为 "foreach" 语句的目标。
iterator() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回组成动作的事件 Iterator。
iterator() - 类 java.beans.beancontext.BeanContextMembershipEvent 中的方法
获得受此事件影响的子级的数组。
iterator() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。
iterator() - 接口 java.lang.Iterable 中的方法
返回一个在一组 T 类型的元素上进行迭代的迭代器。
iterator() - 异常 java.sql.SQLException 中的方法
返回在链接的 SQLExceptions 上进行迭代的迭代器。
iterator() - 类 java.util.AbstractCollection 中的方法
返回在此 collection 中的元素上进行迭代的迭代器。
iterator() - 类 java.util.AbstractList 中的方法
返回以恰当顺序在此列表的元素上进行迭代的迭代器。
iterator() - 类 java.util.AbstractSequentialList 中的方法
返回在此列表中的元素上进行迭代的迭代器（按适当顺序）。
iterator() - 类 java.util.ArrayDeque 中的方法
返回在此双端队列的元素上进行迭代的迭代器。
iterator() - 接口 java.util.Collection 中的方法
返回在此 collection 的元素上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回在此队列中的元素上按适当顺序进行迭代的迭代器。
iterator() - 接口 java.util.concurrent.BlockingDeque 中的方法
返回在此双端队列中的元素上以恰当顺序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
返回在此队列元素上以恰当顺序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回在此 set 的元素上以升序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回以恰当顺序在此列表元素上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
返回按照元素添加顺序在此 set 中包含的元素上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.DelayQueue 中的方法
返回在此队列所有元素（既包括到期的，也包括未到期的）上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回在此双端队列元素上以恰当顺序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回在队列中的元素上按适当顺序进行迭代的迭代器。
iterator() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
返回在此队列元素上进行迭代的迭代器。
iterator() - 类 java.util.concurrent.SynchronousQueue 中的方法
返回一个空迭代器，其中 hasNext 始终返回 false。
iterator() - 接口 java.util.Deque 中的方法
返回以恰当顺序在此双端队列的元素上进行迭代的迭代器。
iterator() - 类 java.util.HashSet 中的方法
返回对此 set 中元素进行迭代的迭代器。
Iterator<E> - java.util 中的 接口
对 collection 进行迭代的迭代器。
iterator() - 接口 java.util.List 中的方法
返回按适当顺序在列表的元素上进行迭代的迭代器。
iterator() - 接口 java.util.NavigableSet 中的方法
以升序返回在此 set 的元素上进行迭代的迭代器。
iterator() - 类 java.util.PriorityQueue 中的方法
返回在此队列中的元素上进行迭代的迭代器。
iterator() - 类 java.util.ServiceLoader 中的方法
以延迟方式加载此加载器服务的可用提供者。
iterator() - 接口 java.util.Set 中的方法
返回在此 set 中的元素上进行迭代的迭代器。
iterator() - 类 java.util.TreeSet 中的方法
返回在此 set 中的元素上按升序进行迭代的迭代器。
iterator() - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
返回可在此 DOMCryptoContext 的 Id/Element 映射集上进行迭代的只读迭代器。
iterator() - 接口 javax.xml.crypto.NodeSetData 中的方法
返回可按照文档顺序在此 NodeSetData 中包含的节点上进行迭代的只读迭代器。
IvParameterSpec - javax.crypto.spec 中的 类
此类指定一个初始化向量 (IV)。
IvParameterSpec(byte[]) - 类 javax.crypto.spec.IvParameterSpec 的构造方法
使用 iv 中的字节作为 IV 来构造一个 IvParameterSpec 对象。
IvParameterSpec(byte[], int, int) - 类 javax.crypto.spec.IvParameterSpec 的构造方法
使用 iv 中始于且包含 offset 的前 len 个字节作为 IV 来构造一个 IvParameterSpec 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


J - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

J

JANUARY - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第一个月的 Calendar.MONTH 字段值。
JANUARY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第一个月的值。
JAPAN - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
JAPANESE - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
JAPANESE_DOUBLE_POSTCARD - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Japanese Double 明信片尺寸，148 mm × 200 mm。
JAPANESE_DOUBLE_POSTCARD - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
Japanese Double Postcard 尺寸。
JAPANESE_POSTCARD - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Japanese 明信片尺寸，100 mm × 148 mm。
JAPANESE_POSTCARD - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
Japanese Postcard 尺寸。
JApplet - javax.swing 中的 类
java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
JApplet() - 类 javax.swing.JApplet 的构造方法
创建一个 swing applet 实例。
JApplet.AccessibleJApplet - javax.swing 中的 类
此类实现对 JApplet 类的可访问性支持。
JApplet.AccessibleJApplet() - 类 javax.swing.JApplet.AccessibleJApplet 的构造方法
JarEntry - java.util.jar 中的 类
此类用于表示 JAR 文件条目。
JarEntry(String) - 类 java.util.jar.JarEntry 的构造方法
为指定的 JAR 文件条目名称创建新的 JarEntry。
JarEntry(ZipEntry) - 类 java.util.jar.JarEntry 的构造方法
使用从指定 ZipEntry 对象获取的字段创建新的 JarEntry。
JarEntry(JarEntry) - 类 java.util.jar.JarEntry 的构造方法
使用从指定的 JarEntry 对象获取的字段创建新的 JarEntry。
JarException - java.util.jar 中的 异常
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。
JarException() - 异常 java.util.jar.JarException 的构造方法
构造不带详细消息的 JarException。
JarException(String) - 异常 java.util.jar.JarException 的构造方法
构造带指定详细消息的 JarException。
JarFile - java.util.jar 中的 类
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。
JarFile(String) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的文件 name 读取的新的 JarFile。
JarFile(String, boolean) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的文件 name 读取的新的 JarFile。
JarFile(File) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File, boolean) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File, boolean, int) - 类 java.util.jar.JarFile 的构造方法
创建一个要从指定的 File 对象中以指定模式读取的新的 JarFile。
jarFileURLConnection - 类 java.net.JarURLConnection 中的变量
到 JAR 文件 URL 的连接，如果已启动连接。
JarInputStream - java.util.jar 中的 类
JarInputStream 类用于从任何输入流读取 JAR 文件内容。
JarInputStream(InputStream) - 类 java.util.jar.JarInputStream 的构造方法
创建新的 JarInputStream 并读取可选的清单。
JarInputStream(InputStream, boolean) - 类 java.util.jar.JarInputStream 的构造方法
创建新的 JarInputStream 并读取可选的清单。
JarOutputStream - java.util.jar 中的 类
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。
JarOutputStream(OutputStream, Manifest) - 类 java.util.jar.JarOutputStream 的构造方法
使用指定的 Manifest 创建新的 JarOutputStream。
JarOutputStream(OutputStream) - 类 java.util.jar.JarOutputStream 的构造方法
创建不带清单的新的 JarOutputStream。
JarURLConnection - java.net 中的 类
连接到 Java ARchive (JAR) 文件或 JAR 文件中条目的 URL Connection。
JarURLConnection(URL) - 类 java.net.JarURLConnection 的构造方法
创建到指定 URL 的新 JarURLConnection。
java.applet - 软件包 java.applet
提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt - 软件包 java.awt
包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color - 软件包 java.awt.color
提供用于颜色空间的类。
java.awt.datatransfer - 软件包 java.awt.datatransfer
提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd - 软件包 java.awt.dnd
Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event - 软件包 java.awt.event
提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font - 软件包 java.awt.font
提供与字体相关的类和接口。
java.awt.geom - 软件包 java.awt.geom
提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im - 软件包 java.awt.im
提供输入方法框架所需的类和接口。
java.awt.im.spi - 软件包 java.awt.im.spi
提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image - 软件包 java.awt.image
提供创建和修改图像的各种类。
java.awt.image.renderable - 软件包 java.awt.image.renderable
提供用于生成与呈现无关的图像的类和接口。
java.awt.print - 软件包 java.awt.print
为通用的打印 API 提供类和接口。
java.beans - 软件包 java.beans
包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext - 软件包 java.beans.beancontext
提供与 bean 上下文有关的类和接口。
java.io - 软件包 java.io
通过数据流、序列化和文件系统提供系统输入和输出。
java.lang - 软件包 java.lang
提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation - 软件包 java.lang.annotation
为 Java 编程语言注释设施提供库支持。
java.lang.instrument - 软件包 java.lang.instrument
提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management - 软件包 java.lang.management
提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.ref - 软件包 java.lang.ref
提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。
java.lang.reflect - 软件包 java.lang.reflect
提供类和接口，以获得关于类和对象的反射信息。
java.math - 软件包 java.math
提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net - 软件包 java.net
为实现网络应用程序提供类。
java.nio - 软件包 java.nio
定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels - 软件包 java.nio.channels
定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi - 软件包 java.nio.channels.spi
用于 java.nio.channels 包的服务提供者类。
java.nio.charset - 软件包 java.nio.charset
定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.nio.charset.spi - 软件包 java.nio.charset.spi
java.nio.charset 包的服务提供者类。
java.rmi - 软件包 java.rmi
提供 RMI 包。
java.rmi.activation - 软件包 java.rmi.activation
为 RMI 对象激活提供支持。
java.rmi.dgc - 软件包 java.rmi.dgc
为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry - 软件包 java.rmi.registry
提供 RMI 注册表的一个类和两个接口。
java.rmi.server - 软件包 java.rmi.server
提供支持服务器端 RMI 的类和接口。
java.security - 软件包 java.security
为安全框架提供类和接口。
java.security.acl - 软件包 java.security.acl
此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert - 软件包 java.security.cert
提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces - 软件包 java.security.interfaces
提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec - 软件包 java.security.spec
提供密钥规范和算法参数规范的类和接口。
java.sql - 软件包 java.sql
提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text - 软件包 java.text
提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi - 软件包 java.text.spi
java.text 包中类的服务提供者类。
java.util - 软件包 java.util
包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent - 软件包 java.util.concurrent
在并发编程中很常用的实用工具类。
java.util.concurrent.atomic - 软件包 java.util.concurrent.atomic
类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.concurrent.locks - 软件包 java.util.concurrent.locks
为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar - 软件包 java.util.jar
提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging - 软件包 java.util.logging
提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs - 软件包 java.util.prefs
此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex - 软件包 java.util.regex
用于匹配字符序列与正则表达式指定模式的类。
java.util.spi - 软件包 java.util.spi
java.util 包中类的服务提供者类。
java.util.zip - 软件包 java.util.zip
提供用于读写标准 ZIP 和 GZIP 文件格式的类。
JAVA_OBJECT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 JAVA_OBJECT 的 Java 编程语言中的常量（有时称为类型代码）。
JavaCompiler - javax.tools 中的 接口
从程序中调用 Java™ 编程语言编译器的接口。
JavaCompiler.CompilationTask - javax.tools 中的 接口
表示编译任务的 future 的接口。
javaFileListFlavor - 类 java.awt.datatransfer.DataFlavor 中的静态变量
要将文件列表传入 Java（及底层平台）或从中传出，需要使用此类型/子类型的 DataFlavor 和 java.util.List 的表示形式类。
JavaFileManager - javax.tools 中的 接口
在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
JavaFileManager.Location - javax.tools 中的 接口
文件对象位置的接口。
JavaFileObject - javax.tools 中的 接口
在 Java™ 编程语言源和类文件上进行操作的工具的文件抽象。
JavaFileObject.Kind - javax.tools 中的 枚举
JavaFileObject 的种类。
javaJVMLocalObjectMimeType - 类 java.awt.datatransfer.DataFlavor 中的静态变量
要将一个引用传输到不具有关联 MIME Content 类型的任意 Java 对象引用（跨越同一 JVM 中的 Transferable 接口），需要使用具有此类型/子类型的 DataFlavor，其中 representationClass 等于跨越 Transferable 传递的类/接口的类型。
javaRemoteObjectMimeType - 类 java.awt.datatransfer.DataFlavor 中的静态变量
为了通过拖放 ACTION_LINK 操作将活动链接传递到 Remote 对象，应该使用 Mime Content 类型的 application/x-java-remote-object，其中 DataFlavor 的表示形式类表示要传输的 Remote 接口的类型。
javaSerializedObjectMimeType - 类 java.awt.datatransfer.DataFlavor 中的静态变量
MIME Content 类型的 application/x-java-serialized-object 表示已变得持久的 Java 对象的图形。
javax.accessibility - 软件包 javax.accessibility
定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation - 软件包 javax.activation
javax.activity - 软件包 javax.activity
包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation - 软件包 javax.annotation
javax.annotation.processing - 软件包 javax.annotation.processing
用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto - 软件包 javax.crypto
为加密操作提供类和接口。
javax.crypto.interfaces - 软件包 javax.crypto.interfaces
根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec - 软件包 javax.crypto.spec
为密钥规范和算法参数规范提供类和接口。
javax.imageio - 软件包 javax.imageio
Java Image I/O API 的主要包。
javax.imageio.event - 软件包 javax.imageio.event
Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.metadata - 软件包 javax.imageio.metadata
用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.plugins.bmp - 软件包 javax.imageio.plugins.bmp
包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg - 软件包 javax.imageio.plugins.jpeg
支持内置 JPEG 插件的类。
javax.imageio.spi - 软件包 javax.imageio.spi
包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream - 软件包 javax.imageio.stream
Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.jws - 软件包 javax.jws
javax.jws.soap - 软件包 javax.jws.soap
javax.lang.model - 软件包 javax.lang.model
用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element - 软件包 javax.lang.model.element
用于 Java 编程语言的模型元素的接口。
javax.lang.model.type - 软件包 javax.lang.model.type
用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util - 软件包 javax.lang.model.util
用来帮助处理程序元素和类型的实用工具。
javax.management - 软件包 javax.management
提供 Java Management Extensions 的核心类。
javax.management.loading - 软件包 javax.management.loading
提供实现高级动态加载的类。
javax.management.modelmbean - 软件包 javax.management.modelmbean
提供了 ModelMBean 类的定义。
javax.management.monitor - 软件包 javax.management.monitor
提供 monitor 类的定义。
javax.management.openmbean - 软件包 javax.management.openmbean
提供开放数据类型和 Open MBean 描述符类。
javax.management.relation - 软件包 javax.management.relation
提供 Relation Service 的定义。
javax.management.remote - 软件包 javax.management.remote
对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi - 软件包 javax.management.remote.rmi
RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer - 软件包 javax.management.timer
提供对 Timer MBean（计时器 MBean）的定义。
javax.naming - 软件包 javax.naming
为访问命名服务提供类和接口。
javax.naming.directory - 软件包 javax.naming.directory
扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event - 软件包 javax.naming.event
在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap - 软件包 javax.naming.ldap
提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi - 软件包 javax.naming.spi
提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net - 软件包 javax.net
提供用于网络应用程序的类。
javax.net.ssl - 软件包 javax.net.ssl
提供用于安全套接字包的类。
javax.print - 软件包 javax.print
为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute - 软件包 javax.print.attribute
提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard - 软件包 javax.print.attribute.standard
包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event - 软件包 javax.print.event
包 javax.print.event 包含事件类和侦听器接口。
javax.rmi - 软件包 javax.rmi
包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA - 软件包 javax.rmi.CORBA
包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl - 软件包 javax.rmi.ssl
通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.script - 软件包 javax.script
脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth - 软件包 javax.security.auth
此包提供用于进行验证和授权的框架。
javax.security.auth.callback - 软件包 javax.security.auth.callback
此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.kerberos - 软件包 javax.security.auth.kerberos
此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login - 软件包 javax.security.auth.login
此包提供可插入的验证框架。
javax.security.auth.spi - 软件包 javax.security.auth.spi
此包提供用于实现可插入验证模块的接口。
javax.security.auth.x500 - 软件包 javax.security.auth.x500
此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert - 软件包 javax.security.cert
为公钥证书提供类。
javax.security.sasl - 软件包 javax.security.sasl
包含用于支持 SASL 的类和接口。
javax.sound.midi - 软件包 javax.sound.midi
提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi - 软件包 javax.sound.midi.spi
在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled - 软件包 javax.sound.sampled
提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi - 软件包 javax.sound.sampled.spi
在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql - 软件包 javax.sql
为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset - 软件包 javax.sql.rowset
JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial - 软件包 javax.sql.rowset.serial
提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi - 软件包 javax.sql.rowset.spi
第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing - 软件包 javax.swing
提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border - 软件包 javax.swing.border
提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser - 软件包 javax.swing.colorchooser
包含供 JColorChooser 组件使用的类和接口。
javax.swing.event - 软件包 javax.swing.event
供 Swing 组件触发的事件使用。
javax.swing.filechooser - 软件包 javax.swing.filechooser
包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf - 软件包 javax.swing.plaf
提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic - 软件包 javax.swing.plaf.basic
提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal - 软件包 javax.swing.plaf.metal
提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi - 软件包 javax.swing.plaf.multi
提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth - 软件包 javax.swing.plaf.synth
Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table - 软件包 javax.swing.table
提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text - 软件包 javax.swing.text
提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html - 软件包 javax.swing.text.html
提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser - 软件包 javax.swing.text.html.parser
提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf - 软件包 javax.swing.text.rtf
提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree - 软件包 javax.swing.tree
提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo - 软件包 javax.swing.undo
允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.tools - 软件包 javax.tools
为能够从程序（例如，编译器）中调用的工具提供接口。
javax.transaction - 软件包 javax.transaction
包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa - 软件包 javax.transaction.xa
提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml - 软件包 javax.xml
根据 XML 规范定义核心 XML 常量和功能。
javax.xml.bind - 软件包 javax.xml.bind
为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation - 软件包 javax.xml.bind.annotation
定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters - 软件包 javax.xml.bind.annotation.adapters
XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.bind.attachment - 软件包 javax.xml.bind.attachment
此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。
javax.xml.bind.helpers - 软件包 javax.xml.bind.helpers
仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util - 软件包 javax.xml.bind.util
有用的客户端实用工具类。
javax.xml.crypto - 软件包 javax.xml.crypto
用于 XML 加密的通用类。
javax.xml.crypto.dom - 软件包 javax.xml.crypto.dom
javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig - 软件包 javax.xml.crypto.dsig
用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom - 软件包 javax.xml.crypto.dsig.dom
javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.crypto.dsig.keyinfo - 软件包 javax.xml.crypto.dsig.keyinfo
用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec - 软件包 javax.xml.crypto.dsig.spec
XML 数字签名的参数类。
javax.xml.datatype - 软件包 javax.xml.datatype
XML/Java 类型映射关系。
javax.xml.namespace - 软件包 javax.xml.namespace
XML 名称空间处理。
javax.xml.parsers - 软件包 javax.xml.parsers
提供允许处理 XML 文档的类。
javax.xml.soap - 软件包 javax.xml.soap
提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream - 软件包 javax.xml.stream
javax.xml.stream.events - 软件包 javax.xml.stream.events
javax.xml.stream.util - 软件包 javax.xml.stream.util
javax.xml.transform - 软件包 javax.xml.transform
此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom - 软件包 javax.xml.transform.dom
此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax - 软件包 javax.xml.transform.sax
此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax - 软件包 javax.xml.transform.stax
提供特定于 StAX 的转换 API。
javax.xml.transform.stream - 软件包 javax.xml.transform.stream
此包实现特定于流和 URI 的转换 API。
javax.xml.validation - 软件包 javax.xml.validation
此包提供了用于 XML 文档验证的 API。
javax.xml.ws - 软件包 javax.xml.ws
此包包含核心 JAX-WS API。
javax.xml.ws.handler - 软件包 javax.xml.ws.handler
该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap - 软件包 javax.xml.ws.handler.soap
该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.http - 软件包 javax.xml.ws.http
该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap - 软件包 javax.xml.ws.soap
该包定义特定于 SOAP 绑定的 API。
javax.xml.ws.spi - 软件包 javax.xml.ws.spi
该包定义用于 JAX-WS 2.0 的 SPI。
javax.xml.xpath - 软件包 javax.xml.xpath
此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
JAXB_CONTEXT_FACTORY - 类 javax.xml.bind.JAXBContext 中的静态变量
属性名称，它包含能够创建新的 JAXBContext 对象的类名称。
JAXB_ENCODING - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定已编组 XML 数据中输出编码的属性名称。
JAXB_FORMATTED_OUTPUT - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定是否使用换行和缩排对已编组 XML 数据进行格式化的属性名称。
JAXB_FRAGMENT - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定 marshaller 是否将生成文档级事件（即调用 startDocument 或 endDocument）的属性名称。
JAXB_NO_NAMESPACE_SCHEMA_LOCATION - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定将放置在已编组 XML 输出中的 xsi:noNamespaceSchemaLocation 属性值的属性名称。
JAXB_SCHEMA_LOCATION - 接口 javax.xml.bind.Marshaller 中的静态变量
用来指定将放置在已编组 XML 输出中的 xsi:schemaLocation 属性值的属性名称。
JAXBContext - javax.xml.bind 中的 类
JAXBContext 类提供到 JAXB API 的客户端入口点。
JAXBContext() - 类 javax.xml.bind.JAXBContext 的构造方法
JAXBElement<T> - javax.xml.bind 中的 类
Xml 元素的 JAXB 表示形式。
JAXBElement(QName, Class<T>, Class, T) - 类 javax.xml.bind.JAXBElement 的构造方法
构造一个 xml 元素实例。
JAXBElement(QName, Class<T>, T) - 类 javax.xml.bind.JAXBElement 的构造方法
构造一个 xml 元素实例。
JAXBElement.GlobalScope - javax.xml.bind 中的 类
为 xml 元素指定全局作用域。
JAXBElement.GlobalScope() - 类 javax.xml.bind.JAXBElement.GlobalScope 的构造方法
JAXBException - javax.xml.bind 中的 异常
这是所有 JAXB 异常的根异常类。
JAXBException(String) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带指定详细消息的 JAXBException。
JAXBException(String, String) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 JAXBException。
JAXBException(Throwable) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带有一个 linkedException 的 JAXBException。
JAXBException(String, Throwable) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带指定的详细消息和 linkedException 的 JAXBException。
JAXBException(String, String, Throwable) - 异常 javax.xml.bind.JAXBException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 JAXBException。
JAXBIntrospector - javax.xml.bind 中的 类
提供对 JAXB 对象的 JAXB xml 绑定数据的访问。
JAXBIntrospector() - 类 javax.xml.bind.JAXBIntrospector 的构造方法
JAXBResult - javax.xml.bind.util 中的 类
解组 JAXB 对象的 JAXP Result 实现。
JAXBResult(JAXBContext) - 类 javax.xml.bind.util.JAXBResult 的构造方法
创建一个使用指定 JAXBContext 来解组的新实例。
JAXBResult(Unmarshaller) - 类 javax.xml.bind.util.JAXBResult 的构造方法
创建一个使用指定 Unmarshaller 来解组对象的新实例。
JAXBSource - javax.xml.bind.util 中的 类
编组 JAXB 生成的对象的 JAXP Source 实现。
JAXBSource(JAXBContext, Object) - 类 javax.xml.bind.util.JAXBSource 的构造方法
针对给定的内容对象创建一个新 Source。
JAXBSource(Marshaller, Object) - 类 javax.xml.bind.util.JAXBSource 的构造方法
针对给定的内容对象创建一个新 Source。
JAXWSPROVIDER_PROPERTY - 类 javax.xml.ws.spi.Provider 中的静态变量
表示用于查找 Provider 实现类名称的属性的常量。
JButton - javax.swing 中的 类
"push" 按钮的实现。
JButton() - 类 javax.swing.JButton 的构造方法
创建不带有设置文本或图标的按钮。
JButton(Icon) - 类 javax.swing.JButton 的构造方法
创建一个带图标的按钮。
JButton(String) - 类 javax.swing.JButton 的构造方法
创建一个带文本的按钮。
JButton(Action) - 类 javax.swing.JButton 的构造方法
创建一个按钮，其属性从所提供的 Action 中获取。
JButton(String, Icon) - 类 javax.swing.JButton 的构造方法
创建一个带初始文本和图标的按钮。
JButton.AccessibleJButton - javax.swing 中的 类
此类实现对 JButton 类的可访问性支持。
JButton.AccessibleJButton() - 类 javax.swing.JButton.AccessibleJButton 的构造方法
JCheckBox - javax.swing 中的 类
复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
JCheckBox() - 类 javax.swing.JCheckBox 的构造方法
创建一个没有文本、没有图标并且最初未被选定的复选框。
JCheckBox(Icon) - 类 javax.swing.JCheckBox 的构造方法
创建有一个图标、最初未被选定的复选框。
JCheckBox(Icon, boolean) - 类 javax.swing.JCheckBox 的构造方法
创建一个带图标的复选框，并指定其最初是否处于选定状态。
JCheckBox(String) - 类 javax.swing.JCheckBox 的构造方法
创建一个带文本的、最初未被选定的复选框。
JCheckBox(Action) - 类 javax.swing.JCheckBox 的构造方法
创建一个复选框，其属性从所提供的 Action 获取。
JCheckBox(String, boolean) - 类 javax.swing.JCheckBox 的构造方法
创建一个带文本的复选框，并指定其最初是否处于选定状态。
JCheckBox(String, Icon) - 类 javax.swing.JCheckBox 的构造方法
创建带有指定文本和图标的、最初未选定的复选框。
JCheckBox(String, Icon, boolean) - 类 javax.swing.JCheckBox 的构造方法
创建一个带文本和图标的复选框，并指定其最初是否处于选定状态。
JCheckBox.AccessibleJCheckBox - javax.swing 中的 类
此类实现对 JCheckBox 类的可访问性支持。
JCheckBox.AccessibleJCheckBox() - 类 javax.swing.JCheckBox.AccessibleJCheckBox 的构造方法
JCheckBoxMenuItem - javax.swing 中的 类
可以被选定或取消选定的菜单项。
JCheckBoxMenuItem() - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建一个没有设置文本或图标的、最初未选定的复选框菜单项。
JCheckBoxMenuItem(Icon) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建有一个带图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建一个带文本的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(Action) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建一个从所提供的 Action 中获取其属性的菜单项。
JCheckBoxMenuItem(String, Icon) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建带有指定文本和图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String, boolean) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建带有指定文本和选择状态的复选框菜单项。
JCheckBoxMenuItem(String, Icon, boolean) - 类 javax.swing.JCheckBoxMenuItem 的构造方法
创建带有指定文本、图标和选择状态的复选框菜单项。
JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem - javax.swing 中的 类
此类实现对 JCheckBoxMenuItem 类的可访问性支持。
JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem() - 类 javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 的构造方法
JColorChooser - javax.swing 中的 类
JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
JColorChooser() - 类 javax.swing.JColorChooser 的构造方法
创建初始颜色为白色的颜色选取器窗格。
JColorChooser(Color) - 类 javax.swing.JColorChooser 的构造方法
创建具有指定初始颜色的颜色选取器窗格。
JColorChooser(ColorSelectionModel) - 类 javax.swing.JColorChooser 的构造方法
创建具有指定 ColorSelectionModel 颜色选取器窗格。
JColorChooser.AccessibleJColorChooser - javax.swing 中的 类
此类实现对 JColorChooser 类的可访问性支持。
JColorChooser.AccessibleJColorChooser() - 类 javax.swing.JColorChooser.AccessibleJColorChooser 的构造方法
JComboBox - javax.swing 中的 类
将按钮或可编辑字段与下拉列表组合的组件。
JComboBox(ComboBoxModel) - 类 javax.swing.JComboBox 的构造方法
创建一个 JComboBox，其项取自现有的 ComboBoxModel。
JComboBox(Object[]) - 类 javax.swing.JComboBox 的构造方法
创建包含指定数组中的元素的 JComboBox。
JComboBox(Vector<?>) - 类 javax.swing.JComboBox 的构造方法
创建包含指定 Vector 中的元素的 JComboBox。
JComboBox() - 类 javax.swing.JComboBox 的构造方法
创建具有默认数据模型的 JComboBox。
JComboBox.AccessibleJComboBox - javax.swing 中的 类
此类实现 JComboBox 类的可访问性支持。
JComboBox.AccessibleJComboBox() - 类 javax.swing.JComboBox.AccessibleJComboBox 的构造方法
返回 AccessibleJComboBox 实例
JComboBox.KeySelectionManager - javax.swing 中的 接口
定义 KeySelectionManager 的接口。
JComponent - javax.swing 中的 类
该类是除顶层容器外所有 Swing 组件的基类。
JComponent() - 类 javax.swing.JComponent 的构造方法
默认的 JComponent 构造方法。
JComponent.AccessibleJComponent - javax.swing 中的 类
用于为可访问性提供默认支持的 JComponent 内部类。
JComponent.AccessibleJComponent() - 类 javax.swing.JComponent.AccessibleJComponent 的构造方法
尽管该类是抽象的，但是应该通过所有子类调用它。
JComponent.AccessibleJComponent.AccessibleContainerHandler - javax.swing 中的 类
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
JComponent.AccessibleJComponent.AccessibleContainerHandler() - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler 的构造方法
JComponent.AccessibleJComponent.AccessibleFocusHandler - javax.swing 中的 类
发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
JComponent.AccessibleJComponent.AccessibleFocusHandler() - 类 javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler 的构造方法
JCOMPONENT_UI - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个作为 Swing 组件实现的 UI。
jdbcCompliant() - 接口 java.sql.Driver 中的方法
报告此驱动程序是否是一个真正的 JDBC CompliantTM 驱动程序。
JdbcRowSet - javax.sql.rowset 中的 接口
所有标准 JdbcRowSet 实现都必须实现的标准接口。
JDesktopPane - javax.swing 中的 类
用于创建多文档界面或虚拟桌面的容器。
JDesktopPane() - 类 javax.swing.JDesktopPane 的构造方法
创建一个新的 JDesktopPane。
JDesktopPane.AccessibleJDesktopPane - javax.swing 中的 类
此类实现对 JDesktopPane 类的可访问性支持。
JDesktopPane.AccessibleJDesktopPane() - 类 javax.swing.JDesktopPane.AccessibleJDesktopPane 的构造方法
JDialog - javax.swing 中的 类
创建对话框窗口的主要类。
JDialog() - 类 javax.swing.JDialog 的构造方法
创建一个没有标题并且没有指定 Frame 所有者的无模式对话框。
JDialog(Frame) - 类 javax.swing.JDialog 的构造方法
创建一个没有标题但将指定的 Frame 作为其所有者的无模式对话框。
JDialog(Frame, boolean) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定所有者 Frame、模式和空标题的对话框。
JDialog(Frame, String) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题和指定所有者窗体的无模式对话框。
JDialog(Frame, String, boolean) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Frame 和模式的对话框。
JDialog(Frame, String, boolean, GraphicsConfiguration) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。
JDialog(Dialog) - 类 javax.swing.JDialog 的构造方法
创建一个没有标题但将指定的 Dialog 作为其所有者的无模式对话框。
JDialog(Dialog, boolean) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定所有者 Dialog 和模式的对话框。
JDialog(Dialog, String) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题和指定所有者对话框的无模式对话框。
JDialog(Dialog, String, boolean) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、模式和指定所有者 Dialog 的对话框。
JDialog(Dialog, String, boolean, GraphicsConfiguration) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。
JDialog(Window) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定所有者 Window 和空标题的无模式对话框。
JDialog(Window, Dialog.ModalityType) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定所有者 Window、模式和空标题的对话框。
JDialog(Window, String) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题和所有者 Window 的无模式对话框。
JDialog(Window, String, Dialog.ModalityType) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Window 和模式的对话框。
JDialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - 类 javax.swing.JDialog 的构造方法
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。
JDialog.AccessibleJDialog - javax.swing 中的 类
此类实现对 JDialog 类的可访问性支持。
JDialog.AccessibleJDialog() - 类 javax.swing.JDialog.AccessibleJDialog 的构造方法
JDIALOG_UI - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个作为 Swing 对话框实现的 UI。
JEditorPane - javax.swing 中的 类
可编辑各种内容的文本组件。
JEditorPane() - 类 javax.swing.JEditorPane 的构造方法
创建一个新的 JEditorPane。
JEditorPane(URL) - 类 javax.swing.JEditorPane 的构造方法
根据用作输入的指定 URL 创建一个 JEditorPane。
JEditorPane(String) - 类 javax.swing.JEditorPane 的构造方法
根据包含 URL 规范的字符串创建一个 JEditorPane。
JEditorPane(String, String) - 类 javax.swing.JEditorPane 的构造方法
创建一个已初始化为给定文件的 JEditorPane。
JEditorPane.AccessibleJEditorPane - javax.swing 中的 类
此类实现对 JEditorPane 类的可访问性支持。
JEditorPane.AccessibleJEditorPane() - 类 javax.swing.JEditorPane.AccessibleJEditorPane 的构造方法
JEditorPane.AccessibleJEditorPaneHTML - javax.swing 中的 类
此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
JEditorPane.AccessibleJEditorPaneHTML() - 类 javax.swing.JEditorPane.AccessibleJEditorPaneHTML 的构造方法
JEditorPane.JEditorPaneAccessibleHypertextSupport - javax.swing 中的 类
AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
JEditorPane.JEditorPaneAccessibleHypertextSupport() - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport 的构造方法
提供某种支持
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink - javax.swing 中的 类
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element) - 类 javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink 的构造方法
JFileChooser - javax.swing 中的 类
JFileChooser 为用户选择文件提供了一种简单的机制。
JFileChooser() - 类 javax.swing.JFileChooser 的构造方法
构造一个指向用户默认目录的 JFileChooser。
JFileChooser(String) - 类 javax.swing.JFileChooser 的构造方法
构造一个使用给定路径的 JFileChooser。
JFileChooser(File) - 类 javax.swing.JFileChooser 的构造方法
使用给定的 File 作为路径来构造一个 JFileChooser。
JFileChooser(FileSystemView) - 类 javax.swing.JFileChooser 的构造方法
使用给定的 FileSystemView 构造一个 JFileChooser。
JFileChooser(File, FileSystemView) - 类 javax.swing.JFileChooser 的构造方法
使用给定的当前目录和 FileSystemView 构造一个 JFileChooser。
JFileChooser(String, FileSystemView) - 类 javax.swing.JFileChooser 的构造方法
使用给定的当前目录路径和 FileSystemView 构造一个 JFileChooser。
JFileChooser.AccessibleJFileChooser - javax.swing 中的 类
此类实现对 JFileChooser 类的可访问性支持。
JFileChooser.AccessibleJFileChooser() - 类 javax.swing.JFileChooser.AccessibleJFileChooser 的构造方法
JFormattedTextField - javax.swing 中的 类
JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
JFormattedTextField() - 类 javax.swing.JFormattedTextField 的构造方法
创建一个没有 AbstractFormatterFactory 的 JFormattedTextField。
JFormattedTextField(Object) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个具有指定值的 JFormattedTextField。
JFormattedTextField(Format) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatter) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个具有指定 AbstractFormatter 的 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个具有指定 AbstractFormatterFactory 的 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory, Object) - 类 javax.swing.JFormattedTextField 的构造方法
创建一个具有指定 AbstractFormatterFactory 和初始值的 JFormattedTextField。
JFormattedTextField.AbstractFormatter - javax.swing 中的 类
JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。
JFormattedTextField.AbstractFormatter() - 类 javax.swing.JFormattedTextField.AbstractFormatter 的构造方法
JFormattedTextField.AbstractFormatterFactory - javax.swing 中的 类
JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。
JFormattedTextField.AbstractFormatterFactory() - 类 javax.swing.JFormattedTextField.AbstractFormatterFactory 的构造方法
JFrame - javax.swing 中的 类
java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
JFrame() - 类 javax.swing.JFrame 的构造方法
构造一个初始时不可见的新窗体。
JFrame(GraphicsConfiguration) - 类 javax.swing.JFrame 的构造方法
以屏幕设备的指定 GraphicsConfiguration 和空白标题创建一个 Frame。
JFrame(String) - 类 javax.swing.JFrame 的构造方法
创建一个新的、初始不可见的、具有指定标题的 Frame。
JFrame(String, GraphicsConfiguration) - 类 javax.swing.JFrame 的构造方法
创建一个具有指定标题和指定屏幕设备的 GraphicsConfiguration 的 JFrame。
JFrame.AccessibleJFrame - javax.swing 中的 类
此类实现对 JFrame 类的可访问性支持。
JFrame.AccessibleJFrame() - 类 javax.swing.JFrame.AccessibleJFrame 的构造方法
JInternalFrame - javax.swing 中的 类
提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
JInternalFrame() - 类 javax.swing.JInternalFrame 的构造方法
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、没有标题的 JInternalFrame。
JInternalFrame(String) - 类 javax.swing.JInternalFrame 的构造方法
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、具有指定标题的 JInternalFrame。
JInternalFrame(String, boolean) - 类 javax.swing.JInternalFrame 的构造方法
创建不可关闭的、不可最大化的、不可图标化的，以及具有指定标题和可调整大小的 JInternalFrame。
JInternalFrame(String, boolean, boolean) - 类 javax.swing.JInternalFrame 的构造方法
创建不可最大化的、不可图标化的，以及具有指定标题、可调整大小和可关闭的 JInternalFrame。
JInternalFrame(String, boolean, boolean, boolean) - 类 javax.swing.JInternalFrame 的构造方法
创建不可图标化的，但具有指定标题、可调整大小、可关闭和可最大化的 JInternalFrame。
JInternalFrame(String, boolean, boolean, boolean, boolean) - 类 javax.swing.JInternalFrame 的构造方法
创建具有指定标题、可调整、可关闭、可最大化和可图标化的 JInternalFrame。
JInternalFrame.AccessibleJInternalFrame - javax.swing 中的 类
此类实现对 JInternalFrame 类的可访问性支持。
JInternalFrame.AccessibleJInternalFrame() - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 的构造方法
JInternalFrame.JDesktopIcon - javax.swing 中的 类
此组件表示 JInternalFrame 的图标化版本。
JInternalFrame.JDesktopIcon(JInternalFrame) - 类 javax.swing.JInternalFrame.JDesktopIcon 的构造方法
为内部 frame 创建一个图标。
JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon - javax.swing 中的 类
此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon() - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 的构造方法
JIS_B0 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B0 (1030 x 1456 mm) 的 MediaType 实例。
JIS_B0 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B0 尺寸。
JIS_B1 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B1 (728 x 1030 mm) 的 MediaType 实例。
JIS_B1 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B1 尺寸。
JIS_B10 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B10 (32 x 45 mm) 的 MediaType 实例。
JIS_B10 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B10 尺寸。
JIS_B2 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B2 (515 x 728 mm) 的 MediaType 实例。
JIS_B2 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B2 尺寸。
JIS_B3 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B3 (364 x 515 mm) 的 MediaType 实例。
JIS_B3 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B3 尺寸。
JIS_B4 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B4 (257 x 364 mm) 的 MediaType 实例。
JIS_B4 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B4 尺寸。
JIS_B5 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B5 (182 x 257 mm) 的 MediaType 实例。
JIS_B5 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B5 尺寸。
JIS_B6 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B6 (128 x 182 mm) 的 MediaType 实例。
JIS_B6 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B6 尺寸。
JIS_B7 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B7 (91 x 128 mm) 的 MediaType 实例。
JIS_B7 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B7 尺寸。
JIS_B8 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B8 (64 x 91 mm) 的 MediaType 实例。
JIS_B8 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B8 尺寸。
JIS_B9 - 类 java.awt.PageAttributes.MediaType 中的静态变量
JIS B9 (45 x 64 mm) 的 MediaType 实例。
JIS_B9 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
JIS B9 尺寸。
JLabel - javax.swing 中的 类
用于短文本字符串或图像或二者的显示区。
JLabel(String, Icon, int) - 类 javax.swing.JLabel 的构造方法
创建具有指定文本、图像和水平对齐方式的 JLabel 实例。
JLabel(String, int) - 类 javax.swing.JLabel 的构造方法
创建具有指定文本和水平对齐方式的 JLabel 实例。
JLabel(String) - 类 javax.swing.JLabel 的构造方法
创建具有指定文本的 JLabel 实例。
JLabel(Icon, int) - 类 javax.swing.JLabel 的构造方法
创建具有指定图像和水平对齐方式的 JLabel 实例。
JLabel(Icon) - 类 javax.swing.JLabel 的构造方法
创建具有指定图像的 JLabel 实例。
JLabel() - 类 javax.swing.JLabel 的构造方法
创建无图像并且其标题为空字符串的 JLabel。
JLabel.AccessibleJLabel - javax.swing 中的 类
该类用于获得此对象的可访问性职责。
JLabel.AccessibleJLabel() - 类 javax.swing.JLabel.AccessibleJLabel 的构造方法
JLayeredPane - javax.swing 中的 类
JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
JLayeredPane() - 类 javax.swing.JLayeredPane 的构造方法
创建新的 JLayeredPane
JLayeredPane.AccessibleJLayeredPane - javax.swing 中的 类
此类实现对 JLayeredPane 类的可访问性支持。
JLayeredPane.AccessibleJLayeredPane() - 类 javax.swing.JLayeredPane.AccessibleJLayeredPane 的构造方法
JList - javax.swing 中的 类
显示对象列表并且允许用户选择一个或多个项的组件。
JList(ListModel) - 类 javax.swing.JList 的构造方法
根据指定的非 null 模型构造一个显示元素的 JList。
JList(Object[]) - 类 javax.swing.JList 的构造方法
构造一个 JList，使其显示指定数组中的元素。
JList(Vector<?>) - 类 javax.swing.JList 的构造方法
构造一个 JList，使其显示指定 Vector 中的元素。
JList() - 类 javax.swing.JList 的构造方法
构造一个具有空的、只读模型的 JList。
JList.AccessibleJList - javax.swing 中的 类
此类实现 JList 类的可访问性支持。
JList.AccessibleJList() - 类 javax.swing.JList.AccessibleJList 的构造方法
JList.AccessibleJList.AccessibleJListChild - javax.swing 中的 类
此类实现供 List 子级使用的可访问性支持。
JList.AccessibleJList.AccessibleJListChild(JList, int) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 的构造方法
JList.DropLocation - javax.swing 中的 类
TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。
JMenu - javax.swing 中的 类
菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
JMenu() - 类 javax.swing.JMenu 的构造方法
构造没有文本的新 JMenu。
JMenu(String) - 类 javax.swing.JMenu 的构造方法
构造一个新 JMenu，用提供的字符串作为其文本。
JMenu(Action) - 类 javax.swing.JMenu 的构造方法
构造一个从提供的 Action 获取其属性的菜单。
JMenu(String, boolean) - 类 javax.swing.JMenu 的构造方法
构造一个新 JMenu，用提供的字符串作为其文本并指定其是否为分离式 (tear-off) 菜单。
JMenu.AccessibleJMenu - javax.swing 中的 类
此类实现 JMenu 类的可访问性支持。
JMenu.AccessibleJMenu() - 类 javax.swing.JMenu.AccessibleJMenu 的构造方法
JMenu.WinListener - javax.swing 中的 类
观察弹出窗口关闭的侦听器类。
JMenu.WinListener(JPopupMenu) - 类 javax.swing.JMenu.WinListener 的构造方法
创建指定弹出菜单的窗口侦听器。
JMenuBar - javax.swing 中的 类
菜单栏的实现。
JMenuBar() - 类 javax.swing.JMenuBar 的构造方法
创建新的菜单栏。
JMenuBar.AccessibleJMenuBar - javax.swing 中的 类
此类实现 JMenuBar 类的可访问性支持。
JMenuBar.AccessibleJMenuBar() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 的构造方法
JMenuItem - javax.swing 中的 类
菜单中的项的实现。
JMenuItem() - 类 javax.swing.JMenuItem 的构造方法
创建不带有设置文本或图标的 JMenuItem。
JMenuItem(Icon) - 类 javax.swing.JMenuItem 的构造方法
创建带有指定图标的 JMenuItem。
JMenuItem(String) - 类 javax.swing.JMenuItem 的构造方法
创建带有指定文本的 JMenuItem。
JMenuItem(Action) - 类 javax.swing.JMenuItem 的构造方法
创建从指定的 Action 获取其属性的菜单项。
JMenuItem(String, Icon) - 类 javax.swing.JMenuItem 的构造方法
创建带有指定文本和图标的 JMenuItem。
JMenuItem(String, int) - 类 javax.swing.JMenuItem 的构造方法
创建带有指定文本和键盘助记符的 JMenuItem。
JMenuItem.AccessibleJMenuItem - javax.swing 中的 类
此类实现 JMenuItem 类的可访问性支持。
JMException - javax.management 中的 异常
由 JMX 实现所抛出的异常。
JMException() - 异常 javax.management.JMException 的构造方法
默认的构造方法。
JMException(String) - 异常 javax.management.JMException 的构造方法
允许指定特定错误消息的构造方法。
JMRuntimeException - javax.management 中的 异常
由 JMX 实现所发出的运行时异常。
JMRuntimeException() - 异常 javax.management.JMRuntimeException 的构造方法
默认的构造方法。
JMRuntimeException(String) - 异常 javax.management.JMRuntimeException 的构造方法
允许指定特定错误消息的构造方法。
JMX - javax.management 中的 类
JMX API 提供的静态方法。
JMXAddressable - javax.management.remote 中的 接口
由可能具有 JMXServiceURL 地址的对象实现。
JMXAuthenticator - javax.management.remote 中的 接口
定义如何将远程凭据转换为 JAAS Subject（主题）的接口。
JMXConnectionNotification - javax.management.remote 中的 类
在客户端连接打开或关闭时，或者当通知丢失时发出的通知。
JMXConnectionNotification(String, Object, String, long, String, Object) - 类 javax.management.remote.JMXConnectionNotification 的构造方法
构造一个新的连接通知。
JMXConnector - javax.management.remote 中的 接口
JMX API 连接器的客户端。
JMXConnectorFactory - javax.management.remote 中的 类
用于创建 JMX API 连接器客户端的工厂。
JMXConnectorProvider - javax.management.remote 中的 接口
使用给定的协议创建 JMX API 连接器客户端的提供者。
JMXConnectorServer - javax.management.remote 中的 类
每个连接器服务器的超类。
JMXConnectorServer() - 类 javax.management.remote.JMXConnectorServer 的构造方法
构造一个将注册为连接到 MBean 服务器的 MBean 的连接器服务器。
JMXConnectorServer(MBeanServer) - 类 javax.management.remote.JMXConnectorServer 的构造方法
构造一个连接到给定 MBean 服务器的连接器服务器。
JMXConnectorServerFactory - javax.management.remote 中的 类
用于创建 JMX API 连接器服务器的工厂。
JMXConnectorServerMBean - javax.management.remote 中的 接口
供连接器服务器使用的 MBean 接口。
JMXConnectorServerProvider - javax.management.remote 中的 接口
使用给定的协议创建 JMX API 连接器服务器的提供者。
JMXPrincipal - javax.management.remote 中的 类
JMX Remote API 的远程客户端的身份。
JMXPrincipal(String) - 类 javax.management.remote.JMXPrincipal 的构造方法
为给定的身份创建一个 JMXPrincipal。
JMXProviderException - javax.management.remote 中的 异常
当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
JMXProviderException() - 异常 javax.management.remote.JMXProviderException 的构造方法
构造一个不带指定详细消息的 JMXProviderException。
JMXProviderException(String) - 异常 javax.management.remote.JMXProviderException 的构造方法
构造带指定详细消息的 JMXProviderException。
JMXProviderException(String, Throwable) - 异常 javax.management.remote.JMXProviderException 的构造方法
构造带指定详细消息和嵌套异常的 JMXProviderException。
JMXServerErrorException - javax.management.remote 中的 异常
在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。
JMXServerErrorException(String, Error) - 异常 javax.management.remote.JMXServerErrorException 的构造方法
构造带指定详细消息和嵌套错误的 JMXServerErrorException。
JMXServiceURL - javax.management.remote 中的 类
JMX API 连接器服务器的地址。
JMXServiceURL(String) - 类 javax.management.remote.JMXServiceURL 的构造方法
通过解析 Service URL 字符串来构造 JMXServiceURL。
JMXServiceURL(String, String, int) - 类 javax.management.remote.JMXServiceURL 的构造方法
构造具有给定协议、主机和端口的 JMXServiceURL。
JMXServiceURL(String, String, int, String) - 类 javax.management.remote.JMXServiceURL 的构造方法
构造具有给定部分的 JMXServiceURL。
JNDI_REBIND_ATTRIBUTE - 类 javax.management.remote.rmi.RMIConnectorServer 中的静态变量
属性名称，它指定代表 RMI 连接器服务器的 RMIServer stub 是否应重写位于同一地址的现有 stub。
JOB_CANCELED - 类 javax.print.event.PrintJobEvent 中的静态变量
作业已被 PrintService 取消。
JOB_CANCELED_AT_DEVICE - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
非标识本地用户取消了作业，即在设备控制台的用户取消了作业。
JOB_CANCELED_BY_OPERATOR - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
操作员取消了作业，操作员即用户，其已被授权为具有操作员权限（无论是本地还是远程）。
JOB_CANCELED_BY_USER - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业所有者取消了作业，作业所有者即用户，通过验证的该用户身份与创建 Print Job 的初始用户的值相同，或某位其他授权终端用户，例如作业所有者安全组成员。
JOB_COMPLETE - 类 javax.print.event.PrintJobEvent 中的静态变量
文档已被完全打印。
JOB_COMPLETED_SUCCESSFULLY - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业成功完成。
JOB_COMPLETED_WITH_ERRORS - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业以错误结束（也可能是警告）。
JOB_COMPLETED_WITH_WARNINGS - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业以警告结束。
JOB_DATA_INSUFFICIENT - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机已创建 Print Job，但打印机在可以将作业转为 PROCESSING 状态之前还需要额外的打印数据。
JOB_FAILED - 类 javax.print.event.PrintJobEvent 中的静态变量
打印服务报告无法完成作业。
JOB_HOLD_UNTIL_SPECIFIED - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
为作业的 JobHoldUntil 属性值指定一个将来的日期-时间。
JOB_INCOMING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机已创建 Print Job，但打印机尚未完成访问或接收所有打印数据。
JOB_INTERPRETING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据。
JOB_OUTGOING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机正将作业传输到输出设备。
JOB_PRINTING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
输出设备为标记介质。
JOB_QUEUED - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机处于 PROCESSING 状态，更明确地讲，打印机已对文档数据排队。
JOB_QUEUED_FOR_MARKER - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机处于 PENDING_HELD、PENDING 或 PROCESSING 状态，更明确地讲，打印机已完成足够的文档处理，能够开始标记且作业正在等待标记。
JOB_RESTARTABLE - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
此作业被保留，且当前可以重新开始。
JOB_TRANSFORMING - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据并生成另一个电子表示形式。
JobAttributes - java.awt 中的 类
控制打印作业的属性集合。
JobAttributes() - 类 java.awt.JobAttributes 的构造方法
构造一个具有每个属性的默认值的 JobAttributes 实例。
JobAttributes(JobAttributes) - 类 java.awt.JobAttributes 的构造方法
构造一个 JobAttributes 实例，作为所提供的 JobAttributes 的副本。
JobAttributes(int, JobAttributes.DefaultSelectionType, JobAttributes.DestinationType, JobAttributes.DialogType, String, int, int, JobAttributes.MultipleDocumentHandlingType, int[][], String, JobAttributes.SidesType) - 类 java.awt.JobAttributes 的构造方法
构造一个具有每个属性指定值的 JobAttributes 实例。
JobAttributes.DefaultSelectionType - java.awt 中的 类
可能的默认选择状态的类型安全的枚举。
JobAttributes.DestinationType - java.awt 中的 类
可能的作业目标的类型安全枚举。
JobAttributes.DialogType - java.awt 中的 类
显示给用户的可能对话框的类型安全枚举。
JobAttributes.MultipleDocumentHandlingType - java.awt 中的 类
可能的多副本处理状态的类型安全枚举。
JobAttributes.SidesType - java.awt 中的 类
可能的多页整版的类型安全枚举。
JobHoldUntil - javax.print.attribute.standard 中的 类
JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
JobHoldUntil(Date) - 类 javax.print.attribute.standard.JobHoldUntil 的构造方法
构造具有给定 Date 值新 JobHoldUntil 属性。
JobImpressions - javax.print.attribute.standard 中的 类
JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
JobImpressions(int) - 类 javax.print.attribute.standard.JobImpressions 的构造方法
构造具有给定整数值的新作业印张属性。
JobImpressionsCompleted - javax.print.attribute.standard 中的 类
JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
JobImpressionsCompleted(int) - 类 javax.print.attribute.standard.JobImpressionsCompleted 的构造方法
构造具有给定整数值的新的 JobImpressionsCompleted 属性。
JobImpressionsSupported - javax.print.attribute.standard 中的 类
JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
JobImpressionsSupported(int, int) - 类 javax.print.attribute.standard.JobImpressionsSupported 的构造方法
构造包含单个整数范围的新的 JobImpressionsSupported 属性。
JobKOctets - javax.print.attribute.standard 中的 类
JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
JobKOctets(int) - 类 javax.print.attribute.standard.JobKOctets 的构造方法
构造具有给定整数值的新 JobKOctets 属性。
JobKOctetsProcessed - javax.print.attribute.standard 中的 类
JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
JobKOctetsProcessed(int) - 类 javax.print.attribute.standard.JobKOctetsProcessed 的构造方法
构造具有给定整数值的新的 JobKOctetsProcessed 属性。
JobKOctetsSupported - javax.print.attribute.standard 中的 类
JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
JobKOctetsSupported(int, int) - 类 javax.print.attribute.standard.JobKOctetsSupported 的构造方法
构造包含单个整数范围的新的 JobKOctetsSupported 属性。
JobMediaSheets - javax.print.attribute.standard 中的 类
JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
JobMediaSheets(int) - 类 javax.print.attribute.standard.JobMediaSheets 的构造方法
构造具有给定整数值的新 JobMediaSheets 属性。
JobMediaSheetsCompleted - javax.print.attribute.standard 中的 类
JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
JobMediaSheetsCompleted(int) - 类 javax.print.attribute.standard.JobMediaSheetsCompleted 的构造方法
构造具有整数值的 JobMediaSheetsCompleted 属性。
JobMediaSheetsSupported - javax.print.attribute.standard 中的 类
Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
JobMediaSheetsSupported(int, int) - 类 javax.print.attribute.standard.JobMediaSheetsSupported 的构造方法
构造包含单个整数范围的新的 JobMediaSheetsSupported 属性。
JobMessageFromOperator - javax.print.attribute.standard 中的 类
JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
JobMessageFromOperator(String, Locale) - 类 javax.print.attribute.standard.JobMessageFromOperator 的构造方法
使用给定消息和语言环境构造新的 JobMessageFromOperator 属性。
JobName - javax.print.attribute.standard 中的 类
JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
JobName(String, Locale) - 类 javax.print.attribute.standard.JobName 的构造方法
构造具有给定作业名称和语言环境的新JobName属性。
JobOriginatingUserName - javax.print.attribute.standard 中的 类
JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
JobOriginatingUserName(String, Locale) - 类 javax.print.attribute.standard.JobOriginatingUserName 的构造方法
构造具有给定用户名称和语言环境的新的 JobOriginatingUserName 属性。
JobPriority - javax.print.attribute.standard 中的 类
JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
JobPriority(int) - 类 javax.print.attribute.standard.JobPriority 的构造方法
构造具有给定整数值的新 JobPriority 属性。
JobPrioritySupported - javax.print.attribute.standard 中的 类
JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
JobPrioritySupported(int) - 类 javax.print.attribute.standard.JobPrioritySupported 的构造方法
构造具有给定整数值的新的 JobPrioritySupported 属性。
JobSheets - javax.print.attribute.standard 中的 类
JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
JobSheets(int) - 类 javax.print.attribute.standard.JobSheets 的构造方法
构造具有给定整数值的新 JobSheets 枚举值。
JobState - javax.print.attribute.standard 中的 类
JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
JobState(int) - 类 javax.print.attribute.standard.JobState 的构造方法
构造具有给定整数值的新 JobState 枚举值。
JobStateReason - javax.print.attribute.standard 中的 类
JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
JobStateReason(int) - 类 javax.print.attribute.standard.JobStateReason 的构造方法
构造具有给定整数值的新 JobStateReason 枚举值。
JobStateReasons - javax.print.attribute.standard 中的 类
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
JobStateReasons() - 类 javax.print.attribute.standard.JobStateReasons 的构造方法
构造新的空作业状态原因属性；底层哈希集合具有默认的初始容量和加载因子。
JobStateReasons(int) - 类 javax.print.attribute.standard.JobStateReasons 的构造方法
构造新的空作业状态原因属性；底层哈希集合具有给定的初始容量和默认的加载因子。
JobStateReasons(int, float) - 类 javax.print.attribute.standard.JobStateReasons 的构造方法
构造新的空作业状态原因属性；底层哈希集合具有给定的容量和加载因子。
JobStateReasons(Collection<JobStateReason>) - 类 javax.print.attribute.standard.JobStateReasons 的构造方法
构造新的作业状态原因属性，它包含与给定集合相同的 JobStateReason 对象。
join(long) - 类 java.lang.Thread 中的方法
等待该线程终止的时间最长为 millis 毫秒。
join(long, int) - 类 java.lang.Thread 中的方法
等待该线程终止的时间最长为 millis 毫秒 + nanos 纳秒。
join() - 类 java.lang.Thread 中的方法
等待该线程终止。
join(InetAddress) - 类 java.net.DatagramSocketImpl 中的方法
加入多播组。
JOIN_BEVEL - 类 java.awt.BasicStroke 中的静态变量
通过直线连接宽体轮廓的外角，将路径线段连接在一起。
JOIN_MITER - 类 java.awt.BasicStroke 中的静态变量
扩展路径线段的外边缘，直到它们连接在一起。
JOIN_ROUND - 类 java.awt.BasicStroke 中的静态变量
通过舍去半径为线长的一半的圆角，将路径线段连接在一起。
Joinable - javax.sql.rowset 中的 接口
1.0 背景 Joinable 接口提供了用于获取和设置匹配列的各种方法，匹配列是形成通过将 RowSet 对象添加到 JoinRowSet 对象所形成的 SQL JOIN 的基础。
JoinFractureDirection - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getDirection 的可能值。
joinGroup(SocketAddress, NetworkInterface) - 类 java.net.DatagramSocketImpl 中的方法
加入多播组。
joinGroup(InetAddress) - 类 java.net.MulticastSocket 中的方法
加入多播组。
joinGroup(SocketAddress, NetworkInterface) - 类 java.net.MulticastSocket 中的方法
加入指定接口上的指定多播组。
JoinNextDirection - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getDirection 的可能值。
JoinPreviousDirection - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getDirection 的可能值。
JoinRowSet - javax.sql.rowset 中的 接口
JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
JOptionPane - javax.swing 中的 类
JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
JOptionPane() - 类 javax.swing.JOptionPane 的构造方法
创建一个带有测试消息的 JOptionPane。
JOptionPane(Object) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其使用 UI 提供的普通消息消息类型和默认选项。
JOptionPane(Object, int) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和默认选项。
JOptionPane(Object, int, int) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和选项。
JOptionPane(Object, int, int, Icon) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、选项和图标。
JOptionPane(Object, int, int, Icon, Object[]) - 类 javax.swing.JOptionPane 的构造方法
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JOptionPane(Object, int, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 的构造方法
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JOptionPane.AccessibleJOptionPane - javax.swing 中的 类
此类实现对 JOptionPane 类的可访问性支持。
JOptionPane.AccessibleJOptionPane() - 类 javax.swing.JOptionPane.AccessibleJOptionPane 的构造方法
JPanel - javax.swing 中的 类
JPanel 是一般轻量级容器。
JPanel(LayoutManager, boolean) - 类 javax.swing.JPanel 的构造方法
创建具有指定布局管理器和缓冲策略的新 JPanel。
JPanel(LayoutManager) - 类 javax.swing.JPanel 的构造方法
创建具有指定布局管理器的新缓冲 JPanel。
JPanel(boolean) - 类 javax.swing.JPanel 的构造方法
创建具有 FlowLayout 和指定缓冲策略的新 JPanel。
JPanel() - 类 javax.swing.JPanel 的构造方法
创建具有双缓冲和流布局的新 JPanel。
JPanel.AccessibleJPanel - javax.swing 中的 类
此类实现对 JPanel 类的可访问性支持。
JPanel.AccessibleJPanel() - 类 javax.swing.JPanel.AccessibleJPanel 的构造方法
JPasswordField - javax.swing 中的 类
JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
JPasswordField() - 类 javax.swing.JPasswordField 的构造方法
构造一个新 JPasswordField，使其具有默认文档、为 null 的开始文本字符串和为 0 的列宽度。
JPasswordField(String) - 类 javax.swing.JPasswordField 的构造方法
构造一个利用指定文本初始化的新 JPasswordField。
JPasswordField(int) - 类 javax.swing.JPasswordField 的构造方法
构造一个具有指定列数的新的空 JPasswordField。
JPasswordField(String, int) - 类 javax.swing.JPasswordField 的构造方法
构造一个利用指定文本和列初始化的新 JPasswordField。
JPasswordField(Document, String, int) - 类 javax.swing.JPasswordField 的构造方法
构造一个使用给定文本存储模型和给定列数的新 JPasswordField。
JPasswordField.AccessibleJPasswordField - javax.swing 中的 类
此类实现对 JPasswordField 类的可访问性支持。
JPasswordField.AccessibleJPasswordField() - 类 javax.swing.JPasswordField.AccessibleJPasswordField 的构造方法
JPEG - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
JPEG - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
JPEG - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
JPEGHuffmanTable - javax.imageio.plugins.jpeg 中的 类
封装单个 JPEG Huffman 表的类。
JPEGHuffmanTable(short[], short[]) - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 的构造方法
创建一个 Huffman 表并将其初始化。
JPEGImageReadParam - javax.imageio.plugins.jpeg 中的 类
此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。
JPEGImageReadParam() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 的构造方法
构造一个 JPEGImageReadParam。
JPEGImageWriteParam - javax.imageio.plugins.jpeg 中的 类
此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。
JPEGImageWriteParam(Locale) - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 的构造方法
构造一个 JPEGImageWriteParam。
JPEGQTable - javax.imageio.plugins.jpeg 中的 类
封装单个 JPEG 量化表的类。
JPEGQTable(int[]) - 类 javax.imageio.plugins.jpeg.JPEGQTable 的构造方法
根据参数构造一个量化表，该参数必须包含以自然顺序（非 Z 字形顺序）显示的 64 个元素。
JPopupMenu - javax.swing 中的 类
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
JPopupMenu() - 类 javax.swing.JPopupMenu 的构造方法
构造一个不带“调用者”的 JPopupMenu。
JPopupMenu(String) - 类 javax.swing.JPopupMenu 的构造方法
构造一个具有指定标题的 JPopupMenu。
JPopupMenu.AccessibleJPopupMenu - javax.swing 中的 类
此类实现 JPopupMenu 类的可访问性支持。
JPopupMenu.AccessibleJPopupMenu() - 类 javax.swing.JPopupMenu.AccessibleJPopupMenu 的构造方法
AccessibleJPopupMenu 构造方法
JPopupMenu.Separator - javax.swing 中的 类
弹出与菜单有关的分隔符。
JPopupMenu.Separator() - 类 javax.swing.JPopupMenu.Separator 的构造方法
JProgressBar - javax.swing 中的 类
以可视化形式显示某些任务进度的组件。
JProgressBar() - 类 javax.swing.JProgressBar 的构造方法
创建一个显示边框但不带进度字符串的水平进度条。
JProgressBar(int) - 类 javax.swing.JProgressBar 的构造方法
创建具有指定方向（SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL）的进度条。
JProgressBar(int, int) - 类 javax.swing.JProgressBar 的构造方法
创建具有指定最小值和最大值的水平进度条。
JProgressBar(int, int, int) - 类 javax.swing.JProgressBar 的构造方法
创建使用指定方向、最小值和最大值的进度条。
JProgressBar(BoundedRangeModel) - 类 javax.swing.JProgressBar 的构造方法
创建使用指定的保存进度条数据模型的水平进度条。
JProgressBar.AccessibleJProgressBar - javax.swing 中的 类
此类实现 JProgressBar 类的可访问性支持。
JProgressBar.AccessibleJProgressBar() - 类 javax.swing.JProgressBar.AccessibleJProgressBar 的构造方法
JRadioButton - javax.swing 中的 类
实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
JRadioButton() - 类 javax.swing.JRadioButton 的构造方法
创建一个初始化为未选择的单选按钮，其文本未设定。
JRadioButton(Icon) - 类 javax.swing.JRadioButton 的构造方法
创建一个初始化为未选择的单选按钮，其具有指定的图像但无文本。
JRadioButton(Action) - 类 javax.swing.JRadioButton 的构造方法
创建一个单选按钮，其属性来自提供的 Action。
JRadioButton(Icon, boolean) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定图像和选择状态的单选按钮，但无文本。
JRadioButton(String) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定文本的状态为未选择的单选按钮。
JRadioButton(String, boolean) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定文本和选择状态的单选按钮。
JRadioButton(String, Icon) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定的文本和图像并初始化为未选择的单选按钮。
JRadioButton(String, Icon, boolean) - 类 javax.swing.JRadioButton 的构造方法
创建一个具有指定的文本、图像和选择状态的单选按钮。
JRadioButton.AccessibleJRadioButton - javax.swing 中的 类
此类实现对 JRadioButton 类的可访问性支持。
JRadioButton.AccessibleJRadioButton() - 类 javax.swing.JRadioButton.AccessibleJRadioButton 的构造方法
JRadioButtonMenuItem - javax.swing 中的 类
一个单选按钮菜单项的实现。
JRadioButtonMenuItem() - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个未设置文本或图标的 JRadioButtonMenuItem。
JRadioButtonMenuItem(Icon) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个带图标的 JRadioButtonMenuItem。
JRadioButtonMenuItem(String) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个带文本的 JRadioButtonMenuItem。
JRadioButtonMenuItem(Action) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个单选按钮菜单项，其属性来自提供的 Action。
JRadioButtonMenuItem(String, Icon) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个具有指定文本和 Icon 的单选按钮菜单项。
JRadioButtonMenuItem(String, boolean) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个具有指定文本和选择状态的单选按钮菜单项。
JRadioButtonMenuItem(Icon, boolean) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个具有指定图像和选择状态的单选按钮菜单项，但无文本。
JRadioButtonMenuItem(String, Icon, boolean) - 类 javax.swing.JRadioButtonMenuItem 的构造方法
创建一个具有指定的文本、图像和选择状态的单选按钮菜单项。
JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem - javax.swing 中的 类
此类实现对 JRadioButtonMenuItem 类的可访问性支持。
JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem() - 类 javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 的构造方法
JRootPane - javax.swing 中的 类
该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
JRootPane() - 类 javax.swing.JRootPane 的构造方法
创建 JRootPane，设置其 glassPane、layeredPane 以及 contentPane。
JRootPane.AccessibleJRootPane - javax.swing 中的 类
此类实现对 JRootPane 类的可访问性支持。
JRootPane.AccessibleJRootPane() - 类 javax.swing.JRootPane.AccessibleJRootPane 的构造方法
JRootPane.RootLayout - javax.swing 中的 类
该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
JRootPane.RootLayout() - 类 javax.swing.JRootPane.RootLayout 的构造方法
JScrollBar - javax.swing 中的 类
滚动条的实现。
JScrollBar(int, int, int, int, int) - 类 javax.swing.JScrollBar 的构造方法
创建具有指定方向、值、跨度、最小值和最大值的一个滚动条。
JScrollBar(int) - 类 javax.swing.JScrollBar 的构造方法
创建具有指定方向和下列初始值的滚动条：
JScrollBar() - 类 javax.swing.JScrollBar 的构造方法
创建具有下列初始值的垂直滚动条：
JScrollBar.AccessibleJScrollBar - javax.swing 中的 类
此类实现 JScrollBar 类的可访问性支持。
JScrollBar.AccessibleJScrollBar() - 类 javax.swing.JScrollBar.AccessibleJScrollBar 的构造方法
JScrollPane - javax.swing 中的 类
提供轻量级组件的 scrollable 视图。
JScrollPane(Component, int, int) - 类 javax.swing.JScrollPane 的构造方法
创建一个 JScrollPane，它将视图组件显示在一个视口中，视图位置可使用一对滚动条控制。
JScrollPane(Component) - 类 javax.swing.JScrollPane 的构造方法
创建一个显示指定组件内容的 JScrollPane，只要组件的内容超过视图大小就会显示水平和垂直滚动条。
JScrollPane(int, int) - 类 javax.swing.JScrollPane 的构造方法
创建一个具有指定滚动条策略的空（无视口的视图）JScrollPane。
JScrollPane() - 类 javax.swing.JScrollPane 的构造方法
创建一个空的（无视口的视图）JScrollPane，需要时水平和垂直滚动条都可显示。
JScrollPane.AccessibleJScrollPane - javax.swing 中的 类
此类实现 JScrollPane 类的可访问性支持。
JScrollPane.AccessibleJScrollPane() - 类 javax.swing.JScrollPane.AccessibleJScrollPane 的构造方法
AccessibleJScrollPane 构造方法
JScrollPane.ScrollBar - javax.swing 中的 类
默认情况下，JScrollPane 创建的滚动条为此类的实例。
JScrollPane.ScrollBar(int) - 类 javax.swing.JScrollPane.ScrollBar 的构造方法
创建具有指定方向的滚动条。
JSeparator - javax.swing 中的 类
JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
JSeparator() - 类 javax.swing.JSeparator 的构造方法
创建一个新的水平分隔符。
JSeparator(int) - 类 javax.swing.JSeparator 的构造方法
创建一个具有指定水平或者垂直方向的分隔符。
JSeparator.AccessibleJSeparator - javax.swing 中的 类
此类实现 JSeparator 类的可访问性支持。
JSeparator.AccessibleJSeparator() - 类 javax.swing.JSeparator.AccessibleJSeparator 的构造方法
JSlider - javax.swing 中的 类
一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
JSlider() - 类 javax.swing.JSlider 的构造方法
创建一个范围在 0 到 100 之间并且初始值为 50 的水平滑块。
JSlider(int) - 类 javax.swing.JSlider 的构造方法
使用指定的方向创建一个滑块，范围在 0 到 100 之间并且初始值为 50。
JSlider(int, int) - 类 javax.swing.JSlider 的构造方法
使用指定的最小值和最大值创建一个水平滑块，初始值等于最小值加上最大值的平均值。
JSlider(int, int, int) - 类 javax.swing.JSlider 的构造方法
用指定的最小值、最大值和初始值创建一个水平滑块。
JSlider(int, int, int, int) - 类 javax.swing.JSlider 的构造方法
用指定的方向和指定的最小值、最大值以及初始值创建一个滑块。
JSlider(BoundedRangeModel) - 类 javax.swing.JSlider 的构造方法
使用指定的 BoundedRangeModel 创建一个水平滑块。
JSlider.AccessibleJSlider - javax.swing 中的 类
此类实现 JSlider 类的可访问性支持。
JSlider.AccessibleJSlider() - 类 javax.swing.JSlider.AccessibleJSlider 的构造方法
JSpinner - javax.swing 中的 类
让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
JSpinner(SpinnerModel) - 类 javax.swing.JSpinner 的构造方法
构造具有一对 next/previous 按钮和 SpinnerModel 编辑器的完整 spinner。
JSpinner() - 类 javax.swing.JSpinner 的构造方法
构造一个 spinner，使其具有初始值为 0 并且无任何最小值或者最大值限制的 Integer SpinnerNumberModel。
JSpinner.AccessibleJSpinner - javax.swing 中的 类
AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
JSpinner.AccessibleJSpinner() - 类 javax.swing.JSpinner.AccessibleJSpinner 的构造方法
AccessibleJSpinner 构造方法
JSpinner.DateEditor - javax.swing 中的 类
其模型为 SpinnerDateModel 的 JSpinner 编辑器。
JSpinner.DateEditor(JSpinner) - 类 javax.swing.JSpinner.DateEditor 的构造方法
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DateEditor(JSpinner, String) - 类 javax.swing.JSpinner.DateEditor 的构造方法
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DefaultEditor - javax.swing 中的 类
一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
JSpinner.DefaultEditor(JSpinner) - 类 javax.swing.JSpinner.DefaultEditor 的构造方法
构造一个针对指定 JSpinner 的编辑器组件。
JSpinner.ListEditor - javax.swing 中的 类
其模型为 SpinnerListModel 的 JSpinner 编辑器。
JSpinner.ListEditor(JSpinner) - 类 javax.swing.JSpinner.ListEditor 的构造方法
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerListModel 的值的显示和编辑。
JSpinner.NumberEditor - javax.swing 中的 类
其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
JSpinner.NumberEditor(JSpinner) - 类 javax.swing.JSpinner.NumberEditor 的构造方法
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerNumberModel 值的显示和编辑。
JSpinner.NumberEditor(JSpinner, String) - 类 javax.swing.JSpinner.NumberEditor 的构造方法
构造一个 JSpinner，使其支持具有一个 JFormattedTextField 的 SpinnerNumberModel 的值。
JSplitPane - javax.swing 中的 类
JSplitPane 用于分隔两个（只能两个）Component。
JSplitPane() - 类 javax.swing.JSplitPane 的构造方法
创建一个配置为将其子组件水平排列、无连续布局、为组件使用两个按钮的新 JSplitPane。
JSplitPane(int) - 类 javax.swing.JSplitPane 的构造方法
创建一个配置为指定方向且无连续布局的新 JSplitPane。
JSplitPane(int, boolean) - 类 javax.swing.JSplitPane 的构造方法
创建一个具有指定方向和重绘方式的新 JSplitPane。
JSplitPane(int, Component, Component) - 类 javax.swing.JSplitPane 的构造方法
创建一个具有指定方向和不连续重绘的指定组件的新 JSplitPane。
JSplitPane(int, boolean, Component, Component) - 类 javax.swing.JSplitPane 的构造方法
创建一个具有指定方向、重绘方式和指定组件的新 JSplitPane。
JSplitPane.AccessibleJSplitPane - javax.swing 中的 类
此类实现 JSplitPane 类的可访问性支持。
JSplitPane.AccessibleJSplitPane() - 类 javax.swing.JSplitPane.AccessibleJSplitPane 的构造方法
JTabbedPane - javax.swing 中的 类
一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
JTabbedPane() - 类 javax.swing.JTabbedPane 的构造方法
创建一个具有默认的 JTabbedPane.TOP 选项卡布局的空 TabbedPane。
JTabbedPane(int) - 类 javax.swing.JTabbedPane 的构造方法
创建一个空的 TabbedPane，使其具有以下指定选项卡布局中的一种：JTabbedPane.TOP、JTabbedPane.BOTTOM、JTabbedPane.LEFT 或 JTabbedPane.RIGHT。
JTabbedPane(int, int) - 类 javax.swing.JTabbedPane 的构造方法
创建一个空的 TabbedPane，使其具有指定的选项卡布局和选项卡布局策略。
JTabbedPane.AccessibleJTabbedPane - javax.swing 中的 类
此类实现对 JTabbedPane 类的可访问性支持。
JTabbedPane.AccessibleJTabbedPane() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 的构造方法
构造 AccessibleJTabbedPane。
JTabbedPane.ModelListener - javax.swing 中的 类
将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
JTabbedPane.ModelListener() - 类 javax.swing.JTabbedPane.ModelListener 的构造方法
JTable - javax.swing 中的 类
JTable 用来显示和编辑常规二维单元表。
JTable() - 类 javax.swing.JTable 的构造方法
构造一个默认的 JTable，使用默认的数据模型、默认的列模型和默认的选择模型对其进行初始化。
JTable(TableModel) - 类 javax.swing.JTable 的构造方法
构造一个 JTable，使用数据模型 dm、默认的列模型和默认的选择模型对其进行初始化。
JTable(TableModel, TableColumnModel) - 类 javax.swing.JTable 的构造方法
构造一个 JTable，使用数据模型 dm、列模型 cm 和默认的选择模型对其进行初始化。
JTable(TableModel, TableColumnModel, ListSelectionModel) - 类 javax.swing.JTable 的构造方法
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。
JTable(int, int) - 类 javax.swing.JTable 的构造方法
使用 DefaultTableModel 构造具有 numRows 行和 numColumns 列个空单元格的 JTable。
JTable(Vector, Vector) - 类 javax.swing.JTable 的构造方法
构造一个 JTable 来显示 Vector 所组成的 Vector rowData 中的值，其列名称为 columnNames。
JTable(Object[][], Object[]) - 类 javax.swing.JTable 的构造方法
构造一个 JTable 来显示二维数组 rowData 中的值，其列名称为 columnNames。
JTable.AccessibleJTable - javax.swing 中的 类
此类实现对 JTable 类的可访问性支持。
JTable.AccessibleJTable() - 类 javax.swing.JTable.AccessibleJTable 的构造方法
AccessibleJTable 构造方法
JTable.AccessibleJTable.AccessibleJTableCell - javax.swing 中的 类
此类提供了适用于表单元格的 Java Accessibility API 实现。
JTable.AccessibleJTable.AccessibleJTableCell(JTable, int, int, int) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 的构造方法
构造一个 AccessibleJTableHeaderEntry。
JTable.AccessibleJTable.AccessibleJTableModelChange - javax.swing 中的 类
JTable.AccessibleJTable.AccessibleJTableModelChange(int, int, int, int, int) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 的构造方法
JTable.DropLocation - javax.swing 中的 类
TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。
JTable.PrintMode - javax.swing 中的 枚举
用于打印 JTable 的打印模式。
JTableHeader - javax.swing.table 中的 类
这是管理 JTable 的头的对象。
JTableHeader() - 类 javax.swing.table.JTableHeader 的构造方法
构造具有默认 TableColumnModel 的 JTableHeader。
JTableHeader(TableColumnModel) - 类 javax.swing.table.JTableHeader 的构造方法
构造 JTableHeader，使用 cm 作为列模型对其进行初始化。
JTableHeader.AccessibleJTableHeader - javax.swing.table 中的 类
此类实现对 JTableHeader 类的可访问性支持。
JTableHeader.AccessibleJTableHeader() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader 的构造方法
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry - javax.swing.table 中的 类
此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry(int, JTableHeader, JTable) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 的构造方法
构造一个 AccessiblJTableHeaaderEntry
JTextArea - javax.swing 中的 类
JTextArea 是一个显示纯文本的多行区域。
JTextArea() - 类 javax.swing.JTextArea 的构造方法
构造新的 TextArea。
JTextArea(String) - 类 javax.swing.JTextArea 的构造方法
构造显示指定文本的新的 TextArea。
JTextArea(int, int) - 类 javax.swing.JTextArea 的构造方法
构造具有指定行数和列数的新的空 TextArea。
JTextArea(String, int, int) - 类 javax.swing.JTextArea 的构造方法
构造具有指定文本、行数和列数的新的 TextArea。
JTextArea(Document) - 类 javax.swing.JTextArea 的构造方法
构造新的 JTextArea，使其具有给定的文档模型，所有其他参数均默认为 (null, 0, 0)。
JTextArea(Document, String, int, int) - 类 javax.swing.JTextArea 的构造方法
构造具有指定行数和列数以及给定模型的新的 JTextArea。
JTextArea.AccessibleJTextArea - javax.swing 中的 类
此类实现对 JTextArea 类的可访问性支持。
JTextArea.AccessibleJTextArea() - 类 javax.swing.JTextArea.AccessibleJTextArea 的构造方法
JTextComponent - javax.swing.text 中的 类
JTextComponent 是 swing 文本组件的基类。
JTextComponent() - 类 javax.swing.text.JTextComponent 的构造方法
创建一个新的 JTextComponent。
JTextComponent.AccessibleJTextComponent - javax.swing.text 中的 类
此类实现 JTextComponent 类的可访问性支持。
JTextComponent.AccessibleJTextComponent() - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 的构造方法
构造 AccessibleJTextComponent。
JTextComponent.DropLocation - javax.swing.text 中的 类
表示 JTextComponent 的放置位置 (drop location)。
JTextComponent.KeyBinding - javax.swing.text 中的 类
用于创建键绑定的绑定记录。
JTextComponent.KeyBinding(KeyStroke, String) - 类 javax.swing.text.JTextComponent.KeyBinding 的构造方法
创建新的键绑定。
JTextField - javax.swing 中的 类
JTextField 是一个轻量级组件，它允许编辑单行文本。
JTextField() - 类 javax.swing.JTextField 的构造方法
构造一个新的 TextField。
JTextField(String) - 类 javax.swing.JTextField 的构造方法
构造一个用指定文本初始化的新 TextField。
JTextField(int) - 类 javax.swing.JTextField 的构造方法
构造一个具有指定列数的新的空 TextField。
JTextField(String, int) - 类 javax.swing.JTextField 的构造方法
构造一个用指定文本和列初始化的新 TextField。
JTextField(Document, String, int) - 类 javax.swing.JTextField 的构造方法
构造一个新的 JTextField，它使用给定文本存储模型和给定的列数。
JTextField.AccessibleJTextField - javax.swing 中的 类
此类实现对 JTextField 类的可访问性支持。
JTextField.AccessibleJTextField() - 类 javax.swing.JTextField.AccessibleJTextField 的构造方法
JTextPane - javax.swing 中的 类
可以用以图形方式表示的属性来标记的文本组件。
JTextPane() - 类 javax.swing.JTextPane 的构造方法
创建一个新的 JTextPane。
JTextPane(StyledDocument) - 类 javax.swing.JTextPane 的构造方法
创建具有指定文档模型的新 JTextPane。
JToggleButton - javax.swing 中的 类
具有两个状态的（two-state）按钮的实现。
JToggleButton() - 类 javax.swing.JToggleButton 的构造方法
创建最初未选定的切换按钮，不设置文本或图像。
JToggleButton(Icon) - 类 javax.swing.JToggleButton 的构造方法
创建一个最初未选定的切换按钮，该按钮具有指定的图像但是没有文本。
JToggleButton(Icon, boolean) - 类 javax.swing.JToggleButton 的构造方法
创建具有指定图像和选择状态但没有文本的切换按钮。
JToggleButton(String) - 类 javax.swing.JToggleButton 的构造方法
创建具有指定文本的未选定的切换按钮。
JToggleButton(String, boolean) - 类 javax.swing.JToggleButton 的构造方法
创建具有指定文本和选择状态的切换按钮。
JToggleButton(Action) - 类 javax.swing.JToggleButton 的构造方法
创建一个切换按钮，其属性从所提供的 Action 获取。
JToggleButton(String, Icon) - 类 javax.swing.JToggleButton 的构造方法
创建一个最初未选定的切换按钮，该按钮具有指定的文本和图像。
JToggleButton(String, Icon, boolean) - 类 javax.swing.JToggleButton 的构造方法
创建具有指定文本、图像和选择状态的切换按钮。
JToggleButton.AccessibleJToggleButton - javax.swing 中的 类
此类实现对 JToggleButton 类的可访问性支持。
JToggleButton.AccessibleJToggleButton() - 类 javax.swing.JToggleButton.AccessibleJToggleButton 的构造方法
JToggleButton.ToggleButtonModel - javax.swing 中的 类
ToggleButton 模型。
JToggleButton.ToggleButtonModel() - 类 javax.swing.JToggleButton.ToggleButtonModel 的构造方法
创建一个新的 ToggleButton Model
JToolBar - javax.swing 中的 类
JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
JToolBar() - 类 javax.swing.JToolBar 的构造方法
创建新的工具栏；默认的方向为 HORIZONTAL。
JToolBar(int) - 类 javax.swing.JToolBar 的构造方法
创建具有指定 orientation 的新工具栏。
JToolBar(String) - 类 javax.swing.JToolBar 的构造方法
创建一个具有指定 name 的新工具栏。
JToolBar(String, int) - 类 javax.swing.JToolBar 的构造方法
创建一个具有指定 name 和 orientation 的新工具栏。
JToolBar.AccessibleJToolBar - javax.swing 中的 类
此类实现对 JToolBar 类的可访问性支持。
JToolBar.AccessibleJToolBar() - 类 javax.swing.JToolBar.AccessibleJToolBar 的构造方法
JToolBar.Separator - javax.swing 中的 类
一个特定于工具栏的分隔符。
JToolBar.Separator() - 类 javax.swing.JToolBar.Separator 的构造方法
创建一个新的工具栏分隔符，使其具有当前外观定义的默认大小。
JToolBar.Separator(Dimension) - 类 javax.swing.JToolBar.Separator 的构造方法
创建具有指定大小的新的工具栏分隔符。
JToolTip - javax.swing 中的 类
用来显示 Component 的“提示”。
JToolTip() - 类 javax.swing.JToolTip 的构造方法
创建一个工具提示。
JToolTip.AccessibleJToolTip - javax.swing 中的 类
此类实现对 JToolTip 类的可访问性支持。
JToolTip.AccessibleJToolTip() - 类 javax.swing.JToolTip.AccessibleJToolTip 的构造方法
JTree - javax.swing 中的 类
将分层数据集显示为轮廓的控件。
JTree() - 类 javax.swing.JTree 的构造方法
返回带有示例模型的 JTree。
JTree(Object[]) - 类 javax.swing.JTree 的构造方法
返回 JTree，指定数组的每个元素作为不被显示的新根节点的子节点。
JTree(Vector<?>) - 类 javax.swing.JTree 的构造方法
返回 JTree，指定 Vector 的每个元素作为不被显示的新根节点的子节点。
JTree(Hashtable<?, ?>) - 类 javax.swing.JTree 的构造方法
返回从 Hashtable 创建的 JTree，它不显示根。
JTree(TreeNode) - 类 javax.swing.JTree 的构造方法
返回 JTree，指定的 TreeNode 作为其根，它显示根节点。
JTree(TreeNode, boolean) - 类 javax.swing.JTree 的构造方法
返回 JTree，指定的 TreeNode 作为其根，它用指定的方式显示根节点，并确定节点是否为叶节点。
JTree(TreeModel) - 类 javax.swing.JTree 的构造方法
返回 JTree 的一个实例，它显示根节点 - 使用指定的数据模型创建树。
JTree.AccessibleJTree - javax.swing 中的 类
此类实现 JTree 类的可访问性支持。
JTree.AccessibleJTree() - 类 javax.swing.JTree.AccessibleJTree 的构造方法
JTree.AccessibleJTree.AccessibleJTreeNode - javax.swing 中的 类
此类实现 JTree 子类的可访问性支持。
JTree.AccessibleJTree.AccessibleJTreeNode(JTree, TreePath, Accessible) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 的构造方法
构造一个 AccessibleJTreeNode
JTree.DropLocation - javax.swing 中的 类
TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。
JTree.DynamicUtilTreeNode - javax.swing 中的 类
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。
JTree.DynamicUtilTreeNode(Object, Object) - 类 javax.swing.JTree.DynamicUtilTreeNode 的构造方法
使用指定的对象作为其值并使用指定的子节点创建一个节点。
JTree.EmptySelectionModel - javax.swing 中的 类
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
JTree.EmptySelectionModel() - 类 javax.swing.JTree.EmptySelectionModel 的构造方法
JTree.TreeModelHandler - javax.swing 中的 类
在移除或更改节点时，监听模型并相应地更新 expandedState。
JTree.TreeModelHandler() - 类 javax.swing.JTree.TreeModelHandler 的构造方法
JTree.TreeSelectionRedirector - javax.swing 中的 类
使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。
JTree.TreeSelectionRedirector() - 类 javax.swing.JTree.TreeSelectionRedirector 的构造方法
JULY - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第七个月的 Calendar.MONTH 字段值。
JULY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第七个月的值。
JUNE - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第六个月的 Calendar.MONTH 字段值。
JUNE - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第六个月的值。
JUSTIFICATION - 类 java.awt.font.TextAttribute 中的静态变量
段落调整的属性键。
JUSTIFICATION_FULL - 类 java.awt.font.TextAttribute 中的静态变量
将线条调整到完整的请求宽度。
JUSTIFICATION_NONE - 类 java.awt.font.TextAttribute 中的静态变量
不允许调整线条。
JViewport - javax.swing 中的 类
用于查看底层信息的“视口”或“观察孔”。
JViewport() - 类 javax.swing.JViewport 的构造方法
创建一个 JViewport。
JViewport.AccessibleJViewport - javax.swing 中的 类
此类实现对 JViewport 类的可访问性支持。
JViewport.AccessibleJViewport() - 类 javax.swing.JViewport.AccessibleJViewport 的构造方法
JViewport.ViewListener - javax.swing 中的 类
视图的侦听器。
JViewport.ViewListener() - 类 javax.swing.JViewport.ViewListener 的构造方法
JWindow - javax.swing 中的 类
JWindow 是一个容器，可以显示在用户桌面上的任何位置。
JWindow() - 类 javax.swing.JWindow 的构造方法
创建未指定所有者的窗口。
JWindow(GraphicsConfiguration) - 类 javax.swing.JWindow 的构造方法
使用屏幕设备的指定 GraphicsConfiguration 创建窗口。
JWindow(Frame) - 类 javax.swing.JWindow 的构造方法
使用指定的所有者框架创建窗口。
JWindow(Window) - 类 javax.swing.JWindow 的构造方法
使用指定的所有者窗口创建窗口。
JWindow(Window, GraphicsConfiguration) - 类 javax.swing.JWindow 的构造方法
使用屏幕设备的指定所有者窗口和 GraphicsConfiguration 创建窗口。
JWindow.AccessibleJWindow - javax.swing 中的 类
此类实现对 JWindow 类的可访问性支持。
JWindow.AccessibleJWindow() - 类 javax.swing.JWindow.AccessibleJWindow 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


K - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

K

K1Div2Luminance - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的静态变量
在 JPEG 规范的表 K.1 中给出的样本亮度量化表，其中所有元素都除以 2。
K1Luminance - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的静态变量
在 JPEG 规范的表 K.1 中给出的样本亮度量化表。
K2Chrominance - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的静态变量
在 JPEG 规范的表 K.2 中给出的样本色度量化表。
K2Div2Chrominance - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的静态变量
在 JPEG 规范的表 K.2 中给出的样本色度量化表，其中所有元素都除以 2。
KAKU_0 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #0 信封尺寸，287 mm × 382 mm。
KAKU_1 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #1 信封尺寸，270 mm × 382 mm。
KAKU_2 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #2 信封尺寸，240 mm × 332 mm。
KAKU_20 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #20 信封尺寸，229 mm × 324 mm。
KAKU_3 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #3 信封尺寸，216 mm × 277 mm。
KAKU_4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #4 信封尺寸，197 mm × 267 mm。
KAKU_5 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #5 信封尺寸，190 mm by 240 mm。
KAKU_6 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #6 信封尺寸，162 mm × 229 mm。
KAKU_7 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #7 信封尺寸，142 mm × 205 mm。
KAKU_8 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") #8 信封尺寸，119 mm × 197 mm。
KAKU_A4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS Kaku ("square") A4 信封尺寸，228 mm × 312 mm。
KANBUN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Kanbun”Unicode 字符块的常量。
KANGXI_RADICALS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Kangxi Radicals”Unicode 字符块的常量。
KANJI - 类 java.awt.im.InputSubset 中的静态变量
编写日语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的日语汉字字集。
KANNADA - 类 java.awt.font.NumericShaper 中的静态变量
标识 KANNADA 范围和十进制基数。
KANNADA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Kannada”Unicode 字符块的常量。
KATAKANA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Katakana”Unicode 字符块的常量。
KATAKANA_PHONETIC_EXTENSIONS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Katakana Phonetic Extensions”Unicode 字符块的常量。
KBD - 类 javax.swing.text.html.HTML.Tag 中的静态变量
KEEP - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "keep"，某些属性的可能值。
KEEP - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
字符串 "keep"，某些属性的可能值。
KEEP_CURRENT_RESULT - 接口 java.sql.Statement 中的静态变量
该常量指示调用 getMoreResults 时应该关闭当前 ResultSet 对象。
KEEP_FILE_ORDER - 接口 java.util.jar.Pack200.Packer 中的静态变量
如果将此属性设置为 Pack200.Packer.TRUE，则打包器将按它们在源存档中的原始顺序传输所有元素。
KerberosKey - javax.security.auth.kerberos 中的 类
此类为 Kerberos 主体封装一个长期秘密密钥。
KerberosKey(KerberosPrincipal, byte[], int, int) - 类 javax.security.auth.kerberos.KerberosKey 的构造方法
当已知密钥类型和密钥版本号时，根据给出的字节构造 KerberosKey。
KerberosKey(KerberosPrincipal, char[], String) - 类 javax.security.auth.kerberos.KerberosKey 的构造方法
根据主体的密码构造 KerberosKey。
KerberosPrincipal - javax.security.auth.kerberos 中的 类
此类封装 Kerberos 主体。
KerberosPrincipal(String) - 类 javax.security.auth.kerberos.KerberosPrincipal 的构造方法
根据提供的字符串输入构造 KerberosPrincipal。
KerberosPrincipal(String, int) - 类 javax.security.auth.kerberos.KerberosPrincipal 的构造方法
根据提供的字符串和名称类型输入构造 KerberosPrincipal。
KerberosTicket - javax.security.auth.kerberos 中的 类
此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。
KerberosTicket(byte[], KerberosPrincipal, KerberosPrincipal, byte[], int, boolean[], Date, Date, Date, Date, InetAddress[]) - 类 javax.security.auth.kerberos.KerberosTicket 的构造方法
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。
Kernel - java.awt.image 中的 类
Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。
Kernel(int, int, float[]) - 类 java.awt.image.Kernel 的构造方法
根据 float 数组构造一个 Kernel 对象。
KERNING - 类 java.awt.font.TextAttribute 中的静态变量
请求进行字距调整的属性键。
KERNING_ON - 类 java.awt.font.TextAttribute 中的静态变量
请求标准字距调整。
key - 类 java.awt.Event 中的变量
在键盘事件中被按下的键的键代码。
Key - java.security 中的 接口
Key 是所有密钥的顶层接口。
key - 类 javax.accessibility.AccessibleBundle 中的变量
与语言环境无关的状态名称。
key - 类 javax.swing.text.JTextComponent.KeyBinding 中的变量
键。
KEY_ACTION - 类 java.awt.Event 中的静态变量
用户已经按下一个非 ASCII action 键。
KEY_ACTION_RELEASE - 类 java.awt.Event 中的静态变量
用户已经释放一个非 ASCII action 键。
KEY_ALPHA_INTERPOLATION - 类 java.awt.RenderingHints 中的静态变量
Alpha 插值提示键。
KEY_ANTIALIASING - 类 java.awt.RenderingHints 中的静态变量
抗锯齿提示键。
KEY_COLOR_RENDERING - 类 java.awt.RenderingHints 中的静态变量
颜色呈现提示键。
KEY_DITHERING - 类 java.awt.RenderingHints 中的静态变量
抖动提示键。
KEY_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择键事件的事件掩码。
KEY_FIRST - 类 java.awt.event.KeyEvent 中的静态变量
用于键事件的 id 范围的起始编号。
KEY_FRACTIONALMETRICS - 类 java.awt.RenderingHints 中的静态变量
字体小数规格提示键。
KEY_INTERPOLATION - 类 java.awt.RenderingHints 中的静态变量
插值提示键。
KEY_LAST - 类 java.awt.event.KeyEvent 中的静态变量
用于键事件的 id 范围的结束编号。
KEY_LOCATION_LEFT - 类 java.awt.event.KeyEvent 中的静态变量
该常量指示按下或释放的键位于左侧（此键的位置有多种可能性）。
KEY_LOCATION_NUMPAD - 类 java.awt.event.KeyEvent 中的静态变量
该常量指示按键事件发自于数字键盘或对应于数字键盘的虚拟键。
KEY_LOCATION_RIGHT - 类 java.awt.event.KeyEvent 中的静态变量
该常量指示按下或释放的键位于右侧（此键的位置有多种可能性）。
KEY_LOCATION_STANDARD - 类 java.awt.event.KeyEvent 中的静态变量
该常量指示按下或释放的键不区分左右，并且不是发自数字键盘（或者不是发自对应于数字键盘的虚拟键）。
KEY_LOCATION_UNKNOWN - 类 java.awt.event.KeyEvent 中的静态变量
指示 keyLocation 为不确定或不相关的常量。
KEY_PRESS - 类 java.awt.Event 中的静态变量
用户已经按下一个常规键。
KEY_PRESSED - 类 java.awt.event.KeyEvent 中的静态变量
“按下键”事件。
KEY_RELEASE - 类 java.awt.Event 中的静态变量
用户已经释放一个常规键。
KEY_RELEASED - 类 java.awt.event.KeyEvent 中的静态变量
“释放键”事件。
KEY_RENDERING - 类 java.awt.RenderingHints 中的静态变量
呈现提示键。
KEY_STROKE_CONTROL - 类 java.awt.RenderingHints 中的静态变量
笔划规范化控制提示键。
KEY_TEXT_ANTIALIASING - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示键。
KEY_TEXT_LCD_CONTRAST - 类 java.awt.RenderingHints 中的静态变量
LCD 文本对比呈现提示键。
KEY_TYPED - 类 java.awt.event.KeyEvent 中的静态变量
“键入键”事件。
KeyAdapter - java.awt.event 中的 类
接收键盘事件的抽象适配器类。
KeyAdapter() - 类 java.awt.event.KeyAdapter 的构造方法
KeyAgreement - javax.crypto 中的 类
此类提供密钥协定（或密钥交换）协议的功能。
KeyAgreement(KeyAgreementSpi, Provider, String) - 类 javax.crypto.KeyAgreement 的构造方法
创建一个 KeyAgreement 对象。
KeyAgreementSpi - javax.crypto 中的 类
此类为 KeyAgreement 类定义了服务提供者接口 (SPI)。
KeyAgreementSpi() - 类 javax.crypto.KeyAgreementSpi 的构造方法
KeyAlreadyExistsException - javax.management.openmbean 中的 异常
当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
KeyAlreadyExistsException() - 异常 javax.management.openmbean.KeyAlreadyExistsException 的构造方法
不带详细消息的 KeyAlreadyExistsException。
KeyAlreadyExistsException(String) - 异常 javax.management.openmbean.KeyAlreadyExistsException 的构造方法
带详细消息的 KeyAlreadyExistsException。
KEYBOARD_DIVIDER_MOVE_OFFSET - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的静态变量
通过键盘上的光标键移动分隔符时移动的距离（相对）。
keyboardDownRightListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
keyboardEndListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
KeyboardFocusManager - java.awt 中的 类
KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。
KeyboardFocusManager() - 类 java.awt.KeyboardFocusManager 的构造方法
初始化 KeyboardFocusManager。
keyboardHomeListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
keyboardResizeToggleListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
keyboardUpLeftListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
keyDown(Event, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
keyEqualsCharSet() - 异常 javax.swing.text.ChangedCharSetException 中的方法
KeyEvent - java.awt.event 中的 类
表示组件中发生键击的事件。
KeyEvent(Component, int, long, int, int, char, int) - 类 java.awt.event.KeyEvent 的构造方法
KeyEvent(Component, int, long, int, int, char) - 类 java.awt.event.KeyEvent 的构造方法
构造一个 KeyEvent 对象。
KeyEvent(Component, int, long, int, int) - 类 java.awt.event.KeyEvent 的构造方法
已过时。 从 JDK1.1 开始
KeyEventDispatcher - java.awt 中的 接口
在指派所有 KeyEvent 和为其确定目标时，KeyEventDispatcher 和当前 KeyboardFocusManager 一起使用。
KeyEventPostProcessor - java.awt 中的 接口
在最终解析所有未使用的 KeyEvent 时，需要将 KeyEventPostProcessor 和当前的 KeyboardFocusManager 一起使用。
KeyException - java.security 中的 异常
此异常是基本的密钥异常。
KeyException() - 异常 java.security.KeyException 的构造方法
构造不带详细消息的 KeyException。
KeyException(String) - 异常 java.security.KeyException 的构造方法
构造带指定详细消息的 KeyException。
KeyException(String, Throwable) - 异常 java.security.KeyException 的构造方法
创建带指定详细消息和 cause 的 KeyException。
KeyException(Throwable) - 异常 java.security.KeyException 的构造方法
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyFactory - java.security 中的 类
密钥工厂用于将密钥（Key 类型的不透明加密密钥）转换成密钥规范（底层密钥材料的透明表示），反之亦然。
KeyFactory(KeyFactorySpi, Provider, String) - 类 java.security.KeyFactory 的构造方法
创建一个 KeyFactory 对象。
KeyFactorySpi - java.security 中的 类
此类为 KeyFactory 类定义服务提供者接口 (SPI)。
KeyFactorySpi() - 类 java.security.KeyFactorySpi 的构造方法
keyFor(Selector) - 类 java.nio.channels.SelectableChannel 中的方法
获取表示通道向给定选择器注册的键。
keyFor(Selector) - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
KeyGenerator - javax.crypto 中的 类
此类提供（对称）密钥生成器的功能。
KeyGenerator(KeyGeneratorSpi, Provider, String) - 类 javax.crypto.KeyGenerator 的构造方法
创建一个 KeyGenerator 对象。
KeyGeneratorSpi - javax.crypto 中的 类
此类为 KeyGenerator 类定义了服务提供者接口 (SPI)。
KeyGeneratorSpi() - 类 javax.crypto.KeyGeneratorSpi 的构造方法
KeyInfo - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyInfo 元素的表示形式。
KeyInfoFactory - javax.xml.crypto.dsig.keyinfo 中的 类
用于从头创建 KeyInfo 对象或从相应的 XML 表示形式解组 KeyInfo 对象的工厂。
KeyInfoFactory() - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 的构造方法
默认的构造方法，由子类调用。
KeyListener - java.awt.event 中的 接口
用于接收键盘事件（击键）的侦听器接口。
keyListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
keyListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
keyListener - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
KeyManagementException - java.security 中的 异常
此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
KeyManagementException() - 异常 java.security.KeyManagementException 的构造方法
构造不带详细消息的 KeyManagementException。
KeyManagementException(String) - 异常 java.security.KeyManagementException 的构造方法
构造带指定详细消息的 KeyManagementException。
KeyManagementException(String, Throwable) - 异常 java.security.KeyManagementException 的构造方法
创建带指定详细消息和 cause 的 KeyManagementException。
KeyManagementException(Throwable) - 异常 java.security.KeyManagementException 的构造方法
创建带指定 cause 和详细消息的 KeyManagementException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyManager - javax.net.ssl 中的 接口
这是用于 JSSE 密钥管理器的基接口。
KeyManagerFactory - javax.net.ssl 中的 类
此类充当基于密钥内容源的密钥管理器的工厂。
KeyManagerFactory(KeyManagerFactorySpi, Provider, String) - 类 javax.net.ssl.KeyManagerFactory 的构造方法
创建 KeyManagerFactory 对象。
KeyManagerFactorySpi - javax.net.ssl 中的 类
此类为 KeyManagerFactory 类定义了服务提供者接口 (SPI)。
KeyManagerFactorySpi() - 类 javax.net.ssl.KeyManagerFactorySpi 的构造方法
Keymap - javax.swing.text 中的 接口
将 KeyStroke 绑定到操作的集合。
KeyName - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyName 元素的表示形式。
KeyPair - java.security 中的 类
此类是简单的密钥对（公钥和私钥）持有者。
KeyPair(PublicKey, PrivateKey) - 类 java.security.KeyPair 的构造方法
根据给定的公钥和私钥构造密钥对。
KeyPairGenerator - java.security 中的 类
KeyPairGenerator 类用于生成公钥和私钥对。
KeyPairGenerator(String) - 类 java.security.KeyPairGenerator 的构造方法
为指定的算法创建 KeyPairGenerator 对象。
KeyPairGeneratorSpi - java.security 中的 类
此类为用来生成公钥和私钥的 KeyPairGenerator 类定义了服务提供者接口 (SPI)。
KeyPairGeneratorSpi() - 类 java.security.KeyPairGeneratorSpi 的构造方法
keyPress(int) - 类 java.awt.Robot 中的方法
按下给定的键。
keyPressed(KeyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 keyPressed 方法处理 keyPressed 事件。
keyPressed(KeyEvent) - 类 java.awt.event.KeyAdapter 中的方法
按下某个键时调用此方法。
keyPressed(KeyEvent) - 接口 java.awt.event.KeyListener 中的方法
按下某个键时调用此方法。
keyPressed(KeyEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler 中的方法
keyPressed(KeyEvent) - 类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 中的方法
keyPressed(KeyEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的方法
keyRelease(int) - 类 java.awt.Robot 中的方法
释放给定的键。
keyReleased(KeyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 keyReleased 方法处理 keyReleased 事件。
keyReleased(KeyEvent) - 类 java.awt.event.KeyAdapter 中的方法
释放某个键时调用此方法。
keyReleased(KeyEvent) - 接口 java.awt.event.KeyListener 中的方法
释放某个键时调用此方法。
keyReleased(KeyEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler 中的方法
keyReleased(KeyEvent) - 类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 中的方法
keyReleased(KeyEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的方法
KeyRep - java.security 中的 类
已序列化的 Key 对象的标准表示形式。
KeyRep(KeyRep.Type, String, String, byte[]) - 类 java.security.KeyRep 的构造方法
构造替换的 Key 类。
KeyRep.Type - java.security 中的 枚举
Key 类型。
keys() - 类 java.nio.channels.Selector 中的方法
返回此选择器的键集。
keys() - 类 java.security.Provider 中的方法
keys() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此表中键的枚举。
keys() - 类 java.util.Dictionary 中的方法
返回此 dictionary 中的键的枚举。
keys() - 类 java.util.Hashtable 中的方法
返回此哈希表中的键的枚举。
keys() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.keys() 中的规范实现 keys 方法。
keys() - 类 java.util.prefs.Preferences 中的方法
返回在此首选项节点中具有关联值的所有键。
keys() - 类 javax.swing.ActionMap 中的方法
返回此 ActionMap 中绑定的 Action 名称。
keys() - 类 javax.swing.InputMap 中的方法
返回绑定在此 InputMap 中的 KeyStroke。
keySelectionManager - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
KeySelector - javax.xml.crypto 中的 类
一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。
KeySelector() - 类 javax.xml.crypto.KeySelector 的构造方法
默认的不带参数的构造方法；仅由子类调用。
KeySelector.Purpose - javax.xml.crypto 中的 类
将被选中的密钥的用途。
KeySelectorException - javax.xml.crypto 中的 异常
指示由 KeySelector 抛出的异常条件。
KeySelectorException() - 异常 javax.xml.crypto.KeySelectorException 的构造方法
构造用 null 作为其详细消息的新 KeySelectorException。
KeySelectorException(String) - 异常 javax.xml.crypto.KeySelectorException 的构造方法
构造带指定详细信息的新 KeySelectorException。
KeySelectorException(String, Throwable) - 异常 javax.xml.crypto.KeySelectorException 的构造方法
构造带指定详细消息和 cause 的新 KeySelectorException。
KeySelectorException(Throwable) - 异常 javax.xml.crypto.KeySelectorException 的构造方法
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 KeySelectorException（它通常包含 cause 的类和详细消息）。
KeySelectorResult - javax.xml.crypto 中的 接口
由 KeySelector.select 方法返回的结果。
keySet() - 类 java.awt.RenderingHints 中的方法
返回此 RenderingHints 中所包含键的 Set 视图。
keySet() - 类 java.security.Provider 中的方法
返回此 provider 中所包含的属性键的一个不可修改的 Set 视图。
keySet() - 类 java.util.AbstractMap 中的方法
返回此映射中包含的键的 Set 视图。
keySet() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此映射中包含的键的 Set 视图。
keySet() - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
返回此映射中所包含键的 NavigableSet 视图。
keySet() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此映射中所包含键的 NavigableSet 视图。
keySet() - 类 java.util.EnumMap 中的方法
返回此映射中所包含键的 Set 视图。
keySet() - 类 java.util.HashMap 中的方法
返回此映射中所包含的键的 Set 视图。
keySet() - 类 java.util.Hashtable 中的方法
返回此映射中包含的键的 Set 视图。
keySet() - 类 java.util.IdentityHashMap 中的方法
返回映射中所包含键的基于标识的 set 视图。
keySet() - 类 java.util.jar.Attributes 中的方法
返回此 Map 所包含的属性名称（键）的 Set 视图。
keySet() - 接口 java.util.Map 中的方法
返回此映射中包含的键的 Set 视图。
keySet() - 类 java.util.ResourceBundle 中的方法
返回此 ResourceBundle 及其父包中包含的所有键的 Set。
keySet() - 接口 java.util.SortedMap 中的方法
返回在此映射中所包含键的 Set 视图。
keySet() - 类 java.util.TreeMap 中的方法
返回此映射包含的键的 Set 视图。
keySet() - 类 java.util.WeakHashMap 中的方法
返回此映射所包含的键的 Set 视图。
keySet() - 类 javax.management.openmbean.CompositeType 中的方法
返回此 CompositeType 实例定义的所有项名称的不可修改的 Set 视图。
keySet() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例中包含的 CompositeData 值（即各行）的键（即索引值）的 set 视图。
keySet() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回包含在此 TabularDataSupport 实例的基础映射中的键的 set 视图，并用于索引行。
keySet() - 类 javax.script.SimpleBindings 中的方法
返回此映射中包含的键的 Set 视图。
KeySpec - java.security.spec 中的 接口
组成加密密钥的密钥内容的（透明）规范。
keysSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
返回在此首选项节点中具有关联值的所有键。
KeyStore - java.security 中的 类
此类表示密钥和证书的存储设施。
KeyStore(KeyStoreSpi, Provider, String) - 类 java.security.KeyStore 的构造方法
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。
KeyStore.Builder - java.security 中的 类
将被实例化的 KeyStore 对象的描述。
KeyStore.Builder() - 类 java.security.KeyStore.Builder 的构造方法
构造新的 Builder。
KeyStore.CallbackHandlerProtection - java.security 中的 类
封装 CallbackHandler 的 ProtectionParameter。
KeyStore.CallbackHandlerProtection(CallbackHandler) - 类 java.security.KeyStore.CallbackHandlerProtection 的构造方法
根据 CallbackHandler 构造新的 CallbackHandlerProtection。
KeyStore.Entry - java.security 中的 接口
用于 KeyStore 项类型的标记接口。
KeyStore.LoadStoreParameter - java.security 中的 接口
用于 KeyStore load 和 store 参数的标记接口。
KeyStore.PasswordProtection - java.security 中的 类
ProtectionParameter 的一个基于密码的实现。
KeyStore.PasswordProtection(char[]) - 类 java.security.KeyStore.PasswordProtection 的构造方法
创建一个 password 参数。
KeyStore.PrivateKeyEntry - java.security 中的 类
保存 PrivateKey 和相应证书链的 KeyStore 项。
KeyStore.PrivateKeyEntry(PrivateKey, Certificate[]) - 类 java.security.KeyStore.PrivateKeyEntry 的构造方法
构造带 PrivateKey 和相应证书链的 PrivateKeyEntry。
KeyStore.ProtectionParameter - java.security 中的 接口
用于 keystore 保护参数的标记接口。
KeyStore.SecretKeyEntry - java.security 中的 类
保存 SecretKey 的 KeyStore 项。
KeyStore.SecretKeyEntry(SecretKey) - 类 java.security.KeyStore.SecretKeyEntry 的构造方法
用 SecretKey 构造 SecretKeyEntry。
KeyStore.TrustedCertificateEntry - java.security 中的 类
保存可信的 Certificate 的 KeyStore 项。
KeyStore.TrustedCertificateEntry(Certificate) - 类 java.security.KeyStore.TrustedCertificateEntry 的构造方法
用可信 Certificate 构造 TrustedCertificateEntry。
KeyStoreBuilderParameters - javax.net.ssl 中的 类
封装了 KeyStore.Builders 列表的 X509KeyManagers 参数对象。
KeyStoreBuilderParameters(KeyStore.Builder) - 类 javax.net.ssl.KeyStoreBuilderParameters 的构造方法
根据指定的 KeyStore.Builder 构造新的 KeyStoreBuilderParameters。
KeyStoreBuilderParameters(List) - 类 javax.net.ssl.KeyStoreBuilderParameters 的构造方法
根据 KeyStore.Builder 的列表构造新的 KeyStoreBuilderParameters。
KeyStoreException - java.security 中的 异常
这是一般的 KeyStore 异常。
KeyStoreException() - 异常 java.security.KeyStoreException 的构造方法
构造不带详细消息的 KeyStoreException。
KeyStoreException(String) - 异常 java.security.KeyStoreException 的构造方法
构造带指定详细消息的 KeyStoreException。
KeyStoreException(String, Throwable) - 异常 java.security.KeyStoreException 的构造方法
创建带指定的详细消息和 cause 的 KeyStoreException。
KeyStoreException(Throwable) - 异常 java.security.KeyStoreException 的构造方法
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyStoreSpi - java.security 中的 类
此类为 KeyStore 类定义服务提供者接口 (SPI)。
KeyStoreSpi() - 类 java.security.KeyStoreSpi 的构造方法
KeyStroke - javax.swing 中的 类
表示键盘或等效输入设置上的键操作的 KeyStroke。
keyTyped(KeyEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 keyTyped 方法处理 keyTyped 事件。
keyTyped(KeyEvent) - 类 java.awt.event.KeyAdapter 中的方法
键入某个键时调用此方法。
keyTyped(KeyEvent) - 接口 java.awt.event.KeyListener 中的方法
键入某个键时调用此方法。
keyTyped(KeyEvent) - 类 javax.swing.plaf.basic.BasicTableUI.KeyHandler 中的方法
keyTyped(KeyEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的方法
键入键时调用。
keyUp(Event, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
KeyValue - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML KeyValue 元素的表示形式。
KHMER - 类 java.awt.font.NumericShaper 中的静态变量
标识 KHMER 范围和十进制基数。
KHMER - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Khmer”Unicode 字符块的常量。
KHMER_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Khmer Symbols”Unicode 字符块的常量。
kind - 类 javax.tools.SimpleJavaFileObject 中的变量
此文件对象的种类。
kind() - 类 org.omg.CORBA.TypeCode 中的方法
检索此 TypeCode 对象的种类。
kind - 类 org.omg.CosNaming.NameComponent 中的变量
KOREA - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
KOREAN - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
KRB_NT_PRINCIPAL - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
用户主体名称类型。
KRB_NT_SRV_HST - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
主机名作为实例 (telnet, rcommands) 的服务的名称类型。
KRB_NT_SRV_INST - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
服务和其他唯一实例 (krbtgt) 名称类型。
KRB_NT_SRV_XHST - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
将主机名作为剩余组件的服务的名称类型。
KRB_NT_UID - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
唯一 ID 名称类型。
KRB_NT_UNKNOWN - 类 javax.security.auth.kerberos.KerberosPrincipal 中的静态变量
未知的名称类型。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


L - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

L

Label - java.awt 中的 类
Label 对象是一个可在容器中放置文本的组件。
Label() - 类 java.awt.Label 的构造方法
构造一个空标签。
Label(String) - 类 java.awt.Label 的构造方法
使用指定的文本字符串构造一个新的标签，其文本对齐方式为左对齐。
Label(String, int) - 类 java.awt.Label 的构造方法
构造一个显示指定的文本字符串的新标签，其文本对齐方式为指定的方式。
LABEL - 类 javax.accessibility.AccessibleRole 中的静态变量
用于在界面中显示图标或短字符串的对象。
LABEL - 类 javax.swing.plaf.synth.Region 中的静态变量
Label 的 region。
label - 类 org.omg.CORBA.UnionMember 中的变量
此 UnionMember 对象所描述的 union 成员的标签。
Label.AccessibleAWTLabel - java.awt 中的 类
此类实现对 Label 类的可访问性支持。
Label.AccessibleAWTLabel() - 类 java.awt.Label.AccessibleAWTLabel 的构造方法
LABEL_FOR - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个目标对象的标签。
LABEL_FOR_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识某个标签的目标组已更改
LABELED_BY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示一个或多个目标对象作为某个对象的标签。
LABELED_BY_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识正在进行标签操作的对象已更改
labelFor - 类 javax.swing.JLabel 中的变量
labelRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
labelsHaveSameBaselines() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
如果标签表中的所有标签具有相同的基线，则返回 true。
labelUI - 类 javax.swing.plaf.basic.BasicLabelUI 中的静态变量
默认 BasicLabelUI 实例。
LabelUI - javax.swing.plaf 中的 类
JLabel 的可插入外观界面。
LabelUI() - 类 javax.swing.plaf.LabelUI 的构造方法
LabelView - javax.swing.text 中的 类
LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
LabelView(Element) - 类 javax.swing.text.LabelView 的构造方法
构造在元素上包装的新视图。
LANDSCAPE - 类 java.awt.PageAttributes.OrientationRequestedType 中的静态变量
用于指定横向方向的 OrientationRequestedType 实例。
LANDSCAPE - 类 java.awt.print.PageFormat 中的静态变量
原点位于纸张的左下方，x 的方向从下到上，y 的方向从左到右。
LANDSCAPE - 类 javax.print.attribute.standard.OrientationRequested 中的静态变量
沿介质的长边描绘内容。
LANG - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
LANGUAGE - 类 java.text.AttributedCharacterIterator.Attribute 中的静态变量
某些文本的语言的属性键。
LANGUAGE - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定用于服务的首选语言的环境属性名称。
LANGUAGE - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它是受实现支持的 Scripting Language 的完全名称。
LANGUAGE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
LANGUAGE_VERSION - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它标识受实现支持的脚本语言的版本。
LanguageCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。
LanguageCallback() - 类 javax.security.auth.callback.LanguageCallback 的构造方法
构造一个 LanguageCallback。
LAO - 类 java.awt.font.NumericShaper 中的静态变量
标识 LAO 范围和十进制基数。
LAO - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Lao”Unicode 字符块的常量。
LARGE_CAPACITY - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的大容量进纸托盘。
LARGE_ICON_KEY - 接口 javax.swing.Action 中的静态变量
用来存储 Icon 的键。
LARGE_MODEL_PROPERTY - 类 javax.swing.JTree 中的静态变量
largeModel 的绑定属性名称。
largeModel - 类 javax.swing.JTree 中的变量
此树是否为大模型？这是一种代码优化设置。
largeModel - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
如果对 largeModel 进行优化，则为 True。
last(Container) - 类 java.awt.CardLayout 中的方法
翻转到容器的最后一张卡片。
last() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的最后一行。
last() - 类 java.text.BreakIterator 中的方法
返回最后一个边界。
last() - 接口 java.text.CharacterIterator 中的方法
将位置设置为 getEndIndex()-1（如果文本为空，则为 getEndIndex()），并返回该位置的字符。
last() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.last()。
last() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
last() - 接口 java.util.SortedSet 中的方法
返回此 set 中当前最后一个（最高）元素。
last() - 类 java.util.TreeSet 中的方法
last() - 类 javax.swing.text.Segment 中的方法
将位置设置为 getEndIndex()-1（如果文本为空，则设置为 getEndIndex()），并返回该位置的字符。
LAST_DIVIDER_LOCATION_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 lastLocation 属性。
LAST_LINE_END - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的结束位置。
LAST_LINE_START - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的开始位置。
lastAlloc - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的变量
最后的可见分配区域（用于向上刷新更改时进行重新绘制）。
lastColumn - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
lastDividerLocation - 类 javax.swing.JSplitPane 中的变量
分隔窗格的上一个位置。
lastEdit() - 类 javax.swing.undo.CompoundEdit 中的方法
返回 edits 中最后一个 UndoableEdit，如果 edits 为空，则返回 null。
lastElement() - 类 java.util.Vector 中的方法
返回此向量的最后一个组件。
lastElement() - 类 javax.swing.DefaultListModel 中的方法
返回列表的最后一个组件。
lastEntry() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。
lastEntry() - 接口 java.util.NavigableMap 中的方法
返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
lastEntry() - 类 java.util.TreeMap 中的方法
lastIndexOf(int) - 类 java.lang.String 中的方法
返回指定字符在此字符串中最后一次出现处的索引。
lastIndexOf(int, int) - 类 java.lang.String 中的方法
返回指定字符在此字符串中最后一次出现处的索引，从指定的索引处开始进行反向搜索。
lastIndexOf(String) - 类 java.lang.String 中的方法
返回指定子字符串在此字符串中最右边出现处的索引。
lastIndexOf(String, int) - 类 java.lang.String 中的方法
返回指定子字符串在此字符串中最后一次出现处的索引，从指定的索引开始反向搜索。
lastIndexOf(String) - 类 java.lang.StringBuffer 中的方法
lastIndexOf(String, int) - 类 java.lang.StringBuffer 中的方法
lastIndexOf(String) - 类 java.lang.StringBuilder 中的方法
lastIndexOf(String, int) - 类 java.lang.StringBuilder 中的方法
lastIndexOf(Object) - 类 java.util.AbstractList 中的方法
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
lastIndexOf(Object) - 类 java.util.ArrayList 中的方法
返回此列表中最后一次出现的指定元素的索引，或如果此列表不包含索引，则返回 -1。
lastIndexOf(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
lastIndexOf(E, int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回最后一次出现的指定元素在此列表中的索引，从 index 开始向后搜索，如果没有找到该元素，则返回 -1。
lastIndexOf(Object) - 类 java.util.LinkedList 中的方法
返回此列表中最后出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。
lastIndexOf(Object) - 接口 java.util.List 中的方法
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
lastIndexOf(Object) - 类 java.util.Vector 中的方法
返回此向量中最后一次出现的指定元素的索引；如果此向量不包含该元素，则返回 -1。
lastIndexOf(Object, int) - 类 java.util.Vector 中的方法
返回此向量中最后一次出现的指定元素的索引，从 index 处逆向搜索，如果未找到该元素，则返回 -1。
lastIndexOf(Object) - 类 javax.swing.DefaultListModel 中的方法
返回 elem 最后一次出现处的索引。
lastIndexOf(Object, int) - 类 javax.swing.DefaultListModel 中的方法
从指定的索引处开始反向搜索 elem，并返回该对象的索引。
lastIndexOfSubList(List<?>, List<?>) - 类 java.util.Collections 中的静态方法
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
lastKey() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
lastKey() - 接口 java.util.SortedMap 中的方法
返回映射中当前最后一个（最高）键。
lastKey() - 类 java.util.TreeMap 中的方法
lastModified() - 类 java.io.File 中的方法
返回此抽象路径名表示的文件最后一次被修改的时间。
LastOwnerException - java.security.acl 中的 异常
如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
LastOwnerException() - 异常 java.security.acl.LastOwnerException 的构造方法
构造一个 LastOwnerException。
lastPageFirst() - 类 java.awt.PrintJob 中的方法
如果首先打印最后一页，则返回 true。
lastPaintPosition - 类 javax.swing.JViewport 中的变量
我们绘制的最后一个 viewPosition，因此我们知道有多少有效的后备存储图像。
lastPath - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
选择的最后路径。
lastRow - 类 javax.swing.event.TableModelEvent 中的变量
lastRow - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
lastRow - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
最后传入到 getTreeCellEditorComponent 的行。
lastSelectedRow - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
上一次选中行的索引。
lastTabInRun(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
lastValidOffset - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的变量
最后一次有效偏移量计算的位置。
LATEST - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "latest"，某些属性的可能值。
latest() - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回可以建模的最新源版本。
latestSupported() - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回完全受当前执行环境支持的最新源版本。
LATIN - 类 java.awt.im.InputSubset 中的静态变量
所有拉丁字符常量，包括 BASIC_LATIN、LATIN_1_SUPPLEMENT、LATIN_EXTENDED_A、LATIN_EXTENDED_B Unicode 字符块中的字符。
LATIN_1_SUPPLEMENT - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Latin-1 Supplement”Unicode 字符块的常量。
LATIN_DIGITS - 类 java.awt.im.InputSubset 中的静态变量
BASIC_LATIN Unicode 字符块中包括的数字常量。
LATIN_EXTENDED_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Latin Extended-A”Unicode 字符块的常量。
LATIN_EXTENDED_ADDITIONAL - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Latin Extended Additional”Unicode 字符块的常量。
LATIN_EXTENDED_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Latin Extended-B”Unicode 字符块的常量。
LAYER_PROPERTY - 类 javax.swing.JLayeredPane 中的静态变量
绑定属性
LAYERED_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
允许其子级在各层中进行绘制的专用窗格，提供堆栈顺序的形式。
LAYERED_PANE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
LayeredHighlighter - javax.swing.text 中的 类
LayeredHighlighter() - 类 javax.swing.text.LayeredHighlighter 的构造方法
LayeredHighlighter.LayerPainter - javax.swing.text 中的 类
分层的高亮显示渲染器。
LayeredHighlighter.LayerPainter() - 类 javax.swing.text.LayeredHighlighter.LayerPainter 的构造方法
layeredPane - 类 javax.swing.JRootPane 中的变量
管理菜单栏和内容窗格的分层窗格。
layout() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
layout() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1，用 doLayout() 取代。
layout() - 类 java.awt.ScrollPane 中的方法
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
layout(int, int) - 类 javax.swing.text.BoxView 中的方法
执行对框的布局
layout(FlowView) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
更新给定 FlowView 的流。
layout(int, int) - 类 javax.swing.text.FlowView 中的方法
布置子级。
LAYOUT_LEFT_TO_RIGHT - 类 java.awt.Font 中的静态变量
layoutGlyphVector 的标志，指示文本是从左到右的，这由 Bidi 分析确定。
LAYOUT_NO_LIMIT_CONTEXT - 类 java.awt.Font 中的静态变量
layoutGlyphVector 的标志，指示不应该检查指定 limit 之后的 char 数组中的文本。
LAYOUT_NO_START_CONTEXT - 类 java.awt.Font 中的静态变量
layoutGlyphVector 的标志，指示不应该检查指定 start 之前的 char 数组中的文本。
LAYOUT_RIGHT_TO_LEFT - 类 java.awt.Font 中的静态变量
layoutGlyphVector 的标志，指示文本是从右到左的，这由 Bidi 分析确定。
layoutChanged(int) - 类 javax.swing.text.BoxView 中的方法
使沿某轴的布局变得无效。
layoutCL(JLabel, FontMetrics, String, Icon, Rectangle, Rectangle, Rectangle) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
将调用转发到 SwingUtilities.layoutCompoundLabel()。
layoutColumns(int, int[], int[], SizeRequirements[]) - 类 javax.swing.text.TableView 中的方法
布局列，使其符合给定的目标跨距。
layoutComboBox(Container, MetalComboBoxUI.MetalComboBoxLayoutManager) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
layoutCompoundLabel(JComponent, FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - 类 javax.swing.SwingUtilities 中的静态方法
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
layoutCompoundLabel(FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - 类 javax.swing.SwingUtilities 中的静态方法
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
layoutContainer(Container) - 类 java.awt.BorderLayout 中的方法
使用此边框布局对容器参数进行布局。
layoutContainer(Container) - 类 java.awt.CardLayout 中的方法
使用此卡片布局布置指定的容器。
layoutContainer(Container) - 类 java.awt.FlowLayout 中的方法
布置该容器。
layoutContainer(Container) - 类 java.awt.GridBagLayout 中的方法
使用此网格包布局布置指定容器。
layoutContainer(Container) - 类 java.awt.GridLayout 中的方法
使用此布局布置指定容器。
layoutContainer(Container) - 接口 java.awt.LayoutManager 中的方法
布置指定容器。
layoutContainer(Container) - 类 javax.swing.BoxLayout 中的方法
在需要布置指定容器时，由 AWT 调用 。
layoutContainer(Container) - 类 javax.swing.GroupLayout 中的方法
布置指定的容器。
layoutContainer(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
指示布局管理器为指定的容器执行布局。
layoutContainer(Container) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
调整一个（并且是唯一）子级的大小，以完全填充父 insets 中的区域。
layoutContainer(Container) - 类 javax.swing.OverlayLayout 中的方法
当需要布置指定的容器时，由 AWT 调用。
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
进行实际布局。
layoutContainer(Container) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
layoutContainer(Container) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager 中的方法
layoutContainer(Container) - 类 javax.swing.ScrollPaneLayout 中的方法
布置滚动窗格。
layoutContainer(Container) - 类 javax.swing.SpringLayout 中的方法
layoutContainer(Container) - 类 javax.swing.ViewportLayout 中的方法
在需要布置指定容器时由 AWT 调用。
LayoutFocusTraversalPolicy - javax.swing 中的 类
根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
LayoutFocusTraversalPolicy() - 类 javax.swing.LayoutFocusTraversalPolicy 的构造方法
构造一个 LayoutFocusTraversalPolicy。
layoutGlyphVector(FontRenderContext, char[], int, int, int) - 类 java.awt.Font 中的方法
返回一个新 GlyphVector 对象，执行完整的文本布局（如有可能）。
layoutHScrollbar(JScrollBar) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
layoutInfo - 类 java.awt.GridBagLayout 中的变量
此字段保持网格包的布局信息。
layoutLabel(int, FontMetrics, int, String, Icon, Rectangle, Rectangle, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
layoutMajorAxis(int, int, int[], int[]) - 类 javax.swing.text.BoxView 中的方法
执行对框的主轴的布局（即它所代表的轴）。
layoutMajorAxis(int, int, int[], int[]) - 类 javax.swing.text.TableView.TableRow 中的方法
对框的主轴（即其表示的轴）执行布局操作。
LayoutManager - java.awt 中的 接口
定义知道如何布置 Container 类的接口。
layoutManager - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
创建并放到拆分窗格中的 LayoutManager。
LayoutManager2 - java.awt 中的 接口
为类定义接口，该类知道如何根据布局约束对象来布置 Container。
layoutMinorAxis(int, int, int[], int[]) - 类 javax.swing.text.BoxView 中的方法
执行对框的辅轴的布局（即与它所代表的轴垂直的轴）。
layoutMinorAxis(int, int, int[], int[]) - 类 javax.swing.text.html.BlockView 中的方法
执行对框的辅轴（即与它所代表的轴垂直的轴）的布局。
layoutMinorAxis(int, int, int[], int[]) - 类 javax.swing.text.TableView 中的方法
针对框的辅轴（即垂直于其所表示的轴的轴）执行布局操作。
layoutMinorAxis(int, int, int[], int[]) - 类 javax.swing.text.TableView.TableRow 中的方法
对盒子的辅轴（即垂直于其表示的轴的轴）执行布局操作。
LayoutPath - java.awt.font 中的 类
LayoutPath 提供相对于基线的位置与用户空间中的点之间的映射。
LayoutPath() - 类 java.awt.font.LayoutPath 的构造方法
layoutPool - 类 javax.swing.text.FlowView 中的变量
这些都是表示此视图表示的元素（要转换为物理视图的逻辑视图）的子元素的视图。
LayoutQueue - javax.swing.text 中的 类
文本布局任务的队列。
LayoutQueue() - 类 javax.swing.text.LayoutQueue 的构造方法
构造一个布局队列。
layoutRow(FlowView, int, int) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
创建一个符合该行布局区域的视图的行。
layoutSpan - 类 javax.swing.text.FlowView 中的变量
创建流所依靠的默认约束。
LayoutStyle - javax.swing 中的 类
LayoutStyle 提供有关如何确定组件位置的信息。
LayoutStyle() - 类 javax.swing.LayoutStyle 的构造方法
创建一个新的 LayoutStyle。
LayoutStyle.ComponentPlacement - javax.swing 中的 枚举
ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
layoutText(SynthContext, FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
根据通过引用返回的放置图标和文本的位置，布局文本和图标。
layoutVScrollbar(JScrollBar) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
lazilyLoadDesktopProperty(String) - 类 java.awt.Toolkit 中的方法
一个对桌面属性值延迟计算的机会。
lazySet(boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
最终设置为给定值。
lazySet(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
最后设置为给定值。
lazySet(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
最后将位置 i 的元素设置为给定值。
lazySet(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
最后将此更新器管理的给定对象的字段设置为给定更新值。
lazySet(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
最后设置为给定值。
lazySet(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
最终将位置 i 的元素设置为给定值。
lazySet(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
最后将此更新器管理的给定对象的字段设置为给定更新值。
lazySet(V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
最终设置为给定值。
lazySet(int, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
最终将位置 i 的元素设置为给定值。
lazySet(T, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
最终将此更新器管理的给定对象的字段设置为给定更新值。
LDAPCertStoreParameters - java.security.cert 中的 类
用作 LDAP CertStore 算法的输入的参数。
LDAPCertStoreParameters(String, int) - 类 java.security.cert.LDAPCertStoreParameters 的构造方法
创建具有指定参数值的 LDAPCertStoreParameters 的实例。
LDAPCertStoreParameters(String) - 类 java.security.cert.LDAPCertStoreParameters 的构造方法
创建具有指定服务器名称和默认端口 389 的 LDAPCertStoreParameters 的实例。
LDAPCertStoreParameters() - 类 java.security.cert.LDAPCertStoreParameters 的构造方法
创建具有默认参数值（服务器名称 "localhost"，端口 389）的 LDAPCertStoreParameters 的实例。
LdapContext - javax.naming.ldap 中的 接口
此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。
LdapName - javax.naming.ldap 中的 类
此类表示 RFC 2253 指定的标识名。
LdapName(String) - 类 javax.naming.ldap.LdapName 的构造方法
根据给定标识名构造 LDAP 名称。
LdapName(List<Rdn>) - 类 javax.naming.ldap.LdapName 的构造方法
在给定已解析 RDN 组件的情况下构造 LDAP 名称。
LdapReferralException - javax.naming.ldap 中的 异常
此抽象类用于表示 LDAP 引用异常。
LdapReferralException(String) - 异常 javax.naming.ldap.LdapReferralException 的构造方法
使用所提供的解释构造一个新的 LdapReferralException 实例。
LdapReferralException() - 异常 javax.naming.ldap.LdapReferralException 的构造方法
构造一个新的 LdapReferralException 实例。
LE - 类 javax.management.Query 中的静态变量
表示 Query.leq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
LEAD_DOTS - 类 javax.swing.text.TabStop 中的静态变量
LEAD_EQUALS - 类 javax.swing.text.TabStop 中的静态变量
LEAD_HYPHENS - 类 javax.swing.text.TabStop 中的静态变量
LEAD_NONE - 类 javax.swing.text.TabStop 中的静态变量
LEAD_SELECTION_PATH_PROPERTY - 类 javax.swing.JTree 中的静态变量
leadSelectionPath 的绑定属性名称。
LEAD_THICKLINE - 类 javax.swing.text.TabStop 中的静态变量
LEAD_UNDERLINE - 类 javax.swing.text.TabStop 中的静态变量
leadAnchorNotificationEnabled - 类 javax.swing.DefaultListSelectionModel 中的变量
leadIndex - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
selection 中前导路径的索引。
LEADING - 类 java.awt.FlowLayout 中的静态变量
此值指示每一行组件都应该与容器方向的开始边对齐，例如，对于从左到右的方向，则与左边对齐。
leading(int) - 类 java.awt.font.TextHitInfo 中的静态方法
在指定 charIndex 处的字符开始边上创建一个 TextHitInfo。
LEADING - 类 javax.swing.border.TitledBorder 中的静态变量
从左到右排列时将标题文本置于边框线的左边，从右到左排列时将标题文本置于边框线的右边。
LEADING - 接口 javax.swing.SwingConstants 中的静态变量
标识使用从左到右和从右到左的语言的文本开始边。
leadPath - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
添加的最后一条路径。
leadRow - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
前导行。
leafIcon - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于显示叶节点的图标。
Lease - java.rmi.dgc 中的 类
一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。
Lease(VMID, long) - 类 java.rmi.dgc.Lease 的构造方法
构造一个具有指定 VMID 和租借期限的 lease。
leave(InetAddress) - 类 java.net.DatagramSocketImpl 中的方法
退出多播组。
leaveGroup(SocketAddress, NetworkInterface) - 类 java.net.DatagramSocketImpl 中的方法
退出多播组。
leaveGroup(InetAddress) - 类 java.net.MulticastSocket 中的方法
离开多播组。
leaveGroup(SocketAddress, NetworkInterface) - 类 java.net.MulticastSocket 中的方法
离开指定本地接口上的多播组。
LEDGER - 类 java.awt.PageAttributes.MediaType 中的静态变量
Ledger (11 x 17 in) 的 MediaType 实例。
LEDGER - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 ledger 尺寸，11 inch × 17 inch。
LEDGER - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
ledger 尺寸。
LEFT - 类 java.awt.Event 中的静态变量
Left Arrow 键，一个非 ASCII 操作键。
LEFT - 类 java.awt.FlowLayout 中的静态变量
此值指示每一行组件都应该是左对齐的。
left - 类 java.awt.Insets 中的变量
左边的 inset。
LEFT - 类 java.awt.Label 中的静态变量
指示标签文本应左对齐。
left - 类 javax.swing.border.EmptyBorder 中的变量
LEFT - 类 javax.swing.border.TitledBorder 中的静态变量
将标题文本置于边框线的左边。
LEFT - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个 Component 到另一个 Component 的左边。
LEFT - 接口 javax.swing.SwingConstants 中的静态变量
用于指定框左侧位置的框方向常量。
LEFT_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentX 的易于使用的常量。
LEFT_JUSTIFY - 类 java.util.FormattableFlags 中的静态变量
将输出左对齐。
LEFT_OUTER_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供两个表之间的左外联合 (left outer join)。
LEFT_TO_RIGHT - 类 java.awt.ComponentOrientation 中的静态变量
各项从左到右布局，各行从上到下，示例：英语、法语。
leftButton - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
用于快速切换左边组件的按钮。
leftChildIndent - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
从左页边空白到将绘制垂直虚线的位置之间的距离。
leftComponent - 类 javax.swing.JSplitPane 中的变量
左边或者顶部的组件。
LeftIndent - 类 javax.swing.text.StyleConstants 中的静态变量
段落左边的缩进量。
leftKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
leftKey - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
leftKey - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
已过时。 从 Java 2 平台 v1.3 开始。
leftToRightCache - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
LEGAL - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_LEGAL 的别名。
LEGAL - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 合法尺寸，8.5 inch × 14 inch。
LEGAL_VALUES_FIELD - 类 javax.management.JMX 中的静态变量
legalValues 字段的名称。
len - 类 java.util.zip.InflaterInputStream 中的变量
输入缓冲区的长度。
length() - 类 java.io.File 中的方法
返回由此抽象路径名表示的文件的长度。
length - 异常 java.io.OptionalDataException 中的变量
当前缓冲区中可读取的基本数据的字节数。
length() - 类 java.io.RandomAccessFile 中的方法
返回此文件的长度。
length() - 接口 java.lang.CharSequence 中的方法
返回此字符序列的长度。
length() - 类 java.lang.String 中的方法
返回此字符串的长度。
length() - 类 java.lang.StringBuffer 中的方法
length() - 类 java.nio.CharBuffer 中的方法
返回此字符缓冲区的长度。
length() - 类 java.nio.charset.CoderResult 中的方法
返回此对象描述的错误输入的长度（可选操作）。
length() - 接口 java.sql.Blob 中的方法
返回此 Blob 对象指定的 BLOB 值中的字节数。
length() - 接口 java.sql.Clob 中的方法
获取此 Clob 对象指定的 CLOB 值中的字符数。
length() - 类 java.util.BitSet 中的方法
返回此 BitSet 的“逻辑大小”：BitSet 中最高设置位的索引加 1。
length() - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
返回该数组的长度。
length() - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
返回该数组的长度。
length() - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
返回该数组的长度。
length() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
length() - 类 javax.imageio.stream.FileImageInputStream 中的方法
返回底层文件的长度，如果其为未知，则返回 -1。
length() - 类 javax.imageio.stream.FileImageOutputStream 中的方法
length() - 接口 javax.imageio.stream.ImageInputStream 中的方法
返回流的总长度（如果已知）。
length() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
返回 -1L，指示流的长度未知。
length() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
length - 类 javax.sound.midi.MidiMessage 中的变量
MIDI 消息中的字节数，包括状态字节和数据字节。
length() - 类 javax.sql.rowset.serial.SerialBlob 中的方法
获取此 SerialBlob 对象字节数组中的字节数。
length() - 类 javax.sql.rowset.serial.SerialClob 中的方法
获取此 SerialClob 对象字节数组中的字节数。
length() - 接口 javax.swing.text.AbstractDocument.Content 中的方法
当前字符序列内容的长度。
length() - 类 javax.swing.text.GapContent 中的方法
返回内容的长度。
length() - 类 javax.swing.text.Segment 中的方法
返回此字符序列的长度。
length() - 类 javax.swing.text.StringContent 中的方法
返回内容的长度。
length() - 接口 org.omg.CORBA.DynSequence 中的方法
已过时。 返回此 DynFixed 对象表示的 sequence 长度。
length(int) - 接口 org.omg.CORBA.DynSequence 中的方法
已过时。 将此 DynFixed 对象所表示的 sequence 长度设置为给定参数。
length() - 类 org.omg.CORBA.TypeCode 中的方法
返回此 TypeCode 对象所描述类型中的成员数。
leq(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于两个值的“小于或等于”约束条件。
LESS_THAN_MIN_ROLE_DEGREE - 类 javax.management.relation.RoleStatus 中的静态变量
试图用比最小期望容量更少的 ObjectName 设置角色值时的问题类型。
LESSER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
比较结果。
lessThanOrEquals(ResolutionSyntax) - 类 javax.print.attribute.ResolutionSyntax 中的方法
确定此分辨率属性的值是否小于或等于给定分辨率属性的值。
LETTER - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_LETTER 的别名。
LETTER - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 信纸尺寸，8.5 inch × 11 inch。
LETTER_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Nl”。
LETTER_SPACING - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LETTERLIKE_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Letterlike Symbols”Unicode 字符块的常量。
Level - java.util.logging 中的 类
Level 类定义了一组可用来控制日志输出的标准日志级别。
Level(String, int) - 类 java.util.logging.Level 的构造方法
使用给定的整数值创建一个指定的 Level。
Level(String, int, String) - 类 java.util.logging.Level 的构造方法
使用给定的整数值和给定的本地化资源名称创建一个指定的 Level。
LexicalHandler - org.xml.sax.ext 中的 接口
用于词法事件的 SAX2 扩展处理程序。
LI - 类 javax.swing.text.html.HTML.Tag 中的静态变量
LIFESPAN_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/LIFESPAN_POLICY_ID.java。
LifespanPolicy - org.omg.PortableServer 中的 接口
LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
LifespanPolicyOperations - org.omg.PortableServer 中的 接口
LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
LifespanPolicyValue - org.omg.PortableServer 中的 类
LifespanPolicyValue 可以具有以下值。
LifespanPolicyValue(int) - 类 org.omg.PortableServer.LifespanPolicyValue 的构造方法
LIGATURE - 类 java.awt.font.GlyphMetrics 中的静态变量
指示将多个字符表示成连字（例如，'fi' 或 'ffi'）的字形。
LIGATURES - 类 java.awt.font.TextAttribute 中的静态变量
启用可选连字的属性键。
LIGATURES_ON - 类 java.awt.font.TextAttribute 中的静态变量
请求标准可选连字。
LIGHT - 类 javax.swing.plaf.metal.MetalIconFactory 中的静态变量
LIGHT_GRAY - 类 java.awt.Color 中的静态变量
浅灰色。
lightGray - 类 java.awt.Color 中的静态变量
浅灰色。
lightHighlight - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的变量
lightHighlight - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的变量
lightHighlight - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
lightWeightPopupEnabled - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
lightWeightPopupEnabled - 类 javax.swing.ToolTipManager 中的变量
LIMBU - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Limbu”Unicode 字符块的常量。
limit() - 类 java.nio.Buffer 中的方法
返回此缓冲区的限制。
limit(int) - 类 java.nio.Buffer 中的方法
设置此缓冲区的限制。
LimitExceededException - javax.naming 中的 异常
当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
LimitExceededException() - 异常 javax.naming.LimitExceededException 的构造方法
构造一个新的 LimitExceededException 实例，将解释和所有名称解析字段初始化为 null。
LimitExceededException(String) - 异常 javax.naming.LimitExceededException 的构造方法
使用解释构造一个新的 LimitExceededException 实例。
LINE - 接口 javax.accessibility.AccessibleExtendedText 中的静态变量
用于指示应被检索的文本部分是单行文本的常量。
Line - javax.sound.sampled 中的 接口
Line 接口表示单声道或多声道音频供给。
Line.Info - javax.sound.sampled 中的 类
Line.Info 对象包含关于行的信息。
Line.Info(Class<?>) - 类 javax.sound.sampled.Line.Info 的构造方法
构造描述指定类的行的 info 对象。
Line2D - java.awt.geom 中的 类
Line2D 表示 (x,y) 坐标空间中的线段。
Line2D() - 类 java.awt.geom.Line2D 的构造方法
这是一个无法直接实例化的抽象类。
Line2D.Double - java.awt.geom 中的 类
使用 double 坐标指定的线段。
Line2D.Double() - 类 java.awt.geom.Line2D.Double 的构造方法
使用坐标 (0, 0) -> (0, 0) 构造并初始化一个 Line。
Line2D.Double(double, double, double, double) - 类 java.awt.geom.Line2D.Double 的构造方法
根据指定坐标构造并初始化 Line2D。
Line2D.Double(Point2D, Point2D) - 类 java.awt.geom.Line2D.Double 的构造方法
根据指定的 Point2D 对象构造并初始化 Line2D。
Line2D.Float - java.awt.geom 中的 类
使用 float 坐标指定的线段。
Line2D.Float() - 类 java.awt.geom.Line2D.Float 的构造方法
使用坐标 (0, 0) -> (0, 0) 构造并初始化一个 Line。
Line2D.Float(float, float, float, float) - 类 java.awt.geom.Line2D.Float 的构造方法
根据指定坐标构造并初始化 Line。
Line2D.Float(Point2D, Point2D) - 类 java.awt.geom.Line2D.Float 的构造方法
根据指定的 Point2D 对象构造并初始化 Line2D。
LINE_AXIS - 类 javax.swing.BoxLayout 中的静态变量
指定应该根据目标容器的 ComponentOrientation 属性确定的文本行方向放置组件。
LINE_END - 类 java.awt.BorderLayout 中的静态变量
组件出现在布局的行方向的结尾处。
LINE_END - 类 java.awt.GridBagConstraints 中的静态变量
沿显示区域的边缘居中放置组件，在该区域中，当前 ComponentOrienation 的文本行正常结束。
LINE_HEIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LINE_IN - 类 javax.sound.sampled.Port.Info 中的静态变量
从线路级音频输入插孔获得音频端口类型。
LINE_OUT - 类 javax.sound.sampled.Port.Info 中的静态变量
向线路级音频输出插孔发送音频端口类型。
LINE_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Zl”。
LINE_START - 类 java.awt.BorderLayout 中的静态变量
组件出现在布局的行方向的开始处。
LINE_START - 类 java.awt.GridBagConstraints 中的静态变量
沿显示区域的边缘居中放置组件，在该区域中，当前 ComponentOrienation 的文本行正常开始。
LINEAR_B_IDEOGRAMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Linear B Ideograms”Unicode 字符块的常量。
LINEAR_B_SYLLABARY - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Linear B Syllabary”Unicode 字符块的常量。
LinearGradientPaint - java.awt 中的 类
LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
LinearGradientPaint(float, float, float, float, float[], Color[]) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(float, float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D, Point2D, float[], Color[]) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod, MultipleGradientPaint.ColorSpaceType, AffineTransform) - 类 java.awt.LinearGradientPaint 的构造方法
构造一个 LinearGradientPaint。
LineBorder - javax.swing.border 中的 类
实现单色、任意厚度线边框的类。
LineBorder(Color) - 类 javax.swing.border.LineBorder 的构造方法
创建具有指定颜色、厚度为 1（thickness = 1）的线边框。
LineBorder(Color, int) - 类 javax.swing.border.LineBorder 的构造方法
创建具有指定颜色和厚度的线边框。
LineBorder(Color, int, boolean) - 类 javax.swing.border.LineBorder 的构造方法
创建具有指定颜色、厚度和拐角形状的线条边框。
LineBreakMeasurer - java.awt.font 中的 类
LineBreakMeasurer 类允许将样式化的文本断为行（或段），以符合特定的可视 advance。
LineBreakMeasurer(AttributedCharacterIterator, FontRenderContext) - 类 java.awt.font.LineBreakMeasurer 的构造方法
为指定的文本构造一个 LineBreakMeasurer。
LineBreakMeasurer(AttributedCharacterIterator, BreakIterator, FontRenderContext) - 类 java.awt.font.LineBreakMeasurer 的构造方法
为指定的文本构造一个 LineBreakMeasurer。
lineColor - 类 javax.swing.border.LineBorder 中的变量
LineEvent - javax.sound.sampled 中的 类
LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。
LineEvent(Line, LineEvent.Type, long) - 类 javax.sound.sampled.LineEvent 的构造方法
构造源自指定行的指定类型的新事件。
LineEvent.Type - javax.sound.sampled 中的 类
该 LineEvent.Type 内部类标识行上所发生事件的种类。
LineEvent.Type(String) - 类 javax.sound.sampled.LineEvent.Type 的构造方法
构造新的事件类型。
lineLimitAttribute - 类 javax.swing.text.PlainDocument 中的静态变量
指定行的最大长度的属性名称（如果有最大长度）。
LineListener - javax.sound.sampled 中的 接口
可以注册实现 LineListener 接口的类的实例来接收行状态更改时发生的事件。
LineMetrics - java.awt.font 中的 类
LineMetrics 类允许访问沿着一行布局字符和多行布局所需要的规格。
LineMetrics() - 类 java.awt.font.LineMetrics 的构造方法
lineno() - 类 java.io.StreamTokenizer 中的方法
返回当前行号。
LineNumberInputStream - java.io 中的 类
已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
LineNumberInputStream(InputStream) - 类 java.io.LineNumberInputStream 的构造方法
已过时。 构造从指定输入流读取其输入的新行号输入流。
LineNumberReader - java.io 中的 类
跟踪行号的缓冲字符输入流。
LineNumberReader(Reader) - 类 java.io.LineNumberReader 的构造方法
使用默认输入缓冲区的大小创建新的行编号 reader。
LineNumberReader(Reader, int) - 类 java.io.LineNumberReader 的构造方法
创建新的行编号 reader，将字符读入给定大小的缓冲区。
linesIntersect(double, double, double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
测试从 (x1,y1) 到 (x2,y2) 的线段是否与从 (x3,y3) 到 (x4,y4) 的线段相交。
LineSpacing - 类 javax.swing.text.StyleConstants 中的静态变量
段落的行之间的空间量。
lineTo(double, double) - 类 java.awt.geom.Path2D.Double 中的方法
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
lineTo(double, double) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
lineTo(float, float) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制一条从当前坐标到指定新坐标（以 float 精度指定）的直线，将一个点添加到路径中。
lineTo(double, double) - 类 java.awt.geom.Path2D 中的方法
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
lineToRect(Shape, int) - 类 javax.swing.text.PlainView 中的方法
确定表示给定行的矩形。
LineUnavailableException - javax.sound.sampled 中的 异常
LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
LineUnavailableException() - 异常 javax.sound.sampled.LineUnavailableException 的构造方法
构造将 null 作为错误详细消息的 LineUnavailableException。
LineUnavailableException(String) - 异常 javax.sound.sampled.LineUnavailableException 的构造方法
构造具有指定详细消息的 LineUnavailableException。
LINK - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
LINK - 类 javax.swing.text.html.HTML.Tag 中的静态变量
LINK - 类 javax.swing.TransferHandler 中的静态变量
表示“链接”传输动作的 int 值。
LinkageError - java.lang 中的 错误
LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
LinkageError() - 错误 java.lang.LinkageError 的构造方法
构造不带详细消息的 LinkageError 类。
LinkageError(String) - 错误 java.lang.LinkageError 的构造方法
构造带指定详细消息的 LinkageError 类。
LinkedBlockingDeque<E> - java.util.concurrent 中的 类
一个基于已链接节点的、任选范围的阻塞双端队列。
LinkedBlockingDeque() - 类 java.util.concurrent.LinkedBlockingDeque 的构造方法
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque。
LinkedBlockingDeque(int) - 类 java.util.concurrent.LinkedBlockingDeque 的构造方法
创建一个具有给定（固定）容量的 LinkedBlockingDeque。
LinkedBlockingDeque(Collection<? extends E>) - 类 java.util.concurrent.LinkedBlockingDeque 的构造方法
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque，最初包含给定 collection 的元素，以该 collection 迭代器的遍历顺序添加。
LinkedBlockingQueue<E> - java.util.concurrent 中的 类
一个基于已链接节点的、范围任意的 blocking queue。
LinkedBlockingQueue() - 类 java.util.concurrent.LinkedBlockingQueue 的构造方法
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingQueue。
LinkedBlockingQueue(int) - 类 java.util.concurrent.LinkedBlockingQueue 的构造方法
创建一个具有给定（固定）容量的 LinkedBlockingQueue。
LinkedBlockingQueue(Collection<? extends E>) - 类 java.util.concurrent.LinkedBlockingQueue 的构造方法
创建一个容量是 Integer.MAX_VALUE 的 LinkedBlockingQueue，最初包含给定 collection 的元素，元素按该 collection 迭代器的遍历顺序添加。
LinkedHashMap<K,V> - java.util 中的 类
Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
LinkedHashMap(int, float) - 类 java.util.LinkedHashMap 的构造方法
构造一个带指定初始容量和加载因子的空插入顺序 LinkedHashMap 实例。
LinkedHashMap(int) - 类 java.util.LinkedHashMap 的构造方法
构造一个带指定初始容量和默认加载因子 (0.75) 的空插入顺序 LinkedHashMap 实例。
LinkedHashMap() - 类 java.util.LinkedHashMap 的构造方法
构造一个带默认初始容量 (16) 和加载因子 (0.75) 的空插入顺序 LinkedHashMap 实例。
LinkedHashMap(Map<? extends K, ? extends V>) - 类 java.util.LinkedHashMap 的构造方法
构造一个映射关系与指定映射相同的插入顺序 LinkedHashMap 实例。
LinkedHashMap(int, float, boolean) - 类 java.util.LinkedHashMap 的构造方法
构造一个带指定初始容量、加载因子和排序模式的空 LinkedHashMap 实例。
LinkedHashSet<E> - java.util 中的 类
具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
LinkedHashSet(int, float) - 类 java.util.LinkedHashSet 的构造方法
构造一个带有指定初始容量和加载因子的新空链接哈希 set。
LinkedHashSet(int) - 类 java.util.LinkedHashSet 的构造方法
构造一个带指定初始容量和默认加载因子 (0.75) 的新空链接哈希 set。
LinkedHashSet() - 类 java.util.LinkedHashSet 的构造方法
构造一个带默认初始容量 (16) 和加载因子 (0.75) 的新空链接哈希 set。
LinkedHashSet(Collection<? extends E>) - 类 java.util.LinkedHashSet 的构造方法
构造一个与指定 collection 中的元素相同的新链接哈希 set。
LinkedList<E> - java.util 中的 类
List 接口的链接列表实现。
LinkedList() - 类 java.util.LinkedList 的构造方法
构造一个空列表。
LinkedList(Collection<? extends E>) - 类 java.util.LinkedList 的构造方法
构造一个包含指定 collection 中的元素的列表，这些元素按其 collection 的迭代器返回的顺序排列。
LinkException - javax.naming 中的 异常
此异常用于描述解析链接时遇到的问题。
LinkException(String) - 异常 javax.naming.LinkException 的构造方法
使用解释构造一个新的 LinkException 实例，其他所有字段都初始化为 null。
LinkException() - 异常 javax.naming.LinkException 的构造方法
构造一个新的 LinkException 实例。
linkExplanation - 异常 javax.naming.LinkException 中的变量
包含链接解析失败原因的异常。
LinkLoopException - javax.naming 中的 异常
当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
LinkLoopException(String) - 异常 javax.naming.LinkLoopException 的构造方法
使用解释构造一个新的 LinkLoopException 实例，其他所有字段都被初始化为 null。
LinkLoopException() - 异常 javax.naming.LinkLoopException 的构造方法
构造一个新的 LinkLoopException 实例。
LinkRef - javax.naming 中的 类
此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。
LinkRef(Name) - 类 javax.naming.LinkRef 的构造方法
为某一名称构造一个 LinkRef。
LinkRef(String) - 类 javax.naming.LinkRef 的构造方法
为某一字符串名称构造一个 LinkRef。
linkRemainingName - 异常 javax.naming.LinkException 中的变量
包含尚未解析的剩余链接名称。
linkResolvedName - 异常 javax.naming.LinkException 中的变量
包含已成功解析的链接部分。
linkResolvedObj - 异常 javax.naming.LinkException 中的变量
包含一个对象，已成功解析的链接部分一直到达该对象。
linkSize(Component...) - 类 javax.swing.GroupLayout 中的方法
将指定组件强制调整为具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
linkSize(int, Component...) - 类 javax.swing.GroupLayout 中的方法
将指定组件强制调整为沿指定轴具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
list() - 类 java.awt.Component 中的方法
将组件列表打印到标准系统输出流 System.out。
list(PrintStream) - 类 java.awt.Component 中的方法
将组件列表打印到指定的输出流。
list(PrintStream, int) - 类 java.awt.Component 中的方法
将列表从指定的缩排开始打印到指定的打印流。
list(PrintWriter) - 类 java.awt.Component 中的方法
将列表打印到指定的打印编写器。
list(PrintWriter, int) - 类 java.awt.Component 中的方法
将列表从指定的缩排开始打印到指定的打印编写器。
list(PrintStream, int) - 类 java.awt.Container 中的方法
将此容器的清单打印到指定输出流。
list(PrintWriter, int) - 类 java.awt.Container 中的方法
将一个列表打印到指定打印编写器，从指定缩排位置开始。
List - java.awt 中的 类
List 组件为用户提供了一个可滚动的文本项列表。
List() - 类 java.awt.List 的构造方法
创建新的滚动列表。
List(int) - 类 java.awt.List 的构造方法
创建一个用指定可视行数初始化的新滚动列表。
List(int, boolean) - 类 java.awt.List 的构造方法
创建一个初始化为显示指定行数的新滚动列表。
list() - 类 java.io.File 中的方法
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中的文件和目录。
list(FilenameFilter) - 类 java.io.File 中的方法
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中满足指定过滤器的文件和目录。
list() - 类 java.lang.ThreadGroup 中的方法
将有关此线程组的信息打印到标准输出。
list(String) - 类 java.rmi.Naming 中的静态方法
返回在注册表中绑定的名称所组成的数组。
list() - 接口 java.rmi.registry.Registry 中的方法
返回在此注册表中绑定的名称的数组。
list(Enumeration<T>) - 类 java.util.Collections 中的静态方法
返回一个数组列表，它按返回顺序包含指定枚举返回的元素。
List<E> - java.util 中的 接口
有序的 collection（也称为序列）。
list(PrintStream) - 类 java.util.Properties 中的方法
将属性列表输出到指定的输出流。
list(PrintWriter) - 类 java.util.Properties 中的方法
将属性列表输出到指定的输出流。
LIST - 类 javax.accessibility.AccessibleRole 中的静态变量
呈现给用户一个对象列表的对象，它还允许用户从中选择一个或多个对象。
list(Name) - 接口 javax.naming.Context 中的方法
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
list(String) - 接口 javax.naming.Context 中的方法
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
list(String) - 类 javax.naming.InitialContext 中的方法
list(Name) - 类 javax.naming.InitialContext 中的方法
list - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
list - 类 javax.swing.plaf.basic.BasicListUI 中的变量
LIST - 类 javax.swing.plaf.synth.Region 中的静态变量
List 的 region。
list(JavaFileManager.Location, String, Set<JavaFileObject.Kind>, boolean) - 类 javax.tools.ForwardingJavaFileManager 中的方法
list(JavaFileManager.Location, String, Set<JavaFileObject.Kind>, boolean) - 接口 javax.tools.JavaFileManager 中的方法
列出给定位置处符合给定标准的所有文件对象。
list(int, BindingListHolder, BindingIteratorHolder) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
列表操作允许客户端迭代命名上下文中的一组绑定。
list(int, BindingListHolder, BindingIteratorHolder) - 类 org.omg.CosNaming._NamingContextStub 中的方法
列表操作允许客户端迭代命名上下文中的一组绑定。
list(int, BindingListHolder, BindingIteratorHolder) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
list 操作允许客户端迭代命名上下文中的一组绑定。
List.AccessibleAWTList - java.awt 中的 类
此类实现 List 类的可访问性支持。
List.AccessibleAWTList() - 类 java.awt.List.AccessibleAWTList 的构造方法
List.AccessibleAWTList.AccessibleAWTListChild - java.awt 中的 类
此类实现 List 子级的可访问性支持。
List.AccessibleAWTList.AccessibleAWTListChild(List, int) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 的构造方法
LIST_DESELECT - 类 java.awt.Event 中的静态变量
已经取消选择列表中的一项。
list_initial_services() - 类 org.omg.CORBA.ORB 中的方法
返回最初可用 CORBA 对象引用（比如 "NameService" 和 "InterfaceRepository"）的列表。
LIST_ITEM - 类 javax.accessibility.AccessibleRole 中的静态变量
呈现列表元素的对象。
LIST_SELECT - 类 java.awt.Event 中的静态变量
已经选择了列表中的一项。
LIST_STYLE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LIST_STYLE_IMAGE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LIST_STYLE_POSITION - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
LIST_STYLE_TYPE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
listBindings(Name) - 接口 javax.naming.Context 中的方法
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
listBindings(String) - 接口 javax.naming.Context 中的方法
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
listBindings(String) - 类 javax.naming.InitialContext 中的方法
listBindings(Name) - 类 javax.naming.InitialContext 中的方法
listBox - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
listBox - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
ListCellRenderer - javax.swing 中的 接口
标识可用作“橡皮图章”以绘制 JList 中单元格的组件。
ListDataEvent - javax.swing.event 中的 类
定义一个封装列表更改的事件。
ListDataEvent(Object, int, int, int) - 类 javax.swing.event.ListDataEvent 的构造方法
构造一个 ListDataEvent 对象。
ListDataListener - javax.swing.event 中的 接口
ListDataListener
listDataListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
listDataListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
listDataListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
listen(int) - 类 java.net.SocketImpl 中的方法
将传入连接指示（连接请求）的最大队列长度设置为 count 参数。
listenerList - 类 javax.swing.AbstractCellEditor 中的变量
listenerList - 类 javax.swing.AbstractListModel 中的变量
listenerList - 类 javax.swing.AbstractSpinnerModel 中的变量
此模型的 ChangeListener 列表。
listenerList - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的变量
listenerList - 类 javax.swing.DefaultBoundedRangeModel 中的变量
等待模型更改的侦听器。
listenerList - 类 javax.swing.DefaultButtonModel 中的变量
在此模型中存储侦听器。
listenerList - 类 javax.swing.DefaultListSelectionModel 中的变量
listenerList - 类 javax.swing.DefaultSingleSelectionModel 中的变量
已注册侦听器的集合
listenerList - 类 javax.swing.event.EventListenerList 中的变量
listenerList - 类 javax.swing.JComponent 中的变量
此组件的事件侦听器列表。
listenerList - 类 javax.swing.MenuSelectionManager 中的变量
listenerList - 类 javax.swing.table.AbstractTableModel 中的变量
侦听器的列表
listenerList - 类 javax.swing.table.DefaultTableColumnModel 中的变量
TableColumnModelListener 的列表
listenerList - 类 javax.swing.text.AbstractDocument 中的变量
文档的事件侦听器列表。
listenerList - 类 javax.swing.text.DefaultCaret 中的变量
事件侦听器列表。
listenerList - 类 javax.swing.text.StyleContext.NamedStyle 中的变量
模型的更改侦听器。
listenerList - 类 javax.swing.Timer 中的变量
listenerList - 类 javax.swing.tree.DefaultTreeModel 中的变量
侦听器。
listenerList - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
事件侦听器列表。
ListenerNotFoundException - javax.management 中的 异常
存储库中不存在指定的 MBean 侦听器。
ListenerNotFoundException() - 异常 javax.management.ListenerNotFoundException 的构造方法
默认的构造方法。
ListenerNotFoundException(String) - 异常 javax.management.ListenerNotFoundException 的构造方法
允许指定特定错误消息的构造方法。
listeners - 类 javax.swing.undo.UndoableEditSupport 中的变量
listFiles() - 类 java.io.File 中的方法
返回一个抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件。
listFiles(FilenameFilter) - 类 java.io.File 中的方法
返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
listFiles(FileFilter) - 类 java.io.File 中的方法
返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
listIterator() - 类 java.util.AbstractList 中的方法
返回此列表元素的列表迭代器（按适当顺序）。
listIterator(int) - 类 java.util.AbstractList 中的方法
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
listIterator(int) - 类 java.util.AbstractSequentialList 中的方法
返回在此列表中的元素上进行迭代的列表迭代器（按适当顺序）。
listIterator() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表元素的列表迭代器（按适当顺序）。
listIterator(int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
listIterator(int) - 类 java.util.LinkedList 中的方法
返回此列表中的元素的列表迭代器（按适当顺序），从列表中指定位置开始。
listIterator() - 接口 java.util.List 中的方法
返回此列表元素的列表迭代器（按适当顺序）。
listIterator(int) - 接口 java.util.List 中的方法
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
ListIterator<E> - java.util 中的 接口
系列表迭代器，允许程序员按任一方向遍历列表、迭代期间修改列表，并获得迭代器在列表中的当前位置。
ListModel - javax.swing 中的 接口
此接口定义方法组件（如 JList），这些组件用于获取列表中每个单元格的值以及列表的长度。
listMouseListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
listMouseMotionListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
ListResourceBundle - java.util 中的 类
ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。
ListResourceBundle() - 类 java.util.ListResourceBundle 的构造方法
单独的构造方法。
listRoots() - 类 java.io.File 中的静态方法
列出可用的文件系统根。
ListSelectionEvent - javax.swing.event 中的 类
表现选择中更改的特征的事件。
ListSelectionEvent(Object, int, int, boolean) - 类 javax.swing.event.ListSelectionEvent 的构造方法
表示 firstIndex 与 lastIndex（包括两者）范围内的选择状态的更改。
ListSelectionListener - javax.swing.event 中的 接口
列表选择值发生更改时收到通知的侦听器。
listSelectionListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
listSelectionListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
ListSelectionModel - javax.swing 中的 接口
此接口表示任何组件的当前选择状态，该组件显示一个具有稳定索引的值列表。
listSelectionModel - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
维护列表选择模型的句柄。
ListUI - javax.swing.plaf 中的 类
JList 的可插入外观代理。
ListUI() - 类 javax.swing.plaf.ListUI 的构造方法
ListView - javax.swing.text.html 中的 类
用于显示 html 列表的视图实现。
ListView(Element) - 类 javax.swing.text.html.ListView 的构造方法
创建表示列表元素的新视图。
listViewIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
LITERAL - 类 java.util.regex.Pattern 中的静态变量
启用模式的字面值解析。
LITTLE_ENDIAN - 类 java.nio.ByteOrder 中的静态变量
表示 little-endian 字节顺序的常量。
LIVE_DRAG_MODE - 类 javax.swing.JDesktopPane 中的静态变量
指示正在被拖动项的所有内容是否应该出现在桌面窗格内部。
LOAD - 类 java.awt.FileDialog 中的静态变量
此常量值指示文件对话框窗口的作用是查找要读取的文件。
load(String) - 类 java.lang.Runtime 中的方法
加载作为动态库的指定文件名。
load(String) - 类 java.lang.System 中的静态方法
从作为动态库的本地文件系统中以指定的文件名加载代码文件。
load() - 类 java.nio.MappedByteBuffer 中的方法
将此缓冲区内容加载到物理内存中。
load(InputStream, char[]) - 类 java.security.KeyStore 中的方法
从给定输入流中加载此 KeyStore。
load(KeyStore.LoadStoreParameter) - 类 java.security.KeyStore 中的方法
使用给定 LoadStoreParameter 加载此 keystore。
load(InputStream) - 类 java.security.Provider 中的方法
从输入流中读取属性列表（键和元素对）。
load(Reader) - 类 java.util.Properties 中的方法
按简单的面向行的格式从输入字符流中读取属性列表（键和元素对）。
load(InputStream) - 类 java.util.Properties 中的方法
从输入流中读取属性列表（键和元素对）。
load(Class<S>, ClassLoader) - 类 java.util.ServiceLoader 中的静态方法
针对给定服务类型和类加载器创建新的服务加载器。
load(Class<S>) - 类 java.util.ServiceLoader 中的静态方法
针对给定服务类型创建新的服务加载器，使用当前线程的上下文类加载器。
load() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
使用在持久存储中找到的 MBean 的数据实例化此 MBean。
load() - 接口 javax.management.PersistentMBean 中的方法
使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
load(InputStream, Class<?>) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。
load(URL) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。
LOAD_FILE - 类 java.awt.Event 中的静态变量
文件加载事件。
loadAllInstruments(Soundbank) - 接口 javax.sound.midi.Synthesizer 中的方法
将指定 Soundbank 中包含的所有乐器加载到 Synthesizer 中。
loadChildren() - 类 javax.swing.JTree.DynamicUtilTreeNode 中的方法
根据 childValue 加载子节点。
loadChildren(ViewFactory) - 类 javax.swing.text.AsyncBoxView 中的方法
加载初始化该视图的所有子级。
loadChildren(ViewFactory) - 类 javax.swing.text.CompositeView 中的方法
加载所有的子级以初始化该视图。
loadChildren(ViewFactory) - 类 javax.swing.text.FlowView 中的方法
加载初始化该视图的所有子级。
loadChildren(ViewFactory) - 类 javax.swing.text.WrappedPlainView 中的方法
加载所有子级来初始化视图。
loadChildren(ViewFactory) - 类 javax.swing.text.ZoneView 中的方法
加载所有子级来初始化视图。
loadClass(String) - 类 java.lang.ClassLoader 中的方法
使用指定的二进制名称来加载类。
loadClass(String, boolean) - 类 java.lang.ClassLoader 中的方法
使用指定的二进制名称来加载类。
loadClass(String) - 接口 java.rmi.server.LoaderHandler 中的方法
已过时。 无替代版本
loadClass(URL, String) - 接口 java.rmi.server.LoaderHandler 中的方法
已过时。 无替代版本
loadClass(String) - 类 java.rmi.server.RMIClassLoader 中的静态方法
已过时。 由 loadClass(String,String) 方法取代
loadClass(URL, String) - 类 java.rmi.server.RMIClassLoader 中的静态方法
从基本代码 URL 加载类。
loadClass(String, String) - 类 java.rmi.server.RMIClassLoader 中的静态方法
从基本代码 URL 路径加载类。
loadClass(String, String, ClassLoader) - 类 java.rmi.server.RMIClassLoader 中的静态方法
有选择地使用提供的加载器从基本代码 URL 路径加载类。
loadClass(String, String, ClassLoader) - 类 java.rmi.server.RMIClassLoaderSpi 中的方法
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
loadClass(String) - 类 javax.management.DefaultLoaderRepository 中的静态方法
已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
loadClass(String) - 接口 javax.management.loading.ClassLoaderRepository 中的方法
通过类加载器列表加载给定的类名称。
loadClass(String) - 类 javax.management.loading.DefaultLoaderRepository 中的静态方法
已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
loadClass(String, ClassLoaderRepository) - 类 javax.management.loading.MLet 中的方法
如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。
loadClass(String, String, ClassLoader) - 类 javax.rmi.CORBA.Util 中的静态方法
为指定的类返回一个类实例。
loadClass(String, String, ClassLoader) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。
loadClassBefore(ClassLoader, String) - 接口 javax.management.loading.ClassLoaderRepository 中的方法
通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
loadClassWithout(ClassLoader, String) - 类 javax.management.DefaultLoaderRepository 中的静态方法
已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。
loadClassWithout(ClassLoader, String) - 接口 javax.management.loading.ClassLoaderRepository 中的方法
通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。
loadClassWithout(ClassLoader, String) - 类 javax.management.loading.DefaultLoaderRepository 中的静态方法
已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。
loadedChildren - 类 javax.swing.JTree.DynamicUtilTreeNode 中的变量
是否已加载此子节点？
LoaderHandler - java.rmi.server 中的 接口
已过时。 无替代版本
loadFromXML(InputStream) - 类 java.util.Properties 中的方法
将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。
loadImage(String) - 类 java.beans.SimpleBeanInfo 中的方法
这是帮助加载图标图像的实用工具方法。
loadImage(Image) - 类 javax.swing.ImageIcon 中的方法
加载图像，并且只在图像已加载时返回。
LOADING - 类 java.awt.MediaTracker 中的静态变量
指示当前正在加载媒体的标志。
loadInstalled(Class<S>) - 类 java.util.ServiceLoader 中的静态方法
针对给定服务类型创建新的服务加载器，使用扩展类加载器。
loadInstrument(Instrument) - 接口 javax.sound.midi.Synthesizer 中的方法
让特定的乐器可用于合成。
loadInstruments(Soundbank, Patch[]) - 接口 javax.sound.midi.Synthesizer 中的方法
从指定 Soundbank 加载指定修补程序所引用的乐器。
loadKeyBindings(InputMap, Object[]) - 类 javax.swing.LookAndFeel 中的静态方法
使用指定绑定填充 InputMap。
loadKeymap(Keymap, JTextComponent.KeyBinding[], Action[]) - 类 javax.swing.text.JTextComponent 中的静态方法
加载带有一组绑定的 keymap。
loadLibrary(String) - 类 java.lang.Runtime 中的方法
加载具有指定库名的动态库。
loadLibrary(String) - 类 java.lang.System 中的静态方法
加载由 libname 参数指定的系统库。
loadProxyClass(String, String[], ClassLoader) - 类 java.rmi.server.RMIClassLoader 中的静态方法
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
loadProxyClass(String, String[], ClassLoader) - 类 java.rmi.server.RMIClassLoaderSpi 中的方法
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。
loadRules(Reader, URL) - 类 javax.swing.text.html.StyleSheet 中的方法
加载 CSS1 语法中指定的规则集合。
loadSystemColors(int[]) - 类 java.awt.Toolkit 中的方法
使用当前系统颜色值填充作为参数提供的整数数组。
loadSystemColors(UIDefaults, String[], boolean) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
用 systemColors 中的 name-color 对填充 table。
localControl(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
打开或关闭本地控制。
locale - 类 java.beans.beancontext.BeanContextSupport 中的变量
此 BeanContext 的当前语言环境。
locale() - 类 java.util.Formatter 中的方法
返回构造此 formatter 时设置的语言环境。
Locale - java.util 中的 类
Locale 对象表示了特定的地理、政治和文化地区。
Locale(String, String, String) - 类 java.util.Locale 的构造方法
根据语言、国家/地区和变量构造一个语言环境。
Locale(String, String) - 类 java.util.Locale 的构造方法
根据语言和国家/地区构造一个语言环境。
Locale(String) - 类 java.util.Locale 的构造方法
根据语言代码构造一个语言环境。
locale() - 类 java.util.Scanner 中的方法
返回此扫描器的语言环境。
locale - 类 javax.imageio.ImageReader 中的变量
用于本地化的当前 Locale，如果没有设置，则为 null。
locale - 类 javax.imageio.ImageWriteParam 中的变量
用于本地化压缩类型名称和质量描述的 Locale，null 表示使用默认 Locale。
locale - 类 javax.imageio.ImageWriter 中的变量
用于本地化的当前 Locale，如果没有设置 Locale，则将它初始化为 null。
LocaleNameProvider - java.util.spi 中的 类
为 Locale 类提供本地化名称的服务提供者的一个抽象类。
LocaleNameProvider() - 类 java.util.spi.LocaleNameProvider 的构造方法
唯一的构造方法。
LocaleServiceProvider - java.util.spi 中的 类
此类是所有与语言环境有关的服务提供者接口（SPI）的超类。
LocaleServiceProvider() - 类 java.util.spi.LocaleServiceProvider 的构造方法
唯一的构造方法。
LocalObject - org.omg.CORBA 中的 类
用作 Java 语言映射中的本地 IDL 接口实现的基本类。
LocalObject() - 类 org.omg.CORBA.LocalObject 的构造方法
构造一个默认 LocalObject 实例。
localPort - 类 java.net.DatagramSocketImpl 中的变量
本地端口号。
localport - 类 java.net.SocketImpl 中的变量
此套接字连接到的本地端口号。
locate(int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。
locate(int, int) - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。
LocateRegistry - java.rmi.registry 中的 类
LocateRegistry 用于获得对特定主机（包括本地主机）上引导远程对象注册表的引用，或用于创建一个接受对特定端口调用的远程对象注册表。
location() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getLocation() 取代。
location(int, int) - 类 java.awt.GridBagLayout 中的方法
确定在布局网格中哪个单元包含由 (x, y) 指定的点。
Location - javax.xml.stream 中的 接口
提供有关事件位置的信息。
location - 异常 javax.xml.stream.XMLStreamException 中的变量
LOCATION_FORWARD - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/LOCATION_FORWARD.java。
locationFor(String) - 枚举 javax.tools.StandardLocation 中的静态方法
使用给定名称获取位置对象。
locationToIndex(Point) - 类 javax.swing.JList 中的方法
返回最接近列表的坐标系统中给定位置的单元索引。
locationToIndex(JList, Point) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
locationToIndex(JList, Point) - 类 javax.swing.plaf.ListUI 中的方法
返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
locationToIndex(JList, Point) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 locationToIndex 方法。
locator - 类 javax.swing.text.AsyncBoxView 中的变量
这是管理子视图偏移量的对象。
Locator - org.xml.sax 中的 接口
用来将 SAX 事件与文档位置关联的接口。
Locator2 - org.xml.sax.ext 中的 接口
SAX2 扩展，用于扩充通过 Locator 提供的实体信息。
Locator2Impl - org.xml.sax.ext 中的 类
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。
Locator2Impl() - 类 org.xml.sax.ext.Locator2Impl 的构造方法
构造一个新的空 Locator2Impl 对象。
Locator2Impl(Locator) - 类 org.xml.sax.ext.Locator2Impl 的构造方法
复制现有 Locator 或 Locator2 对象。
LocatorImpl - org.xml.sax.helpers 中的 类
提供 Locator 的可选的有用实现。
LocatorImpl() - 类 org.xml.sax.helpers.LocatorImpl 的构造方法
零参数的构造方法。
LocatorImpl(Locator) - 类 org.xml.sax.helpers.LocatorImpl 的构造方法
复制构造方法。
locatorsUpdateCopy() - 接口 java.sql.DatabaseMetaData 中的方法
指示对 LOB 的更新是在副本上进行还是直接更新到 LOB。
lock - 类 java.io.Reader 中的变量
用于同步针对此流的操作的对象。
lock - 类 java.io.Writer 中的变量
用于同步针对此流的操作的对象。
lock(long, long, boolean) - 类 java.nio.channels.FileChannel 中的方法
获取此通道的文件给定区域上的锁定。
lock() - 类 java.nio.channels.FileChannel 中的方法
获取对此通道的文件的独占锁定。
Lock - java.util.concurrent.locks 中的 接口
Lock 实现提供了比使用 synchronized 方法和语句可获得的更广泛的锁定操作。
lock() - 接口 java.util.concurrent.locks.Lock 中的方法
获取锁。
lock() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
获取锁。
lock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
获取读取锁。
lock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
获取写入锁。
lock - 类 java.util.prefs.AbstractPreferences 中的变量
使用其监视器锁定此节点的对象。
LockInfo - java.lang.management 中的 类
关于锁 的信息。
LockInfo(String, int) - 类 java.lang.management.LockInfo 的构造方法
构造一个 LockInfo 对象。
lockInterruptibly() - 接口 java.util.concurrent.locks.Lock 中的方法
如果当前线程未被中断，则获取锁。
lockInterruptibly() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
如果当前线程未被中断，则获取锁。
lockInterruptibly() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
获取读取锁，除非当前线程被中断。
lockInterruptibly() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
获取写入锁，除非当前线程被中断。
LockSupport - java.util.concurrent.locks 中的 类
用来创建锁和其他同步类的基本线程阻塞原语。
log(double) - 类 java.lang.Math 中的静态方法
返回 double 值的自然对数（底数是 e）。
log(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的自然对数（底数为 e）。
log(String) - 类 java.rmi.server.LogStream 中的静态方法
已过时。 无替代版本
log(LogRecord) - 类 java.util.logging.Logger 中的方法
记录一条 LogRecord。
log(Level, String) - 类 java.util.logging.Logger 中的方法
记录一条不带参数的消息。
log(Level, String, Object) - 类 java.util.logging.Logger 中的方法
记录带有一个对象参数的消息。
log(Level, String, Object[]) - 类 java.util.logging.Logger 中的方法
记录带有一组对象参数的消息。
log(Level, String, Throwable) - 类 java.util.logging.Logger 中的方法
记录带有相关的可抛出信息的消息。
log10(double) - 类 java.lang.Math 中的静态方法
返回 double 值的底数为 10 的对数。
log10(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的底数为 10 的对数。
log1p(double) - 类 java.lang.Math 中的静态方法
返回参数与 1 之和的自然对数。
log1p(double) - 类 java.lang.StrictMath 中的静态方法
返回参数与 1 之和的自然对数。
LOG_OPTION - 类 javax.swing.DebugGraphics 中的静态变量
记录图形操作。
Logger - java.util.logging 中的 类
Logger 对象用来记录特定系统或应用程序组件的日志消息。
Logger(String, String) - 类 java.util.logging.Logger 的构造方法
受保护的方法，它用于为一个指定子系统的构造 logger。
LOGGING_MXBEAN_NAME - 类 java.util.logging.LogManager 中的静态变量
LoggingMXBean 的 ObjectName 的字符串表示形式。
LoggingMXBean - java.util.logging 中的 接口
日志记录设施的管理接口。
LoggingPermission - java.util.logging 中的 类
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。
LoggingPermission(String, String) - 类 java.util.logging.LoggingPermission 的构造方法
创建一个新的 LoggingPermission 对象。
LOGICAL_STYLE_ACTION - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
逻辑样式选择动作标识符（逻辑样式作为参数传递）
LogicalHandler<C extends LogicalMessageContext> - javax.xml.ws.handler 中的 接口
LogicalHandler 扩展了 Handler，以便为消息上下文参数提供输入安全性。
LogicalMessage - javax.xml.ws 中的 接口
LogicalMessage 接口表示协议无关的 (protocol agnostic) XML 消息，并包含一些方法提供对消息负载的访问。
LogicalMessageContext - javax.xml.ws.handler 中的 接口
LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。
login(Subject, CallbackHandler) - 类 java.security.AuthProvider 中的方法
登录到此 provider 中。
login() - 类 javax.security.auth.login.LoginContext 中的方法
执行验证。
login() - 接口 javax.security.auth.spi.LoginModule 中的方法
对 Subject 进行验证的方法（阶段 1）。
LoginContext - javax.security.auth.login 中的 类
LoginContext 类描述用于验证 Subjects 的基本方法和提供开发与底层验证技术无关的应用程序的方法。
LoginContext(String) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name 实例化一个新 LoginContext 对象。
LoginContext(String, Subject) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。
LoginContext(String, CallbackHandler) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String, Subject, CallbackHandler) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String, Subject, CallbackHandler, Configuration) - 类 javax.security.auth.login.LoginContext 的构造方法
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。
LoginException - javax.security.auth.login 中的 异常
此异常是基本的登录异常。
LoginException() - 异常 javax.security.auth.login.LoginException 的构造方法
构造不带详细消息的 LoginException。
LoginException(String) - 异常 javax.security.auth.login.LoginException 的构造方法
构造带指定详细消息的 LoginException。
LoginModule - javax.security.auth.spi 中的 接口
LoginModule 描述由验证技术提供者实现的接口。
LogManager - java.util.logging 中的 类
存在一个单一的全局 LogManager 对象，它可用于维护 Logger 和日志服务的一组共享状态。
LogManager() - 类 java.util.logging.LogManager 的构造方法
受保护的构造方法。
logout() - 类 java.security.AuthProvider 中的方法
在此 provider 中注销。
logout() - 类 javax.security.auth.login.LoginContext 中的方法
注销 Subject。
logout() - 接口 javax.security.auth.spi.LoginModule 中的方法
注销 Subject 的方法。
logp(Level, String, String, String) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类和方法，不带参数。
logp(Level, String, String, String, Object) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。
logp(Level, String, String, String, Object[]) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类和方法，带有一组对象参数。
logp(Level, String, String, String, Throwable) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定源类和方法，带有相关的可抛出信息。
logrb(Level, String, String, String, String) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类、方法和资源包名，不带参数。
logrb(Level, String, String, String, String, Object) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。
logrb(Level, String, String, String, String, Object[]) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。
logrb(Level, String, String, String, String, Throwable) - 类 java.util.logging.Logger 中的方法
记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。
LogRecord - java.util.logging 中的 类
LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。
LogRecord(Level, String) - 类 java.util.logging.LogRecord 的构造方法
用给定级别和消息值构造 LogRecord。
LogStream - java.rmi.server 中的 类
已过时。 无替代版本
logStream() - 类 javax.swing.DebugGraphics 中的静态方法
返回 DebugGraphics 在其中记录绘制操作的流。
Long - java.lang 中的 类
Long 类在对象中包装了基本类型 long 的值。
Long(long) - 类 java.lang.Long 的构造方法
构造新分配的 Long 对象，表示指定的 long 参数。
Long(String) - 类 java.lang.Long 的构造方法
构造新分配的 Long 对象，表示由 String 参数指示的 long 值。
LONG - 类 java.text.DateFormat 中的静态变量
用于 LONG 模式的常量。
LONG - 类 java.util.Calendar 中的静态变量
指示长名称的 getDisplayName 和 getDisplayNames 的风格说明符，比如 "January"。
LONG - 类 java.util.TimeZone 中的静态变量
指出长名称的 getDisplayName() 的风格说明符。
LONG - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Long 的值。
LONG_DESCRIPTION - 接口 javax.swing.Action 中的静态变量
用来存储动作的较长 String 描述的键，用于上下文相关的帮助文件。
longBitsToDouble(long) - 类 java.lang.Double 中的静态方法
返回对应于给定位表示形式的 double 值。
LongBuffer - java.nio 中的 类
long 缓冲区。
LongHolder - org.omg.CORBA 中的 类
Long 值的 Holder。
LongHolder() - 类 org.omg.CORBA.LongHolder 的构造方法
构造一个新的 LongHolder 对象，将其 value 字段初始化为 0。
LongHolder(long) - 类 org.omg.CORBA.LongHolder 的构造方法
构造一个新的 LongHolder 对象，并使用给定 long 初始化其 value 字段。
LongLongSeqHelper - org.omg.CORBA 中的 类
LongLongSeq 的 Helper。
LongLongSeqHelper() - 类 org.omg.CORBA.LongLongSeqHelper 的构造方法
LongLongSeqHolder - org.omg.CORBA 中的 类
LongLongSeq 的 Holder。
LongLongSeqHolder() - 类 org.omg.CORBA.LongLongSeqHolder 的构造方法
LongLongSeqHolder(long[]) - 类 org.omg.CORBA.LongLongSeqHolder 的构造方法
LONGNVARCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 LONGNVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
LongSeqHelper - org.omg.CORBA 中的 类
LongSeqHelper 的 Helper。
LongSeqHelper() - 类 org.omg.CORBA.LongSeqHelper 的构造方法
LongSeqHolder - org.omg.CORBA 中的 类
LongSeq 的 Holder。
LongSeqHolder() - 类 org.omg.CORBA.LongSeqHolder 的构造方法
LongSeqHolder(int[]) - 类 org.omg.CORBA.LongSeqHolder 的构造方法
longValue() - 类 java.lang.Byte 中的方法
作为一个 long 返回此 Byte 的值。
longValue() - 类 java.lang.Double 中的方法
以 long 形式返回此 Double 的值（通过强制转换为 long 类型）。
longValue() - 类 java.lang.Float 中的方法
将此 Float 值以 long 形式返回（强制转换为 long 类型）。
longValue() - 类 java.lang.Integer 中的方法
以 long 类型返回该 Integer 的值。
longValue() - 类 java.lang.Long 中的方法
以 long 值的形式返回此 Long 的值。
longValue() - 类 java.lang.Number 中的方法
以 long 形式返回指定的数值。
longValue() - 类 java.lang.Short 中的方法
以 Long 形式返回此 Short 的值。
longValue() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 long。
longValue() - 类 java.math.BigInteger 中的方法
将此 BigInteger 转换为 long。
longValue() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
longValue() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
longValueExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 long，以检查丢失的信息。
LONGVARBINARY - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 LONGVARBINARY 的 Java 编程语言中的常量（有时称为类型代码）。
LONGVARCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 LONGVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
LookAndFeel - javax.swing 中的 类
顾名思义，LookAndFeel 封装了一个外观。
LookAndFeel() - 类 javax.swing.LookAndFeel 的构造方法
lookingAt() - 类 java.util.regex.Matcher 中的方法
尝试将从区域开头开始的输入序列与该模式匹配。
lookup(Class<?>) - 类 java.io.ObjectStreamClass 中的静态方法
查找可序列化类的描述符。
lookup(String) - 类 java.rmi.Naming 中的静态方法
返回与指定 name 关联的远程对象的引用（一个 stub）。
lookup(String) - 接口 java.rmi.registry.Registry 中的方法
返回注册表中绑定到指定 name 的远程引用。
lookup(Name) - 接口 javax.naming.Context 中的方法
检索指定的对象。
lookup(String) - 接口 javax.naming.Context 中的方法
检索指定的对象。
lookup(String) - 类 javax.naming.InitialContext 中的方法
lookup(Name) - 类 javax.naming.InitialContext 中的方法
lookup_value_factory(String) - 类 org.omg.CORBA_2_3.ORB 中的方法
lookupAny(Class<?>) - 类 java.io.ObjectStreamClass 中的静态方法
返回任意类的描述符，不考虑它是否实现 Serializable。
lookupConstraints(Component) - 类 java.awt.GridBagLayout 中的方法
检索指定组件的约束。
lookupDefaultPrintService() - 类 javax.print.PrintServiceLookup 中的静态方法
查找此环境的默认 PrintService。
lookupLink(Name) - 接口 javax.naming.Context 中的方法
按照除名称的最终原子组件以外的链接检索指定对象。
lookupLink(String) - 接口 javax.naming.Context 中的方法
按照除名称的最终原子组件以外的链接检索指定对象。
lookupLink(String) - 类 javax.naming.InitialContext 中的方法
lookupLink(Name) - 类 javax.naming.InitialContext 中的方法
lookupMultiDocPrintServices(DocFlavor[], AttributeSet) - 类 javax.print.PrintServiceLookup 中的静态方法
查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。
lookupNamespaceURI(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
lookupNamespaceURI(String) - 接口 org.w3c.dom.Node 中的方法
从此节点开始，查找与给定前缀相关的名称空间 URI。
LookupOp - java.awt.image 中的 类
此类实现从源到目标的查找操作。
LookupOp(LookupTable, RenderingHints) - 类 java.awt.image.LookupOp 的构造方法
在给定查找表和 RenderingHints 对象（可能为 null）的情况下，构造一个 LookupOp 对象。
lookupPixel(int[], int[]) - 类 java.awt.image.ByteLookupTable 中的方法
返回像素的样本数组，使用 lookup table 进行转换。
lookupPixel(byte[], byte[]) - 类 java.awt.image.ByteLookupTable 中的方法
返回像素的样本数组，使用 lookup table 进行转换。
lookupPixel(int[], int[]) - 类 java.awt.image.LookupTable 中的方法
返回一个像素的 int 分量数组。
lookupPixel(int[], int[]) - 类 java.awt.image.ShortLookupTable 中的方法
返回一个使用查找表转换后的像素样本数组。
lookupPixel(short[], short[]) - 类 java.awt.image.ShortLookupTable 中的方法
返回一个使用查找表转换后的像素样本数组。
lookupPrefix(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
lookupPrefix(String) - 接口 org.w3c.dom.Node 中的方法
从此节点开始，查找与给定名称空间 URI 相关的前缀。
lookupPrintServices() - 类 java.awt.print.PrinterJob 中的静态方法
查找 2D 打印服务的便捷方法。
lookupPrintServices(DocFlavor, AttributeSet) - 类 javax.print.PrintServiceLookup 中的静态方法
查找能够打印指定 DocFlavor 的 PrintService。
lookupProviders(Class<T>, ClassLoader) - 类 javax.imageio.spi.ServiceRegistry 中的静态方法
使用给定的类加载器搜索特定服务类的实现。
lookupProviders(Class<T>) - 类 javax.imageio.spi.ServiceRegistry 中的静态方法
使用上下文类加载器定位和递增地实例化给定服务的可用的提供者。
lookupStreamPrintServiceFactories(DocFlavor, String) - 类 javax.print.StreamPrintServiceFactory 中的静态方法
查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。
lookupStreamPrintServices(String) - 类 java.awt.print.PrinterJob 中的静态方法
定位可以成像 2D 图形的流打印服务工厂的便捷方法。
LookupTable - java.awt.image 中的 类
此抽象类定义了一个查找表对象。
LookupTable(int, int) - 类 java.awt.image.LookupTable 的构造方法
根据分量数和查找表中的偏移量构造一个新 LookupTable。
loop() - 接口 java.applet.AudioClip 中的方法
以循环方式开始播放此音频剪辑。
loop(int) - 接口 javax.sound.sampled.Clip 中的方法
从当前位置开始循环回放。
LOOP_CONTINUOUSLY - 接口 javax.sound.midi.Sequencer 中的静态变量
一个值，指示循环应无限继续而不是在执行完特定次数的循环后停止。
LOOP_CONTINUOUSLY - 接口 javax.sound.sampled.Clip 中的静态变量
指示循环应该无限期继续而不是在指定数量的循环后完成的值。
LOST_FOCUS - 类 java.awt.Event 中的静态变量
组件失去焦点。
lostFocus(Event, Object) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
lostOwnership(Clipboard, Transferable) - 接口 java.awt.datatransfer.ClipboardOwner 中的方法
通知此对象，它已不再是剪贴板所有者。
lostOwnership(Clipboard, Transferable) - 类 java.awt.datatransfer.StringSelection 中的方法
LOW_SURROGATES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Low Surrogates”Unicode 字符块的常量。
lower(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
lower(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 中严格小于给定元素的最大元素；如果不存在这样的元素，则返回 null。
lower(E) - 类 java.util.TreeSet 中的方法
LOWER_LEADING_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的底端开始边角。
LOWER_LEFT_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的左下角。
LOWER_RIGHT_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的右下角。
LOWER_TRAILING_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的底端结束边角。
LOWERCASE_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Ll”。
lowerCaseMode(boolean) - 类 java.io.StreamTokenizer 中的方法
确定是否对文字标记自动使用小写字母。
LOWERED - 类 javax.swing.border.BevelBorder 中的静态变量
凹入斜面类型。
LOWERED - 类 javax.swing.border.EtchedBorder 中的静态变量
阴刻浮雕化类型。
lowerEntry(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回与严格小于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
lowerEntry(K) - 接口 java.util.NavigableMap 中的方法
返回一个键-值映射关系，它与严格小于给定键的最大键关联；如果不存在这样的键，则返回 null。
lowerEntry(K) - 类 java.util.TreeMap 中的方法
lowerKey(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
lowerKey(K) - 接口 java.util.NavigableMap 中的方法
返回严格小于给定键的最大键；如果不存在这样的键，则返回 null。
lowerKey(K) - 类 java.util.TreeMap 中的方法
lowerLeft - 类 javax.swing.JScrollPane 中的变量
在左下角显示的组件。
lowerLeft - 类 javax.swing.ScrollPaneLayout 中的变量
左下角显示的组件。
lowerRight - 类 javax.swing.JScrollPane 中的变量
在右下角显示的组件。
lowerRight - 类 javax.swing.ScrollPaneLayout 中的变量
右下角显示的组件。
lowestLayer() - 类 javax.swing.JLayeredPane 中的方法
返回所有当前子组件的最低层值。
lowestOneBit(int) - 类 java.lang.Integer 中的静态方法
返回具有至多单个 1 位的 int 值，在指定的 int 值中最低位（最右边）的 1 位的位置。
lowestOneBit(long) - 类 java.lang.Long 中的静态方法
返回至多有一个 1 位的 long 值，在指定的 long 值中最低位（最右边）的 1 位的位置。
LOWSRC - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
LSException - org.w3c.dom.ls 中的 异常
如果处理停止，解析或写操作可以抛出 LSException。
LSException(short, String) - 异常 org.w3c.dom.ls.LSException 的构造方法
LSInput - org.w3c.dom.ls 中的 接口
此接口表示数据的输入源。
LSLoadEvent - org.w3c.dom.ls 中的 接口
此接口表示通知文档加载完成的加载事件对象。
LSOutput - org.w3c.dom.ls 中的 接口
此接口表示数据的输出目标。
LSParser - org.w3c.dom.ls 中的 接口
可以构建的对象接口，或者参数、来自各种输入源的 DOM 树。
LSParserFilter - org.w3c.dom.ls 中的 接口
LSParserFilter 为应用程序提供了在解析期间构建节点时检查这些节点的能力。
LSProgressEvent - org.w3c.dom.ls 中的 接口
此接口表示进度事件对象，该对象在解析文档时通知应用程序有关进度。
LSResourceResolver - org.w3c.dom.ls 中的 接口
LSResourceResolver 为应用程序提供了将引用重定向到外部资源的方法。
LSSerializer - org.w3c.dom.ls 中的 接口
LSSerializer 提供了将 DOM 文档序列化（编写）为 XML 的 API。
LSSerializerFilter - org.w3c.dom.ls 中的 接口
LSSerializerFilter 为应用程序提供了在序列化节点时检查节点以及决定哪些节点应该或不应该序列化的能力。
LT - 类 javax.management.Query 中的静态变量
表示 Query.lt(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
lt(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示 基于两个值的“小于”约束条件。
lt(File, File) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


M - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

M

Mac - javax.crypto 中的 类
此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。
Mac(MacSpi, Provider, String) - 类 javax.crypto.Mac 的构造方法
创建一个 MAC 对象。
MacSpi - javax.crypto 中的 类
此类为 Mac 类定义服务提供者接口 (SPI)。
MacSpi() - 类 javax.crypto.MacSpi 的构造方法
magenta - 类 java.awt.Color 中的静态变量
洋红色。
MAGENTA - 类 java.awt.Color 中的静态变量
洋红色。
mail() - 类 java.awt.Desktop 中的方法
启动用户默认邮件客户端的邮件组合窗口。
mail(URI) - 类 java.awt.Desktop 中的方法
启动用户默认邮件客户端的邮件组合窗口，填充由 mailto: URI 指定的消息字段。
MailcapCommandMap - javax.activation 中的 类
MailcapCommandMap 扩展 CommandMap 抽象类。
MailcapCommandMap() - 类 javax.activation.MailcapCommandMap 的构造方法
默认的构造方法。
MailcapCommandMap(String) - 类 javax.activation.MailcapCommandMap 的构造方法
允许调用者指定 mailcap 文件路径的构造方法。
MailcapCommandMap(InputStream) - 类 javax.activation.MailcapCommandMap 的构造方法
允许调用者指定一个包含 mailcap 文件的 InputStream 的构造方法。
MAIN - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的主要进纸托盘。
MAIN_CLASS - 类 java.util.jar.Attributes.Name 中的静态变量
Main-Class 的 Name 对象具有的属性，用于启动打包在 JAR 文件中的应用程序。
MAIN_UIROLE - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个充当普通终端用户角色的 UI。
major_version - 类 org.omg.IOP.Encoding 中的变量
此 Encoding 格式的主要形式。
majorRequirementChange(AsyncBoxView.ChildState, float) - 类 javax.swing.text.AsyncBoxView 中的方法
沿主轴上的要求更改。
majorTickSpacing - 类 javax.swing.JSlider 中的变量
主刻度标记（分解次刻度标记的较大标记）之间的值的个数。
make_object(String, byte[]) - 接口 org.omg.PortableInterceptor.ObjectReferenceFactory 中的方法
make_object 根据此模板中的数据，使用给定的存储库 ID 和对象 ID 创建 CORBA 对象引用。
makeBounds(double, double, double, double) - 类 java.awt.geom.Arc2D.Double 中的方法
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
makeBounds(double, double, double, double) - 类 java.awt.geom.Arc2D.Float 中的方法
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
makeBounds(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
makeClient(String, Subject) - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
makeClient(String, Subject) - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
makeClient(String, Subject) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
创建一个新的客户端连接。
makeComponentInputMap(JComponent, Object[]) - 类 javax.swing.LookAndFeel 中的静态方法
根据 keys 创建一个 ComponentInputMapUIResource。
makeIcon(Class<?>, String) - 类 javax.swing.LookAndFeel 中的静态方法
创建并返回一个加载图像的 UIDefault.LazyValue。
makeInputMap(Object[]) - 类 javax.swing.LookAndFeel 中的静态方法
根据 keys 创建一个 InputMapUIResource。
makeKeyBindings(Object[]) - 类 javax.swing.LookAndFeel 中的静态方法
构建一个 KeyBinding 数组的便捷方法。
makeParser() - 类 org.xml.sax.helpers.ParserFactory 中的静态方法
已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
makeParser(String) - 类 org.xml.sax.helpers.ParserFactory 中的静态方法
已过时。 使用提供的类名创建一个新的 SAX 解析器对象。
makeTag(Element, boolean) - 类 javax.swing.text.html.parser.Parser 中的方法
制作 TagElement。
makeTag(Element) - 类 javax.swing.text.html.parser.Parser 中的方法
makeVisible(int) - 类 java.awt.List 中的方法
使指定索引处的项可视。
makeVisible(TreePath) - 类 javax.swing.JTree 中的方法
确保路径标识的节点当前可查看。
MALAYALAM - 类 java.awt.font.NumericShaper 中的静态变量
标识 MALAYALAM 范围和十进制基数。
MALAYALAM - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Malayalam”Unicode 字符块的常量。
malformedForLength(int) - 类 java.nio.charset.CoderResult 中的静态方法
静态工厂方法，返回描述给定长度的错误输入错误的唯一对象。
malformedInputAction() - 类 java.nio.charset.CharsetDecoder 中的方法
返回此解码器对错误输入错误的当前操作。
malformedInputAction() - 类 java.nio.charset.CharsetEncoder 中的方法
返回此编码器对错误输入错误的当前操作。
MalformedInputException - java.nio.charset 中的 异常
当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
MalformedInputException(int) - 异常 java.nio.charset.MalformedInputException 的构造方法
MalformedLinkException - javax.naming 中的 异常
如果在解析或构造链接时遇到错误链接，则抛出此异常。
MalformedLinkException(String) - 异常 javax.naming.MalformedLinkException 的构造方法
使用解释构造一个新的 MalformedLinkException 实例，其他所有字段都被初始化为 null。
MalformedLinkException() - 异常 javax.naming.MalformedLinkException 的构造方法
构造一个新的 Malformed LinkException 实例。
MalformedObjectNameException - javax.management 中的 异常
字符串的格式不对应于有效的 ObjectName。
MalformedObjectNameException() - 异常 javax.management.MalformedObjectNameException 的构造方法
默认的构造方法。
MalformedObjectNameException(String) - 异常 javax.management.MalformedObjectNameException 的构造方法
允许指定特定错误消息的构造方法。
MalformedParameterizedTypeException - java.lang.reflect 中的 异常
当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
MalformedParameterizedTypeException() - 异常 java.lang.reflect.MalformedParameterizedTypeException 的构造方法
MalformedURLException - java.net 中的 异常
抛出这一异常指示出现了错误的 URL。
MalformedURLException() - 异常 java.net.MalformedURLException 的构造方法
构造不带详细消息的 MalformedURLException。
MalformedURLException(String) - 异常 java.net.MalformedURLException 的构造方法
构造带指定详细消息的 MalformedURLException。
ManagementFactory - java.lang.management 中的 类
ManagementFactory 类是一种工厂类，用于获取 Java 平台的管理 Bean。
ManagementPermission - java.lang.management 中的 类
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。
ManagementPermission(String) - 类 java.lang.management.ManagementPermission 的构造方法
构造具有指定名称的 ManagementPermission。
ManagementPermission(String, String) - 类 java.lang.management.ManagementPermission 的构造方法
构造新的 ManagementPermission 对象。
manager_id() - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象适配器管理器 id。
ManageReferralControl - javax.naming.ldap 中的 类
将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
ManageReferralControl() - 类 javax.naming.ldap.ManageReferralControl 的构造方法
构造一个关键的 ManageReferral 控件。
ManageReferralControl(boolean) - 类 javax.naming.ldap.ManageReferralControl 的构造方法
构造一个 ManageReferral 控件。
ManagerFactoryParameters - javax.net.ssl 中的 接口
此类是用来向 KeyManagerFactory 或 TrustManagerFactory 提供特定于算法的信息的基接口。
MANAGES_DESCENDANTS - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象负责管理其子组件。
Manifest - java.util.jar 中的 类
Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。
Manifest() - 类 java.util.jar.Manifest 的构造方法
构造新的空 Manifest。
Manifest(InputStream) - 类 java.util.jar.Manifest 的构造方法
从指定的输入流构造新的 Manifest。
Manifest(Manifest) - 类 java.util.jar.Manifest 的构造方法
构造新的 Manifest，它是指定 Manifest 的副本。
Manifest - javax.xml.crypto.dsig 中的 接口
在 W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Manifest 元素的表示形式。
MANIFEST_NAME - 类 java.util.jar.JarFile 中的静态变量
JAR 清单文件名称。
MANIFEST_VERSION - 类 java.util.jar.Attributes.Name 中的静态变量
Manifest-Version 的 Name 对象具有的属性。
MANUAL - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的手动进纸托盘。
map(FileChannel.MapMode, long, long) - 类 java.nio.channels.FileChannel 中的方法
将此通道的文件区域直接映射到内存中。
map - 类 java.util.jar.Attributes 中的变量
属性名称-值映射关系。
Map<K,V> - java.util 中的 接口
将键映射到值的对象。
MAP - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Map.Entry<K,V> - java.util 中的 接口
映射项（键-值对）。
mapInputMethodHighlight(InputMethodHighlight) - 类 java.awt.Toolkit 中的方法
返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。
mapLibraryName(String) - 类 java.lang.System 中的静态方法
将一个库名称映射到特定于平台的、表示本机库的字符串中。
MappedByteBuffer - java.nio 中的 类
直接字节缓冲区，其内容是文件的内存映射区域。
mapRenderContext(int, RenderContext, ParameterBlock, RenderableImage) - 接口 java.awt.image.renderable.ContextualRenderedImageFactory 中的方法
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。
mapSystemException(SystemException) - 类 javax.rmi.CORBA.Util 中的静态方法
将 SystemException 映射到 RemoteException。
mapSystemException(SystemException) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.mapSystemException(org.omg.CORBA.SystemException) 的委托调用。
MARCH - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第三个月的 Calendar.MONTH 字段值。
MARCH - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第三个月的值。
MARGIN - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGIN_BOTTOM - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGIN_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的边界空白的更改。
MARGIN_LEFT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGIN_RIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGIN_TOP - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
MARGINHEIGHT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
MARGINWIDTH - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
mark(int) - 类 java.io.BufferedInputStream 中的方法
参见 InputStream 的 mark 方法的常规协定。
mark(int) - 类 java.io.BufferedReader 中的方法
标记流中的当前位置。
mark - 类 java.io.ByteArrayInputStream 中的变量
流中当前的标记位置。
mark(int) - 类 java.io.ByteArrayInputStream 中的方法
设置流中的当前标记位置。
mark(int) - 类 java.io.CharArrayReader 中的方法
标记流中的当前位置。
mark(int) - 类 java.io.FilterInputStream 中的方法
在输入流中的当前位置上作标记。
mark(int) - 类 java.io.FilterReader 中的方法
在流中的当前位置上作标记。
mark(int) - 类 java.io.InputStream 中的方法
在此输入流中标记当前的位置。
mark(int) - 类 java.io.LineNumberInputStream 中的方法
已过时。 在此输入流中标记当前的位置。
mark(int) - 类 java.io.LineNumberReader 中的方法
标记该流中的当前位置。
mark(int) - 类 java.io.PushbackInputStream 中的方法
在此输入流中标记当前的位置。
mark(int) - 类 java.io.PushbackReader 中的方法
标记流中的当前位置。
mark(int) - 类 java.io.Reader 中的方法
标记流中的当前位置。
mark(int) - 类 java.io.StringReader 中的方法
标记流中的当前位置。
mark() - 类 java.nio.Buffer 中的方法
在此缓冲区的位置设置标记。
mark(int) - 类 java.util.zip.DeflaterInputStream 中的方法
不支持此操作。
mark(int) - 类 java.util.zip.InflaterInputStream 中的方法
标记此输入流中的当前位置。
mark() - 接口 javax.imageio.stream.ImageInputStream 中的方法
标记流中某个位置，供后续调用 reset 时返回。
mark() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
将当前流位置推进到标记位置的堆栈上。
mark(int) - 类 javax.sound.sampled.AudioInputStream 中的方法
标记此音频输入流中的当前位置。
markCompletelyClean(JComponent) - 类 javax.swing.RepaintManager 中的方法
标记完全干净的组件。
markCompletelyDirty(JComponent) - 类 javax.swing.RepaintManager 中的方法
标记完全弄脏的组件。
markedPos - 类 java.io.CharArrayReader 中的变量
缓冲区中标记的位置。
MARKER_SUPPLY_EMPTY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）已用完。
MARKER_SUPPLY_LOW - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）不足。
MARKER_WASTE_ALMOST_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备指示器耗材废物容器几乎已填满。
MARKER_WASTE_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备指示器耗材废物容器已填满。
markFirstTime(Element) - 类 javax.swing.text.html.parser.Parser 中的方法
标记在文档中首次看到标记
marklimit - 类 java.io.BufferedInputStream 中的变量
调用 mark 方法后，在后续调用 reset 方法失败之前所允许的最大提前读取量。
markpos - 类 java.io.BufferedInputStream 中的变量
最后一次调用 mark 方法时 pos 字段的值。
markSupported() - 类 java.io.BufferedInputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法。
markSupported() - 类 java.io.BufferedReader 中的方法
判断此流是否支持 mark() 操作（它一定支持）。
markSupported() - 类 java.io.ByteArrayInputStream 中的方法
测试此 InputStream 是否支持 mark/reset。
markSupported() - 类 java.io.CharArrayReader 中的方法
判断此流是否支持 mark() 操作（它一定支持）。
markSupported() - 类 java.io.FilterInputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法。
markSupported() - 类 java.io.FilterReader 中的方法
判断此流是否支持 mark() 操作。
markSupported() - 类 java.io.InputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法。
markSupported() - 类 java.io.PushbackInputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法，此输入流不支持这两个方法。
markSupported() - 类 java.io.PushbackReader 中的方法
判断此流是否支持 mark() 操作（它一定不支持）。
markSupported() - 类 java.io.Reader 中的方法
判断此流是否支持 mark() 操作。
markSupported() - 类 java.io.StringReader 中的方法
判断此流是否支持 mark() 操作以及支持哪一项操作。
markSupported() - 类 java.util.zip.DeflaterInputStream 中的方法
始终返回 false，因为此输入流不支持 mark() 和 reset() 方法。
markSupported() - 类 java.util.zip.InflaterInputStream 中的方法
测试此输入流是否支持 mark 和 reset 方法。
markSupported() - 类 javax.crypto.CipherInputStream 中的方法
测试该输入流是否支持 mark 和 reset 方法以及哪一个方法确实不受支持。
markSupported() - 类 javax.sound.sampled.AudioInputStream 中的方法
测试此音频输入流是否支持 mark 和 reset 方法。
marshal(String) - 类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 中的方法
无任何操作。
marshal(byte[]) - 类 javax.xml.bind.annotation.adapters.HexBinaryAdapter 中的方法
marshal(String) - 类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 中的方法
无任何操作。
marshal(BoundType) - 类 javax.xml.bind.annotation.adapters.XmlAdapter 中的方法
将 bound 类型转换为 value 类型。
marshal(ElementT, ValidationEventHandler) - 接口 javax.xml.bind.annotation.DomHandler 中的方法
在 JAXB 提供者需要将元素编组为 XML 时调用此方法。
marshal(Element, ValidationEventHandler) - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法
marshal(Object, XmlNode) - 类 javax.xml.bind.Binder 中的方法
将 JAXB 对象树编组为新的 XML 文档。
marshal(Object, OutputStream) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, Writer) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, ContentHandler) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, Node) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, XMLEventWriter) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, XMLStreamWriter) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
marshal(Object, Result) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。
marshal(Object, OutputStream) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到输出流中。
marshal(Object, Writer) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 Writer 中。
marshal(Object, ContentHandler) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。
marshal(Object, Node) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 DOM 树中。
marshal(Object, XMLStreamWriter) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。
marshal(Object, XMLEventWriter) - 接口 javax.xml.bind.Marshaller 中的方法
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。
marshal(XMLStructure, XMLCryptoContext) - 接口 javax.xml.crypto.dsig.keyinfo.KeyInfo 中的方法
将密钥信息编组为 XML。
marshal(DataOutputStream) - 接口 org.omg.CORBA.CustomMarshal 中的方法
必须通过自定义的 Marshal 类实现 marshal 方法。
MARSHAL - org.omg.CORBA 中的 异常
表示网络中传来的请求或应答在结构上无效。
MARSHAL() - 异常 org.omg.CORBA.MARSHAL 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 MARSHAL 异常。
MARSHAL(String) - 异常 org.omg.CORBA.MARSHAL 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 MARSHAL 异常。
MARSHAL(int, CompletionStatus) - 异常 org.omg.CORBA.MARSHAL 的构造方法
使用指定次要代码和完成状态构造一个 MARSHAL 异常。
MARSHAL(String, int, CompletionStatus) - 异常 org.omg.CORBA.MARSHAL 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 MARSHAL 异常。
MarshalException - java.rmi 中的 异常
如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
MarshalException(String) - 异常 java.rmi.MarshalException 的构造方法
构造带有指定详细消息的 MarshalException。
MarshalException(String, Exception) - 异常 java.rmi.MarshalException 的构造方法
构造带指定详细消息和嵌入异常的 MarshalException。
MarshalException - javax.xml.bind 中的 异常
此异常指示在执行提供者无法恢复的编组操作时发生错误。
MarshalException(String) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带指定详细消息的 MarshalException。
MarshalException(String, String) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 MarshalException。
MarshalException(Throwable) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带有一个 linkedException 的 MarshalException。
MarshalException(String, Throwable) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带指定的详细消息和 linkedException 的 MarshalException。
MarshalException(String, String, Throwable) - 异常 javax.xml.bind.MarshalException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 MarshalException。
MarshalException - javax.xml.crypto 中的 异常
指示 XML 编组或解组过程中发生的异常条件。
MarshalException() - 异常 javax.xml.crypto.MarshalException 的构造方法
构造使用 null 作为其详细消息的新 MarshalException。
MarshalException(String) - 异常 javax.xml.crypto.MarshalException 的构造方法
构造带指定详细消息的新 MarshalException。
MarshalException(String, Throwable) - 异常 javax.xml.crypto.MarshalException 的构造方法
构造一个带指定详细消息和 cause 的新 MarshalException。
MarshalException(Throwable) - 异常 javax.xml.crypto.MarshalException 的构造方法
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的 MarshalException（它通常包含 cause 的类和详细消息）。
MarshalledObject<T> - java.rmi 中的 类
MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。
MarshalledObject(T) - 类 java.rmi.MarshalledObject 的构造方法
创建一个新的 MarshalledObject，它包含所提供对象的当前状态的序列化表示形式。
Marshaller - javax.xml.bind 中的 接口
Marshaller 类负责管理将 Java 内容树序列化回 XML 数据的过程。
Marshaller.Listener - javax.xml.bind 中的 类

向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。

Marshaller.Listener() - 类 javax.xml.bind.Marshaller.Listener 的构造方法
marshalParams(XMLStructure, XMLCryptoContext) - 类 javax.xml.crypto.dsig.TransformService 中的方法
对特定于算法的参数进行编组。
MaskFormatter - javax.swing.text 中的 类
MaskFormatter 用于格式化和编辑字符串。
MaskFormatter() - 类 javax.swing.text.MaskFormatter 的构造方法
创建一个不带掩码的 MaskFormatter。
MaskFormatter(String) - 类 javax.swing.text.MaskFormatter 的构造方法
创建具有指定掩码的 MaskFormatter。
MASTER_GAIN - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上总音量的控件。
match(DataFlavor) - 类 java.awt.datatransfer.DataFlavor 中的方法
测试 DataFlavor 与此 DataFlavor 的相等性。
match(Certificate) - 接口 java.security.cert.CertSelector 中的方法
决定是否应该选择某个 Certificate。
match(CRL) - 接口 java.security.cert.CRLSelector 中的方法
决定是否应该选择某个 CRL。
match(Certificate) - 类 java.security.cert.X509CertSelector 中的方法
决定是否应该选择某个 Certificate。
match(CRL) - 类 java.security.cert.X509CRLSelector 中的方法
决定是否应该选择某个 CRL。
match() - 类 java.util.Scanner 中的方法
返回此扫描器所执行的最后扫描操作的匹配结果。
match(MimeType) - 类 javax.activation.MimeType 中的方法
确定此对象的基本类型和子类型与给定类型中的类型是否相同。
match(String) - 类 javax.activation.MimeType 中的方法
确定此对象的基本类型和子类型与 rawdata 中描述的内容类型是否相同。
match(AttributeValueExp, StringValueExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，表示基于字符串参数的匹配约束条件。
Matcher - java.util.regex 中的 类
通过解释 Pattern 对 character sequence 执行匹配操作的引擎。
matcher(CharSequence) - 类 java.util.regex.Pattern 中的方法
创建匹配给定输入与此模式的匹配器。
matches(String) - 类 java.lang.String 中的方法
告知此字符串是否匹配给定的正则表达式。
matches() - 类 java.util.regex.Matcher 中的方法
尝试将整个区域与模式匹配。
matches(String, CharSequence) - 类 java.util.regex.Pattern 中的静态方法
编译给定正则表达式并尝试将给定输入与其匹配。
matches(AudioFormat) - 类 javax.sound.sampled.AudioFormat 中的方法
指示此格式是否与指定格式匹配。
matches(Line.Info) - 类 javax.sound.sampled.DataLine.Info 中的方法
确定指定的信息对象是否与此对象匹配。
matches(Line.Info) - 类 javax.sound.sampled.Line.Info 中的方法
指示指定的信息对象是否与此对象匹配。
matches(Line.Info) - 类 javax.sound.sampled.Port.Info 中的方法
指示此指定 info 对象是否与此对象匹配。
matchNameAttribute(AttributeSet, HTML.Tag) - 类 javax.swing.text.html.HTMLWriter 中的方法
如果 StyleConstants.NameAttribute 与作为参数传入的标记相同，则返回 true。
MatchResult - java.util.regex 中的 接口
匹配操作的结果。
Math - java.lang 中的 类
Math 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。
MATH_SYMBOL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Sm”。
MathContext - java.math 中的 类
该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。
MathContext(int) - 类 java.math.MathContext 的构造方法
构造一个新的 MathContext，它具有指定的精度和 HALF_UP 舍入模式。
MathContext(int, RoundingMode) - 类 java.math.MathContext 的构造方法
构造一个新的 MathContext，它具有指定的精度和舍入模式。
MathContext(String) - 类 java.math.MathContext 的构造方法
根据字符串构造一个新的 MathContext。
MATHEMATICAL_ALPHANUMERIC_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Mathematical Alphanumeric Symbols”Unicode 字符块的常量。
MATHEMATICAL_OPERATORS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Mathematical Operators”Unicode 字符块的常量。
MatteBorder - javax.swing.border 中的 类
该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
MatteBorder(int, int, int, int, Color) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(Insets, Color) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(int, int, int, int, Icon) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定 insets 和平铺图标的衬边边框。
MatteBorder(Insets, Icon) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定 insets 和平铺图标的衬边边框。
MatteBorder(Icon) - 类 javax.swing.border.MatteBorder 的构造方法
创建具有指定平铺图标的衬边边框。
max(int, int) - 类 java.lang.Math 中的静态方法
返回两个 int 值中较大的一个。
max(long, long) - 类 java.lang.Math 中的静态方法
返回两个 long 值中较大的一个。
max(float, float) - 类 java.lang.Math 中的静态方法
返回两个 float 值中较大的一个。
max(double, double) - 类 java.lang.Math 中的静态方法
返回两个 double 值中较大的一个。
max(int, int) - 类 java.lang.StrictMath 中的静态方法
返回两个 int 值中较大的一个。
max(long, long) - 类 java.lang.StrictMath 中的静态方法
返回两个 long 值中较大的一个。
max(float, float) - 类 java.lang.StrictMath 中的静态方法
返回两个 float 值中较大的一个。
max(double, double) - 类 java.lang.StrictMath 中的静态方法
返回两个 double 值中较大的一个。
max(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 和 val 的最大值。
max(BigInteger) - 类 java.math.BigInteger 中的方法
返回此 BigInteger 和 val 的最大值。
max(Collection<? extends T>) - 类 java.util.Collections 中的静态方法
根据元素的自然顺序，返回给定 collection 的最大元素。
max(Collection<? extends T>, Comparator<? super T>) - 类 java.util.Collections 中的静态方法
根据指定比较器产生的顺序，返回给定 collection 的最大元素。
max(Spring, Spring) - 类 javax.swing.Spring 中的静态方法
返回 max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring。
MAX_BUFFER - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定 SaslClient/SaslServer 接收缓冲区的最大大小（以字节为单位）。
MAX_CODE_POINT - 类 java.lang.Character 中的静态变量
Unicode 代码点的最大值。
MAX_COUNT - 类 javax.swing.plaf.synth.ColorType 中的静态变量
最大 ColorType 数。
MAX_EXPONENT - 类 java.lang.Double 中的静态变量
有限 double 变量可能具有的最大指数。
MAX_EXPONENT - 类 java.lang.Float 中的静态变量
有限 float 变量可能具有的最大指数。
MAX_HIGH_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 高代理项代码单元的最大值。
MAX_KEY_LENGTH - 类 java.util.prefs.Preferences 中的静态变量
允许作为键的字符串最大长度（80 个字符）。
MAX_LOW_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 低代理项代码单元的最大值。
MAX_NAME_LENGTH - 类 java.util.prefs.Preferences 中的静态变量
节点名的最大长度（80 个字符）。
MAX_PRIORITY - 类 java.lang.Thread 中的静态变量
线程可以具有的最高优先级。
MAX_RADIX - 类 java.lang.Character 中的静态变量
可用于与字符串相互转换的最大基数。
MAX_SCROLL - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态变量
MAX_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 代理项代码单元的最大值。
MAX_TIMEZONE_OFFSET - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式最大时区偏移量是 -14:00。
MAX_VALUE - 类 java.lang.Byte 中的静态变量
一个常量，保存 byte 类型可取的最大值，即 27-1。
MAX_VALUE - 类 java.lang.Character 中的静态变量
此字段的常量值是 char 类型的最大值，即 '\uFFFF'。
MAX_VALUE - 类 java.lang.Double 中的静态变量
保存 double 类型的最大正有限值的常量，最大正有限值为 (2-2-52)·21023。
MAX_VALUE - 类 java.lang.Float 中的静态变量
保存 float 类型的最大正有限值的常量，即 (2-2-23)·2127。
MAX_VALUE - 类 java.lang.Integer 中的静态变量
值为 231－1 的常量，它表示 int 类型能够表示的最大值。
MAX_VALUE - 类 java.lang.Long 中的静态变量
保持 long 类型的最大值的常量，该值为 263-1。
MAX_VALUE - 类 java.lang.Short 中的静态变量
保存 short 可取的最大值的常量，最大值为 215-1。
MAX_VALUE_FIELD - 类 javax.management.JMX 中的静态变量
maxValue 字段的名称。
MAX_VALUE_LENGTH - 类 java.util.prefs.Preferences 中的静态变量
允许作为值的字符串最大长度（8192 个字符）。
MAXBQUALSIZE - 接口 javax.transaction.xa.Xid 中的静态变量
getBqual 返回的最大字节数。
maxButton - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
maxBytesPerChar() - 类 java.nio.charset.CharsetEncoder 中的方法
返回为每个输入字符生成的最大字节数。
maxCharsPerByte() - 类 java.nio.charset.CharsetDecoder 中的方法
返回为每个输入字节生成的最大字符数。
MAXGRIDSIZE - 类 java.awt.GridBagLayout 中的静态变量
此字段不再用于保留数组和保持向后兼容性。
MAXGTRIDSIZE - 接口 javax.transaction.xa.Xid 中的静态变量
getGtrid 返回的最大字节数。
maxIcon - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
maximizable - 类 javax.swing.JInternalFrame 中的变量
可将窗体扩展到桌面窗格的大小。
MAXIMIZE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
maximizeAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
MAXIMIZED_BOTH - 类 java.awt.Frame 中的静态变量
此状态位掩码指示将窗体完全最大化（水平和垂直方向）。
MAXIMIZED_HORIZ - 类 java.awt.Frame 中的静态变量
此状态位指示在水平方向将窗体最大化。
MAXIMIZED_VERT - 类 java.awt.Frame 中的静态变量
此状态位指示在垂直方向将窗体最大化。
maximizeFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
重新调整窗体的大小，使其满足其父窗体的限制。
maximizeFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常，应该重新调整窗体的大小，使其满足其父窗体的限制。
maximizeFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要最大化窗体时调用此方法。
maximizeKey - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
maximum - 类 javax.swing.SizeRequirements 中的变量
允许的最大大小。
maximumLayoutSize(Container) - 类 java.awt.BorderLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的最大尺寸。
maximumLayoutSize(Container) - 类 java.awt.CardLayout 中的方法
给出指定目标容器中的组件，返回此布局的最大尺寸。
maximumLayoutSize(Container) - 类 java.awt.GridBagLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的最大维数
maximumLayoutSize(Container) - 接口 java.awt.LayoutManager2 中的方法
给定指定容器的组件，计算该容器的最大大小维数。
maximumLayoutSize(Container) - 类 javax.swing.BoxLayout 中的方法
返回目标容器布置其所包含的组件时可使用的最大尺寸。
maximumLayoutSize(Container) - 类 javax.swing.GroupLayout 中的方法
返回指定容器的最大大小。
maximumLayoutSize(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
返回布局能够使用的最大空间量。
maximumLayoutSize(Container) - 类 javax.swing.OverlayLayout 中的方法
返回需要布置组件的最大维数，该组件包含在指定的目标容器中。
maximumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回最大布局大小，该大小在两个方向上都是 Integer.MAX_VALUE。
maximumLayoutSize(Container) - 类 javax.swing.SpringLayout 中的方法
maximumRowCount - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
maximumThumbSize - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
MAXLENGTH - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
maxMemory() - 类 java.lang.Runtime 中的方法
返回 Java 虚拟机试图使用的最大内存量。
maxTabHeight - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
maxTabWidth - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
maxWidth - 类 javax.swing.table.TableColumn 中的变量
列的最大宽度。
MAY - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第五个月的 Calendar.MONTH 字段值。
MAY - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第五个月的值。
maybeUpdateLayoutState() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
如果 updateLayoutStateNeeded 为非 0，则调用 updateLayoutState() 并重置 updateLayoutStateNeeded。
MBeanAttributeInfo - javax.management 中的 类
描述出于管理目的而公开的 MBean 属性。
MBeanAttributeInfo(String, String, String, boolean, boolean, boolean) - 类 javax.management.MBeanAttributeInfo 的构造方法
构造一个 MBeanAttributeInfo 对象。
MBeanAttributeInfo(String, String, String, boolean, boolean, boolean, Descriptor) - 类 javax.management.MBeanAttributeInfo 的构造方法
构造一个 MBeanAttributeInfo 对象。
MBeanAttributeInfo(String, String, Method, Method) - 类 javax.management.MBeanAttributeInfo 的构造方法
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。
MBeanConstructorInfo - javax.management 中的 类
描述 MBean 所公开的构造方法。
MBeanConstructorInfo(String, Constructor) - 类 javax.management.MBeanConstructorInfo 的构造方法
构造一个 MBeanConstructorInfo 对象。
MBeanConstructorInfo(String, String, MBeanParameterInfo[]) - 类 javax.management.MBeanConstructorInfo 的构造方法
构造一个 MBeanConstructorInfo 对象。
MBeanConstructorInfo(String, String, MBeanParameterInfo[], Descriptor) - 类 javax.management.MBeanConstructorInfo 的构造方法
构造一个 MBeanConstructorInfo 对象。
MBeanException - javax.management 中的 异常
表示由代理的 MBean 方法所抛出的“用户定义的”异常。
MBeanException(Exception) - 异常 javax.management.MBeanException 的构造方法
创建一个包装实际 java.lang.Exception 的 MBeanException。
MBeanException(Exception, String) - 异常 javax.management.MBeanException 的构造方法
创建一个包装实际 java.lang.Exception 的 MBeanException（带有详细消息）。
MBeanFeatureInfo - javax.management 中的 类
提供 MBean 描述符对象的常规信息。
MBeanFeatureInfo(String, String) - 类 javax.management.MBeanFeatureInfo 的构造方法
构造一个 MBeanFeatureInfo 对象。
MBeanFeatureInfo(String, String, Descriptor) - 类 javax.management.MBeanFeatureInfo 的构造方法
构造一个 MBeanFeatureInfo 对象。
MBeanInfo - javax.management 中的 类
描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
MBeanInfo(String, String, MBeanAttributeInfo[], MBeanConstructorInfo[], MBeanOperationInfo[], MBeanNotificationInfo[]) - 类 javax.management.MBeanInfo 的构造方法
构造一个 MBeanInfo。
MBeanInfo(String, String, MBeanAttributeInfo[], MBeanConstructorInfo[], MBeanOperationInfo[], MBeanNotificationInfo[], Descriptor) - 类 javax.management.MBeanInfo 的构造方法
构造一个 MBeanInfo。
MBeanNotificationInfo - javax.management 中的 类
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanNotificationInfo(String[], String, String) - 类 javax.management.MBeanNotificationInfo 的构造方法
构造一个 MBeanNotificationInfo 对象。
MBeanNotificationInfo(String[], String, String, Descriptor) - 类 javax.management.MBeanNotificationInfo 的构造方法
构造一个 MBeanNotificationInfo 对象。
MBeanOperationInfo - javax.management 中的 类
描述由 MBean 公开的管理操作。
MBeanOperationInfo(String, Method) - 类 javax.management.MBeanOperationInfo 的构造方法
构造一个 MBeanOperationInfo 对象。
MBeanOperationInfo(String, String, MBeanParameterInfo[], String, int) - 类 javax.management.MBeanOperationInfo 的构造方法
构造一个 MBeanOperationInfo 对象。
MBeanOperationInfo(String, String, MBeanParameterInfo[], String, int, Descriptor) - 类 javax.management.MBeanOperationInfo 的构造方法
构造一个 MBeanOperationInfo 对象。
MBeanParameterInfo - javax.management 中的 类
描述由 MBean 公开的操作的参数。
MBeanParameterInfo(String, String, String) - 类 javax.management.MBeanParameterInfo 的构造方法
构造一个 MBeanParameterInfo 对象。
MBeanParameterInfo(String, String, String, Descriptor) - 类 javax.management.MBeanParameterInfo 的构造方法
构造一个 MBeanParameterInfo 对象。
MBeanPermission - javax.management 中的 类
权限控制对 MBeanServer 操作的访问。
MBeanPermission(String, String) - 类 javax.management.MBeanPermission 的构造方法
创建具有指定目标名称和操作的新 MBeanPermission 对象。
MBeanPermission(String, String, ObjectName, String) - 类 javax.management.MBeanPermission 的构造方法
创建具有指定目标名称（类名、成员、对象名）和操作的 MBeanPermission 对象。
MBeanRegistration - javax.management 中的 接口
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanRegistrationException - javax.management 中的 异常
包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
MBeanRegistrationException(Exception) - 异常 javax.management.MBeanRegistrationException 的构造方法
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException。
MBeanRegistrationException(Exception, String) - 异常 javax.management.MBeanRegistrationException 的构造方法
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException（带有详细消息）。
MBeanServer - javax.management 中的 接口
这是在代理端进行 MBean 操作的接口。
MBeanServerBuilder - javax.management 中的 类
此类表示创建默认 MBeanServer 实现的生成器。
MBeanServerBuilder() - 类 javax.management.MBeanServerBuilder 的构造方法
公共的默认构造方法。
MBeanServerConnection - javax.management 中的 接口
此接口表示了与 MBean 服务器（无论是本地的还是远程的）进行通信的一种方式。
MBeanServerDelegate - javax.management 中的 类
从管理的角度表示 MBean 服务器。
MBeanServerDelegate() - 类 javax.management.MBeanServerDelegate 的构造方法
创建一个 MBeanServerDelegate 对象。
MBeanServerDelegateMBean - javax.management 中的 接口
定义类 MBeanServerDelegate 的对象的管理接口。
MBeanServerFactory - javax.management 中的 类
提供 MBean 服务器引用。
MBeanServerForwarder - javax.management.remote 中的 接口
此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。
MBeanServerInvocationHandler - javax.management 中的 类
通过 MBean 服务器将 MBean 的管理接口中的方法转发到 MBean 的 InvocationHandler。
MBeanServerInvocationHandler(MBeanServerConnection, ObjectName) - 类 javax.management.MBeanServerInvocationHandler 的构造方法
通过 MBean 服务器将方法转发给 Standard MBean 的调用处理程序。
MBeanServerInvocationHandler(MBeanServerConnection, ObjectName, boolean) - 类 javax.management.MBeanServerInvocationHandler 的构造方法
可以通过 MBean 服务器将方法转发给 Standard MBean 或 MXBean 的调用处理程序。
MBeanServerNotification - javax.management 中的 类
表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。
MBeanServerNotification(String, Object, long, ObjectName) - 类 javax.management.MBeanServerNotification 的构造方法
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。
MBeanServerNotificationFilter - javax.management.relation 中的 类
MBeanServerNotification 的过滤器。
MBeanServerNotificationFilter() - 类 javax.management.relation.MBeanServerNotificationFilter 的构造方法
创建一个选中所有 ObjectName 的所有 MBeanServerNotification 通知的过滤器。
MBeanServerPermission - javax.management 中的 类
执行与 MBeanServer 关联的操作的 Permission。
MBeanServerPermission(String) - 类 javax.management.MBeanServerPermission 的构造方法
创建具有给定名称的新 MBeanServerPermission。
MBeanServerPermission(String, String) - 类 javax.management.MBeanServerPermission 的构造方法
创建具有给定名称的新 MBeanServerPermission。
MBeanTrustPermission - javax.management 中的 类
此权限表示“信任”签名者或代码基。
MBeanTrustPermission(String) - 类 javax.management.MBeanTrustPermission 的构造方法
创建具有给定名称的新 MBeanTrustPermission。
MBeanTrustPermission(String, String) - 类 javax.management.MBeanTrustPermission 的构造方法
创建具有给定名称的新 MBeanTrustPermission。
MD - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Media - javax.print.attribute.standard 中的 类
Media 类是打印属性类，它指定了要在其上打印的介质。
Media(int) - 类 javax.print.attribute.standard.Media 的构造方法
构造通过名称指定的新 Media 属性。
MEDIA_EMPTY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
至少一个输入纸盒是空的。
MEDIA_JAM - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备中卡住了介质。
MEDIA_LOW - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
至少一个输入纸盒的介质不足。
MEDIA_NEEDED - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
纸盒中没有介质。
MEDIA_TYPE - 类 javax.xml.transform.OutputKeys 中的静态变量
media-type = string. media-type 指定了输出结果树得到的数据的介质类型（MIME 内容类型）。
MediaName - javax.print.attribute.standard 中的 类
MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
MediaName(int) - 类 javax.print.attribute.standard.MediaName 的构造方法
构造具有给定整数值的新 MediaName 枚举值。
MediaPrintableArea - javax.print.attribute.standard 中的 类
MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
MediaPrintableArea(float, float, float, float, int) - 类 javax.print.attribute.standard.MediaPrintableArea 的构造方法
从浮点值构造 MediaPrintableArea 对象。
MediaPrintableArea(int, int, int, int, int) - 类 javax.print.attribute.standard.MediaPrintableArea 的构造方法
从整数值构造 MediaPrintableArea 对象。
MediaSize - javax.print.attribute.standard 中的 类
MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。
MediaSize(float, float, int) - 类 javax.print.attribute.standard.MediaSize 的构造方法
从给定浮点值构造新 MediaSize 属性。
MediaSize(int, int, int) - 类 javax.print.attribute.standard.MediaSize 的构造方法
从给定整数值构造新 MediaSize 属性。
MediaSize(float, float, int, MediaSizeName) - 类 javax.print.attribute.standard.MediaSize 的构造方法
从给定浮点值构造新 MediaSize 属性。
MediaSize(int, int, int, MediaSizeName) - 类 javax.print.attribute.standard.MediaSize 的构造方法
从给定整数值构造新 MediaSize 属性。
MediaSize.Engineering - javax.print.attribute.standard 中的 类
MediaSize.Engineering 类包括 engineering 介质的 MediaSize 值。
MediaSize.ISO - javax.print.attribute.standard 中的 类
MediaSize.ISO 类包括 ISO 介质的 MediaSize 值。
MediaSize.JIS - javax.print.attribute.standard 中的 类
MediaSize.JIS 类包括 JIS (Japanese) 介质的 MediaSize 值。
MediaSize.NA - javax.print.attribute.standard 中的 类
MediaSize.NA 类包括 North American 介质的 MediaSize 值。
MediaSize.Other - javax.print.attribute.standard 中的 类
MediaSize.Other 类包括其他介质的 MediaSize 值。
MediaSizeName - javax.print.attribute.standard 中的 类
MediaSizeName 类是 Media 的子类。
MediaSizeName(int) - 类 javax.print.attribute.standard.MediaSizeName 的构造方法
构造具有给定整数值的新 MediaSizeName 枚举值。
MediaTracker - java.awt 中的 类
MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。
MediaTracker(Component) - 类 java.awt.MediaTracker 的构造方法
创建媒体跟踪器以跟踪给定组件的图像。
MediaTray - javax.print.attribute.standard 中的 类
MediaTray 类是 Media 的子类。
MediaTray(int) - 类 javax.print.attribute.standard.MediaTray 的构造方法
构造具有给定整数值的新 MediaTray 枚举值。
MEDIUM - 类 java.text.DateFormat 中的静态变量
用于 MEDIUM 模式的常量。
Member - java.lang.reflect 中的 接口
成员是一种接口，反映有关单个成员（字段或方法）或构造方法的标识信息。
member() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 返回为了插入/获取此 union 成员而使用的 DynAny 对象引用。
member() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前活动成员。
member() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回当前活动成员。
member_count() - 类 org.omg.CORBA.TypeCode 中的方法
检索此 TypeCode 对象所描述类型中的成员数。
member_kind() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 返回与此 union 成员关联的 TCKind。
member_kind() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前活动成员 TypeCode 的 TCKind 值。
member_kind() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回当前活动成员 TypeCode 的 TCKind 值。
member_label(int) - 类 org.omg.CORBA.TypeCode 中的方法
检索给定索引标识的 union 成员的标签。
member_name() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 允许在没有检查鉴别符值的情况下检测此 union 成员的名称。
member_name(String) - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 允许分配此 union 成员的名称。
member_name(int) - 类 org.omg.CORBA.TypeCode 中的方法
检索给定索引标识的成员的简单名称。
member_name() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回当前活动成员的名称。
member_name() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
返回当前活动成员的名称。
MEMBER_OF - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个目标对象集合的成员。
MEMBER_OF_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
标识组成员已更改。
member_type(int) - 类 org.omg.CORBA.TypeCode 中的方法
检索一个 TypeCode 对象，它描述给定索引所标识成员的类型。
member_visibility(int) - 类 org.omg.CORBA.TypeCode 中的方法
返回一个常量，它指示位于给定索引处的成员的可见性。
members() - 接口 java.security.acl.Group 中的方法
返回此组中成员的枚举。
MEMORY_COLLECTION_THRESHOLD_EXCEEDED - 类 java.lang.management.MemoryNotificationInfo 中的静态变量
表示当 Java 虚拟机对内存池中的不使用的对象进行了回收工作之后，内存池的内存使用量大于或等于其集合使用量阈值的通知类型。
MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE - 类 java.lang.management.ManagementFactory 中的静态变量
MemoryManagerMXBean 的 ObjectName 中的域名和类型键属性。
MEMORY_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
MemoryMXBean 的 ObjectName 的字符串表示形式。
MEMORY_POOL_MXBEAN_DOMAIN_TYPE - 类 java.lang.management.ManagementFactory 中的静态变量
MemoryPoolMXBean 的 ObjectName 中的域名和类型键属性。
MEMORY_THRESHOLD_EXCEEDED - 类 java.lang.management.MemoryNotificationInfo 中的静态变量
表示内存池的内存使用量已达到或超过其使用量阈值的通知类型。
MemoryCacheImageInputStream - javax.imageio.stream 中的 类
从常规 InputStream 获取输入的 ImageInputStream 的实现。
MemoryCacheImageInputStream(InputStream) - 类 javax.imageio.stream.MemoryCacheImageInputStream 的构造方法
构造一个将从给定 InputStream 进行读取的 MemoryCacheImageInputStream。
MemoryCacheImageOutputStream - javax.imageio.stream 中的 类
将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
MemoryCacheImageOutputStream(OutputStream) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 的构造方法
构造将向给定 OutputStream 进行写入的 MemoryCacheImageOutputStream。
MemoryHandler - java.util.logging 中的 类
Handler 在内存中的循环缓冲区中对请求进行缓冲处理。
MemoryHandler() - 类 java.util.logging.MemoryHandler 的构造方法
根据 LogManager 配置属性创建一个 MemoryHandler，并对其进行配置。
MemoryHandler(Handler, int, Level) - 类 java.util.logging.MemoryHandler 的构造方法
创建一个 MemoryHandler。
MemoryImageSource - java.awt.image 中的 类
此类是 ImageProducer 接口的一个实现，该接口使用一个数组为 Image 生成像素值。
MemoryImageSource(int, int, ColorModel, byte[], int, int) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, ColorModel, byte[], int, int, Hashtable<?, ?>) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, ColorModel, int[], int, int) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, ColorModel, int[], int, int, Hashtable<?, ?>) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, int[], int, int) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int, int, int[], int, int, Hashtable<?, ?>) - 类 java.awt.image.MemoryImageSource 的构造方法
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryManagerMXBean - java.lang.management 中的 接口
内存管理器的管理接口。
MemoryMXBean - java.lang.management 中的 接口
Java 虚拟机内存系统的管理接口。
MemoryNotificationInfo - java.lang.management 中的 类
关于内存通知的信息。
MemoryNotificationInfo(String, MemoryUsage, long) - 类 java.lang.management.MemoryNotificationInfo 的构造方法
构造一个 MemoryNotificationInfo 对象。
MemoryPoolMXBean - java.lang.management 中的 接口
内存池的管理接口。
MemoryType - java.lang.management 中的 枚举
内存池的类型。
MemoryUsage - java.lang.management 中的 类
表示内存使用量快照的 MemoryUsage 对象。
MemoryUsage(long, long, long, long) - 类 java.lang.management.MemoryUsage 的构造方法
构造一个 MemoryUsage 对象。
Menu - java.awt 中的 类
Menu 对象是从菜单栏部署的下拉式菜单组件。
Menu() - 类 java.awt.Menu 的构造方法
构造具有空标签的新菜单。
Menu(String) - 类 java.awt.Menu 的构造方法
构造具有指定标签的新菜单。
Menu(String, boolean) - 类 java.awt.Menu 的构造方法
构造具有指定标签的新菜单，指示该菜单是否可以分离。
MENU - 类 java.awt.SystemColor 中的静态变量
SystemColor.menu 系统颜色的数组索引。
menu - 类 java.awt.SystemColor 中的静态变量
为菜单提供的背景色。
MENU - 类 javax.accessibility.AccessibleRole 中的静态变量
通常出现在菜单栏中的对象，它包含一个用户可以从中选择的动作列表。
menu - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的变量
MENU - 类 javax.swing.plaf.synth.Region 中的静态变量
Menu 的 region。
MENU - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Menu.AccessibleAWTMenu - java.awt 中的 类
菜单的内部类，用于为可访问性提供默认支持。
Menu.AccessibleAWTMenu() - 类 java.awt.Menu.AccessibleAWTMenu 的构造方法
MENU_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
通常被绘制在应用程序的主对话框顶部的对象，它包含用户可以从中进行选择的菜单列表。
MENU_BAR - 类 javax.swing.plaf.synth.Region 中的静态变量
MenuBar 的 region。
MENU_BAR_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
MENU_ITEM - 类 javax.accessibility.AccessibleRole 中的静态变量
通常包含在菜单中的对象，该对象呈现用户可以选择的动作。
MENU_ITEM - 类 javax.swing.plaf.synth.Region 中的静态变量
MenuItem 的 region。
MENU_ITEM_ACCELERATOR - 类 javax.swing.plaf.synth.Region 中的静态变量
MenuItem 的加速器 region。
MENU_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.menuText 系统颜色的数组索引。
MenuBar - java.awt 中的 类
MenuBar 类封装绑定到框架的菜单栏的平台概念。
MenuBar() - 类 java.awt.MenuBar 的构造方法
创建新的菜单栏。
menuBar - 类 javax.swing.JRootPane 中的变量
菜单栏。
menuBar - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
menuBar - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的变量
MenuBar.AccessibleAWTMenuBar - java.awt 中的 类
菜单栏的内部类，用于为可访问性提供默认支持。
MenuBar.AccessibleAWTMenuBar() - 类 java.awt.MenuBar.AccessibleAWTMenuBar 的构造方法
MenuBarUI - javax.swing.plaf 中的 类
JMenuBar 的可插入外观界面。
MenuBarUI() - 类 javax.swing.plaf.MenuBarUI 的构造方法
menuCanceled(MenuEvent) - 接口 javax.swing.event.MenuListener 中的方法
取消菜单时调用。
MenuComponent - java.awt 中的 类
抽象类 MenuComponent 是所有与菜单相关的组件的超类。
MenuComponent() - 类 java.awt.MenuComponent 的构造方法
创建 MenuComponent。
MenuComponent.AccessibleAWTMenuComponent - java.awt 中的 类
用于为可访问性提供默认支持的 MenuComponent 的内部类。
MenuComponent.AccessibleAWTMenuComponent() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 的构造方法
尽管该类是抽象的，但是应该可以通过所有子类调用它。
MenuContainer - java.awt 中的 接口
所有菜单相关容器的超类。
menuDeselected(MenuEvent) - 接口 javax.swing.event.MenuListener 中的方法
取消选择某个菜单时调用。
menuDragMouseDragged(MenuDragMouseEvent) - 接口 javax.swing.event.MenuDragMouseListener 中的方法
当鼠标被拖动到某一菜单组件的显示区域中时调用。
menuDragMouseEntered(MenuDragMouseEvent) - 接口 javax.swing.event.MenuDragMouseListener 中的方法
当拖动的鼠标进入某一菜单组件的显示区域时调用。
MenuDragMouseEvent - javax.swing.event 中的 类
MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
MenuDragMouseEvent(Component, int, long, int, int, int, int, boolean, MenuElement[], MenuSelectionManager) - 类 javax.swing.event.MenuDragMouseEvent 的构造方法
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component, int, long, int, int, int, int, int, int, boolean, MenuElement[], MenuSelectionManager) - 类 javax.swing.event.MenuDragMouseEvent 的构造方法
构造一个 MenuDragMouseEvent 对象。
menuDragMouseExited(MenuDragMouseEvent) - 接口 javax.swing.event.MenuDragMouseListener 中的方法
当拖动的鼠标离开某一菜单组件的显示区域时调用。
MenuDragMouseListener - javax.swing.event 中的 接口
定义一个菜单鼠标拖动侦听器。
menuDragMouseListener - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
menuDragMouseReleased(MenuDragMouseEvent) - 接口 javax.swing.event.MenuDragMouseListener 中的方法
当在菜单组件的显示区域中释放拖动鼠标时调用。
MenuElement - javax.swing 中的 接口
可以放入菜单中的所有组件都应该实现此接口。
MenuEvent - javax.swing.event 中的 类
MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。
MenuEvent(Object) - 类 javax.swing.event.MenuEvent 的构造方法
构造一个 MenuEvent 对象。
MenuItem - java.awt 中的 类
菜单中的所有项必须属于类 MenuItem 或其子类之一。
MenuItem() - 类 java.awt.MenuItem 的构造方法
构造具有空标签且没有键盘快捷方式的新菜单项。
MenuItem(String) - 类 java.awt.MenuItem 的构造方法
构造具有指定的标签且没有键盘快捷方式的新菜单项。
MenuItem(String, MenuShortcut) - 类 java.awt.MenuItem 的构造方法
创建具有关联的键盘快捷方式的菜单项。
menuItem - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
MenuItem.AccessibleAWTMenuItem - java.awt 中的 类
用于为可访问性提供默认支持的 MenuItem 的内部类。
MenuItem.AccessibleAWTMenuItem() - 类 java.awt.MenuItem.AccessibleAWTMenuItem 的构造方法
MenuItemUI - javax.swing.plaf 中的 类
JMenuItem 的可插入外观界面。
MenuItemUI() - 类 javax.swing.plaf.MenuItemUI 的构造方法
MenuKeyEvent - javax.swing.event 中的 类
MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
MenuKeyEvent(Component, int, long, int, int, char, MenuElement[], MenuSelectionManager) - 类 javax.swing.event.MenuKeyEvent 的构造方法
构造一个 MenuKeyEvent 对象。
MenuKeyListener - javax.swing.event 中的 接口
MenuKeyListener
menuKeyListener - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
menuKeyPressed(MenuKeyEvent) - 接口 javax.swing.event.MenuKeyListener 中的方法
已按下某个键时调用。
menuKeyReleased(MenuKeyEvent) - 接口 javax.swing.event.MenuKeyListener 中的方法
已释放某个键时调用。
menuKeyTyped(MenuKeyEvent) - 接口 javax.swing.event.MenuKeyListener 中的方法
已键入某个键时调用。
MenuListener - javax.swing.event 中的 接口
定义一个菜单事件侦听器。
menuListener - 类 javax.swing.plaf.basic.BasicMenuUI 中的变量
menuSelected(MenuEvent) - 接口 javax.swing.event.MenuListener 中的方法
选择某个菜单时调用。
menuSelectionChanged(boolean) - 类 javax.swing.JMenu 中的方法
当菜单栏选择更改为激活或取消激活此菜单时传递消息。
menuSelectionChanged(boolean) - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement（不执行任何操作）。
menuSelectionChanged(boolean) - 类 javax.swing.JMenuItem 中的方法
当选择或取消选择 MenuElement 时由 MenuSelectionManager 调用。
menuSelectionChanged(boolean) - 类 javax.swing.JPopupMenu 中的方法
当菜单栏选择发生更改以激活或取消激活此菜单时传递消息。
menuSelectionChanged(boolean) - 接口 javax.swing.MenuElement 中的方法
在向菜单选择中添加或从中删除 MenuElement 时，由 MenuSelectionManager 调用。
MenuSelectionManager - javax.swing 中的 类
MenuSelectionManager 拥有菜单层次结构中的选项。
MenuSelectionManager() - 类 javax.swing.MenuSelectionManager 的构造方法
MenuShortcut - java.awt 中的 类
表示 MenuItem 键盘加速器的 MenuShortcut 类。
MenuShortcut(int) - 类 java.awt.MenuShortcut 的构造方法
为指定的虚拟键代码构造一个新的 MenuShortcut。
MenuShortcut(int, boolean) - 类 java.awt.MenuShortcut 的构造方法
为指定的虚拟键代码构造一个新的菜单快捷方式。
menuText - 类 java.awt.SystemColor 中的静态变量
为菜单文本提供的颜色。
mergeTree(String, Node) - 类 javax.imageio.metadata.IIOMetadata 中的方法
根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。
message - 类 javax.swing.JOptionPane 中的变量
要显示的消息。
MESSAGE_OUTBOUND_PROPERTY - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：消息方向，对于出站消息为 true，对于入站消息为 false。
MESSAGE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
message 的绑定属性名。
MESSAGE_TYPE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
type 的绑定属性名。
MessageContext - javax.xml.ws.handler 中的 接口
接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。
MessageContext.Scope - javax.xml.ws.handler 中的 枚举
属性作用域。
MessageDigest - java.security 中的 类
此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。
MessageDigest(String) - 类 java.security.MessageDigest 的构造方法
创建具有指定算法名称的信息摘要。
MessageDigestSpi - java.security 中的 类
此类为 MessageDigest 类定义服务提供者接口 (SPI)，MessageDigest 类提供信息摘要算法的功能，如 MD5 或 SHA。
MessageDigestSpi() - 类 java.security.MessageDigestSpi 的构造方法
MessageFactory - javax.xml.soap 中的 类
创建 SOAPMessage 对象的工厂。
MessageFactory() - 类 javax.xml.soap.MessageFactory 的构造方法
MessageFormat - java.text 中的 类
MessageFormat 提供了以与语言无关方式生成连接消息的方式。
MessageFormat(String) - 类 java.text.MessageFormat 的构造方法
构造默认语言环境和指定模式的 MessageFormat。
MessageFormat(String, Locale) - 类 java.text.MessageFormat 的构造方法
构造指定语言环境和模式的 MessageFormat。
MessageFormat.Field - java.text 中的 类
在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
MessageFormat.Field(String) - 类 java.text.MessageFormat.Field 的构造方法
创建具有指定名称的 Field。
MessageProp - org.ietf.jgss 中的 类
这是一个在 per-message GSSContext 方法中使用的、用来传送 per-message 属性的实用工具类。
MessageProp(boolean) - 类 org.ietf.jgss.MessageProp 的构造方法
设置所需私密状态的构造方法。
MessageProp(int, boolean) - 类 org.ietf.jgss.MessageProp 的构造方法
设置 qop 和私密状态值的构造方法。
Messager - javax.annotation.processing 中的 接口
Messager 提供注释处理器用来报告错误消息、警告和其他通知的方式。
messageType - 类 javax.swing.JOptionPane 中的变量
消息类型。
meta(MetaMessage) - 接口 javax.sound.midi.MetaEventListener 中的方法
在 Sequencer 遇到并处理了一个它正在处理的 Sequence 中的 MetaMessage 时调用。
META - 类 javax.sound.midi.MetaMessage 中的静态变量
MetaMessage 的状态字节（0xFF 或 255），供在 MIDI 文件中使用。
META - 类 javax.swing.text.html.HTML.Tag 中的静态变量
meta - 类 javax.swing.text.html.parser.DTD 中的变量
META_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Meta 键的扩展修饰符常量。
META_MASK - 类 java.awt.event.ActionEvent 中的静态变量
meta 修饰符。
META_MASK - 类 java.awt.event.InputEvent 中的静态变量
Meta 键修饰符常量。
META_MASK - 类 java.awt.Event 中的静态变量
此标志指示当事件发生时按下 Meta 键。
metadata - 类 javax.imageio.IIOImage 中的变量
包含与图像关联的元数据的 IIOMetadata 对象。
metaDown() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
MetaEventListener - javax.sound.midi 中的 接口
MetaEventListener 接口应由其实例需要在 Sequencer 处理了 MetaMessage 时接收通知的类实现。
MetalBorders - javax.swing.plaf.metal 中的 类
可以提供适用于 metal L & F 的 Border 的工厂对象。
MetalBorders() - 类 javax.swing.plaf.metal.MetalBorders 的构造方法
MetalBorders.ButtonBorder - javax.swing.plaf.metal 中的 类
MetalBorders.ButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 的构造方法
MetalBorders.Flush3DBorder - javax.swing.plaf.metal 中的 类
MetalBorders.Flush3DBorder() - 类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 的构造方法
MetalBorders.InternalFrameBorder - javax.swing.plaf.metal 中的 类
MetalBorders.InternalFrameBorder() - 类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 的构造方法
MetalBorders.MenuBarBorder - javax.swing.plaf.metal 中的 类
MetalBorders.MenuBarBorder() - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 的构造方法
MetalBorders.MenuItemBorder - javax.swing.plaf.metal 中的 类
MetalBorders.MenuItemBorder() - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 的构造方法
MetalBorders.OptionDialogBorder - javax.swing.plaf.metal 中的 类
MetalBorders.OptionDialogBorder() - 类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 的构造方法
MetalBorders.PaletteBorder - javax.swing.plaf.metal 中的 类
Palette 的边框。
MetalBorders.PaletteBorder() - 类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 的构造方法
MetalBorders.PopupMenuBorder - javax.swing.plaf.metal 中的 类
MetalBorders.PopupMenuBorder() - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 的构造方法
MetalBorders.RolloverButtonBorder - javax.swing.plaf.metal 中的 类
MetalBorders.RolloverButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder 的构造方法
MetalBorders.ScrollPaneBorder - javax.swing.plaf.metal 中的 类
MetalBorders.ScrollPaneBorder() - 类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 的构造方法
MetalBorders.TableHeaderBorder - javax.swing.plaf.metal 中的 类
Table Header 的边框
MetalBorders.TableHeaderBorder() - 类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 的构造方法
MetalBorders.TextFieldBorder - javax.swing.plaf.metal 中的 类
MetalBorders.TextFieldBorder() - 类 javax.swing.plaf.metal.MetalBorders.TextFieldBorder 的构造方法
MetalBorders.ToggleButtonBorder - javax.swing.plaf.metal 中的 类
MetalBorders.ToggleButtonBorder() - 类 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder 的构造方法
MetalBorders.ToolBarBorder - javax.swing.plaf.metal 中的 类
MetalBorders.ToolBarBorder() - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 的构造方法
MetalButtonUI - javax.swing.plaf.metal 中的 类
MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
MetalButtonUI() - 类 javax.swing.plaf.metal.MetalButtonUI 的构造方法
MetalCheckBoxIcon - javax.swing.plaf.metal 中的 类
OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
MetalCheckBoxIcon() - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 的构造方法
MetalCheckBoxUI - javax.swing.plaf.metal 中的 类
MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalCheckBoxUI() - 类 javax.swing.plaf.metal.MetalCheckBoxUI 的构造方法
MetalComboBoxButton - javax.swing.plaf.metal 中的 类
协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxButton(JComboBox, Icon, CellRendererPane, JList) - 类 javax.swing.plaf.metal.MetalComboBoxButton 的构造方法
MetalComboBoxButton(JComboBox, Icon, boolean, CellRendererPane, JList) - 类 javax.swing.plaf.metal.MetalComboBoxButton 的构造方法
MetalComboBoxEditor - javax.swing.plaf.metal 中的 类
Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxEditor() - 类 javax.swing.plaf.metal.MetalComboBoxEditor 的构造方法
MetalComboBoxEditor.UIResource - javax.swing.plaf.metal 中的 类
实现 UIResource 的 BasicComboBoxEditor 的一个子类。
MetalComboBoxEditor.UIResource() - 类 javax.swing.plaf.metal.MetalComboBoxEditor.UIResource 的构造方法
MetalComboBoxIcon - javax.swing.plaf.metal 中的 类
此实用工具类绘制指示 MetalComboBox 的水平条
MetalComboBoxIcon() - 类 javax.swing.plaf.metal.MetalComboBoxIcon 的构造方法
MetalComboBoxUI - javax.swing.plaf.metal 中的 类
JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalComboBoxUI() - 类 javax.swing.plaf.metal.MetalComboBoxUI 的构造方法
MetalComboBoxUI.MetalComboBoxLayoutManager - javax.swing.plaf.metal 中的 类
此内部类因编译器故障而被标记为 "public"。
MetalComboBoxUI.MetalComboBoxLayoutManager() - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager 的构造方法
MetalComboBoxUI.MetalComboPopup - javax.swing.plaf.metal 中的 类
已过时。 从 Java 2 platform v1.4 开始。
MetalComboBoxUI.MetalComboPopup(JComboBox) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup 的构造方法
已过时。
MetalComboBoxUI.MetalPropertyChangeListener - javax.swing.plaf.metal 中的 类
此内部类由于编译器故障而被标记为 "public"。
MetalComboBoxUI.MetalPropertyChangeListener() - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener 的构造方法
MetalDesktopIconUI - javax.swing.plaf.metal 中的 类
Metal 桌面图标。
MetalDesktopIconUI() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 的构造方法
MetalFileChooserUI - javax.swing.plaf.metal 中的 类
FileChooser 的 Metal L&F 实现。
MetalFileChooserUI(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 的构造方法
MetalFileChooserUI.DirectoryComboBoxAction - javax.swing.plaf.metal 中的 类
当 DirectoryComboBox 已更改所选项时调用。
MetalFileChooserUI.DirectoryComboBoxAction() - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction 的构造方法
MetalFileChooserUI.DirectoryComboBoxModel - javax.swing.plaf.metal 中的 类
字体选择组合框的数据模型。
MetalFileChooserUI.DirectoryComboBoxModel() - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 的构造方法
MetalFileChooserUI.FileRenderer - javax.swing.plaf.metal 中的 类
MetalFileChooserUI.FileRenderer() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer 的构造方法
MetalFileChooserUI.FilterComboBoxModel - javax.swing.plaf.metal 中的 类
字体选择组合框的数据模型。
MetalFileChooserUI.FilterComboBoxModel() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 的构造方法
MetalFileChooserUI.FilterComboBoxRenderer - javax.swing.plaf.metal 中的 类
呈现不同的类型大小和风格。
MetalFileChooserUI.FilterComboBoxRenderer() - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer 的构造方法
MetalFileChooserUI.SingleClickListener - javax.swing.plaf.metal 中的 类
MetalFileChooserUI.SingleClickListener(JList) - 类 javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener 的构造方法
MetalIconFactory - javax.swing.plaf.metal 中的 类
为 JavaTM 外观 (Metal) 提供 Icon 的工厂对象。
MetalIconFactory() - 类 javax.swing.plaf.metal.MetalIconFactory 的构造方法
MetalIconFactory.FileIcon16 - javax.swing.plaf.metal 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.FileIcon16() - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 的构造方法
MetalIconFactory.FolderIcon16 - javax.swing.plaf.metal 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.FolderIcon16() - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 的构造方法
MetalIconFactory.PaletteCloseIcon - javax.swing.plaf.metal 中的 类
定义一个用于 Palette 关闭的图标
MetalIconFactory.PaletteCloseIcon() - 类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 的构造方法
MetalIconFactory.TreeControlIcon - javax.swing.plaf.metal 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.TreeControlIcon(boolean) - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 的构造方法
MetalIconFactory.TreeFolderIcon - javax.swing.plaf.metal 中的 类
警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalIconFactory.TreeFolderIcon() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon 的构造方法
MetalIconFactory.TreeLeafIcon - javax.swing.plaf.metal 中的 类
MetalIconFactory.TreeLeafIcon() - 类 javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon 的构造方法
MetalInternalFrameTitlePane - javax.swing.plaf.metal 中的 类
管理 JLF 标题栏的类
MetalInternalFrameTitlePane(JInternalFrame) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 的构造方法
MetalInternalFrameUI - javax.swing.plaf.metal 中的 类
JInternalFrame 的 Metal 实现。
MetalInternalFrameUI(JInternalFrame) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 的构造方法
MetalLabelUI - javax.swing.plaf.metal 中的 类
LabelUI 的 Windows L&F 实现。
MetalLabelUI() - 类 javax.swing.plaf.metal.MetalLabelUI 的构造方法
metalLabelUI - 类 javax.swing.plaf.metal.MetalLabelUI 中的静态变量
默认的 MetalLabelUI 实例。
MetalLookAndFeel - javax.swing.plaf.metal 中的 类
Java 外观，也称为 Metal。
MetalLookAndFeel() - 类 javax.swing.plaf.metal.MetalLookAndFeel 的构造方法
MetalMenuBarUI - javax.swing.plaf.metal 中的 类
MenuBarUI 的 Metal 实现。
MetalMenuBarUI() - 类 javax.swing.plaf.metal.MetalMenuBarUI 的构造方法
MetalPopupMenuSeparatorUI - javax.swing.plaf.metal 中的 类
PopupMenuSeparatorUI 的 Metal L&F 实现。
MetalPopupMenuSeparatorUI() - 类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 的构造方法
MetalProgressBarUI - javax.swing.plaf.metal 中的 类
ProgressBarUI 的 Metal 实现。
MetalProgressBarUI() - 类 javax.swing.plaf.metal.MetalProgressBarUI 的构造方法
MetalRadioButtonUI - javax.swing.plaf.metal 中的 类
MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalRadioButtonUI() - 类 javax.swing.plaf.metal.MetalRadioButtonUI 的构造方法
MetalRootPaneUI - javax.swing.plaf.metal 中的 类
提供 RootPaneUI 的 metal 外观实现。
MetalRootPaneUI() - 类 javax.swing.plaf.metal.MetalRootPaneUI 的构造方法
MetalScrollBarUI - javax.swing.plaf.metal 中的 类
ScrollBarUI 的 Metal 外观实现
MetalScrollBarUI() - 类 javax.swing.plaf.metal.MetalScrollBarUI 的构造方法
MetalScrollButton - javax.swing.plaf.metal 中的 类
Metal 滚动条箭头的 JButton 对象。
MetalScrollButton(int, int, boolean) - 类 javax.swing.plaf.metal.MetalScrollButton 的构造方法
MetalScrollPaneUI - javax.swing.plaf.metal 中的 类
ScrollPaneUI 的 Metal L&F 实现。
MetalScrollPaneUI() - 类 javax.swing.plaf.metal.MetalScrollPaneUI 的构造方法
MetalSeparatorUI - javax.swing.plaf.metal 中的 类
SeparatorUI 的 Metal L&F 实现。
MetalSeparatorUI() - 类 javax.swing.plaf.metal.MetalSeparatorUI 的构造方法
MetalSliderUI - javax.swing.plaf.metal 中的 类
SliderUI 的 Java L&F 实现。
MetalSliderUI() - 类 javax.swing.plaf.metal.MetalSliderUI 的构造方法
MetalSliderUI.MetalPropertyListener - javax.swing.plaf.metal 中的 类
MetalSliderUI.MetalPropertyListener() - 类 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener 的构造方法
MetalSplitPaneUI - javax.swing.plaf.metal 中的 类
Metal 分隔窗格。
MetalSplitPaneUI() - 类 javax.swing.plaf.metal.MetalSplitPaneUI 的构造方法
MetalTabbedPaneUI - javax.swing.plaf.metal 中的 类
BasicTabbedPaneUI 的 Metal 子类。
MetalTabbedPaneUI() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 的构造方法
MetalTabbedPaneUI.TabbedPaneLayout - javax.swing.plaf.metal 中的 类
此内部类由于编译器故障而被标记为 "public"。
MetalTabbedPaneUI.TabbedPaneLayout() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 的构造方法
MetalTextFieldUI - javax.swing.plaf.metal 中的 类
JTextField 外观的基础。
MetalTextFieldUI() - 类 javax.swing.plaf.metal.MetalTextFieldUI 的构造方法
MetalTheme - javax.swing.plaf.metal 中的 类
MetalTheme 提供 Java 外观所使用的调色板和字体。
MetalTheme() - 类 javax.swing.plaf.metal.MetalTheme 的构造方法
MetalToggleButtonUI - javax.swing.plaf.metal 中的 类
MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
MetalToggleButtonUI() - 类 javax.swing.plaf.metal.MetalToggleButtonUI 的构造方法
MetalToolBarUI - javax.swing.plaf.metal 中的 类
ToolBarUI 的 Metal 外观实现。
MetalToolBarUI() - 类 javax.swing.plaf.metal.MetalToolBarUI 的构造方法
MetalToolBarUI.MetalContainerListener - javax.swing.plaf.metal 中的 类
MetalToolBarUI.MetalContainerListener() - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener 的构造方法
MetalToolBarUI.MetalDockingListener - javax.swing.plaf.metal 中的 类
MetalToolBarUI.MetalDockingListener(JToolBar) - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 的构造方法
MetalToolBarUI.MetalRolloverListener - javax.swing.plaf.metal 中的 类
MetalToolBarUI.MetalRolloverListener() - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener 的构造方法
MetalToolTipUI - javax.swing.plaf.metal 中的 类
BasicToolTipUI 的 Metal L&F 扩展。
MetalToolTipUI() - 类 javax.swing.plaf.metal.MetalToolTipUI 的构造方法
MetalTreeUI - javax.swing.plaf.metal 中的 类
TreeUI 的 metal 外观实现。
MetalTreeUI() - 类 javax.swing.plaf.metal.MetalTreeUI 的构造方法
MetaMessage - javax.sound.midi 中的 类
MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。
MetaMessage() - 类 javax.sound.midi.MetaMessage 的构造方法
构造一个新的 MetaMessage。
MetaMessage(byte[]) - 类 javax.sound.midi.MetaMessage 的构造方法
构造一个新的 MetaMessage。
Method - java.lang.reflect 中的 类
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。
method - 类 java.net.HttpURLConnection 中的变量
HTTP 方法（GET、POST、PUT 等）。
METHOD - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
METHOD - 类 javax.xml.transform.OutputKeys 中的静态变量
method = "xml" | "html" | "text" | expanded name。
METHOD_ATTRIBUTE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
当与方法属性名称连在一起时，指出该属性的格式。
MethodDescriptor - java.beans 中的 类
MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。
MethodDescriptor(Method) - 类 java.beans.MethodDescriptor 的构造方法
根据 Method 构造一个 MethodDescriptor。
MethodDescriptor(Method, ParameterDescriptor[]) - 类 java.beans.MethodDescriptor 的构造方法
根据为每个方法参数提供描述性信息的 Method 构造一个 MethodDescriptor。
methodsIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中方法的列表。
methodsIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中方法的集合。
metrics - 类 javax.swing.text.PlainView 中的变量
当前字体的字体规格。
MGF1ParameterSpec - java.security.spec 中的 类
此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。
MGF1ParameterSpec(String) - 类 java.security.spec.MGF1ParameterSpec 的构造方法
构造如 PKCS #1 标准中所定义的掩码生成函数 MGF1 的参数集。
MICROPHONE - 类 javax.sound.sampled.Port.Info 中的静态变量
从内置麦克风或麦克风插孔中获得音频端口类型。
microsecondLength - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的持续时间，以微秒为单位。
MIDDLE - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的中层进纸托盘。
MIDI_SYNC - 类 javax.sound.midi.Sequencer.SyncMode 中的静态变量
指定使用 MIDI 时钟消息的主或辅同步模式。
MIDI_TIME_CODE - 类 javax.sound.midi.Sequencer.SyncMode 中的静态变量
指定使用 MIDI 时间代码的主或辅同步模式如果此模式用作主同步模式，sequencer 从 MIDI 时间代码消息获取其计时信息。
MIDI_TIME_CODE - 类 javax.sound.midi.ShortMessage 中的静态变量
MIDI Time Code Quarter Frame 消息的状态字节（0xF1 或 241）。
MidiChannel - javax.sound.midi 中的 接口
表示一个单独 MIDI 通道的 MidiChannel 对象。
MidiDevice - javax.sound.midi 中的 接口
MidiDevice 是用于所有 MIDI 设备的基接口。
MidiDevice.Info - javax.sound.midi 中的 类
一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。
MidiDevice.Info(String, String, String, String) - 类 javax.sound.midi.MidiDevice.Info 的构造方法
构造一个设备 info 对象。
MidiDeviceProvider - javax.sound.midi.spi 中的 类
MidiDeviceProvider 是特定类型的 MIDI 设备的工厂或提供者。
MidiDeviceProvider() - 类 javax.sound.midi.spi.MidiDeviceProvider 的构造方法
MidiEvent - javax.sound.midi 中的 类
MIDI 事件包含一个 MIDI 消息和一个相应的用刻度表示的时间戳，可代表存储在 MIDI 文件或 Sequence 对象中的 MIDI 事件信息。
MidiEvent(MidiMessage, long) - 类 javax.sound.midi.MidiEvent 的构造方法
构造一个新的 MidiEvent。
MidiFileFormat - javax.sound.midi 中的 类
MidiFileFormat 对象，它封装了 MIDI 文件的类型、长度和定时信息。
MidiFileFormat(int, float, int, int, long) - 类 javax.sound.midi.MidiFileFormat 的构造方法
构造一个 MidiFileFormat。
MidiFileFormat(int, float, int, int, long, Map<String, Object>) - 类 javax.sound.midi.MidiFileFormat 的构造方法
构造带一组属性的 MidiFileFormat。
MidiFileReader - javax.sound.midi.spi 中的 类
MidiFileReader 提供 MIDI 文件读取服务。
MidiFileReader() - 类 javax.sound.midi.spi.MidiFileReader 的构造方法
MidiFileWriter - javax.sound.midi.spi 中的 类
MidiFileWriter 提供 MIDI 文件写入服务。
MidiFileWriter() - 类 javax.sound.midi.spi.MidiFileWriter 的构造方法
MidiMessage - javax.sound.midi 中的 类
MidiMessage 是 MIDI 消息的基类。
MidiMessage(byte[]) - 类 javax.sound.midi.MidiMessage 的构造方法
构造一个新的 MidiMessage。
MidiSystem - javax.sound.midi 中的 类
MidiSystem 类提供了对已安装的 MIDI 系统资源的访问，包括诸如 synthesizer、sequencer 和 MIDI 输入和输出端口等设备。
MidiUnavailableException - javax.sound.midi 中的 异常
当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。
MidiUnavailableException() - 异常 javax.sound.midi.MidiUnavailableException 的构造方法
构造一个 MidiUnavailableException，使用 null 作为其错误详细消息。
MidiUnavailableException(String) - 异常 javax.sound.midi.MidiUnavailableException 的构造方法
构造带指定详细消息的 MidiUnavailableException。
MILLISECOND - 类 java.text.DateFormat.Field 中的静态变量
标识 MILLISECOND 字段的常量。
MILLISECOND - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一秒中的毫秒。
MILLISECOND_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 MILLISECOND 字段的有用常量。
MimeHeader - javax.xml.soap 中的 类
存储 MIME 头名称及其值的对象。
MimeHeader(String, String) - 类 javax.xml.soap.MimeHeader 的构造方法
构造使用给定的名称和值初始化的 MimeHeader 对象。
MimeHeaders - javax.xml.soap 中的 类
MimeHeader 对象的容器，这些对象表示出现在消息的 MIME 部分的 MIME 头。
MimeHeaders() - 类 javax.xml.soap.MimeHeaders 的构造方法
构造一个用空 Vector 对象初始化的默认 MimeHeaders 对象。
MimeType - javax.activation 中的 类
RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。
MimeType() - 类 javax.activation.MimeType 的构造方法
默认的构造方法。
MimeType(String) - 类 javax.activation.MimeType 的构造方法
根据 String 构建 MimeType 的构造方法。
MimeType(String, String) - 类 javax.activation.MimeType 的构造方法
用给定的基本类型和子类型构建 MimeType 的构造方法，它的参数列表为空。
MimeTypeParameterList - javax.activation 中的 类
RFC 2045 和 2046 中定义的 MimeType 参数列表。
MimeTypeParameterList() - 类 javax.activation.MimeTypeParameterList 的构造方法
默认的构造方法。
MimeTypeParameterList(String) - 类 javax.activation.MimeTypeParameterList 的构造方法
用传入的数据构造新的 MimeTypeParameterList。
MimeTypeParseException - java.awt.datatransfer 中的 异常
对分析相关异常的 MimeType 进行封装的类
MimeTypeParseException() - 异常 java.awt.datatransfer.MimeTypeParseException 的构造方法
构造不带指定详细消息的 MimeTypeParseException。
MimeTypeParseException(String) - 异常 java.awt.datatransfer.MimeTypeParseException 的构造方法
构造带指定详细消息的 MimeTypeParseException。
MimeTypeParseException - javax.activation 中的 异常
封装与 MimeType 解析相关的异常的类。
MimeTypeParseException() - 异常 javax.activation.MimeTypeParseException 的构造方法
构造不带指定详细消息的 MimeTypeParseException。
MimeTypeParseException(String) - 异常 javax.activation.MimeTypeParseException 的构造方法
构造带指定详细消息的 MimeTypeParseException。
MIMETypes - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
从 getMIMETypes 返回的字符串数组，该数组最初为 null。
MimetypesFileTypeMap - javax.activation 中的 类
此类扩展 FileTypeMap 并通过其文件扩展名提供文件的数据分类。
MimetypesFileTypeMap() - 类 javax.activation.MimetypesFileTypeMap 的构造方法
默认的构造方法。
MimetypesFileTypeMap(String) - 类 javax.activation.MimetypesFileTypeMap 的构造方法
用从指定文件中添加的编程条目构造 MimetypesFileTypeMap。
MimetypesFileTypeMap(InputStream) - 类 javax.activation.MimetypesFileTypeMap 的构造方法
用从 InputStream 中添加的编程条目构造 MimetypesFileTypeMap。
min(int, int) - 类 java.lang.Math 中的静态方法
返回两个 int 值中较小的一个。
min(long, long) - 类 java.lang.Math 中的静态方法
返回两个 long 值中较小的一个。
min(float, float) - 类 java.lang.Math 中的静态方法
返回两个 float 值中较小的一个。
min(double, double) - 类 java.lang.Math 中的静态方法
返回两个 double 值中较小的一个。
min(int, int) - 类 java.lang.StrictMath 中的静态方法
返回两个 int 值中较小的一个。
min(long, long) - 类 java.lang.StrictMath 中的静态方法
返回两个 long 值中较小的一个。
min(float, float) - 类 java.lang.StrictMath 中的静态方法
返回两个 float 值中较小的一个。
min(double, double) - 类 java.lang.StrictMath 中的静态方法
返回两个 double 值中较小的一个。
min(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 和 val 的最小值。
min(BigInteger) - 类 java.math.BigInteger 中的方法
返回此 BigInteger 和 val 的最小值。
min(Collection<? extends T>) - 类 java.util.Collections 中的静态方法
根据元素的自然顺序 返回给定 collection 的最小元素。
min(Collection<? extends T>, Comparator<? super T>) - 类 java.util.Collections 中的静态方法
根据指定比较器产生的顺序，返回给定 collection 的最小元素。
MIN_CODE_POINT - 类 java.lang.Character 中的静态变量
Unicode 代码点的最小值。
MIN_EXPONENT - 类 java.lang.Double 中的静态变量
标准化 double 变量可能具有的最小指数。
MIN_EXPONENT - 类 java.lang.Float 中的静态变量
标准化 float 变量可能具有的最小指数。
MIN_HIGH_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 高代理项代码单元的最小值。
MIN_LOW_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 低代理项代码单元的最小值。
MIN_NORMAL - 类 java.lang.Double 中的静态变量
保存 double 类型的最小正标准值的常量，最小正标准值为 2-1022。
MIN_NORMAL - 类 java.lang.Float 中的静态变量
保存 float 类型数据的最小正标准值的常量，即 2-126。
MIN_PRIORITY - 类 java.lang.Thread 中的静态变量
线程可以具有的最低优先级。
MIN_RADIX - 类 java.lang.Character 中的静态变量
可用于与字符串相互转换的最小基数。
MIN_SCROLL - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态变量
MIN_SUPPLEMENTARY_CODE_POINT - 类 java.lang.Character 中的静态变量
增补代码点的最小值。
MIN_SURROGATE - 类 java.lang.Character 中的静态变量
UTF-16 编码中的 Unicode 代理项代码单元的最小值。
MIN_TIMEZONE_OFFSET - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式最小时区偏移量是 +14:00。
MIN_VALUE - 类 java.lang.Byte 中的静态变量
一个常量，保存 byte 类型可取的最小值，即 -27。
MIN_VALUE - 类 java.lang.Character 中的静态变量
此字段的常量值是 char 类型的最小值，即 '\u0000'。
MIN_VALUE - 类 java.lang.Double 中的静态变量
保存 double 类型的最小正非零值的常量，最小正非零值为 2-1074。
MIN_VALUE - 类 java.lang.Float 中的静态变量
保存 float 类型数据的最小正非零值的常量，即 2-149。
MIN_VALUE - 类 java.lang.Integer 中的静态变量
值为 －231 的常量，它表示 int 类型能够表示的最小值。
MIN_VALUE - 类 java.lang.Long 中的静态变量
保持 long 类型的最小值的常量，该值为 -263。
MIN_VALUE - 类 java.lang.Short 中的静态变量
保存 short 可取的最小值的常量，最小值为 -215。
MIN_VALUE_FIELD - 类 javax.management.JMX 中的静态变量
minValue 字段的名称。
minIcon - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
MinimalHTMLWriter - javax.swing.text.html 中的 类
MinimalHTMLWriter 是一个回退 writer，HTMLEditorKit 使用它为非 EditorKit 生成的文档写出 HTML。
MinimalHTMLWriter(Writer, StyledDocument) - 类 javax.swing.text.html.MinimalHTMLWriter 的构造方法
创建一个新的 MinimalHTMLWriter。
MinimalHTMLWriter(Writer, StyledDocument, int, int) - 类 javax.swing.text.html.MinimalHTMLWriter 的构造方法
创建一个新的 MinimalHTMLWriter。
minimizeFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
使窗体恢复回调用 maximizeFrame 之前的大小和位置。
minimizeFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
通常，这指示应该将窗体恢复到调用 maximizeFrame() 前的大小和位置。
minimizeFrame(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
当用户要最小化窗体时调用此方法。
minimizeKey - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
minimum - 类 javax.swing.SizeRequirements 中的变量
要求的最小大小。
MinimumHeight - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的静态变量
minimumLayoutSize(Container) - 类 java.awt.BorderLayout 中的方法
使用此布局管理器确定 target 容器的最小大小。
minimumLayoutSize(Container) - 类 java.awt.CardLayout 中的方法
计算指定面板大小的最小值。
minimumLayoutSize(Container) - 类 java.awt.FlowLayout 中的方法
返回需要布置 visible 组件的最小维数，该组件包含在指定的目标容器中。
minimumLayoutSize(Container) - 类 java.awt.GridBagLayout 中的方法
使用此网格包布局确定 parent 容器的最小大小。
minimumLayoutSize(Container) - 类 java.awt.GridLayout 中的方法
使用此网络布局确定最小大小的容器参数。
minimumLayoutSize(Container) - 接口 java.awt.LayoutManager 中的方法
给定指定容器所包含的组件，计算该容器的最小大小维数。
minimumLayoutSize(Container) - 类 javax.swing.BoxLayout 中的方法
返回布置包含在指定目标容器中的组件所需的最小尺寸。
minimumLayoutSize(Container) - 类 javax.swing.GroupLayout 中的方法
返回指定容器的最小大小。
minimumLayoutSize(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
返回布局需要的最小空间量。
minimumLayoutSize(Container) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回第一个（并且是唯一）的子级最小大小与其父 insets 的大小和。
minimumLayoutSize(Container) - 类 javax.swing.OverlayLayout 中的方法
返回需要布置组件的最小维数，该组件包含在指定的目标容器中。
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回包含子级所需的最小大小。
minimumLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.ScrollPaneLayout 中的方法
ScrollPane 的最小大小是 insets 加上视口最小大小，加上可见标题的最小大小，加上 displayPolicy 不为 NEVER 的滚动条的最小大小。
minimumLayoutSize(Container) - 类 javax.swing.SpringLayout 中的方法
minimumLayoutSize(Container) - 类 javax.swing.ViewportLayout 中的方法
返回需要布置指定目标容器中包含的组件的最小维数。
minimumSize() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
minimumSize() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 getMinimumSize() 取代。
minimumSize(int) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
minimumSize() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
minimumSize(int, int) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。
minimumSize() - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
minimumSize(int) - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
minimumSize() - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
minimumSize - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
minimumThumbSize - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
MinimumWidth - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的静态变量
minIndex - 类 javax.imageio.ImageReader 中的变量
用来读取的最小有效索引，最初为 0。
minor - 异常 org.omg.CORBA.SystemException 中的变量
CORBA Exception 次要代码。
minor_version - 类 org.omg.IOP.Encoding 中的变量
此 Encoding 格式的次要形式。
minorRequirementChange(AsyncBoxView.ChildState) - 类 javax.swing.text.AsyncBoxView 中的方法
沿辅轴上的要求更改。
minorTickSpacing - 类 javax.swing.JSlider 中的变量
次刻度标记（出现在主刻度标记之间的较小标记）之间的值的个数。
minProgressivePass - 类 javax.imageio.ImageReadParam 中的变量
从源中读取的逐步传递的最小索引。
MINSIZE - 类 java.awt.GridBagLayout 中的静态变量
网格包布局可以布置的最小网格。
minTabWidth - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的变量
MINUS - 类 javax.management.Query 中的静态变量
表示 Query.minus(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
minus(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个二进制表达式，表示两个数值的差。
minus(Spring) - 类 javax.swing.Spring 中的静态方法
返回 -s：一个以与 s 相反方向运行的 spring。
MINUTE - 类 java.text.DateFormat.Field 中的静态变量
标识 MINUTE 字段的常量。
MINUTE - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一小时中的分钟。
MINUTE_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 MINUTE 字段的有用常量。
MINUTES - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示分钟字段的常量。
minWidth - 类 javax.swing.table.TableColumn 中的变量
列的最小宽度。
minX - 类 java.awt.image.Raster 中的变量
此 Raster 左上角像素的 X 坐标。
minY - 类 java.awt.image.Raster 中的变量
此 Raster 左上角像素的 Y 坐标。
MirroredTypeException - javax.lang.model.type 中的 异常
当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
MirroredTypeException(TypeMirror) - 异常 javax.lang.model.type.MirroredTypeException 的构造方法
构造一个针对指定类型的新 MirroredTypeException。
MirroredTypesException - javax.lang.model.type 中的 异常
当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
MirroredTypesException(List<? extends TypeMirror>) - 异常 javax.lang.model.type.MirroredTypesException 的构造方法
构造一个针对指定类型的新 MirroredTypesException。
MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Mathematical Symbols-A”Unicode 字符块的常量。
MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Mathematical Symbols-B”Unicode 字符块的常量。
MISCELLANEOUS_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Symbols”Unicode 字符块的常量。
MISCELLANEOUS_SYMBOLS_AND_ARROWS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Symbols and Arrows”Unicode 字符块的常量。
MISCELLANEOUS_TECHNICAL - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Miscellaneous Technical”Unicode 字符块的常量。
missing_node - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
MissingFormatArgumentException - java.util 中的 异常
如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
MissingFormatArgumentException(String) - 异常 java.util.MissingFormatArgumentException 的构造方法
构造带有不匹配的格式说明符的此类的一个实例。
MissingFormatWidthException - java.util 中的 异常
请求格式宽度时抛出未经检查的异常。
MissingFormatWidthException(String) - 异常 java.util.MissingFormatWidthException 的构造方法
构造带有指定格式说明符的此类的一个实例。
MissingResourceException - java.util 中的 异常
缺少资源时抛出此异常。
MissingResourceException(String, String, String) - 异常 java.util.MissingResourceException 的构造方法
构造带有指定信息的 MissingResourceException。
Mixer - javax.sound.sampled 中的 接口
混频器是一个具有一行或多行的音频设备。
Mixer.Info - javax.sound.sampled 中的 类
Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。
Mixer.Info(String, String, String, String) - 类 javax.sound.sampled.Mixer.Info 的构造方法
构造混频器的 info 对象，并向它传递给定的文本信息。
MixerProvider - javax.sound.sampled.spi 中的 类
特定的混频器类型的提供者和工厂。
MixerProvider() - 类 javax.sound.sampled.spi.MixerProvider 的构造方法
mkdir() - 类 java.io.File 中的方法
创建此抽象路径名指定的目录。
mkdirs() - 类 java.io.File 中的方法
创建此抽象路径名指定的目录，包括所有必需但不存在的父目录。
MLet - javax.management.loading 中的 类
允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
MLet() - 类 javax.management.loading.MLet 的构造方法
使用默认的代理父类加载器构造新的 MLet。
MLet(URL[]) - 类 javax.management.loading.MLet 的构造方法
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[], ClassLoader) - 类 javax.management.loading.MLet 的构造方法
为给定的 URL 构造新的 MLet。
MLet(URL[], ClassLoader, URLStreamHandlerFactory) - 类 javax.management.loading.MLet 的构造方法
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[], boolean) - 类 javax.management.loading.MLet 的构造方法
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[], ClassLoader, boolean) - 类 javax.management.loading.MLet 的构造方法
为给定的 URL 构造新的 MLet。
MLet(URL[], ClassLoader, URLStreamHandlerFactory, boolean) - 类 javax.management.loading.MLet 的构造方法
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLetContent - javax.management.loading 中的 类
此类表示 MLET 标记的内容。
MLetContent(URL, Map<String, String>, List<String>, List<String>) - 类 javax.management.loading.MLetContent 的构造方法
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。
MLetMBean - javax.management.loading 中的 接口
公开 MLet MBean 的远程管理接口。
MM - 类 javax.print.attribute.Size2DSyntax 中的静态变量
指示单位为毫米 (mm) 的值。
MM - 类 javax.print.attribute.standard.MediaPrintableArea 中的静态变量
指示以 millimeters (mm) 为单位的值。
mnemonic - 类 javax.swing.DefaultButtonModel 中的变量
按钮的助记符。
MNEMONIC_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的助记符中的更改。
MNEMONIC_KEY - 接口 javax.swing.Action 中的静态变量
用来存储对应于一个 KeyEvent 键代码的 Integer 值的键。
mod(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this mod m) 的 BigInteger。
MODAL - 类 javax.accessibility.AccessibleState 中的静态变量
指示在用户可以与不同窗口中的某个对象交互之前，必须对此对象采取某些操作。
MODAL_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Modal 层的便捷对象。
modCount - 类 java.util.AbstractList 中的变量
已从结构上修改 此列表的次数。
mode - 类 org.omg.Dynamic.Parameter 中的变量
MODE_ASYNCHRONOUS - 接口 org.w3c.dom.ls.DOMImplementationLS 中的静态变量
创建一个异步 LSParser。
MODE_COPY_FROM_METADATA - 类 javax.imageio.ImageWriteParam 中的静态变量
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 或 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
MODE_DEFAULT - 类 javax.imageio.ImageWriteParam 中的静态变量
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 和 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
MODE_DISABLED - 类 javax.imageio.ImageWriteParam 中的静态变量
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 和 setCompressionMode 之类的方法中，以禁用用于以后的写入操作的某个特征。
MODE_EXPLICIT - 类 javax.imageio.ImageWriteParam 中的静态变量
一个常量值，可以传入诸如 setTilingMode 或 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
MODE_SYNCHRONOUS - 接口 org.w3c.dom.ls.DOMImplementationLS 中的静态变量
创建一个同步 LSParser。
model - 类 javax.swing.AbstractButton 中的变量
确定按钮状态的数据模型。
model - 类 javax.swing.JProgressBar 中的变量
保存进度条数据的对象。
model - 类 javax.swing.JScrollBar 中的变量
表示滚动条的最小、最大、跨度（也叫 "visibleAmount"）和当前值的模型。
model - 类 javax.swing.JTabbedPane 中的变量
默认的选择模型。
MODEL - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
MODEL_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮模型中的更改。
ModelAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
用来标识嵌入了对象的模型的属性，这些嵌入的对象具有分开的模型视图。
modelChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
modelChanged() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
标志模型更改。
modelIndex - 类 javax.swing.table.TableColumn 中的变量
模型中的列索引，通过此 TableColumn 显示该模型。
modelListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
ModelMBean - javax.management.modelmbean 中的 接口
ModelMBean 必须实现此接口。
ModelMBeanAttributeInfo - javax.management.modelmbean 中的 类
ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
ModelMBeanAttributeInfo(String, String, Method, Method) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String, String, Method, Method, Descriptor) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
构造 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String, String, String, boolean, boolean, boolean) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String, String, String, boolean, boolean, boolean, Descriptor) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(ModelMBeanAttributeInfo) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 的构造方法
根据此 ModelMBeanAttributeInfo Object 构造新的 ModelMBeanAttributeInfo 对象。
ModelMBeanConstructorInfo - javax.management.modelmbean 中的 类
ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
ModelMBeanConstructorInfo(String, Constructor) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 的构造方法
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String, Constructor, Descriptor) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 的构造方法
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String, String, MBeanParameterInfo[]) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 的构造方法
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String, String, MBeanParameterInfo[], Descriptor) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 的构造方法
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanInfo - javax.management.modelmbean 中的 接口
此接口由每个 ModelMBean 的 ModelMBeanInfo 实现。
ModelMBeanInfoSupport - javax.management.modelmbean 中的 类
此类表示 ModelMBean 的元数据。
ModelMBeanInfoSupport(ModelMBeanInfo) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 的构造方法
构造作为给定 ModelMBeanInfoSupport 副本的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String, String, ModelMBeanAttributeInfo[], ModelMBeanConstructorInfo[], ModelMBeanOperationInfo[], ModelMBeanNotificationInfo[]) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 的构造方法
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String, String, ModelMBeanAttributeInfo[], ModelMBeanConstructorInfo[], ModelMBeanOperationInfo[], ModelMBeanNotificationInfo[], Descriptor) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 的构造方法
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
ModelMBeanNotificationBroadcaster - javax.management.modelmbean 中的 接口
ModelMBean 必须实现此接口。
ModelMBeanNotificationInfo - javax.management.modelmbean 中的 类
ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
ModelMBeanNotificationInfo(String[], String, String) - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 的构造方法
构造带有默认描述符的 ModelMBeanNotificationInfo 对象。
ModelMBeanNotificationInfo(String[], String, String, Descriptor) - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 的构造方法
构造 ModelMBeanNotificationInfo 对象。
ModelMBeanNotificationInfo(ModelMBeanNotificationInfo) - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 的构造方法
从此 ModelMBeanNotfication Object 构造新 ModelMBeanNotificationInfo 对象。
ModelMBeanOperationInfo - javax.management.modelmbean 中的 类
ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。
ModelMBeanOperationInfo(String, Method) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String, Method, Descriptor) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
构造 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String, String, MBeanParameterInfo[], String, int) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String, String, MBeanParameterInfo[], String, int, Descriptor) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
构造 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(ModelMBeanOperationInfo) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 的构造方法
根据此 ModelMBeanOperation Object 构造新的 ModelMBeanOperationInfo 对象。
modelStructureChanged() - 类 javax.swing.DefaultRowSorter 中的方法
当底层模型结构完全更改时，调用此方法。
modelStructureChanged() - 类 javax.swing.RowSorter 中的方法
当底层模型结构完全更改时，调用此方法。
modelToView(JTextComponent, int) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将模型中的给定位置转换成视图坐标系统中的某一个位置。
modelToView(JTextComponent, int, Position.Bias) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将模型中的给定位置转换成视图坐标系统中的某一个位置。
modelToView(JTextComponent, int) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 modelToView 方法。
modelToView(JTextComponent, int, Position.Bias) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 modelToView 方法。
modelToView(JTextComponent, int) - 类 javax.swing.plaf.TextUI 中的方法
将模型中的给定位置转换成视图坐标系统中的某一个位置。
modelToView(JTextComponent, int, Position.Bias) - 类 javax.swing.plaf.TextUI 中的方法
将模型中的给定位置转换成视图坐标系统中的某一个位置。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.AsyncBoxView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.BoxView 中的方法
提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.ComponentView 中的方法
提供模型坐标空间到视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.CompositeView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Position.Bias, int, Position.Bias, Shape) - 类 javax.swing.text.CompositeView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.FieldView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(GlyphView, int, Position.Bias, Shape) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.GlyphView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.html.ImageView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.IconView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int) - 类 javax.swing.text.JTextComponent 中的方法
将模型中给定位置转换为视图坐标系统中的位置。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.PasswordView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.PlainView 中的方法
提供从文档模型坐标空间到所映射的视图坐标空间的映射。
modelToView(int, Shape, Position.Bias) - 类 javax.swing.text.View 中的方法
为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
modelToView(int, Position.Bias, int, Position.Bias, Shape) - 类 javax.swing.text.View 中的方法
为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
modelToView(int, Shape) - 类 javax.swing.text.View 中的方法
已过时。
MODIFICATION - 接口 org.w3c.dom.events.MutationEvent 中的静态变量
适当修改 Attr。
MODIFICATION_TIME - 接口 java.util.jar.Pack200.Packer 中的静态变量
如果将此属性设置为特殊的字符串 Pack200.Packer.LATEST，则打包器将尝试在原始存档中的所有可用条目中确定最后修改时间，或者确定每个段中所有可用条目的最后修改时间。
ModificationItem - javax.naming.directory 中的 类
此类表示修改项。
ModificationItem(int, Attribute) - 类 javax.naming.directory.ModificationItem 的构造方法
创建一个新的 ModificationItem 实例。
Modifier - java.lang.reflect 中的 类
Modifier 类提供了 static 方法和常量，对类和成员访问修饰符进行解码。
Modifier() - 类 java.lang.reflect.Modifier 的构造方法
Modifier - javax.lang.model.element 中的 枚举
表示程序元素（如类、方法或字段）上的修饰符。
modifier - 类 javax.swing.text.html.parser.AttributeList 中的变量
MODIFIER_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Lm”。
MODIFIER_SYMBOL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Sk”。
modifiers - 类 java.awt.Event 中的变量
修饰符键的状态。
modifyAttributes(Name, int, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
修改与命名对象关联的属性。
modifyAttributes(String, int, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
修改与命名对象关联的属性。
modifyAttributes(Name, ModificationItem[]) - 接口 javax.naming.directory.DirContext 中的方法
使用有序的修改列表修改与命名对象关联的属性。
modifyAttributes(String, ModificationItem[]) - 接口 javax.naming.directory.DirContext 中的方法
使用有序的修改列表修改与命名对象关联的属性。
modifyAttributes(String, int, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
modifyAttributes(Name, int, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
modifyAttributes(String, ModificationItem[]) - 类 javax.naming.directory.InitialDirContext 中的方法
modifyAttributes(Name, ModificationItem[]) - 类 javax.naming.directory.InitialDirContext 中的方法
modInverse(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this-1 mod m) 的 BigInteger。
modPow(BigInteger, BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (thisexponent mod m) 的 BigInteger。
MONARCH - 类 java.awt.PageAttributes.MediaType 中的静态变量
MONARCH_ENVELOPE 的别名。
MONARCH_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
Monarch Envelope (3 7/8 x 7 1/2 in) 的 MediaType 实例。
MONARCH_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Monarch 信封尺寸，3.87 inch × 7.5 inch。
MONARCH_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
monarch 信封尺寸。
MONDAY - 类 java.util.Calendar 中的静态变量
指示 Monday 的 Calendar.DAY_OF_WEEK 字段值。
MONGOLIAN - 类 java.awt.font.NumericShaper 中的静态变量
标识 MONGOLIAN 范围和十进制基数。
MONGOLIAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Mongolian”Unicode 字符块的常量。
Monitor - javax.management.monitor 中的 类
定义所有监视器 MBean 的公共部分。
Monitor() - 类 javax.management.monitor.Monitor 的构造方法
MonitorInfo - java.lang.management 中的 类
关于对象监视器锁的信息。
MonitorInfo(String, int, int, StackTraceElement) - 类 java.lang.management.MonitorInfo 的构造方法
构造一个 MonitorInfo 对象。
MonitorMBean - javax.management.monitor 中的 接口
公开监视器 MBean 的远程管理接口。
MonitorNotification - javax.management.monitor 中的 类
提供对监视器 MBean 发送的通知的定义。
MonitorSettingException - javax.management.monitor 中的 异常
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。
MonitorSettingException() - 异常 javax.management.monitor.MonitorSettingException 的构造方法
默认的构造方法。
MonitorSettingException(String) - 异常 javax.management.monitor.MonitorSettingException 的构造方法
允许指定错误消息的构造方法。
MONOCHROME - 类 java.awt.PageAttributes.ColorType 中的静态变量
用来指定单色打印的 ColorType 实例。
MONOCHROME - 类 javax.print.attribute.standard.Chromaticity 中的静态变量
单色打印。
MONOSPACED - 类 java.awt.Font 中的静态变量
逻辑字体 "Monospaced" 的规范系列名称的 String 常量。
MONTH - 类 java.text.DateFormat.Field 中的静态变量
标识 MONTH 字段的常量。
MONTH - 类 java.util.Calendar 中的静态变量
指示月份的 get 和 set 的字段数字。
MONTH_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 MONTH 字段的有用常量。
MONTHS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示月字段的常量。
MORE_THAN_MAX_ROLE_DEGREE - 类 javax.management.relation.RoleStatus 中的静态变量
试图用比最大期望容量更多的 ObjectName 设置角色值时的问题类型。
MOUSE_CLICKED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标单击”事件。
MOUSE_DOWN - 类 java.awt.Event 中的静态变量
用户已经按下鼠标按钮。
MOUSE_DRAG - 类 java.awt.Event 中的静态变量
鼠标已经移动，同时按钮被按下。
MOUSE_DRAGGED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标拖动”事件。
MOUSE_ENTER - 类 java.awt.Event 中的静态变量
鼠标已经进入了一个组件。
MOUSE_ENTERED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标进入”事件。
MOUSE_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择鼠标事件的事件掩码。
MOUSE_EXIT - 类 java.awt.Event 中的静态变量
鼠标已经退出了一个组件。
MOUSE_EXITED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标离开”事件。
MOUSE_FIRST - 类 java.awt.event.MouseEvent 中的静态变量
用于鼠标事件的 id 范围的起始编号。
MOUSE_LAST - 类 java.awt.event.MouseEvent 中的静态变量
用于鼠标事件的 id 范围的结束编号。
MOUSE_MOTION_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择鼠标动作事件的事件掩码。
MOUSE_MOVE - 类 java.awt.Event 中的静态变量
鼠标已经移动，没有按钮被按下。
MOUSE_MOVED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标移动”事件。
MOUSE_OVER - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示鼠标位于 region 之上的基本状态。
MOUSE_PRESSED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标按下”事件。
MOUSE_RELEASED - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标释放”事件。
MOUSE_UP - 类 java.awt.Event 中的静态变量
用户已经释放鼠标按钮。
MOUSE_WHEEL - 类 java.awt.event.MouseEvent 中的静态变量
“鼠标滚轮”事件。
MOUSE_WHEEL_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择鼠标滚轮事件的事件掩码。
MouseAdapter - java.awt.event 中的 类
接收鼠标事件的抽象适配器类。
MouseAdapter() - 类 java.awt.event.MouseAdapter 的构造方法
mouseClicked(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseClicked 方法处理 mouseClicked 事件。
mouseClicked(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标在组件上单击时调用。
mouseClicked(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标按键在组件上单击（按下并释放）时调用。
mouseClicked(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标按键在组件上单击（按下并释放）时调用。
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseClicked(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
单击鼠标时调用。
mouseClicked(MouseEvent) - 类 javax.swing.text.html.HTMLEditorKit.LinkController 中的方法
鼠标单击事件时调用。
mouseDown(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
mouseDrag(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
mouseDragged(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseDragged 方法处理 mouseDragged 事件。
mouseDragged(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标按钮在组件上按下时调用。
mouseDragged(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标按键在组件上按下并拖动时调用。
mouseDragged(MouseEvent) - 类 java.awt.event.MouseMotionAdapter 中的方法
鼠标按键在组件上按下并拖动时调用。
mouseDragged(MouseEvent) - 接口 java.awt.event.MouseMotionListener 中的方法
鼠标按键在组件上按下并拖动时调用。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
在菜单上按下鼠标按键并随后拖动鼠标时调用。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
将模型值设置为 thumb 的 Vertical 滚动条顶部的位置，或者相对于滑道原点的从左到右/从右到左滚动条中 Horizontal 滚动条的左部/右部位置。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
将模型值设置为相对于滑道原点的 thumb 顶部/左部位置。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
如果拖动器不为 null，则此方法利用 continueDrag 传递消息。
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
根据鼠标指针当前位置移动插入符位置。
mouseDragged(MouseEvent) - 类 javax.swing.text.html.HTMLEditorKit.LinkController 中的方法
mouseDragged(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
按下和拖动鼠标时调用。
MouseDragGestureRecognizer - java.awt.dnd 中的 类
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。
MouseDragGestureRecognizer(DragSource, Component, int, DragGestureListener) - 类 java.awt.dnd.MouseDragGestureRecognizer 的构造方法
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource, Component, int) - 类 java.awt.dnd.MouseDragGestureRecognizer 的构造方法
给出 Component c 的 DragSource、要观察的 Component，以及此拖动操作允许的操作，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource, Component) - 类 java.awt.dnd.MouseDragGestureRecognizer 的构造方法
给出 Component c 的 DragSource、要观察的 Component，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource) - 类 java.awt.dnd.MouseDragGestureRecognizer 的构造方法
给出 Component 的 DragSource，构造一个新的 MouseDragGestureRecognizer。
mouseEnter(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
mouseEntered(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseEntered 方法处理 mouseEntered 事件。
mouseEntered(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标移动到组件上时调用。
mouseEntered(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标进入到组件上时调用。
mouseEntered(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标进入到组件上时调用。
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener 中的方法
用于表示文件的 JList 由子类创建，但是在此类中监视选择。
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
在指针进入菜单时调用。
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
鼠标进入组件时调用。
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseEntered(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
鼠标进入某个区域时调用。
mouseEntered(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
鼠标进入组件区域时调用。
MouseEvent - java.awt.event 中的 类
指示组件中发生鼠标动作的事件。
MouseEvent(Component, int, long, int, int, int, int, boolean, int) - 类 java.awt.event.MouseEvent 的构造方法
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component, int, long, int, int, int, int, boolean) - 类 java.awt.event.MouseEvent 的构造方法
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component, int, long, int, int, int, int, int, int, boolean, int) - 类 java.awt.event.MouseEvent 的构造方法
构造一个具有指定源组件、类型、修饰符、相对坐标、绝对坐标和单击计数的 MouseEvent 对象。
MouseEvent - org.w3c.dom.events 中的 接口
MouseEvent 接口提供与鼠标事件相关联的特定上下文信息。
mouseExit(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
mouseExited(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseExited 方法处理 mouseExited 事件。
mouseExited(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标离开组件时调用。
mouseExited(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标离开组件时调用。
mouseExited(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标离开组件时调用。
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
当鼠标退出滚动条时调用。
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
鼠标退出组件时调用。
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseExited(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseExited(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
鼠标退出某个区域时调用。
mouseExited(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
鼠标退出组件区域时调用。
mouseHandler - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
处理发自此类和拆分窗格的鼠标事件。
MouseInfo - java.awt 中的 类
MouseInfo 提供获取有关鼠标信息的方法，如鼠标指针位置和鼠标按钮数。
MouseInputAdapter - javax.swing.event 中的 类
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。
MouseInputAdapter() - 类 javax.swing.event.MouseInputAdapter 的构造方法
MouseInputListener - javax.swing.event 中的 接口
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。
mouseInputListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
mouseInputListener - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
mouseInputListener - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的变量
mouseInputListener - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
MouseListener - java.awt.event 中的 接口
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
mouseListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
mouseListener - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
MouseMotionAdapter - java.awt.event 中的 类
接收鼠标移动事件的抽象适配器类。
MouseMotionAdapter() - 类 java.awt.event.MouseMotionAdapter 的构造方法
MouseMotionListener - java.awt.event 中的 接口
用于接收组件上的鼠标移动事件的侦听器接口。
mouseMotionListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
mouseMove(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
mouseMove(int, int) - 类 java.awt.Robot 中的方法
将鼠标指针移动到给定屏幕坐标。
mouseMoved(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseMoved 方法处理 mouseMoved 事件。
mouseMoved(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标按钮在组件上移动（无按钮按下）时调用。
mouseMoved(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标光标移动到组件上但无按键按下时调用。
mouseMoved(MouseEvent) - 类 java.awt.event.MouseMotionAdapter 中的方法
鼠标按键在组件上移动（无按键按下）时调用。
mouseMoved(MouseEvent) - 接口 java.awt.event.MouseMotionListener 中的方法
鼠标光标移动到组件上但无按键按下时调用。
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
基于方向重置光标。
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 中的方法
已将鼠标按键移动到组件上（但没有按下任何一个按键）时调用。
mouseMoved(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
移动鼠标时调用。
mouseMoved(MouseEvent) - 类 javax.swing.text.html.HTMLEditorKit.LinkController 中的方法
mouseMoved(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
移动鼠标时调用。
mousePress(int) - 类 java.awt.Robot 中的方法
按下一个或多个鼠标按钮。
mousePressed(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mousePressed 方法处理 mousePressed 事件。
mousePressed(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标按钮在 Component 上按下时调用。
mousePressed(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标按键在组件上按下时调用。
mousePressed(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标按键在组件上按下时调用。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 中的方法
响应组合框上的鼠标按下事件。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
在菜单上单击鼠标时调用。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按下鼠标则将滚动条值增加一页。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按鼠标则将滚动条值增加一页。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
通过创建 DragController 的适当实例启动拖动会话。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 中的方法
在组件上按下鼠标按键时调用。
mousePressed(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mousePressed(MouseEvent) - 类 javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener 中的方法
mousePressed(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
如果按下 button 1，实现它可请求将焦点置于关联的文本组件上，并设置插入符位置。
mousePressed(MouseEvent) - 类 javax.swing.ToolTipManager 中的方法
当按下鼠标时调用。
mouseRelease(int) - 类 java.awt.Robot 中的方法
释放一个或多个鼠标按钮。
mouseReleased(MouseEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseReleased 方法处理 mouseReleased 事件。
mouseReleased(MouseEvent) - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
鼠标按钮在组件上释放时调用。
mouseReleased(MouseEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标按钮在组件上释放时调用。
mouseReleased(MouseEvent) - 接口 java.awt.event.MouseListener 中的方法
鼠标按钮在组件上释放时调用。
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler 中的方法
响应用户终止从组合框开始的单击或拖动操作。
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicListUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler 中的方法
在菜单上释放鼠标时调用。
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler 中的方法
如果拖动器不为 null，则此方法利用 completeDrag 传递消息。
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicTableUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
mouseReleased(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
释放鼠标时调用。
mouseReleased(MouseEvent) - 类 javax.swing.text.html.FormView.MouseEventListener 中的方法
mouseUp(Event, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
mouseWheel(int) - 类 java.awt.Robot 中的方法
在配有滚轮的鼠标上旋转滚轮。
MouseWheelEvent - java.awt.event 中的 类
表示鼠标滚轮在组件中滚动的事件。
MouseWheelEvent(Component, int, long, int, int, int, int, boolean, int, int, int) - 类 java.awt.event.MouseWheelEvent 的构造方法
构造一个具有指定源组件、类型、修改键、坐标、滚动类型、滚动量和滚轮旋转的 MouseWheelEvent。
MouseWheelEvent(Component, int, long, int, int, int, int, int, int, boolean, int, int, int) - 类 java.awt.event.MouseWheelEvent 的构造方法
构造一个具有指定源组件、类型、修改键、坐标、绝对坐标、滚动类型、滚动量和滚轮滚动的 MouseWheelEvent 对象。
MouseWheelListener - java.awt.event 中的 接口
用于接收组件上的鼠标滚轮事件的侦听器接口。
mouseWheelMoved(MouseWheelEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 mouseWheelMoved 方法处理 mouseWheelMoved 事件。
mouseWheelMoved(MouseWheelEvent) - 类 java.awt.event.MouseAdapter 中的方法
鼠标滚轮旋转时调用。
mouseWheelMoved(MouseWheelEvent) - 接口 java.awt.event.MouseWheelListener 中的方法
鼠标滚轮旋转时调用。
mouseWheelMoved(MouseWheelEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler 中的方法
当鼠标滚轮在 JScrollPane 上转动时调用。
move(int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
move(int, int) - 类 java.awt.Point 中的方法
将此点移动到 (x,y) 坐标平面中的指定位置。
move(int, int) - 类 java.awt.Rectangle 中的方法
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
MOVE - 类 javax.swing.TransferHandler 中的静态变量
表示“移动”传输动作的 int 值。
MOVE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
MOVE_CURSOR - 类 java.awt.Cursor 中的静态变量
移动光标类型。
MOVE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.MOVE_CURSOR 取代。
moveAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
moveAndRepaint(JComponent, int, int, int, int) - 类 javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler 中的方法
moveCaret(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
试图使用 viewToModel() 从鼠标事件的坐标移动插入符的位置。
moveCaretPosition(int) - 类 javax.swing.text.JTextComponent 中的方法
将插入符移动到新的位置，同时保留最后一次调用 setCaretPosition 之前定义的标记。
moveColumn(int, int) - 类 javax.swing.JTable 中的方法
将视图中的 column 列移动到当前被 targetColumn 列所占用的位置。
moveColumn(int, int) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
将 columnIndex 位置的列和标题移到 newIndex。
moveColumn(int, int) - 接口 javax.swing.table.TableColumnModel 中的方法
将 columnIndex 位置的列及其头移至 newIndex。
moveDot(int) - 接口 javax.swing.text.Caret 中的方法
将插入符位置（点）移动到其他某个位置，放在标记后面。
moveDot(int) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符位置移动到指定位置，存在向前偏差。
moveDot(int, Position.Bias) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符位置移动到指定位置，存在指定偏差。
moveDot(int, Position.Bias) - 类 javax.swing.text.NavigationFilter.FilterBypass 中的方法
移动插入符的位置，并跳过 NavigationFilter。
moveDot(NavigationFilter.FilterBypass, int, Position.Bias) - 类 javax.swing.text.NavigationFilter 中的方法
在 Caret 移动点之前调用。
moveLeadSelectionIndex(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 lead 选择索引，并不作更改地保留所有选择值。
movePointLeft(int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，它等效于将该值的小数点向左移动 n 位。
movePointRight(int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，它等效于将该值的小数点向右移动 n 位。
moveRow(int, int, int) - 类 javax.swing.table.DefaultTableModel 中的方法
将 start（包含）到 end（包含）范围中的一行或多行移到模型中的 to 位置。
moveTo(double, double) - 类 java.awt.geom.Path2D.Double 中的方法
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
moveTo(double, double) - 类 java.awt.geom.Path2D.Float 中的方法
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
moveTo(float, float) - 类 java.awt.geom.Path2D.Float 中的方法
通过移动到指定的坐标（以 float 精度指定），将一个点添加到路径中。
moveTo(double, double) - 类 java.awt.geom.Path2D 中的方法
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
moveToBack() - 类 javax.swing.JInternalFrame 中的方法
如果此组件的父组件是 JLayeredPane，则将此组件移至位置 -1 的便捷方法。
moveToBack(Component) - 类 javax.swing.JLayeredPane 中的方法
将该组件移到当前层中所有组件的底层（位置 -1）。
moveToCurrentRow() - 接口 java.sql.ResultSet 中的方法
将光标移动到记住的光标位置，通常为当前行。
moveToFront() - 类 javax.swing.JInternalFrame 中的方法
如果此组件的父组件是 JLayeredPane，则将此组件移至位置 0 的便捷方法。
moveToFront(Component) - 类 javax.swing.JLayeredPane 中的方法
将该组件移到当前层中所有组件的顶层（位置 0）。
moveToInsertRow() - 接口 java.sql.ResultSet 中的方法
将光标移动到插入行。
MOVING_TO_PAUSED - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
已经暂停了打印机，但设备要停下来还需要一些时间。
MS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
MULTI_LINE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此（文本）对象可以包含多行文本
MULTI_SELECTION_ENABLED_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
允许选择多个文件。
MultiButtonUI - javax.swing.plaf.multi 中的 类
用于组合 ButtonUI 的多路 UI。
MultiButtonUI() - 类 javax.swing.plaf.multi.MultiButtonUI 的构造方法
MulticastSocket - java.net 中的 类
多播数据报套接字类用于发送和接收 IP 多播包。
MulticastSocket() - 类 java.net.MulticastSocket 的构造方法
创建多播套接字。
MulticastSocket(int) - 类 java.net.MulticastSocket 的构造方法
创建多播套接字并将其绑定到特定端口。
MulticastSocket(SocketAddress) - 类 java.net.MulticastSocket 的构造方法
创建绑定到指定套接字地址的 MulticastSocket。
MultiColorChooserUI - javax.swing.plaf.multi 中的 类
用于组合 ColorChooserUI 的多路 UI。
MultiColorChooserUI() - 类 javax.swing.plaf.multi.MultiColorChooserUI 的构造方法
MultiComboBoxUI - javax.swing.plaf.multi 中的 类
用于组合 ComboBoxUI 的多路 UI。
MultiComboBoxUI() - 类 javax.swing.plaf.multi.MultiComboBoxUI 的构造方法
MultiDesktopIconUI - javax.swing.plaf.multi 中的 类
用于组合 DesktopIconUI 的多路 UI。
MultiDesktopIconUI() - 类 javax.swing.plaf.multi.MultiDesktopIconUI 的构造方法
MultiDesktopPaneUI - javax.swing.plaf.multi 中的 类
用于组合 DesktopPaneUI 的多路 UI。
MultiDesktopPaneUI() - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 的构造方法
MultiDoc - javax.print 中的 接口
接口 MultiDoc 指定某个对象的接口，该对象为 PrintJob 提供多部分打印数据。
MultiDocPrintJob - javax.print 中的 接口
从 MultiDocPrintService 中获得，MultiDocPrintJob 可使用作业属性集以单个 PrintJob 的形式打印指定的文档集合。
MultiDocPrintService - javax.print 中的 接口
接口 MultiPrintService 是 MultiDocPrintJob 的工厂。
MultiFileChooserUI - javax.swing.plaf.multi 中的 类
用于组合 FileChooserUI 的多路 UI。
MultiFileChooserUI() - 类 javax.swing.plaf.multi.MultiFileChooserUI 的构造方法
MultiInternalFrameUI - javax.swing.plaf.multi 中的 类
用于组合 InternalFrameUI 的多路 UI。
MultiInternalFrameUI() - 类 javax.swing.plaf.multi.MultiInternalFrameUI 的构造方法
MultiLabelUI - javax.swing.plaf.multi 中的 类
用于组合 LabelUI 的多路 UI。
MultiLabelUI() - 类 javax.swing.plaf.multi.MultiLabelUI 的构造方法
MULTILINE - 类 java.util.regex.Pattern 中的静态变量
启用多行模式。
MultiListUI - javax.swing.plaf.multi 中的 类
用于组合 ListUI 的多路 UI。
MultiListUI() - 类 javax.swing.plaf.multi.MultiListUI 的构造方法
MultiLookAndFeel - javax.swing.plaf.multi 中的 类
多路外观允许同时将多个 UI 与一个组件相关联。
MultiLookAndFeel() - 类 javax.swing.plaf.multi.MultiLookAndFeel 的构造方法
MultiMenuBarUI - javax.swing.plaf.multi 中的 类
用于组合 MenuBarUI 的多路 UI。
MultiMenuBarUI() - 类 javax.swing.plaf.multi.MultiMenuBarUI 的构造方法
MultiMenuItemUI - javax.swing.plaf.multi 中的 类
用于组合 MenuItemUI 的多路 UI。
MultiMenuItemUI() - 类 javax.swing.plaf.multi.MultiMenuItemUI 的构造方法
MultiOptionPaneUI - javax.swing.plaf.multi 中的 类
用于组合 OptionPaneUI 的多路 UI。
MultiOptionPaneUI() - 类 javax.swing.plaf.multi.MultiOptionPaneUI 的构造方法
MultiPanelUI - javax.swing.plaf.multi 中的 类
用于组合 PanelUI 的多路 UI。
MultiPanelUI() - 类 javax.swing.plaf.multi.MultiPanelUI 的构造方法
MultiPixelPackedSampleModel - java.awt.image 中的 类
MultiPixelPackedSampleModel 类表示单 band 图像，能够将多个单样本像素打包到一个数据元素中。
MultiPixelPackedSampleModel(int, int, int, int) - 类 java.awt.image.MultiPixelPackedSampleModel 的构造方法
构造一个具有指定数据类型、宽度、高度和每像素位数的 MultiPixelPackedSampleModel。
MultiPixelPackedSampleModel(int, int, int, int, int, int) - 类 java.awt.image.MultiPixelPackedSampleModel 的构造方法
构造一个具有指定数据类型、宽度、高度、每像素位数、扫描行间距和数据位偏移量的 MultiPixelPackedSampleModel。
MULTIPLE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
MULTIPLE_ID - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态变量
MULTIPLE_INTERVAL_SELECTION - 接口 javax.swing.ListSelectionModel 中的静态变量
selectionMode 属性的值：一次选择一个或多个连续的索引范围。
MultipleComponentProfileHelper - org.omg.IOP 中的 类
形成多组件配置文件的一组加标记的组件。
MultipleComponentProfileHelper() - 类 org.omg.IOP.MultipleComponentProfileHelper 的构造方法
MultipleComponentProfileHolder - org.omg.IOP 中的 类
形成多组件配置文件的一组加标记的组件。
MultipleComponentProfileHolder() - 类 org.omg.IOP.MultipleComponentProfileHolder 的构造方法
MultipleComponentProfileHolder(TaggedComponent[]) - 类 org.omg.IOP.MultipleComponentProfileHolder 的构造方法
MultipleDocumentHandling - javax.print.attribute.standard 中的 类
MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
MultipleDocumentHandling(int) - 类 javax.print.attribute.standard.MultipleDocumentHandling 的构造方法
构造具有给定整数值的新 MultipleDocumentHandling 枚举值。
MultipleGradientPaint - java.awt 中的 类
这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。
MultipleGradientPaint.ColorSpaceType - java.awt 中的 枚举
在其中执行渐变插值操作的颜色空间。
MultipleGradientPaint.CycleMethod - java.awt 中的 枚举
在渐变边界以外进行绘制时使用的方法。
MultipleMaster - java.awt.font 中的 接口
MultipleMaster 接口表示 Type 1 Multiple Master 字体。
multiply(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this × multiplicand)，其标度为 (this.scale() + multiplicand.scale())。
multiply(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
multiply(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this * val) 的 BigInteger。
multiply(int) - 类 javax.xml.datatype.Duration 中的方法
计算新的持续时间，值为此持续时间值的 factor 倍。
multiply(BigDecimal) - 类 javax.xml.datatype.Duration 中的方法
计算新的持续时间，其值是此持续时间值的 factor 倍。
MultiPopupMenuUI - javax.swing.plaf.multi 中的 类
用于组合 PopupMenuUI 的多路 UI。
MultiPopupMenuUI() - 类 javax.swing.plaf.multi.MultiPopupMenuUI 的构造方法
MultiProgressBarUI - javax.swing.plaf.multi 中的 类
用于组合 ProgressBarUI 的多路 UI。
MultiProgressBarUI() - 类 javax.swing.plaf.multi.MultiProgressBarUI 的构造方法
MultiRootPaneUI - javax.swing.plaf.multi 中的 类
用于组合 RootPaneUI 的多路 UI。
MultiRootPaneUI() - 类 javax.swing.plaf.multi.MultiRootPaneUI 的构造方法
MultiScrollBarUI - javax.swing.plaf.multi 中的 类
用于组合 ScrollBarUI 的多路 UI。
MultiScrollBarUI() - 类 javax.swing.plaf.multi.MultiScrollBarUI 的构造方法
MultiScrollPaneUI - javax.swing.plaf.multi 中的 类
用于组合 ScrollPaneUI 的多路 UI。
MultiScrollPaneUI() - 类 javax.swing.plaf.multi.MultiScrollPaneUI 的构造方法
MULTISELECTABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象允许同时选定多个子级。
MultiSeparatorUI - javax.swing.plaf.multi 中的 类
用于组合 SeparatorUI 的多路 UI。
MultiSeparatorUI() - 类 javax.swing.plaf.multi.MultiSeparatorUI 的构造方法
MultiSliderUI - javax.swing.plaf.multi 中的 类
用于组合 SliderUI 的多路 UI。
MultiSliderUI() - 类 javax.swing.plaf.multi.MultiSliderUI 的构造方法
MultiSpinnerUI - javax.swing.plaf.multi 中的 类
用于组合 SpinnerUI 的多路 UI。
MultiSpinnerUI() - 类 javax.swing.plaf.multi.MultiSpinnerUI 的构造方法
MultiSplitPaneUI - javax.swing.plaf.multi 中的 类
用于组合 SplitPaneUI 的多路 UI。
MultiSplitPaneUI() - 类 javax.swing.plaf.multi.MultiSplitPaneUI 的构造方法
MultiTabbedPaneUI - javax.swing.plaf.multi 中的 类
用于组合 TabbedPaneUI 的多路 UI。
MultiTabbedPaneUI() - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 的构造方法
MultiTableHeaderUI - javax.swing.plaf.multi 中的 类
用于组合 TableHeaderUI 的多路 UI。
MultiTableHeaderUI() - 类 javax.swing.plaf.multi.MultiTableHeaderUI 的构造方法
MultiTableUI - javax.swing.plaf.multi 中的 类
用于组合 TableUI 的多路 UI。
MultiTableUI() - 类 javax.swing.plaf.multi.MultiTableUI 的构造方法
MultiTextUI - javax.swing.plaf.multi 中的 类
用于组合 TextUI 的多路 UI。
MultiTextUI() - 类 javax.swing.plaf.multi.MultiTextUI 的构造方法
MultiToolBarUI - javax.swing.plaf.multi 中的 类
用于组合 ToolBarUI 的多路 UI。
MultiToolBarUI() - 类 javax.swing.plaf.multi.MultiToolBarUI 的构造方法
MultiToolTipUI - javax.swing.plaf.multi 中的 类
用于组合 ToolTipUI 的多路 UI。
MultiToolTipUI() - 类 javax.swing.plaf.multi.MultiToolTipUI 的构造方法
MultiTreeUI - javax.swing.plaf.multi 中的 类
用于组合 TreeUI 的多路 UI。
MultiTreeUI() - 类 javax.swing.plaf.multi.MultiTreeUI 的构造方法
MultiViewportUI - javax.swing.plaf.multi 中的 类
用于组合 ViewportUI 的多路 UI。
MultiViewportUI() - 类 javax.swing.plaf.multi.MultiViewportUI 的构造方法
MUSICAL_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Musical Symbols”Unicode 字符块的常量。
MutableAttributeSet - javax.swing.text 中的 接口
独特属性的可变集合的通用接口。
MutableComboBoxModel - javax.swing 中的 接口
ComboBoxModel 的可变版本。
MutableTreeNode - javax.swing.tree 中的 接口
定义针对树节点对象的要求，这些树节点可以通过以下操作更改：添加或移除子节点，或更改该节点中存储的用户对象的内容。
mutatesTo(Object, Object) - 类 java.beans.DefaultPersistenceDelegate 中的方法
如果指定构造方法中的参数数量不为零，且 oldInstance 的类显式声明了一个 "equals" 方法，则此方法返回 oldInstance.equals(newInstance) 的值。
mutatesTo(Object, Object) - 类 java.beans.PersistenceDelegate 中的方法
如果 oldInstance 的等效 副本可以可以通过应用 newInstance 的一系列语句来创建，则返回 true。
MutationEvent - org.w3c.dom.events 中的 接口
MutationEvent 接口提供与 Mutation 事件相关的特定上下文信息。
MUTE - 类 javax.sound.sampled.BooleanControl.Type 中的静态变量
表示行的静音状态的控件。
MXBean - javax.management 中的 注释类型
显式地标记某一接口是否为 MXBean 接口的注释。
MXBEAN_FIELD - 类 javax.management.JMX 中的静态变量
mxbean 字段的名称。
MYANMAR - 类 java.awt.font.NumericShaper 中的静态变量
标识 MYANMAR 范围和十进制基数。
MYANMAR - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Myanmar”Unicode 字符块的常量。
myProps - 类 javax.naming.InitialContext 中的变量
与此 InitialContext 关联的环境。
mySyntax - 类 javax.naming.CompoundName 中的变量
此组合名称的语法属性。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


N - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

N

N - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
N_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口上边框大小的光标类型。
N_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.N_RESIZE_CURSOR 取代。
NA_10X13_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (10 x 13 in) 的 MediaType 实例。
NA_10x13_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 10 inch × 13 inch 信封尺寸。
NA_10X13_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
10x13 North American 信封尺寸。
NA_10X14_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (10 x 14 in) 的 MediaType 实例。
NA_10x14_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 10 inch × 14 inch 信封尺寸。
NA_10X14_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
10x14North American 信封尺寸。
NA_10X15_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (10 x 15 in) 的 MediaType 实例。
NA_10X15_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 10 inch × 15 inch 信封尺寸。
NA_10X15_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
10x15 North American 信封尺寸。
NA_5X7 - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 5 inch × 7 inch 纸。
NA_5X7 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
5x7 North American 纸。
NA_6X9_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (6 x 9 in) 的 MediaType 实例。
NA_6X9_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 6 inch × 9 inch 信封尺寸。
NA_6X9_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
6x9 North American 信封尺寸。
NA_7X9_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (7 x 9 in) 的 MediaType 实例。
NA_7X9_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 7 inch × 9 inch 信封尺寸。
NA_7X9_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
7x9 North American 信封尺寸。
NA_8X10 - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 8 inch × 10 inch 纸。
NA_8X10 - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
8x10 North American 纸。
NA_9X11_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (9 x 11 in) 的 MediaType 实例。
NA_9x11_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 9 inch × 11 inch 信封尺寸。
NA_9X11_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
9x11 North American 信封尺寸。
NA_9X12_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American (9 x 12 in) 的 MediaType 实例。
NA_9x12_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American 9 inch × 12 inch 信封尺寸。
NA_9X12_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
9x12 North American 信封尺寸。
NA_LEGAL - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American Legal (8 1/2 x 14 in) 的 MediaType 实例。
NA_LEGAL - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
legal 尺寸。
NA_LETTER - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American Letter (8 1/2 x 11 in) 的 MediaType 实例。
NA_LETTER - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
信纸尺寸。
NA_LETTER_TRANSPARENT - 类 javax.print.attribute.standard.MediaName 中的静态变量
信纸透明度。
NA_LETTER_WHITE - 类 javax.print.attribute.standard.MediaName 中的静态变量
空白信纸。
NA_NUMBER_10_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #10 Business Envelope (4 1/8 x 9 1/2 in) 的 MediaType 实例。
NA_NUMBER_10_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 10 商用信封尺寸，4.125 inch × 9.5 inch。
NA_NUMBER_10_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
10 号信封尺寸。
NA_NUMBER_11_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #11 Business Envelope (4 1/2 x 10 3/8 in) 的 MediaType 实例。
NA_NUMBER_11_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 11 商用信封尺寸，4.5 inch × 10.375 inch。
NA_NUMBER_11_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
11 号信封尺寸。
NA_NUMBER_12_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #12 Business Envelope (4 3/4 x 11 in) 的 MediaType 实例。
NA_NUMBER_12_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 12 商用信封尺寸，4.75 inch × 11 inch。
NA_NUMBER_12_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
12 号信封尺寸。
NA_NUMBER_14_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #14 Business Envelope (5 x 11 1/2 in) 的 MediaType 实例。
NA_NUMBER_14_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 14 商用信封尺寸，5 inch × 11.5 inch。
NA_NUMBER_14_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
14 号信封尺寸。
NA_NUMBER_9_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
North American #9 Business Envelope (3 7/8 x 8 7/8 in) 的 MediaType 实例。
NA_NUMBER_9_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.NA 中的静态变量
指定 North American Number 9 商用信封尺寸，3.875 inch × 8.875 inch。
NA_NUMBER_9_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
9 号信封尺寸。
name - 类 java.awt.Cursor 中的变量
光标的用户可视名称。
name - 类 java.awt.Font 中的变量
Font 的逻辑名称，它被传递到构造方法中。
name() - 类 java.lang.Enum 中的方法
返回此枚举常量的名称，在其枚举声明中对其进行声明。
name() - 类 java.nio.charset.Charset 中的方法
返回此 charset 的规范名称。
name - 类 java.sql.DriverPropertyInfo 中的变量
属性的名称。
name() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.name() 中的规范实现 name 方法。
name() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点相对于父节点的名称。
Name - javax.lang.model.element 中的 接口
字符的不可变序列。
name - 类 javax.management.MBeanFeatureInfo 中的变量
该功能的名称。
Name - javax.naming 中的 接口
Name 接口表示一个一般名称，即一个有序的组件序列。
NAME - 接口 javax.script.ScriptEngine 中的静态变量
指定值的保留键，它标识脚本语言的短名称。
NAME - 接口 javax.swing.Action 中的静态变量
用来存储动作的 String 名称的键，用于菜单或按钮。
NAME - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
name - 类 javax.swing.text.html.parser.AttributeList 中的变量
name - 类 javax.swing.text.html.parser.DTD 中的变量
NAME - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
name - 类 javax.swing.text.html.parser.Element 中的变量
name - 类 javax.swing.text.html.parser.Entity 中的变量
name - 类 javax.xml.bind.JAXBElement 中的变量
xml 元素标记名称。
Name - javax.xml.soap 中的 接口
XML 名称的表示形式。
name() - 类 org.omg.CORBA.NamedValue 中的方法
检索此 NamedValue 对象的名称。
name(byte[]) - 类 org.omg.CORBA.Principal 中的方法
已过时。 已由 CORBA 2.2 取代。
name() - 类 org.omg.CORBA.Principal 中的方法
已过时。 已由 CORBA 2.2 取代。
name - 类 org.omg.CORBA.StructMember 中的变量
此 StructMember 对象所描述的 struct 成员的名称。
name() - 类 org.omg.CORBA.TypeCode 中的方法
在 TypeCode 对象的封闭作用域内检索标识此对象的简单名称。
name - 类 org.omg.CORBA.UnionMember 中的变量
此 UnionMember 对象所描述的 union 成员的名称。
name - 类 org.omg.CORBA.ValueMember 中的变量
此 ValueMember 对象所描述的 value 成员的名称。
name() - 接口 org.omg.PortableInterceptor.InterceptorOperations 中的方法
返回 interceptor 的名称。
name - 异常 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName 中的变量
已为其注册了 interceptor 的名称。
name2type(String) - 类 javax.swing.text.html.parser.AttributeList 中的静态方法
name2type(String) - 类 javax.swing.text.html.parser.Element 中的静态方法
name2type(String) - 类 javax.swing.text.html.parser.Entity 中的静态方法
将 nm 字符串转换为相应的实体类型。
NAME_NOT_MN - 异常 org.ietf.jgss.GSSException 中的静态变量
包含多机制元素的名称。
NameAlreadyBoundException - javax.naming 中的 异常
一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
NameAlreadyBoundException(String) - 异常 javax.naming.NameAlreadyBoundException 的构造方法
使用所提供的解释构造一个新的 NameAlreadyBoundException 实例。
NameAlreadyBoundException() - 异常 javax.naming.NameAlreadyBoundException 的构造方法
构造一个新的 NameAlreadyBoundException 实例。
NameAttribute - 接口 javax.swing.text.AttributeSet 中的静态变量
用于命名属性集合的属性名。
NameAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
用于命名属性集合的属性名称。
NameCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。
NameCallback(String) - 类 javax.security.auth.callback.NameCallback 的构造方法
构造一个带提示的 NameCallback。
NameCallback(String, String) - 类 javax.security.auth.callback.NameCallback 的构造方法
构造一个带提示和默认名称的 NameCallback。
NameClassPair - javax.naming 中的 类
此类表示存在于上下文中的某一绑定的对象名称和类名称对。
NameClassPair(String, String) - 类 javax.naming.NameClassPair 的构造方法
在给定名称和类名称的情况下构造一个 NameClassPair 实例。
NameClassPair(String, String, boolean) - 类 javax.naming.NameClassPair 的构造方法
在给定其名称、类名称以及该名称是否相对于列表上下文的情况下构造一个 NameClassPair 实例。
NameComponent - org.omg.CosNaming 中的 类
org/omg/CosNaming/NameComponent.java。
NameComponent() - 类 org.omg.CosNaming.NameComponent 的构造方法
NameComponent(String, String) - 类 org.omg.CosNaming.NameComponent 的构造方法
NameComponentHelper - org.omg.CosNaming 中的 类
org/omg/CosNaming/NameComponentHelper.java。
NameComponentHelper() - 类 org.omg.CosNaming.NameComponentHelper 的构造方法
NameComponentHolder - org.omg.CosNaming 中的 类
org/omg/CosNaming/NameComponentHolder.java。
NameComponentHolder() - 类 org.omg.CosNaming.NameComponentHolder 的构造方法
NameComponentHolder(NameComponent) - 类 org.omg.CosNaming.NameComponentHolder 的构造方法
NamedNodeMap - org.w3c.dom 中的 接口
实现 NamedNodeMap 接口的对象用于表示可以通过名称访问的节点的集合。
NamedValue - org.omg.CORBA 中的 类
在 DII 和 DSI 中用来描述参数和返回值的对象。
NamedValue() - 类 org.omg.CORBA.NamedValue 的构造方法
NameDynAnyPair - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameDynAnyPair.java。
NameDynAnyPair() - 类 org.omg.DynamicAny.NameDynAnyPair 的构造方法
NameDynAnyPair(String, DynAny) - 类 org.omg.DynamicAny.NameDynAnyPair 的构造方法
NameDynAnyPairHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameDynAnyPairHelper.java。
NameDynAnyPairHelper() - 类 org.omg.DynamicAny.NameDynAnyPairHelper 的构造方法
NameDynAnyPairSeqHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameDynAnyPairSeqHelper.java。
NameDynAnyPairSeqHelper() - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 的构造方法
NameHelper - org.omg.CosNaming 中的 类
名称是名称组件的序列。
NameHelper() - 类 org.omg.CosNaming.NameHelper 的构造方法
NameHolder - org.omg.CosNaming 中的 类
名称是名称组件的序列。
NameHolder() - 类 org.omg.CosNaming.NameHolder 的构造方法
NameHolder(NameComponent[]) - 类 org.omg.CosNaming.NameHolder 的构造方法
NameList - org.w3c.dom 中的 接口
NameList 接口提供对并行的名称和名称空间值对（可以为 null 值）的有序集合的抽象，无需定义或约束如何实现此集合。
NameNotFoundException - javax.naming 中的 异常
当名称的组件由于没有被绑定而无法解析时，抛出此异常。
NameNotFoundException(String) - 异常 javax.naming.NameNotFoundException 的构造方法
使用所提供的解释构造一个新的 NameNotFoundException 实例。
NameNotFoundException() - 异常 javax.naming.NameNotFoundException 的构造方法
构造一个新的 NameNotFoundException 实例，将解释和所有名称解析字段和初始化为 null。
NameParser - javax.naming 中的 接口
此接口用于解析取自分层的名称空间的名称。
names - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
从 getFormatNames 返回的字符串数组，该数组最初为 null。
NAMES - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Namespace - javax.xml.stream.events 中的 接口
包含有关名称空间的信息的接口。
NAMESPACE - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个名称空间声明
NAMESPACE_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图以一种与名称空间有关的错误的方式创建或更改一个对象。
NamespaceChangeListener - javax.naming.event 中的 接口
指定对名称空间更改感兴趣的侦听器必须实现的方法。
NamespaceContext - javax.xml.namespace 中的 接口
用于只读 XML 名称空间上下文处理的接口。
NamespaceSupport - org.xml.sax.helpers 中的 类
封装名称空间逻辑，以便由使用 SAX 的应用程序使用，或由 SAX 驱动程序内部使用。
NamespaceSupport() - 类 org.xml.sax.helpers.NamespaceSupport 的构造方法
创建新的名称空间支持对象。
nameUUIDFromBytes(byte[]) - 类 java.util.UUID 中的静态方法
根据指定的字节数组获取类型 3（基于名称的）UUID 的静态工厂。
NameValuePair - org.omg.CORBA 中的 类
将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。
NameValuePair() - 类 org.omg.CORBA.NameValuePair 的构造方法
创建一个空的 NameValuePair 对象。
NameValuePair(String, Any) - 类 org.omg.CORBA.NameValuePair 的构造方法
构造一个 NameValuePair 对象，该对象将给定名称与给定 org.omg.CORBA.Any 对象关联。
NameValuePair - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameValuePair.java。
NameValuePair() - 类 org.omg.DynamicAny.NameValuePair 的构造方法
NameValuePair(String, Any) - 类 org.omg.DynamicAny.NameValuePair 的构造方法
NameValuePairHelper - org.omg.CORBA 中的 类
NameValuePair 的 Helper。
NameValuePairHelper() - 类 org.omg.CORBA.NameValuePairHelper 的构造方法
NameValuePairHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameValuePairHelper.java。
NameValuePairHelper() - 类 org.omg.DynamicAny.NameValuePairHelper 的构造方法
NameValuePairSeqHelper - org.omg.DynamicAny 中的 类
org/omg/DynamicAny/NameValuePairSeqHelper.java。
NameValuePairSeqHelper() - 类 org.omg.DynamicAny.NameValuePairSeqHelper 的构造方法
Naming - java.rmi 中的 类
Naming 类提供在对象注册表中存储和获得远程对远程对象引用的方法。
NamingContext - org.omg.CosNaming 中的 接口
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextExt - org.omg.CosNaming 中的 接口
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtHelper - org.omg.CosNaming 中的 类
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtHelper() - 类 org.omg.CosNaming.NamingContextExtHelper 的构造方法
NamingContextExtHolder - org.omg.CosNaming 中的 类
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtHolder() - 类 org.omg.CosNaming.NamingContextExtHolder 的构造方法
NamingContextExtHolder(NamingContextExt) - 类 org.omg.CosNaming.NamingContextExtHolder 的构造方法
NamingContextExtOperations - org.omg.CosNaming 中的 接口
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtPOA - org.omg.CosNaming 中的 类
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
NamingContextExtPOA() - 类 org.omg.CosNaming.NamingContextExtPOA 的构造方法
NamingContextHelper - org.omg.CosNaming 中的 类
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextHelper() - 类 org.omg.CosNaming.NamingContextHelper 的构造方法
NamingContextHolder - org.omg.CosNaming 中的 类
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextHolder() - 类 org.omg.CosNaming.NamingContextHolder 的构造方法
NamingContextHolder(NamingContext) - 类 org.omg.CosNaming.NamingContextHolder 的构造方法
NamingContextOperations - org.omg.CosNaming 中的 接口
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextPOA - org.omg.CosNaming 中的 类
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
NamingContextPOA() - 类 org.omg.CosNaming.NamingContextPOA 的构造方法
NamingEnumeration<T> - javax.naming 中的 接口
此接口用于枚举 javax.naming 和 javax.naming.directory 包中的方法所返回的列表。
NamingEvent - javax.naming.event 中的 类
此类表示命名/目录服务触发的事件。
NamingEvent(EventContext, int, Binding, Binding, Object) - 类 javax.naming.event.NamingEvent 的构造方法
构造一个 NamingEvent 的实例。
NamingException - javax.naming 中的 异常
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
NamingException(String) - 异常 javax.naming.NamingException 的构造方法
使用解释构造一个新的 NamingException。
NamingException() - 异常 javax.naming.NamingException 的构造方法
构造一个新的 NamingException。
NamingExceptionEvent - javax.naming.event 中的 类
此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。
NamingExceptionEvent(EventContext, NamingException) - 类 javax.naming.event.NamingExceptionEvent 的构造方法
使用在抛出过 NamingException 的上下文和抛出的异常构造一个 NamingExceptionEvent 的实例。
namingExceptionThrown(NamingExceptionEvent) - 接口 javax.naming.event.NamingListener 中的方法
在试图触发 NamingEvent 期间抛出命名异常时调用此方法。
NamingListener - javax.naming.event 中的 接口
此接口是处理 NamingEvent 的侦听器接口的根。
NamingManager - javax.naming.spi 中的 类
此类包含一些方法来创建上下文对象以及通过命名或目录服务中的信息引用的对象。
NamingSecurityException - javax.naming 中的 异常
此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
NamingSecurityException(String) - 异常 javax.naming.NamingSecurityException 的构造方法
使用所提供的解释构造一个新的 NamingSecurityException 实例。
NamingSecurityException() - 异常 javax.naming.NamingSecurityException 的构造方法
构造一个新的 NamingSecurityException 实例。
NaN - 类 java.lang.Double 中的静态变量
保存 double 类型的 NaN 值的常量。
NaN - 类 java.lang.Float 中的静态变量
保存 float 类型的非数字 (NaN) 值的常量。
nanoTime() - 类 java.lang.System 中的静态方法
返回最准确的可用系统计时器的当前值，以毫微秒为单位。
narrow(Object, Class) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。
narrow(Object, Class) - 类 javax.rmi.PortableRemoteObject 中的静态方法
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。
narrow(Object) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
narrow(Object) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
narrow(Object) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
narrow(Object) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
narrow(Object) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
narrow(Object) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
narrow(Object) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
narrow(Object) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
narrow(Object) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableServer.POAHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
narrow(Object) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
NATIVE - 类 java.awt.JobAttributes.DialogType 中的静态变量
用于指定平台的本机打印对话框的 DialogType 实例。
NATIVE - 类 java.lang.reflect.Modifier 中的静态变量
表示 native 修饰符的 int 的值。
nativeImageMetadataFormatClassName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的本地流元数据格式的类名称的 String，该字符串最初为 null。
nativeImageMetadataFormatName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。
nativeMetadataFormatClassName - 类 javax.imageio.metadata.IIOMetadata 中的变量
实现 IIOMetadataFormat 和表示本机元数据格式的类的名称，初始化为 null，通过构造方法设置。
nativeMetadataFormatName - 类 javax.imageio.metadata.IIOMetadata 中的变量
此对象本机元数据格式的名称，初始化为 null，通过构造方法设置。
nativeOrder() - 类 java.nio.ByteOrder 中的静态方法
获取底层平台的本机字节顺序。
nativeSQL(String) - 接口 java.sql.Connection 中的方法
将给定的 SQL 语句转换成系统本机 SQL 语法。
nativeStreamMetadataFormatClassName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的本地流元数据格式的类名称的 String，初始为 null。
nativeStreamMetadataFormatName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。
navigableKeySet() - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
返回此映射中所包含键的 NavigableSet 视图。
navigableKeySet() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
navigableKeySet() - 接口 java.util.NavigableMap 中的方法
返回此映射中所包含键的 NavigableSet 视图。
navigableKeySet() - 类 java.util.TreeMap 中的方法
NavigableMap<K,V> - java.util 中的 接口
扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。
NavigableSet<E> - java.util 中的 接口
扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
navigateFocusedComp(int) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
navigateKey - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
navigateKey2 - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的变量
已过时。 从 1.3 开始。
navigateSelectedTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
NavigationFilter - javax.swing.text 中的 类
NavigationFilter 可用于限制光标的定位。
NavigationFilter() - 类 javax.swing.text.NavigationFilter 的构造方法
NavigationFilter.FilterBypass - javax.swing.text 中的 类
用作防止回调插入符以定位光标的方式。
NavigationFilter.FilterBypass() - 类 javax.swing.text.NavigationFilter.FilterBypass 的构造方法
NCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 NCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
NClob - java.sql 中的 接口
SQL NCLOB 类型在 JavaTM 编程语言中的映射。
NCLOB - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 NCLOB 的 Java 编程语言中的常量（有时称为类型代码）。
ncontext - 类 org.omg.CosNaming.BindingType 中的静态变量
nCopies(int, T) - 类 java.util.Collections 中的静态方法
返回由指定对象的 n 个副本组成的不可变列表。
NE_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口右上角大小的光标类型。
NE_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.NE_RESIZE_CURSOR 取代。
needsCacheFile() - 类 javax.imageio.spi.ImageInputStreamSpi 中的方法
如果与此服务提供者关联的 ImageInputStream 实现要求使用缓存 File，则返回 true。
needsCacheFile() - 类 javax.imageio.spi.ImageOutputStreamSpi 中的方法
如果与此服务提供者关联的 ImageOutputStream 实现要求使用缓存 File，则返回 true。
needsDictionary() - 类 java.util.zip.Inflater 中的方法
如果解压缩需要预置字典，则返回 true。
needsGui() - 类 java.beans.beancontext.BeanContextSupport 中的方法
此方法通常从环境中调用，以便确定实现者是否“需要” GUI。
needsGui() - 接口 java.beans.Visibility 中的方法
确定此 bean 是否需要一个 GUI。
needsInput() - 类 java.util.zip.Deflater 中的方法
如果输入数据缓冲区为空，并且应调用 setInput() 以提供更多输入，则返回 true。
needsInput() - 类 java.util.zip.Inflater 中的方法
如果输入缓冲区中没有剩余数据，则返回 true。
needsReload(String, Locale, String, ClassLoader, ResourceBundle, long) - 类 java.util.ResourceBundle.Control 中的方法
确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
negate() - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为 (-this)，其标度为 this.scale()。
negate(MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (-this) 的 BigDecimal（根据上下文设置进行舍入）。
negate() - 类 java.math.BigInteger 中的方法
返回其值是 (-this) 的 BigInteger。
negate() - 类 javax.xml.datatype.Duration 中的方法
返回值为 -this 的新 Duration 对象。
NEGATIVE_INFINITY - 类 java.lang.Double 中的静态变量
保存 double 类型的负无穷大值的常量。
NEGATIVE_INFINITY - 类 java.lang.Float 中的静态变量
保存 float 类型的负无穷大值的常量。
NEGATIVE_SCROLL - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态变量
NegativeArraySizeException - java.lang 中的 异常
如果应用程序试图创建大小为负的数组，则抛出该异常。
NegativeArraySizeException() - 异常 java.lang.NegativeArraySizeException 的构造方法
构造不带详细消息的 NegativeArraySizeException。
NegativeArraySizeException(String) - 异常 java.lang.NegativeArraySizeException 的构造方法
构造带指定详细消息的 NegativeArraySizeException。
negotiate() - 类 javax.naming.ldap.StartTlsResponse 中的方法
使用默认的 SSL 套接字工厂协商 TLS 会话。
negotiate(SSLSocketFactory) - 类 javax.naming.ldap.StartTlsResponse 中的方法
使用 SSL 套接字工厂协商 TLS 会话。
nested - 异常 javax.xml.stream.XMLStreamException 中的变量
NestingKind - javax.lang.model.element 中的 枚举
某一类型元素的嵌套种类 (nesting kind)。
NetPermission - java.net 中的 类
此类可用于各种网络权限。
NetPermission(String) - 类 java.net.NetPermission 的构造方法
创建具有指定名称的新 NetPermission。
NetPermission(String, String) - 类 java.net.NetPermission 的构造方法
创建带指定名称的新 NetPermission。
NetworkInterface - java.net 中的 类
此类表示一个由名称和分配给此接口的 IP 地址列表组成的网络接口。
NEVER_UPDATE - 类 javax.swing.text.DefaultCaret 中的静态变量
指示无论文档有任何更新，插入符都应在文档中保持同一绝对位置，由于删除使文档长度小于当前插入符位置除外。
new_context() - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
new_context() - 类 org.omg.CosNaming._NamingContextStub 中的方法
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
new_context() - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
此操作返回调用该操作的上下文的命名服务器实现的命名上下文。
newAttributes - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的变量
newAudioClip(URL) - 类 java.applet.Applet 中的静态方法
从给定 URL 处获取音频剪辑。
newBinding - 类 javax.naming.event.NamingEvent 中的变量
包含关于更改后对象的信息。
newBundle(String, Locale, String, ClassLoader, boolean) - 类 java.util.ResourceBundle.Control 中的方法
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。
newCachedThreadPool() - 类 java.util.concurrent.Executors 中的静态方法
创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们。
newCachedThreadPool(ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们，并在需要时使用提供的 ThreadFactory 创建新线程。
newCall(RemoteObject, Operation[], int, long) - 接口 java.rmi.server.RemoteRef 中的方法
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。
newCanonicalizationMethod(String, C14NMethodParameterSpec) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 CanonicalizationMethod。
newCanonicalizationMethod(String, XMLStructure) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 CanonicalizationMethod。
newChannel(InputStream) - 类 java.nio.channels.Channels 中的静态方法
构造从给定流读取字节的信道。
newChannel(OutputStream) - 类 java.nio.channels.Channels 中的静态方法
构造向给定流写入字节的信道。
newClient(Object) - 接口 javax.management.remote.rmi.RMIServer 中的方法
建立一个使用该 RMI 连接器的新连接。
newClient(Object) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
创建一个新的客户端连接。
newClient(Object) - 类 javax.management.remote.rmi.RMIServerImpl_Stub 中的方法
newCondition() - 接口 java.util.concurrent.locks.Lock 中的方法
返回绑定到此 Lock 实例的新 Condition 实例。
newCondition() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回用来与此 Lock 实例一起使用的 Condition 实例。
newCondition() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
因为 ReadLocks 不支持条件，所以将抛出 UnsupportedOperationException。
newCondition() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
返回一个用来与此 Lock 实例一起使用的 Condition 实例。
newDataAvailable(TableModelEvent) - 类 javax.swing.table.DefaultTableModel 中的方法
等效于 fireTableChanged。
newDecoder() - 类 java.nio.charset.Charset 中的方法
为此 charset 构造新的解码器。
newDigestMethod(String, DigestMethodParameterSpec) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 DigestMethod。
newDocument() - 类 javax.xml.parsers.DocumentBuilder 中的方法
获取 DOM Document 对象的一个新实例来生成一个 DOM 树。
newDocumentBuilder() - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
使用当前配置的参数创建一个新的 DocumentBuilder 实例。
newDuration(String) - 类 javax.xml.datatype.DatatypeFactory 中的方法
获取新的 Duration 实例，它根据 XML 模式 1.0 第 3.2.6.1 节中的定义将 Duration 指定为其字符串表示形式 "PnYnMnDTnHnMnS"。
newDuration(long) - 类 javax.xml.datatype.DatatypeFactory 中的方法
获取新的 Duration 实例，它将 Duration 指定为毫秒。
newDuration(boolean, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigDecimal) - 类 javax.xml.datatype.DatatypeFactory 中的方法
获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
newDuration(boolean, int, int, int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
newDurationDayTime(String) - 类 javax.xml.datatype.DatatypeFactory 中的方法
通过解析其 String 表示形式 "PnDTnHnMnS"（XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration）创建类型为 xdt:dayTimeDuration 的 Duration。
newDurationDayTime(long) - 类 javax.xml.datatype.DatatypeFactory 中的方法
使用 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中定义的指定毫秒创建类型为 xdt:dayTimeDuration 的 Duration。
newDurationDayTime(boolean, BigInteger, BigInteger, BigInteger, BigInteger) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
newDurationDayTime(boolean, int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
newDurationYearMonth(String) - 类 javax.xml.datatype.DatatypeFactory 中的方法
通过解析其 String 表示形式 "PnYnM"（XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration）创建类型为 xdt:yearMonthDuration 的 Duration。
newDurationYearMonth(long) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定毫秒创建类型为 xdt:yearMonthDuration 的 Duration。
newDurationYearMonth(boolean, BigInteger, BigInteger) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
newDurationYearMonth(boolean, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
newEncoder() - 类 java.nio.charset.Charset 中的方法
为此 charset 构造新的编码器。
newFactory(String) - 类 javax.xml.validation.SchemaFactoryLoader 中的方法
创建指定模式语言的新 SchemaFactory 对象。
newFixedThreadPool(int) - 类 java.util.concurrent.Executors 中的静态方法
创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程。
newFixedThreadPool(int, ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程，在需要时使用提供的 ThreadFactory 创建新线程。
newFolderIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
newInputStream(ReadableByteChannel) - 类 java.nio.channels.Channels 中的静态方法
构造从给定信道读取字节的流。
newInstance() - 类 java.lang.Class 中的方法
创建此 Class 对象所表示的类的一个新实例。
newInstance(Class<?>, int) - 类 java.lang.reflect.Array 中的静态方法
创建一个具有指定的组件类型和长度的新数组。
newInstance(Class<?>, int...) - 类 java.lang.reflect.Array 中的静态方法
创建一个具有指定的组件类型和维度的新数组。
newInstance(Object...) - 类 java.lang.reflect.Constructor 中的方法
使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。
newInstance(URL[], ClassLoader) - 类 java.net.URLClassLoader 中的静态方法
为指定的 URL 和父类加载器创建新 URLClassLoader 实例。
newInstance(URL[]) - 类 java.net.URLClassLoader 中的静态方法
为指定的 URL 和默认的父类加载器创建新 URLClassLoader 实例。
newInstance(ActivationID, ActivationDesc) - 类 java.rmi.activation.ActivationGroup_Stub 中的方法
ActivationGroup.newInstance 的 stub 方法。
newInstance(ActivationID, ActivationDesc) - 接口 java.rmi.activation.ActivationInstantiator 中的方法
激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
newInstance(KeyStore, KeyStore.ProtectionParameter) - 类 java.security.KeyStore.Builder 中的静态方法
返回封装给定 KeyStore 的新 Builder。
newInstance(String, Provider, File, KeyStore.ProtectionParameter) - 类 java.security.KeyStore.Builder 中的静态方法
返回新的 Builder 对象。
newInstance(String, Provider, KeyStore.ProtectionParameter) - 类 java.security.KeyStore.Builder 中的静态方法
返回新的 Builder 对象。
newInstance(Object) - 类 java.security.Provider.Service 中的方法
返回此服务描述的实现的新实例。
newInstance(Control[]) - 类 javax.naming.ldap.InitialLdapContext 中的方法
newInstance(Control[]) - 接口 javax.naming.ldap.LdapContext 中的方法
创建此上下文的新实例，使用请求控件进行初始化。
newInstance(String) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance(String, ClassLoader) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance(String, ClassLoader, Map<String, ?>) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance(Class...) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance(Class[], Map<String, ?>) - 类 javax.xml.bind.JAXBContext 中的静态方法
获得 JAXBContext 类的新实例。
newInstance() - 类 javax.xml.datatype.DatatypeFactory 中的静态方法
获取新的 DatatypeFactory 实例。
newInstance(String, ClassLoader) - 类 javax.xml.datatype.DatatypeFactory 中的静态方法
从类名称中获取新的 DatatypeFactory 实例。
newInstance() - 类 javax.xml.parsers.DocumentBuilderFactory 中的静态方法
获取 DocumentBuilderFactory 的新实例。
newInstance(String, ClassLoader) - 类 javax.xml.parsers.DocumentBuilderFactory 中的静态方法
从类名称中获取新的 DocumentBuilderFactory 实例。
newInstance() - 类 javax.xml.parsers.SAXParserFactory 中的静态方法
获取 SAXParserFactory 的一个新实例。
newInstance(String, ClassLoader) - 类 javax.xml.parsers.SAXParserFactory 中的静态方法
从类名称中获取新的 SAXParserFactory 实例。
newInstance() - 类 javax.xml.soap.MessageFactory 中的静态方法
创建新的 MessageFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
newInstance(String) - 类 javax.xml.soap.MessageFactory 中的静态方法
创建新的 MessageFactory 对象，该对象是指定实现的实例。
newInstance() - 类 javax.xml.soap.SOAPConnectionFactory 中的静态方法
创建默认 SOAPConnectionFactory 对象的实例。
newInstance() - 类 javax.xml.soap.SOAPElementFactory 中的静态方法
已过时。 创建新的 SOAPElementFactory 实例。
newInstance() - 类 javax.xml.soap.SOAPFactory 中的静态方法
创建新的 SOAPFactory 对象，该对象是默认实现 (SOAP 1.1) 的实例。
newInstance(String) - 类 javax.xml.soap.SOAPFactory 中的静态方法
创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。
newInstance() - 接口 javax.xml.stream.util.XMLEventAllocator 中的方法
此方法创建一个 XMLEventAllocator 实例。
newInstance() - 类 javax.xml.stream.XMLEventFactory 中的静态方法
创建一个新的工厂实例。
newInstance(String, ClassLoader) - 类 javax.xml.stream.XMLEventFactory 中的静态方法
创建一个新的工厂实例。
newInstance() - 类 javax.xml.stream.XMLInputFactory 中的静态方法
创建一个新的工厂实例。
newInstance(String, ClassLoader) - 类 javax.xml.stream.XMLInputFactory 中的静态方法
创建一个新的工厂实例。
newInstance() - 类 javax.xml.stream.XMLOutputFactory 中的静态方法
创建一个新的工厂实例。
newInstance(String, ClassLoader) - 类 javax.xml.stream.XMLOutputFactory 中的静态方法
创建一个的新工厂实例。
newInstance() - 类 javax.xml.transform.TransformerFactory 中的静态方法
获取 TransformerFactory 的新实例。
newInstance(String, ClassLoader) - 类 javax.xml.transform.TransformerFactory 中的静态方法
根据类名称获得一个新 TransformerFactory 实例。
newInstance(String) - 类 javax.xml.validation.SchemaFactory 中的静态方法
查找支持指定模式语言的 SchemaFactory 的实现并返回它。
newInstance(String, String, ClassLoader) - 类 javax.xml.validation.SchemaFactory 中的静态方法
根据类名称获得一个新 SchemaFactory 实例。
newInstance() - 类 javax.xml.xpath.XPathFactory 中的静态方法
获取使用默认对象模型 XPathFactory.DEFAULT_OBJECT_MODEL_URI（即 W3C DOM）的新 XPathFactory 实例。
newInstance(String) - 类 javax.xml.xpath.XPathFactory 中的静态方法
获取使用指定对象模型的新 XPathFactory 实例。
newInstance(String, String, ClassLoader) - 类 javax.xml.xpath.XPathFactory 中的静态方法
根据工厂类名称获取一个新 XPathFactory 实例。
newInstance() - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的静态方法
获得 DOMImplementationRegistry 的新实例。
newJMXConnector(JMXServiceURL, Map<String, ?>) - 类 javax.management.remote.JMXConnectorFactory 中的静态方法
为位于给定地址的连接器服务器创建一个连接器客户端。
newJMXConnector(JMXServiceURL, Map<String, ?>) - 接口 javax.management.remote.JMXConnectorProvider 中的方法
创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
newJMXConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - 类 javax.management.remote.JMXConnectorServerFactory 中的静态方法
创建位于给定地址的连接器服务器。
newJMXConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - 接口 javax.management.remote.JMXConnectorServerProvider 中的方法
创建位于给定地址的新连接器服务器。
newKeyInfo(List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
创建包含指定的密钥信息类型列表的 KeyInfo。
newKeyInfo(List, String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。
newKeyName(String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的名称创建 KeyName。
newKeyValue(PublicKey) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的公钥创建 KeyValue。
newLeadSelectionPath - 类 javax.swing.event.TreeSelectionEvent 中的变量
在路径被更改之后的 leadSelectionPath，可能为 null。
newLine() - 类 java.io.BufferedWriter 中的方法
写入一个行分隔符。
NEWLINE - 类 javax.swing.text.AbstractWriter 中的静态变量
text 包模拟新行的方式。
newManifest(List) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建包含指定的 Reference 列表的 Manifest。
newManifest(List, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建包含指定的 Reference 列表和可选 id 的 Manifest。
newMBeanProxy(MBeanServerConnection, ObjectName, Class<T>) - 类 javax.management.JMX 中的静态方法
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
newMBeanProxy(MBeanServerConnection, ObjectName, Class<T>, boolean) - 类 javax.management.JMX 中的静态方法
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
newMBeanServer(String, MBeanServer, MBeanServerDelegate) - 类 javax.management.MBeanServerBuilder 中的方法
此方法创建一个新的 MBeanServer 实现对象。
newMBeanServer() - 类 javax.management.MBeanServerFactory 中的静态方法
返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
newMBeanServer(String) - 类 javax.management.MBeanServerFactory 中的静态方法
返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
newMBeanServerDelegate() - 类 javax.management.MBeanServerBuilder 中的方法
此方法为新的 MBeanServer 创建新的 MBeanServerDelegate。
newMessageFactory(String) - 类 javax.xml.soap.SAAJMetaFactory 中的方法
创建给定 String 协议的 MessageFactory 对象。
newmodel - 类 java.awt.image.RGBImageFilter 中的变量
用户调用 substituteColorModel 时替换 origmodel 的 ColorModel。
newMXBeanProxy(MBeanServerConnection, ObjectName, Class<T>) - 类 javax.management.JMX 中的静态方法
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
newMXBeanProxy(MBeanServerConnection, ObjectName, Class<T>, boolean) - 类 javax.management.JMX 中的静态方法
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
newNode - 类 java.util.prefs.AbstractPreferences 中的变量
如果在创建此对象前内部存储中不存在此节点，则该字段为 true。
newOutputStream(WritableByteChannel) - 类 java.nio.channels.Channels 中的静态方法
构造向给定信道写入字节的流。
newPacker() - 类 java.util.jar.Pack200 中的静态方法
获取一个实现 Packer 的新的类实例。
newPermissionCollection() - 类 java.io.FilePermission 中的方法
返回用于存储 FilePermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.net.SocketPermission 中的方法
用于存储 SocketPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.security.AllPermission 中的方法
返回用于存储 AllPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.security.BasicPermission 中的方法
用于存储 BasicPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.security.Permission 中的方法
对给定 Permission 对象返回空 PermissionCollection，如果没有定义则返回 null。
newPermissionCollection() - 类 java.security.UnresolvedPermission 中的方法
返回存储 UnresolvedPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 java.util.PropertyPermission 中的方法
用于存储 PropertyPermission 对象的新 PermissionCollection 对象。
newPermissionCollection() - 类 javax.management.MBeanServerPermission 中的方法
newPermissionCollection() - 类 javax.security.auth.kerberos.DelegationPermission 中的方法
返回用于存储 DelegationPermission 对象的 PermissionCollection 对象。
newPermissionCollection() - 类 javax.security.auth.kerberos.ServicePermission 中的方法
返回用于存储 ServicePermission 对象的 PermissionCollection 对象。
newPermissionCollection() - 类 javax.security.auth.PrivateCredentialPermission 中的方法
返回 PermissionCollection 中同类的 PrivateCredentialPermissions 集合。
newPGPData(byte[]) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 PGP 公钥标识符创建 PGPData。
newPGPData(byte[], byte[], List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 PGP 公钥标识符、可选的密钥材料包和外部元素的列表，创建 PGPData。
newPGPData(byte[], List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 PGP 密钥材料包和可选的外部元素列表创建 PGPData。
newPixels() - 类 java.awt.image.MemoryImageSource 中的方法
将全部的新像素缓冲区发送到所有目前对此图像数据感兴趣的 ImageConsumer，并通知这些 ImageConsumer 一个动画帧已完成。
newPixels(int, int, int, int) - 类 java.awt.image.MemoryImageSource 中的方法
将像素缓冲区的矩形区域发送到所有目前对此图像数据感兴趣的 ImageConsumer，并通知这些 ImageConsumer 一个动画帧已完成。
newPixels(int, int, int, int, boolean) - 类 java.awt.image.MemoryImageSource 中的方法
将像素缓冲区的矩形区域发送到所有目前对此图像数据感兴趣的 ImageConsumer。
newPixels(byte[], ColorModel, int, int) - 类 java.awt.image.MemoryImageSource 中的方法
改用一个新的 byte 数组以保存此图像的像素。
newPixels(int[], ColorModel, int, int) - 类 java.awt.image.MemoryImageSource 中的方法
改用一个新的 int 数组以保存此图像的像素。
newPlatformMXBeanProxy(MBeanServerConnection, String, Class<T>) - 类 java.lang.management.ManagementFactory 中的静态方法
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。
newProxyInstance(ClassLoader, Class<?>[], InvocationHandler) - 类 java.lang.reflect.Proxy 中的静态方法
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。
newProxyInstance(MBeanServerConnection, ObjectName, Class<T>, boolean) - 类 javax.management.MBeanServerInvocationHandler 中的静态方法
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。
newReader(ReadableByteChannel, CharsetDecoder, int) - 类 java.nio.channels.Channels 中的静态方法
构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。
newReader(ReadableByteChannel, String) - 类 java.nio.channels.Channels 中的静态方法
构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。
newReference(String, DigestMethod) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定 URI 和摘要方法的 Reference。
newReference(String, DigestMethod, List, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定参数的 Reference。
newReference(String, DigestMethod, List, String, String, byte[]) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定参数和预计算的摘要值的 Reference。
newReference(String, DigestMethod, List, Data, List, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定参数的 Reference。
newRetrievalMethod(String) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 URI 创建 RetrievalMethod。
newRetrievalMethod(String, String, List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的参数创建 RetrievalMethod。
newRowsAdded(TableModelEvent) - 类 javax.swing.table.DefaultTableModel 中的方法
确保新行的列数正确。
NEWS - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
USENET 新闻。
newSAXParser() - 类 javax.xml.parsers.SAXParserFactory 中的方法
使用当前配置的工厂参数创建 SAXParser 的一个新实例。
newScheduledThreadPool(int) - 类 java.util.concurrent.Executors 中的静态方法
创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
newScheduledThreadPool(int, ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
newSchema(Source) - 类 javax.xml.validation.SchemaFactory 中的方法
解析作为模式的指定源并以模式形式返回它。
newSchema(File) - 类 javax.xml.validation.SchemaFactory 中的方法
解析作为模式的指定 File 并以 Schema 的形式返回它。
newSchema(URL) - 类 javax.xml.validation.SchemaFactory 中的方法
解析作为模式的指定 URL 并以 Schema 形式返回它。
newSchema(Source[]) - 类 javax.xml.validation.SchemaFactory 中的方法
解析作为模式的指定源（或多个源），并以模式形式返回它。
newSchema() - 类 javax.xml.validation.SchemaFactory 中的方法
创建特殊的 Schema 对象。
newSetFromMap(Map<E, Boolean>) - 类 java.util.Collections 中的静态方法
返回指定映射支持的 set。
newSignatureMethod(String, SignatureMethodParameterSpec) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 SignatureMethod。
newSignatureProperties(List, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。
newSignatureProperty(List, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。
newSignedInfo(CanonicalizationMethod, SignatureMethod, List) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
newSignedInfo(CanonicalizationMethod, SignatureMethod, List, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建带指定参数的 SignedInfo。
newSingleThreadExecutor() - 类 java.util.concurrent.Executors 中的静态方法
创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程。
newSingleThreadExecutor(ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程，并在需要时使用提供的 ThreadFactory 创建新线程。
newSingleThreadScheduledExecutor() - 类 java.util.concurrent.Executors 中的静态方法
创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
newSingleThreadScheduledExecutor(ThreadFactory) - 类 java.util.concurrent.Executors 中的静态方法
创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
newSOAPFactory(String) - 类 javax.xml.soap.SAAJMetaFactory 中的方法
创建给定 String 协议的 SOAPFactory 对象。
newTaskFor(Runnable, T) - 类 java.util.concurrent.AbstractExecutorService 中的方法
为给定可运行任务和默认值返回一个 RunnableFuture。
newTaskFor(Callable<T>) - 类 java.util.concurrent.AbstractExecutorService 中的方法
为给定可调用任务返回一个 RunnableFuture。
newTemplates(Source) - 类 javax.xml.transform.TransformerFactory 中的方法
将 Source 处理为 Templates 对象，后者是源的编译后表示形式。
newTemplatesHandler() - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
获取能够将 SAX ContentHandler 事件处理为 Templates 对象的 TemplatesHandler 对象。
newThread(Runnable) - 接口 java.util.concurrent.ThreadFactory 中的方法
构造一个新 Thread。
newTransform(String, TransformParameterSpec) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 Transform。
newTransform(String, XMLStructure) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
针对指定的算法 URI 和参数创建 Transform。
newTransformer() - 接口 javax.xml.transform.Templates 中的方法
创建此 Templates 对象的新转换上下文。
newTransformer(Source) - 类 javax.xml.transform.TransformerFactory 中的方法
将 Source 处理为 Transformer Object。
newTransformer() - 类 javax.xml.transform.TransformerFactory 中的方法
创建执行从 Source 到 Result 的复制的新 Transformer。
newTransformerHandler(Source) - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
基于参数所指定的转换指令，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
newTransformerHandler(Templates) - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
基于 Templates 参数，获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
newTransformerHandler() - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
获取能够将 SAX ContentHandler 事件处理为 Result 的 TransformerHandler 对象。
newUnpacker() - 类 java.util.jar.Pack200 中的静态方法
获取一个实现 Unpacker 的新的类实例。
newUpdater(Class<U>, String) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的静态方法
使用给定字段为对象创建和返回一个更新器。
newUpdater(Class<U>, String) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的静态方法
为对象创建并返回一个具有给定字段的更新器。
newUpdater(Class<U>, Class<W>, String) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的静态方法
使用给定的字段为对象创建和返回一个更新器。
newValidator() - 类 javax.xml.validation.Schema 中的方法
创建此 Schema 的新 Validator。
newValidatorHandler() - 类 javax.xml.validation.Schema 中的方法
创建此 Schema 的新 ValidatorHandler。
newWriter(WritableByteChannel, CharsetEncoder, int) - 类 java.nio.channels.Channels 中的静态方法
构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。
newWriter(WritableByteChannel, String) - 类 java.nio.channels.Channels 中的静态方法
构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。
newX509Data(List) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
创建包含指定的 X.509 内容列表的 X509Data。
newX509IssuerSerial(String, BigInteger) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。
newXMLFilter(Source) - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
创建使用给定 Source 作为转换指令的 XMLFilter。
newXMLFilter(Templates) - 类 javax.xml.transform.sax.SAXTransformerFactory 中的方法
基于 Templates 参数，创建 XMLFilter。
newXMLGregorianCalendar() - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建新的 XMLGregorianCalendar 实例。
newXMLGregorianCalendar(String) - 类 javax.xml.datatype.DatatypeFactory 中的方法
通过将字符串解析为词汇表示形式，创建新的 XMLGregorianCalendar。
newXMLGregorianCalendar(GregorianCalendar) - 类 javax.xml.datatype.DatatypeFactory 中的方法
根据 GregorianCalendar 创建 XMLGregorianCalendar。
newXMLGregorianCalendar(BigInteger, int, int, int, int, int, BigDecimal, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
newXMLGregorianCalendar(int, int, int, int, int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
java.util.GregorianCalendar 实例需要转换为 XMLGregorianCalendar 实例的值空间的构造方法。
newXMLGregorianCalendarDate(int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建 XML 模式内置数据类型 date 或 g* 的 Java 表示形式。
newXMLGregorianCalendarTime(int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建 XML 模式内置数据类型 time 的 Java 实例。
newXMLGregorianCalendarTime(int, int, int, BigDecimal, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建 XML 模式内置数据类型 time 的 Java 实例。
newXMLGregorianCalendarTime(int, int, int, int, int) - 类 javax.xml.datatype.DatatypeFactory 中的方法
创建 XML 模式内置数据类型 time 的 Java 实例。
newXMLObject(List, String, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
根据指定参数创建 XMLObject。
newXMLSignature(SignedInfo, KeyInfo) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建一个 XMLSignature，并使用指定的 SignedInfo 和 KeyInfo 对象的内容对其进行初始化。
newXMLSignature(SignedInfo, KeyInfo, List, String, String) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
创建一个 XMLSignature，并使用指定的参数对其进行初始化。
newXPath() - 类 javax.xml.xpath.XPathFactory 中的方法
返回使用实例化 XPathFactory 时确定的底层对象模型的新 XPath。
next(Container) - 类 java.awt.CardLayout 中的方法
翻转到指定容器的下一张卡片。
next() - 类 java.awt.geom.FlatteningPathIterator 中的方法
只要最初的遍历方向上存在多个点，就沿该方向将迭代器移动到下一个路径段。
next() - 接口 java.awt.geom.PathIterator 中的方法
只要最初的遍历方向上还存在点，就沿该方向将迭代器移动到下一个路径段。
next() - 类 java.beans.beancontext.BeanContextSupport.BCSIterator 中的方法
next(int) - 类 java.security.SecureRandom 中的方法
生成一个包含用户指定伪随机位数的整数（右对齐，带前导零）。
next() - 接口 java.sql.ResultSet 中的方法
将光标从当前位置向前移一行。
next(int) - 类 java.text.BreakIterator 中的方法
返回从当前边界起第 n 个边界。
next() - 类 java.text.BreakIterator 中的方法
返回当前边界的后一个边界。
next() - 接口 java.text.CharacterIterator 中的方法
将迭代器的索引加一，并返回新索引处的字符。
next() - 类 java.text.CollationElementIterator 中的方法
获取字符串中的下一个 collation 元素。
next() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.next()。
next() - 接口 java.util.Iterator 中的方法
返回迭代的下一个元素。
next() - 接口 java.util.ListIterator 中的方法
返回列表中的下一个元素。
next(int) - 类 java.util.Random 中的方法
生成下一个伪随机数。
next() - 类 java.util.Scanner 中的方法
查找并返回来自此扫描器的下一个完整标记。
next(String) - 类 java.util.Scanner 中的方法
如果下一个标记与从指定字符串构造的模式匹配，则返回下一个标记。
next(Pattern) - 类 java.util.Scanner 中的方法
如果下一个标记与指定模式匹配，则返回下一个标记。
next() - 接口 javax.naming.NamingEnumeration 中的方法
检索枚举中的下一个元素。
next(int) - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
确定此整数集属性中的最小整数是否大于给定值。
next() - 接口 javax.print.MultiDoc 中的方法
转到包含 doc 对象序列中下一个 doc 对象的 multidoc 对象。
NEXT - 接口 javax.swing.SwingConstants 中的静态变量
标识序列中的下一个方向。
next() - 类 javax.swing.text.ElementIterator 中的方法
获取下一个 Element。
next() - 类 javax.swing.text.html.HTMLDocument.Iterator 中的方法
将迭代器向前移动到它所表示的下一个标记出现的位置。
next - 类 javax.swing.text.html.parser.AttributeList 中的变量
next - 类 javax.swing.text.html.parser.ContentModel 中的变量
下一个内容模式（使用 ','、'|' 或 '&' 表达式）。
next() - 类 javax.swing.text.Segment 中的方法
将迭代器的索引加一，并返回新索引处的字符。
next() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
next() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
next() - 接口 javax.xml.stream.XMLStreamReader 中的方法
获取下一个解析事件??处理器可以用单个存储块返回所有连续的字符数据，它也可以将其分割成几个存储块。
next() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 移动到此 DynAny 对象的下一个组件。
next() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynStructStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将当前位置推进到下一个组件。
next() - 类 org.omg.DynamicAny._DynValueStub 中的方法
将当前位置推进到下一个组件。
next() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将当前位置推进到下一个组件。
next_n(int, BindingListHolder) - 类 org.omg.CosNaming._BindingIteratorStub 中的方法
此操作返回最多可以达到的请求绑定数。
next_n(int, BindingListHolder) - 接口 org.omg.CosNaming.BindingIteratorOperations 中的方法
此操作返回最多可以达到的请求绑定数。
next_one(BindingHolder) - 类 org.omg.CosNaming._BindingIteratorStub 中的方法
此操作返回下一个绑定。
next_one(BindingHolder) - 接口 org.omg.CosNaming.BindingIteratorOperations 中的方法
此操作返回下一个绑定。
nextAfter(double, double) - 类 java.lang.Math 中的静态方法
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
nextAfter(float, double) - 类 java.lang.Math 中的静态方法
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
nextAfter(double, double) - 类 java.lang.StrictMath 中的静态方法
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
nextAfter(float, double) - 类 java.lang.StrictMath 中的静态方法
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
nextBigDecimal() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 BigDecimal。
nextBigInteger() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 BigInteger。
nextBigInteger(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 BigInteger。
nextBoolean() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的均匀分布的 boolean 值。
nextBoolean() - 类 java.util.Scanner 中的方法
扫描解释为一个布尔值的输入标记并返回该值。
nextByte() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 byte。
nextByte(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 byte。
nextBytes(byte[]) - 类 java.security.SecureRandom 中的方法
生成用户指定的随机字节数。
nextBytes(byte[]) - 类 java.util.Random 中的方法
生成随机字节并将其置于用户提供的 byte 数组中。
nextClearBit(int) - 类 java.util.BitSet 中的方法
返回第一个设置为 false 的位的索引，这发生在指定的起始索引或之后的索引上。
nextConflict() - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
将指针从其当前位置移动到下一个包含冲突值的行。
nextDouble(double) - 类 java.text.ChoiceFormat 中的静态方法
查找大于 d 的最小 double 值。
nextDouble(double, boolean) - 类 java.text.ChoiceFormat 中的静态方法
查找大于 d 的最小 double 值（如果 positive == true），或者小于 d 的最大值（如果 positive == false）。
nextDouble() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 double 值。
nextDouble() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 double。
nextElement() - 接口 java.util.Enumeration 中的方法
如果此枚举对象至少还有一个可提供的元素，则返回此枚举的下一个元素。
nextElement() - 类 java.util.StringTokenizer 中的方法
除了其声明返回值是 Object 而不是 String 之外，它返回与 nextToken 方法相同的值。
nextEvent() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
nextEvent() - 接口 javax.xml.stream.XMLEventReader 中的方法
获取下一个 XMLEvent。
nextFloat() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 float 值。
nextFloat() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 float。
nextFocus() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 transferFocus() 取代。
nextGaussian() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的、呈高斯（“正态”）分布的 double 值，其平均值是 0.0，标准差是 1.0。
nextIndex() - 接口 java.util.ListIterator 中的方法
返回对 next 的后续调用所返回元素的索引。
nextInt() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是此随机数生成器的序列中均匀分布的 int 值。
nextInt(int) - 类 java.util.Random 中的方法
返回一个伪随机数，它是取自此随机数生成器序列的、在 0（包括）和指定值（不包括）之间均匀分布的 int 值。
nextInt() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 int。
nextInt(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 int。
nextLayout(float) - 类 java.awt.font.LineBreakMeasurer 中的方法
返回下一个布局，并更新当前位置。
nextLayout(float, int, boolean) - 类 java.awt.font.LineBreakMeasurer 中的方法
返回下一个布局，并更新当前位置。
nextLine() - 类 java.util.Scanner 中的方法
此扫描器执行当前行，并返回跳过的输入信息。
nextLong() - 类 java.util.Random 中的方法
返回下一个伪随机数，它是取自此随机数生成器序列的均匀分布的 long 值。
nextLong() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 long。
nextLong(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 long。
nextOffset(float) - 类 java.awt.font.LineBreakMeasurer 中的方法
返回下一个布局结尾处的位置。
nextOffset(float, int, boolean) - 类 java.awt.font.LineBreakMeasurer 中的方法
返回下一个布局结尾处的位置。
nextPage() - 接口 javax.sql.rowset.CachedRowSet 中的方法
逐个增加 CachedRowSet 的当前页。
nextProbablePrime() - 类 java.math.BigInteger 中的方法
返回大于此 BigInteger 的可能为素数的第一个整数。
nextSetBit(int) - 类 java.util.BitSet 中的方法
返回第一个设置为 true 的位的索引，这发生在指定的起始索引或之后的索引上。
nextShort() - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 short。
nextShort(int) - 类 java.util.Scanner 中的方法
将输入信息的下一个标记扫描为一个 short。
nextTabStop(float, int) - 类 javax.swing.text.ParagraphView 中的方法
返回给定了参照位置的下一个制表符位位置。
nextTabStop(float, int) - 类 javax.swing.text.PlainView 中的方法
在给定引用位置之后，返回下一个制表符停靠位的位置。
nextTabStop(float, int) - 接口 javax.swing.text.TabExpander 中的方法
给定一个引用位置，返回下一个制表位 (tab stop) 位置。
nextTabStop(float, int) - 类 javax.swing.text.WrappedPlainView 中的方法
返回给定引用位置之后的下一个制表位位置。
nextTag() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
nextTag() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
nextTag() - 接口 javax.xml.stream.XMLEventReader 中的方法
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有无意义的空格事件。
nextTag() - 接口 javax.xml.stream.XMLStreamReader 中的方法
在到达 START_ELEMENT 或 END_ELEMENT 之前，跳过所有空格（isWhiteSpace() 返回 true）、COMMENT 或 PROCESSING_INSTRUCTION。
nextToken() - 类 java.io.StreamTokenizer 中的方法
从此标记生成器的输入流中解析下一个标记。
nextToken() - 类 java.util.StringTokenizer 中的方法
返回此 string tokenizer 的下一个标记。
nextToken(String) - 类 java.util.StringTokenizer 中的方法
返回此 string tokenizer 的字符串中的下一个标记。
nextUp(double) - 类 java.lang.Math 中的静态方法
返回 d 和正无穷大之间与 d 相邻的浮点值。
nextUp(float) - 类 java.lang.Math 中的静态方法
返回 f 和正无穷大之间与 f 相邻的浮点值。
nextUp(double) - 类 java.lang.StrictMath 中的静态方法
返回 d 和正无穷大之间与 d 相邻的浮点值。
nextUp(float) - 类 java.lang.StrictMath 中的静态方法
返回 f 和正无穷大之间与 f 相邻的浮点值。
nextWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到下一个字开头的 Action 名称。
nil - 类 javax.xml.bind.JAXBElement 中的变量
如果 xml 元素实例具有 xsi:nil="true" 属性，则 nil 为 true。
NMTOKEN - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NMTOKENS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NNTP - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
使用网络新闻传输协议 (NNTP) 的 USENET 新闻。
NO - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
NO 选项。
NO_COMPRESSION - 类 java.util.zip.Deflater 中的静态变量
无压缩的压缩级别。
NO_CONTEXT - 异常 org.ietf.jgss.GSSException 中的静态变量
无效的安全上下文。
NO_CRED - 异常 org.ietf.jgss.GSSException 中的静态变量
无效的凭据。
NO_DATA_ALLOWED_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果为不支持数据的 Node 指定数据。
NO_DECOMPOSITION - 类 java.text.Collator 中的静态变量
Decomposition 模式值。
NO_FIELDS - 类 java.io.ObjectStreamClass 中的静态变量
指示不存在可序列化字段的 serialPersistentFields 值。
NO_GENERATED_KEYS - 接口 java.sql.Statement 中的静态变量
该常量指示生成的键应该不可用于获取。
NO_HIGHLIGHT - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的静态变量
NO_IMPLEMENT - org.omg.CORBA 中的 异常
此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
NO_IMPLEMENT() - 异常 org.omg.CORBA.NO_IMPLEMENT 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(String) - 异常 org.omg.CORBA.NO_IMPLEMENT 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(int, CompletionStatus) - 异常 org.omg.CORBA.NO_IMPLEMENT 的构造方法
使用指定次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_IMPLEMENT(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_IMPLEMENT 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_IMPLEMENT 异常。
NO_IMPLICIT_ACTIVATION - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态变量
NO_MEMORY - org.omg.CORBA 中的 异常
如果 ORB 运行时出现内存不足，则抛出此异常。
NO_MEMORY() - 异常 org.omg.CORBA.NO_MEMORY 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_MEMORY 异常。
NO_MEMORY(String) - 异常 org.omg.CORBA.NO_MEMORY 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_MEMORY 异常。
NO_MEMORY(int, CompletionStatus) - 异常 org.omg.CORBA.NO_MEMORY 的构造方法
使用指定次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_MEMORY(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_MEMORY 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_MEMORY 异常。
NO_MODIFICATION_ALLOWED_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图在不允许修改的位置修改对象。
NO_MORE_EVENTS - 类 javax.print.event.PrintJobEvent 中的静态变量
并非所有的打印服务都能够提供所需的事件，甚至无法通知作业何时完成。
NO_OPTION - 类 javax.swing.JOptionPane 中的静态变量
选择 NO 时从类方法返回的值。
NO_ORIENTATION - 接口 java.awt.Adjustable 中的静态变量
指示 Adjustable 不具有方向。
NO_PERMISSION - org.omg.CORBA 中的 异常
当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
NO_PERMISSION() - 异常 org.omg.CORBA.NO_PERMISSION 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_PERMISSION 异常。
NO_PERMISSION(String) - 异常 org.omg.CORBA.NO_PERMISSION 的构造方法
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_PERMISSION 异常。
NO_PERMISSION(int, CompletionStatus) - 异常 org.omg.CORBA.NO_PERMISSION 的构造方法
使用指定次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_PERMISSION(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_PERMISSION 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_PERMISSION 异常。
NO_PROXY - 类 java.net.Proxy 中的静态变量
表示 DIRECT 连接的代理设置，主要通知协议处理程序不使用任何代理。
NO_RESOURCES - org.omg.CORBA 中的 异常
当 ORB 遇到一些一般资源限制时，抛出此异常。
NO_RESOURCES() - 异常 org.omg.CORBA.NO_RESOURCES 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_RESOURCES 异常。
NO_RESOURCES(String) - 异常 org.omg.CORBA.NO_RESOURCES 的构造方法
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESOURCES 异常。
NO_RESOURCES(int, CompletionStatus) - 异常 org.omg.CORBA.NO_RESOURCES 的构造方法
使用指定次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESOURCES(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_RESOURCES 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_RESOURCES 异常。
NO_RESPONSE - org.omg.CORBA 中的 异常
如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
NO_RESPONSE() - 异常 org.omg.CORBA.NO_RESPONSE 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 NO_RESPONSE 异常。
NO_RESPONSE(String) - 异常 org.omg.CORBA.NO_RESPONSE 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESPONSE 异常。
NO_RESPONSE(int, CompletionStatus) - 异常 org.omg.CORBA.NO_RESPONSE 的构造方法
使用指定次要代码和完成状态构造一个 NO_RESPONSE 异常。
NO_RESPONSE(String, int, CompletionStatus) - 异常 org.omg.CORBA.NO_RESPONSE 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 NO_RESPONSE 异常。
NO_ROLE_WITH_NAME - 类 javax.management.relation.RoleStatus 中的静态变量
试图访问未知角色时的问题类型。
NO_ROW_CONFLICT - 接口 javax.sql.rowset.spi.SyncResolver 中的静态变量
指示在 RowSet 对象试图更新、删除或插入数据源中的行时不发生任何冲突。
NO_SUCH_PAGE - 接口 java.awt.print.Printable 中的静态变量
从 print 返回，表示 pageIndex 太大以及请求的页面不存在。
NO_SYNC - 类 javax.sound.midi.Sequencer.SyncMode 中的静态变量
辅同步模式，指示不应向接收者发送任何计时信息。
nobject - 类 org.omg.CosNaming.BindingType 中的静态变量
NOBUTTON - 类 java.awt.event.MouseEvent 中的静态变量
指示没有鼠标按键，由 MouseEvent.getButton() 使用。
NoClassDefFoundError - java.lang 中的 错误
当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
NoClassDefFoundError() - 错误 java.lang.NoClassDefFoundError 的构造方法
构造不带详细消息的 NoClassDefFoundError。
NoClassDefFoundError(String) - 错误 java.lang.NoClassDefFoundError 的构造方法
构造带指定详细消息的 NoClassDefFoundError。
NoConnectionPendingException - java.nio.channels 中的 异常
在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
NoConnectionPendingException() - 异常 java.nio.channels.NoConnectionPendingException 的构造方法
构造此类的一个实例。
NoContext - org.omg.PortableServer.CurrentPackage 中的 异常
org/omg/PortableServer/CurrentPackage/NoContext.java。
NoContext() - 异常 org.omg.PortableServer.CurrentPackage.NoContext 的构造方法
NoContext(String) - 异常 org.omg.PortableServer.CurrentPackage.NoContext 的构造方法
NoContextHelper - org.omg.PortableServer.CurrentPackage 中的 类
org/omg/PortableServer/CurrentPackage/NoContextHelper.java。
NoContextHelper() - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 的构造方法
node(String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.node(String) 中的规范实现 node 方法。
node(String) - 类 java.util.prefs.Preferences 中的方法
将指定首选项节点返回到此节点所在的同一树中，如果此节点及其祖先已经不存在，则创建它们。
node() - 类 java.util.UUID 中的方法
与此 UUID 相关的节点值。
Node - javax.xml.soap 中的 接口
XML 文档中节点（元素）的表示形式。
NODE - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 NodeSet 数据类型。
Node - org.w3c.dom 中的 接口
该 Node 接口是整个文档对象模型的主要数据类型。
NODE_ADOPTED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
使用 Document.adoptNode() 采用节点。
NODE_CLONED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
使用 Node.cloneNode() 克隆节点。
NODE_DELETED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
删除节点。
NODE_IMPORTED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
使用 Document.importNode() 导入节点。
NODE_RENAMED - 接口 org.w3c.dom.UserDataHandler 中的静态变量
使用 Document.renameNode() 重命名节点。
nodeChanged(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
更改节点在树中的表示方式之后，调用此方法。
NodeChangeEvent - java.util.prefs 中的 类
Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。
NodeChangeEvent(Preferences, Preferences) - 类 java.util.prefs.NodeChangeEvent 的构造方法
构造新的 NodeChangeEvent 实例。
NodeChangeListener - java.util.prefs 中的 接口
用于接收首选项节点更改事件的侦听器。
nodeDimensions - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
负责告知 TreeState 节点所需的大小。
nodeDimensions - 类 javax.swing.tree.AbstractLayoutCache 中的变量
负责获取节点大小的对象。
nodeExists(String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.nodeExists(String) 中的规范实现 nodeExists 方法。
nodeExists(String) - 类 java.util.prefs.Preferences 中的方法
如果此节点所在的树中存在指定首选项节点，则返回 true。
NodeList - org.w3c.dom 中的 接口
NodeList 接口提供对节点的有序集合的抽象，没有定义或约束如何实现此集合。
nodesChanged(TreeNode, int[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
更改由 childIndicies 标识的子对象在树中的表示方式之后，调用此方法。
NODESET - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 NodeSet 数据类型。
NodeSetData - javax.xml.crypto 中的 接口
包含节点集的 Data 类型的抽象表示。
nodeStructureChanged(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
如果完全更改了节点的子节点、子节点的子节点、依此类推，则调用此方法。
nodesWereInserted(TreeNode, int[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
将某些 TreeNodes 插入节点之后，调用此方法。
nodesWereRemoved(TreeNode, int[], Object[]) - 类 javax.swing.tree.DefaultTreeModel 中的方法
从节点移除一些 TreeNodes 之后，调用此方法。
noFocusBorder - 类 javax.swing.DefaultListCellRenderer 中的静态变量
一个空 Border。
noFocusBorder - 类 javax.swing.plaf.basic.BasicComboBoxRenderer 中的静态变量
空 Border。
noFocusBorder - 类 javax.swing.table.DefaultTableCellRenderer 中的静态变量
一个空 Border。
NOFRAMES - 类 javax.swing.text.html.HTML.Tag 中的静态变量
NOHREF - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
NoInitialContextException - javax.naming 中的 异常
当不能创建任何初始上下文实现时，抛出此异常。
NoInitialContextException() - 异常 javax.naming.NoInitialContextException 的构造方法
构造一个 NoInitialContextException 实例。
NoInitialContextException(String) - 异常 javax.naming.NoInitialContextException 的构造方法
使用解释构造一个 NoInitialContextException 实例。
NON_CONTINUOUS_DIVIDER - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的静态变量
用于非连续布局的分隔符通过此对象添加到拆分窗格。
non_existent(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
确定对象引用的服务器对象是否已经被销毁。
NON_EXISTENT - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/NON_EXISTENT.java。
non_existent(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此操作用来检查 Object 是否存在。
NON_RETAIN - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态变量
NON_SPACING_MARK - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Mn”。
nonContinuousLayoutDivider - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
使用非连续布局时分隔符阴影的实例。
NONCRITICAL - 接口 javax.naming.ldap.Control 中的静态变量
指示非关键控件。
NONE - 类 java.awt.GridBagConstraints 中的静态变量
不重新调整组件大小。
NONE - 类 java.awt.JobAttributes.DialogType 中的静态变量
用于指定无打印对话框的 DialogType 实例。
NONE - 类 javax.print.attribute.standard.Compression 中的静态变量
不使用压缩。
NONE - 类 javax.print.attribute.standard.Finishings 中的静态变量
不执行绑定。
NONE - 类 javax.print.attribute.standard.JobSheets 中的静态变量
不打印作业页。
NONE - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
NONE - 类 javax.swing.TransferHandler 中的静态变量
表示无传输动作的 int 值。
NONE_OPTION - 类 javax.swing.DebugGraphics 中的静态变量
不要调试图形操作。
noneOf(Class<E>) - 类 java.util.EnumSet 中的静态方法
创建一个具有指定元素类型的空枚举 set。
NoninvertibleTransformException - java.awt.geom 中的 异常
NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。
NoninvertibleTransformException(String) - 异常 java.awt.geom.NoninvertibleTransformException 的构造方法
构造具有指定详细消息的 NoninvertibleTransformException 的实例。
NonReadableChannelException - java.nio.channels 中的 异常
试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
NonReadableChannelException() - 异常 java.nio.channels.NonReadableChannelException 的构造方法
构造此类的一个实例。
NONUPDATABLE_VIEW_SYNC - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示 SyncProvider 实现不支持 RowSet 对象和用于填充它的 SQL VIEW 之间的同步。
NonWritableChannelException - java.nio.channels 中的 异常
试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
NonWritableChannelException() - 异常 java.nio.channels.NonWritableChannelException 的构造方法
构造此类的一个实例。
NoPermissionException - javax.naming 中的 异常
当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
NoPermissionException(String) - 异常 javax.naming.NoPermissionException 的构造方法
使用解释构造一个新的 NoPermissionException 实例。
NoPermissionException() - 异常 javax.naming.NoPermissionException 的构造方法
构造一个新的 NoPermissionException 实例。
NOPOS - 接口 javax.tools.Diagnostic 中的静态变量
用于指示没有可用的位置。
NORESIZE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
NORM_PRIORITY - 类 java.lang.Thread 中的静态变量
分配给线程的默认优先级。
NORMAL - 类 java.awt.Frame 中的静态变量
窗体处于 "normal" 状态。
NORMAL - 类 java.awt.PageAttributes.PrintQualityType 中的静态变量
用于指定标准打印质量的 PrintQualityType 实例。
NORMAL - 类 javax.print.attribute.standard.PrintQuality 中的静态变量
打印机上的正常或中等质量。
normalize() - 类 java.net.URI 中的方法
规范化此 URI 的路径。
normalize(CharSequence, Normalizer.Form) - 类 java.text.Normalizer 中的静态方法
标准化 char 值序列。
normalize() - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
不执行任何操作，因为 IIOMetadataNode 不包含 Text 子节点。
normalize() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此实例标准化为 UTC。
normalize() - 接口 org.w3c.dom.Node 中的方法
将此 Node 之下完整的深层子树中所有 Text 节点（包括属性节点）放入只有结构（如元素、注释、处理指令、CDATA 节和实体引用）分隔 Text 节点的“常规”形式，也就是说，既没有相邻的 Text 节点，也没有空 Text 节点。
normalizeDocument() - 接口 org.w3c.dom.Document 中的方法
此方法的行为如同使文档通过一个保存和加载的过程，而将其置为 "normal（标准）" 形式。
NormalizedStringAdapter - javax.xml.bind.annotation.adapters 中的 类
处理 xs:normalizedString 的 XmlAdapter。
NormalizedStringAdapter() - 类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 的构造方法
normalizeMimeType(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
已过时。
normalizeMimeType(String) - 类 javax.activation.ActivationDataFlavor 中的方法
已过时。
normalizeMimeTypeParameter(String, String) - 类 java.awt.datatransfer.DataFlavor 中的方法
已过时。
normalizeMimeTypeParameter(String, String) - 类 javax.activation.ActivationDataFlavor 中的方法
已过时。
Normalizer - java.text 中的 类
此类提供 normalize 方法，它把 Unicode 文本转换为等效的组合或分解形式，允许对文本进行更方便地分类和搜索。
Normalizer.Form - java.text 中的 枚举
此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。
normalizeTabRuns(int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
normalizeTabRuns(int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 中的方法
normalizeWith(Calendar) - 类 javax.xml.datatype.Duration 中的方法
通过使用特定的时间点作为参考点，将 years 和 months 字段转换为 days 字段。
NoRouteToHostException - java.net 中的 异常
试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
NoRouteToHostException(String) - 异常 java.net.NoRouteToHostException 的构造方法
构造一个新的 NoRouteToHostException，使其具有关于无法到达远程主机的原因的指定详细消息。
NoRouteToHostException() - 异常 java.net.NoRouteToHostException 的构造方法
构造不带详细信息的新 NoRouteToHostException。
NORTH - 类 java.awt.BorderLayout 中的静态变量
北区域的布局约束（容器顶部）。
NORTH - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的顶部，并在水平方向上居中。
NORTH - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的顶边。
NORTH - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向北（上）。
NORTH_EAST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向东北（右上）。
NORTH_WEST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向西北（左上）。
NORTHEAST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的右上角。
northPane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
NORTHWEST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的左上角。
NoServant - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/NoServant.java。
NoServant() - 异常 org.omg.PortableServer.POAPackage.NoServant 的构造方法
NoServant(String) - 异常 org.omg.PortableServer.POAPackage.NoServant 的构造方法
NoServantHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/NoServantHelper.java。
NoServantHelper() - 类 org.omg.PortableServer.POAPackage.NoServantHelper 的构造方法
NOSHADE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
NoSuchAlgorithmException - java.security 中的 异常
当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchAlgorithmException() - 异常 java.security.NoSuchAlgorithmException 的构造方法
构造不带详细消息的 NoSuchAlgorithmException。
NoSuchAlgorithmException(String) - 异常 java.security.NoSuchAlgorithmException 的构造方法
构造带指定详细消息的 NoSuchAlgorithmException。
NoSuchAlgorithmException(String, Throwable) - 异常 java.security.NoSuchAlgorithmException 的构造方法
创建带指定详细消息和 cause 的 NoSuchAlgorithmException。
NoSuchAlgorithmException(Throwable) - 异常 java.security.NoSuchAlgorithmException 的构造方法
创建带指定 cause 和详细消息的 NoSuchAlgorithmException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
NoSuchAttributeException - javax.naming.directory 中的 异常
尝试访问不存在的属性时，抛出此异常。
NoSuchAttributeException(String) - 异常 javax.naming.directory.NoSuchAttributeException 的构造方法
使用解释构造一个新的 NoSuchAttributeException 实例。
NoSuchAttributeException() - 异常 javax.naming.directory.NoSuchAttributeException 的构造方法
构造一个新的 NoSuchAttributeException 实例。
NoSuchElementException - java.util 中的 异常
由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
NoSuchElementException() - 异常 java.util.NoSuchElementException 的构造方法
构造一个 NoSuchElementException，用 null 作为其错误消息字符串。
NoSuchElementException(String) - 异常 java.util.NoSuchElementException 的构造方法
构造一个 NoSuchElementException，保存对错误消息字符串 s 的引用，以便将来通过 getMessage 方法进行获取。
NoSuchFieldError - java.lang 中的 错误
如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
NoSuchFieldError() - 错误 java.lang.NoSuchFieldError 的构造方法
构造不带详细消息的 NoSuchFieldException。
NoSuchFieldError(String) - 错误 java.lang.NoSuchFieldError 的构造方法
构造带指定详细消息的 NoSuchFieldException。
NoSuchFieldException - java.lang 中的 异常
类不包含指定名称的字段时产生的信号。
NoSuchFieldException() - 异常 java.lang.NoSuchFieldException 的构造方法
构造方法。
NoSuchFieldException(String) - 异常 java.lang.NoSuchFieldException 的构造方法
带有详细消息的构造方法。
NoSuchMechanismException - javax.xml.crypto 中的 异常
当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
NoSuchMechanismException() - 异常 javax.xml.crypto.NoSuchMechanismException 的构造方法
构造使用 null 作为其详细消息的新 NoSuchMechanismException。
NoSuchMechanismException(String) - 异常 javax.xml.crypto.NoSuchMechanismException 的构造方法
构造带指定详细消息的新 NoSuchMechanismException。
NoSuchMechanismException(String, Throwable) - 异常 javax.xml.crypto.NoSuchMechanismException 的构造方法
构造带指定详细消息和 cause 的新 NoSuchMechanismException。
NoSuchMechanismException(Throwable) - 异常 javax.xml.crypto.NoSuchMechanismException 的构造方法
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 NoSuchMechanismException（它通常包含 cause 的类和详细消息）。
NoSuchMethodError - java.lang 中的 错误
当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
NoSuchMethodError() - 错误 java.lang.NoSuchMethodError 的构造方法
构造不带详细消息的 NoSuchMethodError。
NoSuchMethodError(String) - 错误 java.lang.NoSuchMethodError 的构造方法
构造带指定详细消息的 NoSuchMethodError。
NoSuchMethodException - java.lang 中的 异常
无法找到某一特定方法时，抛出该异常。
NoSuchMethodException() - 异常 java.lang.NoSuchMethodException 的构造方法
构造不带详细消息的 NoSuchMethodException。
NoSuchMethodException(String) - 异常 java.lang.NoSuchMethodException 的构造方法
构造带指定详细消息的 NoSuchMethodException。
NoSuchObjectException - java.rmi 中的 异常
如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
NoSuchObjectException(String) - 异常 java.rmi.NoSuchObjectException 的构造方法
构造带指定详细消息的 NoSuchObjectException。
NoSuchPaddingException - javax.crypto 中的 异常
当请求特定填充机制但该环境中未提供时，抛出此异常。
NoSuchPaddingException() - 异常 javax.crypto.NoSuchPaddingException 的构造方法
构造不带详细消息的 NoSuchPaddingException。
NoSuchPaddingException(String) - 异常 javax.crypto.NoSuchPaddingException 的构造方法
构造带指定详细消息的 NoSuchPaddingException。
NoSuchProviderException - java.security 中的 异常
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
NoSuchProviderException() - 异常 java.security.NoSuchProviderException 的构造方法
构造不带详细消息的 NoSuchProviderException。
NoSuchProviderException(String) - 异常 java.security.NoSuchProviderException 的构造方法
构造带指定详细消息的 NoSuchProviderException。
not() - 类 java.math.BigInteger 中的方法
返回其值为 (~this) 的 BigInteger。
not(QueryExp) - 类 javax.management.Query 中的静态方法
返回一个与其参数相反的约束条件。
NOT_ACCEPTING_JOBS - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 中的静态变量
打印机当前拒绝发送给它的任何作业。
NOT_ATTEMPTED - 类 javax.print.attribute.standard.PDLOverrideSupported 中的静态变量
打印机不会尝试让外部的作业属性值优先于嵌入到文档打印数据中的指令。
not_context - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
NOT_FOUND_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果试图在它不存在的上下文中引用 Node。
not_object - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
NOT_SPECIFIED - 类 javax.sound.sampled.AudioSystem 中的静态变量
代表未知数字值的整数。
NOT_SUPPORTED - 类 javax.print.attribute.standard.ColorSupported 中的静态变量
该打印机不能进行任何类型的彩色打印。
NOT_SUPPORTED_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果实现不支持请求类型的对象或操作。
NotActiveException - java.io 中的 异常
当序列化和反序列化不活动时，抛出此异常。
NotActiveException(String) - 异常 java.io.NotActiveException 的构造方法
创建带给定原因的新 NotActiveException 的构造方法。
NotActiveException() - 异常 java.io.NotActiveException 的构造方法
创建不带原因的新 NotActiveException 的构造方法。
NOTATION - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Notation - org.w3c.dom 中的 接口
此接口表示在 DTD 中声明的表示法。
NOTATION_DECLARATION - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示一个 Notation
NOTATION_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Notation。
notationDecl(String, String, String) - 接口 org.xml.sax.DTDHandler 中的方法
接收注释声明事件的通知。
notationDecl(String, String, String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收注释声明的通知。
notationDecl(String, String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收注释声明的通知。
notationDecl(String, String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个注释声明事件。
NotationDeclaration - javax.xml.stream.events 中的 接口
处理注释声明的接口。
NotBoundException - java.rmi 中的 异常
如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
NotBoundException() - 异常 java.rmi.NotBoundException 的构造方法
构造不带指定详细消息的 NotBoundException。
NotBoundException(String) - 异常 java.rmi.NotBoundException 的构造方法
构造带指定详细消息的 NotBoundException。
NotCompliantMBeanException - javax.management 中的 异常
尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
NotCompliantMBeanException() - 异常 javax.management.NotCompliantMBeanException 的构造方法
默认的构造方法。
NotCompliantMBeanException(String) - 异常 javax.management.NotCompliantMBeanException 的构造方法
允许指定具体错误消息的构造方法。
NotContextException - javax.naming 中的 异常
当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
NotContextException(String) - 异常 javax.naming.NotContextException 的构造方法
使用解释构造一个新的 NotContextException 实例。
NotContextException() - 异常 javax.naming.NotContextException 的构造方法
构造一个新的 NotContextException 实例。
NOTE - 类 java.awt.PageAttributes.MediaType 中的静态变量
NA_LETTER 的别名。
note - 类 javax.sound.midi.VoiceStatus 中的变量
此声音正在演奏的 MIDI 音符。
NOTE_OFF - 类 javax.sound.midi.ShortMessage 中的静态变量
NOTE_OFF 消息的命令值（0x80 或 128）
NOTE_ON - 类 javax.sound.midi.ShortMessage 中的静态变量
NOTE_ON 消息的命令值（0x90 或 144）
NotEmpty - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
NotEmpty() - 异常 org.omg.CosNaming.NamingContextPackage.NotEmpty 的构造方法
NotEmpty(String) - 异常 org.omg.CosNaming.NamingContextPackage.NotEmpty 的构造方法
NotEmptyHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java。
NotEmptyHelper() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 的构造方法
NotEmptyHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java。
NotEmptyHolder() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 的构造方法
NotEmptyHolder(NotEmpty) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 的构造方法
noteOff(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
关闭指定的音符。
noteOff(int) - 接口 javax.sound.midi.MidiChannel 中的方法
关闭指定的音符。
noteOn(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
启动指定的音符发出声音。
notFilter(RowFilter<M, I>) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含提供的过滤器不包含的条目。
NotFound - org.omg.CosNaming.NamingContextPackage 中的 异常
org/omg/CosNaming/NamingContextPackage/NotFound.java。
NotFound() - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 的构造方法
NotFound(NotFoundReason, NameComponent[]) - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 的构造方法
NotFound(String, NotFoundReason, NameComponent[]) - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 的构造方法
NotFoundHelper - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java。
NotFoundHelper() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 的构造方法
NotFoundHolder - org.omg.CosNaming.NamingContextPackage 中的 类
org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java。
NotFoundHolder() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 的构造方法
NotFoundHolder(NotFound) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 的构造方法
NotFoundReason - org.omg.CosNaming.NamingContextPackage 中的 类
指示未能解析的原因。
NotFoundReason(int) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 的构造方法
NotFoundReasonHelper - org.omg.CosNaming.NamingContextPackage 中的 类
指示未能解析的原因。
NotFoundReasonHelper() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 的构造方法
NotFoundReasonHolder - org.omg.CosNaming.NamingContextPackage 中的 类
指示未能解析的原因。
NotFoundReasonHolder() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 的构造方法
NotFoundReasonHolder(NotFoundReason) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 的构造方法
NotIdentifiableEvent - javax.xml.bind 中的 接口
此事件指示解析 ID/IDREF 时遇到一个问题。
NotIdentifiableEventImpl - javax.xml.bind.helpers 中的 类
NotIdentifiableEvent 接口的默认实现。
NotIdentifiableEventImpl(int, String, ValidationEventLocator) - 类 javax.xml.bind.helpers.NotIdentifiableEventImpl 的构造方法
创建新的 NotIdentifiableEventImpl。
NotIdentifiableEventImpl(int, String, ValidationEventLocator, Throwable) - 类 javax.xml.bind.helpers.NotIdentifiableEventImpl 的构造方法
创建新的 NotIdentifiableEventImpl。
Notification - javax.management 中的 类
Notification 类表示 MBean 所发出的通知。
Notification(String, Object, long) - 类 javax.management.Notification 的构造方法
创建一个 Notification 对象。
Notification(String, Object, long, String) - 类 javax.management.Notification 的构造方法
创建一个 Notification 对象。
Notification(String, Object, long, long) - 类 javax.management.Notification 的构造方法
创建一个 Notification 对象。
Notification(String, Object, long, long, String) - 类 javax.management.Notification 的构造方法
创建一个 Notification 对象。
NotificationBroadcaster - javax.management 中的 接口
由发出 Notifications 的 MBean 实现的接口。
NotificationBroadcasterSupport - javax.management 中的 类
提供 NotificationEmitter 接口的实现。
NotificationBroadcasterSupport() - 类 javax.management.NotificationBroadcasterSupport 的构造方法
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都由发送通知的线程调用。
NotificationBroadcasterSupport(Executor) - 类 javax.management.NotificationBroadcasterSupport 的构造方法
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationBroadcasterSupport(MBeanNotificationInfo...) - 类 javax.management.NotificationBroadcasterSupport 的构造方法
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport。
NotificationBroadcasterSupport(Executor, MBeanNotificationInfo...) - 类 javax.management.NotificationBroadcasterSupport 的构造方法
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationEmitter - javax.management 中的 接口
由发出 Notifications 的 MBean 实现的接口。
NotificationFilter - javax.management 中的 接口
可由作为通知过滤器的任何类来实现。
NotificationFilterSupport - javax.management 中的 类
提供 NotificationFilter 接口的实现。
NotificationFilterSupport() - 类 javax.management.NotificationFilterSupport 的构造方法
NotificationListener - javax.management 中的 接口
应该由想要接收通知的对象来实现。
notificationReceived(UnsolicitedNotificationEvent) - 接口 javax.naming.ldap.UnsolicitedNotificationListener 中的方法
当收到了未经请求的通知时调用。
NotificationResult - javax.management.remote 中的 类
缓存的通知的查询结果。
NotificationResult(long, long, TargetedNotification[]) - 类 javax.management.remote.NotificationResult 的构造方法
构造一个通知查询结果。
notifier - 类 java.awt.event.InvocationEvent 中的变量
在 Runnable.run() 方法返回之后立即调用其 notifyAll() 方法的对象（可能为 null）。
NOTIFS_LOST - 类 javax.management.remote.JMXConnectionNotification 中的静态变量
可能已丢失通知的连接的通知类型字符串。
notify() - 类 java.lang.Object 中的方法
唤醒在此对象监视器上等待的单个线程。
notifyAction - 类 javax.swing.JTextField 中的静态变量
发送通知（已接收字段内容）的动作名称。
notifyAction(Action, KeyStroke, KeyEvent, Object, int) - 类 javax.swing.SwingUtilities 中的静态方法
如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
notifyAll() - 类 java.lang.Object 中的方法
唤醒在此对象监视器上等待的所有线程。
notifyClientWindowChange(Rectangle) - 接口 java.awt.im.spi.InputMethod 中的方法
通知此输入方法客户端窗口位置或状态的更改。
notifyCursorMoved() - 类 javax.sql.rowset.BaseRowSet 中的方法
通知向此 RowSet 对象注册的所有侦听器其光标已移动。
notifyObservers() - 类 java.util.Observable 中的方法
如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。
notifyObservers(Object) - 类 java.util.Observable 中的方法
如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。
notifyPathChange(Vector<PathPlaceHolder>, TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
通知侦听器路径中的更改。
notifyRowChanged() - 类 javax.sql.rowset.BaseRowSet 中的方法
通知向此 RowSet 对象注册的所有侦听器其行已更改。
notifyRowSetChanged() - 类 javax.sql.rowset.BaseRowSet 中的方法
通知向此 RowSet 对象注册的所有侦听器其整个内容已更改。
NotOwnerException - java.security.acl 中的 异常
当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。
NotOwnerException() - 异常 java.security.acl.NotOwnerException 的构造方法
构造一个 NotOwnerException。
notSelectedTextColor - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
notSelectedTitleColor - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
NotSerializableException - java.io 中的 异常
当实例需要具有序列化接口时，抛出此异常。
NotSerializableException(String) - 异常 java.io.NotSerializableException 的构造方法
构造带消息字符串的 NotSerializableException 对象。
NotSerializableException() - 异常 java.io.NotSerializableException 的构造方法
构造一个 NotSerializableException 对象。
NotYetBoundException - java.nio.channels 中的 异常
试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
NotYetBoundException() - 异常 java.nio.channels.NotYetBoundException 的构造方法
构造此类的一个实例。
NotYetConnectedException - java.nio.channels 中的 异常
试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
NotYetConnectedException() - 异常 java.nio.channels.NotYetConnectedException 的构造方法
构造此类的一个实例。
NoType - javax.lang.model.type 中的 接口
在实际类型不适合的地方使用的伪类型。
NOVEMBER - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第十一个月的 Calendar.MONTH 字段值。
NOVEMBER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第十一个月的值。
NOWRAP - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
npoints - 类 java.awt.Polygon 中的变量
点的总数。
NSDECL - 类 org.xml.sax.helpers.NamespaceSupport 中的静态变量
作为常量的名称空间声明 URI。
NT_ANONYMOUS - 接口 org.ietf.jgss.GSSName 中的静态变量
表示匿名实体的名称类型。
NT_EXPORT_NAME - 接口 org.ietf.jgss.GSSName 中的静态变量
用来表示通过导出方法产生的导出名称的名称类型。
NT_HOSTBASED_SERVICE - 接口 org.ietf.jgss.GSSName 中的静态变量
表示基于主机的服务名称格式的 Oid。
NT_MACHINE_UID_NAME - 接口 org.ietf.jgss.GSSName 中的静态变量
名称类型，表示与本地系统上的用户对应的数值型用户标识符。
NT_STRING_UID_NAME - 接口 org.ietf.jgss.GSSName 中的静态变量
名称类型，指示一个由数字组成的字符串，表示本地系统上用户的数值型用户标识符。
NT_USER_NAME - 接口 org.ietf.jgss.GSSName 中的静态变量
名称类型，表示在本地系统上指定的用户。
NULL - 类 java.sql.Types 中的静态变量
标识一般 SQL 值 NULL 的 Java 编程语言中的常量。
NULL_ATTRIBUTE_VALUE - 类 javax.swing.text.html.HTML 中的静态变量
NULL_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
用于表示不存在名称空间的名称空间 URI。
NullCipher - javax.crypto 中的 类
NullCipher 类是一个提供“标识密码”的类，其不转换纯文本。
NullCipher() - 类 javax.crypto.NullCipher 的构造方法
NULLORDER - 类 java.text.CollationElementIterator 中的静态变量
Null 顺序指示光标到达字符串末尾。
nullPlusNonNullIsNull() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 NULL 值与等于 NULL 的非 NULL 值之间的连接。
NullPointerException - java.lang 中的 异常
当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
NullPointerException() - 异常 java.lang.NullPointerException 的构造方法
构造不带详细消息的 NullPointerException。
NullPointerException(String) - 异常 java.lang.NullPointerException 的构造方法
构造带指定详细消息的 NullPointerException。
nullsAreSortedAtEnd() - 接口 java.sql.DatabaseMetaData 中的方法
获取 NULL 值是否始终排在末尾，不管排序顺序如何。
nullsAreSortedAtStart() - 接口 java.sql.DatabaseMetaData 中的方法
获取 NULL 值是否始终排在开头，不管排序顺序如何。
nullsAreSortedHigh() - 接口 java.sql.DatabaseMetaData 中的方法
获取 NULL 值是否被高排序。
nullsAreSortedLow() - 接口 java.sql.DatabaseMetaData 中的方法
获取 NULL 值是否被低排序。
NullType - javax.lang.model.type 中的 接口
表示 null 类型。
NUM_COLORS - 类 java.awt.SystemColor 中的静态变量
数组中系统颜色的数量。
NUM_LOCK - 类 java.awt.Event 中的静态变量
Num Lock 键，一个非 ASCII 操作键。
numBands - 类 java.awt.image.ComponentSampleModel 中的变量
此 ComponentSampleModel 中的 band 数量。
numBands - 类 java.awt.image.Raster 中的变量
Raster 中的 band 数。
numBands - 类 java.awt.image.SampleModel 中的变量
此 SampleModel 描述的图像数据的 band 数。
numBanks - 类 java.awt.image.ComponentSampleModel 中的变量
此 ComponentSampleModel 中的存储单元数量。
Number - java.lang 中的 类
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Number() - 类 java.lang.Number 的构造方法
NUMBER - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NUMBER - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 数字数据类型。
NUMBER_FORMS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Number Forms”Unicode 字符块的常量。
numberFilter(RowFilter.ComparisonType, Number, int...) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。
numberFormat - 类 java.text.DateFormat 中的变量
数字格式器，DateFormat 用其来格式化日期和时间中的数字。
NumberFormat - java.text 中的 类
NumberFormat 是所有数值格式的抽象基类。
NumberFormat() - 类 java.text.NumberFormat 的构造方法
唯一的构造方法。
NumberFormat.Field - java.text 中的 类
定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。
NumberFormat.Field(String) - 类 java.text.NumberFormat.Field 的构造方法
创建具有指定名称的 Field 实例。
NumberFormatException - java.lang 中的 异常
当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
NumberFormatException() - 异常 java.lang.NumberFormatException 的构造方法
构造不带详细消息的 NumberFormatException。
NumberFormatException(String) - 异常 java.lang.NumberFormatException 的构造方法
构造带指定详细消息的 NumberFormatException。
NumberFormatProvider - java.text.spi 中的 类
提供 NumberFormat 类具体实现的服务提供者的抽象类。
NumberFormatProvider() - 类 java.text.spi.NumberFormatProvider 的构造方法
唯一的构造方法。
NumberFormatter - javax.swing.text 中的 类
添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。
NumberFormatter() - 类 javax.swing.text.NumberFormatter 的构造方法
创建具有默认 NumberFormat 实例的 NumberFormatter，该实例通过 NumberFormat.getNumberInstance() 获得。
NumberFormatter(NumberFormat) - 类 javax.swing.text.NumberFormatter 的构造方法
创建具有指定 Format 实例的 NumberFormatter。
NumberOfDocuments - javax.print.attribute.standard 中的 类
NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
NumberOfDocuments(int) - 类 javax.print.attribute.standard.NumberOfDocuments 的构造方法
构造具有给定整数值的新 NumberOfDocuments 属性。
NumberOfInterveningJobs - javax.print.attribute.standard 中的 类
NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
NumberOfInterveningJobs(int) - 类 javax.print.attribute.standard.NumberOfInterveningJobs 的构造方法
构造具有给定整数值的新的 NumberOfInterveningJobs 属性。
numberOfLeadingZeros(int) - 类 java.lang.Integer 中的静态方法
在指定 int 值的二进制补码表示形式中最高位（最左边）的 1 位之前，返回零位的数量。
numberOfLeadingZeros(long) - 类 java.lang.Long 中的静态方法
在指定 long 值的二进制补码表示形式中最高位（最左边）的 1 位之前，返回零位的数量。
numberOfTrailingZeros(int) - 类 java.lang.Integer 中的静态方法
返回指定的 int 值的二进制补码表示形式中最低（“最右边”）的为 1 的位后面的零位个数。
numberOfTrailingZeros(long) - 类 java.lang.Long 中的静态方法
返回在指定 long 值的二进制补码表示形式中最低位（最右边）的 1 位之后的零位的数量。
NUMBERS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NumberUp - javax.print.attribute.standard 中的 类
NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
NumberUp(int) - 类 javax.print.attribute.standard.NumberUp 的构造方法
构造具有给定整数值的新 NumberUp 属性。
NumberUpSupported - javax.print.attribute.standard 中的 类
NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
NumberUpSupported(int[][]) - 类 javax.print.attribute.standard.NumberUpSupported 的构造方法
构造具有给定成员的新的 NumberUpSupported 属性。
NumberUpSupported(int) - 类 javax.print.attribute.standard.NumberUpSupported 的构造方法
构造一个包含单个整数的新的 NumberUpSupported 属性。
NumberUpSupported(int, int) - 类 javax.print.attribute.standard.NumberUpSupported 的构造方法
构造一个包含单个整数范围的新的 NumberUpSupported 属性。
numBuffers - 类 java.awt.Component.FlipBufferStrategy 中的变量
缓冲区的数目。
numDataElements - 类 java.awt.image.Raster 中的变量
每个像素的 DataBuffer 数据元素数。
NUMERIC - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 NUMERIC 的 Java 编程语言中的常量（有时称为类型代码）。
NUMERIC_SHAPING - 类 java.awt.font.TextAttribute 中的静态变量
将 ASCII 十进制数字转换为其他十进制范围数字的属性键。
NumericShaper - java.awt.font 中的 类
NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。
numProgressivePasses - 类 javax.imageio.ImageReadParam 中的变量
从源中读取的逐步传递的最大数量。
NUTOKEN - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
NUTOKENS - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
nval - 类 java.io.StreamTokenizer 中的变量
如果当前标记是一个数字，则此字段将包含该数字的值。
NVARCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 NVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
NVList - org.omg.CORBA 中的 类
包含 NamedValue 对象所组成的可修改列表。
NVList() - 类 org.omg.CORBA.NVList 的构造方法
NW_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口左上角大小的光标类型。
NW_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.NW_RESIZE_CURSOR 取代。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


O - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

O

OAEPParameterSpec - javax.crypto.spec 中的 类
此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。
OAEPParameterSpec(String, String, AlgorithmParameterSpec, PSource) - 类 javax.crypto.spec.OAEPParameterSpec 的构造方法
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。
OBJ_ADAPTER - org.omg.CORBA 中的 异常
此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
OBJ_ADAPTER() - 异常 org.omg.CORBA.OBJ_ADAPTER 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(String) - 异常 org.omg.CORBA.OBJ_ADAPTER 的构造方法
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(int, CompletionStatus) - 异常 org.omg.CORBA.OBJ_ADAPTER 的构造方法
使用指定次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
OBJ_ADAPTER(String, int, CompletionStatus) - 异常 org.omg.CORBA.OBJ_ADAPTER 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 OBJ_ADAPTER 异常。
Object - java.lang 中的 类
类 Object 是类层次结构的根类。
Object() - 类 java.lang.Object 的构造方法
OBJECT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
object - 类 javax.swing.undo.StateEdit 中的变量
被编辑的对象
Object - org.omg.CORBA 中的 接口
CORBA 对象引用的定义。
OBJECT_ADDED - 类 javax.naming.event.NamingEvent 中的静态变量
指示已经添加了新对象的命名事件类型。
OBJECT_CHANGED - 类 javax.naming.event.NamingEvent 中的静态变量
指示已经更改了某个对象的命名事件类型。
OBJECT_FACTORIES - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定要使用的对象工厂列表的环境属性名称。
object_id() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回描述该操作调用目标的不透明 object_id。
object_id(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
方法 _object_id() 等效于调用 PortableServer::Current::get_object_id。
OBJECT_NOT_EXIST - org.omg.CORBA 中的 异常
只要在已删除的对象上执行调用，就会引发此异常。
OBJECT_NOT_EXIST() - 异常 org.omg.CORBA.OBJECT_NOT_EXIST 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和一个 null 描述构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(String) - 异常 org.omg.CORBA.OBJECT_NOT_EXIST 的构造方法
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(int, CompletionStatus) - 异常 org.omg.CORBA.OBJECT_NOT_EXIST 的构造方法
使用指定次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_NOT_EXIST(String, int, CompletionStatus) - 异常 org.omg.CORBA.OBJECT_NOT_EXIST 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。
OBJECT_REMOVED - 类 javax.naming.event.NamingEvent 中的静态变量
指示已经移除了某个对象的命名事件类型。
OBJECT_RENAMED - 类 javax.naming.event.NamingEvent 中的静态变量
指示已经重命名了某个对象的命名事件类型。
OBJECT_SCOPE - 类 javax.naming.directory.SearchControls 中的静态变量
搜索命名的对象。
OBJECT_SCOPE - 接口 javax.naming.event.EventContext 中的静态变量
该常量用来表示对涉及目标指定对象的事件感兴趣。
object_to_string(Object) - 类 org.omg.CORBA.ORB 中的方法
将给定 CORBA 对象引用转换为字符串。
objectAdded(NamingEvent) - 接口 javax.naming.event.NamespaceChangeListener 中的方法
在已经添加了对象时调用此方法。
ObjectAlreadyActive - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
ObjectAlreadyActive() - 异常 org.omg.PortableServer.POAPackage.ObjectAlreadyActive 的构造方法
ObjectAlreadyActive(String) - 异常 org.omg.PortableServer.POAPackage.ObjectAlreadyActive 的构造方法
ObjectAlreadyActiveHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java。
ObjectAlreadyActiveHelper() - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 的构造方法
objectChanged(NamingEvent) - 接口 javax.naming.event.ObjectChangeListener 中的方法
在已经更改了对象时调用此方法。
ObjectChangeListener - javax.naming.event 中的 接口
指定事件类型为 OBJECT_CHANGED 的 NamingEvent 侦听器必须实现的方法。
ObjectFactory - javax.naming.spi 中的 接口
此类表示用于创建对象的工厂。
ObjectFactoryBuilder - javax.naming.spi 中的 接口
此接口表示创建对象工厂的生成器。
ObjectHelper - org.omg.CORBA 中的 类
ObjectHelper() - 类 org.omg.CORBA.ObjectHelper 的构造方法
ObjectHolder - org.omg.CORBA 中的 类
Object 的 Holder。
ObjectHolder() - 类 org.omg.CORBA.ObjectHolder 的构造方法
构造一个新的 ObjectHolder 对象，将其 value 字段初始化为 null。
ObjectHolder(Object) - 类 org.omg.CORBA.ObjectHolder 的构造方法
构造一个新的 ObjectHolder 对象，并使用给定 Object 初始化其 value 字段。
ObjectIdHelper - org.omg.PortableInterceptor 中的 类
对象 id 类型。
ObjectIdHelper() - 类 org.omg.PortableInterceptor.ObjectIdHelper 的构造方法
ObjectIdHelper - org.omg.PortableInterceptor.ORBInitInfoPackage 中的 类
表示为一个 String 的 Object id
ObjectIdHelper() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 的构造方法
ObjectImpl - org.omg.CORBA.portable 中的 类
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。
ObjectImpl() - 类 org.omg.CORBA.portable.ObjectImpl 的构造方法
ObjectImpl - org.omg.CORBA_2_3.portable 中的 类
ObjectImpl 类是所有 stub 的基类。
ObjectImpl() - 类 org.omg.CORBA_2_3.portable.ObjectImpl 的构造方法
ObjectInput - java.io 中的 接口
ObjectInput 扩展 DataInput 接口以包含对象的读操作。
ObjectInputStream - java.io 中的 类
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
ObjectInputStream(InputStream) - 类 java.io.ObjectInputStream 的构造方法
创建从指定 InputStream 读取的 ObjectInputStream。
ObjectInputStream() - 类 java.io.ObjectInputStream 的构造方法
为完全重新实现 ObjectInputStream 的子类提供一种方式，让它不必分配仅由 ObjectInputStream 的实现使用的私有数据。
ObjectInputStream.GetField - java.io 中的 类
提供对从输入流读取的持久字段的访问权限。
ObjectInputStream.GetField() - 类 java.io.ObjectInputStream.GetField 的构造方法
ObjectInputValidation - java.io 中的 接口
允许验证图形中对象的回调接口。
ObjectInstance - javax.management 中的 类
用于表示 MBean 对象名及其类名。
ObjectInstance(String, String) - 类 javax.management.ObjectInstance 的构造方法
允许创建具有给定字符串表示形式的对象名和完整类名（包括包名）的ｏbjectInstance。
ObjectInstance(ObjectName, String) - 类 javax.management.ObjectInstance 的构造方法
允许创建具有给定对象名和完整类名（包括包名）的 ObjectInstance。
ObjectName - javax.management 中的 类
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
ObjectName(String) - 类 javax.management.ObjectName 的构造方法
根据给定的字符串构造一个对象名。
ObjectName(String, String, String) - 类 javax.management.ObjectName 的构造方法
构造只具有一个键属性的对象名。
ObjectName(String, Hashtable<String, String>) - 类 javax.management.ObjectName 的构造方法
构造一个对象名，它具有根据哈希表获得的多个键属性。
OBJECTNAME - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 javax.management.ObjectName 的值。
ObjectNotActive - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/ObjectNotActive.java。
ObjectNotActive() - 异常 org.omg.PortableServer.POAPackage.ObjectNotActive 的构造方法
ObjectNotActive(String) - 异常 org.omg.PortableServer.POAPackage.ObjectNotActive 的构造方法
ObjectNotActiveHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java。
ObjectNotActiveHelper() - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 的构造方法
ObjectOutput - java.io 中的 接口
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。
ObjectOutputStream - java.io 中的 类
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
ObjectOutputStream(OutputStream) - 类 java.io.ObjectOutputStream 的构造方法
创建写入指定 OutputStream 的 ObjectOutputStream。
ObjectOutputStream() - 类 java.io.ObjectOutputStream 的构造方法
为完全重新实现 ObjectOutputStream 的子类提供一种方法，让它不必分配仅由 ObjectOutputStream 的实现使用的私有数据。
ObjectOutputStream.PutField - java.io 中的 类
提供对要写入 ObjectOutput 的持久字段的编程访问。
ObjectOutputStream.PutField() - 类 java.io.ObjectOutputStream.PutField 的构造方法
ObjectReferenceFactory - org.omg.PortableInterceptor 中的 接口
对象引用工厂。
ObjectReferenceFactoryHelper - org.omg.PortableInterceptor 中的 类
对象引用工厂。
ObjectReferenceFactoryHelper() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 的构造方法
ObjectReferenceFactoryHolder - org.omg.PortableInterceptor 中的 类
对象引用工厂。
ObjectReferenceFactoryHolder() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 的构造方法
ObjectReferenceFactoryHolder(ObjectReferenceFactory) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 的构造方法
ObjectReferenceTemplate - org.omg.PortableInterceptor 中的 接口
对象引用模板。
ObjectReferenceTemplateHelper - org.omg.PortableInterceptor 中的 类
对象引用模板。
ObjectReferenceTemplateHelper() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 的构造方法
ObjectReferenceTemplateHolder - org.omg.PortableInterceptor 中的 类
对象引用模板。
ObjectReferenceTemplateHolder() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 的构造方法
ObjectReferenceTemplateHolder(ObjectReferenceTemplate) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 的构造方法
ObjectReferenceTemplateSeqHelper - org.omg.PortableInterceptor 中的 类
对象引用模板序列用来报告不发生在适配器管理器的状态更改。
ObjectReferenceTemplateSeqHelper() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 的构造方法
ObjectReferenceTemplateSeqHolder - org.omg.PortableInterceptor 中的 类
对象引用模板序列用来报告不发生在适配器管理器的状态更改。
ObjectReferenceTemplateSeqHolder() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 的构造方法
ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[]) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 的构造方法
objectRemoved(NamingEvent) - 接口 javax.naming.event.NamespaceChangeListener 中的方法
在已经移除了对象时调用此方法。
objectRenamed(NamingEvent) - 接口 javax.naming.event.NamespaceChangeListener 中的方法
在已经重命名了对象时调用此方法。
ObjectStreamClass - java.io 中的 类
类的序列化描述符。
ObjectStreamConstants - java.io 中的 接口
写入 Object Serialization Stream 的常量。
ObjectStreamException - java.io 中的 异常
特定于 Object Stream 类的所有异常的超类。
ObjectStreamException(String) - 异常 java.io.ObjectStreamException 的构造方法
创建具有指定参数的 ObjectStreamException。
ObjectStreamException() - 异常 java.io.ObjectStreamException 的构造方法
创建一个 ObjectStreamException。
ObjectStreamField - java.io 中的 类
Serializable 类中 Serializable 字段的描述。
ObjectStreamField(String, Class<?>) - 类 java.io.ObjectStreamField 的构造方法
创建具有指定类型的 Serializable 字段。
ObjectStreamField(String, Class<?>, boolean) - 类 java.io.ObjectStreamField 的构造方法
创建一个 ObjectStreamField，表示给定名称和类型的可序列化字段。
ObjectView - javax.swing.text.html 中的 类
实现 <object> 元素视图接口的组件装饰符。
ObjectView(Element) - 类 javax.swing.text.html.ObjectView 的构造方法
创建新的 ObjectView 对象。
ObjID - java.rmi.server 中的 类
ObjID 是用于标识导出到 RMI 运行时的远程对象。
ObjID() - 类 java.rmi.server.ObjID 的构造方法
生成唯一的对象标识符。
ObjID(int) - 类 java.rmi.server.ObjID 的构造方法
创建“已知的”对象标识符。
Observable - java.util 中的 类
此类表示模型视图范例中的 observable 对象，或者说“数据”。
Observable() - 类 java.util.Observable 的构造方法
构造一个带有零个观察者的 Observable。
OBSERVED_ATTRIBUTE_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性未包含在被观察对象中的通知类型。
OBSERVED_ATTRIBUTE_ERROR_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
表示已在更改被观察属性之后发出了通知的标志。
OBSERVED_ATTRIBUTE_TYPE_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性的类型不正确的通知类型。
OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
表示已在更改被观察对象或被观察属性之后发出了通知的标志。
OBSERVED_OBJECT_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察对象未在 MBean 服务器中注册的通知类型。
OBSERVED_OBJECT_ERROR_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
表示在更改被观察对象之后已发出通知的标志。
Observer - java.util 中的 接口
一个可在观察者要得到 observable 对象更改通知时可实现 Observer 接口的类。
OceanTheme - javax.swing.plaf.metal 中的 类
MetalLookAndFeel 的默认主题。
OceanTheme() - 类 javax.swing.plaf.metal.OceanTheme 的构造方法
创建一个 OceanTheme 实例
OctetSeqHelper - org.omg.CORBA 中的 类
OctetSeq 的 Helper。
OctetSeqHelper() - 类 org.omg.CORBA.OctetSeqHelper 的构造方法
OctetSeqHolder - org.omg.CORBA 中的 类
OctetSeq 的 Holder。
OctetSeqHolder() - 类 org.omg.CORBA.OctetSeqHolder 的构造方法
OctetSeqHolder(byte[]) - 类 org.omg.CORBA.OctetSeqHolder 的构造方法
OctetStreamData - javax.xml.crypto 中的 类
包含一个八位组流的 Data 类型的表示形式。
OctetStreamData(InputStream) - 类 javax.xml.crypto.OctetStreamData 的构造方法
创建新的 SocketImpl。
OctetStreamData(InputStream, String, String) - 类 javax.xml.crypto.OctetStreamData 的构造方法
创建新的 OctetStreamData。
OCTOBER - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第十个月的 Calendar.MONTH 字段值。
OCTOBER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第十个月的值。
oEnd - 类 javax.swing.text.html.parser.Element 中的变量
of(char) - 类 java.lang.Character.UnicodeBlock 中的静态方法
返回表示包含给定字符的 Unicode 块的对象；如果该字符不是某个定义块的成员，则返回 null。
of(int) - 类 java.lang.Character.UnicodeBlock 中的静态方法
返回表示包含给定字符（Unicode 代码点）的 Unicode 块的对象；如果该字符不是定义块的成员，则返回 null。
of(E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E, E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E, E, E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(E, E...) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含指定元素的枚举 set。
of(String, String) - 类 javax.annotation.processing.Completions 中的静态方法
返回值和消息的 completion。
of(String) - 类 javax.annotation.processing.Completions 中的静态方法
返回值和空消息的 completion。
ofCalendarField(int) - 类 java.text.DateFormat.Field 中的静态方法
返回与此 Calendar 常量 calendarField 对应的 Field 常量。
OFF - 类 java.util.logging.Level 中的静态变量
OFF 是一个可用于关闭日志记录的特殊级别。
offendingNode - 异常 javax.imageio.metadata.IIOInvalidTreeException 中的变量
导致解析错误的 Node，或 null。
offer(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的末尾。
offer(E) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
将指定的元素插入到此队列的尾部（如果立即可行且不会超过该队列的容量），在成功时返回 true，如果此队列已满，则返回 false。
offer(E, long, TimeUnit) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
将指定的元素插入此队列的尾部，如果该队列已满，则在到达指定的等待时间之前等待可用的空间。
offer(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则返回 false。
offer(E, long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。
offer(E) - 接口 java.util.concurrent.BlockingQueue 中的方法
将指定元素插入此队列中（如果立即可行且不会违反容量限制），成功时返回 true，如果当前没有可用的空间，则返回 false。
offer(E, long, TimeUnit) - 接口 java.util.concurrent.BlockingQueue 中的方法
将指定元素插入此队列中，在到达指定的等待时间前等待可用的空间（如果有必要）。
offer(E) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
将指定元素插入此队列的尾部。
offer(E) - 类 java.util.concurrent.DelayQueue 中的方法
将指定元素插入此延迟队列。
offer(E, long, TimeUnit) - 类 java.util.concurrent.DelayQueue 中的方法
将指定元素插入此延迟队列中。
offer(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offer(E, long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offer(E, long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
将指定元素插入到此队列的尾部，如有必要，则等待指定的时间以使空间变得可用。
offer(E) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
将指定元素插入到此队列的尾部（如果立即可行且不会超出此队列的容量），在成功时返回 true，如果此队列已满，则返回 false。
offer(E) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
将指定元素插入此优先级队列。
offer(E, long, TimeUnit) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
将指定元素插入此优先级队列。
offer(E, long, TimeUnit) - 类 java.util.concurrent.SynchronousQueue 中的方法
将指定元素插入到此队列，如有必要则等待指定的时间，以便另一个线程接收它。
offer(E) - 类 java.util.concurrent.SynchronousQueue 中的方法
如果另一个线程正在等待以便接收指定元素，则将指定元素插入到此队列。
offer(E) - 接口 java.util.Deque 中的方法
将指定元素插入此双端队列所表示的队列（换句话说，此双端队列的尾部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用的空间，则返回 false。
offer(E) - 类 java.util.LinkedList 中的方法
将指定元素添加到此列表的末尾（最后一个元素）。
offer(E) - 类 java.util.PriorityQueue 中的方法
将指定的元素插入此优先级队列。
offer(E) - 接口 java.util.Queue 中的方法
将指定的元素插入此队列（如果立即可行且不会违反容量限制），当使用有容量限制的队列时，此方法通常要优于 Queue.add(E)，后者可能无法插入元素，而只是抛出一个异常。
offerFirst(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的开头。
offerFirst(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头，并在成功时返回 true；如果当前没有空间可用，则返回 false。
offerFirst(E, long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。
offerFirst(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offerFirst(E, long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offerFirst(E) - 接口 java.util.Deque 中的方法
在不违反容量限制的情况下，将指定的元素插入此双端队列的开头。
offerFirst(E) - 类 java.util.LinkedList 中的方法
在此列表的开头插入指定的元素。
offerLast(E) - 类 java.util.ArrayDeque 中的方法
将指定元素插入此双端队列的末尾。
offerLast(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾，并在成功时返回 true；如果当前没有空间可用，则返回 false。
offerLast(E, long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。
offerLast(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offerLast(E, long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
offerLast(E) - 接口 java.util.Deque 中的方法
在不违反容量限制的情况下，将指定的元素插入此双端队列的末尾。
offerLast(E) - 类 java.util.LinkedList 中的方法
在此列表末尾插入指定的元素。
offset - 类 java.awt.image.DataBuffer 中的变量
默认（第一个）存储单元的偏移量，从中可获得第一个元素。
offset - 类 javax.swing.plaf.basic.BasicScrollBarUI.TrackListener 中的变量
offset - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的变量
offset - 类 javax.swing.text.Segment 中的变量
这是所需文件开始处的数组偏移量。
offset - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
在编辑中使用。
offset - 异常 org.omg.CORBA.portable.IndirectionException 中的变量
指向流偏移量。
offsetByCodePoints(CharSequence, int, int) - 类 java.lang.Character 中的静态方法
返回给定字符序列中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。
offsetByCodePoints(char[], int, int, int, int) - 类 java.lang.Character 中的静态方法
返回给定 char 子数组中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。
offsetByCodePoints(int, int) - 类 java.lang.String 中的方法
返回此 String 中从给定的 index 处偏移 codePointOffset 个代码点的索引。
offsetByCodePoints(int, int) - 类 java.lang.StringBuffer 中的方法
offsetRequested() - 异常 javax.swing.text.BadLocationException 中的方法
返回文档中的非法偏移量。
offsets - 类 java.awt.image.DataBuffer 中的变量
所有存储单元的偏移量。
OGHAM - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Ogham”Unicode 字符块的常量。
OID - 类 javax.naming.ldap.ManageReferralControl 中的静态变量
ManageReferral 控件的分配对象标识符为 2.16.840.1.113730.3.4.2。
OID - 类 javax.naming.ldap.PagedResultsControl 中的静态变量
分页结果控件的分配对象标识符为 1.2.840.113556.1.4.319。
OID - 类 javax.naming.ldap.PagedResultsResponseControl 中的静态变量
分页结果响应控件的分配对象标识符为 1.2.840.113556.1.4.319。
OID - 类 javax.naming.ldap.SortControl 中的静态变量
服务器端排序控件的分配对象标识符为 1.2.840.113556.1.4.473。
OID - 类 javax.naming.ldap.SortResponseControl 中的静态变量
服务器端排序响应控件的分配对象标识符为 1.2.840.113556.1.4.474。
OID - 类 javax.naming.ldap.StartTlsRequest 中的静态变量
StartTLS 扩展请求的分配对象标识符为 1.3.6.1.4.1.1466.20037。
OID - 类 javax.naming.ldap.StartTlsResponse 中的静态变量
StartTLS 扩展响应的分配对象标识符为 1.3.6.1.4.1.1466.20037。
Oid - org.ietf.jgss 中的 类
此类表示 Universal Object Identifiers（通用对象标识符，即 Oid）及其相关的操作。
Oid(String) - 类 org.ietf.jgss.Oid 的构造方法
从其整数组件的字符串表示形式中构建 Oid 对象。
Oid(InputStream) - 类 org.ietf.jgss.Oid 的构造方法
从其 ASN.1 DER 编码中创建 Oid 对象。
Oid(byte[]) - 类 org.ietf.jgss.Oid 的构造方法
从其 ASN.1 DER 编码中创建 Oid 对象。
OK - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
OK 选项。
OK_CANCEL_OPTION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
OK/CANCEL 确认选项。
OK_CANCEL_OPTION - 类 javax.swing.JOptionPane 中的静态变量
用于 showConfirmDialog 的类型。
OK_OPTION - 类 javax.swing.JOptionPane 中的静态变量
选择 OK 时从类方法返回的值。
okToUseGui - 类 java.beans.beancontext.BeanContextSupport 中的变量
指示此实例现在能否呈现 GUI 的 boolean 值。
okToUseGui() - 类 java.beans.beancontext.BeanContextSupport 中的方法
通知此实例它现在可以呈现一个 GUI。
okToUseGui() - 接口 java.beans.Visibility 中的方法
此方法指示可以使用 Gui 的 bean。
OL - 类 javax.swing.text.html.HTML.Tag 中的静态变量
OLD_ITALIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Old Italic”Unicode 字符块的常量。
OLD_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
该标记已无效。
oldBinding - 类 javax.naming.event.NamingEvent 中的变量
包含关于更改前对象的信息。
oldBorderPainted - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
oldLeadSelectionPath - 类 javax.swing.event.TreeSelectionEvent 中的变量
在路径被更改之前的 leadSelectionPath，可能为 null。
OMGVMCID - org.omg.CORBA 中的 接口
为 OMG 保留的供应商次要代码 (minor code) ID。
OMIT_XML_DECLARATION - 类 javax.xml.transform.OutputKeys 中的静态变量
omit-xml-declaration = "yes" | "no". omit-xml-declaration 指定了 XSLT 处理器是否应输出 XML 声明，其值必须为 yes 或 no。
omitEnd() - 类 javax.swing.text.html.parser.Element 中的方法
如果可以忽略结束标记，则返回 true。
omitStart() - 类 javax.swing.text.html.parser.Element 中的方法
如果可以忽略开始标记，则返回 true。
on(boolean) - 类 java.security.DigestInputStream 中的方法
开启或关闭摘要功能。
on(boolean) - 类 java.security.DigestOutputStream 中的方法
开启或关闭摘要功能。
onDeregistration(ServiceRegistry, Class<?>) - 类 javax.imageio.spi.IIOServiceProvider 中的方法
Spi 类一从 ServiceRegistry 中注销即执行的回调。
onDeregistration(ServiceRegistry, Class<?>) - 接口 javax.imageio.spi.RegisterableService 中的方法
将一个实现此接口的对象从给定的 registry 的给定 category 移除时调用此方法。
ONE - 类 java.math.BigDecimal 中的静态变量
值为 1，标度为 0。
ONE - 类 java.math.BigInteger 中的静态变量
BigInteger 的常量 1。
ONE_DAY - 类 javax.management.timer.Timer 中的静态变量
一天内的毫秒数。
ONE_HOUR - 类 javax.management.timer.Timer 中的静态变量
一小时内的毫秒数。
ONE_MINUTE - 类 javax.management.timer.Timer 中的静态变量
一分钟内的毫秒数。
ONE_SECOND - 类 javax.management.timer.Timer 中的静态变量
一秒钟内的毫秒数。
ONE_SIDED - 类 java.awt.JobAttributes.SidesType 中的静态变量
SidesType 实例用于指定应该在连续介质纸张的同一面打印连续作业页面。
ONE_SIDED - 类 javax.print.attribute.standard.Sides 中的静态变量
将每个连续的打印流页应用于连续介质纸张的相同面。
ONE_TOUCH_EXPANDABLE_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 oneTouchExpandable 属性。
ONE_TOUCH_OFFSET - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的静态变量
ONE_TOUCH_SIZE - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的静态变量
基于 BasicSplitPaneUI 添加到它的两个方向的分隔符宽度和高度。
ONE_WEEK - 类 javax.management.timer.Timer 中的静态变量
一周内的毫秒数。
ONELEVEL_SCOPE - 类 javax.naming.directory.SearchControls 中的静态变量
搜索一级命名对象。
ONELEVEL_SCOPE - 接口 javax.naming.event.EventContext 中的静态变量
该常量用来表示对涉及目标指定上下文中对象的事件感兴趣，不包括目标指定的上下文。
oneTouchExpandable - 类 javax.swing.JSplitPane 中的变量
是否要提供一个小部件来快速展开/折叠分隔窗格。
oneTouchExpandableChanged() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
当包含接收者的 JSplitPane 的 oneTouchExpandable 值发生更改时传递消息。
Oneway - javax.jws 中的 注释类型
指示给定 @WebMethod 只有一条输入消息并且没有输出。
onMalformedInput(CodingErrorAction) - 类 java.nio.charset.CharsetDecoder 中的方法
更改此解码器对错误输入错误的操作。
onMalformedInput(CodingErrorAction) - 类 java.nio.charset.CharsetEncoder 中的方法
更改此编码器对错误输入错误的操作。
onRegistration(ServiceRegistry, Class<?>) - 类 javax.imageio.spi.IIOServiceProvider 中的方法
在 ServiceRegistry 中实例化和注册 Spi 类后即执行的回调。
onRegistration(ServiceRegistry, Class<?>) - 接口 javax.imageio.spi.RegisterableService 中的方法
将一个实现此接口的对象添加到给定 registry 的给定 category 时调用此方法。
onUnmappableCharacter(CodingErrorAction) - 类 java.nio.charset.CharsetDecoder 中的方法
更改此解码器对不可映射的字符错误的操作。
onUnmappableCharacter(CodingErrorAction) - 类 java.nio.charset.CharsetEncoder 中的方法
更改此编码器对不可映射的字符错误的操作。
OP_ACCEPT - 类 java.nio.channels.SelectionKey 中的静态变量
用于套接字接受操作的操作集位。
OP_CONNECT - 类 java.nio.channels.SelectionKey 中的静态变量
用于套接字连接操作的操作集位。
op_name() - 类 org.omg.CORBA.ServerRequest 中的方法
已过时。 使用 operation()
OP_READ - 类 java.nio.channels.SelectionKey 中的静态变量
用于读取操作的操作集位。
OP_WRITE - 类 java.nio.channels.SelectionKey 中的静态变量
用于写入操作的操作集位。
OPAQUE - 接口 java.awt.Transparency 中的静态变量
表示保证完全不透明的图像数据，意味着所有像素 alpha 值都为 1.0。
OPAQUE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象在其矩形区域内绘制每个像素。
OPC_LIFE_OVER - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
光敏导电体已不再运行。
OPC_NEAR_EOL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
光敏导电体寿命将到期。
open(File) - 类 java.awt.Desktop 中的方法
启动关联应用程序来打开文件。
OPEN - 类 java.awt.geom.Arc2D 中的静态变量
闭合类型，用于不具有用来连接弧段两个端点的路径段的开弧。
open() - 类 java.nio.channels.DatagramChannel 中的静态方法
打开数据报通道。
open() - 类 java.nio.channels.Pipe 中的静态方法
打开一个管道。
open() - 类 java.nio.channels.Selector 中的静态方法
打开一个选择器。
open() - 类 java.nio.channels.ServerSocketChannel 中的静态方法
打开服务器套接字通道。
open() - 类 java.nio.channels.SocketChannel 中的静态方法
打开套接字通道。
open(SocketAddress) - 类 java.nio.channels.SocketChannel 中的静态方法
打开套接字通道并将其连接到远程地址。
open() - 接口 javax.sound.midi.MidiDevice 中的方法
打开设备，指示它现在应获取任何所需的系统资源然后开始运行。
open(AudioFormat, byte[], int, int) - 接口 javax.sound.sampled.Clip 中的方法
打开剪辑，意味着它应该获得所有所需的系统资源并变得可操作。
open(AudioInputStream) - 接口 javax.sound.sampled.Clip 中的方法
使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。
open() - 接口 javax.sound.sampled.Line 中的方法
打开行，指示它应该获得所有所需系统资源并变得可操作。
OPEN - 类 javax.sound.sampled.LineEvent.Type 中的静态变量
行打开（为行本身保留系统资源）时发送的事件类型。
open(AudioFormat, int) - 接口 javax.sound.sampled.SourceDataLine 中的方法
打开具有指定格式和建议缓冲区大小的行，这样可使该行获得所有所需系统资源并变得可操作。
open(AudioFormat) - 接口 javax.sound.sampled.SourceDataLine 中的方法
打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
open(AudioFormat, int) - 接口 javax.sound.sampled.TargetDataLine 中的方法
打开具有指定格式和请求缓冲区大小的行，这样可使行获得所有所需的系统资源并变得可操作。
open(AudioFormat) - 接口 javax.sound.sampled.TargetDataLine 中的方法
打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
OPEN_DELETE - 类 java.util.zip.ZipFile 中的静态变量
打开 ZIP 文件并将其标记为删除的模式标志。
OPEN_DIALOG - 类 javax.swing.JFileChooser 中的静态变量
指示 JFileChooser 支持 "Open" 文件操作的类型值。
OPEN_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
OPEN_FAILURE 用于对输出流的打开失败时。
OPEN_READ - 类 java.util.zip.ZipFile 中的静态变量
打开 ZIP 文件进行阅读的模式标志。
OPEN_TYPE_FIELD - 类 javax.management.JMX 中的静态变量
openType 字段的名称。
openButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
openButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
openButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
openConnection() - 类 java.net.URL 中的方法
返回一个 URLConnection 对象，它表示到 URL 所引用的远程对象的连接。
openConnection(Proxy) - 类 java.net.URL 中的方法
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
openConnection(URL) - 类 java.net.URLStreamHandler 中的方法
打开一个到 URL 参数引用的对象的连接。
openConnection(URL, Proxy) - 类 java.net.URLStreamHandler 中的方法
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。
OpenDataException - javax.management.openmbean 中的 异常
因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。
OpenDataException() - 异常 javax.management.openmbean.OpenDataException 的构造方法
不带详细消息的 OpenDataException。
OpenDataException(String) - 异常 javax.management.openmbean.OpenDataException 的构造方法
带详细消息的 OpenDataException。
openDatagramChannel() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开数据报通道。
OPENED - 类 javax.management.remote.JMXConnectionNotification 中的静态变量
打开连接通知的通知类型字符串。
openFrame(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
通常不调用此方法。
openFrame(JInternalFrame) - 接口 javax.swing.DesktopManager 中的方法
如有可能，在适当的位置显示此窗体。
openIcon - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于显示扩展的非叶节点的图标。
openInputStream() - 接口 javax.tools.FileObject 中的方法
获取此文件对象的 InputStream。
openInputStream() - 类 javax.tools.ForwardingFileObject 中的方法
openInputStream() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现总是抛出 UnsupportedOperationException。
OpenMBeanAttributeInfo - javax.management.openmbean 中的 接口
描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport - javax.management.openmbean 中的 类
描述 open MBean 的一个属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<?>, boolean, boolean, boolean) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、<openType 和 description 以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<?>, boolean, boolean, boolean, Descriptor) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T, T[]) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T, Comparable<T>, Comparable<T>) - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的构造方法
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanConstructorInfo - javax.management.openmbean 中的 接口
描述 Open MBean 的构造方法。
OpenMBeanConstructorInfoSupport - javax.management.openmbean 中的 类
描述 Open MBean 的构造方法。
OpenMBeanConstructorInfoSupport(String, String, OpenMBeanParameterInfo[]) - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 的构造方法
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description 和 signature 描述 open MBeans 的类的构造方法。
OpenMBeanConstructorInfoSupport(String, String, OpenMBeanParameterInfo[], Descriptor) - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 的构造方法
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。
OpenMBeanInfo - javax.management.openmbean 中的 接口
描述一个 Open MBean：Open MBean 的识别方式为，如果 Open MBean 的 getMBeanInfo() 方法返回实现 OpenMBeanInfo 接口（通常为 OpenMBeanInfoSupport）的类的实例，则可识别 Open MBean。
OpenMBeanInfoSupport - javax.management.openmbean 中的 类
OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
OpenMBeanInfoSupport(String, String, OpenMBeanAttributeInfo[], OpenMBeanConstructorInfo[], OpenMBeanOperationInfo[], MBeanNotificationInfo[]) - 类 javax.management.openmbean.OpenMBeanInfoSupport 的构造方法
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String, String, OpenMBeanAttributeInfo[], OpenMBeanConstructorInfo[], OpenMBeanOperationInfo[], MBeanNotificationInfo[], Descriptor) - 类 javax.management.openmbean.OpenMBeanInfoSupport 的构造方法
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类
OpenMBeanOperationInfo - javax.management.openmbean 中的 接口
描述 Open MBean 的操作。
OpenMBeanOperationInfoSupport - javax.management.openmbean 中的 类
描述 Open MBean 的一个操作。
OpenMBeanOperationInfoSupport(String, String, OpenMBeanParameterInfo[], OpenType<?>, int) - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 的构造方法
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。
OpenMBeanOperationInfoSupport(String, String, OpenMBeanParameterInfo[], OpenType<?>, int, Descriptor) - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 的构造方法
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。
OpenMBeanParameterInfo - javax.management.openmbean 中的 接口
描述用于 open MBean 的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport - javax.management.openmbean 中的 类
描述用于 open MBean 的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<?>) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType 和 description 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<?>, Descriptor) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T, T[]) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T, Comparable<T>, Comparable<T>) - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的构造方法
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
openMenuKey - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
openOutputStream() - 接口 javax.tools.FileObject 中的方法
获取此文件对象的 OutputStream。
openOutputStream() - 类 javax.tools.ForwardingFileObject 中的方法
openOutputStream() - 类 javax.tools.SimpleJavaFileObject 中的方法
此实现总是抛出 UnsupportedOperationException。
openPipe() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开一个管道。
openReader(boolean) - 接口 javax.tools.FileObject 中的方法
获取此对象的 reader。
openReader(boolean) - 类 javax.tools.ForwardingFileObject 中的方法
openReader(boolean) - 类 javax.tools.SimpleJavaFileObject 中的方法
在 Reader 中包装 SimpleJavaFileObject.getCharContent(boolean) 的结果。
openSelector() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开一个选择器。
openServerSocketChannel() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开服务器套接字通道。
openSocketChannel() - 类 java.nio.channels.spi.SelectorProvider 中的方法
打开套接字通道。
openStream() - 类 java.net.URL 中的方法
打开到此 URL 的连接并返回一个用于从该连接读入的 InputStream。
OpenType - java.awt.font 中的 接口
OpenType 接口表示 OpenType 和 TrueType 字体。
OpenType<T> - javax.management.openmbean 中的 类
OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。
OpenType(String, String, String) - 类 javax.management.openmbean.OpenType 的构造方法
构造一个 OpenType 实例（实际上是一个子类实例，因为 OpenType 是抽象的），检查给定参数的有效性。
openWriter() - 接口 javax.tools.FileObject 中的方法
获取此文件对象的 Writer。
openWriter() - 类 javax.tools.ForwardingFileObject 中的方法
openWriter() - 类 javax.tools.SimpleJavaFileObject 中的方法
在 Writer 中包装 openOutputStream 的结果。
OPERATING_SYSTEM_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
OperatingSystemMXBean 的 ObjectName 的字符串表示形式。
OperatingSystemMXBean - java.lang.management 中的 接口
用于操作系统的管理接口，Java 虚拟机在此操作系统上运行。
Operation - java.rmi.server 中的 类
已过时。 无替代版本
Operation(String) - 类 java.rmi.server.Operation 的构造方法
已过时。 无替代版本
operation() - 类 org.omg.CORBA.Request 中的方法
检索将被调用的方法的名称。
operation() - 类 org.omg.CORBA.ServerRequest 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
operation() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回将被调用的操作的名称。
operation_context() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 String 对象数组，这些对象包含将在请求上发送上下文。
OperationNotSupportedException - javax.naming 中的 异常
当上下文实现不支持将调用的操作时，抛出此异常。
OperationNotSupportedException() - 异常 javax.naming.OperationNotSupportedException 的构造方法
构造一个新的 OperationNotSupportedException 实例。
OperationNotSupportedException(String) - 异常 javax.naming.OperationNotSupportedException 的构造方法
使用解释构造一个新的 OperationNotSupportedException 实例。
OperationsException - javax.management 中的 异常
表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
OperationsException() - 异常 javax.management.OperationsException 的构造方法
默认的构造方法。
OperationsException(String) - 异常 javax.management.OperationsException 的构造方法
允许指定具体错误消息的构造方法。
OPTICAL_CHARACTER_RECOGNITION - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Optical Character Recognition”Unicode 字符块的常量。
OPTION - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Option - javax.swing.text.html 中的 类
用来表示 <option> 元素的 ListModel 值。
Option(AttributeSet) - 类 javax.swing.text.html.Option 的构造方法
创建新的 Option 对象。
OPTION_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
主要用于 DIALOG 内部的专用窗格
OPTION_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
OptionPane 的 region。
OPTION_TYPE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
optionType 的绑定属性名。
OPTIONAL - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的静态变量
可供选择的 LoginModule。
OptionalDataException - java.io 中的 异常
指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
OptionChecker - javax.tools 中的 接口
识别选项的接口。
optionPane - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
接收者为其提供外观的 JOptionPane。
OptionPaneUI - javax.swing.plaf 中的 类
JOptionPane 的可插入外观界面。
OptionPaneUI() - 类 javax.swing.plaf.OptionPaneUI 的构造方法
options - 类 javax.swing.JOptionPane 中的变量
要向用户显示的选项。
OPTIONS_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
option 的绑定属性名。
optionType - 类 javax.swing.JOptionPane 中的变量
选项类型，DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION 之一。
or(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this | val) 的 BigInteger。
or(BitSet) - 类 java.util.BitSet 中的方法
对此位 set 和位 set 参数执行逻辑或操作。
or(QueryExp, QueryExp) - 类 javax.management.Query 中的静态方法
返回一个查询表达式，它是其他两个查询表达式的“或”。
orange - 类 java.awt.Color 中的静态变量
桔黄色。
ORANGE - 类 java.awt.Color 中的静态变量
桔黄色。
orb() - 接口 javax.rmi.CORBA.Tie 中的方法
返回此 tie 的 ORB。
orb(ORB) - 接口 javax.rmi.CORBA.Tie 中的方法
设置此 tie 的 ORB。
ORB - org.omg.CORBA 中的 类
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。
ORB() - 类 org.omg.CORBA.ORB 的构造方法
orb(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
提供对与其参数关联的 orb 的引用。
orb() - 类 org.omg.CORBA.portable.InputStream 中的方法
返回创建此 InputStream 的 ORB。
orb() - 类 org.omg.CORBA.portable.OutputStream 中的方法
返回创建此 OutputStream 的 ORB。
ORB - org.omg.CORBA_2_3 中的 类
扩展了 org.omg.CORBA.ORB 的类，使 ORB 在 OMG CORBA 规范 2.3 版下可移植。
ORB() - 类 org.omg.CORBA_2_3.ORB 的构造方法
orb(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
返回当前关联 Servant 的 ORB 实例的便捷方法。
ORB_CTRL_MODEL - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态变量
orb_id() - 接口 org.omg.PortableInterceptor.ObjectReferenceTemplate 中的方法
orb_id() - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
返回将被初始化的 ORB 的 ID。
orb_id() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回用于创建 ORB 的 ID。
ORBIdHelper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/ORBIdHelper.java。
ORBIdHelper() - 类 org.omg.PortableInterceptor.ORBIdHelper 的构造方法
ORBInitializer - org.omg.PortableInterceptor 中的 接口
便于注册 interceptor 和初始化 ORB。
ORBInitializerOperations - org.omg.PortableInterceptor 中的 接口
便于注册 interceptor 和初始化 ORB。
ORBInitInfo - org.omg.PortableInterceptor 中的 接口
传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
ORBInitInfoOperations - org.omg.PortableInterceptor 中的 接口
传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
order() - 类 java.nio.ByteBuffer 中的方法
获取此缓冲区的字节顺序。
order(ByteOrder) - 类 java.nio.ByteBuffer 中的方法
修改此缓冲区的字节顺序。
order() - 类 java.nio.CharBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.DoubleBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.FloatBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.IntBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.LongBuffer 中的方法
获取此缓冲区的字节顺序。
order() - 类 java.nio.ShortBuffer 中的方法
获取此缓冲区的字节顺序。
ordered - 类 javax.naming.directory.BasicAttribute 中的变量
记录此属性的值是否有序的标志。
ordinal() - 类 java.lang.Enum 中的方法
返回枚举常量的序数（它在枚举声明中的位置，其中初始常量序数为零）。
ordinaryChar(int) - 类 java.io.StreamTokenizer 中的方法
指定字符参数在此标记生成器中是“普通”字符。
ordinaryChars(int, int) - 类 java.io.StreamTokenizer 中的方法
指定 low <= c <= high 范围中的所有字符 c 在此标记生成器中都是“普通”字符。
orFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
org.ietf.jgss - 软件包 org.ietf.jgss
此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA - 软件包 org.omg.CORBA
提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage - 软件包 org.omg.CORBA.DynAnyPackage
提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage - 软件包 org.omg.CORBA.ORBPackage
提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable - 软件包 org.omg.CORBA.portable
提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage - 软件包 org.omg.CORBA.TypeCodePackage
提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CORBA_2_3 - 软件包 org.omg.CORBA_2_3
CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CORBA_2_3.portable - 软件包 org.omg.CORBA_2_3.portable
提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CosNaming - 软件包 org.omg.CosNaming
为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage - 软件包 org.omg.CosNaming.NamingContextExtPackage
此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage - 软件包 org.omg.CosNaming.NamingContextPackage
此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic - 软件包 org.omg.Dynamic
此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny - 软件包 org.omg.DynamicAny
提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage - 软件包 org.omg.DynamicAny.DynAnyFactoryPackage
此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage - 软件包 org.omg.DynamicAny.DynAnyPackage
此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP - 软件包 org.omg.IOP
此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage - 软件包 org.omg.IOP.CodecFactoryPackage
此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage - 软件包 org.omg.IOP.CodecPackage
此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging - 软件包 org.omg.Messaging
此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor - 软件包 org.omg.PortableInterceptor
提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage - 软件包 org.omg.PortableInterceptor.ORBInitInfoPackage
此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer - 软件包 org.omg.PortableServer
提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage - 软件包 org.omg.PortableServer.CurrentPackage
提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage - 软件包 org.omg.PortableServer.POAManagerPackage
封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage - 软件包 org.omg.PortableServer.POAPackage
允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.portable - 软件包 org.omg.PortableServer.portable
提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.ServantLocatorPackage - 软件包 org.omg.PortableServer.ServantLocatorPackage
提供定位 servant 的类和接口。
org.omg.SendingContext - 软件包 org.omg.SendingContext
为值类型的编组提供支持。
org.omg.stub.java.rmi - 软件包 org.omg.stub.java.rmi
包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。
org.w3c.dom - 软件包 org.w3c.dom
为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap - 软件包 org.w3c.dom.bootstrap
org.w3c.dom.events - 软件包 org.w3c.dom.events
org.w3c.dom.ls - 软件包 org.w3c.dom.ls
org.xml.sax - 软件包 org.xml.sax
此包提供了核心 SAX API。
org.xml.sax.ext - 软件包 org.xml.sax.ext
此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers - 软件包 org.xml.sax.helpers
此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。
orientation - 类 javax.swing.JProgressBar 中的变量
进度条是水平的还是垂直的。
orientation - 类 javax.swing.JScrollBar 中的变量
orientation - 类 javax.swing.JSlider 中的变量
滑块方向是水平还是垂直的。
orientation - 类 javax.swing.JSplitPane 中的变量
如何分割视图。
orientation - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
JSplitPane 的方向。
Orientation - 类 javax.swing.text.StyleConstants 中的静态变量
段落的方向。
ORIENTATION_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 orientation（水平或者垂直）属性名称。
OrientationRequested - javax.print.attribute.standard 中的 类
OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
OrientationRequested(int) - 类 javax.print.attribute.standard.OrientationRequested 的构造方法
构造具有给定整数值的新 OrientationRequested 枚举值。
origin - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的变量
ORIGINAL_TYPE_FIELD - 类 javax.management.JMX 中的静态变量
originalType 字段的名称。
originalEx - 异常 org.omg.CORBA.portable.UnknownException 中的变量
一个 throwable 对象，包装在 CORBA UnknownException 中的原始异常。
OriginateDirection - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getDirection 的可能值。
originatingProvider - 类 javax.imageio.ImageReader 中的变量
实例化此对象的 ImageReaderSpi，如果其身份未知或不存在，则为 null。
originatingProvider - 类 javax.imageio.ImageWriter 中的变量
实例化此对象的 ImageWriterSpi，如果 ImageWriterSpi 的标识是未知的或不存在，则将此对象实例化为 null。
origmodel - 类 java.awt.image.RGBImageFilter 中的变量
用户调用 substituteColorModel 时将由 newmodel 替换的 ColorModel。
ORIYA - 类 java.awt.font.NumericShaper 中的静态变量
标识 ORIYA 范围和十进制基数。
ORIYA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Oriya”Unicode 字符块的常量。
OSMANYA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Osmanya”Unicode 字符块的常量。
oStart - 类 javax.swing.text.html.parser.Element 中的变量
OTHER - 类 java.sql.Types 中的静态变量
Java 编程语言中的常量，该常量指示 SQL 类型是特定于数据库的并且被映射到可通过 getObject 和 setObject 方法访问的 Java 对象。
OTHER - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
打印机已经检测到了一个以下未列出的错误。
OTHER_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Lo”。
OTHER_NUMBER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“No”。
OTHER_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Po”。
OTHER_SYMBOL - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“So”。
othersDeletesAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取由其他结果集类型进行的删除是否可见。
othersInsertsAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取由其他结果集类型进行的插入是否可见。
othersUpdatesAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取由其他结果集类型进行的更新是否可见。
out - 类 java.io.FileDescriptor 中的静态变量
标准输出流的句柄。
out - 类 java.io.FilterOutputStream 中的变量
要过滤的基础输出流。
out - 类 java.io.FilterWriter 中的变量
底层字符输出流。
out - 类 java.io.PipedInputStream 中的变量
循环缓冲区中位置的索引，此管道输入流将从该位置读取下一个数据字节。
out - 类 java.io.PrintWriter 中的变量
此 PrintWriter 的底层字符输出流。
out - 类 java.lang.System 中的静态变量
“标准”输出流。
out() - 类 java.util.Formatter 中的方法
返回输出的目标文件。
OUT_BOTTOM - 类 java.awt.geom.Rectangle2D 中的静态变量
指示点位于此 Rectangle2D 下方的位掩码。
OUT_LEFT - 类 java.awt.geom.Rectangle2D 中的静态变量
指示点位于此 Rectangle2D 左边的位掩码。
OUT_RIGHT - 类 java.awt.geom.Rectangle2D 中的静态变量
指示点位于此 Rectangle2D 右边的位掩码。
OUT_TOP - 类 java.awt.geom.Rectangle2D 中的静态变量
指示点位于此 Rectangle2D 上方的位掩码。
OUTBOUND_MESSAGE_ATTACHMENTS - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性: 用于出站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。
outcode(double, double) - 类 java.awt.geom.Rectangle2D.Double 中的方法
确定指定坐标相对于此 Rectangle2D 的位置。
outcode(double, double) - 类 java.awt.geom.Rectangle2D.Float 中的方法
确定指定坐标相对于此 Rectangle2D 的位置。
outcode(double, double) - 类 java.awt.geom.Rectangle2D 中的方法
确定指定坐标相对于此 Rectangle2D 的位置。
outcode(Point2D) - 类 java.awt.geom.Rectangle2D 中的方法
确定指定 Point2D 相对于此 Rectangle2D 的位置。
outcode(double, double) - 类 java.awt.Rectangle 中的方法
确定指定坐标相对于此 Rectangle2D 的位置。
OUTLINE_DRAG_MODE - 类 javax.swing.JDesktopPane 中的静态变量
指示桌面窗格是否只应该出现正在被拖动项的轮廓。
OutOfMemoryError - java.lang 中的 错误
因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
OutOfMemoryError() - 错误 java.lang.OutOfMemoryError 的构造方法
构造不带详细消息的 OutOfMemoryError。
OutOfMemoryError(String) - 错误 java.lang.OutOfMemoryError 的构造方法
构造带指定详细消息的 OutOfMemoryError。
outpixbuf - 类 java.awt.image.ReplicateScaleFilter 中的变量
使用 ReplicateScaleFilter.destWidth 的大小初始化的 byte 数组，用于将像素数据行传递给 ImageConsumer。
output - 类 javax.imageio.ImageWriter 中的变量
由 setOutput 设置并由 getOutput 获取的 ImageOutputStream 或其他 Object。
output(char[], int, int) - 类 javax.swing.text.AbstractWriter 中的方法
写出内容过程的最后一步。
output(char[], int, int) - 类 javax.swing.text.html.HTMLWriter 中的方法
重写此方法来映射任何字符实体，例如 < 映射到 <。
OUTPUT_AREA_ALMOST_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
一个或多个输出区域几乎已经填满（例如纸盒、装订器、整理器）。
OUTPUT_AREA_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
一个或多个输出区域已经填满（例如纸盒、装订器、整理器）。
OUTPUT_TRAY_MISSING - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备中没有一个或多个输出纸盒。
outputClass - 类 javax.imageio.spi.ImageOutputStreamSpi 中的变量
指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
OutputDeviceAssigned - javax.print.attribute.standard 中的 类
OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
OutputDeviceAssigned(String, Locale) - 类 javax.print.attribute.standard.OutputDeviceAssigned 的构造方法
构造具有给定设备名称和语言环境的新 OutputDeviceAssigned 属性。
OutputKeys - javax.xml.transform 中的 类
提供可用于设置 Transformer 的输出属性或从 Transformer 或 Templates 对象检索输出属性的字符串常量。
OutputStream - java.io 中的 类
此抽象类是表示输出字节流的所有类的超类。
OutputStream() - 类 java.io.OutputStream 的构造方法
OutputStream - org.omg.CORBA.portable 中的 类
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。
OutputStream() - 类 org.omg.CORBA.portable.OutputStream 的构造方法
OutputStream - org.omg.CORBA_2_3.portable 中的 类
OutputStream 提供将所有映射的 IDL 类型写入流的接口。
OutputStream() - 类 org.omg.CORBA_2_3.portable.OutputStream 的构造方法
OutputStreamWriter - java.io 中的 类
OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
OutputStreamWriter(OutputStream, String) - 类 java.io.OutputStreamWriter 的构造方法
创建使用指定字符集的 OutputStreamWriter。
OutputStreamWriter(OutputStream) - 类 java.io.OutputStreamWriter 的构造方法
创建使用默认字符编码的 OutputStreamWriter。
OutputStreamWriter(OutputStream, Charset) - 类 java.io.OutputStreamWriter 的构造方法
创建使用给定字符集的 OutputStreamWriter。
OutputStreamWriter(OutputStream, CharsetEncoder) - 类 java.io.OutputStreamWriter 的构造方法
创建使用给定字符集编码器的 OutputStreamWriter。
outputTypes - 类 javax.imageio.spi.ImageWriterSpi 中的变量
将从 getOutputTypes 返回的 Class 对象的数组，该数组最初为 null。
outsideBorder - 类 javax.swing.border.CompoundBorder 中的变量
OVER - 类 java.awt.dnd.DragSourceContext 中的静态变量
updateCurrentCursor() 使用的 int 值，指示 Cursor 处于 DropTarget 上。
OVERFLOW - 类 java.nio.charset.CoderResult 中的静态变量
指示溢出的结果对象，意味着输出缓冲区没有足够的空间。
OverlappingFileLockException - java.nio.channels 中的 异常
试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
OverlappingFileLockException() - 异常 java.nio.channels.OverlappingFileLockException 的构造方法
构造此类的一个实例。
overlaps(long, long) - 类 java.nio.channels.FileLock 中的方法
判断此锁定是否与给定的锁定区域重叠。
OverlayLayout - javax.swing 中的 类
要在彼此顶部安排组件的布局管理器。
OverlayLayout(Container) - 类 javax.swing.OverlayLayout 的构造方法
构造执行子容器的覆盖安排的布局管理器。
Override - java.lang 中的 注释类型
表示一个方法声明打算重写超类中的另一个方法声明。
overrides(ExecutableElement, ExecutableElement, TypeElement) - 接口 javax.lang.model.util.Elements 中的方法
测试一个方法（作为给定类型的成员）是否重写了另一个方法。
ownDeletesAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取结果集自身的删除是否可见。
owner - 类 java.awt.datatransfer.Clipboard 中的变量
Owner - java.security.acl 中的 接口
管理访问控制列表 (ACL) 的所有者或 ACL 配置的接口。
ownInsertsAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取结果集自身的插入是否可见。
owns(AbstractQueuedLongSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
查询给定 ConditionObject 是否使用此同步器作为它的锁。
owns(AbstractQueuedSynchronizer.ConditionObject) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
查询给定的 ConditionObject 是否使用了此同步器作为其锁。
ownUpdatesAreVisible(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取对于给定类型的 ResultSet 对象，结果集自身的更新是否可见。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


P - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

P

P - 类 javax.swing.text.html.HTML.Tag 中的静态变量
p - 类 javax.swing.text.html.parser.DTD 中的变量
pack() - 类 java.awt.Window 中的方法
调整此窗口的大小，以适合其子组件的首选大小和布局。
pack(JarFile, OutputStream) - 接口 java.util.jar.Pack200.Packer 中的方法
接收 JarFile 并将其转换为 Pack200 存档。
pack(JarInputStream, OutputStream) - 接口 java.util.jar.Pack200.Packer 中的方法
接收 JarInputStream 并将其转换成 Pack200 存档。
pack() - 类 javax.swing.JInternalFrame 中的方法
使此 JInternalFrame 的子组件按其首选大小进行布局。
pack() - 类 javax.swing.JPopupMenu 中的方法
布置容器，让它使用显示其内容所需的最小空间。
Pack200 - java.util.jar 中的 类
以 Pack200 格式在 JAR 文件和打包的流之间进行转换。
Pack200.Packer - java.util.jar 中的 接口
打包器引擎把各种转换应用到输入 JAR 文件，从而可以通过压缩器（如 gzip 或 zip）高度压缩打包流。
Pack200.Unpacker - java.util.jar 中的 接口
解包器引擎将打包的流转换为 JAR 文件。
Package - java.lang 中的 类
Package 对象包含有关 Java 包的实现和规范的版本信息。
PackageElement - javax.lang.model.element 中的 接口
表示一个包程序元素。
packagePrefix - 接口 java.rmi.server.LoaderHandler 中的静态变量
已过时。 系统 LoaderHandler 实现的包。
packagePrefix - 接口 java.rmi.server.RemoteRef 中的静态变量
初始化服务器包的前缀：假定服务器 ref 类（如 UnicastRef、UnicastServerRef）的实现位于由前缀定义的包中。
packagesIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中包的列表。
packagesIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中包的集合。
PackedColorModel - java.awt.image 中的 类
PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。
PackedColorModel(ColorSpace, int, int[], int, boolean, int, int) - 类 java.awt.image.PackedColorModel 的构造方法
根据颜色掩码数组（指定了 int 像素表示形式中哪些位包含每个颜色的采样）和 alpha 掩码来构造一个 PackedColorModel。
PackedColorModel(ColorSpace, int, int, int, int, int, boolean, int, int) - 类 java.awt.image.PackedColorModel 的构造方法
根据指定的掩码构造一个 PackedColorModel，该掩码指示 int 像素表示形式中的哪些位包含 alpha、红色、绿色和蓝色采样。
padding - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的变量
PADDING - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
PADDING_BOTTOM - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
PADDING_LEFT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
PADDING_RIGHT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
PADDING_TOP - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
padSelectedTab(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
padSelectedTab(int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 中的方法
padSpaceBetweenStrings - 类 javax.swing.plaf.metal.MetalToolTipUI 中的静态变量
padTabRun(int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
PAGE_AXIS - 类 javax.swing.BoxLayout 中的静态变量
指定应该根据目标容器的 ComponentOrientation 属性确定的文本行在页面中的流向来放置组件。
PAGE_END - 类 java.awt.BorderLayout 中的静态变量
组件出现在最后一行布局内容之后。
PAGE_END - 类 java.awt.GridBagConstraints 中的静态变量
沿显示区域的边缘居中放置组件，该显示区域与当前 ComponentOrienation 的页面结束部分相关。
PAGE_EXISTS - 接口 java.awt.print.Printable 中的静态变量
从 Printable.print(Graphics, PageFormat, int) 返回，表示请求的页面被呈现。
PAGE_START - 类 java.awt.BorderLayout 中的静态变量
组件出现在第一行布局内容之前。
PAGE_START - 类 java.awt.GridBagConstraints 中的静态变量
沿显示区域的边缘居中放置组件，该显示区域与当前 ComponentOrienation 的页面开始部分相关。
PAGE_TAB - 类 javax.accessibility.AccessibleRole 中的静态变量
作为页选项卡列表子级的对象。
PAGE_TAB_LIST - 类 javax.accessibility.AccessibleRole 中的静态变量
通过所提供的某种机制一次可呈现一系列窗格（或页选项卡）的对象。
Pageable - java.awt.print 中的 接口
Pageable 实现表示要打印的页面集合。
PAGEABLE - 类 javax.print.DocFlavor.SERVICE_FORMATTED 中的静态变量
打印数据表示形式类名 = "java.awt.print.Pageable"（pageable 对象）的服务格式化打印数据 DocFlavor。
PageAttributes - java.awt 中的 类
用来控制打印页面输出的属性集。
PageAttributes() - 类 java.awt.PageAttributes 的构造方法
构造一个具有每个属性的默认值的 PageAttributes 实例。
PageAttributes(PageAttributes) - 类 java.awt.PageAttributes 的构造方法
构造一个 PageAttributes 实例，它是所提供的 PageAttributes 的副本。
PageAttributes(PageAttributes.ColorType, PageAttributes.MediaType, PageAttributes.OrientationRequestedType, PageAttributes.OriginType, PageAttributes.PrintQualityType, int[]) - 类 java.awt.PageAttributes 的构造方法
构造一个具有每个属性的指定值的 PageAttributes 实例。
PageAttributes.ColorType - java.awt 中的 类
可能颜色状态的类型安全的枚举。
PageAttributes.MediaType - java.awt 中的 类
可能的纸张大小的类型安全的枚举。
PageAttributes.OrientationRequestedType - java.awt 中的 类
可能打印方向的类型安全的枚举。
PageAttributes.OriginType - java.awt 中的 类
可能原点的类型安全的枚举。
PageAttributes.PrintQualityType - java.awt 中的 类
可能的打印质量的类型安全的枚举。
pageDialog(PageFormat) - 类 java.awt.print.PrinterJob 中的方法
显示允许修改 PageFormat 实例的对话框。
pageDialog(PrintRequestAttributeSet) - 类 java.awt.print.PrinterJob 中的方法
显示跨平台页面设置对话框的便捷方法。
pageDownAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
垂直向下翻页的动作名称。
PagedResultsControl - javax.naming.ldap 中的 类
请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
PagedResultsControl(int, boolean) - 类 javax.naming.ldap.PagedResultsControl 的构造方法
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsControl(int, byte[], boolean) - 类 javax.naming.ldap.PagedResultsControl 的构造方法
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsResponseControl - javax.naming.ldap 中的 类
指示一批搜索结果的末尾。
PagedResultsResponseControl(String, boolean, byte[]) - 类 javax.naming.ldap.PagedResultsResponseControl 的构造方法
构造分页结果响应控件。
PageFormat - java.awt.print 中的 类
PageFormat 类描述要打印的页面大小和方向。
PageFormat() - 类 java.awt.print.PageFormat 的构造方法
创建默认的纵向 PageFormat。
PageRanges - javax.print.attribute.standard 中的 类
PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
PageRanges(int[][]) - 类 javax.print.attribute.standard.PageRanges 的构造方法
构造具有给定成员的新 PageRanges 属性。
PageRanges(String) - 类 javax.print.attribute.standard.PageRanges 的构造方法
构造具有给定成员（字符串形式）的新 PageRanges 属性。
PageRanges(int) - 类 javax.print.attribute.standard.PageRanges 的构造方法
构造一个包括单个整数的新 PageRanges 属性。
PageRanges(int, int) - 类 javax.print.attribute.standard.PageRanges 的构造方法
构造一个包括单一整数范围的新 PageRanges 属性。
PagesPerMinute - javax.print.attribute.standard 中的 类
PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
PagesPerMinute(int) - 类 javax.print.attribute.standard.PagesPerMinute 的构造方法
构造具有给定整数值的新 PagesPerMinute 属性。
PagesPerMinuteColor - javax.print.attribute.standard 中的 类
PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
PagesPerMinuteColor(int) - 类 javax.print.attribute.standard.PagesPerMinuteColor 的构造方法
构造具有给定整数值的新 PagesPerMinuteColor 属性。
pageUpAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
垂直向上翻页的动作名称。
paint(Graphics) - 类 java.awt.Canvas 中的方法
绘制此 canvas。
paint(Graphics) - 类 java.awt.Component 中的方法
绘制此组件。
paint(Graphics) - 类 java.awt.Container 中的方法
绘制容器。
PAINT - 类 java.awt.event.PaintEvent 中的静态变量
绘制事件类型。
Paint - java.awt 中的 接口
此 Paint 接口定义如何为 Graphics2D 操作生成颜色模式。
paint(Graphics) - 类 javax.swing.CellRendererPane 中的方法
不应调用。
paint(Graphics) - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
绘制面板。
paint(Graphics) - 类 javax.swing.JComponent 中的方法
由 Swing 调用，以绘制组件。
paint(Graphics) - 类 javax.swing.JLayeredPane 中的方法
在指定的图形上下文中绘制此 JLayeredPane。
paint(Graphics) - 类 javax.swing.JViewport 中的方法
通过后备存储绘制图像，或者使用后备存储“位图传送”剩余图像来仅绘制最新暴露的部分，这具体取决于是否启用 backingStore。
paint(Graphics) - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
paint(Graphics) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
使用前景色绘制标签文本，如果标签不透明，则利用背景色绘制整个背景。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
绘制与 Graphics 对象 clipRect 相交的行。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuSeparatorUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
将绘制委托给两种方法之一：paintDeterminate 和 paintIndeterminate。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
绘制单选按钮
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paint(Graphics) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
绘制分隔符。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
传递消息以绘制外观。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
绘制用 installUI() 设置的 table 实例的表示形式。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
绘制界面。
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicToolBarSeparatorUI 中的方法
paint(Graphics) - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
绘制指定组件，使其适合外观。
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalPopupMenuSeparatorUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法
paint(Graphics) - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalSeparatorUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 paint 方法。
paint(Graphics, Shape) - 类 javax.swing.text.AsyncBoxView 中的方法
使用给定的分配和呈现表面呈现该视图。
paint(Graphics, Shape) - 类 javax.swing.text.BoxView 中的方法
使用该面给定的呈现面和区域呈现 BoxView。
paint(Graphics) - 接口 javax.swing.text.Caret 中的方法
呈现插入符。
paint(Graphics, Shape) - 类 javax.swing.text.ComponentView 中的方法
真正的绘制行为自然来源于组件与其父容器（容纳此视图的同一容器）之间的关联。
paint(Graphics) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符作为垂直线呈现。
paint(Graphics, int, int, Shape, JTextComponent) - 类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 中的方法
绘制高亮显示区域。
paint(Graphics) - 类 javax.swing.text.DefaultHighlighter 中的方法
呈现高亮显示区域。
paint(Graphics, Shape) - 类 javax.swing.text.FieldView 中的方法
使用给定呈现面和该表面的区域呈现。
paint(GlyphView, Graphics, Shape, int, int) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
绘制表示给定范围的字形。
paint(Graphics, Shape) - 类 javax.swing.text.GlyphView 中的方法
呈现一部分运行的文本样式。
paint(Graphics, int, int, Shape, JTextComponent) - 接口 javax.swing.text.Highlighter.HighlightPainter 中的方法
呈现高亮显示。
paint(Graphics) - 接口 javax.swing.text.Highlighter 中的方法
呈现高亮显示。
paint(Graphics, Shape) - 类 javax.swing.text.html.BlockView 中的方法
使用给定呈现面和该表面的区域呈现。
paint(Graphics, Shape) - 类 javax.swing.text.html.ImageView 中的方法
绘制 View。
paint(Graphics, Shape) - 类 javax.swing.text.html.ListView 中的方法
使用给定呈现面和该表面的区域呈现。
paint(Graphics, Shape) - 类 javax.swing.text.html.ParagraphView 中的方法
使用给定的呈现面和该面上的区域进行呈现。
paint(Graphics, float, float, float, float, View) - 类 javax.swing.text.html.StyleSheet.BoxPainter 中的方法
根据给定的属性绘制 CSS 框。
paint(Graphics, float, float, float, float, View, int) - 类 javax.swing.text.html.StyleSheet.ListPainter 中的方法
根据给定的属性绘制 CSS 列表装饰。
paint(Graphics, Shape) - 类 javax.swing.text.IconView 中的方法
绘制图标。
paint(Graphics, Shape) - 类 javax.swing.text.ParagraphView 中的方法
使用给定的呈现面和该面上的区域进行呈现。
paint(Graphics, Shape) - 类 javax.swing.text.PlainView 中的方法
使用给定呈现面和该表面的区域呈现。
paint(Graphics, Shape) - 类 javax.swing.text.View 中的方法
使用给定的呈现表面和该表面上的区域来呈现。
paint(Graphics, Shape) - 类 javax.swing.text.WrappedPlainView 中的方法
使用给定的呈现表面和表现上的区域来呈现。
paint(Graphics) - 类 javax.swing.tree.DefaultTreeCellEditor.EditorContainer 中的方法
重写 Container.paint 以绘制节点的图标，并使用选定的背景色。
paint(Graphics) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
绘制值。
PAINT_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择绘制事件的事件掩码。
PAINT_FIRST - 类 java.awt.event.PaintEvent 中的静态变量
标记绘制事件 id 范围中的首个整数 id。
PAINT_LAST - 类 java.awt.event.PaintEvent 中的静态变量
标记绘制事件 id 范围中的最后一个整数 id。
paintAll(Graphics) - 类 java.awt.Component 中的方法
绘制此组件及其所有子组件。
paintArrowButtonBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制箭头按钮的背景。
paintArrowButtonBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制箭头按钮的边框。
paintArrowButtonForeground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制箭头按钮的前景。
paintBackground(Graphics, JMenuItem, Color) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
绘制菜单项的背景。
paintBackground(Graphics) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
绘制视图的背景。
paintBorder(Graphics) - 类 javax.swing.AbstractButton 中的方法
如果 BorderPainted 属性为 true 并且按钮有边框，则绘制该按钮边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.AbstractBorder 中的方法
此默认实现不执行绘制操作。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.BevelBorder 中的方法
按指定的位置和尺寸绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - 接口 javax.swing.border.Border 中的方法
按指定的位置和尺寸绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.CompoundBorder 中的方法
绘制组合边框，方法是先按指定的位置和尺寸绘制外部边框，然后按照外部边框 insets 指定的位置和尺寸偏移量绘制内部边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.EmptyBorder 中的方法
默认情况下不执行绘制。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.EtchedBorder 中的方法
按照指定的位置和尺寸为指定的组件绘制边框
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.LineBorder 中的方法
按照指定的位置和尺寸为指定的组件绘制边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.MatteBorder 中的方法
绘制衬边边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.SoftBevelBorder 中的方法
按照指定的位置和尺寸绘制指定组件的边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.border.TitledBorder 中的方法
按照指定的位置和大小为指定的组件绘制边框。
paintBorder(Graphics) - 类 javax.swing.JComponent 中的方法
绘制组件的边框。
paintBorder(Graphics) - 类 javax.swing.JMenuBar 中的方法
如果 BorderPainted 属性为 true，则绘制菜单栏的边框。
paintBorder(Graphics) - 类 javax.swing.JPopupMenu 中的方法
如果 borderPainted 属性为 true，则绘制弹出菜单的边框。
paintBorder - 类 javax.swing.JProgressBar 中的变量
是否显示围绕进度条的边框。
paintBorder(Graphics) - 类 javax.swing.JProgressBar 中的方法
如果 borderPainted 属性为 true，则绘制进度条的边框。
paintBorder(Graphics) - 类 javax.swing.JToolBar 中的方法
如果 borderPainted 属性为 true，则绘制工具栏边框。
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.MenuBarBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.RadioButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.BorderUIResource 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.ButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.Flush3DBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.InternalFrameBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.MenuBarBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.MenuItemBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.OptionDialogBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.PaletteBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.PopupMenuBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.TableHeaderBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.TextFieldBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder 中的方法
paintBorder(Component, Graphics, int, int, int, int) - 类 javax.swing.plaf.metal.MetalBorders.ToolBarBorder 中的方法
paintBottomTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintButtonBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制按钮的背景。
paintButtonBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制按钮的边框。
paintButtonPressed(Graphics, AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
paintButtonPressed(Graphics, AbstractButton) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
paintButtonPressed(Graphics, AbstractButton) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
paintCell(Graphics, int, Rectangle, ListCellRenderer, ListModel, ListSelectionModel, int) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。
paintCheckBoxBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制复选框的背景。
paintCheckBoxBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制复选框的边框。
paintCheckBoxMenuItemBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制复选框菜单项的背景。
paintCheckBoxMenuItemBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制复选框菜单项的边框。
paintChild(Graphics, Rectangle, int) - 类 javax.swing.text.BoxView 中的方法
绘制一个子级。
paintChild(Graphics, Rectangle, int) - 类 javax.swing.text.html.ListView 中的方法
通过调用 paint() 绘制其中的一个子级。
paintChildren(Graphics) - 类 javax.swing.JComponent 中的方法
绘制此组件的子组件。
paintChildren(Graphics) - 类 javax.swing.JSplitPane 中的方法
通知超类后，UI 通过 finishedPaintingChildren 通知子类，同时绘制边框。
paintChildren(Graphics) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
绘制与剪贴区域相交的子级。
paintColorChooserBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制颜色选择器的背景。
paintColorChooserBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制颜色选择器的边框。
paintComboBoxBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制组合框的背景。
paintComboBoxBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制组合框的边框。
paintComponent(Graphics) - 类 javax.swing.Box.Filler 中的方法
绘制此 Filler。
paintComponent(Graphics) - 类 javax.swing.Box 中的方法
绘制此 Box。
paintComponent(Graphics, Component, Container, int, int, int, int, boolean) - 类 javax.swing.CellRendererPane 中的方法
在图形对象 g 上绘制一个单元格渲染器组件 c。
paintComponent(Graphics, Component, Container, int, int, int, int) - 类 javax.swing.CellRendererPane 中的方法
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
paintComponent(Graphics, Component, Container, Rectangle) - 类 javax.swing.CellRendererPane 中的方法
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
paintComponent(Graphics) - 类 javax.swing.JComponent 中的方法
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。
paintComponent(Graphics) - 类 javax.swing.JInternalFrame 中的方法
重写此方法，以便在拖动内部窗体时允许进行优化的绘制。
paintComponent(Graphics) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
paintComponent(Graphics) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
paintComponent(Graphics) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
paintComponent(Graphics, Component, Container, int, int, int, int) - 类 javax.swing.SwingUtilities 中的静态方法
在指定的 Graphics 上绘制组件。
paintComponent(Graphics, Component, Container, Rectangle) - 类 javax.swing.SwingUtilities 中的静态方法
在指定的 Graphics 上绘制组件。
paintComponents(Graphics) - 类 java.awt.Container 中的方法
绘制此容器中的每个组件。
paintContentBorder(Graphics, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderBottomEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderBottomEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintContentBorderLeftEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderLeftEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintContentBorderRightEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderRightEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintContentBorderTopEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintContentBorderTopEdge(Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
PaintContext - java.awt 中的 接口
PaintContext 接口定义了经过封装和优化的环境，使用此环境可以生成设备空间中的颜色模式，此模式用于在 Graphics2D 上进行填充操作或笔划操作。
paintCurrentValue(Graphics, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
绘制当前所选项。
paintCurrentValue(Graphics, Rectangle, boolean) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
如有必要，绘制当前所选项。
paintCurrentValueBackground(Graphics, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
绘制当前所选项的背景。
paintCurrentValueBackground(Graphics, Rectangle, boolean) - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
如有必要，绘制当前所选项的背景。
paintDecreaseHighlight(Graphics) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paintDesktopIconBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制桌面图标的背景。
paintDesktopIconBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制桌面图标的边框。
paintDesktopPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制桌面窗格的背景。
paintDesktopPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制桌面窗格的边框。
paintDeterminate(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
对几乎所有线性、确定进度条都能正确执行操作的多用途绘制方法。
paintDeterminate(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalProgressBarUI 中的方法
在进度条上绘制少量特殊的高亮显示。
paintDirtyRegions() - 类 javax.swing.RepaintManager 中的方法
绘制被标记为脏的所有组件。
paintDisabledText(JLabel, Graphics, String, int, int) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。
paintDisabledText(JLabel, Graphics, String, int, int) - 类 javax.swing.plaf.metal.MetalLabelUI 中的方法
只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。
paintDragWindow(Graphics) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
绘制用于拖动的窗口的内容。
paintEditorPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制编辑器窗格的背景。
paintEditorPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制编辑器窗格的边框。
paintEnabledText(JLabel, Graphics, String, int, int) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
利用标签的前景色将 clippedText 绘制在 textX、textY 处。
PaintEvent - java.awt.event 中的 类
组件级绘制事件。
PaintEvent(Component, int, Rectangle) - 类 java.awt.event.PaintEvent 的构造方法
构造一个具有指定源组件和类型的 PaintEvent 对象。
paintExpandControl(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制 row 的展开（切换）部分。
paintFileChooserBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文件选择器的背景。
paintFileChooserBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文件选择器的边框。
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
paintFocus(Graphics, Rectangle, Dimension) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
paintFocus(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
paintFocus(Graphics, Rectangle, Dimension) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法
paintFocus(Graphics) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
paintFocusIndicator(Graphics, int, Rectangle[], int, Rectangle, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintFocusIndicator(Graphics, int, Rectangle[], int, Rectangle, Rectangle, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintFormattedTextFieldBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制已格式化文本字段的背景。
paintFormattedTextFieldBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制已格式化文本字段的边框。
paintHighlightBelowTab() - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintHorizontalLabel(Graphics, int, Component) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
为标签表中的每个标签调用此方法。
paintHorizontalLine(Graphics, JComponent, int, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制水平线。
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制支路 (leg) 的水平部分。
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
paintHorizontalSeparators(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
paintIcon(Component, Graphics, int, int) - 接口 javax.swing.Icon 中的方法
在指定位置上绘制图标。
paintIcon(Component, Graphics, int, int) - 类 javax.swing.ImageIcon 中的方法
绘制图标。
paintIcon(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
paintIcon(Graphics, int, int, Icon, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintIcon(Graphics, AbstractButton, Rectangle) - 类 javax.swing.plaf.basic.BasicToggleButtonUI 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.IconUIResource 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalCheckBoxIcon 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalComboBoxIcon 中的方法
绘制 MetalComboBox 的水平条
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.FileIcon16 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon 中的方法
paintIcon(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的方法
paintIcon(Graphics, AbstractButton, Rectangle) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
在空间 iconRect 中绘制按钮 b 的适当图标。
paintImmediately(int, int, int, int) - 类 javax.swing.JComponent 中的方法
立即绘制此组件及其与该区域重叠的子代中的指定区域。
paintImmediately(Rectangle) - 类 javax.swing.JComponent 中的方法
立即绘制指定的区域。
paintIncreaseHighlight(Graphics) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paintIndeterminate(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
对所有线性跳动框进度条都能正确执行操作的多用途绘制方法。
paintIndeterminate(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalProgressBarUI 中的方法
在进度条和跳动框上绘制少量特殊的高亮显示。
paintInternalFrameBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制内部窗体的背景。
paintInternalFrameBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制内部窗体的边框。
paintInternalFrameTitlePaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制内部窗体标题窗格的背景。
paintInternalFrameTitlePaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制内部窗体标题窗格的边框。
paintLabelBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制标签的背景。
paintLabelBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制标签的边框。
paintLabels(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintLayer(Graphics, int, int, Shape, JTextComponent, View) - 类 javax.swing.text.DefaultHighlighter.DefaultHighlightPainter 中的方法
绘制高亮显示的某一部分。
paintLayer(Graphics, int, int, Shape, JTextComponent, View) - 类 javax.swing.text.LayeredHighlighter.LayerPainter 中的方法
paintLayeredHighlights(Graphics, int, int, Shape, JTextComponent, View) - 类 javax.swing.text.DefaultHighlighter 中的方法
当要呈现叶 View （例如，LabelView）时，要调用此方法。
paintLayeredHighlights(Graphics, int, int, Shape, JTextComponent, View) - 类 javax.swing.text.LayeredHighlighter 中的方法
当叶 View（如 LabelView）呈现时，它们应调用此方法。
paintLeftTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintListBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制列表的背景。
paintListBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制列表的边框。
paintLoweredBevel(Component, Graphics, int, int, int, int) - 类 javax.swing.border.BevelBorder 中的方法
paintMajorTickForHorizSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintMajorTickForHorizSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintMajorTickForVertSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintMajorTickForVertSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintMe(Component, Graphics, int, int) - 类 javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon 中的方法
paintMenuBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单的背景。
paintMenuBarBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单栏的背景。
paintMenuBarBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单栏的边框。
paintMenuBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单的边框。
paintMenuItem(Graphics, JComponent, Icon, Icon, Color, Color, int) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
paintMenuItemBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单项的背景。
paintMenuItemBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制菜单项的边框。
paintMinorTickForHorizSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintMinorTickForHorizSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintMinorTickForVertSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintMinorTickForVertSlider(Graphics, Rectangle, int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintOptionPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项窗格的背景。
paintOptionPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项窗格的边框。
paintPalette(Graphics) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
paintPanelBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制面板的背景。
paintPanelBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制面板的边框。
paintPasswordFieldBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制密码字段的背景。
paintPasswordFieldBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制密码字段的边框。
paintPopupMenuBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制弹出菜单的背景。
paintPopupMenuBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制弹出菜单的边框。
paintProgressBarBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的背景。
paintProgressBarBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的背景。
paintProgressBarBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的边框。
paintProgressBarBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的边框。
paintProgressBarForeground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制进度条的前景。
paintRadioButtonBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制单选钮的背景。
paintRadioButtonBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制单选钮的边框。
paintRadioButtonMenuItemBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制单选钮菜单项的背景。
paintRadioButtonMenuItemBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制单选钮菜单项的边框。
paintRaisedBevel(Component, Graphics, int, int, int, int) - 类 javax.swing.border.BevelBorder 中的方法
paintRightTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintRootPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制根窗体的背景。
paintRootPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制根窗体的边框。
paintRow(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制 row 的渲染器部分。
paintSafely(Graphics) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
安全地绘制界面，保证模型不会根据此线程的视图发生更改。
paintScrollBarBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的背景。
paintScrollBarBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的背景。
paintScrollBarBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的边框。
paintScrollBarBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的边框。
paintScrollBarThumbBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的 thumb 的背景。
paintScrollBarThumbBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条的 thumb 的边框。
paintScrollBarTrackBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条滑道的背景。
paintScrollBarTrackBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条滑道的背景。
paintScrollBarTrackBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条滑道的边框。
paintScrollBarTrackBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动条滑道的边框。
paintScrollPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动窗格的背景。
paintScrollPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滚动窗格的边框。
paintSeparatorBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的背景。
paintSeparatorBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的背景。
paintSeparatorBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的边框。
paintSeparatorBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的边框。
paintSeparatorForeground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔符的前景。
paintSliderBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的背景。
paintSliderBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的背景。
paintSliderBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的边框。
paintSliderBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的边框。
paintSliderThumbBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的 thumb 的背景。
paintSliderThumbBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的 thumb 的边框。
paintSliderTrackBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的滑道的背景。
paintSliderTrackBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的滑道的背景。
paintSliderTrackBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的滑道的边框。
paintSliderTrackBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制滑块的滑道的边框。
paintSpinnerBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制 spinner 的背景。
paintSpinnerBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制 spinner 的边框。
paintSplitPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的背景。
paintSplitPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的边框。
paintSplitPaneDividerBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的分隔栏的背景。
paintSplitPaneDividerBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的分隔栏的背景。
paintSplitPaneDividerForeground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制分隔窗格的分隔栏的前景。
paintSplitPaneDragDivider(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
当用户拖动分隔符时，绘制分隔窗格的分隔栏。
paintString - 类 javax.swing.JProgressBar 中的变量
是否在进度条上显示文本的字符串。
paintString(Graphics, int, int, int, int, int, Insets) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
paintTab(Graphics, int, Rectangle[], int, Rectangle, Rectangle) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintTabArea(Graphics, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
在选项卡区域绘制选项卡。
paintTabBackground(Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintTabBackground(Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintTabbedPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的背景。
paintTabbedPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的边框。
paintTabbedPaneContentBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制包含选项卡窗格中所选选项卡内容的区域的背景。
paintTabbedPaneContentBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制包含选项卡窗格中所选选项卡内容的区域的边框。
paintTabbedPaneTabAreaBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡背后区域的背景。
paintTabbedPaneTabAreaBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡背后区域的背景。
paintTabbedPaneTabAreaBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡背后区域的边框。
paintTabbedPaneTabAreaBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡背后区域的边框。
paintTabbedPaneTabBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡的背景。
paintTabbedPaneTabBackground(SynthContext, Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡的背景。
paintTabbedPaneTabBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡的边框。
paintTabbedPaneTabBorder(SynthContext, Graphics, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制选项卡窗格的选项卡的边框。
paintTabBorder(Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
此方法围绕每个选项卡绘制边框。
paintTabBorder(Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintTableBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制表的背景。
paintTableBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制表的边框。
paintTableHeaderBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制表标题的背景。
paintTableHeaderBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制表标题的边框。
paintText(Graphics, JComponent, Rectangle, String) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
paintText(Graphics, AbstractButton, Rectangle, String) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
呈现当前按钮文本的方法。
paintText(Graphics, JMenuItem, Rectangle, String) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
呈现当前菜单项的文本。
paintText(Graphics, int, Font, FontMetrics, int, String, Rectangle, boolean) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
paintText(Graphics, JComponent, Rectangle, String) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
paintText(Graphics, JComponent, Rectangle, String) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
paintText(SynthContext, Graphics, String, Rectangle, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
在指定位置上绘制文本。
paintText(SynthContext, Graphics, String, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
在指定位置上绘制文本。
paintText(SynthContext, Graphics, String, Icon, int, int, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthGraphicsUtils 中的方法
绘制图标和文本。
paintTextAreaBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本区域的背景。
paintTextAreaBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本区域的边框。
paintTextFieldBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本字段的背景。
paintTextFieldBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本字段的边框。
paintTextPaneBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本窗格的背景。
paintTextPaneBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制文本窗格的边框。
paintThumb(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paintThumb(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintThumb(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
paintThumb(Graphics) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintTicks(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintTitleBackground(Graphics) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
从 paintComponent 调用。
paintToggleButtonBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制切换按钮的背景。
paintToggleButtonBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制切换按钮的边框。
paintToolBarBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏的背景。
paintToolBarBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏的背景。
paintToolBarBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏的边框。
paintToolBarBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏的边框。
paintToolBarContentBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏内容区的背景。
paintToolBarContentBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏内容区的背景。
paintToolBarContentBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏内容区的边框。
paintToolBarContentBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏内容区的边框。
paintToolBarDragWindowBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
paintToolBarDragWindowBackground(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
paintToolBarDragWindowBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
paintToolBarDragWindowBorder(SynthContext, Graphics, int, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
paintToolTipBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具提示的背景。
paintToolTipBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制工具提示的边框。
paintTopTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
paintTrack(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
paintTrack(Graphics) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
paintTrack(Graphics, JComponent, Rectangle) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
paintTrack(Graphics) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
paintTreeBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制树的背景。
paintTreeBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制树的边框。
paintTreeCellBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制包含树中某个单元格的行的背景。
paintTreeCellBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制包含树中某个单元格的行的边框。
paintTreeCellFocus(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
当树中某个单元格拥有焦点时，绘制该单元格的焦点指示器。
paintTriangle(Graphics, int, int, int, int, boolean) - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
绘制一个三角形。
paintValue(Graphics, Rectangle) - 接口 java.beans.PropertyEditor 中的方法
在屏幕实际状态给定区域中绘制值的表示形式。
paintValue(Graphics, Rectangle) - 类 java.beans.PropertyEditorSupport 中的方法
在屏幕实际状态给定区域中绘制值的表示形式。
paintVerticalLabel(Graphics, int, Component) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
为标签表中的每个标签调用此方法。
paintVerticalLine(Graphics, JComponent, int, int, int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制垂直线。
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
绘制支路的垂直部分。
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
paintViewportBackground(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制视口的背景。
paintViewportBorder(SynthContext, Graphics, int, int, int, int) - 类 javax.swing.plaf.synth.SynthPainter 中的方法
绘制视口的边框。
PALETTE_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Palette 层的便捷对象。
paletteCloseIcon - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的变量
paletteTitleHeight - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的变量
PAN - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示信号的相对 pan（左右定位）的控件。
Panel - java.awt 中的 类
Panel 是最简单的容器类。
Panel() - 类 java.awt.Panel 的构造方法
使用默认的布局管理器创建新面板。
Panel(LayoutManager) - 类 java.awt.Panel 的构造方法
创建具有指定布局管理器的新面板。
PANEL - 类 javax.accessibility.AccessibleRole 中的静态变量
通常用于对对象进行分组的一般容器。
PANEL - 类 javax.swing.plaf.synth.Region 中的静态变量
Panel 的 region。
Panel.AccessibleAWTPanel - java.awt 中的 类
此类实现 Panel 类的可访问性支持。
Panel.AccessibleAWTPanel() - 类 java.awt.Panel.AccessibleAWTPanel 的构造方法
PANEL_UI - 类 javax.print.ServiceUIFactory 中的静态变量
表示一个作为 AWT 面板实现的 UI。
PanelUI - javax.swing.plaf 中的 类
Panel 的可插入外观界面。
PanelUI() - 类 javax.swing.plaf.PanelUI 的构造方法
Paper - java.awt.print 中的 类
Paper 类描述一张纸的物理特征。
Paper() - 类 java.awt.print.Paper 的构造方法
创建信函大小的一张纸，页边空白为一英寸。
PARA_INDENT_LEFT - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
段落左缩进动作标识符
PARA_INDENT_RIGHT - 类 javax.swing.text.html.HTMLEditorKit 中的静态变量
段落右缩进动作标识符
PARAGRAPH - 类 javax.accessibility.AccessibleRole 中的静态变量
文本段落
PARAGRAPH_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Zp”。
ParagraphElementName - 类 javax.swing.text.AbstractDocument 中的静态变量
用于表示段落的元素名
ParagraphView - javax.swing.text.html 中的 类
显示段落，并使用 css 属性作为其配置。
ParagraphView(Element) - 类 javax.swing.text.html.ParagraphView 的构造方法
构造给定元素的 ParagraphView。
ParagraphView - javax.swing.text 中的 类
存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。
ParagraphView(Element) - 类 javax.swing.text.ParagraphView 的构造方法
创建给定元素的 ParagraphView。
PARAM - 类 javax.swing.text.html.HTML.Tag 中的静态变量
param - 类 javax.swing.text.html.parser.DTD 中的变量
PARAM_IN - 类 org.omg.CORBA.ParameterMode 中的静态变量
PARAM_INOUT - 类 org.omg.CORBA.ParameterMode 中的静态变量
PARAM_OUT - 类 org.omg.CORBA.ParameterMode 中的静态变量
PARAMETER - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
Parameter - org.omg.Dynamic 中的 类
org/omg/Dynamic/Parameter.java。
Parameter() - 类 org.omg.Dynamic.Parameter 的构造方法
Parameter(Any, ParameterMode) - 类 org.omg.Dynamic.Parameter 的构造方法
ParameterBlock - java.awt.image.renderable 中的 类
ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。
ParameterBlock() - 类 java.awt.image.renderable.ParameterBlock 的构造方法
一个 dummy 构造方法。
ParameterBlock(Vector<Object>) - 类 java.awt.image.renderable.ParameterBlock 的构造方法
使用源的给定 Vector 构造一个 ParameterBlock。
ParameterBlock(Vector<Object>, Vector<Object>) - 类 java.awt.image.renderable.ParameterBlock 的构造方法
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。
ParameterDescriptor - java.beans 中的 类
ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。
ParameterDescriptor() - 类 java.beans.ParameterDescriptor 的构造方法
公共默认构造方法。
ParameterizedType - java.lang.reflect 中的 接口
ParameterizedType 表示参数化类型，如 Collection<String>。
ParameterMetaData - java.sql 中的 接口
可用于获取关于 PreparedStatement 对象中每个参数标记的类型和属性信息的对象。
ParameterMode - org.omg.CORBA 中的 类
Parameter 参数模式的枚举。
ParameterMode(int) - 类 org.omg.CORBA.ParameterMode 的构造方法
ParameterModeHelper - org.omg.CORBA 中的 类
Parameter 参数模式的枚举。
ParameterModeHelper() - 类 org.omg.CORBA.ParameterModeHelper 的构造方法
ParameterModeHolder - org.omg.CORBA 中的 类
Parameter 参数模式的枚举。
ParameterModeHolder() - 类 org.omg.CORBA.ParameterModeHolder 的构造方法
ParameterModeHolder(ParameterMode) - 类 org.omg.CORBA.ParameterModeHolder 的构造方法
parameterModeIn - 接口 java.sql.ParameterMetaData 中的静态变量
指示参数模式为 IN 的常量。
parameterModeInOut - 接口 java.sql.ParameterMetaData 中的静态变量
指示参数模式为 INOUT 的常量。
parameterModeOut - 接口 java.sql.ParameterMetaData 中的静态变量
指示参数模式为 OUT 的常量。
parameterModeUnknown - 接口 java.sql.ParameterMetaData 中的静态变量
指示参数模式是未知的常量。
parameterNoNulls - 接口 java.sql.ParameterMetaData 中的静态变量
指示某一参数将不允许使用 NULL 值的常量。
parameterNullable - 接口 java.sql.ParameterMetaData 中的静态变量
指示某一参数将允许使用 NULL 值的常量。
parameterNullableUnknown - 接口 java.sql.ParameterMetaData 中的静态变量
指示不知道某一参数是否可为 null 的常量。
parameters - 类 java.awt.image.renderable.ParameterBlock 中的变量
一个非源参数的 Vector，存储为任意 Object。
params(NVList) - 类 org.omg.CORBA.ServerRequest 中的方法
已过时。 使用方法 arguments
paramString() - 类 java.awt.AWTEvent 中的方法
返回表示此 Event 状态的字符串。
paramString() - 类 java.awt.Button 中的方法
返回此 Button 状态的字符串表示形式。
paramString() - 类 java.awt.Checkbox 中的方法
返回表示此 Checkbox 的状态的字符串。
paramString() - 类 java.awt.CheckboxMenuItem 中的方法
返回表示此 CheckBoxMenuItem 状态的字符串。
paramString() - 类 java.awt.Choice 中的方法
返回表示此 Choice 菜单的状态的字符串。
paramString() - 类 java.awt.Component 中的方法
返回此组件状态的字符串表示形式。
paramString() - 类 java.awt.Container 中的方法
返回表示此 Container 的状态的字符串。
paramString() - 类 java.awt.Dialog 中的方法
返回表示此 dialog 状态的字符串。
paramString() - 类 java.awt.event.ActionEvent 中的方法
返回标识此动作事件的参数字符串。
paramString() - 类 java.awt.event.AdjustmentEvent 中的方法
paramString() - 类 java.awt.event.ComponentEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.ContainerEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.FocusEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.HierarchyEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.InputMethodEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.InvocationEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.ItemEvent 中的方法
返回标识此项事件的参数字符串。
paramString() - 类 java.awt.event.KeyEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.MouseEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.MouseWheelEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.event.PaintEvent 中的方法
paramString() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
paramString() - 类 java.awt.event.TextEvent 中的方法
返回标识此文本事件的参数字符串。
paramString() - 类 java.awt.event.WindowEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 java.awt.FileDialog 中的方法
返回表示此 FileDialog 窗口状态的字符串。
paramString() - 类 java.awt.Frame 中的方法
返回表示此 Frame 状态的字符串。
paramString() - 类 java.awt.Label 中的方法
返回一个表示此 Label 状态的字符串。
paramString() - 类 java.awt.List 中的方法
返回表示此滚动列表状态的参数字符串。
paramString() - 类 java.awt.Menu 中的方法
返回表示此 Menu 状态的字符串。
paramString() - 类 java.awt.MenuComponent 中的方法
返回表示此 MenuComponent 状态的字符串。
paramString() - 类 java.awt.MenuItem 中的方法
返回表示此 MenuItem 状态的字符串。
paramString() - 类 java.awt.MenuShortcut 中的方法
返回表示此 MenuShortcut 状态的参数字符串。
paramString() - 类 java.awt.Scrollbar 中的方法
返回表示此 Scrollbar 当前状态的字符串表示形式。
paramString() - 类 java.awt.ScrollPane 中的方法
返回表示此 ScrollPane 的状态的字符串。
paramString() - 类 java.awt.ScrollPaneAdjustable 中的方法
返回表示此滚动条的状态的字符串。
paramString() - 类 java.awt.TextArea 中的方法
返回表示此 TextArea 状态的字符串。
paramString() - 类 java.awt.TextComponent 中的方法
返回表示此 TextComponent 状态的字符串。
paramString() - 类 java.awt.TextField 中的方法
返回表示此 TextField 状态的字符串。
paramString() - 类 javax.swing.AbstractButton 中的方法
返回此 AbstractButton 的字符串表示形式。
paramString() - 类 javax.swing.event.InternalFrameEvent 中的方法
返回标识此事件的参数字符串。
paramString() - 类 javax.swing.JApplet 中的方法
返回此 JApplet 的字符串表示形式。
paramString() - 类 javax.swing.JButton 中的方法
返回此 JButton 的字符串表示形式。
paramString() - 类 javax.swing.JCheckBox 中的方法
返回此 JCheckBox 的字符串表示形式。
paramString() - 类 javax.swing.JCheckBoxMenuItem 中的方法
返回此 JCheckBoxMenuItem 的字符串表示形式。
paramString() - 类 javax.swing.JColorChooser 中的方法
返回此 JColorChooser 的字符串表示形式。
paramString() - 类 javax.swing.JComboBox 中的方法
返回此 JComboBox 的字符串表示形式。
paramString() - 类 javax.swing.JComponent 中的方法
返回此 JComponent 的字符串表示形式。
paramString() - 类 javax.swing.JDesktopPane 中的方法
返回此 JDesktopPane 的字符串表示形式。
paramString() - 类 javax.swing.JDialog 中的方法
返回此 JDialog 的字符串表示形式。
paramString() - 类 javax.swing.JEditorPane 中的方法
返回此 JEditorPane 的字符串表示形式。
paramString() - 类 javax.swing.JFileChooser 中的方法
返回此 JFileChooser 的字符串表示形式。
paramString() - 类 javax.swing.JFrame 中的方法
返回此 JFrame 的字符串表示形式。
paramString() - 类 javax.swing.JInternalFrame 中的方法
返回此 JInternalFrame 的字符串表示形式。
paramString() - 类 javax.swing.JLabel 中的方法
返回此 JLabel 的字符串表示形式。
paramString() - 类 javax.swing.JLayeredPane 中的方法
返回此 JLayeredPane 的字符串表示形式。
paramString() - 类 javax.swing.JList 中的方法
返回此 JList 的 String 表示形式。
paramString() - 类 javax.swing.JMenu 中的方法
返回此 JMenu 的字符串表示形式。
paramString() - 类 javax.swing.JMenuBar 中的方法
返回此 JMenuBar 的字符串表示形式。
paramString() - 类 javax.swing.JMenuItem 中的方法
返回此 JMenuItem 的字符串表示形式。
paramString() - 类 javax.swing.JOptionPane 中的方法
返回此 JOptionPane 的字符串表示形式。
paramString() - 类 javax.swing.JPanel 中的方法
返回此 JPanel 的字符串表示形式。
paramString() - 类 javax.swing.JPasswordField 中的方法
返回此 JPasswordField 的字符串表示形式。
paramString() - 类 javax.swing.JPopupMenu 中的方法
返回此 JPopupMenu 的字符串表示形式。
paramString() - 类 javax.swing.JProgressBar 中的方法
返回此 JProgressBar 的字符串表示形式。
paramString() - 类 javax.swing.JRadioButton 中的方法
返回此 JRadioButton 的字符串表示形式。
paramString() - 类 javax.swing.JRadioButtonMenuItem 中的方法
返回此 JRadioButtonMenuItem 的字符串表示形式。
paramString() - 类 javax.swing.JRootPane 中的方法
返回此 JRootPane 的字符串表示形式。
paramString() - 类 javax.swing.JScrollBar 中的方法
返回此 JScrollBar 的字符串表示形式。
paramString() - 类 javax.swing.JScrollPane 中的方法
返回此 JScrollPane 的字符串表示形式。
paramString() - 类 javax.swing.JSeparator 中的方法
返回表示此 JSeparator 的一个字符串。
paramString() - 类 javax.swing.JSlider 中的方法
返回此 JSlider 的字符串表示形式。
paramString() - 类 javax.swing.JSplitPane 中的方法
返回此 JSplitPane 的字符串表示形式。
paramString() - 类 javax.swing.JTabbedPane 中的方法
返回此 JTabbedPane 的字符串表示。
paramString() - 类 javax.swing.JTable 中的方法
返回此表的字符串表示形式。
paramString() - 类 javax.swing.JTextArea 中的方法
返回此 JTextArea 的字符串表示形式。
paramString() - 类 javax.swing.JTextField 中的方法
返回此 JTextField 的字符串表示形式。
paramString() - 类 javax.swing.JTextPane 中的方法
返回此 JTextPane 的字符串表示形式。
paramString() - 类 javax.swing.JToggleButton 中的方法
返回此 JToggleButton 的字符串表示形式。
paramString() - 类 javax.swing.JToolBar 中的方法
返回此 JToolBar 的字符串表示形式。
paramString() - 类 javax.swing.JToolTip 中的方法
返回此 JToolTip 的字符串表示形式。
paramString() - 类 javax.swing.JTree 中的方法
返回此 JTree 的字符串表示形式。
paramString() - 类 javax.swing.JViewport 中的方法
返回此 JViewport 的字符串表示形式。
paramString() - 类 javax.swing.JWindow 中的方法
返回此 JWindow 的字符串表示形式。
paramString() - 类 javax.swing.table.JTableHeader 中的方法
返回此 JTableHeader 的字符串表示形式。
paramString() - 类 javax.swing.text.JTextComponent 中的方法
返回此 JTextComponent 的字符串表示形式。
parent - 类 java.awt.image.Raster 中的变量
此 Raster 的父 Raster，或者为 null。
parent() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.parent() 中的规范实现 parent 方法。
parent() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点的父节点；如果此为根，则返回 null。
parent - 类 java.util.ResourceBundle 中的变量
此包的父包。
parent - 类 javax.swing.tree.DefaultMutableTreeNode 中的变量
此节点的父节点，如果此节点没有父节点，则为 null
parent() - 类 org.omg.CORBA.Context 中的方法
检索此 Context 对象的父对象。
PARENT_CHANGED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示 HIERARCHY_CHANGED 事件是通过 reparenting 操作生成的。
PARENT_WINDOW_OF - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个对象的父窗口。
PARENT_WINDOW_OF_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 PARENT_WINDOW_OF 关系已更改。
parentOf(ThreadGroup) - 类 java.lang.ThreadGroup 中的方法
测试此线程组是否为线程组参数或其祖先线程组之一。
parentTag - 类 javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction 中的变量
要在文档中检查的 Tag。
park(Object) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，在许可可用之前禁用当前线程。
park() - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，禁用当前线程，除非许可可用。
parkNanos(Object, long) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，在许可可用前禁用当前线程，并最多等待指定的等待时间。
parkNanos(long) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度禁用当前线程，最多等待指定的等待时间，除非许可可用。
parkUntil(Object, long) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，在指定的时限前禁用当前线程，除非许可可用。
parkUntil(long) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
为了线程调度，在指定的时限前禁用当前线程，除非许可可用。
parse(String) - 类 java.net.HttpCookie 中的静态方法
根据 set-cookie 或 set-cookie2 头字符串构造 cookie。
parse(String, ParsePosition) - 类 java.text.ChoiceFormat 中的方法
解析输入文本中的一个 Number。
parse(String) - 类 java.text.DateFormat 中的方法
从给定字符串的开始解析文本，以生成一个日期。
parse(String, ParsePosition) - 类 java.text.DateFormat 中的方法
根据给定的解析位置开始解析日期/时间字符串。
parse(String, ParsePosition) - 类 java.text.DecimalFormat 中的方法
解析字符串中的文本，以生成一个 Number。
parse(String, ParsePosition) - 类 java.text.MessageFormat 中的方法
解析字符串。
parse(String) - 类 java.text.MessageFormat 中的方法
从给定字符串的开始位置解析文本，以生成一个对象数组。
parse(String, ParsePosition) - 类 java.text.NumberFormat 中的方法
如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。
parse(String) - 类 java.text.NumberFormat 中的方法
解析给定字符串开头的文本，生成一个数值。
parse(String, ParsePosition) - 类 java.text.SimpleDateFormat 中的方法
解析字符串的文本，生成 Date。
parse(String) - 类 java.util.Date 中的静态方法
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
parse(String) - 类 java.util.logging.Level 中的静态方法
将级别名称字符串解析成 Level。
parse(String) - 类 javax.activation.MimeTypeParameterList 中的方法
将参数列表从一个 String 解析出来的例程。
parse(String) - 接口 javax.naming.NameParser 中的方法
将某一名称解析成其组件。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - 类 javax.swing.text.html.HTMLEditorKit.Parser 中的方法
解析给定的流并通过解析的结果驱动给定的回调。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - 类 javax.swing.text.html.parser.DocumentParser 中的方法
parse(Reader) - 类 javax.swing.text.html.parser.Parser 中的方法
在给定 DTD 的情况下，解析 HTML 流。
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - 类 javax.swing.text.html.parser.ParserDelegator 中的方法
parse(InputStream) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(InputStream, String) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(String) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(File) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(InputSource) - 类 javax.xml.parsers.DocumentBuilder 中的方法
将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
parse(InputStream, HandlerBase) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
parse(InputStream, HandlerBase, String) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
parse(InputStream, DefaultHandler) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
parse(InputStream, DefaultHandler, String) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
parse(String, HandlerBase) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
parse(String, DefaultHandler) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
parse(File, HandlerBase) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将指定文件的内容解析为 XML。
parse(File, DefaultHandler) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
parse(InputSource, HandlerBase) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
parse(InputSource, DefaultHandler) - 类 javax.xml.parsers.SAXParser 中的方法
使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
parse(LSInput) - 接口 org.w3c.dom.ls.LSParser 中的方法
从通过 LSInput 标识的资源中解析 XML 文档。
parse(String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
解析 XML 文档。
parse(InputSource) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
解析 XML 文档。
parse(InputSource) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
解析一个文档。
parse(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
解析一个文档。
parse(String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
解析文档。
parse(InputSource) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
解析文档。
parse(InputSource) - 接口 org.xml.sax.Parser 中的方法
已过时。 解析 XML 文档。
parse(String) - 接口 org.xml.sax.Parser 中的方法
已过时。 从系统标识符 (URI) 解析 XML 文档。
parse(InputSource) - 接口 org.xml.sax.XMLReader 中的方法
解析 XML 文档。
parse(String) - 接口 org.xml.sax.XMLReader 中的方法
从系统标识符 (URI) 解析 XML 文档。
PARSE_ERR - 异常 org.w3c.dom.ls.LSException 中的静态变量
如果尝试使用 LSParser 加载文档或 XML 片段并且处理已经停止。
parseAnySimpleType(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
返回包含简单类型的词汇表示形式的字符串。
parseAnySimpleType(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
返回包含简单类型的词汇表示形式的字符串。
parseBase64Binary(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个字节数组。
parseBase64Binary(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个字节数组。
parseBoolean(String) - 类 java.lang.Boolean 中的静态方法
将字符串参数解析为 boolean 值。
parseBoolean(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 boolean 值。
parseBoolean(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 boolean 值。
parseBuffer - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的变量
parseByte(String) - 类 java.lang.Byte 中的静态方法
将 string 参数解析为有符号的十进制 byte。
parseByte(String, int) - 类 java.lang.Byte 中的静态方法
将 string 参数解析为一个有符号的 byte，其基数由第二个参数指定。
parseByte(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 byte 值。
parseByte(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 byte 值。
ParseConversionEvent - javax.xml.bind 中的 接口
此事件指示将 XML 数据中的字符串转换为目标 Java 数据类型的值时遇到一个问题。
ParseConversionEventImpl - javax.xml.bind.helpers 中的 类
ParseConversionEvent 接口的默认实现。
ParseConversionEventImpl(int, String, ValidationEventLocator) - 类 javax.xml.bind.helpers.ParseConversionEventImpl 的构造方法
创建新的 ParseConversionEventImpl。
ParseConversionEventImpl(int, String, ValidationEventLocator, Throwable) - 类 javax.xml.bind.helpers.ParseConversionEventImpl 的构造方法
创建新的 ParseConversionEventImpl。
parseDate(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 Calendar 值。
parseDate(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 Calendar 值。
parseDateTime(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 Calendar 值。
parseDateTime(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 Calendar 值。
parseDecimal(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 BigDecimal 值。
parseDecimal(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 BigDecimal 值。
parseDouble(String) - 类 java.lang.Double 中的静态方法
返回一个新的 double 值，该值被初始化为用指定 String 表示的值，这与 Double 类的 valueOf 方法一样。
parseDouble(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 double 值。
parseDouble(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 double 值。
parseDTDMarkup() - 类 javax.swing.text.html.parser.Parser 中的方法
解析 Document Type Declaration 标记声明。
ParseException - java.text 中的 异常
表示解析时出现意外错误。
ParseException(String, int) - 异常 java.text.ParseException 的构造方法
构造带指定详细消息和偏移量的 ParseException。
parseFloat(String) - 类 java.lang.Float 中的静态方法
返回一个新的 float 值，该值被初始化为用指定 String 表示的值，这与 Float 类的 valueOf 方法一样。
parseFloat(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 float 值。
parseFloat(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 float 值。
parseHexBinary(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个字节数组。
parseHexBinary(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个字节数组。
parseInt(String, int) - 类 java.lang.Integer 中的静态方法
使用第二个参数指定的基数，将字符串参数解析为有符号的整数。
parseInt(String) - 类 java.lang.Integer 中的静态方法
将字符串参数作为有符号的十进制整数进行解析。
parseInt(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 int 值。
parseInt(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 int 值。
parseInteger(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 BigInteger 值。
parseInteger(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 BigInteger 值。
parseLevel(String) - 类 java.rmi.server.LogStream 中的静态方法
已过时。 无替代版本
parseLong(String, int) - 类 java.lang.Long 中的静态方法
将 string 参数解析为有符号的 long，基数由第二个参数指定。
parseLong(String) - 类 java.lang.Long 中的静态方法
将 string 参数解析为有符号十进制 long。
parseLong(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 long 值。
parseLong(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 long 值。
parseMarkupDeclarations(StringBuffer) - 类 javax.swing.text.html.parser.Parser 中的方法
解析标记声明。
parseNumbers() - 类 java.io.StreamTokenizer 中的方法
指定此标记生成器应解析的数字。
parseObject(String, ParsePosition) - 类 java.text.DateFormat 中的方法
解析字符串中的文本，以生成一个 Date。
parseObject(String, ParsePosition) - 类 java.text.Format 中的方法
解析字符串文本，生成一个对象。
parseObject(String) - 类 java.text.Format 中的方法
从给定字符串的开始处解析文本以生成一个对象。
parseObject(String, ParsePosition) - 类 java.text.MessageFormat 中的方法
解析字符串文本，生成一个对象数组。
parseObject(String, ParsePosition) - 类 java.text.NumberFormat 中的方法
解析字符串中的文本，以生成一个 Number。
ParsePosition - java.text 中的 类
ParsePosition 是 Format 及其子类所使用的简单类，用来在解析过程中跟踪当前位置。
ParsePosition(int) - 类 java.text.ParsePosition 的构造方法
创建一个具有给定初始索引的新 ParsePosition。
parseQName(String, NamespaceContext) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 byte 值。
parseQName(String, NamespaceContext) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 QName 值。
Parser - javax.swing.text.html.parser 中的 类
一个简单的 DTD 驱动的 HTML 解析器。
Parser(DTD) - 类 javax.swing.text.html.parser.Parser 的构造方法
Parser - org.xml.sax 中的 接口
已过时。 此接口已经被 SAX2 XMLReader 接口取代，后者包括名称空间支持。
ParserAdapter - org.xml.sax.helpers 中的 类
将 SAX1 Parser 适配为 SAX2 XMLReader。
ParserAdapter() - 类 org.xml.sax.helpers.ParserAdapter 的构造方法
构造一个新解析器适配器。
ParserAdapter(Parser) - 类 org.xml.sax.helpers.ParserAdapter 的构造方法
构造一个新的解析器适配器。
ParserConfigurationException - javax.xml.parsers 中的 异常
指示一个严重的配置错误。
ParserConfigurationException() - 异常 javax.xml.parsers.ParserConfigurationException 的构造方法
创建一个新的不带详细消息的 ParserConfigurationException。
ParserConfigurationException(String) - 异常 javax.xml.parsers.ParserConfigurationException 的构造方法
创建一个新的 ParserConfigurationException，并将 String 指定为一个错误消息。
ParserDelegator - javax.swing.text.html.parser 中的 类
负责每次在调用其 parse 方法时启动一个新的 DocumentParser。
ParserDelegator() - 类 javax.swing.text.html.parser.ParserDelegator 的构造方法
ParserFactory - org.xml.sax.helpers 中的 类
已过时。 此类与不推荐使用的 Parser 接口一起使用。
parseServerAuthority() - 类 java.net.URI 中的方法
尝试将此 URI 的授权组成部分（如果已定义）解析为用户信息、主机和端口组成部分。
parseShort(String) - 类 java.lang.Short 中的静态方法
将字符串参数解析为有符号的十进制 short。
parseShort(String, int) - 类 java.lang.Short 中的静态方法
将字符串参数解析为由第二个参数指定的基数中的有符号的 short。
parseShort(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 short 值。
parseShort(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 short 值。
parseString(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将词汇 XSD 字符串参数转换为一个 String 值。
parseString(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个字符串。
parseTime(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 Calendar 值。
parseTime(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 Calendar 值。
parseUnsignedInt(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 long 值。
parseUnsignedInt(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 long 值。
parseUnsignedShort(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个 int 值。
parseUnsignedShort(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个 int 值。
parseURI(String) - 接口 org.w3c.dom.ls.LSParser 中的方法
从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。
parseURL(URL, String, int, int) - 类 java.net.URLStreamHandler 中的方法
将 URL 的字符表示形式解析为 URL 对象。
parseWithContext(LSInput, Node, short) - 接口 org.w3c.dom.ls.LSParser 中的方法
从通过 LSInput 标识的资源中解析 XML 片段，并将其内容插入到用 context 和 action 参数指定的位置的现有文档。
PartialResultException - javax.naming 中的 异常
抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
PartialResultException(String) - 异常 javax.naming.PartialResultException 的构造方法
使用指定的解释消息构造一个新的异常实例。
PartialResultException() - 异常 javax.naming.PartialResultException 的构造方法
构造一个新的 PartialResultException 实例。
PASS - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "pass"，某些属性的可能值。
PASS_FILE_PFX - 接口 java.util.jar.Pack200.Packer 中的静态变量
指出文件应该按字节传递（无压缩）。
passComplete(ImageReader, BufferedImage) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告当前读操作已经完成一个逐步传递。
passStarted(ImageReader, BufferedImage, int, int, int, int, int, int, int, int[]) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告当前的读操作将开始逐步传递 (progressive pass)。
PASSWORD_FIELD - 类 javax.swing.plaf.synth.Region 中的静态变量
PasswordField 的 region。
PASSWORD_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
标准属性：用于验证的密码。
PASSWORD_TEXT - 类 javax.accessibility.AccessibleRole 中的静态变量
用于密码或文本内容不显示给用户的其他地方的文本对象。
PasswordAuthentication - java.net 中的 类
PasswordAuthentication 类是供 Authenticator 使用的数据持有者。
PasswordAuthentication(String, char[]) - 类 java.net.PasswordAuthentication 的构造方法
根据给定用户名和密码创建新的 PasswordAuthentication 对象。
PasswordCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。
PasswordCallback(String, boolean) - 类 javax.security.auth.callback.PasswordCallback 的构造方法
构造带提示和布尔值的 PasswordCallback，该布尔值指定键入密码时是否应该显示该密码。
PasswordView - javax.swing.text 中的 类
实现适用于 JPasswordField UI 实现的视图。
PasswordView(Element) - 类 javax.swing.text.PasswordView 的构造方法
构造在元素上包装的新视图。
paste(int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
将系统剪贴板中的文本粘贴到文本的指定索引开始处。
paste(int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
将系统剪贴板中的文本粘贴到指定文本的文件开始处。
paste(int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
将系统剪贴板中的文本粘贴到指定索引的文本开始处。
paste() - 类 javax.swing.text.JTextComponent 中的方法
将系统剪贴板的内容传输到关联的文本模型中。
pasteAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将系统剪贴板内容粘贴到选定区域、如果未选中任何内容，则粘贴到插入符之前的动作名称。
Patch - javax.sound.midi 中的 类
一个 Patch 对象，用于表示 MIDI 合成器上的某个位置，其中存储（加载）了单个乐器。
Patch(int, int) - 类 javax.sound.midi.Patch 的构造方法
从指定的库和程序号构造一个新的 patch 对象。
path - 类 javax.swing.event.TreeExpansionEvent 中的变量
到达此事件表示的值的路径。
path - 类 javax.swing.event.TreeModelEvent 中的变量
到达已更改节点的父节点的路径。
Path2D - java.awt.geom 中的 类
Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。
Path2D.Double - java.awt.geom 中的 类
Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
Path2D.Double() - 类 java.awt.geom.Path2D.Double 的构造方法
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的双精度空 Path2D 对象。
Path2D.Double(int) - 类 java.awt.geom.Path2D.Double 的构造方法
根据指定旋绕规则构造一个新的双精度空 Path2D 对象，以控制需要定义路径内部的操作。
Path2D.Double(int, int) - 类 java.awt.geom.Path2D.Double 的构造方法
根据指定旋绕规则和指定初始容量构造一个新的双精度空 Path2D 对象，以存储路径段。
Path2D.Double(Shape) - 类 java.awt.geom.Path2D.Double 的构造方法
根据任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Double(Shape, AffineTransform) - 类 java.awt.geom.Path2D.Double 的构造方法
根据由 AffineTransform 对象变换的任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Float - java.awt.geom 中的 类
Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
Path2D.Float() - 类 java.awt.geom.Path2D.Float 的构造方法
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的单精度空 Path2D 对象。
Path2D.Float(int) - 类 java.awt.geom.Path2D.Float 的构造方法
根据指定旋绕规则构造一个新的单精度空 Path2D 对象，以控制需要定义路径内部的操作。
Path2D.Float(int, int) - 类 java.awt.geom.Path2D.Float 的构造方法
根据指定旋绕规则和指定初始容量构造一个新的单精度空 Path2D 对象，以存储路径段。
Path2D.Float(Shape) - 类 java.awt.geom.Path2D.Float 的构造方法
根据任意 Shape 对象构造一个新的单精度 Path2D 对象。
Path2D.Float(Shape, AffineTransform) - 类 java.awt.geom.Path2D.Float 的构造方法
根据 AffineTransform 对象变换的任意 Shape 对象构造一个新的单精度 Path2D 对象。
PATH_INFO - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：请求路径信息
pathByAddingChild(Object) - 类 javax.swing.tree.TreePath 中的方法
返回包含此对象的所有元素加上 child 的新路径。
pathFromAncestorEnumeration(TreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回沿着从 ancestor 到此节点的路径的一个枚举。
PathIterator - java.awt.geom 中的 接口
PathIterator 接口通过允许调用者一次一段地获取边界的路径，为实现 Shape 接口的对象提供返回其边界几何形状的机制。
paths - 类 javax.swing.event.TreeSelectionEvent 中的变量
此事件表示的路径。
pathSeparator - 类 java.io.File 中的静态变量
与系统有关的路径分隔符，为了方便，它被表示为一个字符串。
pathSeparatorChar - 类 java.io.File 中的静态变量
与系统有关的路径分隔符。
pathToPoint(Point2D, boolean, Point2D) - 类 java.awt.font.LayoutPath 中的方法
将相对于路径的位置转换为用户坐标中的点。
pathWasCollapsed(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
在折叠 VisibleTreeNode 后，从其传递消息。
pathWasExpanded(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
在展开 VisibleTreeNode 后，从其传递消息。
pattern() - 类 java.util.regex.Matcher 中的方法
返回由此匹配器解释的模式。
Pattern - java.util.regex 中的 类
正则表达式的编译表示形式。
pattern() - 类 java.util.regex.Pattern 中的方法
返回在其中编译过此模式的正则表达式。
PatternSyntaxException - java.util.regex 中的 异常
抛出未经检查的异常，表明正则表达式模式中的语法错误。
PatternSyntaxException(String, String, int) - 异常 java.util.regex.PatternSyntaxException 的构造方法
构造此类的新实例。
PAUSE - 类 java.awt.Event 中的静态变量
Pause 键，一个非 ASCII 操作键。
PAUSED - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
已经暂停了打印机并且打印机的 PrinterState 为 STOPPED。
PBEKey - javax.crypto.interfaces 中的 接口
调用者 PBE 密钥接口。
PBEKeySpec - javax.crypto.spec 中的 类
可随同基于密码的加密法 (PBE) 使用的供用户选择的密码。
PBEKeySpec(char[]) - 类 javax.crypto.spec.PBEKeySpec 的构造方法
带有一个密码的构造方法。
PBEKeySpec(char[], byte[], int, int) - 类 javax.crypto.spec.PBEKeySpec 的构造方法
带有生成可变密钥大小的 PBE 密码的 PBEKey 时使用的一个密码、salt、迭代计数以及导出密钥长度的构造方法。
PBEKeySpec(char[], byte[], int) - 类 javax.crypto.spec.PBEKeySpec 的构造方法
带有生成固定密钥大小的 PBE 密码的 PBEKey 时使用的一个密码、salt、迭代数的构造方法。
PBEParameterSpec - javax.crypto.spec 中的 类
此类指定随同以密码为基础的加密法 (PBE) 使用的参数集合，该加密法在 PKCS #5 标准中定义。
PBEParameterSpec(byte[], int) - 类 javax.crypto.spec.PBEParameterSpec 的构造方法
为 PKCS #5 标准中所定义的基于密码的加密法构造一个参数集合。
pcdata - 类 javax.swing.text.html.parser.DTD 中的变量
PCL - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
PCL - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
PCL - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
PCM_SIGNED - 类 javax.sound.sampled.AudioFormat.Encoding 中的静态变量
指定有符号的线性 PCM 数据。
PCM_UNSIGNED - 类 javax.sound.sampled.AudioFormat.Encoding 中的静态变量
指定无符号的线性 PCM 数据。
pcSupport - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
与此 BeanContextChildSupport 相关联的 PropertyChangeSupport。
PDF - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
PDF - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
PDF - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
PDLOverrideSupported - javax.print.attribute.standard 中的 类
PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
PDLOverrideSupported(int) - 类 javax.print.attribute.standard.PDLOverrideSupported 的构造方法
构造具有给定整数值的新 PDLOverrideSupported 枚举值。
peek(InetAddress) - 类 java.net.DatagramSocketImpl 中的方法
查看包来自哪里。
peek() - 类 java.util.ArrayDeque 中的方法
获取，但不移除此双端队列所表示的队列的头；如果此双端队列为空，则返回 null。
peek() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
peek() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
peek() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
peek() - 类 java.util.concurrent.DelayQueue 中的方法
获取但不移除此队列的头部；如果此队列为空，则返回 null。
peek() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
peek() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
peek() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
peek() - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 null。
peek() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
peek() - 类 java.util.LinkedList 中的方法
获取但不移除此列表的头（第一个元素）。
peek() - 类 java.util.PriorityQueue 中的方法
peek() - 接口 java.util.Queue 中的方法
获取但不移除此队列的头；如果此队列为空，则返回 null。
peek() - 类 java.util.Stack 中的方法
查看堆栈顶部的对象，但不从堆栈中移除它。
peek() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
peek() - 接口 javax.xml.stream.XMLEventReader 中的方法
检查下一个 XMLEvent，但不从流中读取它。
peekData(DatagramPacket) - 类 java.net.DatagramSocketImpl 中的方法
查看包来自哪里。
peekEvent() - 类 java.awt.EventQueue 中的方法
返回 EventQueue 上的第一个事件，而不移除它。
peekEvent(int) - 类 java.awt.EventQueue 中的方法
返回指定 id（如果有） 的第一个事件。
peekFirst() - 类 java.util.ArrayDeque 中的方法
peekFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
peekFirst() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
peekFirst() - 类 java.util.LinkedList 中的方法
获取但不移除此列表的第一个元素；如果此列表为空，则返回 null。
peekLast() - 类 java.util.ArrayDeque 中的方法
peekLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
peekLast() - 接口 java.util.Deque 中的方法
获取，但不移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
peekLast() - 类 java.util.LinkedList 中的方法
获取但不移除此列表的最后一个元素；如果此列表为空，则返回 null。
PENDING - 类 javax.print.attribute.standard.JobState 中的静态变量
作业为要开始处理的候选作业，但尚未开始处理。
PENDING_HELD - 类 javax.print.attribute.standard.JobState 中的静态变量
由于某些原因，作业不是要处理的候选作业，但当这些原因不再存在时，作业将返回 PENDING 状态。
PERCENT - 类 java.text.NumberFormat.Field 中的静态变量
标识百分数字段的常量。
perform_work() - 类 org.omg.CORBA.ORB 中的方法
如果该操作由主线程调用，则执行与实现有关的单元操作。
performDefaultLayout() - 类 java.awt.font.GlyphVector 中的方法
为此 GlyphVector 中的每个字形分配默认位置。
PERMILLE - 类 java.text.NumberFormat.Field 中的静态变量
标识千分数字段的常量。
Permission - java.security.acl 中的 接口
此接口表示一个权限，比如授予访问资源的特定类型的权限。
Permission - java.security 中的 类
表示访问系统资源的抽象类。
Permission(String) - 类 java.security.Permission 的构造方法
构造具有指定名称的权限。
PermissionCollection - java.security 中的 类
表示 Permission 对象集合的抽象类。
PermissionCollection() - 类 java.security.PermissionCollection 的构造方法
permissions() - 接口 java.security.acl.AclEntry 中的方法
返回此 ACL 项中各个权限的枚举。
Permissions - java.security 中的 类
此类表示一个不同种类的 Permission 集合。
Permissions() - 类 java.security.Permissions 的构造方法
创建一个不包含任何 PermissionCollection 的新 Permissions 对象。
PERSIST - 类 javax.swing.JFormattedTextField 中的静态变量
标识丢失焦点时，应该保留编辑值的常量。
PERSIST_STORE - org.omg.CORBA 中的 异常
此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
PERSIST_STORE() - 异常 org.omg.CORBA.PERSIST_STORE 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 PERSIST_STORE 异常。
PERSIST_STORE(String) - 异常 org.omg.CORBA.PERSIST_STORE 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 PERSIST_STORE 异常。
PERSIST_STORE(int, CompletionStatus) - 异常 org.omg.CORBA.PERSIST_STORE 的构造方法
使用指定次要代码和完成状态构造一个 PERSIST_STORE 异常。
PERSIST_STORE(String, int, CompletionStatus) - 异常 org.omg.CORBA.PERSIST_STORE 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 PERSIST_STORE 异常。
PersistenceDelegate - java.beans 中的 类
PersistenceDelegate 类负责根据类的公共 API 中的方法表示给定类的实例状态。
PersistenceDelegate() - 类 java.beans.PersistenceDelegate 的构造方法
PERSISTENT - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态变量
PersistentMBean - javax.management 中的 接口
此类是一个由希望是持久性的 MBean 实现的接口。
PERSONAL - 类 java.awt.PageAttributes.MediaType 中的静态变量
PERSONAL_ENVELOPE 的别名。
PERSONAL_ENVELOPE - 类 java.awt.PageAttributes.MediaType 中的静态变量
6 3/4 envelope (3 5/8 x 6 1/2 in) 的 MediaType 实例。
PERSONAL_ENVELOPE - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 Personal 信封尺寸，3.625 inch × 6.5 inch。
PERSONAL_ENVELOPE - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
私人信封尺寸。
PGDN - 类 java.awt.Event 中的静态变量
Page Down 键，一个非 ASCII 操作键。
PGPData - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML PGPData 元素的表示形式。
PGUP - 类 java.awt.Event 中的静态变量
Page Up 键，一个非 ASCII 操作键。
PhantomReference<T> - java.lang.ref 中的 类
虚引用对象，在回收器确定其指示对象可另外回收之后，被加入队列。
PhantomReference(T, ReferenceQueue<? super T>) - 类 java.lang.ref.PhantomReference 的构造方法
创建一个引用给定对象的新的虚引用，并向给定队列注册它。
PHONETIC_EXTENSIONS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Phonetic Extensions”Unicode 字符块的常量。
PHYSICAL - 类 java.awt.PageAttributes.OriginType 中的静态变量
用于指定物理原点的 OriginType 实例。
PI - 类 java.lang.Math 中的静态变量
比任何其他值都更接近 pi（即圆的周长与直径之比）的 double 值。
PI - 类 java.lang.StrictMath 中的静态变量
比任何其他值都更接近 pi（即圆的周长与直径之比）的 double 值。
PI - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
PI_DISABLE_OUTPUT_ESCAPING - 接口 javax.xml.transform.Result 中的静态变量
如果结果树禁用了输出转义，则为发送处理指令的名称。
PI_ENABLE_OUTPUT_ESCAPING - 接口 javax.xml.transform.Result 中的静态变量
如果结果树在已接收 PI_DISABLE_OUTPUT_ESCAPING 处理指令后的某时刻启用了输出转义，则发送处理指令的名称。
PIE - 类 java.awt.geom.Arc2D 中的静态变量
闭合类型，用于通过从弧段的起始点到完整椭圆的中心，再从圆心到弧段的结束点画直线来闭合的弧。
pink - 类 java.awt.Color 中的静态变量
粉红色。
PINK - 类 java.awt.Color 中的静态变量
粉红色。
Pipe - java.nio.channels 中的 类
实现单向管道传送的通道对。
Pipe() - 类 java.nio.channels.Pipe 的构造方法
初始化此类的一个新实例。
Pipe.SinkChannel - java.nio.channels 中的 类
表示 Pipe 的可写入结尾的通道。
Pipe.SinkChannel(SelectorProvider) - 类 java.nio.channels.Pipe.SinkChannel 的构造方法
初始化此类的一个新实例。
Pipe.SourceChannel - java.nio.channels 中的 类
表示 Pipe 的可读取结尾的通道。
Pipe.SourceChannel(SelectorProvider) - 类 java.nio.channels.Pipe.SourceChannel 的构造方法
构造此类的一个新实例。
PIPE_SIZE - 类 java.io.PipedInputStream 中的静态变量
管道循环输入缓冲区的默认大小。
PipedInputStream - java.io 中的 类
管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。
PipedInputStream(PipedOutputStream) - 类 java.io.PipedInputStream 的构造方法
创建 PipedInputStream，使其连接到管道输出流 src。
PipedInputStream(PipedOutputStream, int) - 类 java.io.PipedInputStream 的构造方法
创建一个 PipedInputStream，使其连接到管道输出流 src，并对管道缓冲区使用指定的管道大小。
PipedInputStream() - 类 java.io.PipedInputStream 的构造方法
创建尚未连接的 PipedInputStream。
PipedInputStream(int) - 类 java.io.PipedInputStream 的构造方法
创建一个尚未连接的 PipedInputStream，并对管道缓冲区使用指定的管道大小。
PipedOutputStream - java.io 中的 类
可以将管道输出流连接到管道输入流来创建通信管道。
PipedOutputStream(PipedInputStream) - 类 java.io.PipedOutputStream 的构造方法
创建连接到指定管道输入流的管道输出流。
PipedOutputStream() - 类 java.io.PipedOutputStream 的构造方法
创建尚未连接到管道输入流的管道输出流。
PipedReader - java.io 中的 类
传送的字符输入流。
PipedReader(PipedWriter) - 类 java.io.PipedReader 的构造方法
创建连接到传送 writer src 的 PipedReader。
PipedReader(PipedWriter, int) - 类 java.io.PipedReader 的构造方法
创建一个 PipedReader，使其连接到管道 writer src，并对管道缓冲区使用指定的管道大小。
PipedReader() - 类 java.io.PipedReader 的构造方法
创建尚未连接的 PipedReader。
PipedReader(int) - 类 java.io.PipedReader 的构造方法
创建一个尚未连接的 PipedReader，并对管道缓冲区使用指定的管道大小。
PipedWriter - java.io 中的 类
传送的字符输出流。
PipedWriter(PipedReader) - 类 java.io.PipedWriter 的构造方法
创建传送 writer，使其连接到指定的传送 reader。
PipedWriter() - 类 java.io.PipedWriter 的构造方法
创建一个尚未连接到传送 reader 的传送 writer。
PITCH_BEND - 类 javax.sound.midi.ShortMessage 中的静态变量
PITCH_BEND 消息的命令值（0xE0 或 224）
pixel_bits - 类 java.awt.image.ColorModel 中的变量
像素总位数。
PixelGrabber - java.awt.image 中的 类
PixelGrabber 类实现可以附加在 Image 或 ImageProducer 对象上获得图像像素子集的 ImageConsumer。
PixelGrabber(Image, int, int, int, int, int[], int, int) - 类 java.awt.image.PixelGrabber 的构造方法
创建一个 PixelGrabber 对象，以从指定图像将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。
PixelGrabber(ImageProducer, int, int, int, int, int[], int, int) - 类 java.awt.image.PixelGrabber 的构造方法
创建一个 PixelGrabber 对象，以从指定 ImageProducer 所生成的图像中将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。
PixelGrabber(Image, int, int, int, int, boolean) - 类 java.awt.image.PixelGrabber 的构造方法
创建一个 PixelGrabber 对象，以从指定的图像中抓取像素矩形部分 (x, y, w, h)。
PixelInterleavedSampleModel - java.awt.image 中的 类
此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。
PixelInterleavedSampleModel(int, int, int, int, int, int[]) - 类 java.awt.image.PixelInterleavedSampleModel 的构造方法
构造一个带指定参数的 PixelInterleavedSampleModel。
pixelStride - 类 java.awt.image.ComponentSampleModel 中的变量
由此 ComponentSampleModel 所描述的图像数据区域的像素间距（以数据数组元素表示）。
PKCS8EncodedKeySpec - java.security.spec 中的 类
此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。
PKCS8EncodedKeySpec(byte[]) - 类 java.security.spec.PKCS8EncodedKeySpec 的构造方法
根据给定的编码密钥创建一个新的 PKCS8EncodedKeySpec。
PKIXBuilderParameters - java.security.cert 中的 类
用作 PKIX CertPathBuilder 算法的输入的参数。
PKIXBuilderParameters(Set<TrustAnchor>, CertSelector) - 类 java.security.cert.PKIXBuilderParameters 的构造方法
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
PKIXBuilderParameters(KeyStore, CertSelector) - 类 java.security.cert.PKIXBuilderParameters 的构造方法
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXCertPathBuilderResult - java.security.cert 中的 类
此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。
PKIXCertPathBuilderResult(CertPath, TrustAnchor, PolicyNode, PublicKey) - 类 java.security.cert.PKIXCertPathBuilderResult 的构造方法
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
PKIXCertPathChecker - java.security.cert 中的 类
对 X509Certificate 执行一种或多种检查的抽象类。
PKIXCertPathChecker() - 类 java.security.cert.PKIXCertPathChecker 的构造方法
默认的构造方法。
PKIXCertPathValidatorResult - java.security.cert 中的 类
此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。
PKIXCertPathValidatorResult(TrustAnchor, PolicyNode, PublicKey) - 类 java.security.cert.PKIXCertPathValidatorResult 的构造方法
创建包含指定参数的 PKIXCertPathValidatorResult 实例。
PKIXParameters - java.security.cert 中的 类
用作 PKIX CertPathValidator 算法的输入的参数。
PKIXParameters(Set<TrustAnchor>) - 类 java.security.cert.PKIXParameters 的构造方法
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。
PKIXParameters(KeyStore) - 类 java.security.cert.PKIXParameters 的构造方法
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。
PLAIN - 类 java.awt.Font 中的静态变量
普通样式常量。
PLAIN_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
PLAIN_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
未使用图标。
PlainDocument - javax.swing.text 中的 类
维护无任何字符属性的普通文档。
PlainDocument() - 类 javax.swing.text.PlainDocument 的构造方法
构造一个纯文本文档。
PlainDocument(AbstractDocument.Content) - 类 javax.swing.text.PlainDocument 的构造方法
构造一个纯文本文档。
plainTextFlavor - 类 java.awt.datatransfer.DataFlavor 中的静态变量
已过时。 从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。
PlainView - javax.swing.text 中的 类
实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。
PlainView(Element) - 类 javax.swing.text.PlainView 的构造方法
构造在元素上包装的新 PlainView。
play(URL) - 类 java.applet.Applet 中的方法
播放指定绝对 URL 处的音频剪辑。
play(URL, String) - 类 java.applet.Applet 中的方法
播放音频剪辑，给定了 URL 及与之相对的说明符。
play() - 接口 java.applet.AudioClip 中的方法
开始播放此音频剪辑。
playSound(Action) - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
如有必要，在 audioAction 上调用 actionPerformed 以播放声音。
pluginClassName - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
包含关联的插件类名称的 String，该字符串最初为 null。
plus() - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其值为 (+this)，其标度为 this.scale()。
plus(MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (+this) 的 BigDecimal（根据上下文设置进行舍入）。
PLUS - 类 javax.management.Query 中的静态变量
表示 Query.plus(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
plus(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个二进制表达式，表示两个数值的和，或者两个字符串值的串接。
PM - 类 java.util.Calendar 中的静态变量
指示从中午到午夜之前这段时间的 Calendar.AM_PM 字段值。
PNG - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "image/png"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
PNG - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "image/png"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
PNG - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "image/png"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
POA - org.omg.PortableServer 中的 接口
POA 对象管理对象集合的实现。
poa(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
method _poa() 等效于调用 PortableServer::Current:get_POA。
POAHelper - org.omg.PortableServer 中的 类
POA 对象管理对象集合的实现。
POAHelper() - 类 org.omg.PortableServer.POAHelper 的构造方法
POAManager - org.omg.PortableServer 中的 接口
每个 POA 对象都有一个关联的 POAManager 对象。
POAManagerOperations - org.omg.PortableServer 中的 接口
每个 POA 对象具有一个关联的 POAManager 对象。
POAOperations - org.omg.PortableServer 中的 接口
POA 对象管理对象集合的实现。
Point - java.awt 中的 类
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Point() - 类 java.awt.Point 的构造方法
在坐标空间的原点 (0,0) 构造并初始化一个点。
Point(Point) - 类 java.awt.Point 的构造方法
构造并初始化一个与指定的 Point 对象具有相同位置的点。
Point(int, int) - 类 java.awt.Point 的构造方法
在坐标空间中指定的 (x,y) 位置构造并初始化一个点。
Point2D - java.awt.geom 中的 类
Point2D 类定义表示 (x,y) 坐标空间中位置的点。
Point2D() - 类 java.awt.geom.Point2D 的构造方法
这是一个无法直接实例化的抽象类。
Point2D.Double - java.awt.geom 中的 类
Double 类以 double 精度定义指定的点。
Point2D.Double() - 类 java.awt.geom.Point2D.Double 的构造方法
使用坐标 (0,0) 构造并初始化一个 Point2D。
Point2D.Double(double, double) - 类 java.awt.geom.Point2D.Double 的构造方法
使用指定坐标构造并初始化一个 Point2D。
Point2D.Float - java.awt.geom 中的 类
Float 类以 float 精度定义指定的点。
Point2D.Float() - 类 java.awt.geom.Point2D.Float 的构造方法
使用坐标 (0,0) 构造并初始化一个 Point2D。
Point2D.Float(float, float) - 类 java.awt.geom.Point2D.Float 的构造方法
使用指定坐标构造并初始化一个 Point2D。
POINT_INFINITY - 类 java.security.spec.ECPoint 中的静态变量
这就将该点定义为无穷大。
PointerInfo - java.awt 中的 类
描述指针位置的类。
pointSize - 类 java.awt.Font 中的变量
以 float 形式表示的 Font 的磅值大小。
pointToPath(Point2D, Point2D) - 类 java.awt.font.LayoutPath 中的方法
将用户空间中的点转换为相对于路径的位置。
Policy - java.security 中的 类
Policy 对象负责确定在 Java 运行时环境中执行的代码是否有权执行安全敏感的操作。
Policy() - 类 java.security.Policy 的构造方法
Policy - javax.security.auth 中的 类
已过时。 从 JDK 1.4 版本开始，由 java.security.Policy 取代。java.security.Policy 有一个方法：
        public PermissionCollection getPermissions
            (java.security.ProtectionDomain pd)
ProtectionDomain 有一个构造方法：
        public ProtectionDomain
            (CodeSource cs,
             PermissionCollection permissions,
             ClassLoader loader,
             Principal[] principals)
这两个 API 为调用者提供向 Policy 查询基于 Principal 的 Permission 条目的方法。
Policy() - 类 javax.security.auth.Policy 的构造方法
已过时。 唯一的构造方法。
Policy - org.omg.CORBA 中的 接口
派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。
Policy.Parameters - java.security 中的 接口
此类表示用于 Policy 参数的标记接口。
POLICY_FORWARD_SECRECY - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否需要在会话间实现了转发安全性的机制。
POLICY_NOACTIVE - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否允许易受主动式攻击（非字典）的机制。
POLICY_NOANONYMOUS - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否允许接受匿名登录的机制。
POLICY_NODICTIONARY - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否允许易受被动式字典攻击的机制。
POLICY_NOPLAINTEXT - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否允许易受简单被动式攻击（例如 "PLAIN"）的机制。
POLICY_PASS_CREDENTIALS - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否需要传递客户端证书的机制。
policy_type() - 类 org.omg.CORBA._PolicyStub 中的方法
返回对应于策略对象类型的常量值。
policy_type() - 接口 org.omg.CORBA.PolicyOperations 中的方法
返回对应于策略对象类型的常量值。
PolicyError - org.omg.CORBA 中的 异常
发生策略错误时抛出的用户异常。
PolicyError() - 异常 org.omg.CORBA.PolicyError 的构造方法
使用空原因代码和空原因详细消息构造一个默认 PolicyError 用户异常。
PolicyError(short) - 异常 org.omg.CORBA.PolicyError 的构造方法
构造一个 PolicyError 用户异常，并使用给定原因代码和空原因详细消息初始化。
PolicyError(String, short) - 异常 org.omg.CORBA.PolicyError 的构造方法
构造一个 PolicyError 用户异常，并使用给定原因详细消息和原因代码初始化。
PolicyErrorCodeHelper - org.omg.CORBA 中的 类
封装 Policy 无效的原因。
PolicyErrorCodeHelper() - 类 org.omg.CORBA.PolicyErrorCodeHelper 的构造方法
PolicyErrorHelper - org.omg.CORBA 中的 类
抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。
PolicyErrorHelper() - 类 org.omg.CORBA.PolicyErrorHelper 的构造方法
PolicyErrorHolder - org.omg.CORBA 中的 类
抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。
PolicyErrorHolder() - 类 org.omg.CORBA.PolicyErrorHolder 的构造方法
PolicyErrorHolder(PolicyError) - 类 org.omg.CORBA.PolicyErrorHolder 的构造方法
PolicyFactory - org.omg.PortableInterceptor 中的 接口
使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
PolicyFactoryOperations - org.omg.PortableInterceptor 中的 接口
使得策略类型能够通过 CORBA.ORB.create_policy 构建。
PolicyHelper - org.omg.CORBA 中的 类
Policy 的 Helper。
PolicyHelper() - 类 org.omg.CORBA.PolicyHelper 的构造方法
PolicyHolder - org.omg.CORBA 中的 类
Policy 的 Holder。
PolicyHolder() - 类 org.omg.CORBA.PolicyHolder 的构造方法
PolicyHolder(Policy) - 类 org.omg.CORBA.PolicyHolder 的构造方法
PolicyListHelper - org.omg.CORBA 中的 类
PolicyList 的 Helper。
PolicyListHelper() - 类 org.omg.CORBA.PolicyListHelper 的构造方法
PolicyListHolder - org.omg.CORBA 中的 类
PolicyList 的 Holder。
PolicyListHolder() - 类 org.omg.CORBA.PolicyListHolder 的构造方法
PolicyListHolder(Policy[]) - 类 org.omg.CORBA.PolicyListHolder 的构造方法
PolicyNode - java.security.cert 中的 接口
PKIX 证书路径验证算法所定义的、不可变的有效策略树节点。
PolicyOperations - org.omg.CORBA 中的 接口
提供针对某一 Policy 对象的操作。
PolicyQualifierInfo - java.security.cert 中的 类
由 ASN.1 PolicyQualifierInfo 结构所表示的、不可变的策略限定符。
PolicyQualifierInfo(byte[]) - 类 java.security.cert.PolicyQualifierInfo 的构造方法
根据已编码的字节创建一个 PolicyQualifierInfo 实例。
PolicySpi - java.security 中的 类
此类为 Policy 类定义服务提供者接口 (SPI)。
PolicySpi() - 类 java.security.PolicySpi 的构造方法
PolicyTypeHelper - org.omg.CORBA 中的 类
PolicyType 的 Helper。
PolicyTypeHelper() - 类 org.omg.CORBA.PolicyTypeHelper 的构造方法
poll() - 类 java.lang.ref.ReferenceQueue 中的方法
轮询此队列，查看是否存在可用的引用对象。
poll() - 类 java.util.ArrayDeque 中的方法
获取并移除此双端队列所表示的队列的头（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
poll() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
poll() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
poll(long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。
poll(long, TimeUnit) - 接口 java.util.concurrent.BlockingQueue 中的方法
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
poll() - 接口 java.util.concurrent.CompletionService 中的方法
获取并移除表示下一个已完成任务的 Future，如果不存在这样的任务，则返回 null。
poll(long, TimeUnit) - 接口 java.util.concurrent.CompletionService 中的方法
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
poll() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
poll() - 类 java.util.concurrent.DelayQueue 中的方法
获取并移除此队列的头，如果此队列不包含具有已到期延迟时间的元素，则返回 null。
poll(long, TimeUnit) - 类 java.util.concurrent.DelayQueue 中的方法
获取并移除此队列的头部，在可从此队列获得到期延迟的元素，或者到达指定的等待时间之前一直等待（如有必要）。
poll() - 类 java.util.concurrent.ExecutorCompletionService 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.ExecutorCompletionService 中的方法
poll() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
poll() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
poll() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
poll(long, TimeUnit) - 类 java.util.concurrent.SynchronousQueue 中的方法
获取并移除此队列的头，如有必要则等待指定的时间，以便另一个线程插入它。
poll() - 类 java.util.concurrent.SynchronousQueue 中的方法
如果另一个线程当前正要使用某个元素，则获取并移除此队列的头。
poll() - 接口 java.util.Deque 中的方法
获取并移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
poll() - 类 java.util.LinkedList 中的方法
获取并移除此列表的头（第一个元素）
poll() - 类 java.util.PriorityQueue 中的方法
poll() - 接口 java.util.Queue 中的方法
获取并移除此队列的头，如果此队列为空，则返回 null。
poll_next_response() - 类 org.omg.CORBA.ORB 中的方法
找出是否已经响应了延迟的（异步）调用。
poll_response() - 类 org.omg.CORBA.Request 中的方法
允许用户确定是否已接收到之前使用 send_deferred 方法所触发调用的响应。
pollFirst() - 类 java.util.ArrayDeque 中的方法
pollFirst(long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。
pollFirst() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
pollFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pollFirst(long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pollFirst() - 接口 java.util.Deque 中的方法
获取并移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
pollFirst() - 类 java.util.LinkedList 中的方法
获取并移除此列表的第一个元素；如果此列表为空，则返回 null。
pollFirst() - 接口 java.util.NavigableSet 中的方法
获取并移除第一个（最低）元素；如果此 set 为空，则返回 null。
pollFirst() - 类 java.util.TreeSet 中的方法
pollFirstEntry() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
移除并返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
pollFirstEntry() - 接口 java.util.NavigableMap 中的方法
移除并返回与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
pollFirstEntry() - 类 java.util.TreeMap 中的方法
pollLast() - 类 java.util.ArrayDeque 中的方法
pollLast(long, TimeUnit) - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。
pollLast() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
pollLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pollLast(long, TimeUnit) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pollLast() - 接口 java.util.Deque 中的方法
获取并移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
pollLast() - 类 java.util.LinkedList 中的方法
获取并移除此列表的最后一个元素；如果此列表为空，则返回 null。
pollLast() - 接口 java.util.NavigableSet 中的方法
获取并移除最后一个（最高）元素；如果此 set 为空，则返回 null。
pollLast() - 类 java.util.TreeSet 中的方法
pollLastEntry() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
移除并返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。
pollLastEntry() - 接口 java.util.NavigableMap 中的方法
移除并返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
pollLastEntry() - 类 java.util.TreeMap 中的方法
POLY_PRESSURE - 类 javax.sound.midi.ShortMessage 中的静态变量
Polyphonic Key Pressure (Aftertouch) 消息的命令值（0xA0 或 128）
Polygon - java.awt 中的 类
Polygon 类封装了坐标空间中封闭的二维区域的描述。
Polygon() - 类 java.awt.Polygon 的构造方法
创建空的多边形。
Polygon(int[], int[], int) - 类 java.awt.Polygon 的构造方法
根据指定的参数构造并初始化新的 Polygon。
PooledConnection - javax.sql 中的 接口
为连接池管理提供钩子 (hook) 的对象。
pop() - 类 java.awt.EventQueue 中的方法
停止使用此 EventQueue 指派事件。
pop() - 类 java.util.ArrayDeque 中的方法
从此双端队列所表示的堆栈中弹出一个元素。
pop() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
pop() - 接口 java.util.Deque 中的方法
从此双端队列所表示的堆栈中弹出一个元素。
pop() - 类 java.util.LinkedList 中的方法
从此列表所表示的堆栈处弹出一个元素。
pop() - 类 java.util.Stack 中的方法
移除堆栈顶部的对象，并作为此函数的值返回该对象。
popCharacterStyle() - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
将以前压入堆栈的字符样式弹出，以返回以前的样式。
popContext() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
恢复到以前的名称空间上下文。
populate(ResultSet) - 接口 javax.sql.rowset.CachedRowSet 中的方法
使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
populate(ResultSet, int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
popup - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
Popup - javax.swing 中的 类
Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。
Popup(Component, Component, int, int) - 类 javax.swing.Popup 的构造方法
为包含 Component content 的 Component owner 创建 Popup。
Popup() - 类 javax.swing.Popup 的构造方法
创建 Popup。
POPUP_LAYER - 类 javax.swing.JLayeredPane 中的静态变量
定义 Popup 层的便捷对象。
POPUP_MENU - 类 javax.accessibility.AccessibleRole 中的静态变量
一个临时窗口，通常用于为用户提供选项列表，当用户选中其中某个选项后，此窗口隐藏。
POPUP_MENU - 类 javax.swing.plaf.synth.Region 中的静态变量
PopupMenu 的 region。
POPUP_MENU_SEPARATOR - 类 javax.swing.plaf.synth.Region 中的静态变量
PopupMenuSeparator 的 region。
PopupFactory - javax.swing 中的 类
顾名思义，PopupFactory 用于获取 Popup 的实例。
PopupFactory() - 类 javax.swing.PopupFactory 的构造方法
popupKeyListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
popupListener - 类 javax.swing.JMenu 中的变量
弹出菜单的窗口关闭侦听器。
PopupMenu - java.awt 中的 类
此类实现能够在组件中的指定位置上动态弹出的菜单。
PopupMenu() - 类 java.awt.PopupMenu 的构造方法
创建具有空名称的新弹出式菜单。
PopupMenu(String) - 类 java.awt.PopupMenu 的构造方法
创建具有指定名称的新弹出式菜单。
popupMenu - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的变量
PopupMenu.AccessibleAWTPopupMenu - java.awt 中的 类
用于为可访问性提供默认支持的 PopupMenu 的内部类。
PopupMenu.AccessibleAWTPopupMenu() - 类 java.awt.PopupMenu.AccessibleAWTPopupMenu 的构造方法
popupMenuCanceled(PopupMenuEvent) - 接口 javax.swing.event.PopupMenuListener 中的方法
此方法在弹出菜单被取消时调用。
PopupMenuEvent - javax.swing.event 中的 类
PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
PopupMenuEvent(Object) - 类 javax.swing.event.PopupMenuEvent 的构造方法
构造一个 PopupMenuEvent 对象。
PopupMenuListener - javax.swing.event 中的 接口
弹出菜单侦听器
PopupMenuUI - javax.swing.plaf 中的 类
JPopupMenu 的可插入外观界面。
PopupMenuUI() - 类 javax.swing.plaf.PopupMenuUI 的构造方法
popupMenuWillBecomeInvisible(PopupMenuEvent) - 接口 javax.swing.event.PopupMenuListener 中的方法
此方法在弹出菜单变得不可见之前调用。
popupMenuWillBecomeVisible(PopupMenuEvent) - 接口 javax.swing.event.PopupMenuListener 中的方法
此方法在弹出菜单变得可见之前调用
popupMouseListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
popupMouseMotionListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
port - 类 java.net.SocketImpl 中的变量
此套接字连接到的远程主机的端口号。
Port - javax.sound.sampled 中的 接口
端口是往返于音频输入或输出线与音频设备之间的简单线路。
Port.Info - javax.sound.sampled 中的 类
该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。
Port.Info(Class<?>, String, boolean) - 类 javax.sound.sampled.Port.Info 的构造方法
根据给定的信息构造端口的 info 对象。
PortableRemoteObject - javax.rmi 中的 类
服务器实现对象可以从 javax.rmi.PortableRemoteObject 继承，也可以实现一个远程接口，然后使用 exportObject 方法将其本身注册为服务器对象。
PortableRemoteObject() - 类 javax.rmi.PortableRemoteObject 的构造方法
通过调用 exportObject(this) 初始化该对象。
PortableRemoteObjectDelegate - javax.rmi.CORBA 中的 接口
支持 PortableRemoteObject 中方法实现的委托。
PortInfo - javax.xml.ws.handler 中的 接口
HandlerResolver 使用 PortInfo 接口查询有关要用来创建处理程序链的端口的信息。
PORTRAIT - 类 java.awt.PageAttributes.OrientationRequestedType 中的静态变量
用于指定纵向方向的 OrientationRequestedType 实例。
PORTRAIT - 类 java.awt.print.PageFormat 中的静态变量
原点在纸张的左上方，x 指向右方，y 指向下方。
PORTRAIT - 类 javax.print.attribute.standard.OrientationRequested 中的静态变量
沿介质的短边描绘内容。
PortUnreachableException - java.net 中的 异常
在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
PortUnreachableException(String) - 异常 java.net.PortUnreachableException 的构造方法
构造带详细消息的新 PortUnreachableException。
PortUnreachableException() - 异常 java.net.PortUnreachableException 的构造方法
构造不带详细消息的新 PortUnreachableException。
pos - 类 java.io.BufferedInputStream 中的变量
缓冲区中的当前位置。
pos - 类 java.io.ByteArrayInputStream 中的变量
要从输入流缓冲区中读取的下一个字符的索引。
pos - 类 java.io.CharArrayReader 中的变量
当前缓冲区位置。
pos - 类 java.io.PushbackInputStream 中的变量
推回缓冲区中的位置，将读取该位置的下一个字节。
pos - 类 java.io.StringBufferInputStream 中的变量
已过时。 要从输入流缓冲区中读取的下一个字符的索引。
position() - 类 java.nio.Buffer 中的方法
返回此缓冲区的位置。
position(int) - 类 java.nio.Buffer 中的方法
设置此缓冲区的位置。
position() - 类 java.nio.channels.FileChannel 中的方法
返回此通道的文件位置。
position(long) - 类 java.nio.channels.FileChannel 中的方法
设置此通道的文件位置。
position() - 类 java.nio.channels.FileLock 中的方法
返回文件内锁定区域中第一个字节的位置。
position(byte[], long) - 接口 java.sql.Blob 中的方法
获取此 Blob 对象表示的 BLOB 值中指定 byte 数组 pattern 开始处的字节位置。
position(Blob, long) - 接口 java.sql.Blob 中的方法
获取此 Blob 对象指定的 BLOB 值中 pattern 开始处的字节位置。
position(String, long) - 接口 java.sql.Clob 中的方法
获取此 Clob 对象表示的 SQL CLOB 值中指定子字符串 searchstr 出现的字符位置。
position(Clob, long) - 接口 java.sql.Clob 中的方法
获取此 Clob 对象中指定的 Clob 对象 searchstr 出现的字符位置。
position(byte[], long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
返回在此 SerialBlob 对象中给定模式的字节开始的位置，搜索从指定的位置开始。
position(Blob, long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
position(String, long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。
position(Clob, long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
Position - javax.swing.text 中的 接口
表示文档中的位置。
Position.Bias - javax.swing.text 中的 类
用来指示模型中位置偏差的类型安全的枚举。
positionCaret(MouseEvent) - 类 javax.swing.text.DefaultCaret 中的方法
试图使用 viewToModel() 从鼠标事件的坐标设置插入符的位置。
positionForMouseEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DragController 中的方法
返回基于传入的 MouseEvent 放置分隔器的新位置。
positionForMouseEvent(MouseEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController 中的方法
返回基于传入的 MouseEvent 放置分隔器的新位置。
positionToElement(int) - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
获得包含给定模型位置的子元素。
POSITIVE_INFINITY - 类 java.lang.Double 中的静态变量
保存 double 类型的正无穷大值的常量。
POSITIVE_INFINITY - 类 java.lang.Float 中的静态变量
保存 float 类型的正无穷大值的常量。
POSITIVE_SCROLL - 类 javax.swing.plaf.basic.BasicSliderUI 中的静态变量
post_init(ORBInitInfo) - 接口 org.omg.PortableInterceptor.ORBInitializerOperations 中的方法
初始化 ORB 期间调用此方法。
postActionEvent() - 类 javax.swing.JTextField 中的方法
通过将其指派给所有已注册的 ActionListener 对象来处理发生在此文本字段上的操作事件。
postClosingEvent(JInternalFrame) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
将类似于 WINDOW_CLOSING 的事件发送到窗体，以便将其当作规则的 Frame 来对待。
PostConstruct - javax.annotation 中的 注释类型
PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
postDeregister() - 类 javax.management.loading.MLet 中的方法
允许 m-let 在已从 MBean 服务器注销之后执行任何所需要的操作。
postDeregister() - 接口 javax.management.MBeanRegistration 中的方法
允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。
postDeregister() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
允许 MBean 在已从 MBean 服务器注销之后执行任何所需要的操作。
postDeregister() - 类 javax.management.monitor.Monitor 中的方法
允许在 MBean 服务器注销监视器 MBean 之前执行所需的任何操作。
postDeregister() - 类 javax.management.relation.RelationService 中的方法
postDeregister() - 类 javax.management.relation.RelationSupport 中的方法
postDeregister() - 类 javax.management.remote.JMXConnectorServer 中的方法
postDeregister() - 类 javax.management.StandardMBean 中的方法
允许 MBean 在 MBean 服务器中取消注册后执行任何它所需要的操作。
postDeregister() - 类 javax.management.timer.Timer 中的方法
允许计时器 MBean 在 MBean 服务器注销它之后执行任何所需的操作。
postEdit(UndoableEdit) - 类 javax.swing.undo.UndoableEditSupport 中的方法
死锁警告：调用此方法可能调用所有侦听器中的 undoableEditHappened。
postEvent(Event) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
postEvent(AWTEvent) - 类 java.awt.EventQueue 中的方法
将一个 1.1 样式的事件发送到 EventQueue 中。
postEvent(Event) - 类 java.awt.MenuComponent 中的方法
已过时。 从 JDK version 1.1 开始，已由 dispatchEvent 取代。
postEvent(Event) - 接口 java.awt.MenuContainer 中的方法
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
postEvent(Event) - 类 java.awt.Window 中的方法
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
postinvoke(byte[], POA, String, Object, Servant) - 类 org.omg.PortableServer._ServantLocatorStub 中的方法
servant 完成请求时都将调用此操作。
postinvoke(byte[], POA, String, Object, Servant) - 接口 org.omg.PortableServer.ServantLocatorOperations 中的方法
servant 完成请求时都将调用此操作。
postorderEnumeration() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回按后序遍历以此节点为根的树的一个枚举。
postProcessKeyEvent(KeyEvent) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
由 dispatchKeyEvent 调用此方法。
postProcessKeyEvent(KeyEvent) - 类 java.awt.KeyboardFocusManager 中的方法
dispatchKeyEvent 将调用此方法。
postProcessKeyEvent(KeyEvent) - 接口 java.awt.KeyEventPostProcessor 中的方法
当前 KeyboardFocusManager 调用此方法，请求此 KeyEventPostProcessor 执行应该作为 KeyEvent 最终解析的一部分的所需后处理。
postRegister(Boolean) - 类 javax.management.loading.MLet 中的方法
允许 m-let 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。
postRegister(Boolean) - 接口 javax.management.MBeanRegistration 中的方法
允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。
postRegister(Boolean) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
允许 MBean 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。
postRegister(Boolean) - 类 javax.management.monitor.Monitor 中的方法
允许在 MBean 服务器中注册监视器 MBean 后或注册失败后执行所需的任何操作。
postRegister(Boolean) - 类 javax.management.relation.RelationService 中的方法
postRegister(Boolean) - 类 javax.management.relation.RelationSupport 中的方法
postRegister(Boolean) - 类 javax.management.remote.JMXConnectorServer 中的方法
postRegister(Boolean) - 类 javax.management.StandardMBean 中的方法
允许 MBean 在已注册到 MBean 服务器之后或注册已失败之后执行任何它所需要的操作。
postRegister(Boolean) - 类 javax.management.timer.Timer 中的方法
允许计时器 MBean 在 MBean 服务器中注册后或注册失败后执行任何所需的操作。
postRemoveUpdate(AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
随文本的移除更新任何文档结构。
POSTSCRIPT - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
POSTSCRIPT - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
POSTSCRIPT - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
postState - 类 javax.swing.undo.StateEdit 中的变量
编辑之后的状态信息
POSTURE - 类 java.awt.font.TextAttribute 中的静态变量
字体形态的属性键。
POSTURE_OBLIQUE - 类 java.awt.font.TextAttribute 中的静态变量
标准斜体形态。
POSTURE_REGULAR - 类 java.awt.font.TextAttribute 中的静态变量
标准直立形态。
pow(double, double) - 类 java.lang.Math 中的静态方法
返回第一个参数的第二个参数次幂的值。
pow(double, double) - 类 java.lang.StrictMath 中的静态方法
返回第一个参数的第二个参数次幂的值。
pow(int) - 类 java.math.BigDecimal 中的方法
返回其值为 (thisn) 的 BigDecimal，准确计算该幂，使其具有无限精度。
pow(int, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (thisn) 的 BigDecimal。
pow(int) - 类 java.math.BigInteger 中的方法
返回其值为 (thisexponent) 的 BigInteger。
PPQ - 类 javax.sound.midi.Sequence 中的静态变量
基于速度的定时类型，其精度用每四分音符的拍子数（节拍）表示。
PRC - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
PRE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
pre_init(ORBInitInfo) - 接口 org.omg.PortableInterceptor.ORBInitializerOperations 中的方法
初始化 ORB 期间调用此方法。
preceding(int) - 类 java.text.BreakIterator 中的方法
返回指定字符偏移量前面的最后一个边界。
precision() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的精度。
preConcatenate(AffineTransform) - 类 java.awt.geom.AffineTransform 中的方法
以不常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，从而 Tx 相对于绝对像素空间（而非相对于现有用户空间）修改坐标变换。
preConcatenateTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
通过预先挂起另一变换修改当前的“用户到设备”变换。
preConcetenateTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
已过时。 由 preConcatenateTransform(AffineTransform) 所取代。
preContent(char[]) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
添加在 PRE 元素中遇到的给定内容。
predefined - 类 java.awt.Cursor 中的静态变量
preDeregister() - 类 javax.management.loading.MLet 中的方法
允许 m-let 在由 MBean 服务器注销之前执行任何所需要的操作。
preDeregister() - 接口 javax.management.MBeanRegistration 中的方法
允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。
preDeregister() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
允许 MBean 在由 MBean 服务器注销之前执行任何所需要的操作。
preDeregister() - 类 javax.management.monitor.Monitor 中的方法
允许在 MBean 服务器注销监视器 MBean 之前执行监视器 MBean 所需要的任何操作。
preDeregister() - 类 javax.management.relation.RelationService 中的方法
preDeregister() - 类 javax.management.relation.RelationSupport 中的方法
preDeregister() - 类 javax.management.remote.JMXConnectorServer 中的方法
当此连接器服务器从 MBean 服务器上注销时，由该 MBean 服务器调用此方法。
preDeregister() - 类 javax.management.StandardMBean 中的方法
允许 MBean 由 MBean 服务器取消注册前执行任何它所需要的操作。
preDeregister() - 类 javax.management.timer.Timer 中的方法
允许计时器 MBean 在 MBean 服务器注销它之前执行任何所需的操作。
PreDestroy - javax.annotation 中的 注释类型
PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
Predicate - javax.sql.rowset 中的 接口
为所有 FilteredRowSet 对象提供框架以描述其过滤器的标准接口。
preferenceChange(PreferenceChangeEvent) - 接口 java.util.prefs.PreferenceChangeListener 中的方法
当添加、移除首选项或者更改首选项的值时，调用此方法。
preferenceChanged(boolean, boolean) - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
标记此子视图更改的首选项。
preferenceChanged(View, boolean, boolean) - 类 javax.swing.text.AsyncBoxView 中的方法
子视图可以在父级上调用此方法，以指示首选项已更改并且应该重新考虑布局。
preferenceChanged(View, boolean, boolean) - 类 javax.swing.text.BoxView 中的方法
这由子级来调用，以表明它的首选项区域已更改。
preferenceChanged(View, boolean, boolean) - 类 javax.swing.text.View 中的方法
子视图能在父级上调用此方法来指示首选项已经更改，并且应该重新考虑布局。
PreferenceChangeEvent - java.util.prefs 中的 类
Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。
PreferenceChangeEvent(Preferences, String, String) - 类 java.util.prefs.PreferenceChangeEvent 的构造方法
构造新的 PreferenceChangeEvent 实例。
PreferenceChangeListener - java.util.prefs 中的 接口
用于接收首选项节点更改事件的侦听器。
Preferences - java.util.prefs 中的 类
首选项数据的层次结构 collection 中的节点。
Preferences() - 类 java.util.prefs.Preferences 的构造方法
单独的构造方法。
PreferencesFactory - java.util.prefs 中的 接口
生成 Preferences 对象的 factory 对象。
preferLocaleFonts() - 类 java.awt.GraphicsEnvironment 中的方法
指示在逻辑字体到实际字体的映射关系中特定于语言环境的字体的首选项。
preferProportionalFonts() - 类 java.awt.GraphicsEnvironment 中的方法
指示在逻辑字体到实际字体的映射关系中用于均衡字体和非均衡字体（如双字节的中日韩字体）的首选项。
PREFERRED - 类 java.awt.GraphicsConfigTemplate 中的静态变量
用于“枚举”（整数）类型的值。
preferred - 类 javax.swing.SizeRequirements 中的变量
首选（自然）大小。
PREFERRED_SIZE - 类 javax.swing.GroupLayout 中的静态变量
指示组件或间隙的首选大小应该用于特定的范围值。
preferredLayoutSize(Container) - 类 java.awt.BorderLayout 中的方法
基于容器中的组件，使用此布局管理器确定 target 容器的首选大小。
preferredLayoutSize(Container) - 类 java.awt.CardLayout 中的方法
使用此卡片布局确定容器参数的首选大小。
preferredLayoutSize(Container) - 类 java.awt.FlowLayout 中的方法
给出指定目标容器中的 visible 组件，返回此布局的首选维数。
preferredLayoutSize(Container) - 类 java.awt.GridBagLayout 中的方法
使用此网络包布局确定 parent 容器的首选大小。
preferredLayoutSize(Container) - 类 java.awt.GridLayout 中的方法
使用此网格布局确定容器参数的首选大小。
preferredLayoutSize(Container) - 接口 java.awt.LayoutManager 中的方法
给定指定容器所包含的组件，计算该容器的首选大小维数。
preferredLayoutSize(Container) - 类 javax.swing.BoxLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。
preferredLayoutSize(Container) - 类 javax.swing.GroupLayout 中的方法
返回指定容器的首选大小。
preferredLayoutSize(Container) - 类 javax.swing.JRootPane.RootLayout 中的方法
返回布局要使用的空间量。
preferredLayoutSize(Container) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
返回第一个（并且是唯一）子级的首选大小与其父 insets 的大小和。
preferredLayoutSize(Container) - 类 javax.swing.OverlayLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
返回包含子级所需的首选大小。
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.plaf.basic.DefaultMenuLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.ScrollPaneLayout 中的方法
ScrollPane 的首选大小是 insets 的大小加上视口的首选大小、可见标题首选大小以及滚动条的首选大小，它按照给定的当前视图和当前滚动条策略显示。
preferredLayoutSize(Container) - 类 javax.swing.SpringLayout 中的方法
preferredLayoutSize(Container) - 类 javax.swing.ViewportLayout 中的方法
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
preferredMinSize - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
最小首选大小。
preferredSize() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
preferredSize() - 类 java.awt.Container 中的方法
已过时。 从 JDK version 1.1 开始，用 getPreferredSize() 取代。
PREFERREDSIZE - 类 java.awt.GridBagLayout 中的静态变量
网格包布局可以布置的首选网格大小。
preferredSize(int) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
preferredSize() - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
preferredSize(int, int) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。
preferredSize() - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
preferredSize(int) - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
preferredSize() - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
preferredSize - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
完全显示所有节点所需的大小。
preferredTabAreaHeight(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
preferredTabAreaWidth(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
preferredTileSizes - 类 javax.imageio.ImageWriteParam 中的变量
首选 tile 大小范围对组成的数组。
preferredViewportSize - 类 javax.swing.JTable 中的变量
Scrollable 接口使用它来确定初始的可见区域。
preinvoke(byte[], POA, String, CookieHolder) - 类 org.omg.PortableServer._ServantLocatorStub 中的方法
此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。
preinvoke(byte[], POA, String, CookieHolder) - 接口 org.omg.PortableServer.ServantLocatorOperations 中的方法
此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。
preorderEnumeration() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
创建并返回按前序遍历以此节点为根的子树的一个枚举。
prepare(Xid) - 接口 javax.transaction.xa.XAResource 中的方法
请求资源管理器准备好 xid 中指定的事务的事务提交工作。
prepareCall(String) - 接口 java.sql.Connection 中的方法
创建一个 CallableStatement 对象来调用数据库存储过程。
prepareCall(String, int, int) - 接口 java.sql.Connection 中的方法
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
prepareCall(String, int, int, int) - 接口 java.sql.Connection 中的方法
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
PreparedStatement - java.sql 中的 接口
表示预编译的 SQL 语句的对象。
prepareEditor(TableCellEditor, int, int) - 类 javax.swing.JTable 中的方法
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备编辑器。
prepareForDragging() - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
传递消息以准备拖动操作。
prepareForEditing() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
仅在编辑启动之前调用。
prepareForUIInstall() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
在设置 tree 实例变量之后，但在安装任何默认值/侦听器之前调用此方法。
prepareForUIUninstall() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
prepareImage(Image, ImageObserver) - 类 java.awt.Component 中的方法
准备一幅在此组件上呈现的图像。
prepareImage(Image, int, int, ImageObserver) - 类 java.awt.Component 中的方法
以指定的宽度和高度准备一幅在此组件上呈现的图像。
prepareImage(Image, int, int, ImageObserver) - 类 java.awt.Toolkit 中的方法
准备一个用于呈现的图像。
prepareInsertEmpty(int, ImageTypeSpecifier, int, int, IIOMetadata, List<? extends BufferedImage>, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
从将带有不确定像素值的新图像插入现有图像流中开始。
prepareRenderer(TableCellRenderer, int, int) - 类 javax.swing.JTable 中的方法
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备渲染器。
prepareReplacePixels(int, Rectangle) - 类 javax.imageio.ImageWriter 中的方法
准备好 writer，处理一系列对 replacePixels 方法的调用。
prepareStatement(String) - 接口 java.sql.Connection 中的方法
创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。
prepareStatement(String, int, int) - 接口 java.sql.Connection 中的方法
创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
prepareStatement(String, int, int, int) - 接口 java.sql.Connection 中的方法
创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
prepareStatement(String, int) - 接口 java.sql.Connection 中的方法
创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。
prepareStatement(String, int[]) - 接口 java.sql.Connection 中的方法
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
prepareStatement(String, String[]) - 接口 java.sql.Connection 中的方法
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
prepareWriteEmpty(IIOMetadata, ImageTypeSpecifier, int, int, IIOMetadata, List<? extends BufferedImage>, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
prepareWriteSequence(IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
使用提供的流元数据对象准备一个流，以接受一系列的后续 writeToSequence 调用。
preRegister(MBeanServer, ObjectName) - 类 javax.management.loading.MLet 中的方法
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。
preRegister(MBeanServer, ObjectName) - 接口 javax.management.MBeanRegistration 中的方法
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
preRegister(MBeanServer, ObjectName) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。
preRegister(MBeanServer, ObjectName) - 类 javax.management.monitor.Monitor 中的方法
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。
preRegister(MBeanServer, ObjectName) - 类 javax.management.relation.RelationService 中的方法
preRegister(MBeanServer, ObjectName) - 类 javax.management.relation.RelationSupport 中的方法
preRegister(MBeanServer, ObjectName) - 类 javax.management.remote.JMXConnectorServer 中的方法
当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。
preRegister(MBeanServer, ObjectName) - 类 javax.management.StandardMBean 中的方法
允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。
preRegister(MBeanServer, ObjectName) - 类 javax.management.timer.Timer 中的方法
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。
PresentationDirection - javax.print.attribute.standard 中的 类
PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
PRESSED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象当前是按下的。
PRESSED - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“按下的”位，该位指示按钮已经被按下。
PRESSED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 处于被按下状态的基本状态。
PRESSED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对按下按钮时使用的图标的更改。
prestartAllCoreThreads() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
启动所有核心线程，使其处于等待工作的空闲状态。
prestartCoreThread() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
启动核心线程，使其处于等待工作的空闲状态。
preState - 类 javax.swing.undo.StateEdit 中的变量
编辑之前的状态信息
preventDefault() - 接口 org.w3c.dom.events.Event 中的方法
如果事件可取消，则 preventDefault 方法用于表示要取消该事件，意味着作为事件结果的、通常由该实现采取的任何默认操作将不出现。
PREVIEW_PANEL_PROPERTY - 类 javax.swing.JColorChooser 中的静态变量
预览面板属性名。
previewListener - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的变量
previous(Container) - 类 java.awt.CardLayout 中的方法
翻转到指定容器的前一张卡片。
previous() - 接口 java.sql.ResultSet 中的方法
将光标移动到此 ResultSet 对象的上一行。
previous() - 类 java.text.BreakIterator 中的方法
返回当前边界的前一个边界。
previous() - 接口 java.text.CharacterIterator 中的方法
将迭代器的索引减一，并返回新索引处的字符。
previous() - 类 java.text.CollationElementIterator 中的方法
获取字符串中前一个 collation 元素。
previous() - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.previous()。
previous() - 接口 java.util.ListIterator 中的方法
返回列表中的前一个元素。
PREVIOUS - 接口 javax.swing.SwingConstants 中的静态变量
标识序列中前一个方向。
previous() - 类 javax.swing.text.ElementIterator 中的方法
获取前一个 Element。
previous() - 类 javax.swing.text.Segment 中的方法
将迭代器的索引减一，并返回新索引处的字符。
previousConflict() - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
将指针从其当前位置移动到此 SyncResolver 对象中上一个冲突行。
previousDouble(double) - 类 java.text.ChoiceFormat 中的静态方法
查找小于 d 的最大 double 值。
previousIndex() - 接口 java.util.ListIterator 中的方法
返回对 previous 的后续调用所返回元素的索引。
previousPage() - 接口 javax.sql.rowset.CachedRowSet 中的方法
逐个减少 CachedRowSet 的当前页。
previousWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到前一个字开头的 Action 名称。
PRIMARY - 类 java.text.Collator 中的静态变量
Collator 的 strength 值。
primaryOrder(int) - 类 java.text.CollationElementIterator 中的静态方法
返回 collation 元素的主顺序。
PrimitiveType - javax.lang.model.type 中的 接口
表示一个基本类型。
Principal - java.security 中的 接口
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
Principal - org.omg.CORBA 中的 类
已过时。 已由 CORBA 2.2 取代。
Principal() - 类 org.omg.CORBA.Principal 的构造方法
已过时。
PrincipalHolder - org.omg.CORBA 中的 类
已过时。 Deprecated by CORBA 2.2.
PrincipalHolder() - 类 org.omg.CORBA.PrincipalHolder 的构造方法
已过时。 构造一个新的 PrincipalHolder 对象，将其 value 字段初始化为 null。
PrincipalHolder(Principal) - 类 org.omg.CORBA.PrincipalHolder 的构造方法
已过时。 构造一个新的 PrincipalHolder 对象，并将其 value 字段初始化为给定的 Principal 对象。
print(Graphics) - 类 java.awt.Component 中的方法
打印此组件。
print(Graphics) - 类 java.awt.Container 中的方法
打印容器。
print(File) - 类 java.awt.Desktop 中的方法
使用关联应用程序的打印命令，用本机桌面打印设施来打印文件。
print(Graphics, PageFormat, int) - 接口 java.awt.print.Printable 中的方法
将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。
print() - 类 java.awt.print.PrinterJob 中的方法
打印一组页面。
print(PrintRequestAttributeSet) - 类 java.awt.print.PrinterJob 中的方法
使用属性集中的设置打印一组页面。
print(boolean) - 类 java.io.PrintStream 中的方法
打印 boolean 值。
print(char) - 类 java.io.PrintStream 中的方法
打印字符。
print(int) - 类 java.io.PrintStream 中的方法
打印整数。
print(long) - 类 java.io.PrintStream 中的方法
打印 long 整数。
print(float) - 类 java.io.PrintStream 中的方法
打印浮点数。
print(double) - 类 java.io.PrintStream 中的方法
打印双精度浮点数。
print(char[]) - 类 java.io.PrintStream 中的方法
打印字符数组。
print(String) - 类 java.io.PrintStream 中的方法
打印字符串。
print(Object) - 类 java.io.PrintStream 中的方法
打印对象。
print(boolean) - 类 java.io.PrintWriter 中的方法
打印 boolean 值。
print(char) - 类 java.io.PrintWriter 中的方法
打印字符。
print(int) - 类 java.io.PrintWriter 中的方法
打印整数。
print(long) - 类 java.io.PrintWriter 中的方法
打印 long 整数。
print(float) - 类 java.io.PrintWriter 中的方法
打印一个浮点数。
print(double) - 类 java.io.PrintWriter 中的方法
打印 double 精度浮点数。
print(char[]) - 类 java.io.PrintWriter 中的方法
打印字符数组。
print(String) - 类 java.io.PrintWriter 中的方法
打印字符串。
print(Object) - 类 java.io.PrintWriter 中的方法
打印对象。
print(Doc, PrintRequestAttributeSet) - 接口 javax.print.DocPrintJob 中的方法
使用指定的作业属性打印文档。
print(MultiDoc, PrintRequestAttributeSet) - 接口 javax.print.MultiDocPrintJob 中的方法
使用指定的作业属性打印 MultiDoc。
print(Graphics) - 类 javax.swing.JComponent 中的方法
调用此方法打印指定 Graphics 的组件。
print() - 类 javax.swing.JTable 中的方法
一个便捷的方法，它显示一个打印对话框，然后以 PrintMode.FIT_WIDTH 模式打印此 JTable，不打印标题或脚注文本。
print(JTable.PrintMode) - 类 javax.swing.JTable 中的方法
一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，不打印标题或脚注文本。
print(JTable.PrintMode, MessageFormat, MessageFormat) - 类 javax.swing.JTable 中的方法
一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean) - 类 javax.swing.JTable 中的方法
根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService) - 类 javax.swing.JTable 中的方法
打印此 JTable。
print() - 类 javax.swing.text.JTextComponent 中的方法
一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，不打印标题和脚注文本。
print(MessageFormat, MessageFormat) - 类 javax.swing.text.JTextComponent 中的方法
一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，打印指定的标题和脚注文本。
print(MessageFormat, MessageFormat, boolean, PrintService, PrintRequestAttributeSet, boolean) - 类 javax.swing.text.JTextComponent 中的方法
打印此 JTextComponent 的内容。
PRINT_SCREEN - 类 java.awt.Event 中的静态变量
Print Screen 键，一个非 ASCII 操作键。
PRINTABLE - 类 java.awt.PageAttributes.OriginType 中的静态变量
用于指定可打印原点的 OriginType 实例。
Printable - java.awt.print 中的 接口
Printable 接口由当前页面 painter 的 print 方法实现，该方法由打印系统调用，以呈现页面。
PRINTABLE - 类 javax.print.DocFlavor.SERVICE_FORMATTED 中的静态变量
打印数据表示形式类名 = "java.awt.print.Printable"（printable 对象）的服务格式化打印数据 DocFlavor。
printAll(Graphics) - 类 java.awt.Component 中的方法
打印此组件及其所有子组件。
printAll(Graphics) - 类 javax.swing.JComponent 中的方法
调用此方法打印组件。
printAnySimpleType(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串值转换为一个字符串。
printAnySimpleType(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串值转换为一个字符串。
printBase64Binary(byte[]) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字节数组转换为一个字符串。
printBase64Binary(byte[]) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字节数组转换为一个字符串。
printBoolean(boolean) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 boolean 值转换为一个字符串。
printBoolean(boolean) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 boolean 值转换为一个字符串。
printBorder(Graphics) - 类 javax.swing.JComponent 中的方法
打印组件的边框。
printByte(byte) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 byte 值转换为一个字符串。
printByte(byte) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 byte 值转换为一个字符串。
printChildren(Graphics) - 类 javax.swing.JComponent 中的方法
打印此组件的子组件。
printComponent(Graphics) - 类 javax.swing.JComponent 中的方法
在打印操作期间调用此方法。
printComponents(Graphics) - 类 java.awt.Container 中的方法
打印此容器中的每个组件。
printComponents(Graphics) - 类 java.awt.ScrollPane 中的方法
显示此滚动窗格中的组件。
PrintConversionEvent - javax.xml.bind 中的 接口
此事件指示将 Java 内容树中的数据转换为其词汇表示形式时遇到一个问题。
PrintConversionEventImpl - javax.xml.bind.helpers 中的 类
PrintConversionEvent 接口的默认实现。
PrintConversionEventImpl(int, String, ValidationEventLocator) - 类 javax.xml.bind.helpers.PrintConversionEventImpl 的构造方法
创建新的 PrintConversionEventImpl。
PrintConversionEventImpl(int, String, ValidationEventLocator, Throwable) - 类 javax.xml.bind.helpers.PrintConversionEventImpl 的构造方法
创建新的 PrintConversionEventImpl。
printDataTransferCompleted(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
printDataTransferCompleted(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
printDate(Calendar) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 Calendar 值转换为一个字符串。
printDate(Calendar) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 Calendar 值转换为一个字符串。
printDateTime(Calendar) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 Calendar 值转换为一个字符串。
printDateTime(Calendar) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 Calendar 值转换为一个字符串。
printDecimal(BigDecimal) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 BigDecimal 值转换为一个字符串。
printDecimal(BigDecimal) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 BigDecimal 值转换为一个字符串。
printDialog() - 类 java.awt.print.PrinterJob 中的方法
向用户呈现一个对话框，用来更改打印作业的属性。
printDialog(PrintRequestAttributeSet) - 类 java.awt.print.PrinterJob 中的方法
为所有服务显示跨平台打印对话框的便捷方法，这些服务能够使用 Pageable 接口打印 2D 图形。
printDialog(GraphicsConfiguration, int, int, PrintService[], PrintService, DocFlavor, PrintRequestAttributeSet) - 类 javax.print.ServiceUI 中的静态方法
为用户提供一个选择 PrintService（打印机）的对话框。
printDouble(double) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 double 值转换为一个字符串。
printDouble(double) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 double 值转换为一个字符串。
printElements(Writer, Element...) - 接口 javax.lang.model.util.Elements 中的方法
按指定顺序将元素的表示形式打印到给定 writer。
PRINTER - 类 java.awt.JobAttributes.DestinationType 中的静态变量
用于指定打印到打印机的 DestinationType 实例。
PRINTER_STOPPED - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机的 PrinterState 属性值为 STOPPED。
PRINTER_STOPPED_PARTLY - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机的 PrinterStateReasons 属性值包含 STOPPED_PARTLY 的 PrinterStateReason 值。
PrinterAbortException - java.awt.print 中的 异常
PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
PrinterAbortException() - 异常 java.awt.print.PrinterAbortException 的构造方法
构造不带详细信息的新 PrinterAbortException。
PrinterAbortException(String) - 异常 java.awt.print.PrinterAbortException 的构造方法
构造带指定详细信息的新 PrinterAbortException。
PrinterException - java.awt.print 中的 异常
PrinterException 类及其子类用于指示打印系统中发生的异常情况。
PrinterException() - 异常 java.awt.print.PrinterException 的构造方法
构造不带详细信息的新 PrinterException 对象。
PrinterException(String) - 异常 java.awt.print.PrinterException 的构造方法
构造带指定详细信息的新 PrinterException 对象。
PrinterGraphics - java.awt.print 中的 接口
PrinterGraphics 接口由被传递到 Printable 对象以呈现页面的 Graphics 对象实现。
PrinterInfo - javax.print.attribute.standard 中的 类
PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
PrinterInfo(String, Locale) - 类 javax.print.attribute.standard.PrinterInfo 的构造方法
构造具有给定信息字符串和语言环境的新 PrinterInfo 属性。
PrinterIOException - java.awt.print 中的 异常
PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。
PrinterIOException(IOException) - 异常 java.awt.print.PrinterIOException 的构造方法
构造具有指定 IOException 字符串表示形式的新 PrinterIOException。
PrinterIsAcceptingJobs - javax.print.attribute.standard 中的 类
PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
PrinterIsAcceptingJobs(int) - 类 javax.print.attribute.standard.PrinterIsAcceptingJobs 的构造方法
构造具有给定整数值的新 PrinterIsAcceptingJobs 枚举值。
PrinterJob - java.awt.print 中的 类
PrinterJob 类是控制打印的主要类。
PrinterJob() - 类 java.awt.print.PrinterJob 的构造方法
应使用静态 getPrinterJob 方法创建 PrinterJob 对象。
PrinterLocation - javax.print.attribute.standard 中的 类
PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
PrinterLocation(String, Locale) - 类 javax.print.attribute.standard.PrinterLocation 的构造方法
构造具有给定位置和语言环境的新 PrinterLocation 属性。
PrinterMakeAndModel - javax.print.attribute.standard 中的 类
PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
PrinterMakeAndModel(String, Locale) - 类 javax.print.attribute.standard.PrinterMakeAndModel 的构造方法
构造具有给定制造和型号字符串以及语言环境的新 PrinterMakeAndModel 属性。
PrinterMessageFromOperator - javax.print.attribute.standard 中的 类
PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
PrinterMessageFromOperator(String, Locale) - 类 javax.print.attribute.standard.PrinterMessageFromOperator 的构造方法
构造具有给定消息和语言环境的新 PrinterMessageFromOperator 属性。
PrinterMoreInfo - javax.print.attribute.standard 中的 类
PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
PrinterMoreInfo(URI) - 类 javax.print.attribute.standard.PrinterMoreInfo 的构造方法
构造具有指定 URI 的新 PrinterMoreInfo 属性。
PrinterMoreInfoManufacturer - javax.print.attribute.standard 中的 类
PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
PrinterMoreInfoManufacturer(URI) - 类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 的构造方法
构造具有指定 URI 的新 PrinterMoreInfoManufacturer 属性。
PrinterName - javax.print.attribute.standard 中的 类
PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
PrinterName(String, Locale) - 类 javax.print.attribute.standard.PrinterName 的构造方法
构造具有给定名称和语言环境的新 PrinterName 属性。
PrinterResolution - javax.print.attribute.standard 中的 类
PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
PrinterResolution(int, int, int) - 类 javax.print.attribute.standard.PrinterResolution 的构造方法
根据给定的项构造新的 PrinterResolution 属性。
PrinterState - javax.print.attribute.standard 中的 类
PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
PrinterState(int) - 类 javax.print.attribute.standard.PrinterState 的构造方法
构造具有给定整数值的新 PrinterState 枚举值。
PrinterStateReason - javax.print.attribute.standard 中的 类
PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
PrinterStateReason(int) - 类 javax.print.attribute.standard.PrinterStateReason 的构造方法
构造具有给定整数值的新 PrinterStateReason 枚举值。
PrinterStateReasons - javax.print.attribute.standard 中的 类
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
PrinterStateReasons() - 类 javax.print.attribute.standard.PrinterStateReasons 的构造方法
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有默认的初始容量和加载因子。
PrinterStateReasons(int) - 类 javax.print.attribute.standard.PrinterStateReasons 的构造方法
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有给定的初始容量和默认的加载因子。
PrinterStateReasons(int, float) - 类 javax.print.attribute.standard.PrinterStateReasons 的构造方法
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有给定的初始容量和加载因子。
PrinterStateReasons(Map<PrinterStateReason, Severity>) - 类 javax.print.attribute.standard.PrinterStateReasons 的构造方法
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。
printerStateReasonSet(Severity) - 类 javax.print.attribute.standard.PrinterStateReasons 中的方法
在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。
PrinterURI - javax.print.attribute.standard 中的 类
PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
PrinterURI(URI) - 类 javax.print.attribute.standard.PrinterURI 的构造方法
构建具有指定 URI 的新 PrinterURI 属性。
PrintEvent - javax.print.event 中的 类
类 PrintEvent 是所有 Print Service API 事件的超类。
PrintEvent(Object) - 类 javax.print.event.PrintEvent 的构造方法
构造一个 PrintEvent 对象。
PrintException - javax.print 中的 异常
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。
PrintException() - 异常 javax.print.PrintException 的构造方法
构造不带详细消息的 print 异常。
PrintException(String) - 异常 javax.print.PrintException 的构造方法
构造带给定详细消息的 print 异常。
PrintException(Exception) - 异常 javax.print.PrintException 的构造方法
构造链接了所提供异常的 print 异常。
PrintException(String, Exception) - 异常 javax.print.PrintException 的构造方法
构造带给定详细消息和链异常的 print 异常。
printf(String, Object...) - 类 java.io.Console 中的方法
使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。
printf(String, Object...) - 类 java.io.PrintStream 中的方法
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。
printf(Locale, String, Object...) - 类 java.io.PrintStream 中的方法
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。
printf(String, Object...) - 类 java.io.PrintWriter 中的方法
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
printf(Locale, String, Object...) - 类 java.io.PrintWriter 中的方法
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
printFloat(float) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 float 值转换为一个字符串。
printFloat(float) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 float 值转换为一个字符串。
PrintGraphics - java.awt 中的 接口
提供页面的打印图形上下文的抽象类。
printHexBinary(byte[]) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字节数组转换为一个字符串。
printHexBinary(byte[]) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字节数组转换为一个字符串。
printInt(int) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 int 值转换为一个字符串。
printInt(int) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 int 值转换为一个字符串。
printInteger(BigInteger) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 BigInteger 值转换为一个字符串。
printInteger(BigInteger) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 BigInteger 值转换为一个字符串。
PrintJob - java.awt 中的 类
启动并执行打印作业的抽象类。
PrintJob() - 类 java.awt.PrintJob 的构造方法
PrintJobAdapter - javax.print.event 中的 类
接收打印作业事件的抽象适配器类。
PrintJobAdapter() - 类 javax.print.event.PrintJobAdapter 的构造方法
PrintJobAttribute - javax.print.attribute 中的 接口
PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
PrintJobAttributeEvent - javax.print.event 中的 类
类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
PrintJobAttributeEvent(DocPrintJob, PrintJobAttributeSet) - 类 javax.print.event.PrintJobAttributeEvent 的构造方法
构造一个 PrintJobAttributeEvent 对象。
PrintJobAttributeListener - javax.print.event 中的 接口
此接口的实现连接到 DocPrintJob，以监视与此打印作业关联的属性状态的更改。
PrintJobAttributeSet - javax.print.attribute 中的 接口
接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。
printJobCanceled(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，作业已被用户或程序取消。
printJobCanceled(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，作业已被用户或程序取消。
printJobCompleted(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，作业已成功完成。
printJobCompleted(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，作业已成功完成。
PrintJobEvent - javax.print.event 中的 类
类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
PrintJobEvent(DocPrintJob, int) - 类 javax.print.event.PrintJobEvent 的构造方法
构造一个 PrintJobEvent 对象。
printJobFailed(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
printJobFailed(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
PrintJobListener - javax.print.event 中的 接口
此侦听器接口的实现应该连接到 DocPrintJob，以监视打印机作业的状态。
printJobNoMoreEvents(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，不需要再提供事件。
printJobNoMoreEvents(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，不需要再提供事件。
printJobRequiresAttention(PrintJobEvent) - 类 javax.print.event.PrintJobAdapter 中的方法
调用此方法来通知客户端，可能会发生一些用户可纠正的问题（例如打印机缺纸）。
printJobRequiresAttention(PrintJobEvent) - 接口 javax.print.event.PrintJobListener 中的方法
调用此方法来通知客户端，发生了一个用户也许能够修复的错误，可以生成此事件的一个错误示例是打印机用完了纸张。
println() - 类 java.io.PrintStream 中的方法
通过写入行分隔符字符串终止当前行。
println(boolean) - 类 java.io.PrintStream 中的方法
打印 boolean 值，然后终止行。
println(char) - 类 java.io.PrintStream 中的方法
打印字符，然后终止该行。
println(int) - 类 java.io.PrintStream 中的方法
打印整数，然后终止该行。
println(long) - 类 java.io.PrintStream 中的方法
打印 long，然后终止该行。
println(float) - 类 java.io.PrintStream 中的方法
打印 float，然后终止该行。
println(double) - 类 java.io.PrintStream 中的方法
打印 double，然后终止该行。
println(char[]) - 类 java.io.PrintStream 中的方法
打印字符数组，然后终止该行。
println(String) - 类 java.io.PrintStream 中的方法
打印 String，然后终止该行。
println(Object) - 类 java.io.PrintStream 中的方法
打印 Object，然后终止该行。
println() - 类 java.io.PrintWriter 中的方法
通过写入行分隔符字符串终止当前行。
println(boolean) - 类 java.io.PrintWriter 中的方法
打印 boolean 值，然后终止该行。
println(char) - 类 java.io.PrintWriter 中的方法
打印字符，然后终止该行。
println(int) - 类 java.io.PrintWriter 中的方法
打印整数，然后终止该行。
println(long) - 类 java.io.PrintWriter 中的方法
打印 long 整数，然后终止该行。
println(float) - 类 java.io.PrintWriter 中的方法
打印浮点数，然后终止该行。
println(double) - 类 java.io.PrintWriter 中的方法
打印双精度浮点数，然后终止该行。
println(char[]) - 类 java.io.PrintWriter 中的方法
打印字符数组，然后终止该行。
println(String) - 类 java.io.PrintWriter 中的方法
打印 String，然后终止该行。
println(Object) - 类 java.io.PrintWriter 中的方法
打印 Object，然后终止该行。
println(String) - 类 java.sql.DriverManager 中的静态方法
将一条消息打印到当前 JDBC 日志流中。
printLong(long) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 long 值转换为一个字符串。
printLong(long) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 long 值转换为一个字符串。
printMessage(Diagnostic.Kind, CharSequence) - 接口 javax.annotation.processing.Messager 中的方法
打印指定种类的消息。
printMessage(Diagnostic.Kind, CharSequence, Element) - 接口 javax.annotation.processing.Messager 中的方法
在元素的位置上打印指定种类的消息。
printMessage(Diagnostic.Kind, CharSequence, Element, AnnotationMirror) - 接口 javax.annotation.processing.Messager 中的方法
在已注释元素的注释镜像位置上打印指定种类的消息。
printMessage(Diagnostic.Kind, CharSequence, Element, AnnotationMirror, AnnotationValue) - 接口 javax.annotation.processing.Messager 中的方法
在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。
printQName(QName, NamespaceContext) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 QName 实例转换为一个字符串。
printQName(QName, NamespaceContext) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 QName 实例转换为一个字符串。
PrintQuality - javax.print.attribute.standard 中的 类
PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
PrintQuality(int) - 类 javax.print.attribute.standard.PrintQuality 的构造方法
构造具有给定整数值的新 PrintQuality 枚举值。
PrintRequestAttribute - javax.print.attribute 中的 接口
接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
PrintRequestAttributeSet - javax.print.attribute 中的 接口
接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。
PrintService - javax.print 中的 接口
接口 PrintService 是 DocPrintJob 的工厂。
PrintServiceAttribute - javax.print.attribute 中的 接口
接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
PrintServiceAttributeEvent - javax.print.event 中的 类
类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。
PrintServiceAttributeEvent(PrintService, PrintServiceAttributeSet) - 类 javax.print.event.PrintServiceAttributeEvent 的构造方法
构造一个 PrintServiceAttributeEvent 对象。
PrintServiceAttributeListener - javax.print.event 中的 接口
此侦听器接口的实现连接到 PrintService，以便监视打印服务的状态。
PrintServiceAttributeSet - javax.print.attribute 中的 接口
接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。
PrintServiceLookup - javax.print 中的 类
此类的实现为特定类型的 PrintService（通常等效于打印机）提供查找服务。
PrintServiceLookup() - 类 javax.print.PrintServiceLookup 的构造方法
printShort(short) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 short 值转换为一个字符串。
printShort(short) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 short 值转换为一个字符串。
printStackTrace() - 类 java.lang.Throwable 中的方法
将此 throwable 及其追踪输出至标准错误流。
printStackTrace(PrintStream) - 类 java.lang.Throwable 中的方法
将此 throwable 及其追踪输出到指定的输出流。
printStackTrace(PrintWriter) - 类 java.lang.Throwable 中的方法
将此 throwable 及其追踪输出到指定的 PrintWriter。
printStackTrace(PrintStream) - 异常 javax.xml.bind.JAXBException 中的方法
打印此 JAXBException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
printStackTrace() - 异常 javax.xml.bind.JAXBException 中的方法
打印此 JAXBException 及其对 System.err 的堆栈跟踪（如果为非 null，则包括 linkedException 的堆栈跟踪）。
printStackTrace(PrintWriter) - 异常 javax.xml.bind.JAXBException 中的方法
打印此 JAXBException 及其对 PrintWriter 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
printStackTrace(PrintStream) - 异常 javax.xml.bind.TypeConstraintException 中的方法
打印此 TypeConstraintException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
printStackTrace() - 异常 javax.xml.bind.TypeConstraintException 中的方法
打印此 TypeConstraintException 及其对 System.err 的堆栈跟踪（如果为非 null，则包括 linkedException 的堆栈跟踪。
printStackTrace() - 异常 javax.xml.crypto.dsig.TransformException 中的方法
将此 TransformException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.dsig.TransformException 中的方法
将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印流中。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.dsig.TransformException 中的方法
将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印编写器。
printStackTrace() - 异常 javax.xml.crypto.dsig.XMLSignatureException 中的方法
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.dsig.XMLSignatureException 中的方法
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.dsig.XMLSignatureException 中的方法
将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。
printStackTrace() - 异常 javax.xml.crypto.KeySelectorException 中的方法
将此 KeySelectorException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.KeySelectorException 中的方法
将此 KeySelectorException、它的追踪和 cause 追踪打印到指定的打印流。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.KeySelectorException 中的方法
将此 KeySelectorException、它的追踪和 cause 追踪打印到指定打印编写器。
printStackTrace() - 异常 javax.xml.crypto.MarshalException 中的方法
将此 MarshalException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.MarshalException 中的方法
将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印流。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.MarshalException 中的方法
将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印编写器。
printStackTrace() - 异常 javax.xml.crypto.NoSuchMechanismException 中的方法
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.NoSuchMechanismException 中的方法
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定的打印流。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.NoSuchMechanismException 中的方法
将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定打印编写器。
printStackTrace() - 异常 javax.xml.crypto.URIReferenceException 中的方法
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到标准错误流中。
printStackTrace(PrintStream) - 异常 javax.xml.crypto.URIReferenceException 中的方法
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流。
printStackTrace(PrintWriter) - 异常 javax.xml.crypto.URIReferenceException 中的方法
将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印编写器。
printStackTrace() - 异常 javax.xml.transform.TransformerException 中的方法
打印从中产生错误的方法跟踪。
printStackTrace(PrintStream) - 异常 javax.xml.transform.TransformerException 中的方法
打印从中产生错误的方法跟踪。
printStackTrace(PrintWriter) - 异常 javax.xml.transform.TransformerException 中的方法
打印从中产生错误的方法跟踪。
printStackTrace(PrintStream) - 异常 javax.xml.xpath.XPathException 中的方法
将堆栈跟踪打印到指定的 PrintStream。
printStackTrace() - 异常 javax.xml.xpath.XPathException 中的方法
将堆栈跟踪打印到 System.err。
printStackTrace(PrintWriter) - 异常 javax.xml.xpath.XPathException 中的方法
将堆栈跟踪打印到指定的 PrintWriter。
PrintStream - java.io 中的 类
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintStream(OutputStream) - 类 java.io.PrintStream 的构造方法
创建新的打印流。
PrintStream(OutputStream, boolean) - 类 java.io.PrintStream 的构造方法
创建新的打印流。
PrintStream(OutputStream, boolean, String) - 类 java.io.PrintStream 的构造方法
创建新的打印流。
PrintStream(String) - 类 java.io.PrintStream 的构造方法
创建具有指定文件名称且不带自动行刷新的新打印流。
PrintStream(String, String) - 类 java.io.PrintStream 的构造方法
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintStream(File) - 类 java.io.PrintStream 的构造方法
创建具有指定文件且不带自动行刷新的新打印流。
PrintStream(File, String) - 类 java.io.PrintStream 的构造方法
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
printString(String) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将字符串参数转换为一个字符串。
printString(String) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将字符串参数转换为一个字符串。
printTime(Calendar) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 Calendar 值转换为一个字符串。
printTime(Calendar) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 Calendar 值转换为一个字符串。
printUnsignedInt(long) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 long 值转换为一个字符串。
printUnsignedInt(long) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 long 值转换为一个字符串。
printUnsignedShort(int) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
将 int 值转换为一个字符串。
printUnsignedShort(int) - 接口 javax.xml.bind.DatatypeConverterInterface 中的方法
将 int 值转换为一个字符串。
PrintWriter - java.io 中的 类
向文本输出流打印对象的格式化表示形式。
PrintWriter(Writer) - 类 java.io.PrintWriter 的构造方法
创建不带自动行刷新的新 PrintWriter。
PrintWriter(Writer, boolean) - 类 java.io.PrintWriter 的构造方法
创建新 PrintWriter。
PrintWriter(OutputStream) - 类 java.io.PrintWriter 的构造方法
根据现有的 OutputStream 创建不带自动行刷新的新 PrintWriter。
PrintWriter(OutputStream, boolean) - 类 java.io.PrintWriter 的构造方法
通过现有的 OutputStream 创建新的 PrintWriter。
PrintWriter(String) - 类 java.io.PrintWriter 的构造方法
创建具有指定文件名称且不带自动行刷新的新 PrintWriter。
PrintWriter(String, String) - 类 java.io.PrintWriter 的构造方法
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。
PrintWriter(File) - 类 java.io.PrintWriter 的构造方法
使用指定文件创建不具有自动行刷新的新 PrintWriter。
PrintWriter(File, String) - 类 java.io.PrintWriter 的构造方法
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
PRIOR - 类 java.awt.BufferCapabilities.FlipContents 中的静态变量
当翻转内容为 PRIOR 时，后台缓冲区的内容为前台缓冲区的先前内容（真实的页面翻转）。
PRIORITY_INTERCHAR - 类 java.awt.font.GlyphJustificationInfo 中的静态变量
次低调整 priority。
PRIORITY_KASHIDA - 类 java.awt.font.GlyphJustificationInfo 中的静态变量
最高调整 priority。
PRIORITY_NONE - 类 java.awt.font.GlyphJustificationInfo 中的静态变量
最低调整 priority。
PRIORITY_WHITESPACE - 类 java.awt.font.GlyphJustificationInfo 中的静态变量
次高调整 priority。
PriorityBlockingQueue<E> - java.util.concurrent 中的 类
一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
PriorityBlockingQueue() - 类 java.util.concurrent.PriorityBlockingQueue 的构造方法
用默认的初始容量 (11) 创建一个 PriorityBlockingQueue，并根据元素的自然顺序对其元素进行排序。
PriorityBlockingQueue(int) - 类 java.util.concurrent.PriorityBlockingQueue 的构造方法
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据元素的自然顺序对其元素进行排序。
PriorityBlockingQueue(int, Comparator<? super E>) - 类 java.util.concurrent.PriorityBlockingQueue 的构造方法
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据指定的比较器对其元素进行排序。
PriorityBlockingQueue(Collection<? extends E>) - 类 java.util.concurrent.PriorityBlockingQueue 的构造方法
创建一个包含指定 collection 元素的 PriorityBlockingQueue。
PriorityQueue<E> - java.util 中的 类
一个基于优先级堆的无界优先级队列。
PriorityQueue() - 类 java.util.PriorityQueue 的构造方法
使用默认的初始容量（11）创建一个 PriorityQueue，并根据其自然顺序对元素进行排序。
PriorityQueue(int) - 类 java.util.PriorityQueue 的构造方法
使用指定的初始容量创建一个 PriorityQueue，并根据其自然顺序对元素进行排序。
PriorityQueue(int, Comparator<? super E>) - 类 java.util.PriorityQueue 的构造方法
使用指定的初始容量创建一个 PriorityQueue，并根据指定的比较器对元素进行排序。
PriorityQueue(Collection<? extends E>) - 类 java.util.PriorityQueue 的构造方法
创建包含指定 collection 中元素的 PriorityQueue。
PriorityQueue(PriorityQueue<? extends E>) - 类 java.util.PriorityQueue 的构造方法
创建包含指定优先级队列元素的 PriorityQueue。
PriorityQueue(SortedSet<? extends E>) - 类 java.util.PriorityQueue 的构造方法
创建包含指定有序 set 元素的 PriorityQueue。
PRIVATE - 类 java.lang.reflect.Modifier 中的静态变量
表示 private 修饰符的 int 值。
PRIVATE - 类 java.nio.channels.FileChannel.MapMode 中的静态变量
专用（写入时拷贝）映射模式。
PRIVATE_KEY - 类 javax.crypto.Cipher 中的静态变量
用于表示要解包的密钥为“私钥”的常量。
PRIVATE_MEMBER - org.omg.CORBA 中的 接口
定义 ValueMember 类中私有成员的常量。
PRIVATE_USE - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Co”。
PRIVATE_USE_AREA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Private Use Area”Unicode 字符块的常量。
PrivateClassLoader - javax.management.loading 中的 接口
指示不应将某个 ClassLoader 添加到 ClassLoaderRepository 的标记接口。
PrivateCredentialPermission - javax.security.auth 中的 类
此类用来保护对属于特定 Subject 的私有 Credential 的访问。
PrivateCredentialPermission(String, String) - 类 javax.security.auth.PrivateCredentialPermission 的构造方法
创建具有指定 name 的新 PrivateCredentialPermission。
PrivateKey - java.security 中的 接口
私钥。
PrivateMLet - javax.management.loading 中的 类
不添加到 ClassLoaderRepository 的 MLet。
PrivateMLet(URL[], boolean) - 类 javax.management.loading.PrivateMLet 的构造方法
使用默认的委托父 ClassLoader 为指定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[], ClassLoader, boolean) - 类 javax.management.loading.PrivateMLet 的构造方法
为给定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[], ClassLoader, URLStreamHandlerFactory, boolean) - 类 javax.management.loading.PrivateMLet 的构造方法
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。
PrivilegedAction<T> - java.security 中的 接口
启用特权的情况下要执行的计算。
PrivilegedActionException - java.security 中的 异常
doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
PrivilegedActionException(Exception) - 异常 java.security.PrivilegedActionException 的构造方法
构造一个新的“包装”指定 Exception 的 PrivilegedActionException。
privilegedCallable(Callable<T>) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可在当前的访问控制上下文中执行给定的 callable 对象。
privilegedCallableUsingCurrentClassLoader(Callable<T>) - 类 java.util.concurrent.Executors 中的静态方法
返回 Callable 对象，调用它时可在当前的访问控制上下文中，使用当前上下文类加载器作为上下文类加载器来执行给定的 callable 对象。
PrivilegedExceptionAction<T> - java.security 中的 接口
在启用特权的情况下将要执行的计算，会抛出一个或多个经过检查的异常。
privilegedThreadFactory() - 类 java.util.concurrent.Executors 中的静态方法
返回用于创建新线程的线程工厂，这些新线程与当前线程具有相同的权限。
probablePrime(int, Random) - 类 java.math.BigInteger 中的静态方法
返回有可能是素数的、具有指定长度的正 BigInteger。
procedureColumnIn - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了 IN 参数。
procedureColumnInOut - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了 INOUT 参数。
procedureColumnOut - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了 OUT 参数。
procedureColumnResult - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了结果。
procedureColumnReturn - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列中存储了返回值。
procedureColumnUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示列的类型为未知。
procedureNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不允许使用 NULL 值。
procedureNoResult - 接口 java.sql.DatabaseMetaData 中的静态变量
指示过程不返回结果。
procedureNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示允许使用 NULL 值。
procedureNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道是否允许使用 NULL 值。
procedureResultUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道过程是否返回结果。
procedureReturnsResult - 接口 java.sql.DatabaseMetaData 中的静态变量
指示过程返回结果。
Process - java.lang 中的 类
ProcessBuilder.start() 和 Runtime.exec 方法创建一个本机进程，并返回 Process 子类的一个实例，该实例可用来控制进程并获得相关信息。
Process() - 类 java.lang.Process 的构造方法
process(Set<? extends TypeElement>, RoundEnvironment) - 类 javax.annotation.processing.AbstractProcessor 中的方法
处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
process(Set<? extends TypeElement>, RoundEnvironment) - 接口 javax.annotation.processing.Processor 中的方法
处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
process(List<V>) - 类 javax.swing.SwingWorker 中的方法
在事件指派线程 上异步地从 publish 方法接收数据块。
processActionEvent(ActionEvent) - 类 java.awt.Button 中的方法
处理发生在此按钮上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
processActionEvent(ActionEvent) - 类 java.awt.List 中的方法
处理发生在此列表上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
processActionEvent(ActionEvent) - 类 java.awt.MenuItem 中的方法
处理此菜单项上发生的动作事件，方法是将其指派给任何已注册的 ActionListener 对象。
processActionEvent(ActionEvent) - 类 java.awt.TextField 中的方法
处理发生在此文本字段上的操作事件：将这些事件指派给所有已注册的 ActionListener 对象。
processAdjustmentEvent(AdjustmentEvent) - 类 java.awt.Scrollbar 中的方法
处理此滚动条上发生的调整事件，方法是将其指派到任意已注册的 AdjustmentListener 对象。
ProcessBuilder - java.lang 中的 类
此类用于创建操作系统进程。
ProcessBuilder(List<String>) - 类 java.lang.ProcessBuilder 的构造方法
利用指定的操作系统程序和参数构造一个进程生成器。
ProcessBuilder(String...) - 类 java.lang.ProcessBuilder 的构造方法
利用指定的操作系统程序和参数构造一个进程生成器。
processComponentEvent(ComponentEvent) - 类 java.awt.Component 中的方法
处理组件上发生的组件事件，方法是将其指派到任意已注册的 ComponentListener 对象。
processComponentKeyEvent(KeyEvent) - 类 javax.swing.JComponent 中的方法
处理该组件本身可识别的所有键事件。
processContainerEvent(ContainerEvent) - 类 java.awt.Container 中的方法
通过将发生在此容器上的容器事件指派给所有已注册的 ContainerListener 对象来处理这些事件。
processEvent(AWTEvent) - 类 java.awt.Button 中的方法
处理此按钮上的事件。
processEvent(AWTEvent) - 类 java.awt.Checkbox 中的方法
处理关于此复选框的事件。
processEvent(AWTEvent) - 类 java.awt.CheckboxMenuItem 中的方法
处理此复选框菜单项上的事件。
processEvent(AWTEvent) - 类 java.awt.Choice 中的方法
处理关于此选择的事件。
processEvent(AWTEvent) - 类 java.awt.Component 中的方法
处理组件上发生的事件。
processEvent(AWTEvent) - 类 java.awt.Container 中的方法
处理关于此容器的事件。
processEvent(AWTEvent) - 类 java.awt.List 中的方法
此滚动列表的进程事件。
processEvent(AWTEvent) - 类 java.awt.MenuComponent 中的方法
处理发生在此菜单组件上的事件。
processEvent(AWTEvent) - 类 java.awt.MenuItem 中的方法
处理此菜单项上的事件。
processEvent(AWTEvent) - 类 java.awt.Scrollbar 中的方法
处理在滚动条上发生的事件。
processEvent(AWTEvent) - 类 java.awt.TextComponent 中的方法
处理此文本组件上发生的事件。
processEvent(AWTEvent) - 类 java.awt.TextField 中的方法
处理此文本字段上的事件。
processEvent(AWTEvent) - 类 java.awt.Window 中的方法
处理此窗口上的事件。
processFocusEvent(FocusEvent) - 类 java.awt.Component 中的方法
处理组件上发生的焦点事件，方法是将其指派到任意已注册的 FocusListener 对象。
processFocusEvent(FocusEvent) - 类 javax.swing.JFormattedTextField 中的方法
处理所有的焦点事件，如 FocusEvent.FOCUS_GAINED 或 FocusEvent.FOCUS_LOST。
processFocusEvent(FocusEvent) - 类 javax.swing.JPopupMenu 中的方法
processHierarchyBoundsEvent(HierarchyEvent) - 类 java.awt.Component 中的方法
处理组件上发生的层次结构边界事件，方法是将其指派到任意已注册的 HierarchyBoundsListener 对象。
processHierarchyEvent(HierarchyEvent) - 类 java.awt.Component 中的方法
处理组件上发生的层次结构事件，方法是将其指派到任意已注册的 HierarchyListener 对象。
processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent) - 类 javax.swing.text.html.HTMLDocument 中的方法
处理 HTML 框架中的文档所生成的 HyperlinkEvents。
processImageComplete() - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 imageComplete 方法向其广播图像读取的完成。
processImageComplete() - 类 javax.imageio.ImageWriter 中的方法
通过调用 imageComplete 方法向所有已注册 IIOWriteProgressListener 广播图像写入的完成。
processImageProgress(float) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 imageProgress 方法向其广播图像完成的当前百分比。
processImageProgress(float) - 类 javax.imageio.ImageWriter 中的方法
通过调用 imageProgress 方法向所有已注册 IIOWriteProgressListener 广播图像完成的当前百分比。
processImageStarted(int) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 imageStarted 方法向其广播图像读取起始处。
processImageStarted(int) - 类 javax.imageio.ImageWriter 中的方法
通过调用 imageStarted 方法向所有已注册 IIOWriteProgressListener 广播开始写入图像的起始处。
processImageUpdate(BufferedImage, int, int, int, int, int, int, int[]) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 imageUpdate 方法向其广播样本集合的更新。
PROCESSING - 类 javax.print.attribute.standard.JobState 中的静态变量
正在处理作业。
PROCESSING - 类 javax.print.attribute.standard.PrinterState 中的静态变量
指示正在处理作业；处理完成前新作业需等待。
PROCESSING_INSTRUCTION - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一条处理指令
PROCESSING_INSTRUCTION_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 ProcessingInstruction。
PROCESSING_STOPPED - 类 javax.print.attribute.standard.JobState 中的静态变量
由于某些原因，正在处理时作业已停止，且当这些原因不再存在时，作业返回到 PROCESSING 状态。
PROCESSING_TO_STOP_POINT - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
请求者已取消作业，或打印机已中止作业，但打印机仍在执行该作业的某些操作，直到遇到指定的停止点，或已完成作业终止/清除操作。
processingEnv - 类 javax.annotation.processing.AbstractProcessor 中的变量
工具框架提供的处理环境。
ProcessingEnvironment - javax.annotation.processing 中的 接口
注释处理工具框架将提供一个具有实现此接口的对象的注释 processor，因此 processor 可以使用该框架提供的设施来编写新文件、报告错误消息并查找其他实用工具。
ProcessingInstruction - javax.xml.stream.events 中的 接口
描述处理指令中的数据的接口。
ProcessingInstruction - org.w3c.dom 中的 接口
ProcessingInstruction 接口表示“处理指令”，该指令作为一种在文档的文本中保持特定于处理器的信息的方法在 XML 中使用。
processingInstruction(String, String) - 接口 org.xml.sax.ContentHandler 中的方法
接收处理指令的通知。
processingInstruction(String, String) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收处理指令的通知。
processingInstruction(String, String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收处理指令的通知。
processingInstruction(String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收处理指令的通知。
processingInstruction(String, String) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
processingInstruction(String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个处理指令事件。
processingInstruction(String, String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 处理指令事件。
processingOver() - 接口 javax.annotation.processing.RoundEnvironment 中的方法
如果此 round 生成的类型不是以注释处理的后续 round 为准，则返回 true；否则返回 false。
processInputMethodEvent(InputMethodEvent) - 类 java.awt.Component 中的方法
处理组件上发生的输入方法事件，方法是将其指派到任意已注册的 InputMethodListener 对象。
processInputMethodEvent(InputMethodEvent) - 类 javax.swing.JFormattedTextField 中的方法
处理所有的输入法事件，如 InputMethodEvent.INPUT_METHOD_TEXT_CHANGED 或 InputMethodEvent.CARET_POSITION_CHANGED。
processInputMethodEvent(InputMethodEvent) - 类 javax.swing.text.JTextComponent 中的方法
processItemEvent(ItemEvent) - 类 java.awt.Checkbox 中的方法
处理发生在此复选框上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
processItemEvent(ItemEvent) - 类 java.awt.CheckboxMenuItem 中的方法
处理发生在此复选框菜单项上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
processItemEvent(ItemEvent) - 类 java.awt.Choice 中的方法
处理发生在此 Choice 菜单上的项事件，实现方式是将这些事件指派给所有已注册的 ItemListener 对象。
processItemEvent(ItemEvent) - 类 java.awt.List 中的方法
处理发生在此列表上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - 类 javax.swing.JComponent 中的方法
由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - 类 javax.swing.JMenuBar 中的方法
子类化以检查所有子菜单。
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - 类 javax.swing.JTable 中的方法
processKeyBindings(KeyEvent) - 类 javax.swing.SwingUtilities 中的静态方法
处理与 event 关联的 Component 的键绑定。
processKeyEvent(KeyEvent) - 类 java.awt.Component 中的方法
处理组件上发生的按键事件，方法是将其指派到任意已注册的 KeyListener 对象。
processKeyEvent(Component, KeyEvent) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法才会启动一个焦点遍历操作。
processKeyEvent(Component, KeyEvent) - 类 java.awt.KeyboardFocusManager 中的方法
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法启动焦点遍历操作。
processKeyEvent(KeyEvent) - 类 javax.swing.JComboBox 中的方法
处理 KeyEvent，查找 Tab 键。
processKeyEvent(KeyEvent) - 类 javax.swing.JComponent 中的方法
重写 processKeyEvent 以处理事件。
processKeyEvent(KeyEvent) - 类 javax.swing.JMenu 中的方法
处理键击事件，如助记符和加速器。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement（不执行任何操作）。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JMenuItem 中的方法
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
processKeyEvent(KeyEvent) - 类 javax.swing.JPopupMenu 中的方法
处理快捷键事件，如助记符和加速器。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JPopupMenu 中的方法
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - 接口 javax.swing.MenuElement 中的方法
处理键事件。
processKeyEvent(KeyEvent) - 类 javax.swing.MenuSelectionManager 中的方法
当 MenuElement 从 KeyListener 接收事件时，它决不应直接处理该事件。
processMenuDragMouseEvent(MenuDragMouseEvent) - 类 javax.swing.JMenuItem 中的方法
处理菜单中的鼠标拖动。
processMenuKeyEvent(MenuKeyEvent) - 类 javax.swing.JMenuItem 中的方法
处理菜单中的快捷键。
processMouseEvent(MouseEvent) - 类 java.awt.Component 中的方法
处理组件上发生的鼠标事件，方法是将其指派到任意已注册的 MouseListener 对象。
processMouseEvent(MouseEvent) - 类 javax.swing.JComponent 中的方法
处理此组件上发生的鼠标事件，通过将其指派到任意已注册的 MouseListener 对象来完成，有关此方法的完整描述，请参阅 Component.processMouseEvent(MouseEvent)。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JMenuBar 中的方法
实现为 MenuElement（不执行任何操作）。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JMenuItem 中的方法
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.JPopupMenu 中的方法
要求此方法遵守 MenuElement 接口，但它没有被实现。
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - 接口 javax.swing.MenuElement 中的方法
处理鼠标事件。
processMouseEvent(MouseEvent) - 类 javax.swing.MenuSelectionManager 中的方法
当 MenuElement 从 MouseListener 接收事件时，它决不应直接处理该事件。
processMouseEvent(JMenuItem, MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.plaf.basic.BasicCheckBoxMenuItemUI 中的方法
processMouseEvent(JMenuItem, MouseEvent, MenuElement[], MenuSelectionManager) - 类 javax.swing.plaf.basic.BasicRadioButtonMenuItemUI 中的方法
processMouseMotionEvent(MouseEvent) - 类 java.awt.Component 中的方法
处理组件上发生的鼠标移动事件，方法是将其指派到任意已注册的 MouseMotionListener 事件。
processMouseMotionEvent(MouseEvent) - 类 javax.swing.JComponent 中的方法
处理鼠标移动事件，如 MouseEvent.MOUSE_DRAGGED。
processMouseWheelEvent(MouseWheelEvent) - 类 java.awt.Component 中的方法
处理组件上发生的鼠标滚轮事件，方法是将其指派到任意已注册的 MouseWheelListener 对象。
processMouseWheelEvent(MouseWheelEvent) - 类 java.awt.ScrollPane 中的方法
处理通过滚动适当量而传递给此 ScrollPane 的鼠标滚轮事件。
processName(String, String[], boolean) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。
Processor - javax.annotation.processing 中的 接口
注释 Processor 的接口。
processPassComplete(BufferedImage) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 passComplete 方法向其广播逐步传递的结束。
processPassStarted(BufferedImage, int, int, int, int, int, int, int, int[]) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 passStarted 方法向其广播逐步传递的开始。
processReadAborted() - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 readAborted 方法向其广播读取已经中止。
processSequenceComplete() - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 sequenceComplete 方法向其广播图像读取序列的完成。
processSequenceStarted(int) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 sequenceStarted 方法向其广播图像读取序列的起始处。
processTextEvent(TextEvent) - 类 java.awt.TextComponent 中的方法
处理发生在此文本组件上的文本事件：将这些事件指派给所有已注册的 TextListener 对象。
processThumbnailComplete() - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 thumbnailComplete 方法向其广播缩略图读取的完成。
processThumbnailComplete() - 类 javax.imageio.ImageWriter 中的方法
通过调用 thumbnailComplete 方法向所有已注册 IIOWriteProgressListener 广播缩略图写入的完成。
processThumbnailPassComplete(BufferedImage) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassComplete 方法向其广播缩略图逐步传递的结束。
processThumbnailPassStarted(BufferedImage, int, int, int, int, int, int, int, int[]) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassStarted 方法向其广播缩略图逐步传递的开始。
processThumbnailProgress(float) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 thumbnailProgress 方法向其广播缩略图完成的当前百分比。
processThumbnailProgress(float) - 类 javax.imageio.ImageWriter 中的方法
通过调用 thumbnailProgress 方法向所有已注册 IIOWriteProgressListener 广播缩略图完成的当前百分比。
processThumbnailStarted(int, int) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadProgressListener 的 thumbnailStarted 方法向其广播缩略图读取的起始处。
processThumbnailStarted(int, int) - 类 javax.imageio.ImageWriter 中的方法
通过调用 thumbnailStarted 方法向所有已注册 IIOWriteProgressListener 广播缩略图写入的起始处。
processThumbnailUpdate(BufferedImage, int, int, int, int, int, int, int[]) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailUpdate 方法向其广播缩略图图像中样本集合的更新。
processWarningOccurred(String) - 类 javax.imageio.ImageReader 中的方法
通过调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播警告消息。
processWarningOccurred(String, String) - 类 javax.imageio.ImageReader 中的方法
通过使用取自 ResourceBundle 的字符串调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播本地化警告消息。
processWarningOccurred(int, String) - 类 javax.imageio.ImageWriter 中的方法
通过调用 warningOccurred 方法向所有已注册 IIOWriteWarningListener 广播一条警告消息。
processWarningOccurred(int, String, String) - 类 javax.imageio.ImageWriter 中的方法
通过使用取自 ResourceBundle 的字符串调用 warningOccurred 方法来向所有已注册 IIOWriteWarningListener 广播一条本地化警告消息。
processWindowEvent(WindowEvent) - 类 java.awt.Window 中的方法
处理此窗口上发生的窗口事件：将它们指派到任何注册的 WindowListener 对象。
processWindowEvent(WindowEvent) - 类 javax.swing.JDialog 中的方法
根据 defaultCloseOperation 属性的状态处理窗口事件。
processWindowEvent(WindowEvent) - 类 javax.swing.JFrame 中的方法
处理此组件上发生的窗口事件。
processWindowFocusEvent(WindowEvent) - 类 java.awt.Window 中的方法
处理此窗口上发生的窗口焦点事件：将它们指派到任何注册的 WindowFocusListener 对象。
processWindowStateEvent(WindowEvent) - 类 java.awt.Window 中的方法
处理此窗口上发生的窗口状态事件：将它们指派到任何注册的 WindowStateListener 对象。
processWriteAborted() - 类 javax.imageio.ImageWriter 中的方法
通过调用 readAborted 方法向对所有已注册 IIOWriteProgressListener 广播写入已经中止。
profile_data - 类 org.omg.IOP.TaggedProfile 中的变量
关联的配置文件数据。
ProfileDataException - java.awt.color 中的 异常
当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。
ProfileDataException(String) - 异常 java.awt.color.ProfileDataException 的构造方法
构造带指定详细消息的 ProfileDataException。
ProfileIdHelper - org.omg.IOP 中的 类
配置文件 ID
ProfileIdHelper() - 类 org.omg.IOP.ProfileIdHelper 的构造方法
profiles - 类 org.omg.IOP.IOR 中的变量
与此对象引用关联的一组有标记的配置文件。
program - 类 javax.sound.midi.VoiceStatus 中的变量
此声音当前正在使用的乐器的程序号。
PROGRAM_CHANGE - 类 javax.sound.midi.ShortMessage 中的静态变量
PROGRAM_CHANGE 消息的命令值（0xC0 或 192）
programChange(int) - 接口 javax.sound.midi.MidiChannel 中的方法
更改一个程序（包）。
programChange(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
使用库和程序（包）号更改程序。
PROGRESS - 接口 java.util.jar.Pack200.Packer 中的静态变量
解包器的百分比进度，由解包器定期更新。
PROGRESS - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
解包器的百分比进度，由解包器定期更新。
PROGRESS_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
用于指示某项任务已完成多少的对象。
PROGRESS_BAR - 类 javax.swing.plaf.synth.Region 中的静态变量
ProgressBar 的 region。
PROGRESS_MONITOR - 类 javax.accessibility.AccessibleRole 中的静态变量
该职责表示监视某个操作进度的对象。
progressBar - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的变量
ProgressBarUI - javax.swing.plaf 中的 类
JProgressBar 的可插入外观界面。
ProgressBarUI() - 类 javax.swing.plaf.ProgressBarUI 的构造方法
progressiveMode - 类 javax.imageio.ImageWriteParam 中的变量
控制逐步编码的模式，必须将它设置为除 MODE_EXPLICIT 以外的四个 MODE_* 值之一。
progressListeners - 类 javax.imageio.ImageReader 中的变量
当前已注册 IIOReadProgressListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
progressListeners - 类 javax.imageio.ImageWriter 中的变量
当前已注册 IIOWriteProgressListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
ProgressMonitor - javax.swing 中的 类
监视某个操作的进度的类。
ProgressMonitor(Component, Object, String, int, int) - 类 javax.swing.ProgressMonitor 的构造方法
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。
ProgressMonitor.AccessibleProgressMonitor - javax.swing 中的 类
AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。
ProgressMonitor.AccessibleProgressMonitor() - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 的构造方法
AccessibleProgressMonitor 构造方法
ProgressMonitorInputStream - javax.swing 中的 类
监视读取某些 InputStream 的进度。
ProgressMonitorInputStream(Component, Object, InputStream) - 类 javax.swing.ProgressMonitorInputStream 的构造方法
构造一个对象，以监视输入流的进度。
progressString - 类 javax.swing.JProgressBar 中的变量
可以在进度条上显示的可选字符串。
PROMPT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
propagatedFrom - 类 java.beans.beancontext.BeanContextEvent 中的变量
作为此事件传播源的 BeanContext
PROPERTIES - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示该图像的属性现在可用。
properties() - 接口 java.util.jar.Pack200.Packer 中的方法
获取此引擎属性集。
properties() - 接口 java.util.jar.Pack200.Unpacker 中的方法
获取此引擎属性集。
Properties - java.util 中的 类
Properties 类表示了一个持久的属性集。
Properties() - 类 java.util.Properties 的构造方法
创建一个无默认值的空属性列表。
Properties(Properties) - 类 java.util.Properties 的构造方法
创建一个带有指定默认值的空属性列表。
properties() - 类 javax.sound.midi.MidiFileFormat 中的方法
获得属性的一个不可修改的映射。
properties() - 类 javax.sound.sampled.AudioFileFormat 中的方法
获得不可修改的属性映射。
properties() - 类 javax.sound.sampled.AudioFormat 中的方法
获取不可修改的属性映射。
PROPERTY - 类 org.w3c.dom.bootstrap.DOMImplementationRegistry 中的静态变量
指定 DOMImplementationSource 类名称的系统属性。
propertyChange(PropertyChangeEvent) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以封装此方法来监视子类属性的更改。
propertyChange(PropertyChangeEvent) - 接口 java.beans.PropertyChangeListener 中的方法
在绑定属性发生更改时调用此方法。
propertyChange(PropertyChangeEvent) - 类 java.beans.PropertyChangeListenerProxy 中的方法
将属性更改事件转发给侦听器代理。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
Property Change Listener 更改方法。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JPopupMenu.AccessibleJPopupMenu 中的方法
更改绑定 (bound) 属性时调用此方法。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的方法
当有一个绑定 (bound) 属性改变时，此方法被调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
由 JFormattedTextField 的 PropertyChangeListener 调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪选择模型、列模型等的变更，从而能够重新将侦听器放置这些模型上，以便把信息传递给 Accessibility PropertyChange 机制
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，调用此方法。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener 中的方法
从 JInternalFrame 检测状态更改并处理动作。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler 中的方法
如果 PropertyChangeEvent e 的源等于 optionPane 并且为 ICON_PROPERTY、MESSAGE_PROPERTY、OPTIONS_PROPERTY 或 INITIAL_VALUE_PROPERTY 之一，则调用 validateComponent。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
在根窗格上发生属性更改时调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
属性更改事件（假定发自 JSplitPane）将在必要时传递 updateOrientation 的消息。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler 中的方法
从包含接收者的 JSplitPane 传递消息。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTextAreaUI 中的方法
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTextPaneUI 中的方法
当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
当关联的 JTextComponent 上有一个绑定属性更改时，此方法被调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.PropertyListener 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalRootPaneUI 中的方法
属性更改时调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener 中的方法
propertyChange(PropertyChangeEvent) - 类 javax.swing.plaf.metal.MetalTextFieldUI 中的方法
此方法在关联的 JTextComponent 上的绑定 (bound) 属性发生更改时调用。
propertyChange(PropertyChangeEvent) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
更改绑定 (bound) 属性时，调用此方法。
propertyChange(PropertyChangeEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
Property Change Listener 更改方法。
PropertyChangeEvent - java.beans 中的 类
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeEvent(Object, String, Object, Object) - 类 java.beans.PropertyChangeEvent 的构造方法
构造一个新的 PropertyChangeEvent。
PropertyChangeListener - java.beans 中的 接口
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的变量
此受保护字段是特定于实现的。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicListUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
从 createPropertyChangeListener 返回的 PropertyChangeListener。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
propertyChangeListener - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
此 JSplitPane 的 PropertyChangeListener 的实例。
propertyChangeListener - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
PropertyChangeListenerProxy - java.beans 中的 类
扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。
PropertyChangeListenerProxy(String, PropertyChangeListener) - 类 java.beans.PropertyChangeListenerProxy 的构造方法
将 PropertyChangeListener 绑定到特定属性的构造方法。
PropertyChangeSupport - java.beans 中的 类
这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。
PropertyChangeSupport(Object) - 类 java.beans.PropertyChangeSupport 的构造方法
构造一个 PropertyChangeSupport 对象。
PropertyDescriptor - java.beans 中的 类
PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。
PropertyDescriptor(String, Class<?>) - 类 java.beans.PropertyDescriptor 的构造方法
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。
PropertyDescriptor(String, Class<?>, String, String) - 类 java.beans.PropertyDescriptor 的构造方法
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。
PropertyDescriptor(String, Method, Method) - 类 java.beans.PropertyDescriptor 的构造方法
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
PropertyEditor - java.beans 中的 接口
PropertyEditor 类为希望允许用户编辑某个给定类型的属性值的 GUI 提供支持。
PropertyEditorManager - java.beans 中的 类
PropertyEditorManager 可用于查找任何给定类型名称的属性编辑器。
PropertyEditorManager() - 类 java.beans.PropertyEditorManager 的构造方法
PropertyEditorSupport - java.beans 中的 类
这是一个帮助构建属性编辑器的支持类。
PropertyEditorSupport() - 类 java.beans.PropertyEditorSupport 的构造方法
构造一个 PropertyEditorSupport 对象。
PropertyEditorSupport(Object) - 类 java.beans.PropertyEditorSupport 的构造方法
构造一个 PropertyEditorSupport 对象。
PropertyException - javax.xml.bind 中的 异常
此异常指示在获取或设置属性时遇到一个错误。
PropertyException(String) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带指定详细消息的 PropertyException。
PropertyException(String, String) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 PropertyException。
PropertyException(Throwable) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带有一个 linkedException 的 PropertyException。
PropertyException(String, Throwable) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带指定详细消息和 linkedException 的 PropertyException。
PropertyException(String, String, Throwable) - 异常 javax.xml.bind.PropertyException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 PropertyException。
PropertyException(String, Object) - 异常 javax.xml.bind.PropertyException 的构造方法
构造一个基于属性名称和 value.toString() 设置其消息字段的 PropertyException。
propertyKey - 类 javax.swing.plaf.basic.BasicHTML 中的静态变量
存储为 JComponent 的客户端属性时用于 html 渲染器的键。
propertyListener - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
PROPERTYNAME - 接口 java.beans.DesignMode 中的静态变量
从 BeanContext 或 PropertyChangeEvent 的其他源激发的 propertyName 的标准值。
propertyNames() - 类 java.util.Properties 中的方法
返回属性列表中所有键的枚举，如果在主属性列表中未找到同名的键，则包括默认属性列表中不同的键。
PropertyPermission - java.util 中的 类
此类用于属性权限。
PropertyPermission(String, String) - 类 java.util.PropertyPermission 的构造方法
创建带指定名称的新 PropertyPermission 对象。
PropertyResourceBundle - java.util 中的 类
PropertyResourceBundle 是 ResourceBundle 的一个具体子类，它使用属性文件中的静态字符串集来管理语言环境资源。
PropertyResourceBundle(InputStream) - 类 java.util.PropertyResourceBundle 的构造方法
根据 InputStream 创建属性资源包。
PropertyResourceBundle(Reader) - 类 java.util.PropertyResourceBundle 的构造方法
根据 Reader 创建属性资源包。
PropertyVetoException - java.beans 中的 异常
当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。
PropertyVetoException(String, PropertyChangeEvent) - 异常 java.beans.PropertyVetoException 的构造方法
构造带详细消息的 PropertyVetoException。
PROTECTED - 类 java.lang.reflect.Modifier 中的静态变量
表示 protected 修饰符的 int 值。
ProtectionDomain - java.security 中的 类
此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。
ProtectionDomain(CodeSource, PermissionCollection) - 类 java.security.ProtectionDomain 的构造方法
创建具有给定 CodeSource 和 Permissions 的新 ProtectionDomain。
ProtectionDomain(CodeSource, PermissionCollection, ClassLoader, Principal[]) - 类 java.security.ProtectionDomain 的构造方法
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。
PROTOCOL_PROVIDER_CLASS_LOADER - 类 javax.management.remote.JMXConnectorFactory 中的静态变量
指定用于加载协议提供者的类加载器的属性名称。
PROTOCOL_PROVIDER_CLASS_LOADER - 类 javax.management.remote.JMXConnectorServerFactory 中的静态变量
指定用于加载协议提供者的类加载器的属性名称。
PROTOCOL_PROVIDER_PACKAGES - 类 javax.management.remote.JMXConnectorFactory 中的静态变量
指定查找协议的处理程序时需参考的提供者包的属性名称。
PROTOCOL_PROVIDER_PACKAGES - 类 javax.management.remote.JMXConnectorServerFactory 中的静态变量
指定查找协议的处理程序时需参考的提供者包的属性名称。
PROTOCOL_VERSION_1 - 接口 java.io.ObjectStreamConstants 中的静态变量
流协议的版本。
PROTOCOL_VERSION_2 - 接口 java.io.ObjectStreamConstants 中的静态变量
流协议的版本。
ProtocolException - java.net 中的 异常
抛出此异常指示在底层协议中存在错误，如 TCP 错误。
ProtocolException(String) - 异常 java.net.ProtocolException 的构造方法
构造带指定详细消息的新 ProtocolException。
ProtocolException() - 异常 java.net.ProtocolException 的构造方法
构造不带详细消息的新 ProtocolException。
ProtocolException - javax.xml.ws 中的 异常
ProtocolException 类是与特定协议绑定有关的异常的基类。
ProtocolException() - 异常 javax.xml.ws.ProtocolException 的构造方法
构造一个新的协议异常，将 null 作为它的详细消息。
ProtocolException(String) - 异常 javax.xml.ws.ProtocolException 的构造方法
构造一个具有指定详细消息的新协议异常。
ProtocolException(String, Throwable) - 异常 javax.xml.ws.ProtocolException 的构造方法
构造一个具有指定详细消息和 cause 的新运行时异常。
ProtocolException(Throwable) - 异常 javax.xml.ws.ProtocolException 的构造方法
构造具有指定 cause 和详细消息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新运行时异常。
prototypeCellValueChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
provideErrorFeedback(Component) - 类 javax.swing.LookAndFeel 中的方法
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
provideErrorFeedback(Component) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的方法
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
provider() - 类 java.nio.channels.SelectableChannel 中的方法
返回创建此通道的提供者。
provider() - 类 java.nio.channels.Selector 中的方法
返回创建此通道的提供者。
provider() - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
返回创建此通道的提供者。
provider() - 类 java.nio.channels.spi.AbstractSelector 中的方法
返回创建此通道的提供者。
provider() - 类 java.nio.channels.spi.SelectorProvider 中的静态方法
返回此次调用 Java 虚拟机的系统级默认选择器提供者。
Provider - java.security 中的 类
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
Provider(String, double, String) - 类 java.security.Provider 的构造方法
用指定的名称、版本号和信息构造一个 provider。
Provider<T> - javax.xml.ws 中的 接口
服务端点可以将 Provider 接口作为 SEI 的动态替代方法实现。
Provider - javax.xml.ws.spi 中的 类
ServiceDelegate 和 Endpoint 对象的服务提供者。
Provider() - 类 javax.xml.ws.spi.Provider 的构造方法
创建一个新的 Provider 实例。
provider() - 类 javax.xml.ws.spi.Provider 中的静态方法
创建一个新的提供者对象。
Provider.Service - java.security 中的 类
安全服务的描述。
Provider.Service(Provider, String, String, String, List<String>, Map<String, String>) - 类 java.security.Provider.Service 的构造方法
构造新的服务。
PROVIDER_URL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定要使用的服务提供者配置信息的环境属性名称。
ProviderException - java.security 中的 异常
用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
ProviderException() - 异常 java.security.ProviderException 的构造方法
构造不带详细消息的 ProviderException。
ProviderException(String) - 异常 java.security.ProviderException 的构造方法
构造带指定详细消息的 ProviderException。
ProviderException(String, Throwable) - 异常 java.security.ProviderException 的构造方法
创建带指定的详细消息和 cause 的 ProviderException。
ProviderException(Throwable) - 异常 java.security.ProviderException 的构造方法
创建带指定的 cause 和详细消息的 ProviderException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
proxy - 类 java.beans.beancontext.BeanContextServicesSupport 中的变量
BeanContextServiceProvider 的委托。
Proxy - java.lang.reflect 中的 类
Proxy 提供用于创建动态代理类和实例的静态方法，它还是由这些方法创建的所有动态代理类的超类。
Proxy(InvocationHandler) - 类 java.lang.reflect.Proxy 的构造方法
使用其调用处理程序的指定值从子类（通常为动态代理类）构建新的 Proxy 实例。
Proxy - java.net 中的 类
此类表示代理设置，通常为类型（http、socks）和套接字地址。
Proxy(Proxy.Type, SocketAddress) - 类 java.net.Proxy 的构造方法
创建表示 PROXY 连接的条目。
Proxy.Type - java.net 中的 枚举
表示代理类型。
ProxySelector - java.net 中的 类
连接到 URL 引用的网络资源时选择要使用的代理服务器（如果有）。
ProxySelector() - 类 java.net.ProxySelector 的构造方法
PSource - javax.crypto.spec 中的 类
此类为在 OAEP 冗余中的编码输入 P 指定源，OAEP 冗余在 PKCS #1 标准中定义。
PSource(String) - 类 javax.crypto.spec.PSource 的构造方法
使用指定的 PSource 算法为 PKCS #1 标准中定义的 OAEP 冗余构造一个编码输入 P 的源。
PSource.PSpecified - javax.crypto.spec 中的 类
此类用于显式地指定 OAEP 冗余中编码输入 P 的值。
PSource.PSpecified(byte[]) - 类 javax.crypto.spec.PSource.PSpecified 的构造方法
将指定的值 p 作为编码输入 P 显式地构造源。
PSSParameterSpec - java.security.spec 中的 类
此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。
PSSParameterSpec(String, String, AlgorithmParameterSpec, int, int) - 类 java.security.spec.PSSParameterSpec 的构造方法
根据 PKCS #1 中的定义，使用指定的消息摘要、掩码生成函数、掩码生成函数的参数、salt 长度和尾部字段值，创建一个新的 PSSParameterSpec。
PSSParameterSpec(int) - 类 java.security.spec.PSSParameterSpec 的构造方法
使用指定的 salt 长度和 PKCS#1 定义的其他默认值创建一个新的 PSSParameterSpec。
ptLineDist(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回从点到线的距离。
ptLineDist(double, double) - 类 java.awt.geom.Line2D 中的方法
返回从点到此线的距离。
ptLineDist(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回从 Point2D 到此线的距离。
ptLineDistSq(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回从点到线的距离的平方。
ptLineDistSq(double, double) - 类 java.awt.geom.Line2D 中的方法
返回从点到此线的距离的平方。
ptLineDistSq(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回从指定 Point2D 到此线的距离的平方。
ptSegDist(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回从点到线段的距离。
ptSegDist(double, double) - 类 java.awt.geom.Line2D 中的方法
返回从点到此线段的距离。
ptSegDist(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回从 Point2D 到此线段的距离的平方。
ptSegDistSq(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回从点到线段的距离的平方。
ptSegDistSq(double, double) - 类 java.awt.geom.Line2D 中的方法
返回从点到此线段的距离的平方。
ptSegDistSq(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回从 Point2D 到此线段的距离的平方。
PUBLIC - 接口 java.lang.reflect.Member 中的静态变量
标识类或接口的所有公共成员（包括继承成员）的集合。
PUBLIC - 类 java.lang.reflect.Modifier 中的静态变量
表示 public 修饰符的 int 值。
PUBLIC - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
PUBLIC_KEY - 类 javax.crypto.Cipher 中的静态变量
用于表示要解包的密钥为“公钥”的常量。
PUBLIC_MEMBER - org.omg.CORBA 中的 接口
定义 ValueMember 类中公共成员的常量。
PUBLIC_XML_SCHEMA - 接口 javax.sql.rowset.WebRowSet 中的静态变量
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的公共标识符。
PublicKey - java.security 中的 接口
公钥。
publish(LogRecord) - 类 java.util.logging.ConsoleHandler 中的方法
发布 LogRecord。
publish(LogRecord) - 类 java.util.logging.FileHandler 中的方法
格式化并发布 LogRecord。
publish(LogRecord) - 类 java.util.logging.Handler 中的方法
发布 LogRecord。
publish(LogRecord) - 类 java.util.logging.MemoryHandler 中的方法
将 LogRecord 存储在内部缓冲区。
publish(LogRecord) - 类 java.util.logging.SocketHandler 中的方法
格式化并发布 LogRecord。
publish(LogRecord) - 类 java.util.logging.StreamHandler 中的方法
格式化并发布 LogRecord。
publish(V...) - 类 javax.swing.SwingWorker 中的方法
将数据块发送给 SwingWorker.process(java.util.List) 方法。
publish(String) - 类 javax.xml.ws.Endpoint 中的方法
在给定地址处发布此端点。
publish(String, Object) - 类 javax.xml.ws.Endpoint 中的静态方法
在给定地址处针对指定的实现者对象创建并发布端点。
publish(Object) - 类 javax.xml.ws.Endpoint 中的方法
在提供的服务器上下文中发布此端点。
purge() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
尝试从工作队列移除所有已取消的 Future 任务。
purge() - 类 java.util.Timer 中的方法
从此计时器的任务队列中移除所有已取消的任务。
purgeRelations() - 类 javax.management.relation.RelationService 中的方法
肃清关系。
purgeRelations() - 接口 javax.management.relation.RelationServiceMBean 中的方法
肃清关系。
push(EventQueue) - 类 java.awt.EventQueue 中的方法
用指定的事件队列替换现有的 EventQueue。
push(E) - 类 java.util.ArrayDeque 中的方法
将元素推入此双端队列所表示的堆栈。
push(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
将元素推入此双端队列表示的栈。
push(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
push(E) - 接口 java.util.Deque 中的方法
将一个元素推入此双端队列所表示的堆栈（换句话说，此双端队列的头部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
push(E) - 类 java.util.LinkedList 中的方法
将元素推入此列表所表示的堆栈。
push() - 类 java.util.logging.MemoryHandler 中的方法
将所有已缓冲的输出 push 到目标 Handler 中。
push(E) - 类 java.util.Stack 中的方法
把项压入堆栈顶部。
PUSH_BUTTON - 类 javax.accessibility.AccessibleRole 中的静态变量
用户可以操作以通知应用程序执行某任务的对象。
pushBack() - 类 java.io.StreamTokenizer 中的方法
导致对此标记生成器的 nextToken 方法的下一个调用返回 ttype 字段中的当前值，而不修改 nval 或 sval 字段中的值。
PushbackInputStream - java.io 中的 类
PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。
PushbackInputStream(InputStream, int) - 类 java.io.PushbackInputStream 的构造方法
使用指定 size 的推回缓冲区创建 PushbackInputStream，并保存其参数（即输入流 in），以供将来使用。
PushbackInputStream(InputStream) - 类 java.io.PushbackInputStream 的构造方法
创建 PushbackInputStream 并保存其参数（即输入流 in），以供将来使用。
PushbackReader - java.io 中的 类
允许将字符推回到流的字符流 reader。
PushbackReader(Reader, int) - 类 java.io.PushbackReader 的构造方法
创建具有给定大小推回缓冲区的新推回 reader。
PushbackReader(Reader) - 类 java.io.PushbackReader 的构造方法
创建具有单字符推回缓冲区的新推回 reader。
pushCharacterStyle() - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
将当前字符样式压入堆栈，以准备形成新的嵌套字符样式。
pushContext() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
开始新的名称空间上下文。
put(Object, Object) - 类 java.awt.RenderingHints 中的方法
将指定 key 映射到此 RenderingHints 对象中指定的 value。
put(String, boolean) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 boolean 字段的值置于持久字段中。
put(String, byte) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 byte 字段值置于持久字段中。
put(String, char) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 char 字段的值置于持久字段中。
put(String, short) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 short 字段的值置于持久字段中。
put(String, int) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 int 字段的值置于持久字段中。
put(String, long) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 long 字段的值置于持久字段中。
put(String, float) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 float 字段的值置于持久字段中。
put(String, double) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 double 字段的值置于持久字段中。
put(String, Object) - 类 java.io.ObjectOutputStream.PutField 中的方法
将指定的 Object 字段的值置于持久字段中。
put(URI, Map<String, List<String>>) - 类 java.net.CookieHandler 中的方法
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
put(URI, Map<String, List<String>>) - 类 java.net.CookieManager 中的方法
put(URI, URLConnection) - 类 java.net.ResponseCache 中的方法
协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。
put(byte) - 类 java.nio.ByteBuffer 中的方法
相对 put 方法（可选操作）。
put(int, byte) - 类 java.nio.ByteBuffer 中的方法
绝对 put 方法（可选操作）。
put(ByteBuffer) - 类 java.nio.ByteBuffer 中的方法
相对批量 put 方法（可选操作）。
put(byte[], int, int) - 类 java.nio.ByteBuffer 中的方法
相对批量 put 方法（可选操作）。
put(byte[]) - 类 java.nio.ByteBuffer 中的方法
相对批量 put 方法（可选操作）。
put(char) - 类 java.nio.CharBuffer 中的方法
相对 put 方法（可选操作）。
put(int, char) - 类 java.nio.CharBuffer 中的方法
绝对 put 方法（可选操作）。
put(CharBuffer) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(char[], int, int) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(char[]) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(String, int, int) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(String) - 类 java.nio.CharBuffer 中的方法
相对批量 put 方法（可选操作）。
put(double) - 类 java.nio.DoubleBuffer 中的方法
相对 put 方法（可选操作）。
put(int, double) - 类 java.nio.DoubleBuffer 中的方法
绝对 put 方法（可选操作）。
put(DoubleBuffer) - 类 java.nio.DoubleBuffer 中的方法
相对批量 put 方法（可选操作）。
put(double[], int, int) - 类 java.nio.DoubleBuffer 中的方法
相对批量 put 方法（可选操作）。
put(double[]) - 类 java.nio.DoubleBuffer 中的方法
相对批量 put 方法（可选操作）。
put(float) - 类 java.nio.FloatBuffer 中的方法
相对 put 方法（可选操作）。
put(int, float) - 类 java.nio.FloatBuffer 中的方法
绝对 put 方法（可选操作）。
put(FloatBuffer) - 类 java.nio.FloatBuffer 中的方法
相对批量 put 方法（可选操作）。
put(float[], int, int) - 类 java.nio.FloatBuffer 中的方法
相对批量 put 方法（可选操作）。
put(float[]) - 类 java.nio.FloatBuffer 中的方法
相对批量 put 方法（可选操作）。
put(int) - 类 java.nio.IntBuffer 中的方法
相对 put 方法（可选操作）。
put(int, int) - 类 java.nio.IntBuffer 中的方法
绝对 put 方法（可选操作）。
put(IntBuffer) - 类 java.nio.IntBuffer 中的方法
相对批量 put 方法（可选操作）。
put(int[], int, int) - 类 java.nio.IntBuffer 中的方法
相对批量 put 方法（可选操作）。
put(int[]) - 类 java.nio.IntBuffer 中的方法
相对批量 put 方法（可选操作）。
put(long) - 类 java.nio.LongBuffer 中的方法
相对 put 方法（可选操作）。
put(int, long) - 类 java.nio.LongBuffer 中的方法
绝对 put 方法（可选操作）。
put(LongBuffer) - 类 java.nio.LongBuffer 中的方法
相对批量 put 方法（可选操作）。
put(long[], int, int) - 类 java.nio.LongBuffer 中的方法
相对批量 put 方法（可选操作）。
put(long[]) - 类 java.nio.LongBuffer 中的方法
相对批量 put 方法（可选操作）。
put(short) - 类 java.nio.ShortBuffer 中的方法
相对 put 方法（可选操作）。
put(int, short) - 类 java.nio.ShortBuffer 中的方法
绝对 put 方法（可选操作）。
put(ShortBuffer) - 类 java.nio.ShortBuffer 中的方法
相对批量 put 方法（可选操作）。
put(short[], int, int) - 类 java.nio.ShortBuffer 中的方法
相对批量 put 方法（可选操作）。
put(short[]) - 类 java.nio.ShortBuffer 中的方法
相对批量 put 方法（可选操作）。
put(Object, Object) - 类 java.security.Provider 中的方法
设置 key 属性，使其具有指定的 value。
put(K, V) - 类 java.util.AbstractMap 中的方法
将指定的值与此映射中的指定键关联（可选操作）。
put(E) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
将指定的元素插入此队列的尾部，如果该队列已满，则等待可用的空间。
put(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将一直等待可用空间。
put(E) - 接口 java.util.concurrent.BlockingQueue 中的方法
将指定元素插入此队列中，将等待可用的空间（如果有必要）。
put(K, V) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
将指定键映射到此表中的指定值。
put(K, V) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
将指定值与此映射中的指定键关联。
put(E) - 类 java.util.concurrent.DelayQueue 中的方法
将指定元素插入此延迟队列。
put(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
put(E) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
将指定元素插入到此队列的尾部，如有必要，则等待空间变得可用。
put(E) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
将指定元素插入此优先级队列。
put(E) - 类 java.util.concurrent.SynchronousQueue 中的方法
将指定元素添加到此队列，如有必要则等待另一个线程接收它。
put(K, V) - 类 java.util.Dictionary 中的方法
将指定 key 映射到此 dictionary 中指定 value。
put(K, V) - 类 java.util.EnumMap 中的方法
将指定值与此映射中指定键关联。
put(K, V) - 类 java.util.HashMap 中的方法
在此映射中关联指定值与指定键。
put(K, V) - 类 java.util.Hashtable 中的方法
将指定 key 映射到此哈希表中的指定 value。
put(K, V) - 类 java.util.IdentityHashMap 中的方法
在此标识哈希映射中关联指定值与指定键。
put(Object, Object) - 类 java.util.jar.Attributes 中的方法
在此 Map 中将指定的值关联到指定的属性名称（键）。
put(K, V) - 接口 java.util.Map 中的方法
将指定的值与此映射中的指定键关联（可选操作）。
put(String, String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.put(String,String) 中的规范实现 put 方法。
put(String, String) - 类 java.util.prefs.Preferences 中的方法
将指定值与此首选项节点中的指定键相关联。
put(K, V) - 类 java.util.TreeMap 中的方法
将指定值与此映射中的指定键进行关联。
put(K, V) - 类 java.util.WeakHashMap 中的方法
关联此映射中的指定值与指定键。
put(CompositeData) - 接口 javax.management.openmbean.TabularData 中的方法
将 value 添加到此 TabularData 实例。
put(Object, Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
此方法仅调用 put((CompositeData) value)，因此忽略其可能为 null 的 key 参数。
put(CompositeData) - 类 javax.management.openmbean.TabularDataSupport 中的方法
put(String, Object) - 接口 javax.naming.directory.Attributes 中的方法
向属性集中添加新属性。
put(Attribute) - 接口 javax.naming.directory.Attributes 中的方法
向属性集中添加新属性。
put(String, Object) - 类 javax.naming.directory.BasicAttributes 中的方法
put(Attribute) - 类 javax.naming.directory.BasicAttributes 中的方法
put(PrinterStateReason, Severity) - 类 javax.print.attribute.standard.PrinterStateReasons 中的方法
根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。
put(String, Object) - 类 javax.script.AbstractScriptEngine 中的方法
使用受保护 context 字段的 ENGINE_SCOPE Bindings 中的指定键设置指定的值。
put(String, Object) - 接口 javax.script.Bindings 中的方法
设置指定的值。
put(String, Object) - 接口 javax.script.ScriptEngine 中的方法
设置 ScriptEngine 的状态中的键/值对，它创建一个将在脚本执行中使用或者以其他方式使用的 Java Language Binding，具体取决于该键是否被保留。
put(String, Object) - 类 javax.script.ScriptEngineManager 中的方法
设置 Global Scope 中指定的键/值对。
put(String, Object) - 类 javax.script.SimpleBindings 中的方法
设置底层 map 字段中的指定键/值。
put(Object, Action) - 类 javax.swing.ActionMap 中的方法
添加一个 key 到 action 的绑定。
put(KeyStroke, Object) - 类 javax.swing.ComponentInputMap 中的方法
将一个 keyStroke 的绑定添加到 actionMapKey。
put(KeyStroke, Object) - 类 javax.swing.InputMap 中的方法
将 keyStroke 的一个绑定添加到 actionMapKey。
put(Object, Object) - 类 javax.swing.UIDefaults 中的方法
将 key 值设置为所有语言环境的 value。
put(Object, Object) - 类 javax.swing.UIManager 中的静态方法
在开发人员默认值中存储一个对象。
put(Object, Object) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 将键映射到指定的对象。
put(Object, Object) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
将指定值与此上下文中的指定键关联。
putAll(Map<?, ?>) - 类 java.awt.RenderingHints 中的方法
将指定 Map 中所有映射关系复制到此 RenderingHints 中。
putAll(Map<?, ?>) - 类 java.security.Provider 中的方法
将指定 Map 中所有映射关系复制到此 provider 中。
putAll(Map<? extends K, ? extends V>) - 类 java.util.AbstractMap 中的方法
从指定映射中将所有映射关系复制到此映射中（可选操作）。
putAll(Map<? extends K, ? extends V>) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
将指定映射中所有映射关系复制到此映射中。
putAll(Map<? extends K, ? extends V>) - 类 java.util.EnumMap 中的方法
将指定映射中所有映射关系复制到此映射中。
putAll(Map<? extends K, ? extends V>) - 类 java.util.HashMap 中的方法
将指定映射的所有映射关系复制到此映射中，这些映射关系将替换此映射目前针对指定映射中所有键的所有映射关系。
putAll(Map<? extends K, ? extends V>) - 类 java.util.Hashtable 中的方法
将指定映射的所有映射关系复制到此哈希表中，这些映射关系将替换此哈希表拥有的、针对当前指定映射中所有键的所有映射关系。
putAll(Map<? extends K, ? extends V>) - 类 java.util.IdentityHashMap 中的方法
将指定映射的全部映射关系复制到此映射，这些映射关系将替换此映射目前针对指定映射的任何键的任何映射关系。
putAll(Map<?, ?>) - 类 java.util.jar.Attributes 中的方法
将所有的属性名称-值映射关系从指定的 Attributes 复制到此 Map。
putAll(Map<? extends K, ? extends V>) - 接口 java.util.Map 中的方法
从指定映射中将所有映射关系复制到此映射中（可选操作）。
putAll(Map<? extends K, ? extends V>) - 类 java.util.TreeMap 中的方法
将指定映射中的所有映射关系复制到此映射中。
putAll(Map<? extends K, ? extends V>) - 类 java.util.WeakHashMap 中的方法
将指定映射的全部映射关系复制到此映射。
putAll(CompositeData[]) - 接口 javax.management.openmbean.TabularData 中的方法
将 values 中的所有元素添加到此 TabularData 实例。
putAll(Map<?, ?>) - 类 javax.management.openmbean.TabularDataSupport 中的方法
将包含在指定映射 t 中的所有值添加到此 TabularData 实例。
putAll(CompositeData[]) - 类 javax.management.openmbean.TabularDataSupport 中的方法
将 values 中的所有元素添加到此 TabularData 实例。
putAll(Map<? extends String, ? extends Object>) - 接口 javax.script.Bindings 中的方法
将给定 Map 中的所有映射关系添加到此 Bindings 中。
putAll(Map<? extends String, ? extends Object>) - 类 javax.script.SimpleBindings 中的方法
putAll 是使用 Map.putAll 实现的。
putBoolean(String, boolean) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putBoolean(String,boolean) 中的规范实现 putBoolean 方法。
putBoolean(String, boolean) - 类 java.util.prefs.Preferences 中的方法
将表示指定 boolean 值的字符串与此首选项节点中的指定键相关联。
putByteArray(String, byte[]) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putByteArray(String,byte[]) 中的规范实现 putByteArray 方法。
putByteArray(String, byte[]) - 类 java.util.prefs.Preferences 中的方法
将表示指定字节数组的字符串与此首选项节点中的指定键相关联。
putChar(char) - 类 java.nio.ByteBuffer 中的方法
用来写入 char 值的相对 put 方法（可选操作）。
putChar(int, char) - 类 java.nio.ByteBuffer 中的方法
用于写入 char 值的绝对 put 方法（可选操作）。
putClientProperty(Object, Object) - 类 javax.swing.JComponent 中的方法
向此组件添加任意的键/值“客户端属性”。
putConstraint(String, Component, int, String, Component) - 类 javax.swing.SpringLayout 中的方法
将组件 c1 的边 e1 连接到组件 c2 的边 e2，边与边之间的距离固定。
putConstraint(String, Component, Spring, String, Component) - 类 javax.swing.SpringLayout 中的方法
将组件 c1 的边 e1 连接到组件 c2 的边 e2。
putDefaults(Object[]) - 类 javax.swing.UIDefaults 中的方法
将所有键/值对放入数据库中，并无条件地生成一个 PropertyChangeEvent。
putDouble(double) - 类 java.nio.ByteBuffer 中的方法
用于写入 double 值的相对 put 方法（可选操作）。
putDouble(int, double) - 类 java.nio.ByteBuffer 中的方法
用于写入 double 值的绝对 put 方法（可选操作）。
putDouble(String, double) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putDouble(String,double) 中的规范实现 putDouble 方法。
putDouble(String, double) - 类 java.util.prefs.Preferences 中的方法
将表示指定 double 值的字符串与此首选项节点中的指定键相关联。
putDTDHash(String, DTD) - 类 javax.swing.text.html.parser.DTD 中的静态方法
putFields() - 类 java.io.ObjectOutputStream 中的方法
获取用于缓冲写入流中的持久存储字段的对象。
putFirst(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列的开头，必要时将一直等待可用空间。
putFirst(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
putFloat(float) - 类 java.nio.ByteBuffer 中的方法
用于写入 float 值的相对 put 方法（可选操作）。
putFloat(int, float) - 类 java.nio.ByteBuffer 中的方法
用于写入 float 值的绝对 put 方法（可选操作）。
putFloat(String, float) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putFloat(String,float) 中的规范实现 putFloat 方法。
putFloat(String, float) - 类 java.util.prefs.Preferences 中的方法
将表示指定 float 值的字符串与此首选项节点中的指定键相关联。
putIfAbsent(K, V) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
如果指定键已经不再与某个值相关联，则将它与给定值关联。
putIfAbsent(K, V) - 接口 java.util.concurrent.ConcurrentMap 中的方法
如果指定键已经不再与某个值相关联，则将它与给定值关联。
putIfAbsent(K, V) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
如果指定键已经不再与某个值相关联，则将它与给定值关联。
putInt(int) - 类 java.nio.ByteBuffer 中的方法
用于写入 int 值的相对 put 方法（可选操作）。
putInt(int, int) - 类 java.nio.ByteBuffer 中的方法
用于写入 int 值的绝对 put 方法（可选操作）。
putInt(String, int) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putInt(String,int) 中的规范实现 putInt 方法。
putInt(String, int) - 类 java.util.prefs.Preferences 中的方法
将表示指定 int 值的字符串与此首选项节点中的指定键相关联。
putLast(E) - 接口 java.util.concurrent.BlockingDeque 中的方法
将指定的元素插入此双端队列的末尾，必要时将一直等待可用空间。
putLast(E) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
putLayer(JComponent, int) - 类 javax.swing.JLayeredPane 中的静态方法
设置 JComponent 上的 layer 属性。
putLong(long) - 类 java.nio.ByteBuffer 中的方法
用于写入 long 值（可先操作） 的相对 put 方法。
putLong(int, long) - 类 java.nio.ByteBuffer 中的方法
用于写入 long 值的绝对 put 方法（可选操作）。
putLong(String, long) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.putLong(String,long) 中的规范实现 putLong 方法。
putLong(String, long) - 类 java.util.prefs.Preferences 中的方法
将表示指定 long 值的字符串与此首选项节点中的指定键相关联。
putNamespacePrefix(String, String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 将 URI 映射到指定的前缀。
putNamespacePrefix(String, String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
将指定的名称空间 URI 映射到指定的前缀。
putNextEntry(ZipEntry) - 类 java.util.jar.JarOutputStream 中的方法
开始写入新的 JAR 文件条目，并将流定位到条目数据的开始处。
putNextEntry(ZipEntry) - 类 java.util.zip.ZipOutputStream 中的方法
开始写入新的 ZIP 文件条目并将流定位到条目数据的开始处。
putProperty(Object, Object) - 类 javax.swing.text.AbstractDocument 中的方法
存储属性值的便捷方法。
putProperty(Object, Object) - 接口 javax.swing.text.Document 中的方法
将属性与文档关联。
putService(Provider.Service) - 类 java.security.Provider 中的方法
添加服务。
putShort(short) - 类 java.nio.ByteBuffer 中的方法
用于写入 short 值的相对 put 方法（可选操作）。
putShort(int, short) - 类 java.nio.ByteBuffer 中的方法
用于写入 short 值的绝对 put 方法（可选操作）。
putSpi(String, String) - 类 java.util.prefs.AbstractPreferences 中的方法
将给定的键-值关联置于此首选项节点中。
putValue(String, String) - 类 java.util.jar.Attributes 中的方法
将指定的值作为一个 String 关联到指定的属性名称。
putValue(String, Object) - 接口 javax.net.ssl.SSLSession 中的方法
使用给定的 name 将指定的 value 对象绑定到会话的应用层数据中。
putValue(String, Object) - 类 javax.swing.AbstractAction 中的方法
设置与指定键关联的 Value。
putValue(String, Object) - 接口 javax.swing.Action 中的方法
使用关联的键设置此对象的一个属性。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Q - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Q

QName - javax.xml.namespace 中的 类
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。
QName(String, String) - 类 javax.xml.namespace.QName 的构造方法
指定名称空间 URI 和本地部分的 QName 构造方法。
QName(String, String, String) - 类 javax.xml.namespace.QName 的构造方法
指定名称空间 URI、本地部分和前缀的 QName 构造方法。
QName(String) - 类 javax.xml.namespace.QName 的构造方法
指定本地部分的 QName 构造方法。
QOP - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定要使用的保护级别。
QuadCurve2D - java.awt.geom 中的 类
QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。
QuadCurve2D() - 类 java.awt.geom.QuadCurve2D 的构造方法
这是一个不可直接实例化的抽象类。
QuadCurve2D.Double - java.awt.geom 中的 类
使用 double 坐标指定的二次参数曲线段。
QuadCurve2D.Double() - 类 java.awt.geom.QuadCurve2D.Double 的构造方法
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 QuadCurve2D。
QuadCurve2D.Double(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D.Double 的构造方法
根据指定 double 坐标构造并初始化 QuadCurve2D。
QuadCurve2D.Float - java.awt.geom 中的 类
使用 float 坐标指定的二次参数曲线段。
QuadCurve2D.Float() - 类 java.awt.geom.QuadCurve2D.Float 的构造方法
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 QuadCurve2D。
QuadCurve2D.Float(float, float, float, float, float, float) - 类 java.awt.geom.QuadCurve2D.Float 的构造方法
根据指定 float 坐标构造并初始化一个 QuadCurve2D。
quadrantRotate(int) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与按照指定象限数旋转坐标的变换。
quadrantRotate(int, double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与按指定象限数绕指定锚点旋转坐标的变换。
quadTo(double, double, double, double) - 类 java.awt.geom.Path2D.Double 中的方法
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
quadTo(double, double, double, double) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
quadTo(float, float, float, float) - 类 java.awt.geom.Path2D.Float 中的方法
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
quadTo(double, double, double, double) - 类 java.awt.geom.Path2D 中的方法
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
QUARTO - 类 java.awt.PageAttributes.MediaType 中的静态变量
Quarto (215 x 275 mm) 的 MediaType 实例。
QUARTO - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 quarto 尺寸，8.5 inch × 10.83 inch。
QUARTO - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
quarto 尺寸。
Query - javax.management 中的 类
构造查询对象约束。
Query() - 类 javax.management.Query 的构造方法
基本构造方法。
QUERY_STRING - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：请求的查询字符串。
QueryEval - javax.management 中的 类
允许在特定的 MBean 服务器上下文中执行查询。
QueryEval() - 类 javax.management.QueryEval 的构造方法
QueryExp - javax.management 中的 接口
表示可在数据库查询“where 子句”中使用的相关约束。
queryMBeans(ObjectName, QueryExp) - 接口 javax.management.MBeanServer 中的方法
queryMBeans(ObjectName, QueryExp) - 接口 javax.management.MBeanServerConnection 中的方法
获得该 MBean 服务器所控制的 MBean。
queryMBeans(ObjectName, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
queryMBeans(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
queryMBeans(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
queryNames(ObjectName, QueryExp) - 接口 javax.management.MBeanServer 中的方法
queryNames(ObjectName, QueryExp) - 接口 javax.management.MBeanServerConnection 中的方法
获得该 MBean 服务器所控制的 MBean 的名称。
queryNames(ObjectName, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
queryNames(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
queryNames(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
QUESTION_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
QUESTION_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
用于问题。
Queue<E> - java.util 中的 接口
在处理元素前用于保存元素的 collection。
QUEUED_IN_DEVICE - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
作业已被转发到某个不能发送回状态的设备或打印系统。
QueuedJobCount - javax.print.attribute.standard 中的 类
QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。
QueuedJobCount(int) - 类 javax.print.attribute.standard.QueuedJobCount 的构造方法
构造具有给定整数值的新 QueuedJobCount 属性。
quote(String) - 类 java.util.regex.Pattern 中的静态方法
返回指定 String 的字面值模式 String。
quote(String) - 类 javax.management.ObjectName 中的静态方法
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。
quoteChar(int) - 类 java.io.StreamTokenizer 中的方法
指定此字符的匹配对分隔此标记生成器中的字符串常量。
quoteReplacement(String) - 类 java.util.regex.Matcher 中的静态方法
返回指定 String 的字面值替换 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


R - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

R

RadialGradientPaint - java.awt 中的 类
RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。
RadialGradientPaint(float, float, float, float[], Color[]) - 类 java.awt.RadialGradientPaint 的构造方法
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D, float, float[], Color[]) - 类 java.awt.RadialGradientPaint 的构造方法
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D, float, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float, float, float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D, float, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D, float, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod, MultipleGradientPaint.ColorSpaceType, AffineTransform) - 类 java.awt.RadialGradientPaint 的构造方法
构造一个 RadialGradientPaint。
RadialGradientPaint(Rectangle2D, float[], Color[], MultipleGradientPaint.CycleMethod) - 类 java.awt.RadialGradientPaint 的构造方法
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RADIO_BUTTON - 类 javax.accessibility.AccessibleRole 中的静态变量
一个专用复选框，当选中此复选框时，将导致取消选中同一组中的其他单选按钮。
RADIO_BUTTON - 类 javax.swing.plaf.synth.Region 中的静态变量
RadioButton 的 region。
RADIO_BUTTON_MENU_ITEM - 类 javax.swing.plaf.synth.Region 中的静态变量
RegionButtonMenuItem 的 region。
radix() - 类 java.util.Scanner 中的方法
返回此扫描器的默认基数。
RAISED - 类 javax.swing.border.BevelBorder 中的静态变量
凸出斜面类型。
RAISED - 类 javax.swing.border.EtchedBorder 中的静态变量
阳刻浮雕化类型。
random() - 类 java.lang.Math 中的静态方法
返回带正号的 double 值，该值大于等于 0.0 且小于 1.0。
random() - 类 java.lang.StrictMath 中的静态方法
返回带有正号的 double 值，该值大于等于 0.0 且小于 1.0。
Random - java.util 中的 类
此类的实例用于生成伪随机数流。
Random() - 类 java.util.Random 的构造方法
创建一个新的随机数生成器。
Random(long) - 类 java.util.Random 的构造方法
使用单个 long 种子创建一个新的随机数生成器。
RandomAccess - java.util 中的 接口
List 实现所使用的标记接口，用来表明其支持快速（通常是固定时间）随机访问。
RandomAccessFile - java.io 中的 类
此类的实例支持对随机访问文件的读取和写入。
RandomAccessFile(String, String) - 类 java.io.RandomAccessFile 的构造方法
创建从中读取和向其中写入（可选）的随机访问文件流，该文件具有指定名称。
RandomAccessFile(File, String) - 类 java.io.RandomAccessFile 的构造方法
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。
RANDOMPIXELORDER - 接口 java.awt.image.ImageConsumer 中的静态变量
按随机顺序传递像素。
randomUUID() - 类 java.util.UUID 中的静态方法
获取类型 4（伪随机生成的）UUID 的静态工厂。
RANGE - 类 java.awt.JobAttributes.DefaultSelectionType 中的静态变量
用于指定应该打印一定范围的作业页面的 DefaultSelectionType 实例。
range(E, E) - 类 java.util.EnumSet 中的静态方法
创建一个最初包含由两个指定端点所定义范围内的所有元素的枚举 set。
Raster - java.awt.image 中的 类
表示像素矩形数组的类。
Raster(SampleModel, Point) - 类 java.awt.image.Raster 的构造方法
构建具有给定 SampleModel 的 Raster。
Raster(SampleModel, DataBuffer, Point) - 类 java.awt.image.Raster 的构造方法
构建具有给定 SampleModel 和 DataBuffer 的 Raster。
Raster(SampleModel, DataBuffer, Rectangle, Point, Raster) - 类 java.awt.image.Raster 的构造方法
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
raster - 类 javax.imageio.IIOImage 中的变量
正被引用的 Raster。
RasterFormatException - java.awt.image 中的 异常
如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。
RasterFormatException(String) - 异常 java.awt.image.RasterFormatException 的构造方法
构造带指定消息的新 RasterFormatException。
RasterOp - java.awt.image 中的 接口
此接口描述对 Raster 对象执行的单输入/单输出操作。
RAW_SEND_SIZE - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定 SaslClient/SaslServer 初始发送缓冲区的最大大小（以字节为单位）。
RAW_TEXT - 类 java.awt.im.InputMethodHighlight 中的静态变量
原文本状态的常量。
RAW_X509_CERTIFICATE_TYPE - 接口 javax.xml.crypto.dsig.keyinfo.X509Data 中的静态变量
标识二进制 (ASN.1 DER) X.509 Certificate KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#rawX509Certificate。
RC2ParameterSpec - javax.crypto.spec 中的 类
此类指定随同 RC2 算法使用的参数。
RC2ParameterSpec(int) - 类 javax.crypto.spec.RC2ParameterSpec 的构造方法
根据给定的有效密钥大小（以位为单位）为 RC2 构造一个参数集合。
RC2ParameterSpec(int, byte[]) - 类 javax.crypto.spec.RC2ParameterSpec 的构造方法
根据给定的有效密钥大小（以位为单位）和一个 8 字节的 IV 为 RC2 构造一个参数集合。
RC2ParameterSpec(int, byte[], int) - 类 javax.crypto.spec.RC2ParameterSpec 的构造方法
根据给定的有效密钥大小（以位为单位）和 IV 为 RC2 构造一个参数集合。
RC5ParameterSpec - javax.crypto.spec 中的 类
此类指定随同 RC5 算法使用的参数。
RC5ParameterSpec(int, int, int) - 类 javax.crypto.spec.RC5ParameterSpec 的构造方法
根据给定的版本、round 的数量以及 word 大小（以位为单位）为 RC5 构造一个参数集合。
RC5ParameterSpec(int, int, int, byte[]) - 类 javax.crypto.spec.RC5ParameterSpec 的构造方法
根据给定的版本、round 的数量、word 大小（以位为单位）以及 IV 为 RC5 构造一个参数集合。
RC5ParameterSpec(int, int, int, byte[], int) - 类 javax.crypto.spec.RC5ParameterSpec 的构造方法
根据给定的版本、round 的数量、word 大小（以位为单位）以及 IV 为 RC5 构造一个参数集合。
RCDATA - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
RCSID - 类 javax.swing.undo.StateEdit 中的静态变量
RCSID - 接口 javax.swing.undo.StateEditable 中的静态变量
此类的资源 ID。
Rdn - javax.naming.ldap 中的 类
此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。
Rdn(Attributes) - 类 javax.naming.ldap.Rdn 的构造方法
根据给定属性集构造 Rdn。
Rdn(String) - 类 javax.naming.ldap.Rdn 的构造方法
根据给定字符串构造 Rdn。
Rdn(Rdn) - 类 javax.naming.ldap.Rdn 的构造方法
根据给定 rdn 构造 Rdn。
Rdn(String, Object) - 类 javax.naming.ldap.Rdn 的构造方法
根据给定属性类型和值构造 Rdn。
read() - 类 java.io.BufferedInputStream 中的方法
参见 InputStream 的 read 方法的常规协定。
read(byte[], int, int) - 类 java.io.BufferedInputStream 中的方法
从此字节输入流中给定偏移量处开始将各字节读取到指定的 byte 数组中。
read() - 类 java.io.BufferedReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.BufferedReader 中的方法
将字符读入数组的某一部分。
read() - 类 java.io.ByteArrayInputStream 中的方法
从此输入流中读取下一个数据字节。
read(byte[], int, int) - 类 java.io.ByteArrayInputStream 中的方法
将最多 len 个数据字节从此输入流读入 byte 数组。
read() - 类 java.io.CharArrayReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.CharArrayReader 中的方法
将字符读入数组的某一部分。
read(byte[]) - 类 java.io.DataInputStream 中的方法
从包含的输入流中读取一定数量的字节，并将它们存储到缓冲区数组 b 中。
read(byte[], int, int) - 类 java.io.DataInputStream 中的方法
从包含的输入流中将最多 len 个字节读入一个 byte 数组中。
read() - 类 java.io.FileInputStream 中的方法
从此输入流中读取一个数据字节。
read(byte[]) - 类 java.io.FileInputStream 中的方法
从此输入流中将最多 b.length 个字节的数据读入一个 byte 数组中。
read(byte[], int, int) - 类 java.io.FileInputStream 中的方法
从此输入流中将最多 len 个字节的数据读入一个 byte 数组中。
read() - 类 java.io.FilterInputStream 中的方法
从此输入流中读取下一个数据字节。
read(byte[]) - 类 java.io.FilterInputStream 中的方法
从此输入流中将 byte.length 个字节的数据读入一个 byte 数组中。
read(byte[], int, int) - 类 java.io.FilterInputStream 中的方法
从此输入流中将 len 个字节的数据读入一个 byte 数组中。
read() - 类 java.io.FilterReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.FilterReader 中的方法
将字符读入数组的某一部分。
read() - 类 java.io.InputStream 中的方法
从输入流中读取数据的下一个字节。
read(byte[]) - 类 java.io.InputStream 中的方法
从输入流中读取一定数量的字节，并将其存储在缓冲区数组 b 中。
read(byte[], int, int) - 类 java.io.InputStream 中的方法
将输入流中最多 len 个数据字节读入 byte 数组。
read() - 类 java.io.InputStreamReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.InputStreamReader 中的方法
将字符读入数组中的某一部分。
read() - 类 java.io.LineNumberInputStream 中的方法
已过时。 从此输入流读取下一个数据字节。
read(byte[], int, int) - 类 java.io.LineNumberInputStream 中的方法
已过时。 将最多 len 个数据字节从此输入流读入 byte 数组。
read() - 类 java.io.LineNumberReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.LineNumberReader 中的方法
将字符读入数组中的某一部分。
read() - 接口 java.io.ObjectInput 中的方法
读取数据字节。
read(byte[]) - 接口 java.io.ObjectInput 中的方法
读入 byte 数组。
read(byte[], int, int) - 接口 java.io.ObjectInput 中的方法
读入 byte 数组。
read() - 类 java.io.ObjectInputStream 中的方法
读取数据字节。
read(byte[], int, int) - 类 java.io.ObjectInputStream 中的方法
读入 byte 数组。
read() - 类 java.io.PipedInputStream 中的方法
读取此管道输入流中的下一个数据字节。
read(byte[], int, int) - 类 java.io.PipedInputStream 中的方法
将最多 len 个数据字节从此管道输入流读入 byte 数组。
read() - 类 java.io.PipedReader 中的方法
读取此传送流中的下一个数据字符。
read(char[], int, int) - 类 java.io.PipedReader 中的方法
将此传送流中最多 len 个数据字符读入字符数组。
read() - 类 java.io.PushbackInputStream 中的方法
从此输入流中读取下一个数据字节。
read(byte[], int, int) - 类 java.io.PushbackInputStream 中的方法
从此输入流将最多 len 个数据字节读入 byte 数组。
read() - 类 java.io.PushbackReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.PushbackReader 中的方法
将字符读入数组的某一部分。
read() - 类 java.io.RandomAccessFile 中的方法
从此文件中读取一个数据字节。
read(byte[], int, int) - 类 java.io.RandomAccessFile 中的方法
将最多 len 个数据字节从此文件读入 byte 数组。
read(byte[]) - 类 java.io.RandomAccessFile 中的方法
将最多 b.length 个数据字节从此文件读入 byte 数组。
read(CharBuffer) - 类 java.io.Reader 中的方法
试图将字符读入指定的字符缓冲区。
read() - 类 java.io.Reader 中的方法
读取单个字符。
read(char[]) - 类 java.io.Reader 中的方法
将字符读入数组。
read(char[], int, int) - 类 java.io.Reader 中的方法
将字符读入数组的某一部分。
read() - 类 java.io.SequenceInputStream 中的方法
从此输入流中读取下一个数据字节。
read(byte[], int, int) - 类 java.io.SequenceInputStream 中的方法
将最多 len 个数据字节从此输入流读入 byte 数组。
read() - 类 java.io.StringBufferInputStream 中的方法
已过时。 从此输入流中读取下一个数据的字节。
read(byte[], int, int) - 类 java.io.StringBufferInputStream 中的方法
已过时。 将最多 len 个数据字节从此输入流读入 byte 数组。
read() - 类 java.io.StringReader 中的方法
读取单个字符。
read(char[], int, int) - 类 java.io.StringReader 中的方法
将字符读入数组的某一部分。
read(CharBuffer) - 接口 java.lang.Readable 中的方法
试图将字符读入指定的字符缓冲区。
read(ByteBuffer) - 类 java.nio.channels.DatagramChannel 中的方法
从此通道读取数据报。
read(ByteBuffer[], int, int) - 类 java.nio.channels.DatagramChannel 中的方法
从此通道读取数据报。
read(ByteBuffer[]) - 类 java.nio.channels.DatagramChannel 中的方法
从此通道读取数据报。
read(ByteBuffer) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从此通道读入给定的缓冲区。
read(ByteBuffer[], int, int) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从此通道读入给定缓冲区的子序列中。
read(ByteBuffer[]) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从此通道读入给定的缓冲区。
read(ByteBuffer, long) - 类 java.nio.channels.FileChannel 中的方法
从给定的文件位置开始，从此通道读取字节序列,并写入给定的缓冲区。
read(ByteBuffer) - 接口 java.nio.channels.ReadableByteChannel 中的方法
将字节序列从此通道中读入给定的缓冲区。
read(ByteBuffer[], int, int) - 接口 java.nio.channels.ScatteringByteChannel 中的方法
将字节序列从此通道读入给定缓冲区的子序列中。
read(ByteBuffer[]) - 接口 java.nio.channels.ScatteringByteChannel 中的方法
将字节序列从此通道读入给定的缓冲区。
read(ByteBuffer) - 类 java.nio.channels.SocketChannel 中的方法
read(ByteBuffer[], int, int) - 类 java.nio.channels.SocketChannel 中的方法
read(ByteBuffer[]) - 类 java.nio.channels.SocketChannel 中的方法
read(CharBuffer) - 类 java.nio.CharBuffer 中的方法
试图将字符读入指定的字符缓冲区。
read(ObjectInput) - 类 java.rmi.server.ObjID 中的静态方法
通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。
read(DataInput) - 类 java.rmi.server.UID 中的静态方法
通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。
read() - 类 java.security.DigestInputStream 中的方法
读取字节并更新消息摘要（如果开启了摘要功能）。
read(byte[], int, int) - 类 java.security.DigestInputStream 中的方法
读入 byte 数组并更新消息摘要（如果开启了摘要功能）。
read(byte[], int, int) - 类 java.util.jar.JarInputStream 中的方法
从当前 JAR 文件条目读入字节数组。
read(InputStream) - 类 java.util.jar.Manifest 中的方法
从指定的 InputStream 读取 Manifest。
read() - 类 java.util.zip.CheckedInputStream 中的方法
读取字节。
read(byte[], int, int) - 类 java.util.zip.CheckedInputStream 中的方法
读入字节数组。
read() - 类 java.util.zip.DeflaterInputStream 中的方法
从输入流读取一个压缩数据的单个字节。
read(byte[], int, int) - 类 java.util.zip.DeflaterInputStream 中的方法
将压缩数据读入 byte 数组。
read(byte[], int, int) - 类 java.util.zip.GZIPInputStream 中的方法
将未压缩数据读入字节数组。
read() - 类 java.util.zip.InflaterInputStream 中的方法
读取未压缩数据的字节。
read(byte[], int, int) - 类 java.util.zip.InflaterInputStream 中的方法
将未压缩数据读入字节数组。
read(byte[], int, int) - 类 java.util.zip.ZipInputStream 中的方法
从当前 ZIP 条目读入字节数组。
read() - 类 javax.crypto.CipherInputStream 中的方法
从该输入流读取下一数据字节。
read(byte[]) - 类 javax.crypto.CipherInputStream 中的方法
从该输入流将 b.length 个数据字节读入到字节数组中。
read(byte[], int, int) - 类 javax.crypto.CipherInputStream 中的方法
从该输入流将 len 个字节数据读入到字节数组中。
read(File) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
read(InputStream) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。
read(URL) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。
read(ImageInputStream) - 类 javax.imageio.ImageIO 中的静态方法
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。
read(int) - 类 javax.imageio.ImageReader 中的方法
使用默认 ImageReadParam 读取通过索引 imageIndex 指定的图像，并将其作为一个完整的 BufferedImage 返回。
read(int, ImageReadParam) - 类 javax.imageio.ImageReader 中的方法
使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
read() - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.FileCacheImageInputStream 中的方法
read() - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
read() - 类 javax.imageio.stream.FileImageInputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.FileImageInputStream 中的方法
read() - 类 javax.imageio.stream.FileImageOutputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.FileImageOutputStream 中的方法
read() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取单个字节，并以整数（0 到 255 之间）形式返回该字节。
read(byte[]) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取至多 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
read(byte[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取至多 len 个字节，并将其存储到 b 中（从索引 off 开始）。
read() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
read(byte[]) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
调用 read(b, 0, b.length) 的便捷方法。
read(byte[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
read() - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.MemoryCacheImageInputStream 中的方法
read() - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
read(byte[], int, int) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
read() - 类 javax.sound.sampled.AudioInputStream 中的方法
从音频输入流读取数据下一个字节。
read(byte[]) - 类 javax.sound.sampled.AudioInputStream 中的方法
从音频输入流读取一定数量的字节，并将其存储在缓冲区数组 b 中。
read(byte[], int, int) - 类 javax.sound.sampled.AudioInputStream 中的方法
从音频流读取指定的最大数量的数据字节，并将其放入给定的字节数组中。
read(byte[], int, int) - 接口 javax.sound.sampled.TargetDataLine 中的方法
从数据行的输入缓冲区读取音频数据。
read(InputStream, Object) - 类 javax.swing.JEditorPane 中的方法
此方法根据流进行初始化。
read() - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.read，以便在读取之后更新进度监视器。
read(byte[]) - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.read，以读取之后更新进度监视器。
read(byte[], int, int) - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.read，以便在读取之后更新进度监视器。
read(InputStream, Document, int) - 类 javax.swing.text.DefaultEditorKit 中的方法
插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
read(Reader, Document, int) - 类 javax.swing.text.DefaultEditorKit 中的方法
插入取自给定流的内容，它将被视为纯文本。
read(InputStream, Document, int) - 类 javax.swing.text.EditorKit 中的方法
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
read(Reader, Document, int) - 类 javax.swing.text.EditorKit 中的方法
插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
read(Reader, Document, int) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
插入来自给定流的内容。
read(DataInputStream) - 类 javax.swing.text.html.parser.DTD 中的方法
根据存档格式重新创建一个 DTD。
read(Reader, Object) - 类 javax.swing.text.JTextComponent 中的方法
根据流进行初始化。
read(InputStream, Document, int) - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
read(Reader, Document, int) - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
插入来自给定流的内容，该内容将被视为纯文本。
read(InputStream) - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ObjectHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
read() - 类 org.omg.CORBA.portable.InputStream 中的方法
read(InputStream) - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.StringValueHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.BindingHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.IstringHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NameHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
read(InputStream) - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.IORHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
read(InputStream) - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
read(InputStream) - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
read(InputStream) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
read_Abstract() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL Abstract 接口。
read_abstract_interface() - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
解组值对象或适当的 stub 对象。
read_abstract_interface(Class) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
解组与传递类型相对应的类对象或 stub 类。
read_any() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL Any 值。
read_any() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 Any。
read_any_array(AnySeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL Any 数组中从 offset 处开始的 length 个元素。
read_boolean() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL boolean 值。
read_boolean() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 boolean 值。
read_boolean_array(BooleanSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL boolean 数组中 offset 处开始的 length 个元素。
read_boolean_array(boolean[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 boolean 数组。
read_char() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 字符值。
read_char() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 char 值。
read_char_array(CharSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 字符数组中从 offset 处开始的 length 个元素。
read_char_array(char[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 char 数组。
read_Context() - 类 org.omg.CORBA.portable.InputStream 中的方法
从流中读取一个 CORBA 上下文。
read_double() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL double 值。
read_double() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 double 值。
read_double_array(DoubleSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL double 数组中从 offset 处开始的 length 个元素。
read_double_array(double[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 double 数组。
read_fixed() - 类 org.omg.CORBA.portable.InputStream 中的方法
读取一个 BigDecimal 数。
read_float() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL float 值。
read_float() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 float 值。
read_float_array(FloatSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL float 数组中从 offset 处开始的 length 个元素。
read_float_array(float[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 float 数组。
read_long() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL long 值。
read_long() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA long（即 Java int）值。
read_long_array(LongSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL long 数组中从 offset 处开始的 length 个元素。
read_long_array(int[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA long（即 Java int）数组。
read_longlong() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL long long 值。
read_longlong() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA longlong（即 Java long）值。
read_longlong_array(LongLongSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL long long 数组中从 offset 处开始的 length 个元素。
read_longlong_array(long[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA longlong（即 Java long）数组。
read_Object() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL CORBA::Object。
read_Object() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA 对象。
read_Object(Class) - 类 org.omg.CORBA.portable.InputStream 中的方法
取消对象的编组并返回一个 CORBA Object，该对象是作为参数传递的类的实例。
read_octet() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL octet 值。
read_octet() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个八位组（即 byte）值。
read_octet_array(OctetSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL octet 数组中从 offset 处开始的 length 个元素。
read_octet_array(byte[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个八位组（即 bytes）数组。
READ_ONLY - 类 java.nio.channels.FileChannel.MapMode 中的静态变量
只读映射模式。
read_Principal() - 类 org.omg.CORBA.portable.InputStream 中的方法
已过时。 已由 CORBA 2.2 取代。
read_short() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL short 值。
read_short() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 short 值。
read_short_array(ShortSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL short 数组中从 offset 处开始的 length 个元素。
read_short_array(short[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 short 数组。
read_string() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 字符串值。
read_string() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 string 值。
read_TypeCode() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL typecode 值。
read_TypeCode() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 TypeCode。
read_ulong() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL long 值。
read_ulong() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 CORBA long（即 Java int）值。
read_ulong_array(ULongSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL long 数组中从 offset 处开始的 length 个元素。
read_ulong_array(int[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 CORBA long（即 Java int）数组。
read_ulonglong() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL long long 值。
read_ulonglong() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 CORBA 无符号 longlong（即 Java long）值。
read_ulonglong_array(ULongLongSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL long long 数组中从 offset 处开始的 length 个元素。
read_ulonglong_array(long[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 CORBA longlong（即 Java long）数组。
read_ushort() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL short 值。
read_ushort() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 short 值。
read_ushort_array(UShortSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取无符号 IDL short 数组中从 offset 处开始的 length 个元素。
read_ushort_array(short[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个无符号 short 数组。
read_value(InputStream, TypeCode) - 类 org.omg.CORBA.Any 中的方法
使用给定 typecode 读出（解组）给定输入流中某一 Any 对象的值。
read_Value() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 值类型。
read_value(InputStream) - 接口 org.omg.CORBA.portable.BoxedValueHelper 中的方法
read_value(InputStream) - 接口 org.omg.CORBA.portable.ValueFactory 中的方法
ORB 运行时在解组值类型的过程中调用此方法。
read_value(InputStream) - 类 org.omg.CORBA.StringValueHelper 中的方法
read_value(InputStream) - 类 org.omg.CORBA.WStringValueHelper 中的方法
read_value() - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_value(Class) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_value(BoxedValueHelper) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_value(String) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_value(Serializable) - 类 org.omg.CORBA_2_3.portable.InputStream 中的方法
从输入流解组值类型。
read_wchar() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 宽字符值。
read_wchar() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 wide char 值。
read_wchar_array(WCharSeqHolder, int, int) - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 宽字符数组中从 offset 处开始的 length 个元素。
read_wchar_array(char[], int, int) - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 wide char 数组。
READ_WRITE - 类 java.nio.channels.FileChannel.MapMode 中的静态变量
读取/写入映射模式。
read_wstring() - 接口 org.omg.CORBA.DataInputStream 中的方法
从输入流读取 IDL 宽字符串值。
read_wstring() - 类 org.omg.CORBA.portable.InputStream 中的方法
从此输入流中读取一个 wide string 值。
Readable - java.lang 中的 接口
Readable 是一个字符源。
ReadableByteChannel - java.nio.channels 中的 接口
可读取字节的通道。
readAborted(ImageReader) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告已通过 reader 的 abort 方法中止读操作。
readAll(int, ImageReadParam) - 类 javax.imageio.ImageReader 中的方法
使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。
readAll(Iterator<? extends ImageReadParam>) - 类 javax.imageio.ImageReader 中的方法
以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。
readAny(InputStream) - 类 javax.rmi.CORBA.Util 中的静态方法
将 java.lang.Object 作为 CORBA any 读取。
readAny(InputStream) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.readAny(org.omg.CORBA.portable.InputStream) 的委托调用。
readArray() - 接口 java.sql.SQLInput 中的方法
从流中读取 SQL ARRAY 值并将其作为 Java 编程语言中的 Array 对象返回。
readArray() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL ARRAY 值并以 Java 编程语言中 Array 对象的形式返回。
readAsciiStream() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 ASCII 字符流返回。
readAsciiStream() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 ASCII 字符流的形式返回此 SQLInputImpl 对象中的下一个属性。
readAsRenderedImage(int, ImageReadParam) - 类 javax.imageio.ImageReader 中的方法
返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。
readAttributes(ObjectInputStream, MutableAttributeSet) - 类 javax.swing.text.StyleContext 中的方法
读入属性的特定于上下文的处理。
readAttributeSet(ObjectInputStream, MutableAttributeSet) - 类 javax.swing.text.StyleContext 中的静态方法
从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。
readBigDecimal() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 java.math.BigDecimal 对象返回。
readBigDecimal() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 java.math.BigDecimal 的形式获取此 SQLInputImpl 对象中的下一个属性。
readBinaryStream() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为未解释的字节流返回。
readBinaryStream() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以未解释字节流的形式返回此 SQLInputImpl 对象中的下一个属性。
readBit() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取单个字节，并以 int（0 或 1）的形式返回该字节。
readBit() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readBits(int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取位串 (bitstring) 并以 long 的形式返回，使第一个读取的位成为输出的最高有效位。
readBits(int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readBlob() - 接口 java.sql.SQLInput 中的方法
从流中读取 SQL BLOB 值并将其作为 Java 编程语言中的 Blob 对象返回。
readBlob() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 Blob 对象的形式获取此 SQLInputImpl 对象头部的 BLOB 值。
readBoolean() - 接口 java.io.DataInput 中的方法
读取一个输入字节，如果该字节不是零，则返回 true，如果是零，则返回 false。
readBoolean() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readBoolean 方法的常规协定。
readBoolean() - 类 java.io.ObjectInputStream 中的方法
读取一个 boolean 值。
readBoolean() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个 boolean。
readBoolean() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 boolean 返回。
readBoolean() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取一个字节，如果其不为 0，则返回 boolean 值 true；如果为 0，则返回 false。
readBoolean() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readBoolean() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 boolean 的形式获取此 SQLInputImpl 对象中的下一个属性。
readByte() - 接口 java.io.DataInput 中的方法
读取并返回一个输入字节。
readByte() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readByte 方法的常规协定。
readByte() - 类 java.io.ObjectInputStream 中的方法
读取一个 8 位的字节。
readByte() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个有符号的八位值。
readByte() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 byte 返回。
readByte() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取一个字节，并以 byte 值的形式返回该字节。
readByte() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readByte() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 byte 的形式获取此 SQLInputImpl 对象中的下一个属性。
readBytes() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的字节数组返回。
readBytes(IIOByteBuffer, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。
readBytes(IIOByteBuffer, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readBytes() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以字节数组的形式获取此 SQLInputImpl 对象中的下一个属性。
readChar() - 接口 java.io.DataInput 中的方法
读取两个输入字节并返回一个 char 值。
readChar() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readChar 方法的常规协定。
readChar() - 类 java.io.ObjectInputStream 中的方法
读取一个 16 位的 char 值。
readChar() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个字符。
readChar() - 接口 javax.imageio.stream.ImageInputStream 中的方法
与 readUnsignedShort 等效，唯一的不同在于它的结果使用 char 数据类型返回。
readChar() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readCharacterStream() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Unicode 字符流返回。
readCharacterStream() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Unicode 字符流的形式获取此 SQLInputImpl 对象中的下一个属性。
readChildren(ObjectInputStream) - 类 java.beans.beancontext.BeanContextSupport 中的方法
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。
readClassDescriptor() - 类 java.io.ObjectInputStream 中的方法
从序列化流读取类描述符。
readClob() - 接口 java.sql.SQLInput 中的方法
从流中读取 SQL CLOB 值并将其作为 Java 编程语言中的 Clob 对象返回。
readClob() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 Clob 对象的形式获取此 SQLInputImpl 对象头部的 CLOB 值。
readConfiguration() - 类 java.util.logging.LogManager 中的方法
重新初始化日志属性并重新读取日志配置。
readConfiguration(InputStream) - 类 java.util.logging.LogManager 中的方法
从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。
readData(RowSetInternal) - 接口 javax.sql.RowSetReader 中的方法
读取调用 RowSet 对象的新内容。
readDate() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 java.sql.Date 对象返回。
readDate() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 java.sql.Date 对象的形式获取此 SQLInputImpl 中的下一个属性。
readDouble() - 接口 java.io.DataInput 中的方法
读取八个输入字节并返回一个 double 值。
readDouble() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readDouble 方法的常规协定。
readDouble() - 类 java.io.ObjectInputStream 中的方法
读取一个 64 位的 double 值。
readDouble() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个 double。
readDouble() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 double 返回。
readDouble() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 double 值的形式返回结果。
readDouble() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readDouble() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 double 的形式获取此 SQLInputImpl 对象中的下一个属性。
reader() - 类 java.io.Console 中的方法
获取与此控制台关联的唯一 Reader 对象。
Reader - java.io 中的 类
用于读取字符流的抽象类。
Reader() - 类 java.io.Reader 的构造方法
创建一个新的字符流 reader，其重要部分将同步其自身的 reader。
Reader(Object) - 类 java.io.Reader 的构造方法
创建一个新的字符流 reader，其重要部分将同步给定的对象。
reader - 类 javax.script.SimpleScriptContext 中的变量
此字段是用于脚本输入的 reader。
readerSpiNames - 类 javax.imageio.spi.ImageWriterSpi 中的变量
将从 getImageReaderSpiNames 返回的字符串数组，该数组最初为 null。
readerSupportsThumbnails() - 类 javax.imageio.ImageReader 中的方法
如果此 reader 所理解的图像格式支持与之关联的缩略图预览图像，则返回 true。
readExternal(ObjectInput) - 类 java.awt.datatransfer.DataFlavor 中的方法
根据 Serialized 状态还原此 DataFlavor。
readExternal(ObjectInput) - 接口 java.io.Externalizable 中的方法
对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。
readExternal(ObjectInput) - 类 javax.activation.MimeType 中的方法
对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。
readExternal(ObjectInput) - 类 javax.management.loading.MLet 中的方法
从给定的 ObjectInput 恢复此 MLet 的内容。
readFields() - 类 java.io.ObjectInputStream 中的方法
按名称从流中读取持久字段并使其可用。
readFloat() - 接口 java.io.DataInput 中的方法
读取四个输入字节并返回一个 float 值。
readFloat() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readFloat 方法的常规协定。
readFloat() - 类 java.io.ObjectInputStream 中的方法
读取一个 32 位的 float 值。
readFloat() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个 float。
readFloat() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 float 返回。
readFloat() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 float 值的形式返回结果。
readFloat() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFloat() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 float 的形式获取此 SQLInputImpl 对象中的下一个属性。
readFully(byte[]) - 接口 java.io.DataInput 中的方法
从输入流中读取一些字节，并将它们存储在缓冲区数组 b 中。
readFully(byte[], int, int) - 接口 java.io.DataInput 中的方法
从输入流中读取 len 个字节。
readFully(byte[]) - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readFully 方法的常规协定。
readFully(byte[], int, int) - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readFully 方法的常规协定。
readFully(byte[]) - 类 java.io.ObjectInputStream 中的方法
读取字节，同时阻塞直至读取所有字节。
readFully(byte[], int, int) - 类 java.io.ObjectInputStream 中的方法
读取字节，同时阻塞直至读取所有字节。
readFully(byte[]) - 类 java.io.RandomAccessFile 中的方法
将 b.length 个字节从此文件读入 byte 数组，并从当前文件指针开始。
readFully(byte[], int, int) - 类 java.io.RandomAccessFile 中的方法
将正好 len 个字节从此文件读入 byte 数组，并从当前文件指针开始。
readFully(byte[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 len 个字节，并将其存储到 b 中（从索引 off 开始）。
readFully(byte[]) - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
readFully(short[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 short（有符号 16 位整数），并将其存储到 s 中（从索引 off 开始）。
readFully(char[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 char（无符号 16 位整数），并将其存储到 c 中（从索引 off 开始）。
readFully(int[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 int（有符号 32 位整数），并将其存储到 i 中（从索引 off 开始）。
readFully(long[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 long（有符号 64 位整数），并将其存储到 l 中（从索引 off 开始）。
readFully(float[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 float（32 位 IEEE 单精度浮点值），并将其存储到 f 中（从索引 off 开始）。
readFully(double[], int, int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
根据当前字节顺序从流中读取 len 个 double（64 位 IEEE 双精度浮点值），并将其存储到 d 中（从索引 off 开始）。
readFully(byte[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(byte[]) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(short[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(char[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(int[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(long[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(float[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readFully(double[], int, int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
READING - 类 java.text.AttributedCharacterIterator.Attribute 中的静态变量
某些文本的读法的属性键。
readInt() - 接口 java.io.DataInput 中的方法
读取四个输入字节并返回一个 int 值。
readInt() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readInt 方法的常规协定。
readInt() - 类 java.io.ObjectInputStream 中的方法
读取一个 32 位的 int 值。
readInt() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个有符号的 32 位整数。
readInt() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 int 返回。
readInt() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 int 值的形式返回结果。
readInt() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readInt() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 int 的形式获取此 SQLInputImpl 对象中的下一个属性。
readLine() - 类 java.io.BufferedReader 中的方法
读取一个文本行。
readLine(String, Object...) - 类 java.io.Console 中的方法
提供一个格式化提示，然后从控制台读取单行文本。
readLine() - 类 java.io.Console 中的方法
从控制台读取单行文本。
readLine() - 接口 java.io.DataInput 中的方法
从输入流中读取下一文本行。
readLine() - 类 java.io.DataInputStream 中的方法
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
readLine() - 类 java.io.LineNumberReader 中的方法
读取文本行。
readLine() - 类 java.io.ObjectInputStream 中的方法
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。
readLine() - 类 java.io.RandomAccessFile 中的方法
从此文件读取文本的下一行。
readLine() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从输入流中读取文本的下一行。
readLine() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readLock() - 接口 java.util.concurrent.locks.ReadWriteLock 中的方法
返回用于读取操作的锁。
readLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
readLock() - 类 javax.swing.text.AbstractDocument 中的方法
获取一个锁定，以开始读取文档的某个状态。
readLong() - 接口 java.io.DataInput 中的方法
读取八个输入字节并返回一个 long 值。
readLong() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readLong 方法的常规协定。
readLong() - 类 java.io.ObjectInputStream 中的方法
读取一个 64 位的 long 值。
readLong() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个有符号的 64 位整数。
readLong() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 long 返回。
readLong() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 long 值的形式返回结果。
readLong() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readLong() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 long 的形式获取此 SQLInputImpl 对象中的下一个属性。
readNClob() - 接口 java.sql.SQLInput 中的方法
从流中读取一个 SQL NCLOB 值，并以 Java 编程语言中 NCLOB 对象的形式返回。
readNClob() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL NCLOB 值并以 Java 编程语言中 Clob 对象的形式返回。
readNString() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性，并以 Java 编程语言中 String 的形式返回。
readNString() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
读取流中下一个属性并以 Java 编程语言中 String 的形式返回。
readObject() - 类 java.beans.XMLDecoder 中的方法
从基础输入流中读取下一个对象。
readObject() - 接口 java.io.ObjectInput 中的方法
读取并返回对象。
readObject() - 类 java.io.ObjectInputStream 中的方法
从 ObjectInputStream 读取对象。
readObject() - 接口 java.sql.SQLInput 中的方法
读取流头中的下一个属性并将其作为 Java 编程语言中的 Object 返回。
readObject(Stub, ObjectInputStream) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.readObject(java.io.ObjectInputStream) 的委托调用。
readObject() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 Object 的形式获取此 SQLInputImpl 对象的头部值。
readObjectOverride() - 类 java.io.ObjectInputStream 中的方法
此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。
readOnlyAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将编辑器设置为只读模式的动作名称。
ReadOnlyBufferException - java.nio 中的 异常
当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。
ReadOnlyBufferException() - 异常 java.nio.ReadOnlyBufferException 的构造方法
构造此类的一个实例。
readPassword(String, Object...) - 类 java.io.Console 中的方法
提供一个格式化提示，然后从控制台读取密码，禁用回显。
readPassword() - 类 java.io.Console 中的方法
从控制台读取密码，禁用回显。
readRaster(int, ImageReadParam) - 类 javax.imageio.ImageReader 中的方法
返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。
readRef() - 接口 java.sql.SQLInput 中的方法
从流读取 SQL REF 值并将其作为 Java 编程语言中的 Ref 对象返回。
readRef() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 Ref 对象的形式获取此 SQLInputImpl 对象的头部值。
readResolve() - 类 java.awt.AWTKeyStroke 中的方法
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。
readResolve() - 类 java.awt.color.ICC_Profile 中的方法
解析将被反序列化为用 CMM 注册的实例的实例。
readResolve() - 类 java.awt.font.TextAttribute 中的方法
将反序列化的实例解析为预定义常量。
readResolve() - 类 java.security.cert.Certificate.CertificateRep 中的方法
解析该 Certificate 对象。
readResolve() - 类 java.security.cert.CertPath.CertPathRep 中的方法
返回根据类型和数据所构造的 CertPath。
readResolve() - 类 java.security.KeyRep 中的方法
解析 Key 对象。
readResolve() - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
解析将被反序列化为预定义常量的实例。
readResolve() - 类 java.text.DateFormat.Field 中的方法
将反序列化的实例解析成预定义的常量。
readResolve() - 类 java.text.MessageFormat.Field 中的方法
把正被反序列化的实例解析为预定义的常量。
readResolve() - 类 java.text.NumberFormat.Field 中的方法
将正被反序列化的实例解析为预定义的常量。
readResolve() - 类 javax.management.openmbean.SimpleType 中的方法
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。
readResolve() - 类 javax.print.attribute.EnumSyntax 中的方法
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。
readRowId() - 接口 java.sql.SQLInput 中的方法
从流中读取一个 SQL ROWID 值，并以 Java 编程语言中 RowId 对象的形式返回。
readRowId() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL ROWID 值并以 Java 编程语言中 RowId 对象的形式返回。
readShort() - 接口 java.io.DataInput 中的方法
读取两个输入字节并返回一个 short 值。
readShort() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readShort 方法的常规协定。
readShort() - 类 java.io.ObjectInputStream 中的方法
读取一个 16 位的 short 值。
readShort() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个有符号的 16 位数。
readShort() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 short 返回。
readShort() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取两个字节，根据当前字节顺序将其连接（概念上），然后以 short 值的形式返回结果。
readShort() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readShort() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 short 的形式获取此 SQLInputImpl 对象中的下一个属性。
readSQL(SQLInput, String) - 接口 java.sql.SQLData 中的方法
用从数据库读取的数据填充此对象。
readSQLXML() - 接口 java.sql.SQLInput 中的方法
从流中读取一个 SQL XML 值，并以 Java 编程语言中 SQLXML 对象的形式返回。
readSQLXML() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL XML 值并以 Java 编程语言中 SQLXML 对象的形式返回。
readStreamHeader() - 类 java.io.ObjectInputStream 中的方法
提供的 readStreamHeader 方法允许子类读取并验证它们自己的流头部。
readString() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 Java 编程语言中的 String 返回。
readString() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 Java 编程语言中 String 的形式获取此 SQLInputImpl 对象中的下一个属性。
readThumbnail(int, int) - 类 javax.imageio.ImageReader 中的方法
以 BufferedImage 形式返回通过索引 thumbnailIndex 指定的缩略图预览图像，其与通过索引 ImageIndex 指定的图像关联。
readTile(int, int, int) - 类 javax.imageio.ImageReader 中的方法
读取由 tileX 和 tileY 参数指示的 tile，并以 BufferedImage 形式返回。
readTileRaster(int, int, int) - 类 javax.imageio.ImageReader 中的方法
返回包含 tile 中的原始像素数据的新 Raster 对象，不应用任何颜色转换。
readTime() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 java.sql.Time 对象返回。
readTime() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 java.sql.Time 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
readTimestamp() - 接口 java.sql.SQLInput 中的方法
读取流中的下一个属性并将其作为 java.sql.Timestamp 对象返回。
readTimestamp() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
以 java.sql.Timestamp 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
readUnlock() - 类 javax.swing.text.AbstractDocument 中的方法
执行读取解除锁定。
readUnshared() - 类 java.io.ObjectInputStream 中的方法
从 ObjectInputStream 读取“非共享”对象。
readUnsignedByte() - 接口 java.io.DataInput 中的方法
读取一个输入字节，将它左侧补零 (zero-extend) 转变为 int 类型，并返回结果，所以结果的范围是 0 到 255。
readUnsignedByte() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readUnsignedByte 方法的常规协定。
readUnsignedByte() - 类 java.io.ObjectInputStream 中的方法
读取一个无符号的 8 位字节。
readUnsignedByte() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个无符号的八位数。
readUnsignedByte() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取一个字节，将其转换为 int（概念上），使用 0xff 屏蔽以便去掉所有符号扩展位，然后以 byte 值的形式返回。
readUnsignedByte() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readUnsignedInt() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 long，使用 0xffffffffL 屏蔽以便去掉所有符号扩展位，然后以无符号 long 值的形式返回结果。
readUnsignedInt() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readUnsignedShort() - 接口 java.io.DataInput 中的方法
读取两个输入字节，并返回 0 到 65535 范围内的一个 int 值。
readUnsignedShort() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readUnsignedShort 方法的常规协定。
readUnsignedShort() - 类 java.io.ObjectInputStream 中的方法
读取一个无符号的 16 位 short 值。
readUnsignedShort() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个无符号的 16 位数。
readUnsignedShort() - 接口 javax.imageio.stream.ImageInputStream 中的方法
从流中读取两个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 int，使用 0xffff 屏蔽以便去掉所有符号扩展位，然后以无符号 int 值的形式返回结果。
readUnsignedShort() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readURL() - 接口 java.sql.SQLInput 中的方法
从流中读取 SQL DATALINK 值并将其作为 Java 编程语言中的 java.net.URL 对象返回。
readURL() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
从流中读取 SQL DATALINK 值并以 Java 编程语言中 URL 对象的形式返回。
readUTF() - 接口 java.io.DataInput 中的方法
读入一个已使用 UTF-8 修改版格式编码的字符串。
readUTF() - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 readUTF 方法的常规协定。
readUTF(DataInput) - 类 java.io.DataInputStream 中的静态方法
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。
readUTF() - 类 java.io.ObjectInputStream 中的方法
读取 UTF-8 修改版格式的 String。
readUTF() - 类 java.io.RandomAccessFile 中的方法
从此文件读取一个字符串。
readUTF() - 接口 javax.imageio.stream.ImageInputStream 中的方法
读入一个已使用 UTF-8 修改版格式编码的字符串。
readUTF() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
readValue(InputStream, int, Class, String, RunTime) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
使用 Java 语义从流中读取一个值。
ReadWriteLock - java.util.concurrent.locks 中的 接口
ReadWriteLock 维护了一对相关的锁，一个用于只读操作，另一个用于写入操作。
readXML(WebRowSet, Reader) - 接口 javax.sql.rowset.spi.XmlReader 中的方法
从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。
readXml(Reader) - 接口 javax.sql.rowset.WebRowSet 中的方法
从给定的 Reader 对象以其 XML 格式读取 WebRowSet 对象。
readXml(InputStream) - 接口 javax.sql.rowset.WebRowSet 中的方法
读取基于流的 XML 输入，以填充此 WebRowSet 对象。
ready() - 类 java.io.BufferedReader 中的方法
判断此流是否已准备好被读取。
ready() - 类 java.io.CharArrayReader 中的方法
判断此流是否已准备好被读取。
ready() - 类 java.io.FilterReader 中的方法
判断此流是否已经准备好用于读取。
ready() - 类 java.io.InputStreamReader 中的方法
判断此流是否已经准备好用于读取。
ready() - 类 java.io.PipedReader 中的方法
告知是否准备读取此流。
ready() - 类 java.io.PushbackReader 中的方法
判断是否准备读取此流。
ready() - 类 java.io.Reader 中的方法
判断是否准备读取此流。
ready() - 类 java.io.StringReader 中的方法
判断此流是否已经准备好用于读取。
readyOps() - 类 java.nio.channels.SelectionKey 中的方法
获取此键的 ready 操作集合。
REAL - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 REAL 的 Java 编程语言中的常量（有时称为类型代码）。
realEditor - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
处理该编辑的编辑器。
RealmCallback - javax.security.sasl 中的 类
SaslClient 和 SaslServer 使用此回调来获取领域信息。
RealmCallback(String) - 类 javax.security.sasl.RealmCallback 的构造方法
构造带提示的 RealmCallback。
RealmCallback(String, String) - 类 javax.security.sasl.RealmCallback 的构造方法
构造带提示和默认领域信息的 RealmCallback。
RealmChoiceCallback - javax.security.sasl 中的 类
SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。
RealmChoiceCallback(String, String[], int, boolean) - 类 javax.security.sasl.RealmChoiceCallback 的构造方法
构造带提示、选项列表和默认选项的 RealmChoiceCallback。
realSource - 类 javax.swing.undo.UndoableEditSupport 中的变量
reason - 异常 org.omg.CORBA.PolicyError 中的变量
抛出 PolicyError 异常的原因。
rebind(String, Remote) - 类 java.rmi.Naming 中的静态方法
将指定名称重新绑定到一个新的远程对象。
rebind(String, Remote) - 接口 java.rmi.registry.Registry 中的方法
用提供的远程引用替换此注册表中指定的 name 绑定。
rebind(Name, Object) - 接口 javax.naming.Context 中的方法
将名称绑定到对象，重写任何现有绑定。
rebind(String, Object) - 接口 javax.naming.Context 中的方法
将名称绑定到对象，重写所有现有绑定。
rebind(Name, Object, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
rebind(String, Object, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
rebind(String, Object, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
rebind(Name, Object, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
rebind(String, Object) - 类 javax.naming.InitialContext 中的方法
rebind(Name, Object) - 类 javax.naming.InitialContext 中的方法
REBIND - org.omg.CORBA 中的 异常
如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
REBIND() - 异常 org.omg.CORBA.REBIND 的构造方法
构造一个 REBIND 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
REBIND(String) - 异常 org.omg.CORBA.REBIND 的构造方法
使用指定消息构造一个 REBIND 异常。
REBIND(int, CompletionStatus) - 异常 org.omg.CORBA.REBIND 的构造方法
使用指定次要代码和完成状态 (completion status) 构造一个 REBIND 异常。
REBIND(String, int, CompletionStatus) - 异常 org.omg.CORBA.REBIND 的构造方法
使用指定消息、次要代码和完成状态构造一个 REBIND 异常。
rebind(NameComponent[], Object) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
rebind(NameComponent[], Object) - 类 org.omg.CosNaming._NamingContextStub 中的方法
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
rebind(NameComponent[], Object) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
在命名上下文中创建名称和对象的绑定，即使该名称已经绑定在上下文中。
rebind_context(NameComponent[], NamingContext) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
rebind_context(NameComponent[], NamingContext) - 类 org.omg.CosNaming._NamingContextStub 中的方法
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
rebind_context(NameComponent[], NamingContext) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
在命名上下文中创建名称和命名上下文的绑定，即使该名称已经绑定在上下文中。
recalculateIfInsetsChanged() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
recalculateIfOrientationChanged() - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
recalcWidthCache() - 类 javax.swing.table.DefaultTableColumnModel 中的方法
重新计算所有列的总宽度。
receive(int) - 类 java.io.PipedInputStream 中的方法
接收数据字节。
receive(DatagramPacket) - 类 java.net.DatagramSocket 中的方法
从此套接字接收数据报包。
receive(DatagramPacket) - 类 java.net.DatagramSocketImpl 中的方法
接收数据报包。
receive(ByteBuffer) - 类 java.nio.channels.DatagramChannel 中的方法
通过此通道接收数据报。
receive_exception(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
指示 interceptor 发生异常。
receive_other(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
receive_reply(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
允许 Interceptor 在从服务器返回后但在向客户端返回控件前查询信息。
receive_request(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 Interceptor 在所有信息（包括操作参数）可用后查询信息。
receive_request_service_contexts(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 interceptor 处理服务上下文信息。
received_exception() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回一个 any，它包含要向客户端返回的异常。
received_exception_id() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回将向客户端返回的异常的存储库 id。
Receiver - javax.sound.midi 中的 接口
一个 Receiver，用于接收 MidiEvent 对象，并且通常执行一些响应性的操作，例如，解释该对象以生成声音或原始 MIDI 输出。
reclaim(AttributeSet) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
回收某个属性集。
reclaim(AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
返回 MutableAttributeSet 实现不再需要的集合。
reconnect(Control[]) - 类 javax.naming.ldap.InitialLdapContext 中的方法
reconnect(Control[]) - 接口 javax.naming.ldap.LdapContext 中的方法
使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。
reconvert() - 类 java.awt.im.InputContext 中的方法
让当前输入方法从当前客户端组件中恢复文本。
reconvert() - 接口 java.awt.im.spi.InputMethod 中的方法
启动恢复操作。
recordDisable(Track) - 接口 javax.sound.midi.Sequencer 中的方法
禁止向指定轨道的录制。
recordEnable(Track, int) - 接口 javax.sound.midi.Sequencer 中的方法
为录制特定通道上接收的事件准备指定的轨道。
recover(int) - 接口 javax.transaction.xa.XAResource 中的方法
从资源管理器获取准备的事务分支的列表。
Rectangle - java.awt 中的 类
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Rectangle() - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角的坐标为 (0,0)，宽度和高度均为 0。
Rectangle(Rectangle) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，并将其初始化，以与指定 Rectangle 的值匹配。
Rectangle(int, int, int, int) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角被指定为 (x,y)，其宽度和高度由同名的参数指定。
Rectangle(int, int) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角的坐标为 (0,0)，其宽度和高度由同名的参数指定。
Rectangle(Point, Dimension) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角由 Point 参数指定，其宽度和高度由 Dimension 参数指定。
Rectangle(Point) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角是指定的 Point，其宽度和高度均为 0。
Rectangle(Dimension) - 类 java.awt.Rectangle 的构造方法
构造一个新的 Rectangle，其左上角为 (0,0)，其宽度和高度由 Dimension 参数指定。
Rectangle2D - java.awt.geom 中的 类
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
Rectangle2D() - 类 java.awt.geom.Rectangle2D 的构造方法
这是一个不可直接实例化的抽象类。
Rectangle2D.Double - java.awt.geom 中的 类
Double 类定义一个在 double 坐标中指定的矩形。
Rectangle2D.Double() - 类 java.awt.geom.Rectangle2D.Double 的构造方法
构造一个新 Rectangle2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Rectangle2D.Double(double, double, double, double) - 类 java.awt.geom.Rectangle2D.Double 的构造方法
根据指定的 double 坐标构造和初始化 Rectangle2D。
Rectangle2D.Float - java.awt.geom 中的 类
Float 类定义一个在 float 坐标中指定的矩形。
Rectangle2D.Float() - 类 java.awt.geom.Rectangle2D.Float 的构造方法
构造一个新 Rectangle2D，并将其初始化为：位置 (0.0, 0.0)、大小 (0.0, 0.0)。
Rectangle2D.Float(float, float, float, float) - 类 java.awt.geom.Rectangle2D.Float 的构造方法
根据指定的 float 坐标构造和初始化 Rectangle2D。
rectangleForCurrentValue() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
返回为绘制当前所选项而保留的区域。
RectangularShape - java.awt.geom 中的 类
RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。
RectangularShape() - 类 java.awt.geom.RectangularShape 的构造方法
这是一个不可直接实例化的抽象类。
rects - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
recycleNode() - 接口 javax.xml.soap.Node 中的方法
通知实现此 Node 对象不再由应用程序使用，对于以后可能创建的节点，实现可以随意重用此对象。
red - 类 java.awt.Color 中的静态变量
红色。
RED - 类 java.awt.Color 中的静态变量
红色。
REDCOMPONENT - 类 java.awt.color.ICC_ProfileRGB 中的静态变量
用于获取红色分量的 gamma 值或 TRC。
redefineClasses(ClassDefinition...) - 接口 java.lang.instrument.Instrumentation 中的方法
使用提供的类文件重定义提供的类集。
redirectErrorStream() - 类 java.lang.ProcessBuilder 中的方法
通知进程生成器是否合并标准错误和标准输出。
redirectErrorStream(boolean) - 类 java.lang.ProcessBuilder 中的方法
设置此进程生成器的 redirectErrorStream 属性。
redispatchEvent(Component, AWTEvent) - 类 java.awt.KeyboardFocusManager 中的方法
重新指派 AWTEvent 的方式是，AWT 事件调度程序不会递归式请求 KeyboardFocusManager 或任何已安装的 KeyEventDispatcher 再次指派该事件。
redo() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
重复执行更改。
redo() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
重复执行更改。
redo() - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的方法
重复更改。
redo() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
如果 canRedo 返回 false，则抛出 CannotRedoException。
redo() - 类 javax.swing.undo.CompoundEdit 中的方法
按添加时的顺序将 redo 发送到所有包含的 UndoableEdit 中。
redo() - 类 javax.swing.undo.StateEdit 中的方法
通知编辑对象应用编辑之后的状态
redo() - 接口 javax.swing.undo.UndoableEdit 中的方法
重新应用编辑。
redo() - 类 javax.swing.undo.UndoManager 中的方法
恢复适当的编辑。
RedoName - 类 javax.swing.undo.AbstractUndoableEdit 中的静态变量
由 getRedoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此段落。
redoTo(UndoableEdit) - 类 javax.swing.undo.UndoManager 中的方法
恢复从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
reducePermits(int) - 类 java.util.concurrent.Semaphore 中的方法
根据指定的缩减量减小可用许可的数目。
ReentrantLock - java.util.concurrent.locks 中的 类
一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。
ReentrantLock() - 类 java.util.concurrent.locks.ReentrantLock 的构造方法
创建一个 ReentrantLock 的实例。
ReentrantLock(boolean) - 类 java.util.concurrent.locks.ReentrantLock 的构造方法
创建一个具有给定公平策略的 ReentrantLock。
ReentrantReadWriteLock - java.util.concurrent.locks 中的 类
支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。
ReentrantReadWriteLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 的构造方法
使用默认（非公平）的排序属性创建一个新的 ReentrantReadWriteLock。
ReentrantReadWriteLock(boolean) - 类 java.util.concurrent.locks.ReentrantReadWriteLock 的构造方法
使用给定的公平策略创建一个新的 ReentrantReadWriteLock。
ReentrantReadWriteLock.ReadLock - java.util.concurrent.locks 中的 类
ReentrantReadWriteLock.readLock() 方法返回的锁。
ReentrantReadWriteLock.ReadLock(ReentrantReadWriteLock) - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 的构造方法
子类使用的构造方法
ReentrantReadWriteLock.WriteLock - java.util.concurrent.locks 中的 类
ReentrantReadWriteLock.writeLock() 方法返回的锁。
ReentrantReadWriteLock.WriteLock(ReentrantReadWriteLock) - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 的构造方法
子类使用的构造方法
ref - 类 java.rmi.server.RemoteObject 中的变量
对象的远程引用。
Ref - java.sql 中的 接口
Java 编程语言中 SQL REF 值的映射关系，它是到数据库中的 SQL 结构类型值的引用。
REF - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 REF 的 Java 编程语言中的常量（有时称为类型代码）。
REF_MBEAN_NOT_REGISTERED - 类 javax.management.relation.RoleStatus 中的静态变量
试图设置角色值时的问题类型，包括未在 MBean Server 中注册的 MBean 的 ObjectName。
REF_MBEAN_OF_INCORRECT_CLASS - 类 javax.management.relation.RoleStatus 中的静态变量
试图设置角色值时的问题类型，包括不属于该角色所期望类的 MBean 的 ObjectName。
RefAddr - javax.naming 中的 类
此类表示通信端点的地址。
RefAddr(String) - 类 javax.naming.RefAddr 的构造方法
使用地址类型构造一个新的 RefAddr 实例。
Reference<T> - java.lang.ref 中的 类
引用对象的抽象基类。
Reference - javax.naming 中的 类
此类表示对存在于命名/目录系统以外的对象的引用。
Reference(String) - 类 javax.naming.Reference 的构造方法
使用类名称 'className' 构造对某个对象的新引用。
Reference(String, RefAddr) - 类 javax.naming.Reference 的构造方法
使用类名称 'className' 和一个地址构造对某个对象的新引用。
Reference(String, String, String) - 类 javax.naming.Reference 的构造方法
使用类名称 'className' 以及对象工厂的类名称和位置创建对某个对象的新引用。
Reference(String, RefAddr, String, String) - 类 javax.naming.Reference 的构造方法
使用类名称 'className'、对象工厂的类名称和位置以及对象的地址创建该对某个对象的新引用。
Reference - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Reference 元素的表示形式。
reference_to_id(Object) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作返回指定引用封装的 Object Id 值。
reference_to_servant(Object) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果 POA 具有 RETAIN 策略并且指定的对象存在于 Active Object Map 中，则此操作返回与 Active Object Map 中该对象关联的 servant。
Referenceable - javax.naming 中的 接口
此接口由可以为自身提供 Reference 的对象实现。
ReferenceQueue<T> - java.lang.ref 中的 类
引用队列，在检测到适当的可到达性更改后，垃圾回收器将已注册的引用对象添加到该队列中。
ReferenceQueue() - 类 java.lang.ref.ReferenceQueue 的构造方法
构造一个新的引用对象队列。
ReferenceType - javax.lang.model.type 中的 接口
表示一个引用类型。
ReferenceUriSchemesSupported - javax.print.attribute.standard 中的 类
ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
ReferenceUriSchemesSupported(int) - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 的构造方法
构造具有给定整数值的新 ReferenceUriSchemesSupported 枚举值。
REFERRAL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定将如何处理服务提供者遇到的引用的环境属性名称。
ReferralException - javax.naming 中的 异常
此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
ReferralException(String) - 异常 javax.naming.ReferralException 的构造方法
使用所提供的解释构造一个新的 ReferralException 实例。
ReferralException() - 异常 javax.naming.ReferralException 的构造方法
构造一个新的 ReferralException 实例。
ReflectionException - javax.management 中的 异常
表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
ReflectionException(Exception) - 异常 javax.management.ReflectionException 的构造方法
创建包装实际 java.lang.Exception 的 ReflectionException。
ReflectionException(Exception, String) - 异常 javax.management.ReflectionException 的构造方法
创建包装带有详细消息的实际 java.lang.Exception 的 ReflectionException。
ReflectPermission - java.lang.reflect 中的 类
反射操作的 Permission 类。
ReflectPermission(String) - 类 java.lang.reflect.ReflectPermission 的构造方法
构造不带指定名称的 ReflectPermission。
ReflectPermission(String, String) - 类 java.lang.reflect.ReflectPermission 的构造方法
构造带指定名称和动作的 ReflectPermission。
refresh() - 类 java.security.Policy 中的方法
刷新/重新加载策略配置。
refresh() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
延长此票据的有效期。
refresh() - 类 javax.security.auth.login.Configuration 中的方法
刷新和重新加载 Configuration。
refresh() - 类 javax.security.auth.Policy 中的方法
已过时。 刷新/重新加载 Policy。
refresh() - 接口 javax.security.auth.Refreshable 中的方法
更新或延长此 Object 的有效期。
REFRESH_RATE_UNKNOWN - 类 java.awt.DisplayMode 中的静态变量
刷新率的值（如果未知）。
Refreshable - javax.security.auth 中的 接口
诸如证书之类的对象可以选择实现此接口，以提供对自己进行刷新的功能。
RefreshFailedException - javax.security.auth 中的 异常
当 refresh 操作失败时，抛出此异常。
RefreshFailedException() - 异常 javax.security.auth.RefreshFailedException 的构造方法
构造不带详细消息的 RefreshFailedException。
RefreshFailedException(String) - 异常 javax.security.auth.RefreshFailedException 的构造方法
构造带指定详细消息的 RefreshFailedException。
refreshRow() - 接口 java.sql.ResultSet 中的方法
用数据库中的最近值刷新当前行。
regexFilter(String, int...) - 类 javax.swing.RowFilter 中的静态方法
返回一个 RowFilter，它使用正则表达式确定要包含哪些条目。
region(int, int) - 类 java.util.regex.Matcher 中的方法
设置此匹配器的区域限制。
Region - javax.swing.plaf.synth 中的 类
Swing 组件的独特呈现区域。
Region(String, String, boolean) - 类 javax.swing.plaf.synth.Region 的构造方法
创建具有指定名称的 Region。
regionEnd() - 类 java.util.regex.Matcher 中的方法
报告此匹配器区域的结束索引（不包括）。
regionMatches(int, String, int, int) - 类 java.lang.String 中的方法
测试两个字符串区域是否相等。
regionMatches(boolean, int, String, int, int) - 类 java.lang.String 中的方法
测试两个字符串区域是否相等。
regionStart() - 类 java.util.regex.Matcher 中的方法
报告此匹配器区域的开始索引。
register(Selector, int, Object) - 类 java.nio.channels.SelectableChannel 中的方法
向给定的选择器注册此通道，返回一个选择键。
register(Selector, int) - 类 java.nio.channels.SelectableChannel 中的方法
向给定的选择器注册此通道，返回一个选择键。
register(Selector, int, Object) - 类 java.nio.channels.spi.AbstractSelectableChannel 中的方法
向给定的选择器注册此通道，返回一个选择键。
register(AbstractSelectableChannel, int, Object) - 类 java.nio.channels.spi.AbstractSelector 中的方法
向此选择器注册给定的通道。
register(ActivationDesc) - 类 java.rmi.activation.Activatable 中的静态方法
为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
register_initial_reference(String, Object) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
等同于 ORB.register_initial_reference。
register_policy_factory(int, PolicyFactory) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
注册给定 PolicyType 的 PolicyFactory。
register_value_factory(String, ValueFactory) - 类 org.omg.CORBA_2_3.ORB 中的方法
RegisterableService - javax.imageio.spi 中的 接口
一个可选接口，它可能是由向 ServiceRegistry 注册的服务提供者对象提供的。
registerApplicationClasspathSpis() - 类 javax.imageio.spi.IIORegistry 中的方法
使用默认的 ClassLoader 注册应用程序类路径中找到的所有可用的服务提供者。
registerComponent(JComponent) - 类 javax.swing.ToolTipManager 中的方法
注册一个工具提示管理组件。
registerDriver(Driver) - 类 java.sql.DriverManager 中的静态方法
向 DriverManager 注册给定驱动程序。
registerEditor(Class<?>, Class<?>) - 类 java.beans.PropertyEditorManager 中的静态方法
注册一个将用来编辑给定目标类的值的编辑器类。
registerEditorKitForContentType(String, String) - 类 javax.swing.JEditorPane 中的静态方法
建立 type 到 classname 的默认绑定。
registerEditorKitForContentType(String, String, ClassLoader) - 类 javax.swing.JEditorPane 中的静态方法
建立 type 到 classname 的默认绑定。
registerEngineExtension(String, ScriptEngineFactory) - 类 javax.script.ScriptEngineManager 中的方法
注册一个 ScriptEngineFactory 来处理扩展。
registerEngineMimeType(String, ScriptEngineFactory) - 类 javax.script.ScriptEngineManager 中的方法
注册一个 ScriptEngineFactory 来处理 mime 类型。
registerEngineName(String, ScriptEngineFactory) - 类 javax.script.ScriptEngineManager 中的方法
注册一个 ScriptEngineFactory 来处理语言名称。
registerFont(Font) - 类 java.awt.GraphicsEnvironment 中的方法
在此 GraphicsEnvironment 中注册一个/已创建的 Font。
registerGroup(ActivationGroupDesc) - 接口 java.rmi.activation.ActivationSystem 中的方法
注册激活组。
registerKeyboardAction(ActionListener, String, KeyStroke, int) - 类 javax.swing.JComponent 中的方法
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
registerKeyboardAction(ActionListener, KeyStroke, int) - 类 javax.swing.JComponent 中的方法
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
registerKeyboardActions() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
registerListeners() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
向该 Component 注册此 DragGestureRecognizer 的 Listeners。
registerListeners() - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
注册此 DragGestureRecognizer 的 Listener 和 Component
registerMBean(Object, ObjectName) - 接口 javax.management.MBeanServer 中的方法
将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
registerObject(ActivationDesc) - 接口 java.rmi.activation.ActivationSystem 中的方法
registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
registerOutParameter(int, int) - 接口 java.sql.CallableStatement 中的方法
按顺序位置 parameterIndex 将 OUT 参数注册为 JDBC 类型 sqlType。
registerOutParameter(int, int, int) - 接口 java.sql.CallableStatement 中的方法
按顺序位置 parameterIndex 将参数注册为 JDBC 类型 sqlType。
registerOutParameter(int, int, String) - 接口 java.sql.CallableStatement 中的方法
注册指定的输出参数。
registerOutParameter(String, int) - 接口 java.sql.CallableStatement 中的方法
将名为 parameterName 的 OUT 参数注册为 JDBC 类型 sqlType。
registerOutParameter(String, int, int) - 接口 java.sql.CallableStatement 中的方法
将名为 parameterName 的参数注册为 JDBC 类型 sqlType。
registerOutParameter(String, int, String) - 接口 java.sql.CallableStatement 中的方法
注册指定的输出参数。
registerProvider(String) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
将给定的同步提供者添加到工厂注册器。
registerService(PrintService) - 类 javax.print.PrintServiceLookup 中的静态方法
允许应用程序直接注册一个实现了 PrintService 的类的实例。
registerServiceProvider(T, Class<T>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
将一个服务提供者对象添加到注册表。
registerServiceProvider(Object) - 类 javax.imageio.spi.ServiceRegistry 中的方法
将一个服务提供者对象添加到注册表。
registerServiceProvider(PrintServiceLookup) - 类 javax.print.PrintServiceLookup 中的静态方法
允许应用程序显式地注册一个实现了查找服务的类。
registerServiceProviders(Iterator<?>) - 类 javax.imageio.spi.ServiceRegistry 中的方法
将一组取自 Iterator 的服务提供者对象添加到注册表。
registerStaticAttributeKey(Object) - 类 javax.swing.text.StyleContext 中的静态方法
将一个对象注册为用作属性集中的一个键的静态对象。
registerSubclass(Class<?>) - 类 java.awt.AWTKeyStroke 中的静态方法
注册一个新类，AWTKeyStroke 中的工厂方法在生成 AWTKeyStroke 的新实例时将使用它。
registerTag(HTML.Tag, HTMLDocument.HTMLReader.TagAction) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
注册给定标记的处理程序。
registerTarget(Tie, Remote) - 类 javax.rmi.CORBA.Util 中的静态方法
为 tie 注册一个目标。
registerTarget(Tie, Remote) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 的委托调用。
registerValidation(ObjectInputValidation, int) - 类 java.io.ObjectInputStream 中的方法
在返回图形前注册要验证的对象。
REGISTRATION_NOTIFICATION - 类 javax.management.MBeanServerNotification 中的静态变量
表示已注册该 MBean 的通知类型。
Registry - java.rmi.registry 中的 接口
Registry 是简单远程对象注册表的一个远程接口，它提供存储和获取绑定了任意字符串名称的远程对象引用的方法。
REGISTRY_ID - 类 java.rmi.server.ObjID 中的静态变量
注册表的已知 ObjID 的对象数。
REGISTRY_PORT - 接口 java.rmi.registry.Registry 中的静态变量
已知的注册表端口。
RegistryHandler - java.rmi.registry 中的 接口
已过时。 无替代版本
registryImpl(int) - 接口 java.rmi.registry.RegistryHandler 中的方法
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
registryStub(String, int) - 接口 java.rmi.registry.RegistryHandler 中的方法
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。
rehash() - 类 java.util.Hashtable 中的方法
增加此哈希表的容量并在内部对其进行重组，以便更有效地容纳和访问其元素。
rejectDrag() - 类 java.awt.dnd.DropTargetContext 中的方法
拒绝该 Drag。
rejectDrag() - 类 java.awt.dnd.DropTargetDragEvent 中的方法
作为检查 dropAction 或可用的 DataFlavor 类型的结果，拒绝 drag。
rejectDrop() - 类 java.awt.dnd.DropTargetContext 中的方法
调用以指示放置操作是不可接受的。
rejectDrop() - 类 java.awt.dnd.DropTargetDropEvent 中的方法
拒绝 Drop。
rejectedExecution(Runnable, ThreadPoolExecutor) - 接口 java.util.concurrent.RejectedExecutionHandler 中的方法
当 execute 不能接受某个任务时，可以由 ThreadPoolExecutor 调用的方法。
rejectedExecution(Runnable, ThreadPoolExecutor) - 类 java.util.concurrent.ThreadPoolExecutor.AbortPolicy 中的方法
总是抛出 RejectedExecutionException。
rejectedExecution(Runnable, ThreadPoolExecutor) - 类 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy 中的方法
执行调用者线程中的任务 r；如果执行程序已关闭，则会丢弃该任务。
rejectedExecution(Runnable, ThreadPoolExecutor) - 类 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy 中的方法
获取并忽略下一个任务，否则如果该任务立即可用，执行程序将执行该任务，然后再试图重新执行任务 r；如果执行程序已关闭，则会丢弃任务 r。
rejectedExecution(Runnable, ThreadPoolExecutor) - 类 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy 中的方法
不执行任何操作，在这种情况下将放弃任务 r。
RejectedExecutionException - java.util.concurrent 中的 异常
当无法执行某个任务时,由 Executor 抛出的异常。
RejectedExecutionException() - 异常 java.util.concurrent.RejectedExecutionException 的构造方法
构造不带详细消息的 RejectedExecutionException。
RejectedExecutionException(String) - 异常 java.util.concurrent.RejectedExecutionException 的构造方法
构造带指定详细消息的 RejectedExecutionException。
RejectedExecutionException(String, Throwable) - 异常 java.util.concurrent.RejectedExecutionException 的构造方法
构造带指定详细消息和原因的 RejectedExecutionException。
RejectedExecutionException(Throwable) - 异常 java.util.concurrent.RejectedExecutionException 的构造方法
构造带指定原因的 RejectedExecutionException。
RejectedExecutionHandler - java.util.concurrent 中的 接口
无法由 ThreadPoolExecutor 执行的任务的处理程序。
rejectedSetBCOnce - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
一个标志，指示在试图执行 setBeanContext 操作时，至少已经抛出了一个 PropertyChangeVetoException。
REL - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Relation - javax.management.relation 中的 接口
此接口必须由任何 MBean 类（期望表示为一种使用 Relation Service 管理的关系）来实现。
RELATION_BASIC_CREATION - 类 javax.management.relation.RelationNotification 中的静态变量
内部关系的创建类型。
RELATION_BASIC_REMOVAL - 类 javax.management.relation.RelationNotification 中的静态变量
从内部关系的 Relation Service 中移除的类型。
RELATION_BASIC_UPDATE - 类 javax.management.relation.RelationNotification 中的静态变量
内部关系的更新类型。
RELATION_MBEAN_CREATION - 类 javax.management.relation.RelationNotification 中的静态变量
添加到 Relation Service 中的关系 MBean 的类型。
RELATION_MBEAN_REMOVAL - 类 javax.management.relation.RelationNotification 中的静态变量
从关系 MBean 的 Relation Service 中移除的类型。
RELATION_MBEAN_UPDATE - 类 javax.management.relation.RelationNotification 中的静态变量
关系 MBean 的更新类型。
RelationException - javax.management.relation 中的 异常
此类是关系管理过程中引发的任何异常的超类。
RelationException() - 异常 javax.management.relation.RelationException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RelationException(String) - 异常 javax.management.relation.RelationException 的构造方法
异常中放置了给定消息的构造方法。
RelationNotFoundException - javax.management.relation 中的 异常
Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
RelationNotFoundException() - 异常 javax.management.relation.RelationNotFoundException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RelationNotFoundException(String) - 异常 javax.management.relation.RelationNotFoundException 的构造方法
异常中放置了给定消息的构造方法。
RelationNotification - javax.management.relation 中的 类
Relation Service（关系服务）中的更改通知。
RelationNotification(String, Object, long, long, String, String, String, ObjectName, List<ObjectName>) - 类 javax.management.relation.RelationNotification 的构造方法
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String, Object, long, long, String, String, String, ObjectName, String, List<ObjectName>, List<ObjectName>) - 类 javax.management.relation.RelationNotification 的构造方法
为关系中的角色更新创建通知。
relations - 类 javax.accessibility.AccessibleRelationSet 中的变量
Vector 中的每个项表示一个 AccessibleRelation。
RelationService - javax.management.relation 中的 类
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。
RelationService(boolean) - 类 javax.management.relation.RelationService 的构造方法
构造方法。
RelationServiceMBean - javax.management.relation 中的 接口
Relation Service 负责创建和删除关系类型和关系，还负责处理一致性和提供查询机制。
RelationServiceNotRegisteredException - javax.management.relation 中的 异常
在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
RelationServiceNotRegisteredException() - 异常 javax.management.relation.RelationServiceNotRegisteredException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RelationServiceNotRegisteredException(String) - 异常 javax.management.relation.RelationServiceNotRegisteredException 的构造方法
异常中放置了给定消息的构造方法。
RelationSupport - javax.management.relation 中的 类
RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。
RelationSupport(String, ObjectName, String, RoleList) - 类 javax.management.relation.RelationSupport 的构造方法
创建一个 RelationSupport 对象。
RelationSupport(String, ObjectName, MBeanServer, String, RoleList) - 类 javax.management.relation.RelationSupport 的构造方法
创建一个 RelationSupport 对象。
RelationSupportMBean - javax.management.relation 中的 接口
RelationSupport 对象由 Relation Service 内部使用，表示任何关系类型的具有无限量角色的简单关系（只有角色，没有属性或方法）。
RelationType - javax.management.relation 中的 接口
该 RelationType 接口必须由期望表示关系类型的任何类来实现。
RelationTypeNotFoundException - javax.management.relation 中的 异常
Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
RelationTypeNotFoundException() - 异常 javax.management.relation.RelationTypeNotFoundException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RelationTypeNotFoundException(String) - 异常 javax.management.relation.RelationTypeNotFoundException 的构造方法
异常中放置了给定消息的构造方法。
RelationTypeSupport - javax.management.relation 中的 类
RelationTypeSupport 对象实现 RelationType 接口。
RelationTypeSupport(String, RoleInfo[]) - 类 javax.management.relation.RelationTypeSupport 的构造方法
所有角色定义在其中动态创建并作为参数传递的构造方法。
RelationTypeSupport(String) - 类 javax.management.relation.RelationTypeSupport 的构造方法
用于子类的构造方法。
RELATIVE - 类 java.awt.GridBagConstraints 中的静态变量
指定此组件为其行或列（gridwidth、gridheight）中的倒数第二个组件，或者让此组件紧跟在以前添加的组件（gridx、gridy）之后。
relative(int) - 接口 java.sql.ResultSet 中的方法
按相对行数（或正或负）移动光标。
relativeCCW(double, double, double, double, double, double) - 类 java.awt.geom.Line2D 中的静态方法
返回一个指示符，指示指定点 (px,py) 相对于从 (x1,y1) 到 (x2,y2) 的线段的位置。
relativeCCW(double, double) - 类 java.awt.geom.Line2D 中的方法
返回一个指示符，指示指定点 (px,py) 相对于此线段的位置。
relativeCCW(Point2D) - 类 java.awt.geom.Line2D 中的方法
返回一个指示符，指示指定 Point2D 相对于此线段的位置。
relativize(URI) - 类 java.net.URI 中的方法
根据此 URI 将给定 URI 相对化。
RELAXNG_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
RELAX NG Namespace URI. 被定义为 "http://relaxng.org/ns/structure/1.0"。
release() - 类 java.nio.channels.FileLock 中的方法
释放此锁定。
release(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以独占模式释放。
release(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以独占模式释放对象。
release() - 类 java.util.concurrent.Semaphore 中的方法
释放一个许可，将其返回给信号量。
release(int) - 类 java.util.concurrent.Semaphore 中的方法
释放给定数目的许可，将其返回到信号量。
release() - 接口 javax.sql.rowset.CachedRowSet 中的方法
释放此 CachedRowSet 对象的当前内容并将 rowSetChanged 事件发送到所有已注册侦听器。
release(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
发布与所提供对象引用关联的资源。
releaseBeanContextResources() - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
子类可重写此方法来提供它们自己的释放行为。
releaseBeanContextResources() - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
从 setBeanContext 中调用，以通知 BeanContextChild 释放从嵌套 BeanContext 中获得的资源。
releaseInputStream() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
releaseMBeanServer(MBeanServer) - 类 javax.management.MBeanServerFactory 中的静态方法
移除对已创建 MBeanServer 的内部 MBeanServerFactory 引用。
releaseOutputStream() - 接口 java.rmi.server.RemoteCall 中的方法
已过时。 无替代版本
releaseReply(Object, InputStream) - 类 org.omg.CORBA.portable.Delegate 中的方法
releaseReply 可以由 stub 以可选方式调用，以在解组完成时将应答流释放回 ORB。
releaseSavepoint(Savepoint) - 接口 java.sql.Connection 中的方法
从当前事务中移除指定的 Savepoint 和后续 Savepoint 对象。
releaseService(BeanContextServices, Object, Object) - 接口 java.beans.beancontext.BeanContextServiceProvider 中的方法
由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。
releaseService(BeanContextChild, Object, Object) - 接口 java.beans.beancontext.BeanContextServices 中的方法
通过在基础 BeanContextServiceProvider 上调用 releaseService() 释放 BeanContextChild（或与 BeanContextChild 关联的任意对象）对指定服务的引用。
releaseService(BeanContextServices, Object, Object) - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 中的方法
releaseService(BeanContextChild, Object, Object) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
释放服务。
releaseShared(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
以共享模式释放。
releaseShared(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
以共享模式释放对象。
releaseWritableTile(int, int) - 类 java.awt.image.BufferedImage 中的方法
放弃写入一个 tile 的权限。
releaseWritableTile(int, int) - 接口 java.awt.image.WritableRenderedImage 中的方法
放弃写入一个 tile 的权力。
reload() - 类 java.util.ServiceLoader 中的方法
清除此加载器的服务者缓存，以重载所有服务者。
reload() - 类 javax.swing.tree.DefaultTreeModel 中的方法
如果已修改此模型依赖的 TreeNode，则调用此方法。
reload(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
如果已修改此模型依赖的 TreeNode，则调用此方法。
REMAINDER - 类 java.awt.GridBagConstraints 中的静态变量
指定此组件是其行或列中的最后一个组件。
remainder(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回其值为 (this % divisor) 的 BigDecimal。
remainder(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
remainder(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this % val) 的 BigInteger。
remaining() - 类 java.nio.Buffer 中的方法
返回当前位置与限制之间的元素数。
remainingCapacity() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回在无阻塞的理想情况下（不存在内存或资源约束）此队列能接受的其他元素数量。
remainingCapacity() - 接口 java.util.concurrent.BlockingQueue 中的方法
返回在无阻塞的理想情况下（不存在内存或资源约束）此队列能接受的附加元素数量；如果没有内部限制，则返回 Integer.MAX_VALUE。
remainingCapacity() - 类 java.util.concurrent.DelayQueue 中的方法
因为 DelayQueue 没有容量限制，所以它总是返回 Integer.MAX_VALUE。
remainingCapacity() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回理想情况下（没有内存和资源约束）此双端队列可不受阻塞地接受的额外元素数。
remainingCapacity() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回理想情况下（没有内存和资源约束）此队列可接受并且不会被阻塞的附加元素数量。
remainingCapacity() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
总是返回 Integer.MAX_VALUE，因为 PriorityBlockingQueue 没有容量限制。
remainingCapacity() - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 0。
remainingName - 异常 javax.naming.NamingException 中的变量
包含尚未解析的剩余名称。
remainingName - 类 javax.naming.spi.ResolveResult 中的变量
该字段包含要解析的剩余名称。
remainingNewName - 异常 javax.naming.CannotProceedException 中的变量
包含 Context.rename() 第二个 "name" 参数的剩余未解析部分。
remapInstrument(Instrument, Instrument) - 接口 javax.sound.midi.Synthesizer 中的方法
重新映射一个乐器。
RemarshalException - org.omg.CORBA.portable 中的 异常
此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
RemarshalException() - 异常 org.omg.CORBA.portable.RemarshalException 的构造方法
构造一个 RemarshalException。
Remote - java.rmi 中的 接口
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteCall - java.rmi.server 中的 接口
已过时。 无替代版本。
remoteEquals(RemoteRef) - 接口 java.rmi.server.RemoteRef 中的方法
比较两个远程对象是否相等。
RemoteException - java.rmi 中的 异常
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
RemoteException() - 异常 java.rmi.RemoteException 的构造方法
构造一个 RemoteException。
RemoteException(String) - 异常 java.rmi.RemoteException 的构造方法
构造带指定详细消息的 RemoteException。
RemoteException(String, Throwable) - 异常 java.rmi.RemoteException 的构造方法
构造带指定详细消息和原因的 RemoteException。
remoteHashCode() - 接口 java.rmi.server.RemoteRef 中的方法
返回远程对象的哈希码。
RemoteObject - java.rmi.server 中的 类
该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
RemoteObject() - 类 java.rmi.server.RemoteObject 的构造方法
创建远程对象。
RemoteObject(RemoteRef) - 类 java.rmi.server.RemoteObject 的构造方法
创建一个用指定远程引用初始化的远程对象。
RemoteObjectInvocationHandler - java.rmi.server 中的 类
与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
RemoteObjectInvocationHandler(RemoteRef) - 类 java.rmi.server.RemoteObjectInvocationHandler 的构造方法
创建一个用指定 RemoteRef 构造的新 RemoteObjectInvocationHandler。
RemoteRef - java.rmi.server 中的 接口
RemoteRef 表示远程对象的句柄。
RemoteServer - java.rmi.server 中的 类
该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
RemoteServer() - 类 java.rmi.server.RemoteServer 的构造方法
构造一个 RemoteServer。
RemoteServer(RemoteRef) - 类 java.rmi.server.RemoteServer 的构造方法
构造带指定引用类型的 RemoteServer。
RemoteStub - java.rmi.server 中的 类
该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
RemoteStub() - 类 java.rmi.server.RemoteStub 的构造方法
构造一个 RemoteStub。
RemoteStub(RemoteRef) - 类 java.rmi.server.RemoteStub 的构造方法
构造带指定远程引用的 RemoteStub。
remoteToString() - 接口 java.rmi.server.RemoteRef 中的方法
返回表示此远程对象的引用的 String。
REMOVAL - 接口 org.w3c.dom.events.MutationEvent 中的静态变量
只移除 Attr。
remove(EventListener) - 类 java.awt.AWTEventMulticaster 中的方法
从此多路广播器中移除一个侦听器。
remove(ComponentListener, ComponentListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从组件侦听器 l 中移除旧的组件侦听器，并返回得到的多路广播侦听器。
remove(ContainerListener, ContainerListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从容器侦听器 l 中移除旧的容器侦听器，并返回得到的多路广播侦听器。
remove(FocusListener, FocusListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从焦点侦听器 l 中移除旧的焦点侦听器，并返回得到的多路广播侦听器。
remove(KeyListener, KeyListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从键侦听器 l 中移除旧的键侦听器，并返回得到的多路广播侦听器。
remove(MouseListener, MouseListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从鼠标侦听器 l 中移除旧的鼠标侦听器，并返回得到的多路广播侦听器。
remove(MouseMotionListener, MouseMotionListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从鼠标移动侦听器 l 中移除旧的鼠标移动侦听器，并返回得到的多路广播侦听器。
remove(WindowListener, WindowListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从窗口侦听器 l 中移除旧的窗口侦听器，并返回得到的多路广播侦听器。
remove(WindowStateListener, WindowStateListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从窗口状态侦听器 l 中移除旧的窗口状态侦听器，并返回得到的多路广播侦听器。
remove(WindowFocusListener, WindowFocusListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从窗口焦点侦听器 l 中移除旧的窗口焦点侦听器，并返回得到的多路广播侦听器。
remove(ActionListener, ActionListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从操作侦听器 l 中移除旧的操作侦听器，并返回得到的多路广播侦听器。
remove(ItemListener, ItemListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从项侦听器 l 中移除旧的项侦听器，并返回得到的多路广播侦听器。
remove(AdjustmentListener, AdjustmentListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从调整侦听器 l 中移除旧的调整侦听器，并返回得到的多路广播侦听器。
remove(TextListener, TextListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
remove(InputMethodListener, InputMethodListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从输入方法侦听器 l 中移除旧的输入方法侦听器，并返回得到的多路广播侦听器。
remove(HierarchyListener, HierarchyListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从层次结构侦听器 l 中移除旧的层次结构侦听器，并返回得到的多路广播侦听器。
remove(HierarchyBoundsListener, HierarchyBoundsListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从层次结构边界侦听器 l 中移除旧的层次结构边界侦听器，并返回得到的多路广播侦听器。
remove(MouseWheelListener, MouseWheelListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
从鼠标滚轮侦听器 l 中移除旧的鼠标滚轮侦听器，并返回得到的多路广播侦听器。
remove(String) - 类 java.awt.Choice 中的方法
移除 Choice 菜单中第一个出现的 item。
remove(int) - 类 java.awt.Choice 中的方法
从选择菜单的指定位置上移除一个项。
remove(MenuComponent) - 类 java.awt.Component 中的方法
从组件移除指定的弹出菜单。
remove(int) - 类 java.awt.Container 中的方法
从此容器中移除 index 指定的组件。
remove(Component) - 类 java.awt.Container 中的方法
从此容器中移除指定组件。
remove(MenuComponent) - 类 java.awt.Frame 中的方法
从此窗体移除指定的菜单栏。
remove(String) - 类 java.awt.List 中的方法
从列表中移除项的第一次出现。
remove(int) - 类 java.awt.List 中的方法
从此滚动列表中移除指定位置处的项。
remove(int) - 类 java.awt.Menu 中的方法
从此菜单移除指定索引处的菜单项。
remove(MenuComponent) - 类 java.awt.Menu 中的方法
从此菜单移除指定的菜单项。
remove(int) - 类 java.awt.MenuBar 中的方法
从此菜单栏移除指定索引处的菜单。
remove(MenuComponent) - 类 java.awt.MenuBar 中的方法
从此菜单栏移除指定的菜单组件。
remove(MenuComponent) - 接口 java.awt.MenuContainer 中的方法
remove(Object) - 类 java.awt.RenderingHints 中的方法
从此 RenderingHints 对象中移除键和它所对应的值。
remove(TrayIcon) - 类 java.awt.SystemTray 中的方法
从 SystemTray 中移除指定的 TrayIcon。
remove() - 类 java.beans.beancontext.BeanContextSupport.BCSIterator 中的方法
remove(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
从此 BeanContext 中移除一个子对象。
remove(Object, boolean) - 类 java.beans.beancontext.BeanContextSupport 中的方法
当由意外的 setBeanContext 或 remove() 调用导致移除时使用的内部移除方法。
remove(Object) - 类 java.beans.Encoder 中的方法
移除此实例的条目，返回旧条目。
remove(long) - 类 java.lang.ref.ReferenceQueue 中的方法
移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。
remove() - 类 java.lang.ref.ReferenceQueue 中的方法
移除此队列中的下一个引用对象，阻塞到某个对象变得可用为止。
remove() - 类 java.lang.ThreadLocal 中的方法
移除此线程局部变量当前线程的值。
remove(URI, HttpCookie) - 接口 java.net.CookieStore 中的方法
从存储区中移除 cookie。
remove(Object) - 类 java.security.Provider 中的方法
移除 key 属性（及其相应的 value）。
remove(Object) - 类 java.util.AbstractCollection 中的方法
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。
remove(int) - 类 java.util.AbstractList 中的方法
移除列表中指定位置的元素（可选操作）。
remove(Object) - 类 java.util.AbstractMap 中的方法
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。
remove() - 类 java.util.AbstractQueue 中的方法
获取并移除此队列的头。
remove(int) - 类 java.util.AbstractSequentialList 中的方法
移除此列表中指定位置上的元素（可选操作）。
remove() - 类 java.util.ArrayDeque 中的方法
获取并移除此双端队列所表示的队列的头。
remove(Object) - 类 java.util.ArrayDeque 中的方法
从此双端队列中移除指定元素的单个实例。
remove(int) - 类 java.util.ArrayList 中的方法
移除此列表中指定位置上的元素。
remove(Object) - 类 java.util.ArrayList 中的方法
移除此列表中首次出现的指定元素（如果存在）。
remove(Object) - 接口 java.util.Collection 中的方法
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。
remove(Object) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
从此队列中移除指定元素的单个实例（如果存在）。
remove() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）。
remove(Object) - 接口 java.util.concurrent.BlockingDeque 中的方法
从此双端队列移除第一次出现的指定元素。
remove(Object) - 接口 java.util.concurrent.BlockingQueue 中的方法
从此队列中移除指定元素的单个实例（如果存在）。
remove(Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
从此映射中移除键（及其相应的值）。
remove(Object, Object) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
只有目前将键的条目映射到给定值时，才移除该键的条目。
remove(Object) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
从队列中移除指定元素的单个实例（如果存在）。
remove(Object, Object) - 接口 java.util.concurrent.ConcurrentMap 中的方法
只有目前将键的条目映射到给定值时，才移除该键的条目。
remove(Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
从此映射中移除指定键的映射关系（如果存在）。
remove(Object, Object) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
只有目前将键的条目映射到给定值时，才移除该键的条目。
remove(Object) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
如果此 set 中存在指定的元素，则将其移除。
remove(int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
移除此列表指定位置上的元素。
remove(Object) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
从此列表移除第一次出现的指定元素（如果存在）。
remove(Object) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
如果指定元素存在于此 set 中，则将其移除。
remove(Object) - 类 java.util.concurrent.DelayQueue 中的方法
从此队列中移除指定元素的单个实例（如果存在），无论它是否到期。
remove() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部。
remove(Object) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
从此双端队列移除第一次出现的指定元素。
remove(Object) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
从此队列移除指定元素的单个实例（如果存在）。
remove(Object) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
从队列中移除指定元素的单个实例（如果存在）。
remove(Runnable) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
remove(Object) - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 false。
remove(Runnable) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
从执行程序的内部队列中移除此任务（如果存在），从而如果尚未开始，则其不再运行。
remove() - 接口 java.util.Deque 中的方法
获取并移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）。
remove(Object) - 接口 java.util.Deque 中的方法
从此双端队列中移除第一次出现的指定元素。
remove(Object) - 类 java.util.Dictionary 中的方法
从此 dictionary 中移除 key （及其相应的 value）。
remove(Object) - 类 java.util.EnumMap 中的方法
从此映射中移除该键的映射关系（如果存在）。
remove(Object) - 类 java.util.HashMap 中的方法
从此映射中移除指定键的映射关系（如果存在）。
remove(Object) - 类 java.util.HashSet 中的方法
如果指定元素存在于此 set 中，则将其移除。
remove(Object) - 类 java.util.Hashtable 中的方法
从哈希表中移除该键及其相应的值。
remove(Object) - 类 java.util.IdentityHashMap 中的方法
移除映射中此键的映射关系（如果存在的话）。
remove() - 接口 java.util.Iterator 中的方法
从迭代器指向的 collection 中移除迭代器返回的最后一个元素（可选操作）。
remove(Object) - 类 java.util.jar.Attributes 中的方法
从此 Map 中移除具有指定名称（键）的属性。
remove(Object) - 类 java.util.LinkedList 中的方法
从此列表中移除首次出现的指定元素（如果存在）。
remove(int) - 类 java.util.LinkedList 中的方法
移除此列表中指定位置处的元素。
remove() - 类 java.util.LinkedList 中的方法
获取并移除此列表的头（第一个元素）。
remove(Object) - 接口 java.util.List 中的方法
从此列表中移除第一次出现的指定元素（如果存在）（可选操作）。
remove(int) - 接口 java.util.List 中的方法
移除列表中指定位置的元素（可选操作）。
remove() - 接口 java.util.ListIterator 中的方法
从列表中移除由 next 或 previous 返回的最后一个元素（可选操作）。
remove(Object) - 接口 java.util.Map 中的方法
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。
remove(String) - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.remove(String) 中的规范实现 remove(String) 方法。
remove(String) - 类 java.util.prefs.Preferences 中的方法
移除与此首选项节点中与指定键相关联的值（如果有）。
remove(Object) - 类 java.util.PriorityQueue 中的方法
从此队列中移除指定元素的单个实例（如果存在）。
remove() - 接口 java.util.Queue 中的方法
获取并移除此队列的头。
remove() - 类 java.util.Scanner 中的方法
Iterator 的这种实现不支持移除操作。
remove(Object) - 接口 java.util.Set 中的方法
如果 set 中存在指定的元素，则将其移除（可选操作）。
remove(Object) - 类 java.util.TreeMap 中的方法
如果此 TreeMap 中存在该键的映射关系，则将其删除。
remove(Object) - 类 java.util.TreeSet 中的方法
将指定的元素从 set 中移除（如果该元素存在于此 set 中）。
remove(Object) - 类 java.util.Vector 中的方法
移除此向量中指定元素的第一个匹配项，如果向量不包含该元素，则元素保持不变。
remove(int) - 类 java.util.Vector 中的方法
移除此向量中指定位置的元素。
remove(Object) - 类 java.util.WeakHashMap 中的方法
从此弱哈希映射中移除键的映射关系（如果存在）。
remove(AccessibleRelation) - 类 javax.accessibility.AccessibleRelationSet 中的方法
从当前关系集中移除一个关系。
remove(AccessibleState) - 类 javax.accessibility.AccessibleStateSet 中的方法
从当前状态集中移除一个状态。
remove(String) - 类 javax.activation.MimeTypeParameterList 中的方法
移除与给定名称关联的所有值。
remove(Object[]) - 接口 javax.management.openmbean.TabularData 中的方法
从此 TabularData 实例中移除其索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
remove(Object) - 类 javax.management.openmbean.TabularDataSupport 中的方法
此方法仅调用 remove((Object[]) key)。
remove(Object[]) - 类 javax.management.openmbean.TabularDataSupport 中的方法
从此 TabularData 实例中移除索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
remove(int) - 类 javax.naming.CompositeName 中的方法
从此复合名称中删除一个组件。
remove(int) - 类 javax.naming.CompoundName 中的方法
从此组合名称中删除一个组件。
remove(Object) - 接口 javax.naming.directory.Attribute 中的方法
从属性中移除指定值。
remove(int) - 接口 javax.naming.directory.Attribute 中的方法
从属性值的有序列表中移除属性值。
remove(String) - 接口 javax.naming.directory.Attributes 中的方法
从属性集中移除属性 id 为 'attrID' 的属性。
remove(Object) - 类 javax.naming.directory.BasicAttribute 中的方法
从此属性中移除指定值。
remove(int) - 类 javax.naming.directory.BasicAttribute 中的方法
remove(String) - 类 javax.naming.directory.BasicAttributes 中的方法
remove(int) - 类 javax.naming.ldap.LdapName 中的方法
从此 LDAP 名称中移除一个组件。
remove(int) - 接口 javax.naming.Name 中的方法
从此名称中移除一个组件。
remove(int) - 类 javax.naming.Reference 中的方法
从地址列表中删除索引 posn 处的地址。
remove(Class<?>) - 接口 javax.print.attribute.AttributeSet 中的方法
从此属性集移除此类别的任何属性（如果存在）。
remove(Attribute) - 接口 javax.print.attribute.AttributeSet 中的方法
从此属性集移除指定的属性（如果存在）。
remove(Class<?>) - 类 javax.print.attribute.HashAttributeSet 中的方法
从此属性集移除此类别的任何属性（如果存在）。
remove(Attribute) - 类 javax.print.attribute.HashAttributeSet 中的方法
从此属性集移除指定的属性（如果存在）。
remove(Object) - 接口 javax.script.Bindings 中的方法
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。
remove(Object) - 类 javax.script.SimpleBindings 中的方法
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。
remove(MidiEvent) - 类 javax.sound.midi.Track 中的方法
从音轨中移除指定的事件。
remove(Object) - 类 javax.swing.ActionMap 中的方法
从此 ActionMap 中移除 key 的绑定。
remove(AbstractButton) - 类 javax.swing.ButtonGroup 中的方法
从组中移除按钮。
remove(KeyStroke) - 类 javax.swing.ComponentInputMap 中的方法
从此对象中移除 key 的绑定。
remove(int) - 类 javax.swing.DefaultListModel 中的方法
移除此列表中指定位置处的元素。
REMOVE - 类 javax.swing.event.DocumentEvent.EventType 中的静态变量
移除类型。
remove(Class<T>, T) - 类 javax.swing.event.EventListenerList 中的方法
将侦听器作为指定类型的侦听器进行移除。
remove(KeyStroke) - 类 javax.swing.InputMap 中的方法
从此 InputMap 中移除 key 的绑定。
remove(Component) - 类 javax.swing.JApplet 中的方法
从容器中移除指定的组件。
remove(int) - 类 javax.swing.JDesktopPane 中的方法
从此窗格中移除已索引的组件。
remove(Component) - 类 javax.swing.JDialog 中的方法
从该容器中移除指定组件。
remove(Component) - 类 javax.swing.JFrame 中的方法
从该容器中移除指定组件。
remove(Component) - 类 javax.swing.JInternalFrame 中的方法
从此容器中移除指定组件。
remove(int) - 类 javax.swing.JLayeredPane 中的方法
从此窗格中移除已索引的组件。
remove(JMenuItem) - 类 javax.swing.JMenu 中的方法
从此菜单移除指定的菜单项。
remove(int) - 类 javax.swing.JMenu 中的方法
从此菜单移除指定索引处的菜单项。
remove(Component) - 类 javax.swing.JMenu 中的方法
从此菜单移除组件 c。
remove(int) - 类 javax.swing.JPopupMenu 中的方法
从此弹出菜单移除指定索引处的组件。
remove(Component) - 类 javax.swing.JSplitPane 中的方法
移除窗格中的子组件 component。
remove(int) - 类 javax.swing.JSplitPane 中的方法
移除指定索引处的 Component。
remove(Component) - 类 javax.swing.JTabbedPane 中的方法
从 JTabbedPane 中移除指定 Component。
remove(int) - 类 javax.swing.JTabbedPane 中的方法
移除对应于指定索引的选项卡和组件。
remove(Component) - 类 javax.swing.JViewport 中的方法
移除 Viewport 的一个轻量子对象。
remove(Component) - 类 javax.swing.JWindow 中的方法
从该容器中移除指定组件。
remove(int, int) - 接口 javax.swing.text.AbstractDocument.Content 中的方法
移除该序列的某一部分。
remove(int, int) - 类 javax.swing.text.AbstractDocument 中的方法
从文档中移除某些内容。
remove(int, int, AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
移除内容。
remove(int, int) - 接口 javax.swing.text.Document 中的方法
移除文档的部分内容。
remove(int, int) - 类 javax.swing.text.DocumentFilter.FilterBypass 中的方法
移除指定的文本区域，绕过 DocumentFilter。
remove(DocumentFilter.FilterBypass, int, int) - 类 javax.swing.text.DocumentFilter 中的方法
移除指定 Document 中的指定区域之前调用。
remove(int, int) - 类 javax.swing.text.GapContent 中的方法
移除部分内容。
remove(int, int) - 类 javax.swing.text.StringContent 中的方法
移除部分内容，其中 where ＋ nitems 必须 < length()。
remove(int) - 类 javax.swing.text.View 中的方法
移除给定位置处的一个子级。
remove(int) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
从此节点的子节点中移除指定索引处的子节点，并将该节点的父节点设置为 null。
remove(MutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
通过向其提供一个 null 父节点，从此节点的子节点数组移除 aChild。
remove(int) - 接口 javax.swing.tree.MutableTreeNode 中的方法
从接收者移除 index 位置的子节点。
remove(MutableTreeNode) - 接口 javax.swing.tree.MutableTreeNode 中的方法
从接收者移除 node。
remove() - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
remove(int) - 类 org.omg.CORBA.ContextList 中的方法
移除给定索引处的 String 对象。
remove(int) - 类 org.omg.CORBA.ExceptionList 中的方法
移除给定索引处的 TypeCode 对象。
remove(int) - 类 org.omg.CORBA.NVList 中的方法
移除位于给定索引处的 NamedValue 对象。
REMOVE_ATTRIBUTE - 接口 javax.naming.directory.DirContext 中的静态变量
此常量指定从属性中删除指定的属性值。
removeAccessibleSelection(int) - 类 java.awt.List.AccessibleAWTList 中的方法
从对象选择中移除对象中的指定选项。
removeAccessibleSelection(int) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
从对象的选择中移除该对象的指定子对象。
removeAccessibleSelection(int) - 接口 javax.accessibility.AccessibleSelection 中的方法
从对象的选项中移除该对象的指定子对象。
removeAccessibleSelection(int) - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
从对象的选择中移除对象的指定子对象。
removeAccessibleSelection(int) - 类 javax.swing.JList.AccessibleJList 中的方法
从对象选择中移除对象中的指定选项。
removeAccessibleSelection(int) - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
从选择中移除第 n 个项。
removeAccessibleSelection(int) - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
从对象选择中移除对象中的第 n 个选项。
removeAccessibleSelection(int) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
removeAccessibleSelection(int) - 类 javax.swing.JTable.AccessibleJTable 中的方法
从对象的选择中移除该对象的指定子对象。
removeAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
将该对象中指定选择的项从该对象的选择中移除。
removeAccessibleSelection(int) - 类 javax.swing.JTree.AccessibleJTree 中的方法
将对象中指定选择项从对象的选择中移除。
removeActionListener(ActionListener) - 类 java.awt.Button 中的方法
移除指定的动作侦听器，以便它不再接收发自此按钮的动作事件。
removeActionListener(ActionListener) - 类 java.awt.List 中的方法
移除指定的动作侦听器，以便不再从此列表接收动作事件。
removeActionListener(ActionListener) - 类 java.awt.MenuItem 中的方法
移除指定的动作侦听器，使其不再从此菜单项中接收动作事件。
removeActionListener(ActionListener) - 类 java.awt.TextField 中的方法
移除指定的操作侦听器，不再从此文本字段接收操作事件。
removeActionListener(ActionListener) - 类 java.awt.TrayIcon 中的方法
移除指定的动作侦听器。
removeActionListener(ActionListener) - 类 javax.swing.AbstractButton 中的方法
从按钮中移除一个 ActionListener。
removeActionListener(ActionListener) - 接口 javax.swing.ButtonModel 中的方法
从模型中移除一个 ActionListener。
removeActionListener(ActionListener) - 接口 javax.swing.ComboBoxEditor 中的方法
移除一个 ActionListener
removeActionListener(ActionListener) - 类 javax.swing.DefaultButtonModel 中的方法
从模型中移除一个 ActionListener。
removeActionListener(ActionListener) - 类 javax.swing.JComboBox 中的方法
移除 ActionListener。
removeActionListener(ActionListener) - 类 javax.swing.JFileChooser 中的方法
从文件选择器中移除一个 ActionListener。
removeActionListener(ActionListener) - 类 javax.swing.JTextField 中的方法
移除指定的操作侦听器，以便不再从此文本字段接收操作事件。
removeActionListener(ActionListener) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
removeActionListener(ActionListener) - 类 javax.swing.Timer 中的方法
从 Timer 移除指定的动作侦听器。
removeAdjustmentListener(AdjustmentListener) - 接口 java.awt.Adjustable 中的方法
移除一个调整侦听器。
removeAdjustmentListener(AdjustmentListener) - 类 java.awt.Scrollbar 中的方法
移除指定的调整侦听器，不再接收发自此滚动条的 AdjustmentEvent 实例。
removeAdjustmentListener(AdjustmentListener) - 类 java.awt.ScrollPaneAdjustable 中的方法
移除指定的调整侦听器，不再接收发自此 ScrollPaneAdjustable 的调整事件。
removeAdjustmentListener(AdjustmentListener) - 类 javax.swing.JScrollBar 中的方法
移除一个 AdjustmentEvent 侦听器。
removeAll() - 类 java.awt.Choice 中的方法
从选择菜单中移除所有的项。
removeAll() - 类 java.awt.Container 中的方法
从此容器中移除所有组件。
removeAll() - 类 java.awt.List 中的方法
从此列表中移除所有项。
removeAll() - 类 java.awt.Menu 中的方法
从此菜单移除所有项。
removeAll(Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
移除所有指定 Children（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
removeAll() - 接口 java.net.CookieStore 中的方法
移除此 cookie 存储区中的所有 cookie。
removeAll(Collection<?>) - 类 java.util.AbstractCollection 中的方法
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
removeAll(Collection<?>) - 类 java.util.AbstractSet 中的方法
从此 set 中移除包含在指定 collection 中的所有元素（可选操作）。
removeAll(Collection<?>) - 接口 java.util.Collection 中的方法
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
removeAll(Collection<?>) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
从此 set 中移除包含在指定 collection 中的所有元素。
removeAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
从此列表移除所有包含在指定 collection 中的元素。
removeAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
移除此 set 中包含在指定 collection 中的所有元素。
removeAll(Collection<?>) - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 false。
removeAll(Collection<?>) - 接口 java.util.List 中的方法
从列表中移除指定 collection 中包含的其所有元素（可选操作）。
removeAll(Collection<?>) - 接口 java.util.Set 中的方法
移除 set 中那些包含在指定 collection 中的元素（可选操作）。
removeAll(Collection<?>) - 类 java.util.Vector 中的方法
从此向量中移除包含在指定 Collection 中的所有元素。
removeAll() - 类 javax.swing.JDesktopPane 中的方法
从此容器中移除所有组件。
removeAll() - 类 javax.swing.JLayeredPane 中的方法
从此容器中移除所有组件。
removeAll() - 类 javax.swing.JMenu 中的方法
从此菜单移除所有菜单项。
removeAll() - 类 javax.swing.JSplitPane 中的方法
从分隔窗格中移除所有子组件。
removeAll() - 类 javax.swing.JTabbedPane 中的方法
从 tabbedpane 中移除所有选项卡及其相应组件。
removeAll() - 类 javax.swing.text.View 中的方法
移除所有子级。
removeAllAttachments() - 类 javax.xml.soap.SOAPMessage 中的方法
移除所有已经添加到此 SOAPMessage 对象的 AttachmentPart 对象。
removeAllChildren() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
通过将其父节点设置为 null，移除此节点的所有子节点。
removeAllElements() - 类 java.util.Vector 中的方法
从此向量中移除全部组件，并将其大小设置为零。
removeAllElements() - 类 javax.swing.DefaultComboBoxModel 中的方法
清空列表。
removeAllElements() - 类 javax.swing.DefaultListModel 中的方法
从此列表中移除所有组件，并将它们的大小设置为零。
removeAllFaultSubcodes() - 接口 javax.xml.soap.SOAPFault 中的方法
移除此 SOAPFault 可能包含的任何 Subcode。
removeAllHeaders() - 类 javax.xml.soap.MimeHeaders 中的方法
从此 MimeHeaders 对象中移除所有头条目。
removeAllHighlights() - 类 javax.swing.text.DefaultHighlighter 中的方法
移除所有的高亮显示。
removeAllHighlights() - 接口 javax.swing.text.Highlighter 中的方法
移除此轮廓色负责的所有高亮显示。
removeAllIIOReadProgressListeners() - 类 javax.imageio.ImageReader 中的方法
移除所有当前已注册的 IIOReadProgressListener 对象。
removeAllIIOReadUpdateListeners() - 类 javax.imageio.ImageReader 中的方法
移除所有当前已注册的 IIOReadUpdateListener 对象。
removeAllIIOReadWarningListeners() - 类 javax.imageio.ImageReader 中的方法
移除所有当前已注册的 IIOReadWarningListener 对象。
removeAllIIOWriteProgressListeners() - 类 javax.imageio.ImageWriter 中的方法
移除所有当前已注册的 IIOWriteProgressListener 对象。
removeAllIIOWriteWarningListeners() - 类 javax.imageio.ImageWriter 中的方法
移除所有当前已注册的 IIOWriteWarningListener 对象。
removeAllItems() - 类 javax.swing.JComboBox 中的方法
从项列表中移除所有项。
removeAllMimeHeaders() - 类 javax.xml.soap.AttachmentPart 中的方法
移除所有 MIME 头条目。
removeAllMimeHeaders() - 类 javax.xml.soap.SOAPPart 中的方法
移除此 SOAPEnvelope 对象的所有 MimeHeader 对象。
removeAllNotifications() - 类 javax.management.timer.Timer 中的方法
从通知列表中删除所有计时器通知并重置用来更新计时器通知标识符的计数器。
removeAllNotifications() - 接口 javax.management.timer.TimerMBean 中的方法
从通知列表中删除所有的计时器通知并重置用来更新计时器通知标识符的计数器。
removeAncestorListener(AncestorListener) - 类 javax.swing.JComponent 中的方法
注销 listener，使其不再接收 AncestorEvent。
removeAttachments(MimeHeaders) - 类 javax.xml.soap.SOAPMessage 中的方法
移除所有头条目匹配指定头的 AttachmentPart 对象。
removeAttribute(String, String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
从以前定义的元素中移除属性。
removeAttribute(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
removeAttribute(String, int) - 接口 javax.script.ScriptContext 中的方法
移除给定范围中的某一属性。
removeAttribute(String, int) - 类 javax.script.SimpleScriptContext 中的方法
移除给定范围中的某一属性。
removeAttribute(Object) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
从该集合中移除一个属性。
removeAttribute(AttributeSet, Object) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
从属性集中移除某个属性。
removeAttribute(AttributeSet, Object) - 类 javax.swing.text.html.StyleSheet 中的方法
从集合中移除属性。
removeAttribute(Object) - 接口 javax.swing.text.MutableAttributeSet 中的方法
移除具有给定 name 的属性。
removeAttribute(Object) - 类 javax.swing.text.SimpleAttributeSet 中的方法
从列表中移除属性。
removeAttribute(Object) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
从集合中移除属性。
removeAttribute(AttributeSet, Object) - 类 javax.swing.text.StyleContext 中的方法
从集合中移除一个属性。
removeAttribute(Name) - 接口 javax.xml.soap.SOAPElement 中的方法
移除带有指定名称的属性。
removeAttribute(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
移除带有指定 qname 的属性。
removeAttribute(String) - 接口 org.w3c.dom.Element 中的方法
通过名称移除一个属性。
removeAttribute(int) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
removeAttribute(String) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 从列表移除属性。
removeAttribute(int) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
从列表移除属性。
removeAttributeChangeNotificationListener(NotificationListener, String) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
removeAttributeChangeNotificationListener(NotificationListener, String) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
removeAttributeNode(Attr) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
removeAttributeNode(Attr) - 接口 org.w3c.dom.Element 中的方法
移除指定的属性节点。
removeAttributeNS(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 removeAttribute(localName)。
removeAttributeNS(String, String) - 接口 org.w3c.dom.Element 中的方法
通过本地名称和名称空间 URI 移除属性值。
removeAttributes(Enumeration<?>) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
移除该元素的属性集合。
removeAttributes(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
移除该元素的属性集合。
removeAttributes(AttributeSet, Enumeration<?>) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
移除元素的一组属性。
removeAttributes(AttributeSet, AttributeSet) - 接口 javax.swing.text.AbstractDocument.AttributeContext 中的方法
移除元素的一组属性。
removeAttributes(AttributeSet, Enumeration<?>) - 类 javax.swing.text.html.StyleSheet 中的方法
移除元素的属性集。
removeAttributes(AttributeSet, AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
移除属性集。
removeAttributes(Enumeration<?>) - 接口 javax.swing.text.MutableAttributeSet 中的方法
移除具有给定 name 的属性集。
removeAttributes(AttributeSet) - 接口 javax.swing.text.MutableAttributeSet 中的方法
移除具有给定 name 的属性集。
removeAttributes(Enumeration<?>) - 类 javax.swing.text.SimpleAttributeSet 中的方法
从列表中移除属性集。
removeAttributes(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
从列表中移除属性集。
removeAttributes(Enumeration<?>) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
移除元素的属性集。
removeAttributes(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
移除元素的属性集。
removeAttributes(AttributeSet, Enumeration<?>) - 类 javax.swing.text.StyleContext 中的方法
移除元素的一个属性集。
removeAttributes(AttributeSet, AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
移除元素的属性集。
removeAuxiliaryLookAndFeel(LookAndFeel) - 类 javax.swing.UIManager 中的静态方法
从辅助外观列表移除一个 LookAndFeel。
removeAWTEventListener(AWTEventListener) - 类 java.awt.Toolkit 中的方法
从正接收的指派 AWTEvent 中移除一个 AWTEventListener。
removeBeanContextMembershipListener(BeanContextMembershipListener) - 接口 java.beans.beancontext.BeanContext 中的方法
移除指定的 BeanContextMembershipListener，以便在添加或移除子 Component 时不再接收 BeanContextMembershipEvent。
removeBeanContextMembershipListener(BeanContextMembershipListener) - 类 java.beans.beancontext.BeanContextSupport 中的方法
移除一个 BeanContextMembershipListener。
removeBeanContextServicesListener(BeanContextServicesListener) - 接口 java.beans.beancontext.BeanContextServices 中的方法
从此 BeanContext 中移除一个 BeanContextServicesListener
removeBeanContextServicesListener(BeanContextServicesListener) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
移除一个 BeanContextServicesListener。
removeBindings() - 接口 javax.swing.text.Keymap 中的方法
从 keymap 移除所有绑定。
removeCaretListener(CaretListener) - 类 javax.swing.text.JTextComponent 中的方法
移除插入符侦听器。
removeCellEditorListener(CellEditorListener) - 类 javax.swing.AbstractCellEditor 中的方法
从侦听器列表中移除一个 CellEditorListener。
removeCellEditorListener(CellEditorListener) - 接口 javax.swing.CellEditor 中的方法
从被通知的列表中移除一个侦听器
removeCellEditorListener(CellEditorListener) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
移除以前添加的 CellEditorListener。
removeCertificate(Certificate) - 类 java.security.Identity 中的方法
已过时。 从此 Identity 中移除证书。
removeChangeListener(ChangeListener) - 类 javax.swing.AbstractButton 中的方法
从按钮中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.AbstractSpinnerModel 中的方法
从模型的侦听器列表中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.BoundedRangeModel 中的方法
从模型的侦听器列表中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.ButtonModel 中的方法
从模型中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.colorchooser.ColorSelectionModel 中的方法
从模型中移除作为更改侦听器的 listener。
removeChangeListener(ChangeListener) - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
从模型中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.DefaultButtonModel 中的方法
从模型中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.DefaultSingleSelectionModel 中的方法
从按钮中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JProgressBar 中的方法
从进度条移除 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JSlider 中的方法
从滑块中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JSpinner 中的方法
从此 spinne 中移除 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JTabbedPane 中的方法
从此选项卡窗格中移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.JViewport 中的方法
从每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表中移除 ChangeListener。
removeChangeListener(ChangeListener) - 类 javax.swing.MenuSelectionManager 中的方法
从按钮中移除 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.SingleSelectionModel 中的方法
从模型中移除作为更改侦听器的 listener。
removeChangeListener(ChangeListener) - 接口 javax.swing.SpinnerModel 中的方法
从该模型的侦听器列表移除一个 ChangeListener。
removeChangeListener(ChangeListener) - 接口 javax.swing.text.Caret 中的方法
移除跟踪插入符位置更改的侦听器。
removeChangeListener(ChangeListener) - 类 javax.swing.text.DefaultCaret 中的方法
移除跟踪位置更改的侦听器。
removeChangeListener(ChangeListener) - 接口 javax.swing.text.Style 中的方法
移除跟踪属性更改的侦听器。
removeChangeListener(ChangeListener) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
移除更改侦听器。
removeChangeListener(ChangeListener) - 类 javax.swing.text.StyleContext 中的方法
移除一个跟踪正被添加或移除样式的侦听器。
removeChild(Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
removeChild(Node) - 接口 org.w3c.dom.Node 中的方法
从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
removeChoosableFileFilter(FileFilter) - 类 javax.swing.JFileChooser 中的方法
从用户可选择的文件过滤器列表中移除一个过滤器。
removeChooserPanel(AbstractColorChooserPanel) - 类 javax.swing.JColorChooser 中的方法
移除指定的 Color Panel。
removeColumn(TableColumn) - 类 javax.swing.JTable 中的方法
从此 JTable 的列数组中移除 aColumn。
removeColumn(TableColumn) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
从 tableColumns 数组删除 column。
removeColumn(TableColumn) - 接口 javax.swing.table.TableColumnModel 中的方法
从 tableColumns 数组中删除 TableColumn column。
removeColumnModelListener(TableColumnModelListener) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
移除表列模型事件的侦听器。
removeColumnModelListener(TableColumnModelListener) - 接口 javax.swing.table.TableColumnModel 中的方法
移除表列模型事件的侦听器。
removeColumnSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
取消选中从 index0 到 index1 之间（包含两端）的列。
removeComponentListener(ComponentListener) - 类 java.awt.Component 中的方法
移除指定的组件侦听器，以便它不再接收发自此组件的组件事件。
removeConnectionEventListener(ConnectionEventListener) - 接口 javax.sql.PooledConnection 中的方法
从在此 PooledConnection 对象上发生事件时得到通知的组件所组成的列表中移除给定的事件侦听器。
removeConnectionNotificationListener(NotificationListener) - 接口 javax.management.remote.JMXConnector 中的方法
将一个用于接收状态更改通知的侦听器从列表中移除。
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - 接口 javax.management.remote.JMXConnector 中的方法
将一个用于接收状态更改通知的侦听器从列表中移除。
removeConnectionNotificationListener(NotificationListener) - 类 javax.management.remote.rmi.RMIConnector 中的方法
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.remote.rmi.RMIConnector 中的方法
removeConsumer(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
removeConsumer(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
从目前已注册以接收图像数据的使用者列表中移除指定的 ImageConsumer 对象。
removeConsumer(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
removeConsumer(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
从对此图像的数据感兴趣的使用者列表中删除一个 ImageConsumer。
removeContainerListener(ContainerListener) - 类 java.awt.Container 中的方法
移除指定容器的侦听器，从而不再接收来自此容器的容器事件。
removeContents() - 接口 javax.xml.soap.SOAPElement 中的方法
分离此 SOAPElement 的所有子级。
removeControlButtons() - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
removeControllerEventListener(ControllerEventListener, int[]) - 接口 javax.sound.midi.Sequencer 中的方法
移除侦听一类或多类控件事件的控件事件侦听器。
removeDescendantSelectedPaths(TreePath, boolean) - 类 javax.swing.JTree 中的方法
移除选择中的任何路径（path 的子路径）。
removeDescendantToggledPaths(Enumeration<TreePath>) - 类 javax.swing.JTree 中的方法
移除已展开的 toRemove 中 TreePath 的所有子路径。
removeDocumentListener(DocumentListener) - 类 javax.swing.text.AbstractDocument 中的方法
移除文档侦听器。
removeDocumentListener(DocumentListener) - 类 javax.swing.text.DefaultStyledDocument 中的方法
移除文档侦听器。
removeDocumentListener(DocumentListener) - 接口 javax.swing.text.Document 中的方法
将给定的观察者从通知列表中撤消注册，这样就不再接收改动更新。
removeDragGestureListener(DragGestureListener) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
取消注册当前的 DragGestureListener
removeDragSourceListener(DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
从此 DragSource 移除指定的 DragSourceListener。
removeDragSourceListener(DragSourceListener) - 类 java.awt.dnd.DragSourceContext 中的方法
从此 DragSourceContext 移除指定的 DragSourceListener。
removeDragSourceMotionListener(DragSourceMotionListener) - 类 java.awt.dnd.DragSource 中的方法
从此 DragSource 移除指定的 DragSourceMotionListener。
removeDropTargetListener(DropTargetListener) - 类 java.awt.dnd.DropTarget 中的方法
移除当前的 DropTargetListener (UNICAST SOURCE)。
removeEditor() - 类 javax.swing.JTable 中的方法
丢弃编辑器对象并释放它用于单元格呈现的资源。
removeEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此公共方法是特定于实现的，应该为私有，不要调用或重写。
removeEldestEntry(Map.Entry<K, V>) - 类 java.util.LinkedHashMap 中的方法
如果此映射移除其最旧的条目，则返回 true。
removeElement(Object) - 类 java.util.Vector 中的方法
从此向量中移除变量的第一个（索引最小的）匹配项。
removeElement(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
从格式中移除元素。
removeElement(Object) - 类 javax.swing.DefaultComboBoxModel 中的方法
removeElement(Object) - 类 javax.swing.DefaultListModel 中的方法
从此列表中移除参数的第一个（索引最小的）匹配项。
removeElement(Object) - 接口 javax.swing.MutableComboBoxModel 中的方法
从模型中移除项。
removeElementAt(int) - 类 java.util.Vector 中的方法
删除指定索引处的组件。
removeElementAt(int) - 类 javax.swing.DefaultComboBoxModel 中的方法
removeElementAt(int) - 类 javax.swing.DefaultListModel 中的方法
删除指定索引处的组件。
removeElementAt(int) - 接口 javax.swing.MutableComboBoxModel 中的方法
在指定索引处移除项。
removeEntries(int, int) - 类 javax.swing.SizeSequence 中的方法
从此 SizeSequence 中移除一组相邻的条目。
removeEntry(Principal, AclEntry) - 接口 java.security.acl.Acl 中的方法
从此 ACL 中移除 ACL 项。
removeEventListener(String, EventListener, boolean) - 接口 org.w3c.dom.events.EventTarget 中的方法
此方法允许从事件目标移除事件侦听器。
removeField(String) - 接口 javax.management.Descriptor 中的方法
从该 descriptor 中删除字段。
removeField(String) - 类 javax.management.ImmutableDescriptor 中的方法
从描述符移除字段。
removeField(String) - 类 javax.management.modelmbean.DescriptorSupport 中的方法
removeFirst() - 类 java.util.ArrayDeque 中的方法
removeFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
removeFirst() - 接口 java.util.Deque 中的方法
获取并移除此双端队列第一个元素。
removeFirst() - 类 java.util.LinkedList 中的方法
移除并返回此列表的第一个元素。
removeFirstOccurrence(Object) - 类 java.util.ArrayDeque 中的方法
移除此双端队列中第一次出现的指定元素（当从头部到尾部遍历双端队列时）。
removeFirstOccurrence(Object) - 接口 java.util.concurrent.BlockingDeque 中的方法
从此双端队列移除第一次出现的指定元素。
removeFirstOccurrence(Object) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
removeFirstOccurrence(Object) - 接口 java.util.Deque 中的方法
从此双端队列移除第一次出现的指定元素。
removeFirstOccurrence(Object) - 类 java.util.LinkedList 中的方法
从此列表中移除第一次出现的指定元素（从头部到尾部遍历列表时）。
removeFlavorListener(FlavorListener) - 类 java.awt.datatransfer.Clipboard 中的方法
移除指定的 FlavorListener，使其不再从此 Clipboard 接收 FlavorEvent。
removeFocusListener(FocusListener) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。
removeFocusListener(FocusListener) - 类 java.awt.Component 中的方法
移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。
removeFocusListener(FocusListener) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
移除指定的焦点侦听器，使其不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
移除指定的焦点侦听器，使之不再从此组件接收焦点事件。
removeFocusListener(FocusListener) - 接口 javax.accessibility.AccessibleComponent 中的方法
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
removeFocusListener(FocusListener) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
removeFocusListener(FocusListener) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
removeFocusListener(FocusListener) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
removeFocusListener(FocusListener) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
removeFromEnvironment(String) - 接口 javax.naming.Context 中的方法
从此上下文的环境中移除一个环境属性。
removeFromEnvironment(String) - 类 javax.naming.InitialContext 中的方法
removeFromParent() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
通过向此节点提供一个 null 父节点，从树中移除以此节点为根的子树。
removeFromParent() - 接口 javax.swing.tree.MutableTreeNode 中的方法
从其父对象移除接收者。
removeFromSource() - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的方法
removeHandler(Handler) - 类 java.util.logging.Logger 中的方法
移除一个日志 Handler。
removeHandshakeCompletedListener(HandshakeCompletedListener) - 类 javax.net.ssl.SSLSocket 中的方法
移除一个以前注册的握手完成侦听器。
removeHeader(String) - 类 javax.xml.soap.MimeHeaders 中的方法
移除其名称与给定名称匹配的所有 MimeHeader 对象。
removeHierarchyBoundsListener(HierarchyBoundsListener) - 类 java.awt.Component 中的方法
移除指定的层次结构边界侦听器，以便它不再接收发自此组件的层次结构边界事件。
removeHierarchyListener(HierarchyListener) - 类 java.awt.Component 中的方法
移除指定的层次结构侦听器，以便它不再接收发自此组件的层次结构变化事件。
removeHighlight(Object) - 类 javax.swing.text.DefaultHighlighter 中的方法
从视图中移除高亮显示。
removeHighlight(Object) - 接口 javax.swing.text.Highlighter 中的方法
从视图中移除高亮显示。
removeHyperlinkListener(HyperlinkListener) - 类 javax.swing.JEditorPane 中的方法
移除超链接侦听器。
removeIconFor(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
在需要时移除 f 的 desktopIcon 的便捷方法。
removeIdentity(Identity) - 类 java.security.IdentityScope 中的方法
已过时。 从此身份作用作用域移除一个身份。
removeIIOReadProgressListener(IIOReadProgressListener) - 类 javax.imageio.ImageReader 中的方法
从已注册的进度侦听器列表中移除 IIOReadProgressListener。
removeIIOReadUpdateListener(IIOReadUpdateListener) - 类 javax.imageio.ImageReader 中的方法
从已注册的更新侦听器列表中移除 IIOReadUpdateListener。
removeIIOReadWarningListener(IIOReadWarningListener) - 类 javax.imageio.ImageReader 中的方法
从已注册的错误侦听器列表中移除 IIOReadWarningListener。
removeIIOWriteProgressListener(IIOWriteProgressListener) - 类 javax.imageio.ImageWriter 中的方法
从已注册的进度侦听器列表中移除 IIOWriteProgressListener。
removeIIOWriteWarningListener(IIOWriteWarningListener) - 类 javax.imageio.ImageWriter 中的方法
从已注册的警告侦听器列表中移除 IIOWriteWarningListener。
removeImage(Image) - 类 java.awt.MediaTracker 中的方法
从此媒体跟踪器移除指定的图像。
removeImage(Image, int) - 类 java.awt.MediaTracker 中的方法
从此媒体跟踪器的指定跟踪 ID 中移除指定的图像。
removeImage(Image, int, int, int) - 类 java.awt.MediaTracker 中的方法
从此媒体跟踪器移除具有指定宽度、高度和 ID 的指定图像。
removeImage(int) - 类 javax.imageio.ImageWriter 中的方法
从流中移除图像。
removeIndexInterval(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
从选择模型中移除 index0,index1 区间中（包括两端点）的索引。
removeIndexInterval(int, int) - 接口 javax.swing.ListSelectionModel 中的方法
从选择模型中移除区间 index0、index1（包括）中的索引。
removeInputMethodListener(InputMethodListener) - 类 java.awt.Component 中的方法
移除指定的输入方法侦听器，以便它不再接收发自此组件的输入方法事件。
removeInternal(EventListener, EventListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
在从侦听器 l 中移除旧的侦听器之后，返回得到的多路广播侦听器。
removeInternalFrameListener(InternalFrameListener) - 类 javax.swing.JInternalFrame 中的方法
移除指定的内部窗体侦听器，不再接收此内部窗体发出的内部窗体事件。
removeInvalidComponent(JComponent) - 类 javax.swing.RepaintManager 中的方法
从无效组件的列表移除组件。
removeItem(Object) - 类 javax.swing.JComboBox 中的方法
从项列表中移除项。
removeItemAt(int) - 类 javax.swing.JComboBox 中的方法
移除 anIndex 处的项。
removeItemListener(ItemListener) - 类 java.awt.Checkbox 中的方法
移除此项侦听器，这样项侦听器将不再接收发自此复选框的项事件。
removeItemListener(ItemListener) - 类 java.awt.CheckboxMenuItem 中的方法
移除指定的项侦听器，以便它不再接收发自此复选框菜单项的项事件。
removeItemListener(ItemListener) - 类 java.awt.Choice 中的方法
移除指定的项侦听器，以便它不再接收发自此 Choice 菜单的项事件。
removeItemListener(ItemListener) - 接口 java.awt.ItemSelectable 中的方法
移除项侦听器。
removeItemListener(ItemListener) - 类 java.awt.List 中的方法
移除指定的项侦听器，以便不再从此列表接收项事件。
removeItemListener(ItemListener) - 类 javax.swing.AbstractButton 中的方法
从按钮中移除一个 ItemListener。
removeItemListener(ItemListener) - 接口 javax.swing.ButtonModel 中的方法
从模型中移除一个 ItemListener。
removeItemListener(ItemListener) - 类 javax.swing.DefaultButtonModel 中的方法
从模型中移除一个 ItemListener。
removeItemListener(ItemListener) - 类 javax.swing.JComboBox 中的方法
移除 ItemListener。
removeKeyEventDispatcher(KeyEventDispatcher) - 类 java.awt.KeyboardFocusManager 中的方法
移除以前添加到此 KeyboardFocusManager 调度程序链中的 KeyEventDispatcher。
removeKeyEventPostProcessor(KeyEventPostProcessor) - 类 java.awt.KeyboardFocusManager 中的方法
从此 KeyboardFocusManager 的后处理器链中移除以前添加的 KeyEventPostProcessor。
removeKeyListener(KeyListener) - 类 java.awt.Component 中的方法
移除指定的按键侦听器，以便它不再接收发自此组件的按键事件。
removeKeymap(String) - 类 javax.swing.text.JTextComponent 中的静态方法
移除以前添加到文档中的已命名 keymap。
removeKeyStrokeBinding(KeyStroke) - 接口 javax.swing.text.Keymap 中的方法
从 keymap 移除绑定。
removeLast() - 类 java.util.ArrayDeque 中的方法
removeLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
removeLast() - 接口 java.util.Deque 中的方法
获取并移除此双端队列的最后一个元素。
removeLast() - 类 java.util.LinkedList 中的方法
移除并返回此列表的最后一个元素。
removeLastOccurrence(Object) - 类 java.util.ArrayDeque 中的方法
移除此双端队列中最后一次出现的指定元素（当从头部到尾部遍历双端队列时）。
removeLastOccurrence(Object) - 接口 java.util.concurrent.BlockingDeque 中的方法
从此双端队列移除最后一次出现的指定元素。
removeLastOccurrence(Object) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
removeLastOccurrence(Object) - 接口 java.util.Deque 中的方法
从此双端队列移除最后一次出现的指定元素。
removeLastOccurrence(Object) - 类 java.util.LinkedList 中的方法
从此列表中移除最后一次出现的指定元素（从头部到尾部遍历列表时）。
removeLayoutComponent(Component) - 类 java.awt.BorderLayout 中的方法
从此边框布局中移除指定组件。
removeLayoutComponent(Component) - 类 java.awt.CardLayout 中的方法
从布局中移除指定的组件。
removeLayoutComponent(Component) - 类 java.awt.FlowLayout 中的方法
从布局中移除指定的组件。
removeLayoutComponent(Component) - 类 java.awt.GridBagLayout 中的方法
从此布局移除指定组件。
removeLayoutComponent(Component) - 类 java.awt.GridLayout 中的方法
从布局移除指定组件。
removeLayoutComponent(Component) - 接口 java.awt.LayoutManager 中的方法
从布局移除指定组件。
removeLayoutComponent(Component) - 类 javax.swing.BoxLayout 中的方法
此类不使用。
removeLayoutComponent(Component) - 类 javax.swing.GroupLayout 中的方法
已从父容器中移除 Component 的通知。
removeLayoutComponent(Component) - 类 javax.swing.JRootPane.RootLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
此 LayoutManager 方法不执行任何操作。
removeLayoutComponent(Component) - 类 javax.swing.OverlayLayout 中的方法
从布局移除指定组件。
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
根据了解的情况移除指定的组件。
removeLayoutComponent(Component) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
removeLayoutComponent(Component) - 类 javax.swing.ScrollPaneLayout 中的方法
从布局中移除指定的组件。
removeLayoutComponent(Component) - 类 javax.swing.SpringLayout 中的方法
移除与指定组件相关的约束。
removeLayoutComponent(Component) - 类 javax.swing.ViewportLayout 中的方法
从布局中移除指定组件。
removeLineListener(LineListener) - 接口 javax.sound.sampled.Line 中的方法
从此行的侦听器列表中移除指定侦听器。
removeListDataListener(ListDataListener) - 类 javax.swing.AbstractListModel 中的方法
将某个侦听器从每次更改数据模型都要通知的列表中移除。
removeListDataListener(ListDataListener) - 接口 javax.swing.ListModel 中的方法
从每次在数据模型发生更改时都得到通知的列表中移除侦听器。
removeListeners() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
已过时。 从 Java 2 platform v1.4 开始。
removeListSelectionListener(ListSelectionListener) - 类 javax.swing.DefaultListSelectionModel 中的方法
将侦听器从每次在选择发生更改时都得到通知的列表中移除。
removeListSelectionListener(ListSelectionListener) - 类 javax.swing.JList 中的方法
从列表中移除一个选择侦听器。
removeListSelectionListener(ListSelectionListener) - 接口 javax.swing.ListSelectionModel 中的方法
将侦听器从每次在选择发生更改时都得到通知的列表中移除。
removeMember(Principal) - 接口 java.security.acl.Group 中的方法
从组中移除指定的成员。
removeMenuDragMouseListener(MenuDragMouseListener) - 类 javax.swing.JMenuItem 中的方法
从菜单项中移除 MenuDragMouseListener。
removeMenuKeyListener(MenuKeyListener) - 类 javax.swing.JMenuItem 中的方法
从菜单项中移除 MenuKeyListener。
removeMenuKeyListener(MenuKeyListener) - 类 javax.swing.JPopupMenu 中的方法
从弹出菜单移除 MenuKeyListener。
removeMenuListener(MenuListener) - 类 javax.swing.JMenu 中的方法
移除菜单事件的侦听器。
removeMetaEventListener(MetaEventListener) - 接口 javax.sound.midi.Sequencer 中的方法
从此 sequencer 的已注册侦听器列表中移除指定的元事件侦听器（如果实际上此侦听器已注册）。
removeMimeHeader(String) - 类 javax.xml.soap.AttachmentPart 中的方法
移除匹配给定名称的所有 MIME 头。
removeMimeHeader(String) - 类 javax.xml.soap.SOAPPart 中的方法
移除所有与给定名称匹配的 MIME 头。
removeMouseListener(MouseListener) - 类 java.awt.Component 中的方法
移除指定的鼠标侦听器，以便它不再接收发自此组件的鼠标事件。
removeMouseListener(MouseListener) - 类 java.awt.TrayIcon 中的方法
移除指定的鼠标侦听器。
removeMouseMotionListener(MouseMotionListener) - 类 java.awt.Component 中的方法
移除指定的鼠标移动侦听器，以便它不再接收发自此组件的鼠标移动事件。
removeMouseMotionListener(MouseMotionListener) - 类 java.awt.TrayIcon 中的方法
移除指定的鼠标移动侦听器。
removeMouseWheelListener(MouseWheelListener) - 类 java.awt.Component 中的方法
移除指定的鼠标滚轮侦听器，以便它不再接收发自此组件的鼠标滚轮事件。
removeNamedItem(String) - 接口 org.w3c.dom.NamedNodeMap 中的方法
移除通过名称指定的节点。
removeNamedItemNS(String, String) - 接口 org.w3c.dom.NamedNodeMap 中的方法
移除通过本地名称和名称空间 URI 指定的节点。
removeNamespaceDeclaration(String) - 接口 javax.xml.soap.SOAPElement 中的方法
移除对应于给定前缀的名称空间声明。
removeNamingListener(NamingListener) - 接口 javax.naming.event.EventContext 中的方法
从此 EventContext 触发的接收命名事件中移除一个侦听器。
removeNode() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.removeNode() 中的规范实现 removeNode() 方法。
removeNode() - 类 java.util.prefs.Preferences 中的方法
移除此首选项节点及其所有子节点，移除的节点中所包含的全部首选项都将失效。
removeNodeChangeListener(NodeChangeListener) - 类 java.util.prefs.AbstractPreferences 中的方法
removeNodeChangeListener(NodeChangeListener) - 类 java.util.prefs.Preferences 中的方法
移除指定 NodeChangeListener，使其不再接收更改事件。
removeNodeFromParent(MutableTreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通知它从其父节点中移除节点。
removeNodeSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
移除此首选项节点，该首选项节点及其所包含的所有首选项都将失效。
removeNotification(Integer) - 类 javax.management.timer.Timer 中的方法
从通知列表中移除与指定标识符对应的计时器通知。
removeNotification(Integer) - 接口 javax.management.timer.TimerMBean 中的方法
从通知列表中移除与指定的标识符对应的计时器通知。
removeNotificationListener(ObjectName, ObjectName) - 接口 javax.management.MBeanServer 中的方法
removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - 接口 javax.management.MBeanServer 中的方法
removeNotificationListener(ObjectName, NotificationListener) - 接口 javax.management.MBeanServer 中的方法
removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - 接口 javax.management.MBeanServer 中的方法
removeNotificationListener(ObjectName, ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
从已注册的 MBean 中移除一个侦听器。
removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - 接口 javax.management.MBeanServerConnection 中的方法
从已注册的 MBean 中移除一个侦听器。
removeNotificationListener(ObjectName, NotificationListener) - 接口 javax.management.MBeanServerConnection 中的方法
从已注册的 MBean 中移除一个侦听器。
removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - 接口 javax.management.MBeanServerConnection 中的方法
从已注册的 MBean 中移除一个侦听器。
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.MBeanServerDelegate 中的方法
removeNotificationListener(NotificationListener) - 类 javax.management.MBeanServerDelegate 中的方法
removeNotificationListener(NotificationListener) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
从 RequiredModelMBean 移除一个 Notification 的侦听器。
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
removeNotificationListener(NotificationListener) - 接口 javax.management.NotificationBroadcaster 中的方法
从此 MBean 移除一个侦听器。
removeNotificationListener(NotificationListener) - 类 javax.management.NotificationBroadcasterSupport 中的方法
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.NotificationBroadcasterSupport 中的方法
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 接口 javax.management.NotificationEmitter 中的方法
从此 MBean 移除一个侦听器。
removeNotificationListener(ObjectName, ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
removeNotificationListener(ObjectName, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
removeNotificationListener(ObjectName, ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
removeNotificationListener(NotificationListener) - 类 javax.management.StandardEmitterMBean 中的方法
removeNotificationListener(NotificationListener, NotificationFilter, Object) - 类 javax.management.StandardEmitterMBean 中的方法
removeNotificationListeners(ObjectName, Integer[], Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
removeNotificationListeners(ObjectName, Integer[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
removeNotificationListeners(ObjectName, Integer[], Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
removeNotifications(String) - 类 javax.management.timer.Timer 中的方法
从通知列表中移除与指定类型对应的所有计时器通知。
removeNotifications(String) - 接口 javax.management.timer.TimerMBean 中的方法
从通知列表中移除与指定的类型对应的所有计时器通知。
removeNotify() - 类 java.awt.Component 中的方法
通过销毁此 Component 的本机屏幕资源使其成为不可显示的。
removeNotify() - 类 java.awt.Container 中的方法
通过移除此 Container 到其本机屏幕资源的连接，使其不可显示。
removeNotify(ComponentPeer) - 类 java.awt.dnd.DropTarget 中的方法
通知 DropTarget 它已经与某个 Component 解除关联。
removeNotify() - 类 java.awt.dnd.DropTargetContext 中的方法
取消与 DropTargetContextPeer 的关联时调用。
removeNotify() - 类 java.awt.Frame 中的方法
通过移除与本机屏幕资源的连接，将此窗体设置为不可显示的。
removeNotify(Component) - 类 java.awt.im.InputContext 中的方法
通知输入上下文，客户端组件已从它的包含层次结构中移除，或该组件已禁用输入方法支持。
removeNotify() - 接口 java.awt.im.spi.InputMethod 中的方法
通知输入方法已从客户端组件所在容器层次结构中移除该客户端组件，或通知它该组件已禁用输入方法支持。
removeNotify() - 类 java.awt.List 中的方法
移除此列表的同位体。
removeNotify() - 类 java.awt.Menu 中的方法
移除该菜单的同位体。
removeNotify() - 类 java.awt.MenuBar 中的方法
移除该菜单栏的同位体。
removeNotify() - 类 java.awt.MenuComponent 中的方法
移除该菜单组件的同位体。
removeNotify() - 类 java.awt.TextComponent 中的方法
移除 TextComponent 的同位体。
removeNotify() - 类 java.awt.Window 中的方法
通过移除此 Container 到其本机屏幕资源的连接，使其不可显示。
removeNotify() - 类 javax.swing.AbstractButton 中的方法
通知此组件它不再有父组件。
removeNotify() - 类 javax.swing.JButton 中的方法
重写 JComponent.removeNotify 来检查此按钮当前是否被设置为 RootPane 上的默认按钮，如果是，则将 RootPane 的默认按钮设置为 null，以确保 RootPane 不继续停留在无效的按钮引用上。
removeNotify() - 类 javax.swing.JComponent 中的方法
通知此组件它不再有父组件。
removeNotify() - 类 javax.swing.JMenuBar 中的方法
重写 JComponent.removeNotify 以在当前键盘管理器中注销此菜单栏。
removeNotify() - 类 javax.swing.JRootPane 中的方法
将本身从 SystemEventQueueUtils 注销。
removeNotify() - 类 javax.swing.JTable 中的方法
调用 unconfigureEnclosingScrollPane 方法。
removeNotify() - 类 javax.swing.text.JTextComponent 中的方法
removeObjectValue(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
禁止将 Object 引用存储在实现指定元素的节点中。
removeObservedObject(ObjectName) - 类 javax.management.monitor.Monitor 中的方法
从所观察的 MBean 集中移除指定的对象。
removeObservedObject(ObjectName) - 接口 javax.management.monitor.MonitorMBean 中的方法
从所观察的 MBean 集中移除指定的对象。
removeParameter(String) - 类 javax.activation.MimeType 中的方法
移除与给定名称关联的所有值。
removeParameters() - 类 java.awt.image.renderable.ParameterBlock 中的方法
清除参数列表。
removePermission(Permission) - 接口 java.security.acl.AclEntry 中的方法
从此 ACL 项中移除指定的权限。
removePopupMenuListener(PopupMenuListener) - 类 javax.swing.JComboBox 中的方法
移除 PopupMenuListener。
removePopupMenuListener(PopupMenuListener) - 类 javax.swing.JPopupMenu 中的方法
移除 PopupMenu 侦听器。
removePreferenceChangeListener(PreferenceChangeListener) - 类 java.util.prefs.AbstractPreferences 中的方法
removePreferenceChangeListener(PreferenceChangeListener) - 类 java.util.prefs.Preferences 中的方法
移除指定首选项更改侦听器，使其不再接收首选项更改事件。
removePrintJobAttributeListener(PrintJobAttributeListener) - 接口 javax.print.DocPrintJob 中的方法
移除此 PrintJob 的属性侦听器。
removePrintJobListener(PrintJobListener) - 接口 javax.print.DocPrintJob 中的方法
移除此 PrintJob 的侦听器。
removePrintServiceAttributeListener(PrintServiceAttributeListener) - 接口 javax.print.PrintService 中的方法
移除此 PrintService 的 PrintService 侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
将 PropertyChangeListener 从侦听器列表中移除。
removePropertyChangeListener(PropertyChangeListener) - 类 java.awt.Component 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Component 中的方法
从指定属性的侦听器列表中移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
从侦听器列表移除 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
从特定属性的侦听器列表移除 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.SystemTray 中的方法
从特定属性的侦听器列表中移除 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.awt.Toolkit 中的方法
为指定的桌面属性移除指定的属性更改侦听器。
removePropertyChangeListener(String, PropertyChangeListener) - 接口 java.beans.beancontext.BeanContextChild 中的方法
从此 BeanContextChild 中移除一个 PropertyChangeListener，以便指定属性发生更改时不再接收 PropertyChangeEvent。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
为特定属性移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 接口 java.beans.Customizer 中的方法
移除一个用于 PropertyChange 事件的侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 java.beans.PropertyChangeSupport 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(String, PropertyChangeListener) - 类 java.beans.PropertyChangeSupport 中的方法
为特定属性移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 接口 java.beans.PropertyEditor 中的方法
移除一个用于 PropertyChange 事件的侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 java.beans.PropertyEditorSupport 中的方法
移除一个用于 PropertyChange 事件的侦听器。
removePropertyChangeListener(PropertyChangeListener) - 接口 java.util.jar.Pack200.Packer 中的方法
移除由 Pack200.Packer.addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。
removePropertyChangeListener(PropertyChangeListener) - 接口 java.util.jar.Pack200.Unpacker 中的方法
移除由 Pack200.Unpacker.addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 java.util.logging.LogManager 中的方法
移除属性更改事件的事件侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.accessibility.AccessibleContext 中的方法
从侦听器列表移除 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.AbstractAction 中的方法
从侦听器列表中移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 接口 javax.swing.Action 中的方法
移除一个 PropertyChange 侦听器。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JComponent.AccessibleJComponent 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
从侦听器列表中移除 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.SwingWorker 中的方法
从侦听器列表中移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.table.TableColumn 中的方法
从侦听器列表中移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
从侦听器列表移除 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.UIDefaults 中的方法
从侦听器列表移除一个 PropertyChangeListener。
removePropertyChangeListener(PropertyChangeListener) - 类 javax.swing.UIManager 中的静态方法
从侦听器列表移除 PropertyChangeListener。
removeProvider(String) - 类 java.security.Security 中的静态方法
移除带有指定名称的提供者。
removeRange(int, int) - 类 java.util.AbstractList 中的方法
从此列表中移除索引在 fromIndex（包括）和 toIndex（不包括）之间的所有元素。
removeRange(int, int) - 类 java.util.ArrayList 中的方法
移除列表中索引在 fromIndex（包括）和 toIndex（不包括）之间的所有元素。
removeRange(int, int) - 类 java.util.Vector 中的方法
从此 List 中移除其索引位于 fromIndex（包括）与 toIndex（不包括）之间的所有元素。
removeRange(int, int) - 类 javax.swing.DefaultListModel 中的方法
删除指定索引范围中的组件。
removeRedundantState() - 类 javax.swing.undo.StateEdit 中的方法
移除状态哈希表中多余的键/值。
removeRelation(String) - 类 javax.management.relation.RelationService 中的方法
从 Relation Service 移除给定的关系。
removeRelation(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
从 Relation Service 移除给定的关系。
removeRelationType(String) - 类 javax.management.relation.RelationService 中的方法
从 Relation Service 中移除给定的关系类型。
removeRelationType(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
从 Relation Service 中移除给定的关系类型。
removeResourceBundle(String) - 类 javax.swing.UIDefaults 中的方法
从在其中搜索本地化默认的资源包列表中移除一个资源包。
removeRow(int) - 类 javax.swing.table.DefaultTableModel 中的方法
移除模型中 row 位置的行。
removeRowSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
取消选中从 index0 到 index1 之间（包含两端）的行。
removeRowSetListener(RowSetListener) - 类 javax.sql.rowset.BaseRowSet 中的方法
从此 RowSet 对象的侦听器列表中移除指定的对象。
removeRowSetListener(RowSetListener) - 接口 javax.sql.RowSet 中的方法
从在此 RowSet 对象上发生事件时得到通知的组件所组成的列表中移除指定的侦听器。
removeRowSorterListener(RowSorterListener) - 类 javax.swing.RowSorter 中的方法
移除一个 RowSorterListener。
removeSelectionInterval(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
将选择更改为当前选择与 index0 和 index1（包括）之间索引的差集。
removeSelectionInterval(int, int) - 类 javax.swing.JList 中的方法
将选择设置为指定间隔和当前选择的差集。
removeSelectionInterval(int, int) - 类 javax.swing.JTree 中的方法
从该选择中移除 index0 和 index1（包含）之间的节点。
removeSelectionInterval(int, int) - 接口 javax.swing.ListSelectionModel 中的方法
将选择更改为当前选择与 index0 和 index1 之间（包括两者）索引的差集。
removeSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
从当前选择中移除指定路径标识的节点。
removeSelectionPath(TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
从 selection 中移除路径。
removeSelectionPath(TreePath) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
从选择中移除路径。
removeSelectionPaths(TreePath[]) - 类 javax.swing.JTree.EmptySelectionModel 中的方法
一个未移除任何内容的 null 实现。
removeSelectionPaths(TreePath[]) - 类 javax.swing.JTree 中的方法
从当前选择移除指定路径标识的节点。
removeSelectionPaths(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
从 selection 中移除路径。
removeSelectionPaths(TreePath[]) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
从选择中移除路径。
removeSelectionRow(int) - 类 javax.swing.JTree 中的方法
从当前选择移除索引 row 处的行。
removeSelectionRows(int[]) - 类 javax.swing.JTree 中的方法
移除在每个指定行处选择的行。
removeService(Provider.Service) - 类 java.security.Provider 中的方法
移除以前用 putService() 添加的服务。
removeShutdownHook(Thread) - 类 java.lang.Runtime 中的方法
取消注册某个先前已注册的虚拟机关闭钩子。
removeSources() - 类 java.awt.image.renderable.ParameterBlock 中的方法
清除源图像的列表。
removeSpi(String) - 类 java.util.prefs.AbstractPreferences 中的方法
移除此首选项节点上指定键的关联值（如果有）。
removeStatementEventListener(StatementEventListener) - 接口 javax.sql.PooledConnection 中的方法
从一个组件列表中移除指定的 StatementEventListener，该列表由驱动程序检测到 PreparedStatement 已关闭或无效时将获得通知的组件组成。
removeStyle(String) - 类 javax.swing.JTextPane 中的方法
移除以前添加到文档中的已命名的非 null 样式。
removeStyle(String) - 类 javax.swing.text.DefaultStyledDocument 中的方法
移除以前添加到文档中的已命名样式。
removeStyle(String) - 类 javax.swing.text.html.StyleSheet 中的方法
移除以前添加到该文档中的指定样式。
removeStyle(String) - 类 javax.swing.text.StyleContext 中的方法
移除以前添加到文档中的已命名样式。
removeStyle(String) - 接口 javax.swing.text.StyledDocument 中的方法
移除以前添加到文档中的指定样式。
removeStyleSheet(StyleSheet) - 类 javax.swing.text.html.StyleSheet 中的方法
从接收者的规则中移除 StyleSheet ss。
removeTabAt(int) - 类 javax.swing.JTabbedPane 中的方法
移除 index 位置的选项卡。
removeTableModelListener(TableModelListener) - 类 javax.swing.table.AbstractTableModel 中的方法
每次数据模型发生更改时，就从被通知的列表移除一个侦听器。
removeTableModelListener(TableModelListener) - 接口 javax.swing.table.TableModel 中的方法
每当数据模型发生更改时，就从被通知的列表中移除一个侦听器。
removeTextListener(TextListener) - 类 java.awt.TextComponent 中的方法
移除指定的文本事件侦听器，不再接收此文本组件发出的文本事件。
removeTileObserver(TileObserver) - 类 java.awt.image.BufferedImage 中的方法
移除一个 tile observer。
removeTileObserver(TileObserver) - 接口 java.awt.image.WritableRenderedImage 中的方法
移除一个观察器。
removeTransformer(ClassFileTransformer) - 接口 java.lang.instrument.Instrumentation 中的方法
注销提供的转换器。
removeTreeExpansionListener(TreeExpansionListener) - 类 javax.swing.JTree 中的方法
移除 TreeExpansion 事件的侦听器。
removeTreeModelListener(TreeModelListener) - 类 javax.swing.tree.DefaultTreeModel 中的方法
移除以前使用 addTreeModelListener() 添加的侦听器。
removeTreeModelListener(TreeModelListener) - 接口 javax.swing.tree.TreeModel 中的方法
移除以前通过 addTreeModelListener 添加的侦听器。
removeTreeSelectionListener(TreeSelectionListener) - 类 javax.swing.JTree 中的方法
移除 TreeSelection 侦听器。
removeTreeSelectionListener(TreeSelectionListener) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
从每次已选的 TreePaths 集合发生更改时都会得到通知的侦听器列表中移除 x。
removeTreeSelectionListener(TreeSelectionListener) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
从每次已选的 TreePath 集合发生更改时都会得到通知的侦听器列表中移除 x。
removeTreeWillExpandListener(TreeWillExpandListener) - 类 javax.swing.JTree 中的方法
移除 TreeWillExpand 事件的侦听器。
removeUndoableEditListener(UndoableEditListener) - 类 javax.swing.text.AbstractDocument 中的方法
移除撤消侦听器。
removeUndoableEditListener(UndoableEditListener) - 接口 javax.swing.text.Document 中的方法
将给定的观察者从通知列表中撤消注册，这样就不再接收更新。
removeUndoableEditListener(UndoableEditListener) - 类 javax.swing.undo.UndoableEditSupport 中的方法
移除一个 UndoableEditListener。
removeUpdate(DocumentEvent) - 接口 javax.swing.event.DocumentListener 中的方法
给出移除了一部分文档的通知。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.AbstractDocument 中的方法
随文本的移除更新任何文档结构。
removeUpdate() - 类 javax.swing.text.DefaultStyledDocument.ElementBuffer 中的方法
更新元素结构，以响应对文档中关联序列的移除操作。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.DefaultStyledDocument 中的方法
在文本移除后更新文档结构。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FieldView 中的方法
通知在文档中此视图负责的某个位置已插入内容。
removeUpdate(FlowView, DocumentEvent, Rectangle) - 类 javax.swing.text.FlowView.FlowStrategy 中的方法
发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.FlowView 中的方法
发出通知，通知从文档中此视图负责的某个位置已移除内容。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.GlyphView 中的方法
发出通知，通知文档中此视图负责的位置已移除内容。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.html.InlineView 中的方法
发出通知，通知文档中此视图负责的位置已移除内容。
removeUpdate(DocumentEvent) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
处理文档移除（触发适当的属性更改事件 AccessibleContext.ACCESSIBLE_TEXT_PROPERTY）。
removeUpdate(AbstractDocument.DefaultDocumentEvent) - 类 javax.swing.text.PlainDocument 中的方法
随文本的移除更新任何文档结构。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.PlainView 中的方法
通知在文档中此视图负责的某个位置已插入内容。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.View 中的方法
给出从文档中此视图负责的位置移除了某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.WrappedPlainView 中的方法
发出从文档中此视图负责的位置移除了某些内容的通知。
removeUpdate(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.ZoneView 中的方法
给出从文档中此视图负责的位置移除了某些内容的通知。
removeValue(String) - 接口 javax.net.ssl.SSLSession 中的方法
移除会话的应用层数据中绑定到给定名称的对象。
removeVetoableChangeListener(VetoableChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
从侦听器列表移除 VetoableChangeListener。
removeVetoableChangeListener(String, VetoableChangeListener) - 类 java.awt.KeyboardFocusManager 中的方法
从特定属性的侦听器列表移除 VetoableChangeListener。
removeVetoableChangeListener(String, VetoableChangeListener) - 接口 java.beans.beancontext.BeanContextChild 中的方法
从此 BeanContextChild 中移除一个 VetoableChangeListener，以便指定属性发生更改时不再接收事件。
removeVetoableChangeListener(String, VetoableChangeListener) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
移除一个 VetoableChangeListener。
removeVetoableChangeListener(VetoableChangeListener) - 类 java.beans.VetoableChangeSupport 中的方法
从侦听器列表移除一个 VetoableChangeListener。
removeVetoableChangeListener(String, VetoableChangeListener) - 类 java.beans.VetoableChangeSupport 中的方法
为特定属性移除一个 VetoableChangeListener。
removeVetoableChangeListener(VetoableChangeListener) - 类 javax.swing.JComponent 中的方法
从侦听器列表移除一个 VetoableChangeListener。
removeWindowFocusListener(WindowFocusListener) - 类 java.awt.Window 中的方法
移除指定的窗口焦点侦听器，以便不再从此窗口接收窗口事件。
removeWindowListener(WindowListener) - 类 java.awt.Window 中的方法
移除指定的窗口侦听器，以便不再从此窗口接收窗口事件。
removeWindowStateListener(WindowStateListener) - 类 java.awt.Window 中的方法
移除指定的窗口状态侦听器，以便不再从此窗口接收窗口事件。
rename(Name, Name) - 接口 javax.naming.Context 中的方法
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
rename(String, String) - 接口 javax.naming.Context 中的方法
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
rename(String, String) - 类 javax.naming.InitialContext 中的方法
rename(Name, Name) - 类 javax.naming.InitialContext 中的方法
renameFile(File, File) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
重命名底层文件系统中的文件。
renameNode(Node, String, String) - 接口 org.w3c.dom.Document 中的方法
重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。
renameTo(File) - 类 java.io.File 中的方法
重新命名此抽象路径名表示的文件。
render(Runnable) - 类 javax.swing.text.AbstractDocument 中的方法
如果模型支持被异步更新，则此方法允许在并发情况下安全地呈现该模型。
render(Runnable) - 接口 javax.swing.text.Document 中的方法
如果模型支持异步更新，则允许在并发情况下安全呈现模型。
RENDERABLE_IMAGE - 类 javax.print.DocFlavor.SERVICE_FORMATTED 中的静态变量
打印数据表示形式类名 = "java.awt.image.renderable.RenderableImage"（RenderableImage 对象）的服务格式化打印数据 DocFlavor。
RenderableImage - java.awt.image.renderable 中的 接口
RenderableImage 是与呈现无关的图像（该概念包含与分辨率无关的意思）的公共接口。
RenderableImageOp - java.awt.image.renderable 中的 类
此类借助其相关的 ContextualRenderedImageFactory 实例处理某个操作的可呈现方面。
RenderableImageOp(ContextualRenderedImageFactory, ParameterBlock) - 类 java.awt.image.renderable.RenderableImageOp 的构造方法
根据给定 ContextualRenderedImageFactory 对象以及一个包含 RenderableImage 源和其他参数的 ParameterBlock 构造 RenderedImageOp。
RenderableImageProducer - java.awt.image.renderable 中的 类
实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。
RenderableImageProducer(RenderableImage, RenderContext) - 类 java.awt.image.renderable.RenderableImageProducer 的构造方法
根据 RenderableImage 和 RenderContext 构造新的 RenderableImageProducer。
RenderContext - java.awt.image.renderable 中的 类
RenderContext 封装从 enderableImage 生成特定呈现所需的信息。
RenderContext(AffineTransform, Shape, RenderingHints) - 类 java.awt.image.renderable.RenderContext 的构造方法
构造具有给定转换的 RenderContext。
RenderContext(AffineTransform) - 类 java.awt.image.renderable.RenderContext 的构造方法
构造具有给定变换的 RenderContext。
RenderContext(AffineTransform, RenderingHints) - 类 java.awt.image.renderable.RenderContext 的构造方法
构造具有给定转换和呈现提示的 RenderContext。
RenderContext(AffineTransform, Shape) - 类 java.awt.image.renderable.RenderContext 的构造方法
构造具有给定变换和感兴趣区域的 RenderContext。
RenderedImage - java.awt.image 中的 接口
RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。
RenderedImageFactory - java.awt.image.renderable 中的 接口
RenderedImageFactory 接口（通常简称为 RIF）由希望充当工厂以生成不同呈现的类实现，例如，根据一组特定的参数、属性和呈现提示集，通过对一组源执行一连串的 BufferedImageOp。
renderer - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
Renderer - javax.swing 中的 接口
为负责“呈现”（显示）值的对象定义需求。
renderer - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
用于从中获取边框和偏移量的呈现器。
rendererPane - 类 javax.swing.plaf.basic.BasicListUI 中的变量
rendererPane - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的变量
rendererPane - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
rendererPane - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
用于绘制 TreeCellRenderer。
rendererPane - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的变量
RenderingHints - java.awt 中的 类
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。
RenderingHints(Map<RenderingHints.Key, ?>) - 类 java.awt.RenderingHints 的构造方法
构造一个新对象，该对象具有根据指定 Map 对象（可以为 null）初始化的键和值。
RenderingHints(RenderingHints.Key, Object) - 类 java.awt.RenderingHints 的构造方法
构造一个具有指定键/值对的新对象。
RenderingHints.Key - java.awt 中的 类
定义与 RenderingHints 一起使用的、用来控制呈现和图像管线中各种算法选择的所有键的基本类型。
RenderingHints.Key(int) - 类 java.awt.RenderingHints.Key 的构造方法
使用指示的私有键构造一个键。
reorderingAllowed - 类 javax.swing.table.JTableHeader 中的变量
如果为 true，则允许用户重新排序各列；默认值为 true。
reorderVisually(byte[], int, Object[], int, int) - 类 java.text.Bidi 中的静态方法
根据对象的层次，在数组中将对象重新排序为可视顺序。
repaint() - 类 java.awt.Component 中的方法
重绘此组件。
repaint(long) - 类 java.awt.Component 中的方法
重绘组件。
repaint(int, int, int, int) - 类 java.awt.Component 中的方法
重绘组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 java.awt.Component 中的方法
在 tm 毫秒内重绘组件的指定矩形区域。
repaint() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
repaint(long, int, int, int, int) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
repaint(Rectangle) - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
repaint(long, int, int, int, int) - 类 javax.swing.JApplet 中的方法
在 time 毫秒内重绘此组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 javax.swing.JComponent 中的方法
如果要显示组件，则将指定的区域添加到脏区 (dirty region) 列表。
repaint(Rectangle) - 类 javax.swing.JComponent 中的方法
如果要显示该组件，则将指定的区域添加到脏区列表。
repaint(long, int, int, int, int) - 类 javax.swing.JDialog 中的方法
在 time 毫秒内重绘此组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 javax.swing.JFrame 中的方法
在 time 毫秒内重绘此组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 javax.swing.JViewport 中的方法
始终在父坐标系统中重绘，以确保 RepaintManager 仅执行一种绘制方法。
repaint(long, int, int, int, int) - 类 javax.swing.JWindow 中的方法
在 time 毫秒内重绘此组件的指定矩形区域。
repaint(long, int, int, int, int) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
repaint(Rectangle) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
repaint() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
repaint() - 类 javax.swing.text.DefaultCaret 中的方法
使得重绘插入符。
repaint(long, int, int, int, int) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
repaint(Rectangle) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
repaint() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
repaintCellFocus() - 类 javax.swing.plaf.basic.BasicListUI.FocusHandler 中的方法
RepaintManager - javax.swing 中的 类
此类管理重绘请求，以最大限度地降低重绘次数。
RepaintManager() - 类 javax.swing.RepaintManager 的构造方法
创建新的 RepaintManager 实例。
repeatKeyAction - 类 javax.swing.plaf.basic.BasicTreeUI.KeyHandler 中的变量
正在生成的键代码。
replace(char, char) - 类 java.lang.String 中的方法
返回一个新的字符串，它是通过用 newChar 替换此字符串中出现的所有 oldChar 得到的。
replace(CharSequence, CharSequence) - 类 java.lang.String 中的方法
使用指定的字面值替换序列替换此字符串所有匹配字面值目标序列的子字符串。
replace(int, int, String) - 类 java.lang.StringBuffer 中的方法
replace(int, int, String) - 类 java.lang.StringBuilder 中的方法
REPLACE - 类 java.nio.charset.CodingErrorAction 中的静态变量
指示通过删除错误输入、向输出缓冲区追加 coder 的替换值和恢复编码操作来处理编码错误的操作。
replace(K, V, V) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
只有目前将键的条目映射到给定值时，才替换该键的条目。
replace(K, V) - 类 java.util.concurrent.ConcurrentHashMap 中的方法
只有目前将键的条目映射到某一值时，才替换该键的条目。
replace(K, V, V) - 接口 java.util.concurrent.ConcurrentMap 中的方法
只有目前将键的条目映射到给定值时，才替换该键的条目。
replace(K, V) - 接口 java.util.concurrent.ConcurrentMap 中的方法
只有目前将键的条目映射到某一值时，才替换该键的条目。
replace(K, V, V) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
只有目前将键的条目映射到给定值时，才替换该键的条目。
replace(K, V) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
只有目前将键的条目映射到某一值时，才替换该键的条目。
replace(Component, Component) - 类 javax.swing.GroupLayout 中的方法
使用新的组件替代现有组件。
replace(int, int, Element[]) - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
使用新的元素集替换该内容。
replace(int, int, String, AttributeSet) - 类 javax.swing.text.AbstractDocument 中的方法
删除从 offset 到 offset + length 的文本区域，并用 text 替换它。
replace(int, int, View[]) - 类 javax.swing.text.AsyncBoxView 中的方法
调用超类以更新子视图，并且更新子视图的状态记录。
replace(int, int, View[]) - 类 javax.swing.text.BoxView 中的方法
使布局变得无效并调整所需/分配的缓存大小。
replace(int, int, View[]) - 类 javax.swing.text.CompositeView 中的方法
替换子视图。
replace(int, int, String, AttributeSet) - 类 javax.swing.text.DocumentFilter.FilterBypass 中的方法
删除从 offset 到 offset + length 的文本区域，并用 text 替换。
replace(DocumentFilter.FilterBypass, int, int, String, AttributeSet) - 类 javax.swing.text.DocumentFilter 中的方法
在替换指定的 Document 中的文本区域之前调用。
replace(int, int, View[]) - 类 javax.swing.text.TableView 中的方法
更改子视图。
replace(int, int, View[]) - 类 javax.swing.text.TableView.TableRow 中的方法
更改子视图。
replace(int, int, View[]) - 类 javax.swing.text.View 中的方法
替代子视图。
REPLACE_ATTRIBUTE - 接口 javax.naming.directory.DirContext 中的静态变量
此常量指定使用指定值替换属性。
replaceAll(String, String) - 类 java.lang.String 中的方法
使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。
replaceAll(List<T>, T, T) - 类 java.util.Collections 中的静态方法
使用另一个值替换列表中出现的所有某一指定值。
replaceAll(String) - 类 java.util.regex.Matcher 中的方法
替换模式与给定替换字符串相匹配的输入序列的每个子序列。
replaceChild(Node, Node) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
将子节点 oldChild 替换为子节点列表中的 newChild，并返回 oldChild 节点。
replaceChild(Node, Node) - 接口 org.w3c.dom.Node 中的方法
将子节点列表中的子节点 oldChild 替换为 newChild，并返回 oldChild 节点。
replaceData(int, int, String) - 接口 org.w3c.dom.CharacterData 中的方法
用指定的字符串替换从指定 16 位单元偏移量起始的字符。
replaceEdit(UndoableEdit) - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
此默认实现返回 false。
replaceEdit(UndoableEdit) - 接口 javax.swing.undo.UndoableEdit 中的方法
如果此 UndoableEdit 应替换 anEdit，则返回 true。
replaceEditor(JComponent, JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
当 JSpinner 编辑器属性更改时，由 PropertyChangeListener 调用。
replaceFirst(String, String) - 类 java.lang.String 中的方法
使用给定的 replacement 替换此字符串匹配给定的正则表达式的第一个子字符串。
replaceFirst(String) - 类 java.util.regex.Matcher 中的方法
替换模式与给定替换字符串匹配的输入序列的第一个子序列。
replaceImageMetadata(int, IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
替换与现有图像有关的图像元数据。
replaceItem(String, int) - 类 java.awt.List 中的方法
使用新字符串替换滚动列表中指定索引处的项。
replacement() - 类 java.nio.charset.CharsetDecoder 中的方法
返回此解码器的替换值。
replacement() - 类 java.nio.charset.CharsetEncoder 中的方法
返回此编码器的替换值。
replaceObject(Object) - 类 java.io.ObjectOutputStream 中的方法
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。
replacePane(JComponent, JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
将必需的鼠标处理程序安装在 newPane 上并将其添加到窗体。
replacePixels(RenderedImage, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
用给定图像部分替换已出现在输出中的图像部分。
replacePixels(Raster, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
用给定 Raster 部分替换已出现在输出中的图像部分。
replaceRange(String, int, int) - 类 java.awt.TextArea 中的方法
用指定替换文本替换指定开始位置与结束位置之间的文本。
replaceRange(String, int, int) - 类 javax.swing.JTextArea 中的方法
用给定的新文本替换从指示的起始位置到结尾位置的文本。
replaceSelection(String) - 类 javax.swing.JEditorPane 中的方法
用由给定字符串表示的新内容替换当前选中的内容。
replaceSelection(String) - 类 javax.swing.JTextPane 中的方法
用给定字符串所表示的新内容替换当前选择的内容。
replaceSelection(String) - 类 javax.swing.text.JTextComponent 中的方法
用给定字符串所表示的新内容替换当前选定的内容。
replaceStreamMetadata(IIOMetadata) - 类 javax.imageio.ImageWriter 中的方法
使用新信息替换输出中的流元数据。
replaceText(String, int, int) - 类 java.awt.TextArea 中的方法
已过时。 从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。
replaceText(int, int, String) - 接口 javax.accessibility.AccessibleEditableText 中的方法
用指定的字符串替换两个索引之间的文本。
replaceText(int, int, String) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
用指定的字符串替换两个索引之间的文本。
replaceText(int, int, String) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
使用指定字符串替换两个索引之间的文本。
replaceUIActionMap(JComponent, ActionMap) - 类 javax.swing.SwingUtilities 中的静态方法
将 component 的 UI ActionMap 更改为 uiActionMap 的便捷方法。
replaceUIInputMap(JComponent, int, InputMap) - 类 javax.swing.SwingUtilities 中的静态方法
将 component 的 UI InputMap 更改为 uiInputMap 的便捷方法。
replaceWholeText(String) - 接口 org.w3c.dom.Text 中的方法
将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。
replaceWith(String) - 类 java.nio.charset.CharsetDecoder 中的方法
更改此解码器的替换值。
replaceWith(byte[]) - 类 java.nio.charset.CharsetEncoder 中的方法
更改此编码器的替换值。
ReplicateScaleFilter - java.awt.image 中的 类
使用最简单的算法缩放图像的 ImageFilter 类。
ReplicateScaleFilter(int, int) - 类 java.awt.image.ReplicateScaleFilter 的构造方法
构造一个根据 width 和 height 参数指定的源 Image 来缩放像素的 ReplicateScaleFilter。
reply_status() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
描述操作调用结果的状态。
REPORT - 类 java.nio.charset.CodingErrorAction 中的静态变量
指示要报告编码错误的操作，报告的方式是通过返回 CoderResult 对象或抛出 CharacterCodingException，以上两者都适合实现编码过程的方法。
REPORT - 类 javax.print.attribute.standard.Severity 中的静态变量
指示 PrinterStateReason 是 "report"（不太严重）。
report(Diagnostic<? extends S>) - 类 javax.tools.DiagnosticCollector 中的方法
report(Diagnostic<? extends S>) - 接口 javax.tools.DiagnosticListener 中的方法
发现问题时调用此方法。
report(String, String, Object, Location) - 接口 javax.xml.stream.XMLReporter 中的方法
以特定于应用程序的格式报告所需消息。
REPORTER - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于设置/获取 XMLReporter 接口实现的属性。
reportError(String, Exception, int) - 类 java.util.logging.Handler 中的方法
用于向该 Handler 的 ErrorManager 报告错误的受保护便利方法。
RepositoryIdHelper - org.omg.CORBA 中的 类
RepositoryId 的 Helper。
RepositoryIdHelper() - 类 org.omg.CORBA.RepositoryIdHelper 的构造方法
request(Object, String) - 类 org.omg.CORBA.portable.Delegate 中的方法
创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
request(Object, String, boolean) - 类 org.omg.CORBA.portable.Delegate 中的方法
request 由 stub 调用，以获取用于编组参数的 OutputStream。
Request - org.omg.CORBA 中的 类
包含调用某一方法所必需的信息的对象。
Request() - 类 org.omg.CORBA.Request 的构造方法
request_id() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回唯一地标识激活的请求/应答序列的 id。
REQUEST_PROCESSING_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java。
requestAnonymity(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求不要将初始端的身份泄露给接受端。
requestConf(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求针对 wrap 方法启用数据机密性。
requestCredDeleg(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求在上下文创建期间将初始端的凭据委托给接受端。
requestDefaultFocus() - 类 javax.swing.JComponent 中的方法
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy.getDefaultComponent(Container).requestFocus() 取代
requestFocus() - 类 java.awt.Component.AccessibleAWTComponent 中的方法
请求使此对象拥有焦点。
requestFocus() - 类 java.awt.Component 中的方法
请求此 Component 获取输入焦点，并且此 Component 的顶层祖先成为获得焦点的 Window。
requestFocus(boolean) - 类 java.awt.Component 中的方法
请求此 Component 获取输入焦点，并且此 Component 的顶层祖先成为获得焦点的 Window。
requestFocus() - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
请求聚焦此对象。
requestFocus() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
请求此对象的焦点。
requestFocus() - 接口 javax.accessibility.AccessibleComponent 中的方法
请求此对象的焦点。
requestFocus() - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点。
requestFocus(boolean) - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点。
requestFocus() - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
requestFocus() - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
requestFocus() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
requestFocus() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar 中的方法
requestFocus() - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
requestFocusInWindow() - 类 java.awt.Component 中的方法
如果此 Component 的顶层祖先已经是获得焦点的 Window，则请求此 Component 获取输入焦点。
requestFocusInWindow(boolean) - 类 java.awt.Component 中的方法
如果此 Component 的顶层祖先已经是获得焦点的 Window，则请求此 Component 获取输入焦点。
requestFocusInWindow() - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点。
requestFocusInWindow(boolean) - 类 javax.swing.JComponent 中的方法
请求此 Component 获取输入焦点。
RequestInfo - org.omg.PortableInterceptor 中的 接口
Interceptor 可访问的请求信息。
RequestInfoOperations - org.omg.PortableInterceptor 中的 接口
Interceptor 可访问的请求信息。
RequestingUserName - javax.print.attribute.standard 中的 类
RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
RequestingUserName(String, Locale) - 类 javax.print.attribute.standard.RequestingUserName 的构造方法
构造具有给定用户名称和语言环境的新 RequestingUserName 属性。
requestInteg(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求针对 wrap 和 getMIC 方法启用数据完整性。
requestLifetime(int) - 接口 org.ietf.jgss.GSSContext 中的方法
请求上下文以秒为单位的生存期。
requestMutualAuth(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
要求相互验证在上下文创建期间完成。
requestPasswordAuthentication(InetAddress, int, String, String, String) - 类 java.net.Authenticator 中的静态方法
要求已经向系统注册的 authenticator 提供密码。
requestPasswordAuthentication(String, InetAddress, int, String, String, String) - 类 java.net.Authenticator 中的静态方法
要求已经向系统注册的 authenticator 提供密码。
requestPasswordAuthentication(String, InetAddress, int, String, String, String, URL, Authenticator.RequestorType) - 类 java.net.Authenticator 中的静态方法
要求已经向系统注册的 authenticator 提供密码。
RequestProcessingPolicy - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 处理请求的方式。
RequestProcessingPolicyOperations - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 处理请求的方式。
RequestProcessingPolicyValue - org.omg.PortableServer 中的 类
RequestProcessingPolicyValue 可以具有以下值。
RequestProcessingPolicyValue(int) - 类 org.omg.PortableServer.RequestProcessingPolicyValue 的构造方法
requestReplayDet(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求在上下文创建之后针对 per-message 安全服务启用重放检测。
requestSequenceDet(boolean) - 接口 org.ietf.jgss.GSSContext 中的方法
请求在上下文创建之后针对 per-message 安全服务启用序列检查。
requestTopDownLeftRightResend(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
requestTopDownLeftRightResend(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
代表 ImageConsumer 请求 ImageProducer 尝试再次以 TOPDOWNLEFTRIGHT 的顺序重新发送图像数据，从而可以使用依赖于按顺序接收像素的高质量转换算法以生成更佳的图像输出。
requestTopDownLeftRightResend(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
requestTopDownLeftRightResend(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
请求给定 ImageConsumer 按从上到下、从左到右的顺序再次提交图像数据。
RequestWrapper - javax.xml.ws 中的 注释类型
此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
require(int, String, String) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
require(int, String, String) - 接口 javax.xml.stream.XMLStreamReader 中的方法
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。
REQUIRED - 类 java.awt.GraphicsConfigTemplate 中的静态变量
用于“枚举”（整数）类型的值。
required - 类 java.sql.DriverPropertyInfo 中的变量
如果在 Driver.connect 期间必须为此属性提供一个值，则 required 字段为 true，否则为 false。
REQUIRED - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的静态变量
所需的 LoginModule。
REQUIRED - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
RequiredModelMBean - javax.management.modelmbean 中的 类
此类是 ModelMBean 的实现。
RequiredModelMBean() - 类 javax.management.modelmbean.RequiredModelMBean 的构造方法
构造带有空 ModelMBeanInfo 的 RequiredModelMBean。
RequiredModelMBean(ModelMBeanInfo) - 类 javax.management.modelmbean.RequiredModelMBean 的构造方法
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。
requireEnd() - 类 java.util.regex.Matcher 中的方法
如果很多输入都可以将正匹配更改为负匹配，则返回 true。
REQUIRES_ATTENTION - 类 javax.print.event.PrintJobEvent 中的静态变量
打印服务指示可能发生需要外部干预的瞬态问题，然后打印服务才可以继续进行。
requiresBidi(char[], int, int) - 类 java.text.Bidi 中的静态方法
如果指定的文本需要双向解析，则返回 true。
REQUISITE - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的静态变量
必需的 LoginModule。
RescaleOp - java.awt.image 中的 类
通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。
RescaleOp(float[], float[], RenderingHints) - 类 java.awt.image.RescaleOp 的构造方法
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。
RescaleOp(float, float, RenderingHints) - 类 java.awt.image.RescaleOp 的构造方法
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。
rescanCurrentDirectory() - 类 javax.swing.JFileChooser 中的方法
通知 UI 重新扫描当前目录的文件列表。
rescanCurrentDirectory(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
rescanCurrentDirectory(JFileChooser) - 类 javax.swing.plaf.FileChooserUI 中的方法
rescanCurrentDirectory(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
rescanCurrentDirectory(JFileChooser) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 rescanCurrentDirectory 方法。
resendTopDownLeftRight(ImageProducer) - 类 java.awt.image.ImageFilter 中的方法
响应来自 ImageConsumer 的一个按 TopDownLeftRight (TDLR) 顺序将像素数据重新发送的请求。
RESERVED_ID_MAX - 类 java.awt.AWTEvent 中的静态变量
保留的 AWT 事件 ID 的最大值。
RESERVED_UIROLE - 类 javax.print.ServiceUIFactory 中的静态变量
不是有效的角色，但是可将大于此的角色 ID 用于服务支持的专用角色。
reset() - 类 java.awt.geom.Area 中的方法
从此 Area 删除所有几何形状，将其恢复为空区域。
reset() - 类 java.awt.geom.Path2D 中的方法
将路径重置为空。
reset() - 类 java.awt.Polygon 中的方法
将此 Polygon 对象重置为一个空多边形。
reset() - 类 java.io.BufferedInputStream 中的方法
参见 InputStream 的 reset 方法的常规协定。
reset() - 类 java.io.BufferedReader 中的方法
将流重置到最新的标记。
reset() - 类 java.io.ByteArrayInputStream 中的方法
将缓冲区的位置重置为标记位置。
reset() - 类 java.io.ByteArrayOutputStream 中的方法
将此 byte 数组输出流的 count 字段重置为零，从而丢弃输出流中目前已累积的所有输出。
reset() - 类 java.io.CharArrayReader 中的方法
将该流重置为最新的标记，如果从未标记过，则将其重置到开头。
reset() - 类 java.io.CharArrayWriter 中的方法
重置该缓冲区，以便再次使用它而无需丢弃已分配的缓冲区。
reset() - 类 java.io.FilterInputStream 中的方法
将此流重新定位到对此输入流最后调用 mark 方法时的位置。
reset() - 类 java.io.FilterReader 中的方法
重置该流。
reset() - 类 java.io.InputStream 中的方法
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
reset() - 类 java.io.LineNumberInputStream 中的方法
已过时。 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
reset() - 类 java.io.LineNumberReader 中的方法
将该流重新设置为最新的标记。
reset() - 类 java.io.ObjectOutputStream 中的方法
重置将丢弃已写入流中的所有对象的状态。
reset() - 类 java.io.PushbackInputStream 中的方法
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
reset() - 类 java.io.PushbackReader 中的方法
重置该流。
reset() - 类 java.io.Reader 中的方法
重置该流。
reset() - 类 java.io.StringBufferInputStream 中的方法
已过时。 将输入流重置为开始读取此输入流的基础缓冲区的第一个字符处。
reset() - 类 java.io.StringReader 中的方法
将该流重置为最新的标记，如果从未标记过，则将其重置到该字符串的开头。
reset() - 类 java.nio.Buffer 中的方法
将此缓冲区的位置重置为以前标记的位置。
reset() - 类 java.nio.charset.CharsetDecoder 中的方法
重置此解码器，清除所有内部状态。
reset() - 类 java.nio.charset.CharsetEncoder 中的方法
重置此编码器，清除所有内部状态。
reset() - 类 java.security.MessageDigest 中的方法
重置摘要以供再次使用。
reset() - 类 java.text.CollationElementIterator 中的方法
将光标重置于字符串开始处。
reset() - 类 java.util.concurrent.CyclicBarrier 中的方法
将屏障重置为其初始状态。
reset() - 类 java.util.logging.LogManager 中的方法
重置日志配置。
reset() - 类 java.util.regex.Matcher 中的方法
重置匹配器。
reset(CharSequence) - 类 java.util.regex.Matcher 中的方法
重置此具有新输入序列的匹配器。
reset() - 类 java.util.Scanner 中的方法
重置此扫描器。
reset() - 类 java.util.zip.Adler32 中的方法
将校验和重置为初始值。
reset() - 接口 java.util.zip.Checksum 中的方法
将校验和重置为其初始值。
reset() - 类 java.util.zip.CRC32 中的方法
将 CRC-32 重置为初始值。
reset() - 类 java.util.zip.Deflater 中的方法
重置 deflater 以处理新的输入数据集。
reset() - 类 java.util.zip.DeflaterInputStream 中的方法
不支持此操作。
reset() - 类 java.util.zip.Inflater 中的方法
重置 inflater 以处理新的输入数据集。
reset() - 类 java.util.zip.InflaterInputStream 中的方法
将此流重新定位到对此输入流最后调用 mark 方法时的位置。
reset() - 类 javax.crypto.Mac 中的方法
重置此 Mac 对象。
reset() - 类 javax.imageio.ImageReader 中的方法
将 ImageReader 恢复到其初始状态。
reset() - 类 javax.imageio.ImageWriter 中的方法
将 ImageWriter 恢复到其初始状态。
reset() - 类 javax.imageio.metadata.IIOMetadata 中的方法
将此对象中存储的所有数据重置为默认值，通常为此对象构造后立即处于的状态，尽管精确的语义是特定于插件的。
reset() - 接口 javax.imageio.stream.ImageInputStream 中的方法
返回在最近一次非匹配地调用 mark 时指向上一个位置（包括位偏移量）的流指针。
reset() - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
根据标记的堆栈重置当前流字节和位位置。
reset() - 类 javax.sound.sampled.AudioInputStream 中的方法
将此音频输入流重新定位到上一次调用其 mark 方法时的位置。
reset() - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.reset，以重置进度监视器以及流。
RESET - 类 javax.swing.text.html.FormView 中的静态变量
已过时。 从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值
reset() - 类 javax.xml.bind.util.ValidationEventCollector 中的方法
清除所有收集的错误和警告。
reset() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此 XMLGregorianCalendar 重设为其原始值。
reset() - 类 javax.xml.parsers.DocumentBuilder 中的方法
将此 DocumentBuilder 重置为其原始配置。
reset() - 类 javax.xml.parsers.SAXParser 中的方法
将此 SAXParser 重置为其原始配置。
reset() - 类 javax.xml.transform.Transformer 中的方法
将此 Transformer 重置为其初始配置。
reset() - 类 javax.xml.validation.Validator 中的方法
将此 Validator 重置为其初始配置。
reset() - 接口 javax.xml.xpath.XPath 中的方法
将此 XPath 重置为其初始配置。
reset() - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
重设此名称空间支持对象，以便重新使用。
RESET_FLAGS_ALREADY_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
此标志用来重新设置 alreadyNotifieds 监视器属性。
resetAllControllers() - 接口 javax.sound.midi.MidiChannel 中的方法
将所有实现的控件重置为其默认值。
resetChoosableFileFilters() - 类 javax.swing.JFileChooser 中的方法
将可选择文件过滤器列表重置为其开始状态。
resetInputValue() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
基于 inputComponent 中的值，设置接收者为其提供外观的选项窗格中的输入值。
resetKeyboardActions() - 类 javax.swing.JComponent 中的方法
注销首层 InputMaps 和 ActionMap 中的所有绑定。
resetLayoutManager() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
基于方向重置布局管理器，并利用 invalidateLayout 传递其消息以拉入适当的 Component。
resetMarksAtZero() - 类 javax.swing.text.GapContent 中的方法
重新设置具有 0 偏移量的所有标记，使其也有零索引。
resetPeakThreadCount() - 接口 java.lang.management.ThreadMXBean 中的方法
将峰值线程计数重置为当前活动线程的数量。
resetPeakUsage() - 接口 java.lang.management.MemoryPoolMXBean 中的方法
将此内存池的峰值内存使用量统计重置为当前内存使用量。
resetRecognizer() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
重置 Recognizer，如果 Recognizer 当前正在识别一个动作，则忽略。
resetRowSelection() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
更新此对象从 TreePath 到行的映射关系。
resetRowSelection() - 接口 javax.swing.tree.TreeSelectionModel 中的方法
更新此对象从 TreePath 到行的映射关系。
resetSizeAt(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
在传入位置重置 Component 的大小。
resetSyntax() - 类 java.io.StreamTokenizer 中的方法
重置此标记生成器的语法表，使所有字符都成为“普通”字符。
resetToPreferredSizes() - 类 javax.swing.JSplitPane 中的方法
以子组件的首选大小为基础调整 JSplitPane 的布局。
resetToPreferredSizes() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
标记接收者，以便下一次布置此实例时它将请求首选大小。
resetToPreferredSizes(JSplitPane) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
传递消息以重置首选大小。
resetToPreferredSizes(JSplitPane) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 resetToPreferredSizes 方法。
resetToPreferredSizes(JSplitPane) - 类 javax.swing.plaf.SplitPaneUI 中的方法
传递消息，以便基于子组件的首选大小重新布置 JSplitPane。
resetViewPort() - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的方法
reshape(int, int, int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
reshape(int, int, int, int) - 类 java.awt.Rectangle 中的方法
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
reshape(int, int, int, int) - 类 java.awt.Window 中的方法
已过时。 从 JDK 1.1 版开始，由 setBounds(int, int, int, int) 取代。
reshape(int, int, int, int) - 类 javax.swing.JComponent 中的方法
已过时。 从 JDK 5 开始，由 Component.setBounds(int, int, int, int) 取代。

移动此组件并调整其大小。

reshape(int, int, int, int) - 类 javax.swing.JInternalFrame 中的方法
移动此组件并调整其大小。
reshape(int, int, int, int) - 类 javax.swing.JViewport 中的方法
设置此视口的边界。
RESIZABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象的大小不固定。
resizable - 类 javax.swing.JInternalFrame 中的变量
可以更改窗体的大小。
resize(int, int) - 类 java.applet.Applet 中的方法
请求调整此 applet 的大小。
resize(Dimension) - 类 java.applet.Applet 中的方法
请求调整此 applet 的大小。
resize(int, int) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
resize(Dimension) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setSize(Dimension) 取代。
resize(int, int) - 类 java.awt.Rectangle 中的方法
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
RESIZE_NONE - 类 javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener 中的变量
RESIZE_WEIGHT_PROPERTY - 类 javax.swing.JSplitPane 中的静态变量
绑定 weight 属性。
resizeAndRepaint() - 类 javax.swing.JTable 中的方法
等效于先调用 revalidate 再调用 repaint。
resizeAndRepaint() - 类 javax.swing.table.JTableHeader 中的方法
确定头的大小并将其标记为需要显示。
resizedPostingDisableCount - 类 javax.swing.table.TableColumn 中的变量
已过时。 从 Java 2 platform v1.3 开始
resizeFrame(JComponent, int, int, int, int) - 类 javax.swing.DefaultDesktopManager 中的方法
使用新值调用 setBoundsForFrame。
resizeFrame(JComponent, int, int, int, int) - 接口 javax.swing.DesktopManager 中的方法
用户已经重新调整组件的大小。
resizingAllowed - 类 javax.swing.table.JTableHeader 中的变量
如果为 true，则允许用户调整各列的大小；默认值为 true。
resizingColumn - 类 javax.swing.table.JTableHeader 中的变量
进行大小调整的列的索引。
resolution - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的定时精度。
resolution - 类 javax.sound.midi.Sequence 中的变量
sequence 的定时精度。
ResolutionSyntax - javax.print.attribute 中的 类
类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。
ResolutionSyntax(int, int, int) - 类 javax.print.attribute.ResolutionSyntax 的构造方法
根据给定项构造一个新的分辨率属性。
resolve(URI) - 类 java.net.URI 中的方法
根据此 URI 解析给定的 URI。
resolve(String) - 类 java.net.URI 中的方法
解析给定的字符串，然后在此 URI 的基础上构造一个新的 URI。
resolve(String, String) - 接口 javax.xml.transform.URIResolver 中的方法
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。
resolve(NameComponent[]) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
解析操作是指检索绑定到给定上下文中名称的对象的过程。
resolve(NameComponent[]) - 类 org.omg.CosNaming._NamingContextStub 中的方法
解析操作是指检索绑定到给定上下文中名称的对象的过程。
resolve(NameComponent[]) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
解析操作是指检索绑定到给定上下文中名称的对象的过程。
resolve_initial_references(String) - 类 org.omg.CORBA.ORB 中的方法
根据可用初始服务名称集解析特定对象引用。
resolve_initial_references(String) - 接口 org.omg.PortableInterceptor.ORBInitInfoOperations 中的方法
等同于 ORB.resolve_initial_references。
resolve_str(String) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作将“字符串化的”名称解析为对象引用。
resolve_str(String) - 接口 org.omg.CosNaming.NamingContextExtOperations 中的方法
此操作将“字符串化的”名称解析为对象引用。
ResolveAttribute - 接口 javax.swing.text.AttributeSet 中的静态变量
用于标识解析父集合属性集（如果已定义）的属性名。
ResolveAttribute - 类 javax.swing.text.StyleConstants 中的静态变量
用来标识属性的解析父集的属性名（如果定义了属性的解析父集）。
resolveClass(ObjectStreamClass) - 类 java.io.ObjectInputStream 中的方法
加载指定流类描述的本地等价类。
resolveClass(Class<?>) - 类 java.lang.ClassLoader 中的方法
链接指定的类。
resolvedName - 异常 javax.naming.NamingException 中的变量
包含已成功解析的名称部分。
resolvedObj - 异常 javax.naming.NamingException 中的变量
包含一个对象，已成功解析的名称部分进行到该对象。
resolvedObj - 类 javax.naming.spi.ResolveResult 中的变量
该字段包含已成功解析成的 Object。
resolveEntity(String, String, String, String) - 接口 javax.xml.stream.XMLResolver 中的方法
检索资源。
resolveEntity(String, String) - 接口 org.xml.sax.EntityResolver 中的方法
允许应用程序解析外部实体。
resolveEntity(String, String, String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
resolveEntity(String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
resolveEntity(String, String, String, String) - 接口 org.xml.sax.ext.EntityResolver2 中的方法
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。
resolveEntity(String, String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 解析外部实体。
resolveEntity(String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
解析外部实体。
resolveEntity(String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个外部实体解析。
resolveFunction(QName, int) - 接口 javax.xml.xpath.XPathFunctionResolver 中的方法
在可用的函数集中查找函数。
resolveObject(Object) - 类 java.io.ObjectInputStream 中的方法
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。
resolveProxyClass(String[]) - 类 java.io.ObjectInputStream 中的方法
返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。
Resolver - javax.naming.spi 中的 接口
此接口表示用于名称解析的“中间上下文”。
RESOLVER - 类 javax.xml.stream.XMLInputFactory 中的静态变量
用于设置/获取 XMLResolver 实现的属性。
resolveResource(String, String, String, String, String) - 接口 org.w3c.dom.ls.LSResourceResolver 中的方法
允许应用程序解析外部资源。
ResolveResult - javax.naming.spi 中的 类
此类表示解析某一名称的结果。
ResolveResult() - 类 javax.naming.spi.ResolveResult 的构造方法
构造一个 ResolveResult 实例，使已解析对象和剩余名称都被初始化为 null。
ResolveResult(Object, String) - 类 javax.naming.spi.ResolveResult 的构造方法
构造一个新的 ResolveResult 实例，该实例由已解析对象和剩余未解析组件组成。
ResolveResult(Object, Name) - 类 javax.naming.spi.ResolveResult 的构造方法
构造一个新的 ResolveResult 实例，该实例由已解析 Object 和剩余名称组成。
resolveToClass(Name, Class<? extends Context>) - 接口 javax.naming.spi.Resolver 中的方法
部分解析某一名称。
resolveToClass(String, Class<? extends Context>) - 接口 javax.naming.spi.Resolver 中的方法
部分解析某一名称。
resolveVariable(QName) - 接口 javax.xml.xpath.XPathVariableResolver 中的方法
在可用的变量集中查找变量。
Resource - javax.annotation 中的 注释类型
Resource 注释标记应用程序所需的资源。
Resource.AuthenticationType - javax.annotation 中的 枚举
资源的两种可能验证类型。
ResourceBundle - java.util 中的 类
资源包包含特定于语言环境的对象。
ResourceBundle() - 类 java.util.ResourceBundle 的构造方法
唯一的构造方法（由子类构造方法调用，通常是隐式的）。
ResourceBundle.Control - java.util 中的 类
ResourceBundle.Control 定义一个回调方法集，它在包加载进程中由 ResourceBundle.getBundle 工厂方法调用。
ResourceBundle.Control() - 类 java.util.ResourceBundle.Control 的构造方法
唯一的构造方法。
Resources - javax.annotation 中的 注释类型
此类用于允许多个资源声明。
RESOURCES_ARE_NOT_READY - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
在候选作业的任何物理打印机上，至少有一个该作业所需的资源（例如介质、字体、资源对象等）未就绪。
Response<T> - javax.xml.ws 中的 接口
Response 接口提供一些方法，用来获得为响应操作调用而发送的消息的净荷和上下文。
response_expected() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
指示是否希望响应。
ResponseCache - java.net 中的 类
表示 URLConnection 缓存的实现。
ResponseCache() - 类 java.net.ResponseCache 的构造方法
responseCode() - 异常 java.net.HttpRetryException 中的方法
返回 http 响应代码
responseCode - 类 java.net.HttpURLConnection 中的变量
表示三位字数的 HTTP 状态码 (Status-Code) 的 int。
ResponseHandler - org.omg.CORBA.portable 中的 接口
此接口由 ORB 在调用期间提供给 servant，允许 servant 稍后检索用来返回调用结果的 OutputStream。
responseMessage - 类 java.net.HttpURLConnection 中的变量
HTTP 响应消息。
ResponseWrapper - javax.xml.ws 中的 注释类型
此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
rest_of_name - 异常 org.omg.CosNaming.NamingContextPackage.CannotProceed 中的变量
rest_of_name - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 中的变量
restart() - 类 javax.swing.Timer 中的方法
重新启动 Timer，取消所有挂起的触发并使它按初始延迟触发。
RESTORE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
restoreAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
restoreOriginal() - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象还原成其原始值，即执行上一组更改前的值。
restoreState(Hashtable<?, ?>) - 接口 javax.swing.undo.StateEditable 中的方法
收到此消息时，接收者应从 state 中提取任何相关状态。
restoreSubcomponentFocus() - 类 javax.swing.JInternalFrame 中的方法
请求内部窗体将焦点还原到具有焦点的最后一个子组件。
Result - javax.xml.transform 中的 接口
实现此接口的对象包含构建转换结果树所需的信息。
result() - 类 org.omg.CORBA.Request 中的方法
检索包含该方法的返回值的 NamedValue 对象。
result(Any) - 类 org.omg.CORBA.ServerRequest 中的方法
已过时。 使用方法 set_result
result() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
返回一个 any，它包含该操作调用的结果。
ResultSet - java.sql 中的 接口
表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
ResultSetMetaData - java.sql 中的 接口
可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。
resume() - 类 java.lang.Thread 中的方法
已过时。 该方法只与 Thread.suspend() 一起使用，但 Thread.suspend() 已经遭到反对，因为它具有死锁倾向。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
resume() - 类 java.lang.ThreadGroup 中的方法
已过时。 此方法只用于联合 Thread.suspend 和 ThreadGroup.suspend 时，因为它们所固有的容易导致死锁的特性，所以两者都已废弃。有关详细信息，请参阅 Thread.suspend()。
RETAIN - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态变量
retainAll(Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
仅保留指定子对象（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
retainAll(Collection<?>) - 类 java.util.AbstractCollection 中的方法
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
retainAll(Collection<?>) - 接口 java.util.Collection 中的方法
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
retainAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
只保留此列表中包含在指定 collection 中的元素。
retainAll(Collection<?>) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
仅保留此 set 中那些包含在指定 collection 中的元素。
retainAll(Collection<?>) - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 false。
retainAll(Collection<?>) - 接口 java.util.List 中的方法
仅在列表中保留指定 collection 中所包含的元素（可选操作）。
retainAll(Collection<?>) - 接口 java.util.Set 中的方法
仅保留 set 中那些包含在指定 collection 中的元素（可选操作）。
retainAll(Collection<?>) - 类 java.util.Vector 中的方法
在此向量中仅保留包含在指定 Collection 中的元素。
Retention - java.lang.annotation 中的 注释类型
指示注释类型的注释要保留多久。
RetentionPolicy - java.lang.annotation 中的 枚举
注释保留策略。
retransformClasses(Class<?>...) - 接口 java.lang.instrument.Instrumentation 中的方法
重转换提供的类集。
RetrievalMethod - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML RetrievalMethod 元素的表示形式。
retrieveAllRoles() - 接口 javax.management.relation.Relation 中的方法
返回关系中的所有角色，不检查读取模式。
retrieveAllRoles() - 类 javax.management.relation.RelationSupport 中的方法
返回关系中的所有角色，不检查读取模式。
retryReferral() - 异常 javax.naming.ReferralException 中的方法
检索当前正被处理的引用。
RETURN_GENERATED_KEYS - 接口 java.sql.Statement 中的静态变量
该常量指示生成的键应该可用于获取。
return_value() - 类 org.omg.CORBA.Request 中的方法
返回包含方法结果值的 Any 对象。
REUSE - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定是否重用以前已验证过的会话信息。
REV - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
revalidate() - 类 java.awt.Component.BltBufferStrategy 中的方法
如果绘制缓冲区已经丢失，则恢复它
revalidate() - 类 java.awt.Component.FlipBufferStrategy 中的方法
如果绘制缓冲区已丢失，则将其还原。
revalidate() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
revalidate() - 类 javax.swing.JComponent 中的方法
支持推迟的自动布局。
revalidate() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
revalidate() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
REVERB - 类 javax.sound.sampled.EnumControl.Type 中的静态变量
表示对一组可能的回响设置的控件。
REVERB_RETURN - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上后回响 (post-reverb) 音量的控件。
REVERB_SEND - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上预回响 (pre-reverb) 音量的控件。
ReverbType - javax.sound.sampled 中的 类
ReverbType 类提供用于访问应用于音频信号的各种回响设置的方法。
ReverbType(String, int, float, int, float, int) - 类 javax.sound.sampled.ReverbType 的构造方法
构造具有指定回响参数值的新回响类型。
reverse(int) - 类 java.lang.Integer 中的静态方法
返回通过反转指定 int 值的二进制补码表示形式中位的顺序而获得的值。
reverse(long) - 类 java.lang.Long 中的静态方法
返回通过反转指定 long 值的二进制补码表示形式中位的顺序而获得的值。
reverse() - 类 java.lang.StringBuffer 中的方法
reverse() - 类 java.lang.StringBuilder 中的方法
reverse(List<?>) - 类 java.util.Collections 中的静态方法
反转指定列表中元素的顺序。
REVERSE_LANDSCAPE - 类 java.awt.print.PageFormat 中的静态变量
原点位于纸张的右上方，x 的方向从上到下，y 的方向从右到左。
REVERSE_LANDSCAPE - 类 javax.print.attribute.standard.OrientationRequested 中的静态变量
沿介质的长边描绘内容，但方式正好与横向相反。
REVERSE_PORTRAIT - 类 javax.print.attribute.standard.OrientationRequested 中的静态变量
沿介质的短边描绘内容，但方式正好与纵向相反。
reverseBytes(char) - 类 java.lang.Character 中的静态方法
返回通过反转指定 char 值中的字节顺序而获得的值。
reverseBytes(int) - 类 java.lang.Integer 中的静态方法
返回通过反转指定 int 值的二进制补码表示形式中字节的顺序而获得的值。
reverseBytes(long) - 类 java.lang.Long 中的静态方法
返回通过反转指定 long 值的二进制补码表示形式中字节的顺序而获得的值。
reverseBytes(short) - 类 java.lang.Short 中的静态方法
返回通过反转指定 short 值的二进制补码表示形式中字节的顺序而获得的值。
reverseOrder() - 类 java.util.Collections 中的静态方法
返回一个比较器，它强行逆转实现了 Comparable 接口的对象 collection 的自然顺序。
reverseOrder(Comparator<T>) - 类 java.util.Collections 中的静态方法
返回一个比较器，它强行逆转指定比较器的顺序。
REVERT - 类 javax.swing.JFormattedTextField 中的静态变量
标识丢失焦点时，应该将编辑的值恢复为 JFormattedTextField 上所设当前值的常量。
revokeService(Class, BeanContextServiceProvider, boolean) - 接口 java.beans.beancontext.BeanContextServices 中的方法
希望从此上下文中移除当前已注册服务的 BeanContextServiceProvider 可以通过调用此方法实现移除。
revokeService(Class, BeanContextServiceProvider, boolean) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
移除服务。
rewind() - 类 java.nio.Buffer 中的方法
重绕此缓冲区。
rewind() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 将内部指针移动到第一个组件。
rewind() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynStructStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
等效于 seek(0)。
rewind() - 类 org.omg.DynamicAny._DynValueStub 中的方法
等效于 seek(0)。
rewind() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
等效于 seek(0)。
RFC1779 - 类 javax.security.auth.x500.X500Principal 中的静态变量
标识名的 RFC 1779 字符串格式。
RFC2253 - 类 javax.security.auth.x500.X500Principal 中的静态变量
标识名的 RFC 2253 字符串格式。
RGBImageFilter - java.awt.image 中的 类
此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。
RGBImageFilter() - 类 java.awt.image.RGBImageFilter 的构造方法
RGBtoHSB(int, int, int, float[]) - 类 java.awt.Color 中的静态方法
将默认 RGB 模式指定的颜色分量转换为等价的色调、饱和度和亮度值的集合，这三个值是 HSB 模型的三个分量。
RIGHT - 类 java.awt.Event 中的静态变量
Right Arrow 键，一个非 ASCII 操作键。
RIGHT - 类 java.awt.FlowLayout 中的静态变量
此值指示每一行组件都应该是右对齐的。
right - 类 java.awt.Insets 中的变量
右边的 inset。
RIGHT - 类 java.awt.Label 中的静态变量
指示标签文本应右对齐。
right - 类 javax.swing.border.EmptyBorder 中的变量
RIGHT - 类 javax.swing.border.TitledBorder 中的静态变量
将标题文本置于边框线的右边。
RIGHT - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个 Component 到另一个 Component 的右边。
RIGHT - 接口 javax.swing.SwingConstants 中的静态变量
用于指定框右侧位置的框方向常量。
RIGHT_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentX 的易于使用的常量。
RIGHT_OUTER_JOIN - 接口 javax.sql.rowset.JoinRowSet 中的静态变量
ANSI 风格的 JOIN，提供两个表之间的右外联合 (right outer join)。
RIGHT_TO_LEFT - 类 java.awt.ComponentOrientation 中的静态变量
各项从右到左布局，各行从上到下，示例：阿拉伯语、希伯来语。
rightButton - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
用于快速切换右边组件的按钮。
rightChildIndent - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
添加到 leftChildIndent 以确定将绘制单元格内容的位置的距离。
rightComponent - 类 javax.swing.JSplitPane 中的变量
右边或者底部的组件。
RightIndent - 类 javax.swing.text.StyleConstants 中的静态变量
段落右边的缩进量。
rightKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
rightKey - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
rightKey - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
已过时。 从 Java 2 平台 v1.3 开始。
rint(double) - 类 java.lang.Math 中的静态方法
返回最接近参数并等于某一整数的 double 值。
rint(double) - 类 java.lang.StrictMath 中的静态方法
返回最接近参数并等于某一整数的 double 值。
RIPEMD160 - 接口 javax.xml.crypto.dsig.DigestMethod 中的静态变量
RIPEMD-160 摘要方法的算法 URI。
RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE - 类 javax.management.remote.rmi.RMIConnectorServer 中的静态变量
属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIClientSocketFactory。
RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE - 类 javax.management.remote.rmi.RMIConnectorServer 中的静态变量
属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIServerSocketFactory。
RMIClassLoader - java.rmi.server 中的 类
RMIClassLoader 包含支持用 RMI 进行动态类加载的静态方法。
RMIClassLoaderSpi - java.rmi.server 中的 类
RMIClassLoaderSpi 是 RMIClassLoader 的服务提供者接口。
RMIClassLoaderSpi() - 类 java.rmi.server.RMIClassLoaderSpi 的构造方法
RMIClientSocketFactory - java.rmi.server 中的 接口
RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。
RMIConnection - javax.management.remote.rmi 中的 接口
RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。
RMIConnectionImpl - javax.management.remote.rmi 中的 类
RMIConnection 接口的实现。
RMIConnectionImpl(RMIServerImpl, String, ClassLoader, Subject, Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnectionImpl 的构造方法
构造新的 RMIConnection。
RMIConnectionImpl_Stub - javax.management.remote.rmi 中的 类
RMIConnectionImpl_Stub(RemoteRef) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 的构造方法
RMIConnector - javax.management.remote.rmi 中的 类
一个到远程 RMI 连接器的连接。
RMIConnector(JMXServiceURL, Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnector 的构造方法
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。
RMIConnector(RMIServer, Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnector 的构造方法
用给定的 RMI stub 构造一个 RMIConnector。
RMIConnectorServer - javax.management.remote.rmi 中的 类
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。
RMIConnectorServer(JMXServiceURL, Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnectorServer 的构造方法
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - 类 javax.management.remote.rmi.RMIConnectorServer 的构造方法
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL, Map<String, ?>, RMIServerImpl, MBeanServer) - 类 javax.management.remote.rmi.RMIConnectorServer 的构造方法
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMICustomMaxStreamFormat - org.omg.IOP 中的 接口
org/omg/IOP/RMICustomMaxStreamFormat.java。
RMIFailureHandler - java.rmi.server 中的 接口
RMIFailureHandler 可以通过 RMISocketFactory.setFailureHandler 调用注册。
RMIIIOPServerImpl - javax.management.remote.rmi 中的 类
一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
RMIIIOPServerImpl(Map<String, ?>) - 类 javax.management.remote.rmi.RMIIIOPServerImpl 的构造方法
创建新的 RMIServerImpl。
RMIJRMPServerImpl - javax.management.remote.rmi 中的 类
一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
RMIJRMPServerImpl(int, RMIClientSocketFactory, RMIServerSocketFactory, Map<String, ?>) - 类 javax.management.remote.rmi.RMIJRMPServerImpl 的构造方法
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。
RMISecurityException - java.rmi 中的 异常
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
RMISecurityException(String) - 异常 java.rmi.RMISecurityException 的构造方法
已过时。 无替换版本
RMISecurityException(String, String) - 异常 java.rmi.RMISecurityException 的构造方法
已过时。 无替换版本
RMISecurityManager - java.rmi 中的 类
由使用下载的代码的 RMI 应用程序使用的 SecurityManager 的子类。
RMISecurityManager() - 类 java.rmi.RMISecurityManager 的构造方法
构造新的 RMISecurityManager。
RMIServer - javax.management.remote.rmi 中的 接口
用于建立到 RMI 连接器的连接的 RMI 对象。
RMIServerImpl - javax.management.remote.rmi 中的 类
表示连接器服务器的 RMI 对象。
RMIServerImpl(Map<String, ?>) - 类 javax.management.remote.rmi.RMIServerImpl 的构造方法
构造一个新的 RMIServerImpl。
RMIServerImpl_Stub - javax.management.remote.rmi 中的 类
RMIServerImpl_Stub(RemoteRef) - 类 javax.management.remote.rmi.RMIServerImpl_Stub 的构造方法
RMIServerSocketFactory - java.rmi.server 中的 接口
RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。
RMISocketFactory - java.rmi.server 中的 类
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。
RMISocketFactory() - 类 java.rmi.server.RMISocketFactory 的构造方法
构造一个 RMISocketFactory。
Robot - java.awt 中的 类
此类用于为测试自动化、自运行演示程序和其他需要控制鼠标和键盘的应用程序生成本机系统输入事件。
Robot() - 类 java.awt.Robot 的构造方法
在基本屏幕坐标系中构造一个 Robot 对象。
Robot(GraphicsDevice) - 类 java.awt.Robot 的构造方法
为给定屏幕设备创建一个 Robot 。
Role - javax.management.relation 中的 类
表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。
Role(String, List<ObjectName>) - 类 javax.management.relation.Role 的构造方法
创建一个新的 Role 对象。
ROLE_CARDINALITY_INFINITY - 类 javax.management.relation.RoleInfo 中的静态变量
指定无限的容量。
ROLE_NOT_READABLE - 类 javax.management.relation.RoleStatus 中的静态变量
试图读取不可读属性时的问题类型。
ROLE_NOT_WRITABLE - 类 javax.management.relation.RoleStatus 中的静态变量
试图更新不可写属性时的问题类型。
RoleInfo - javax.management.relation 中的 类
RoleInfo 概括介绍关系类型中的角色。
RoleInfo(String, String, boolean, boolean, int, int, String) - 类 javax.management.relation.RoleInfo 的构造方法
构造方法。
RoleInfo(String, String, boolean, boolean) - 类 javax.management.relation.RoleInfo 的构造方法
构造方法。
RoleInfo(String, String) - 类 javax.management.relation.RoleInfo 的构造方法
构造方法。
RoleInfo(RoleInfo) - 类 javax.management.relation.RoleInfo 的构造方法
复制构造方法。
RoleInfoNotFoundException - javax.management.relation 中的 异常
给定的关系类型中不存在带指定名称的角色信息时引发此异常。
RoleInfoNotFoundException() - 异常 javax.management.relation.RoleInfoNotFoundException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RoleInfoNotFoundException(String) - 异常 javax.management.relation.RoleInfoNotFoundException 的构造方法
异常中放置了给定消息的构造方法。
RoleList - javax.management.relation 中的 类
RoleList 表示角色（Role 对象）的列表。
RoleList() - 类 javax.management.relation.RoleList 的构造方法
构造一个空的 RoleList。
RoleList(int) - 类 javax.management.relation.RoleList 的构造方法
构造一个具有指定初始容量的空 RoleList。
RoleList(List<Role>) - 类 javax.management.relation.RoleList 的构造方法
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。
RoleNotFoundException - javax.management.relation 中的 异常
关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。
RoleNotFoundException() - 异常 javax.management.relation.RoleNotFoundException 的构造方法
默认的构造方法，其异常中未放置任何消息。
RoleNotFoundException(String) - 异常 javax.management.relation.RoleNotFoundException 的构造方法
异常中放置了给定消息的构造方法。
RoleResult - javax.management.relation 中的 类
表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。
RoleResult(RoleList, RoleUnresolvedList) - 类 javax.management.relation.RoleResult 的构造方法
构造方法。
RoleStatus - javax.management.relation 中的 类
此类描述访问某个角色时可能遇到的各种问题。
RoleStatus() - 类 javax.management.relation.RoleStatus 的构造方法
RoleUnresolved - javax.management.relation 中的 类
表示未解析的角色：由于存在问题而无法从关系中检索到的角色。
RoleUnresolved(String, List<ObjectName>, int) - 类 javax.management.relation.RoleUnresolved 的构造方法
构造方法。
RoleUnresolvedList - javax.management.relation 中的 类
RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。
RoleUnresolvedList() - 类 javax.management.relation.RoleUnresolvedList 的构造方法
构造一个空的 RoleUnresolvedList。
RoleUnresolvedList(int) - 类 javax.management.relation.RoleUnresolvedList 的构造方法
构造一个具有指定初始容量的空 RoleUnresolvedList。
RoleUnresolvedList(List<RoleUnresolved>) - 类 javax.management.relation.RoleUnresolvedList 的构造方法
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。
roleValueToString(List<ObjectName>) - 类 javax.management.relation.Role 中的静态方法
返回给定角色值的字符串。
roll(int, boolean) - 类 java.util.Calendar 中的方法
在给定的时间字段上添加或减去（上/下）单个时间单元，不更改更大的字段。
roll(int, int) - 类 java.util.Calendar 中的方法
向指定日历字段添加指定（有符号的）时间量，不更改更大的字段。
roll(int, boolean) - 类 java.util.GregorianCalendar 中的方法
在给定的时间字段上添加或减去（上/下）单个时间单元，不更改更大的字段。
roll(int, int) - 类 java.util.GregorianCalendar 中的方法
向指定日历字段添加有符号的时间量，不更改更大的字段。
rollback() - 接口 java.sql.Connection 中的方法
取消在当前事务中进行的所有更改，并释放此 Connection 对象当前持有的所有数据库锁。
rollback(Savepoint) - 接口 java.sql.Connection 中的方法
取消所有设置给定 Savepoint 对象之后进行的更改。
rollback() - 接口 javax.sql.rowset.CachedRowSet 中的方法
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
rollback(Savepoint) - 接口 javax.sql.rowset.CachedRowSet 中的方法
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
rollback() - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
rollback(Savepoint) - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
rollback() - 接口 javax.sql.rowset.spi.TransactionalWriter 中的方法
撤消在当前事务中进行的所有更改。
rollback(Savepoint) - 接口 javax.sql.rowset.spi.TransactionalWriter 中的方法
撤消在给定 Savepoint 对象之前所进行的当前事务中的所有更改。
rollback(Xid) - 接口 javax.transaction.xa.XAResource 中的方法
通知资源管理器回滚代表事务分支执行的工作。
ROLLOVER - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“翻转的”位，该位指示鼠标位于按钮上。
ROLLOVER_ENABLED_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识从启用翻转到禁用翻转或者从禁用翻转到启用翻转的更改。
ROLLOVER_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对光标移动到按钮上时使用的图标的更改。
ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对光标移动到按钮上并选定该按钮时使用的图标的更改。
rolloverColumnUpdated(int, int) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
每次更新表标题中的翻转列时调用此方法。
rolloverListener - 类 javax.swing.plaf.metal.MetalToolBarUI 中的变量
此受保护的字段是特定于实现的。
ROMAN_BASELINE - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形的原点与行的罗马字体基线对齐。
ROMAN_BASELINE - 类 java.awt.Font 中的静态变量
布置文本时，在大多数 Roman 脚本中使用的基线。
ROOT - 类 java.util.Locale 中的静态变量
用于表示根语言环境的有用常量。
root - 类 javax.swing.tree.DefaultTreeModel 中的变量
树的根。
ROOT_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
一个专用窗格，带有玻璃窗格和作为其子窗格的分层窗格。
ROOT_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
RootPane 的 region。
ROOT_PANE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
ROOT_VISIBLE_PROPERTY - 类 javax.swing.JTree 中的静态变量
rootVisible 的绑定属性名称。
rootException - 异常 javax.naming.NamingException 中的变量
包含导致抛出此 NamingException 的原始异常。
rootPane - 类 javax.swing.JApplet 中的变量
rootPane - 类 javax.swing.JDialog 中的变量
rootPane - 类 javax.swing.JFrame 中的变量
JRootPane 实例管理此窗体的 contentPane 和可选的 menuBar，以及 glassPane。
rootPane - 类 javax.swing.JInternalFrame 中的变量
JRootPane 实例，它管理此内部窗体的内容窗格和可选菜单栏以及玻璃窗格（glass pane）。
rootPane - 类 javax.swing.JWindow 中的变量
管理此框架的 contentPane 和可选 menuBar 以及 glassPane 的 JRootPane 实例。
rootPaneCheckingEnabled - 类 javax.swing.JApplet 中的变量
如果为 true，则对 add 和 setLayout 的调用将转发给 contentPane。
rootPaneCheckingEnabled - 类 javax.swing.JDialog 中的变量
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
rootPaneCheckingEnabled - 类 javax.swing.JFrame 中的变量
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
rootPaneCheckingEnabled - 类 javax.swing.JInternalFrame 中的变量
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
rootPaneCheckingEnabled - 类 javax.swing.JWindow 中的变量
如果为 true，则对 add 和 setLayout 的调用将转发到 contentPane。
RootPaneContainer - javax.swing 中的 接口
此接口由具有单个 JRootPane 子组件的组件来实现，这些子组件包括：JDialog、JFrame、JWindow、JApplet、JInternalFrame。
RootPaneUI - javax.swing.plaf 中的 类
JRootPane 的可插入外观界面。
RootPaneUI() - 类 javax.swing.plaf.RootPaneUI 的构造方法
rootVisible - 类 javax.swing.JTree 中的变量
如果显示根节点，则为 true；如果其子节点为最高可见节点，则为 false。
rootVisible - 类 javax.swing.tree.AbstractLayoutCache 中的变量
如果显示根节点，则为 True，如果其子节点是最高可视节点，则为 false。
rotate(double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与旋转变换。
rotate(double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与绕锚点旋转坐标的变换。
rotate(double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与根据旋转向量旋转坐标的变换。
rotate(double, double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与根据旋转向量绕锚点旋转坐标的变换。
rotate(double) - 类 java.awt.Graphics2D 中的方法
将当前的 Graphics2D Transform 与旋转转换连接。
rotate(double, double, double) - 类 java.awt.Graphics2D 中的方法
将当前的 Graphics2D Transform 与平移后的旋转转换连接。
rotate(List<?>, int) - 类 java.util.Collections 中的静态方法
根据指定的距离轮换指定列表中的元素。
rotateInsets(Insets, Insets, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的静态方法
rotateLeft(int, int) - 类 java.lang.Integer 中的静态方法
返回根据指定的位数循环左移指定的 int 值的二进制补码表示形式而得到的值。
rotateLeft(long, int) - 类 java.lang.Long 中的静态方法
返回根据指定的位数循环左移指定的 long 值的二进制补码表示形式而得到的值。
rotateRight(int, int) - 类 java.lang.Integer 中的静态方法
返回根据指定的位数循环右移指定的 int 值的二进制补码表示形式而得到的值。
rotateRight(long, int) - 类 java.lang.Long 中的静态方法
返回根据指定的位数循环右移指定的 long 值的二进制补码表示形式而得到的值。
rotateTabRuns(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout 中的方法
rotateTabRuns(int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout 中的方法
round(float) - 类 java.lang.Math 中的静态方法
返回最接近参数的 int。
round(double) - 类 java.lang.Math 中的静态方法
返回最接近参数的 long。
round(float) - 类 java.lang.StrictMath 中的静态方法
返回最接近参数的 int。
round(double) - 类 java.lang.StrictMath 中的静态方法
返回最接近参数的 long。
round(MathContext) - 类 java.math.BigDecimal 中的方法
返回根据 MathContext 设置进行舍入后的 BigDecimal。
ROUND_CEILING - 类 java.math.BigDecimal 中的静态变量
接近正无穷大的舍入模式。
ROUND_DOWN - 类 java.math.BigDecimal 中的静态变量
接近零的舍入模式。
ROUND_FLOOR - 类 java.math.BigDecimal 中的静态变量
接近负无穷大的舍入模式。
ROUND_HALF_DOWN - 类 java.math.BigDecimal 中的静态变量
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则为上舍入的舍入模式。
ROUND_HALF_EVEN - 类 java.math.BigDecimal 中的静态变量
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则向相邻的偶数舍入。
ROUND_HALF_UP - 类 java.math.BigDecimal 中的静态变量
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则为向上舍入的舍入模式。
ROUND_UNNECESSARY - 类 java.math.BigDecimal 中的静态变量
断言请求的操作具有精确的结果，因此不需要舍入。
ROUND_UP - 类 java.math.BigDecimal 中的静态变量
舍入远离零的舍入模式。
roundedCorners - 类 javax.swing.border.LineBorder 中的变量
RoundEnvironment - javax.annotation.processing 中的 接口
注释处理工具框架将提供一个注释处理器和一个实现此接口的对象，这样处理器可以查询有关注释处理的 round 的信息。
RoundingMode - java.math 中的 枚举
为可能丢弃精度的数值操作指定一种舍入行为。
RoundRectangle2D - java.awt.geom 中的 类
RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
RoundRectangle2D() - 类 java.awt.geom.RoundRectangle2D 的构造方法
这是一个无法直接实例化的抽象类。
RoundRectangle2D.Double - java.awt.geom 中的 类
Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
RoundRectangle2D.Double() - 类 java.awt.geom.RoundRectangle2D.Double 的构造方法
构造一个新 RoundRectangle2D，并将其初始化为：位置 (0.0,0)、大小 (0.0,0.0)、圆角弧半径 0.0。
RoundRectangle2D.Double(double, double, double, double, double, double) - 类 java.awt.geom.RoundRectangle2D.Double 的构造方法
根据指定 double 坐标构造并初始化 RoundRectangle2D。
RoundRectangle2D.Float - java.awt.geom 中的 类
Float 类定义一个所有圆角都使用 float 坐标指定的矩形。
RoundRectangle2D.Float() - 类 java.awt.geom.RoundRectangle2D.Float 的构造方法
构造一个新 RoundRectangle2D，并将其初始化为：位置 (0.0,0)、大小 (0.0,0.0)、圆角弧半径 0.0。
RoundRectangle2D.Float(float, float, float, float, float, float) - 类 java.awt.geom.RoundRectangle2D.Float 的构造方法
根据指定 float 坐标构造并初始化 RoundRectangle2D。
ROW_HEADER - 类 javax.accessibility.AccessibleRole 中的静态变量
数据行的头。
ROW_HEADER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识沿视口左边左上角和左下角之间的区域。
ROW_HEIGHT_PROPERTY - 类 javax.swing.JTree 中的静态变量
rowHeight 的绑定属性名称。
rowAtPoint(Point) - 类 javax.swing.JTable 中的方法
返回 point 所在的行索引；如果结果不在 [0, getRowCount()-1] 范围内，则返回 -1。
rowChanged(RowSetEvent) - 接口 javax.sql.RowSetListener 中的方法
通知已注册侦听器 RowSet 对象的其中一行发生了更改。
rowDeleted() - 接口 java.sql.ResultSet 中的方法
获取是否已删除某行。
RowFilter<M,I> - javax.swing 中的 类
RowFilter 用于从模型中过滤条目，使得这些条目不会在视图中显示。
RowFilter() - 类 javax.swing.RowFilter 的构造方法
RowFilter.ComparisonType - javax.swing 中的 枚举
由某些默认 RowFilter 支持的可能比较值的枚举。
RowFilter.Entry<M,I> - javax.swing 中的 类
一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。
RowFilter.Entry() - 类 javax.swing.RowFilter.Entry 的构造方法
创建一个 Entry。
rowHead - 类 javax.swing.ScrollPaneLayout 中的变量
子级行标题。
rowHeader - 类 javax.swing.JScrollPane 中的变量
行标题子级。
rowHeight - 类 javax.swing.JTable 中的变量
表中每一行的高度，以像素为单位。
rowHeight - 类 javax.swing.JTree 中的变量
用于每个显示行的高度。
rowHeight - 类 javax.swing.tree.AbstractLayoutCache 中的变量
每行的高度。
rowHeights - 类 java.awt.GridBagLayout 中的变量
此字段保持对行最小高度的重写。
RowId - java.sql 中的 接口
SQL ROWID 值在 Java 编程语言中的表示形式（映射）。
ROWID - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 ROWID 的 Java 编程语言中的常量（有时称为类型代码）。
RowIdLifetime - java.sql 中的 枚举
RowId 生存期值的枚举。
rowInserted() - 接口 java.sql.ResultSet 中的方法
获取当前行是否已有插入。
rowMapper - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
提供给定路径的行。
RowMapper - javax.swing.tree 中的 接口
定义针对将树中的路径转换为显示行的对象的要求。
rowMargin - 类 javax.swing.JTable 中的变量
每行中单元格之间间距的高度，以像素为单位。
ROWS - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
rowsDeleted(int, int) - 类 javax.swing.DefaultRowSorter 中的方法
当行已经从指定范围（包括）内的底层模型中被删除时，调用此方法。
rowsDeleted(int, int) - 类 javax.swing.RowSorter 中的方法
当行已经从指定范围（包括）内的底层模型中被删除时，调用此方法。
rowSelectionAllowed - 类 javax.swing.JTable 中的变量
如果行选择在此表中是允许的，则返回 true。
RowSet - javax.sql 中的 接口
该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。
ROWSET_SYNC_PROVIDER - 类 javax.sql.rowset.spi.SyncFactory 中的静态变量
用于同步提供者实现名称的标准属性 id。
ROWSET_SYNC_PROVIDER_VERSION - 类 javax.sql.rowset.spi.SyncFactory 中的静态变量
用于同步提供者实现版本标记的标准属性 id。
ROWSET_SYNC_VENDOR - 类 javax.sql.rowset.spi.SyncFactory 中的静态变量
用于同步提供者实现供应商名称的标准属性 id。
rowSetChanged(RowSetEvent) - 接口 javax.sql.RowSetListener 中的方法
通知已注册侦听器给定 RowSetEvent 对象中的 RowSet 对象已更改其全部内部。
RowSetEvent - javax.sql 中的 类
RowSet 对象发生事件时生成的 Event 对象。
RowSetEvent(RowSet) - 类 javax.sql.RowSetEvent 的构造方法
构造一个 RowSetEvent 对象，并使用给定的 RowSet 对象进行初始化。
RowSetInternal - javax.sql 中的 接口
为了将自身呈现给 RowSetReader 或 RowSetWriter 对象的 RowSet 对象实现应实现该接口。
RowSetListener - javax.sql 中的 接口
要在 RowSet 对象的生命周期内发生重要事件时得到通知的组件必须实现该接口。
RowSetMetaData - javax.sql 中的 接口
该对象包含关于 RowSet 对象的列的信息。
RowSetMetaDataImpl - javax.sql.rowset 中的 类
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。
RowSetMetaDataImpl() - 类 javax.sql.rowset.RowSetMetaDataImpl 的构造方法
rowSetPopulated(RowSetEvent, int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
通知已注册侦听器给定 RowSetEvent 对象中的某个 RowSet 对象已经填充了多个附加行。
RowSetReader - javax.sql 中的 接口
该设施供非连接 RowSet 对象调用以填充数据行。
RowSetWarning - javax.sql.rowset 中的 异常
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。
RowSetWarning(String) - 异常 javax.sql.rowset.RowSetWarning 的构造方法
用给定的 reason 值构造 RowSetWarning 对象；SQLState 默认为 null，vendorCode 默认为 0。
RowSetWarning() - 异常 javax.sql.rowset.RowSetWarning 的构造方法
构造一个默认的 RowSetWarning 对象。
RowSetWarning(String, String) - 异常 javax.sql.rowset.RowSetWarning 的构造方法
构造一个 RowSetWarning 对象，并使用给定的 reason 和 SQLState 值进行初始化。
RowSetWarning(String, String, int) - 异常 javax.sql.rowset.RowSetWarning 的构造方法
构造一个完全指定的 RowSetWarning 对象，并使用给定的 reason、SQLState 和 vendorCode 值进行初始化。
RowSetWriter - javax.sql 中的 接口
实现 RowSetWriter 接口的对象，称为 writer。
rowsInserted(int, int) - 类 javax.swing.DefaultRowSorter 中的方法
当行已经插入到指定范围（包括）内的底层模型时，调用此方法。
rowsInserted(int, int) - 类 javax.swing.RowSorter 中的方法
当行已经插入到指定范围（包括）内的底层模型时，调用此方法。
RowSorter<M> - javax.swing 中的 类
RowSorter 提供排序和过滤的基础。
RowSorter() - 类 javax.swing.RowSorter 的构造方法
创建一个RowSorter。
RowSorter.SortKey - javax.swing 中的 类
SortKey 描述特定列的排序顺序。
RowSorter.SortKey(int, SortOrder) - 类 javax.swing.RowSorter.SortKey 的构造方法
使用指定的排序顺序创建指定列的 SortKey。
RowSorterEvent - javax.swing.event 中的 类
RowSorterEvent 提供 RowSorter 的更改通知。
RowSorterEvent(RowSorter) - 类 javax.swing.event.RowSorterEvent 的构造方法
创建类型为 SORT_ORDER_CHANGED 的 RowSorterEvent。
RowSorterEvent(RowSorter, RowSorterEvent.Type, int[]) - 类 javax.swing.event.RowSorterEvent 的构造方法
创建一个 RowSorterEvent。
RowSorterEvent.Type - javax.swing.event 中的 枚举
RowSorterEvent 类型的枚举。
RowSorterListener - javax.swing.event 中的 接口
通知 RowSorterListener 对 RowSorter 的更改。
ROWSPAN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
rowsRemoved(TableModelEvent) - 类 javax.swing.table.DefaultTableModel 中的方法
等效于 fireTableChanged。
rowsUpdated(int, int) - 类 javax.swing.DefaultRowSorter 中的方法
当行已经在指定范围（包括）内的底层模型中被更改时，调用此方法。
rowsUpdated(int, int, int) - 类 javax.swing.DefaultRowSorter 中的方法
当行中的列已经在指定范围内的底层模型中被更新时，调用此方法。
rowsUpdated(int, int) - 类 javax.swing.RowSorter 中的方法
当行已经在指定范围（包括）内的底层模型中被更改时，调用此方法。
rowsUpdated(int, int, int) - 类 javax.swing.RowSorter 中的方法
当行中的列已经在指定范围内的底层模型中被更新时，调用此方法。
rowUpdated() - 接口 java.sql.ResultSet 中的方法
获取是否已更新当前行。
rowWeights - 类 java.awt.GridBagLayout 中的变量
此字段保持对行权重的重写。
RSA_SHA1 - 接口 javax.xml.crypto.dsig.SignatureMethod 中的静态变量
RSAwithSHA1 (PKCS #1) 签名方法的算法 URI。
RSA_TYPE - 接口 javax.xml.crypto.dsig.keyinfo.KeyValue 中的静态变量
标识 RSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#RSAKeyValue。
RSAKey - java.security.interfaces 中的 接口
RSA 公用密钥或专用密钥的接口。
RSAKeyGenParameterSpec - java.security.spec 中的 类
此类指定用于生成 RSA 密钥对的参数集。
RSAKeyGenParameterSpec(int, BigInteger) - 类 java.security.spec.RSAKeyGenParameterSpec 的构造方法
构造一个具有给定密钥大小和公用指数值的新的 RSAParameterSpec 对象。
RSAMultiPrimePrivateCrtKey - java.security.interfaces 中的 接口
如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
RSAMultiPrimePrivateCrtKeySpec - java.security.spec 中的 类
如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。
RSAMultiPrimePrivateCrtKeySpec(BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, RSAOtherPrimeInfo[]) - 类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 的构造方法
给定系数、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ、crtCoefficient 和如 PKCS#1 v2.1 中所定义的 otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec。
RSAOtherPrimeInfo - java.security.spec 中的 类
此类表示 RSA 的 OtherPrimeInfo 结构中的三元组（素数、指数和素数），如 PKCS#1 v2.1 中所定义的。
RSAOtherPrimeInfo(BigInteger, BigInteger, BigInteger) - 类 java.security.spec.RSAOtherPrimeInfo 的构造方法
给定如 PKCS#1 中所定义的素数、primeExponent 和 crtCoefficient，创建一个新的 RSAOtherPrimeInfo。
RSAPrivateCrtKey - java.security.interfaces 中的 接口
如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
RSAPrivateCrtKeySpec - java.security.spec 中的 类
为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。
RSAPrivateCrtKeySpec(BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger) - 类 java.security.spec.RSAPrivateCrtKeySpec 的构造方法
给定在 PKCS#1 v2.1 中所定义的系数、publicExponent、privateExponent、 primeP、primeQ、primeExponentP、primeExponentQ 和 crtCoefficient，创建一个新的 RSAPrivateCrtKeySpec。
RSAPrivateKey - java.security.interfaces 中的 接口
RSA 专用密钥的接口。
RSAPrivateKeySpec - java.security.spec 中的 类
此类指定 RSA 专用密钥。
RSAPrivateKeySpec(BigInteger, BigInteger) - 类 java.security.spec.RSAPrivateKeySpec 的构造方法
创建一个新的 RSAPrivateKeySpec。
RSAPublicKey - java.security.interfaces 中的 接口
RSA 公用密钥的接口。
RSAPublicKeySpec - java.security.spec 中的 类
此类指定 RSA 公用密钥。
RSAPublicKeySpec(BigInteger, BigInteger) - 类 java.security.spec.RSAPublicKeySpec 的构造方法
创建一个新的 RSAPublicKeySpec。
RTFEditorKit - javax.swing.text.rtf 中的 类
这是对 RTF 编辑功能的默认实现。
RTFEditorKit() - 类 javax.swing.text.rtf.RTFEditorKit 的构造方法
构造一个 RTFEditorKit。
RuleBasedCollator - java.text 中的 类
RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。
RuleBasedCollator(String) - 类 java.text.RuleBasedCollator 的构造方法
RuleBasedCollator 构造方法。
RULER - 类 javax.accessibility.AccessibleRole 中的静态变量
RULER 是用于测量距离的对象
run() - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
此类的 runnable 方法。
run() - 接口 java.lang.Runnable 中的方法
使用实现接口 Runnable 的对象创建一个线程时，启动该线程将导致在独立执行的线程中调用对象的 run 方法。
run() - 类 java.lang.Thread 中的方法
如果该线程是使用独立的 Runnable 运行对象构造的，则调用该 Runnable 对象的 run 方法；否则，该方法不执行任何操作并返回。
run() - 接口 java.security.PrivilegedAction 中的方法
执行计算。
run() - 接口 java.security.PrivilegedExceptionAction 中的方法
执行计算。
run() - 类 java.util.concurrent.FutureTask 中的方法
除非已将此 Future 取消，否则将其设置为其计算的结果。
run() - 接口 java.util.concurrent.RunnableFuture 中的方法
在未被取消的情况下，将此 Future 设置为计算的结果。
run() - 类 java.util.TimerTask 中的方法
此计时器任务要执行的操作。
run() - 类 javax.swing.SwingWorker 中的方法
将此 Future 设置为计算的结果，除非它已经被取消。
run() - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
更新 ChildState。
run(InputStream, OutputStream, OutputStream, String...) - 接口 javax.tools.Tool 中的方法
使用给定 I/O 通道和参数运行工具。
run() - 类 org.omg.CORBA.ORB 中的方法
在 ORB 已完成关闭过程前（该过程始于某些线程调用 shutdown 时），此操作将一直阻塞当前线程。
RUN_DIRECTION - 类 java.awt.font.TextAttribute 中的静态变量
线条延伸方向的属性键。
RUN_DIRECTION_LTR - 类 java.awt.font.TextAttribute 中的静态变量
从左到右的延伸方向。
RUN_DIRECTION_RTL - 类 java.awt.font.TextAttribute 中的静态变量
从右到左的延伸方向。
runAndReset() - 类 java.util.concurrent.FutureTask 中的方法
执行计算而不设置其结果，然后将此 Future 重置为初始状态，如果计算遇到异常或已取消，则该操作失败。
runCount - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
runFinalization() - 类 java.lang.Runtime 中的方法
运行挂起 finalization 的所有对象的终止方法。
runFinalization() - 类 java.lang.System 中的静态方法
运行处于挂起终止状态的所有对象的终止方法。
runFinalizersOnExit(boolean) - 类 java.lang.Runtime 中的静态方法
已过时。 此方法本身具有不安全性。它可能对正在使用的对象调用终结方法，而其他线程正在操作这些对象，从而导致不正确的行为或死锁。
runFinalizersOnExit(boolean) - 类 java.lang.System 中的静态方法
已过时。 该方法具有固有的不安全性。它可能对正在使用的对象调用终结方法，而其他线程同时正在操作这些对象，从而导致不正确的行为或死锁。
RUNIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Runic”Unicode 字符块的常量。
runnable - 类 java.awt.event.InvocationEvent 中的变量
调用其 run() 方法的 Runnable。
Runnable - java.lang 中的 接口
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
RunnableFuture<V> - java.util.concurrent 中的 接口
作为 Runnable 的 Future。
RunnableScheduledFuture<V> - java.util.concurrent 中的 接口
作为 Runnable 的 ScheduledFuture。
Runtime - java.lang 中的 类
每个 Java 应用程序都有一个 Runtime 类实例，使应用程序能够与其运行的环境相连接。
RunTime - org.omg.SendingContext 中的 接口
定义表示请求的发送上下文的基类。
RUNTIME_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示在尝试获取被观察属性的值时发生未预定义的错误类型的通知类型。
RUNTIME_ERROR_NOTIFIED - 类 javax.management.monitor.Monitor 中的静态变量
表示已在更改被观察对象或被观察属性之后发出了通知的标志。
RUNTIME_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
RuntimeMXBean 的 ObjectName 的字符串表示形式。
RuntimeErrorException - javax.management 中的 异常
当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
RuntimeErrorException(Error) - 异常 javax.management.RuntimeErrorException 的构造方法
默认的构造方法。
RuntimeErrorException(Error, String) - 异常 javax.management.RuntimeErrorException 的构造方法
允许指定特定错误消息的构造方法。
RuntimeException - java.lang 中的 异常
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
RuntimeException() - 异常 java.lang.RuntimeException 的构造方法
用 null 作为其详细消息构造一个新的运行时异常。
RuntimeException(String) - 异常 java.lang.RuntimeException 的构造方法
用指定的详细消息构造一个新的运行时异常。
RuntimeException(String, Throwable) - 异常 java.lang.RuntimeException 的构造方法
用指定的详细消息和原因构造一个新的运行时异常。
RuntimeException(Throwable) - 异常 java.lang.RuntimeException 的构造方法
用指定的原因和详细消息 (cause==null ? null :cause.toString()） 构造一个新的运行时异常（它通常包含类和 cause 的详细消息）。
RuntimeMBeanException - javax.management 中的 异常
表示由代理中的 MBean 方法抛出的运行时异常。
RuntimeMBeanException(RuntimeException) - 异常 javax.management.RuntimeMBeanException 的构造方法
创建包装实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeMBeanException(RuntimeException, String) - 异常 javax.management.RuntimeMBeanException 的构造方法
创建带有详细信息的实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeMXBean - java.lang.management 中的 接口
Java 虚拟机的运行时系统的管理接口。
RunTimeOperations - org.omg.SendingContext 中的 接口
定义在表示请求的发送上下文的基类上使用的操作。
RuntimeOperationsException - javax.management 中的 异常
表示在 MBean 上执行操作时代理中抛出的运行时异常。
RuntimeOperationsException(RuntimeException) - 异常 javax.management.RuntimeOperationsException 的构造方法
创建包装实际 java.lang.RuntimeException 的 RuntimeOperationsException。
RuntimeOperationsException(RuntimeException, String) - 异常 javax.management.RuntimeOperationsException 的构造方法
创建包装带有详细信息的实际 java.lang.RuntimeException 的 RuntimeOperationsException。
RuntimePermission - java.lang 中的 类
该类用于运行时权限。
RuntimePermission(String) - 类 java.lang.RuntimePermission 的构造方法
创建具有指定名称的新 RuntimePermission。
RuntimePermission(String, String) - 类 java.lang.RuntimePermission 的构造方法
创建具有指定名称的新 RuntimePermission 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


S - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

S

S - 类 javax.swing.text.html.HTML.Tag 中的静态变量
S_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口下边框大小的光标类型。
S_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.S_RESIZE_CURSOR 取代。
SAAJMetaFactory - javax.xml.soap 中的 类
SAAJ API 中定义的工厂实现类的访问点。
SAAJMetaFactory() - 类 javax.xml.soap.SAAJMetaFactory 的构造方法
SAAJResult - javax.xml.soap 中的 类
以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。
SAAJResult() - 类 javax.xml.soap.SAAJResult 的构造方法
创建一个 SAAJResult，此类将以支持默认 (SOAP 1.1) 协议的 SAAJ 树的形式显示结果。
SAAJResult(String) - 类 javax.xml.soap.SAAJResult 的构造方法
创建一个 SAAJResult，它将以支持指定协议的 SAAJ 树的形式显示结果。
SAAJResult(SOAPMessage) - 类 javax.xml.soap.SAAJResult 的构造方法
创建一个 SAAJResult，它会将结果写入提供的 SOAPMessage 的 SOAPPart 中。
SAAJResult(SOAPElement) - 类 javax.xml.soap.SAAJResult 的构造方法
创建一个 SAAJResult，它会将结果编写为指定 SOAPElement 的子节点。
SADDLE_STITCH - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿中折线的一个或多个装订点（金属针脚）绑定。
sameFile(URL) - 类 java.net.URL 中的方法
比较两个 URL，不包括片段部分。
sameFile(URL, URL) - 类 java.net.URLStreamHandler 中的方法
比较两个 url 以确定它们是否引用相同的文件（即具有相同的协议、主机、端口和路径）。
SAMP - 类 javax.swing.text.html.HTML.Tag 中的静态变量
SAMPLE_RATE - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示更改音频回放的样本频率的控件。
sampleModel - 类 java.awt.image.Raster 中的变量
描述此 Raster 的像素在 DataBuffer 中存储方式的 SampleModel。
SampleModel - java.awt.image 中的 类
此抽象类定义一个提取图像像素样本的接口。
SampleModel(int, int, int, int) - 类 java.awt.image.SampleModel 的构造方法
构造一个具有指定参数的 SampleModel。
sampleModel - 类 javax.imageio.ImageTypeSpecifier 中的变量
将用作原型的 SampleModel。
sampleModelTranslateX - 类 java.awt.image.Raster 中的变量
从 Raster 的 SampleModel 坐标空间到该 Raster 坐标空间的 X 平移。
sampleModelTranslateY - 类 java.awt.image.Raster 中的变量
从 Raster 的 SampleModel 坐标空间到该 Raster 坐标空间的 Y 平移。
sampleRate - 类 javax.sound.sampled.AudioFormat 中的变量
具有此格式的声音每秒播放或录制的样本数。
sampleSizeInBits - 类 javax.sound.sampled.AudioFormat 中的变量
每个具有此格式的声音样本中的位数。
SANS_SERIF - 类 java.awt.Font 中的静态变量
逻辑字体 "SansSerif" 的规范系列名称的 String 常量。
Sasl - javax.security.sasl 中的 类
用于创建 SASL 客户端和服务器的静态类。
SaslClient - javax.security.sasl 中的 接口
以客户端的身份执行 SASL 验证。
SaslClientFactory - javax.security.sasl 中的 接口
用于创建 SaslClient 实例的接口。
SaslException - javax.security.sasl 中的 异常
此类表示在使用 SASL 时所发生的错误。
SaslException() - 异常 javax.security.sasl.SaslException 的构造方法
构造一个新的 SaslException 实例。
SaslException(String) - 异常 javax.security.sasl.SaslException 的构造方法
构造带详细消息的新 SaslException 实例。
SaslException(String, Throwable) - 异常 javax.security.sasl.SaslException 的构造方法
构造带详细消息和根异常的新 SaslException 实例。
SaslServer - javax.security.sasl 中的 接口
以服务器的身份执行 SASL 验证。
SaslServerFactory - javax.security.sasl 中的 接口
用于创建 SaslServer 实例的接口。
SATURDAY - 类 java.util.Calendar 中的静态变量
指示 Saturday 的 Calendar.DAY_OF_WEEK 字段值。
save(ObjectOutputStream, String, EventListener) - 类 java.awt.AWTEventMulticaster 中的静态方法
SAVE - 类 java.awt.FileDialog 中的静态变量
此常量值指示文件对话框窗口的作用是查找要写入的文件。
save(OutputStream, String) - 类 java.util.Properties 中的方法
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。
SAVE_DIALOG - 类 javax.swing.JFileChooser 中的静态变量
指示 JFileChooser 支持 "Save" 文件操作的类型值。
SAVE_FILE - 类 java.awt.Event 中的静态变量
文件保存事件。
saveButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
saveButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
saveButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
saveChanges() - 类 javax.xml.soap.SOAPMessage 中的方法
使用对其所作的所有更改更新此 SOAPMessage 对象。
saveInternal(ObjectOutputStream, String) - 类 java.awt.AWTEventMulticaster 中的方法
Savepoint - java.sql 中的 接口
保存点的表示形式，保存点是可以从 Connection.rollback 方法引用的当前事务中的点。
saveRequired() - 类 javax.xml.soap.SOAPMessage 中的方法
指示是否此 SOAPMessage 对象需要调用方法 saveChanges。
SAXException - org.xml.sax 中的 异常
封装一般的 SAX 错误或警告。
SAXException() - 异常 org.xml.sax.SAXException 的构造方法
创建一个新的 SAXException。
SAXException(String) - 异常 org.xml.sax.SAXException 的构造方法
创建一个新的 SAXException。
SAXException(Exception) - 异常 org.xml.sax.SAXException 的构造方法
创建一个包装现有异常的新的 SAXException。
SAXException(String, Exception) - 异常 org.xml.sax.SAXException 的构造方法
从现有的异常创建新的 SAXException。
SAXNotRecognizedException - org.xml.sax 中的 异常
用于未识别的标识符的 Exception 类。
SAXNotRecognizedException() - 异常 org.xml.sax.SAXNotRecognizedException 的构造方法
默认的构造方法。
SAXNotRecognizedException(String) - 异常 org.xml.sax.SAXNotRecognizedException 的构造方法
构造带指定的消息的新的异常。
SAXNotSupportedException - org.xml.sax 中的 异常
用于不被支持的操作的 Exception 类。
SAXNotSupportedException() - 异常 org.xml.sax.SAXNotSupportedException 的构造方法
构造不带任何消息的新异常。
SAXNotSupportedException(String) - 异常 org.xml.sax.SAXNotSupportedException 的构造方法
构造带指定消息的新的异常。
SAXParseException - org.xml.sax 中的 异常
封装 XML 解析错误或警告。
SAXParseException(String, Locator) - 异常 org.xml.sax.SAXParseException 的构造方法
从消息和 Locator 创建新的 SAXParseException。
SAXParseException(String, Locator, Exception) - 异常 org.xml.sax.SAXParseException 的构造方法
将现有的异常包装在 SAXParseException 中。
SAXParseException(String, String, String, int, int) - 异常 org.xml.sax.SAXParseException 的构造方法
创建新的 SAXParseException。
SAXParseException(String, String, String, int, int, Exception) - 异常 org.xml.sax.SAXParseException 的构造方法
创建带有嵌入异常的新 SAXParseException。
SAXParser - javax.xml.parsers 中的 类
定义包装 XMLReader 实现类的 API。
SAXParser() - 类 javax.xml.parsers.SAXParser 的构造方法
将阻止实例化的受保护构造方法。
SAXParserFactory - javax.xml.parsers 中的 类
定义工厂 API，使应用程序能够配置和获取基于 SAX 的解析器以解析 XML 文档。
SAXParserFactory() - 类 javax.xml.parsers.SAXParserFactory 的构造方法
受保护构造方法，以强制使用 SAXParserFactory.newInstance()。
SAXResult - javax.xml.transform.sax 中的 类
充当转换 Result 的持有者。
SAXResult() - 类 javax.xml.transform.sax.SAXResult 的构造方法
零参数的默认构造方法。
SAXResult(ContentHandler) - 类 javax.xml.transform.sax.SAXResult 的构造方法
创建以 SAX2 ContentHandler 为目标的 SAXResult。
SAXSource - javax.xml.transform.sax 中的 类
充当 SAX 样式 Source 的持有者。
SAXSource() - 类 javax.xml.transform.sax.SAXSource 的构造方法
零参数的默认构造方法。
SAXSource(XMLReader, InputSource) - 类 javax.xml.transform.sax.SAXSource 的构造方法
使用 XMLReader 和 SAX InputSource 创建 SAXSource。
SAXSource(InputSource) - 类 javax.xml.transform.sax.SAXSource 的构造方法
使用 SAX InputSource，创建 SAXSource。
SAXTransformerFactory - javax.xml.transform.sax 中的 类
此类扩展了 TransformerFactory 以提供特定于 SAX 的工厂方法。
SAXTransformerFactory() - 类 javax.xml.transform.sax.SAXTransformerFactory 的构造方法
默认构造方法受到有意保护。
SC_BLOCK_DATA - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
SC_ENUM - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
SC_EXTERNALIZABLE - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
SC_SERIALIZABLE - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
SC_WRITE_METHOD - 接口 java.io.ObjectStreamConstants 中的静态变量
ObjectStreamClass 标志的位掩码。
scalb(double, int) - 类 java.lang.Math 中的静态方法
返回 d × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘以 double 值集合中的一个值。
scalb(float, int) - 类 java.lang.Math 中的静态方法
返回 f × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘以 float 值集合中的一个值。
scalb(double, int) - 类 java.lang.StrictMath 中的静态方法
返回 d × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘到 double 值集合中的一个值。
scalb(float, int) - 类 java.lang.StrictMath 中的静态方法
返回 f × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘到 float 值集合中的一个值。
scale(double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与缩放变换。
scale(double, double) - 类 java.awt.Graphics2D 中的方法
将当前 Graphics2D Transform 与缩放转换连接。
scale() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的标度。
scale(Spring, float) - 类 javax.swing.Spring 中的静态方法
返回一个 spring，其 minimum、preferred、maximum 和 value 属性都是参数 spring s 的属性的倍数。
SCALE_AREA_AVERAGING - 类 java.awt.Image 中的静态变量
使用 Area Averaging 图像缩放算法。
SCALE_DEFAULT - 类 java.awt.Image 中的静态变量
使用默认的图像缩放算法。
SCALE_FAST - 类 java.awt.Image 中的静态变量
选择一种图像缩放算法，在这种缩放算法中，缩放速度比缩放平滑度具有更高的优先级。
SCALE_REPLICATE - 类 java.awt.Image 中的静态变量
使用 ReplicateScaleFilter 类中包含的图像缩放算法。
SCALE_SMOOTH - 类 java.awt.Image 中的静态变量
选择图像平滑度比缩放速度具有更高优先级的图像缩放算法。
scaleByPowerOfTen(int) - 类 java.math.BigDecimal 中的方法
返回其数值等于 (this * 10n) 的 BigDecimal。
scan(Iterable<? extends Element>, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
迭代给定元素并对每个元素调用 scan(Element, P)。
scan(Element, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
通过调用 e.accept(this, p) 处理元素；此方法可被子类重写。
scan(Element) - 类 javax.lang.model.util.ElementScanner6 中的方法
等效于 v.scan(e, null) 的便捷方法。
scanForPlugins() - 类 javax.imageio.ImageIO 中的静态方法
扫描应用程序类路径上的插件，加载其服务提供者类，并使用 IIORegistry 为每一个找到的插件注册一个服务提供者实例。
scanlineStride - 类 java.awt.image.ComponentSampleModel 中的变量
由此 ComponentSampleModel 所描述的图像数据区域的行间距（以数据数组元素表示）。
Scanner - java.util 中的 类
一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。
Scanner(Readable) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定源扫描的。
Scanner(InputStream) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。
Scanner(InputStream, String) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。
Scanner(File) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(File, String) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(String) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定字符串扫描的。
Scanner(ReadableByteChannel) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定信道扫描的。
Scanner(ReadableByteChannel, String) - 类 java.util.Scanner 的构造方法
构造一个新的 Scanner，它生成的值是从指定信道扫描的。
ScatteringByteChannel - java.nio.channels 中的 接口
可将字节读入缓冲区序列的通道。
schedule(Runnable, long, TimeUnit) - 接口 java.util.concurrent.ScheduledExecutorService 中的方法
创建并执行在给定延迟后启用的一次性操作。
schedule(Callable<V>, long, TimeUnit) - 接口 java.util.concurrent.ScheduledExecutorService 中的方法
创建并执行在给定延迟后启用的 ScheduledFuture。
schedule(Runnable, long, TimeUnit) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
schedule(Callable<V>, long, TimeUnit) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
schedule(TimerTask, long) - 类 java.util.Timer 中的方法
安排在指定延迟后执行指定的任务。
schedule(TimerTask, Date) - 类 java.util.Timer 中的方法
安排在指定的时间执行指定的任务。
schedule(TimerTask, long, long) - 类 java.util.Timer 中的方法
安排指定的任务从指定的延迟后开始进行重复的固定延迟执行。
schedule(TimerTask, Date, long) - 类 java.util.Timer 中的方法
安排指定的任务在指定的时间开始进行重复的固定延迟执行。
scheduleAtFixedRate(Runnable, long, long, TimeUnit) - 接口 java.util.concurrent.ScheduledExecutorService 中的方法
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
scheduleAtFixedRate(Runnable, long, long, TimeUnit) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
scheduleAtFixedRate(TimerTask, long, long) - 类 java.util.Timer 中的方法
安排指定的任务在指定的延迟后开始进行重复的固定速率执行。
scheduleAtFixedRate(TimerTask, Date, long) - 类 java.util.Timer 中的方法
安排指定的任务在指定的时间开始进行重复的固定速率执行。
scheduledExecutionTime() - 类 java.util.TimerTask 中的方法
返回此任务最近实际 执行的已安排 执行时间。
ScheduledExecutorService - java.util.concurrent 中的 接口
一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。
ScheduledFuture<V> - java.util.concurrent 中的 接口
一个延迟的、结果可接受的操作，可将其取消。
ScheduledThreadPoolExecutor - java.util.concurrent 中的 类
ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
ScheduledThreadPoolExecutor(int) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 的构造方法
使用给定核心池大小创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int, ThreadFactory) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 的构造方法
使用给定的初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int, RejectedExecutionHandler) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 的构造方法
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int, ThreadFactory, RejectedExecutionHandler) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 的构造方法
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
scheduleWithFixedDelay(Runnable, long, long, TimeUnit) - 接口 java.util.concurrent.ScheduledExecutorService 中的方法
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
scheduleWithFixedDelay(Runnable, long, long, TimeUnit) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
Schema - javax.xml.validation 中的 类
不可变的语法存储表示形式。
Schema() - 类 javax.xml.validation.Schema 的构造方法
派生类的构造方法。
SCHEMA_SYSTEM_ID - 接口 javax.sql.rowset.WebRowSet 中的静态变量
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的 URL。
SchemaFactory - javax.xml.validation 中的 类
创建 Schema 对象的工厂。
SchemaFactory() - 类 javax.xml.validation.SchemaFactory 的构造方法
派生类的构造方法。
SchemaFactoryLoader - javax.xml.validation 中的 类
创建 SchemaFactory 的工厂。
SchemaFactoryLoader() - 类 javax.xml.validation.SchemaFactoryLoader 的构造方法
不执行操作的构造方法。
SchemaOutputResolver - javax.xml.bind 中的 类
控制 JAXB 实现放置生成的模式文件的位置。
SchemaOutputResolver() - 类 javax.xml.bind.SchemaOutputResolver 的构造方法
SchemaViolationException - javax.naming.directory 中的 异常
当方法在某些方面违反模式时，抛出此异常。
SchemaViolationException() - 异常 javax.naming.directory.SchemaViolationException 的构造方法
构造一个新的 SchemaViolationException 实例。
SchemaViolationException(String) - 异常 javax.naming.directory.SchemaViolationException 的构造方法
使用所提供的解释构造一个新的 SchemaViolationException 实例。
scope - 类 javax.xml.bind.JAXBElement 中的变量
表示此 xml 元素实例的 xml 元素声明的作用域。
SCRIPT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
ScriptContext - javax.script 中的 接口
该接口的实现类被用来连接 Script Engines 和宿主应用程序中的对象（如有范围的 Bindings）。
ScriptEngine - javax.script 中的 接口
ScriptEngine 是基础接口，该接口的方法在此规范的每个实现中都必须具有完整的功能。
ScriptEngineFactory - javax.script 中的 接口
ScriptEngineFactory 用来描述和实例化 ScriptEngine。
ScriptEngineManager - javax.script 中的 类
ScriptEngineManager 为 ScriptEngine 类实现一个发现和实例化机制，还维护一个键/值对集合来存储所有 Manager 创建的引擎所共享的状态。
ScriptEngineManager() - 类 javax.script.ScriptEngineManager 的构造方法
如果调用者可访问线程上下文 ClassLoader，则调用此构造方法的效果与调用 ScriptEngineManager(Thread.currentThread().getContextClassLoader()) 相同。
ScriptEngineManager(ClassLoader) - 类 javax.script.ScriptEngineManager 的构造方法
此构造方法使用服务调用者机制加载对于给定 ClassLoader 可见的 ScriptEngineFactory 实现。
ScriptException - javax.script 中的 异常
脚本 API 的一般 Exception 类。
ScriptException(String) - 异常 javax.script.ScriptException 的构造方法
使用将在其消息中使用的 String 创建一个 ScriptException。
ScriptException(Exception) - 异常 javax.script.ScriptException 的构造方法
创建一个包装底层解释器抛出的 Exception 的 ScriptException。
ScriptException(String, String, int) - 异常 javax.script.ScriptException 的构造方法
使用将在错误消息中使用的消息、文件名和行号创建一个 ScriptException。
ScriptException(String, String, int, int) - 异常 javax.script.ScriptException 的构造方法
指定消息、文件名、行号和列号的 ScriptException 构造方法。
SCROLL_ABSOLUTE - 类 java.awt.Event 中的静态变量
用户已经将滚动条中的“气泡”（即翻阅标志）移到一个“绝对的”位置，而不是相对最后位置的偏移量。
SCROLL_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
通常用于允许用户逐渐查看大量数据的对象。
SCROLL_BAR - 类 javax.swing.plaf.synth.Region 中的静态变量
ScrollBar 的 region。
SCROLL_BAR_THUMB - 类 javax.swing.plaf.synth.Region 中的静态变量
ScrollBar 的 thumb。
SCROLL_BAR_TRACK - 类 javax.swing.plaf.synth.Region 中的静态变量
ScrollBar 的滑道。
SCROLL_BEGIN - 类 java.awt.Event 中的静态变量
滚动开始事件。
SCROLL_DOWN - 类 javax.swing.plaf.basic.BasicComboPopup 中的静态变量
SCROLL_END - 类 java.awt.Event 中的静态变量
滚动结束事件。
SCROLL_LINE_DOWN - 类 java.awt.Event 中的静态变量
用户已经激活了滚动条的 line down 区域。
SCROLL_LINE_UP - 类 java.awt.Event 中的静态变量
用户已经激活了滚动条的 line up 区域。
SCROLL_LOCK - 类 java.awt.Event 中的静态变量
Scroll Lock 键，一个非 ASCII 操作键。
SCROLL_PAGE_DOWN - 类 java.awt.Event 中的静态变量
用户已经激活了滚动条的 page down 区域。
SCROLL_PAGE_UP - 类 java.awt.Event 中的静态变量
用户已经激活了滚动条的 page up 区域。
SCROLL_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
允许用户逐渐查看大量信息的对象。
SCROLL_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
ScrollPane 的 region。
SCROLL_TAB_LAYOUT - 类 javax.swing.JTabbedPane 中的静态变量
当在一次运行中不能放入所有的选项卡时，用于提供可用选项卡子集的选项卡布局策略。
SCROLL_UP - 类 javax.swing.plaf.basic.BasicComboPopup 中的静态变量
Scrollable - javax.swing 中的 接口
为类似 JScrollPane 的滚动容器提供信息的接口。
Scrollbar - java.awt 中的 类
Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
Scrollbar() - 类 java.awt.Scrollbar 的构造方法
构造一个新的垂直滚动条。
Scrollbar(int) - 类 java.awt.Scrollbar 的构造方法
构造一个具有指定方向的新滚动条。
Scrollbar(int, int, int, int, int) - 类 java.awt.Scrollbar 的构造方法
构造一个新的滚动条，它具有指定的方向、初始值、可见量、最小值和最大值。
SCROLLBAR - 类 java.awt.SystemColor 中的静态变量
SystemColor.scrollbar 系统颜色的数组索引。
scrollbar - 类 java.awt.SystemColor 中的静态变量
为滚动条提供的背景色。
scrollbar - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
scrollBar - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的变量
正在调整的 scrollBar。
Scrollbar.AccessibleAWTScrollBar - java.awt 中的 类
此类实现 Scrollbar 类的可访问性支持。
Scrollbar.AccessibleAWTScrollBar() - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 的构造方法
SCROLLBARS_ALWAYS - 类 java.awt.ScrollPane 中的静态变量
指定无论滚动窗格和子组件各自大小如何，总是显示水平/垂直滚动条。
SCROLLBARS_AS_NEEDED - 类 java.awt.ScrollPane 中的静态变量
指定只在子组件的大小超过了滚动窗格水平/垂直尺寸时显示水平/垂直滚动条。
SCROLLBARS_BOTH - 类 java.awt.TextArea 中的静态变量
创建并显示垂直和水平滚动条。
SCROLLBARS_HORIZONTAL_ONLY - 类 java.awt.TextArea 中的静态变量
只创建并显示水平滚动条。
SCROLLBARS_NEVER - 类 java.awt.ScrollPane 中的静态变量
指定无论滚动窗格和子组件各自大小如何，永不显示水平/垂直滚动条。
SCROLLBARS_NONE - 类 java.awt.TextArea 中的静态变量
不为文本区创建或显示任何滚动条。
SCROLLBARS_VERTICAL_ONLY - 类 java.awt.TextArea 中的静态变量
只创建并显示垂直滚动条。
ScrollBarUI - javax.swing.plaf 中的 类
JScrollBar 的可插入外观界面。
ScrollBarUI() - 类 javax.swing.plaf.ScrollBarUI 的构造方法
scrollBarWidth - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的变量
scrollByBlock(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
scrollByBlock(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
scrollByUnit(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
scrollByUnit(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
scrollDirection - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
scrollDueToClickInTrack(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
在滑道（而非 thumb）中检测到 mousePressed 时调用此方法。
scrollDueToClickInTrack(int) - 类 javax.swing.plaf.metal.MetalSliderUI 中的方法
scroller - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
此受保护字段是特定于实现的。
SCROLLING - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
scrollListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
scrollListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
ScrollPane - java.awt 中的 类
实现用于单个子组件的自动水平和/或垂直滚动的容器类。
ScrollPane() - 类 java.awt.ScrollPane 的构造方法
创建一个具有滚动条策略 "as needed" 的新滚动窗格容器。
ScrollPane(int) - 类 java.awt.ScrollPane 的构造方法
创建新的滚动窗格容器。
scrollpane - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
ScrollPane.AccessibleAWTScrollPane - java.awt 中的 类
此类实现 ScrollPane 类的可访问性支持。
ScrollPane.AccessibleAWTScrollPane() - 类 java.awt.ScrollPane.AccessibleAWTScrollPane 的构造方法
ScrollPaneAdjustable - java.awt 中的 类
此类表示 ScrollPane 的水平或垂直滚动条的状态。
ScrollPaneConstants - javax.swing 中的 接口
与 JScrollPane 组件一起使用的常数。
ScrollPaneLayout - javax.swing 中的 类
JScrollPane 使用的布局管理器。
ScrollPaneLayout() - 类 javax.swing.ScrollPaneLayout 的构造方法
ScrollPaneLayout.UIResource - javax.swing 中的 类
ScrollPaneLayout 的 UI 资源版本。
ScrollPaneLayout.UIResource() - 类 javax.swing.ScrollPaneLayout.UIResource 的构造方法
ScrollPaneUI - javax.swing.plaf 中的 类
JScrollPane 的可插入外观界面。
ScrollPaneUI() - 类 javax.swing.plaf.ScrollPaneUI 的构造方法
scrollPathToVisible(TreePath) - 类 javax.swing.JTree 中的方法
确保路径中所有的路径组件均展开（最后一个路径组件除外）并滚动，以便显示该路径标识的节点。
scrollRectToVisible(Rectangle) - 类 javax.swing.JComponent 中的方法
将 scrollRectToVisible() 消息转发到 JComponent 的父组件。
scrollRectToVisible(Rectangle) - 类 javax.swing.JTextField 中的方法
将字段向左或向右滚动。
scrollRectToVisible(Rectangle) - 类 javax.swing.JViewport 中的方法
滚动该视图，使该视图中的 Rectangle 变得可见。
scrollRowToVisible(int) - 类 javax.swing.JTree 中的方法
滚动行标识的条目，直到显示出来。
SCROLLS_ON_EXPAND_PROPERTY - 类 javax.swing.JTree 中的静态变量
scrollsOnExpand 的绑定属性名称。
scrollsOnExpand - 类 javax.swing.JTree 中的变量
如果为 true，则当展开节点时，将滚动尽可能多的子节点，以便看到它们。
scrollTimer - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
scrollTimer - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
scrollToReference(String) - 类 javax.swing.JEditorPane 中的方法
将视图滚动到给定的参考位置（也就是正在显示的 URL 的 UL.getRef 方法所返回的值）。
scrollUnderway - 类 javax.swing.JViewport 中的变量
scrollUnderway 标志用于 JList 之类的组件。
SDATA - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
SE_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口右下角大小的光标类型。
SE_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.SE_RESIZE_CURSOR 取代。
SEALED - 类 java.util.jar.Attributes.Name 中的静态变量
Sealed 的 Name 对象给出了用于密封的属性。
SealedObject - javax.crypto 中的 类
此类使程序员能够用加密算法创建对象并保护其机密性。
SealedObject(Serializable, Cipher) - 类 javax.crypto.SealedObject 的构造方法
从任何 Serializable 对象构造一个 SealedObject。
SealedObject(SealedObject) - 类 javax.crypto.SealedObject 的构造方法
根据传入的 SealedObject 构造一个 SealedObject 对象。
search(Object) - 类 java.util.Stack 中的方法
返回对象在堆栈中的位置，以 1 为基数。
search(Name, Attributes, String[]) - 接口 javax.naming.directory.DirContext 中的方法
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
search(String, Attributes, String[]) - 接口 javax.naming.directory.DirContext 中的方法
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
search(Name, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
在单个上下文中搜索包含指定属性集的对象。
search(String, Attributes) - 接口 javax.naming.directory.DirContext 中的方法
在单个上下文中搜索包含指定属性集的对象。
search(Name, String, SearchControls) - 接口 javax.naming.directory.DirContext 中的方法
在命名上下文或对象中搜索符合给定搜索过滤器的项。
search(String, String, SearchControls) - 接口 javax.naming.directory.DirContext 中的方法
在命名上下文或对象中搜索符合给定搜索过滤器的项。
search(Name, String, Object[], SearchControls) - 接口 javax.naming.directory.DirContext 中的方法
在命名上下文或对象中搜索符合给定搜索过滤器的项。
search(String, String, Object[], SearchControls) - 接口 javax.naming.directory.DirContext 中的方法
在命名上下文或对象中搜索符合给定搜索过滤器的项。
search(String, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
search(Name, Attributes) - 类 javax.naming.directory.InitialDirContext 中的方法
search(String, Attributes, String[]) - 类 javax.naming.directory.InitialDirContext 中的方法
search(Name, Attributes, String[]) - 类 javax.naming.directory.InitialDirContext 中的方法
search(String, String, SearchControls) - 类 javax.naming.directory.InitialDirContext 中的方法
search(Name, String, SearchControls) - 类 javax.naming.directory.InitialDirContext 中的方法
search(String, String, Object[], SearchControls) - 类 javax.naming.directory.InitialDirContext 中的方法
search(Name, String, Object[], SearchControls) - 类 javax.naming.directory.InitialDirContext 中的方法
SearchControls - javax.naming.directory 中的 类
此类封装确定搜索范围和搜索返回结果的因子。
SearchControls() - 类 javax.naming.directory.SearchControls 的构造方法
使用默认值构造搜索约束。
SearchControls(int, long, int, String[], boolean, boolean) - 类 javax.naming.directory.SearchControls 的构造方法
使用参数构造搜索约束。
SearchResult - javax.naming.directory 中的 类
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。
SearchResult(String, Object, Attributes) - 类 javax.naming.directory.SearchResult 的构造方法
使用结果的名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String, Object, Attributes, boolean) - 类 javax.naming.directory.SearchResult 的构造方法
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。
SearchResult(String, String, Object, Attributes) - 类 javax.naming.directory.SearchResult 的构造方法
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String, String, Object, Attributes, boolean) - 类 javax.naming.directory.SearchResult 的构造方法
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。
SECOND - 类 java.text.DateFormat.Field 中的静态变量
标识 SECOND 字段的常量。
SECOND - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示一分钟中的秒。
SECOND_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 SECOND 字段的有用常量。
SECONDARY - 类 java.text.Collator 中的静态变量
Collator 的 strength 值。
secondaryOrder(int) - 类 java.text.CollationElementIterator 中的静态方法
返回 collation 元素的第二顺序。
SECONDS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示秒字段的常量。
SECRET_KEY - 类 javax.crypto.Cipher 中的静态变量
用于表示要解包的密钥为“秘密密钥”的常量。
SecretKey - javax.crypto 中的 接口
秘密（对称）密钥。
SecretKeyFactory - javax.crypto 中的 类
此类表示秘密密钥的工厂。
SecretKeyFactory(SecretKeyFactorySpi, Provider, String) - 类 javax.crypto.SecretKeyFactory 的构造方法
创建一个 SecretKeyFactory 对象。
SecretKeyFactorySpi - javax.crypto 中的 类
此类定义 SecretKeyFactory 类的服务提供者接口 (SPI)。
SecretKeyFactorySpi() - 类 javax.crypto.SecretKeyFactorySpi 的构造方法
SecretKeySpec - javax.crypto.spec 中的 类
此类以与 provider 无关的方式指定一个密钥。
SecretKeySpec(byte[], String) - 类 javax.crypto.spec.SecretKeySpec 的构造方法
根据给定的字节数组构造一个密钥。
SecretKeySpec(byte[], int, int, String) - 类 javax.crypto.spec.SecretKeySpec 的构造方法
根据给定的字节数组构造一个密钥，使用 key 中的始于且包含 offset 的前 len 个字节。
SectionElementName - 类 javax.swing.text.AbstractDocument 中的静态变量
用于保存各节（行/段落）的元素名。
SecureCacheResponse - java.net 中的 类
表示最初通过安全方法（如 TLS）获得的缓存响应。
SecureCacheResponse() - 类 java.net.SecureCacheResponse 的构造方法
SecureClassLoader - java.security 中的 类
此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。
SecureClassLoader(ClassLoader) - 类 java.security.SecureClassLoader 的构造方法
使用指定的父类加载器为委托创建新 SecureClassLoader。
SecureClassLoader() - 类 java.security.SecureClassLoader 的构造方法
使用默认的父类加载器为委托创建新 SecureClassLoader。
SecureRandom - java.security 中的 类
此类提供强加密随机数生成器 (RNG)。
SecureRandom() - 类 java.security.SecureRandom 的构造方法
构造一个实现默认随机数算法的安全随机数生成器 (RNG)。
SecureRandom(byte[]) - 类 java.security.SecureRandom 的构造方法
构造一个实现默认随机数算法的安全随机数生成器 (RNG)。
SecureRandom(SecureRandomSpi, Provider) - 类 java.security.SecureRandom 的构造方法
创建 SecureRandom 对象。
SecureRandomSpi - java.security 中的 类
此类为 SecureRandom 类定义了服务提供者接口 (SPI)。
SecureRandomSpi() - 类 java.security.SecureRandomSpi 的构造方法
Security - java.security 中的 类
此类集中了所有的安全属性和常见的安全方法。
SECURITY_AUTHENTICATION - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定将使用的安全级别的环境属性名称。
SECURITY_CREDENTIALS - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定用于验证服务调用者主体证书的环境属性名称。
SECURITY_PRINCIPAL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定用于验证服务调用者主体身份的环境属性名称。
SECURITY_PROTOCOL - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定将使用的安全协议的环境属性名称。
SecurityException - java.lang 中的 异常
由安全管理器抛出的异常，指示存在安全侵犯。
SecurityException() - 异常 java.lang.SecurityException 的构造方法
构造不带详细消息的 SecurityException。
SecurityException(String) - 异常 java.lang.SecurityException 的构造方法
构造带指定详细消息的 SecurityException。
SecurityException(String, Throwable) - 异常 java.lang.SecurityException 的构造方法
创建带指定详细消息和原因的 SecurityException。
SecurityException(Throwable) - 异常 java.lang.SecurityException 的构造方法
创建一个 SecurityException，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含该类和 cause 的详细消息）。
SecurityManager - java.lang 中的 类
安全管理器是一个允许应用程序实现安全策略的类。
SecurityManager() - 类 java.lang.SecurityManager 的构造方法
构造一个新的 SecurityManager。
SecurityPermission - java.security 中的 类
此类用于安全权限。
SecurityPermission(String) - 类 java.security.SecurityPermission 的构造方法
创建具有指定名称的新 SecurityPermission。
SecurityPermission(String, String) - 类 java.security.SecurityPermission 的构造方法
创建具有指定名称的新 SecurityPermission 对象。
seek(long) - 类 java.io.RandomAccessFile 中的方法
设置到此文件开头测量到的文件指针偏移量，在该位置发生下一个读取或写入操作。
seek(long) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
设置当前流位置并将位偏移量重置为 0。
seek(long) - 类 javax.imageio.stream.FileImageInputStream 中的方法
seek(long) - 类 javax.imageio.stream.FileImageOutputStream 中的方法
设置当前流位置并将位偏移量重置为 0。
seek(long) - 接口 javax.imageio.stream.ImageInputStream 中的方法
将当前流位置设置为所需的位置。
seek(long) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
seek(int) - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 将内部指针移动到给定索引。
seek(int) - 类 org.omg.DynamicAny._DynAnyStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynStructStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将当前位置设置为索引。
seek(int) - 类 org.omg.DynamicAny._DynValueStub 中的方法
将当前位置设置为索引。
seek(int) - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
将当前位置设置为索引。
seekForwardOnly - 类 javax.imageio.ImageReader 中的变量
如果当前输入源已经被 setInput 标记为允许只向前搜索，则为 true。
SEG_CLOSE - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量指定应该通过将线段追加到与最新 SEG_MOVETO 对应的点来关闭前面的子路径。
SEG_CUBICTO - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量针对某个 3 个点的集合，指定要根据最新指定点绘制的三次参数曲线。
SEG_LINETO - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量针对某个点，指定要根据最新指定点绘制的线的结束点。
SEG_MOVETO - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量针对某个点，指定新子路径的起始位置。
SEG_QUADTO - 接口 java.awt.geom.PathIterator 中的静态变量
该段类型常量针对某对点，指定要根据最新指定点绘制的二次参数曲线。
Segment - javax.swing.text 中的 类
表示文本片段的字符数组的 segment。
Segment() - 类 javax.swing.text.Segment 的构造方法
创建一个新 segment。
Segment(char[], int, int) - 类 javax.swing.text.Segment 的构造方法
创建一个引用现有数组的新 segment。
SEGMENT_LIMIT - 接口 java.util.jar.Pack200.Packer 中的静态变量
此属性是一个数字，给出了每个存档段的估计目标大小 N（以字节为单位）。
select(int) - 类 java.awt.Choice 中的方法
将此 Choice 菜单中的选定项设置为指定位置上的项。
select(String) - 类 java.awt.Choice 中的方法
将此 Choice 菜单中的选定项设置为其名称等于指定字符串的项。
select(int) - 类 java.awt.List 中的方法
选择滚动列表中指定索引处的项。
select(int, int) - 类 java.awt.TextComponent 中的方法
选择指定开始位置和结束位置之间的文本。
select(URI) - 类 java.net.ProxySelector 中的方法
基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。
select(long) - 类 java.nio.channels.Selector 中的方法
选择一组键，其相应的通道已为 I/O 操作准备就绪。
select() - 类 java.nio.channels.Selector 中的方法
选择一组键，其相应的通道已为 I/O 操作准备就绪。
SELECT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
select(int, int) - 类 javax.swing.text.JTextComponent 中的方法
选定指定的开始和结束位置之间的文本。
select(KeyInfo, KeySelector.Purpose, AlgorithmMethod, XMLCryptoContext) - 类 javax.xml.crypto.KeySelector 中的方法
尝试查找满足指定约束的密钥。
SELECTABLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是某个允许选择子级的对象的子对象，并且此子对象就是这些可以被选择的子对象之一。
SelectableChannel - java.nio.channels 中的 类
可通过 Selector 实现多路复用的通道。
SelectableChannel() - 类 java.nio.channels.SelectableChannel 的构造方法
初始化此类的一个新实例。
selectAdjacentRunTab(int, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectAll() - 类 java.awt.TextComponent 中的方法
选择此文本组件中的所有文本。
selectAll() - 接口 javax.swing.ComboBoxEditor 中的方法
请求编辑器开始编辑并选定所有对象
selectAll() - 类 javax.swing.JTable 中的方法
选择表中的所有行、列和单元格。
selectAll() - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
selectAll() - 类 javax.swing.text.JTextComponent 中的方法
选择 TextComponent 中的所有文本。
selectAllAccessibleSelection() - 类 java.awt.List.AccessibleAWTList 中的方法
如果对象支持多种选择，则导致选择对象中的所有已选择项。
selectAllAccessibleSelection() - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
如果该对象支持多个选择，则会导致该对象的每个子对象都被选择。
selectAllAccessibleSelection() - 接口 javax.accessibility.AccessibleSelection 中的方法
如果该对象支持多项选择，则会导致该对象的每个子对象都被选中。
selectAllAccessibleSelection() - 类 javax.swing.JComboBox.AccessibleJComboBox 中的方法
如果对象支持多个选择，则导致选定对象中的所有子对象。
selectAllAccessibleSelection() - 类 javax.swing.JList.AccessibleJList 中的方法
如果对象支持多种选择，则导致选择对象中的所有选择项。
selectAllAccessibleSelection() - 类 javax.swing.JMenu.AccessibleJMenu 中的方法
如果对象支持多种选择，则通常导致选择对象中的所有选择项。
selectAllAccessibleSelection() - 类 javax.swing.JMenuBar.AccessibleJMenuBar 中的方法
如果对象支持多种选择，则通常导致选择对象中的所有选择项。
selectAllAccessibleSelection() - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
selectAllAccessibleSelection() - 类 javax.swing.JTable.AccessibleJTable 中的方法
只有 JTable 支持多个选择，并且单个单元格选择为启用状态时，才会导致该对象的每个子对象都被选择。
selectAllAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
导致该对象中的所有选择项都被选中，前提是该对象支持多个选择。
selectAllAccessibleSelection() - 类 javax.swing.JTree.AccessibleJTree 中的方法
导致对象中的所有选择项都被选中，前提是对象支持多个选择。
selectAllAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于选中整个文档的动作名称
selectBestTextFlavor(DataFlavor[]) - 类 java.awt.datatransfer.DataFlavor 中的静态方法
从 DataFlavor 数组中选择最佳文本 DataFlavor。
selectColor - 类 javax.swing.plaf.metal.MetalButtonUI 中的变量
selectColor - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的变量
selectColor - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的变量
selectColor - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的变量
selectContent(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出 SELECT 表单元素的内容。
SELECTED - 类 java.awt.event.ItemEvent 中的静态变量
此状态更改值指示项被选定。
SELECTED - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是某个允许选择子级的对象的子对象，且此子对象是已被选定的子对象之一。
SELECTED - 类 javax.swing.DefaultButtonModel 中的静态变量
标识位掩码中“选定的”位，该位指示按纽已被选定。
SELECTED - 接口 javax.swing.plaf.synth.SynthConstants 中的静态变量
指示 region 被选定。
SELECTED - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
selected - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
当前是否选择该值。
SELECTED_CONVERTED_TEXT_HIGHLIGHT - 类 java.awt.im.InputMethodHighlight 中的静态变量
已选定已转换文本的默认高亮显示常量。
SELECTED_FILE_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用户单个文件选择的更改。
SELECTED_FILES_CHANGED_PROPERTY - 类 javax.swing.JFileChooser 中的静态变量
标识用户多个文件选择的更改。
SELECTED_ICON_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识对选定按钮时使用的图标的更改。
SELECTED_KEY - 接口 javax.swing.Action 中的静态变量
用来存储对应于选定状态的 Boolean 值的键。
SELECTED_RAW_TEXT_HIGHLIGHT - 类 java.awt.im.InputMethodHighlight 中的静态变量
已选定原文本的默认高亮显示常量。
selectedItemChanged() - 类 javax.swing.JComboBox 中的方法
此受保护方法是特定于实现的。
selectedItemReminder - 类 javax.swing.JComboBox 中的变量
此受保护字段是特定于实现的。
selectedKeys() - 类 java.nio.channels.Selector 中的方法
返回此选择器的已选择键集。
selectedRun - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
selectedTabPadInsets - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
selectedTextColor - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
selectedTitleColor - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
selectFrame(boolean) - 类 javax.swing.JDesktopPane 中的方法
选择此桌面窗格中的下一个 JInternalFrame。
selectHighlight - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的变量
selectInitialValue() - 类 javax.swing.JOptionPane 中的方法
请求选择初始值，该请求将焦点设置为初始值。
selectInitialValue(JOptionPane) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
如果 inputComponent 为非 null，则请求焦点位于其上；否则请求焦点位于默认值上
selectInitialValue(JOptionPane) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 selectInitialValue 方法。
selectInitialValue(JOptionPane) - 类 javax.swing.plaf.OptionPaneUI 中的方法
请求表示默认值的组件拥有焦点。
selectInputMethod(Locale) - 类 java.awt.im.InputContext 中的方法
试图选择一个支持给定语言环境的输入方法或键盘布局，并返回指示是否成功选定此类输入方法或键盘布局的值。
SELECTION - 类 java.awt.JobAttributes.DefaultSelectionType 中的静态变量
用于指定应该打印当前选择作业页面的 DefaultSelectionType 实例。
selection - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
当前选择的路径。
SELECTION_MODE_PROPERTY - 类 javax.swing.tree.DefaultTreeSelectionModel 中的静态变量
selectionMode 的属性名称。
SELECTION_MODEL_PROPERTY - 类 javax.swing.JColorChooser 中的静态变量
选择模型属性名。
SELECTION_MODEL_PROPERTY - 类 javax.swing.JTree 中的静态变量
selectionModel 的绑定属性名称。
SELECTION_VALUES_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
selectionValues 的绑定属性名。
selectionBackground - 类 javax.swing.JTable 中的变量
已选定单元格的背景色。
selectionBackground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
selectionBackwardAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
通过将插入符在逻辑上向后移动一个位置来扩展选定内容的动作名称。
selectionBeginAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到文档开头的 Action 名称。
selectionBeginLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到行首并扩展选定内容的 Action 名称。
selectionBeginParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到段落开头并扩展选定内容的 Action 名称。
selectionBeginWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到字首并扩展选定内容的 Action 名称。
selectionDownAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向下移动一个位置并扩展选定内容的动作名称。
selectionEndAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到文档末尾的 Action 名称。
selectionEndLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到行尾并扩展选定内容的 Action 名称。
selectionEndParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到段落末尾并扩展选定内容的 Action 名称。
selectionEndWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符移动到字尾并扩展选定内容的动作名称。
selectionForeground - 类 javax.swing.JTable 中的变量
已选定单元格的前景色。
selectionForeground - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的变量
selectionForKey(char, ComboBoxModel) - 接口 javax.swing.JComboBox.KeySelectionManager 中的方法
给定的 aKey 和模型返回应该被选择的行。
selectionForwardAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
通过将插入符在逻辑上向前移动一个位置来扩展选定内容的动作名称。
SelectionKey - java.nio.channels 中的 类
表示 SelectableChannel 在 Selector 中的注册的标记。
SelectionKey() - 类 java.nio.channels.SelectionKey 的构造方法
构造此类的一个实例。
selectionMode - 类 javax.swing.tree.DefaultTreeSelectionModel 中的变量
用于 selection 的模式，将是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION。
selectionModel - 类 javax.swing.JTable 中的变量
表的 ListSelectionModel，用来追踪行选择。
selectionModel - 类 javax.swing.JTree 中的变量
对此树中选择的节点集建模。
selectionModel - 类 javax.swing.table.DefaultTableColumnModel 中的变量
跟踪列选择的模型
selectionModelChanged - 类 javax.swing.plaf.basic.BasicListUI 中的静态变量
selectionNextWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将选定内容移动到下一个字的开头并扩展选定内容的 Action 名称。
selectionPreviousWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将选定内容移动到前一个字的开头并扩展选定内容的 Action 名称。
selectionRedirector - 类 javax.swing.JTree 中的变量
创建一个新事件，并将它传递给 selectionListeners。
selectionUpAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向上移动一个位置并扩展选定内容的动作名称。
selectionValues - 类 javax.swing.JOptionPane 中的变量
用户可以从中选择值的数组。
selectLineAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于选中围绕插入符的某一行的 Action 名称。
selectNextIndex() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
选择下一行并强行使其可见。
selectNextPossibleValue() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
选择列表中的下一项。
selectNextTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectNextTabInRun(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectNow() - 类 java.nio.channels.Selector 中的方法
选择一组键，其相应的通道已为 I/O 操作准备就绪。
selector() - 类 java.nio.channels.SelectionKey 中的方法
返回为此选择器创建的键。
Selector - java.nio.channels 中的 类
SelectableChannel 对象的多路复用器。
Selector() - 类 java.nio.channels.Selector 的构造方法
初始化此类的一个新实例。
SelectorProvider - java.nio.channels.spi 中的 类
用于选择器和可选择通道的服务提供者类。
SelectorProvider() - 类 java.nio.channels.spi.SelectorProvider 的构造方法
初始化此类的一个新实例。
selectParagraphAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于选中围绕插入符的一个段落的动作名称。
selectPathForEvent(TreePath, MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
传递消息以基于特定行上的 MouseEvent 更新选择。
selectPreviousIndex() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
选择前一行并强行使其可见。
selectPreviousPossibleValue() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
选择列表中的上一项。
selectPreviousTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectPreviousTabInRun(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
selectText(int, int) - 接口 javax.accessibility.AccessibleEditableText 中的方法
选中两个索引之间的文本
selectText(int, int) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
选中两个索引之间的文本
selectText(int, int) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
选择两个索引之间的文本。
selectWithKeyChar(char) - 类 javax.swing.JComboBox 中的方法
如果存在与指定键盘字符相对应的项，则选择该列表项并返回 true。
selectWordAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于选中围绕插入符的某个字的 Action 名称。
Semaphore - java.util.concurrent 中的 类
一个计数信号量。
Semaphore(int) - 类 java.util.concurrent.Semaphore 的构造方法
创建具有给定的许可数和非公平的公平设置的 Semaphore。
Semaphore(int, boolean) - 类 java.util.concurrent.Semaphore 的构造方法
创建具有给定的许可数和给定的公平设置的 Semaphore。
send(DatagramPacket) - 类 java.net.DatagramSocket 中的方法
从此套接字发送数据报包。
send(DatagramPacket) - 类 java.net.DatagramSocketImpl 中的方法
发送数据报包。
send(DatagramPacket, byte) - 类 java.net.MulticastSocket 中的方法
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
send(ByteBuffer, SocketAddress) - 类 java.nio.channels.DatagramChannel 中的方法
通过此通道发送数据报。
send(MidiMessage, long) - 接口 javax.sound.midi.Receiver 中的方法
向接收器发送一个 MIDI 消息和时间戳。
send_deferred() - 类 org.omg.CORBA.Request 中的方法
对请求进行异步调用。
send_exception(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 Interceptor 在向客户端抛出异常前查询异常信息并修改应答服务上下文。
send_multiple_requests_deferred(Request[]) - 类 org.omg.CORBA.ORB 中的方法
异步发送多个动态 (DII) 请求。
send_multiple_requests_oneway(Request[]) - 类 org.omg.CORBA.ORB 中的方法
异步发送多个动态 (DII) 请求，并且不期望任何响应。
send_oneway() - 类 org.omg.CORBA.Request 中的方法
在请求上执行单向调用。
send_other(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 Interceptor 在请求引起了正常应答和异常之外的情况时查询可用信息。
send_poll(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
允许 Interceptor 在轮询获取应答序列的与时间无关的调用（Time-Independent Invocation，TII）时查询信息。
send_reply(ServerRequestInfo) - 接口 org.omg.PortableInterceptor.ServerRequestInterceptorOperations 中的方法
允许 Interceptor 在已调用目标操作后、向客户端返回应答前查询应答信息并修改应答服务上下文。
send_request(ClientRequestInfo) - 接口 org.omg.PortableInterceptor.ClientRequestInterceptorOperations 中的方法
允许 Interceptor 在请求被发送到服务器前查询请求信息并修改服务上下文。
sendAttributeChangeNotification(AttributeChangeNotification) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
sendAttributeChangeNotification(Attribute, Attribute) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
sendAttributeChangeNotification(AttributeChangeNotification) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
sendAttributeChangeNotification(Attribute, Attribute) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
sending_exception() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回一个 any，它包含将向客户端返回的异常。
sendNotification(Notification) - 类 javax.management.MBeanServerDelegate 中的方法
允许 MBean 服务器发送通知。
sendNotification(Notification) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
sendNotification(String) - 接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 中的方法
将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
sendNotification(Notification) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
sendNotification(String) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
sendNotification(Notification) - 类 javax.management.NotificationBroadcasterSupport 中的方法
发送一个通知。
sendNotification(Notification) - 类 javax.management.StandardEmitterMBean 中的方法
发送通知。
sendRelationCreationNotification(String) - 类 javax.management.relation.RelationService 中的方法
发送关系创建通知 (RelationNotification)。
sendRelationCreationNotification(String) - 接口 javax.management.relation.RelationServiceMBean 中的方法
发送关系创建通知 (RelationNotification)。
sendRelationRemovalNotification(String, List<ObjectName>) - 类 javax.management.relation.RelationService 中的方法
发送关系移除通知 (RelationNotification)。
sendRelationRemovalNotification(String, List<ObjectName>) - 接口 javax.management.relation.RelationServiceMBean 中的方法
发送关系移除通知 (RelationNotification)。
sendRoleUpdateNotification(String, Role, List<ObjectName>) - 类 javax.management.relation.RelationService 中的方法
发送给定关系中的角色更新通知 (RelationNotification)。
sendRoleUpdateNotification(String, Role, List<ObjectName>) - 接口 javax.management.relation.RelationServiceMBean 中的方法
发送给定关系中的角色更新通知 (RelationNotification)。
sendUrgentData(int) - 类 java.net.Socket 中的方法
在套接字上发送一个紧急数据字节。
sendUrgentData(int) - 类 java.net.SocketImpl 中的方法
在套接字上发送一个紧急数据字节。
SENTENCE - 接口 javax.accessibility.AccessibleText 中的静态变量
用于指示应获取的文本部分是一个语句的常量。
SEPARATE_DOCUMENTS_COLLATED_COPIES - 类 java.awt.JobAttributes.MultipleDocumentHandlingType 中的静态变量
用于指定应该将作业分成单独的、已整理的副本的 MultipleDocumentHandlingType 实例。
SEPARATE_DOCUMENTS_COLLATED_COPIES - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的静态变量
独立文档逐份打印副本 －－ 有关更多信息，请参见上文。
SEPARATE_DOCUMENTS_UNCOLLATED_COPIES - 类 java.awt.JobAttributes.MultipleDocumentHandlingType 中的静态变量
用于指定应该将作业分成单独的、未整理的副本的 MultipleDocumentHandlingType 实例。
SEPARATE_DOCUMENTS_UNCOLLATED_COPIES - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的静态变量
独立文档非逐份打印副本 －－ 有关更多信息，请参见上文。
separator - 类 java.io.File 中的静态变量
与系统有关的默认名称分隔符，为了方便，它被表示为一个字符串。
SEPARATOR - 类 javax.accessibility.AccessibleRole 中的静态变量
通常包含在菜单中的对象，它对菜单中的内容进行可视和逻辑分离。
SEPARATOR - 类 javax.swing.plaf.synth.Region 中的静态变量
Separator 的 region。
separatorChar - 类 java.io.File 中的静态变量
与系统有关的默认名称分隔符。
SeparatorUI - javax.swing.plaf 中的 类
JSeparator 的可插入外观界面。
SeparatorUI() - 类 javax.swing.plaf.SeparatorUI 的构造方法
SEPTEMBER - 类 java.util.Calendar 中的静态变量
指示在格里高利历和罗马儒略历中一年中第九个月的 Calendar.MONTH 字段值。
SEPTEMBER - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
用于一年第九个月的值。
Sequence - javax.sound.midi 中的 类
Sequence 是一种数据结构，包含可由 Sequencer 对象回放的音乐信息（通常是整首歌曲或音乐作品）。
Sequence(float, int) - 类 javax.sound.midi.Sequence 的构造方法
构造具有指定的定时 division 类型和定时精度的新 MIDI Sequence。
Sequence(float, int, int) - 类 javax.sound.midi.Sequence 的构造方法
构造具有指定的定时 division 类型、定时精度和轨道数的新 MIDI Sequence。
sequenceComplete(ImageReader) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告读操作序列已经完成。
SequenceInputStream - java.io 中的 类
SequenceInputStream 表示其他输入流的逻辑串联。
SequenceInputStream(Enumeration<? extends InputStream>) - 类 java.io.SequenceInputStream 的构造方法
通过记住参数来初始化新创建的 SequenceInputStream，该参数必须是生成运行时类型为 InputStream 对象的 Enumeration 型参数。
SequenceInputStream(InputStream, InputStream) - 类 java.io.SequenceInputStream 的构造方法
通过记住这两个参数来初始化新创建的 SequenceInputStream（将按顺序读取这两个参数，先读取 s1，然后读取 s2），以提供从此 SequenceInputStream 读取的字节。
Sequencer - javax.sound.midi 中的 接口
回放 MIDI sequence 的硬件或软件设备就是所谓的 sequencer。
Sequencer.SyncMode - javax.sound.midi 中的 类
SyncMode 对象表示 MIDI sequencer 的时间标记可与主或从设备同步的方式之一。
Sequencer.SyncMode(String) - 类 javax.sound.midi.Sequencer.SyncMode 的构造方法
构造一个同步模式。
sequenceStarted(ImageReader, int) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告读操作序列将要开始。
SerialArray - javax.sql.rowset.serial 中的 类
序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。
SerialArray(Array, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialArray 的构造方法
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialArray(Array) - 类 javax.sql.rowset.serial.SerialArray 的构造方法
根据给定 Array 对象构造新的 SerialArray 对象。
SerialBlob - javax.sql.rowset.serial 中的 类
SQL BLOB 值在 Java 编程语言中的序列化映射关系。
SerialBlob(byte[]) - 类 javax.sql.rowset.serial.SerialBlob 的构造方法
按照给定 byte 数组的序列化形式构造一个 SerialBlob 对象。
SerialBlob(Blob) - 类 javax.sql.rowset.serial.SerialBlob 的构造方法
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。
SerialClob - javax.sql.rowset.serial 中的 类
SQL CLOB 值在 Java 编程语言中的序列化映射关系。
SerialClob(char[]) - 类 javax.sql.rowset.serial.SerialClob 的构造方法
按照给定 char 数组的序列化形式构造一个 SerialClob 对象。
SerialClob(Clob) - 类 javax.sql.rowset.serial.SerialClob 的构造方法
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。
SerialDatalink - javax.sql.rowset.serial 中的 类
SQL DATALINK 值在 Java 编程语言中的序列化映射关系。
SerialDatalink(URL) - 类 javax.sql.rowset.serial.SerialDatalink 的构造方法
根据给定的 java.net.URL 对象构造新的 SerialDatalink 对象。
SerialException - javax.sql.rowset.serial 中的 异常
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。
SerialException() - 异常 javax.sql.rowset.serial.SerialException 的构造方法
创建不带消息的新 SerialException。
SerialException(String) - 异常 javax.sql.rowset.serial.SerialException 的构造方法
创建带有指定消息的新 SerialException。
serializable - 类 java.beans.beancontext.BeanContextServicesSupport 中的变量
可序列化 BeanContextServceProvider 的实例数。
Serializable - java.io 中的 接口
类通过实现 java.io.Serializable 接口以启用其序列化功能。
SerializablePermission - java.io 中的 类
此类用于可序列化权限。
SerializablePermission(String) - 类 java.io.SerializablePermission 的构造方法
创建具有指定名称的新 SerializablePermission。
SerializablePermission(String, String) - 类 java.io.SerializablePermission 的构造方法
创建具有指定名称的新 SerializablePermission 对象。
serialize(ObjectOutputStream, Collection) - 类 java.beans.beancontext.BeanContextSupport 中的方法
writeObject 使用此方法来序列化一个 Collection。
SERIALIZE_ERR - 异常 org.w3c.dom.ls.LSException 中的静态变量
如果尝试使用 LSSerializer 序列化 Node 并且处理已经停止。
SerialJavaObject - javax.sql.rowset.serial 中的 类
SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。
SerialJavaObject(Object) - 类 javax.sql.rowset.serial.SerialJavaObject 的构造方法
SerialJavaObject 帮助器类的构造方法。
SerialRef - javax.sql.rowset.serial 中的 类
Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。
SerialRef(Ref) - 类 javax.sql.rowset.serial.SerialRef 的构造方法
根据给定 Ref 对象构造 SerialRef 对象。
SerialStruct - javax.sql.rowset.serial 中的 类
SQL 结构类型在 Java 编程语言中的序列化映射关系。
SerialStruct(Struct, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialStruct 的构造方法
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。
SerialStruct(SQLData, Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SerialStruct 的构造方法
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
serialVersionUID - 接口 java.rmi.server.RemoteRef 中的静态变量
指示与类的 JDK 1.1.x 版本的兼容性。
serialVersionUID - 接口 java.rmi.server.ServerRef 中的静态变量
指示与类的 JDK 1.1.x 版本的兼容性。
serialVersionUID - 接口 java.security.interfaces.DSAPrivateKey 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 java.security.interfaces.DSAPublicKey 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 java.security.interfaces.ECPrivateKey 中的静态变量
设置为指示序列化兼容性的类指纹。
serialVersionUID - 接口 java.security.interfaces.ECPublicKey 中的静态变量
设置为指示序列化兼容性的类指纹。
serialVersionUID - 接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 中的静态变量
serialVersionUID - 接口 java.security.interfaces.RSAPrivateCrtKey 中的静态变量
serialVersionUID - 接口 java.security.interfaces.RSAPrivateKey 中的静态变量
serialVersionUID - 接口 java.security.interfaces.RSAPublicKey 中的静态变量
serialVersionUID - 接口 java.security.Key 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 java.security.PrivateKey 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 java.security.PublicKey 中的静态变量
设置为指示与以前的类版本序列化兼容的类指纹。
serialVersionUID - 接口 javax.crypto.interfaces.DHPrivateKey 中的静态变量
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
serialVersionUID - 接口 javax.crypto.interfaces.DHPublicKey 中的静态变量
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
serialVersionUID - 接口 javax.crypto.interfaces.PBEKey 中的静态变量
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
serialVersionUID - 接口 javax.crypto.SecretKey 中的静态变量
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
serialVersionUID - 接口 javax.naming.directory.Attribute 中的静态变量
使用 JNDI 1.1.1 中的 serialVersionUID 获取互操作性。
serialVersionUID - 接口 javax.naming.Name 中的静态变量
为指示与以前的类版本序列化兼容而设置的类指纹。
SERIF - 类 java.awt.Font 中的静态变量
逻辑字体 "Serif" 的规范系列名称的 String 常量。
servant - 类 org.omg.CORBA.portable.ServantObject 中的变量
实际的 servant。
Servant - org.omg.PortableServer 中的 类
定义本机 Servant 类型。
Servant() - 类 org.omg.PortableServer.Servant 的构造方法
servant_postinvoke(Object, ServantObject) - 类 org.omg.CORBA.portable.Delegate 中的方法
servant_postinvoke() 由本地 stub 在已经对本地 servant 调用该操作之后调用。
servant_preinvoke(Object, String, Class) - 类 org.omg.CORBA.portable.Delegate 中的方法
返回对应该用作此请求的 servant 的 Java 引用。
SERVANT_RETENTION_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java。
servant_to_id(Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作有四种可能的行为。
servant_to_reference(Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
如果在此 POA 指派的操作的上下文外调用此操作，则需要 RETAIN 策略以及 UNIQUE_ID 或 IMPLICIT_ACTIVATION 策略之一。
ServantActivator - org.omg.PortableServer 中的 接口
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorHelper - org.omg.PortableServer 中的 类
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorHelper() - 类 org.omg.PortableServer.ServantActivatorHelper 的构造方法
ServantActivatorOperations - org.omg.PortableServer 中的 接口
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorPOA - org.omg.PortableServer 中的 类
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
ServantActivatorPOA() - 类 org.omg.PortableServer.ServantActivatorPOA 的构造方法
ServantAlreadyActive - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
ServantAlreadyActive() - 异常 org.omg.PortableServer.POAPackage.ServantAlreadyActive 的构造方法
ServantAlreadyActive(String) - 异常 org.omg.PortableServer.POAPackage.ServantAlreadyActive 的构造方法
ServantAlreadyActiveHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java。
ServantAlreadyActiveHelper() - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 的构造方法
ServantLocator - org.omg.PortableServer 中的 接口
当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
ServantLocatorHelper - org.omg.PortableServer 中的 类
POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。
ServantLocatorHelper() - 类 org.omg.PortableServer.ServantLocatorHelper 的构造方法
ServantLocatorOperations - org.omg.PortableServer 中的 接口
当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
ServantLocatorPOA - org.omg.PortableServer 中的 类
POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。
ServantLocatorPOA() - 类 org.omg.PortableServer.ServantLocatorPOA 的构造方法
ServantManager - org.omg.PortableServer 中的 接口
servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
ServantManagerOperations - org.omg.PortableServer 中的 接口
servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
ServantNotActive - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/ServantNotActive.java。
ServantNotActive() - 异常 org.omg.PortableServer.POAPackage.ServantNotActive 的构造方法
ServantNotActive(String) - 异常 org.omg.PortableServer.POAPackage.ServantNotActive 的构造方法
ServantNotActiveHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java。
ServantNotActiveHelper() - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 的构造方法
ServantObject - org.omg.CORBA.portable 中的 类
此类是本地 stub API 的一部分，其目的是为配置的客户端和服务器（即驻留在同一 Java VM 上的客户端和服务器）提供高性能的调用。
ServantObject() - 类 org.omg.CORBA.portable.ServantObject 的构造方法
ServantRetentionPolicy - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
ServantRetentionPolicyOperations - org.omg.PortableServer 中的 接口
此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
ServantRetentionPolicyValue - org.omg.PortableServer 中的 类
ServantRetentionPolicyValue 可以具有以下值。
ServantRetentionPolicyValue(int) - 类 org.omg.PortableServer.ServantRetentionPolicyValue 的构造方法
server - 类 javax.management.monitor.Monitor 中的变量
对 MBean 服务器的引用。
SERVER_AUTH - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定服务器是否必须验证客户端。
server_id() - 接口 org.omg.PortableInterceptor.ObjectReferenceTemplate 中的方法
server_id() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回使用 -ORBServerId 参数的 ORB::init 上指定的服务器 ID。
ServerCloneException - java.rmi.server 中的 异常
如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
ServerCloneException(String) - 异常 java.rmi.server.ServerCloneException 的构造方法
构造带指定详细消息的 ServerCloneException。
ServerCloneException(String, Exception) - 异常 java.rmi.server.ServerCloneException 的构造方法
构造带指定详细消息和原因的 ServerCloneException。
ServerError - java.rmi 中的 异常
当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
ServerError(String, Error) - 异常 java.rmi.ServerError 的构造方法
构造带指定详细消息和嵌入错误的 ServerError。
ServerException - java.rmi 中的 异常
在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
ServerException(String) - 异常 java.rmi.ServerException 的构造方法
构造带指定详细消息的 ServerException。
ServerException(String, Exception) - 异常 java.rmi.ServerException 的构造方法
构造带有指定详细消息和嵌入异常的 ServerException。
ServerIdHelper - org.omg.PortableInterceptor 中的 类
org/omg/PortableInterceptor/ServerIdHelper.java。
ServerIdHelper() - 类 org.omg.PortableInterceptor.ServerIdHelper 的构造方法
ServerNotActiveException - java.rmi.server 中的 异常
如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
ServerNotActiveException() - 异常 java.rmi.server.ServerNotActiveException 的构造方法
构造不带指定详细消息的 ServerNotActiveException。
ServerNotActiveException(String) - 异常 java.rmi.server.ServerNotActiveException 的构造方法
构造带指定详细消息的 ServerNotActiveException。
ServerRef - java.rmi.server 中的 接口
ServerRef 表示远程对象实现的服务器端句柄。
ServerRequest - org.omg.CORBA 中的 类
捕获对动态框架接口（Dynamic Skeleton Interface，DSI）请求的显式状态的对象。
ServerRequest() - 类 org.omg.CORBA.ServerRequest 的构造方法
ServerRequestInfo - org.omg.PortableInterceptor 中的 接口
服务器端请求 interceptor 可访问的请求信息。
ServerRequestInfoOperations - org.omg.PortableInterceptor 中的 接口
服务器端请求 interceptor 可访问的请求信息。
ServerRequestInterceptor - org.omg.PortableInterceptor 中的 接口
服务器端的请求 interceptor。
ServerRequestInterceptorOperations - org.omg.PortableInterceptor 中的 接口
服务器端的请求 interceptor。
ServerRuntimeException - java.rmi 中的 异常
已过时。 无替换版本
ServerRuntimeException(String, Exception) - 异常 java.rmi.ServerRuntimeException 的构造方法
已过时。 无替换版本
ServerSocket - java.net 中的 类
此类实现服务器套接字。
ServerSocket() - 类 java.net.ServerSocket 的构造方法
创建非绑定服务器套接字。
ServerSocket(int) - 类 java.net.ServerSocket 的构造方法
创建绑定到特定端口的服务器套接字。
ServerSocket(int, int) - 类 java.net.ServerSocket 的构造方法
利用指定的 backlog 创建服务器套接字并将其绑定到指定的本地端口号。
ServerSocket(int, int, InetAddress) - 类 java.net.ServerSocket 的构造方法
使用指定的端口、侦听 backlog 和要绑定到的本地 IP 地址创建服务器。
ServerSocketChannel - java.nio.channels 中的 类
针对面向流的侦听套接字的可选择通道。
ServerSocketChannel(SelectorProvider) - 类 java.nio.channels.ServerSocketChannel 的构造方法
初始化此类的一个新实例。
ServerSocketFactory - javax.net 中的 类
此类创建服务器套接字。
ServerSocketFactory() - 类 javax.net.ServerSocketFactory 的构造方法
创建服务器套接字工厂。
Service - javax.xml.ws 中的 类
Service 对象提供 Web 服务的客户端视图。
Service(URL, QName) - 类 javax.xml.ws.Service 的构造方法
Service.Mode - javax.xml.ws 中的 枚举
动态客户端或服务的方向。
service_detail - 类 org.omg.CORBA.ServiceDetail 中的变量
描述此 ServiceDetail 对象所表示的 ORB 服务的数据。
service_detail_type - 类 org.omg.CORBA.ServiceDetail 中的变量
此 ServiceDetail 对象表示的 ORB 服务的类型。
service_details - 类 org.omg.CORBA.ServiceInformation 中的变量
提供有关服务更多详细信息的 ServiceDetail 所组成的数组。
SERVICE_OFF_LINE - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
打印机离线，不接受作业。
service_options - 类 org.omg.CORBA.ServiceInformation 中的变量
表示服务选项的 int 值所组成的数组。
serviceAvailable(BeanContextServiceAvailableEvent) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
可从嵌套 BeanContext 中获得新的服务。
serviceAvailable(BeanContextServiceAvailableEvent) - 接口 java.beans.beancontext.BeanContextServicesListener 中的方法
指定服务已被注册。
serviceAvailable(BeanContextServiceAvailableEvent) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。
serviceClass - 类 java.beans.beancontext.BeanContextServiceAvailableEvent 中的变量
新近可用服务的 Class 引用
serviceClass - 类 java.beans.beancontext.BeanContextServiceRevokedEvent 中的变量
将被取消服务的 Class 引用。
ServiceConfigurationError - java.util 中的 错误
在加载服务提供者的过程中出错时抛出的错误。
ServiceConfigurationError(String) - 错误 java.util.ServiceConfigurationError 的构造方法
构造一个带有指定消息的新实例。
ServiceConfigurationError(String, Throwable) - 错误 java.util.ServiceConfigurationError 的构造方法
构造一个带有指定消息和 cause 的新实例。
ServiceContext - org.omg.IOP 中的 类
org/omg/IOP/ServiceContext.java。
ServiceContext() - 类 org.omg.IOP.ServiceContext 的构造方法
ServiceContext(int, byte[]) - 类 org.omg.IOP.ServiceContext 的构造方法
ServiceContextHelper - org.omg.IOP 中的 类
org/omg/IOP/ServiceContextHelper.java。
ServiceContextHelper() - 类 org.omg.IOP.ServiceContextHelper 的构造方法
ServiceContextHolder - org.omg.IOP 中的 类
org/omg/IOP/ServiceContextHolder.java。
ServiceContextHolder() - 类 org.omg.IOP.ServiceContextHolder 的构造方法
ServiceContextHolder(ServiceContext) - 类 org.omg.IOP.ServiceContextHolder 的构造方法
ServiceContextListHelper - org.omg.IOP 中的 类
形成服务上下文列表的一组服务上下文。
ServiceContextListHelper() - 类 org.omg.IOP.ServiceContextListHelper 的构造方法
ServiceContextListHolder - org.omg.IOP 中的 类
形成服务上下文列表的一组服务上下文。
ServiceContextListHolder() - 类 org.omg.IOP.ServiceContextListHolder 的构造方法
ServiceContextListHolder(ServiceContext[]) - 类 org.omg.IOP.ServiceContextListHolder 的构造方法
ServiceDelegate - javax.xml.ws.spi 中的 类
服务委托由 Service 对象内部使用，以允许插入 JAX-WS 实现。
ServiceDelegate() - 类 javax.xml.ws.spi.ServiceDelegate 的构造方法
ServiceDetail - org.omg.CORBA 中的 类
表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。
ServiceDetail() - 类 org.omg.CORBA.ServiceDetail 的构造方法
使用 0 作为 ORB 服务的类型并使用空描述构造一个 ServiceDetail 对象。
ServiceDetail(int, byte[]) - 类 org.omg.CORBA.ServiceDetail 的构造方法
使用给定 ORB 服务类型和给定描述构造一个 ServiceDetail 对象。
ServiceDetailHelper - org.omg.CORBA 中的 类
ServiceDetailHelper() - 类 org.omg.CORBA.ServiceDetailHelper 的构造方法
ServiceIdHelper - org.omg.IOP 中的 类
以 int 形式表示的服务 id
ServiceIdHelper() - 类 org.omg.IOP.ServiceIdHelper 的构造方法
ServiceInformation - org.omg.CORBA 中的 类
CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。
ServiceInformation() - 类 org.omg.CORBA.ServiceInformation 的构造方法
使用空 service_options 和 service_details 构造一个 ServiceInformation 对象。
ServiceInformation(int[], ServiceDetail[]) - 类 org.omg.CORBA.ServiceInformation 的构造方法
使用给定 service_options 和 service_details 构造一个 ServiceInformation 对象。
ServiceInformationHelper - org.omg.CORBA 中的 类
ServiceInformationHelper() - 类 org.omg.CORBA.ServiceInformationHelper 的构造方法
ServiceInformationHolder - org.omg.CORBA 中的 类
ServiceInformation 的 Holder。
ServiceInformationHolder() - 类 org.omg.CORBA.ServiceInformationHolder 的构造方法
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为 null。
ServiceInformationHolder(ServiceInformation) - 类 org.omg.CORBA.ServiceInformationHolder 的构造方法
构造一个新的 ServiceInformationHolder 对象，将其 value 字段初始化为给定的 ServiceInformation 对象。
ServiceLoader<S> - java.util 中的 类
一个简单的服务提供者加载设施。
ServiceMode - javax.xml.ws 中的 注释类型
用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
ServiceNotFoundException - javax.management 中的 异常
表示请求的服务不受支持时引发的异常。
ServiceNotFoundException() - 异常 javax.management.ServiceNotFoundException 的构造方法
默认的构造方法。
ServiceNotFoundException(String) - 异常 javax.management.ServiceNotFoundException 的构造方法
允许指定特定错误消息的构造方法。
ServicePermission - javax.security.auth.kerberos 中的 类
此类用于保护 Kerberos 服务和访问这些服务所必需的证书。
ServicePermission(String, String) - 类 javax.security.auth.kerberos.ServicePermission 的构造方法
创建带指定的 servicePrincipal 和 action 的新 ServicePermission。
serviceProvider - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider 中的变量
ServiceRegistry - javax.imageio.spi 中的 类
用于服务提供者实例的注册表。
ServiceRegistry(Iterator<Class<?>>) - 类 javax.imageio.spi.ServiceRegistry 的构造方法
使用取自 categories 参数的一组类别构造 ServiceRegistry 实例。
ServiceRegistry.Filter - javax.imageio.spi 中的 接口
ServiceRegistry.getServiceProviders 使用的一个简单过滤器接口，用来选择与任意条件匹配的提供者。
serviceRevoked(BeanContextServiceRevokedEvent) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
由嵌套 BeanContext 提供的服务已经被取消。
serviceRevoked(BeanContextServiceRevokedEvent) - 接口 java.beans.beancontext.BeanContextServiceRevokedListener 中的方法
指定服务已被取消。
serviceRevoked(BeanContextServiceRevokedEvent) - 类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 中的方法
serviceRevoked(BeanContextServiceRevokedEvent) - 类 java.beans.beancontext.BeanContextServicesSupport 中的方法
BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。
services - 类 java.beans.beancontext.BeanContextServicesSupport 中的变量
protected transient HashMap services 字段的所有访问在该对象上都应该是同步的。
ServiceUI - javax.print 中的 类
此类是各种 UI 便捷方法的集合，这些方法为浏览那些通过 Java Print Service API 所查找的 PrintService 提供了图形用户对话框。
ServiceUI() - 类 javax.print.ServiceUI 的构造方法
ServiceUIFactory - javax.print 中的 类
服务可以可选地提供 UI，这些 UI 允许以不同的角色进行不同风格的交互。
ServiceUIFactory() - 类 javax.print.ServiceUIFactory 的构造方法
ServiceUnavailableException - javax.naming 中的 异常
当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
ServiceUnavailableException(String) - 异常 javax.naming.ServiceUnavailableException 的构造方法
使用解释构造一个新的 ServiceUnavailableException 实例。
ServiceUnavailableException() - 异常 javax.naming.ServiceUnavailableException 的构造方法
构造一个新的 ServiceUnavailableException 实例。
SERVLET_CONTEXT - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：servlet 上下文对象
SERVLET_REQUEST - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：servlet 请求对象。
SERVLET_RESPONSE - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：servlet 响应对象。
SESSION_MAINTAIN_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
标准属性：服务客户端使用此 boolean 属性指示它是否希望参与与服务端点的会话。
set(Object, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
替换此参数列表中的一个 Object。
set(byte, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Byte 替换参数列表中的一个 Object。
set(char, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Character 替换参数列表中的一个 Object。
set(short, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Short 替换参数列表中的一个 Object。
set(int, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Integer 替换参数列表中的一个 Object。
set(long, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Long 替换参数列表中的一个 Object。
set(float, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Float 替换参数列表中的一个 Object。
set(double, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
使用 Double 替换参数列表中的一个 Object。
set(int, int, int, int) - 类 java.awt.Insets 中的方法
将顶部、底部、左边和右边设置为指定值
set(JobAttributes) - 类 java.awt.JobAttributes 中的方法
将此 JobAttributes 的所有属性设置为与 obj 的属性相同的值。
set(PageAttributes) - 类 java.awt.PageAttributes 中的方法
将此 PageAttributes 的所有属性设置为与 obj 的属性相同的值。
set(Object, int, Object) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的新值。
set(Object, Object) - 类 java.lang.reflect.Field 中的方法
将指定对象变量上此 Field 对象表示的字段设置为指定的新值。
set(T) - 类 java.lang.ThreadLocal 中的方法
将此线程局部变量的当前线程副本中的值设置为指定值。
set(String, String, int, String, String) - 类 java.net.URL 中的方法
设置 URL 的字段。
set(String, String, int, String, String, String, String, String) - 类 java.net.URL 中的方法
设置 URL 的指定的 8 个字段。
set(int, E) - 类 java.util.AbstractList 中的方法
用指定元素替换列表中指定位置的元素（可选操作）。
set(int, E) - 类 java.util.AbstractSequentialList 中的方法
用指定的元素替代此列表中指定位置上的元素（可选操作）。
set(int, E) - 类 java.util.ArrayList 中的方法
用指定的元素替代此列表中指定位置上的元素。
set(int) - 类 java.util.BitSet 中的方法
将指定索引处的位设置为 true。
set(int, boolean) - 类 java.util.BitSet 中的方法
将指定索引处的位设置为指定的值。
set(int, int) - 类 java.util.BitSet 中的方法
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为 true。
set(int, int, boolean) - 类 java.util.BitSet 中的方法
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为指定的值。
set(int, int) - 类 java.util.Calendar 中的方法
将给定的日历字段设置为给定值。
set(int, int, int) - 类 java.util.Calendar 中的方法
设置日历字段 YEAR、MONTH 和 DAY_OF_MONTH 的值。
set(int, int, int, int, int) - 类 java.util.Calendar 中的方法
设置日历字段 YEAR、MONTH、DAY_OF_MONTH、HOUR_OF_DAY 和 MINUTE 的值。
set(int, int, int, int, int, int) - 类 java.util.Calendar 中的方法
设置字段 YEAR、MONTH、DAY_OF_MONTH、HOUR、MINUTE 和 SECOND 的值。
set(boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
无条件地设置为给定值。
set(int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
设置为给定值。
set(int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
将位置 i 的元素设置为给定值。
set(T, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
将此更新器管理的给定对象的字段设置为给定更新值。
set(long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
设置为给定值。
set(int, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
将位置 i 的元素设置为给定值。
set(T, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
将此更新器管理的给定对象的字段设置为给定更新值。
set(V, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
无条件地同时设置该引用和标记的值。
set(V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
设置为给定值。
set(int, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
将位置 i 的元素设置为给定值。
set(T, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
将此更新器管理的给定对象的字段设置为给定更新值。
set(V, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
无条件地同时设置该引用和标志的值。
set(int, E) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
用指定的元素替代此列表指定位置上的元素。
set(V) - 类 java.util.concurrent.FutureTask 中的方法
除非已经设置了此 Future 或已将其取消，否则将其结果设置为给定的值。
set(int, E) - 类 java.util.LinkedList 中的方法
将此列表中指定位置的元素替换为指定的元素。
set(int, E) - 接口 java.util.List 中的方法
用指定元素替换列表中指定位置的元素（可选操作）。
set(E) - 接口 java.util.ListIterator 中的方法
用指定元素替换 next 或 previous 返回的最后一个元素（可选操作）。
Set<E> - java.util 中的 接口
一个不包含重复元素的 collection。
set(int, E) - 类 java.util.Vector 中的方法
用指定的元素替换此向量中指定位置处的元素。
set(String, String) - 类 javax.activation.MimeTypeParameterList 中的方法
将值设置为与给定名称关联，替换以前的任何关联。
set(int, Attribute) - 类 javax.management.AttributeList 中的方法
将指定位置的元素设置为指定的属性。
set(int, Object) - 类 javax.management.AttributeList 中的方法
set(int, Role) - 类 javax.management.relation.RoleList 中的方法
将指定位置处的元素设置为指定角色。
set(int, Object) - 类 javax.management.relation.RoleList 中的方法
set(int, RoleUnresolved) - 类 javax.management.relation.RoleUnresolvedList 中的方法
将指定位置处的元素设置为指定的未解析角色。
set(int, Object) - 类 javax.management.relation.RoleUnresolvedList 中的方法
set(int, Object) - 接口 javax.naming.directory.Attribute 中的方法
设置属性值的有序列表中的属性值。
set(int, Object) - 类 javax.naming.directory.BasicAttribute 中的方法
set(int, Object) - 类 javax.swing.DefaultListModel 中的方法
使用指定元素替换此列表中指定位置上的元素。
set2DigitYearStart(Date) - 类 java.text.SimpleDateFormat 中的方法
设置 100 年周期的两位数年份，该年份将被解释为从用户指定的日期开始。
set_as_default() - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 确定与此 union 关联的鉴别符是否已经分配了一个有效默认值。
set_as_default(boolean) - 接口 org.omg.CORBA.DynUnion 中的方法
已过时。 确定与此 union 关联的鉴别符是否被分配了一个有效默认值。
set_as_string(String) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
set_as_string(String) - 接口 org.omg.DynamicAny.DynEnumOperations 中的方法
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。
set_as_ulong(int) - 类 org.omg.DynamicAny._DynEnumStub 中的方法
将 DynEnum 的值设置为枚举值的序号。
set_as_ulong(int) - 接口 org.omg.DynamicAny.DynEnumOperations 中的方法
将 DynEnum 的值设置为枚举值的序号。
set_boxed_value(Any) - 接口 org.omg.DynamicAny.DynValueBoxOperations 中的方法
使用指定值取代已装箱值。
set_boxed_value_as_dyn_any(DynAny) - 接口 org.omg.DynamicAny.DynValueBoxOperations 中的方法
使用参数中包含的值取代已装箱值。
set_delegate(Object) - 类 org.omg.CORBA_2_3.ORB 中的方法
set_discriminator(DynAny) - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将 DynUnion 的鉴别符值设置为指定值。
set_discriminator(DynAny) - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
将 DynUnion 的鉴别符值设置为指定值。
set_elements(Any[]) - 接口 org.omg.CORBA.DynArray 中的方法
已过时。 将此 DynArray 对象的值设置为给定数组。
set_elements(Any[]) - 接口 org.omg.CORBA.DynSequence 中的方法
已过时。 使用给定数组设置此 sequence 中所有元素的值。
set_elements(Any[]) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
设置 DynArray 以包含传递的元素。
set_elements(Any[]) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
设置序列的元素。
set_elements(Any[]) - 接口 org.omg.DynamicAny.DynArrayOperations 中的方法
设置 DynArray 以包含传递的元素。
set_elements(Any[]) - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
设置序列的元素。
set_elements_as_dyn_any(DynAny[]) - 类 org.omg.DynamicAny._DynArrayStub 中的方法
设置 DynArray 以包含传递的元素。
set_elements_as_dyn_any(DynAny[]) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
使用 DynAny 设置序列的元素。
set_elements_as_dyn_any(DynAny[]) - 接口 org.omg.DynamicAny.DynArrayOperations 中的方法
设置 DynArray 以包含传递的元素。
set_elements_as_dyn_any(DynAny[]) - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
使用 DynAny 设置序列的元素。
set_exception(Any) - 类 org.omg.CORBA.ServerRequest 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
set_length(int) - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
设置序列的长度。
set_length(int) - 接口 org.omg.DynamicAny.DynSequenceOperations 中的方法
设置序列的长度。
set_members(NameValuePair[]) - 接口 org.omg.CORBA.DynStruct 中的方法
已过时。 设置 struct 的成员。
set_members(NameValuePair[]) - 接口 org.omg.CORBA.DynValue 中的方法
已过时。 将此 DynValue 对象表示的 value 对象成员设置为给定的 NameValuePair 对象数组。
set_members(NameValuePair[]) - 类 org.omg.DynamicAny._DynStructStub 中的方法
初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
set_members(NameValuePair[]) - 类 org.omg.DynamicAny._DynValueStub 中的方法
根据 NameValuePair 序列初始化该值类型的成员。
set_members(NameValuePair[]) - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
初始化与 NameValuePair 序列中的 DynStruct 对象关联的结构数据值。
set_members(NameValuePair[]) - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
根据 NameValuePair 序列初始化该值类型的成员。
set_members_as_dyn_any(NameDynAnyPair[]) - 类 org.omg.DynamicAny._DynStructStub 中的方法
初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
set_members_as_dyn_any(NameDynAnyPair[]) - 类 org.omg.DynamicAny._DynValueStub 中的方法
根据 NameDynAnyPair 序列初始化该值类型的成员。
set_members_as_dyn_any(NameDynAnyPair[]) - 接口 org.omg.DynamicAny.DynStructOperations 中的方法
初始化与 NameDynAnyPair 序列中的 DynStruct 对象关联的结构数据值。
set_members_as_dyn_any(NameDynAnyPair[]) - 接口 org.omg.DynamicAny.DynValueOperations 中的方法
根据 NameDynAnyPair 序列初始化该值类型的成员。
set_one_value(String, Any) - 类 org.omg.CORBA.Context 中的方法
创建一个 NamedValue 对象，并将它添加到此 Context 对象中。
SET_OVERRIDE - 类 org.omg.CORBA.SetOverrideType 中的静态变量
用于枚举值 SET_OVERRIDE 的 SetOverrideType 常量。
set_parameters(String[], Properties) - 类 org.omg.CORBA.ORB 中的方法
允许使用给定的参数和属性初始化 ORB 实现。
set_parameters(Applet, Properties) - 类 org.omg.CORBA.ORB 中的方法
允许使用给定 applet 和参数初始化 ORB 实现。
set_policy_override(Object, Policy[], SetOverrideType) - 类 org.omg.CORBA.portable.Delegate 中的方法
将传入的策略与它返回的新创建对象引用关联。
set_result(Any) - 类 org.omg.CORBA.ServerRequest 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
set_return_type(TypeCode) - 类 org.omg.CORBA.Request 中的方法
设置该方法返回值的 typecode。
set_servant(Servant) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作在 POA 中将指定的 servant 注册为默认 servant。
set_servant_manager(ServantManager) - 接口 org.omg.PortableServer.POAOperations 中的方法
此操作设置与 POA 关联的默认 servant 管理器。
set_slot(int, Any) - 接口 org.omg.PortableInterceptor.CurrentOperations 中的方法
在槽中设置数据。
set_slot(int, Any) - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
允许 Interceptor 在请求域中的 PortableInterceptor.Current 内设置槽 (slot)。
set_to_default_member() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将鉴别符设置为联合数据的默认 case 的值。
set_to_default_member() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
将鉴别符设置为联合数据的默认 case 的值。
set_to_no_active_member() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
将鉴别符设置为与任何联合数据 case 标签都不相应的值。
set_to_no_active_member() - 接口 org.omg.DynamicAny.DynUnionOperations 中的方法
将鉴别符设置为与任何联合数据 case 标签都不相应的值。
set_to_null() - 类 org.omg.DynamicAny._DynValueStub 中的方法
将 DynValueCommon 的表示形式更改为 null 值类型。
set_to_null() - 接口 org.omg.DynamicAny.DynValueCommonOperations 中的方法
将 DynValueCommon 的表示形式更改为 null 值类型。
set_to_value() - 类 org.omg.DynamicAny._DynValueStub 中的方法
使用新构造的值取代 null 值类型。
set_to_value() - 接口 org.omg.DynamicAny.DynValueCommonOperations 中的方法
使用新构造的值取代 null 值类型。
set_value(byte[]) - 接口 org.omg.CORBA.DynFixed 中的方法
已过时。 将给定 fixed 类型的实例设置为此 DynFixed 对象的值。
set_value(String) - 类 org.omg.DynamicAny._DynFixedStub 中的方法
设置 DynFixed 的值。
set_value(String) - 接口 org.omg.DynamicAny.DynFixedOperations 中的方法
设置 DynFixed 的值。
set_values(NVList) - 类 org.omg.CORBA.Context 中的方法
在此 Context 对象中设置一个或多个属性值。
setAccelerationPriority(float) - 类 java.awt.Image 中的方法
就加速的重要性设置此图像的提示。
setAccelerator(KeyStroke) - 类 javax.swing.JMenu 中的方法
没有为 JMenu 定义 setAccelerator。
setAccelerator(KeyStroke) - 类 javax.swing.JMenuItem 中的方法
设置修改键，它能直接调用菜单项的操作侦听器而不必显示菜单的层次结构。
setAcceptAllFileFilterUsed(boolean) - 类 javax.swing.JFileChooser 中的方法
确定是否将 AcceptAll FileFilter 用作可选择过滤器列表中一个可用选项。
setAccessible(AccessibleObject[], boolean) - 类 java.lang.reflect.AccessibleObject 中的静态方法
使用单一安全性检查（为了提高效率）为一组对象设置 accessible 标志的便捷方法。
setAccessible(boolean) - 类 java.lang.reflect.AccessibleObject 中的方法
将此对象的 accessible 标志设置为指示的布尔值。
setAccessibleCaption(Accessible) - 接口 javax.accessibility.AccessibleTable 中的方法
设置表的标题。
setAccessibleCaption(Accessible) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置表的标题。
setAccessibleColumnDescription(int, Accessible) - 接口 javax.accessibility.AccessibleTable 中的方法
设置表中指定列的描述文本。
setAccessibleColumnDescription(int, Accessible) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置表中指定列的描述文本。
setAccessibleColumnHeader(AccessibleTable) - 接口 javax.accessibility.AccessibleTable 中的方法
设置列标题。
setAccessibleColumnHeader(AccessibleTable) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置以 AccessibleTable 表示的列标题。
setAccessibleDescription(String) - 类 javax.accessibility.AccessibleContext 中的方法
设置此对象的可访问描述。
setAccessibleDescription(String) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setAccessibleDescription(String) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的可访问的描述。
setAccessibleDescription(String) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
设置此对象的可访问描述。
setAccessibleDescription(String) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setAccessibleIconDescription(String) - 接口 javax.accessibility.AccessibleIcon 中的方法
设置图标的描述。
setAccessibleIconDescription(String) - 类 javax.swing.ImageIcon.AccessibleImageIcon 中的方法
设置图标的描述。
setAccessibleName(String) - 类 javax.accessibility.AccessibleContext 中的方法
设置此对象的可访问的本地化名称。
setAccessibleName(String) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setAccessibleName(String) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
获取此对象的可访问的本地化名称。
setAccessibleName(String) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
设置此对象的本地化可访问名称。
setAccessibleName(String) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setAccessibleParent(Accessible) - 类 javax.accessibility.AccessibleContext 中的方法
设置此对象的 Accessible 父对象。
setAccessibleRowDescription(int, Accessible) - 接口 javax.accessibility.AccessibleTable 中的方法
设置表中指定行的描述文本。
setAccessibleRowDescription(int, Accessible) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置表中指定行的描述文本。
setAccessibleRowHeader(AccessibleTable) - 接口 javax.accessibility.AccessibleTable 中的方法
设置行标题。
setAccessibleRowHeader(AccessibleTable) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置以 AccessibleTable 表示的列标题。
setAccessibleSummary(Accessible) - 接口 javax.accessibility.AccessibleTable 中的方法
设置表的摘要描述。
setAccessibleSummary(Accessible) - 类 javax.swing.JTable.AccessibleJTable 中的方法
设置表的摘要描述。
setAccessory(JComponent) - 类 javax.swing.JFileChooser 中的方法
设置 accessory 组件。
setAction(Action) - 类 javax.swing.AbstractButton 中的方法
设置 Action。
setAction(Action) - 类 javax.swing.JComboBox 中的方法
设置 ActionEvent 源的 Action。
setAction(Action) - 类 javax.swing.JTextField 中的方法
设置 ActionEvent 源的 Action。
setActionCommand(String) - 类 java.awt.Button 中的方法
设置此按钮激发的动作事件的命令名称。
setActionCommand(String) - 类 java.awt.MenuItem 中的方法
设置由此菜单项引发的动作事件的命令名。
setActionCommand(String) - 类 java.awt.TrayIcon 中的方法
设置由此托盘图标触发的动作事件的命令名。
setActionCommand(String) - 类 javax.swing.AbstractButton 中的方法
设置此按钮的动作命令。
setActionCommand(String) - 接口 javax.swing.ButtonModel 中的方法
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。
setActionCommand(String) - 类 javax.swing.DefaultButtonModel 中的方法
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。
setActionCommand(String) - 类 javax.swing.JComboBox 中的方法
设置发送到动作侦听器的事件中应该包括的动作命令。
setActionCommand(String) - 类 javax.swing.JTextField 中的方法
设置用于操作事件的命令字符串。
setActionCommand(String) - 类 javax.swing.Timer 中的方法
设置将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。
setActionMap(ActionMap) - 类 javax.swing.JComponent 中的方法
将 ActionMap 设置为 am。
setActivationDesc(ActivationID, ActivationDesc) - 接口 java.rmi.activation.ActivationSystem 中的方法
为具有激活标识符 id 的对象设置激活描述符 desc。
setActivationGroupDesc(ActivationGroupID, ActivationGroupDesc) - 接口 java.rmi.activation.ActivationSystem 中的方法
为具有激活组标识符 id 的对象设置激活组描述符 desc。
setActive(boolean) - 类 java.awt.dnd.DropTarget 中的方法
如果为 true，则将 DropTarget 设置为激活状态；如果为 false，则将 DropTarget 设置为非激活状态。
setActor(String) - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
将与此 SOAPHeaderElement 对象关联的 actor 设置为指定 actor。
setAdapter(XmlAdapter) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setAdapter(Class<A>, A) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setAdapter(XmlAdapter) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setAdapter(Class<A>, A) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setAdapter(XmlAdapter) - 接口 javax.xml.bind.Marshaller 中的方法
将已配置的 XmlAdapter 实例与此 marshaller 关联。
setAdapter(Class<A>, A) - 接口 javax.xml.bind.Marshaller 中的方法
将已配置的 XmlAdapter 实例与此 marshaller 关联。
setAdapter(XmlAdapter) - 接口 javax.xml.bind.Unmarshaller 中的方法
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
setAdapter(Class<A>, A) - 接口 javax.xml.bind.Unmarshaller 中的方法
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
setAddress(InetAddress) - 类 java.net.DatagramPacket 中的方法
设置要将此数据报发往的那台机器的 IP 地址。
setAlignment(int) - 类 java.awt.FlowLayout 中的方法
设置此布局的对齐方式。
setAlignment(int) - 类 java.awt.Label 中的方法
将此标签的对齐方式设置为指定的方式。
setAlignment(MutableAttributeSet, int) - 类 javax.swing.text.StyleConstants 中的静态方法
设置对齐方式。
setAlignmentX(float) - 类 javax.swing.JComponent 中的方法
设置垂直对齐方式。
setAlignmentY(float) - 类 javax.swing.JComponent 中的方法
设置水平对齐方式。
setAlignOnBaseline(boolean) - 类 java.awt.FlowLayout 中的方法
设置组件是否应该沿着其基线垂直对齐。
setAllocation(Shape) - 类 javax.swing.text.AsyncBoxView.ChildLocator 中的方法
将当前已分配的形状复制到用于存储当前分配区域的 Rectangle 中。
setAllowsChildren(boolean) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
确定是否允许此节点拥有子节点。
setAllowsInvalid(boolean) - 类 javax.swing.text.DefaultFormatter 中的方法
设置编辑的值在一段时间内是否允许为无效（也就是说，stringToValue 是否抛出 ParseException）。
setAllowUserInteraction(boolean) - 类 java.net.URLConnection 中的方法
设置此 URLConnection 的 allowUserInteraction 字段的值。
setAltName(Name) - 异常 javax.naming.CannotProceedException 中的方法
设置此异常的 altName 字段。
setAltNameCtx(Context) - 异常 javax.naming.CannotProceedException 中的方法
设置此异常的 altNameCtx 字段。
setAlwaysOnTop(boolean) - 类 java.awt.Window 中的方法
设置此窗口是否应该始终位于其他窗口上方。
setAmPmStrings(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置 ampm 字符串。
setAnchorSelectionIndex(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 anchor 选择索引，并不作更改地保留所有选择值。
setAnchorSelectionIndex(int) - 接口 javax.swing.ListSelectionModel 中的方法
设置 anchor 选择索引。
setAnchorSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
将标识的路径设置为定位路径。
setAngleExtent(double) - 类 java.awt.geom.Arc2D.Double 中的方法
将此弧的角跨越设置为指定的 double 值。
setAngleExtent(double) - 类 java.awt.geom.Arc2D.Float 中的方法
将此弧的角跨越设置为指定的 double 值。
setAngleExtent(double) - 类 java.awt.geom.Arc2D 中的方法
将此弧的角跨越设置为指定的 double 值。
setAngles(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
使用两组坐标设置此弧的起始角度和角跨越。
setAngles(Point2D, Point2D) - 类 java.awt.geom.Arc2D 中的方法
使用两个点设置此弧的起始角度和角跨越。
setAngleStart(double) - 类 java.awt.geom.Arc2D.Double 中的方法
将此弧的起始角度设置为指定的 double 值。
setAngleStart(double) - 类 java.awt.geom.Arc2D.Float 中的方法
将此弧的起始角度设置为指定的 double 值。
setAngleStart(double) - 类 java.awt.geom.Arc2D 中的方法
将此弧的起始角度设置为指定的 double 值。
setAngleStart(Point2D) - 类 java.awt.geom.Arc2D 中的方法
将此弧的起始角度设置为由指定点定义、相对于此弧中心的角度。
setAnimated(boolean) - 类 java.awt.image.MemoryImageSource 中的方法
根据 animated 参数将此内存图像更改为多帧动画或单帧静态图像。
setAnimationIndex(int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
将当前动画窗体的索引设置为指定的值，并请求重绘进度条。
setAnyPolicyInhibited(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置状态，以确定当证书中包括了策略 OID 时是否应该处理它。
setApproveButtonMnemonic(int) - 类 javax.swing.JFileChooser 中的方法
使用数值键代码设置确认按钮的助记符。
setApproveButtonMnemonic(char) - 类 javax.swing.JFileChooser 中的方法
使用字符设置确认按钮的助记符。
setApproveButtonText(String) - 类 javax.swing.JFileChooser 中的方法
设置 FileChooserUI 中的 ApproveButton 内使用的文本。
setApproveButtonToolTipText(String) - 类 javax.swing.JFileChooser 中的方法
设置 ApproveButton 中使用的工具提示文本。
setArc(double, double, double, double, double, double, int) - 类 java.awt.geom.Arc2D.Double 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
setArc(double, double, double, double, double, double, int) - 类 java.awt.geom.Arc2D.Float 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
setArc(double, double, double, double, double, double, int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
setArc(Point2D, Dimension2D, double, double, int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定值。
setArc(Rectangle2D, double, double, int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、大小、角跨越和闭合类型设置为指定值。
setArc(Arc2D) - 类 java.awt.geom.Arc2D 中的方法
将此弧设置为与指定弧相同。
setArcByCenter(double, double, double, double, double, int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、边界、角跨越和闭合类型设置为指定值。
setArcByTangent(Point2D, Point2D, Point2D, double) - 类 java.awt.geom.Arc2D 中的方法
将此弧的位置、边界和角跨越设置为指定值。
setArcType(int) - 类 java.awt.geom.Arc2D 中的方法
将此弧的闭合类型设置为指定值：OPEN、CHORD 或 PIE。
setAreaOfInterest(Shape) - 类 java.awt.image.renderable.RenderContext 中的方法
设置当前的感兴趣区域。
setArmed(boolean) - 接口 javax.swing.ButtonModel 中的方法
将此按钮标记为选中或未选中。
setArmed(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
将此按钮标记为选中或未选中。
setArmed(boolean) - 类 javax.swing.JMenuItem 中的方法
将菜单项标识为“调出”。
setArray(int, Array) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Array 对象。
setArray(int, Array) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的 Array 对象。
setArray(int, Array) - 接口 javax.sql.RowSet 中的方法
使用给定 Array 值设置此 RowSet 对象命令中的指定参数。
setAsciiStream(String, InputStream, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
setAsciiStream(String, InputStream, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
setAsciiStream(String, InputStream) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流。
setAsciiStream(long) - 接口 java.sql.Clob 中的方法
获取用于将 Ascii 字符写入此 Clob 对象表示的 Clob 值中的流，从位置 pos 处开始。
setAsciiStream(int, InputStream, int) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流，该输入流将具有给定字节数。
setAsciiStream(int, InputStream, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流，该输入流将具有指定字节数。
setAsciiStream(int, InputStream) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流。
setAsciiStream(int, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.io.InputStream 对象，该对象将具有指定的字节数。
setAsciiStream(int, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定输入流。
setAsciiStream(String, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
setAsciiStream(String, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的输入流。
setAsciiStream(long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
setAsciiStream(int, InputStream, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
setAsciiStream(String, InputStream, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
setAsciiStream(int, InputStream) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定输入流。
setAsciiStream(String, InputStream) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定输入流。
setAsksAllowsChildren(boolean) - 类 javax.swing.tree.DefaultTreeModel 中的方法
通过向 TreeNodes 询问 getAllowsChildren() 或 isLeaf()，设置是否测试无叶性。
setAsText(String) - 接口 java.beans.PropertyEditor 中的方法
通过解析给定 String 设置属性值。
setAsText(String) - 类 java.beans.PropertyEditorSupport 中的方法
通过解析给定字符串设置属性值。
setAsynchronousLoadPriority(int) - 类 javax.swing.text.AbstractDocument 中的方法
设置异步加载优先级。
setAttachmentMarshaller(AttachmentMarshaller) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setAttachmentMarshaller(AttachmentMarshaller) - 接口 javax.xml.bind.Marshaller 中的方法
与上下文关联，使 XML 文档内的二进制数据能够以优化的 XML 二进制附件的形式传送。
setAttachmentUnmarshaller(AttachmentUnmarshaller) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setAttachmentUnmarshaller(AttachmentUnmarshaller) - 接口 javax.xml.bind.Unmarshaller 中的方法
将解析 cid（内容 id URI）的上下文与作为附件传递的二进制数据关联。
setAttribute(String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setAttribute(Attribute) - 接口 javax.management.DynamicMBean 中的方法
设置 Dynamic MBean 的特定属性的值。
setAttribute(ObjectName, Attribute) - 接口 javax.management.MBeanServer 中的方法
setAttribute(ObjectName, Attribute) - 接口 javax.management.MBeanServerConnection 中的方法
设置指定 MBean 的特定属性值。
setAttribute(Attribute) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
设置指定的 ModelMBean 的指定属性值。
setAttribute(ObjectName, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
setAttribute(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
setAttribute(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
setAttribute(Attribute) - 类 javax.management.StandardMBean 中的方法
setAttribute(String, Object, int) - 接口 javax.script.ScriptContext 中的方法
设置给定范围中某一属性的值。
setAttribute(String, Object, int) - 类 javax.script.SimpleScriptContext 中的方法
设置给定范围中某一属性的值。
setAttribute(String, Object) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
允许用户在底层实现上设置特定属性。
setAttribute(String, Object) - 类 javax.xml.transform.TransformerFactory 中的方法
允许用户设置底层实现上的指定属性。
setAttribute(String, String) - 接口 org.w3c.dom.Element 中的方法
添加一个新属性。
setAttribute(int, String, String, String, String, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
在列表中设置属性。
setAttributeList(AttributeList) - 类 org.xml.sax.helpers.AttributeListImpl 中的方法
已过时。 设置属性列表，丢弃以前的内容。
setAttributeNode(Attr) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setAttributeNode(Attr) - 接口 org.w3c.dom.Element 中的方法
添加新的属性节点。
setAttributeNodeNS(Attr) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 setAttributeNode(newAttr)。
setAttributeNodeNS(Attr) - 接口 org.w3c.dom.Element 中的方法
添加新属性。
setAttributeNS(String, String, String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
等效于 setAttribute(qualifiedName, value)。
setAttributeNS(String, String, String) - 接口 org.w3c.dom.Element 中的方法
添加新属性。
setAttributes(int, int, AttributeSet) - 接口 javax.accessibility.AccessibleEditableText 中的方法
设置两个索引之间文本的属性。
setAttributes(AttributeList) - 接口 javax.management.DynamicMBean 中的方法
设置 Dynamic MBean 多个属性的值。
setAttributes(ObjectName, AttributeList) - 接口 javax.management.MBeanServer 中的方法
setAttributes(ObjectName, AttributeList) - 接口 javax.management.MBeanServerConnection 中的方法
设置指定 MBean 的多个属性值。
setAttributes(AttributeList) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
设置此 ModelMBean 的属性数组的值。
setAttributes(ObjectName, MarshalledObject, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
setAttributes(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
setAttributes(ObjectName, MarshalledObject, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
setAttributes(AttributeList) - 类 javax.management.StandardMBean 中的方法
setAttributes(Attributes) - 类 javax.naming.directory.SearchResult 中的方法
将此搜索结果的属性设置为 attrs。
setAttributes(int, int, AttributeSet) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
设置两个索引之间文本的属性。
setAttributes(int, int, AttributeSet) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
设置两个索引之间的文本的属性。
setAttributes(Attributes) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
复制整个属性对象。
setAttributes(Attributes) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
复制整个 Attributes 对象。
setAuthorityKeyIdentifier(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 authorityKeyIdentifier 扩展。
setAuthorized(boolean) - 类 javax.security.sasl.AuthorizeCallback 中的方法
设置是否允许授权。
setAuthorizedID(String) - 类 javax.security.sasl.AuthorizeCallback 中的方法
设置已授权实体的 id。
setAutoCommit(boolean) - 接口 java.sql.Connection 中的方法
将此连接的自动提交模式设置为给定状态。
setAutoCommit(boolean) - 接口 javax.sql.rowset.JdbcRowSet 中的方法
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
setAutoCreateColumnsFromModel(boolean) - 类 javax.swing.JTable 中的方法
设置此表的 autoCreateColumnsFromModel 标志。
setAutoCreateContainerGaps(boolean) - 类 javax.swing.GroupLayout 中的方法
设置是否应该自动创建容器与触到容器边框的组件之间的间隙。
setAutoCreateGaps(boolean) - 类 javax.swing.GroupLayout 中的方法
设置是否将自动创建组件之间的间隙。
setAutoCreateRowSorter(boolean) - 类 javax.swing.JTable 中的方法
指定其模型更改时是否应该为表创建一个 RowSorter。
setAutoDelay(int) - 类 java.awt.Robot 中的方法
设置此 Robot 在生成一个事件后睡眠的毫秒数。
setAutoFormSubmission(boolean) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
指定是否自动处理 html 表单提交，或只是激发 FormSubmitEvent。
setAutoIncrement(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定 boolean 值，以指示是否为该列自动编号，从而变为只读。
setAutoIncrement(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置是否为指定列自动编号。
setAutoResizeMode(int) - 类 javax.swing.JTable 中的方法
当调整表的大小时，设置表的自动调整模式。
setAutoscrolls(boolean) - 类 javax.swing.JComponent 中的方法
设置 autoscrolls 属性。
setAutoWaitForIdle(boolean) - 类 java.awt.Robot 中的方法
设置此 Robot 在生成一个事件后是否自动调用 waitForIdle。
setAxis(int) - 类 javax.swing.text.BoxView 中的方法
设置平铺轴属性。
setBackground(Color) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的背景色。
setBackground(Color) - 类 java.awt.Component 中的方法
设置组件的背景色。
setBackground(Color) - 类 java.awt.Graphics2D 中的方法
设置 Graphics2D 上下文的背景色。
setBackground(Color) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的背景颜色。
setBackground(Color) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置此对象的背景色。
setBackground(Color) - 类 java.awt.TextComponent 中的方法
设置此文本组件的背景色。
setBackground(Color) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置此对象的背景色。
setBackground(Color) - 类 javax.swing.JComponent 中的方法
设置此组件的背景色。
setBackground(Color) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setBackground(Color) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的背景色。
setBackground(Color) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
设置此对象的背景色。
setBackground(Color) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
重写 JComponent.setBackground 将未选定单元格的背景色分配为指定颜色。
setBackground(Color) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setBackground(Color) - 类 javax.swing.text.LabelView 中的方法
设置视图的背景色。
setBackground(MutableAttributeSet, Color) - 类 javax.swing.text.StyleConstants 中的静态方法
设置背景色。
setBackground(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
创建子类，以便将 ColorUIResource 映射为 null。
setBackgroundAt(int, Color) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的背景色设置为 background，它可以为 null，在这种情况下选项卡的背景色默认为 tabbedpane 的背景色。
setBackgroundNonSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于非选定节点的背景色。
setBackgroundSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置在选定节点的情况下背景所使用的颜色。
setBackingStoreEnabled(boolean) - 类 javax.swing.JViewport 中的方法
已过时。 从 Java 2 平台 1.3 版开始，由 setScrollMode() 取代。
setBase(URL) - 类 javax.swing.text.html.HTMLDocument 中的方法
设置解析相对 URL 所根据的位置。
setBase(URL) - 类 javax.swing.text.html.StyleSheet 中的方法
设置 base。
setBase64Content(InputStream, String) - 类 javax.xml.soap.AttachmentPart 中的方法
根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。
setBaseFontSize(int) - 类 javax.swing.text.html.StyleSheet 中的方法
设置基本字体大小，其有效值范围为 1 到 7。
setBaseFontSize(String) - 类 javax.swing.text.html.StyleSheet 中的方法
根据传入的 String 设置基本字体大小。
setBaseURI(String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
setBaseURI(String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置基本 URI。
setBaseURI(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
基 URI（请参阅 [IETF RFC 2396])中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。
setBasicConstraints(int) - 类 java.security.cert.X509CertSelector 中的方法
设置 basicConstraints 限制。
setBasicSplitPaneUI(BasicSplitPaneUI) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
设置要使用接收者的 SplitPaneUI。
setBeanContext(BeanContext) - 接口 java.beans.beancontext.BeanContextChild 中的方法
实现此接口的对象应使用以下参数激活一个 java.beans.PropertyChangeEvent：propertyName "beanContext"、oldValue（以前的嵌套 BeanContext 实例，或 null）、newValue（当前的嵌套 BeanContext 实例，或 null）。
setBeanContext(BeanContext) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
设置此 BeanContextChildSupport 的 BeanContext。
setBeanInfoSearchPath(String[]) - 类 java.beans.Introspector 中的静态方法
更改将用来查找 BeanInfo 类的包名称的列表。
setBeginIndex(int) - 类 java.text.FieldPosition 中的方法
设置起始索引。
setBidiLevel(MutableAttributeSet, int) - 类 javax.swing.text.StyleConstants 中的静态方法
设置 BidiLevel。
setBigDecimal(String, BigDecimal) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.math.BigDecimal 值。
setBigDecimal(int, BigDecimal) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.math.BigDecimal 值。
setBigDecimal(int, BigDecimal) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.lang.BigDecimal 值。
setBigDecimal(String, BigDecimal) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.math.BigDecimal 值。
setBigDecimal(int, BigDecimal) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.math.BigDeciaml 值。
setBigDecimal(String, BigDecimal) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.math.BigDecimal 值。
setBinaryStream(long) - 接口 java.sql.Blob 中的方法
获取用于写入此 Blob 对象表示的 BLOB 值的流。
setBinaryStream(String, InputStream, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
setBinaryStream(String, InputStream, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
setBinaryStream(String, InputStream) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定输入流。
setBinaryStream(int, InputStream, int) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流，该输入流将具有给定字节数。
setBinaryStream(int, InputStream, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流，该输入流将具有指定字节数。
setBinaryStream(int, InputStream) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定输入流。
setBinaryStream() - 接口 java.sql.SQLXML 中的方法
获取可用于写入此 SQLXML 实例表示的 XML 值的流。
setBinaryStream(int, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。
setBinaryStream(int, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定输入流。
setBinaryStream(String, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。
setBinaryStream(String, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定输入流。
setBinaryStream(long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
获取用于写入此 Blob 对象所表示的 BLOB 值的流。
setBinaryStream(int, InputStream, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
setBinaryStream(String, InputStream, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定输入流，该输入流将拥有给定字节数。
setBinaryStream(int, InputStream) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定输入流。
setBinaryStream(String, InputStream) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定输入流。
setBindings(Bindings, int) - 类 javax.script.AbstractScriptEngine 中的方法
使用 context 字段中的相应范围值设置 Bindings。
setBindings(Bindings, int) - 接口 javax.script.ScriptContext 中的方法
将 Bindings 实例与此 ScriptContext 中的特定范围关联。
setBindings(Bindings, int) - 接口 javax.script.ScriptEngine 中的方法
设置将由脚本使用的指定值的范围。
setBindings(Bindings) - 类 javax.script.ScriptEngineManager 中的方法
setBindings 存储 globalScope 字段中的指定 Bindings。
setBindings(Bindings, int) - 类 javax.script.SimpleScriptContext 中的方法
针对给定范围设置属性的 Bindings。
setBit(int) - 类 java.math.BigInteger 中的方法
返回其值与设置了指定位的此 BigInteger 等效的 BigInteger。
setBitOffset(int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
将位偏移量设置为 0 到 7 之间（包含两者）的整数。
setBitOffset(int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
setBlinkRate(int) - 接口 javax.swing.text.Caret 中的方法
设置插入符的闪烁率。
setBlinkRate(int) - 类 javax.swing.text.DefaultCaret 中的方法
设置插入符闪烁率。
setBlob(String, InputStream, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, Blob) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定的 java.sql.Blob 对象。
setBlob(String, InputStream) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, Blob) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Blob 对象。
setBlob(int, InputStream, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, InputStream) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, Blob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 Blob 对象。
setBlob(int, InputStream, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, InputStream, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, Blob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Blob 对象。
setBlob(String, InputStream) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, Blob) - 接口 javax.sql.RowSet 中的方法
使用给定 Blob 值设置此 RowSet 对象命令中的指定参数。
setBlob(int, InputStream, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(int, InputStream) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, InputStream, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlob(String, Blob) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.Blob 对象。
setBlob(String, InputStream) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 InputStream 对象。
setBlockIncrement(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的块值增量。
setBlockIncrement(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的块增量。
setBlockIncrement(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
setBlockIncrement(int) - 类 javax.swing.JScrollBar 中的方法
设置 blockIncrement 属性。
setBlockIncrement(int) - 类 javax.swing.JScrollPane.ScrollBar 中的方法
通知超类来设定该值，并将 blockIncrementSet 实例变量重置为 true。
setBold(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置粗体属性。
setBoolean(Object, int, boolean) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 boolean 值。
setBoolean(Object, boolean) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 boolean 值。
setBoolean(String, boolean) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java boolean 值。
setBoolean(int, boolean) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java boolean 值。
setBoolean(int, boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 boolean 值。
setBoolean(String, boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java boolean 值。
setBoolean(int, boolean) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java boolean 值。
setBoolean(String, boolean) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java boolean 值。
setBorder(Border) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的边框。
setBorder(Border) - 类 javax.swing.JComponent 中的方法
设置此组件的边框。
setBorder(Border) - 类 javax.swing.JViewport 中的方法
视口通过常规父/子剪贴（一般该视图向滚动的相反方向移动）“滚动”其子视口（称为“视图”）。
setBorder(Border) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
设置此组件的边框。
setBorder(Border) - 类 javax.swing.tree.DefaultTreeCellEditor.DefaultTextField 中的方法
设置此组件的边框。
setBorderColor(Color) - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
setBorderPainted(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 borderPainted 属性。
setBorderPainted(boolean) - 类 javax.swing.JMenuBar 中的方法
设置是否应该绘制边框。
setBorderPainted(boolean) - 类 javax.swing.JPopupMenu 中的方法
设置是否应该绘制边框。
setBorderPainted(boolean) - 类 javax.swing.JProgressBar 中的方法
设置 borderPainted 属性，如果进度条应该绘制其边框，则此属性为 true。
setBorderPainted(boolean) - 类 javax.swing.JToolBar 中的方法
设置 borderPainted 属性，如果需要绘制边框，则此属性为 true。
setBorderPaintedFlat(boolean) - 类 javax.swing.JCheckBox 中的方法
设置 borderPaintedFlat 属性，该属性为外观提供了关于复选框边框外观的提示。
setBorderSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
设置用于边框的颜色。
setBorderSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于边框的颜色。
setBorderToNonRollover(Component) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
将组件的边框设置为具有由 createNonRolloverBorder 创建的翻转边框。
setBorderToNonRollover(Component) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
setBorderToNormal(Component) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
将组件的边框设置为具有普通边框。
setBorderToRollover(Component) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
将组件的边框设置为具有由 createRolloverBorder 创建的翻转边框。
setBottomComponent(Component) - 类 javax.swing.JSplitPane 中的方法
将组件设置到分隔条的下面或者右边。
setBottomInset(float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图四周底部的空白部分。
setBound(boolean) - 类 java.beans.PropertyDescriptor 中的方法
更新 "bound" 属性将导致更改该属性时激发 "PropertyChange" 事件。
setBounds(Rectangle) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的边界，用 Rectangle 对象的形式表示它。
setBounds(int, int, int, int) - 类 java.awt.Component 中的方法
移动组件并调整其大小。
setBounds(Rectangle) - 类 java.awt.Component 中的方法
移动组件并调整其大小，使其符合新的有界矩形 r。
setBounds(Rectangle) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
以 Rectangle 对象的形式设置此对象的界限。
setBounds(Rectangle) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
以 Rectangle 对象的形式设置此对象的边界。
setBounds(Rectangle) - 类 java.awt.Rectangle 中的方法
设置此 Rectangle 的边界 Rectangle，以匹配指定的 Rectangle。
setBounds(int, int, int, int) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 的边界 Rectangle 设置为指定的 x、y、width 和 height。
setBounds(int, int, int, int) - 类 java.awt.Window 中的方法
移动组件并调整其大小。
setBounds(Rectangle) - 类 java.awt.Window 中的方法
移动组件并调整其大小，使其符合新的有界矩形 r。
setBounds(Rectangle) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置 Rectangle 对象形式的此对象的边界。
setBounds(Rectangle) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setBounds(Rectangle) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
setBounds(Rectangle) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setBounds(Rectangle) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setBoundsForFrame(JComponent, int, int, int, int) - 类 javax.swing.DefaultDesktopManager 中的方法
此方法移动 JComponent 并重新绘制已毁坏的区域。
setBoundsForFrame(JComponent, int, int, int, int) - 接口 javax.swing.DesktopManager 中的方法
这是一个基本重塑方法。
setBroadcast(boolean) - 类 java.net.DatagramSocket 中的方法
启用/禁用 SO_BROADCAST。
setBuilder(DocumentBuilder) - 类 javax.xml.bind.annotation.W3CDomHandler 中的方法
setButtonIcons() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
setByte(Object, int, byte) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 byte 值。
setByte(Object, byte) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 byte 值。
setByte(String, byte) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java byte 值。
setByte(int, byte) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java byte 值。
setByte(int, byte) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 byte 值。
setByte(String, byte) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java byte 值。
setByte(int, byte) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值。
setByte(String, byte) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java byte 值。
setByteOrder(ByteOrder) - 接口 javax.imageio.stream.ImageInputStream 中的方法
设置希望以后从此流中读取数据值时使用的字节顺序。
setByteOrder(ByteOrder) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
setBytes(long, byte[]) - 接口 java.sql.Blob 中的方法
从位置 pos 处开始，将给定 byte 数组写入此 Blob 对象表示的 BLOB 值，并返回写入的字节数。
setBytes(long, byte[], int, int) - 接口 java.sql.Blob 中的方法
将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
setBytes(String, byte[]) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java byte 数组。
setBytes(int, byte[]) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java byte 数组。
setBytes(int, byte[]) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 byte 数组。
setBytes(String, byte[]) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java byte 数组。
setBytes(long, byte[]) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
将给定字节数组写入此 Blob 对象表示的 BLOB 值（从位置 pos 处开始），并返回写入的字节数。
setBytes(long, byte[], int, int) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
setBytes(int, byte[]) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值数组。
setBytes(String, byte[]) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java byte 数组。
setByteStream(InputStream) - 接口 org.w3c.dom.ls.LSInput 中的方法
依赖于语言和绑定类型的属性，表示字节流。
setByteStream(OutputStream) - 接口 org.w3c.dom.ls.LSOutput 中的方法
具有语言和绑定依赖性类型的属性，表示字节的可写流。
setByteStream(InputStream) - 类 org.xml.sax.InputSource 中的方法
设置此输入源的字节流。
setCacheDirectory(File) - 类 javax.imageio.ImageIO 中的静态方法
设置将在其中创建缓存文件的目录。
setCalendar(Calendar) - 类 java.text.DateFormat 中的方法
设置此日期格式所使用的日历。
setCalendarField(int) - 类 javax.swing.SpinnerDateModel 中的方法
更改由 nextValue 和 previousValue 方法计算的日期值更改的大小。
setCallbackHandler(CallbackHandler) - 类 java.security.AuthProvider 中的方法
设置 CallbackHandler。
setCanWrapLines(boolean) - 类 javax.swing.text.AbstractWriter 中的方法
设置是否可以换行。
setCaret(Caret) - 类 javax.swing.text.JTextComponent 中的方法
设置要使用的插入符。
setCaretColor(Color) - 类 javax.swing.text.JTextComponent 中的方法
设置用于呈现插入符的当前颜色。
setCaretPosition(int) - 类 java.awt.TextComponent 中的方法
设置文本插入符的位置。
setCaretPosition(int) - 类 javax.swing.text.JTextComponent 中的方法
设置 TextComponent 的文本插入符的位置。
setCaseSensitive(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定的 boolean 值，以指示该列的名称是否区分大小写。
setCaseSensitive(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置指定列是否区分大小写。
setCatalog(String) - 接口 java.sql.Connection 中的方法
设置给定目录名称，以便选择要在其中进行工作的此 Connection 对象数据库的子空间。
setCatalogName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将派生指定列的表名称设置为 catalogName。
setCatalogName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的表的类别名称（如果有）设置为给定的 String。
setCellEditor(TableCellEditor) - 类 javax.swing.JTable 中的方法
设置活动单元格编辑器。
setCellEditor(TreeCellEditor) - 类 javax.swing.JTree 中的方法
设置单元格编辑器。
setCellEditor(TreeCellEditor) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
设置单元格编辑器。
setCellEditor(TableCellEditor) - 类 javax.swing.table.TableColumn 中的方法
设置编辑此列中单元格时所用的编辑器。
setCellLength(int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
setCellRenderer(ListCellRenderer) - 类 javax.swing.JList 中的方法
设置用于绘制列表中每个单元的委托。
setCellRenderer(TreeCellRenderer) - 类 javax.swing.JTree 中的方法
设置将用于绘制每个单元格的 TreeCellRenderer。
setCellRenderer(TreeCellRenderer) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
将 TreeCellRenderer 设置为 tcr。
setCellRenderer(TableCellRenderer) - 类 javax.swing.table.TableColumn 中的方法
设置 JTable 用于绘制此列各值的 TableCellRenderer。
setCellSelectionEnabled(boolean) - 类 javax.swing.JTable 中的方法
设置此表是否允许同时存在行选择和列选择。
setCellSpacing(int) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
setCentersChildren(boolean) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
setCertificate(X509Certificate) - 类 java.security.cert.X509CertSelector 中的方法
设置 certificateEquals 标准。
setCertificateChecking(X509Certificate) - 类 java.security.cert.X509CRLSelector 中的方法
设置要检查的证书。
setCertificateEntry(String, Certificate) - 类 java.security.KeyStore 中的方法
将给定可信证书分配给给定别名。
setCertificateValid(Date) - 类 java.security.cert.X509CertSelector 中的方法
设置 certificateValid 标准。
setCertifiedText(boolean) - 接口 org.w3c.dom.ls.LSInput 中的方法
如果设置为 true，则假定解析 [XML 1.1] 时对输入进行验证（请参阅 [XML 1.1] 中的 2.13 节）。
setCertPathCheckers(List<PKIXCertPathChecker>) - 类 java.security.cert.PKIXParameters 中的方法
设置其他证书路径检查器的 List。
setCertStores(List<CertStore>) - 类 java.security.cert.PKIXParameters 中的方法
设置在查找证书和 CRL 时所使用的 CertStore 列表。
setChanged() - 类 java.util.Observable 中的方法
标记此 Observable 对象为已改变的对象；现在 hasChanged 方法将返回 true。
setChannelBinding(ChannelBinding) - 接口 org.ietf.jgss.GSSContext 中的方法
设置在上下文创建期间使用的通道绑定。
setChannelPressure(int) - 接口 javax.sound.midi.MidiChannel 中的方法
对键盘力度的更改作出反应。
setChar(Object, int, char) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 char 值。
setChar(Object, char) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 char 值。
setCharacterAttributes(AttributeSet, boolean) - 类 javax.swing.JTextPane 中的方法
将给定属性应用于字符内容。
setCharacterAttributes(int, int, AttributeSet, boolean) - 类 javax.swing.text.DefaultStyledDocument 中的方法
为文档某些部分设置属性。
setCharacterAttributes(int, int, AttributeSet, boolean) - 接口 javax.swing.text.StyledDocument 中的方法
更改内容元素属性，该属性是用来给定文档中现有内容范围的。
setCharacterAttributes(JEditorPane, AttributeSet, boolean) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
对字符内容应用给定的属性。
setCharacterStream(String, Reader, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。
setCharacterStream(String, Reader, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
setCharacterStream(String, Reader) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Reader 对象。
setCharacterStream(long) - 接口 java.sql.Clob 中的方法
获取用于将 Unicode 字符流写入此 Clob 对象表示的 CLOB 值中（位置 pos 处）的流。
setCharacterStream(int, Reader, int) - 接口 java.sql.PreparedStatement 中的方法
将给定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
setCharacterStream(int, Reader, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
setCharacterStream(int, Reader) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Reader 对象。
setCharacterStream() - 接口 java.sql.SQLXML 中的方法
获取用于写入此 SQLXML 实例表示的 XML 值的流。
setCharacterStream(int, Reader, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.io.Reader 对象，该对象具有指定的字符数。
setCharacterStream(int, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Reader 对象。
setCharacterStream(String, Reader, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。
setCharacterStream(String, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定 Reader 对象。
setCharacterStream(long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。
setCharacterStream(int, Reader, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.Reader 值。
setCharacterStream(String, Reader, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。
setCharacterStream(int, Reader) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定 Reader 对象。
setCharacterStream(String, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定 Reader 对象。
setCharacterStream(Reader) - 接口 org.w3c.dom.ls.LSInput 中的方法
依赖于语言和绑定类型的属性，表示 16 位单元的流。
setCharacterStream(Writer) - 接口 org.w3c.dom.ls.LSOutput 中的方法
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。
setCharacterStream(Reader) - 类 org.xml.sax.InputSource 中的方法
设置此输入源的字符流。
setCharacterSubsets(Character.Subset[]) - 类 java.awt.im.InputContext 中的方法
设置此输入上下文的输入方法应允许输入的 Unicode 字符集的子集。
setCharacterSubsets(Character.Subset[]) - 接口 java.awt.im.spi.InputMethod 中的方法
设置允许此输入方法进行输入的 Unicode 字符集的子集。
setCharAt(int, char) - 类 java.lang.StringBuffer 中的方法
setCheckboxGroup(CheckboxGroup) - 类 java.awt.Checkbox 中的方法
将此复选框的组设置为指定复选框组。
setChoices(double[], String[]) - 类 java.text.ChoiceFormat 中的方法
设置要在格式化中使用的 choice。
setChooserPanels(AbstractColorChooserPanel[]) - 类 javax.swing.JColorChooser 中的方法
指定用于选取颜色值的 Color Panel。
setChunkedStreamingMode(int) - 类 java.net.HttpURLConnection 中的方法
此方法用于在预先不知道内容长度时启用没有进行内部缓冲的 HTTP 请求正文的流。
setCipherSuites(String[]) - 类 javax.net.ssl.SSLParameters 中的方法
设置密码套件数组。
setClassAssertionStatus(String, boolean) - 类 java.lang.ClassLoader 中的方法
设置在此类加载器及其包含的嵌套类中指定的最高层类所需的断言状态。
setClassName(String) - 类 javax.naming.NameClassPair 中的方法
设置此绑定的类名称。
setClickCountToStart(int) - 类 javax.swing.DefaultCellEditor 中的方法
指定开始编辑所需的单击次数。
setClientInfo(String, String) - 接口 java.sql.Connection 中的方法
将 name 指定的客户端信息属性的值设置为 value 指定的值。
setClientInfo(Properties) - 接口 java.sql.Connection 中的方法
设置连接的客户端信息属性的值。
setClip(int, int, int, int) - 类 java.awt.Graphics 中的方法
将当前剪贴区设置为由给定坐标指定的矩形。
setClip(Shape) - 类 java.awt.Graphics 中的方法
将当前剪贴区域设置为任意的剪贴形状。
setClip(int, int, int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.setClip。
setClip(Shape) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.setClip。
setClob(String, Reader, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Clob) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定的 java.sql.Clob 对象。
setClob(String, Reader) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Clob) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Clob 对象。
setClob(int, Reader, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Reader) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Clob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 Clob 对象。
setClob(int, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Clob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Clob 对象。
setClob(String, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Clob) - 接口 javax.sql.RowSet 中的方法
使用给定 Clob 值设置此 RowSet 对象命令中的指定参数。
setClob(int, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(int, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setClob(String, Clob) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.Clob 对象。
setClob(String, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setClosable(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置是否可以通过某个用户操作关闭此 JInternalFrame。
setClosed(boolean) - 类 javax.swing.JInternalFrame 中的方法
如果参数为 true，则关闭此内部窗体。
setClosedIcon(Icon) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于表示没有扩展的非叶节点的图标。
setCoalesce(boolean) - 类 javax.swing.Timer 中的方法
设置 Timer 是否组合多个挂起的 ActionEvent 触发。
setCoalescing(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将把 CDATA 节点转换为 Text 节点，并将其附加到相邻（如果有）的 Text 节点。
setCollapsedIcon(Icon) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setCollectionUsageThreshold(long) - 接口 java.lang.management.MemoryPoolMXBean 中的方法
将此内存池的回收使用量阈值设置为给定的 threshold 值。
setColor(Color) - 类 java.awt.Graphics 中的方法
将此图形上下文的当前颜色设置为指定颜色。
setColor(PageAttributes.ColorType) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面以彩色呈现，还是以单色呈现。
setColor(Color) - 类 javax.swing.DebugGraphics 中的方法
设置用于绘制和填充线条和图形的颜色。
setColor(Color) - 类 javax.swing.JColorChooser 中的方法
将颜色选取器的当前颜色设置为指定颜色。
setColor(int, int, int) - 类 javax.swing.JColorChooser 中的方法
将颜色选取器的当前颜色设置为指定的 RGB 颜色。
setColor(int) - 类 javax.swing.JColorChooser 中的方法
将颜色选取器的当前颜色设置为指定颜色。
setColorModel(ColorModel) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口的 setColorModel 方法提供的信息。
setColorModel(ColorModel) - 接口 java.awt.image.ImageConsumer 中的方法
设置用于大多数像素的 ColorModel 对象，这些像素使用 setPixels 方法调用进行报告。
setColorModel(ColorModel) - 类 java.awt.image.ImageFilter 中的方法
过滤 ImageConsumer 接口的 setColorModel 方法中所提供的信息。
setColorModel(ColorModel) - 类 java.awt.image.PixelGrabber 中的方法
setColorModel 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setColorModel(ColorModel) - 类 java.awt.image.RGBImageFilter 中的方法
如果 ColorModel 是 IndexColorModel 且子类将 canFilterIndexColorModel 标志设置为 true，则将此处及 setPixels 方法中任何出现原始 ColorModel 对象的地方替换为过滤后的颜色模型。
setColumnCount(int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
在为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中，将列数设置为给定数。
setColumnCount(int) - 接口 javax.sql.RowSetMetaData 中的方法
将 RowSet 对象中的列数设置为给定数。
setColumnCount(int) - 类 javax.swing.table.DefaultTableModel 中的方法
设置模型中的列数。
setColumnDisplaySize(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列中的正常最大 char 数设置为给定数。
setColumnDisplaySize(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的正常最大宽度（以 char 表示）设置为给定的 int。
setColumnHeader(JViewport) - 类 javax.swing.JScrollPane 中的方法
移除旧的 columnHeader，如果有的话；如果新的 columnHeader 不为 null，将其 viewPosition 的 x 坐标与视口（如果有）同步然后将其添加到滚动窗格。
setColumnHeaderView(Component) - 类 javax.swing.JScrollPane 中的方法
创建一个列标题视口（如果有必要），设置其视图然后将此列标题视口添加到滚动窗格。
setColumnIdentifiers(Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
替换模型中的列标识符。
setColumnIdentifiers(Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
替换模型中的列标识符。
setColumnLabel(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将建议用于打印输出和显示的列标签（如果有）设置为给定的 label。
setColumnLabel(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将建议用于打印输出和显示的列标题（如果有）设置为给定的 String。
setColumnMargin(int) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
将列空白设置为 newMargin。
setColumnMargin(int) - 接口 javax.swing.table.TableColumnModel 中的方法
将 TableColumn 的列空白设置为 newMargin。
setColumnModel(TableColumnModel) - 类 javax.swing.JTable 中的方法
将此表的列模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
setColumnModel(TableColumnModel) - 类 javax.swing.table.JTableHeader 中的方法
将此表的列模型设置为 newModel，并向侦听器注册来自新列模型的通知。
setColumnName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列的列名称设置为给定的名称。
setColumnName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的名称设置为给定的 String。
setColumnNumber(int) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 columnNumber 字段。
setColumnNumber(int) - 类 org.xml.sax.helpers.LocatorImpl 中的方法
设置此定位器的列数（从 1 开始）。
setColumns(int) - 类 java.awt.GridLayout 中的方法
将此布局中的列数设置为指定值。
setColumns(int) - 类 java.awt.TextArea 中的方法
设置此文本区的列数。
setColumns(int) - 类 java.awt.TextField 中的方法
设置此文本字段中的列数。
setColumns(int) - 类 javax.swing.JTextArea 中的方法
设置此 TextArea 中的列数。
setColumns(int) - 类 javax.swing.JTextField 中的方法
设置此 TextField 中的列数，然后验证布局。
setColumnSelectionAllowed(boolean) - 类 javax.swing.JTable 中的方法
设置是否可以选择此模型中的列。
setColumnSelectionAllowed(boolean) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
设置是否允许列选择。
setColumnSelectionAllowed(boolean) - 接口 javax.swing.table.TableColumnModel 中的方法
设置是否可以选择此模型中的列。
setColumnSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
选择从 index0 到 index1 之间（包含两端）的列。
setColumnType(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将存储在指定列中的值的 SQL 类型代码设置为 java.sql.Types 类中的给定类型代码。
setColumnType(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的 SQL 类型设置为给定的类型。
setColumnTypeName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将供存储在指定列中的值的数据源使用的类型名称设置为给定类型名称。
setColumnTypeName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的特定于数据源的类型名称（如果有）设置为给定的 String。
setComboBox(JComboBox) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
setComboIcon(Icon) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
setCommand(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 command 属性设置为给定的 String 对象，并清除为前一个命令设置的参数（如果有）。
setCommand(String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的命令属性设置为给定的 SQL 查询。
setCommandContext(String, DataHandler) - 接口 javax.activation.CommandObject 中的方法
用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。
setCommandMap(CommandMap) - 类 javax.activation.DataHandler 中的方法
设置此 DataHandler 使用的 CommandMap。
setComment(String) - 类 java.net.HttpCookie 中的方法
指定一个描述 cookie 用途的注释。
setComment(String) - 类 java.util.zip.ZipEntry 中的方法
为条目设置可选的注释字符串。
setComment(String) - 类 java.util.zip.ZipOutputStream 中的方法
设置 ZIP 文件注释。
setCommentURL(String) - 类 java.net.HttpCookie 中的方法
指定一个描述 cookie 用途的注释 URL。
setCommitsOnValidEdit(boolean) - 类 javax.swing.text.DefaultFormatter 中的方法
设置何时将编辑内容发布回 JFormattedTextField。
setComparator(int, Comparator<?>) - 类 javax.swing.DefaultRowSorter 中的方法
设置对指定列进行排序时要使用的 Comparator。
setComparator(Comparator<? super Component>) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
设置将用于对焦点遍历循环中的 Components 排序的 Comparator。
setComponent(Component) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
设置与该 DragGestureRecognizer 关联的 Component 使用此方法时还会调用 registerListeners() 和 unregisterListeners()。
setComponent(Component) - 类 java.awt.dnd.DropTarget 中的方法
注意：要求此接口允许 DropTarget 以下面两种方式之一与 Component 安全关联：component.setDropTarget(droptarget) 或 droptarget.setComponent(component)。
setComponent(JComponent) - 类 javax.swing.JToolTip 中的方法
指定工具提示所描述的组件。
setComponent(MutableAttributeSet, Component) - 类 javax.swing.text.StyleConstants 中的静态方法
设置组件属性。
setComponentAt(int, Component) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的组件设置为 component。
setComponentOrientation(ComponentOrientation) - 类 java.awt.Component 中的方法
设置语言敏感的方向，用于排序此组件内的元素或文本。
setComponentOrientation(ComponentOrientation) - 类 javax.swing.JMenu 中的方法
setComponentOrientation(ComponentOrientation) - 类 javax.swing.JScrollPane 中的方法
设置由 ComponentOrientation 参数确定的垂直和水平滚动条方向。
setComponentOrientation(ComponentOrientation) - 类 javax.swing.text.JTextComponent 中的方法
setComponentPopupMenu(JPopupMenu) - 类 javax.swing.JComponent 中的方法
设置此 JComponent 的 JPopupMenu。
setComponentToSize(Component, int, int, Insets, Dimension) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。
setComponentZOrder(Component, int) - 类 java.awt.Container 中的方法
将指定组件移动到容器中指定的 z 顺序索引。
setComponentZOrder(Component, int) - 类 javax.swing.JDesktopPane 中的方法
将指定组件移动到容器中指定的 z 顺序索引。
setComposite(Composite) - 类 java.awt.Graphics2D 中的方法
为 Graphics2D 上下文设置 Composite。
setCompositionEnabled(boolean) - 类 java.awt.im.InputContext 中的方法
根据参数 enable 的值启用或禁用当前输入方法进行撰写。
setCompositionEnabled(boolean) - 接口 java.awt.im.spi.InputMethod 中的方法
启用或禁用输入方法的撰写功能，具体取决于参数 enable 的值。
setCompressedSize(long) - 类 java.util.zip.ZipEntry 中的方法
设置压缩条目数据的大小。
setCompressionMode(int) - 类 javax.imageio.ImageWriteParam 中的方法
指定是否执行压缩，如果执行压缩，将如何确定 compression 参数。
setCompressionQuality(float) - 类 javax.imageio.ImageWriteParam 中的方法
将压缩质量设置为 0 和 1 之间的某个值。
setCompressionType(String) - 类 javax.imageio.ImageWriteParam 中的方法
将压缩类型设置为 getCompressionTypes 指示的值之一。
setConcurrency(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的并发性设置为指定的并发性。
setConcurrency(int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的并发性设置为给定的并发级别。
setConfiguration(Configuration) - 类 javax.security.auth.login.Configuration 中的静态方法
设置登录 Configuration。
setConnectTimeout(int) - 类 java.net.URLConnection 中的方法
设置一个指定的超时值（以毫秒为单位），该值将在打开到此 URLConnection 引用的资源的通信链接时使用。
setConstrained(boolean) - 类 java.beans.PropertyDescriptor 中的方法
试图更新 "Constrained" 属性将导致更改该属性时激发 "VetoableChange" 事件。
setConstraint(String, Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置控制指定边的 spring。
setConstraints(Component, GridBagConstraints) - 类 java.awt.GridBagLayout 中的方法
设置此布局中指定组件的约束条件。
setContent(Object, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将此附件部分的内容设置为给定 Object 的内容，并将 Content-Type 头的值设置为给定类型。
setContent(Source) - 类 javax.xml.soap.SOAPPart 中的方法
使用取自给定 Source 对象的数据设置 SOAPEnvelope 对象的内容。
setContentAreaFilled(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 contentAreaFilled 属性。
setContentDescription(String) - 类 javax.xml.soap.SOAPMessage 中的方法
使用给定描述设置此 SOAPMessage 对象内容的描述。
setContentHandler(ContentHandler) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置 ContentHandler，它接收扩充的验证结果。
setContentHandler(ContentHandler) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置内容处理程序。
setContentHandler(ContentHandler) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置内容事件处理程序。
setContentHandler(ContentHandler) - 接口 org.xml.sax.XMLReader 中的方法
允许应用程序注册内容事件处理程序。
setContentHandlerFactory(ContentHandlerFactory) - 类 java.net.URLConnection 中的静态方法
设置应用程序的 ContentHandlerFactory。
setContentId(String) - 类 javax.xml.soap.AttachmentPart 中的方法
使用给定值设置名为 "Content-ID" 的 MIME 头。
setContentId(String) - 类 javax.xml.soap.SOAPPart 中的方法
将名为 "Content-Id" 的 MIME 头的值设置为给定 String。
setContentLocation(String) - 类 javax.xml.soap.AttachmentPart 中的方法
使用给定值设置名为 "Content-Location" 的 MIME 头。
setContentLocation(String) - 类 javax.xml.soap.SOAPPart 中的方法
将 MIME 头 "Content-Location" 的值设置为给定 String。
setContentPane(Container) - 类 javax.swing.JApplet 中的方法
设置 contentPane 属性。
setContentPane(Container) - 类 javax.swing.JDialog 中的方法
设置 contentPane 属性。
setContentPane(Container) - 类 javax.swing.JFrame 中的方法
设置 contentPane 属性。
setContentPane(Container) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 contentPane 属性。
setContentPane(Container) - 类 javax.swing.JRootPane 中的方法
设置内容窗格，它是保存以根窗格为父级的组件的容器。
setContentPane(Container) - 类 javax.swing.JWindow 中的方法
设置此窗口的 contentPane 属性。
setContentPane(Container) - 接口 javax.swing.RootPaneContainer 中的方法
"contentPane" 是应用程序特定组件的主要容器。
setContents(Transferable, ClipboardOwner) - 类 java.awt.datatransfer.Clipboard 中的方法
将剪贴板的当前内容设置到指定的 transferable 对象，并将指定的剪贴板所有者作为新内容的所有者注册。
setContentType(String) - 类 javax.swing.JEditorPane 中的方法
设置此编辑器所处理的内容类型。
setContentType(String) - 类 javax.xml.soap.AttachmentPart 中的方法
使用给定值设置名为 "Content-Type" 的 MIME 头。
setContext(ScriptContext) - 类 javax.script.AbstractScriptEngine 中的方法
将受保护 context 字段的值设置为指定的 ScriptContext。
setContext(ScriptContext) - 接口 javax.script.ScriptEngine 中的方法
设置 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。
setContextClassLoader(ClassLoader) - 类 java.lang.Thread 中的方法
设置该线程的上下文 ClassLoader。
setContinueExistingPeriodicTasksAfterShutdownPolicy(boolean) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
设置有关在此执行程序已 shutdown 的情况下是否继续执行现有定期任务的策略。
setContinuousLayout(boolean) - 类 javax.swing.JSplitPane 中的方法
设置 continuousLayout 属性的值，在用户干预期要使子组件连续地重新显示和布局子组件，此值必须为 true。
setContinuousLayout(boolean) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
打开/关闭连续布局。
setControlButtonsAreShown(boolean) - 类 javax.swing.JFileChooser 中的方法
设置属性，指示在文件选择器中是否显示 approve 和 cancel 按钮。
setController(IIOParamController) - 类 javax.imageio.IIOParam 中的方法
设置在调用 activateController 方法时用来为 IIOParam 对象提供设置值的 IIOParamController，重写所有默认控制器。
setController(IIOMetadataController) - 类 javax.imageio.metadata.IIOMetadata 中的方法
设置在调用 activateController 方法时用来为此 IIOParam 对象提供设置值的 IIOMetadataController，重写任何默认控制器。
setCookiePolicy(CookiePolicy) - 类 java.net.CookieManager 中的方法
设置此 cookie 管理器的 cookie 策略。
setCopies(int) - 类 java.awt.JobAttributes 中的方法
指定应用程序应该使用这些属性呈现作业的份数。
setCopies(int) - 类 java.awt.print.PrinterJob 中的方法
设置要打印的副本数。
setCopiesToDefault() - 类 java.awt.JobAttributes 中的方法
将应用程序应该使用这些属性呈现作业的份数设置为默认值。
setCorePoolSize(int) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置核心线程数。
setCorner(String, Component) - 类 javax.swing.JScrollPane 中的方法
添加一个将显示在一个滚动窗格角中的子级，如果有空间的话。
setCountLimit(long) - 类 javax.naming.directory.SearchControls 中的方法
设置要作为搜索结果返回的最大项数。
setCrc(long) - 类 java.util.zip.ZipEntry 中的方法
设置未压缩条目数据的 CRC-32 校验和。
setCurrency(Currency) - 类 java.text.DecimalFormat 中的方法
设置格式化货币值时，此数字格式使用的货币。
setCurrency(Currency) - 类 java.text.DecimalFormatSymbols 中的方法
设置这些 DecimalFormatSymbols 的货币。
setCurrency(Currency) - 类 java.text.NumberFormat 中的方法
设置格式化货币值时此数值格式使用的货币。
setCurrency(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定的 boolean，以指示存储在该列中的值是否为缓存值。
setCurrency(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置指定的列是否是现金值。
setCurrencySymbol(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。
setCurrent(Checkbox) - 类 java.awt.CheckboxGroup 中的方法
已过时。 从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。
setCurrentAccessibleValue(Number) - 类 java.awt.Button.AccessibleAWTButton 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 java.awt.Checkbox.AccessibleAWTCheckbox 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 java.awt.MenuItem.AccessibleAWTMenuItem 中的方法
将此对象的值设置为数字。
setCurrentAccessibleValue(Number) - 类 java.awt.Scrollbar.AccessibleAWTScrollBar 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 接口 javax.accessibility.AccessibleValue 中的方法
以 Number 形式设置此对象的值。
setCurrentAccessibleValue(Number) - 类 javax.swing.AbstractButton.AccessibleAbstractButton 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JInternalFrame.AccessibleJInternalFrame 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JProgressBar.AccessibleJProgressBar 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JScrollBar.AccessibleJScrollBar 中的方法
将此对象的值设置为一个 Number。
setCurrentAccessibleValue(Number) - 类 javax.swing.JSlider.AccessibleJSlider 中的方法
将此对象的值设置为数字。
setCurrentAccessibleValue(Number) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
将此对象的值设置为数字。
setCurrentAccessibleValue(Number) - 类 javax.swing.JSplitPane.AccessibleJSplitPane 中的方法
将此对象的值设置为一个 Number。
setCurrentDirectory(File) - 类 javax.swing.JFileChooser 中的方法
设置当前目录。
setCurrentKeyboardFocusManager(KeyboardFocusManager) - 类 java.awt.KeyboardFocusManager 中的静态方法
设置调用线程上下文的当前 KeyboardFocusManager 实例。
setCurrentLineLength(int) - 类 javax.swing.text.AbstractWriter 中的方法
设置当前行的长度。
setCurrentManager(FocusManager) - 类 javax.swing.FocusManager 中的静态方法
设置调用线程上下文的当前 KeyboardFocusManager 实例。
setCurrentManager(RepaintManager) - 类 javax.swing.RepaintManager 中的静态方法
设置用于调用线程的 RepaintManager。
setCurrentTheme(MetalTheme) - 类 javax.swing.plaf.metal.MetalLookAndFeel 中的静态方法
设置 MetalLookAndFeel 使用的主题。
setCursor(Cursor) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 java.awt.Component 中的方法
为指定的光标设置光标图像。
setCursor(Cursor) - 类 java.awt.dnd.DragSourceContext 中的方法
将此拖动操作的光标设置为指定的 Cursor。
setCursor(int) - 类 java.awt.Frame 中的方法
已过时。 从 JDK version 1.1 开始，由 Component.setCursor(Cursor) 取代。
setCursor(Cursor) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 java.awt.Window 中的方法
设置指定光标的光标图像。
setCursor(Cursor) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 javax.swing.JInternalFrame 中的方法
为指定的光标设置光标图像。
setCursor(Cursor) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setCursor(Cursor) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的 Cursor。
setCursor(Cursor) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setCursor(Cursor) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setCursorName(String) - 接口 java.sql.Statement 中的方法
将 SQL 指针名称设置为给定的 String，后续 Statement 对象的 execute 方法将使用此字符串。
setCurve(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D.Double 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D.Float 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(float, float, float, float, float, float, float, float) - 类 java.awt.geom.CubicCurve2D.Float 中的方法
将此曲线结束点和控制点的位置设置为指定的 float 坐标。
setCurve(double, double, double, double, double, double, double, double) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(double[], int) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 double 坐标。
setCurve(Point2D, Point2D, Point2D, Point2D) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定的 Point2D 坐标。
setCurve(Point2D[], int) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 Point2D 对象的坐标。
setCurve(CubicCurve2D) - 类 java.awt.geom.CubicCurve2D 中的方法
将此曲线端点和控制点的位置设置为与指定的 CubicCurve2D 相同。
setCurve(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D.Double 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D.Float 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(float, float, float, float, float, float) - 类 java.awt.geom.QuadCurve2D.Float 中的方法
将此曲线端点和控制点的位置设置为指定的 float 坐标。
setCurve(double, double, double, double, double, double) - 类 java.awt.geom.QuadCurve2D 中的方法
将此曲线端点和控制点的位置设置为指定的 double 坐标。
setCurve(double[], int) - 类 java.awt.geom.QuadCurve2D 中的方法
将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处的 double 坐标。
setCurve(Point2D, Point2D, Point2D) - 类 java.awt.geom.QuadCurve2D 中的方法
将此 QuadCurve2D 端点和控制点的位置设置为指定的 Point2D 坐标。
setCurve(Point2D[], int) - 类 java.awt.geom.QuadCurve2D 中的方法
将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处 Point2D 对象的坐标。
setCurve(QuadCurve2D) - 类 java.awt.geom.QuadCurve2D 中的方法
将此 QuadCurve2D 端点和控制点的位置设置为与指定的 QuadCurve2D 相同。
setDaemon(boolean) - 类 java.lang.Thread 中的方法
将该线程标记为守护线程或用户线程。
setDaemon(boolean) - 类 java.lang.ThreadGroup 中的方法
更改此线程组的后台程序状态。
setData(int, byte[]) - 类 java.awt.color.ICC_Profile 中的方法
从一个 byte 数组中设置配置文件中的特定标记数据元素。
setData(Raster) - 类 java.awt.image.BufferedImage 中的方法
将图像的矩形区域设置为指定 Raster r 的内容，假定该区域与 BufferedImage 处于相同的坐标空间。
setData(Raster) - 接口 java.awt.image.WritableRenderedImage 中的方法
将图像的 rect 设置为 Raster r 的内容，假定 r 位于与 WritableRenderedImage 相同的坐标空间。
setData(byte[], int, int) - 类 java.net.DatagramPacket 中的方法
为此包设置数据缓冲区。
setData(byte[]) - 类 java.net.DatagramPacket 中的方法
为此包设置数据缓冲区。
setData(byte[]) - 类 javax.imageio.stream.IIOByteBuffer 中的方法
更新对 getData 方法的后续调用将返回的数组引用。
setData(String) - 接口 org.w3c.dom.CharacterData 中的方法
实现此接口的节点的字符数据。
setData(String) - 接口 org.w3c.dom.ProcessingInstruction 中的方法
此处理指令的内容。
setDataContentHandlerFactory(DataContentHandlerFactory) - 类 javax.activation.DataHandler 中的静态方法
设置 DataContentHandlerFactory。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, int, int, Object, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 TransferType 类型的基本数组设置指定 DataBuffer 中像素矩形的数据。
setDataElements(int, int, Object, DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
根据 TransferType 类型的基本数组设置指定 DataBuffer 中单个像素的数据。
setDataElements(int, int, Object) - 类 java.awt.image.WritableRaster 中的方法
为类型 TransferType 基本数组中的单个像素设置数据。
setDataElements(int, int, Raster) - 类 java.awt.image.WritableRaster 中的方法
为输入 Raster 中的像素矩形设置数据。
setDataElements(int, int, int, int, Object) - 类 java.awt.image.WritableRaster 中的方法
为类型 TransferType 基本数组中的像素矩形设置数据。
setDatagramSocketImplFactory(DatagramSocketImplFactory) - 类 java.net.DatagramSocket 中的静态方法
为应用程序设置数据报套接字实现工厂。
setDataHandler(DataHandler) - 类 javax.xml.soap.AttachmentPart 中的方法
将给定的 DataHandler 对象设置为此 AttachmentPart 对象的数据处理程序。
setDataSourceLock(int) - 类 javax.sql.rowset.spi.SyncProvider 中的方法
按照 datasource_lock 指示的级别在底层数据源上设置锁定。
setDataSourceName(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 DataSource 名称属性设置为给定的逻辑名，并将此 RowSet 对象的 Url 属性设置为 null。
setDataSourceName(String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的数据源名称属性设置为给定的 String。
setDatatypeConverter(DatatypeConverterInterface) - 类 javax.xml.bind.DatatypeConverter 中的静态方法
此方法仅适用于 JAXB 提供者。
setDataVector(Vector, Vector) - 类 javax.swing.table.DefaultTableModel 中的方法
用新的行 Vector（dataVector）替换当前的 dataVector 实例变量。
setDataVector(Object[][], Object[]) - 类 javax.swing.table.DefaultTableModel 中的方法
用数组 dataVector 中的值替换 dataVector 实例变量中的值。
setDate(Date) - 类 java.security.cert.PKIXParameters 中的方法
设置应该确定证书路径有效性的时间。
setDate(String, Date) - 接口 java.sql.CallableStatement 中的方法
使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。
setDate(String, Date, Calendar) - 接口 java.sql.CallableStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
setDate(int, Date) - 接口 java.sql.PreparedStatement 中的方法
使用运行应用程序的虚拟机的默认时区将指定参数设置为给定 java.sql.Date 值。
setDate(int, Date, Calendar) - 接口 java.sql.PreparedStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
setDate(int) - 类 java.sql.Time 中的方法
已过时。
setDate(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.DAY_OF_MONTH, int date) 取代。
setDate(int, Date) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Date 值。
setDate(int, Date, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Date 对象。
setDate(String, Date) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
setDate(String, Date, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
setDate(int, Date) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Date 值。
setDate(int, Date, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
setDate(String, Date) - 接口 javax.sql.RowSet 中的方法
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
setDate(String, Date, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
setDateAndTime(Date) - 类 java.security.cert.X509CRLSelector 中的方法
设置 dateAndTime 标准。
setDateFormatSymbols(DateFormatSymbols) - 类 java.text.SimpleDateFormat 中的方法
设置此日期格式的日期和时间格式符号。
setDay(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置月中的日。
setDebugGraphicsOptions(int) - 类 javax.swing.JComponent 中的方法
启用或禁用与组件或其某个子组件内执行的每个图形操作有关的诊断信息。
setDebugOptions(int) - 类 javax.swing.DebugGraphics 中的方法
启用/禁用有关每个图形操作的诊断信息。
setDecimalFormatSymbols(DecimalFormatSymbols) - 类 java.text.DecimalFormat 中的方法
设置小数格式符号，通常程序员或用户不改变此符号。
setDecimalSeparator(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于十进制符号的字符。
setDecimalSeparatorAlwaysShown(boolean) - 类 java.text.DecimalFormat 中的方法
允许设置整数中小数分隔符的行为。
setDeclared(int, boolean) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
将值分配给特定属性的“声明的”标志。
setDecodeTables(JPEGQTable[], JPEGHuffmanTable[], JPEGHuffmanTable[]) - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
设置量化表和 Huffman 表以在解码简写流中使用。
setDecomposition(int) - 类 java.text.Collator 中的方法
设置此 Collator 的 decomposition 模式。
setDefault(Authenticator) - 类 java.net.Authenticator 中的静态方法
设置在代理或 HTTP 服务器请求验证时连网密码使用的 authenticator。
setDefault(CookieHandler) - 类 java.net.CookieHandler 中的静态方法
设置（或取消设置）系统级 cookie 处理程序。
setDefault(ProxySelector) - 类 java.net.ProxySelector 中的静态方法
设置（或取消设置）系统级代理选择器。
setDefault(ResponseCache) - 类 java.net.ResponseCache 中的静态方法
设置（或取消设置）系统级缓存。
setDefault(Locale) - 类 java.util.Locale 中的静态方法
为此 Java 虚拟机实例设置默认语言环境。
setDefault(TimeZone) - 类 java.util.TimeZone 中的静态方法
设置由 getDefault 方法返回的 TimeZone。
setDefault(SSLContext) - 类 javax.net.ssl.SSLContext 中的静态方法
设置默认的 SSL 上下文。
setDefaultAction(Action) - 接口 javax.swing.text.Keymap 中的方法
在进行击键的情况下设置要激发的默认操作。
setDefaultActions(int) - 类 java.awt.dnd.DropTarget 中的方法
为此 DropTarget 设置默认的可接受操作。
setDefaultAllowUserInteraction(boolean) - 类 java.net.URLConnection 中的静态方法
将未来的所有 URLConnection 对象的 allowUserInteraction 字段的默认值设置为指定的值。
setDefaultAssertionStatus(boolean) - 类 java.lang.ClassLoader 中的方法
设置此类加载器的默认断言状态。
setDefaultButton(JButton) - 类 javax.swing.JRootPane 中的方法
设置 defaultButton 属性，它确定此 JRootPane 的当前默认按钮。
setDefaultCapable(boolean) - 类 javax.swing.JButton 中的方法
设置 defaultCapable 属性，该属性确定此按钮是否可以是其根窗格的默认按钮。
setDefaultClassLoader(ClassLoader) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
设置此连接器服务器的默认 ClassLoader。
setDefaultCloseOperation(int) - 类 javax.swing.JDialog 中的方法
设置当用户在此对话框上启动 "close" 时默认执行的操作。
setDefaultCloseOperation(int) - 类 javax.swing.JFrame 中的方法
设置用户在此窗体上发起 "close" 时默认执行的操作。
setDefaultCloseOperation(int) - 类 javax.swing.JInternalFrame 中的方法
设置用户在此内部窗体上发起 "close" 时默认执行的操作。
setDefaultCommandMap(CommandMap) - 类 javax.activation.CommandMap 中的静态方法
设置默认的 CommandMap。
setDefaultCursor(Cursor) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
设置默认光标。
setDefaultDTD() - 类 javax.swing.text.html.parser.ParserDelegator 中的静态方法
setDefaultEditor(Class<?>, TableCellEditor) - 类 javax.swing.JTable 中的方法
如果尚未在 TableColumn 中设置编辑器，则设置要使用的默认单元格编辑器。
setDefaultFileTypeMap(FileTypeMap) - 类 javax.activation.FileTypeMap 中的静态方法
设置系统的默认 FileTypeMap。
setDefaultFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - 类 java.awt.KeyboardFocusManager 中的方法
设置给定遍历操作的默认焦点遍历键。
setDefaultFocusTraversalPolicy(FocusTraversalPolicy) - 类 java.awt.KeyboardFocusManager 中的方法
设置默认 FocusTraversalPolicy。
setDefaultFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
设置 JFormattedTextField.AbstractFormatter 供最后选择使用，例如，未指定任何显示、编辑或 null JFormattedTextField.AbstractFormatter。
setDefaultHostnameVerifier(HostnameVerifier) - 类 javax.net.ssl.HttpsURLConnection 中的静态方法
设置此类的新实例所继承的默认 HostnameVerifier。
setDefaultLightWeightPopupEnabled(boolean) - 类 javax.swing.JPopupMenu 中的静态方法
设置 lightWeightPopupEnabled 属性的默认值。
setDefaultLocale(Locale) - 类 javax.swing.JComponent 中的静态方法
设置在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。
setDefaultLocale(Locale) - 类 javax.swing.UIDefaults 中的方法
设置默认语言环境。
setDefaultLookAndFeelDecorated(boolean) - 类 javax.swing.JDialog 中的静态方法
提供一个关于是否应该通过当前外观为新创建的 JDialog 提供其 Window 装饰（如边界、关闭窗口的小部件、标题……）的提示。
setDefaultLookAndFeelDecorated(boolean) - 类 javax.swing.JFrame 中的静态方法
提供一个关于新创建的 JFrame 是否应该具有当前外观为其提供的 Window 装饰（如边框、关闭窗口的小部件、标题等等）的提示。
setDefaultNamespace(String) - 接口 javax.xml.stream.XMLEventWriter 中的方法
将 URI 绑定到默认名称空间。
setDefaultNamespace(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
将 URI 绑定到默认名称空间。
setDefaultNamespacePrefix(String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
setDefaultNamespacePrefix(String) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置默认的名称空间前缀。
setDefaultQueue(LayoutQueue) - 类 javax.swing.text.LayoutQueue 中的静态方法
设置默认的布局队列。
setDefaultRenderer(Class<?>, TableCellRenderer) - 类 javax.swing.JTable 中的方法
如果没有在 TableColumn 中设置渲染器，则设置要使用的默认单元格渲染器。
setDefaultRenderer(TableCellRenderer) - 类 javax.swing.table.JTableHeader 中的方法
设置 TableColumn 未定义 headerRenderer 时所使用的默认渲染器。
setDefaultRequestProperty(String, String) - 类 java.net.URLConnection 中的静态方法
已过时。 应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。
setDefaultSelection(JobAttributes.DefaultSelectionType) - 类 java.awt.JobAttributes 中的方法
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。
setDefaultSSLSocketFactory(SSLSocketFactory) - 类 javax.net.ssl.HttpsURLConnection 中的静态方法
设置此类的新实例所继承的默认 SSLSocketFactory。
setDefaultStream(PrintStream) - 类 java.rmi.server.LogStream 中的静态方法
已过时。 无替代版本
setDefaultUncaughtExceptionHandler(Thread.UncaughtExceptionHandler) - 类 java.lang.Thread 中的静态方法
设置当线程由于未捕获到异常而突然终止，并且没有为该线程定义其他处理程序时所调用的默认处理程序。
setDefaultUseCaches(boolean) - 类 java.net.URLConnection 中的方法
将 useCaches 字段的默认值设置为指定的值。
setDelay(int) - 类 javax.swing.JMenu 中的方法
设置菜单的 PopupMenu 向上或向下弹出前建议的延迟。
setDelay(int) - 类 javax.swing.Timer 中的方法
设置 Timer 的事件间延迟，两次连续的动作事件之间的毫秒数。
setDerefLinkFlag(boolean) - 类 javax.naming.directory.SearchControls 中的方法
启用/禁用在搜索期间取消对链接的引用。
setDescription(String) - 类 javax.swing.ImageIcon 中的方法
设置图像的描述。
setDescriptor(Descriptor) - 接口 javax.management.DescriptorAccess 中的方法
设置 Descriptor（完全替换）。
setDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 中的方法
设置 ModelMBeanAttributeDescriptor 的关联 Descriptor（完全取代）。
setDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 中的方法
设置 ModelMBeanConstructorInfo 的关联 Descriptor（完全替换）。
setDescriptor(Descriptor, String) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
setDescriptor(Descriptor, String) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
setDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 中的方法
设置 ModelMBeanNotificationInfo 的关联 Descriptor（完全替换）。
setDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanOperationInfo 中的方法
设置 ModelMBeanOperationInfo 的关联 Descriptor（完全取代）。
setDescriptors(Descriptor[]) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
添加或替换 ModelMBeanInfo 中的描述符。
setDescriptors(Descriptor[]) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
setDesignTime(boolean) - 类 java.beans.beancontext.BeanContextSupport 中的方法
为此 BeanContext 设置新的设计时间值。
setDesignTime(boolean) - 类 java.beans.Beans 中的静态方法
用于指示是否正运行在应用程序生成器环境中。
setDesignTime(boolean) - 接口 java.beans.DesignMode 中的方法
设置 "designTime" 属性的 "value"。
setDesktopIcon(JInternalFrame.JDesktopIcon) - 类 javax.swing.JInternalFrame 中的方法
设置与此 JInternalFrame 关联的 JDesktopIcon。
setDesktopManager(DesktopManager) - 类 javax.swing.JDesktopPane 中的方法
设置处理特定于桌面 UI 操作的 DesktopManger。
setDesktopProperty(String, Object) - 类 java.awt.Toolkit 中的方法
将指定桌面属性设置为指定值，并触发一个属性更改事件，以通知所有侦听器该值已更改。
setDestination(JobAttributes.DestinationType) - 类 java.awt.JobAttributes 中的方法
指定将输出到打印机还是使用这些属性的作业文件。
setDestination(BufferedImage) - 类 javax.imageio.ImageReadParam 中的方法
提供一个 BufferedImage，将其用作解码像素数据的目标。
setDestinationBands(int[]) - 类 javax.imageio.ImageReadParam 中的方法
设置将在其中放置数据的目标 band 的索引。
setDestinationOffset(Point) - 类 javax.imageio.IIOParam 中的方法
指定目标图像中的偏移量。
setDestinationType(ImageTypeSpecifier) - 类 javax.imageio.IIOParam 中的方法
使用 ImageTypeSpecifier 设置目标图像的所需图像类型。
setDestinationType(ImageTypeSpecifier) - 类 javax.imageio.ImageReadParam 中的方法
setDialog(JobAttributes.DialogType) - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。
setDialogTitle(String) - 类 javax.swing.JFileChooser 中的方法
设置显示在 JFileChooser 窗口标题栏的字符串。
setDialogType(int) - 类 javax.swing.JFileChooser 中的方法
设置此对话框的类型。
setDictionary(byte[], int, int) - 类 java.util.zip.Deflater 中的方法
为压缩设置预置字典。
setDictionary(byte[]) - 类 java.util.zip.Deflater 中的方法
为压缩预置字典。
setDictionary(byte[], int, int) - 类 java.util.zip.Inflater 中的方法
为给定的字节数组设置预置字典。
setDictionary(byte[]) - 类 java.util.zip.Inflater 中的方法
为给定字节的数组设置预置字典。
setDifferenceMode(boolean) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察到的 MBeans 的共同的差分模式标志值。
setDifferenceMode(boolean) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置差分模式标志值。
setDifferenceMode(boolean) - 类 javax.management.monitor.GaugeMonitor 中的方法
设置所有观察到的 MBean 的公共差分模式标志值。
setDifferenceMode(boolean) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
设置差分模式标志值。
setDigit(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于某种模式中数字的字符。
setDimensions(int, int) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口的 setDimensions 方法中提供的信息。
setDimensions(int, int) - 类 java.awt.image.CropImageFilter 中的方法
重写源图像的维度，并将矩形裁剪区域的维度传递给 ImageConsumer。
setDimensions(int, int) - 接口 java.awt.image.ImageConsumer 中的方法
使用 setDimensions 方法调用报告源图像尺寸。
setDimensions(int, int) - 类 java.awt.image.ImageFilter 中的方法
过滤 ImageConsumer 接口的 setDimensions 方法中所提供的信息。
setDimensions(int, int) - 类 java.awt.image.PixelGrabber 中的方法
setDimensions 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setDimensions(int, int) - 类 java.awt.image.ReplicateScaleFilter 中的方法
覆盖源像素的尺寸，并将缩放后的新尺寸传递给 ImageConsumer。
setDirection(int) - 类 javax.swing.plaf.basic.BasicArrowButton 中的方法
设置箭头的方向。
setDirection(int) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 中的方法
setDirection(int) - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 中的方法
setDirection(short) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
设置方向。
setDirectory(String) - 类 java.awt.FileDialog 中的方法
将此文件对话框窗口的目录设置为指定目录。
setDirectory(File) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
记忆当前在 UI 中选择的目录的属性。
setDirectoryName(String) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
setDirectoryName(String) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
setDirectorySelected(boolean) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
记忆当前是否在 UI 中选择了目录的属性。
setDirectorySelected(boolean) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
记忆某个目录在 UI 中当前是否被选择的属性。
setDisabledIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的禁用图标。
setDisabledIcon(Icon) - 类 javax.swing.JLabel 中的方法
设置如果此 JLabel 是“禁用的”(JLabel.setEnabled(false))，则要显示的图标。
setDisabledIconAt(int, Icon) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的禁用图标设置为 icon，它可以为 null。
setDisabledSelectedIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的禁用选择图标。
setDisabledTextColor(Color) - 类 javax.swing.text.JTextComponent 中的方法
设置用于呈现禁用文本的当前颜色。
setDiscard(boolean) - 类 java.net.HttpCookie 中的方法
指定用户代理是否应该无条件丢弃 cookie。
setDismissDelay(int) - 类 javax.swing.ToolTipManager 中的方法
指定取消工具提示的延迟值。
setDisplayedMnemonic(int) - 类 javax.swing.JLabel 中的方法
指定一个指示助记符键的键代码。
setDisplayedMnemonic(char) - 类 javax.swing.JLabel 中的方法
指定 displayedMnemonic 为一个 char 值。
setDisplayedMnemonicIndex(int) - 类 javax.swing.AbstractButton 中的方法
提供关于应该装饰文本中哪一个字符来表示助记符的外观提示。
setDisplayedMnemonicIndex(int) - 类 javax.swing.JLabel 中的方法
关于应该装饰文本中的哪个字符以表示助记符，为外观提供一个提示。
setDisplayedMnemonicIndexAt(int, int) - 类 javax.swing.JTabbedPane 中的方法
提供一个外观的提示，此提示是关于文本中哪此字符必须被装饰用来表示助记符。
setDisplayFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
设置在不编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
setDisplayMode(DisplayMode) - 类 java.awt.GraphicsDevice 中的方法
设置此图形设备的显示模式。
setDisplayName(String) - 类 java.beans.FeatureDescriptor 中的方法
设置此特性的本地化显示名称。
setDividerLocation(double) - 类 javax.swing.JSplitPane 中的方法
设置分隔条的位置为 JSplitPane 大小的一个百分比。
setDividerLocation(int) - 类 javax.swing.JSplitPane 中的方法
设置分隔条的位置。
setDividerLocation(JSplitPane, int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
将分隔符的位置设置到 location。
setDividerLocation(JSplitPane, int) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 setDividerLocation 方法。
setDividerLocation(JSplitPane, int) - 类 javax.swing.plaf.SplitPaneUI 中的方法
将分隔符的位置设置到 location。
setDividerSize(int) - 类 javax.swing.JSplitPane 中的方法
设置分隔条的大小。
setDividerSize(int) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
将分隔符的大小设置为 newSize。
setDockingColor(Color) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
设置在连接区域上时显示的颜色。
setDocument(Document) - 类 javax.swing.JFormattedTextField 中的方法
将该编辑器与某个文本文档关联。
setDocument(Document) - 类 javax.swing.JTextField 中的方法
将编辑器与一个文本文档关联。
setDocument(Document) - 类 javax.swing.JTextPane 中的方法
将编辑器与一个文本文档关联。
setDocument(Document) - 类 javax.swing.text.JTextComponent 中的方法
将编辑器与文本文档关联。
setDocumentFilter(DocumentFilter) - 类 javax.swing.text.AbstractDocument 中的方法
设置 DocumentFilter。
setDocumentHandler(DocumentHandler) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
注册 SAX1 文档事件处理程序。
setDocumentHandler(DocumentHandler) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序注册文档事件处理程序。
setDocumentLocator(Locator) - 接口 org.xml.sax.ContentHandler 中的方法
接收用来查找 SAX 文档事件起源的对象。
setDocumentLocator(Locator) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收用来查找 SAX 文档事件起源的对象。
setDocumentLocator(Locator) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收文档事件的 Locator 对象。
setDocumentLocator(Locator) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收文档事件的 Locator 对象。
setDocumentLocator(Locator) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
setDocumentLocator(Locator) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个新的文档定位器事件。
setDocumentLocator(Locator) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
设置文档定位器。
setDocumentProperties(Dictionary<Object, Object>) - 类 javax.swing.text.AbstractDocument 中的方法
替换此文档的文档属性字典。
setDocumentURI(String) - 接口 org.w3c.dom.Document 中的方法
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。
setDoInput(boolean) - 类 java.net.URLConnection 中的方法
将此 URLConnection 的 doInput 字段的值设置为指定的值。
setDomain(String) - 类 java.net.HttpCookie 中的方法
指定应在其中显示此 cookie 的域。
setDoOutput(boolean) - 类 java.net.URLConnection 中的方法
将此 URLConnection 的 doOutput 字段的值设置为指定的值。
setDot(int) - 接口 javax.swing.text.Caret 中的方法
将插入符位置设置为其他某个位置。
setDot(int) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符位置和标记设置为指定位置，存在向前偏差。
setDot(int, Position.Bias) - 类 javax.swing.text.DefaultCaret 中的方法
将插入符位置和标记设置为指定位置，存在指定偏差。
setDot(int, Position.Bias) - 类 javax.swing.text.NavigationFilter.FilterBypass 中的方法
设置插入符的位置，并跳过 NavigationFilter。
setDot(NavigationFilter.FilterBypass, int, Position.Bias) - 类 javax.swing.text.NavigationFilter 中的方法
在 Caret 设置点之前调用。
setDouble(Object, int, double) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 double 值。
setDouble(Object, double) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 double 值。
setDouble(String, double) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java double 值。
setDouble(int, double) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java double 值。
setDouble(int, double) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 double 值。
setDouble(String, double) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java double 值。
setDouble(int, double) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java double 值。
setDouble(String, double) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java double 值。
setDoubleBuffered(boolean) - 类 javax.swing.JComponent 中的方法
设置此组件是否应该使用缓冲区进行绘制。
setDoubleBuffered(boolean) - 类 javax.swing.JRootPane 中的方法
设置此组件是否应该使用缓冲区进行绘制。
setDoubleBufferingEnabled(boolean) - 类 javax.swing.RepaintManager 中的方法
在此 RepaintManager 中，启用或禁用双缓冲。
setDoubleBufferMaximumSize(Dimension) - 类 javax.swing.RepaintManager 中的方法
设置最大双缓冲区大小。
setDragEnabled(boolean) - 类 javax.swing.JColorChooser 中的方法
设置 dragEnabled 属性，该属性必须为 true 才能启用对此组件的自动拖动处理（拖放操作的第一部分）。
setDragEnabled(boolean) - 类 javax.swing.JFileChooser 中的方法
设置 dragEnabled 属性，要在此组件上启用自动拖动处理（drag 和 drop 的第一部分），此属性必须为 true。
setDragEnabled(boolean) - 类 javax.swing.JList 中的方法
打开或关闭自动拖动处理。
setDragEnabled(boolean) - 类 javax.swing.JTable 中的方法
打开或关闭自动拖动处理。
setDragEnabled(boolean) - 类 javax.swing.JTree 中的方法
打开或关闭自动拖动处理。
setDragEnabled(boolean) - 类 javax.swing.text.JTextComponent 中的方法
开启或关闭自动拖动处理。
setDraggedColumn(TableColumn) - 类 javax.swing.table.JTableHeader 中的方法
将头的 draggedColumn 设置为 aColumn。
setDraggedDistance(int) - 类 javax.swing.table.JTableHeader 中的方法
将头的 draggedDistance 设置为 distance。
setDragMode(int) - 类 javax.swing.JDesktopPane 中的方法
设置桌面窗格使用的“拖动样式”。
setDragOffset(Point) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
setDrawsLayeredHighlights(boolean) - 类 javax.swing.text.DefaultHighlighter 中的方法
如果为 true，则高亮显示将在视图绘制文本时绘制。
setDropAction(int) - 类 javax.swing.TransferHandler.TransferSupport 中的方法
将传输（必须表示一个放置操作）的放置动作设置为给定动作，而不是默认的用户放置动作。
setDropMode(DropMode) - 类 javax.swing.JList 中的方法
设置此组件的放置模式。
setDropMode(DropMode) - 类 javax.swing.JTable 中的方法
设置此组件的放置模式。
setDropMode(DropMode) - 类 javax.swing.JTree 中的方法
设置此组件的放置模式。
setDropMode(DropMode) - 类 javax.swing.text.JTextComponent 中的方法
设置此组件的放置模式，为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。
setDropTarget(DropTarget) - 类 java.awt.Component 中的方法
将组件与 DropTarget 相关联。
setDSTSavings(int) - 类 java.util.SimpleTimeZone 中的方法
设置在夏令时期间时钟提前的时间量（以毫秒为单位）。
setDTDHandler(DTDHandler) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置 DTD 处理程序。
setDTDHandler(DTDHandler) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置 DTD 事件处理程序。
setDTDHandler(DTDHandler) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
注册 DTD 事件处理程序。
setDTDHandler(DTDHandler) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序注册 DTD 事件处理程序。
setDTDHandler(DTDHandler) - 接口 org.xml.sax.XMLReader 中的方法
允许应用程序注册 DTD 事件处理程序。
setDynamicLayout(boolean) - 类 java.awt.Toolkit 中的方法
控制 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。
setEastPane(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setEchoChar(char) - 类 java.awt.TextField 中的方法
设置此文本字段的回显字符。
setEchoChar(char) - 类 javax.swing.JPasswordField 中的方法
设置此 JPasswordField 的回显字符。
setEchoCharacter(char) - 类 java.awt.TextField 中的方法
已过时。 从 JDK version 1.1 开始，由 setEchoChar(char) 取代。
setEditable(boolean) - 类 java.awt.TextComponent 中的方法
设置判断此文本组件是否可编辑的标志。
setEditable(boolean) - 类 javax.swing.JComboBox 中的方法
确定 JComboBox 字段是否可编辑。
setEditable(boolean) - 类 javax.swing.JTree 中的方法
确定树是否可编辑。
setEditable(boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
配置接收者以允许或不允许进行编辑。
setEditable(boolean) - 类 javax.swing.text.JTextComponent 中的方法
设置指定的 boolean 变量，以指示此 TextComponent 是否应该为可编辑的。
setEditFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
设置在编辑 JFormattedTextField 并且值为非 null 或值虽然为 null 但是未指定 null formatter 的情况下使用的 JFormattedTextField.AbstractFormatter。
setEditingColumn(int) - 类 javax.swing.JTable 中的方法
设置 editingColumn 变量。
setEditingRow(int) - 类 javax.swing.JTable 中的方法
设置 editingRow 变量。
setEditor(ComboBoxEditor) - 类 javax.swing.JComboBox 中的方法
设置用于绘制和编辑 JComboBox 字段中所选项的编辑器。
setEditor(JComponent) - 类 javax.swing.JSpinner 中的方法
更改显示 SpinnerModel 当前值的 JComponent。
setEditorKit(EditorKit) - 类 javax.swing.JEditorPane 中的方法
设置当前为处理内容而安装的工具包。
setEditorKit(EditorKit) - 类 javax.swing.JTextPane 中的方法
设置当前安装的用于内容处理的工具包。
setEditorKitForContentType(String, EditorKit) - 类 javax.swing.JEditorPane 中的方法
直接设置用于给定类型的编辑器工具包。
setEditorSearchPath(String[]) - 类 java.beans.PropertyEditorManager 中的静态方法
更改将用来查找属性编辑器的包名称的列表。
setEditValid(boolean) - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
调用此方法以更新 JFormattedTextField 的 editValid 属性。
setElem(int, int) - 类 java.awt.image.DataBuffer 中的方法
根据给定的整数设置第一个（默认）存储单元中所请求的数据数组元素。
setElem(int, int, int) - 类 java.awt.image.DataBuffer 中的方法
根据给定的整数设置指定存储单元中所请求的数据数组元素。
setElem(int, int) - 类 java.awt.image.DataBufferByte 中的方法
将第一个（默认）存储单元中所请求的数据数组设置为指定值。
setElem(int, int, int) - 类 java.awt.image.DataBufferByte 中的方法
根据给定的整数设置指定存储单元中所请求的数据数组元素。
setElem(int, int) - 类 java.awt.image.DataBufferDouble 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 int。
setElem(int, int, int) - 类 java.awt.image.DataBufferDouble 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 int。
setElem(int, int) - 类 java.awt.image.DataBufferFloat 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 int。
setElem(int, int, int) - 类 java.awt.image.DataBufferFloat 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 int。
setElem(int, int) - 类 java.awt.image.DataBufferInt 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
setElem(int, int, int) - 类 java.awt.image.DataBufferInt 中的方法
将指定存储单元中所请求的数据数组元素设置为整数值 i。
setElem(int, int) - 类 java.awt.image.DataBufferShort 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
setElem(int, int, int) - 类 java.awt.image.DataBufferShort 中的方法
根据给定的整数设置指定存储单元中所请求的数据数组元素。
setElem(int, int) - 类 java.awt.image.DataBufferUShort 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
setElem(int, int, int) - 类 java.awt.image.DataBufferUShort 中的方法
根据给定的整数设置指定存储单元中所请求的数据数组元素。
setElemDouble(int, double) - 类 java.awt.image.DataBuffer 中的方法
根据给定的 double 设置第一个（默认）存储单元中所请求的数据数组元素。
setElemDouble(int, int, double) - 类 java.awt.image.DataBuffer 中的方法
根据给定的 double 设置指定存储单元中所请求的数据数组元素。
setElemDouble(int, double) - 类 java.awt.image.DataBufferDouble 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 double。
setElemDouble(int, int, double) - 类 java.awt.image.DataBufferDouble 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 double。
setElemDouble(int, double) - 类 java.awt.image.DataBufferFloat 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 double。
setElemDouble(int, int, double) - 类 java.awt.image.DataBufferFloat 中的方法
将指定存储单元中所请求的数据数组元素设置为 double。
setElementAt(E, int) - 类 java.util.Vector 中的方法
将此向量指定 index 处的组件设置为指定的对象。
setElementAt(Object, int) - 类 javax.swing.DefaultListModel 中的方法
将此列表指定 index 处的组件设置为指定的对象。
setElementQName(QName) - 接口 javax.xml.soap.SOAPElement 中的方法
如果可能，将此 Element 的名称更改为 newName。
setElemFloat(int, float) - 类 java.awt.image.DataBuffer 中的方法
根据给定的 float 设置第一个（默认）存储单元中所请求的数据数组元素。
setElemFloat(int, int, float) - 类 java.awt.image.DataBuffer 中的方法
根据给定的 float 设置指定存储单元中所请求的数据数组元素。
setElemFloat(int, float) - 类 java.awt.image.DataBufferDouble 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 float。
setElemFloat(int, int, float) - 类 java.awt.image.DataBufferDouble 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 float。
setElemFloat(int, float) - 类 java.awt.image.DataBufferFloat 中的方法
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 float。
setElemFloat(int, int, float) - 类 java.awt.image.DataBufferFloat 中的方法
将指定存储单元中所请求的数据数组元素设置为给定的 float。
setEnabled(boolean) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的启用状态。
setEnabled(boolean) - 类 java.awt.Component 中的方法
根据参数 b 的值启用或禁用此组件。
setEnabled(boolean) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置对象的启用状态。
setEnabled(boolean) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置该对象的启用状态。
setEnabled(boolean) - 类 java.awt.MenuItem 中的方法
设置是否可以选择此菜单项。
setEnabled(boolean) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置对象的启用状态。
setEnabled(boolean) - 类 javax.swing.AbstractAction 中的方法
启用或禁用该操作。
setEnabled(boolean) - 类 javax.swing.AbstractButton 中的方法
启用（或禁用）按钮。
setEnabled(boolean) - 接口 javax.swing.Action 中的方法
设置 Action 的启用状态。
setEnabled(boolean) - 接口 javax.swing.ButtonModel 中的方法
启用或禁用该按钮。
setEnabled(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
启用或禁用该按钮。
setEnabled(boolean) - 类 javax.swing.JComboBox 中的方法
启用组合框以便可以选择项。
setEnabled(boolean) - 类 javax.swing.JComponent 中的方法
设置是否启用此组件。
setEnabled(boolean) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setEnabled(boolean) - 类 javax.swing.JMenuItem 中的方法
启用或禁用菜单项。
setEnabled(boolean) - 类 javax.swing.JScrollBar 中的方法
启用该组件以便滑块位置能够改变。
setEnabled(boolean) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置该对象的启用状态。
setEnabled(boolean) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setEnabled(boolean) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
setEnabled(boolean) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setEnabled(boolean) - 类 javax.swing.ToolTipManager 中的方法
启用或禁用工具提示。
setEnabledAt(int, boolean) - 类 javax.swing.JTabbedPane 中的方法
设置是否启用 index 位置的选项卡。
setEnabledCipherSuites(String[]) - 类 javax.naming.ldap.StartTlsResponse 中的方法
重写在 TLS 连接上启用的密码套件的默认列表。
setEnabledCipherSuites(String[]) - 类 javax.net.ssl.SSLEngine 中的方法
设置密码套件为启用，以便在此引擎上使用。
setEnabledCipherSuites(String[]) - 类 javax.net.ssl.SSLServerSocket 中的方法
把密码套件设置为启用的以供接受的连接使用。
setEnabledCipherSuites(String[]) - 类 javax.net.ssl.SSLSocket 中的方法
将密码套件设置为启用以供此连接使用。
setEnabledProtocols(String[]) - 类 javax.net.ssl.SSLEngine 中的方法
设置为了在此引擎上使用而启用的协议版本。
setEnabledProtocols(String[]) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制启用哪些特定的协议以供接受的连接使用。
setEnabledProtocols(String[]) - 类 javax.net.ssl.SSLSocket 中的方法
设置启用以供此连接使用的协议版本。
setEnableSessionCreation(boolean) - 类 javax.net.ssl.SSLEngine 中的方法
控制是否可以由此引擎建立新的 SSL 会话。
setEnableSessionCreation(boolean) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制新 SSL 会话是否可以通过此服务器套接字创建的套接字建立。
setEnableSessionCreation(boolean) - 类 javax.net.ssl.SSLSocket 中的方法
控制是否可以使用此套接字建立新的 SSL 会话。
setEncodeTables(JPEGQTable[], JPEGHuffmanTable[], JPEGHuffmanTable[]) - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
设置量化表和 Huffman 表以在编码简写流中使用。
setEncoding(String) - 类 java.util.logging.Handler 中的方法
设置该 Handler 所用的字符编码。
setEncoding(String) - 类 java.util.logging.StreamHandler 中的方法
设置（或更改）该 Handler 所用的字符编码。
setEncoding(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置输出编码的便捷方法。
setEncoding(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
字符串编码（如果已知）。
setEncoding(String) - 接口 org.w3c.dom.ls.LSOutput 中的方法
用于输出的字符编码。
setEncoding(String) - 类 org.xml.sax.ext.Locator2Impl 中的方法
分配编码属性的当前值。
setEncoding(String) - 类 org.xml.sax.InputSource 中的方法
设置字符编码（如果已知）。
setEncodingStyle(String) - 接口 javax.xml.soap.SOAPElement 中的方法
将此 SOAPElement 对象的编码样式设置为指定样式。
setEnd(Comparable) - 类 javax.swing.SpinnerDateModel 中的方法
更改此序列中 Date 的上限。
setEndIndex(int) - 类 java.text.FieldPosition 中的方法
Sets the end index.由 Format 的子类使用。
setEndRule(int, int, int, int) - 类 java.util.SimpleTimeZone 中的方法
设置夏令时结束规则。
setEndRule(int, int, int) - 类 java.util.SimpleTimeZone 中的方法
将夏令时结束规则设置为某个月份的固定日期。
setEndRule(int, int, int, int, boolean) - 类 java.util.SimpleTimeZone 中的方法
将夏令时结束规则设置为某个月份给定日期之前或之后的星期几，例如，8 号或之后的第一个星期一。
setEntityResolver(EntityResolver) - 类 javax.xml.parsers.DocumentBuilder 中的方法
指定使用 EntityResolver 解析要解析的 XML 文档中存在的实体。
setEntityResolver(EntityResolver) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置实体解析器。
setEntityResolver(EntityResolver) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置实体解析器。
setEntityResolver(EntityResolver) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
注册实体解析器。
setEntityResolver(EntityResolver) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序注册自定义的实体解析器。
setEntityResolver(EntityResolver) - 接口 org.xml.sax.XMLReader 中的方法
允许应用程序注册实体解析器。
setEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - 类 java.security.KeyStore 中的方法
用指定别名保存 keystore Entry。
setEnvironment(Hashtable<?, ?>) - 异常 javax.naming.CannotProceedException 中的方法
设置调用 getEnvironment() 时将返回的环境。
setEras(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置年代字符串。
setErr(PrintStream) - 类 java.lang.System 中的静态方法
重新分配“标准”错误输出流。
setError() - 类 java.io.PrintStream 中的方法
将该流的错误状态设置为 true。
setError() - 类 java.io.PrintWriter 中的方法
指示已发生错误。
setErrorHandler(ErrorHandler) - 类 javax.xml.parsers.DocumentBuilder 中的方法
指定解析器要使用的 ErrorHandler。
setErrorHandler(ErrorHandler) - 类 javax.xml.validation.SchemaFactory 中的方法
设置 ErrorHandler 以接收在 newSchema 方法调用期间遇到的错误。
setErrorHandler(ErrorHandler) - 类 javax.xml.validation.Validator 中的方法
设置 ErrorHandler 以接收在 validate 方法调用期间遇到的错误。
setErrorHandler(ErrorHandler) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置 ErrorHandler 以接收验证期间遇到的错误。
setErrorHandler(ErrorHandler) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置错误处理程序。
setErrorHandler(ErrorHandler) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置错误事件处理程序。
setErrorHandler(ErrorHandler) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
注册错误事件处理程序。
setErrorHandler(ErrorHandler) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序注册错误事件处理程序。
setErrorHandler(ErrorHandler) - 接口 org.xml.sax.XMLReader 中的方法
允许应用程序注册错误事件处理程序。
setErrorIndex(int) - 类 java.text.ParsePosition 中的方法
设置解析出错时的索引。
setErrorListener(ErrorListener) - 类 javax.xml.transform.Transformer 中的方法
设置转换的实际错误事件侦听器。
setErrorListener(ErrorListener) - 类 javax.xml.transform.TransformerFactory 中的方法
设置此 TransformerFactory 的错误事件侦听器，它将用于转换指令的处理，而不用于转换本身。
setErrorManager(ErrorManager) - 类 java.util.logging.Handler 中的方法
为该 Handler 定义一个 ErrorManager。
setErrorWriter(Writer) - 接口 javax.script.ScriptContext 中的方法
设置用来显示错误输出的 Writer。
setErrorWriter(Writer) - 类 javax.script.SimpleScriptContext 中的方法
设置用来显示错误输出的 Writer。
setEscapeProcessing(boolean) - 接口 java.sql.Statement 中的方法
将转义处理设置为开或关。
setEscapeProcessing(boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
设置为给定的 boolean 值，指示将 SQL 语句发送到数据库之前，驱动程序是否扫描转义语法并进行转义替换。
setEscapeProcessing(boolean) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的转义处理设置为开或关。
setEstimatedMajorSpan(boolean) - 类 javax.swing.text.AsyncBoxView 中的方法
设置 estimatedMajorSpan 属性，它确定是否应该将主跨距视为估计值。
setEventAllocator(XMLEventAllocator) - 类 javax.xml.stream.XMLInputFactory 中的方法
为事件设置一个用户定义的事件分配器。
setEventHandler(ValidationEventHandler) - 类 javax.xml.bind.Binder 中的方法
允许应用程序注册 ValidationEventHandler。
setEventHandler(ValidationEventHandler) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setEventHandler(ValidationEventHandler) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
允许应用程序注册一个验证事件处理程序。
setEventHandler(ValidationEventHandler) - 接口 javax.xml.bind.Marshaller 中的方法
允许应用程序注册一个验证事件处理程序。
setEventHandler(ValidationEventHandler) - 接口 javax.xml.bind.Unmarshaller 中的方法
允许应用程序注册 ValidationEventHandler。
setEventHandler(ValidationEventHandler) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
setException(Throwable) - 类 java.util.concurrent.FutureTask 中的方法
除非已经设置了此 Future 或已将其取消，否则它将报告一个 ExecutionException，并将给定的 throwable 作为其原因。
setExceptionListener(ExceptionListener) - 类 java.beans.Encoder 中的方法
将此流的异常处理程序设置为 exceptionListener。
setExceptionListener(ExceptionListener) - 类 java.beans.XMLDecoder 中的方法
将此流的异常处理程序设置为 exceptionListener。
setExclusiveOwnerThread(Thread) - 类 java.util.concurrent.locks.AbstractOwnableSynchronizer 中的方法
设置当前拥有独占访问的线程。
setExecutable(boolean, boolean) - 类 java.io.File 中的方法
设置此抽象路径名的所有者或所有用户的执行权限。
setExecutable(boolean) - 类 java.io.File 中的方法
设置此抽象路径名所有者执行权限的一个便捷方法。
setExecuteExistingDelayedTasksAfterShutdownPolicy(boolean) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
设置有关在此执行程序已 shutdown 的情况下是否继续执行现有延迟任务的策略。
setExecutor(Executor) - 类 javax.xml.ws.Endpoint 中的方法
设置此 Endpoint 实例的执行程序。
setExecutor(Executor) - 类 javax.xml.ws.Service 中的方法
设置此 Service 实例的执行程序。
setExecutor(Executor) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
设置此 Service 实例的执行程序。
setExpandedIcon(Icon) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setExpandedState(TreePath, boolean) - 类 javax.swing.JTree 中的方法
设置此 JTree 的展开状态。
setExpandedState(TreePath, boolean) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
将路径 path 的已扩展状态标记为 isExpanded。
setExpandedState(TreePath, boolean) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
将路径 path 的扩展状态标记为 isExpanded。
setExpandedState(TreePath, boolean) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
将路径 path 的扩展状态标记为 isExpanded。
setExpandEntityReferences(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将扩展实体引用节点。
setExpandsSelectedPaths(boolean) - 类 javax.swing.JTree 中的方法
配置 expandsSelectedPaths 属性。
setExpert(boolean) - 类 java.beans.FeatureDescriptor 中的方法
"expert" 标志用于区分打算供高级用户使用的特性和那些打算供普通用户使用的特性。
setExplicitPolicyRequired(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置 ExplicitPolicyRequired 标志。
setExponentSeparator(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于分隔尾数和指数的字符串。
setExtendedKeyUsage(Set<String>) - 类 java.security.cert.X509CertSelector 中的方法
设置 extendedKeyUsage 标准。
setExtendedState(int) - 类 java.awt.Frame 中的方法
设置此窗体的状态。
setExtent(int) - 接口 javax.swing.BoundedRangeModel 中的方法
设置模型的 extent。
setExtent(int) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
在确保 n 大于或等于零，且落在以下模型约束范围内之后，将 extent 设置为 n：
setExtent(int) - 类 javax.swing.JSlider 中的方法
设置滑块所“覆盖”的范围的大小。
setExtentSize(Dimension) - 类 javax.swing.JViewport 中的方法
使用视图坐标设置该视图可见部分的大小。
setExtra(byte[]) - 类 java.util.zip.ZipEntry 中的方法
为条目设置可选的额外字段数据。
setFailureHandler(RMIFailureHandler) - 类 java.rmi.server.RMISocketFactory 中的静态方法
如果服务器套接字创建失败，则设置将由 RMI 运行时调用的 failure 处理程序。
setFaultActor(String) - 接口 javax.xml.soap.SOAPFault 中的方法
使用给定的错误参与者 (actor) 设置此 SOAPFault 对象。
setFaultCode(Name) - 接口 javax.xml.soap.SOAPFault 中的方法
使用给定的错误代码设置此 SOAPFault 对象。
setFaultCode(QName) - 接口 javax.xml.soap.SOAPFault 中的方法
使用给定的错误代码设置此 SOAPFault 对象。
setFaultCode(String) - 接口 javax.xml.soap.SOAPFault 中的方法
使用给定的错误代码设置此 SOAPFault 对象。
setFaultNode(String) - 接口 javax.xml.soap.SOAPFault 中的方法
创建或替换此 SOAPFault 对象的任何现有 Node 元素。
setFaultRole(String) - 接口 javax.xml.soap.SOAPFault 中的方法
创建或替换此 SOAPFault 对象的任何现有 Role 元素。
setFaultString(String) - 接口 javax.xml.soap.SOAPFault 中的方法
将此 SOAPFault 对象的错误字符串设定为给定字符串。
setFaultString(String, Locale) - 接口 javax.xml.soap.SOAPFault 中的方法
将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。
setFeature(String, boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
设置由此工厂创建的此 DocumentBuilderFactory 和 DocumentBuilder 的功能。
setFeature(String, boolean) - 类 javax.xml.parsers.SAXParserFactory 中的方法
在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。
setFeature(String, boolean) - 类 javax.xml.transform.TransformerFactory 中的方法
设置通过此工厂创建的此 TransformerFactory 和 Transformer 或 Template 的功能。
setFeature(String, boolean) - 类 javax.xml.validation.SchemaFactory 中的方法
设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。
setFeature(String, boolean) - 类 javax.xml.validation.Validator 中的方法
设置功能标志的值。
setFeature(String, boolean) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置此 ValidatorHandler 的特性。
setFeature(String, boolean) - 类 javax.xml.xpath.XPathFactory 中的方法
设置此工厂所创建的此 XPathFactory 和 XPath 的功能。
setFeature(String, boolean) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
为解析器设置功能标志。
setFeature(String, boolean) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置功能的值。
setFeature(String, boolean) - 接口 org.xml.sax.XMLReader 中的方法
设置功能标志的值。
setFetchDirection(int) - 接口 java.sql.ResultSet 中的方法
设置此 ResultSet 对象中行的处理方向。
setFetchDirection(int) - 接口 java.sql.Statement 中的方法
向驱动程序提供关于方向的提示，在使用此 Statement 对象创建的 ResultSet 对象中将按该方向处理行。
setFetchDirection(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
为驱动程序提供一个性能提示，该提示指示处理此 RowSet 对象中各行时使用的方向。
setFetchSize(int) - 接口 java.sql.ResultSet 中的方法
为 JDBC 驱动程序设置此 ResultSet 对象需要更多行时应该从数据库获取的行数。
setFetchSize(int) - 接口 java.sql.Statement 中的方法
为 JDBC 驱动程序提供一个提示，它提示此 Statement 生成的 ResultSet 对象需要更多行时应该从数据库获取的行数。
setFetchSize(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的获取大小设置为给定的行数。
setField(String, Object) - 接口 javax.management.Descriptor 中的方法
设置特定字段名的值。
setField(String, Object) - 类 javax.management.ImmutableDescriptor 中的方法
因为此类不可变，所以不支持此操作。
setField(String, Object) - 类 javax.management.modelmbean.DescriptorSupport 中的方法
setFields(String[], Object[]) - 接口 javax.management.Descriptor 中的方法
将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。
setFields(String[], Object[]) - 类 javax.management.ImmutableDescriptor 中的方法
因为此类不可变，所以不支持此操作。
setFields(String[], Object[]) - 类 javax.management.modelmbean.DescriptorSupport 中的方法
setFile(String) - 类 java.awt.FileDialog 中的方法
将此文件对话框窗口的选定文件设置为指定文件。
setFileFilter(FileFilter) - 类 javax.swing.JFileChooser 中的方法
设置当前文件过滤器。
setFileHidingEnabled(boolean) - 类 javax.swing.JFileChooser 中的方法
设置是否实现文件隐藏。
setFileName(String) - 类 java.awt.JobAttributes 中的方法
指定使用这些属性的作业的输出文件的文件名。
setFileName(String) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
setFileName(String) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
setFilenameFilter(FilenameFilter) - 类 java.awt.FileDialog 中的方法
将此文件对话框窗口的文件名过滤器设置为指定的过滤器。
setFileNameMap(FileNameMap) - 类 java.net.URLConnection 中的静态方法
设置 FileNameMap。
setFileSelectionMode(int) - 类 javax.swing.JFileChooser 中的方法
设置 JFileChooser，以允许用户只选择文件、只选择目录，或者可选择文件和目录。
setFileSystemView(FileSystemView) - 类 javax.swing.JFileChooser 中的方法
设置为访问和创建文件系统资源（如查找软驱和获得根驱动器列表），JFileChooser 所使用的文件系统视图。
setFileTypeMap(FileTypeMap) - 类 javax.activation.FileDataSource 中的方法
设置用于此 FileDataSource 的 FileTypeMap。
setFileView(FileView) - 类 javax.swing.JFileChooser 中的方法
设置用于检索 UI 信息的文件视图，如表示文件的图标或文件的类型描述。
setFillsViewportHeight(boolean) - 类 javax.swing.JTable 中的方法
设置此表是否始终大到足以填充封闭视口的高度。
setFilter(Filter) - 类 java.util.logging.Handler 中的方法
设置 Filter，以控制该 Handler 的输出。
setFilter(Filter) - 类 java.util.logging.Logger 中的方法
设置过滤器以控制此 Logger 的输出。
setFilter(Predicate) - 接口 javax.sql.rowset.FilteredRowSet 中的方法
将给定的 Predicate 对象应用到此 FilteredRowSet 对象。
setFilter(LSParserFilter) - 接口 org.w3c.dom.ls.LSParser 中的方法
当提供过滤器时，实现将在构建 DOM 树结构时调出该过滤器。
setFilter(LSSerializerFilter) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
当应用程序提供过滤器时，在序列化每个节点前串行器将先调出过滤器。
setFirstDayOfWeek(int) - 类 java.util.Calendar 中的方法
设置一星期的第一天是哪一天；例如，在美国，这一天是 SUNDAY，而在法国，这一天是 MONDAY。
setFirstLineIndent(float) - 类 javax.swing.text.ParagraphView 中的方法
设置第一行的行缩进量。
setFirstLineIndent(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置首行缩进。
setFixedCellHeight(int) - 类 javax.swing.JList 中的方法
设置一个固定值，将用于列表中每个单元的高度。
setFixedCellWidth(int) - 类 javax.swing.JList 中的方法
设置一个固定值，将用于列表中每个单元的宽度。
setFixedLengthStreamingMode(int) - 类 java.net.HttpURLConnection 中的方法
此方法用于在预先已知内容长度时启用没有进行内部缓冲的 HTTP 请求正文的流。
setFlashColor(Color) - 类 javax.swing.DebugGraphics 中的静态方法
设置用于 flash 绘制操作的 Color。
setFlashCount(int) - 类 javax.swing.DebugGraphics 中的静态方法
设置绘制操作将要 flash 的次数。
setFlashTime(int) - 类 javax.swing.DebugGraphics 中的静态方法
设置绘制操作 flash 的时间延迟。
setFlavorMap(FlavorMap) - 类 java.awt.dnd.DropTarget 中的方法
设置 FlavorMap 与此 DropTarget 关联。
setFlavorsForNative(String, DataFlavor[]) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
放弃指定 String native 的当前映射，而创建指定 DataFlavor 的新映射。
setFloat(Object, int, float) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 float 值。
setFloat(Object, float) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 float 值。
setFloat(String, float) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java float 值。
setFloat(int, float) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java REAL 值。
setFloat(int, float) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 float 值。
setFloat(String, float) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java float 值。
setFloat(int, float) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java float 值。
setFloat(String, float) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java float 值。
setFloatable(boolean) - 类 javax.swing.JToolBar 中的方法
设置 floatable 属性，如果要移动工具栏，此属性必须设置为 true。
setFloating(boolean, Point) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
setFloatingColor(Color) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
设置在浮动区域上时显示的颜色。
setFloatingLocation(int, int) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
setFocusable(boolean) - 类 java.awt.Component 中的方法
将此 Component 的焦点状态设置为指定值。
setFocusableWindowState(boolean) - 类 java.awt.Window 中的方法
设置如果此窗口满足 isFocusableWindow 中列出的其他要求，其是否可以成为焦点窗口。
setFocusAccelerator(char) - 类 javax.swing.text.JTextComponent 中的方法
设置将导致接收的文本组件获取焦点的加速键。
setFocusCycleRoot(boolean) - 类 java.awt.Container 中的方法
设置此 Container 是否是某个焦点遍历循环的根。
setFocusCycleRoot(boolean) - 类 java.awt.Window 中的方法
不执行任何操作，因为窗口必须始终是焦点遍历循环的根。
setFocusCycleRoot(boolean) - 类 javax.swing.JInternalFrame 中的方法
不执行任何操作，原因是 JInternalFrame 必须始终为焦点遍历循环的根。
setFocusLostBehavior(int) - 类 javax.swing.JFormattedTextField 中的方法
设置丢失焦点时的行为。
setFocusPainted(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 paintFocus 属性，对于要绘制的焦点状态，该属性必须为 true。
setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - 类 java.awt.Component 中的方法
为此 Component 的给定遍历操作设置焦点遍历键。
setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - 类 java.awt.Container 中的方法
为此 Container 的给定遍历操作设置焦点遍历键。
setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - 类 javax.swing.JComponent 中的方法
设置针对此 Component 的给定遍历操作的焦点遍历键。
setFocusTraversalKeysEnabled(boolean) - 类 java.awt.Component 中的方法
设置是否为此 Component 启用焦点遍历键。
setFocusTraversalPolicy(FocusTraversalPolicy) - 类 java.awt.Container 中的方法
如果此 Container 是一个焦点循环根，则设置将管理此 Container 的子代的键盘遍历的焦点遍历策略。
setFocusTraversalPolicyProvider(boolean) - 类 java.awt.Container 中的方法
设置是否将用此容器提供焦点遍历策略。
setFollowRedirects(boolean) - 类 java.net.HttpURLConnection 中的静态方法
设置此类是否应该自动执行 HTTP 重定向（响应代码为 3xx 的请求）。
setFont(Font) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的 Font。
setFont(Font) - 类 java.awt.Component 中的方法
设置组件的字体。
setFont(Font) - 类 java.awt.Container 中的方法
设置此容器的字体。
setFont(Font) - 类 java.awt.Graphics 中的方法
将此图形上下文的字体设置为指定字体。
setFont(Font) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的 Font。
setFont(Font) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置此对象的 Font。
setFont(Font) - 类 java.awt.MenuComponent 中的方法
将用于此菜单组件的字体设置为指定字体。
setFont(Font) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置此对象的 Font。
setFont(Font) - 类 javax.swing.DebugGraphics 中的方法
设置用于文本绘制操作的 Font。
setFont(Font) - 类 javax.swing.JComponent 中的方法
设置此组件的字体。
setFont(Font) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setFont(Font) - 类 javax.swing.JSlider 中的方法
设置此组件的字体。
setFont(Font) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的 Font。
setFont(Font) - 类 javax.swing.JTextArea 中的方法
设置当前字体。
setFont(Font) - 类 javax.swing.JTextField 中的方法
设置当前字体。
setFont(Font) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setFont(Font) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setFont(Font) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
设置编辑使用的字体。
setFont(Font) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
创建子类，以便将 FontUIResource 映射为 null。
setFontFamily(MutableAttributeSet, String) - 类 javax.swing.text.StyleConstants 中的静态方法
设置字体属性。
setFontSize(MutableAttributeSet, int) - 类 javax.swing.text.StyleConstants 中的静态方法
设置字体大小属性。
setForeground(Color) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的前景色。
setForeground(Color) - 类 java.awt.Component 中的方法
设置组件的前景色。
setForeground(Color) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置此对象的前景颜色。
setForeground(Color) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置此对象的前景色。
setForeground(Color) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置此对象的前景色。
setForeground(Color) - 类 javax.swing.JComponent 中的方法
设置此组件的前景色。
setForeground(Color) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setForeground(Color) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置此对象的前景色。
setForeground(Color) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setForeground(Color) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
重写 JComponent.setForeground 将未选定单元格的前景色分配为指定颜色。
setForeground(Color) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setForeground(MutableAttributeSet, Color) - 类 javax.swing.text.StyleConstants 中的静态方法
设置前景色。
setForegroundAt(int, Color) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的前景色设置为 foreground，它可以为 null，在这种情况下选项卡的前景色默认为此 tabbedpane 的前景色。
setFormat(int, Format) - 类 java.text.MessageFormat 中的方法
使用在以前设置的模式字符串中给定的格式元素索引来设置格式元素使用的格式。
setFormat(DateFormat) - 类 javax.swing.text.DateFormatter 中的方法
设置用于指示可编辑和显示的合法值的格式。
setFormat(Format) - 类 javax.swing.text.InternationalFormatter 中的方法
设置指示可以编辑和显示的合法值的格式。
setFormat(Format) - 类 javax.swing.text.NumberFormatter 中的方法
设置指示可以编辑和显示的合法值的格式。
setFormatByArgumentIndex(int, Format) - 类 java.text.MessageFormat 中的方法
设置用于以前所设置的模式字符串中格式元素的格式，其中以前的模式字符串是用给定的参数索引设置的。
setFormats(Format[]) - 类 java.text.MessageFormat 中的方法
设置用于以前所设置的模式字符串中格式元素的格式。
setFormatsByArgumentIndex(Format[]) - 类 java.text.MessageFormat 中的方法
设置传递给 format 方法或从 parse 方法返回的值使用的格式。
setFormattedOutput(boolean) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置格式化输出标志的便捷方法。
setFormatter(Formatter) - 类 java.util.logging.Handler 中的方法
设置 Formatter。
setFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.JFormattedTextField 中的方法
设置当前的 AbstractFormatter。
setFormatterFactory(JFormattedTextField.AbstractFormatterFactory) - 类 javax.swing.JFormattedTextField 中的方法
设置 AbstractFormatterFactory。
setFractionalSecond(BigDecimal) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置小数秒。
setFragment(boolean) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置片段标志的便捷方法。
setFrame(double, double, double, double) - 类 java.awt.geom.Arc2D 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrame(double, double, double, double) - 类 java.awt.geom.Ellipse2D.Double 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrame(float, float, float, float) - 类 java.awt.geom.Ellipse2D.Float 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定矩形值。
setFrame(double, double, double, double) - 类 java.awt.geom.Ellipse2D.Float 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrame(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
将此 Rectangle2D 外部边界的位置和大小设置为指定矩形值。
setFrame(double, double, double, double) - 类 java.awt.geom.RectangularShape 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrame(Point2D, Dimension2D) - 类 java.awt.geom.RectangularShape 中的方法
将此 Shape 窗体矩形的位置和大小分别设置为指定的 Point2D 和 Dimension2D。
setFrame(Rectangle2D) - 类 java.awt.geom.RectangularShape 中的方法
将此 Shape 窗体矩形设置为指定的 Rectangle2D。
setFrame(double, double, double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
setFrameFromCenter(double, double, double, double) - 类 java.awt.geom.RectangularShape 中的方法
基于指定的中心点坐标和角点坐标设置此 Shape 的窗体矩形。
setFrameFromCenter(Point2D, Point2D) - 类 java.awt.geom.RectangularShape 中的方法
基于指定的中心 Point2D 和角 Point2D 设置此 Shape 的窗体矩形。
setFrameFromDiagonal(double, double, double, double) - 类 java.awt.geom.RectangularShape 中的方法
基于两个指定的坐标设置此 Shape 窗体矩形的对角线。
setFrameFromDiagonal(Point2D, Point2D) - 类 java.awt.geom.RectangularShape 中的方法
基于两个指定的 Point2D 对象设置此 Shape 窗体矩形的对角线。
setFrameIcon(Icon) - 类 javax.swing.JInternalFrame 中的方法
设置要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
setFramePosition(int) - 接口 javax.sound.sampled.Clip 中的方法
设置介质位置（以示例帧为单位）。
setFreeStanding(boolean) - 类 javax.swing.plaf.metal.MetalScrollButton 中的方法
setFromPage(int) - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的第一页。
setFromTree(String, Node) - 类 javax.imageio.metadata.IIOMetadata 中的方法
根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。
setFullBufferUpdates(boolean) - 类 java.awt.image.MemoryImageSource 中的方法
指定在像素缓冲区发生变化时，是否总是通过发送像素的完整缓冲区来更新此动画内存图像。
setFullScreenWindow(Window) - 类 java.awt.GraphicsDevice 中的方法
进入全屏模式，或返回窗口化模式。
setGlassPane(Component) - 类 javax.swing.JApplet 中的方法
设置 glassPane 属性。
setGlassPane(Component) - 类 javax.swing.JDialog 中的方法
设置 glassPane 属性。
setGlassPane(Component) - 类 javax.swing.JFrame 中的方法
设置 glassPane 属性。
setGlassPane(Component) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 glassPane 属性。
setGlassPane(Component) - 类 javax.swing.JRootPane 中的方法
将指定的 Component 设置为此根窗格的玻璃窗格。
setGlassPane(Component) - 类 javax.swing.JWindow 中的方法
设置 glassPane 属性。
setGlassPane(Component) - 接口 javax.swing.RootPaneContainer 中的方法
glassPane 始终为 rootPane 的第一个子组件，rootPanes 布局管理器确保它始终与 rootPane 一样大。
setGlobalActiveWindow(Window) - 类 java.awt.KeyboardFocusManager 中的方法
设置活动 Window。
setGlobalCurrentFocusCycleRoot(Container) - 类 java.awt.KeyboardFocusManager 中的方法
设置当前焦点循环根。
setGlobalFocusedWindow(Window) - 类 java.awt.KeyboardFocusManager 中的方法
设置聚焦 Window。
setGlobalFocusOwner(Component) - 类 java.awt.KeyboardFocusManager 中的方法
设置焦点所有者。
setGlobalPermanentFocusOwner(Component) - 类 java.awt.KeyboardFocusManager 中的方法
设置持久焦点所有者。
setGlyphPainter(GlyphView.GlyphPainter) - 类 javax.swing.text.GlyphView 中的方法
设置用于呈现字形的 painter。
setGlyphPosition(int, Point2D) - 类 java.awt.font.GlyphVector 中的方法
设置此 GlyphVector 中的指定字形位置。
setGlyphTransform(int, AffineTransform) - 类 java.awt.font.GlyphVector 中的方法
设置此 GlyphVector 中指定字形的转换。
setGranularityPeriod(long) - 类 javax.management.monitor.Monitor 中的方法
设置粒度周期（以毫秒为单位）。
setGranularityPeriod(long) - 接口 javax.management.monitor.MonitorMBean 中的方法
设置粒度时段（以毫秒为单位）。
setGregorianChange(Date) - 类 java.util.GregorianCalendar 中的方法
设置 GregorianCalendar 的更改日期。
setGridColor(Color) - 类 javax.swing.JTable 中的方法
将用来绘制网格线的颜色设置为 gridColor 并重新显示它。
setGridLocation(int, int) - 类 javax.swing.text.TableView.TableCell 中的方法
已过时。 设置网格的位置。
setGroup(ButtonGroup) - 接口 javax.swing.ButtonModel 中的方法
标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。
setGroup(ButtonGroup) - 类 javax.swing.DefaultButtonModel 中的方法
标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。
setGroupingSeparator(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于千位分隔符的字符。
setGroupingSize(int) - 类 java.text.DecimalFormat 中的方法
设置分组大小。
setGroupingUsed(boolean) - 类 java.text.NumberFormat 中的方法
设置此格式中是否使用分组。
setGuiAvailable(boolean) - 类 java.beans.Beans 中的静态方法
用于指示是否正运行在可进行 GUI 交互的环境中。
setHandler(ContentHandler) - 类 javax.xml.transform.sax.SAXResult 中的方法
设置要作为 SAX2 ContentHandler 的目标。
setHandlerChain(List<Handler>) - 接口 javax.xml.ws.Binding 中的方法
设置协议绑定实例的处理程序链。
setHandlerResolver(HandlerResolver) - 类 javax.xml.ws.Service 中的方法
设置此 Service 实例的 HandlerResolver。
setHandlerResolver(HandlerResolver) - 类 javax.xml.ws.spi.ServiceDelegate 中的方法
为此 Service 实例设置 HandlerResolver。
setHashColor(Color) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setHeader(String, String) - 类 javax.xml.soap.MimeHeaders 中的方法
将其名称与给定名称匹配的第一个头条目的当前值替换为给定值，如果现有的头名称都不匹配，则添加一个新的头。
setHeaderRenderer(TableCellRenderer) - 类 javax.swing.table.TableColumn 中的方法
将用于绘制 TableColumn 的标题的 TableCellRenderer 设置为 headerRenderer。
setHeaderValue(Object) - 类 javax.swing.table.TableColumn 中的方法
设置 Object，将使用其字符串表示形式作为 headerRenderer 的值。
setHeight(Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置 height 属性，该属性控制组件的高度。
setHelpMenu(Menu) - 类 java.awt.MenuBar 中的方法
将指定的菜单设置为此菜单栏的帮助菜单。
setHelpMenu(JMenu) - 类 javax.swing.JMenuBar 中的方法
设置用户选择菜单栏中的“帮助”选项时显示的帮助菜单。
setHgap(int) - 类 java.awt.BorderLayout 中的方法
设置组件之间的水平间距。
setHgap(int) - 类 java.awt.CardLayout 中的方法
设置组件之间的水平间距。
setHgap(int) - 类 java.awt.FlowLayout 中的方法
设置组件之间以及组件与 Container 的边之间的水平间隙。
setHgap(int) - 类 java.awt.GridLayout 中的方法
将组件之间的水平间距设置为指定值。
setHidden(boolean) - 类 java.beans.FeatureDescriptor 中的方法
"hidden" 标志用于标识只打算供工具使用、不应对人类开放的特性。
setHideActionText(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 hideActionText 属性，该属性确定按钮是否显示 Action 的文本。
setHighlighter(Highlighter) - 类 javax.swing.text.JTextComponent 中的方法
设置要使用的 highlighter。
setHints(int) - 类 java.awt.image.AreaAveragingScaleFilter 中的方法
检测数据是否正使用必要的提示进行传送，从而允许平均算法执行其功能。
setHints(int) - 接口 java.awt.image.ImageConsumer 中的方法
设置 ImageConsumer 用于处理 ImageProducer 所传递像素的提示。
setHints(int) - 类 java.awt.image.ImageFilter 中的方法
过滤 ImageConsumer 接口的 setHints 方法中所提供的信息。
setHints(int) - 类 java.awt.image.PixelGrabber 中的方法
setHints 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setHoldability(int) - 接口 java.sql.Connection 中的方法
将使用此 Connection 对象创建的 ResultSet 对象的默认可保存性 (holdability) 更改为给定可保存性。
setHonorsVisibility(boolean) - 类 javax.swing.GroupLayout 中的方法
设置确定组件的大小和位置时是否要考虑组件的可见性。
setHonorsVisibility(Component, Boolean) - 类 javax.swing.GroupLayout 中的方法
设置确定组件的大小和位置时是否要考虑组件的可见性。
setHorizontalAlignment(int) - 类 javax.swing.AbstractButton 中的方法
设置图标和文本的水平对齐方式。
setHorizontalAlignment(int) - 类 javax.swing.JLabel 中的方法
设置标签内容沿 X 轴的对齐方式。
setHorizontalAlignment(int) - 类 javax.swing.JTextField 中的方法
设置文本的水平对齐方式。
setHorizontalGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout 中的方法
设置沿水平轴确定组件位置和大小的 Group。
setHorizontalScrollBar(JScrollBar) - 类 javax.swing.JScrollPane 中的方法
将控制视口水平视图位置的水平滚动条添加到滚动窗格中。
setHorizontalScrollBarPolicy(int) - 类 javax.swing.JScrollPane 中的方法
确定水平滚动条何时显示在滚动窗格上。
setHorizontalScrollBarPolicy(int) - 类 javax.swing.ScrollPaneLayout 中的方法
设置水平滚动条显示策略。
setHorizontalTextPosition(int) - 类 javax.swing.AbstractButton 中的方法
设置文本相对于图标的水平位置。
setHorizontalTextPosition(int) - 类 javax.swing.JLabel 中的方法
设置标签的文本相对其图像的水平位置。
setHostnameVerifier(HostnameVerifier) - 类 javax.naming.ldap.StartTlsResponse 中的方法
设置在已完成 TLS 握手且默认主机名校验失败后供 negotiate() 使用的主机名校验器。
setHostnameVerifier(HostnameVerifier) - 类 javax.net.ssl.HttpsURLConnection 中的方法
设置此实例的 HostnameVerifier。
setHour(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置小时。
setHours(int) - 类 java.sql.Date 中的方法
已过时。
setHours(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.HOUR_OF_DAY, int hours) 取代。
setHumanPresentableName(String) - 类 java.awt.datatransfer.DataFlavor 中的方法
设置此 DataFlavor 表示的数据格式的得体的名称。
setHumanPresentableName(String) - 类 javax.activation.ActivationDataFlavor 中的方法
设置得体的名称。
setIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的默认图标。
setIcon(boolean) - 类 javax.swing.JInternalFrame 中的方法
如果外观支持图标化，则对此内部窗体执行图标化或取消图标化。
setIcon(Icon) - 类 javax.swing.JLabel 中的方法
定义此组件将要显示的图标。
setIcon(Icon) - 类 javax.swing.JOptionPane 中的方法
设置要显示的图标。
setIcon(MutableAttributeSet, Icon) - 类 javax.swing.text.StyleConstants 中的静态方法
设置图标属性。
setIconAt(int, Icon) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的图标设置为 icon，它可以为 null。
setIconifiable(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置 iconable 属性，对于能够使 JInternalFrame 变成一个图标的用户而言，该属性必须为 true。
setIconImage(Image) - 类 java.awt.Frame 中的方法
设置要作为此窗口图标显示的图像。
setIconImage(Image) - 类 java.awt.Window 中的方法
设置要作为此窗口图标显示的图像。
setIconImage(Image) - 类 javax.swing.JFrame 中的方法
设置要作为此窗口图标显示的图像。
setIconImages(List<? extends Image>) - 类 java.awt.Window 中的方法
设置要作为此窗口的图标显示的图像序列。
setIconOnly(boolean) - 类 javax.swing.plaf.metal.MetalComboBoxButton 中的方法
setIconTextGap(int) - 类 javax.swing.AbstractButton 中的方法
如果图标和文本的属性都已设置，则此属性定义图标和文本之间的间隔。
setIconTextGap(int) - 类 javax.swing.JLabel 中的方法
如果同时设置了图标和文本属性，则此属性定义它们之间的间隔。
setID(String) - 类 java.util.TimeZone 中的方法
设置时区 ID。
setIdAttribute(String, boolean) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setIdAttribute(String, boolean) - 接口 org.w3c.dom.Element 中的方法
如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。
setIdAttributeNode(Attr, boolean) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setIdAttributeNode(Attr, boolean) - 接口 org.w3c.dom.Element 中的方法
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
setIdAttributeNS(String, String, boolean) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setIdAttributeNS(Element, String, String) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
将名称空间 URI 和本地名称指定的元素属性注册为类型 ID。
setIdAttributeNS(String, String, boolean) - 接口 org.w3c.dom.Element 中的方法
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
setIdentifier(Object) - 类 javax.swing.table.TableColumn 中的方法
将 TableColumn 的标识符设置为 anIdentifier。
setIfModifiedSince(long) - 类 java.net.URLConnection 中的方法
将此 URLConnection 的 ifModifiedSince 字段的值设置为指定的值。
setIgnoreRepaint(boolean) - 类 java.awt.Component 中的方法
设置是否应该忽略从操作系统接受的绘制消息。
setIgnoringComments(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将忽略注释。
setIgnoringElementContentWhitespace(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此工厂创建的解析器在解析 XML 文档时，必须删除元素内容中的空格（有时也可以称作“可忽略空格”，请参阅 XML Rec 2.10）。
setImage(Image) - 类 java.awt.TrayIcon 中的方法
设置此 TrayIcon 的图像。
setImage(Image) - 类 javax.swing.ImageIcon 中的方法
设置由此图标显示的图像。
setImageableArea(double, double, double, double) - 类 java.awt.print.Paper 中的方法
设置此 Paper 的可成像区域。
setImageAutoSize(boolean) - 类 java.awt.TrayIcon 中的方法
设置自动调整大小的属性。
setImageObserver(ImageObserver) - 类 javax.swing.ImageIcon 中的方法
设置图像的图像观察者。
setImageURL(URL) - 类 java.awt.SplashScreen 中的方法
更改闪现屏幕图像。
setImplementation(Object) - 类 javax.management.StandardMBean 中的方法
替换包装在此对象中的实现对象。
setImplicitDownCycleTraversal(boolean) - 类 java.awt.ContainerOrderFocusTraversalPolicy 中的方法
设置此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环。
setImplicitDownCycleTraversal(boolean) - 类 javax.swing.SortingFocusTraversalPolicy 中的方法
设置此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环。
setIn(InputStream) - 类 java.lang.System 中的静态方法
重新分配“标准”输入流。
setInDefaultEventSet(boolean) - 类 java.beans.EventSetDescriptor 中的方法
将事件集标记为“默认”集合（或非默认集合）。
setIndentSpace(int) - 类 javax.swing.text.AbstractWriter 中的方法
允许子类指定缩进映射为多少空格。
setIndeterminate(boolean) - 类 javax.swing.JProgressBar 中的方法
设置进度条的 indeterminate 属性，该属性确定进度条处于确定模式中还是处于不确定模式中。
setIndex(int) - 接口 java.text.CharacterIterator 中的方法
将位置设置为文本中的指定位置，并返回该字符。
setIndex(int) - 类 java.text.ParsePosition 中的方法
设置当前解析位置。
setIndex(int) - 类 java.text.StringCharacterIterator 中的方法
实现 String 的 CharacterIterator.setIndex()。
setIndex(int) - 类 javax.swing.text.Segment 中的方法
将位置设置为文本中的指定位置，并返回该字符。
setIndexedReadMethod(Method) - 类 java.beans.IndexedPropertyDescriptor 中的方法
设置应该用于读取索引属性值的方法。
setIndexedWriteMethod(Method) - 类 java.beans.IndexedPropertyDescriptor 中的方法
设置应该用于写入索引属性值的方法。
setInfinity(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于表示无穷大的字符串。
setInfo(String) - 类 java.security.Identity 中的方法
已过时。 为此 Identity 指定一个常规信息字符串。
setInheritsPopupMenu(boolean) - 类 javax.swing.JComponent 中的方法
设置如果此组件没有分配给它的 JPopupMenu，那么 getComponentPopupMenu 是否应该委托给其父组件。
setInitialContextFactoryBuilder(InitialContextFactoryBuilder) - 类 javax.naming.spi.NamingManager 中的静态方法
将 InitialContextFactory 生成器设置为生成器。
setInitialDelay(int) - 类 javax.swing.Timer 中的方法
设置 Timer 的初始延迟，即启动计时器后触发第一个事件之前要等待的时间（以毫秒为单位）。
setInitialDelay(int) - 类 javax.swing.ToolTipManager 中的方法
指定初始延迟值。
setInitialPolicies(Set<String>) - 类 java.security.cert.PKIXParameters 中的方法
设置初始策略标识符（OID 字符串）的 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
setInitialSelectionValue(Object) - 类 javax.swing.JOptionPane 中的方法
设置（根据选择）最初向用户显示的输入值。
setInitialValue(Object) - 类 javax.swing.JOptionPane 中的方法
设置要启用的初始值，即最初显示窗格时处于焦点状态的 Component。
setInitThreshold(Number) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察对象的共同初始阈值。
setInitThreshold(Number) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置所有观察到的 MBeans 的公共初始阈值。
setInnerHTML(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
用指定为 HTML 字符串的内容替换给定元素的子元素。
setInput(byte[], int, int) - 类 java.util.zip.Deflater 中的方法
为压缩设置输入数据。
setInput(byte[]) - 类 java.util.zip.Deflater 中的方法
为压缩设置输入数据。
setInput(byte[], int, int) - 类 java.util.zip.Inflater 中的方法
为解压缩设置输入数据。
setInput(byte[]) - 类 java.util.zip.Inflater 中的方法
为解压缩设置输入数据。
setInput(Object, boolean, boolean) - 类 javax.imageio.ImageReader 中的方法
设置用于给定的 ImageInputStream 或其他 Object 的输入源。
setInput(Object, boolean) - 类 javax.imageio.ImageReader 中的方法
设置用于给定的 ImageInputStream 或其他 Object 的输入源。
setInput(Object) - 类 javax.imageio.ImageReader 中的方法
设置用于给定的 ImageInputStream 或其他 Object 的输入源。
setInputMap(int, InputMap) - 类 javax.swing.JComponent 中的方法
设置在 map 的 condition 条件下要使用的 InputMap。
setInputMethodContext(InputMethodContext) - 接口 java.awt.im.spi.InputMethod 中的方法
设置输入方法的上下文，这样可以将输入方法事件指派到客户端组件并能从客户端组件请求信息。
setInputSource(InputSource) - 类 javax.xml.transform.sax.SAXSource 中的方法
设置要用于 Source 的 SAX InputSource。
setInputStream(InputStream) - 类 javax.xml.transform.stream.StreamSource 中的方法
设置要用作输入的字节流。
setInputValue(Object) - 类 javax.swing.JOptionPane 中的方法
设置由用户选择或输入的输入值。
setInputVerifier(InputVerifier) - 类 javax.swing.JComponent 中的方法
设置此组件的输入校验器。
setInsets(short, short, short, short) - 类 javax.swing.text.CompositeView 中的方法
设置视图的 insets。
setInstalledLookAndFeels(UIManager.LookAndFeelInfo[]) - 类 javax.swing.UIManager 中的静态方法
设置可用外观的集合。
setInstance(LayoutStyle) - 类 javax.swing.LayoutStyle 中的静态方法
设置 LayoutStyle 的共享实例。
setInstanceFollowRedirects(boolean) - 类 java.net.HttpURLConnection 中的方法
设置此 HttpURLConnection 实例是否应该自动执行 HTTP 重定向（响应代码为 3xx 的请求）。
setInt(Object, int, int) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 int 值。
setInt(Object, int) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 int 值。
setInt(String, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java int 值。
setInt(int, int) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java int 值。
setInt(int, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的 int 值。
setInt(String, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java int 值。
setInt(int, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java int 值。
setInt(String, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java int 值。
setIntercellSpacing(Dimension) - 类 javax.swing.JTable 中的方法
将 rowMargin 和 columnMargin（单元格之间间距的高度和宽度）设置为 intercellSpacing。
setInterface(InetAddress) - 类 java.net.MulticastSocket 中的方法
设置多播网络接口，供其行为将受网络接口值影响的方法使用。
setInternalFrame(JInternalFrame) - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
设置与此 DesktopIcon 关联的 JInternalFrame。
setInternationalCurrencySymbol(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。
setInvalidCharacters(String) - 类 javax.swing.text.MaskFormatter 中的方法
允许进一步限制可以输入的字符。
setInverted(boolean) - 类 javax.swing.JSlider 中的方法
指定为 true，则反转滑块显示的值范围，指定为 false 则将值范围置为正常顺序。
setInvoker(Component) - 类 javax.swing.JPopupMenu 中的方法
设置此弹出菜单的调用者，即弹出菜单在其中显示的组件。
setInvokesStopCellEditing(boolean) - 类 javax.swing.JTree 中的方法
通过选择树中的另一个节点、树的数据中的更改或通过其他方法来确定编辑被中断时发生了什么情况。
setIssuer(X500Principal) - 类 java.security.cert.X509CertSelector 中的方法
设置 issuer 标准。
setIssuer(String) - 类 java.security.cert.X509CertSelector 中的方法
已过时，使用 X509CertSelector.setIssuer(X500Principal) 或 X509CertSelector.setIssuer(byte[]) 替代。
setIssuer(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 issuer 标准。
setIssuerNames(Collection<?>) - 类 java.security.cert.X509CRLSelector 中的方法
注意：请使用 X509CRLSelector.setIssuers(Collection) 方法，或者使用此方法时仅指定 byte 数组形式的标识名。
setIssuers(Collection<X500Principal>) - 类 java.security.cert.X509CRLSelector 中的方法
设置 issuerNames 标准。
setItalic(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置斜体属性。
setItem(Object) - 接口 javax.swing.ComboBoxEditor 中的方法
设置应该编辑的项。
setItem(Object) - 类 javax.swing.plaf.basic.BasicComboBoxEditor 中的方法
设置应该编辑的项。
setJMenuBar(JMenuBar) - 类 javax.swing.JApplet 中的方法
设置此 applet 的菜单栏。
setJMenuBar(JMenuBar) - 类 javax.swing.JDialog 中的方法
设置此对话框的菜单栏。
setJMenuBar(JMenuBar) - 类 javax.swing.JFrame 中的方法
设置此窗体的菜单栏。
setJMenuBar(JMenuBar) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 menuBar 属性。
setJMenuBar(JMenuBar) - 类 javax.swing.JRootPane 中的方法
添加或更改在分层窗格中使用的菜单栏。
setJNDIContext(Context) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
设置初始 JNDI 上下文，通过该上下文可以从 JNDI 名称空间获取 SyncProvider 实现
setJobName(String) - 类 java.awt.print.PrinterJob 中的方法
设置要打印的文档名称。
setJoinType(int) - 接口 javax.sql.rowset.JoinRowSet 中的方法
允许应用程序调整在 JoinRowSet 对象实例包含的表上强制应用的 JOIN 类型。
setJustification(int) - 类 javax.swing.text.ParagraphView 中的方法
设置对齐方式的类型。
setKeepAlive(boolean) - 类 java.net.Socket 中的方法
启用/禁用 SO_KEEPALIVE。
setKeepAliveTime(long, TimeUnit) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置线程在终止前可以保持空闲的时间限制。
setKeyBindingActive(boolean) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setKeyBindingRegistered(boolean) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setKeyChar(char) - 类 java.awt.event.KeyEvent 中的方法
设置 keyCode 值，以表示某个逻辑字符。
setKeyCode(int) - 类 java.awt.event.KeyEvent 中的方法
设置 keyCode 值，以表示某个物理键。
setKeyColumns(int[]) - 接口 javax.sql.rowset.CachedRowSet 中的方法
使用给定的列号数组设置此 CachedRowSet 对象的 keyCols 字段，它形成了唯一标识此 CachedRowSet 对象中某个行的键。
setKeyEntry(String, Key, char[], Certificate[]) - 类 java.security.KeyStore 中的方法
将给定的密钥分配给给定的别名，并用给定密码保护它。
setKeyEntry(String, byte[], Certificate[]) - 类 java.security.KeyStore 中的方法
将给定密钥（已经被保护）分配给给定别名。
setKeymap(Keymap) - 类 javax.swing.text.JTextComponent 中的方法
设置用于将事件绑定到操作的 keymap。
setKeyPair(KeyPair) - 类 java.security.Signer 中的方法
已过时。 为此签署人设置密钥对（公钥和私钥）。
setKeySelectionManager(JComboBox.KeySelectionManager) - 类 javax.swing.JComboBox 中的方法
设置将键盘字符转换为列表选择的对象。
setKeySelector(KeySelector) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
setKeySelector(KeySelector) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置用于查找某个密钥的密钥选择器。
setKeyUsage(boolean[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 keyUsage 标准。
setLabel(String) - 类 java.awt.Button 中的方法
将按钮的标签设置为指定的字符串。
setLabel(String) - 类 java.awt.Checkbox 中的方法
将此复选框的标签设置为字符串参数。
setLabel(String) - 类 java.awt.MenuItem 中的方法
将此菜单项的标签设置为指定标签。
setLabel(String) - 类 javax.swing.AbstractButton 中的方法
已过时。 - 由 setText(text) 取代
setLabel(String) - 类 javax.swing.JPopupMenu 中的方法
设置弹出菜单的标签。
setLabel(String) - 类 javax.swing.text.html.Option 中的方法
设置该选项使用的标签。
setLabelFor(Component) - 类 javax.swing.JLabel 中的方法
设置要添加标签的组件。
setLabelTable(Dictionary) - 类 javax.swing.JSlider 中的方法
用于指定将在给定值处绘制哪个标签。
setLargeModel(boolean) - 类 javax.swing.JTree 中的方法
指定 UI 是否使用大模型。
setLargeModel(boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果必要，则更新 componentListener。
setLastDividerLocation(int) - 类 javax.swing.JSplitPane 中的方法
将分隔条所处的最后位置设置为 newLastLocation。
setLastDragLocation(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
设置 JSplitPane 的最后拖动位置。
setLastModified(long) - 类 java.io.File 中的方法
设置此抽象路径名指定的文件或目录的最后一次修改时间。
setLayer(Integer) - 类 javax.swing.JInternalFrame 中的方法
设置此组件 layer 属性的便捷方法。
setLayer(int) - 类 javax.swing.JInternalFrame 中的方法
设置此组件 layer 属性的便捷方法。
setLayer(Component, int) - 类 javax.swing.JLayeredPane 中的方法
设置指定组件的 layer 属性，使之成为该层中最底部的组件。
setLayer(Component, int, int) - 类 javax.swing.JLayeredPane 中的方法
为指定组件设置 layer 属性，并设置它在该层中的位置。
setLayeredPane(JLayeredPane) - 类 javax.swing.JApplet 中的方法
设置 layeredPane 属性。
setLayeredPane(JLayeredPane) - 类 javax.swing.JDialog 中的方法
设置 layeredPane 属性。
setLayeredPane(JLayeredPane) - 类 javax.swing.JFrame 中的方法
设置 layeredPane 属性。
setLayeredPane(JLayeredPane) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 layeredPane 属性。
setLayeredPane(JLayeredPane) - 类 javax.swing.JRootPane 中的方法
设置供根窗格使用的分层窗格。
setLayeredPane(JLayeredPane) - 类 javax.swing.JWindow 中的方法
设置 layeredPane 属性。
setLayeredPane(JLayeredPane) - 接口 javax.swing.RootPaneContainer 中的方法
管理 contentPane 的 Container，在某些情况下为菜单栏。
setLayout(LayoutManager) - 类 java.awt.Container 中的方法
设置此容器的布局管理器。
setLayout(LayoutManager) - 类 java.awt.ScrollPane 中的方法
设置此容器的布局管理器。
setLayout(LayoutManager) - 类 javax.swing.AbstractButton 中的方法
为此容器设置布局管理器，有关此方法的完整描述，请参阅 Container.setLayout(LayoutManager)。
setLayout(LayoutManager) - 类 javax.swing.Box 中的方法
抛出一个 AWTError，因为 Box 只能使用 BoxLayout。
setLayout(LayoutManager) - 类 javax.swing.JApplet 中的方法
设置 LayoutManager。
setLayout(LayoutManager) - 类 javax.swing.JDialog 中的方法
设置 LayoutManager。
setLayout(LayoutManager) - 类 javax.swing.JFrame 中的方法
设置 LayoutManager。
setLayout(LayoutManager) - 类 javax.swing.JInternalFrame 中的方法
确保默认情况下无法设置此组件的布局。
setLayout(LayoutManager) - 类 javax.swing.JScrollPane 中的方法
设置此 JScrollPane 的布局管理器。
setLayout(LayoutManager) - 类 javax.swing.JToolBar 中的方法
setLayout(LayoutManager) - 类 javax.swing.JWindow 中的方法
设置 LayoutManager。
setLayoutOrientation(int) - 类 javax.swing.JList 中的方法
定义布置列表单元的方式。
setLayoutStyle(LayoutStyle) - 类 javax.swing.GroupLayout 中的方法
设置用于计算组件之间首选间隙的 LayoutStyle。
setLeadAnchorNotificationEnabled(boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 leadAnchorNotificationEnabled 标志的值。
setLeadSelectionIndex(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 lead 选择索引，确保 anchor 和新 lead 之间的值要么全部被选定，要么全部被取消选定。
setLeadSelectionIndex(int) - 接口 javax.swing.ListSelectionModel 中的方法
设置 lead 选择索引。
setLeadSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
将标识的路径设置为前导路径。
setLeafIcon(Icon) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于表示叶节点的图标。
setLeftChildIndent(int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setLeftComponent(Component) - 类 javax.swing.JSplitPane 中的方法
将组件设置到分隔条的左边（或上面）。
setLeftIndent(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置左边缩进。
setLeftInset(float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图四周左侧的空白部分。
setLength(long) - 类 java.io.RandomAccessFile 中的方法
设置此文件的长度。
setLength(int) - 类 java.lang.StringBuffer 中的方法
setLength(int) - 类 java.net.DatagramPacket 中的方法
为此包设置长度。
setLength(int) - 类 javax.imageio.stream.IIOByteBuffer 中的方法
更新对 getLength 方法的后续调用将返回的值。
setLenient(boolean) - 类 java.text.DateFormat 中的方法
指定日期/时间解析是否不严格。
setLenient(boolean) - 类 java.util.Calendar 中的方法
指定日期/时间解释是否是宽松的。
setLevel(Level) - 类 java.util.logging.Handler 中的方法
设置日志级别，指定该 Handler 所记录的信息级别。
setLevel(Level) - 类 java.util.logging.Logger 中的方法
设置日志级别，指定此 logger 记录的消息级别。
setLevel(Level) - 类 java.util.logging.LogRecord 中的方法
设置日志消息级别，例如 Level.SEVERE。
setLevel(int) - 类 java.util.zip.Deflater 中的方法
将当前压缩级别设置为指定值。
setLevel(int) - 类 java.util.zip.ZipOutputStream 中的方法
为后续的 DEFLATED 条目设置压缩级别。
setLexicalHandler(LexicalHandler) - 类 javax.xml.transform.sax.SAXResult 中的方法
设置输出的 SAX2 LexicalHandler。
setLibraryDirectory(String) - 类 javax.management.loading.MLet 中的方法
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。
setLibraryDirectory(String) - 接口 javax.management.loading.MLetMBean 中的方法
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。
setLightWeightPopupEnabled(boolean) - 类 javax.swing.JComboBox 中的方法
设置 lightWeightPopupEnabled 属性，该属性提供一个提示：是应该使用重量级 Component（如 Panel 或 Window）还是轻量级 Component 来包含 JComboBox。
setLightWeightPopupEnabled(boolean) - 类 javax.swing.JPopupMenu 中的方法
设置 lightWeightPopupEnabled 属性的值，默认情况下该值为 true。
setLightWeightPopupEnabled(boolean) - 类 javax.swing.ToolTipManager 中的方法
显示 JToolTip 时，该 ToolTipManager 会选择使用一个轻量级 JPanel（如果合适）。
setLimit(int) - 类 javax.swing.undo.UndoManager 中的方法
设置此 UndoManager 保持的最大编辑数。
setLine(double, double, double, double) - 类 java.awt.geom.Line2D.Double 中的方法
将此 Line2D 的端点位置设置为指定的 double 坐标。
setLine(double, double, double, double) - 类 java.awt.geom.Line2D.Float 中的方法
将此 Line2D 的端点位置设置为指定的 double 坐标。
setLine(float, float, float, float) - 类 java.awt.geom.Line2D.Float 中的方法
将此 Line2D 端点的位置设置为指定的 float 坐标。
setLine(double, double, double, double) - 类 java.awt.geom.Line2D 中的方法
将此 Line2D 的端点位置设置为指定的 double 坐标。
setLine(Point2D, Point2D) - 类 java.awt.geom.Line2D 中的方法
将此 Line2D 端点的位置设置为指定的 Point2D 坐标。
setLine(Line2D) - 类 java.awt.geom.Line2D 中的方法
将此 Line2D 端点的位置设置为与指定 Line2D 的这些端点相同。
setLineIncrement(int) - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 setUnitIncrement(int) 取代。
setLineLength(int) - 类 javax.swing.text.AbstractWriter 中的方法
允许子类设置每行上要写入的字符数。
setLineNumber(int) - 类 java.io.LineNumberInputStream 中的方法
已过时。 将行号设置为指定参数。
setLineNumber(int) - 类 java.io.LineNumberReader 中的方法
设置当前行号。
setLineNumber(int) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 lineNumber 字段。
setLineNumber(int) - 类 org.xml.sax.helpers.LocatorImpl 中的方法
设置此定位器的行数（从 1 开始）。
setLineSeparator(String) - 类 javax.swing.text.AbstractWriter 中的方法
设置用于表示换行的 String。
setLineSpacing(float) - 类 javax.swing.text.ParagraphView 中的方法
设置行间距。
setLineSpacing(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置行间距。
setLineWrap(boolean) - 类 javax.swing.JTextArea 中的方法
设置文本区的换行策略。
setLinkCursor(Cursor) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
设置要在链接上使用的光标。
setLinkedException(Throwable) - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
设置此事件的 linked exception 字段。
setLinkedException(Throwable) - 异常 javax.xml.bind.JAXBException 中的方法
添加链接的异常。
setLinkedException(Throwable) - 异常 javax.xml.bind.TypeConstraintException 中的方法
添加一个链接的异常。
setLinkExplanation(String) - 异常 javax.naming.LinkException 中的方法
设置与解析某一链接时所遇问题关联的解释。
setLinkRemainingName(Name) - 异常 javax.naming.LinkException 中的方法
设置此异常的剩余链接名称字段。
setLinkResolvedName(Name) - 异常 javax.naming.LinkException 中的方法
设置此异常的已解析链接名称字段。
setLinkResolvedObj(Object) - 异常 javax.naming.LinkException 中的方法
设置此异常的已解析链接对象字段。
setList(List<?>) - 类 javax.swing.SpinnerListModel 中的方法
更改定义此序列的列表，并将该模型 value 的索引重新设置为零。
setListData(Object[]) - 类 javax.swing.JList 中的方法
根据一个对象数组构造只读 ListModel，然后对此模型调用 setModel。
setListData(Vector<?>) - 类 javax.swing.JList 中的方法
根据一个 Vector 构造只读 ListModel，然后对此模型调用 setModel。
setListener(Marshaller.Listener) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setListener(Unmarshaller.Listener) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setListener(Marshaller.Listener) - 接口 javax.xml.bind.Marshaller 中的方法
向此 Marshaller 注册编组事件回调 Marshaller.Listener。
setListener(Unmarshaller.Listener) - 接口 javax.xml.bind.Unmarshaller 中的方法
向此 Unmarshaller 注册解组事件回调 Unmarshaller.Listener。
setLoadsSynchronously(boolean) - 类 javax.swing.text.html.ImageView 中的方法
设置如何加载图像。
setLocale(Locale) - 类 java.awt.Component 中的方法
设置组件的语言环境。
setLocale(Locale) - 接口 java.awt.im.spi.InputMethod 中的方法
试图设置输入语言环境。
setLocale(Locale) - 类 java.beans.beancontext.BeanContextSupport 中的方法
设置此 BeanContext 的语言环境。
setLocale(Locale) - 类 java.text.MessageFormat 中的方法
设置创建或比较子格式时要使用的语言环境。
setLocale(Locale) - 类 javax.imageio.ImageReader 中的方法
将此 ImageReader 的当前 Locale 设置为给定值。
setLocale(Locale) - 类 javax.imageio.ImageWriter 中的方法
将此 ImageWriter 的当前 Locale 设置为给定值。
setLocale(Locale) - 类 javax.security.auth.callback.LanguageCallback 中的方法
设置获取到的 Locale。
setLocale(Locale) - 接口 javax.tools.JavaCompiler.CompilationTask 中的方法
设置格式化诊断和其他本地化数据时要应用的语言环境。
setLocale(Locale) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
设置错误报告的语言环境。
setLocale(Locale) - 接口 org.xml.sax.Parser 中的方法
已过时。 允许应用程序请求错误和警告的环境。
setLocalName(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的本地名称。
setLocalPatternChars(String) - 类 java.text.DateFormatSymbols 中的方法
设置本地化的日期-时间模式字符。
setLocation(Point) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置对象相对父对象的位置。
setLocation(int, int) - 类 java.awt.Component 中的方法
将组件移到新位置。
setLocation(Point) - 类 java.awt.Component 中的方法
将组件移到新位置。
setLocation(double, double) - 类 java.awt.geom.Point2D.Double 中的方法
将此 Point2D 的位置设为指定的 double 坐标。
setLocation(double, double) - 类 java.awt.geom.Point2D.Float 中的方法
将此 Point2D 的位置设为指定的 double 坐标。
setLocation(float, float) - 类 java.awt.geom.Point2D.Float 中的方法
将此 Point2D 的位置设为指定的 float 坐标。
setLocation(double, double) - 类 java.awt.geom.Point2D 中的方法
将此 Point2D 的位置设为指定的 double 坐标。
setLocation(Point2D) - 类 java.awt.geom.Point2D 中的方法
将此 Point2D 的位置设为指定 Point2D 对象的坐标。
setLocation(Point) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置对象相对于父级的位置。
setLocation(Point) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置该对象相对于父对象的位置。
setLocation(Point) - 类 java.awt.Point 中的方法
将点的位置设为指定位置。
setLocation(int, int) - 类 java.awt.Point 中的方法
将此点更改为具有指定位置。
setLocation(double, double) - 类 java.awt.Point 中的方法
将此点的位置设为指定的双精度坐标。
setLocation(Point) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 移动到指定位置。
setLocation(int, int) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 移动到指定位置。
setLocation(Point) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置对象相对于父级的位置。
setLocation(Point) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setLocation(int, int) - 类 javax.swing.JPopupMenu 中的方法
使用 X、Y 坐标设置弹出菜单的左上角的位置。
setLocation(Point) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置该对象相对于父对象的位置。
setLocation(Point) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setLocation(Point) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setLocation(JavaFileManager.Location, Iterable<? extends File>) - 接口 javax.tools.StandardJavaFileManager 中的方法
将给定路径与给定位置关联。
setLocation(Location) - 类 javax.xml.stream.XMLEventFactory 中的方法
此方法允许对此工厂创建的每个事件设置 Location。
setLocationByPlatform(boolean) - 类 java.awt.Window 中的方法
设置窗口下次可见时应该出现的位置：本机窗口系统的默认位置，还是当前位置（由 getLocation 返回）。
setLocationRelativeTo(Component) - 类 java.awt.Window 中的方法
设置窗口相对于指定组件的位置。
setLocator(ValidationEventLocator) - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
设置此事件的 Locator 对象。
setLocator(SourceLocator) - 异常 javax.xml.transform.TransformerException 中的方法
setLocator 方法设置 SourceLocator 对象的实例，此对象指定了错误发生的位置。
setLockingKeyState(int, boolean) - 类 java.awt.Toolkit 中的方法
设置键盘上给定锁定键的状态。
setLog(OutputStream) - 类 java.rmi.server.RemoteServer 中的静态方法
将 RMI 调用记录到输出流 out 中。
setLogger(Logger) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
设置 SyncFactory 提供的 SyncProvider 实现所使用的日志对象。
setLogger(Logger, Level) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
设置 SyncFactory SPI 提供的 SyncProvider 实现所使用的日志对象。
setLoggerLevel(String, String) - 接口 java.util.logging.LoggingMXBean 中的方法
将指定 logger 设置为指定的新级别。
setLoggerName(String) - 类 java.util.logging.LogRecord 中的方法
设置源 Logger 名称。
setLogicalStyle(Style) - 类 javax.swing.JTextPane 中的方法
设置在当前插入符号位置用于段落的逻辑样式。
setLogicalStyle(int, Style) - 类 javax.swing.text.DefaultStyledDocument 中的方法
设置给定位置处用于段落的逻辑样式。
setLogicalStyle(int, Style) - 接口 javax.swing.text.StyledDocument 中的方法
设置给定位置的段落所用的逻辑样式。
setLoginTimeout(int) - 类 java.sql.DriverManager 中的静态方法
设置驱动程序试图连接到某一数据库时将等待的最长时间，以秒为单位。
setLoginTimeout(int) - 接口 javax.sql.CommonDataSource 中的方法
设置此数据源试图连接到某一数据库时将等待的最长时间，以秒为单位。
setLogStream(PrintStream) - 类 java.sql.DriverManager 中的静态方法
已过时。
setLogStream(PrintStream) - 类 javax.swing.DebugGraphics 中的静态方法
设置 DebugGraphics 在其中记录绘制操作的流。
setLogTimers(boolean) - 类 javax.swing.Timer 中的静态方法
启用／禁用计时器日志。
setLogWriter(PrintWriter) - 类 java.sql.DriverManager 中的静态方法
设置由 DriverManager 和所有驱动程序使用的日志/追踪 PrintWriter 对象。
setLogWriter(PrintWriter) - 接口 javax.sql.CommonDataSource 中的方法
将此 DataSource 对象的日志 writer 设置为给定的 java.io.PrintWriter 对象。
setLong(Object, int, long) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 long 值。
setLong(Object, long) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 long 值。
setLong(String, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java long 值。
setLong(int, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java long 值。
setLong(int, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 long 值。
setLong(String, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java long 值。
setLong(int, long) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java long 值。
setLong(String, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java long 值。
setLookAndFeel(LookAndFeel) - 类 javax.swing.UIManager 中的静态方法
将当前外观设置为 newLookAndFeel。
setLookAndFeel(String) - 类 javax.swing.UIManager 中的静态方法
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。
setLoopbackMode(boolean) - 类 java.net.MulticastSocket 中的方法
启用/禁用多播数据报的本地回送。
setLoopCount(int) - 接口 javax.sound.midi.Sequencer 中的方法
设置循环回放的重复次数。
setLoopEndPoint(long) - 接口 javax.sound.midi.Sequencer 中的方法
设置在循环中播放的最后一个 MIDI 节拍。
setLoopPoints(int, int) - 接口 javax.sound.sampled.Clip 中的方法
设置将在循环中播放的第一个和最后一个示例帧。
setLoopStartPoint(long) - 接口 javax.sound.midi.Sequencer 中的方法
设置在循环中播放的第一个 MIDI 节拍。
setMagicCaretPosition(Point) - 接口 javax.swing.text.Caret 中的方法
设置当前插入符的可视位置。
setMagicCaretPosition(Point) - 类 javax.swing.text.DefaultCaret 中的方法
保存当前插入符位置。
setMajorOffset(float) - 类 javax.swing.text.AsyncBoxView.ChildState 中的方法
此方法应该仅由 ChildLocator 调用，它只是一个保存缓存位置的便捷场所。
setMajorTickSpacing(int) - 类 javax.swing.JSlider 中的方法
此方法设置主刻度标记的间隔。
setManagedResource(Object, String) - 接口 javax.management.modelmbean.ModelMBean 中的方法
设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
setManagedResource(Object, String) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
setMargin(Insets) - 类 javax.swing.AbstractButton 中的方法
设置按钮边框和标签之间的空白。
setMargin(Insets) - 类 javax.swing.JMenuBar 中的方法
设置菜单栏的边框与其菜单之间的空白。
setMargin(Insets) - 类 javax.swing.JToolBar 中的方法
设置工具栏边框和它的按钮之间的空白。
setMargin(Insets) - 类 javax.swing.text.JTextComponent 中的方法
设置组件的边框和它的文本之间的空白。
setMask(String) - 类 javax.swing.text.MaskFormatter 中的方法
设置指示合法字符的掩码。
setMasterSyncMode(Sequencer.SyncMode) - 接口 javax.sound.midi.Sequencer 中的方法
设置此 sequencer 使用的定时信息源。
setMatchAllSubjectAltNames(boolean) - 类 java.security.cert.X509CertSelector 中的方法
允许/禁止匹配 setSubjectAlternativeNames 或 addSubjectAlternativeName 方法中所指定的所有 subjectAlternativeNames。
setMatchColumn(int) - 接口 javax.sql.rowset.Joinable 中的方法
将指定的列设置为此 RowSet 对象的匹配列。
setMatchColumn(int[]) - 接口 javax.sql.rowset.Joinable 中的方法
将指定的列设置为此 RowSet 对象的匹配列。
setMatchColumn(String) - 接口 javax.sql.rowset.Joinable 中的方法
将指定的列设置为此 RowSet 对象的匹配列。
setMatchColumn(String[]) - 接口 javax.sql.rowset.Joinable 中的方法
将指定的列设置为此 RowSet 对象的匹配列。
setMaxAge(long) - 类 java.net.HttpCookie 中的方法
设置 cookie 的最大生存时间，以秒为单位。
setMaxCRLNumber(BigInteger) - 类 java.security.cert.X509CRLSelector 中的方法
设置 maxCRLNumber 标准。
setMaxFieldSize(int) - 接口 java.sql.Statement 中的方法
设置此 Statement 对象生成的 ResultSet 对象中字符和二进制列值可以返回的最大字节数限制。
setMaxFieldSize(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将可用于此 RowSet 对象列值的最大字节数设置为给定数。
setMaxFieldSize(int) - 接口 javax.sql.RowSet 中的方法
将可以对列值返回的最大字节数设置为给定的字节数。
setMaximizable(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置 maximizable 属性，该属性确定是否可以通过某个用户操作最大化此 JInternalFrame。
setMaximizedBounds(Rectangle) - 类 java.awt.Frame 中的方法
设置此窗体的最大化边界。
setMaximum(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的最大值。
setMaximum(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的最大值。
setMaximum(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
此方法不应由用户代码调用。
setMaximum(int) - 接口 javax.swing.BoundedRangeModel 中的方法
将模型的 maximum 设置为 newMaximum。
setMaximum(int) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
在确保 n 以及其他三个属性满足以下模型约束条件之后，将 maximum 设置为 n：
setMaximum(boolean) - 类 javax.swing.JInternalFrame 中的方法
最大化并还原此内部窗体。
setMaximum(int) - 类 javax.swing.JProgressBar 中的方法
将进度条的最大值（存储在进度条的数据模型中）设置为 n。
setMaximum(int) - 类 javax.swing.JScrollBar 中的方法
设置模型的 maximum 属性。
setMaximum(int) - 类 javax.swing.JSlider 中的方法
将滑块的最大值设置为 maximum。
setMaximum(int) - 类 javax.swing.ProgressMonitor 中的方法
指定最大值。
setMaximum(Comparable) - 类 javax.swing.SpinnerNumberModel 中的方法
更改此序列中数字的上边界。
setMaximum(Comparable) - 类 javax.swing.text.InternationalFormatter 中的方法
设置最大允许值。
setMaximumFractionDigits(int) - 类 java.text.DecimalFormat 中的方法
设置某个数的小数部分中所允许的最大数字位数。
setMaximumFractionDigits(int) - 类 java.text.NumberFormat 中的方法
设置数的小数部分所允许的最大位数。
setMaximumIntegerDigits(int) - 类 java.text.DecimalFormat 中的方法
设置某个数字的整数部分中所允许的最大数字位数。
setMaximumIntegerDigits(int) - 类 java.text.NumberFormat 中的方法
设置数的整数部分所允许的最大位数。
setMaximumPoolSize(int) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置允许的最大线程数。
setMaximumRowCount(int) - 类 javax.swing.JComboBox 中的方法
设置 JComboBox 显示的最大行数。
setMaximumSize(Dimension) - 类 java.awt.Component 中的方法
将组件的最大大小设置为常量值。
setMaximumSize(Dimension) - 类 javax.swing.JComponent 中的方法
将此组件的最大大小设置为一个常量值。
setMaximumZoneSize(int) - 类 javax.swing.text.ZoneView 中的方法
设置所需的最大分区大小。
setMaxPage(int) - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户可以指定为要打印的最后一页的最大值。
setMaxPathLength(int) - 类 java.security.cert.PKIXBuilderParameters 中的方法
设置证书路径中可能存在的非自发中间证书的最大数目值。
setMaxPriority(int) - 类 java.lang.ThreadGroup 中的方法
设置线程组的最高优先级。
setMaxRows(int) - 接口 java.sql.Statement 中的方法
将此 Statement 对象生成的所有 ResultSet 对象可以包含的最大行数限制设置为给定数。
setMaxRows(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象可以包含的最大行数设置为给定数。
setMaxRows(int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象可以包含的最大行数设置为指定数。
setMaxSortKeys(int) - 类 javax.swing.DefaultRowSorter 中的方法
设置排序键的最大数量。
setMaxWidth(int) - 类 javax.swing.table.TableColumn 中的方法
将 TableColumn 的最大宽度设置为 maxWidth；如果 maxWidth 小于最小宽度，则设置为最小宽度。
setMaxZonesLoaded(int) - 类 javax.swing.text.ZoneView 中的方法
设置当前设置的允许同时加载的分区数。
setMBeanDescriptor(Descriptor) - 接口 javax.management.modelmbean.ModelMBeanInfo 中的方法
设置 ModelMBean 的描述符。
setMBeanDescriptor(Descriptor) - 类 javax.management.modelmbean.ModelMBeanInfoSupport 中的方法
setMBeanServer(MBeanServer) - 类 javax.management.AttributeValueExp 中的方法
设置要在其上执行查询的 MBean 服务器。
setMBeanServer(MBeanServer) - 类 javax.management.ObjectName 中的方法
setMBeanServer(MBeanServer) - 类 javax.management.QueryEval 中的方法
设置将在其上执行查询的 MBean 服务器。
setMBeanServer(MBeanServer) - 接口 javax.management.QueryExp 中的方法
设置将在其上执行查询的 MBean 服务器。
setMBeanServer(MBeanServer) - 接口 javax.management.remote.MBeanServerForwarder 中的方法
设置 MBeanServer 对象，请求经此对象处理后将转发到其上。
setMBeanServer(MBeanServer) - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
设置此连接器服务器所连接的 MBeanServer。
setMBeanServer(MBeanServer) - 类 javax.management.StringValueExp 中的方法
设置将在其上执行查询的 MBean 服务器。
setMBeanServer(MBeanServer) - 接口 javax.management.ValueExp 中的方法
已过时。 不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。
setMBeanServerForwarder(MBeanServerForwarder) - 类 javax.management.remote.JMXConnectorServer 中的方法
setMBeanServerForwarder(MBeanServerForwarder) - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。
setMBeanServerForwarder(MBeanServerForwarder) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
setMedia(PageAttributes.MediaType) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面所需的纸张尺寸。
setMediaToDefault() - 类 java.awt.PageAttributes 中的方法
将使用这些属性的页面的纸张尺寸设置为默认地区的默认尺寸。
setMenuBar(MenuBar) - 类 java.awt.Frame 中的方法
将此窗体的菜单栏设置为指定的菜单栏。
setMenuBar(JMenuBar) - 类 javax.swing.JInternalFrame 中的方法
已过时。 从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。
setMenuBar(JMenuBar) - 类 javax.swing.JRootPane 中的方法
已过时。 从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。
setMenuLocation(int, int) - 类 javax.swing.JMenu 中的方法
设置弹出组件的位置。
setMessage(String) - 类 java.util.logging.LogRecord 中的方法
设置本地化或格式化之前的“原始”日志消息。
setMessage(int, byte[], int) - 类 javax.sound.midi.MetaMessage 中的方法
为 MetaMessage 设置消息参数。
setMessage(byte[], int) - 类 javax.sound.midi.MidiMessage 中的方法
为 MIDI 消息设置数据。
setMessage(int) - 类 javax.sound.midi.ShortMessage 中的方法
为不带任何数据字节的 MIDI 消息设置参数。
setMessage(int, int, int) - 类 javax.sound.midi.ShortMessage 中的方法
为带一个或两个数据字节的 MIDI 消息设置参数。
setMessage(int, int, int, int) - 类 javax.sound.midi.ShortMessage 中的方法
为带两个数据字节的通道消息设置短消息参数。
setMessage(byte[], int) - 类 javax.sound.midi.SysexMessage 中的方法
为系统独占消息设置数据。
setMessage(int, byte[], int) - 类 javax.sound.midi.SysexMessage 中的方法
为系统独占消息设置数据。
setMessage(Object) - 类 javax.swing.JOptionPane 中的方法
设置选项窗格的消息对象。
setMessage(String) - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
设置此事件的 message 字段。
setMessage(SOAPMessage) - 接口 javax.xml.ws.handler.soap.SOAPMessageContext 中的方法
在此消息上下文中设置 SOAPMessage。
setMessageDigest(MessageDigest) - 类 java.security.DigestInputStream 中的方法
将指定的消息摘要与此流相关联。
setMessageDigest(MessageDigest) - 类 java.security.DigestOutputStream 中的方法
将指定的消息摘要与此流相关联。
setMessageType(int) - 类 javax.swing.JOptionPane 中的方法
设置选项窗格的消息类型。
setMetadata(IIOMetadata) - 类 javax.imageio.IIOImage 中的方法
将 IIOMetadata 设置为一个新对象或 null。
setMetaData(RowSetMetaData) - 接口 javax.sql.rowset.CachedRowSet 中的方法
使用给定的 RowSetMetaData 对象设置此 CachedRowSet 对象的元数据。
setMetaData(RowSetMetaData) - 接口 javax.sql.RowSetInternal 中的方法
将给定的 RowSetMetaData 对象设置为此 RowSet 对象的 RowSetMetaData 对象。
setMetadata(List<Source>) - 类 javax.xml.ws.Endpoint 中的方法
设置此端点的元数据。
setMethod(int) - 类 java.util.zip.ZipEntry 中的方法
设置条目的压缩方法。
setMethod(int) - 类 java.util.zip.ZipOutputStream 中的方法
设置用于后续条目的默认压缩方法。
setMicrosecondPosition(long) - 接口 javax.sound.midi.Sequencer 中的方法
设置 sequence 中的当前位置，用微秒表示
setMicrosecondPosition(long) - 接口 javax.sound.sampled.Clip 中的方法
设置介质位置（以微秒为单位）。
setMillis(long) - 类 java.util.logging.LogRecord 中的方法
设置事件时间。
setMillisecond(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置毫秒。
setMillisToDecideToPopup(int) - 类 javax.swing.ProgressMonitor 中的方法
指定在确定是否弹出进度监视器之前要等待的时间量。
setMillisToPopup(int) - 类 javax.swing.ProgressMonitor 中的方法
指定显示弹出监视器花费的时间量。
setMimeHeader(String, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将匹配给定名称的第一个头条目的值更改为给定值，如果现有的头都不匹配，则添加一个新的头。
setMimeHeader(String, String) - 类 javax.xml.soap.SOAPPart 中的方法
将与给定头名称匹配的第一个头条目的值更改为给定值，如果现有头都不匹配，则添加一个带有给定名称和值的新头。
setMinCRLNumber(BigInteger) - 类 java.security.cert.X509CRLSelector 中的方法
设置 minCRLNumber 标准。
setMinimalDaysInFirstWeek(int) - 类 java.util.Calendar 中的方法
设置一年中第一个星期所需的最少天数，例如，如果定义第一个星期包含一年第一个月的第一天，则使用值 1 调用此方法。
setMinimum(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的最小值。
setMinimum(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的最小值。
setMinimum(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
此方法不应由用户代码调用。
setMinimum(int) - 接口 javax.swing.BoundedRangeModel 中的方法
将模型的 minimum 设置为 newMinimum。
setMinimum(int) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
在确保 n 以及其他三个属性满足以下模型约束条件之后，将 minimum 设置为 n：
setMinimum(int) - 类 javax.swing.JProgressBar 中的方法
将进度条的最小值（存储在进度条的数据模型中）设置为 n。
setMinimum(int) - 类 javax.swing.JScrollBar 中的方法
设置模型的 minimum 属性。
setMinimum(int) - 类 javax.swing.JSlider 中的方法
将滑块的最小值设置为 minimum。
setMinimum(int) - 类 javax.swing.ProgressMonitor 中的方法
指定最小值。
setMinimum(Comparable) - 类 javax.swing.SpinnerNumberModel 中的方法
更改此序列中数字的下边界。
setMinimum(Comparable) - 类 javax.swing.text.InternationalFormatter 中的方法
设置最小允许值。
setMinimumFractionDigits(int) - 类 java.text.DecimalFormat 中的方法
设置某个数的小数部分中所允许的最小数字位数。
setMinimumFractionDigits(int) - 类 java.text.NumberFormat 中的方法
设置数的小数部分所允许的最小位数。
setMinimumIntegerDigits(int) - 类 java.text.DecimalFormat 中的方法
设置某个数字的整数部分中所允许的最小数字位数。
setMinimumIntegerDigits(int) - 类 java.text.NumberFormat 中的方法
设置数的整数部分所允许的最小位数。
setMinimumSize(Dimension) - 类 java.awt.Component 中的方法
将组件的最小大小设置为常量值。
setMinimumSize(Dimension) - 类 java.awt.Window 中的方法
将此窗口的最小大小设置为一个常量值。
setMinimumSize(Dimension) - 类 javax.swing.JComponent 中的方法
将此组件的最小大小设置为一个常量值。
setMinor(int, String) - 异常 org.ietf.jgss.GSSException 中的方法
由异常抛出器使用，以设置机制级的次要错误代码及其字符串解释。
setMinorTickSpacing(int) - 类 javax.swing.JSlider 中的方法
此方法设置次刻度标记的间隔。
setMinPage(int) - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，用户可以指定为要打印的第一页的最小值。
setMinusSign(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于表示减号的字符。
setMinute(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置分。
setMinutes(int) - 类 java.sql.Date 中的方法
已过时。
setMinutes(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MINUTE, int minutes) 取代。
setMinWidth(int) - 类 javax.swing.table.TableColumn 中的方法
将 TableColumn 的最小宽度设置为 minWidth，如有必要，调整新的最小宽度以确保 0 <= minWidth <= maxWidth。
setMnemonic(int) - 类 javax.swing.AbstractButton 中的方法
设置当前模型上的键盘助记符。
setMnemonic(char) - 类 javax.swing.AbstractButton 中的方法
此方法现在已废弃，请使用 setMnemonic(int) 来设置按钮的助记符。
setMnemonic(int) - 接口 javax.swing.ButtonModel 中的方法
设置该按钮的键盘助记符（快捷键或加速键）。
setMnemonic(int) - 类 javax.swing.DefaultButtonModel 中的方法
设置该按钮的键盘助记符（快捷键或加速键）。
setMnemonicAt(int, int) - 类 javax.swing.JTabbedPane 中的方法
设置用于访问指定选项卡的键盘助记符。
setModal(boolean) - 类 java.awt.Dialog 中的方法
指定此 dialog 是否应该是有模式的。
setModalExclusionType(Dialog.ModalExclusionType) - 类 java.awt.Window 中的方法
指定此窗口的模式排斥类型。
setModalityType(Dialog.ModalityType) - 类 java.awt.Dialog 中的方法
设置此 dialog 的模式类型。
setMode(int) - 类 java.awt.FileDialog 中的方法
设置文件对话框的模式。
setModel(ButtonModel) - 类 javax.swing.AbstractButton 中的方法
设置此按钮表示的模型。
setModel(ComboBoxModel) - 类 javax.swing.JComboBox 中的方法
设置 JComboBox 用于获取项列表的数据模型。
setModel(ListModel) - 类 javax.swing.JList 中的方法
设置表示列表内容或列表“值”的模型，通知属性更改侦听器，然后清除列表选择。
setModel(ButtonModel) - 类 javax.swing.JMenu 中的方法
设置“菜单按钮”的数据模型，即用户单击可以打开或关闭菜单的标签。
setModel(ButtonModel) - 类 javax.swing.JMenuItem 中的方法
设置此按钮表示的模型。
setModel(BoundedRangeModel) - 类 javax.swing.JProgressBar 中的方法
设置 JProgressBar 使用的数据模型。
setModel(BoundedRangeModel) - 类 javax.swing.JScrollBar 中的方法
设置处理滚动条的以下四个基本属性的模型：minimum、maximum、value 和 extent。
setModel(BoundedRangeModel) - 类 javax.swing.JSlider 中的方法
设置处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
setModel(SpinnerModel) - 类 javax.swing.JSpinner 中的方法
更改表示此 spinner 值的模型。
setModel(SingleSelectionModel) - 类 javax.swing.JTabbedPane 中的方法
设置要用于此选项卡窗格的模型。
setModel(TableModel) - 类 javax.swing.JTable 中的方法
将此表的数据模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
setModel(TreeModel) - 类 javax.swing.JTree 中的方法
设置将提供数据的 TreeModel。
setModel(TreeModel) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
设置 TreeModel。
setModel(M) - 类 javax.swing.table.TableRowSorter 中的方法
将 TableModel 设置为此 TableRowSorter 要使用的底层模型。
setModel(TreeModel) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
设置将提供数据的 TreeModel。
setModel(TreeModel) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
设置将提供数据的 TreeModel。
setModel(TreeModel) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
设置将提供数据的 TreeModel。
setModelIndex(int) - 类 javax.swing.table.TableColumn 中的方法
设置此列的模型索引。
setModelMBeanInfo(ModelMBeanInfo) - 接口 javax.management.modelmbean.ModelMBean 中的方法
使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
setModelMBeanInfo(ModelMBeanInfo) - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
setModelWrapper(DefaultRowSorter.ModelWrapper<M, I>) - 类 javax.swing.DefaultRowSorter 中的方法
设置模型包装器，它提供将要进行排序和过滤的数据。
setModifiers(int) - 类 java.awt.event.KeyEvent 中的方法
已过时。 从 JDK1.1.4 开始
setModulus(Number) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察到的 MBeans 共同的模值。
setModulus(Number) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置模值。
setMonetaryDecimalSeparator(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置货币小数点分隔符。
setMono(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
打开或关闭 mono 模式。
setMonth(int) - 类 java.sql.Time 中的方法
已过时。
setMonth(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MONTH, int month) 取代。
setMonth(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置月。
setMonths(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置月份字符串。
setMouseOver(boolean) - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的方法
设置鼠标当前是否位于分隔符上。
setMTOMEnabled(boolean) - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
启用或禁用 MTOM。
setMultiClickThreshhold(long) - 类 javax.swing.AbstractButton 中的方法
设置对按钮按下鼠标到生成相应动作事件所需的时间量（以毫秒为单位）。
setMultipleDocumentHandling(JobAttributes.MultipleDocumentHandlingType) - 类 java.awt.JobAttributes 中的方法
为使用这些属性的作业指定多份处理，包括整理。
setMultipleDocumentHandlingToDefault() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，将多份处理（包括整理）设置为默认值。
setMultipleMode(boolean) - 类 java.awt.List 中的方法
设置确定此列表是否允许进行多项选择的标志。
setMultipleSelections(boolean) - 类 java.awt.List 中的方法
已过时。 从 JDK version 1.1 开始，由 setMultipleMode(boolean) 取代。
setMultiplier(int) - 类 java.text.DecimalFormat 中的方法
设置百分数、千分数和类似格式中使用的乘数。
setMultiSelectionEnabled(boolean) - 类 javax.swing.JFileChooser 中的方法
设置文件选择器，以允许选择多个文件。
setMustUnderstand(boolean) - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
将此 SOAPHeaderElement 对象的 mustUnderstand 属性设置为 true 或 false。
setMute(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
设置此通道的静音状态。
setName(String) - 类 java.awt.Component 中的方法
将组件的名称设置为指定的字符串。
setName(String) - 类 java.awt.MenuComponent 中的方法
将该组件的名称设置为指定字符串。
setName(String) - 类 java.beans.FeatureDescriptor 中的方法
设置此特性的编程名称。
setName(String) - 类 java.lang.Thread 中的方法
改变线程名称，使之与参数 name 相同。
setName(Principal, String) - 接口 java.security.acl.Acl 中的方法
设置此 ACL 的名称。
setName(String) - 类 javax.naming.NameClassPair 中的方法
设置此绑定的名称。
setName(String) - 类 javax.security.auth.callback.NameCallback 中的方法
设置检索到的名称。
setName(String) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
更改样式的名称。
setNameConstraints(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 NameConstraints 标准。
setNamedItem(Node) - 接口 org.w3c.dom.NamedNodeMap 中的方法
使用 nodeName 属性添加节点。
setNamedItemNS(Node) - 接口 org.w3c.dom.NamedNodeMap 中的方法
使用其 namespaceURI 和 localName 添加节点。
setNameInNamespace(String) - 类 javax.naming.NameClassPair 中的方法
设置此绑定的完全名称。
setNamespaceAware(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将提供对 XML 名称空间的支持。
setNamespaceAware(boolean) - 类 javax.xml.parsers.SAXParserFactory 中的方法
指定由此代码生成的解析器将提供对 XML 名称空间的支持。
setNamespaceContext(NamespaceContext) - 接口 javax.xml.stream.XMLEventWriter 中的方法
设置前缀的当前名称空间上下文和 URI 绑定。
setNamespaceContext(NamespaceContext) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
设置前缀和 URI 绑定的当前名称空间上下文。
setNamespaceContext(NamespaceContext) - 接口 javax.xml.xpath.XPath 中的方法
建立名称空间上下文。
setNamespaceDeclUris(boolean) - 类 org.xml.sax.helpers.NamespaceSupport 中的方法
控制是否通过 processName() 将名称空间声明属性放置到 NSDECL 名称空间中。
setNaN(String) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于表示“非数字”的字符串。
setNanos(int) - 类 java.sql.Timestamp 中的方法
将此 Timestamp 对象的 nanos 字段设置为给定值。
setNativeMethodPrefix(ClassFileTransformer, String) - 接口 java.lang.instrument.Instrumentation 中的方法
通过允许重试，将前缀应用到名称，此方法修改本机方法解析的失败处理。
setNativesForFlavor(DataFlavor, String[]) - 类 java.awt.datatransfer.SystemFlavorMap 中的方法
放弃指定 DataFlavor 和等于指定 DataFlavor 的所有 DataFlavor 的当前映射，并创建到指定 String native 的新映射。
setNavigationFilter(NavigationFilter) - 类 javax.swing.text.JTextComponent 中的方法
设置 NavigationFilter。
setNCharacterStream(String, Reader, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
setNCharacterStream(int, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNCharacterStream(String, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, NClob) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(String, Reader, long) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, Reader) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, NClob) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(int, Reader, long) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, Reader) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, NClob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(String, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, Reader, long) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, NClob) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(int, Reader) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, NClob) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(String, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(String, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, Reader, long) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNClob(int, NClob) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 java.sql.NClob 对象。
setNClob(int, Reader) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 Reader 对象。
setNeedClientAuth(boolean) - 类 javax.net.ssl.SSLEngine 中的方法
配置引擎要求 客户端进行验证。
setNeedClientAuth(boolean) - 类 javax.net.ssl.SSLParameters 中的方法
设置是否应该要求客户机验证。
setNeedClientAuth(boolean) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制接受的服务器模式 SSLSocket 是否将在开始时配置为要求 客户端验证。
setNeedClientAuth(boolean) - 类 javax.net.ssl.SSLSocket 中的方法
配置套接字要求 客户机验证。
setNegativePermissions() - 接口 java.security.acl.AclEntry 中的方法
将此 ACL 项设置为 negative 项。
setNegativePrefix(String) - 类 java.text.DecimalFormat 中的方法
设置负数前缀。
setNegativeSuffix(String) - 类 java.text.DecimalFormat 中的方法
设置负数后缀。
setNetworkInterface(NetworkInterface) - 类 java.net.MulticastSocket 中的方法
指定在此套接字上发送的输出多播数据报的网络接口。
setNewLine(String) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
在所写出的 XML 中使用的字符的行尾序列。
setNextException(SQLException) - 异常 java.sql.SQLException 中的方法
将 SQLException 对象添加到链接的末尾。
setNextFocusableComponent(Component) - 类 javax.swing.JComponent 中的方法
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代
setNextSibling(Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 中的方法
设置下一个兄弟节点。
setNextSibling(Node) - 类 javax.xml.transform.dom.DOMResult 中的方法
设置将要插入的结果节点之后的子节点。
setNextWarning(SQLWarning) - 异常 java.sql.SQLWarning 中的方法
将 SQLWarning 对象添加到链接的末尾。
setNextWarning(RowSetWarning) - 异常 javax.sql.rowset.RowSetWarning 中的方法
将 warning 设置为下一个警告，即连接到此 RowSetWarning 对象的警告。
setNil(boolean) - 类 javax.xml.bind.JAXBElement 中的方法
设置此属性是否包含 nil 内容。
setNode(Node) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 Node 字段。
setNode(Node) - 类 javax.xml.crypto.dsig.dom.DOMValidateContext 中的方法
设置节点。
setNode(Node) - 类 javax.xml.transform.dom.DOMResult 中的方法
设置将包含结果 DOM 树的节点。
setNode(Node) - 类 javax.xml.transform.dom.DOMSource 中的方法
设置将表示 Source DOM 树的节点。
setNodeDimensions(AbstractLayoutCache.NodeDimensions) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
设置负责绘制树中节点的 renderer，因此，它还负责计算各个节点的尺寸。
setNodeDimensions(AbstractLayoutCache.NodeDimensions) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
设置负责绘制树中节点的渲染器。
setNodeValue(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setNodeValue(String) - 接口 org.w3c.dom.Node 中的方法
此节点的值，取决于其类型；参见上表。
setNonContinuousLayoutDivider(Component) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
设置要在将 splitPane 配置为非连续布局时使用的分隔符。
setNonContinuousLayoutDivider(Component, boolean) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
设置要使用的分隔符。
setNoNSSchemaLocation(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置 noNamespaceSchemaLocation 的便捷方法。
setNormalBounds(Rectangle) - 类 javax.swing.JInternalFrame 中的方法
设置此内部窗体的正常边界，即此内部窗体从其最大化状态还原后的边界。
setNorthPane(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setNote(String) - 类 javax.swing.ProgressMonitor 中的方法
指定与进度消息一起显示的其他注释。
setNotify(boolean) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察到的 MBeans 共同的通知的开/关切换值。
setNotify(boolean) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置通知的开/关切换值。
setNotifyDiffer(boolean) - 类 javax.management.monitor.StringMonitor 中的方法
设置所有观察到的 MBeans 共同的不同通知的开/关切换值。
setNotifyDiffer(boolean) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
设置不同通知的开/关切换值。
setNotifyHigh(boolean) - 类 javax.management.monitor.GaugeMonitor 中的方法
设置所有观察到的 MBean 的公共高阈值通知的开/关切换值。
setNotifyHigh(boolean) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
设置高阈值通知的开/关切换值。
setNotifyLow(boolean) - 类 javax.management.monitor.GaugeMonitor 中的方法
设置所有观察到的 MBean 的公共低阈值通知的开/关切换值。
setNotifyLow(boolean) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
设置低阈值通知的开/关切换值。
setNotifyMatch(boolean) - 类 javax.management.monitor.StringMonitor 中的方法
设置所有观察到的 MBeans 共同的匹配通知的开/关切换值。
setNotifyMatch(boolean) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
设置匹配的通知的开/关切换值。
setNString(String, String) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 String 对象。
setNString(int, String) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 String 对象。
setNString(int, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 String 对象。
setNString(String, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 String 对象。
setNString(int, String) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 String 对象。
setNString(String, String) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 String 对象。
setNull(String, int) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 SQL NULL。
setNull(String, int, String) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int, String) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(String, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(String, int, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
setNull(String, int) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 SQL NULL。
setNull(int, int, String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
setNull(String, int, String) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为 SQL NULL。
setNullable(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为 ResultSetMetaData 接口中的给定常量，以指示是否可以将存储在该列中的值设置为 NULL。
setNullable(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
设置是否可以将指定列的值设置为 NULL。
setNullFormatter(JFormattedTextField.AbstractFormatter) - 类 javax.swing.text.DefaultFormatterFactory 中的方法
设置在 JFormattedTextField 值为 null 时使用的 formatter。
setNumberFormat(NumberFormat) - 类 java.text.DateFormat 中的方法
允许用户设置数字格式器。
setNumRows(int) - 类 javax.swing.table.DefaultTableModel 中的方法
从 Java 2 platform v1.3 开始已过时。
setObject(Object) - 接口 java.beans.Customizer 中的方法
设置将要自定义的对象。
setObject(String, Object, int, int) - 接口 java.sql.CallableStatement 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object, int) - 接口 java.sql.CallableStatement 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object) - 接口 java.sql.CallableStatement 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object, int) - 接口 java.sql.PreparedStatement 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object) - 接口 java.sql.PreparedStatement 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object, int, int) - 接口 java.sql.PreparedStatement 中的方法
使用给定对象设置指定参数的值。
setObject(Object) - 接口 java.sql.Ref 中的方法
将此 Ref 对象引用的结构类型值设置为给定的 Object 实例。
setObject(Object) - 类 javax.naming.Binding 中的方法
设置与此绑定关联的对象。
setObject(int, Object, int, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的 Object。
setObject(int, Object, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定 Object 值设置指定参数的值。
setObject(int, Object) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的 Object。
setObject(String, Object, int, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定对象设置指定参数的值。
setObject(Object) - 类 javax.sql.rowset.serial.SerialRef 中的方法
将此 SerialRef 对象引用的 SQL 结构类型设置为给定的 Object 对象。
setObject(int, Object, int, int) - 接口 javax.sql.RowSet 中的方法
使用给定 Java Object 设置此 RowSet 对象命令中的指定参数。
setObject(String, Object, int, int) - 接口 javax.sql.RowSet 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object, int) - 接口 javax.sql.RowSet 中的方法
使用 Java Object 设置此 RowSet 对象命令中的指定参数。
setObject(String, Object, int) - 接口 javax.sql.RowSet 中的方法
使用给定对象设置指定参数的值。
setObject(String, Object) - 接口 javax.sql.RowSet 中的方法
使用给定对象设置指定参数的值。
setObject(int, Object) - 接口 javax.sql.RowSet 中的方法
使用 Java Object 设置此 RowSet 对象命令中的指定参数。
setObject(Object) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 Object 字段。
setObjectFactoryBuilder(ObjectFactoryBuilder) - 类 javax.naming.spi.NamingManager 中的静态方法
ObjectFactoryBuilder 确定尝试加载对象工厂时使用的策略。
setObservedAttribute(String) - 类 javax.management.monitor.Monitor 中的方法
设置要观察的属性。
setObservedAttribute(String) - 接口 javax.management.monitor.MonitorMBean 中的方法
设置要观察的属性。
setObservedObject(ObjectName) - 类 javax.management.monitor.Monitor 中的方法
已过时。 从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
setObservedObject(ObjectName) - 接口 javax.management.monitor.MonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 MonitorMBean.addObservedObject(javax.management.ObjectName) 取代
setOffset(int) - 类 java.io.ObjectStreamField 中的方法
实例数据中的偏移量。
setOffset(int) - 类 java.text.CollationElementIterator 中的方法
将迭代器设置为指向对应于指定字符的 collation 元素（参数是源字符串中的一个 CHARACTER 偏移量，而不是其对应 collation 元素序列的偏移量）。
setOffset(int) - 类 javax.imageio.stream.IIOByteBuffer 中的方法
更新对 getOffset 方法的后续调用将返回的值。
setOffset(Number) - 类 javax.management.monitor.CounterMonitor 中的方法
设置所有观察到的 MBeans 共同的偏移量值。
setOffset(Number) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
设置偏移量值。
setOffset(Point) - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
setOffset(int) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 offset 字段。
SetOfIntegerSyntax - javax.print.attribute 中的 类
类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。
SetOfIntegerSyntax(String) - 类 javax.print.attribute.SetOfIntegerSyntax 的构造方法
使用以字符串形式给定的成员构造一个新的整数集属性。
SetOfIntegerSyntax(int[][]) - 类 javax.print.attribute.SetOfIntegerSyntax 的构造方法
使用以字符串形式给定的成员构造一个新的整数集属性。
SetOfIntegerSyntax(int) - 类 javax.print.attribute.SetOfIntegerSyntax 的构造方法
构造一个包含单个整数的新整数集属性。
SetOfIntegerSyntax(int, int) - 类 javax.print.attribute.SetOfIntegerSyntax 的构造方法
构造一个包含单一整数范围的新整数集属性。
setOmni(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
打开或关闭 omni 模式。
setOneTouchExpandable(boolean) - 类 javax.swing.JSplitPane 中的方法
设置 oneTouchExpandable 属性的值，要使 JSplitPane 在分隔条上提供一个 UI 小部件来快速展开/折叠分隔条，此属性必须为 true。
setOOBInline(boolean) - 类 java.net.Socket 中的方法
启用/禁用 OOBINLINE（TCP 紧急数据的接收者） 默认情况下，此选项是禁用的，即在套接字上接收的 TCP 紧急数据被静默丢弃。
setOpaque(boolean) - 类 javax.swing.JComponent 中的方法
如果为 true，则该组件绘制其边界内的所有像素。
setOpenIcon(Icon) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置用于表示扩展的非叶节点的图标。
setOptimizeHuffmanTables(boolean) - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
告知 writer 是否作为写入过程的一部分为图像生成最佳 Huffman 表。
setOption(int, Object) - 接口 java.net.SocketOptions 中的方法
启用/禁用 optID 指定的选项。
setOptions(Object[]) - 类 javax.swing.JOptionPane 中的方法
设置此窗格显示的选项。
setOptionType(int) - 类 javax.swing.JOptionPane 中的方法
设置要显示的选项。
setOrdering(Class<T>, T, T) - 类 javax.imageio.spi.ServiceRegistry 中的方法
为给定类别中的两个服务提供者对象设置配对排序。
setOrientation(int) - 类 java.awt.print.PageFormat 中的方法
设置页面方向。
setOrientation(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的方向。
setOrientation(int) - 类 javax.swing.JProgressBar 中的方法
将进度条的方向设置为 newOrientation（必须为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL）。
setOrientation(int) - 类 javax.swing.JScrollBar 中的方法
将滚动条的方向设置为 VERTICAL 或 HORIZONTAL。
setOrientation(int) - 类 javax.swing.JSeparator 中的方法
设置此分隔符的方向。
setOrientation(int) - 类 javax.swing.JSlider 中的方法
将滑块的方向设置为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
setOrientation(int) - 类 javax.swing.JSplitPane 中的方法
设置方向，或者分隔窗格的方式。
setOrientation(int) - 类 javax.swing.JToolBar 中的方法
设置工具栏的方向。
setOrientation(int) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
设置 JSplitPane 的方向。
setOrientation(int) - 类 javax.swing.plaf.basic.BasicToolBarUI.DragWindow 中的方法
setOrientation(int) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
setOrientationRequested(PageAttributes.OrientationRequestedType) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面的打印方向。
setOrientationRequested(int) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面的打印方向。
setOrientationRequestedToDefault() - 类 java.awt.PageAttributes 中的方法
将使用这些属性的页面的打印方向设置为默认值。
setOrigin(PageAttributes.OriginType) - 类 java.awt.PageAttributes 中的方法
指定在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。
setOriginalRow() - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象中的当前行设置为原始行。
setOut(PrintStream) - 类 java.lang.System 中的静态方法
重新分配“标准”输出流。
setOuterHTML(Element, String) - 类 javax.swing.text.html.HTMLDocument 中的方法
用指定为 HTML 字符串的内容替换父元素中的给定元素。
setOutput(Object) - 类 javax.imageio.ImageWriter 中的方法
将目标设置为给定 ImageOutputStream 或其他 Object。
setOutputProperties(Properties) - 类 javax.xml.transform.Transformer 中的方法
设置转换的输出属性。
setOutputProperty(String, String) - 类 javax.xml.transform.Transformer 中的方法
设置转换中实际的输出属性。
setOutputStream(OutputStream) - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
setOutputStream(OutputStream) - 类 java.util.logging.StreamHandler 中的方法
更改输出流。
setOutputStream(OutputStream) - 类 javax.xml.transform.stream.StreamResult 中的方法
设置要写入的 ByteStream。
SetOverrideType - org.omg.CORBA 中的 类
标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
SetOverrideType(int) - 类 org.omg.CORBA.SetOverrideType 的构造方法
根据 int 值构造一个 SetOverrideType 实例。
SetOverrideTypeHelper - org.omg.CORBA 中的 类
SetOverrideType 的 Helper。
SetOverrideTypeHelper() - 类 org.omg.CORBA.SetOverrideTypeHelper 的构造方法
setOverwriteMode(boolean) - 类 javax.swing.text.DefaultFormatter 中的方法
配置插入字符时的行为。
setOwner(Object) - 类 java.beans.XMLDecoder 中的方法
将此解码器的所有者设置为 owner。
setOwner(Object) - 类 java.beans.XMLEncoder 中的方法
将此编码器的所有者设置为 owner。
setPackageAssertionStatus(String, boolean) - 类 java.lang.ClassLoader 中的方法
为指定包设置默认断言状态。
setPadding(int) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
setPage(int, Printable, PageFormat) - 类 java.awt.print.Book 中的方法
为指定的页码设置 PageFormat 和 Painter。
setPage(URL) - 类 javax.swing.JEditorPane 中的方法
设置当前要显示的 URL。
setPage(String) - 类 javax.swing.JEditorPane 中的方法
设置当前要显示的 URL。
setPageable(Pageable) - 类 java.awt.print.PrinterJob 中的方法
查询 document，以获得页面数和 Pageable 实例 document 中保存的每个页面的 PageFormat 和 Printable。
setPageIncrement(int) - 类 java.awt.Scrollbar 中的方法
已过时。 从 JDK version 1.1 开始，由 setBlockIncrement() 取代。
setPageRanges(int[][]) - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的页面范围。
setPageSize(int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
设置 CachedRowSet 对象的页大小。
setPaint(Paint) - 类 java.awt.Graphics2D 中的方法
为 Graphics2D 上下文设置 Paint 属性。
setPaintLabels(boolean) - 类 javax.swing.JSlider 中的方法
确定是否在滑块上绘制标签。
setPaintMode() - 类 java.awt.Graphics 中的方法
设置将此图形上下文的绘图模式，以便通过此图形上下文中的当前颜色来覆盖目标。
setPaintMode() - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.setPaintMode。
setPaintTicks(boolean) - 类 javax.swing.JSlider 中的方法
确定是否在滑块上绘制刻度标记。
setPaintTrack(boolean) - 类 javax.swing.JSlider 中的方法
确定是否在滑块上绘制滑道。
setPalette(boolean) - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
setPalette(boolean) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
setPaper(Paper) - 类 java.awt.print.PageFormat 中的方法
为此 PageFormat 设置 Paper 对象。
setParagraphAttributes(AttributeSet, boolean) - 类 javax.swing.JTextPane 中的方法
将给定属性应用于段落。
setParagraphAttributes(int, int, AttributeSet, boolean) - 类 javax.swing.text.DefaultStyledDocument 中的方法
设置段落属性。
setParagraphAttributes(int, int, AttributeSet, boolean) - 类 javax.swing.text.html.HTMLDocument 中的方法
设置段落属性。
setParagraphAttributes(int, int, AttributeSet, boolean) - 接口 javax.swing.text.StyledDocument 中的方法
设置段落属性。
setParagraphAttributes(JEditorPane, AttributeSet, boolean) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 中的方法
对段落应用给定的属性。
setParagraphInsets(AttributeSet) - 类 javax.swing.text.CompositeView 中的方法
按照给定属性中指定的段落属性设置 insets。
setParameter(String, Object) - 类 java.security.Signature 中的方法
已过时。 使用 setParameter 取代。
setParameter(AlgorithmParameterSpec) - 类 java.security.Signature 中的方法
使用指定的参数集初始化此签名引擎。
setParameter(String, String) - 类 javax.activation.MimeType 中的方法
将值设置为与给定的名称关联，替换以前的任何关联。
setParameter(String, Object) - 类 javax.xml.transform.Transformer 中的方法
添加一个转换参数。
setParameter(String, Object) - 接口 org.w3c.dom.DOMConfiguration 中的方法
设置参数的值。
setParameterBlock(ParameterBlock) - 类 java.awt.image.renderable.RenderableImageOp 中的方法
更改操作的当前 ParameterBlock，允许编辑图像呈现链。
setParameters(Vector<Object>) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将参数的整个 Vector 设置为给定 Vector。
setParameters(Object[]) - 类 java.util.logging.LogRecord 中的方法
设置日志消息的参数。
setParent(Logger) - 类 java.util.logging.Logger 中的方法
设置此 Logger 的父 Logger。
setParent(ResourceBundle) - 类 java.util.ResourceBundle 中的方法
设置此包的父包。
setParent(ActionMap) - 类 javax.swing.ActionMap 中的方法
设置此 ActionMap 的父级。
setParent(InputMap) - 类 javax.swing.ComponentInputMap 中的方法
设置父组件，该组件必须是一个和与此 ComponentInputMap 相同的组件相关联的 ComponentInputMap。
setParent(InputMap) - 类 javax.swing.InputMap 中的方法
设置此 InputMap 的父级。
setParent(View) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图的父级。
setParent(View) - 类 javax.swing.text.ComponentView 中的方法
为子视图设置父级。
setParent(View) - 类 javax.swing.text.CompositeView 中的方法
设置此视图的父级。
setParent(View) - 类 javax.swing.text.FlowView 中的方法
设置此视图的父级。
setParent(View) - 类 javax.swing.text.html.BlockView 中的方法
建立此视图的父视图。
setParent(View) - 类 javax.swing.text.html.ImageView 中的方法
建立此视图的父视图。
setParent(View) - 类 javax.swing.text.html.ParagraphView 中的方法
建立此视图的父视图。
setParent(View) - 类 javax.swing.text.View 中的方法
为此视图建立父视图。
setParent(MutableTreeNode) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
将此节点的父节点设置为 newParent，但不更改父节点的子节点数组。
setParent(MutableTreeNode) - 接口 javax.swing.tree.MutableTreeNode 中的方法
将接收者的父对象设置为 newParent。
setParent(Node) - 类 javax.xml.crypto.dsig.dom.DOMSignContext 中的方法
设置父节点。
setParent(XMLEventReader) - 类 javax.xml.stream.util.EventReaderDelegate 中的方法
设置此实例的父实例。
setParent(XMLStreamReader) - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
设置此实例的父实例。
setParent(XMLReader) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置父读取器。
setParent(XMLReader) - 接口 org.xml.sax.XMLFilter 中的方法
设置父阅读器。
setParentElement(SOAPElement) - 接口 javax.xml.soap.Node 中的方法
将此 Node 对象的父节点设置为给定的 SOAPElement 对象。
setParseBigDecimal(boolean) - 类 java.text.DecimalFormat 中的方法
设置 DecimalFormat.parse(java.lang.String, java.text.ParsePosition) 方法是否返回 BigDecimal。
setParseIntegerOnly(boolean) - 类 java.text.NumberFormat 中的方法
设置数是否应该仅作为整数进行解析。
setParser(HTMLEditorKit.Parser) - 类 javax.swing.text.html.HTMLDocument 中的方法
设置将 html 插入现有文档的方法所使用的解析器，例如 setInnerHTML 和 setOuterHTML。
setPartialReturn(boolean) - 类 javax.swing.text.Segment 中的方法
指示部分返回有效的标记。
setPassword(char[]) - 类 javax.security.auth.callback.PasswordCallback 中的方法
设置获取到的密码。
setPassword(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将用于创建此 RowSet 对象的数据库连接的密码设置为给定的 String 对象。
setPassword(String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的数据库密码设置为给定的 String。
setPath(String) - 类 java.net.HttpCookie 中的方法
指定客户机应该返回 cookie 的路径。
setPathToNames(Collection<List<?>>) - 类 java.security.cert.X509CertSelector 中的方法
设置 pathToNames 标准。
setPatternSeparator(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于在模式中分隔正数和负数子模式的字符。
setPayload(Source) - 接口 javax.xml.ws.LogicalMessage 中的方法
设置消息负载
setPayload(Object, JAXBContext) - 接口 javax.xml.ws.LogicalMessage 中的方法
设置消息负载
setPercent(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于百分数符号的字符。
setPerformancePreferences(int, int, int) - 类 java.net.ServerSocket 中的方法
设置此 ServerSocket 的性能首选项。
setPerformancePreferences(int, int, int) - 类 java.net.Socket 中的方法
设置此套接字的性能偏好。
setPerformancePreferences(int, int, int) - 类 java.net.SocketImpl 中的方法
设置此套接字的性能偏好 (performance preferences)。
setPerMill(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于千分数符号的字符。
setPersistenceDelegate(Class<?>, PersistenceDelegate) - 类 java.beans.Encoder 中的方法
将与此 type 相关联的持久委托设置为 persistenceDelegate。
setPitchBend(int) - 接口 javax.sound.midi.MidiChannel 中的方法
更改此通道上所有音符的音高偏移量。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
使用输入样本的 int 数组设置 DataBuffer 中的像素。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
使用输入样本的 int 数组设置 DataBuffer 中的像素。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
使用输入的 int 数组设置 DataBuffer 中的某个像素。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 int 样本数组设置 DataBuffer 中的像素。
setPixel(int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 float 样本数组设置 DataBuffer 中的像素。
setPixel(int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 double 样本数组设置 DataBuffer 中的像素。
setPixel(int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
使用输入样本的 int 数组设置 DataBuffer 中的像素。
setPixel(int, int, int[]) - 类 java.awt.image.WritableRaster 中的方法
使用输入样本的 int 型数组设置 DataBuffer 中的像素。
setPixel(int, int, float[]) - 类 java.awt.image.WritableRaster 中的方法
使用输入样本的 float 型数组设置 DataBuffer 中的像素。
setPixel(int, int, double[]) - 类 java.awt.image.WritableRaster 中的方法
使用输入样本的 double 型数组设置 DataBuffer 中的像素。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.AreaAveragingScaleFilter 中的方法
将已传送 byte 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.AreaAveragingScaleFilter 中的方法
将已传送 int 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
setPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
根据 int 数组设置对应于像素矩形的所有样本，int 数组中每个数组元素包含一个样本。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口（采用字节数组）的 setPixels 方法中提供的信息。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.BufferedImageFilter 中的方法
过滤 ImageConsumer 接口（采用整数数组）的 setPixels 方法中提供的信息。
setPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
根据 int 数组（每个数组元素包含一个样本）设置对应于像素矩形区域的所有样本。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.CropImageFilter 中的方法
确定已传递的字节像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.CropImageFilter 中的方法
确定已传递的 int 像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 接口 java.awt.image.ImageConsumer 中的方法
一次或多次调用此方法来传递图像的像素。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 接口 java.awt.image.ImageConsumer 中的方法
一次或多次调用 setPixels 方法来传递图像的像素。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.ImageFilter 中的方法
过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以 byte 数组为参数。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.ImageFilter 中的方法
过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以整数数组为参数。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.PixelGrabber 中的方法
setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.PixelGrabber 中的方法
setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.ReplicateScaleFilter 中的方法
从传递的 byte pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.ReplicateScaleFilter 中的方法
从传递的 int pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
setPixels(int, int, int, int, ColorModel, byte[], int, int) - 类 java.awt.image.RGBImageFilter 中的方法
如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素。
setPixels(int, int, int, int, ColorModel, int[], int, int) - 类 java.awt.image.RGBImageFilter 中的方法
如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素，否则，将整数像素的缓冲区转换为默认 RGB ColorModel，并将转换后的缓冲区传递给 filterRGBPixels 方法进行逐一转换。
setPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
setPixels(int, int, int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 float 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
setPixels(int, int, int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 double 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
setPixels(int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
setPixels(int, int, int, int, int[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 int 型数组中的像素矩形设置所有样本。
setPixels(int, int, int, int, float[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 float 型数组中的像素矩形设置所有样本。
setPixels(int, int, int, int, double[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 double 型数组中的像素矩形设置所有样本。
setPlaceholder(String) - 类 javax.swing.text.MaskFormatter 中的方法
设置值未完全填充掩码时要使用的字符串。
setPlaceholderCharacter(char) - 类 javax.swing.text.MaskFormatter 中的方法
设置一个字符，用来替代值中不存在的字符（即用户必须填充它们）。
setPolicy(Set<String>) - 类 java.security.cert.X509CertSelector 中的方法
设置策略限制。
setPolicy(Policy) - 类 java.security.Policy 中的静态方法
设置系统范围的 Policy 对象。
setPolicy(Policy) - 类 javax.security.auth.Policy 中的静态方法
已过时。 设置系统级 Policy 对象。
setPolicyMappingInhibited(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置 PolicyMappingInhibited 标志。
setPolicyQualifiersRejected(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置 PolicyQualifiersRejected 标志。
setPolyPressure(int, int) - 接口 javax.sound.midi.MidiChannel 中的方法
对指定音符键力度的更改作出反应。
setPoolable(boolean) - 接口 java.sql.Statement 中的方法
请求将 Statement 池化或非池化。
setPopupMenu(PopupMenu) - 类 java.awt.TrayIcon 中的方法
设置此 TrayIcon 的弹出菜单。
setPopupMenuVisible(boolean) - 类 javax.swing.JMenu 中的方法
设置菜单弹出的可见性。
setPopupSize(Dimension) - 类 javax.swing.JPopupMenu 中的方法
使用 Dimension 对象设置弹出窗口的大小。
setPopupSize(int, int) - 类 javax.swing.JPopupMenu 中的方法
将弹出窗口的大小设置为指定的宽度和高度。
setPopupVisible(boolean) - 类 javax.swing.JComboBox 中的方法
设置弹出窗口的可见性。
setPopupVisible(JComboBox, boolean) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
隐藏弹出部分。
setPopupVisible(JComboBox, boolean) - 类 javax.swing.plaf.ComboBoxUI 中的方法
设置弹出菜单的可见性
setPopupVisible(JComboBox, boolean) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 setPopupVisible 方法。
setPort(int) - 类 java.net.DatagramPacket 中的方法
设置要将此数据报发往的远程主机上的端口号。
setPortlist(String) - 类 java.net.HttpCookie 中的方法
指定 cookie 的端口列表，该列表在 Cookie 头中限制可能将 cookie 发送回的端口。
setPosition(int) - 类 java.awt.font.LineBreakMeasurer 中的方法
设置此 LineBreakMeasurer 的当前位置。
setPosition(Component, int) - 类 javax.swing.JLayeredPane 中的方法
将该组件移到当前层中的 position 处，其中 0 表示该层中的最顶层位置，-1 表示最底层位置。
setPositivePrefix(String) - 类 java.text.DecimalFormat 中的方法
设置正数前缀。
setPositiveSuffix(String) - 类 java.text.DecimalFormat 中的方法
设置正数后缀。
setPrecision(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将存储在指定列中的值的小数位数的总数设置为给定数。
setPrecision(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的小数位数设置为给定的 int。
setPreferred(boolean) - 类 java.beans.FeatureDescriptor 中的方法
"preferred" 标志用于标识呈现给用户的特别重要的特性。
setPreferredMinSize(Dimension) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
设置首选最小大小。
setPreferredScrollableViewportSize(Dimension) - 类 javax.swing.JTable 中的方法
设置此表视口的首选大小。
setPreferredSize(Dimension) - 类 java.awt.Component 中的方法
将组件的首选大小设置为常量值。
setPreferredSize(Dimension) - 类 javax.swing.JComponent 中的方法
设置此组件的首选大小。
setPreferredWidth(int) - 类 javax.swing.table.TableColumn 中的方法
将此列的首选宽度设置为 preferredWidth。
setPrefix(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
不执行任何操作，因为不支持名称空间。
setPrefix(String, String) - 接口 javax.xml.stream.XMLEventWriter 中的方法
设置绑定 URI 的前缀。
setPrefix(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
设置绑定 URI 的前缀。
setPrefix(String) - 接口 org.w3c.dom.Node 中的方法
此节点的名称空间前缀；如果未指定，则为 null。
setPreservesUnknownTags(boolean) - 类 javax.swing.text.html.HTMLDocument 中的方法
确定解析器如何处理未知标记。
setPressed(boolean) - 接口 javax.swing.ButtonModel 中的方法
将按钮设置为按下或未被按下。
setPressed(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
将按钮设置为按下或未被按下。
setPressed(boolean) - 类 javax.swing.JToggleButton.ToggleButtonModel 中的方法
设置切换按钮按下时的状态。
setPressedIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的按下图标。
setPreviewPanel(JComponent) - 类 javax.swing.JColorChooser 中的方法
设置当前预览面板。
setPreviousBounds(JInternalFrame, Rectangle) - 类 javax.swing.DefaultDesktopManager 中的方法
在进行 maximize 调用之前存储组件的边界。
setPrimaryType(String) - 类 javax.activation.MimeType 中的方法
将此对象的基本类型设置为给定的 String。
setPrincipal(Principal) - 接口 java.security.acl.AclEntry 中的方法
指定此 ACL 项要为其授予或拒绝权限的主体。
setPrintable(Printable) - 类 java.awt.print.PrinterJob 中的方法
调用 painter 以呈现页面。
setPrintable(Printable, PageFormat) - 类 java.awt.print.PrinterJob 中的方法
调用 painter，用指定的 format 呈现该页面。
setPrinter(String) - 类 java.awt.JobAttributes 中的方法
为使用这些属性的作业指定目标打印机。
setPrinterResolution(int[]) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面所需的打印分辨率。
setPrinterResolution(int) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面所需的反向进纸和进纸的打印分辨率，分辨率以每英寸的点数为单位。
setPrinterResolutionToDefault() - 类 java.awt.PageAttributes 中的方法
将使用这些属性的页面的打印机分辨率设置为默认值。
setPrintQuality(PageAttributes.PrintQualityType) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面的打印质量。
setPrintQuality(int) - 类 java.awt.PageAttributes 中的方法
指定使用这些属性的页面的打印质量。
setPrintQualityToDefault() - 类 java.awt.PageAttributes 中的方法
将使用这些属性的页面的打印质量设置为默认值。
setPrintService(PrintService) - 类 java.awt.print.PrinterJob 中的方法
将此 PrinterJob 与新的 PrintService 关联。
setPriority(int) - 类 java.lang.Thread 中的方法
更改线程的优先级。
setPrivacy(boolean) - 类 org.ietf.jgss.MessageProp 中的方法
设置私密状态。
setPrivateKeyValid(Date) - 类 java.security.cert.X509CertSelector 中的方法
设置 privateKeyValid 标准。
setProblemType(int) - 类 javax.management.relation.RoleUnresolved 中的方法
设置问题类型。
setProcessors(Iterable<? extends Processor>) - 接口 javax.tools.JavaCompiler.CompilationTask 中的方法
设置处理器（用于注释处理）。
setProgress(int) - 类 javax.swing.ProgressMonitor 中的方法
指示正被监视操作的进度。
setProgress(int) - 类 javax.swing.SwingWorker 中的方法
设置 progress 绑定属性。
setProgressiveMode(int) - 类 javax.imageio.ImageWriteParam 中的方法
指定 writer 使用逐步模式写出图像，从而输出流将包含一系列质量递增的扫描。
setPropagatedFrom(BeanContext) - 类 java.beans.beancontext.BeanContextEvent 中的方法
设置作为此事件传播源的 BeanContext。
setPropagationId(Object) - 类 java.beans.PropertyChangeEvent 中的方法
设置事件的 propagationId 对象。
setProperties(Hashtable<?, ?>) - 类 java.awt.image.CropImageFilter 中的方法
添加指示裁剪区域的属性后传递源对象的属性。
setProperties(Hashtable<?, ?>) - 接口 java.awt.image.ImageConsumer 中的方法
设置与此图像关联的可扩展属性列表。
setProperties(Hashtable<?, ?>) - 类 java.awt.image.ImageFilter 中的方法
添加一个属性，来指示已通过的过滤器流，并在这之后从源对象传递这些属性。
setProperties(Hashtable<?, ?>) - 类 java.awt.image.PixelGrabber 中的方法
setProperties 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
setProperties(Hashtable<?, ?>) - 类 java.awt.image.ReplicateScaleFilter 中的方法
在添加一个指示所应用的缩放比例的属性后传递来自源对象的属性。
setProperties(Properties) - 类 java.lang.System 中的静态方法
将系统属性设置为 Properties 参数。
setProperties(Map<String, Object>) - 类 javax.xml.ws.Endpoint 中的方法
设置此 Endpoint 实例的属性包。
setPropertiesFromAttributes() - 类 javax.swing.text.html.BlockView 中的方法
更新来自属性的任何缓存的值。
setPropertiesFromAttributes() - 类 javax.swing.text.html.ImageView 中的方法
更新来自属性的任何缓存的值。
setPropertiesFromAttributes() - 类 javax.swing.text.html.InlineView 中的方法
从 attribute 设置缓存的属性。
setPropertiesFromAttributes() - 类 javax.swing.text.html.ListView 中的方法
setPropertiesFromAttributes() - 类 javax.swing.text.html.ParagraphView 中的方法
通过 css 属性设置段落，而不是根据 StyleConstants 中的值（即超类所使用的值）设置段落。
setPropertiesFromAttributes() - 类 javax.swing.text.LabelView 中的方法
从属性集设置缓存的属性。
setPropertiesFromAttributes() - 类 javax.swing.text.ParagraphView 中的方法
从属性集设置缓存的属性。
setProperty(String, String) - 类 java.lang.System 中的静态方法
设置指定键指示的系统属性。
setProperty(String, String) - 类 java.security.Security 中的静态方法
设置安全属性值。
setProperty(String, String) - 类 java.util.Properties 中的方法
调用 Hashtable 的方法 put。
setProperty(String, Object) - 类 javax.xml.bind.Binder 中的方法
设置 Binder 的基础实现中的特定属性。
setProperty(String, Object) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。
setProperty(String, Object) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。
setProperty(String, Object) - 接口 javax.xml.bind.Marshaller 中的方法
设置 Marshaller 底层实现中的特定属性。
setProperty(String, Object) - 接口 javax.xml.bind.Unmarshaller 中的方法
设置 Unmarshaller 底层实现中的特定属性。
setProperty(String, Object) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
setProperty(String, Object) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
此实现使用内部 HashMap 将名称映射到指定对象。
setProperty(String, Object) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置指定的属性。
setProperty(String, Object) - 类 javax.xml.parsers.SAXParser 中的方法
设置 XMLReader 的底层实现中的特定属性。
setProperty(String, Object) - 类 javax.xml.soap.SOAPMessage 中的方法
将指定值与指定属性关联。
setProperty(String, Object) - 类 javax.xml.stream.XMLInputFactory 中的方法
允许用户在底层实现上设置特定功能/属性。
setProperty(String, Object) - 类 javax.xml.stream.XMLOutputFactory 中的方法
允许用户在底层实现上设置特定功能/属性。
setProperty(String, Object) - 类 javax.xml.validation.SchemaFactory 中的方法
设置属性值。
setProperty(String, Object) - 类 javax.xml.validation.Validator 中的方法
设置属性值。
setProperty(String, Object) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置属性值。
setProperty(String, Object) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
设置解析器属性。
setProperty(String, Object) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
设置属性值。
setProperty(String, Object) - 接口 org.xml.sax.XMLReader 中的方法
设置属性的值。
setPropertyEditorClass(Class<?>) - 类 java.beans.PropertyDescriptor 中的方法
通常 PropertyEditor 是使用 PropertyEditorManager 找到的。
setProtocols(String[]) - 类 javax.net.ssl.SSLParameters 中的方法
设置协议数组。
setPrototypeCellValue(Object) - 类 javax.swing.JList 中的方法
设置 prototypeCellValue 属性，然后（如果新值为非 null）计算 fixedCellWidth 和 fixedCellHeight 属性：请求单元渲染器组件提供单元渲染器的给定值（及索引 0），并使用该组件的首选大小。
setPrototypeDisplayValue(Object) - 类 javax.swing.JComboBox 中的方法
设置用于计算 UI 部分的显示大小的原型显示值。
setPublicId(String) - 类 javax.xml.transform.stream.StreamSource 中的方法
设置此 Source 的公共标识符。
setPublicId(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
此输入源的公共标识符。
setPublicId(String) - 类 org.xml.sax.helpers.LocatorImpl 中的方法
设置此定位器的公开标识符。
setPublicId(String) - 类 org.xml.sax.InputSource 中的方法
设置此输入源的公共标识符。
setPublicKey(PublicKey) - 类 java.security.Identity 中的方法
已过时。 设置此 Identity 的公钥。
setPurgeFlag(boolean) - 类 javax.management.relation.RelationService 中的方法
设置一个标志，以指示注销关系中引用的 MBean 时是否接收通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
setPurgeFlag(boolean) - 接口 javax.management.relation.RelationServiceMBean 中的方法
设置一个标志，以指示注销关系中引用的 MBean 时是否接收到通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
setPushLevel(Level) - 类 java.util.logging.MemoryHandler 中的方法
设置 pushLevel。
setQName(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的限定名称。
setQOP(int) - 类 org.ietf.jgss.MessageProp 中的方法
设置 QOP 值。
setQueryTimeout(int) - 接口 java.sql.Statement 中的方法
将驱动程序等待 Statement 对象执行的秒数设置为给定秒数。
setQueryTimeout(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将驱动程序等待查询执行的最大秒数设置为给定的数。
setQueryTimeout(int) - 接口 javax.sql.RowSet 中的方法
将驱动程序等待语句执行的最大秒数设置为给定的秒数。
setRangeProperties(int, int, int, int, boolean) - 接口 javax.swing.BoundedRangeModel 中的方法
此方法使用一个方法调用设置模型的所有数据。
setRangeProperties(int, int, int, int, boolean) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
在强行使参数满足以下常规约束条件之后，设置所有的 BoundedRangeModel 属性： minimum <= value <= value+extent <= maximum 至多生成一个 ChangeEvent。
setRaster(Raster) - 类 javax.imageio.IIOImage 中的方法
设置当前 Raster。
setRawContent(InputStream, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
setRawContentBytes(byte[], int, int, String) - 类 javax.xml.soap.AttachmentPart 中的方法
将此附件部分的内容设置为 byte[] 数组 content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。
setRawOffset(int) - 类 java.util.SimpleTimeZone 中的方法
把基准时区偏移量设置到 GMT。
setRawOffset(int) - 类 java.util.TimeZone 中的方法
把基准时区偏移量设置到 GMT。
setReadable(boolean, boolean) - 类 java.io.File 中的方法
设置此抽象路径名的所有者或所有用户的读权限。
setReadable(boolean) - 类 java.io.File 中的方法
设置此抽象路径名所有者读权限的一个便捷方法。
setReader(Reader) - 接口 javax.script.ScriptContext 中的方法
设置脚本的 Reader，以读取输入。
setReader(Reader) - 类 javax.script.SimpleScriptContext 中的方法
设置脚本的 Reader，以读取输入。
setReader(Reader) - 类 javax.xml.transform.stream.StreamSource 中的方法
调用要作为字符 reader 的输入。
setReadMethod(Method) - 类 java.beans.PropertyDescriptor 中的方法
设置应该用于读取属性值的方法。
setReadOnly() - 类 java.io.File 中的方法
标记此抽象路径名指定的文件或目录，从而只能对其进行读操作。
setReadOnly() - 类 java.security.PermissionCollection 中的方法
将此 PermissionCollection 对象标记为 "readonly"。
setReadOnly(boolean) - 接口 java.sql.Connection 中的方法
将此连接设置为只读模式，作为驱动程序启用数据库优化的提示。
setReadOnly() - 类 javax.security.auth.Subject 中的方法
将此 Subject 设置为只读的。
setReadOnly(boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 readOnly 属性设置为给定的 boolean 值。
setReadOnly(boolean) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的只读性设置为给定的 boolean 值。
setReadTimeout(int) - 类 java.net.URLConnection 中的方法
将读超时设置为指定的超时值，以毫秒为单位。
setReceiveBufferSize(int) - 类 java.net.DatagramSocket 中的方法
将此 DatagramSocket 的 SO_RCVBUF 选项设置为指定的值。
setReceiveBufferSize(int) - 类 java.net.ServerSocket 中的方法
为从此 ServerSocket 接受的套接字的 SO_RCVBUF 选项设置默认建议值。
setReceiveBufferSize(int) - 类 java.net.Socket 中的方法
将此 Socket 的 SO_RCVBUF 选项设置为指定的值。
setReceiver(Receiver) - 接口 javax.sound.midi.Transmitter 中的方法
设置此传输器将向其传送 MIDI 消息的接收器。
setRect(double, double, double, double) - 类 java.awt.geom.Rectangle2D.Double 中的方法
将此 Rectangle2D 的位置和大小设置为指定的 double 值。
setRect(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Double 中的方法
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
setRect(float, float, float, float) - 类 java.awt.geom.Rectangle2D.Float 中的方法
将此 Rectangle2D 的位置和大小设置为指定的 float 值。
setRect(double, double, double, double) - 类 java.awt.geom.Rectangle2D.Float 中的方法
将此 Rectangle2D 的位置和大小设置为指定的 double 值。
setRect(Rectangle2D) - 类 java.awt.geom.Rectangle2D.Float 中的方法
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
setRect(double, double, double, double) - 类 java.awt.geom.Rectangle2D 中的方法
将此 Rectangle2D 的位置和大小设置为指定的 double 值。
setRect(Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的方法
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
setRect(Raster) - 类 java.awt.image.WritableRaster 中的方法
将像素从 Raster srcRaster 复制到此 WritableRaster。
setRect(int, int, Raster) - 类 java.awt.image.WritableRaster 中的方法
将像素从 Raster srcRaster 复制到此 WritableRaster。
setRect(double, double, double, double) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 的边界设置为整数边界，它包含指定的 x、y、width 和 height。
setRef(RemoteStub, RemoteRef) - 类 java.rmi.server.RemoteStub 中的静态方法
已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。
setRef(int, Ref) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 REF(<structured-type>) 值。
setRef(int, Ref) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 Ref 对象。
setRef(int, Ref) - 接口 javax.sql.RowSet 中的方法
使用给定 Ref 值设置此 RowSet 对象命令中的指定参数。
setRejectedExecutionHandler(RejectedExecutionHandler) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置用于未执行任务的新处理程序。
setRelationServiceManagementFlag(Boolean) - 类 javax.management.relation.RelationSupport 中的方法
setRelationServiceManagementFlag(Boolean) - 接口 javax.management.relation.RelationSupportMBean 中的方法
指定此关系是否由 Relation Service 处理。
setRelative(boolean) - 类 javax.naming.NameClassPair 中的方法
设置此绑定的名称是否相对于目标上下文（由 list() 方法的第一个参数命名）。
setRelay(boolean) - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
将此 SOAPHeaderElement 的 relay 属性设置为 true 或 false。
setRemainingName(Name) - 异常 javax.naming.NamingException 中的方法
设置此异常的剩余名称字段。
setRemainingName(Name) - 类 javax.naming.spi.ResolveResult 中的方法
将此结果的剩余名称字段设置为 name。
setRemainingNewName(Name) - 异常 javax.naming.CannotProceedException 中的方法
设置此异常的 "remaining new name" 字段。
setRenderContext(RenderContext) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
设置下一次调用 startProduction() 要使用的新 RenderContext。
setRenderedImage(RenderedImage) - 类 javax.imageio.IIOImage 中的方法
设置当前 RenderedImage。
setRenderer(ListCellRenderer) - 类 javax.swing.JComboBox 中的方法
设置渲染器，该渲染器用于绘制列表项和从 JComboBox 字段的列表中选择的项。
setRenderingHint(RenderingHints.Key, Object) - 类 java.awt.Graphics2D 中的方法
为呈现算法设置单个首选项的值。
setRenderingHints(Map<?, ?>) - 类 java.awt.Graphics2D 中的方法
使用指定的 hints 替换用于所有呈现算法首选项的值。
setRenderingHints(RenderingHints) - 类 java.awt.image.renderable.RenderContext 中的方法
设置此 RenderContext 的呈现提示。
setReorderingAllowed(boolean) - 类 javax.swing.table.JTableHeader 中的方法
设置用户是否可以拖动列头，以重新排序各列。
setRepeats(boolean) - 类 javax.swing.Timer 中的方法
如果 flag 为 false，则指示 Timer 只向其侦听器发送一次动作事件。
setRequestControls(Control[]) - 类 javax.naming.ldap.InitialLdapContext 中的方法
setRequestControls(Control[]) - 接口 javax.naming.ldap.LdapContext 中的方法
为在此上下文上后续调用的方法设置请求控件。
setRequestFocusEnabled(boolean) - 类 javax.swing.JComponent 中的方法
提供一个关于此 JComponent 是否应该获得焦点的提示。
setRequestMethod(String) - 类 java.net.HttpURLConnection 中的方法
设置 URL 请求的方法， GET POST HEAD OPTIONS PUT DELETE TRACE 以上方法之一是合法的，具体取决于协议的限制。
setRequestProperty(String, String) - 类 java.net.URLConnection 中的方法
设置一般请求属性。
setReshowDelay(int) - 类 javax.swing.ToolTipManager 中的方法
在显示工具提示之前，用于指定用户必须等待 initialDelay 毫秒之前的时间。
setResizable(boolean) - 类 java.awt.Dialog 中的方法
设置此 dialog 是否可以由用户调整大小。
setResizable(boolean) - 类 java.awt.Frame 中的方法
设置此窗体是否可由用户调整大小。
setResizable(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置是否可以通过某个用户操作调整 JInternalFrame 的大小。
setResizable(boolean) - 类 javax.swing.table.TableColumn 中的方法
设置是否可以调整此列的大小。
setResizeWeight(double) - 类 javax.swing.JSplitPane 中的方法
指定当分隔窗格的大小改变时如何分配额外空间。
setResizingAllowed(boolean) - 类 javax.swing.table.JTableHeader 中的方法
设置用户是否可以通过在头间拖动来调整各列的大小。
setResizingColumn(TableColumn) - 类 javax.swing.table.JTableHeader 中的方法
将头的 resizingColumn 设置为 aColumn。
setResolvedName(Name) - 异常 javax.naming.NamingException 中的方法
设置此异常的已解析名称字段。
setResolvedObj(Object) - 异常 javax.naming.NamingException 中的方法
设置此异常的已解析对象字段。
setResolvedObj(Object) - 类 javax.naming.spi.ResolveResult 中的方法
将此结果的已解析 Object 字段设置为 obj。
setResolvedValue(int, Object) - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
将 obj 设置为将同步的 RowSet 对象当前行中第 index 列的值。
setResolvedValue(String, Object) - 接口 javax.sql.rowset.spi.SyncResolver 中的方法
将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。
setResolveParent(AttributeSet) - 类 javax.swing.text.AbstractDocument.AbstractElement 中的方法
设置要解析的父级。
setResolveParent(Keymap) - 接口 javax.swing.text.Keymap 中的方法
设置将用于解析键绑定的父级 keymap。
setResolveParent(AttributeSet) - 接口 javax.swing.text.MutableAttributeSet 中的方法
设置正解析的父级。
setResolveParent(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 中的方法
设置解析的父级。
setResolveParent(AttributeSet) - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
设置解析的父级。
setResourceBaseName(String) - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的方法
设置用于查找包含此格式的元素和属性描述的 ResourceBundle 新基本名称。
setResourceBundle(ResourceBundle) - 类 java.util.logging.LogRecord 中的方法
设置本地化资源包。
setResourceBundleName(String) - 类 java.util.logging.LogRecord 中的方法
设置本地化资源包名称。
setResourceResolver(LSResourceResolver) - 类 javax.xml.validation.SchemaFactory 中的方法
设置 LSResourceResolver 以自定义解析模式时的资源解析。
setResourceResolver(LSResourceResolver) - 类 javax.xml.validation.Validator 中的方法
设置 LSResourceResolver 以自定义验证期间的资源解析。
setResourceResolver(LSResourceResolver) - 类 javax.xml.validation.ValidatorHandler 中的方法
设置 LSResourceResolver 以自定义验证期间的资源解析。
setResult(Class<T>) - 接口 java.sql.SQLXML 中的方法
返回设置此 SQLXML 实例指定的 XML 值的 Result。
setResult(Result) - 接口 javax.xml.transform.sax.TransformerHandler 中的方法
设置与用于转换的此 TransformerHandler 关联的 Result。
setReturningAttributes(String[]) - 类 javax.naming.directory.SearchControls 中的方法
指定将作为搜索的一部分返回的属性。
setReturningObjFlag(boolean) - 类 javax.naming.directory.SearchControls 中的方法
启用/禁用作为结果的一部分返回所返回对象。
setReuseAddress(boolean) - 类 java.net.DatagramSocket 中的方法
启用/禁用 SO_REUSEADDR 套接字选项。
setReuseAddress(boolean) - 类 java.net.ServerSocket 中的方法
启用/禁用 SO_REUSEADDR 套接字选项。
setReuseAddress(boolean) - 类 java.net.Socket 中的方法
启用/禁用 SO_REUSEADDR 套接字选项。
setRevocationEnabled(boolean) - 类 java.security.cert.PKIXParameters 中的方法
设置 RevocationEnabled 标志。
setRGB(int, int, int) - 类 java.awt.image.BufferedImage 中的方法
将此 BufferedImage 中的像素设置为指定的 RGB 值。
setRGB(int, int, int, int, int[], int, int) - 类 java.awt.image.BufferedImage 中的方法
将默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中的整数像素数组设置为图像数据的一部分。
setRightChildIndent(int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
setRightComponent(Component) - 类 javax.swing.JSplitPane 中的方法
将组件设置到分隔条的右边（或者下面）。
setRightIndent(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置右边缩进。
setRightInset(float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图四周右侧的空白部分。
setRole(Role) - 接口 javax.management.relation.Relation 中的方法
设置给定角色。
setRole(String, Role) - 类 javax.management.relation.RelationService 中的方法
设置给定关系中的给定角色。
setRole(String, Role) - 接口 javax.management.relation.RelationServiceMBean 中的方法
以给定关系设置给定角色。
setRole(Role) - 类 javax.management.relation.RelationSupport 中的方法
设置给定的角色。
setRole(String) - 接口 javax.xml.soap.SOAPHeaderElement 中的方法
将与此 SOAPHeaderElement 对象关联的 Role 设置为指定 Role。
setRoleName(String) - 类 javax.management.relation.Role 中的方法
设置角色名称。
setRoleName(String) - 类 javax.management.relation.RoleUnresolved 中的方法
设置角色名称。
setRoles(RoleList) - 接口 javax.management.relation.Relation 中的方法
设置给定的角色。
setRoles(String, RoleList) - 类 javax.management.relation.RelationService 中的方法
设置给定关系中的给定角色。
setRoles(String, RoleList) - 接口 javax.management.relation.RelationServiceMBean 中的方法
以给定关系设置给定角色。
setRoles(RoleList) - 类 javax.management.relation.RelationSupport 中的方法
设置给定的角色。
setRoles(RoleList) - 类 javax.management.relation.RoleResult 中的方法
设置成功访问的角色列表。
setRoles(Set<String>) - 接口 javax.xml.ws.soap.SOAPBinding 中的方法
设置由 SOAP 绑定实例扮演的角色。
setRolesUnresolved(RoleUnresolvedList) - 类 javax.management.relation.RoleResult 中的方法
设置未成功访问的角色列表。
setRoleValue(List<ObjectName>) - 类 javax.management.relation.Role 中的方法
设置角色值。
setRoleValue(List<ObjectName>) - 类 javax.management.relation.RoleUnresolved 中的方法
设置角色值。
setRollover(boolean) - 接口 javax.swing.ButtonModel 中的方法
设置或清除该按钮的翻转状态
setRollover(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
设置或清除该按钮的翻转状态
setRollover(boolean) - 类 javax.swing.JToolBar 中的方法
设置此工具栏的 rollover 状态。
setRolloverBorders(boolean) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
在工具栏上设置启用翻转边框的标志并根据标志的状态安装适当的边框。
setRolloverEnabled(boolean) - 类 javax.swing.AbstractButton 中的方法
设置 rolloverEnabled 属性，若需要翻转效果，该属性必须为 true。
setRolloverIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的翻转图标。
setRolloverSelectedIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的翻转选择图标。
setRolloverTab(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
将当前有鼠标位于其上方的选项卡设置为 index。
setRoot(TreeNode) - 类 javax.swing.tree.DefaultTreeModel 中的方法
将根设置为 root。
setRootCause(Throwable) - 异常 javax.naming.NamingException 中的方法
记录此 NamingException 的根 cause。
setRootFrame(Frame) - 类 javax.swing.JOptionPane 中的静态方法
设置窗体，以用于不提供窗体的类方法。
setRootPane(JRootPane) - 类 javax.swing.JApplet 中的方法
设置 rootPane 属性。
setRootPane(JRootPane) - 类 javax.swing.JDialog 中的方法
设置 rootPane 属性。
setRootPane(JRootPane) - 类 javax.swing.JFrame 中的方法
设置 rootPane 属性。
setRootPane(JRootPane) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 rootPane 属性。
setRootPane(JRootPane) - 类 javax.swing.JWindow 中的方法
设置此窗口的新 rootPane 对象。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JApplet 中的方法
设置是否将对 add 和 setLayout 的调用转发给 contentPane。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JDialog 中的方法
设置是否将对 add 和 setLayout 的调用转发到 contentPane。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JFrame 中的方法
设置是否将对 add 和 setLayout 的调用转发到 contentPane。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JInternalFrame 中的方法
设置是否将对 add 和 setLayout 的调用转发到 contentPane。
setRootPaneCheckingEnabled(boolean) - 类 javax.swing.JWindow 中的方法
设置对 add 和 setLayout 的调用是否转发到 contentPane。
setRootVisible(boolean) - 类 javax.swing.JTree 中的方法
确定 TreeModel 的根节点是否可见。
setRootVisible(boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
将根设置为可见。
setRootVisible(boolean) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
确定 TreeModel 的根节点是否可视。
setRootVisible(boolean) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
确定 TreeModel 的根节点是否可见。
setRootVisible(boolean) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
确定 TreeModel 的根节点是否可见。
setRoundingMode(RoundingMode) - 类 java.text.DecimalFormat 中的方法
设置在此 DecimalFormat 中使用的 RoundingMode。
setRoundingMode(RoundingMode) - 类 java.text.NumberFormat 中的方法
设置在此 NumberFormat 中使用的 RoundingMode。
setRoundRect(double, double, double, double, double, double) - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
setRoundRect(RoundRectangle2D) - 类 java.awt.geom.RoundRectangle2D.Double 中的方法
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
setRoundRect(float, float, float, float, float, float) - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 float 值。
setRoundRect(double, double, double, double, double, double) - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
setRoundRect(RoundRectangle2D) - 类 java.awt.geom.RoundRectangle2D.Float 中的方法
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
setRoundRect(double, double, double, double, double, double) - 类 java.awt.geom.RoundRectangle2D 中的方法
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
setRoundRect(RoundRectangle2D) - 类 java.awt.geom.RoundRectangle2D 中的方法
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
setRowCount(int) - 类 javax.swing.table.DefaultTableModel 中的方法
设置模型中的行数。
setRowFilter(RowFilter<? super M, ? super I>) - 类 javax.swing.DefaultRowSorter 中的方法
设置用于确定哪些行（如果有）应该在视图中隐藏的过滤器。
setRowHeader(JViewport) - 类 javax.swing.JScrollPane 中的方法
移除旧的 rowHeader，如果存在；如果新的 rowHeader 不为 null，将其 viewPosition 的 y 坐标与视口（如果有）同步然后将其添加到滚动窗格。
setRowHeaderView(Component) - 类 javax.swing.JScrollPane 中的方法
创建一个行标题视口（如果有必要），设置其视图然后将此行标题视口添加到滚动窗格。
setRowHeight(int) - 类 javax.swing.JTable 中的方法
将所有单元格的高度设置为 rowHeight（以像素为单位），重新验证并重新绘制它。
setRowHeight(int, int) - 类 javax.swing.JTable 中的方法
将 row 的高度设置为 rowHeight，重新验证并重新绘制它。
setRowHeight(int) - 类 javax.swing.JTree 中的方法
设置每个单元格的高度（以像素为单位）。
setRowHeight(int) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
设置行高度，此方法将被转发到 treeState。
setRowHeight(int) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
设置每个单元的高度。
setRowHeight(int) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
设置每个单元格的高度。
setRowHeight(int) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
设置每个单元格的高度。
setRowId(String, RowId) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.sql.RowId 对象。
setRowId(int, RowId) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.RowId 对象。
setRowId(int, RowId) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.RowId 对象。
setRowId(String, RowId) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.RowId 对象。
setRowId(int, RowId) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.RowId 对象。
setRowId(String, RowId) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.RowId 对象。
setRowMapper(RowMapper) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
设置 RowMapper 实例。
setRowMapper(RowMapper) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
设置 RowMapper 实例。
setRowMargin(int) - 类 javax.swing.JTable 中的方法
设置相临行中单元格之间的间距。
setRows(int) - 类 java.awt.GridLayout 中的方法
将此布局中的行数设置为指定值。
setRows(int) - 类 java.awt.TextArea 中的方法
设置此文本区的行数。
setRows(int) - 类 javax.swing.JTextArea 中的方法
设置此 TextArea 的行数。
setRowSelectionAllowed(boolean) - 类 javax.swing.JTable 中的方法
设置是否可以选择此模型中的行。
setRowSelectionInterval(int, int) - 类 javax.swing.JTable 中的方法
选择从 index0 到 index1 之间（包含两端）的行。
setRowSorter(RowSorter<? extends TableModel>) - 类 javax.swing.JTable 中的方法
设置 RowSorter。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
使用输入的 int 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, float, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
使用输入的 float 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, double, DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
使用输入的 double 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
使用输入的 int 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, float, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
使用输入的 float 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, double, DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
使用输入的 double 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.MultiPixelPackedSampleModel 中的方法
使用输入的 int，设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, float, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 float 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, double, DataBuffer) - 类 java.awt.image.SampleModel 中的方法
使用输入的 double 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, int, DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
setSample(int, int, int, int) - 类 java.awt.image.WritableRaster 中的方法
使用 int 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
setSample(int, int, int, float) - 类 java.awt.image.WritableRaster 中的方法
使用 float 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
setSample(int, int, int, double) - 类 java.awt.image.WritableRaster 中的方法
使用 double 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
setSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.BandedSampleModel 中的方法
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，int 数组中每个数据数组元素包含一个样本。
setSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.ComponentSampleModel 中的方法
根据 int 数组（每个数据数组元素包含一个样本），在指定 band 中设置对应于指定像素矩形的样本。
setSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
setSamples(int, int, int, int, int, float[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 float 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
setSamples(int, int, int, int, int, double[], DataBuffer) - 类 java.awt.image.SampleModel 中的方法
根据 double 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
setSamples(int, int, int, int, int, int[], DataBuffer) - 类 java.awt.image.SinglePixelPackedSampleModel 中的方法
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
setSamples(int, int, int, int, int, int[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 int 型数组中指定的像素矩形在指定 band 中设置样本。
setSamples(int, int, int, int, int, float[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 float 型数组中指定的像素矩形在指定 band 中设置样本。
setSamples(int, int, int, int, int, double[]) - 类 java.awt.image.WritableRaster 中的方法
为每个数组元素包含一个样本的 double 型数组中指定的像素矩形在指定 band 中设置样本。
setSavepoint() - 接口 java.sql.Connection 中的方法
在当前事务中创建一个未命名的保存点 (savepoint)，并返回表示它的新 Savepoint 对象。
setSavepoint(String) - 接口 java.sql.Connection 中的方法
在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。
setScale(int, RoundingMode) - 类 java.math.BigDecimal 中的方法
返回 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
setScale(int, int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
setScale(int) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其标度为指定值，其值在数值上等于此 BigDecimal 的值。
setScale(int, int) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将存储在指定列中的值的小数点右边的位数设置为给定数。
setScale(int, int) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的小数点右边的位数设置为给定的 int。
setSchema(Schema) - 类 javax.xml.bind.Binder 中的方法
指定 marshal、unmarshal 和 update 方法是否在其 XML 内容上执行验证。
setSchema(Schema) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
setSchema(Schema) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
setSchema(Schema) - 接口 javax.xml.bind.Marshaller 中的方法
指定应该用作验证后续编组操作依据的 JAXP 1.3 Schema 对象。
setSchema(Schema) - 接口 javax.xml.bind.Unmarshaller 中的方法
指定应用作验证后续解组操作依据的 JAXP 1.3 Schema 对象。
setSchema(Schema) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
设置将由解析器使用的 Schema，该解析器从此工厂创建。
setSchema(Schema) - 类 javax.xml.parsers.SAXParserFactory 中的方法
设置将由解析器使用的 Schema，该解析器从此工厂创建。
setSchemaLocation(String) - 类 javax.xml.bind.helpers.AbstractMarshallerImpl 中的方法
设置 schemaLocation 的便捷方法。
setSchemaName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列的表的模式名称（如果有）设置为 schemaName。
setSchemaName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的表模式的名称（如果有）设置为给定的 String。
setScope(String, MessageContext.Scope) - 接口 javax.xml.ws.handler.MessageContext 中的方法
设置属性的作用域。
setScrollByBlock(boolean) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener 中的方法
setScrollByBlock(boolean) - 类 javax.swing.plaf.basic.BasicSliderUI.ScrollListener 中的方法
setScrollMode(int) - 类 javax.swing.JViewport 中的方法
用于控制滚动视口内容的方法。
setScrollOffset(int) - 类 javax.swing.JTextField 中的方法
获取滚动偏移量（以像素为单位）。
setScrollPosition(int, int) - 类 java.awt.ScrollPane 中的方法
滚动到子组件中的指定位置。
setScrollPosition(Point) - 类 java.awt.ScrollPane 中的方法
滚动到子组件中的指定位置。
setScrollsOnExpand(boolean) - 类 javax.swing.JTree 中的方法
设置 scrollsOnExpand 属性，它确定树是否可以滚动显示以前隐藏的子节点。
setSearchable(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否可以在 WHERE 子句中使用。
setSearchable(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置是否可以在 where 子句中使用指定的列。
setSearchScope(int) - 类 javax.naming.directory.SearchControls 中的方法
将搜索范围设置为以下值之一：OBJECT_SCOPE、ONELEVEL_SCOPE 和 SUBTREE_SCOPE。
setSecond(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置秒。
setSeconds(int) - 类 java.sql.Date 中的方法
已过时。
setSeconds(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.SECOND, int seconds) 取代。
setSecure(boolean) - 类 java.net.HttpCookie 中的方法
指示浏览器是否只能使用安全协议（如 HTTPS 或 SSL）发送 cookie。
setSecurityManager(SecurityManager) - 类 java.lang.System 中的静态方法
设置系统安全性。
setSeed(byte[]) - 类 java.security.SecureRandom 中的方法
重新设置此随机对象的种子。
setSeed(long) - 类 java.security.SecureRandom 中的方法
使用给定 long seed 中包含的八个字节，重新设置此随机对象的种子。
setSeed(long) - 类 java.util.Random 中的方法
使用单个 long 种子设置此随机数生成器的种子。
setSelected(boolean) - 类 javax.swing.AbstractButton 中的方法
设置按钮的状态。
setSelected(ButtonModel, boolean) - 类 javax.swing.ButtonGroup 中的方法
为 ButtonModel 设置选择值。
setSelected(boolean) - 接口 javax.swing.ButtonModel 中的方法
选择或取消选择该按钮。
setSelected(boolean) - 类 javax.swing.DefaultButtonModel 中的方法
选择或取消选择该按钮。
setSelected(boolean) - 类 javax.swing.JInternalFrame 中的方法
如果要显示内部窗体，则选定或取消选定该窗体。
setSelected(boolean) - 类 javax.swing.JMenu 中的方法
设置菜单的选择状态。
setSelected(Component) - 类 javax.swing.JMenuBar 中的方法
设置当前选择的组件，更改选择模型。
setSelected(Component) - 类 javax.swing.JPopupMenu 中的方法
设置当前选择的组件，此方法将更改选择模型。
setSelected(boolean) - 类 javax.swing.JToggleButton.ToggleButtonModel 中的方法
设置按钮的选定状态。
setSelectedCheckbox(Checkbox) - 类 java.awt.CheckboxGroup 中的方法
将此组中当前选中的复选框设置为指定的复选框。
setSelectedColor(Color) - 接口 javax.swing.colorchooser.ColorSelectionModel 中的方法
将选取的颜色设置为 color。
setSelectedColor(Color) - 类 javax.swing.colorchooser.DefaultColorSelectionModel 中的方法
将选取的颜色设置为 color。
setSelectedComponent(Component) - 类 javax.swing.JTabbedPane 中的方法
设置此选项卡窗格的已选组件。
setSelectedFile(File) - 类 javax.swing.JFileChooser 中的方法
设置选中的文件。
setSelectedFiles(File[]) - 类 javax.swing.JFileChooser 中的方法
如果将文件选择器设置为允许选择多个文件，则设置选中文件的列表。
setSelectedFrame(JInternalFrame) - 类 javax.swing.JDesktopPane 中的方法
设置此 JDesktopPane 中当前活动的 JInternalFrame。
setSelectedIcon(Icon) - 类 javax.swing.AbstractButton 中的方法
设置按钮的选择图标。
setSelectedIndex(int) - 类 javax.security.auth.callback.ChoiceCallback 中的方法
设置选中的选项。
setSelectedIndex(int) - 类 javax.security.auth.callback.ConfirmationCallback 中的方法
设置选中的确认选项。
setSelectedIndex(int) - 类 javax.swing.DefaultSingleSelectionModel 中的方法
setSelectedIndex(int) - 类 javax.swing.JComboBox 中的方法
选择索引 anIndex 处的项。
setSelectedIndex(int) - 类 javax.swing.JList 中的方法
选择单个单元。
setSelectedIndex(int) - 类 javax.swing.JTabbedPane 中的方法
设置所选择的此选项卡窗格的索引。
setSelectedIndex(int) - 接口 javax.swing.SingleSelectionModel 中的方法
将模型中选定的索引设置为 index。
setSelectedIndexes(int[]) - 类 javax.security.auth.callback.ChoiceCallback 中的方法
设置选中的选项。
setSelectedIndices(int[]) - 类 javax.swing.JList 中的方法
将选择更改为给定数组所指定的索引的集合。
setSelectedItem(Object) - 接口 javax.swing.ComboBoxModel 中的方法
设置选择项。
setSelectedItem(Object) - 类 javax.swing.DefaultComboBoxModel 中的方法
设置选择项的值。
setSelectedItem(Object) - 类 javax.swing.JComboBox 中的方法
将组合框显示区域中所选项设置为参数中的对象。
setSelectedItem(Object) - 类 javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel 中的方法
setSelectedItem(Object) - 类 javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel 中的方法
setSelectedPath(MenuElement[]) - 类 javax.swing.MenuSelectionManager 中的方法
更改菜单层次结构中的选项。
setSelectedTextColor(Color) - 类 javax.swing.text.JTextComponent 中的方法
设置用于呈现选定文本的当前颜色。
setSelectedValue(Object, boolean) - 类 javax.swing.JList 中的方法
从列表中选择指定的对象。
setSelection(boolean) - 类 javax.swing.text.html.Option 中的方法
设置选定的状态。
setSelectionBackground(Color) - 类 javax.swing.JList 中的方法
设置用于绘制选定项的背景的颜色，单元渲染器可以使用此颜色填充所选单元。
setSelectionBackground(Color) - 类 javax.swing.JTable 中的方法
设置选定单元格的背景色。
setSelectionColor(Color) - 类 javax.swing.text.JTextComponent 中的方法
设置用于呈现选定的当前颜色。
setSelectionEnd(int) - 类 java.awt.TextComponent 中的方法
将此文本组件的选定结束位置设置为指定位置。
setSelectionEnd(int) - 类 javax.swing.text.JTextComponent 中的方法
将选择结束点设置为指定的位置。
setSelectionForeground(Color) - 类 javax.swing.JList 中的方法
设置用于绘制选定项的前景的颜色，单元渲染器可以使用此颜色呈现文本和图形。
setSelectionForeground(Color) - 类 javax.swing.JTable 中的方法
设置选定单元格的前景色。
setSelectionInterval(int, int) - 类 javax.swing.DefaultListSelectionModel 中的方法
将选择更改为 index0 和 index1（包括）的范围之间。
setSelectionInterval(int, int) - 类 javax.swing.JList 中的方法
选择指定的间隔。
setSelectionInterval(int, int) - 类 javax.swing.JTree 中的方法
选择 index0 和 index1（包含）之间的节点。
setSelectionInterval(int, int) - 接口 javax.swing.ListSelectionModel 中的方法
将选择更改为在 index0 和 index1 之间（包括两者）。
setSelectionMode(int) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置选择模式。
setSelectionMode(int) - 类 javax.swing.JList 中的方法
设置列表的选择模式。
setSelectionMode(int) - 类 javax.swing.JTable 中的方法
将表的选择模式设置为只允许单个选择、单个连续间隔选择或多间隔选择。
setSelectionMode(int) - 接口 javax.swing.ListSelectionModel 中的方法
设置选择模式。
setSelectionMode(int) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
设置选择模式，它必须是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一。
setSelectionMode(int) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
设置选择模型，它必须是 SINGLE_TREE_SELECTION、CONTIGUOUS_TREE_SELECTION 或 DISCONTIGUOUS_TREE_SELECTION 之一。
setSelectionModel(ColorSelectionModel) - 类 javax.swing.JColorChooser 中的方法
设置包含所选颜色的模型。
setSelectionModel(ListSelectionModel) - 类 javax.swing.JList 中的方法
将列表的 selectionModel 设置为非 null 的 ListSelectionModel 实现。
setSelectionModel(SingleSelectionModel) - 类 javax.swing.JMenuBar 中的方法
设置处理单个选择的模型对象。
setSelectionModel(SingleSelectionModel) - 类 javax.swing.JPopupMenu 中的方法
设置处理单个选择的模型对象。
setSelectionModel(ListSelectionModel) - 类 javax.swing.JTable 中的方法
将此表的行选择模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
setSelectionModel(TreeSelectionModel) - 类 javax.swing.JTree 中的方法
设置树的选择模型。
setSelectionModel(TreeSelectionModel) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
重置选择模型。
setSelectionModel(ListSelectionModel) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
将此 TableColumnModel 的选择模型设置为 newModel，并为来自新选择模型的侦听器通知注册它。
setSelectionModel(ListSelectionModel) - 接口 javax.swing.table.TableColumnModel 中的方法
设置选择模型。
setSelectionModel(TreeSelectionModel) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
将用于管理选择的 TreeSelectionModel 设置为新的 LSM。
setSelectionPath(TreePath) - 类 javax.swing.JTree 中的方法
选择指定路径标识的节点。
setSelectionPath(TreePath) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
为该选择设置路径。
setSelectionPath(TreePath) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
为该选择设置路径。
setSelectionPaths(TreePath[]) - 类 javax.swing.JTree.EmptySelectionModel 中的方法
一个未选择任何内容的 null 实现。
setSelectionPaths(TreePath[]) - 类 javax.swing.JTree 中的方法
选择由指定的路径数组标识的节点。
setSelectionPaths(TreePath[]) - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
为该选择设置路径中的路径。
setSelectionPaths(TreePath[]) - 接口 javax.swing.tree.TreeSelectionModel 中的方法
为该选择设置路径。
setSelectionRow(int) - 类 javax.swing.JTree 中的方法
选择显示的指定行的节点。
setSelectionRows(int[]) - 类 javax.swing.JTree 中的方法
选择与显示的每个指定行对应的节点。
setSelectionStart(int) - 类 java.awt.TextComponent 中的方法
将此文本组件的选定开始位置设置为指定位置。
setSelectionStart(int) - 类 javax.swing.text.JTextComponent 中的方法
将选定起始点设置为指定的位置。
setSelectionValues(Object[]) - 类 javax.swing.JOptionPane 中的方法
设置窗格的输入选择值，该窗格向用户提供可以从中进行选择的项列表。
setSelectionVisible(boolean) - 接口 javax.swing.text.Caret 中的方法
设置选定项的可见性
setSelectionVisible(boolean) - 类 javax.swing.text.DefaultCaret 中的方法
更改选定的可见性。
setSendBufferSize(int) - 类 java.net.DatagramSocket 中的方法
将此 DatagramSocket 的 SO_SNDBUF 选项设置为指定的值。
setSendBufferSize(int) - 类 java.net.Socket 中的方法
将此 Socket 的 SO_SNDBUF 选项设置为指定的值。
setSendPastNotifications(boolean) - 类 javax.management.timer.Timer 中的方法
设置指示计时器是否发送过期通知的标志。
setSendPastNotifications(boolean) - 接口 javax.management.timer.TimerMBean 中的方法
设置指示计时器是否发送过期通知的标志。
setSeparatorSize(Dimension) - 类 javax.swing.JToolBar.Separator 中的方法
设置分隔符的大小。
setSequence(Sequence) - 接口 javax.sound.midi.Sequencer 中的方法
设置 sequencer 所操作的当前 sequence。
setSequence(InputStream) - 接口 javax.sound.midi.Sequencer 中的方法
设置 sequencer 所操作的当前 sequence。
setSequenceNumber(long) - 类 java.util.logging.LogRecord 中的方法
设置序列号。
setSequenceNumber(long) - 类 javax.management.Notification 中的方法
设置通知序列号。
setSerialNumber(BigInteger) - 类 java.security.cert.X509CertSelector 中的方法
设置 serialNumber 标准。
setSessionCacheSize(int) - 接口 javax.net.ssl.SSLSessionContext 中的方法
设置用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。
setSessionTimeout(int) - 接口 javax.net.ssl.SSLSessionContext 中的方法
设置在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。
setSeverity(int) - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
设置此事件的 severity 字段。
setSharedInstance(PopupFactory) - 类 javax.swing.PopupFactory 中的静态方法
设置用于获取 Popup 的 PopupFactory。
setShort(Object, int, short) - 类 java.lang.reflect.Array 中的静态方法
将指定数组对象中索引组件的值设置为指定的 short 值。
setShort(Object, short) - 类 java.lang.reflect.Field 中的方法
将字段的值设置为指定对象上的一个 short 值。
setShort(String, short) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java short 值。
setShort(int, short) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java short 值。
setShort(int, short) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为 Java 编程语言中的给定 short 值。
setShort(String, short) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java short 值。
setShort(int, short) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java short 值。
setShort(String, short) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java short 值。
setShortcut(MenuShortcut) - 类 java.awt.MenuItem 中的方法
设置与此菜单项关联的 MenuShortcut 对象。
setShortDescription(String) - 类 java.beans.FeatureDescriptor 中的方法
可以将简短描述性字符串与某一特性相关联。
setShortMonths(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置简短形式的月份字符串。
setShortWeekdays(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置简短形式的星期字符串。
setShowDeleted(boolean) - 类 javax.sql.rowset.BaseRowSet 中的方法
将属性 showDeleted 设置为给定的 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
setShowDeleted(boolean) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将属性 showDeleted 设置为给定的 boolean 值，它确定标记为删除的行是否会出现在当前行集合中。
setShowDeleted(boolean) - 接口 javax.sql.rowset.JdbcRowSet 中的方法
将属性 showDeleted 设置为给定的 boolean 值。
setShowDropLocation(boolean) - 类 javax.swing.TransferHandler.TransferSupport 中的方法
设置是否应该为传输（必须表示一个放置操作）可视地指出放置位置。
setShowGrid(boolean) - 类 javax.swing.JTable 中的方法
设置表是否绘制单元格周围的网格线。
setShowHorizontalLines(boolean) - 类 javax.swing.JTable 中的方法
设置表是否绘制单元格之间的水平线。
setShowsRootHandles(boolean) - 类 javax.swing.JTree 中的方法
设置 showsRootHandles 属性的值，它指定是否应显示节点句柄。
setShowsRootHandles(boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
确定是否显示节点句柄。
setShowVerticalLines(boolean) - 类 javax.swing.JTable 中的方法
设置表是否绘制单元格之间的垂直线。
setSides(JobAttributes.SidesType) - 类 java.awt.JobAttributes 中的方法
指定对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。
setSidesToDefault() - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，将如何在打印介质的面上强制应用连续页设置为默认值。
setSigned(int, boolean) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否为有符号数。
setSigned(int, boolean) - 接口 javax.sql.RowSetMetaData 中的方法
设置指定列是否是有符号数字。
setSigners(Class<?>, Object[]) - 类 java.lang.ClassLoader 中的方法
设置类的签署者。
setSigProvider(String) - 类 java.security.cert.PKIXParameters 中的方法
设置签名提供者的名称。
setSize(Dimension) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
调整此对象的大小，使它具有宽度和高度。
setSize(int, int) - 类 java.awt.Component 中的方法
调整组件的大小，使其宽度为 width，高度为 height。
setSize(Dimension) - 类 java.awt.Component 中的方法
调整组件的大小，使其宽度为 d.width，高度为 d.height。
setSize(double, double) - 类 java.awt.Dimension 中的方法
将此 Dimension 对象的大小设置为指定的宽度和高度（以双精度表示）。
setSize(Dimension) - 类 java.awt.Dimension 中的方法
将 Dimension 对象的大小设置为指定大小。
setSize(int, int) - 类 java.awt.Dimension 中的方法
将此 Dimension 对象的大小设置为指定的宽度和高度。
setSize(double, double) - 类 java.awt.geom.Dimension2D 中的方法
将此 Dimension 对象的大小设置为指定的宽度和高度。
setSize(Dimension2D) - 类 java.awt.geom.Dimension2D 中的方法
将 Dimension2D 对象的大小设置为指定大小。
setSize(Dimension) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
调整此对象，使其具有高度和宽度。
setSize(Dimension) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
调整此对象的大小。
setSize(double, double) - 类 java.awt.print.Paper 中的方法
设置此 Paper 对象的宽和高，它表示要用来打印的页面的属性。
setSize(Dimension) - 类 java.awt.Rectangle 中的方法
设置此 Rectangle 的大小，以匹配指定的 Dimension。
setSize(int, int) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 的大小设置为指定的宽度和高度。
setSize(Dimension) - 类 java.awt.Window 中的方法
调整组件的大小，使其宽度为 d.width，高度为 d.height。
setSize(int, int) - 类 java.awt.Window 中的方法
调整组件的大小，使其宽度为 width，高度为 height。
setSize(int) - 类 java.util.Vector 中的方法
设置此向量的大小。
setSize(long) - 类 java.util.zip.ZipEntry 中的方法
设置条目数据的未压缩大小。
setSize(Dimension) - 接口 javax.accessibility.AccessibleComponent 中的方法
调整此对象，使其具有高度和宽度。
setSize(int) - 类 javax.swing.DefaultListModel 中的方法
设置此列表的大小。
setSize(Dimension) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setSize(Dimension) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
setSize(Dimension) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setSize(int, int) - 类 javax.swing.SizeSequence 中的方法
设置指定条目的大小。
setSize(Dimension) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setSize(float, float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.BoxView 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.html.ImageView 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.PlainView 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.View 中的方法
设置视图的大小。
setSize(float, float) - 类 javax.swing.text.WrappedPlainView 中的方法
设置视图的大小。
setSizes(int[]) - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
将大小设置为 newSizes。
setSizes(int[]) - 类 javax.swing.SizeSequence 中的方法
用 sizes 参数中的数据重置此 SizeSequence 对象。
setSlaveSyncMode(Sequencer.SyncMode) - 接口 javax.sound.midi.Sequencer 中的方法
设置此 sequencer 的从同步模式。
setSnapToTicks(boolean) - 类 javax.swing.JSlider 中的方法
指定为 true，则滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值。
setSocketAddress(SocketAddress) - 类 java.net.DatagramPacket 中的方法
设置要将此数据报发往的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。
setSocketFactory(SocketImplFactory) - 类 java.net.ServerSocket 中的静态方法
为应用程序设置服务器套接字实现工厂。
setSocketFactory(RMISocketFactory) - 类 java.rmi.server.RMISocketFactory 中的静态方法
设置 RMI 从中获取套接字的全局套接字工厂（如果远程对象与指定客户机和/或服务器套接字工厂无关）。
setSocketImplFactory(SocketImplFactory) - 类 java.net.Socket 中的静态方法
为应用程序设置客户端套接字实现工厂。
setSoLinger(boolean, int) - 类 java.net.Socket 中的方法
启用/禁用具有指定逗留时间（以秒为单位）的 SO_LINGER。
setSolo(boolean) - 接口 javax.sound.midi.MidiChannel 中的方法
设置此通道的 solo 状态。
setSortable(int, boolean) - 类 javax.swing.DefaultRowSorter 中的方法
设置指定列是否可排序。
setSortKeys(List<? extends RowSorter.SortKey>) - 类 javax.swing.DefaultRowSorter 中的方法
设置排序键。
setSortKeys(List<? extends RowSorter.SortKey>) - 类 javax.swing.RowSorter 中的方法
设置当前排序键。
setSortsOnUpdates(boolean) - 类 javax.swing.DefaultRowSorter 中的方法
如果为 true，则指定应该在底层模型更新（调用了 rowsUpdated）时进行排序。
setSoTimeout(int) - 类 java.net.DatagramSocket 中的方法
启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
setSoTimeout(int) - 类 java.net.ServerSocket 中的方法
通过指定超时值启用/禁用 SO_TIMEOUT，以毫秒为单位。
setSoTimeout(int) - 类 java.net.Socket 中的方法
启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
setSource(Object) - 类 java.awt.AWTEvent 中的方法
将事件的目标更改为新的源。
setSource(Object, int) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将源列表中的某个项替换为一个新源。
setSource(Object) - 类 java.beans.PropertyEditorSupport 中的方法
设置源 bean。
setSource(Object) - 类 javax.management.Notification 中的方法
设置源。
setSourceActions(int) - 类 java.awt.dnd.DragGestureRecognizer 中的方法
此方法设置此 Drag 和 Drop 操作允许的源拖动动作。
setSourceBands(int[]) - 类 javax.imageio.IIOParam 中的方法
设置将要使用的源 band 的索引。
setSourceClassName(String) - 类 java.util.logging.LogRecord 中的方法
设置（可能）发出日志请求的类的名称。
setSourceMethodName(String) - 类 java.util.logging.LogRecord 中的方法
设置（可能）发出日志请求的方法的名称。
setSourceProgressivePasses(int, int) - 类 javax.imageio.ImageReadParam 中的方法
设置将被解码的逐步传递的范围。
setSourceRegion(Rectangle) - 类 javax.imageio.IIOParam 中的方法
设置感兴趣的源区域。
setSourceRenderSize(Dimension) - 类 javax.imageio.ImageReadParam 中的方法
如果能够以任意大小呈现图像，则将源宽度和高度设置为所提供的值。
setSources(Vector<Object>) - 类 java.awt.image.renderable.ParameterBlock 中的方法
将源的整个 Vector 设置为给定 Vector。
setSourceSubsampling(int, int, int, int) - 类 javax.imageio.IIOParam 中的方法
指定进行 I/O 时应用的抽取十分之一的二次取样。
setSouthPane(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setSpaceAbove(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置上部空间。
setSpaceBelow(MutableAttributeSet, float) - 类 javax.swing.text.StyleConstants 中的静态方法
设置下部空间。
setSpecified(int, boolean) - 类 org.xml.sax.ext.Attributes2Impl 中的方法
将值分配给特定属性的“指定的”标志。
setSQLXML(String, SQLXML) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.sql.SQLXML 对象。
setSQLXML(int, SQLXML) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.SQLXML 对象。
setSQLXML(int, SQLXML) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定 java.sql.SQLXML 对象。
setSQLXML(String, SQLXML) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.SQLXML 对象。
setSQLXML(int, SQLXML) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定 java.sql.SQLXML 对象。
setSQLXML(String, SQLXML) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.SQLXML 对象。
setSSLParameters(SSLParameters) - 类 javax.net.ssl.SSLEngine 中的方法
对此引擎应用 SSLParameters。
setSSLParameters(SSLParameters) - 类 javax.net.ssl.SSLSocket 中的方法
对此套接字应用 SSLParameters。
setSSLSocketFactory(SSLSocketFactory) - 类 javax.net.ssl.HttpsURLConnection 中的方法
设置当此实例为安全 https URL 连接创建套接字时使用的 SSLSocketFactory。
setStackTrace(StackTraceElement[]) - 类 java.lang.Throwable 中的方法
设置将由 Throwable.getStackTrace() 返回，并由 Throwable.printStackTrace() 和相关方法输出的堆栈跟踪元素。
setStart(Comparable) - 类 javax.swing.SpinnerDateModel 中的方法
更改此序列中的日期下限。
setStartRule(int, int, int, int) - 类 java.util.SimpleTimeZone 中的方法
设置夏令时的开始规则。
setStartRule(int, int, int) - 类 java.util.SimpleTimeZone 中的方法
将夏令时开始规则设置为某个月份的固定日期。
setStartRule(int, int, int, int, boolean) - 类 java.util.SimpleTimeZone 中的方法
将夏令时开始规则设置为某个月份给定日期之前或之后的星期几，例如，8 号或之后的第一个星期一。
setStartYear(int) - 类 java.util.SimpleTimeZone 中的方法
设置夏令时的开始年份。
setState(boolean) - 类 java.awt.Checkbox 中的方法
将此复选框的状态设置为指定状态。
setState(boolean) - 类 java.awt.CheckboxMenuItem 中的方法
将此复选框菜单项设置为指定的状态。
setState(int) - 类 java.awt.Frame 中的方法
设置此窗体的状态（已废弃）。
setState(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
设置同步状态的值。
setState(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
设置同步状态的值。
setState(boolean) - 类 javax.swing.JCheckBoxMenuItem 中的方法
设置该项的选定状态。
setStepSize(Number) - 类 javax.swing.SpinnerNumberModel 中的方法
更改由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。
setStrategy(int) - 类 java.util.zip.Deflater 中的方法
将压缩策略设置为指定值。
setStream(String, InputStream) - 接口 java.applet.AppletContext 中的方法
在此 applet 上下文中用指定的键关联指定的流。
setStrength(int) - 类 java.text.Collator 中的方法
设置此 Collator 的 strength 属性。
setStrictErrorChecking(boolean) - 接口 org.w3c.dom.Document 中的方法
指定是否强制执行错误检查的属性。
setStrikeThrough(boolean) - 类 javax.swing.text.LabelView 中的方法
设置视图是否具有删除线。
setStrikeThrough(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置删除线属性。
setString(String, String) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 Java String 值。
setString(long, String) - 接口 java.sql.Clob 中的方法
在位置 pos 处将给定 Java String 写入此 Clob 对象指定的 CLOB 值中。
setString(long, String, int, int) - 接口 java.sql.Clob 中的方法
将 str 的 len 个字符（从字符 offset 开始）写入此 Clob 表示的 CLOB 值中。
setString(int, String) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 Java String 值。
setString(String) - 接口 java.sql.SQLXML 中的方法
将此 SQLXML 实例指定的 XML 值设置为给定的 String 表示形式。
setString(int, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 String 值。
setString(String, String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 Java String 值。
setString(long, String) - 类 javax.sql.rowset.serial.SerialClob 中的方法
在位置 pos 处将给定 Java String 写入此 SerialClob 对象表示的 CLOB 值中。
setString(long, String, int, int) - 类 javax.sql.rowset.serial.SerialClob 中的方法
将 str 的 len 个字符写入此 Clob 表示的 CLOB 值中，从字符 offset 开始。
setString(int, String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 Java String 值。
setString(String, String) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 Java String 值。
setString(String) - 类 javax.swing.JProgressBar 中的方法
设置进度字符串的值。
setStringConverter(TableStringConverter) - 类 javax.swing.table.TableRowSorter 中的方法
设置负责将值从模型转换为字符串的对象。
setStringData(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
要解析的字符串数据。
setStringPainted(boolean) - 类 javax.swing.JProgressBar 中的方法
设置 stringPainted 属性的值，该属性确定进度条是否应该呈现进度字符串。
setStringToCompare(String) - 类 javax.management.monitor.StringMonitor 中的方法
设置要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。
setStringToCompare(String) - 接口 javax.management.monitor.StringMonitorMBean 中的方法
设置要与 observed 属性进行比较的字符串。
setStroke(Stroke) - 类 java.awt.Graphics2D 中的方法
为 Graphics2D 上下文设置 Stroke
setStub(AppletStub) - 类 java.applet.Applet 中的方法
设置此 applet 的 stub。
setStyledDocument(StyledDocument) - 类 javax.swing.JTextPane 中的方法
将编辑器与一个文本文档关联。
setStyleFactory(SynthStyleFactory) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
设置 SynthStyleFactory，由 synth 提供的 UI 类将使用它来获取 SynthStyle。
setStyleSheet(StyleSheet) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
设置要用于呈现各种 HTML 元素的样式集。
setSubject(X500Principal) - 类 java.security.cert.X509CertSelector 中的方法
设置 subject 标准。
setSubject(String) - 类 java.security.cert.X509CertSelector 中的方法
已过时，使用 X509CertSelector.setSubject(X500Principal) 或 X509CertSelector.setSubject(byte[]) 替代。
setSubject(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 subject 标准。
setSubjectAlternativeNames(Collection<List<?>>) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectAlternativeNames 标准。
setSubjectKeyIdentifier(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectKeyIdentifier 标准。
setSubjectPublicKey(PublicKey) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectPublicKey 标准。
setSubjectPublicKey(byte[]) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectPublicKey 标准。
setSubjectPublicKeyAlgID(String) - 类 java.security.cert.X509CertSelector 中的方法
设置 subjectPublicKeyAlgID 标准。
setSubscript(boolean) - 类 javax.swing.text.LabelView 中的方法
设置视图是否有下标。
setSubscript(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置下标属性。
setSubType(String) - 类 javax.activation.MimeType 中的方法
将此对象的子类型设置为给定的 String。
setSuperscript(boolean) - 类 javax.swing.text.LabelView 中的方法
设置视图是否有上标。
setSuperscript(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置上标属性。
setSupplementaryStates(boolean, boolean, boolean, boolean, int, String) - 类 org.ietf.jgss.MessageProp 中的方法
此方法将设置 MessageProp 中的增补信息标记的状态和次要状态。
setSurrendersFocusOnKeystroke(boolean) - 类 javax.swing.JTable 中的方法
设置由于 JTable 为某个单元格转发键盘事件而导致编辑器被激活时，此 JTable 中的编辑器是否获得键盘焦点。
setSyncAllWidths(boolean) - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的方法
setSyncProvider(String) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象的 SyncProvider 对象设置为指定的提供者。
setSyncResolver(SyncResolver) - 异常 javax.sql.rowset.spi.SyncProviderException 中的方法
将此 SyncProviderException 对象的 SyncResolver 对象设置为提供的对象。
setSystem(ActivationSystem) - 类 java.rmi.activation.ActivationGroup 中的静态方法
设置该 VM 的激活系统。
setSystemId(String) - 类 javax.xml.transform.dom.DOMResult 中的方法
设置可与此节点联合使用的 systemId。
setSystemId(String) - 类 javax.xml.transform.dom.DOMSource 中的方法
设置将从其解析 URL 的基本 ID（URL 或系统 ID）。
setSystemId(String) - 接口 javax.xml.transform.Result 中的方法
设置此 Result 的系统标识符。
setSystemId(String) - 类 javax.xml.transform.sax.SAXResult 中的方法
setSystemId 方法设置可与 ContentHandler 关联使用的 systemID。
setSystemId(String) - 类 javax.xml.transform.sax.SAXSource 中的方法
设置此 Source 的系统标识符。
setSystemId(String) - 接口 javax.xml.transform.sax.TemplatesHandler 中的方法
设置此生成器所创建的 Templates 对象的基本 ID（URI 或系统 ID）。
setSystemId(String) - 接口 javax.xml.transform.sax.TransformerHandler 中的方法
设置要从其解析相对 URL 的基本 ID（URI 或系统 ID）。
setSystemId(String) - 接口 javax.xml.transform.Source 中的方法
设置此 Source 的系统标识符。
setSystemId(String) - 类 javax.xml.transform.stax.StAXResult 中的方法
在 StAXResult 的上下文中，它不适合显示设置系统标识符。
setSystemId(String) - 类 javax.xml.transform.stax.StAXSource 中的方法
在 StAXSource 的上下文中，它不适合显示设置系统标识符。
setSystemId(String) - 类 javax.xml.transform.stream.StreamResult 中的方法
设置可以与字节流或字符流关联使用的 systemID，如果未设置，则使用此值作为 writeable URI（可能是文件名）。
setSystemId(File) - 类 javax.xml.transform.stream.StreamResult 中的方法
设置来自 File 引用的系统 ID。
setSystemId(String) - 类 javax.xml.transform.stream.StreamSource 中的方法
设置此 Source 的系统标识符。
setSystemId(File) - 类 javax.xml.transform.stream.StreamSource 中的方法
设置来自 File 引用的系统 ID。
setSystemId(String) - 接口 org.w3c.dom.ls.LSInput 中的方法
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。
setSystemId(String) - 接口 org.w3c.dom.ls.LSOutput 中的方法
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。
setSystemId(String) - 类 org.xml.sax.helpers.LocatorImpl 中的方法
设置此定位器的系统标识符。
setSystemId(String) - 类 org.xml.sax.InputSource 中的方法
设置此输入源的系统标识符。
setSystemScope(IdentityScope) - 类 java.security.IdentityScope 中的静态方法
已过时。 设置系统的身份作用域。
setTabComponentAt(int, Component) - 类 javax.swing.JTabbedPane 中的方法
设置负责呈现指定选项卡标题的组件。
setTabLayoutPolicy(int) - 类 javax.swing.JTabbedPane 中的方法
设置在一次运行中不能放入所有的选项卡时，选项卡窗格使用的对选项卡进行布局安排的策略。
setTable(JTable) - 类 javax.swing.table.JTableHeader 中的方法
设置与此头关联的表。
setTableHeader(JTableHeader) - 类 javax.swing.JTable 中的方法
将此 JTable 所使用的 tableHeader 设置为 newHeader。
setTableName(String) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将派生此 CachedRowSet 对象的表的标识符设置为给定的表名。
setTableName(int, String) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
将派生指定列的表名称设置为给定的表名称。
setTableName(int, String) - 接口 javax.sql.RowSetMetaData 中的方法
将指定列的表名称（如果有）设置为给定的 String。
setTabPlacement(int) - 类 javax.swing.JTabbedPane 中的方法
设置此选项卡窗格的选项卡布局。
setTabSet(MutableAttributeSet, TabSet) - 类 javax.swing.text.StyleConstants 中的静态方法
设置 TabSet。
setTabSize(int) - 类 javax.swing.JTextArea 中的方法
设置选项卡要扩大到的字符数。
setTarget(Object) - 类 javax.accessibility.AccessibleRelation 中的方法
设置此关系的目标对象
setTarget(Object[]) - 类 javax.accessibility.AccessibleRelation 中的方法
设置此关系的目标对象
setTarget(Remote) - 接口 javax.rmi.CORBA.Tie 中的方法
由 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 调用以设置此 tie 的目标。
setTargetActions(int) - 类 java.awt.dnd.DropTargetContext 中的方法
此方法设置此 DropTarget 可接受的当前操作。
setTargetCertConstraints(CertSelector) - 类 java.security.cert.PKIXParameters 中的方法
设置目标证书所需的限制。
setTcpNoDelay(boolean) - 类 java.net.Socket 中的方法
启用/禁用 TCP_NODELAY（启用/禁用 Nagle 算法）。
setTempoFactor(float) - 接口 javax.sound.midi.Sequencer 中的方法
根据所提供的 factor 按比例提高 sequencer 的实际回放速度。
setTempoInBPM(float) - 接口 javax.sound.midi.Sequencer 中的方法
设置速度，以每分钟的拍数为单位。
setTempoInMPQ(float) - 接口 javax.sound.midi.Sequencer 中的方法
设置速度，以每四分音符的微秒数为单位。
setText(String) - 类 java.awt.Label 中的方法
将此标签的文本设置为指定的文本。
setText(String) - 类 java.awt.TextComponent 中的方法
将此文本组件显示的文本设置为指定文本。
setText(String) - 类 java.awt.TextField 中的方法
将此文本组件显示的文本设置为指定文本。
setText(String) - 类 java.text.BreakIterator 中的方法
设置要被扫描的新文本字符串。
setText(CharacterIterator) - 类 java.text.BreakIterator 中的方法
设置一个新文本用于扫描。
setText(String) - 类 java.text.CollationElementIterator 中的方法
设置一个要迭代的新字符串。
setText(CharacterIterator) - 类 java.text.CollationElementIterator 中的方法
设置一个要迭代的新字符串。
setText(String) - 类 java.text.StringCharacterIterator 中的方法
将此迭代器重置为指向一个新的字符串。
setText(String) - 类 javax.security.auth.callback.TextInputCallback 中的方法
设置获取到的文本。
setText(String) - 类 javax.swing.AbstractButton 中的方法
设置按钮的文本。
setText(String) - 类 javax.swing.JEditorPane 中的方法
将此 TextComponent 的文本设置为指定内容，预期以此编辑器的内容类型格式提供该内容。
setText(String) - 类 javax.swing.JLabel 中的方法
定义此组件将要显示的单行文本。
setText(String) - 类 javax.swing.text.JTextComponent 中的方法
将此 TextComponent 文本设置为指定文本。
setTextContent(String) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setTextContent(String) - 接口 org.w3c.dom.Node 中的方法
此属性返回此节点及其后代的文本内容。
setTextContents(String) - 接口 javax.accessibility.AccessibleEditableText 中的方法
将文本内容设置为指定字符串。
setTextContents(String) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
将文本内容设置为指定字符串。
setTextContents(String) - 类 javax.swing.text.JTextComponent.AccessibleJTextComponent 中的方法
将文本内容设置为指定字符串。
setTextNonSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置选定节点时绘制文本所使用的颜色。
setTextSelectionColor(Color) - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
设置选定节点时绘制文本所使用的颜色。
setTextShiftOffset() - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
setThreadContentionMonitoringEnabled(boolean) - 接口 java.lang.management.ThreadMXBean 中的方法
启用或禁用线程争用监视。
setThreadCpuTimeEnabled(boolean) - 接口 java.lang.management.ThreadMXBean 中的方法
启用或禁用线程 CPU 时间测量。
setThreadFactory(ThreadFactory) - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
设置用于创建新线程的线程工厂。
setThreadID(int) - 类 java.util.logging.LogRecord 中的方法
设置产生消息的线程的标识符。
setThreshold(Number) - 类 javax.management.monitor.CounterMonitor 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
setThreshold(Number) - 接口 javax.management.monitor.CounterMonitorMBean 中的方法
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代
setThresholds(Number, Number) - 类 javax.management.monitor.GaugeMonitor 中的方法
设置所有观察到的 MBean 的公共高、低阈值。
setThresholds(Number, Number) - 接口 javax.management.monitor.GaugeMonitorMBean 中的方法
设置高、低阈值。
setThrown(Throwable) - 类 java.util.logging.LogRecord 中的方法
设置与日志事件相关联的 throwable。
setThumbBounds(int, int, int, int) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
设置 thumb 的边界并强制进行包括新旧 thumbBounds 在内的重绘。
setThumbBounds(int, int, int, int) - 类 javax.swing.plaf.metal.MetalScrollBarUI 中的方法
重写此方法只是为了增加无效区域。
setThumbLocation(int, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
setThumbnails(List<? extends BufferedImage>) - 类 javax.imageio.IIOImage 中的方法
将缩略图列表设置为 BufferedImage 的一个新 List 或 null。
setThumbRollover(boolean) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
设置鼠标当前是否位于 thumb 上。
setTick(long) - 类 javax.sound.midi.MidiEvent 中的方法
设置事件的用 MIDI 刻度表示的时间戳
setTickPosition(long) - 接口 javax.sound.midi.Sequencer 中的方法
设置当前 sequencer 位置，以 MIDI 节拍数为单位。
setTiling(int, int, int, int) - 类 javax.imageio.ImageWriteParam 中的方法
指定应该在输出流中平铺图像。
setTilingMode(int) - 类 javax.imageio.ImageWriteParam 中的方法
确定图像在输出流中是否将被平铺，如果将被平铺，将如何确定 tiling 参数。
setTime(String, Time) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.sql.Time 值。
setTime(String, Time, Calendar) - 接口 java.sql.CallableStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
setTime(long) - 类 java.sql.Date 中的方法
使用给定毫秒时间值设置现有 Date 对象。
setTime(int, Time) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Time 值。
setTime(int, Time, Calendar) - 接口 java.sql.PreparedStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
setTime(long) - 类 java.sql.Time 中的方法
使用毫秒时间值设置 Time 对象。
setTime(long) - 类 java.sql.Timestamp 中的方法
设置此 Timestamp 对象，以表示 1970 年 1 月 1 日 00:00:00 GMT 以后 time 毫秒的时间点。
setTime(Date) - 类 java.util.Calendar 中的方法
使用给定的 Date 设置此 Calendar 的时间。
setTime(long) - 类 java.util.Date 中的方法
设置此 Date 对象，以表示 1970 年 1 月 1 日 00:00:00 GMT 以后 time 毫秒的时间点。
setTime(long) - 类 java.util.zip.ZipEntry 中的方法
设置条目的修改时间。
setTime(int, Time) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Time 值。
setTime(int, Time, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Time 对象。
setTime(String, Time) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Time 值。
setTime(String, Time, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
setTime(int, Time) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Time 值。
setTime(int, Time, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
setTime(String, Time) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.Time 值。
setTime(String, Time, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
setTime(int, int, int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将时间设置为一个单元。
setTime(int, int, int, BigDecimal) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将时间设置为一个单元，包括可选无限精度小数秒。
setTime(int, int, int, int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将时间设置为一个单元，包括可选的毫秒。
setTimeInMillis(long) - 类 java.util.Calendar 中的方法
用给定的 long 值设置此 Calendar 的当前时间值。
setTimeLimit(int) - 类 javax.naming.directory.SearchControls 中的方法
设置这些 SearchControls 以毫秒为单位的时间限制。
setTimestamp(String, Timestamp) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.sql.Timestamp 值。
setTimestamp(String, Timestamp, Calendar) - 接口 java.sql.CallableStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
setTimestamp(int, Timestamp) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.sql.Timestamp 值。
setTimestamp(int, Timestamp, Calendar) - 接口 java.sql.PreparedStatement 中的方法
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
setTimeStamp(long) - 类 javax.management.Notification 中的方法
设置通知时间戳。
setTimestamp(int, Timestamp) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(int, Timestamp, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Timestamp 对象。
setTimestamp(String, Timestamp) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(String, Timestamp, Calendar) - 类 javax.sql.rowset.BaseRowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(int, Timestamp) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(String, Timestamp) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.sql.Timestamp 值。
setTimestamp(int, Timestamp, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
setTimestamp(String, Timestamp, Calendar) - 接口 javax.sql.RowSet 中的方法
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
setTimeToLive(int) - 类 java.net.DatagramSocketImpl 中的方法
设置 TTL （生存时间）选项。
setTimeToLive(int) - 类 java.net.MulticastSocket 中的方法
设置在此 MulticastSocket 上发出的多播数据包的默认生存时间，以便控制多播的范围。
setTimeZone(TimeZone) - 类 java.text.DateFormat 中的方法
为此 DateFormat 对象的日历设置时区。
setTimeZone(TimeZone) - 类 java.util.Calendar 中的方法
使用给定的时区值来设置时区。
setTimeZone(TimeZone) - 类 java.util.GregorianCalendar 中的方法
setTimezone(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置时区偏移量中的分钟数。
setTipText(String) - 类 javax.swing.JToolTip 中的方法
设置显示工具提示时要显示的文本。
setTitle(String) - 类 java.awt.Dialog 中的方法
设置 Dialog 的标题。
setTitle(String) - 类 java.awt.Frame 中的方法
将此窗体的标题设置为指定的字符串。
setTitle(String) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题。
setTitle(String) - 类 javax.swing.JInternalFrame 中的方法
设置 JInternalFrame 的标题。
setTitleAt(int, String) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的标题设置为 title，它可以为 null。
setTitleColor(Color) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题颜色。
setTitleFont(Font) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题字体。
setTitleJustification(int) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题对齐方式。
setTitlePosition(int) - 类 javax.swing.border.TitledBorder 中的方法
设置带标题边框的标题位置。
setToggleClickCount(int) - 类 javax.swing.JTree 中的方法
设置节点展开或关闭之前鼠标的单击数。
setToIdentity() - 类 java.awt.geom.AffineTransform 中的方法
将此变换重置为恒等变换。
setTokenThreshold(int) - 类 javax.swing.text.html.HTMLDocument 中的方法
设置在试图更新文档元素结构之前要缓冲的标记数。
setToolTip(String) - 类 java.awt.TrayIcon 中的方法
设置此 TrayIcon 的工具提示字符串。
setToolTipText(String) - 类 javax.swing.JComponent 中的方法
注册要在工具提示中显示的文本。
setToolTipTextAt(int, String) - 类 javax.swing.JTabbedPane 中的方法
将 index 位置的工具提示文本设置为 toolTipText，它可以为 null。
setToPage(int) - 类 java.awt.JobAttributes 中的方法
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的最后一页（包括该页）。
setTopComponent(Component) - 类 javax.swing.JSplitPane 中的方法
将组件设置到分隔条的上面或者左边。
setTopDown(boolean) - 类 javax.imageio.plugins.bmp.BMPImageWriteParam 中的方法
如果设置，则数据以从上到下的方式写出，首先写出第一个扫描行。
setTopInset(float) - 类 javax.swing.text.AsyncBoxView 中的方法
设置视图四周顶部的空白部分。
setToQuadrantRotation(int) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为按指定象限数旋转坐标的旋转变换。
setToQuadrantRotation(int, double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为按指定象限数绕指定锚点旋转坐标的平移旋转变换。
setToRotation(double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为旋转变换。
setToRotation(double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为平移的旋转变换。
setToRotation(double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为根据旋转向量旋转坐标的旋转变换。
setToRotation(double, double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为根据旋转向量绕锚点旋转坐标的旋转变换。
setToScale(double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为缩放变换。
setToShear(double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为错切变换。
setToTranslation(double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为平移变换。
setTrackMute(int, boolean) - 接口 javax.sound.midi.Sequencer 中的方法
设置轨道的静音状态。
setTrackSolo(int, boolean) - 接口 javax.sound.midi.Sequencer 中的方法
设置轨道的 solo 状态。
setTrafficClass(int) - 类 java.net.DatagramSocket 中的方法
为从此 DatagramSocket 上发送的数据报在 IP 数据报头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
setTrafficClass(int) - 类 java.net.Socket 中的方法
为从此 Socket 上发送的包在 IP 头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
setTransactionIsolation(int) - 接口 java.sql.Connection 中的方法
试图将此 Connection 对象的事务隔离级别更改为给定的级别。
setTransactionIsolation(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 JDBC RowSet 对象的事务隔离属性设置为给定的常量。
setTransactionIsolation(int) - 接口 javax.sql.RowSet 中的方法
设置此 RowSet 对象的事务隔离级别。
setTransactionTimeout(int) - 接口 javax.transaction.xa.XAResource 中的方法
为此 XAResource 实例设置当前事务超时值。
setTransferHandler(TransferHandler) - 类 javax.swing.JApplet 中的方法
设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
setTransferHandler(TransferHandler) - 类 javax.swing.JComponent 中的方法
设置 transferHandler 属性；如果该组件不支持数据传输操作，则为 null。
setTransferHandler(TransferHandler) - 类 javax.swing.JDialog 中的方法
设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。
setTransferHandler(TransferHandler) - 类 javax.swing.JFrame 中的方法
设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。
setTransferHandler(TransferHandler) - 类 javax.swing.JWindow 中的方法
设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
setTransform(AffineTransform) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为指定 AffineTransform 对象中变换的副本。
setTransform(double, double, double, double, double, double) - 类 java.awt.geom.AffineTransform 中的方法
将此变换设置为 6 个双精度值指定的矩阵。
setTransform(AffineTransform) - 类 java.awt.Graphics2D 中的方法
重写 Graphics2D 上下文中的 Transform。
setTransform(AffineTransform) - 类 java.awt.image.renderable.RenderContext 中的方法
将 RenderContext 中包含的当前“用户到设备”的 AffineTransform 设置为给定的变换。
setTree(JTree) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
设置当前正在为其编辑的树。
setTrustAnchors(Set<TrustAnchor>) - 类 java.security.cert.PKIXParameters 中的方法
设置最受信任的 CA Set。
setTTL(byte) - 类 java.net.DatagramSocketImpl 中的方法
已过时。 使用 setTimeToLive 代替。
setTTL(byte) - 类 java.net.MulticastSocket 中的方法
已过时。 使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。
setType(int) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的类型设置为指定类型。
setType(int) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的类型设置为给定的类型。
setType(short) - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
设置元素类型。
setType(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的类型。
setTypeMap(Map<String, Class<?>>) - 接口 java.sql.Connection 中的方法
将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。
setTypeMap(Map<String, Class<?>>) - 类 javax.sql.rowset.BaseRowSet 中的方法
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。
setTypeMap(Map<String, Class<?>>) - 接口 javax.sql.RowSet 中的方法
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。
setUI(ButtonUI) - 类 javax.swing.AbstractButton 中的方法
设置呈现此组件的 L&F 对象。
setUI(ColorChooserUI) - 类 javax.swing.JColorChooser 中的方法
设置呈现此组件的 L&F 对象。
setUI(ComboBoxUI) - 类 javax.swing.JComboBox 中的方法
设置呈现此组件的 L&F 对象。
setUI(ComponentUI) - 类 javax.swing.JComponent 中的方法
设置此组件的外观委托。
setUI(DesktopPaneUI) - 类 javax.swing.JDesktopPane 中的方法
设置呈现此组件的 L&F 对象。
setUI(DesktopIconUI) - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
设置呈现此组件的外观对象。
setUI(InternalFrameUI) - 类 javax.swing.JInternalFrame 中的方法
设置此 JInternalFrame 的 UI 委托。
setUI(LabelUI) - 类 javax.swing.JLabel 中的方法
设置呈现此组件的 L&F 对象。
setUI(ListUI) - 类 javax.swing.JList 中的方法
设置呈现此组件的外观对象 ListUI。
setUI(MenuBarUI) - 类 javax.swing.JMenuBar 中的方法
设置呈现此组件的 L&F 对象。
setUI(MenuItemUI) - 类 javax.swing.JMenuItem 中的方法
设置呈现此组件的外观对象。
setUI(OptionPaneUI) - 类 javax.swing.JOptionPane 中的方法
设置实现此组件 L&F 的 UI 对象。
setUI(PanelUI) - 类 javax.swing.JPanel 中的方法
设置呈现此组件的外观 (L&F) 对象。
setUI(PopupMenuUI) - 类 javax.swing.JPopupMenu 中的方法
设置呈现此组件的 L&F 对象。
setUI(ProgressBarUI) - 类 javax.swing.JProgressBar 中的方法
设置呈现此组件的外观对象。
setUI(RootPaneUI) - 类 javax.swing.JRootPane 中的方法
设置呈现此组件的 L&F 对象。
setUI(ScrollBarUI) - 类 javax.swing.JScrollBar 中的方法
设置呈现此组件的 L&F 对象。
setUI(ScrollPaneUI) - 类 javax.swing.JScrollPane 中的方法
设置 ScrollPaneUI 对象，它为此组件提供外观 (L&F)。
setUI(SeparatorUI) - 类 javax.swing.JSeparator 中的方法
设置呈现此组件的 L&F 对象。
setUI(SliderUI) - 类 javax.swing.JSlider 中的方法
设置实现此组件 L&F 的 UI 对象。
setUI(SpinnerUI) - 类 javax.swing.JSpinner 中的方法
设置呈现此组件的外观 (L&F) 对象。
setUI(SplitPaneUI) - 类 javax.swing.JSplitPane 中的方法
设置呈现此组件的 L&F 对象。
setUI(TabbedPaneUI) - 类 javax.swing.JTabbedPane 中的方法
设置实现此组件的 L&F 的 UI 对象。
setUI(TableUI) - 类 javax.swing.JTable 中的方法
设置呈现此组件并进行重新绘制的 L&F 对象。
setUI(ToolBarUI) - 类 javax.swing.JToolBar 中的方法
设置呈现此组件的 L&F 对象。
setUI(TreeUI) - 类 javax.swing.JTree 中的方法
设置呈现此组件的 L&F 对象。
setUI(ViewportUI) - 类 javax.swing.JViewport 中的方法
设置呈现此组件的 L&F 对象。
setUI(TableHeaderUI) - 类 javax.swing.table.JTableHeader 中的方法
设置渲染此组件的 (L&F) 对象。
setUI(TextUI) - 类 javax.swing.text.JTextComponent 中的方法
设置此面向文本的编辑器的用户界面工厂。
setUncaughtExceptionHandler(Thread.UncaughtExceptionHandler) - 类 java.lang.Thread 中的方法
设置该线程由于未捕获到异常而突然终止时调用的处理程序。
setUndecorated(boolean) - 类 java.awt.Dialog 中的方法
禁用或启用此 dialog 的装饰。
setUndecorated(boolean) - 类 java.awt.Frame 中的方法
禁用或启用此窗体的装饰。
setUnderline(boolean) - 类 javax.swing.text.LabelView 中的方法
设置视图是否加下划线。
setUnderline(MutableAttributeSet, boolean) - 类 javax.swing.text.StyleConstants 中的静态方法
设置下标属性。
setUnexecutedModifications(ModificationItem[]) - 异常 javax.naming.directory.AttributeModificationException 中的方法
将未执行的修改列表设置为 e。
setUnicast(boolean) - 类 java.beans.EventSetDescriptor 中的方法
将事件集标记为单播（或非单播）。
setUnicodeStream(int, InputStream, int) - 接口 java.sql.PreparedStatement 中的方法
已过时。
setUnicodeStream(int, InputStream, int) - 类 javax.sql.rowset.BaseRowSet 中的方法
已过时。 应该使用 getCharacterStream 替代它
setUnitIncrement(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的单位值增量。
setUnitIncrement(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的单位增量。
setUnitIncrement(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
setUnitIncrement(int) - 类 javax.swing.JScrollBar 中的方法
设置 unitIncrement 属性。
setUnitIncrement(int) - 类 javax.swing.JScrollPane.ScrollBar 中的方法
通知超类来设定该值，并将 unitIncrementSet 实例变量重置为 true。
setup(FileSystemView) - 类 javax.swing.JFileChooser 中的方法
执行公共的构造方法初始化和设置。
setUpdatePolicy(int) - 类 javax.swing.text.DefaultCaret 中的方法
设置文档更新时的插入符移动策略。
setUpdateRect(Rectangle) - 类 java.awt.event.PaintEvent 中的方法
设置表示需要进行重绘区域以响应此事件的矩形。
setUpdateSelectionOnSort(boolean) - 类 javax.swing.JTable 中的方法
指定排序后是否应该更新选择。
setUpdateTableInRealTime(boolean) - 类 javax.swing.table.JTableHeader 中的方法
从 Java 2 platform v1.3 开始已过时。
setupMenuCloseKey() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setupMenuOpenKey() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setupPostTimer(JMenu) - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
setURI(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的名称空间 URI。
setURIDereferencer(URIDereferencer) - 类 javax.xml.crypto.dom.DOMCryptoContext 中的方法
setURIDereferencer(URIDereferencer) - 接口 javax.xml.crypto.XMLCryptoContext 中的方法
设置用来取消引用 URIReference 的 URIDereferencer。
setURIResolver(URIResolver) - 类 javax.xml.transform.Transformer 中的方法
设置将用于解析在 document() 中使用的 URI 的对象。
setURIResolver(URIResolver) - 类 javax.xml.transform.TransformerFactory 中的方法
设置在转换过程中默认用于解析 document()、xsl:import 或 xsl:include 中所使用的 URI 的对象。
setURL(URL, String, String, int, String, String, String, String, String) - 类 java.net.URLStreamHandler 中的方法
将 URL 参数的字段设置为指示的值。
setURL(URL, String, String, int, String, String) - 类 java.net.URLStreamHandler 中的方法
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);
setURL(String, URL) - 接口 java.sql.CallableStatement 中的方法
将指定参数设置为给定 java.net.URL 对象。
setURL(int, URL) - 接口 java.sql.PreparedStatement 中的方法
将指定参数设置为给定 java.net.URL 值。
setUrl(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 Url 属性设置为给定的 String 对象，并将 dataSource 名称属性设置为 null。
setURL(int, URL) - 类 javax.sql.rowset.BaseRowSet 中的方法
将指定参数设置为给定的 java.net.URL 值。
setUrl(String) - 接口 javax.sql.RowSet 中的方法
设置此 RowSet 对象在使用 DriverManager 创建连接时将使用的 URL。
setURL(int, URL) - 接口 javax.sql.RowSet 中的方法
将指定参数设置为给定的 java.net.URL 值。
setURL(URL) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
在此事件定位符上设置 URL 字段。
setURLStreamHandlerFactory(URLStreamHandlerFactory) - 类 java.net.URL 中的静态方法
设置应用程序的 URLStreamHandlerFactory。
setUsageThreshold(long) - 接口 java.lang.management.MemoryPoolMXBean 中的方法
如果此内存池支持使用量阈值，则将此内存池的阈值设置为给定的 threshold 值。
setUseCache(boolean) - 类 javax.imageio.ImageIO 中的静态方法
设置一个标记，指示在创建 ImageInputStream 和 ImageOutputStream 时是否应该使用基于磁盘的缓存文件。
setUseCaches(boolean) - 类 java.net.URLConnection 中的方法
将此 URLConnection 的 useCaches 字段的值设置为指定的值。
setUseClientMode(boolean) - 类 javax.net.ssl.SSLEngine 中的方法
配置引擎在握手时使用客户端（或服务器）模式。
setUseClientMode(boolean) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制接受的连接是以（默认的）SSL 服务器模式还是在 SSL 客户端模式工作。
setUseClientMode(boolean) - 类 javax.net.ssl.SSLSocket 中的方法
配置套接字在握手时使用客户机（或服务器）模式。
setUseParentHandlers(boolean) - 类 java.util.logging.Logger 中的方法
指定此 logger 是否应该将其输出发送到它的父 Logger。
setUserData(String, Object, UserDataHandler) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
setUserData(Object) - 类 javax.management.Notification 中的方法
设置用户数据。
setUserData(String, Object, UserDataHandler) - 接口 org.w3c.dom.Node 中的方法
将对象与此节点上的键相关联。
setUsername(String) - 类 javax.sql.rowset.BaseRowSet 中的方法
将此 RowSet 对象的 username 属性设置为给定的用户名。
setUsername(String) - 接口 javax.sql.RowSet 中的方法
将此 RowSet 对象的用户名属性设置为给定的 String。
setUserObject(Object) - 类 javax.imageio.metadata.IIOMetadataNode 中的方法
设置与此节点关联的值。
setUserObject(Object) - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
将此节点的用户对象设置为 userObject。
setUserObject(Object) - 接口 javax.swing.tree.MutableTreeNode 中的方法
将接收者的用户对象重新设置为 object。
setValidating(boolean) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
指定 Unmarshaller 是否应该在执行解组操作期间进行验证。
setValidating(boolean) - 接口 javax.xml.bind.Unmarshaller 中的方法
已过时。 从 JAXB2.0 开始，请参阅 Unmarshaller.setSchema(javax.xml.validation.Schema)
setValidating(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
指定由此代码生成的解析器将验证被解析的文档。
setValidating(boolean) - 类 javax.xml.parsers.SAXParserFactory 中的方法
指定由此代码生成的解析器将验证被解析的文档。
setValidCharacters(String) - 类 javax.swing.text.MaskFormatter 中的方法
允许进一步限制可以输入的字符。
setValue(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的当前值。
setValue(int) - 类 java.awt.Scrollbar 中的方法
将此滚动条的值设置为指定值。
setValue(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
将此滚动条的值设置为指定值。
setValue(Object) - 类 java.beans.Expression 中的方法
将此表达式的值设置为 value。
setValue(String, Object) - 类 java.beans.FeatureDescriptor 中的方法
将某一指定属性与此特性相关联。
setValue(Object) - 接口 java.beans.PropertyEditor 中的方法
设置（或更改）将编辑的对象。
setValue(Object) - 类 java.beans.PropertyEditorSupport 中的方法
设置（或更改）将被编辑的对象。
setValue(String) - 类 java.net.HttpCookie 中的方法
在创建 cookie 之后将新值分配给 cookie。
setValue(V) - 类 java.util.AbstractMap.SimpleEntry 中的方法
用指定值替换对应于此项的值。
setValue(V) - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
用指定值替换对应于此项的值（可选操作）。
setValue(V) - 接口 java.util.Map.Entry 中的方法
用指定的值替换与此项对应的值（可选操作）。
setValue(boolean) - 类 javax.sound.sampled.BooleanControl 中的方法
设置控件的当前值。
setValue(Object) - 类 javax.sound.sampled.EnumControl 中的方法
设置控件的当前值。
setValue(float) - 类 javax.sound.sampled.FloatControl 中的方法
设置控件的当前值。
setValue(int) - 接口 javax.swing.BoundedRangeModel 中的方法
如果 newValue 满足模型的约束限制，则将模型的当前值设置为 newValue。
setValue(int) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
设置模型的当前值。
setValue(Object) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
设置此单元格的值。
setValue(Object) - 类 javax.swing.JFormattedTextField 中的方法
设置值，该值由从当前 AbstractFormatterFactory 获得的 AbstractFormatter 进行格式化。
setValue(Object) - 类 javax.swing.JOptionPane 中的方法
设置用户所选值。
setValue(int) - 类 javax.swing.JProgressBar 中的方法
将进度条的当前值设置为 n。
setValue(int) - 类 javax.swing.JScrollBar 中的方法
设置滚动条的值。
setValue(int) - 类 javax.swing.JSlider 中的方法
将滑块的当前值设置为 n。
setValue(Object) - 类 javax.swing.JSpinner 中的方法
更改模型的当前值，通常此值是 editor 所显示的值。
setValue(Object, boolean) - 接口 javax.swing.Renderer 中的方法
指定要显示的值和是否应将该值描绘为“当前选定”。
setValue(Object) - 类 javax.swing.SpinnerDateModel 中的方法
设置此序列的当前 Date。
setValue(Object) - 类 javax.swing.SpinnerListModel 中的方法
改变该序列的当前元素并通知 ChangeListeners。
setValue(Object) - 接口 javax.swing.SpinnerModel 中的方法
改变该模型的当前值，通常此值由 JSpinner 的 editor 部分显示。
setValue(Object) - 类 javax.swing.SpinnerNumberModel 中的方法
设置此序列的当前元素。
setValue(int) - 类 javax.swing.Spring 中的方法
将此 Spring 的当前 value 设置为 value。
setValue(Object) - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
将要呈现的单元格的 String 对象设置为 value。
setValue(T) - 类 javax.xml.bind.JAXBElement 中的方法
设置此 xml 元素的内容模式和属性。
setValue(String) - 接口 javax.xml.soap.Node 中的方法
如果这是一个 Text 节点，则此方法会设置它的值，否则该方法设置此节点的直接 (Text) 子节点值。
setValue(String) - 接口 org.w3c.dom.Attr 中的方法
检索时，该属性值以字符串形式返回。
setValue(int, String) - 类 org.xml.sax.helpers.AttributesImpl 中的方法
设置特定属性的值。
setValueAt(Object, int, int) - 类 javax.swing.JTable 中的方法
设置表模型中 row 和 column 位置的单元格值。
setValueAt(Object, int, int) - 类 javax.swing.table.AbstractTableModel 中的方法
由于提供了此空实现，因此，如果用户的数据模型是不可编辑的，则他们不必实现此方法。
setValueAt(Object, int, int) - 类 javax.swing.table.DefaultTableModel 中的方法
设置 column 和 row 处单元格的对象值。
setValueAt(Object, int, int) - 接口 javax.swing.table.TableModel 中的方法
将 columnIndex 和 rowIndex 位置的单元格中的值设置为 aValue。
setValueClass(Class<?>) - 类 javax.swing.text.DefaultFormatter 中的方法
设置用于创建新 Objects 的类。
setValueContainsLiteralCharacters(boolean) - 类 javax.swing.text.MaskFormatter 中的方法
如果为 true，则返回的值和设置的值还将包含掩码中的字面值字符。
setValueIsAdjusting(boolean) - 类 java.awt.Scrollbar 中的方法
设置 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 类 java.awt.ScrollPaneAdjustable 中的方法
设置 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 接口 javax.swing.BoundedRangeModel 中的方法
此属性指示，即将对模型值所做的任何更改都应被认为是一个单独的事件。
setValueIsAdjusting(boolean) - 类 javax.swing.DefaultBoundedRangeModel 中的方法
设置 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 类 javax.swing.DefaultListSelectionModel 中的方法
设置 valueIsAdjusting 属性，指示即将进行的选择更改是否应该被视为单个更改的一部分。
setValueIsAdjusting(boolean) - 类 javax.swing.JList 中的方法
设置选择模型的 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 类 javax.swing.JScrollBar 中的方法
设置模型的 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 类 javax.swing.JSlider 中的方法
设置模型的 valueIsAdjusting 属性。
setValueIsAdjusting(boolean) - 接口 javax.swing.ListSelectionModel 中的方法
设置 valueIsAdjusting 属性，指示即将进行的选择更改是否应该被视为单个更改的一部分。
setValues(int, int, int, int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的四个属性值：value、visibleAmount、minimum 和 maximum。
setValues(int, int, int, int) - 类 javax.swing.JScrollBar 中的方法
强制参数满足以下常规约束后设置四个 BoundedRangeModel 属性：
setVerbose(boolean) - 接口 java.lang.management.ClassLoadingMXBean 中的方法
为类加载系统启用或禁用 verbose 输出。
setVerbose(boolean) - 接口 java.lang.management.MemoryMXBean 中的方法
启用或禁用内存系统的 verbose 输出。
setVerifyInputWhenFocusTarget(boolean) - 类 javax.swing.JComponent 中的方法
设置该值指示是否在此组件请求焦点前，为当前的焦点所有者调用输入校验器。
setVersion(int) - 类 java.net.HttpCookie 中的方法
设置此 cookie 遵守的 cookie 协议版本。
setVerticalAlignment(int) - 类 javax.swing.AbstractButton 中的方法
设置图标和文本的垂直对齐方式。
setVerticalAlignment(int) - 类 javax.swing.JLabel 中的方法
设置标签内容沿 Y 轴的对齐方式。
setVerticalGroup(GroupLayout.Group) - 类 javax.swing.GroupLayout 中的方法
设置沿垂直轴确定组件位置和大小的 Group。
setVerticalScrollBar(JScrollBar) - 类 javax.swing.JScrollPane 中的方法
将控制视口垂直视图位置的滚动条添加到滚动窗格中。
setVerticalScrollBarPolicy(int) - 类 javax.swing.JScrollPane 中的方法
确定垂直滚动条何时显示在滚动窗格上。
setVerticalScrollBarPolicy(int) - 类 javax.swing.ScrollPaneLayout 中的方法
设置垂直滚动条的显示策略。
setVerticalTextPosition(int) - 类 javax.swing.AbstractButton 中的方法
设置文本相对于图标的垂直位置。
setVerticalTextPosition(int) - 类 javax.swing.JLabel 中的方法
设置标签的文本相对其图像的垂直位置。
setVgap(int) - 类 java.awt.BorderLayout 中的方法
设置组件之间的垂直间距。
setVgap(int) - 类 java.awt.CardLayout 中的方法
设置组件之间的垂直间距。
setVgap(int) - 类 java.awt.FlowLayout 中的方法
设置组件之间以及组件与 Container 的边之间的垂直间隙。
setVgap(int) - 类 java.awt.GridLayout 中的方法
将组件之间的垂直间距设置为指定值。
setView(Component) - 类 javax.swing.JViewport 中的方法
设置 JViewport 的一个轻量子对象 (view)，可以为 null。
setView(View) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
设置视图层次结构的当前根并调用 invalidate()。
setViewport(JViewport) - 类 javax.swing.JScrollPane 中的方法
移除旧视口（如果有）；强制新视口的 viewPosition 位于 +x,+y 象限中；将行和列标题（如果有）与新视口同步；最后将滚动条和标题与新视口同步。
setViewportBorder(Border) - 类 javax.swing.JScrollPane 中的方法
围绕视口添加一个边界。
setViewportView(Component) - 类 javax.swing.JScrollPane 中的方法
创建一个视口（如果有必要）并设置其视图。
setViewPosition(Point) - 类 javax.swing.JViewport 中的方法
设置显示在视口左上角的视图坐标，如果不存在视图，则不执行任何操作。
setViewSize(Dimension) - 类 javax.swing.JViewport 中的方法
设置视图的大小。
setVisible(boolean) - 类 java.awt.Component.AccessibleAWTComponent 中的方法
设置此对象的可见状态。
setVisible(boolean) - 类 java.awt.Component 中的方法
根据参数 b 的值显示或隐藏此组件。
setVisible(boolean) - 类 java.awt.Dialog 中的方法
根据参数 b 的值显示或隐藏此 Dialog。
setVisible(boolean) - 类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 中的方法
设置对象的可见状态。
setVisible(boolean) - 类 java.awt.MenuComponent.AccessibleAWTMenuComponent 中的方法
设置该对象的可见状态。
setVisible(boolean) - 类 java.awt.Window 中的方法
根据参数 b 的值显示或隐藏此 Window。
setVisible(boolean) - 接口 javax.accessibility.AccessibleComponent 中的方法
设置对象的可见状态。
setVisible(boolean) - 类 javax.swing.JComponent 中的方法
使该组件可见或不可见。
setVisible(boolean) - 类 javax.swing.JList.AccessibleJList.AccessibleJListChild 中的方法
setVisible(boolean) - 类 javax.swing.JPopupMenu 中的方法
设置弹出菜单的可见性。
setVisible(boolean) - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableCell 中的方法
设置该对象的可见状态。
setVisible(boolean) - 类 javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode 中的方法
setVisible(boolean) - 类 javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 中的方法
setVisible(boolean) - 接口 javax.swing.text.Caret 中的方法
设置插入符的可见性。
setVisible(boolean) - 类 javax.swing.text.DefaultCaret 中的方法
设置插入符可见性，并重绘插入符。
setVisibleAmount(int) - 接口 java.awt.Adjustable 中的方法
设置可调整对象的比例指示器的长度。
setVisibleAmount(int) - 类 java.awt.Scrollbar 中的方法
设置此滚动条的可见量。
setVisibleAmount(int) - 类 java.awt.ScrollPaneAdjustable 中的方法
此方法不应由用户代码调用。
setVisibleAmount(int) - 类 javax.swing.JScrollBar 中的方法
设置模型的 extent 属性。
setVisibleComponent(Component) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
setVisibleRowCount(int) - 类 javax.swing.JList 中的方法
设置 visibleRowCount 属性，对于不同的布局方向，此方法有不同的含义：对于 VERTICAL 布局方向，此方法设置要显示的首选行数（不要求滚动）；对于其他方向，它影响单元的包装。
setVisibleRowCount(int) - 类 javax.swing.JTree 中的方法
设置要显示的行数。
setWantClientAuth(boolean) - 类 javax.net.ssl.SSLEngine 中的方法
配置引擎请求 客户端验证。
setWantClientAuth(boolean) - 类 javax.net.ssl.SSLParameters 中的方法
设置是否应该请求客户机验证。
setWantClientAuth(boolean) - 类 javax.net.ssl.SSLServerSocket 中的方法
控制 accept 服务器模式的 SSLSockets 是否将在开始时配置为请求 客户端验证。
setWantClientAuth(boolean) - 类 javax.net.ssl.SSLSocket 中的方法
配置套接字请求 客户机验证。
setWantsInput(boolean) - 类 javax.swing.JOptionPane 中的方法
设置 wantsInput 属性。
setWasIcon(JInternalFrame, Boolean) - 类 javax.swing.DefaultDesktopManager 中的方法
设定组件已被图标化并且 desktopIcon 的边界是有效的。
setWeekdays(String[]) - 类 java.text.DateFormatSymbols 中的方法
设置星期字符串。
setWestPane(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
setWheelScrollingEnabled(boolean) - 类 java.awt.ScrollPane 中的方法
启用/禁用对鼠标滚轮滚动的移动响应。
setWheelScrollingEnabled(boolean) - 类 javax.swing.JScrollPane 中的方法
启用/禁用对鼠标滚轮滚动的移动响应。
setWidth(Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置 width 属性，该属性控制组件的宽度。
setWidth(int) - 类 javax.swing.table.TableColumn 中的方法
不应使用此方法来设置 JTable 中列的宽度，而应使用 setPreferredWidth。
setWindingRule(int) - 类 java.awt.geom.Path2D 中的方法
将此路径的旋绕规则设置为指定值。
setWindowDecorationStyle(int) - 类 javax.swing.JRootPane 中的方法
设置 JRootPane 应提供的 Window 装饰类型（例如，边界、关闭 Window 的小部件、标题等）。
setWrapStyleWord(boolean) - 类 javax.swing.JTextArea 中的方法
设置换行方式（如果文本区要换行）。
setWritable(boolean, boolean) - 类 java.io.File 中的方法
设置此抽象路径名的所有者或所有用户的写权限。
setWritable(boolean) - 类 java.io.File 中的方法
设置此抽象路径名所有者写权限的一个便捷方法。
setWriteMethod(Method) - 类 java.beans.PropertyDescriptor 中的方法
设置应该用于写入属性值的方法。
setWriter(Writer) - 接口 javax.script.ScriptContext 中的方法
设置脚本的 Writer，以便在显示输出时使用。
setWriter(Writer) - 类 javax.script.SimpleScriptContext 中的方法
设置脚本的 Writer，以便在显示输出时使用。
setWriter(Writer) - 类 javax.xml.transform.stream.StreamResult 中的方法
设置要接收结果的 writer。
setX(Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置 x 属性，该属性控制组件位置的 x 值。
setXIncludeAware(boolean) - 类 javax.xml.parsers.DocumentBuilderFactory 中的方法
设置 XInclude 处理的状态。
setXIncludeAware(boolean) - 类 javax.xml.parsers.SAXParserFactory 中的方法
设置 XInclude 处理的状态。
setXMLReader(XMLReader) - 类 javax.xml.transform.sax.SAXSource 中的方法
设置要用于 Source 的 XMLReader。
setXMLReporter(XMLReporter) - 类 javax.xml.stream.XMLInputFactory 中的方法
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的报告器。
setXMLResolver(XMLResolver) - 类 javax.xml.stream.XMLInputFactory 中的方法
要在此工厂实例创建的任何 XMLStreamReader 或 XMLEventReader 上进行设置的解析器。
setXmlStandalone(boolean) - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明 的一部分指定此文档是否是单独的的属性。
setXmlVersion(String) - 接口 org.w3c.dom.Document 中的方法
作为 XML 声明 的一部分指定此文档版本号的属性。
setXMLVersion(String) - 类 org.xml.sax.ext.Locator2Impl 中的方法
分配版本属性的当前值。
setXORMode(Color) - 类 java.awt.Graphics 中的方法
将此图形上下文的绘图模式设置为在此图形上下文的当前颜色和新的指定颜色之间交替。
setXORMode(Color) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.setXORMode。
setXPathFunctionResolver(XPathFunctionResolver) - 接口 javax.xml.xpath.XPath 中的方法
建立函数解析器。
setXPathFunctionResolver(XPathFunctionResolver) - 类 javax.xml.xpath.XPathFactory 中的方法
建立默认函数解析器。
setXPathVariableResolver(XPathVariableResolver) - 接口 javax.xml.xpath.XPath 中的方法
建立变量解析器。
setXPathVariableResolver(XPathVariableResolver) - 类 javax.xml.xpath.XPathFactory 中的方法
建立默认变量解析器。
setY(Spring) - 类 javax.swing.SpringLayout.Constraints 中的方法
设置 y 属性，该属性控制组件位置的 y 值。
setYear(int) - 类 java.sql.Time 中的方法
已过时。
setYear(int) - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.YEAR, year + 1900) 取代。
setYear(BigInteger) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置 XSD dateTime year 字段的低和高顺序组件。
setYear(int) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
设置 XSD dateTime year 字段的年。
setZeroDigit(char) - 类 java.text.DecimalFormatSymbols 中的方法
设置用于零的字符。
setZoneStrings(String[][]) - 类 java.text.DateFormatSymbols 中的方法
设置时区字符串。
SEVERE - 类 java.util.logging.Level 中的静态变量
SEVERE 是指示严重失败的消息级别。
severe(String) - 类 java.util.logging.Logger 中的方法
记录一条 SEVERE 消息。
Severity - javax.print.attribute.standard 中的 类
Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
Severity(int) - 类 javax.print.attribute.standard.Severity 的构造方法
构造具有给定整数值的新 Severity 枚举值。
SEVERITY_ERROR - 接口 org.w3c.dom.DOMError 中的静态变量
DOMError 描述的错误的严重性为错误。
SEVERITY_FATAL_ERROR - 接口 org.w3c.dom.DOMError 中的静态变量
DOMError 描述的错误的严重性为严重错误。
SEVERITY_WARNING - 接口 org.w3c.dom.DOMError 中的静态变量
DOMError 描述的错误的严重性为警告。
SHA1 - 类 java.security.spec.MGF1ParameterSpec 中的静态变量
使用“SHA-1”消息摘要的 MGF1ParameterSpec。
SHA1 - 接口 javax.xml.crypto.dsig.DigestMethod 中的静态变量
SHA1 摘要方法的算法 URI。
SHA256 - 类 java.security.spec.MGF1ParameterSpec 中的静态变量
使用“SHA-256”消息摘要的 MGF1ParameterSpec。
SHA256 - 接口 javax.xml.crypto.dsig.DigestMethod 中的静态变量
SHA256 摘要方法的算法 URI。
SHA384 - 类 java.security.spec.MGF1ParameterSpec 中的静态变量
使用“SHA-384”消息摘要的 MGF1ParameterSpec。
SHA512 - 类 java.security.spec.MGF1ParameterSpec 中的静态变量
使用 SHA-512 消息摘要的 MGF1ParameterSpec。
SHA512 - 接口 javax.xml.crypto.dsig.DigestMethod 中的静态变量
SHA512 摘要方法的算法 URI。
shadow - 类 javax.swing.border.EtchedBorder 中的变量
shadow - 类 javax.swing.plaf.basic.BasicBorders.ButtonBorder 中的变量
shadow - 类 javax.swing.plaf.basic.BasicBorders.FieldBorder 中的变量
shadow - 类 javax.swing.plaf.basic.BasicBorders.SplitPaneBorder 中的变量
shadow - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的变量
shadow - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
shadowInner - 类 javax.swing.border.BevelBorder 中的变量
shadowOuter - 类 javax.swing.border.BevelBorder 中的变量
shallowClone() - 类 java.awt.image.renderable.ParameterBlock 中的方法
创建 ParameterBlock 的一个浅表副本。
shape(char[], int, int) - 类 java.awt.font.NumericShaper 中的方法
转换文本中在 start 和 start + count 之间出现的数字。
shape(char[], int, int, int) - 类 java.awt.font.NumericShaper 中的方法
使用提供的上下文，转换文本中在 start 和 start + count 之间出现的数字。
Shape - java.awt 中的 接口
Shape 接口提供了表示一些几何形状的对象的定义。
SHAPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
ShapeGraphicAttribute - java.awt.font 中的 类
ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。
ShapeGraphicAttribute(Shape, int, boolean) - 类 java.awt.font.ShapeGraphicAttribute 的构造方法
针对指定 Shape 构造 ShapeGraphicAttribute。
SHAPES - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
sharedInstance - 类 javax.swing.JTree.EmptySelectionModel 中的静态变量
独有的共享实例。
sharedInstance() - 类 javax.swing.JTree.EmptySelectionModel 中的静态方法
返回空选择模型的共享实例。
sharedInstance() - 类 javax.swing.ToolTipManager 中的静态方法
返回共享的 ToolTipManager 实例。
SHAVIAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Shavian”Unicode 字符块的常量。
shear(double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与错切变换。
shear(double, double) - 类 java.awt.Graphics2D 中的方法
将当前 Graphics2D Transform 与剪裁转换连接。
SheetCollate - javax.print.attribute.standard 中的 类
SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
SheetCollate(int) - 类 javax.print.attribute.standard.SheetCollate 的构造方法
构造具有给定整数值的新 SheetCollate 枚举值。
shift(float, float, int) - 类 javax.sound.sampled.FloatControl 中的方法
在整个指定的时间内线性地将控件值从初始值更改为最终值，以微秒为单位进行指定。
SHIFT_DOWN_MASK - 类 java.awt.event.InputEvent 中的静态变量
Shift 键的扩展修饰符常量。
SHIFT_MASK - 类 java.awt.event.ActionEvent 中的静态变量
shift 修饰符。
SHIFT_MASK - 类 java.awt.event.InputEvent 中的静态变量
Shift 键修饰符常量。
SHIFT_MASK - 类 java.awt.Event 中的静态变量
此标志指示当事件发生时按下 Shift 键。
shiftDown() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
shiftEnd(int) - 类 javax.swing.text.GapContent 中的方法
扩大间隙、移动任何必要的数据和更新适当的标记。
shiftGap(int) - 类 javax.swing.text.GapContent 中的方法
将间隙的起始点移动到新位置，而不更改间隙的大小。
shiftGapEndUp(int) - 类 javax.swing.text.GapContent 中的方法
调整间隙，使其结尾向前扩展。
shiftGapStartDown(int) - 类 javax.swing.text.GapContent 中的方法
调整间隙，使其结尾向后扩展。
shiftLeft(int) - 类 java.math.BigInteger 中的方法
返回其值为 (this << n) 的 BigInteger。
shiftRight(int) - 类 java.math.BigInteger 中的方法
返回其值为 (this >> n) 的 BigInteger。
Short - java.lang 中的 类
Short 类在对象中包装基本类型 short 的值。
Short(short) - 类 java.lang.Short 的构造方法
构造一个新分配的 Short 对象，用来表示指定的 short 值。
Short(String) - 类 java.lang.Short 的构造方法
构造一个新分配的 Short 对象，用来表示 String 参数所指示的 short 值。
SHORT - 类 java.text.DateFormat 中的静态变量
用于 SHORT 模式的常量。
SHORT - 类 java.util.Calendar 中的静态变量
指示短名称的 getDisplayName 和 getDisplayNames 的风格说明符，比如 "Jan"。
SHORT - 类 java.util.TimeZone 中的静态变量
指出短名称（比如 "PST"）的 getDisplayName() 的风格说明符。
SHORT - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Short 的值。
SHORT_DESCRIPTION - 接口 javax.swing.Action 中的静态变量
用来存储动作的简短 String 描述的键，用于工具提示文本。
ShortBuffer - java.nio 中的 类
short 缓冲区。
ShortBufferException - javax.crypto 中的 异常
当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。
ShortBufferException() - 异常 javax.crypto.ShortBufferException 的构造方法
构造不带详细信息的 ShortBufferException。
ShortBufferException(String) - 异常 javax.crypto.ShortBufferException 的构造方法
构造带指定详细信息的 ShortBufferException。
shortcuts() - 类 java.awt.MenuBar 中的方法
获取此菜单栏正在管理的所有菜单快捷方式的枚举。
ShortHolder - org.omg.CORBA 中的 类
Short 的 Holder。
ShortHolder() - 类 org.omg.CORBA.ShortHolder 的构造方法
构造一个新的 ShortHolder 对象，将其 value 字段初始化为 0。
ShortHolder(short) - 类 org.omg.CORBA.ShortHolder 的构造方法
构造一个新的 ShortHolder 对象，并使用给定 short 值初始化其 value 字段。
ShortLookupTable - java.awt.image 中的 类
此类定义了一个查找表对象。
ShortLookupTable(int, short[][]) - 类 java.awt.image.ShortLookupTable 的构造方法
根据表示每个 band 的查找表的 short 型数组的数组构造 ShortLookupTable 对象。
ShortLookupTable(int, short[]) - 类 java.awt.image.ShortLookupTable 的构造方法
根据表示每个 band 的查找表的 short 型数组构造 ShortLookupTable 对象。
ShortMessage - javax.sound.midi 中的 类
ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。
ShortMessage() - 类 javax.sound.midi.ShortMessage 的构造方法
构造一个新的 ShortMessage。
ShortMessage(byte[]) - 类 javax.sound.midi.ShortMessage 的构造方法
构造一个新的 ShortMessage。
ShortSeqHelper - org.omg.CORBA 中的 类
ShortSeqHelper 的 Helper。
ShortSeqHelper() - 类 org.omg.CORBA.ShortSeqHelper 的构造方法
ShortSeqHolder - org.omg.CORBA 中的 类
ShortSeq 的 Holder。
ShortSeqHolder() - 类 org.omg.CORBA.ShortSeqHolder 的构造方法
ShortSeqHolder(short[]) - 类 org.omg.CORBA.ShortSeqHolder 的构造方法
shortValue() - 类 java.lang.Byte 中的方法
作为一个 short 返回此 Byte 的值。
shortValue() - 类 java.lang.Double 中的方法
以 short 形式返回此 Double 的值（通过强制转换为 short）。
shortValue() - 类 java.lang.Float 中的方法
将此 Float 值以 short 形式返回（强制转换为 short）。
shortValue() - 类 java.lang.Integer 中的方法
以 short 类型返回该 Integer 的值。
shortValue() - 类 java.lang.Long 中的方法
以 short 形式返回此 Long 的值。
shortValue() - 类 java.lang.Number 中的方法
以 short 形式返回指定的数值。
shortValue() - 类 java.lang.Short 中的方法
以 short 形式返回此 Short 的值。
shortValueExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 short，以检查丢失的信息。
shouldAccept(URI, HttpCookie) - 接口 java.net.CookiePolicy 中的方法
调用此方法查看此 cookie 是否应该被接受。
shouldFillGap(int, int, int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
shouldPadTabRun(int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
shouldPadTabRun(int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
shouldPaintExpandControl(TreePath, int, boolean, boolean, boolean) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果应该为指定行绘制展开（切换）控件，则返回 true。
shouldRotateTabRuns(int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
shouldRotateTabRuns(int, int) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
shouldScroll(int) - 类 javax.swing.plaf.basic.BasicSliderUI.TrackListener 中的方法
shouldSelectCell(EventObject) - 类 javax.swing.AbstractCellEditor 中的方法
返回 true。
shouldSelectCell(EventObject) - 接口 javax.swing.CellEditor 中的方法
如果应该选择正编辑的单元格，则返回 true，否则返回 false。
shouldSelectCell(EventObject) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
返回 true 指示可能选定正编辑的单元格。
shouldSelectCell(EventObject) - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
shouldSelectCell(EventObject) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
针对返回值，向 realEditor 发送消息。
shouldStartEditingTimer(EventObject) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果 event 为 MouseEvent，并且单击计数为 1，则返回 true。
shouldUpdateStyleOnAncestorChanged() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
返回在 JComponent 的祖先发生更改时，UI 是否应该更新 SynthStyleFactory 中的 SynthStyles。
shouldYieldFocus(JComponent) - 类 javax.swing.InputVerifier 中的方法
调用 verify(input) 来确保输入是有效的。
show(Container, String) - 类 java.awt.CardLayout 中的方法
翻转到使用 addLayoutComponent 添加到此布局的具有指定 name 的组件。
show() - 类 java.awt.Component.BltBufferStrategy 中的方法
使下一个有效缓冲区可见。
show() - 类 java.awt.Component.FlipBufferStrategy 中的方法
通过位图传送或翻转，使下一个可用的缓冲区可见。
show() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
show(boolean) - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
show() - 类 java.awt.Dialog 中的方法
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
show() - 类 java.awt.image.BufferStrategy 中的方法
通过复制内存（位图传输）或更改显示指针（翻转）使下一个可用缓冲区可见。
show(Component, int, int) - 类 java.awt.PopupMenu 中的方法
在相对于初始组件的 x、y 位置上显示弹出式菜单。
show() - 类 java.awt.Window 中的方法
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
show() - 类 javax.swing.JInternalFrame 中的方法
如果内部窗体不可见，则将该内部窗体置于前端，使其可见并尝试选定它。
show(Component, int, int) - 类 javax.swing.JPopupMenu 中的方法
在组件调用者的坐标空间中的位置 X、Y 显示弹出菜单。
show() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
ComboPopup.show() 的实现。
show() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
显示弹出菜单
show() - 类 javax.swing.Popup 中的方法
使 Popup 可见。
showConfirmDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。
showConfirmDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
调出一个由 optionType 参数确定其中选项数的对话框。
showConfirmDialog(Component, Object, String, int, int) - 类 javax.swing.JOptionPane 中的静态方法
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。
showConfirmDialog(Component, Object, String, int, int, Icon) - 类 javax.swing.JOptionPane 中的静态方法
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
showDialog(Component, String, Color) - 类 javax.swing.JColorChooser 中的静态方法
显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。
showDialog(Component, String) - 类 javax.swing.JFileChooser 中的方法
弹出具有自定义 approve 按钮的自定义文件选择器对话框。
showDocument(URL) - 接口 java.applet.AppletContext 中的方法
请求浏览器或 applet viewer 显示 url 参数指示的 Web 页面。
showDocument(URL, String) - 接口 java.applet.AppletContext 中的方法
请求浏览器或 applet viewer 显示由 url 参数所指示的 Web 页。
showHorizontalLines - 类 javax.swing.JTable 中的变量
如果 showHorizontalLines 为 true，则表在单元格之间绘制水平行。
SHOWING - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象、此对象的父对象、其父对象的父对象等都是可见的。
SHOWING_CHANGED - 类 java.awt.event.HierarchyEvent 中的静态变量
指示 HIERARCHY_CHANGED 事件是因为层次结构的显示状态发生更改而生成的。
showInputDialog(Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入的问题消息对话框。
showInputDialog(Object, Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入的问题消息对话框，它带有已初始化为 initialSelectionValue 的输入值。
showInputDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
showInputDialog(Component, Object, Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
showInputDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。
showInputDialog(Component, Object, String, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 中的静态方法
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
showInternalConfirmDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
调出带有选项 Yes、No 和 Cancel 的内部对话框面板；标题为 Select an Option。
showInternalConfirmDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
调出一个由 optionType 参数确定其中选项数的内部对话框面板。
showInternalConfirmDialog(Component, Object, String, int, int) - 类 javax.swing.JOptionPane 中的静态方法
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。
showInternalConfirmDialog(Component, Object, String, int, int, Icon) - 类 javax.swing.JOptionPane 中的静态方法
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。
showInternalInputDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。
showInternalInputDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。
showInternalInputDialog(Component, Object, String, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 中的静态方法
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。
showInternalMessageDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
调出内部确认对话框面板。
showInternalMessageDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。
showInternalMessageDialog(Component, Object, String, int, Icon) - 类 javax.swing.JOptionPane 中的静态方法
调出一个显示消息的内部对话框面板，为其指定了所有参数。
showInternalOptionDialog(Component, Object, String, int, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 中的静态方法
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
showMessageDialog(Component, Object) - 类 javax.swing.JOptionPane 中的静态方法
调出标题为 "Message" 的信息消息对话框。
showMessageDialog(Component, Object, String, int) - 类 javax.swing.JOptionPane 中的静态方法
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。
showMessageDialog(Component, Object, String, int, Icon) - 类 javax.swing.JOptionPane 中的静态方法
调出一个显示信息的对话框，为其指定了所有参数。
showOpenDialog(Component) - 类 javax.swing.JFileChooser 中的方法
弹出一个 "Open File" 文件选择器对话框。
showOptionDialog(Component, Object, String, int, int, Icon, Object[], Object) - 类 javax.swing.JOptionPane 中的静态方法
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
showPopup() - 类 javax.swing.JComboBox 中的方法
促使组合框显示其弹出窗口。
SHOWS_ROOT_HANDLES_PROPERTY - 类 javax.swing.JTree 中的静态变量
showsRootHandles 的绑定属性名称。
showSaveDialog(Component) - 类 javax.swing.JFileChooser 中的方法
弹出一个 "Save File" 文件选择器对话框。
showsRootHandles - 类 javax.swing.JTree 中的变量
如果在树的最高层显示句柄，则为 True。
showStatus(String) - 类 java.applet.Applet 中的方法
请求将参数字符串显示在“状态窗口”中。
showStatus(String) - 接口 java.applet.AppletContext 中的方法
请求参数字符串显示在“状态窗口”中。
showSystemMenu() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
showSystemMenu() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
重写父级的方法，使其不执行任何操作。
showVerticalLines - 类 javax.swing.JTable 中的变量
如果 showVerticalLines 为 true，则表在单元格之间绘制垂直行。
shrinkAbsorb - 类 java.awt.font.GlyphJustificationInfo 中的变量
如果为 true，那么当此字形缩小时，它会占有此 priority 和更低 priority 的所有剩余收缩量。
shrinkLeftLimit - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形左边可以收缩的最大量（一个正数）。
shrinkPriority - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形缩小时的 priority 级别。
shrinkRightLimit - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形右边可以收缩的最大量（一个正数）。
shuffle(List<?>) - 类 java.util.Collections 中的静态方法
使用默认随机源对指定列表进行置换。
shuffle(List<?>, Random) - 类 java.util.Collections 中的静态方法
使用指定的随机源对指定列表进行置换。
shutdown() - 接口 java.rmi.activation.ActivationSystem 中的方法
关闭此激活系统。
shutdown() - 接口 java.util.concurrent.ExecutorService 中的方法
启动一次顺序关闭，执行以前提交的任务，但不接受新任务。
shutdown() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
在以前已提交任务的执行中发起一个有序的关闭，但是不接受新任务。
shutdown() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
按过去执行已提交任务的顺序发起一个有序的关闭，但是不接受新任务。
SHUTDOWN - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
已经从服务中移除了打印机，并且可以给该打印机断电或者物理移除它。
shutdown(boolean) - 类 org.omg.CORBA.ORB 中的方法
指示关闭 ORB，这将导致关闭所有对象适配器，以准备销毁。
shutdownInput() - 类 java.net.Socket 中的方法
此套接字的输入流置于“流的末尾”。
shutdownInput() - 类 java.net.SocketImpl 中的方法
将此套接字的输入流置于“流的末尾”。
shutdownNow() - 接口 java.util.concurrent.ExecutorService 中的方法
试图停止所有正在执行的活动任务，暂停处理正在等待的任务，并返回等待执行的任务列表。
shutdownNow() - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
尝试停止所有正在执行的任务、暂停等待任务的处理，并返回等待执行的任务列表。
shutdownNow() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
尝试停止所有的活动执行任务、暂停等待任务的处理，并返回等待执行的任务列表。
shutdownOutput() - 类 java.net.Socket 中的方法
禁用此套接字的输出流。
shutdownOutput() - 类 java.net.SocketImpl 中的方法
禁用此套接字的输出流。
SIDE - 类 javax.print.attribute.standard.MediaTray 中的静态变量
侧面进纸托盘。
Sides - javax.print.attribute.standard 中的 类
Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。
Sides(int) - 类 javax.print.attribute.standard.Sides 的构造方法
构造具有给定整数值的新 sides 枚举值，
SIGN - 类 java.security.Signature 中的静态变量
可能的 Signature.state 值，表示此签名对象已经初始化签名。
sign() - 类 java.security.Signature 中的方法
返回所有已更新数据的签名字节。
sign(byte[], int, int) - 类 java.security.Signature 中的方法
完成签名操作并从 offset 开始，将得到的签名字节存储在提供的缓冲区 outbuf 中。
SIGN - 类 java.text.NumberFormat.Field 中的静态变量
标识符号字段的常量。
sign(XMLSignContext) - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
为此 XMLSignature 签名。
SIGN - 类 javax.xml.crypto.KeySelector.Purpose 中的静态变量
用于签名的密钥。
signal() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
将等待时间最长的线程（如果有）从此条件的等待队列移动到拥有锁的等待队列。
signal() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
将等待时间最长的线程（如果存在）从此条件的等待队列中移动到拥有锁的等待队列。
signal() - 接口 java.util.concurrent.locks.Condition 中的方法
唤醒一个等待线程。
signalAll() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 中的方法
将所有线程从此条件的等待队列移动到拥有锁的等待队列。
signalAll() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 中的方法
将所有线程从此条件的等待队列移动到拥有锁的等待队列中。
signalAll() - 接口 java.util.concurrent.locks.Condition 中的方法
唤醒所有等待线程。
Signature - java.security 中的 类
此 Signature 类用来为应用程序提供数字签名算法功能。
Signature(String) - 类 java.security.Signature 的构造方法
创建指定算法的 Signature 对象。
SIGNATURE_VERSION - 类 java.util.jar.Attributes.Name 中的静态变量
Signature-Version 的 Name 对象给出了签名 JAR 文件时所使用的属性。
SignatureException - java.security 中的 异常
这是一般的签名异常。
SignatureException() - 异常 java.security.SignatureException 的构造方法
构造不带详细消息的 SignatureException。
SignatureException(String) - 异常 java.security.SignatureException 的构造方法
构造带指定详细消息的 SignatureException。
SignatureException(String, Throwable) - 异常 java.security.SignatureException 的构造方法
创建带指定详细消息和原因的 SignatureException。
SignatureException(Throwable) - 异常 java.security.SignatureException 的构造方法
创建带指定的原因和详细消息的 SignatureException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
SignatureMethod - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureMethod 元素的表示形式。
SignatureMethodParameterSpec - javax.xml.crypto.dsig.spec 中的 接口
用于 XML SignatureMethod 算法的算法参数规范。
SignatureProperties - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperties 元素的表示形式。
SignatureProperty - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureProperty 元素的表示形式。
SignatureSpi - java.security 中的 类
此类为 Signature 类定义了服务提供者接口 (SPI)，可用来提供数字签名算法功能。
SignatureSpi() - 类 java.security.SignatureSpi 的构造方法
SignedInfo - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignedInfo 元素的表示形式。
SignedObject - java.security 中的 类
SignedObject 是一个用来创建实际运行时对象的类，在检测不到这些对象的情况下，其完整性不会遭受损害。
SignedObject(Serializable, PrivateKey, Signature) - 类 java.security.SignedObject 的构造方法
通过任何可序列化对象构造 SignedObject。
Signer - java.security 中的 类
已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。
Signer() - 类 java.security.Signer 的构造方法
已过时。 创建 signer。
Signer(String) - 类 java.security.Signer 的构造方法
已过时。 创建带有指定标识名称的 signer。
Signer(String, IdentityScope) - 类 java.security.Signer 的构造方法
已过时。 创建带有指定标识名称和范围的 signer。
signum(int) - 类 java.lang.Integer 中的静态方法
返回指定 int 值的符号函数。
signum(long) - 类 java.lang.Long 中的静态方法
返回指定 long 值的符号函数。
signum(double) - 类 java.lang.Math 中的静态方法
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
signum(float) - 类 java.lang.Math 中的静态方法
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
signum(double) - 类 java.lang.StrictMath 中的静态方法
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
signum(float) - 类 java.lang.StrictMath 中的静态方法
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0f；如果参数小于 0，则返回 -1.0f。
signum() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的正负号函数。
signum() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的正负号函数。
SILENT - 类 java.rmi.server.LogStream 中的静态变量
已过时。 日志级别常量（无日志记录）。
SIMPLE_SCROLL_MODE - 类 javax.swing.JViewport 中的静态变量
此模式使用非常简单的方法，在 scrollpane 每次滚动时重绘它的整个内容。
SimpleAnnotationValueVisitor6<R,P> - javax.lang.model.util 中的 类
注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleAnnotationValueVisitor6() - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
SimpleAnnotationValueVisitor6(R) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 的构造方法
具体子类的构造方法；使用参数作为默认值。
SimpleAttributeSet - javax.swing.text 中的 类
使用哈希表的 MutableAttributeSet 的直接实现。
SimpleAttributeSet() - 类 javax.swing.text.SimpleAttributeSet 的构造方法
创建新属性集。
SimpleAttributeSet(AttributeSet) - 类 javax.swing.text.SimpleAttributeSet 的构造方法
根据提供的属性集创建新属性集。
SimpleBeanInfo - java.beans 中的 类
这是一个使得用户提供 BeanInfo 类更容易的支持类。
SimpleBeanInfo() - 类 java.beans.SimpleBeanInfo 的构造方法
SimpleBindings - javax.script 中的 类
一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。
SimpleBindings(Map<String, Object>) - 类 javax.script.SimpleBindings 的构造方法
构造方法使用现有 Map 来存储值。
SimpleBindings() - 类 javax.script.SimpleBindings 的构造方法
默认构造方法使用 HashMap。
SimpleDateFormat - java.text 中的 类
SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。
SimpleDateFormat() - 类 java.text.SimpleDateFormat 的构造方法
用默认的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。
SimpleDateFormat(String) - 类 java.text.SimpleDateFormat 的构造方法
用给定的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。
SimpleDateFormat(String, Locale) - 类 java.text.SimpleDateFormat 的构造方法
用给定的模式和给定语言环境的默认日期格式符号构造 SimpleDateFormat。
SimpleDateFormat(String, DateFormatSymbols) - 类 java.text.SimpleDateFormat 的构造方法
用给定的模式和日期符号构造 SimpleDateFormat。
SimpleDoc - javax.print 中的 类
此类是接口 Doc 的实现，可用于很多常见的打印请求中。
SimpleDoc(Object, DocFlavor, DocAttributeSet) - 类 javax.print.SimpleDoc 的构造方法
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。
SimpleElementVisitor6<R,P> - javax.lang.model.util 中的 类
程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleElementVisitor6() - 类 javax.lang.model.util.SimpleElementVisitor6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
SimpleElementVisitor6(R) - 类 javax.lang.model.util.SimpleElementVisitor6 的构造方法
具体子类的构造方法；使用参数作为默认值。
SimpleFormatter - java.util.logging 中的 类
以可读格式输出 LogRecord 的简单摘要。
SimpleFormatter() - 类 java.util.logging.SimpleFormatter 的构造方法
SimpleJavaFileObject - javax.tools 中的 类
为 JavaFileObject 中的大多数方法提供简单实现。
SimpleJavaFileObject(URI, JavaFileObject.Kind) - 类 javax.tools.SimpleJavaFileObject 的构造方法
使用给定 URI 构建给定种类的 SimpleJavaFileObject。
SimpleScriptContext - javax.script 中的 类
ScriptContext 的简单实现。
SimpleScriptContext() - 类 javax.script.SimpleScriptContext 的构造方法
SimpleTimeZone - java.util 中的 类
SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。
SimpleTimeZone(int, String) - 类 java.util.SimpleTimeZone 的构造方法
使用给定的相对于 GMT 的基准时区偏移量和不带夏令时安排的时区 ID 构造一个 SimpleTimeZone。
SimpleTimeZone(int, String, int, int, int, int, int, int, int, int) - 类 java.util.SimpleTimeZone 的构造方法
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
SimpleTimeZone(int, String, int, int, int, int, int, int, int, int, int) - 类 java.util.SimpleTimeZone 的构造方法
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
SimpleTimeZone(int, String, int, int, int, int, int, int, int, int, int, int, int) - 类 java.util.SimpleTimeZone 的构造方法
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
SimpleType<T> - javax.management.openmbean 中的 类
SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。
SimpleTypeVisitor6<R,P> - javax.lang.model.util 中的 类
类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleTypeVisitor6() - 类 javax.lang.model.util.SimpleTypeVisitor6 的构造方法
具体子类的构造方法；使用 null 作为默认值。
SimpleTypeVisitor6(R) - 类 javax.lang.model.util.SimpleTypeVisitor6 的构造方法
具体子类的构造方法；使用参数作为默认值。
SIMPLIFIED_CHINESE - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
SIMPLIFIED_HANZI - 类 java.awt.im.InputSubset 中的静态变量
编写简体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的简体中文汉字字集。
sin(double) - 类 java.lang.Math 中的静态方法
返回角的三角正弦。
sin(double) - 类 java.lang.StrictMath 中的静态方法
返回角的三角正弦。
SINGLE_DOCUMENT - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的静态变量
单个文档 －－ 有关更多信息，请参见上文。
SINGLE_DOCUMENT_NEW_SHEET - 类 javax.print.attribute.standard.MultipleDocumentHandling 中的静态变量
单个文档新纸张 －－ 有关更多信息，请参见上文。
SINGLE_INTERVAL_SELECTION - 接口 javax.swing.ListSelectionModel 中的静态变量
selectionMode 属性的值：一次选择一个连续的索引范围。
SINGLE_LINE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此（文本）对象只能包含单行文本
SINGLE_SELECTION - 接口 javax.swing.ListSelectionModel 中的静态变量
selectionMode 属性的值：一次选择一个列表索引。
SINGLE_THREAD_MODEL - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态变量
SINGLE_TREE_SELECTION - 接口 javax.swing.tree.TreeSelectionModel 中的静态变量
一次只能选择一个路径。
SINGLEFRAME - 接口 java.awt.image.ImageConsumer 中的静态变量
该图像包含单幅静态图像。
SINGLEFRAMEDONE - 接口 java.awt.image.ImageConsumer 中的静态变量
图像的某一帧已完成，但还有更多的帧要传递。
SINGLEPASS - 接口 java.awt.image.ImageConsumer 中的静态变量
以单通道的方式传递像素。
SinglePixelPackedSampleModel - java.awt.image 中的 类
此类表示压缩的像素数据：将 N 个样本组成的单个像素存储在单个数据数组元素中，每个数据数组元素只保存一个像素的样本。
SinglePixelPackedSampleModel(int, int, int, int[]) - 类 java.awt.image.SinglePixelPackedSampleModel 的构造方法
构造一个具有 bitMasks.length band 的 SinglePixelPackedSampleModel。
SinglePixelPackedSampleModel(int, int, int, int, int[]) - 类 java.awt.image.SinglePixelPackedSampleModel 的构造方法
构造一个 SinglePixelPackedSampleModel，使其具有 bitMasks.length band，且扫描行间距等于 scanlineStride 数据数组元素。
SingleSelectionModel - javax.swing 中的 接口
最多支持一个索引选项的模型。
singleton(T) - 类 java.util.Collections 中的静态方法
返回一个只包含指定对象的不可变 set。
singletonKeySelector(Key) - 类 javax.xml.crypto.KeySelector 中的静态方法
返回一个总是选择指定密钥的 KeySelector，不管传递给它的 KeyInfo 是什么。
singletonList(T) - 类 java.util.Collections 中的静态方法
返回一个只包含指定对象的不可变列表。
singletonMap(K, V) - 类 java.util.Collections 中的静态方法
返回一个不可变的映射，它只将指定键映射到指定值。
sinh(double) - 类 java.lang.Math 中的静态方法
返回 double 值的双曲线正弦。
sinh(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的双曲线正弦。
SINHALA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Sinhala”Unicode 字符块的常量。
sink() - 类 java.nio.channels.Pipe 中的方法
返回此管道的接收器通道。
size() - 类 java.awt.Component 中的方法
已过时。 从 JDK version 1.1 开始，由 getSize() 取代。
size - 类 java.awt.Font 中的变量
Font 的磅值大小，舍入为整数。
SIZE - 类 java.awt.font.TextAttribute 中的静态变量
字体大小的属性键。
size - 类 java.awt.image.DataBuffer 中的变量
所有存储单元的可用大小。
size() - 类 java.awt.RenderingHints 中的方法
返回此 RenderingHints 中的键-值映射关系数。
size() - 类 java.beans.beancontext.BeanContextMembershipEvent 中的方法
获得受通知影响的子级的数量。
size() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得当前嵌套在此 BeanContext 中的子级数。
size() - 类 java.io.ByteArrayOutputStream 中的方法
返回缓冲区的当前大小。
size() - 类 java.io.CharArrayWriter 中的方法
返回缓冲区的当前大小。
size() - 类 java.io.DataOutputStream 中的方法
返回计数器 written 的当前值，即到目前为止写入此数据输出流的字节数。
SIZE - 类 java.lang.Byte 中的静态变量
用于以二进制补码形式表示 byte 值的位数。
SIZE - 类 java.lang.Character 中的静态变量
用来以无符号二进制形式表示 char 值的位数。
SIZE - 类 java.lang.Double 中的静态变量
用于表示 double 值的位数。
SIZE - 类 java.lang.Float 中的静态变量
表示一个 float 值所使用的位数。
SIZE - 类 java.lang.Integer 中的静态变量
用来以二进制补码形式表示 int 值的比特位数。
SIZE - 类 java.lang.Long 中的静态变量
用来以二进制补码形式表示 long 值的位数。
SIZE - 类 java.lang.Short 中的静态变量
用来以二进制补码形式表示 short 值的位数。
size() - 类 java.nio.channels.FileChannel 中的方法
返回此通道的文件的当前大小。
size() - 类 java.nio.channels.FileLock 中的方法
返回锁定区域的大小，以字节为单位。
size() - 类 java.security.IdentityScope 中的方法
已过时。 返回此身份作用域内身份的数目。
size() - 类 java.security.KeyStore 中的方法
获取此 keystore 中条目数。
size() - 类 java.util.AbstractCollection 中的方法
size() - 类 java.util.AbstractMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.ArrayDeque 中的方法
返回此双端队列中的元素数。
size() - 类 java.util.ArrayList 中的方法
返回此列表中的元素数。
size() - 类 java.util.BitSet 中的方法
返回此 BitSet 表示位值时实际使用空间的位数。
size() - 接口 java.util.Collection 中的方法
返回此 collection 中的元素数。
size() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回此队列中元素的数量。
size() - 接口 java.util.concurrent.BlockingDeque 中的方法
返回此双端队列中的元素数。
size() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
返回此队列中的元素数量。
size() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
返回此 set 中的元素数目。
size() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表中的元素数。
size() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
返回此 set 中的元素数目。
size() - 类 java.util.concurrent.DelayQueue 中的方法
size() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回此双端队列中的元素数。
size() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回队列中的元素个数。
size() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
size() - 类 java.util.concurrent.SynchronousQueue 中的方法
始终返回 0。
size() - 接口 java.util.Deque 中的方法
返回此双端队列的元素数。
size() - 类 java.util.Dictionary 中的方法
返回此 dictionary 中条目（不同键）的数量。
size() - 类 java.util.EnumMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.HashMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.HashSet 中的方法
返回此 set 中的元素的数量（set 的容量）。
size() - 类 java.util.Hashtable 中的方法
返回此哈希表中的键的数量。
size() - 类 java.util.IdentityHashMap 中的方法
返回标识哈希映射中的键-值映射关系数。
size() - 类 java.util.jar.Attributes 中的方法
返回此 Map 中的属性数目。
size() - 类 java.util.LinkedList 中的方法
返回此列表的元素数。
size() - 接口 java.util.List 中的方法
返回列表中的元素数。
size() - 接口 java.util.Map 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.PriorityQueue 中的方法
size() - 接口 java.util.Set 中的方法
返回 set 中的元素数（其容量）。
size() - 类 java.util.TreeMap 中的方法
返回此映射中的键-值映射关系数。
size() - 类 java.util.TreeSet 中的方法
返回 set 中的元素数（set 的容量）。
size() - 类 java.util.Vector 中的方法
返回此向量中的组件数。
size() - 类 java.util.WeakHashMap 中的方法
返回该映射中的键-值映射关系的数目。
size() - 类 java.util.zip.ZipFile 中的方法
返回 ZIP 文件中的条目数。
size() - 类 javax.accessibility.AccessibleRelationSet 中的方法
返回关系集中的关系数。
size() - 类 javax.activation.MimeTypeParameterList 中的方法
返回此列表中名称-值对的数量。
size() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例中包含的 CompositeData 值的数目（即行数）。
size() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例中的行数。
size() - 类 javax.naming.CompositeName 中的方法
检索此复合名称中的组件数。
size() - 类 javax.naming.CompoundName 中的方法
检索此组合名称中的组件数。
size() - 接口 javax.naming.directory.Attribute 中的方法
检索此属性中的值数。
size() - 接口 javax.naming.directory.Attributes 中的方法
在属性集中检索属性数。
size() - 类 javax.naming.directory.BasicAttribute 中的方法
size() - 类 javax.naming.directory.BasicAttributes 中的方法
size() - 类 javax.naming.ldap.LdapName 中的方法
检索此 LDAP 名称中的组件数。
size() - 类 javax.naming.ldap.Rdn 中的方法
检索此 Rdn 中的属性类型/值对的数目。
size() - 接口 javax.naming.Name 中的方法
返回此名称中的组件数。
size() - 类 javax.naming.Reference 中的方法
检索此引用中的地址数。
size() - 接口 javax.print.attribute.AttributeSet 中的方法
返回此属性集中属性的数量。
size() - 类 javax.print.attribute.HashAttributeSet 中的方法
返回此属性集中属性的数量。
size() - 类 javax.script.SimpleBindings 中的方法
返回此映射中的键-值映射关系数。
size() - 类 javax.sound.midi.Track 中的方法
获得此音轨中的事件数。
size() - 接口 javax.sql.rowset.CachedRowSet 中的方法
返回此 CachedRowSet 对象中的行数。
size() - 类 javax.swing.ActionMap 中的方法
返回 KeyStroke 绑定的数量。
size() - 类 javax.swing.DefaultListModel 中的方法
返回此列表中的组件数。
size() - 类 javax.swing.InputMap 中的方法
返回 KeyStroke 绑定的数量。
SIZE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
Size - 类 javax.swing.text.StyleConstants 中的静态变量
字体大小的名称。
Size2DSyntax - javax.print.attribute 中的 类
类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。
Size2DSyntax(float, float, int) - 类 javax.print.attribute.Size2DSyntax 的构造方法
根据给定的浮点值构造一个新的二维大小属性。
Size2DSyntax(int, int, int) - 类 javax.print.attribute.Size2DSyntax 的构造方法
根据给定的整数值构造一个新的二维大小属性。
SIZE_CMD - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的静态变量
sizeAction - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
sizeColumnsToFit(boolean) - 类 javax.swing.JTable 中的方法
已过时。 从 Swing version 1.0.3 开始，由 doLayout() 取代。
sizeColumnsToFit(int) - 类 javax.swing.JTable 中的方法
从 Java 2 平台 v1.4 开始已过时。
SizeLimitExceededException - javax.naming 中的 异常
当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
SizeLimitExceededException() - 异常 javax.naming.SizeLimitExceededException 的构造方法
构造一个新的 SizeLimitExceededException 实例。
SizeLimitExceededException(String) - 异常 javax.naming.SizeLimitExceededException 的构造方法
使用解释构造一个新的 SizeLimitExceededException 实例。
SizeRequirements - javax.swing 中的 类
为方便布局管理器，计算组件的有关大小和位置信息。
SizeRequirements() - 类 javax.swing.SizeRequirements 的构造方法
创建 SizeRequirements 对象，其最小、首选和最大大小设置为零，对齐方式值为 0.5（居中）。
SizeRequirements(int, int, int, float) - 类 javax.swing.SizeRequirements 的构造方法
用指定的最小、首选和最大大小以及指定的对齐方式创建 SizeRequirements 对象。
sizes - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的变量
SizeSequence - javax.swing 中的 类
一个 SizeSequence 对象，它有效地维护一个包含大小和相应位置的顺序列表。
SizeSequence() - 类 javax.swing.SizeSequence 的构造方法
创建一个新的 SizeSequence 对象，它不包含任何条目。
SizeSequence(int) - 类 javax.swing.SizeSequence 的构造方法
创建一个新的 SizeSequence 对象，它包含指定的条目数，每个大小都已初始化为 0。
SizeSequence(int, int) - 类 javax.swing.SizeSequence 的构造方法
创建一个新的 SizeSequence 对象，它包含指定的条目数，每个大小都已初始化为 value。
SizeSequence(int[]) - 类 javax.swing.SizeSequence 的构造方法
创建一个新的 SizeSequence 对象，它包含指定的大小。
sizeWidthToFit() - 类 javax.swing.table.TableColumn 中的方法
调整 TableColumn 的大小，以适合其标题单元格的宽度。
Skeleton - java.rmi.server 中的 接口
已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
SkeletonMismatchException - java.rmi.server 中的 异常
已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
SkeletonMismatchException(String) - 异常 java.rmi.server.SkeletonMismatchException 的构造方法
已过时。 无替代版本
SkeletonNotFoundException - java.rmi.server 中的 异常
已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
SkeletonNotFoundException(String) - 异常 java.rmi.server.SkeletonNotFoundException 的构造方法
已过时。 构造带指定详细消息的 SkeletonNotFoundException。
SkeletonNotFoundException(String, Exception) - 异常 java.rmi.server.SkeletonNotFoundException 的构造方法
已过时。 构造带指定详细消息和嵌套异常的 SkeletonNotFoundException。
skip(long) - 类 java.io.BufferedInputStream 中的方法
参见 InputStream 的 skip 方法的常规协定。
skip(long) - 类 java.io.BufferedReader 中的方法
跳过字符。
skip(long) - 类 java.io.ByteArrayInputStream 中的方法
从此输入流中跳过 n 个输入字节。
skip(long) - 类 java.io.CharArrayReader 中的方法
跳过字符。
skip(long) - 类 java.io.FileInputStream 中的方法
从输入流中跳过并丢弃 n 个字节的数据。
skip(long) - 类 java.io.FilterInputStream 中的方法
跳过和丢弃此输入流中数据的 n 个字节。
skip(long) - 类 java.io.FilterReader 中的方法
跳过某些字符。
skip(long) - 类 java.io.InputStream 中的方法
跳过和丢弃此输入流中数据的 n 个字节。
skip(long) - 类 java.io.LineNumberInputStream 中的方法
已过时。 跳过和放弃此输入流中的 n 个数据字节。
skip(long) - 类 java.io.LineNumberReader 中的方法
跳过字符。
skip(long) - 接口 java.io.ObjectInput 中的方法
跳过输入的 n 个字节。
skip(long) - 类 java.io.PushbackInputStream 中的方法
从此输入流中跳过并丢弃 n 个数据字节。
skip(long) - 类 java.io.PushbackReader 中的方法
跳过字符。
skip(long) - 类 java.io.Reader 中的方法
跳过字符。
skip(long) - 类 java.io.StringBufferInputStream 中的方法
已过时。 从此输入流中跳过输入的 n 个字节。
skip(long) - 类 java.io.StringReader 中的方法
跳过流中指定数量的字符。
skip(Pattern) - 类 java.util.Scanner 中的方法
在忽略分隔符的情况下跳过与指定模式匹配的输入信息。
skip(String) - 类 java.util.Scanner 中的方法
跳过与从指定字符串构造的模式匹配的输入信息。
skip(long) - 类 java.util.zip.CheckedInputStream 中的方法
跳过指定的输入字节数。
skip(long) - 类 java.util.zip.DeflaterInputStream 中的方法
从输入流中跳过并丢弃数据。
skip(long) - 类 java.util.zip.InflaterInputStream 中的方法
跳过指定的未压缩数据的字节数。
skip(long) - 类 java.util.zip.ZipInputStream 中的方法
跳过当前 ZIP 条目中指定的字节数。
skip(long) - 类 javax.crypto.CipherInputStream 中的方法
跳过不发生阻塞地从该输入流读取的字节中的 n 个字节的输入。
skip(long) - 类 javax.sound.sampled.AudioInputStream 中的方法
跳过并丢弃此音频输入流中指定数量的字节。
skip(long) - 类 javax.swing.ProgressMonitorInputStream 中的方法
重写 FilterInputStream.skip，以便在跳过之后更新进度监视器。
skipBytes(int) - 接口 java.io.DataInput 中的方法
试图在输入流中跳过数据的 n 个字节，并丢弃跳过的字节。
skipBytes(int) - 类 java.io.DataInputStream 中的方法
参见 DataInput 的 skipBytes 方法的常规协定。
skipBytes(int) - 类 java.io.ObjectInputStream 中的方法
跳过字节。
skipBytes(int) - 类 java.io.RandomAccessFile 中的方法
尝试跳过输入的 n 个字节以丢弃跳过的字节。
skipBytes(int) - 接口 javax.imageio.stream.ImageInputStream 中的方法
将流位置向前移动给定的字节数。
skipBytes(long) - 接口 javax.imageio.stream.ImageInputStream 中的方法
将流位置向前移动给定的字节数。
skipBytes(int) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
通过调用 seek(getStreamPosition() + n) 推进当前流位置。
skipBytes(long) - 类 javax.imageio.stream.ImageInputStreamImpl 中的方法
通过调用 seek(getStreamPosition() + n) 推进当前流位置。
skippedEntity(String) - 接口 org.xml.sax.ContentHandler 中的方法
接收跳过的实体的通知。
skippedEntity(String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收跳过的实体的通知。
skippedEntity(String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个跳过的实体事件。
skippedEntity(String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 跳过的实体事件。
skipReferral() - 异常 javax.naming.ReferralException 中的方法
放弃将要处理的引用。
slashSlashComments(boolean) - 类 java.io.StreamTokenizer 中的方法
确定标记生成器是否识别 C++ 样式注释。
slashStarComments(boolean) - 类 java.io.StreamTokenizer 中的方法
确定标记生成器是否识别 C 样式注释。
sleep(long) - 类 java.lang.Thread 中的静态方法
在指定的毫秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
sleep(long, int) - 类 java.lang.Thread 中的静态方法
在指定的毫秒数加指定的纳秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
sleep(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
使用此单元执行 Thread.sleep.这是将时间参数转换为 Thread.sleep 方法所需格式的便捷方法。
slice() - 类 java.nio.ByteBuffer 中的方法
创建新的字节缓冲区，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.CharBuffer 中的方法
创建新的字符缓冲区，其内容为此缓冲区内容的共享子序列。
slice() - 类 java.nio.DoubleBuffer 中的方法
创建新的 double 缓冲区，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.FloatBuffer 中的方法
创建新的 float 缓冲区，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.IntBuffer 中的方法
创建新的 int 数组，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.LongBuffer 中的方法
创建新的 long 缓冲区，其内容是此缓冲区内容的共享子序列。
slice() - 类 java.nio.ShortBuffer 中的方法
创建新的 short 缓冲区，其内容是此缓冲区内容的共享子序列。
SLIDER - 类 javax.accessibility.AccessibleRole 中的静态变量
允许用户在有限范围内进行选择的对象。
slider - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
SLIDER - 类 javax.swing.plaf.synth.Region 中的静态变量
Slider 的 region。
SLIDER_FILL - 类 javax.swing.plaf.metal.MetalSliderUI 中的变量
SLIDER_THUMB - 类 javax.swing.plaf.synth.Region 中的静态变量
滑块的 thumb。
SLIDER_TRACK - 类 javax.swing.plaf.synth.Region 中的静态变量
Slider 的滑道。
sliderModel - 类 javax.swing.JSlider 中的变量
处理滑块的数字最大值、最小值和当前位置值的数据模型。
SliderUI - javax.swing.plaf 中的 类
JSlider 的可插入外观界面。
SliderUI() - 类 javax.swing.plaf.SliderUI 的构造方法
SMALL - 类 javax.swing.text.html.HTML.Tag 中的静态变量
SMALL_FORM_VARIANTS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Small Form Variants”Unicode 字符块的常量。
SMALL_ICON - 接口 javax.swing.Action 中的静态变量
用来存储小型 Icon（比如 ImageIcon）的键。
SMALLINT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 SMALLINT 的 Java 编程语言中的常量（有时称为类型代码）。
SMPTE_24 - 类 javax.sound.midi.Sequence 中的静态变量
基于 SMPTE 的定时类型，每秒 24 帧（精度用每帧的节拍数表示）。
SMPTE_25 - 类 javax.sound.midi.Sequence 中的静态变量
基于 SMPTE 的定时类型，每秒 25 帧（精度用每帧的节拍数表示）。
SMPTE_30 - 类 javax.sound.midi.Sequence 中的静态变量
基于 SMPTE 的定时类型，每秒 30 帧（精度用每帧的节拍数表示）。
SMPTE_30DROP - 类 javax.sound.midi.Sequence 中的静态变量
基于 SMPTE 的定时类型，每秒 29.97 帧（精度用每帧的节拍数表示）。
snapToTicks - 类 javax.swing.JSlider 中的变量
如果为 true，滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值。
SND - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 SND 文件。
SO_BINDADDR - 接口 java.net.SocketOptions 中的静态变量
获取绑定套接字的本地地址（不能仅将此选项“设置”为“得到”，因为套接字是在创建时绑定的，所以本地绑定的地址不可更改）。
SO_BROADCAST - 接口 java.net.SocketOptions 中的静态变量
为套接字设置 SO_BROADCAST。
SO_KEEPALIVE - 接口 java.net.SocketOptions 中的静态变量
为 TCP 套接字设置 keepalive 选项时，如果在 2 个小时（注：实际值与实现有关）内在任意方向上都没有跨越套接字交换数据，则 TCP 会自动将 keepalive 探头发送到同位体。
SO_LINGER - 接口 java.net.SocketOptions 中的静态变量
指定关闭时逗留的超时值。
SO_OOBINLINE - 接口 java.net.SocketOptions 中的静态变量
设置 OOBINLINE 选项时，在套接字上接收的所有 TCP 紧急数据都将通过套接字输入流接收。
SO_RCVBUF - 接口 java.net.SocketOptions 中的静态变量
设置传入网络 I/O 的平台所使用基础缓冲区的大小的提示。
SO_REUSEADDR - 接口 java.net.SocketOptions 中的静态变量
设置套接字的 SO_REUSEADDR。
SO_SNDBUF - 接口 java.net.SocketOptions 中的静态变量
设置传出网络 I/O 的平台所使用的基础缓冲区大小的提示。
SO_TIMEOUT - 接口 java.net.SocketOptions 中的静态变量
设置阻塞 Socket 操作的超时值：

 ServerSocket.accept();
 SocketInputStream.read();
 DatagramSocket.receive();

 选项必须在进入阻塞操作前设置才能生效。
SOAP11HTTP_BINDING - 接口 javax.xml.ws.soap.SOAPBinding 中的静态变量
表示 HTTP 绑定上的 SOAP 1.1 标识的常量。
SOAP11HTTP_MTOM_BINDING - 接口 javax.xml.ws.soap.SOAPBinding 中的静态变量
表示 HTTP 绑定上的 SOAP 1.1 标识，且默认启用 MTOM 的常量。
SOAP12HTTP_BINDING - 接口 javax.xml.ws.soap.SOAPBinding 中的静态变量
表示 HTTP 绑定上的 SOAP 1.2 标识的常量。
SOAP12HTTP_MTOM_BINDING - 接口 javax.xml.ws.soap.SOAPBinding 中的静态变量
表示 HTTP 绑定上的 SOAP 1.2 标识，且默认启用 MTOM 的常量。
SOAP_1_1_CONTENT_TYPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.1 中 Content-Type MIME 头的媒体类型。
SOAP_1_1_PROTOCOL - 接口 javax.xml.soap.SOAPConstants 中的静态变量
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.1 规范的 SOAPMessages。
SOAP_1_2_CONTENT_TYPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 中 Content-Type MIME 头的媒体类型。
SOAP_1_2_PROTOCOL - 接口 javax.xml.soap.SOAPConstants 中的静态变量
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.2 规范的 SOAPMessages
SOAP_DATAENCODINGUNKNOWN_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 DataEncodingUnknown 错误。
SOAP_ENV_PREFIX - 接口 javax.xml.soap.SOAPConstants 中的静态变量
http://www.w3.org/2003/05/soap-envelope 的默认名称空间前缀。
SOAP_MUSTUNDERSTAND_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 MustUnderstand 错误。
SOAP_RECEIVER_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 Receiver 错误。
SOAP_SENDER_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 Sender 错误。
SOAP_VERSIONMISMATCH_FAULT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 VersionMismatch 错误。
SOAPACTION_URI_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
SOAPAction 的标准属性。
SOAPACTION_USE_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
SOAPAction 的标准属性。
SOAPBinding - javax.jws.soap 中的 注释类型
指定 Web Service 到 SOAP 消息协议的映射关系。
SOAPBinding - javax.xml.ws.soap 中的 接口
SOAPBinding 接口是 SOAP 绑定的抽象。
SOAPBinding.ParameterStyle - javax.jws.soap 中的 枚举
参数到 SOAP 消息的映射关系的样式。
SOAPBinding.Style - javax.jws.soap 中的 枚举
SOAP 绑定样式。
SOAPBinding.Use - javax.jws.soap 中的 枚举
SOAP 绑定的使用。
SOAPBody - javax.xml.soap 中的 接口
表示 SOAP 消息中 SOAP 正文元素内容的对象。
SOAPBodyElement - javax.xml.soap 中的 接口
表示 SOAPBody 对象中内容的 SOAPBodyElement 对象。
SOAPConnection - javax.xml.soap 中的 类
客户端可以用于直接将消息发送到（例如，用 URL 表示的）远程方的点对点连接。
SOAPConnection() - 类 javax.xml.soap.SOAPConnection 的构造方法
SOAPConnectionFactory - javax.xml.soap 中的 类
创建 SOAPConnection 对象的工厂。
SOAPConnectionFactory() - 类 javax.xml.soap.SOAPConnectionFactory 的构造方法
SOAPConstants - javax.xml.soap 中的 接口
与 SOAP 协议有关的常量的定义。
SOAPElement - javax.xml.soap 中的 接口
表示 SOAP 规范允许使用但未特别规定的 SOAP 消息元素的对象。
SOAPElementFactory - javax.xml.soap 中的 类
已过时。 - 使用 javax.xml.soap.SOAPFactory 创建 SOAPElements。
SOAPEnvelope - javax.xml.soap 中的 接口
SOAPPart 对象的 SOAPHeader 和 SOAPBody 部分的容器。
SOAPException - javax.xml.soap 中的 异常
当发生 SOAP 异常时，抛出此异常。
SOAPException() - 异常 javax.xml.soap.SOAPException 的构造方法
构造不带原因或内置 Throwable 对象的 SOAPException 对象。
SOAPException(String) - 异常 javax.xml.soap.SOAPException 的构造方法
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因。
SOAPException(String, Throwable) - 异常 javax.xml.soap.SOAPException 的构造方法
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因，使用给定 Throwable 对象作为嵌入的异常。
SOAPException(Throwable) - 异常 javax.xml.soap.SOAPException 的构造方法
构造使用给定 Throwable 对象初始化的 SOAPException 对象。
SOAPFactory - javax.xml.soap 中的 类
SOAPFactory 是用来创建存在于 SOAP XML 树中的各种对象的工厂。
SOAPFactory() - 类 javax.xml.soap.SOAPFactory 的构造方法
SOAPFault - javax.xml.soap 中的 接口
SOAPBody 对象中的元素，包含错误和/或状态信息。
SOAPFaultElement - javax.xml.soap 中的 接口
SOAPFault 对象内容的表示形式。
SOAPFaultException - javax.xml.ws.soap 中的 异常
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。
SOAPFaultException(SOAPFault) - 异常 javax.xml.ws.soap.SOAPFaultException 的构造方法
SOAPFaultException 的构造方法
SOAPHandler<T extends SOAPMessageContext> - javax.xml.ws.handler.soap 中的 接口
SOAPHandler 类扩展了 Handler，以便为消息上下文参数提供输入安全性，并添加了一个方法，以访问可能由该处理程序处理的头。
SOAPHeader - javax.xml.soap 中的 接口
SOAP 头元素的表示形式。
SOAPHeaderElement - javax.xml.soap 中的 接口
表示 SOAP 信封 SOAP 头部分的内容的对象。
SOAPMessage - javax.xml.soap 中的 类
所有 SOAP 消息的根类。
SOAPMessage() - 类 javax.xml.soap.SOAPMessage 的构造方法
SOAPMessageContext - javax.xml.ws.handler.soap 中的 接口
接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。
SOAPMessageHandler - javax.jws.soap 中的 注释类型
已过时。 从 JSR-181 2.0 开始，无替代版本。
SOAPMessageHandlers - javax.jws.soap 中的 注释类型
已过时。 从 JSR-181 2.0 开始，无替代版本。
SOAPPart - javax.xml.soap 中的 类
SOAPMessage 对象中特定于 SOAP 部分的容器。
SOAPPart() - 类 javax.xml.soap.SOAPPart 的构造方法
Socket - java.net 中的 类
此类实现客户端套接字（也可以就叫“套接字”）。
Socket() - 类 java.net.Socket 的构造方法
通过系统默认类型的 SocketImpl 创建未连接套接字
Socket(Proxy) - 类 java.net.Socket 的构造方法
创建一个未连接的套接字并指定代理类型（如果有），该代理不管其他设置如何都应被使用。
Socket(SocketImpl) - 类 java.net.Socket 的构造方法
使用用户指定的 SocketImpl 创建一个未连接 Socket。
Socket(String, int) - 类 java.net.Socket 的构造方法
创建一个流套接字并将其连接到指定主机上的指定端口号。
Socket(InetAddress, int) - 类 java.net.Socket 的构造方法
创建一个流套接字并将其连接到指定 IP 地址的指定端口号。
Socket(String, int, InetAddress, int) - 类 java.net.Socket 的构造方法
创建一个套接字并将其连接到指定远程主机上的指定远程端口。
Socket(InetAddress, int, InetAddress, int) - 类 java.net.Socket 的构造方法
创建一个套接字并将其连接到指定远程地址上的指定远程端口。
Socket(String, int, boolean) - 类 java.net.Socket 的构造方法
已过时。 使用 DatagramSocket 取代 UDP 传输。
Socket(InetAddress, int, boolean) - 类 java.net.Socket 的构造方法
已过时。 Use DatagramSocket instead for UDP transport.
socket() - 类 java.nio.channels.DatagramChannel 中的方法
获取与此通道关联的数据报套接字。
socket() - 类 java.nio.channels.ServerSocketChannel 中的方法
获取与此通道关联的服务器套接字。
socket() - 类 java.nio.channels.SocketChannel 中的方法
获取与此通道关联的套接字。
SocketAddress - java.net 中的 类
此类表示不带任何协议附件的 Socket Address。
SocketAddress() - 类 java.net.SocketAddress 的构造方法
SocketChannel - java.nio.channels 中的 类
针对面向流的连接套接字的可选择通道。
SocketChannel(SelectorProvider) - 类 java.nio.channels.SocketChannel 的构造方法
初始化此类的一个新实例。
SocketException - java.net 中的 异常
抛出此异常指示在底层协议中存在错误，如 TCP 错误。
SocketException(String) - 异常 java.net.SocketException 的构造方法
构造带指定详细消息的新 SocketException。
SocketException() - 异常 java.net.SocketException 的构造方法
构造不带详细消息的新 SocketException。
SocketFactory - javax.net 中的 类
此类创建套接字。
SocketFactory() - 类 javax.net.SocketFactory 的构造方法
创建一个 SocketFactory。
SocketHandler - java.util.logging 中的 类
简单的网络日志 Handler。
SocketHandler() - 类 java.util.logging.SocketHandler 的构造方法
仅使用 LogManager 属性（或其默认值）创建 SocketHandler。
SocketHandler(String, int) - 类 java.util.logging.SocketHandler 的构造方法
构造一个带有指定主机和端口的 SocketHandler。
SocketImpl - java.net 中的 类
抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。
SocketImpl() - 类 java.net.SocketImpl 的构造方法
SocketImplFactory - java.net 中的 接口
此接口定义用于套接字实现的工厂。
SocketOptions - java.net 中的 接口
获取/设置套接字选项的方法的接口。
SocketPermission - java.net 中的 类
此类表示通过套接字对网络的访问。
SocketPermission(String, String) - 类 java.net.SocketPermission 的构造方法
创建带指定动作的新 SocketPermission 对象。
SocketSecurityException - java.rmi.server 中的 异常
已废弃的 ExportException 的子类。
SocketSecurityException(String) - 异常 java.rmi.server.SocketSecurityException 的构造方法
构造带指定详细消息的 SocketSecurityException。
SocketSecurityException(String, Exception) - 异常 java.rmi.server.SocketSecurityException 的构造方法
构造带指定详细消息和嵌入异常的 SocketSecurityIOException。
SocketTimeoutException - java.net 中的 异常
如果在读取或接受套接字时发生超时，则抛出此异常。
SocketTimeoutException(String) - 异常 java.net.SocketTimeoutException 的构造方法
构造带详细消息的新 SocketTimeoutException。
SocketTimeoutException() - 异常 java.net.SocketTimeoutException 的构造方法
构造不带详细信息的新 SocketTimeoutException。
SoftBevelBorder - javax.swing.border 中的 类
实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
SoftBevelBorder(int) - 类 javax.swing.border.SoftBevelBorder 的构造方法
创建具有用指定类型的斜面边框，其颜色将从传递给 paintBorder 方法的组件背景色派生。
SoftBevelBorder(int, Color, Color) - 类 javax.swing.border.SoftBevelBorder 的构造方法
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
SoftBevelBorder(int, Color, Color, Color, Color) - 类 javax.swing.border.SoftBevelBorder 的构造方法
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
SoftReference<T> - java.lang.ref 中的 类
软引用对象，在响应内存需要时，由垃圾回收器决定是否清除此对象。
SoftReference(T) - 类 java.lang.ref.SoftReference 的构造方法
创建引用给定对象的新的软引用。
SoftReference(T, ReferenceQueue<? super T>) - 类 java.lang.ref.SoftReference 的构造方法
创建一个引用给定对象的新的软引用，并向给定队列注册该引用。
solveCubic(double[]) - 类 java.awt.geom.CubicCurve2D 中的静态方法
解系数位于 eqn 数组中的三次曲线，并将非复数的根放回该数组，同时返回根数。
solveCubic(double[], double[]) - 类 java.awt.geom.CubicCurve2D 中的静态方法
解系数位于 eqn 数组中的三次曲线，并将非复数的根放入 res 数组，同时返回根数。
solveQuadratic(double[]) - 类 java.awt.geom.QuadCurve2D 中的静态方法
解系数位于 eqn 数组中的二次曲线，并将非复数的根放回该数组，同时返回根数。
solveQuadratic(double[], double[]) - 类 java.awt.geom.QuadCurve2D 中的静态方法
解系数位于 eqn 数组中的二次曲线，并将非复数的根放入 res 数组，同时返回根数。
SOMEBITS - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示已提供了绘制图像缩放变体所需的更多像素。
SONG_POSITION_POINTER - 类 javax.sound.midi.ShortMessage 中的静态变量
SONG_POSITION_POINTER 消息的状态字节（0xF2 或 242）。
SONG_SELECT - 类 javax.sound.midi.ShortMessage 中的静态变量
MIDI SONG_SELECT 消息的状态字节（0xF3 或 243）。
sort(long[]) - 类 java.util.Arrays 中的静态方法
对指定的 long 型数组按数字升序进行排序。
sort(long[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 long 型数组的指定范围按数字升序进行排序。
sort(int[]) - 类 java.util.Arrays 中的静态方法
对指定的 int 型数组按数字升序进行排序。
sort(int[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 int 型数组的指定范围按数字升序进行排序。
sort(short[]) - 类 java.util.Arrays 中的静态方法
对指定的 short 型数组按数字升序进行排序。
sort(short[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 short 型数组的指定范围按数字升序进行排序。
sort(char[]) - 类 java.util.Arrays 中的静态方法
对指定的 char 型数组按数字升序进行排序。
sort(char[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 char 型数组的指定范围按数字升序进行排序。
sort(byte[]) - 类 java.util.Arrays 中的静态方法
对指定的 byte 型数组按数字升序进行排序。
sort(byte[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 byte 型数组的指定范围按数字升序进行排序。
sort(double[]) - 类 java.util.Arrays 中的静态方法
对指定的 double 型数组按数字升序进行排序。
sort(double[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 double 型数组的指定范围按数字升序进行排序。
sort(float[]) - 类 java.util.Arrays 中的静态方法
对指定的 float 型数组按数字升序进行排序。
sort(float[], int, int) - 类 java.util.Arrays 中的静态方法
对指定 float 型数组的指定范围按数字升序进行排序。
sort(Object[]) - 类 java.util.Arrays 中的静态方法
根据元素的自然顺序对指定对象数组按升序进行排序。
sort(Object[], int, int) - 类 java.util.Arrays 中的静态方法
根据元素的自然顺序对指定对象数组的指定范围按升序进行排序。
sort(T[], Comparator<? super T>) - 类 java.util.Arrays 中的静态方法
根据指定比较器产生的顺序对指定对象数组进行排序。
sort(T[], int, int, Comparator<? super T>) - 类 java.util.Arrays 中的静态方法
根据指定比较器产生的顺序对指定对象数组的指定范围进行排序。
sort(List<T>) - 类 java.util.Collections 中的静态方法
根据元素的自然顺序 对指定列表按升序进行排序。
sort(List<T>, Comparator<? super T>) - 类 java.util.Collections 中的静态方法
根据指定比较器产生的顺序对指定列表进行排序。
sort() - 类 javax.swing.DefaultRowSorter 中的方法
根据当前正在排序的列的排序键以及与此排序器关联的过滤器（如果有）对视图中的行进行排序和过滤。
sort(Vector<? extends File>) - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
SortControl - javax.naming.ldap 中的 类
请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
SortControl(String, boolean) - 类 javax.naming.ldap.SortControl 的构造方法
构造一个控件来按升序对单个属性进行排序。
SortControl(String[], boolean) - 类 javax.naming.ldap.SortControl 的构造方法
构造一个控件来按升序对属性列表进行排序。
SortControl(SortKey[], boolean) - 类 javax.naming.ldap.SortControl 的构造方法
构造一个控件来对排序键列表进行排序。
SortedMap<K,V> - java.util 中的 接口
进一步提供关于键的总体排序 的 Map。
SortedSet<E> - java.util 中的 接口
进一步提供关于元素的总体排序 的 Set。
sorterChanged(RowSorterEvent) - 接口 javax.swing.event.RowSorterListener 中的方法
RowSorter 发生了更改的通知。
sorterChanged(RowSorterEvent) - 类 javax.swing.JTable 中的方法
RowSorter 以某种方式发生了更改的 RowSorterListener 通知。
SortingFocusTraversalPolicy - javax.swing 中的 类
通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。
SortingFocusTraversalPolicy() - 类 javax.swing.SortingFocusTraversalPolicy 的构造方法
构造一个不带 Comparator 的 SortingFocusTraversalPolicy。
SortingFocusTraversalPolicy(Comparator<? super Component>) - 类 javax.swing.SortingFocusTraversalPolicy 的构造方法
构造具有指定 Comparator 的 SortingFocusTraversalPolicy。
SortKey - javax.naming.ldap 中的 类
排序键及其关联的排序参数。
SortKey(String) - 类 javax.naming.ldap.SortKey 的构造方法
创建属性的默认排序键。
SortKey(String, boolean, String) - 类 javax.naming.ldap.SortKey 的构造方法
创建属性的排序键。
SortOrder - javax.swing 中的 枚举
SortOrder 是可能排序顺序的枚举。
SortResponseControl - javax.naming.ldap 中的 类
指示搜索结果的请求排序是否成功。
SortResponseControl(String, boolean, byte[]) - 类 javax.naming.ldap.SortResponseControl 的构造方法
构造一个控件来指示排序请求的结果。
Soundbank - javax.sound.midi 中的 接口
Soundbank 包含可加载到 Synthesizer 中的一组 Instruments。
SoundbankReader - javax.sound.midi.spi 中的 类
SoundbankReader 提供音库文件读取服务。
SoundbankReader() - 类 javax.sound.midi.spi.SoundbankReader 的构造方法
SoundbankResource - javax.sound.midi 中的 类
SoundbankResource 表示存储在 Soundbank 中的任何音频资源。
SoundbankResource(Soundbank, String, Class<?>) - 类 javax.sound.midi.SoundbankResource 的构造方法
根据给定的音库和波表索引构造一个新的 SoundbankResource。
source() - 类 java.nio.channels.Pipe 中的方法
返回此管道的源通道。
source - 类 java.util.EventObject 中的变量
最初发生 Event 的对象。
source - 类 javax.management.Notification 中的变量
此域隐藏了父类中的 EventObject.source 域，使其成为非 transient 的，并因此成为序列化形式的一部分。
source - 类 javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler 中的变量
发起事件的源。
Source - javax.xml.transform 中的 接口
实现此接口的对象包含充当源输入（XML 源或转换指令）所需的信息
sourceActions - 类 java.awt.dnd.DragGestureRecognizer 中的变量
此 Drag 和 Drop 操作中所用动作类型的 int 表示形式。
sourceBands - 类 javax.imageio.IIOParam 中的变量
指示将使用的源 band 的 int 数组，或为 null。
SourceDataLine - javax.sound.sampled 中的 接口
源数据行是可以写入数据的数据行。
SourceLocator - javax.xml.transform 中的 接口
此接口的主要目的是报告在 XML 源或转换指令中发生错误的位置。
sourceRegion - 类 javax.imageio.IIOParam 中的变量
源区域；如果没有设置源区域，则为 null。
sourceRenderSize - 类 javax.imageio.ImageReadParam 中的变量
如果 canSetSourceRenderSize 为 true，则为源的所需呈现宽度和高度；或者为 null。
sources - 类 java.awt.image.renderable.ParameterBlock 中的变量
源的 Vector，存储为任意 Objects。
sourceToInputSource(Source) - 类 javax.xml.transform.sax.SAXSource 中的静态方法
尝试从 Source 对象获取 SAX InputSource 对象。
SourceVersion - javax.lang.model 中的 枚举
Java™ 编程语言的源版本。
sourceXSubsampling - 类 javax.imageio.IIOParam 中的变量
在水平方向应用抽取十分之一的二次取样。
sourceYSubsampling - 类 javax.imageio.IIOParam 中的变量
在垂直方向应用抽取十分之一的二次取样。
SOUTH - 类 java.awt.BorderLayout 中的静态变量
南区域的布局约束（容器底部）。
SOUTH - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的底部，并在水平方向上居中。
SOUTH - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的底边。
SOUTH - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向南（下）。
SOUTH_EAST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向东南（右下）。
SOUTH_WEST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向西南（左下）。
SOUTHEAST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的右下角。
southPane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
SOUTHWEST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的左下角。
SPACE - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
字符是空格（参阅 [XML], 2.10 "White Space Handling"）。
SPACE_SEPARATOR - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Zs”。
SpaceAbove - 类 javax.swing.text.StyleConstants 中的静态变量
段落上方的空间量。
SpaceBelow - 类 javax.swing.text.StyleConstants 中的静态变量
段落下方的空间量。
SPACING_MODIFIER_LETTERS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Spacing Modifier Letters”Unicode 字符块的常量。
SPAN - 类 javax.swing.text.html.HTML.Tag 中的静态变量
SPEAKER - 类 javax.sound.sampled.Port.Info 中的静态变量
向内置扬声器或扬声器插孔发送音频端口类型。
SPECIAL_SYSTEM_EXCLUSIVE - 类 javax.sound.midi.SysexMessage 中的静态变量
用于 SPECIAL_SYSTEM_EXCLUSIVE 消息的状态字节（0xF7 或 247），供在 MIDI 文件中使用。
SPECIALS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Specials”Unicode 字符块的常量。
SPECIFICATION_TITLE - 类 java.util.jar.Attributes.Name 中的静态变量
Specification-Title 的 Name 对象给出了用于包的版本控制的属性。
SPECIFICATION_VENDOR - 类 java.util.jar.Attributes.Name 中的静态变量
Specification-Vendor 的 Name 对象给出了用于包的版本控制的属性。
SPECIFICATION_VERSION - 类 java.util.jar.Attributes.Name 中的静态变量
Specification-Version 的 Name 对象给出了用于包的版本控制的属性。
SPIN_BOX - 类 javax.accessibility.AccessibleRole 中的静态变量
SPIN_BOX 是简单的微调器组件，它主要用于简单数字。
spinner - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的变量
作为 UI 委托的 spinner。
SPINNER - 类 javax.swing.plaf.synth.Region 中的静态变量
Spinner 的 region。
SpinnerDateModel - javax.swing 中的 类
Date 序列的一个 SpinnerModel。
SpinnerDateModel(Date, Comparable, Comparable, int) - 类 javax.swing.SpinnerDateModel 的构造方法
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。
SpinnerDateModel() - 类 javax.swing.SpinnerDateModel 的构造方法
构造一个 SpinnerDateModel，其初始 value 为当前日期，calendarField 等于 Calendar.DAY_OF_MONTH，且没有 start/end 限制。
SpinnerListModel - javax.swing 中的 类
其值由数组或 List 定义的 SpinnerModel 的简单实现。
SpinnerListModel(List<?>) - 类 javax.swing.SpinnerListModel 的构造方法
构造一个由指定 List 定义其值序列的 SpinnerModel。
SpinnerListModel(Object[]) - 类 javax.swing.SpinnerListModel 的构造方法
构造一个由指定数组定义其值序列的 SpinnerModel。
SpinnerListModel() - 类 javax.swing.SpinnerListModel 的构造方法
创建一个实际为空的 SpinnerListModel。
SpinnerModel - javax.swing 中的 接口
对象值的潜在无界序列的模型。
SpinnerNumberModel - javax.swing 中的 类
用于数字序列的 SpinnerModel。
SpinnerNumberModel(Number, Comparable, Comparable, Number) - 类 javax.swing.SpinnerNumberModel 的构造方法
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。
SpinnerNumberModel(int, int, int, int) - 类 javax.swing.SpinnerNumberModel 的构造方法
构造一个具有指定 value、minimum/maximum 边界和 stepSize 的 SpinnerNumberModel。
SpinnerNumberModel(double, double, double, double) - 类 javax.swing.SpinnerNumberModel 的构造方法
构造一个具有指定 value、minimum/maximum 边界和 stepSize 的 SpinnerNumberModel。
SpinnerNumberModel() - 类 javax.swing.SpinnerNumberModel 的构造方法
构造一个没有 minimum 或 maximum 值、stepSize 等于 1 且初始值为零的 SpinnerNumberModel。
SpinnerUI - javax.swing.plaf 中的 类
JSpinner 的可插入外观界面
SpinnerUI() - 类 javax.swing.plaf.SpinnerUI 的构造方法
SplashScreen - java.awt 中的 类
在 Java 虚拟机 (JVM) 启动之前，可以在应用程序启动时创建闪现屏幕。
split(String, int) - 类 java.lang.String 中的方法
根据匹配给定的正则表达式来拆分此字符串。
split(String) - 类 java.lang.String 中的方法
根据给定正则表达式的匹配拆分此字符串。
split(CharSequence, int) - 类 java.util.regex.Pattern 中的方法
围绕此模式的匹配拆分给定输入序列。
split(CharSequence) - 类 java.util.regex.Pattern 中的方法
围绕此模式的匹配拆分给定输入序列。
SPLIT_PANE - 类 javax.accessibility.AccessibleRole 中的静态变量
同时呈现两个其他窗格的专用窗格。
SPLIT_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
SplitPane 的 region。
SPLIT_PANE_DIVIDER - 类 javax.swing.plaf.synth.Region 中的静态变量
SplitPane 的分隔器。
splitPane - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
其中包含接收者的 JSplitPane。
splitPane - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
此实例为其提供外观的 JSplitPane 实例。
splitPaneUI - 类 javax.swing.plaf.basic.BasicSplitPaneDivider 中的变量
从其创建此实例的 UI。
SplitPaneUI - javax.swing.plaf 中的 类
JSplitPane 的可插入外观界面。
SplitPaneUI() - 类 javax.swing.plaf.SplitPaneUI 的构造方法
splitText(int) - 接口 org.w3c.dom.Text 中的方法
在指定的 offset 处将此节点拆分为两个节点，并将二者作为兄弟节点保持在树中。
SPOOL_AREA_FULL - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
已达到为后台打印分配的持久存储限制。
spPropertyChangeListener - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
Spring - javax.swing 中的 类
该 Spring 类的实例将存储以下三个表示其行为特征的属性：minimum、preferred 和 maximum 值。
Spring() - 类 javax.swing.Spring 的构造方法
由工厂方法创建 Spring 时使用。
SpringLayout - javax.swing 中的 类
SpringLayout 根据一组约束布置其相关容器的子组件。
SpringLayout() - 类 javax.swing.SpringLayout 的构造方法
构造一个新 SpringLayout。
SpringLayout.Constraints - javax.swing 中的 类
Constraints 对象将管理组件大小和位置更改方式的约束存储在 SpringLayout 控制的容器中。
SpringLayout.Constraints() - 类 javax.swing.SpringLayout.Constraints 的构造方法
创建一个空 Constraints 对象。
SpringLayout.Constraints(Spring, Spring) - 类 javax.swing.SpringLayout.Constraints 的构造方法
创建一个指定了 x 和 y 属性值的 Constraints 对象。
SpringLayout.Constraints(Spring, Spring, Spring, Spring) - 类 javax.swing.SpringLayout.Constraints 的构造方法
创建一个指定了 x、y、width 和 height 属性值的 Constraints 对象。
SpringLayout.Constraints(Component) - 类 javax.swing.SpringLayout.Constraints 的构造方法
创建组件 c 的合适 x、y、width 和 height spring 的 Constraints 对象。
SQLClientInfoException - java.sql 中的 异常
当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
SQLClientInfoException() - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个 SQLClientInfoException 对象。
SQLClientInfoException(Map<String, ClientInfoStatus>) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(Map<String, ClientInfoStatus>, Throwable) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, Map<String, ClientInfoStatus>) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, Map<String, ClientInfoStatus>, Throwable) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, String, Map<String, ClientInfoStatus>) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, String, Map<String, ClientInfoStatus>, Throwable) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, String, int, Map<String, ClientInfoStatus>) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String, String, int, Map<String, ClientInfoStatus>, Throwable) - 异常 java.sql.SQLClientInfoException 的构造方法
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLData - java.sql 中的 接口
该接口用于 SQL 用户定义类型 (UDT) 到 Java 编程语言中类的自定义映射关系。
SQLDataException - java.sql 中的 异常
当 SQLState 类值为“22”时抛出的 SQLException 子类。
SQLDataException() - 异常 java.sql.SQLDataException 的构造方法
构造一个 SQLDataException 对象。
SQLDataException(String) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason 的 SQLDataException 对象。
SQLDataException(String, String) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLDataException 对象。
SQLDataException(String, String, int) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLDataException 对象。
SQLDataException(Throwable) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 cause 的 SQLDataException 对象。
SQLDataException(String, Throwable) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLDataException 对象。
SQLDataException(String, String, Throwable) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLDataException 对象。
SQLDataException(String, String, int, Throwable) - 异常 java.sql.SQLDataException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLDataException 对象。
SQLException - java.sql 中的 异常
提供关于数据库访问错误或其他错误信息的异常。
SQLException(String, String, int) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLException 对象。
SQLException(String, String) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason 和 SQLState 的 SQLException 对象。
SQLException(String) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason 的 SQLException 对象。
SQLException() - 异常 java.sql.SQLException 的构造方法
构造一个 SQLException 对象。
SQLException(Throwable) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 cause 的 SQLException 对象。
SQLException(String, Throwable) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason 和 cause 的 SQLException 对象。
SQLException(String, String, Throwable) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason、SQLState 和 cause 的 SQLException 对象。
SQLException(String, String, int, Throwable) - 异常 java.sql.SQLException 的构造方法
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLException 对象。
SQLFeatureNotSupportedException - java.sql 中的 异常
当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
SQLFeatureNotSupportedException() - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, String) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, String, int) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(Throwable) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, Throwable) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, String, Throwable) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String, String, int, Throwable) - 异常 java.sql.SQLFeatureNotSupportedException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLInput - java.sql 中的 接口
一个输入流，它包含表示 SQL 结构化类型或 SQL 不同类型的实例的值组成的流。
SQLInputImpl - javax.sql.rowset.serial 中的 类
用于自定义映射用户定义类型 (UDT) 的输入流。
SQLInputImpl(Object[], Map<String, Class<?>>) - 类 javax.sql.rowset.serial.SQLInputImpl 的构造方法
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。
SQLIntegrityConstraintViolationException - java.sql 中的 异常
当 SQLState 类值为“23”时抛出的 SQLException 子类。
SQLIntegrityConstraintViolationException() - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason 的 SQLIntegrityConstraintViolationException。
SQLIntegrityConstraintViolationException(String, String) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String, String, int) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(Throwable) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String, Throwable) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String, String, Throwable) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String, String, int, Throwable) - 异常 java.sql.SQLIntegrityConstraintViolationException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLInvalidAuthorizationSpecException - java.sql 中的 异常
当 SQLState 类值为“28”时抛出的 SQLException 子类。
SQLInvalidAuthorizationSpecException() - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, String) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, String, int) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(Throwable) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, Throwable) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, String, Throwable) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String, String, int, Throwable) - 异常 java.sql.SQLInvalidAuthorizationSpecException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLNonTransientConnectionException - java.sql 中的 异常
SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
SQLNonTransientConnectionException() - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String, String) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String, String, int) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(Throwable) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String, Throwable) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientConnectionException(String, String, Throwable) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String, String, int, Throwable) - 异常 java.sql.SQLNonTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientException - java.sql 中的 异常
重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
SQLNonTransientException() - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个 SQLNonTransientException 对象。
SQLNonTransientException(String) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason 的 SQLNonTransientException 对象。
SQLNonTransientException(String, String) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientException 对象。
SQLNonTransientException(String, String, int) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientException 对象。
SQLNonTransientException(Throwable) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String, Throwable) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientException(String, String, Throwable) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String, String, int, Throwable) - 异常 java.sql.SQLNonTransientException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientException 对象。
SQLOutput - java.sql 中的 接口
用于将用户定义类型的属性写回数据库的输出流。
SQLOutputImpl - javax.sql.rowset.serial 中的 类
用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。
SQLOutputImpl(Vector<?>, Map<String, ?>) - 类 javax.sql.rowset.serial.SQLOutputImpl 的构造方法
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。
SQLPermission - java.sql 中的 类
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。
SQLPermission(String) - 类 java.sql.SQLPermission 的构造方法
创建具有指定名称的新 SQLPermission 对象。
SQLPermission(String, String) - 类 java.sql.SQLPermission 的构造方法
创建具有指定名称的新 SQLPermission 对象。
SQLRecoverableException - java.sql 中的 异常
应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
SQLRecoverableException() - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个 SQLRecoverableException 对象。
SQLRecoverableException(String) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason 的 SQLRecoverableException 对象。
SQLRecoverableException(String, String) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLRecoverableException 对象。
SQLRecoverableException(String, String, int) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLRecoverableException 对象。
SQLRecoverableException(Throwable) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String, Throwable) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String, String, Throwable) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String, String, int, Throwable) - 异常 java.sql.SQLRecoverableException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLRecoverableException 对象。
sqlStateSQL - 接口 java.sql.DatabaseMetaData 中的静态变量
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 方法返回的值是否是一个 SQLSTATE 值。
sqlStateSQL99 - 接口 java.sql.DatabaseMetaData 中的静态变量
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 方法返回的值是否是一个 SQL99 SQLSTATE 值。
sqlStateXOpen - 接口 java.sql.DatabaseMetaData 中的静态变量
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 返回的值是否是一个 X/Open（现在称为 Open Group）SQL CLI SQLSTATE 值。
SQLSyntaxErrorException - java.sql 中的 异常
当 SQLState 类值为“42”时抛出的 SQLException 子类。
SQLSyntaxErrorException() - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, String) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, String, int) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(Throwable) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, Throwable) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, String, Throwable) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String, String, int, Throwable) - 异常 java.sql.SQLSyntaxErrorException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLSyntaxErrorException 对象。
SQLTimeoutException - java.sql 中的 异常
Statement 指定的超时已到期时抛出的 SQLException 子类。
SQLTimeoutException() - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个 SQLTimeoutException 对象。
SQLTimeoutException(String) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason 的 SQLTimeoutException 对象。
SQLTimeoutException(String, String) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLTimeoutException 对象。
SQLTimeoutException(String, String, int) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTimeoutException 对象。
SQLTimeoutException(Throwable) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String, Throwable) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String, String, Throwable) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String, String, int, Throwable) - 异常 java.sql.SQLTimeoutException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTimeoutException 对象。
SQLTransactionRollbackException - java.sql 中的 异常
当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
SQLTransactionRollbackException() - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, String) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, String, int) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(Throwable) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, Throwable) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, String, Throwable) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String, String, int, Throwable) - 异常 java.sql.SQLTransactionRollbackException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransientConnectionException - java.sql 中的 异常
SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
SQLTransientConnectionException() - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, String) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, String, int) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(Throwable) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, Throwable) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, String, Throwable) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String, String, int, Throwable) - 异常 java.sql.SQLTransientConnectionException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientException - java.sql 中的 异常
没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
SQLTransientException() - 异常 java.sql.SQLTransientException 的构造方法
构造一个 SQLTransientException 对象。
SQLTransientException(String) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason 的 SQLTransientException 对象。
SQLTransientException(String, String) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason 和 SQLState 的 SQLTransientException 对象。
SQLTransientException(String, String, int) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientException 对象。
SQLTransientException(Throwable) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 cause 的 SQLTransientException 对象。
SQLTransientException(String, Throwable) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLTransientException(String, String, Throwable) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientException 对象。
SQLTransientException(String, String, int, Throwable) - 异常 java.sql.SQLTransientException 的构造方法
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientException 对象。
SQLWarning - java.sql 中的 异常
提供关于数据库访问警告信息的异常。
SQLWarning(String, String, int) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLWarning 对象。
SQLWarning(String, String) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason 和 SQLState 的 SQLWarning 对象。
SQLWarning(String) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason 的 SQLWarning 对象。
SQLWarning() - 异常 java.sql.SQLWarning 的构造方法
构造一个 SQLWarning 对象。
SQLWarning(Throwable) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 cause 的 SQLWarning 对象。
SQLWarning(String, Throwable) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason 和 cause 的 SQLWarning 对象。
SQLWarning(String, String, Throwable) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason、SQLState 和 cause 的 SQLWarning 对象。
SQLWarning(String, String, int, Throwable) - 异常 java.sql.SQLWarning 的构造方法
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLWarning 对象。
SQLXML - java.sql 中的 接口
SQL XML 类型在 JavaTM 编程语言中的映射关系。
SQLXML - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 XML 的 Java 编程语言中的常量（有时称为类型代码）。
sqrt(double) - 类 java.lang.Math 中的静态方法
返回正确舍入的 double 值的正平方根。
sqrt(double) - 类 java.lang.StrictMath 中的静态方法
返回正确舍入的 double 值的正平方根。
SRC - 类 java.awt.AlphaComposite 中的静态变量
将源色复制到目标色（Porter-Duff Source 规则）。
Src - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
SRC - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
SRC_ATOP - 类 java.awt.AlphaComposite 中的静态变量
目标色中的源色部分将被合成到目标色中（Porter-Duff Source Atop Destination 规则）。
SRC_IN - 类 java.awt.AlphaComposite 中的静态变量
目标色中的源色部分将替换目标色（Porter-Duff Source In Destination 规则）。
SRC_OUT - 类 java.awt.AlphaComposite 中的静态变量
目标色以外的源色部分将替换目标色（Porter-Duff Source Held Out By Destination 规则）。
SRC_OVER - 类 java.awt.AlphaComposite 中的静态变量
在目标色之上合成源色（Porter-Duff Source Over Destination 规则）。
SrcAtop - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
srccols - 类 java.awt.image.ReplicateScaleFilter 中的变量
包含关于像素列信息的 int 数组。
srcHeight - 类 java.awt.image.ReplicateScaleFilter 中的变量
源图像的高度。
SrcIn - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
SrcOut - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
SrcOver - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 SRC_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
srcrows - 类 java.awt.image.ReplicateScaleFilter 中的变量
包含关于像素行信息的 int 数组。
srcWidth - 类 java.awt.image.ReplicateScaleFilter 中的变量
源图像的宽度。
SSLContext - javax.net.ssl 中的 类
此类的实例表示安全套接字协议的实现，它充当用于安全套接字工厂或 SSLEngine 的工厂。
SSLContext(SSLContextSpi, Provider, String) - 类 javax.net.ssl.SSLContext 的构造方法
创建 SSLContext 对象。
SSLContextSpi - javax.net.ssl 中的 类
此类为 SSLContext 类定义了服务提供者接口 (SPI)。
SSLContextSpi() - 类 javax.net.ssl.SSLContextSpi 的构造方法
SSLEngine - javax.net.ssl 中的 类
此类允许使用安全套接字层 (SSL) 或 IETF RFC 2246 "Transport Layer Security" (TLS) 协议进行安全通信，但它与传输无关。
SSLEngine() - 类 javax.net.ssl.SSLEngine 的构造方法
SSLEngine 的构造方法，该构造方法不为内部会话重用策略提供提示。
SSLEngine(String, int) - 类 javax.net.ssl.SSLEngine 的构造方法
SSLEngine 的构造方法。
SSLEngineResult - javax.net.ssl 中的 类
SSLEngine I/O 调用所生成的结果状态的封装。
SSLEngineResult(SSLEngineResult.Status, SSLEngineResult.HandshakeStatus, int, int) - 类 javax.net.ssl.SSLEngineResult 的构造方法
初始化此类的一个新实例。
SSLEngineResult.HandshakeStatus - javax.net.ssl 中的 枚举
描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
SSLEngineResult.Status - javax.net.ssl 中的 枚举
描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。
SSLException - javax.net.ssl 中的 异常
指示由 SSL 子系统检测到的某类错误。
SSLException(String) - 异常 javax.net.ssl.SSLException 的构造方法
构造一个异常，该异常报告由 SSL 子系统发现的错误。
SSLException(String, Throwable) - 异常 javax.net.ssl.SSLException 的构造方法
创建带指定详细消息和原因的 SSLException。
SSLException(Throwable) - 异常 javax.net.ssl.SSLException 的构造方法
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造异常 SSLException（它通常包含 cause 的类和详细消息）。
SSLHandshakeException - javax.net.ssl 中的 异常
指示客户端和服务器不能就所需安全级别进行协商。
SSLHandshakeException(String) - 异常 javax.net.ssl.SSLHandshakeException 的构造方法
构造一个报告由 SSL 子系统在握手期间发现的错误的异常。
SSLKeyException - javax.net.ssl 中的 异常
报告错误的 SSL 密钥。
SSLKeyException(String) - 异常 javax.net.ssl.SSLKeyException 的构造方法
构造一个报告由 SSL 子系统发现的密钥管理错误的异常。
SSLParameters - javax.net.ssl 中的 类
封装 SSL/TLS 连接的参数。
SSLParameters() - 类 javax.net.ssl.SSLParameters 的构造方法
构造 SSLParameters。
SSLParameters(String[]) - 类 javax.net.ssl.SSLParameters 的构造方法
根据指定的密码套件数组构造 SSLParameters。
SSLParameters(String[], String[]) - 类 javax.net.ssl.SSLParameters 的构造方法
根据指定的密码套件数组和协议数组构造 SSLParameters。
SSLPeerUnverifiedException - javax.net.ssl 中的 异常
指示还没有验证同位体的身份。
SSLPeerUnverifiedException(String) - 异常 javax.net.ssl.SSLPeerUnverifiedException 的构造方法
构造一个报告还没有验证 SSL 同位体的身份的异常。
SSLPermission - javax.net.ssl 中的 类
此类用于各种网络权限。
SSLPermission(String) - 类 javax.net.ssl.SSLPermission 的构造方法
用指定的名称创建一个新的 SSLPermission。
SSLPermission(String, String) - 类 javax.net.ssl.SSLPermission 的构造方法
用指定的名称创建一个新的 SSLPermission 对象。
SSLProtocolException - javax.net.ssl 中的 异常
报告在 SSL 协议的操作中的错误。
SSLProtocolException(String) - 异常 javax.net.ssl.SSLProtocolException 的构造方法
构造一个报告由 SSL 子系统检测到的 SSL 协议错误的异常。
SslRMIClientSocketFactory - javax.rmi.ssl 中的 类
SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。
SslRMIClientSocketFactory() - 类 javax.rmi.ssl.SslRMIClientSocketFactory 的构造方法
创建一个新的 SslRMIClientSocketFactory。
SslRMIServerSocketFactory - javax.rmi.ssl 中的 类
SslRMIServerSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的服务端套接字。
SslRMIServerSocketFactory() - 类 javax.rmi.ssl.SslRMIServerSocketFactory 的构造方法
使用默认的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。
SslRMIServerSocketFactory(String[], String[], boolean) - 类 javax.rmi.ssl.SslRMIServerSocketFactory 的构造方法
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。
SSLServerSocket - javax.net.ssl 中的 类
此类扩展了 ServerSocket 并且提供使用像 Secure Sockets Layer (SSL) 或 Transport Layer Security (TLS) 协议的安全服务器套接字。
SSLServerSocket() - 类 javax.net.ssl.SSLServerSocket 的构造方法
仅供子类使用。
SSLServerSocket(int) - 类 javax.net.ssl.SSLServerSocket 的构造方法
仅供子类使用。
SSLServerSocket(int, int) - 类 javax.net.ssl.SSLServerSocket 的构造方法
仅供子类使用。
SSLServerSocket(int, int, InetAddress) - 类 javax.net.ssl.SSLServerSocket 的构造方法
仅供子类使用。
SSLServerSocketFactory - javax.net.ssl 中的 类
SSLServerSocketFactory 创建 SSLServerSocket。
SSLServerSocketFactory() - 类 javax.net.ssl.SSLServerSocketFactory 的构造方法
构造方法仅供子类使用。
SSLSession - javax.net.ssl 中的 接口
在 SSL 中，会话用来描述两个实体间正在发生的关系。
SSLSessionBindingEvent - javax.net.ssl 中的 类
此事件向 SSLSessionBindingListener 传播。
SSLSessionBindingEvent(SSLSession, String) - 类 javax.net.ssl.SSLSessionBindingEvent 的构造方法
构造一个新的 SSLSessionBindingEvent。
SSLSessionBindingListener - javax.net.ssl 中的 接口
想知道何时将它们绑定到 SSLSession 或从 SSLSession 解除绑定的对象实现此接口。
SSLSessionContext - javax.net.ssl 中的 接口
SSLSessionContext 表示与单个实体关联的 SSLSession。
SSLSocket - javax.net.ssl 中的 类
此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。
SSLSocket() - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocket(String, int) - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocket(InetAddress, int) - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocket(String, int, InetAddress, int) - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocket(InetAddress, int, InetAddress, int) - 类 javax.net.ssl.SSLSocket 的构造方法
仅供子类使用。
SSLSocketFactory - javax.net.ssl 中的 类
SSLSocketFactory 创建 SSLSocket。
SSLSocketFactory() - 类 javax.net.ssl.SSLSocketFactory 的构造方法
构造方法仅供子类使用。
Stack<E> - java.util 中的 类
Stack 类表示后进先出（LIFO）的对象堆栈。
Stack() - 类 java.util.Stack 的构造方法
创建一个空堆栈。
StackOverflowError - java.lang 中的 错误
当应用程序递归太深而发生堆栈溢出时，抛出该错误。
StackOverflowError() - 错误 java.lang.StackOverflowError 的构造方法
构造不带详细消息的 StackOverflowError。
StackOverflowError(String) - 错误 java.lang.StackOverflowError 的构造方法
构造带指定详细消息的 StackOverflowError。
StackTraceElement - java.lang 中的 类
堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。
StackTraceElement(String, String, String, int) - 类 java.lang.StackTraceElement 的构造方法
创建表示指定执行点的堆栈跟踪元素。
STANDALONE - 类 javax.xml.transform.OutputKeys 中的静态变量
standalone = "yes" | "no". standalone 指定了 Transformer 是否应输出单独的文档声明，其值必须为 yes 或 no。
standaloneSet() - 接口 javax.xml.stream.events.StartDocument 中的方法
如果在文档的编码声明中设置了单独属性，则返回 ture。
standaloneSet() - 类 javax.xml.stream.util.StreamReaderDelegate 中的方法
standaloneSet() - 接口 javax.xml.stream.XMLStreamReader 中的方法
检查文档中是否设置了独立
STANDARD - 类 java.awt.font.GlyphMetrics 中的静态变量
指示表示单个标准字符的字形。
STANDARD - 类 javax.print.attribute.standard.JobSheets 中的静态变量
打印一个或多个指定位置的标准作业页，例如，打印单张开始页，或者打印开始页和结束页。
STANDARD_INPUT_TYPE - 类 javax.imageio.spi.ImageReaderSpi 中的静态变量
将从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。
STANDARD_OUTPUT_TYPE - 类 javax.imageio.spi.ImageWriterSpi 中的静态变量
从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。
STANDARD_TIME - 类 java.util.SimpleTimeZone 中的静态变量
指定为标准时间的开始或结束时间模式的常量。
StandardEmitterMBean - javax.management 中的 类
一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。
StandardEmitterMBean(T, Class<T>, NotificationEmitter) - 类 javax.management.StandardEmitterMBean 的构造方法
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T, Class<T>, boolean, NotificationEmitter) - 类 javax.management.StandardEmitterMBean 的构造方法
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(Class<?>, NotificationEmitter) - 类 javax.management.StandardEmitterMBean 的构造方法
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(Class<?>, boolean, NotificationEmitter) - 类 javax.management.StandardEmitterMBean 的构造方法
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
standardFormatSupported - 类 javax.imageio.metadata.IIOMetadata 中的变量
指示具体子类是否支持标准元数据格式的 boolean 值，通过构造方法设置。
StandardJavaFileManager - javax.tools 中的 接口
基于 java.io.File 的文件管理器。
StandardLocation - javax.tools 中的 枚举
文件对象的标准位置。
StandardMBean - javax.management 中的 类
一个管理接口由 Java 接口上的反射确定的 MBean。
StandardMBean(T, Class<T>) - 类 javax.management.StandardMBean 的构造方法
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。
StandardMBean(Class<?>) - 类 javax.management.StandardMBean 的构造方法
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
StandardMBean(T, Class<T>, boolean) - 类 javax.management.StandardMBean 的构造方法
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。
StandardMBean(Class<?>, boolean) - 类 javax.management.StandardMBean 的构造方法
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
standardMetadataFormatName - 类 javax.imageio.metadata.IIOMetadataFormatImpl 中的静态变量
包含标准格式名称 "javax_imageio_1.0" 的 String 常量。
STANDBY - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
STAPLE - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与一个或多个装订点进行绑定。
STAPLE_BOTTOM_LEFT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与左下角中的一个或多个装订点绑定。
STAPLE_BOTTOM_RIGHT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档或多个文档与右下角中的一个或多个装订点绑定。
STAPLE_DUAL_BOTTOM - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿底边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
STAPLE_DUAL_LEFT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿左边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
STAPLE_DUAL_RIGHT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿右边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
STAPLE_DUAL_TOP - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与沿顶边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
STAPLE_TOP_LEFT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档（或多个文档）与左上角中的一个或多个装订点绑定。
STAPLE_TOP_RIGHT - 类 javax.print.attribute.standard.Finishings 中的静态变量
将文档或多个文档与右上角中的一个或多个装订点绑定。
start() - 类 java.applet.Applet 中的方法
由浏览器或 applet viewer 调用，通知此 applet 它应该开始执行。
start - 类 java.awt.geom.Arc2D.Double 中的变量
弧的起始角度（以度数表示）。
start - 类 java.awt.geom.Arc2D.Float 中的变量
弧的起始角度（以度数表示）。
start() - 类 java.lang.ProcessBuilder 中的方法
使用此进程生成器的属性启动一个新进程。
start() - 类 java.lang.Thread 中的方法
使该线程开始执行；Java 虚拟机调用该线程的 run 方法。
start() - 类 java.util.regex.Matcher 中的方法
返回以前匹配的初始索引。
start(int) - 类 java.util.regex.Matcher 中的方法
返回在以前的匹配操作期间，由给定组所捕获的子序列的初始索引。
start() - 接口 java.util.regex.MatchResult 中的方法
返回匹配的初始索引。
start(int) - 接口 java.util.regex.MatchResult 中的方法
返回在匹配期间由给定组捕获的子序列的初始索引。
start() - 类 javax.management.monitor.CounterMonitor 中的方法
启动计数器监视器。
start() - 类 javax.management.monitor.GaugeMonitor 中的方法
启用尺度监视器。
start() - 类 javax.management.monitor.Monitor 中的方法
启动监视器。
start() - 接口 javax.management.monitor.MonitorMBean 中的方法
启动监视器。
start() - 类 javax.management.monitor.StringMonitor 中的方法
启动字符串监视器。
start() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
激活连接器服务器，即开始侦听客户端连接。
start() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
激活连接器服务器，即启动对客户端连接的侦听。
start() - 类 javax.management.timer.Timer 中的方法
启动计时器。
start() - 接口 javax.management.timer.TimerMBean 中的方法
启动计时器。
start() - 接口 javax.sound.midi.Sequencer 中的方法
开始回放当前已加载 sequence 中的 MIDI 数据。
START - 类 javax.sound.midi.ShortMessage 中的静态变量
START 消息的状态字节（0xFA 或 250）。
start() - 接口 javax.sound.sampled.DataLine 中的方法
允许某一数据行执行数据 I/O。
START - 类 javax.sound.sampled.LineEvent.Type 中的静态变量
在行响应 start 请求而进行音频数据的活动输入或输出时发送的事件类型。
START - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.FormAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.PreAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction 中的方法
start(HTML.Tag, MutableAttributeSet) - 类 javax.swing.text.html.HTMLDocument.HTMLReader.TagAction 中的方法
当发现此动作所注册的标记类型的开始标记时调用。
start() - 类 javax.swing.Timer 中的方法
启动 Timer，使它开始向其侦听器发送动作事件。
start(Xid, int) - 接口 javax.transaction.xa.XAResource 中的方法
代表 xid 中指定的事务分支开始工作。
START_DOCUMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个开始文档
START_ELEMENT - 接口 javax.xml.stream.XMLStreamConstants 中的静态变量
指示事件是一个开始元素
START_PUNCTUATION - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Ps”。
start_value() - 接口 org.omg.CORBA.portable.ValueInputStream 中的方法
start_value 方法读取嵌套自定义 valuetype 的 valuetype 头并将该 valuetype 的嵌套层次加 1。
start_value(String) - 接口 org.omg.CORBA.portable.ValueOutputStream 中的方法
start_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的 valuetype 头（使用 null 代码基和指定的存储库 ID），并将 valuetype 嵌套层次加 1。
startAnimationTimer() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
启动动画线程，如果必要则创建并初始化它。
startAutoScrolling(int) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
startCDATA() - 类 org.xml.sax.ext.DefaultHandler2 中的方法
startCDATA() - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告 CDATA 节的开始。
startCellEditing(EventObject) - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
返回 true 指示编辑已经开始。
StartDocument - javax.xml.stream.events 中的 接口
开始文档事件的接口。
startDocument() - 接口 org.xml.sax.ContentHandler 中的方法
接收文档的开始的通知。
startDocument() - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收文档的开始的通知。
startDocument() - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收文档开始的通知。
startDocument() - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收文档开始的通知。
startDocument() - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
startDocument() - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个开始文档事件。
startDocument() - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
开始文档事件。
startDrag(Cursor, Transferable) - 类 java.awt.dnd.DragGestureEvent 中的方法
在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
startDrag(Cursor, Transferable, DragSourceListener) - 类 java.awt.dnd.DragGestureEvent 中的方法
在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
startDrag(Cursor, Image, Point, Transferable, DragSourceListener) - 类 java.awt.dnd.DragGestureEvent 中的方法
在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
startDrag(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener, FlavorMap) - 类 java.awt.dnd.DragSource 中的方法
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
startDrag(DragGestureEvent, Cursor, Transferable, DragSourceListener, FlavorMap) - 类 java.awt.dnd.DragSource 中的方法
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
startDrag(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
startDrag(DragGestureEvent, Cursor, Transferable, DragSourceListener) - 类 java.awt.dnd.DragSource 中的方法
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
startDragging() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
应该在拖动会话开始、重置 lastDragLocation 和 dividerSize 之前传递消息。
startDTD(String, String, String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
startDTD(String, String, String) - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告 DTD 声明的开始（如果存在）。
startEditing(TreePath, MouseEvent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果存在 cellEditor 并且 shouldSelectCell 返回 true，则启动节点的编辑操作。
startEditingAtPath(TreePath) - 类 javax.swing.JTree 中的方法
选择指定路径标识的节点，并开始编辑。
startEditingAtPath(JTree, TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
选择路径中的最后一个项并尝试对其进行编辑。
startEditingAtPath(JTree, TreePath) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 startEditingAtPath 方法。
startEditingAtPath(JTree, TreePath) - 类 javax.swing.plaf.TreeUI 中的方法
选择路径中的最后一个项并试着编辑它。
startEditingTimer() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
启动编辑计时器。
StartElement - javax.xml.stream.events 中的 接口
StartElement 接口提供对有关开始元素的信息的访问。
startElement(Element) - 接口 org.w3c.dom.ls.LSParserFilter 中的方法
解析器将在扫描完每个 Element 启动标记后，处理其余的 Element 之前调用此方法。
startElement(String, String, String, Attributes) - 接口 org.xml.sax.ContentHandler 中的方法
接收元素开始的通知。
startElement(String, AttributeList) - 接口 org.xml.sax.DocumentHandler 中的方法
已过时。 接收元素开始的通知。
startElement(String, AttributeList) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收元素开始的通知。
startElement(String, String, String, Attributes) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收元素开始的通知。
startElement(String, AttributeList) - 类 org.xml.sax.helpers.ParserAdapter 中的方法
适配器实现方法；不调用。
startElement(String, String, String, Attributes) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个开始元素事件。
startElement(String, String, String, Attributes) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 开始元素事件。
startEntity(String) - 类 org.xml.sax.ext.DefaultHandler2 中的方法
startEntity(String) - 接口 org.xml.sax.ext.LexicalHandler 中的方法
报告一些内部和外部 XML 实体的开始。
startFontTag(String) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
此方法已不再使用，而用写出 <span> 来替换。
startGrabbing() - 类 java.awt.image.PixelGrabber 中的方法
请求 PixelGrabber 开始获取像素。
startHandshake() - 类 javax.net.ssl.SSLSocket 中的方法
在此连接上开始 SSL 握手。
startIndex - 类 javax.accessibility.AccessibleAttributeSequence 中的变量
文本序列的起始索引
startIndex - 类 javax.accessibility.AccessibleTextSequence 中的变量
startPrefixMapping(String, String) - 接口 org.xml.sax.ContentHandler 中的方法
开始前缀 URI 名称空间范围映射。
startPrefixMapping(String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收名称空间映射开始的通知。
startPrefixMapping(String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个开始名称空间前缀映射事件。
startPrefixMapping(String, String) - 类 org.xml.sax.helpers.XMLReaderAdapter 中的方法
适配 SAX2 开始前缀映射事件。
startProduction(ImageConsumer) - 类 java.awt.image.FilteredImageSource 中的方法
开始生成过滤图像。
startProduction(ImageConsumer) - 接口 java.awt.image.ImageProducer 中的方法
将指定的 ImageConsumer 对象注册为使用者，并立即开始图像数据的重构，然后这些图像数据将传递到此使用者和已经向该生产者注册的所有其他使用者。
startProduction(ImageConsumer) - 类 java.awt.image.MemoryImageSource 中的方法
将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表中，并立即开始通过 ImageConsumer 接口传递图像数据。
startProduction(ImageConsumer) - 类 java.awt.image.renderable.RenderableImageProducer 中的方法
将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表，并立即通过 ImageConsumer 接口开始提交该图像数据。
startRecording() - 接口 javax.sound.midi.Sequencer 中的方法
开始录制和回放 MIDI 数据。
startsWith(String, int) - 类 java.lang.String 中的方法
测试此字符串从指定索引开始的子字符串是否以指定前缀开始。
startsWith(String) - 类 java.lang.String 中的方法
测试此字符串是否以指定的前缀开始。
startsWith(Name) - 类 javax.naming.CompositeName 中的方法
确定某一复合名称是否是此复合名称的前缀。
startsWith(Name) - 类 javax.naming.CompoundName 中的方法
确定某一组合名称是否是此组合名称的前缀。
startsWith(Name) - 类 javax.naming.ldap.LdapName 中的方法
确定此 LDAP 名称是否从某一指定 LDAP 名称前缀开始。
startsWith(List<Rdn>) - 类 javax.naming.ldap.LdapName 中的方法
确定指定的 RDN 序列是否形成此 LDAP 名称的前缀。
startsWith(Name) - 接口 javax.naming.Name 中的方法
确定此名称是否从某一指定前缀开始。
startTag(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出元素的开始标记。
STARTTAG - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
startTag(TagElement) - 类 javax.swing.text.html.parser.Parser 中的方法
处理开始标记。
StartTagType - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的静态变量
getType 的可能值。
startTimer() - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的方法
在必要时，创建并启动 Timer 来检查是否需要调整边界的大小。
StartTlsRequest - javax.naming.ldap 中的 类
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。
StartTlsRequest() - 类 javax.naming.ldap.StartTlsRequest 的构造方法
构造 StartTLS 扩展请求。
StartTlsResponse - javax.naming.ldap 中的 类
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。
StartTlsResponse() - 类 javax.naming.ldap.StartTlsResponse 的构造方法
构造 StartTLS 扩展响应。
state - 类 java.security.Signature 中的变量
此签名对象的当前状态。
state() - 接口 org.omg.PortableInterceptor.IORInfoOperations 中的方法
返回刚创建并在 IOR interceptor 上运行的对象适配器的对象适配器状态。
State - org.omg.PortableServer.POAManagerPackage 中的 类
指定 POAManager 的状态。
State(int) - 类 org.omg.PortableServer.POAManagerPackage.State 的构造方法
STATE_FACTORIES - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定要使用的状态工厂列表的环境属性名称。
stateChanged(ChangeEvent) - 类 javax.swing.AbstractButton.ButtonChangeListener 中的方法
stateChanged(ChangeEvent) - 接口 javax.swing.event.ChangeListener 中的方法
当侦听器的目标已更改其状态时调用。
stateChanged(ChangeEvent) - 类 javax.swing.JMenuItem.AccessibleJMenuItem 中的方法
支持更改侦听器接口并激发属性更改。
stateChanged(ChangeEvent) - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的方法
当侦听器目标的状态改变时，此方法被调用。
stateChanged(ChangeEvent) - 类 javax.swing.JSpinner.AccessibleJSpinner 中的方法
侦听器的目标已更改其状态时调用。
stateChanged(ChangeEvent) - 类 javax.swing.JSpinner.DefaultEditor 中的方法
当 spinner 的模型状态更改时调用此方法。
stateChanged(ChangeEvent) - 类 javax.swing.JTabbedPane.AccessibleJTabbedPane 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.JTabbedPane.ModelListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollBarUI.ModelListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicSliderUI.ChangeHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler 中的方法
stateChanged(ChangeEvent) - 类 javax.swing.ProgressMonitor.AccessibleProgressMonitor 中的方法
在侦听器的目标已更改其状态时调用。
StateEdit - javax.swing.undo 中的 类
StateEdit 是更改状态的对象的通用编辑。
StateEdit(StateEditable) - 类 javax.swing.undo.StateEdit 的构造方法
创建并返回新的 StateEdit。
StateEdit(StateEditable, String) - 类 javax.swing.undo.StateEdit 的构造方法
创建并返回具有表示名称的新 StateEdit。
StateEditable - javax.swing.undo 中的 接口
StateEditable 定义可以由 StateEdit 撤消/恢复其状态的对象的接口。
StateFactory - javax.naming.spi 中的 接口
此接口表示一个工厂，该工厂用来获得用于绑定的对象状态。
stateMask - 类 javax.swing.DefaultButtonModel 中的变量
用于存储按钮状态的位掩码。
STATEMENT - 类 java.awt.PageAttributes.MediaType 中的静态变量
INVOICE 的别名。
Statement - java.beans 中的 类
Statement 对象表示基本语句，其中将单个方法应用于某一目标和一组参数，以返回结果，比如 "a.setFoo(b)"。
Statement(Object, String, Object[]) - 类 java.beans.Statement 的构造方法
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。
Statement - java.sql 中的 接口
用于执行静态 SQL 语句并返回它所生成结果的对象。
statementClosed(StatementEvent) - 接口 javax.sql.StatementEventListener 中的方法
检测到 PreparedStatement 关闭时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。
statementErrorOccurred(StatementEvent) - 接口 javax.sql.StatementEventListener 中的方法
检测到 PreparedStatement 无效时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。
StatementEvent - javax.sql 中的 类
StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。
StatementEvent(PooledConnection, PreparedStatement) - 类 javax.sql.StatementEvent 的构造方法
用指定的 PooledConnection 和 PreparedStatement 构造 StatementEvent。
StatementEvent(PooledConnection, PreparedStatement, SQLException) - 类 javax.sql.StatementEvent 的构造方法
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。
StatementEventListener - javax.sql 中的 接口
注册为能获得 Statement 池中 PreparedStatement 上所发生事件的通知的对象。
states - 类 javax.accessibility.AccessibleStateSet 中的变量
Vector 中的每个项表示一个 AccessibleState。
STATIC - 类 java.lang.reflect.Modifier 中的静态变量
表示 static 修饰符的 int 值。
STATICIMAGEDONE - 接口 java.awt.image.ImageConsumer 中的静态变量
图像已完成，不再有像素或帧要传递。
status() - 类 java.awt.image.PixelGrabber 中的方法
返回像素的状态。
STATUS_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
STATUS_BAR 是可以包含多个用户状态信息标签的简单组件。
statusAll(boolean) - 类 java.awt.MediaTracker 中的方法
计算并返回此媒体跟踪器跟踪的所有媒体状态的按位或。
statusID(int, boolean) - 类 java.awt.MediaTracker 中的方法
计算或返回由此媒体跟踪器跟踪且具有指定标识符的所有媒体状态的按位或。
StAXResult - javax.xml.transform.stax 中的 类
以 StAX writer 的形式（即 XMLStreamWriter 或 XMLEventWriter）充当 XML Result 的持有者。
StAXResult(XMLEventWriter) - 类 javax.xml.transform.stax.StAXResult 的构造方法
通过提供 XMLEventWriter 创建 StAXResult 的一个新实例。
StAXResult(XMLStreamWriter) - 类 javax.xml.transform.stax.StAXResult 的构造方法
通过提供 XMLStreamWriter 创建 StAXResult 的一个新实例。
StAXSource - javax.xml.transform.stax 中的 类
以 StAX reader 的形式（即 XMLStreamReader 或 XMLEventReader）充当 XML Source 的持有者。
StAXSource(XMLEventReader) - 类 javax.xml.transform.stax.StAXSource 的构造方法
通过提供 XMLEventReader 创建 StAXSource 的一个新实例。
StAXSource(XMLStreamReader) - 类 javax.xml.transform.stax.StAXSource 的构造方法
通过 XMLStreamReader 创建 StAXSource 的一个新实例。
StdACChrominance - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的静态变量
标准 AC 色度 Huffman 表。
StdACLuminance - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的静态变量
标准 AC 亮度 Huffman 表。
StdDCChrominance - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的静态变量
标准 DC 色度 Huffman 表。
StdDCLuminance - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的静态变量
标准 DC 亮度 Huffman 表。
stop() - 类 java.applet.Applet 中的方法
由浏览器或 applet viewer 调用，通知此 applet 它应该终止执行。
stop() - 接口 java.applet.AudioClip 中的方法
停止播放此音频剪辑。
stop() - 类 java.awt.dnd.DropTarget.DropTargetAutoScroller 中的方法
导致停止自动滚动
stop() - 类 java.lang.Thread 中的方法
已过时。 该方法具有固有的不安全性。用 Thread.stop 来终止线程将释放它已经锁定的所有监视器（作为沿堆栈向上传播的未检查 ThreadDeath 异常的一个自然后果）。如果以前受这些监视器保护的任何对象都处于一种不一致的状态，则损坏的对象将对其他线程可见，这有可能导致任意的行为。stop 的许多使用都应由只修改某些变量以指示目标线程应该停止运行的代码来取代。目标线程应定期检查该变量，并且如果该变量指示它要停止运行，则从其运行方法依次返回。如果目标线程等待很长时间（例如基于一个条件变量），则应使用 interrupt 方法来中断该等待。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
stop(Throwable) - 类 java.lang.Thread 中的方法
已过时。 该方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
stop() - 类 java.lang.ThreadGroup 中的方法
已过时。 此方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。
stop() - 类 javax.management.monitor.CounterMonitor 中的方法
停止计数器监视器。
stop() - 类 javax.management.monitor.GaugeMonitor 中的方法
停止尺度监视器。
stop() - 类 javax.management.monitor.Monitor 中的方法
停止监视器。
stop() - 接口 javax.management.monitor.MonitorMBean 中的方法
停止监视器。
stop() - 类 javax.management.monitor.StringMonitor 中的方法
停止字符串监视器。
stop() - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
取消激活连接器服务器，即停止对客户端连接的侦听。
stop() - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
取消激活连接器服务器，即停止对客户端连接的侦听。
stop() - 类 javax.management.timer.Timer 中的方法
停止计时器。
stop() - 接口 javax.management.timer.TimerMBean 中的方法
停止计时器。
stop() - 接口 javax.sound.midi.Sequencer 中的方法
停止录音（如果处于活动状态）及当前已加载 sequence（如果有）的回放。
STOP - 类 javax.sound.midi.ShortMessage 中的静态变量
STOP 消息的状态字节（0xFC 或 252）。
stop() - 接口 javax.sound.sampled.DataLine 中的方法
停止行。
STOP - 类 javax.sound.sampled.LineEvent.Type 中的静态变量
当行响应 stop 请求或者因为已到达介质的结尾处而终止音频数据的活动输入或输出时发送的事件类型。
stop() - 类 javax.swing.Timer 中的方法
停止 Timer，使它停止向其侦听器发送动作事件。
stop() - 类 javax.xml.ws.Endpoint 中的方法
停止发布此端点。
stopAnimationTimer() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
停止动画线程。
stopAutoScrolling() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
此受保护方法是特定于实现的，应该为私有，不要调用或重写。
stopCellEditing() - 类 javax.swing.AbstractCellEditor 中的方法
调用 fireEditingStopped 并返回 true。
stopCellEditing() - 接口 javax.swing.CellEditor 中的方法
告知编辑器停止编辑并接受任何已部分编辑的值作为编辑器的值。
stopCellEditing() - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的方法
停止编辑并返回 true，指示编辑已经停止。
stopCellEditing() - 类 javax.swing.DefaultCellEditor 中的方法
将消息从 CellEditor 转发到 delegate。
stopCellEditing() - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
如果 realEditor 允许编辑停止，则移除 realEditor，并返回 true，否则返回 false。
stopEditing() - 类 javax.swing.JTree 中的方法
结束当前编辑会话。
stopEditing(JTree) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
停止当前编辑会话。
stopEditing(JTree) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 stopEditing 方法。
stopEditing(JTree) - 类 javax.swing.plaf.TreeUI 中的方法
停止当前编辑会话。
stopEditingInCompleteEditing - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
编辑时设置为 false，shouldSelectCell() 返回 true 表示应该在编辑前选中节点，在 completeEditing 中使用该字段。
STOPPED - 类 javax.print.attribute.standard.PrinterState 中的静态变量
指示没有作业可以处理，需要干预。
STOPPED_PARTLY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
当打印机控制多个输出设备时，此原因指示一个或多个设备被停止。
STOPPING - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
打印机正在停止设备，并且打印机也将很快停下来。
stopPropagation() - 接口 org.w3c.dom.events.Event 中的方法
stopPropagation 方法用于阻止在事件流期间事件的进一步传播。
stopRecording() - 接口 javax.sound.midi.Sequencer 中的方法
停止录制（如果处于活动状态）。
store(OutputStream, char[]) - 类 java.security.KeyStore 中的方法
将此 keystore 存储到给定输出流，并用给定密码保护其完整性。
store(KeyStore.LoadStoreParameter) - 类 java.security.KeyStore 中的方法
使用给定 LoadStoreParameter 存储此 keystore。
store(Writer, String) - 类 java.util.Properties 中的方法
以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。
store(OutputStream, String) - 类 java.util.Properties 中的方法
以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。
store() - 类 javax.management.modelmbean.RequiredModelMBean 中的方法
捕获此 MBean 实例的当前状态，并将它写出到持久存储中。
store() - 接口 javax.management.PersistentMBean 中的方法
捕获此 MBean 实例的当前状态并将其写出到持久存储中。
STORED - 类 java.util.zip.ZipEntry 中的静态变量
用于未压缩条目的压缩方法。
STORED - 类 java.util.zip.ZipOutputStream 中的静态变量
用于未压缩 (STORED) 条目的压缩方法。
storesLowerCaseIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
storesLowerCaseQuotedIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
storesMixedCaseIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
storesMixedCaseQuotedIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
storeState(Hashtable<Object, Object>) - 接口 javax.swing.undo.StateEditable 中的方法
收到此消息时，接收者应把任何相关状态放置到 state 中。
storesUpperCaseIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
storesUpperCaseQuotedIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
storeToXML(OutputStream, String) - 类 java.util.Properties 中的方法
发出一个表示此表中包含的所有属性的 XML 文档。
storeToXML(OutputStream, String, String) - 类 java.util.Properties 中的方法
使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。
strategy - 类 javax.swing.text.FlowView 中的变量
保持流更新的行为。
STREAM_MAGIC - 接口 java.io.ObjectStreamConstants 中的静态变量
写入流头的幻数。
STREAM_VERSION - 接口 java.io.ObjectStreamConstants 中的静态变量
写入流头的版本号。
Streamable - org.omg.CORBA.portable 中的 接口
所有复杂 IDL 类型的 Holder 类的基类。
StreamableValue - org.omg.CORBA.portable 中的 接口
为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。
StreamCorruptedException - java.io 中的 异常
当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
StreamCorruptedException(String) - 异常 java.io.StreamCorruptedException 的构造方法
创建一个 StreamCorruptedException 并列出抛出异常的一个原因。
StreamCorruptedException() - 异常 java.io.StreamCorruptedException 的构造方法
创建一个 StreamCorruptedException，但不列出抛出异常的原因。
StreamDescriptionProperty - 接口 javax.swing.text.Document 中的静态变量
用于描述初始化文档的流的属性名。
StreamFilter - javax.xml.stream 中的 接口
此接口声明了一个简单的过滤器接口，用户可创建它来过滤 XMLStreamReader。
StreamHandler - java.util.logging 中的 类
基于流的日志 Handler。
StreamHandler() - 类 java.util.logging.StreamHandler 的构造方法
创建不带当前输出流的 StreamHandler。
StreamHandler(OutputStream, Formatter) - 类 java.util.logging.StreamHandler 的构造方法
创建带给定 Formatter 和输出流的 StreamHandler。
streamPos - 类 javax.imageio.stream.ImageInputStreamImpl 中的变量
流中的当前读取位置。
StreamPrintService - javax.print 中的 类
此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。
StreamPrintService(OutputStream) - 类 javax.print.StreamPrintService 的构造方法
构造一个 StreamPrintService 对象。
StreamPrintServiceFactory - javax.print 中的 类
StreamPrintServiceFactory 是 StreamPrintService 实例的工厂，StreamPrintService 可以 mime 类型所描述的特定文档格式向输出流中打印数据。
StreamPrintServiceFactory() - 类 javax.print.StreamPrintServiceFactory 的构造方法
StreamReaderDelegate - javax.xml.stream.util 中的 类
该类是用于派生 XMLStreamReader 过滤器的基类。
StreamReaderDelegate() - 类 javax.xml.stream.util.StreamReaderDelegate 的构造方法
构造没有父过滤器的空过滤器。
StreamReaderDelegate(XMLStreamReader) - 类 javax.xml.stream.util.StreamReaderDelegate 的构造方法
用指定的父过滤器来构造一个过滤器。
StreamResult - javax.xml.transform.stream 中的 类
充当转换结果的持有者，可以为 XML、纯文本、HTML 或某些其他格式的标记。
StreamResult() - 类 javax.xml.transform.stream.StreamResult 的构造方法
零参数的默认构造方法。
StreamResult(OutputStream) - 类 javax.xml.transform.stream.StreamResult 的构造方法
从字节流构造 StreamResult。
StreamResult(Writer) - 类 javax.xml.transform.stream.StreamResult 的构造方法
从字符流构造 StreamResult。
StreamResult(String) - 类 javax.xml.transform.stream.StreamResult 的构造方法
从 URL 构造 StreamResult。
StreamResult(File) - 类 javax.xml.transform.stream.StreamResult 的构造方法
从 File 构造 StreamResult。
StreamSource - javax.xml.transform.stream 中的 类
以 XML 标记流的形式充当转换 Source 的持有者。
StreamSource() - 类 javax.xml.transform.stream.StreamSource 的构造方法
零参数的默认构造方法。
StreamSource(InputStream) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从字节流构造 StreamSource。
StreamSource(InputStream, String) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从字节流构造 StreamSource。
StreamSource(Reader) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从字符 reader 构造 StreamSource。
StreamSource(Reader, String) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从字符 reader 构造 StreamSource。
StreamSource(String) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从 URL 构造 StreamSource。
StreamSource(File) - 类 javax.xml.transform.stream.StreamSource 的构造方法
从 File 构造 StreamSource。
StreamTokenizer - java.io 中的 类
StreamTokenizer 类获取输入流并将其解析为“标记”，允许一次读取一个标记。
StreamTokenizer(InputStream) - 类 java.io.StreamTokenizer 的构造方法
已过时。 从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
StreamTokenizer(Reader) - 类 java.io.StreamTokenizer 的构造方法
创建解析给定字符流的标记生成器。
STRENGTH - 类 javax.security.sasl.Sasl 中的静态变量
属性名，指定要使用的密码强度。
STRICT - 类 java.lang.reflect.Modifier 中的静态变量
表示 strictfp 修饰符的 int 的值。
strict - 类 javax.swing.text.html.parser.Parser 中的变量
此标记确定 Parser 在强制执行 SGML 兼容性方面是否严格。
StrictMath - java.lang 中的 类
StrictMath 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。
STRIKE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
STRIKETHROUGH - 类 java.awt.font.TextAttribute 中的静态变量
删除线的属性键。
StrikeThrough - 类 javax.swing.text.StyleConstants 中的静态变量
删除线属性的名称。
STRIKETHROUGH_ON - 类 java.awt.font.TextAttribute 中的静态变量
单删除线。
String - java.lang 中的 类
String 类代表字符串。
String() - 类 java.lang.String 的构造方法
初始化一个新创建的 String 对象，使其表示一个空字符序列。
String(String) - 类 java.lang.String 的构造方法
初始化一个新创建的 String 对象，使其表示一个与参数相同的字符序列；换句话说，新创建的字符串是该参数字符串的副本。
String(char[]) - 类 java.lang.String 的构造方法
分配一个新的 String，使其表示字符数组参数中当前包含的字符序列。
String(char[], int, int) - 类 java.lang.String 的构造方法
分配一个新的 String，它包含取自字符数组参数一个子数组的字符。
String(int[], int, int) - 类 java.lang.String 的构造方法
分配一个新的 String，它包含 Unicode 代码点数组参数一个子数组的字符。
String(byte[], int, int, int) - 类 java.lang.String 的构造方法
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
String(byte[], int) - 类 java.lang.String 的构造方法
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
String(byte[], int, int, String) - 类 java.lang.String 的构造方法
通过使用指定的字符集解码指定的 byte 子数组，构造一个新的 String。
String(byte[], int, int, Charset) - 类 java.lang.String 的构造方法
通过使用指定的 charset 解码指定的 byte 子数组，构造一个新的 String。
String(byte[], String) - 类 java.lang.String 的构造方法
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。
String(byte[], Charset) - 类 java.lang.String 的构造方法
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。
String(byte[], int, int) - 类 java.lang.String 的构造方法
通过使用平台的默认字符集解码指定的 byte 子数组，构造一个新的 String。
String(byte[]) - 类 java.lang.String 的构造方法
通过使用平台的默认字符集解码指定的 byte 数组，构造一个新的 String。
String(StringBuffer) - 类 java.lang.String 的构造方法
分配一个新的字符串，它包含字符串缓冲区参数中当前包含的字符序列。
String(StringBuilder) - 类 java.lang.String 的构造方法
分配一个新的字符串，它包含字符串生成器参数中当前包含的字符序列。
STRING - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.String 的值。
STRING - 类 javax.xml.xpath.XPathConstants 中的静态变量
XPath 1.0 字符串数据类型。
STRING_TO_COMPARE_VALUE_DIFFERED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性与“要比较的字符串”值不同的通知类型。
STRING_TO_COMPARE_VALUE_MATCHED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性与“要比较的字符串”值匹配的通知类型。
string_to_object(String) - 类 org.omg.CORBA.ORB 中的方法
将方法 object_to_string 生成的字符串转换回 CORBA 对象引用。
StringBuffer - java.lang 中的 类
线程安全的可变字符序列。
StringBuffer() - 类 java.lang.StringBuffer 的构造方法
构造一个其中不带字符的字符串缓冲区，初始容量为 16 个字符。
StringBuffer(int) - 类 java.lang.StringBuffer 的构造方法
构造一个不带字符，但具有指定初始容量的字符串缓冲区。
StringBuffer(String) - 类 java.lang.StringBuffer 的构造方法
构造一个字符串缓冲区，并将其内容初始化为指定的字符串内容。
StringBuffer(CharSequence) - 类 java.lang.StringBuffer 的构造方法
public java.lang.StringBuilder(CharSequence seq) 构造一个字符串缓冲区，它包含与指定的 CharSequence 相同的字符。
StringBufferInputStream - java.io 中的 类
已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。
StringBufferInputStream(String) - 类 java.io.StringBufferInputStream 的构造方法
已过时。 创建一个字符串输入流，以从指定字符串读取数据。
StringBuilder - java.lang 中的 类
一个可变的字符序列。
StringBuilder() - 类 java.lang.StringBuilder 的构造方法
构造一个其中不带字符的字符串生成器，初始容量为 16 个字符。
StringBuilder(int) - 类 java.lang.StringBuilder 的构造方法
构造一个其中不带字符的字符串生成器，初始容量由 capacity 参数指定。
StringBuilder(String) - 类 java.lang.StringBuilder 的构造方法
构造一个字符串生成器，并初始化为指定的字符串内容。
StringBuilder(CharSequence) - 类 java.lang.StringBuilder 的构造方法
构造一个字符串生成器，包含与指定的 CharSequence 相同的字符。
StringCharacterIterator - java.text 中的 类
StringCharacterIterator 为 String 实现 CharacterIterater 协议。
StringCharacterIterator(String) - 类 java.text.StringCharacterIterator 的构造方法
构造初始索引为 0 的迭代器。
StringCharacterIterator(String, int) - 类 java.text.StringCharacterIterator 的构造方法
构造具有指定的初始索引的迭代器。
StringCharacterIterator(String, int, int, int) - 类 java.text.StringCharacterIterator 的构造方法
构造对给定字符串的给定范围进行迭代的迭代器（其索引设置为指定位置）。
StringContent - javax.swing.text 中的 类
AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。
StringContent() - 类 javax.swing.text.StringContent 的构造方法
创建新的 StringContent 对象。
StringContent(int) - 类 javax.swing.text.StringContent 的构造方法
创建具有指定初始大小的新 StringContent。
stringFlavor - 类 java.awt.datatransfer.DataFlavor 中的静态变量
DataFlavor 表示 Java Unicode String 类，其中：
StringHolder - org.omg.CORBA 中的 类
String 的 Holder。
StringHolder() - 类 org.omg.CORBA.StringHolder 的构造方法
构造一个新的 StringHolder 对象，将其 value 字段初始化为 null。
StringHolder(String) - 类 org.omg.CORBA.StringHolder 的构造方法
构造一个新的 StringHolder 对象，并使用给定 String 初始化其 value 字段。
StringIndexOutOfBoundsException - java.lang 中的 异常
此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
StringIndexOutOfBoundsException() - 异常 java.lang.StringIndexOutOfBoundsException 的构造方法
构造不带详细消息的 StringIndexOutOfBoundsException。
StringIndexOutOfBoundsException(String) - 异常 java.lang.StringIndexOutOfBoundsException 的构造方法
构造带指定详细消息的 StringIndexOutOfBoundsException。
StringIndexOutOfBoundsException(int) - 异常 java.lang.StringIndexOutOfBoundsException 的构造方法
构造一个新的 StringIndexOutOfBoundsException 类，该类带有一个指示非法索引的参数。
StringMonitor - javax.management.monitor 中的 类
定义设计用于观察字符串属性值的监视器 MBean。
StringMonitor() - 类 javax.management.monitor.StringMonitor 的构造方法
默认构造方法。
StringMonitorMBean - javax.management.monitor 中的 接口
公开字符串监视器 MBean 的远程管理接口。
StringNameHelper - org.omg.CosNaming.NamingContextExtPackage 中的 类
StringName 是以 String 形式表示的“字符串化的名称”和“名称组件数组”。
StringNameHelper() - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 的构造方法
stringPropertyNames() - 类 java.util.Properties 中的方法
返回此属性列表中的键集，其中该键及其对应值是字符串，如果在主属性列表中未找到同名的键，则还包括默认属性列表中不同的键。
StringReader - java.io 中的 类
其源为一个字符串的字符流。
StringReader(String) - 类 java.io.StringReader 的构造方法
创建一个新字符串 reader。
StringRefAddr - javax.naming 中的 类
此类表示通信终端地址的字符串形式。
StringRefAddr(String, String) - 类 javax.naming.StringRefAddr 的构造方法
使用地址类型和内容构造一个新的 StringRefAddr 实例。
StringSelection - java.awt.datatransfer 中的 类
实现传输 String 所需能力的 Transferable。
StringSelection(String) - 类 java.awt.datatransfer.StringSelection 的构造方法
创建能传输指定 String 的 Transferable。
StringSeqHelper - org.omg.CORBA 中的 类
String 数组
StringSeqHelper() - 类 org.omg.CORBA.StringSeqHelper 的构造方法
StringSeqHolder - org.omg.CORBA 中的 类
String 数组
StringSeqHolder() - 类 org.omg.CORBA.StringSeqHolder 的构造方法
StringSeqHolder(String[]) - 类 org.omg.CORBA.StringSeqHolder 的构造方法
stringToColor(String) - 类 javax.swing.text.html.StyleSheet 中的方法
将颜色字符串（如 "RED" 或 "#NNNNNN"）转换为 Color。
StringTokenizer - java.util 中的 类
string tokenizer 类允许应用程序将字符串分解为标记。
StringTokenizer(String, String, boolean) - 类 java.util.StringTokenizer 的构造方法
为指定字符串构造一个 string tokenizer。
StringTokenizer(String, String) - 类 java.util.StringTokenizer 的构造方法
为指定字符串构造一个 string tokenizer。
StringTokenizer(String) - 类 java.util.StringTokenizer 的构造方法
为指定字符串构造一个 string tokenizer。
stringToValue(String) - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
分析 text，返回任意 Object。
stringToValue(String) - 类 javax.swing.text.DefaultFormatter 中的方法
通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。
stringToValue(String) - 类 javax.swing.text.InternationalFormatter 中的方法
返回 String text 的 Object 表示形式。
stringToValue(String) - 类 javax.swing.text.MaskFormatter 中的方法
解析文本，返回 String value 的适当 Object 表示形式。
StringValueExp - javax.management 中的 类
表示作为关系约束变量的字符串。
StringValueExp() - 类 javax.management.StringValueExp 的构造方法
基本构造方法。
StringValueExp(String) - 类 javax.management.StringValueExp 的构造方法
创建表示给定字符串的新 StringValueExp。
StringValueHelper - org.omg.CORBA 中的 类
StringValue 的 Helper。
StringValueHelper() - 类 org.omg.CORBA.StringValueHelper 的构造方法
stringWidth(String) - 类 java.awt.FontMetrics 中的方法
返回此 Font 中指定 String 的总 advance width。
StringWriter - java.io 中的 类
一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
StringWriter() - 类 java.io.StringWriter 的构造方法
使用默认初始字符串缓冲区大小创建一个新字符串 writer。
StringWriter(int) - 类 java.io.StringWriter 的构造方法
使用指定初始字符串缓冲区大小创建一个新字符串 writer。
STRIP - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "strip"，某些属性的可能值。
stripTrailingZeros() - 类 java.math.BigDecimal 中的方法
返回数值上等于此小数，但从该表示形式移除所有尾部零的 BigDecimal。
STROKE - 类 java.awt.font.ShapeGraphicAttribute 中的静态变量
指示该形状应使用 1 像素宽的笔画进行勾画的键。
Stroke - java.awt 中的 接口
Stroke 接口允许 Graphics2D 对象获得一个 Shape，该 Shape 是指定 Shape 的装饰轮廓，或该轮廓的风格表示形式。
STRONG - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Struct - java.sql 中的 接口
用于 SQL 结构化类型的 Java 编程语言中的标准映射关系。
STRUCT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 STRUCT 的 Java 编程语言中的常量（有时称为类型代码）。
StructMember - org.omg.CORBA 中的 类
描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。
StructMember() - 类 org.omg.CORBA.StructMember 的构造方法
构造一个默认 StructMember 对象。
StructMember(String, TypeCode, IDLType) - 类 org.omg.CORBA.StructMember 的构造方法
构造一个 StructMember 对象，并使用给定值进行初始化。
StructMemberHelper - org.omg.CORBA 中的 类
StructMember 的 Helper。
StructMemberHelper() - 类 org.omg.CORBA.StructMemberHelper 的构造方法
Stub - javax.rmi.CORBA 中的 类
必须从其继承所有 RMI-IIOP stub 的基类。
Stub() - 类 javax.rmi.CORBA.Stub 的构造方法
StubDelegate - javax.rmi.CORBA 中的 接口
支持 Stub 中方法实现的委托。
StubNotFoundException - java.rmi 中的 异常
如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
StubNotFoundException(String) - 异常 java.rmi.StubNotFoundException 的构造方法
构造带指定详细消息的 StubNotFoundException。
StubNotFoundException(String, Exception) - 异常 java.rmi.StubNotFoundException 的构造方法
构造带指定详细消息和嵌入异常的 StubNotFoundException。
style - 类 java.awt.Font 中的变量
Font 的样式，它被传递到构造方法中。
STYLE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
STYLE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
Style - javax.swing.text 中的 接口
与文档中某个元素相关的属性集合。
styleChanged(Style) - 类 javax.swing.text.DefaultStyledDocument 中的方法
此文档样式有任何改变时调用。
StyleConstants - javax.swing.text 中的 类
一个已知的 或常见的属性键和方法的集合，可通过应用 AttributeSet 或 MutableAttributeSet 方法以类型安全的方式获取/设置属性。
StyleConstants.CharacterConstants - javax.swing.text 中的 类
这是一个类型安全的已知 属性的枚举，它用于字符样式。
StyleConstants.ColorConstants - javax.swing.text 中的 类
这是一个类型安全的已知 属性的枚举，它用于颜色样式。
StyleConstants.FontConstants - javax.swing.text 中的 类
这是一个类型安全的已知 属性的枚举，它用于字体样式。
StyleConstants.ParagraphConstants - javax.swing.text 中的 类
这是一个类型安全的已知 属性的枚举，它用于段落样式。
StyleContext - javax.swing.text 中的 类
样式池及其关联的资源。
StyleContext() - 类 javax.swing.text.StyleContext 的构造方法
创建新的 StyleContext 对象。
StyleContext.NamedStyle - javax.swing.text 中的 类
通常用于表示字符和段落样式的属性集合。
StyleContext.NamedStyle(String, Style) - 类 javax.swing.text.StyleContext.NamedStyle 的构造方法
创建新的命名样式。
StyleContext.NamedStyle(Style) - 类 javax.swing.text.StyleContext.NamedStyle 的构造方法
创建新的命名样式。
StyleContext.NamedStyle() - 类 javax.swing.text.StyleContext.NamedStyle 的构造方法
利用 null 名称和父级创建新的命名样式。
StyleContext.SmallAttributeSet - javax.swing.text 中的 类
此类可在数组中存储少量的属性。
StyleContext.SmallAttributeSet(Object[]) - 类 javax.swing.text.StyleContext.SmallAttributeSet 的构造方法
StyleContext.SmallAttributeSet(AttributeSet) - 类 javax.swing.text.StyleContext.SmallAttributeSet 的构造方法
StyledDocument - javax.swing.text 中的 接口
用作通用样式化文档的接口。
StyledEditorKit - javax.swing.text 中的 类
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
StyledEditorKit() - 类 javax.swing.text.StyledEditorKit 的构造方法
创建供样式化文档使用新的 EditorKit。
StyledEditorKit.AlignmentAction - javax.swing.text 中的 类
设置段落对齐的操作。
StyledEditorKit.AlignmentAction(String, int) - 类 javax.swing.text.StyledEditorKit.AlignmentAction 的构造方法
创建新的 AlignmentAction。
StyledEditorKit.BoldAction - javax.swing.text 中的 类
切换粗体属性的操作。
StyledEditorKit.BoldAction() - 类 javax.swing.text.StyledEditorKit.BoldAction 的构造方法
构造新的 BoldAction。
StyledEditorKit.FontFamilyAction - javax.swing.text 中的 类
在相关的 JEditorPane 中设置字体系列的操作。
StyledEditorKit.FontFamilyAction(String, String) - 类 javax.swing.text.StyledEditorKit.FontFamilyAction 的构造方法
创建新的 FontFamilyAction。
StyledEditorKit.FontSizeAction - javax.swing.text 中的 类
设置关联的 JEditorPane 中字体大小的操作。
StyledEditorKit.FontSizeAction(String, int) - 类 javax.swing.text.StyledEditorKit.FontSizeAction 的构造方法
创建新 FontSizeAction。
StyledEditorKit.ForegroundAction - javax.swing.text 中的 类
设置前景色的操作。
StyledEditorKit.ForegroundAction(String, Color) - 类 javax.swing.text.StyledEditorKit.ForegroundAction 的构造方法
创建新的 ForegroundAction。
StyledEditorKit.ItalicAction - javax.swing.text 中的 类
切换斜体属性的一种操作。
StyledEditorKit.ItalicAction() - 类 javax.swing.text.StyledEditorKit.ItalicAction 的构造方法
构造新的 ItalicAction。
StyledEditorKit.StyledTextAction - javax.swing.text 中的 类
假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
StyledEditorKit.StyledTextAction(String) - 类 javax.swing.text.StyledEditorKit.StyledTextAction 的构造方法
通过字符串操作名称创建新的 StyledTextAction。
StyledEditorKit.UnderlineAction - javax.swing.text 中的 类
切换下划线属性的操作。
StyledEditorKit.UnderlineAction() - 类 javax.swing.text.StyledEditorKit.UnderlineAction 的构造方法
创建新的 UnderlineAction。
StyleSheet - javax.swing.text.html 中的 类
支持定义要呈现的 HTML 视图的可视化特征。
StyleSheet() - 类 javax.swing.text.html.StyleSheet 的构造方法
构造 StyleSheet
StyleSheet.BoxPainter - javax.swing.text.html 中的 类
可以执行某些 CSS 格式化任务的类。
StyleSheet.ListPainter - javax.swing.text.html 中的 类
要执行某些 CSS 列表格式化任务的类。
SUB - 类 javax.swing.text.html.HTML.Tag 中的静态变量
SUBCLASS_IMPLEMENTATION_PERMISSION - 接口 java.io.ObjectStreamConstants 中的静态变量
允许重写 readObject 和 writeObject。
subdivide(CubicCurve2D, CubicCurve2D) - 类 java.awt.geom.CubicCurve2D 中的方法
细分此三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
subdivide(CubicCurve2D, CubicCurve2D, CubicCurve2D) - 类 java.awt.geom.CubicCurve2D 中的静态方法
细分由 src 参数指定的三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
subdivide(double[], int, double[], int, double[], int) - 类 java.awt.geom.CubicCurve2D 中的静态方法
细分由存储在 src 数组 srcoff 到 (srcoff + 7) 索引处的坐标指定的三次曲线，并将得到的两个细分曲线存储到所得数组的相应索引中。
subdivide(QuadCurve2D, QuadCurve2D) - 类 java.awt.geom.QuadCurve2D 中的方法
细分此 QuadCurve2D 并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
subdivide(QuadCurve2D, QuadCurve2D, QuadCurve2D) - 类 java.awt.geom.QuadCurve2D 中的静态方法
细分由 src 参数指定的二次曲线并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
subdivide(double[], int, double[], int, double[], int) - 类 java.awt.geom.QuadCurve2D 中的静态方法
细分由存储在 src 数组 srcoff 到 (srcoff + 5) 索引处的坐标指定的二次曲线，并将得到的两个细分曲线存储到所得数组的相应索引中。
Subject - javax.security.auth 中的 类
Subject 表示某一项（如一个人）的一组相关信息。
Subject() - 类 javax.security.auth.Subject 的构造方法
创建一个带有空的 Principal Set 和空的公开或私有证书 Set 的 Subject 的一个实例。
Subject(boolean, Set<? extends Principal>, Set<?>, Set<?>) - 类 javax.security.auth.Subject 的构造方法
创建带有 Principal 和证书的 Subject 的实例。
SubjectDelegationPermission - javax.management.remote 中的 类
授权标识表示验证标识执行操作所需的权限。
SubjectDelegationPermission(String) - 类 javax.management.remote.SubjectDelegationPermission 的构造方法
创建具有指定名称的新 SubjectDelegationPermission。
SubjectDelegationPermission(String, String) - 类 javax.management.remote.SubjectDelegationPermission 的构造方法
创建带指定名称的新 SubjectDelegationPermission 对象。
SubjectDomainCombiner - javax.security.auth 中的 类
SubjectDomainCombiner 通过与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新 ProtectionDomains。
SubjectDomainCombiner(Subject) - 类 javax.security.auth.SubjectDomainCombiner 的构造方法
将提供的 Subject 与此 SubjectDomainCombiner 关联。
subList(int, int) - 类 java.util.AbstractList 中的方法
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
subList(int, int) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表中 fromIndex（包括）和 toIndex（不包括）之间部分的视图。
subList(int, int) - 接口 java.util.List 中的方法
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
subList(int, int) - 类 java.util.Vector 中的方法
返回此 List 的部分视图，元素范围为从 fromIndex（包括）到 toIndex（不包括）。
subMap(K, boolean, K, boolean) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
subMap(K, K) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
subMap(K, boolean, K, boolean) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
subMap(K, K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
subMap(K, boolean, K, boolean) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键的范围从 fromKey 到 toKey。
subMap(K, K) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
subMap(K, K) - 接口 java.util.SortedMap 中的方法
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
subMap(K, boolean, K, boolean) - 类 java.util.TreeMap 中的方法
subMap(K, K) - 类 java.util.TreeMap 中的方法
SUBMISSION_INTERRUPTED - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
由于某些不可预见的原因，作业未完成提交。
submit(Runnable) - 类 java.util.concurrent.AbstractExecutorService 中的方法
submit(Runnable, T) - 类 java.util.concurrent.AbstractExecutorService 中的方法
submit(Callable<T>) - 类 java.util.concurrent.AbstractExecutorService 中的方法
submit(Callable<V>) - 接口 java.util.concurrent.CompletionService 中的方法
提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。
submit(Runnable, V) - 接口 java.util.concurrent.CompletionService 中的方法
提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。
submit(Callable<V>) - 类 java.util.concurrent.ExecutorCompletionService 中的方法
submit(Runnable, V) - 类 java.util.concurrent.ExecutorCompletionService 中的方法
submit(Callable<T>) - 接口 java.util.concurrent.ExecutorService 中的方法
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
submit(Runnable, T) - 接口 java.util.concurrent.ExecutorService 中的方法
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
submit(Runnable) - 接口 java.util.concurrent.ExecutorService 中的方法
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
submit(Runnable) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
submit(Runnable, T) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
submit(Callable<T>) - 类 java.util.concurrent.ScheduledThreadPoolExecutor 中的方法
SUBMIT - 类 javax.swing.text.html.FormView 中的静态变量
已过时。 从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值
submitData(String) - 类 javax.swing.text.html.FormView 中的方法
此方法负责提交表单数据。
subsamplingXOffset - 类 javax.imageio.IIOParam 中的变量
在进行二次取样之前，将水平偏移量应用于二次取样网格。
subsamplingYOffset - 类 javax.imageio.IIOParam 中的变量
在进行二次取样之前，将垂直偏移量应用于二次取样网格。
Subscript - 类 javax.swing.text.StyleConstants 中的静态变量
下标属性的名称。
subSequence(int, int) - 接口 java.lang.CharSequence 中的方法
返回一个新的 CharSequence，它是此序列的子序列。
subSequence(int, int) - 类 java.lang.String 中的方法
返回一个新的字符序列，它是此序列的一个子序列。
subSequence(int, int) - 类 java.lang.StringBuffer 中的方法
subSequence(int, int) - 类 java.nio.CharBuffer 中的方法
创建表示此缓冲区的指定序列、相对于当前位置的新字符缓冲区。
subSequence(int, int) - 类 javax.swing.text.Segment 中的方法
返回一个新的 CharSequence，它是此序列的子序列。
subSet(E, boolean, E, boolean) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
subSet(E, E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
subSet(E, boolean, E, boolean) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。
subSet(E, E) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
subSet(E, E) - 接口 java.util.SortedSet 中的方法
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
subSet(E, boolean, E, boolean) - 类 java.util.TreeSet 中的方法
subSet(E, E) - 类 java.util.TreeSet 中的方法
substituteColorModel(ColorModel, ColorModel) - 类 java.awt.image.RGBImageFilter 中的方法
注册两个用于替换的 ColorModel 对象。
SUBSTITUTION_PERMISSION - 接口 java.io.ObjectStreamConstants 中的静态变量
允许在序列化/反序列化期间使用一个对象取代另一个对象。
substring(int) - 类 java.lang.String 中的方法
返回一个新的字符串，它是此字符串的一个子字符串。
substring(int, int) - 类 java.lang.String 中的方法
返回一个新字符串，它是此字符串的一个子字符串。
substring(int) - 类 java.lang.StringBuffer 中的方法
substring(int, int) - 类 java.lang.StringBuffer 中的方法
substringData(int, int) - 接口 org.w3c.dom.CharacterData 中的方法
从该节点提取某个范围的数据。
subtract(Area) - 类 java.awt.geom.Area 中的方法
从此 Area 的形状中减去指定 Area 的形状。
subtract(BigDecimal) - 类 java.math.BigDecimal 中的方法
返回一个 BigDecimal，其值为 (this - subtrahend)，其标度为 max(this.scale(), subtrahend.scale())。
subtract(BigDecimal, MathContext) - 类 java.math.BigDecimal 中的方法
返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。
subtract(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this - val) 的 BigInteger。
SUBTRACT - 类 javax.xml.crypto.dsig.spec.XPathType.Filter 中的静态变量
减少过滤操作。
subtract(Duration) - 类 javax.xml.datatype.Duration 中的方法
计算值为 this-rhs 的新持续时间。
SUBTREE_SCOPE - 类 javax.naming.directory.SearchControls 中的静态变量
搜索以命名对象为根的整个子树。
SUBTREE_SCOPE - 接口 javax.naming.event.EventContext 中的静态变量
该常量用来表示对涉及目标指定对象的子树中对象的事件感兴趣，包括目标指定的对象。
SUBWINDOW_OF - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示某个对象是一个或多个对象的子窗口。
SUBWINDOW_OF_PROPERTY - 类 javax.accessibility.AccessibleRelation 中的静态变量
指示两个或多个对象之间的 SUBWINDOW_OF 关系已更改。
SUCCESS_NO_INFO - 接口 java.sql.Statement 中的静态变量
该常量指示批量语句执行成功但不存在受影响的可用行数计数。
SUCCESSFUL - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/SUCCESSFUL.java。
SUFFICIENT - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的静态变量
足够的 LoginModule。
suffixes - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
从 getFileSuffixes 返回的字符串数组，该数组最初为 null。
sum(Spring, Spring) - 类 javax.swing.Spring 中的静态方法
返回 s1+s2：一个连续表示 s1 和 s2 的 spring。
SUNDAY - 类 java.util.Calendar 中的静态变量
指示 Sunday 的 Calendar.DAY_OF_WEEK 字段值。
SUP - 类 javax.swing.text.html.HTML.Tag 中的静态变量
superLayout(Container) - 类 javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager 中的方法
SUPERSCRIPT - 类 java.awt.font.TextAttribute 中的静态变量
用于上标和下标的属性键。
Superscript - 类 javax.swing.text.StyleConstants 中的静态变量
上标属性的名称。
SUPERSCRIPT_SUB - 类 java.awt.font.TextAttribute 中的静态变量
标准下标。
SUPERSCRIPT_SUPER - 类 java.awt.font.TextAttribute 中的静态变量
标准上标。
SUPERSCRIPTS_AND_SUBSCRIPTS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Superscripts and Subscripts”Unicode 字符块的常量。
SUPPLEMENTAL_ARROWS_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplemental Arrows-A”Unicode 字符块的常量。
SUPPLEMENTAL_ARROWS_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplemental Arrows-B”Unicode 字符块的常量。
SUPPLEMENTAL_MATHEMATICAL_OPERATORS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplemental Mathematical Operators”Unicode 字符块的常量。
SUPPLEMENTARY_PRIVATE_USE_AREA_A - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplementary Private Use Area-A”Unicode 字符块的常量。
SUPPLEMENTARY_PRIVATE_USE_AREA_B - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Supplementary Private Use Area-B”Unicode 字符块的常量。
SUPPORT_DTD - 类 javax.xml.stream.XMLInputFactory 中的静态变量
要求解析器支持 DTD 的属性。
SUPPORTED - 类 javax.print.attribute.standard.ColorSupported 中的静态变量
该打印机能够进行某些类型的彩色打印，例如高亮颜色或全处理颜色。
SupportedAnnotationTypes - javax.annotation.processing 中的 注释类型
用来指示注释处理器支持哪些注释类型的注释。
SupportedOptions - javax.annotation.processing 中的 注释类型
用来指示注释处理器支持哪些选项的注释。
SupportedSourceVersion - javax.annotation.processing 中的 注释类型
用来指示注释处理器所支持的最新源版本的注释。
SupportedValuesAttribute - javax.print.attribute 中的 接口
接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。
supportsAlterTableWithAddColumn() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持带有 add 列的 ALTER TABLE。
supportsAlterTableWithDropColumn() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持带有 drop 列的 ALTER TABLE。
supportsANSI92EntryLevelSQL() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ANSI92 入门级 SQL 语法。
supportsANSI92FullSQL() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持受支持的 ANSI92 完全 SQL 语法。
supportsANSI92IntermediateSQL() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持受支持的 ANSI92 中间 SQL 语法。
supportsBatchUpdates() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持批量更新。
supportsCatalogsInDataManipulation() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在数据操作语句中使用。
supportsCatalogsInIndexDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在获取定义语句中使用。
supportsCatalogsInPrivilegeDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在特权定义语句中使用。
supportsCatalogsInProcedureCalls() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在过程调用语句中使用。
supportsCatalogsInTableDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个类别名称是否可以在表定义语句中使用。
supportsColumnAliasing() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持为列提供别名。
supportsConvert() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持用于 JDBC 类型之间转换的 JDBC 标量函数 CONVERT。
supportsConvert(int, int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持用于 JDBC fromType 和 toType 类型之间转换的 JDBC 标量函数 CONVERT。
supportsCoreSQLGrammar() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ODBC Core SQL 语法。
supportsCorrelatedSubqueries() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持相关子查询。
supportsCrossJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 CROSS_JOIN。
supportsCustomEditor() - 接口 java.beans.PropertyEditor 中的方法
确定此属性编辑器是否支持自定义编辑器。
supportsCustomEditor() - 类 java.beans.PropertyEditorSupport 中的方法
确定 propertyEditor 是否可以提供自定义编辑器。
supportsDataDefinitionAndDataManipulationTransactions() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否同时支持事务中的数据定义和数据操作语句。
supportsDataManipulationTransactionsOnly() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否仅支持事务中的数据操作语句。
supportsDifferentTableCorrelationNames() - 接口 java.sql.DatabaseMetaData 中的方法
获取在表关联名称受支持时，是否要限制它们与表的名称不同。
supportsExpressionsInOrderBy() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ORDER BY 列表中的表达式。
supportsExtendedSQLGrammar() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ODBC Extended SQL 语法。
supportsFullJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 FULL_JOIN。
supportsFullOuterJoins() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持完全嵌套的外连接。
supportsGetGeneratedKeys() - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以在执行语句后获取自动生成的键。
supportsGroupBy() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持某种形式的 GROUP BY 子句。
supportsGroupByBeyondSelect() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用不包含在 SELECT 语句中而包含在 GROUP BY 子句中的列，假设 SELECT 语句中的所有列都包含在 GROUP BY 子句中。
supportsGroupByUnrelated() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用不在 SELECT 语句中而在 GROUP BY 子句中的列。
supportsInnerJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 INNER_JOIN。
supportsIntegrityEnhancementFacility() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 SQL Integrity Enhancement Facility。
supportsLeftOuterJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 LEFT_OUTER_JOIN。
supportsLikeEscapeClause() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持指定 LIKE 转义子句。
supportsLimitedOuterJoins() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否为外连接提供受限制的支持。
supportsMinimumSQLGrammar() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 ODBC Minimum SQL 语法。
supportsMixedCaseIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
supportsMixedCaseQuotedIdentifiers() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
supportsMulticast() - 类 java.net.NetworkInterface 中的方法
返回网络接口是否支持多址广播。
supportsMultipleOpenResults() - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以同时拥有从 CallableStatement 对象中返回的多个 ResultSet 对象。
supportsMultipleResultSets() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持一次调用 execute 方法获得多个 ResultSet 对象。
supportsMultipleTransactions() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否允许一次打开多个事务（在不同的 connection 上）。
supportsNamedParameters() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持可调用语句的指定参数。
supportsNonNullableColumns() - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以将此数据库中的列定义为非 null。
supportsOpenCursorsAcrossCommit() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持在进行提交期间保持游标开放。
supportsOpenCursorsAcrossRollback() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持在回滚期间保持游标开放。
supportsOpenStatementsAcrossCommit() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持在进行提交期间保持语句开放。
supportsOpenStatementsAcrossRollback() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持在回滚期间保持语句开放。
supportsOrderByUnrelated() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用不在 SELECT 语句中而在 ORDER BY 子句中的列。
supportsOuterJoins() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持某种形式的外连接。
supportsParameter(Object) - 类 java.security.Provider.Service 中的方法
测试此 Service 是否能使用指定的参数。
supportsPositionedDelete() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持位置的 DELETE 语句。
supportsPositionedUpdate() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持位置的 UPDATE 语句。
supportsResultSetConcurrency(int, int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持与给定结果集类型结合在一起的给定并发性类型。
supportsResultSetHoldability(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持给定结果集可保存性。
supportsResultSetType(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持给定结果集类型。
supportsRightOuterJoin() - 接口 javax.sql.rowset.JoinRowSet 中的方法
指示 JoinRowSet 实现是否支持 RIGHT_OUTER_JOIN。
supportsSavepoints() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持保存点 (savepoint)。
supportsSchemasInDataManipulation() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以数据操作语句中使用。
supportsSchemasInIndexDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以在获取定义语句中使用。
supportsSchemasInPrivilegeDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以在特权定义语句中使用。
supportsSchemasInProcedureCalls() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以在过程调用语句中使用。
supportsSchemasInTableDefinitions() - 接口 java.sql.DatabaseMetaData 中的方法
获取某个模式名称是否可以在表定义语句中使用。
supportsSelectForUpdate() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持位置的 SELECT FOR UPDATE 语句。
supportsStandardImageMetadataFormat - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
指示此插件是否支持图像元数据的标准元数据格式的 boolean 值，该值最初为 false。
supportsStandardStreamMetadataFormat - 类 javax.imageio.spi.ImageReaderWriterSpi 中的变量
指示此插件是否支持流元数据的标准元数据格式的 boolean 值，该值最初为 false。
supportsStatementPooling() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持语句合并 (statement pooling)。
supportsStoredFunctionsUsingCallSyntax() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用存储过程转义语法调用用户定义的函数或供应商函数。
supportsStoredProcedures() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持使用存储过程转义语法的存储过程调用。
supportsSubqueriesInComparisons() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持比较表达式中的子查询。
supportsSubqueriesInExists() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 EXISTS 表达式中的子查询。
supportsSubqueriesInIns() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 IN 表达式中的子查询。
supportsSubqueriesInQuantifieds() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持量化表达式 (quantified expression) 中的子查询。
supportsTableCorrelationNames() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持表关联名称。
supportsTransactionIsolationLevel(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持给定事务隔离级别。
supportsTransactions() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持事务。
supportsUnion() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 SQL UNION。
supportsUnionAll() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否支持 SQL UNION ALL。
supportsUpdatableView() - 类 javax.sql.rowset.spi.SyncProvider 中的方法
返回此 SyncProvider 实现是否可以执行 RowSet 对象和数据源（RowSet 从中获取其数据）中的 SQL VIEW 之间的同步。
supportsUrgentData() - 类 java.net.SocketImpl 中的方法
返回此 SocketImpl 是否支持发送紧急数据。
SuppressWarnings - java.lang 中的 注释类型
指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。
SURROGATE - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Cs”。
SURROGATES_AREA - 类 java.lang.Character.UnicodeBlock 中的静态变量
已过时。 从 J2SE 5 开始，使用 Character.UnicodeBlock.HIGH_SURROGATES、Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES 和 Character.UnicodeBlock.LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。Character.UnicodeBlock.of(char) 和 Character.UnicodeBlock.of(int) 方法返回新常量，而不是 SURROGATES_AREA。
suspend() - 类 java.lang.Thread 中的方法
已过时。 该方法已经遭到反对，因为它具有固有的死锁倾向。如果目标线程挂起时在保护关键系统资源的监视器上保持有锁，则在目标线程重新开始以前任何线程都不能访问该资源。如果重新开始目标线程的线程想在调用 resume 之前锁定该监视器，则会发生死锁。这类死锁通常会证明自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
suspend() - 类 java.lang.ThreadGroup 中的方法
已过时。 此方法容易导致死锁。有关详细信息，请参阅 Thread.suspend()。
sval - 类 java.io.StreamTokenizer 中的变量
如果当前标记是一个文字标记，则此字段包含一个给出该文字标记的字符的字符串。
SW_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口左下角大小的光标类型。
SW_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.SW_RESIZE_CURSOR 取代。
swap(List<?>, int, int) - 类 java.util.Collections 中的静态方法
在指定列表的指定位置处交换元素。
SWAP_COLORS - 类 java.awt.font.TextAttribute 中的静态变量
交换前景和背景 Paint 的属性键。
SWAP_COLORS_ON - 类 java.awt.font.TextAttribute 中的静态变量
交换前景和背景。
SWING_COMPONENT - 类 javax.accessibility.AccessibleRole 中的静态变量
一个 Swing 组件，但关于它的其他信息都是未知的。
SwingConstants - javax.swing 中的 接口
通常用于在屏幕上定位或定向组件的常量的集合。
SwingPropertyChangeSupport - javax.swing.event 中的 类
java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。
SwingPropertyChangeSupport(Object) - 类 javax.swing.event.SwingPropertyChangeSupport 的构造方法
构造一个 SwingPropertyChangeSupport 对象。
SwingPropertyChangeSupport(Object, boolean) - 类 javax.swing.event.SwingPropertyChangeSupport 的构造方法
构造一个 SwingPropertyChangeSupport 对象。
SwingUtilities - javax.swing 中的 类
Swing 实用方法的集合。
SwingWorker<T,V> - javax.swing 中的 类
在专用线程中执行长时间 GUI 交互任务的抽象类。
SwingWorker() - 类 javax.swing.SwingWorker 的构造方法
构造此 SwingWorker。
SwingWorker.StateValue - javax.swing 中的 枚举
state 绑定 (bound) 属性的值。
sync() - 类 java.awt.Toolkit 中的方法
同步此工具包的图形状态。
sync() - 类 java.io.FileDescriptor 中的方法
强制所有系统缓冲区与基础设备同步。
sync() - 类 java.util.prefs.AbstractPreferences 中的方法
根据 Preferences.sync() 中的规范实现 sync 方法。
sync() - 类 java.util.prefs.Preferences 中的方法
确保在调用 sync 之前从此首选项节点及其子节点进行的后续读取能反映出提交到持久存储（从任何 VM）的所有更改。
sync_scope() - 接口 org.omg.PortableInterceptor.RequestInfoOperations 中的方法
定义在控制信息返回到客户端前请求应前进的距离。
SYNC_WITH_TRANSPORT - org.omg.Messaging 中的 接口
org/omg/Messaging/SYNC_WITH_TRANSPORT.java。
syncAllWidths - 类 javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout 中的变量
SyncFactory - javax.sql.rowset.spi 中的 类
该服务提供者接口 (SPI) 机制可以生成由非连接 RowSet 对象使用的 SyncProvider 实例。
SyncFactoryException - javax.sql.rowset.spi 中的 异常
指示 SyncFactory 机制发生的错误。
SyncFactoryException() - 异常 javax.sql.rowset.spi.SyncFactoryException 的构造方法
创建不带详细消息的新 SyncFactoryException。
SyncFactoryException(String) - 异常 javax.sql.rowset.spi.SyncFactoryException 的构造方法
构造带指定详细消息的 SyncFactoryException。
SyncFailedException - java.io 中的 异常
当 sync 操作失败时，抛出此异常。
SyncFailedException(String) - 异常 java.io.SyncFailedException 的构造方法
构造一个带详细消息的 SyncFailedException。
synchronize(Line[], boolean) - 接口 javax.sound.sampled.Mixer 中的方法
同步两个或多个行。
SYNCHRONIZED - 类 java.lang.reflect.Modifier 中的静态变量
表示 synchronized 修饰符的 int 值。
synchronizedCollection(Collection<T>) - 类 java.util.Collections 中的静态方法
返回指定 collection 支持的同步（线程安全的）collection。
synchronizedList(List<T>) - 类 java.util.Collections 中的静态方法
返回指定列表支持的同步（线程安全的）列表。
synchronizedMap(Map<K, V>) - 类 java.util.Collections 中的静态方法
返回由指定映射支持的同步（线程安全的）映射。
synchronizedSet(Set<T>) - 类 java.util.Collections 中的静态方法
返回指定 set 支持的同步（线程安全的）set。
synchronizedSortedMap(SortedMap<K, V>) - 类 java.util.Collections 中的静态方法
返回指定有序映射支持的同步（线程安全的）有序映射。
synchronizedSortedSet(SortedSet<T>) - 类 java.util.Collections 中的静态方法
返回指定有序 set 支持的同步（线程安全的）有序 set。
synchronizedView(AttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建给定属性集的同步视图。
synchronizedView(DocAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定文档属性集的同步视图。
synchronizedView(PrintRequestAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印请求属性集的同步视图。
synchronizedView(PrintJobAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印作业属性集的同步视图。
synchronizedView(PrintServiceAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印服务属性集的同步视图。
SynchronousQueue<E> - java.util.concurrent 中的 类
一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。
SynchronousQueue() - 类 java.util.concurrent.SynchronousQueue 的构造方法
创建一个具有非公平访问策略的 SynchronousQueue。
SynchronousQueue(boolean) - 类 java.util.concurrent.SynchronousQueue 的构造方法
创建一个具有指定公平策略的 SynchronousQueue。
SyncProvider - javax.sql.rowset.spi 中的 类
为非连接 RowSet 对象提供 reader/writer 功能的同步机制。
SyncProvider() - 类 javax.sql.rowset.spi.SyncProvider 的构造方法
创建默认的 SyncProvider 对象。
SyncProviderException - javax.sql.rowset.spi 中的 异常
指示 SyncProvider 机制发生的错误。
SyncProviderException() - 异常 javax.sql.rowset.spi.SyncProviderException 的构造方法
创建不带任何详细消息的新 SyncProviderException 对象。
SyncProviderException(String) - 异常 javax.sql.rowset.spi.SyncProviderException 的构造方法
构造带指定详细消息的 SyncProviderException 对象。
SyncProviderException(SyncResolver) - 异常 javax.sql.rowset.spi.SyncProviderException 的构造方法
构造带指定 SyncResolver 实例的 SyncProviderException 对象。
SyncResolver - javax.sql.rowset.spi 中的 接口
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。
SyncScopeHelper - org.omg.Messaging 中的 类
Synchronization 作用域
SyncScopeHelper() - 类 org.omg.Messaging.SyncScopeHelper 的构造方法
syncScrollPaneWithViewport() - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
syncSpi() - 类 java.util.prefs.AbstractPreferences 中的方法
此方法是在此节点被锁定的情况下调用的。
syncWithScrollPane(JScrollPane) - 类 javax.swing.ScrollPaneLayout 中的方法
在 ScrollPaneLayout 被设置为 JScrollPane 的 LayoutManager 后，此方法被调用。
SYNTAX_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果指定无效或非法字符串。
SynthConstants - javax.swing.plaf.synth 中的 接口
由 Synth 使用的常量。
SynthContext - javax.swing.plaf.synth 中的 类
一个不可变的瞬态对象，它包含有关 Region 的上下文信息。
SynthContext(JComponent, Region, SynthStyle, int) - 类 javax.swing.plaf.synth.SynthContext 的构造方法
创建一个具有指定值的 SynthContext。
synthesizedElement(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
如果元素是合成元素，则返回 true。
Synthesizer - javax.sound.midi 中的 接口
Synthesizer 生成声音。
SynthGraphicsUtils - javax.swing.plaf.synth 中的 类
用于基本图形调用的包装器。
SynthGraphicsUtils() - 类 javax.swing.plaf.synth.SynthGraphicsUtils 的构造方法
创建一个 SynthGraphicsUtils。
SynthLookAndFeel - javax.swing.plaf.synth 中的 类
SynthLookAndFeel 提供创建定制外观的基础。
SynthLookAndFeel() - 类 javax.swing.plaf.synth.SynthLookAndFeel 的构造方法
创建一个 SynthLookAndFeel。
SynthPainter - javax.swing.plaf.synth 中的 类
SynthPainter 用于绘制 JComponent 的某些部分。
SynthPainter() - 类 javax.swing.plaf.synth.SynthPainter 的构造方法
SynthStyle - javax.swing.plaf.synth 中的 类
SynthStyle 是一个样式属性集。
SynthStyle() - 类 javax.swing.plaf.synth.SynthStyle 的构造方法
构造一个 SynthStyle。
SynthStyleFactory - javax.swing.plaf.synth 中的 类
用于获得 SynthStyle 的工厂。
SynthStyleFactory() - 类 javax.swing.plaf.synth.SynthStyleFactory 的构造方法
创建一个 SynthStyleFactory。
SYRIAC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Syriac”Unicode 字符块的常量。
SysexMessage - javax.sound.midi 中的 类
表示 MIDI 系统独占消息 SysexMessage 对象。
SysexMessage() - 类 javax.sound.midi.SysexMessage 的构造方法
构造一个新的 SysexMessage。
SysexMessage(byte[]) - 类 javax.sound.midi.SysexMessage 的构造方法
构造一个新的 SysexMessage。
System - java.lang 中的 类
System 类包含一些有用的类字段和方法。
SYSTEM - 接口 javax.swing.text.html.parser.DTDConstants 中的静态变量
SYSTEM_EXCEPTION - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java。
SYSTEM_EXCLUSIVE - 类 javax.sound.midi.SysexMessage 中的静态变量
用于 SYSTEM_EXCLUSIVE 消息的状态字节（0xF0 或 240）。
SYSTEM_ID - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态变量
SYSTEM_PORT - 接口 java.rmi.activation.ActivationSystem 中的静态变量
查找激活系统的端口。
SYSTEM_RESET - 类 javax.sound.midi.ShortMessage 中的静态变量
SYSTEM_RESET 消息的状态字节（0xFF 或 255）。
SystemColor - java.awt 中的 类
封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
SystemException - org.omg.CORBA 中的 异常
所有 CORBA 标准异常的根类。
SystemException(String, int, CompletionStatus) - 异常 org.omg.CORBA.SystemException 的构造方法
使用指定详细消息、次要代码和完成状态构造一个 SystemException 异常。
SystemFlavorMap - java.awt.datatransfer 中的 类
SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。
systemNodeForPackage(Class<?>) - 类 java.util.prefs.Preferences 中的静态方法
从系统首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
systemRoot() - 类 java.util.prefs.Preferences 中的静态方法
返回系统的根首选项节点。
systemRoot() - 接口 java.util.prefs.PreferencesFactory 中的方法
返回系统根首选项节点。
SystemTray - java.awt 中的 类
SystemTray 类表示桌面的系统托盘。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


T - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

T

TAB - 类 java.awt.Event 中的静态变量
Tab 键。
TabableView - javax.swing.text 中的 接口
大小依赖于制表符的 View 的接口。
tabAreaBackground - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的变量
tabAreaInsets - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
TABBED_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
TabbedPane 的 region。
TABBED_PANE_CONTENT - 类 javax.swing.plaf.synth.Region 中的静态变量
包含内容的 TabbedPane 的 region。
TABBED_PANE_TAB - 类 javax.swing.plaf.synth.Region 中的静态变量
某一选项卡的 TabbedPane 的 region。
TABBED_PANE_TAB_AREA - 类 javax.swing.plaf.synth.Region 中的静态变量
包含选项卡的 TabbedPane 的 region。
TabbedPaneUI - javax.swing.plaf 中的 类
JTabbedPane 的可插入外观界面。
TabbedPaneUI() - 类 javax.swing.plaf.TabbedPaneUI 的构造方法
tabChangeListener - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
TabExpander - javax.swing.text 中的 接口
允许不同类型的制表符扩展实现的简单接口。
tabForCoordinate(JTabbedPane, int, int) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
返回与 JTabbedPane 的坐标空间中的指定点相交的选项卡索引。
tabForCoordinate(JTabbedPane, int, int) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 tabForCoordinate 方法。
tabForCoordinate(JTabbedPane, int, int) - 类 javax.swing.plaf.TabbedPaneUI 中的方法
tabInsets - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
TABLE - 类 javax.accessibility.AccessibleRole 中的静态变量
用于根据行和列来呈现信息的对象。
table - 类 javax.swing.plaf.basic.BasicTableUI 中的变量
TABLE - 类 javax.swing.plaf.synth.Region 中的静态变量
Table 的 region。
table - 类 javax.swing.table.JTableHeader 中的变量
将此对象作为其头的表，默认值为 null。
TABLE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
TABLE_HEADER - 类 javax.swing.plaf.synth.Region 中的静态变量
TableHeader 的 region。
TableCellEditor - javax.swing.table 中的 接口
此接口定义了要成为组件（如 JListBox、JComboBox、JTree 或 JTable）的值编辑器的任意对象需要实现的方法。
TableCellRenderer - javax.swing.table 中的 接口
此接口定义了要成为 JTable 中单元格渲染器的任意对象所需的方法。
tableChanged(TableModelEvent) - 接口 javax.swing.event.TableModelListener 中的方法
此细粒度通知告知侦听器单元格、行或列的哪些具体范围发生了更改。
tableChanged(TableModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更
tableChanged(TableModelEvent) - 类 javax.swing.JTable 中的方法
当此表的 TableModel 生成 TableModelEvent 时调用。
TableColumn - javax.swing.table 中的 类
TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。
TableColumn() - 类 javax.swing.table.TableColumn 的构造方法
覆盖方法，它使用的默认模型索引为 0、默认宽度为 75、渲染器为 null、编辑器为 null。
TableColumn(int) - 类 javax.swing.table.TableColumn 的构造方法
覆盖方法，它使用的默认宽度为 75、渲染器为 null、编辑器为 null。
TableColumn(int, int) - 类 javax.swing.table.TableColumn 的构造方法
覆盖方法，它使用的渲染器为 null、编辑器为 null 。
TableColumn(int, int, TableCellRenderer, TableCellEditor) - 类 javax.swing.table.TableColumn 的构造方法
使用指定的模型索引、宽度、单元格渲染器、单元格编辑器创建并初始化 TableColumn 实例；所有 TableColumn 构造方法都委托给此方法。
TableColumnModel - javax.swing.table 中的 接口
定义了适合用于 JTable 的表列模型对象的要求。
TableColumnModelEvent - javax.swing.event 中的 类
TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
TableColumnModelEvent(TableColumnModel, int, int) - 类 javax.swing.event.TableColumnModelEvent 的构造方法
构造一个 TableColumnModelEvent 对象。
TableColumnModelListener - javax.swing.event 中的 接口
TableColumnModelListener 定义侦听 TableColumnModel 中更改的对象的接口。
tableColumns - 类 javax.swing.table.DefaultTableColumnModel 中的变量
此模型中 TableColumn 对象组成的数组
tableHeader - 类 javax.swing.JTable 中的变量
表所使用的 TableHeader。
TableHeaderUI - javax.swing.plaf 中的 类
JTableHeader 的可插入外观界面。
TableHeaderUI() - 类 javax.swing.plaf.TableHeaderUI 的构造方法
tableIndexClustered - 接口 java.sql.DatabaseMetaData 中的静态变量
指示此表索引是一个集群索引 (clustered index)。
tableIndexHashed - 接口 java.sql.DatabaseMetaData 中的静态变量
指示此表索引是一个散列索引。
tableIndexOther - 接口 java.sql.DatabaseMetaData 中的静态变量
指示此表索引不是集群索引、散列索引或表统计信息，它是其他某种东西。
tableIndexStatistic - 接口 java.sql.DatabaseMetaData 中的静态变量
指示此列包含与表的索引描述一起返回的表统计信息。
TableModel - javax.swing.table 中的 接口
TableModel 接口指定了 JTable 用于询问表格式数据模型的方法。
TableModelEvent - javax.swing.event 中的 类
TableModelEvent 用于通知侦听器某一表模型已发生更改。
TableModelEvent(TableModel) - 类 javax.swing.event.TableModelEvent 的构造方法
如果表中的所有行数据都发生更改，那么侦听器应该丢弃基于这些行的所有状态，并重新查询 TableModel 来获得新的行计数和所有恰当值。
TableModelEvent(TableModel, int) - 类 javax.swing.event.TableModelEvent 的构造方法
此数据行已被更新。
TableModelEvent(TableModel, int, int) - 类 javax.swing.event.TableModelEvent 的构造方法
行 [firstRow, lastRow] 中的数据已被更新。
TableModelEvent(TableModel, int, int, int) - 类 javax.swing.event.TableModelEvent 的构造方法
列 column 的 [firstRow, lastRow] 范围内的单元格已被更新。
TableModelEvent(TableModel, int, int, int, int) - 类 javax.swing.event.TableModelEvent 的构造方法
从 (firstRow, column) 到 (lastRow, column) 的单元格已被更改。
TableModelListener - javax.swing.event 中的 接口
TableModelListener 定义侦听 TableModel 中更改的对象的接口。
tableRowsDeleted(TableModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更（行删除）
tableRowsInserted(TableModelEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表内容的变更（行插入）
TableRowSorter<M extends TableModel> - javax.swing.table 中的 类
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。
TableRowSorter() - 类 javax.swing.table.TableRowSorter 的构造方法
使用空模型创建一个 TableRowSorter。
TableRowSorter(M) - 类 javax.swing.table.TableRowSorter 的构造方法
使用 model 作为底层 TableModel 创建一个 TableRowSorter。
TableStringConverter - javax.swing.table 中的 类
TableStringConverter 用于将对象从模型转换为字符串。
TableStringConverter() - 类 javax.swing.table.TableStringConverter 的构造方法
TableUI - javax.swing.plaf 中的 类
JTable 的可插入外观界面。
TableUI() - 类 javax.swing.plaf.TableUI 的构造方法
TableView - javax.swing.text 中的 类
为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。
TableView(Element) - 类 javax.swing.text.TableView 的构造方法
针对给定的元素构造一个 TableView。
TableView.TableCell - javax.swing.text 中的 类
已过时。 表单元格如今可以是任何 View 实现。
TableView.TableCell(Element) - 类 javax.swing.text.TableView.TableCell 的构造方法
已过时。 构造给定元素的 TableCell。
TableView.TableRow - javax.swing.text 中的 类
以行为中心的表格中的行视图。
TableView.TableRow(Element) - 类 javax.swing.text.TableView.TableRow 的构造方法
构造给定元素的 TableView。
TABLOID - 类 java.awt.PageAttributes.MediaType 中的静态变量
LEDGER 的别名。
TABLOID - 类 javax.print.attribute.standard.MediaSize.Other 中的静态变量
指定 tabloid 尺寸，11 inch × 17 inch。
TABLOID - 类 javax.print.attribute.standard.MediaSizeName 中的静态变量
tabloid 尺寸。
tabPane - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
tabPlacement - 类 javax.swing.JTabbedPane 中的变量
选项卡的放置位置。
tabRunOverlay - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
tabRuns - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
TabSet - 类 javax.swing.text.StyleConstants 中的静态变量
段落的 TabSet，类型为包含了 TabStop 的 TabSet。
TabSet - javax.swing.text 中的 类
由许多 TabStop 组成的一个 TabSet。
TabSet(TabStop[]) - 类 javax.swing.text.TabSet 的构造方法
创建并且返回 TabSet 的一个实例。
tabSizeAttribute - 类 javax.swing.text.PlainDocument 中的静态变量
指定内容中包含的制表符大小的属性名称。
TabStop - javax.swing.text 中的 类
此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。
TabStop(float) - 类 javax.swing.text.TabStop 的构造方法
在给定位置 pos 创建一个具有默认对齐方式和默认前导字符的制表符。
TabStop(float, int, int) - 类 javax.swing.text.TabStop 的构造方法
创建一个具有指定位置 pos、对齐方式 align 和前导字符 leader 的制表符。
TabularData - javax.management.openmbean 中的 接口
TabularData 接口指定特定类型的复杂开放数据 对象的行为，该对象表示了表格数据 结构。
TabularDataSupport - javax.management.openmbean 中的 类
TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。
TabularDataSupport(TabularType) - 类 javax.management.openmbean.TabularDataSupport 的构造方法
创建一个空 TabularDataSupport 实例，其开放类型是 tabularType，并且它的基础 HashMap 具有默认初始容量 (101) 和默认加载因子 (0.75)。
TabularDataSupport(TabularType, int, float) - 类 javax.management.openmbean.TabularDataSupport 的构造方法
创建一个空 TabularDataSupport 实例，其开放类型为 tabularType，它的基础 HashMap 具有指定的初始容量和加载因子。
TabularType - javax.management.openmbean 中的 类
TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。
TabularType(String, String, CompositeType, String[]) - 类 javax.management.openmbean.TabularType 的构造方法
构造一个 TabularType 实例，检查给定参数的有效性。
tag - 类 org.omg.IOP.TaggedComponent 中的变量
以组件 id 形式表示的标记。
tag - 类 org.omg.IOP.TaggedProfile 中的变量
以配置文件 id 形式表示的标记。
TAG_ACNT - 接口 java.awt.font.OpenType 中的静态变量
重音符附件。
TAG_ALTERNATE_IIOP_ADDRESS - org.omg.IOP 中的 接口
org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java。
TAG_AVAR - 接口 java.awt.font.OpenType 中的静态变量
轴变体。
TAG_BASE - 接口 java.awt.font.OpenType 中的静态变量
基线数据。
TAG_BDAT - 接口 java.awt.font.OpenType 中的静态变量
位图数据。
TAG_BLOC - 接口 java.awt.font.OpenType 中的静态变量
位图位置。
TAG_BSLN - 接口 java.awt.font.OpenType 中的静态变量
基线表。
TAG_CFF - 接口 java.awt.font.OpenType 中的静态变量
紧凑字体格式（Type1 字体）。
TAG_CMAP - 接口 java.awt.font.OpenType 中的静态变量
字形映射的字符。
TAG_CODE_SETS - org.omg.IOP 中的 接口
org/omg/IOP/TAG_CODE_SETS.java。
TAG_CVAR - 接口 java.awt.font.OpenType 中的静态变量
CVT 变体。
TAG_CVT - 接口 java.awt.font.OpenType 中的静态变量
控制值表。
TAG_DSIG - 接口 java.awt.font.OpenType 中的静态变量
数字签名。
TAG_EBDT - 接口 java.awt.font.OpenType 中的静态变量
内嵌位图数据。
TAG_EBLC - 接口 java.awt.font.OpenType 中的静态变量
内嵌位图位置。
TAG_EBSC - 接口 java.awt.font.OpenType 中的静态变量
内嵌位图缩放。
TAG_FDSC - 接口 java.awt.font.OpenType 中的静态变量
字体描述符。
TAG_FEAT - 接口 java.awt.font.OpenType 中的静态变量
特性名称。
TAG_FMTX - 接口 java.awt.font.OpenType 中的静态变量
字体规格。
TAG_FPGM - 接口 java.awt.font.OpenType 中的静态变量
字体程序。
TAG_FVAR - 接口 java.awt.font.OpenType 中的静态变量
字体变体。
TAG_GASP - 接口 java.awt.font.OpenType 中的静态变量
网格适应和扫描转换过程。
TAG_GDEF - 接口 java.awt.font.OpenType 中的静态变量
字形定义。
TAG_GLYF - 接口 java.awt.font.OpenType 中的静态变量
字形数据。
TAG_GPOS - 接口 java.awt.font.OpenType 中的静态变量
字形定位。
TAG_GSUB - 接口 java.awt.font.OpenType 中的静态变量
字形替换。
TAG_GVAR - 接口 java.awt.font.OpenType 中的静态变量
字形变体。
TAG_HDMX - 接口 java.awt.font.OpenType 中的静态变量
水平设备规格。
TAG_HEAD - 接口 java.awt.font.OpenType 中的静态变量
字体头部。
TAG_HHEA - 接口 java.awt.font.OpenType 中的静态变量
水平规格头部。
TAG_HMTX - 接口 java.awt.font.OpenType 中的静态变量
水平规格。
TAG_INTERNET_IOP - org.omg.IOP 中的 接口
org/omg/IOP/TAG_INTERNET_IOP.java。
TAG_JAVA_CODEBASE - org.omg.IOP 中的 接口
org/omg/IOP/TAG_JAVA_CODEBASE.java。
TAG_JSTF - 接口 java.awt.font.OpenType 中的静态变量
调整。
TAG_JUST - 接口 java.awt.font.OpenType 中的静态变量
调整。
TAG_KERN - 接口 java.awt.font.OpenType 中的静态变量
字距调整。
TAG_LCAR - 接口 java.awt.font.OpenType 中的静态变量
连字插入符。
TAG_LOCA - 接口 java.awt.font.OpenType 中的静态变量
位置索引。
TAG_LTSH - 接口 java.awt.font.OpenType 中的静态变量
线性阈值。
TAG_MAXP - 接口 java.awt.font.OpenType 中的静态变量
最大轮廓。
TAG_MMFX - 接口 java.awt.font.OpenType 中的静态变量
Multiple Master 字体规格。
TAG_MMSD - 接口 java.awt.font.OpenType 中的静态变量
Multiple master 增补数据。
TAG_MORT - 接口 java.awt.font.OpenType 中的静态变量
字形变化。
TAG_MULTIPLE_COMPONENTS - org.omg.IOP 中的 接口
org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java。
TAG_NAME - 接口 java.awt.font.OpenType 中的静态变量
命名表。
TAG_OPBD - 接口 java.awt.font.OpenType 中的静态变量
视觉边界。
TAG_ORB_TYPE - org.omg.IOP 中的 接口
org/omg/IOP/TAG_ORB_TYPE.java。
TAG_OS2 - 接口 java.awt.font.OpenType 中的静态变量
OS/2 和 Windows 特定规格。
TAG_PCLT - 接口 java.awt.font.OpenType 中的静态变量
PCL 5 数据。
TAG_POLICIES - org.omg.IOP 中的 接口
org/omg/IOP/TAG_POLICIES.java。
TAG_POST - 接口 java.awt.font.OpenType 中的静态变量
PostScript 信息。
TAG_PREP - 接口 java.awt.font.OpenType 中的静态变量
CVT 预编程。
TAG_PROP - 接口 java.awt.font.OpenType 中的静态变量
字形属性。
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT - org.omg.IOP 中的 接口
org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java。
TAG_TRAK - 接口 java.awt.font.OpenType 中的静态变量
跟踪。
TAG_TYP1 - 接口 java.awt.font.OpenType 中的静态变量
Adobe Type 1 字体数据。
TAG_VDMX - 接口 java.awt.font.OpenType 中的静态变量
垂直设备规格。
TAG_VHEA - 接口 java.awt.font.OpenType 中的静态变量
垂直规格头部。
TAG_VMTX - 接口 java.awt.font.OpenType 中的静态变量
垂直规格。
TAGALOG - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tagalog”Unicode 字符块的常量。
TAGBANWA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tagbanwa”Unicode 字符块的常量。
TagElement - javax.swing.text.html.parser 中的 类
一般的 HTML TagElement 类。
TagElement(Element) - 类 javax.swing.text.html.parser.TagElement 的构造方法
TagElement(Element, boolean) - 类 javax.swing.text.html.parser.TagElement 的构造方法
TaggedComponent - org.omg.IOP 中的 类
org/omg/IOP/TaggedComponent.java。
TaggedComponent() - 类 org.omg.IOP.TaggedComponent 的构造方法
TaggedComponent(int, byte[]) - 类 org.omg.IOP.TaggedComponent 的构造方法
TaggedComponentHelper - org.omg.IOP 中的 类
org/omg/IOP/TaggedComponentHelper.java。
TaggedComponentHelper() - 类 org.omg.IOP.TaggedComponentHelper 的构造方法
TaggedComponentHolder - org.omg.IOP 中的 类
org/omg/IOP/TaggedComponentHolder.java。
TaggedComponentHolder() - 类 org.omg.IOP.TaggedComponentHolder 的构造方法
TaggedComponentHolder(TaggedComponent) - 类 org.omg.IOP.TaggedComponentHolder 的构造方法
TaggedProfile - org.omg.IOP 中的 类
org/omg/IOP/TaggedProfile.java。
TaggedProfile() - 类 org.omg.IOP.TaggedProfile 的构造方法
TaggedProfile(int, byte[]) - 类 org.omg.IOP.TaggedProfile 的构造方法
TaggedProfileHelper - org.omg.IOP 中的 类
org/omg/IOP/TaggedProfileHelper.java。
TaggedProfileHelper() - 类 org.omg.IOP.TaggedProfileHelper 的构造方法
TaggedProfileHolder - org.omg.IOP 中的 类
org/omg/IOP/TaggedProfileHolder.java。
TaggedProfileHolder() - 类 org.omg.IOP.TaggedProfileHolder 的构造方法
TaggedProfileHolder(TaggedProfile) - 类 org.omg.IOP.TaggedProfileHolder 的构造方法
TAGS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tags”Unicode 字符块的常量。
TAI_LE - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tai Le”Unicode 字符块的常量。
TAI_XUAN_JING_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tai Xuan Jing Symbols”Unicode 字符块的常量。
tailMap(K, boolean) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
tailMap(K) - 接口 java.util.concurrent.ConcurrentNavigableMap 中的方法
tailMap(K, boolean) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
tailMap(K) - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
tailMap(K, boolean) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。
tailMap(K) - 接口 java.util.NavigableMap 中的方法
返回此映射的部分视图，其键大于等于 fromKey。
tailMap(K) - 接口 java.util.SortedMap 中的方法
返回此映射的部分视图，其键大于等于 fromKey。
tailMap(K, boolean) - 类 java.util.TreeMap 中的方法
tailMap(K) - 类 java.util.TreeMap 中的方法
tailSet(E, boolean) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
tailSet(E) - 类 java.util.concurrent.ConcurrentSkipListSet 中的方法
tailSet(E, boolean) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。
tailSet(E) - 接口 java.util.NavigableSet 中的方法
返回此 set 的部分视图，其元素大于等于 fromElement。
tailSet(E) - 接口 java.util.SortedSet 中的方法
返回此 set 的部分视图，其元素大于等于 fromElement。
tailSet(E, boolean) - 类 java.util.TreeSet 中的方法
tailSet(E) - 类 java.util.TreeSet 中的方法
TAIWAN - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
take() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
take() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），必要时将一直等待可用元素。
take() - 接口 java.util.concurrent.BlockingQueue 中的方法
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。
take() - 接口 java.util.concurrent.CompletionService 中的方法
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。
take() - 类 java.util.concurrent.DelayQueue 中的方法
获取并移除此队列的头部，在可从此队列获得到期延迟的元素之前一直等待（如有必要）。
take() - 类 java.util.concurrent.ExecutorCompletionService 中的方法
take() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
take() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
take() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
take() - 类 java.util.concurrent.SynchronousQueue 中的方法
获取并移除此队列的头，如有必要则等待另一个线程插入它。
takeFirst() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列的第一个元素，必要时将一直等待可用元素。
takeFirst() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
takeLast() - 接口 java.util.concurrent.BlockingDeque 中的方法
获取并移除此双端队列的最后一个元素，必要时将一直等待可用元素。
takeLast() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
TAMIL - 类 java.awt.font.NumericShaper 中的静态变量
标识 TAMIL 范围和十进制基数。
TAMIL - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tamil”Unicode 字符块的常量。
tan(double) - 类 java.lang.Math 中的静态方法
返回角的三角正切。
tan(double) - 类 java.lang.StrictMath 中的静态方法
返回角的三角正切。
tanh(double) - 类 java.lang.Math 中的静态方法
返回 double 值的双曲线余弦。
tanh(double) - 类 java.lang.StrictMath 中的静态方法
返回 double 值的双曲线正切。
target - 类 java.awt.Event 中的变量
目标组件。
Target - java.lang.annotation 中的 注释类型
指示注释类型所适用的程序元素的种类。
TARGET - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
target() - 类 org.omg.CORBA.Request 中的方法
检索目标对象引用。
target() - 接口 org.omg.PortableInterceptor.ClientRequestInfoOperations 中的方法
返回客户端调用以执行操作的对象。
target_is_a(String) - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
如果 servant 是给定的存储库 id，则返回 true；若不是则返回 false。
target_most_derived_interface() - 接口 org.omg.PortableInterceptor.ServerRequestInfoOperations 中的方法
返回 servant 最终派生接口的存储库 id。
TargetDataLine - javax.sound.sampled 中的 接口
目标数据行是可以从中读取音频数据的某种类型的 DataLine。
TargetedNotification - javax.management.remote 中的 类
一个 (Notification, Listener ID) 对。
TargetedNotification(Notification, Integer) - 类 javax.management.remote.TargetedNotification 的构造方法
构造一个 TargetedNotification 对象。
targetMustExist() - 接口 javax.naming.event.EventContext 中的方法
确定侦听器是否可以注册不存在的感兴趣目标。
TC_ARRAY - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Array。
TC_BASE - 接口 java.io.ObjectStreamConstants 中的静态变量
第一个标记值。
TC_BLOCKDATA - 接口 java.io.ObjectStreamConstants 中的静态变量
可选数据块。
TC_BLOCKDATALONG - 接口 java.io.ObjectStreamConstants 中的静态变量
long Block 数据。
TC_CLASS - 接口 java.io.ObjectStreamConstants 中的静态变量
Class 的引用。
TC_CLASSDESC - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Class Descriptor。
TC_ENDBLOCKDATA - 接口 java.io.ObjectStreamConstants 中的静态变量
可选块数据的末尾因对象而阻塞。
TC_ENUM - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Enum 常量。
TC_EXCEPTION - 接口 java.io.ObjectStreamConstants 中的静态变量
写入过程中的异常。
TC_LONGSTRING - 接口 java.io.ObjectStreamConstants 中的静态变量
Long 字符串。
TC_MAX - 接口 java.io.ObjectStreamConstants 中的静态变量
最后一个标记值。
TC_NULL - 接口 java.io.ObjectStreamConstants 中的静态变量
Null 对象引用。
TC_OBJECT - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Object。
TC_PROXYCLASSDESC - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 Proxy Class Descriptor。
TC_REFERENCE - 接口 java.io.ObjectStreamConstants 中的静态变量
已写入流的对象的引用。
TC_RESET - 接口 java.io.ObjectStreamConstants 中的静态变量
重置流上下文。
TC_STRING - 接口 java.io.ObjectStreamConstants 中的静态变量
新的 String。
TCKind - org.omg.CORBA 中的 类
IDL enum TCKind 的 Java 映射，TCKind 指定 TypeCode 对象的种类。
TCKind(int) - 类 org.omg.CORBA.TCKind 的构造方法
已过时。 不要使用此构造方法，因为根据 OMG 规范，此方法应该是私有的。使用 TCKind.from_int(int) 代替。
TCP_NODELAY - 接口 java.net.SocketOptions 中的静态变量
对此连接禁用 Nagle 算法。
TD - 类 javax.swing.text.html.HTML.Tag 中的静态变量
TELUGU - 类 java.awt.font.NumericShaper 中的静态变量
标识 TELUGU 范围和十进制基数。
TELUGU - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Telugu”Unicode 字符块的常量。
Templates - javax.xml.transform 中的 接口
实现此接口的对象是处理后的转换指令的运行时表示形式。
TemplatesHandler - javax.xml.transform.sax 中的 接口
可用于将 SAX 解析事件（解析转换指令）处理为 Templates 对象的 SAX ContentHandler。
TEN - 类 java.math.BigDecimal 中的静态变量
值为 10，标度为 0。
TEN - 类 java.math.BigInteger 中的静态变量
BigInteger 的常量 10。
terminated() - 类 java.util.concurrent.ThreadPoolExecutor 中的方法
当 Executor 已经终止时调用的方法。
TERTIARY - 类 java.text.Collator 中的静态变量
Collator 的 strength 值。
tertiaryOrder(int) - 类 java.text.CollationElementIterator 中的静态方法
返回 collation 元素的第三顺序。
testBit(int) - 类 java.math.BigInteger 中的方法
当且仅当设置了指定的位时，返回 true。
TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.text 系统颜色的数组索引。
text - 类 java.awt.SystemColor 中的静态变量
为文本控制对象（比如文本字段和组合框）提供的背景色。
TEXT - 类 javax.accessibility.AccessibleRole 中的静态变量
将文本呈现给用户的对象。
text - 类 javax.accessibility.AccessibleTextSequence 中的变量
文本
text(Element) - 类 javax.swing.text.AbstractWriter 中的方法
写出文本。
TEXT - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
text(Element) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出文本。
text(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出文本。
Text - javax.xml.soap 中的 接口
值为文本的节点的表示形式。
Text - org.w3c.dom 中的 接口
该 Text 接口继承自 CharacterData，并且表示 Element 或 Attr 的文本内容（在 XML 中称为字符数据）。
TEXT_ALIGN - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
TEXT_AREA - 类 javax.swing.plaf.synth.Region 中的静态变量
TextArea 的 region。
TEXT_BACKGROUND - 类 javax.swing.plaf.synth.ColorType 中的静态变量
某一 region 背景的 ColorType。
TEXT_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的文本中的更改。
TEXT_CURSOR - 类 java.awt.Cursor 中的静态变量
文字光标类型。
TEXT_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.TEXT_CURSOR 取代。
TEXT_DECORATION - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
TEXT_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择文本事件的事件掩码。
TEXT_FIELD - 类 javax.swing.plaf.synth.Region 中的静态变量
TextField 的 region。
TEXT_FIRST - 类 java.awt.event.TextEvent 中的静态变量
用于文本事件的 id 范围的起始编号。
TEXT_FOREGROUND - 类 javax.swing.plaf.synth.ColorType 中的静态变量
某一 region 前景的 ColorType。
TEXT_HIGHLIGHT - 类 java.awt.SystemColor 中的静态变量
SystemColor.textHighlight 系统颜色的数组索引。
TEXT_HIGHLIGHT_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.textHighlightText 系统颜色的数组索引。
TEXT_HTML - 类 javax.print.DocFlavor.CHAR_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。
TEXT_HTML - 类 javax.print.DocFlavor.READER 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。
TEXT_HTML - 类 javax.print.DocFlavor.STRING 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。
TEXT_HTML_HOST - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
TEXT_HTML_HOST - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
TEXT_HTML_HOST - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
TEXT_HTML_US_ASCII - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_US_ASCII - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_US_ASCII - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16 - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_UTF_16 - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16 - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16BE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_UTF_16BE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16BE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16LE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_UTF_16LE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_16LE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_8 - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_HTML_UTF_8 - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_HTML_UTF_8 - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_INACTIVE_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.textInactiveText 系统颜色的数组索引。
TEXT_INDENT - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
TEXT_INSET_H - 类 javax.swing.border.TitledBorder 中的静态变量
TEXT_LAST - 类 java.awt.event.TextEvent 中的静态变量
用于文本事件的 id 范围的结束编号。
TEXT_NODE - 接口 org.w3c.dom.Node 中的静态变量
该节点为 Text 节点。
TEXT_PANE - 类 javax.swing.plaf.synth.Region 中的静态变量
TextPane 的 region。
TEXT_PLAIN - 类 javax.print.DocFlavor.CHAR_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。
TEXT_PLAIN - 类 javax.print.DocFlavor.READER 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。
TEXT_PLAIN - 类 javax.print.DocFlavor.STRING 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。
TEXT_PLAIN_HOST - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
TEXT_PLAIN_HOST - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
TEXT_PLAIN_HOST - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
TEXT_PLAIN_US_ASCII - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_US_ASCII - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_US_ASCII - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16 - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_UTF_16 - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16 - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = java.net.URL""（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16BE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_UTF_16BE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16BE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16LE - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_UTF_16LE - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_16LE - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_8 - 类 javax.print.DocFlavor.BYTE_ARRAY 中的静态变量
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
TEXT_PLAIN_UTF_8 - 类 javax.print.DocFlavor.INPUT_STREAM 中的静态变量
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
TEXT_PLAIN_UTF_8 - 类 javax.print.DocFlavor.URL 中的静态变量
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
TEXT_SPACING - 类 javax.swing.border.TitledBorder 中的静态变量
TEXT_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.textText 系统颜色的数组索引。
TEXT_TRANSFORM - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
TEXT_VALUE_CHANGED - 类 java.awt.event.TextEvent 中的静态变量
此事件 id 指示对象的文本已改变。
TextAction - javax.swing.text 中的 类
用于跨多个不同文本组件共享的键绑定的 Action 实现。
TextAction(String) - 类 javax.swing.text.TextAction 的构造方法
创建一个新的 JTextAction 对象。
TextArea - java.awt 中的 类
TextArea 对象是显示文本的多行区域。
TextArea() - 类 java.awt.TextArea 的构造方法
构造一个将空字符串作为文本的新文本区。
TextArea(String) - 类 java.awt.TextArea 的构造方法
构造具有指定文本的新文本区。
TextArea(int, int) - 类 java.awt.TextArea 的构造方法
构造一个新文本区，该文本区具有指定的行数和列数，并将空字符串作为文本。
TextArea(String, int, int) - 类 java.awt.TextArea 的构造方法
构造一个新文本区，该文本区具有指定的文本，以及指定的行数和列数。
TextArea(String, int, int, int) - 类 java.awt.TextArea 的构造方法
构造一个新文本区，该文本区具有指定的文本，以及指定的行数、列数和滚动条可见性。
TEXTAREA - 类 javax.swing.text.html.HTML.Tag 中的静态变量
TextArea.AccessibleAWTTextArea - java.awt 中的 类
此类实现 TextArea 类的可访问性支持。
TextArea.AccessibleAWTTextArea() - 类 java.awt.TextArea.AccessibleAWTTextArea 的构造方法
textAreaContent(char[]) - 类 javax.swing.text.html.HTMLDocument.HTMLReader 中的方法
将给定的内容添加到 textarea 文档。
textAreaContent(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出 TEXTAREA 表单元素中所包含的文本。
TextAttribute - java.awt.font 中的 类
TextAttribute 类定义用于呈现文本的属性键和属性值。
TextAttribute(String) - 类 java.awt.font.TextAttribute 的构造方法
构造一个具有指定名称的 TextAttribute。
TextComponent - java.awt 中的 类
TextComponent 类是所有允许编辑文本的组件的超类。
TextComponent.AccessibleAWTTextComponent - java.awt 中的 类
此类实现对 TextComponent 类的可访问性支持。
TextComponent.AccessibleAWTTextComponent() - 类 java.awt.TextComponent.AccessibleAWTTextComponent 的构造方法
构造 AccessibleAWTTextComponent。
TextEvent - java.awt.event 中的 类
指示对象文本已改变的语义事件。
TextEvent(Object, int) - 类 java.awt.event.TextEvent 的构造方法
构造一个 TextEvent 对象。
TextField - java.awt 中的 类
TextField 对象是允许编辑单行文本的文本组件。
TextField() - 类 java.awt.TextField 的构造方法
构造新文本字段。
TextField(String) - 类 java.awt.TextField 的构造方法
构造使用指定文本初始化的新文本字段。
TextField(int) - 类 java.awt.TextField 的构造方法
构造具有指定列数的新空文本字段。
TextField(String, int) - 类 java.awt.TextField 的构造方法
构造使用要显示的指定文本初始化的新文本字段，宽度足够容纳指定列数。
TextField.AccessibleAWTTextField - java.awt 中的 类
此类实现 TextField 类的可访问性支持。
TextField.AccessibleAWTTextField() - 类 java.awt.TextField.AccessibleAWTTextField 的构造方法
textHighlight - 类 java.awt.SystemColor 中的静态变量
为选则项（比如菜单、组合框和文本）提供的背景色。
textHighlightText - 类 java.awt.SystemColor 中的静态变量
为选则项（比如菜单、组合框和文本）的文本提供的颜色。
TextHitInfo - java.awt.font 中的 类
TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。
textIconGap - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
textInactiveText - 类 java.awt.SystemColor 中的静态变量
为非活动项（比如菜单中的项）的文本提供的颜色。
TextInputCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。
TextInputCallback(String) - 类 javax.security.auth.callback.TextInputCallback 的构造方法
构造一个带提示的 TextInputCallback。
TextInputCallback(String, String) - 类 javax.security.auth.callback.TextInputCallback 的构造方法
构造一个带提示和默认输入值的 TextInputCallback。
TextLayout - java.awt.font 中的 类
TextLayout 是样式字符数据的不可变图形表示形式。
TextLayout(String, Font, FontRenderContext) - 类 java.awt.font.TextLayout 的构造方法
根据 String 和 Font 构造一个 TextLayout。
TextLayout(String, Map<? extends AttributedCharacterIterator.Attribute, ?>, FontRenderContext) - 类 java.awt.font.TextLayout 的构造方法
根据 String 和属性集构造一个 TextLayout。
TextLayout(AttributedCharacterIterator, FontRenderContext) - 类 java.awt.font.TextLayout 的构造方法
根据样式文本上的迭代器构造一个 TextLayout。
TextLayout.CaretPolicy - java.awt.font 中的 类
定义确定强插入符位置的策略。
TextLayout.CaretPolicy() - 类 java.awt.font.TextLayout.CaretPolicy 的构造方法
构造一个 CaretPolicy。
TextListener - java.awt.event 中的 接口
用于接收文本事件的侦听器接口。
textListener - 类 java.awt.TextComponent 中的变量
TextMeasurer - java.awt.font 中的 类
TextMeasurer 类提供换行所需的基本操作：测量到给定的 advance，确定字符范围的 advance，并为字符范围生成一个 TextLayout。
TextMeasurer(AttributedCharacterIterator, FontRenderContext) - 类 java.awt.font.TextMeasurer 的构造方法
从源文本构造 TextMeasurer。
textNonSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于非选定节点的前景颜色。
TextOutputCallback - javax.security.auth.callback 中的 类
底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。
TextOutputCallback(int, String) - 类 javax.security.auth.callback.TextOutputCallback 的构造方法
构造一个带消息类型和将要显示的消息的 TextOutputCallback。
textSelectionColor - 类 javax.swing.tree.DefaultTreeCellRenderer 中的变量
用于选定节点的前景颜色。
TextSyntax - javax.print.attribute 中的 类
类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。
TextSyntax(String, Locale) - 类 javax.print.attribute.TextSyntax 的构造方法
使用指定的字符串和语言环境构造 TextAttribute。
textText - 类 java.awt.SystemColor 中的静态变量
为文本控制对象（比如文本字段和组合框）的文本提供的颜色。
TextUI - javax.swing.plaf 中的 类
文本编辑器用户界面
TextUI() - 类 javax.swing.plaf.TextUI 的构造方法
TexturePaint - java.awt 中的 类
TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。
TexturePaint(BufferedImage, Rectangle2D) - 类 java.awt.TexturePaint 的构造方法
构造 TexturePaint 对象。
textValueChanged(TextEvent) - 类 java.awt.AWTEventMulticaster 中的方法
textValueChanged(TextEvent) - 接口 java.awt.event.TextListener 中的方法
文本的值已改变时调用。
textValueChanged(TextEvent) - 类 java.awt.TextComponent.AccessibleAWTTextComponent 中的方法
文本值更改的 TextListener 通知。
TH - 类 javax.swing.text.html.HTML.Tag 中的静态变量
THAANA - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Thaana”Unicode 字符块的常量。
THAI - 类 java.awt.font.NumericShaper 中的静态变量
标识 THAI 范围和十进制基数。
THAI - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Thai”Unicode 字符块的常量。
the_activator() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识与 POA 关联的适配器激活器。
the_activator(AdapterActivator) - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识与 POA 关联的适配器激活器。
the_children() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识 POA 的所有子 POA 的当前设置。
the_name() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识相对于其父 POA 的 POA。
the_parent() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识 POA 的父 POA。
the_POAManager() - 接口 org.omg.PortableServer.POAOperations 中的方法
此属性标识与 POA 关联的 POA 管理器。
thickness - 类 javax.swing.border.LineBorder 中的变量
this_object(Servant) - 接口 org.omg.PortableServer.portable.Delegate 中的方法
此方法允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
thisObject() - 接口 javax.rmi.CORBA.Tie 中的方法
返回此 tie 表示的目标对象的对象引用。
Thread - java.lang 中的 类
线程 是程序中的执行线程。
Thread() - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(Runnable) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(ThreadGroup, Runnable) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(String) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(ThreadGroup, String) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(Runnable, String) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象。
Thread(ThreadGroup, Runnable, String) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。
Thread(ThreadGroup, Runnable, String, long) - 类 java.lang.Thread 的构造方法
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。
Thread.State - java.lang 中的 枚举
线程状态。
Thread.UncaughtExceptionHandler - java.lang 中的 接口
当 Thread 因未捕获的异常而突然终止时，调用处理程序的接口。
THREAD_MXBEAN_NAME - 类 java.lang.management.ManagementFactory 中的静态变量
ThreadMXBean 的 ObjectName 的字符串表示形式。
THREAD_POLICY_ID - org.omg.PortableServer 中的 接口
org/omg/PortableServer/THREAD_POLICY_ID.java。
ThreadDeath - java.lang 中的 错误
调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
ThreadDeath() - 错误 java.lang.ThreadDeath 的构造方法
ThreadFactory - java.util.concurrent 中的 接口
根据需要创建新线程的对象。
ThreadGroup - java.lang 中的 类
线程组表示一个线程的集合。
ThreadGroup(String) - 类 java.lang.ThreadGroup 的构造方法
构造一个新线程组。
ThreadGroup(ThreadGroup, String) - 类 java.lang.ThreadGroup 的构造方法
创建一个新线程组。
ThreadInfo - java.lang.management 中的 类
线程信息。
ThreadLocal<T> - java.lang 中的 类
该类提供了线程局部 (thread-local) 变量。
ThreadLocal() - 类 java.lang.ThreadLocal 的构造方法
创建一个线程本地变量。
ThreadMXBean - java.lang.management 中的 接口
Java 虚拟机线程系统的管理接口。
ThreadPolicy - org.omg.PortableServer 中的 接口
ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。
ThreadPolicyOperations - org.omg.PortableServer 中的 接口
ThreadPolicy 指定与已创建的 POA 一起使用的线程模型 (threading model)。
ThreadPolicyValue - org.omg.PortableServer 中的 类
ThreadPolicyValue 可以具有以下值。
ThreadPolicyValue(int) - 类 org.omg.PortableServer.ThreadPolicyValue 的构造方法
ThreadPoolExecutor - java.util.concurrent 中的 类
一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>) - 类 java.util.concurrent.ThreadPoolExecutor 的构造方法
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, ThreadFactory) - 类 java.util.concurrent.ThreadPoolExecutor 的构造方法
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, RejectedExecutionHandler) - 类 java.util.concurrent.ThreadPoolExecutor 的构造方法
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, ThreadFactory, RejectedExecutionHandler) - 类 java.util.concurrent.ThreadPoolExecutor 的构造方法
用给定的初始参数创建新的 ThreadPoolExecutor。
ThreadPoolExecutor.AbortPolicy - java.util.concurrent 中的 类
用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.
ThreadPoolExecutor.AbortPolicy() - 类 java.util.concurrent.ThreadPoolExecutor.AbortPolicy 的构造方法
创建一个 AbortPolicy。
ThreadPoolExecutor.CallerRunsPolicy - java.util.concurrent 中的 类
用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。
ThreadPoolExecutor.CallerRunsPolicy() - 类 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy 的构造方法
创建一个 CallerRunsPolicy。
ThreadPoolExecutor.DiscardOldestPolicy - java.util.concurrent 中的 类
用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。
ThreadPoolExecutor.DiscardOldestPolicy() - 类 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy 的构造方法
为给定执行程序创建 DiscardOldestPolicy。
ThreadPoolExecutor.DiscardPolicy - java.util.concurrent 中的 类
用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。
ThreadPoolExecutor.DiscardPolicy() - 类 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy 的构造方法
创建一个 DiscardPolicy。
THRESHOLD_ERROR - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示阈值类型、偏移量或模不正确的通知类型。
THRESHOLD_HIGH_VALUE_EXCEEDED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性已超出高阈值的通知类型。
THRESHOLD_LOW_VALUE_EXCEEDED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性已超出低阈值的通知类型。
THRESHOLD_VALUE_EXCEEDED - 类 javax.management.monitor.MonitorNotification 中的静态变量
表示被观察属性已达到阈值的通知类型。
Throwable - java.lang 中的 类
Throwable 类是 Java 语言中所有错误或异常的超类。
Throwable() - 类 java.lang.Throwable 的构造方法
构造一个将 null 作为其详细消息的新 throwable。
Throwable(String) - 类 java.lang.Throwable 的构造方法
构造带指定详细消息的新 throwable。
Throwable(String, Throwable) - 类 java.lang.Throwable 的构造方法
构造一个带指定详细消息和 cause 的新 throwable。
Throwable(Throwable) - 类 java.lang.Throwable 的构造方法
构造一个带指定 cause 和 (cause==null ? null :cause.toString())（它通常包含类和 cause 的详细消息）的详细消息的新 throwable。
throwException() - 类 java.nio.charset.CoderResult 中的方法
抛出相应于此对象描述的结果的异常。
throwing(String, String, Throwable) - 类 java.util.logging.Logger 中的方法
正抛出异常的记录。
thumbColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbColor - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
thumbDarkShadowColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbHighlightColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbLightShadowColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbnailComplete(ImageReader) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告缩略图读操作已经完成。
thumbnailComplete(ImageWriter) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告缩略图写操作已经完成。
thumbnailPassComplete(ImageReader, BufferedImage) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告当前缩略图读操作已经完成一个逐步传递。
thumbnailPassStarted(ImageReader, BufferedImage, int, int, int, int, int, int, int, int[]) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告当前的缩略图读操作将开始逐步传递。
thumbnailProgress(ImageReader, float) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告在关联的 ImageReader 中完成当前 getThumbnail 调用的近似程度。
thumbnailProgress(ImageWriter, float) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告在关联的 ImageWriter 中完成当前缩略图写操作的近似程度。
thumbnails - 类 javax.imageio.IIOImage 中的变量
BufferedImage 缩略图的 List，或为 null。
thumbnailStarted(ImageReader, int, int) - 接口 javax.imageio.event.IIOReadProgressListener 中的方法
报告缩略图读操作将要开始。
thumbnailStarted(ImageWriter, int, int) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告缩略图写操作将要开始。
thumbnailUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - 接口 javax.imageio.event.IIOReadUpdateListener 中的方法
报告已更新缩略图图像的给定区域。
thumbRect - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
thumbRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
THURSDAY - 类 java.util.Calendar 中的静态变量
指示 Thursday 的 Calendar.DAY_OF_WEEK 字段值。
TIBETAN - 类 java.awt.font.NumericShaper 中的静态变量
标识 TIBETAN 范围和十进制基数。
TIBETAN - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Tibetan”Unicode 字符块的常量。
TICK_BUFFER - 类 javax.swing.plaf.metal.MetalSliderUI 中的变量
tickLength - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
tickRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
ticks() - 类 javax.sound.midi.Track 中的方法
获得音轨的长度，用 MIDI 刻度表示。
Tie - javax.rmi.CORBA 中的 接口
定义所有 RMI-IIOP 服务器端 tie 必须实现的方法。
tileGridXOffset - 类 javax.imageio.ImageWriteParam 中的变量
如果已经设置 tiling，则返回 tile 网格原点应该从图像原点水平偏移的量。
tileGridYOffset - 类 javax.imageio.ImageWriteParam 中的变量
如果已经设置 tiling，则返回 tile 网格原点应该从图像原点垂直偏移的量。
tileHeight - 类 javax.imageio.ImageWriteParam 中的变量
如果已经设置 tiling，则返回每个 tile 的高度，否则返回 0。
tileIcon - 类 javax.swing.border.MatteBorder 中的变量
TileObserver - java.awt.image 中的 接口
希望在出现以下情况时被通知的对象的接口：某个 writer 通过调用 getWritableTile 使 WritableRenderedImage 的 tile 变得可修改；通过最后调用 releaseWritableTile 使这些 tile 变得不可修改。
tileUpdate(WritableRenderedImage, int, int, boolean) - 接口 java.awt.image.TileObserver 中的方法
即将被更新的 tile（此 tile 或者即将被获取以写入，或者正在从写入释放）。
tileWidth - 类 javax.imageio.ImageWriteParam 中的变量
如果已经设置 tiling，则返回每个 tile 的宽度，否则返回 0。
tilingMode - 类 javax.imageio.ImageWriteParam 中的变量
控制 tiling 设置的模式，必须将它设置为以下四个 MODE_* 值之一。
tilingSet - 类 javax.imageio.ImageWriteParam 中的变量
如果已经指定 tiling 参数，则返回一个为 true 的 boolean 值。
Time - java.sql 中的 类
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
Time(int, int, int) - 类 java.sql.Time 的构造方法
已过时。 使用采用毫秒值的构造方法取代此构造方法
Time(long) - 类 java.sql.Time 的构造方法
使用毫秒时间值构造 Time 对象。
TIME - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 TIME 的 Java 编程语言中的常量（有时称为类型代码）。
time - 类 java.util.Calendar 中的变量
日历的当前设置时间，以毫秒为单位，表示自格林威治标准时间 1970 年 1月 1 日 0:00:00 后经过的时间。
TIME - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
W3C XML 模式 1.0 数据类型 time 的完全限定名称。
TIME_ZONE - 类 java.text.DateFormat.Field 中的静态变量
标识 TIME_ZONE 字段的常量。
TIMED_OUT - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
服务器能够连接到输出设备（或始终处于连接状态），但却无法获得输出设备的响应。
timedJoin(Thread, long) - 枚举 java.util.concurrent.TimeUnit 中的方法
使用此时间单元执行计时的 Thread.join。
timedWait(Object, long) - 枚举 java.util.concurrent.TimeUnit 中的方法
使用此时间单元执行计时的 Object.wait。
TimeLimitExceededException - javax.naming 中的 异常
当某一方法没有在指定的时间限制内终止时，抛出此异常。
TimeLimitExceededException() - 异常 javax.naming.TimeLimitExceededException 的构造方法
构造一个新的 TimeLimitExceededException 实例。
TimeLimitExceededException(String) - 异常 javax.naming.TimeLimitExceededException 的构造方法
使用所提供的参数构造一个新的 TimeLimitExceededException 实例。
TIMEOUT - org.omg.CORBA 中的 异常
当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
TIMEOUT() - 异常 org.omg.CORBA.TIMEOUT 的构造方法
构造一个 TIMEOUT 异常，使次要代码 (minor code) 设置为 0，CompletionStatus 设置为 COMPLETED_NO。
TIMEOUT(String) - 异常 org.omg.CORBA.TIMEOUT 的构造方法
使用指定消息构造一个 TIMEOUT 异常。
TIMEOUT(int, CompletionStatus) - 异常 org.omg.CORBA.TIMEOUT 的构造方法
使用指定次要代码和完成状态构造一个 TIMEOUT 异常。
TIMEOUT(String, int, CompletionStatus) - 异常 org.omg.CORBA.TIMEOUT 的构造方法
使用指定消息、次要代码和完成状态构造一个 TIMEOUT 异常。
TimeoutException - java.util.concurrent 中的 异常
阻塞操作超时时，抛出该异常。
TimeoutException() - 异常 java.util.concurrent.TimeoutException 的构造方法
构造不带详细消息的 TimeoutException。
TimeoutException(String) - 异常 java.util.concurrent.TimeoutException 的构造方法
构造带指定详细消息的 TimeoutException。
Timer - java.util 中的 类
一种工具，线程用其安排以后在后台线程中执行的任务。
Timer() - 类 java.util.Timer 的构造方法
创建一个新计时器。
Timer(boolean) - 类 java.util.Timer 的构造方法
创建一个新计时器，可以指定其相关的线程作为守护程序运行。
Timer(String) - 类 java.util.Timer 的构造方法
创建一个新计时器，其相关的线程具有指定的名称。
Timer(String, boolean) - 类 java.util.Timer 的构造方法
创建一个新计时器，其相关的线程具有指定的名称，并且可以指定作为守护程序运行。
Timer - javax.management.timer 中的 类
提供对计时器 MBean 的实现。
Timer() - 类 javax.management.timer.Timer 的构造方法
默认的构造方法。
timer - 类 javax.swing.plaf.basic.BasicTreeUI.ComponentHandler 中的变量
在滚动窗格中调整滚动条时使用的 Timer。
Timer - javax.swing 中的 类
在指定时间间隔触发一个或多个 ActionEvent。
Timer(int, ActionListener) - 类 javax.swing.Timer 的构造方法
创建一个 Timer 并将初始延迟和事件间延迟初始化为 delay 毫秒。
timer - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
在启动编辑会话之前使用。
TimerMBean - javax.management.timer 中的 接口
公开计时器 MBean 的管理接口。
TimerNotification - javax.management.timer 中的 类
此类定义了由计时器 MBean 发送的通知。
TimerNotification(String, Object, long, long, String, Integer) - 类 javax.management.timer.TimerNotification 的构造方法
创建计时器通知对象。
TimerTask - java.util 中的 类
由 Timer 安排为一次执行或重复执行的任务。
TimerTask() - 类 java.util.TimerTask 的构造方法
创建一个新的计时器任务。
TIMES - 类 javax.management.Query 中的静态变量
表示 Query.times(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
times(ValueExp, ValueExp) - 类 javax.management.Query 中的静态方法
返回一个二进制表达式，表示两个数值的乘积。
Timestamp - java.security 中的 类
此类封装有关签署时间戳的信息。
Timestamp(Date, CertPath) - 类 java.security.Timestamp 的构造方法
构造一个时间戳。
Timestamp - java.sql 中的 类
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。
Timestamp(int, int, int, int, int, int, int) - 类 java.sql.Timestamp 的构造方法
已过时。 使用构造方法 Timestamp(long millis) 来代替
Timestamp(long) - 类 java.sql.Timestamp 的构造方法
使用毫秒时间值构造 Timestamp 对象。
TIMESTAMP - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 TIMESTAMP 的 Java 编程语言中的常量（有时称为类型代码）。
timestamp() - 类 java.util.UUID 中的方法
与此 UUID 相关联的时间戳值。
TimeUnit - java.util.concurrent 中的 枚举
TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。
TimeZone - java.util 中的 类
TimeZone 表示时区偏移量，也可以计算夏令时。
TimeZone() - 类 java.util.TimeZone 的构造方法
单独的构造方法。
TIMEZONE_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 TIMEZONE 字段的有用常量。
TimeZoneNameProvider - java.util.spi 中的 类
为 TimeZone 类提供本地化时区名称的服务提供者的抽象类。
TimeZoneNameProvider() - 类 java.util.spi.TimeZoneNameProvider 的构造方法
唯一的构造方法。
TIMING_CLOCK - 类 javax.sound.midi.ShortMessage 中的静态变量
TIMING_CLOCK 消息的状态字节（0xF8 或 248）。
TINYINT - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 TINYINT 的 Java 编程语言中的常量（有时称为类型代码）。
title - 类 javax.swing.border.TitledBorder 中的变量
title - 类 javax.swing.JInternalFrame 中的变量
此内部窗体标题栏中所显示的标题。
TITLE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
TITLE - 类 javax.swing.text.html.HTML.Tag 中的静态变量
title - 类 javax.swing.text.html.parser.DTD 中的变量
TITLE_PROPERTY - 类 javax.swing.JInternalFrame 中的静态变量
绑定属性名。
TITLECASE_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Lt”。
titleColor - 类 javax.swing.border.TitledBorder 中的变量
TitledBorder - javax.swing.border 中的 类
该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。
TitledBorder(String) - 类 javax.swing.border.TitledBorder 的构造方法
创建 TitledBorder 实例。
TitledBorder(Border) - 类 javax.swing.border.TitledBorder 的构造方法
创建具有指定边框和空标题的 TitledBorder 实例。
TitledBorder(Border, String) - 类 javax.swing.border.TitledBorder 的构造方法
创建具有指定边框和标题的 TitledBorder 实例。
TitledBorder(Border, String, int, int) - 类 javax.swing.border.TitledBorder 的构造方法
用指定的边框、标题、标题对齐方式和标题位置创建 TitledBorder 实例。
TitledBorder(Border, String, int, int, Font) - 类 javax.swing.border.TitledBorder 的构造方法
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。
TitledBorder(Border, String, int, int, Font, Color) - 类 javax.swing.border.TitledBorder 的构造方法
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。
titleFont - 类 javax.swing.border.TitledBorder 中的变量
titleJustification - 类 javax.swing.border.TitledBorder 中的变量
titlePane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
titlePosition - 类 javax.swing.border.TitledBorder 中的变量
TitleProperty - 接口 javax.swing.text.Document 中的静态变量
文档标题的属性名（如果有）。
tk_abstract_interface - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_abstract_interface 初始化其 value 字段。
tk_alias - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_alias 初始化其 value 字段。
tk_any - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_any 初始化其 value 字段。
tk_array - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_array 初始化其 value 字段。
tk_boolean - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_boolean 初始化其 value 字段。
tk_char - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_char 初始化其 value 字段。
tk_double - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_double 初始化其 value 字段。
tk_enum - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_enum 初始化其 value 字段。
tk_except - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_except 初始化其 value 字段。
tk_fixed - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_fixed 初始化其 value 字段。
tk_float - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_float 初始化其 value 字段。
tk_long - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_long 初始化其 value 字段。
tk_longdouble - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_longdouble 初始化其 value 字段。
tk_longlong - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_longlong 初始化其 value 字段。
tk_native - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_native 初始化其 value 字段。
tk_null - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_null 初始化其 value 字段。
tk_objref - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_objref 初始化其 value 字段。
tk_octet - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_octet 初始化其 value 字段。
tk_Principal - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_Principal 初始化其 value 字段。
tk_sequence - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_sequence 初始化其 value 字段。
tk_short - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_short 初始化其 value 字段。
tk_string - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_string 初始化其 value 字段。
tk_struct - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_struct 初始化其 value 字段。
tk_TypeCode - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_TypeCode 初始化其 value 字段。
tk_ulong - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_ulong 初始化其 value 字段。
tk_ulonglong - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_ulonglong 初始化其 value 字段。
tk_union - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_union 初始化其 value 字段。
tk_ushort - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_ushort 初始化其 value 字段。
tk_value - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_value 初始化其 value 字段。
tk_value_box - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_value_box 初始化其 value 字段。
tk_void - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_void 初始化其 value 字段。
tk_wchar - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_wchar 初始化其 value 字段。
tk_wstring - 类 org.omg.CORBA.TCKind 中的静态变量
TCKind 常量，使用 TCKind._tk_wstring 初始化其 value 字段。
TMENDRSCAN - 接口 javax.transaction.xa.XAResource 中的静态变量
终止恢复扫描。
TMFAIL - 接口 javax.transaction.xa.XAResource 中的静态变量
取消关联调用者，并将事务分支标记为只回滚。
TMJOIN - 接口 javax.transaction.xa.XAResource 中的静态变量
调用者正连接现有事务分支。
TMNOFLAGS - 接口 javax.transaction.xa.XAResource 中的静态变量
使用 TMNOFLAGS 指示不选择任何标志值。
TMONEPHASE - 接口 javax.transaction.xa.XAResource 中的静态变量
调用者正在使用一阶段优化。
TMRESUME - 接口 javax.transaction.xa.XAResource 中的静态变量
调用者正在恢复与挂起的事务分支的关联。
TMSTARTRSCAN - 接口 javax.transaction.xa.XAResource 中的静态变量
启动恢复扫描。
TMSUCCESS - 接口 javax.transaction.xa.XAResource 中的静态变量
取消调用者与事务分支的关联。
TMSUSPEND - 接口 javax.transaction.xa.XAResource 中的静态变量
调用者正挂起（不是终止）其与事务分支的关联。
to_any() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 将 DynAny 对象转换成 Any 对象。
to_any() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
从 DynAny 对象中创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynStructStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 类 org.omg.DynamicAny._DynValueStub 中的方法
从 DynAny 对象创建 any 值。
to_any() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
从 DynAny 对象创建 any 值。
to_name(String) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作将“字符串化的名称”转换为等效的“名称组件”数组。
to_name(String) - 接口 org.omg.CosNaming.NamingContextExtOperations 中的方法
此操作将“字符串化的名称”转换为等效的“名称组件”数组。
to_string(NameComponent[]) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作从 Name 组件数组创建字符串化的名称。
to_string(NameComponent[]) - 接口 org.omg.CosNaming.NamingContextExtOperations 中的方法
此操作根据 Name 组件数组创建字符串化的名称。
to_url(String, String) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
to_url(String, String) - 接口 org.omg.CosNaming.NamingContextExtOperations 中的方法
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。
toArray() - 类 java.awt.dnd.DragGestureEvent 中的方法
返回组成拖动动作的事件 Object 数组。
toArray(Object[]) - 类 java.awt.dnd.DragGestureEvent 中的方法
返回组成拖动动作的事件数组。
toArray() - 类 java.beans.beancontext.BeanContextMembershipEvent 中的方法
获得受此事件影响的子级的数组。
toArray() - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。
toArray(Object[]) - 类 java.beans.beancontext.BeanContextSupport 中的方法
获得包含与数组中所包含类型匹配的此 BeanContext 的所有子级的数组。
toArray() - 类 java.util.AbstractCollection 中的方法
返回包含此 collection 中所有元素的数组。
toArray(T[]) - 类 java.util.AbstractCollection 中的方法
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。
toArray() - 类 java.util.ArrayDeque 中的方法
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）。
toArray(T[]) - 类 java.util.ArrayDeque 中的方法
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.ArrayList 中的方法
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组。
toArray(T[]) - 类 java.util.ArrayList 中的方法
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 接口 java.util.Collection 中的方法
返回包含此 collection 中所有元素的数组。
toArray(T[]) - 接口 java.util.Collection 中的方法
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。
toArray() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回一个按适当顺序包含此队列中所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
返回一个按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
返回以恰当顺序包含此队列所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.ConcurrentLinkedQueue 中的方法
返回以恰当顺序包含此队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回一个按恰当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回以恰当顺序（从第一个元素到最后一个元素）包含列表所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
返回一个包含此 set 所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.CopyOnWriteArraySet 中的方法
返回一个包含此 set 所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 类 java.util.concurrent.DelayQueue 中的方法
返回包含此队列所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.DelayQueue 中的方法
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回以恰当顺序（从第一个元素到最后一个元素）包含此双端队列所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
返回以恰当顺序包含此双端队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回按适当顺序包含此队列中所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
返回按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
返回包含此队列所有元素的数组。
toArray(T[]) - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 类 java.util.concurrent.SynchronousQueue 中的方法
返回一个 0 长度的数组。
toArray(T[]) - 类 java.util.concurrent.SynchronousQueue 中的方法
将指定数组的第 0 个元素设置为 null（如果该数组有非 0 的长度）并返回它。
toArray() - 类 java.util.LinkedList 中的方法
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。
toArray(T[]) - 类 java.util.LinkedList 中的方法
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组；返回数组的运行时类型为指定数组的类型。
toArray() - 接口 java.util.List 中的方法
返回按适当顺序包含列表中的所有元素的数组（从第一个元素到最后一个元素）。
toArray(T[]) - 接口 java.util.List 中的方法
返回按适当顺序（从第一个元素到最后一个元素）包含列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
toArray() - 类 java.util.PriorityQueue 中的方法
返回一个包含此队列所有元素的数组。
toArray(T[]) - 类 java.util.PriorityQueue 中的方法
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 接口 java.util.Set 中的方法
返回一个包含 set 中所有元素的数组。
toArray(T[]) - 接口 java.util.Set 中的方法
返回一个包含此 set 中所有元素的数组；返回数组的运行时类型是指定数组的类型。
toArray() - 类 java.util.Vector 中的方法
返回一个数组，包含此向量中以恰当顺序存放的所有元素。
toArray(T[]) - 类 java.util.Vector 中的方法
返回一个数组，包含此向量中以恰当顺序存放的所有元素；返回数组的运行时类型为指定数组的类型。
toArray() - 类 javax.accessibility.AccessibleRelationSet 中的方法
返回作为 AccessibleRelation 数组的当前关系集
toArray() - 类 javax.accessibility.AccessibleStateSet 中的方法
以 AccessibleState 数组形式返回当前状态集
toArray() - 接口 javax.print.attribute.AttributeSet 中的方法
返回此集合中包含的属性的数组。
toArray() - 类 javax.print.attribute.HashAttributeSet 中的方法
toArray() - 类 javax.swing.DefaultListModel 中的方法
以正确顺序返回包含此列表中所有元素的数组。
toASCII(String, int) - 类 java.net.IDN 中的静态方法
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。
toASCII(String) - 类 java.net.IDN 中的静态方法
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。
toASCIIString() - 类 java.net.URI 中的方法
以 US-ASCII 字符串形式返回此 URI 的内容。
toAttributes() - 类 javax.naming.ldap.Rdn 中的方法
检索此 Rdn 中包含的类型/值映射关系的 Attributes 视图。
toBack() - 类 java.awt.Dialog 中的方法
如果此窗口是可视的，则将此窗口置于后方，如果它是焦点窗口或活动窗口，则会导致丢失焦点或活动状态。
toBack() - 类 java.awt.Window 中的方法
如果此窗口是可视的，则将此窗口置于后方，如果它是焦点窗口或活动窗口，则会导致丢失焦点或活动状态。
toBack() - 类 javax.swing.JInternalFrame 中的方法
将此内部窗体发送至后台。
toBigInteger() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 BigInteger。
toBigIntegerExact() - 类 java.math.BigDecimal 中的方法
将此 BigDecimal 转换为 BigInteger，以检查丢失的信息。
toBinaryString(int) - 类 java.lang.Integer 中的静态方法
以二进制（基数 2）无符号整数形式返回一个整数参数的字符串表示形式。
toBinaryString(long) - 类 java.lang.Long 中的静态方法
以二进制无符号整数形式返回 long 参数的字符串表示形式。
TOBOTTOM_TOLEFT - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从右上开始，按列布置各页，然后向左下部展开。
TOBOTTOM_TORIGHT - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从左上开始，按列布置各页，然后向右下部展开。
toBundleName(String, Locale) - 类 java.util.ResourceBundle.Control 中的方法
将给定 baseName 和 locale 转换为包名称。
toByteArray() - 类 java.io.ByteArrayOutputStream 中的方法
创建一个新分配的 byte 数组。
toByteArray() - 类 java.math.BigInteger 中的方法
返回一个 byte 数组，该数组包含此 BigInteger 的二进制补码表示形式。
toByteArray() - 类 java.text.CollationKey 中的方法
将 CollationKey 转换成位序列。
toCachedRowSet() - 接口 javax.sql.rowset.JoinRowSet 中的方法
创建一个包含此 JoinRowSet 对象中数据的新 CachedRowSet 对象，可以使用 CachedRowSet 对象的 SyncProvider 对象将此 JoinRowSet 对象保存到数据源。
toCharArray() - 类 java.io.CharArrayWriter 中的方法
返回输入数据的副本。
toCharArray() - 类 java.lang.String 中的方法
将此字符串转换为一个新的字符数组。
toChars(int, char[], int) - 类 java.lang.Character 中的静态方法
将指定字符（Unicode 代码点）转换为其 UTF-16 表示形式。
toChars(int) - 类 java.lang.Character 中的静态方法
将指定的字符（Unicode 代码点）转换成其存储在 char 数组中的 UTF-16 表示形式。
toCIEXYZ(float[]) - 类 java.awt.color.ColorSpace 中的方法
将假定为此 ColorSpace 中的颜色值转换成 CS_CIEXYZ 变换颜色空间中的值。
toCIEXYZ(float[]) - 类 java.awt.color.ICC_ColorSpace 中的方法
将假定为此 ColorSpace 中的颜色值转换成 CS_CIEXYZ 变换颜色空间中的值。
toCodePoint(char, char) - 类 java.lang.Character 中的静态方法
将指定的代理项对转换为其增补代码点值。
toCollection() - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象转换成一个 Collection 对象，它包含此 CachedRowSet 对象的所有数据。
toCollection(int) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
toCollection(String) - 接口 javax.sql.rowset.CachedRowSet 中的方法
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
toCompositeData(CompositeType) - 接口 javax.management.openmbean.CompositeDataView 中的方法
返回对应于此对象中的值的 CompositeData。
toDays(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 DAYS.convert(duration, this)。
toDegrees(double) - 类 java.lang.Math 中的静态方法
将用弧度表示的角转换为近似相等的用角度表示的角。
toDegrees(double) - 类 java.lang.StrictMath 中的静态方法
将用弧度表示的角转换为近似相等的用角度表示的角。
toDisplayString(String, Locale) - 类 javax.accessibility.AccessibleBundle 中的方法
获取本地化字符串形式的键。
toDisplayString(Locale) - 类 javax.accessibility.AccessibleBundle 中的方法
获取本地化字符串形式的键。
toDisplayString() - 类 javax.accessibility.AccessibleBundle 中的方法
获取使用默认语言环境来描述键的本地化字符串。
toEngineeringString() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的字符串表示形式，需要指数时，则使用工程计数法。
toExternalForm() - 类 java.net.URL 中的方法
构造此 URL 的字符串表示形式。
toExternalForm(URL) - 类 java.net.URLStreamHandler 中的方法
将特定协议的 URL 转换为 String。
toFront() - 类 java.awt.Window 中的方法
如果此窗口是可见的，则将此窗口置于前端，并可以将其设为焦点 Window。
toFront() - 类 javax.swing.JInternalFrame 中的方法
将此内部窗体置于前端。
toGenericString() - 类 java.lang.reflect.Constructor 中的方法
返回描述此 Constructor 的字符串，其中包括类型参数。
toGenericString() - 类 java.lang.reflect.Field 中的方法
返回一个描述此 Field（包括其一般类型）的字符串。
toGenericString() - 类 java.lang.reflect.Method 中的方法
返回描述此 Method 的字符串，包括类型参数。
TOGGLE_BUTTON - 类 javax.accessibility.AccessibleRole 中的静态变量
可以被选中或不被选中的专用按钮，但不针对当前状态提供单独的指示符。
TOGGLE_BUTTON - 类 javax.swing.plaf.synth.Region 中的静态变量
ToggleButton 的 region。
TOGGLE_CLICK_COUNT_PROPERTY - 类 javax.swing.JTree 中的静态变量
toggleClickCount 的绑定属性名称。
TOGGLE_EXPAND - 接口 javax.accessibility.AccessibleAction 中的静态变量
如果树节点是展开的，则此动作将折叠它，如果是折叠的则展开它。
TOGGLE_POPUP - 接口 javax.accessibility.AccessibleAction 中的静态变量
如果某个弹出菜单是隐藏的，则此动作将使其可见，如果是可见的则将其隐藏。
toggleClickCount - 类 javax.swing.JTree 中的变量
展开节点之前的鼠标单击数。
toggleExpandState(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
如果路径不是展开的，则展开它；如果它是展开的，则折叠它。
toggleOpenClose() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
如果正在显示弹出部分，则隐藏它；如果它是隐藏的，则显示它。
togglePopup() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
如果弹出部分是隐藏的，则使其可见；如果它是可见的，则将其隐藏。
toggleSortOrder(int) - 类 javax.swing.DefaultRowSorter 中的方法
如果指定列已经是主要排序列，则反转排序顺序（将升序变为降序，或将降序变为升序）；否则，使指定列成为主要排序列，并使用升序排序顺序。
toggleSortOrder(int) - 类 javax.swing.RowSorter 中的方法
颠倒指定列的排序顺序。
toGMTString() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。
toGregorianCalendar() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此 XMLGregorianCalendar 转换为 GregorianCalendar。
toGregorianCalendar(TimeZone, Locale, XMLGregorianCalendar) - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。
toHexString(double) - 类 java.lang.Double 中的静态方法
返回 double 参数的十六进制字符串表示形式。
toHexString(float) - 类 java.lang.Float 中的静态方法
返回 float 参数的十六进制字符串表示形式。
toHexString(int) - 类 java.lang.Integer 中的静态方法
以十六进制（基数 16）无符号整数形式返回一个整数参数的字符串表示形式。
toHexString(long) - 类 java.lang.Long 中的静态方法
以十六进制无符号整数形式返回 long 参数的字符串表示形式。
toHours(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 HOURS.convert(duration, this)。
toIndex - 类 javax.swing.event.TableColumnModelEvent 中的变量
列的索引，该索引处是移动或添加操作的目标位置
toJMXConnector(Map<String, ?>) - 类 javax.management.remote.JMXConnectorServer 中的方法
返回此连接器服务器的客户端 stub。
toJMXConnector(Map<String, ?>) - 接口 javax.management.remote.JMXConnectorServerMBean 中的方法
返回此连接器服务器的客户端 stub。
toJMXConnector(Map<String, ?>) - 类 javax.management.remote.rmi.RMIConnectorServer 中的方法
返回此连接器服务器的客户端 stub。
TOLEFT_TOBOTTOM - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从右上部开始，按行布置各页，然后向左下部展开。
TOLEFT_TOTOP - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从右下部开始，按行布置各页，然后向左上部展开。
toLocaleString() - 类 java.util.Date 中的方法
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。
toLocalizedPattern() - 类 java.text.DecimalFormat 中的方法
合成一个表示此 Format 对象当前状态的、已本地化的模式字符串。
toLocalizedPattern() - 类 java.text.SimpleDateFormat 中的方法
返回描述此日期格式的本地化模式字符串。
toLowerCase(char) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为小写。
toLowerCase(int) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为小写。
toLowerCase(Locale) - 类 java.lang.String 中的方法
使用给定 Locale 的规则将此 String 中的所有字符都转换为小写。
toLowerCase() - 类 java.lang.String 中的方法
使用默认语言环境的规则将此 String 中的所有字符都转换为小写。
toMatchResult() - 类 java.util.regex.Matcher 中的方法
作为 MatchResult 返回此匹配器的匹配状态。
toMicros(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 MICROSECONDS.convert(duration, this)。
toMillis(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 MILLISECONDS.convert(duration, this)。
toMinutes(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 MINUTES.convert(duration, this)。
toNanos(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 NANOSECONDS.convert(duration, this)。
TONER_EMPTY - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备的碳粉用完。
TONER_LOW - 类 javax.print.attribute.standard.PrinterStateReason 中的静态变量
设备的碳粉不足。
toOctalString(int) - 类 java.lang.Integer 中的静态方法
以八进制（基数 8）无符号整数形式返回一个整数参数的字符串表示形式。
toOctalString(long) - 类 java.lang.Long 中的静态方法
以八进制无符号整数形式返回 long 参数的字符串表示形式。
Tool - javax.tools 中的 接口
可以从程序中调用的工具的公共接口。
TOOL_BAR - 类 javax.accessibility.AccessibleRole 中的静态变量
通常由普通按钮或切换按钮组成的工具栏或调色板。
TOOL_BAR - 类 javax.swing.plaf.synth.Region 中的静态变量
ToolBar 的 region。
TOOL_BAR_CONTENT - 类 javax.swing.plaf.synth.Region 中的静态变量
包含内容的 ToolBar 的 region。
TOOL_BAR_DRAG_WINDOW - 类 javax.swing.plaf.synth.Region 中的静态变量
包含 ToolBar 的 Window 的 region。
TOOL_BAR_SEPARATOR - 类 javax.swing.plaf.synth.Region 中的静态变量
ToolBar 分隔器的 region。
TOOL_TIP - 类 javax.accessibility.AccessibleRole 中的静态变量
提供关于另一个对象信息的对象。
TOOL_TIP - 类 javax.swing.plaf.synth.Region 中的静态变量
ToolTip 的 region。
TOOL_TIP_TEXT_KEY - 类 javax.swing.JComponent 中的静态变量
光标位于组件上方时显示的注释，也称为“值提示”、“相交提示 (flyover help)”或“相交标签 (flyover label)”。
toolBar - 类 javax.swing.plaf.basic.BasicToolBarUI.DockingListener 中的变量
toolBar - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
toolBarContListener - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
toolBarFocusListener - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
ToolBarUI - javax.swing.plaf 中的 类
JToolBar 的可插入外观界面。
ToolBarUI() - 类 javax.swing.plaf.ToolBarUI 的构造方法
Toolkit - java.awt 中的 类
此类是所有 Abstract Window Toolkit 实际实现的抽象超类。
Toolkit() - 类 java.awt.Toolkit 的构造方法
ToolProvider - javax.tools 中的 类
为查找工具提供者提供方法，例如，编译器的提供者。
ToolTipManager - javax.swing 中的 类
管理系统中的所有 ToolTips。
ToolTipManager.insideTimerAction - javax.swing 中的 类
ToolTipManager.insideTimerAction() - 类 javax.swing.ToolTipManager.insideTimerAction 的构造方法
ToolTipManager.outsideTimerAction - javax.swing 中的 类
ToolTipManager.outsideTimerAction() - 类 javax.swing.ToolTipManager.outsideTimerAction 的构造方法
ToolTipManager.stillInsideTimerAction - javax.swing 中的 类
ToolTipManager.stillInsideTimerAction() - 类 javax.swing.ToolTipManager.stillInsideTimerAction 的构造方法
ToolTipUI - javax.swing.plaf 中的 类
JToolTip 的可插入外观界面。
ToolTipUI() - 类 javax.swing.plaf.ToolTipUI 的构造方法
TooManyListenersException - java.util 中的 异常
TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
TooManyListenersException() - 异常 java.util.TooManyListenersException 的构造方法
构造不带详细消息的 TooManyListenersException。
TooManyListenersException(String) - 异常 java.util.TooManyListenersException 的构造方法
构造带指定详细消息的 TooManyListenersException。
top - 类 java.awt.Insets 中的变量
顶部的 inset。
TOP - 类 javax.print.attribute.standard.MediaTray 中的静态变量
打印机中的顶层进纸托盘。
top - 类 javax.swing.border.EmptyBorder 中的变量
TOP - 类 javax.swing.border.TitledBorder 中的静态变量
将标题置于边框顶端线的中部。
TOP - 类 javax.swing.JSplitPane 中的静态变量
用于添加一个 Component 到另一个 Component 的上面。
TOP - 接口 javax.swing.SwingConstants 中的静态变量
用于指定框顶部位置的框方向常量。
TOP_ALIGNMENT - 类 java.awt.Component 中的静态变量
getAlignmentY() 的易于使用的常量。
TOP_ALIGNMENT - 类 java.awt.font.GraphicAttribute 中的静态变量
将图形顶端与行的顶端对齐。
toPattern() - 类 java.text.ChoiceFormat 中的方法
获取模式。
toPattern() - 类 java.text.DecimalFormat 中的方法
合成一个表示此 Format 对象当前状态的模式字符串。
toPattern() - 类 java.text.MessageFormat 中的方法
返回表示消息格式当前状态的模式。
toPattern() - 类 java.text.SimpleDateFormat 中的方法
返回描述此日期格式的模式字符串。
TOPDOWNLEFTRIGHT - 接口 java.awt.image.ImageConsumer 中的静态变量
按从上到下、从左到右的顺序传递像素。
toPlainString() - 类 java.math.BigDecimal 中的方法
返回不带指数字段的此 BigDecimal 的字符串表示形式。
toRadians(double) - 类 java.lang.Math 中的静态方法
将用角度表示的角转换为近似相等的用弧度表示的角。
toRadians(double) - 类 java.lang.StrictMath 中的静态方法
将用角度表示的角转换为近似相等的用弧度表示的角。
toResourceName(String, String) - 类 java.util.ResourceBundle.Control 中的方法
将给定 bundleName 转换为 ClassLoader.getResource 方法要求的形式：用 '/' 替换 bundleName 中出现的所有 '.'，并添加一个 '.' 和给定的文件 suffix。
toRGB(float[]) - 类 java.awt.color.ColorSpace 中的方法
将假定为此 ColorSpace 中的颜色值转换成默认 CS_sRGB 颜色空间中的值。
toRGB(float[]) - 类 java.awt.color.ICC_ColorSpace 中的方法
将假定为此 ColorSpace 中的颜色值转换成默认 CS_sRGB 颜色空间中的值。
TORIGHT_TOBOTTOM - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从左上部开始，按行布置各页，然后向右下部展开。
TORIGHT_TOTOP - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从左下部开始，按行布置各页，然后向右上部展开。
toSeconds(long) - 枚举 java.util.concurrent.TimeUnit 中的方法
等效于 SECONDS.convert(duration, this)。
toString() - 类 java.awt.AWTEvent 中的方法
返回此对象的字符串表示形式。
toString() - 类 java.awt.AWTKeyStroke 中的方法
返回一个显示并标识此对象属性的字符串。
toString() - 类 java.awt.BorderLayout 中的方法
返回此边框布局的状态的字符串表示形式。
toString() - 类 java.awt.CardLayout 中的方法
返回此卡片布局状态的字符串表示形式。
toString() - 类 java.awt.CheckboxGroup 中的方法
返回此复选框组的字符串表示形式，包含当前选中复选框的值。
toString() - 类 java.awt.Color 中的方法
返回此 Color 的字符串表示形式。
toString() - 类 java.awt.Component 中的方法
返回此组件及其值的字符串表示形式。
toString() - 类 java.awt.Cursor 中的方法
返回此光标的字符串表示形式。
toString() - 类 java.awt.datatransfer.DataFlavor 中的方法
此 DataFlavor 及其参数的字符串表示形式。
toString() - 类 java.awt.Dimension 中的方法
返回此 Dimension 对象的 height 和 width 字段的字符串表示形式。
toString() - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
toString() - 类 java.awt.FlowLayout 中的方法
返回此 FlowLayout 对象及其值的字符串表示形式。
toString() - 类 java.awt.font.NumericShaper 中的方法
返回描述此成形器的 String。
toString() - 类 java.awt.font.TextHitInfo 中的方法
返回表示此 TextHitInfo 的 String，只用于调试目的。
toString() - 类 java.awt.font.TextLayout 中的方法
返回此 TextLayout 的调试信息。
toString() - 类 java.awt.Font 中的方法
将此 Font 对象转换为 String 表示形式。
toString() - 类 java.awt.FontMetrics 中的方法
返回此 FontMetrics 对象的值的 String 表示形式。
toString() - 类 java.awt.geom.AffineTransform 中的方法
返回表示此 Object 值的 String。
toString() - 类 java.awt.geom.Point2D.Double 中的方法
返回表示此 Point2D 值的 String。
toString() - 类 java.awt.geom.Point2D.Float 中的方法
返回表示此 Point2D 值的 String。
toString() - 类 java.awt.geom.Rectangle2D.Double 中的方法
返回此 Rectangle2D 的 String 表示形式。
toString() - 类 java.awt.geom.Rectangle2D.Float 中的方法
返回此 Rectangle2D 的 String 表示形式。
toString() - 类 java.awt.Graphics 中的方法
返回表示此 Graphics 对象值的 String 对象。
toString() - 类 java.awt.GridBagLayout 中的方法
返回此网格包布局的值的字符串表示形式。
toString() - 类 java.awt.GridLayout 中的方法
返回此网格布局的值的字符串表示形式。
toString() - 类 java.awt.image.BufferedImage 中的方法
返回此 BufferedImage 对象及其值的 String 表示形式。
toString() - 类 java.awt.image.ColorModel 中的方法
返回此 ColorModel 对象的内容的 String 表示形式。
toString() - 类 java.awt.image.DirectColorModel 中的方法
返回表示此 DirectColorModel 的 String。
toString() - 类 java.awt.image.IndexColorModel 中的方法
返回此 ColorModel 对象内容的 String 表示形式。
toString() - 类 java.awt.Insets 中的方法
返回此 Insets 对象的字符串表示形式。
toString() - 类 java.awt.JobAttributes 中的方法
返回此 JobAttributes 的字符串表示形式。
toString() - 类 java.awt.MenuComponent 中的方法
返回此菜单组件的表示形式。
toString() - 类 java.awt.MenuShortcut 中的方法
返回此菜单快捷方式的国际化描述。
toString() - 类 java.awt.PageAttributes 中的方法
返回此 PageAttributes 的字符串表示形式。
toString() - 类 java.awt.Point 中的方法
返回此点的字符串表示形式及其在 (x,y) 坐标空间中的位置。
toString() - 类 java.awt.Rectangle 中的方法
返回表示此 Rectangle 及其值的 String。
toString() - 类 java.awt.RenderingHints 中的方法
返回 hashmap 的一个相当长的字符串表示形式，该 hashmap 包含此 RenderingHints 对象的键或值的映射关系。
toString() - 类 java.awt.Robot 中的方法
返回此 Robot 的字符串表示形式。
toString() - 类 java.awt.ScrollPaneAdjustable 中的方法
返回此滚动条及其值的字符串表示形式。
toString() - 类 java.awt.SystemColor 中的方法
返回此 Color 值的字符串表示形式。
toString() - 类 java.beans.Expression 中的方法
使用 Java 风格的语法打印此表达式的值。
toString() - 类 java.beans.Statement 中的方法
使用 Java 风格的语法打印此语句的值。
toString() - 类 java.io.ByteArrayOutputStream 中的方法
使用平台默认的字符集，通过解码字节将缓冲区内容转换为字符串。
toString(String) - 类 java.io.ByteArrayOutputStream 中的方法
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。
toString(int) - 类 java.io.ByteArrayOutputStream 中的方法
已过时。 此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。
toString() - 类 java.io.CharArrayWriter 中的方法
将输入数据转换为字符串。
toString() - 类 java.io.File 中的方法
返回此抽象路径名的路径名字符串。
toString() - 类 java.io.ObjectStreamClass 中的方法
返回描述此 ObjectStreamClass 的字符串。
toString() - 类 java.io.ObjectStreamField 中的方法
返回描述此字段的字符串。
toString() - 类 java.io.StreamTokenizer 中的方法
返回当前流标记和在其上发生的行号的字符串表示形式。
toString() - 类 java.io.StringWriter 中的方法
以字符串的形式返回该缓冲区的当前值。
toString() - 接口 java.lang.annotation.Annotation 中的方法
返回此 annotation 的字符串表示形式。
toString(boolean) - 类 java.lang.Boolean 中的静态方法
返回一个表示指定布尔值的 String 对象。
toString() - 类 java.lang.Boolean 中的方法
返回表示该布尔值的 String 对象。
toString(byte) - 类 java.lang.Byte 中的静态方法
返回表示指定 byte 的一个新 String 对象。
toString() - 类 java.lang.Byte 中的方法
返回表示此 Byte 的值的 String 对象。
toString() - 类 java.lang.Character.Subset 中的方法
返回该子集的名称。
toString() - 类 java.lang.Character 中的方法
返回表示此 Character 值的 String 对象。
toString(char) - 类 java.lang.Character 中的静态方法
返回一个表示指定 char 值的 String 对象。
toString() - 接口 java.lang.CharSequence 中的方法
返回一个包含此序列中字符的字符串，该字符串与此序列的顺序相同。
toString() - 类 java.lang.Class 中的方法
将对象转换为字符串。
toString(double) - 类 java.lang.Double 中的静态方法
返回 double 参数的字符串表示形式。
toString() - 类 java.lang.Double 中的方法
返回此 Double 对象的字符串表示形式。
toString() - 类 java.lang.Enum 中的方法
返回枚举常量的名称，它包含在声明中。
toString(float) - 类 java.lang.Float 中的静态方法
返回 float 参数的字符串表示形式。
toString() - 类 java.lang.Float 中的方法
返回此 Float 对象的字符串表示形式。
toString(int, int) - 类 java.lang.Integer 中的静态方法
返回用第二个参数指定基数表示的第一个参数的字符串表示形式。
toString(int) - 类 java.lang.Integer 中的静态方法
返回一个表示指定整数的 String 对象。
toString() - 类 java.lang.Integer 中的方法
返回一个表示该 Integer 值的 String 对象。
toString(long, int) - 类 java.lang.Long 中的静态方法
返回在使用第二个参数指定的基数时第一个参数的字符串表示形式。
toString(long) - 类 java.lang.Long 中的静态方法
返回表示指定 long 的 String 对象。
toString() - 类 java.lang.Long 中的方法
返回表示 Long 值的 String 对象。
toString() - 类 java.lang.management.LockInfo 中的方法
返回锁的字符串表示形式。
toString() - 枚举 java.lang.management.MemoryType 中的方法
返回该 MemoryType 的字符串表示形式。
toString() - 类 java.lang.management.MemoryUsage 中的方法
返回此内存使用量的描述性表示形式。
toString() - 类 java.lang.management.ThreadInfo 中的方法
返回此线程信息的字符串表示形式。
toString() - 类 java.lang.Object 中的方法
返回该对象的字符串表示。
toString() - 类 java.lang.Package 中的方法
返回此 Package 的字符串表示形式。
toString() - 类 java.lang.reflect.Constructor 中的方法
返回描述此 Constructor 的字符串。
toString() - 类 java.lang.reflect.Field 中的方法
返回一个描述此 Field 的字符串。
toString() - 类 java.lang.reflect.Method 中的方法
返回描述此 Method 的字符串。
toString(int) - 类 java.lang.reflect.Modifier 中的静态方法
返回描述指定修饰符中的访问修饰符标志的字符串。
toString(short) - 类 java.lang.Short 中的静态方法
返回表示指定 short 的一个新 String 对象。
toString() - 类 java.lang.Short 中的方法
返回表示此 Short 的值的 String 对象。
toString() - 类 java.lang.StackTraceElement 中的方法
返回表示该堆栈跟踪元素的字符串。
toString() - 类 java.lang.String 中的方法
返回此对象本身（它已经是一个字符串！）。
toString() - 类 java.lang.StringBuffer 中的方法
toString() - 类 java.lang.StringBuilder 中的方法
toString() - 类 java.lang.Thread 中的方法
返回该线程的字符串表示形式，包括线程名称、优先级和线程组。
toString() - 类 java.lang.ThreadGroup 中的方法
返回此线程组的字符串表示形式。
toString() - 类 java.lang.Throwable 中的方法
返回此 throwable 的简短描述。
toString() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的字符串表示形式，如果需要指数，则使用科学记数法。
toString(int) - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的给定基数的字符串表示形式。
toString() - 类 java.math.BigInteger 中的方法
返回此 BigInteger 的十进制字符串表示形式。
toString() - 类 java.math.MathContext 中的方法
返回此 MathContext 的字符串表示形式。
toString() - 类 java.net.HttpCookie 中的方法
构造此 cookie 的一个 cookie 头字符串表示形式，其格式为对应的 cookie 规范定义的格式，但没有前导 "Cookie:" 标记。
toString() - 类 java.net.InetAddress 中的方法
将此 IP 地址转换为 String。
toString() - 类 java.net.InetSocketAddress 中的方法
构造此 InetSocketAddress 的字符串表示形式。
toString() - 类 java.net.InterfaceAddress 中的方法
将此接口地址转换为 String。
toString() - 类 java.net.NetworkInterface 中的方法
toString() - 类 java.net.Proxy 中的方法
构造此代理的字符串表示形式。
toString() - 类 java.net.ServerSocket 中的方法
作为 String 返回此套接字的实现地址和实现端口。
toString() - 类 java.net.Socket 中的方法
将此套接字转换为 String。
toString() - 类 java.net.SocketImpl 中的方法
以 String 的形式返回此套接字的地址和端口。
toString() - 类 java.net.URI 中的方法
以字符串形式返回此 URI 的内容。
toString() - 类 java.net.URL 中的方法
构造此 URL 的字符串表示形式。
toString() - 类 java.net.URLConnection 中的方法
返回此 URL 连接的 String 表示形式。
toString() - 类 java.nio.ByteBuffer 中的方法
返回汇总了此缓冲区状态的字符串。
toString() - 类 java.nio.ByteOrder 中的方法
构造描述此对象的字符串。
toString() - 类 java.nio.channels.FileChannel.MapMode 中的方法
返回描述此文件映射模式的字符串。
toString() - 类 java.nio.channels.FileLock 中的方法
返回描述此锁定的范围、类型和有效性的字符串。
toString() - 类 java.nio.CharBuffer 中的方法
返回包含此缓冲区中字符的字符串。
toString() - 类 java.nio.charset.Charset 中的方法
返回描述此 charset 的字符串。
toString() - 类 java.nio.charset.CoderResult 中的方法
返回描述此 CoderResult 的字符串。
toString() - 类 java.nio.charset.CodingErrorAction 中的方法
返回描述此操作的字符串。
toString() - 类 java.nio.DoubleBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.nio.FloatBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.nio.IntBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.nio.LongBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.nio.ShortBuffer 中的方法
返回总结了此缓冲区状态的字符串。
toString() - 类 java.rmi.dgc.VMID 中的方法
返回此 VMID 的字符串表示形式。
toString() - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
toString() - 类 java.rmi.server.ObjID 中的方法
返回此对象标识符的字符串表示形式。
toString() - 类 java.rmi.server.Operation 中的方法
已过时。 无替代版本
toString() - 类 java.rmi.server.RemoteObject 中的方法
返回表示此远程对象的值的 String。
toString() - 类 java.rmi.server.UID 中的方法
返回此 UID 的字符串表示形式。
toString() - 接口 java.security.acl.Acl 中的方法
返回 ACL 内容的字符串表示形式。
toString() - 接口 java.security.acl.AclEntry 中的方法
返回此 ACL 项内容的字符串表示形式。
toString() - 接口 java.security.acl.Permission 中的方法
打印此权限的字符串表示形式。
toString() - 类 java.security.AlgorithmParameters 中的方法
返回描述参数的格式化字符串。
toString() - 类 java.security.cert.Certificate 中的方法
返回此证书的字符串表示形式。
toString() - 类 java.security.cert.CertPath 中的方法
返回此证书路径的字符串表示形式。
toString() - 类 java.security.cert.CollectionCertStoreParameters 中的方法
返回描述该参数的格式化字符串。
toString() - 类 java.security.cert.CRL 中的方法
返回此 CRL 的字符串表示形式。
toString() - 类 java.security.cert.LDAPCertStoreParameters 中的方法
返回描述该参数的格式化字符串。
toString() - 类 java.security.cert.PKIXBuilderParameters 中的方法
返回描述该参数的格式化字符串。
toString() - 类 java.security.cert.PKIXCertPathBuilderResult 中的方法
返回此 PKIXCertPathBuilderResult 的可打印表示形式。
toString() - 类 java.security.cert.PKIXCertPathValidatorResult 中的方法
返回此 PKIXCertPathValidatorResult 的可打印表示形式。
toString() - 类 java.security.cert.PKIXParameters 中的方法
返回描述该参数的格式化字符串。
toString() - 类 java.security.cert.PolicyQualifierInfo 中的方法
返回此 PolicyQualifierInfo 的可打印表示形式。
toString() - 类 java.security.cert.TrustAnchor 中的方法
返回描述此 TrustAnchor 的格式化字符串。
toString() - 类 java.security.cert.X509CertSelector 中的方法
返回该 CertSelector 的可打印表示形式。
toString() - 类 java.security.cert.X509CRLEntry 中的方法
返回此 CRL 项的字符串表示形式。
toString() - 类 java.security.cert.X509CRLSelector 中的方法
返回该 X509CRLSelector 的可打印表示形式。
toString(boolean) - 接口 java.security.Certificate 中的方法
已过时。 返回表示证书内容的字符串。
toString() - 类 java.security.CodeSigner 中的方法
返回描述此代码签名者的字符串。
toString() - 类 java.security.CodeSource 中的方法
返回描述此 CodeSource 的字符串，告知其 URL 和证书。
toString() - 类 java.security.DigestInputStream 中的方法
打印此摘要输入流及其关联的消息摘要对象的字符串表示形式。
toString() - 类 java.security.DigestOutputStream 中的方法
打印此摘要输出流及其关联的消息摘要对象的字符串表示形式。
toString() - 类 java.security.Identity 中的方法
已过时。 返回描述此 Identity 的短字符串，说明其名称和作用域（如果有的话）。
toString(boolean) - 类 java.security.Identity 中的方法
已过时。 返回此 Identity 的字符串表示形式，可以选择比不带任何参数的 toString 方法带有更多的详细信息。
toString() - 类 java.security.IdentityScope 中的方法
已过时。 返回此身份作用域的字符串表示形式，包括其名称、作用域名称和此身份作用域中身份的数目。
toString() - 类 java.security.KeyStore.PrivateKeyEntry 中的方法
返回此 PrivateKeyEntry 的字符串表示形式。
toString() - 类 java.security.KeyStore.SecretKeyEntry 中的方法
返回此 SecretKeyEntry 的字符串表示形式。
toString() - 类 java.security.KeyStore.TrustedCertificateEntry 中的方法
返回此 TrustedCertificateEntry 的字符串表示形式。
toString() - 类 java.security.MessageDigest 中的方法
返回此信息摘要对象的字符串表示形式。
toString() - 类 java.security.Permission 中的方法
返回描述此 Permission 的字符串。
toString() - 类 java.security.PermissionCollection 中的方法
返回描述此 PermissionCollection 对象的字符串，提供该对象中包含的关于所有权限的信息。
toString() - 接口 java.security.Principal 中的方法
返回此主体的字符串表示形式。
toString() - 异常 java.security.PrivilegedActionException 中的方法
toString() - 类 java.security.ProtectionDomain 中的方法
将 ProtectionDomain 转换成为 String。
toString() - 类 java.security.Provider.Service 中的方法
返回此服务的字符串表示形式。
toString() - 类 java.security.Provider 中的方法
返回具有此 provider 名称和版本号的字符串。
toString() - 类 java.security.Signature 中的方法
返回此签名对象的字符串表示形式，以提供包括对象状态和所用算法名称在内的信息。
toString() - 类 java.security.Signer 中的方法
已过时。 返回有关该 signer 信息的字符串。
toString() - 类 java.security.Timestamp 中的方法
返回描述此时间戳的字符串。
toString() - 类 java.security.UnresolvedPermission 中的方法
返回描述此 UnresolvedPermission 的字符串。
toString() - 类 java.sql.Date 中的方法
格式化日期转义形式 yyyy-mm-dd 的日期。
toString() - 接口 java.sql.RowId 中的方法
返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 String。
toString() - 类 java.sql.Time 中的方法
使用 JDBC 时间转义格式对时间进行格式化。
toString() - 类 java.sql.Timestamp 中的方法
使用 JDBC 时间戳转义格式编排时间戳。
toString() - 类 java.text.Annotation 中的方法
返回此 Annotation 的 String 表示形式。
toString() - 类 java.text.AttributedCharacterIterator.Attribute 中的方法
返回该对象的字符串表示形式。
toString() - 类 java.text.Bidi 中的方法
用于调试时显示双向算法的内部状态。
toString() - 类 java.text.FieldPosition 中的方法
返回此 FieldPosition 的字符串表示形式。
toString() - 类 java.text.ParsePosition 中的方法
返回此 ParsePosition 的字符串表示形式。
toString() - 类 java.util.AbstractCollection 中的方法
返回此 collection 的字符串表示形式。
toString() - 类 java.util.AbstractMap.SimpleEntry 中的方法
返回此映射项的 String 表示形式。
toString() - 类 java.util.AbstractMap.SimpleImmutableEntry 中的方法
返回此映射项的 String 表示形式。
toString() - 类 java.util.AbstractMap 中的方法
返回此映射的字符串表示形式。
toString(long[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(int[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(short[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(char[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(byte[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(boolean[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(float[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(double[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString(Object[]) - 类 java.util.Arrays 中的静态方法
返回指定数组内容的字符串表示形式。
toString() - 类 java.util.BitSet 中的方法
返回此位 set 的字符串表示形式。
toString() - 类 java.util.Calendar 中的方法
返回此日历的字符串表示形式。
toString() - 类 java.util.concurrent.ArrayBlockingQueue 中的方法
toString() - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
返回当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
返回当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
返回数组当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicLong 中的方法
返回当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
返回数组当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicReference 中的方法
返回当前值的字符串表示形式。
toString() - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
返回数组当前值的字符串表示形式。
toString() - 类 java.util.concurrent.CopyOnWriteArrayList 中的方法
返回此列表的字符串表示形式。
toString() - 类 java.util.concurrent.CountDownLatch 中的方法
返回标识此锁存器及其状态的字符串。
toString() - 类 java.util.concurrent.LinkedBlockingDeque 中的方法
toString() - 类 java.util.concurrent.LinkedBlockingQueue 中的方法
toString() - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
返回标识此同步器及其状态的字符串。
toString() - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
返回标识此同步器及其状态的字符串。
toString() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
返回标识此锁及其锁定状态的字符串。
toString() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
返回标识此锁及其锁状态的字符串。
toString() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
返回标识此锁及其锁状态的字符串。
toString() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
返回标识此锁及其锁状态的字符串。
toString() - 类 java.util.concurrent.PriorityBlockingQueue 中的方法
toString() - 类 java.util.concurrent.Semaphore 中的方法
返回标识此信号量的字符串，以及信号量的状态。
toString() - 类 java.util.Currency 中的方法
返回此货币的 ISO 4217 货币代码。
toString() - 类 java.util.Date 中的方法
把此 Date 对象转换为以下形式的 String： dow mon dd hh:mm:ss zzz yyyy 其中： dow 是一周中的某一天 (Sun, Mon, Tue, Wed, Thu, Fri, Sat)。
toString() - 类 java.util.EventObject 中的方法
返回此 EventObject 的 String 表示形式。
toString() - 类 java.util.Formatter 中的方法
返回对输出的目标文件调用 toString() 的结果。
toString() - 类 java.util.Hashtable 中的方法
返回此 Hashtable 对象的字符串表示形式，其形式为 ASCII 字符 ", " （逗号加空格）分隔开的、括在括号中的一组条目。
toString() - 类 java.util.jar.Attributes.Name 中的方法
返回字符串形式的属性名称。
toString() - 类 java.util.Locale 中的方法
使用由下划线分隔的语言、国家/地区和变量来获取整个语言环境的编程名称。
toString() - 类 java.util.logging.Level 中的方法
toString() - 类 java.util.prefs.AbstractPreferences 中的方法
返回此首选项节点的绝对路径名称。
toString() - 类 java.util.prefs.Preferences 中的方法
返回此首选项节点的字符串表示形式，与通过表达式：(this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 计算的结果一样。
toString() - 类 java.util.regex.Matcher 中的方法
返回匹配器的字符串表示形式。
toString() - 类 java.util.regex.Pattern 中的方法
返回此模式的字符串表示形式。
toString() - 类 java.util.Scanner 中的方法
返回此 Scanner 的字符串表示形式。
toString() - 类 java.util.ServiceLoader 中的方法
返回一个描述此服务的字符串。
toString() - 类 java.util.SimpleTimeZone 中的方法
返回此时区的字符串表示形式。
toString() - 类 java.util.UUID 中的方法
返回表示此 UUID 的 String 对象。
toString() - 类 java.util.Vector 中的方法
返回此向量的字符串表示形式，其中包含每个元素的 String 表示形式。
toString() - 类 java.util.zip.ZipEntry 中的方法
返回 ZIP 条目的字符串表示形式。
toString() - 类 javax.accessibility.AccessibleBundle 中的方法
获取使用默认语言环境来描述键的本地化字符串。
toString() - 类 javax.accessibility.AccessibleRelationSet 中的方法
使用默认语言环境创建表示关系集中所有关系的本地化 String。
toString() - 类 javax.accessibility.AccessibleStateSet 中的方法
使用默认语言环境创建表示状态集中所有状态的本地化 String。
toString() - 类 javax.activation.MimeType 中的方法
返回此对象的 String 表示形式。
toString() - 类 javax.activation.MimeTypeParameterList 中的方法
返回此对象的字符串表示形式。
toString() - 类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 中的方法
toString() - 类 javax.imageio.plugins.jpeg.JPEGQTable 中的方法
toString() - 接口 javax.lang.model.element.AnnotationValue 中的方法
返回此值的字符串表示形式。
toString() - 枚举 javax.lang.model.element.Modifier 中的方法
返回此修饰符的小写名称。
toString() - 接口 javax.lang.model.type.TypeMirror 中的方法
返回包含此类型许多信息的字符串表示形式。
toString() - 类 javax.management.Attribute 中的方法
返回一个表示此 Attribute 值 String 对象。
toString() - 类 javax.management.AttributeValueExp 中的方法
返回表示其值的字符串。
toString() - 异常 javax.management.BadAttributeValueExpException 中的方法
返回该对象的字符串表示形式。
toString() - 异常 javax.management.BadBinaryOpValueExpException 中的方法
返回该对象的字符串表示形式。
toString() - 异常 javax.management.BadStringOperationException 中的方法
返回该对象的字符串表示形式。
toString() - 类 javax.management.ImmutableDescriptor 中的方法
toString() - 类 javax.management.MBeanAttributeInfo 中的方法
toString() - 类 javax.management.MBeanConstructorInfo 中的方法
toString() - 类 javax.management.MBeanInfo 中的方法
toString() - 类 javax.management.MBeanNotificationInfo 中的方法
toString() - 类 javax.management.MBeanOperationInfo 中的方法
toString() - 类 javax.management.MBeanParameterInfo 中的方法
toString() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
返回表示描述符的可读字符串。
toString() - 类 javax.management.modelmbean.ModelMBeanAttributeInfo 中的方法
返回 ModelMBeanAttributeInfo 实例的可读版本。
toString() - 类 javax.management.modelmbean.ModelMBeanConstructorInfo 中的方法
以可读形式返回包含 ModelMBeanConstructorInfo 全部内容的字符串。
toString() - 类 javax.management.modelmbean.ModelMBeanNotificationInfo 中的方法
返回包含 ModelMBeanNotificationInfo 的可读字符串。
toString() - 类 javax.management.modelmbean.ModelMBeanOperationInfo 中的方法
以可读形式返回包含 ModelMBeanOperationInfo 全部内容的字符串。
toString() - 类 javax.management.Notification 中的方法
返回此通知的字符串表示形式。
toString() - 类 javax.management.ObjectInstance 中的方法
返回表示此 ObjectInstance 对象字符串。
toString() - 类 javax.management.ObjectName 中的方法
返回该对象名的字符串表示形式。
toString() - 类 javax.management.openmbean.ArrayType 中的方法
返回此 ArrayType 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.CompositeData 中的方法
返回此 CompositeData 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回此 CompositeDataSupport 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.CompositeType 中的方法
返回此 CompositeType 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanAttributeInfo 中的方法
返回此 OpenMBeanAttributeInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 中的方法
返回此 OpenMBeanAttributeInfoSupport 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanConstructorInfo 中的方法
返回此 OpenMBeanConstructorInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 中的方法
返回此 OpenMBeanConstructorInfoSupport 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanInfo 中的方法
返回此 OpenMBeanInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanInfoSupport 中的方法
返回此 OpenMBeanInfoSupport 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanOperationInfo 中的方法
返回此 OpenMBeanOperationInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanOperationInfoSupport 中的方法
返回此 OpenMBeanOperationInfoSupport 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.OpenMBeanParameterInfo 中的方法
返回此 OpenMBeanParameterInfo 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenMBeanParameterInfoSupport 中的方法
返回此 OpenMBeanParameterInfoSupport 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.OpenType 中的方法
返回此开放类型实例的字符串表示形式。
toString() - 类 javax.management.openmbean.SimpleType 中的方法
返回此 SimpleType 实例的字符串表示形式。
toString() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回此 TabularDataSupport 实例的字符串表示形式。
toString() - 类 javax.management.openmbean.TabularType 中的方法
返回此 TabularType 实例的字符串表示形式。
toString() - 类 javax.management.relation.Role 中的方法
返回描述角色的字符串。
toString() - 类 javax.management.relation.RoleInfo 中的方法
返回描述角色信息的字符串。
toString() - 类 javax.management.relation.RoleUnresolved 中的方法
返回描述此对象的字符串。
toString() - 类 javax.management.remote.JMXPrincipal 中的方法
返回此 JMXPrincipal 的字符串表示形式。
toString() - 类 javax.management.remote.JMXServiceURL 中的方法
此 Service URL 的字符串表示形式。
toString() - 类 javax.management.remote.NotificationResult 中的方法
返回该对象的字符串表示形式。
toString() - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
返回此对象的字符串表示形式。
toString() - 类 javax.management.remote.rmi.RMIConnector 中的方法
返回此对象的字符串表示形式。
toString() - 类 javax.management.remote.TargetedNotification 中的方法
返回此定向通知的一个文本表示形式。
toString() - 类 javax.management.StringValueExp 中的方法
返回表示对象的字符串。
toString() - 类 javax.naming.BinaryRefAddr 中的方法
生成此地址的字符串表示形式。
toString() - 类 javax.naming.Binding 中的方法
生成此绑定的字符串表示形式。
toString() - 类 javax.naming.CompositeName 中的方法
生成此复合名称的字符串表示形式。
toString() - 类 javax.naming.CompoundName 中的方法
使用组合名称的语法规则生成此组合名称的字符串表示形式。
toString() - 异常 javax.naming.directory.AttributeModificationException 中的方法
此异常的字符串表示形式由关于发生错误的位置信息和第一个未执行的修改组成。
toString() - 类 javax.naming.directory.BasicAttribute 中的方法
生成此属性的字符串表示形式。
toString() - 类 javax.naming.directory.BasicAttributes 中的方法
生成此属性集的字符串表示形式。
toString() - 类 javax.naming.directory.ModificationItem 中的方法
生成此修改项的字符串表示形式，该表示形式由修改操作及其相关属性组成。
toString() - 类 javax.naming.directory.SearchResult 中的方法
生成此 SearchResult 的字符串表示形式。
toString() - 类 javax.naming.ldap.LdapName 中的方法
返回一个此 LDAP 名称的字符串表示形式，该表示形式使用 RFC 2253 定义并在类描述中描述的格式。
toString() - 类 javax.naming.ldap.Rdn 中的方法
以字符串形式返回此 Rdn，该字符串使用由 RFC 2253 定义并在 LdapName 类描述中描述的格式表示。
toString() - 异常 javax.naming.LinkException 中的方法
生成此异常的字符串表示形式。
toString(boolean) - 异常 javax.naming.LinkException 中的方法
生成此异常的字符串表示形式。
toString() - 类 javax.naming.NameClassPair 中的方法
生成此名称/类对的字符串表示形式。
toString() - 异常 javax.naming.NamingException 中的方法
生成此异常的字符串表示形式。
toString(boolean) - 异常 javax.naming.NamingException 中的方法
生成更详细的字符串表示形式。
toString() - 类 javax.naming.RefAddr 中的方法
生成此地址的字符串表示形式。
toString() - 类 javax.naming.Reference 中的方法
生成此引用的字符串表示形式。
toString() - 类 javax.net.ssl.SSLEngineResult 中的方法
返回此对象的字符串表示形式。
toString() - 类 javax.print.attribute.DateTimeSyntax 中的方法
返回对应于此日期-时间属性的字符串值。
toString() - 类 javax.print.attribute.EnumSyntax 中的方法
返回对应于此枚举值的字符串值。
toString() - 类 javax.print.attribute.IntegerSyntax 中的方法
返回对应于此整数属性的字符串值。
toString(int, String) - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回给定单位的此分辨率属性的字符串版本。
toString() - 类 javax.print.attribute.ResolutionSyntax 中的方法
返回此分辨率属性的字符串版本。
toString() - 类 javax.print.attribute.SetOfIntegerSyntax 中的方法
返回对应于此整数集属性的字符串值。
toString(int, String) - 类 javax.print.attribute.Size2DSyntax 中的方法
返回给定单位的此二维大小属性的字符串版本。
toString() - 类 javax.print.attribute.Size2DSyntax 中的方法
返回此二维大小属性的字符串版本。
toString(int, String) - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以给定单位返回此矩形大小属性的字符串版本。
toString() - 类 javax.print.attribute.standard.MediaPrintableArea 中的方法
以 mm 为单位返回此矩形大小属性的字符串版本。
toString() - 类 javax.print.attribute.TextSyntax 中的方法
返回标识此文本属性的字符串。
toString() - 类 javax.print.attribute.URISyntax 中的方法
返回标识此 URI 属性的字符串。
toString() - 类 javax.print.DocFlavor 中的方法
将此 DocFlavor 转换为字符串。
toString() - 类 javax.print.event.PrintEvent 中的方法
toString() - 类 javax.rmi.CORBA.Stub 中的方法
返回此 stub 的字符串表示形式。
toString(Stub) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.toString() 的委托调用。
toString() - 类 javax.security.auth.kerberos.KerberosKey 中的方法
toString() - 类 javax.security.auth.kerberos.KerberosPrincipal 中的方法
toString() - 类 javax.security.auth.kerberos.KerberosTicket 中的方法
toString() - 类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 中的方法
返回此 controlFlag 的字符串表示形式。
toString() - 类 javax.security.auth.Subject 中的方法
返回此 Subject 的字符串表示形式。
toString() - 类 javax.security.auth.x500.X500Principal 中的方法
返回此 X500Principal 的用户友好的字符串表示形式。
toString() - 类 javax.security.cert.Certificate 中的方法
返回此证书的字符串表示形式。
toString() - 异常 javax.security.sasl.SaslException 中的方法
返回此异常的字符串表示形式。
toString() - 类 javax.sound.midi.MidiDevice.Info 中的方法
提供设备信息的字符串表示形式。
toString() - 类 javax.sound.midi.Sequencer.SyncMode 中的方法
以模式的字符串表示形式提供此同步模式的名称。
toString() - 类 javax.sound.sampled.AudioFileFormat 中的方法
提供文件格式的字符串表示形式。
toString() - 类 javax.sound.sampled.AudioFileFormat.Type 中的方法
按文件类型的 String 表示形式提供文件类型的名称。
toString() - 类 javax.sound.sampled.AudioFormat.Encoding 中的方法
提供编码的 String 表示形式。
toString() - 类 javax.sound.sampled.AudioFormat 中的方法
返回描述格式的字符串，如："PCM SIGNED 22050 Hz 16 bit mono big-endian"。
toString() - 类 javax.sound.sampled.BooleanControl 中的方法
提供控件的字符串表示形式
toString() - 类 javax.sound.sampled.CompoundControl 中的方法
提供控件的字符串表示形式
toString() - 类 javax.sound.sampled.Control 中的方法
获得描述控件类型及其当前状态的 String。
toString() - 类 javax.sound.sampled.Control.Type 中的方法
提供控件类型的 String 表示形式。
toString() - 类 javax.sound.sampled.DataLine.Info 中的方法
获得数据行信息的文本描述。
toString() - 类 javax.sound.sampled.EnumControl 中的方法
提供该控件的字符串表示形式。
toString() - 类 javax.sound.sampled.FloatControl 中的方法
提供控件的字符串表示形式
toString() - 类 javax.sound.sampled.Line.Info 中的方法
获得行信息的文本描述。
toString() - 类 javax.sound.sampled.LineEvent 中的方法
获得事件的字符串表示形式。
toString() - 类 javax.sound.sampled.LineEvent.Type 中的方法
以字符串形式返回类型名称。
toString() - 类 javax.sound.sampled.Mixer.Info 中的方法
提供混频器信息的字符串表示形式。
toString() - 类 javax.sound.sampled.Port.Info 中的方法
提供该端口的 String 表示形式。
toString() - 类 javax.sound.sampled.ReverbType 中的方法
提供回响类型的 String 表示形式，包括其名称和其参数设置。
toString() - 类 javax.swing.DefaultBoundedRangeModel 中的方法
返回显示所有 BoundedRangeModel 属性的字符串。
toString() - 类 javax.swing.DefaultListModel 中的方法
返回显示并标识此对象的属性的字符串。
toString() - 类 javax.swing.DefaultListSelectionModel 中的方法
返回显示并标识此对象的属性的字符串。
toString() - 类 javax.swing.event.DocumentEvent.EventType 中的方法
将类型转换成一个字符串。
toString() - 类 javax.swing.event.EventListenerList 中的方法
返回此 EventListenerList 的字符串表示形式。
toString() - 类 javax.swing.event.HyperlinkEvent.EventType 中的方法
将类型转换成一个字符串。
toString() - 类 javax.swing.event.ListDataEvent 中的方法
返回此 ListDataEvent 的字符串表示形式。
toString() - 类 javax.swing.event.ListSelectionEvent 中的方法
返回显示并标识此对象的属性的 String。
toString() - 类 javax.swing.event.TreeModelEvent 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.swing.filechooser.FileNameExtensionFilter 中的方法
返回 FileNameExtensionFilter 的字符串表示形式。
toString() - 类 javax.swing.GroupLayout 中的方法
返回此 GroupLayout 的字符串表示形式。
toString() - 类 javax.swing.ImageIcon 中的方法
返回此图像的字符串表示形式。
toString() - 类 javax.swing.JList.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.JTable.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.JTree.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.LookAndFeel 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.swing.plaf.synth.ColorType 中的方法
返回此 ColorType 的文本描述。
toString() - 类 javax.swing.plaf.synth.Region 中的方法
返回 Region 的名称。
toString() - 类 javax.swing.RepaintManager 中的方法
返回一个显示并标记此对象属性的字符串。
toString() - 类 javax.swing.SizeRequirements 中的方法
返回一个描述最小、首选和最大大小以及对齐方式要求的字符串。
toString(TableModel, int, int) - 类 javax.swing.table.TableStringConverter 中的方法
返回指定位置处值的字符串表示形式。
toString() - 类 javax.swing.text.AbstractDocument.BranchElement 中的方法
将该元素转换为字符串。
toString() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
返回更改事件的字符串表示形式。
toString() - 类 javax.swing.text.AbstractDocument.LeafElement 中的方法
将该元素转换为字符串。
toString() - 类 javax.swing.text.DefaultCaret 中的方法
toString() - 类 javax.swing.text.DefaultStyledDocument.ElementSpec 中的方法
将元素转换为字符串。
toString() - 类 javax.swing.text.html.CSS.Attribute 中的方法
属性的字符串表示形式。
toString() - 类 javax.swing.text.html.HTML.Attribute 中的方法
返回此属性的字符串表示形式。
toString() - 类 javax.swing.text.html.HTML.Tag 中的方法
返回该标记的字符串表示形式。
toString() - 类 javax.swing.text.html.Option 中的方法
String 的表示形式为 label。
toString() - 类 javax.swing.text.html.parser.AttributeList 中的方法
toString() - 类 javax.swing.text.html.parser.ContentModel 中的方法
转换为字符串。
toString() - 类 javax.swing.text.html.parser.DTD 中的方法
返回此 DTD 的字符串表示形式。
toString() - 类 javax.swing.text.html.parser.Element 中的方法
转换为字符串。
toString() - 类 javax.swing.text.JTextComponent.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.text.Position.Bias 中的方法
字符串表示形式
toString() - 类 javax.swing.text.Segment 中的方法
将 segment 转换为 String。
toString() - 类 javax.swing.text.SimpleAttributeSet 中的方法
将属性集转换为 String。
toString() - 类 javax.swing.text.StyleConstants 中的方法
返回字符串表示形式。
toString() - 类 javax.swing.text.StyleContext.NamedStyle 中的方法
将样式转换成为字符串。
toString() - 类 javax.swing.text.StyleContext.SmallAttributeSet 中的方法
返回表示键/值对的字符串
toString() - 类 javax.swing.text.StyleContext 中的方法
将 StyleContext 转换成为 String。
toString() - 类 javax.swing.text.TabSet 中的方法
返回此 tab 集合的字符串表示形式。
toString() - 类 javax.swing.text.TabStop 中的方法
toString() - 类 javax.swing.TransferHandler.DropLocation 中的方法
返回此放置位置的字符串表示形式。
toString() - 类 javax.swing.tree.DefaultMutableTreeNode 中的方法
返回将 toString() 发送到此节点的用户对象的结果，如果此节点没有用户对象，则返回 null。
toString() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
返回显示并标识此对象属性的字符串。
toString() - 类 javax.swing.tree.TreePath 中的方法
返回一个显示并标识此对象属性的字符串。
toString() - 类 javax.swing.UIManager.LookAndFeelInfo 中的方法
返回一个显示并标识此对象属性的字符串。
toString() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.swing.undo.CompoundEdit 中的方法
返回一个显示并标识此对象属性的字符串。
toString() - 类 javax.swing.undo.UndoableEditSupport 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.swing.undo.UndoManager 中的方法
返回显示和标识此对象属性的字符串。
toString() - 类 javax.tools.SimpleJavaFileObject 中的方法
toString() - 类 javax.xml.bind.helpers.ValidationEventImpl 中的方法
以有助于调试的格式返回此对象的字符串表示形式。
toString() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 中的方法
以有助于调试的格式返回此对象的字符串表示形式。
toString() - 异常 javax.xml.bind.JAXBException 中的方法
返回此 JAXBException 的简短描述。
toString() - 异常 javax.xml.bind.TypeConstraintException 中的方法
返回此 TypeConstraintException 的简短描述。
toString() - 类 javax.xml.crypto.dsig.spec.XPathType.Filter 中的方法
返回操作的字符串形式。
toString() - 类 javax.xml.crypto.KeySelector.Purpose 中的方法
返回此用途的字符串表示形式（“sign”、“verify”、“encrypt”或“decrypt”）。
toString() - 类 javax.xml.datatype.DatatypeConstants.Field 中的方法
以英文返回字段名称。
toString() - 类 javax.xml.datatype.Duration 中的方法
返回此 Duration Object 的 String 表示形式。
toString() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回此 XMLGregorianCalendar Object 的 String 表示形式。
toString() - 类 javax.xml.namespace.QName 中的方法
此 QName 的 String 表示形式。
toString() - 异常 org.ietf.jgss.GSSException 中的方法
返回主要和次要状态码的文本表示形式。
toString() - 接口 org.ietf.jgss.GSSName 中的方法
返回 GSSName 对象的文本表示形式。
toString() - 类 org.ietf.jgss.Oid 中的方法
返回 oid 用句点符号分隔的整数组件的字符串表示形式。
toString(Object) - 类 org.omg.CORBA.portable.Delegate 中的方法
提供重写委托 CORBA 对象的 toString() 方法的实现。
toString() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回表示此 ObjectImpl 对象的 String 对象。
toString() - 异常 org.omg.CORBA.SystemException 中的方法
将此异常转换成有代表性的字符串。
toString() - 异常 org.xml.sax.SAXException 中的方法
重写 toString 以获取任何嵌入的异常。
toStub(Remote) - 类 java.rmi.server.RemoteObject 中的静态方法
返回作为参数传递的远程对象 obj 的 stub。
toStub() - 类 javax.management.remote.rmi.RMIIIOPServerImpl 中的方法
返回一个 IIOP stub。
toStub() - 类 javax.management.remote.rmi.RMIJRMPServerImpl 中的方法
返回此 RMIServer 对象的可序列化的 stub。
toStub() - 类 javax.management.remote.rmi.RMIServerImpl 中的方法
返回此服务器对象的可远程化的 stub。
toStub(Remote) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。
toStub(Remote) - 类 javax.rmi.PortableRemoteObject 中的静态方法
返回给定服务器对象的 stub。
totalChildIndent - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
将缩进的总距离。
totalColumnWidth - 类 javax.swing.table.DefaultTableColumnModel 中的变量
所有列总宽度的本地缓存
totalMemory() - 类 java.lang.Runtime 中的方法
返回 Java 虚拟机中的内存总量。
toTitleCase(char) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为首字母大写。
toTitleCase(int) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为首字母大写。
TOTOP_TOLEFT - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从右下部开始，按列布置各页，然后向左上部展开。
TOTOP_TORIGHT - 类 javax.print.attribute.standard.PresentationDirection 中的静态变量
从左下部开始，按列布置各页，然后向右上部展开。
toUnicode(String, int) - 类 java.net.IDN 中的静态方法
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 (ACE) 转换为 Unicode。
toUnicode(String) - 类 java.net.IDN 中的静态方法
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 ACE) 转换为 Unicode。
toUpperCase(char) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为大写。
toUpperCase(int) - 类 java.lang.Character 中的静态方法
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为大写。
toUpperCase(Locale) - 类 java.lang.String 中的方法
使用给定 Locale 的规则将此 String 中的所有字符都转换为大写。
toUpperCase() - 类 java.lang.String 中的方法
使用默认语言环境的规则将此 String 中的所有字符都转换为大写。
toURI() - 类 java.io.File 中的方法
构造一个表示此抽象路径名的 file: URI。
toURI() - 类 java.net.URL 中的方法
返回与此 URL 等效的 URI。
toUri() - 接口 javax.tools.FileObject 中的方法
返回标识此文件对象的 URI。
toUri() - 类 javax.tools.ForwardingFileObject 中的方法
toUri() - 类 javax.tools.SimpleJavaFileObject 中的方法
toURL() - 类 java.io.File 中的方法
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。
toURL() - 类 java.net.URI 中的方法
根据此 URI 构造一个 URL。
toViewCoordinates(Dimension) - 类 javax.swing.JViewport 中的方法
将一个大小的像素坐标转换为视图坐标。
toViewCoordinates(Point) - 类 javax.swing.JViewport 中的方法
将一个点的像素坐标转换为视图坐标。
toXMLFormat() - 类 javax.xml.datatype.XMLGregorianCalendar 中的方法
返回 this 实例的词汇表示形式。
toXMLString() - 类 javax.management.modelmbean.DescriptorSupport 中的方法
返回表示描述符的 XML 字符串。
TR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
traceInstructions(boolean) - 类 java.lang.Runtime 中的方法
启用／禁用指令跟踪。
traceMethodCalls(boolean) - 类 java.lang.Runtime 中的方法
启用／禁用方法调用跟踪。
TRACK - 类 java.awt.event.AdjustmentEvent 中的静态变量
绝对跟踪调整类型。
Track - javax.sound.midi 中的 类
MIDI 音轨是一个可随其他音轨存储在标准 MIDI 文件中的独立的 MIDI 事件流（带时间戳的 MIDI 数据）。
trackBuffer - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
trackColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
tracker - 类 javax.swing.ImageIcon 中的静态变量
trackHighlight - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
trackHighlightColor - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
TRACKING - 类 java.awt.font.TextAttribute 中的静态变量
控制跟踪的属性键。
TRACKING_LOOSE - 类 java.awt.font.TextAttribute 中的静态变量
执行宽松跟踪。
TRACKING_TIGHT - 类 java.awt.font.TextAttribute 中的静态变量
执行紧密跟踪。
trackListener - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
trackListener - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
trackRect - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的变量
trackRect - 类 javax.swing.plaf.basic.BasicSliderUI 中的变量
tracks - 类 javax.sound.midi.Sequence 中的变量
此 sequence 中的 MIDI 轨道。
trackWidth - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
TRADITIONAL_CHINESE - 类 java.util.Locale 中的静态变量
用于表示语言的有用常量。
TRADITIONAL_HANZI - 类 java.awt.im.InputSubset 中的静态变量
编写繁体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的繁体中文汉字字集。
TRAILING - 类 java.awt.FlowLayout 中的静态变量
此值指示每行组件都应该与容器方向的结束边对齐，例如，对于从左到右的方向，则与右边对齐。
trailing(int) - 类 java.awt.font.TextHitInfo 中的静态方法
在指定 charIndex 处的字符的结尾边上创建一个 TextHitInfo。
TRAILING - 类 javax.swing.border.TitledBorder 中的静态变量
从左到右排列时将标题文本置于边框线的右边，从右到左排列时将标题文本置于边框线的左边。
TRAILING - 接口 javax.swing.SwingConstants 中的静态变量
标识使用从左到右和从右到左的语言的文本结束边。
TRANSACTION_MODE - org.omg.CORBA 中的 异常
如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
TRANSACTION_MODE() - 异常 org.omg.CORBA.TRANSACTION_MODE 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(String) - 异常 org.omg.CORBA.TRANSACTION_MODE 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_MODE 的构造方法
使用指定次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_MODE(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_MODE 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_MODE 异常。
TRANSACTION_NONE - 接口 java.sql.Connection 中的静态变量
指示事务不受支持的常量。
TRANSACTION_READ_COMMITTED - 接口 java.sql.Connection 中的静态变量
指示不可以发生脏读的常量；不可重复读和虚读可以发生。
TRANSACTION_READ_UNCOMMITTED - 接口 java.sql.Connection 中的静态变量
指示可以发生脏读 (dirty read)、不可重复读和虚读 (phantom read) 的常量。
TRANSACTION_REPEATABLE_READ - 接口 java.sql.Connection 中的静态变量
指示不可以发生脏读和不可重复读的常量；虚读可以发生。
TRANSACTION_REQUIRED - org.omg.CORBA 中的 异常
此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
TRANSACTION_REQUIRED() - 异常 org.omg.CORBA.TRANSACTION_REQUIRED 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(String) - 异常 org.omg.CORBA.TRANSACTION_REQUIRED 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_REQUIRED 的构造方法
使用指定次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_REQUIRED(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_REQUIRED 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。
TRANSACTION_ROLLEDBACK - org.omg.CORBA 中的 异常
当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
TRANSACTION_ROLLEDBACK() - 异常 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(String) - 异常 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的构造方法
使用指定次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_ROLLEDBACK(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_ROLLEDBACK 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。
TRANSACTION_SERIALIZABLE - 接口 java.sql.Connection 中的静态变量
指示不可以发生脏读、不可重复读和虚读的常量。
TRANSACTION_UNAVAILABLE - org.omg.CORBA 中的 异常
当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE() - 异常 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(String) - 异常 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的构造方法
使用指定次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TRANSACTION_UNAVAILABLE(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSACTION_UNAVAILABLE 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。
TransactionalWriter - javax.sql.rowset.spi 中的 接口
一个专用接口，用来方便地扩展标准 SyncProvider 抽象类以便拥有细粒度的事务控制。
TransactionRequiredException - javax.transaction 中的 异常
此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
TransactionRequiredException() - 异常 javax.transaction.TransactionRequiredException 的构造方法
TransactionRequiredException(String) - 异常 javax.transaction.TransactionRequiredException 的构造方法
TransactionRolledbackException - javax.transaction 中的 异常
此异常指示与请求处理关联的事务已回滚，或已标记为回滚。
TransactionRolledbackException() - 异常 javax.transaction.TransactionRolledbackException 的构造方法
TransactionRolledbackException(String) - 异常 javax.transaction.TransactionRolledbackException 的构造方法
TransactionService - org.omg.IOP 中的 接口
org/omg/IOP/TransactionService.java。
Transferable - java.awt.datatransfer 中的 接口
定义为传输操作提供数据所使用的类的接口。
transferable - 类 java.awt.dnd.DropTargetContext.TransferableProxy 中的变量
封装的 Transferable 对象。
transferablesFlavorsChanged() - 类 java.awt.dnd.DragSourceContext 中的方法
通知同位体该 Transferable 的 DataFlavor 已改变。
transferFocus() - 类 java.awt.Component 中的方法
将焦点转移到下一个组件，就好像此 Component 曾是焦点所有者。
transferFocusBackward() - 类 java.awt.Component 中的方法
将焦点转移到前一个组件，就好像此 Component 曾是焦点所有者。
transferFocusBackward() - 类 java.awt.Container 中的方法
transferFocusDownCycle() - 类 java.awt.Container 中的方法
将焦点向下传输一个焦点遍历循环。
transferFocusUpCycle() - 类 java.awt.Component 中的方法
将焦点向上转移一个焦点遍历循环。
transferFrom(ReadableByteChannel, long, long) - 类 java.nio.channels.FileChannel 中的方法
将字节从给定的可读取字节通道传输到此通道的文件中。
TransferHandler - javax.swing 中的 类
此类用于处理往返于 Swing 组件的 Transferable 的传输。
TransferHandler(String) - 类 javax.swing.TransferHandler 的构造方法
构造一个通过剪贴板或拖放操作可以将 Java Bean 属性从一个组件传输到另一个组件的传输处理程序。
TransferHandler() - 类 javax.swing.TransferHandler 的构造方法
子类的便捷构造方法。
TransferHandler.DropLocation - javax.swing 中的 类
表示放置的数据 (dropped data) 应该插入的位置。
TransferHandler.DropLocation(Point) - 类 javax.swing.TransferHandler.DropLocation 的构造方法
构造给定点的放置位置。
TransferHandler.TransferSupport - javax.swing 中的 类
此类封装剪贴板或拖放传输的所有相关详细信息，并且还允许自定义拖放过程的各方面。
TransferHandler.TransferSupport(Component, Transferable) - 类 javax.swing.TransferHandler.TransferSupport 的构造方法
使用给定组件和 Transferable 创建一个 TransferSupport，对于该 TransferSupport isDrop() 返回 false。
transferTo(long, long, WritableByteChannel) - 类 java.nio.channels.FileChannel 中的方法
将字节从此通道的文件传输到给定的可写入字节通道。
transferType - 类 java.awt.image.ColorModel 中的变量
用于表示像素值的数组的数据类型。
TRANSFORM - 类 java.awt.font.TextAttribute 中的静态变量
字体转换的属性键。
transform(Point2D, Point2D) - 类 java.awt.geom.AffineTransform 中的方法
变换指定的 ptSrc 并将结果存储在 ptDst 中。
transform(Point2D[], int, Point2D[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换点对象数组。
transform(float[], int, float[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换浮点坐标数组。
transform(double[], int, double[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换双精度坐标数组。
transform(float[], int, double[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换浮点坐标数组，并将结果存储在 double 数组中。
transform(double[], int, float[], int, int) - 类 java.awt.geom.AffineTransform 中的方法
通过此变换来变换双精度坐标数组，并将结果存储在 float 数组中。
transform(AffineTransform) - 类 java.awt.geom.Area 中的方法
使用指定的 AffineTransform 变换此 Area 的几何形状。
transform(AffineTransform) - 类 java.awt.geom.Path2D.Double 中的方法
使用指定的 AffineTransform 变换此路径的几何形状。
transform(AffineTransform) - 类 java.awt.geom.Path2D.Float 中的方法
使用指定的 AffineTransform 变换此路径的几何形状。
transform(AffineTransform) - 类 java.awt.geom.Path2D 中的方法
使用指定的 AffineTransform 变换此路径的几何形状。
transform(AffineTransform) - 类 java.awt.Graphics2D 中的方法
根据“最后指定首先应用”规则，使用此 Graphics2D 中的 Transform 组合 AffineTransform 对象。
transform(ClassLoader, String, Class<?>, ProtectionDomain, byte[]) - 接口 java.lang.instrument.ClassFileTransformer 中的方法
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。
Transform - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Transform 元素的表示形式。
transform(Data, XMLCryptoContext) - 接口 javax.xml.crypto.dsig.Transform 中的方法
使用底层转换算法对指定数据进行转换。
transform(Data, XMLCryptoContext, OutputStream) - 接口 javax.xml.crypto.dsig.Transform 中的方法
使用底层转换算法对指定数据进行转换。
transform(Source, Result) - 类 javax.xml.transform.Transformer 中的方法
将 XML Source 转换为 Result。
TransformAttribute - java.awt.font 中的 类
TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。
TransformAttribute(AffineTransform) - 类 java.awt.font.TransformAttribute 的构造方法
包装指定的转换。
Transformer - javax.xml.transform 中的 类
此抽象类的实例能够将源树转换为结果树。
Transformer() - 类 javax.xml.transform.Transformer 的构造方法
默认构造方法受到有意保护。
TransformerConfigurationException - javax.xml.transform 中的 异常
指示严重的配置错误。
TransformerConfigurationException() - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
创建不带详细消息的新 TransformerConfigurationException。
TransformerConfigurationException(String) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
创建带有指定为错误消息的 String 的新 TransformerConfigurationException。
TransformerConfigurationException(Throwable) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
创建带有错误的给定 Exception 基本原因的新 TransformerConfigurationException。
TransformerConfigurationException(String, Throwable) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
创建带有给定 Exception 基本原因和详细消息的新 TransformerConfigurationException。
TransformerConfigurationException(String, SourceLocator) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
从消息和 Locator 创建新 TransformerConfigurationException。
TransformerConfigurationException(String, SourceLocator, Throwable) - 异常 javax.xml.transform.TransformerConfigurationException 的构造方法
包装了 TransformerConfigurationException 中的现有异常。
TransformerException - javax.xml.transform 中的 异常
此类指定了转换过程中发生的异常条件。
TransformerException(String) - 异常 javax.xml.transform.TransformerException 的构造方法
创建一个新的 TransformerException。
TransformerException(Throwable) - 异常 javax.xml.transform.TransformerException 的构造方法
创建一个包装了现有异常的新 TransformerException。
TransformerException(String, Throwable) - 异常 javax.xml.transform.TransformerException 的构造方法
包装 TransformerException 中的一个现有异常。
TransformerException(String, SourceLocator) - 异常 javax.xml.transform.TransformerException 的构造方法
从消息和 Locator 创建一个新 TransformerException。
TransformerException(String, SourceLocator, Throwable) - 异常 javax.xml.transform.TransformerException 的构造方法
包装了 TransformerException 中的现有异常。
TransformerFactory - javax.xml.transform 中的 类
TransformerFactory 实例可用于创建 Transformer 和 Templates 对象。
TransformerFactory() - 类 javax.xml.transform.TransformerFactory 的构造方法
默认构造方法受到有意保护。
TransformerFactoryConfigurationError - javax.xml.transform 中的 错误
当通过 Transformer Factories 进行的配置存在问题时抛出此异常。
TransformerFactoryConfigurationError() - 错误 javax.xml.transform.TransformerFactoryConfigurationError 的构造方法
创建不带详细消息的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(String) - 错误 javax.xml.transform.TransformerFactoryConfigurationError 的构造方法
创建带有指定为错误消息的 String 的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(Exception) - 错误 javax.xml.transform.TransformerFactoryConfigurationError 的构造方法
创建带有错误的给定 Exception 基本原因的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(Exception, String) - 错误 javax.xml.transform.TransformerFactoryConfigurationError 的构造方法
创建带有给定 Exception 基本原因和详细消息的新 TransformerFactoryConfigurationError。
TransformerHandler - javax.xml.transform.sax 中的 接口
侦听 SAX ContentHandler 解析事件，并将它们转换为 Result 的 TransformerHandler。
TransformException - javax.xml.crypto.dsig 中的 异常
指示执行转换算法时出现异常的异常条件。
TransformException() - 异常 javax.xml.crypto.dsig.TransformException 的构造方法
构造用 null 作为其详细消息的新 TransformException。
TransformException(String) - 异常 javax.xml.crypto.dsig.TransformException 的构造方法
构造带有指定详细消息的新 TransformException。
TransformException(String, Throwable) - 异常 javax.xml.crypto.dsig.TransformException 的构造方法
构造带指定详细消息和 cause 的新 TransformException。
TransformException(Throwable) - 异常 javax.xml.crypto.dsig.TransformException 的构造方法
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 TransformException（它通常包含 cause 的类和详细消息）。
TransformParameterSpec - javax.xml.crypto.dsig.spec 中的 接口
用于 Transform 算法的算法参数规范。
TransformService - javax.xml.crypto.dsig 中的 类
转换算法和规范算法的服务提供者接口。
TransformService() - 类 javax.xml.crypto.dsig.TransformService 的构造方法
默认的构造方法，由子类调用。
TRANSIENT - 类 java.lang.reflect.Modifier 中的静态变量
表示 transient 修饰符的 int 的值。
TRANSIENT - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是临时的。
TRANSIENT - org.omg.CORBA 中的 异常
当 ORB 试图到达某一对象但失败时，抛出此异常。
TRANSIENT() - 异常 org.omg.CORBA.TRANSIENT 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 TRANSIENT 异常。
TRANSIENT(String) - 异常 org.omg.CORBA.TRANSIENT 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSIENT 异常。
TRANSIENT(int, CompletionStatus) - 异常 org.omg.CORBA.TRANSIENT 的构造方法
使用指定次要代码和完成状态构造一个 TRANSIENT 异常。
TRANSIENT(String, int, CompletionStatus) - 异常 org.omg.CORBA.TRANSIENT 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 TRANSIENT 异常。
TRANSIENT - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态变量
translate(int, int) - 类 java.awt.Event 中的方法
注：Event 类已废弃，只可用于向后兼容。
translate(double, double) - 类 java.awt.geom.AffineTransform 中的方法
连接此变换与平移变换。
translate(int, int) - 类 java.awt.Graphics 中的方法
将图形上下文的原点平移到当前坐标系中的点 (x, y)。
translate(int, int) - 类 java.awt.Graphics2D 中的方法
将 Graphics2D 上下文的原点平移到当前坐标系中的点 (x, y)。
translate(double, double) - 类 java.awt.Graphics2D 中的方法
将当前 Graphics2D Transform 与平移转换连接。
translate(int, int) - 类 java.awt.Point 中的方法
平移 (x,y) 位置的点，沿 x 轴平移 dx，沿 y 轴平移 dy，移动后得到点 (x+dx,y+dy)。
translate(int, int) - 类 java.awt.Polygon 中的方法
对 Polygon 的顶点进行平移，沿 x 轴移动 deltaX，沿 y 移动 deltaY。
translate(int, int) - 类 java.awt.Rectangle 中的方法
将此 Rectangle 沿 X 坐标轴向右，沿 Y 坐标轴向下平移指定距离。
translate(int, int) - 类 javax.swing.DebugGraphics 中的方法
重写 Graphics.translate。
translateHTMLToCSS(AttributeSet) - 类 javax.swing.text.html.StyleSheet 中的方法
将 HTML 属性集合转换为对等的 CSS 属性集合。
translateKey(Key) - 类 java.security.KeyFactory 中的方法
将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。
translateKey(SecretKey) - 类 javax.crypto.SecretKeyFactory 中的方法
将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。
translatePoint(int, int) - 类 java.awt.event.MouseEvent 中的方法
通过将事件坐标加上指定的 x（水平）和 y（垂直）偏移量，将事件的坐标平移到新位置。
TRANSLUCENT - 接口 java.awt.Transparency 中的静态变量
表示包含或可能包含位于 0.0 和 1.0（含两者）之间的任意 alpha 值的图像数据。
Transmitter - javax.sound.midi 中的 接口
一个 Transmitter，其将 MidiEvent 对象发送至一个或多个 Receivers。
transparency - 类 java.awt.image.VolatileImage 中的变量
创建此图像所使用的透明度值。
Transparency - java.awt 中的 接口
Transparency 接口定义用于实现类的通用透明模式。
TRANSPORT_RETRY - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/TRANSPORT_RETRY.java。
TrayIcon - java.awt 中的 类
TrayIcon 对象表示可以添加到系统托盘的托盘图标。
TrayIcon(Image) - 类 java.awt.TrayIcon 的构造方法
创建带有指定图像的 TrayIcon。
TrayIcon(Image, String) - 类 java.awt.TrayIcon 的构造方法
创建带有指定图像和工具提示文本的 TrayIcon。
TrayIcon(Image, String, PopupMenu) - 类 java.awt.TrayIcon 的构造方法
创建带指定图像、工具提示和弹出菜单的 TrayIcon。
TrayIcon.MessageType - java.awt 中的 枚举
MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。
TREE - 类 javax.accessibility.AccessibleRole 中的静态变量
用于将层次结构信息呈现给用户的对象。
tree - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
要在其中进行绘制的组件。
TREE - 类 javax.swing.plaf.synth.Region 中的静态变量
Tree 的 region。
tree - 类 javax.swing.tree.DefaultTreeCellEditor 中的变量
JTree 实例侦听。
TREE_CELL - 类 javax.swing.plaf.synth.Region 中的静态变量
用于某一单元格的 Tree 的 region。
TREE_MODEL_PROPERTY - 类 javax.swing.JTree 中的静态变量
treeModel 的绑定属性名称。
TreeCellEditor - javax.swing.tree 中的 接口
向 CellEditor 添加配置树中编辑器必需的扩展。
TreeCellRenderer - javax.swing.tree 中的 接口
定义针对显示树节点的对象的要求。
treeCollapsed(TreeExpansionEvent) - 接口 javax.swing.event.TreeExpansionListener 中的方法
每当树中的一个项被折叠时调用。
treeCollapsed(TreeExpansionEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树折叠通知。
treeCollapsed(TreeExpansionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 中的方法
每当树中的项被折叠时调用。
treeDidChange() - 类 javax.swing.JTree 中的方法
当树被更改得足以需要调整边界大小，但还不足以需要移除展开的节点集（例如，展开或折叠节点，或者将节点插入到树）时发送。
treeExpanded(TreeExpansionEvent) - 接口 javax.swing.event.TreeExpansionListener 中的方法
每当树中的一个项被扩展时调用。
treeExpanded(TreeExpansionEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型展开通知。
treeExpanded(TreeExpansionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler 中的方法
每当树中的项被展开时调用。
TreeExpansionEvent - javax.swing.event 中的 类
用于标识树中的单个路径的事件。
TreeExpansionEvent(Object, TreePath) - 类 javax.swing.event.TreeExpansionEvent 的构造方法
构造一个 TreeExpansionEvent 对象。
TreeExpansionListener - javax.swing.event 中的 接口
当树扩展或折叠某一节点时获得通知的侦听器。
TreeMap<K,V> - java.util 中的 类
基于红黑树（Red-Black tree）的 NavigableMap 实现。
TreeMap() - 类 java.util.TreeMap 的构造方法
使用键的自然顺序构造一个新的、空的树映射。
TreeMap(Comparator<? super K>) - 类 java.util.TreeMap 的构造方法
构造一个新的、空的树映射，该映射根据给定比较器进行排序。
TreeMap(Map<? extends K, ? extends V>) - 类 java.util.TreeMap 的构造方法
构造一个与给定映射具有相同映射关系的新的树映射，该映射根据其键的自然顺序 进行排序。
TreeMap(SortedMap<K, ? extends V>) - 类 java.util.TreeMap 的构造方法
构造一个与指定有序映射具有相同映射关系和相同排序顺序的新的树映射。
treeModel - 类 javax.swing.JTree 中的变量
定义此对象显示的树的模型。
treeModel - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
用于确定要显示的内容。
treeModel - 类 javax.swing.tree.AbstractLayoutCache 中的变量
提供信息的模型。
TreeModel - javax.swing.tree 中的 接口
JTree 所使用的模型。
TreeModelEvent - javax.swing.event 中的 类
封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
TreeModelEvent(Object, Object[], int[], Object[]) - 类 javax.swing.event.TreeModelEvent 的构造方法
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。
TreeModelEvent(Object, TreePath, int[], Object[]) - 类 javax.swing.event.TreeModelEvent 的构造方法
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。
TreeModelEvent(Object, Object[]) - 类 javax.swing.event.TreeModelEvent 的构造方法
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 Object 数组。
TreeModelEvent(Object, TreePath) - 类 javax.swing.event.TreeModelEvent 的构造方法
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 TreePath 对象。
TreeModelListener - javax.swing.event 中的 接口
定义侦听 TreeModel 中更改的对象的接口。
treeModelListener - 类 javax.swing.JTree 中的变量
更新 expandedState。
TreeNode - javax.swing.tree 中的 接口
定义可以用作 JTree 中树节点的对象所需的要求。
treeNodesChanged(TreeModelEvent) - 接口 javax.swing.event.TreeModelListener 中的方法
在已经以某种方式更改节点（或同级节点集）后调用。
treeNodesChanged(TreeModelEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型节点更改通知。
treeNodesChanged(TreeModelEvent) - 类 javax.swing.JTree.TreeModelHandler 中的方法
treeNodesChanged(TreeModelEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 中的方法
treeNodesChanged(TreeModelEvent) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
在某个节点（或一组兄弟节点）以某种方式更改后进行调用。
treeNodesChanged(TreeModelEvent) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
在已经以某种方式更改节点（或同级节点集）后调用。
treeNodesChanged(TreeModelEvent) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
按某种方式更改节点（或兄弟节点集）后进行调用。
treeNodesInserted(TreeModelEvent) - 接口 javax.swing.event.TreeModelListener 中的方法
在已将节点插入树中以后调用。
treeNodesInserted(TreeModelEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型节点更改通知。
treeNodesInserted(TreeModelEvent) - 类 javax.swing.JTree.TreeModelHandler 中的方法
treeNodesInserted(TreeModelEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 中的方法
treeNodesInserted(TreeModelEvent) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
将节点插入树之后进行调用。
treeNodesInserted(TreeModelEvent) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
将节点插入树之后进行调用。
treeNodesInserted(TreeModelEvent) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
将节点插入树后进行调用。
treeNodesRemoved(TreeModelEvent) - 接口 javax.swing.event.TreeModelListener 中的方法
在已从树中移除节点后调用。
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型节点更改通知。
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.JTree.TreeModelHandler 中的方法
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 中的方法
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
将节点从树移除之后进行调用。
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
将节点从树移除之后进行调用。
treeNodesRemoved(TreeModelEvent) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
将节点从树删除后进行调用。
TreePath - javax.swing.tree 中的 类
表示节点的路径。
TreePath(Object[]) - 类 javax.swing.tree.TreePath 的构造方法
根据 Objects 的数组构造路径，并根据树的数据模型的返回情况，唯一地标识树的根到指定节点的路径。
TreePath(Object) - 类 javax.swing.tree.TreePath 的构造方法
构造仅包含单个元素的 TreePath。
TreePath(TreePath, Object) - 类 javax.swing.tree.TreePath 的构造方法
构造一个新的 TreePath，它是以 lastElement 结束的 parent 标识的路径。
TreePath(Object[], int) - 类 javax.swing.tree.TreePath 的构造方法
构造一个具有长度为 length 的标识路径组件的新 TreePath。
TreePath() - 类 javax.swing.tree.TreePath 的构造方法
主要为以不同方式表示路径的子类提供。
TreeSelectionEvent - javax.swing.event 中的 类
描述当前选择中的更改的事件。
TreeSelectionEvent(Object, TreePath[], boolean[], TreePath, TreePath) - 类 javax.swing.event.TreeSelectionEvent 的构造方法
表示 TreeSelectionModel 选择中的更改。
TreeSelectionEvent(Object, TreePath, boolean, TreePath, TreePath) - 类 javax.swing.event.TreeSelectionEvent 的构造方法
表示 TreeSelectionModel 选择中的更改。
TreeSelectionListener - javax.swing.event 中的 接口
当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。
treeSelectionModel - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
维护选择的模型。
treeSelectionModel - 类 javax.swing.tree.AbstractLayoutCache 中的变量
选择模型。
TreeSelectionModel - javax.swing.tree 中的 接口
此接口表示树选择组件的当前状态。
TreeSet<E> - java.util 中的 类
基于 TreeMap 的 NavigableSet 实现。
TreeSet() - 类 java.util.TreeSet 的构造方法
构造一个新的空 set，该 set 根据其元素的自然顺序进行排序。
TreeSet(Comparator<? super E>) - 类 java.util.TreeSet 的构造方法
构造一个新的空 TreeSet，它根据指定比较器进行排序。
TreeSet(Collection<? extends E>) - 类 java.util.TreeSet 的构造方法
构造一个包含指定 collection 元素的新 TreeSet，它按照其元素的自然顺序进行排序。
TreeSet(SortedSet<E>) - 类 java.util.TreeSet 的构造方法
构造一个与指定有序 set 具有相同映射关系和相同排序的新 TreeSet。
treeState - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
负责处理大小和展开问题的对象。
treeStructureChanged(TreeModelEvent) - 接口 javax.swing.event.TreeModelListener 中的方法
在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。
treeStructureChanged(TreeModelEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树模型结构更改通知。
treeStructureChanged(TreeModelEvent) - 类 javax.swing.JTree.TreeModelHandler 中的方法
treeStructureChanged(TreeModelEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler 中的方法
treeStructureChanged(TreeModelEvent) - 类 javax.swing.tree.AbstractLayoutCache 中的方法
树彻底更改给定节点以下的结构之后进行调用。
treeStructureChanged(TreeModelEvent) - 类 javax.swing.tree.FixedHeightLayoutCache 中的方法
树彻底更改给定节点以下的结构之后进行调用。
treeStructureChanged(TreeModelEvent) - 类 javax.swing.tree.VariableHeightLayoutCache 中的方法
树彻底更改给定节点以下的结构之后进行调用。
TreeUI - javax.swing.plaf 中的 类
JTree 的可插入外观界面。
TreeUI() - 类 javax.swing.plaf.TreeUI 的构造方法
treeWillCollapse(TreeExpansionEvent) - 接口 javax.swing.event.TreeWillExpandListener 中的方法
每当树中的一个节点将被折叠时调用。
treeWillExpand(TreeExpansionEvent) - 接口 javax.swing.event.TreeWillExpandListener 中的方法
每当树中的一个节点将被扩展时调用。
TreeWillExpandListener - javax.swing.event 中的 接口
当树扩展或折叠某一节点时获得通知的侦听器。
trim() - 类 java.lang.String 中的方法
返回字符串的副本，忽略前导空白和尾部空白。
trimEdits(int, int) - 类 javax.swing.undo.UndoManager 中的方法
移除指定范围内的编辑。
trimForLimit() - 类 javax.swing.undo.UndoManager 中的方法
以下一个编辑的索引为中心，将已排队编辑的数量减少到限制的大小范围内。
trimToSize() - 类 java.lang.StringBuffer 中的方法
trimToSize() - 类 java.util.ArrayList 中的方法
将此 ArrayList 实例的容量调整为列表的当前大小。
trimToSize() - 类 java.util.Vector 中的方法
对此向量的容量进行微调，使其等于向量的当前大小。
trimToSize() - 类 javax.swing.DefaultListModel 中的方法
对此列表的容量进行裁剪，使其等于此列表的当前大小。
TRUE - 类 java.lang.Boolean 中的静态变量
对应基值 true 的 Boolean 对象。
TRUE - 接口 java.util.jar.Pack200.Packer 中的静态变量
字符串 "true"，某些属性的可能值。
TRUE - 接口 java.util.jar.Pack200.Unpacker 中的静态变量
字符串 "true"，某些属性的可能值。
TRUETYPE_FONT - 类 java.awt.Font 中的静态变量
标识 TRUETYPE 类型的字体资源。
truncate(long) - 类 java.nio.channels.FileChannel 中的方法
将此通道的文件截取为给定大小。
truncate(long) - 接口 java.sql.Blob 中的方法
截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
truncate(long) - 接口 java.sql.Clob 中的方法
截取此 Clob 指定的 CLOB 值，使其长度为 len 个字符。
truncate(long) - 类 javax.sql.rowset.serial.SerialBlob 中的方法
截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
truncate(long) - 类 javax.sql.rowset.serial.SerialClob 中的方法
截取此 SerialClob 对象所表示的 CLOB 值，使其长度为 len 个字符。
TRUNCATED - 类 javax.accessibility.AccessibleState 中的静态变量
该状态指示文本被边界矩形截取，并且有些文本不显示在屏幕上。
TrustAnchor - java.security.cert 中的 类
一个信任定位点或最受信任的证书颁发机构 (CA)。
TrustAnchor(X509Certificate, byte[]) - 类 java.security.cert.TrustAnchor 的构造方法
创建具有指定 X509Certificate 和可选 nameConstraints 的 TrustAnchor 实例，在验证 X.509 证书路径时，该 nameConstraints 用作额外的限制条件。
TrustAnchor(X500Principal, PublicKey, byte[]) - 类 java.security.cert.TrustAnchor 的构造方法
创建一个 TrustAnchor 实例，其中以 X500Principal 和公钥的形式指定最受信任的 CA。
TrustAnchor(String, PublicKey, byte[]) - 类 java.security.cert.TrustAnchor 的构造方法
创建一个 TrustAnchor 实例，其中以不同的名称和公钥的形式指定最受信任的 CA。
TrustManager - javax.net.ssl 中的 接口
这是用于 JSSE 信任管理器的基接口。
TrustManagerFactory - javax.net.ssl 中的 类
此类充当基于信任材料源的信任管理器的工厂。
TrustManagerFactory(TrustManagerFactorySpi, Provider, String) - 类 javax.net.ssl.TrustManagerFactory 的构造方法
创建 TrustManagerFactory 对象。
TrustManagerFactorySpi - javax.net.ssl 中的 类
此类为 TrustManagerFactory 类定义了服务提供者接口 (SPI)。
TrustManagerFactorySpi() - 类 javax.net.ssl.TrustManagerFactorySpi 的构造方法
tryAcquire(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试在独占模式下获取。
tryAcquire(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图在独占模式下获取对象状态。
tryAcquire() - 类 java.util.concurrent.Semaphore 中的方法
仅在调用时此信号量存在一个可用许可，才从信号量获取许可。
tryAcquire(long, TimeUnit) - 类 java.util.concurrent.Semaphore 中的方法
如果在给定的等待时间内，此信号量有可用的许可并且当前线程未被中断，则从此信号量获取一个许可。
tryAcquire(int) - 类 java.util.concurrent.Semaphore 中的方法
仅在调用时此信号量中有给定数目的许可时，才从此信号量中获取这些许可。
tryAcquire(int, long, TimeUnit) - 类 java.util.concurrent.Semaphore 中的方法
如果在给定的等待时间内此信号量有可用的所有许可，并且当前线程未被中断，则从此信号量获取给定数目的许可。
tryAcquireNanos(long, long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试以独占模式获取，如果被中断则中止，如果超过给定超时期则失败。
tryAcquireNanos(int, long) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图以独占模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
tryAcquireShared(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试在共享模式下获取。
tryAcquireShared(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图在共享模式下获取对象状态。
tryAcquireSharedNanos(long, long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试以共享模式获取，如果被中断则中止，如果超过给定超时期则失败。
tryAcquireSharedNanos(int, long) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图以共享模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
tryLock(long, long, boolean) - 类 java.nio.channels.FileChannel 中的方法
试图获取对此通道的文件给定区域的锁定。
tryLock() - 类 java.nio.channels.FileChannel 中的方法
试图获取对此通道的文件的独占锁定。
tryLock() - 接口 java.util.concurrent.locks.Lock 中的方法
仅在调用时锁为空闲状态才获取该锁。
tryLock(long, TimeUnit) - 接口 java.util.concurrent.locks.Lock 中的方法
如果锁在给定的等待时间内空闲，并且当前线程未被中断，则获取锁。
tryLock() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
仅在调用时锁未被另一个线程保持的情况下，才获取该锁。
tryLock(long, TimeUnit) - 类 java.util.concurrent.locks.ReentrantLock 中的方法
如果锁在给定等待时间内没有被另一个线程保持，且当前线程未被中断，则获取该锁。
tryLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
仅当写入锁在调用期间未被另一个线程保持时获取读取锁。
tryLock(long, TimeUnit) - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取读取锁。
tryLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
仅当写入锁在调用期间未被另一个线程保持时获取该锁。
tryLock(long, TimeUnit) - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取写入锁。
tryRelease(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试设置状态来反映独占模式下的释放。
tryRelease(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图设置状态来反映独占模式下的一个释放。
tryReleaseShared(long) - 类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 中的方法
尝试设置状态来反映共享模式下的释放。
tryReleaseShared(int) - 类 java.util.concurrent.locks.AbstractQueuedSynchronizer 中的方法
试图设置状态来反映共享模式下的一个释放。
tryToLoadClass(String, ClassLoader) - 类 java.awt.datatransfer.DataFlavor 中的静态方法
试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。
TT - 类 javax.swing.text.html.HTML.Tag 中的静态变量
TT_EOF - 类 java.io.StreamTokenizer 中的静态变量
指示已读到流末尾的常量。
TT_EOL - 类 java.io.StreamTokenizer 中的静态变量
指示已读到行末尾的常量。
TT_NUMBER - 类 java.io.StreamTokenizer 中的静态变量
指示已读到一个数字标记的常量。
TT_WORD - 类 java.io.StreamTokenizer 中的静态变量
指示已读到一个文字标记的常量。
TTL_DONT_CACHE - 类 java.util.ResourceBundle.Control 中的静态变量
不缓存已加载资源包实例的生存时间常量。
TTL_NO_EXPIRATION_CONTROL - 类 java.util.ResourceBundle.Control 中的静态变量
对缓存中已加载资源包实例禁用到期控制的生存时间常量。
ttype - 类 java.io.StreamTokenizer 中的变量
在调用 nextToken 方法之后，此字段将包含刚读取的标记的类型。
TUESDAY - 类 java.util.Calendar 中的静态变量
指示 Tuesday 的 Calendar.DAY_OF_WEEK 字段值。
TUMBLE - 类 javax.print.attribute.standard.Sides 中的静态变量
“双面短边”的别名（请参阅 TWO_SIDED_SHORT_EDGE）。
TUNE_REQUEST - 类 javax.sound.midi.ShortMessage 中的静态变量
TUNE_REQUEST 消息的状态字节（0xF6 或 246）。
TWO_SIDED_LONG_EDGE - 类 java.awt.JobAttributes.SidesType 中的静态变量
SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在长边上一样。
TWO_SIDED_LONG_EDGE - 类 javax.print.attribute.standard.Sides 中的静态变量
将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在长边上一样。
TWO_SIDED_SHORT_EDGE - 类 java.awt.JobAttributes.SidesType 中的静态变量
SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在短边上一样。
TWO_SIDED_SHORT_EDGE - 类 javax.print.attribute.standard.Sides 中的静态变量
将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在短边上一样。
TYPE - 类 java.lang.Boolean 中的静态变量
表示基本类型 boolean 的 Class 对象。
TYPE - 类 java.lang.Byte 中的静态变量
表示基本类型 byte 的 Class 实例。
TYPE - 类 java.lang.Character 中的静态变量
表示基本类型 char 的 Class 实例。
TYPE - 类 java.lang.Double 中的静态变量
表示基本类型 double 的 Class 实例。
TYPE - 类 java.lang.Float 中的静态变量
表示 float 基本类型的 Class 实例。
TYPE - 类 java.lang.Integer 中的静态变量
表示基本类型 int 的 Class 实例。
TYPE - 类 java.lang.Long 中的静态变量
表示基本类型 long 的 Class 实例。
Type - java.lang.reflect 中的 接口
Type 是 Java 编程语言中所有类型的公共高级接口。
TYPE - 类 java.lang.Short 中的静态变量
表示基本类型 short 的 Class 实例。
TYPE - 类 java.lang.Void 中的静态变量
表示对应于关键字 void 的伪类型的 Class 对象。
type() - 类 java.net.Proxy 中的方法
返回代理类型。
type - 类 javax.naming.event.NamingEvent 中的变量
包含此事件的类型。
type - 类 javax.sound.midi.MidiFileFormat 中的变量
MIDI 文件的类型。
type - 类 javax.swing.event.TableModelEvent 中的变量
type - 类 javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange 中的变量
TYPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
type - 类 javax.swing.text.html.parser.AttributeList 中的变量
type - 类 javax.swing.text.html.parser.ContentModel 中的变量
类型。
type - 类 javax.swing.text.html.parser.Element 中的变量
type - 类 javax.swing.text.html.parser.Entity 中的变量
TYPE - 接口 javax.xml.crypto.dsig.keyinfo.PGPData 中的静态变量
标识 PGPData KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#PGPData.可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 PGPData 结构。
TYPE - 接口 javax.xml.crypto.dsig.keyinfo.X509Data 中的静态变量
标识 X509Data KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#X509Data。
TYPE - 接口 javax.xml.crypto.dsig.Manifest 中的静态变量
标识 Manifest 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
TYPE - 接口 javax.xml.crypto.dsig.SignatureProperties 中的静态变量
标识 SignatureProperties 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
TYPE - 接口 javax.xml.crypto.dsig.XMLObject 中的静态变量
标识 Object 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。
type() - 类 org.omg.CORBA._IDLTypeStub 中的方法
type() - 类 org.omg.CORBA.Any 中的方法
返回此 Any 对象中所包含元素的类型信息。
type(TypeCode) - 类 org.omg.CORBA.Any 中的方法
将此 Any 对象的 type 字段设置为给定的 TypeCode 对象，并清除其值。
type() - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
type() - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
type() - 类 org.omg.CORBA.CurrentHelper 中的静态方法
type() - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
type() - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
type() - 接口 org.omg.CORBA.DynAny 中的方法
已过时。 返回插入此 DynAny 对象的 TypeCode。
type() - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
type() - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
type() - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
type() - 接口 org.omg.CORBA.IDLTypeOperations 中的方法
type 属性描述源自 IDLType 的对象定义的类型。
type() - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
type() - 类 org.omg.CORBA.ObjectHelper 中的静态方法
type() - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
type() - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
type() - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
type() - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
type() - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
type() - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
type() - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.StringValueHelper 中的静态方法
type - 类 org.omg.CORBA.StructMember 中的变量
此 StructMember 对象所描述的 struct 成员的类型。
type() - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
type() - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
type - 类 org.omg.CORBA.UnionMember 中的变量
此 UnionMember 对象所描述的 union 成员的类型。
type() - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
type() - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
type() - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
type - 类 org.omg.CORBA.ValueMember 中的变量
此 value 成员的类型。
type() - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
type() - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
type() - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
type() - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
type() - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
type() - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
type() - 类 org.omg.CosNaming.BindingHelper 中的静态方法
type() - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
type() - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
type() - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
type() - 类 org.omg.CosNaming.IstringHelper 中的静态方法
type() - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
type() - 类 org.omg.CosNaming.NameHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
type() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
type() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
返回与此 DynAny 对象关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
返回与此 DynAny 对象关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynStructStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny._DynValueStub 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
type() - 接口 org.omg.DynamicAny.DynAnyOperations 中的方法
返回与此 DynAny 对象有关联的 TypeCode。
type() - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
type() - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
type() - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
type() - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
type() - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
type() - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
type() - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
type() - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
type() - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
type() - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
type() - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
type() - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
type() - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
type() - 类 org.omg.IOP.IORHelper 中的静态方法
type() - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
type() - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
type() - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
type() - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
type() - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
type() - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
type() - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
type() - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
type() - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
type() - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
type() - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
type() - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
type() - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
type() - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
type() - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
TYPE1_FONT - 类 java.awt.Font 中的静态变量
标识 TYPE1 类型的字体资源。
type2name(int) - 类 javax.swing.text.html.parser.AttributeList 中的静态方法
TYPE_2CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 2 分量颜色空间。
TYPE_3BYTE_BGR - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 8 位 RGB 颜色分量的图像，对应于 Windows 风格的 BGR 颜色模型，具有用 3 字节存储的 Blue、Green 和 Red 三种颜色。
TYPE_3CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 3 分量颜色空间。
TYPE_4BYTE_ABGR - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 8 位 RGBA 颜色分量的图像，具有用 3 字节存储的 Blue、Green 和 Red 颜色以及 1 字节的 alpha。
TYPE_4BYTE_ABGR_PRE - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 8 位 RGBA 颜色分量的图像，具有用 3 字节存储的 Blue、Green 和 Red 颜色以及 1 字节的 alpha。
TYPE_4CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 4 分量颜色空间。
TYPE_5CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 5 分量颜色空间。
TYPE_6CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 6 分量颜色空间。
TYPE_7CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 7 分量颜色空间。
TYPE_8CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 8 分量颜色空间。
TYPE_9CLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 9 分量颜色空间。
TYPE_ACLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 10 分量颜色空间。
TYPE_BCLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 11 分量颜色空间。
TYPE_BICUBIC - 类 java.awt.image.AffineTransformOp 中的静态变量
双三次插值类型。
TYPE_BILINEAR - 类 java.awt.image.AffineTransformOp 中的静态变量
双线性的插值类型。
TYPE_BYTE - 类 java.awt.image.DataBuffer 中的静态变量
无符号 byte 数据的标记
TYPE_BYTE_BINARY - 类 java.awt.image.BufferedImage 中的静态变量
表示一个不透明的以字节打包的 1、2 或 4 位图像。
TYPE_BYTE_GRAY - 类 java.awt.image.BufferedImage 中的静态变量
表示无符号 byte 灰度级图像（无索引）。
TYPE_BYTE_INDEXED - 类 java.awt.image.BufferedImage 中的静态变量
表示带索引的字节图像。
TYPE_CCLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 12 分量颜色空间。
TYPE_CMY - 类 java.awt.color.ColorSpace 中的静态变量
CMY 颜色空间的任意颜色系列。
TYPE_CMYK - 类 java.awt.color.ColorSpace 中的静态变量
CMYK 颜色空间的任意颜色系列。
TYPE_CUSTOM - 类 java.awt.image.BufferedImage 中的静态变量
没有识别出图像类型，因此它必定是一个自定义图像。
TYPE_DCLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 13 分量颜色空间。
type_def - 类 org.omg.CORBA.StructMember 中的变量
typedef，它表示此 StructMember 对象所描述的 struct 成员的 IDL 类型。
type_def - 类 org.omg.CORBA.UnionMember 中的变量
typedef，它表示此 UnionMember 对象描述的 union 成员的 IDL 类型。
type_def - 类 org.omg.CORBA.ValueMember 中的变量
typedef，它表示此 ValueMember 对象描述的 value 成员的 IDL 类型。
TYPE_DOUBLE - 类 java.awt.image.DataBuffer 中的静态变量
double 数据的标记。
TYPE_ECLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 14 分量颜色空间。
TYPE_FCLR - 类 java.awt.color.ColorSpace 中的静态变量
Generic 15 分量颜色空间。
TYPE_FLIP - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行关于某个坐标轴的镜像翻转操作，此操作将通常的右旋坐标系更改为左旋坐标系。
TYPE_FLOAT - 类 java.awt.image.DataBuffer 中的静态变量
float 数据的标记。
TYPE_FORWARD_ONLY - 接口 java.sql.ResultSet 中的静态变量
该常量指示光标只能向前移动的 ResultSet 对象的类型。
TYPE_GENERAL_ROTATION - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行任意角度的旋转操作。
TYPE_GENERAL_SCALE - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行常规缩放操作。
TYPE_GENERAL_TRANSFORM - 类 java.awt.geom.AffineTransform 中的静态变量
此常量指示此对象定义的变换执行输入坐标的任意转换操作。
TYPE_GRAY - 类 java.awt.color.ColorSpace 中的静态变量
GRAY 颜色空间的任意颜色系列。
TYPE_HLS - 类 java.awt.color.ColorSpace 中的静态变量
HLS 颜色空间的任意颜色系列。
TYPE_HSV - 类 java.awt.color.ColorSpace 中的静态变量
HSV 颜色空间的任意颜色系列。
type_id - 类 org.omg.IOP.IOR 中的变量
以 String 形式表示的类型 id。
TYPE_IDENTITY - 类 java.awt.geom.AffineTransform 中的静态变量
此常量指示此对象定义的变换是恒等变换。
TYPE_IMAGE_BUFFER - 类 java.awt.GraphicsDevice 中的静态变量
设备是图像缓冲区。
TYPE_INT - 类 java.awt.image.DataBuffer 中的静态变量
int 数据的标记。
TYPE_INT_ARGB - 类 java.awt.image.BufferedImage 中的静态变量
表示一个图像，它具有合成整数像素的 8 位 RGBA 颜色分量。
TYPE_INT_ARGB_PRE - 类 java.awt.image.BufferedImage 中的静态变量
表示一个图像，它具有合成整数像素的 8 位 RGBA 颜色分量。
TYPE_INT_BGR - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 8 位 RGB 颜色分量的图像，对应于 Windows 或 Solaris 风格的 BGR 颜色模型，具有打包为整数像素的 Blue、Green 和 Red 三种颜色。
TYPE_INT_RGB - 类 java.awt.image.BufferedImage 中的静态变量
表示一个图像，它具有合成整数像素的 8 位 RGB 颜色分量。
TYPE_Lab - 类 java.awt.color.ColorSpace 中的静态变量
Lab 颜色空间的任意颜色系列。
TYPE_Luv - 类 java.awt.color.ColorSpace 中的静态变量
Luv 颜色空间的任意颜色系列。
TYPE_MASK_ROTATION - 类 java.awt.geom.AffineTransform 中的静态变量
此常量是所有旋转标志位的位掩码。
TYPE_MASK_SCALE - 类 java.awt.geom.AffineTransform 中的静态变量
此常量是所有缩放标志位的位掩码。
TYPE_MISMATCH_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果对象的类型和与此对象相关联的参数的期望类型不兼容。
type_modifier() - 类 org.omg.CORBA.TypeCode 中的方法
返回一个常量，它指示此 TypeCode 对象所描述的 value 类型的修饰符。
TYPE_NEAREST_NEIGHBOR - 类 java.awt.image.AffineTransformOp 中的静态变量
最接近的邻插值类型。
TYPE_PRINTER - 类 java.awt.GraphicsDevice 中的静态变量
设备是打印机。
TYPE_QUADRANT_ROTATION - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还通过乘以 90 度的某个倍数执行象限旋转操作。
TYPE_RASTER_SCREEN - 类 java.awt.GraphicsDevice 中的静态变量
设备是光栅屏幕。
TYPE_RGB - 类 java.awt.color.ColorSpace 中的静态变量
RGB 颜色空间的任意颜色系列。
TYPE_SCROLL_INSENSITIVE - 接口 java.sql.ResultSet 中的静态变量
该常量指示可滚动但通常不受 ResultSet 底层数据更改影响的 ResultSet 对象的类型。
TYPE_SCROLL_SENSITIVE - 接口 java.sql.ResultSet 中的静态变量
该常量指示可滚动并且通常受 ResultSet 底层数据更改影响的 ResultSet 对象的类型。
TYPE_SHORT - 类 java.awt.image.DataBuffer 中的静态变量
有符号 short 数据的标记。
TYPE_TRANSLATION - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行平移操作。
TYPE_UNDEFINED - 类 java.awt.image.DataBuffer 中的静态变量
未定义数据的标记。
TYPE_UNIFORM_SCALE - 类 java.awt.geom.AffineTransform 中的静态变量
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行统一缩放操作。
TYPE_USHORT - 类 java.awt.image.DataBuffer 中的静态变量
无符号 short 数据的标记
TYPE_USHORT_555_RGB - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 5-5-5 RGB 颜色分量（5 位 red、5 位 green、5 位 blue）的图像，不带 alpha。
TYPE_USHORT_565_RGB - 类 java.awt.image.BufferedImage 中的静态变量
表示一个具有 5-6-5 RGB 颜色分量（5 位 red、6 位 green、5 位 blue）的图像，不带 alpha。
TYPE_USHORT_GRAY - 类 java.awt.image.BufferedImage 中的静态变量
表示一个无符号 short 灰度级图像（无索引）。
TYPE_XYZ - 类 java.awt.color.ColorSpace 中的静态变量
XYZ 颜色空间的任意颜色系列。
TYPE_YCbCr - 类 java.awt.color.ColorSpace 中的静态变量
YCbCr 颜色空间的任意颜色系列。
TYPE_Yxy - 类 java.awt.color.ColorSpace 中的静态变量
Yxy 颜色空间的任意颜色系列。
TypeCode - org.omg.CORBA 中的 类
用于有关特定 CORBA 数据类型的信息的容器。
TypeCode() - 类 org.omg.CORBA.TypeCode 的构造方法
TypeCodeHolder - org.omg.CORBA 中的 类
TypeCode 的 Holder。
TypeCodeHolder() - 类 org.omg.CORBA.TypeCodeHolder 的构造方法
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为 null。
TypeCodeHolder(TypeCode) - 类 org.omg.CORBA.TypeCodeHolder 的构造方法
构造一个新的 TypeCodeHolder 对象，将其 value 字段初始化为给定的 TypeCode 对象。
TypeConstraintException - javax.xml.bind 中的 异常
此异常指示已检测到存在违反动态检查的类型约束的情况。
TypeConstraintException(String) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带指定详细消息的 TypeConstraintException。
TypeConstraintException(String, String) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 TypeConstraintException。
TypeConstraintException(Throwable) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带有一个 linkedException 的 TypeConstraintException。
TypeConstraintException(String, Throwable) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带指定详细消息和 linkedException 的 TypeConstraintException。
TypeConstraintException(String, String, Throwable) - 异常 javax.xml.bind.TypeConstraintException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 TypeConstraintException。
TypeElement - javax.lang.model.element 中的 接口
表示一个类或接口程序元素。
TypeInfo - org.w3c.dom 中的 接口
TypeInfo 接口表示从 Element 或 Attr 节点引用的类型，用与文档相关的模式指定。
TypeInfoProvider - javax.xml.validation 中的 类
此类提供了对 ValidatorHandler 所确定的类型信息的访问。
TypeInfoProvider() - 类 javax.xml.validation.TypeInfoProvider 的构造方法
派生类的构造方法。
TypeKind - javax.lang.model.type 中的 枚举
类型镜像的种类。
TypeKindVisitor6<R,P> - javax.lang.model.util 中的 类
基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。
TypeKindVisitor6() - 类 javax.lang.model.util.TypeKindVisitor6 的构造方法
要调用的具体子类的构造方法；使用 null 作为默认值。
TypeKindVisitor6(R) - 类 javax.lang.model.util.TypeKindVisitor6 的构造方法
要调用的具体子类的构造方法；使用参数作为默认值。
TypeMirror - javax.lang.model.type 中的 接口
表示 Java 编程语言中的类型。
TypeMismatch - org.omg.CORBA.DynAnyPackage 中的 异常
动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。
TypeMismatch() - 异常 org.omg.CORBA.DynAnyPackage.TypeMismatch 的构造方法
构造一个 TypeMismatch 对象。
TypeMismatch(String) - 异常 org.omg.CORBA.DynAnyPackage.TypeMismatch 的构造方法
构造一个 TypeMismatch 对象。
TypeMismatch - org.omg.DynamicAny.DynAnyPackage 中的 异常
org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java。
TypeMismatch() - 异常 org.omg.DynamicAny.DynAnyPackage.TypeMismatch 的构造方法
TypeMismatch(String) - 异常 org.omg.DynamicAny.DynAnyPackage.TypeMismatch 的构造方法
TypeMismatch - org.omg.IOP.CodecPackage 中的 异常
org/omg/IOP/CodecPackage/TypeMismatch.java。
TypeMismatch() - 异常 org.omg.IOP.CodecPackage.TypeMismatch 的构造方法
TypeMismatch(String) - 异常 org.omg.IOP.CodecPackage.TypeMismatch 的构造方法
TypeMismatchHelper - org.omg.DynamicAny.DynAnyPackage 中的 类
org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java。
TypeMismatchHelper() - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 的构造方法
TypeMismatchHelper - org.omg.IOP.CodecPackage 中的 类
org/omg/IOP/CodecPackage/TypeMismatchHelper.java。
TypeMismatchHelper() - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 的构造方法
typeName() - 异常 java.lang.TypeNotPresentException 中的方法
返回不可用类型的完全限定名。
typeNoNulls - 接口 java.sql.DatabaseMetaData 中的静态变量
指示“不”允许对这种数据类型使用 NULL 值。
TypeNotPresentException - java.lang 中的 异常
当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
TypeNotPresentException(String, Throwable) - 异常 java.lang.TypeNotPresentException 的构造方法
为指定类型构造一个带指定原因的 TypeNotPresentException。
typeNullable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示允许对这种数据类型使用 NULL 值。
typeNullableUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不知道是否允许对这种数据类型使用 NULL 值。
TypeParameterElement - javax.lang.model.element 中的 接口
表示一般类、接口、方法或构造方法元素的形式类型参数。
typePredBasic - 接口 java.sql.DatabaseMetaData 中的静态变量
指示该数据类型只能用于不使用 LIKE 谓词的 WHERE 搜索子句中。
typePredChar - 接口 java.sql.DatabaseMetaData 中的静态变量
指示该数据类型只能用于使用 LIKE 谓词的 WHERE 搜索子句中。
typePredNone - 接口 java.sql.DatabaseMetaData 中的静态变量
指示不支持将 WHERE 搜索子句用于这种类型。
Types - java.sql 中的 类
定义用于标识一般 SQL 类型（称为 JDBC 类型）的常量的类。
Types - javax.lang.model.util 中的 接口
用来对类型进行操作的实用工具方法。
typeSearchable - 接口 java.sql.DatabaseMetaData 中的静态变量
指示在此类型上可以建立所有 WHERE 搜索子句。
typesIn(Iterable<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中类型的列表。
typesIn(Set<? extends Element>) - 类 javax.lang.model.util.ElementFilter 中的静态方法
返回 elements 中类型的集合。
TypeVariable<D extends GenericDeclaration> - java.lang.reflect 中的 接口
TypeVariable 是各种类型变量的公共高级接口。
TypeVariable - javax.lang.model.type 中的 接口
表示一个类型变量。
TypeVisitor<R,P> - javax.lang.model.type 中的 接口
类型的 visitor，使用 visitor 设计模式的样式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


U - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

U

U - 类 javax.swing.text.html.HTML.Tag 中的静态变量
UGARITIC - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Ugaritic”Unicode 字符块的常量。
ui - 类 javax.swing.JComponent 中的变量
此组件的外观委托。
ui - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的变量
UID - java.rmi.server 中的 类
UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。
UID() - 类 java.rmi.server.UID 的构造方法
生成一个 UID，它和生成它的主机的时间有关且具有唯一性。
UID(short) - 类 java.rmi.server.UID 的构造方法
创建一个“熟知”UID。
UIDefaults - javax.swing 中的 类
Swing 组件的默认值表。
UIDefaults() - 类 javax.swing.UIDefaults 的构造方法
创建一个空默认值表。
UIDefaults(int, float) - 类 javax.swing.UIDefaults 的构造方法
创建一个带有指定初始容量和加载因子的空默认值表。
UIDefaults(Object[]) - 类 javax.swing.UIDefaults 的构造方法
创建一个使用指定键/值对初始化的默认值表。
UIDefaults.ActiveValue - javax.swing 中的 接口
此类使用户能够在默认表中存储项，该默认表在每次使用某个 getXXX(key) 方法进行查找时创建。
UIDefaults.LazyInputMap - javax.swing 中的 类
LazyInputMap 将在其 createValue 方法中创建一个 InputMap。
UIDefaults.LazyInputMap(Object[]) - 类 javax.swing.UIDefaults.LazyInputMap 的构造方法
UIDefaults.LazyValue - javax.swing 中的 接口
此类使用户能够在默认表中存储项，该默认表只有在第一次使用某个 getXXX(key) 方法进行查找时才创建。
UIDefaults.ProxyLazyValue - javax.swing 中的 类
此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。
UIDefaults.ProxyLazyValue(String) - 类 javax.swing.UIDefaults.ProxyLazyValue 的构造方法
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String, String) - 类 javax.swing.UIDefaults.ProxyLazyValue 的构造方法
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String, Object[]) - 类 javax.swing.UIDefaults.ProxyLazyValue 的构造方法
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String, String, Object[]) - 类 javax.swing.UIDefaults.ProxyLazyValue 的构造方法
创建一个将在请求时构造实例的 LazyValue。
UIEvent - org.w3c.dom.events 中的 接口
UIEvent 接口提供与用户界面事件相关联的特定上下文信息。
UIManager - javax.swing 中的 类
UIManager 管理当前外观、可用外观集合、外观更改时被通知的 PropertyChangeListeners、外观默认值以及获取各种默认值的便捷方法。
UIManager() - 类 javax.swing.UIManager 的构造方法
UIManager.LookAndFeelInfo - javax.swing 中的 类
为了配置菜单或为了初始应用程序设置而提供关于已安装的 LookAndFeel 的少量信息。
UIManager.LookAndFeelInfo(String, String) - 类 javax.swing.UIManager.LookAndFeelInfo 的构造方法
构造一个 UIManager LookAndFeelInfo 对象。
UIResource - javax.swing.plaf 中的 接口
此接口用于标记由 ComponentUI 委托创建的对象。
uis - 类 javax.swing.plaf.multi.MultiButtonUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiLabelUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiListUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiPanelUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiSliderUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTableUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTextUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiToolBarUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiToolTipUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiTreeUI 中的变量
包含实际 UI 的向量。
uis - 类 javax.swing.plaf.multi.MultiViewportUI 中的变量
包含实际 UI 的向量。
uisToArray(Vector) - 类 javax.swing.plaf.multi.MultiLookAndFeel 中的静态方法
创建一个数组，使用来自传入向量的 UI 对象填充它并返回该数组。
UK - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
UL - 类 javax.swing.text.html.HTML.Tag 中的静态变量
ULAW - 类 javax.sound.sampled.AudioFormat.Encoding 中的静态变量
指定 u-law 编码数据。
ULongLongSeqHelper - org.omg.CORBA 中的 类
ULongLongSeq 的 Helper。
ULongLongSeqHelper() - 类 org.omg.CORBA.ULongLongSeqHelper 的构造方法
ULongLongSeqHolder - org.omg.CORBA 中的 类
ULongLongSeq 的 Holder。
ULongLongSeqHolder() - 类 org.omg.CORBA.ULongLongSeqHolder 的构造方法
ULongLongSeqHolder(long[]) - 类 org.omg.CORBA.ULongLongSeqHolder 的构造方法
ULongSeqHelper - org.omg.CORBA 中的 类
ULongSeq 的 Helper。
ULongSeqHelper() - 类 org.omg.CORBA.ULongSeqHelper 的构造方法
ULongSeqHolder - org.omg.CORBA 中的 类
ULongSeq 的 Holder。
ULongSeqHolder() - 类 org.omg.CORBA.ULongSeqHolder 的构造方法
ULongSeqHolder(int[]) - 类 org.omg.CORBA.ULongSeqHolder 的构造方法
ulp(double) - 类 java.lang.Math 中的静态方法
返回参数的 ulp 大小。
ulp(float) - 类 java.lang.Math 中的静态方法
返回参数的 ulp 大小。
ulp(double) - 类 java.lang.StrictMath 中的静态方法
返回参数的 ulp 大小。
ulp(float) - 类 java.lang.StrictMath 中的静态方法
返回参数的 ulp 大小。
ulp() - 类 java.math.BigDecimal 中的方法
返回此 BigDecimal 的 ulp（最后一位的单位）的大小。
UNASSIGNED - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Cn”。
UNAUTHORIZED - 异常 org.ietf.jgss.GSSException 中的静态变量
未授权的操作。
UNAVAILABLE - 异常 org.ietf.jgss.GSSException 中的静态变量
不可用的操作。
unbind(String) - 类 java.rmi.Naming 中的静态方法
销毁与远程对象关联的指定名称的绑定。
unbind(String) - 接口 java.rmi.registry.Registry 中的方法
移除此注册表中指定的 name 绑定。
unbind(Name) - 接口 javax.naming.Context 中的方法
取消对指定对象的绑定。
unbind(String) - 接口 javax.naming.Context 中的方法
取消对指定对象的绑定。
unbind(String) - 类 javax.naming.InitialContext 中的方法
unbind(Name) - 类 javax.naming.InitialContext 中的方法
unbind(NameComponent[]) - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
unbind 操作从上下文移除名称绑定。
unbind(NameComponent[]) - 类 org.omg.CosNaming._NamingContextStub 中的方法
unbind 操作从上下文移除名称绑定。
unbind(NameComponent[]) - 接口 org.omg.CosNaming.NamingContextOperations 中的方法
unbind 操作从上下文移除名称绑定。
unboxedType(TypeMirror) - 接口 javax.lang.model.util.Types 中的方法
返回给定类型的拆箱 (unboxed) 值类型（基本类型）。
uncaughtException(Thread, Throwable) - 接口 java.lang.Thread.UncaughtExceptionHandler 中的方法
当给定线程因给定的未捕获异常而终止时，调用该方法。
uncaughtException(Thread, Throwable) - 类 java.lang.ThreadGroup 中的方法
当此线程组中的线程因为一个未捕获的异常而停止，并且线程没有安装特定 Thread.UncaughtExceptionHandler 时，由 Java Virtual Machine 调用此方法。
unchecked_narrow(Object) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
unchecked_narrow(Object) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
UNCOLLATED - 类 javax.print.attribute.standard.SheetCollate 中的静态变量
当打印多个副本时，文档中的纸张以非整理顺序出现。
unconfigurableExecutorService(ExecutorService) - 类 java.util.concurrent.Executors 中的静态方法
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。
unconfigurableScheduledExecutorService(ScheduledExecutorService) - 类 java.util.concurrent.Executors 中的静态方法
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。
unconfigureArrowButton() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此公共方法是特定于实现的，应该为私有。
unconfigureEditor() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
此受保护方法是特定于实现的，应该为私有。
unconfigureEditor() - 类 javax.swing.plaf.metal.MetalComboBoxUI 中的方法
unconfigureEnclosingScrollPane() - 类 javax.swing.JTable 中的方法
通过将封闭滚动窗格的 columnHeaderView 替换为 null，可以起到 configureEnclosingScrollPane 的相反作用。
UNDECIMBER - 类 java.util.Calendar 中的静态变量
指示一年中第十三个月的 Calendar.MONTH 字段值。
UndeclaredThrowableException - java.lang.reflect 中的 异常
如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。
UndeclaredThrowableException(Throwable) - 异常 java.lang.reflect.UndeclaredThrowableException 的构造方法
根据指定的 Throwable 构造一个 UndeclaredThrowableException。
UndeclaredThrowableException(Throwable, String) - 异常 java.lang.reflect.UndeclaredThrowableException 的构造方法
根据指定的 Throwable 和详细消息构造 UndeclaredThrowableException。
UNDEFINED - 类 java.awt.BufferCapabilities.FlipContents 中的静态变量
当翻转内容为 UNDEFINED 时，后台缓冲区的内容在翻转后是不明确的。
UNDEFINED_CONDITION - 类 javax.swing.JComponent 中的静态变量
某些 API 使用的常量，意味着没有定义任何条件。
UndefinedProperty - 类 java.awt.Image 中的静态变量
每当获得某个不是为特定图像定义的属性时，应返回 UndefinedProperty 对象。
UNDERFLOW - 类 java.nio.charset.CoderResult 中的静态变量
指示下溢的结果对象，意味着输入缓冲区中的输入被用完，或者如果输入缓冲区不是空的，但还需要其他的输入。
UNDERLINE - 类 java.awt.font.TextAttribute 中的静态变量
下划线的属性键。
Underline - 类 javax.swing.text.StyleConstants 中的静态变量
下划线属性的名称。
UNDERLINE_LOW_DASHED - 类 java.awt.font.TextAttribute 中的静态变量
单像素虚线低下划线。
UNDERLINE_LOW_DOTTED - 类 java.awt.font.TextAttribute 中的静态变量
单像素点线式低下划线。
UNDERLINE_LOW_GRAY - 类 java.awt.font.TextAttribute 中的静态变量
双像素灰色低下划线。
UNDERLINE_LOW_ONE_PIXEL - 类 java.awt.font.TextAttribute 中的静态变量
单像素实心低下划线。
UNDERLINE_LOW_TWO_PIXEL - 类 java.awt.font.TextAttribute 中的静态变量
双像素实心低下划线。
UNDERLINE_ON - 类 java.awt.font.TextAttribute 中的静态变量
标准下划线。
undo() - 类 javax.swing.text.AbstractDocument.DefaultDocumentEvent 中的方法
撤消更改。
undo() - 类 javax.swing.text.AbstractDocument.ElementEdit 中的方法
撤消更改。
undo() - 类 javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit 中的方法
撤消更改。
undo() - 类 javax.swing.undo.AbstractUndoableEdit 中的方法
如果 canUndo 返回 false，则抛出 CannotUndoException。
undo() - 类 javax.swing.undo.CompoundEdit 中的方法
按与添加时相反的顺序将 undo 发送到所有包含的 UndoableEdits 中。
undo() - 类 javax.swing.undo.StateEdit 中的方法
通知被编辑的对象应用编辑之前的状态
undo() - 接口 javax.swing.undo.UndoableEdit 中的方法
撤消编辑。
undo() - 类 javax.swing.undo.UndoManager 中的方法
撤消适当的编辑。
UndoableEdit - javax.swing.undo 中的 接口
UndoableEdit 表示一个编辑。
UndoableEditEvent - javax.swing.event 中的 类
指示发生了可撤消操作的事件。
UndoableEditEvent(Object, UndoableEdit) - 类 javax.swing.event.UndoableEditEvent 的构造方法
构造一个 UndoableEditEvent 对象。
undoableEditHappened(UndoableEditEvent) - 接口 javax.swing.event.UndoableEditListener 中的方法
发生了可撤消的编辑操作
undoableEditHappened(UndoableEditEvent) - 类 javax.swing.undo.UndoManager 中的方法
一个 UndoableEditListener 方法。
UndoableEditListener - javax.swing.event 中的 接口
该接口由某个对接收有关可撤消操作的消息感兴趣的类实现。
UndoableEditSupport - javax.swing.undo 中的 类
用于管理 UndoableEdit 侦听器的支持类。
UndoableEditSupport() - 类 javax.swing.undo.UndoableEditSupport 的构造方法
构造一个 UndoableEditSupport 对象。
UndoableEditSupport(Object) - 类 javax.swing.undo.UndoableEditSupport 的构造方法
构造一个 UndoableEditSupport 对象。
undoDelete() - 接口 javax.sql.rowset.CachedRowSet 中的方法
取消删除当前行并通知侦听器已更改了某个行。
undoInsert() - 接口 javax.sql.rowset.CachedRowSet 中的方法
如果已经插入了当前行，则立即将它从此 CachedRowSet 对象移除，同样要通知侦听器已更改了某个行。
UndoManager - javax.swing.undo 中的 类
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。
UndoManager() - 类 javax.swing.undo.UndoManager 的构造方法
创建一个新的 UndoManager。
UndoName - 类 javax.swing.undo.AbstractUndoableEdit 中的静态变量
由 getUndoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此字段。
undoOrRedo() - 类 javax.swing.undo.UndoManager 中的方法
一个便捷方法，它调用 undo 或 redo。
undoRedoName - 类 javax.swing.undo.StateEdit 中的变量
撤消/恢复的表示名称
undoTo(UndoableEdit) - 类 javax.swing.undo.UndoManager 中的方法
撤消从下一个编辑的索引到 edit 的所有更改，适当地更新下一个编辑的索引。
undoUpdate() - 接口 javax.sql.rowset.CachedRowSet 中的方法
如果已经修改了行，则立即逆转上一次更新操作。
unescapeValue(String) - 类 javax.naming.ldap.Rdn 中的静态方法
在给定根据 RFC 2253 中指定的规则进行格式化的属性值字符串的情况下，返回未格式化的值。
UnexpectedException - java.rmi 中的 异常
如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
UnexpectedException(String) - 异常 java.rmi.UnexpectedException 的构造方法
构造带指定详细消息的 UnexpectedException。
UnexpectedException(String, Exception) - 异常 java.rmi.UnexpectedException 的构造方法
构造带有指定详细消息和嵌入异常的 UnexpectedException。
unexportObject(Remote, boolean) - 类 java.rmi.activation.Activatable 中的静态方法
从 RMI 运行库中移除远程对象 obj。
unexportObject(Remote, boolean) - 类 java.rmi.server.UnicastRemoteObject 中的静态方法
从 RMI 运行时移除远程对象 obj。
unexportObject(Remote) - 接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 中的方法
PortableRemoteObject.unexportObject(java.rmi.Remote) 的委托调用。
unexportObject(Remote) - 类 javax.rmi.CORBA.Util 中的静态方法
从内部表中移除关联的 tie，并调用 Tie.deactivate() 以取消激活该对象。
unexportObject(Remote) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.unexportObject(java.rmi.Remote) 的委托调用。
unexportObject(Remote) - 类 javax.rmi.PortableRemoteObject 中的静态方法
从运行时注销服务器对象，允许对象用于垃圾回收。
UnicastRemoteObject - java.rmi.server 中的 类
用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。
UnicastRemoteObject() - 类 java.rmi.server.UnicastRemoteObject 的构造方法
使用匿名端口创建并导出一个新 UnicastRemoteObject 对象。
UnicastRemoteObject(int) - 类 java.rmi.server.UnicastRemoteObject 的构造方法
使用提供的特定端口创建并导出一个新 UnicastRemoteObject 对象。
UnicastRemoteObject(int, RMIClientSocketFactory, RMIServerSocketFactory) - 类 java.rmi.server.UnicastRemoteObject 的构造方法
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。
UNICODE_CASE - 类 java.util.regex.Pattern 中的静态变量
启用 Unicode 感知的大小写折叠。
UNICODE_STREAM_PARAM - 类 javax.sql.rowset.BaseRowSet 中的静态变量
该常量向 RowSetReaderImpl 对象指示给定的参数是一个 Unicode 流。
unicodeStream - 类 javax.sql.rowset.BaseRowSet 中的变量
将由方法 getUnicodeStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Unified Canadian Aboriginal Syllabics”Unicode 字符块的常量。
uninitialize() - 类 javax.swing.LookAndFeel 中的方法
取消初始化外观。
uninitialize() - 类 javax.swing.plaf.basic.BasicLookAndFeel 中的方法
取消初始化外观。
uninitialize() - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的方法
在卸载此外观时由 UIManager 调用。
UNINITIALIZED - 类 java.security.Signature 中的静态变量
可能的 Signature.state 值，表示尚未初始化此签名对象。
UNINITIALIZED_VALUE - 类 javax.swing.JOptionPane 中的静态变量
指示用户尚未选择值。
uninstall() - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
卸载 AbstractFormatter 可能已在 JFormattedTextField 上安装的所有状态。
uninstallBorder(JComponent) - 类 javax.swing.LookAndFeel 中的静态方法
卸载边框的便捷方法。
uninstallChooserPanel(JColorChooser) - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
从选取器中移除面板时被调用。
uninstallComboBoxModelListeners(ComboBoxModel) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
从组合框模型中移除侦听器
uninstallComponents() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
注销并卸载组成组合框的聚合组件。
uninstallComponents() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
uninstallComponents(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallComponents(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallComponents(JMenuItem) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
uninstallComponents(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
从 JTabbedPane 移除所有已安装的子组件。
uninstallComponents() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
卸载渲染器窗格。
uninstallComponents() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
uninstallComponents(JFileChooser) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
uninstallComponents() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
uninstallDefaultChoosers() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
从 JComboBox 中卸载默认颜色、默认字体、默认渲染器和默认编辑器。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
uninstallDefaults(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallDefaults(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
将尚未显式重写的 JList 属性设置为 null。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
uninstallDefaults(JPanel) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.basic.BasicRadioButtonUI 中的方法
uninstallDefaults(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallDefaults(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
uninstallDefaults(JSeparator) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
将 JSpinner 的布局管理器设置为 null。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
卸载 UI 默认值。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将尚未显式重写的组件属性设置为 null。
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallDefaults(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
uninstallDefaults(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalCheckBoxUI 中的方法
uninstallDefaults() - 类 javax.swing.plaf.metal.MetalInternalFrameTitlePane 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalRadioButtonUI 中的方法
uninstallDefaults(AbstractButton) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
uninstallDefaults(SynthContext) - 类 javax.swing.plaf.synth.SynthStyle 中的方法
卸载此样式在 context 的 JComponent 上安装的任何状态。
uninstallDesktopManager() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
uninstallIcons(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallingUI() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
卸载 UI 时调用。
uninstallingUI() - 接口 javax.swing.plaf.basic.ComboPopup 中的方法
调用以通知 ComboPopup 正在卸载 UI。
uninstallKeyboardActions(JComponent) - 类 javax.swing.plaf.basic.BasicButtonListener 中的方法
未注册的默认键动作
uninstallKeyboardActions(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
移除焦点 InputMap 和 ActionMap。
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallKeyboardActions(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
注销根据 installKeyboardActions 安装的键盘动作。
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
uninstallKeyboardActions(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallKeyboardActions(JScrollPane) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
uninstallKeyboardActions(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
卸载 UI 的键盘动作。
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
注销默认键动作。
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
uninstallKeyboardActions() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
uninstallListeners(AbstractButton) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
从组合框及其模型中移除已安装的侦听器。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
从 JDesktopPane 卸载从 createPropertyChangeListener 返回的 PropertyChangeListener。
uninstallListeners(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallListeners(JLabel) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
移除 JList、其模型及其 selectionModel 的侦听器。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicMenuUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
移除此对象安装的所有侦听器。
uninstallListeners(JRootPane) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallListeners(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
uninstallListeners(JSeparator) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
uninstallListeners(JSlider) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
移除 installListeners 添加的 PropertyChangeListener。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
卸载 UI 的事件侦听器。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
卸载 UI 的侦听器。
uninstallListeners() - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallListeners(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.metal.MetalDesktopIconUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
uninstallListeners(JScrollPane) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
uninstallListeners() - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
uninstallStrings(JFileChooser) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicButtonUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicColorChooserUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicComboBoxUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopIconUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicEditorPaneUI 中的方法
卸载组件的 UI。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicLabelUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicListUI 中的方法
按顺序调用 uninstallListeners()、uninstallKeyboardActions() 和 uninstallDefaults() 来取消初始化 this.list。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicOptionPaneUI 中的方法
从传入拆分窗格的 L&F 控制器移除接收者。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicPanelUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicPopupMenuUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicProgressBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicRootPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicSeparatorUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicSpinnerUI 中的方法
调用 uninstallDefaults、uninstallListeners，然后移除所有子 spinner。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的方法
卸载 UI。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableHeaderUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTableUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
卸载组件的 UI。
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicToolTipUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.basic.BasicViewportUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
在 installUI 期间，在指定组件上反向执行的配置操作。
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalInternalFrameUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalMenuBarUI 中的方法
在 installUI 期间，在指定组件上反向执行的配置操作。
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalRootPaneUI 中的方法
调用超实现来卸载所有状态。
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalScrollPaneUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalToolTipUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.metal.MetalTreeUI 中的方法
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
uninstallUI(JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 uninstallUI 方法。
union(Rectangle2D, Rectangle2D, Rectangle2D) - 类 java.awt.geom.Rectangle2D 中的静态方法
将一对源 Rectangle2D 对象合并，并将结果置于指定的目标 Rectangle2D 对象中。
union(Rectangle) - 类 java.awt.Rectangle 中的方法
计算此 Rectangle 与指定 Rectangle 的并集。
union(Descriptor...) - 类 javax.management.ImmutableDescriptor 中的静态方法
返回一个 ImmutableDescriptor，其内容是给定描述符的并集。
UNION - 类 javax.xml.crypto.dsig.spec.XPathType.Filter 中的静态变量
联合过滤操作。
UnionMember - org.omg.CORBA 中的 类
接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。
UnionMember() - 类 org.omg.CORBA.UnionMember 的构造方法
构造一个新的 UnionMember 对象，将其字段初始化为 null。
UnionMember(String, Any, TypeCode, IDLType) - 类 org.omg.CORBA.UnionMember 的构造方法
构造一个新的 UnionMember 对象，将其字段初始化为给定值。
UnionMemberHelper - org.omg.CORBA 中的 类
UnionMember 的 Helper。
UnionMemberHelper() - 类 org.omg.CORBA.UnionMemberHelper 的构造方法
UNIQUE_ID - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态变量
UNIT_DECREMENT - 类 java.awt.event.AdjustmentEvent 中的静态变量
单位减量调整类型。
UNIT_INCREMENT - 类 java.awt.event.AdjustmentEvent 中的静态变量
单位增量调整类型。
unitIncrement - 类 javax.swing.JScrollBar 中的变量
UNIX_LINES - 类 java.util.regex.Pattern 中的静态变量
启用 Unix 行模式。
UNKNOWN - 类 java.awt.ComponentOrientation 中的静态变量
表示尚未设置组件的方向。
UNKNOWN - 类 javax.accessibility.AccessibleRole 中的静态变量
该对象包含某些 Accessible 信息，但其职责是未知的。
UNKNOWN - 类 javax.management.MBeanOperationInfo 中的静态变量
指示操作具有“未知”的特性。
UNKNOWN - 类 javax.print.attribute.standard.JobState 中的静态变量
作业状态是未知的。
UNKNOWN - 类 javax.print.attribute.standard.PrinterState 中的静态变量
打印机状态未知。
UNKNOWN - org.omg.CORBA 中的 异常
如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
UNKNOWN() - 异常 org.omg.CORBA.UNKNOWN 的构造方法
使用默认次要代码 0、完成状态 CompletionStatus.COMPLETED_NO 和 null 描述构造一个 UNKNOWN 异常。
UNKNOWN(String) - 异常 org.omg.CORBA.UNKNOWN 的构造方法
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 UNKNOWN 异常。
UNKNOWN(int, CompletionStatus) - 异常 org.omg.CORBA.UNKNOWN 的构造方法
使用指定次要代码和完成状态构造一个 UNKNOWN 异常。
UNKNOWN(String, int, CompletionStatus) - 异常 org.omg.CORBA.UNKNOWN 的构造方法
使用指定描述消息、次要代码和完成状态构造一个 UNKNOWN 异常。
UNKNOWN - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/UNKNOWN.java。
unknown_adapter(POA, String) - 接口 org.omg.PortableServer.AdapterActivatorOperations 中的方法
在 ORB 接收对象引用的请求时，如果该对象引用定义不存在的目标 POA，则将调用此操作。
UNKNOWN_ATTRIBUTE - 接口 java.util.jar.Pack200.Packer 中的静态变量
指出遇到包含有未知属性的类文件时所采取的行动。
UNKNOWN_LENGTH - 类 javax.sound.midi.MidiFileFormat 中的静态变量
表示未知长度。
UNKNOWN_NUMBER_OF_PAGES - 接口 java.awt.print.Pageable 中的静态变量
如果集合中的页面数对于 Pageable 实现是未知的，则从 getNumberOfPages 方法返回此常量。
UnknownAnnotationValueException - javax.lang.model.element 中的 异常
指示遇到一个未知种类的注释值。
UnknownAnnotationValueException(AnnotationValue, Object) - 异常 javax.lang.model.element.UnknownAnnotationValueException 的构造方法
创建一个新的 UnknownAnnotationValueException。
UnknownElementException - javax.lang.model.element 中的 异常
指示遇到一个未知种类的元素。
UnknownElementException(Element, Object) - 异常 javax.lang.model.element.UnknownElementException 的构造方法
创建一个新的 UnknownElementException。
UnknownEncoding - org.omg.IOP.CodecFactoryPackage 中的 异常
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。
UnknownEncoding() - 异常 org.omg.IOP.CodecFactoryPackage.UnknownEncoding 的构造方法
UnknownEncoding(String) - 异常 org.omg.IOP.CodecFactoryPackage.UnknownEncoding 的构造方法
UnknownEncodingHelper - org.omg.IOP.CodecFactoryPackage 中的 类
org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java。
UnknownEncodingHelper() - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 的构造方法
UnknownError - java.lang 中的 错误
当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
UnknownError() - 错误 java.lang.UnknownError 的构造方法
构造不带详细消息的 UnknownError。
UnknownError(String) - 错误 java.lang.UnknownError 的构造方法
构造带指定详细消息的 UnknownError。
UnknownException - org.omg.CORBA.portable 中的 异常
org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。
UnknownException(Throwable) - 异常 org.omg.CORBA.portable.UnknownException 的构造方法
构造一个 UnknownException 对象。
UnknownFormatConversionException - java.util 中的 异常
给定未知的转换时所抛出的未经检查的异常。
UnknownFormatConversionException(String) - 异常 java.util.UnknownFormatConversionException 的构造方法
使用未知的转换构造此类的实例。
UnknownFormatFlagsException - java.util 中的 异常
给定未知标志时所抛出的未经检查的异常。
UnknownFormatFlagsException(String) - 异常 java.util.UnknownFormatFlagsException 的构造方法
使用指定的标志构造此类的实例。
UnknownGroupException - java.rmi.activation 中的 异常
当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
UnknownGroupException(String) - 异常 java.rmi.activation.UnknownGroupException 的构造方法
构造带指定详细消息的 UnknownGroupException。
UnknownHostException - java.net 中的 异常
指示主机 IP 地址无法确定而抛出的异常。
UnknownHostException(String) - 异常 java.net.UnknownHostException 的构造方法
构造带有指定详细消息的新 UnknownHostException。
UnknownHostException() - 异常 java.net.UnknownHostException 的构造方法
构造不带详细消息的新 UnknownHostException。
UnknownHostException - java.rmi 中的 异常
如果在创建到远程主机的连接以便进行远程方法调用时发生 java.net.UnknownHostException，则抛出 UnknownHostException。
UnknownHostException(String) - 异常 java.rmi.UnknownHostException 的构造方法
构造带指定详细消息的 UnknownHostException。
UnknownHostException(String, Exception) - 异常 java.rmi.UnknownHostException 的构造方法
构造带指定详细消息和嵌入异常的 UnknownHostException。
UnknownObjectException - java.rmi.activation 中的 异常
当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。
UnknownObjectException(String) - 异常 java.rmi.activation.UnknownObjectException 的构造方法
构造带指定详细消息的 UnknownObjectException。
UnknownServiceException - java.net 中的 异常
抛出这一异常指示出现了未知服务异常。
UnknownServiceException() - 异常 java.net.UnknownServiceException 的构造方法
构造不带详细消息的新 UnknownServiceException。
UnknownServiceException(String) - 异常 java.net.UnknownServiceException 的构造方法
构造带指定详细消息的新 UnknownServiceException。
UnknownTypeException - javax.lang.model.type 中的 异常
指示遇到未知种类的类型。
UnknownTypeException(TypeMirror, Object) - 异常 javax.lang.model.type.UnknownTypeException 的构造方法
创建一个新的 UnknownTypeException。
UnknownUserException - org.omg.CORBA 中的 异常
包含由服务器返回的用户异常的类。
UnknownUserException() - 异常 org.omg.CORBA.UnknownUserException 的构造方法
构造一个 UnknownUserException 对象。
UnknownUserException(Any) - 异常 org.omg.CORBA.UnknownUserException 的构造方法
构造一个包含给定 Any 对象的 UnknownUserException 对象。
UnknownUserExceptionHelper - org.omg.CORBA 中的 类
UnknownUserException 的 Helper。
UnknownUserExceptionHelper() - 类 org.omg.CORBA.UnknownUserExceptionHelper 的构造方法
UnknownUserExceptionHolder - org.omg.CORBA 中的 类
UnknownUserException 的 Holder。
UnknownUserExceptionHolder() - 类 org.omg.CORBA.UnknownUserExceptionHolder 的构造方法
UnknownUserExceptionHolder(UnknownUserException) - 类 org.omg.CORBA.UnknownUserExceptionHolder 的构造方法
UNLIMITED - 类 java.math.MathContext 中的静态变量
其设置具有无限精度算法所需值的 MathContext 对象。
unloadAllInstruments(Soundbank) - 接口 javax.sound.midi.Synthesizer 中的方法
卸载指定 Soundbank 中包含的所有乐器。
unloadInstrument(Instrument) - 接口 javax.sound.midi.Synthesizer 中的方法
卸载特定的乐器。
unloadInstruments(Soundbank, Patch[]) - 接口 javax.sound.midi.Synthesizer 中的方法
从指定的 MIDI 音库中卸载指定修补程序所引用的乐器。
unloadZone(View) - 类 javax.swing.text.ZoneView 中的方法
卸载一个分区（将分区转换到其内存节省状态）。
unlock() - 接口 java.util.concurrent.locks.Lock 中的方法
释放锁。
unlock() - 类 java.util.concurrent.locks.ReentrantLock 中的方法
试图释放此锁。
unlock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 中的方法
试图释放此锁。
unlock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 中的方法
试图释放此锁。
unmappableCharacterAction() - 类 java.nio.charset.CharsetDecoder 中的方法
返回此解码器对不可映射的字符错误的当前操作。
unmappableCharacterAction() - 类 java.nio.charset.CharsetEncoder 中的方法
返回此编码器对不可映射的字符错误的当前操作。
UnmappableCharacterException - java.nio.charset 中的 异常
当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
UnmappableCharacterException(int) - 异常 java.nio.charset.UnmappableCharacterException 的构造方法
unmappableForLength(int) - 类 java.nio.charset.CoderResult 中的静态方法
静态工厂方法，返回描述给定长度的不可映射的字符错误的唯一对象。
unmarshal(String) - 类 javax.xml.bind.annotation.adapters.CollapsedStringAdapter 中的方法
移除作为参数提供的字符串的前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。
unmarshal(String) - 类 javax.xml.bind.annotation.adapters.HexBinaryAdapter 中的方法
unmarshal(String) - 类 javax.xml.bind.annotation.adapters.NormalizedStringAdapter 中的方法
移除作为参数给定的字符串的前导空白和尾部空白，然后用单个空白字符“ ”替换所有制表符、CR 和 LF。
unmarshal(ValueType) - 类 javax.xml.bind.annotation.adapters.XmlAdapter 中的方法
将 value 类型转换为 bound 类型。
unmarshal(XmlNode) - 类 javax.xml.bind.Binder 中的方法
将 XML 信息集视图解组为 JAXB 对象树。
unmarshal(XmlNode, Class<T>) - 类 javax.xml.bind.Binder 中的方法
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
unmarshal(Source) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLReader, InputSource) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
使用指定的 XMLReader 和 InputSource 解组对象。
unmarshal(InputSource) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(URL) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(File) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(InputStream) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(Reader) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLEventReader) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLStreamReader) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(Node, Class<T>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(Source, Class<T>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLStreamReader, Class<T>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(XMLEventReader, Class<T>) - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的方法
unmarshal(File) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的文件解组 XML 数据并返回得到的内容树。
unmarshal(InputStream) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 InputStream 解组 XML 数据并返回得到的内容树。
unmarshal(Reader) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 Reader 解组 XML 数据并返回得到的内容树。
unmarshal(URL) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 URL 解组 XML 数据并返回得到的内容树。
unmarshal(InputSource) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。
unmarshal(Node) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。
unmarshal(Node, Class<T>) - 接口 javax.xml.bind.Unmarshaller 中的方法
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
unmarshal(Source) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 XML Source 解组 XML 数据并返回得到的内容树。
unmarshal(Source, Class<T>) - 接口 javax.xml.bind.Unmarshaller 中的方法
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
unmarshal(XMLStreamReader) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
unmarshal(XMLStreamReader, Class<T>) - 接口 javax.xml.bind.Unmarshaller 中的方法
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
unmarshal(XMLEventReader) - 接口 javax.xml.bind.Unmarshaller 中的方法
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。
unmarshal(XMLEventReader, Class<T>) - 接口 javax.xml.bind.Unmarshaller 中的方法
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
unmarshal(DataInputStream) - 接口 org.omg.CORBA.CustomMarshal 中的方法
必须通过自定义的 Marshal 类实现 unmarshal 方法。
UnmarshalException - java.rmi 中的 异常
在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。
UnmarshalException(String) - 异常 java.rmi.UnmarshalException 的构造方法
构造带指定详细消息的 UnmarshalException。
UnmarshalException(String, Exception) - 异常 java.rmi.UnmarshalException 的构造方法
构造带指定详细消息和嵌入异常的 UnmarshalException。
UnmarshalException - javax.xml.bind 中的 异常
此异常指示在执行阻止 JAXB 提供者完成操作的解组操作时遇到一个错误。
UnmarshalException(String) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带指定详细消息的 UnmarshalException。
UnmarshalException(String, String) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 UnmarshalException。
UnmarshalException(Throwable) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带有一个 linkedException 的 UnmarshalException。
UnmarshalException(String, Throwable) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带指定详细消息和 linkedException 的 UnmarshalException。
UnmarshalException(String, String, Throwable) - 异常 javax.xml.bind.UnmarshalException 的构造方法
构造带指定详细消息、特定于供应商的 errorCode 和 linkedException 的 UnmarshalException。
unmarshalKeyInfo(XMLStructure) - 类 javax.xml.crypto.dsig.keyinfo.KeyInfoFactory 中的方法
根据特定于机制的 XMLStructure（比如：DOMStructure）实例解组新的 KeyInfo 实例。
Unmarshaller - javax.xml.bind 中的 接口
Unmarshaller 类管理将 XML 数据反序列化为新创建的 Java 内容树的过程，并可在解组时有选择地验证 XML 数据。
Unmarshaller.Listener - javax.xml.bind 中的 类

向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

Unmarshaller.Listener() - 类 javax.xml.bind.Unmarshaller.Listener 的构造方法
UnmarshallerHandler - javax.xml.bind 中的 接口
作为 SAX ContentHandler 实现的 Unmarshaller。
unmarshalXMLSignature(XMLValidateContext) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
从特定于机制的 XMLValidateContext 实例解组新的 XMLSignature 实例。
unmarshalXMLSignature(XMLStructure) - 类 javax.xml.crypto.dsig.XMLSignatureFactory 中的方法
从特定于机制的 XMLStructure 实例解组新的 XMLSignature 实例。
UnmodifiableClassException - java.lang.instrument 中的 异常
在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。
UnmodifiableClassException() - 异常 java.lang.instrument.UnmodifiableClassException 的构造方法
构造不带详细消息的 UnmodifiableClassException。
UnmodifiableClassException(String) - 异常 java.lang.instrument.UnmodifiableClassException 的构造方法
构造具有指定详细消息的 UnmodifiableClassException。
unmodifiableCollection(Collection<? extends T>) - 类 java.util.Collections 中的静态方法
返回指定 collection 的不可修改视图。
unmodifiableList(List<? extends T>) - 类 java.util.Collections 中的静态方法
返回指定列表的不可修改视图。
unmodifiableMap(Map<? extends K, ? extends V>) - 类 java.util.Collections 中的静态方法
返回指定映射的不可修改视图。
unmodifiableSet(Set<? extends T>) - 类 java.util.Collections 中的静态方法
返回指定 set 的不可修改视图。
UnmodifiableSetException - javax.print.attribute 中的 异常
当由于设置不可修改而无法执行请求的操作时，抛出该异常。
UnmodifiableSetException() - 异常 javax.print.attribute.UnmodifiableSetException 的构造方法
构造不带详细消息的 UnsupportedOperationException。
UnmodifiableSetException(String) - 异常 javax.print.attribute.UnmodifiableSetException 的构造方法
构造带指定详细消息的 UnmodifiableSetException。
unmodifiableSortedMap(SortedMap<K, ? extends V>) - 类 java.util.Collections 中的静态方法
返回指定有序映射的不可修改视图。
unmodifiableSortedSet(SortedSet<T>) - 类 java.util.Collections 中的静态方法
返回指定有序 set 的不可修改视图。
unmodifiableView(AttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建给定属性集的不可修改的视图。
unmodifiableView(DocAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定文档属性集的不可修改的视图。
unmodifiableView(PrintRequestAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印请求属性集的不可修改的视图。
unmodifiableView(PrintJobAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印作业属性集的不可修改的视图。
unmodifiableView(PrintServiceAttributeSet) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
创建一个给定打印服务属性集的不可修改的视图。
UNNECESSARY - 类 java.awt.GraphicsConfigTemplate 中的静态变量
用于“枚举”（整数）类型的值。
unpack(InputStream, JarOutputStream) - 接口 java.util.jar.Pack200.Unpacker 中的方法
读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
unpack(File, JarOutputStream) - 接口 java.util.jar.Pack200.Unpacker 中的方法
读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
unpark(Thread) - 类 java.util.concurrent.locks.LockSupport 中的静态方法
如果给定线程的许可尚不可用，则使其可用。
unparsedEntityDecl(String, String, String, String) - 接口 org.xml.sax.DTDHandler 中的方法
接收未解析的实体声明事件的通知。
unparsedEntityDecl(String, String, String, String) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收未解析的实体声明的通知。
unparsedEntityDecl(String, String, String, String) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收未解析实体声明的通知。
unparsedEntityDecl(String, String, String, String) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个未解析实体声明事件。
unquote(String) - 类 javax.management.ObjectName 中的静态方法
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。
unread(int) - 类 java.io.PushbackInputStream 中的方法
推回一个字节：将其复制到推回缓冲区之前。
unread(byte[], int, int) - 类 java.io.PushbackInputStream 中的方法
推回 byte 数组的某一部分：将其复制到推回缓冲区之前。
unread(byte[]) - 类 java.io.PushbackInputStream 中的方法
推回一个 byte 数组：将其复制到推回缓冲区之前。
unread(int) - 类 java.io.PushbackReader 中的方法
推回单个字符：将其复制到推回缓冲区的前面。
unread(char[], int, int) - 类 java.io.PushbackReader 中的方法
推回字符数组的某一部分，方法是将其复制到推回缓冲区的前面。
unread(char[]) - 类 java.io.PushbackReader 中的方法
推回一个字符数组，方法是将其复制到推回缓冲区前面。
UnrecoverableEntryException - java.security 中的 异常
如果 keystore 中的某项无法恢复，则抛出此异常。
UnrecoverableEntryException() - 异常 java.security.UnrecoverableEntryException 的构造方法
构造不带详细消息的 UnrecoverableEntryException。
UnrecoverableEntryException(String) - 异常 java.security.UnrecoverableEntryException 的构造方法
构造具有指定详细消息的 UnrecoverableEntryException，其提供了有关为什么抛出此异常的更多信息。
UnrecoverableKeyException - java.security 中的 异常
如果 keystore 中的密钥无法恢复，则抛出此异常。
UnrecoverableKeyException() - 异常 java.security.UnrecoverableKeyException 的构造方法
构造不带详细消息的 UnrecoverableKeyException。
UnrecoverableKeyException(String) - 异常 java.security.UnrecoverableKeyException 的构造方法
构造具有指定详细消息的 UnrecoverableKeyException，其提供了有关为什么抛出此异常的更多信息。
Unreferenced - java.rmi.server 中的 接口
远程对象实现应该实现 Unreferenced 接口，以便在没有多个引用该对象的客户机时接收通知。
unreferenced() - 接口 java.rmi.server.Unreferenced 中的方法
在运行时确定引用列表（引用远程对象的客户机列表）变空之后的某个时候由 RMI 运行时调用。
unreferenced() - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
unregister(ActivationID) - 类 java.rmi.activation.Activatable 中的静态方法
为与 id 关联的激活描述符撤消前面的注册。
unregister_value_factory(String) - 类 org.omg.CORBA_2_3.ORB 中的方法
unregisterComponent(JComponent) - 类 javax.swing.ToolTipManager 中的方法
从工具提示控件中移除一个组件。
unregisterGroup(ActivationGroupID) - 接口 java.rmi.activation.ActivationSystem 中的方法
移除激活组。
unregisterKeyboardAction(KeyStroke) - 类 javax.swing.JComponent 中的方法
此方法现在已过时。
unregisterKeyboardActions() - 类 javax.swing.plaf.basic.BasicDesktopPaneUI 中的方法
unregisterListeners() - 类 java.awt.dnd.DragGestureRecognizer 中的方法
向该 Component 取消注册此 DragGestureRecognizer 的 Listeners。
unregisterListeners() - 类 java.awt.dnd.MouseDragGestureRecognizer 中的方法
取消注册此 DragGestureRecognizer 的 Listener 和 Component 子类必须重写此方法：
unregisterMBean(ObjectName) - 接口 javax.management.MBeanServer 中的方法
unregisterMBean(ObjectName) - 接口 javax.management.MBeanServerConnection 中的方法
从 MBean 服务器中注销一个 MBean。
unregisterMBean(ObjectName, Subject) - 接口 javax.management.remote.rmi.RMIConnection 中的方法
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
unregisterMBean(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl 中的方法
unregisterMBean(ObjectName, Subject) - 类 javax.management.remote.rmi.RMIConnectionImpl_Stub 中的方法
unregisterObject(ActivationID) - 接口 java.rmi.activation.ActivationSystem 中的方法
移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。
unregisterProvider(String) - 类 javax.sql.rowset.spi.SyncFactory 中的静态方法
从工厂 SPI 注册器移除指派的当前已注册同步提供者。
UNREGISTRATION_NOTIFICATION - 类 javax.management.MBeanServerNotification 中的静态变量
表示已注销该 MBean 的通知类型。
UnresolvedAddressException - java.nio.channels 中的 异常
试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
UnresolvedAddressException() - 异常 java.nio.channels.UnresolvedAddressException 的构造方法
构造此类的一个实例。
UnresolvedPermission - java.security 中的 类
UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。
UnresolvedPermission(String, String, String, Certificate[]) - 类 java.security.UnresolvedPermission 的构造方法
在解析权限时，创建一个新的 UnresolvedPermission，使之包含稍后实际创建指定类的 Permission 时所需的权限信息。
UnsatisfiedLinkError - java.lang 中的 错误
当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
UnsatisfiedLinkError() - 错误 java.lang.UnsatisfiedLinkError 的构造方法
构造不带详细消息的 UnsatisfiedLinkError。
UnsatisfiedLinkError(String) - 错误 java.lang.UnsatisfiedLinkError 的构造方法
构造带指定详细消息的 UnsatisfiedLinkError。
unscaledValue() - 类 java.math.BigDecimal 中的方法
返回其值为此 BigDecimal 的非标度值 的 BigInteger。
UNSELECTED_CONVERTED_TEXT_HIGHLIGHT - 类 java.awt.im.InputMethodHighlight 中的静态变量
未选定已转换文本的默认高亮显示常量。
UNSELECTED_RAW_TEXT_HIGHLIGHT - 类 java.awt.im.InputMethodHighlight 中的静态变量
未选定原文本的默认高亮显示常量。
UNSEQ_TOKEN - 异常 org.ietf.jgss.GSSException 中的静态变量
后面的标记已处理过。
UNSET - 类 javax.swing.Spring 中的静态变量
一个表示属性值尚未计算的整数值。
unsetCompression() - 类 javax.imageio.ImageWriteParam 中的方法
移除所有以前的压缩类型和质量设置。
unsetCompression() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
移除所有以前的压缩质量设置值。
unsetDecodeTables() - 类 javax.imageio.plugins.jpeg.JPEGImageReadParam 中的方法
移除当前设置的所有量化表和 Huffman 表。
unsetEncodeTables() - 类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 中的方法
移除当前设置的所有量化表和 Huffman 表。
unsetMatchColumn(int) - 接口 javax.sql.rowset.Joinable 中的方法
取消将指定的列设置为此 RowSet 对象的匹配列。
unsetMatchColumn(int[]) - 接口 javax.sql.rowset.Joinable 中的方法
取消将指定的列设置为此 RowSet 对象的匹配列。
unsetMatchColumn(String) - 接口 javax.sql.rowset.Joinable 中的方法
取消将指定的列设置为此 RowSet 对象的匹配列。
unsetMatchColumn(String[]) - 接口 javax.sql.rowset.Joinable 中的方法
取消将指定的列设置为此 RowSet 对象的匹配列。
unsetOrdering(Class<T>, T, T) - 类 javax.imageio.spi.ServiceRegistry 中的方法
为给定类别中的两个服务提供者对象设置配对排序。
unsetTiling() - 类 javax.imageio.ImageWriteParam 中的方法
移除通过调用 setTiling 指定的所有以前的 tile 网格参数。
UnsolicitedNotification - javax.naming.ldap 中的 接口
此接口表示在 RFC 2251 中定义的未经请求的通知。
UnsolicitedNotificationEvent - javax.naming.ldap 中的 类
此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。
UnsolicitedNotificationEvent(Object, UnsolicitedNotification) - 类 javax.naming.ldap.UnsolicitedNotificationEvent 的构造方法
构造一个新的 UnsolicitedNotificationEvent 实例。
UnsolicitedNotificationListener - javax.naming.ldap 中的 接口
此接口用于处理 UnsolicitedNotificationEvent。
UNSPECIFIED_EVENT_TYPE_ERR - 异常 org.w3c.dom.events.EventException 中的静态变量
如果 Event 的类型不是在调用该方法之前通过初始化该事件指定的。
UNSPECIFIED_OPTION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
未指定的选项类型。
UNSUPPORTED_COMPRESSION - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统取消了作业，这是因为打印机尝试解压缩文档数据时确定该压缩实际上不在打印机所支持的文档数据中。
UNSUPPORTED_DOCUMENT_FORMAT - 类 javax.print.attribute.standard.JobStateReason 中的静态变量
系统中止了作业，因为文档数据的文档格式（doc flavor）不在打印机所支持的格式中。
UNSUPPORTED_EMPTY_COLLECTION - 类 java.security.Policy 中的静态变量
一个空的只读 PermissionCollection 实例。
UNSUPPORTED_POLICY - org.omg.CORBA 中的 接口
在所请求的 Policy 被 ORB 认为是有效的，但目前不受支持时将被填充的一个 PolicyErrorCode。
UNSUPPORTED_POLICY_VALUE - org.omg.CORBA 中的 接口
当所请求的 Policy 值是有效类型并且在该类型的有效范围内，但该有效值目前不受支持时将被填充的 PolicyErrorCode。
UnsupportedAddressTypeException - java.nio.channels 中的 异常
试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。
UnsupportedAddressTypeException() - 异常 java.nio.channels.UnsupportedAddressTypeException 的构造方法
构造此类的一个实例。
UnsupportedAudioFileException - javax.sound.sampled 中的 异常
UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。
UnsupportedAudioFileException() - 异常 javax.sound.sampled.UnsupportedAudioFileException 的构造方法
构造将 null 作为其错误详细消息的 UnsupportedAudioFileException。
UnsupportedAudioFileException(String) - 异常 javax.sound.sampled.UnsupportedAudioFileException 的构造方法
构造具有指定详细消息的 UnsupportedAudioFileException。
UnsupportedCallbackException - javax.security.auth.callback 中的 异常
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。
UnsupportedCallbackException(Callback) - 异常 javax.security.auth.callback.UnsupportedCallbackException 的构造方法
构造不带详细消息的 UnsupportedCallbackException。
UnsupportedCallbackException(Callback, String) - 异常 javax.security.auth.callback.UnsupportedCallbackException 的构造方法
构造带指定详细消息的 UnsupportedCallbackException。
UnsupportedCharsetException - java.nio.charset 中的 异常
当不支持请求的 charset 时，抛出此未经检查的异常。
UnsupportedCharsetException(String) - 异常 java.nio.charset.UnsupportedCharsetException 的构造方法
构造此类的一个实例。
UnsupportedClassVersionError - java.lang 中的 错误
当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
UnsupportedClassVersionError() - 错误 java.lang.UnsupportedClassVersionError 的构造方法
构造不带详细消息的 UnsupportedClassVersionError。
UnsupportedClassVersionError(String) - 错误 java.lang.UnsupportedClassVersionError 的构造方法
构造带指定详细消息的 UnsupportedClassVersionError。
UnsupportedDataTypeException - javax.activation 中的 异常
当请求操作不支持请求的数据类型时，抛出此异常。
UnsupportedDataTypeException() - 异常 javax.activation.UnsupportedDataTypeException 的构造方法
构造不带详细消息的 UnsupportedDataTypeException。
UnsupportedDataTypeException(String) - 异常 javax.activation.UnsupportedDataTypeException 的构造方法
构造带指定消息的 UnsupportedDataTypeException。
UnsupportedEncodingException - java.io 中的 异常
不支持字符编码。
UnsupportedEncodingException() - 异常 java.io.UnsupportedEncodingException 的构造方法
构造不带详细消息的 UnsupportedEncodingException。
UnsupportedEncodingException(String) - 异常 java.io.UnsupportedEncodingException 的构造方法
构造带详细消息的 UnsupportedEncodingException。
UnsupportedFlavorException - java.awt.datatransfer 中的 异常
在此 flavor 中不支持所请求的数据的信号。
UnsupportedFlavorException(DataFlavor) - 异常 java.awt.datatransfer.UnsupportedFlavorException 的构造方法
构造一个 UnsupportedFlavorException。
UnsupportedLookAndFeelException - javax.swing 中的 异常
指示在用户系统上不存在请求的外观管理类的异常。
UnsupportedLookAndFeelException(String) - 异常 javax.swing.UnsupportedLookAndFeelException 的构造方法
构造一个 UnsupportedLookAndFeelException 对象。
UnsupportedOperationException - java.lang 中的 异常
当不支持请求的操作时，抛出该异常。
UnsupportedOperationException() - 异常 java.lang.UnsupportedOperationException 的构造方法
构造不带详细消息的 UnsupportedOperationException。
UnsupportedOperationException(String) - 异常 java.lang.UnsupportedOperationException 的构造方法
构造带指定详细消息的 UnsupportedOperationException。
UnsupportedOperationException(String, Throwable) - 异常 java.lang.UnsupportedOperationException 的构造方法
根据指定的详细消息和原因，构造一个新异常。
UnsupportedOperationException(Throwable) - 异常 java.lang.UnsupportedOperationException 的构造方法
根据指定的原因和 (cause==null ? null :cause.toString())（它通常包含了 cause 的类和详细消息）的详细消息，构造一个新异常。
unsynchronize(Line[]) - 接口 javax.sound.sampled.Mixer 中的方法
释放指定行的同步。
unwrap(Class<T>) - 接口 java.sql.Wrapper 中的方法
返回一个对象，该对象实现给定接口，以允许访问非标准方法或代理未公开的标准方法。
unwrap(byte[], String, int) - 类 javax.crypto.Cipher 中的方法
解包一个以前包装的密钥。
unwrap(ByteBuffer, ByteBuffer) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
unwrap(ByteBuffer, ByteBuffer[]) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
unwrap(ByteBuffer, ByteBuffer[], int, int) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
unwrap(byte[], int, int) - 接口 javax.security.sasl.SaslClient 中的方法
解包接收自服务器的 byte 数组。
unwrap(byte[], int, int) - 接口 javax.security.sasl.SaslServer 中的方法
解包接收自客户端的 byte 数组。
unwrap(Class<T>) - 类 javax.sql.rowset.RowSetMetaDataImpl 中的方法
返回实现给定接口以允许访问非标准方法，或者代理未公开标准方法的的对象。
unwrap(byte[], int, int, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
用来处理在上下文的另一方由 wrap 方法生成的标记。
unwrap(InputStream, OutputStream, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
使用流来处理在上下文的另一方由 wrap 方法生成的标记。
UNWRAP_MODE - 类 javax.crypto.Cipher 中的静态变量
用于将 Cipher 初始化为密钥解包模式的常量。
UP - 类 java.awt.Event 中的静态变量
Up Arrow 键，一个非 ASCII 操作键。
UP_CYCLE_TRAVERSAL_KEYS - 类 java.awt.KeyboardFocusManager 中的静态变量
Up Cycle 焦点遍历键的标识符。
upAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
用于将插入符在逻辑上向上移动一个位置的动作名称。
UPDATABLE_VIEW_SYNC - 类 javax.sql.rowset.spi.SyncProvider 中的静态变量
指示 SyncProvider 实现支持 RowSet 对象和用于填充它的 SQL VIEW 之间的同步。
update(Graphics) - 类 java.awt.Canvas 中的方法
更新此 canvas。
update(Graphics) - 类 java.awt.Component 中的方法
更新组件。
update(Graphics) - 类 java.awt.Container 中的方法
更新容器。
UPDATE - 类 java.awt.event.PaintEvent 中的静态变量
更新事件类型。
update() - 类 java.awt.SplashScreen 中的方法
用当前叠加图像的上下文来更新闪现屏幕窗口。
update(byte) - 类 java.security.MessageDigest 中的方法
使用指定的字节更新摘要。
update(byte[], int, int) - 类 java.security.MessageDigest 中的方法
使用指定的 byte 数组，从指定的偏移量开始更新摘要。
update(byte[]) - 类 java.security.MessageDigest 中的方法
使用指定的 byte 数组更新摘要。
update(ByteBuffer) - 类 java.security.MessageDigest 中的方法
使用指定的 ByteBuffer 更新摘要。
update(byte) - 类 java.security.Signature 中的方法
更新要由字节签名或验证的数据。
update(byte[]) - 类 java.security.Signature 中的方法
使用指定的 byte 数组更新要签名或验证的数据。
update(byte[], int, int) - 类 java.security.Signature 中的方法
从指定的偏移量开始，使用指定的 byte 数组更新要签名或验证的数据。
update(ByteBuffer) - 类 java.security.Signature 中的方法
使用指定的 ByteBuffer 更新要签名或验证的数据。
update(Observable, Object) - 接口 java.util.Observer 中的方法
只要改变了 observable 对象就调用此方法。
update(int) - 类 java.util.zip.Adler32 中的方法
使用指定字节更新校验和。
update(byte[], int, int) - 类 java.util.zip.Adler32 中的方法
使用指定的字节数组更新校验和。
update(byte[]) - 类 java.util.zip.Adler32 中的方法
使用指定的字节数组更新校验和。
update(int) - 接口 java.util.zip.Checksum 中的方法
使用指定字节更新当前校验和。
update(byte[], int, int) - 接口 java.util.zip.Checksum 中的方法
使用指定的字节数组更新当前校验和。
update(int) - 类 java.util.zip.CRC32 中的方法
使用指定字节更新 CRC-32。
update(byte[], int, int) - 类 java.util.zip.CRC32 中的方法
使用指定的字节数组更新 CRC-32。
update(byte[]) - 类 java.util.zip.CRC32 中的方法
使用指定的字节数组更新校验和。
UPDATE - 接口 javax.accessibility.AccessibleTableModelChange 中的静态变量
标识现有数据的更改。
update(byte[]) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(byte[], int, int) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(byte[], int, int, byte[]) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(byte[], int, int, byte[], int) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(ByteBuffer, ByteBuffer) - 类 javax.crypto.Cipher 中的方法
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
update(byte) - 类 javax.crypto.Mac 中的方法
处理给定的字节。
update(byte[]) - 类 javax.crypto.Mac 中的方法
处理给定的 byte 数组。
update(byte[], int, int) - 类 javax.crypto.Mac 中的方法
从 offset（包含）开始，处理 input 中的前 len 个字节。
update(ByteBuffer) - 类 javax.crypto.Mac 中的方法
从 input.position() 开始，处理 ByteBuffer input 中的 input.remaining() 个字节。
update(LineEvent) - 接口 javax.sound.sampled.LineListener 中的方法
通知侦听器行的状态已发生更改。
update(Graphics) - 类 javax.swing.CellRendererPane 中的方法
不应调用。
UPDATE - 类 javax.swing.event.TableModelEvent 中的静态变量
标识现有数据的更改。
update(Graphics) - 类 javax.swing.JApplet 中的方法
调用 paint(g)。
update(Graphics) - 类 javax.swing.JComponent 中的方法
调用 paint。
update(Graphics) - 类 javax.swing.JDialog 中的方法
调用 paint(g)。
update(Graphics) - 类 javax.swing.JFrame 中的方法
只是调用 paint(g)。
update(Graphics) - 类 javax.swing.JWindow 中的方法
调用 paint(g)。
update(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicMenuItemUI 中的方法
使用 paintMenuItem() 绘制背景，从而重写 update（默认情况下填充不透明组件的背景）以调用 paint()。
update(Graphics, JComponent) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
超类以无法控制的方式绘制背景（即有人可能希望将图像平铺在背景中）。
update(Graphics, JComponent) - 类 javax.swing.plaf.ComponentUI 中的方法
通知此 UI 委托开始绘制指定的组件。
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalButtonUI 中的方法
如果必要，绘制组件的背景，然后调用 paint。
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalMenuBarUI 中的方法
如果必要，绘制组件的背景，然后调用 paint。
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalTabbedPaneUI 中的方法
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalToggleButtonUI 中的方法
如果必要，绘制组件的背景，然后调用 paint。
update(Graphics, JComponent) - 类 javax.swing.plaf.metal.MetalToolBarUI 中的方法
如果必要，绘制组件的背景，然后调用 paint。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiButtonUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiColorChooserUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiComboBoxUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiDesktopIconUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiDesktopPaneUI 中的方法
在此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiFileChooserUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiInternalFrameUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiLabelUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiListUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiMenuBarUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiMenuItemUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiOptionPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiPanelUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiPopupMenuUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiProgressBarUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiRootPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiScrollBarUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiScrollPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSeparatorUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSliderUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSpinnerUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiSplitPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTabbedPaneUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTableHeaderUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTableUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiToolBarUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiToolTipUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiTreeUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
update(Graphics, JComponent) - 类 javax.swing.plaf.multi.MultiViewportUI 中的方法
在由此对象处理的每个 UI 上调用 update 方法。
UPDATE_ROW_CONFLICT - 接口 javax.sql.rowset.spi.SyncResolver 中的静态变量
指示在 RowSet 对象试图更新数据源中的行时发生冲突。
UPDATE_WHEN_ON_EDT - 类 javax.swing.text.DefaultCaret 中的静态变量
指示只有在事件调度线程中执行文档更改时，才更新插入符位置。
updateArray(int, Array) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Array 值更新指定列。
updateArray(String, Array) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Array 值更新指定列。
updateAsciiStream(int, InputStream, int) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定列，该列将具有指定字节数。
updateAsciiStream(String, InputStream, int) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定列，该列具有指定的字节数。
updateAsciiStream(int, InputStream, long) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定的列，该值将具有指定的字节数。
updateAsciiStream(String, InputStream, long) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定的列，该值将具有指定的字节数。
updateAsciiStream(int, InputStream) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定的列。
updateAsciiStream(String, InputStream) - 接口 java.sql.ResultSet 中的方法
用 ascii 流值更新指定列。
updateAutoscroll(Point) - 类 java.awt.dnd.DropTarget 中的方法
使用当前的光标位置更新自动滚动
updateBigDecimal(int, BigDecimal) - 接口 java.sql.ResultSet 中的方法
用 java.math.BigDecimal 值更新指定列。
updateBigDecimal(String, BigDecimal) - 接口 java.sql.ResultSet 中的方法
用 java.sql.BigDecimal 值更新指定列。
updateBinaryStream(int, InputStream, int) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定列，该列将具有指定字节数。
updateBinaryStream(String, InputStream, int) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定列，该列具有指定的字节数。
updateBinaryStream(int, InputStream, long) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定的列，该值将具有指定的字节数。
updateBinaryStream(String, InputStream, long) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定的列，该值将具有指定的字节数。
updateBinaryStream(int, InputStream) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定的列。
updateBinaryStream(String, InputStream) - 接口 java.sql.ResultSet 中的方法
用二进制流值更新指定列。
updateBlob(int, Blob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Blob 值更新指定列。
updateBlob(String, Blob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Blob 值更新指定列。
updateBlob(int, InputStream, long) - 接口 java.sql.ResultSet 中的方法
使用给定输入流更新指定的列，该流将具有指定的字节数。
updateBlob(String, InputStream, long) - 接口 java.sql.ResultSet 中的方法
使用给定输入流更新指定列，该流将具有指定的字节数。
updateBlob(int, InputStream) - 接口 java.sql.ResultSet 中的方法
使用给定输入流值更新指定列。
updateBlob(String, InputStream) - 接口 java.sql.ResultSet 中的方法
使用给定输入流值更新指定列。
updateBoolean(int, boolean) - 接口 java.sql.ResultSet 中的方法
用 boolean 值更新指定列。
updateBoolean(String, boolean) - 接口 java.sql.ResultSet 中的方法
用 boolean 值更新指定列。
updateButtonMnemonic - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
updateButtonText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
updateButtonToolTipText - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
updateByte(int, byte) - 接口 java.sql.ResultSet 中的方法
用 byte 值更新指定列。
updateByte(String, byte) - 接口 java.sql.ResultSet 中的方法
用 byte 值更新指定列。
updateBytes(int, byte[]) - 接口 java.sql.ResultSet 中的方法
用 byte 数组值更新指定列。
updateBytes(String, byte[]) - 接口 java.sql.ResultSet 中的方法
用字节数组值更新指定列。
updateCachedPreferredSize() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
更新 preferredSize 实例变量，该变量从 getPreferredSize() 返回。
updateCellEditor() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
基于包含所在的 JTree 的可编辑性更新 cellEditor。
updateCharacterStream(int, Reader, int) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定列，该列将具有指定字节数。
updateCharacterStream(String, Reader, int) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定列，该列具有指定的字节数。
updateCharacterStream(int, Reader, long) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列，该值将具有指定的字节数。
updateCharacterStream(String, Reader, long) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列，该值将具有指定的字节数。
updateCharacterStream(int, Reader) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列。
updateCharacterStream(String, Reader) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定列。
updateChildren(DocumentEvent.ElementChange, DocumentEvent, ViewFactory) - 类 javax.swing.text.View 中的方法
更新子视图以响应接收模型变化的通知，并且有一条此视图负责的元素的变化记录。
updateChildren(DocumentEvent.ElementChange, DocumentEvent, ViewFactory) - 类 javax.swing.text.ZoneView 中的方法
超类行为将试图更新子视图，而在这种情况下并不需要这样做，因为子级是分区并且不受关联元素变化的直接影响。
updateChooser() - 类 javax.swing.colorchooser.AbstractColorChooserPanel 中的方法
在模型状态更改时自动调用。
updateClob(int, Clob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Clob 值更新指定列。
updateClob(String, Clob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Clob 值更新指定列。
updateClob(int, Reader, long) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
updateClob(String, Reader, long) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
updateClob(int, Reader) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列。
updateClob(String, Reader) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列。
updateColumnHeader(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
updateComponents() - 类 javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager 中的方法
确定组件。
updateComponentTreeUI(Component) - 类 javax.swing.SwingUtilities 中的静态方法
简单的外观更改：将树结构中的每个节点转到 updateUI() -- 也就是说，通过当前外观初始化其 UI 属性。
updateCurrentCursor(int, int, int) - 类 java.awt.dnd.DragSourceContext 中的方法
如果默认拖动光标行为处于活动状态，则此方法将为默认拖动光标设置受拖动源、放置目标动作和状态支持的指定动作，否则此方法不执行任何操作。
updateDamage(DocumentEvent, Shape, ViewFactory) - 类 javax.swing.text.PlainView 中的方法
重新绘制给定文档事件覆盖的更改区域。
updateDate(int, Date) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Date 值更新指定列。
updateDate(String, Date) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Date 值更新指定列。
updateDepthOffset() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
更新每次应该偏移的深度量。
updateDouble(int, double) - 接口 java.sql.ResultSet 中的方法
用 double 值更新指定列。
updateDouble(String, double) - 接口 java.sql.ResultSet 中的方法
用 double 值更新指定列。
updateExpandedDescendants(TreePath) - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
通过从树获取展开的子代并将其转发到树状态来更新 path 的所有子代的展开状态。
updateFloat(int, float) - 接口 java.sql.ResultSet 中的方法
用 float 值更新指定列。
updateFloat(String, float) - 接口 java.sql.ResultSet 中的方法
用 float 值更新指定列。
updateInt(int, int) - 接口 java.sql.ResultSet 中的方法
用 int 值更新指定列。
updateInt(String, int) - 接口 java.sql.ResultSet 中的方法
用 int 值更新指定列。
updateJAXB(XmlNode) - 类 javax.xml.bind.Binder 中的方法
取一个 XML 节点，并更新与其关联的 JAXB 对象和该对象的子级。
updateLabelUIs() - 类 javax.swing.JSlider 中的方法
通过在每个标签上调用 updateUI 更新标签表中标签的 UI。
updateLayout(DocumentEvent.ElementChange, DocumentEvent, Shape) - 类 javax.swing.text.AsyncBoxView 中的方法
更新布局，以响应从模型接收的更改通知。
updateLayout(DocumentEvent.ElementChange, DocumentEvent, Shape) - 类 javax.swing.text.View 中的方法
更新布局，以响应从模型接受的更改通知。
updateLayoutCacheExpandedNodes() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
让在 JTree 中展开的所有节点在 LayoutCache 中展开。
updateLayoutState() - 类 javax.swing.plaf.basic.BasicListUI 中的方法
基于当前字体和 fixedCellWidth、fixedCellHeight 和 prototypeCellValue 的当前值重新计算 cellHeight（一个或多个）和 cellWidth 的值。
updateLayoutStateNeeded - 类 javax.swing.plaf.basic.BasicListUI 中的变量
updateLeadIndex() - 类 javax.swing.tree.DefaultTreeSelectionModel 中的方法
更新 leadIndex 实例变量。
updateLevel - 类 javax.swing.undo.UndoableEditSupport 中的变量
updateListBoxSelectionForEvent(MouseEvent, boolean) - 类 javax.swing.plaf.basic.BasicComboPopup 中的方法
供事件侦听器使用的实用程序方法。
updateListeners - 类 javax.imageio.ImageReader 中的变量
当前已注册 IIOReadUpdateListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
updateLocation(Point) - 类 java.awt.dnd.DropTarget.DropTargetAutoScroller 中的方法
导致发生自动滚动
updateLong(int, long) - 接口 java.sql.ResultSet 中的方法
用 long 值更新指定列。
updateLong(String, long) - 接口 java.sql.ResultSet 中的方法
用 long 值更新指定列。
updateMetrics() - 类 javax.swing.text.PlainView 中的方法
检查字体规格和最长行是否最新。
updateNCharacterStream(int, Reader, long) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列，该值将具有指定的字节数。
updateNCharacterStream(String, Reader, long) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列，该值将具有指定的字节数。
updateNCharacterStream(int, Reader) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列。
updateNCharacterStream(String, Reader) - 接口 java.sql.ResultSet 中的方法
用字符流值更新指定的列。
updateNClob(int, NClob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.NClob 值更新指定的列。
updateNClob(String, NClob) - 接口 java.sql.ResultSet 中的方法
用 java.sql.NClob 值更新指定的列。
updateNClob(int, Reader, long) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
updateNClob(String, Reader, long) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
updateNClob(int, Reader) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列。
updateNClob(String, Reader) - 接口 java.sql.ResultSet 中的方法
使用给定的 Reader 对象更新指定列。
updateNString(int, String) - 接口 java.sql.ResultSet 中的方法
用 String 值更新指定的列。
updateNString(String, String) - 接口 java.sql.ResultSet 中的方法
用 String 值更新指定的列。
updateNull(int) - 接口 java.sql.ResultSet 中的方法
用 null 值更新指定列。
updateNull(String) - 接口 java.sql.ResultSet 中的方法
用 null 值更新指定列。
updateObject(int, Object, int) - 接口 java.sql.ResultSet 中的方法
用 Object 值更新指定列。
updateObject(int, Object) - 接口 java.sql.ResultSet 中的方法
用 Object 值更新指定列。
updateObject(String, Object, int) - 接口 java.sql.ResultSet 中的方法
用 Object 值更新指定列。
updateObject(String, Object) - 接口 java.sql.ResultSet 中的方法
用 Object 值更新指定列。
updateRef(int, Ref) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Ref 值更新指定列。
updateRef(String, Ref) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Ref 值更新指定列。
updateRenderer(JComponent, String) - 类 javax.swing.plaf.basic.BasicHTML 中的静态方法
将给定文本的 HTML 渲染器隐藏在给定 JComponent 的客户端属性中。
updateRenderer() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
当渲染器更改时从所处的树中传递消息。
updateRoleMap(String, Role, List<ObjectName>) - 类 javax.management.relation.RelationService 中的方法
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
updateRoleMap(String, Role, List<ObjectName>) - 接口 javax.management.relation.RelationServiceMBean 中的方法
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
updateRow() - 接口 java.sql.ResultSet 中的方法
用此 ResultSet 对象的当前行的新内容更新底层数据库。
updateRowHeader(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
updateRowId(int, RowId) - 接口 java.sql.ResultSet 中的方法
用 RowId 值更新指定列。
updateRowId(String, RowId) - 接口 java.sql.ResultSet 中的方法
用 RowId 值更新指定的列。
updatesAreDetected(int) - 接口 java.sql.DatabaseMetaData 中的方法
获取是否可以通过调用 ResultSet.rowUpdated 方法检测可见行的更新。
updateScrollBarDisplayPolicy(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
updateShort(int, short) - 接口 java.sql.ResultSet 中的方法
用 short 值更新指定列。
updateShort(String, short) - 接口 java.sql.ResultSet 中的方法
用 short 值更新指定列。
updateSize() - 类 javax.swing.plaf.basic.BasicTreeUI 中的方法
将缓存大小标记为无效并使用 treeDidChange 传递树的信息。
updateSQLXML(int, SQLXML) - 接口 java.sql.ResultSet 中的方法
用 java.sql.SQLXML 值更新指定列。
updateSQLXML(String, SQLXML) - 接口 java.sql.ResultSet 中的方法
用 java.sql.SQLXML 值更新指定的列。
updateString(int, String) - 接口 java.sql.ResultSet 中的方法
用 String 值更新指定列。
updateString(String, String) - 接口 java.sql.ResultSet 中的方法
用 String 值更新指定列。
updateStyles(Component) - 类 javax.swing.plaf.synth.SynthLookAndFeel 中的静态方法
更新与 c 关联的样式以及其所有子样式。
updateTableInRealTime - 类 javax.swing.table.JTableHeader 中的变量
从 Java 2 platform v1.3 开始已过时。
updateTime(int, Time) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Time 值更新指定列。
updateTime(String, Time) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Time 值更新指定列。
updateTimestamp(int, Timestamp) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Timestamp 值更新指定列。
updateTimestamp(String, Timestamp) - 接口 java.sql.ResultSet 中的方法
用 java.sql.Timestamp 值更新指定列。
updateUI() - 类 javax.swing.AbstractButton 中的方法
将 UI 属性重置为当前外观中的一个值。
updateUI() - 类 javax.swing.JButton 中的方法
根据当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JCheckBox 中的方法
根据当前外观重置 UI 属性值。
updateUI() - 类 javax.swing.JColorChooser 中的方法
UIManager 发出的关于 L&F 已更改的通知。
updateUI() - 类 javax.swing.JComboBox 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JComponent 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JDesktopPane 中的方法
UIManager 发出的关于 L&F 已更改的通知。
updateUI() - 类 javax.swing.JFileChooser 中的方法
将 UI 属性重置为当前的外观值。
updateUI() - 类 javax.swing.JInternalFrame.JDesktopIcon 中的方法
来自 UIManager 的通知，告知外观已更改。
updateUI() - 类 javax.swing.JInternalFrame 中的方法
来自 UIManager 的通知，告知外观已更改。
updateUI() - 类 javax.swing.JLabel 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JList 中的方法
重置 ListUI 属性，将其设置为当前外观所提供的值。
updateUI() - 类 javax.swing.JMenu 中的方法
利用当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JMenuBar 中的方法
利用当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JMenuItem 中的方法
利用当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JOptionPane 中的方法
UIManager 发出的关于 L&F 已改变的通知。
updateUI() - 类 javax.swing.JPanel 中的方法
利用当前外观的值重置 UI 属性。
updateUI() - 类 javax.swing.JPasswordField 中的方法
重新加载可插入的 UI。
updateUI() - 类 javax.swing.JPopupMenu 中的方法
将 UI 属性重置为一个来自当前外观的值。
updateUI() - 类 javax.swing.JProgressBar 中的方法
将 UI 属性重置为当前外观对应的值。
updateUI() - 类 javax.swing.JRadioButton 中的方法
将 UI 属性重置为当前外观对应的值。
updateUI() - 类 javax.swing.JRootPane 中的方法
将 UI 属性重置为当前外观对应的值。
updateUI() - 类 javax.swing.JScrollBar 中的方法
重写 JComponent.updateUI。
updateUI() - 类 javax.swing.JScrollPane 中的方法
用一个来自当前默认外观的 ScrollPaneUI 替换当前的 ScrollPaneUI 对象。
updateUI() - 类 javax.swing.JSeparator 中的方法
根据当前外观将 UI 属性重设成某个值。
updateUI() - 类 javax.swing.JSlider 中的方法
根据当前外观将 UI 属性重设为某个值。
updateUI() - 类 javax.swing.JSpinner 中的方法
用取自当前外观的值重设 UI 属性。
updateUI() - 类 javax.swing.JSplitPane 中的方法
UIManager 发出的关于 L&F 已改变的通知。
updateUI() - 类 javax.swing.JTabbedPane 中的方法
从当前外观更新 UI 属性的值。
updateUI() - 类 javax.swing.JTable 中的方法
UIManager 发出的表明 L&F 已经更改的通知。
updateUI() - 类 javax.swing.JToggleButton 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JToolBar 中的方法
UIFactory 发出的关于 L&F 已更改的通知。
updateUI() - 类 javax.swing.JToolTip 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.JTree 中的方法
UIManager 发出的关于 L&F 已经更改的通知。
updateUI() - 类 javax.swing.JViewport 中的方法
将 UI 属性重置为当前外观的值。
updateUI() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
取自 UIManager 的关于外观 [L&F] 已更改的通知。
updateUI() - 类 javax.swing.table.JTableHeader 中的方法
UIManager 发出的关于 L&F 已更改的通知。
updateUI() - 类 javax.swing.text.JTextComponent 中的方法
重新加载可插入的 UI。
updateUndoPositions(Vector, int, int) - 类 javax.swing.text.GapContent 中的方法
重新设置处在 positions 的所有 UndoPosRef 实例的位置。
updateUndoPositions(Vector) - 类 javax.swing.text.StringContent 中的方法
在 positions 处重新设置所有 UndoPosRef 实例的位置。
updateViewport(PropertyChangeEvent) - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的方法
updateXML(Object) - 类 javax.xml.bind.Binder 中的方法
取一个 JAXB 对象，并更新与其关联的 XML 节点和该节点的子级。
updateXML(Object, XmlNode) - 类 javax.xml.bind.Binder 中的方法
JAXB 对象树中所做的更改在与其关联的 XML 解析树中得到更新。
upFocusCycle(Component) - 类 java.awt.DefaultKeyboardFocusManager 中的方法
将焦点上移一个焦点遍历循环。
upFocusCycle(Component) - 类 java.awt.KeyboardFocusManager 中的方法
将焦点上移一个焦点遍历循环。
upFocusCycle() - 类 java.awt.KeyboardFocusManager 中的方法
从当前焦点所有者将焦点上移一个焦点遍历循环。
upFolderIcon - 类 javax.swing.plaf.basic.BasicFileChooserUI 中的变量
upKey - 类 javax.swing.plaf.basic.BasicSplitPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
upKey - 类 javax.swing.plaf.basic.BasicTabbedPaneUI 中的变量
已过时。 从 Java 2 platform v1.3 开始。
upKey - 类 javax.swing.plaf.basic.BasicToolBarUI 中的变量
已过时。 从 Java 2 平台 v1.3 开始。
UPPER_LEADING_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的顶端开始边角。
UPPER_LEFT_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的左上角。
UPPER_RIGHT_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的右上角。
UPPER_TRAILING_CORNER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识视口的顶端结束边角。
UPPERCASE - 类 java.util.FormattableFlags 中的静态变量
根据创建 formatTo() 方法的 formatter 参数期间给出的 locale 规则，将输出转换为大写形式。
UPPERCASE_LETTER - 类 java.lang.Character 中的静态变量
Unicode 规范中的常规类别“Lu”。
upperLeft - 类 javax.swing.JScrollPane 中的变量
在左上角显示的组件。
upperLeft - 类 javax.swing.ScrollPaneLayout 中的变量
左上角显示的组件。
upperRight - 类 javax.swing.JScrollPane 中的变量
在右上角显示的组件。
upperRight - 类 javax.swing.ScrollPaneLayout 中的变量
右上角显示的组件。
URI - java.net 中的 类
表示一个统一资源标识符 (URI) 引用。
URI(String) - 类 java.net.URI 的构造方法
通过解析给定的字符串构造一个 URI。
URI(String, String, String, int, String, String, String) - 类 java.net.URI 的构造方法
根据给定的组成部分构造一个分层 URI。
URI(String, String, String, String, String) - 类 java.net.URI 的构造方法
根据给定的组成部分构造分层 URI。
URI(String, String, String, String) - 类 java.net.URI 的构造方法
根据给定的组成部分构造分层 URI。
URI(String, String, String) - 类 java.net.URI 的构造方法
根据给定的组成部分构造 URI。
uri - 类 javax.tools.SimpleJavaFileObject 中的变量
此文件对象的 URI。
URI_NS_SOAP_1_1_ENVELOPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.1 信封的名称空间标识符。
URI_NS_SOAP_1_2_ENCODING - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 编码的名称空间标识符。
URI_NS_SOAP_1_2_ENVELOPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.2 信封的名称空间标识符。
URI_NS_SOAP_ENCODING - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.1 编码的名称空间标识符。
URI_NS_SOAP_ENVELOPE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
SOAP 1.1 信封的名称空间标识符，此名称空间中的所有 SOAPElements 是由 SOAP 1.1 规范定义的。
URI_SOAP_1_2_ROLE_NEXT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
该 URI 标识将 SOAP 请求处理为 SOAP 1.2 头条目预定角色 (intended role) 的下一个应用程序（请参阅 SOAP 1.2 规范第 1 部分第 2.2 节）。
URI_SOAP_1_2_ROLE_NONE - 接口 javax.xml.soap.SOAPConstants 中的静态变量
该 URI 指定 SOAP 1.2 中的角色 None。
URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER - 接口 javax.xml.soap.SOAPConstants 中的静态变量
该 URI 标识 SOAP 1.2 消息的最终接收者。
URI_SOAP_ACTOR_NEXT - 接口 javax.xml.soap.SOAPConstants 中的静态变量
该 URI 标识将 SOAP 请求处理为 SOAP 1.1 头条目预定参与者的下一个应用程序（请参阅 SOAP 1.1 规范的第 4.2.2 节）。
URIDereferencer - javax.xml.crypto 中的 接口
URIReference 的 dereferencer。
URIException - javax.print 中的 接口
接口 URIException 是一个混合接口，PrintException 的子类可实现它来报告有关 URI 地址的错误状况。
URIInaccessible - 接口 javax.print.URIException 中的静态变量
指示打印机无法访问该 URI 地址。
URIOtherProblem - 接口 javax.print.URIException 中的静态变量
指示出于所有其他原因未明确标识的问题类别。
URIParameter - java.security 中的 类
包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。
URIParameter(URI) - 类 java.security.URIParameter 的构造方法
使用指向数据的 URI 构造一个 URIParameter，指向的数据用于 SPI 实现。
URIReference - javax.xml.crypto 中的 接口
通过 URI-Reference 标识数据对象，正如 RFC 2396 所指定的。
URIReferenceException - javax.xml.crypto 中的 异常
指示取消引用 URIReference 时抛出的异常条件。
URIReferenceException() - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造使用 null 作为其详细消息的新 URIReferenceException。
URIReferenceException(String) - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造带指定详细消息的新 URIReferenceException。
URIReferenceException(String, Throwable) - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造带指定详细消息和 cause 的新 URIReferenceException。
URIReferenceException(String, Throwable, URIReference) - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。
URIReferenceException(Throwable) - 异常 javax.xml.crypto.URIReferenceException 的构造方法
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 URIReferenceException（它通常包含 cause 的类和详细消息）。
URIResolver - javax.xml.transform 中的 接口
实现此接口的对象可由处理器进行调用，以将 document()、xsl:import 或 xsl:include 中使用的 URI 转换为 Source 对象。
URISchemeNotSupported - 接口 javax.print.URIException 中的静态变量
指示打印机不支持该 URI 地址中的 URI 方案（"http"、"ftp" 等等）。
URISyntax - javax.print.attribute 中的 类
类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。
URISyntax(URI) - 类 javax.print.attribute.URISyntax 的构造方法
构造带有指定 URI 的 URI 属性。
URISyntaxException - java.net 中的 异常
抛出经过检查的指示字符串不能解析为 URI 引用的异常。
URISyntaxException(String, String, int) - 异常 java.net.URISyntaxException 的构造方法
根据给定的输入字符串、原因和错误索引构造一个实例。
URISyntaxException(String, String) - 异常 java.net.URISyntaxException 的构造方法
根据给定的输入字符串和原因构造一个实例。
URL - java.net 中的 类
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。
URL(String, String, int, String) - 类 java.net.URL 的构造方法
根据指定 protocol、host、port 号和 file 创建 URL 对象。
URL(String, String, String) - 类 java.net.URL 的构造方法
根据指定的 protocol 名称、host 名称和 file 名称创建 URL。
URL(String, String, int, String, URLStreamHandler) - 类 java.net.URL 的构造方法
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。
URL(String) - 类 java.net.URL 的构造方法
根据 String 表示形式创建 URL 对象。
URL(URL, String) - 类 java.net.URL 的构造方法
通过在指定的上下文中对给定的 spec 进行解析创建 URL。
URL(URL, String, URLStreamHandler) - 类 java.net.URL 的构造方法
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。
url - 类 java.net.URLConnection 中的变量
URL 表示此连接要在互联网上打开的远程对象。
URL_PKG_PREFIXES - 接口 javax.naming.Context 中的静态变量
该常量保存用来指定加载 URL 上下文工厂时要使用的包前缀列表的环境属性名称。
URLClassLoader - java.net 中的 类
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。
URLClassLoader(URL[], ClassLoader) - 类 java.net.URLClassLoader 的构造方法
为给定的 URL 构造新 URLClassLoader。
URLClassLoader(URL[]) - 类 java.net.URLClassLoader 的构造方法
使用默认的委托父 ClassLoader 为指定的 URL 构造一个新 URLClassLoader。
URLClassLoader(URL[], ClassLoader, URLStreamHandlerFactory) - 类 java.net.URLClassLoader 的构造方法
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。
URLConnection - java.net 中的 类
抽象类 URLConnection 是所有类的超类，它代表应用程序和 URL 之间的通信链接。
URLConnection(URL) - 类 java.net.URLConnection 的构造方法
构造一个到指定 URL 的 URL 连接。
URLDataSource - javax.activation 中的 类
URLDataSource 类提供一个对象，此对象将 URL 对象包装在 DataSource 接口中。
URLDataSource(URL) - 类 javax.activation.URLDataSource 的构造方法
URLDataSource 构造方法。
URLDecoder - java.net 中的 类
HTML 格式解码的实用工具类。
URLDecoder() - 类 java.net.URLDecoder 的构造方法
URLEncoder - java.net 中的 类
HTML 格式编码的实用工具类。
URLStreamHandler - java.net 中的 类
抽象类 URLStreamHandler 是所有流协议处理程序的通用超类。
URLStreamHandler() - 类 java.net.URLStreamHandler 的构造方法
URLStreamHandlerFactory - java.net 中的 接口
该接口为 URL 流协议处理程序定义一个工厂。
URLStringHelper - org.omg.CosNaming.NamingContextExtPackage 中的 类
URLString 是以 String 形式表示的 URL 地址（corbaloc: 或 corbaname:）。
URLStringHelper() - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 的构造方法
US - 类 java.util.Locale 中的静态变量
用于表示国家/地区的有用常量。
USE_ACTIVE_OBJECT_MAP_ONLY - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
USE_ALL_BEANINFO - 类 java.beans.Introspector 中的静态变量
USE_DEFAULT_SERVANT - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
USE_SERVANT_MANAGER - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
USE_STD3_ASCII_RULES - 类 java.net.IDN 中的静态变量
根据 STD-3 ASCII 规则执行检查的标志。
useAnchoringBounds(boolean) - 类 java.util.regex.Matcher 中的方法
设置匹配器区域界限的定位。
useCaches - 类 java.net.URLConnection 中的变量
如果为 true，则只要有条件就允许协议使用缓存。
useDaylightTime() - 类 java.util.SimpleTimeZone 中的方法
如果此时区使用夏令时，则执行查询。
useDaylightTime() - 类 java.util.TimeZone 中的方法
查询此时区是否使用夏令时。
useDelimiter(Pattern) - 类 java.util.Scanner 中的方法
将此扫描器的分隔模式设置为指定模式。
useDelimiter(String) - 类 java.util.Scanner 中的方法
将此扫描器的分隔模式设置为从指定 String 构造的模式。
useLocale(Locale) - 类 java.util.Scanner 中的方法
将此扫描器的语言环境设置为指定的语言环境。
USEMAP - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
usePattern(Pattern) - 类 java.util.regex.Matcher 中的方法
更改此 Matcher 用于查找匹配项的 Pattern。
useProtocolVersion(int) - 类 java.io.ObjectOutputStream 中的方法
指定要在写入流时使用的流协议版本。
USER_EXCEPTION - org.omg.PortableInterceptor 中的 接口
org/omg/PortableInterceptor/USER_EXCEPTION.java。
USER_ID - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态变量
useRadix(int) - 类 java.util.Scanner 中的方法
将此扫描器的默认基数设置为指定基数。
UserDataHandler - org.w3c.dom 中的 接口
当使用 Node.setUserData() 将一个对象与节点上的键相关联时，当克隆、导入或重命名该对象关联的节点时应用程序可以提供调用的处理程序。
UserException - org.omg.CORBA 中的 异常
CORBA IDL 定义的用户异常的根类。
UserException() - 异常 org.omg.CORBA.UserException 的构造方法
构造一个 UserException 对象。
UserException(String) - 异常 org.omg.CORBA.UserException 的构造方法
构造带详细消息的 UserException 对象。
USERNAME_PROPERTY - 接口 javax.xml.ws.BindingProvider 中的静态变量
标准属性：用于验证的用户名。
userNodeForPackage(Class<?>) - 类 java.util.prefs.Preferences 中的静态方法
从调用用户首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
userObject - 类 javax.swing.tree.DefaultMutableTreeNode 中的变量
可选用户对象
userRoot() - 类 java.util.prefs.Preferences 中的静态方法
返回调用用户的根首选项节点。
userRoot() - 接口 java.util.prefs.PreferencesFactory 中的方法
返回与调用用户相对应的用户根首选项节点。
usesFractionalMetrics() - 类 java.awt.font.FontRenderContext 中的方法
返回一个 boolean 值，指示是否在此 FontRenderContext 中使用文本 fractional metrics 模式。
usesLocalFilePerTable() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否为每个表使用一个文件。
usesLocalFiles() - 接口 java.sql.DatabaseMetaData 中的方法
获取此数据库是否将表存储在本地文件中。
usesShiftModifier() - 类 java.awt.MenuShortcut 中的方法
返回是否此菜单快捷方式必须使用 SHIFT 键调用。
useToString(int) - 类 javax.swing.DefaultRowSorter 中的方法
返回排序过程中进行比较之前是否要将值转换为字符串。
useToString(int) - 类 javax.swing.table.TableRowSorter 中的方法
返回排序过程中进行比较之前是否要将值转换为字符串。
useTransparentBounds(boolean) - 类 java.util.regex.Matcher 中的方法
设置此匹配器区域边界的透明度。
UShortSeqHelper - org.omg.CORBA 中的 类
UShortSeq 的 Helper。
UShortSeqHelper() - 类 org.omg.CORBA.UShortSeqHelper 的构造方法
UShortSeqHolder - org.omg.CORBA 中的 类
UShortSeq 的 Holder。
UShortSeqHolder() - 类 org.omg.CORBA.UShortSeqHolder 的构造方法
UShortSeqHolder(short[]) - 类 org.omg.CORBA.UShortSeqHolder 的构造方法
usingProxy() - 类 java.net.HttpURLConnection 中的方法
指示连接是否通过代理。
UTC(int, int, int, int, int, int) - 类 java.util.Date 中的静态方法
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代，使用 UTC TimeZone，后跟 Calendar.getTime().getTime()。
UTC_TIME - 类 java.util.SimpleTimeZone 中的静态变量
指定为 UTC 的开始或结束时间模式的常量。
UTFDataFormatException - java.io 中的 异常
在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
UTFDataFormatException() - 异常 java.io.UTFDataFormatException 的构造方法
构造用 null 作为其错误详细消息的 UTFDataFormatException。
UTFDataFormatException(String) - 异常 java.io.UTFDataFormatException 的构造方法
构造带有指定详细消息的 UTFDataFormatException。
Util - javax.rmi.CORBA 中的 类
提供可以由 stub 和 tie 用于执行公共操作的实用方法。
UtilDelegate - javax.rmi.CORBA 中的 接口
支持 Util 中方法实现的委托。
Utilities - javax.swing.text 中的 类
处理各种文本相关活动的方法集合。
Utilities() - 类 javax.swing.text.Utilities 的构造方法
UUID - java.util 中的 类
表示通用唯一标识符 (UUID) 的类。
UUID(long, long) - 类 java.util.UUID 的构造方法
使用指定的数据构造新的 UUID。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


V - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

V

valid() - 类 java.io.FileDescriptor 中的方法
测试此文件描述符对象是否有效。
validate() - 类 java.awt.Component 中的方法
确保组件具有有效的布局。
validate() - 类 java.awt.Container 中的方法
验证此容器及其所有子组件。
validate(GraphicsConfiguration) - 类 java.awt.image.VolatileImage 中的方法
如果上次调用 validate 后绘制表面丢失，则试图恢复图像的绘制表面。
validate(CertPath, CertPathParameters) - 类 java.security.cert.CertPathValidator 中的方法
使用指定的算法参数集验证指定的证书路径。
validate() - 类 javax.swing.DefaultListCellRenderer 中的方法
因为性能原因而被重写。
validate() - 类 javax.swing.table.DefaultTableCellRenderer 中的方法
因为性能原因而被重写。
validate() - 类 javax.swing.tree.DefaultTreeCellRenderer 中的方法
因为性能原因而被重写。
validate(Object) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
validate(XMLValidateContext) - 接口 javax.xml.crypto.dsig.Reference 中的方法
验证此引用。
validate(XMLValidateContext) - 接口 javax.xml.crypto.dsig.XMLSignature.SignatureValue 中的方法
验证签名值。
validate(XMLValidateContext) - 接口 javax.xml.crypto.dsig.XMLSignature 中的方法
根据核心验证处理规则来验证签名。
validate(Source) - 类 javax.xml.validation.Validator 中的方法
验证指定的输入。
validate(Source, Result) - 类 javax.xml.validation.Validator 中的方法
验证指定输入并将扩充的验证结果发送到指定输出。
validate_connection() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
validatedContents - 类 java.awt.Component.BltBufferStrategy 中的变量
绘制缓冲区最近是否已经从丢失状态中恢复。
validatedContents - 类 java.awt.Component.FlipBufferStrategy 中的变量
绘制缓冲区是否已从最近的丢失状态还原。
validateFileCache() - 类 javax.swing.plaf.basic.BasicDirectoryModel 中的方法
validateInvalidComponents() - 类 javax.swing.RepaintManager 中的方法
验证被标记为无效的所有组件。
validateObject() - 接口 java.io.ObjectInputValidation 中的方法
验证对象。
validatePage(PageFormat) - 类 java.awt.print.PrinterJob 中的方法
返回 page 的副本，调整其设置，以与此 PrinterJob 的当前打印机兼容。
validatePendingAdd(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象添加到 BeanContext 之前立即检查它们。
validatePendingRemove(Object) - 类 java.beans.beancontext.BeanContextSupport 中的方法
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象从 BeanContext 中移除之前立即检查它们。
validatePendingSetBeanContext(BeanContext) - 类 java.beans.beancontext.BeanContextChildSupport 中的方法
从 setBeanContext 调用，以验证（或相反）嵌套 BeanContext 属性值中的挂起更改。
validateRoot(Object) - 接口 javax.xml.bind.Validator 中的方法
已过时。 从 JAXB2.0 开始
validateTree() - 类 java.awt.Container 中的方法
递归继承容器树，对于所有被标记为需要重新计算布局的子树（标记为无效的那些子树）重新计算布局。
validating - 类 javax.xml.bind.helpers.AbstractUnmarshallerImpl 中的变量
指示 Unmarshaller 是否将执行验证。
VALIDATION_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果调用诸如 insertBefore 或 removeChild 之类的方法使 Node 无效(和 "partial validity" 有关的），则引发此异常并且将不进行操作。
ValidationEvent - javax.xml.bind 中的 接口
此事件指示在执行解组操作期间验证传入的 XML 数据时、对 Java 内容树执行按需验证时或将 Java 内容树编组回 XML 数据时遇到问题。
ValidationEventCollector - javax.xml.bind.util 中的 类
收集所有事件的 ValidationEventHandler 实现。
ValidationEventCollector() - 类 javax.xml.bind.util.ValidationEventCollector 的构造方法
ValidationEventHandler - javax.xml.bind 中的 接口
用来验证错误的基本事件处理程序接口。
ValidationEventImpl - javax.xml.bind.helpers 中的 类
ValidationEvent 接口的默认实现。
ValidationEventImpl(int, String, ValidationEventLocator) - 类 javax.xml.bind.helpers.ValidationEventImpl 的构造方法
创建新的 ValidationEventImpl。
ValidationEventImpl(int, String, ValidationEventLocator, Throwable) - 类 javax.xml.bind.helpers.ValidationEventImpl 的构造方法
创建新的 ValidationEventImpl。
ValidationEventLocator - javax.xml.bind 中的 接口
封装 ValidationEvent 的位置。
ValidationEventLocatorImpl - javax.xml.bind.helpers 中的 类
ValidationEventLocator 接口的默认实现。
ValidationEventLocatorImpl() - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
创建所有字段都不可用的对象。
ValidationEventLocatorImpl(Locator) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
根据 org.xml.sax.Locator 构造一个对象。
ValidationEventLocatorImpl(SAXParseException) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
根据 SAXParseException 的位置信息构造一个对象。
ValidationEventLocatorImpl(Node) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
构造一个指向 DOM Node 的对象。
ValidationEventLocatorImpl(Object) - 类 javax.xml.bind.helpers.ValidationEventLocatorImpl 的构造方法
构造一个指向 JAXB 内容对象的对象。
ValidationException - javax.xml.bind 中的 异常
此异常指示在执行验证操作时发生错误。
ValidationException(String) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带指定详细消息的 ValidationException。
ValidationException(String, String) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带指定详细消息和特定于供应商的 errorCode 的 ValidationException。
ValidationException(Throwable) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带有一个 linkedException 的 ValidationException。
ValidationException(String, Throwable) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带指定的详细消息和 linkedException 的 ValidationException。
ValidationException(String, String, Throwable) - 异常 javax.xml.bind.ValidationException 的构造方法
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 ValidationException。
Validator - javax.xml.bind 中的 接口
已过时。 从 JAXB 2.0 开始
Validator - javax.xml.validation 中的 类
根据 Schema 检查 XML 文档的处理器。
Validator() - 类 javax.xml.validation.Validator 的构造方法
派生类的构造方法。
ValidatorHandler - javax.xml.validation 中的 类
处理 SAX 流的流验证器。
ValidatorHandler() - 类 javax.xml.validation.ValidatorHandler 的构造方法
派生类的构造方法。
validCachedPreferredSize - 类 javax.swing.plaf.basic.BasicTreeUI 中的变量
preferredSize 是否有效？
validOps() - 类 java.nio.channels.DatagramChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.Pipe.SinkChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.Pipe.SourceChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.SelectableChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.ServerSocketChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
validOps() - 类 java.nio.channels.SocketChannel 中的方法
返回一个操作集，标识此通道所支持的操作。
VALIGN - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
value - 类 java.sql.DriverPropertyInfo 中的变量
value 字段通过综合为 getPropertyInfo 方法提供的信息、Java 环境和驱动程序提供的默认值来指定当前属性值。
value(String) - 类 javax.management.Query 中的静态方法
返回一个新的字符串表达式。
value(Number) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(int) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(long) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(float) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(double) - 类 javax.management.Query 中的静态方法
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value(boolean) - 类 javax.management.Query 中的静态方法
返回一个 boolean 值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
value - 类 javax.naming.ldap.BasicControl 中的变量
控件的 ASN.1 BER 编码值。
value - 类 javax.swing.DefaultCellEditor.EditorDelegate 中的变量
此单元格的值。
value - 类 javax.swing.JOptionPane 中的变量
当前选择的值，该值将为有效选项或者 UNINITIALIZED_VALUE 或 null。
VALUE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
value - 类 javax.swing.text.html.parser.AttributeList 中的变量
value - 类 javax.xml.bind.JAXBElement 中的变量
xml 元素值。
value - 类 javax.xml.ws.Holder 中的变量
持有者中包含的值。
value - 类 org.omg.CORBA.AnyHolder 中的变量
此 AnyHolder 对象保存的 Any 值。
value - 类 org.omg.CORBA.AnySeqHolder 中的变量
value - 接口 org.omg.CORBA.ARG_IN 中的静态变量
指示 input 参数的值。
value - 接口 org.omg.CORBA.ARG_INOUT 中的静态变量
指示用于输入和输出的参数的常量值。
value - 接口 org.omg.CORBA.ARG_OUT 中的静态变量
指示 output 参数的常量值。
value - 接口 org.omg.CORBA.BAD_POLICY 中的静态变量
PolicyError 异常中的 Error 代码。
value - 接口 org.omg.CORBA.BAD_POLICY_TYPE 中的静态变量
PolicyError 异常中的 Error 代码。
value - 接口 org.omg.CORBA.BAD_POLICY_VALUE 中的静态变量
该值用于表示 PolicyError 异常中的严重策略值错误。
value - 类 org.omg.CORBA.BooleanHolder 中的变量
此 BooleanHolder 对象保存的 boolean 值。
value - 类 org.omg.CORBA.BooleanSeqHolder 中的变量
value - 类 org.omg.CORBA.ByteHolder 中的变量
此 ByteHolder 对象保存的 byte 值。
value - 类 org.omg.CORBA.CharHolder 中的变量
此 CharHolder 对象保存的 char 值。
value - 类 org.omg.CORBA.CharSeqHolder 中的变量
value() - 类 org.omg.CORBA.CompletionStatus 中的方法
检索此 CompletionStatus 对象的值。
value - 接口 org.omg.CORBA.CTX_RESTRICT_SCOPE 中的静态变量
该字段包含 CTX_RESTRICT_SCOPE 标志的 int 值。
value - 类 org.omg.CORBA.CurrentHolder 中的变量
value() - 类 org.omg.CORBA.DefinitionKind 中的方法
返回标识 IR 对象类型的 int 常量。
value - 类 org.omg.CORBA.DoubleHolder 中的变量
此 DoubleHolder 对象保存的 double 值。
value - 类 org.omg.CORBA.DoubleSeqHolder 中的变量
value - 类 org.omg.CORBA.FixedHolder 中的变量
FixedHolder 保存的值。
value - 类 org.omg.CORBA.FloatHolder 中的变量
此 FloatHolder 对象保存的 float 值。
value - 类 org.omg.CORBA.FloatSeqHolder 中的变量
value - 类 org.omg.CORBA.IntHolder 中的变量
此 IntHolder 对象在其 value 字段中保存的 int 值。
value - 类 org.omg.CORBA.LongHolder 中的变量
此 LongHolder 对象保存的 long 值。
value - 类 org.omg.CORBA.LongLongSeqHolder 中的变量
value - 类 org.omg.CORBA.LongSeqHolder 中的变量
value() - 类 org.omg.CORBA.NamedValue 中的方法
检索此 NamedValue 对象的值。
value - 类 org.omg.CORBA.NameValuePair 中的变量
将通过此 NameValuePair 对象与某一名称关联的值。
value - 类 org.omg.CORBA.ObjectHolder 中的变量
此 ObjectHolder 对象保存的 Object 值。
value - 类 org.omg.CORBA.OctetSeqHolder 中的变量
value - 接口 org.omg.CORBA.OMGVMCID 中的静态变量
为 OMG 保留的供应商次要代码 ID。
value() - 类 org.omg.CORBA.ParameterMode 中的方法
value - 类 org.omg.CORBA.ParameterModeHolder 中的变量
value - 类 org.omg.CORBA.PolicyErrorHolder 中的变量
value - 类 org.omg.CORBA.PolicyHolder 中的变量
value - 类 org.omg.CORBA.PolicyListHolder 中的变量
value - 类 org.omg.CORBA.PrincipalHolder 中的变量
已过时。 此 PrincipalHolder 对象保存的 Principal 值。
value - 接口 org.omg.CORBA.PRIVATE_MEMBER 中的静态变量
value - 接口 org.omg.CORBA.PUBLIC_MEMBER 中的静态变量
value - 类 org.omg.CORBA.ServiceInformationHolder 中的变量
此 ServiceInformationHolder 对象保存在其 value 字段中的 ServiceInformation 值。
value() - 类 org.omg.CORBA.SetOverrideType 中的方法
检索此 SetOverrideType 实例的值。
value - 类 org.omg.CORBA.ShortHolder 中的变量
此 ShortHolder 对象保存的 short 值。
value - 类 org.omg.CORBA.ShortSeqHolder 中的变量
value - 类 org.omg.CORBA.StringHolder 中的变量
此 StringHolder 对象保存的 String 值。
value - 类 org.omg.CORBA.StringSeqHolder 中的变量
value() - 类 org.omg.CORBA.TCKind 中的方法
检索此 TCKind 实例的值。
value - 类 org.omg.CORBA.TypeCodeHolder 中的变量
此 TypeCodeHolder 对象保存的 TypeCode 值。
value - 类 org.omg.CORBA.ULongLongSeqHolder 中的变量
value - 类 org.omg.CORBA.ULongSeqHolder 中的变量
value - 类 org.omg.CORBA.UnknownUserExceptionHolder 中的变量
value - 接口 org.omg.CORBA.UNSUPPORTED_POLICY 中的静态变量
PolicyError 异常的 Error 代码。
value - 接口 org.omg.CORBA.UNSUPPORTED_POLICY_VALUE 中的静态变量
PolicyError 异常的 Error 代码。
value - 类 org.omg.CORBA.UShortSeqHolder 中的变量
value - 类 org.omg.CORBA.ValueBaseHolder 中的变量
此 ValueBaseHolder 对象保存的 java.io.Serializable 值。
value - 接口 org.omg.CORBA.VM_ABSTRACT 中的静态变量
表示 typecode 中的抽象接口值类型的值。
value - 接口 org.omg.CORBA.VM_CUSTOM 中的静态变量
表示 typecode 中自定义编组值类型的值。
value - 接口 org.omg.CORBA.VM_NONE 中的静态变量
根据 CORBA 2.3 规范表示 typecode 中值类型的值。
value - 接口 org.omg.CORBA.VM_TRUNCATABLE 中的静态变量
表示 typecode 中可截断值类型的值。
value - 类 org.omg.CORBA.WCharSeqHolder 中的变量
value - 类 org.omg.CORBA.WrongTransactionHolder 中的变量
value - 类 org.omg.CORBA.WStringSeqHolder 中的变量
value - 类 org.omg.CosNaming.BindingHolder 中的变量
value - 类 org.omg.CosNaming.BindingIteratorHolder 中的变量
value - 类 org.omg.CosNaming.BindingListHolder 中的变量
value() - 类 org.omg.CosNaming.BindingType 中的方法
value - 类 org.omg.CosNaming.BindingTypeHolder 中的变量
value - 类 org.omg.CosNaming.NameComponentHolder 中的变量
value - 类 org.omg.CosNaming.NameHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextExtHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 中的变量
value - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 中的变量
value() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的方法
value - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 中的变量
value - 类 org.omg.DynamicAny.NameDynAnyPair 中的变量
与名称关联的 DynAny 值。
value - 类 org.omg.DynamicAny.NameValuePair 中的变量
与名称关联的 Any 值。
value - 接口 org.omg.IOP.CodeSets 中的静态变量
标识在 "GIOP Code Set Service Context" 13-43 页，13.10.2.5 这一部分定义的 CONV_FRAME.CodeSetContext CDR 封装。
value - 接口 org.omg.IOP.ENCODING_CDR_ENCAPS 中的静态变量
CDR Encapsulation 编码。
value - 接口 org.omg.IOP.ExceptionDetailMessage 中的静态变量
CORBA formal/02-06-01:13.7.1: ExceptionDetailMessage，它标识 wstring 的 CDR 封装，使用 GIOP 1.2 与 UTF-16 的 TCS-W 编码。
value - 类 org.omg.IOP.IORHolder 中的变量
value - 类 org.omg.IOP.MultipleComponentProfileHolder 中的变量
value - 接口 org.omg.IOP.RMICustomMaxStreamFormat 中的静态变量
标识 RMICustomMaxStreamFormat 服务上下文的 CDR 封装，该封装中包含指示客户端最大 RMI-IIOP 流格式形式的单个字节。
value - 类 org.omg.IOP.ServiceContextHolder 中的变量
value - 类 org.omg.IOP.ServiceContextListHolder 中的变量
value - 接口 org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS 中的静态变量
在将同一个对象键 (object key) 用于多个互联网位置的情况下，定义了以下标准 IOR Component 来支持 IIOP 1.2 版。
value - 接口 org.omg.IOP.TAG_CODE_SETS 中的静态变量
IOR 多组件配置文件结构的代码集组件包括： 服务器的本机 char 代码集和变换码集，和 服务器的本机 wchar 代码集和变换码集。
value - 接口 org.omg.IOP.TAG_INTERNET_IOP 中的静态变量
标识支持网络 ORB 交换协议 (Internet Inter-ORB Protocol) 的配置文件。
value - 接口 org.omg.IOP.TAG_JAVA_CODEBASE 中的静态变量
支持 stub、tie、value 和 value helper 的类下载。
value - 接口 org.omg.IOP.TAG_MULTIPLE_COMPONENTS 中的静态变量
指示封装的值类型为 MultipleComponentProfile。
value - 接口 org.omg.IOP.TAG_ORB_TYPE 中的静态变量
它在实际应用中通常很有用，能够标识生成对象引用的特定 ORB 种类、解决该特定 ORB 的问题，或者充分利用共享效率。
value - 接口 org.omg.IOP.TAG_POLICIES 中的静态变量
一个包含 QoS 策略序列的配置文件组件，这些策略通过对象适配器与对象引用一起输出。
value - 接口 org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT 中的静态变量
RMI-IIOP 具有多个流格式形式。
value - 类 org.omg.IOP.TaggedComponentHolder 中的变量
value - 类 org.omg.IOP.TaggedProfileHolder 中的变量
value - 接口 org.omg.IOP.TransactionService 中的静态变量
标识一个定义在 CORBAservices: Common Object Services Specifications 中的 CosTSInteroperation.PropogationContext 的 CDR 封装。
value - 接口 org.omg.Messaging.SYNC_WITH_TRANSPORT 中的静态变量
Messaging 规范中定义的常量，定义请求在控件返回客户端前应传输的距离。
value - 接口 org.omg.PortableInterceptor.ACTIVE 中的静态变量
指示正常请求处理的对象适配器状态。
value - 接口 org.omg.PortableInterceptor.DISCARDING 中的静态变量
导致丢弃所有请求的对象适配器状态。
value - 接口 org.omg.PortableInterceptor.HOLDING 中的静态变量
在状态更改前暂时保持请求的对象适配器状态。
value - 接口 org.omg.PortableInterceptor.INACTIVE 中的静态变量
导致丢弃所有请求的对象适配器状态。
value - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 中的变量
value - 接口 org.omg.PortableInterceptor.LOCATION_FORWARD 中的静态变量
指示 LocationForward 应答状态。
value - 接口 org.omg.PortableInterceptor.NON_EXISTENT 中的静态变量
指示适配器已经被销毁的对象适配器状态。
value - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 中的变量
value - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 中的变量
value - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 中的变量
value - 接口 org.omg.PortableInterceptor.SUCCESSFUL 中的静态变量
指示一个成功的应答状态。
value - 接口 org.omg.PortableInterceptor.SYSTEM_EXCEPTION 中的静态变量
指示 SystemException 应答状态。
value - 接口 org.omg.PortableInterceptor.TRANSPORT_RETRY 中的静态变量
指示 Transport Retry 应答状态。
value - 接口 org.omg.PortableInterceptor.UNKNOWN 中的静态变量
XXX
value - 接口 org.omg.PortableInterceptor.USER_EXCEPTION 中的静态变量
指示 UserException 应答状态。
value - 接口 org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID 中的静态变量
表示 ID_ASSIGNMENT_POLICY_ID 的值。
value - 接口 org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID 中的静态变量
表示 ID_UNIQUENESS_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.IdAssignmentPolicyOperations 中的方法
指定策略值。
value() - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的方法
value() - 接口 org.omg.PortableServer.IdUniquenessPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的方法
value - 接口 org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID 中的静态变量
表示 IMPLICIT_ACTIVATION_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.ImplicitActivationPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的方法
value - 接口 org.omg.PortableServer.LIFESPAN_POLICY_ID 中的静态变量
表示 LIFESPAN_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.LifespanPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.LifespanPolicyValue 中的方法
value() - 类 org.omg.PortableServer.POAManagerPackage.State 中的方法
value - 接口 org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID 中的静态变量
表示 REQUEST_PROCESSING_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.RequestProcessingPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的方法
value - 接口 org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID 中的静态变量
表示 SERVANT_RETENTION_POLICY_ID 的值。
value - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 中的变量
value() - 接口 org.omg.PortableServer.ServantRetentionPolicyOperations 中的方法
指示策略值
value() - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的方法
value - 接口 org.omg.PortableServer.THREAD_POLICY_ID 中的静态变量
表示 THREAD_POLICY_ID 的值。
value() - 接口 org.omg.PortableServer.ThreadPolicyOperations 中的方法
指定策略值
value() - 类 org.omg.PortableServer.ThreadPolicyValue 中的方法
VALUE_ALPHA_INTERPOLATION_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
Alpha 插值提示值——由实现选择对性能和质量进行良好权衡的 alpha 混合算法
VALUE_ALPHA_INTERPOLATION_QUALITY - 类 java.awt.RenderingHints 中的静态变量
Alpha 插值提示值——选择偏重于精确度和视觉质量的 alpha 混合算法。
VALUE_ALPHA_INTERPOLATION_SPEED - 类 java.awt.RenderingHints 中的静态变量
Alpha 插值提示值——选择偏重于计算速度的 alpha 混合算法。
VALUE_ANTIALIAS_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
抗锯齿提示值——使用由实现选择的默认抗锯齿模式完成呈现。
VALUE_ANTIALIAS_OFF - 类 java.awt.RenderingHints 中的静态变量
抗锯齿提示值——在不使用抗锯齿模式的情况下完成呈现。
VALUE_ANTIALIAS_ON - 类 java.awt.RenderingHints 中的静态变量
抗锯齿提示值——使用抗锯齿模式完成呈现。
VALUE_ARBITRARY - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为单个任意值。
value_as_string() - 接口 org.omg.CORBA.DynEnum 中的方法
已过时。 以字符串形式返回此 DynEnum 中存储的 IDL enum 的值。
value_as_string(String) - 接口 org.omg.CORBA.DynEnum 中的方法
已过时。 设置此 DynEnum 中的特定 enum。
value_as_ulong() - 接口 org.omg.CORBA.DynEnum 中的方法
已过时。 以 Java int 值形式返回 IDL enum 的值。
value_as_ulong(int) - 接口 org.omg.CORBA.DynEnum 中的方法
已过时。 设置 IDL enum 的值。
VALUE_COLOR_RENDER_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
颜色呈现提示值——根据实现的选择执行颜色转换计算，以表示可用的性能和精确度之间的最佳权衡。
VALUE_COLOR_RENDER_QUALITY - 类 java.awt.RenderingHints 中的静态变量
颜色呈现提示值——用最高的精确度和视觉质量执行颜色转换计算。
VALUE_COLOR_RENDER_SPEED - 类 java.awt.RenderingHints 中的静态变量
颜色呈现提示值——最快地执行输出设备格式的颜色转换。
VALUE_DITHER_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
抖动提示值——对该实现选择的抖动使用默认值。
VALUE_DITHER_DISABLE - 类 java.awt.RenderingHints 中的静态变量
抖动提示值——呈现几何形状时不抖动。
VALUE_DITHER_ENABLE - 类 java.awt.RenderingHints 中的静态变量
抖动提示值——如果需要，在呈现几何形状时抖动。
VALUE_ENUMERATION - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为许多枚举值之一。
VALUE_FRACTIONALMETRICS_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
字体小数规格提示值——用实现选择的精度定位字符字形。
VALUE_FRACTIONALMETRICS_OFF - 类 java.awt.RenderingHints 中的静态变量
字体小数规格提示值——用舍入为像素边界的 advance width 定位字符字形。
VALUE_FRACTIONALMETRICS_ON - 类 java.awt.RenderingHints 中的静态变量
字体小数规格提示值——用子像素精确度定位字符字形。
VALUE_INTERPOLATION_BICUBIC - 类 java.awt.RenderingHints 中的静态变量
插值提示值—— 使用 X 和 Y 中的立方函数插入图像中整数坐标附近的 9 个样本，以生成一个颜色样本。
VALUE_INTERPOLATION_BILINEAR - 类 java.awt.RenderingHints 中的静态变量
插值提示值——图像中最接近整数坐标样本的 4 种颜色样本被线性地插入，以生成一个颜色样本。
VALUE_INTERPOLATION_NEAREST_NEIGHBOR - 类 java.awt.RenderingHints 中的静态变量
插值提示值——使用图像中最接近整数坐标样本的颜色样本。
VALUE_LIST - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为一个值的列表或数组。
VALUE_NONE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getObjectValueType 返回的常量，指示缺少用户对象。
VALUE_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
value 的绑定属性名。
VALUE_RANGE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可能将属性或用户对象设置为某个值范围。
VALUE_RANGE_MAX_INCLUSIVE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可将属性或用户对象设置为某个值范围。
VALUE_RANGE_MAX_INCLUSIVE_MASK - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
该值可以与 VALUE_RANGE 进行“或”运算来获取 VALUE_RANGE_MAX_INCLUSIVE，可以与 VALUE_RANGE_MIN_INCLUSIVE 进行“或”运算来获取 VALUE_RANGE_MIN_MAX_INCLUSIVE。
VALUE_RANGE_MIN_INCLUSIVE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为某个值范围。
VALUE_RANGE_MIN_INCLUSIVE_MASK - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
该值可以与 VALUE_RANGE 进行“或”运算来获取 VALUE_RANGE_MIN_INCLUSIVE，可以与 VALUE_RANGE_MAX_INCLUSIVE 进行“或”运算来获取 VALUE_RANGE_MIN_MAX_INCLUSIVE。
VALUE_RANGE_MIN_MAX_INCLUSIVE - 接口 javax.imageio.metadata.IIOMetadataFormat 中的静态变量
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为某个值范围。
VALUE_RENDER_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
呈现提示值——由实现选择对性能和质量进行良好权衡的呈现算法。
VALUE_RENDER_QUALITY - 类 java.awt.RenderingHints 中的静态变量
呈现提示值——选择偏重输出质量的呈现算法。
VALUE_RENDER_SPEED - 类 java.awt.RenderingHints 中的静态变量
呈现提示值——选择偏重输出速度的呈现算法。
VALUE_STROKE_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
笔划规范化控制提示值——根据给定实现的权衡，可以修改几何形状或保留原来的几何形状。
VALUE_STROKE_NORMALIZE - 类 java.awt.RenderingHints 中的静态变量
笔划规范化控制提示值——几何形状应当规范化，以提高均匀性或直线间隔和整体美观。
VALUE_STROKE_PURE - 类 java.awt.RenderingHints 中的静态变量
笔划规范化控制提示值——几何形状应该保持不变并使用子像素精确度呈现。
VALUE_TEXT_ANTIALIAS_DEFAULT - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——根据 RenderingHints.KEY_ANTIALIASING 提示或由实现选择的默认值完成文本呈现。
VALUE_TEXT_ANTIALIAS_GASP - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——文本呈现需要使用字体资源中的信息，这些信息指定了每个点大小是否适合应用 RenderingHints.VALUE_TEXT_ANTIALIAS_ON 或 RenderingHints.VALUE_TEXT_ANTIALIAS_OFF。
VALUE_TEXT_ANTIALIAS_LCD_HBGR - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素按从左到右为 B、G、R 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HBGR) 的三倍。
VALUE_TEXT_ANTIALIAS_LCD_HRGB - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，该 LCD 显示器子像素按从左到右为 R、G、B 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HRGB) 的三倍。
VALUE_TEXT_ANTIALIAS_LCD_VBGR - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VBGR) 的三倍。
VALUE_TEXT_ANTIALIAS_LCD_VRGB - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VRGB) 的三倍。
VALUE_TEXT_ANTIALIAS_OFF - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——不使用任何抗锯齿形式完成文本呈现。
VALUE_TEXT_ANTIALIAS_ON - 类 java.awt.RenderingHints 中的静态变量
文本抗锯齿提示值——使用某种抗锯齿形式完成文本呈现。
ValueBase - org.omg.CORBA.portable 中的 接口
所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。
ValueBaseHelper - org.omg.CORBA 中的 类
ValueBaseHelper() - 类 org.omg.CORBA.ValueBaseHelper 的构造方法
ValueBaseHolder - org.omg.CORBA 中的 类
ValueBase 的 Holder。
ValueBaseHolder() - 类 org.omg.CORBA.ValueBaseHolder 的构造方法
构造一个新的 ValueBaseHolder 对象，将其 value 字段初始化为 0。
ValueBaseHolder(Serializable) - 类 org.omg.CORBA.ValueBaseHolder 的构造方法
构造一个新的 ValueBaseHolder 对象，并将其 value 字段初始化为给定的 java.io.Serializable。
valueBound(SSLSessionBindingEvent) - 接口 javax.net.ssl.SSLSessionBindingListener 中的方法
调用此方法通知侦听器要将其绑定到 SSLSession 中。
valueChanged(ListSelectionEvent) - 接口 javax.swing.event.ListSelectionListener 中的方法
每当选择值发生更改时调用。
valueChanged(TreeSelectionEvent) - 接口 javax.swing.event.TreeSelectionListener 中的方法
每当选择值发生更改时调用。
valueChanged(ListSelectionEvent) - 类 javax.swing.JList.AccessibleJList 中的方法
List Selection Listener 值更改方法。
valueChanged(ListSelectionEvent) - 类 javax.swing.JTable.AccessibleJTable 中的方法
跟踪表单元格选择的变更
valueChanged(ListSelectionEvent) - 类 javax.swing.JTable 中的方法
行选择更改时调用，重新绘制来显示新的选择。
valueChanged(TreeSelectionEvent) - 类 javax.swing.JTree.AccessibleJTree 中的方法
树选择侦听器值更改方法。
valueChanged(TreeSelectionEvent) - 类 javax.swing.JTree.TreeSelectionRedirector 中的方法
在选择更改时由 TreeSelectionModel 调用。
valueChanged(ListSelectionEvent) - 类 javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler 中的方法
valueChanged(ListSelectionEvent) - 类 javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener 中的方法
valueChanged(ListSelectionEvent) - 类 javax.swing.plaf.basic.BasicListUI.ListSelectionHandler 中的方法
valueChanged(TreeSelectionEvent) - 类 javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler 中的方法
当显示的树中发生选择更改时传递消息。
valueChanged(ListSelectionEvent) - 类 javax.swing.plaf.metal.MetalFileChooserUI 中的方法
valueChanged(ListSelectionEvent) - 类 javax.swing.table.DefaultTableColumnModel 中的方法
列选择更改时转发 ListSelectionEvents 的 ListSelectionListener。
valueChanged(TreeSelectionEvent) - 类 javax.swing.tree.DefaultTreeCellEditor 中的方法
重置 lastPath。
ValueExp - javax.management 中的 接口
表示可以作为参数传递给关系表达式的值。
ValueFactory - org.omg.CORBA.portable 中的 接口
ValueFactory 接口是 IDL 类型 CORBA::ValueFactory 的本地映射。
valueForPathChanged(TreePath, Object) - 类 javax.swing.tree.DefaultTreeModel 中的方法
此方法设置由路径标识的 TreeNode 的用户对象，并发送更改的节点。
valueForPathChanged(TreePath, Object) - 接口 javax.swing.tree.TreeModel 中的方法
用户已将 path 标识的项的值更改为 newValue 时，进行通知。
valueForXPosition(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回给出 x 位置的值。
valueForYPosition(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回给出 y 位置的值。
ValueHandler - javax.rmi.CORBA 中的 接口
定义允许序列化 Java 对象到 GIOP 流或从其序列化 Java 对象的方法。
ValueHandlerMultiFormat - javax.rmi.CORBA 中的 接口
Java 到 IDL ptc 02-01-12 1.5.1.5。
ValueInputStream - org.omg.CORBA.portable 中的 接口
Java 到 IDL ptc 02-01-12 1.5.1.4 ValueInputStream 用来实现第 2 版的 RMI-IIOP 流格式。
valueIsAdjusting - 类 javax.swing.plaf.basic.BasicComboPopup 中的变量
从 Java 2 平台 v1.4 开始，不再使用这种以前没有记录的字段。
ValueMember - org.omg.CORBA 中的 类
接口存储库 (Interface Repository) 中关于 value 对象成员的描述。
ValueMember() - 类 org.omg.CORBA.ValueMember 的构造方法
构造一个默认 ValueMember 对象。
ValueMember(String, String, String, String, TypeCode, IDLType, short) - 类 org.omg.CORBA.ValueMember 的构造方法
构造一个 ValueMember 对象，使用给定值进行初始化。
ValueMemberHelper - org.omg.CORBA 中的 类
ValueMember 的 Helper。
ValueMemberHelper() - 类 org.omg.CORBA.ValueMemberHelper 的构造方法
valueOf(String) - 枚举 java.awt.Component.BaselineResizeBehavior 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.Desktop.Action 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.Dialog.ModalExclusionType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.Dialog.ModalityType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.MultipleGradientPaint.ColorSpaceType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.MultipleGradientPaint.CycleMethod 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.awt.TrayIcon.MessageType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.lang.annotation.ElementType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.lang.annotation.RetentionPolicy 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(boolean) - 类 java.lang.Boolean 中的静态方法
返回一个表示指定 boolean 值的 Boolean 实例。
valueOf(String) - 类 java.lang.Boolean 中的静态方法
返回一个用指定的字符串表示值的 Boolean 值。
valueOf(byte) - 类 java.lang.Byte 中的静态方法
返回表示指定 byte 值的一个 Byte 实例。
valueOf(String, int) - 类 java.lang.Byte 中的静态方法
返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。
valueOf(String) - 类 java.lang.Byte 中的静态方法
返回一个保持指定 String 所给出的值的 Byte 对象。
valueOf(char) - 类 java.lang.Character 中的静态方法
返回一个表示指定 char 值的 Character 实例。
valueOf(String) - 类 java.lang.Double 中的静态方法
返回保存用参数字符串 s 表示的 double 值的 Double 对象。
valueOf(double) - 类 java.lang.Double 中的静态方法
返回表示指定的 double 值的 Double 实例。
valueOf(Class<T>, String) - 类 java.lang.Enum 中的静态方法
返回带指定名称的指定枚举类型的枚举常量。
valueOf(String) - 类 java.lang.Float 中的静态方法
返回保存用参数字符串 s 表示的 float 值的 Float 对象。
valueOf(float) - 类 java.lang.Float 中的静态方法
返回表示指定的 float 值的 Float 实例。
valueOf(String, int) - 类 java.lang.Integer 中的静态方法
返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。
valueOf(String) - 类 java.lang.Integer 中的静态方法
返回保存指定的 String 的值的 Integer 对象。
valueOf(int) - 类 java.lang.Integer 中的静态方法
返回一个表示指定的 int 值的 Integer 实例。
valueOf(String, int) - 类 java.lang.Long 中的静态方法
当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。
valueOf(String) - 类 java.lang.Long 中的静态方法
返回保持指定 String 的值的 Long 对象。
valueOf(long) - 类 java.lang.Long 中的静态方法
返回表示指定 long 值的 Long 实例。
valueOf(String) - 枚举 java.lang.management.MemoryType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String, int) - 类 java.lang.Short 中的静态方法
返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。
valueOf(String) - 类 java.lang.Short 中的静态方法
返回一个保持指定 String 所给出的值的 Short 对象。
valueOf(short) - 类 java.lang.Short 中的静态方法
返回表示指定 short 值的 Short 实例。
valueOf(Object) - 类 java.lang.String 中的静态方法
返回 Object 参数的字符串表示形式。
valueOf(char[]) - 类 java.lang.String 中的静态方法
返回 char 数组参数的字符串表示形式。
valueOf(char[], int, int) - 类 java.lang.String 中的静态方法
返回 char 数组参数的特定子数组的字符串表示形式。
valueOf(boolean) - 类 java.lang.String 中的静态方法
返回 boolean 参数的字符串表示形式。
valueOf(char) - 类 java.lang.String 中的静态方法
返回 char 参数的字符串表示形式。
valueOf(int) - 类 java.lang.String 中的静态方法
返回 int 参数的字符串表示形式。
valueOf(long) - 类 java.lang.String 中的静态方法
返回 long 参数的字符串表示形式。
valueOf(float) - 类 java.lang.String 中的静态方法
返回 float 参数的字符串表示形式。
valueOf(double) - 类 java.lang.String 中的静态方法
返回 double 参数的字符串表示形式。
valueOf(String) - 枚举 java.lang.Thread.State 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(long, int) - 类 java.math.BigDecimal 中的静态方法
将 long 非标度值和 int 标度转换为 BigDecimal。
valueOf(long) - 类 java.math.BigDecimal 中的静态方法
将 long 值转换为具有零标度的 BigDecimal。
valueOf(double) - 类 java.math.BigDecimal 中的静态方法
使用 Double.toString(double) 方法提供的 double 规范的字符串表示形式将 double 转换为 BigDecimal。
valueOf(long) - 类 java.math.BigInteger 中的静态方法
返回其值等于指定 long 的值的 BigInteger。
valueOf(String) - 枚举 java.math.RoundingMode 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(int) - 枚举 java.math.RoundingMode 中的静态方法
返回与 BigDecimal 中遗留整数舍入模式常量对应的 RoundingMode 对象。
valueOf(String) - 枚举 java.net.Authenticator.RequestorType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.net.Proxy.Type 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.security.KeyRep.Type 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.sql.ClientInfoStatus 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 类 java.sql.Date 中的静态方法
将 JDBC 日期转义形式的字符串转换成 Date 值。
valueOf(String) - 枚举 java.sql.RowIdLifetime 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 类 java.sql.Time 中的静态方法
将使用 JDBC 时间转义格式的字符串转换为 Time 值。
valueOf(String) - 类 java.sql.Timestamp 中的静态方法
将使用 JDBC 时间戳转义格式的 String 对象转换为 Timestamp 值。
valueOf(String) - 枚举 java.text.Normalizer.Form 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.util.concurrent.TimeUnit 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 java.util.Formatter.BigDecimalLayoutForm 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.annotation.Resource.AuthenticationType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.jws.soap.SOAPBinding.ParameterStyle 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.jws.soap.SOAPBinding.Style 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.jws.soap.SOAPBinding.Use 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.jws.WebParam.Mode 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.element.ElementKind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.element.Modifier 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.element.NestingKind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.SourceVersion 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.lang.model.type.TypeKind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.net.ssl.SSLEngineResult.HandshakeStatus 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.net.ssl.SSLEngineResult.Status 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.DropMode 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.event.RowSorterEvent.Type 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.GroupLayout.Alignment 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.JTable.PrintMode 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.LayoutStyle.ComponentPlacement 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.RowFilter.ComparisonType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.SortOrder 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.SwingWorker.StateValue 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.swing.text.html.FormSubmitEvent.MethodType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.tools.Diagnostic.Kind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.tools.JavaFileObject.Kind 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.tools.StandardLocation 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.xml.bind.annotation.XmlAccessOrder 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.xml.bind.annotation.XmlAccessType 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.xml.bind.annotation.XmlNsForm 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 类 javax.xml.namespace.QName 中的静态方法
从解析格式化 String 中派生的 QName。
valueOf(String) - 枚举 javax.xml.ws.handler.MessageContext.Scope 中的静态方法
返回带有指定名称的该类型的枚举常量。
valueOf(String) - 枚举 javax.xml.ws.Service.Mode 中的静态方法
返回带有指定名称的该类型的枚举常量。
ValueOutputStream - org.omg.CORBA.portable 中的 接口
Java 到 IDL ptc 02-01-12 1.5.1.3 ValueOutputStream 用来实现第 2 版的 RMI-IIOP 流格式。
values() - 枚举 java.awt.Component.BaselineResizeBehavior 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.Desktop.Action 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.Dialog.ModalExclusionType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.Dialog.ModalityType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.MultipleGradientPaint.ColorSpaceType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.awt.MultipleGradientPaint.CycleMethod 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.awt.RenderingHints 中的方法
返回此 RenderinHints 中所包含键的 Collection 视图。
values() - 枚举 java.awt.TrayIcon.MessageType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.lang.annotation.ElementType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.lang.annotation.RetentionPolicy 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.lang.management.MemoryType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.lang.Thread.State 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.math.RoundingMode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.net.Authenticator.RequestorType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.net.Proxy.Type 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.security.KeyRep.Type 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.security.Provider 中的方法
返回此 provider 中所包含的属性值的一个不可修改的 Collection 视图。
values() - 枚举 java.sql.ClientInfoStatus 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.sql.RowIdLifetime 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 java.text.Normalizer.Form 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.util.AbstractMap 中的方法
返回此映射中包含的值的 Collection 视图。
values() - 类 java.util.concurrent.ConcurrentHashMap 中的方法
返回此映射中包含的值的 Collection 视图。
values() - 类 java.util.concurrent.ConcurrentSkipListMap 中的方法
返回此映射中所包含值的 Collection 视图。
values() - 枚举 java.util.concurrent.TimeUnit 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.util.EnumMap 中的方法
返回此映射中所包含值的 Collection 视图。
values() - 枚举 java.util.Formatter.BigDecimalLayoutForm 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 java.util.HashMap 中的方法
返回此映射所包含的值的 Collection 视图。
values() - 类 java.util.Hashtable 中的方法
返回此映射中包含的键的 Collection 视图。
values() - 类 java.util.IdentityHashMap 中的方法
返回映射所包含值的 Collection 视图。
values() - 类 java.util.jar.Attributes 中的方法
返回此 Map 所包含的属性值的 Collection 视图。
values() - 接口 java.util.Map 中的方法
返回此映射中包含的值的 Collection 视图。
values() - 接口 java.util.SortedMap 中的方法
返回在此映射中所包含值的 Collection 视图。
values() - 类 java.util.TreeMap 中的方法
返回此映射包含的值的 Collection 视图。
values() - 类 java.util.WeakHashMap 中的方法
返回此映射所包含的值的 Collection 视图。
values() - 枚举 javax.annotation.Resource.AuthenticationType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.jws.soap.SOAPBinding.ParameterStyle 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.jws.soap.SOAPBinding.Style 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.jws.soap.SOAPBinding.Use 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.jws.WebParam.Mode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.element.ElementKind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.element.Modifier 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.element.NestingKind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.SourceVersion 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.lang.model.type.TypeKind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 接口 javax.management.openmbean.CompositeData 中的方法
返回此 CompositeData 实例中所包含项值的不可修改的 Collection 视图。
values() - 类 javax.management.openmbean.CompositeDataSupport 中的方法
返回此 CompositeData 实例中包含的项值的不可修改的 Collection 视图。
values() - 接口 javax.management.openmbean.TabularData 中的方法
返回此 TabularData 实例中包含的 CompositeData 值（即各行）的 collection 视图。
values() - 类 javax.management.openmbean.TabularDataSupport 中的方法
返回包含在此 TabularDataSupport 实例中的行的 collection 视图。
values - 类 javax.naming.directory.BasicAttribute 中的变量
保存属性的值。
values() - 枚举 javax.net.ssl.SSLEngineResult.HandshakeStatus 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.net.ssl.SSLEngineResult.Status 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 类 javax.script.SimpleBindings 中的方法
返回此映射中包含的值的 Collection 视图。
values() - 枚举 javax.swing.DropMode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.event.RowSorterEvent.Type 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.GroupLayout.Alignment 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.JTable.PrintMode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.LayoutStyle.ComponentPlacement 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.RowFilter.ComparisonType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.SortOrder 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.SwingWorker.StateValue 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.swing.text.html.FormSubmitEvent.MethodType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values - 类 javax.swing.text.html.parser.AttributeList 中的变量
values() - 枚举 javax.tools.Diagnostic.Kind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.tools.JavaFileObject.Kind 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.tools.StandardLocation 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.bind.annotation.XmlAccessOrder 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.bind.annotation.XmlAccessType 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.bind.annotation.XmlNsForm 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.ws.handler.MessageContext.Scope 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
values() - 枚举 javax.xml.ws.Service.Mode 中的静态方法
Returns an array containing the constants of this enum type, in the order they are declared.
valueToString(Object) - 类 javax.swing.JFormattedTextField.AbstractFormatter 中的方法
返回为 value 显示的 string 值。
valueToString(Object) - 类 javax.swing.text.DefaultFormatter 中的方法
使用 toString 方法将传入的 Object 转换为 String。
valueToString(Object) - 类 javax.swing.text.InternationalFormatter 中的方法
返回 Object value 的 String 表示形式。
valueToString(Object) - 类 javax.swing.text.MaskFormatter 中的方法
返回基于掩码的 Object value 的 String 表示形式。
VALUETYPE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
valueUnbound(SSLSessionBindingEvent) - 接口 javax.net.ssl.SSLSessionBindingListener 中的方法
调用此方法通知侦听器要从 SSLSession 中解除其绑定。
VAR - 类 javax.swing.text.html.HTML.Tag 中的静态变量
VARBINARY - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 VARBINARY 的 Java 编程语言中的常量（有时称为类型代码）。
VARCHAR - 类 java.sql.Types 中的静态变量
标识一般 SQL 类型 VARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
VariableElement - javax.lang.model.element 中的 接口
表示一个字段、enum 常量、方法或构造方法参数、局部变量或异常参数。
VariableHeightLayoutCache - javax.swing.tree 中的 类
注：在以后的版本中，此类将变得更加开放。
VariableHeightLayoutCache() - 类 javax.swing.tree.VariableHeightLayoutCache 的构造方法
variant() - 类 java.util.UUID 中的方法
与此 UUID 相关联的变体号。
VARIATION_SELECTORS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Variation Selectors”Unicode 字符块的常量。
VARIATION_SELECTORS_SUPPLEMENT - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Variation Selectors Supplement”Unicode 字符块的常量。
vcSupport - 类 java.beans.beancontext.BeanContextChildSupport 中的变量
与此 BeanContextChildSupport 相关联的 VetoableChangeSupport。
Vector<E> - java.util 中的 类
Vector 类可以实现可增长的对象数组。
Vector(int, int) - 类 java.util.Vector 的构造方法
使用指定的初始容量和容量增量构造一个空的向量。
Vector(int) - 类 java.util.Vector 的构造方法
使用指定的初始容量和等于零的容量增量构造一个空向量。
Vector() - 类 java.util.Vector 的构造方法
构造一个空向量，使其内部数据数组的大小为 10，其标准容量增量为零。
Vector(Collection<? extends E>) - 类 java.util.Vector 的构造方法
构造一个包含指定 collection 中的元素的向量，这些元素按其 collection 的迭代器返回元素的顺序排列。
vendorName - 类 javax.imageio.spi.IIOServiceProvider 中的变量
将从 getVendorName 返回的一个 String，初始值为 null。
VERBOSE - 类 java.rmi.server.LogStream 中的静态变量
已过时。 日志级别常量（详细日志记录）。
verify(PublicKey) - 类 java.security.cert.Certificate 中的方法
验证是否已使用与指定公钥相应的私钥签署了此证书。
verify(PublicKey, String) - 类 java.security.cert.Certificate 中的方法
验证是否已使用与指定公钥相应的私钥签署了此证书。
verify(PublicKey) - 类 java.security.cert.X509CRL 中的方法
验证是否已使用与给定公钥相应的私钥签署了此 CRL。
verify(PublicKey, String) - 类 java.security.cert.X509CRL 中的方法
验证是否已使用与给定公钥相应的私钥签署了此 CRL。
VERIFY - 类 java.security.Signature 中的静态变量
可能的 Signature.state 值，表示此签名对象已经初始化验证。
verify(byte[]) - 类 java.security.Signature 中的方法
验证传入的签名。
verify(byte[], int, int) - 类 java.security.Signature 中的方法
从指定的偏移量开始，验证指定的 byte 数组中传入的签名。
verify(PublicKey, Signature) - 类 java.security.SignedObject 中的方法
使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。
verify(String, SSLSession) - 接口 javax.net.ssl.HostnameVerifier 中的方法
验证主机名和服务器验证方案的匹配是可接受的。
verify(PublicKey) - 类 javax.security.cert.Certificate 中的方法
验证是否已使用与指定公钥相对应的私钥签署了此证书。
verify(PublicKey, String) - 类 javax.security.cert.Certificate 中的方法
验证是否已使用与指定公钥相对应的私钥签署了此证书。
verify(JComponent) - 类 javax.swing.InputVerifier 中的方法
检查 JComponent 的输入是否有效。
VERIFY - 类 javax.xml.crypto.KeySelector.Purpose 中的静态变量
用于验证的密钥。
verifyAttributeCategory(Object, Class<?>) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。
verifyAttributeValue(Object, Class<?>) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。
verifyCategoryForValue(Class<?>, Attribute) - 类 javax.print.attribute.AttributeSetUtilities 中的静态方法
验证给定的属性类别对象是否等于给定属性值对象的类别。
VerifyError - java.lang 中的 错误
当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
VerifyError() - 错误 java.lang.VerifyError 的构造方法
构造不带详细消息的 VerifyError。
VerifyError(String) - 错误 java.lang.VerifyError 的构造方法
构造带指定详细消息的 VerifyError。
verifyMIC(byte[], int, int, byte[], int, int, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
通过提供的消息，检查包含在标记参数中的加密的 MIC。
verifyMIC(InputStream, InputStream, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
version() - 类 java.util.UUID 中的方法
与此 UUID 相关联的版本号。
version - 类 javax.imageio.spi.IIOServiceProvider 中的变量
将从 getVersion 返回的一个 String，初始值为 null。
VERSION - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
VERSION - 类 javax.xml.transform.OutputKeys 中的静态变量
version = nmtoken. version 指定了输出方法的版本。
version - 类 org.omg.CORBA.ValueMember 中的变量
用来定义此成员的 value 的版本。
versionColumnNotPseudo - 接口 java.sql.DatabaseMetaData 中的静态变量
指示这种版本的列“不”是伪列。
versionColumnPseudo - 接口 java.sql.DatabaseMetaData 中的静态变量
指示这种版本的列是伪列。
versionColumnUnknown - 接口 java.sql.DatabaseMetaData 中的静态变量
指示这种版本的列可能是伪列，也可能不是。
VersionSpecHelper - org.omg.CORBA 中的 类
VersionSpec 的 Helper。
VersionSpecHelper() - 类 org.omg.CORBA.VersionSpecHelper 的构造方法
VERTICAL - 接口 java.awt.Adjustable 中的静态变量
指示 Adjustable 具有垂直方向。
VERTICAL - 类 java.awt.GridBagConstraints 中的静态变量
在垂直方向而不是水平方向上调整组件大小。
VERTICAL - 类 java.awt.Scrollbar 中的静态变量
指示一个垂直滚动条的常量。
VERTICAL - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象的方向为垂直方向。
VERTICAL - 类 javax.swing.JList 中的静态变量
指示单个列中单元的垂直布局；默认布局。
VERTICAL - 接口 javax.swing.SwingConstants 中的静态变量
垂直方向。
VERTICAL_ALIGN - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
VERTICAL_ALIGNMENT_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的垂直对齐方式的更改。
VERTICAL_CENTER - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的垂直中央位置。
VERTICAL_SCROLLBAR - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识垂直滚动条。
VERTICAL_SCROLLBAR_ALWAYS - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置垂直滚动条策略以使垂直滚动条一直显示。
VERTICAL_SCROLLBAR_AS_NEEDED - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置垂直滚动条策略以使垂直滚动条只在需要时显示。
VERTICAL_SCROLLBAR_NEVER - 接口 javax.swing.ScrollPaneConstants 中的静态变量
用于设置垂直滚动条策略以使垂直滚动条从不显示。
VERTICAL_SCROLLBAR_POLICY - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识垂直滚动条策略属性。
VERTICAL_SPLIT - 类 javax.swing.JSplitPane 中的静态变量
垂直分割表示 Component 沿 y 轴分割。
VERTICAL_TEXT_POSITION_CHANGED_PROPERTY - 类 javax.swing.AbstractButton 中的静态变量
标识按钮的垂直文本位置的更改。
VERTICAL_WRAP - 类 javax.swing.JList 中的静态变量
指示“报纸样式”布局，单元按先垂直后水平排列。
verticalScrollBar - 类 javax.swing.JScrollPane 中的变量
滚动窗格的垂直滚动条子级。
verticalScrollBarPolicy - 类 javax.swing.JScrollPane 中的变量
用于垂直滚动条的显示策略。
vertThumbIcon - 类 javax.swing.plaf.metal.MetalSliderUI 中的静态变量
默认垂直 thumb Icon。
vetoableChange(PropertyChangeEvent) - 类 java.beans.beancontext.BeanContextSupport 中的方法
子类可以封装此方法来监视子类属性的更改。
vetoableChange(PropertyChangeEvent) - 接口 java.beans.VetoableChangeListener 中的方法
在约束属性发生更改时调用此方法。
vetoableChange(PropertyChangeEvent) - 类 java.beans.VetoableChangeListenerProxy 中的方法
将属性更改事件转发给侦听器代理。
VetoableChangeListener - java.beans 中的 接口
只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。
VetoableChangeListenerProxy - java.beans 中的 类
扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。
VetoableChangeListenerProxy(String, VetoableChangeListener) - 类 java.beans.VetoableChangeListenerProxy 的构造方法
VetoableChangeSupport - java.beans 中的 类
这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。
VetoableChangeSupport(Object) - 类 java.beans.VetoableChangeSupport 的构造方法
构造一个 VetoableChangeSupport 对象。
View - javax.swing.text 中的 类
View 类是 text 包极为重要的一部分。
View(Element) - 类 javax.swing.text.View 的构造方法
创建一个新的 View 对象。
ViewFactory - javax.swing.text 中的 接口
创建文档专题某些部分的视图的工厂。
VIEWPORT - 类 javax.accessibility.AccessibleRole 中的静态变量
通常在滚动窗格中使用的对象。
viewPort - 类 javax.swing.JScrollPane.AccessibleJScrollPane 中的变量
viewport - 类 javax.swing.JScrollPane 中的变量
滚动窗格的视口子级。
VIEWPORT - 类 javax.swing.plaf.synth.Region 中的静态变量
Viewport 的 region。
VIEWPORT - 接口 javax.swing.ScrollPaneConstants 中的静态变量
标识一个“视口”或显示区域，在这个范围内能看到滚动的内容。
viewport - 类 javax.swing.ScrollPaneLayout 中的变量
滚动窗格的子级视口。
viewportChangeListener - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
ViewportLayout - javax.swing 中的 类
JViewport 的默认布局管理器。
ViewportLayout() - 类 javax.swing.ViewportLayout 的构造方法
ViewportUI - javax.swing.plaf 中的 类
JViewport 的可插入外观界面。
ViewportUI() - 类 javax.swing.plaf.ViewportUI 的构造方法
viewToModel(JTextComponent, Point) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
viewToModel(JTextComponent, Point, Position.Bias[]) - 类 javax.swing.plaf.basic.BasicTextUI 中的方法
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
viewToModel(JTextComponent, Point) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 viewToModel 方法。
viewToModel(JTextComponent, Point, Position.Bias[]) - 类 javax.swing.plaf.multi.MultiTextUI 中的方法
在由此对象处理的每个 UI 上调用 viewToModel 方法。
viewToModel(JTextComponent, Point) - 类 javax.swing.plaf.TextUI 中的方法
将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
viewToModel(JTextComponent, Point, Position.Bias[]) - 类 javax.swing.plaf.TextUI 中的方法
提供从视图坐标空间到模型的逻辑坐标空间的映射关系。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.AsyncBoxView 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.BoxView 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.ComponentView 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.CompositeView 中的方法
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.FieldView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(GlyphView, float, float, Shape, Position.Bias[]) - 类 javax.swing.text.GlyphView.GlyphPainter 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.GlyphView 中的方法
提供从视图坐标空间到模型逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.html.ImageView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.IconView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(Point) - 类 javax.swing.text.JTextComponent 中的方法
将视图坐标系统中的给定位置转换为模型中最具代表性的位置。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.PasswordView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.PlainView 中的方法
提供从视图坐标空间到该模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape, Position.Bias[]) - 类 javax.swing.text.View 中的方法
提供从视图坐标空间到模型的逻辑坐标空间的映射。
viewToModel(float, float, Shape) - 类 javax.swing.text.View 中的方法
已过时。
VirtualMachineError - java.lang 中的 错误
当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。
VirtualMachineError() - 错误 java.lang.VirtualMachineError 的构造方法
构造不带详细消息的 VirtualMachineError。
VirtualMachineError(String) - 错误 java.lang.VirtualMachineError 的构造方法
构造带指定详细消息的 VirtualMachineError。
Visibility - java.beans 中的 接口
在某些情况下，bean 可能运行在 GUI 不可用的服务器上。
VisibilityHelper - org.omg.CORBA 中的 类
Visibility 的 Helper。
VisibilityHelper() - 类 org.omg.CORBA.VisibilityHelper 的构造方法
VISIBLE - 类 javax.accessibility.AccessibleState 中的静态变量
指示此对象是可见的。
VISIBLE_ROW_COUNT_PROPERTY - 类 javax.swing.JTree 中的静态变量
visibleRowCount 的绑定属性名称。
visibleRowCount - 类 javax.swing.JTree 中的变量
一次可见的行数。
visit(AnnotationValue, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释值。
visit(AnnotationValue) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
等效于 v.visit(av, null) 的便捷方法。
visit(Element, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问一个元素。
visit(Element) - 接口 javax.lang.model.element.ElementVisitor 中的方法
等效于 v.visit(e, null) 的便捷方法。
visit(TypeMirror, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问一个类型。
visit(TypeMirror) - 接口 javax.lang.model.type.TypeVisitor 中的方法
等效于 v.visit(t, null) 的便捷方法。
visit(AnnotationValue, P) - 类 javax.lang.model.util.AbstractAnnotationValueVisitor6 中的方法
访问注释值，这与将自身传递给该值的 accept 方法一样。
visit(AnnotationValue) - 类 javax.lang.model.util.AbstractAnnotationValueVisitor6 中的方法
访问注释值，这与将自身传递给该值的 accept 方法，并为附加参数传递 null 一样。
visit(Element, P) - 类 javax.lang.model.util.AbstractElementVisitor6 中的方法
访问任何程序元素，这与将自身传递给该元素的 accept 方法一样。
visit(Element) - 类 javax.lang.model.util.AbstractElementVisitor6 中的方法
访问任何程序元素，这与将自身传递给该元素的 accept 方法，并为附加参数传递 null 一样。
visit(TypeMirror, P) - 类 javax.lang.model.util.AbstractTypeVisitor6 中的方法
访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法一样。
visit(TypeMirror) - 类 javax.lang.model.util.AbstractTypeVisitor6 中的方法
访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法，并为附加参数传递 null 一样。
visitAnnotation(AnnotationMirror, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 annotation 值。
visitAnnotation(AnnotationMirror, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 annotation 值。
visitArray(List<? extends AnnotationValue>, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 array 值。
visitArray(ArrayType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问数组类型。
visitArray(List<? extends AnnotationValue>, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 array 值。
visitArray(ArrayType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问数组类型。
visitBoolean(boolean, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 boolean 值。
visitBoolean(boolean, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 boolean 值。
visitByte(byte, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 byte 值。
visitByte(byte, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 byte 值。
visitChar(char, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 char 值。
visitChar(char, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 char 值。
visitDeclared(DeclaredType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问已声明的类型。
visitDeclared(DeclaredType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问已声明的类型。
visitDouble(double, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 double 值。
visitDouble(double, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 double 值。
visitEnumConstant(VariableElement, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 enum 值。
visitEnumConstant(VariableElement, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 enum 值。
visitError(ErrorType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问错误类型。
visitError(ErrorType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问错误类型。
visitExecutable(ExecutableElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问 executable 元素。
visitExecutable(ExecutableType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问 executable 类型。
visitExecutable(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问 executable 元素，指派给用于特定的 executable 种类 CONSTRUCTOR、INSTANCE_INIT、METHOD 或 STATIC_INIT 的 visit 方法。
visitExecutable(ExecutableElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问 executable 元素。
visitExecutable(ExecutableElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问 executable 元素。
visitExecutable(ExecutableType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问 executable 类型。
visitExecutableAsConstructor(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 CONSTRUCTOR executable 元素。
visitExecutableAsInstanceInit(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 INSTANCE_INIT executable 元素。
visitExecutableAsMethod(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 METHOD executable 元素。
visitExecutableAsStaticInit(ExecutableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 STATIC_INIT executable 元素。
visitFloat(float, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 float 值。
visitFloat(float, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 float 值。
visitInt(int, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 int 值。
visitInt(int, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 int 值。
visitLong(long, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 long 值。
visitLong(long, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 long 值。
visitNoType(NoType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问 NoType 实例。
visitNoType(NoType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问 NoType 实例。
visitNoType(NoType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
访问 NoType 实例，指派给用于以下特定的伪类型种类的 visit 方法：VOID、PACKAGE 或 NONE。
visitNoTypeAsNone(NoType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 NONE 伪类型。
visitNoTypeAsPackage(NoType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 PACKAGE 伪类型。
visitNoTypeAsVoid(NoType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 VOID 伪类型。
visitNull(NullType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问 null 类型。
visitNull(NullType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问 null 类型。
visitPackage(PackageElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问包元素。
visitPackage(PackageElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问包元素。
visitPackage(PackageElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问包元素。
visitPackage(PackageElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问包元素。
visitPrimitive(PrimitiveType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问基本类型。
visitPrimitive(PrimitiveType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问基本类型。
visitPrimitive(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
访问基本类型，指派给用于以下特定的基本类型种类的 visit 方法：BOOLEAN、BYTE 等。
visitPrimitiveAsBoolean(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 BOOLEAN 基本类型。
visitPrimitiveAsByte(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 BYTE 基本类型。
visitPrimitiveAsChar(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 CHAR 基本类型。
visitPrimitiveAsDouble(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 DOUBLE 基本类型。
visitPrimitiveAsFloat(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 FLOAT 基本类型。
visitPrimitiveAsInt(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 INT 基本类型。
visitPrimitiveAsLong(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 LONG 基本类型。
visitPrimitiveAsShort(PrimitiveType, P) - 类 javax.lang.model.util.TypeKindVisitor6 中的方法
通过调用 defaultAction 访问 SHORT 基本类型。
visitShort(short, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 short 值。
visitShort(short, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 short 值。
visitString(String, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 string 值。
visitString(String, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 string 值。
visitType(TypeMirror, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问注释中的 type 值。
visitType(TypeElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问类型元素。
visitType(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问类型元素，指派给用于特定的类型种类 ANNOTATION_TYPE、CLASS、ENUM 或 INTERFACE 的 visit 方法。
visitType(TypeElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问类型元素。
visitType(TypeMirror, P) - 类 javax.lang.model.util.SimpleAnnotationValueVisitor6 中的方法
访问注释中的 type 值。
visitType(TypeElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问类型元素。
visitTypeAsAnnotationType(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 ANNOTATION_TYPE 类型元素。
visitTypeAsClass(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 CLASS 类型元素。
visitTypeAsEnum(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 ENUM 类型元素。
visitTypeAsInterface(TypeElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 INTERFACE 类型元素。
visitTypeParameter(TypeParameterElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问类型参数元素。
visitTypeParameter(TypeParameterElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问类型参数元素。
visitTypeVariable(TypeVariable, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问类型变量。
visitTypeVariable(TypeVariable, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问类型变量。
visitUnknown(AnnotationValue, P) - 接口 javax.lang.model.element.AnnotationValueVisitor 中的方法
访问未知种类的注释值。
visitUnknown(Element, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问未知种类的元素。
visitUnknown(TypeMirror, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问未知种类的类型。
visitUnknown(AnnotationValue, P) - 类 javax.lang.model.util.AbstractAnnotationValueVisitor6 中的方法
访问未知种类的注释值。
visitUnknown(Element, P) - 类 javax.lang.model.util.AbstractElementVisitor6 中的方法
访问未知种类的元素。
visitUnknown(TypeMirror, P) - 类 javax.lang.model.util.AbstractTypeVisitor6 中的方法
访问未知种类的类型。
visitVariable(VariableElement, P) - 接口 javax.lang.model.element.ElementVisitor 中的方法
访问变量元素。
visitVariable(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
访问变量元素，指派给用于特定的变量种类 ENUM_CONSTANT、EXCEPTION_PARAMETER、FIELD、LOCAL_VARIABLE 或 PARAMETER 的 visit 方法。
visitVariable(VariableElement, P) - 类 javax.lang.model.util.ElementScanner6 中的方法
访问变量元素。
visitVariable(VariableElement, P) - 类 javax.lang.model.util.SimpleElementVisitor6 中的方法
访问变量元素。
visitVariableAsEnumConstant(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 ENUM_CONSTANT 变量元素。
visitVariableAsExceptionParameter(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 EXCEPTION_PARAMETER 变量元素。
visitVariableAsField(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 FIELD 变量元素。
visitVariableAsLocalVariable(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 LOCAL_VARIABLE 变量元素。
visitVariableAsParameter(VariableElement, P) - 类 javax.lang.model.util.ElementKindVisitor6 中的方法
通过调用 defaultAction 访问 PARAMETER 变量元素。
visitWildcard(WildcardType, P) - 接口 javax.lang.model.type.TypeVisitor 中的方法
访问通配符类型。
visitWildcard(WildcardType, P) - 类 javax.lang.model.util.SimpleTypeVisitor6 中的方法
访问通配符类型。
VK_0 - 类 java.awt.event.KeyEvent 中的静态变量
VK_0 到 VK_9 与 ASCII 的‘0’到‘9’(0x30 - 0x39) 相同
VK_1 - 类 java.awt.event.KeyEvent 中的静态变量
VK_2 - 类 java.awt.event.KeyEvent 中的静态变量
VK_3 - 类 java.awt.event.KeyEvent 中的静态变量
VK_4 - 类 java.awt.event.KeyEvent 中的静态变量
VK_5 - 类 java.awt.event.KeyEvent 中的静态变量
VK_6 - 类 java.awt.event.KeyEvent 中的静态变量
VK_7 - 类 java.awt.event.KeyEvent 中的静态变量
VK_8 - 类 java.awt.event.KeyEvent 中的静态变量
VK_9 - 类 java.awt.event.KeyEvent 中的静态变量
VK_A - 类 java.awt.event.KeyEvent 中的静态变量
VK_A 到 VK_Z 与 ASCII 的‘A’到‘Z’(0x41 - 0x5A) 相同
VK_ACCEPT - 类 java.awt.event.KeyEvent 中的静态变量
用于 Accept 或 Commit 功能键的常量。
VK_ADD - 类 java.awt.event.KeyEvent 中的静态变量
VK_AGAIN - 类 java.awt.event.KeyEvent 中的静态变量
VK_ALL_CANDIDATES - 类 java.awt.event.KeyEvent 中的静态变量
用于 All Candidates 功能键的常量。
VK_ALPHANUMERIC - 类 java.awt.event.KeyEvent 中的静态变量
用于 Alphanumeric 功能键的常量。
VK_ALT - 类 java.awt.event.KeyEvent 中的静态变量
VK_ALT_GRAPH - 类 java.awt.event.KeyEvent 中的静态变量
用于 AltGraph 功能键的常量。
VK_AMPERSAND - 类 java.awt.event.KeyEvent 中的静态变量
VK_ASTERISK - 类 java.awt.event.KeyEvent 中的静态变量
VK_AT - 类 java.awt.event.KeyEvent 中的静态变量
用于 "@" 键的常量。
VK_B - 类 java.awt.event.KeyEvent 中的静态变量
VK_BACK_QUOTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_BACK_SLASH - 类 java.awt.event.KeyEvent 中的静态变量
用于反斜杠键 "\" 的常量。
VK_BACK_SPACE - 类 java.awt.event.KeyEvent 中的静态变量
VK_BEGIN - 类 java.awt.event.KeyEvent 中的静态变量
用于 Begin 键的常量。
VK_BRACELEFT - 类 java.awt.event.KeyEvent 中的静态变量
VK_BRACERIGHT - 类 java.awt.event.KeyEvent 中的静态变量
VK_C - 类 java.awt.event.KeyEvent 中的静态变量
VK_CANCEL - 类 java.awt.event.KeyEvent 中的静态变量
VK_CAPS_LOCK - 类 java.awt.event.KeyEvent 中的静态变量
VK_CIRCUMFLEX - 类 java.awt.event.KeyEvent 中的静态变量
用于 "^" 键的常量。
VK_CLEAR - 类 java.awt.event.KeyEvent 中的静态变量
VK_CLOSE_BRACKET - 类 java.awt.event.KeyEvent 中的静态变量
用于右方括号键 "]" 的常量。
VK_CODE_INPUT - 类 java.awt.event.KeyEvent 中的静态变量
用于 Code Input 功能键的常量。
VK_COLON - 类 java.awt.event.KeyEvent 中的静态变量
用于 ":" 键的常量。
VK_COMMA - 类 java.awt.event.KeyEvent 中的静态变量
用于逗号键 "," 的常量。
VK_COMPOSE - 类 java.awt.event.KeyEvent 中的静态变量
用于 Compose 功能键的常量。
VK_CONTEXT_MENU - 类 java.awt.event.KeyEvent 中的静态变量
用于 Microsoft Windows 上下文菜单键的常量。
VK_CONTROL - 类 java.awt.event.KeyEvent 中的静态变量
VK_CONVERT - 类 java.awt.event.KeyEvent 中的静态变量
用于 Convert 功能键的常量。
VK_COPY - 类 java.awt.event.KeyEvent 中的静态变量
VK_CUT - 类 java.awt.event.KeyEvent 中的静态变量
VK_D - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_ABOVEDOT - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_ABOVERING - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_ACUTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_BREVE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_CARON - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_CEDILLA - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_CIRCUMFLEX - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_DIAERESIS - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_DOUBLEACUTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_GRAVE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_IOTA - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_MACRON - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_OGONEK - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_SEMIVOICED_SOUND - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_TILDE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DEAD_VOICED_SOUND - 类 java.awt.event.KeyEvent 中的静态变量
VK_DECIMAL - 类 java.awt.event.KeyEvent 中的静态变量
VK_DELETE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DIVIDE - 类 java.awt.event.KeyEvent 中的静态变量
VK_DOLLAR - 类 java.awt.event.KeyEvent 中的静态变量
用于 "$" 键的常量。
VK_DOWN - 类 java.awt.event.KeyEvent 中的静态变量
用于非数字键盘向下方向键的常量。
VK_E - 类 java.awt.event.KeyEvent 中的静态变量
VK_END - 类 java.awt.event.KeyEvent 中的静态变量
VK_ENTER - 类 java.awt.event.KeyEvent 中的静态变量
VK_EQUALS - 类 java.awt.event.KeyEvent 中的静态变量
用于等号键 "=" 的常量。
VK_ESCAPE - 类 java.awt.event.KeyEvent 中的静态变量
VK_EURO_SIGN - 类 java.awt.event.KeyEvent 中的静态变量
用于欧洲货币符号键的常量。
VK_EXCLAMATION_MARK - 类 java.awt.event.KeyEvent 中的静态变量
用于 "!" 键的常量。
VK_F - 类 java.awt.event.KeyEvent 中的静态变量
VK_F1 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F1 功能键的常量。
VK_F10 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F10 功能键的常量。
VK_F11 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F11 功能键的常量。
VK_F12 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F12 功能键的常量。
VK_F13 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F13 功能键的常量。
VK_F14 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F14 功能键的常量。
VK_F15 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F15 功能键的常量。
VK_F16 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F16 功能键的常量。
VK_F17 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F17 功能键的常量。
VK_F18 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F18 功能键的常量。
VK_F19 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F19 功能键的常量。
VK_F2 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F2 功能键的常量。
VK_F20 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F20 功能键的常量。
VK_F21 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F21 功能键的常量。
VK_F22 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F22 功能键的常量。
VK_F23 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F23 功能键的常量。
VK_F24 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F24 功能键的常量。
VK_F3 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F3 功能键的常量。
VK_F4 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F4 功能键的常量。
VK_F5 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F5 功能键的常量。
VK_F6 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F6 功能键的常量。
VK_F7 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F7 功能键的常量。
VK_F8 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F8 功能键的常量。
VK_F9 - 类 java.awt.event.KeyEvent 中的静态变量
用于 F9 功能键的常量。
VK_FINAL - 类 java.awt.event.KeyEvent 中的静态变量
VK_FIND - 类 java.awt.event.KeyEvent 中的静态变量
VK_FULL_WIDTH - 类 java.awt.event.KeyEvent 中的静态变量
用于 Full-Width Characters 功能键的常量。
VK_G - 类 java.awt.event.KeyEvent 中的静态变量
VK_GREATER - 类 java.awt.event.KeyEvent 中的静态变量
VK_H - 类 java.awt.event.KeyEvent 中的静态变量
VK_HALF_WIDTH - 类 java.awt.event.KeyEvent 中的静态变量
用于 Half-Width Characters 功能键的常量。
VK_HELP - 类 java.awt.event.KeyEvent 中的静态变量
VK_HIRAGANA - 类 java.awt.event.KeyEvent 中的静态变量
用于 Hiragana 功能键的常量。
VK_HOME - 类 java.awt.event.KeyEvent 中的静态变量
VK_I - 类 java.awt.event.KeyEvent 中的静态变量
VK_INPUT_METHOD_ON_OFF - 类 java.awt.event.KeyEvent 中的静态变量
用于输入法开/关键的常量。
VK_INSERT - 类 java.awt.event.KeyEvent 中的静态变量
VK_INVERTED_EXCLAMATION_MARK - 类 java.awt.event.KeyEvent 中的静态变量
用于反向感叹号键的常量。
VK_J - 类 java.awt.event.KeyEvent 中的静态变量
VK_JAPANESE_HIRAGANA - 类 java.awt.event.KeyEvent 中的静态变量
用于 Japanese-Hiragana 功能键的常量。
VK_JAPANESE_KATAKANA - 类 java.awt.event.KeyEvent 中的静态变量
用于 Japanese-Katakana 功能键的常量。
VK_JAPANESE_ROMAN - 类 java.awt.event.KeyEvent 中的静态变量
用于 Japanese-Roman 功能键的常量。
VK_K - 类 java.awt.event.KeyEvent 中的静态变量
VK_KANA - 类 java.awt.event.KeyEvent 中的静态变量
VK_KANA_LOCK - 类 java.awt.event.KeyEvent 中的静态变量
用于锁定 Kana 功能键的常量。
VK_KANJI - 类 java.awt.event.KeyEvent 中的静态变量
VK_KATAKANA - 类 java.awt.event.KeyEvent 中的静态变量
用于 Katakana 功能键的常量。
VK_KP_DOWN - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘向下方向键的常量。
VK_KP_LEFT - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘向左方向键的常量。
VK_KP_RIGHT - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘向右方向键的常量。
VK_KP_UP - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘向上方向键的常量。
VK_L - 类 java.awt.event.KeyEvent 中的静态变量
VK_LEFT - 类 java.awt.event.KeyEvent 中的静态变量
用于非数字键盘向左方向键的常量。
VK_LEFT_PARENTHESIS - 类 java.awt.event.KeyEvent 中的静态变量
用于 "(" 键的常量。
VK_LESS - 类 java.awt.event.KeyEvent 中的静态变量
VK_M - 类 java.awt.event.KeyEvent 中的静态变量
VK_META - 类 java.awt.event.KeyEvent 中的静态变量
VK_MINUS - 类 java.awt.event.KeyEvent 中的静态变量
用于减号键 "-" 的常量
VK_MODECHANGE - 类 java.awt.event.KeyEvent 中的静态变量
VK_MULTIPLY - 类 java.awt.event.KeyEvent 中的静态变量
VK_N - 类 java.awt.event.KeyEvent 中的静态变量
VK_NONCONVERT - 类 java.awt.event.KeyEvent 中的静态变量
用于 Don't Convert 功能键的常量。
VK_NUM_LOCK - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMBER_SIGN - 类 java.awt.event.KeyEvent 中的静态变量
用于 "#" 键的常量。
VK_NUMPAD0 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD1 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD2 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD3 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD4 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD5 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD6 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD7 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD8 - 类 java.awt.event.KeyEvent 中的静态变量
VK_NUMPAD9 - 类 java.awt.event.KeyEvent 中的静态变量
VK_O - 类 java.awt.event.KeyEvent 中的静态变量
VK_OPEN_BRACKET - 类 java.awt.event.KeyEvent 中的静态变量
用于左方括号键 "[" 的常量。
VK_P - 类 java.awt.event.KeyEvent 中的静态变量
VK_PAGE_DOWN - 类 java.awt.event.KeyEvent 中的静态变量
VK_PAGE_UP - 类 java.awt.event.KeyEvent 中的静态变量
VK_PASTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_PAUSE - 类 java.awt.event.KeyEvent 中的静态变量
VK_PERIOD - 类 java.awt.event.KeyEvent 中的静态变量
用于句点键 "." 的常量。
VK_PLUS - 类 java.awt.event.KeyEvent 中的静态变量
用于 "+" 键的常量。
VK_PREVIOUS_CANDIDATE - 类 java.awt.event.KeyEvent 中的静态变量
用于 Previous Candidate 功能键的常量。
VK_PRINTSCREEN - 类 java.awt.event.KeyEvent 中的静态变量
VK_PROPS - 类 java.awt.event.KeyEvent 中的静态变量
VK_Q - 类 java.awt.event.KeyEvent 中的静态变量
VK_QUOTE - 类 java.awt.event.KeyEvent 中的静态变量
VK_QUOTEDBL - 类 java.awt.event.KeyEvent 中的静态变量
VK_R - 类 java.awt.event.KeyEvent 中的静态变量
VK_RIGHT - 类 java.awt.event.KeyEvent 中的静态变量
用于非数字键盘向右方向键的常量。
VK_RIGHT_PARENTHESIS - 类 java.awt.event.KeyEvent 中的静态变量
用于 ")" 键的常量。
VK_ROMAN_CHARACTERS - 类 java.awt.event.KeyEvent 中的静态变量
用于 Roman Characters 功能键的常量。
VK_S - 类 java.awt.event.KeyEvent 中的静态变量
VK_SCROLL_LOCK - 类 java.awt.event.KeyEvent 中的静态变量
VK_SEMICOLON - 类 java.awt.event.KeyEvent 中的静态变量
用于分号键 ";" 的常量。
VK_SEPARATER - 类 java.awt.event.KeyEvent 中的静态变量
此常量已废弃，包括它仅为了向后兼容。
VK_SEPARATOR - 类 java.awt.event.KeyEvent 中的静态变量
用于数字键盘分隔符键的常量。
VK_SHIFT - 类 java.awt.event.KeyEvent 中的静态变量
VK_SLASH - 类 java.awt.event.KeyEvent 中的静态变量
用于正斜杠键 "/" 的常量。
VK_SPACE - 类 java.awt.event.KeyEvent 中的静态变量
VK_STOP - 类 java.awt.event.KeyEvent 中的静态变量
VK_SUBTRACT - 类 java.awt.event.KeyEvent 中的静态变量
VK_T - 类 java.awt.event.KeyEvent 中的静态变量
VK_TAB - 类 java.awt.event.KeyEvent 中的静态变量
VK_U - 类 java.awt.event.KeyEvent 中的静态变量
VK_UNDEFINED - 类 java.awt.event.KeyEvent 中的静态变量
此值用于指出 keyCode 是未知的。
VK_UNDERSCORE - 类 java.awt.event.KeyEvent 中的静态变量
用于 "_" 键的常量。
VK_UNDO - 类 java.awt.event.KeyEvent 中的静态变量
VK_UP - 类 java.awt.event.KeyEvent 中的静态变量
用于非数字键盘向上方向键的常量。
VK_V - 类 java.awt.event.KeyEvent 中的静态变量
VK_W - 类 java.awt.event.KeyEvent 中的静态变量
VK_WINDOWS - 类 java.awt.event.KeyEvent 中的静态变量
用于 Microsoft Windows 的 "Windows" 键的常量。
VK_X - 类 java.awt.event.KeyEvent 中的静态变量
VK_Y - 类 java.awt.event.KeyEvent 中的静态变量
VK_Z - 类 java.awt.event.KeyEvent 中的静态变量
VLINK - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
VM_ABSTRACT - org.omg.CORBA 中的 接口
定义用来表示 typecode 中的 Abstract 接口的代码。
VM_CUSTOM - org.omg.CORBA 中的 接口
定义用来表示类型代码中自定义编组值类型的代码。
VM_NONE - org.omg.CORBA 中的 接口
定义代码，用来表示一个 typecode 中值类型的值。
VM_TRUNCATABLE - org.omg.CORBA 中的 接口
定义用来表示 typecode 中可截断值类型的代码。
VMID - java.rmi.dgc 中的 类
VMID 是跨所有 Java 虚拟机都唯一的标识符。
VMID() - 类 java.rmi.dgc.VMID 的构造方法
创建一个新的 VMID。
VoiceStatus - javax.sound.midi 中的 类
VoiceStatus 对象包含有关由 Synthesizer 生成的某个声音当前状态的信息。
VoiceStatus() - 类 javax.sound.midi.VoiceStatus 的构造方法
Void - java.lang 中的 类
Void 类是一个不可实例化的占位符类，它持有对表示 Java 关键字 void 的 Class 对象的引用。
VOID - 类 javax.management.openmbean.SimpleType 中的静态变量
SimpleType 实例描述其 Java 类名称为 java.lang.Void 的值。
VOLATILE - 类 java.lang.reflect.Modifier 中的静态变量
表示 volatile 修饰符的 int 值。
VolatileImage - java.awt.image 中的 类
VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。
VolatileImage() - 类 java.awt.image.VolatileImage 的构造方法
volume - 类 javax.sound.midi.VoiceStatus 中的变量
声音的当前 MIDI 音量级。
VOLUME - 类 javax.sound.sampled.FloatControl.Type 中的静态变量
表示某一行上的音量的控件。
vsb - 类 javax.swing.ScrollPaneLayout 中的变量
滚动窗格的子级垂直滚动条。
vsbChangeListener - 类 javax.swing.plaf.basic.BasicScrollPaneUI 中的变量
vsbPolicy - 类 javax.swing.ScrollPaneLayout 中的变量
垂直滚动条的显示策略。
VSPACE - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


W - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

W

W3C_LENGTH_UNITS - 类 javax.swing.JEditorPane 中的静态变量
用于客户机属性的关键字，指示是否为 html 呈现使用 w3c 兼容的长度单位。
W3C_XML_SCHEMA_INSTANCE_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
W3C XML Schema Instance Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。
W3C_XML_SCHEMA_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
W3C XML Schema Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。
W3C_XPATH_DATATYPE_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
W3C XPath Datatype Namespace URI. 被定义为 "http://www.w3.org/2003/11/xpath-datatypes"。
W3CDomHandler - javax.xml.bind.annotation 中的 类
W3C DOM（org.w3c.dom 包）的 DomHandler 实现。
W3CDomHandler() - 类 javax.xml.bind.annotation.W3CDomHandler 的构造方法
默认的构造方法。
W3CDomHandler(DocumentBuilder) - 类 javax.xml.bind.annotation.W3CDomHandler 的构造方法
允许应用程序指定使用哪一个 DOM 实现的构造方法。
W_RESIZE_CURSOR - 类 java.awt.Cursor 中的静态变量
调整窗口左边框大小的光标类型。
W_RESIZE_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.W_RESIZE_CURSOR 取代。
WAIS - 类 javax.print.attribute.standard.ReferenceUriSchemesSupported 中的静态变量
广域信息服务器 (WAIS) 协议。
wait(long) - 类 java.lang.Object 中的方法
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法，或者超过指定的时间量前，导致当前线程等待。
wait(long, int) - 类 java.lang.Object 中的方法
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法，或者其他某个线程中断当前线程，或者已超过某个实际时间量前，导致当前线程等待。
wait() - 类 java.lang.Object 中的方法
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法前，导致当前线程等待。
WAIT_CURSOR - 类 java.awt.Cursor 中的静态变量
等待光标类型。
WAIT_CURSOR - 类 java.awt.Frame 中的静态变量
已过时。 由 Cursor.WAIT_CURSOR 取代。
waitFor() - 类 java.lang.Process 中的方法
导致当前线程等待，如有必要，一直要等到由该 Process 对象表示的进程已经终止。
waitForAll() - 类 java.awt.MediaTracker 中的方法
开始加载由此媒体跟踪器跟踪的所有图像。
waitForAll(long) - 类 java.awt.MediaTracker 中的方法
开始加载由此媒体跟踪器跟踪的所有图像。
waitForID(int) - 类 java.awt.MediaTracker 中的方法
开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。
waitForID(int, long) - 类 java.awt.MediaTracker 中的方法
开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。
waitForIdle() - 类 java.awt.Robot 中的方法
在处理完当前事件队列中的所有事件之前，一直等待。
waitForWork() - 类 javax.swing.text.LayoutQueue 中的方法
由 worker 线程使用以获取一个要执行的新任务
wakeup() - 类 java.nio.channels.Selector 中的方法
使尚未返回的第一个选择操作立即返回。
WALL_TIME - 类 java.util.SimpleTimeZone 中的静态变量
指定为挂钟时间的开始或结束时间模式的常量。
WANTS_INPUT_PROPERTY - 类 javax.swing.JOptionPane 中的静态变量
wantsInput 的绑定属性名。
wantsInput - 类 javax.swing.JOptionPane 中的变量
如果为 true，则向用户提供 UI 窗口小部件以获取输入。
WARNING - 类 java.util.logging.Level 中的静态变量
WARNING 是指示潜在问题的消息级别。
warning(String) - 类 java.util.logging.Logger 中的方法
记录一条 WARNING 消息。
WARNING - 类 javax.print.attribute.standard.Severity 中的静态变量
指示 PrinterStateReason 是 "warning"。
WARNING - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
WARNING 消息类型。
WARNING - 类 javax.security.auth.callback.TextOutputCallback 中的静态变量
警告消息。
WARNING - 接口 javax.xml.bind.ValidationEvent 中的静态变量
根据 XML 1.0 Recommendation 的定义，不属于错误或致命错误的那些条件。
warning(TransformerException) - 接口 javax.xml.transform.ErrorListener 中的方法
接收警告通知。
warning(SAXParseException) - 接口 org.xml.sax.ErrorHandler 中的方法
接收警告的通知。
warning(SAXParseException) - 类 org.xml.sax.HandlerBase 中的方法
已过时。 接收解析器警告的通知。
warning(SAXParseException) - 类 org.xml.sax.helpers.DefaultHandler 中的方法
接收解析器警告的通知。
warning(SAXParseException) - 类 org.xml.sax.helpers.XMLFilterImpl 中的方法
过滤一个警告事件。
WARNING_DIALOG - 类 javax.swing.JRootPane 中的静态变量
供 windowDecorationStyle 属性使用的常量。
WARNING_MESSAGE - 类 javax.swing.JOptionPane 中的静态变量
用于警告消息。
warningListeners - 类 javax.imageio.ImageReader 中的变量
当前已注册 IIOReadWarningListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
warningListeners - 类 javax.imageio.ImageWriter 中的变量
当前已注册 IIOWriteWarningListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
warningLocales - 类 javax.imageio.ImageReader 中的变量
与每个当前已注册 IIOReadWarningListener 关联的 Locale 组成的 List，默认情况下初始化为 null，它与空 List 同义。
warningLocales - 类 javax.imageio.ImageWriter 中的变量
Locale 的 List，warningListeners 的每个元素都有一个 Locale 列表，默认情况下该列表被初始化为 null，它与空 List 同义。
warningOccurred(ImageReader, String) - 接口 javax.imageio.event.IIOReadWarningListener 中的方法
报告在解码中发生非严重错误。
warningOccurred(ImageWriter, int, String) - 接口 javax.imageio.event.IIOWriteWarningListener 中的方法
报告在编码中发生非严重错误。
wasFocused - 类 javax.swing.plaf.basic.BasicMenuUI.ChangeHandler 中的变量
wasIcon(JInternalFrame) - 类 javax.swing.DefaultDesktopManager 中的方法
如果组件已被图标化并且 desktopIcon 的边界是有效的，则返回 true，否则返回 false。
wasNull() - 接口 java.sql.CallableStatement 中的方法
查询最后一个读取的 OUT 参数是否为 SQL NULL。
wasNull() - 接口 java.sql.ResultSet 中的方法
报告最后一个读取的列是否具有值 SQL NULL。
wasNull() - 接口 java.sql.SQLInput 中的方法
获取最后一个读取的值是否为 SQL NULL。
wasNull() - 类 javax.sql.rowset.serial.SQLInputImpl 中的方法
确认从此 SQLInputImpl 对象读取的上一个值是否为 null。
WAVE - 类 javax.sound.sampled.AudioFileFormat.Type 中的静态变量
指定 WAVE 文件。
WCharSeqHelper - org.omg.CORBA 中的 类
WCharSeq 的 Helper。
WCharSeqHelper() - 类 org.omg.CORBA.WCharSeqHelper 的构造方法
WCharSeqHolder - org.omg.CORBA 中的 类
WCharSeq 的 Holder。
WCharSeqHolder() - 类 org.omg.CORBA.WCharSeqHolder 的构造方法
WCharSeqHolder(char[]) - 类 org.omg.CORBA.WCharSeqHolder 的构造方法
weakCompareAndSet(boolean, boolean) - 类 java.util.concurrent.atomic.AtomicBoolean 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
weakCompareAndSet(int, int) - 类 java.util.concurrent.atomic.AtomicInteger 中的方法
如果当前值 == 预期值，则以原子方式将该设置为给定的更新值。
weakCompareAndSet(int, int, int) - 类 java.util.concurrent.atomic.AtomicIntegerArray 中的方法
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
weakCompareAndSet(T, int, int) - 类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段值设置为给定的更新值。
weakCompareAndSet(long, long) - 类 java.util.concurrent.atomic.AtomicLong 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
weakCompareAndSet(int, long, long) - 类 java.util.concurrent.atomic.AtomicLongArray 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
weakCompareAndSet(T, long, long) - 类 java.util.concurrent.atomic.AtomicLongFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段设置为给定的更新值。
weakCompareAndSet(V, V, boolean, boolean) - 类 java.util.concurrent.atomic.AtomicMarkableReference 中的方法
如果当前引用 == 预期引用，并且当前标记等于预期标记，那么以原子方式将引用和标记的值设置为给定的更新值。
weakCompareAndSet(V, V) - 类 java.util.concurrent.atomic.AtomicReference 中的方法
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
weakCompareAndSet(int, E, E) - 类 java.util.concurrent.atomic.AtomicReferenceArray 中的方法
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
weakCompareAndSet(T, V, V) - 类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 中的方法
如果当前值 == 预期值，则以原子方式将此更新器管理的给定对象的字段设置为给定的更新值。
weakCompareAndSet(V, V, int, int) - 类 java.util.concurrent.atomic.AtomicStampedReference 中的方法
如果当前引用 == 预期引用，并且当前标志等于预期标志，则以原子方式将该引用和该标志的值设置为给定的更新值。
WeakHashMap<K,V> - java.util 中的 类
以弱键 实现的基于哈希表的 Map。
WeakHashMap(int, float) - 类 java.util.WeakHashMap 的构造方法
用给定的初始容量和加载因子构造一个新的空 WeakHashMap。
WeakHashMap(int) - 类 java.util.WeakHashMap 的构造方法
构造具有给定初始容量和默认加载因子 (0.75) 的新的空 WeakHashMap。
WeakHashMap() - 类 java.util.WeakHashMap 的构造方法
构造具有默认初始容量 (16) 和加载因子 (0.75) 的新的空 WeakHashMap。
WeakHashMap(Map<? extends K, ? extends V>) - 类 java.util.WeakHashMap 的构造方法
构造一个新 WeakHashMap，使其与指定的映射具有相同的映射关系。
WeakReference<T> - java.lang.ref 中的 类
弱引用对象，它们并不禁止其指示对象变得可终结，并被终结，然后被回收。
WeakReference(T) - 类 java.lang.ref.WeakReference 的构造方法
创建引用给定对象的新的弱引用。
WeakReference(T, ReferenceQueue<? super T>) - 类 java.lang.ref.WeakReference 的构造方法
创建引用给定对象的新的弱引用，并向给定队列注册该引用。
WebEndpoint - javax.xml.ws 中的 注释类型
此类用来注释所生成服务接口的 getPortName() 方法。
WebFault - javax.xml.ws 中的 注释类型
此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
WebMethod - javax.jws 中的 注释类型
定制一个公开为 Web Service 操作的方法。
WebParam - javax.jws 中的 注释类型
定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
WebParam.Mode - javax.jws 中的 枚举
参数的流向。
WebResult - javax.jws 中的 注释类型
定制返回值到 WSDL 部分和 XML 元素的映射关系。
WebRowSet - javax.sql.rowset 中的 接口
所有 WebRowSet 的实现都必须实现的标准接口。
WebService - javax.jws 中的 注释类型
将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。
WebServiceClient - javax.xml.ws 中的 注释类型
此类用来注释生成的服务接口。
WebServiceContext - javax.xml.ws 中的 接口
WebServiceContext 能使 Web 服务端点实现类访问与服务的请求有关的消息上下文和安全信息。
WebServiceException - javax.xml.ws 中的 异常
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。
WebServiceException() - 异常 javax.xml.ws.WebServiceException 的构造方法
构造一个新异常，它的详细消息为 null。
WebServiceException(String) - 异常 javax.xml.ws.WebServiceException 的构造方法
构造具有指定详细消息的新异常。
WebServiceException(String, Throwable) - 异常 javax.xml.ws.WebServiceException 的构造方法
构造一个具有指定详细消息和 cause 的新异常。
WebServiceException(Throwable) - 异常 javax.xml.ws.WebServiceException 的构造方法
构造具有指定 cause 和详细信息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新 WebServiceException。
WebServicePermission - javax.xml.ws 中的 类
此类定义 Web 服务权限。
WebServicePermission(String) - 类 javax.xml.ws.WebServicePermission 的构造方法
创建具有指定名称的新权限。
WebServicePermission(String, String) - 类 javax.xml.ws.WebServicePermission 的构造方法
创建具有指定名称和操作的新权限。
WebServiceProvider - javax.xml.ws 中的 注释类型
此类用来注释 Provider 实现类。
WebServiceRef - javax.xml.ws 中的 注释类型
WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
WebServiceRefs - javax.xml.ws 中的 注释类型
WebServiceRefs 注释允许在类级别声明多个 web 服务引用。
WEDNESDAY - 类 java.util.Calendar 中的静态变量
指示 Wednesday 的 Calendar.DAY_OF_WEEK 字段值。
WEEK_OF_MONTH - 类 java.text.DateFormat.Field 中的静态变量
标识 WEEK_OF_MONTH 字段的常量。
WEEK_OF_MONTH - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示当前月中的星期数。
WEEK_OF_MONTH_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 WEEK_OF_MONTH 字段的有用常量。
WEEK_OF_YEAR - 类 java.text.DateFormat.Field 中的静态变量
标识 WEEK_OF_YEAR 字段的常量。
WEEK_OF_YEAR - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，指示当前年中的星期数。
WEEK_OF_YEAR_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 WEEK_OF_YEAR 字段的有用常量。
weight - 类 java.awt.font.GlyphJustificationInfo 中的变量
此字形的 weight。
WEIGHT - 类 java.awt.font.TextAttribute 中的静态变量
字体 weight 的属性键。
WEIGHT_BOLD - 类 java.awt.font.TextAttribute 中的静态变量
标准的粗体 weight。
WEIGHT_DEMIBOLD - 类 java.awt.font.TextAttribute 中的静态变量
比 WEIGHT_BOLD 稍轻的 weight。
WEIGHT_DEMILIGHT - 类 java.awt.font.TextAttribute 中的静态变量
WEIGHT_LIGHT 和 WEIGHT_STANDARD 之间的中间 weight。
WEIGHT_EXTRA_LIGHT - 类 java.awt.font.TextAttribute 中的静态变量
最轻的预定义 weight。
WEIGHT_EXTRABOLD - 类 java.awt.font.TextAttribute 中的静态变量
特别重的 weight。
WEIGHT_HEAVY - 类 java.awt.font.TextAttribute 中的静态变量
比 WEIGHT_BOLD 稍重的 weight。
WEIGHT_LIGHT - 类 java.awt.font.TextAttribute 中的静态变量
标准的轻 weight。
WEIGHT_MEDIUM - 类 java.awt.font.TextAttribute 中的静态变量
WEIGHT_REGULAR 和 WEIGHT_BOLD 之间的中间 weight。
WEIGHT_REGULAR - 类 java.awt.font.TextAttribute 中的静态变量
标准 weight。
WEIGHT_SEMIBOLD - 类 java.awt.font.TextAttribute 中的静态变量
比 WEIGHT_REGULAR 稍重的 weight。
WEIGHT_ULTRABOLD - 类 java.awt.font.TextAttribute 中的静态变量
最重的预定义 weight。
weightx - 类 java.awt.GridBagConstraints 中的变量
指定如何分布额外的水平空间。
weighty - 类 java.awt.GridBagConstraints 中的变量
指定如何分布额外的垂直空间。
WEST - 类 java.awt.BorderLayout 中的静态变量
西区域的布局约束（容器左边）。
WEST - 类 java.awt.GridBagConstraints 中的静态变量
将组件置于其显示区域的左部，并在垂直方向上居中。
WEST - 类 javax.swing.SpringLayout 中的静态变量
指定组件的边界矩形的左边。
WEST - 接口 javax.swing.SwingConstants 中的静态变量
罗盘方向西（左）。
westPane - 类 javax.swing.plaf.basic.BasicInternalFrameUI 中的变量
WHEEL_BLOCK_SCROLL - 类 java.awt.event.MouseWheelEvent 中的静态变量
表示按“块”进行滚动的常量（如使用 page-up、page-down 键进行滚动）
WHEEL_UNIT_SCROLL - 类 java.awt.event.MouseWheelEvent 中的静态变量
表示按“单位”进行滚动的常量（如使用方向键进行滚动）
when - 类 java.awt.Event 中的变量
时间戳。
WHEN_ANCESTOR_OF_FOCUSED_COMPONENT - 类 javax.swing.JComponent 中的静态变量
用于 registerKeyboardAction 的常量，意味着当接收组件是获得焦点的组件的祖先或者其本身就是获得焦点的组件时，应该调用命令。
WHEN_FOCUSED - 类 javax.swing.JComponent 中的静态变量
用于 registerKeyboardAction 的常量，意味着在组件获得焦点时应该调用命令。
WHEN_IN_FOCUSED_WINDOW - 类 javax.swing.JComponent 中的静态变量
用于 registerKeyboardAction 的常量，意味着当接收组件处于获得焦点的窗口内或者其本身就是获得焦点的组件时，应该调用命令。
white - 类 java.awt.Color 中的静态变量
白色。
WHITE - 类 java.awt.Color 中的静态变量
白色。
WHITE_SPACE - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
WHITESPACE - 类 java.awt.font.GlyphMetrics 中的静态变量
指示一个无可视化表示形式的字形。
whitespaceChars(int, int) - 类 java.io.StreamTokenizer 中的方法
指定 low <= c <= high 范围中的所有字符 c 都是空白字符。
why - 异常 org.omg.CosNaming.NamingContextPackage.NotFound 中的变量
width - 类 java.awt.Component.BltBufferStrategy 中的变量
后台缓冲区的大小
width - 类 java.awt.Dimension 中的变量
dimension 的宽度，可以使用负值。
WIDTH - 类 java.awt.font.TextAttribute 中的静态变量
字体宽度的属性键。
width - 类 java.awt.geom.Arc2D.Double 中的变量
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。
width - 类 java.awt.geom.Arc2D.Float 中的变量
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。
width - 类 java.awt.geom.Ellipse2D.Double 中的变量
此 Ellipse2D 的总宽度。
width - 类 java.awt.geom.Ellipse2D.Float 中的变量
此 Ellipse2D 的总宽度。
width - 类 java.awt.geom.Rectangle2D.Double 中的变量
此 Rectangle2D 的宽度。
width - 类 java.awt.geom.Rectangle2D.Float 中的变量
此 Rectangle2D 的宽度。
width - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
此 RoundRectangle2D 的宽度。
width - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
此 RoundRectangle2D 的宽度。
WIDTH - 接口 java.awt.image.ImageObserver 中的静态变量
imageUpdate 的 infoflags 参数中的此标志指示基本图像的宽度现在可用，并且可从 width 参数中获取此宽度到 imageUpdate 回调方法。
width - 类 java.awt.image.Raster 中的变量
此 Raster 的宽度。
width - 类 java.awt.image.SampleModel 中的变量
此 SampleModel 描述的图像数据区域的宽度（以像素位单位）。
width - 类 java.awt.Rectangle 中的变量
Rectangle 的宽度。
width(Component) - 类 javax.swing.Spring 中的静态方法
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的宽度定义。
WIDTH - 类 javax.swing.SpringLayout 中的静态变量
指定组件边界矩形的宽度。
width - 类 javax.swing.table.TableColumn 中的变量
列的宽度。
WIDTH - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
WIDTH - 类 javax.swing.text.html.HTML.Attribute 中的静态变量
WIDTH_CONDENSED - 类 java.awt.font.TextAttribute 中的静态变量
最精简的预定义 width。
WIDTH_EXTENDED - 类 java.awt.font.TextAttribute 中的静态变量
最大扩展的预定义 width。
WIDTH_REGULAR - 类 java.awt.font.TextAttribute 中的静态变量
标准 width。
WIDTH_SEMI_CONDENSED - 类 java.awt.font.TextAttribute 中的静态变量
适度精简的 width。
WIDTH_SEMI_EXTENDED - 类 java.awt.font.TextAttribute 中的静态变量
适度扩展的 width。
WILDCARD - 类 javax.management.ObjectName 中的静态变量
定义通配符 "*:*" ObjectName。
WildcardType - java.lang.reflect 中的 接口
WildcardType 表示一个通配符类型表达式，如 ?、? extends Number 或 ? super Integer。
WildcardType - javax.lang.model.type 中的 接口
表示通配符类型参数。
WIND_EVEN_ODD - 类 java.awt.geom.Path2D 中的静态变量
用于确定路径内部的奇偶旋绕规则。
WIND_EVEN_ODD - 接口 java.awt.geom.PathIterator 中的静态变量
用于指定确定路径内部的奇偶规则的旋绕规则常量。
WIND_NON_ZERO - 类 java.awt.geom.Path2D 中的静态变量
用于确定路径内部的非零旋绕规则。
WIND_NON_ZERO - 接口 java.awt.geom.PathIterator 中的静态变量
用于指定确定路径内部的非零规则的旋绕规则常量。
WINDOW - 类 java.awt.SystemColor 中的静态变量
SystemColor.window 系统颜色的数组索引。
window - 类 java.awt.SystemColor 中的静态变量
为窗口的内部区域提供的背景色。
Window - java.awt 中的 类
Window 对象是一个没有边界和菜单栏的顶层窗口。
Window(Frame) - 类 java.awt.Window 的构造方法
构造一个新的、最初不可见的窗口，使用指定的 Frame 作为其所有者。
Window(Window) - 类 java.awt.Window 的构造方法
构造一个新的、最初不可见的窗口，使用指定 Window 作为其所有者。
Window(Window, GraphicsConfiguration) - 类 java.awt.Window 的构造方法
构造一个新的、最初不可见的窗口，使用指定的所有者 Window 和屏幕设备的 GraphicsConfiguration。
WINDOW - 类 javax.accessibility.AccessibleRole 中的静态变量
不带标题或边框的顶层窗口。
Window.AccessibleAWTWindow - java.awt 中的 类
此类实现对 Window 类的可访问性支持。
Window.AccessibleAWTWindow() - 类 java.awt.Window.AccessibleAWTWindow 的构造方法
WINDOW_ACTIVATED - 类 java.awt.event.WindowEvent 中的静态变量
窗口激活事件类型。
WINDOW_BORDER - 类 java.awt.SystemColor 中的静态变量
SystemColor.windowBorder 系统颜色的数组索引。
WINDOW_CLOSED - 类 java.awt.event.WindowEvent 中的静态变量
窗口关闭事件。
WINDOW_CLOSING - 类 java.awt.event.WindowEvent 中的静态变量
“窗口正在关闭”事件。
WINDOW_DEACTIVATED - 类 java.awt.event.WindowEvent 中的静态变量
窗口停用事件类型。
WINDOW_DEICONIFIED - 类 java.awt.event.WindowEvent 中的静态变量
窗口取消图标化事件类型。
WINDOW_DEICONIFY - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序取消窗口图标化。
WINDOW_DESTROY - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序关掉窗口。
WINDOW_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择窗口事件的事件掩码。
WINDOW_EXPOSE - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序公开窗口。
WINDOW_FIRST - 类 java.awt.event.WindowEvent 中的静态变量
用于窗口事件的 id 范围的起始编号。
WINDOW_FOCUS_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择窗口焦点事件的事件掩码。
WINDOW_GAINED_FOCUS - 类 java.awt.event.WindowEvent 中的静态变量
窗口获得焦点事件类型。
WINDOW_ICONIFIED - 类 java.awt.event.WindowEvent 中的静态变量
窗口图标化事件。
WINDOW_ICONIFY - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序图标化窗口。
WINDOW_LAST - 类 java.awt.event.WindowEvent 中的静态变量
用于窗口事件的 id 范围的结束编号。
WINDOW_LOST_FOCUS - 类 java.awt.event.WindowEvent 中的静态变量
窗口失去焦点事件类型。
WINDOW_MOVED - 类 java.awt.Event 中的静态变量
用户要求窗口管理程序移动窗口。
WINDOW_OPENED - 类 java.awt.event.WindowEvent 中的静态变量
窗口打开事件。
WINDOW_STATE_CHANGED - 类 java.awt.event.WindowEvent 中的静态变量
窗口状态改变事件类型。
WINDOW_STATE_EVENT_MASK - 类 java.awt.AWTEvent 中的静态变量
用于选择窗口状态事件的事件掩码。
WINDOW_TEXT - 类 java.awt.SystemColor 中的静态变量
SystemColor.windowText 系统颜色的数组索引。
windowActivated(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowActivated 方法处理 windowActivated 事件。
windowActivated(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
激活窗口时调用。
windowActivated(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
将 Window 设置为活动 Window 时调用。
WindowAdapter - java.awt.event 中的 类
接收窗口事件的抽象适配器类。
WindowAdapter() - 类 java.awt.event.WindowAdapter 的构造方法
windowBorder - 类 java.awt.SystemColor 中的静态变量
为窗口内部区域的边框提供的颜色。
windowClosed(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowClosed 方法处理 windowClosed 事件。
windowClosed(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
当窗口已被关闭时调用。
windowClosed(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
因对窗口调用 dispose 而将其关闭时调用。
windowClosing(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowClosing 方法处理 windowClosing 事件。
windowClosing(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
窗口正处在关闭过程中时调用。
windowClosing(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
用户试图从窗口的系统菜单中关闭窗口时调用。
windowClosing(WindowEvent) - 类 javax.swing.JMenu.WinListener 中的方法
从外部关闭弹出菜单时取消选择该菜单。
windowClosing(WindowEvent) - 类 javax.swing.plaf.basic.BasicToolBarUI.FrameListener 中的方法
WindowConstants - javax.swing 中的 接口
用于控制窗口关闭操作的常量。
windowDeactivated(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowDeactivated 方法处理 windowDeactivated 事件。
windowDeactivated(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
停用窗口时调用。
windowDeactivated(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
当 Window 不再是活动 Window 时调用。
windowDeiconified(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowDeiconified 方法处理 windowDeiconified 事件。
windowDeiconified(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
取消图标化窗口时调用。
windowDeiconified(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
窗口从最小化状态变为正常状态时调用。
WindowEvent - java.awt.event 中的 类
指示窗口状态改变的低级别事件。
WindowEvent(Window, int, Window, int, int) - 类 java.awt.event.WindowEvent 的构造方法
构造一个 WindowEvent 对象。
WindowEvent(Window, int, Window) - 类 java.awt.event.WindowEvent 的构造方法
构造一个具有指定对应 Window 的 WindowEvent 对象。
WindowEvent(Window, int, int, int) - 类 java.awt.event.WindowEvent 的构造方法
构造一个具有指定的以前和新窗口状态的 WindowEvent 对象。
WindowEvent(Window, int) - 类 java.awt.event.WindowEvent 的构造方法
构造一个 WindowEvent 对象。
WindowFocusListener - java.awt.event 中的 接口
用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
windowForComponent(Component) - 类 javax.swing.SwingUtilities 中的静态方法
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
windowGainedFocus(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowGainedFocus 方法处理 windowGainedFocus 事件。
windowGainedFocus(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
windowGainedFocus(WindowEvent) - 接口 java.awt.event.WindowFocusListener 中的方法
该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
windowIconified(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowIconified 方法处理 windowIconified 事件。
windowIconified(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
图标化窗口时调用。
windowIconified(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
窗口从正常状态变为最小化状态时调用。
windowInit() - 类 javax.swing.JWindow 中的方法
由该构造方法调用以正确初始化 JWindow。
WindowListener - java.awt.event 中的 接口
用于接收窗口事件的侦听器接口。
windowLostFocus(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowLostFocus 方法处理 windowLostFocus 事件。
windowLostFocus(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
该 Window 不再为聚焦 Window 时调用，不再为聚焦 Window 意味着键盘事件不再传递到该 Window 或其任意子组件。
windowLostFocus(WindowEvent) - 接口 java.awt.event.WindowFocusListener 中的方法
该 Window 不再是聚焦 Window 时调用，不再是聚焦 Window 意味着不再传递键盘事件到该 Window 或其任意子组件。
windowMenu - 类 javax.swing.plaf.basic.BasicInternalFrameTitlePane 中的变量
windowOpened(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowOpened 方法处理 windowOpened 事件。
windowOpened(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
已打开窗口时调用。
windowOpened(WindowEvent) - 接口 java.awt.event.WindowListener 中的方法
窗口首次变为可见时调用。
windowStateChanged(WindowEvent) - 类 java.awt.AWTEventMulticaster 中的方法
通过在侦听器 a 和侦听器 b 上调用 windowStateChanged 方法处理 windowStateChanged 事件。
windowStateChanged(WindowEvent) - 类 java.awt.event.WindowAdapter 中的方法
窗口状态改变时调用。
windowStateChanged(WindowEvent) - 接口 java.awt.event.WindowStateListener 中的方法
窗口状态改变时调用。
WindowStateListener - java.awt.event 中的 接口
用于接收窗口状态事件的侦听器接口。
windowText - 类 java.awt.SystemColor 中的静态变量
为窗口内部区域的文本提供的颜色。
WORD - 接口 javax.accessibility.AccessibleText 中的静态变量
用于指示应获取的文本部分是一个单词的常量。
WORD_SPACING - 类 javax.swing.text.html.CSS.Attribute 中的静态变量
wordChars(int, int) - 类 java.io.StreamTokenizer 中的方法
指定 low <= c <= high 范围中的所有字符 c 都是文字成分。
work_pending() - 类 org.omg.CORBA.ORB 中的方法
如果 ORB 需要主线程来执行某些操作，则返回 true；如果 ORB 不需要主线程，则返回 false。
wrap(byte[], int, int) - 类 java.nio.ByteBuffer 中的静态方法
将 byte 数组包装到缓冲区中。
wrap(byte[]) - 类 java.nio.ByteBuffer 中的静态方法
将 byte 数组包装到缓冲区中。
wrap(char[], int, int) - 类 java.nio.CharBuffer 中的静态方法
将字符数组包装到缓冲区中。
wrap(char[]) - 类 java.nio.CharBuffer 中的静态方法
将字符数组包装到缓冲区中。
wrap(CharSequence, int, int) - 类 java.nio.CharBuffer 中的静态方法
将字符序列包装到缓冲区中。
wrap(CharSequence) - 类 java.nio.CharBuffer 中的静态方法
将字符序列包装到缓冲区中。
wrap(double[], int, int) - 类 java.nio.DoubleBuffer 中的静态方法
将 double 数组包装到缓冲区中。
wrap(double[]) - 类 java.nio.DoubleBuffer 中的静态方法
将 double 数组包装到缓冲区中。
wrap(float[], int, int) - 类 java.nio.FloatBuffer 中的静态方法
将 float 数组包装到缓冲区中。
wrap(float[]) - 类 java.nio.FloatBuffer 中的静态方法
将 float 数组包装到缓冲区中。
wrap(int[], int, int) - 类 java.nio.IntBuffer 中的静态方法
将 int 数组包装到缓冲区中。
wrap(int[]) - 类 java.nio.IntBuffer 中的静态方法
将 int 数组包装到缓冲区中。
wrap(long[], int, int) - 类 java.nio.LongBuffer 中的静态方法
将 long 数组包装到缓冲区中。
wrap(long[]) - 类 java.nio.LongBuffer 中的静态方法
将 long 数组包装到缓冲区中。
wrap(short[], int, int) - 类 java.nio.ShortBuffer 中的静态方法
将 short 数组包装到缓冲区中。
wrap(short[]) - 类 java.nio.ShortBuffer 中的静态方法
将 short 数组包装到缓冲区中。
wrap(Key) - 类 javax.crypto.Cipher 中的方法
包装密钥。
wrap(ByteBuffer, ByteBuffer) - 类 javax.net.ssl.SSLEngine 中的方法
试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。
wrap(ByteBuffer[], ByteBuffer) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
wrap(ByteBuffer[], int, int, ByteBuffer) - 类 javax.net.ssl.SSLEngine 中的方法
尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
wrap(byte[], int, int) - 接口 javax.security.sasl.SaslClient 中的方法
包装要发送到服务器的 byte 数组。
wrap(byte[], int, int) - 接口 javax.security.sasl.SaslServer 中的方法
包装要发送到客户端的 byte 数组。
wrap(byte[], int, int, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
将 per-message 安全服务应用于已创建的安全上下文。
wrap(InputStream, OutputStream, MessageProp) - 接口 org.ietf.jgss.GSSContext 中的方法
将 per-message 安全服务应用于已创建的使用流的安全上下文。
WRAP_MODE - 类 javax.crypto.Cipher 中的静态变量
用于将 Cipher 初始化为密钥包装模式的常量。
WRAP_TAB_LAYOUT - 类 javax.swing.JTabbedPane 中的静态变量
当在一次运行中不能放入所有的选项卡时，在多次运行中包装选项卡的选项卡布局策略。
wrapException(Throwable) - 类 javax.rmi.CORBA.Util 中的静态方法
包装由实现方法抛出的异常。
wrapException(Throwable) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.wrapException(java.lang.Throwable) 的委托调用。
WrappedPlainView - javax.swing.text 中的 类
进行换行的纯文本（仅有一种字体和颜色的文本）视图。
WrappedPlainView(Element) - 类 javax.swing.text.WrappedPlainView 的构造方法
创建一个新的 WrappedPlainView。
WrappedPlainView(Element, boolean) - 类 javax.swing.text.WrappedPlainView 的构造方法
创建一个新的 WrappedPlainView。
Wrapper - java.sql 中的 接口
在相关实例实际上是代理类时提供获取委托实例能力的 JDBC 类的接口。
writableAction - 类 javax.swing.text.DefaultEditorKit 中的静态变量
将编辑器设置为可写入模式的动作名称。
WritableByteChannel - java.nio.channels 中的 接口
可写入字节的通道。
WritableRaster - java.awt.image 中的 类
此类扩展了 Raster 以提供像素写入功能。
WritableRaster(SampleModel, Point) - 类 java.awt.image.WritableRaster 的构造方法
构造具有给定 SampleModel 的 WritableRaster。
WritableRaster(SampleModel, DataBuffer, Point) - 类 java.awt.image.WritableRaster 的构造方法
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster(SampleModel, DataBuffer, Rectangle, Point, WritableRaster) - 类 java.awt.image.WritableRaster 的构造方法
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。
WritableRenderedImage - java.awt.image 中的 接口
WriteableRenderedImage 公共接口用于那些包含或者能够生成 Rasters 形式图像数据的对象，以及能够被修改和/或写入的对象。
write(String) - 类 java.awt.color.ICC_Profile 中的方法
将此 ICC_Profile 写入一个文件。
write(OutputStream) - 类 java.awt.color.ICC_Profile 中的方法
将 ICC_Profile 写入一个 OutputStream。
write(int) - 类 java.io.BufferedOutputStream 中的方法
将指定的字节写入此缓冲的输出流。
write(byte[], int, int) - 类 java.io.BufferedOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此缓冲的输出流。
write(int) - 类 java.io.BufferedWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.BufferedWriter 中的方法
写入字符数组的某一部分。
write(String, int, int) - 类 java.io.BufferedWriter 中的方法
写入字符串的某一部分。
write(int) - 类 java.io.ByteArrayOutputStream 中的方法
将指定的字节写入此 byte 数组输出流。
write(byte[], int, int) - 类 java.io.ByteArrayOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此 byte 数组输出流。
write(int) - 类 java.io.CharArrayWriter 中的方法
将一个字符写入缓冲区。
write(char[], int, int) - 类 java.io.CharArrayWriter 中的方法
将字符写入缓冲区。
write(String, int, int) - 类 java.io.CharArrayWriter 中的方法
将字符串的某一部分写入缓冲区。
write(int) - 接口 java.io.DataOutput 中的方法
将参数 b 的八个低位写入输出流。
write(byte[]) - 接口 java.io.DataOutput 中的方法
将数组 b 中的所有字节写入输出流。
write(byte[], int, int) - 接口 java.io.DataOutput 中的方法
将数组 b 中的 len 个字节按顺序写入输出流。
write(int) - 类 java.io.DataOutputStream 中的方法
将指定字节（参数 b 的八个低位）写入基础输出流。
write(byte[], int, int) - 类 java.io.DataOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入基础输出流。
write(int) - 类 java.io.FileOutputStream 中的方法
将指定字节写入此文件输出流。
write(byte[]) - 类 java.io.FileOutputStream 中的方法
将 b.length 个字节从指定 byte 数组写入此文件输出流中。
write(byte[], int, int) - 类 java.io.FileOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此文件输出流。
write(int) - 类 java.io.FilterOutputStream 中的方法
将指定 byte 写入此输出流。
write(byte[]) - 类 java.io.FilterOutputStream 中的方法
将 b.length 个字节写入此输出流。
write(byte[], int, int) - 类 java.io.FilterOutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
write(int) - 类 java.io.FilterWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.FilterWriter 中的方法
将字符写入数组的某一部分。
write(String, int, int) - 类 java.io.FilterWriter 中的方法
写入一部分字符串。
write(int) - 接口 java.io.ObjectOutput 中的方法
写入字节。
write(byte[]) - 接口 java.io.ObjectOutput 中的方法
写入 byte 数组。
write(byte[], int, int) - 接口 java.io.ObjectOutput 中的方法
写入字节的子数组。
write(ObjectOutput) - 类 java.io.ObjectOutputStream.PutField 中的方法
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。
write(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个字节。
write(byte[]) - 类 java.io.ObjectOutputStream 中的方法
写入一个 byte 数组。
write(byte[], int, int) - 类 java.io.ObjectOutputStream 中的方法
写入字节的子数组。
write(int) - 类 java.io.OutputStream 中的方法
将指定的字节写入此输出流。
write(byte[]) - 类 java.io.OutputStream 中的方法
将 b.length 个字节从指定的 byte 数组写入此输出流。
write(byte[], int, int) - 类 java.io.OutputStream 中的方法
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
write(int) - 类 java.io.OutputStreamWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.OutputStreamWriter 中的方法
写入字符数组的某一部分。
write(String, int, int) - 类 java.io.OutputStreamWriter 中的方法
写入字符串的某一部分。
write(int) - 类 java.io.PipedOutputStream 中的方法
将指定 byte 写入传送的输出流。
write(byte[], int, int) - 类 java.io.PipedOutputStream 中的方法
将 len 字节从初始偏移量为 off 的指定 byte 数组写入该管道输出流。
write(int) - 类 java.io.PipedWriter 中的方法
将指定的 char 写入管道输出流。
write(char[], int, int) - 类 java.io.PipedWriter 中的方法
将 len 字符从指定初始偏移量为 off 的字符数组写入到此管道输出流。
write(int) - 类 java.io.PrintStream 中的方法
将指定的字节写入此流。
write(byte[], int, int) - 类 java.io.PrintStream 中的方法
将 len 字节从指定的初始偏移量为 off 的 byte 数组写入此流。
write(int) - 类 java.io.PrintWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.PrintWriter 中的方法
写入字符数组的某一部分。
write(char[]) - 类 java.io.PrintWriter 中的方法
写入字符数组。
write(String, int, int) - 类 java.io.PrintWriter 中的方法
写入字符串的某一部分。
write(String) - 类 java.io.PrintWriter 中的方法
写入字符串。
write(int) - 类 java.io.RandomAccessFile 中的方法
向此文件写入指定的字节。
write(byte[]) - 类 java.io.RandomAccessFile 中的方法
将 b.length 个字节从指定 byte 数组写入到此文件，并从当前文件指针开始。
write(byte[], int, int) - 类 java.io.RandomAccessFile 中的方法
将 len 个字节从指定 byte 数组写入到此文件，并从偏移量 off 处开始。
write(int) - 类 java.io.StringWriter 中的方法
写入单个字符。
write(char[], int, int) - 类 java.io.StringWriter 中的方法
写入字符数组的某一部分。
write(String) - 类 java.io.StringWriter 中的方法
写入一个字符串。
write(String, int, int) - 类 java.io.StringWriter 中的方法
写入字符串的某一部分。
write(int) - 类 java.io.Writer 中的方法
写入单个字符。
write(char[]) - 类 java.io.Writer 中的方法
写入字符数组。
write(char[], int, int) - 类 java.io.Writer 中的方法
写入字符数组的某一部分。
write(String) - 类 java.io.Writer 中的方法
写入字符串。
write(String, int, int) - 类 java.io.Writer 中的方法
写入字符串的某一部分。
write(ByteBuffer) - 类 java.nio.channels.DatagramChannel 中的方法
将数据报写入此通道。
write(ByteBuffer[], int, int) - 类 java.nio.channels.DatagramChannel 中的方法
将数据报写入此通道。
write(ByteBuffer[]) - 类 java.nio.channels.DatagramChannel 中的方法
将数据报写入此通道。
write(ByteBuffer) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从给定的缓冲区写入此通道。
write(ByteBuffer[], int, int) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从给定缓冲区的子序列写入此通道。
write(ByteBuffer[]) - 类 java.nio.channels.FileChannel 中的方法
将字节序列从给定的缓冲区写入此通道。
write(ByteBuffer, long) - 类 java.nio.channels.FileChannel 中的方法
从给定的文件位置开始，将字节序列从给定缓冲区写入此通道。
write(ByteBuffer[], int, int) - 接口 java.nio.channels.GatheringByteChannel 中的方法
将字节序列从给定缓冲区的子序列写入此通道。
write(ByteBuffer[]) - 接口 java.nio.channels.GatheringByteChannel 中的方法
将字节序列从给定的缓冲区写入此通道。
write(ByteBuffer) - 类 java.nio.channels.SocketChannel 中的方法
write(ByteBuffer[], int, int) - 类 java.nio.channels.SocketChannel 中的方法
write(ByteBuffer[]) - 类 java.nio.channels.SocketChannel 中的方法
write(ByteBuffer) - 接口 java.nio.channels.WritableByteChannel 中的方法
将字节序列从给定的缓冲区中写入此通道。
write(int) - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
write(byte[], int, int) - 类 java.rmi.server.LogStream 中的方法
已过时。 无替代版本
write(ObjectOutput) - 类 java.rmi.server.ObjID 中的方法
将此 ObjID 的二进制表示形式编组为一个 ObjectOutput 实例。
write(DataOutput) - 类 java.rmi.server.UID 中的方法
将此 UID 的二进制表示形式编组为一个 DataOutput 实例。
write(int) - 类 java.security.DigestOutputStream 中的方法
使用指定的字节更新消息摘要（如果开启了摘要功能），并将字节写入输出流（不管是否开启了摘要功能）。
write(byte[], int, int) - 类 java.security.DigestOutputStream 中的方法
使用指定的子数组更新消息摘要（如果开启了摘要功能），并将子数组写入输出流（不管是否开启了摘要功能）。
write(OutputStream) - 类 java.util.jar.Manifest 中的方法
将 Manifest 写入指定的 OutputStream。
write(int) - 类 java.util.zip.CheckedOutputStream 中的方法
写入字节。
write(byte[], int, int) - 类 java.util.zip.CheckedOutputStream 中的方法
写入字节数组。
write(int) - 类 java.util.zip.DeflaterOutputStream 中的方法
将字节写入压缩的输出流。
write(byte[], int, int) - 类 java.util.zip.DeflaterOutputStream 中的方法
将字节数组写入压缩的输出流。
write(byte[], int, int) - 类 java.util.zip.GZIPOutputStream 中的方法
将字节数组写入压缩输出流。
write(int) - 类 java.util.zip.InflaterOutputStream 中的方法
将字节写入未压缩输出流。
write(byte[], int, int) - 类 java.util.zip.InflaterOutputStream 中的方法
将 byte 数组写入未压缩输出流。
write(byte[], int, int) - 类 java.util.zip.ZipOutputStream 中的方法
将字节数组写入当前 ZIP 条目数据。
write(int) - 类 javax.crypto.CipherOutputStream 中的方法
将指定的字节写入此输出流。
write(byte[]) - 类 javax.crypto.CipherOutputStream 中的方法
从指定的字节数组中将 b.length 个字节写入此输出流。
write(byte[], int, int) - 类 javax.crypto.CipherOutputStream 中的方法
将指定的字节数组中从 off 偏移量开始的 len 个字节写入此输出流。
write(RenderedImage, String, ImageOutputStream) - 类 javax.imageio.ImageIO 中的静态方法
使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。
write(RenderedImage, String, File) - 类 javax.imageio.ImageIO 中的静态方法
使用支持给定格式的任意 ImageWriter 将一个图像写入 File。
write(RenderedImage, String, OutputStream) - 类 javax.imageio.ImageIO 中的静态方法
使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。
write(IIOMetadata, IIOImage, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
write(IIOImage) - 类 javax.imageio.ImageWriter 中的方法
将包含带有默认元数据和缩略图的单个图像的完整图像流添加到输出中。
write(RenderedImage) - 类 javax.imageio.ImageWriter 中的方法
将由带有默认元数据和缩略图的单个图像组成的完整图像流添加到输出中。
write(int) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
write(byte[], int, int) - 类 javax.imageio.stream.FileCacheImageOutputStream 中的方法
write(int) - 类 javax.imageio.stream.FileImageOutputStream 中的方法
write(byte[], int, int) - 类 javax.imageio.stream.FileImageOutputStream 中的方法
write(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将单个字节写入到流中的当前位置。
write(byte[]) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将字节序列写入到流中的当前位置。
write(byte[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将字节序列写入到流中的当前位置。
write(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
write(byte[]) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
write(byte[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
write(int) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
write(byte[], int, int) - 类 javax.imageio.stream.MemoryCacheImageOutputStream 中的方法
write(Sequence, int, OutputStream) - 类 javax.sound.midi.MidiSystem 中的静态方法
将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。
write(Sequence, int, File) - 类 javax.sound.midi.MidiSystem 中的静态方法
将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。
write(Sequence, int, OutputStream) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。
write(Sequence, int, File) - 类 javax.sound.midi.spi.MidiFileWriter 中的方法
写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。
write(AudioInputStream, AudioFileFormat.Type, OutputStream) - 类 javax.sound.sampled.AudioSystem 中的静态方法
将表示指定文件类型的音频文件的字节流写入所提供的输出流。
write(AudioInputStream, AudioFileFormat.Type, File) - 类 javax.sound.sampled.AudioSystem 中的静态方法
将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
write(byte[], int, int) - 接口 javax.sound.sampled.SourceDataLine 中的方法
通过此源数据行将音频数据写入混频器。
write(AudioInputStream, AudioFileFormat.Type, OutputStream) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
将表示所指示文件类型的音频文件的字节流写入所提供的输出流。
write(AudioInputStream, AudioFileFormat.Type, File) - 类 javax.sound.sampled.spi.AudioFileWriter 中的方法
将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
write() - 类 javax.swing.text.AbstractWriter 中的方法
需要由子类实现此抽象方法。
write(char) - 类 javax.swing.text.AbstractWriter 中的方法
写出字符。
write(String) - 类 javax.swing.text.AbstractWriter 中的方法
写出字符串。
write(char[], int, int) - 类 javax.swing.text.AbstractWriter 中的方法
所有 write 方法都调用到此方法。
write(OutputStream, Document, int, int) - 类 javax.swing.text.DefaultEditorKit 中的方法
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
write(Writer, Document, int, int) - 类 javax.swing.text.DefaultEditorKit 中的方法
将取自文档的内容以纯文本格式写入给定流。
write(OutputStream, Document, int, int) - 类 javax.swing.text.EditorKit 中的方法
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
write(Writer, Document, int, int) - 类 javax.swing.text.EditorKit 中的方法
将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
write(Writer, Document, int, int) - 类 javax.swing.text.html.HTMLEditorKit 中的方法
以适合此类内容处理程序的格式，将文档中的内容写入给定流。
write() - 类 javax.swing.text.html.HTMLWriter 中的方法
对 Element 树进行迭代并控制所有标记及其属性的写出。
write() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
从 StyledDocument 生成 HTML 输出。
write(Writer) - 类 javax.swing.text.JTextComponent 中的方法
将模型的内容存储到给定的流中。
write(OutputStream, Document, int, int) - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
以适合此类内容处理程序的格式，将文档中的内容写入给定流。
write(Writer, Document, int, int) - 类 javax.swing.text.rtf.RTFEditorKit 中的方法
将文档中的内容作为纯文本写入给定的流。
write(OutputStream, Any[]) - 类 org.omg.CORBA.AnySeqHelper 中的静态方法
write(OutputStream, boolean[]) - 类 org.omg.CORBA.BooleanSeqHelper 中的静态方法
write(OutputStream, char[]) - 类 org.omg.CORBA.CharSeqHelper 中的静态方法
write(OutputStream, CompletionStatus) - 类 org.omg.CORBA.CompletionStatusHelper 中的静态方法
write(OutputStream, Current) - 类 org.omg.CORBA.CurrentHelper 中的静态方法
write(OutputStream, DefinitionKind) - 类 org.omg.CORBA.DefinitionKindHelper 中的静态方法
write(OutputStream, double[]) - 类 org.omg.CORBA.DoubleSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.FieldNameHelper 中的静态方法
write(OutputStream, float[]) - 类 org.omg.CORBA.FloatSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.IdentifierHelper 中的静态方法
write(OutputStream, IDLType) - 类 org.omg.CORBA.IDLTypeHelper 中的静态方法
write(OutputStream, long[]) - 类 org.omg.CORBA.LongLongSeqHelper 中的静态方法
write(OutputStream, int[]) - 类 org.omg.CORBA.LongSeqHelper 中的静态方法
write(OutputStream, NameValuePair) - 类 org.omg.CORBA.NameValuePairHelper 中的静态方法
write(OutputStream, Object) - 类 org.omg.CORBA.ObjectHelper 中的静态方法
write(OutputStream, byte[]) - 类 org.omg.CORBA.OctetSeqHelper 中的静态方法
write(OutputStream, ParameterMode) - 类 org.omg.CORBA.ParameterModeHelper 中的静态方法
write(OutputStream, short) - 类 org.omg.CORBA.PolicyErrorCodeHelper 中的静态方法
write(OutputStream, PolicyError) - 类 org.omg.CORBA.PolicyErrorHelper 中的静态方法
write(OutputStream, Policy) - 类 org.omg.CORBA.PolicyHelper 中的静态方法
write(OutputStream, Policy[]) - 类 org.omg.CORBA.PolicyListHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.CORBA.PolicyTypeHelper 中的静态方法
write(int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 integer（数组长度）写入此流。
write(OutputStream, String) - 类 org.omg.CORBA.RepositoryIdHelper 中的静态方法
write(OutputStream, ServiceDetail) - 类 org.omg.CORBA.ServiceDetailHelper 中的静态方法
write(OutputStream, ServiceInformation) - 类 org.omg.CORBA.ServiceInformationHelper 中的静态方法
write(OutputStream, SetOverrideType) - 类 org.omg.CORBA.SetOverrideTypeHelper 中的静态方法
write(OutputStream, short[]) - 类 org.omg.CORBA.ShortSeqHelper 中的静态方法
write(OutputStream, String[]) - 类 org.omg.CORBA.StringSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.StringValueHelper 中的静态方法
write(OutputStream, StructMember) - 类 org.omg.CORBA.StructMemberHelper 中的静态方法
write(OutputStream, long[]) - 类 org.omg.CORBA.ULongLongSeqHelper 中的静态方法
write(OutputStream, int[]) - 类 org.omg.CORBA.ULongSeqHelper 中的静态方法
write(OutputStream, UnionMember) - 类 org.omg.CORBA.UnionMemberHelper 中的静态方法
write(OutputStream, UnknownUserException) - 类 org.omg.CORBA.UnknownUserExceptionHelper 中的静态方法
write(OutputStream, short[]) - 类 org.omg.CORBA.UShortSeqHelper 中的静态方法
write(OutputStream, Serializable) - 类 org.omg.CORBA.ValueBaseHelper 中的静态方法
write(OutputStream, ValueMember) - 类 org.omg.CORBA.ValueMemberHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.VersionSpecHelper 中的静态方法
write(OutputStream, short) - 类 org.omg.CORBA.VisibilityHelper 中的静态方法
write(OutputStream, char[]) - 类 org.omg.CORBA.WCharSeqHelper 中的静态方法
write(OutputStream, WrongTransaction) - 类 org.omg.CORBA.WrongTransactionHelper 中的静态方法
write(OutputStream, String[]) - 类 org.omg.CORBA.WStringSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CORBA.WStringValueHelper 中的静态方法
write(OutputStream, Binding) - 类 org.omg.CosNaming.BindingHelper 中的静态方法
write(OutputStream, BindingIterator) - 类 org.omg.CosNaming.BindingIteratorHelper 中的静态方法
write(OutputStream, Binding[]) - 类 org.omg.CosNaming.BindingListHelper 中的静态方法
write(OutputStream, BindingType) - 类 org.omg.CosNaming.BindingTypeHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CosNaming.IstringHelper 中的静态方法
write(OutputStream, NameComponent) - 类 org.omg.CosNaming.NameComponentHelper 中的静态方法
write(OutputStream, NameComponent[]) - 类 org.omg.CosNaming.NameHelper 中的静态方法
write(OutputStream, NamingContextExt) - 类 org.omg.CosNaming.NamingContextExtHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CosNaming.NamingContextExtPackage.AddressHelper 中的静态方法
write(OutputStream, InvalidAddress) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CosNaming.NamingContextExtPackage.StringNameHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.CosNaming.NamingContextExtPackage.URLStringHelper 中的静态方法
write(OutputStream, NamingContext) - 类 org.omg.CosNaming.NamingContextHelper 中的静态方法
write(OutputStream, AlreadyBound) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper 中的静态方法
write(OutputStream, CannotProceed) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHelper 中的静态方法
write(OutputStream, InvalidName) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHelper 中的静态方法
write(OutputStream, NotEmpty) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHelper 中的静态方法
write(OutputStream, NotFound) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHelper 中的静态方法
write(OutputStream, NotFoundReason) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper 中的静态方法
write(OutputStream, Any[]) - 类 org.omg.DynamicAny.AnySeqHelper 中的静态方法
write(OutputStream, DynAnyFactory) - 类 org.omg.DynamicAny.DynAnyFactoryHelper 中的静态方法
write(OutputStream, InconsistentTypeCode) - 类 org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper 中的静态方法
write(OutputStream, DynAny) - 类 org.omg.DynamicAny.DynAnyHelper 中的静态方法
write(OutputStream, InvalidValue) - 类 org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper 中的静态方法
write(OutputStream, TypeMismatch) - 类 org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper 中的静态方法
write(OutputStream, DynAny[]) - 类 org.omg.DynamicAny.DynAnySeqHelper 中的静态方法
write(OutputStream, DynArray) - 类 org.omg.DynamicAny.DynArrayHelper 中的静态方法
write(OutputStream, DynEnum) - 类 org.omg.DynamicAny.DynEnumHelper 中的静态方法
write(OutputStream, DynFixed) - 类 org.omg.DynamicAny.DynFixedHelper 中的静态方法
write(OutputStream, DynSequence) - 类 org.omg.DynamicAny.DynSequenceHelper 中的静态方法
write(OutputStream, DynStruct) - 类 org.omg.DynamicAny.DynStructHelper 中的静态方法
write(OutputStream, DynUnion) - 类 org.omg.DynamicAny.DynUnionHelper 中的静态方法
write(OutputStream, DynValue) - 类 org.omg.DynamicAny.DynValueHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.DynamicAny.FieldNameHelper 中的静态方法
write(OutputStream, NameDynAnyPair) - 类 org.omg.DynamicAny.NameDynAnyPairHelper 中的静态方法
write(OutputStream, NameDynAnyPair[]) - 类 org.omg.DynamicAny.NameDynAnyPairSeqHelper 中的静态方法
write(OutputStream, NameValuePair) - 类 org.omg.DynamicAny.NameValuePairHelper 中的静态方法
write(OutputStream, NameValuePair[]) - 类 org.omg.DynamicAny.NameValuePairSeqHelper 中的静态方法
write(OutputStream, CodecFactory) - 类 org.omg.IOP.CodecFactoryHelper 中的静态方法
write(OutputStream, UnknownEncoding) - 类 org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper 中的静态方法
write(OutputStream, FormatMismatch) - 类 org.omg.IOP.CodecPackage.FormatMismatchHelper 中的静态方法
write(OutputStream, InvalidTypeForEncoding) - 类 org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper 中的静态方法
write(OutputStream, TypeMismatch) - 类 org.omg.IOP.CodecPackage.TypeMismatchHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.IOP.ComponentIdHelper 中的静态方法
write(OutputStream, IOR) - 类 org.omg.IOP.IORHelper 中的静态方法
write(OutputStream, TaggedComponent[]) - 类 org.omg.IOP.MultipleComponentProfileHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.IOP.ProfileIdHelper 中的静态方法
write(OutputStream, ServiceContext) - 类 org.omg.IOP.ServiceContextHelper 中的静态方法
write(OutputStream, ServiceContext[]) - 类 org.omg.IOP.ServiceContextListHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.IOP.ServiceIdHelper 中的静态方法
write(OutputStream, TaggedComponent) - 类 org.omg.IOP.TaggedComponentHelper 中的静态方法
write(OutputStream, TaggedProfile) - 类 org.omg.IOP.TaggedProfileHelper 中的静态方法
write(OutputStream, short) - 类 org.omg.Messaging.SyncScopeHelper 中的静态方法
write(OutputStream, int) - 类 org.omg.PortableInterceptor.AdapterManagerIdHelper 中的静态方法
write(OutputStream, String[]) - 类 org.omg.PortableInterceptor.AdapterNameHelper 中的静态方法
write(OutputStream, short) - 类 org.omg.PortableInterceptor.AdapterStateHelper 中的静态方法
write(OutputStream, Current) - 类 org.omg.PortableInterceptor.CurrentHelper 中的静态方法
write(OutputStream, ForwardRequest) - 类 org.omg.PortableInterceptor.ForwardRequestHelper 中的静态方法
write(OutputStream, InvalidSlot) - 类 org.omg.PortableInterceptor.InvalidSlotHelper 中的静态方法
write(OutputStream, IORInterceptor_3_0) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Helper 中的静态方法
write(OutputStream, byte[]) - 类 org.omg.PortableInterceptor.ObjectIdHelper 中的静态方法
write(OutputStream, ObjectReferenceFactory) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHelper 中的静态方法
write(OutputStream, ObjectReferenceTemplate) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHelper 中的静态方法
write(OutputStream, ObjectReferenceTemplate[]) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.PortableInterceptor.ORBIdHelper 中的静态方法
write(OutputStream, DuplicateName) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper 中的静态方法
write(OutputStream, InvalidName) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper 中的静态方法
write(OutputStream, String) - 类 org.omg.PortableInterceptor.ServerIdHelper 中的静态方法
write(OutputStream, Current) - 类 org.omg.PortableServer.CurrentHelper 中的静态方法
write(OutputStream, NoContext) - 类 org.omg.PortableServer.CurrentPackage.NoContextHelper 中的静态方法
write(OutputStream, ForwardRequest) - 类 org.omg.PortableServer.ForwardRequestHelper 中的静态方法
write(OutputStream, POA) - 类 org.omg.PortableServer.POAHelper 中的静态方法
write(OutputStream, AdapterInactive) - 类 org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper 中的静态方法
write(OutputStream, AdapterAlreadyExists) - 类 org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper 中的静态方法
write(OutputStream, AdapterNonExistent) - 类 org.omg.PortableServer.POAPackage.AdapterNonExistentHelper 中的静态方法
write(OutputStream, InvalidPolicy) - 类 org.omg.PortableServer.POAPackage.InvalidPolicyHelper 中的静态方法
write(OutputStream, NoServant) - 类 org.omg.PortableServer.POAPackage.NoServantHelper 中的静态方法
write(OutputStream, ObjectAlreadyActive) - 类 org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper 中的静态方法
write(OutputStream, ObjectNotActive) - 类 org.omg.PortableServer.POAPackage.ObjectNotActiveHelper 中的静态方法
write(OutputStream, ServantAlreadyActive) - 类 org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper 中的静态方法
write(OutputStream, ServantNotActive) - 类 org.omg.PortableServer.POAPackage.ServantNotActiveHelper 中的静态方法
write(OutputStream, WrongAdapter) - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 中的静态方法
write(OutputStream, WrongPolicy) - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 中的静态方法
write(OutputStream, ServantActivator) - 类 org.omg.PortableServer.ServantActivatorHelper 中的静态方法
write(OutputStream, ServantLocator) - 类 org.omg.PortableServer.ServantLocatorHelper 中的静态方法
write(Node, LSOutput) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
write_Abstract(Object) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL Abstract 接口类型写入输出流。
write_abstract_interface(Object) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
编组值对象或 stub 对象。
write_any(Any) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 Any 值写入输出流。
write_any(Any) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 Any。
write_any_array(Any[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL Any 数组中从 offset 处开始的 length 个元素写入输出流。
write_boolean(boolean) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 boolean 值写入输出流。
write_boolean(boolean) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 boolean 值写入此流。
write_boolean_array(boolean[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL boolean 数组中从 offset 处开始的 length 个元素写入输出流。
write_boolean_array(boolean[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 boolean 数组。
write_char(char) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 字符值写入输出流。
write_char(char) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 char 值写入此流。
write_char_array(char[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 字符数组中从 offset 处开始的 length 个元素写入输出流。
write_char_array(char[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 char 数组。
write_Context(Context, ContextList) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此流上写入一个 CORBA 上下文。
write_double(double) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL double 值写入输出流。
write_double(double) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 double 值写入此流。
write_double_array(double[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL double 数组中从 offset 处开始的 length 个元素写入输出流。
write_double_array(double[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输入流上写入一个 double 数组。
WRITE_FAILURE - 类 java.util.logging.ErrorManager 中的静态变量
WRITE_FAILURE 用于对输出流的写入失败时。
write_fixed(BigDecimal) - 类 org.omg.CORBA.portable.OutputStream 中的方法
写入一个 BigDecimal 数。
write_float(float) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL float 值写入输出流。
write_float(float) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 float 值写入此流。
write_float_array(float[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL float 数组中从 offset 处开始的 length 个元素写入输出流。
write_float_array(float[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输入流上写入一个 float 数组。
write_long(int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL long 值（以 Java int 的形式表示）写入输出流。
write_long(int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 CORBA long（即 Java int）值写入此流。
write_long_array(int[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL long 数组中从 offset 处开始的 length 个元素写入输出流。
write_long_array(int[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 CORBA long（即 Java int）数组。
write_longlong(long) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL long long 值（以 Java long 的形式表示）写入输出流。
write_longlong(long) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 CORBA longlong（即 Java long）值写入此流。
write_longlong_array(long[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL long long 数组中从 offset 处开始的 length 个元素写入输出流。
write_longlong_array(long[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 CORBA longlong（即 Java int）数组。
write_Object(Object) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL CORBA::Object 值写入输出流。
write_Object(Object) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输入流上写入一个 CORBA Object。
write_octet(byte) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL octet 值（以一个 Java 字节的形式表示）写入输出流。
write_octet(byte) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 CORBA 八位组（即字节）写入此流。
write_octet_array(byte[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL octet 数组中从 offset 处开始的 length 个元素写入输出流。
write_octet_array(byte[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 CORBA 八位组 (byte) 数组。
write_Principal(Principal) - 类 org.omg.CORBA.portable.OutputStream 中的方法
已过时。 已由 CORBA 2.2 取代。
write_short(short) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL short 值写入输出流。
write_short(short) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 short 值写入此流。
write_short_array(short[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL short 数组中从 offset 处开始的 length 个元素写入输出流。
write_short_array(short[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 short 数组。
write_string(String) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL string 值写入输出流。
write_string(String) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 string 值写入此流。
write_TypeCode(TypeCode) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 typecode 写入输出流。
write_TypeCode(TypeCode) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 TypeCode。
write_ulong(int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL long 值（以 Java int 的形式表示）写入输出流。
write_ulong(int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个无符号 CORBA long（即 Java int）值写入此流。
write_ulong_array(int[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL long 数组中从 offset 处开始的 length 个元素（以 Java int 的形式表示）写入输出流。
write_ulong_array(int[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个无符号 CORBA long（即 Java int）数组。
write_ulonglong(long) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL long long 值（以 Java long 的形式表示）写入输出流。
write_ulonglong(long) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个无符号 CORBA longlong（即 Java long）值写入此流。
write_ulonglong_array(long[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL long long 数组中从 offset 处开始的 length 个元素（以 Java long 的形式表示）写入输出流。
write_ulonglong_array(long[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个无符号 CORBA longlong（即 Java int）数组。
write_ushort(short) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL short 值（以 Java short 值的形式表示）写入输出流。
write_ushort(short) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个无符号 short 值写入此流。
write_ushort_array(short[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将无符号 IDL short 数组中从 offset 处开始的 length 个元素（以 Java short 的形式表示）写入输出流。
write_ushort_array(short[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个无符号 short 数组。
write_value(OutputStream) - 类 org.omg.CORBA.Any 中的方法
将此 Any 对象的值写出到给定输出流。
write_Value(Serializable) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL value 类型值写入输出流。
write_value(OutputStream, Serializable) - 接口 org.omg.CORBA.portable.BoxedValueHelper 中的方法
write_value(OutputStream, Serializable) - 类 org.omg.CORBA.StringValueHelper 中的方法
write_value(OutputStream, Serializable) - 类 org.omg.CORBA.WStringValueHelper 中的方法
write_value(Serializable) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
将值类型编组到输出流中。
write_value(Serializable, Class) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
将值类型编组到输出流中。
write_value(Serializable, String) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
将值类型编组到输出流中。
write_value(Serializable, BoxedValueHelper) - 类 org.omg.CORBA_2_3.portable.OutputStream 中的方法
将值类型编组到输出流中。
write_wchar(char) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 宽字符值写入输出流。
write_wchar(char) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 wide char 值写入此流。
write_wchar_array(char[], int, int) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 宽字符数组中从 offset 处开始的 length 个元素写入输出流。
write_wchar_array(char[], int, int) - 类 org.omg.CORBA.portable.OutputStream 中的方法
在此输出流上写入一个 wide char 数组。
write_wstring(String) - 接口 org.omg.CORBA.DataOutputStream 中的方法
将 IDL 宽字符串值（以 Java String 的形式表示）写入输出流。
write_wstring(String) - 类 org.omg.CORBA.portable.OutputStream 中的方法
将一个 wide string 值写入此流。
WRITE_XML_DECLARATION - 类 javax.xml.soap.SOAPMessage 中的静态变量
指定 SOAP Message 在发送时是否包含 XML 声明。
writeAborted(ImageWriter) - 接口 javax.imageio.event.IIOWriteProgressListener 中的方法
报告已通过 writer 的 abort 方法中止写操作。
WriteAbortedException - java.io 中的 异常
在写入操作过程中抛出 ObjectStreamException 之一的信号。
WriteAbortedException(String, Exception) - 异常 java.io.WriteAbortedException 的构造方法
使用描述该异常的字符串和导致中止的异常构造一个 WriteAbortedException。
writeAbstractObject(OutputStream, Object) - 类 javax.rmi.CORBA.Util 中的静态方法
将 java.lang.Object 作为一个值或 CORBA Object 写入。
writeAbstractObject(OutputStream, Object) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
writeAny(OutputStream, Object) - 类 javax.rmi.CORBA.Util 中的静态方法
将 any java.lang.Object 作为 CORBA any 写入。
writeAny(OutputStream, Object) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
writeArray(Array) - 接口 java.sql.SQLOutput 中的方法
将 SQL ARRAY 值写入流中。
writeArray(Array) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Array 对象写入此 SQLOutputImpl 对象。
writeAsciiStream(InputStream) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 ASCII 字符流写入流中。
writeAsciiStream(InputStream) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 ASCII 字符流写入此 SQLOutputImpl 对象。
writeAsEncodedUnicode(Writer) - 接口 javax.xml.stream.events.XMLEvent 中的方法
此方法根据 XML 1.0 规范将 XMLEvent 编写为 Unicode 字符。
writeAttribute(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出流写入一个不带前缀的属性。
writeAttribute(String, String, String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出流写入一个属性
writeAttribute(String, String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出流写入一个属性
writeAttributes(AttributeSet) - 类 javax.swing.text.AbstractWriter 中的方法
以 " =" 对的形式写出属性集。
writeAttributes(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出属性集。
writeAttributes(AttributeSet) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出以下类型的所有属性：StyleConstants.ParagraphConstants、StyleConstants.CharacterConstants、StyleConstants.FontConstants、StyleConstants.ColorConstants。
writeAttributes(ObjectOutputStream, AttributeSet) - 类 javax.swing.text.StyleContext 中的方法
写出属性的特定于上下文的处理。
writeAttributeSet(ObjectOutputStream, AttributeSet) - 类 javax.swing.text.StyleContext 中的静态方法
将属性集写入到给定的对象流以便序列化。
writeBigDecimal(BigDecimal) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 java.math.BigDecimal 对象写入流中。
writeBigDecimal(BigDecimal) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.math.BigDecimal 对象写入此 SQLOutputImpl 对象。
writeBinaryStream(InputStream) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为未解释字节流写入流中。
writeBinaryStream(InputStream) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将未解释字节流写入此 SQLOutputImpl 对象。
writeBit(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将单个位（由参数的最低有效位给定）写入到流的当前字节位置中的当前位偏移量。
writeBit(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeBits(long, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个位序列（由 bits 参数的 numBits 个最低有效位按从左到右的顺序给定）写入到流的当前字节位置中的当前位偏移量。
writeBits(long, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeBlob(Blob) - 接口 java.sql.SQLOutput 中的方法
将 SQL BLOB 值写入流中。
writeBlob(Blob) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Blob 对象写入此 SQLOutputImpl 对象。
writeBody() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
对文档中的元素进行迭代，并基于元素是分支元素还是叶元素来处理它们。
writeBoolean(boolean) - 接口 java.io.DataOutput 中的方法
将一个 boolean 值写入输出流。
writeBoolean(boolean) - 类 java.io.DataOutputStream 中的方法
将一个 boolean 值以 1-byte 值形式写入基础输出流。
writeBoolean(boolean) - 类 java.io.ObjectOutputStream 中的方法
写入一个 boolean 值。
writeBoolean(boolean) - 类 java.io.RandomAccessFile 中的方法
按单字节值将 boolean 写入该文件。
writeBoolean(boolean) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java boolean 值写入流。
writeBoolean(boolean) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个 boolean 值写入到流中。
writeBoolean(boolean) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeBoolean(boolean) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 boolean 写入此 SQLOutputImpl 对象。
writeByte(int) - 接口 java.io.DataOutput 中的方法
将参数 v 的八个低位写入输出流。
writeByte(int) - 类 java.io.DataOutputStream 中的方法
将一个 byte 值以 1-byte 值形式写出到基础输出流中。
writeByte(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个 8 位字节。
writeByte(int) - 类 java.io.RandomAccessFile 中的方法
按单字节值将 byte 写入该文件。
writeByte(byte) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java byte 值写入流中。
writeByte(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 v 的 8 个低位写入到流中。
writeByte(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeByte(byte) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 byte 写入此 SQLOutputImpl 对象。
writeBytes(String) - 接口 java.io.DataOutput 中的方法
将一个字符串写入输出流。
writeBytes(String) - 类 java.io.DataOutputStream 中的方法
将字符串按字节顺序写出到基础输出流中。
writeBytes(String) - 类 java.io.ObjectOutputStream 中的方法
以字节序列形式写入一个 String。
writeBytes(String) - 类 java.io.RandomAccessFile 中的方法
按字节序列将该字符串写入该文件。
writeBytes(byte[]) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为字节数组写入流中。
writeBytes(String) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个字符串写入输出流。
writeBytes(String) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeBytes(byte[]) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 byte 数组写入此 SQLOutputImpl 对象。
writeCData(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 CData 节
writeChar(int) - 接口 java.io.DataOutput 中的方法
将一个 char 值写入输出流，该值由两个字节组成。
writeChar(int) - 类 java.io.DataOutputStream 中的方法
将一个 char 值以 2-byte 值形式写入基础输出流中，先写入高字节。
writeChar(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个 16 位的 char 值。
writeChar(int) - 类 java.io.RandomAccessFile 中的方法
按双字节值将 char 写入该文件，先写高字节。
writeChar(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
此方法与 writeShort 同义。
writeChar(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeCharacters(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入文本
writeCharacters(char[], int, int) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入文本
writeCharacterStream(Reader) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Unicode 字符的流写入流中。
writeCharacterStream(Reader) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Unicode 字符流写入此 SQLOutputImpl 对象。
writeChars(String) - 接口 java.io.DataOutput 中的方法
将字符串 s 中的所有字符按顺序写入输出流，每个字符用两个字节表示。
writeChars(String) - 类 java.io.DataOutputStream 中的方法
将字符串按字符顺序写入基础输出流。
writeChars(String) - 类 java.io.ObjectOutputStream 中的方法
以 char 序列形式写入一个 String。
writeChars(String) - 类 java.io.RandomAccessFile 中的方法
按字符序列将一个字符串写入该文件。
writeChars(String) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个字符串写入输出流。
writeChars(char[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 char 序列写入到流中的当前位置。
writeChars(String) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeChars(char[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeChildren(ObjectOutputStream) - 类 java.beans.beancontext.BeanContextSupport 中的方法
用于序列化此 BeanContext 的所有子级。
writeClassDescriptor(ObjectStreamClass) - 类 java.io.ObjectOutputStream 中的方法
将指定的类描述符写入 ObjectOutputStream。
writeClob(Clob) - 接口 java.sql.SQLOutput 中的方法
将 SQL CLOB 值写入流中。
writeClob(Clob) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Clob 对象写入此 SQLOutputImpl 对象。
writeComment(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写一个包含数据的 XML 注释
writeComponent(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
负责处理 Component Elements；有意不实现它。
writeContent(Element, boolean) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
以与 HTML 兼容的方式写出属性集。
writeData(RowSetInternal) - 接口 javax.sql.RowSetWriter 中的方法
将此 RowSetWriter 对象的 rowset 中的更改写回它从中获取数据的数据源。
writeDate(Date) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 java.sql.Date 对象写入流中。
writeDate(Date) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.sql.Date 对象写入此 SQLOutputImpl 对象。
writeDefaultNamespace(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向流写入默认名称空间
writeDouble(double) - 接口 java.io.DataOutput 中的方法
将一个 double 值写入输出流，该值由八个字节组成。
writeDouble(double) - 类 java.io.DataOutputStream 中的方法
使用 Double 类中的 doubleToLongBits 方法将 double 参数转换为一个 long 值，然后将该 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
writeDouble(double) - 类 java.io.ObjectOutputStream 中的方法
写入一个 64 位的 double 值。
writeDouble(double) - 类 java.io.RandomAccessFile 中的方法
使用 Double 类中的 doubleToLongBits 方法将双精度参数转换为一个 long，然后按八字节数量将该 long 值写入该文件，先定高字节。
writeDouble(double) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java double 值写入流中。
writeDouble(double) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个 double 值写入输出流，该值由四个字节组成。
writeDouble(double) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeDouble(double) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 double 写入此 SQLOutputImpl 对象。
writeDoubles(double[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 double 序列写入到流中的当前位置。
writeDoubles(double[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeDTD(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 DTD 节。
writeEmbeddedTags(AttributeSet) - 类 javax.swing.text.html.HTMLWriter 中的方法
搜索 AttributeSet 中的嵌入式标记并写出它们。
writeEmptyElement(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个空元素标记
writeEmptyElement(String, String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个空元素标记
writeEmptyElement(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个空元素标记
writeEndDocument() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
关闭所有开始标记并写入相应的结束标记。
writeEndElement() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向依赖于 writer 内部状态的输出写入一个结束标记，以此确定事件的前缀和本地名称。
writeEndParagraph() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
发出 <p> 标记的结束标记。
writeEndTag(String) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出适当缩进的结束标记。
writeEntityRef(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写一个实体引用
writeExpression(Expression) - 类 java.beans.Encoder 中的方法
该实现首先查看使用此值的表达式是否已经被写入。
writeExpression(Expression) - 类 java.beans.XMLEncoder 中的方法
记录 Expression，以便 Encoder 在刷新流的缓存时产生实际输出。
writeExternal(ObjectOutput) - 类 java.awt.datatransfer.DataFlavor 中的方法
序列化此 DataFlavor。
writeExternal(ObjectOutput) - 接口 java.io.Externalizable 中的方法
该对象可实现 writeExternal 方法来保存其内容，它可以通过调用 DataOutput 的方法来保存其基本值，或调用 ObjectOutput 的 writeObject 方法来保存对象、字符串和数组。
writeExternal(ObjectOutput) - 类 javax.activation.MimeType 中的方法
对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。
writeExternal(ObjectOutput) - 类 javax.management.loading.MLet 中的方法
将此 MLet 的内容保存到给定的 ObjectOutput。
writeFields() - 类 java.io.ObjectOutputStream 中的方法
将已缓冲的字段写入流中。
writeFloat(float) - 接口 java.io.DataOutput 中的方法
将一个 float 值写入输出流，该值由四个字节组成。
writeFloat(float) - 类 java.io.DataOutputStream 中的方法
使用 Float 类中的 floatToIntBits 方法将 float 参数转换为一个 int 值，然后将该 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
writeFloat(float) - 类 java.io.ObjectOutputStream 中的方法
写入一个 32 位的 float 值。
writeFloat(float) - 类 java.io.RandomAccessFile 中的方法
使用 Float 类中的 floatToIntBits 方法将浮点参数转换为一个 int，然后按四字节数量将该 int 值写入该文件，先写高字节。
writeFloat(float) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java float 值写入流中。
writeFloat(float) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将一个 float 值（由四个字节组成）写入输出流。
writeFloat(float) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeFloat(float) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 float 写入此 SQLOutputImpl 对象。
writeFloats(float[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 float 序列写入到流中的当前位置。
writeFloats(float[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeHeader() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出 <head> 和 <style> 标记，然后调用 writeStyles()，以写出所有命名的样式，这些样式作为 <style> 标记的内容。
writeHTMLTags(AttributeSet) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
基于文本的属性设置生成文本的 bold <b>、italic <i> 和 <u> 标记。
writeImage(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
负责处理 Icon Elements；有意不实现它。
writeInsert(int, IIOImage, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
将新的图像插入现有图像流。
writeInt(int) - 接口 java.io.DataOutput 中的方法
将一个 int 值写入输出流，该值由四个字节组成。
writeInt(int) - 类 java.io.DataOutputStream 中的方法
将一个 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
writeInt(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个 32 位的 int 值。
writeInt(int) - 类 java.io.RandomAccessFile 中的方法
按四个字节将 int 写入该文件，先写高字节。
writeInt(int) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java int 值写入流中。
writeInt(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 v 的 32 个位写入到流中。
writeInt(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeInt(int) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 int 写入此 SQLOutputImpl 对象。
writeInts(int[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 int 序列写入到流中的当前位置。
writeInts(int[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeLeaf(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
负责写出其他非文本叶元素。
writeLineSeparator() - 类 javax.swing.text.AbstractWriter 中的方法
写入行分隔符。
writeLineSeparator() - 类 javax.swing.text.html.HTMLWriter 中的方法
写出行分隔符。
writeLock() - 接口 java.util.concurrent.locks.ReadWriteLock 中的方法
返回用于写入操作的锁。
writeLock() - 类 java.util.concurrent.locks.ReentrantReadWriteLock 中的方法
writeLock() - 类 javax.swing.text.AbstractDocument 中的方法
获取一个锁定，以开始改变此锁定保护的文档。
writeLong(long) - 接口 java.io.DataOutput 中的方法
将一个 long 值写入输出流，该值由八个字节组成。
writeLong(long) - 类 java.io.DataOutputStream 中的方法
将一个 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
writeLong(long) - 类 java.io.ObjectOutputStream 中的方法
写入一个 64 位的 long 值。
writeLong(long) - 类 java.io.RandomAccessFile 中的方法
按八个字节将 long 写入该文件，先写高字节。
writeLong(long) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java long 值写入流中。
writeLong(long) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 v 的 64 个位写入到流中。
writeLong(long) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeLong(long) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 long 写入此 SQLOutputImpl 对象。
writeLongs(long[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 long 序列写入到流中的当前位置。
writeLongs(long[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeNamespace(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出流写入一个名称空间。
writeNClob(NClob) - 接口 java.sql.SQLOutput 中的方法
将 SQL NCLOB 值写入流中。
writeNClob(NClob) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 SQL NCLOB 值写入流中。
writeNonHTMLAttributes(AttributeSet) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
以与 HTML 兼容的方式写出其余的字符级属性（bold、italic 和 underline 之外的属性）。
writeNString(String) - 接口 java.sql.SQLOutput 中的方法
将下一个属性以 Java 编程语言中 String 的形式写入流中。
writeNString(String) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将下一个属性以 Java 编程语言中 String 的形式写入流中。
writeObject(Object) - 类 java.beans.Encoder 中的方法
将指定对象写入输出流中。
writeObject(Object, Encoder) - 类 java.beans.PersistenceDelegate 中的方法
writeObject 是持久性的一个入口点，由传统委托模式中的 Encoder 使用。
writeObject(Object) - 类 java.beans.XMLEncoder 中的方法
将指定对象的 XML 表示形式写入输出中。
writeObject(Object) - 接口 java.io.ObjectOutput 中的方法
将对象写入底层存储或流。
writeObject(Object) - 类 java.io.ObjectOutputStream 中的方法
将指定的对象写入 ObjectOutputStream。
writeObject(SQLData) - 接口 java.sql.SQLOutput 中的方法
将给定 SQLData 对象中包含的数据写入流中。
writeObject(Stub, ObjectOutputStream) - 接口 javax.rmi.CORBA.StubDelegate 中的方法
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。
writeObject(SQLData) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将包含在给定 SQLData 对象中的数据写入流中。
writeObjectOverride(Object) - 类 java.io.ObjectOutputStream 中的方法
子类用于重写默认 writeObject 方法的方法。
writeOption(Option) - 类 javax.swing.text.html.HTMLWriter 中的方法
写出 Option 表单元素的内容。
writeProcessingInstruction(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写一条处理指令
writeProcessingInstruction(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写一条处理指令
writer() - 类 java.io.Console 中的方法
获取与此控制台关联的唯一 PrintWriter 对象。
Writer - java.io 中的 类
写入字符流的抽象类。
Writer() - 类 java.io.Writer 的构造方法
创建一个新的字符流 writer，其关键部分将同步 writer 自身。
Writer(Object) - 类 java.io.Writer 的构造方法
创建一个新的字符流 writer，其关键部分将同步给定的对象。
writer - 类 javax.script.SimpleScriptContext 中的变量
此字段是用于脚本输出的 writer。
writeRef(Ref) - 接口 java.sql.SQLOutput 中的方法
将 SQL REF 值写入流中。
writeRef(Ref) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Ref 对象写入此 SQLOutputImpl 对象。
writeRemoteObject(OutputStream, Object) - 类 javax.rmi.CORBA.Util 中的静态方法
将 java.lang.Object 作为 CORBA Object 写入。
writeRemoteObject(OutputStream, Object) - 接口 javax.rmi.CORBA.UtilDelegate 中的方法
Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
writeReplace() - 类 java.security.cert.Certificate 中的方法
替换要被序列化的 Certificate。
writeReplace() - 类 java.security.cert.CertPath 中的方法
使用 CertPathRep 对象替换要被序列化的 CertPath。
writeReplace(Serializable) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
如果该值包含 writeReplace 方法，则返回该结果。
writeRowId(RowId) - 接口 java.sql.SQLOutput 中的方法
将 SQL ROWID 值写入流中。
writeRowId(RowId) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 SQL ROWID 值写入流中。
writerSpiNames - 类 javax.imageio.spi.ImageReaderSpi 中的变量
将从 getImageWriterSpiNames 返回的字符串数组，该数组最初为 null。
writeShort(int) - 接口 java.io.DataOutput 中的方法
将两个字节写入输出流，用它们表示参数值。
writeShort(int) - 类 java.io.DataOutputStream 中的方法
将一个 short 值以 2-byte 值形式写入基础输出流中，先写入高字节。
writeShort(int) - 类 java.io.ObjectOutputStream 中的方法
写入一个 16 位的 short 值。
writeShort(int) - 类 java.io.RandomAccessFile 中的方法
按两个字节将 short 写入该文件，先写高字节。
writeShort(short) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java short 值写入流中。
writeShort(int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 v 的 16 个低位写入到流中。
writeShort(int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeShort(short) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 short 写入此 SQLOutputImpl 对象。
writeShorts(short[], int, int) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将 short 序列写入到流中的当前位置。
writeShorts(short[], int, int) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeSQL(SQLOutput) - 接口 java.sql.SQLData 中的方法
将此对象写入给定的 SQL 数据流，同时将其转换回数据源中它的 SQL 值。
writeSQLXML(SQLXML) - 接口 java.sql.SQLOutput 中的方法
将 SQL XML 值写入流中。
writeSQLXML(SQLXML) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 SQL XML 值写入流中。
writeStartDocument() - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 XML 声明。
writeStartDocument(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 XML 声明。
writeStartDocument(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
编写 XML 声明。
writeStartElement(String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个开始标记。
writeStartElement(String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个开始标记
writeStartElement(String, String, String) - 接口 javax.xml.stream.XMLStreamWriter 中的方法
向输出写入一个开始标记
writeStartParagraph(Element) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
发出段落的开始标记。
writeStartTag(String) - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出适当缩进的开始标记。
writeStatement(Statement) - 类 java.beans.Encoder 中的方法
将语句 oldStm 写入流中。
writeStatement(Statement) - 类 java.beans.XMLEncoder 中的方法
记录 Statement，以便 Encoder 在刷新流的缓存时产生实际输出。
writeStreamHeader() - 类 java.io.ObjectOutputStream 中的方法
提供 writeStreamHeader 方法，这样子类可以将其自身的头部添加或预加到流中。
writeString(String) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 Java 编程语言中的 String 写入流中。
writeString(String) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 String 写入此 SQLOutputImpl 对象。
writeStruct(Struct) - 接口 java.sql.SQLOutput 中的方法
将 SQL 结构类型值写入流中。
writeStruct(Struct) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 Struct 对象写入此 SQLOutputImpl 对象。
writeStyles() - 类 javax.swing.text.html.MinimalHTMLWriter 中的方法
写出所有命名的样式，这些样式作为 <style> 标记的内容。
writeTime(Time) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 java.sql.Time 对象写入流中。
writeTime(Time) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.sql.Time 对象写入此 SQLOutputImpl 对象。
writeTimestamp(Timestamp) - 接口 java.sql.SQLOutput 中的方法
将下一个属性作为 java.sql.Timestamp 对象写入流中。
writeTimestamp(Timestamp) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.sql.Timestamp 对象写入此 SQLOutputImpl 对象。
writeTo(OutputStream) - 类 java.io.ByteArrayOutputStream 中的方法
将此 byte 数组输出流的全部内容写入到指定的输出流参数中，这与使用 out.write(buf, 0, count) 调用该输出流的 write 方法效果一样。
writeTo(Writer) - 类 java.io.CharArrayWriter 中的方法
将缓冲区的内容写入另一个字符流。
writeTo(Object, String, OutputStream) - 接口 javax.activation.DataContentHandler 中的方法
将对象转换为指定 MIME 类型的字节流，并将其写入输出流。
writeTo(OutputStream) - 类 javax.activation.DataHandler 中的方法
将数据写入 OutputStream。
writeTo(OutputStream) - 类 javax.xml.soap.SOAPMessage 中的方法
将此 SOAPMessage 对象写入给定输出流。
writeToSequence(IIOImage, ImageWriteParam) - 类 javax.imageio.ImageWriter 中的方法
将单幅图像、可能相关的元数据和缩略图添加到输出中。
writeToString(Node) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。
writeToURI(Node, String) - 接口 org.w3c.dom.ls.LSSerializer 中的方法
这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。
writeUnlock() - 类 javax.swing.text.AbstractDocument 中的方法
释放以前通过 writeLock 所获得的写入锁定。
writeUnshared(Object) - 类 java.io.ObjectOutputStream 中的方法
将“未共享”对象写入 ObjectOutputStream。
writeURL(URL) - 接口 java.sql.SQLOutput 中的方法
将 SQL DATALINK 值写入流中。
writeURL(URL) - 类 javax.sql.rowset.serial.SQLOutputImpl 中的方法
将 Java 编程语言中的 java.sql.Type.DATALINK 对象写入此 SQLOutputImpl 对象。
writeUTF(String) - 接口 java.io.DataOutput 中的方法
将表示长度信息的两个字节写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。
writeUTF(String) - 类 java.io.DataOutputStream 中的方法
以与机器无关方式使用 UTF-8 修改版编码将一个字符串写入基础输出流。
writeUTF(String) - 类 java.io.ObjectOutputStream 中的方法
以 UTF-8 修改版格式写入此 String 的基本数据。
writeUTF(String) - 类 java.io.RandomAccessFile 中的方法
使用 modified UTF-8 编码以与机器无关的方式将一个字符串写入该文件。
writeUTF(String) - 接口 javax.imageio.stream.ImageOutputStream 中的方法
将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。
writeUTF(String) - 类 javax.imageio.stream.ImageOutputStreamImpl 中的方法
writeValue(OutputStream, Serializable) - 接口 javax.rmi.CORBA.ValueHandler 中的方法
使用 Java 语义将一个值写入流。
writeValue(OutputStream, Serializable, byte) - 接口 javax.rmi.CORBA.ValueHandlerMultiFormat 中的方法
允许 ORB 为 RMI/IDL 自定义值类型传递流格式版本。
writeXML(WebRowSet, Writer) - 接口 javax.sql.rowset.spi.XmlWriter 中的方法
将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。
writeXml(ResultSet, Writer) - 接口 javax.sql.rowset.WebRowSet 中的方法
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。
writeXml(ResultSet, OutputStream) - 接口 javax.sql.rowset.WebRowSet 中的方法
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。
writeXml(Writer) - 接口 javax.sql.rowset.WebRowSet 中的方法
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 Writer 对象。
writeXml(OutputStream) - 接口 javax.sql.rowset.WebRowSet 中的方法
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
written - 类 java.io.DataOutputStream 中的变量
到目前为止写入数据输出流的字节数。
WRONG_DOCUMENT_ERR - 异常 org.w3c.dom.DOMException 中的静态变量
如果 Node 用于不同的文档而不是创建它的文档（该文档不支持它）。
WrongAdapter - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/WrongAdapter.java。
WrongAdapter() - 异常 org.omg.PortableServer.POAPackage.WrongAdapter 的构造方法
WrongAdapter(String) - 异常 org.omg.PortableServer.POAPackage.WrongAdapter 的构造方法
WrongAdapterHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/WrongAdapterHelper.java。
WrongAdapterHelper() - 类 org.omg.PortableServer.POAPackage.WrongAdapterHelper 的构造方法
WrongPolicy - org.omg.PortableServer.POAPackage 中的 异常
org/omg/PortableServer/POAPackage/WrongPolicy.java。
WrongPolicy() - 异常 org.omg.PortableServer.POAPackage.WrongPolicy 的构造方法
WrongPolicy(String) - 异常 org.omg.PortableServer.POAPackage.WrongPolicy 的构造方法
WrongPolicyHelper - org.omg.PortableServer.POAPackage 中的 类
org/omg/PortableServer/POAPackage/WrongPolicyHelper.java。
WrongPolicyHelper() - 类 org.omg.PortableServer.POAPackage.WrongPolicyHelper 的构造方法
WrongTransaction - org.omg.CORBA 中的 异常
CORBA WrongTransaction 用户定义异常。
WrongTransaction() - 异常 org.omg.CORBA.WrongTransaction 的构造方法
使用空详细消息构造一个 WrongTransaction 对象。
WrongTransaction(String) - 异常 org.omg.CORBA.WrongTransaction 的构造方法
使用给定详细消息构造一个 WrongTransaction 对象。
WrongTransactionHelper - org.omg.CORBA 中的 类
WrongTransaction 的 Helper。
WrongTransactionHelper() - 类 org.omg.CORBA.WrongTransactionHelper 的构造方法
WrongTransactionHolder - org.omg.CORBA 中的 类
WrongTransaction 的 Holder。
WrongTransactionHolder() - 类 org.omg.CORBA.WrongTransactionHolder 的构造方法
WrongTransactionHolder(WrongTransaction) - 类 org.omg.CORBA.WrongTransactionHolder 的构造方法
WSDL_DESCRIPTION - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：WSDL 文档的输入源。
WSDL_INTERFACE - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：wsdl 接口 (2.0) 或端口类型 (1.1) 的名称。
WSDL_OPERATION - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：WSDL 操作的名称。
WSDL_PORT - 类 javax.xml.ws.Endpoint 中的静态变量
标准属性：WSDL 端口的名称。
WSDL_PORT - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：WSDL 端口的名称。
WSDL_SERVICE - 类 javax.xml.ws.Endpoint 中的静态变量
标准属性：WSDL 服务的名称。
WSDL_SERVICE - 接口 javax.xml.ws.handler.MessageContext 中的静态变量
标准属性：WSDL 服务的名称。
WStringSeqHelper - org.omg.CORBA 中的 类
WString 数组
WStringSeqHelper() - 类 org.omg.CORBA.WStringSeqHelper 的构造方法
WStringSeqHolder - org.omg.CORBA 中的 类
WString 数组
WStringSeqHolder() - 类 org.omg.CORBA.WStringSeqHolder 的构造方法
WStringSeqHolder(String[]) - 类 org.omg.CORBA.WStringSeqHolder 的构造方法
WStringValueHelper - org.omg.CORBA 中的 类
org/omg/CORBA/WStringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范： 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07) ptc/00-01-08 中定义的 IDL/Java 语言映射
WStringValueHelper() - 类 org.omg.CORBA.WStringValueHelper 的构造方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


X - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

X

x - 类 java.awt.Event 中的变量
事件的 x 坐标。
x - 类 java.awt.geom.Arc2D.Double 中的变量
弧的窗体矩形左上角的 X 坐标。
x - 类 java.awt.geom.Arc2D.Float 中的变量
弧的窗体矩形左上角的 X 坐标。
x - 类 java.awt.geom.Ellipse2D.Double 中的变量
此 Ellipse2D 的窗体矩形左上角的 X 坐标。
x - 类 java.awt.geom.Ellipse2D.Float 中的变量
此 Ellipse2D 窗体矩形左上角的 X 坐标。
x - 类 java.awt.geom.Point2D.Double 中的变量
此 Point2D 的 X 坐标。
x - 类 java.awt.geom.Point2D.Float 中的变量
此 Point2D 的 X 坐标。
x - 类 java.awt.geom.Rectangle2D.Double 中的变量
此 Rectangle2D 的 X 坐标。
x - 类 java.awt.geom.Rectangle2D.Float 中的变量
此 Rectangle2D 的 X 坐标。
x - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
此 RoundRectangle2D 的 X 坐标。
x - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
此 RoundRectangle2D 的 X 坐标。
x - 类 java.awt.Point 中的变量
此 Point 的 X 坐标。
x - 类 java.awt.Rectangle 中的变量
Rectangle 左上角的 X 坐标。
x1 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段起始点的 X 坐标。
x1 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段起始点的 X 坐标。
x1 - 类 java.awt.geom.Line2D.Double 中的变量
线段起始点的 X 坐标。
x1 - 类 java.awt.geom.Line2D.Float 中的变量
线段起始点的 X 坐标。
x1 - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段起始点的 X 坐标。
x1 - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段起始点的 X 坐标。
x2 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段结束点的 X 坐标。
x2 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段结束点的 X 坐标。
x2 - 类 java.awt.geom.Line2D.Double 中的变量
线段结束点的 X 坐标。
x2 - 类 java.awt.geom.Line2D.Float 中的变量
线段结束点的 X 坐标。
x2 - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段结束点的 X 坐标。
x2 - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段结束点的 X 坐标。
X500Principal - javax.security.auth.x500 中的 类
此类表示一个 X.500 Principal。
X500Principal(String) - 类 javax.security.auth.x500.X500Principal 的构造方法
根据 X.500 标识名（例："CN=Duke、 OU=JavaSoft、 O=Sun Microsystems、 C=US"）的字符串表示形式创建 X500Principal。
X500Principal(String, Map<String, String>) - 类 javax.security.auth.x500.X500Principal 的构造方法
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。
X500Principal(byte[]) - 类 javax.security.auth.x500.X500Principal 的构造方法
根据 ASN.1 DER 编码格式的标识名创建 X500Principal。
X500Principal(InputStream) - 类 javax.security.auth.x500.X500Principal 的构造方法
根据包含 ASN.1 DER 编码格式的标识名的 InputStream 创建 X500Principal。
X500PrivateCredential - javax.security.auth.x500 中的 类
此类表示一个 X500PrivateCredential。
X500PrivateCredential(X509Certificate, PrivateKey) - 类 javax.security.auth.x500.X500PrivateCredential 的构造方法
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X500PrivateCredential(X509Certificate, PrivateKey, String) - 类 javax.security.auth.x500.X500PrivateCredential 的构造方法
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X509Certificate - java.security.cert 中的 类
X.509 证书的抽象类。
X509Certificate() - 类 java.security.cert.X509Certificate 的构造方法
X.509 证书的构造方法。
X509Certificate - javax.security.cert 中的 类
X.509 v1 证书的抽象类。
X509Certificate() - 类 javax.security.cert.X509Certificate 的构造方法
X509CertSelector - java.security.cert 中的 类
选择与所有指定标准匹配的 X509Certificates 的 CertSelector。
X509CertSelector() - 类 java.security.cert.X509CertSelector 的构造方法
创建一个 X509CertSelector。
X509CRL - java.security.cert 中的 类
X.509 证书撤消列表 (CRL) 的抽象类。
X509CRL() - 类 java.security.cert.X509CRL 的构造方法
X.509 CRL 的构造方法。
X509CRLEntry - java.security.cert 中的 类
用于 CRL（证书撤消列表）中已撤消证书的抽象类。
X509CRLEntry() - 类 java.security.cert.X509CRLEntry 的构造方法
X509CRLSelector - java.security.cert 中的 类
选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。
X509CRLSelector() - 类 java.security.cert.X509CRLSelector 的构造方法
创建一个 X509CRLSelector。
X509Data - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509Data 元素的表示形式。
X509EncodedKeySpec - java.security.spec 中的 类
此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。
X509EncodedKeySpec(byte[]) - 类 java.security.spec.X509EncodedKeySpec 的构造方法
根据给定的编码密钥创建一个新的 X509EncodedKeySpec。
X509ExtendedKeyManager - javax.net.ssl 中的 类
提供 X509KeyManager 接口的扩展的抽象类。
X509ExtendedKeyManager() - 类 javax.net.ssl.X509ExtendedKeyManager 的构造方法
仅供子类使用的构造方法。
X509Extension - java.security.cert 中的 接口
X.509 扩展的接口。
X509IssuerSerial - javax.xml.crypto.dsig.keyinfo 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML X509IssuerSerial 元素的表示形式。
X509KeyManager - javax.net.ssl 中的 接口
此接口的实例管理使用哪一个基于 X509 证书的密钥对来验证本地的安全套接字。
X509TrustManager - javax.net.ssl 中的 接口
此接口的实例管理使用哪一个 X509 证书来验证远端的安全套接字。
X_AXIS - 类 javax.swing.BoxLayout 中的静态变量
指定组件应该从左到右放置。
X_AXIS - 类 javax.swing.text.View 中的静态变量
用于格式化/拆分操作的轴。
XA_HEURCOM - 异常 javax.transaction.xa.XAException 中的静态变量
以启发式方式提交事务分支。
XA_HEURHAZ - 异常 javax.transaction.xa.XAException 中的静态变量
以启发式方式完成事务分支。
XA_HEURMIX - 异常 javax.transaction.xa.XAException 中的静态变量
以启发式方式提交并回滚事务分支。
XA_HEURRB - 异常 javax.transaction.xa.XAException 中的静态变量
以启发式方式回滚事务分支。
XA_NOMIGRATE - 异常 javax.transaction.xa.XAException 中的静态变量
必须在发生挂起的地方发生恢复。
XA_OK - 接口 javax.transaction.xa.XAResource 中的静态变量
事务工作正常准备就绪。
XA_RBBASE - 异常 javax.transaction.xa.XAException 中的静态变量
回滚代码包含的下边界。
XA_RBCOMMFAIL - 异常 javax.transaction.xa.XAException 中的静态变量
指示通讯失败导致该回滚。
XA_RBDEADLOCK - 异常 javax.transaction.xa.XAException 中的静态变量
检测死锁。
XA_RBEND - 异常 javax.transaction.xa.XAException 中的静态变量
回滚错误代码包含的上边界。
XA_RBINTEGRITY - 异常 javax.transaction.xa.XAException 中的静态变量
检测违反资源完整性的条件。
XA_RBOTHER - 异常 javax.transaction.xa.XAException 中的静态变量
由于一个不在此列表上的原因，资源管理器回滚事务分支。
XA_RBPROTO - 异常 javax.transaction.xa.XAException 中的静态变量
在资源管理器中发生协议错误。
XA_RBROLLBACK - 异常 javax.transaction.xa.XAException 中的静态变量
指示未指定的原因导致该回滚。
XA_RBTIMEOUT - 异常 javax.transaction.xa.XAException 中的静态变量
事务分支占用时间太长。
XA_RBTRANSIENT - 异常 javax.transaction.xa.XAException 中的静态变量
可以重试事务分支。
XA_RDONLY - 异常 javax.transaction.xa.XAException 中的静态变量
事务分支是只读的，并且已提交。
XA_RDONLY - 接口 javax.transaction.xa.XAResource 中的静态变量
事务分支是只读的，并且已提交。
XA_RETRY - 异常 javax.transaction.xa.XAException 中的静态变量
返回的例程无效，可以重新发布。
XAConnection - javax.sql 中的 接口
为分布式事务提供支持的对象。
XADataSource - javax.sql 中的 接口
在内部使用的 XAConnection 对象的工厂。
XAER_ASYNC - 异常 javax.transaction.xa.XAException 中的静态变量
已存在明显的异步操作。
XAER_DUPID - 异常 javax.transaction.xa.XAException 中的静态变量
XID 已存在。
XAER_INVAL - 异常 javax.transaction.xa.XAException 中的静态变量
提供了无效的参数。
XAER_NOTA - 异常 javax.transaction.xa.XAException 中的静态变量
XID 无效。
XAER_OUTSIDE - 异常 javax.transaction.xa.XAException 中的静态变量
资源管理器进行全局事务之外的工作。
XAER_PROTO - 异常 javax.transaction.xa.XAException 中的静态变量
在不合适的上下文中调用例程。
XAER_RMERR - 异常 javax.transaction.xa.XAException 中的静态变量
在事务分支中发生资源管理器错误。
XAER_RMFAIL - 异常 javax.transaction.xa.XAException 中的静态变量
资源管理器不可用。
XAException - javax.transaction.xa 中的 异常
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。
XAException() - 异常 javax.transaction.xa.XAException 的构造方法
创建一个 XAException。
XAException(String) - 异常 javax.transaction.xa.XAException 的构造方法
创建一个具有给定字符串的 XAException。
XAException(int) - 异常 javax.transaction.xa.XAException 的构造方法
创建一个具有给定错误代码的 XAException。
XAResource - javax.transaction.xa 中的 接口
XAResource 接口是基于 X/Open CAE 规范（分布式事务处理：XA 规范）的工业标准 XA 接口的 Java 映射。
Xid - javax.transaction.xa 中的 接口
Xid 接口是 X/Open 事务标识符 XID 结构的 Java 映射。
XML_DTD_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
作为属性值的 XML 文档类型声明名称空间 URI。
XML_NS_PREFIX - 类 javax.xml.XMLConstants 中的静态变量
正式的 XML 名称空间前缀。
XML_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
正式的 XML 名称空间名称 URI。
XmlAccessOrder - javax.xml.bind.annotation 中的 枚举
由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。
XmlAccessorOrder - javax.xml.bind.annotation 中的 注释类型
控制类中字段和属性的排序。
XmlAccessorType - javax.xml.bind.annotation 中的 注释类型
控制默认情况下是否对字段或 Javabean 属性进行系列化。
XmlAccessType - javax.xml.bind.annotation 中的 枚举
由 XmlAccessorType 使用，用于控制字段或属性的序列化。
XmlAdapter<ValueType,BoundType> - javax.xml.bind.annotation.adapters 中的 类
修改 Java 类型以适应自定义编组。
XmlAdapter() - 类 javax.xml.bind.annotation.adapters.XmlAdapter 的构造方法
派生类的构造方法，不执行任何操作。
XmlAnyAttribute - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到通配符属性的映射表中。
XmlAnyElement - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
XmlAttachmentRef - javax.xml.bind.annotation 中的 注释类型
标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
XmlAttribute - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到 XML 属性。
XMLConstants - javax.xml 中的 类
包含基本 XML 值作为常量的实用工具类。
XMLCryptoContext - javax.xml.crypto 中的 接口
包含用于 XML 加密操作的通用上下文信息。
XMLDecoder - java.beans 中的 类
XMLDecoder 类用于读取使用 XMLEncoder 创建的 XML 文档，用途类似于 ObjectInputStream。
XMLDecoder(InputStream) - 类 java.beans.XMLDecoder 的构造方法
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream, Object) - 类 java.beans.XMLDecoder 的构造方法
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream, Object, ExceptionListener) - 类 java.beans.XMLDecoder 的构造方法
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream, Object, ExceptionListener, ClassLoader) - 类 java.beans.XMLDecoder 的构造方法
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XmlElement - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到派生于属性名称的 XML 元素。
XmlElement.DEFAULT - javax.xml.bind.annotation 中的 类
在 XmlElement.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlElement.DEFAULT() - 类 javax.xml.bind.annotation.XmlElement.DEFAULT 的构造方法
XmlElementDecl - javax.xml.bind.annotation 中的 注释类型
将工厂方法映射到 XML 元素。
XmlElementDecl.GLOBAL - javax.xml.bind.annotation 中的 类
在 XmlElementDecl.scope() 中使用，指示声明是全局范围的。
XmlElementDecl.GLOBAL() - 类 javax.xml.bind.annotation.XmlElementDecl.GLOBAL 的构造方法
XmlElementRef - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到派生于属性类型的 XML 元素。
XmlElementRef.DEFAULT - javax.xml.bind.annotation 中的 类
在 XmlElementRef.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlElementRef.DEFAULT() - 类 javax.xml.bind.annotation.XmlElementRef.DEFAULT 的构造方法
XmlElementRefs - javax.xml.bind.annotation 中的 注释类型
标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
XmlElements - javax.xml.bind.annotation 中的 注释类型
多个 @XmlElement 注释的容器。
XmlElementWrapper - javax.xml.bind.annotation 中的 注释类型
生成一个包装 XML 表示形式的包装器元素。
XMLEncoder - java.beans 中的 类
XMLEncoder 类是 ObjectOutputStream 的互补替换，可用于生成 JavaBean 的文本表示形式，所使用方式与用 ObjectOutputStream 创建 Serializable 对象的二进制表示形式的方式相同。
XMLEncoder(OutputStream) - 类 java.beans.XMLEncoder 的构造方法
使用 XML 编码创建一个新的输出流，将 JavaBeans 发送给流 out。
XmlEnum - javax.xml.bind.annotation 中的 注释类型
将枚举类型 Enum 映射到 XML 表示形式。
XmlEnumValue - javax.xml.bind.annotation 中的 注释类型
将 Enum 类型中的枚举常量映射到 XML 表示形式。
XMLEvent - javax.xml.stream.events 中的 接口
处理标记事件的基础事件接口。
XMLEventAllocator - javax.xml.stream.util 中的 接口
此接口定义了一个类，该类允许用户注册给定 XMLStreamReader 的情况下分配事件的方式。
XMLEventConsumer - javax.xml.stream.util 中的 接口
此接口定义了一个事件使用者接口。
XMLEventFactory - javax.xml.stream 中的 类
此接口定义一个创建 XMLEvent 实例的实用工具类。
XMLEventFactory() - 类 javax.xml.stream.XMLEventFactory 的构造方法
XMLEventReader - javax.xml.stream 中的 接口
此类是用于解析 XML 事件的顶层接口。
XMLEventWriter - javax.xml.stream 中的 接口
此类是用于编写 XML 文档的顶层接口。
XMLFilter - org.xml.sax 中的 接口
用于 XML 过滤器的接口。
XMLFilterImpl - org.xml.sax.helpers 中的 类
派生 XML 过滤器的基类。
XMLFilterImpl() - 类 org.xml.sax.helpers.XMLFilterImpl 的构造方法
构造一个不带父过滤器的空 XML 过滤器。
XMLFilterImpl(XMLReader) - 类 org.xml.sax.helpers.XMLFilterImpl 的构造方法
构造一个带有特定父过滤器的 XML 过滤器。
XMLFormatter - java.util.logging 中的 类
将 LogRecord 格式化为标准 XML 格式。
XMLFormatter() - 类 java.util.logging.XMLFormatter 的构造方法
XMLGregorianCalendar - javax.xml.datatype 中的 类
W3C XML 模式 1.0 日期/时间数据类型的表示形式。
XMLGregorianCalendar() - 类 javax.xml.datatype.XMLGregorianCalendar 的构造方法
默认的无参数构造方法。
XmlID - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到 XML ID。
XmlIDREF - javax.xml.bind.annotation 中的 注释类型
将 JavaBean 属性映射到 XML IDREF。
XmlInlineBinaryData - javax.xml.bind.annotation 中的 注释类型
禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
XMLInputFactory - javax.xml.stream 中的 类
定义用于获取流的工厂的抽象实现。
XMLInputFactory() - 类 javax.xml.stream.XMLInputFactory 的构造方法
XmlJavaTypeAdapter - javax.xml.bind.annotation.adapters 中的 注释类型
对自定义编组使用实现 XmlAdapter 的适配器。
XmlJavaTypeAdapter.DEFAULT - javax.xml.bind.annotation.adapters 中的 类
此类在 XmlJavaTypeAdapter.type() 中使用，用来表示从字段、属性、参数或类的签名推导出的类型。
XmlJavaTypeAdapter.DEFAULT() - 类 javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT 的构造方法
XmlJavaTypeAdapters - javax.xml.bind.annotation.adapters 中的 注释类型
多个 @XmlJavaTypeAdapter 注释的容器。
XmlList - javax.xml.bind.annotation 中的 注释类型
用来将属性映射到列表简单类型。
XmlMimeType - javax.xml.bind.annotation 中的 注释类型
关联控制属性 XML 表示形式的 MIME 类型。
XmlMixed - javax.xml.bind.annotation 中的 注释类型
注释 JavaBean 多值属性，以支持混合内容。
XmlNs - javax.xml.bind.annotation 中的 注释类型
关联名称空间前缀与 XML 名称空间 URI。
XMLNS - 接口 javax.xml.crypto.dsig.XMLSignature 中的静态变量
W3C Recommendation for XML-Signature Syntax and Processing 的 XML 名称空间 URI。
XMLNS - 类 org.xml.sax.helpers.NamespaceSupport 中的静态变量
作为常量的 XML 名称空间 URI。
XMLNS_ATTRIBUTE - 类 javax.xml.XMLConstants 中的静态变量
用于指定 XML 名称空间声明的正式 XML 属性。
XMLNS_ATTRIBUTE_NS_URI - 类 javax.xml.XMLConstants 中的静态变量
用于指定 XML 名称空间声明、XMLConstants.XMLNS_ATTRIBUTE、名称空间名称 URI 的正式 XML 属性。
XmlNsForm - javax.xml.bind.annotation 中的 枚举
XML 模式名称空间限定的枚举。
XMLObject - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Object 元素的表示形式。
XMLOutputFactory - javax.xml.stream 中的 类
定义用于获取 XMLEventWriter 和 XMLStreamWriter 的工厂抽象实现。
XMLOutputFactory() - 类 javax.xml.stream.XMLOutputFactory 的构造方法
XMLParseException - javax.management.modelmbean 中的 异常
当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。
XMLParseException() - 异常 javax.management.modelmbean.XMLParseException 的构造方法
默认构造方法。
XMLParseException(String) - 异常 javax.management.modelmbean.XMLParseException 的构造方法
带有字符串的构造方法。
XMLParseException(Exception, String) - 异常 javax.management.modelmbean.XMLParseException 的构造方法
带有字符串和异常的构造方法。
XmlReader - javax.sql.rowset.spi 中的 接口
一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。
XMLReader - org.xml.sax 中的 接口
用于使用回调读取 XML 文档的接口。
XMLReaderAdapter - org.xml.sax.helpers 中的 类
将 SAX2 XMLReader 适配为 SAX1 解析器。
XMLReaderAdapter() - 类 org.xml.sax.helpers.XMLReaderAdapter 的构造方法
创建一个新的适配器。
XMLReaderAdapter(XMLReader) - 类 org.xml.sax.helpers.XMLReaderAdapter 的构造方法
创建一个新的适配器。
XMLReaderFactory - org.xml.sax.helpers 中的 类
创建 XML 阅读器的工厂。
XmlRegistry - javax.xml.bind.annotation 中的 注释类型
标记具有 XmlElementDecl 的类。
XMLReporter - javax.xml.stream 中的 接口
此接口用于报告非严重错误。
XMLResolver - javax.xml.stream 中的 接口
此接口用于在 XML 解析过程中解析资源。
XmlRootElement - javax.xml.bind.annotation 中的 注释类型
将类或枚举类型映射到 XML 元素。
XmlSchema - javax.xml.bind.annotation 中的 注释类型
将包名称映射到 XML 名称空间。
XmlSchemaType - javax.xml.bind.annotation 中的 注释类型
将 Java 类型映射到一个简单的模式内置类型。
XmlSchemaType.DEFAULT - javax.xml.bind.annotation 中的 类
在 XmlSchemaType.type() 中使用，用于表示根据属性签名推断出来的类型。
XmlSchemaType.DEFAULT() - 类 javax.xml.bind.annotation.XmlSchemaType.DEFAULT 的构造方法
XmlSchemaTypes - javax.xml.bind.annotation 中的 注释类型
多个 @XmlSchemaType 注释的容器。
XMLSignature - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML Signature 元素的表示形式。
XMLSignature.SignatureValue - javax.xml.crypto.dsig 中的 接口
W3C Recommendation for XML-Signature Syntax and Processing 中定义的 XML SignatureValue 元素的表示形式。
XMLSignatureException - javax.xml.crypto.dsig 中的 异常
指示生成或验证 XML 签名过程中发生的异常条件。
XMLSignatureException() - 异常 javax.xml.crypto.dsig.XMLSignatureException 的构造方法
构造用 null 作为其详细消息的新 XMLSignatureException。
XMLSignatureException(String) - 异常 javax.xml.crypto.dsig.XMLSignatureException 的构造方法
构造带指定详细消息的新 XMLSignatureException。
XMLSignatureException(String, Throwable) - 异常 javax.xml.crypto.dsig.XMLSignatureException 的构造方法
构造一个带指定详细消息和 cause 的新 XMLSignatureException。
XMLSignatureException(Throwable) - 异常 javax.xml.crypto.dsig.XMLSignatureException 的构造方法
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 XMLSignatureException（它通常包含 cause 的类和详细消息）。
XMLSignatureFactory - javax.xml.crypto.dsig 中的 类
用于从头创建 XMLSignature 对象或从相应的 XML 表示形式解组 XMLSignature 对象的工厂。
XMLSignatureFactory() - 类 javax.xml.crypto.dsig.XMLSignatureFactory 的构造方法
默认的构造方法，由子类调用。
XMLSignContext - javax.xml.crypto.dsig 中的 接口
包含用于生成 XML Signature 的上下文信息。
XMLStreamConstants - javax.xml.stream 中的 接口
此接口声明此 API 中所使用的常量。
XMLStreamException - javax.xml.stream 中的 异常
用于不可预料处理错误的基本异常。
XMLStreamException() - 异常 javax.xml.stream.XMLStreamException 的构造方法
默认构造方法
XMLStreamException(String) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联消息的异常。
XMLStreamException(Throwable) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联异常的异常
XMLStreamException(String, Throwable) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联消息和异常的异常
XMLStreamException(String, Location, Throwable) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联消息、异常和位置的异常。
XMLStreamException(String, Location) - 异常 javax.xml.stream.XMLStreamException 的构造方法
构造具有关联消息、异常和位置的异常。
XMLStreamReader - javax.xml.stream 中的 接口
XMLStreamReader 接口允许转发 XML 和对 XML 的只读访问。
XMLStreamWriter - javax.xml.stream 中的 接口
XMLStreamWriter 接口指定如何编写 XML。
XMLStructure - javax.xml.crypto 中的 接口
任何名称空间的 XML 结构的表示形式。
XmlTransient - javax.xml.bind.annotation 中的 注释类型
阻止将 JavaBean 属性映射到 XML 表示形式。
XmlType - javax.xml.bind.annotation 中的 注释类型
将类或枚举类型映射到 XML 模式类型。
XmlType.DEFAULT - javax.xml.bind.annotation 中的 类
在 XmlType.factoryClass() 中使用，指示工厂方法未被使用或者在具有此 XmlType 的类中。
XmlType.DEFAULT() - 类 javax.xml.bind.annotation.XmlType.DEFAULT 的构造方法
XMLValidateContext - javax.xml.crypto.dsig 中的 接口
包含用于验证 XML Signature 的上下文信息。
XmlValue - javax.xml.bind.annotation 中的 注释类型
支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。
XmlWriter - javax.sql.rowset.spi 中的 接口
一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。
XOR - 类 java.awt.AlphaComposite 中的静态变量
将目标色之外的源色部分与源色之外的目标色部分结合到一起（Porter-Duff Source Xor Destination 规则）。
Xor - 类 java.awt.AlphaComposite 中的静态变量
实现不透明 XOR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
xor(BigInteger) - 类 java.math.BigInteger 中的方法
返回其值为 (this ^ val) 的 BigInteger。
xor(BitSet) - 类 java.util.BitSet 中的方法
对此位 set 和位 set 参数执行逻辑异或操作。
XPATH - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
XPath 转换算法 URI。
XPath - javax.xml.xpath 中的 接口
XPath 提供了对 XPath 计算环境和表达式的访问。
XPATH2 - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
XPath Filter 2 转换算法 URI。
XPathConstants - javax.xml.xpath 中的 类
XPath 常量。
XPathException - javax.xml.xpath 中的 异常
XPathException 表示通用 XPath 异常。
XPathException(String) - 异常 javax.xml.xpath.XPathException 的构造方法
构造带指定详细 message 的新 XPathException。
XPathException(Throwable) - 异常 javax.xml.xpath.XPathException 的构造方法
构造带指定 cause 的新 XPathException。
XPathExpression - javax.xml.xpath 中的 接口
XPathExpression 提供了对编译后的 XPath 表达式的访问。
XPathExpressionException - javax.xml.xpath 中的 异常
XPathExpressionException 表示 XPath 表达式中的错误。
XPathExpressionException(String) - 异常 javax.xml.xpath.XPathExpressionException 的构造方法
构造带指定详细 message 的新 XPathExpressionException。
XPathExpressionException(Throwable) - 异常 javax.xml.xpath.XPathExpressionException 的构造方法
构造带指定 cause 的新 XPathExpressionException。
XPathFactory - javax.xml.xpath 中的 类
XPathFactory 实例可用于创建 XPath 对象。
XPathFactory() - 类 javax.xml.xpath.XPathFactory 的构造方法
应使用 XPathFactory.newInstance()、XPathFactory.newInstance(String uri) 或 XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader) 之类的受保护构造方法创建 XPathFactory 的新实例。
XPathFactoryConfigurationException - javax.xml.xpath 中的 异常
XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
XPathFactoryConfigurationException(String) - 异常 javax.xml.xpath.XPathFactoryConfigurationException 的构造方法
构造带指定详细 message 的新 XPathFactoryConfigurationException。
XPathFactoryConfigurationException(Throwable) - 异常 javax.xml.xpath.XPathFactoryConfigurationException 的构造方法
构造带指定 cause 的新 XPathFactoryConfigurationException。
XPathFilter2ParameterSpec - javax.xml.crypto.dsig.spec 中的 类
W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。
XPathFilter2ParameterSpec(List) - 类 javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec 的构造方法
创建一个 XPathFilter2ParameterSpec。
XPathFilterParameterSpec - javax.xml.crypto.dsig.spec 中的 类
XPath Filtering Transform Algorithm 的参数。
XPathFilterParameterSpec(String) - 类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 的构造方法
创建带有指定 XPath 表达式的 XPathFilterParameterSpec。
XPathFilterParameterSpec(String, Map) - 类 javax.xml.crypto.dsig.spec.XPathFilterParameterSpec 的构造方法
创建带有指定 XPath 表达式和名称空间映射表的 XPathFilterParameterSpec。
XPathFunction - javax.xml.xpath 中的 接口
XPathFunction 提供了对 XPath 函数的访问。
XPathFunctionException - javax.xml.xpath 中的 异常
XPathFunctionException 表示 XPath 函数的错误。
XPathFunctionException(String) - 异常 javax.xml.xpath.XPathFunctionException 的构造方法
构造带指定详细 message 的新 XPathFunctionException。
XPathFunctionException(Throwable) - 异常 javax.xml.xpath.XPathFunctionException 的构造方法
构造带指定 cause 的新 XPathFunctionException。
XPathFunctionResolver - javax.xml.xpath 中的 接口
XPathFunctionResolver 提供了对用户定义的 XPathFunction 集的访问。
XPathType - javax.xml.crypto.dsig.spec 中的 类
W3C Recommendation for XML-Signature XPath Filter 2.0 中所定义的 XPath 元素的 XML 模式定义：
XPathType(String, XPathType.Filter) - 类 javax.xml.crypto.dsig.spec.XPathType 的构造方法
创建带有指定 XPath 表达式和过滤器的 XPathType 实例。
XPathType(String, XPathType.Filter, Map) - 类 javax.xml.crypto.dsig.spec.XPathType 的构造方法
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。
XPathType.Filter - javax.xml.crypto.dsig.spec 中的 类
表示过滤器设置操作。
XPathVariableResolver - javax.xml.xpath 中的 接口
XPathVariableResolver 提供了对用户定义的 XPath 变量集的访问。
xpoints - 类 java.awt.Polygon 中的变量
X 坐标的数组。
xPositionForValue(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
XSLT - 接口 javax.xml.crypto.dsig.Transform 中的静态变量
XSLT 转换算法 URI。
XSLTTransformParameterSpec - javax.xml.crypto.dsig.spec 中的 类
XSLT Transform Algorithm 的参数。
XSLTTransformParameterSpec(XMLStructure) - 类 javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec 的构造方法
创建带有指定样式表的 XSLTTransformParameterSpec。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Y - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Y

y - 类 java.awt.Event 中的变量
事件的 y 坐标。
y - 类 java.awt.geom.Arc2D.Double 中的变量
弧的窗体矩形左上角的 Y 坐标。
y - 类 java.awt.geom.Arc2D.Float 中的变量
弧的窗体矩形左上角的 Y 坐标。
y - 类 java.awt.geom.Ellipse2D.Double 中的变量
此 Ellipse2D 的窗体矩形左上角的 Y 坐标。
y - 类 java.awt.geom.Ellipse2D.Float 中的变量
此 Ellipse2D 窗体矩形左上角的 Y 坐标。
y - 类 java.awt.geom.Point2D.Double 中的变量
此 Point2D 的 Y 坐标。
y - 类 java.awt.geom.Point2D.Float 中的变量
此 Point2D 的 Y 坐标。
y - 类 java.awt.geom.Rectangle2D.Double 中的变量
此 Rectangle2D 的 Y 坐标。
y - 类 java.awt.geom.Rectangle2D.Float 中的变量
此 Rectangle2D 的 Y 坐标。
y - 类 java.awt.geom.RoundRectangle2D.Double 中的变量
此 RoundRectangle2D 的 Y 坐标。
y - 类 java.awt.geom.RoundRectangle2D.Float 中的变量
此 RoundRectangle2D 的 Y 坐标。
y - 类 java.awt.Point 中的变量
此 Point 的 Y 坐标。
y - 类 java.awt.Rectangle 中的变量
Rectangle 左上角的 Y 坐标。
y1 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.Line2D.Double 中的变量
线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.Line2D.Float 中的变量
线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段起始点的 Y 坐标。
y1 - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段起始点的 Y 坐标。
y2 - 类 java.awt.geom.CubicCurve2D.Double 中的变量
三次曲线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.CubicCurve2D.Float 中的变量
三次曲线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.Line2D.Double 中的变量
线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.Line2D.Float 中的变量
线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.QuadCurve2D.Double 中的变量
二次曲线段结束点的 Y 坐标。
y2 - 类 java.awt.geom.QuadCurve2D.Float 中的变量
二次曲线段结束点的 Y 坐标。
Y_AXIS - 类 javax.swing.BoxLayout 中的静态变量
指定组件应该从上到下放置。
Y_AXIS - 类 javax.swing.text.View 中的静态变量
用于格式化/拆分操作的轴。
YEAR - 类 java.text.DateFormat.Field 中的静态变量
标识 YEAR 字段的常量。
YEAR - 类 java.util.Calendar 中的静态变量
指示年的 get 和 set 的字段数字。
YEAR_FIELD - 类 java.text.DateFormat 中的静态变量
用于对齐 YEAR 字段的有用常量。
YEARS - 类 javax.xml.datatype.DatatypeConstants 中的静态变量
表示年字段的常量。
yellow - 类 java.awt.Color 中的静态变量
黄色。
YELLOW - 类 java.awt.Color 中的静态变量
黄色。
YES - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
YES 选项。
YES_NO_CANCEL_OPTION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
YES/NO/CANCEL 确认选项。
YES_NO_CANCEL_OPTION - 类 javax.swing.JOptionPane 中的静态变量
用于 showConfirmDialog 的类型。
YES_NO_OPTION - 类 javax.security.auth.callback.ConfirmationCallback 中的静态变量
YES/NO 确认选项。
YES_NO_OPTION - 类 javax.swing.JOptionPane 中的静态变量
用于 showConfirmDialog 的类型。
YES_OPTION - 类 javax.swing.JOptionPane 中的静态变量
选择 YES 时从类方法返回的值。
YI_RADICALS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Yi Radicals”Unicode 字符块的常量。
YI_SYLLABLES - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Yi Syllables”Unicode 字符块的常量。
yield() - 类 java.lang.Thread 中的静态方法
暂停当前正在执行的线程对象，并执行其他线程。
YIJING_HEXAGRAM_SYMBOLS - 类 java.lang.Character.UnicodeBlock 中的静态变量
“Yijing Hexagram Symbols”Unicode 字符块的常量。
YOU_1 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #1 信封尺寸，120 mm × 176 mm。
YOU_2 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #2 信封尺寸，114 mm × 162 mm。
YOU_3 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #3 信封尺寸，98 mm × 148 mm。
YOU_4 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #4 信封尺寸，105 mm × 235 mm。
YOU_5 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #5 信封尺寸，95 mm × 217 mm。
YOU_6 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #6 信封尺寸，98 mm × 190 mm。
YOU_7 - 类 javax.print.attribute.standard.MediaSize.JIS 中的静态变量
指定 JIS You ("Western") #7 信封尺寸，92 mm × 165 mm。
ypoints - 类 java.awt.Polygon 中的变量
Y 坐标的数组。
yPositionForValue(int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
yPositionForValue(int, int, int) - 类 javax.swing.plaf.basic.BasicSliderUI 中的方法
返回指定值的 y 位置。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


Z - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Z

ZERO - 类 java.math.BigDecimal 中的静态变量
值为 0，标度为 0。
ZERO - 类 java.math.BigInteger 中的静态变量
BigInteger 的常量 0。
ZipEntry - java.util.zip 中的 类
此类用于表示 ZIP 文件条目。
ZipEntry(String) - 类 java.util.zip.ZipEntry 的构造方法
使用指定名称创建新的 ZIP 条目。
ZipEntry(ZipEntry) - 类 java.util.zip.ZipEntry 的构造方法
使用从指定 ZIP 条目获取的字段创建新的 ZIP 条目。
ZipError - java.util.zip 中的 错误
发生不可恢复的错误时抛出。
ZipError(String) - 错误 java.util.zip.ZipError 的构造方法
构造带有给定详细消息的 ZipError。
ZipException - java.util.zip 中的 异常
如果某种 ZIP 异常发生，则抛出此错误。
ZipException() - 异常 java.util.zip.ZipException 的构造方法
使用 null 作为错误详细消息构造 ZipException。
ZipException(String) - 异常 java.util.zip.ZipException 的构造方法
构建带指定详细消息的 ZipException。
ZipFile - java.util.zip 中的 类
此类用于从 ZIP 文件读取条目。
ZipFile(String) - 类 java.util.zip.ZipFile 的构造方法
打开 ZIP 文件进行阅读。
ZipFile(File, int) - 类 java.util.zip.ZipFile 的构造方法
打开新的 ZipFile 以使用指定模式从指定 File 对象读取。
ZipFile(File) - 类 java.util.zip.ZipFile 的构造方法
打开供阅读的 ZIP 文件，由指定的 File 对象给出。
ZipInputStream - java.util.zip 中的 类
此类为读取 ZIP 文件格式的文件实现输入流过滤器。
ZipInputStream(InputStream) - 类 java.util.zip.ZipInputStream 的构造方法
创建新的 ZIP 输入流。
ZipOutputStream - java.util.zip 中的 类
此类为以 ZIP 文件格式写入文件实现输出流过滤器。
ZipOutputStream(OutputStream) - 类 java.util.zip.ZipOutputStream 的构造方法
创建新的 ZIP 输出流。
ZONE_OFFSET - 类 java.util.Calendar 中的静态变量
get 和 set 的字段数字，以毫秒为单位指示距 GMT 的大致偏移量。
ZoneView - javax.swing.text 中的 类
ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。
ZoneView(Element, int) - 类 javax.swing.text.ZoneView 的构造方法
构造一个 ZoneView。
zoneWasLoaded(View) - 类 javax.swing.text.ZoneView 中的方法
当加载某个分区后由该分区调用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _


_ - 索引 (Java Platform SE 6)

上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

_

_ACTIVE - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
_ADD_OVERRIDE - 类 org.omg.CORBA.SetOverrideType 中的静态变量
用于枚举值 ADD_OVERRIDE 的 int 常量。
_all_interfaces(POA, byte[]) - 类 org.omg.CosNaming.BindingIteratorPOA 中的方法
_all_interfaces(POA, byte[]) - 类 org.omg.CosNaming.NamingContextExtPOA 中的方法
_all_interfaces(POA, byte[]) - 类 org.omg.CosNaming.NamingContextPOA 中的方法
_all_interfaces(POA, byte[]) - 类 org.omg.PortableServer.Servant 中的方法
ORB 使用此操作从 servant 获取完整的类型信息。
_all_interfaces(POA, byte[]) - 类 org.omg.PortableServer.ServantActivatorPOA 中的方法
_all_interfaces(POA, byte[]) - 类 org.omg.PortableServer.ServantLocatorPOA 中的方法
_BindingIteratorImplBase - org.omg.CosNaming 中的 类
_BindingIteratorImplBase() - 类 org.omg.CosNaming._BindingIteratorImplBase 的构造方法
_BindingIteratorStub - org.omg.CosNaming 中的 类
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
_BindingIteratorStub() - 类 org.omg.CosNaming._BindingIteratorStub 的构造方法
_COMPLETED_MAYBE - 类 org.omg.CORBA.CompletionStatus 中的静态变量
指示某一方法在抛出 SystemException 之前已结束运行的常量。
_COMPLETED_NO - 类 org.omg.CORBA.CompletionStatus 中的静态变量
指示某一方法在抛出 SystemException 之前已结束运行的常量。
_COMPLETED_YES - 类 org.omg.CORBA.CompletionStatus 中的静态变量
指示某一方法在抛出 SystemException 之前已结束运行的常量。
_create_request(Context, String, NVList, NamedValue) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_create_request(Context, String, NVList, NamedValue) - 接口 org.omg.CORBA.Object 中的方法
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - 接口 org.omg.CORBA.Object 中的方法
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。
_create_request(Context, String, NVList, NamedValue) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。
_default_POA() - 类 org.omg.PortableServer.Servant 中的方法
从与 servant 关联的 ORB 实例返回根 POA。
_DISCARDING - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
_dk_AbstractInterface - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Alias - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_all - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Array - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Attribute - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Constant - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Enum - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Exception - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Fixed - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Interface - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Module - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Native - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_none - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有定义种类的常量。
_dk_Operation - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Primitive - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Repository - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Sequence - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_String - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Struct - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Typedef - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Union - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Value - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_ValueBox - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_ValueMember - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_dk_Wstring - 类 org.omg.CORBA.DefinitionKind 中的静态变量
指示 Interface Repository 对象不具有某一定义种类的常量。
_duplicate() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_duplicate() - 接口 org.omg.CORBA.Object 中的方法
返回此 CORBA 对象引用的副本。
_duplicate() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回此 ObjectImpl 对象的一个副本。
_DynAnyFactoryStub - org.omg.DynamicAny 中的 类
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
_DynAnyFactoryStub() - 类 org.omg.DynamicAny._DynAnyFactoryStub 的构造方法
_DynAnyStub - org.omg.DynamicAny 中的 类
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
_DynAnyStub() - 类 org.omg.DynamicAny._DynAnyStub 的构造方法
_DynArrayStub - org.omg.DynamicAny 中的 类
DynArray 对象支持对 IDL 数组 (array) 的操作。
_DynArrayStub() - 类 org.omg.DynamicAny._DynArrayStub 的构造方法
_DynEnumStub - org.omg.DynamicAny 中的 类
DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
_DynEnumStub() - 类 org.omg.DynamicAny._DynEnumStub 的构造方法
_DynFixedStub - org.omg.DynamicAny 中的 类
DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
_DynFixedStub() - 类 org.omg.DynamicAny._DynFixedStub 的构造方法
_DynSequenceStub - org.omg.DynamicAny 中的 类
DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
_DynSequenceStub() - 类 org.omg.DynamicAny._DynSequenceStub 的构造方法
_DynStructStub - org.omg.DynamicAny 中的 类
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
_DynStructStub() - 类 org.omg.DynamicAny._DynStructStub 的构造方法
_DynUnionStub - org.omg.DynamicAny 中的 类
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
_DynUnionStub() - 类 org.omg.DynamicAny._DynUnionStub 的构造方法
_DynValueStub - org.omg.DynamicAny 中的 类
DynValue 对象支持 IDL non-boxed value 类型的操作。
_DynValueStub() - 类 org.omg.DynamicAny._DynValueStub 的构造方法
_get_codebase() - 类 org.omg.CORBA_2_3.portable.ObjectImpl 中的方法
返回此对象引用的代码基。
_get_delegate() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得对特定于供应商的 Delegate 对象的引用，此 ObjectImpl 对象将对其调用的所有方法委托给该对象。
_get_delegate() - 类 org.omg.PortableServer.Servant 中的方法
获取 PortableServer::Servant 特定于供应商的 ORB 实现。
_get_domain_managers() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_get_domain_managers() - 接口 org.omg.CORBA.Object 中的方法
检索此对象的 DomainManager。
_get_domain_managers() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得此 ObjectImpl 对象的域管理程序所组成的列表。
_get_interface() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_get_interface_def() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_get_interface_def() - 接口 org.omg.CORBA.Object 中的方法
获取此对象引用所引用的对象实现的 InterfaceDef。
_get_interface_def() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得此 ObjectImpl 对象的接口定义。
_get_interface_def() - 类 org.omg.PortableServer.Servant 中的方法
以 CORBA::Object 的形式返回 InterfaceDef 对象，该对象定义由 Servant 实现的 CORBA::Object 的运行时类型。
_get_policy(int) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_get_policy(int) - 接口 org.omg.CORBA.Object 中的方法
返回应用于此对象的指定类型的 Policy 对象。
_get_policy(int) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得此 ObjectImpl 对象具有给定策略类型的 Policy 对象。
_hash(int) - 类 org.omg.CORBA.LocalObject 中的方法
返回与对象的生命周期一致的哈希值，使用给定数字作为最大值。
_hash(int) - 接口 org.omg.CORBA.Object 中的方法
返回此对象引用的 ORB 内部标识符。
_hash(int) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得充当此 ObjectImpl 对象内部 ORB 标识符的哈希码。
_HOLDING - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
_IDLTypeStub - org.omg.CORBA 中的 类
IDLType 的 Stub。
_IDLTypeStub() - 类 org.omg.CORBA._IDLTypeStub 的构造方法
构造一个默认 _IDLTypeStub 对象。
_IDLTypeStub(Delegate) - 类 org.omg.CORBA._IDLTypeStub 的构造方法
构造一个 _IDLTypeStub 对象，并使用给定 Delegate 对象初始化。
_ids() - 类 org.omg.CORBA._IDLTypeStub 中的方法
_ids() - 类 org.omg.CORBA._PolicyStub 中的方法
_ids() - 类 org.omg.CORBA.DynamicImplementation 中的方法
已过时。
_ids() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。
_ids() - 类 org.omg.CosNaming._BindingIteratorImplBase 中的方法
_ids() - 类 org.omg.CosNaming._BindingIteratorStub 中的方法
_ids() - 类 org.omg.CosNaming._NamingContextExtStub 中的方法
_ids() - 类 org.omg.CosNaming._NamingContextImplBase 中的方法
_ids() - 类 org.omg.CosNaming._NamingContextStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynAnyFactoryStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynAnyStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynArrayStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynEnumStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynFixedStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynSequenceStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynStructStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynUnionStub 中的方法
_ids() - 类 org.omg.DynamicAny._DynValueStub 中的方法
_ids() - 类 org.omg.PortableServer._ServantActivatorStub 中的方法
_ids() - 类 org.omg.PortableServer._ServantLocatorStub 中的方法
_ids() - 类 org.omg.stub.java.rmi._Remote_Stub 中的方法
返回对象实现的存储库 id 数组。
_IMPLICIT_ACTIVATION - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态变量
_INACTIVE - 类 org.omg.PortableServer.POAManagerPackage.State 中的静态变量
_invoke(OutputStream) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_invoke(String, InputStream, ResponseHandler) - 接口 org.omg.CORBA.portable.InvokeHandler 中的方法
由 ORB 调用来调度对 servant 的请求。
_invoke(OutputStream) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
调用某个操作并返回用来读取响应的 InputStream 对象。
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.CosNaming.BindingIteratorPOA 中的方法
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.CosNaming.NamingContextExtPOA 中的方法
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.CosNaming.NamingContextPOA 中的方法
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.PortableServer.ServantActivatorPOA 中的方法
_invoke(String, InputStream, ResponseHandler) - 类 org.omg.PortableServer.ServantLocatorPOA 中的方法
_is_a(String) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_is_a(String) - 接口 org.omg.CORBA.Object 中的方法
检查此对象是否是实现给定接口的类的实例。
_is_a(String) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
检查给定存储库标识符标识的对象是否是 ObjectImpl 对象。
_is_a(String) - 类 org.omg.PortableServer.Servant 中的方法
查看指定的 repository_id 是否存在于 _all_interfaces() 返回的列表，或者其是否是一般 CORBA 对象的 repository_id。
_is_equivalent(Object) - 类 org.omg.CORBA.LocalObject 中的方法
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
_is_equivalent(Object) - 接口 org.omg.CORBA.Object 中的方法
在 ORB 确定时所需开销不大的范围内确定两个对象引用是否相等。
_is_equivalent(Object) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
检查给定的 ObjectImpl 对象是否等于此 ObjectImpl 对象。
_is_local() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_is_local() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
检查此 ObjectImpl 对象是否是由本地 servant 实现的。
_missing_node - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
_MULTIPLE_ID - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态变量
_NamingContextExtStub - org.omg.CosNaming 中的 类
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
_NamingContextExtStub() - 类 org.omg.CosNaming._NamingContextExtStub 的构造方法
_NamingContextImplBase - org.omg.CosNaming 中的 类
_NamingContextImplBase() - 类 org.omg.CosNaming._NamingContextImplBase 的构造方法
_NamingContextStub - org.omg.CosNaming 中的 类
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
_NamingContextStub() - 类 org.omg.CosNaming._NamingContextStub 的构造方法
_ncontext - 类 org.omg.CosNaming.BindingType 中的静态变量
_NO_IMPLICIT_ACTIVATION - 类 org.omg.PortableServer.ImplicitActivationPolicyValue 中的静态变量
_nobject - 类 org.omg.CosNaming.BindingType 中的静态变量
_non_existent() - 类 org.omg.CORBA.LocalObject 中的方法
总是返回 false。
_non_existent() - 接口 org.omg.CORBA.Object 中的方法
确定此对象引用的 server 对象是否已经被销毁。
_non_existent() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
检查此 ObjectImpl 对象的 server 对象是否已经被销毁。
_non_existent() - 类 org.omg.PortableServer.Servant 中的方法
检查 Object 是否存在。
_NON_RETAIN - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态变量
_not_context - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
_not_object - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReason 中的静态变量
_object_id() - 类 org.omg.PortableServer.Servant 中的方法
允许便捷地执行公共方法，等效于调用 PortableServer::Current::get_object_id。
_opsClass - 类 org.omg.DynamicAny._DynAnyFactoryStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynAnyStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynArrayStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynEnumStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynFixedStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynSequenceStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynStructStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynUnionStub 中的静态变量
_opsClass - 类 org.omg.DynamicAny._DynValueStub 中的静态变量
_opsClass - 类 org.omg.PortableServer._ServantActivatorStub 中的静态变量
_opsClass - 类 org.omg.PortableServer._ServantLocatorStub 中的静态变量
_orb() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_orb() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回对与此对象及其委托相关的 ORB 的引用。
_orb() - 类 org.omg.PortableServer.Servant 中的方法
返回当前与 Servant 关联的 ORB 实例（便捷方法）。
_ORB_CTRL_MODEL - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态变量
_PARAM_IN - 类 org.omg.CORBA.ParameterMode 中的静态变量
_PARAM_INOUT - 类 org.omg.CORBA.ParameterMode 中的静态变量
_PARAM_OUT - 类 org.omg.CORBA.ParameterMode 中的静态变量
_PERSISTENT - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态变量
_poa() - 类 org.omg.PortableServer.Servant 中的方法
允许便捷地执行共用方法，等效于 PortableServer::Current:get_POA。
_PolicyStub - org.omg.CORBA 中的 类
Policy 的 Stub。
_PolicyStub() - 类 org.omg.CORBA._PolicyStub 的构造方法
构造方法注意事项：如果使用默认构造方法，则该对象在调用 _set_delegate (...) 方法前没有用。
_PolicyStub(Delegate) - 类 org.omg.CORBA._PolicyStub 的构造方法
构造一个 _PolicyStub 对象，并使用给定 Delegate 对象初始化。
_postEdit(UndoableEdit) - 类 javax.swing.undo.UndoableEditSupport 中的方法
仅从 postEdit 和 endUpdate 调用。
_read(InputStream) - 类 org.omg.CORBA.AnyHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
_read(InputStream) - 类 org.omg.CORBA.AnySeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.BooleanHolder 中的方法
从 input 中读取已解组的数据，并将它们分配给此 BooleanHolder 对象的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.BooleanSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ByteHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 ByteHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.CharHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 CharHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.CharSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.CurrentHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.DoubleHolder 中的方法
从输入流读取一个 double 值，并将其存储在值成员中。
_read(InputStream) - 类 org.omg.CORBA.DoubleSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.FixedHolder 中的方法
从输入流读取定点值，并将其存储在值成员中。
_read(InputStream) - 类 org.omg.CORBA.FloatHolder 中的方法
从输入流读取一个 float 值，并使用该 float 值初始化值成员。
_read(InputStream) - 类 org.omg.CORBA.FloatSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.IntHolder 中的方法
从 input 中读取已解组数据，并将其分配给此 IntHolder 对象的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.LongHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
_read(InputStream) - 类 org.omg.CORBA.LongLongSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.LongSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ObjectHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 ObjectHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.OctetSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ParameterModeHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.PolicyErrorHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.PolicyHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.PolicyListHolder 中的方法
_read(InputStream) - 接口 org.omg.CORBA.portable.Streamable 中的方法
从 istream 读取数据，并使用已解组数据初始化 Holder 的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.PrincipalHolder 中的方法
已过时。
_read(InputStream) - 类 org.omg.CORBA.ServiceInformationHolder 中的方法
从输入流 in 中读取已解组数据，并将它赋予此 ServiceInformationHolder 对象的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.ShortHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 ShortHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.ShortSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.StringHolder 中的方法
从 input 中读取已解组的数据，并将它赋予此 StringHolder 对象的 value 字段。
_read(InputStream) - 类 org.omg.CORBA.StringSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.TypeCodeHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化此 TypeCodeHolder 对象中的值。
_read(InputStream) - 类 org.omg.CORBA.ULongLongSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ULongSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.UnknownUserExceptionHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.UShortSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.ValueBaseHolder 中的方法
从 input 中读取数据，并使用已解组数据初始化 Holder 中的值。
_read(InputStream) - 类 org.omg.CORBA.WCharSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.WrongTransactionHolder 中的方法
_read(InputStream) - 类 org.omg.CORBA.WStringSeqHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.BindingHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.BindingIteratorHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.BindingListHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.BindingTypeHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NameComponentHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NameHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextExtHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 中的方法
_read(InputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.IORHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.MultipleComponentProfileHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.ServiceContextHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.ServiceContextListHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.TaggedComponentHolder 中的方法
_read(InputStream) - 类 org.omg.IOP.TaggedProfileHolder 中的方法
_read(InputStream) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 中的方法
_read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 中的方法
_read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 中的方法
_read(InputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 中的方法
_read(InputStream) - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 中的方法
_release() - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_release() - 接口 org.omg.CORBA.Object 中的方法
发出信号，指示此对象引用调用者已经使用完毕，因而可以释放与此对象引用关联的内部 ORB 资源。
_release() - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
释放与此 ObjectImpl 对象关联的资源。
_releaseReply(InputStream) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_releaseReply(InputStream) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
调用 _invoke 方法并且解组完成后，将给定的应答流释放回 ORB。
_Remote_Stub - org.omg.stub.java.rmi 中的 类
此类为 Remote 类型提供 Stub。
_Remote_Stub() - 类 org.omg.stub.java.rmi._Remote_Stub 的构造方法
_request(String) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_request(String, boolean) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_request(String) - 接口 org.omg.CORBA.Object 中的方法
创建一个在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。
_request(String) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
创建一个 Request 对象，使其包含可用于动态调用接口 (Dynamic Invocation Interface) 的给定方法。
_request(String, boolean) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回一个 OutputStream 对象，该对象用于编组给定方法的参数。
_RETAIN - 类 org.omg.PortableServer.ServantRetentionPolicyValue 中的静态变量
_servant_postinvoke(ServantObject) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_servant_postinvoke(ServantObject) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
本地 stub 在发起了对本地 servant（通过对 _servant_preinvoke 方法的调用得到）的一次操作后，再调用此方法。
_servant_preinvoke(String, Class) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_servant_preinvoke(String, Class) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。
_ServantActivatorStub - org.omg.PortableServer 中的 类
当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
_ServantActivatorStub() - 类 org.omg.PortableServer._ServantActivatorStub 的构造方法
_ServantLocatorStub - org.omg.PortableServer 中的 类
POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
_ServantLocatorStub() - 类 org.omg.PortableServer._ServantLocatorStub 的构造方法
_set_delegate(Delegate) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
将此 ObjectImpl 实例的 Delegate 设置为给定的 Delegate 对象。
_set_delegate(Delegate) - 类 org.omg.PortableServer.Servant 中的方法
此操作支持 Java ORB 可移植性接口，它向通过代理支持 ORB 可移植性的类提供一个设置其委托的方法。
_SET_OVERRIDE - 类 org.omg.CORBA.SetOverrideType 中的静态变量
用于枚举值 SET_OVERRIDE 的 int 常量。
_set_policy_override(Policy[], SetOverrideType) - 类 org.omg.CORBA.LocalObject 中的方法
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。
_set_policy_override(Policy[], SetOverrideType) - 接口 org.omg.CORBA.Object 中的方法
返回一个新的 Object，使用给定策略替换此 Object 中的所有现有策略，或者根据给定 SetOverrideType 对象的值将给定策略添加到现有策略。
_set_policy_override(Policy[], SetOverrideType) - 类 org.omg.CORBA.portable.ObjectImpl 中的方法
将此 ObjectImpl 对象给定策略的重写类型设置为给定的 SetOverrideType 实例。
_SINGLE_THREAD_MODEL - 类 org.omg.PortableServer.ThreadPolicyValue 中的静态变量
_SYSTEM_ID - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态变量
_this() - 类 org.omg.CosNaming.BindingIteratorPOA 中的方法
_this(ORB) - 类 org.omg.CosNaming.BindingIteratorPOA 中的方法
_this() - 类 org.omg.CosNaming.NamingContextExtPOA 中的方法
_this(ORB) - 类 org.omg.CosNaming.NamingContextExtPOA 中的方法
_this() - 类 org.omg.CosNaming.NamingContextPOA 中的方法
_this(ORB) - 类 org.omg.CosNaming.NamingContextPOA 中的方法
_this() - 类 org.omg.PortableServer.ServantActivatorPOA 中的方法
_this(ORB) - 类 org.omg.PortableServer.ServantActivatorPOA 中的方法
_this() - 类 org.omg.PortableServer.ServantLocatorPOA 中的方法
_this(ORB) - 类 org.omg.PortableServer.ServantLocatorPOA 中的方法
_this_object() - 类 org.omg.PortableServer.Servant 中的方法
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
_this_object(ORB) - 类 org.omg.PortableServer.Servant 中的方法
允许 servant 获取为请求实现的目标 CORBA 对象的对象引用。
_tk_abstract_interface - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 abstract interface 的 int 常量。
_tk_alias - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 alias 的 int 常量。
_tk_any - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 any 的 int 常量。
_tk_array - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 array 的 int 常量。
_tk_boolean - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 boolean 的 int 常量。
_tk_char - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 char 的 int 常量。
_tk_double - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 double 的 int 常量。
_tk_enum - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 enum 的 int 常量。
_tk_except - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 except 的 int 常量。
_tk_fixed - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 fixed 的 int 常量。
_tk_float - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 float 的 int 常量。
_tk_long - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 long 的 int 常量。
_tk_longdouble - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 longdouble 的 int 常量。
_tk_longlong - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 longlong 的 int 常量。
_tk_native - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 native 的 int 常量。
_tk_null - 类 org.omg.CORBA.TCKind 中的静态变量
用于 null IDL 数据类型的 int 常量。
_tk_objref - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 objref 的 int 常量。
_tk_octet - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 octet 的 int 常量。
_tk_Principal - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 Principal 的 int 常量。
_tk_sequence - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 sequence 的 int 常量。
_tk_short - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 short 的 int 常量。
_tk_string - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 string 的 int 常量。
_tk_struct - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 struct 的 int 常量。
_tk_TypeCode - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 TypeCode 的 int 常量。
_tk_ulong - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 ulong 的 int 常量。
_tk_ulonglong - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 ulonglong 的 int 常量。
_tk_union - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 union 的 int 常量。
_tk_ushort - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 ushort 的 int 常量。
_tk_value - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 value 的 int 常量。
_tk_value_box - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 value_box 的 int 常量。
_tk_void - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 void 的 int 常量。
_tk_wchar - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 wchar 的 int 常量。
_tk_wstring - 类 org.omg.CORBA.TCKind 中的静态变量
用于 IDL 数据类型 wstring 的 int 常量。
_TRANSIENT - 类 org.omg.PortableServer.LifespanPolicyValue 中的静态变量
_truncatable_ids() - 接口 org.omg.CORBA.portable.ValueBase 中的方法
提供可截断的存储库 id。
_type() - 类 org.omg.CORBA.AnyHolder 中的方法
返回对应于此 AnyHolder 对象中保存值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.AnySeqHolder 中的方法
_type() - 类 org.omg.CORBA.BooleanHolder 中的方法
检索对应于此 BooleanHolder 对象中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.BooleanSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ByteHolder 中的方法
返回对应于此 ByteHolder 对象中所保存的值的 TypeCode。
_type() - 类 org.omg.CORBA.CharHolder 中的方法
返回对应于此 CharHolder 对象中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.CharSeqHolder 中的方法
_type() - 类 org.omg.CORBA.CurrentHolder 中的方法
_type() - 类 org.omg.CORBA.DoubleHolder 中的方法
返回此 holder 对象的 TypeCode。
_type() - 类 org.omg.CORBA.DoubleSeqHolder 中的方法
_type() - 类 org.omg.CORBA.FixedHolder 中的方法
返回此 holder 对象的 TypeCode。
_type() - 类 org.omg.CORBA.FloatHolder 中的方法
返回此 Streamable 的 TypeCode。
_type() - 类 org.omg.CORBA.FloatSeqHolder 中的方法
_type() - 类 org.omg.CORBA.IntHolder 中的方法
检索对应于此 IntHolder 对象 value 字段的 TypeCode 对象。
_type() - 类 org.omg.CORBA.LongHolder 中的方法
返回对应于此 Holder 中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.LongLongSeqHolder 中的方法
_type() - 类 org.omg.CORBA.LongSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ObjectHolder 中的方法
返回对应于此 ObjectHolder 对象中所保存的值的 TypeCode
_type() - 类 org.omg.CORBA.OctetSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ParameterModeHolder 中的方法
_type() - 类 org.omg.CORBA.PolicyErrorHolder 中的方法
_type() - 类 org.omg.CORBA.PolicyHolder 中的方法
_type() - 类 org.omg.CORBA.PolicyListHolder 中的方法
_type() - 接口 org.omg.CORBA.portable.Streamable 中的方法
检索对应于 Holder 中 value 字段值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.PrincipalHolder 中的方法
已过时。
_type() - 类 org.omg.CORBA.ServiceInformationHolder 中的方法
检索对应于此 ServiceInformationHolder 对象的 value 字段中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.ShortHolder 中的方法
返回对应于此 ShortHolder 对象中所保存的值的 TypeCode。
_type() - 类 org.omg.CORBA.ShortSeqHolder 中的方法
_type() - 类 org.omg.CORBA.StringHolder 中的方法
检索对应于此 StringHolder 对象中所保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.StringSeqHolder 中的方法
_type() - 类 org.omg.CORBA.TypeCodeHolder 中的方法
返回对应于此 TypeCodeHolder 对象中所保存的值的 TypeCode。
_type() - 类 org.omg.CORBA.ULongLongSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ULongSeqHolder 中的方法
_type() - 类 org.omg.CORBA.UnknownUserExceptionHolder 中的方法
_type() - 类 org.omg.CORBA.UShortSeqHolder 中的方法
_type() - 类 org.omg.CORBA.ValueBaseHolder 中的方法
返回对应于此 Holder 中保存的值的 TypeCode 对象。
_type() - 类 org.omg.CORBA.WCharSeqHolder 中的方法
_type() - 类 org.omg.CORBA.WrongTransactionHolder 中的方法
_type() - 类 org.omg.CORBA.WStringSeqHolder 中的方法
_type() - 类 org.omg.CosNaming.BindingHolder 中的方法
_type() - 类 org.omg.CosNaming.BindingIteratorHolder 中的方法
_type() - 类 org.omg.CosNaming.BindingListHolder 中的方法
_type() - 类 org.omg.CosNaming.BindingTypeHolder 中的方法
_type() - 类 org.omg.CosNaming.NameComponentHolder 中的方法
_type() - 类 org.omg.CosNaming.NameHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextExtHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 中的方法
_type() - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 中的方法
_type() - 类 org.omg.IOP.IORHolder 中的方法
_type() - 类 org.omg.IOP.MultipleComponentProfileHolder 中的方法
_type() - 类 org.omg.IOP.ServiceContextHolder 中的方法
_type() - 类 org.omg.IOP.ServiceContextListHolder 中的方法
_type() - 类 org.omg.IOP.TaggedComponentHolder 中的方法
_type() - 类 org.omg.IOP.TaggedProfileHolder 中的方法
_type() - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 中的方法
_type() - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 中的方法
_type() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 中的方法
_type() - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 中的方法
_type() - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 中的方法
_UNIQUE_ID - 类 org.omg.PortableServer.IdUniquenessPolicyValue 中的静态变量
_USE_ACTIVE_OBJECT_MAP_ONLY - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
_USE_DEFAULT_SERVANT - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
_USE_SERVANT_MANAGER - 类 org.omg.PortableServer.RequestProcessingPolicyValue 中的静态变量
_USER_ID - 类 org.omg.PortableServer.IdAssignmentPolicyValue 中的静态变量
_write(OutputStream) - 类 org.omg.CORBA.AnyHolder 中的方法
将此 AnyHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.AnySeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.BooleanHolder 中的方法
将此 BooleanHolder 对象 value 字段中的值编组到输出流 output。
_write(OutputStream) - 类 org.omg.CORBA.BooleanSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ByteHolder 中的方法
将此 ByteHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.CharHolder 中的方法
将此 CharHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.CharSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.CurrentHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.DoubleHolder 中的方法
将存储在此 holder 中的 double 值写入 OutputStream。
_write(OutputStream) - 类 org.omg.CORBA.DoubleSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.FixedHolder 中的方法
将存储在此 holder 中的定点值写入 OutputStream。
_write(OutputStream) - 类 org.omg.CORBA.FloatHolder 中的方法
将 float 值写入输出流。
_write(OutputStream) - 类 org.omg.CORBA.FloatSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.IntHolder 中的方法
将此 IntHolder 对象 value 字段中的值编组到输出流 output 中。
_write(OutputStream) - 类 org.omg.CORBA.LongHolder 中的方法
将此 Holder 中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.LongLongSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.LongSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ObjectHolder 中的方法
将此 ObjectHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.OctetSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ParameterModeHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.PolicyErrorHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.PolicyHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.PolicyListHolder 中的方法
_write(OutputStream) - 接口 org.omg.CORBA.portable.Streamable 中的方法
将 Holder 中 value 字段的值编组到 ostream。
_write(OutputStream) - 类 org.omg.CORBA.PrincipalHolder 中的方法
已过时。
_write(OutputStream) - 类 org.omg.CORBA.ServiceInformationHolder 中的方法
将此 ServiceInformationHolder 对象的 value 字段中的值编组到输出流 out。
_write(OutputStream) - 类 org.omg.CORBA.ShortHolder 中的方法
将此 ShortHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.ShortSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.StringHolder 中的方法
将此 StringHolder 对象所保存的值编组到输出流 output。
_write(OutputStream) - 类 org.omg.CORBA.StringSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.TypeCodeHolder 中的方法
将此 TypeCodeHolder 对象中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.ULongLongSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ULongSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.UnknownUserExceptionHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.UShortSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.ValueBaseHolder 中的方法
将此 Holder 中的值编组到 output。
_write(OutputStream) - 类 org.omg.CORBA.WCharSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.WrongTransactionHolder 中的方法
_write(OutputStream) - 类 org.omg.CORBA.WStringSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.BindingHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.BindingIteratorHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.BindingListHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.BindingTypeHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NameComponentHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NameHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextExtHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.CannotProceedHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.InvalidNameHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotEmptyHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundHolder 中的方法
_write(OutputStream) - 类 org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.IORHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.MultipleComponentProfileHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.ServiceContextHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.ServiceContextListHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.TaggedComponentHolder 中的方法
_write(OutputStream) - 类 org.omg.IOP.TaggedProfileHolder 中的方法
_write(OutputStream) - 类 org.omg.PortableInterceptor.IORInterceptor_3_0Holder 中的方法
_write(OutputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceFactoryHolder 中的方法
_write(OutputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateHolder 中的方法
_write(OutputStream) - 类 org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder 中的方法
_write(OutputStream) - 类 org.omg.PortableServer.ServantLocatorPackage.CookieHolder 中的方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM Platform
Standard Ed. 6
上一个字母 下一个字母 框架 无框架
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _